ServiceDetail (Java Platform SE 7 b59)

Please note that this documentation is not final and is subject to change.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.omg.CORBA
Class ServiceDetail

java.lang.Object
    extended by  org.omg.CORBA.ServiceDetail
All Implemented Interfaces:
Serializable, IDLEntity
public final class ServiceDetail
extends Object
implements IDLEntity

An object that represents an ORB service: its service_detail_type field contains the type of the ORB service, and its service_detail field contains a description of the ORB service.

Field Summary
Modifier and Type | Field and Description
byte[] | service_detail The data describing the ORB service that this ServiceDetail object represents.
int | service_detail_type The type of the ORB service that this ServiceDetail object represents.
Constructor Summary
Constructor and Description
ServiceDetail()
Constructs a ServiceDetail object with 0 for the type of ORB service and an empty description.
ServiceDetail(int service_detail_type, byte[] service_detail)
Constructs a ServiceDetail object with the given ORB service type and the given description.
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

service_detail_type

public int service_detail_type
The type of the ORB service that this ServiceDetail object represents.

service_detail

public byte[] service_detail
The data describing the ORB service that this ServiceDetail object represents.

Constructor Detail

ServiceDetail

public ServiceDetail()
Constructs a ServiceDetail object with 0 for the type of ORB service and an empty description.

ServiceDetail

public ServiceDetail(int service_detail_type,
                     byte[] service_detail)
Constructs a ServiceDetail object with the given ORB service type and the given description.

Parameters:
service_detail_type - an int specifying the type of ORB service
service_detail - a byte array describing the ORB service
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7


ServiceDetailHelper (Java Platform SE 7 b59)

Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.omg.CORBA
Class ServiceDetailHelper

java.lang.Object
    extended by  org.omg.CORBA.ServiceDetailHelper

public abstract class ServiceDetailHelper
extends Object

Constructor Summary
Constructor and Description
ServiceDetailHelper()
Method Summary
Modifier and Type | Method and Description
static ServiceDetail | extract(Any a)
static String | id()
static void | insert(Any a, ServiceDetail that)
static ServiceDetail | read(InputStream in)
static TypeCode | type()
static void | write(OutputStream out, ServiceDetail that)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ServiceDetailHelper

public ServiceDetailHelper()
Method Detail

write

public static void write(OutputStream out,
                         ServiceDetail that)

read

public static ServiceDetail read(InputStream in)

extract

public static ServiceDetail extract(Any a)

insert

public static void insert(Any a,
                          ServiceDetail that)

type

public static TypeCode type()

id

public static String id()
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServiceInformation (Java Platform SE 7 b59)

DRAFT ea-b59
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.omg.CORBA
Class ServiceInformation

java.lang.Object
    extended by  org.omg.CORBA.ServiceInformation
All Implemented Interfaces:
Serializable, IDLEntity
public final class ServiceInformation
extends Object
implements IDLEntity

An IDL struct in the CORBA module that stores information about a CORBA service available in the ORB implementation and is obtained from the ORB.get_service_information method.

Field Summary
Modifier and Type | Field and Description
ServiceDetail[] | service_details Array of ServiceDetails giving more details about the service.
int[] | service_options Array of ints representing service options.
Constructor Summary
Constructor and Description
ServiceInformation()
Constructs a ServiceInformation object with empty service_options and service_details.
ServiceInformation(int[] __service_options, ServiceDetail[] __service_details)
Constructs a ServiceInformation object with the given service_options and service_details.
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

service_options

public int[] service_options
Array of ints representing service options.

service_details

public ServiceDetail[] service_details
Array of ServiceDetails giving more details about the service.

Constructor Detail

ServiceInformation

public ServiceInformation()
Constructs a ServiceInformation object with empty service_options and service_details.

ServiceInformation

public ServiceInformation(int[] __service_options,
                          ServiceDetail[] __service_details)
Constructs a ServiceInformation object with the given service_options and service_details.

Parameters:
__service_options - An array of ints describing the service options.
__service_details - An array of ServiceDetails describing the service details.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServiceInformationHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class ServiceInformationHelper

java.lang.Object
    extended by  org.omg.CORBA.ServiceInformationHelper

public abstract class ServiceInformationHelper
extends Object

Constructor Summary
Constructor and Description
ServiceInformationHelper()
Method Summary
Modifier and Type | Method and Description
static ServiceInformation | extract(Any a)
static String | id()
static void | insert(Any a, ServiceInformation that)
static ServiceInformation | read(InputStream in)
static TypeCode | type()
static void | write(OutputStream out, ServiceInformation that)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ServiceInformationHelper

public ServiceInformationHelper()
Method Detail

write

public static void write(OutputStream out,
                         ServiceInformation that)

read

public static ServiceInformation read(InputStream in)

extract

public static ServiceInformation extract(Any a)

insert

public static void insert(Any a,
                          ServiceInformation that)

type

public static TypeCode type()

id

public static String id()
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServiceInformationHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class ServiceInformationHolder

java.lang.Object
    extended by  org.omg.CORBA.ServiceInformationHolder
All Implemented Interfaces:
Streamable
public final class ServiceInformationHolder
extends Object
implements Streamable

The Holder for ServiceInformation. For more information on Holder files, see "Generated Files: Holder Files".

A Holder class for a ServiceInformation object that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL xxx as an "out" or "inout" parameter, the programmer must pass an instance of ServiceInformationHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

If myServiceInformationHolder is an instance of ServiceInformationHolder, the value stored in its value field can be accessed with myServiceInformationHolder.value.

Field Summary
Modifier and Type | Field and Description
ServiceInformation | value The ServiceInformation value held by this ServiceInformationHolder object in its value field.
Constructor Summary
Constructor and Description
ServiceInformationHolder()
Constructs a new ServiceInformationHolder object with its value field initialized to null.
ServiceInformationHolder(ServiceInformation arg)
Constructs a new ServiceInformationHolder object with its value field initialized to the given ServiceInformation object.
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream in) Reads unmarshalled data from the input stream in and assigns it to the value field in this ServiceInformationHolder object.
TypeCode | _type() Retrieves the TypeCode object that corresponds to the value held in this ServiceInformationHolder object's value field.
void | _write(OutputStream out) Marshals the value in this ServiceInformationHolder object's value field to the output stream out.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public ServiceInformation value
The ServiceInformation value held by this ServiceInformationHolder object in its value field.

Constructor Detail

ServiceInformationHolder

public ServiceInformationHolder()
Constructs a new ServiceInformationHolder object with its value field initialized to null.

ServiceInformationHolder

public ServiceInformationHolder(ServiceInformation arg)
Constructs a new ServiceInformationHolder object with its value field initialized to the given ServiceInformation object.

Parameters:
arg - the ServiceInformation object with which to initialize the value field of the newly-created ServiceInformationHolder object
Method Detail

_write

public void _write(OutputStream out)
Marshals the value in this ServiceInformationHolder object's value field to the output stream out.

Specified by:
_write in interface Streamable
Parameters:
out - the OutputStream object that will contain the CDR formatted data

_read

public void _read(InputStream in)
Reads unmarshalled data from the input stream in and assigns it to the value field in this ServiceInformationHolder object.

Specified by:
_read in interface Streamable
Parameters:
in - the InputStream object containing CDR formatted data from the wire

_type

public TypeCode _type()
Retrieves the TypeCode object that corresponds to the value held in this ServiceInformationHolder object's value field.

Specified by:
_type in interface Streamable
Returns:
the type code for the value held in this ServiceInformationHolder object
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


SetOverrideType (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class SetOverrideType

java.lang.Object
    extended by  org.omg.CORBA.SetOverrideType
All Implemented Interfaces:
Serializable, IDLEntity
public class SetOverrideType
extends Object
implements IDLEntity

The mapping of a CORBA enum tagging SET_OVERRIDE and ADD_OVERRIDE, which indicate whether policies should replace the existing policies of an Object or be added to them.

The method omg.org.CORBA.Object._set_policy_override takes either SetOverrideType.SET_OVERRIDE or SetOverrideType.ADD_OVERRIDE as its second argument. The method _set_policy_override creates a new Object initialized with the Policy objects supplied as the first argument. If the second argument is ADD_OVERRIDE, the new policies are added to those of the Object instance that is calling the _set_policy_override method. If SET_OVERRIDE is given instead, the existing policies are replaced with the given ones.

Since:
JDK1.2

Field Summary
Modifier and Type | Field and Description
static int | _ADD_OVERRIDE The int constant for the enum value ADD_OVERRIDE.
static int | _SET_OVERRIDE The int constant for the enum value SET_OVERRIDE.
static SetOverrideType | ADD_OVERRIDE The SetOverrideType constant for the enum value ADD_OVERRIDE.
static SetOverrideType | SET_OVERRIDE The SetOverrideType constant for the enum value SET_OVERRIDE.
Constructor Summary
Modifier | Constructor and Description
protected | SetOverrideType(int _value) Constructs a SetOverrideType instance from an int.
Method Summary
Modifier and Type | Method and Description
static SetOverrideType | from_int(int i) Converts the given int to the corresponding SetOverrideType instance.
int | value() Retrieves the value of this SetOverrideType instance.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_SET_OVERRIDE

public static final int _SET_OVERRIDE
The int constant for the enum value SET_OVERRIDE.

See Also:
Constant Field Values

_ADD_OVERRIDE

public static final int _ADD_OVERRIDE
The int constant for the enum value ADD_OVERRIDE.

See Also:
Constant Field Values

SET_OVERRIDE

public static final SetOverrideType SET_OVERRIDE
The SetOverrideType constant for the enum value SET_OVERRIDE.

ADD_OVERRIDE

public static final SetOverrideType ADD_OVERRIDE
The SetOverrideType constant for the enum value ADD_OVERRIDE.

Constructor Detail

SetOverrideType

protected SetOverrideType(int _value)
Constructs a SetOverrideType instance from an int.

Parameters:
_value - must be either SET_OVERRIDE or ADD_OVERRIDE
Method Detail

value

public int value()
Retrieves the value of this SetOverrideType instance.

Returns:
the int for this SetOverrideType instance.

from_int

public static SetOverrideType from_int(int i)
Converts the given int to the corresponding SetOverrideType instance.

Parameters:
i - the int to convert; must be either SetOverrideType._SET_OVERRIDE or SetOverrideType._ADD_OVERRIDE
Returns:
the SetOverrideType instance whose value matches the given int
Throws:
BAD_PARAM - if the given int does not match the value of any SetOverrideType instance
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


SetOverrideTypeHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class SetOverrideTypeHelper

java.lang.Object
    extended by  org.omg.CORBA.SetOverrideTypeHelper

public abstract class SetOverrideTypeHelper
extends Object

The Helper for SetOverrideType. For more information on Helper files, see "Generated Files: Helper Files".

org/omg/CORBA/SetOverrideTypeHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" 03 June 1999 11:52:03 o'clock GMT+00:00

Constructor Summary
Constructor and Description
SetOverrideTypeHelper()
Method Summary
Modifier and Type | Method and Description
static SetOverrideType | extract(Any a)
static String | id()
static void | insert(Any a, SetOverrideType that)
static SetOverrideType | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, SetOverrideType value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SetOverrideTypeHelper

public SetOverrideTypeHelper()
Method Detail

insert

public static void insert(Any a,
                          SetOverrideType that)

extract

public static SetOverrideType extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static SetOverrideType read(InputStream istream)

write

public static void write(OutputStream ostream,
                         SetOverrideType value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ShortHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class ShortHolder

java.lang.Object
    extended by  org.omg.CORBA.ShortHolder
All Implemented Interfaces:
Streamable
public final class ShortHolder
extends Object
implements Streamable

The Holder for Short. For more information on Holder files, see "Generated Files: Holder Files".

short that is used to store "out" and "inout" parameters in IDL operations. If an IDL operation signature has an IDL short as an "out" or "inout" parameter, the programmer must pass an instance of ShortHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

If myShortHolder is an instance of ShortHolder, the value stored in its value field can be accessed with myShortHolder.value.

Since:
JDK1.2

Field Summary
Modifier and Type | Field and Description
short | value The short value held by this ShortHolder object.
Constructor Summary
Constructor and Description
ShortHolder()
Constructs a new ShortHolder object with its value field initialized to 0.
ShortHolder(short initial)
Constructs a new ShortHolder object with its value field initialized to the given short.
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream input) Reads from input and initalizes the value in this ShortHolder object with the unmarshalled data.
TypeCode | _type() Returns the TypeCode corresponding to the value held in this ShortHolder object.
void | _write(OutputStream output) Marshals to output the value in this ShortHolder object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public short value
The short value held by this ShortHolder object.

Constructor Detail

ShortHolder

public ShortHolder()
Constructs a new ShortHolder object with its value field initialized to 0.

ShortHolder

public ShortHolder(short initial)
Constructs a new ShortHolder object with its value field initialized to the given short.

Parameters:
initial - the short with which to initialize the value field of the newly-created ShortHolder object
Method Detail

_read

public void _read(InputStream input)
Reads from input and initalizes the value in this ShortHolder object with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
input - the InputStream containing CDR formatted data from the wire.

_write

public void _write(OutputStream output)
Marshals to output the value in this ShortHolder object.

Specified by:
_write in interface Streamable
Parameters:
output - the OutputStream which will contain the CDR formatted data.

_type

public TypeCode _type()
Returns the TypeCode corresponding to the value held in this ShortHolder object.

Specified by:
_type in interface Streamable
Returns:
the TypeCode of the value held in this ShortHolder object
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ShortSeqHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class ShortSeqHelper

java.lang.Object
    extended by  org.omg.CORBA.ShortSeqHelper

public abstract class ShortSeqHelper
extends Object

The Helper for ShortSeqHelper. For more information on Helper files, see "Generated Files: Helper Files".

org/omg/CORBA/ShortSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

  • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
  • IDL/Java Language Mapping as defined in ptc/00-01-08

Constructor Summary
Constructor and Description
ShortSeqHelper()
Method Summary
Modifier and Type | Method and Description
static short[] | extract(Any a)
static String | id()
static void | insert(Any a, short[] that)
static short[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, short[] value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ShortSeqHelper

public ShortSeqHelper()
Method Detail

insert

public static void insert(Any a,
                          short[] that)

extract

public static short[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static short[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         short[] value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ShortSeqHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class ShortSeqHolder

java.lang.Object
    extended by  org.omg.CORBA.ShortSeqHolder
All Implemented Interfaces:
Streamable
public final class ShortSeqHolder
extends Object
implements Streamable

The Holder for ShortSeq. For more information on Holder files, see "Generated Files: Holder Files".

org/omg/CORBA/ShortSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

Field Summary
Modifier and Type | Field and Description
short[] | value
Constructor Summary
Constructor and Description
ShortSeqHolder()
ShortSeqHolder(short[] initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public short[] value
Constructor Detail

ShortSeqHolder

public ShortSeqHolder()

ShortSeqHolder

public ShortSeqHolder(short[] initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


StringHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class StringHolder

java.lang.Object
    extended by  org.omg.CORBA.StringHolder
All Implemented Interfaces:
Streamable
public final class StringHolder
extends Object
implements Streamable

The Holder for String. For more information on Holder files, see "Generated Files: Holder Files".

A Holder class for a String that is used to store "out" and "inout" parameters in IDL operations. If an IDL operation signature has an IDL string as an "out" or "inout" parameter, the programmer must pass an instance of StringHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

If myStringHolder is an instance of StringHolder, the value stored in its value field can be accessed with myStringHolder.value.

Since:
JDK1.2

Field Summary
Modifier and Type | Field and Description
String | value The String value held by this StringHolder object.
Constructor Summary
Constructor and Description
StringHolder()
Constructs a new StringHolder object with its value field initialized to null.
StringHolder(String initial)
Constructs a new StringHolder object with its value field initialized to the given String.
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream input) Reads the unmarshalled data from input and assigns it to the value field of this StringHolder object.
TypeCode | _type() Retrieves the TypeCode object that corresponds to the value held in this StringHolder object.
void | _write(OutputStream output) Marshals the value held by this StringHolder object to the output stream output.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public String value
The String value held by this StringHolder object.

Constructor Detail

StringHolder

public StringHolder()
Constructs a new StringHolder object with its value field initialized to null.

StringHolder

public StringHolder(String initial)
Constructs a new StringHolder object with its value field initialized to the given String.

Parameters:
initial - the String with which to initialize the value field of the newly-created StringHolder object
Method Detail

_read

public void _read(InputStream input)
Reads the unmarshalled data from input and assigns it to the value field of this StringHolder object.

Specified by:
_read in interface Streamable
Parameters:
input - the InputStream containing CDR formatted data from the wire.

_write

public void _write(OutputStream output)
Marshals the value held by this StringHolder object to the output stream output.

Specified by:
_write in interface Streamable
Parameters:
output - the OutputStream which will contain the CDR formatted data.

_type

public TypeCode _type()
Retrieves the TypeCode object that corresponds to the value held in this StringHolder object.

Specified by:
_type in interface Streamable
Returns:
the type code of the value held in this StringHolder object
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


StringSeqHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class StringSeqHelper

java.lang.Object
    extended by  org.omg.CORBA.StringSeqHelper

public abstract class StringSeqHelper
extends Object

An array of Strings

Constructor Summary
Constructor and Description
StringSeqHelper()
Method Summary
Modifier and Type | Method and Description
static String[] | extract(Any a)
static String | id()
static void | insert(Any a, String[] that)
static String[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String[] value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StringSeqHelper

public StringSeqHelper()
Method Detail

insert

public static void insert(Any a,
                          String[] that)

extract

public static String[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String[] value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


StringSeqHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class StringSeqHolder

java.lang.Object
    extended by  org.omg.CORBA.StringSeqHolder
All Implemented Interfaces:
Streamable
public final class StringSeqHolder
extends Object
implements Streamable

An array of Strings

Field Summary
Modifier and Type | Field and Description
String[] | value
Constructor Summary
Constructor and Description
StringSeqHolder()
StringSeqHolder(String[] initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public String[] value
Constructor Detail

StringSeqHolder

public StringSeqHolder()

StringSeqHolder

public StringSeqHolder(String[] initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


StringValueHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class StringValueHelper

java.lang.Object
    extended by  org.omg.CORBA.StringValueHelper
All Implemented Interfaces:
BoxedValueHelper
public class StringValueHelper
extends Object
implements BoxedValueHelper

The Helper for StringValue. For more information on Helper files, see "Generated Files: Helper Files".

org/omg/CORBA/StringValueHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from orb.idl 31 May 1999 22:27:30 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

  • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
  • IDL/Java Language Mapping as defined in ptc/00-01-08

Constructor Summary
Constructor and Description
StringValueHelper()
Method Summary
Modifier and Type | Method and Description
static String | extract(Any a)
String | get_id()
static String | id()
static void | insert(Any a, String that)
Serializable | read_value(InputStream istream)
static String | read(InputStream istream)
static TypeCode | type()
void | write_value(OutputStream ostream, Serializable value)
static void | write(OutputStream ostream, String value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StringValueHelper

public StringValueHelper()
Method Detail

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

read_value

public Serializable read_value(InputStream istream)
Specified by:
read_value in interface BoxedValueHelper

write

public static void write(OutputStream ostream,
                         String value)

write_value

public void write_value(OutputStream ostream,
                        Serializable value)
Specified by:
write_value in interface BoxedValueHelper

get_id

public String get_id()
Specified by:
get_id in interface BoxedValueHelper
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


StructMember (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class StructMember

java.lang.Object
    extended by  org.omg.CORBA.StructMember
All Implemented Interfaces:
Serializable, IDLEntity
public final class StructMember
extends Object
implements IDLEntity

Describes a member of an IDL struct in the Interface Repository, including the name of the struct member, the type of the struct member, and the typedef that represents the IDL type of the struct member described the struct member object.

Field Summary
Modifier and Type | Field and Description
String | name The name of the struct member described by this StructMember object.
TypeCode | type The type of the struct member described by this StructMember object.
IDLType | type_def The typedef that represents the IDL type of the struct member described by this StructMember object.
Constructor Summary
Constructor and Description
StructMember()
Constructs a default StructMember object.
StructMember(String __name, TypeCode __type, IDLType __type_def)
Constructs a StructMember object initialized with the given values.
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

name

public String name
The name of the struct member described by this StructMember object.

type

public TypeCode type
The type of the struct member described by this StructMember object.

type_def

public IDLType type_def
The typedef that represents the IDL type of the struct member described by this StructMember object.

Constructor Detail

StructMember

public StructMember()
Constructs a default StructMember object.

StructMember

public StructMember(String __name,
                    TypeCode __type,
                    IDLType __type_def)
Constructs a StructMember object initialized with the given values.

Parameters:
__name - a String object with the name of the struct member
__type - a TypeCode object describing the type of the struct member
__type_def - an IDLType object representing the IDL type of the struct member
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


StructMemberHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class StructMemberHelper

java.lang.Object
    extended by  org.omg.CORBA.StructMemberHelper

public abstract class StructMemberHelper
extends Object

The Helper for StructMember. For more information on Helper files, see "Generated Files: Helper Files".

org/omg/CORBA/StructMemberHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl 03 June 1999 11:33:43 o'clock GMT+00:00

Constructor Summary
Constructor and Description
StructMemberHelper()
Method Summary
Modifier and Type | Method and Description
static StructMember | extract(Any a)
static String | id()
static void | insert(Any a, StructMember that)
static StructMember | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, StructMember value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StructMemberHelper

public StructMemberHelper()
Method Detail

insert

public static void insert(Any a,
                          StructMember that)

extract

public static StructMember extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static StructMember read(InputStream istream)

write

public static void write(OutputStream ostream,
                         StructMember value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


SystemException (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class SystemException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.omg.CORBA.SystemException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
ACTIVITY_COMPLETED, ACTIVITY_REQUIRED, BAD_CONTEXT, BAD_INV_ORDER, BAD_OPERATION, BAD_PARAM, BAD_QOS, BAD_TYPECODE, CODESET_INCOMPATIBLE, COMM_FAILURE, DATA_CONVERSION, FREE_MEM, IMP_LIMIT, IndirectionException, INITIALIZE, INTERNAL, INTF_REPOS, INV_FLAG, INV_IDENT, INV_OBJREF, INV_POLICY, INVALID_ACTIVITY, INVALID_TRANSACTION, MARSHAL, NO_IMPLEMENT, NO_MEMORY, NO_PERMISSION, NO_RESOURCES, NO_RESPONSE, OBJ_ADAPTER, OBJECT_NOT_EXIST, PERSIST_STORE, REBIND, TIMEOUT, TRANSACTION_MODE, TRANSACTION_REQUIRED, TRANSACTION_ROLLEDBACK, TRANSACTION_UNAVAILABLE, TRANSIENT, UNKNOWN, UnknownException
public abstract class SystemException
extends RuntimeException

The root class for all CORBA standard exceptions. These exceptions may be thrown as a result of any CORBA operation invocation and may also be returned by many standard CORBA API methods. The standard exceptions contain a minor code, allowing more detailed specification, and a completion status. This class is subclassed to generate each one of the set of standard ORB exceptions. SystemException extends java.lang.RuntimeException; thus none of the SystemException exceptions need to be declared in signatures of the Java methods mapped from operations in IDL interfaces.

See Also:
documentation on Java IDL exceptions

Field Summary
Modifier and Type | Field and Description
CompletionStatus | completed The status of the operation that threw this exception.
int | minor The CORBA Exception minor code.
Constructor Summary
Modifier | Constructor and Description
protected | SystemException(String reason, int minor, CompletionStatus completed) Constructs a SystemException exception with the specified detail message, minor code, and completion status.
Method Summary
Modifier and Type | Method and Description
String | toString() Converts this exception to a representative string.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

minor

public int minor
The CORBA Exception minor code.

completed

public CompletionStatus completed
The status of the operation that threw this exception.

Constructor Detail

SystemException

protected SystemException(String reason,
                          int minor,
                          CompletionStatus completed)
Constructs a SystemException exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.

Parameters:
reason - the String containing a detail message
minor - the minor code
completed - the completion status
Method Detail

toString

public String toString()
Converts this exception to a representative string.

Overrides:
toString in class Throwable
Returns:
a string representation of this throwable.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TCKind (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class TCKind

java.lang.Object
    extended by  org.omg.CORBA.TCKind

public class TCKind
extends Object

The Java mapping of the IDL enum TCKind, which specifies the kind of a TypeCode object. There is one kind for each primitive and essential IDL data type.

The class TCKind consists of:

  • a set of int constants, one for each kind of IDL data type. These int constants make it possible to use a switch statement.
  • a set of TCKind constants, one for each kind of IDL data type. The value field for each TCKind instance is initialized with the int constant that corresponds with the IDL data type that the instance represents.
  • the method from_intfor converting an int to its corresponding TCKind instance

    Example:

          org.omg.CORBA.TCKind k = org.omg.CORBA.TCKind.from_int(
                         org.omg.CORBA.TCKind._tk_string);
    The variable k represents the TCKind instance for the IDL type string, which is tk_string.

  • the method value for accessing the _value field of a TCKind constant

    Example:

       int i = org.omg.CORBA.TCKind.tk_char.value();
    The variable i represents 9, the value for the IDL data type char.

The value field of a TCKind instance is the CDR encoding used for a TypeCode object in an IIOP message.

Field Summary
Modifier and Type | Field and Description
static int | _tk_abstract_interface The int constant for the IDL data type abstract interface.
static int | _tk_alias The int constant for the IDL data type alias.
static int | _tk_any The int constant for the IDL data type any.
static int | _tk_array The int constant for the IDL data type array.
static int | _tk_boolean The int constant for the IDL data type boolean.
static int | _tk_char The int constant for the IDL data type char.
static int | _tk_double The int constant for the IDL data type double.
static int | _tk_enum The int constant for the IDL data type enum.
static int | _tk_except The int constant for the IDL data type except.
static int | _tk_fixed The int constant for the IDL data type fixed.
static int | _tk_float The int constant for the IDL data type float.
static int | _tk_long The int constant for the IDL data type long.
static int | _tk_longdouble The int constant for the IDL data type longdouble.
static int | _tk_longlong The int constant for the IDL data type longlong.
static int | _tk_native The int constant for the IDL data type native.
static int | _tk_null The int constant for a null IDL data type.
static int | _tk_objref The int constant for the IDL data type objref.
static int | _tk_octet The int constant for the IDL data type octet.
static int | _tk_Principal The int constant for the IDL data type Principal.
static int | _tk_sequence The int constant for the IDL data type sequence.
static int | _tk_short The int constant for the IDL data type short.
static int | _tk_string The int constant for the IDL data type string.
static int | _tk_struct The int constant for the IDL data type struct.
static int | _tk_TypeCode The int constant for the IDL data type TypeCode.
static int | _tk_ulong The int constant for the IDL data type ulong.
static int | _tk_ulonglong The int constant for the IDL data type ulonglong.
static int | _tk_union The int constant for the IDL data type union.
static int | _tk_ushort The int constant for the IDL data type ushort.
static int | _tk_value The int constant for the IDL data type value.
static int | _tk_value_box The int constant for the IDL data type value_box.
static int | _tk_void The int constant for the IDL data type void.
static int | _tk_wchar The int constant for the IDL data type wchar.
static int | _tk_wstring The int constant for the IDL data type wstring.
static TCKind | tk_abstract_interface The TCKind constant whose value field is initialized with TCKind._tk_abstract_interface.
static TCKind | tk_alias The TCKind constant whose value field is initialized with TCKind._tk_alias.
static TCKind | tk_any The TCKind constant whose value field is initialized with TCKind._tk_any.
static TCKind | tk_array The TCKind constant whose value field is initialized with TCKind._tk_array.
static TCKind | tk_boolean The TCKind constant whose value field is initialized with TCKind._tk_boolean.
static TCKind | tk_char The TCKind constant whose value field is initialized with TCKind._tk_char.
static TCKind | tk_double The TCKind constant whose value field is initialized with TCKind._tk_double.
static TCKind | tk_enum The TCKind constant whose value field is initialized with TCKind._tk_enum.
static TCKind | tk_except The TCKind constant whose value field is initialized with TCKind._tk_except.
static TCKind | tk_fixed The TCKind constant whose value field is initialized with TCKind._tk_fixed.
static TCKind | tk_float The TCKind constant whose value field is initialized with TCKind._tk_float.
static TCKind | tk_long The TCKind constant whose value field is initialized with TCKind._tk_long.
static TCKind | tk_longdouble The TCKind constant whose value field is initialized with TCKind._tk_longdouble.
static TCKind | tk_longlong The TCKind constant whose value field is initialized with TCKind._tk_longlong.
static TCKind | tk_native The TCKind constant whose value field is initialized with TCKind._tk_native.
static TCKind | tk_null The TCKind constant whose value field is initialized with TCKind._tk_null.
static TCKind | tk_objref The TCKind constant whose value field is initialized with TCKind._tk_objref.
static TCKind | tk_octet The TCKind constant whose value field is initialized with TCKind._tk_octet.
static TCKind | tk_Principal The TCKind constant whose value field is initialized with TCKind._tk_Principal.
static TCKind | tk_sequence The TCKind constant whose value field is initialized with TCKind._tk_sequence.
static TCKind | tk_short The TCKind constant whose value field is initialized with TCKind._tk_short.
static TCKind | tk_string The TCKind constant whose value field is initialized with TCKind._tk_string.
static TCKind | tk_struct The TCKind constant whose value field is initialized with TCKind._tk_struct.
static TCKind | tk_TypeCode The TCKind constant whose value field is initialized with TCKind._tk_TypeCode.
static TCKind | tk_ulong The TCKind constant whose value field is initialized with TCKind._tk_ulong.
static TCKind | tk_ulonglong The TCKind constant whose value field is initialized with TCKind._tk_ulonglong.
static TCKind | tk_union The TCKind constant whose value field is initialized with TCKind._tk_union.
static TCKind | tk_ushort The TCKind constant whose value field is initialized with TCKind._tk_ushort.
static TCKind | tk_value The TCKind constant whose value field is initialized with TCKind._tk_value.
static TCKind | tk_value_box The TCKind constant whose value field is initialized with TCKind._tk_value_box.
static TCKind | tk_void The TCKind constant whose value field is initialized with TCKind._tk_void.
static TCKind | tk_wchar The TCKind constant whose value field is initialized with TCKind._tk_wchar.
static TCKind | tk_wstring The TCKind constant whose value field is initialized with TCKind._tk_wstring.
Constructor Summary
Modifier | Constructor and Description
protected | TCKind(int _value) Deprecated. Do not use this constructor as this method should be private according to the OMG specification. Use from_int(int) instead.
Method Summary
Modifier and Type | Method and Description
static TCKind | from_int(int i) Converts the given int to the corresponding TCKind instance.
int | value() Retrieves the value of this TCKind instance.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_tk_null

public static final int _tk_null
The int constant for a null IDL data type.

See Also:
Constant Field Values

_tk_void

public static final int _tk_void
The int constant for the IDL data type void.

See Also:
Constant Field Values

_tk_short

public static final int _tk_short
The int constant for the IDL data type short.

See Also:
Constant Field Values

_tk_long

public static final int _tk_long
The int constant for the IDL data type long.

See Also:
Constant Field Values

_tk_ushort

public static final int _tk_ushort
The int constant for the IDL data type ushort.

See Also:
Constant Field Values

_tk_ulong

public static final int _tk_ulong
The int constant for the IDL data type ulong.

See Also:
Constant Field Values

_tk_float

public static final int _tk_float
The int constant for the IDL data type float.

See Also:
Constant Field Values

_tk_double

public static final int _tk_double
The int constant for the IDL data type double.

See Also:
Constant Field Values

_tk_boolean

public static final int _tk_boolean
The int constant for the IDL data type boolean.

See Also:
Constant Field Values

_tk_char

public static final int _tk_char
The int constant for the IDL data type char.

See Also:
Constant Field Values

_tk_octet

public static final int _tk_octet
The int constant for the IDL data type octet.

See Also:
Constant Field Values

_tk_any

public static final int _tk_any
The int constant for the IDL data type any.

See Also:
Constant Field Values

_tk_TypeCode

public static final int _tk_TypeCode
The int constant for the IDL data type TypeCode.

See Also:
Constant Field Values

_tk_Principal

public static final int _tk_Principal
The int constant for the IDL data type Principal.

See Also:
Constant Field Values

_tk_objref

public static final int _tk_objref
The int constant for the IDL data type objref.

See Also:
Constant Field Values

_tk_struct

public static final int _tk_struct
The int constant for the IDL data type struct.

See Also:
Constant Field Values

_tk_union

public static final int _tk_union
The int constant for the IDL data type union.

See Also:
Constant Field Values

_tk_enum

public static final int _tk_enum
The int constant for the IDL data type enum.

See Also:
Constant Field Values

_tk_string

public static final int _tk_string
The int constant for the IDL data type string.

See Also:
Constant Field Values

_tk_sequence

public static final int _tk_sequence
The int constant for the IDL data type sequence.

See Also:
Constant Field Values

_tk_array

public static final int _tk_array
The int constant for the IDL data type array.

See Also:
Constant Field Values

_tk_alias

public static final int _tk_alias
The int constant for the IDL data type alias.

See Also:
Constant Field Values

_tk_except

public static final int _tk_except
The int constant for the IDL data type except.

See Also:
Constant Field Values

_tk_longlong

public static final int _tk_longlong
The int constant for the IDL data type longlong.

See Also:
Constant Field Values

_tk_ulonglong

public static final int _tk_ulonglong
The int constant for the IDL data type ulonglong.

See Also:
Constant Field Values

_tk_longdouble

public static final int _tk_longdouble
The int constant for the IDL data type longdouble.

See Also:
Constant Field Values

_tk_wchar

public static final int _tk_wchar
The int constant for the IDL data type wchar.

See Also:
Constant Field Values

_tk_wstring

public static final int _tk_wstring
The int constant for the IDL data type wstring.

See Also:
Constant Field Values

_tk_fixed

public static final int _tk_fixed
The int constant for the IDL data type fixed.

See Also:
Constant Field Values

_tk_value

public static final int _tk_value
The int constant for the IDL data type value.

See Also:
Constant Field Values

_tk_value_box

public static final int _tk_value_box
The int constant for the IDL data type value_box.

See Also:
Constant Field Values

_tk_native

public static final int _tk_native
The int constant for the IDL data type native.

See Also:
Constant Field Values

_tk_abstract_interface

public static final int _tk_abstract_interface
The int constant for the IDL data type abstract interface.

See Also:
Constant Field Values

tk_null

public static final TCKind tk_null
The TCKind constant whose value field is initialized with TCKind._tk_null.

tk_void

public static final TCKind tk_void
The TCKind constant whose value field is initialized with TCKind._tk_void.

tk_short

public static final TCKind tk_short
The TCKind constant whose value field is initialized with TCKind._tk_short.

tk_long

public static final TCKind tk_long
The TCKind constant whose value field is initialized with TCKind._tk_long.

tk_ushort

public static final TCKind tk_ushort
The TCKind constant whose value field is initialized with TCKind._tk_ushort.

tk_ulong

public static final TCKind tk_ulong
The TCKind constant whose value field is initialized with TCKind._tk_ulong.

tk_float

public static final TCKind tk_float
The TCKind constant whose value field is initialized with TCKind._tk_float.

tk_double

public static final TCKind tk_double
The TCKind constant whose value field is initialized with TCKind._tk_double.

tk_boolean

public static final TCKind tk_boolean
The TCKind constant whose value field is initialized with TCKind._tk_boolean.

tk_char

public static final TCKind tk_char
The TCKind constant whose value field is initialized with TCKind._tk_char.

tk_octet

public static final TCKind tk_octet
The TCKind constant whose value field is initialized with TCKind._tk_octet.

tk_any

public static final TCKind tk_any
The TCKind constant whose value field is initialized with TCKind._tk_any.

tk_TypeCode

public static final TCKind tk_TypeCode
The TCKind constant whose value field is initialized with TCKind._tk_TypeCode.

tk_Principal

public static final TCKind tk_Principal
The TCKind constant whose value field is initialized with TCKind._tk_Principal.

tk_objref

public static final TCKind tk_objref
The TCKind constant whose value field is initialized with TCKind._tk_objref.

tk_struct

public static final TCKind tk_struct
The TCKind constant whose value field is initialized with TCKind._tk_struct.

tk_union

public static final TCKind tk_union
The TCKind constant whose value field is initialized with TCKind._tk_union.

tk_enum

public static final TCKind tk_enum
The TCKind constant whose value field is initialized with TCKind._tk_enum.

tk_string

public static final TCKind tk_string
The TCKind constant whose value field is initialized with TCKind._tk_string.

tk_sequence

public static final TCKind tk_sequence
The TCKind constant whose value field is initialized with TCKind._tk_sequence.

tk_array

public static final TCKind tk_array
The TCKind constant whose value field is initialized with TCKind._tk_array.

tk_alias

public static final TCKind tk_alias
The TCKind constant whose value field is initialized with TCKind._tk_alias.

tk_except

public static final TCKind tk_except
The TCKind constant whose value field is initialized with TCKind._tk_except.

tk_longlong

public static final TCKind tk_longlong
The TCKind constant whose value field is initialized with TCKind._tk_longlong.

tk_ulonglong

public static final TCKind tk_ulonglong
The TCKind constant whose value field is initialized with TCKind._tk_ulonglong.

tk_longdouble

public static final TCKind tk_longdouble
The TCKind constant whose value field is initialized with TCKind._tk_longdouble.

tk_wchar

public static final TCKind tk_wchar
The TCKind constant whose value field is initialized with TCKind._tk_wchar.

tk_wstring

public static final TCKind tk_wstring
The TCKind constant whose value field is initialized with TCKind._tk_wstring.

tk_fixed

public static final TCKind tk_fixed
The TCKind constant whose value field is initialized with TCKind._tk_fixed.

tk_value

public static final TCKind tk_value
The TCKind constant whose value field is initialized with TCKind._tk_value.

tk_value_box

public static final TCKind tk_value_box
The TCKind constant whose value field is initialized with TCKind._tk_value_box.

tk_native

public static final TCKind tk_native
The TCKind constant whose value field is initialized with TCKind._tk_native.

tk_abstract_interface

public static final TCKind tk_abstract_interface
The TCKind constant whose value field is initialized with TCKind._tk_abstract_interface.

Constructor Detail

TCKind

@Deprecated
protected TCKind(int _value)
Deprecated. Do not use this constructor as this method should be private according to the OMG specification. Use from_int(int) instead.

Creates a new TCKind instance initialized with the given int.

Parameters:
_value - the int to convert. It must be one of the int constants in the class TCKind.
Method Detail

value

public int value()
Retrieves the value of this TCKind instance.

Returns:
the int that represents the kind of IDL data type for this TCKind instance

from_int

public static TCKind from_int(int i)
Converts the given int to the corresponding TCKind instance.

Parameters:
i - the int to convert. It must be one of the int constants in the class TCKind.
Returns:
the TCKind instance whose value field matches the given int
Throws:
BAD_PARAM - if the given int does not match the _value field of any TCKind instance
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TIMEOUT (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class TIMEOUT

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.omg.CORBA.SystemException
                    extended by  org.omg.CORBA.TIMEOUT
All Implemented Interfaces:
Serializable
public final class TIMEOUT
extends SystemException

TIMEOUT is raised when no delivery has been made and the specified time-to-live period has been exceeded. It is a standard system exception because time-to-live QoS can be applied to any invocation.

Since:
J2SE 1.5
See Also:
documentation on Java IDL exceptions

Field Summary
Modifier and Type Field and Description
Fields inherited from class org.omg.CORBA.SystemException
completed, minor
Constructor Summary
Constructor and Description
TIMEOUT()
Constructs an TIMEOUT exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
TIMEOUT(int minorCode, CompletionStatus completionStatus)
Constructs an TIMEOUT exception with the specified minor code and completion status.
TIMEOUT(String detailMessage)
Constructs an TIMEOUT exception with the specified message.
TIMEOUT(String detailMessage, int minorCode, CompletionStatus completionStatus)
Constructs an TIMEOUT exception with the specified message, minor code, and completion status.
Method Summary
Modifier and Type Method and Description
Methods inherited from class org.omg.CORBA.SystemException
toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TIMEOUT

public TIMEOUT()
Constructs an TIMEOUT exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.

TIMEOUT

public TIMEOUT(String detailMessage)
Constructs an TIMEOUT exception with the specified message.

Parameters:
detailMessage - string containing a detailed message.

TIMEOUT

public TIMEOUT(int minorCode,
               CompletionStatus completionStatus)
Constructs an TIMEOUT exception with the specified minor code and completion status.

Parameters:
minorCode - minor code.
completionStatus - completion status.

TIMEOUT

public TIMEOUT(String detailMessage,
               int minorCode,
               CompletionStatus completionStatus)
Constructs an TIMEOUT exception with the specified message, minor code, and completion status.

Parameters:
detailMessage - string containing a detailed message.
minorCode - minor code.
completionStatus - completion status.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TRANSACTION_MODE (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class TRANSACTION_MODE

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.omg.CORBA.SystemException
                    extended by  org.omg.CORBA.TRANSACTION_MODE
All Implemented Interfaces:
Serializable
public final class TRANSACTION_MODE
extends SystemException

The CORBA TRANSACTION_MODE exception is thrown by the client ORB if it detects a mismatch between the InvocationPolicy in the IOR and the chosen invocation path (i.e, direct or routed invocation). It contains a minor code, which gives information about what caused the exception, and a completion status. It may also contain a string describing the exception. The OMG CORBA core 2.4 specification has details.

See Also:
documentation on Java IDL exceptions

Field Summary
Modifier and Type Field and Description
Fields inherited from class org.omg.CORBA.SystemException
completed, minor
Constructor Summary
Constructor and Description
TRANSACTION_MODE()
Constructs a TRANSACTION_MODE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
TRANSACTION_MODE(int minor, CompletionStatus completed)
Constructs a TRANSACTION_MODE exception with the specified minor code and completion status.
TRANSACTION_MODE(String s)
Constructs a TRANSACTION_MODE exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
TRANSACTION_MODE(String s, int minor, CompletionStatus completed)
Constructs a TRANSACTION_MODE exception with the specified description message, minor code, and completion status.
Method Summary
Modifier and Type Method and Description
Methods inherited from class org.omg.CORBA.SystemException
toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TRANSACTION_MODE

public TRANSACTION_MODE()
Constructs a TRANSACTION_MODE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

TRANSACTION_MODE

public TRANSACTION_MODE(String s)
Constructs a TRANSACTION_MODE exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.

Parameters:
s - the String containing a detail message

TRANSACTION_MODE

public TRANSACTION_MODE(int minor,
                        CompletionStatus completed)
Constructs a TRANSACTION_MODE exception with the specified minor code and completion status.

Parameters:
minor - the minor code
completed - the completion status

TRANSACTION_MODE

public TRANSACTION_MODE(String s,
                        int minor,
                        CompletionStatus completed)
Constructs a TRANSACTION_MODE exception with the specified description message, minor code, and completion status.

Parameters:
s - the String containing a description message
minor - the minor code
completed - the completion status
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TRANSACTION_REQUIRED (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class TRANSACTION_REQUIRED

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.omg.CORBA.SystemException
                    extended by  org.omg.CORBA.TRANSACTION_REQUIRED
All Implemented Interfaces:
Serializable
public final class TRANSACTION_REQUIRED
extends SystemException

Exception indicates that the request carried a null transaction context, but an active transaction is required.

It contains a minor code, which gives information about what caused the exception, and a completion status. It may also contain a string describing the exception. The OMG Transaction Service specfication has details.

See Also:
documentation on Java IDL exceptions

Field Summary
Modifier and Type Field and Description
Fields inherited from class org.omg.CORBA.SystemException
completed, minor
Constructor Summary
Constructor and Description
TRANSACTION_REQUIRED()
Constructs a TRANSACTION_REQUIRED exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
TRANSACTION_REQUIRED(int minor, CompletionStatus completed)
Constructs a TRANSACTION_REQUIRED exception with the specified minor code and completion status.
TRANSACTION_REQUIRED(String s)
Constructs a TRANSACTION_REQUIRED exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
TRANSACTION_REQUIRED(String s, int minor, CompletionStatus completed)
Constructs a TRANSACTION_REQUIRED exception with the specified description message, minor code, and completion status.
Method Summary
Modifier and Type Method and Description
Methods inherited from class org.omg.CORBA.SystemException
toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TRANSACTION_REQUIRED

public TRANSACTION_REQUIRED()
Constructs a TRANSACTION_REQUIRED exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

TRANSACTION_REQUIRED

public TRANSACTION_REQUIRED(String s)
Constructs a TRANSACTION_REQUIRED exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.

Parameters:
s - the String containing a detail message

TRANSACTION_REQUIRED

public TRANSACTION_REQUIRED(int minor,
                            CompletionStatus completed)
Constructs a TRANSACTION_REQUIRED exception with the specified minor code and completion status.

Parameters:
minor - the minor code
completed - the completion status

TRANSACTION_REQUIRED

public TRANSACTION_REQUIRED(String s,
                            int minor,
                            CompletionStatus completed)
Constructs a TRANSACTION_REQUIRED exception with the specified description message, minor code, and completion status.

Parameters:
s - the String containing a description message
minor - the minor code
completed - the completion status
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TRANSACTION_ROLLEDBACK (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class TRANSACTION_ROLLEDBACK

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.omg.CORBA.SystemException
                    extended by  org.omg.CORBA.TRANSACTION_ROLLEDBACK
All Implemented Interfaces:
Serializable
public final class TRANSACTION_ROLLEDBACK
extends SystemException

Exception thrown when the transaction associated with the request has already been rolled back or marked to roll back. Thus, the requested operation either could not be performed or was not performed because further computation on behalf of the transaction would be fruitless.

See the OMG Transaction Service specification for details. It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

See Also:
documentation on Java IDL exceptions

Field Summary
Modifier and Type Field and Description
Fields inherited from class org.omg.CORBA.SystemException
completed, minor
Constructor Summary
Constructor and Description
TRANSACTION_ROLLEDBACK()
Constructs a TRANSACTION_ROLLEDBACK exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
TRANSACTION_ROLLEDBACK(int minor, CompletionStatus completed)
Constructs a TRANSACTION_ROLLEDBACK exception with the specified minor code and completion status.
TRANSACTION_ROLLEDBACK(String s)
Constructs a TRANSACTION_ROLLEDBACK exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
TRANSACTION_ROLLEDBACK(String s, int minor, CompletionStatus completed)
Constructs a TRANSACTION_ROLLEDBACK exception with the specified description message, minor code, and completion status.
Method Summary
Modifier and Type Method and Description
Methods inherited from class org.omg.CORBA.SystemException
toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TRANSACTION_ROLLEDBACK

public TRANSACTION_ROLLEDBACK()
Constructs a TRANSACTION_ROLLEDBACK exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

TRANSACTION_ROLLEDBACK

public TRANSACTION_ROLLEDBACK(String s)
Constructs a TRANSACTION_ROLLEDBACK exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.

Parameters:
s - the String containing a detail message

TRANSACTION_ROLLEDBACK

public TRANSACTION_ROLLEDBACK(int minor,
                              CompletionStatus completed)
Constructs a TRANSACTION_ROLLEDBACK exception with the specified minor code and completion status.

Parameters:
minor - the minor code
completed - the completion status

TRANSACTION_ROLLEDBACK

public TRANSACTION_ROLLEDBACK(String s,
                              int minor,
                              CompletionStatus completed)
Constructs a TRANSACTION_ROLLEDBACK exception with the specified description message, minor code, and completion status.

Parameters:
s - the String containing a description message
minor - the minor code
completed - the completion status
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TRANSACTION_UNAVAILABLE (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class TRANSACTION_UNAVAILABLE

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.omg.CORBA.SystemException
                    extended by  org.omg.CORBA.TRANSACTION_UNAVAILABLE
All Implemented Interfaces:
Serializable
public final class TRANSACTION_UNAVAILABLE
extends SystemException

The CORBA TRANSACTION_UNAVAILABLE exception is thrown by the ORB when it cannot process a transaction service context because its connection to the Transaction Service has been abnormally terminated. It contains a minor code, which gives information about what caused the exception, and a completion status. It may also contain a string describing the exception. The OMG CORBA core 2.4 specification has details.

See Also:
documentation on Java IDL exceptions

Field Summary
Modifier and Type Field and Description
Fields inherited from class org.omg.CORBA.SystemException
completed, minor
Constructor Summary
Constructor and Description
TRANSACTION_UNAVAILABLE()
Constructs a TRANSACTION_UNAVAILABLE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
TRANSACTION_UNAVAILABLE(int minor, CompletionStatus completed)
Constructs a TRANSACTION_UNAVAILABLE exception with the specified minor code and completion status.
TRANSACTION_UNAVAILABLE(String s)
Constructs a TRANSACTION_UNAVAILABLE exception with the specifieddescription message, a minor code of 0, and a completion state of COMPLETED_NO.
TRANSACTION_UNAVAILABLE(String s, int minor, CompletionStatus completed)
Constructs a TRANSACTION_UNAVAILABLE exception with the specified description message, minor code, and completion status.
Method Summary
Modifier and Type Method and Description
Methods inherited from class org.omg.CORBA.SystemException
toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TRANSACTION_UNAVAILABLE

public TRANSACTION_UNAVAILABLE()
Constructs a TRANSACTION_UNAVAILABLE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

TRANSACTION_UNAVAILABLE

public TRANSACTION_UNAVAILABLE(String s)
Constructs a TRANSACTION_UNAVAILABLE exception with the specifieddescription message, a minor code of 0, and a completion state of COMPLETED_NO.

Parameters:
s - the String containing a detail message

TRANSACTION_UNAVAILABLE

public TRANSACTION_UNAVAILABLE(int minor,
                               CompletionStatus completed)
Constructs a TRANSACTION_UNAVAILABLE exception with the specified minor code and completion status.

Parameters:
minor - the minor code
completed - the completion status

TRANSACTION_UNAVAILABLE

public TRANSACTION_UNAVAILABLE(String s,
                               int minor,
                               CompletionStatus completed)
Constructs a TRANSACTION_UNAVAILABLE exception with the specified description message, minor code, and completion status.

Parameters:
s - the String containing a description message
minor - the minor code
completed - the completion status
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TRANSIENT (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class TRANSIENT

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.omg.CORBA.SystemException
                    extended by  org.omg.CORBA.TRANSIENT
All Implemented Interfaces:
Serializable
public final class TRANSIENT
extends SystemException

Exception thrown when the ORB attempted to reach an object and failed. It is not an indication that an object does not exist. Instead, it simply means that no further determination of an object's status was possible because it could not be reached. This exception is raised if an attempt to establish a connection fails, for example, because the server or the implementation repository is down.

It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

See Also:
documentation on Java IDL exceptions

Field Summary
Modifier and Type Field and Description
Fields inherited from class org.omg.CORBA.SystemException
completed, minor
Constructor Summary
Constructor and Description
TRANSIENT()
Constructs a TRANSIENT exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
TRANSIENT(int minor, CompletionStatus completed)
Constructs a TRANSIENT exception with the specified minor code and completion status.
TRANSIENT(String s)
Constructs a TRANSIENT exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
TRANSIENT(String s, int minor, CompletionStatus completed)
Constructs a TRANSIENT exception with the specified description message, minor code, and completion status.
Method Summary
Modifier and Type Method and Description
Methods inherited from class org.omg.CORBA.SystemException
toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TRANSIENT

public TRANSIENT()
Constructs a TRANSIENT exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

TRANSIENT

public TRANSIENT(String s)
Constructs a TRANSIENT exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.

Parameters:
s - the String containing a detail message

TRANSIENT

public TRANSIENT(int minor,
                 CompletionStatus completed)
Constructs a TRANSIENT exception with the specified minor code and completion status.

Parameters:
minor - the minor code
completed - the completion status

TRANSIENT

public TRANSIENT(String s,
                 int minor,
                 CompletionStatus completed)
Constructs a TRANSIENT exception with the specified description message, minor code, and completion status.

Parameters:
s - the String containing a description message
minor - the minor code
completed - the completion status
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TypeCode (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class TypeCode

java.lang.Object
    extended by  org.omg.CORBA.TypeCode
All Implemented Interfaces:
Serializable, IDLEntity
public abstract class TypeCode
extends Object
implements IDLEntity

A container for information about a specific CORBA data type.

TypeCode objects are used:

  • in the Dynamic Invocation Interface -- to indicate the types of the actual arguments or the type of the return value.
    NamedValue objects are used to represent arguments and return values. One of their components is an Any object, which in turn has as one of its components a TypeCode object.
  • by an Interface Repository to represent the type specifications that are part of many OMG IDL declarations

The representation of a TypeCode object is opaque, but abstractly, a TypeCode object consists of:

  • a kind field, which is set to an instance of the class TCKind
  • zero or more additional fields appropriate for the particular kind. For example, the TypeCode object describing the OMG IDL type 1ong has kind TCKind.tk_long and no additional fields. The TypeCode describing OMG IDL type sequence<boolean, 10> has a kind field with the value TCKind.tk_sequence and also fields with the values boolean and 10 for the type of sequence elements and the length of the sequence.

TypeCode objects can be obtained in various ways:
  1. from a call to the method Any.insert_X, where X is a basic IDL type. This method creates a TypeCode object for type X and assigns it to the Any object's type field.
  2. from invocations of methods in the ORB class

    For example, the following creates a TypeCode object for a string with a maximum of 30 characters:

       org.omg.CORBA.TypeCode tcString = orb.create_string_tc(30);

    The following creates a TypeCode object for an array of five strings:

       org.omg.CORBA.TypeCode tcArray = orb.create_array_tc(
                                       5, TCKind.tk_string);

    The following creates a TypeCode object for an interface named "Account":

       org.omg.CORBA.TypeCode tcInterface = orb.create_interface_tc(
                                                 "thisId", "Account");
  3. as the return value from the _type method in Holder classes for user-defined IDL types. These Holder classes are generated by the idltojava compiler.
  4. from a CORBA Interface Repository

Most of the methods in the class TypeCode are accessors, and the information contained in a TypeCode object is specific to a particular type. Therefore, methods must be invoked only on the kind of type codes to which they apply. If an accessor method tries to access information from an inappropriate kind of type code, it will throw the exception TypeCodePackage.BadKind. For example, if the method discriminator_type is called on anything other than a union, it will throw BadKind because only unions have a discriminator. The following list shows which methods apply to which kinds of type codes:

These methods may be invoked on all TypeCode kinds:

  • equal
  • kind

These methods may be invoked on objref, struct, union, enum, alias, exception, value, value_box, native, and abstract_interface:

  • id
  • name

These methods may be invoked on struct, union, enum, and exception:

  • member_count
  • member_name

These methods may be invoked on struct, union, and exception:

  • member_type(int index)

These methods may be invoked on union:

  • member_label
  • discriminator_type
  • default_index

These methods may be invoked on string, sequence, and array:

  • length

These methods may be invoked on alias, sequence, array, and value_box:

  • content_type

Unlike other CORBA pseudo-objects, TypeCode objects can be passed as general IDL parameters.

The methods parameter and param_count, which are deprecated, are not mapped.

Java IDL extends the CORBA specification to allow all operations permitted on a struct TypeCode to be permitted on an exception TypeCode as well.

Constructor Summary
Constructor and Description
TypeCode()
Method Summary
Modifier and Type | Method and Description
abstract TypeCode | concrete_base_type() Returns the TypeCode object that describes the concrete base type of the value type that this TypeCode object describes.
abstract TypeCode | content_type() Returns the TypeCode object representing the IDL type for the members of the object described by this TypeCode object.
abstract int | default_index() Returns the index of the default member, or -1 if there is no default member.
abstract TypeCode | discriminator_type() Returns a TypeCode object describing all non-default member labels.
abstract boolean | equal(TypeCode tc) Compares this TypeCode object with the given one, testing for equality.
abstract boolean | equivalent(TypeCode tc) Tests to see if the given TypeCode object is equivalent to this TypeCode object.
abstract short | fixed_digits() Returns the number of digits in the fixed type described by this TypeCode object.
abstract short | fixed_scale() Returns the scale of the fixed type described by this TypeCode object.
abstract TypeCode | get_compact_typecode() Strips out all optional name and member name fields, but leaves all alias typecodes intact.
abstract String | id() Retrieves the RepositoryId globally identifying the type of this TypeCode object.
abstract TCKind | kind() Retrieves the kind of this TypeCode object.
abstract int | length() Returns the number of elements in the type described by this TypeCode object.
abstract int | member_count() Retrieves the number of members in the type described by this TypeCode object.
abstract Any | member_label(int index) Retrieves the label of the union member identified by the given index.
abstract String | member_name(int index) Retrieves the simple name of the member identified by the given index.
abstract TypeCode | member_type(int index) Retrieves the TypeCode object describing the type of the member identified by the given index.
abstract short | member_visibility(int index) Returns the constant that indicates the visibility of the member at the given index.
abstract String | name() Retrieves the simple name identifying this TypeCode object within its enclosing scope.
abstract short | type_modifier() Returns a constant indicating the modifier of the value type that this TypeCode object describes.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TypeCode

public TypeCode()
Method Detail

equal

public abstract boolean equal(TypeCode tc)
Compares this TypeCode object with the given one, testing for equality. TypeCode objects are equal if they are interchangeable and give identical results when TypeCode operations are applied to them.

Parameters:
tc - the TypeCode object to compare against
Returns:
true if the type codes are equal; false otherwise

equivalent

public abstract boolean equivalent(TypeCode tc)
Tests to see if the given TypeCode object is equivalent to this TypeCode object.

Parameters:
tc - the typecode to compare with this typecode
Returns:
true if the given typecode is equivalent to this typecode; false otherwise

get_compact_typecode

public abstract TypeCode get_compact_typecode()
Strips out all optional name and member name fields, but leaves all alias typecodes intact.

Returns:
a TypeCode object with optional name and member name fields stripped out, except for alias typecodes, which are left intact
See Also:
CORBA package comments for unimplemented features

kind

public abstract TCKind kind()
Retrieves the kind of this TypeCode object. The kind of a type code determines which TypeCode methods may legally be invoked on it.

The method kind may be invoked on any TypeCode object.

Returns:
the TCKind instance indicating the value of the kind field of this TypeCode object

id

public abstract String id()
                   throws BadKind
Retrieves the RepositoryId globally identifying the type of this TypeCode object.

The method id can be invoked on object reference, structure, union, enumeration, alias, exception, valuetype, boxed valuetype, native, and abstract interface type codes. Object reference, exception, valuetype, boxed valuetype, native, and abstract interface TypeCode objects always have a RepositoryId. Structure, union, enumeration, and alias TypeCode objects obtained from the Interface Repository or the method ORB.create_operation_list also always have a RepositoryId. If there is no RepositoryId, the method can return an empty string.

Returns:
the RepositoryId for this TypeCode object or an empty string if there is no RepositoryID
Throws:
BadKind - if the method is invoked on an inappropriate kind ofTypeCode object

name

public abstract String name()
                     throws BadKind
Retrieves the simple name identifying this TypeCode object within its enclosing scope. Since names are local to a Repository, the name returned from a TypeCode object may not match the name of the type in any particular Repository, and may even be an empty string.

The method name can be invoked on object reference, structure, union, enumeration, alias, exception, valuetype, boxed valuetype, native, and abstract interface TypeCode objects.

Returns:
the name identifying this TypeCode object or an empty string
Throws:
BadKind - if the method is invoked on an inappropriate kind ofTypeCode object

member_count

public abstract int member_count()
                          throws BadKind
Retrieves the number of members in the type described by this TypeCode object.

The method member_count can be invoked on structure, union, and enumeration TypeCode objects. Java IDL extends the CORBA specification to allow this method to operate on exceptions as well.

Returns:
the number of members constituting the type described by this TypeCode object
Throws:
BadKind - if the method is invoked on an inappropriate kind of TypeCode object

member_name

public abstract String member_name(int index)
                            throws BadKind,
                                   Bounds
Retrieves the simple name of the member identified by the given index. Since names are local to a Repository, the name returned from a TypeCode object may not match the name of the member in any particular Repository, and may even be an empty string.

The method member_name can be invoked on structure, union, and enumeration TypeCode objects. Java IDL extends the CORBA specification to allow this method to operate on exceptions as well.

Parameters:
index - index of the member for which a name is being reqested
Returns:
simple name of the member identified by the index or an empty string
Throws:
Bounds - if the index is equal to or greater than the number of members constituting the type
BadKind - if the method is invoked on an inappropriate kind of TypeCode object

member_type

public abstract TypeCode member_type(int index)
                              throws BadKind,
                                     Bounds
Retrieves the TypeCode object describing the type of the member identified by the given index.

The method member_type can be invoked on structure and union TypeCode objects. Java IDL extends the CORBA specification to allow this method to operate on exceptions as well.

Parameters:
index - index of the member for which type information is begin requested
Returns:
the TypeCode object describing the member at the given index
Throws:
Bounds - if the index is equal to or greater than the number of members constituting the type
BadKind - if the method is invoked on an inappropriate kind of TypeCode object

member_label

public abstract Any member_label(int index)
                          throws BadKind,
                                 Bounds
Retrieves the label of the union member identified by the given index. For the default member, the label is the zero octet.

The method member_label can only be invoked on union TypeCode objects.

Parameters:
index - index of the union member for which the label is being requested
Returns:
an Any object describing the label of the requested union member or the zero octet for the default member
Throws:
Bounds - if the index is equal to or greater than the number of members constituting the union
BadKind - if the method is invoked on a non-union TypeCode object

discriminator_type

public abstract TypeCode discriminator_type()
                                     throws BadKind
Returns a TypeCode object describing all non-default member labels. The method discriminator_type can be invoked only on union TypeCode objects.

Returns:
the TypeCode object describing the non-default member labels
Throws:
BadKind - if the method is invoked on a non-union TypeCode object

default_index

public abstract int default_index()
                           throws BadKind
Returns the index of the default member, or -1 if there is no default member.

The method default_index can be invoked only on union TypeCode objects.

Returns:
the index of the default member, or -1 if there is no default member
Throws:
BadKind - if the method is invoked on a non-union TypeCode object

length

public abstract int length()
                    throws BadKind
Returns the number of elements in the type described by this TypeCode object. For strings and sequences, it returns the bound, with zero indicating an unbounded string or sequence. For arrays, it returns the number of elements in the array.

The method length can be invoked on string, sequence, and array TypeCode objects.

Returns:
the bound for strings and sequences, or the number of elements for arrays
Throws:
BadKind - if the method is invoked on an inappropriate kind of TypeCode object

content_type

public abstract TypeCode content_type()
                               throws BadKind
Returns the TypeCode object representing the IDL type for the members of the object described by this TypeCode object. For sequences and arrays, it returns the element type. For aliases, it returns the original type. Note that multidimensional arrays are represented by nesting TypeCode objects, one per dimension. For boxed valuetypes, it returns the boxed type.

The method content_type can be invoked on sequence, array, alias, and boxed valuetype TypeCode objects.

Returns:
a TypeCode object representing the element type for sequences and arrays, the original type for aliases, or the boxed type for boxed valuetypes.
Throws:
BadKind - if the method is invoked on an inappropriate kind of TypeCode object

fixed_digits

public abstract short fixed_digits()
                            throws BadKind
Returns the number of digits in the fixed type described by this TypeCode object. For example, the typecode for the number 3000.275d could be fixed<7,3>, where 7 is the precision and 3 is the scale.

Returns:
the total number of digits
Throws:
BadKind - if this method is invoked on an inappropriate kind of TypeCode object

fixed_scale

public abstract short fixed_scale()
                           throws BadKind
Returns the scale of the fixed type described by this TypeCode object. A positive number indicates the number of digits to the right of the decimal point. For example, the number 3000d could have the typecode fixed<4,0>, where the first number is the precision and the second number is the scale. A negative number is also possible and adds zeroes to the left of the decimal point. In this case, fixed<1,-3>, could be the typecode for the number 3000d.

Returns:
the scale of the fixed type that this TypeCode object describes
Throws:
BadKind - if this method is invoked on an inappropriate kind of TypeCode object

member_visibility

public abstract short member_visibility(int index)
                                 throws BadKind,
                                        Bounds
Returns the constant that indicates the visibility of the member at the given index. This operation can only be invoked on non-boxed value TypeCode objects.

Parameters:
index - an int indicating the index into the value
Returns:
either PRIVATE_MEMBER.value or PUBLIC_MEMBER.value
Throws:
BadKind - if this method is invoked on a non-value type TypeCode object
Bounds - if the given index is out of bounds
See Also:
CORBA package comments for unimplemented features

type_modifier

public abstract short type_modifier()
                             throws BadKind
Returns a constant indicating the modifier of the value type that this TypeCode object describes. The constant returned must be one of the following: VM_NONE.value, VM_ABSTRACT.value, VM_CUSTOM.value, or VM_TRUNCATABLE.value,

Returns:
a constant describing the value type that this TypeCode object describes
Throws:
BadKind - if this method is invoked on a non-value type TypeCode object
See Also:
CORBA package comments for unimplemented features

concrete_base_type

public abstract TypeCode concrete_base_type()
                                     throws BadKind
Returns the TypeCode object that describes the concrete base type of the value type that this TypeCode object describes. Returns null if it doesn't have a concrete base type.

Returns:
the TypeCode object that describes the concrete base type of the value type that this TypeCode object describes
Throws:
BadKind - if this method is invoked on a non-boxed value type TypeCode object
See Also:
CORBA package comments for unimplemented features
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TypeCodeHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class TypeCodeHolder

java.lang.Object
    extended by  org.omg.CORBA.TypeCodeHolder
All Implemented Interfaces:
Streamable
public final class TypeCodeHolder
extends Object
implements Streamable

The Holder for TypeCode. For more information on Holder files, see "Generated Files: Holder Files".

A Holder class for a TypeCode object that is used to store "out" and "inout" parameters in IDL operations. If an IDL operation signature has an IDL TypeCode as an "out" or "inout" parameter, the programmer must pass an instance of TypeCodeHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

If myTypeCodeHolder is an instance of TypeCodeHolder, the value stored in its value field can be accessed with myTypeCodeHolder.value.

Since:
JDK1.2

Field Summary
Modifier and Type | Field and Description
TypeCode | value The TypeCode value held by this TypeCodeHolder object.
Constructor Summary
Constructor and Description
TypeCodeHolder()
Constructs a new TypeCodeHolder object with its value field initialized to null.
TypeCodeHolder(TypeCode initial)
Constructs a new TypeCodeHolder object with its value field initialized to the given TypeCode object.
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream input) Reads from input and initalizes the value in this TypeCodeHolder object with the unmarshalled data.
TypeCode | _type() Returns the TypeCode corresponding to the value held in this TypeCodeHolder object.
void | _write(OutputStream output) Marshals to output the value in this TypeCodeHolder object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public TypeCode value
The TypeCode value held by this TypeCodeHolder object.

Constructor Detail

TypeCodeHolder

public TypeCodeHolder()
Constructs a new TypeCodeHolder object with its value field initialized to null.

TypeCodeHolder

public TypeCodeHolder(TypeCode initial)
Constructs a new TypeCodeHolder object with its value field initialized to the given TypeCode object.

Parameters:
initial - the TypeCode object with which to initialize the value field of the newly-created TypeCodeHolder object
Method Detail

_read

public void _read(InputStream input)
Reads from input and initalizes the value in this TypeCodeHolder object with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
input - the InputStream containing CDR formatted data from the wire

_write

public void _write(OutputStream output)
Marshals to output the value in this TypeCodeHolder object.

Specified by:
_write in interface Streamable
Parameters:
output - the OutputStream which will contain the CDR formatted data

_type

public TypeCode _type()
Returns the TypeCode corresponding to the value held in this TypeCodeHolder object.

Specified by:
_type in interface Streamable
Returns:
the TypeCode of the value held in this TypeCodeHolder object
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ULongLongSeqHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class ULongLongSeqHelper

java.lang.Object
    extended by  org.omg.CORBA.ULongLongSeqHelper

public abstract class ULongLongSeqHelper
extends Object

The Helper for ULongLongSeq. For more information on Helper files, see "Generated Files: Helper Files".

org/omg/CORBA/ULongLongSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:37 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

  • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
  • IDL/Java Language Mapping as defined in ptc/00-01-08

Constructor Summary
Constructor and Description
ULongLongSeqHelper()
Method Summary
Modifier and Type | Method and Description
static long[] | extract(Any a)
static String | id()
static void | insert(Any a, long[] that)
static long[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, long[] value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ULongLongSeqHelper

public ULongLongSeqHelper()
Method Detail

insert

public static void insert(Any a,
                          long[] that)

extract

public static long[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static long[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         long[] value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ULongLongSeqHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class ULongLongSeqHolder

java.lang.Object
    extended by  org.omg.CORBA.ULongLongSeqHolder
All Implemented Interfaces:
Streamable
public final class ULongLongSeqHolder
extends Object
implements Streamable

The Holder for ULongLongSeq. For more information on Holder files, see "Generated Files: Holder Files".

org/omg/CORBA/ULongLongSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:37 o'clock GMT+00:00

Field Summary
Modifier and Type | Field and Description
long[] | value
Constructor Summary
Constructor and Description
ULongLongSeqHolder()
ULongLongSeqHolder(long[] initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public long[] value
Constructor Detail

ULongLongSeqHolder

public ULongLongSeqHolder()

ULongLongSeqHolder

public ULongLongSeqHolder(long[] initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ULongSeqHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class ULongSeqHelper

java.lang.Object
    extended by  org.omg.CORBA.ULongSeqHelper

public abstract class ULongSeqHelper
extends Object

The Helper for ULongSeq. For more information on Helper files, see "Generated Files: Helper Files".

org/omg/CORBA/ULongSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

  • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
  • IDL/Java Language Mapping as defined in ptc/00-01-08

Constructor Summary
Constructor and Description
ULongSeqHelper()
Method Summary
Modifier and Type | Method and Description
static int[] | extract(Any a)
static String | id()
static void | insert(Any a, int[] that)
static int[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, int[] value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ULongSeqHelper

public ULongSeqHelper()
Method Detail

insert

public static void insert(Any a,
                          int[] that)

extract

public static int[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static int[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         int[] value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ULongSeqHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class ULongSeqHolder

java.lang.Object
    extended by  org.omg.CORBA.ULongSeqHolder
All Implemented Interfaces:
Streamable
public final class ULongSeqHolder
extends Object
implements Streamable

The Holder for ULongSeq. For more information on Holder files, see "Generated Files: Holder Files".

org/omg/CORBA/ULongSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

Field Summary
Modifier and Type | Field and Description
int[] | value
Constructor Summary
Constructor and Description
ULongSeqHolder()
ULongSeqHolder(int[] initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public int[] value
Constructor Detail

ULongSeqHolder

public ULongSeqHolder()

ULongSeqHolder

public ULongSeqHolder(int[] initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


UnionMember (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class UnionMember

java.lang.Object
    extended by  org.omg.CORBA.UnionMember
All Implemented Interfaces:
Serializable, IDLEntity
public final class UnionMember
extends Object
implements IDLEntity

A description in the Interface Repository of a member of an IDL union.

Field Summary
Modifier and Type | Field and Description
Any | label The label of the union member described by this UnionMember object.
String | name The name of the union member described by this UnionMember object.
TypeCode | type The type of the union member described by this UnionMember object.
IDLType | type_def The typedef that represents the IDL type of the union member described by this UnionMember object.
Constructor Summary
Constructor and Description
UnionMember()
Constructs a new UnionMember object with its fields initialized to null.
UnionMember(String __name, Any __label, TypeCode __type, IDLType __type_def)
Constructs a new UnionMember object with its fields initialized to the given values.
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

name

public String name
The name of the union member described by this UnionMember object.

label

public Any label
The label of the union member described by this UnionMember object.

type

public TypeCode type
The type of the union member described by this UnionMember object.

type_def

public IDLType type_def
The typedef that represents the IDL type of the union member described by this UnionMember object.

Constructor Detail

UnionMember

public UnionMember()
Constructs a new UnionMember object with its fields initialized to null.

UnionMember

public UnionMember(String __name,
                   Any __label,
                   TypeCode __type,
                   IDLType __type_def)
Constructs a new UnionMember object with its fields initialized to the given values.

Parameters:
__name - a String object with the name of this UnionMember object
__label - an Any object with the label of this UnionMember object
__type - a TypeCode object describing the type of this UnionMember object
__type_def - an IDLType object that represents the IDL type of this UnionMember object
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


UnionMemberHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class UnionMemberHelper

java.lang.Object
    extended by  org.omg.CORBA.UnionMemberHelper

public abstract class UnionMemberHelper
extends Object

The Helper for UnionMember. For more information on Helper files, see "Generated Files: Helper Files".

org/omg/CORBA/UnionMemberHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl 03 June 1999 11:33:43 o'clock GMT+00:00

Constructor Summary
Constructor and Description
UnionMemberHelper()
Method Summary
Modifier and Type | Method and Description
static UnionMember | extract(Any a)
static String | id()
static void | insert(Any a, UnionMember that)
static UnionMember | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, UnionMember value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UnionMemberHelper

public UnionMemberHelper()
Method Detail

insert

public static void insert(Any a,
                          UnionMember that)

extract

public static UnionMember extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static UnionMember read(InputStream istream)

write

public static void write(OutputStream ostream,
                         UnionMember value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


UNKNOWN (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class UNKNOWN

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.omg.CORBA.SystemException
                    extended by  org.omg.CORBA.UNKNOWN
All Implemented Interfaces:
Serializable
public final class UNKNOWN
extends SystemException

This exception is raised if an operation implementation throws a non-CORBA exception (such as an exception specific to the implementation's programming language), or if an operation raises a user exception that does not appear in the operation's raises expression. UNKNOWN is also raised if the server returns a system exception that is unknown to the client. (This can happen if the server uses a later version of CORBA than the client and new system exceptions have been added to the later version.)

It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

See the section Minor Code Meanings to see the minor codes for this exception.

See Also:
documentation on Java IDL exceptions

Field Summary
Modifier and Type Field and Description
Fields inherited from class org.omg.CORBA.SystemException
completed, minor
Constructor Summary
Constructor and Description
UNKNOWN()
Constructs an UNKNOWN exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
UNKNOWN(int minor, CompletionStatus completed)
Constructs an UNKNOWN exception with the specified minor code and completion status.
UNKNOWN(String s)
Constructs an UNKNOWN exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
UNKNOWN(String s, int minor, CompletionStatus completed)
Constructs an UNKNOWN exception with the specified description message, minor code, and completion status.
Method Summary
Modifier and Type Method and Description
Methods inherited from class org.omg.CORBA.SystemException
toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UNKNOWN

public UNKNOWN()
Constructs an UNKNOWN exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

UNKNOWN

public UNKNOWN(String s)
Constructs an UNKNOWN exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.

Parameters:
s - the String containing a detail message

UNKNOWN

public UNKNOWN(int minor,
               CompletionStatus completed)
Constructs an UNKNOWN exception with the specified minor code and completion status.

Parameters:
minor - the minor code
completed - the completion status

UNKNOWN

public UNKNOWN(String s,
               int minor,
               CompletionStatus completed)
Constructs an UNKNOWN exception with the specified description message, minor code, and completion status.

Parameters:
s - the String containing a description message
minor - the minor code
completed - the completion status
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


UnknownUserException (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class UnknownUserException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.CORBA.UnknownUserException
All Implemented Interfaces:
Serializable, IDLEntity
public final class UnknownUserException
extends UserException

A class that contains user exceptions returned by the server. When the client uses the DII to make an invocation, any user exception returned from the server is enclosed in an Any object contained in the UnknownUserException object. This is available from the Environment object returned by the method Request.env.

See Also:
documentation on Java IDL exceptions, Request

Field Summary
Modifier and Type | Field and Description
Any | except The Any instance that contains the actual user exception thrown by the server.
Constructor Summary
Constructor and Description
UnknownUserException()
Constructs an UnknownUserException object.
UnknownUserException(Any a)
Constructs an UnknownUserException object that contains the given Any object.
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

except

public Any except
The Any instance that contains the actual user exception thrown by the server.

Constructor Detail

UnknownUserException

public UnknownUserException()
Constructs an UnknownUserException object.

UnknownUserException

public UnknownUserException(Any a)
Constructs an UnknownUserException object that contains the given Any object.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


UnknownUserExceptionHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class UnknownUserExceptionHelper

java.lang.Object
    extended by  org.omg.CORBA.UnknownUserExceptionHelper

public abstract class UnknownUserExceptionHelper
extends Object

The Helper for UnknownUserException. For more information on Helper files, see "Generated Files: Helper Files".

org/omg/CORBA/UnknownUserExceptionHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from CORBA.idl Thursday, August 24, 2000 5:52:22 PM PDT

Constructor Summary
Constructor and Description
UnknownUserExceptionHelper()
Method Summary
Modifier and Type | Method and Description
static UnknownUserException | extract(Any a)
static String | id()
static void | insert(Any a, UnknownUserException that)
static UnknownUserException | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, UnknownUserException value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UnknownUserExceptionHelper

public UnknownUserExceptionHelper()
Method Detail

insert

public static void insert(Any a,
                          UnknownUserException that)

extract

public static UnknownUserException extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static UnknownUserException read(InputStream istream)

write

public static void write(OutputStream ostream,
                         UnknownUserException value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


UnknownUserExceptionHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class UnknownUserExceptionHolder

java.lang.Object
    extended by  org.omg.CORBA.UnknownUserExceptionHolder
All Implemented Interfaces:
Streamable
public final class UnknownUserExceptionHolder
extends Object
implements Streamable

The Holder for UnknownUserException. For more information on Holder files, see "Generated Files: Holder Files".

org/omg/CORBA/UnknownUserExceptionHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from CORBA.idl Thursday, August 24, 2000 5:52:22 PM PDT

Field Summary
Modifier and Type | Field and Description
UnknownUserException | value
Constructor Summary
Constructor and Description
UnknownUserExceptionHolder()
UnknownUserExceptionHolder(UnknownUserException initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public UnknownUserException value
Constructor Detail

UnknownUserExceptionHolder

public UnknownUserExceptionHolder()

UnknownUserExceptionHolder

public UnknownUserExceptionHolder(UnknownUserException initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


UNSUPPORTED_POLICY (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Interface UNSUPPORTED_POLICY

public interface UNSUPPORTED_POLICY

One of the PolicyErrorCodes which would be filled if the requested Policy is understood to be valid by the ORB, but is not currently supported.

Field Summary
Modifier and Type | Field and Description
static short | value The Error code for PolicyError exception.

Field Detail

value

static final short value
The Error code for PolicyError exception.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


UNSUPPORTED_POLICY_VALUE (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Interface UNSUPPORTED_POLICY_VALUE

public interface UNSUPPORTED_POLICY_VALUE

A PolicyErrorCode which would be filled if the value requested for the Policy is of a valid type and within the valid range for that type, but this valid value is not currently supported.

Field Summary
Modifier and Type | Field and Description
static short | value The Error code for PolicyError exception.

Field Detail

value

static final short value
The Error code for PolicyError exception.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


UserException (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class UserException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
All Implemented Interfaces:
Serializable, IDLEntity
Direct Known Subclasses:
AdapterAlreadyExists, AdapterInactive, AdapterNonExistent, AlreadyBound, BadKind, Bounds, Bounds, CannotProceed, DuplicateName, FormatMismatch, ForwardRequest, ForwardRequest, InconsistentTypeCode, InconsistentTypeCode, Invalid, InvalidAddress, InvalidName, InvalidName, InvalidName, InvalidPolicy, InvalidSeq, InvalidSlot, InvalidTypeForEncoding, InvalidValue, InvalidValue, NoContext, NoServant, NotEmpty, NotFound, ObjectAlreadyActive, ObjectNotActive, PolicyError, ServantAlreadyActive, ServantNotActive, TypeMismatch, TypeMismatch, TypeMismatch, UnknownEncoding, UnknownUserException, WrongAdapter, WrongPolicy, WrongTransaction
public abstract class UserException
extends Exception
implements IDLEntity

The root class for CORBA IDL-defined user exceptions. All CORBA user exceptions are checked exceptions, which means that they need to be declared in method signatures.

See Also:
documentation on Java IDL exceptions

Constructor Summary
Modifier | Constructor and Description
protected | UserException() Constructs a UserException object.
protected | UserException(String reason) Constructs a UserException object with a detail message.
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UserException

protected UserException()
Constructs a UserException object. This method is called only by subclasses.

UserException

protected UserException(String reason)
Constructs a UserException object with a detail message. This method is called only by subclasses.

Parameters:
reason - a String object giving the reason for this exception
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


UShortSeqHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class UShortSeqHelper

java.lang.Object
    extended by  org.omg.CORBA.UShortSeqHelper

public abstract class UShortSeqHelper
extends Object

The Helper for UShortSeq. For more information on Helper files, see "Generated Files: Helper Files".

org/omg/CORBA/UShortSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

  • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
  • IDL/Java Language Mapping as defined in ptc/00-01-08

Constructor Summary
Constructor and Description
UShortSeqHelper()
Method Summary
Modifier and Type | Method and Description
static short[] | extract(Any a)
static String | id()
static void | insert(Any a, short[] that)
static short[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, short[] value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UShortSeqHelper

public UShortSeqHelper()
Method Detail

insert

public static void insert(Any a,
                          short[] that)

extract

public static short[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static short[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         short[] value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


UShortSeqHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class UShortSeqHolder

java.lang.Object
    extended by  org.omg.CORBA.UShortSeqHolder
All Implemented Interfaces:
Streamable
public final class UShortSeqHolder
extends Object
implements Streamable

The Holder for UShortSeq. For more information on Holder files, see "Generated Files: Holder Files".

org/omg/CORBA/UShortSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

Field Summary
Modifier and Type | Field and Description
short[] | value
Constructor Summary
Constructor and Description
UShortSeqHolder()
UShortSeqHolder(short[] initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public short[] value
Constructor Detail

UShortSeqHolder

public UShortSeqHolder()

UShortSeqHolder

public UShortSeqHolder(short[] initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ValueBaseHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class ValueBaseHelper

java.lang.Object
    extended by  org.omg.CORBA.ValueBaseHelper

public abstract class ValueBaseHelper
extends Object

Constructor Summary
Constructor and Description
ValueBaseHelper()
Method Summary
Modifier and Type | Method and Description
static Serializable | extract(Any a)
static String | id()
static void | insert(Any a, Serializable that)
static Serializable | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, Serializable value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ValueBaseHelper

public ValueBaseHelper()
Method Detail

insert

public static void insert(Any a,
                          Serializable that)

extract

public static Serializable extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static Serializable read(InputStream istream)

write

public static void write(OutputStream ostream,
                         Serializable value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ValueBaseHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class ValueBaseHolder

java.lang.Object
    extended by  org.omg.CORBA.ValueBaseHolder
All Implemented Interfaces:
Streamable
public final class ValueBaseHolder
extends Object
implements Streamable

The Holder for ValueBase. For more information on Holder files, see "Generated Files: Holder Files".

A Holder class for a java.io.Serializable that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL ValueBase as an "out" or "inout" parameter, the programmer must pass an instance of ValueBaseHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

If myValueBaseHolder is an instance of ValueBaseHolder, the value stored in its value field can be accessed with myValueBaseHolder.value.

Field Summary
Modifier and Type | Field and Description
Serializable | value The java.io.Serializable value held by this ValueBaseHolder object.
Constructor Summary
Constructor and Description
ValueBaseHolder()
Constructs a new ValueBaseHolder object with its value field initialized to 0.
ValueBaseHolder(Serializable initial)
Constructs a new ValueBaseHolder object with its value field initialized to the given java.io.Serializable.
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream input) Reads from input and initalizes the value in the Holder with the unmarshalled data.
TypeCode | _type() Returns the TypeCode object corresponding to the value held in the Holder.
void | _write(OutputStream output) Marshals to output the value in the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public Serializable value
The java.io.Serializable value held by this ValueBaseHolder object.

Constructor Detail

ValueBaseHolder

public ValueBaseHolder()
Constructs a new ValueBaseHolder object with its value field initialized to 0.

ValueBaseHolder

public ValueBaseHolder(Serializable initial)
Constructs a new ValueBaseHolder object with its value field initialized to the given java.io.Serializable.

Parameters:
initial - the java.io.Serializable with which to initialize the value field of the newly-created ValueBaseHolder object
Method Detail

_read

public void _read(InputStream input)
Reads from input and initalizes the value in the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
input - the InputStream containing CDR formatted data from the wire

_write

public void _write(OutputStream output)
Marshals to output the value in the Holder.

Specified by:
_write in interface Streamable
Parameters:
output - the OutputStream which will contain the CDR formatted data

_type

public TypeCode _type()
Returns the TypeCode object corresponding to the value held in the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode of the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ValueMember (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class ValueMember

java.lang.Object
    extended by  org.omg.CORBA.ValueMember
All Implemented Interfaces:
Serializable, IDLEntity
public final class ValueMember
extends Object
implements IDLEntity

A description in the Interface Repository of a member of a value object.

Field Summary
Modifier and Type | Field and Description
short | access The type of access (public, private) for the value member described by this ValueMember object.
String | defined_in The repository ID of the value in which this member is defined.
String | id The repository ID of the value member described by this ValueMember object;
String | name The name of the value member described by this ValueMember object.
TypeCode | type The type of of this value member.
IDLType | type_def The typedef that represents the IDL type of the value member described by this ValueMember object.
String | version The version of the value in which this member is defined.
Constructor Summary
Constructor and Description
ValueMember()
Constructs a default ValueMember object.
ValueMember(String __name, String __id, String __defined_in, String __version, TypeCode __type, IDLType __type_def, short __access)
Constructs a ValueMember object initialized with the given values.
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

name

public String name
The name of the value member described by this ValueMember object.

id

public String id
The repository ID of the value member described by this ValueMember object;

defined_in

public String defined_in
The repository ID of the value in which this member is defined.

version

public String version
The version of the value in which this member is defined.

type

public TypeCode type
The type of of this value member.

type_def

public IDLType type_def
The typedef that represents the IDL type of the value member described by this ValueMember object.

access

public short access
The type of access (public, private) for the value member described by this ValueMember object.

Constructor Detail

ValueMember

public ValueMember()
Constructs a default ValueMember object.

ValueMember

public ValueMember(String __name,
                   String __id,
                   String __defined_in,
                   String __version,
                   TypeCode __type,
                   IDLType __type_def,
                   short __access)
Constructs a ValueMember object initialized with the given values.

Parameters:
__name - The name of the value member described by this ValueMember object.
__id - The repository ID of the value member described by this ValueMember object;
__defined_in - The repository ID of the value in which this member is defined.
__version - The version of the value in which this member is defined.
__type - The type of of this value member.
__type_def - The typedef that represents the IDL type of the value member described by this ValueMember object.
__access - The type of access (public, private) for the value member described by this ValueMember object.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ValueMemberHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class ValueMemberHelper

java.lang.Object
    extended by  org.omg.CORBA.ValueMemberHelper

public abstract class ValueMemberHelper
extends Object

The Helper for ValueMember. For more information on Helper files, see "Generated Files: Helper Files".

org/omg/CORBA/ValueMemberHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl 03 June 1999 11:33:44 o'clock GMT+00:00

Constructor Summary
Constructor and Description
ValueMemberHelper()
Method Summary
Modifier and Type | Method and Description
static ValueMember | extract(Any a)
static String | id()
static void | insert(Any a, ValueMember that)
static ValueMember | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ValueMember value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ValueMemberHelper

public ValueMemberHelper()
Method Detail

insert

public static void insert(Any a,
                          ValueMember that)

extract

public static ValueMember extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ValueMember read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ValueMember value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


VersionSpecHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class VersionSpecHelper

java.lang.Object
    extended by  org.omg.CORBA.VersionSpecHelper

public abstract class VersionSpecHelper
extends Object

The Helper for VersionSpec. For more information on Helper files, see "Generated Files: Helper Files".

org/omg/CORBA/VersionSpecHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl 03 June 1999 11:33:43 o'clock GMT+00:00

Constructor Summary
Constructor and Description
VersionSpecHelper()
Method Summary
Modifier and Type | Method and Description
static String | extract(Any a)
static String | id()
static void | insert(Any a, String that)
static String | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

VersionSpecHelper

public VersionSpecHelper()
Method Detail

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


VisibilityHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class VisibilityHelper

java.lang.Object
    extended by  org.omg.CORBA.VisibilityHelper

public abstract class VisibilityHelper
extends Object

The Helper for Visibility. For more information on Helper files, see "Generated Files: Helper Files".

org/omg/CORBA/VisibilityHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl 03 June 1999 11:33:44 o'clock GMT+00:00

Constructor Summary
Constructor and Description
VisibilityHelper()
Method Summary
Modifier and Type | Method and Description
static short | extract(Any a)
static String | id()
static void | insert(Any a, short that)
static short | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, short value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

VisibilityHelper

public VisibilityHelper()
Method Detail

insert

public static void insert(Any a,
                          short that)

extract

public static short extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static short read(InputStream istream)

write

public static void write(OutputStream ostream,
                         short value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


VM_ABSTRACT (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Interface VM_ABSTRACT

public interface VM_ABSTRACT

Defines the code used to represent an Abstract interface in a typecode. This is one of the possible results of the type_modified method on the TypeCode interface.

See Also:
TypeCode

Field Summary
Modifier and Type | Field and Description
static short | value The value representing an abstract interface value type in a typecode.

Field Detail

value

static final short value
The value representing an abstract interface value type in a typecode.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


VM_CUSTOM (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Interface VM_CUSTOM

public interface VM_CUSTOM

Defines the code used to represent a custom marshalled value type in a typecode. This is one of the possible results of the type_modifier method on the TypeCode interface.

See Also:
TypeCode

Field Summary
Modifier and Type | Field and Description
static short | value The value representing a custom marshalled value type in a typecode.

Field Detail

value

static final short value
The value representing a custom marshalled value type in a typecode.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


VM_NONE (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Interface VM_NONE

public interface VM_NONE

Defines the code used to represent the one of the values of a value type in a typecode.

Since:
JDK1.2
See Also:
TypeCode

Field Summary
Modifier and Type | Field and Description
static short | value The value representing the value type in a typecode as per CORBA 2.3 spec.

Field Detail

value

static final short value
The value representing the value type in a typecode as per CORBA 2.3 spec.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


VM_TRUNCATABLE (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Interface VM_TRUNCATABLE

public interface VM_TRUNCATABLE

Defines the code used to represent a truncatable value type in a typecode. A value type is truncatable if it inherits "safely" from another value type, which means it can be cast to a more general inherited type. This is one of the possible results of the type_modifier method on the TypeCode interface.

See Also:
TypeCode

Field Summary
Modifier and Type | Field and Description
static short | value The value representing a truncatable value type in a typecode.

Field Detail

value

static final short value
The value representing a truncatable value type in a typecode.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


WCharSeqHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class WCharSeqHelper

java.lang.Object
    extended by  org.omg.CORBA.WCharSeqHelper

public abstract class WCharSeqHelper
extends Object

The Helper for WCharSeq. For more information on Helper files, see "Generated Files: Helper Files".

org/omg/CORBA/WCharSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

  • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
  • IDL/Java Language Mapping as defined in ptc/00-01-08

Constructor Summary
Constructor and Description
WCharSeqHelper()
Method Summary
Modifier and Type | Method and Description
static char[] | extract(Any a)
static String | id()
static void | insert(Any a, char[] that)
static char[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, char[] value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WCharSeqHelper

public WCharSeqHelper()
Method Detail

insert

public static void insert(Any a,
                          char[] that)

extract

public static char[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static char[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         char[] value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


WCharSeqHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class WCharSeqHolder

java.lang.Object
    extended by  org.omg.CORBA.WCharSeqHolder
All Implemented Interfaces:
Streamable
public final class WCharSeqHolder
extends Object
implements Streamable

The Holder for WCharSeq. For more information on Holder files, see "Generated Files: Holder Files".

org/omg/CORBA/WCharSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

Field Summary
Modifier and Type | Field and Description
char[] | value
Constructor Summary
Constructor and Description
WCharSeqHolder()
WCharSeqHolder(char[] initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public char[] value
Constructor Detail

WCharSeqHolder

public WCharSeqHolder()

WCharSeqHolder

public WCharSeqHolder(char[] initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


WrongTransaction (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class WrongTransaction

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.CORBA.WrongTransaction
All Implemented Interfaces:
Serializable, IDLEntity
public final class WrongTransaction
extends UserException

The CORBA WrongTransaction user-defined exception. This exception is thrown only by the methods Request.get_response and ORB.get_next_response when they are invoked from a transaction scope that is different from the one in which the client originally sent the request. See the OMG Transaction Service Specification for details.

See Also:
documentation on Java IDL exceptions

Constructor Summary
Constructor and Description
WrongTransaction()
Constructs a WrongTransaction object with an empty detail message.
WrongTransaction(String reason)
Constructs a WrongTransaction object with the given detail message.
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

WrongTransaction

public WrongTransaction()
Constructs a WrongTransaction object with an empty detail message.

WrongTransaction

public WrongTransaction(String reason)
Constructs a WrongTransaction object with the given detail message.

Parameters:
reason - The detail message explaining what caused this exception to be thrown.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


WrongTransactionHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class WrongTransactionHelper

java.lang.Object
    extended by  org.omg.CORBA.WrongTransactionHelper

public abstract class WrongTransactionHelper
extends Object

The Helper for WrongTransaction. For more information on Helper files, see "Generated Files: Helper Files".

org/omg/CORBA/WrongTransactionHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from CORBA.idl Thursday, August 24, 2000 5:32:50 PM PDT

Constructor Summary
Constructor and Description
WrongTransactionHelper()
Method Summary
Modifier and Type | Method and Description
static WrongTransaction | extract(Any a)
static String | id()
static void | insert(Any a, WrongTransaction that)
static WrongTransaction | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, WrongTransaction value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WrongTransactionHelper

public WrongTransactionHelper()
Method Detail

insert

public static void insert(Any a,
                          WrongTransaction that)

extract

public static WrongTransaction extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static WrongTransaction read(InputStream istream)

write

public static void write(OutputStream ostream,
                         WrongTransaction value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


WrongTransactionHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class WrongTransactionHolder

java.lang.Object
    extended by  org.omg.CORBA.WrongTransactionHolder
All Implemented Interfaces:
Streamable
public final class WrongTransactionHolder
extends Object
implements Streamable

The Holder for WrongTransaction. For more information on Holder files, see "Generated Files: Holder Files".

org/omg/CORBA/WrongTransactionHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from CORBA.idl Thursday, August 24, 2000 5:32:50 PM PDT

Field Summary
Modifier and Type | Field and Description
WrongTransaction | value
Constructor Summary
Constructor and Description
WrongTransactionHolder()
WrongTransactionHolder(WrongTransaction initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public WrongTransaction value
Constructor Detail

WrongTransactionHolder

public WrongTransactionHolder()

WrongTransactionHolder

public WrongTransactionHolder(WrongTransaction initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


WStringSeqHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class WStringSeqHelper

java.lang.Object
    extended by  org.omg.CORBA.WStringSeqHelper

public abstract class WStringSeqHelper
extends Object

An array of WStrings

Constructor Summary
Constructor and Description
WStringSeqHelper()
Method Summary
Modifier and Type | Method and Description
static String[] | extract(Any a)
static String | id()
static void | insert(Any a, String[] that)
static String[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String[] value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WStringSeqHelper

public WStringSeqHelper()
Method Detail

insert

public static void insert(Any a,
                          String[] that)

extract

public static String[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String[] value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


WStringSeqHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA
Class WStringSeqHolder

java.lang.Object
    extended by  org.omg.CORBA.WStringSeqHolder
All Implemented Interfaces:
Streamable
public final class WStringSeqHolder
extends Object
implements Streamable

An array of WStrings

Field Summary
Modifier and Type | Field and Description
String[] | value
Constructor Summary
Constructor and Description
WStringSeqHolder()
WStringSeqHolder(String[] initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public String[] value
Constructor Detail

WStringSeqHolder

public WStringSeqHolder()

WStringSeqHolder

public WStringSeqHolder(String[] initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


WStringValueHelper (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.CORBA
Class WStringValueHelper

java.lang.Object
    extended by  org.omg.CORBA.WStringValueHelper
All Implemented Interfaces:
BoxedValueHelper
public class WStringValueHelper
extends Object
implements BoxedValueHelper

org/omg/CORBA/WStringValueHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from orb.idl 31 May 1999 22:27:30 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

  • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
  • IDL/Java Language Mapping as defined in ptc/00-01-08

Constructor Summary
Constructor and Description
WStringValueHelper()
Method Summary
Modifier and Type | Method and Description
static String | extract(Any a)
String | get_id()
static String | id()
static void | insert(Any a, String that)
Serializable | read_value(InputStream istream)
static String | read(InputStream istream)
static TypeCode | type()
void | write_value(OutputStream ostream, Serializable value)
static void | write(OutputStream ostream, String value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WStringValueHelper

public WStringValueHelper()
Method Detail

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

read_value

public Serializable read_value(InputStream istream)
Specified by:
read_value in interface BoxedValueHelper

write

public static void write(OutputStream ostream,
                         String value)

write_value

public void write_value(OutputStream ostream,
                        Serializable value)
Specified by:
write_value in interface BoxedValueHelper

get_id

public String get_id()
Specified by:
get_id in interface BoxedValueHelper
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Invalid (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.CORBA.DynAnyPackage
Class Invalid

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.CORBA.DynAnyPackage.Invalid
All Implemented Interfaces:
Serializable, IDLEntity
public final class Invalid
extends UserException

Invalid is thrown by dynamic any operations when a bad DynAny or Any is passed as a parameter.

Constructor Summary
Constructor and Description
Invalid()
Constructs an Invalid object.
Invalid(String reason)
Constructs an Invalid object.
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Invalid

public Invalid()
Constructs an Invalid object.

Invalid

public Invalid(String reason)
Constructs an Invalid object.

Parameters:
reason - a String giving more information regarding the bad parameter passed to a dynamic any operation.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


InvalidSeq (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA.DynAnyPackage
Class InvalidSeq

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.CORBA.DynAnyPackage.InvalidSeq
All Implemented Interfaces:
Serializable, IDLEntity
public final class InvalidSeq
extends UserException

The InvalidSeq exception is thrown by all operations on dynamic anys that take a sequence (Java array) as an argument, when that sequence is invalid.

Constructor Summary
Constructor and Description
InvalidSeq()
Constructs an InvalidSeq object.
InvalidSeq(String reason)
Constructs an InvalidSeq object.
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidSeq

public InvalidSeq()
Constructs an InvalidSeq object.

InvalidSeq

public InvalidSeq(String reason)
Constructs an InvalidSeq object.

Parameters:
reason - a String giving more information regarding the exception.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


InvalidValue (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA.DynAnyPackage
Class InvalidValue

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.CORBA.DynAnyPackage.InvalidValue
All Implemented Interfaces:
Serializable, IDLEntity
public final class InvalidValue
extends UserException

Constructor Summary
Constructor and Description
InvalidValue()
Constructs an InvalidValue object.
InvalidValue(String reason)
Constructs an InvalidValue object.
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidValue

public InvalidValue()
Constructs an InvalidValue object.

InvalidValue

public InvalidValue(String reason)
Constructs an InvalidValue object.

Parameters:
reason - a String giving more information regarding the exception.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


org.omg.CORBA.DynAnyPackage (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.CORBA.DynAnyPackage

Provides the exceptions used with the DynAny interface (InvalidValue, Invalid, InvalidSeq, and TypeMismatch).

See:
Description

Exception Summary
Exception | Description
Invalid | Invalid is thrown by dynamic any operations when a bad DynAny or Any is passed as a parameter.
InvalidSeq | The InvalidSeq exception is thrown by all operations on dynamic anys that take a sequence (Java array) as an argument, when that sequence is invalid.
InvalidValue |
TypeMismatch | TypeMismatch is thrown by dynamic any accessor methods when type of the actual contents do not match what is trying to be accessed.

Package org.omg.CORBA.DynAnyPackage Description

Provides the exceptions used with the DynAny interface (InvalidValue, Invalid, InvalidSeq, and TypeMismatch).

Since:
JDK1.2
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


TypeMismatch (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.CORBA.DynAnyPackage
Class TypeMismatch

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.CORBA.DynAnyPackage.TypeMismatch
All Implemented Interfaces:
Serializable, IDLEntity
public final class TypeMismatch
extends UserException

TypeMismatch is thrown by dynamic any accessor methods when type of the actual contents do not match what is trying to be accessed.

Constructor Summary
Constructor and Description
TypeMismatch()
Constructs a TypeMismatch object.
TypeMismatch(String reason)
Constructs a TypeMismatch object.
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TypeMismatch

public TypeMismatch()
Constructs a TypeMismatch object.

TypeMismatch

public TypeMismatch(String reason)
Constructs a TypeMismatch object.

Parameters:
reason - a String giving more information regarding the exception.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


InconsistentTypeCode (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.CORBA.ORBPackage
Class InconsistentTypeCode

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.CORBA.ORBPackage.InconsistentTypeCode
All Implemented Interfaces:
Serializable, IDLEntity
public final class InconsistentTypeCode
extends UserException

InconsistentTypeCode is thrown when an attempt is made to create a dynamic any with a type code that does not match the particular subclass of DynAny.

Constructor Summary
Constructor and Description
InconsistentTypeCode()
Constructs an InconsistentTypeCode user exception with no reason message.
InconsistentTypeCode(String reason)
Constructs an InconsistentTypeCode user exception with the specified reason message.
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InconsistentTypeCode

public InconsistentTypeCode()
Constructs an InconsistentTypeCode user exception with no reason message.

InconsistentTypeCode

public InconsistentTypeCode(String reason)
Constructs an InconsistentTypeCode user exception with the specified reason message.

Parameters:
reason - The String containing a reason message
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


InvalidName (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.CORBA.ORBPackage
Class InvalidName

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.CORBA.ORBPackage.InvalidName
All Implemented Interfaces:
Serializable, IDLEntity
public final class InvalidName
extends UserException

The InvalidName exception is raised when ORB.resolve_initial_references is passed a name for which there is no initial reference.

Since:
JDK1.2
See Also:
ORB.resolve_initial_references(String)

Constructor Summary
Constructor and Description
InvalidName()
Constructs an InvalidName exception with no reason message.
InvalidName(String reason)
Constructs an InvalidName exception with the specified reason message.
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidName

public InvalidName()
Constructs an InvalidName exception with no reason message.

InvalidName

public InvalidName(String reason)
Constructs an InvalidName exception with the specified reason message.

Parameters:
reason - the String containing a reason message
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.omg.CORBA.ORBPackage (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.CORBA.ORBPackage

Provides the exception InvalidName, which is thrown by the method ORB.resolve_initial_references and the exception InconsistentTypeCode, which is thrown by the Dynamic Any creation methods in the ORB class.

See:
Description

Exception Summary
Exception | Description
InconsistentTypeCode | InconsistentTypeCode is thrown when an attempt is made to create a dynamic any with a type code that does not match the particular subclass of DynAny.
InvalidName | The InvalidName exception is raised when ORB.resolve_initial_references is passed a name for which there is no initial reference.

Package org.omg.CORBA.ORBPackage Description

Provides the exception InvalidName, which is thrown by the method ORB.resolve_initial_references and the exception InconsistentTypeCode, which is thrown by the Dynamic Any creation methods in the ORB class.

Related Documentation

For an overview, please see:
  • comments on the CORBA package

Since:
JDK1.2
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


ApplicationException (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.CORBA.portable
Class ApplicationException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.portable.ApplicationException
All Implemented Interfaces:
Serializable
public class ApplicationException
extends Exception

This class is used for reporting application level exceptions between ORBs and stubs.

Constructor Summary
Constructor and Description
ApplicationException(String id, InputStream ins)
Constructs an ApplicationException from the CORBA repository ID of the exception and an input stream from which the exception data can be read as its parameters.
Method Summary
Modifier and Type | Method and Description
String | getId() Returns the CORBA repository ID of the exception without removing it from the exceptions input stream.
InputStream | getInputStream() Returns the input stream from which the exception data can be read as its parameters.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ApplicationException

public ApplicationException(String id,
                            InputStream ins)
Constructs an ApplicationException from the CORBA repository ID of the exception and an input stream from which the exception data can be read as its parameters.

Parameters:
id - the repository id of the user exception
ins - the stream which contains the user exception data
Method Detail

getId

public String getId()
Returns the CORBA repository ID of the exception without removing it from the exceptions input stream.

Returns:
The CORBA repository ID of this exception

getInputStream

public InputStream getInputStream()
Returns the input stream from which the exception data can be read as its parameters.

Returns:
The stream which contains the user exception data
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BoxedValueHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA.portable
Interface BoxedValueHelper

All Known Implementing Classes:
StringValueHelper, WStringValueHelper
public interface BoxedValueHelper

Method Summary
Modifier and Type | Method and Description
String | get_id()
Serializable | read_value(InputStream is)
void | write_value(OutputStream os, Serializable value)

Method Detail

read_value

Serializable read_value(InputStream is)

write_value

void write_value(OutputStream os,
                 Serializable value)

get_id

String get_id()
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


CustomValue (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA.portable
Interface CustomValue

All Superinterfaces:
CustomMarshal, IDLEntity, Serializable, ValueBase
public interface CustomValue
extends ValueBase, CustomMarshal

An extension of ValueBase that is implemented by custom value types.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.CORBA.portable.ValueBase
_truncatable_ids
Methods inherited from interface org.omg.CORBA.CustomMarshal
marshal, unmarshal

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


Delegate (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA.portable
Class Delegate

java.lang.Object
    extended by  org.omg.CORBA.portable.Delegate
Direct Known Subclasses:
Delegate
public abstract class Delegate
extends Object

Specifies a portable API for ORB-vendor-specific implementation of the org.omg.CORBA.Object methods. Each stub (proxy) contains a delegate object, to which all org.omg.CORBA.Object methods are forwarded. This allows a stub generated by one vendor's ORB to work with the delegate from another vendor's ORB.

See Also:
Object

Constructor Summary
Constructor and Description
Delegate()
Method Summary
Modifier and Type Method and Description
abstract  Request create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result)
Creates a Request instance for use in the Dynamic Invocation Interface.
abstract  Request create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
Creates a Request instance for use in the Dynamic Invocation Interface.
abstract  Object duplicate(Object obj)
Returns a duplicate of the object reference provided.
 boolean equals(Object self, Object obj)
Provides the implementation to override the equals(java.lang.Object obj) method of the delegating CORBA object.
 DomainManager[] get_domain_managers(Object self)
Retrieves the DomainManagers of this object.
abstract  Object get_interface_def(Object self)
Return an InterfaceDef for the object reference provided.
 Policy get_policy(Object self, int policy_type)
Returns the Policy object of the specified type which applies to this object.
abstract  int hash(Object obj, int max)
Returns an ORB-internal identifier (hashcode) for this object reference.
 int hashCode(Object self)
Provides the implementation to override the hashCode() method of the delegating CORBA object.
 InputStream invoke(Object self, OutputStream output)
invoke is called by a stub to invoke an operation.
abstract  boolean is_a(Object obj, String repository_id)
Checks if the object reference is an instance of the given interface.
abstract  boolean is_equivalent(Object obj, Object other)
Determines if the two object references are equivalent.
 boolean is_local(Object self)
Returns true if this object is implemented by a local servant.
abstract  boolean non_existent(Object obj)
Determines whether the server object for the object reference has been destroyed.
 ORB orb(Object obj)
Provides a reference to the orb associated with its parameter.
abstract  void release(Object obj)
Releases resources associated with the object reference provided.
 void releaseReply(Object self, InputStream input)
releaseReply may optionally be called by a stub to release a reply stream back to the ORB when the unmarshaling has completed.
abstract  Request request(Object obj, String operation)
Creates a Request instance for use in the Dynamic Invocation Interface.
 OutputStream request(Object self, String operation, boolean responseExpected)
request is called by a stub to obtain an OutputStream for marshaling arguments.
 void servant_postinvoke(Object self, ServantObject servant)
servant_postinvoke() is invoked by the local stub after the operation has been invoked on the local servant.
 ServantObject servant_preinvoke(Object self, String operation, Class expectedType)
Returns a Java reference to the servant which should be used for this request.
 Object set_policy_override(Object self, Policy[] policies, SetOverrideType set_add)
Associates the policies passed in with a newly created object reference that it returns.
 String toString(Object self)
Provides the implementation to override the toString() method of the delegating CORBA object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Delegate

public Delegate()
Method Detail

get_interface_def

public abstract Object get_interface_def(Object self)
Return an InterfaceDef for the object reference provided.

Parameters:
self - The object reference whose InterfaceDef needs to be returned
Returns:
the InterfaceDef

duplicate

public abstract Object duplicate(Object obj)
Returns a duplicate of the object reference provided.

Parameters:
obj - The object reference whose duplicate needs to be returned
Returns:
the duplicate object reference

release

public abstract void release(Object obj)
Releases resources associated with the object reference provided.

Parameters:
obj - The object reference whose resources need to be released

is_a

public abstract boolean is_a(Object obj,
                             String repository_id)
Checks if the object reference is an instance of the given interface.

Parameters:
obj - The object reference to be checked.
repository_id - The repository identifier of the interface to check against.
Returns:
true if the object reference supports the interface

non_existent

public abstract boolean non_existent(Object obj)
Determines whether the server object for the object reference has been destroyed.

Parameters:
obj - The object reference which delegated to this delegate.
Returns:
true if the ORB knows authoritatively that the server object does not exist, false otherwise

is_equivalent

public abstract boolean is_equivalent(Object obj,
                                      Object other)
Determines if the two object references are equivalent.

Parameters:
obj - The object reference which delegated to this delegate.
other - The object reference to check equivalence against.
Returns:
true if the objects are CORBA-equivalent.

hash

public abstract int hash(Object obj,
                         int max)
Returns an ORB-internal identifier (hashcode) for this object reference.

Parameters:
obj - The object reference which delegated to this delegate.
max - specifies an upper bound on the hash value returned by the ORB.
Returns:
ORB-internal hash identifier for object reference

request

public abstract Request request(Object obj,
                                String operation)
Creates a Request instance for use in the Dynamic Invocation Interface.

Parameters:
obj - The object reference which delegated to this delegate.
operation - The name of the operation to be invoked using the Request instance.
Returns:
the created Request instance

create_request

public abstract Request create_request(Object obj,
                                       Context ctx,
                                       String operation,
                                       NVList arg_list,
                                       NamedValue result)
Creates a Request instance for use in the Dynamic Invocation Interface.

Parameters:
obj - The object reference which delegated to this delegate.
ctx - The context to be used.
operation - The name of the operation to be invoked.
arg_list - The arguments to the operation in the form of an NVList.
result - A container for the result as a NamedValue.
Returns:
The created Request object.

create_request

public abstract Request create_request(Object obj,
                                       Context ctx,
                                       String operation,
                                       NVList arg_list,
                                       NamedValue result,
                                       ExceptionList exclist,
                                       ContextList ctxlist)
Creates a Request instance for use in the Dynamic Invocation Interface.

Parameters:
obj - The object reference which delegated to this delegate.
ctx - The context to be used.
operation - The name of the operation to be invoked.
arg_list - The arguments to the operation in the form of an NVList.
result - A container for the result as a NamedValue.
exclist - A list of possible exceptions the operation can throw.
ctxlist - A list of context strings that need to be resolved and sent with the Request.
Returns:
The created Request object.

orb

public ORB orb(Object obj)
Provides a reference to the orb associated with its parameter.

Parameters:
obj - the object reference which delegated to this delegate.
Returns:
the associated orb.
See Also:
portable package comments for unimplemented features

get_policy

public Policy get_policy(Object self,
                         int policy_type)
Returns the Policy object of the specified type which applies to this object.

Parameters:
self - The object reference which delegated to this delegate.
policy_type - The type of policy to be obtained.
Returns:
A Policy object of the type specified by the policy_type parameter.
Throws:
BAD_PARAM - raised when the value of policy type is not valid either because the specified type is not supported by this ORB or because a policy object of that type is not associated with this Object.
See Also:
portable package comments for unimplemented features

get_domain_managers

public DomainManager[] get_domain_managers(Object self)
Retrieves the DomainManagers of this object. This allows administration services (and applications) to retrieve the domain managers, and hence the security and other policies applicable to individual objects that are members of the domain.

Parameters:
self - The object reference which delegated to this delegate.
Returns:
The list of immediately enclosing domain managers of this object. At least one domain manager is always returned in the list since by default each object is associated with at least one domain manager at creation.
See Also:
portable package comments for unimplemented features

set_policy_override

public Object set_policy_override(Object self,
                                  Policy[] policies,
                                  SetOverrideType set_add)
Associates the policies passed in with a newly created object reference that it returns. Only certain policies that pertain to the invocation of an operation at the client end can be overridden using this operation. Attempts to override any other policy will result in the raising of the CORBA::NO_PERMISSION exception.

Parameters:
self - The object reference which delegated to this delegate.
policies - A sequence of references to Policy objects.
set_add - Indicates whether these policies should be added onto any otheroverrides that already exist (ADD_OVERRIDE) in the object reference, or they should be added to a clean override free object reference (SET_OVERRIDE).
Returns:
A new object reference with the new policies associated with it.
See Also:
portable package comments for unimplemented features

is_local

public boolean is_local(Object self)
Returns true if this object is implemented by a local servant.

Parameters:
self - The object reference which delegated to this delegate.
Returns:
true only if the servant incarnating this object is located in this Java VM. Return false if the servant is not local or the ORB does not support local stubs for this particular servant. The default behavior of is_local() is to return false.

servant_preinvoke

public ServantObject servant_preinvoke(Object self,
                                       String operation,
                                       Class expectedType)
Returns a Java reference to the servant which should be used for this request. servant_preinvoke() is invoked by a local stub. If a ServantObject object is returned, then its servant field has been set to an object of the expected type (Note: the object may or may not be the actual servant instance). The local stub may cast the servant field to the expected type, and then invoke the operation directly. The ServantRequest object is valid for only one invocation, and cannot be used for more than one invocation.

Parameters:
self - The object reference which delegated to this delegate.
operation - a string containing the operation name. The operation name corresponds to the operation name as it would be encoded in a GIOP request.
expectedType - a Class object representing the expected type of the servant. The expected type is the Class object associated with the operations class of the stub's interface (e.g. A stub for an interface Foo, would pass the Class object for the FooOperations interface).
Returns:
a ServantObject object. The method may return a null value if it does not wish to support this optimization (e.g. due to security, transactions, etc). The method must return null if the servant is not of the expected type.

servant_postinvoke

public void servant_postinvoke(Object self,
                               ServantObject servant)
servant_postinvoke() is invoked by the local stub after the operation has been invoked on the local servant. This method must be called if servant_preinvoke() returned a non-null value, even if an exception was thrown by the servant's method. For this reason, the call to servant_postinvoke() should be placed in a Java finally clause.

Parameters:
self - The object reference which delegated to this delegate.
servant - the instance of the ServantObject returned from the servant_preinvoke() method.

request

public OutputStream request(Object self,
                            String operation,
                            boolean responseExpected)
request is called by a stub to obtain an OutputStream for marshaling arguments. The stub must supply the operation name, and indicate if a response is expected (i.e is this a oneway call).

Parameters:
self - The object reference which delegated to this delegate.
operation - a string containing the operation name. The operation name corresponds to the operation name as it would be encoded in a GIOP request.
responseExpected - false if the operation is a one way operation, and true otherwise.
Returns:
OutputStream the OutputStream into which request arguments can be marshaled.
See Also:
portable package comments for unimplemented features

invoke

public InputStream invoke(Object self,
                          OutputStream output)
                   throws ApplicationException,
                          RemarshalException
invoke is called by a stub to invoke an operation. The stub provides an OutputStream that was previously returned by a request() call. invoke returns an InputStream which contains the marshaled reply. If an exception occurs, invoke may throw an ApplicationException object which contains an InputStream from which the user exception state may be unmarshaled.

Parameters:
self - The object reference which delegated to this delegate.
output - the OutputStream which contains marshaled arguments
Returns:
input the InputStream from which reply parameters can be unmarshaled.
Throws:
ApplicationException - thrown when implementation throws (upon invocation) an exception defined as part of its remote method definition.
RemarshalException - thrown when remarshalling fails.
See Also:
portable package comments for unimplemented features

releaseReply

public void releaseReply(Object self,
                         InputStream input)
releaseReply may optionally be called by a stub to release a reply stream back to the ORB when the unmarshaling has completed. The stub passes the InputStream returned by invoke() or ApplicationException.getInputStream(). A null value may also be passed to releaseReply, in which case the method is a noop.

Parameters:
self - The object reference which delegated to this delegate.
input - the InputStream returned from invoke().
See Also:
portable package comments for unimplemented features

toString

public String toString(Object self)
Provides the implementation to override the toString() method of the delegating CORBA object.

Parameters:
self - the object reference that delegated to this delegate
Returns:
a String object that represents the object reference that delegated to this Delegate object

hashCode

public int hashCode(Object self)
Provides the implementation to override the hashCode() method of the delegating CORBA object.

Parameters:
self - the object reference that delegated to this delegate
Returns:
an int that represents the hashcode for the object reference that delegated to this Delegate object

equals

public boolean equals(Object self,
                      Object obj)
Provides the implementation to override the equals(java.lang.Object obj) method of the delegating CORBA object.

Parameters:
self - the object reference that delegated to this delegate
obj - the Object with which to compare
Returns:
true if obj equals self; false otherwise
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


IDLEntity (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA.portable
Interface IDLEntity

All Superinterfaces:
Serializable
All Known Subinterfaces:
AdapterActivator, BindingIterator, ClientRequestInfo, ClientRequestInterceptor, Codec, CodecFactory, Current, Current, Current, CustomValue, DataInputStream, DataOutputStream, DomainManager, DynAny, DynAnyFactory, DynArray, DynEnum, DynFixed, DynSequence, DynStruct, DynUnion, DynValue, DynValueBox, DynValueCommon, IdAssignmentPolicy, IDLType, IdUniquenessPolicy, ImplicitActivationPolicy, Interceptor, IORInfo, IORInterceptor, IORInterceptor_3_0, IRObject, LifespanPolicy, NamingContext, NamingContextExt, ObjectReferenceFactory, ObjectReferenceTemplate, ORBInitializer, ORBInitInfo, POA, POAManager, Policy, PolicyFactory, RequestInfo, RequestProcessingPolicy, RunTime, ServantActivator, ServantLocator, ServantManager, ServantRetentionPolicy, ServerRequestInfo, ServerRequestInterceptor, StreamableValue, ThreadPolicy, ValueBase
All Known Implementing Classes:
_BindingIteratorImplBase, _BindingIteratorStub, _DynAnyFactoryStub, _DynAnyStub, _DynArrayStub, _DynEnumStub, _DynFixedStub, _DynSequenceStub, _DynStructStub, _DynUnionStub, _DynValueStub, _IDLTypeStub, _NamingContextExtStub, _NamingContextImplBase, _NamingContextStub, _PolicyStub, _ServantActivatorStub, _ServantLocatorStub, AdapterAlreadyExists, AdapterInactive, AdapterNonExistent, AlreadyBound, Any, BadKind, Binding, BindingType, Bounds, Bounds, CannotProceed, CompletionStatus, DefinitionKind, DuplicateName, Encoding, FormatMismatch, ForwardRequest, ForwardRequest, IdAssignmentPolicyValue, IdUniquenessPolicyValue, ImplicitActivationPolicyValue, InconsistentTypeCode, InconsistentTypeCode, Invalid, InvalidAddress, InvalidName, InvalidName, InvalidName, InvalidPolicy, InvalidSeq, InvalidSlot, InvalidTypeForEncoding, InvalidValue, InvalidValue, IOR, LifespanPolicyValue, NameComponent, NameDynAnyPair, NameValuePair, NameValuePair, NoContext, NoServant, NotEmpty, NotFound, NotFoundReason, ObjectAlreadyActive, ObjectNotActive, Parameter, ParameterMode, PolicyError, RequestProcessingPolicyValue, ServantAlreadyActive, ServantNotActive, ServantRetentionPolicyValue, ServiceContext, ServiceDetail, ServiceInformation, SetOverrideType, State, StructMember, TaggedComponent, TaggedProfile, ThreadPolicyValue, TypeCode, TypeMismatch, TypeMismatch, TypeMismatch, UnionMember, UnknownEncoding, UnknownUserException, UserException, ValueMember, WrongAdapter, WrongPolicy, WrongTransaction
public interface IDLEntity
extends Serializable

An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class. RMI IIOP serialization looks for such a marker to perform marshalling/unmarshalling.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


IndirectionException (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA.portable
Class IndirectionException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.omg.CORBA.SystemException
                    extended by  org.omg.CORBA.portable.IndirectionException
All Implemented Interfaces:
Serializable
public class IndirectionException
extends SystemException

The Indirection exception is a Java specific system exception. It is thrown when the ORB's input stream is called to demarshal a value that is encoded as an indirection that is in the process of being demarshaled. This can occur when the ORB input stream calls the ValueHandler to demarshal an RMI value whose state contains a recursive reference to itself. Because the top-level ValueHandler.read_value() call has not yet returned a value, the ORB input stream's indirection table does not contain an entry for an object with the stream offset specified by the indirection tag. The stream offset is returned in the exception's offset field.

See Also:
InputStream, OutputStream

Field Summary
Modifier and Type | Field and Description
int | offset Points to the stream's offset.
Fields inherited from class org.omg.CORBA.SystemException
completed, minor
Constructor Summary
Constructor and Description
IndirectionException(int offset)
Creates an IndirectionException with the right offset value.
Method Summary
Modifier and Type Method and Description
Methods inherited from class org.omg.CORBA.SystemException
toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

offset

public int offset
Points to the stream's offset.

Constructor Detail

IndirectionException

public IndirectionException(int offset)
Creates an IndirectionException with the right offset value. The stream offset is returned in the exception's offset field. This exception is constructed and thrown during reading recursively defined values off of a stream.

Parameters:
offset - the stream offset where recursion is detected.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


InputStream (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA.portable
Class InputStream

java.lang.Object
    extended by  java.io.InputStream
        extended by  org.omg.CORBA.portable.InputStream
All Implemented Interfaces:
Closeable
Direct Known Subclasses:
InputStream
public abstract class InputStream
extends InputStream

InputStream is the Java API for reading IDL types from CDR marshal streams. These methods are used by the ORB to unmarshal IDL types as well as to extract IDL types out of Anys. The _array versions of the methods can be directly used to read sequences and arrays of IDL types.

Since:
JDK1.2

Constructor Summary
Constructor and Description
InputStream()
Method Summary
Modifier and Type | Method and Description
ORB | orb() Returns the ORB that created this InputStream.
abstract Any | read_any() Reads an Any from this input stream.
abstract void | read_boolean_array(boolean[] value, int offset, int length) Reads an array of booleans from this input stream.
abstract boolean | read_boolean() Reads a boolean value from this input stream.
abstract void | read_char_array(char[] value, int offset, int length) Reads an array of chars from this input stream.
abstract char | read_char() Reads a char value from this input stream.
Context | read_Context() Reads a CORBA context from the stream.
abstract void | read_double_array(double[] value, int offset, int length) Reads an array of doubles from this input stream.
abstract double | read_double() Reads a double value from this input stream.
BigDecimal | read_fixed() Reads a BigDecimal number.
abstract void | read_float_array(float[] value, int offset, int length) Reads an array of floats from this input stream.
abstract float | read_float() Reads a float value from this input stream.
abstract void | read_long_array(int[] value, int offset, int length) Reads an array of CORBA longs (that is, Java ints) from this input stream.
abstract int | read_long() Reads a CORBA long (that is, Java int) value from this input stream.
abstract void | read_longlong_array(long[] value, int offset, int length) Reads an array of CORBA longlongs (that is, Java longs) from this input stream.
abstract long | read_longlong() Reads a CORBA longlong (that is, Java long) value from this input stream.
abstract Object | read_Object() Reads a CORBA object from this input stream.
Object | read_Object(Class clz) Unmarshals an object and returns a CORBA Object, which is an instance of the class passed as its argument.
abstract void | read_octet_array(byte[] value, int offset, int length) Reads an array of octets (that is, bytes) from this input stream.
abstract byte | read_octet() Reads an octet (that is, a byte) value from this input stream.
Principal | read_Principal() Deprecated. Deprecated by CORBA 2.2.
abstract void | read_short_array(short[] value, int offset, int length) Reads an array of shorts from this input stream.
abstract short | read_short() Reads a short value from this input stream.
abstract String | read_string() Reads a string value from this input stream.
abstract TypeCode | read_TypeCode() Reads a TypeCode from this input stream.
abstract void | read_ulong_array(int[] value, int offset, int length) Reads an array of unsigned CORBA longs (that is, Java ints) from this input stream.
abstract int | read_ulong() Reads an unsigned CORBA long (that is, Java int) value from this input stream.
abstract void | read_ulonglong_array(long[] value, int offset, int length) Reads an array of unsigned CORBA longlongs (that is, Java longs) from this input stream.
abstract long | read_ulonglong() Reads a CORBA unsigned longlong (that is, Java long) value from this input stream.
abstract void | read_ushort_array(short[] value, int offset, int length) Reads an array of unsigned shorts from this input stream.
abstract short | read_ushort() Reads a unsigned short value from this input stream.
abstract void | read_wchar_array(char[] value, int offset, int length) Reads an array of wide chars from this input stream.
abstract char | read_wchar() Reads a wide char value from this input stream.
abstract String | read_wstring() Reads a wide string value from this input stream.
int | read() Reads the next byte of data from the input stream.
Methods inherited from class java.io.InputStream
available, close, mark, markSupported, read, read, reset, skip
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InputStream

public InputStream()
Method Detail

read_boolean

public abstract boolean read_boolean()
Reads a boolean value from this input stream.

Returns:
the boolean value read from this input stream

read_char

public abstract char read_char()
Reads a char value from this input stream.

Returns:
the char value read from this input stream

read_wchar

public abstract char read_wchar()
Reads a wide char value from this input stream.

Returns:
the char value read from this input stream

read_octet

public abstract byte read_octet()
Reads an octet (that is, a byte) value from this input stream.

Returns:
the byte value read from this input stream

read_short

public abstract short read_short()
Reads a short value from this input stream.

Returns:
the short value read from this input stream

read_ushort

public abstract short read_ushort()
Reads a unsigned short value from this input stream.

Returns:
the short value read from this input stream

read_long

public abstract int read_long()
Reads a CORBA long (that is, Java int) value from this input stream.

Returns:
the int value read from this input stream

read_ulong

public abstract int read_ulong()
Reads an unsigned CORBA long (that is, Java int) value from this input stream.

Returns:
the int value read from this input stream

read_longlong

public abstract long read_longlong()
Reads a CORBA longlong (that is, Java long) value from this input stream.

Returns:
the long value read from this input stream

read_ulonglong

public abstract long read_ulonglong()
Reads a CORBA unsigned longlong (that is, Java long) value from this input stream.

Returns:
the long value read from this input stream

read_float

public abstract float read_float()
Reads a float value from this input stream.

Returns:
the float value read from this input stream

read_double

public abstract double read_double()
Reads a double value from this input stream.

Returns:
the double value read from this input stream

read_string

public abstract String read_string()
Reads a string value from this input stream.

Returns:
the String value read from this input stream

read_wstring

public abstract String read_wstring()
Reads a wide string value from this input stream.

Returns:
the String value read from this input stream

read_boolean_array

public abstract void read_boolean_array(boolean[] value,
                                        int offset,
                                        int length)
Reads an array of booleans from this input stream.

Parameters:
value - returned array of booleans.
offset - offset on the stream.
length - length of buffer to read.

read_char_array

public abstract void read_char_array(char[] value,
                                     int offset,
                                     int length)
Reads an array of chars from this input stream.

Parameters:
value - returned array of chars.
offset - offset on the stream.
length - length of buffer to read.

read_wchar_array

public abstract void read_wchar_array(char[] value,
                                      int offset,
                                      int length)
Reads an array of wide chars from this input stream.

Parameters:
value - returned array of wide chars.
offset - offset on the stream.
length - length of buffer to read.

read_octet_array

public abstract void read_octet_array(byte[] value,
                                      int offset,
                                      int length)
Reads an array of octets (that is, bytes) from this input stream.

Parameters:
value - returned array of octets (that is, bytes).
offset - offset on the stream.
length - length of buffer to read.

read_short_array

public abstract void read_short_array(short[] value,
                                      int offset,
                                      int length)
Reads an array of shorts from this input stream.

Parameters:
value - returned array of shorts.
offset - offset on the stream.
length - length of buffer to read.

read_ushort_array

public abstract void read_ushort_array(short[] value,
                                       int offset,
                                       int length)
Reads an array of unsigned shorts from this input stream.

Parameters:
value - returned array of shorts.
offset - offset on the stream.
length - length of buffer to read.

read_long_array

public abstract void read_long_array(int[] value,
                                     int offset,
                                     int length)
Reads an array of CORBA longs (that is, Java ints) from this input stream.

Parameters:
value - returned array of CORBA longs (that is, Java ints).
offset - offset on the stream.
length - length of buffer to read.

read_ulong_array

public abstract void read_ulong_array(int[] value,
                                      int offset,
                                      int length)
Reads an array of unsigned CORBA longs (that is, Java ints) from this input stream.

Parameters:
value - returned array of CORBA longs (that is, Java ints).
offset - offset on the stream.
length - length of buffer to read.

read_longlong_array

public abstract void read_longlong_array(long[] value,
                                         int offset,
                                         int length)
Reads an array of CORBA longlongs (that is, Java longs) from this input stream.

Parameters:
value - returned array of CORBA longs (that is, Java longs).
offset - offset on the stream.
length - length of buffer to read.

read_ulonglong_array

public abstract void read_ulonglong_array(long[] value,
                                          int offset,
                                          int length)
Reads an array of unsigned CORBA longlongs (that is, Java longs) from this input stream.

Parameters:
value - returned array of CORBA longs (that is, Java longs).
offset - offset on the stream.
length - length of buffer to read.

read_float_array

public abstract void read_float_array(float[] value,
                                      int offset,
                                      int length)
Reads an array of floats from this input stream.

Parameters:
value - returned array of floats.
offset - offset on the stream.
length - length of buffer to read.

read_double_array

public abstract void read_double_array(double[] value,
                                       int offset,
                                       int length)
Reads an array of doubles from this input stream.

Parameters:
value - returned array of doubles.
offset - offset on the stream.
length - length of buffer to read.

read_Object

public abstract Object read_Object()
Reads a CORBA object from this input stream.

Returns:
the Object instance read from this input stream.

read_TypeCode

public abstract TypeCode read_TypeCode()
Reads a TypeCode from this input stream.

Returns:
the TypeCode instance read from this input stream.

read_any

public abstract Any read_any()
Reads an Any from this input stream.

Returns:
the Any instance read from this input stream.

read_Principal

@Deprecated
public Principal read_Principal()
Deprecated. Deprecated by CORBA 2.2.

Returns principal for invocation.

Returns:
Principal for invocation.

read

public int read()
         throws IOException
Description copied from class: InputStream
Reads the next byte of data from the input stream. The value byte is returned as an int in the range 0 to 255. If no byte is available because the end of the stream has been reached, the value -1 is returned. This method blocks until input data is available, the end of the stream is detected, or an exception is thrown.

A subclass must provide an implementation of this method.

Specified by:
read in class InputStream
Returns:
the next byte of data, or -1 if the end of the stream is reached.
Throws:
IOException - if an I/O error occurs.
See Also:
portable package comments for unimplemented features

read_fixed

public BigDecimal read_fixed()
Reads a BigDecimal number.

Returns:
a java.math.BigDecimal number

read_Context

public Context read_Context()
Reads a CORBA context from the stream.

Returns:
a CORBA context
See Also:
portable package comments for unimplemented features

read_Object

public Object read_Object(Class clz)
Unmarshals an object and returns a CORBA Object, which is an instance of the class passed as its argument. This class is the stub class of the expected type.

Parameters:
clz - The Class object for the stub class which corresponds to the type that is statistically expected, or the Class object for the RMI/IDL interface type that is statistically expected.
Returns:
an Object instance of clz read from this stream
See Also:
portable package comments for unimplemented features

orb

public ORB orb()
Returns the ORB that created this InputStream.

Returns:
the ORB object that created this stream
See Also:
portable package comments for unimplemented features
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


InvokeHandler (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA.portable
Interface InvokeHandler

All Known Subinterfaces:
Tie
All Known Implementing Classes:
BindingIteratorPOA, NamingContextExtPOA, NamingContextPOA, ServantActivatorPOA, ServantLocatorPOA
public interface InvokeHandler

This interface provides a dispatching mechanism for an incoming call. It is invoked by the ORB to dispatch a request to a servant.

Method Summary
Modifier and Type | Method and Description
OutputStream | _invoke(String method, InputStream input, ResponseHandler handler) Invoked by the ORB to dispatch a request to the servant.

Method Detail

_invoke

OutputStream _invoke(String method,
                     InputStream input,
                     ResponseHandler handler)
                     throws SystemException
Invoked by the ORB to dispatch a request to the servant. ORB passes the method name, an InputStream containing the marshalled arguments, and a ResponseHandler which the servant uses to construct a proper reply. Only CORBA SystemException may be thrown by this method. The method must return an OutputStream created by the ResponseHandler which contains the marshalled reply. A servant must not retain a reference to the ResponseHandler beyond the lifetime of a method invocation. Servant behaviour is defined as follows:

1. Determine correct method, and unmarshal parameters from InputStream.

2. Invoke method implementation.

3. If no user exception, create a normal reply using ResponseHandler.

4. If user exception occurred, create exception reply using ResponseHandler.

5. Marshal reply into OutputStream returned by ResponseHandler.

6. Return OutputStream to ORB.

Parameters:
method - The method name.
input - The InputStream containing the marshalled arguments.
handler - The ResponseHandler which the servant uses to construct a proper reply
Returns:
The OutputStream created by the ResponseHandler which contains the marshalled reply
Throws:
SystemException - is thrown when invocation fails due to a CORBA system exception.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ObjectImpl (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA.portable
Class ObjectImpl

java.lang.Object
    extended by  org.omg.CORBA.portable.ObjectImpl
All Implemented Interfaces:
Object
Direct Known Subclasses:
_BindingIteratorStub, _DynAnyFactoryStub, _DynAnyStub, _DynArrayStub, _DynEnumStub, _DynFixedStub, _DynSequenceStub, _DynStructStub, _DynUnionStub, _DynValueStub, _IDLTypeStub, _NamingContextExtStub, _NamingContextStub, _PolicyStub, _ServantActivatorStub, _ServantLocatorStub, DynamicImplementation, ObjectImpl
public abstract class ObjectImpl
extends Object
implements Object

The common base class for all stub classes; provides default implementations of the org.omg.CORBA.Object methods. All method implementations are forwarded to a Delegate object stored in the ObjectImpl instance. ObjectImpl allows for portable stubs because the Delegate can be implemented by a different vendor-specific ORB.

Constructor Summary
Constructor and Description
ObjectImpl()
Method Summary
Modifier and Type | Method and Description
Request | _create_request(Context ctx, String operation, NVList arg_list, NamedValue result) Creates a Request object that contains the given context, method, argument list, and container for the result.
Request | _create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) Creates a Request object that contains the given context, method, argument list, container for the result, exceptions, and list of property names to be used in resolving the context strings.
Object | _duplicate() Returns a duplicate of this ObjectImpl object.
Delegate | _get_delegate() Retrieves the reference to the vendor-specific Delegate object to which this ObjectImpl object delegates all methods invoked on it.
DomainManager[] | _get_domain_managers() Retrieves a list of the domain managers for this ObjectImpl object.
Object | _get_interface_def() Retrieves the interface definition for this ObjectImpl object.
Policy | _get_policy(int policy_type) Retrieves the Policy object for this ObjectImpl object that has the given policy type.
int | _hash(int maximum) Retrieves the hash code that serves as an ORB-internal identifier for this ObjectImpl object.
abstract String[] | _ids() Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
InputStream | _invoke(OutputStream output) Invokes an operation and returns an InputStream object for reading the response.
boolean | _is_a(String repository_id) Checks whether the object identified by the given repository identifier is an ObjectImpl object.
boolean | _is_equivalent(Object that) Checks whether the the given ObjectImpl object is equivalent to this ObjectImpl object.
boolean | _is_local() Checks whether this ObjectImpl object is implemented by a local servant.
boolean | _non_existent() Checks whether the server object for this ObjectImpl object has been destroyed.
ORB | _orb() Returns a reference to the ORB associated with this object and its delegate.
void | _release() Releases the resources associated with this ObjectImpl object.
void | _releaseReply(InputStream input) Releases the given reply stream back to the ORB when unmarshalling has completed after a call to the method _invoke.
Request | _request(String operation) Creates a Request object containing the given method that can be used with the Dynamic Invocation Interface.
OutputStream | _request(String operation, boolean responseExpected) Returns an OutputStream object to use for marshalling the arguments of the given method.
void | _servant_postinvoke(ServantObject servant) Is called by the local stub after it has invoked an operation on the local servant that was previously retrieved from a call to the method _servant_preinvoke.
ServantObject | _servant_preinvoke(String operation, Class expectedType) Returns a Java reference to the local servant that should be used for sending a request for the method specified.
void | _set_delegate(Delegate delegate) Sets the Delegate for this ObjectImpl instance to the given Delegate object.
Object | _set_policy_override(Policy[] policies, SetOverrideType set_add) Sets this ObjectImpl object's override type for the given policies to the given instance of SetOverrideType.
boolean | equals(Object obj) Compares this ObjectImpl object with the given one for equality.
int | hashCode() Returns the hash code for this ObjectImpl object.
String | toString() Returns a String object that represents this ObjectImpl object.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ObjectImpl

public ObjectImpl()
Method Detail

_get_delegate

public Delegate _get_delegate()
Retrieves the reference to the vendor-specific Delegate object to which this ObjectImpl object delegates all methods invoked on it.

Returns:
the Delegate contained in this ObjectImpl instance
Throws:
BAD_OPERATION - if the delegate has not been set
See Also:
_set_delegate(org.omg.CORBA.portable.Delegate)

_set_delegate

public void _set_delegate(Delegate delegate)
Sets the Delegate for this ObjectImpl instance to the given Delegate object. All method invocations on this ObjectImpl object will be forwarded to this delegate.

Parameters:
delegate - the Delegate instance to which all method calls on this ObjectImpl object will be delegated; may be implemented by a third-party ORB
See Also:
_get_delegate()

_ids

public abstract String[] _ids()
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.

Returns:
the array of all repository identifiers supported by this ObjectImpl instance

_duplicate

public Object _duplicate()
Returns a duplicate of this ObjectImpl object.

Specified by:
_duplicate in interface Object
Returns:
an orb.omg.CORBA.Object object that is a duplicate of this object

_release

public void _release()
Releases the resources associated with this ObjectImpl object.

Specified by:
_release in interface Object

_is_a

public boolean _is_a(String repository_id)
Checks whether the object identified by the given repository identifier is an ObjectImpl object.

Specified by:
_is_a in interface Object
Parameters:
repository_id - a String object with the repository identifier to check
Returns:
true if the object identified by the given repository id is an instance of ObjectImpl; false otherwise

_is_equivalent

public boolean _is_equivalent(Object that)
Checks whether the the given ObjectImpl object is equivalent to this ObjectImpl object.

Specified by:
_is_equivalent in interface Object
Parameters:
that - an instance of ObjectImpl to compare with this ObjectImpl object
Returns:
true if the given object is equivalent to this ObjectImpl object; false otherwise

_non_existent

public boolean _non_existent()
Checks whether the server object for this ObjectImpl object has been destroyed.

Specified by:
_non_existent in interface Object
Returns:
true if the ORB knows authoritatively that the server object does not exist; false otherwise

_hash

public int _hash(int maximum)
Retrieves the hash code that serves as an ORB-internal identifier for this ObjectImpl object.

Specified by:
_hash in interface Object
Parameters:
maximum - an int indicating the upper bound on the hash value returned by the ORB
Returns:
an int representing the hash code for this ObjectImpl object

_request

public Request _request(String operation)
Creates a Request object containing the given method that can be used with the Dynamic Invocation Interface.

Specified by:
_request in interface Object
Parameters:
operation - the method to be invoked by the new Request object
Returns:
a new Request object initialized with the given method

_create_request

public Request _create_request(Context ctx,
                               String operation,
                               NVList arg_list,
                               NamedValue result)
Creates a Request object that contains the given context, method, argument list, and container for the result.

Specified by:
_create_request in interface Object
Parameters:
ctx - the Context for the request
operation - the method that the new Request object will invoke
arg_list - the arguments for the method; an NVList in which each argument is a NamedValue object
result - a NamedValue object to be used for returning the result of executing the request's method
Returns:
a new Request object initialized with the given context, method, argument list, and container for the return value
See Also:
Request, NVList, NamedValue

_create_request

public Request _create_request(Context ctx,
                               String operation,
                               NVList arg_list,
                               NamedValue result,
                               ExceptionList exceptions,
                               ContextList contexts)
Creates a Request object that contains the given context, method, argument list, container for the result, exceptions, and list of property names to be used in resolving the context strings. This Request object is for use in the Dynamic Invocation Interface.

Specified by:
_create_request in interface Object
Parameters:
ctx - the Context object that contains the context strings that must be resolved before they are sent along with the request
operation - the method that the new Request object will invoke
arg_list - the arguments for the method; an NVList in which each argument is a NamedValue object
result - a NamedValue object to be used for returning the result of executing the request's method
exceptions - a list of the exceptions that the given method throws
contexts - a list of the properties that are needed to resolve the contexts in ctx; the strings in contexts are used as arguments to the method Context.get_values, which returns the value associated with the given property
Returns:
a new Request object initialized with the given context strings to resolve, method, argument list, container for the result, exceptions, and list of property names to be used in resolving the context strings
See Also:
Request, NVList, NamedValue, ExceptionList, ContextList

_get_interface_def

public Object _get_interface_def()
Retrieves the interface definition for this ObjectImpl object.

Specified by:
_get_interface_def in interface Object
Returns:
the org.omg.CORBA.Object instance that is the interface definition for this ObjectImpl object

_orb

public ORB _orb()
Returns a reference to the ORB associated with this object and its delegate. This is the ORB object that created the delegate.

Returns:
the ORB instance that created the Delegate object contained in this ObjectImpl object

_get_policy

public Policy _get_policy(int policy_type)
Retrieves the Policy object for this ObjectImpl object that has the given policy type.

Specified by:
_get_policy in interface Object
Parameters:
policy_type - an int indicating the policy type
Returns:
the Policy object that is the specified policy type and that applies to this ObjectImpl object
See Also:
PolicyOperations.policy_type()

_get_domain_managers

public DomainManager[] _get_domain_managers()
Retrieves a list of the domain managers for this ObjectImpl object.

Specified by:
_get_domain_managers in interface Object
Returns:
an array containing the DomainManager objects for this instance of ObjectImpl

_set_policy_override

public Object _set_policy_override(Policy[] policies,
                                   SetOverrideType set_add)
Sets this ObjectImpl object's override type for the given policies to the given instance of SetOverrideType.

Specified by:
_set_policy_override in interface Object
Parameters:
policies - an array of Policy objects with the policies that will replace the current policies or be added to the current policies
set_add - either SetOverrideType.SET_OVERRIDE, indicating that the given policies will replace any existing ones, or SetOverrideType.ADD_OVERRIDE, indicating that the given policies should be added to any existing ones
Returns:
an Object with the given policies replacing or added to its previous policies

_is_local

public boolean _is_local()
Checks whether this ObjectImpl object is implemented by a local servant. If so, local invocation API's may be used.

Returns:
true if this object is implemented by a local servant; false otherwise

_servant_preinvoke

public ServantObject _servant_preinvoke(String operation,
                                        Class expectedType)
Returns a Java reference to the local servant that should be used for sending a request for the method specified. If this ObjectImpl object is a local stub, it will invoke the _servant_preinvoke method before sending a request in order to obtain the ServantObject instance to use.

If a ServantObject object is returned, its servant field has been set to an object of the expected type (Note: the object may or may not be the actual servant instance). The local stub may cast the servant field to the expected type, and then invoke the operation directly. The ServantRequest object is valid for only one invocation and cannot be used for more than one invocation.

Parameters:
operation - a String containing the name of the method to be invoked. This name should correspond to the method name as it would be encoded in a GIOP request.
expectedType - a Class object representing the expected type of the servant that is returned. This expected type is the Class object associated with the operations class for the stub's interface. For example, a stub for an interface Foo would pass the Class object for the FooOperations interface.
Returns:
(1) a ServantObject object, which may or may not be the actual servant instance, or (2) null if (a) the servant is not local or (b) the servant has ceased to be local due to a ForwardRequest from a POA ServantManager
Throws:
BAD_PARAM - if the servant is not the expected type

_servant_postinvoke

public void _servant_postinvoke(ServantObject servant)
Is called by the local stub after it has invoked an operation on the local servant that was previously retrieved from a call to the method _servant_preinvoke. The _servant_postinvoke method must be called if the _servant_preinvoke method returned a non-null value, even if an exception was thrown by the method invoked by the servant. For this reason, the call to the method _servant_postinvoke should be placed in a Java finally clause.

Parameters:
servant - the instance of the ServantObject returned by the _servant_preinvoke method

_request

public OutputStream _request(String operation,
                             boolean responseExpected)
Returns an OutputStream object to use for marshalling the arguments of the given method. This method is called by a stub, which must indicate if a response is expected, that is, whether or not the call is oneway.

Parameters:
operation - a String giving the name of the method.
responseExpected - a boolean -- true if the request is not one way, that is, a response is expected
Returns:
an OutputStream object for dispatching the request

_invoke

public InputStream _invoke(OutputStream output)
                    throws ApplicationException,
                           RemarshalException
Invokes an operation and returns an InputStream object for reading the response. The stub provides the OutputStream object that was previously returned by a call to the _request method. The method specified as an argument to _request when it was called previously is the method that this method invokes.

If an exception occurs, the _invoke method may throw an ApplicationException object that contains an InputStream from which the user exception state may be unmarshalled.

Parameters:
output - an OutputStream object for dispatching the request
Returns:
an InputStream object containing the marshalled response to the method invoked
Throws:
ApplicationException - if the invocation meets application-defined exception
RemarshalException - if the invocation leads to a remarshalling error
See Also:
_request(java.lang.String)

_releaseReply

public void _releaseReply(InputStream input)
Releases the given reply stream back to the ORB when unmarshalling has completed after a call to the method _invoke. Calling this method is optional for the stub.

Parameters:
input - the InputStream object that was returned by the _invoke method or the ApplicationException.getInputStream method; may be null, in which case this method does nothing
See Also:
_invoke(org.omg.CORBA.portable.OutputStream)

toString

public String toString()
Returns a String object that represents this ObjectImpl object.

Overrides:
toString in class Object
Returns:
the String representation of this object

hashCode

public int hashCode()
Returns the hash code for this ObjectImpl object.

Overrides:
hashCode in class Object
Returns:
the hash code for this object
See Also:
Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

equals

public boolean equals(Object obj)
Compares this ObjectImpl object with the given one for equality.

Overrides:
equals in class Object
Parameters:
obj - the object with which to compare this object
Returns:
true if the two objects are equal; false otherwise
See Also:
Object.hashCode(), HashMap
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


OutputStream (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA.portable
Class OutputStream

java.lang.Object
    extended by  java.io.OutputStream
        extended by  org.omg.CORBA.portable.OutputStream
All Implemented Interfaces:
Closeable, Flushable
Direct Known Subclasses:
OutputStream
public abstract class OutputStream
extends OutputStream

OuputStream is the Java API for writing IDL types to CDR marshal streams. These methods are used by the ORB to marshal IDL types as well as to insert IDL types into Anys. The _array versions of the methods can be directly used to write sequences and arrays of IDL types.

Since:
JDK1.2

Constructor Summary
Constructor and Description
OutputStream()
Method Summary
Modifier and Type | Method and Description
abstract InputStream | create_input_stream() Returns an input stream with the same buffer.
ORB | orb() Returns the ORB that created this OutputStream.
abstract void | write_any(Any value) Writes an Any on this output stream.
abstract void | write_boolean_array(boolean[] value, int offset, int length) Writes an array of booleans on this output stream.
abstract void | write_boolean(boolean value) Writes a boolean value to this stream.
abstract void | write_char_array(char[] value, int offset, int length) Writes an array of chars on this output stream.
abstract void | write_char(char value) Writes a char value to this stream.
void | write_Context(Context ctx, ContextList contexts) Writes a CORBA context on this stream.
abstract void | write_double_array(double[] value, int offset, int length) Writes an array of doubles on this output stream.
abstract void | write_double(double value) Writes a double value to this stream.
void | write_fixed(BigDecimal value) Writes a BigDecimal number.
abstract void | write_float_array(float[] value, int offset, int length) Writes an array of floats on this output stream.
abstract void | write_float(float value) Writes a float value to this stream.
abstract void | write_long_array(int[] value, int offset, int length) Writes an array of CORBA longs (i.e.
abstract void | write_long(int value) Writes a CORBA long (i.e.
abstract void | write_longlong_array(long[] value, int offset, int length) Writes an array of CORBA longlongs (i.e.
abstract void | write_longlong(long value) Writes a CORBA longlong (i.e.
abstract void | write_Object(Object value) Writes a CORBA Object on this output stream.
abstract void | write_octet_array(byte[] value, int offset, int length) Writes an array of CORBA octets (bytes) on this output stream.
abstract void | write_octet(byte value) Writes a CORBA octet (i.e.
void | write_Principal(Principal value) Deprecated. Deprecated by CORBA 2.2.
abstract void | write_short_array(short[] value, int offset, int length) Writes an array of shorts on this output stream.
abstract void | write_short(short value) Writes a short value to this stream.
abstract void | write_string(String value) Writes a string value to this stream.
abstract void | write_TypeCode(TypeCode value) Writes a TypeCode on this output stream.
abstract void | write_ulong_array(int[] value, int offset, int length) Writes an array of unsigned CORBA longs (i.e.
abstract void | write_ulong(int value) Writes an unsigned CORBA long (i.e.
abstract void | write_ulonglong_array(long[] value, int offset, int length) Writes an array of unsigned CORBA longlongs (i.e.
abstract void | write_ulonglong(long value) Writes an unsigned CORBA longlong (i.e.
abstract void | write_ushort_array(short[] value, int offset, int length) Writes an array of unsigned shorts on this output stream.
abstract void | write_ushort(short value) Writes an unsigned short value to this stream.
abstract void | write_wchar_array(char[] value, int offset, int length) Writes an array of wide chars on this output stream.
abstract void | write_wchar(char value) Writes a wide char value to this stream.
abstract void | write_wstring(String value) Writes a wide string value to this stream.
void | write(int b) Writes an integer (length of arrays) onto this stream.
Methods inherited from class java.io.OutputStream
close, flush, write, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OutputStream

public OutputStream()
Method Detail

create_input_stream

public abstract InputStream create_input_stream()
Returns an input stream with the same buffer.

Returns:
an input stream with the same buffer.

write_boolean

public abstract void write_boolean(boolean value)
Writes a boolean value to this stream.

Parameters:
value - the value to be written.

write_char

public abstract void write_char(char value)
Writes a char value to this stream.

Parameters:
value - the value to be written.

write_wchar

public abstract void write_wchar(char value)
Writes a wide char value to this stream.

Parameters:
value - the value to be written.

write_octet

public abstract void write_octet(byte value)
Writes a CORBA octet (i.e. byte) value to this stream.

Parameters:
value - the value to be written.

write_short

public abstract void write_short(short value)
Writes a short value to this stream.

Parameters:
value - the value to be written.

write_ushort

public abstract void write_ushort(short value)
Writes an unsigned short value to this stream.

Parameters:
value - the value to be written.

write_long

public abstract void write_long(int value)
Writes a CORBA long (i.e. Java int) value to this stream.

Parameters:
value - the value to be written.

write_ulong

public abstract void write_ulong(int value)
Writes an unsigned CORBA long (i.e. Java int) value to this stream.

Parameters:
value - the value to be written.

write_longlong

public abstract void write_longlong(long value)
Writes a CORBA longlong (i.e. Java long) value to this stream.

Parameters:
value - the value to be written.

write_ulonglong

public abstract void write_ulonglong(long value)
Writes an unsigned CORBA longlong (i.e. Java long) value to this stream.

Parameters:
value - the value to be written.

write_float

public abstract void write_float(float value)
Writes a float value to this stream.

Parameters:
value - the value to be written.

write_double

public abstract void write_double(double value)
Writes a double value to this stream.

Parameters:
value - the value to be written.

write_string

public abstract void write_string(String value)
Writes a string value to this stream.

Parameters:
value - the value to be written.

write_wstring

public abstract void write_wstring(String value)
Writes a wide string value to this stream.

Parameters:
value - the value to be written.

write_boolean_array

public abstract void write_boolean_array(boolean[] value,
                                         int offset,
                                         int length)
Writes an array of booleans on this output stream.

Parameters:
value - the array to be written.
offset - offset on the stream.
length - length of buffer to write.

write_char_array

public abstract void write_char_array(char[] value,
                                      int offset,
                                      int length)
Writes an array of chars on this output stream.

Parameters:
value - the array to be written.
offset - offset on the stream.
length - length of buffer to write.

write_wchar_array

public abstract void write_wchar_array(char[] value,
                                       int offset,
                                       int length)
Writes an array of wide chars on this output stream.

Parameters:
value - the array to be written.
offset - offset on the stream.
length - length of buffer to write.

write_octet_array

public abstract void write_octet_array(byte[] value,
                                       int offset,
                                       int length)
Writes an array of CORBA octets (bytes) on this output stream.

Parameters:
value - the array to be written.
offset - offset on the stream.
length - length of buffer to write.

write_short_array

public abstract void write_short_array(short[] value,
                                       int offset,
                                       int length)
Writes an array of shorts on this output stream.

Parameters:
value - the array to be written.
offset - offset on the stream.
length - length of buffer to write.

write_ushort_array

public abstract void write_ushort_array(short[] value,
                                        int offset,
                                        int length)
Writes an array of unsigned shorts on this output stream.

Parameters:
value - the array to be written.
offset - offset on the stream.
length - length of buffer to write.

write_long_array

public abstract void write_long_array(int[] value,
                                      int offset,
                                      int length)
Writes an array of CORBA longs (i.e. Java ints) on this output stream.

Parameters:
value - the array to be written.
offset - offset on the stream.
length - length of buffer to write.

write_ulong_array

public abstract void write_ulong_array(int[] value,
                                       int offset,
                                       int length)
Writes an array of unsigned CORBA longs (i.e. Java ints) on this output stream.

Parameters:
value - the array to be written.
offset - offset on the stream.
length - length of buffer to write.

write_longlong_array

public abstract void write_longlong_array(long[] value,
                                          int offset,
                                          int length)
Writes an array of CORBA longlongs (i.e. Java longs) on this output stream.

Parameters:
value - the array to be written.
offset - offset on the stream.
length - length of buffer to write.

write_ulonglong_array

public abstract void write_ulonglong_array(long[] value,
                                           int offset,
                                           int length)
Writes an array of unsigned CORBA longlongs (i.e. Java ints) on this output stream.

Parameters:
value - the array to be written.
offset - offset on the stream.
length - length of buffer to write.

write_float_array

public abstract void write_float_array(float[] value,
                                       int offset,
                                       int length)
Writes an array of floats on this output stream.

Parameters:
value - the array to be written.
offset - offset on the stream.
length - length of buffer to write.

write_double_array

public abstract void write_double_array(double[] value,
                                        int offset,
                                        int length)
Writes an array of doubles on this output stream.

Parameters:
value - the array to be written.
offset - offset on the stream.
length - length of buffer to write.

write_Object

public abstract void write_Object(Object value)
Writes a CORBA Object on this output stream.

Parameters:
value - the value to be written.

write_TypeCode

public abstract void write_TypeCode(TypeCode value)
Writes a TypeCode on this output stream.

Parameters:
value - the value to be written.

write_any

public abstract void write_any(Any value)
Writes an Any on this output stream.

Parameters:
value - the value to be written.

write_Principal

@Deprecated
public void write_Principal(Principal value)
Deprecated. Deprecated by CORBA 2.2.

Writes a Principle on this output stream.

Parameters:
value - the value to be written.

write

public void write(int b)
           throws IOException
Writes an integer (length of arrays) onto this stream.

Specified by:
write in class OutputStream
Parameters:
b - the value to be written.
Throws:
IOException - if there is an input/output error
See Also:
portable package comments for unimplemented features

write_fixed

public void write_fixed(BigDecimal value)
Writes a BigDecimal number.

Parameters:
value - a BidDecimal--value to be written.

write_Context

public void write_Context(Context ctx,
                          ContextList contexts)
Writes a CORBA context on this stream. The Context is marshaled as a sequence of strings. Only those Context values specified in the contexts parameter are actually written.

Parameters:
ctx - a CORBA context
contexts - a ContextList object containing the list of contexts to be written
See Also:
portable package comments for unimplemented features

orb

public ORB orb()
Returns the ORB that created this OutputStream.

Returns:
the ORB that created this OutputStream
See Also:
portable package comments for unimplemented features
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


org.omg.CORBA.portable (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.CORBA.portable

Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

See:
Description

Interface Summary
Interface | Description
BoxedValueHelper |
CustomValue | An extension of ValueBase that is implemented by custom value types.
IDLEntity | An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
InvokeHandler | This interface provides a dispatching mechanism for an incoming call.
ResponseHandler | This interface is supplied by an ORB to a servant at invocation time and allows the servant to later retrieve an OutputStream for returning the invocation results.
Streamable | The base class for the Holder classess of all complex IDL types.
StreamableValue | Defines the base type for all non-boxed IDL valuetypes that are not custom marshaled.
ValueBase | The generated Java classes corresponding to valuetype IDL types implement this interface.
ValueFactory | The ValueFactory interface is the native mapping for the IDL type CORBA::ValueFactory.
ValueInputStream | Java to IDL ptc 02-01-12 1.5.1.4 ValueInputStream is used for implementing RMI-IIOP stream format version 2.
ValueOutputStream | Java to IDL ptc 02-01-12 1.5.1.3 ValueOutputStream is used for implementing RMI-IIOP stream format version 2.

Class Summary
Class | Description
Delegate | Specifies a portable API for ORB-vendor-specific implementation of the org.omg.CORBA.Object methods.
InputStream | InputStream is the Java API for reading IDL types from CDR marshal streams.
ObjectImpl | The common base class for all stub classes; provides default implementations of the org.omg.CORBA.Object methods.
OutputStream | OuputStream is the Java API for writing IDL types to CDR marshal streams.
ServantObject | This class is part of the local stub API, the purpose of which is to provide high performance calls for collocated clients and servers (i.e.

Exception Summary
Exception | Description
ApplicationException | This class is used for reporting application level exceptions between ORBs and stubs.
IndirectionException | The Indirection exception is a Java specific system exception.
RemarshalException | This class is used for reporting locate forward exceptions and object forward GIOP messages back to the ORB.
UnknownException | The org.omg.CORBA.portable.UnknownException is used for reporting unknown exceptions between ties and ORBs and between ORBs and stubs.

Package org.omg.CORBA.portable Description

Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB. Stubs and other code, generated either from IDL or interfaces written in the Java programming language, can call into these ORB APIs.

CORBA Features Throwing NO_IMPLEMENT() Exceptions

Some methods throw NO_IMPLEMENT() exceptions by default, but ORB vendors can override them to provide real implementations. The ORB included in Sun's release of the Java[tm] Platform, Standard Edition 6, includes implementations for the following methods.

List of Unimplemented Features in Package org.omg.CORBA.portable

Unimplemented Interfaces in package org.omg.CORBA.portable

  • InvokeHandler
  • ResponseHandler

Unimplemented Methods in package org.omg.CORBA.portable

  • InputStream
    • public int read()
    • public.math.BigDecimal read_fixed()
    • public org.omg.CORBA.Context read_Context()
    • public org.omg.CORBA.Object read_Object(java.lang.Class clz)
    • public org.omg.CORBA.ORB orb()
  • OutputStream
    • public org.omg.CORBA.ORB orb()
    • public void write_Context(org.omg.CORBA.Context ctx, org.omg.CORBA.ContextList contexts)
    • public void write_fixed(java.math.BigDecimal value)
    • public void write(int b)
  • Delegate
    • public void releaseReply(org.omg.CORBA.Object self, InputStream input)
    • public InputStream invoke(org.omg.CORBA.Object self, OutputStream output)
    • public OutputStream request(org.omg.CORBA.Object self, String operation, boolean responseExpected)
    • public org.omg.CORBA.Object set_policy_override(org.omg.CORBA.Object self, org.omg.CORBA.Policy[] policies, org.omg.CORBA.SetOverrideType set_add)
    • public org.omg.CORBA.DomainManager[] get_domain_managers( org.omg.CORBA.Object self)
    • public org.omg.CORBA.Policy get_policy(org.omg.CORBA.Object self, int policy_type)

Since:
JDK1.2
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


RemarshalException (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA.portable
Class RemarshalException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.portable.RemarshalException
All Implemented Interfaces:
Serializable
public final class RemarshalException
extends Exception

This class is used for reporting locate forward exceptions and object forward GIOP messages back to the ORB. In this case the ORB must remarshal the request before trying again. Stubs which use the stream-based model shall catch the RemarshalException which is potentially thrown from the _invoke() method of ObjectImpl. Upon catching the exception, the stub shall immediately remarshal the request by calling _request(), marshalling the arguments (if any), and then calling _invoke(). The stub shall repeat this process until _invoke() returns normally or raises some exception other than RemarshalException.

Constructor Summary
Constructor and Description
RemarshalException()
Constructs a RemarshalException.
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RemarshalException

public RemarshalException()
Constructs a RemarshalException.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ResponseHandler (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA.portable
Interface ResponseHandler

public interface ResponseHandler

This interface is supplied by an ORB to a servant at invocation time and allows the servant to later retrieve an OutputStream for returning the invocation results.

Method Summary
Modifier and Type | Method and Description
OutputStream | createExceptionReply() Called by the servant during a method invocation.
OutputStream | createReply() Called by the servant during a method invocation.

Method Detail

createReply

OutputStream createReply()
Called by the servant during a method invocation. The servant should call this method to create a reply marshal buffer if no exception occurred.

Returns:
an OutputStream suitable for marshalling the reply.
See Also:
portable package comments for unimplemented features

createExceptionReply

OutputStream createExceptionReply()
Called by the servant during a method invocation. The servant should call this method to create a reply marshal buffer if a user exception occurred.

Returns:
an OutputStream suitable for marshalling the exception ID and the user exception body.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServantObject (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA.portable
Class ServantObject

java.lang.Object
    extended by  org.omg.CORBA.portable.ServantObject

public class ServantObject
extends Object

This class is part of the local stub API, the purpose of which is to provide high performance calls for collocated clients and servers (i.e. clients and servers residing in the same Java VM). The local stub API is supported via three additional methods on ObjectImpl and Delegate. ORB vendors may subclass this class to return additional request state that may be required by their implementations.

See Also:
ObjectImpl, Delegate

Field Summary
Modifier and Type | Field and Description
Object | servant The real servant.
Constructor Summary
Constructor and Description
ServantObject()
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

servant

public Object servant
The real servant. The local stub may cast this field to the expected type, and then invoke the operation directly. Note, the object may or may not be the actual servant instance.

Constructor Detail

ServantObject

public ServantObject()
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


Streamable (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA.portable
Interface Streamable

All Known Subinterfaces:
StreamableValue
All Known Implementing Classes:
AlreadyBoundHolder, AnyHolder, AnySeqHolder, BindingHolder, BindingIteratorHolder, BindingListHolder, BindingTypeHolder, BooleanHolder, BooleanSeqHolder, ByteHolder, CannotProceedHolder, CharHolder, CharSeqHolder, CookieHolder, CurrentHolder, DoubleHolder, DoubleSeqHolder, FixedHolder, FloatHolder, FloatSeqHolder, IntHolder, InvalidAddressHolder, InvalidNameHolder, IORHolder, IORInterceptor_3_0Holder, LongHolder, LongLongSeqHolder, LongSeqHolder, MultipleComponentProfileHolder, NameComponentHolder, NameHolder, NamingContextExtHolder, NamingContextHolder, NotEmptyHolder, NotFoundHolder, NotFoundReasonHolder, ObjectHolder, ObjectReferenceFactoryHolder, ObjectReferenceTemplateHolder, ObjectReferenceTemplateSeqHolder, OctetSeqHolder, ParameterModeHolder, PolicyErrorHolder, PolicyHolder, PolicyListHolder, PrincipalHolder, ServiceContextHolder, ServiceContextListHolder, ServiceInformationHolder, ShortHolder, ShortSeqHolder, StringHolder, StringSeqHolder, TaggedComponentHolder, TaggedProfileHolder, TypeCodeHolder, ULongLongSeqHolder, ULongSeqHolder, UnknownUserExceptionHolder, UShortSeqHolder, ValueBaseHolder, WCharSeqHolder, WrongTransactionHolder, WStringSeqHolder
public interface Streamable

The base class for the Holder classess of all complex IDL types. The ORB treats all generated Holders as Streamable to invoke the methods for marshalling and unmarshalling.

Since:
JDK1.2

Method Summary
Modifier and Type | Method and Description
void | _read(InputStream istream) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream ostream) Marshals to ostream the value in the value field of the Holder.

Method Detail

_read

void _read(InputStream istream)
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Parameters:
istream - the InputStream that represents the CDR data from the wire.

_write

void _write(OutputStream ostream)
Marshals to ostream the value in the value field of the Holder.

Parameters:
ostream - the CDR OutputStream

_type

TypeCode _type()
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


StreamableValue (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA.portable
Interface StreamableValue

All Superinterfaces:
IDLEntity, Serializable, Streamable, ValueBase
public interface StreamableValue
extends Streamable, ValueBase

Defines the base type for all non-boxed IDL valuetypes that are not custom marshaled. All value types implement ValueBase either directly or indirectly by implementing either the StreamableValue or CustomValue interface.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.CORBA.portable.Streamable
_read, _type, _write
Methods inherited from interface org.omg.CORBA.portable.ValueBase
_truncatable_ids

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


UnknownException (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA.portable
Class UnknownException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.omg.CORBA.SystemException
                    extended by  org.omg.CORBA.portable.UnknownException
All Implemented Interfaces:
Serializable
public class UnknownException
extends SystemException

The org.omg.CORBA.portable.UnknownException is used for reporting unknown exceptions between ties and ORBs and between ORBs and stubs. It provides a Java representation of an UNKNOWN system exception that has an UnknownExceptionInfo service context. If the CORBA system exception org.omg.CORBA.portable.UnknownException is thrown, then the stub does one of the following: (1) Translates it to org.omg.CORBA.UNKNOWN. (2) Translates it to the nested exception that the UnknownException contains. (3) Passes it on directly to the user.

Field Summary
Modifier and Type | Field and Description
Throwable | originalEx A throwable--the original exception that was wrapped in a CORBA UnknownException.
Fields inherited from class org.omg.CORBA.SystemException
completed, minor
Constructor Summary
Constructor and Description
UnknownException(Throwable ex)
Constructs an UnknownException object.
Method Summary
Modifier and Type Method and Description
Methods inherited from class org.omg.CORBA.SystemException
toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

originalEx

public Throwable originalEx
A throwable--the original exception that was wrapped in a CORBA UnknownException.

Constructor Detail

UnknownException

public UnknownException(Throwable ex)
Constructs an UnknownException object.

Parameters:
ex - a Throwable object--to be wrapped in this exception.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ValueBase (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA.portable
Interface ValueBase

All Superinterfaces:
IDLEntity, Serializable
All Known Subinterfaces:
CustomValue, DataInputStream, DataOutputStream, ObjectReferenceFactory, ObjectReferenceTemplate, StreamableValue
public interface ValueBase
extends IDLEntity

The generated Java classes corresponding to valuetype IDL types implement this interface. In other words, the Java mapping of valuetype objects implement the ValueBase interface. The generated Java class for valuetype's shall provide an implementation of the ValueBase interface for the corresponding value type. For value types that are streamable (i.e. non-custom), the generated Java class shall also provide an implementation for the org.omg.CORBA.portable.Streamable interface. (CORBA::ValueBase is mapped to java.io.Serializable.)

Method Summary
Modifier and Type | Method and Description
String[] | _truncatable_ids() Provides truncatable repository ids.

Method Detail

_truncatable_ids

String[] _truncatable_ids()
Provides truncatable repository ids.

Returns:
a String array--list of truncatable repository ids.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ValueFactory (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA.portable
Interface ValueFactory

public interface ValueFactory

The ValueFactory interface is the native mapping for the IDL type CORBA::ValueFactory. The read_value() method is called by the ORB runtime while in the process of unmarshaling a value type. A user shall implement this method as part of implementing a type specific value factory. In the implementation, the user shall call is.read_value(java.io.Serializable) with a uninitialized valuetype to use for unmarshaling. The value returned by the stream is the same value passed in, with all the data unmarshaled.

See Also:
ORB

Method Summary
Modifier and Type | Method and Description
Serializable | read_value(InputStream is) Is called by the ORB runtime while in the process of unmarshaling a value type.

Method Detail

read_value

Serializable read_value(InputStream is)
Is called by the ORB runtime while in the process of unmarshaling a value type. A user shall implement this method as part of implementing a type specific value factory.

Parameters:
is - an InputStream object--from which the value will be read.
Returns:
a Serializable object--the value read off of "is" Input stream.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ValueInputStream (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA.portable
Interface ValueInputStream

public interface ValueInputStream

Java to IDL ptc 02-01-12 1.5.1.4 ValueInputStream is used for implementing RMI-IIOP stream format version 2.

Method Summary
Modifier and Type | Method and Description
void | end_value() The end_value method reads the end tag for the nested custom valuetype (after skipping any data that precedes the end tag) and decrements the valuetype nesting depth.
void | start_value() The start_value method reads a valuetype header for a nested custom valuetype and increments the valuetype nesting depth.

Method Detail

start_value

void start_value()
The start_value method reads a valuetype header for a nested custom valuetype and increments the valuetype nesting depth.

end_value

void end_value()
The end_value method reads the end tag for the nested custom valuetype (after skipping any data that precedes the end tag) and decrements the valuetype nesting depth.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ValueOutputStream (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.CORBA.portable
Interface ValueOutputStream

public interface ValueOutputStream

Java to IDL ptc 02-01-12 1.5.1.3 ValueOutputStream is used for implementing RMI-IIOP stream format version 2.

Method Summary
Modifier and Type | Method and Description
void | end_value() The end_value method ends any currently open chunk, writes the end tag for the nested custom valuetype, and decrements the valuetype nesting depth.
void | start_value(String rep_id) The start_value method ends any currently open chunk, writes a valuetype header for a nested custom valuetype (with a null codebase and the specified repository ID), and increments the valuetype nesting depth.

Method Detail

start_value

void start_value(String rep_id)
The start_value method ends any currently open chunk, writes a valuetype header for a nested custom valuetype (with a null codebase and the specified repository ID), and increments the valuetype nesting depth.

end_value

void end_value()
The end_value method ends any currently open chunk, writes the end tag for the nested custom valuetype, and decrements the valuetype nesting depth.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BadKind (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.CORBA.TypeCodePackage
Class BadKind

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.CORBA.TypeCodePackage.BadKind
All Implemented Interfaces:
Serializable, IDLEntity
public final class BadKind
extends UserException

The exception BadKind is thrown when an inappropriate operation is invoked on a TypeCode object. For example, invoking the method discriminator_type() on an instance of TypeCode that does not represent an IDL union will cause the exception BadKind to be thrown.

Since:
JDK1.2
See Also:
TypeCode

Constructor Summary
Constructor and Description
BadKind()
Constructs a BadKind exception with no reason message.
BadKind(String reason)
Constructs a BadKind exception with the specified reason message.
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

BadKind

public BadKind()
Constructs a BadKind exception with no reason message.

BadKind

public BadKind(String reason)
Constructs a BadKind exception with the specified reason message.

Parameters:
reason - the String containing a reason message
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Bounds (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.CORBA.TypeCodePackage
Class Bounds

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.CORBA.TypeCodePackage.Bounds
All Implemented Interfaces:
Serializable, IDLEntity
public final class Bounds
extends UserException

Provides the TypeCode operations member_name(), member_type(), and member_label. These methods raise Bounds when the index parameter is greater than or equal to the number of members constituting the type.

Since:
JDK1.2

Constructor Summary
Constructor and Description
Bounds()
Constructs a Bounds exception with no reason message.
Bounds(String reason)
Constructs a Bounds exception with the specified reason message.
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Bounds

public Bounds()
Constructs a Bounds exception with no reason message.

Bounds

public Bounds(String reason)
Constructs a Bounds exception with the specified reason message.

Parameters:
reason - the String containing a reason message
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.omg.CORBA.TypeCodePackage (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.CORBA.TypeCodePackage

Provides the user-defined exceptions BadKind and Bounds, which are thrown by methods in in the class TypeCode.

See:
Description

Exception Summary
Exception | Description
BadKind | The exception BadKind is thrown when an inappropriate operation is invoked on a TypeCode object.
Bounds | Provides the TypeCode operations member_name(), member_type(), and member_label.

Package org.omg.CORBA.TypeCodePackage Description

Provides the user-defined exceptions BadKind and Bounds, which are thrown by methods in in the class TypeCode.

Related Documentation

For an overview, please see:
  • comments on the CORBA package

Since:
JDK1.2
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


ORB (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.CORBA_2_3
Class ORB

java.lang.Object
    extended by  org.omg.CORBA.ORB
        extended by  org.omg.CORBA_2_3.ORB

public abstract class ORB
extends ORB

A class extending org.omg.CORBA.ORB to make the ORB portable under the OMG CORBA version 2.3 specification.

Constructor Summary
Constructor and Description
ORB()
Method Summary
Modifier and Type | Method and Description
Object | get_value_def(String repid)
ValueFactory | lookup_value_factory(String id)
ValueFactory | register_value_factory(String id, ValueFactory factory)
void | set_delegate(Object wrapper)
void | unregister_value_factory(String id)
Methods inherited from class org.omg.CORBA.ORB
connect, create_abstract_interface_tc, create_alias_tc, create_any, create_array_tc, create_basic_dyn_any, create_context_list, create_dyn_any, create_dyn_array, create_dyn_enum, create_dyn_sequence, create_dyn_struct, create_dyn_union, create_enum_tc, create_environment, create_exception_list, create_exception_tc, create_fixed_tc, create_interface_tc, create_list, create_named_value, create_native_tc, create_operation_list, create_output_stream, create_policy, create_recursive_sequence_tc, create_recursive_tc, create_sequence_tc, create_string_tc, create_struct_tc, create_union_tc, create_value_box_tc, create_value_tc, create_wstring_tc, destroy, disconnect, get_current, get_default_context, get_next_response, get_primitive_tc, get_service_information, init, init, init, list_initial_services, object_to_string, perform_work, poll_next_response, resolve_initial_references, run, send_multiple_requests_deferred, send_multiple_requests_oneway, set_parameters, set_parameters, shutdown, string_to_object, work_pending
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ORB

public ORB()
Method Detail

register_value_factory

public ValueFactory register_value_factory(String id,
                                           ValueFactory factory)

unregister_value_factory

public void unregister_value_factory(String id)

lookup_value_factory

public ValueFactory lookup_value_factory(String id)

get_value_def

public Object get_value_def(String repid)
                     throws BAD_PARAM
Throws:
BAD_PARAM
See Also:
CORBA_2_3 package comments for unimplemented features

set_delegate

public void set_delegate(Object wrapper)
See Also:
CORBA_2_3 package comments for unimplemented features
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.omg.CORBA_2_3 (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.CORBA_2_3

The CORBA_2_3 package defines additions to existing CORBA interfaces in the Java[tm] Standard Edition 6. These changes occurred in recent revisions to the CORBA API defined by the OMG. The new methods were added to interfaces derived from the corresponding interfaces in the CORBA package. This provides backward compatibility and avoids breaking the JCK tests.

See:
Description

Class Summary
Class | Description
ORB | A class extending org.omg.CORBA.ORB to make the ORB portable under the OMG CORBA version 2.3 specification.

Package org.omg.CORBA_2_3 Description

The CORBA_2_3 package defines additions to existing CORBA interfaces in the Java[tm] Standard Edition 6. These changes occurred in recent revisions to the CORBA API defined by the OMG. The new methods were added to interfaces derived from the corresponding interfaces in the CORBA package. This provides backward compatibility and avoids breaking the JCK tests.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6, ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

The following methods in the abstract class org.omg.CORBA_2_3.ORB are unimplemented:

  • public org.omg.CORBA.portable.ValueFactory register_value_factory(String id, org.omg.CORBA.portable.ValueFactory factory)
  • public void unregister_value_factory(String id)
  • public org.omg.CORBA.portable.ValueFactory lookup_value_factory(String id)
  • public org.omg.CORBA.Object get_value_def(String repid)
  • public void set_delegate(java.lang.Object wrapper)

Since:
JDK 1.3
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


Delegate (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.CORBA_2_3.portable
Class Delegate

java.lang.Object
    extended by  org.omg.CORBA.portable.Delegate
        extended by  org.omg.CORBA_2_3.portable.Delegate

public abstract class Delegate
extends Delegate

Delegate class provides the ORB vendor specific implementation of CORBA object. It extends org.omg.CORBA.portable.Delegate and provides new methods that were defined by CORBA 2.3.

Since:
JDK1.2
See Also:
Delegate

Constructor Summary
Constructor and Description
Delegate()
Method Summary
Modifier and Type | Method and Description
String | get_codebase(Object self) Returns the codebase for object reference provided.
Methods inherited from class org.omg.CORBA.portable.Delegate
create_request, create_request, duplicate, equals, get_domain_managers, get_interface_def, get_policy, hash, hashCode, invoke, is_a, is_equivalent, is_local, non_existent, orb, release, releaseReply, request, request, servant_postinvoke, servant_preinvoke, set_policy_override, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Delegate

public Delegate()
Method Detail

get_codebase

public String get_codebase(Object self)
Returns the codebase for object reference provided.

Parameters:
self - the object reference whose codebase needs to be returned.
Returns:
the codebase as a space delimited list of url strings or null if none.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


InputStream (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA_2_3.portable
Class InputStream

java.lang.Object
    extended by  java.io.InputStream
        extended by  org.omg.CORBA.portable.InputStream
            extended by  org.omg.CORBA_2_3.portable.InputStream
All Implemented Interfaces:
Closeable
public abstract class InputStream
extends InputStream

InputStream provides for the reading of all of the mapped IDL types from the stream. It extends org.omg.CORBA.portable.InputStream. This class defines new methods that were added for CORBA 2.3.

Since:
JDK1.2
See Also:
InputStream

Constructor Summary
Constructor and Description
InputStream()
Method Summary
Modifier and Type | Method and Description
Object | read_abstract_interface() Unmarshal the value object or a suitable stub object.
Object | read_abstract_interface(Class clz) Unmarshal the class object or the stub class corresponding to the passed type.
Serializable | read_value() Unmarshalls a value type from the input stream.
Serializable | read_value(BoxedValueHelper factory) Unmarshalls a value type from the input stream.
Serializable | read_value(Class clz) Unmarshalls a value type from the input stream.
Serializable | read_value(Serializable value) Unmarshalls a value type from the input stream.
Serializable | read_value(String rep_id) Unmarshalls a value type from the input stream.
Methods inherited from class org.omg.CORBA.portable.InputStream
orb, read_any, read_boolean_array, read_boolean, read_char_array, read_char, read_Context, read_double_array, read_double, read_fixed, read_float_array, read_float, read_long_array, read_long, read_longlong_array, read_longlong, read_Object, read_Object, read_octet_array, read_octet, read_Principal, read_short_array, read_short, read_string, read_TypeCode, read_ulong_array, read_ulong, read_ulonglong_array, read_ulonglong, read_ushort_array, read_ushort, read_wchar_array, read_wchar, read_wstring, read
Methods inherited from class java.io.InputStream
available, close, mark, markSupported, read, read, reset, skip
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InputStream

public InputStream()
Method Detail

read_value

public Serializable read_value()
Unmarshalls a value type from the input stream.

Returns:
the value type unmarshalled from the input stream

read_value

public Serializable read_value(Class clz)
Unmarshalls a value type from the input stream.

Parameters:
clz - is the declared type of the value to be unmarshalled
Returns:
the value unmarshalled from the input stream

read_value

public Serializable read_value(BoxedValueHelper factory)
Unmarshalls a value type from the input stream.

Parameters:
factory - is the instance fo the helper to be used for unmarshalling the value type
Returns:
the value unmarshalled from the input stream

read_value

public Serializable read_value(String rep_id)
Unmarshalls a value type from the input stream.

Parameters:
rep_id - identifies the type of the value to be unmarshalled
Returns:
value type unmarshalled from the input stream

read_value

public Serializable read_value(Serializable value)
Unmarshalls a value type from the input stream.

Parameters:
value - is an uninitialized value which is added to the orb's indirection table before calling Streamable._read() or CustomMarshal.unmarshal() to unmarshal the value.
Returns:
value type unmarshalled from the input stream

read_abstract_interface

public Object read_abstract_interface()
Unmarshal the value object or a suitable stub object.

Returns:
ORB runtime returns the value object or a suitable stub object.

read_abstract_interface

public Object read_abstract_interface(Class clz)
Unmarshal the class object or the stub class corresponding to the passed type.

Parameters:
clz - is the Class object for the stub class which corresponds to the type that is statically expected.
Returns:
ORB runtime returns the value object or a suitable stub object.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ObjectImpl (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CORBA_2_3.portable
Class ObjectImpl

java.lang.Object
    extended by  org.omg.CORBA.portable.ObjectImpl
        extended by  org.omg.CORBA_2_3.portable.ObjectImpl
All Implemented Interfaces:
Object
Direct Known Subclasses:
Stub
public abstract class ObjectImpl
extends ObjectImpl

ObjectImpl class is the base class for all stubs. It provides the basic delegation mechanism. It extends org.omg.CORBA.portable.ObjectImpl and provides new methods defined by CORBA 2.3.

Since:
JDK1.2
See Also:
ObjectImpl

Constructor Summary
Constructor and Description
ObjectImpl()
Method Summary
Modifier and Type | Method and Description
String | _get_codebase() Returns the codebase for this object reference.
Methods inherited from class org.omg.CORBA.portable.ObjectImpl
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _ids, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ObjectImpl

public ObjectImpl()
Method Detail

_get_codebase

public String _get_codebase()
Returns the codebase for this object reference.

Returns:
the codebase as a space delimited list of url strings or null if none.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


OutputStream (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.CORBA_2_3.portable
Class OutputStream

java.lang.Object
    extended by  java.io.OutputStream
        extended by  org.omg.CORBA.portable.OutputStream
            extended by  org.omg.CORBA_2_3.portable.OutputStream
All Implemented Interfaces:
Closeable, Flushable
public abstract class OutputStream
extends OutputStream

OutputStream provides interface for writing of all of the mapped IDL type to the stream. It extends org.omg.CORBA.portable.OutputStream, and defines new methods defined by CORBA 2.3.

Since:
JDK1.2
See Also:
OutputStream

Constructor Summary
Constructor and Description
OutputStream()
Method Summary
Modifier and Type | Method and Description
void | write_abstract_interface(Object obj) Marshals a value object or a stub object.
void | write_value(Serializable value) Marshals a value type to the output stream.
void | write_value(Serializable value, BoxedValueHelper factory) Marshals a value type to the output stream.
void | write_value(Serializable value, Class clz) Marshals a value type to the output stream.
void | write_value(Serializable value, String repository_id) Marshals a value type to the output stream.
Methods inherited from class org.omg.CORBA.portable.OutputStream
create_input_stream, orb, write_any, write_boolean_array, write_boolean, write_char_array, write_char, write_Context, write_double_array, write_double, write_fixed, write_float_array, write_float, write_long_array, write_long, write_longlong_array, write_longlong, write_Object, write_octet_array, write_octet, write_Principal, write_short_array, write_short, write_string, write_TypeCode, write_ulong_array, write_ulong, write_ulonglong_array, write_ulonglong, write_ushort_array, write_ushort, write_wchar_array, write_wchar, write_wstring, write
Methods inherited from class java.io.OutputStream
close, flush, write, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OutputStream

public OutputStream()
Method Detail

write_value

public void write_value(Serializable value)
Marshals a value type to the output stream.

Parameters:
value - is the acutal value to write

write_value

public void write_value(Serializable value,
                        Class clz)
Marshals a value type to the output stream.

Parameters:
value - is the acutal value to write
clz - is the declared type of the value to be marshaled

write_value

public void write_value(Serializable value,
                        String repository_id)
Marshals a value type to the output stream.

Parameters:
value - is the acutal value to write
repository_id - identifies the type of the value type to be marshaled

write_value

public void write_value(Serializable value,
                        BoxedValueHelper factory)
Marshals a value type to the output stream.

Parameters:
value - is the acutal value to write
factory - is the instance of the helper to be used for marshaling the boxed value

write_abstract_interface

public void write_abstract_interface(Object obj)
Marshals a value object or a stub object.

Parameters:
obj - the actual value object to marshal or the stub to be marshalled
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.omg.CORBA_2_3.portable (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.CORBA_2_3.portable

Provides methods for the input and output of value types, and contains other updates to the org/omg/CORBA/portable package.

See:
Description

Class Summary
Class | Description
Delegate | Delegate class provides the ORB vendor specific implementation of CORBA object.
InputStream | InputStream provides for the reading of all of the mapped IDL types from the stream.
ObjectImpl | ObjectImpl class is the base class for all stubs.
OutputStream | OutputStream provides interface for writing of all of the mapped IDL type to the stream.

Package org.omg.CORBA_2_3.portable Description

Provides methods for the input and output of value types, and contains other updates to the org/omg/CORBA/portable package.

Since:
1.3
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


Binding (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class Binding

java.lang.Object
    extended by  org.omg.CosNaming.Binding
All Implemented Interfaces:
Serializable, IDLEntity
public final class Binding
extends Object
implements IDLEntity

org/omg/CosNaming/Binding.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

See Also:
Serialized Form

Field Summary
Modifier and Type | Field and Description
NameComponent[] | binding_name
BindingType | binding_type
Constructor Summary
Constructor and Description
Binding()
Binding(NameComponent[] _binding_name, BindingType _binding_type)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

binding_name

public NameComponent[] binding_name

binding_type

public BindingType binding_type
Constructor Detail

Binding

public Binding()

Binding

public Binding(NameComponent[] _binding_name,
               BindingType _binding_type)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


BindingHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class BindingHelper

java.lang.Object
    extended by  org.omg.CosNaming.BindingHelper

public abstract class BindingHelper
extends Object

org/omg/CosNaming/BindingHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
BindingHelper()
Method Summary
Modifier and Type | Method and Description
static Binding | extract(Any a)
static String | id()
static void | insert(Any a, Binding that)
static Binding | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, Binding value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BindingHelper

public BindingHelper()
Method Detail

insert

public static void insert(Any a,
                          Binding that)

extract

public static Binding extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static Binding read(InputStream istream)

write

public static void write(OutputStream ostream,
                         Binding value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


BindingHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class BindingHolder

java.lang.Object
    extended by  org.omg.CosNaming.BindingHolder
All Implemented Interfaces:
Streamable
public final class BindingHolder
extends Object
implements Streamable

org/omg/CosNaming/BindingHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

Field Summary
Modifier and Type | Field and Description
Binding | value
Constructor Summary
Constructor and Description
BindingHolder()
BindingHolder(Binding initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public Binding value
Constructor Detail

BindingHolder

public BindingHolder()

BindingHolder

public BindingHolder(Binding initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


BindingIterator (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Interface BindingIterator

All Superinterfaces:
BindingIteratorOperations, IDLEntity, Object, Serializable
All Known Implementing Classes:
_BindingIteratorImplBase, _BindingIteratorStub
public interface BindingIterator
extends BindingIteratorOperations, Object, IDLEntity

The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations. The bindings iterator is obtained by using the list method on the NamingContext.

See Also:
NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder)

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.CosNaming.BindingIteratorOperations
destroy, next_n, next_one
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


BindingIteratorHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class BindingIteratorHelper

java.lang.Object
    extended by  org.omg.CosNaming.BindingIteratorHelper

public abstract class BindingIteratorHelper
extends Object

The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations. The bindings iterator is obtained by using the list method on the NamingContext.

See Also:
NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder)

Constructor Summary
Constructor and Description
BindingIteratorHelper()
Method Summary
Modifier and Type | Method and Description
static BindingIterator | extract(Any a)
static String | id()
static void | insert(Any a, BindingIterator that)
static BindingIterator | narrow(Object obj)
static BindingIterator | read(InputStream istream)
static TypeCode | type()
static BindingIterator | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, BindingIterator value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BindingIteratorHelper

public BindingIteratorHelper()
Method Detail

insert

public static void insert(Any a,
                          BindingIterator that)

extract

public static BindingIterator extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static BindingIterator read(InputStream istream)

write

public static void write(OutputStream ostream,
                         BindingIterator value)

narrow

public static BindingIterator narrow(Object obj)

unchecked_narrow

public static BindingIterator unchecked_narrow(Object obj)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


BindingIteratorHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class BindingIteratorHolder

java.lang.Object
    extended by  org.omg.CosNaming.BindingIteratorHolder
All Implemented Interfaces:
Streamable
public final class BindingIteratorHolder
extends Object
implements Streamable

The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations. The bindings iterator is obtained by using the list method on the NamingContext.

See Also:
NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder)

Field Summary
Modifier and Type | Field and Description
BindingIterator | value
Constructor Summary
Constructor and Description
BindingIteratorHolder()
BindingIteratorHolder(BindingIterator initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public BindingIterator value
Constructor Detail

BindingIteratorHolder

public BindingIteratorHolder()

BindingIteratorHolder

public BindingIteratorHolder(BindingIterator initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


_BindingIteratorImplBase (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.CosNaming
Class _BindingIteratorImplBase

java.lang.Object
    extended by  org.omg.CORBA.portable.ObjectImpl
        extended by  org.omg.CORBA.DynamicImplementation
            extended by  org.omg.CosNaming._BindingIteratorImplBase
All Implemented Interfaces:
Serializable, Object, IDLEntity, BindingIterator, BindingIteratorOperations
public abstract class _BindingIteratorImplBase
extends DynamicImplementation
implements BindingIterator

See Also:
Serialized Form

Constructor Summary
Constructor and Description
_BindingIteratorImplBase()
Method Summary
Modifier and Type | Method and Description
String[] | _ids() Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
void | invoke(ServerRequest r)
Methods inherited from class org.omg.CORBA.portable.ObjectImpl
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.omg.CosNaming.BindingIteratorOperations
destroy, next_n, next_one
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Constructor Detail

_BindingIteratorImplBase

public _BindingIteratorImplBase()
Method Detail

_ids

public String[] _ids()
Description copied from class: ObjectImpl
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.

Overrides:
_ids in class DynamicImplementation
Returns:
the array of all repository identifiers supported by this ObjectImpl instance

invoke

public void invoke(ServerRequest r)
Overrides:
invoke in class DynamicImplementation
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BindingIteratorOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Interface BindingIteratorOperations

All Known Subinterfaces:
BindingIterator
All Known Implementing Classes:
_BindingIteratorImplBase, _BindingIteratorStub, BindingIteratorPOA
public interface BindingIteratorOperations

The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations. The bindings iterator is obtained by using the list method on the NamingContext.

See Also:
NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder)

Method Summary
Modifier and Type | Method and Description
void | destroy() This operation destroys the iterator.
boolean | next_n(int how_many, BindingListHolder bl) This operation returns at most the requested number of bindings.
boolean | next_one(BindingHolder b) This operation returns the next binding.

Method Detail

next_one

boolean next_one(BindingHolder b)
This operation returns the next binding. If there are no more bindings, false is returned.

Parameters:
b - the returned binding

next_n

boolean next_n(int how_many,
               BindingListHolder bl)
This operation returns at most the requested number of bindings.

Parameters:
how_many - the maximum number of bindings tro return

bl - the returned bindings

destroy

void destroy()
This operation destroys the iterator.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


BindingIteratorPOA (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class BindingIteratorPOA

java.lang.Object
    extended by  org.omg.PortableServer.Servant
        extended by  org.omg.CosNaming.BindingIteratorPOA
All Implemented Interfaces:
InvokeHandler, BindingIteratorOperations
public abstract class BindingIteratorPOA
extends Servant
implements BindingIteratorOperations, InvokeHandler

The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations. The bindings iterator is obtained by using the list method on the NamingContext.

See Also:
NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder)

Constructor Summary
Constructor and Description
BindingIteratorPOA()
Method Summary
Modifier and Type | Method and Description
String[] | _all_interfaces(POA poa, byte[] objectId) Used by the ORB to obtain complete type information from the servant.
OutputStream | _invoke(String $method, InputStream in, ResponseHandler $rh) Invoked by the ORB to dispatch a request to the servant.
BindingIterator | _this()
BindingIterator | _this(ORB orb)
Methods inherited from class org.omg.PortableServer.Servant
_default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.omg.CosNaming.BindingIteratorOperations
destroy, next_n, next_one

Constructor Detail

BindingIteratorPOA

public BindingIteratorPOA()
Method Detail

_invoke

public OutputStream _invoke(String $method,
                            InputStream in,
                            ResponseHandler $rh)
Description copied from interface: InvokeHandler
Invoked by the ORB to dispatch a request to the servant. ORB passes the method name, an InputStream containing the marshalled arguments, and a ResponseHandler which the servant uses to construct a proper reply. Only CORBA SystemException may be thrown by this method. The method must return an OutputStream created by the ResponseHandler which contains the marshalled reply. A servant must not retain a reference to the ResponseHandler beyond the lifetime of a method invocation. Servant behaviour is defined as follows:

1. Determine correct method, and unmarshal parameters from InputStream.

2. Invoke method implementation.

3. If no user exception, create a normal reply using ResponseHandler.

4. If user exception occurred, create exception reply using ResponseHandler.

5. Marshal reply into OutputStream returned by ResponseHandler.

6. Return OutputStream to ORB.

Specified by:
_invoke in interface InvokeHandler
Parameters:
$method - The method name.
in - The InputStream containing the marshalled arguments.
$rh - The ResponseHandler which the servant uses to construct a proper reply
Returns:
The OutputStream created by the ResponseHandler which contains the marshalled reply

_all_interfaces

public String[] _all_interfaces(POA poa,
                                byte[] objectId)
Description copied from class: Servant
Used by the ORB to obtain complete type information from the servant.

Specified by:
_all_interfaces in class Servant
Parameters:
poa - POA with which the servant is associated.
objectId - is the id corresponding to the object associated with this servant.
Returns:
list of type information for the object.

_this

public BindingIterator _this()

_this

public BindingIterator _this(ORB orb)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


_BindingIteratorStub (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class _BindingIteratorStub

java.lang.Object
    extended by  org.omg.CORBA.portable.ObjectImpl
        extended by  org.omg.CosNaming._BindingIteratorStub
All Implemented Interfaces:
Serializable, Object, IDLEntity, BindingIterator, BindingIteratorOperations
public class _BindingIteratorStub
extends ObjectImpl
implements BindingIterator

The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations. The bindings iterator is obtained by using the list method on the NamingContext.

See Also:
NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder), Serialized Form

Constructor Summary
Constructor and Description
_BindingIteratorStub()
Method Summary
Modifier and Type | Method and Description
String[] | _ids() Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
void | destroy() This operation destroys the iterator.
boolean | next_n(int how_many, BindingListHolder bl) This operation returns at most the requested number of bindings.
boolean | next_one(BindingHolder b) This operation returns the next binding.
Methods inherited from class org.omg.CORBA.portable.ObjectImpl
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Constructor Detail

_BindingIteratorStub

public _BindingIteratorStub()
Method Detail

next_one

public boolean next_one(BindingHolder b)
This operation returns the next binding. If there are no more bindings, false is returned.

Specified by:
next_one in interface BindingIteratorOperations
Parameters:
b - the returned binding

next_n

public boolean next_n(int how_many,
                      BindingListHolder bl)
This operation returns at most the requested number of bindings.

Specified by:
next_n in interface BindingIteratorOperations
Parameters:
how_many - the maximum number of bindings tro return

bl - the returned bindings

destroy

public void destroy()
This operation destroys the iterator.

Specified by:
destroy in interface BindingIteratorOperations

_ids

public String[] _ids()
Description copied from class: ObjectImpl
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.

Specified by:
_ids in class ObjectImpl
Returns:
the array of all repository identifiers supported by this ObjectImpl instance
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


BindingListHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class BindingListHelper

java.lang.Object
    extended by  org.omg.CosNaming.BindingListHelper

public abstract class BindingListHelper
extends Object

List of Bindings.

Constructor Summary
Constructor and Description
BindingListHelper()
Method Summary
Modifier and Type | Method and Description
static Binding[] | extract(Any a)
static String | id()
static void | insert(Any a, Binding[] that)
static Binding[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, Binding[] value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BindingListHelper

public BindingListHelper()
Method Detail

insert

public static void insert(Any a,
                          Binding[] that)

extract

public static Binding[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static Binding[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         Binding[] value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


BindingListHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class BindingListHolder

java.lang.Object
    extended by  org.omg.CosNaming.BindingListHolder
All Implemented Interfaces:
Streamable
public final class BindingListHolder
extends Object
implements Streamable

List of Bindings.

Field Summary
Modifier and Type | Field and Description
Binding[] | value
Constructor Summary
Constructor and Description
BindingListHolder()
BindingListHolder(Binding[] initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public Binding[] value
Constructor Detail

BindingListHolder

public BindingListHolder()

BindingListHolder

public BindingListHolder(Binding[] initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


BindingType (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class BindingType

java.lang.Object
    extended by  org.omg.CosNaming.BindingType
All Implemented Interfaces:
Serializable, IDLEntity
public class BindingType
extends Object
implements IDLEntity

Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.

See Also:
Serialized Form

Field Summary
Modifier and Type | Field and Description
static int | _ncontext
static int | _nobject
static BindingType | ncontext
static BindingType | nobject
Constructor Summary
Modifier | Constructor and Description
protected | BindingType(int value)
Method Summary
Modifier and Type | Method and Description
static BindingType | from_int(int value)
int | value()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_nobject

public static final int _nobject
See Also:
Constant Field Values

nobject

public static final BindingType nobject

_ncontext

public static final int _ncontext
See Also:
Constant Field Values

ncontext

public static final BindingType ncontext
Constructor Detail

BindingType

protected BindingType(int value)
Method Detail

value

public int value()

from_int

public static BindingType from_int(int value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


BindingTypeHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class BindingTypeHelper

java.lang.Object
    extended by  org.omg.CosNaming.BindingTypeHelper

public abstract class BindingTypeHelper
extends Object

Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.

Constructor Summary
Constructor and Description
BindingTypeHelper()
Method Summary
Modifier and Type | Method and Description
static BindingType | extract(Any a)
static String | id()
static void | insert(Any a, BindingType that)
static BindingType | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, BindingType value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BindingTypeHelper

public BindingTypeHelper()
Method Detail

insert

public static void insert(Any a,
                          BindingType that)

extract

public static BindingType extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static BindingType read(InputStream istream)

write

public static void write(OutputStream ostream,
                         BindingType value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


BindingTypeHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class BindingTypeHolder

java.lang.Object
    extended by  org.omg.CosNaming.BindingTypeHolder
All Implemented Interfaces:
Streamable
public final class BindingTypeHolder
extends Object
implements Streamable

Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.

Field Summary
Modifier and Type | Field and Description
BindingType | value
Constructor Summary
Constructor and Description
BindingTypeHolder()
BindingTypeHolder(BindingType initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public BindingType value
Constructor Detail

BindingTypeHolder

public BindingTypeHolder()

BindingTypeHolder

public BindingTypeHolder(BindingType initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


IstringHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class IstringHelper

java.lang.Object
    extended by  org.omg.CosNaming.IstringHelper

public abstract class IstringHelper
extends Object

org/omg/CosNaming/IstringHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
IstringHelper()
Method Summary
Modifier and Type | Method and Description
static String | extract(Any a)
static String | id()
static void | insert(Any a, String that)
static String | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IstringHelper

public IstringHelper()
Method Detail

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NameComponent (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class NameComponent

java.lang.Object
    extended by  org.omg.CosNaming.NameComponent
All Implemented Interfaces:
Serializable, IDLEntity
public final class NameComponent
extends Object
implements IDLEntity

org/omg/CosNaming/NameComponent.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

See Also:
Serialized Form

Field Summary
Modifier and Type | Field and Description
String | id
String | kind
Constructor Summary
Constructor and Description
NameComponent()
NameComponent(String _id, String _kind)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

id

public String id

kind

public String kind
Constructor Detail

NameComponent

public NameComponent()

NameComponent

public NameComponent(String _id,
                     String _kind)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NameComponentHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class NameComponentHelper

java.lang.Object
    extended by  org.omg.CosNaming.NameComponentHelper

public abstract class NameComponentHelper
extends Object

org/omg/CosNaming/NameComponentHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
NameComponentHelper()
Method Summary
Modifier and Type | Method and Description
static NameComponent | extract(Any a)
static String | id()
static void | insert(Any a, NameComponent that)
static NameComponent | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, NameComponent value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NameComponentHelper

public NameComponentHelper()
Method Detail

insert

public static void insert(Any a,
                          NameComponent that)

extract

public static NameComponent extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NameComponent read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NameComponent value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NameComponentHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class NameComponentHolder

java.lang.Object
    extended by  org.omg.CosNaming.NameComponentHolder
All Implemented Interfaces:
Streamable
public final class NameComponentHolder
extends Object
implements Streamable

org/omg/CosNaming/NameComponentHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

Field Summary
Modifier and Type | Field and Description
NameComponent | value
Constructor Summary
Constructor and Description
NameComponentHolder()
NameComponentHolder(NameComponent initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public NameComponent value
Constructor Detail

NameComponentHolder

public NameComponentHolder()

NameComponentHolder

public NameComponentHolder(NameComponent initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NameHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class NameHelper

java.lang.Object
    extended by  org.omg.CosNaming.NameHelper

public abstract class NameHelper
extends Object

A name is a sequence of name components.

Constructor Summary
Constructor and Description
NameHelper()
Method Summary
Modifier and Type | Method and Description
static NameComponent[] | extract(Any a)
static String | id()
static void | insert(Any a, NameComponent[] that)
static NameComponent[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, NameComponent[] value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NameHelper

public NameHelper()
Method Detail

insert

public static void insert(Any a,
                          NameComponent[] that)

extract

public static NameComponent[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NameComponent[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NameComponent[] value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NameHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class NameHolder

java.lang.Object
    extended by  org.omg.CosNaming.NameHolder
All Implemented Interfaces:
Streamable
public final class NameHolder
extends Object
implements Streamable

A name is a sequence of name components.

Field Summary
Modifier and Type | Field and Description
NameComponent[] | value
Constructor Summary
Constructor and Description
NameHolder()
NameHolder(NameComponent[] initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public NameComponent[] value
Constructor Detail

NameHolder

public NameHolder()

NameHolder

public NameHolder(NameComponent[] initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NamingContext (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Interface NamingContext

All Superinterfaces:
IDLEntity, NamingContextOperations, Object, Serializable
All Known Subinterfaces:
NamingContextExt
All Known Implementing Classes:
_NamingContextExtStub, _NamingContextImplBase, _NamingContextStub
public interface NamingContext
extends NamingContextOperations, Object, IDLEntity

A naming context is an object that contains a set of name bindings in which each name is unique. Different names can be bound to an object in the same or different contexts at the same time.

See CORBA COS Naming Specification.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.CosNaming.NamingContextOperations
bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NamingContextExt (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Interface NamingContextExt

All Superinterfaces:
IDLEntity, NamingContext, NamingContextExtOperations, NamingContextOperations, Object, Serializable
All Known Implementing Classes:
_NamingContextExtStub
public interface NamingContextExt
extends NamingContextExtOperations, NamingContext, IDLEntity

NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service. Different names can be bound to an object in the same or different contexts at the same time. Using NamingContextExt, you can use URL-based names to bind and resolve.

See CORBA COS Naming Specification.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.CosNaming.NamingContextExtOperations
resolve_str, to_name, to_string, to_url
Methods inherited from interface org.omg.CosNaming.NamingContextOperations
bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NamingContextExtHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class NamingContextExtHelper

java.lang.Object
    extended by  org.omg.CosNaming.NamingContextExtHelper

public abstract class NamingContextExtHelper
extends Object

NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service. Different names can be bound to an object in the same or different contexts at the same time. Using NamingContextExt, you can use URL-based names to bind and resolve.

See CORBA COS Naming Specification.

Constructor Summary
Constructor and Description
NamingContextExtHelper()
Method Summary
Modifier and Type | Method and Description
static NamingContextExt | extract(Any a)
static String | id()
static void | insert(Any a, NamingContextExt that)
static NamingContextExt | narrow(Object obj)
static NamingContextExt | read(InputStream istream)
static TypeCode | type()
static NamingContextExt | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, NamingContextExt value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NamingContextExtHelper

public NamingContextExtHelper()
Method Detail

insert

public static void insert(Any a,
                          NamingContextExt that)

extract

public static NamingContextExt extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NamingContextExt read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NamingContextExt value)

narrow

public static NamingContextExt narrow(Object obj)

unchecked_narrow

public static NamingContextExt unchecked_narrow(Object obj)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NamingContextExtHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class NamingContextExtHolder

java.lang.Object
    extended by  org.omg.CosNaming.NamingContextExtHolder
All Implemented Interfaces:
Streamable
public final class NamingContextExtHolder
extends Object
implements Streamable

NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service. Different names can be bound to an object in the same or different contexts at the same time. Using NamingContextExt, you can use URL-based names to bind and resolve.

See CORBA COS Naming Specification.

Field Summary
Modifier and Type | Field and Description
NamingContextExt | value
Constructor Summary
Constructor and Description
NamingContextExtHolder()
NamingContextExtHolder(NamingContextExt initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public NamingContextExt value
Constructor Detail

NamingContextExtHolder

public NamingContextExtHolder()

NamingContextExtHolder

public NamingContextExtHolder(NamingContextExt initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NamingContextExtOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Interface NamingContextExtOperations

All Superinterfaces:
NamingContextOperations
All Known Subinterfaces:
NamingContextExt
All Known Implementing Classes:
_NamingContextExtStub, NamingContextExtPOA
public interface NamingContextExtOperations
extends NamingContextOperations

NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service. Different names can be bound to an object in the same or different contexts at the same time. Using NamingContextExt, you can use URL-based names to bind and resolve.

See CORBA COS Naming Specification.

Method Summary
Modifier and Type | Method and Description
Object | resolve_str(String sn) This operation resolves the Stringified name into the object reference.
NameComponent[] | to_name(String sn) This operation converts a Stringified Name into an equivalent array of Name Components.
String | to_string(NameComponent[] n) This operation creates a stringified name from the array of Name components.
String | to_url(String addr, String sn) This operation creates a URL based "iiopname://" format name from the Stringified Name of the object.
Methods inherited from interface org.omg.CosNaming.NamingContextOperations
bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind

Method Detail

to_string

String to_string(NameComponent[] n)
                 throws InvalidName
This operation creates a stringified name from the array of Name components.

Parameters:
n - Name of the object

Throws:
org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

InvalidName

to_name

NameComponent[] to_name(String sn)
                        throws InvalidName
This operation converts a Stringified Name into an equivalent array of Name Components.

Parameters:
sn - Stringified Name of the object

Throws:
org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

InvalidName

to_url

String to_url(String addr,
              String sn)
              throws InvalidAddress,
                     InvalidName
This operation creates a URL based "iiopname://" format name from the Stringified Name of the object.

Parameters:
addr - internet based address of the host machine where Name Service is running

sn - Stringified Name of the object

Throws:
org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

org.omg.CosNaming.NamingContextPackage.InvalidAddress - Indicates the internet based address of the host machine is incorrect

InvalidAddress
InvalidName

resolve_str

Object resolve_str(String sn)
                   throws NotFound,
                          CannotProceed,
                          InvalidName
This operation resolves the Stringified name into the object reference.

Parameters:
sn - Stringified Name of the object

Throws:
NotFound - Indicates there is no object reference for the given name.

CannotProceed - Indicates that the given compound name is incorrect

org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

InvalidName
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NamingContextExtPOA (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class NamingContextExtPOA

java.lang.Object
    extended by  org.omg.PortableServer.Servant
        extended by  org.omg.CosNaming.NamingContextExtPOA
All Implemented Interfaces:
InvokeHandler, NamingContextExtOperations, NamingContextOperations
public abstract class NamingContextExtPOA
extends Servant
implements NamingContextExtOperations, InvokeHandler

NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service. Different names can be bound to an object in the same or different contexts at the same time. Using NamingContextExt, you can use URL-based names to bind and resolve.

See CORBA COS Naming Specification.

Constructor Summary
Constructor and Description
NamingContextExtPOA()
Method Summary
Modifier and Type | Method and Description
String[] | _all_interfaces(POA poa, byte[] objectId) Used by the ORB to obtain complete type information from the servant.
OutputStream | _invoke(String $method, InputStream in, ResponseHandler $rh) Invoked by the ORB to dispatch a request to the servant.
NamingContextExt | _this()
NamingContextExt | _this(ORB orb)
Methods inherited from class org.omg.PortableServer.Servant
_default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.omg.CosNaming.NamingContextExtOperations
resolve_str, to_name, to_string, to_url
Methods inherited from interface org.omg.CosNaming.NamingContextOperations
bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind

Constructor Detail

NamingContextExtPOA

public NamingContextExtPOA()
Method Detail

_invoke

public OutputStream _invoke(String $method,
                            InputStream in,
                            ResponseHandler $rh)
Description copied from interface: InvokeHandler
Invoked by the ORB to dispatch a request to the servant. ORB passes the method name, an InputStream containing the marshalled arguments, and a ResponseHandler which the servant uses to construct a proper reply. Only CORBA SystemException may be thrown by this method. The method must return an OutputStream created by the ResponseHandler which contains the marshalled reply. A servant must not retain a reference to the ResponseHandler beyond the lifetime of a method invocation. Servant behaviour is defined as follows:

1. Determine correct method, and unmarshal parameters from InputStream.

2. Invoke method implementation.

3. If no user exception, create a normal reply using ResponseHandler.

4. If user exception occurred, create exception reply using ResponseHandler.

5. Marshal reply into OutputStream returned by ResponseHandler.

6. Return OutputStream to ORB.

Specified by:
_invoke in interface InvokeHandler
Parameters:
$method - The method name.
in - The InputStream containing the marshalled arguments.
$rh - The ResponseHandler which the servant uses to construct a proper reply
Returns:
The OutputStream created by the ResponseHandler which contains the marshalled reply

_all_interfaces

public String[] _all_interfaces(POA poa,
                                byte[] objectId)
Description copied from class: Servant
Used by the ORB to obtain complete type information from the servant.

Specified by:
_all_interfaces in class Servant
Parameters:
poa - POA with which the servant is associated.
objectId - is the id corresponding to the object associated with this servant.
Returns:
list of type information for the object.

_this

public NamingContextExt _this()

_this

public NamingContextExt _this(ORB orb)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


_NamingContextExtStub (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class _NamingContextExtStub

java.lang.Object
    extended by  org.omg.CORBA.portable.ObjectImpl
        extended by  org.omg.CosNaming._NamingContextExtStub
All Implemented Interfaces:
Serializable, Object, IDLEntity, NamingContext, NamingContextExt, NamingContextExtOperations, NamingContextOperations
public class _NamingContextExtStub
extends ObjectImpl
implements NamingContextExt

NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service. Different names can be bound to an object in the same or different contexts at the same time. Using NamingContextExt, you can use URL-based names to bind and resolve.

See CORBA COS Naming Specification.

See Also:
Serialized Form

Constructor Summary
Constructor and Description
_NamingContextExtStub()
Method Summary
Modifier and Type | Method and Description
String[] | _ids() Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
void | bind_context(NameComponent[] n, NamingContext nc) Names an object that is a naming context.
NamingContext | bind_new_context(NameComponent[] n) This operation creates a new context and binds it to the name supplied as an argument.
void | bind(NameComponent[] n, Object obj) Creates a binding of a name and an object in the naming context.
void | destroy() The destroy operation deletes a naming context.
void | list(int how_many, BindingListHolder bl, BindingIteratorHolder bi) The list operation allows a client to iterate through a set of bindings in a naming context.
NamingContext | new_context() This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked.
void | rebind_context(NameComponent[] n, NamingContext nc) Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
void | rebind(NameComponent[] n, Object obj) Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
Object | resolve_str(String sn) This operation resolves the Stringified name into the object reference.
Object | resolve(NameComponent[] n) The resolve operation is the process of retrieving an object bound to a name in a given context.
NameComponent[] | to_name(String sn) This operation converts a Stringified Name into an equivalent array of Name Components.
String | to_string(NameComponent[] n) This operation creates a stringified name from the array of Name components.
String | to_url(String addr, String sn) This operation creates a URL based "iiopname://" format name from the Stringified Name of the object.
void | unbind(NameComponent[] n) The unbind operation removes a name binding from a context.
Methods inherited from class org.omg.CORBA.portable.ObjectImpl
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Constructor Detail

_NamingContextExtStub

public _NamingContextExtStub()
Method Detail

to_string

public String to_string(NameComponent[] n)
                 throws InvalidName
This operation creates a stringified name from the array of Name components.

Specified by:
to_string in interface NamingContextExtOperations
Parameters:
n - Name of the object

Throws:
org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

InvalidName

to_name

public NameComponent[] to_name(String sn)
                        throws InvalidName
This operation converts a Stringified Name into an equivalent array of Name Components.

Specified by:
to_name in interface NamingContextExtOperations
Parameters:
sn - Stringified Name of the object

Throws:
org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

InvalidName

to_url

public String to_url(String addr,
                     String sn)
              throws InvalidAddress,
                     InvalidName
This operation creates a URL based "iiopname://" format name from the Stringified Name of the object.

Specified by:
to_url in interface NamingContextExtOperations
Parameters:
addr - internet based address of the host machine where Name Service is running

sn - Stringified Name of the object

Throws:
org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

org.omg.CosNaming.NamingContextPackage.InvalidAddress - Indicates the internet based address of the host machine is incorrect

InvalidAddress
InvalidName

resolve_str

public Object resolve_str(String sn)
                   throws NotFound,
                          CannotProceed,
                          InvalidName
This operation resolves the Stringified name into the object reference.

Specified by:
resolve_str in interface NamingContextExtOperations
Parameters:
sn - Stringified Name of the object

Throws:
NotFound - Indicates there is no object reference for the given name.

CannotProceed - Indicates that the given compound name is incorrect

org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

InvalidName

bind

public void bind(NameComponent[] n,
                 Object obj)
          throws NotFound,
                 CannotProceed,
                 InvalidName,
                 AlreadyBound
Creates a binding of a name and an object in the naming context. Naming contexts that are bound using bind do not participate in name resolution when compound names are passed to be resolved.

Specified by:
bind in interface NamingContextOperations
Parameters:
n - Name of the object

obj - The Object to bind with the given name

Throws:
NotFound - Indicates the name does not identify a binding.

CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

InvalidName - Indicates that the name is invalid.

AlreadyBound - Indicates an object is already bound to the specified name.

bind_context

public void bind_context(NameComponent[] n,
                         NamingContext nc)
                  throws NotFound,
                         CannotProceed,
                         InvalidName,
                         AlreadyBound
Names an object that is a naming context. Naming contexts that are bound using bind_context() participate in name resolution when compound names are passed to be resolved.

Specified by:
bind_context in interface NamingContextOperations
Parameters:
n - Name of the object

nc - NamingContect object to bind with the given name

Throws:
NotFound - Indicates the name does not identify a binding.

CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

InvalidName - Indicates that the name is invalid.

AlreadyBound - Indicates an object is already bound to the specified name.

rebind

public void rebind(NameComponent[] n,
                   Object obj)
            throws NotFound,
                   CannotProceed,
                   InvalidName
Creates a binding of a name and an object in the naming context even if the name is already bound in the context. Naming contexts that are bound using rebind do not participate in name resolution when compound names are passed to be resolved.

Specified by:
rebind in interface NamingContextOperations
Parameters:
n - Name of the object

Throws:
NotFound - Indicates the name does not identify a binding.

CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

InvalidName - Indicates that the name is invalid.

rebind_context

public void rebind_context(NameComponent[] n,
                           NamingContext nc)
                    throws NotFound,
                           CannotProceed,
                           InvalidName
Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context. Naming contexts that are bound using rebind_context() participate in name resolution when compound names are passed to be resolved.

Specified by:
rebind_context in interface NamingContextOperations
Parameters:
n - Name of the object

nc - NamingContect object to rebind with the given name

Throws:
NotFound - Indicates the name does not identify a binding.

CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

InvalidName - Indicates that the name is invalid.

resolve

public Object resolve(NameComponent[] n)
               throws NotFound,
                      CannotProceed,
                      InvalidName
The resolve operation is the process of retrieving an object bound to a name in a given context. The given name must exactly match the bound name. The naming service does not return the type of the object. Clients are responsible for "narrowing" the object to the appropriate type. That is, clients typically cast the returned object from Object to a more specialized interface.

Specified by:
resolve in interface NamingContextOperations
Parameters:
n - Name of the object

Throws:
NotFound - Indicates the name does not identify a binding.

CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

InvalidName - Indicates that the name is invalid.

unbind

public void unbind(NameComponent[] n)
            throws NotFound,
                   CannotProceed,
                   InvalidName
The unbind operation removes a name binding from a context.

Specified by:
unbind in interface NamingContextOperations
Parameters:
n - Name of the object

Throws:
NotFound - Indicates the name does not identify a binding.

CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

InvalidName - Indicates that the name is invalid.

list

public void list(int how_many,
                 BindingListHolder bl,
                 BindingIteratorHolder bi)
The list operation allows a client to iterate through a set of bindings in a naming context.

The list operation returns at most the requested number of bindings in BindingList bl.

  • If the naming context contains additional bindings, the list operation returns a BindingIterator with the additional bindings.
  • If the naming context does not contain additional bindings, the binding iterator is a nil object reference.

Specified by:
list in interface NamingContextOperations
Parameters:
how_many - the maximum number of bindings to return

bl - the returned list of bindings

bi - the returned binding iterator

new_context

public NamingContext new_context()
This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked. The new context is not bound to any name.

Specified by:
new_context in interface NamingContextOperations

bind_new_context

public NamingContext bind_new_context(NameComponent[] n)
                               throws NotFound,
                                      AlreadyBound,
                                      CannotProceed,
                                      InvalidName
This operation creates a new context and binds it to the name supplied as an argument. The newly-created context is implemented by the same naming server as the context in which it was bound (that is, the naming server that implements the context denoted by the name argument excluding the last component).

Specified by:
bind_new_context in interface NamingContextOperations
Parameters:
n - Name of the object

Throws:
NotFound - Indicates the name does not identify a binding.

AlreadyBound - Indicates an object is already bound to the specified name.

CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

InvalidName - Indicates that the name is invalid.

destroy

public void destroy()
             throws NotEmpty
The destroy operation deletes a naming context. If the naming context contains bindings, the NotEmpty exception is raised.

Specified by:
destroy in interface NamingContextOperations
Throws:
NotEmpty - Indicates that the Naming Context contains bindings.

_ids

public String[] _ids()
Description copied from class: ObjectImpl
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.

Specified by:
_ids in class ObjectImpl
Returns:
the array of all repository identifiers supported by this ObjectImpl instance
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NamingContextHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class NamingContextHelper

java.lang.Object
    extended by  org.omg.CosNaming.NamingContextHelper

public abstract class NamingContextHelper
extends Object

A naming context is an object that contains a set of name bindings in which each name is unique. Different names can be bound to an object in the same or different contexts at the same time.

See CORBA COS Naming Specification.

Constructor Summary
Constructor and Description
NamingContextHelper()
Method Summary
Modifier and Type | Method and Description
static NamingContext | extract(Any a)
static String | id()
static void | insert(Any a, NamingContext that)
static NamingContext | narrow(Object obj)
static NamingContext | read(InputStream istream)
static TypeCode | type()
static NamingContext | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, NamingContext value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NamingContextHelper

public NamingContextHelper()
Method Detail

insert

public static void insert(Any a,
                          NamingContext that)

extract

public static NamingContext extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NamingContext read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NamingContext value)

narrow

public static NamingContext narrow(Object obj)

unchecked_narrow

public static NamingContext unchecked_narrow(Object obj)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NamingContextHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class NamingContextHolder

java.lang.Object
    extended by  org.omg.CosNaming.NamingContextHolder
All Implemented Interfaces:
Streamable
public final class NamingContextHolder
extends Object
implements Streamable

A naming context is an object that contains a set of name bindings in which each name is unique. Different names can be bound to an object in the same or different contexts at the same time.

See CORBA COS Naming Specification.

Field Summary
Modifier and Type | Field and Description
NamingContext | value
Constructor Summary
Constructor and Description
NamingContextHolder()
NamingContextHolder(NamingContext initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public NamingContext value
Constructor Detail

NamingContextHolder

public NamingContextHolder()

NamingContextHolder

public NamingContextHolder(NamingContext initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


_NamingContextImplBase (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class _NamingContextImplBase

java.lang.Object
    extended by  org.omg.CORBA.portable.ObjectImpl
        extended by  org.omg.CORBA.DynamicImplementation
            extended by  org.omg.CosNaming._NamingContextImplBase
All Implemented Interfaces:
Serializable, Object, IDLEntity, NamingContext, NamingContextOperations
public abstract class _NamingContextImplBase
extends DynamicImplementation
implements NamingContext

See Also:
Serialized Form

Constructor Summary
Constructor and Description
_NamingContextImplBase()
Method Summary
Modifier and Type | Method and Description
String[] | _ids() Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
void | invoke(ServerRequest r)
Methods inherited from class org.omg.CORBA.portable.ObjectImpl
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.omg.CosNaming.NamingContextOperations
bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Constructor Detail

_NamingContextImplBase

public _NamingContextImplBase()
Method Detail

_ids

public String[] _ids()
Description copied from class: ObjectImpl
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.

Overrides:
_ids in class DynamicImplementation
Returns:
the array of all repository identifiers supported by this ObjectImpl instance

invoke

public void invoke(ServerRequest r)
Overrides:
invoke in class DynamicImplementation
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NamingContextOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Interface NamingContextOperations

All Known Subinterfaces:
NamingContext, NamingContextExt, NamingContextExtOperations
All Known Implementing Classes:
_NamingContextExtStub, _NamingContextImplBase, _NamingContextStub, NamingContextExtPOA, NamingContextPOA
public interface NamingContextOperations

A naming context is an object that contains a set of name bindings in which each name is unique. Different names can be bound to an object in the same or different contexts at the same time.

See CORBA COS Naming Specification.

Method Summary
Modifier and Type | Method and Description
void | bind_context(NameComponent[] n, NamingContext nc) Names an object that is a naming context.
NamingContext | bind_new_context(NameComponent[] n) This operation creates a new context and binds it to the name supplied as an argument.
void | bind(NameComponent[] n, Object obj) Creates a binding of a name and an object in the naming context.
void | destroy() The destroy operation deletes a naming context.
void | list(int how_many, BindingListHolder bl, BindingIteratorHolder bi) The list operation allows a client to iterate through a set of bindings in a naming context.
NamingContext | new_context() This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked.
void | rebind_context(NameComponent[] n, NamingContext nc) Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
void | rebind(NameComponent[] n, Object obj) Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
Object | resolve(NameComponent[] n) The resolve operation is the process of retrieving an object bound to a name in a given context.
void | unbind(NameComponent[] n) The unbind operation removes a name binding from a context.

Method Detail

bind

void bind(NameComponent[] n,
          Object obj)
          throws NotFound,
                 CannotProceed,
                 InvalidName,
                 AlreadyBound
Creates a binding of a name and an object in the naming context. Naming contexts that are bound using bind do not participate in name resolution when compound names are passed to be resolved.

Parameters:
n - Name of the object

obj - The Object to bind with the given name

Throws:
NotFound - Indicates the name does not identify a binding.

CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

InvalidName - Indicates that the name is invalid.

AlreadyBound - Indicates an object is already bound to the specified name.

bind_context

void bind_context(NameComponent[] n,
                  NamingContext nc)
                  throws NotFound,
                         CannotProceed,
                         InvalidName,
                         AlreadyBound
Names an object that is a naming context. Naming contexts that are bound using bind_context() participate in name resolution when compound names are passed to be resolved.

Parameters:
n - Name of the object

nc - NamingContect object to bind with the given name

Throws:
NotFound - Indicates the name does not identify a binding.

CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

InvalidName - Indicates that the name is invalid.

AlreadyBound - Indicates an object is already bound to the specified name.

rebind

void rebind(NameComponent[] n,
            Object obj)
            throws NotFound,
                   CannotProceed,
                   InvalidName
Creates a binding of a name and an object in the naming context even if the name is already bound in the context. Naming contexts that are bound using rebind do not participate in name resolution when compound names are passed to be resolved.

Parameters:
n - Name of the object

Throws:
NotFound - Indicates the name does not identify a binding.

CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

InvalidName - Indicates that the name is invalid.

rebind_context

void rebind_context(NameComponent[] n,
                    NamingContext nc)
                    throws NotFound,
                           CannotProceed,
                           InvalidName
Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context. Naming contexts that are bound using rebind_context() participate in name resolution when compound names are passed to be resolved.

Parameters:
n - Name of the object

nc - NamingContect object to rebind with the given name

Throws:
NotFound - Indicates the name does not identify a binding.

CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

InvalidName - Indicates that the name is invalid.

resolve

Object resolve(NameComponent[] n)
               throws NotFound,
                      CannotProceed,
                      InvalidName
The resolve operation is the process of retrieving an object bound to a name in a given context. The given name must exactly match the bound name. The naming service does not return the type of the object. Clients are responsible for "narrowing" the object to the appropriate type. That is, clients typically cast the returned object from Object to a more specialized interface.

Parameters:
n - Name of the object

Throws:
NotFound - Indicates the name does not identify a binding.

CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

InvalidName - Indicates that the name is invalid.

unbind

void unbind(NameComponent[] n)
            throws NotFound,
                   CannotProceed,
                   InvalidName
The unbind operation removes a name binding from a context.

Parameters:
n - Name of the object

Throws:
NotFound - Indicates the name does not identify a binding.

CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

InvalidName - Indicates that the name is invalid.

list

void list(int how_many,
          BindingListHolder bl,
          BindingIteratorHolder bi)
The list operation allows a client to iterate through a set of bindings in a naming context.

The list operation returns at most the requested number of bindings in BindingList bl.

  • If the naming context contains additional bindings, the list operation returns a BindingIterator with the additional bindings.
  • If the naming context does not contain additional bindings, the binding iterator is a nil object reference.

Parameters:
how_many - the maximum number of bindings to return

bl - the returned list of bindings

bi - the returned binding iterator

new_context

NamingContext new_context()
This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked. The new context is not bound to any name.

bind_new_context

NamingContext bind_new_context(NameComponent[] n)
                               throws NotFound,
                                      AlreadyBound,
                                      CannotProceed,
                                      InvalidName
This operation creates a new context and binds it to the name supplied as an argument. The newly-created context is implemented by the same naming server as the context in which it was bound (that is, the naming server that implements the context denoted by the name argument excluding the last component).

Parameters:
n - Name of the object

Throws:
NotFound - Indicates the name does not identify a binding.

AlreadyBound - Indicates an object is already bound to the specified name.

CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

InvalidName - Indicates that the name is invalid.

destroy

void destroy()
             throws NotEmpty
The destroy operation deletes a naming context. If the naming context contains bindings, the NotEmpty exception is raised.

Throws:
NotEmpty - Indicates that the Naming Context contains bindings.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NamingContextPOA (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.CosNaming
Class NamingContextPOA

java.lang.Object
    extended by  org.omg.PortableServer.Servant
        extended by  org.omg.CosNaming.NamingContextPOA
All Implemented Interfaces:
InvokeHandler, NamingContextOperations
public abstract class NamingContextPOA
extends Servant
implements NamingContextOperations, InvokeHandler

A naming context is an object that contains a set of name bindings in which each name is unique. Different names can be bound to an object in the same or different contexts at the same time.

See CORBA COS Naming Specification.

Constructor Summary
Constructor and Description
NamingContextPOA()
Method Summary
Modifier and Type | Method and Description
String[] | _all_interfaces(POA poa, byte[] objectId) Used by the ORB to obtain complete type information from the servant.
OutputStream | _invoke(String $method, InputStream in, ResponseHandler $rh) Invoked by the ORB to dispatch a request to the servant.
NamingContext | _this()
NamingContext | _this(ORB orb)
Methods inherited from class org.omg.PortableServer.Servant
_default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.omg.CosNaming.NamingContextOperations
bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind

Constructor Detail

NamingContextPOA

public NamingContextPOA()
Method Detail

_invoke

public OutputStream _invoke(String $method,
                            InputStream in,
                            ResponseHandler $rh)
Description copied from interface: InvokeHandler
Invoked by the ORB to dispatch a request to the servant. ORB passes the method name, an InputStream containing the marshalled arguments, and a ResponseHandler which the servant uses to construct a proper reply. Only CORBA SystemException may be thrown by this method. The method must return an OutputStream created by the ResponseHandler which contains the marshalled reply. A servant must not retain a reference to the ResponseHandler beyond the lifetime of a method invocation. Servant behaviour is defined as follows:

1. Determine correct method, and unmarshal parameters from InputStream.

2. Invoke method implementation.

3. If no user exception, create a normal reply using ResponseHandler.

4. If user exception occurred, create exception reply using ResponseHandler.

5. Marshal reply into OutputStream returned by ResponseHandler.

6. Return OutputStream to ORB.

Specified by:
_invoke in interface InvokeHandler
Parameters:
$method - The method name.
in - The InputStream containing the marshalled arguments.
$rh - The ResponseHandler which the servant uses to construct a proper reply
Returns:
The OutputStream created by the ResponseHandler which contains the marshalled reply

_all_interfaces

public String[] _all_interfaces(POA poa,
                                byte[] objectId)
Description copied from class: Servant
Used by the ORB to obtain complete type information from the servant.

Specified by:
_all_interfaces in class Servant
Parameters:
poa - POA with which the servant is associated.
objectId - is the id corresponding to the object associated with this servant.
Returns:
list of type information for the object.

_this

public NamingContext _this()

_this

public NamingContext _this(ORB orb)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


_NamingContextStub (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming
Class _NamingContextStub

java.lang.Object
    extended by  org.omg.CORBA.portable.ObjectImpl
        extended by  org.omg.CosNaming._NamingContextStub
All Implemented Interfaces:
Serializable, Object, IDLEntity, NamingContext, NamingContextOperations
public class _NamingContextStub
extends ObjectImpl
implements NamingContext

A naming context is an object that contains a set of name bindings in which each name is unique. Different names can be bound to an object in the same or different contexts at the same time.

See CORBA COS Naming Specification.

See Also:
Serialized Form

Constructor Summary
Constructor and Description
_NamingContextStub()
Method Summary
Modifier and Type | Method and Description
String[] | _ids() Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
void | bind_context(NameComponent[] n, NamingContext nc) Names an object that is a naming context.
NamingContext | bind_new_context(NameComponent[] n) This operation creates a new context and binds it to the name supplied as an argument.
void | bind(NameComponent[] n, Object obj) Creates a binding of a name and an object in the naming context.
void | destroy() The destroy operation deletes a naming context.
void | list(int how_many, BindingListHolder bl, BindingIteratorHolder bi) The list operation allows a client to iterate through a set of bindings in a naming context.
NamingContext | new_context() This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked.
void | rebind_context(NameComponent[] n, NamingContext nc) Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
void | rebind(NameComponent[] n, Object obj) Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
Object | resolve(NameComponent[] n) The resolve operation is the process of retrieving an object bound to a name in a given context.
void | unbind(NameComponent[] n) The unbind operation removes a name binding from a context.
Methods inherited from class org.omg.CORBA.portable.ObjectImpl
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Constructor Detail

_NamingContextStub

public _NamingContextStub()
Method Detail

bind

public void bind(NameComponent[] n,
                 Object obj)
          throws NotFound,
                 CannotProceed,
                 InvalidName,
                 AlreadyBound
Creates a binding of a name and an object in the naming context. Naming contexts that are bound using bind do not participate in name resolution when compound names are passed to be resolved.

Specified by:
bind in interface NamingContextOperations
Parameters:
n - Name of the object

obj - The Object to bind with the given name

Throws:
NotFound - Indicates the name does not identify a binding.

CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

InvalidName - Indicates that the name is invalid.

AlreadyBound - Indicates an object is already bound to the specified name.

bind_context

public void bind_context(NameComponent[] n,
                         NamingContext nc)
                  throws NotFound,
                         CannotProceed,
                         InvalidName,
                         AlreadyBound
Names an object that is a naming context. Naming contexts that are bound using bind_context() participate in name resolution when compound names are passed to be resolved.

Specified by:
bind_context in interface NamingContextOperations
Parameters:
n - Name of the object

nc - NamingContect object to bind with the given name

Throws:
NotFound - Indicates the name does not identify a binding.

CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

InvalidName - Indicates that the name is invalid.

AlreadyBound - Indicates an object is already bound to the specified name.

rebind

public void rebind(NameComponent[] n,
                   Object obj)
            throws NotFound,
                   CannotProceed,
                   InvalidName
Creates a binding of a name and an object in the naming context even if the name is already bound in the context. Naming contexts that are bound using rebind do not participate in name resolution when compound names are passed to be resolved.

Specified by:
rebind in interface NamingContextOperations
Parameters:
n - Name of the object

Throws:
NotFound - Indicates the name does not identify a binding.

CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

InvalidName - Indicates that the name is invalid.

rebind_context

public void rebind_context(NameComponent[] n,
                           NamingContext nc)
                    throws NotFound,
                           CannotProceed,
                           InvalidName
Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context. Naming contexts that are bound using rebind_context() participate in name resolution when compound names are passed to be resolved.

Specified by:
rebind_context in interface NamingContextOperations
Parameters:
n - Name of the object

nc - NamingContect object to rebind with the given name

Throws:
NotFound - Indicates the name does not identify a binding.

CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

InvalidName - Indicates that the name is invalid.

resolve

public Object resolve(NameComponent[] n)
               throws NotFound,
                      CannotProceed,
                      InvalidName
The resolve operation is the process of retrieving an object bound to a name in a given context. The given name must exactly match the bound name. The naming service does not return the type of the object. Clients are responsible for "narrowing" the object to the appropriate type. That is, clients typically cast the returned object from Object to a more specialized interface.

Specified by:
resolve in interface NamingContextOperations
Parameters:
n - Name of the object

Throws:
NotFound - Indicates the name does not identify a binding.

CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

InvalidName - Indicates that the name is invalid.

unbind

public void unbind(NameComponent[] n)
            throws NotFound,
                   CannotProceed,
                   InvalidName
The unbind operation removes a name binding from a context.

Specified by:
unbind in interface NamingContextOperations
Parameters:
n - Name of the object

Throws:
NotFound - Indicates the name does not identify a binding.

CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

InvalidName - Indicates that the name is invalid.

list

public void list(int how_many,
                 BindingListHolder bl,
                 BindingIteratorHolder bi)
The list operation allows a client to iterate through a set of bindings in a naming context.

The list operation returns at most the requested number of bindings in BindingList bl.

  • If the naming context contains additional bindings, the list operation returns a BindingIterator with the additional bindings.
  • If the naming context does not contain additional bindings, the binding iterator is a nil object reference.

Specified by:
list in interface NamingContextOperations
Parameters:
how_many - the maximum number of bindings to return

bl - the returned list of bindings

bi - the returned binding iterator

new_context

public NamingContext new_context()
This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked. The new context is not bound to any name.

Specified by:
new_context in interface NamingContextOperations

bind_new_context

public NamingContext bind_new_context(NameComponent[] n)
                               throws NotFound,
                                      AlreadyBound,
                                      CannotProceed,
                                      InvalidName
This operation creates a new context and binds it to the name supplied as an argument. The newly-created context is implemented by the same naming server as the context in which it was bound (that is, the naming server that implements the context denoted by the name argument excluding the last component).

Specified by:
bind_new_context in interface NamingContextOperations
Parameters:
n - Name of the object

Throws:
NotFound - Indicates the name does not identify a binding.

AlreadyBound - Indicates an object is already bound to the specified name.

CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

InvalidName - Indicates that the name is invalid.

destroy

public void destroy()
             throws NotEmpty
The destroy operation deletes a naming context. If the naming context contains bindings, the NotEmpty exception is raised.

Specified by:
destroy in interface NamingContextOperations
Throws:
NotEmpty - Indicates that the Naming Context contains bindings.

_ids

public String[] _ids()
Description copied from class: ObjectImpl
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.

Specified by:
_ids in class ObjectImpl
Returns:
the array of all repository identifiers supported by this ObjectImpl instance
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


org.omg.CosNaming (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.CosNaming

Provides a naming service for Java IDL.

See:
Description

Interface Summary
Interface | Description
BindingIterator | The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
BindingIteratorOperations | The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
NamingContext | A naming context is an object that contains a set of name bindings in which each name is unique.
NamingContextExt | NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
NamingContextExtOperations | NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
NamingContextOperations | A naming context is an object that contains a set of name bindings in which each name is unique.

Class Summary
Class | Description
_BindingIteratorImplBase |
_BindingIteratorStub | The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
_NamingContextExtStub | NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
_NamingContextImplBase |
_NamingContextStub | A naming context is an object that contains a set of name bindings in which each name is unique.
Binding | org/omg/CosNaming/Binding.java .
BindingHelper | org/omg/CosNaming/BindingHelper.java .
BindingHolder | org/omg/CosNaming/BindingHolder.java .
BindingIteratorHelper | The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
BindingIteratorHolder | The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
BindingIteratorPOA | The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
BindingListHelper | List of Bindings.
BindingListHolder | List of Bindings.
BindingType | Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.
BindingTypeHelper | Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.
BindingTypeHolder | Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.
IstringHelper | org/omg/CosNaming/IstringHelper.java .
NameComponent | org/omg/CosNaming/NameComponent.java .
NameComponentHelper | org/omg/CosNaming/NameComponentHelper.java .
NameComponentHolder | org/omg/CosNaming/NameComponentHolder.java .
NameHelper | A name is a sequence of name components.
NameHolder | A name is a sequence of name components.
NamingContextExtHelper | NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
NamingContextExtHolder | NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
NamingContextExtPOA | NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
NamingContextHelper | A naming context is an object that contains a set of name bindings in which each name is unique.
NamingContextHolder | A naming context is an object that contains a set of name bindings in which each name is unique.
NamingContextPOA | A naming context is an object that contains a set of name bindings in which each name is unique.

Package org.omg.CosNaming Description

Provides a naming service for Java IDL. The Object Request Broker Daemon (ORBD) also includes both a transient and persistent naming service.

The package and all its classes and interfaces were generated by running the tool idlj on the file nameservice.idl, which is a module written in OMG IDL.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6, ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Interfaces

The package org.omg.CosNaming contains two public interfaces and several auxiliary classes.

The interfaces are:

  • NamingContext
  • BindingIterator

These two interfaces provide the means to bind/unbind names and object references, to retrieve bound object references, and to iterate through a list of bindings. The NamingContext interface supplies the main functionality for the naming service, and BindingIterator provides a means of iterating through a list of name/object reference bindings.

Auxiliary Classes

In order to map an OMG IDL interface to the Java programming language, the idlj compiler creates Java classes that can be thought of as auxiliary classes. Comments for the generated auxiliary classes used by the interfaces NamingContext and BindingIterator are included here.

Classes Used by NamingContext and BindingIterator

The following are classes used by the naming service. (Helper and holder classes, which are generated for each of the classes listed here, are discussed below.)
  • public final class NameComponent -- a building block for names. (Names are bound to object references in a naming context.)

    A name is an array of one or more NameComponent objects. A name with a single NameComponent is called a simple name; a name with multiple NameComponent objects is called a compound name.

    A NameComponent object consists of two fields:

    1. id -- a String used as an identifier
    2. kind -- a String that can be used for any descriptive purpose. Its importance is that it can be used to describe an object without affecting syntax. The C programming language, for example, uses the the syntactic convention of appending the extension ".c" to a file name to indicate that it is a source code file. In a NameComponent object, the kind field can be used to describe the type of object rather than a file extension or some other syntactic convention. Examples of the value of the kind field include the strings "c_source", "object_code", "executable", "postscript", and "". It is not unusual for the kind field to be the empty string.

    In a name, each NameComponent object except the last denotes a NamingContext object; the last NameComponent object denotes the bound object reference. This is similar to a path name, in which the last name is the file name, and all names before it are directory names.

  • public final class Binding -- an object that associates a name with an object reference or a naming context. A Binding object has two fields:
    1. binding_name - an array of one or more NameComponent objects that represents the bound name
    2. binding_type - a BindingType object indicating whether the binding is between a name and an object reference or between a name and a naming context

    The interface NamingContext has methods for binding/unbinding names with object references or naming contexts, for listing bindings, and for resolving bindings (given a name, the method resolve returns the object reference bound to it).

  • public final class BindingType -- an object that specifies whether the given Binding object is a binding between a name and an object reference (that is, not a naming context) or between a name and a naming context.

    The classBindingType consists of two methods and four constants. Two of these constants are BindingType objects, and two are ints.

    The BindingType objects can be passed to the constructor for the class Binding or used as parameters or return values. These BindingType objects are:

    • public static final BindingType nobject -- to indicate that the binding is with an object reference
    • public static final BindingType ncontext -- to indicate that the binding is with a naming context

    The int constants can be supplied to the method from_int to create BindingType objects, or they can be return values for the method value. These constants are:

    • public static final int _nobject
    • public static final int _ncontext
    If the method from_int is supplied with anything other than _nobject or _ncontext, it will throw the exception org.omg.CORBA.BAD_PARAM.

    Usage is as follows:

           BindingType btObject = from_int(_nobject);
       BindingType btContext = from_int(_ncontext);
    The variable btObject refers to a BindingType object initialized to represent a binding with an object reference. The variable btContext refers to a BindingType object initialized to represent a binding with a NamingContex object.

    The method value returns either _nobject or _ncontext, so in the following line of code, the variable bt will contain _nobject or _ncontext:

           int bt = BindingType.value();

Holder Classes

OMG IDL uses OUT and INOUT parameters for returning values from operations. The mapping to the Java programming language, which does not have OUT and INOUT parameters, creates a special class for each type, called a holder class. An instance of a holder class can be passed to a Java method as a parameter, and a value can be assigned to its value field. This allows it to perform the function of an OUT or INOUT parameter.

The following holder classes are generated for the package org.omg.CosNaming:

  • NamingContextHolder
  • BindingIteratorHolder
  • BindingHolder
  • BindingListHolder
  • BindingTypeHolder
  • NameComponentHolder
  • NameHolder

Note that in the org.omg.CORBA package, there is a holder class for each of the basic Java types: IntHolder, ShortHolder, StringHolder, and so on.

Note also that there is a NameHolder class even though there is no Name class; similarly, there is a BindingListHolder class even though there is no BindingList class. This is true because in the OMG IDL interface, Name and BindingList are typedefs. There is no mapping from an IDL typedef to a Java construct, but holder classes are generated if the typedef is for a sequence or an array. As mapped to the Java programming language, Name is an array of NameComponent objects, and a BindingList is an array of Binding objects. All holder classes have at least two constructors and one field:

  • value field -- an instance of the type being used as an OUT or INOUT parameter. For example, the value field of a NamingContextHolder will be a NamingContext object.
  • default constructor -- a constructor that creates a new holder object initialized with the default value for the type. For example, a new BindingHolder object created with the default constructor will have its value field set to null because that is the default value for an object. Other defaults are false for boolean, 0 for numeric and char types, and null for object references.
  • constructor from an instance -- a constructor that creates a new holder object whose value field is initialized with the instance supplied

A holder class for a user-defined type (a Java class) has three more methods, but application developers do not use them directly.

Helper Classes

Helper classes, which are generated for all user-defined types in an OMG IDL interface, supply static methods needed to manipulate those types.

There is only one method in a helper class that an application programmer uses: the method narrow. Only Java interfaces mapped from IDL interfaces will have a helper class that includes a narrow method, so in the CosNaming package, only the classes NamingContextHelper and BindingIteratorHelper have a narrow method.

  • public static NamingContext narrow(org.omg.CORBA.Object obj) -- converts the given CORBA object to a NamingContext object
  • public static BindingIterator narrow(org.omg.CORBA.Object obj) -- converts the given CORBA object to a BindingIterator object

Package org.omg.CosNaming.NamingContextPackage

This package supplies Helper and Holder classes for the exceptions used in the package org.omg.CosNaming and also for the class NotFoundReason, which supplies a reason for the exception NotFound.

There are Helper and Holder classes for the following exceptions:

  • AlreadyBound
  • CannotProceed
  • InvalidName
  • NotEmpty
  • NotFound

Naming Service Compatibility

Sun's implementation of the CosNaming package complies with the OMG COSNaming specification. In other words, the APIs in Sun's naming service are implemented according to the guidelines for a naming service provided by OMG. Therefore, if a third-party vendor has implemented a naming service that is OMG compliant, it is possible to switch between Sun's implementation of CosNaming and the third-party vendor's implementation. However, it is important to understand that there can be minor variations in the way different vendors implement the naming service, such as differences in the exception strings.

Instructions for Using a Third Party's Naming Service

Although we encourage using an ORB and ORB services that are both from one vendor, it is possible to plug in a third party's COSNaming implementation with Sun's RMI-IIOP ORB. Here are the steps to follow:
  1. Create a properties file for the Bootstrap server and give it two entries. For example, you could call this properties file /tmp/services and put the following in it: NameService, <Stringified IOR of the Root Naming Context>.

    This associates NameService with the Root Naming Context of the CosNaming implementation that you want to use.

  2. Start the standalone Bootstrap server using the following command:

      java -classpath $(CLASSPATH)
      com.sun.corba.ee.internal.CosNaming.BootstrapServer -InitialServicesFile
      "/tmp/services" [-ORBInitialPort port]

    Note that the square brackets at the end of the command indicate that specifying a port number is optional.

Now when an application calls the method org.omg.CORBA.ORB.resolve_initial_references, CORBA processes will contact the Bootstrap Server to get the Root Naming Context.

Package Specification

  • Interoperable Naming Service (ptc/00-08-07)

Related Documentation

For an overview and examples of how to use the CosNaming API, please see:
  • Naming Service

For an overview of Java IDL, please see:

  • Java IDL home page

Since:
JDK1.3
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


AddressHelper (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.CosNaming.NamingContextExtPackage
Class AddressHelper

java.lang.Object
    extended by  org.omg.CosNaming.NamingContextExtPackage.AddressHelper

public abstract class AddressHelper
extends Object

Address is the Host and Port information represented as a String.

Constructor Summary
Constructor and Description
AddressHelper()
Method Summary
Modifier and Type | Method and Description
static String | extract(Any a)
static String | id()
static void | insert(Any a, String that)
static String | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AddressHelper

public AddressHelper()
Method Detail

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


InvalidAddress (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming.NamingContextExtPackage
Class InvalidAddress

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.CosNaming.NamingContextExtPackage.InvalidAddress
All Implemented Interfaces:
Serializable, IDLEntity
public final class InvalidAddress
extends UserException

org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
InvalidAddress()
InvalidAddress(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidAddress

public InvalidAddress()

InvalidAddress

public InvalidAddress(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


InvalidAddressHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming.NamingContextExtPackage
Class InvalidAddressHelper

java.lang.Object
    extended by  org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper

public abstract class InvalidAddressHelper
extends Object

org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
InvalidAddressHelper()
Method Summary
Modifier and Type | Method and Description
static InvalidAddress | extract(Any a)
static String | id()
static void | insert(Any a, InvalidAddress that)
static InvalidAddress | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, InvalidAddress value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InvalidAddressHelper

public InvalidAddressHelper()
Method Detail

insert

public static void insert(Any a,
                          InvalidAddress that)

extract

public static InvalidAddress extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static InvalidAddress read(InputStream istream)

write

public static void write(OutputStream ostream,
                         InvalidAddress value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


InvalidAddressHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming.NamingContextExtPackage
Class InvalidAddressHolder

java.lang.Object
    extended by  org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder
All Implemented Interfaces:
Streamable
public final class InvalidAddressHolder
extends Object
implements Streamable

org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

Field Summary
Modifier and Type | Field and Description
InvalidAddress | value
Constructor Summary
Constructor and Description
InvalidAddressHolder()
InvalidAddressHolder(InvalidAddress initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public InvalidAddress value
Constructor Detail

InvalidAddressHolder

public InvalidAddressHolder()

InvalidAddressHolder

public InvalidAddressHolder(InvalidAddress initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


org.omg.CosNaming.NamingContextExtPackage (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.CosNaming.NamingContextExtPackage

This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:

See:
Description

Class Summary
Class | Description
AddressHelper | Address is the Host and Port information represented as a String.
InvalidAddressHelper | org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHelper.java .
InvalidAddressHolder | org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHolder.java .
StringNameHelper | StringName is the Stringified Name, Array of Name Components represented as a String.
URLStringHelper | URLString is the URL address (corbaloc: or corbaname:) represented as a String.

Exception Summary
Exception | Description
InvalidAddress | org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java .

Package org.omg.CosNaming.NamingContextExtPackage Description

This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:

  • AddressHelper
  • StringNameHelper
  • URLStringHelper
  • InvalidAddress

    Package Specification

    For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

    Since:
    1.4
    Overview Package Class Use Tree Deprecated Index Help
            Java™ Platform
    Standard Ed. 7
    DRAFT ea-b59
    PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


StringNameHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming.NamingContextExtPackage
Class StringNameHelper

java.lang.Object
    extended by  org.omg.CosNaming.NamingContextExtPackage.StringNameHelper

public abstract class StringNameHelper
extends Object

StringName is the Stringified Name, Array of Name Components represented as a String.

Constructor Summary
Constructor and Description
StringNameHelper()
Method Summary
Modifier and Type | Method and Description
static String | extract(Any a)
static String | id()
static void | insert(Any a, String that)
static String | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StringNameHelper

public StringNameHelper()
Method Detail

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


URLStringHelper (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.CosNaming.NamingContextExtPackage
Class URLStringHelper

java.lang.Object
    extended by  org.omg.CosNaming.NamingContextExtPackage.URLStringHelper

public abstract class URLStringHelper
extends Object

URLString is the URL address (corbaloc: or corbaname:) represented as a String.

Constructor Summary
Constructor and Description
URLStringHelper()
Method Summary
Modifier and Type | Method and Description
static String | extract(Any a)
static String | id()
static void | insert(Any a, String that)
static String | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

URLStringHelper

public URLStringHelper()
Method Detail

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AlreadyBound (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.CosNaming.NamingContextPackage
Class AlreadyBound

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.CosNaming.NamingContextPackage.AlreadyBound
All Implemented Interfaces:
Serializable, IDLEntity
public final class AlreadyBound
extends UserException

org/omg/CosNaming/NamingContextPackage/AlreadyBound.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
AlreadyBound()
AlreadyBound(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

AlreadyBound

public AlreadyBound()

AlreadyBound

public AlreadyBound(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AlreadyBoundHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming.NamingContextPackage
Class AlreadyBoundHelper

java.lang.Object
    extended by  org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper

public abstract class AlreadyBoundHelper
extends Object

org/omg/CosNaming/NamingContextPackage/AlreadyBoundHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
AlreadyBoundHelper()
Method Summary
Modifier and Type | Method and Description
static AlreadyBound | extract(Any a)
static String | id()
static void | insert(Any a, AlreadyBound that)
static AlreadyBound | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, AlreadyBound value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AlreadyBoundHelper

public AlreadyBoundHelper()
Method Detail

insert

public static void insert(Any a,
                          AlreadyBound that)

extract

public static AlreadyBound extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static AlreadyBound read(InputStream istream)

write

public static void write(OutputStream ostream,
                         AlreadyBound value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


AlreadyBoundHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming.NamingContextPackage
Class AlreadyBoundHolder

java.lang.Object
    extended by  org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder
All Implemented Interfaces:
Streamable
public final class AlreadyBoundHolder
extends Object
implements Streamable

org/omg/CosNaming/NamingContextPackage/AlreadyBoundHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

Field Summary
Modifier and Type | Field and Description
AlreadyBound | value
Constructor Summary
Constructor and Description
AlreadyBoundHolder()
AlreadyBoundHolder(AlreadyBound initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public AlreadyBound value
Constructor Detail

AlreadyBoundHolder

public AlreadyBoundHolder()

AlreadyBoundHolder

public AlreadyBoundHolder(AlreadyBound initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


CannotProceed (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming.NamingContextPackage
Class CannotProceed

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.CosNaming.NamingContextPackage.CannotProceed
All Implemented Interfaces:
Serializable, IDLEntity
public final class CannotProceed
extends UserException

org/omg/CosNaming/NamingContextPackage/CannotProceed.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

Field Summary
Modifier and Type | Field and Description
NamingContext | cxt
NameComponent[] | rest_of_name
Constructor Summary
Constructor and Description
CannotProceed()
CannotProceed(NamingContext _cxt, NameComponent[] _rest_of_name)
CannotProceed(String $reason, NamingContext _cxt, NameComponent[] _rest_of_name)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

cxt

public NamingContext cxt

rest_of_name

public NameComponent[] rest_of_name
Constructor Detail

CannotProceed

public CannotProceed()

CannotProceed

public CannotProceed(NamingContext _cxt,
                     NameComponent[] _rest_of_name)

CannotProceed

public CannotProceed(String $reason,
                     NamingContext _cxt,
                     NameComponent[] _rest_of_name)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


CannotProceedHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming.NamingContextPackage
Class CannotProceedHelper

java.lang.Object
    extended by  org.omg.CosNaming.NamingContextPackage.CannotProceedHelper

public abstract class CannotProceedHelper
extends Object

org/omg/CosNaming/NamingContextPackage/CannotProceedHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
CannotProceedHelper()
Method Summary
Modifier and Type | Method and Description
static CannotProceed | extract(Any a)
static String | id()
static void | insert(Any a, CannotProceed that)
static CannotProceed | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, CannotProceed value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CannotProceedHelper

public CannotProceedHelper()
Method Detail

insert

public static void insert(Any a,
                          CannotProceed that)

extract

public static CannotProceed extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static CannotProceed read(InputStream istream)

write

public static void write(OutputStream ostream,
                         CannotProceed value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


CannotProceedHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming.NamingContextPackage
Class CannotProceedHolder

java.lang.Object
    extended by  org.omg.CosNaming.NamingContextPackage.CannotProceedHolder
All Implemented Interfaces:
Streamable
public final class CannotProceedHolder
extends Object
implements Streamable

org/omg/CosNaming/NamingContextPackage/CannotProceedHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

Field Summary
Modifier and Type | Field and Description
CannotProceed | value
Constructor Summary
Constructor and Description
CannotProceedHolder()
CannotProceedHolder(CannotProceed initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public CannotProceed value
Constructor Detail

CannotProceedHolder

public CannotProceedHolder()

CannotProceedHolder

public CannotProceedHolder(CannotProceed initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


InvalidName (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming.NamingContextPackage
Class InvalidName

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.CosNaming.NamingContextPackage.InvalidName
All Implemented Interfaces:
Serializable, IDLEntity
public final class InvalidName
extends UserException

org/omg/CosNaming/NamingContextPackage/InvalidName.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
InvalidName()
InvalidName(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidName

public InvalidName()

InvalidName

public InvalidName(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


InvalidNameHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming.NamingContextPackage
Class InvalidNameHelper

java.lang.Object
    extended by  org.omg.CosNaming.NamingContextPackage.InvalidNameHelper

public abstract class InvalidNameHelper
extends Object

org/omg/CosNaming/NamingContextPackage/InvalidNameHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
InvalidNameHelper()
Method Summary
Modifier and Type | Method and Description
static InvalidName | extract(Any a)
static String | id()
static void | insert(Any a, InvalidName that)
static InvalidName | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, InvalidName value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InvalidNameHelper

public InvalidNameHelper()
Method Detail

insert

public static void insert(Any a,
                          InvalidName that)

extract

public static InvalidName extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static InvalidName read(InputStream istream)

write

public static void write(OutputStream ostream,
                         InvalidName value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


InvalidNameHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming.NamingContextPackage
Class InvalidNameHolder

java.lang.Object
    extended by  org.omg.CosNaming.NamingContextPackage.InvalidNameHolder
All Implemented Interfaces:
Streamable
public final class InvalidNameHolder
extends Object
implements Streamable

org/omg/CosNaming/NamingContextPackage/InvalidNameHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

Field Summary
Modifier and Type | Field and Description
InvalidName | value
Constructor Summary
Constructor and Description
InvalidNameHolder()
InvalidNameHolder(InvalidName initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public InvalidName value
Constructor Detail

InvalidNameHolder

public InvalidNameHolder()

InvalidNameHolder

public InvalidNameHolder(InvalidName initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NotEmpty (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming.NamingContextPackage
Class NotEmpty

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.CosNaming.NamingContextPackage.NotEmpty
All Implemented Interfaces:
Serializable, IDLEntity
public final class NotEmpty
extends UserException

org/omg/CosNaming/NamingContextPackage/NotEmpty.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
NotEmpty()
NotEmpty(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NotEmpty

public NotEmpty()

NotEmpty

public NotEmpty(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NotEmptyHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming.NamingContextPackage
Class NotEmptyHelper

java.lang.Object
    extended by  org.omg.CosNaming.NamingContextPackage.NotEmptyHelper

public abstract class NotEmptyHelper
extends Object

org/omg/CosNaming/NamingContextPackage/NotEmptyHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
NotEmptyHelper()
Method Summary
Modifier and Type | Method and Description
static NotEmpty | extract(Any a)
static String | id()
static void | insert(Any a, NotEmpty that)
static NotEmpty | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, NotEmpty value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NotEmptyHelper

public NotEmptyHelper()
Method Detail

insert

public static void insert(Any a,
                          NotEmpty that)

extract

public static NotEmpty extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NotEmpty read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NotEmpty value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NotEmptyHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming.NamingContextPackage
Class NotEmptyHolder

java.lang.Object
    extended by  org.omg.CosNaming.NamingContextPackage.NotEmptyHolder
All Implemented Interfaces:
Streamable
public final class NotEmptyHolder
extends Object
implements Streamable

org/omg/CosNaming/NamingContextPackage/NotEmptyHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

Field Summary
Modifier and Type | Field and Description
NotEmpty | value
Constructor Summary
Constructor and Description
NotEmptyHolder()
NotEmptyHolder(NotEmpty initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public NotEmpty value
Constructor Detail

NotEmptyHolder

public NotEmptyHolder()

NotEmptyHolder

public NotEmptyHolder(NotEmpty initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NotFound (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming.NamingContextPackage
Class NotFound

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.CosNaming.NamingContextPackage.NotFound
All Implemented Interfaces:
Serializable, IDLEntity
public final class NotFound
extends UserException

org/omg/CosNaming/NamingContextPackage/NotFound.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

Field Summary
Modifier and Type | Field and Description
NameComponent[] | rest_of_name
NotFoundReason | why
Constructor Summary
Constructor and Description
NotFound()
NotFound(NotFoundReason _why, NameComponent[] _rest_of_name)
NotFound(String $reason, NotFoundReason _why, NameComponent[] _rest_of_name)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

why

public NotFoundReason why

rest_of_name

public NameComponent[] rest_of_name
Constructor Detail

NotFound

public NotFound()

NotFound

public NotFound(NotFoundReason _why,
                NameComponent[] _rest_of_name)

NotFound

public NotFound(String $reason,
                NotFoundReason _why,
                NameComponent[] _rest_of_name)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NotFoundHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming.NamingContextPackage
Class NotFoundHelper

java.lang.Object
    extended by  org.omg.CosNaming.NamingContextPackage.NotFoundHelper

public abstract class NotFoundHelper
extends Object

org/omg/CosNaming/NamingContextPackage/NotFoundHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
NotFoundHelper()
Method Summary
Modifier and Type | Method and Description
static NotFound | extract(Any a)
static String | id()
static void | insert(Any a, NotFound that)
static NotFound | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, NotFound value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NotFoundHelper

public NotFoundHelper()
Method Detail

insert

public static void insert(Any a,
                          NotFound that)

extract

public static NotFound extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NotFound read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NotFound value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NotFoundHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming.NamingContextPackage
Class NotFoundHolder

java.lang.Object
    extended by  org.omg.CosNaming.NamingContextPackage.NotFoundHolder
All Implemented Interfaces:
Streamable
public final class NotFoundHolder
extends Object
implements Streamable

org/omg/CosNaming/NamingContextPackage/NotFoundHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, May 14, 2009 3:15:25 AM PDT

Field Summary
Modifier and Type | Field and Description
NotFound | value
Constructor Summary
Constructor and Description
NotFoundHolder()
NotFoundHolder(NotFound initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public NotFound value
Constructor Detail

NotFoundHolder

public NotFoundHolder()

NotFoundHolder

public NotFoundHolder(NotFound initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NotFoundReason (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming.NamingContextPackage
Class NotFoundReason

java.lang.Object
    extended by  org.omg.CosNaming.NamingContextPackage.NotFoundReason
All Implemented Interfaces:
Serializable, IDLEntity
public class NotFoundReason
extends Object
implements IDLEntity

Indicates the reason for not able to resolve.

Field Summary
Modifier and Type | Field and Description
static int | _missing_node
static int | _not_context
static int | _not_object
static NotFoundReason | missing_node
static NotFoundReason | not_context
static NotFoundReason | not_object
Constructor Summary
Modifier | Constructor and Description
protected | NotFoundReason(int value)
Method Summary
Modifier and Type | Method and Description
static NotFoundReason | from_int(int value)
int | value()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_missing_node

public static final int _missing_node
See Also:
Constant Field Values

missing_node

public static final NotFoundReason missing_node

_not_context

public static final int _not_context
See Also:
Constant Field Values

not_context

public static final NotFoundReason not_context

_not_object

public static final int _not_object
See Also:
Constant Field Values

not_object

public static final NotFoundReason not_object
Constructor Detail

NotFoundReason

protected NotFoundReason(int value)
Method Detail

value

public int value()

from_int

public static NotFoundReason from_int(int value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NotFoundReasonHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.CosNaming.NamingContextPackage
Class NotFoundReasonHelper

java.lang.Object
    extended by  org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper

public abstract class NotFoundReasonHelper
extends Object

Indicates the reason for not able to resolve.

Constructor Summary
Constructor and Description
NotFoundReasonHelper()
Method Summary
Modifier and Type | Method and Description
static NotFoundReason | extract(Any a)
static String | id()
static void | insert(Any a, NotFoundReason that)
static NotFoundReason | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, NotFoundReason value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NotFoundReasonHelper

public NotFoundReasonHelper()
Method Detail

insert

public static void insert(Any a,
                          NotFoundReason that)

extract

public static NotFoundReason extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NotFoundReason read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NotFoundReason value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NotFoundReasonHolder (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.CosNaming.NamingContextPackage
Class NotFoundReasonHolder

java.lang.Object
    extended by  org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder
All Implemented Interfaces:
Streamable
public final class NotFoundReasonHolder
extends Object
implements Streamable

Indicates the reason for not able to resolve.

Field Summary
Modifier and Type | Field and Description
NotFoundReason | value
Constructor Summary
Constructor and Description
NotFoundReasonHolder()
NotFoundReasonHolder(NotFoundReason initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public NotFoundReason value
Constructor Detail

NotFoundReasonHolder

public NotFoundReasonHolder()

NotFoundReasonHolder

public NotFoundReasonHolder(NotFoundReason initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.omg.CosNaming.NamingContextPackage (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.CosNaming.NamingContextPackage

This package contains Exception classes for the org.omg.CosNaming package.

See:
Description

Class Summary
Class | Description
AlreadyBoundHelper | org/omg/CosNaming/NamingContextPackage/AlreadyBoundHelper.java .
AlreadyBoundHolder | org/omg/CosNaming/NamingContextPackage/AlreadyBoundHolder.java .
CannotProceedHelper | org/omg/CosNaming/NamingContextPackage/CannotProceedHelper.java .
CannotProceedHolder | org/omg/CosNaming/NamingContextPackage/CannotProceedHolder.java .
InvalidNameHelper | org/omg/CosNaming/NamingContextPackage/InvalidNameHelper.java .
InvalidNameHolder | org/omg/CosNaming/NamingContextPackage/InvalidNameHolder.java .
NotEmptyHelper | org/omg/CosNaming/NamingContextPackage/NotEmptyHelper.java .
NotEmptyHolder | org/omg/CosNaming/NamingContextPackage/NotEmptyHolder.java .
NotFoundHelper | org/omg/CosNaming/NamingContextPackage/NotFoundHelper.java .
NotFoundHolder | org/omg/CosNaming/NamingContextPackage/NotFoundHolder.java .
NotFoundReason | Indicates the reason for not able to resolve.
NotFoundReasonHelper | Indicates the reason for not able to resolve.
NotFoundReasonHolder | Indicates the reason for not able to resolve.

Exception Summary
Exception | Description
AlreadyBound | org/omg/CosNaming/NamingContextPackage/AlreadyBound.java .
CannotProceed | org/omg/CosNaming/NamingContextPackage/CannotProceed.java .
InvalidName | org/omg/CosNaming/NamingContextPackage/InvalidName.java .
NotEmpty | org/omg/CosNaming/NamingContextPackage/NotEmpty.java .
NotFound | org/omg/CosNaming/NamingContextPackage/NotFound.java .

Package org.omg.CosNaming.NamingContextPackage Description

This package contains Exception classes for the org.omg.CosNaming package. The list of exception classes are:

  • AlreadyBound
  • CannotProceed
  • InvalidName
  • NotEmpty
  • NotFound
  • NotFoundReason

    Package Specification

    For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java SE 6.

    Since:
    1.4
    Overview Package Class Use Tree Deprecated Index Help
            Java™ Platform
    Standard Ed. 7
    DRAFT ea-b59
    PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


org.omg.Dynamic (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.Dynamic

This package contains the Dynamic module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.9.

See:
Description

Class Summary
Class | Description
Parameter | org/omg/Dynamic/Parameter.java .

Package org.omg.Dynamic Description

This package contains the Dynamic module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.9. Please refer to that OMG specification for further details.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


Parameter (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.Dynamic
Class Parameter

java.lang.Object
    extended by  org.omg.Dynamic.Parameter
All Implemented Interfaces:
Serializable, IDLEntity
public final class Parameter
extends Object
implements IDLEntity

org/omg/Dynamic/Parameter.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Field Summary
Modifier and Type | Field and Description
Any | argument
ParameterMode | mode
Constructor Summary
Constructor and Description
Parameter()
Parameter(Any _argument, ParameterMode _mode)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

argument

public Any argument

mode

public ParameterMode mode
Constructor Detail

Parameter

public Parameter()

Parameter

public Parameter(Any _argument,
                 ParameterMode _mode)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AnySeqHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class AnySeqHelper

java.lang.Object
    extended by  org.omg.DynamicAny.AnySeqHelper

public abstract class AnySeqHelper
extends Object

org/omg/DynamicAny/AnySeqHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
AnySeqHelper()
Method Summary
Modifier and Type | Method and Description
static Any[] | extract(Any a)
static String | id()
static void | insert(Any a, Any[] that)
static Any[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, Any[] value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AnySeqHelper

public AnySeqHelper()
Method Detail

insert

public static void insert(Any a,
                          Any[] that)

extract

public static Any[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static Any[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         Any[] value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynAny (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Interface DynAny

All Superinterfaces:
DynAnyOperations, IDLEntity, Object, Serializable
All Known Subinterfaces:
DynArray, DynEnum, DynFixed, DynSequence, DynStruct, DynUnion, DynValue, DynValueBox, DynValueCommon
All Known Implementing Classes:
_DynAnyStub, _DynArrayStub, _DynEnumStub, _DynFixedStub, _DynSequenceStub, _DynStructStub, _DynUnionStub, _DynValueStub
public interface DynAny
extends DynAnyOperations, Object, IDLEntity

Any values can be dynamically interpreted (traversed) and constructed through DynAny objects. A DynAny object is associated with a data value which corresponds to a copy of the value inserted into an any.

A DynAny object may be viewed as an ordered collection of component DynAnys. For DynAnys representing a basic type, such as long, or a type without components, such as an empty exception, the ordered collection of components is empty. Each DynAny object maintains the notion of a current position into its collection of component DynAnys. The current position is identified by an index value that runs from 0 to n-1, where n is the number of components. The special index value -1 indicates a current position that points nowhere. For values that cannot have a current position (such as an empty exception), the index value is fixed at -1. If a DynAny is initialized with a value that has components, the index is initialized to 0. After creation of an uninitialized DynAny (that is, a DynAny that has no value but a TypeCode that permits components), the current position depends on the type of value represented by the DynAny. (The current position is set to 0 or -1, depending on whether the new DynAny gets default values for its components.)

The iteration operations rewind, seek, and next can be used to change the current position and the current_component operation returns the component at the current position. The component_count operation returns the number of components of a DynAny. Collectively, these operations enable iteration over the components of a DynAny, for example, to (recursively) examine its contents.

A constructed DynAny object is a DynAny object associated with a constructed type. There is a different interface, inheriting from the DynAny interface, associated with each kind of constructed type in IDL (fixed, enum, struct, sequence, union, array, exception, and value type).

A constructed DynAny object exports operations that enable the creation of new DynAny objects, each of them associated with a component of the constructed data value. As an example, a DynStruct is associated with a struct value. This means that the DynStruct may be seen as owning an ordered collection of components, one for each structure member. The DynStruct object exports operations that enable the creation of new DynAny objects, each of them associated with a member of the struct.

If a DynAny object has been obtained from another (constructed) DynAny object, such as a DynAny representing a structure member that was created from a DynStruct, the member DynAny is logically contained in the DynStruct. Calling an insert or get operation leaves the current position unchanged. Destroying a top-level DynAny object (one that was not obtained as a component of another DynAny) also destroys any component DynAny objects obtained from it. Destroying a non-top level DynAny object does nothing. Invoking operations on a destroyed top-level DynAny or any of its descendants raises OBJECT_NOT_EXIST. If the programmer wants to destroy a DynAny object but still wants to manipulate some component of the data value associated with it, then he or she should first create a DynAny for the component and, after that, make a copy of the created DynAny object.

The behavior of DynAny objects has been defined in order to enable efficient implementations in terms of allocated memory space and speed of access. DynAny objects are intended to be used for traversing values extracted from anys or constructing values of anys at runtime. Their use for other purposes is not recommended.

Insert and get operations are necessary to handle basic DynAny objects but are also helpful to handle constructed DynAny objects. Inserting a basic data type value into a constructed DynAny object implies initializing the current component of the constructed data value associated with the DynAny object. For example, invoking insert_boolean on a DynStruct implies inserting a boolean data value at the current position of the associated struct data value. A type is consistent for inserting or extracting a value if its TypeCode is equivalent to the TypeCode contained in the DynAny or, if the DynAny has components, is equivalent to the TypeCode of the DynAny at the current position.

DynAny and DynAnyFactory objects are intended to be local to the process in which they are created and used. This means that references to DynAny and DynAnyFactory objects cannot be exported to other processes, or externalized with ORB.object_to_string(). If any attempt is made to do so, the offending operation will raise a MARSHAL system exception. Since their interfaces are specified in IDL, DynAny objects export operations defined in the standard org.omg.CORBA.Object interface. However, any attempt to invoke operations exported through the Object interface may raise the standard NO_IMPLEMENT exception. An attempt to use a DynAny object with the DII may raise the NO_IMPLEMENT exception.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.DynamicAny.DynAnyOperations
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynAnyFactory (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Interface DynAnyFactory

All Superinterfaces:
DynAnyFactoryOperations, IDLEntity, Object, Serializable
All Known Implementing Classes:
_DynAnyFactoryStub
public interface DynAnyFactory
extends DynAnyFactoryOperations, Object, IDLEntity

DynAny objects can be created by invoking operations on the DynAnyFactory object. Generally there are only two ways to create a DynAny object:

  • invoking an operation on an existing DynAny object
  • invoking an operation on a DynAnyFactory object
A constructed DynAny object supports operations that enable the creation of new DynAny objects encapsulating access to the value of some constituent. DynAny objects also support the copy operation for creating new DynAny objects. A reference to the DynAnyFactory object is obtained by calling ORB.resolve_initial_references() with the identifier parameter set to the string constant "DynAnyFactory".

Dynamic interpretation of an any usually involves creating a DynAny object using create_dyn_any() as the first step. Depending on the type of the any, the resulting DynAny object reference can be narrowed to a DynFixed, DynStruct, DynSequence, DynArray, DynUnion, DynEnum, or DynValue object reference.

Dynamic creation of an any involves creating a DynAny object using create_dyn_any_from_type_code(), passing the TypeCode associated with the value to be created. The returned reference is narrowed to one of the complex types, such as DynStruct, if appropriate. Then, the value can be initialized by means of invoking operations on the resulting object. Finally, the to_any operation can be invoked to create an any value from the constructed DynAny.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.DynamicAny.DynAnyFactoryOperations
create_dyn_any_from_type_code, create_dyn_any
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynAnyFactoryHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class DynAnyFactoryHelper

java.lang.Object
    extended by  org.omg.DynamicAny.DynAnyFactoryHelper

public abstract class DynAnyFactoryHelper
extends Object

DynAny objects can be created by invoking operations on the DynAnyFactory object. Generally there are only two ways to create a DynAny object:

  • invoking an operation on an existing DynAny object
  • invoking an operation on a DynAnyFactory object
A constructed DynAny object supports operations that enable the creation of new DynAny objects encapsulating access to the value of some constituent. DynAny objects also support the copy operation for creating new DynAny objects. A reference to the DynAnyFactory object is obtained by calling ORB.resolve_initial_references() with the identifier parameter set to the string constant "DynAnyFactory".

Dynamic interpretation of an any usually involves creating a DynAny object using create_dyn_any() as the first step. Depending on the type of the any, the resulting DynAny object reference can be narrowed to a DynFixed, DynStruct, DynSequence, DynArray, DynUnion, DynEnum, or DynValue object reference.

Dynamic creation of an any involves creating a DynAny object using create_dyn_any_from_type_code(), passing the TypeCode associated with the value to be created. The returned reference is narrowed to one of the complex types, such as DynStruct, if appropriate. Then, the value can be initialized by means of invoking operations on the resulting object. Finally, the to_any operation can be invoked to create an any value from the constructed DynAny.

Constructor Summary
Constructor and Description
DynAnyFactoryHelper()
Method Summary
Modifier and Type | Method and Description
static DynAnyFactory | extract(Any a)
static String | id()
static void | insert(Any a, DynAnyFactory that)
static DynAnyFactory | narrow(Object obj)
static DynAnyFactory | read(InputStream istream)
static TypeCode | type()
static DynAnyFactory | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, DynAnyFactory value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DynAnyFactoryHelper

public DynAnyFactoryHelper()
Method Detail

insert

public static void insert(Any a,
                          DynAnyFactory that)

extract

public static DynAnyFactory extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static DynAnyFactory read(InputStream istream)

write

public static void write(OutputStream ostream,
                         DynAnyFactory value)

narrow

public static DynAnyFactory narrow(Object obj)

unchecked_narrow

public static DynAnyFactory unchecked_narrow(Object obj)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynAnyFactoryOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Interface DynAnyFactoryOperations

All Known Subinterfaces:
DynAnyFactory
All Known Implementing Classes:
_DynAnyFactoryStub
public interface DynAnyFactoryOperations

DynAny objects can be created by invoking operations on the DynAnyFactory object. Generally there are only two ways to create a DynAny object:

  • invoking an operation on an existing DynAny object
  • invoking an operation on a DynAnyFactory object
A constructed DynAny object supports operations that enable the creation of new DynAny objects encapsulating access to the value of some constituent. DynAny objects also support the copy operation for creating new DynAny objects. A reference to the DynAnyFactory object is obtained by calling ORB.resolve_initial_references() with the identifier parameter set to the string constant "DynAnyFactory".

Dynamic interpretation of an any usually involves creating a DynAny object using create_dyn_any() as the first step. Depending on the type of the any, the resulting DynAny object reference can be narrowed to a DynFixed, DynStruct, DynSequence, DynArray, DynUnion, DynEnum, or DynValue object reference.

Dynamic creation of an any involves creating a DynAny object using create_dyn_any_from_type_code(), passing the TypeCode associated with the value to be created. The returned reference is narrowed to one of the complex types, such as DynStruct, if appropriate. Then, the value can be initialized by means of invoking operations on the resulting object. Finally, the to_any operation can be invoked to create an any value from the constructed DynAny.

Method Summary
Modifier and Type | Method and Description
DynAny | create_dyn_any_from_type_code(TypeCode type) Creates a DynAny from a TypeCode.
DynAny | create_dyn_any(Any value) Creates a new DynAny object from an any value.

Method Detail

create_dyn_any

DynAny create_dyn_any(Any value)
                      throws InconsistentTypeCode
Creates a new DynAny object from an any value. A copy of the TypeCode associated with the any value is assigned to the resulting DynAny object. The value associated with the DynAny object is a copy of the value in the original any. The current position of the created DynAny is set to zero if the passed value has components, to -1 otherwise

Throws:
InconsistentTypeCode - if value has a TypeCode with a TCKind of tk_Principal, tk_native, or tk_abstract_interface

create_dyn_any_from_type_code

DynAny create_dyn_any_from_type_code(TypeCode type)
                                     throws InconsistentTypeCode
Creates a DynAny from a TypeCode. Depending on the TypeCode, the created object may be of type DynAny, or one of its derived types, such as DynStruct. The returned reference can be narrowed to the derived type. In all cases, a DynAny constructed from a TypeCode has an initial default value. The default values of basic types are:
  • false for boolean
  • zero for numeric types
  • zero for types octet, char, and wchar
  • the empty string for string and wstring
  • null for object references
  • a type code with a TCKind value of tk_null for type codes
  • for any values, an any containing a type code with a TCKind value of tk_null type and no value
For complex types, creation of the corresponding DynAny assigns a default value as follows:
  • For DynSequence it sets the current position to -1 and creates an empty sequence.
  • For DynEnum it sets the current position to -1 and sets the value of the enumerator to the first enumerator value indicated by the TypeCode.
  • For DynFixed it sets the current position to -1 and sets the value zero.
  • For DynStruct it sets the current position to -1 for empty exceptions and to zero for all other TypeCodes. The members (if any) are (recursively) initialized to their default values.
  • For DynArray sets the current position to zero and (recursively) initializes elements to their default value.
  • For DynUnion sets the current position to zero. The discriminator value is set to a value consistent with the first named member of the union. That member is activated and (recursively) initialized to its default value.
  • For DynValue and DynValueBox it initializes to a null value.

Throws:
InconsistentTypeCode
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


_DynAnyFactoryStub (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.DynamicAny
Class _DynAnyFactoryStub

java.lang.Object
    extended by  org.omg.CORBA.portable.ObjectImpl
        extended by  org.omg.DynamicAny._DynAnyFactoryStub
All Implemented Interfaces:
Serializable, Object, IDLEntity, DynAnyFactory, DynAnyFactoryOperations
public class _DynAnyFactoryStub
extends ObjectImpl
implements DynAnyFactory

DynAny objects can be created by invoking operations on the DynAnyFactory object. Generally there are only two ways to create a DynAny object:

  • invoking an operation on an existing DynAny object
  • invoking an operation on a DynAnyFactory object
A constructed DynAny object supports operations that enable the creation of new DynAny objects encapsulating access to the value of some constituent. DynAny objects also support the copy operation for creating new DynAny objects. A reference to the DynAnyFactory object is obtained by calling ORB.resolve_initial_references() with the identifier parameter set to the string constant "DynAnyFactory".

Dynamic interpretation of an any usually involves creating a DynAny object using create_dyn_any() as the first step. Depending on the type of the any, the resulting DynAny object reference can be narrowed to a DynFixed, DynStruct, DynSequence, DynArray, DynUnion, DynEnum, or DynValue object reference.

Dynamic creation of an any involves creating a DynAny object using create_dyn_any_from_type_code(), passing the TypeCode associated with the value to be created. The returned reference is narrowed to one of the complex types, such as DynStruct, if appropriate. Then, the value can be initialized by means of invoking operations on the resulting object. Finally, the to_any operation can be invoked to create an any value from the constructed DynAny.

Field Summary
Modifier and Type | Field and Description
static Class | _opsClass
Constructor Summary
Constructor and Description
_DynAnyFactoryStub()
Method Summary
Modifier and Type | Method and Description
String[] | _ids() Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
DynAny | create_dyn_any_from_type_code(TypeCode type) Creates a DynAny from a TypeCode.
DynAny | create_dyn_any(Any value) Creates a new DynAny object from an any value.
Methods inherited from class org.omg.CORBA.portable.ObjectImpl
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Field Detail

_opsClass

public static final Class _opsClass
Constructor Detail

_DynAnyFactoryStub

public _DynAnyFactoryStub()
Method Detail

create_dyn_any

public DynAny create_dyn_any(Any value)
                      throws InconsistentTypeCode
Creates a new DynAny object from an any value. A copy of the TypeCode associated with the any value is assigned to the resulting DynAny object. The value associated with the DynAny object is a copy of the value in the original any. The current position of the created DynAny is set to zero if the passed value has components, to -1 otherwise

Specified by:
create_dyn_any in interface DynAnyFactoryOperations
Throws:
InconsistentTypeCode - if value has a TypeCode with a TCKind of tk_Principal, tk_native, or tk_abstract_interface

create_dyn_any_from_type_code

public DynAny create_dyn_any_from_type_code(TypeCode type)
                                     throws InconsistentTypeCode
Creates a DynAny from a TypeCode. Depending on the TypeCode, the created object may be of type DynAny, or one of its derived types, such as DynStruct. The returned reference can be narrowed to the derived type. In all cases, a DynAny constructed from a TypeCode has an initial default value. The default values of basic types are:
  • false for boolean
  • zero for numeric types
  • zero for types octet, char, and wchar
  • the empty string for string and wstring
  • null for object references
  • a type code with a TCKind value of tk_null for type codes
  • for any values, an any containing a type code with a TCKind value of tk_null type and no value
For complex types, creation of the corresponding DynAny assigns a default value as follows:
  • For DynSequence it sets the current position to -1 and creates an empty sequence.
  • For DynEnum it sets the current position to -1 and sets the value of the enumerator to the first enumerator value indicated by the TypeCode.
  • For DynFixed it sets the current position to -1 and sets the value zero.
  • For DynStruct it sets the current position to -1 for empty exceptions and to zero for all other TypeCodes. The members (if any) are (recursively) initialized to their default values.
  • For DynArray sets the current position to zero and (recursively) initializes elements to their default value.
  • For DynUnion sets the current position to zero. The discriminator value is set to a value consistent with the first named member of the union. That member is activated and (recursively) initialized to its default value.
  • For DynValue and DynValueBox it initializes to a null value.

Specified by:
create_dyn_any_from_type_code in interface DynAnyFactoryOperations
Throws:
InconsistentTypeCode

_ids

public String[] _ids()
Description copied from class: ObjectImpl
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.

Specified by:
_ids in class ObjectImpl
Returns:
the array of all repository identifiers supported by this ObjectImpl instance
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DynAnyHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class DynAnyHelper

java.lang.Object
    extended by  org.omg.DynamicAny.DynAnyHelper

public abstract class DynAnyHelper
extends Object

Any values can be dynamically interpreted (traversed) and constructed through DynAny objects. A DynAny object is associated with a data value which corresponds to a copy of the value inserted into an any.

A DynAny object may be viewed as an ordered collection of component DynAnys. For DynAnys representing a basic type, such as long, or a type without components, such as an empty exception, the ordered collection of components is empty. Each DynAny object maintains the notion of a current position into its collection of component DynAnys. The current position is identified by an index value that runs from 0 to n-1, where n is the number of components. The special index value -1 indicates a current position that points nowhere. For values that cannot have a current position (such as an empty exception), the index value is fixed at -1. If a DynAny is initialized with a value that has components, the index is initialized to 0. After creation of an uninitialized DynAny (that is, a DynAny that has no value but a TypeCode that permits components), the current position depends on the type of value represented by the DynAny. (The current position is set to 0 or -1, depending on whether the new DynAny gets default values for its components.)

The iteration operations rewind, seek, and next can be used to change the current position and the current_component operation returns the component at the current position. The component_count operation returns the number of components of a DynAny. Collectively, these operations enable iteration over the components of a DynAny, for example, to (recursively) examine its contents.

A constructed DynAny object is a DynAny object associated with a constructed type. There is a different interface, inheriting from the DynAny interface, associated with each kind of constructed type in IDL (fixed, enum, struct, sequence, union, array, exception, and value type).

A constructed DynAny object exports operations that enable the creation of new DynAny objects, each of them associated with a component of the constructed data value. As an example, a DynStruct is associated with a struct value. This means that the DynStruct may be seen as owning an ordered collection of components, one for each structure member. The DynStruct object exports operations that enable the creation of new DynAny objects, each of them associated with a member of the struct.

If a DynAny object has been obtained from another (constructed) DynAny object, such as a DynAny representing a structure member that was created from a DynStruct, the member DynAny is logically contained in the DynStruct. Calling an insert or get operation leaves the current position unchanged. Destroying a top-level DynAny object (one that was not obtained as a component of another DynAny) also destroys any component DynAny objects obtained from it. Destroying a non-top level DynAny object does nothing. Invoking operations on a destroyed top-level DynAny or any of its descendants raises OBJECT_NOT_EXIST. If the programmer wants to destroy a DynAny object but still wants to manipulate some component of the data value associated with it, then he or she should first create a DynAny for the component and, after that, make a copy of the created DynAny object.

The behavior of DynAny objects has been defined in order to enable efficient implementations in terms of allocated memory space and speed of access. DynAny objects are intended to be used for traversing values extracted from anys or constructing values of anys at runtime. Their use for other purposes is not recommended.

Insert and get operations are necessary to handle basic DynAny objects but are also helpful to handle constructed DynAny objects. Inserting a basic data type value into a constructed DynAny object implies initializing the current component of the constructed data value associated with the DynAny object. For example, invoking insert_boolean on a DynStruct implies inserting a boolean data value at the current position of the associated struct data value. A type is consistent for inserting or extracting a value if its TypeCode is equivalent to the TypeCode contained in the DynAny or, if the DynAny has components, is equivalent to the TypeCode of the DynAny at the current position.

DynAny and DynAnyFactory objects are intended to be local to the process in which they are created and used. This means that references to DynAny and DynAnyFactory objects cannot be exported to other processes, or externalized with ORB.object_to_string(). If any attempt is made to do so, the offending operation will raise a MARSHAL system exception. Since their interfaces are specified in IDL, DynAny objects export operations defined in the standard org.omg.CORBA.Object interface. However, any attempt to invoke operations exported through the Object interface may raise the standard NO_IMPLEMENT exception. An attempt to use a DynAny object with the DII may raise the NO_IMPLEMENT exception.

Constructor Summary
Constructor and Description
DynAnyHelper()
Method Summary
Modifier and Type | Method and Description
static DynAny | extract(Any a)
static String | id()
static void | insert(Any a, DynAny that)
static DynAny | narrow(Object obj)
static DynAny | read(InputStream istream)
static TypeCode | type()
static DynAny | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, DynAny value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DynAnyHelper

public DynAnyHelper()
Method Detail

insert

public static void insert(Any a,
                          DynAny that)

extract

public static DynAny extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static DynAny read(InputStream istream)

write

public static void write(OutputStream ostream,
                         DynAny value)

narrow

public static DynAny narrow(Object obj)

unchecked_narrow

public static DynAny unchecked_narrow(Object obj)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynAnyOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Interface DynAnyOperations

All Known Subinterfaces:
DynAny, DynArray, DynArrayOperations, DynEnum, DynEnumOperations, DynFixed, DynFixedOperations, DynSequence, DynSequenceOperations, DynStruct, DynStructOperations, DynUnion, DynUnionOperations, DynValue, DynValueBox, DynValueBoxOperations, DynValueCommon, DynValueCommonOperations, DynValueOperations
All Known Implementing Classes:
_DynAnyStub, _DynArrayStub, _DynEnumStub, _DynFixedStub, _DynSequenceStub, _DynStructStub, _DynUnionStub, _DynValueStub
public interface DynAnyOperations

Any values can be dynamically interpreted (traversed) and constructed through DynAny objects. A DynAny object is associated with a data value which corresponds to a copy of the value inserted into an any.

A DynAny object may be viewed as an ordered collection of component DynAnys. For DynAnys representing a basic type, such as long, or a type without components, such as an empty exception, the ordered collection of components is empty. Each DynAny object maintains the notion of a current position into its collection of component DynAnys. The current position is identified by an index value that runs from 0 to n-1, where n is the number of components. The special index value -1 indicates a current position that points nowhere. For values that cannot have a current position (such as an empty exception), the index value is fixed at -1. If a DynAny is initialized with a value that has components, the index is initialized to 0. After creation of an uninitialized DynAny (that is, a DynAny that has no value but a TypeCode that permits components), the current position depends on the type of value represented by the DynAny. (The current position is set to 0 or -1, depending on whether the new DynAny gets default values for its components.)

The iteration operations rewind, seek, and next can be used to change the current position and the current_component operation returns the component at the current position. The component_count operation returns the number of components of a DynAny. Collectively, these operations enable iteration over the components of a DynAny, for example, to (recursively) examine its contents.

A constructed DynAny object is a DynAny object associated with a constructed type. There is a different interface, inheriting from the DynAny interface, associated with each kind of constructed type in IDL (fixed, enum, struct, sequence, union, array, exception, and value type).

A constructed DynAny object exports operations that enable the creation of new DynAny objects, each of them associated with a component of the constructed data value. As an example, a DynStruct is associated with a struct value. This means that the DynStruct may be seen as owning an ordered collection of components, one for each structure member. The DynStruct object exports operations that enable the creation of new DynAny objects, each of them associated with a member of the struct.

If a DynAny object has been obtained from another (constructed) DynAny object, such as a DynAny representing a structure member that was created from a DynStruct, the member DynAny is logically contained in the DynStruct. Calling an insert or get operation leaves the current position unchanged. Destroying a top-level DynAny object (one that was not obtained as a component of another DynAny) also destroys any component DynAny objects obtained from it. Destroying a non-top level DynAny object does nothing. Invoking operations on a destroyed top-level DynAny or any of its descendants raises OBJECT_NOT_EXIST. If the programmer wants to destroy a DynAny object but still wants to manipulate some component of the data value associated with it, then he or she should first create a DynAny for the component and, after that, make a copy of the created DynAny object.

The behavior of DynAny objects has been defined in order to enable efficient implementations in terms of allocated memory space and speed of access. DynAny objects are intended to be used for traversing values extracted from anys or constructing values of anys at runtime. Their use for other purposes is not recommended.

Insert and get operations are necessary to handle basic DynAny objects but are also helpful to handle constructed DynAny objects. Inserting a basic data type value into a constructed DynAny object implies initializing the current component of the constructed data value associated with the DynAny object. For example, invoking insert_boolean on a DynStruct implies inserting a boolean data value at the current position of the associated struct data value. A type is consistent for inserting or extracting a value if its TypeCode is equivalent to the TypeCode contained in the DynAny or, if the DynAny has components, is equivalent to the TypeCode of the DynAny at the current position.

DynAny and DynAnyFactory objects are intended to be local to the process in which they are created and used. This means that references to DynAny and DynAnyFactory objects cannot be exported to other processes, or externalized with ORB.object_to_string(). If any attempt is made to do so, the offending operation will raise a MARSHAL system exception. Since their interfaces are specified in IDL, DynAny objects export operations defined in the standard org.omg.CORBA.Object interface. However, any attempt to invoke operations exported through the Object interface may raise the standard NO_IMPLEMENT exception. An attempt to use a DynAny object with the DII may raise the NO_IMPLEMENT exception.

Method Summary
Modifier and Type Method and Description
 void assign(DynAny dyn_any)
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
 int component_count()
Returns the number of components of a DynAny.
 DynAny copy()
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
 DynAny current_component()
Returns the DynAny for the component at the current position.
 void destroy()
Destroys a DynAny object.
 boolean equal(DynAny dyn_any)
Compares two DynAny values for equality.
 void from_any(Any value)
Initializes the value associated with a DynAny object with the value contained in an any.
 Any get_any()
Extracts an Any value contained in the Any represented by this DynAny.
 boolean get_boolean()
Extracts the boolean value from this DynAny.
 char get_char()
Extracts the char value from this DynAny.
 double get_double()
Extracts the double value from this DynAny.
 DynAny get_dyn_any()
Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
 float get_float()
Extracts the float value from this DynAny.
 int get_long()
Extracts the integer value from this DynAny.
 long get_longlong()
Extracts the long value from this DynAny.
 byte get_octet()
Extracts the byte value from this DynAny.
 Object get_reference()
Extracts the reference to a CORBA Object from this DynAny.
 short get_short()
Extracts the short value from this DynAny.
 String get_string()
Extracts the string value from this DynAny.
 TypeCode get_typecode()
Extracts the TypeCode object from this DynAny.
 int get_ulong()
Extracts the integer value from this DynAny.
 long get_ulonglong()
Extracts the long value from this DynAny.
 short get_ushort()
Extracts the short value from this DynAny.
 Serializable get_val()
Extracts a Serializable object from this DynAny.
 char get_wchar()
Extracts the long value from this DynAny.
 String get_wstring()
Extracts the string value from this DynAny.
 void insert_any(Any value)
Inserts an Any value into the Any represented by this DynAny.
 void insert_boolean(boolean value)
Inserts a boolean value into the DynAny.
 void insert_char(char value)
Inserts a char value into the DynAny.
 void insert_double(double value)
Inserts a double value into the DynAny.
 void insert_dyn_any(DynAny value)
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
 void insert_float(float value)
Inserts a float value into the DynAny.
 void insert_long(int value)
Inserts an integer value into the DynAny.
 void insert_longlong(long value)
Inserts a long value into the DynAny.
 void insert_octet(byte value)
Inserts a byte value into the DynAny.
 void insert_reference(Object value)
Inserts a reference to a CORBA object into the DynAny.
 void insert_short(short value)
Inserts a short value into the DynAny.
 void insert_string(String value)
Inserts a string value into the DynAny.
 void insert_typecode(TypeCode value)
Inserts a TypeCode object into the DynAny.
 void insert_ulong(int value)
Inserts an integer value into the DynAny.
 void insert_ulonglong(long value)
Inserts a long value into the DynAny.
 void insert_ushort(short value)
Inserts a short value into the DynAny.
 void insert_val(Serializable value)
Inserts a reference to a Serializable object into this DynAny.
 void insert_wchar(char value)
Inserts a char value into the DynAny.
 void insert_wstring(String value)
Inserts a string value into the DynAny.
 boolean next()
Advances the current position to the next component.
 void rewind()
Is equivalent to seek(0).
 boolean seek(int index)
Sets the current position to index.
 Any to_any()
Creates an any value from a DynAny object.
 TypeCode type()
Returns the TypeCode associated with this DynAny object.

Method Detail

type

TypeCode type()
Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.

Returns:
The TypeCode associated with this DynAny object

assign

void assign(DynAny dyn_any)
            throws TypeMismatch
Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.

Parameters:
dyn_any -
Throws:
TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

from_any

void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.

Throws:
TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
InvalidValue - if the passed Any does not contain a legal value (such as a null string)

to_any

Any to_any()
Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.

Returns:
a new Any object with the same value and TypeCode

equal

boolean equal(DynAny dyn_any)
Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.

Returns:
true of the DynAnys are equal, false otherwise

destroy

void destroy()
Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.

copy

DynAny copy()
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.

Returns:
a deep copy of the DynAny object

insert_boolean

void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
Inserts a boolean value into the DynAny.

Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_octet

void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.

Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_char

void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
Inserts a char value into the DynAny.

Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_short

void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a short value into the DynAny.

Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ushort

void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.

Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_long

void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.

Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ulong

void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.

Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_float

void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a float value into the DynAny.

Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_double

void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a double value into the DynAny.

Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_string

void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.

Throws:
InvalidValue - if this DynAny has components but has a current position of -1
InvalidValue - if the string inserted is longer than the bound of a bounded string
TypeMismatch - if called on a DynAny whose current component itself has components

insert_reference

void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
Inserts a reference to a CORBA object into the DynAny.

Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_typecode

void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
Inserts a TypeCode object into the DynAny.

Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_longlong

void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.

Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ulonglong

void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.

Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_wchar

void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.

Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_wstring

void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.

Throws:
InvalidValue - if this DynAny has components but has a current position of -1
InvalidValue - if the string inserted is longer than the bound of a bounded string
TypeMismatch

insert_any

void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
Inserts an Any value into the Any represented by this DynAny.

Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_dyn_any

void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.

Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_val

void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.

Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

get_boolean

boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
Extracts the boolean value from this DynAny.

Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_octet

byte get_octet()
               throws TypeMismatch,
                      InvalidValue
Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.

Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_char

char get_char()
              throws TypeMismatch,
                     InvalidValue
Extracts the char value from this DynAny.

Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_short

short get_short()
                throws TypeMismatch,
                       InvalidValue
Extracts the short value from this DynAny.

Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ushort

short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.

Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_long

int get_long()
             throws TypeMismatch,
                    InvalidValue
Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.

Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ulong

int get_ulong()
              throws TypeMismatch,
                     InvalidValue
Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.

Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_float

float get_float()
                throws TypeMismatch,
                       InvalidValue
Extracts the float value from this DynAny.

Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_double

double get_double()
                  throws TypeMismatch,
                         InvalidValue
Extracts the double value from this DynAny.

Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_string

String get_string()
                  throws TypeMismatch,
                         InvalidValue
Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.

Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_reference

Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
Extracts the reference to a CORBA Object from this DynAny.

Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_typecode

TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
Extracts the TypeCode object from this DynAny.

Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_longlong

long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.

Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ulonglong

long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.

Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_wchar

char get_wchar()
               throws TypeMismatch,
                      InvalidValue
Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.

Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_wstring

String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.

Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue

get_any

Any get_any()
            throws TypeMismatch,
                   InvalidValue
Extracts an Any value contained in the Any represented by this DynAny.

Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_dyn_any

DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_val

Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.

Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

seek

boolean seek(int index)
Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.

rewind

void rewind()
Is equivalent to seek(0).

next

boolean next()
Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.

component_count

int component_count()
Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
  • For sequences, the operation returns the current number of elements.
  • For structures, exceptions, and value types, the operation returns the number of members.
  • For arrays, the operation returns the number of elements.
  • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
  • For DynFixed and DynEnum, the operation returns zero.

current_component

DynAny current_component()
                         throws TypeMismatch
Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.

Throws:
TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynAnySeqHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class DynAnySeqHelper

java.lang.Object
    extended by  org.omg.DynamicAny.DynAnySeqHelper

public abstract class DynAnySeqHelper
extends Object

org/omg/DynamicAny/DynAnySeqHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
DynAnySeqHelper()
Method Summary
Modifier and Type | Method and Description
static DynAny[] | extract(Any a)
static String | id()
static void | insert(Any a, DynAny[] that)
static DynAny[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, DynAny[] value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DynAnySeqHelper

public DynAnySeqHelper()
Method Detail

insert

public static void insert(Any a,
                          DynAny[] that)

extract

public static DynAny[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static DynAny[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         DynAny[] value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


_DynAnyStub (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class _DynAnyStub

java.lang.Object
    extended by  org.omg.CORBA.portable.ObjectImpl
        extended by  org.omg.DynamicAny._DynAnyStub
All Implemented Interfaces:
Serializable, Object, IDLEntity, DynAny, DynAnyOperations
public class _DynAnyStub
extends ObjectImpl
implements DynAny

Any values can be dynamically interpreted (traversed) and constructed through DynAny objects. A DynAny object is associated with a data value which corresponds to a copy of the value inserted into an any.

A DynAny object may be viewed as an ordered collection of component DynAnys. For DynAnys representing a basic type, such as long, or a type without components, such as an empty exception, the ordered collection of components is empty. Each DynAny object maintains the notion of a current position into its collection of component DynAnys. The current position is identified by an index value that runs from 0 to n-1, where n is the number of components. The special index value -1 indicates a current position that points nowhere. For values that cannot have a current position (such as an empty exception), the index value is fixed at -1. If a DynAny is initialized with a value that has components, the index is initialized to 0. After creation of an uninitialized DynAny (that is, a DynAny that has no value but a TypeCode that permits components), the current position depends on the type of value represented by the DynAny. (The current position is set to 0 or -1, depending on whether the new DynAny gets default values for its components.)

The iteration operations rewind, seek, and next can be used to change the current position and the current_component operation returns the component at the current position. The component_count operation returns the number of components of a DynAny. Collectively, these operations enable iteration over the components of a DynAny, for example, to (recursively) examine its contents.

A constructed DynAny object is a DynAny object associated with a constructed type. There is a different interface, inheriting from the DynAny interface, associated with each kind of constructed type in IDL (fixed, enum, struct, sequence, union, array, exception, and value type).

A constructed DynAny object exports operations that enable the creation of new DynAny objects, each of them associated with a component of the constructed data value. As an example, a DynStruct is associated with a struct value. This means that the DynStruct may be seen as owning an ordered collection of components, one for each structure member. The DynStruct object exports operations that enable the creation of new DynAny objects, each of them associated with a member of the struct.

If a DynAny object has been obtained from another (constructed) DynAny object, such as a DynAny representing a structure member that was created from a DynStruct, the member DynAny is logically contained in the DynStruct. Calling an insert or get operation leaves the current position unchanged. Destroying a top-level DynAny object (one that was not obtained as a component of another DynAny) also destroys any component DynAny objects obtained from it. Destroying a non-top level DynAny object does nothing. Invoking operations on a destroyed top-level DynAny or any of its descendants raises OBJECT_NOT_EXIST. If the programmer wants to destroy a DynAny object but still wants to manipulate some component of the data value associated with it, then he or she should first create a DynAny for the component and, after that, make a copy of the created DynAny object.

The behavior of DynAny objects has been defined in order to enable efficient implementations in terms of allocated memory space and speed of access. DynAny objects are intended to be used for traversing values extracted from anys or constructing values of anys at runtime. Their use for other purposes is not recommended.

Insert and get operations are necessary to handle basic DynAny objects but are also helpful to handle constructed DynAny objects. Inserting a basic data type value into a constructed DynAny object implies initializing the current component of the constructed data value associated with the DynAny object. For example, invoking insert_boolean on a DynStruct implies inserting a boolean data value at the current position of the associated struct data value. A type is consistent for inserting or extracting a value if its TypeCode is equivalent to the TypeCode contained in the DynAny or, if the DynAny has components, is equivalent to the TypeCode of the DynAny at the current position.

DynAny and DynAnyFactory objects are intended to be local to the process in which they are created and used. This means that references to DynAny and DynAnyFactory objects cannot be exported to other processes, or externalized with ORB.object_to_string(). If any attempt is made to do so, the offending operation will raise a MARSHAL system exception. Since their interfaces are specified in IDL, DynAny objects export operations defined in the standard org.omg.CORBA.Object interface. However, any attempt to invoke operations exported through the Object interface may raise the standard NO_IMPLEMENT exception. An attempt to use a DynAny object with the DII may raise the NO_IMPLEMENT exception.

Field Summary
Modifier and Type | Field and Description
static Class | _opsClass
Constructor Summary
Constructor and Description
_DynAnyStub()
Method Summary
Modifier and Type Method and Description
 String[] _ids()
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
 void assign(DynAny dyn_any)
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
 int component_count()
Returns the number of components of a DynAny.
 DynAny copy()
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
 DynAny current_component()
Returns the DynAny for the component at the current position.
 void destroy()
Destroys a DynAny object.
 boolean equal(DynAny dyn_any)
Compares two DynAny values for equality.
 void from_any(Any value)
Initializes the value associated with a DynAny object with the value contained in an any.
 Any get_any()
Extracts an Any value contained in the Any represented by this DynAny.
 boolean get_boolean()
Extracts the boolean value from this DynAny.
 char get_char()
Extracts the char value from this DynAny.
 double get_double()
Extracts the double value from this DynAny.
 DynAny get_dyn_any()
Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
 float get_float()
Extracts the float value from this DynAny.
 int get_long()
Extracts the integer value from this DynAny.
 long get_longlong()
Extracts the long value from this DynAny.
 byte get_octet()
Extracts the byte value from this DynAny.
 Object get_reference()
Extracts the reference to a CORBA Object from this DynAny.
 short get_short()
Extracts the short value from this DynAny.
 String get_string()
Extracts the string value from this DynAny.
 TypeCode get_typecode()
Extracts the TypeCode object from this DynAny.
 int get_ulong()
Extracts the integer value from this DynAny.
 long get_ulonglong()
Extracts the long value from this DynAny.
 short get_ushort()
Extracts the short value from this DynAny.
 Serializable get_val()
Extracts a Serializable object from this DynAny.
 char get_wchar()
Extracts the long value from this DynAny.
 String get_wstring()
Extracts the string value from this DynAny.
 void insert_any(Any value)
Inserts an Any value into the Any represented by this DynAny.
 void insert_boolean(boolean value)
Inserts a boolean value into the DynAny.
 void insert_char(char value)
Inserts a char value into the DynAny.
 void insert_double(double value)
Inserts a double value into the DynAny.
 void insert_dyn_any(DynAny value)
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
 void insert_float(float value)
Inserts a float value into the DynAny.
 void insert_long(int value)
Inserts an integer value into the DynAny.
 void insert_longlong(long value)
Inserts a long value into the DynAny.
 void insert_octet(byte value)
Inserts a byte value into the DynAny.
 void insert_reference(Object value)
Inserts a reference to a CORBA object into the DynAny.
 void insert_short(short value)
Inserts a short value into the DynAny.
 void insert_string(String value)
Inserts a string value into the DynAny.
 void insert_typecode(TypeCode value)
Inserts a TypeCode object into the DynAny.
 void insert_ulong(int value)
Inserts an integer value into the DynAny.
 void insert_ulonglong(long value)
Inserts a long value into the DynAny.
 void insert_ushort(short value)
Inserts a short value into the DynAny.
 void insert_val(Serializable value)
Inserts a reference to a Serializable object into this DynAny.
 void insert_wchar(char value)
Inserts a char value into the DynAny.
 void insert_wstring(String value)
Inserts a string value into the DynAny.
 boolean next()
Advances the current position to the next component.
 void rewind()
Is equivalent to seek(0).
 boolean seek(int index)
Sets the current position to index.
 Any to_any()
Creates an any value from a DynAny object.
 TypeCode type()
Returns the TypeCode associated with this DynAny object.
Methods inherited from class org.omg.CORBA.portable.ObjectImpl
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Field Detail

_opsClass

public static final Class _opsClass
Constructor Detail

_DynAnyStub

public _DynAnyStub()
Method Detail

type

public TypeCode type()
Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.

Specified by:
type in interface DynAnyOperations
Returns:
The TypeCode associated with this DynAny object

assign

public void assign(DynAny dyn_any)
            throws TypeMismatch
Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.

Specified by:
assign in interface DynAnyOperations
Parameters:
dyn_any -
Throws:
TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

from_any

public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.

Specified by:
from_any in interface DynAnyOperations
Throws:
TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
InvalidValue - if the passed Any does not contain a legal value (such as a null string)

to_any

public Any to_any()
Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.

Specified by:
to_any in interface DynAnyOperations
Returns:
a new Any object with the same value and TypeCode

equal

public boolean equal(DynAny dyn_any)
Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.

Specified by:
equal in interface DynAnyOperations
Returns:
true of the DynAnys are equal, false otherwise

destroy

public void destroy()
Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.

Specified by:
destroy in interface DynAnyOperations

copy

public DynAny copy()
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.

Specified by:
copy in interface DynAnyOperations
Returns:
a deep copy of the DynAny object

insert_boolean

public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
Inserts a boolean value into the DynAny.

Specified by:
insert_boolean in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_octet

public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.

Specified by:
insert_octet in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_char

public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
Inserts a char value into the DynAny.

Specified by:
insert_char in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_short

public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a short value into the DynAny.

Specified by:
insert_short in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ushort

public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.

Specified by:
insert_ushort in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_long

public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.

Specified by:
insert_long in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ulong

public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.

Specified by:
insert_ulong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_float

public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a float value into the DynAny.

Specified by:
insert_float in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_double

public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a double value into the DynAny.

Specified by:
insert_double in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_string

public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.

Specified by:
insert_string in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
InvalidValue - if the string inserted is longer than the bound of a bounded string
TypeMismatch - if called on a DynAny whose current component itself has components

insert_reference

public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
Inserts a reference to a CORBA object into the DynAny.

Specified by:
insert_reference in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_typecode

public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
Inserts a TypeCode object into the DynAny.

Specified by:
insert_typecode in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_longlong

public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.

Specified by:
insert_longlong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ulonglong

public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.

Specified by:
insert_ulonglong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_wchar

public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.

Specified by:
insert_wchar in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_wstring

public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.

Specified by:
insert_wstring in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
InvalidValue - if the string inserted is longer than the bound of a bounded string
TypeMismatch

insert_any

public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
Inserts an Any value into the Any represented by this DynAny.

Specified by:
insert_any in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_dyn_any

public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.

Specified by:
insert_dyn_any in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_val

public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.

Specified by:
insert_val in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

get_boolean

public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
Extracts the boolean value from this DynAny.

Specified by:
get_boolean in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_octet

public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.

Specified by:
get_octet in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_char

public char get_char()
              throws TypeMismatch,
                     InvalidValue
Extracts the char value from this DynAny.

Specified by:
get_char in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_short

public short get_short()
                throws TypeMismatch,
                       InvalidValue
Extracts the short value from this DynAny.

Specified by:
get_short in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ushort

public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.

Specified by:
get_ushort in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_long

public int get_long()
             throws TypeMismatch,
                    InvalidValue
Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.

Specified by:
get_long in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ulong

public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.

Specified by:
get_ulong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_float

public float get_float()
                throws TypeMismatch,
                       InvalidValue
Extracts the float value from this DynAny.

Specified by:
get_float in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_double

public double get_double()
                  throws TypeMismatch,
                         InvalidValue
Extracts the double value from this DynAny.

Specified by:
get_double in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_string

public String get_string()
                  throws TypeMismatch,
                         InvalidValue
Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.

Specified by:
get_string in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_reference

public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
Extracts the reference to a CORBA Object from this DynAny.

Specified by:
get_reference in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_typecode

public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
Extracts the TypeCode object from this DynAny.

Specified by:
get_typecode in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_longlong

public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.

Specified by:
get_longlong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ulonglong

public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.

Specified by:
get_ulonglong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_wchar

public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.

Specified by:
get_wchar in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_wstring

public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.

Specified by:
get_wstring in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue

get_any

public Any get_any()
            throws TypeMismatch,
                   InvalidValue
Extracts an Any value contained in the Any represented by this DynAny.

Specified by:
get_any in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_dyn_any

public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

Specified by:
get_dyn_any in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_val

public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.

Specified by:
get_val in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

seek

public boolean seek(int index)
Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.

Specified by:
seek in interface DynAnyOperations

rewind

public void rewind()
Is equivalent to seek(0).

Specified by:
rewind in interface DynAnyOperations

next

public boolean next()
Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.

Specified by:
next in interface DynAnyOperations

component_count

public int component_count()
Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
  • For sequences, the operation returns the current number of elements.
  • For structures, exceptions, and value types, the operation returns the number of members.
  • For arrays, the operation returns the number of elements.
  • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
  • For DynFixed and DynEnum, the operation returns zero.

Specified by:
component_count in interface DynAnyOperations

current_component

public DynAny current_component()
                         throws TypeMismatch
Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.

Specified by:
current_component in interface DynAnyOperations
Throws:
TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

_ids

public String[] _ids()
Description copied from class: ObjectImpl
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.

Specified by:
_ids in class ObjectImpl
Returns:
the array of all repository identifiers supported by this ObjectImpl instance
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynArray (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Interface DynArray

All Superinterfaces:
DynAny, DynAnyOperations, DynArrayOperations, IDLEntity, Object, Serializable
All Known Implementing Classes:
_DynArrayStub
public interface DynArray
extends DynArrayOperations, DynAny, IDLEntity

DynArray objects support the manipulation of IDL arrays. Note that the dimension of the array is contained in the TypeCode which is accessible through the type attribute. It can also be obtained by calling the component_count operation.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.DynamicAny.DynArrayOperations
get_elements_as_dyn_any, get_elements, set_elements_as_dyn_any, set_elements
Methods inherited from interface org.omg.DynamicAny.DynAnyOperations
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynArrayHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class DynArrayHelper

java.lang.Object
    extended by  org.omg.DynamicAny.DynArrayHelper

public abstract class DynArrayHelper
extends Object

DynArray objects support the manipulation of IDL arrays. Note that the dimension of the array is contained in the TypeCode which is accessible through the type attribute. It can also be obtained by calling the component_count operation.

Constructor Summary
Constructor and Description
DynArrayHelper()
Method Summary
Modifier and Type | Method and Description
static DynArray | extract(Any a)
static String | id()
static void | insert(Any a, DynArray that)
static DynArray | narrow(Object obj)
static DynArray | read(InputStream istream)
static TypeCode | type()
static DynArray | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, DynArray value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DynArrayHelper

public DynArrayHelper()
Method Detail

insert

public static void insert(Any a,
                          DynArray that)

extract

public static DynArray extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static DynArray read(InputStream istream)

write

public static void write(OutputStream ostream,
                         DynArray value)

narrow

public static DynArray narrow(Object obj)

unchecked_narrow

public static DynArray unchecked_narrow(Object obj)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynArrayOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Interface DynArrayOperations

All Superinterfaces:
DynAnyOperations
All Known Subinterfaces:
DynArray
All Known Implementing Classes:
_DynArrayStub
public interface DynArrayOperations
extends DynAnyOperations

DynArray objects support the manipulation of IDL arrays. Note that the dimension of the array is contained in the TypeCode which is accessible through the type attribute. It can also be obtained by calling the component_count operation.

Method Summary
Modifier and Type | Method and Description
DynAny[] | get_elements_as_dyn_any() Returns the elements of the DynArray as DynAnys.
Any[] | get_elements() Returns the elements of the DynArray.
void | set_elements_as_dyn_any(DynAny[] value) Sets the DynArray to contain the passed elements.
void | set_elements(Any[] value) Sets the DynArray to contain the passed elements.
Methods inherited from interface org.omg.DynamicAny.DynAnyOperations
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

Method Detail

get_elements

Any[] get_elements()
Returns the elements of the DynArray.

set_elements

void set_elements(Any[] value)
                  throws TypeMismatch,
                         InvalidValue
Sets the DynArray to contain the passed elements.

Throws:
TypeMismatch - if one or more elements have a type that is inconsistent with the DynArrays TypeCode
InvalidValue - if the sequence does not contain the same number of elements as the array dimension

get_elements_as_dyn_any

DynAny[] get_elements_as_dyn_any()
Returns the elements of the DynArray as DynAnys.

set_elements_as_dyn_any

void set_elements_as_dyn_any(DynAny[] value)
                             throws TypeMismatch,
                                    InvalidValue
Sets the DynArray to contain the passed elements.

Throws:
TypeMismatch - if one or more elements have a type that is inconsistent with the DynArrays TypeCode
InvalidValue - if the sequence does not contain the same number of elements as the array dimension
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


_DynArrayStub (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class _DynArrayStub

java.lang.Object
    extended by  org.omg.CORBA.portable.ObjectImpl
        extended by  org.omg.DynamicAny._DynArrayStub
All Implemented Interfaces:
Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynArray, DynArrayOperations
public class _DynArrayStub
extends ObjectImpl
implements DynArray

DynArray objects support the manipulation of IDL arrays. Note that the dimension of the array is contained in the TypeCode which is accessible through the type attribute. It can also be obtained by calling the component_count operation.

Field Summary
Modifier and Type | Field and Description
static Class | _opsClass
Constructor Summary
Constructor and Description
_DynArrayStub()
Method Summary
Modifier and Type Method and Description
 String[] _ids()
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
 void assign(DynAny dyn_any)
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
 int component_count()
Returns the number of components of a DynAny.
 DynAny copy()
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
 DynAny current_component()
Returns the DynAny for the component at the current position.
 void destroy()
Destroys a DynAny object.
 boolean equal(DynAny dyn_any)
Compares two DynAny values for equality.
 void from_any(Any value)
Initializes the value associated with a DynAny object with the value contained in an any.
 Any get_any()
Extracts an Any value contained in the Any represented by this DynAny.
 boolean get_boolean()
Extracts the boolean value from this DynAny.
 char get_char()
Extracts the char value from this DynAny.
 double get_double()
Extracts the double value from this DynAny.
 DynAny get_dyn_any()
Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
 DynAny[] get_elements_as_dyn_any()
Returns the elements of the DynArray as DynAnys.
 Any[] get_elements()
Returns the elements of the DynArray.
 float get_float()
Extracts the float value from this DynAny.
 int get_long()
Extracts the integer value from this DynAny.
 long get_longlong()
Extracts the long value from this DynAny.
 byte get_octet()
Extracts the byte value from this DynAny.
 Object get_reference()
Extracts the reference to a CORBA Object from this DynAny.
 short get_short()
Extracts the short value from this DynAny.
 String get_string()
Extracts the string value from this DynAny.
 TypeCode get_typecode()
Extracts the TypeCode object from this DynAny.
 int get_ulong()
Extracts the integer value from this DynAny.
 long get_ulonglong()
Extracts the long value from this DynAny.
 short get_ushort()
Extracts the short value from this DynAny.
 Serializable get_val()
Extracts a Serializable object from this DynAny.
 char get_wchar()
Extracts the long value from this DynAny.
 String get_wstring()
Extracts the string value from this DynAny.
 void insert_any(Any value)
Inserts an Any value into the Any represented by this DynAny.
 void insert_boolean(boolean value)
Inserts a boolean value into the DynAny.
 void insert_char(char value)
Inserts a char value into the DynAny.
 void insert_double(double value)
Inserts a double value into the DynAny.
 void insert_dyn_any(DynAny value)
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
 void insert_float(float value)
Inserts a float value into the DynAny.
 void insert_long(int value)
Inserts an integer value into the DynAny.
 void insert_longlong(long value)
Inserts a long value into the DynAny.
 void insert_octet(byte value)
Inserts a byte value into the DynAny.
 void insert_reference(Object value)
Inserts a reference to a CORBA object into the DynAny.
 void insert_short(short value)
Inserts a short value into the DynAny.
 void insert_string(String value)
Inserts a string value into the DynAny.
 void insert_typecode(TypeCode value)
Inserts a TypeCode object into the DynAny.
 void insert_ulong(int value)
Inserts an integer value into the DynAny.
 void insert_ulonglong(long value)
Inserts a long value into the DynAny.
 void insert_ushort(short value)
Inserts a short value into the DynAny.
 void insert_val(Serializable value)
Inserts a reference to a Serializable object into this DynAny.
 void insert_wchar(char value)
Inserts a char value into the DynAny.
 void insert_wstring(String value)
Inserts a string value into the DynAny.
 boolean next()
Advances the current position to the next component.
 void rewind()
Is equivalent to seek(0).
 boolean seek(int index)
Sets the current position to index.
 void set_elements_as_dyn_any(DynAny[] value)
Sets the DynArray to contain the passed elements.
 void set_elements(Any[] value)
Sets the DynArray to contain the passed elements.
 Any to_any()
Creates an any value from a DynAny object.
 TypeCode type()
Returns the TypeCode associated with this DynAny object.
Methods inherited from class org.omg.CORBA.portable.ObjectImpl
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Field Detail

_opsClass

public static final Class _opsClass
Constructor Detail

_DynArrayStub

public _DynArrayStub()
Method Detail

get_elements

public Any[] get_elements()
Returns the elements of the DynArray.

Specified by:
get_elements in interface DynArrayOperations

set_elements

public void set_elements(Any[] value)
                  throws TypeMismatch,
                         InvalidValue
Sets the DynArray to contain the passed elements.

Specified by:
set_elements in interface DynArrayOperations
Throws:
TypeMismatch - if one or more elements have a type that is inconsistent with the DynArrays TypeCode
InvalidValue - if the sequence does not contain the same number of elements as the array dimension

get_elements_as_dyn_any

public DynAny[] get_elements_as_dyn_any()
Returns the elements of the DynArray as DynAnys.

Specified by:
get_elements_as_dyn_any in interface DynArrayOperations

set_elements_as_dyn_any

public void set_elements_as_dyn_any(DynAny[] value)
                             throws TypeMismatch,
                                    InvalidValue
Sets the DynArray to contain the passed elements.

Specified by:
set_elements_as_dyn_any in interface DynArrayOperations
Throws:
TypeMismatch - if one or more elements have a type that is inconsistent with the DynArrays TypeCode
InvalidValue - if the sequence does not contain the same number of elements as the array dimension

type

public TypeCode type()
Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.

Specified by:
type in interface DynAnyOperations
Returns:
The TypeCode associated with this DynAny object

assign

public void assign(DynAny dyn_any)
            throws TypeMismatch
Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.

Specified by:
assign in interface DynAnyOperations
Parameters:
dyn_any -
Throws:
TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

from_any

public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.

Specified by:
from_any in interface DynAnyOperations
Throws:
TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
InvalidValue - if the passed Any does not contain a legal value (such as a null string)

to_any

public Any to_any()
Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.

Specified by:
to_any in interface DynAnyOperations
Returns:
a new Any object with the same value and TypeCode

equal

public boolean equal(DynAny dyn_any)
Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.

Specified by:
equal in interface DynAnyOperations
Returns:
true of the DynAnys are equal, false otherwise

destroy

public void destroy()
Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.

Specified by:
destroy in interface DynAnyOperations

copy

public DynAny copy()
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.

Specified by:
copy in interface DynAnyOperations
Returns:
a deep copy of the DynAny object

insert_boolean

public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
Inserts a boolean value into the DynAny.

Specified by:
insert_boolean in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_octet

public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.

Specified by:
insert_octet in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_char

public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
Inserts a char value into the DynAny.

Specified by:
insert_char in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_short

public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a short value into the DynAny.

Specified by:
insert_short in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ushort

public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.

Specified by:
insert_ushort in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_long

public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.

Specified by:
insert_long in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ulong

public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.

Specified by:
insert_ulong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_float

public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a float value into the DynAny.

Specified by:
insert_float in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_double

public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a double value into the DynAny.

Specified by:
insert_double in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_string

public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.

Specified by:
insert_string in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
InvalidValue - if the string inserted is longer than the bound of a bounded string
TypeMismatch - if called on a DynAny whose current component itself has components

insert_reference

public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
Inserts a reference to a CORBA object into the DynAny.

Specified by:
insert_reference in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_typecode

public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
Inserts a TypeCode object into the DynAny.

Specified by:
insert_typecode in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_longlong

public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.

Specified by:
insert_longlong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ulonglong

public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.

Specified by:
insert_ulonglong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_wchar

public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.

Specified by:
insert_wchar in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_wstring

public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.

Specified by:
insert_wstring in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
InvalidValue - if the string inserted is longer than the bound of a bounded string
TypeMismatch

insert_any

public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
Inserts an Any value into the Any represented by this DynAny.

Specified by:
insert_any in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_dyn_any

public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.

Specified by:
insert_dyn_any in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_val

public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.

Specified by:
insert_val in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

get_boolean

public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
Extracts the boolean value from this DynAny.

Specified by:
get_boolean in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_octet

public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.

Specified by:
get_octet in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_char

public char get_char()
              throws TypeMismatch,
                     InvalidValue
Extracts the char value from this DynAny.

Specified by:
get_char in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_short

public short get_short()
                throws TypeMismatch,
                       InvalidValue
Extracts the short value from this DynAny.

Specified by:
get_short in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ushort

public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.

Specified by:
get_ushort in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_long

public int get_long()
             throws TypeMismatch,
                    InvalidValue
Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.

Specified by:
get_long in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ulong

public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.

Specified by:
get_ulong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_float

public float get_float()
                throws TypeMismatch,
                       InvalidValue
Extracts the float value from this DynAny.

Specified by:
get_float in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_double

public double get_double()
                  throws TypeMismatch,
                         InvalidValue
Extracts the double value from this DynAny.

Specified by:
get_double in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_string

public String get_string()
                  throws TypeMismatch,
                         InvalidValue
Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.

Specified by:
get_string in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_reference

public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
Extracts the reference to a CORBA Object from this DynAny.

Specified by:
get_reference in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_typecode

public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
Extracts the TypeCode object from this DynAny.

Specified by:
get_typecode in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_longlong

public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.

Specified by:
get_longlong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ulonglong

public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.

Specified by:
get_ulonglong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_wchar

public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.

Specified by:
get_wchar in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_wstring

public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.

Specified by:
get_wstring in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue

get_any

public Any get_any()
            throws TypeMismatch,
                   InvalidValue
Extracts an Any value contained in the Any represented by this DynAny.

Specified by:
get_any in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_dyn_any

public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

Specified by:
get_dyn_any in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_val

public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.

Specified by:
get_val in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

seek

public boolean seek(int index)
Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.

Specified by:
seek in interface DynAnyOperations

rewind

public void rewind()
Is equivalent to seek(0).

Specified by:
rewind in interface DynAnyOperations

next

public boolean next()
Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.

Specified by:
next in interface DynAnyOperations

component_count

public int component_count()
Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
  • For sequences, the operation returns the current number of elements.
  • For structures, exceptions, and value types, the operation returns the number of members.
  • For arrays, the operation returns the number of elements.
  • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
  • For DynFixed and DynEnum, the operation returns zero.

Specified by:
component_count in interface DynAnyOperations

current_component

public DynAny current_component()
                         throws TypeMismatch
Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.

Specified by:
current_component in interface DynAnyOperations
Throws:
TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

_ids

public String[] _ids()
Description copied from class: ObjectImpl
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.

Specified by:
_ids in class ObjectImpl
Returns:
the array of all repository identifiers supported by this ObjectImpl instance
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynEnum (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Interface DynEnum

All Superinterfaces:
DynAny, DynAnyOperations, DynEnumOperations, IDLEntity, Object, Serializable
All Known Implementing Classes:
_DynEnumStub
public interface DynEnum
extends DynEnumOperations, DynAny, IDLEntity

DynEnum objects support the manipulation of IDL enumerated values. The current position of a DynEnum is always -1.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.DynamicAny.DynEnumOperations
get_as_string, get_as_ulong, set_as_string, set_as_ulong
Methods inherited from interface org.omg.DynamicAny.DynAnyOperations
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynEnumHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class DynEnumHelper

java.lang.Object
    extended by  org.omg.DynamicAny.DynEnumHelper

public abstract class DynEnumHelper
extends Object

DynEnum objects support the manipulation of IDL enumerated values. The current position of a DynEnum is always -1.

Constructor Summary
Constructor and Description
DynEnumHelper()
Method Summary
Modifier and Type | Method and Description
static DynEnum | extract(Any a)
static String | id()
static void | insert(Any a, DynEnum that)
static DynEnum | narrow(Object obj)
static DynEnum | read(InputStream istream)
static TypeCode | type()
static DynEnum | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, DynEnum value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DynEnumHelper

public DynEnumHelper()
Method Detail

insert

public static void insert(Any a,
                          DynEnum that)

extract

public static DynEnum extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static DynEnum read(InputStream istream)

write

public static void write(OutputStream ostream,
                         DynEnum value)

narrow

public static DynEnum narrow(Object obj)

unchecked_narrow

public static DynEnum unchecked_narrow(Object obj)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynEnumOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Interface DynEnumOperations

All Superinterfaces:
DynAnyOperations
All Known Subinterfaces:
DynEnum
All Known Implementing Classes:
_DynEnumStub
public interface DynEnumOperations
extends DynAnyOperations

DynEnum objects support the manipulation of IDL enumerated values. The current position of a DynEnum is always -1.

Method Summary
Modifier and Type | Method and Description
String | get_as_string() Returns the value of the DynEnum as an IDL identifier.
int | get_as_ulong() Returns the value of the DynEnum as the enumerated value's ordinal value.
void | set_as_string(String value) Sets the value of the DynEnum to the enumerated value whose IDL identifier is passed in the value parameter.
void | set_as_ulong(int value) Sets the value of the DynEnum as the enumerated value's ordinal value.
Methods inherited from interface org.omg.DynamicAny.DynAnyOperations
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

Method Detail

get_as_string

String get_as_string()
Returns the value of the DynEnum as an IDL identifier.

set_as_string

void set_as_string(String value)
                   throws InvalidValue
Sets the value of the DynEnum to the enumerated value whose IDL identifier is passed in the value parameter.

Throws:
InvalidValue - If value contains a string that is not a valid IDL identifier for the corresponding enumerated type

get_as_ulong

int get_as_ulong()
Returns the value of the DynEnum as the enumerated value's ordinal value. Enumerators have ordinal values 0 to n-1, as they appear from left to right in the corresponding IDL definition.

set_as_ulong

void set_as_ulong(int value)
                  throws InvalidValue
Sets the value of the DynEnum as the enumerated value's ordinal value.

Throws:
InvalidValue - If value contains a value that is outside the range of ordinal values for the corresponding enumerated type
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


_DynEnumStub (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class _DynEnumStub

java.lang.Object
    extended by  org.omg.CORBA.portable.ObjectImpl
        extended by  org.omg.DynamicAny._DynEnumStub
All Implemented Interfaces:
Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynEnum, DynEnumOperations
public class _DynEnumStub
extends ObjectImpl
implements DynEnum

DynEnum objects support the manipulation of IDL enumerated values. The current position of a DynEnum is always -1.

Field Summary
Modifier and Type | Field and Description
static Class | _opsClass
Constructor Summary
Constructor and Description
_DynEnumStub()
Method Summary
Modifier and Type Method and Description
 String[] _ids()
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
 void assign(DynAny dyn_any)
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
 int component_count()
Returns the number of components of a DynAny.
 DynAny copy()
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
 DynAny current_component()
Returns the DynAny for the component at the current position.
 void destroy()
Destroys a DynAny object.
 boolean equal(DynAny dyn_any)
Compares two DynAny values for equality.
 void from_any(Any value)
Initializes the value associated with a DynAny object with the value contained in an any.
 Any get_any()
Extracts an Any value contained in the Any represented by this DynAny.
 String get_as_string()
Returns the value of the DynEnum as an IDL identifier.
 int get_as_ulong()
Returns the value of the DynEnum as the enumerated value's ordinal value.
 boolean get_boolean()
Extracts the boolean value from this DynAny.
 char get_char()
Extracts the char value from this DynAny.
 double get_double()
Extracts the double value from this DynAny.
 DynAny get_dyn_any()
Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
 float get_float()
Extracts the float value from this DynAny.
 int get_long()
Extracts the integer value from this DynAny.
 long get_longlong()
Extracts the long value from this DynAny.
 byte get_octet()
Extracts the byte value from this DynAny.
 Object get_reference()
Extracts the reference to a CORBA Object from this DynAny.
 short get_short()
Extracts the short value from this DynAny.
 String get_string()
Extracts the string value from this DynAny.
 TypeCode get_typecode()
Extracts the TypeCode object from this DynAny.
 int get_ulong()
Extracts the integer value from this DynAny.
 long get_ulonglong()
Extracts the long value from this DynAny.
 short get_ushort()
Extracts the short value from this DynAny.
 Serializable get_val()
Extracts a Serializable object from this DynAny.
 char get_wchar()
Extracts the long value from this DynAny.
 String get_wstring()
Extracts the string value from this DynAny.
 void insert_any(Any value)
Inserts an Any value into the Any represented by this DynAny.
 void insert_boolean(boolean value)
Inserts a boolean value into the DynAny.
 void insert_char(char value)
Inserts a char value into the DynAny.
 void insert_double(double value)
Inserts a double value into the DynAny.
 void insert_dyn_any(DynAny value)
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
 void insert_float(float value)
Inserts a float value into the DynAny.
 void insert_long(int value)
Inserts an integer value into the DynAny.
 void insert_longlong(long value)
Inserts a long value into the DynAny.
 void insert_octet(byte value)
Inserts a byte value into the DynAny.
 void insert_reference(Object value)
Inserts a reference to a CORBA object into the DynAny.
 void insert_short(short value)
Inserts a short value into the DynAny.
 void insert_string(String value)
Inserts a string value into the DynAny.
 void insert_typecode(TypeCode value)
Inserts a TypeCode object into the DynAny.
 void insert_ulong(int value)
Inserts an integer value into the DynAny.
 void insert_ulonglong(long value)
Inserts a long value into the DynAny.
 void insert_ushort(short value)
Inserts a short value into the DynAny.
 void insert_val(Serializable value)
Inserts a reference to a Serializable object into this DynAny.
 void insert_wchar(char value)
Inserts a char value into the DynAny.
 void insert_wstring(String value)
Inserts a string value into the DynAny.
 boolean next()
Advances the current position to the next component.
 void rewind()
Is equivalent to seek(0).
 boolean seek(int index)
Sets the current position to index.
 void set_as_string(String value)
Sets the value of the DynEnum to the enumerated value whose IDL identifier is passed in the value parameter.
 void set_as_ulong(int value)
Sets the value of the DynEnum as the enumerated value's ordinal value.
 Any to_any()
Creates an any value from a DynAny object.
 TypeCode type()
Returns the TypeCode associated with this DynAny object.
Methods inherited from class org.omg.CORBA.portable.ObjectImpl
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Field Detail

_opsClass

public static final Class _opsClass
Constructor Detail

_DynEnumStub

public _DynEnumStub()
Method Detail

get_as_string

public String get_as_string()
Returns the value of the DynEnum as an IDL identifier.

Specified by:
get_as_string in interface DynEnumOperations

set_as_string

public void set_as_string(String value)
                   throws InvalidValue
Sets the value of the DynEnum to the enumerated value whose IDL identifier is passed in the value parameter.

Specified by:
set_as_string in interface DynEnumOperations
Throws:
InvalidValue - If value contains a string that is not a valid IDL identifier for the corresponding enumerated type

get_as_ulong

public int get_as_ulong()
Returns the value of the DynEnum as the enumerated value's ordinal value. Enumerators have ordinal values 0 to n-1, as they appear from left to right in the corresponding IDL definition.

Specified by:
get_as_ulong in interface DynEnumOperations

set_as_ulong

public void set_as_ulong(int value)
                  throws InvalidValue
Sets the value of the DynEnum as the enumerated value's ordinal value.

Specified by:
set_as_ulong in interface DynEnumOperations
Throws:
InvalidValue - If value contains a value that is outside the range of ordinal values for the corresponding enumerated type

type

public TypeCode type()
Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.

Specified by:
type in interface DynAnyOperations
Returns:
The TypeCode associated with this DynAny object

assign

public void assign(DynAny dyn_any)
            throws TypeMismatch
Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.

Specified by:
assign in interface DynAnyOperations
Parameters:
dyn_any -
Throws:
TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

from_any

public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.

Specified by:
from_any in interface DynAnyOperations
Throws:
TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
InvalidValue - if the passed Any does not contain a legal value (such as a null string)

to_any

public Any to_any()
Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.

Specified by:
to_any in interface DynAnyOperations
Returns:
a new Any object with the same value and TypeCode

equal

public boolean equal(DynAny dyn_any)
Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.

Specified by:
equal in interface DynAnyOperations
Returns:
true of the DynAnys are equal, false otherwise

destroy

public void destroy()
Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.

Specified by:
destroy in interface DynAnyOperations

copy

public DynAny copy()
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.

Specified by:
copy in interface DynAnyOperations
Returns:
a deep copy of the DynAny object

insert_boolean

public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
Inserts a boolean value into the DynAny.

Specified by:
insert_boolean in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_octet

public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.

Specified by:
insert_octet in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_char

public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
Inserts a char value into the DynAny.

Specified by:
insert_char in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_short

public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a short value into the DynAny.

Specified by:
insert_short in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ushort

public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.

Specified by:
insert_ushort in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_long

public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.

Specified by:
insert_long in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ulong

public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.

Specified by:
insert_ulong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_float

public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a float value into the DynAny.

Specified by:
insert_float in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_double

public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a double value into the DynAny.

Specified by:
insert_double in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_string

public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.

Specified by:
insert_string in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
InvalidValue - if the string inserted is longer than the bound of a bounded string
TypeMismatch - if called on a DynAny whose current component itself has components

insert_reference

public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
Inserts a reference to a CORBA object into the DynAny.

Specified by:
insert_reference in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_typecode

public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
Inserts a TypeCode object into the DynAny.

Specified by:
insert_typecode in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_longlong

public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.

Specified by:
insert_longlong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ulonglong

public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.

Specified by:
insert_ulonglong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_wchar

public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.

Specified by:
insert_wchar in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_wstring

public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.

Specified by:
insert_wstring in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
InvalidValue - if the string inserted is longer than the bound of a bounded string
TypeMismatch

insert_any

public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
Inserts an Any value into the Any represented by this DynAny.

Specified by:
insert_any in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_dyn_any

public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.

Specified by:
insert_dyn_any in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_val

public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.

Specified by:
insert_val in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

get_boolean

public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
Extracts the boolean value from this DynAny.

Specified by:
get_boolean in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_octet

public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.

Specified by:
get_octet in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_char

public char get_char()
              throws TypeMismatch,
                     InvalidValue
Extracts the char value from this DynAny.

Specified by:
get_char in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_short

public short get_short()
                throws TypeMismatch,
                       InvalidValue
Extracts the short value from this DynAny.

Specified by:
get_short in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ushort

public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.

Specified by:
get_ushort in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_long

public int get_long()
             throws TypeMismatch,
                    InvalidValue
Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.

Specified by:
get_long in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ulong

public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.

Specified by:
get_ulong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_float

public float get_float()
                throws TypeMismatch,
                       InvalidValue
Extracts the float value from this DynAny.

Specified by:
get_float in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_double

public double get_double()
                  throws TypeMismatch,
                         InvalidValue
Extracts the double value from this DynAny.

Specified by:
get_double in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_string

public String get_string()
                  throws TypeMismatch,
                         InvalidValue
Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.

Specified by:
get_string in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_reference

public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
Extracts the reference to a CORBA Object from this DynAny.

Specified by:
get_reference in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_typecode

public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
Extracts the TypeCode object from this DynAny.

Specified by:
get_typecode in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_longlong

public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.

Specified by:
get_longlong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ulonglong

public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.

Specified by:
get_ulonglong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_wchar

public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.

Specified by:
get_wchar in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_wstring

public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.

Specified by:
get_wstring in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue

get_any

public Any get_any()
            throws TypeMismatch,
                   InvalidValue
Extracts an Any value contained in the Any represented by this DynAny.

Specified by:
get_any in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_dyn_any

public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

Specified by:
get_dyn_any in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_val

public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.

Specified by:
get_val in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

seek

public boolean seek(int index)
Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.

Specified by:
seek in interface DynAnyOperations

rewind

public void rewind()
Is equivalent to seek(0).

Specified by:
rewind in interface DynAnyOperations

next

public boolean next()
Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.

Specified by:
next in interface DynAnyOperations

component_count

public int component_count()
Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
  • For sequences, the operation returns the current number of elements.
  • For structures, exceptions, and value types, the operation returns the number of members.
  • For arrays, the operation returns the number of elements.
  • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
  • For DynFixed and DynEnum, the operation returns zero.

Specified by:
component_count in interface DynAnyOperations

current_component

public DynAny current_component()
                         throws TypeMismatch
Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.

Specified by:
current_component in interface DynAnyOperations
Throws:
TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

_ids

public String[] _ids()
Description copied from class: ObjectImpl
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.

Specified by:
_ids in class ObjectImpl
Returns:
the array of all repository identifiers supported by this ObjectImpl instance
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynFixed (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Interface DynFixed

All Superinterfaces:
DynAny, DynAnyOperations, DynFixedOperations, IDLEntity, Object, Serializable
All Known Implementing Classes:
_DynFixedStub
public interface DynFixed
extends DynFixedOperations, DynAny, IDLEntity

DynFixed objects support the manipulation of IDL fixed values. Because IDL does not have a generic type that can represent fixed types with arbitrary number of digits and arbitrary scale, the operations use the IDL string type.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.DynamicAny.DynFixedOperations
get_value, set_value
Methods inherited from interface org.omg.DynamicAny.DynAnyOperations
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynFixedHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class DynFixedHelper

java.lang.Object
    extended by  org.omg.DynamicAny.DynFixedHelper

public abstract class DynFixedHelper
extends Object

DynFixed objects support the manipulation of IDL fixed values. Because IDL does not have a generic type that can represent fixed types with arbitrary number of digits and arbitrary scale, the operations use the IDL string type.

Constructor Summary
Constructor and Description
DynFixedHelper()
Method Summary
Modifier and Type | Method and Description
static DynFixed | extract(Any a)
static String | id()
static void | insert(Any a, DynFixed that)
static DynFixed | narrow(Object obj)
static DynFixed | read(InputStream istream)
static TypeCode | type()
static DynFixed | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, DynFixed value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DynFixedHelper

public DynFixedHelper()
Method Detail

insert

public static void insert(Any a,
                          DynFixed that)

extract

public static DynFixed extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static DynFixed read(InputStream istream)

write

public static void write(OutputStream ostream,
                         DynFixed value)

narrow

public static DynFixed narrow(Object obj)

unchecked_narrow

public static DynFixed unchecked_narrow(Object obj)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynFixedOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Interface DynFixedOperations

All Superinterfaces:
DynAnyOperations
All Known Subinterfaces:
DynFixed
All Known Implementing Classes:
_DynFixedStub
public interface DynFixedOperations
extends DynAnyOperations

DynFixed objects support the manipulation of IDL fixed values. Because IDL does not have a generic type that can represent fixed types with arbitrary number of digits and arbitrary scale, the operations use the IDL string type.

Method Summary
Modifier and Type | Method and Description
String | get_value() Returns the value of a DynFixed.
boolean | set_value(String val) Sets the value of the DynFixed.
Methods inherited from interface org.omg.DynamicAny.DynAnyOperations
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

Method Detail

get_value

String get_value()
Returns the value of a DynFixed.

set_value

boolean set_value(String val)
                  throws TypeMismatch,
                         InvalidValue
Sets the value of the DynFixed. The val string must contain a fixed string constant in the same format as used for IDL fixed-point literals. However, the trailing d or D is optional. The return value is true if val can be represented as the DynFixed without loss of precision. If val has more fractional digits than can be represented in the DynFixed, fractional digits are truncated and the return value is false.

Throws:
TypeMismatch - If val does not contain a valid fixed-point literal or contains extraneous characters other than leading or trailing white space
InvalidValue - If val contains a value whose scale exceeds that of the DynFixed or is not initialized
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


_DynFixedStub (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class _DynFixedStub

java.lang.Object
    extended by  org.omg.CORBA.portable.ObjectImpl
        extended by  org.omg.DynamicAny._DynFixedStub
All Implemented Interfaces:
Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynFixed, DynFixedOperations
public class _DynFixedStub
extends ObjectImpl
implements DynFixed

DynFixed objects support the manipulation of IDL fixed values. Because IDL does not have a generic type that can represent fixed types with arbitrary number of digits and arbitrary scale, the operations use the IDL string type.

Field Summary
Modifier and Type | Field and Description
static Class | _opsClass
Constructor Summary
Constructor and Description
_DynFixedStub()
Method Summary
Modifier and Type Method and Description
 String[] _ids()
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
 void assign(DynAny dyn_any)
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
 int component_count()
Returns the number of components of a DynAny.
 DynAny copy()
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
 DynAny current_component()
Returns the DynAny for the component at the current position.
 void destroy()
Destroys a DynAny object.
 boolean equal(DynAny dyn_any)
Compares two DynAny values for equality.
 void from_any(Any value)
Initializes the value associated with a DynAny object with the value contained in an any.
 Any get_any()
Extracts an Any value contained in the Any represented by this DynAny.
 boolean get_boolean()
Extracts the boolean value from this DynAny.
 char get_char()
Extracts the char value from this DynAny.
 double get_double()
Extracts the double value from this DynAny.
 DynAny get_dyn_any()
Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
 float get_float()
Extracts the float value from this DynAny.
 int get_long()
Extracts the integer value from this DynAny.
 long get_longlong()
Extracts the long value from this DynAny.
 byte get_octet()
Extracts the byte value from this DynAny.
 Object get_reference()
Extracts the reference to a CORBA Object from this DynAny.
 short get_short()
Extracts the short value from this DynAny.
 String get_string()
Extracts the string value from this DynAny.
 TypeCode get_typecode()
Extracts the TypeCode object from this DynAny.
 int get_ulong()
Extracts the integer value from this DynAny.
 long get_ulonglong()
Extracts the long value from this DynAny.
 short get_ushort()
Extracts the short value from this DynAny.
 Serializable get_val()
Extracts a Serializable object from this DynAny.
 String get_value()
Returns the value of a DynFixed.
 char get_wchar()
Extracts the long value from this DynAny.
 String get_wstring()
Extracts the string value from this DynAny.
 void insert_any(Any value)
Inserts an Any value into the Any represented by this DynAny.
 void insert_boolean(boolean value)
Inserts a boolean value into the DynAny.
 void insert_char(char value)
Inserts a char value into the DynAny.
 void insert_double(double value)
Inserts a double value into the DynAny.
 void insert_dyn_any(DynAny value)
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
 void insert_float(float value)
Inserts a float value into the DynAny.
 void insert_long(int value)
Inserts an integer value into the DynAny.
 void insert_longlong(long value)
Inserts a long value into the DynAny.
 void insert_octet(byte value)
Inserts a byte value into the DynAny.
 void insert_reference(Object value)
Inserts a reference to a CORBA object into the DynAny.
 void insert_short(short value)
Inserts a short value into the DynAny.
 void insert_string(String value)
Inserts a string value into the DynAny.
 void insert_typecode(TypeCode value)
Inserts a TypeCode object into the DynAny.
 void insert_ulong(int value)
Inserts an integer value into the DynAny.
 void insert_ulonglong(long value)
Inserts a long value into the DynAny.
 void insert_ushort(short value)
Inserts a short value into the DynAny.
 void insert_val(Serializable value)
Inserts a reference to a Serializable object into this DynAny.
 void insert_wchar(char value)
Inserts a char value into the DynAny.
 void insert_wstring(String value)
Inserts a string value into the DynAny.
 boolean next()
Advances the current position to the next component.
 void rewind()
Is equivalent to seek(0).
 boolean seek(int index)
Sets the current position to index.
 boolean set_value(String val)
Sets the value of the DynFixed.
 Any to_any()
Creates an any value from a DynAny object.
 TypeCode type()
Returns the TypeCode associated with this DynAny object.
Methods inherited from class org.omg.CORBA.portable.ObjectImpl
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Field Detail

_opsClass

public static final Class _opsClass
Constructor Detail

_DynFixedStub

public _DynFixedStub()
Method Detail

get_value

public String get_value()
Returns the value of a DynFixed.

Specified by:
get_value in interface DynFixedOperations

set_value

public boolean set_value(String val)
                  throws TypeMismatch,
                         InvalidValue
Sets the value of the DynFixed. The val string must contain a fixed string constant in the same format as used for IDL fixed-point literals. However, the trailing d or D is optional. The return value is true if val can be represented as the DynFixed without loss of precision. If val has more fractional digits than can be represented in the DynFixed, fractional digits are truncated and the return value is false.

Specified by:
set_value in interface DynFixedOperations
Throws:
TypeMismatch - If val does not contain a valid fixed-point literal or contains extraneous characters other than leading or trailing white space
InvalidValue - If val contains a value whose scale exceeds that of the DynFixed or is not initialized

type

public TypeCode type()
Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.

Specified by:
type in interface DynAnyOperations
Returns:
The TypeCode associated with this DynAny object

assign

public void assign(DynAny dyn_any)
            throws TypeMismatch
Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.

Specified by:
assign in interface DynAnyOperations
Parameters:
dyn_any -
Throws:
TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

from_any

public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.

Specified by:
from_any in interface DynAnyOperations
Throws:
TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
InvalidValue - if the passed Any does not contain a legal value (such as a null string)

to_any

public Any to_any()
Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.

Specified by:
to_any in interface DynAnyOperations
Returns:
a new Any object with the same value and TypeCode

equal

public boolean equal(DynAny dyn_any)
Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.

Specified by:
equal in interface DynAnyOperations
Returns:
true of the DynAnys are equal, false otherwise

destroy

public void destroy()
Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.

Specified by:
destroy in interface DynAnyOperations

copy

public DynAny copy()
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.

Specified by:
copy in interface DynAnyOperations
Returns:
a deep copy of the DynAny object

insert_boolean

public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
Inserts a boolean value into the DynAny.

Specified by:
insert_boolean in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_octet

public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.

Specified by:
insert_octet in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_char

public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
Inserts a char value into the DynAny.

Specified by:
insert_char in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_short

public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a short value into the DynAny.

Specified by:
insert_short in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ushort

public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.

Specified by:
insert_ushort in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_long

public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.

Specified by:
insert_long in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ulong

public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.

Specified by:
insert_ulong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_float

public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a float value into the DynAny.

Specified by:
insert_float in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_double

public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a double value into the DynAny.

Specified by:
insert_double in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_string

public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.

Specified by:
insert_string in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
InvalidValue - if the string inserted is longer than the bound of a bounded string
TypeMismatch - if called on a DynAny whose current component itself has components

insert_reference

public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
Inserts a reference to a CORBA object into the DynAny.

Specified by:
insert_reference in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_typecode

public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
Inserts a TypeCode object into the DynAny.

Specified by:
insert_typecode in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_longlong

public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.

Specified by:
insert_longlong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ulonglong

public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.

Specified by:
insert_ulonglong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_wchar

public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.

Specified by:
insert_wchar in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_wstring

public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.

Specified by:
insert_wstring in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
InvalidValue - if the string inserted is longer than the bound of a bounded string
TypeMismatch

insert_any

public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
Inserts an Any value into the Any represented by this DynAny.

Specified by:
insert_any in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_dyn_any

public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.

Specified by:
insert_dyn_any in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_val

public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.

Specified by:
insert_val in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

get_boolean

public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
Extracts the boolean value from this DynAny.

Specified by:
get_boolean in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_octet

public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.

Specified by:
get_octet in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_char

public char get_char()
              throws TypeMismatch,
                     InvalidValue
Extracts the char value from this DynAny.

Specified by:
get_char in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_short

public short get_short()
                throws TypeMismatch,
                       InvalidValue
Extracts the short value from this DynAny.

Specified by:
get_short in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ushort

public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.

Specified by:
get_ushort in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_long

public int get_long()
             throws TypeMismatch,
                    InvalidValue
Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.

Specified by:
get_long in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ulong

public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.

Specified by:
get_ulong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_float

public float get_float()
                throws TypeMismatch,
                       InvalidValue
Extracts the float value from this DynAny.

Specified by:
get_float in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_double

public double get_double()
                  throws TypeMismatch,
                         InvalidValue
Extracts the double value from this DynAny.

Specified by:
get_double in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_string

public String get_string()
                  throws TypeMismatch,
                         InvalidValue
Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.

Specified by:
get_string in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_reference

public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
Extracts the reference to a CORBA Object from this DynAny.

Specified by:
get_reference in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_typecode

public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
Extracts the TypeCode object from this DynAny.

Specified by:
get_typecode in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_longlong

public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.

Specified by:
get_longlong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ulonglong

public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.

Specified by:
get_ulonglong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_wchar

public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.

Specified by:
get_wchar in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_wstring

public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.

Specified by:
get_wstring in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue

get_any

public Any get_any()
            throws TypeMismatch,
                   InvalidValue
Extracts an Any value contained in the Any represented by this DynAny.

Specified by:
get_any in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_dyn_any

public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

Specified by:
get_dyn_any in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_val

public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.

Specified by:
get_val in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

seek

public boolean seek(int index)
Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.

Specified by:
seek in interface DynAnyOperations

rewind

public void rewind()
Is equivalent to seek(0).

Specified by:
rewind in interface DynAnyOperations

next

public boolean next()
Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.

Specified by:
next in interface DynAnyOperations

component_count

public int component_count()
Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
  • For sequences, the operation returns the current number of elements.
  • For structures, exceptions, and value types, the operation returns the number of members.
  • For arrays, the operation returns the number of elements.
  • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
  • For DynFixed and DynEnum, the operation returns zero.

Specified by:
component_count in interface DynAnyOperations

current_component

public DynAny current_component()
                         throws TypeMismatch
Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.

Specified by:
current_component in interface DynAnyOperations
Throws:
TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

_ids

public String[] _ids()
Description copied from class: ObjectImpl
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.

Specified by:
_ids in class ObjectImpl
Returns:
the array of all repository identifiers supported by this ObjectImpl instance
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynSequence (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Interface DynSequence

All Superinterfaces:
DynAny, DynAnyOperations, DynSequenceOperations, IDLEntity, Object, Serializable
All Known Implementing Classes:
_DynSequenceStub
public interface DynSequence
extends DynSequenceOperations, DynAny, IDLEntity

DynSequence objects support the manipulation of IDL sequences.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.DynamicAny.DynSequenceOperations
get_elements_as_dyn_any, get_elements, get_length, set_elements_as_dyn_any, set_elements, set_length
Methods inherited from interface org.omg.DynamicAny.DynAnyOperations
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynSequenceHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class DynSequenceHelper

java.lang.Object
    extended by  org.omg.DynamicAny.DynSequenceHelper

public abstract class DynSequenceHelper
extends Object

DynSequence objects support the manipulation of IDL sequences.

Constructor Summary
Constructor and Description
DynSequenceHelper()
Method Summary
Modifier and Type | Method and Description
static DynSequence | extract(Any a)
static String | id()
static void | insert(Any a, DynSequence that)
static DynSequence | narrow(Object obj)
static DynSequence | read(InputStream istream)
static TypeCode | type()
static DynSequence | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, DynSequence value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DynSequenceHelper

public DynSequenceHelper()
Method Detail

insert

public static void insert(Any a,
                          DynSequence that)

extract

public static DynSequence extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static DynSequence read(InputStream istream)

write

public static void write(OutputStream ostream,
                         DynSequence value)

narrow

public static DynSequence narrow(Object obj)

unchecked_narrow

public static DynSequence unchecked_narrow(Object obj)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynSequenceOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Interface DynSequenceOperations

All Superinterfaces:
DynAnyOperations
All Known Subinterfaces:
DynSequence
All Known Implementing Classes:
_DynSequenceStub
public interface DynSequenceOperations
extends DynAnyOperations

DynSequence objects support the manipulation of IDL sequences.

Method Summary
Modifier and Type | Method and Description
DynAny[] | get_elements_as_dyn_any() Returns the DynAnys representing the elements of the sequence.
Any[] | get_elements() Returns the elements of the sequence.
int | get_length() Returns the current length of the sequence.
void | set_elements_as_dyn_any(DynAny[] value) Sets the elements of a sequence using DynAnys.
void | set_elements(Any[] value) Sets the elements of a sequence.
void | set_length(int len) Sets the length of the sequence.
Methods inherited from interface org.omg.DynamicAny.DynAnyOperations
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

Method Detail

get_length

int get_length()
Returns the current length of the sequence.

set_length

void set_length(int len)
                throws InvalidValue
Sets the length of the sequence. Increasing the length of a sequence adds new elements at the tail without affecting the values of already existing elements. Newly added elements are default-initialized. Increasing the length of a sequence sets the current position to the first newly-added element if the previous current position was -1. Otherwise, if the previous current position was not -1, the current position is not affected. Decreasing the length of a sequence removes elements from the tail without affecting the value of those elements that remain. The new current position after decreasing the length of a sequence is determined as follows:
  • If the length of the sequence is set to zero, the current position is set to -1.
  • If the current position is -1 before decreasing the length, it remains at -1.
  • If the current position indicates a valid element and that element is not removed when the length is decreased, the current position remains unaffected.
  • If the current position indicates a valid element and that element is removed, the current position is set to -1.

Throws:
InvalidValue - if this is a bounded sequence and len is larger than the bound

get_elements

Any[] get_elements()
Returns the elements of the sequence.

set_elements

void set_elements(Any[] value)
                  throws TypeMismatch,
                         InvalidValue
Sets the elements of a sequence. The length of the DynSequence is set to the length of value. The current position is set to zero if value has non-zero length and to -1 if value is a zero-length sequence.

Throws:
TypeMismatch - if value contains one or more elements whose TypeCode is not equivalent to the element TypeCode of the DynSequence
InvalidValue - if the length of value exceeds the bound of a bounded sequence

get_elements_as_dyn_any

DynAny[] get_elements_as_dyn_any()
Returns the DynAnys representing the elements of the sequence.

set_elements_as_dyn_any

void set_elements_as_dyn_any(DynAny[] value)
                             throws TypeMismatch,
                                    InvalidValue
Sets the elements of a sequence using DynAnys. The length of the DynSequence is set to the length of value. The current position is set to zero if value has non-zero length and to -1 if value is a zero-length sequence.

Throws:
TypeMismatch - if value contains one or more elements whose TypeCode is not equivalent to the element TypeCode of the DynSequence
InvalidValue - if the length of value exceeds the bound of a bounded sequence
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


_DynSequenceStub (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class _DynSequenceStub

java.lang.Object
    extended by  org.omg.CORBA.portable.ObjectImpl
        extended by  org.omg.DynamicAny._DynSequenceStub
All Implemented Interfaces:
Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynSequence, DynSequenceOperations
public class _DynSequenceStub
extends ObjectImpl
implements DynSequence

DynSequence objects support the manipulation of IDL sequences.

Field Summary
Modifier and Type | Field and Description
static Class | _opsClass
Constructor Summary
Constructor and Description
_DynSequenceStub()
Method Summary
Modifier and Type Method and Description
 String[] _ids()
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
 void assign(DynAny dyn_any)
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
 int component_count()
Returns the number of components of a DynAny.
 DynAny copy()
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
 DynAny current_component()
Returns the DynAny for the component at the current position.
 void destroy()
Destroys a DynAny object.
 boolean equal(DynAny dyn_any)
Compares two DynAny values for equality.
 void from_any(Any value)
Initializes the value associated with a DynAny object with the value contained in an any.
 Any get_any()
Extracts an Any value contained in the Any represented by this DynAny.
 boolean get_boolean()
Extracts the boolean value from this DynAny.
 char get_char()
Extracts the char value from this DynAny.
 double get_double()
Extracts the double value from this DynAny.
 DynAny get_dyn_any()
Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
 DynAny[] get_elements_as_dyn_any()
Returns the DynAnys representing the elements of the sequence.
 Any[] get_elements()
Returns the elements of the sequence.
 float get_float()
Extracts the float value from this DynAny.
 int get_length()
Returns the current length of the sequence.
 int get_long()
Extracts the integer value from this DynAny.
 long get_longlong()
Extracts the long value from this DynAny.
 byte get_octet()
Extracts the byte value from this DynAny.
 Object get_reference()
Extracts the reference to a CORBA Object from this DynAny.
 short get_short()
Extracts the short value from this DynAny.
 String get_string()
Extracts the string value from this DynAny.
 TypeCode get_typecode()
Extracts the TypeCode object from this DynAny.
 int get_ulong()
Extracts the integer value from this DynAny.
 long get_ulonglong()
Extracts the long value from this DynAny.
 short get_ushort()
Extracts the short value from this DynAny.
 Serializable get_val()
Extracts a Serializable object from this DynAny.
 char get_wchar()
Extracts the long value from this DynAny.
 String get_wstring()
Extracts the string value from this DynAny.
 void insert_any(Any value)
Inserts an Any value into the Any represented by this DynAny.
 void insert_boolean(boolean value)
Inserts a boolean value into the DynAny.
 void insert_char(char value)
Inserts a char value into the DynAny.
 void insert_double(double value)
Inserts a double value into the DynAny.
 void insert_dyn_any(DynAny value)
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
 void insert_float(float value)
Inserts a float value into the DynAny.
 void insert_long(int value)
Inserts an integer value into the DynAny.
 void insert_longlong(long value)
Inserts a long value into the DynAny.
 void insert_octet(byte value)
Inserts a byte value into the DynAny.
 void insert_reference(Object value)
Inserts a reference to a CORBA object into the DynAny.
 void insert_short(short value)
Inserts a short value into the DynAny.
 void insert_string(String value)
Inserts a string value into the DynAny.
 void insert_typecode(TypeCode value)
Inserts a TypeCode object into the DynAny.
 void insert_ulong(int value)
Inserts an integer value into the DynAny.
 void insert_ulonglong(long value)
Inserts a long value into the DynAny.
 void insert_ushort(short value)
Inserts a short value into the DynAny.
 void insert_val(Serializable value)
Inserts a reference to a Serializable object into this DynAny.
 void insert_wchar(char value)
Inserts a char value into the DynAny.
 void insert_wstring(String value)
Inserts a string value into the DynAny.
 boolean next()
Advances the current position to the next component.
 void rewind()
Is equivalent to seek(0).
 boolean seek(int index)
Sets the current position to index.
 void set_elements_as_dyn_any(DynAny[] value)
Sets the elements of a sequence using DynAnys.
 void set_elements(Any[] value)
Sets the elements of a sequence.
 void set_length(int len)
Sets the length of the sequence.
 Any to_any()
Creates an any value from a DynAny object.
 TypeCode type()
Returns the TypeCode associated with this DynAny object.
Methods inherited from class org.omg.CORBA.portable.ObjectImpl
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Field Detail

_opsClass

public static final Class _opsClass
Constructor Detail

_DynSequenceStub

public _DynSequenceStub()
Method Detail

get_length

public int get_length()
Returns the current length of the sequence.

Specified by:
get_length in interface DynSequenceOperations

set_length

public void set_length(int len)
                throws InvalidValue
Sets the length of the sequence. Increasing the length of a sequence adds new elements at the tail without affecting the values of already existing elements. Newly added elements are default-initialized. Increasing the length of a sequence sets the current position to the first newly-added element if the previous current position was -1. Otherwise, if the previous current position was not -1, the current position is not affected. Decreasing the length of a sequence removes elements from the tail without affecting the value of those elements that remain. The new current position after decreasing the length of a sequence is determined as follows:
  • If the length of the sequence is set to zero, the current position is set to -1.
  • If the current position is -1 before decreasing the length, it remains at -1.
  • If the current position indicates a valid element and that element is not removed when the length is decreased, the current position remains unaffected.
  • If the current position indicates a valid element and that element is removed, the current position is set to -1.

Specified by:
set_length in interface DynSequenceOperations
Throws:
InvalidValue - if this is a bounded sequence and len is larger than the bound

get_elements

public Any[] get_elements()
Returns the elements of the sequence.

Specified by:
get_elements in interface DynSequenceOperations

set_elements

public void set_elements(Any[] value)
                  throws TypeMismatch,
                         InvalidValue
Sets the elements of a sequence. The length of the DynSequence is set to the length of value. The current position is set to zero if value has non-zero length and to -1 if value is a zero-length sequence.

Specified by:
set_elements in interface DynSequenceOperations
Throws:
TypeMismatch - if value contains one or more elements whose TypeCode is not equivalent to the element TypeCode of the DynSequence
InvalidValue - if the length of value exceeds the bound of a bounded sequence

get_elements_as_dyn_any

public DynAny[] get_elements_as_dyn_any()
Returns the DynAnys representing the elements of the sequence.

Specified by:
get_elements_as_dyn_any in interface DynSequenceOperations

set_elements_as_dyn_any

public void set_elements_as_dyn_any(DynAny[] value)
                             throws TypeMismatch,
                                    InvalidValue
Sets the elements of a sequence using DynAnys. The length of the DynSequence is set to the length of value. The current position is set to zero if value has non-zero length and to -1 if value is a zero-length sequence.

Specified by:
set_elements_as_dyn_any in interface DynSequenceOperations
Throws:
TypeMismatch - if value contains one or more elements whose TypeCode is not equivalent to the element TypeCode of the DynSequence
InvalidValue - if the length of value exceeds the bound of a bounded sequence

type

public TypeCode type()
Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.

Specified by:
type in interface DynAnyOperations
Returns:
The TypeCode associated with this DynAny object

assign

public void assign(DynAny dyn_any)
            throws TypeMismatch
Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.

Specified by:
assign in interface DynAnyOperations
Parameters:
dyn_any -
Throws:
TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

from_any

public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.

Specified by:
from_any in interface DynAnyOperations
Throws:
TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
InvalidValue - if the passed Any does not contain a legal value (such as a null string)

to_any

public Any to_any()
Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.

Specified by:
to_any in interface DynAnyOperations
Returns:
a new Any object with the same value and TypeCode

equal

public boolean equal(DynAny dyn_any)
Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.

Specified by:
equal in interface DynAnyOperations
Returns:
true of the DynAnys are equal, false otherwise

destroy

public void destroy()
Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.

Specified by:
destroy in interface DynAnyOperations

copy

public DynAny copy()
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.

Specified by:
copy in interface DynAnyOperations
Returns:
a deep copy of the DynAny object

insert_boolean

public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
Inserts a boolean value into the DynAny.

Specified by:
insert_boolean in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_octet

public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.

Specified by:
insert_octet in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_char

public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
Inserts a char value into the DynAny.

Specified by:
insert_char in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_short

public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a short value into the DynAny.

Specified by:
insert_short in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ushort

public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.

Specified by:
insert_ushort in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_long

public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.

Specified by:
insert_long in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ulong

public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.

Specified by:
insert_ulong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_float

public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a float value into the DynAny.

Specified by:
insert_float in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_double

public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a double value into the DynAny.

Specified by:
insert_double in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_string

public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.

Specified by:
insert_string in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
InvalidValue - if the string inserted is longer than the bound of a bounded string
TypeMismatch - if called on a DynAny whose current component itself has components

insert_reference

public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
Inserts a reference to a CORBA object into the DynAny.

Specified by:
insert_reference in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_typecode

public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
Inserts a TypeCode object into the DynAny.

Specified by:
insert_typecode in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_longlong

public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.

Specified by:
insert_longlong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ulonglong

public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.

Specified by:
insert_ulonglong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_wchar

public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.

Specified by:
insert_wchar in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_wstring

public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.

Specified by:
insert_wstring in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
InvalidValue - if the string inserted is longer than the bound of a bounded string
TypeMismatch

insert_any

public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
Inserts an Any value into the Any represented by this DynAny.

Specified by:
insert_any in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_dyn_any

public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.

Specified by:
insert_dyn_any in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_val

public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.

Specified by:
insert_val in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

get_boolean

public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
Extracts the boolean value from this DynAny.

Specified by:
get_boolean in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_octet

public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.

Specified by:
get_octet in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_char

public char get_char()
              throws TypeMismatch,
                     InvalidValue
Extracts the char value from this DynAny.

Specified by:
get_char in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_short

public short get_short()
                throws TypeMismatch,
                       InvalidValue
Extracts the short value from this DynAny.

Specified by:
get_short in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ushort

public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.

Specified by:
get_ushort in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_long

public int get_long()
             throws TypeMismatch,
                    InvalidValue
Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.

Specified by:
get_long in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ulong

public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.

Specified by:
get_ulong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_float

public float get_float()
                throws TypeMismatch,
                       InvalidValue
Extracts the float value from this DynAny.

Specified by:
get_float in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_double

public double get_double()
                  throws TypeMismatch,
                         InvalidValue
Extracts the double value from this DynAny.

Specified by:
get_double in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_string

public String get_string()
                  throws TypeMismatch,
                         InvalidValue
Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.

Specified by:
get_string in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_reference

public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
Extracts the reference to a CORBA Object from this DynAny.

Specified by:
get_reference in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_typecode

public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
Extracts the TypeCode object from this DynAny.

Specified by:
get_typecode in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_longlong

public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.

Specified by:
get_longlong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ulonglong

public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.

Specified by:
get_ulonglong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_wchar

public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.

Specified by:
get_wchar in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_wstring

public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.

Specified by:
get_wstring in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue

get_any

public Any get_any()
            throws TypeMismatch,
                   InvalidValue
Extracts an Any value contained in the Any represented by this DynAny.

Specified by:
get_any in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_dyn_any

public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

Specified by:
get_dyn_any in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_val

public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.

Specified by:
get_val in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

seek

public boolean seek(int index)
Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.

Specified by:
seek in interface DynAnyOperations

rewind

public void rewind()
Is equivalent to seek(0).

Specified by:
rewind in interface DynAnyOperations

next

public boolean next()
Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.

Specified by:
next in interface DynAnyOperations

component_count

public int component_count()
Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
  • For sequences, the operation returns the current number of elements.
  • For structures, exceptions, and value types, the operation returns the number of members.
  • For arrays, the operation returns the number of elements.
  • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
  • For DynFixed and DynEnum, the operation returns zero.

Specified by:
component_count in interface DynAnyOperations

current_component

public DynAny current_component()
                         throws TypeMismatch
Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.

Specified by:
current_component in interface DynAnyOperations
Throws:
TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

_ids

public String[] _ids()
Description copied from class: ObjectImpl
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.

Specified by:
_ids in class ObjectImpl
Returns:
the array of all repository identifiers supported by this ObjectImpl instance
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynStruct (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Interface DynStruct

All Superinterfaces:
DynAny, DynAnyOperations, DynStructOperations, IDLEntity, Object, Serializable
All Known Implementing Classes:
_DynStructStub
public interface DynStruct
extends DynStructOperations, DynAny, IDLEntity

DynStruct objects support the manipulation of IDL struct and exception values. Members of the exceptions are handled in the same way as members of a struct.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.DynamicAny.DynStructOperations
current_member_kind, current_member_name, get_members_as_dyn_any, get_members, set_members_as_dyn_any, set_members
Methods inherited from interface org.omg.DynamicAny.DynAnyOperations
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynStructHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class DynStructHelper

java.lang.Object
    extended by  org.omg.DynamicAny.DynStructHelper

public abstract class DynStructHelper
extends Object

DynStruct objects support the manipulation of IDL struct and exception values. Members of the exceptions are handled in the same way as members of a struct.

Constructor Summary
Constructor and Description
DynStructHelper()
Method Summary
Modifier and Type | Method and Description
static DynStruct | extract(Any a)
static String | id()
static void | insert(Any a, DynStruct that)
static DynStruct | narrow(Object obj)
static DynStruct | read(InputStream istream)
static TypeCode | type()
static DynStruct | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, DynStruct value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DynStructHelper

public DynStructHelper()
Method Detail

insert

public static void insert(Any a,
                          DynStruct that)

extract

public static DynStruct extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static DynStruct read(InputStream istream)

write

public static void write(OutputStream ostream,
                         DynStruct value)

narrow

public static DynStruct narrow(Object obj)

unchecked_narrow

public static DynStruct unchecked_narrow(Object obj)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynStructOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Interface DynStructOperations

All Superinterfaces:
DynAnyOperations
All Known Subinterfaces:
DynStruct
All Known Implementing Classes:
_DynStructStub
public interface DynStructOperations
extends DynAnyOperations

DynStruct objects support the manipulation of IDL struct and exception values. Members of the exceptions are handled in the same way as members of a struct.

Method Summary
Modifier and Type | Method and Description
TCKind | current_member_kind() Returns the TCKind associated with the member at the current position.
String | current_member_name() Returns the name of the member at the current position.
NameDynAnyPair[] | get_members_as_dyn_any() Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the struct associated with a DynStruct object.
NameValuePair[] | get_members() Returns a sequence of NameValuePairs describing the name and the value of each member in the struct associated with a DynStruct object.
void | set_members_as_dyn_any(NameDynAnyPair[] value) Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs.
void | set_members(NameValuePair[] value) Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs.
Methods inherited from interface org.omg.DynamicAny.DynAnyOperations
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

Method Detail

current_member_name

String current_member_name()
                           throws TypeMismatch,
                                  InvalidValue
Returns the name of the member at the current position. This operation may return an empty string since the TypeCode of the value being manipulated may not contain the names of members.

Throws:
TypeMismatch - if the DynStruct represents an empty exception.
InvalidValue - if the current position does not indicate a member

current_member_kind

TCKind current_member_kind()
                           throws TypeMismatch,
                                  InvalidValue
Returns the TCKind associated with the member at the current position.

Throws:
TypeMismatch - if the DynStruct represents an empty exception.
InvalidValue - if the current position does not indicate a member

get_members

NameValuePair[] get_members()
Returns a sequence of NameValuePairs describing the name and the value of each member in the struct associated with a DynStruct object. The sequence contains members in the same order as the declaration order of members as indicated by the DynStruct's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynStruct's TypeCode does not contain member names.

set_members

void set_members(NameValuePair[] value)
                 throws TypeMismatch,
                        InvalidValue
Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1.

Members must appear in the NameValuePairs in the order in which they appear in the IDL specification of the struct as indicated by the DynStruct's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

Throws:
TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynStruct's TypeCode and they are not empty strings
InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynStruct's TypeCode

get_members_as_dyn_any

NameDynAnyPair[] get_members_as_dyn_any()
Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the struct associated with a DynStruct object. The sequence contains members in the same order as the declaration order of members as indicated by the DynStruct's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynStruct's TypeCode does not contain member names.

set_members_as_dyn_any

void set_members_as_dyn_any(NameDynAnyPair[] value)
                            throws TypeMismatch,
                                   InvalidValue
Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1.

Members must appear in the NameDynAnyPairs in the order in which they appear in the IDL specification of the struct as indicated by the DynStruct's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

Throws:
TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynStruct's TypeCode and they are not empty strings
InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynStruct's TypeCode
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


_DynStructStub (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class _DynStructStub

java.lang.Object
    extended by  org.omg.CORBA.portable.ObjectImpl
        extended by  org.omg.DynamicAny._DynStructStub
All Implemented Interfaces:
Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynStruct, DynStructOperations
public class _DynStructStub
extends ObjectImpl
implements DynStruct

DynStruct objects support the manipulation of IDL struct and exception values. Members of the exceptions are handled in the same way as members of a struct.

Field Summary
Modifier and Type | Field and Description
static Class | _opsClass
Constructor Summary
Constructor and Description
_DynStructStub()
Method Summary
Modifier and Type Method and Description
 String[] _ids()
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
 void assign(DynAny dyn_any)
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
 int component_count()
Returns the number of components of a DynAny.
 DynAny copy()
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
 DynAny current_component()
Returns the DynAny for the component at the current position.
 TCKind current_member_kind()
Returns the TCKind associated with the member at the current position.
 String current_member_name()
Returns the name of the member at the current position.
 void destroy()
Destroys a DynAny object.
 boolean equal(DynAny dyn_any)
Compares two DynAny values for equality.
 void from_any(Any value)
Initializes the value associated with a DynAny object with the value contained in an any.
 Any get_any()
Extracts an Any value contained in the Any represented by this DynAny.
 boolean get_boolean()
Extracts the boolean value from this DynAny.
 char get_char()
Extracts the char value from this DynAny.
 double get_double()
Extracts the double value from this DynAny.
 DynAny get_dyn_any()
Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
 float get_float()
Extracts the float value from this DynAny.
 int get_long()
Extracts the integer value from this DynAny.
 long get_longlong()
Extracts the long value from this DynAny.
 NameDynAnyPair[] get_members_as_dyn_any()
Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the struct associated with a DynStruct object.
 NameValuePair[] get_members()
Returns a sequence of NameValuePairs describing the name and the value of each member in the struct associated with a DynStruct object.
 byte get_octet()
Extracts the byte value from this DynAny.
 Object get_reference()
Extracts the reference to a CORBA Object from this DynAny.
 short get_short()
Extracts the short value from this DynAny.
 String get_string()
Extracts the string value from this DynAny.
 TypeCode get_typecode()
Extracts the TypeCode object from this DynAny.
 int get_ulong()
Extracts the integer value from this DynAny.
 long get_ulonglong()
Extracts the long value from this DynAny.
 short get_ushort()
Extracts the short value from this DynAny.
 Serializable get_val()
Extracts a Serializable object from this DynAny.
 char get_wchar()
Extracts the long value from this DynAny.
 String get_wstring()
Extracts the string value from this DynAny.
 void insert_any(Any value)
Inserts an Any value into the Any represented by this DynAny.
 void insert_boolean(boolean value)
Inserts a boolean value into the DynAny.
 void insert_char(char value)
Inserts a char value into the DynAny.
 void insert_double(double value)
Inserts a double value into the DynAny.
 void insert_dyn_any(DynAny value)
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
 void insert_float(float value)
Inserts a float value into the DynAny.
 void insert_long(int value)
Inserts an integer value into the DynAny.
 void insert_longlong(long value)
Inserts a long value into the DynAny.
 void insert_octet(byte value)
Inserts a byte value into the DynAny.
 void insert_reference(Object value)
Inserts a reference to a CORBA object into the DynAny.
 void insert_short(short value)
Inserts a short value into the DynAny.
 void insert_string(String value)
Inserts a string value into the DynAny.
 void insert_typecode(TypeCode value)
Inserts a TypeCode object into the DynAny.
 void insert_ulong(int value)
Inserts an integer value into the DynAny.
 void insert_ulonglong(long value)
Inserts a long value into the DynAny.
 void insert_ushort(short value)
Inserts a short value into the DynAny.
 void insert_val(Serializable value)
Inserts a reference to a Serializable object into this DynAny.
 void insert_wchar(char value)
Inserts a char value into the DynAny.
 void insert_wstring(String value)
Inserts a string value into the DynAny.
 boolean next()
Advances the current position to the next component.
 void rewind()
Is equivalent to seek(0).
 boolean seek(int index)
Sets the current position to index.
 void set_members_as_dyn_any(NameDynAnyPair[] value)
Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs.
 void set_members(NameValuePair[] value)
Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs.
 Any to_any()
Creates an any value from a DynAny object.
 TypeCode type()
Returns the TypeCode associated with this DynAny object.
Methods inherited from class org.omg.CORBA.portable.ObjectImpl
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Field Detail

_opsClass

public static final Class _opsClass
Constructor Detail

_DynStructStub

public _DynStructStub()
Method Detail

current_member_name

public String current_member_name()
                           throws TypeMismatch,
                                  InvalidValue
Returns the name of the member at the current position. This operation may return an empty string since the TypeCode of the value being manipulated may not contain the names of members.

Specified by:
current_member_name in interface DynStructOperations
Throws:
TypeMismatch - if the DynStruct represents an empty exception.
InvalidValue - if the current position does not indicate a member

current_member_kind

public TCKind current_member_kind()
                           throws TypeMismatch,
                                  InvalidValue
Returns the TCKind associated with the member at the current position.

Specified by:
current_member_kind in interface DynStructOperations
Throws:
TypeMismatch - if the DynStruct represents an empty exception.
InvalidValue - if the current position does not indicate a member

get_members

public NameValuePair[] get_members()
Returns a sequence of NameValuePairs describing the name and the value of each member in the struct associated with a DynStruct object. The sequence contains members in the same order as the declaration order of members as indicated by the DynStruct's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynStruct's TypeCode does not contain member names.

Specified by:
get_members in interface DynStructOperations

set_members

public void set_members(NameValuePair[] value)
                 throws TypeMismatch,
                        InvalidValue
Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1.

Members must appear in the NameValuePairs in the order in which they appear in the IDL specification of the struct as indicated by the DynStruct's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

Specified by:
set_members in interface DynStructOperations
Throws:
TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynStruct's TypeCode and they are not empty strings
InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynStruct's TypeCode

get_members_as_dyn_any

public NameDynAnyPair[] get_members_as_dyn_any()
Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the struct associated with a DynStruct object. The sequence contains members in the same order as the declaration order of members as indicated by the DynStruct's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynStruct's TypeCode does not contain member names.

Specified by:
get_members_as_dyn_any in interface DynStructOperations

set_members_as_dyn_any

public void set_members_as_dyn_any(NameDynAnyPair[] value)
                            throws TypeMismatch,
                                   InvalidValue
Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1.

Members must appear in the NameDynAnyPairs in the order in which they appear in the IDL specification of the struct as indicated by the DynStruct's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

Specified by:
set_members_as_dyn_any in interface DynStructOperations
Throws:
TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynStruct's TypeCode and they are not empty strings
InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynStruct's TypeCode

type

public TypeCode type()
Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.

Specified by:
type in interface DynAnyOperations
Returns:
The TypeCode associated with this DynAny object

assign

public void assign(DynAny dyn_any)
            throws TypeMismatch
Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.

Specified by:
assign in interface DynAnyOperations
Parameters:
dyn_any -
Throws:
TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

from_any

public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.

Specified by:
from_any in interface DynAnyOperations
Throws:
TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
InvalidValue - if the passed Any does not contain a legal value (such as a null string)

to_any

public Any to_any()
Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.

Specified by:
to_any in interface DynAnyOperations
Returns:
a new Any object with the same value and TypeCode

equal

public boolean equal(DynAny dyn_any)
Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.

Specified by:
equal in interface DynAnyOperations
Returns:
true of the DynAnys are equal, false otherwise

destroy

public void destroy()
Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.

Specified by:
destroy in interface DynAnyOperations

copy

public DynAny copy()
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.

Specified by:
copy in interface DynAnyOperations
Returns:
a deep copy of the DynAny object

insert_boolean

public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
Inserts a boolean value into the DynAny.

Specified by:
insert_boolean in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_octet

public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.

Specified by:
insert_octet in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_char

public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
Inserts a char value into the DynAny.

Specified by:
insert_char in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_short

public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a short value into the DynAny.

Specified by:
insert_short in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ushort

public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.

Specified by:
insert_ushort in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_long

public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.

Specified by:
insert_long in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ulong

public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.

Specified by:
insert_ulong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_float

public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a float value into the DynAny.

Specified by:
insert_float in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_double

public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a double value into the DynAny.

Specified by:
insert_double in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_string

public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.

Specified by:
insert_string in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
InvalidValue - if the string inserted is longer than the bound of a bounded string
TypeMismatch - if called on a DynAny whose current component itself has components

insert_reference

public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
Inserts a reference to a CORBA object into the DynAny.

Specified by:
insert_reference in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_typecode

public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
Inserts a TypeCode object into the DynAny.

Specified by:
insert_typecode in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_longlong

public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.

Specified by:
insert_longlong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ulonglong

public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.

Specified by:
insert_ulonglong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_wchar

public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.

Specified by:
insert_wchar in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_wstring

public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.

Specified by:
insert_wstring in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
InvalidValue - if the string inserted is longer than the bound of a bounded string
TypeMismatch

insert_any

public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
Inserts an Any value into the Any represented by this DynAny.

Specified by:
insert_any in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_dyn_any

public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.

Specified by:
insert_dyn_any in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_val

public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.

Specified by:
insert_val in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

get_boolean

public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
Extracts the boolean value from this DynAny.

Specified by:
get_boolean in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_octet

public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.

Specified by:
get_octet in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_char

public char get_char()
              throws TypeMismatch,
                     InvalidValue
Extracts the char value from this DynAny.

Specified by:
get_char in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_short

public short get_short()
                throws TypeMismatch,
                       InvalidValue
Extracts the short value from this DynAny.

Specified by:
get_short in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ushort

public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.

Specified by:
get_ushort in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_long

public int get_long()
             throws TypeMismatch,
                    InvalidValue
Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.

Specified by:
get_long in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ulong

public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.

Specified by:
get_ulong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_float

public float get_float()
                throws TypeMismatch,
                       InvalidValue
Extracts the float value from this DynAny.

Specified by:
get_float in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_double

public double get_double()
                  throws TypeMismatch,
                         InvalidValue
Extracts the double value from this DynAny.

Specified by:
get_double in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_string

public String get_string()
                  throws TypeMismatch,
                         InvalidValue
Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.

Specified by:
get_string in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_reference

public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
Extracts the reference to a CORBA Object from this DynAny.

Specified by:
get_reference in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_typecode

public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
Extracts the TypeCode object from this DynAny.

Specified by:
get_typecode in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_longlong

public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.

Specified by:
get_longlong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ulonglong

public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.

Specified by:
get_ulonglong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_wchar

public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.

Specified by:
get_wchar in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_wstring

public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.

Specified by:
get_wstring in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue

get_any

public Any get_any()
            throws TypeMismatch,
                   InvalidValue
Extracts an Any value contained in the Any represented by this DynAny.

Specified by:
get_any in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_dyn_any

public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

Specified by:
get_dyn_any in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_val

public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.

Specified by:
get_val in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

seek

public boolean seek(int index)
Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.

Specified by:
seek in interface DynAnyOperations

rewind

public void rewind()
Is equivalent to seek(0).

Specified by:
rewind in interface DynAnyOperations

next

public boolean next()
Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.

Specified by:
next in interface DynAnyOperations

component_count

public int component_count()
Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
  • For sequences, the operation returns the current number of elements.
  • For structures, exceptions, and value types, the operation returns the number of members.
  • For arrays, the operation returns the number of elements.
  • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
  • For DynFixed and DynEnum, the operation returns zero.

Specified by:
component_count in interface DynAnyOperations

current_component

public DynAny current_component()
                         throws TypeMismatch
Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.

Specified by:
current_component in interface DynAnyOperations
Throws:
TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

_ids

public String[] _ids()
Description copied from class: ObjectImpl
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.

Specified by:
_ids in class ObjectImpl
Returns:
the array of all repository identifiers supported by this ObjectImpl instance
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynUnion (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Interface DynUnion

All Superinterfaces:
DynAny, DynAnyOperations, DynUnionOperations, IDLEntity, Object, Serializable
All Known Implementing Classes:
_DynUnionStub
public interface DynUnion
extends DynUnionOperations, DynAny, IDLEntity

DynUnion objects support the manipulation of IDL unions. A union can have only two valid current positions:

  • zero, which denotes the discriminator
  • one, which denotes the active member
The component_count value for a union depends on the current discriminator: it is 2 for a union whose discriminator indicates a named member, and 1 otherwise.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.DynamicAny.DynUnionOperations
discriminator_kind, get_discriminator, has_no_active_member, member_kind, member_name, member, set_discriminator, set_to_default_member, set_to_no_active_member
Methods inherited from interface org.omg.DynamicAny.DynAnyOperations
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynUnionHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class DynUnionHelper

java.lang.Object
    extended by  org.omg.DynamicAny.DynUnionHelper

public abstract class DynUnionHelper
extends Object

DynUnion objects support the manipulation of IDL unions. A union can have only two valid current positions:

  • zero, which denotes the discriminator
  • one, which denotes the active member
The component_count value for a union depends on the current discriminator: it is 2 for a union whose discriminator indicates a named member, and 1 otherwise.

Constructor Summary
Constructor and Description
DynUnionHelper()
Method Summary
Modifier and Type | Method and Description
static DynUnion | extract(Any a)
static String | id()
static void | insert(Any a, DynUnion that)
static DynUnion | narrow(Object obj)
static DynUnion | read(InputStream istream)
static TypeCode | type()
static DynUnion | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, DynUnion value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DynUnionHelper

public DynUnionHelper()
Method Detail

insert

public static void insert(Any a,
                          DynUnion that)

extract

public static DynUnion extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static DynUnion read(InputStream istream)

write

public static void write(OutputStream ostream,
                         DynUnion value)

narrow

public static DynUnion narrow(Object obj)

unchecked_narrow

public static DynUnion unchecked_narrow(Object obj)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynUnionOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Interface DynUnionOperations

All Superinterfaces:
DynAnyOperations
All Known Subinterfaces:
DynUnion
All Known Implementing Classes:
_DynUnionStub
public interface DynUnionOperations
extends DynAnyOperations

DynUnion objects support the manipulation of IDL unions. A union can have only two valid current positions:

  • zero, which denotes the discriminator
  • one, which denotes the active member
The component_count value for a union depends on the current discriminator: it is 2 for a union whose discriminator indicates a named member, and 1 otherwise.

Method Summary
Modifier and Type | Method and Description
TCKind | discriminator_kind() Returns the TCKind value of the discriminators TypeCode.
DynAny | get_discriminator() Returns the current discriminator value.
boolean | has_no_active_member() Returns true if the union has no active member, that is, the unions value consists solely of its discriminator because the discriminator has a value that is not listed as an explicit case label.
TCKind | member_kind() Returns the TCKind value of the currently active members TypeCode.
String | member_name() Returns the name of the currently active member.
DynAny | member() Returns the currently active member.
void | set_discriminator(DynAny d) Sets the discriminator of the DynUnion to the specified value.
void | set_to_default_member() Sets the discriminator to a value that is consistent with the value of the default case of a union.
void | set_to_no_active_member() Sets the discriminator to a value that does not correspond to any of the unions case labels.
Methods inherited from interface org.omg.DynamicAny.DynAnyOperations
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

Method Detail

get_discriminator

DynAny get_discriminator()
Returns the current discriminator value.

set_discriminator

void set_discriminator(DynAny d)
                       throws TypeMismatch
Sets the discriminator of the DynUnion to the specified value. Setting the discriminator to a value that is consistent with the currently active union member does not affect the currently active member. Setting the discriminator to a value that is inconsistent with the currently active member deactivates the member and activates the member that is consistent with the new discriminator value (if there is a member for that value) by initializing the member to its default value. Setting the discriminator of a union sets the current position to 0 if the discriminator value indicates a non-existent union member (has_no_active_member returns true in this case). Otherwise, if the discriminator value indicates a named union member, the current position is set to 1 (has_no_active_member returns false and component_count returns 2 in this case).

Throws:
TypeMismatch - if the TypeCode of the parameter is not equivalent to the TypeCode of the union's discriminator

set_to_default_member

void set_to_default_member()
                           throws TypeMismatch
Sets the discriminator to a value that is consistent with the value of the default case of a union. It sets the current position to zero and causes component_count to return 2.

Throws:
TypeMismatch - if the union does not have an explicit default case

set_to_no_active_member

void set_to_no_active_member()
                             throws TypeMismatch
Sets the discriminator to a value that does not correspond to any of the unions case labels. It sets the current position to zero and causes component_count to return 1.

Throws:
TypeMismatch - if the union has an explicit default case or if it uses the entire range of discriminator values for explicit case labels

has_no_active_member

boolean has_no_active_member()
Returns true if the union has no active member, that is, the unions value consists solely of its discriminator because the discriminator has a value that is not listed as an explicit case label. Calling this operation on a union that has a default case returns false. Calling this operation on a union that uses the entire range of discriminator values for explicit case labels returns false.

discriminator_kind

TCKind discriminator_kind()
Returns the TCKind value of the discriminators TypeCode.

member_kind

TCKind member_kind()
                   throws InvalidValue
Returns the TCKind value of the currently active members TypeCode.

Throws:
InvalidValue - if the union does not have a currently active member

member

DynAny member()
              throws InvalidValue
Returns the currently active member. Note that the returned reference remains valid only for as long as the currently active member does not change. Using the returned reference beyond the life time of the currently active member raises OBJECT_NOT_EXIST.

Throws:
InvalidValue - if the union has no active member

member_name

String member_name()
                   throws InvalidValue
Returns the name of the currently active member. If the unions TypeCode does not contain a member name for the currently active member, the operation returns an empty string.

Throws:
InvalidValue - if the union has no active member
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


_DynUnionStub (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class _DynUnionStub

java.lang.Object
    extended by  org.omg.CORBA.portable.ObjectImpl
        extended by  org.omg.DynamicAny._DynUnionStub
All Implemented Interfaces:
Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynUnion, DynUnionOperations
public class _DynUnionStub
extends ObjectImpl
implements DynUnion

DynUnion objects support the manipulation of IDL unions. A union can have only two valid current positions:

  • zero, which denotes the discriminator
  • one, which denotes the active member
The component_count value for a union depends on the current discriminator: it is 2 for a union whose discriminator indicates a named member, and 1 otherwise.

Field Summary
Modifier and Type | Field and Description
static Class | _opsClass
Constructor Summary
Constructor and Description
_DynUnionStub()
Method Summary
Modifier and Type Method and Description
 String[] _ids()
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
 void assign(DynAny dyn_any)
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
 int component_count()
Returns the number of components of a DynAny.
 DynAny copy()
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
 DynAny current_component()
Returns the DynAny for the component at the current position.
 void destroy()
Destroys a DynAny object.
 TCKind discriminator_kind()
Returns the TCKind value of the discriminators TypeCode.
 boolean equal(DynAny dyn_any)
Compares two DynAny values for equality.
 void from_any(Any value)
Initializes the value associated with a DynAny object with the value contained in an any.
 Any get_any()
Extracts an Any value contained in the Any represented by this DynAny.
 boolean get_boolean()
Extracts the boolean value from this DynAny.
 char get_char()
Extracts the char value from this DynAny.
 DynAny get_discriminator()
Returns the current discriminator value.
 double get_double()
Extracts the double value from this DynAny.
 DynAny get_dyn_any()
Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
 float get_float()
Extracts the float value from this DynAny.
 int get_long()
Extracts the integer value from this DynAny.
 long get_longlong()
Extracts the long value from this DynAny.
 byte get_octet()
Extracts the byte value from this DynAny.
 Object get_reference()
Extracts the reference to a CORBA Object from this DynAny.
 short get_short()
Extracts the short value from this DynAny.
 String get_string()
Extracts the string value from this DynAny.
 TypeCode get_typecode()
Extracts the TypeCode object from this DynAny.
 int get_ulong()
Extracts the integer value from this DynAny.
 long get_ulonglong()
Extracts the long value from this DynAny.
 short get_ushort()
Extracts the short value from this DynAny.
 Serializable get_val()
Extracts a Serializable object from this DynAny.
 char get_wchar()
Extracts the long value from this DynAny.
 String get_wstring()
Extracts the string value from this DynAny.
 boolean has_no_active_member()
Returns true if the union has no active member, that is, the unions value consists solely of its discriminator because the discriminator has a value that is not listed as an explicit case label.
 void insert_any(Any value)
Inserts an Any value into the Any represented by this DynAny.
 void insert_boolean(boolean value)
Inserts a boolean value into the DynAny.
 void insert_char(char value)
Inserts a char value into the DynAny.
 void insert_double(double value)
Inserts a double value into the DynAny.
 void insert_dyn_any(DynAny value)
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
 void insert_float(float value)
Inserts a float value into the DynAny.
 void insert_long(int value)
Inserts an integer value into the DynAny.
 void insert_longlong(long value)
Inserts a long value into the DynAny.
 void insert_octet(byte value)
Inserts a byte value into the DynAny.
 void insert_reference(Object value)
Inserts a reference to a CORBA object into the DynAny.
 void insert_short(short value)
Inserts a short value into the DynAny.
 void insert_string(String value)
Inserts a string value into the DynAny.
 void insert_typecode(TypeCode value)
Inserts a TypeCode object into the DynAny.
 void insert_ulong(int value)
Inserts an integer value into the DynAny.
 void insert_ulonglong(long value)
Inserts a long value into the DynAny.
 void insert_ushort(short value)
Inserts a short value into the DynAny.
 void insert_val(Serializable value)
Inserts a reference to a Serializable object into this DynAny.
 void insert_wchar(char value)
Inserts a char value into the DynAny.
 void insert_wstring(String value)
Inserts a string value into the DynAny.
 TCKind member_kind()
Returns the TCKind value of the currently active members TypeCode.
 String member_name()
Returns the name of the currently active member.
 DynAny member()
Returns the currently active member.
 boolean next()
Advances the current position to the next component.
 void rewind()
Is equivalent to seek(0).
 boolean seek(int index)
Sets the current position to index.
 void set_discriminator(DynAny d)
Sets the discriminator of the DynUnion to the specified value.
 void set_to_default_member()
Sets the discriminator to a value that is consistent with the value of the default case of a union.
 void set_to_no_active_member()
Sets the discriminator to a value that does not correspond to any of the unions case labels.
 Any to_any()
Creates an any value from a DynAny object.
 TypeCode type()
Returns the TypeCode associated with this DynAny object.
Methods inherited from class org.omg.CORBA.portable.ObjectImpl
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Field Detail

_opsClass

public static final Class _opsClass
Constructor Detail

_DynUnionStub

public _DynUnionStub()
Method Detail

get_discriminator

public DynAny get_discriminator()
Returns the current discriminator value.

Specified by:
get_discriminator in interface DynUnionOperations

set_discriminator

public void set_discriminator(DynAny d)
                       throws TypeMismatch
Sets the discriminator of the DynUnion to the specified value. Setting the discriminator to a value that is consistent with the currently active union member does not affect the currently active member. Setting the discriminator to a value that is inconsistent with the currently active member deactivates the member and activates the member that is consistent with the new discriminator value (if there is a member for that value) by initializing the member to its default value. Setting the discriminator of a union sets the current position to 0 if the discriminator value indicates a non-existent union member (has_no_active_member returns true in this case). Otherwise, if the discriminator value indicates a named union member, the current position is set to 1 (has_no_active_member returns false and component_count returns 2 in this case).

Specified by:
set_discriminator in interface DynUnionOperations
Throws:
TypeMismatch - if the TypeCode of the parameter is not equivalent to the TypeCode of the union's discriminator

set_to_default_member

public void set_to_default_member()
                           throws TypeMismatch
Sets the discriminator to a value that is consistent with the value of the default case of a union. It sets the current position to zero and causes component_count to return 2.

Specified by:
set_to_default_member in interface DynUnionOperations
Throws:
TypeMismatch - if the union does not have an explicit default case

set_to_no_active_member

public void set_to_no_active_member()
                             throws TypeMismatch
Sets the discriminator to a value that does not correspond to any of the unions case labels. It sets the current position to zero and causes component_count to return 1.

Specified by:
set_to_no_active_member in interface DynUnionOperations
Throws:
TypeMismatch - if the union has an explicit default case or if it uses the entire range of discriminator values for explicit case labels

has_no_active_member

public boolean has_no_active_member()
Returns true if the union has no active member, that is, the unions value consists solely of its discriminator because the discriminator has a value that is not listed as an explicit case label. Calling this operation on a union that has a default case returns false. Calling this operation on a union that uses the entire range of discriminator values for explicit case labels returns false.

Specified by:
has_no_active_member in interface DynUnionOperations

discriminator_kind

public TCKind discriminator_kind()
Returns the TCKind value of the discriminators TypeCode.

Specified by:
discriminator_kind in interface DynUnionOperations

member_kind

public TCKind member_kind()
                   throws InvalidValue
Returns the TCKind value of the currently active members TypeCode.

Specified by:
member_kind in interface DynUnionOperations
Throws:
InvalidValue - if the union does not have a currently active member

member

public DynAny member()
              throws InvalidValue
Returns the currently active member. Note that the returned reference remains valid only for as long as the currently active member does not change. Using the returned reference beyond the life time of the currently active member raises OBJECT_NOT_EXIST.

Specified by:
member in interface DynUnionOperations
Throws:
InvalidValue - if the union has no active member

member_name

public String member_name()
                   throws InvalidValue
Returns the name of the currently active member. If the unions TypeCode does not contain a member name for the currently active member, the operation returns an empty string.

Specified by:
member_name in interface DynUnionOperations
Throws:
InvalidValue - if the union has no active member

type

public TypeCode type()
Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.

Specified by:
type in interface DynAnyOperations
Returns:
The TypeCode associated with this DynAny object

assign

public void assign(DynAny dyn_any)
            throws TypeMismatch
Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.

Specified by:
assign in interface DynAnyOperations
Parameters:
dyn_any -
Throws:
TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

from_any

public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.

Specified by:
from_any in interface DynAnyOperations
Throws:
TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
InvalidValue - if the passed Any does not contain a legal value (such as a null string)

to_any

public Any to_any()
Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.

Specified by:
to_any in interface DynAnyOperations
Returns:
a new Any object with the same value and TypeCode

equal

public boolean equal(DynAny dyn_any)
Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.

Specified by:
equal in interface DynAnyOperations
Returns:
true of the DynAnys are equal, false otherwise

destroy

public void destroy()
Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.

Specified by:
destroy in interface DynAnyOperations

copy

public DynAny copy()
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.

Specified by:
copy in interface DynAnyOperations
Returns:
a deep copy of the DynAny object

insert_boolean

public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
Inserts a boolean value into the DynAny.

Specified by:
insert_boolean in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_octet

public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.

Specified by:
insert_octet in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_char

public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
Inserts a char value into the DynAny.

Specified by:
insert_char in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_short

public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a short value into the DynAny.

Specified by:
insert_short in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ushort

public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.

Specified by:
insert_ushort in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_long

public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.

Specified by:
insert_long in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ulong

public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.

Specified by:
insert_ulong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_float

public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a float value into the DynAny.

Specified by:
insert_float in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_double

public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a double value into the DynAny.

Specified by:
insert_double in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_string

public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.

Specified by:
insert_string in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
InvalidValue - if the string inserted is longer than the bound of a bounded string
TypeMismatch - if called on a DynAny whose current component itself has components

insert_reference

public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
Inserts a reference to a CORBA object into the DynAny.

Specified by:
insert_reference in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_typecode

public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
Inserts a TypeCode object into the DynAny.

Specified by:
insert_typecode in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_longlong

public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.

Specified by:
insert_longlong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ulonglong

public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.

Specified by:
insert_ulonglong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_wchar

public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.

Specified by:
insert_wchar in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_wstring

public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.

Specified by:
insert_wstring in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
InvalidValue - if the string inserted is longer than the bound of a bounded string
TypeMismatch

insert_any

public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
Inserts an Any value into the Any represented by this DynAny.

Specified by:
insert_any in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_dyn_any

public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.

Specified by:
insert_dyn_any in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_val

public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.

Specified by:
insert_val in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

get_boolean

public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
Extracts the boolean value from this DynAny.

Specified by:
get_boolean in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_octet

public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.

Specified by:
get_octet in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_char

public char get_char()
              throws TypeMismatch,
                     InvalidValue
Extracts the char value from this DynAny.

Specified by:
get_char in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_short

public short get_short()
                throws TypeMismatch,
                       InvalidValue
Extracts the short value from this DynAny.

Specified by:
get_short in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ushort

public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.

Specified by:
get_ushort in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_long

public int get_long()
             throws TypeMismatch,
                    InvalidValue
Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.

Specified by:
get_long in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ulong

public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.

Specified by:
get_ulong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_float

public float get_float()
                throws TypeMismatch,
                       InvalidValue
Extracts the float value from this DynAny.

Specified by:
get_float in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_double

public double get_double()
                  throws TypeMismatch,
                         InvalidValue
Extracts the double value from this DynAny.

Specified by:
get_double in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_string

public String get_string()
                  throws TypeMismatch,
                         InvalidValue
Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.

Specified by:
get_string in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_reference

public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
Extracts the reference to a CORBA Object from this DynAny.

Specified by:
get_reference in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_typecode

public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
Extracts the TypeCode object from this DynAny.

Specified by:
get_typecode in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_longlong

public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.

Specified by:
get_longlong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ulonglong

public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.

Specified by:
get_ulonglong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_wchar

public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.

Specified by:
get_wchar in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_wstring

public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.

Specified by:
get_wstring in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue

get_any

public Any get_any()
            throws TypeMismatch,
                   InvalidValue
Extracts an Any value contained in the Any represented by this DynAny.

Specified by:
get_any in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_dyn_any

public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

Specified by:
get_dyn_any in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_val

public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.

Specified by:
get_val in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

seek

public boolean seek(int index)
Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.

Specified by:
seek in interface DynAnyOperations

rewind

public void rewind()
Is equivalent to seek(0).

Specified by:
rewind in interface DynAnyOperations

next

public boolean next()
Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.

Specified by:
next in interface DynAnyOperations

component_count

public int component_count()
Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
  • For sequences, the operation returns the current number of elements.
  • For structures, exceptions, and value types, the operation returns the number of members.
  • For arrays, the operation returns the number of elements.
  • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
  • For DynFixed and DynEnum, the operation returns zero.

Specified by:
component_count in interface DynAnyOperations

current_component

public DynAny current_component()
                         throws TypeMismatch
Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.

Specified by:
current_component in interface DynAnyOperations
Throws:
TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

_ids

public String[] _ids()
Description copied from class: ObjectImpl
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.

Specified by:
_ids in class ObjectImpl
Returns:
the array of all repository identifiers supported by this ObjectImpl instance
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynValue (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Interface DynValue

All Superinterfaces:
DynAny, DynAnyOperations, DynValueCommon, DynValueCommonOperations, DynValueOperations, IDLEntity, Object, Serializable
All Known Implementing Classes:
_DynValueStub
public interface DynValue
extends DynValueOperations, DynValueCommon, IDLEntity

DynValue objects support the manipulation of IDL non-boxed value types. The DynValue interface can represent both null and non-null value types. For a DynValue representing a non-null value type, the DynValue's components comprise the public and private members of the value type, including those inherited from concrete base value types, in the order of definition. A DynValue representing a null value type has no components and a current position of -1.

Warning: Indiscriminantly changing the contents of private value type members can cause the value type implementation to break by violating internal constraints. Access to private members is provided to support such activities as ORB bridging and debugging and should not be used to arbitrarily violate the encapsulation of the value type.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.DynamicAny.DynValueOperations
current_member_kind, current_member_name, get_members_as_dyn_any, get_members, set_members_as_dyn_any, set_members
Methods inherited from interface org.omg.DynamicAny.DynValueCommonOperations
is_null, set_to_null, set_to_value
Methods inherited from interface org.omg.DynamicAny.DynAnyOperations
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynValueBox (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Interface DynValueBox

All Superinterfaces:
DynAny, DynAnyOperations, DynValueBoxOperations, DynValueCommon, DynValueCommonOperations, IDLEntity, Object, Serializable
public interface DynValueBox
extends DynValueBoxOperations, DynValueCommon, IDLEntity

DynValueBox objects support the manipulation of IDL boxed value types. The DynValueBox interface can represent both null and non-null value types. For a DynValueBox representing a non-null value type, the DynValueBox has a single component of the boxed type. A DynValueBox representing a null value type has no components and a current position of -1.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.DynamicAny.DynValueBoxOperations
get_boxed_value_as_dyn_any, get_boxed_value, set_boxed_value_as_dyn_any, set_boxed_value
Methods inherited from interface org.omg.DynamicAny.DynValueCommonOperations
is_null, set_to_null, set_to_value
Methods inherited from interface org.omg.DynamicAny.DynAnyOperations
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynValueBoxOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Interface DynValueBoxOperations

All Superinterfaces:
DynAnyOperations, DynValueCommonOperations
All Known Subinterfaces:
DynValueBox
public interface DynValueBoxOperations
extends DynValueCommonOperations

DynValueBox objects support the manipulation of IDL boxed value types. The DynValueBox interface can represent both null and non-null value types. For a DynValueBox representing a non-null value type, the DynValueBox has a single component of the boxed type. A DynValueBox representing a null value type has no components and a current position of -1.

Method Summary
Modifier and Type | Method and Description
DynAny | get_boxed_value_as_dyn_any() Returns the boxed value as a DynAny.
Any | get_boxed_value() Returns the boxed value as an Any.
void | set_boxed_value_as_dyn_any(DynAny boxed) Replaces the boxed value with the value contained in the parameter.
void | set_boxed_value(Any boxed) Replaces the boxed value with the specified value.
Methods inherited from interface org.omg.DynamicAny.DynValueCommonOperations
is_null, set_to_null, set_to_value
Methods inherited from interface org.omg.DynamicAny.DynAnyOperations
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

Method Detail

get_boxed_value

Any get_boxed_value()
                    throws InvalidValue
Returns the boxed value as an Any.

Throws:
InvalidValue - if this object represents a null value box type

set_boxed_value

void set_boxed_value(Any boxed)
                     throws TypeMismatch
Replaces the boxed value with the specified value. If the DynBoxedValue represents a null valuetype, it is converted to a non-null value.

Throws:
TypeMismatch - if this object represents a non-null value box type and the type of the parameter is not matching the current boxed value type.

get_boxed_value_as_dyn_any

DynAny get_boxed_value_as_dyn_any()
                                  throws InvalidValue
Returns the boxed value as a DynAny.

Throws:
InvalidValue - if this object represents a null value box type

set_boxed_value_as_dyn_any

void set_boxed_value_as_dyn_any(DynAny boxed)
                                throws TypeMismatch
Replaces the boxed value with the value contained in the parameter. If the DynBoxedValue represents a null valuetype, it is converted to a non-null value.

Throws:
TypeMismatch - if this object represents a non-null value box type and the type of the parameter is not matching the current boxed value type.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynValueCommon (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Interface DynValueCommon

All Superinterfaces:
DynAny, DynAnyOperations, DynValueCommonOperations, IDLEntity, Object, Serializable
All Known Subinterfaces:
DynValue, DynValueBox
All Known Implementing Classes:
_DynValueStub
public interface DynValueCommon
extends DynValueCommonOperations, DynAny, IDLEntity

DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.DynamicAny.DynValueCommonOperations
is_null, set_to_null, set_to_value
Methods inherited from interface org.omg.DynamicAny.DynAnyOperations
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynValueCommonOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Interface DynValueCommonOperations

All Superinterfaces:
DynAnyOperations
All Known Subinterfaces:
DynValue, DynValueBox, DynValueBoxOperations, DynValueCommon, DynValueOperations
All Known Implementing Classes:
_DynValueStub
public interface DynValueCommonOperations
extends DynAnyOperations

DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.

Method Summary
Modifier and Type | Method and Description
boolean | is_null() Returns true if the DynValueCommon represents a null value type.
void | set_to_null() Changes the representation of a DynValueCommon to a null value type.
void | set_to_value() Replaces a null value type with a newly constructed value.
Methods inherited from interface org.omg.DynamicAny.DynAnyOperations
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

Method Detail

is_null

boolean is_null()
Returns true if the DynValueCommon represents a null value type.

set_to_null

void set_to_null()
Changes the representation of a DynValueCommon to a null value type.

set_to_value

void set_to_value()
Replaces a null value type with a newly constructed value. Its components are initialized to default values as in DynAnyFactory.create_dyn_any_from_type_code. If the DynValueCommon represents a non-null value type, then this operation has no effect.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynValueHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class DynValueHelper

java.lang.Object
    extended by  org.omg.DynamicAny.DynValueHelper

public abstract class DynValueHelper
extends Object

DynValue objects support the manipulation of IDL non-boxed value types. The DynValue interface can represent both null and non-null value types. For a DynValue representing a non-null value type, the DynValue's components comprise the public and private members of the value type, including those inherited from concrete base value types, in the order of definition. A DynValue representing a null value type has no components and a current position of -1.

Warning: Indiscriminantly changing the contents of private value type members can cause the value type implementation to break by violating internal constraints. Access to private members is provided to support such activities as ORB bridging and debugging and should not be used to arbitrarily violate the encapsulation of the value type.

Constructor Summary
Constructor and Description
DynValueHelper()
Method Summary
Modifier and Type | Method and Description
static DynValue | extract(Any a)
static String | id()
static void | insert(Any a, DynValue that)
static DynValue | narrow(Object obj)
static DynValue | read(InputStream istream)
static TypeCode | type()
static DynValue | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, DynValue value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DynValueHelper

public DynValueHelper()
Method Detail

insert

public static void insert(Any a,
                          DynValue that)

extract

public static DynValue extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static DynValue read(InputStream istream)

write

public static void write(OutputStream ostream,
                         DynValue value)

narrow

public static DynValue narrow(Object obj)

unchecked_narrow

public static DynValue unchecked_narrow(Object obj)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynValueOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Interface DynValueOperations

All Superinterfaces:
DynAnyOperations, DynValueCommonOperations
All Known Subinterfaces:
DynValue
All Known Implementing Classes:
_DynValueStub
public interface DynValueOperations
extends DynValueCommonOperations

DynValue objects support the manipulation of IDL non-boxed value types. The DynValue interface can represent both null and non-null value types. For a DynValue representing a non-null value type, the DynValue's components comprise the public and private members of the value type, including those inherited from concrete base value types, in the order of definition. A DynValue representing a null value type has no components and a current position of -1.

Warning: Indiscriminantly changing the contents of private value type members can cause the value type implementation to break by violating internal constraints. Access to private members is provided to support such activities as ORB bridging and debugging and should not be used to arbitrarily violate the encapsulation of the value type.

Method Summary
Modifier and Type | Method and Description
TCKind | current_member_kind() Returns the TCKind associated with the member at the current position.
String | current_member_name() Returns the name of the member at the current position.
NameDynAnyPair[] | get_members_as_dyn_any() Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type.
NameValuePair[] | get_members() Returns a sequence of NameValuePairs describing the name and the value of each member in the value type.
void | set_members_as_dyn_any(NameDynAnyPair[] value) Initializes the value type's members from a sequence of NameDynAnyPairs.
void | set_members(NameValuePair[] value) Initializes the value type's members from a sequence of NameValuePairs.
Methods inherited from interface org.omg.DynamicAny.DynValueCommonOperations
is_null, set_to_null, set_to_value
Methods inherited from interface org.omg.DynamicAny.DynAnyOperations
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

Method Detail

current_member_name

String current_member_name()
                           throws TypeMismatch,
                                  InvalidValue
Returns the name of the member at the current position. This operation may return an empty string since the TypeCode of the value being manipulated may not contain the names of members.

Throws:
TypeMismatch - if the DynValue represents a null value type.
InvalidValue - if the current position does not indicate a member

current_member_kind

TCKind current_member_kind()
                           throws TypeMismatch,
                                  InvalidValue
Returns the TCKind associated with the member at the current position.

Throws:
TypeMismatch - if the DynValue represents a null value type.
InvalidValue - if the current position does not indicate a member

get_members

NameValuePair[] get_members()
                            throws InvalidValue
Returns a sequence of NameValuePairs describing the name and the value of each member in the value type. The sequence contains members in the same order as the declaration order of members as indicated by the DynValue's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynValue's TypeCode does not contain member names.

Throws:
InvalidValue - if this object represents a null value type

set_members

void set_members(NameValuePair[] value)
                 throws TypeMismatch,
                        InvalidValue
Initializes the value type's members from a sequence of NameValuePairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1. A null value type can be initialized to a non-null value type using this method.

Members must appear in the NameValuePairs in the order in which they appear in the IDL specification of the value type as indicated by the DynValue's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

Throws:
TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynValue's TypeCode and they are not empty strings
InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynValue's TypeCode

get_members_as_dyn_any

NameDynAnyPair[] get_members_as_dyn_any()
                                        throws InvalidValue
Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type. The sequence contains members in the same order as the declaration order of members as indicated by the DynValue's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynValue's TypeCode does not contain member names.

Throws:
InvalidValue - if this object represents a null value type

set_members_as_dyn_any

void set_members_as_dyn_any(NameDynAnyPair[] value)
                            throws TypeMismatch,
                                   InvalidValue
Initializes the value type's members from a sequence of NameDynAnyPairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1. A null value type can be initialized to a non-null value type using this method.

Members must appear in the NameDynAnyPairs in the order in which they appear in the IDL specification of the value type as indicated by the DynValue's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

Throws:
TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynValue's TypeCode and they are not empty strings
InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynValue's TypeCode
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


_DynValueStub (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class _DynValueStub

java.lang.Object
    extended by  org.omg.CORBA.portable.ObjectImpl
        extended by  org.omg.DynamicAny._DynValueStub
All Implemented Interfaces:
Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynValue, DynValueCommon, DynValueCommonOperations, DynValueOperations
public class _DynValueStub
extends ObjectImpl
implements DynValue

DynValue objects support the manipulation of IDL non-boxed value types. The DynValue interface can represent both null and non-null value types. For a DynValue representing a non-null value type, the DynValue's components comprise the public and private members of the value type, including those inherited from concrete base value types, in the order of definition. A DynValue representing a null value type has no components and a current position of -1.

Warning: Indiscriminantly changing the contents of private value type members can cause the value type implementation to break by violating internal constraints. Access to private members is provided to support such activities as ORB bridging and debugging and should not be used to arbitrarily violate the encapsulation of the value type.

Field Summary
Modifier and Type | Field and Description
static Class | _opsClass
Constructor Summary
Constructor and Description
_DynValueStub()
Method Summary
Modifier and Type Method and Description
 String[] _ids()
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
 void assign(DynAny dyn_any)
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
 int component_count()
Returns the number of components of a DynAny.
 DynAny copy()
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
 DynAny current_component()
Returns the DynAny for the component at the current position.
 TCKind current_member_kind()
Returns the TCKind associated with the member at the current position.
 String current_member_name()
Returns the name of the member at the current position.
 void destroy()
Destroys a DynAny object.
 boolean equal(DynAny dyn_any)
Compares two DynAny values for equality.
 void from_any(Any value)
Initializes the value associated with a DynAny object with the value contained in an any.
 Any get_any()
Extracts an Any value contained in the Any represented by this DynAny.
 boolean get_boolean()
Extracts the boolean value from this DynAny.
 char get_char()
Extracts the char value from this DynAny.
 double get_double()
Extracts the double value from this DynAny.
 DynAny get_dyn_any()
Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
 float get_float()
Extracts the float value from this DynAny.
 int get_long()
Extracts the integer value from this DynAny.
 long get_longlong()
Extracts the long value from this DynAny.
 NameDynAnyPair[] get_members_as_dyn_any()
Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type.
 NameValuePair[] get_members()
Returns a sequence of NameValuePairs describing the name and the value of each member in the value type.
 byte get_octet()
Extracts the byte value from this DynAny.
 Object get_reference()
Extracts the reference to a CORBA Object from this DynAny.
 short get_short()
Extracts the short value from this DynAny.
 String get_string()
Extracts the string value from this DynAny.
 TypeCode get_typecode()
Extracts the TypeCode object from this DynAny.
 int get_ulong()
Extracts the integer value from this DynAny.
 long get_ulonglong()
Extracts the long value from this DynAny.
 short get_ushort()
Extracts the short value from this DynAny.
 Serializable get_val()
Extracts a Serializable object from this DynAny.
 char get_wchar()
Extracts the long value from this DynAny.
 String get_wstring()
Extracts the string value from this DynAny.
 void insert_any(Any value)
Inserts an Any value into the Any represented by this DynAny.
 void insert_boolean(boolean value)
Inserts a boolean value into the DynAny.
 void insert_char(char value)
Inserts a char value into the DynAny.
 void insert_double(double value)
Inserts a double value into the DynAny.
 void insert_dyn_any(DynAny value)
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
 void insert_float(float value)
Inserts a float value into the DynAny.
 void insert_long(int value)
Inserts an integer value into the DynAny.
 void insert_longlong(long value)
Inserts a long value into the DynAny.
 void insert_octet(byte value)
Inserts a byte value into the DynAny.
 void insert_reference(Object value)
Inserts a reference to a CORBA object into the DynAny.
 void insert_short(short value)
Inserts a short value into the DynAny.
 void insert_string(String value)
Inserts a string value into the DynAny.
 void insert_typecode(TypeCode value)
Inserts a TypeCode object into the DynAny.
 void insert_ulong(int value)
Inserts an integer value into the DynAny.
 void insert_ulonglong(long value)
Inserts a long value into the DynAny.
 void insert_ushort(short value)
Inserts a short value into the DynAny.
 void insert_val(Serializable value)
Inserts a reference to a Serializable object into this DynAny.
 void insert_wchar(char value)
Inserts a char value into the DynAny.
 void insert_wstring(String value)
Inserts a string value into the DynAny.
 boolean is_null()
Returns true if the DynValueCommon represents a null value type.
 boolean next()
Advances the current position to the next component.
 void rewind()
Is equivalent to seek(0).
 boolean seek(int index)
Sets the current position to index.
 void set_members_as_dyn_any(NameDynAnyPair[] value)
Initializes the value type's members from a sequence of NameDynAnyPairs.
 void set_members(NameValuePair[] value)
Initializes the value type's members from a sequence of NameValuePairs.
 void set_to_null()
Changes the representation of a DynValueCommon to a null value type.
 void set_to_value()
Replaces a null value type with a newly constructed value.
 Any to_any()
Creates an any value from a DynAny object.
 TypeCode type()
Returns the TypeCode associated with this DynAny object.
Methods inherited from class org.omg.CORBA.portable.ObjectImpl
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Field Detail

_opsClass

public static final Class _opsClass
Constructor Detail

_DynValueStub

public _DynValueStub()
Method Detail

current_member_name

public String current_member_name()
                           throws TypeMismatch,
                                  InvalidValue
Returns the name of the member at the current position. This operation may return an empty string since the TypeCode of the value being manipulated may not contain the names of members.

Specified by:
current_member_name in interface DynValueOperations
Throws:
TypeMismatch - if the DynValue represents a null value type.
InvalidValue - if the current position does not indicate a member

current_member_kind

public TCKind current_member_kind()
                           throws TypeMismatch,
                                  InvalidValue
Returns the TCKind associated with the member at the current position.

Specified by:
current_member_kind in interface DynValueOperations
Throws:
TypeMismatch - if the DynValue represents a null value type.
InvalidValue - if the current position does not indicate a member

get_members

public NameValuePair[] get_members()
                            throws InvalidValue
Returns a sequence of NameValuePairs describing the name and the value of each member in the value type. The sequence contains members in the same order as the declaration order of members as indicated by the DynValue's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynValue's TypeCode does not contain member names.

Specified by:
get_members in interface DynValueOperations
Throws:
InvalidValue - if this object represents a null value type

set_members

public void set_members(NameValuePair[] value)
                 throws TypeMismatch,
                        InvalidValue
Initializes the value type's members from a sequence of NameValuePairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1. A null value type can be initialized to a non-null value type using this method.

Members must appear in the NameValuePairs in the order in which they appear in the IDL specification of the value type as indicated by the DynValue's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

Specified by:
set_members in interface DynValueOperations
Throws:
TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynValue's TypeCode and they are not empty strings
InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynValue's TypeCode

get_members_as_dyn_any

public NameDynAnyPair[] get_members_as_dyn_any()
                                        throws InvalidValue
Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type. The sequence contains members in the same order as the declaration order of members as indicated by the DynValue's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynValue's TypeCode does not contain member names.

Specified by:
get_members_as_dyn_any in interface DynValueOperations
Throws:
InvalidValue - if this object represents a null value type

set_members_as_dyn_any

public void set_members_as_dyn_any(NameDynAnyPair[] value)
                            throws TypeMismatch,
                                   InvalidValue
Initializes the value type's members from a sequence of NameDynAnyPairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1. A null value type can be initialized to a non-null value type using this method.

Members must appear in the NameDynAnyPairs in the order in which they appear in the IDL specification of the value type as indicated by the DynValue's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

Specified by:
set_members_as_dyn_any in interface DynValueOperations
Throws:
TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynValue's TypeCode and they are not empty strings
InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynValue's TypeCode

is_null

public boolean is_null()
Returns true if the DynValueCommon represents a null value type.

Specified by:
is_null in interface DynValueCommonOperations

set_to_null

public void set_to_null()
Changes the representation of a DynValueCommon to a null value type.

Specified by:
set_to_null in interface DynValueCommonOperations

set_to_value

public void set_to_value()
Replaces a null value type with a newly constructed value. Its components are initialized to default values as in DynAnyFactory.create_dyn_any_from_type_code. If the DynValueCommon represents a non-null value type, then this operation has no effect.

Specified by:
set_to_value in interface DynValueCommonOperations

type

public TypeCode type()
Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.

Specified by:
type in interface DynAnyOperations
Returns:
The TypeCode associated with this DynAny object

assign

public void assign(DynAny dyn_any)
            throws TypeMismatch
Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.

Specified by:
assign in interface DynAnyOperations
Parameters:
dyn_any -
Throws:
TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

from_any

public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.

Specified by:
from_any in interface DynAnyOperations
Throws:
TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
InvalidValue - if the passed Any does not contain a legal value (such as a null string)

to_any

public Any to_any()
Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.

Specified by:
to_any in interface DynAnyOperations
Returns:
a new Any object with the same value and TypeCode

equal

public boolean equal(DynAny dyn_any)
Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.

Specified by:
equal in interface DynAnyOperations
Returns:
true of the DynAnys are equal, false otherwise

destroy

public void destroy()
Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.

Specified by:
destroy in interface DynAnyOperations

copy

public DynAny copy()
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.

Specified by:
copy in interface DynAnyOperations
Returns:
a deep copy of the DynAny object

insert_boolean

public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
Inserts a boolean value into the DynAny.

Specified by:
insert_boolean in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_octet

public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.

Specified by:
insert_octet in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_char

public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
Inserts a char value into the DynAny.

Specified by:
insert_char in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_short

public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a short value into the DynAny.

Specified by:
insert_short in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ushort

public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.

Specified by:
insert_ushort in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_long

public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.

Specified by:
insert_long in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ulong

public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.

Specified by:
insert_ulong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_float

public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a float value into the DynAny.

Specified by:
insert_float in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_double

public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a double value into the DynAny.

Specified by:
insert_double in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_string

public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.

Specified by:
insert_string in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
InvalidValue - if the string inserted is longer than the bound of a bounded string
TypeMismatch - if called on a DynAny whose current component itself has components

insert_reference

public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
Inserts a reference to a CORBA object into the DynAny.

Specified by:
insert_reference in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_typecode

public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
Inserts a TypeCode object into the DynAny.

Specified by:
insert_typecode in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_longlong

public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.

Specified by:
insert_longlong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_ulonglong

public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.

Specified by:
insert_ulonglong in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_wchar

public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.

Specified by:
insert_wchar in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_wstring

public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.

Specified by:
insert_wstring in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
InvalidValue - if the string inserted is longer than the bound of a bounded string
TypeMismatch

insert_any

public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
Inserts an Any value into the Any represented by this DynAny.

Specified by:
insert_any in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_dyn_any

public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.

Specified by:
insert_dyn_any in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

insert_val

public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.

Specified by:
insert_val in interface DynAnyOperations
Throws:
InvalidValue - if this DynAny has components but has a current position of -1
TypeMismatch - if called on a DynAny whose current component itself has components

get_boolean

public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
Extracts the boolean value from this DynAny.

Specified by:
get_boolean in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_octet

public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.

Specified by:
get_octet in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_char

public char get_char()
              throws TypeMismatch,
                     InvalidValue
Extracts the char value from this DynAny.

Specified by:
get_char in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_short

public short get_short()
                throws TypeMismatch,
                       InvalidValue
Extracts the short value from this DynAny.

Specified by:
get_short in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ushort

public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.

Specified by:
get_ushort in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_long

public int get_long()
             throws TypeMismatch,
                    InvalidValue
Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.

Specified by:
get_long in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ulong

public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.

Specified by:
get_ulong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_float

public float get_float()
                throws TypeMismatch,
                       InvalidValue
Extracts the float value from this DynAny.

Specified by:
get_float in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_double

public double get_double()
                  throws TypeMismatch,
                         InvalidValue
Extracts the double value from this DynAny.

Specified by:
get_double in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_string

public String get_string()
                  throws TypeMismatch,
                         InvalidValue
Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.

Specified by:
get_string in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_reference

public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
Extracts the reference to a CORBA Object from this DynAny.

Specified by:
get_reference in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_typecode

public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
Extracts the TypeCode object from this DynAny.

Specified by:
get_typecode in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_longlong

public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.

Specified by:
get_longlong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_ulonglong

public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.

Specified by:
get_ulonglong in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_wchar

public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.

Specified by:
get_wchar in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_wstring

public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.

Specified by:
get_wstring in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue

get_any

public Any get_any()
            throws TypeMismatch,
                   InvalidValue
Extracts an Any value contained in the Any represented by this DynAny.

Specified by:
get_any in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_dyn_any

public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

Specified by:
get_dyn_any in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

get_val

public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.

Specified by:
get_val in interface DynAnyOperations
Throws:
TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
TypeMismatch - if called on a DynAny whose current component itself has components
InvalidValue - if this DynAny has components but has a current position of -1

seek

public boolean seek(int index)
Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.

Specified by:
seek in interface DynAnyOperations

rewind

public void rewind()
Is equivalent to seek(0).

Specified by:
rewind in interface DynAnyOperations

next

public boolean next()
Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.

Specified by:
next in interface DynAnyOperations

component_count

public int component_count()
Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
  • For sequences, the operation returns the current number of elements.
  • For structures, exceptions, and value types, the operation returns the number of members.
  • For arrays, the operation returns the number of elements.
  • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
  • For DynFixed and DynEnum, the operation returns zero.

Specified by:
component_count in interface DynAnyOperations

current_component

public DynAny current_component()
                         throws TypeMismatch
Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.

Specified by:
current_component in interface DynAnyOperations
Throws:
TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

_ids

public String[] _ids()
Description copied from class: ObjectImpl
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.

Specified by:
_ids in class ObjectImpl
Returns:
the array of all repository identifiers supported by this ObjectImpl instance
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


FieldNameHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class FieldNameHelper

java.lang.Object
    extended by  org.omg.DynamicAny.FieldNameHelper

public abstract class FieldNameHelper
extends Object

org/omg/DynamicAny/FieldNameHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
FieldNameHelper()
Method Summary
Modifier and Type | Method and Description
static String | extract(Any a)
static String | id()
static void | insert(Any a, String that)
static String | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FieldNameHelper

public FieldNameHelper()
Method Detail

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NameDynAnyPair (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class NameDynAnyPair

java.lang.Object
    extended by  org.omg.DynamicAny.NameDynAnyPair
All Implemented Interfaces:
Serializable, IDLEntity
public final class NameDynAnyPair
extends Object
implements IDLEntity

org/omg/DynamicAny/NameDynAnyPair.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, May 14, 2009 3:15:25 AM PDT

Field Summary
Modifier and Type | Field and Description
String | id The name associated with the DynAny.
DynAny | value The DynAny value associated with the name.
Constructor Summary
Constructor and Description
NameDynAnyPair()
NameDynAnyPair(String _id, DynAny _value)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

id

public String id
The name associated with the DynAny.

value

public DynAny value
The DynAny value associated with the name.

Constructor Detail

NameDynAnyPair

public NameDynAnyPair()

NameDynAnyPair

public NameDynAnyPair(String _id,
                      DynAny _value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NameDynAnyPairHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class NameDynAnyPairHelper

java.lang.Object
    extended by  org.omg.DynamicAny.NameDynAnyPairHelper

public abstract class NameDynAnyPairHelper
extends Object

org/omg/DynamicAny/NameDynAnyPairHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
NameDynAnyPairHelper()
Method Summary
Modifier and Type | Method and Description
static NameDynAnyPair | extract(Any a)
static String | id()
static void | insert(Any a, NameDynAnyPair that)
static NameDynAnyPair | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, NameDynAnyPair value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NameDynAnyPairHelper

public NameDynAnyPairHelper()
Method Detail

insert

public static void insert(Any a,
                          NameDynAnyPair that)

extract

public static NameDynAnyPair extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NameDynAnyPair read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NameDynAnyPair value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NameDynAnyPairSeqHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class NameDynAnyPairSeqHelper

java.lang.Object
    extended by  org.omg.DynamicAny.NameDynAnyPairSeqHelper

public abstract class NameDynAnyPairSeqHelper
extends Object

org/omg/DynamicAny/NameDynAnyPairSeqHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
NameDynAnyPairSeqHelper()
Method Summary
Modifier and Type | Method and Description
static NameDynAnyPair[] | extract(Any a)
static String | id()
static void | insert(Any a, NameDynAnyPair[] that)
static NameDynAnyPair[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, NameDynAnyPair[] value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NameDynAnyPairSeqHelper

public NameDynAnyPairSeqHelper()
Method Detail

insert

public static void insert(Any a,
                          NameDynAnyPair[] that)

extract

public static NameDynAnyPair[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NameDynAnyPair[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NameDynAnyPair[] value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NameValuePair (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class NameValuePair

java.lang.Object
    extended by  org.omg.DynamicAny.NameValuePair
All Implemented Interfaces:
Serializable, IDLEntity
public final class NameValuePair
extends Object
implements IDLEntity

org/omg/DynamicAny/NameValuePair.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, May 14, 2009 3:15:25 AM PDT

Field Summary
Modifier and Type | Field and Description
String | id The name associated with the Any.
Any | value The Any value associated with the name.
Constructor Summary
Constructor and Description
NameValuePair()
NameValuePair(String _id, Any _value)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

id

public String id
The name associated with the Any.

value

public Any value
The Any value associated with the name.

Constructor Detail

NameValuePair

public NameValuePair()

NameValuePair

public NameValuePair(String _id,
                     Any _value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NameValuePairHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny
Class NameValuePairHelper

java.lang.Object
    extended by  org.omg.DynamicAny.NameValuePairHelper

public abstract class NameValuePairHelper
extends Object

org/omg/DynamicAny/NameValuePairHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
NameValuePairHelper()
Method Summary
Modifier and Type | Method and Description
static NameValuePair | extract(Any a)
static String | id()
static void | insert(Any a, NameValuePair that)
static NameValuePair | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, NameValuePair value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NameValuePairHelper

public NameValuePairHelper()
Method Detail

insert

public static void insert(Any a,
                          NameValuePair that)

extract

public static NameValuePair extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NameValuePair read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NameValuePair value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NameValuePairSeqHelper (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.DynamicAny
Class NameValuePairSeqHelper

java.lang.Object
    extended by  org.omg.DynamicAny.NameValuePairSeqHelper

public abstract class NameValuePairSeqHelper
extends Object

org/omg/DynamicAny/NameValuePairSeqHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
NameValuePairSeqHelper()
Method Summary
Modifier and Type | Method and Description
static NameValuePair[] | extract(Any a)
static String | id()
static void | insert(Any a, NameValuePair[] that)
static NameValuePair[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, NameValuePair[] value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NameValuePairSeqHelper

public NameValuePairSeqHelper()
Method Detail

insert

public static void insert(Any a,
                          NameValuePair[] that)

extract

public static NameValuePair[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NameValuePair[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NameValuePair[] value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.omg.DynamicAny (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.DynamicAny

Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

See:
Description

Interface Summary
Interface | Description
DynAny | Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
DynAnyFactory | DynAny objects can be created by invoking operations on the DynAnyFactory object.
DynAnyFactoryOperations | DynAny objects can be created by invoking operations on the DynAnyFactory object.
DynAnyOperations | Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
DynArray | DynArray objects support the manipulation of IDL arrays.
DynArrayOperations | DynArray objects support the manipulation of IDL arrays.
DynEnum | DynEnum objects support the manipulation of IDL enumerated values.
DynEnumOperations | DynEnum objects support the manipulation of IDL enumerated values.
DynFixed | DynFixed objects support the manipulation of IDL fixed values.
DynFixedOperations | DynFixed objects support the manipulation of IDL fixed values.
DynSequence | DynSequence objects support the manipulation of IDL sequences.
DynSequenceOperations | DynSequence objects support the manipulation of IDL sequences.
DynStruct | DynStruct objects support the manipulation of IDL struct and exception values.
DynStructOperations | DynStruct objects support the manipulation of IDL struct and exception values.
DynUnion | DynUnion objects support the manipulation of IDL unions.
DynUnionOperations | DynUnion objects support the manipulation of IDL unions.
DynValue | DynValue objects support the manipulation of IDL non-boxed value types.
DynValueBox | DynValueBox objects support the manipulation of IDL boxed value types.
DynValueBoxOperations | DynValueBox objects support the manipulation of IDL boxed value types.
DynValueCommon | DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
DynValueCommonOperations | DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
DynValueOperations | DynValue objects support the manipulation of IDL non-boxed value types.

Class Summary
Class | Description
_DynAnyFactoryStub | DynAny objects can be created by invoking operations on the DynAnyFactory object.
_DynAnyStub | Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
_DynArrayStub | DynArray objects support the manipulation of IDL arrays.
_DynEnumStub | DynEnum objects support the manipulation of IDL enumerated values.
_DynFixedStub | DynFixed objects support the manipulation of IDL fixed values.
_DynSequenceStub | DynSequence objects support the manipulation of IDL sequences.
_DynStructStub | DynStruct objects support the manipulation of IDL struct and exception values.
_DynUnionStub | DynUnion objects support the manipulation of IDL unions.
_DynValueStub | DynValue objects support the manipulation of IDL non-boxed value types.
AnySeqHelper | org/omg/DynamicAny/AnySeqHelper.java .
DynAnyFactoryHelper | DynAny objects can be created by invoking operations on the DynAnyFactory object.
DynAnyHelper | Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
DynAnySeqHelper | org/omg/DynamicAny/DynAnySeqHelper.java .
DynArrayHelper | DynArray objects support the manipulation of IDL arrays.
DynEnumHelper | DynEnum objects support the manipulation of IDL enumerated values.
DynFixedHelper | DynFixed objects support the manipulation of IDL fixed values.
DynSequenceHelper | DynSequence objects support the manipulation of IDL sequences.
DynStructHelper | DynStruct objects support the manipulation of IDL struct and exception values.
DynUnionHelper | DynUnion objects support the manipulation of IDL unions.
DynValueHelper | DynValue objects support the manipulation of IDL non-boxed value types.
FieldNameHelper | org/omg/DynamicAny/FieldNameHelper.java .
NameDynAnyPair | org/omg/DynamicAny/NameDynAnyPair.java .
NameDynAnyPairHelper | org/omg/DynamicAny/NameDynAnyPairHelper.java .
NameDynAnyPairSeqHelper | org/omg/DynamicAny/NameDynAnyPairSeqHelper.java .
NameValuePair | org/omg/DynamicAny/NameValuePair.java .
NameValuePairHelper | org/omg/DynamicAny/NameValuePairHelper.java .
NameValuePairSeqHelper | org/omg/DynamicAny/NameValuePairSeqHelper.java .

Package org.omg.DynamicAny Description

Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

An any can be passed to a program that doesn't have any static information for the type of the any (code generated for the type by an IDL compiler has not been compiled with the object implementation). As a result, the object receiving the any does not have a portable method of using it.

DynAnys enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value. This is especially helpful for writing powerful generic servers (bridges, event channels supporting filtering). Similarly, this facility enables the construction of an any at runtime, without having static knowledge of its type. This is especially helpful for writing generic clients (bridges, browsers, debuggers, user interface tools).

Any values can be dynamically interpreted (traversed) and constructed through DynAny objects. A DynAny object is associated with a data value which corresponds to a copy of the value inserted into an Any. A DynAny object may be viewed as an ordered collection of component DynAnys. For DynAnys representing a basic type, such as long, or a type without components, such as an empty exception, the ordered collection of components is empty.

Each DynAny object maintains the notion of a current position into its collection of component DynAnys. The current position is identified by an index value that runs from 0 to n-1, where n is the number of components. The special index value -1 indicates a current position that points nowhere. For values that cannot have a current position (such as an empty exception), the index value is fixed at -1. If a DynAny is initialized with a value that has components, the index is initialized to 0. After creation of an uninitialized DynAny (that is, a DynAny that has no value but a TypeCode that permits components), the current position depends on the type of value represented by the DynAny. (The current position is set to 0 or -1, depending on whether the new DynAny gets default values for its components.)

The iteration operations rewind, seek, and next can be used to change the current position and the current_component operation returns the component at the current position. The component_count operation returns the number of components of a DynAny. Collectively, these operations enable iteration over the components of a DynAny, for example, to (recursively) examine its contents.

A constructed DynAny object is a DynAny object associated with a constructed type. There is a different interface, inheriting from the DynAny interface, associated with each kind of constructed type in IDL (fixed, enum, struct, sequence, union, array, exception, and value type). A constructed DynAny object exports operations that enable the creation of new DynAny objects, each of them associated with a component of the constructed data value. As an example, a DynStruct is associated with a struct value. This means that the DynStruct may be seen as owning an ordered collection of components, one for each structure member. The DynStruct object exports operations that enable the creation of new DynAny objects, each of them associated with a member of the struct.

If a DynAny object has been obtained from another (constructed) DynAny object, such as a DynAny representing a structure member that was created from a DynStruct, the member DynAny is logically contained in the DynStruct. Calling an insert or get operation leaves the current position unchanged. Destroying a top-level DynAny object (one that was not obtained as a component of another DynAny) also destroys any component DynAny objects obtained from it. Destroying a non-top level DynAny object does nothing. Invoking operations on a destroyed top-level DynAny or any of its descendants raises OBJECT_NOT_EXIST. If the programmer wants to destroy a DynAny object but still wants to manipulate some component of the data value associated with it, then he or she should first create a DynAny for the component and, after that, make a copy of the created DynAny object.

The behavior of DynAny objects has been defined in order to enable efficient implementations in terms of allocated memory space and speed of access. DynAny objects are intended to be used for traversing values extracted from anys or constructing values of anys at runtime. Their use for other purposes is not recommended.

Handling DynAny objects

Insert and get operations are necessary to handle basic DynAny objects but are also helpful to handle constructed DynAny objects. Inserting a basic data type value into a constructed DynAny object implies initializing the current component of the constructed data value associated with the DynAny object. For example, invoking insert_boolean on a DynStruct implies inserting a boolean data value at the current position of the associated struct data value. A type is consistent for inserting or extracting a value if its TypeCode is equivalent to the TypeCode contained in the DynAny or, if the DynAny has components, is equivalent to the TypeCode of the DynAny at the current position.

Basic operations include:

  • insert_boolean, get_boolean
  • insert_char, get_char
  • insert_short, get_short
  • insert_ushort, get_ushort
  • insert_long, get_long
  • insert_ulong, get_ulong
  • insert_double, get_double
  • insert_string, get_string
  • insert_reference, get_reference
  • insert_typecode, get_typecode
  • insert_longlong, get_longlong
  • insert_ulonglong, get_ulonglong
  • insert_longdouble, get_longdouble
  • insert_wchar, get_wchar
  • insert_wstring, get_wstring
  • insert_any, get_any
  • insert_dyn_any, get_dyn_any
  • insert_val, get_val
  • insert_octet, get_octet
  • insert_float, get_float
  • get_value
  • get_as_string
  • get_as_ulong
  • get_members
  • get_members_as_dyn_any
  • get_discriminator
  • get_length
  • get_elements
  • get_elements_as_dyn_any
  • get_boxed_value
  • get_boxed_value_as_dyn_any

DynAny and DynAnyFactory objects are intended to be local to the process in which they are created and used. This means that references to DynAny and DynAnyFactory objects cannot be exported to other processes, or externalized with ORB.object_to_string(). If any attempt is made to do so, the offending operation will raise a MARSHAL system exception. Since their interfaces are specified in IDL, DynAny objects export operations defined in the standard org.omg.CORBA.Object interface. However, any attempt to invoke operations exported through the Object interface may raise the standard NO_IMPLEMENT exception. An attempt to use a DynAny object with the DII may raise the NO_IMPLEMENT exception.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


InconsistentTypeCode (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.DynamicAny.DynAnyFactoryPackage
Class InconsistentTypeCode

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode
All Implemented Interfaces:
Serializable, IDLEntity
public final class InconsistentTypeCode
extends UserException

org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCode.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, May 14, 2009 3:15:26 AM PDT

Constructor Summary
Constructor and Description
InconsistentTypeCode()
InconsistentTypeCode(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InconsistentTypeCode

public InconsistentTypeCode()

InconsistentTypeCode

public InconsistentTypeCode(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


InconsistentTypeCodeHelper (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.DynamicAny.DynAnyFactoryPackage
Class InconsistentTypeCodeHelper

java.lang.Object
    extended by  org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper

public abstract class InconsistentTypeCodeHelper
extends Object

org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCodeHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, May 14, 2009 3:15:26 AM PDT

Constructor Summary
Constructor and Description
InconsistentTypeCodeHelper()
Method Summary
Modifier and Type | Method and Description
static InconsistentTypeCode | extract(Any a)
static String | id()
static void | insert(Any a, InconsistentTypeCode that)
static InconsistentTypeCode | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, InconsistentTypeCode value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InconsistentTypeCodeHelper

public InconsistentTypeCodeHelper()
Method Detail

insert

public static void insert(Any a,
                          InconsistentTypeCode that)

extract

public static InconsistentTypeCode extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static InconsistentTypeCode read(InputStream istream)

write

public static void write(OutputStream ostream,
                         InconsistentTypeCode value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.omg.DynamicAny.DynAnyFactoryPackage (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.DynamicAny.DynAnyFactoryPackage

This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2.

See:
Description

Class Summary
Class | Description
InconsistentTypeCodeHelper | org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCodeHelper.java .

Exception Summary
Exception | Description
InconsistentTypeCode | org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCode.java .

Package org.omg.DynamicAny.DynAnyFactoryPackage Description

This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2. Please refer to that OMG specification for further details.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java SE 6.

Since:
1.4
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


InvalidValue (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.DynamicAny.DynAnyPackage
Class InvalidValue

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.DynamicAny.DynAnyPackage.InvalidValue
All Implemented Interfaces:
Serializable, IDLEntity
public final class InvalidValue
extends UserException

org/omg/DynamicAny/DynAnyPackage/InvalidValue.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
InvalidValue()
InvalidValue(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidValue

public InvalidValue()

InvalidValue

public InvalidValue(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


InvalidValueHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny.DynAnyPackage
Class InvalidValueHelper

java.lang.Object
    extended by  org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper

public abstract class InvalidValueHelper
extends Object

org/omg/DynamicAny/DynAnyPackage/InvalidValueHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
InvalidValueHelper()
Method Summary
Modifier and Type | Method and Description
static InvalidValue | extract(Any a)
static String | id()
static void | insert(Any a, InvalidValue that)
static InvalidValue | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, InvalidValue value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InvalidValueHelper

public InvalidValueHelper()
Method Detail

insert

public static void insert(Any a,
                          InvalidValue that)

extract

public static InvalidValue extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static InvalidValue read(InputStream istream)

write

public static void write(OutputStream ostream,
                         InvalidValue value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


org.omg.DynamicAny.DynAnyPackage (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.DynamicAny.DynAnyPackage

This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.

See:
Description

Class Summary
Class | Description
InvalidValueHelper | org/omg/DynamicAny/DynAnyPackage/InvalidValueHelper.java .
TypeMismatchHelper | org/omg/DynamicAny/DynAnyPackage/TypeMismatchHelper.java .

Exception Summary
Exception | Description
InvalidValue | org/omg/DynamicAny/DynAnyPackage/InvalidValue.java .
TypeMismatch | org/omg/DynamicAny/DynAnyPackage/TypeMismatch.java .

Package org.omg.DynamicAny.DynAnyPackage Description

This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2. Please refer to that OMG specification for further details.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


TypeMismatch (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.DynamicAny.DynAnyPackage
Class TypeMismatch

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.DynamicAny.DynAnyPackage.TypeMismatch
All Implemented Interfaces:
Serializable, IDLEntity
public final class TypeMismatch
extends UserException

org/omg/DynamicAny/DynAnyPackage/TypeMismatch.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
TypeMismatch()
TypeMismatch(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TypeMismatch

public TypeMismatch()

TypeMismatch

public TypeMismatch(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TypeMismatchHelper (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.DynamicAny.DynAnyPackage
Class TypeMismatchHelper

java.lang.Object
    extended by  org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper

public abstract class TypeMismatchHelper
extends Object

org/omg/DynamicAny/DynAnyPackage/TypeMismatchHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, May 14, 2009 3:15:25 AM PDT

Constructor Summary
Constructor and Description
TypeMismatchHelper()
Method Summary
Modifier and Type | Method and Description
static TypeMismatch | extract(Any a)
static String | id()
static void | insert(Any a, TypeMismatch that)
static TypeMismatch | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, TypeMismatch value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TypeMismatchHelper

public TypeMismatchHelper()
Method Detail

insert

public static void insert(Any a,
                          TypeMismatch that)

extract

public static TypeMismatch extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static TypeMismatch read(InputStream istream)

write

public static void write(OutputStream ostream,
                         TypeMismatch value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Codec (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.IOP
Interface Codec

All Superinterfaces:
CodecOperations, IDLEntity, Object, Serializable
public interface Codec
extends CodecOperations, Object, IDLEntity

The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types. The Codec provides a mechanism to transfer these components between their IDL data types and their CDR encapsulation representations.

A Codec is obtained from the CodecFactory. The CodecFactory is obtained through a call to ORB.resolve_initial_references( "CodecFactory" ).

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.IOP.CodecOperations
decode_value, decode, encode_value, encode
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CodecFactory (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Interface CodecFactory

All Superinterfaces:
CodecFactoryOperations, IDLEntity, Object, Serializable
public interface CodecFactory
extends CodecFactoryOperations, Object, IDLEntity

Codecs are obtained from the CodecFactory. The CodecFactory is obtained through a call to ORB.resolve_initial_references( "CodecFactory" ).

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.IOP.CodecFactoryOperations
create_codec
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


CodecFactoryHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Class CodecFactoryHelper

java.lang.Object
    extended by  org.omg.IOP.CodecFactoryHelper

public abstract class CodecFactoryHelper
extends Object

Codecs are obtained from the CodecFactory. The CodecFactory is obtained through a call to ORB.resolve_initial_references( "CodecFactory" ).

Constructor Summary
Constructor and Description
CodecFactoryHelper()
Method Summary
Modifier and Type | Method and Description
static CodecFactory | extract(Any a)
static String | id()
static void | insert(Any a, CodecFactory that)
static CodecFactory | narrow(Object obj)
static CodecFactory | read(InputStream istream)
static TypeCode | type()
static CodecFactory | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, CodecFactory value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CodecFactoryHelper

public CodecFactoryHelper()
Method Detail

insert

public static void insert(Any a,
                          CodecFactory that)

extract

public static CodecFactory extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static CodecFactory read(InputStream istream)

write

public static void write(OutputStream ostream,
                         CodecFactory value)

narrow

public static CodecFactory narrow(Object obj)

unchecked_narrow

public static CodecFactory unchecked_narrow(Object obj)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


CodecFactoryOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Interface CodecFactoryOperations

All Known Subinterfaces:
CodecFactory
public interface CodecFactoryOperations

Codecs are obtained from the CodecFactory. The CodecFactory is obtained through a call to ORB.resolve_initial_references( "CodecFactory" ).

Method Summary
Modifier and Type | Method and Description
Codec | create_codec(Encoding enc) Create a Codec of the given encoding.

Method Detail

create_codec

Codec create_codec(Encoding enc)
                   throws UnknownEncoding
Create a Codec of the given encoding.

Parameters:
enc - The encoding for which to create a Codec.
Returns:
A Codec obtained with the given encoding.
Throws:
UnknownEncoding - thrown if this factory cannot create a Codec of the given encoding.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


CodecOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Interface CodecOperations

All Known Subinterfaces:
Codec
public interface CodecOperations

The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types. The Codec provides a mechanism to transfer these components between their IDL data types and their CDR encapsulation representations.

A Codec is obtained from the CodecFactory. The CodecFactory is obtained through a call to ORB.resolve_initial_references( "CodecFactory" ).

Method Summary
Modifier and Type | Method and Description
Any | decode_value(byte[] data, TypeCode tc) Decodes the given byte array into an Any based on the given TypeCode and the encoding format effective for this Codec.
Any | decode(byte[] data) Decodes the given byte array into an Any based on the encoding format effective for this Codec.
byte[] | encode_value(Any data) Converts the given any into a byte array based on the encoding format effective for this Codec.
byte[] | encode(Any data) Converts the given any into a byte array based on the encoding format effective for this Codec.

Method Detail

encode

byte[] encode(Any data)
              throws InvalidTypeForEncoding
Converts the given any into a byte array based on the encoding format effective for this Codec.

Parameters:
data - The data, in the form of an any, to be encoded into a byte array.
Returns:
A byte array containing the encoded Any. This byte array contains both the TypeCode and the data of the type.
Throws:
InvalidTypeForEncoding - thrown if the type is not valid for the encoding format effective for this Codec.

decode

Any decode(byte[] data)
           throws FormatMismatch
Decodes the given byte array into an Any based on the encoding format effective for this Codec.

Parameters:
data - The data, in the form of a byte array, to be decoded into an Any.
Returns:
An Any containing the data from the decoded byte array.
Throws:
FormatMismatch - is thrown if the byte array cannot be decoded into an Any.

encode_value

byte[] encode_value(Any data)
                    throws InvalidTypeForEncoding
Converts the given any into a byte array based on the encoding format effective for this Codec. Only the data from the Any is encoded, not the TypeCode.

Parameters:
data - The data, in the form of an Any, to be encoded into a byte array.
Returns:
A byte array containing the data from the encoded any.
Throws:
InvalidTypeForEncoding - thrown if the type is not valid for the encoding format effective for this Codec.

decode_value

Any decode_value(byte[] data,
                 TypeCode tc)
                 throws FormatMismatch,
                        TypeMismatch
Decodes the given byte array into an Any based on the given TypeCode and the encoding format effective for this Codec.

Parameters:
data - The data, in the form of a byte array, to be decoded into an Any.
tc - The TypeCode to be used to decode the data.
Returns:
An Any containing the data from the decoded byte array.
Throws:
FormatMismatch - thrown if the byte array cannot be decoded into an Any.
TypeMismatch
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


CodeSets (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Interface CodeSets

public interface CodeSets

org/omg/IOP/CodeSets.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
static int | value Identifies a CDR encapsulation of the CONV_FRAME.CodeSetContext defined in Section 13.10.2.5, "GIOP Code Set Service Context," on page 13-43.

Field Detail

value

static final int value
Identifies a CDR encapsulation of the CONV_FRAME.CodeSetContext defined in Section 13.10.2.5, "GIOP Code Set Service Context," on page 13-43.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ComponentIdHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Class ComponentIdHelper

java.lang.Object
    extended by  org.omg.IOP.ComponentIdHelper

public abstract class ComponentIdHelper
extends Object

Standard way of representing multicomponent profiles. This would be encapsulated in a TaggedProfile.

Constructor Summary
Constructor and Description
ComponentIdHelper()
Method Summary
Modifier and Type | Method and Description
static int | extract(Any a)
static String | id()
static void | insert(Any a, int that)
static int | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, int value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ComponentIdHelper

public ComponentIdHelper()
Method Detail

insert

public static void insert(Any a,
                          int that)

extract

public static int extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static int read(InputStream istream)

write

public static void write(OutputStream ostream,
                         int value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


Encoding (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Class Encoding

java.lang.Object
    extended by  org.omg.IOP.Encoding
All Implemented Interfaces:
Serializable, IDLEntity
public final class Encoding
extends Object
implements IDLEntity

org/omg/IOP/Encoding.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:23 AM PDT

Field Summary
Modifier and Type | Field and Description
short | format The encoding format.
byte | major_version The major version of this Encoding format.
byte | minor_version The minor version of this Encoding format.
Constructor Summary
Constructor and Description
Encoding()
Encoding(short _format, byte _major_version, byte _minor_version)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

format

public short format
The encoding format.

major_version

public byte major_version
The major version of this Encoding format.

minor_version

public byte minor_version
The minor version of this Encoding format.

Constructor Detail

Encoding

public Encoding()

Encoding

public Encoding(short _format,
                byte _major_version,
                byte _minor_version)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ENCODING_CDR_ENCAPS (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Interface ENCODING_CDR_ENCAPS

public interface ENCODING_CDR_ENCAPS

org/omg/IOP/ENCODING_CDR_ENCAPS.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
static short | value The CDR Encapsulation encoding.

Field Detail

value

static final short value
The CDR Encapsulation encoding.

See Also:
CodecFactory, Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ExceptionDetailMessage (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Interface ExceptionDetailMessage

public interface ExceptionDetailMessage

org/omg/IOP/ExceptionDetailMessage.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
static int | value CORBA formal/02-06-01: 13.7.1: ExceptionDetailMessage identifies a CDR encapsulation of a wstring, encoded using GIOP 1.2 with a TCS-W of UTF-16.

Field Detail

value

static final int value
CORBA formal/02-06-01: 13.7.1: ExceptionDetailMessage identifies a CDR encapsulation of a wstring, encoded using GIOP 1.2 with a TCS-W of UTF-16. This service context may be sent on Reply messages with a reply_status of SYSTEM_EXCEPTION or USER_EXCEPTION. The usage of this service context is defined by language mappings.

IDL/Java: ptc/02-01-22: 1.15.2: When a System Exception is marshaled, its GIOP Reply message shall include an associated ExceptionDetailMessage service context. The callee's stack trace is often very valuable debugging information but may contain sensitive or unwanted information. The wstring within the service context will therefore contain additional information relating to the exception, for example the result of calling either printStackTrace(PrintWriter) or getMessage() on the exception. When unmarshaling a System Exception on the client side, the wstring from any ExceptionDetailMessage service context shall become the Java error message in the unmarshaled exception object.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


IOR (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Class IOR

java.lang.Object
    extended by  org.omg.IOP.IOR
All Implemented Interfaces:
Serializable, IDLEntity
public final class IOR
extends Object
implements IDLEntity

org/omg/IOP/IOR.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
TaggedProfile[] | profiles An array of tagged profiles associated with this object reference.
String | type_id The type id, represented as a String.
Constructor Summary
Constructor and Description
IOR()
IOR(String _type_id, TaggedProfile[] _profiles)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

type_id

public String type_id
The type id, represented as a String.

profiles

public TaggedProfile[] profiles
An array of tagged profiles associated with this object reference.

Constructor Detail

IOR

public IOR()

IOR

public IOR(String _type_id,
           TaggedProfile[] _profiles)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


IORHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Class IORHelper

java.lang.Object
    extended by  org.omg.IOP.IORHelper

public abstract class IORHelper
extends Object

org/omg/IOP/IORHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
IORHelper()
Method Summary
Modifier and Type | Method and Description
static IOR | extract(Any a)
static String | id()
static void | insert(Any a, IOR that)
static IOR | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, IOR value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IORHelper

public IORHelper()
Method Detail

insert

public static void insert(Any a,
                          IOR that)

extract

public static IOR extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static IOR read(InputStream istream)

write

public static void write(OutputStream ostream,
                         IOR value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


IORHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Class IORHolder

java.lang.Object
    extended by  org.omg.IOP.IORHolder
All Implemented Interfaces:
Streamable
public final class IORHolder
extends Object
implements Streamable

org/omg/IOP/IORHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
IOR | value
Constructor Summary
Constructor and Description
IORHolder()
IORHolder(IOR initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public IOR value
Constructor Detail

IORHolder

public IORHolder()

IORHolder

public IORHolder(IOR initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


MultipleComponentProfileHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Class MultipleComponentProfileHelper

java.lang.Object
    extended by  org.omg.IOP.MultipleComponentProfileHelper

public abstract class MultipleComponentProfileHelper
extends Object

An array of tagged components, forming a multiple component profile.

Constructor Summary
Constructor and Description
MultipleComponentProfileHelper()
Method Summary
Modifier and Type | Method and Description
static TaggedComponent[] | extract(Any a)
static String | id()
static void | insert(Any a, TaggedComponent[] that)
static TaggedComponent[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, TaggedComponent[] value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MultipleComponentProfileHelper

public MultipleComponentProfileHelper()
Method Detail

insert

public static void insert(Any a,
                          TaggedComponent[] that)

extract

public static TaggedComponent[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static TaggedComponent[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         TaggedComponent[] value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


MultipleComponentProfileHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Class MultipleComponentProfileHolder

java.lang.Object
    extended by  org.omg.IOP.MultipleComponentProfileHolder
All Implemented Interfaces:
Streamable
public final class MultipleComponentProfileHolder
extends Object
implements Streamable

An array of tagged components, forming a multiple component profile.

Field Summary
Modifier and Type | Field and Description
TaggedComponent[] | value
Constructor Summary
Constructor and Description
MultipleComponentProfileHolder()
MultipleComponentProfileHolder(TaggedComponent[] initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public TaggedComponent[] value
Constructor Detail

MultipleComponentProfileHolder

public MultipleComponentProfileHolder()

MultipleComponentProfileHolder

public MultipleComponentProfileHolder(TaggedComponent[] initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


org.omg.IOP (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.IOP

This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.

See:
Description

Interface Summary
Interface | Description
Codec | The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
CodecFactory | Codecs are obtained from the CodecFactory.
CodecFactoryOperations | Codecs are obtained from the CodecFactory.
CodecOperations | The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
CodeSets | org/omg/IOP/CodeSets.java .
ENCODING_CDR_ENCAPS | org/omg/IOP/ENCODING_CDR_ENCAPS.java .
ExceptionDetailMessage | org/omg/IOP/ExceptionDetailMessage.java .
RMICustomMaxStreamFormat | org/omg/IOP/RMICustomMaxStreamFormat.java .
TAG_ALTERNATE_IIOP_ADDRESS | org/omg/IOP/TAG_ALTERNATE_IIOP_ADDRESS.java .
TAG_CODE_SETS | org/omg/IOP/TAG_CODE_SETS.java .
TAG_INTERNET_IOP | org/omg/IOP/TAG_INTERNET_IOP.java .
TAG_JAVA_CODEBASE | org/omg/IOP/TAG_JAVA_CODEBASE.java .
TAG_MULTIPLE_COMPONENTS | org/omg/IOP/TAG_MULTIPLE_COMPONENTS.java .
TAG_ORB_TYPE | org/omg/IOP/TAG_ORB_TYPE.java .
TAG_POLICIES | org/omg/IOP/TAG_POLICIES.java .
TAG_RMI_CUSTOM_MAX_STREAM_FORMAT | org/omg/IOP/TAG_RMI_CUSTOM_MAX_STREAM_FORMAT.java .
TransactionService | org/omg/IOP/TransactionService.java .

Class Summary
Class | Description
CodecFactoryHelper | Codecs are obtained from the CodecFactory.
ComponentIdHelper | Standard way of representing multicomponent profiles.
Encoding | org/omg/IOP/Encoding.java .
IOR | org/omg/IOP/IOR.java .
IORHelper | org/omg/IOP/IORHelper.java .
IORHolder | org/omg/IOP/IORHolder.java .
MultipleComponentProfileHelper | An array of tagged components, forming a multiple component profile.
MultipleComponentProfileHolder | An array of tagged components, forming a multiple component profile.
ProfileIdHelper | Profile ID
ServiceContext | org/omg/IOP/ServiceContext.java .
ServiceContextHelper | org/omg/IOP/ServiceContextHelper.java .
ServiceContextHolder | org/omg/IOP/ServiceContextHolder.java .
ServiceContextListHelper | An array of service contexts, forming a service context list.
ServiceContextListHolder | An array of service contexts, forming a service context list.
ServiceIdHelper | A service id, represented as an int
TaggedComponent | org/omg/IOP/TaggedComponent.java .
TaggedComponentHelper | org/omg/IOP/TaggedComponentHelper.java .
TaggedComponentHolder | org/omg/IOP/TaggedComponentHolder.java .
TaggedProfile | org/omg/IOP/TaggedProfile.java .
TaggedProfileHelper | org/omg/IOP/TaggedProfileHelper.java .
TaggedProfileHolder | org/omg/IOP/TaggedProfileHolder.java .

Package org.omg.IOP Description

This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6. Please refer to that OMG specification for further details.

Please note that we do not provide all parts of the IOP module from the specification. We only provide those parts that are referenced as return values or parameter types in public APIs, most notably, Portable Interceptors.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


ProfileIdHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Class ProfileIdHelper

java.lang.Object
    extended by  org.omg.IOP.ProfileIdHelper

public abstract class ProfileIdHelper
extends Object

Profile ID

Constructor Summary
Constructor and Description
ProfileIdHelper()
Method Summary
Modifier and Type | Method and Description
static int | extract(Any a)
static String | id()
static void | insert(Any a, int that)
static int | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, int value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ProfileIdHelper

public ProfileIdHelper()
Method Detail

insert

public static void insert(Any a,
                          int that)

extract

public static int extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static int read(InputStream istream)

write

public static void write(OutputStream ostream,
                         int value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


RMICustomMaxStreamFormat (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Interface RMICustomMaxStreamFormat

public interface RMICustomMaxStreamFormat

org/omg/IOP/RMICustomMaxStreamFormat.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
static int | value Identifies a CDR encapsulation of the RMICustomMaxStreamFormat service context which contains a single byte specifying the client's maximum RMI-IIOP stream format version.

Field Detail

value

static final int value
Identifies a CDR encapsulation of the RMICustomMaxStreamFormat service context which contains a single byte specifying the client's maximum RMI-IIOP stream format version. See Java to IDL ptc/02-01-12 1.4.12.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServiceContext (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Class ServiceContext

java.lang.Object
    extended by  org.omg.IOP.ServiceContext
All Implemented Interfaces:
Serializable, IDLEntity
public final class ServiceContext
extends Object
implements IDLEntity

org/omg/IOP/ServiceContext.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
byte[] | context_data The data associated with this service context
int | context_id The service context id
Constructor Summary
Constructor and Description
ServiceContext()
ServiceContext(int _context_id, byte[] _context_data)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

context_id

public int context_id
The service context id

context_data

public byte[] context_data
The data associated with this service context

Constructor Detail

ServiceContext

public ServiceContext()

ServiceContext

public ServiceContext(int _context_id,
                      byte[] _context_data)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServiceContextHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Class ServiceContextHelper

java.lang.Object
    extended by  org.omg.IOP.ServiceContextHelper

public abstract class ServiceContextHelper
extends Object

org/omg/IOP/ServiceContextHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
ServiceContextHelper()
Method Summary
Modifier and Type | Method and Description
static ServiceContext | extract(Any a)
static String | id()
static void | insert(Any a, ServiceContext that)
static ServiceContext | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ServiceContext value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ServiceContextHelper

public ServiceContextHelper()
Method Detail

insert

public static void insert(Any a,
                          ServiceContext that)

extract

public static ServiceContext extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ServiceContext read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ServiceContext value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServiceContextHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Class ServiceContextHolder

java.lang.Object
    extended by  org.omg.IOP.ServiceContextHolder
All Implemented Interfaces:
Streamable
public final class ServiceContextHolder
extends Object
implements Streamable

org/omg/IOP/ServiceContextHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
ServiceContext | value
Constructor Summary
Constructor and Description
ServiceContextHolder()
ServiceContextHolder(ServiceContext initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public ServiceContext value
Constructor Detail

ServiceContextHolder

public ServiceContextHolder()

ServiceContextHolder

public ServiceContextHolder(ServiceContext initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServiceContextListHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Class ServiceContextListHelper

java.lang.Object
    extended by  org.omg.IOP.ServiceContextListHelper

public abstract class ServiceContextListHelper
extends Object

An array of service contexts, forming a service context list.

Constructor Summary
Constructor and Description
ServiceContextListHelper()
Method Summary
Modifier and Type | Method and Description
static ServiceContext[] | extract(Any a)
static String | id()
static void | insert(Any a, ServiceContext[] that)
static ServiceContext[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ServiceContext[] value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ServiceContextListHelper

public ServiceContextListHelper()
Method Detail

insert

public static void insert(Any a,
                          ServiceContext[] that)

extract

public static ServiceContext[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ServiceContext[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ServiceContext[] value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServiceContextListHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Class ServiceContextListHolder

java.lang.Object
    extended by  org.omg.IOP.ServiceContextListHolder
All Implemented Interfaces:
Streamable
public final class ServiceContextListHolder
extends Object
implements Streamable

An array of service contexts, forming a service context list.

Field Summary
Modifier and Type | Field and Description
ServiceContext[] | value
Constructor Summary
Constructor and Description
ServiceContextListHolder()
ServiceContextListHolder(ServiceContext[] initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public ServiceContext[] value
Constructor Detail

ServiceContextListHolder

public ServiceContextListHolder()

ServiceContextListHolder

public ServiceContextListHolder(ServiceContext[] initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServiceIdHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Class ServiceIdHelper

java.lang.Object
    extended by  org.omg.IOP.ServiceIdHelper

public abstract class ServiceIdHelper
extends Object

A service id, represented as an int

Constructor Summary
Constructor and Description
ServiceIdHelper()
Method Summary
Modifier and Type | Method and Description
static int | extract(Any a)
static String | id()
static void | insert(Any a, int that)
static int | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, int value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ServiceIdHelper

public ServiceIdHelper()
Method Detail

insert

public static void insert(Any a,
                          int that)

extract

public static int extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static int read(InputStream istream)

write

public static void write(OutputStream ostream,
                         int value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TAG_ALTERNATE_IIOP_ADDRESS (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Interface TAG_ALTERNATE_IIOP_ADDRESS

public interface TAG_ALTERNATE_IIOP_ADDRESS

org/omg/IOP/TAG_ALTERNATE_IIOP_ADDRESS.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
static int | value In cases where the same object key is used for more than one internet location, the following standard IOR Component is defined for support in IIOP version 1.2.

Field Detail

value

static final int value
In cases where the same object key is used for more than one internet location, the following standard IOR Component is defined for support in IIOP version 1.2.

The TAG_ALTERNATE_IIOP_ADDRESS component has an associated value of type:

     struct {
         string HostID,
         short Port
     };
encoded as a CDR encapsulation.

Zero or more instances of the TAG_ALTERNATE_IIOP_ADDRESS component type may be included in a version 1.2 TAG_INTERNET_IOP Profile. Each of these alternative addresses may be used by the client orb, in addition to the host and port address expressed in the body of the Profile. In cases where one or more TAG_ALTERNATE_IIOP_ADDRESS components are present in a TAG_INTERNET_IOP Profile, no order of use is prescribed by Version 1.2 of IIOP.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TAG_CODE_SETS (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Interface TAG_CODE_SETS

public interface TAG_CODE_SETS

org/omg/IOP/TAG_CODE_SETS.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
static int | value The code set component of the IOR multi-component profile structure contains: server's native char code set and conversion code sets, and server's native wchar code set and conversion code sets. Both char and wchar conversion code sets are listed in order of preference.

Field Detail

value

static final int value
The code set component of the IOR multi-component profile structure contains:
  • server's native char code set and conversion code sets, and
  • server's native wchar code set and conversion code sets.
Both char and wchar conversion code sets are listed in order of preference.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TAG_INTERNET_IOP (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Interface TAG_INTERNET_IOP

public interface TAG_INTERNET_IOP

org/omg/IOP/TAG_INTERNET_IOP.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
static int | value Identifies profiles that support the Internet Inter-ORB Protocol.

Field Detail

value

static final int value
Identifies profiles that support the Internet Inter-ORB Protocol. The ProfileBody of this profile contains a CDR encapsulation of a structure containing addressing and object identification information used by IIOP. Version 1.1 of the TAG_INTERNET_IOP profile also includes an array of TaggedComponent objects that can contain additional information supporting optional IIOP features, ORB services such as security, and future protocol extensions.

Protocols other than IIOP (such as ESIOPs and other GIOPs) can share profile information (such as object identity or security information) with IIOP by encoding their additional profile information as components in the TAG_INTERNET_IOP profile. All TAG_INTERNET_IOP profiles support IIOP, regardless of whether they also support additional protocols. Interoperable ORBs are not required to create or understand any other profile, nor are they required to create or understand any of the components defined for other protocols that might share the TAG_INTERNET_IOP profile with IIOP.

The profile_data for the TAG_INTERNET_IOP profile is a CDR encapsulation of the IIOP.ProfileBody_1_1 type.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TAG_JAVA_CODEBASE (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Interface TAG_JAVA_CODEBASE

public interface TAG_JAVA_CODEBASE

org/omg/IOP/TAG_JAVA_CODEBASE.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
static int | value Class downloading is supported for stubs, ties, values, and value helpers.

Field Detail

value

static final int value
Class downloading is supported for stubs, ties, values, and value helpers. The specification allows transmission of codebase information on the wire for stubs and ties, and enables usage of pre-existing ClassLoaders when relevant.

For values and value helpers, the codebase is transmitted after the value tag. For stubs and ties, the codebase is transmitted as the TaggedComponent TAG_JAVA_CODEBASE in the IOR profile, where the component_data is a CDR encapsulation of the codebase written as an IDL string. The codebase is a space-separated list of one or more URLs.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TAG_MULTIPLE_COMPONENTS (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Interface TAG_MULTIPLE_COMPONENTS

public interface TAG_MULTIPLE_COMPONENTS

org/omg/IOP/TAG_MULTIPLE_COMPONENTS.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
static int | value Indicates that the value encapsulated is of type MultipleComponentProfile.

Field Detail

value

static final int value
Indicates that the value encapsulated is of type MultipleComponentProfile. In this case, the profile consists of a list of protocol components, the use of which must be specified by the protocol using this profile. This profile may be used to carry IOR components.

The profile_data for the TAG_MULTIPLE_COMPONENTS profile is a CDR encapsulation of the MultipleComponentProfile type shown above.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TAG_ORB_TYPE (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Interface TAG_ORB_TYPE

public interface TAG_ORB_TYPE

org/omg/IOP/TAG_ORB_TYPE.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
static int | value It is often useful in the real world to be able to identify the particular kind of ORB an object reference is coming from, to work around problems with that particular ORB, or exploit shared efficiencies.

Field Detail

value

static final int value
It is often useful in the real world to be able to identify the particular kind of ORB an object reference is coming from, to work around problems with that particular ORB, or exploit shared efficiencies.

The TAG_ORB_TYPE component has an associated value of type unsigned long (Java long), encoded as a CDR encapsulation, designating an ORB type ID allocated by the OMG for the ORB type of the originating ORB. Anyone may register any ORB types by submitting a short (one-paragraph) description of the ORB type to the OMG, and will receive a new ORB type ID in return. A list of ORB type descriptions and values will be made available on the OMG web server.

The TAG_ORB_TYPE component can appear at most once in any IOR profile. For profiles supporting IIOP 1.1 or greater, it is optionally present.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TAG_POLICIES (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Interface TAG_POLICIES

public interface TAG_POLICIES

org/omg/IOP/TAG_POLICIES.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
static int | value A profile component containing the sequence of QoS policies exported with the object reference by an object adapter.

Field Detail

value

static final int value
A profile component containing the sequence of QoS policies exported with the object reference by an object adapter.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TAG_RMI_CUSTOM_MAX_STREAM_FORMAT (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Interface TAG_RMI_CUSTOM_MAX_STREAM_FORMAT

public interface TAG_RMI_CUSTOM_MAX_STREAM_FORMAT

org/omg/IOP/TAG_RMI_CUSTOM_MAX_STREAM_FORMAT.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
static int | value RMI-IIOP has multiple stream format versions.

Field Detail

value

static final int value
RMI-IIOP has multiple stream format versions. A server can specify its maximum version by including the TAG_RMI_CUSTOM_MAX_STREAM_FORMAT tagged component or rely on the default of version 1 for GIOP 1.2 and less and version 2 for GIOP 1.3 and higher. See Java to IDL ptc/02-01-12 1.4.11.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TaggedComponent (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Class TaggedComponent

java.lang.Object
    extended by  org.omg.IOP.TaggedComponent
All Implemented Interfaces:
Serializable, IDLEntity
public final class TaggedComponent
extends Object
implements IDLEntity

org/omg/IOP/TaggedComponent.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
byte[] | component_data The component data associated with the component id.
int | tag The tag, represented as a component id.
Constructor Summary
Constructor and Description
TaggedComponent()
TaggedComponent(int _tag, byte[] _component_data)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

tag

public int tag
The tag, represented as a component id.

component_data

public byte[] component_data
The component data associated with the component id.

Constructor Detail

TaggedComponent

public TaggedComponent()

TaggedComponent

public TaggedComponent(int _tag,
                       byte[] _component_data)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TaggedComponentHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Class TaggedComponentHelper

java.lang.Object
    extended by  org.omg.IOP.TaggedComponentHelper

public abstract class TaggedComponentHelper
extends Object

org/omg/IOP/TaggedComponentHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
TaggedComponentHelper()
Method Summary
Modifier and Type | Method and Description
static TaggedComponent | extract(Any a)
static String | id()
static void | insert(Any a, TaggedComponent that)
static TaggedComponent | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, TaggedComponent value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TaggedComponentHelper

public TaggedComponentHelper()
Method Detail

insert

public static void insert(Any a,
                          TaggedComponent that)

extract

public static TaggedComponent extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static TaggedComponent read(InputStream istream)

write

public static void write(OutputStream ostream,
                         TaggedComponent value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TaggedComponentHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Class TaggedComponentHolder

java.lang.Object
    extended by  org.omg.IOP.TaggedComponentHolder
All Implemented Interfaces:
Streamable
public final class TaggedComponentHolder
extends Object
implements Streamable

org/omg/IOP/TaggedComponentHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
TaggedComponent | value
Constructor Summary
Constructor and Description
TaggedComponentHolder()
TaggedComponentHolder(TaggedComponent initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public TaggedComponent value
Constructor Detail

TaggedComponentHolder

public TaggedComponentHolder()

TaggedComponentHolder

public TaggedComponentHolder(TaggedComponent initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TaggedProfile (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Class TaggedProfile

java.lang.Object
    extended by  org.omg.IOP.TaggedProfile
All Implemented Interfaces:
Serializable, IDLEntity
public final class TaggedProfile
extends Object
implements IDLEntity

org/omg/IOP/TaggedProfile.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
byte[] | profile_data The associated profile data.
int | tag The tag, represented as a profile id.
Constructor Summary
Constructor and Description
TaggedProfile()
TaggedProfile(int _tag, byte[] _profile_data)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

tag

public int tag
The tag, represented as a profile id.

profile_data

public byte[] profile_data
The associated profile data.

Constructor Detail

TaggedProfile

public TaggedProfile()

TaggedProfile

public TaggedProfile(int _tag,
                     byte[] _profile_data)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TaggedProfileHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Class TaggedProfileHelper

java.lang.Object
    extended by  org.omg.IOP.TaggedProfileHelper

public abstract class TaggedProfileHelper
extends Object

org/omg/IOP/TaggedProfileHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
TaggedProfileHelper()
Method Summary
Modifier and Type | Method and Description
static TaggedProfile | extract(Any a)
static String | id()
static void | insert(Any a, TaggedProfile that)
static TaggedProfile | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, TaggedProfile value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TaggedProfileHelper

public TaggedProfileHelper()
Method Detail

insert

public static void insert(Any a,
                          TaggedProfile that)

extract

public static TaggedProfile extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static TaggedProfile read(InputStream istream)

write

public static void write(OutputStream ostream,
                         TaggedProfile value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TaggedProfileHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP
Class TaggedProfileHolder

java.lang.Object
    extended by  org.omg.IOP.TaggedProfileHolder
All Implemented Interfaces:
Streamable
public final class TaggedProfileHolder
extends Object
implements Streamable

org/omg/IOP/TaggedProfileHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
TaggedProfile | value
Constructor Summary
Constructor and Description
TaggedProfileHolder()
TaggedProfileHolder(TaggedProfile initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public TaggedProfile value
Constructor Detail

TaggedProfileHolder

public TaggedProfileHolder()

TaggedProfileHolder

public TaggedProfileHolder(TaggedProfile initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TransactionService (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.IOP
Interface TransactionService

public interface TransactionService

org/omg/IOP/TransactionService.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
static int | value Identifies a CDR encapsulation of the CosTSInteroperation.PropogationContext defined in CORBAservices: Common Object Services Specifications.

Field Detail

value

static final int value
Identifies a CDR encapsulation of the CosTSInteroperation.PropogationContext defined in CORBAservices: Common Object Services Specifications.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.omg.IOP.CodecFactoryPackage (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.IOP.CodecFactoryPackage

This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).

See:
Description

Class Summary
Class | Description
UnknownEncodingHelper | org/omg/IOP/CodecFactoryPackage/UnknownEncodingHelper.java .

Exception Summary
Exception | Description
UnknownEncoding | org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java .

Package org.omg.IOP.CodecFactoryPackage Description

This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java SE 6.

Since:
1.4
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


UnknownEncoding (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.IOP.CodecFactoryPackage
Class UnknownEncoding

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.IOP.CodecFactoryPackage.UnknownEncoding
All Implemented Interfaces:
Serializable, IDLEntity
public final class UnknownEncoding
extends UserException

org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:23 AM PDT

Constructor Summary
Constructor and Description
UnknownEncoding()
UnknownEncoding(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UnknownEncoding

public UnknownEncoding()

UnknownEncoding

public UnknownEncoding(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


UnknownEncodingHelper (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.IOP.CodecFactoryPackage
Class UnknownEncodingHelper

java.lang.Object
    extended by  org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper

public abstract class UnknownEncodingHelper
extends Object

org/omg/IOP/CodecFactoryPackage/UnknownEncodingHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:23 AM PDT

Constructor Summary
Constructor and Description
UnknownEncodingHelper()
Method Summary
Modifier and Type | Method and Description
static UnknownEncoding | extract(Any a)
static String | id()
static void | insert(Any a, UnknownEncoding that)
static UnknownEncoding | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, UnknownEncoding value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UnknownEncodingHelper

public UnknownEncodingHelper()
Method Detail

insert

public static void insert(Any a,
                          UnknownEncoding that)

extract

public static UnknownEncoding extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static UnknownEncoding read(InputStream istream)

write

public static void write(OutputStream ostream,
                         UnknownEncoding value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


FormatMismatch (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.IOP.CodecPackage
Class FormatMismatch

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.IOP.CodecPackage.FormatMismatch
All Implemented Interfaces:
Serializable, IDLEntity
public final class FormatMismatch
extends UserException

org/omg/IOP/CodecPackage/FormatMismatch.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
FormatMismatch()
FormatMismatch(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

FormatMismatch

public FormatMismatch()

FormatMismatch

public FormatMismatch(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


FormatMismatchHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP.CodecPackage
Class FormatMismatchHelper

java.lang.Object
    extended by  org.omg.IOP.CodecPackage.FormatMismatchHelper

public abstract class FormatMismatchHelper
extends Object

org/omg/IOP/CodecPackage/FormatMismatchHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
FormatMismatchHelper()
Method Summary
Modifier and Type | Method and Description
static FormatMismatch | extract(Any a)
static String | id()
static void | insert(Any a, FormatMismatch that)
static FormatMismatch | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, FormatMismatch value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FormatMismatchHelper

public FormatMismatchHelper()
Method Detail

insert

public static void insert(Any a,
                          FormatMismatch that)

extract

public static FormatMismatch extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static FormatMismatch read(InputStream istream)

write

public static void write(OutputStream ostream,
                         FormatMismatch value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


InvalidTypeForEncoding (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP.CodecPackage
Class InvalidTypeForEncoding

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.IOP.CodecPackage.InvalidTypeForEncoding
All Implemented Interfaces:
Serializable, IDLEntity
public final class InvalidTypeForEncoding
extends UserException

org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
InvalidTypeForEncoding()
InvalidTypeForEncoding(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidTypeForEncoding

public InvalidTypeForEncoding()

InvalidTypeForEncoding

public InvalidTypeForEncoding(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


InvalidTypeForEncodingHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP.CodecPackage
Class InvalidTypeForEncodingHelper

java.lang.Object
    extended by  org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper

public abstract class InvalidTypeForEncodingHelper
extends Object

org/omg/IOP/CodecPackage/InvalidTypeForEncodingHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
InvalidTypeForEncodingHelper()
Method Summary
Modifier and Type | Method and Description
static InvalidTypeForEncoding | extract(Any a)
static String | id()
static void | insert(Any a, InvalidTypeForEncoding that)
static InvalidTypeForEncoding | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, InvalidTypeForEncoding value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InvalidTypeForEncodingHelper

public InvalidTypeForEncodingHelper()
Method Detail

insert

public static void insert(Any a,
                          InvalidTypeForEncoding that)

extract

public static InvalidTypeForEncoding extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static InvalidTypeForEncoding read(InputStream istream)

write

public static void write(OutputStream ostream,
                         InvalidTypeForEncoding value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


org.omg.IOP.CodecPackage (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.IOP.CodecPackage

This package is generated from the IOP::Codec IDL interface definition.

See:
Description

Class Summary
Class | Description
FormatMismatchHelper | org/omg/IOP/CodecPackage/FormatMismatchHelper.java .
InvalidTypeForEncodingHelper | org/omg/IOP/CodecPackage/InvalidTypeForEncodingHelper.java .
TypeMismatchHelper | org/omg/IOP/CodecPackage/TypeMismatchHelper.java .

Exception Summary
Exception | Description
FormatMismatch | org/omg/IOP/CodecPackage/FormatMismatch.java .
InvalidTypeForEncoding | org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java .
TypeMismatch | org/omg/IOP/CodecPackage/TypeMismatch.java .

Package org.omg.IOP.CodecPackage Description

This package is generated from the IOP::Codec IDL interface definition. It contains the Java representations of the IDL exceptions specified in IOP::Codec (as part of the Portable Interceptors specification). Please refer to that OMG specification for further details.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


TypeMismatch (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.IOP.CodecPackage
Class TypeMismatch

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.IOP.CodecPackage.TypeMismatch
All Implemented Interfaces:
Serializable, IDLEntity
public final class TypeMismatch
extends UserException

org/omg/IOP/CodecPackage/TypeMismatch.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
TypeMismatch()
TypeMismatch(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TypeMismatch

public TypeMismatch()

TypeMismatch

public TypeMismatch(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TypeMismatchHelper (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.IOP.CodecPackage
Class TypeMismatchHelper

java.lang.Object
    extended by  org.omg.IOP.CodecPackage.TypeMismatchHelper

public abstract class TypeMismatchHelper
extends Object

org/omg/IOP/CodecPackage/TypeMismatchHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
TypeMismatchHelper()
Method Summary
Modifier and Type | Method and Description
static TypeMismatch | extract(Any a)
static String | id()
static void | insert(Any a, TypeMismatch that)
static TypeMismatch | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, TypeMismatch value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TypeMismatchHelper

public TypeMismatchHelper()
Method Detail

insert

public static void insert(Any a,
                          TypeMismatch that)

extract

public static TypeMismatch extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static TypeMismatch read(InputStream istream)

write

public static void write(OutputStream ostream,
                         TypeMismatch value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.omg.Messaging (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.Messaging

This package contains the Messaging module specified in the OMG CORBA Messaging specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07.

See:
Description

Interface Summary
Interface | Description
SYNC_WITH_TRANSPORT | org/omg/Messaging/SYNC_WITH_TRANSPORT.java .

Class Summary
Class | Description
SyncScopeHelper | Synchronization scope

Package org.omg.Messaging Description

This package contains the Messaging module specified in the OMG CORBA Messaging specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07. Please refer to that OMG specification for further details.

Please note that we do not provide all parts of the Messaging module from the specification. We only provide those parts that are referenced as return values or parameter types in public APIs, most notably, Portable Interceptors.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


SYNC_WITH_TRANSPORT (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.Messaging
Interface SYNC_WITH_TRANSPORT

public interface SYNC_WITH_TRANSPORT

org/omg/Messaging/SYNC_WITH_TRANSPORT.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Messaging.idl Thursday, May 14, 2009 3:15:23 AM PDT

Field Summary
Modifier and Type | Field and Description
static short | value Constant, defined in the Messaging spec, to define how far the request shall progress before control is returned to the client.

Field Detail

value

static final short value
Constant, defined in the Messaging spec, to define how far the request shall progress before control is returned to the client.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


SyncScopeHelper (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.Messaging
Class SyncScopeHelper

java.lang.Object
    extended by  org.omg.Messaging.SyncScopeHelper

public abstract class SyncScopeHelper
extends Object

Synchronization scope

Constructor Summary
Constructor and Description
SyncScopeHelper()
Method Summary
Modifier and Type | Method and Description
static short | extract(Any a)
static String | id()
static void | insert(Any a, short that)
static short | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, short value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SyncScopeHelper

public SyncScopeHelper()
Method Detail

insert

public static void insert(Any a,
                          short that)

extract

public static short extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static short read(InputStream istream)

write

public static void write(OutputStream ostream,
                         short value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ACTIVE (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.PortableInterceptor
Interface ACTIVE

public interface ACTIVE

org/omg/PortableInterceptor/ACTIVE.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Field Summary
Modifier and Type | Field and Description
static short | value Object adapter state that indicates normal request processing.

Field Detail

value

static final short value
Object adapter state that indicates normal request processing.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AdapterManagerIdHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Class AdapterManagerIdHelper

java.lang.Object
    extended by  org.omg.PortableInterceptor.AdapterManagerIdHelper

public abstract class AdapterManagerIdHelper
extends Object

Adapter manager identifier. Every object adapter has an adapter manager, indicated in this API only through the ID. A group of object adapter instances may share the same adapter manager, in which case state transitions reported for the adapter manager are observed by all object adapters with the same adapter manager ID.

Constructor Summary
Constructor and Description
AdapterManagerIdHelper()
Method Summary
Modifier and Type | Method and Description
static int | extract(Any a)
static String | id()
static void | insert(Any a, int that)
static int | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, int value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AdapterManagerIdHelper

public AdapterManagerIdHelper()
Method Detail

insert

public static void insert(Any a,
                          int that)

extract

public static int extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static int read(InputStream istream)

write

public static void write(OutputStream ostream,
                         int value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


AdapterNameHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Class AdapterNameHelper

java.lang.Object
    extended by  org.omg.PortableInterceptor.AdapterNameHelper

public abstract class AdapterNameHelper
extends Object

The name of an object adapter. This is unique only within the scope of the ORB that created the object adapter.

Constructor Summary
Constructor and Description
AdapterNameHelper()
Method Summary
Modifier and Type | Method and Description
static String[] | extract(Any a)
static String | id()
static void | insert(Any a, String[] that)
static String[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String[] value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AdapterNameHelper

public AdapterNameHelper()
Method Detail

insert

public static void insert(Any a,
                          String[] that)

extract

public static String[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String[] value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


AdapterStateHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Class AdapterStateHelper

java.lang.Object
    extended by  org.omg.PortableInterceptor.AdapterStateHelper

public abstract class AdapterStateHelper
extends Object

Type of object adapter state. State changes are reported either to the object adapter or to the adapter manager.

Constructor Summary
Constructor and Description
AdapterStateHelper()
Method Summary
Modifier and Type | Method and Description
static short | extract(Any a)
static String | id()
static void | insert(Any a, short that)
static short | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, short value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AdapterStateHelper

public AdapterStateHelper()
Method Detail

insert

public static void insert(Any a,
                          short that)

extract

public static short extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static short read(InputStream istream)

write

public static void write(OutputStream ostream,
                         short value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ClientRequestInfo (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface ClientRequestInfo

All Superinterfaces:
ClientRequestInfoOperations, IDLEntity, Object, RequestInfo, RequestInfoOperations, Serializable
public interface ClientRequestInfo
extends ClientRequestInfoOperations, RequestInfo, IDLEntity

Request Information, accessible to client-side request interceptors.

Some attributes and operations on ClientRequestInfo are not valid at all interception points. The following table shows the validity of each attribute or operation. If it is not valid, attempting to access it will result in a BAD_INV_ORDER being thrown with a standard minor code of 14.

 | send_request | send_poll | receive_reply | receive_exception | receive_other
Inherited from RequestInfo:
request_id | yes | yes | yes | yes | yes
operation | yes | yes | yes | yes | yes
arguments | yes1 | no | yes | no | no
exceptions | yes | no | yes | yes | yes
contexts | yes | no | yes | yes | yes
operation_context | yes | no | yes | yes | yes
result | no | no | yes | no | no
response_expected | yes | yes | yes | yes | yes
sync_scope | yes | no | yes | yes | yes
reply_status | no | no | yes | yes | yes
forward_reference | no | no | no | no | yes2
get_slot | yes | yes | yes | yes | yes
get_request_service_context | yes | no | yes | yes | yes
get_reply_service_context | no | no | yes | yes | yes
ClientRequestInfo-specific:
target | yes | yes | yes | yes | yes
effective_target | yes | yes | yes | yes | yes
effective_profile | yes | yes | yes | yes | yes
received_exception | no | no | no | yes | no
received_exception_id | no | no | no | yes | no
get_effective_component | yes | no | yes | yes | yes
get_effective_components | yes | no | yes | yes | yes
get_request_policy | yes | no | yes | yes | yes
add_request_service_context | yes | no | no | no | no
  1. When ClientRequestInfo is passed to send_request, there is an entry in the list for every argument, whether in, inout, or out. But only the in and inout arguments will be available.
  2. If the reply_status atribute is not LOCATION_FORWARD, accessing this attribute will throw BAD_INV_ORDER with a standard minor code of 14.

See Also:
ClientRequestInterceptor

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableInterceptor.ClientRequestInfoOperations
add_request_service_context, effective_profile, effective_target, get_effective_component, get_effective_components, get_request_policy, received_exception_id, received_exception, target
Methods inherited from interface org.omg.PortableInterceptor.RequestInfoOperations
arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ClientRequestInfoOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface ClientRequestInfoOperations

All Superinterfaces:
RequestInfoOperations
All Known Subinterfaces:
ClientRequestInfo
public interface ClientRequestInfoOperations
extends RequestInfoOperations

Request Information, accessible to client-side request interceptors.

Some attributes and operations on ClientRequestInfo are not valid at all interception points. The following table shows the validity of each attribute or operation. If it is not valid, attempting to access it will result in a BAD_INV_ORDER being thrown with a standard minor code of 14.

 | send_request | send_poll | receive_reply | receive_exception | receive_other
Inherited from RequestInfo:
request_id | yes | yes | yes | yes | yes
operation | yes | yes | yes | yes | yes
arguments | yes1 | no | yes | no | no
exceptions | yes | no | yes | yes | yes
contexts | yes | no | yes | yes | yes
operation_context | yes | no | yes | yes | yes
result | no | no | yes | no | no
response_expected | yes | yes | yes | yes | yes
sync_scope | yes | no | yes | yes | yes
reply_status | no | no | yes | yes | yes
forward_reference | no | no | no | no | yes2
get_slot | yes | yes | yes | yes | yes
get_request_service_context | yes | no | yes | yes | yes
get_reply_service_context | no | no | yes | yes | yes
ClientRequestInfo-specific:
target | yes | yes | yes | yes | yes
effective_target | yes | yes | yes | yes | yes
effective_profile | yes | yes | yes | yes | yes
received_exception | no | no | no | yes | no
received_exception_id | no | no | no | yes | no
get_effective_component | yes | no | yes | yes | yes
get_effective_components | yes | no | yes | yes | yes
get_request_policy | yes | no | yes | yes | yes
add_request_service_context | yes | no | no | no | no
  1. When ClientRequestInfo is passed to send_request, there is an entry in the list for every argument, whether in, inout, or out. But only the in and inout arguments will be available.
  2. If the reply_status atribute is not LOCATION_FORWARD, accessing this attribute will throw BAD_INV_ORDER with a standard minor code of 14.

See Also:
ClientRequestInterceptor

Method Summary
Modifier and Type | Method and Description
void | add_request_service_context(ServiceContext service_context, boolean replace) Allows Interceptors to add service contexts to the request.
TaggedProfile | effective_profile() Returns the profile that will be used to send the request.
Object | effective_target() Returns the actual object on which the operation will be invoked.
TaggedComponent | get_effective_component(int id) Returns the IOP.TaggedComponent with the given ID from the profile selected for this request.
TaggedComponent[] | get_effective_components(int id) Returns an array of all tagged components with the given ID from the profile selected for this request.
Policy | get_request_policy(int type) Returns the given policy in effect for this operation.
String | received_exception_id() Returns the repository id of the exception to be returned to the client.
Any | received_exception() Returns an any which contains the exception to be returned to the client.
Object | target() Returns the object which the client called to perform the operation.
Methods inherited from interface org.omg.PortableInterceptor.RequestInfoOperations
arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope

Method Detail

target

Object target()
Returns the object which the client called to perform the operation.

See Also:
effective_target()

effective_target

Object effective_target()
Returns the actual object on which the operation will be invoked. If the reply_status is LOCATION_FORWARD, then on subsequent requests, effective_target will contain the forwarded IOR while target will remain unchanged.

See Also:
target()

effective_profile

TaggedProfile effective_profile()
Returns the profile that will be used to send the request. If a location forward has occurred for this operation's object and that object's profile changed accordingly, then this profile will be that located profile.

received_exception

Any received_exception()
Returns an any which contains the exception to be returned to the client.

If the exception is a user exception which cannot be inserted into an any (e.g., it is unknown or the bindings don t provide the TypeCode), then this attribute will be an any containing the system exception UNKNOWN with a standard minor code of 1. However, the repository id of the exception is available in the received_exception_id attribute.

See Also:
received_exception_id()

received_exception_id

String received_exception_id()
Returns the repository id of the exception to be returned to the client.

See Also:
received_exception(), PortableInterceptor package comments for limitations / unimplemented features

get_effective_component

TaggedComponent get_effective_component(int id)
Returns the IOP.TaggedComponent with the given ID from the profile selected for this request.

If there is more than one component for a given component ID, it is undefined which component this operation returns. If there is more than one component for a given component ID, get_effective_components should be called instead.

Parameters:
id - The component id of the component which is to be returned.
Returns:
The IOP.TaggedComponent obtained with the given identifier.
Throws:
BAD_PARAM - thrown, with a standard minor code of 28, if no component exists for the given component ID.
See Also:
get_effective_components(int)

get_effective_components

TaggedComponent[] get_effective_components(int id)
Returns an array of all tagged components with the given ID from the profile selected for this request.

Parameters:
id - The component id of the components which are to be returned.
Returns:
An array of TaggedComponent objects, each of which contains the given identifier.
Throws:
BAD_PARAM - thrown, with a standard minor code of 28, if no component exists for the given component ID.
See Also:
get_effective_component(int)

get_request_policy

Policy get_request_policy(int type)
Returns the given policy in effect for this operation.

Parameters:
type - The policy type which specifies the policy to be returned.
Returns:
The CORBA.Policy obtained with the given type.
Throws:
INV_POLICY - thrown, with a standard minor code of 1, if the policy type is not valid either because the specified type is not supported by this ORB or because a policy object of that type is not associated with this Object
See Also:
PortableInterceptor package comments for limitations / unimplemented features

add_request_service_context

void add_request_service_context(ServiceContext service_context,
                                 boolean replace)
Allows Interceptors to add service contexts to the request.

There is no declaration of the order of the service contexts. They may or may not appear in the order that they are added.

Parameters:
service_context - The IOP.ServiceContext to be added to the request.
replace - Indicates the behavior of this operation when a service context already exists with the given ID. If false, then BAD_INV_ORDER with a standard minor code of 15 is thrown. If true, then the existing service context is replaced by the new one.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ClientRequestInterceptor (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface ClientRequestInterceptor

All Superinterfaces:
ClientRequestInterceptorOperations, IDLEntity, Interceptor, InterceptorOperations, Object, Serializable
public interface ClientRequestInterceptor
extends ClientRequestInterceptorOperations, Interceptor, IDLEntity

Client-side request interceptor.

A request Interceptor is designed to intercept the flow of a request/reply sequence through the ORB at specific points so that services can query the request information and manipulate the service contexts which are propagated between clients and servers. The primary use of request Interceptors is to enable ORB services to transfer context information between clients and servers. There are two types of request Interceptors: client-side and server-side.

To write a client-side Interceptor, implement the ClientRequestInterceptor interface.

See Also:
ClientRequestInfo

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableInterceptor.ClientRequestInterceptorOperations
receive_exception, receive_other, receive_reply, send_poll, send_request
Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations
destroy, name
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ClientRequestInterceptorOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface ClientRequestInterceptorOperations

All Superinterfaces:
InterceptorOperations
All Known Subinterfaces:
ClientRequestInterceptor
public interface ClientRequestInterceptorOperations
extends InterceptorOperations

Client-side request interceptor.

A request Interceptor is designed to intercept the flow of a request/reply sequence through the ORB at specific points so that services can query the request information and manipulate the service contexts which are propagated between clients and servers. The primary use of request Interceptors is to enable ORB services to transfer context information between clients and servers. There are two types of request Interceptors: client-side and server-side.

To write a client-side Interceptor, implement the ClientRequestInterceptor interface.

See Also:
ClientRequestInfo

Method Summary
Modifier and Type | Method and Description
void | receive_exception(ClientRequestInfo ri) Indicates to the interceptor that an exception occurred.
void | receive_other(ClientRequestInfo ri) Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception.
void | receive_reply(ClientRequestInfo ri) Allows an Interceptor to query the information on a reply after it is returned from the server and before control is returned to the client.
void | send_poll(ClientRequestInfo ri) Allows an Interceptor to query information during a Time-Independent Invocation (TII) polling get reply sequence.
void | send_request(ClientRequestInfo ri) Allows an Interceptor to query request information and modify the service context before the request is sent to the server.
Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations
destroy, name

Method Detail

send_request

void send_request(ClientRequestInfo ri)
                  throws ForwardRequest
Allows an Interceptor to query request information and modify the service context before the request is sent to the server.

This interception point may throw a system exception. If it does, no other Interceptors' send_request operations are called. Those Interceptors on the Flow Stack are popped and their receive_exception interception points are called. This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, no other Interceptors' send_request operations are called. Those Interceptors on the Flow Stack are popped and their receive_other interception points are called.

Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO.

Parameters:
ri - Information about the current request being intercepted.
Throws:
ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.

send_poll

void send_poll(ClientRequestInfo ri)
Allows an Interceptor to query information during a Time-Independent Invocation (TII) polling get reply sequence.

With TII, an application may poll for a response to a request sent previously by the polling client or some other client. This poll is reported to Interceptors through the send_poll interception point and the response is returned through the receive_reply or receive_exception interception points. If the response is not available before the poll time-out expires, the system exception TIMEOUT is thrown and receive_exception is called with this exception.

This interception point may throw a system exception. If it does, no other Interceptors' send_poll operations are called. Those Interceptors on the Flow Stack are popped and their receive_exception interception points are called.

Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO.

Parameters:
ri - Information about the current request being intercepted.
Throws:
TIMEOUT - thrown if the response is not available before the poll time-out expires

receive_reply

void receive_reply(ClientRequestInfo ri)
Allows an Interceptor to query the information on a reply after it is returned from the server and before control is returned to the client.

This interception point may throw a system exception. If it does, no other Interceptors' receive_reply operations are called. The remaining Interceptors in the Flow Stack shall have their receive_exception interception point called.

Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_YES.

Parameters:
ri - Information about the current request being intercepted.

receive_exception

void receive_exception(ClientRequestInfo ri)
                       throws ForwardRequest
Indicates to the interceptor that an exception occurred. Allows an Interceptor to query the exception's information before it is thrown to the client.

This interception point may throw a system exception. This has the effect of changing the exception which successive Interceptors popped from the Flow Stack receive on their calls to receive_exception. The exception thrown to the client will be the last exception thrown by an Interceptor, or the original exception if no Interceptor changes the exception.

This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, no other Interceptors' receive_exception operations are called. The remaining Interceptors in the Flow Stack are popped and have their receive_other interception point called.

If the completion_status of the exception is not COMPLETED_NO, then it is inappropriate for this interception point to throw a ForwardRequest exception. The request s at-most-once semantics would be lost.

Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. If the original exception is a system exception, the completion_status of the new exception shall be the same as on the original. If the original exception is a user exception, then the completion_status of the new exception shall be COMPLETED_YES.

Under some conditions, depending on what policies are in effect, an exception (such as COMM_FAILURE) may result in a retry of the request. While this retry is a new request with respect to Interceptors, there is one point of correlation between the original request and the retry: because control has not returned to the client, the PortableInterceptor.Current for both the original request and the retrying request is the same.

Parameters:
ri - Information about the current request being intercepted.
Throws:
ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.

receive_other

void receive_other(ClientRequestInfo ri)
                   throws ForwardRequest
Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception. For example, a request could result in a retry (e.g., a GIOP Reply with a LOCATION_FORWARD status was received); or on asynchronous calls, the reply does not immediately follow the request, but control shall return to the client and an ending interception point shall be called.

For retries, depending on the policies in effect, a new request may or may not follow when a retry has been indicated. If a new request does follow, while this request is a new request, with respect to Interceptors, there is one point of correlation between the original request and the retry: because control has not returned to the client, the request scoped PortableInterceptor.Current for both the original request and the retrying request is the same.

This interception point may throw a system exception. If it does, no other Interceptors' receive_other operations are called. The remaining Interceptors in the Flow Stack are popped and have their receive_exception interception point called.

This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, successive Interceptors' receive_other operations are called with the new information provided by the ForwardRequest exception.

Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO. If the target invocation had completed, this interception point would not be called.

Parameters:
ri - Information about the current request being intercepted.
Throws:
ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


Current (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface Current

All Superinterfaces:
Current, CurrentOperations, IDLEntity, Object, Serializable
public interface Current
extends CurrentOperations, Current, IDLEntity

Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context. Each service which wishes to use PICurrent reserves a slot or slots at initialization time and uses those slots during the processing of requests and replies.

Before an invocation is made, PICurrent is obtained via a call to ORB.resolve_initial_references( "PICurrent" ). From within the interception points, the data on PICurrent that has moved from the thread scope to the request scope is available via the get_slot operation on the RequestInfo object. A PICurrent can still be obtained via resolve_initial_references, but that is the Interceptor's thread scope PICurrent.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableInterceptor.CurrentOperations
get_slot, set_slot
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


CurrentHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Class CurrentHelper

java.lang.Object
    extended by  org.omg.PortableInterceptor.CurrentHelper

public abstract class CurrentHelper
extends Object

Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context. Each service which wishes to use PICurrent reserves a slot or slots at initialization time and uses those slots during the processing of requests and replies.

Before an invocation is made, PICurrent is obtained via a call to ORB.resolve_initial_references( "PICurrent" ). From within the interception points, the data on PICurrent that has moved from the thread scope to the request scope is available via the get_slot operation on the RequestInfo object. A PICurrent can still be obtained via resolve_initial_references, but that is the Interceptor's thread scope PICurrent.

Constructor Summary
Constructor and Description
CurrentHelper()
Method Summary
Modifier and Type | Method and Description
static Current | extract(Any a)
static String | id()
static void | insert(Any a, Current that)
static Current | narrow(Object obj)
static Current | read(InputStream istream)
static TypeCode | type()
static Current | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, Current value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CurrentHelper

public CurrentHelper()
Method Detail

insert

public static void insert(Any a,
                          Current that)

extract

public static Current extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static Current read(InputStream istream)

write

public static void write(OutputStream ostream,
                         Current value)

narrow

public static Current narrow(Object obj)

unchecked_narrow

public static Current unchecked_narrow(Object obj)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


CurrentOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface CurrentOperations

All Superinterfaces:
CurrentOperations
All Known Subinterfaces:
Current
public interface CurrentOperations
extends CurrentOperations

Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context. Each service which wishes to use PICurrent reserves a slot or slots at initialization time and uses those slots during the processing of requests and replies.

Before an invocation is made, PICurrent is obtained via a call to ORB.resolve_initial_references( "PICurrent" ). From within the interception points, the data on PICurrent that has moved from the thread scope to the request scope is available via the get_slot operation on the RequestInfo object. A PICurrent can still be obtained via resolve_initial_references, but that is the Interceptor's thread scope PICurrent.

Method Summary
Modifier and Type | Method and Description
Any | get_slot(int id) Retrieves the slot data the application set in PICurrent via get_slot.
void | set_slot(int id, Any data) Sets data in a slot.

Method Detail

get_slot

Any get_slot(int id)
             throws InvalidSlot
Retrieves the slot data the application set in PICurrent via get_slot. The data is in the form of an Any.

If the given slot has not been set, an Any containing a type code with a TCKind value of tk_null and no value is returned.

Parameters:
id - The SlotId of the slot from which the data will be returned.
Returns:
The data, in the form of an Any, of the given slot identifier.
Throws:
InvalidSlot - thrown if get_slot is called on a slot that has not been allocated.
BAD_INV_ORDER - thrown if get_slot is called from within an ORB initializer

set_slot

void set_slot(int id,
              Any data)
              throws InvalidSlot
Sets data in a slot. The data is in the form of an Any. If data already exists in that slot, it is overridden.

Parameters:
id - The SlotId of the slot to which the data will be set.
data - The data, in the form of an Any, which will be set to the identified slot.
Throws:
InvalidSlot - thrown if set_slot is called on a slot that has not been allocated.
BAD_INV_ORDER - thrown if set_slot is called from within an ORB initializer.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DISCARDING (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface DISCARDING

public interface DISCARDING

org/omg/PortableInterceptor/DISCARDING.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Field Summary
Modifier and Type | Field and Description
static short | value Object adapter state that causes all requests to be discarded.

Field Detail

value

static final short value
Object adapter state that causes all requests to be discarded.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ForwardRequest (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Class ForwardRequest

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.PortableInterceptor.ForwardRequest
All Implemented Interfaces:
Serializable, IDLEntity
public final class ForwardRequest
extends UserException

org/omg/PortableInterceptor/ForwardRequest.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Field Summary
Modifier and Type | Field and Description
Object | forward The new object to forward the request to.
Constructor Summary
Constructor and Description
ForwardRequest()
ForwardRequest(Object _forward)
ForwardRequest(String $reason, Object _forward)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

forward

public Object forward
The new object to forward the request to.

Constructor Detail

ForwardRequest

public ForwardRequest()

ForwardRequest

public ForwardRequest(Object _forward)

ForwardRequest

public ForwardRequest(String $reason,
                      Object _forward)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ForwardRequestHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Class ForwardRequestHelper

java.lang.Object
    extended by  org.omg.PortableInterceptor.ForwardRequestHelper

public abstract class ForwardRequestHelper
extends Object

org/omg/PortableInterceptor/ForwardRequestHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Constructor Summary
Constructor and Description
ForwardRequestHelper()
Method Summary
Modifier and Type | Method and Description
static ForwardRequest | extract(Any a)
static String | id()
static void | insert(Any a, ForwardRequest that)
static ForwardRequest | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ForwardRequest value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ForwardRequestHelper

public ForwardRequestHelper()
Method Detail

insert

public static void insert(Any a,
                          ForwardRequest that)

extract

public static ForwardRequest extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ForwardRequest read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ForwardRequest value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


HOLDING (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface HOLDING

public interface HOLDING

org/omg/PortableInterceptor/HOLDING.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Field Summary
Modifier and Type | Field and Description
static short | value Object adapter state that holds requests temporarily until the state is changed.

Field Detail

value

static final short value
Object adapter state that holds requests temporarily until the state is changed.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


INACTIVE (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface INACTIVE

public interface INACTIVE

org/omg/PortableInterceptor/INACTIVE.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Field Summary
Modifier and Type | Field and Description
static short | value Object adapter state that causes all requests to be discarded.

Field Detail

value

static final short value
Object adapter state that causes all requests to be discarded. This state indicates that the adapter is shutting down.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


Interceptor (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface Interceptor

All Superinterfaces:
IDLEntity, InterceptorOperations, Object, Serializable
All Known Subinterfaces:
ClientRequestInterceptor, IORInterceptor, IORInterceptor_3_0, ServerRequestInterceptor
public interface Interceptor
extends InterceptorOperations, Object, IDLEntity

All Portable Interceptors implement Interceptor.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations
destroy, name
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


InterceptorOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface InterceptorOperations

All Known Subinterfaces:
ClientRequestInterceptor, ClientRequestInterceptorOperations, Interceptor, IORInterceptor, IORInterceptor_3_0, IORInterceptor_3_0Operations, IORInterceptorOperations, ServerRequestInterceptor, ServerRequestInterceptorOperations
public interface InterceptorOperations

All Portable Interceptors implement Interceptor.

Method Summary
Modifier and Type | Method and Description
void | destroy() Provides an opportunity to destroy this interceptor.
String | name() Returns the name of the interceptor.

Method Detail

name

String name()
Returns the name of the interceptor.

Each Interceptor may have a name that may be used administratively to order the lists of Interceptors. Only one Interceptor of a given name can be registered with the ORB for each Interceptor type. An Interceptor may be anonymous, i.e., have an empty string as the name attribute. Any number of anonymous Interceptors may be registered with the ORB.

Returns:
the name of the interceptor.

destroy

void destroy()
Provides an opportunity to destroy this interceptor. The destroy method is called during ORB.destroy. When an application calls ORB.destroy, the ORB:
  1. waits for all requests in progress to complete
  2. calls the Interceptor.destroy operation for each interceptor
  3. completes destruction of the ORB
Method invocations from within Interceptor.destroy on object references for objects implemented on the ORB being destroyed result in undefined behavior. However, method invocations on objects implemented on an ORB other than the one being destroyed are permitted. (This means that the ORB being destroyed is still capable of acting as a client, but not as a server.)

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


InvalidSlot (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Class InvalidSlot

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.PortableInterceptor.InvalidSlot
All Implemented Interfaces:
Serializable, IDLEntity
public final class InvalidSlot
extends UserException

org/omg/PortableInterceptor/InvalidSlot.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Constructor Summary
Constructor and Description
InvalidSlot()
InvalidSlot(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidSlot

public InvalidSlot()

InvalidSlot

public InvalidSlot(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


InvalidSlotHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Class InvalidSlotHelper

java.lang.Object
    extended by  org.omg.PortableInterceptor.InvalidSlotHelper

public abstract class InvalidSlotHelper
extends Object

org/omg/PortableInterceptor/InvalidSlotHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Constructor Summary
Constructor and Description
InvalidSlotHelper()
Method Summary
Modifier and Type | Method and Description
static InvalidSlot | extract(Any a)
static String | id()
static void | insert(Any a, InvalidSlot that)
static InvalidSlot | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, InvalidSlot value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InvalidSlotHelper

public InvalidSlotHelper()
Method Detail

insert

public static void insert(Any a,
                          InvalidSlot that)

extract

public static InvalidSlot extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static InvalidSlot read(InputStream istream)

write

public static void write(OutputStream ostream,
                         InvalidSlot value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


IORInfo (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface IORInfo

All Superinterfaces:
IDLEntity, IORInfoOperations, Object, Serializable
public interface IORInfo
extends IORInfoOperations, Object, IDLEntity

Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components. The ORB passes an instance of its implementation of this interface as a parameter to IORInterceptor.establish_components.

See Also:
IORInterceptor

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableInterceptor.IORInfoOperations
adapter_template, add_ior_component_to_profile, add_ior_component, current_factory, current_factory, get_effective_policy, manager_id, state
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


IORInfoOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface IORInfoOperations

All Known Subinterfaces:
IORInfo
public interface IORInfoOperations

Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components. The ORB passes an instance of its implementation of this interface as a parameter to IORInterceptor.establish_components.

See Also:
IORInterceptor

Method Summary
Modifier and Type | Method and Description
ObjectReferenceTemplate | adapter_template() Return the object reference template of the object adapter that was just created and is running IOR interceptors.
void | add_ior_component_to_profile(TaggedComponent tagged_component, int profile_id) A portable ORB service implementation calls add_ior_component_to_profile from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs.
void | add_ior_component(TaggedComponent tagged_component) A portable ORB service implementation calls add_ior_component from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs.
ObjectReferenceFactory | current_factory() On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors.
void | current_factory(ObjectReferenceFactory newCurrent_factory) On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors.
Policy | get_effective_policy(int type) Allows an ORB service implementation to determine what server side policy of a particular type is in effect for an IOR being constructed.
int | manager_id() Return the adapter manager id of the object adapter that was just created and is running IOR interceptors.
short | state() Return the adapter state of the object adapter that was just created and is running IOR interceptors.

Method Detail

get_effective_policy

Policy get_effective_policy(int type)
Allows an ORB service implementation to determine what server side policy of a particular type is in effect for an IOR being constructed. When the IOR being constructed is for an object implemented using a POA, all Policy objects passed to the PortableServer.POA.create_POA call that created that POA are accessable via get_effective_policy.

If a policy for the given type is not known to the ORB, then this operation will throw INV_POLICY with a standard minor code of 2.

Parameters:
type - an int specifying the type of policy to return.
Returns:
The effective CORBA.Policy object of the requested type. If the given policy type is known, but no policy of that type is in effect, then this operation will return a nil object reference.

add_ior_component

void add_ior_component(TaggedComponent tagged_component)
A portable ORB service implementation calls add_ior_component from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs. The components in this set will be included in all profiles.

Any number of components may exist with the same component ID.

Parameters:
a_component - The IOP.TaggedComponent to add.

add_ior_component_to_profile

void add_ior_component_to_profile(TaggedComponent tagged_component,
                                  int profile_id)
A portable ORB service implementation calls add_ior_component_to_profile from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs. The components in this set will be included in the specified profile.

Any number of components may exist with the same component ID.

Parameters:
a_component - The IOP.TaggedComponent to add.
profile_id - The profile id of the profile to which this component will be added.
Throws:
BAD_PARAM - thrown, with a standard minor code of 29, if the given profile ID does not define a known profile or it is impossible to add components to that profile.

manager_id

int manager_id()
Return the adapter manager id of the object adapter that was just created and is running IOR interceptors.

state

short state()
Return the adapter state of the object adapter that was just created and is running IOR interceptors.

adapter_template

ObjectReferenceTemplate adapter_template()
Return the object reference template of the object adapter that was just created and is running IOR interceptors.

current_factory

ObjectReferenceFactory current_factory()
On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors. By default, this factory is the same as the value of the adapter_template attribute. The current_factory may also be set to another object reference template inside an IORInterceptor_3_0.

current_factory

void current_factory(ObjectReferenceFactory newCurrent_factory)
On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors. By default, this factory is the same as the value of the adapter_template attribute. The current_factory may also be set to another object reference template inside an IORInterceptor_3_0.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


IORInterceptor (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface IORInterceptor

All Superinterfaces:
IDLEntity, Interceptor, InterceptorOperations, IORInterceptorOperations, Object, Serializable
All Known Subinterfaces:
IORInterceptor_3_0
public interface IORInterceptor
extends IORInterceptorOperations, Interceptor, IDLEntity

Interceptor used to establish tagged components in the profiles within an IOR.

In some cases, a portable ORB service implementation may need to add information describing the server's or object's ORB service related capabilities to object references in order to enable the ORB service implementation in the client to function properly.

This is supported through the IORInterceptor and IORInfo interfaces.

See Also:
IORInfo

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableInterceptor.IORInterceptorOperations
establish_components
Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations
destroy, name
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


IORInterceptor_3_0 (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface IORInterceptor_3_0

All Superinterfaces:
IDLEntity, Interceptor, InterceptorOperations, IORInterceptor, IORInterceptor_3_0Operations, IORInterceptorOperations, Object, Serializable
public interface IORInterceptor_3_0
extends IORInterceptor_3_0Operations, IORInterceptor, IDLEntity

org/omg/PortableInterceptor/IORInterceptor_3_0.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableInterceptor.IORInterceptor_3_0Operations
adapter_manager_state_changed, adapter_state_changed, components_established
Methods inherited from interface org.omg.PortableInterceptor.IORInterceptorOperations
establish_components
Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations
destroy, name
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


IORInterceptor_3_0Helper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Class IORInterceptor_3_0Helper

java.lang.Object
    extended by  org.omg.PortableInterceptor.IORInterceptor_3_0Helper

public abstract class IORInterceptor_3_0Helper
extends Object

org/omg/PortableInterceptor/IORInterceptor_3_0Helper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Constructor Summary
Constructor and Description
IORInterceptor_3_0Helper()
Method Summary
Modifier and Type | Method and Description
static IORInterceptor_3_0 | extract(Any a)
static String | id()
static void | insert(Any a, IORInterceptor_3_0 that)
static IORInterceptor_3_0 | narrow(Object obj)
static IORInterceptor_3_0 | read(InputStream istream)
static TypeCode | type()
static IORInterceptor_3_0 | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, IORInterceptor_3_0 value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IORInterceptor_3_0Helper

public IORInterceptor_3_0Helper()
Method Detail

insert

public static void insert(Any a,
                          IORInterceptor_3_0 that)

extract

public static IORInterceptor_3_0 extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static IORInterceptor_3_0 read(InputStream istream)

write

public static void write(OutputStream ostream,
                         IORInterceptor_3_0 value)

narrow

public static IORInterceptor_3_0 narrow(Object obj)

unchecked_narrow

public static IORInterceptor_3_0 unchecked_narrow(Object obj)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


IORInterceptor_3_0Holder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Class IORInterceptor_3_0Holder

java.lang.Object
    extended by  org.omg.PortableInterceptor.IORInterceptor_3_0Holder
All Implemented Interfaces:
Streamable
public final class IORInterceptor_3_0Holder
extends Object
implements Streamable

org/omg/PortableInterceptor/IORInterceptor_3_0Holder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Field Summary
Modifier and Type | Field and Description
IORInterceptor_3_0 | value
Constructor Summary
Constructor and Description
IORInterceptor_3_0Holder()
IORInterceptor_3_0Holder(IORInterceptor_3_0 initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public IORInterceptor_3_0 value
Constructor Detail

IORInterceptor_3_0Holder

public IORInterceptor_3_0Holder()

IORInterceptor_3_0Holder

public IORInterceptor_3_0Holder(IORInterceptor_3_0 initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


IORInterceptor_3_0Operations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface IORInterceptor_3_0Operations

All Superinterfaces:
InterceptorOperations, IORInterceptorOperations
All Known Subinterfaces:
IORInterceptor_3_0
public interface IORInterceptor_3_0Operations
extends IORInterceptorOperations

org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Method Summary
Modifier and Type | Method and Description
void | adapter_manager_state_changed(int id, short state) Called whenever the state of an adapter manager changes.
void | adapter_state_changed(ObjectReferenceTemplate[] templates, short state) Called whenever the state of an object adapter changes, and the state change is not caused by an adapter manager.
void | components_established(IORInfo info) The components_established method is invoked on all registered IORInterceptor_3_0 instances after establish_components has been invoked on all registered IORInterceptor instances.
Methods inherited from interface org.omg.PortableInterceptor.IORInterceptorOperations
establish_components
Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations
destroy, name

Method Detail

components_established

void components_established(IORInfo info)
The components_established method is invoked on all registered IORInterceptor_3_0 instances after establish_components has been invoked on all registered IORInterceptor instances. The adapter_template is available in info during this call. The current_factory may be get or set in info during this call.

Any exception thrown from this method is handled by the Object Adapter that called this interceptor. In the case of the POA, an exception results in a OBJ_ADAPTER exception with an OMG standard minor code of 6.

Parameters:
info - The IORInfo for the object adapter being created.

adapter_manager_state_changed

void adapter_manager_state_changed(int id,
                                   short state)
Called whenever the state of an adapter manager changes. For the POA, that is the POAManager. If the state change is reported through adapter_manager_state_changed, it is not reported through adapter_state_changed.

Parameters:
id - the adapter manager id of the adapter manager that changed state
state - the new state of the adapter manager

adapter_state_changed

void adapter_state_changed(ObjectReferenceTemplate[] templates,
                           short state)
Called whenever the state of an object adapter changes, and the state change is not caused by an adapter manager. Such changes are reported to all registered IORInterceptor_3_0 instances.

Parameters:
templates - the sequence of ObjectReferenceTemplate instances on which this state change occurred.
state - the new AdapterState shared by all of the templates.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


IORInterceptorOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface IORInterceptorOperations

All Superinterfaces:
InterceptorOperations
All Known Subinterfaces:
IORInterceptor, IORInterceptor_3_0, IORInterceptor_3_0Operations
public interface IORInterceptorOperations
extends InterceptorOperations

Interceptor used to establish tagged components in the profiles within an IOR.

In some cases, a portable ORB service implementation may need to add information describing the server's or object's ORB service related capabilities to object references in order to enable the ORB service implementation in the client to function properly.

This is supported through the IORInterceptor and IORInfo interfaces.

See Also:
IORInfo

Method Summary
Modifier and Type | Method and Description
void | establish_components(IORInfo info) A server side ORB calls the establish_components operation on all registered IORInterceptor instances when it is assembling the list of components that will be included in the profile or profiles of an object reference.
Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations
destroy, name

Method Detail

establish_components

void establish_components(IORInfo info)
A server side ORB calls the establish_components operation on all registered IORInterceptor instances when it is assembling the list of components that will be included in the profile or profiles of an object reference. This operation is not necessarily called for each individual object reference. In the case of the POA, this operation is called each time POA::create_POA is called. In any case, establish_components is guaranteed to be called at least once for each distinct set of server policies.

An implementation of establish_components must not throw exceptions. If it does, the ORB shall ignore the exception and proceed to call the next IOR Interceptor's establish_components operation.

Parameters:
info - The IORInfo instance used by the ORB service to query applicable policies and add components to be included in the generated IORs.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


LOCATION_FORWARD (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface LOCATION_FORWARD

public interface LOCATION_FORWARD

org/omg/PortableInterceptor/LOCATION_FORWARD.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Field Summary
Modifier and Type | Field and Description
static short | value Indicates a LocationForward reply status.

Field Detail

value

static final short value
Indicates a LocationForward reply status. One possible value for RequestInfo.reply_status.

See Also:
RequestInfoOperations.reply_status(), SUCCESSFUL, SYSTEM_EXCEPTION, USER_EXCEPTION, TRANSPORT_RETRY, Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NON_EXISTENT (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface NON_EXISTENT

public interface NON_EXISTENT

org/omg/PortableInterceptor/NON_EXISTENT.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Field Summary
Modifier and Type | Field and Description
static short | value Object adapter state indicating that the adapter has been destroyed.

Field Detail

value

static final short value
Object adapter state indicating that the adapter has been destroyed.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ObjectIdHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Class ObjectIdHelper

java.lang.Object
    extended by  org.omg.PortableInterceptor.ObjectIdHelper

public abstract class ObjectIdHelper
extends Object

Type of an object id. This provides the identity of a particular object that was created by an object adapter.

Constructor Summary
Constructor and Description
ObjectIdHelper()
Method Summary
Modifier and Type | Method and Description
static byte[] | extract(Any a)
static String | id()
static void | insert(Any a, byte[] that)
static byte[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, byte[] value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ObjectIdHelper

public ObjectIdHelper()
Method Detail

insert

public static void insert(Any a,
                          byte[] that)

extract

public static byte[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static byte[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         byte[] value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ObjectReferenceFactory (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface ObjectReferenceFactory

All Superinterfaces:
IDLEntity, Serializable, ValueBase
All Known Subinterfaces:
ObjectReferenceTemplate
public interface ObjectReferenceFactory
extends ValueBase

The object reference factory. This provides the capability of creating an object reference.

Method Summary
Modifier and Type | Method and Description
Object | make_object(String repositoryId, byte[] object_id) make_object creates a CORBA object reference according to the data in this template, with the given repository ID and object ID.
Methods inherited from interface org.omg.CORBA.portable.ValueBase
_truncatable_ids

Method Detail

make_object

Object make_object(String repositoryId,
                   byte[] object_id)
make_object creates a CORBA object reference according to the data in this template, with the given repository ID and object ID.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ObjectReferenceFactoryHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Class ObjectReferenceFactoryHelper

java.lang.Object
    extended by  org.omg.PortableInterceptor.ObjectReferenceFactoryHelper

public abstract class ObjectReferenceFactoryHelper
extends Object

The object reference factory. This provides the capability of creating an object reference.

Constructor Summary
Constructor and Description
ObjectReferenceFactoryHelper()
Method Summary
Modifier and Type | Method and Description
static ObjectReferenceFactory | extract(Any a)
static String | id()
static void | insert(Any a, ObjectReferenceFactory that)
static ObjectReferenceFactory | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ObjectReferenceFactory value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ObjectReferenceFactoryHelper

public ObjectReferenceFactoryHelper()
Method Detail

insert

public static void insert(Any a,
                          ObjectReferenceFactory that)

extract

public static ObjectReferenceFactory extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ObjectReferenceFactory read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ObjectReferenceFactory value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ObjectReferenceFactoryHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Class ObjectReferenceFactoryHolder

java.lang.Object
    extended by  org.omg.PortableInterceptor.ObjectReferenceFactoryHolder
All Implemented Interfaces:
Streamable
public final class ObjectReferenceFactoryHolder
extends Object
implements Streamable

The object reference factory. This provides the capability of creating an object reference.

Field Summary
Modifier and Type | Field and Description
ObjectReferenceFactory | value
Constructor Summary
Constructor and Description
ObjectReferenceFactoryHolder()
ObjectReferenceFactoryHolder(ObjectReferenceFactory initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public ObjectReferenceFactory value
Constructor Detail

ObjectReferenceFactoryHolder

public ObjectReferenceFactoryHolder()

ObjectReferenceFactoryHolder

public ObjectReferenceFactoryHolder(ObjectReferenceFactory initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ObjectReferenceTemplate (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface ObjectReferenceTemplate

All Superinterfaces:
IDLEntity, ObjectReferenceFactory, Serializable, ValueBase
public interface ObjectReferenceTemplate
extends ObjectReferenceFactory

The object reference template. An instance of this must exist for each object adapter created in an ORB. The server_id, orb_id, and adapter_name attributes uniquely identify this template within the scope of an IMR. Note that adapter_id is similarly unique within the same scope, but it is opaque, and less useful in many cases.

Method Summary
Modifier and Type | Method and Description
String[] | adapter_name()
String | orb_id()
String | server_id()
Methods inherited from interface org.omg.PortableInterceptor.ObjectReferenceFactory
make_object
Methods inherited from interface org.omg.CORBA.portable.ValueBase
_truncatable_ids

Method Detail

server_id

String server_id()

orb_id

String orb_id()

adapter_name

String[] adapter_name()
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ObjectReferenceTemplateHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Class ObjectReferenceTemplateHelper

java.lang.Object
    extended by  org.omg.PortableInterceptor.ObjectReferenceTemplateHelper

public abstract class ObjectReferenceTemplateHelper
extends Object

The object reference template. An instance of this must exist for each object adapter created in an ORB. The server_id, orb_id, and adapter_name attributes uniquely identify this template within the scope of an IMR. Note that adapter_id is similarly unique within the same scope, but it is opaque, and less useful in many cases.

Constructor Summary
Constructor and Description
ObjectReferenceTemplateHelper()
Method Summary
Modifier and Type | Method and Description
static ObjectReferenceTemplate | extract(Any a)
static String | id()
static void | insert(Any a, ObjectReferenceTemplate that)
static ObjectReferenceTemplate | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ObjectReferenceTemplate value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ObjectReferenceTemplateHelper

public ObjectReferenceTemplateHelper()
Method Detail

insert

public static void insert(Any a,
                          ObjectReferenceTemplate that)

extract

public static ObjectReferenceTemplate extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ObjectReferenceTemplate read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ObjectReferenceTemplate value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ObjectReferenceTemplateHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Class ObjectReferenceTemplateHolder

java.lang.Object
    extended by  org.omg.PortableInterceptor.ObjectReferenceTemplateHolder
All Implemented Interfaces:
Streamable
public final class ObjectReferenceTemplateHolder
extends Object
implements Streamable

The object reference template. An instance of this must exist for each object adapter created in an ORB. The server_id, orb_id, and adapter_name attributes uniquely identify this template within the scope of an IMR. Note that adapter_id is similarly unique within the same scope, but it is opaque, and less useful in many cases.

Field Summary
Modifier and Type | Field and Description
ObjectReferenceTemplate | value
Constructor Summary
Constructor and Description
ObjectReferenceTemplateHolder()
ObjectReferenceTemplateHolder(ObjectReferenceTemplate initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public ObjectReferenceTemplate value
Constructor Detail

ObjectReferenceTemplateHolder

public ObjectReferenceTemplateHolder()

ObjectReferenceTemplateHolder

public ObjectReferenceTemplateHolder(ObjectReferenceTemplate initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ObjectReferenceTemplateSeqHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Class ObjectReferenceTemplateSeqHelper

java.lang.Object
    extended by  org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper

public abstract class ObjectReferenceTemplateSeqHelper
extends Object

Sequence of object reference templates is used for reporting state changes that do not occur on the adapter manager.

Constructor Summary
Constructor and Description
ObjectReferenceTemplateSeqHelper()
Method Summary
Modifier and Type | Method and Description
static ObjectReferenceTemplate[] | extract(Any a)
static String | id()
static void | insert(Any a, ObjectReferenceTemplate[] that)
static ObjectReferenceTemplate[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ObjectReferenceTemplate[] value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ObjectReferenceTemplateSeqHelper

public ObjectReferenceTemplateSeqHelper()
Method Detail

insert

public static void insert(Any a,
                          ObjectReferenceTemplate[] that)

extract

public static ObjectReferenceTemplate[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ObjectReferenceTemplate[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ObjectReferenceTemplate[] value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ObjectReferenceTemplateSeqHolder (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Class ObjectReferenceTemplateSeqHolder

java.lang.Object
    extended by  org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder
All Implemented Interfaces:
Streamable
public final class ObjectReferenceTemplateSeqHolder
extends Object
implements Streamable

Sequence of object reference templates is used for reporting state changes that do not occur on the adapter manager.

Field Summary
Modifier and Type | Field and Description
ObjectReferenceTemplate[] | value
Constructor Summary
Constructor and Description
ObjectReferenceTemplateSeqHolder()
ObjectReferenceTemplateSeqHolder(ObjectReferenceTemplate[] initialValue)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream i) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream o) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public ObjectReferenceTemplate[] value
Constructor Detail

ObjectReferenceTemplateSeqHolder

public ObjectReferenceTemplateSeqHolder()

ObjectReferenceTemplateSeqHolder

public ObjectReferenceTemplateSeqHolder(ObjectReferenceTemplate[] initialValue)
Method Detail

_read

public void _read(InputStream i)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
i - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream o)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
o - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ORBIdHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Class ORBIdHelper

java.lang.Object
    extended by  org.omg.PortableInterceptor.ORBIdHelper

public abstract class ORBIdHelper
extends Object

org/omg/PortableInterceptor/ORBIdHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Constructor Summary
Constructor and Description
ORBIdHelper()
Method Summary
Modifier and Type | Method and Description
static String | extract(Any a)
static String | id()
static void | insert(Any a, String that)
static String | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ORBIdHelper

public ORBIdHelper()
Method Detail

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ORBInitializer (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface ORBInitializer

All Superinterfaces:
IDLEntity, Object, ORBInitializerOperations, Serializable
public interface ORBInitializer
extends ORBInitializerOperations, Object, IDLEntity

Facilitates interceptor registration and ORB initialization.

Interceptors are intended to be a means by which ORB services gain access to ORB processing, effectively becoming part of the ORB. Since Interceptors are part of the ORB, when ORB.init returns an ORB, the Interceptors shall have been registered. Interceptors cannot be registered on an ORB after it has been returned by a call to ORB.init.

An Interceptor is registered by registering an associated ORBInitializer object which implements the ORBInitializer interface. When an ORB is initializing, it shall call each registered ORBInitializer, passing it an ORBInitInfo object which is used to register its Interceptor.

Registering ORB Initializers in Java

ORBInitializers are registered via Java ORB properties.

The property names are of the form:

org.omg.PortableInterceptor.ORBInitializerClass.<Service>
where <Service> is the string name of a class which implements
org.omg.PortableInterceptor.ORBInitializer
To avoid name collisions, the reverse DNS name convention should be used. For example, if company X has three initializers, it could define the following properties:
  • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init1
  • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init2
  • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init3
During ORB.init, these ORB properties which begin with org.omg.PortableInterceptor.ORBInitializerClass shall be collected, the <Service> portion of each property shall be extracted, an object shall be instantiated with the <Service> string as its class name, and the pre_init and post_init methods shall be called on that object. If there are any exceptions, the ORB shall ignore them and proceed.

Example

A client-side logging service written by company X, for example, may have the following ORBInitializer implementation:

 package com.x.logging;

 import org.omg.PortableInterceptor.Interceptor;
 import org.omg.PortableInterceptor.ORBInitializer;
 import org.omg.PortableInterceptor.ORBInitInfo;

 public class LoggingService implements ORBInitializer {
     void pre_init( ORBInitInfo info ) {
         // Instantiate the Logging Service s Interceptor.
         Interceptor interceptor = new LoggingInterceptor();

         // Register the Logging Service s Interceptor.
         info.add_client_request_interceptor( interceptor );
     }

     void post_init( ORBInitInfo info ) {
         // This service does not need two init points.
     }
 }
To run a program called MyApp using this logging service, the user could type:
java -Dorg.omg.PortableInterceptor.ORBInitializerClass.com.x.Logging.LoggingService MyApp

Notes about Registering Interceptors

Request Interceptors are registered on a per-ORB basis.

To achieve virtual per-object Interceptors, query the policies on the target from within the interception points to determine whether they should do any work.

To achieve virtual per-POA Interceptors, instantiate each POA with a different ORB. While Interceptors may be ordered administratively, there is no concept of order with respect to the registration of Interceptors. Request Interceptors are concerned with service contexts. Service contexts have no order, so there is no purpose for request Interceptors to have an order. IOR Interceptors are concerned with tagged components. Tagged components also have no order, so there is no purpose for IOR Interceptors to have an order.

Registration code should avoid using the ORB (i.e., calling ORB.init with the provided orb_id). Since registration occurs during ORB initialization, results of invocations on this ORB while it is in this state are undefined.

See Also:
ORBInitInfo

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableInterceptor.ORBInitializerOperations
post_init, pre_init
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ORBInitializerOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface ORBInitializerOperations

All Known Subinterfaces:
ORBInitializer
public interface ORBInitializerOperations

Facilitates interceptor registration and ORB initialization.

Interceptors are intended to be a means by which ORB services gain access to ORB processing, effectively becoming part of the ORB. Since Interceptors are part of the ORB, when ORB.init returns an ORB, the Interceptors shall have been registered. Interceptors cannot be registered on an ORB after it has been returned by a call to ORB.init.

An Interceptor is registered by registering an associated ORBInitializer object which implements the ORBInitializer interface. When an ORB is initializing, it shall call each registered ORBInitializer, passing it an ORBInitInfo object which is used to register its Interceptor.

Registering ORB Initializers in Java

ORBInitializers are registered via Java ORB properties.

The property names are of the form:

org.omg.PortableInterceptor.ORBInitializerClass.<Service>
where <Service> is the string name of a class which implements
org.omg.PortableInterceptor.ORBInitializer
To avoid name collisions, the reverse DNS name convention should be used. For example, if company X has three initializers, it could define the following properties:
  • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init1
  • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init2
  • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init3
During ORB.init, these ORB properties which begin with org.omg.PortableInterceptor.ORBInitializerClass shall be collected, the <Service> portion of each property shall be extracted, an object shall be instantiated with the <Service> string as its class name, and the pre_init and post_init methods shall be called on that object. If there are any exceptions, the ORB shall ignore them and proceed.

Example

A client-side logging service written by company X, for example, may have the following ORBInitializer implementation:

 package com.x.logging;

 import org.omg.PortableInterceptor.Interceptor;
 import org.omg.PortableInterceptor.ORBInitializer;
 import org.omg.PortableInterceptor.ORBInitInfo;

 public class LoggingService implements ORBInitializer {
     void pre_init( ORBInitInfo info ) {
         // Instantiate the Logging Service s Interceptor.
         Interceptor interceptor = new LoggingInterceptor();

         // Register the Logging Service s Interceptor.
         info.add_client_request_interceptor( interceptor );
     }

     void post_init( ORBInitInfo info ) {
         // This service does not need two init points.
     }
 }
To run a program called MyApp using this logging service, the user could type:
java -Dorg.omg.PortableInterceptor.ORBInitializerClass.com.x.Logging.LoggingService MyApp

Notes about Registering Interceptors

Request Interceptors are registered on a per-ORB basis.

To achieve virtual per-object Interceptors, query the policies on the target from within the interception points to determine whether they should do any work.

To achieve virtual per-POA Interceptors, instantiate each POA with a different ORB. While Interceptors may be ordered administratively, there is no concept of order with respect to the registration of Interceptors. Request Interceptors are concerned with service contexts. Service contexts have no order, so there is no purpose for request Interceptors to have an order. IOR Interceptors are concerned with tagged components. Tagged components also have no order, so there is no purpose for IOR Interceptors to have an order.

Registration code should avoid using the ORB (i.e., calling ORB.init with the provided orb_id). Since registration occurs during ORB initialization, results of invocations on this ORB while it is in this state are undefined.

See Also:
ORBInitInfo

Method Summary
Modifier and Type | Method and Description
void | post_init(ORBInitInfo info) Called during ORB initialization.
void | pre_init(ORBInitInfo info) Called during ORB initialization.

Method Detail

pre_init

void pre_init(ORBInitInfo info)
Called during ORB initialization. If it is expected that initial services registered by an interceptor will be used by other interceptors, then those initial services shall be registered at this point via calls to ORBInitInfo.register_initial_reference.

Parameters:
info - provides initialization attributes and operations by which Interceptors can be registered.

post_init

void post_init(ORBInitInfo info)
Called during ORB initialization. If a service must resolve initial references as part of its initialization, it can assume that all initial references will be available at this point.

Calling the post_init operations is not the final task of ORB initialization. The final task, following the post_init calls, is attaching the lists of registered interceptors to the ORB. Therefore, the ORB does not contain the interceptors during calls to post_init. If an ORB-mediated call is made from within post_init, no request interceptors will be invoked on that call. Likewise, if an operation is performed which causes an IOR to be created, no IOR interceptors will be invoked.

Parameters:
info - provides initialization attributes and operations by which Interceptors can be registered.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ORBInitInfo (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface ORBInitInfo

All Superinterfaces:
IDLEntity, Object, ORBInitInfoOperations, Serializable
public interface ORBInitInfo
extends ORBInitInfoOperations, Object, IDLEntity

Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.

The ORBInitInfo object is only valid during ORB.init. If a service keeps a reference to its ORBInitInfo object and tries to use it after ORB.init returns, the object no longer exists and an OBJECT_NOT_EXIST exception shall be thrown.

See Also:
ORBInitializer

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableInterceptor.ORBInitInfoOperations
add_client_request_interceptor, add_ior_interceptor, add_server_request_interceptor, allocate_slot_id, arguments, codec_factory, orb_id, register_initial_reference, register_policy_factory, resolve_initial_references
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ORBInitInfoOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface ORBInitInfoOperations

All Known Subinterfaces:
ORBInitInfo
public interface ORBInitInfoOperations

Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.

The ORBInitInfo object is only valid during ORB.init. If a service keeps a reference to its ORBInitInfo object and tries to use it after ORB.init returns, the object no longer exists and an OBJECT_NOT_EXIST exception shall be thrown.

See Also:
ORBInitializer

Method Summary
Modifier and Type | Method and Description
void | add_client_request_interceptor(ClientRequestInterceptor interceptor) Used to add a client-side request Interceptor to the list of client-side request Interceptors.
void | add_ior_interceptor(IORInterceptor interceptor) Used to add an IOR Interceptor to the list of IOR Interceptors.
void | add_server_request_interceptor(ServerRequestInterceptor interceptor) Used to add a server-side request Interceptor to the list of server-side request Interceptors.
int | allocate_slot_id() Called to allocate a slot on PortableInterceptor.Current.
String[] | arguments() Returns the arguments passed to ORB.init.
CodecFactory | codec_factory() Returns the IOP.CodecFactory.
String | orb_id() Returns the ID of the ORB being initialized.
void | register_initial_reference(String id, Object obj) Identical to ORB.register_initial_reference.
void | register_policy_factory(int type, PolicyFactory policy_factory) Registers a PolicyFactory for the given PolicyType.
Object | resolve_initial_references(String id) Identical to ORB.resolve_initial_references.

Method Detail

arguments

String[] arguments()
Returns the arguments passed to ORB.init. They may or may not contain the ORB's arguments.

orb_id

String orb_id()
Returns the ID of the ORB being initialized.

codec_factory

CodecFactory codec_factory()
Returns the IOP.CodecFactory. The CodecFactory is normally obtained via a call to ORB.resolve_initial_references( "CodecFactory" ), but since the ORB is not yet available and Interceptors, particularly when processing service contexts, will require a Codec, a means of obtaining a Codec is necessary during ORB initialization.

register_initial_reference

void register_initial_reference(String id,
                                Object obj)
                                throws InvalidName
Identical to ORB.register_initial_reference. This same functionality exists here because the ORB, not yet fully initialized, is not yet available but initial references may need to be registered as part of Interceptor registration. The only difference is that the version of this operation on the ORB uses PIDL (CORBA.ORB.ObjectId) and (CORBA.ORB.InvalidName) whereas the version in this interface uses IDL defined in this interface; the semantics are identical.

Throws:
InvalidName

resolve_initial_references

Object resolve_initial_references(String id)
                                  throws InvalidName
Identical to ORB.resolve_initial_references. This same functionality exists here because the ORB, not yet fully initialized, is not yet available but initial references may be required from the ORB as part of Interceptor registration. The only difference is that the version of this operation on the ORB uses PIDL (CORBA::ORB::ObjectId and CORBA::ORB::InvalidName) whereas the version in this interface uses IDL defined in this interface; the semantics are identical.

This operation is only valid during post_init.

Throws:
InvalidName

add_client_request_interceptor

void add_client_request_interceptor(ClientRequestInterceptor interceptor)
                                    throws DuplicateName
Used to add a client-side request Interceptor to the list of client-side request Interceptors.

Parameters:
interceptor - The ClientRequestInterceptor to be added.
Throws:
DuplicateName - thrown if a client-side request Interceptor has already been registered with this Interceptor's name.

add_server_request_interceptor

void add_server_request_interceptor(ServerRequestInterceptor interceptor)
                                    throws DuplicateName
Used to add a server-side request Interceptor to the list of server-side request Interceptors.

Parameters:
interceptor - The ServerRequestInterceptor to be added.
Throws:
DuplicateName - thrown if a server-side request Interceptor has already been registered with this Interceptor's name

add_ior_interceptor

void add_ior_interceptor(IORInterceptor interceptor)
                         throws DuplicateName
Used to add an IOR Interceptor to the list of IOR Interceptors.

Parameters:
interceptor - The IORInterceptor to be added.
Throws:
DuplicateName - thrown if an IOR Interceptor has already been registered with this Interceptor's name.

allocate_slot_id

int allocate_slot_id()
Called to allocate a slot on PortableInterceptor.Current.

Note that while slot id's can be allocated within an ORB initializer, the slots themselves cannot be initialized.

Returns:
The index to the slot which has been allocated.
Throws:
BAD_INV_ORDER - thrown, with a standard minor code of 14, if set_slot or get_slot is called on the PICurrent within an ORB initializer.
See Also:
Current

register_policy_factory

void register_policy_factory(int type,
                             PolicyFactory policy_factory)
Registers a PolicyFactory for the given PolicyType.

Parameters:
type - The policy type that the given PolicyFactory serves.
policy_factory - The factory for the given policy type.
Throws:
BAD_INV_ORDER - thrown, with a standard minor code of 16, if a PolicyFactory already exists for the given PolicyType.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


org.omg.PortableInterceptor (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.PortableInterceptor

Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

See:
Description

Interface Summary
Interface | Description
ACTIVE | org/omg/PortableInterceptor/ACTIVE.java .
ClientRequestInfo | Request Information, accessible to client-side request interceptors.
ClientRequestInfoOperations | Request Information, accessible to client-side request interceptors.
ClientRequestInterceptor | Client-side request interceptor.
ClientRequestInterceptorOperations | Client-side request interceptor.
Current | Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
CurrentOperations | Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
DISCARDING | org/omg/PortableInterceptor/DISCARDING.java .
HOLDING | org/omg/PortableInterceptor/HOLDING.java .
INACTIVE | org/omg/PortableInterceptor/INACTIVE.java .
Interceptor | All Portable Interceptors implement Interceptor.
InterceptorOperations | All Portable Interceptors implement Interceptor.
IORInfo | Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
IORInfoOperations | Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
IORInterceptor | Interceptor used to establish tagged components in the profiles within an IOR.
IORInterceptor_3_0 | org/omg/PortableInterceptor/IORInterceptor_3_0.java .
IORInterceptor_3_0Operations | org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java .
IORInterceptorOperations | Interceptor used to establish tagged components in the profiles within an IOR.
LOCATION_FORWARD | org/omg/PortableInterceptor/LOCATION_FORWARD.java .
NON_EXISTENT | org/omg/PortableInterceptor/NON_EXISTENT.java .
ObjectReferenceFactory | The object reference factory.
ObjectReferenceTemplate | The object reference template.
ORBInitializer | Facilitates interceptor registration and ORB initialization.
ORBInitializerOperations | Facilitates interceptor registration and ORB initialization.
ORBInitInfo | Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.
ORBInitInfoOperations | Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.
PolicyFactory | Enables policy types to be constructed using CORBA.ORB.create_policy.
PolicyFactoryOperations | Enables policy types to be constructed using CORBA.ORB.create_policy.
RequestInfo | Request Information, accessible to Interceptors.
RequestInfoOperations | Request Information, accessible to Interceptors.
ServerRequestInfo | Request Information, accessible to server-side request interceptors.
ServerRequestInfoOperations | Request Information, accessible to server-side request interceptors.
ServerRequestInterceptor | Server-side request interceptor.
ServerRequestInterceptorOperations | Server-side request interceptor.
SUCCESSFUL | org/omg/PortableInterceptor/SUCCESSFUL.java .
SYSTEM_EXCEPTION | org/omg/PortableInterceptor/SYSTEM_EXCEPTION.java .
TRANSPORT_RETRY | org/omg/PortableInterceptor/TRANSPORT_RETRY.java .
UNKNOWN | org/omg/PortableInterceptor/UNKNOWN.java .
USER_EXCEPTION | org/omg/PortableInterceptor/USER_EXCEPTION.java .

Class Summary
Class | Description
AdapterManagerIdHelper | Adapter manager identifier.
AdapterNameHelper | The name of an object adapter.
AdapterStateHelper | Type of object adapter state.
CurrentHelper | Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
ForwardRequestHelper | org/omg/PortableInterceptor/ForwardRequestHelper.java .
InvalidSlotHelper | org/omg/PortableInterceptor/InvalidSlotHelper.java .
IORInterceptor_3_0Helper | org/omg/PortableInterceptor/IORInterceptor_3_0Helper.java .
IORInterceptor_3_0Holder | org/omg/PortableInterceptor/IORInterceptor_3_0Holder.java .
ObjectIdHelper | Type of an object id.
ObjectReferenceFactoryHelper | The object reference factory.
ObjectReferenceFactoryHolder | The object reference factory.
ObjectReferenceTemplateHelper | The object reference template.
ObjectReferenceTemplateHolder | The object reference template.
ObjectReferenceTemplateSeqHelper | Sequence of object reference templates is used for reporting state changes that do not occur on the adapter manager.
ObjectReferenceTemplateSeqHolder | Sequence of object reference templates is used for reporting state changes that do not occur on the adapter manager.
ORBIdHelper | org/omg/PortableInterceptor/ORBIdHelper.java .
ServerIdHelper | org/omg/PortableInterceptor/ServerIdHelper.java .

Exception Summary
Exception | Description
ForwardRequest | org/omg/PortableInterceptor/ForwardRequest.java .
InvalidSlot | org/omg/PortableInterceptor/InvalidSlot.java .

Package org.omg.PortableInterceptor Description

Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

Interceptor Types

There are currently three types of interceptors that can be registered:
  • IORInterceptor - Used to establish tagged components in the profiles within an IOR.
  • ClientRequestInterceptor - Intercepts the flow of a request/reply sequence through the ORB on the client side.
  • ServerRequestInterceptor - Intercepts the flow of a request/reply sequence through the ORB on the server side.
See the javadocs for class ORBInitializer for how to go about registering interceptors.

Known limitations / unimplemented methods in package org.omg.PortableInterceptor

  • RequestInfo
    • sync_scope(): Always returns SYNC_WITH_TRANSPORT
    • arguments(): Only supported for DII/DSI calls
    • exceptions(): Only supported for DII calls on client side. Not supported on server-side.
    • contexts(): Only supported for DII calls on client side. Not supported on server-side since our ORB does not send contexts.
    • operation_context(): Only supported for DII calls on client side. Not supported on server-side since ORB does not send contexts.
    • result(): Only supported for DII/DSI calls
  • ClientRequestInfo
    • received_exception_id(): Always returns null in the DII case
    • get_request_policy(int type): Not implemented.
  • ServerRequestInfo
    • sending_exception(): Does not support user exceptions on the server side in non-DSI case.

Package Specification

For a precise list of supported sections of official OMG specifications with which the Java[tm] Platform, Standard Edition 6 complies, see Official Specifications for CORBA support in Java SE 6.

Since:
1.4
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


PolicyFactory (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface PolicyFactory

All Superinterfaces:
IDLEntity, Object, PolicyFactoryOperations, Serializable
public interface PolicyFactory
extends PolicyFactoryOperations, Object, IDLEntity

Enables policy types to be constructed using CORBA.ORB.create_policy.

A portable ORB service implementation registers an instance of the PolicyFactory interface during ORB initialization in order to enable its policy types to be constructed using CORBA.ORB.create_policy. The POA is required to preserve any policy which is registered with ORBInitInfo in this manner.

See Also:
ORBInitInfoOperations.register_policy_factory(int, org.omg.PortableInterceptor.PolicyFactory)

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableInterceptor.PolicyFactoryOperations
create_policy
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


PolicyFactoryOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface PolicyFactoryOperations

All Known Subinterfaces:
PolicyFactory
public interface PolicyFactoryOperations

Enables policy types to be constructed using CORBA.ORB.create_policy.

A portable ORB service implementation registers an instance of the PolicyFactory interface during ORB initialization in order to enable its policy types to be constructed using CORBA.ORB.create_policy. The POA is required to preserve any policy which is registered with ORBInitInfo in this manner.

See Also:
ORBInitInfoOperations.register_policy_factory(int, org.omg.PortableInterceptor.PolicyFactory)

Method Summary
Modifier and Type | Method and Description
Policy | create_policy(int type, Any value) Returns an instance of the appropriate interface derived from CORBA.Policy whose value corresponds to the specified any.

Method Detail

create_policy

Policy create_policy(int type,
                     Any value)
                     throws PolicyError
Returns an instance of the appropriate interface derived from CORBA.Policy whose value corresponds to the specified any.

The ORB calls create_policy on a registered PolicyFactory instance when CORBA.ORB.create_policy is called for the PolicyType under which the PolicyFactory has been registered. The create_policy operation then returns an instance of the appropriate interface derived from CORBA.Policy whose value corresponds to the specified any. If it cannot, it shall throw an exception as described for CORBA.ORB.create_policy.

Parameters:
type - An int specifying the type of policy being created.
value - An any containing data with which to construct the CORBA.Policy.
Returns:
A CORBA.Policy object of the specified type and value.
Throws:
PolicyError
Overview  Package   Class  Use  Tree  Deprecated  Index  Help
Java™ Platform
Standard Ed. 7


RequestInfo (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface RequestInfo

All Superinterfaces:
IDLEntity, Object, RequestInfoOperations, Serializable
All Known Subinterfaces:
ClientRequestInfo, ServerRequestInfo
public interface RequestInfo
extends RequestInfoOperations, Object, IDLEntity

Request Information, accessible to Interceptors.

Each interception point is given an object through which the Interceptor can access request information. Client-side and server-side interception points are concerned with different information, so there are two information objects: ClientRequestInfo is passed to the client-side interception points and ServerRequestInfo is passed to the server-side interception points. But there is information that is common to both, so they both inherit from a common interface: RequestInfo.

See Also:
ClientRequestInfo, ServerRequestInfo

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableInterceptor.RequestInfoOperations
arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


RequestInfoOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface RequestInfoOperations

All Known Subinterfaces:
ClientRequestInfo, ClientRequestInfoOperations, RequestInfo, ServerRequestInfo, ServerRequestInfoOperations
public interface RequestInfoOperations

Request Information, accessible to Interceptors.

Each interception point is given an object through which the Interceptor can access request information. Client-side and server-side interception points are concerned with different information, so there are two information objects: ClientRequestInfo is passed to the client-side interception points and ServerRequestInfo is passed to the server-side interception points. But there is information that is common to both, so they both inherit from a common interface: RequestInfo.

See Also:
ClientRequestInfo, ServerRequestInfo

Method Summary
Modifier and Type | Method and Description
Parameter[] | arguments() Returns an array of Parameter objects, containing the arguments on the operation being invoked.
String[] | contexts() Returns an array of String objects describing the contexts that may be passed on this operation invocation.
TypeCode[] | exceptions() Returns an array of TypeCode objects describing the TypeCodes of the user exceptions that this operation invocation may throw.
Object | forward_reference() Contains the object to which the request will be forwarded, if the reply_status attribute is LOCATION_FORWARD.
ServiceContext | get_reply_service_context(int id) Returns a copy of the service context with the given ID that is associated with the reply.
ServiceContext | get_request_service_context(int id) Returns a copy of the service context with the given ID that is associated with the request.
Any | get_slot(int id) Returns the data from the given slot of the PortableInterceptor.Current that is in the scope of the request.
String[] | operation_context() Returns an array of String objects containing the contexts being sent on the request.
String | operation() Returns the name of the operation being invoked.
short | reply_status() Describes the state of the result of the operation invocation.
int | request_id() Returns an id that uniquely identifies an active request/reply sequence.
boolean | response_expected() Indicates whether a response is expected.
Any | result() Returns an any containing the result of the operation invocation.
short | sync_scope() Defines how far the request shall progress before control is returned to the client.

Method Detail

request_id

int request_id()
Returns an id that uniquely identifies an active request/reply sequence. Once a request/reply sequence is concluded this ID may be reused. Note that this id is not the same as the GIOP request_id. If GIOP is the transport mechanism used, then these IDs may very well be the same, but this is not guaranteed nor required.

operation

String operation()
Returns the name of the operation being invoked.

arguments

Parameter[] arguments()
Returns an array of Parameter objects, containing the arguments on the operation being invoked. If there are no arguments, this attribute will be a zero length array.

Not all environments provide access to the arguments. With the Java portable bindings, for example, the arguments are not available. In these environments, when this attribute is accessed, NO_RESOURCES will be thrown with a standard minor code of 1.

Note: Arguments are available for DSI/DII calls.

Throws:
NO_RESOURCES - thrown if arguments are not available.
See Also:
PortableInterceptor package comments for limitations / unimplemented features

exceptions

TypeCode[] exceptions()
Returns an array of TypeCode objects describing the TypeCodes of the user exceptions that this operation invocation may throw. If there are no user exceptions, this will return a zero length array.

Not all environments provide access to the exception list. With the Java portable bindings, for example, the exception list is not available. In these environments, when this attribute is accessed, NO_RESOURCES will be thrown with a standard minor code of 1.

Note: Exceptions are available for DSI/DII calls.

Throws:
NO_RESOURCES - thrown if exceptions are not available.
See Also:
PortableInterceptor package comments for limitations / unimplemented features

contexts

String[] contexts()
Returns an array of String objects describing the contexts that may be passed on this operation invocation. If there are no contexts, this will return a zero length array.

Not all environments provide access to the context list. With the Java portable bindings, for example, the context list is not available. In these environments, when this attribute is accessed, NO_RESOURCES will be thrown with a standard minor code of 1.

Note: Contexts are available for DSI/DII calls.

Throws:
NO_RESOURCES - thrown if contexts are not available.
See Also:
PortableInterceptor package comments for limitations / unimplemented features

operation_context

String[] operation_context()
Returns an array of String objects containing the contexts being sent on the request.

Not all environments provide access to the context. With the Java portable bindings, for example, the context is not available. In these environments, when this attribute is accessed, NO_RESOURCES will be thrown with standard minor code of 1.

Note: operation_context is available for DSI/DII calls.

Throws:
NO_RESOURCES - thrown if operation context is not available.
See Also:
PortableInterceptor package comments for limitations / unimplemented features

result

Any result()
Returns an any containing the result of the operation invocation. If the operation return type is void, this attribute will be an any containing a type code with a TCKind value of tk_void and no value.

Not all environments provide access to the result. With the Java portable bindings, for example, the result is not available. In these environments, when this attribute is accessed, NO_RESOURCES will be thrown with a standard minor code of 1.

Note: Result is available for DSI/DII calls.

Throws:
NO_RESOURCES - thrown if result is not available.
See Also:
PortableInterceptor package comments for limitations / unimplemented features

response_expected

boolean response_expected()
Indicates whether a response is expected.

On the client, a reply is not returned when response_expected is false, so receive_reply cannot be called. receive_other is called unless an exception occurs, in which case receive_exception is called.

On the client, within send_poll, this attribute is true.

sync_scope

short sync_scope()
Defines how far the request shall progress before control is returned to the client. This is defined in the Messaging specification, and is pertinent only when response_expected is false. If response_expected is true, the value of sync_scope is undefined. This attribute may have one of the following values:
  • Messaging.SYNC_NONE
  • Messaging.SYNC_WITH_TRANSPORT
  • Messaging.SYNC_WITH_SERVER
  • Messaging.SYNC_WITH_TARGET
On the server, for all scopes, a reply will be created from the return of the target operation call, but the reply will not return to the client. Although it does not return to the client, it does occur, so the normal server-side interception points are followed (i.e., receive_request_service_contexts, receive_request, send_reply or send_exception).

For SYNC_WITH_SERVER and SYNC_WITH_TARGET, the server does send an empty reply back to the client before the target is invoked. This reply is not intercepted by server-side Interceptors.

See Also:
PortableInterceptor package comments for limitations / unimplemented features

reply_status

short reply_status()
Describes the state of the result of the operation invocation. The return value can be one of the following:
  • PortableInterceptor.SUCCESSFUL
  • PortableInterceptor.SYSTEM_EXCEPTION
  • PortableInterceptor.USER_EXCEPTION
  • PortableInterceptor.LOCATION_FORWARD
  • PortableInterceptor.TRANSPORT_RETRY
On the client:
  • Within the receive_reply interception point, this will only return SUCCESSFUL
    • .
  • Within the receive_exception interception point, this will be either SYSTEM_EXCEPTION or USER_EXCEPTION.
  • Within the receive_other interception point, this will be any of: SUCCESSFUL, LOCATION_FORWARD, or TRANSPORT_RETRY. SUCCESSFUL means an asynchronous request returned successfully. LOCATION_FORWARD means that a reply came back with LOCATION_FORWARD as its status. TRANSPORT_RETRY means that the transport mechanism indicated a retry - a GIOP reply with a status of NEEDS_ADDRESSING_MODE, for instance.
On the server:
  • Within the send_reply interception point, this will only be SUCCESSFUL.
  • Within the send_exception interception point, this will be either SYSTEM_EXCEPTION or USER_EXCEPTION.
  • Within the send_other interception point, this attribute will be any of: SUCCESSFUL, or LOCATION_FORWARD. SUCCESSFUL means an asynchronous request returned successfully. LOCATION_FORWARD means that a reply came back with LOCATION_FORWARD as its status.

See Also:
SUCCESSFUL, SYSTEM_EXCEPTION, USER_EXCEPTION, LOCATION_FORWARD, TRANSPORT_RETRY

forward_reference

Object forward_reference()
Contains the object to which the request will be forwarded, if the reply_status attribute is LOCATION_FORWARD. It is indeterminate whether a forwarded request will actually occur.

get_slot

Any get_slot(int id)
             throws InvalidSlot
Returns the data from the given slot of the PortableInterceptor.Current that is in the scope of the request.

If the given slot has not been set, then an any containing a type code with a TCKind value of tk_null is returned.

Parameters:
id - The SlotId of the slot which is to be returned.
Returns:
The slot data, in the form of an any, obtained with the given identifier.
Throws:
InvalidSlot - thrown if the ID does not define an allocated slot.
See Also:
Current

get_request_service_context

ServiceContext get_request_service_context(int id)
Returns a copy of the service context with the given ID that is associated with the request.

Parameters:
id - The IOP.ServiceId of the service context which is to be returned.
Returns:
The IOP.ServiceContext obtained with the given identifier.
Throws:
BAD_PARAM - thrown with a standard minor code of 26, if the request's service context does not contain an entry for that ID.

get_reply_service_context

ServiceContext get_reply_service_context(int id)
Returns a copy of the service context with the given ID that is associated with the reply.

Parameters:
id - The IOP.ServiceId of the service context which is to be returned.
Returns:
The IOP.ServiceContext obtained with the given identifier.
Throws:
BAD_PARAM - thrown with a standard minor code of 26 if the request's service context does not contain an entry for that ID.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServerIdHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Class ServerIdHelper

java.lang.Object
    extended by  org.omg.PortableInterceptor.ServerIdHelper

public abstract class ServerIdHelper
extends Object

org/omg/PortableInterceptor/ServerIdHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Constructor Summary
Constructor and Description
ServerIdHelper()
Method Summary
Modifier and Type | Method and Description
static String | extract(Any a)
static String | id()
static void | insert(Any a, String that)
static String | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ServerIdHelper

public ServerIdHelper()
Method Detail

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServerRequestInfo (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface ServerRequestInfo

All Superinterfaces:
IDLEntity, Object, RequestInfo, RequestInfoOperations, Serializable, ServerRequestInfoOperations
public interface ServerRequestInfo
extends ServerRequestInfoOperations, RequestInfo, IDLEntity

Request Information, accessible to server-side request interceptors.

Some attributes and operations on ServerRequestInfo are not valid at all interception points. The following table shows the validity of each attribute or operation. If it is not valid, attempting to access it will result in a BAD_INV_ORDER being thrown with a standard minor code of 14.

 | receive_request_ service_contexts | receive_request | send_reply | send_exception | send_other
Inherited from RequestInfo:
request_id | yes | yes | yes | yes | yes
operation | yes | yes | yes | yes | yes
arguments | no | yes1 | yes | no2 | no2
exceptions | no | yes | yes | yes | yes
contexts | no | yes | yes | yes | yes
operation_context | no | yes | yes | no | no
result | no | no | yes | no | no
response_expected | yes | yes | yes | yes | yes
sync_scope | yes | yes | yes | yes | yes
request_id | yes | yes | yes | yes | yes
operation | yes | yes | yes | yes | yes
arguments | no | yes1 | yes | no2 | no2
exceptions | no | yes | yes | yes | yes
contexts | no | yes | yes | yes | yes
operation_context | no | yes | yes | no | no
result | no | no | yes | no | no
response_expected | yes | yes | yes | yes | yes
sync_scope | yes | yes | yes | yes | yes
reply_status | no | no | yes | yes | yes
forward_reference | no | no | no | no | yes2
get_slot | yes | yes | yes | yes | yes
get_request_service_context | yes | no | yes | yes | yes
get_reply_service_context | no | no | yes | yes | yes
ServerRequestInfo-specific:
sending_exception | no | no | no | yes | no
object_id | no | yes | yes | yes3 | yes3
adapter_id | no | yes | yes | yes3 | yes3
server_id | no | yes | yes | yes | yes
orb_id | no | yes | yes | yes | yes
adapter_name | no | yes | yes | yes | yes
target_most_derived_interface | no | yes | no4 | no4 | no4
get_server_policy | yes | yes | yes | yes | yes
set_slot | yes | yes | yes | yes | yes
target_is_a | no | yes | no4 | no4 | no4
add_reply_service_context | yes | yes | yes | yes | yes
  1. When ServerRequestInfo is passed to receive_request, there is an entry in the list for every argument, whether in, inout, or out. But only the in and inout arguments will be available.
  2. If the reply_status attribute is not LOCATION_FORWARD, accessing this attribute will throw BAD_INV_ORDER with a standard minor code of 14.
  3. If the servant locator caused a location forward, or thrown an exception, this attribute/operation may not be available in this interception point. NO_RESOURCES with a standard minor code of 1 will be thrown if it is not available.
  4. The operation is not available in this interception point because the necessary information requires access to the target object's servant, which may no longer be available to the ORB. For example, if the object's adapter is a POA that uses a ServantLocator, then the ORB invokes the interception point after it calls ServantLocator.postinvoke()
    5. .

See Also:
ServerRequestInterceptor

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableInterceptor.ServerRequestInfoOperations
adapter_id, adapter_name, add_reply_service_context, get_server_policy, object_id, orb_id, sending_exception, server_id, set_slot, target_is_a, target_most_derived_interface
Methods inherited from interface org.omg.PortableInterceptor.RequestInfoOperations
arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServerRequestInfoOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface ServerRequestInfoOperations

All Superinterfaces:
RequestInfoOperations
All Known Subinterfaces:
ServerRequestInfo
public interface ServerRequestInfoOperations
extends RequestInfoOperations

Request Information, accessible to server-side request interceptors.

Some attributes and operations on ServerRequestInfo are not valid at all interception points. The following table shows the validity of each attribute or operation. If it is not valid, attempting to access it will result in a BAD_INV_ORDER being thrown with a standard minor code of 14.

 | receive_request_ service_contexts | receive_request | send_reply | send_exception | send_other
Inherited from RequestInfo:
request_id | yes | yes | yes | yes | yes
operation | yes | yes | yes | yes | yes
arguments | no | yes1 | yes | no2 | no2
exceptions | no | yes | yes | yes | yes
contexts | no | yes | yes | yes | yes
operation_context | no | yes | yes | no | no
result | no | no | yes | no | no
response_expected | yes | yes | yes | yes | yes
sync_scope | yes | yes | yes | yes | yes
request_id | yes | yes | yes | yes | yes
operation | yes | yes | yes | yes | yes
arguments | no | yes1 | yes | no2 | no2
exceptions | no | yes | yes | yes | yes
contexts | no | yes | yes | yes | yes
operation_context | no | yes | yes | no | no
result | no | no | yes | no | no
response_expected | yes | yes | yes | yes | yes
sync_scope | yes | yes | yes | yes | yes
reply_status | no | no | yes | yes | yes
forward_reference | no | no | no | no | yes2
get_slot | yes | yes | yes | yes | yes
get_request_service_context | yes | no | yes | yes | yes
get_reply_service_context | no | no | yes | yes | yes
ServerRequestInfo-specific:
sending_exception | no | no | no | yes | no
object_id | no | yes | yes | yes3 | yes3
adapter_id | no | yes | yes | yes3 | yes3
server_id | no | yes | yes | yes | yes
orb_id | no | yes | yes | yes | yes
adapter_name | no | yes | yes | yes | yes
target_most_derived_interface | no | yes | no4 | no4 | no4
get_server_policy | yes | yes | yes | yes | yes
set_slot | yes | yes | yes | yes | yes
target_is_a | no | yes | no4 | no4 | no4
add_reply_service_context | yes | yes | yes | yes | yes
  1. When ServerRequestInfo is passed to receive_request, there is an entry in the list for every argument, whether in, inout, or out. But only the in and inout arguments will be available.
  2. If the reply_status attribute is not LOCATION_FORWARD, accessing this attribute will throw BAD_INV_ORDER with a standard minor code of 14.
  3. If the servant locator caused a location forward, or thrown an exception, this attribute/operation may not be available in this interception point. NO_RESOURCES with a standard minor code of 1 will be thrown if it is not available.
  4. The operation is not available in this interception point because the necessary information requires access to the target object's servant, which may no longer be available to the ORB. For example, if the object's adapter is a POA that uses a ServantLocator, then the ORB invokes the interception point after it calls ServantLocator.postinvoke()
    5. .

See Also:
ServerRequestInterceptor

Method Summary
Modifier and Type Method and Description
 byte[] adapter_id()
Returns the opaque identifier for the object adapter.
 String[] adapter_name()
Returns the sequence of strings that identifies the object adapter instance that is handling this request.
 void add_reply_service_context(ServiceContext service_context, boolean replace)
Allows Interceptors to add service contexts to the request.
 Policy get_server_policy(int type)
Returns the policy in effect for this operation for the given policy type.
 byte[] object_id()
Returns the opaque object_id describing the target of the operation invocation.
 String orb_id()
Returns the ID that was used to create the ORB.
 Any sending_exception()
Returns an any which contains the exception to be returned to the client.
 String server_id()
Returns the server ID that was specified on ORB::init using the -ORBServerId argument.
 void set_slot(int id, Any data)
Allows an Interceptor to set a slot in the PortableInterceptor.Current that is in the scope of the request.
 boolean target_is_a(String id)
Returns true if the servant is the given repository id, false if it is not.
 String target_most_derived_interface()
Returns the repository id for the most derived interface of the servant.
Methods inherited from interface org.omg.PortableInterceptor.RequestInfoOperations
arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope

Method Detail

sending_exception

Any sending_exception()
Returns an any which contains the exception to be returned to the client.

If the exception is a user exception which cannot be inserted into an any (e.g., it is unknown or the bindings don't provide the TypeCode), then this attribute will be an any containing the system exception UNKNOWN with a standard minor code of 1.

See Also:
PortableInterceptor package comments for limitations / unimplemented features

object_id

byte[] object_id()
Returns the opaque object_id describing the target of the operation invocation.

adapter_id

byte[] adapter_id()
Returns the opaque identifier for the object adapter.

server_id

String server_id()
Returns the server ID that was specified on ORB::init using the -ORBServerId argument.

orb_id

String orb_id()
Returns the ID that was used to create the ORB.

adapter_name

String[] adapter_name()
Returns the sequence of strings that identifies the object adapter instance that is handling this request.

target_most_derived_interface

String target_most_derived_interface()
Returns the repository id for the most derived interface of the servant.

get_server_policy

Policy get_server_policy(int type)
Returns the policy in effect for this operation for the given policy type. The returned CORBA.Policy object shall only be a policy whose type was registered via register_policy_factory.

Parameters:
type - The CORBA.PolicyType which specifies the policy to be returned.
Returns:
The CORBA.Policy obtained with the given policy type.
Throws:
INV_POLICY - thrown, with a standard minor code of 2, if a policy for the given type was not registered via register_policy_factory.
See Also:
ORBInitInfoOperations.register_policy_factory(int, org.omg.PortableInterceptor.PolicyFactory)

set_slot

void set_slot(int id,
              Any data)
              throws InvalidSlot
Allows an Interceptor to set a slot in the PortableInterceptor.Current that is in the scope of the request. If data already exists in that slot, it will be overwritten.

Parameters:
id - The id of the slot.
data - The data, in the form of an any, to store in that slot.
Throws:
InvalidSlot - thrown if the ID does not define an allocated slot.
See Also:
Current

target_is_a

boolean target_is_a(String id)
Returns true if the servant is the given repository id, false if it is not.

Parameters:
id - The caller wants to know if the servant is this repository id.
Returns:
Is the servant the given RepositoryId?

add_reply_service_context

void add_reply_service_context(ServiceContext service_context,
                               boolean replace)
Allows Interceptors to add service contexts to the request.

There is no declaration of the order of the service contexts. They may or may not appear in the order that they are added.

Parameters:
service_context - The IOP.ServiceContext to add to the reply.
replace - Indicates the behavior of this operation when a service context already exists with the given ID. If false, then BAD_INV_ORDER with a standard minor code of 15 is thrown. If true, then the existing service context is replaced by the new one.
Throws:
BAD_INV_ORDER - thrown, with a standard minor code of 15, if replace is false and a service context already exists with the given ID.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServerRequestInterceptor (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface ServerRequestInterceptor

All Superinterfaces:
IDLEntity, Interceptor, InterceptorOperations, Object, Serializable, ServerRequestInterceptorOperations
public interface ServerRequestInterceptor
extends ServerRequestInterceptorOperations, Interceptor, IDLEntity

Server-side request interceptor.

A request Interceptor is designed to intercept the flow of a request/reply sequence through the ORB at specific points so that services can query the request information and manipulate the service contexts which are propagated between clients and servers. The primary use of request Interceptors is to enable ORB services to transfer context information between clients and servers. There are two types of request Interceptors: client-side and server-side.

To write a server-side Interceptor, implement the ServerRequestInterceptor interface.

See Also:
ServerRequestInfo

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableInterceptor.ServerRequestInterceptorOperations
receive_request_service_contexts, receive_request, send_exception, send_other, send_reply
Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations
destroy, name
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServerRequestInterceptorOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface ServerRequestInterceptorOperations

All Superinterfaces:
InterceptorOperations
All Known Subinterfaces:
ServerRequestInterceptor
public interface ServerRequestInterceptorOperations
extends InterceptorOperations

Server-side request interceptor.

A request Interceptor is designed to intercept the flow of a request/reply sequence through the ORB at specific points so that services can query the request information and manipulate the service contexts which are propagated between clients and servers. The primary use of request Interceptors is to enable ORB services to transfer context information between clients and servers. There are two types of request Interceptors: client-side and server-side.

To write a server-side Interceptor, implement the ServerRequestInterceptor interface.

See Also:
ServerRequestInfo

Method Summary
Modifier and Type | Method and Description
void | receive_request_service_contexts(ServerRequestInfo ri) Allows the interceptor to process service context information.
void | receive_request(ServerRequestInfo ri) Allows an Interceptor to query request information after all the information, including operation parameters, are available.
void | send_exception(ServerRequestInfo ri) Allows an Interceptor to query the exception information and modify the reply service context before the exception is thrown to the client.
void | send_other(ServerRequestInfo ri) Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception.
void | send_reply(ServerRequestInfo ri) Allows an Interceptor to query reply information and modify the reply service context after the target operation has been invoked and before the reply is returned to the client.
Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations
destroy, name

Method Detail

receive_request_service_contexts

void receive_request_service_contexts(ServerRequestInfo ri)
                                      throws ForwardRequest
Allows the interceptor to process service context information.

At this interception point, Interceptors must get their service context information from the incoming request transfer it to PortableInterceptor.Current's slots.

This interception point is called before the servant manager is called. Operation parameters are not yet available at this point. This interception point may or may not execute in the same thread as the target invocation.

This interception point may throw a system exception. If it does, no other Interceptors' receive_request_service_contexts operations are called. Those Interceptors on the Flow Stack are popped and their send_exception interception points are called.

This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, no other Interceptors' receive_request_service_contexts operations are called. Those Interceptors on the Flow Stack are popped and their send_other interception points are called.

Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO.

Parameters:
ri - Information about the current request being intercepted.
Throws:
ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.

receive_request

void receive_request(ServerRequestInfo ri)
                     throws ForwardRequest
Allows an Interceptor to query request information after all the information, including operation parameters, are available. This interception point shall execute in the same thread as the target invocation.

In the DSI model, since the parameters are first available when the user code calls arguments, receive_request is called from within arguments. It is possible that arguments is not called in the DSI model. The target may call set_exception before calling arguments. The ORB shall guarantee that receive_request is called once, either through arguments or through set_exception. If it is called through set_exception, requesting the arguments will result in NO_RESOURCES being thrown with a standard minor code of 1.

This interception point may throw a system exception. If it does, no other Interceptors' receive_request operations are called. Those Interceptors on the Flow Stack are popped and their send_exception interception points are called.

This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, no other Interceptors' receive_request operations are called. Those Interceptors on the Flow Stack are popped and their send_other interception points are called.

Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO.

Parameters:
ri - Information about the current request being intercepted.
Throws:
ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.

send_reply

void send_reply(ServerRequestInfo ri)
Allows an Interceptor to query reply information and modify the reply service context after the target operation has been invoked and before the reply is returned to the client. This interception point shall execute in the same thread as the target invocation.

This interception point may throw a system exception. If it does, no other Interceptors' send_reply operations are called. The remaining Interceptors in the Flow Stack shall have their send_exception interception point called.

Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_YES.

Parameters:
ri - Information about the current request being intercepted.

send_exception

void send_exception(ServerRequestInfo ri)
                    throws ForwardRequest
Allows an Interceptor to query the exception information and modify the reply service context before the exception is thrown to the client. When an exception occurs, this interception point is called. This interception point shall execute in the same thread as the target invocation.

This interception point may throw a system exception. This has the effect of changing the exception which successive Interceptors popped from the Flow Stack receive on their calls to send_exception. The exception thrown to the client will be the last exception thrown by an Interceptor, or the original exception if no Interceptor changes the exception.

This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, no other Interceptors' send_exception operations are called. The remaining Interceptors in the Flow Stack shall have their send_other interception points called.

If the completion_status of the exception is not COMPLETED_NO, then it is inappropriate for this interception point to throw a ForwardRequest exception. The request's at-most-once semantics would be lost.

Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. If the original exception is a system exception, the completion_status of the new exception shall be the same as on the original. If the original exception is a user exception, then the completion_status of the new exception shall be COMPLETED_YES.

Parameters:
ri - Information about the current request being intercepted.
Throws:
ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.

send_other

void send_other(ServerRequestInfo ri)
                throws ForwardRequest
Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception. For example, a request could result in a retry (e.g., a GIOP Reply with a LOCATION_FORWARD status was received). This interception point shall execute in the same thread as the target invocation.

This interception point may throw a system exception. If it does, no other Interceptors' send_other operations are called. The remaining Interceptors in the Flow Stack shall have their send_exception interception points called.

This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, successive Interceptors' send_other operations are called with the new information provided by the ForwardRequest exception.

Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO.

Parameters:
ri - Information about the current request being intercepted.
Throws:
ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


SUCCESSFUL (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface SUCCESSFUL

public interface SUCCESSFUL

org/omg/PortableInterceptor/SUCCESSFUL.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Field Summary
Modifier and Type | Field and Description
static short | value Indicates a successful Reply Status.

Field Detail

value

static final short value
Indicates a successful Reply Status. One possible value for RequestInfo.reply_status.

See Also:
RequestInfoOperations.reply_status(), SYSTEM_EXCEPTION, USER_EXCEPTION, LOCATION_FORWARD, TRANSPORT_RETRY, Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


SYSTEM_EXCEPTION (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface SYSTEM_EXCEPTION

public interface SYSTEM_EXCEPTION

org/omg/PortableInterceptor/SYSTEM_EXCEPTION.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Field Summary
Modifier and Type | Field and Description
static short | value Indicates a SystemException reply status.

Field Detail

value

static final short value
Indicates a SystemException reply status. One possible value for RequestInfo.reply_status.

See Also:
RequestInfoOperations.reply_status(), SUCCESSFUL, USER_EXCEPTION, LOCATION_FORWARD, TRANSPORT_RETRY, Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TRANSPORT_RETRY (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface TRANSPORT_RETRY

public interface TRANSPORT_RETRY

org/omg/PortableInterceptor/TRANSPORT_RETRY.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Field Summary
Modifier and Type | Field and Description
static short | value Indicates a Transport Retry reply status.

Field Detail

value

static final short value
Indicates a Transport Retry reply status. One possible value for RequestInfo.reply_status.

See Also:
RequestInfoOperations.reply_status(), SUCCESSFUL, SYSTEM_EXCEPTION, USER_EXCEPTION, LOCATION_FORWARD, Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


UNKNOWN (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor
Interface UNKNOWN

public interface UNKNOWN

org/omg/PortableInterceptor/UNKNOWN.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Field Summary
Modifier and Type | Field and Description
static short | value XXX

Field Detail

value

static final short value
XXX

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


USER_EXCEPTION (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.PortableInterceptor
Interface USER_EXCEPTION

public interface USER_EXCEPTION

org/omg/PortableInterceptor/USER_EXCEPTION.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Field Summary
Modifier and Type | Field and Description
static short | value Indicates a UserException reply status.

Field Detail

value

static final short value
Indicates a UserException reply status. One possible value for RequestInfo.reply_status.

See Also:
RequestInfoOperations.reply_status(), SUCCESSFUL, SYSTEM_EXCEPTION, LOCATION_FORWARD, TRANSPORT_RETRY, Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DuplicateName (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.PortableInterceptor.ORBInitInfoPackage
Class DuplicateName

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName
All Implemented Interfaces:
Serializable, IDLEntity
public final class DuplicateName
extends UserException

org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Field Summary
Modifier and Type | Field and Description
String | name The name for which there was already an interceptor registered.
Constructor Summary
Constructor and Description
DuplicateName()
DuplicateName(String _name)
DuplicateName(String $reason, String _name)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

name

public String name
The name for which there was already an interceptor registered.

Constructor Detail

DuplicateName

public DuplicateName()

DuplicateName

public DuplicateName(String _name)

DuplicateName

public DuplicateName(String $reason,
                     String _name)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DuplicateNameHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor.ORBInitInfoPackage
Class DuplicateNameHelper

java.lang.Object
    extended by  org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper

public abstract class DuplicateNameHelper
extends Object

org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateNameHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Constructor Summary
Constructor and Description
DuplicateNameHelper()
Method Summary
Modifier and Type | Method and Description
static DuplicateName | extract(Any a)
static String | id()
static void | insert(Any a, DuplicateName that)
static DuplicateName | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, DuplicateName value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DuplicateNameHelper

public DuplicateNameHelper()
Method Detail

insert

public static void insert(Any a,
                          DuplicateName that)

extract

public static DuplicateName extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static DuplicateName read(InputStream istream)

write

public static void write(OutputStream ostream,
                         DuplicateName value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


InvalidName (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor.ORBInitInfoPackage
Class InvalidName

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName
All Implemented Interfaces:
Serializable, IDLEntity
public final class InvalidName
extends UserException

org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidName.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Constructor Summary
Constructor and Description
InvalidName()
InvalidName(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidName

public InvalidName()

InvalidName

public InvalidName(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


InvalidNameHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableInterceptor.ORBInitInfoPackage
Class InvalidNameHelper

java.lang.Object
    extended by  org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper

public abstract class InvalidNameHelper
extends Object

org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidNameHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, May 14, 2009 3:15:24 AM PDT

Constructor Summary
Constructor and Description
InvalidNameHelper()
Method Summary
Modifier and Type | Method and Description
static InvalidName | extract(Any a)
static String | id()
static void | insert(Any a, InvalidName that)
static InvalidName | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, InvalidName value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InvalidNameHelper

public InvalidNameHelper()
Method Detail

insert

public static void insert(Any a,
                          InvalidName that)

extract

public static InvalidName extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static InvalidName read(InputStream istream)

write

public static void write(OutputStream ostream,
                         InvalidName value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ObjectIdHelper (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.PortableInterceptor.ORBInitInfoPackage
Class ObjectIdHelper

java.lang.Object
    extended by  org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper

public abstract class ObjectIdHelper
extends Object

Object id, represented as a String

Constructor Summary
Constructor and Description
ObjectIdHelper()
Method Summary
Modifier and Type | Method and Description
static String | extract(Any a)
static String | id()
static void | insert(Any a, String that)
static String | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ObjectIdHelper

public ObjectIdHelper()
Method Detail

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.omg.PortableInterceptor.ORBInitInfoPackage (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.PortableInterceptor.ORBInitInfoPackage

This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.

See:
Description

Class Summary
Class | Description
DuplicateNameHelper | org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateNameHelper.java .
InvalidNameHelper | org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidNameHelper.java .
ObjectIdHelper | Object id, represented as a String

Exception Summary
Exception | Description
DuplicateName | org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java .
InvalidName | org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidName.java .

Package org.omg.PortableInterceptor.ORBInitInfoPackage Description

This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2. Please refer to that OMG specification for further details.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java SE 6.

Since:
1.4
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


AdapterActivator (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface AdapterActivator

All Superinterfaces:
AdapterActivatorOperations, IDLEntity, Object, Serializable
public interface AdapterActivator
extends AdapterActivatorOperations, Object, IDLEntity

An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableServer.AdapterActivatorOperations
unknown_adapter
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


AdapterActivatorOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface AdapterActivatorOperations

All Known Subinterfaces:
AdapterActivator
public interface AdapterActivatorOperations

An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.

Method Summary
Modifier and Type | Method and Description
boolean | unknown_adapter(POA parent, String name) This operation is invoked when the ORB receives a request for an object reference that identifies a target POA that does not exist.

Method Detail

unknown_adapter

boolean unknown_adapter(POA parent,
                        String name)
This operation is invoked when the ORB receives a request for an object reference that identifies a target POA that does not exist. The ORB invokes this operation once for each POA that must be created in order for the target POA to exist.

Parameters:
parent - indicates the parent POA for the POA that needs to be created.
name - identifies the name of the POA relative to the parent.
Returns:
returns TRUE if the POA was created or FALSE otherwise.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


Current (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface Current

All Superinterfaces:
Current, CurrentOperations, IDLEntity, Object, Serializable
public interface Current
extends CurrentOperations, Current, IDLEntity

The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked. The Current interface is provided to support servants that implement multiple objects, but can be used within the context of POA-dispatched method invocations on any servant. To provide location transparency, ORBs are required to support use of Current in the context of both locally and remotely invoked operations. An instance of Current can be obtained by the application by issuing the CORBA::ORB::resolve_initial_references("POACurrent") operation. Thereafter, it can be used within the context of a method dispatched by the POA to obtain the POA and ObjectId that identify the object on which that operation was invoked.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableServer.CurrentOperations
get_object_id, get_POA
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


CurrentHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Class CurrentHelper

java.lang.Object
    extended by  org.omg.PortableServer.CurrentHelper

public abstract class CurrentHelper
extends Object

The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked. The Current interface is provided to support servants that implement multiple objects, but can be used within the context of POA-dispatched method invocations on any servant. To provide location transparency, ORBs are required to support use of Current in the context of both locally and remotely invoked operations. An instance of Current can be obtained by the application by issuing the CORBA::ORB::resolve_initial_references("POACurrent") operation. Thereafter, it can be used within the context of a method dispatched by the POA to obtain the POA and ObjectId that identify the object on which that operation was invoked.

Constructor Summary
Constructor and Description
CurrentHelper()
Method Summary
Modifier and Type | Method and Description
static Current | extract(Any a)
static String | id()
static void | insert(Any a, Current that)
static Current | narrow(Object obj)
static Current | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, Current value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CurrentHelper

public CurrentHelper()
Method Detail

insert

public static void insert(Any a,
                          Current that)

extract

public static Current extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static Current read(InputStream istream)

write

public static void write(OutputStream ostream,
                         Current value)

narrow

public static Current narrow(Object obj)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


CurrentOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface CurrentOperations

All Superinterfaces:
CurrentOperations
All Known Subinterfaces:
Current
public interface CurrentOperations
extends CurrentOperations

The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked. The Current interface is provided to support servants that implement multiple objects, but can be used within the context of POA-dispatched method invocations on any servant. To provide location transparency, ORBs are required to support use of Current in the context of both locally and remotely invoked operations. An instance of Current can be obtained by the application by issuing the CORBA::ORB::resolve_initial_references("POACurrent") operation. Thereafter, it can be used within the context of a method dispatched by the POA to obtain the POA and ObjectId that identify the object on which that operation was invoked.

Method Summary
Modifier and Type | Method and Description
byte[] | get_object_id() Returns the ObjectId identifying the object in whose context it is called.
POA | get_POA() Returns reference to the POA implementing the object in whose context it is called.

Method Detail

get_POA

POA get_POA()
            throws NoContext
Returns reference to the POA implementing the object in whose context it is called.

Returns:
The poa implementing the object
Throws:
NoContext - is raised when the operation is outside the context of a POA-dispatched operation

get_object_id

byte[] get_object_id()
                     throws NoContext
Returns the ObjectId identifying the object in whose context it is called.

Returns:
the ObjectId of the object
Throws:
NoContext - is raised when the operation is called outside the context of a POA-dispatched operation.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DynamicImplementation (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Class DynamicImplementation

java.lang.Object
    extended by  org.omg.PortableServer.Servant
        extended by  org.omg.PortableServer.DynamicImplementation

public abstract class DynamicImplementation
extends Servant

Allows dynamic handling of object invocations. POA-based DSI servants inherit from the standard DynamicImplementation class, this class inherits from the Servant class. Based on IDL to Java spec. CORBA V 2.3.1 ptc/00-01-08.pdf.

Constructor Summary
Constructor and Description
DynamicImplementation()
Method Summary
Modifier and Type | Method and Description
abstract void | invoke(ServerRequest request) Receives requests issued to any CORBA object incarnated by the DSI servant and performs the processing necessary to execute the request.
Methods inherited from class org.omg.PortableServer.Servant
_all_interfaces, _default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DynamicImplementation

public DynamicImplementation()
Method Detail

invoke

public abstract void invoke(ServerRequest request)
Receives requests issued to any CORBA object incarnated by the DSI servant and performs the processing necessary to execute the request.

Parameters:
request - the request issued to the CORBA object.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ForwardRequest (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Class ForwardRequest

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.PortableServer.ForwardRequest
All Implemented Interfaces:
Serializable, IDLEntity
public final class ForwardRequest
extends UserException

org/omg/PortableServer/ForwardRequest.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
Object | forward_reference
Constructor Summary
Constructor and Description
ForwardRequest()
ForwardRequest(Object _forward_reference)
ForwardRequest(String $reason, Object _forward_reference)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

forward_reference

public Object forward_reference
Constructor Detail

ForwardRequest

public ForwardRequest()

ForwardRequest

public ForwardRequest(Object _forward_reference)

ForwardRequest

public ForwardRequest(String $reason,
                      Object _forward_reference)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ForwardRequestHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Class ForwardRequestHelper

java.lang.Object
    extended by  org.omg.PortableServer.ForwardRequestHelper

public abstract class ForwardRequestHelper
extends Object

org/omg/PortableServer/ForwardRequestHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
ForwardRequestHelper()
Method Summary
Modifier and Type | Method and Description
static ForwardRequest | extract(Any a)
static String | id()
static void | insert(Any a, ForwardRequest that)
static ForwardRequest | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ForwardRequest value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ForwardRequestHelper

public ForwardRequestHelper()
Method Detail

insert

public static void insert(Any a,
                          ForwardRequest that)

extract

public static ForwardRequest extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ForwardRequest read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ForwardRequest value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ID_ASSIGNMENT_POLICY_ID (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface ID_ASSIGNMENT_POLICY_ID

public interface ID_ASSIGNMENT_POLICY_ID

org/omg/PortableServer/ID_ASSIGNMENT_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
static int | value The value representing ID_ASSIGNMENT_POLICY_ID.

Field Detail

value

static final int value
The value representing ID_ASSIGNMENT_POLICY_ID.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ID_UNIQUENESS_POLICY_ID (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface ID_UNIQUENESS_POLICY_ID

public interface ID_UNIQUENESS_POLICY_ID

org/omg/PortableServer/ID_UNIQUENESS_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
static int | value The value representing ID_UNIQUENESS_POLICY_ID.

Field Detail

value

static final int value
The value representing ID_UNIQUENESS_POLICY_ID.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


IdAssignmentPolicy (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface IdAssignmentPolicy

All Superinterfaces:
IdAssignmentPolicyOperations, IDLEntity, Object, Policy, PolicyOperations, Serializable
public interface IdAssignmentPolicy
extends IdAssignmentPolicyOperations, Policy, IDLEntity

IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB. The default is SYSTEM_ID.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableServer.IdAssignmentPolicyOperations
value
Methods inherited from interface org.omg.CORBA.PolicyOperations
copy, destroy, policy_type
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


IdAssignmentPolicyOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface IdAssignmentPolicyOperations

All Superinterfaces:
PolicyOperations
All Known Subinterfaces:
IdAssignmentPolicy
public interface IdAssignmentPolicyOperations
extends PolicyOperations

IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB. The default is SYSTEM_ID.

Method Summary
Modifier and Type | Method and Description
IdAssignmentPolicyValue | value() specifies the policy value
Methods inherited from interface org.omg.CORBA.PolicyOperations
copy, destroy, policy_type

Method Detail

value

IdAssignmentPolicyValue value()
specifies the policy value

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


IdAssignmentPolicyValue (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Class IdAssignmentPolicyValue

java.lang.Object
    extended by  org.omg.PortableServer.IdAssignmentPolicyValue
All Implemented Interfaces:
Serializable, IDLEntity
public class IdAssignmentPolicyValue
extends Object
implements IDLEntity

The IdAssignmentPolicyValue can have the following values. USER_ID - Objects created with that POA are assigned Object Ids only by the application. SYSTEM_ID - Objects created with that POA are assigned Object Ids only by the POA. If the POA also has the PERSISTENT policy, assigned Object Ids must be unique across all instantiations of the same POA.

Field Summary
Modifier and Type | Field and Description
static int | _SYSTEM_ID
static int | _USER_ID
static IdAssignmentPolicyValue | SYSTEM_ID
static IdAssignmentPolicyValue | USER_ID
Constructor Summary
Modifier | Constructor and Description
protected | IdAssignmentPolicyValue(int value)
Method Summary
Modifier and Type | Method and Description
static IdAssignmentPolicyValue | from_int(int value)
int | value()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_USER_ID

public static final int _USER_ID
See Also:
Constant Field Values

USER_ID

public static final IdAssignmentPolicyValue USER_ID

_SYSTEM_ID

public static final int _SYSTEM_ID
See Also:
Constant Field Values

SYSTEM_ID

public static final IdAssignmentPolicyValue SYSTEM_ID
Constructor Detail

IdAssignmentPolicyValue

protected IdAssignmentPolicyValue(int value)
Method Detail

value

public int value()

from_int

public static IdAssignmentPolicyValue from_int(int value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


IdUniquenessPolicy (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface IdUniquenessPolicy

All Superinterfaces:
IDLEntity, IdUniquenessPolicyOperations, Object, Policy, PolicyOperations, Serializable
public interface IdUniquenessPolicy
extends IdUniquenessPolicyOperations, Policy, IDLEntity

The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities. The default is UNIQUE_ID.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableServer.IdUniquenessPolicyOperations
value
Methods inherited from interface org.omg.CORBA.PolicyOperations
copy, destroy, policy_type
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


IdUniquenessPolicyOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface IdUniquenessPolicyOperations

All Superinterfaces:
PolicyOperations
All Known Subinterfaces:
IdUniquenessPolicy
public interface IdUniquenessPolicyOperations
extends PolicyOperations

The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities. The default is UNIQUE_ID.

Method Summary
Modifier and Type | Method and Description
IdUniquenessPolicyValue | value() specifies the policy value
Methods inherited from interface org.omg.CORBA.PolicyOperations
copy, destroy, policy_type

Method Detail

value

IdUniquenessPolicyValue value()
specifies the policy value

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


IdUniquenessPolicyValue (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Class IdUniquenessPolicyValue

java.lang.Object
    extended by  org.omg.PortableServer.IdUniquenessPolicyValue
All Implemented Interfaces:
Serializable, IDLEntity
public class IdUniquenessPolicyValue
extends Object
implements IDLEntity

IdUniquenessPolicyValue can have the following values. UNIQUE_ID - Servants activated with that POA support exactly one Object Id. MULTIPLE_ID - a servant activated with that POA may support one or more Object Ids.

Field Summary
Modifier and Type | Field and Description
static int | _MULTIPLE_ID
static int | _UNIQUE_ID
static IdUniquenessPolicyValue | MULTIPLE_ID
static IdUniquenessPolicyValue | UNIQUE_ID
Constructor Summary
Modifier | Constructor and Description
protected | IdUniquenessPolicyValue(int value)
Method Summary
Modifier and Type | Method and Description
static IdUniquenessPolicyValue | from_int(int value)
int | value()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_UNIQUE_ID

public static final int _UNIQUE_ID
See Also:
Constant Field Values

UNIQUE_ID

public static final IdUniquenessPolicyValue UNIQUE_ID

_MULTIPLE_ID

public static final int _MULTIPLE_ID
See Also:
Constant Field Values

MULTIPLE_ID

public static final IdUniquenessPolicyValue MULTIPLE_ID
Constructor Detail

IdUniquenessPolicyValue

protected IdUniquenessPolicyValue(int value)
Method Detail

value

public int value()

from_int

public static IdUniquenessPolicyValue from_int(int value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


IMPLICIT_ACTIVATION_POLICY_ID (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface IMPLICIT_ACTIVATION_POLICY_ID

public interface IMPLICIT_ACTIVATION_POLICY_ID

org/omg/PortableServer/IMPLICIT_ACTIVATION_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
static int | value The value representing IMPLICIT_ACTIVATION_POLICY_ID.

Field Detail

value

static final int value
The value representing IMPLICIT_ACTIVATION_POLICY_ID.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ImplicitActivationPolicy (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface ImplicitActivationPolicy

All Superinterfaces:
IDLEntity, ImplicitActivationPolicyOperations, Object, Policy, PolicyOperations, Serializable
public interface ImplicitActivationPolicy
extends ImplicitActivationPolicyOperations, Policy, IDLEntity

This policy specifies whether implicit activation of servants is supported in the created POA.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableServer.ImplicitActivationPolicyOperations
value
Methods inherited from interface org.omg.CORBA.PolicyOperations
copy, destroy, policy_type
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ImplicitActivationPolicyOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface ImplicitActivationPolicyOperations

All Superinterfaces:
PolicyOperations
All Known Subinterfaces:
ImplicitActivationPolicy
public interface ImplicitActivationPolicyOperations
extends PolicyOperations

This policy specifies whether implicit activation of servants is supported in the created POA.

Method Summary
Modifier and Type | Method and Description
ImplicitActivationPolicyValue | value() specifies the policy value
Methods inherited from interface org.omg.CORBA.PolicyOperations
copy, destroy, policy_type

Method Detail

value

ImplicitActivationPolicyValue value()
specifies the policy value

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ImplicitActivationPolicyValue (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Class ImplicitActivationPolicyValue

java.lang.Object
    extended by  org.omg.PortableServer.ImplicitActivationPolicyValue
All Implemented Interfaces:
Serializable, IDLEntity
public class ImplicitActivationPolicyValue
extends Object
implements IDLEntity

ImplicitActivationPolicyValue has the following semantics. IMPLICIT_ACTIVATION to indicate implicit activation of servants. This requires SYSTEM_ID and RETAIN policies to be set. NO_IMPLICIT_ACTIVATION to indicate no implicit servant activation.

Field Summary
Modifier and Type | Field and Description
static int | _IMPLICIT_ACTIVATION
static int | _NO_IMPLICIT_ACTIVATION
static ImplicitActivationPolicyValue | IMPLICIT_ACTIVATION
static ImplicitActivationPolicyValue | NO_IMPLICIT_ACTIVATION
Constructor Summary
Modifier | Constructor and Description
protected | ImplicitActivationPolicyValue(int value)
Method Summary
Modifier and Type | Method and Description
static ImplicitActivationPolicyValue | from_int(int value)
int | value()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_IMPLICIT_ACTIVATION

public static final int _IMPLICIT_ACTIVATION
See Also:
Constant Field Values

IMPLICIT_ACTIVATION

public static final ImplicitActivationPolicyValue IMPLICIT_ACTIVATION

_NO_IMPLICIT_ACTIVATION

public static final int _NO_IMPLICIT_ACTIVATION
See Also:
Constant Field Values

NO_IMPLICIT_ACTIVATION

public static final ImplicitActivationPolicyValue NO_IMPLICIT_ACTIVATION
Constructor Detail

ImplicitActivationPolicyValue

protected ImplicitActivationPolicyValue(int value)
Method Detail

value

public int value()

from_int

public static ImplicitActivationPolicyValue from_int(int value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


LIFESPAN_POLICY_ID (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface LIFESPAN_POLICY_ID

public interface LIFESPAN_POLICY_ID

org/omg/PortableServer/LIFESPAN_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
static int | value The value representing LIFESPAN_POLICY_ID.

Field Detail

value

static final int value
The value representing LIFESPAN_POLICY_ID.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


LifespanPolicy (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface LifespanPolicy

All Superinterfaces:
IDLEntity, LifespanPolicyOperations, Object, Policy, PolicyOperations, Serializable
public interface LifespanPolicy
extends LifespanPolicyOperations, Policy, IDLEntity

The LifespanPolicy specifies the lifespan of the objects implemented in the created POA. The default is TRANSIENT.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableServer.LifespanPolicyOperations
value
Methods inherited from interface org.omg.CORBA.PolicyOperations
copy, destroy, policy_type
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


LifespanPolicyOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface LifespanPolicyOperations

All Superinterfaces:
PolicyOperations
All Known Subinterfaces:
LifespanPolicy
public interface LifespanPolicyOperations
extends PolicyOperations

The LifespanPolicy specifies the lifespan of the objects implemented in the created POA. The default is TRANSIENT.

Method Summary
Modifier and Type | Method and Description
LifespanPolicyValue | value() specifies the policy value
Methods inherited from interface org.omg.CORBA.PolicyOperations
copy, destroy, policy_type

Method Detail

value

LifespanPolicyValue value()
specifies the policy value

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


LifespanPolicyValue (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Class LifespanPolicyValue

java.lang.Object
    extended by  org.omg.PortableServer.LifespanPolicyValue
All Implemented Interfaces:
Serializable, IDLEntity
public class LifespanPolicyValue
extends Object
implements IDLEntity

The LifespanPolicyValue can have the following values. TRANSIENT - The objects implemented in the POA cannot outlive the POA instance in which they are first created. PERSISTENT - The objects implemented in the POA can outlive the process in which they are first created.

Field Summary
Modifier and Type | Field and Description
static int | _PERSISTENT
static int | _TRANSIENT
static LifespanPolicyValue | PERSISTENT
static LifespanPolicyValue | TRANSIENT
Constructor Summary
Modifier | Constructor and Description
protected | LifespanPolicyValue(int value)
Method Summary
Modifier and Type | Method and Description
static LifespanPolicyValue | from_int(int value)
int | value()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_TRANSIENT

public static final int _TRANSIENT
See Also:
Constant Field Values

TRANSIENT

public static final LifespanPolicyValue TRANSIENT

_PERSISTENT

public static final int _PERSISTENT
See Also:
Constant Field Values

PERSISTENT

public static final LifespanPolicyValue PERSISTENT
Constructor Detail

LifespanPolicyValue

protected LifespanPolicyValue(int value)
Method Detail

value

public int value()

from_int

public static LifespanPolicyValue from_int(int value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


org.omg.PortableServer (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.PortableServer

Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

See:
Description

Interface Summary
Interface | Description
AdapterActivator | An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
AdapterActivatorOperations | An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
Current | The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
CurrentOperations | The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
ID_ASSIGNMENT_POLICY_ID | org/omg/PortableServer/ID_ASSIGNMENT_POLICY_ID.java .
ID_UNIQUENESS_POLICY_ID | org/omg/PortableServer/ID_UNIQUENESS_POLICY_ID.java .
IdAssignmentPolicy | IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
IdAssignmentPolicyOperations | IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
IdUniquenessPolicy | The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
IdUniquenessPolicyOperations | The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
IMPLICIT_ACTIVATION_POLICY_ID | org/omg/PortableServer/IMPLICIT_ACTIVATION_POLICY_ID.java .
ImplicitActivationPolicy | This policy specifies whether implicit activation of servants is supported in the created POA.
ImplicitActivationPolicyOperations | This policy specifies whether implicit activation of servants is supported in the created POA.
LIFESPAN_POLICY_ID | org/omg/PortableServer/LIFESPAN_POLICY_ID.java .
LifespanPolicy | The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
LifespanPolicyOperations | The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
POA | A POA object manages the implementation of a collection of objects.
POAManager | Each POA object has an associated POAManager object.
POAManagerOperations | Each POA object has an associated POAManager object.
POAOperations | A POA object manages the implementation of a collection of objects.
REQUEST_PROCESSING_POLICY_ID | org/omg/PortableServer/REQUEST_PROCESSING_POLICY_ID.java .
RequestProcessingPolicy | This policy specifies how requests are processed by the created POA.
RequestProcessingPolicyOperations | This policy specifies how requests are processed by the created POA.
SERVANT_RETENTION_POLICY_ID | org/omg/PortableServer/SERVANT_RETENTION_POLICY_ID.java .
ServantActivator | When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
ServantActivatorOperations | When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
ServantLocator | When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
ServantLocatorOperations | When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
ServantManager | A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object.
ServantManagerOperations | A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object.
ServantRetentionPolicy | This policy specifies whether the created POA retains active servants in an Active Object Map.
ServantRetentionPolicyOperations | This policy specifies whether the created POA retains active servants in an Active Object Map.
THREAD_POLICY_ID | org/omg/PortableServer/THREAD_POLICY_ID.java .
ThreadPolicy | The ThreadPolicy specifies the threading model used with the created POA.
ThreadPolicyOperations | The ThreadPolicy specifies the threading model used with the created POA.

Class Summary
Class | Description
_ServantActivatorStub | When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
_ServantLocatorStub | When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
CurrentHelper | The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
DynamicImplementation | Allows dynamic handling of object invocations.
ForwardRequestHelper | org/omg/PortableServer/ForwardRequestHelper.java .
IdAssignmentPolicyValue | The IdAssignmentPolicyValue can have the following values.
IdUniquenessPolicyValue | IdUniquenessPolicyValue can have the following values.
ImplicitActivationPolicyValue | ImplicitActivationPolicyValue has the following semantics.
LifespanPolicyValue | The LifespanPolicyValue can have the following values.
POAHelper | A POA object manages the implementation of a collection of objects.
RequestProcessingPolicyValue | The RequestProcessingPolicyValue can have the following values.
Servant | Defines the native Servant type.
ServantActivatorHelper | When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
ServantActivatorPOA | When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
ServantLocatorHelper | When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
ServantLocatorPOA | When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
ServantRetentionPolicyValue | ServantRetentionPolicyValue can have the following values.
ThreadPolicyValue | The ThreadPolicyValue can have the following values.

Exception Summary
Exception | Description
ForwardRequest | org/omg/PortableServer/ForwardRequest.java .

Package org.omg.PortableServer Description

Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

In Java, Portable Object Adaptor (POA)-based Dynamic Skeleton Interface (DSI) servants inherit from the standard DynamicImplementation class, which inherits from the Servant class. The native Servant type is defined by the PortableServer module for the POA. In Java, the Servant type is mapped to the Java org.omg.PortableServer.Servant class. It serves as the base class for all POA servant implementations and provides a number of methods that may be invoked by the application programmer, as well as methods which are invoked by the POA itself and may be overridden by the user to control aspects of servant behavior.

Package Specification

For a precise list of supported sections of official OMG specifications with which the Java[tm] Platform, Standard Edition 6 complies, see Official Specifications for CORBA support in Java[tm] SE 6.

POA-related Interfaces

The PortableServer module defines the following POA-related interfaces:

  • POA
  • POAManager
  • ServantManager
  • ServantActivator
  • ServantLocator
  • AdapterActivator
  • ThreadPolicy
  • LifespanPolicy
  • IdUniquenessPolicy
  • IdAssignmentPolicy
  • ImplicitActivationPolicy
  • ServantRetentionPolicy
  • RequestProcessingPolicy
  • Current

In addition, the POA defines the Servant native type.

Operations classes

Each of the interfaces listed above has an associated Operations interface. The Operations interface is generated by the idlj compiler and contains the method signatures for methods defined in its associated interface. The Operations interface can be accessed by both the client and the server, while its associated interface can only be called by the client.

Value Classes

Classes ending in the suffix PolicyValue provide the values used for the create_POA call, which sets the policy for the POA. See the sample code below for a demonstration. PolicyValue files include the following:

  • IdAssignmentPolicyValue
  • IdUniquenessPolicyValue
  • ImplicitActivationPolicyValue
  • LifespanPolicyValue
  • RequestProcessingPolicyValue
  • ServantRetentionPolicyValue
  • ThreadPolicyValue

Helper Classes

Helper classes, which are generated for all user-defined types in an OMG IDL interface, supply static methods needed to manipulate those types. There is only one method in a helper class that an application programmer uses: the narrow method. Only Java interfaces mapped from IDL interfaces will have a helper class that includes a narrow method, so in the PortableServer package, only the following classes have a narrow method:

  • ForwardRequestHelper
  • ServantActivatorHelper
  • ServantLocatorHelper

POA Classes

POA classes are used to implement the ServantActivator or ServantLocator.

Exceptions

The ForwardRequest exception indicates to the ORB that it is responsible for delivering the current request and subsequent ForwardRequest requests to the object denoted in the forward_reference member of the exception.

Interfaces Implemented by the Application Programmer

Most of what PortableServer does is transparent to the user. The result is that programmers will use only a few of the interfaces mentioned above. The remaining interfaces will be provided by the ORB implementation. The interfaces of interest to application programmers are the following:

  • AdapterActivator

    Adapter activators are associated with POAs. An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE. An application server that creates all its needed POAs at the beginning of execution does not need to use or provide an adapter activator; it is necessary only for the case in which POAs need to be created during request processing.

  • ServantLocator

    When the POA has the NON_RETAIN policy, it uses servant managers that are ServantLocators.

  • ServantActivator

    When the POA has the RETAIN policy, it uses servant managers that are ServantActivators.

Package org.omg.PortableServer.ServantLocatorPackage

This package supplies a CookieHolder class for passing the Cookie type as an out parameter. The CookieHolder class follows exactly the same pattern as the other holder classes for basic types.

Related Documentation

For an overview of Java IDL, please see:

  • Java IDL home page.

    Example Code

    Example Server Code

    import javax.naming.InitialContext;
import javax.naming.Context;
import javax.rmi.PortableRemoteObject ;
import com.sun.corba.se.impl.poa.POAORB;
import org.omg.PortableServer.*;
import java.util.*;
import org.omg.CORBA.*;
import javax.rmi.CORBA.Stub;
import javax.rmi.CORBA.Util;

public class HelloServer {
    public HelloServer(String[] args) {
        try {
            Properties p = System.getProperties();
         //   p.put("org.omg.CORBA.ORBClass", "com.sun.corba.ee.internal.POA.POAORB");
            ORB orb = ORB.init( args, p );

            POA rootPOA = (POA)orb.resolve_initial_references("RootPOA");

            Policy[] tpolicy = new Policy[3];
            tpolicy[0] = rootPOA.create_lifespan_policy(
                LifespanPolicyValue.TRANSIENT );
            tpolicy[1] = rootPOA.create_request_processing_policy(
                RequestProcessingPolicyValue.USE_ACTIVE_OBJECT_MAP_ONLY );
            tpolicy[2] = rootPOA.create_servant_retention_policy(
                ServantRetentionPolicyValue.RETAIN);
            POA tpoa = rootPOA.create_POA("MyTransientPOA", null, tpolicy);

            String  ObjectId = "MyObjectId";
            byte[] oid = ObjectId.getBytes();

            org.omg.CORBA.Object obj = tpoa.create_reference_with_id(oid,
                new _HelloImpl_Tie()._all_interfaces(tpoa, oid)[0]);
            HelloInterface helloRef = (HelloInterface)PortableRemoteObject.narrow(
                obj, HelloInterface.class );

            Context initialNamingContext = new InitialContext();
            initialNamingContext.rebind("HelloService", helloRef);
            System.out.println("Hello Server: Ready...");
            orb.run();
         } catch (Exception e) {
            System.out.println("Trouble: " + e);
            e.printStackTrace();
         }
     }

     public static void main(String args[]) {
         new HelloServer( args );
     }
}

    Since:
    1.4
    Overview Package Class Use Tree Deprecated Index Help
            Java™ Platform
    Standard Ed. 7
    DRAFT ea-b59
    PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


POA (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface POA

All Superinterfaces:
IDLEntity, Object, POAOperations, Serializable
public interface POA
extends POAOperations, Object, IDLEntity

A POA object manages the implementation of a collection of objects. The POA supports a name space for the objects, which are identified by Object Ids. A POA also provides a name space for POAs. A POA is created as a child of an existing POA, which forms a hierarchy starting with the root POA. A POA object must not be exported to other processes, or externalized with ORB::object_to_string.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableServer.POAOperations
activate_object_with_id, activate_object, create_id_assignment_policy, create_id_uniqueness_policy, create_implicit_activation_policy, create_lifespan_policy, create_POA, create_reference_with_id, create_reference, create_request_processing_policy, create_servant_retention_policy, create_thread_policy, deactivate_object, destroy, find_POA, get_servant_manager, get_servant, id_to_reference, id_to_servant, id, reference_to_id, reference_to_servant, servant_to_id, servant_to_reference, set_servant_manager, set_servant, the_activator, the_activator, the_children, the_name, the_parent, the_POAManager
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


POAHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Class POAHelper

java.lang.Object
    extended by  org.omg.PortableServer.POAHelper

public abstract class POAHelper
extends Object

A POA object manages the implementation of a collection of objects. The POA supports a name space for the objects, which are identified by Object Ids. A POA also provides a name space for POAs. A POA is created as a child of an existing POA, which forms a hierarchy starting with the root POA. A POA object must not be exported to other processes, or externalized with ORB::object_to_string.

Constructor Summary
Constructor and Description
POAHelper()
Method Summary
Modifier and Type | Method and Description
static POA | extract(Any a)
static String | id()
static void | insert(Any a, POA that)
static POA | narrow(Object obj)
static POA | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, POA value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

POAHelper

public POAHelper()
Method Detail

insert

public static void insert(Any a,
                          POA that)

extract

public static POA extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static POA read(InputStream istream)

write

public static void write(OutputStream ostream,
                         POA value)

narrow

public static POA narrow(Object obj)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


POAManager (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface POAManager

All Superinterfaces:
IDLEntity, Object, POAManagerOperations, Serializable
public interface POAManager
extends POAManagerOperations, Object, IDLEntity

Each POA object has an associated POAManager object. A POA manager may be associated with one or more POA objects. A POA manager encapsulates the processing state of the POAs it is associated with.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableServer.POAManagerOperations
activate, deactivate, discard_requests, get_state, hold_requests
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


POAManagerOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface POAManagerOperations

All Known Subinterfaces:
POAManager
public interface POAManagerOperations

Each POA object has an associated POAManager object. A POA manager may be associated with one or more POA objects. A POA manager encapsulates the processing state of the POAs it is associated with.

Method Summary
Modifier and Type | Method and Description
void | activate() This operation changes the state of the POA manager to active, causing associated POAs to start processing requests.
void | deactivate(boolean etherealize_objects, boolean wait_for_completion) This operation changes the state of the POA manager to inactive, causing associated POAs to reject the requests that have not begun executing as well as as any new requests.
void | discard_requests(boolean wait_for_completion) This operation changes the state of the POA manager to discarding.
State | get_state() This operation returns the state of the POA manager.
void | hold_requests(boolean wait_for_completion) This operation changes the state of the POA manager to holding, causing associated POAs to queue incoming requests.

Method Detail

activate

void activate()
              throws AdapterInactive
This operation changes the state of the POA manager to active, causing associated POAs to start processing requests.

Throws:
AdapterInactive - is raised if the operation is invoked on the POAManager in inactive state.

hold_requests

void hold_requests(boolean wait_for_completion)
                   throws AdapterInactive
This operation changes the state of the POA manager to holding, causing associated POAs to queue incoming requests.

Parameters:
wait_for_completion - if FALSE, the operation returns immediately after changing state. If TRUE, it waits for all active requests to complete.
Throws:
AdapterInactive - is raised if the operation is invoked on the POAManager in inactive state.

discard_requests

void discard_requests(boolean wait_for_completion)
                      throws AdapterInactive
This operation changes the state of the POA manager to discarding. This causes associated POAs to discard incoming requests.

Parameters:
wait_for_completion - if FALSE, the operation returns immediately after changing state. If TRUE, it waits for all active requests to complete.
Throws:
AdapterInactive - is raised if the operation is invoked on the POAManager in inactive state.

deactivate

void deactivate(boolean etherealize_objects,
                boolean wait_for_completion)
                throws AdapterInactive
This operation changes the state of the POA manager to inactive, causing associated POAs to reject the requests that have not begun executing as well as as any new requests.

Parameters:
etherealize_objects - a flag to indicate whether to invoke the etherealize operation of the associated servant manager for all active objects.
wait_for_completion - if FALSE, the operation returns immediately after changing state. If TRUE, it waits for all active requests to complete.
Throws:
AdapterInactive - is raised if the operation is invoked on the POAManager in inactive state.

get_state

State get_state()
This operation returns the state of the POA manager.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


POAOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface POAOperations

All Known Subinterfaces:
POA
public interface POAOperations

A POA object manages the implementation of a collection of objects. The POA supports a name space for the objects, which are identified by Object Ids. A POA also provides a name space for POAs. A POA is created as a child of an existing POA, which forms a hierarchy starting with the root POA. A POA object must not be exported to other processes, or externalized with ORB::object_to_string.

Method Summary
Modifier and Type | Method and Description
void | activate_object_with_id(byte[] id, Servant p_servant) This operation enters an association between the specified Object Id and the specified servant in the Active Object Map.
byte[] | activate_object(Servant p_servant) This operation generates an Object Id and enters the Object Id and the specified servant in the Active Object Map.
IdAssignmentPolicy | create_id_assignment_policy(IdAssignmentPolicyValue value) These operations each return a reference to a policy object with the specified value.
IdUniquenessPolicy | create_id_uniqueness_policy(IdUniquenessPolicyValue value) These operations each return a reference to a policy object with the specified value.
ImplicitActivationPolicy | create_implicit_activation_policy(ImplicitActivationPolicyValue value) These operations each return a reference to a policy object with the specified value.
LifespanPolicy | create_lifespan_policy(LifespanPolicyValue value) These operations each return a reference to a policy object with the specified value.
POA | create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies) This operation creates a new POA as a child of the target POA.
Object | create_reference_with_id(byte[] oid, String intf) This operation creates an object reference that encapsulates the specified Object Id and interface repository Id values.
Object | create_reference(String intf) This operation creates an object reference that encapsulates a POA-generated Object Id value and the specified interface repository id.
RequestProcessingPolicy | create_request_processing_policy(RequestProcessingPolicyValue value) These operations each return a reference to a policy object with the specified value.
ServantRetentionPolicy | create_servant_retention_policy(ServantRetentionPolicyValue value) These operations each return a reference to a policy object with the specified value.
ThreadPolicy | create_thread_policy(ThreadPolicyValue value) These operations each return a reference to a policy object with the specified value.
void | deactivate_object(byte[] oid) This operation causes the ObjectId specified in the oid parameter to be deactivated.
void | destroy(boolean etherealize_objects, boolean wait_for_completion) This operation destroys the POA and all descendant POAs.
POA | find_POA(String adapter_name, boolean activate_it) If the target POA is the parent of a child POA with the specified name (relative to the target POA), that child POA is returned.
ServantManager | get_servant_manager() If the ServantRetentionPolicy of the POA is RETAIN, then the ServantManager argument (imgr) shall support the ServantActivator interface.
Servant | get_servant() This operation returns the default servant associated with the POA.
Object | id_to_reference(byte[] oid) If an object with the specified Object Id value is currently active, a reference encapsulating the information used to activate the object is returned.
Servant | id_to_servant(byte[] oid) If the POA has the RETAIN policy and the specified ObjectId is in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
byte[] | id() This returns the unique id of the POA in the process in which it is created.
byte[] | reference_to_id(Object reference) This operation returns the Object Id value encapsulated by the specified reference.
Servant | reference_to_servant(Object reference) If the POA has the RETAIN policy and the specified object is present in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
byte[] | servant_to_id(Servant p_servant) This operation has four possible behaviors.
Object | servant_to_reference(Servant p_servant) This operation requires the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies if invoked outside the context of an operation dispatched by this POA.
void | set_servant_manager(ServantManager imgr) This operation sets the default servant manager associated with the POA.
void | set_servant(Servant p_servant) This operation registers the specified servant with the POA as the default servant.
AdapterActivator | the_activator() This attribute identifies the adapter activator associated with the POA.
void | the_activator(AdapterActivator newThe_activator) This attribute identifies the adapter activator associated with the POA.
POA[] | the_children() This attribute identifies the current set of all child POAs of the POA.
String | the_name() This attribute identifies the POA relative to its parent.
POA | the_parent() This attribute identifies the parent of the POA.
POAManager | the_POAManager() This attribute identifies the POA manager associated with the POA.

Method Detail

create_POA

POA create_POA(String adapter_name,
               POAManager a_POAManager,
               Policy[] policies)
               throws AdapterAlreadyExists,
                      InvalidPolicy
This operation creates a new POA as a child of the target POA.

Parameters:
adapter_name - identifies the new POA with respect to other POAs with the same parent POA.
a_POAManager - specifies the POA Manager to be associated with the new POA.
policies - specifies policy objects to be associated with the POA to control its behavior.
Throws:
AdapterAlreadyExists - specifies that the target POA already has a child POA with the specified name.
InvalidPolicy - is raised if any of the policy objects are not valid for the ORB, or are in conflict, or require an administrative action that has not been performed.

find_POA

POA find_POA(String adapter_name,
             boolean activate_it)
             throws AdapterNonExistent
If the target POA is the parent of a child POA with the specified name (relative to the target POA), that child POA is returned.

Parameters:
adapter_name - POA name to be found.
activate_it - if a POA with the specified name does not exist and the value of the activate_it parameter is TRUE, the target POA's AdapterActivator, if one exists, is invoked.
Returns:
POA if one exists or is activated by the AdapterActivator.
Throws:
AdapterNonExistent

destroy

void destroy(boolean etherealize_objects,
             boolean wait_for_completion)
This operation destroys the POA and all descendant POAs. All descendant POAs are destroyed (recursively) before the destruction of the containing POA. The POA so destroyed (that is, the POA with its name) may be re-created later in the same process.

Parameters:
etherealize_objects - flag to indicate whether etherealize operation on servant manager needs to be called.
wait_for_completion - flag to indicate whether POA and its children need to wait for active requests and the etherealization to complete.

create_thread_policy

ThreadPolicy create_thread_policy(ThreadPolicyValue value)
These operations each return a reference to a policy object with the specified value.

Parameters:
value - policy type
Returns:
ThreadPolcy Object

create_lifespan_policy

LifespanPolicy create_lifespan_policy(LifespanPolicyValue value)
These operations each return a reference to a policy object with the specified value.

Parameters:
value - policy type
Returns:
LifespanPolicy Object.

create_id_uniqueness_policy

IdUniquenessPolicy create_id_uniqueness_policy(IdUniquenessPolicyValue value)
These operations each return a reference to a policy object with the specified value.

Parameters:
value - policy type
Returns:
IdUniquenessPolicy Object.

create_id_assignment_policy

IdAssignmentPolicy create_id_assignment_policy(IdAssignmentPolicyValue value)
These operations each return a reference to a policy object with the specified value.

Parameters:
value - policy type
Returns:
IdAssignmentPolicy Object.

create_implicit_activation_policy

ImplicitActivationPolicy create_implicit_activation_policy(ImplicitActivationPolicyValue value)
These operations each return a reference to a policy object with the specified value.

Parameters:
value - policy type
Returns:
ImplicitActivationPolicy Object.

create_servant_retention_policy

ServantRetentionPolicy create_servant_retention_policy(ServantRetentionPolicyValue value)
These operations each return a reference to a policy object with the specified value.

Parameters:
value - policy type
Returns:
ServantRetentionPolicy Object.

create_request_processing_policy

RequestProcessingPolicy create_request_processing_policy(RequestProcessingPolicyValue value)
These operations each return a reference to a policy object with the specified value.

Parameters:
value - policy type
Returns:
RequestProcessingPolicy Object.

the_name

String the_name()
This attribute identifies the POA relative to its parent. This name is assigned when the POA is created.

the_parent

POA the_parent()
This attribute identifies the parent of the POA. The parent of the root POA is null.

the_children

POA[] the_children()
This attribute identifies the current set of all child POAs of the POA. The set of child POAs includes only the POA's immediate children, and not their descendants.

the_POAManager

POAManager the_POAManager()
This attribute identifies the POA manager associated with the POA.

the_activator

AdapterActivator the_activator()
This attribute identifies the adapter activator associated with the POA.

the_activator

void the_activator(AdapterActivator newThe_activator)
This attribute identifies the adapter activator associated with the POA.

get_servant_manager

ServantManager get_servant_manager()
                                   throws WrongPolicy
If the ServantRetentionPolicy of the POA is RETAIN, then the ServantManager argument (imgr) shall support the ServantActivator interface. For a NON_RETAIN policy, the ServantManager shall support the ServantLocator interface. If the argument is nil, or does not support the required interface, then the OBJ_ADAPTER exception is raised.

Returns:
ServantManager associated with a POA or null if none exists.
Throws:
WrongPolicy - raised if the USE_SERVANT_MANAGER policy is not specified.

set_servant_manager

void set_servant_manager(ServantManager imgr)
                         throws WrongPolicy
This operation sets the default servant manager associated with the POA. This operation may only be invoked once after a POA has been created. Attempting to set the servant manager after one has already been set will result in the BAD_INV_ORDER exception being raised.

Parameters:
imgr - servant manager to be used as a default.
Throws:
WrongPolicy - raised if the USE_SERVANT_MANAGER policy is not specified.

get_servant

Servant get_servant()
                    throws NoServant,
                           WrongPolicy
This operation returns the default servant associated with the POA.

Returns:
p_servant default servant associated with a POA.
Throws:
NoServant - raised if no default servant is associated with the POA.
WrongPolicy - raised if the USE_DEFAULT_SERVANT policy is not specified.

set_servant

void set_servant(Servant p_servant)
                 throws WrongPolicy
This operation registers the specified servant with the POA as the default servant. This servant will be used for all requests for which no servant is found in the Active Object Map.

Parameters:
p_servant - servant to be used as a default.
Throws:
WrongPolicy - raised if the USE_DEFAULT_SERVANT policy is not specified.

activate_object

byte[] activate_object(Servant p_servant)
                       throws ServantAlreadyActive,
                              WrongPolicy
This operation generates an Object Id and enters the Object Id and the specified servant in the Active Object Map.

Parameters:
p_servant - servant to be associated with an object to be activated.
Returns:
POA generated object id.
Throws:
ServantAlreadyActive - is raised if the POA has UNIQUE_ID policy and servant is is already in the Active Object Map.
WrongPolicy - raised if the SYSTEM_ID and RETAIN policies are not specified.

activate_object_with_id

void activate_object_with_id(byte[] id,
                             Servant p_servant)
                             throws ServantAlreadyActive,
                                    ObjectAlreadyActive,
                                    WrongPolicy
This operation enters an association between the specified Object Id and the specified servant in the Active Object Map.

Parameters:
id - object id for the object to be activated.
p_servant - servant to be associated with the object.
Throws:
ServantAlreadyActive - raised if the POA has the UNIQUE_ID policy and the servant is already in the Active Object Map.
ObjectAlreadyActive - raised if the object is already active in the POA.
WrongPolicy - raised if the RETAIN policy is is not specified.

deactivate_object

void deactivate_object(byte[] oid)
                       throws ObjectNotActive,
                              WrongPolicy
This operation causes the ObjectId specified in the oid parameter to be deactivated. An ObjectId which has been deactivated continues to process requests until there are no active requests for that ObjectId. A deactivated ObjectId is removed from the Active Object Map when all requests executing for that ObjectId have completed.

Parameters:
oid - Object Id for the object to be deactivated.
Throws:
ObjectNotActive - if the object with the specified oid is not in the Active Object Map.
WrongPolicy - raised if the RETAIN policy is is not specified.

create_reference

Object create_reference(String intf)
                        throws WrongPolicy
This operation creates an object reference that encapsulates a POA-generated Object Id value and the specified interface repository id.

Parameters:
intf - rep id for creating an object reference.
Returns:
object reference created using intf.
Throws:
WrongPolicy - if SYSTEM_ID policy is not specified.

create_reference_with_id

Object create_reference_with_id(byte[] oid,
                                String intf)
This operation creates an object reference that encapsulates the specified Object Id and interface repository Id values. It does not cause an activation to take place. The resulting reference may be passed to clients, so that subsequent requests on those references will cause the object to be activated if necessary, or the default servant used, depending on the applicable policies.

Parameters:
oid - object id for creating an objref
intf - rep id for creating an objref
Returns:
object reference created using oid and intf
Throws:
BAD_PARAM - is raised if the POA has the SYSTEM_ID policy and it detects that the Object Id value was not generated by the system or for this POA.

servant_to_id

byte[] servant_to_id(Servant p_servant)
                     throws ServantNotActive,
                            WrongPolicy
This operation has four possible behaviors. 1. If the POA has the UNIQUE_ID policy and the specified servant is active, the Object Id associated with that servant is returned. 2. If the POA has the IMPLICIT_ACTIVATION policy and either the POA has the MULTIPLE_ID policy or the specified servant is not active, the servant is activated using a POA-generated Object Id and the Interface Id associated with the servant, and that Object Id is returned. 3. If the POA has the USE_DEFAULT_SERVANT policy, the servant specified is the default servant, and the operation is being invoked in the context of executing a request on the default servant, then the ObjectId associated with the current invocation is returned. 4. Otherwise, the ServantNotActive exception is raised.

Parameters:
p_servant - servant for which the object disi returned.
Returns:
object id associated with the servant.
Throws:
ServantNotActive - if the above rules and policy combination is not met.
WrongPolicy - if the USE_DEFAULT_SERVANT policy or a combination of the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies are not present.

servant_to_reference

Object servant_to_reference(Servant p_servant)
                            throws ServantNotActive,
                                   WrongPolicy
This operation requires the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies if invoked outside the context of an operation dispatched by this POA. It has four possible behaviors. 1. If the POA has both the RETAIN and the UNIQUE_ID policy and the specified servant is active, an object reference encapsulating the information used to activate the servant is returned. 2. If the POA has both the RETAIN and the IMPLICIT_ACTIVATION policy and either the POA has the MULTIPLE_ID policy or the specified servant is not active, the servant is activated using a POA-generated Object Id and the Interface Id associated with the servant, and a corresponding object reference is returned. 3. If the operation was invoked in the context of executing a request on the specified servant, the reference associated with the current invocation is returned. 4. Otherwise, the ServantNotActive exception is raised.

Parameters:
p_servant - servant for which the object reference needs to be obtained.
Returns:
object reference associated with the servant.
Throws:
WrongPolicy - if the operation is not invoked in the context of executing a request on the specified servant and the required policies are not present.
ServantNotActive - if the above specified policies and rules are not met.

reference_to_servant

Servant reference_to_servant(Object reference)
                             throws ObjectNotActive,
                                    WrongPolicy,
                                    WrongAdapter
If the POA has the RETAIN policy and the specified object is present in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map. Otherwise, if the POA has the USE_DEFAULT_SERVANT policy and a default servant has been registered with the POA, this operation returns the default servant. If the object reference was not created by this POA, the WrongAdapter exception is raised. (OMG Issue on inconsistency with the POA.IDL.

Parameters:
reference - object reference for which the servant is returned.
Returns:
servant associated with the reference.
Throws:
WrongPolicy - if neither the RETAIN policy or the USE_DEFAULT_SERVANT policy is present.
ObjectNotActive - if the servant is not present in the Active Object Map (for RETAIN) or no default servant is registered (for USE_DEFAULT_POLICY).
WrongAdapter - if reference was not created by this POA instance.

reference_to_id

byte[] reference_to_id(Object reference)
                       throws WrongAdapter,
                              WrongPolicy
This operation returns the Object Id value encapsulated by the specified reference. This operation is valid only if the reference was created by the POA on which the operation is being performed. The object denoted by the reference does not have to be active for this operation to succeed.

Parameters:
reference - the object reference from which the object id needs to be returned.
Returns:
object id encapsulated in the reference.
Throws:
WrongAdapter - if the reference was not created by the POA specified in the reference.
WrongPolicy - declared to allow future extensions.

id_to_servant

Servant id_to_servant(byte[] oid)
                      throws ObjectNotActive,
                             WrongPolicy
If the POA has the RETAIN policy and the specified ObjectId is in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map. Otherwise, if the POA has the USE_DEFAULT_SERVANT policy and a default servant has been registered with the POA, this operation returns the default servant.

Parameters:
oid - object id for the which the servant is returned.
Returns:
servant associated with oid.
Throws:
ObjectNotActive - is raised if ObjectId is is not in the Active Object Map (for RETAIN policy), or no default servant is registered (for USE_DEFAULT_SERVANT policy).
WrongPolicy - is raised if the RETAIN policy or the USE_DEFAULT_SERVANT policy is not present.

id_to_reference

Object id_to_reference(byte[] oid)
                       throws ObjectNotActive,
                              WrongPolicy
If an object with the specified Object Id value is currently active, a reference encapsulating the information used to activate the object is returned.

Parameters:
oid - id of the object for which the reference is returned.
Returns:
the object reference
Throws:
ObjectNotActive - if the Object Id value is not active in the POA.
WrongPolicy - if the RETAIN policy is not present.

id

byte[] id()
This returns the unique id of the POA in the process in which it is created. It is for use by portable interceptors.

This id is guaranteed unique for the life span of the POA in the process. For persistent POAs, this means that if a POA is created in the same path with the same name as another POA, these POAs are identical and, therefore, have the same id. For transient POAs, each POA is unique.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


REQUEST_PROCESSING_POLICY_ID (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface REQUEST_PROCESSING_POLICY_ID

public interface REQUEST_PROCESSING_POLICY_ID

org/omg/PortableServer/REQUEST_PROCESSING_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
static int | value The value representing REQUEST_PROCESSING_POLICY_ID.

Field Detail

value

static final int value
The value representing REQUEST_PROCESSING_POLICY_ID.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


RequestProcessingPolicy (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface RequestProcessingPolicy

All Superinterfaces:
IDLEntity, Object, Policy, PolicyOperations, RequestProcessingPolicyOperations, Serializable
public interface RequestProcessingPolicy
extends RequestProcessingPolicyOperations, Policy, IDLEntity

This policy specifies how requests are processed by the created POA. The default is USE_ACTIVE_OBJECT_MAP_ONLY.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableServer.RequestProcessingPolicyOperations
value
Methods inherited from interface org.omg.CORBA.PolicyOperations
copy, destroy, policy_type
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


RequestProcessingPolicyOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface RequestProcessingPolicyOperations

All Superinterfaces:
PolicyOperations
All Known Subinterfaces:
RequestProcessingPolicy
public interface RequestProcessingPolicyOperations
extends PolicyOperations

This policy specifies how requests are processed by the created POA. The default is USE_ACTIVE_OBJECT_MAP_ONLY.

Method Summary
Modifier and Type | Method and Description
RequestProcessingPolicyValue | value() specifies the policy value
Methods inherited from interface org.omg.CORBA.PolicyOperations
copy, destroy, policy_type

Method Detail

value

RequestProcessingPolicyValue value()
specifies the policy value

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


RequestProcessingPolicyValue (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Class RequestProcessingPolicyValue

java.lang.Object
    extended by  org.omg.PortableServer.RequestProcessingPolicyValue
All Implemented Interfaces:
Serializable, IDLEntity
public class RequestProcessingPolicyValue
extends Object
implements IDLEntity

The RequestProcessingPolicyValue can have the following values. USE_ACTIVE_OBJECT_MAP_ONLY - If the Object Id is not found in the Active Object Map, an OBJECT_NOT_EXIST exception is returned to the client. The RETAIN policy is also required. USE_DEFAULT_SERVANT - If the Object Id is not found in the Active Object Map or the NON_RETAIN policy is present, and a default servant has been registered with the POA using the set_servant operation, the request is dispatched to the default servant. USE_SERVANT_MANAGER - If the Object Id is not found in the Active Object Map or the NON_RETAIN policy is present, and a servant manager has been registered with the POA using the set_servant_manager operation, the servant manager is given the opportunity to locate a servant or raise an exception.

Field Summary
Modifier and Type | Field and Description
static int | _USE_ACTIVE_OBJECT_MAP_ONLY
static int | _USE_DEFAULT_SERVANT
static int | _USE_SERVANT_MANAGER
static RequestProcessingPolicyValue | USE_ACTIVE_OBJECT_MAP_ONLY
static RequestProcessingPolicyValue | USE_DEFAULT_SERVANT
static RequestProcessingPolicyValue | USE_SERVANT_MANAGER
Constructor Summary
Modifier | Constructor and Description
protected | RequestProcessingPolicyValue(int value)
Method Summary
Modifier and Type | Method and Description
static RequestProcessingPolicyValue | from_int(int value)
int | value()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_USE_ACTIVE_OBJECT_MAP_ONLY

public static final int _USE_ACTIVE_OBJECT_MAP_ONLY
See Also:
Constant Field Values

USE_ACTIVE_OBJECT_MAP_ONLY

public static final RequestProcessingPolicyValue USE_ACTIVE_OBJECT_MAP_ONLY

_USE_DEFAULT_SERVANT

public static final int _USE_DEFAULT_SERVANT
See Also:
Constant Field Values

USE_DEFAULT_SERVANT

public static final RequestProcessingPolicyValue USE_DEFAULT_SERVANT

_USE_SERVANT_MANAGER

public static final int _USE_SERVANT_MANAGER
See Also:
Constant Field Values

USE_SERVANT_MANAGER

public static final RequestProcessingPolicyValue USE_SERVANT_MANAGER
Constructor Detail

RequestProcessingPolicyValue

protected RequestProcessingPolicyValue(int value)
Method Detail

value

public int value()

from_int

public static RequestProcessingPolicyValue from_int(int value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


Servant (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Class Servant

java.lang.Object
    extended by  org.omg.PortableServer.Servant
Direct Known Subclasses:
BindingIteratorPOA, DynamicImplementation, NamingContextExtPOA, NamingContextPOA, ServantActivatorPOA, ServantLocatorPOA
public abstract class Servant
extends Object

Defines the native Servant type. In Java, the Servant type is mapped to the Java org.omg.PortableServer.Servant class. It serves as the base class for all POA servant implementations and provides a number of methods that may be invoked by the application programmer, as well as methods which are invoked by the POA itself and may be overridden by the user to control aspects of servant behavior. Based on IDL to Java spec. (CORBA V2.3.1) ptc/00-01-08.pdf.

Constructor Summary
Constructor and Description
Servant()
Method Summary
Modifier and Type Method and Description
abstract  String[] _all_interfaces(POA poa, byte[] objectId)
Used by the ORB to obtain complete type information from the servant.
 POA _default_POA()
Returns the root POA from the ORB instance associated with the servant.
 Delegate _get_delegate()
Gets the ORB vendor-specific implementation of PortableServer::Servant.
 Object _get_interface_def()
Returns an InterfaceDef object as a CORBA::Object that defines the runtime type of the CORBA::Object implemented by the Servant.
 boolean _is_a(String repository_id)
Checks to see if the specified repository_id is present on the list returned by _all_interfaces() or is the repository_id for the generic CORBA Object.
 boolean _non_existent()
Checks for the existence of an Object.
 byte[] _object_id()
Allows easy execution of common methods, equivalent to calling PortableServer::Current::get_object_id.
 ORB _orb()
Returns the instance of the ORB currently associated with the Servant (convenience method).
 POA _poa()
Allows easy execution of common methods, equivalent to PortableServer::Current:get_POA.
 void _set_delegate(Delegate delegate)
Supports the Java ORB portability interfaces by providing a method for classes that support ORB portability through delegation to set their delegate.
 Object _this_object()
Allows the servant to obtain the object reference for the target CORBA object it is incarnating for that request.
 Object _this_object(ORB orb)
Allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Servant

public Servant()
Method Detail

_get_delegate

public final Delegate _get_delegate()
Gets the ORB vendor-specific implementation of PortableServer::Servant.

Returns:
_delegate the ORB vendor-specific implementation of PortableServer::Servant.

_set_delegate

public final void _set_delegate(Delegate delegate)
Supports the Java ORB portability interfaces by providing a method for classes that support ORB portability through delegation to set their delegate.

Parameters:
delegate - ORB vendor-specific implementation of the PortableServer::Servant.

_this_object

public final Object _this_object()
Allows the servant to obtain the object reference for the target CORBA object it is incarnating for that request.

Returns:
this_object Object reference associated with the request.

_this_object

public final Object _this_object(ORB orb)
Allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.

Parameters:
orb - ORB with which the servant is associated.
Returns:
_this_object reference associated with the request.

_orb

public final ORB _orb()
Returns the instance of the ORB currently associated with the Servant (convenience method).

Returns:
orb the instance of the ORB currently associated with the Servant.

_poa

public final POA _poa()
Allows easy execution of common methods, equivalent to PortableServer::Current:get_POA.

Returns:
poa POA associated with the servant.

_object_id

public final byte[] _object_id()
Allows easy execution of common methods, equivalent to calling PortableServer::Current::get_object_id.

Returns:
object_id the Object ID associated with this servant.

_default_POA

public POA _default_POA()
Returns the root POA from the ORB instance associated with the servant. Subclasses may override this method to return a different POA.

Returns:
default_POA the POA associated with the Servant.

_is_a

public boolean _is_a(String repository_id)
Checks to see if the specified repository_id is present on the list returned by _all_interfaces() or is the repository_id for the generic CORBA Object.

Parameters:
repository_id - the repository_id to be checked in the repository list or against the id of generic CORBA objects.
Returns:
is_a boolean indicating whether the specified repository_id is in the repository list or is same as a generic CORBA object.

_non_existent

public boolean _non_existent()
Checks for the existence of an Object. The Servant provides a default implementation of _non_existent() that can be overridden by derived servants.

Returns:
non_existent true if that object does not exist, false otherwise.

_get_interface_def

public Object _get_interface_def()
Returns an InterfaceDef object as a CORBA::Object that defines the runtime type of the CORBA::Object implemented by the Servant. The invoker of _get_interface_def must narrow the result to an InterfaceDef in order to use it.

This default implementation of _get_interface_def() can be overridden by derived servants if the default behavior is not adequate. As defined in the CORBA 2.3.1 specification, section 11.3.1, the default behavior of _get_interface_def() is to use the most derived interface of a static servant or the most derived interface retrieved from a dynamic servant to obtain the InterfaceDef. This behavior must be supported by the Delegate that implements the Servant.

Returns:
get_interface_def an InterfaceDef object as a CORBA::Object that defines the runtime type of the CORBA::Object implemented by the Servant.

_all_interfaces

public abstract String[] _all_interfaces(POA poa,
                                         byte[] objectId)
Used by the ORB to obtain complete type information from the servant.

Parameters:
poa - POA with which the servant is associated.
objectId - is the id corresponding to the object associated with this servant.
Returns:
list of type information for the object.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


SERVANT_RETENTION_POLICY_ID (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface SERVANT_RETENTION_POLICY_ID

public interface SERVANT_RETENTION_POLICY_ID

org/omg/PortableServer/SERVANT_RETENTION_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
static int | value The value representing SERVANT_RETENTION_POLICY_ID.

Field Detail

value

static final int value
The value representing SERVANT_RETENTION_POLICY_ID.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServantActivator (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface ServantActivator

All Superinterfaces:
IDLEntity, Object, Serializable, ServantActivatorOperations, ServantManager, ServantManagerOperations
All Known Implementing Classes:
_ServantActivatorStub
public interface ServantActivator
extends ServantActivatorOperations, ServantManager, IDLEntity

When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableServer.ServantActivatorOperations
etherealize, incarnate
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServantActivatorHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Class ServantActivatorHelper

java.lang.Object
    extended by  org.omg.PortableServer.ServantActivatorHelper

public abstract class ServantActivatorHelper
extends Object

When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

Constructor Summary
Constructor and Description
ServantActivatorHelper()
Method Summary
Modifier and Type | Method and Description
static ServantActivator | extract(Any a)
static String | id()
static void | insert(Any a, ServantActivator that)
static ServantActivator | narrow(Object obj)
static ServantActivator | read(InputStream istream)
static TypeCode | type()
static ServantActivator | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, ServantActivator value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ServantActivatorHelper

public ServantActivatorHelper()
Method Detail

insert

public static void insert(Any a,
                          ServantActivator that)

extract

public static ServantActivator extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ServantActivator read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ServantActivator value)

narrow

public static ServantActivator narrow(Object obj)

unchecked_narrow

public static ServantActivator unchecked_narrow(Object obj)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServantActivatorOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface ServantActivatorOperations

All Superinterfaces:
ServantManagerOperations
All Known Subinterfaces:
ServantActivator
All Known Implementing Classes:
_ServantActivatorStub, ServantActivatorPOA
public interface ServantActivatorOperations
extends ServantManagerOperations

When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

Method Summary
Modifier and Type | Method and Description
void | etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations) This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
Servant | incarnate(byte[] oid, POA adapter) This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.

Method Detail

incarnate

Servant incarnate(byte[] oid,
                  POA adapter)
                  throws ForwardRequest
This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.

Parameters:
oid - object Id associated with the object on the request was made.
adapter - object reference for the POA in which the object is being activated.
Returns:
Servant corresponding to oid is created or located by the user supplied servant manager.
Throws:
ForwardRequest - to indicate to the ORB that it is responsible for delivering the current request and subsequent requests to the object denoted in the forward_reference member of the exception.

etherealize

void etherealize(byte[] oid,
                 POA adapter,
                 Servant serv,
                 boolean cleanup_in_progress,
                 boolean remaining_activations)
This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.

Parameters:
oid - object Id associated with the object being deactivated.
adapter - object reference for the POA in which the object was active.
serv - contains reference to the servant associated with the object being deactivated.
cleanup_in_progress - if TRUE indicates that destroy or deactivate is called with etherealize_objects param of TRUE. FALSE indicates that etherealize was called due to other reasons.
remaining_activations - indicates whether the Servant Manager can destroy a servant. If set to TRUE, the Servant Manager should wait until all invocations in progress have completed.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServantActivatorPOA (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Class ServantActivatorPOA

java.lang.Object
    extended by  org.omg.PortableServer.Servant
        extended by  org.omg.PortableServer.ServantActivatorPOA
All Implemented Interfaces:
InvokeHandler, ServantActivatorOperations, ServantManagerOperations
public abstract class ServantActivatorPOA
extends Servant
implements ServantActivatorOperations, InvokeHandler

When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

Constructor Summary
Constructor and Description
ServantActivatorPOA()
Method Summary
Modifier and Type | Method and Description
String[] | _all_interfaces(POA poa, byte[] objectId) Used by the ORB to obtain complete type information from the servant.
OutputStream | _invoke(String $method, InputStream in, ResponseHandler $rh) Invoked by the ORB to dispatch a request to the servant.
ServantActivator | _this()
ServantActivator | _this(ORB orb)
Methods inherited from class org.omg.PortableServer.Servant
_default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.omg.PortableServer.ServantActivatorOperations
etherealize, incarnate

Constructor Detail

ServantActivatorPOA

public ServantActivatorPOA()
Method Detail

_invoke

public OutputStream _invoke(String $method,
                            InputStream in,
                            ResponseHandler $rh)
Description copied from interface: InvokeHandler
Invoked by the ORB to dispatch a request to the servant. ORB passes the method name, an InputStream containing the marshalled arguments, and a ResponseHandler which the servant uses to construct a proper reply. Only CORBA SystemException may be thrown by this method. The method must return an OutputStream created by the ResponseHandler which contains the marshalled reply. A servant must not retain a reference to the ResponseHandler beyond the lifetime of a method invocation. Servant behaviour is defined as follows:

1. Determine correct method, and unmarshal parameters from InputStream.

2. Invoke method implementation.

3. If no user exception, create a normal reply using ResponseHandler.

4. If user exception occurred, create exception reply using ResponseHandler.

5. Marshal reply into OutputStream returned by ResponseHandler.

6. Return OutputStream to ORB.

Specified by:
_invoke in interface InvokeHandler
Parameters:
$method - The method name.
in - The InputStream containing the marshalled arguments.
$rh - The ResponseHandler which the servant uses to construct a proper reply
Returns:
The OutputStream created by the ResponseHandler which contains the marshalled reply

_all_interfaces

public String[] _all_interfaces(POA poa,
                                byte[] objectId)
Description copied from class: Servant
Used by the ORB to obtain complete type information from the servant.

Specified by:
_all_interfaces in class Servant
Parameters:
poa - POA with which the servant is associated.
objectId - is the id corresponding to the object associated with this servant.
Returns:
list of type information for the object.

_this

public ServantActivator _this()

_this

public ServantActivator _this(ORB orb)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


_ServantActivatorStub (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.PortableServer
Class _ServantActivatorStub

java.lang.Object
    extended by  org.omg.CORBA.portable.ObjectImpl
        extended by  org.omg.PortableServer._ServantActivatorStub
All Implemented Interfaces:
Serializable, Object, IDLEntity, ServantActivator, ServantActivatorOperations, ServantManager, ServantManagerOperations
public class _ServantActivatorStub
extends ObjectImpl
implements ServantActivator

When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

Field Summary
Modifier and Type | Field and Description
static Class | _opsClass
Constructor Summary
Constructor and Description
_ServantActivatorStub()
Method Summary
Modifier and Type | Method and Description
String[] | _ids() Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
void | etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations) This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
Servant | incarnate(byte[] oid, POA adapter) This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
Methods inherited from class org.omg.CORBA.portable.ObjectImpl
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Field Detail

_opsClass

public static final Class _opsClass
Constructor Detail

_ServantActivatorStub

public _ServantActivatorStub()
Method Detail

incarnate

public Servant incarnate(byte[] oid,
                         POA adapter)
                  throws ForwardRequest
This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.

Specified by:
incarnate in interface ServantActivatorOperations
Parameters:
oid - object Id associated with the object on the request was made.
adapter - object reference for the POA in which the object is being activated.
Returns:
Servant corresponding to oid is created or located by the user supplied servant manager.
Throws:
ForwardRequest - to indicate to the ORB that it is responsible for delivering the current request and subsequent requests to the object denoted in the forward_reference member of the exception.

etherealize

public void etherealize(byte[] oid,
                        POA adapter,
                        Servant serv,
                        boolean cleanup_in_progress,
                        boolean remaining_activations)
This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.

Specified by:
etherealize in interface ServantActivatorOperations
Parameters:
oid - object Id associated with the object being deactivated.
adapter - object reference for the POA in which the object was active.
serv - contains reference to the servant associated with the object being deactivated.
cleanup_in_progress - if TRUE indicates that destroy or deactivate is called with etherealize_objects param of TRUE. FALSE indicates that etherealize was called due to other reasons.
remaining_activations - indicates whether the Servant Manager can destroy a servant. If set to TRUE, the Servant Manager should wait until all invocations in progress have completed.

_ids

public String[] _ids()
Description copied from class: ObjectImpl
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.

Specified by:
_ids in class ObjectImpl
Returns:
the array of all repository identifiers supported by this ObjectImpl instance
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ServantLocator (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface ServantLocator

All Superinterfaces:
IDLEntity, Object, Serializable, ServantLocatorOperations, ServantManager, ServantManagerOperations
All Known Implementing Classes:
_ServantLocatorStub
public interface ServantLocator
extends ServantLocatorOperations, ServantManager, IDLEntity

When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators. Because the POA knows that the servant returned by this servant manager will be used only for a single request, it can supply extra information to the servant manager's operations and the servant manager's pair of operations may be able to cooperate to do something different than a ServantActivator. When the POA uses the ServantLocator interface, immediately after performing the operation invocation on the servant returned by preinvoke, the POA will invoke postinvoke on the servant manager, passing the ObjectId value and the Servant value as parameters (among others). This feature may be used to force every request for objects associated with a POA to be mediated by the servant manager.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableServer.ServantLocatorOperations
postinvoke, preinvoke
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServantLocatorHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Class ServantLocatorHelper

java.lang.Object
    extended by  org.omg.PortableServer.ServantLocatorHelper

public abstract class ServantLocatorHelper
extends Object

When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators. Because the POA knows that the servant returned by this servant manager will be used only for a single request, it can supply extra information to the servant manager's operations and the servant manager's pair of operations may be able to cooperate to do something different than a ServantActivator. When the POA uses the ServantLocator interface, immediately after performing the operation invocation on the servant returned by preinvoke, the POA will invoke postinvoke on the servant manager, passing the ObjectId value and the Servant value as parameters (among others). This feature may be used to force every request for objects associated with a POA to be mediated by the servant manager.

Constructor Summary
Constructor and Description
ServantLocatorHelper()
Method Summary
Modifier and Type | Method and Description
static ServantLocator | extract(Any a)
static String | id()
static void | insert(Any a, ServantLocator that)
static ServantLocator | narrow(Object obj)
static ServantLocator | read(InputStream istream)
static TypeCode | type()
static ServantLocator | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, ServantLocator value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ServantLocatorHelper

public ServantLocatorHelper()
Method Detail

insert

public static void insert(Any a,
                          ServantLocator that)

extract

public static ServantLocator extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ServantLocator read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ServantLocator value)

narrow

public static ServantLocator narrow(Object obj)

unchecked_narrow

public static ServantLocator unchecked_narrow(Object obj)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServantLocatorOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface ServantLocatorOperations

All Superinterfaces:
ServantManagerOperations
All Known Subinterfaces:
ServantLocator
All Known Implementing Classes:
_ServantLocatorStub, ServantLocatorPOA
public interface ServantLocatorOperations
extends ServantManagerOperations

When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators. Because the POA knows that the servant returned by this servant manager will be used only for a single request, it can supply extra information to the servant manager's operations and the servant manager's pair of operations may be able to cooperate to do something different than a ServantActivator. When the POA uses the ServantLocator interface, immediately after performing the operation invocation on the servant returned by preinvoke, the POA will invoke postinvoke on the servant manager, passing the ObjectId value and the Servant value as parameters (among others). This feature may be used to force every request for objects associated with a POA to be mediated by the servant manager.

Method Summary
Modifier and Type | Method and Description
void | postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant) This operation is invoked whenener a servant completes a request.
Servant | preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie) This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.

Method Detail

preinvoke

Servant preinvoke(byte[] oid,
                  POA adapter,
                  String operation,
                  CookieHolder the_cookie)
                  throws ForwardRequest
This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.

Parameters:
oid - the object id associated with object on which the request was made.
adapter - the reference for POA in which the object is being activated.
operation - the operation name.
the_cookie - an opaque value that can be set by the servant manager to be used during postinvoke.
Returns:
Servant used to process incoming request.
Throws:
ForwardRequest - to indicate to the ORB that it is responsible for delivering the current request and subsequent requests to the object denoted in the forward_reference member of the exception.

postinvoke

void postinvoke(byte[] oid,
                POA adapter,
                String operation,
                Object the_cookie,
                Servant the_servant)
This operation is invoked whenener a servant completes a request.

Parameters:
oid - the object id ssociated with object on which the request was made.
adapter - the reference for POA in which the object was active.
the_cookie - an opaque value that contains the data set by preinvoke.
the_servant - reference to the servant that is associated with the object.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServantLocatorPOA (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Class ServantLocatorPOA

java.lang.Object
    extended by  org.omg.PortableServer.Servant
        extended by  org.omg.PortableServer.ServantLocatorPOA
All Implemented Interfaces:
InvokeHandler, ServantLocatorOperations, ServantManagerOperations
public abstract class ServantLocatorPOA
extends Servant
implements ServantLocatorOperations, InvokeHandler

When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators. Because the POA knows that the servant returned by this servant manager will be used only for a single request, it can supply extra information to the servant manager's operations and the servant manager's pair of operations may be able to cooperate to do something different than a ServantActivator. When the POA uses the ServantLocator interface, immediately after performing the operation invocation on the servant returned by preinvoke, the POA will invoke postinvoke on the servant manager, passing the ObjectId value and the Servant value as parameters (among others). This feature may be used to force every request for objects associated with a POA to be mediated by the servant manager.

Constructor Summary
Constructor and Description
ServantLocatorPOA()
Method Summary
Modifier and Type | Method and Description
String[] | _all_interfaces(POA poa, byte[] objectId) Used by the ORB to obtain complete type information from the servant.
OutputStream | _invoke(String $method, InputStream in, ResponseHandler $rh) Invoked by the ORB to dispatch a request to the servant.
ServantLocator | _this()
ServantLocator | _this(ORB orb)
Methods inherited from class org.omg.PortableServer.Servant
_default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.omg.PortableServer.ServantLocatorOperations
postinvoke, preinvoke

Constructor Detail

ServantLocatorPOA

public ServantLocatorPOA()
Method Detail

_invoke

public OutputStream _invoke(String $method,
                            InputStream in,
                            ResponseHandler $rh)
Description copied from interface: InvokeHandler
Invoked by the ORB to dispatch a request to the servant. ORB passes the method name, an InputStream containing the marshalled arguments, and a ResponseHandler which the servant uses to construct a proper reply. Only CORBA SystemException may be thrown by this method. The method must return an OutputStream created by the ResponseHandler which contains the marshalled reply. A servant must not retain a reference to the ResponseHandler beyond the lifetime of a method invocation. Servant behaviour is defined as follows:

1. Determine correct method, and unmarshal parameters from InputStream.

2. Invoke method implementation.

3. If no user exception, create a normal reply using ResponseHandler.

4. If user exception occurred, create exception reply using ResponseHandler.

5. Marshal reply into OutputStream returned by ResponseHandler.

6. Return OutputStream to ORB.

Specified by:
_invoke in interface InvokeHandler
Parameters:
$method - The method name.
in - The InputStream containing the marshalled arguments.
$rh - The ResponseHandler which the servant uses to construct a proper reply
Returns:
The OutputStream created by the ResponseHandler which contains the marshalled reply

_all_interfaces

public String[] _all_interfaces(POA poa,
                                byte[] objectId)
Description copied from class: Servant
Used by the ORB to obtain complete type information from the servant.

Specified by:
_all_interfaces in class Servant
Parameters:
poa - POA with which the servant is associated.
objectId - is the id corresponding to the object associated with this servant.
Returns:
list of type information for the object.

_this

public ServantLocator _this()

_this

public ServantLocator _this(ORB orb)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


_ServantLocatorStub (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Class _ServantLocatorStub

java.lang.Object
    extended by  org.omg.CORBA.portable.ObjectImpl
        extended by  org.omg.PortableServer._ServantLocatorStub
All Implemented Interfaces:
Serializable, Object, IDLEntity, ServantLocator, ServantLocatorOperations, ServantManager, ServantManagerOperations
public class _ServantLocatorStub
extends ObjectImpl
implements ServantLocator

When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators. Because the POA knows that the servant returned by this servant manager will be used only for a single request, it can supply extra information to the servant manager's operations and the servant manager's pair of operations may be able to cooperate to do something different than a ServantActivator. When the POA uses the ServantLocator interface, immediately after performing the operation invocation on the servant returned by preinvoke, the POA will invoke postinvoke on the servant manager, passing the ObjectId value and the Servant value as parameters (among others). This feature may be used to force every request for objects associated with a POA to be mediated by the servant manager.

Field Summary
Modifier and Type | Field and Description
static Class | _opsClass
Constructor Summary
Constructor and Description
_ServantLocatorStub()
Method Summary
Modifier and Type | Method and Description
String[] | _ids() Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
void | postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant) This operation is invoked whenener a servant completes a request.
Servant | preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie) This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
Methods inherited from class org.omg.CORBA.portable.ObjectImpl
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Field Detail

_opsClass

public static final Class _opsClass
Constructor Detail

_ServantLocatorStub

public _ServantLocatorStub()
Method Detail

preinvoke

public Servant preinvoke(byte[] oid,
                         POA adapter,
                         String operation,
                         CookieHolder the_cookie)
                  throws ForwardRequest
This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.

Specified by:
preinvoke in interface ServantLocatorOperations
Parameters:
oid - the object id associated with object on which the request was made.
adapter - the reference for POA in which the object is being activated.
operation - the operation name.
the_cookie - an opaque value that can be set by the servant manager to be used during postinvoke.
Returns:
Servant used to process incoming request.
Throws:
ForwardRequest - to indicate to the ORB that it is responsible for delivering the current request and subsequent requests to the object denoted in the forward_reference member of the exception.

postinvoke

public void postinvoke(byte[] oid,
                       POA adapter,
                       String operation,
                       Object the_cookie,
                       Servant the_servant)
This operation is invoked whenener a servant completes a request.

Specified by:
postinvoke in interface ServantLocatorOperations
Parameters:
oid - the object id ssociated with object on which the request was made.
adapter - the reference for POA in which the object was active.
the_cookie - an opaque value that contains the data set by preinvoke.
the_servant - reference to the servant that is associated with the object.

_ids

public String[] _ids()
Description copied from class: ObjectImpl
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.

Specified by:
_ids in class ObjectImpl
Returns:
the array of all repository identifiers supported by this ObjectImpl instance
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServantManager (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface ServantManager

All Superinterfaces:
IDLEntity, Object, Serializable, ServantManagerOperations
All Known Subinterfaces:
ServantActivator, ServantLocator
All Known Implementing Classes:
_ServantActivatorStub, _ServantLocatorStub
public interface ServantManager
extends ServantManagerOperations, Object, IDLEntity

A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object. A servant manager is registered with a POA as a callback object, to be invoked by the POA when necessary. ServantManagers can either be ServantActivators or ServantLocators. A ServantManager object must be local to the process containing the POA objects it is registered with.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServantManagerOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface ServantManagerOperations

All Known Subinterfaces:
ServantActivator, ServantActivatorOperations, ServantLocator, ServantLocatorOperations, ServantManager
All Known Implementing Classes:
_ServantActivatorStub, _ServantLocatorStub, ServantActivatorPOA, ServantLocatorPOA
public interface ServantManagerOperations

A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object. A servant manager is registered with a POA as a callback object, to be invoked by the POA when necessary. ServantManagers can either be ServantActivators or ServantLocators. A ServantManager object must be local to the process containing the POA objects it is registered with.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServantRetentionPolicy (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface ServantRetentionPolicy

All Superinterfaces:
IDLEntity, Object, Policy, PolicyOperations, Serializable, ServantRetentionPolicyOperations
public interface ServantRetentionPolicy
extends ServantRetentionPolicyOperations, Policy, IDLEntity

This policy specifies whether the created POA retains active servants in an Active Object Map.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableServer.ServantRetentionPolicyOperations
value
Methods inherited from interface org.omg.CORBA.PolicyOperations
copy, destroy, policy_type
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServantRetentionPolicyOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface ServantRetentionPolicyOperations

All Superinterfaces:
PolicyOperations
All Known Subinterfaces:
ServantRetentionPolicy
public interface ServantRetentionPolicyOperations
extends PolicyOperations

This policy specifies whether the created POA retains active servants in an Active Object Map.

Method Summary
Modifier and Type | Method and Description
ServantRetentionPolicyValue | value() specifies the policy value
Methods inherited from interface org.omg.CORBA.PolicyOperations
copy, destroy, policy_type

Method Detail

value

ServantRetentionPolicyValue value()
specifies the policy value

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServantRetentionPolicyValue (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Class ServantRetentionPolicyValue

java.lang.Object
    extended by  org.omg.PortableServer.ServantRetentionPolicyValue
All Implemented Interfaces:
Serializable, IDLEntity
public class ServantRetentionPolicyValue
extends Object
implements IDLEntity

ServantRetentionPolicyValue can have the following values. RETAIN - to indicate that the POA will retain active servants in its Active Object Map. NON_RETAIN - to indicate Servants are not retained by the POA. If no ServantRetentionPolicy is specified at POA creation, the default is RETAIN.

Field Summary
Modifier and Type | Field and Description
static int | _NON_RETAIN
static int | _RETAIN
static ServantRetentionPolicyValue | NON_RETAIN
static ServantRetentionPolicyValue | RETAIN
Constructor Summary
Modifier | Constructor and Description
protected | ServantRetentionPolicyValue(int value)
Method Summary
Modifier and Type | Method and Description
static ServantRetentionPolicyValue | from_int(int value)
int | value()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_RETAIN

public static final int _RETAIN
See Also:
Constant Field Values

RETAIN

public static final ServantRetentionPolicyValue RETAIN

_NON_RETAIN

public static final int _NON_RETAIN
See Also:
Constant Field Values

NON_RETAIN

public static final ServantRetentionPolicyValue NON_RETAIN
Constructor Detail

ServantRetentionPolicyValue

protected ServantRetentionPolicyValue(int value)
Method Detail

value

public int value()

from_int

public static ServantRetentionPolicyValue from_int(int value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


THREAD_POLICY_ID (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface THREAD_POLICY_ID

public interface THREAD_POLICY_ID

org/omg/PortableServer/THREAD_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
static int | value The value representing THREAD_POLICY_ID.

Field Detail

value

static final int value
The value representing THREAD_POLICY_ID.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ThreadPolicy (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface ThreadPolicy

All Superinterfaces:
IDLEntity, Object, Policy, PolicyOperations, Serializable, ThreadPolicyOperations
public interface ThreadPolicy
extends ThreadPolicyOperations, Policy, IDLEntity

The ThreadPolicy specifies the threading model used with the created POA. The default is ORB_CTRL_MODEL.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.PortableServer.ThreadPolicyOperations
value
Methods inherited from interface org.omg.CORBA.PolicyOperations
copy, destroy, policy_type
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ThreadPolicyOperations (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer
Interface ThreadPolicyOperations

All Superinterfaces:
PolicyOperations
All Known Subinterfaces:
ThreadPolicy
public interface ThreadPolicyOperations
extends PolicyOperations

The ThreadPolicy specifies the threading model used with the created POA. The default is ORB_CTRL_MODEL.

Method Summary
Modifier and Type | Method and Description
ThreadPolicyValue | value() specifies the policy value
Methods inherited from interface org.omg.CORBA.PolicyOperations
copy, destroy, policy_type

Method Detail

value

ThreadPolicyValue value()
specifies the policy value

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ThreadPolicyValue (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.PortableServer
Class ThreadPolicyValue

java.lang.Object
    extended by  org.omg.PortableServer.ThreadPolicyValue
All Implemented Interfaces:
Serializable, IDLEntity
public class ThreadPolicyValue
extends Object
implements IDLEntity

The ThreadPolicyValue can have the following values. ORB_CTRL_MODEL - The ORB is responsible for assigning requests for an ORB- controlled POA to threads. SINGLE_THREAD_MODEL - Requests for a single-threaded POA are processed sequentially.

Field Summary
Modifier and Type | Field and Description
static int | _ORB_CTRL_MODEL
static int | _SINGLE_THREAD_MODEL
static ThreadPolicyValue | ORB_CTRL_MODEL
static ThreadPolicyValue | SINGLE_THREAD_MODEL
Constructor Summary
Modifier | Constructor and Description
protected | ThreadPolicyValue(int value)
Method Summary
Modifier and Type | Method and Description
static ThreadPolicyValue | from_int(int value)
int | value()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_ORB_CTRL_MODEL

public static final int _ORB_CTRL_MODEL
See Also:
Constant Field Values

ORB_CTRL_MODEL

public static final ThreadPolicyValue ORB_CTRL_MODEL

_SINGLE_THREAD_MODEL

public static final int _SINGLE_THREAD_MODEL
See Also:
Constant Field Values

SINGLE_THREAD_MODEL

public static final ThreadPolicyValue SINGLE_THREAD_MODEL
Constructor Detail

ThreadPolicyValue

protected ThreadPolicyValue(int value)
Method Detail

value

public int value()

from_int

public static ThreadPolicyValue from_int(int value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


NoContext (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.PortableServer.CurrentPackage
Class NoContext

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.PortableServer.CurrentPackage.NoContext
All Implemented Interfaces:
Serializable, IDLEntity
public final class NoContext
extends UserException

org/omg/PortableServer/CurrentPackage/NoContext.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
NoContext()
NoContext(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NoContext

public NoContext()

NoContext

public NoContext(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


NoContextHelper (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.PortableServer.CurrentPackage
Class NoContextHelper

java.lang.Object
    extended by  org.omg.PortableServer.CurrentPackage.NoContextHelper

public abstract class NoContextHelper
extends Object

org/omg/PortableServer/CurrentPackage/NoContextHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
NoContextHelper()
Method Summary
Modifier and Type | Method and Description
static NoContext | extract(Any a)
static String | id()
static void | insert(Any a, NoContext that)
static NoContext | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, NoContext value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NoContextHelper

public NoContextHelper()
Method Detail

insert

public static void insert(Any a,
                          NoContext that)

extract

public static NoContext extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NoContext read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NoContext value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.omg.PortableServer.CurrentPackage (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.PortableServer.CurrentPackage

Provides method implementations with access to the identity of the object on which the method was invoked.

See:
Description

Class Summary
Class | Description
NoContextHelper | org/omg/PortableServer/CurrentPackage/NoContextHelper.java .

Exception Summary
Exception | Description
NoContext | org/omg/PortableServer/CurrentPackage/NoContext.java .

Package org.omg.PortableServer.CurrentPackage Description

Provides method implementations with access to the identity of the object on which the method was invoked. The Current package supports servants that implement multiple objects, but can be used within the context of POA-dispatched method invocations on any servant. To provide location transparency, ORBs are required to support use of Current in the context of both locally and remotely invoked operations. An instance of Current can be obtained by the application by issuing the CORBA::ORB::resolve_initial_references("POACurrent") operation. Thereafter, it can be used within the context of a method dispatched by the POA to obtain the POA and ObjectId that identify the object on which that operation was invoked.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


AdapterInactive (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.PortableServer.POAManagerPackage
Class AdapterInactive

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.PortableServer.POAManagerPackage.AdapterInactive
All Implemented Interfaces:
Serializable, IDLEntity
public final class AdapterInactive
extends UserException

org/omg/PortableServer/POAManagerPackage/AdapterInactive.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
AdapterInactive()
AdapterInactive(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

AdapterInactive

public AdapterInactive()

AdapterInactive

public AdapterInactive(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AdapterInactiveHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer.POAManagerPackage
Class AdapterInactiveHelper

java.lang.Object
    extended by  org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper

public abstract class AdapterInactiveHelper
extends Object

org/omg/PortableServer/POAManagerPackage/AdapterInactiveHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
AdapterInactiveHelper()
Method Summary
Modifier and Type | Method and Description
static AdapterInactive | extract(Any a)
static String | id()
static void | insert(Any a, AdapterInactive that)
static AdapterInactive | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, AdapterInactive value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AdapterInactiveHelper

public AdapterInactiveHelper()
Method Detail

insert

public static void insert(Any a,
                          AdapterInactive that)

extract

public static AdapterInactive extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static AdapterInactive read(InputStream istream)

write

public static void write(OutputStream ostream,
                         AdapterInactive value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


org.omg.PortableServer.POAManagerPackage (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.PortableServer.POAManagerPackage

Encapsulates the processing state of the POAs it is associated with.

See:
Description

Class Summary
Class | Description
AdapterInactiveHelper | org/omg/PortableServer/POAManagerPackage/AdapterInactiveHelper.java .
State | Specifies the states for the POAManager

Exception Summary
Exception | Description
AdapterInactive | org/omg/PortableServer/POAManagerPackage/AdapterInactive.java .

Package org.omg.PortableServer.POAManagerPackage Description

Encapsulates the processing state of the POAs it is associated with. Each POA object has an associated POAManager object. A POA manager may be associated with one or more POA objects.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


State (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.PortableServer.POAManagerPackage
Class State

java.lang.Object
    extended by  org.omg.PortableServer.POAManagerPackage.State
All Implemented Interfaces:
Serializable, IDLEntity
public class State
extends Object
implements IDLEntity

Specifies the states for the POAManager

Field Summary
Modifier and Type | Field and Description
static int | _ACTIVE
static int | _DISCARDING
static int | _HOLDING
static int | _INACTIVE
static State | ACTIVE
static State | DISCARDING
static State | HOLDING
static State | INACTIVE
Constructor Summary
Modifier | Constructor and Description
protected | State(int value)
Method Summary
Modifier and Type | Method and Description
static State | from_int(int value)
int | value()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_HOLDING

public static final int _HOLDING
See Also:
Constant Field Values

HOLDING

public static final State HOLDING

_ACTIVE

public static final int _ACTIVE
See Also:
Constant Field Values

ACTIVE

public static final State ACTIVE

_DISCARDING

public static final int _DISCARDING
See Also:
Constant Field Values

DISCARDING

public static final State DISCARDING

_INACTIVE

public static final int _INACTIVE
See Also:
Constant Field Values

INACTIVE

public static final State INACTIVE
Constructor Detail

State

protected State(int value)
Method Detail

value

public int value()

from_int

public static State from_int(int value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AdapterAlreadyExists (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.PortableServer.POAPackage
Class AdapterAlreadyExists

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.PortableServer.POAPackage.AdapterAlreadyExists
All Implemented Interfaces:
Serializable, IDLEntity
public final class AdapterAlreadyExists
extends UserException

org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
AdapterAlreadyExists()
AdapterAlreadyExists(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

AdapterAlreadyExists

public AdapterAlreadyExists()

AdapterAlreadyExists

public AdapterAlreadyExists(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AdapterAlreadyExistsHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer.POAPackage
Class AdapterAlreadyExistsHelper

java.lang.Object
    extended by  org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper

public abstract class AdapterAlreadyExistsHelper
extends Object

org/omg/PortableServer/POAPackage/AdapterAlreadyExistsHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
AdapterAlreadyExistsHelper()
Method Summary
Modifier and Type | Method and Description
static AdapterAlreadyExists | extract(Any a)
static String | id()
static void | insert(Any a, AdapterAlreadyExists that)
static AdapterAlreadyExists | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, AdapterAlreadyExists value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AdapterAlreadyExistsHelper

public AdapterAlreadyExistsHelper()
Method Detail

insert

public static void insert(Any a,
                          AdapterAlreadyExists that)

extract

public static AdapterAlreadyExists extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static AdapterAlreadyExists read(InputStream istream)

write

public static void write(OutputStream ostream,
                         AdapterAlreadyExists value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


AdapterNonExistent (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer.POAPackage
Class AdapterNonExistent

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.PortableServer.POAPackage.AdapterNonExistent
All Implemented Interfaces:
Serializable, IDLEntity
public final class AdapterNonExistent
extends UserException

org/omg/PortableServer/POAPackage/AdapterNonExistent.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
AdapterNonExistent()
AdapterNonExistent(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

AdapterNonExistent

public AdapterNonExistent()

AdapterNonExistent

public AdapterNonExistent(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


AdapterNonExistentHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer.POAPackage
Class AdapterNonExistentHelper

java.lang.Object
    extended by  org.omg.PortableServer.POAPackage.AdapterNonExistentHelper

public abstract class AdapterNonExistentHelper
extends Object

org/omg/PortableServer/POAPackage/AdapterNonExistentHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
AdapterNonExistentHelper()
Method Summary
Modifier and Type | Method and Description
static AdapterNonExistent | extract(Any a)
static String | id()
static void | insert(Any a, AdapterNonExistent that)
static AdapterNonExistent | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, AdapterNonExistent value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AdapterNonExistentHelper

public AdapterNonExistentHelper()
Method Detail

insert

public static void insert(Any a,
                          AdapterNonExistent that)

extract

public static AdapterNonExistent extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static AdapterNonExistent read(InputStream istream)

write

public static void write(OutputStream ostream,
                         AdapterNonExistent value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


InvalidPolicy (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer.POAPackage
Class InvalidPolicy

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.PortableServer.POAPackage.InvalidPolicy
All Implemented Interfaces:
Serializable, IDLEntity
public final class InvalidPolicy
extends UserException

org/omg/PortableServer/POAPackage/InvalidPolicy.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Field Summary
Modifier and Type | Field and Description
short | index
Constructor Summary
Constructor and Description
InvalidPolicy()
InvalidPolicy(short _index)
InvalidPolicy(String $reason, short _index)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

index

public short index
Constructor Detail

InvalidPolicy

public InvalidPolicy()

InvalidPolicy

public InvalidPolicy(short _index)

InvalidPolicy

public InvalidPolicy(String $reason,
                     short _index)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


InvalidPolicyHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer.POAPackage
Class InvalidPolicyHelper

java.lang.Object
    extended by  org.omg.PortableServer.POAPackage.InvalidPolicyHelper

public abstract class InvalidPolicyHelper
extends Object

org/omg/PortableServer/POAPackage/InvalidPolicyHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
InvalidPolicyHelper()
Method Summary
Modifier and Type | Method and Description
static InvalidPolicy | extract(Any a)
static String | id()
static void | insert(Any a, InvalidPolicy that)
static InvalidPolicy | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, InvalidPolicy value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InvalidPolicyHelper

public InvalidPolicyHelper()
Method Detail

insert

public static void insert(Any a,
                          InvalidPolicy that)

extract

public static InvalidPolicy extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static InvalidPolicy read(InputStream istream)

write

public static void write(OutputStream ostream,
                         InvalidPolicy value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NoServant (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer.POAPackage
Class NoServant

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.PortableServer.POAPackage.NoServant
All Implemented Interfaces:
Serializable, IDLEntity
public final class NoServant
extends UserException

org/omg/PortableServer/POAPackage/NoServant.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
NoServant()
NoServant(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NoServant

public NoServant()

NoServant

public NoServant(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NoServantHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer.POAPackage
Class NoServantHelper

java.lang.Object
    extended by  org.omg.PortableServer.POAPackage.NoServantHelper

public abstract class NoServantHelper
extends Object

org/omg/PortableServer/POAPackage/NoServantHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
NoServantHelper()
Method Summary
Modifier and Type | Method and Description
static NoServant | extract(Any a)
static String | id()
static void | insert(Any a, NoServant that)
static NoServant | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, NoServant value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NoServantHelper

public NoServantHelper()
Method Detail

insert

public static void insert(Any a,
                          NoServant that)

extract

public static NoServant extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NoServant read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NoServant value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ObjectAlreadyActive (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer.POAPackage
Class ObjectAlreadyActive

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.PortableServer.POAPackage.ObjectAlreadyActive
All Implemented Interfaces:
Serializable, IDLEntity
public final class ObjectAlreadyActive
extends UserException

org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
ObjectAlreadyActive()
ObjectAlreadyActive(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ObjectAlreadyActive

public ObjectAlreadyActive()

ObjectAlreadyActive

public ObjectAlreadyActive(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ObjectAlreadyActiveHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer.POAPackage
Class ObjectAlreadyActiveHelper

java.lang.Object
    extended by  org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper

public abstract class ObjectAlreadyActiveHelper
extends Object

org/omg/PortableServer/POAPackage/ObjectAlreadyActiveHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
ObjectAlreadyActiveHelper()
Method Summary
Modifier and Type | Method and Description
static ObjectAlreadyActive | extract(Any a)
static String | id()
static void | insert(Any a, ObjectAlreadyActive that)
static ObjectAlreadyActive | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ObjectAlreadyActive value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ObjectAlreadyActiveHelper

public ObjectAlreadyActiveHelper()
Method Detail

insert

public static void insert(Any a,
                          ObjectAlreadyActive that)

extract

public static ObjectAlreadyActive extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ObjectAlreadyActive read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ObjectAlreadyActive value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ObjectNotActive (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer.POAPackage
Class ObjectNotActive

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.PortableServer.POAPackage.ObjectNotActive
All Implemented Interfaces:
Serializable, IDLEntity
public final class ObjectNotActive
extends UserException

org/omg/PortableServer/POAPackage/ObjectNotActive.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
ObjectNotActive()
ObjectNotActive(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ObjectNotActive

public ObjectNotActive()

ObjectNotActive

public ObjectNotActive(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ObjectNotActiveHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer.POAPackage
Class ObjectNotActiveHelper

java.lang.Object
    extended by  org.omg.PortableServer.POAPackage.ObjectNotActiveHelper

public abstract class ObjectNotActiveHelper
extends Object

org/omg/PortableServer/POAPackage/ObjectNotActiveHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
ObjectNotActiveHelper()
Method Summary
Modifier and Type | Method and Description
static ObjectNotActive | extract(Any a)
static String | id()
static void | insert(Any a, ObjectNotActive that)
static ObjectNotActive | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ObjectNotActive value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ObjectNotActiveHelper

public ObjectNotActiveHelper()
Method Detail

insert

public static void insert(Any a,
                          ObjectNotActive that)

extract

public static ObjectNotActive extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ObjectNotActive read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ObjectNotActive value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


org.omg.PortableServer.POAPackage (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.PortableServer.POAPackage

Allows programmers to construct object implementations that are portable between different ORB products.

See:
Description

Class Summary
Class | Description
AdapterAlreadyExistsHelper | org/omg/PortableServer/POAPackage/AdapterAlreadyExistsHelper.java .
AdapterNonExistentHelper | org/omg/PortableServer/POAPackage/AdapterNonExistentHelper.java .
InvalidPolicyHelper | org/omg/PortableServer/POAPackage/InvalidPolicyHelper.java .
NoServantHelper | org/omg/PortableServer/POAPackage/NoServantHelper.java .
ObjectAlreadyActiveHelper | org/omg/PortableServer/POAPackage/ObjectAlreadyActiveHelper.java .
ObjectNotActiveHelper | org/omg/PortableServer/POAPackage/ObjectNotActiveHelper.java .
ServantAlreadyActiveHelper | org/omg/PortableServer/POAPackage/ServantAlreadyActiveHelper.java .
ServantNotActiveHelper | org/omg/PortableServer/POAPackage/ServantNotActiveHelper.java .
WrongAdapterHelper | org/omg/PortableServer/POAPackage/WrongAdapterHelper.java .
WrongPolicyHelper | org/omg/PortableServer/POAPackage/WrongPolicyHelper.java .

Exception Summary
Exception | Description
AdapterAlreadyExists | org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java .
AdapterNonExistent | org/omg/PortableServer/POAPackage/AdapterNonExistent.java .
InvalidPolicy | org/omg/PortableServer/POAPackage/InvalidPolicy.java .
NoServant | org/omg/PortableServer/POAPackage/NoServant.java .
ObjectAlreadyActive | org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java .
ObjectNotActive | org/omg/PortableServer/POAPackage/ObjectNotActive.java .
ServantAlreadyActive | org/omg/PortableServer/POAPackage/ServantAlreadyActive.java .
ServantNotActive | org/omg/PortableServer/POAPackage/ServantNotActive.java .
WrongAdapter | org/omg/PortableServer/POAPackage/WrongAdapter.java .
WrongPolicy | org/omg/PortableServer/POAPackage/WrongPolicy.java .

Package org.omg.PortableServer.POAPackage Description

Allows programmers to construct object implementations that are portable between different ORB products.

The Portable Object Adaptor (POA) is designed to meet the following goals:

  • Allow programmers to construct object implementations that are portable between different ORB products.
  • Provide support for objects with persistent identities.
  • Provide support for transparent activation of objects.
  • Allow a single servant to support multiple object identities simultaneously.

Given an interface My defined in My.idl, the file MyPOA.java is generated by the idlj compiler. You must provide the implementation for My and it must inherit from MyPOA.

MyPOA.java is a stream-based skeleton that extends org.omg.PortableServer.Servant and implements the InvokeHandler interface and the operations interface associated with the IDL interface the skeleton implements.

The PortableServer module for the Portable Object Adapter (POA) defines the native Servant type. In the Java programming language, the Servant type is mapped to the Java org.omg.PortableServer.Servant class. It serves as the base class for all POA servant implementations and provides a number of methods that may be invoked by the application programmer, as well as methods which are invoked by the POA itself and may be overridden by the user to control aspects of servant behavior.

All Mapping corresponds to the Chapter 11 of CORBA V2.3.1 specified by OMG document formal/99-10-07.pdf. The exception to this is the id attribute, which is added in ptc/00-08-06, section 11.3.8.26.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6, ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


ServantAlreadyActive (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer.POAPackage
Class ServantAlreadyActive

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.PortableServer.POAPackage.ServantAlreadyActive
All Implemented Interfaces:
Serializable, IDLEntity
public final class ServantAlreadyActive
extends UserException

org/omg/PortableServer/POAPackage/ServantAlreadyActive.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
ServantAlreadyActive()
ServantAlreadyActive(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ServantAlreadyActive

public ServantAlreadyActive()

ServantAlreadyActive

public ServantAlreadyActive(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServantAlreadyActiveHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer.POAPackage
Class ServantAlreadyActiveHelper

java.lang.Object
    extended by  org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper

public abstract class ServantAlreadyActiveHelper
extends Object

org/omg/PortableServer/POAPackage/ServantAlreadyActiveHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
ServantAlreadyActiveHelper()
Method Summary
Modifier and Type | Method and Description
static ServantAlreadyActive | extract(Any a)
static String | id()
static void | insert(Any a, ServantAlreadyActive that)
static ServantAlreadyActive | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ServantAlreadyActive value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ServantAlreadyActiveHelper

public ServantAlreadyActiveHelper()
Method Detail

insert

public static void insert(Any a,
                          ServantAlreadyActive that)

extract

public static ServantAlreadyActive extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ServantAlreadyActive read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ServantAlreadyActive value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServantNotActive (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer.POAPackage
Class ServantNotActive

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.PortableServer.POAPackage.ServantNotActive
All Implemented Interfaces:
Serializable, IDLEntity
public final class ServantNotActive
extends UserException

org/omg/PortableServer/POAPackage/ServantNotActive.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
ServantNotActive()
ServantNotActive(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ServantNotActive

public ServantNotActive()

ServantNotActive

public ServantNotActive(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ServantNotActiveHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer.POAPackage
Class ServantNotActiveHelper

java.lang.Object
    extended by  org.omg.PortableServer.POAPackage.ServantNotActiveHelper

public abstract class ServantNotActiveHelper
extends Object

org/omg/PortableServer/POAPackage/ServantNotActiveHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
ServantNotActiveHelper()
Method Summary
Modifier and Type | Method and Description
static ServantNotActive | extract(Any a)
static String | id()
static void | insert(Any a, ServantNotActive that)
static ServantNotActive | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ServantNotActive value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ServantNotActiveHelper

public ServantNotActiveHelper()
Method Detail

insert

public static void insert(Any a,
                          ServantNotActive that)

extract

public static ServantNotActive extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ServantNotActive read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ServantNotActive value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


WrongAdapter (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer.POAPackage
Class WrongAdapter

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.PortableServer.POAPackage.WrongAdapter
All Implemented Interfaces:
Serializable, IDLEntity
public final class WrongAdapter
extends UserException

org/omg/PortableServer/POAPackage/WrongAdapter.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
WrongAdapter()
WrongAdapter(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

WrongAdapter

public WrongAdapter()

WrongAdapter

public WrongAdapter(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


WrongAdapterHelper (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer.POAPackage
Class WrongAdapterHelper

java.lang.Object
    extended by  org.omg.PortableServer.POAPackage.WrongAdapterHelper

public abstract class WrongAdapterHelper
extends Object

org/omg/PortableServer/POAPackage/WrongAdapterHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
WrongAdapterHelper()
Method Summary
Modifier and Type | Method and Description
static WrongAdapter | extract(Any a)
static String | id()
static void | insert(Any a, WrongAdapter that)
static WrongAdapter | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, WrongAdapter value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WrongAdapterHelper

public WrongAdapterHelper()
Method Detail

insert

public static void insert(Any a,
                          WrongAdapter that)

extract

public static WrongAdapter extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static WrongAdapter read(InputStream istream)

write

public static void write(OutputStream ostream,
                         WrongAdapter value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


WrongPolicy (Java Platform SE 7 b59)

DRAFT ea-b59

org.omg.PortableServer.POAPackage
Class WrongPolicy

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.omg.CORBA.UserException
                extended by  org.omg.PortableServer.POAPackage.WrongPolicy
All Implemented Interfaces:
Serializable, IDLEntity
public final class WrongPolicy
extends UserException

org/omg/PortableServer/POAPackage/WrongPolicy.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
WrongPolicy()
WrongPolicy(String $reason)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

WrongPolicy

public WrongPolicy()

WrongPolicy

public WrongPolicy(String $reason)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


WrongPolicyHelper (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.PortableServer.POAPackage
Class WrongPolicyHelper

java.lang.Object
    extended by  org.omg.PortableServer.POAPackage.WrongPolicyHelper

public abstract class WrongPolicyHelper
extends Object

org/omg/PortableServer/POAPackage/WrongPolicyHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, May 14, 2009 3:15:22 AM PDT

Constructor Summary
Constructor and Description
WrongPolicyHelper()
Method Summary
Modifier and Type | Method and Description
static WrongPolicy | extract(Any a)
static String | id()
static void | insert(Any a, WrongPolicy that)
static WrongPolicy | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, WrongPolicy value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WrongPolicyHelper

public WrongPolicyHelper()
Method Detail

insert

public static void insert(Any a,
                          WrongPolicy that)

extract

public static WrongPolicy extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static WrongPolicy read(InputStream istream)

write

public static void write(OutputStream ostream,
                         WrongPolicy value)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Delegate (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.PortableServer.portable
Interface Delegate

public interface Delegate

The portability package contains interfaces and classes that are designed for and intended to be used by ORB implementor. It exposes the publicly defined APIs that are used to connect stubs and skeletons to the ORB. The Delegate interface provides the ORB vendor specific implementation of PortableServer::Servant. Conformant to spec CORBA V2.3.1, ptc/00-01-08.pdf

Method Summary
Modifier and Type Method and Description
 POA default_POA(Servant Self)
The default behavior of this function is to return the root POA from the ORB instance associated with the servant.
 Object get_interface_def(Servant self)
This operation returns an object in the Interface Repository which provides type information that may be useful to a program.
 boolean is_a(Servant Self, String Repository_Id)
This method checks to see if the specified repid is present on the list returned by _all_interfaces() or is the repository id for the generic CORBA Object.
 boolean non_existent(Servant Self)
This operation is used to check for the existence of the Object.
 byte[] object_id(Servant Self)
The method _object_id() is equivalent to calling PortableServer::Current::get_object_id.
 ORB orb(Servant Self)
Convenience method that returns the instance of the ORB currently associated with the Servant.
 POA poa(Servant Self)
The method _poa() is equivalent to calling PortableServer::Current:get_POA.
 Object this_object(Servant Self)
This allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.

Method Detail

orb

ORB orb(Servant Self)
Convenience method that returns the instance of the ORB currently associated with the Servant.

Parameters:
Self - the servant.
Returns:
ORB associated with the Servant.

this_object

Object this_object(Servant Self)
This allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.

Parameters:
Self - the servant.
Returns:
Object reference associated with the request.

poa

POA poa(Servant Self)
The method _poa() is equivalent to calling PortableServer::Current:get_POA.

Parameters:
Self - the servant.
Returns:
POA associated with the servant.

object_id

byte[] object_id(Servant Self)
The method _object_id() is equivalent to calling PortableServer::Current::get_object_id.

Parameters:
Self - the servant.
Returns:
ObjectId associated with this servant.

default_POA

POA default_POA(Servant Self)
The default behavior of this function is to return the root POA from the ORB instance associated with the servant.

Parameters:
Self - the servant.
Returns:
POA associated with the servant class.

is_a

boolean is_a(Servant Self,
             String Repository_Id)
This method checks to see if the specified repid is present on the list returned by _all_interfaces() or is the repository id for the generic CORBA Object.

Parameters:
Self - the servant.
Repository_Id - the repository_id to be checked in the repository list or against the id of generic CORBA object.
Returns:
boolean indicating whether the specified repid is in the list or is same as that got generic CORBA object.

non_existent

boolean non_existent(Servant Self)
This operation is used to check for the existence of the Object.

Parameters:
Self - the servant.
Returns:
boolean true to indicate that object does not exist, and false otherwise.

get_interface_def

Object get_interface_def(Servant self)
This operation returns an object in the Interface Repository which provides type information that may be useful to a program.

Parameters:
self - the servant.
Returns:
type information corresponding to the object.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.omg.PortableServer.portable (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.PortableServer.portable

Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

See:
Description

Interface Summary
Interface | Description
Delegate | The portability package contains interfaces and classes that are designed for and intended to be used by ORB implementor.

Package org.omg.PortableServer.portable Description

Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

The portable package contains interfaces and classes that are designed for and intended to be used by an ORB implementor. It exposes the publicly defined APIs that are used to connect stubs and skeletons to the ORB. The Delegate interface provides the ORB-vendor-specific implementation of PortableServer::Servant. This package conforms CORBA Specification V2.3.1, ptc/00-01-08.

Since:
1.4
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


CookieHolder (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.PortableServer.ServantLocatorPackage
Class CookieHolder

java.lang.Object
    extended by  org.omg.PortableServer.ServantLocatorPackage.CookieHolder
All Implemented Interfaces:
Streamable
public final class CookieHolder
extends Object
implements Streamable

The native type PortableServer::ServantLocator::Cookie is mapped to java.lang.Object. A CookieHolder class is provided for passing the Cookie type as an out parameter. The CookieHolder class follows exactly the same pattern as the other holder classes for basic types.

Field Summary
Modifier and Type | Field and Description
Object | value
Constructor Summary
Constructor and Description
CookieHolder()
CookieHolder(Object initial)
Method Summary
Modifier and Type | Method and Description
void | _read(InputStream is) Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
TypeCode | _type() Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
void | _write(OutputStream os) Marshals to ostream the value in the value field of the Holder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public Object value
Constructor Detail

CookieHolder

public CookieHolder()

CookieHolder

public CookieHolder(Object initial)
Method Detail

_read

public void _read(InputStream is)
Description copied from interface: Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.

Specified by:
_read in interface Streamable
Parameters:
is - the InputStream that represents the CDR data from the wire.

_write

public void _write(OutputStream os)
Description copied from interface: Streamable
Marshals to ostream the value in the value field of the Holder.

Specified by:
_write in interface Streamable
Parameters:
os - the CDR OutputStream

_type

public TypeCode _type()
Description copied from interface: Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.

Specified by:
_type in interface Streamable
Returns:
the TypeCode object for the value held in the holder
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.omg.PortableServer.ServantLocatorPackage (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.PortableServer.ServantLocatorPackage

Provides classes and interfaces for locating the servant.

See:
Description

Class Summary
Class | Description
CookieHolder | The native type PortableServer::ServantLocator::Cookie is mapped to java.lang.Object.

Package org.omg.PortableServer.ServantLocatorPackage Description

Provides classes and interfaces for locating the servant.

This package supplies a CookieHolder class for passing the Cookie type as an out parameter. The CookieHolder class follows exactly the same pattern as the other holder classes for basic types.

Package Specification

For a precise list of supported sections of official OMG specifications with which the Java[tm] Platform, Standard Edition 6 complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


org.omg.SendingContext (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.SendingContext

Provides support for the marshalling of value types.

See:
Description

Interface Summary
Interface | Description
RunTime | Defines the base class that represents the Sending Context of a request.
RunTimeOperations | Defines operations on the base class that represents the Sending Context of a request.

Package org.omg.SendingContext Description

Provides support for the marshalling of value types. Value type marshalling may require access to an implementation of the value type or to meta information about the value type. This information is passed between the sending context and the receiving context using a particular service context containing an instance of the SendingContext.RunTime interface.

A sending context may be either the client side or the server side of an invocation, depending on which contains a value type. The sending context is the client side of an invocation if the request contains a value type. It is the server side if the reply contains a value type. The other party in the communication is the receiving context.

The service context marshalled for SendingContext consists of an encapsulated IOR for the SendingContext.RunTime interface. RunTime is just a marker interface defined to allow extensibility in the future. There is currently only one subinterface of RunTime defined: the SendingContext.CodeBase interface. The interface CodeBase defines operations to obtain code URLs and meta-information about a value type received from the sending context.

Note that these classes are currently defined in the com.sun.org.omg.SendingContext package rather than in the package org.omg.SendingContext. This has been done to avoid including large parts of the interface repository in the JDK core, since the interface repository is still evolving in response to the needs of the CORBA Components work.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.3
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


RunTime (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.SendingContext
Interface RunTime

All Superinterfaces:
IDLEntity, Object, RunTimeOperations, Serializable
public interface RunTime
extends RunTimeOperations, Object, IDLEntity

Defines the base class that represents the Sending Context of a request. The sending context provides access to information about the runtime environment of the originator of a GIOP message. For example, when a value type is marshalled on a GIOP Request message, the receiver of the value type may need to ask the sender about the CodeBase for the implementation of the value type.

Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.omg.CORBA.Object
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


RunTimeOperations (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.SendingContext
Interface RunTimeOperations

All Known Subinterfaces:
RunTime
public interface RunTimeOperations

Defines operations on the base class that represents the Sending Context of a request. The sending context provides access to information about the runtime environment of the originator of a GIOP message. For example, when a value type is marshalled on a GIOP Request message, the receiver of the value type may need to ask the sender about the CodeBase for the implementation of the value type.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.omg.stub.java.rmi (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.omg.stub.java.rmi

Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.

See:
Description

Class Summary
Class | Description
_Remote_Stub | This class provides the Stub for the Remote Type.

Package org.omg.stub.java.rmi Description

Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.

Since:
1.3
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


_Remote_Stub (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.omg.stub.java.rmi
Class _Remote_Stub

java.lang.Object
    extended by  org.omg.CORBA.portable.ObjectImpl
        extended by  org.omg.CORBA_2_3.portable.ObjectImpl
            extended by  javax.rmi.CORBA.Stub
                extended by  org.omg.stub.java.rmi._Remote_Stub
All Implemented Interfaces:
Serializable, Remote, Object
public final class _Remote_Stub
extends Stub
implements Remote

This class provides the Stub for the Remote Type. The class is generated by the rmic compiler, and is still under works at OMG. It's contents are subject to change without notice as the specification evolves.

Constructor Summary
Constructor and Description
_Remote_Stub()
Method Summary
Modifier and Type | Method and Description
String[] | _ids() Returns an array of repository ids that an object implements.
Methods inherited from class javax.rmi.CORBA.Stub
connect, equals, hashCode, toString
Methods inherited from class org.omg.CORBA_2_3.portable.ObjectImpl
_get_codebase
Methods inherited from class org.omg.CORBA.portable.ObjectImpl
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

_Remote_Stub

public _Remote_Stub()
Method Detail

_ids

public String[] _ids()
Returns an array of repository ids that an object implements. The string at index zero represents the most derived interface. The last id, for the generic CORBA object is (i.e., IDL:omg.org/CORBA/Object:1.0") is implied and not present.

Specified by:
_ids in class ObjectImpl
Returns:
an array of repository ids that an object implements.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Attr (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.w3c.dom
Interface Attr

All Superinterfaces:
Node
public interface Attr
extends Node

The Attr interface represents an attribute in an Element object. Typically the allowable values for the attribute are defined in a schema associated with the document.

Attr objects inherit the Node interface, but since they are not actually child nodes of the element they describe, the DOM does not consider them part of the document tree. Thus, the Node attributes parentNode, previousSibling, and nextSibling have a null value for Attr objects. The DOM takes the view that attributes are properties of elements rather than having a separate identity from the elements they are associated with; this should make it more efficient to implement such features as default attributes associated with all elements of a given type. Furthermore, Attr nodes may not be immediate children of a DocumentFragment. However, they can be associated with Element nodes contained within a DocumentFragment. In short, users and implementors of the DOM need to be aware that Attr nodes have some things in common with other objects inheriting the Node interface, but they also are quite distinct.

The attribute's effective value is determined as follows: if this attribute has been explicitly assigned any value, that value is the attribute's effective value; otherwise, if there is a declaration for this attribute, and that declaration includes a default value, then that default value is the attribute's effective value; otherwise, the attribute does not exist on this element in the structure model until it has been explicitly added. Note that the Node.nodeValue attribute on the Attr instance can also be used to retrieve the string version of the attribute's value(s).

If the attribute was not explicitly given a value in the instance document but has a default value provided by the schema associated with the document, an attribute node will be created with specified set to false. Removing attribute nodes for which a default value is defined in the schema generates a new attribute node with the default value and specified set to false. If validation occurred while invoking Document.normalizeDocument(), attribute nodes with specified equals to false are recomputed according to the default attribute values provided by the schema. If no default value is associate with this attribute in the schema, the attribute node is discarded.

In XML, where the value of an attribute can contain entity references, the child nodes of the Attr node may be either Text or EntityReference nodes (when these are in use; see the description of EntityReference for discussion).

The DOM Core represents all attribute values as simple strings, even if the DTD or schema associated with the document declares them of some specific type such as tokenized.

The way attribute value normalization is performed by the DOM implementation depends on how much the implementation knows about the schema in use. Typically, the value and nodeValue attributes of an Attr node initially returns the normalized value given by the parser. It is also the case after Document.normalizeDocument() is called (assuming the right options have been set). But this may not be the case after mutation, independently of whether the mutation is performed by setting the string value directly or by changing the Attr child nodes. In particular, this is true when character references are involved, given that they are not represented in the DOM and they impact attribute value normalization. On the other hand, if the implementation knows about the schema in use when the attribute value is changed, and it is of a different type than CDATA, it may normalize it again at that time. This is especially true of specialized DOM implementations, such as SVG DOM implementations, which store attribute values in an internal form different from a string.

The following table gives some examples of the relations between the attribute value in the original document (parsed attribute), the value as exposed in the DOM, and the serialization of the value:

Examples Parsed attribute value Initial Attr.value Serialized attribute value
Character reference
"x&#178;=5"

"x�=5"

"x&#178;=5"
Built-in character entity
"y&lt;6"

"y<6"

"y&lt;6"
Literal newline between
 "x=5&#10;y=6"

"x=5 y=6"

"x=5&#10;y=6"
Normalized newline between
"x=5
 y=6"

"x=5 y=6"

"x=5 y=6"
Entity e with literal newline
 <!ENTITY e '...&#10;...'> [...]> "x=5&e;y=6"
 Dependent on Implementation and Load Options Dependent on Implementation and Load/Save Options

See also the Document Object Model (DOM) Level 3 Core Specification.

Field Summary
Modifier and Type Field and Description
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
Modifier and Type | Method and Description
String | getName() Returns the name of this attribute.
Element | getOwnerElement() The Element node this attribute is attached to or null if this attribute is not in use.
TypeInfo | getSchemaTypeInfo() The type information associated with this attribute.
boolean | getSpecified() True if this attribute was explicitly given a value in the instance document, false otherwise.
String | getValue() On retrieval, the value of the attribute is returned as a string.
boolean | isId() Returns whether this attribute is known to be of type ID (i.e.
void | setValue(String value) On retrieval, the value of the attribute is returned as a string.
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Method Detail

getName

String getName()
Returns the name of this attribute. If Node.localName is different from null, this attribute is a qualified name.

getSpecified

boolean getSpecified()
True if this attribute was explicitly given a value in the instance document, false otherwise. If the application changed the value of this attribute node (even if it ends up having the same value as the default value) then it is set to true. The implementation may handle attributes with default values from other schemas similarly but applications should use Document.normalizeDocument() to guarantee this information is up-to-date.

getValue

String getValue()
On retrieval, the value of the attribute is returned as a string. Character and general entity references are replaced with their values. See also the method getAttribute on the Element interface.
On setting, this creates a Text node with the unparsed contents of the string, i.e. any characters that an XML processor would recognize as markup are instead treated as literal text. See also the method Element.setAttribute().
Some specialized implementations, such as some [SVG 1.1] implementations, may do normalization automatically, even after mutation; in such case, the value on retrieval may differ from the value on setting.

setValue

void setValue(String value)
              throws DOMException
On retrieval, the value of the attribute is returned as a string. Character and general entity references are replaced with their values. See also the method getAttribute on the Element interface.
On setting, this creates a Text node with the unparsed contents of the string, i.e. any characters that an XML processor would recognize as markup are instead treated as literal text. See also the method Element.setAttribute().
Some specialized implementations, such as some [SVG 1.1] implementations, may do normalization automatically, even after mutation; in such case, the value on retrieval may differ from the value on setting.

Throws:
DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised when the node is readonly.

getOwnerElement

Element getOwnerElement()
The Element node this attribute is attached to or null if this attribute is not in use.

Since:
DOM Level 2

getSchemaTypeInfo

TypeInfo getSchemaTypeInfo()
The type information associated with this attribute. While the type information contained in this attribute is guarantee to be correct after loading the document or invoking Document.normalizeDocument(), schemaTypeInfo may not be reliable if the node was moved.

Since:
DOM Level 3

isId

boolean isId()
Returns whether this attribute is known to be of type ID (i.e. to contain an identifier for its owner element) or not. When it is and its value is unique, the ownerElement of this attribute can be retrieved using the method Document.getElementById . The implementation could use several ways to determine if an attribute node is known to contain an identifier:
  • If validation occurred using an XML Schema [XML Schema Part 1] while loading the document or while invoking Document.normalizeDocument(), the post-schema-validation infoset contributions (PSVI contributions) values are used to determine if this attribute is a schema-determined ID attribute using the schema-determined ID definition in [XPointer] .
  • If validation occurred using a DTD while loading the document or while invoking Document.normalizeDocument(), the infoset [type definition] value is used to determine if this attribute is a DTD-determined ID attribute using the DTD-determined ID definition in [XPointer] .
  • from the use of the methods Element.setIdAttribute(), Element.setIdAttributeNS(), or Element.setIdAttributeNode(), i.e. it is an user-determined ID attribute;

    Note: XPointer framework (see section 3.2 in [XPointer] ) consider the DOM user-determined ID attribute as being part of the XPointer externally-determined ID definition.

  • using mechanisms that are outside the scope of this specification, it is then an externally-determined ID attribute. This includes using schema languages different from XML schema and DTD.

If validation occurred while invoking Document.normalizeDocument(), all user-determined ID attributes are reset and all attribute nodes ID information are then reevaluated in accordance to the schema used. As a consequence, if the Attr.schemaTypeInfo attribute contains an ID type, isId will always return true.

Since:
DOM Level 3
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CDATASection (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface CDATASection

All Superinterfaces:
CharacterData, Node, Text
public interface CDATASection
extends Text

CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup. The only delimiter that is recognized in a CDATA section is the "]]>" string that ends the CDATA section. CDATA sections cannot be nested. Their primary purpose is for including material such as XML fragments, without needing to escape all the delimiters.

The CharacterData.data attribute holds the text that is contained by the CDATA section. Note that this may contain characters that need to be escaped outside of CDATA sections and that, depending on the character encoding ("charset") chosen for serialization, it may be impossible to write out some characters as part of a CDATA section.

The CDATASection interface inherits from the CharacterData interface through the Text interface. Adjacent CDATASection nodes are not merged by use of the normalize method of the Node interface.

No lexical check is done on the content of a CDATA section and it is therefore possible to have the character sequence "]]>" in the content, which is illegal in a CDATA section per section 2.7 of [XML 1.0]. The presence of this character sequence must generate a fatal error during serialization or the cdata section must be splitted before the serialization (see also the parameter "split-cdata-sections" in the DOMConfiguration interface).

Note: Because no markup is recognized within a CDATASection, character numeric references cannot be used as an escape mechanism when serializing. Therefore, action needs to be taken when serializing a CDATASection with a character encoding where some of the contained characters cannot be represented. Failure to do so would not produce well-formed XML.

Note: One potential solution in the serialization process is to end the CDATA section before the character, output the character using a character reference or entity reference, and open a new CDATA section for any further characters in the text node. Note, however, that some code conversion libraries at the time of writing do not return an error or exception when a character is missing from the encoding, making the task of ensuring that data is not corrupted on serialization more difficult.

See also the Document Object Model (DOM) Level 3 Core Specification.

Field Summary
Modifier and Type Field and Description
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.w3c.dom.Text
getWholeText, isElementContentWhitespace, replaceWholeText, splitText
Methods inherited from interface org.w3c.dom.CharacterData
appendData, deleteData, getData, getLength, insertData, replaceData, setData, substringData
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


CharacterData (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface CharacterData

All Superinterfaces:
Node
All Known Subinterfaces:
CDATASection, Comment, Text, Text
public interface CharacterData
extends Node

The CharacterData interface extends Node with a set of attributes and methods for accessing character data in the DOM. For clarity this set is defined here rather than on each object that uses these attributes and methods. No DOM objects correspond directly to CharacterData, though Text and others do inherit the interface from it. All offsets in this interface start from 0.

As explained in the DOMString interface, text strings in the DOM are represented in UTF-16, i.e. as a sequence of 16-bit units. In the following, the term 16-bit units is used whenever necessary to indicate that indexing on CharacterData is done in 16-bit units.

See also the Document Object Model (DOM) Level 3 Core Specification.

Field Summary
Modifier and Type Field and Description
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
Modifier and Type | Method and Description
void | appendData(String arg) Append the string to the end of the character data of the node.
void | deleteData(int offset, int count) Remove a range of 16-bit units from the node.
String | getData() The character data of the node that implements this interface.
int | getLength() The number of 16-bit units that are available through data and the substringData method below.
void | insertData(int offset, String arg) Insert a string at the specified 16-bit unit offset.
void | replaceData(int offset, int count, String arg) Replace the characters starting at the specified 16-bit unit offset with the specified string.
void | setData(String data) The character data of the node that implements this interface.
String | substringData(int offset, int count) Extracts a range of data from the node.
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Method Detail

getData

String getData()
               throws DOMException
The character data of the node that implements this interface. The DOM implementation may not put arbitrary limits on the amount of data that may be stored in a CharacterData node. However, implementation limits may mean that the entirety of a node's data may not fit into a single DOMString. In such cases, the user may call substringData to retrieve the data in appropriately sized pieces.

Throws:
DOMException - DOMSTRING_SIZE_ERR: Raised when it would return more characters than fit in a DOMString variable on the implementation platform.

setData

void setData(String data)
             throws DOMException
The character data of the node that implements this interface. The DOM implementation may not put arbitrary limits on the amount of data that may be stored in a CharacterData node. However, implementation limits may mean that the entirety of a node's data may not fit into a single DOMString. In such cases, the user may call substringData to retrieve the data in appropriately sized pieces.

Throws:
DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised when the node is readonly.

getLength

int getLength()
The number of 16-bit units that are available through data and the substringData method below. This may have the value zero, i.e., CharacterData nodes may be empty.

substringData

String substringData(int offset,
                     int count)
                     throws DOMException
Extracts a range of data from the node.

Parameters:
offset - Start offset of substring to extract.
count - The number of 16-bit units to extract.
Returns:
The specified substring. If the sum of offset and count exceeds the length, then all 16-bit units to the end of the data are returned.
Throws:
DOMException - INDEX_SIZE_ERR: Raised if the specified offset is negative or greater than the number of 16-bit units in data, or if the specified count is negative.
DOMSTRING_SIZE_ERR: Raised if the specified range of text does not fit into a DOMString.

appendData

void appendData(String arg)
                throws DOMException
Append the string to the end of the character data of the node. Upon success, data provides access to the concatenation of data and the DOMString specified.

Parameters:
arg - The DOMString to append.
Throws:
DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

insertData

void insertData(int offset,
                String arg)
                throws DOMException
Insert a string at the specified 16-bit unit offset.

Parameters:
offset - The character offset at which to insert.
arg - The DOMString to insert.
Throws:
DOMException - INDEX_SIZE_ERR: Raised if the specified offset is negative or greater than the number of 16-bit units in data.
NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

deleteData

void deleteData(int offset,
                int count)
                throws DOMException
Remove a range of 16-bit units from the node. Upon success, data and length reflect the change.

Parameters:
offset - The offset from which to start removing.
count - The number of 16-bit units to delete. If the sum of offset and count exceeds length then all 16-bit units from offset to the end of the data are deleted.
Throws:
DOMException - INDEX_SIZE_ERR: Raised if the specified offset is negative or greater than the number of 16-bit units in data, or if the specified count is negative.
NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

replaceData

void replaceData(int offset,
                 int count,
                 String arg)
                 throws DOMException
Replace the characters starting at the specified 16-bit unit offset with the specified string.

Parameters:
offset - The offset from which to start replacing.
count - The number of 16-bit units to replace. If the sum of offset and count exceeds length, then all 16-bit units to the end of the data are replaced; (i.e., the effect is the same as a remove method call with the same range, followed by an append method invocation).
arg - The DOMString with which the range must be replaced.
Throws:
DOMException - INDEX_SIZE_ERR: Raised if the specified offset is negative or greater than the number of 16-bit units in data, or if the specified count is negative.
NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


Comment (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface Comment

All Superinterfaces:
CharacterData, Node
public interface Comment
extends CharacterData

This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'. Note that this is the definition of a comment in XML, and, in practice, HTML, although some HTML tools may implement the full SGML comment structure.

No lexical check is done on the content of a comment and it is therefore possible to have the character sequence "--" (double-hyphen) in the content, which is illegal in a comment per section 2.5 of [XML 1.0]. The presence of this character sequence must generate a fatal error during serialization.

See also the Document Object Model (DOM) Level 3 Core Specification.

Field Summary
Modifier and Type Field and Description
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.w3c.dom.CharacterData
appendData, deleteData, getData, getLength, insertData, replaceData, setData, substringData
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


Document (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface Document

All Superinterfaces:
Node
All Known Implementing Classes:
SOAPPart
public interface Document
extends Node

The Document interface represents the entire HTML or XML document. Conceptually, it is the root of the document tree, and provides the primary access to the document's data.

Since elements, text nodes, comments, processing instructions, etc. cannot exist outside the context of a Document, the Document interface also contains the factory methods needed to create these objects. The Node objects created have a ownerDocument attribute which associates them with the Document within whose context they were created.

See also the Document Object Model (DOM) Level 3 Core Specification.

Field Summary
Modifier and Type Field and Description
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
Modifier and Type Method and Description
 Node adoptNode(Node source)
Attempts to adopt a node from another document to this document.
 Attr createAttribute(String name)
Creates an Attr of the given name.
 Attr createAttributeNS(String namespaceURI, String qualifiedName)
Creates an attribute of the given qualified name and namespace URI.
 CDATASection createCDATASection(String data)
Creates a CDATASection node whose value is the specified string.
 Comment createComment(String data)
Creates a Comment node given the specified string.
 DocumentFragment createDocumentFragment()
Creates an empty DocumentFragment object.
 Element createElement(String tagName)
Creates an element of the type specified.
 Element createElementNS(String namespaceURI, String qualifiedName)
Creates an element of the given qualified name and namespace URI.
 EntityReference createEntityReference(String name)
Creates an EntityReference object.
 ProcessingInstruction createProcessingInstruction(String target, String data)
Creates a ProcessingInstruction node given the specified name and data strings.
 Text createTextNode(String data)
Creates a Text node given the specified string.
 DocumentType getDoctype()
The Document Type Declaration (see DocumentType) associated with this document.
 Element getDocumentElement()
This is a convenience attribute that allows direct access to the child node that is the document element of the document.
 String getDocumentURI()
The location of the document or null if undefined or if the Document was created using DOMImplementation.createDocument.
 DOMConfiguration getDomConfig()
The configuration used when Document.normalizeDocument() is invoked.
 Element getElementById(String elementId)
Returns the Element that has an ID attribute with the given value.
 NodeList getElementsByTagName(String tagname)
Returns a NodeList of all the Elements in document order with a given tag name and are contained in the document.
 NodeList getElementsByTagNameNS(String namespaceURI, String localName)
Returns a NodeList of all the Elements with a given local name and namespace URI in document order.
 DOMImplementation getImplementation()
The DOMImplementation object that handles this document.
 String getInputEncoding()
An attribute specifying the encoding used for this document at the time of the parsing.
 boolean getStrictErrorChecking()
An attribute specifying whether error checking is enforced or not.
 String getXmlEncoding()
An attribute specifying, as part of the XML declaration, the encoding of this document.
 boolean getXmlStandalone()
An attribute specifying, as part of the XML declaration, whether this document is standalone.
 String getXmlVersion()
An attribute specifying, as part of the XML declaration, the version number of this document.
 Node importNode(Node importedNode, boolean deep)
Imports a node from another document to this document, without altering or removing the source node from the original document; this method creates a new copy of the source node.
 void normalizeDocument()
This method acts as if the document was going through a save and load cycle, putting the document in a "normal" form.
 Node renameNode(Node n, String namespaceURI, String qualifiedName)
Rename an existing node of type ELEMENT_NODE or ATTRIBUTE_NODE.
 void setDocumentURI(String documentURI)
The location of the document or null if undefined or if the Document was created using DOMImplementation.createDocument.
 void setStrictErrorChecking(boolean strictErrorChecking)
An attribute specifying whether error checking is enforced or not.
 void setXmlStandalone(boolean xmlStandalone)
An attribute specifying, as part of the XML declaration, whether this document is standalone.
 void setXmlVersion(String xmlVersion)
An attribute specifying, as part of the XML declaration, the version number of this document.
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Method Detail

getDoctype

DocumentType getDoctype()
The Document Type Declaration (see DocumentType) associated with this document. For XML documents without a document type declaration this returns null. For HTML documents, a DocumentType object may be returned, independently of the presence or absence of document type declaration in the HTML document.
This provides direct access to the DocumentType node, child node of this Document. This node can be set at document creation time and later changed through the use of child nodes manipulation methods, such as Node.insertBefore, or Node.replaceChild. Note, however, that while some implementations may instantiate different types of Document objects supporting additional features than the "Core", such as "HTML" [DOM Level 2 HTML] , based on the DocumentType specified at creation time, changing it afterwards is very unlikely to result in a change of the features supported.

Since:
DOM Level 3

getImplementation

DOMImplementation getImplementation()
The DOMImplementation object that handles this document. A DOM application may use objects from multiple implementations.

getDocumentElement

Element getDocumentElement()
This is a convenience attribute that allows direct access to the child node that is the document element of the document.

createElement

Element createElement(String tagName)
                      throws DOMException
Creates an element of the type specified. Note that the instance returned implements the Element interface, so attributes can be specified directly on the returned object.
In addition, if there are known attributes with default values, Attr nodes representing them are automatically created and attached to the element.
To create an element with a qualified name and namespace URI, use the createElementNS method.

Parameters:
tagName - The name of the element type to instantiate. For XML, this is case-sensitive, otherwise it depends on the case-sensitivity of the markup language in use. In that case, the name is mapped to the canonical form of that markup by the DOM implementation.
Returns:
A new Element object with the nodeName attribute set to tagName, and localName, prefix, and namespaceURI set to null.
Throws:
DOMException - INVALID_CHARACTER_ERR: Raised if the specified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.

createDocumentFragment

DocumentFragment createDocumentFragment()
Creates an empty DocumentFragment object.

Returns:
A new DocumentFragment.

createTextNode

Text createTextNode(String data)
Creates a Text node given the specified string.

Parameters:
data - The data for the node.
Returns:
The new Text object.

createComment

Comment createComment(String data)
Creates a Comment node given the specified string.

Parameters:
data - The data for the node.
Returns:
The new Comment object.

createCDATASection

CDATASection createCDATASection(String data)
                                throws DOMException
Creates a CDATASection node whose value is the specified string.

Parameters:
data - The data for the CDATASection contents.
Returns:
The new CDATASection object.
Throws:
DOMException - NOT_SUPPORTED_ERR: Raised if this document is an HTML document.

createProcessingInstruction

ProcessingInstruction createProcessingInstruction(String target,
                                                  String data)
                                                  throws DOMException
Creates a ProcessingInstruction node given the specified name and data strings.

Parameters:
target - The target part of the processing instruction.Unlike Document.createElementNS or Document.createAttributeNS, no namespace well-formed checking is done on the target name. Applications should invoke Document.normalizeDocument() with the parameter " namespaces" set to true in order to ensure that the target name is namespace well-formed.
data - The data for the node.
Returns:
The new ProcessingInstruction object.
Throws:
DOMException - INVALID_CHARACTER_ERR: Raised if the specified target is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
NOT_SUPPORTED_ERR: Raised if this document is an HTML document.

createAttribute

Attr createAttribute(String name)
                     throws DOMException
Creates an Attr of the given name. Note that the Attr instance can then be set on an Element using the setAttributeNode method.
To create an attribute with a qualified name and namespace URI, use the createAttributeNS method.

Parameters:
name - The name of the attribute.
Returns:
A new Attr object with the nodeName attribute set to name, and localName, prefix, and namespaceURI set to null. The value of the attribute is the empty string.
Throws:
DOMException - INVALID_CHARACTER_ERR: Raised if the specified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.

createEntityReference

EntityReference createEntityReference(String name)
                                      throws DOMException
Creates an EntityReference object. In addition, if the referenced entity is known, the child list of the EntityReference node is made the same as that of the corresponding Entity node.

Note: If any descendant of the Entity node has an unbound namespace prefix, the corresponding descendant of the created EntityReference node is also unbound; (its namespaceURI is null). The DOM Level 2 and 3 do not support any mechanism to resolve namespace prefixes in this case.

Parameters:
name - The name of the entity to reference.Unlike Document.createElementNS or Document.createAttributeNS, no namespace well-formed checking is done on the entity name. Applications should invoke Document.normalizeDocument() with the parameter " namespaces" set to true in order to ensure that the entity name is namespace well-formed.
Returns:
The new EntityReference object.
Throws:
DOMException - INVALID_CHARACTER_ERR: Raised if the specified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
NOT_SUPPORTED_ERR: Raised if this document is an HTML document.

getElementsByTagName

NodeList getElementsByTagName(String tagname)
Returns a NodeList of all the Elements in document order with a given tag name and are contained in the document.

Parameters:
tagname - The name of the tag to match on. The special value "*" matches all tags. For XML, the tagname parameter is case-sensitive, otherwise it depends on the case-sensitivity of the markup language in use.
Returns:
A new NodeList object containing all the matched Elements.

importNode

Node importNode(Node importedNode,
                boolean deep)
                throws DOMException
Imports a node from another document to this document, without altering or removing the source node from the original document; this method creates a new copy of the source node. The returned node has no parent; (parentNode is null).
For all nodes, importing a node creates a node object owned by the importing document, with attribute values identical to the source node's nodeName and nodeType, plus the attributes related to namespaces (prefix, localName, and namespaceURI). As in the cloneNode operation, the source node is not altered. User data associated to the imported node is not carried over. However, if any UserDataHandlers has been specified along with the associated data these handlers will be called with the appropriate parameters before this method returns.
Additional information is copied as appropriate to the nodeType, attempting to mirror the behavior expected if a fragment of XML or HTML source was copied from one document to another, recognizing that the two documents may have different DTDs in the XML case. The following list describes the specifics for each type of node.
ATTRIBUTE_NODE
The ownerElement attribute is set to null and the specified flag is set to true on the generated Attr. The descendants of the source Attr are recursively imported and the resulting nodes reassembled to form the corresponding subtree. Note that the deep parameter has no effect on Attr nodes; they always carry their children with them when imported.
DOCUMENT_FRAGMENT_NODE
If the deep option was set to true, the descendants of the source DocumentFragment are recursively imported and the resulting nodes reassembled under the imported DocumentFragment to form the corresponding subtree. Otherwise, this simply generates an empty DocumentFragment.
DOCUMENT_NODE
Document nodes cannot be imported.
DOCUMENT_TYPE_NODE
DocumentType nodes cannot be imported.
ELEMENT_NODE
Specified attribute nodes of the source element are imported, and the generated Attr nodes are attached to the generated Element. Default attributes are not copied, though if the document being imported into defines default attributes for this element name, those are assigned. If the importNode deep parameter was set to true, the descendants of the source element are recursively imported and the resulting nodes reassembled to form the corresponding subtree.
ENTITY_NODE
Entity nodes can be imported, however in the current release of the DOM the DocumentType is readonly. Ability to add these imported nodes to a DocumentType will be considered for addition to a future release of the DOM.On import, the publicId, systemId, and notationName attributes are copied. If a deep import is requested, the descendants of the the source Entity are recursively imported and the resulting nodes reassembled to form the corresponding subtree.
ENTITY_REFERENCE_NODE
Only the EntityReference itself is copied, even if a deep import is requested, since the source and destination documents might have defined the entity differently. If the document being imported into provides a definition for this entity name, its value is assigned.
NOTATION_NODE
Notation nodes can be imported, however in the current release of the DOM the DocumentType is readonly. Ability to add these imported nodes to a DocumentType will be considered for addition to a future release of the DOM.On import, the publicId and systemId attributes are copied. Note that the deep parameter has no effect on this type of nodes since they cannot have any children.
PROCESSING_INSTRUCTION_NODE
The imported node copies its target and data values from those of the source node.Note that the deep parameter has no effect on this type of nodes since they cannot have any children.
TEXT_NODE, CDATA_SECTION_NODE, COMMENT_NODE
These three types of nodes inheriting from CharacterData copy their data and length attributes from those of the source node.Note that the deep parameter has no effect on these types of nodes since they cannot have any children.

Parameters:
importedNode - The node to import.
deep - If true, recursively import the subtree under the specified node; if false, import only the node itself, as explained above. This has no effect on nodes that cannot have any children, and on Attr, and EntityReference nodes.
Returns:
The imported node that belongs to this Document.
Throws:
DOMException - NOT_SUPPORTED_ERR: Raised if the type of node being imported is not supported.
INVALID_CHARACTER_ERR: Raised if one of the imported names is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute. This may happen when importing an XML 1.1 [XML 1.1] element into an XML 1.0 document, for instance.
Since:
DOM Level 2

createElementNS

Element createElementNS(String namespaceURI,
                        String qualifiedName)
                        throws DOMException
Creates an element of the given qualified name and namespace URI.
Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.

Parameters:
namespaceURI - The namespace URI of the element to create.
qualifiedName - The qualified name of the element type to instantiate.
Returns:
A new Element object with the following attributes:
Attribute | Value
Node.nodeName | qualifiedName
Node.namespaceURI | namespaceURI
Node.prefix | prefix, extracted from qualifiedName, or null if there is no prefix
Node.localName | local name, extracted from qualifiedName
Element.tagName | qualifiedName
Throws:
DOMException - INVALID_CHARACTER_ERR: Raised if the specified qualifiedName is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
NAMESPACE_ERR: Raised if the qualifiedName is a malformed qualified name, if the qualifiedName has a prefix and the namespaceURI is null, or if the qualifiedName has a prefix that is "xml" and the namespaceURI is different from " http://www.w3.org/XML/1998/namespace" [XML Namespaces] , or if the qualifiedName or its prefix is "xmlns" and the namespaceURI is different from "http://www.w3.org/2000/xmlns/", or if the namespaceURI is "http://www.w3.org/2000/xmlns/" and neither the qualifiedName nor its prefix is "xmlns".
NOT_SUPPORTED_ERR: Always thrown if the current document does not support the "XML" feature, since namespaces were defined by XML.
Since:
DOM Level 2

createAttributeNS

Attr createAttributeNS(String namespaceURI,
                       String qualifiedName)
                       throws DOMException
Creates an attribute of the given qualified name and namespace URI.
Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.

Parameters:
namespaceURI - The namespace URI of the attribute to create.
qualifiedName - The qualified name of the attribute to instantiate.
Returns:
A new Attr object with the following attributes:
Attribute | Value
Node.nodeName | qualifiedName
Node.namespaceURI | namespaceURI
Node.prefix | prefix, extracted from qualifiedName, or null if there is no prefix
Node.localName | local name, extracted from qualifiedName
Attr.name | qualifiedName
Node.nodeValue | the empty string
Throws:
DOMException - INVALID_CHARACTER_ERR: Raised if the specified qualifiedName is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
NAMESPACE_ERR: Raised if the qualifiedName is a malformed qualified name, if the qualifiedName has a prefix and the namespaceURI is null, if the qualifiedName has a prefix that is "xml" and the namespaceURI is different from " http://www.w3.org/XML/1998/namespace", if the qualifiedName or its prefix is "xmlns" and the namespaceURI is different from "http://www.w3.org/2000/xmlns/", or if the namespaceURI is "http://www.w3.org/2000/xmlns/" and neither the qualifiedName nor its prefix is "xmlns".
NOT_SUPPORTED_ERR: Always thrown if the current document does not support the "XML" feature, since namespaces were defined by XML.
Since:
DOM Level 2

getElementsByTagNameNS

NodeList getElementsByTagNameNS(String namespaceURI,
                                String localName)
Returns a NodeList of all the Elements with a given local name and namespace URI in document order.

Parameters:
namespaceURI - The namespace URI of the elements to match on. The special value "*" matches all namespaces.
localName - The local name of the elements to match on. The special value "*" matches all local names.
Returns:
A new NodeList object containing all the matched Elements.
Since:
DOM Level 2

getElementById

Element getElementById(String elementId)
Returns the Element that has an ID attribute with the given value. If no such element exists, this returns null . If more than one element has an ID attribute with that value, what is returned is undefined.
The DOM implementation is expected to use the attribute Attr.isId to determine if an attribute is of type ID.

Note: Attributes with the name "ID" or "id" are not of type ID unless so defined.

Parameters:
elementId - The unique id value for an element.
Returns:
The matching element or null if there is none.
Since:
DOM Level 2

getInputEncoding

String getInputEncoding()
An attribute specifying the encoding used for this document at the time of the parsing. This is null when it is not known, such as when the Document was created in memory.

Since:
DOM Level 3

getXmlEncoding

String getXmlEncoding()
An attribute specifying, as part of the XML declaration, the encoding of this document. This is null when unspecified or when it is not known, such as when the Document was created in memory.

Since:
DOM Level 3

getXmlStandalone

boolean getXmlStandalone()
An attribute specifying, as part of the XML declaration, whether this document is standalone. This is false when unspecified.

Note: No verification is done on the value when setting this attribute. Applications should use Document.normalizeDocument() with the "validate" parameter to verify if the value matches the validity constraint for standalone document declaration as defined in [XML 1.0].

Since:
DOM Level 3

setXmlStandalone

void setXmlStandalone(boolean xmlStandalone)
                      throws DOMException
An attribute specifying, as part of the XML declaration, whether this document is standalone. This is false when unspecified.

Note: No verification is done on the value when setting this attribute. Applications should use Document.normalizeDocument() with the "validate" parameter to verify if the value matches the validity constraint for standalone document declaration as defined in [XML 1.0].

Throws:
DOMException - NOT_SUPPORTED_ERR: Raised if this document does not support the "XML" feature.
Since:
DOM Level 3

getXmlVersion

String getXmlVersion()
An attribute specifying, as part of the XML declaration, the version number of this document. If there is no declaration and if this document supports the "XML" feature, the value is "1.0". If this document does not support the "XML" feature, the value is always null. Changing this attribute will affect methods that check for invalid characters in XML names. Application should invoke Document.normalizeDocument() in order to check for invalid characters in the Nodes that are already part of this Document.
DOM applications may use the DOMImplementation.hasFeature(feature, version) method with parameter values "XMLVersion" and "1.0" (respectively) to determine if an implementation supports [XML 1.0]. DOM applications may use the same method with parameter values "XMLVersion" and "1.1" (respectively) to determine if an implementation supports [XML 1.1]. In both cases, in order to support XML, an implementation must also support the "XML" feature defined in this specification. Document objects supporting a version of the "XMLVersion" feature must not raise a NOT_SUPPORTED_ERR exception for the same version number when using Document.xmlVersion.

Since:
DOM Level 3

setXmlVersion

void setXmlVersion(String xmlVersion)
                   throws DOMException
An attribute specifying, as part of the XML declaration, the version number of this document. If there is no declaration and if this document supports the "XML" feature, the value is "1.0". If this document does not support the "XML" feature, the value is always null. Changing this attribute will affect methods that check for invalid characters in XML names. Application should invoke Document.normalizeDocument() in order to check for invalid characters in the Nodes that are already part of this Document.
DOM applications may use the DOMImplementation.hasFeature(feature, version) method with parameter values "XMLVersion" and "1.0" (respectively) to determine if an implementation supports [XML 1.0]. DOM applications may use the same method with parameter values "XMLVersion" and "1.1" (respectively) to determine if an implementation supports [XML 1.1]. In both cases, in order to support XML, an implementation must also support the "XML" feature defined in this specification. Document objects supporting a version of the "XMLVersion" feature must not raise a NOT_SUPPORTED_ERR exception for the same version number when using Document.xmlVersion.

Throws:
DOMException - NOT_SUPPORTED_ERR: Raised if the version is set to a value that is not supported by this Document or if this document does not support the "XML" feature.
Since:
DOM Level 3

getStrictErrorChecking

boolean getStrictErrorChecking()
An attribute specifying whether error checking is enforced or not. When set to false, the implementation is free to not test every possible error case normally defined on DOM operations, and not raise any DOMException on DOM operations or report errors while using Document.normalizeDocument(). In case of error, the behavior is undefined. This attribute is true by default.

Since:
DOM Level 3

setStrictErrorChecking

void setStrictErrorChecking(boolean strictErrorChecking)
An attribute specifying whether error checking is enforced or not. When set to false, the implementation is free to not test every possible error case normally defined on DOM operations, and not raise any DOMException on DOM operations or report errors while using Document.normalizeDocument(). In case of error, the behavior is undefined. This attribute is true by default.

Since:
DOM Level 3

getDocumentURI

String getDocumentURI()
The location of the document or null if undefined or if the Document was created using DOMImplementation.createDocument. No lexical checking is performed when setting this attribute; this could result in a null value returned when using Node.baseURI .
Beware that when the Document supports the feature "HTML" [DOM Level 2 HTML] , the href attribute of the HTML BASE element takes precedence over this attribute when computing Node.baseURI.

Since:
DOM Level 3

setDocumentURI

void setDocumentURI(String documentURI)
The location of the document or null if undefined or if the Document was created using DOMImplementation.createDocument. No lexical checking is performed when setting this attribute; this could result in a null value returned when using Node.baseURI .
Beware that when the Document supports the feature "HTML" [DOM Level 2 HTML] , the href attribute of the HTML BASE element takes precedence over this attribute when computing Node.baseURI.

Since:
DOM Level 3

adoptNode

Node adoptNode(Node source)
               throws DOMException
Attempts to adopt a node from another document to this document. If supported, it changes the ownerDocument of the source node, its children, as well as the attached attribute nodes if there are any. If the source node has a parent it is first removed from the child list of its parent. This effectively allows moving a subtree from one document to another (unlike importNode() which create a copy of the source node instead of moving it). When it fails, applications should use Document.importNode() instead. Note that if the adopted node is already part of this document (i.e. the source and target document are the same), this method still has the effect of removing the source node from the child list of its parent, if any. The following list describes the specifics for each type of node.
ATTRIBUTE_NODE
The ownerElement attribute is set to null and the specified flag is set to true on the adopted Attr. The descendants of the source Attr are recursively adopted.
DOCUMENT_FRAGMENT_NODE
The descendants of the source node are recursively adopted.
DOCUMENT_NODE
Document nodes cannot be adopted.
DOCUMENT_TYPE_NODE
DocumentType nodes cannot be adopted.
ELEMENT_NODE
Specified attribute nodes of the source element are adopted. Default attributes are discarded, though if the document being adopted into defines default attributes for this element name, those are assigned. The descendants of the source element are recursively adopted.
ENTITY_NODE
Entity nodes cannot be adopted.
ENTITY_REFERENCE_NODE
Only the EntityReference node itself is adopted, the descendants are discarded, since the source and destination documents might have defined the entity differently. If the document being imported into provides a definition for this entity name, its value is assigned.
NOTATION_NODE
Notation nodes cannot be adopted.
PROCESSING_INSTRUCTION_NODE, TEXT_NODE, CDATA_SECTION_NODE, COMMENT_NODE
These nodes can all be adopted. No specifics.

Note: Since it does not create new nodes unlike the Document.importNode() method, this method does not raise an INVALID_CHARACTER_ERR exception, and applications should use the Document.normalizeDocument() method to check if an imported name is not an XML name according to the XML version in use.

Parameters:
source - The node to move into this document.
Returns:
The adopted node, or null if this operation fails, such as when the source node comes from a different implementation.
Throws:
DOMException - NOT_SUPPORTED_ERR: Raised if the source node is of type DOCUMENT, DOCUMENT_TYPE.
NO_MODIFICATION_ALLOWED_ERR: Raised when the source node is readonly.
Since:
DOM Level 3

getDomConfig

DOMConfiguration getDomConfig()
The configuration used when Document.normalizeDocument() is invoked.

Since:
DOM Level 3

normalizeDocument

void normalizeDocument()
This method acts as if the document was going through a save and load cycle, putting the document in a "normal" form. As a consequence, this method updates the replacement tree of EntityReference nodes and normalizes Text nodes, as defined in the method Node.normalize().
Otherwise, the actual result depends on the features being set on the Document.domConfig object and governing what operations actually take place. Noticeably this method could also make the document namespace well-formed according to the algorithm described in , check the character normalization, remove the CDATASection nodes, etc. See DOMConfiguration for details.
// Keep in the document
 the information defined // in the XML Information Set (Java example)
 DOMConfiguration docConfig = myDocument.getDomConfig();
 docConfig.setParameter("infoset", Boolean.TRUE);
 myDocument.normalizeDocument();

Mutation events, when supported, are generated to reflect the changes occurring on the document.
If errors occur during the invocation of this method, such as an attempt to update a read-only node or a Node.nodeName contains an invalid character according to the XML version in use, errors or warnings (DOMError.SEVERITY_ERROR or DOMError.SEVERITY_WARNING) will be reported using the DOMErrorHandler object associated with the "error-handler " parameter. Note this method might also report fatal errors ( DOMError.SEVERITY_FATAL_ERROR) if an implementation cannot recover from an error.

Since:
DOM Level 3

renameNode

Node renameNode(Node n,
                String namespaceURI,
                String qualifiedName)
                throws DOMException
Rename an existing node of type ELEMENT_NODE or ATTRIBUTE_NODE.
When possible this simply changes the name of the given node, otherwise this creates a new node with the specified name and replaces the existing node with the new node as described below.
If simply changing the name of the given node is not possible, the following operations are performed: a new node is created, any registered event listener is registered on the new node, any user data attached to the old node is removed from that node, the old node is removed from its parent if it has one, the children are moved to the new node, if the renamed node is an Element its attributes are moved to the new node, the new node is inserted at the position the old node used to have in its parent's child nodes list if it has one, the user data that was attached to the old node is attached to the new node.
When the node being renamed is an Element only the specified attributes are moved, default attributes originated from the DTD are updated according to the new element name. In addition, the implementation may update default attributes from other schemas. Applications should use Document.normalizeDocument() to guarantee these attributes are up-to-date.
When the node being renamed is an Attr that is attached to an Element, the node is first removed from the Element attributes map. Then, once renamed, either by modifying the existing node or creating a new one as described above, it is put back.
In addition,
  • a user data event NODE_RENAMED is fired,
  • when the implementation supports the feature "MutationNameEvents", each mutation operation involved in this method fires the appropriate event, and in the end the event { http://www.w3.org/2001/xml-events, DOMElementNameChanged} or { http://www.w3.org/2001/xml-events, DOMAttributeNameChanged} is fired.

Parameters:
n - The node to rename.
namespaceURI - The new namespace URI.
qualifiedName - The new qualified name.
Returns:
The renamed node. This is either the specified node or the new node that was created to replace the specified node.
Throws:
DOMException - NOT_SUPPORTED_ERR: Raised when the type of the specified node is neither ELEMENT_NODE nor ATTRIBUTE_NODE, or if the implementation does not support the renaming of the document element.
INVALID_CHARACTER_ERR: Raised if the new qualified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
WRONG_DOCUMENT_ERR: Raised when the specified node was created from a different document than this document.
NAMESPACE_ERR: Raised if the qualifiedName is a malformed qualified name, if the qualifiedName has a prefix and the namespaceURI is null, or if the qualifiedName has a prefix that is "xml" and the namespaceURI is different from " http://www.w3.org/XML/1998/namespace" [XML Namespaces] . Also raised, when the node being renamed is an attribute, if the qualifiedName, or its prefix, is "xmlns" and the namespaceURI is different from "http://www.w3.org/2000/xmlns/".
Since:
DOM Level 3
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DocumentFragment (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface DocumentFragment

All Superinterfaces:
Node
public interface DocumentFragment
extends Node

DocumentFragment is a "lightweight" or "minimal" Document object. It is very common to want to be able to extract a portion of a document's tree or to create a new fragment of a document. Imagine implementing a user command like cut or rearranging a document by moving fragments around. It is desirable to have an object which can hold such fragments and it is quite natural to use a Node for this purpose. While it is true that a Document object could fulfill this role, a Document object can potentially be a heavyweight object, depending on the underlying implementation. What is really needed for this is a very lightweight object. DocumentFragment is such an object.

Furthermore, various operations -- such as inserting nodes as children of another Node -- may take DocumentFragment objects as arguments; this results in all the child nodes of the DocumentFragment being moved to the child list of this node.

The children of a DocumentFragment node are zero or more nodes representing the tops of any sub-trees defining the structure of the document. DocumentFragment nodes do not need to be well-formed XML documents (although they do need to follow the rules imposed upon well-formed XML parsed entities, which can have multiple top nodes). For example, a DocumentFragment might have only one child and that child node could be a Text node. Such a structure model represents neither an HTML document nor a well-formed XML document.

When a DocumentFragment is inserted into a Document (or indeed any other Node that may take children) the children of the DocumentFragment and not the DocumentFragment itself are inserted into the Node. This makes the DocumentFragment very useful when the user wishes to create nodes that are siblings; the DocumentFragment acts as the parent of these nodes so that the user can use the standard methods from the Node interface, such as Node.insertBefore and Node.appendChild.

See also the Document Object Model (DOM) Level 3 Core Specification.

Field Summary
Modifier and Type Field and Description
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DocumentType (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface DocumentType

All Superinterfaces:
Node
public interface DocumentType
extends Node

Each Document has a doctype attribute whose value is either null or a DocumentType object. The DocumentType interface in the DOM Core provides an interface to the list of entities that are defined for the document, and little else because the effect of namespaces and the various XML schema efforts on DTD representation are not clearly understood as of this writing.

DOM Level 3 doesn't support editing DocumentType nodes. DocumentType nodes are read-only.

See also the Document Object Model (DOM) Level 3 Core Specification.

Field Summary
Modifier and Type Field and Description
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
Modifier and Type | Method and Description
NamedNodeMap | getEntities() A NamedNodeMap containing the general entities, both external and internal, declared in the DTD.
String | getInternalSubset() The internal subset as a string, or null if there is none.
String | getName() The name of DTD; i.e., the name immediately following the DOCTYPE keyword.
NamedNodeMap | getNotations() A NamedNodeMap containing the notations declared in the DTD.
String | getPublicId() The public identifier of the external subset.
String | getSystemId() The system identifier of the external subset.
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Method Detail

getName

String getName()
The name of DTD; i.e., the name immediately following the DOCTYPE keyword.

getEntities

NamedNodeMap getEntities()
A NamedNodeMap containing the general entities, both external and internal, declared in the DTD. Parameter entities are not contained. Duplicates are discarded. For example in:
<!DOCTYPE
 ex SYSTEM "ex.dtd" [ <!ENTITY foo "foo"> <!ENTITY bar
 "bar"> <!ENTITY bar "bar2"> <!ENTITY % baz "baz">
 ]> <ex/>
the interface provides access to foo and the first declaration of bar but not the second declaration of bar or baz. Every node in this map also implements the Entity interface.
The DOM Level 2 does not support editing entities, therefore entities cannot be altered in any way.

getNotations

NamedNodeMap getNotations()
A NamedNodeMap containing the notations declared in the DTD. Duplicates are discarded. Every node in this map also implements the Notation interface.
The DOM Level 2 does not support editing notations, therefore notations cannot be altered in any way.

getPublicId

String getPublicId()
The public identifier of the external subset.

Since:
DOM Level 2

getSystemId

String getSystemId()
The system identifier of the external subset. This may be an absolute URI or not.

Since:
DOM Level 2

getInternalSubset

String getInternalSubset()
The internal subset as a string, or null if there is none. This is does not contain the delimiting square brackets.

Note: The actual content returned depends on how much information is available to the implementation. This may vary depending on various parameters, including the XML processor used to build the document.

Since:
DOM Level 2
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DOMConfiguration (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface DOMConfiguration

public interface DOMConfiguration

The DOMConfiguration interface represents the configuration of a document and maintains a table of recognized parameters. Using the configuration, it is possible to change Document.normalizeDocument() behavior, such as replacing the CDATASection nodes with Text nodes or specifying the type of the schema that must be used when the validation of the Document is requested. DOMConfiguration objects are also used in [DOM Level 3 Load and Save] in the DOMParser and DOMSerializer interfaces.

The parameter names used by the DOMConfiguration object are defined throughout the DOM Level 3 specifications. Names are case-insensitive. To avoid possible conflicts, as a convention, names referring to parameters defined outside the DOM specification should be made unique. Because parameters are exposed as properties in names are recommended to follow the section 5.16 Identifiers of [Unicode] with the addition of the character '-' (HYPHEN-MINUS) but it is not enforced by the DOM implementation. DOM Level 3 Core Implementations are required to recognize all parameters defined in this specification. Some parameter values may also be required to be supported by the implementation. Refer to the definition of the parameter to know if a value must be supported or not.

Note: Parameters are similar to features and properties used in SAX2 [SAX].

The following list of parameters defined in the DOM:

"canonical-form"
true
[optional] Canonicalize the document according to the rules specified in [Canonical XML], such as removing the DocumentType node (if any) from the tree, or removing superfluous namespace declarations from each element. Note that this is limited to what can be represented in the DOM; in particular, there is no way to specify the order of the attributes in the DOM. In addition, Setting this parameter to true will also set the state of the parameters listed below. Later changes to the state of one of those parameters will revert "canonical-form" back to false. Parameters set to false: "entities", " normalize-characters", "cdata-sections". Parameters set to true: "namespaces", "namespace-declarations", "well-formed", "element-content-whitespace". Other parameters are not changed unless explicitly specified in the description of the parameters.
false
[required] (default)Do not canonicalize the document.
"cdata-sections"
true
[required] (default)Keep CDATASection nodes in the document.
false
[required]Transform CDATASection nodes in the document into Text nodes. The new Text node is then combined with any adjacent Text node.
"check-character-normalization"
true
[optional] Check if the characters in the document are fully normalized, as defined in appendix B of [XML 1.1]. When a sequence of characters is encountered that fails normalization checking, an error with the DOMError.type equals to "check-character-normalization-failure" is issued.
false
[required] (default)Do not check if characters are normalized.
"comments"
true
[required] (default)Keep Comment nodes in the document.
false
[required]Discard Comment nodes in the document.
"datatype-normalization"
true
[optional] Expose schema normalized values in the tree, such as XML Schema normalized values in the case of XML Schema. Since this parameter requires to have schema information, the "validate" parameter will also be set to true. Having this parameter activated when "validate" is false has no effect and no schema-normalization will happen.

Note: Since the document contains the result of the XML 1.0 processing, this parameter does not apply to attribute value normalization as defined in section 3.3.3 of [XML 1.0] and is only meant for schema languages other than Document Type Definition (DTD).

false
[required] (default) Do not perform schema normalization on the tree.
"element-content-whitespace"
true
[required] (default)Keep all whitespaces in the document.
false
[optional] Discard all Text nodes that contain whitespaces in element content, as described in [element content whitespace]. The implementation is expected to use the attribute Text.isElementContentWhitespace to determine if a Text node should be discarded or not.
"entities"
true
[required] (default)Keep EntityReference nodes in the document.
false
[required] Remove all EntityReference nodes from the document, putting the entity expansions directly in their place. Text nodes are normalized, as defined in Node.normalize. Only unexpanded entity references are kept in the document.

Note: This parameter does not affect Entity nodes.

"error-handler"
[required] Contains a DOMErrorHandler object. If an error is encountered in the document, the implementation will call back the DOMErrorHandler registered using this parameter. The implementation may provide a default DOMErrorHandler object. When called, DOMError.relatedData will contain the closest node to where the error occurred. If the implementation is unable to determine the node where the error occurs, DOMError.relatedData will contain the Document node. Mutations to the document from within an error handler will result in implementation dependent behavior.
"infoset"
true
[required]Keep in the document the information defined in the XML Information Set [XML Information Set] .This forces the following parameters to false: " validate-if-schema", "entities", "datatype-normalization", "cdata-sections ".This forces the following parameters to true: " namespace-declarations", "well-formed", "element-content-whitespace", " comments", "namespaces".Other parameters are not changed unless explicitly specified in the description of the parameters. Note that querying this parameter with getParameter returns true only if the individual parameters specified above are appropriately set.
false
Setting infoset to false has no effect.
"namespaces"
true
[required] (default) Perform the namespace processing as defined in .
false
[optional] Do not perform the namespace processing.
"namespace-declarations"
This parameter has no effect if the parameter "namespaces" is set to false.
true
[required] (default) Include namespace declaration attributes, specified or defaulted from the schema, in the document. See also the sections "Declaring Namespaces" in [XML Namespaces] and [XML Namespaces 1.1] .
false
[required]Discard all namespace declaration attributes. The namespace prefixes ( Node.prefix) are retained even if this parameter is set to false.
"normalize-characters"
true
[optional] Fully normalized the characters in the document as defined in appendix B of [XML 1.1].
false
[required] (default)Do not perform character normalization.
"schema-location"
[optional] Represent a DOMString object containing a list of URIs, separated by whitespaces (characters matching the nonterminal production S defined in section 2.3 [XML 1.0]), that represents the schemas against which validation should occur, i.e. the current schema. The types of schemas referenced in this list must match the type specified with schema-type, otherwise the behavior of an implementation is undefined. The schemas specified using this property take precedence to the schema information specified in the document itself. For namespace aware schema, if a schema specified using this property and a schema specified in the document instance (i.e. using the schemaLocation attribute) in a schema document (i.e. using schema import mechanisms) share the same targetNamespace, the schema specified by the user using this property will be used. If two schemas specified using this property share the same targetNamespace or have no namespace, the behavior is implementation dependent. If no location has been provided, this parameter is null.

Note: The "schema-location" parameter is ignored unless the "schema-type" parameter value is set. It is strongly recommended that Document.documentURI will be set so that an implementation can successfully resolve any external entities referenced.

"schema-type"
[optional] Represent a DOMString object containing an absolute URI and representing the type of the schema language used to validate a document against. Note that no lexical checking is done on the absolute URI. If this parameter is not set, a default value may be provided by the implementation, based on the schema languages supported and on the schema language used at load time. If no value is provided, this parameter is null.

Note: For XML Schema [XML Schema Part 1] , applications must use the value "http://www.w3.org/2001/XMLSchema". For XML DTD [XML 1.0], applications must use the value "http://www.w3.org/TR/REC-xml". Other schema languages are outside the scope of the W3C and therefore should recommend an absolute URI in order to use this method.

"split-cdata-sections"
true
[required] (default)Split CDATA sections containing the CDATA section termination marker ']]>'. When a CDATA section is split a warning is issued with a DOMError.type equals to "cdata-sections-splitted" and DOMError.relatedData equals to the first CDATASection node in document order resulting from the split.
false
[required]Signal an error if a CDATASection contains an unrepresentable character.
"validate"
true
[optional] Require the validation against a schema (i.e. XML schema, DTD, any other type or representation of schema) of the document as it is being normalized as defined by [XML 1.0]. If validation errors are found, or no schema was found, the error handler is notified. Schema-normalized values will not be exposed according to the schema in used unless the parameter "datatype-normalization" is true. This parameter will reevaluate:
  • Attribute nodes with Attr.specified equals to false, as specified in the description of the Attr interface;
  • The value of the attribute Text.isElementContentWhitespace for all Text nodes;
  • The value of the attribute Attr.isId for all Attr nodes;
  • The attributes Element.schemaTypeInfo and Attr.schemaTypeInfo.

Note: "validate-if-schema" and "validate" are mutually exclusive, setting one of them to true will set the other one to false. Applications should also consider setting the parameter "well-formed" to true, which is the default for that option, when validating the document.

false
[required] (default) Do not accomplish schema processing, including the internal subset processing. Default attribute values information are kept. Note that validation might still happen if "validate-if-schema" is true .
"validate-if-schema"
true
[optional]Enable validation only if a declaration for the document element can be found in a schema (independently of where it is found, i.e. XML schema, DTD, or any other type or representation of schema). If validation is enabled, this parameter has the same behavior as the parameter "validate" set to true.

Note: "validate-if-schema" and "validate" are mutually exclusive, setting one of them to true will set the other one to false.

false
[required] (default) No schema processing should be performed if the document has a schema, including internal subset processing. Default attribute values information are kept. Note that validation must still happen if "validate " is true.
"well-formed"
true
[required] (default) Check if all nodes are XML well formed according to the XML version in use in Document.xmlVersion:
  • check if the attribute Node.nodeName contains invalid characters according to its node type and generate a DOMError of type "wf-invalid-character-in-node-name", with a DOMError.SEVERITY_ERROR severity, if necessary;
  • check if the text content inside Attr, Element, Comment, Text, CDATASection nodes for invalid characters and generate a DOMError of type "wf-invalid-character", with a DOMError.SEVERITY_ERROR severity, if necessary;
  • check if the data inside ProcessingInstruction nodes for invalid characters and generate a DOMError of type "wf-invalid-character", with a DOMError.SEVERITY_ERROR severity, if necessary;
false
[optional] Do not check for XML well-formedness.

The resolution of the system identifiers associated with entities is done using Document.documentURI. However, when the feature "LS" defined in [DOM Level 3 Load and Save] is supported by the DOM implementation, the parameter "resource-resolver" can also be used on DOMConfiguration objects attached to Document nodes. If this parameter is set, Document.normalizeDocument() will invoke the resource resolver instead of using Document.documentURI.

See also the Document Object Model (DOM) Level 3 Core Specification.

Since:
DOM Level 3

Method Summary
Modifier and Type | Method and Description
boolean | canSetParameter(String name, Object value) Check if setting a parameter to a specific value is supported.
Object | getParameter(String name) Return the value of a parameter if known.
DOMStringList | getParameterNames() The list of the parameters supported by this DOMConfiguration object and for which at least one value can be set by the application.
void | setParameter(String name, Object value) Set the value of a parameter.

Method Detail

setParameter

void setParameter(String name,
                  Object value)
                  throws DOMException
Set the value of a parameter.

Parameters:
name - The name of the parameter to set.
value - The new value or null if the user wishes to unset the parameter. While the type of the value parameter is defined as DOMUserData, the object type must match the type defined by the definition of the parameter. For example, if the parameter is "error-handler", the value must be of type DOMErrorHandler.
Throws:
DOMException - NOT_FOUND_ERR: Raised when the parameter name is not recognized.
NOT_SUPPORTED_ERR: Raised when the parameter name is recognized but the requested value cannot be set.
TYPE_MISMATCH_ERR: Raised if the value type for this parameter name is incompatible with the expected value type.

getParameter

Object getParameter(String name)
                    throws DOMException
Return the value of a parameter if known.

Parameters:
name - The name of the parameter.
Returns:
The current object associated with the specified parameter or null if no object has been associated or if the parameter is not supported.
Throws:
DOMException - NOT_FOUND_ERR: Raised when the parameter name is not recognized.

canSetParameter

boolean canSetParameter(String name,
                        Object value)
Check if setting a parameter to a specific value is supported.

Parameters:
name - The name of the parameter to check.
value - An object. if null, the returned value is true.
Returns:
true if the parameter could be successfully set to the specified value, or false if the parameter is not recognized or the requested value is not supported. This does not change the current value of the parameter itself.

getParameterNames

DOMStringList getParameterNames()
The list of the parameters supported by this DOMConfiguration object and for which at least one value can be set by the application. Note that this list can also contain parameter names defined outside this specification.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DOMError (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface DOMError

public interface DOMError

DOMError is an interface that describes an error.

See also the Document Object Model (DOM) Level 3 Core Specification.

Since:
DOM Level 3

Field Summary
Modifier and Type | Field and Description
static short | SEVERITY_ERROR The severity of the error described by the DOMError is error.
static short | SEVERITY_FATAL_ERROR The severity of the error described by the DOMError is fatal error.
static short | SEVERITY_WARNING The severity of the error described by the DOMError is warning.
Method Summary
Modifier and Type | Method and Description
DOMLocator | getLocation() The location of the error.
String | getMessage() An implementation specific string describing the error that occurred.
Object | getRelatedData() The related DOMError.type dependent data if any.
Object | getRelatedException() The related platform dependent exception if any.
short | getSeverity() The severity of the error, either SEVERITY_WARNING, SEVERITY_ERROR, or SEVERITY_FATAL_ERROR.
String | getType() A DOMString indicating which related data is expected in relatedData.

Field Detail

SEVERITY_WARNING

static final short SEVERITY_WARNING
The severity of the error described by the DOMError is warning. A SEVERITY_WARNING will not cause the processing to stop, unless DOMErrorHandler.handleError() returns false.

See Also:
Constant Field Values

SEVERITY_ERROR

static final short SEVERITY_ERROR
The severity of the error described by the DOMError is error. A SEVERITY_ERROR may not cause the processing to stop if the error can be recovered, unless DOMErrorHandler.handleError() returns false.

See Also:
Constant Field Values

SEVERITY_FATAL_ERROR

static final short SEVERITY_FATAL_ERROR
The severity of the error described by the DOMError is fatal error. A SEVERITY_FATAL_ERROR will cause the normal processing to stop. The return value of DOMErrorHandler.handleError() is ignored unless the implementation chooses to continue, in which case the behavior becomes undefined.

See Also:
Constant Field Values
Method Detail

getSeverity

short getSeverity()
The severity of the error, either SEVERITY_WARNING, SEVERITY_ERROR, or SEVERITY_FATAL_ERROR.

getMessage

String getMessage()
An implementation specific string describing the error that occurred.

getType

String getType()
A DOMString indicating which related data is expected in relatedData. Users should refer to the specification of the error in order to find its DOMString type and relatedData definitions if any.

Note: As an example, Document.normalizeDocument() does generate warnings when the "split-cdata-sections" parameter is in use. Therefore, the method generates a SEVERITY_WARNING with type "cdata-sections-splitted" and the first CDATASection node in document order resulting from the split is returned by the relatedData attribute.

getRelatedException

Object getRelatedException()
The related platform dependent exception if any.

getRelatedData

Object getRelatedData()
The related DOMError.type dependent data if any.

getLocation

DOMLocator getLocation()
The location of the error.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DOMErrorHandler (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface DOMErrorHandler

public interface DOMErrorHandler

DOMErrorHandler is a callback interface that the DOM implementation can call when reporting errors that happens while processing XML data, or when doing some other processing (e.g. validating a document). A DOMErrorHandler object can be attached to a Document using the "error-handler" on the DOMConfiguration interface. If more than one error needs to be reported during an operation, the sequence and numbers of the errors passed to the error handler are implementation dependent.

The application that is using the DOM implementation is expected to implement this interface.

See also the Document Object Model (DOM) Level 3 Core Specification.

Since:
DOM Level 3

Method Summary
Modifier and Type | Method and Description
boolean | handleError(DOMError error) This method is called on the error handler when an error occurs.

Method Detail

handleError

boolean handleError(DOMError error)
This method is called on the error handler when an error occurs.
If an exception is thrown from this method, it is considered to be equivalent of returning true.

Parameters:
error - The error object that describes the error. This object may be reused by the DOM implementation across multiple calls to the handleError method.
Returns:
If the handleError method returns false, the DOM implementation should stop the current processing when possible. If the method returns true, the processing may continue depending on DOMError.severity.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DOMException (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Class DOMException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.w3c.dom.DOMException
All Implemented Interfaces:
Serializable
public class DOMException
extends RuntimeException

DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable). In general, DOM methods return specific error values in ordinary processing situations, such as out-of-bound errors when using NodeList.

Implementations should raise other exceptions under other circumstances. For example, implementations should raise an implementation-dependent exception if a null argument is passed when null was not expected.

Some languages and object systems do not support the concept of exceptions. For such systems, error conditions may be indicated using native error reporting mechanisms. For some bindings, for example, methods may return error codes similar to those listed in the corresponding method descriptions.

See also the Document Object Model (DOM) Level 3 Core Specification.

See Also:
Serialized Form

Field Summary
Modifier and Type | Field and Description
short | code
static short | DOMSTRING_SIZE_ERR If the specified range of text does not fit into a DOMString.
static short | HIERARCHY_REQUEST_ERR If any Node is inserted somewhere it doesn't belong.
static short | INDEX_SIZE_ERR If index or size is negative, or greater than the allowed value.
static short | INUSE_ATTRIBUTE_ERR If an attempt is made to add an attribute that is already in use elsewhere.
static short | INVALID_ACCESS_ERR If a parameter or an operation is not supported by the underlying object.
static short | INVALID_CHARACTER_ERR If an invalid or illegal character is specified, such as in an XML name.
static short | INVALID_MODIFICATION_ERR If an attempt is made to modify the type of the underlying object.
static short | INVALID_STATE_ERR If an attempt is made to use an object that is not, or is no longer, usable.
static short | NAMESPACE_ERR If an attempt is made to create or change an object in a way which is incorrect with regard to namespaces.
static short | NO_DATA_ALLOWED_ERR If data is specified for a Node which does not support data.
static short | NO_MODIFICATION_ALLOWED_ERR If an attempt is made to modify an object where modifications are not allowed.
static short | NOT_FOUND_ERR If an attempt is made to reference a Node in a context where it does not exist.
static short | NOT_SUPPORTED_ERR If the implementation does not support the requested type of object or operation.
static short | SYNTAX_ERR If an invalid or illegal string is specified.
static short | TYPE_MISMATCH_ERR If the type of an object is incompatible with the expected type of the parameter associated to the object.
static short | VALIDATION_ERR If a call to a method such as insertBefore or removeChild would make the Node invalid with respect to "partial validity", this exception would be raised and the operation would not be done.
static short | WRONG_DOCUMENT_ERR If a Node is used in a different document than the one that created it (that doesn't support it).
Constructor Summary
Constructor and Description
DOMException(short code, String message)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

code

public short code

INDEX_SIZE_ERR

public static final short INDEX_SIZE_ERR
If index or size is negative, or greater than the allowed value.

See Also:
Constant Field Values

DOMSTRING_SIZE_ERR

public static final short DOMSTRING_SIZE_ERR
If the specified range of text does not fit into a DOMString.

See Also:
Constant Field Values

HIERARCHY_REQUEST_ERR

public static final short HIERARCHY_REQUEST_ERR
If any Node is inserted somewhere it doesn't belong.

See Also:
Constant Field Values

WRONG_DOCUMENT_ERR

public static final short WRONG_DOCUMENT_ERR
If a Node is used in a different document than the one that created it (that doesn't support it).

See Also:
Constant Field Values

INVALID_CHARACTER_ERR

public static final short INVALID_CHARACTER_ERR
If an invalid or illegal character is specified, such as in an XML name.

See Also:
Constant Field Values

NO_DATA_ALLOWED_ERR

public static final short NO_DATA_ALLOWED_ERR
If data is specified for a Node which does not support data.

See Also:
Constant Field Values

NO_MODIFICATION_ALLOWED_ERR

public static final short NO_MODIFICATION_ALLOWED_ERR
If an attempt is made to modify an object where modifications are not allowed.

See Also:
Constant Field Values

NOT_FOUND_ERR

public static final short NOT_FOUND_ERR
If an attempt is made to reference a Node in a context where it does not exist.

See Also:
Constant Field Values

NOT_SUPPORTED_ERR

public static final short NOT_SUPPORTED_ERR
If the implementation does not support the requested type of object or operation.

See Also:
Constant Field Values

INUSE_ATTRIBUTE_ERR

public static final short INUSE_ATTRIBUTE_ERR
If an attempt is made to add an attribute that is already in use elsewhere.

See Also:
Constant Field Values

INVALID_STATE_ERR

public static final short INVALID_STATE_ERR
If an attempt is made to use an object that is not, or is no longer, usable.

Since:
DOM Level 2
See Also:
Constant Field Values

SYNTAX_ERR

public static final short SYNTAX_ERR
If an invalid or illegal string is specified.

Since:
DOM Level 2
See Also:
Constant Field Values

INVALID_MODIFICATION_ERR

public static final short INVALID_MODIFICATION_ERR
If an attempt is made to modify the type of the underlying object.

Since:
DOM Level 2
See Also:
Constant Field Values

NAMESPACE_ERR

public static final short NAMESPACE_ERR
If an attempt is made to create or change an object in a way which is incorrect with regard to namespaces.

Since:
DOM Level 2
See Also:
Constant Field Values

INVALID_ACCESS_ERR

public static final short INVALID_ACCESS_ERR
If a parameter or an operation is not supported by the underlying object.

Since:
DOM Level 2
See Also:
Constant Field Values

VALIDATION_ERR

public static final short VALIDATION_ERR
If a call to a method such as insertBefore or removeChild would make the Node invalid with respect to "partial validity", this exception would be raised and the operation would not be done. This code is used in [DOM Level 3 Validation] . Refer to this specification for further information.

Since:
DOM Level 3
See Also:
Constant Field Values

TYPE_MISMATCH_ERR

public static final short TYPE_MISMATCH_ERR
If the type of an object is incompatible with the expected type of the parameter associated to the object.

Since:
DOM Level 3
See Also:
Constant Field Values
Constructor Detail

DOMException

public DOMException(short code,
                    String message)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DOMImplementation (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface DOMImplementation

public interface DOMImplementation

The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.

See also the Document Object Model (DOM) Level 3 Core Specification.

Method Summary
Modifier and Type | Method and Description
Document | createDocument(String namespaceURI, String qualifiedName, DocumentType doctype) Creates a DOM Document object of the specified type with its document element.
DocumentType | createDocumentType(String qualifiedName, String publicId, String systemId) Creates an empty DocumentType node.
Object | getFeature(String feature, String version) This method returns a specialized object which implements the specialized APIs of the specified feature and version, as specified in DOM Features.
boolean | hasFeature(String feature, String version) Test if the DOM implementation implements a specific feature and version, as specified in DOM Features.

Method Detail

hasFeature

boolean hasFeature(String feature,
                   String version)
Test if the DOM implementation implements a specific feature and version, as specified in DOM Features.

Parameters:
feature - The name of the feature to test.
version - This is the version number of the feature to test.
Returns:
true if the feature is implemented in the specified version, false otherwise.

createDocumentType

DocumentType createDocumentType(String qualifiedName,
                                String publicId,
                                String systemId)
                                throws DOMException
Creates an empty DocumentType node. Entity declarations and notations are not made available. Entity reference expansions and default attribute additions do not occur..

Parameters:
qualifiedName - The qualified name of the document type to be created.
publicId - The external subset public identifier.
systemId - The external subset system identifier.
Returns:
A new DocumentType node with Node.ownerDocument set to null.
Throws:
DOMException - INVALID_CHARACTER_ERR: Raised if the specified qualified name is not an XML name according to [XML 1.0].
NAMESPACE_ERR: Raised if the qualifiedName is malformed.
NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
Since:
DOM Level 2

createDocument

Document createDocument(String namespaceURI,
                        String qualifiedName,
                        DocumentType doctype)
                        throws DOMException
Creates a DOM Document object of the specified type with its document element.
Note that based on the DocumentType given to create the document, the implementation may instantiate specialized Document objects that support additional features than the "Core", such as "HTML" [DOM Level 2 HTML] . On the other hand, setting the DocumentType after the document was created makes this very unlikely to happen. Alternatively, specialized Document creation methods, such as createHTMLDocument [DOM Level 2 HTML] , can be used to obtain specific types of Document objects.

Parameters:
namespaceURI - The namespace URI of the document element to create or null.
qualifiedName - The qualified name of the document element to be created or null.
doctype - The type of document to be created or null. When doctype is not null, its Node.ownerDocument attribute is set to the document being created.
Returns:
A new Document object with its document element. If the NamespaceURI, qualifiedName, and doctype are null, the returned Document is empty with no document element.
Throws:
DOMException - INVALID_CHARACTER_ERR: Raised if the specified qualified name is not an XML name according to [XML 1.0].
NAMESPACE_ERR: Raised if the qualifiedName is malformed, if the qualifiedName has a prefix and the namespaceURI is null, or if the qualifiedName is null and the namespaceURI is different from null, or if the qualifiedName has a prefix that is "xml" and the namespaceURI is different from " http://www.w3.org/XML/1998/namespace" [XML Namespaces] , or if the DOM implementation does not support the "XML" feature but a non-null namespace URI was provided, since namespaces were defined by XML.
WRONG_DOCUMENT_ERR: Raised if doctype has already been used with a different document or was created from a different implementation.
NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
Since:
DOM Level 2

getFeature

Object getFeature(String feature,
                  String version)
This method returns a specialized object which implements the specialized APIs of the specified feature and version, as specified in DOM Features. The specialized object may also be obtained by using binding-specific casting methods but is not necessarily expected to, as discussed in . This method also allow the implementation to provide specialized objects which do not support the DOMImplementation interface.

Parameters:
feature - The name of the feature requested. Note that any plus sign "+" prepended to the name of the feature will be ignored since it is not significant in the context of this method.
version - This is the version number of the feature to test.
Returns:
Returns an object which implements the specialized APIs of the specified feature and version, if any, or null if there is no object which implements interfaces associated with that feature. If the DOMObject returned by this method implements the DOMImplementation interface, it must delegate to the primary core DOMImplementation and not return results inconsistent with the primary core DOMImplementation such as hasFeature, getFeature, etc.
Since:
DOM Level 3
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DOMImplementationList (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface DOMImplementationList

public interface DOMImplementationList

The DOMImplementationList interface provides the abstraction of an ordered collection of DOM implementations, without defining or constraining how this collection is implemented. The items in the DOMImplementationList are accessible via an integral index, starting from 0.

See also the Document Object Model (DOM) Level 3 Core Specification.

Since:
DOM Level 3

Method Summary
Modifier and Type | Method and Description
int | getLength() The number of DOMImplementations in the list.
DOMImplementation | item(int index) Returns the indexth item in the collection.

Method Detail

item

DOMImplementation item(int index)
Returns the indexth item in the collection. If index is greater than or equal to the number of DOMImplementations in the list, this returns null.

Parameters:
index - Index into the collection.
Returns:
The DOMImplementation at the index th position in the DOMImplementationList, or null if that is not a valid index.

getLength

int getLength()
The number of DOMImplementations in the list. The range of valid child node indices is 0 to length-1 inclusive.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DOMImplementationSource (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface DOMImplementationSource

public interface DOMImplementationSource

This interface permits a DOM implementer to supply one or more implementations, based upon requested features and versions, as specified in . Each implemented DOMImplementationSource object is listed in the binding-specific list of available sources so that its DOMImplementation objects are made available.

See also the Document Object Model (DOM) Level 3 Core Specification.

Since:
DOM Level 3

Method Summary
Modifier and Type | Method and Description
DOMImplementation | getDOMImplementation(String features) A method to request the first DOM implementation that supports the specified features.
DOMImplementationList | getDOMImplementationList(String features) A method to request a list of DOM implementations that support the specified features and versions, as specified in .

Method Detail

getDOMImplementation

DOMImplementation getDOMImplementation(String features)
A method to request the first DOM implementation that supports the specified features.

Parameters:
features - A string that specifies which features and versions are required. This is a space separated list in which each feature is specified by its name optionally followed by a space and a version number. This method returns the first item of the list returned by getDOMImplementationList. As an example, the string "XML 3.0 Traversal +Events 2.0" will request a DOM implementation that supports the module "XML" for its 3.0 version, a module that support of the "Traversal" module for any version, and the module "Events" for its 2.0 version. The module "Events" must be accessible using the method Node.getFeature() and DOMImplementation.getFeature().
Returns:
The first DOM implementation that support the desired features, or null if this source has none.

getDOMImplementationList

DOMImplementationList getDOMImplementationList(String features)
A method to request a list of DOM implementations that support the specified features and versions, as specified in .

Parameters:
features - A string that specifies which features and versions are required. This is a space separated list in which each feature is specified by its name optionally followed by a space and a version number. This is something like: "XML 3.0 Traversal +Events 2.0"
Returns:
A list of DOM implementations that support the desired features.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DOMLocator (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface DOMLocator

public interface DOMLocator

DOMLocator is an interface that describes a location (e.g. where an error occurred).

See also the Document Object Model (DOM) Level 3 Core Specification.

Since:
DOM Level 3

Method Summary
Modifier and Type | Method and Description
int | getByteOffset() The byte offset into the input source this locator is pointing to or -1 if there is no byte offset available.
int | getColumnNumber() The column number this locator is pointing to, or -1 if there is no column number available.
int | getLineNumber() The line number this locator is pointing to, or -1 if there is no column number available.
Node | getRelatedNode() The node this locator is pointing to, or null if no node is available.
String | getUri() The URI this locator is pointing to, or null if no URI is available.
int | getUtf16Offset() The UTF-16, as defined in [Unicode] and Amendment 1 of [ISO/IEC 10646], offset into the input source this locator is pointing to or -1 if there is no UTF-16 offset available.

Method Detail

getLineNumber

int getLineNumber()
The line number this locator is pointing to, or -1 if there is no column number available.

getColumnNumber

int getColumnNumber()
The column number this locator is pointing to, or -1 if there is no column number available.

getByteOffset

int getByteOffset()
The byte offset into the input source this locator is pointing to or -1 if there is no byte offset available.

getUtf16Offset

int getUtf16Offset()
The UTF-16, as defined in [Unicode] and Amendment 1 of [ISO/IEC 10646], offset into the input source this locator is pointing to or -1 if there is no UTF-16 offset available.

getRelatedNode

Node getRelatedNode()
The node this locator is pointing to, or null if no node is available.

getUri

String getUri()
The URI this locator is pointing to, or null if no URI is available.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DOMStringList (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface DOMStringList

public interface DOMStringList

The DOMStringList interface provides the abstraction of an ordered collection of DOMString values, without defining or constraining how this collection is implemented. The items in the DOMStringList are accessible via an integral index, starting from 0.

See also the Document Object Model (DOM) Level 3 Core Specification.

Since:
DOM Level 3

Method Summary
Modifier and Type | Method and Description
boolean | contains(String str) Test if a string is part of this DOMStringList.
int | getLength() The number of DOMStrings in the list.
String | item(int index) Returns the indexth item in the collection.

Method Detail

item

String item(int index)
Returns the indexth item in the collection. If index is greater than or equal to the number of DOMStrings in the list, this returns null.

Parameters:
index - Index into the collection.
Returns:
The DOMString at the indexth position in the DOMStringList, or null if that is not a valid index.

getLength

int getLength()
The number of DOMStrings in the list. The range of valid child node indices is 0 to length-1 inclusive.

contains

boolean contains(String str)
Test if a string is part of this DOMStringList.

Parameters:
str - The string to look for.
Returns:
true if the string has been found, false otherwise.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


Element (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface Element

All Superinterfaces:
Node
All Known Subinterfaces:
Detail, DetailEntry, SOAPBody, SOAPBodyElement, SOAPElement, SOAPEnvelope, SOAPFault, SOAPFaultElement, SOAPHeader, SOAPHeaderElement
All Known Implementing Classes:
IIOMetadataNode
public interface Element
extends Node

The Element interface represents an element in an HTML or XML document. Elements may have attributes associated with them; since the Element interface inherits from Node, the generic Node interface attribute attributes may be used to retrieve the set of all attributes for an element. There are methods on the Element interface to retrieve either an Attr object by name or an attribute value by name. In XML, where an attribute value may contain entity references, an Attr object should be retrieved to examine the possibly fairly complex sub-tree representing the attribute value. On the other hand, in HTML, where all attributes have simple string values, methods to directly access an attribute value can safely be used as a convenience.

Note: In DOM Level 2, the method normalize is inherited from the Node interface where it was moved.

See also the Document Object Model (DOM) Level 3 Core Specification.

Field Summary
Modifier and Type Field and Description
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
Modifier and Type | Method and Description
String | getAttribute(String name) Retrieves an attribute value by name.
Attr | getAttributeNode(String name) Retrieves an attribute node by name.
Attr | getAttributeNodeNS(String namespaceURI, String localName) Retrieves an Attr node by local name and namespace URI.
String | getAttributeNS(String namespaceURI, String localName) Retrieves an attribute value by local name and namespace URI.
NodeList | getElementsByTagName(String name) Returns a NodeList of all descendant Elements with a given tag name, in document order.
NodeList | getElementsByTagNameNS(String namespaceURI, String localName) Returns a NodeList of all the descendant Elements with a given local name and namespace URI in document order.
TypeInfo | getSchemaTypeInfo() The type information associated with this element.
String | getTagName() The name of the element.
boolean | hasAttribute(String name) Returns true when an attribute with a given name is specified on this element or has a default value, false otherwise.
boolean | hasAttributeNS(String namespaceURI, String localName) Returns true when an attribute with a given local name and namespace URI is specified on this element or has a default value, false otherwise.
void | removeAttribute(String name) Removes an attribute by name.
Attr | removeAttributeNode(Attr oldAttr) Removes the specified attribute node.
void | removeAttributeNS(String namespaceURI, String localName) Removes an attribute by local name and namespace URI.
void | setAttribute(String name, String value) Adds a new attribute.
Attr | setAttributeNode(Attr newAttr) Adds a new attribute node.
Attr | setAttributeNodeNS(Attr newAttr) Adds a new attribute.
void | setAttributeNS(String namespaceURI, String qualifiedName, String value) Adds a new attribute.
void | setIdAttribute(String name, boolean isId) If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
void | setIdAttributeNode(Attr idAttr, boolean isId) If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
void | setIdAttributeNS(String namespaceURI, String localName, boolean isId) If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Method Detail

getTagName

String getTagName()
The name of the element. If Node.localName is different from null, this attribute is a qualified name. For example, in:
 <elementExample id="demo"> ...
 </elementExample> ,
tagName has the value "elementExample". Note that this is case-preserving in XML, as are all of the operations of the DOM. The HTML DOM returns the tagName of an HTML element in the canonical uppercase form, regardless of the case in the source HTML document.

getAttribute

String getAttribute(String name)
Retrieves an attribute value by name.

Parameters:
name - The name of the attribute to retrieve.
Returns:
The Attr value as a string, or the empty string if that attribute does not have a specified or default value.

setAttribute

void setAttribute(String name,
                  String value)
                  throws DOMException
Adds a new attribute. If an attribute with that name is already present in the element, its value is changed to be that of the value parameter. This value is a simple string; it is not parsed as it is being set. So any markup (such as syntax to be recognized as an entity reference) is treated as literal text, and needs to be appropriately escaped by the implementation when it is written out. In order to assign an attribute value that contains entity references, the user must create an Attr node plus any Text and EntityReference nodes, build the appropriate subtree, and use setAttributeNode to assign it as the value of an attribute.
To set an attribute with a qualified name and namespace URI, use the setAttributeNS method.

Parameters:
name - The name of the attribute to create or alter.
value - Value to set in string form.
Throws:
DOMException - INVALID_CHARACTER_ERR: Raised if the specified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

removeAttribute

void removeAttribute(String name)
                     throws DOMException
Removes an attribute by name. If a default value for the removed attribute is defined in the DTD, a new attribute immediately appears with the default value as well as the corresponding namespace URI, local name, and prefix when applicable. The implementation may handle default values from other schemas similarly but applications should use Document.normalizeDocument() to guarantee this information is up-to-date.
If no attribute with this name is found, this method has no effect.
To remove an attribute by local name and namespace URI, use the removeAttributeNS method.

Parameters:
name - The name of the attribute to remove.
Throws:
DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

getAttributeNode

Attr getAttributeNode(String name)
Retrieves an attribute node by name.
To retrieve an attribute node by qualified name and namespace URI, use the getAttributeNodeNS method.

Parameters:
name - The name (nodeName) of the attribute to retrieve.
Returns:
The Attr node with the specified name ( nodeName) or null if there is no such attribute.

setAttributeNode

Attr setAttributeNode(Attr newAttr)
                      throws DOMException
Adds a new attribute node. If an attribute with that name ( nodeName) is already present in the element, it is replaced by the new one. Replacing an attribute node by itself has no effect.
To add a new attribute node with a qualified name and namespace URI, use the setAttributeNodeNS method.

Parameters:
newAttr - The Attr node to add to the attribute list.
Returns:
If the newAttr attribute replaces an existing attribute, the replaced Attr node is returned, otherwise null is returned.
Throws:
DOMException - WRONG_DOCUMENT_ERR: Raised if newAttr was created from a different document than the one that created the element.
NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
INUSE_ATTRIBUTE_ERR: Raised if newAttr is already an attribute of another Element object. The DOM user must explicitly clone Attr nodes to re-use them in other elements.

removeAttributeNode

Attr removeAttributeNode(Attr oldAttr)
                         throws DOMException
Removes the specified attribute node. If a default value for the removed Attr node is defined in the DTD, a new node immediately appears with the default value as well as the corresponding namespace URI, local name, and prefix when applicable. The implementation may handle default values from other schemas similarly but applications should use Document.normalizeDocument() to guarantee this information is up-to-date.

Parameters:
oldAttr - The Attr node to remove from the attribute list.
Returns:
The Attr node that was removed.
Throws:
DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
NOT_FOUND_ERR: Raised if oldAttr is not an attribute of the element.

getElementsByTagName

NodeList getElementsByTagName(String name)
Returns a NodeList of all descendant Elements with a given tag name, in document order.

Parameters:
name - The name of the tag to match on. The special value "*" matches all tags.
Returns:
A list of matching Element nodes.

getAttributeNS

String getAttributeNS(String namespaceURI,
                      String localName)
                      throws DOMException
Retrieves an attribute value by local name and namespace URI.
Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.

Parameters:
namespaceURI - The namespace URI of the attribute to retrieve.
localName - The local name of the attribute to retrieve.
Returns:
The Attr value as a string, or the empty string if that attribute does not have a specified or default value.
Throws:
DOMException - NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
Since:
DOM Level 2

setAttributeNS

void setAttributeNS(String namespaceURI,
                    String qualifiedName,
                    String value)
                    throws DOMException
Adds a new attribute. If an attribute with the same local name and namespace URI is already present on the element, its prefix is changed to be the prefix part of the qualifiedName, and its value is changed to be the value parameter. This value is a simple string; it is not parsed as it is being set. So any markup (such as syntax to be recognized as an entity reference) is treated as literal text, and needs to be appropriately escaped by the implementation when it is written out. In order to assign an attribute value that contains entity references, the user must create an Attr node plus any Text and EntityReference nodes, build the appropriate subtree, and use setAttributeNodeNS or setAttributeNode to assign it as the value of an attribute.
Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.

Parameters:
namespaceURI - The namespace URI of the attribute to create or alter.
qualifiedName - The qualified name of the attribute to create or alter.
value - The value to set in string form.
Throws:
DOMException - INVALID_CHARACTER_ERR: Raised if the specified qualified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
NAMESPACE_ERR: Raised if the qualifiedName is malformed per the Namespaces in XML specification, if the qualifiedName has a prefix and the namespaceURI is null, if the qualifiedName has a prefix that is "xml" and the namespaceURI is different from " http://www.w3.org/XML/1998/namespace", if the qualifiedName or its prefix is "xmlns" and the namespaceURI is different from "http://www.w3.org/2000/xmlns/", or if the namespaceURI is "http://www.w3.org/2000/xmlns/" and neither the qualifiedName nor its prefix is "xmlns".
NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
Since:
DOM Level 2

removeAttributeNS

void removeAttributeNS(String namespaceURI,
                       String localName)
                       throws DOMException
Removes an attribute by local name and namespace URI. If a default value for the removed attribute is defined in the DTD, a new attribute immediately appears with the default value as well as the corresponding namespace URI, local name, and prefix when applicable. The implementation may handle default values from other schemas similarly but applications should use Document.normalizeDocument() to guarantee this information is up-to-date.
If no attribute with this local name and namespace URI is found, this method has no effect.
Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.

Parameters:
namespaceURI - The namespace URI of the attribute to remove.
localName - The local name of the attribute to remove.
Throws:
DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
Since:
DOM Level 2

getAttributeNodeNS

Attr getAttributeNodeNS(String namespaceURI,
                        String localName)
                        throws DOMException
Retrieves an Attr node by local name and namespace URI.
Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.

Parameters:
namespaceURI - The namespace URI of the attribute to retrieve.
localName - The local name of the attribute to retrieve.
Returns:
The Attr node with the specified attribute local name and namespace URI or null if there is no such attribute.
Throws:
DOMException - NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
Since:
DOM Level 2

setAttributeNodeNS

Attr setAttributeNodeNS(Attr newAttr)
                        throws DOMException
Adds a new attribute. If an attribute with that local name and that namespace URI is already present in the element, it is replaced by the new one. Replacing an attribute node by itself has no effect.
Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.

Parameters:
newAttr - The Attr node to add to the attribute list.
Returns:
If the newAttr attribute replaces an existing attribute with the same local name and namespace URI, the replaced Attr node is returned, otherwise null is returned.
Throws:
DOMException - WRONG_DOCUMENT_ERR: Raised if newAttr was created from a different document than the one that created the element.
NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
INUSE_ATTRIBUTE_ERR: Raised if newAttr is already an attribute of another Element object. The DOM user must explicitly clone Attr nodes to re-use them in other elements.
NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
Since:
DOM Level 2

getElementsByTagNameNS

NodeList getElementsByTagNameNS(String namespaceURI,
                                String localName)
                                throws DOMException
Returns a NodeList of all the descendant Elements with a given local name and namespace URI in document order.

Parameters:
namespaceURI - The namespace URI of the elements to match on. The special value "*" matches all namespaces.
localName - The local name of the elements to match on. The special value "*" matches all local names.
Returns:
A new NodeList object containing all the matched Elements.
Throws:
DOMException - NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
Since:
DOM Level 2

hasAttribute

boolean hasAttribute(String name)
Returns true when an attribute with a given name is specified on this element or has a default value, false otherwise.

Parameters:
name - The name of the attribute to look for.
Returns:
true if an attribute with the given name is specified on this element or has a default value, false otherwise.
Since:
DOM Level 2

hasAttributeNS

boolean hasAttributeNS(String namespaceURI,
                       String localName)
                       throws DOMException
Returns true when an attribute with a given local name and namespace URI is specified on this element or has a default value, false otherwise.
Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.

Parameters:
namespaceURI - The namespace URI of the attribute to look for.
localName - The local name of the attribute to look for.
Returns:
true if an attribute with the given local name and namespace URI is specified or has a default value on this element, false otherwise.
Throws:
DOMException - NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
Since:
DOM Level 2

getSchemaTypeInfo

TypeInfo getSchemaTypeInfo()
The type information associated with this element.

Since:
DOM Level 3

setIdAttribute

void setIdAttribute(String name,
                    boolean isId)
                    throws DOMException
If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute . This affects the value of Attr.isId and the behavior of Document.getElementById, but does not change any schema that may be in use, in particular this does not affect the Attr.schemaTypeInfo of the specified Attr node. Use the value false for the parameter isId to undeclare an attribute for being a user-determined ID attribute.
To specify an attribute by local name and namespace URI, use the setIdAttributeNS method.

Parameters:
name - The name of the attribute.
isId - Whether the attribute is a of type ID.
Throws:
DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
NOT_FOUND_ERR: Raised if the specified node is not an attribute of this element.
Since:
DOM Level 3

setIdAttributeNS

void setIdAttributeNS(String namespaceURI,
                      String localName,
                      boolean isId)
                      throws DOMException
If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute . This affects the value of Attr.isId and the behavior of Document.getElementById, but does not change any schema that may be in use, in particular this does not affect the Attr.schemaTypeInfo of the specified Attr node. Use the value false for the parameter isId to undeclare an attribute for being a user-determined ID attribute.

Parameters:
namespaceURI - The namespace URI of the attribute.
localName - The local name of the attribute.
isId - Whether the attribute is a of type ID.
Throws:
DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
NOT_FOUND_ERR: Raised if the specified node is not an attribute of this element.
Since:
DOM Level 3

setIdAttributeNode

void setIdAttributeNode(Attr idAttr,
                        boolean isId)
                        throws DOMException
If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute . This affects the value of Attr.isId and the behavior of Document.getElementById, but does not change any schema that may be in use, in particular this does not affect the Attr.schemaTypeInfo of the specified Attr node. Use the value false for the parameter isId to undeclare an attribute for being a user-determined ID attribute.

Parameters:
idAttr - The attribute node.
isId - Whether the attribute is a of type ID.
Throws:
DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
NOT_FOUND_ERR: Raised if the specified node is not an attribute of this element.
Since:
DOM Level 3
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


Entity (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface Entity

All Superinterfaces:
Node
public interface Entity
extends Node

This interface represents a known entity, either parsed or unparsed, in an XML document. Note that this models the entity itself not the entity declaration.

The nodeName attribute that is inherited from Node contains the name of the entity.

An XML processor may choose to completely expand entities before the structure model is passed to the DOM; in this case there will be no EntityReference nodes in the document tree.

XML does not mandate that a non-validating XML processor read and process entity declarations made in the external subset or declared in parameter entities. This means that parsed entities declared in the external subset need not be expanded by some classes of applications, and that the replacement text of the entity may not be available. When the replacement text is available, the corresponding Entity node's child list represents the structure of that replacement value. Otherwise, the child list is empty.

DOM Level 3 does not support editing Entity nodes; if a user wants to make changes to the contents of an Entity, every related EntityReference node has to be replaced in the structure model by a clone of the Entity's contents, and then the desired changes must be made to each of those clones instead. Entity nodes and all their descendants are readonly.

An Entity node does not have any parent.

Note: If the entity contains an unbound namespace prefix, the namespaceURI of the corresponding node in the Entity node subtree is null. The same is true for EntityReference nodes that refer to this entity, when they are created using the createEntityReference method of the Document interface.

See also the Document Object Model (DOM) Level 3 Core Specification.

Field Summary
Modifier and Type Field and Description
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
Modifier and Type | Method and Description
String | getInputEncoding() An attribute specifying the encoding used for this entity at the time of parsing, when it is an external parsed entity.
String | getNotationName() For unparsed entities, the name of the notation for the entity.
String | getPublicId() The public identifier associated with the entity if specified, and null otherwise.
String | getSystemId() The system identifier associated with the entity if specified, and null otherwise.
String | getXmlEncoding() An attribute specifying, as part of the text declaration, the encoding of this entity, when it is an external parsed entity.
String | getXmlVersion() An attribute specifying, as part of the text declaration, the version number of this entity, when it is an external parsed entity.
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Method Detail

getPublicId

String getPublicId()
The public identifier associated with the entity if specified, and null otherwise.

getSystemId

String getSystemId()
The system identifier associated with the entity if specified, and null otherwise. This may be an absolute URI or not.

getNotationName

String getNotationName()
For unparsed entities, the name of the notation for the entity. For parsed entities, this is null.

getInputEncoding

String getInputEncoding()
An attribute specifying the encoding used for this entity at the time of parsing, when it is an external parsed entity. This is null if it an entity from the internal subset or if it is not known.

Since:
DOM Level 3

getXmlEncoding

String getXmlEncoding()
An attribute specifying, as part of the text declaration, the encoding of this entity, when it is an external parsed entity. This is null otherwise.

Since:
DOM Level 3

getXmlVersion

String getXmlVersion()
An attribute specifying, as part of the text declaration, the version number of this entity, when it is an external parsed entity. This is null otherwise.

Since:
DOM Level 3
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


EntityReference (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface EntityReference

All Superinterfaces:
Node
public interface EntityReference
extends Node

EntityReference nodes may be used to represent an entity reference in the tree. Note that character references and references to predefined entities are considered to be expanded by the HTML or XML processor so that characters are represented by their Unicode equivalent rather than by an entity reference. Moreover, the XML processor may completely expand references to entities while building the Document, instead of providing EntityReference nodes. If it does provide such nodes, then for an EntityReference node that represents a reference to a known entity an Entity exists, and the subtree of the EntityReference node is a copy of the Entity node subtree. However, the latter may not be true when an entity contains an unbound namespace prefix. In such a case, because the namespace prefix resolution depends on where the entity reference is, the descendants of the EntityReference node may be bound to different namespace URIs. When an EntityReference node represents a reference to an unknown entity, the node has no children and its replacement value, when used by Attr.value for example, is empty.

As for Entity nodes, EntityReference nodes and all their descendants are readonly.

Note: EntityReference nodes may cause element content and attribute value normalization problems when, such as in XML 1.0 and XML Schema, the normalization is performed after entity reference are expanded.

See also the Document Object Model (DOM) Level 3 Core Specification.

Field Summary
Modifier and Type Field and Description
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
Modifier and Type Method and Description
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NamedNodeMap (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface NamedNodeMap

public interface NamedNodeMap

Objects implementing the NamedNodeMap interface are used to represent collections of nodes that can be accessed by name. Note that NamedNodeMap does not inherit from NodeList; NamedNodeMaps are not maintained in any particular order. Objects contained in an object implementing NamedNodeMap may also be accessed by an ordinal index, but this is simply to allow convenient enumeration of the contents of a NamedNodeMap, and does not imply that the DOM specifies an order to these Nodes.

NamedNodeMap objects in the DOM are live.

See also the Document Object Model (DOM) Level 3 Core Specification.

Method Summary
Modifier and Type | Method and Description
int | getLength() The number of nodes in this map.
Node | getNamedItem(String name) Retrieves a node specified by name.
Node | getNamedItemNS(String namespaceURI, String localName) Retrieves a node specified by local name and namespace URI.
Node | item(int index) Returns the indexth item in the map.
Node | removeNamedItem(String name) Removes a node specified by name.
Node | removeNamedItemNS(String namespaceURI, String localName) Removes a node specified by local name and namespace URI.
Node | setNamedItem(Node arg) Adds a node using its nodeName attribute.
Node | setNamedItemNS(Node arg) Adds a node using its namespaceURI and localName.

Method Detail

getNamedItem

Node getNamedItem(String name)
Retrieves a node specified by name.

Parameters:
name - The nodeName of a node to retrieve.
Returns:
A Node (of any type) with the specified nodeName, or null if it does not identify any node in this map.

setNamedItem

Node setNamedItem(Node arg)
                  throws DOMException
Adds a node using its nodeName attribute. If a node with that name is already present in this map, it is replaced by the new one. Replacing a node by itself has no effect.
As the nodeName attribute is used to derive the name which the node must be stored under, multiple nodes of certain types (those that have a "special" string value) cannot be stored as the names would clash. This is seen as preferable to allowing nodes to be aliased.

Parameters:
arg - A node to store in this map. The node will later be accessible using the value of its nodeName attribute.
Returns:
If the new Node replaces an existing node the replaced Node is returned, otherwise null is returned.
Throws:
DOMException - WRONG_DOCUMENT_ERR: Raised if arg was created from a different document than the one that created this map.
NO_MODIFICATION_ALLOWED_ERR: Raised if this map is readonly.
INUSE_ATTRIBUTE_ERR: Raised if arg is an Attr that is already an attribute of another Element object. The DOM user must explicitly clone Attr nodes to re-use them in other elements.
HIERARCHY_REQUEST_ERR: Raised if an attempt is made to add a node doesn't belong in this NamedNodeMap. Examples would include trying to insert something other than an Attr node into an Element's map of attributes, or a non-Entity node into the DocumentType's map of Entities.

removeNamedItem

Node removeNamedItem(String name)
                     throws DOMException
Removes a node specified by name. When this map contains the attributes attached to an element, if the removed attribute is known to have a default value, an attribute immediately appears containing the default value as well as the corresponding namespace URI, local name, and prefix when applicable.

Parameters:
name - The nodeName of the node to remove.
Returns:
The node removed from this map if a node with such a name exists.
Throws:
DOMException - NOT_FOUND_ERR: Raised if there is no node named name in this map.
NO_MODIFICATION_ALLOWED_ERR: Raised if this map is readonly.

item

Node item(int index)
Returns the indexth item in the map. If index is greater than or equal to the number of nodes in this map, this returns null.

Parameters:
index - Index into this map.
Returns:
The node at the indexth position in the map, or null if that is not a valid index.

getLength

int getLength()
The number of nodes in this map. The range of valid child node indices is 0 to length-1 inclusive.

getNamedItemNS

Node getNamedItemNS(String namespaceURI,
                    String localName)
                    throws DOMException
Retrieves a node specified by local name and namespace URI.
Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.

Parameters:
namespaceURI - The namespace URI of the node to retrieve.
localName - The local name of the node to retrieve.
Returns:
A Node (of any type) with the specified local name and namespace URI, or null if they do not identify any node in this map.
Throws:
DOMException - NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
Since:
DOM Level 2

setNamedItemNS

Node setNamedItemNS(Node arg)
                    throws DOMException
Adds a node using its namespaceURI and localName. If a node with that namespace URI and that local name is already present in this map, it is replaced by the new one. Replacing a node by itself has no effect.
Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.

Parameters:
arg - A node to store in this map. The node will later be accessible using the value of its namespaceURI and localName attributes.
Returns:
If the new Node replaces an existing node the replaced Node is returned, otherwise null is returned.
Throws:
DOMException - WRONG_DOCUMENT_ERR: Raised if arg was created from a different document than the one that created this map.
NO_MODIFICATION_ALLOWED_ERR: Raised if this map is readonly.
INUSE_ATTRIBUTE_ERR: Raised if arg is an Attr that is already an attribute of another Element object. The DOM user must explicitly clone Attr nodes to re-use them in other elements.
HIERARCHY_REQUEST_ERR: Raised if an attempt is made to add a node doesn't belong in this NamedNodeMap. Examples would include trying to insert something other than an Attr node into an Element's map of attributes, or a non-Entity node into the DocumentType's map of Entities.
NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
Since:
DOM Level 2

removeNamedItemNS

Node removeNamedItemNS(String namespaceURI,
                       String localName)
                       throws DOMException
Removes a node specified by local name and namespace URI. A removed attribute may be known to have a default value when this map contains the attributes attached to an element, as returned by the attributes attribute of the Node interface. If so, an attribute immediately appears containing the default value as well as the corresponding namespace URI, local name, and prefix when applicable.
Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.

Parameters:
namespaceURI - The namespace URI of the node to remove.
localName - The local name of the node to remove.
Returns:
The node removed from this map if a node with such a local name and namespace URI exists.
Throws:
DOMException - NOT_FOUND_ERR: Raised if there is no node with the specified namespaceURI and localName in this map.
NO_MODIFICATION_ALLOWED_ERR: Raised if this map is readonly.
NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
Since:
DOM Level 2
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NameList (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface NameList

public interface NameList

The NameList interface provides the abstraction of an ordered collection of parallel pairs of name and namespace values (which could be null values), without defining or constraining how this collection is implemented. The items in the NameList are accessible via an integral index, starting from 0.

See also the Document Object Model (DOM) Level 3 Core Specification.

Since:
DOM Level 3

Method Summary
Modifier and Type | Method and Description
boolean | contains(String str) Test if a name is part of this NameList.
boolean | containsNS(String namespaceURI, String name) Test if the pair namespaceURI/name is part of this NameList.
int | getLength() The number of pairs (name and namespaceURI) in the list.
String | getName(int index) Returns the indexth name item in the collection.
String | getNamespaceURI(int index) Returns the indexth namespaceURI item in the collection.

Method Detail

getName

String getName(int index)
Returns the indexth name item in the collection.

Parameters:
index - Index into the collection.
Returns:
The name at the indexth position in the NameList, or null if there is no name for the specified index or if the index is out of range.

getNamespaceURI

String getNamespaceURI(int index)
Returns the indexth namespaceURI item in the collection.

Parameters:
index - Index into the collection.
Returns:
The namespace URI at the indexth position in the NameList, or null if there is no name for the specified index or if the index is out of range.

getLength

int getLength()
The number of pairs (name and namespaceURI) in the list. The range of valid child node indices is 0 to length-1 inclusive.

contains

boolean contains(String str)
Test if a name is part of this NameList.

Parameters:
str - The name to look for.
Returns:
true if the name has been found, false otherwise.

containsNS

boolean containsNS(String namespaceURI,
                   String name)
Test if the pair namespaceURI/name is part of this NameList.

Parameters:
namespaceURI - The namespace URI to look for.
name - The name to look for.
Returns:
true if the pair namespaceURI/name has been found, false otherwise.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


Node (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface Node

All Known Subinterfaces:
Attr, CDATASection, CharacterData, Comment, Detail, DetailEntry, Document, DocumentFragment, DocumentType, Element, Entity, EntityReference, Node, Notation, ProcessingInstruction, SOAPBody, SOAPBodyElement, SOAPElement, SOAPEnvelope, SOAPFault, SOAPFaultElement, SOAPHeader, SOAPHeaderElement, Text, Text
All Known Implementing Classes:
IIOMetadataNode, SOAPPart
public interface Node

The Node interface is the primary datatype for the entire Document Object Model. It represents a single node in the document tree. While all objects implementing the Node interface expose methods for dealing with children, not all objects implementing the Node interface may have children. For example, Text nodes may not have children, and adding children to such nodes results in a DOMException being raised.

The attributes nodeName, nodeValue and attributes are included as a mechanism to get at node information without casting down to the specific derived interface. In cases where there is no obvious mapping of these attributes for a specific nodeType (e.g., nodeValue for an Element or attributes for a Comment ), this returns null. Note that the specialized interfaces may contain additional and more convenient mechanisms to get and set the relevant information.

The values of nodeName, nodeValue, and attributes vary according to the node type as follows:

Interface | nodeName | nodeValue | attributes
Attr | same as Attr.name | same as Attr.value | null
CDATASection | "#cdata-section" | same as CharacterData.data, the content of the CDATA Section | null
Comment | "#comment" | same as CharacterData.data, the content of the comment | null
Document | "#document" | null | null
DocumentFragment | "#document-fragment" | null | null
DocumentType | same as DocumentType.name | null | null
Element | same as Element.tagName | null | NamedNodeMap
Entity | entity name | null | null
EntityReference | name of entity referenced | null | null
Notation | notation name | null | null
ProcessingInstruction | same as ProcessingInstruction.target | same as ProcessingInstruction.data | null
Text | "#text" | same as CharacterData.data, the content of the text node | null

See also the Document Object Model (DOM) Level 3 Core Specification.

Field Summary
Modifier and Type | Field and Description
static short | ATTRIBUTE_NODE The node is an Attr.
static short | CDATA_SECTION_NODE The node is a CDATASection.
static short | COMMENT_NODE The node is a Comment.
static short | DOCUMENT_FRAGMENT_NODE The node is a DocumentFragment.
static short | DOCUMENT_NODE The node is a Document.
static short | DOCUMENT_POSITION_CONTAINED_BY The node is contained by the reference node.
static short | DOCUMENT_POSITION_CONTAINS The node contains the reference node.
static short | DOCUMENT_POSITION_DISCONNECTED The two nodes are disconnected.
static short | DOCUMENT_POSITION_FOLLOWING The node follows the reference node.
static short | DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC The determination of preceding versus following is implementation-specific.
static short | DOCUMENT_POSITION_PRECEDING The second node precedes the reference node.
static short | DOCUMENT_TYPE_NODE The node is a DocumentType.
static short | ELEMENT_NODE The node is an Element.
static short | ENTITY_NODE The node is an Entity.
static short | ENTITY_REFERENCE_NODE The node is an EntityReference.
static short | NOTATION_NODE The node is a Notation.
static short | PROCESSING_INSTRUCTION_NODE The node is a ProcessingInstruction.
static short | TEXT_NODE The node is a Text node.
Method Summary
Modifier and Type | Method and Description
Node | appendChild(Node newChild) Adds the node newChild to the end of the list of children of this node.
Node | cloneNode(boolean deep) Returns a duplicate of this node, i.e., serves as a generic copy constructor for nodes.
short | compareDocumentPosition(Node other) Compares the reference node, i.e.
NamedNodeMap | getAttributes() A NamedNodeMap containing the attributes of this node (if it is an Element) or null otherwise.
String | getBaseURI() The absolute base URI of this node or null if the implementation wasn't able to obtain an absolute URI.
NodeList | getChildNodes() A NodeList that contains all children of this node.
Object | getFeature(String feature, String version) This method returns a specialized object which implements the specialized APIs of the specified feature and version, as specified in .
Node | getFirstChild() The first child of this node.
Node | getLastChild() The last child of this node.
String | getLocalName() Returns the local part of the qualified name of this node.
String | getNamespaceURI() The namespace URI of this node, or null if it is unspecified (see ).
Node | getNextSibling() The node immediately following this node.
String | getNodeName() The name of this node, depending on its type; see the table above.
short | getNodeType() A code representing the type of the underlying object, as defined above.
String | getNodeValue() The value of this node, depending on its type; see the table above.
Document | getOwnerDocument() The Document object associated with this node.
Node | getParentNode() The parent of this node.
String | getPrefix() The namespace prefix of this node, or null if it is unspecified.
Node | getPreviousSibling() The node immediately preceding this node.
String | getTextContent() This attribute returns the text content of this node and its descendants.
Object | getUserData(String key) Retrieves the object associated to a key on a this node.
boolean | hasAttributes() Returns whether this node (if it is an element) has any attributes.
boolean | hasChildNodes() Returns whether this node has any children.
Node | insertBefore(Node newChild, Node refChild) Inserts the node newChild before the existing child node refChild.
boolean | isDefaultNamespace(String namespaceURI) This method checks if the specified namespaceURI is the default namespace or not.
boolean | isEqualNode(Node arg) Tests whether two nodes are equal.
boolean | isSameNode(Node other) Returns whether this node is the same node as the given one.
boolean | isSupported(String feature, String version) Tests whether the DOM implementation implements a specific feature and that feature is supported by this node, as specified in .
String | lookupNamespaceURI(String prefix) Look up the namespace URI associated to the given prefix, starting from this node.
String | lookupPrefix(String namespaceURI) Look up the prefix associated to the given namespace URI, starting from this node.
void | normalize() Puts all Text nodes in the full depth of the sub-tree underneath this Node, including attribute nodes, into a "normal" form where only structure (e.g., elements, comments, processing instructions, CDATA sections, and entity references) separates Text nodes, i.e., there are neither adjacent Text nodes nor empty Text nodes.
Node | removeChild(Node oldChild) Removes the child node indicated by oldChild from the list of children, and returns it.
Node | replaceChild(Node newChild, Node oldChild) Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
void | setNodeValue(String nodeValue) The value of this node, depending on its type; see the table above.
void | setPrefix(String prefix) The namespace prefix of this node, or null if it is unspecified.
void | setTextContent(String textContent) This attribute returns the text content of this node and its descendants.
Object | setUserData(String key, Object data, UserDataHandler handler) Associate an object to a key on this node.

Field Detail

ELEMENT_NODE

static final short ELEMENT_NODE
The node is an Element.

See Also:
Constant Field Values

ATTRIBUTE_NODE

static final short ATTRIBUTE_NODE
The node is an Attr.

See Also:
Constant Field Values

TEXT_NODE

static final short TEXT_NODE
The node is a Text node.

See Also:
Constant Field Values

CDATA_SECTION_NODE

static final short CDATA_SECTION_NODE
The node is a CDATASection.

See Also:
Constant Field Values

ENTITY_REFERENCE_NODE

static final short ENTITY_REFERENCE_NODE
The node is an EntityReference.

See Also:
Constant Field Values

ENTITY_NODE

static final short ENTITY_NODE
The node is an Entity.

See Also:
Constant Field Values

PROCESSING_INSTRUCTION_NODE

static final short PROCESSING_INSTRUCTION_NODE
The node is a ProcessingInstruction.

See Also:
Constant Field Values

COMMENT_NODE

static final short COMMENT_NODE
The node is a Comment.

See Also:
Constant Field Values

DOCUMENT_NODE

static final short DOCUMENT_NODE
The node is a Document.

See Also:
Constant Field Values

DOCUMENT_TYPE_NODE

static final short DOCUMENT_TYPE_NODE
The node is a DocumentType.

See Also:
Constant Field Values

DOCUMENT_FRAGMENT_NODE

static final short DOCUMENT_FRAGMENT_NODE
The node is a DocumentFragment.

See Also:
Constant Field Values

NOTATION_NODE

static final short NOTATION_NODE
The node is a Notation.

See Also:
Constant Field Values

DOCUMENT_POSITION_DISCONNECTED

static final short DOCUMENT_POSITION_DISCONNECTED
The two nodes are disconnected. Order between disconnected nodes is always implementation-specific.

See Also:
Constant Field Values

DOCUMENT_POSITION_PRECEDING

static final short DOCUMENT_POSITION_PRECEDING
The second node precedes the reference node.

See Also:
Constant Field Values

DOCUMENT_POSITION_FOLLOWING

static final short DOCUMENT_POSITION_FOLLOWING
The node follows the reference node.

See Also:
Constant Field Values

DOCUMENT_POSITION_CONTAINS

static final short DOCUMENT_POSITION_CONTAINS
The node contains the reference node. A node which contains is always preceding, too.

See Also:
Constant Field Values

DOCUMENT_POSITION_CONTAINED_BY

static final short DOCUMENT_POSITION_CONTAINED_BY
The node is contained by the reference node. A node which is contained is always following, too.

See Also:
Constant Field Values

DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC

static final short DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC
The determination of preceding versus following is implementation-specific.

See Also:
Constant Field Values
Method Detail

getNodeName

String getNodeName()
The name of this node, depending on its type; see the table above.

getNodeValue

String getNodeValue()
                    throws DOMException
The value of this node, depending on its type; see the table above. When it is defined to be null, setting it has no effect, including if the node is read-only.

Throws:
DOMException - DOMSTRING_SIZE_ERR: Raised when it would return more characters than fit in a DOMString variable on the implementation platform.

setNodeValue

void setNodeValue(String nodeValue)
                  throws DOMException
The value of this node, depending on its type; see the table above. When it is defined to be null, setting it has no effect, including if the node is read-only.

Throws:
DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised when the node is readonly and if it is not defined to be null.

getNodeType

short getNodeType()
A code representing the type of the underlying object, as defined above.

getParentNode

Node getParentNode()
The parent of this node. All nodes, except Attr, Document, DocumentFragment, Entity, and Notation may have a parent. However, if a node has just been created and not yet added to the tree, or if it has been removed from the tree, this is null.

getChildNodes

NodeList getChildNodes()
A NodeList that contains all children of this node. If there are no children, this is a NodeList containing no nodes.

getFirstChild

Node getFirstChild()
The first child of this node. If there is no such node, this returns null.

getLastChild

Node getLastChild()
The last child of this node. If there is no such node, this returns null.

getPreviousSibling

Node getPreviousSibling()
The node immediately preceding this node. If there is no such node, this returns null.

getNextSibling

Node getNextSibling()
The node immediately following this node. If there is no such node, this returns null.

getAttributes

NamedNodeMap getAttributes()
A NamedNodeMap containing the attributes of this node (if it is an Element) or null otherwise.

getOwnerDocument

Document getOwnerDocument()
The Document object associated with this node. This is also the Document object used to create new nodes. When this node is a Document or a DocumentType which is not used with any Document yet, this is null.

Since:
DOM Level 2

insertBefore

Node insertBefore(Node newChild,
                  Node refChild)
                  throws DOMException
Inserts the node newChild before the existing child node refChild. If refChild is null, insert newChild at the end of the list of children.
If newChild is a DocumentFragment object, all of its children are inserted, in the same order, before refChild. If the newChild is already in the tree, it is first removed.

Note: Inserting a node before itself is implementation dependent.

Parameters:
newChild - The node to insert.
refChild - The reference node, i.e., the node before which the new node must be inserted.
Returns:
The node being inserted.
Throws:
DOMException - HIERARCHY_REQUEST_ERR: Raised if this node is of a type that does not allow children of the type of the newChild node, or if the node to insert is one of this node's ancestors or this node itself, or if this node is of type Document and the DOM application attempts to insert a second DocumentType or Element node.
WRONG_DOCUMENT_ERR: Raised if newChild was created from a different document than the one that created this node.
NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly or if the parent of the node being inserted is readonly.
NOT_FOUND_ERR: Raised if refChild is not a child of this node.
NOT_SUPPORTED_ERR: if this node is of type Document, this exception might be raised if the DOM implementation doesn't support the insertion of a DocumentType or Element node.
Since:
DOM Level 3

replaceChild

Node replaceChild(Node newChild,
                  Node oldChild)
                  throws DOMException
Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
If newChild is a DocumentFragment object, oldChild is replaced by all of the DocumentFragment children, which are inserted in the same order. If the newChild is already in the tree, it is first removed.

Note: Replacing a node with itself is implementation dependent.

Parameters:
newChild - The new node to put in the child list.
oldChild - The node being replaced in the list.
Returns:
The node replaced.
Throws:
DOMException - HIERARCHY_REQUEST_ERR: Raised if this node is of a type that does not allow children of the type of the newChild node, or if the node to put in is one of this node's ancestors or this node itself, or if this node is of type Document and the result of the replacement operation would add a second DocumentType or Element on the Document node.
WRONG_DOCUMENT_ERR: Raised if newChild was created from a different document than the one that created this node.
NO_MODIFICATION_ALLOWED_ERR: Raised if this node or the parent of the new node is readonly.
NOT_FOUND_ERR: Raised if oldChild is not a child of this node.
NOT_SUPPORTED_ERR: if this node is of type Document, this exception might be raised if the DOM implementation doesn't support the replacement of the DocumentType child or Element child.
Since:
DOM Level 3

removeChild

Node removeChild(Node oldChild)
                 throws DOMException
Removes the child node indicated by oldChild from the list of children, and returns it.

Parameters:
oldChild - The node being removed.
Returns:
The node removed.
Throws:
DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
NOT_FOUND_ERR: Raised if oldChild is not a child of this node.
NOT_SUPPORTED_ERR: if this node is of type Document, this exception might be raised if the DOM implementation doesn't support the removal of the DocumentType child or the Element child.
Since:
DOM Level 3

appendChild

Node appendChild(Node newChild)
                 throws DOMException
Adds the node newChild to the end of the list of children of this node. If the newChild is already in the tree, it is first removed.

Parameters:
newChild - The node to add.If it is a DocumentFragment object, the entire contents of the document fragment are moved into the child list of this node
Returns:
The node added.
Throws:
DOMException - HIERARCHY_REQUEST_ERR: Raised if this node is of a type that does not allow children of the type of the newChild node, or if the node to append is one of this node's ancestors or this node itself, or if this node is of type Document and the DOM application attempts to append a second DocumentType or Element node.
WRONG_DOCUMENT_ERR: Raised if newChild was created from a different document than the one that created this node.
NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly or if the previous parent of the node being inserted is readonly.
NOT_SUPPORTED_ERR: if the newChild node is a child of the Document node, this exception might be raised if the DOM implementation doesn't support the removal of the DocumentType child or Element child.
Since:
DOM Level 3

hasChildNodes

boolean hasChildNodes()
Returns whether this node has any children.

Returns:
Returns true if this node has any children, false otherwise.

cloneNode

Node cloneNode(boolean deep)
Returns a duplicate of this node, i.e., serves as a generic copy constructor for nodes. The duplicate node has no parent ( parentNode is null) and no user data. User data associated to the imported node is not carried over. However, if any UserDataHandlers has been specified along with the associated data these handlers will be called with the appropriate parameters before this method returns.
Cloning an Element copies all attributes and their values, including those generated by the XML processor to represent defaulted attributes, but this method does not copy any children it contains unless it is a deep clone. This includes text contained in an the Element since the text is contained in a child Text node. Cloning an Attr directly, as opposed to be cloned as part of an Element cloning operation, returns a specified attribute (specified is true). Cloning an Attr always clones its children, since they represent its value, no matter whether this is a deep clone or not. Cloning an EntityReference automatically constructs its subtree if a corresponding Entity is available, no matter whether this is a deep clone or not. Cloning any other type of node simply returns a copy of this node.
Note that cloning an immutable subtree results in a mutable copy, but the children of an EntityReference clone are readonly . In addition, clones of unspecified Attr nodes are specified. And, cloning Document, DocumentType, Entity, and Notation nodes is implementation dependent.

Parameters:
deep - If true, recursively clone the subtree under the specified node; if false, clone only the node itself (and its attributes, if it is an Element).
Returns:
The duplicate node.

normalize

void normalize()
Puts all Text nodes in the full depth of the sub-tree underneath this Node, including attribute nodes, into a "normal" form where only structure (e.g., elements, comments, processing instructions, CDATA sections, and entity references) separates Text nodes, i.e., there are neither adjacent Text nodes nor empty Text nodes. This can be used to ensure that the DOM view of a document is the same as if it were saved and re-loaded, and is useful when operations (such as XPointer [XPointer] lookups) that depend on a particular document tree structure are to be used. If the parameter "normalize-characters" of the DOMConfiguration object attached to the Node.ownerDocument is true, this method will also fully normalize the characters of the Text nodes.

Note: In cases where the document contains CDATASections, the normalize operation alone may not be sufficient, since XPointers do not differentiate between Text nodes and CDATASection nodes.

Since:
DOM Level 3

isSupported

boolean isSupported(String feature,
                    String version)
Tests whether the DOM implementation implements a specific feature and that feature is supported by this node, as specified in .

Parameters:
feature - The name of the feature to test.
version - This is the version number of the feature to test.
Returns:
Returns true if the specified feature is supported on this node, false otherwise.
Since:
DOM Level 2

getNamespaceURI

String getNamespaceURI()
The namespace URI of this node, or null if it is unspecified (see ).
This is not a computed value that is the result of a namespace lookup based on an examination of the namespace declarations in scope. It is merely the namespace URI given at creation time.
For nodes of any type other than ELEMENT_NODE and ATTRIBUTE_NODE and nodes created with a DOM Level 1 method, such as Document.createElement(), this is always null.

Note: Per the Namespaces in XML Specification [XML Namespaces] an attribute does not inherit its namespace from the element it is attached to. If an attribute is not explicitly given a namespace, it simply has no namespace.

Since:
DOM Level 2

getPrefix

String getPrefix()
The namespace prefix of this node, or null if it is unspecified. When it is defined to be null, setting it has no effect, including if the node is read-only.
Note that setting this attribute, when permitted, changes the nodeName attribute, which holds the qualified name, as well as the tagName and name attributes of the Element and Attr interfaces, when applicable.
Setting the prefix to null makes it unspecified, setting it to an empty string is implementation dependent.
Note also that changing the prefix of an attribute that is known to have a default value, does not make a new attribute with the default value and the original prefix appear, since the namespaceURI and localName do not change.
For nodes of any type other than ELEMENT_NODE and ATTRIBUTE_NODE and nodes created with a DOM Level 1 method, such as createElement from the Document interface, this is always null.

Since:
DOM Level 2

setPrefix

void setPrefix(String prefix)
               throws DOMException
The namespace prefix of this node, or null if it is unspecified. When it is defined to be null, setting it has no effect, including if the node is read-only.
Note that setting this attribute, when permitted, changes the nodeName attribute, which holds the qualified name, as well as the tagName and name attributes of the Element and Attr interfaces, when applicable.
Setting the prefix to null makes it unspecified, setting it to an empty string is implementation dependent.
Note also that changing the prefix of an attribute that is known to have a default value, does not make a new attribute with the default value and the original prefix appear, since the namespaceURI and localName do not change.
For nodes of any type other than ELEMENT_NODE and ATTRIBUTE_NODE and nodes created with a DOM Level 1 method, such as createElement from the Document interface, this is always null.

Throws:
DOMException - INVALID_CHARACTER_ERR: Raised if the specified prefix contains an illegal character according to the XML version in use specified in the Document.xmlVersion attribute.
NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
NAMESPACE_ERR: Raised if the specified prefix is malformed per the Namespaces in XML specification, if the namespaceURI of this node is null, if the specified prefix is "xml" and the namespaceURI of this node is different from " http://www.w3.org/XML/1998/namespace", if this node is an attribute and the specified prefix is "xmlns" and the namespaceURI of this node is different from "http://www.w3.org/2000/xmlns/", or if this node is an attribute and the qualifiedName of this node is "xmlns" [XML Namespaces] .
Since:
DOM Level 2

getLocalName

String getLocalName()
Returns the local part of the qualified name of this node.
For nodes of any type other than ELEMENT_NODE and ATTRIBUTE_NODE and nodes created with a DOM Level 1 method, such as Document.createElement(), this is always null.

Since:
DOM Level 2

hasAttributes

boolean hasAttributes()
Returns whether this node (if it is an element) has any attributes.

Returns:
Returns true if this node has any attributes, false otherwise.
Since:
DOM Level 2

getBaseURI

String getBaseURI()
The absolute base URI of this node or null if the implementation wasn't able to obtain an absolute URI. This value is computed as described in . However, when the Document supports the feature "HTML" [DOM Level 2 HTML] , the base URI is computed using first the value of the href attribute of the HTML BASE element if any, and the value of the documentURI attribute from the Document interface otherwise.

Since:
DOM Level 3

compareDocumentPosition

short compareDocumentPosition(Node other)
                              throws DOMException
Compares the reference node, i.e. the node on which this method is being called, with a node, i.e. the one passed as a parameter, with regard to their position in the document and according to the document order.

Parameters:
other - The node to compare against the reference node.
Returns:
Returns how the node is positioned relatively to the reference node.
Throws:
DOMException - NOT_SUPPORTED_ERR: when the compared nodes are from different DOM implementations that do not coordinate to return consistent implementation-specific results.
Since:
DOM Level 3

getTextContent

String getTextContent()
                      throws DOMException
This attribute returns the text content of this node and its descendants. When it is defined to be null, setting it has no effect. On setting, any possible children this node may have are removed and, if it the new string is not empty or null, replaced by a single Text node containing the string this attribute is set to.
On getting, no serialization is performed, the returned string does not contain any markup. No whitespace normalization is performed and the returned string does not contain the white spaces in element content (see the attribute Text.isElementContentWhitespace). Similarly, on setting, no parsing is performed either, the input string is taken as pure textual content.
The string returned is made of the text content of this node depending on its type, as defined below:
Node type | Content
ELEMENT_NODE, ATTRIBUTE_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, DOCUMENT_FRAGMENT_NODE | concatenation of the textContent attribute value of every child node, excluding COMMENT_NODE and PROCESSING_INSTRUCTION_NODE nodes. This is the empty string if the node has no children.
TEXT_NODE, CDATA_SECTION_NODE, COMMENT_NODE, PROCESSING_INSTRUCTION_NODE | nodeValue
DOCUMENT_NODE, DOCUMENT_TYPE_NODE, NOTATION_NODE | null

Throws:
DOMException - DOMSTRING_SIZE_ERR: Raised when it would return more characters than fit in a DOMString variable on the implementation platform.
Since:
DOM Level 3

setTextContent

void setTextContent(String textContent)
                    throws DOMException
This attribute returns the text content of this node and its descendants. When it is defined to be null, setting it has no effect. On setting, any possible children this node may have are removed and, if it the new string is not empty or null, replaced by a single Text node containing the string this attribute is set to.
On getting, no serialization is performed, the returned string does not contain any markup. No whitespace normalization is performed and the returned string does not contain the white spaces in element content (see the attribute Text.isElementContentWhitespace). Similarly, on setting, no parsing is performed either, the input string is taken as pure textual content.
The string returned is made of the text content of this node depending on its type, as defined below:
Node type | Content
ELEMENT_NODE, ATTRIBUTE_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, DOCUMENT_FRAGMENT_NODE | concatenation of the textContent attribute value of every child node, excluding COMMENT_NODE and PROCESSING_INSTRUCTION_NODE nodes. This is the empty string if the node has no children.
TEXT_NODE, CDATA_SECTION_NODE, COMMENT_NODE, PROCESSING_INSTRUCTION_NODE | nodeValue
DOCUMENT_NODE, DOCUMENT_TYPE_NODE, NOTATION_NODE | null

Throws:
DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised when the node is readonly.
Since:
DOM Level 3

isSameNode

boolean isSameNode(Node other)
Returns whether this node is the same node as the given one.
This method provides a way to determine whether two Node references returned by the implementation reference the same object. When two Node references are references to the same object, even if through a proxy, the references may be used completely interchangeably, such that all attributes have the same values and calling the same DOM method on either reference always has exactly the same effect.

Parameters:
other - The node to test against.
Returns:
Returns true if the nodes are the same, false otherwise.
Since:
DOM Level 3

lookupPrefix

String lookupPrefix(String namespaceURI)
Look up the prefix associated to the given namespace URI, starting from this node. The default namespace declarations are ignored by this method.
See for details on the algorithm used by this method.

Parameters:
namespaceURI - The namespace URI to look for.
Returns:
Returns an associated namespace prefix if found or null if none is found. If more than one prefix are associated to the namespace prefix, the returned namespace prefix is implementation dependent.
Since:
DOM Level 3

isDefaultNamespace

boolean isDefaultNamespace(String namespaceURI)
This method checks if the specified namespaceURI is the default namespace or not.

Parameters:
namespaceURI - The namespace URI to look for.
Returns:
Returns true if the specified namespaceURI is the default namespace, false otherwise.
Since:
DOM Level 3

lookupNamespaceURI

String lookupNamespaceURI(String prefix)
Look up the namespace URI associated to the given prefix, starting from this node.
See for details on the algorithm used by this method.

Parameters:
prefix - The prefix to look for. If this parameter is null, the method will return the default namespace URI if any.
Returns:
Returns the associated namespace URI or null if none is found.
Since:
DOM Level 3

isEqualNode

boolean isEqualNode(Node arg)
Tests whether two nodes are equal.
This method tests for equality of nodes, not sameness (i.e., whether the two nodes are references to the same object) which can be tested with Node.isSameNode(). All nodes that are the same will also be equal, though the reverse may not be true.
Two nodes are equal if and only if the following conditions are satisfied:
  • The two nodes are of the same type.
  • The following string attributes are equal: nodeName, localName, namespaceURI, prefix, nodeValue . This is: they are both null, or they have the same length and are character for character identical.
  • The attributes NamedNodeMaps are equal. This is: they are both null, or they have the same length and for each node that exists in one map there is a node that exists in the other map and is equal, although not necessarily at the same index.
  • The childNodes NodeLists are equal. This is: they are both null, or they have the same length and contain equal nodes at the same index. Note that normalization can affect equality; to avoid this, nodes should be normalized before being compared.

For two DocumentType nodes to be equal, the following conditions must also be satisfied:
  • The following string attributes are equal: publicId, systemId, internalSubset.
  • The entities NamedNodeMaps are equal.
  • The notations NamedNodeMaps are equal.

On the other hand, the following do not affect equality: the ownerDocument, baseURI, and parentNode attributes, the specified attribute for Attr nodes, the schemaTypeInfo attribute for Attr and Element nodes, the Text.isElementContentWhitespace attribute for Text nodes, as well as any user data or event listeners registered on the nodes.

Note: As a general rule, anything not mentioned in the description above is not significant in consideration of equality checking. Note that future versions of this specification may take into account more attributes and implementations conform to this specification are expected to be updated accordingly.

Parameters:
arg - The node to compare equality with.
Returns:
Returns true if the nodes are equal, false otherwise.
Since:
DOM Level 3

getFeature

Object getFeature(String feature,
                  String version)
This method returns a specialized object which implements the specialized APIs of the specified feature and version, as specified in . The specialized object may also be obtained by using binding-specific casting methods but is not necessarily expected to, as discussed in . This method also allow the implementation to provide specialized objects which do not support the Node interface.

Parameters:
feature - The name of the feature requested. Note that any plus sign "+" prepended to the name of the feature will be ignored since it is not significant in the context of this method.
version - This is the version number of the feature to test.
Returns:
Returns an object which implements the specialized APIs of the specified feature and version, if any, or null if there is no object which implements interfaces associated with that feature. If the DOMObject returned by this method implements the Node interface, it must delegate to the primary core Node and not return results inconsistent with the primary core Node such as attributes, childNodes, etc.
Since:
DOM Level 3

setUserData

Object setUserData(String key,
                   Object data,
                   UserDataHandler handler)
Associate an object to a key on this node. The object can later be retrieved from this node by calling getUserData with the same key.

Parameters:
key - The key to associate the object to.
data - The object to associate to the given key, or null to remove any existing association to that key.
handler - The handler to associate to that key, or null.
Returns:
Returns the DOMUserData previously associated to the given key on this node, or null if there was none.
Since:
DOM Level 3

getUserData

Object getUserData(String key)
Retrieves the object associated to a key on a this node. The object must first have been set to this node by calling setUserData with the same key.

Parameters:
key - The key the object is associated to.
Returns:
Returns the DOMUserData associated to the given key on this node, or null if there was none.
Since:
DOM Level 3
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NodeList (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface NodeList

All Known Implementing Classes:
IIOMetadataNode
public interface NodeList

The NodeList interface provides the abstraction of an ordered collection of nodes, without defining or constraining how this collection is implemented. NodeList objects in the DOM are live.

The items in the NodeList are accessible via an integral index, starting from 0.

See also the Document Object Model (DOM) Level 3 Core Specification.

Method Summary
Modifier and Type | Method and Description
int | getLength() The number of nodes in the list.
Node | item(int index) Returns the indexth item in the collection.

Method Detail

item

Node item(int index)
Returns the indexth item in the collection. If index is greater than or equal to the number of nodes in the list, this returns null.

Parameters:
index - Index into the collection.
Returns:
The node at the indexth position in the NodeList, or null if that is not a valid index.

getLength

int getLength()
The number of nodes in the list. The range of valid child node indices is 0 to length-1 inclusive.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


Notation (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface Notation

All Superinterfaces:
Node
public interface Notation
extends Node

This interface represents a notation declared in the DTD. A notation either declares, by name, the format of an unparsed entity (see section 4.7 of the XML 1.0 specification [XML 1.0]), or is used for formal declaration of processing instruction targets (see section 2.6 of the XML 1.0 specification [XML 1.0]). The nodeName attribute inherited from Node is set to the declared name of the notation.

The DOM Core does not support editing Notation nodes; they are therefore readonly.

A Notation node does not have any parent.

See also the Document Object Model (DOM) Level 3 Core Specification.

Field Summary
Modifier and Type Field and Description
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
Modifier and Type | Method and Description
String | getPublicId() The public identifier of this notation.
String | getSystemId() The system identifier of this notation.
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Method Detail

getPublicId

String getPublicId()
The public identifier of this notation. If the public identifier was not specified, this is null.

getSystemId

String getSystemId()
The system identifier of this notation. If the system identifier was not specified, this is null. This may be an absolute URI or not.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


org.w3c.dom (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.w3c.dom

Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

See:
Description

Interface Summary
Interface | Description
Attr | The Attr interface represents an attribute in an Element object.
CDATASection | CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup.
CharacterData | The CharacterData interface extends Node with a set of attributes and methods for accessing character data in the DOM.
Comment | This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'.
Document | The Document interface represents the entire HTML or XML document.
DocumentFragment | DocumentFragment is a "lightweight" or "minimal" Document object.
DocumentType | Each Document has a doctype attribute whose value is either null or a DocumentType object.
DOMConfiguration | The DOMConfiguration interface represents the configuration of a document and maintains a table of recognized parameters.
DOMError | DOMError is an interface that describes an error.
DOMErrorHandler | DOMErrorHandler is a callback interface that the DOM implementation can call when reporting errors that happens while processing XML data, or when doing some other processing (e.g.
DOMImplementation | The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.
DOMImplementationList | The DOMImplementationList interface provides the abstraction of an ordered collection of DOM implementations, without defining or constraining how this collection is implemented.
DOMImplementationSource | This interface permits a DOM implementer to supply one or more implementations, based upon requested features and versions, as specified in .
DOMLocator | DOMLocator is an interface that describes a location (e.g.
DOMStringList | The DOMStringList interface provides the abstraction of an ordered collection of DOMString values, without defining or constraining how this collection is implemented.
Element | The Element interface represents an element in an HTML or XML document.
Entity | This interface represents a known entity, either parsed or unparsed, in an XML document.
EntityReference | EntityReference nodes may be used to represent an entity reference in the tree.
NamedNodeMap | Objects implementing the NamedNodeMap interface are used to represent collections of nodes that can be accessed by name.
NameList | The NameList interface provides the abstraction of an ordered collection of parallel pairs of name and namespace values (which could be null values), without defining or constraining how this collection is implemented.
Node | The Node interface is the primary datatype for the entire Document Object Model.
NodeList | The NodeList interface provides the abstraction of an ordered collection of nodes, without defining or constraining how this collection is implemented.
Notation | This interface represents a notation declared in the DTD.
ProcessingInstruction | The ProcessingInstruction interface represents a "processing instruction", used in XML as a way to keep processor-specific information in the text of the document.
Text | The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr.
TypeInfo | The TypeInfo interface represents a type referenced from Element or Attr nodes, specified in the schemas associated with the document.
UserDataHandler | When associating an object to a key on a node using Node.setUserData() the application can provide a handler that gets called when the node the object is associated to is being cloned, imported, or renamed.

Exception Summary
Exception | Description
DOMException | DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable).

Package org.w3c.dom Description

Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing. The Document Object Model Level 2 Core API allows programs to dynamically access and update the content and structure of documents. See the specification for more information.

Since:
JDK1.4
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


ProcessingInstruction (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface ProcessingInstruction

All Superinterfaces:
Node
public interface ProcessingInstruction
extends Node

The ProcessingInstruction interface represents a "processing instruction", used in XML as a way to keep processor-specific information in the text of the document.

No lexical check is done on the content of a processing instruction and it is therefore possible to have the character sequence "?>" in the content, which is illegal a processing instruction per section 2.6 of [XML 1.0]. The presence of this character sequence must generate a fatal error during serialization.

See also the Document Object Model (DOM) Level 3 Core Specification.

Field Summary
Modifier and Type Field and Description
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
Modifier and Type | Method and Description
String | getData() The content of this processing instruction.
String | getTarget() The target of this processing instruction.
void | setData(String data) The content of this processing instruction.
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Method Detail

getTarget

String getTarget()
The target of this processing instruction. XML defines this as being the first token following the markup that begins the processing instruction.

getData

String getData()
The content of this processing instruction. This is from the first non white space character after the target to the character immediately preceding the ?>.

setData

void setData(String data)
             throws DOMException
The content of this processing instruction. This is from the first non white space character after the target to the character immediately preceding the ?>.

Throws:
DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised when the node is readonly.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


Text (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface Text

All Superinterfaces:
CharacterData, Node
All Known Subinterfaces:
CDATASection, Text
public interface Text
extends CharacterData

The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr. If there is no markup inside an element's content, the text is contained in a single object implementing the Text interface that is the only child of the element. If there is markup, it is parsed into the information items (elements, comments, etc.) and Text nodes that form the list of children of the element.

When a document is first made available via the DOM, there is only one Text node for each block of text. Users may create adjacent Text nodes that represent the contents of a given element without any intervening markup, but should be aware that there is no way to represent the separations between these nodes in XML or HTML, so they will not (in general) persist between DOM editing sessions. The Node.normalize() method merges any such adjacent Text objects into a single node for each block of text.

No lexical check is done on the content of a Text node and, depending on its position in the document, some characters must be escaped during serialization using character references; e.g. the characters "<&" if the textual content is part of an element or of an attribute, the character sequence "]]>" when part of an element, the quotation mark character " or the apostrophe character ' when part of an attribute.

See also the Document Object Model (DOM) Level 3 Core Specification.

Field Summary
Modifier and Type Field and Description
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
Modifier and Type | Method and Description
String | getWholeText() Returns all text of Text nodes logically-adjacent text nodes to this node, concatenated in document order.
boolean | isElementContentWhitespace() Returns whether this text node contains element content whitespace, often abusively called "ignorable whitespace".
Text | replaceWholeText(String content) Replaces the text of the current node and all logically-adjacent text nodes with the specified text.
Text | splitText(int offset) Breaks this node into two nodes at the specified offset, keeping both in the tree as siblings.
Methods inherited from interface org.w3c.dom.CharacterData
appendData, deleteData, getData, getLength, insertData, replaceData, setData, substringData
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Method Detail

splitText

Text splitText(int offset)
               throws DOMException
Breaks this node into two nodes at the specified offset, keeping both in the tree as siblings. After being split, this node will contain all the content up to the offset point. A new node of the same type, which contains all the content at and after the offset point, is returned. If the original node had a parent node, the new node is inserted as the next sibling of the original node. When the offset is equal to the length of this node, the new node has no data.

Parameters:
offset - The 16-bit unit offset at which to split, starting from 0.
Returns:
The new node, of the same type as this node.
Throws:
DOMException - INDEX_SIZE_ERR: Raised if the specified offset is negative or greater than the number of 16-bit units in data.
NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

isElementContentWhitespace

boolean isElementContentWhitespace()
Returns whether this text node contains element content whitespace, often abusively called "ignorable whitespace". The text node is determined to contain whitespace in element content during the load of the document or if validation occurs while using Document.normalizeDocument().

Since:
DOM Level 3

getWholeText

String getWholeText()
Returns all text of Text nodes logically-adjacent text nodes to this node, concatenated in document order.
For instance, in the example below wholeText on the Text node that contains "bar" returns "barfoo", while on the Text node that contains "foo" it returns "barfoo".
                     +-----+
                     | <p> |
                     +-----+
                       /\
                      /  \
               /-----\    +-------+
               | bar |    | &ent; |
               \-----/    +-------+
                              |
                              |
                           /-----\
                           | foo |
                           \-----/
Figure: barTextNode.wholeText value is "barfoo"

Since:
DOM Level 3

replaceWholeText

Text replaceWholeText(String content)
                      throws DOMException
Replaces the text of the current node and all logically-adjacent text nodes with the specified text. All logically-adjacent text nodes are removed including the current node unless it was the recipient of the replacement text.

This method returns the node which received the replacement text. The returned node is:

  • null, when the replacement text is the empty string;
  • the current node, except when the current node is read-only;
  • a new Text node of the same type ( Text or CDATASection) as the current node inserted at the location of the replacement.

For instance, in the above example calling replaceWholeText on the Text node that contains "bar" with "yo" in argument results in the following:

                     +-----+
                     | <p> |
                     +-----+
                        |
                        |
                     /-----\
                     | yo  |
                     \-----/
Figure: barTextNode.replaceWholeText("yo") modifies the textual content of barTextNode with "yo"

Where the nodes to be removed are read-only descendants of an EntityReference, the EntityReference must be removed instead of the read-only nodes. If any EntityReference to be removed has descendants that are not EntityReference, Text, or CDATASection nodes, the replaceWholeText method must fail before performing any modification of the document, raising a DOMException with the code NO_MODIFICATION_ALLOWED_ERR.

For instance, in the example below calling replaceWholeText on the Text node that contains "bar" fails, because the EntityReference node "ent" contains an Element node which cannot be removed.

Parameters:
content - The content of the replacing Text node.
Returns:
The Text node created with the specified content.
Throws:
DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if one of the Text nodes being replaced is readonly.
Since:
DOM Level 3
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


TypeInfo (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom
Interface TypeInfo

public interface TypeInfo

The TypeInfo interface represents a type referenced from Element or Attr nodes, specified in the schemas associated with the document. The type is a pair of a namespace URI and name properties, and depends on the document's schema.

If the document's schema is an XML DTD [XML 1.0], the values are computed as follows:

  • If this type is referenced from an Attr node, typeNamespace is "http://www.w3.org/TR/REC-xml" and typeName represents the [attribute type] property in the [XML Information Set] . If there is no declaration for the attribute, typeNamespace and typeName are null.
  • If this type is referenced from an Element node, typeNamespace and typeName are null.

If the document's schema is an XML Schema [XML Schema Part 1] , the values are computed as follows using the post-schema-validation infoset contributions (also called PSVI contributions):

  • If the [validity] property exists AND is "invalid" or "notKnown": the {target namespace} and {name} properties of the declared type if available, otherwise null.

    Note: At the time of writing, the XML Schema specification does not require exposing the declared type. Thus, DOM implementations might choose not to provide type information if validity is not valid.

  • If the [validity] property exists and is "valid":
    1. If [member type definition] exists:
      1. If {name} is not absent, then expose {name} and {target namespace} properties of the [member type definition] property;
      2. Otherwise, expose the namespace and local name of the corresponding anonymous type name.
    2. If the [type definition] property exists:
      1. If {name} is not absent, then expose {name} and {target namespace} properties of the [type definition] property;
      2. Otherwise, expose the namespace and local name of the corresponding anonymous type name.
    3. If the [member type definition anonymous] exists:
      1. If it is false, then expose [member type definition name] and [member type definition namespace] properties;
      2. Otherwise, expose the namespace and local name of the corresponding anonymous type name.
    4. If the [type definition anonymous] exists:
      1. If it is false, then expose [type definition name] and [type definition namespace] properties;
      2. Otherwise, expose the namespace and local name of the corresponding anonymous type name.

Note: Other schema languages are outside the scope of the W3C and therefore should define how to represent their type systems using TypeInfo.

See also the Document Object Model (DOM) Level 3 Core Specification.

Since:
DOM Level 3

Field Summary
Modifier and Type | Field and Description
static int | DERIVATION_EXTENSION If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the derivation by extension.
static int | DERIVATION_LIST If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the list.
static int | DERIVATION_RESTRICTION If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the derivation by restriction if complex types are involved, or a restriction if simple types are involved.
static int | DERIVATION_UNION If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the union if simple types are involved.
Method Summary
Modifier and Type | Method and Description
String | getTypeName() The name of a type declared for the associated element or attribute, or null if unknown.
String | getTypeNamespace() The namespace of the type declared for the associated element or attribute or null if the element does not have declaration or if no namespace information is available.
boolean | isDerivedFrom(String typeNamespaceArg, String typeNameArg, int derivationMethod) This method returns if there is a derivation between the reference type definition, i.e.

Field Detail

DERIVATION_RESTRICTION

static final int DERIVATION_RESTRICTION
If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the derivation by restriction if complex types are involved, or a restriction if simple types are involved.
The reference type definition is derived by restriction from the other type definition if the other type definition is the same as the reference type definition, or if the other type definition can be reached recursively following the {base type definition} property from the reference type definition, and all the derivation methods involved are restriction.

See Also:
Constant Field Values

DERIVATION_EXTENSION

static final int DERIVATION_EXTENSION
If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the derivation by extension.
The reference type definition is derived by extension from the other type definition if the other type definition can be reached recursively following the {base type definition} property from the reference type definition, and at least one of the derivation methods involved is an extension.

See Also:
Constant Field Values

DERIVATION_UNION

static final int DERIVATION_UNION
If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the union if simple types are involved.
The reference type definition is derived by union from the other type definition if there exists two type definitions T1 and T2 such as the reference type definition is derived from T1 by DERIVATION_RESTRICTION or DERIVATION_EXTENSION, T2 is derived from the other type definition by DERIVATION_RESTRICTION, T1 has {variety} union, and one of the {member type definitions} is T2. Note that T1 could be the same as the reference type definition, and T2 could be the same as the other type definition.

See Also:
Constant Field Values

DERIVATION_LIST

static final int DERIVATION_LIST
If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the list.
The reference type definition is derived by list from the other type definition if there exists two type definitions T1 and T2 such as the reference type definition is derived from T1 by DERIVATION_RESTRICTION or DERIVATION_EXTENSION, T2 is derived from the other type definition by DERIVATION_RESTRICTION, T1 has {variety} list, and T2 is the {item type definition}. Note that T1 could be the same as the reference type definition, and T2 could be the same as the other type definition.

See Also:
Constant Field Values
Method Detail

getTypeName

String getTypeName()
The name of a type declared for the associated element or attribute, or null if unknown.

getTypeNamespace

String getTypeNamespace()
The namespace of the type declared for the associated element or attribute or null if the element does not have declaration or if no namespace information is available.

isDerivedFrom

boolean isDerivedFrom(String typeNamespaceArg,
                      String typeNameArg,
                      int derivationMethod)
This method returns if there is a derivation between the reference type definition, i.e. the TypeInfo on which the method is being called, and the other type definition, i.e. the one passed as parameters.

Parameters:
typeNamespaceArg - the namespace of the other type definition.
typeNameArg - the name of the other type definition.
derivationMethod - the type of derivation and conditions applied between two types, as described in the list of constants provided in this interface.
Returns:
If the document's schema is a DTD or no schema is associated with the document, this method will always return false . If the document's schema is an XML Schema, the method will return true if the reference type definition is derived from the other type definition according to the derivation parameter. If the value of the parameter is 0 (no bit is set to 1 for the derivationMethod parameter), the method will return true if the other type definition can be reached by recursing any combination of {base type definition}, {item type definition}, or {member type definitions} from the reference type definition.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


UserDataHandler (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.w3c.dom
Interface UserDataHandler

public interface UserDataHandler

When associating an object to a key on a node using Node.setUserData() the application can provide a handler that gets called when the node the object is associated to is being cloned, imported, or renamed. This can be used by the application to implement various behaviors regarding the data it associates to the DOM nodes. This interface defines that handler.

See also the Document Object Model (DOM) Level 3 Core Specification.

Since:
DOM Level 3

Field Summary
Modifier and Type | Field and Description
static short | NODE_ADOPTED The node is adopted, using Document.adoptNode().
static short | NODE_CLONED The node is cloned, using Node.cloneNode().
static short | NODE_DELETED The node is deleted.
static short | NODE_IMPORTED The node is imported, using Document.importNode().
static short | NODE_RENAMED The node is renamed, using Document.renameNode().
Method Summary
Modifier and Type | Method and Description
void | handle(short operation, String key, Object data, Node src, Node dst) This method is called whenever the node for which this handler is registered is imported or cloned.

Field Detail

NODE_CLONED

static final short NODE_CLONED
The node is cloned, using Node.cloneNode().

See Also:
Constant Field Values

NODE_IMPORTED

static final short NODE_IMPORTED
The node is imported, using Document.importNode().

See Also:
Constant Field Values

NODE_DELETED

static final short NODE_DELETED
The node is deleted.

Note: This may not be supported or may not be reliable in certain environments, such as Java, where the implementation has no real control over when objects are actually deleted.

See Also:
Constant Field Values

NODE_RENAMED

static final short NODE_RENAMED
The node is renamed, using Document.renameNode().

See Also:
Constant Field Values

NODE_ADOPTED

static final short NODE_ADOPTED
The node is adopted, using Document.adoptNode().

See Also:
Constant Field Values
Method Detail

handle

void handle(short operation,
            String key,
            Object data,
            Node src,
            Node dst)
This method is called whenever the node for which this handler is registered is imported or cloned.
DOM applications must not raise exceptions in a UserDataHandler. The effect of throwing exceptions from the handler is DOM implementation dependent.

Parameters:
operation - Specifies the type of operation that is being performed on the node.
key - Specifies the key for which this handler is being called.
data - Specifies the data for which this handler is being called.
src - Specifies the node being cloned, adopted, imported, or renamed. This is null when the node is being deleted.
dst - Specifies the node newly created if any, or null.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DOMImplementationRegistry (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.w3c.dom.bootstrap
Class DOMImplementationRegistry

java.lang.Object
    extended by  org.w3c.dom.bootstrap.DOMImplementationRegistry

public final class DOMImplementationRegistry
extends Object

A factory that enables applications to obtain instances of DOMImplementation.

Example:

  // get an instance of the DOMImplementation registry
  DOMImplementationRegistry registry =
       DOMImplementationRegistry.newInstance();
  // get a DOM implementation the Level 3 XML module
  DOMImplementation domImpl =
       registry.getDOMImplementation("XML 3.0");

This provides an application with an implementation-independent starting point. DOM implementations may modify this class to meet new security standards or to provide *additional* fallbacks for the list of DOMImplementationSources.

Since:
DOM Level 3
See Also:
DOMImplementation, DOMImplementationSource

Field Summary
Modifier and Type | Field and Description
static String | PROPERTY The system property to specify the DOMImplementationSource class names.
Method Summary
Modifier and Type | Method and Description
void | addSource(DOMImplementationSource s) Register an implementation.
DOMImplementation | getDOMImplementation(String features) Return the first implementation that has the desired features, or null if none is found.
DOMImplementationList | getDOMImplementationList(String features) Return a list of implementations that support the desired features.
static DOMImplementationRegistry | newInstance() Obtain a new instance of a DOMImplementationRegistry.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PROPERTY

public static final String PROPERTY
The system property to specify the DOMImplementationSource class names.

See Also:
Constant Field Values
Method Detail

newInstance

public static DOMImplementationRegistry newInstance()
                                             throws ClassNotFoundException,
                                                    InstantiationException,
                                                    IllegalAccessException,
                                                    ClassCastException
Obtain a new instance of a DOMImplementationRegistry. The DOMImplementationRegistry is initialized by the application or the implementation, depending on the context, by first checking the value of the Java system property org.w3c.dom.DOMImplementationSourceList and the the service provider whose contents are at "META_INF/services/org.w3c.dom.DOMImplementationSourceList" The value of this property is a white-space separated list of names of availables classes implementing the DOMImplementationSource interface. Each class listed in the class name list is instantiated and any exceptions encountered are thrown to the application.

Returns:
an initialized instance of DOMImplementationRegistry
Throws:
ClassNotFoundException - If any specified class can not be found
InstantiationException - If any specified class is an interface or abstract class
IllegalAccessException - If the default constructor of a specified class is not accessible
ClassCastException - If any specified class does not implement DOMImplementationSource

getDOMImplementation

public DOMImplementation getDOMImplementation(String features)
Return the first implementation that has the desired features, or null if none is found.

Parameters:
features - A string that specifies which features are required. This is a space separated list in which each feature is specified by its name optionally followed by a space and a version number. This is something like: "XML 1.0 Traversal +Events 2.0"
Returns:
An implementation that has the desired features, or null if none found.

getDOMImplementationList

public DOMImplementationList getDOMImplementationList(String features)
Return a list of implementations that support the desired features.

Parameters:
features - A string that specifies which features are required. This is a space separated list in which each feature is specified by its name optionally followed by a space and a version number. This is something like: "XML 1.0 Traversal +Events 2.0"
Returns:
A list of DOMImplementations that support the desired features.

addSource

public void addSource(DOMImplementationSource s)
Register an implementation.

Parameters:
s - The source to be registered, may not be null
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.w3c.dom.bootstrap (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.w3c.dom.bootstrap

Class Summary
Class | Description
DOMImplementationRegistry | A factory that enables applications to obtain instances of DOMImplementation.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


DocumentEvent (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.w3c.dom.events
Interface DocumentEvent

public interface DocumentEvent

The DocumentEvent interface provides a mechanism by which the user can create an Event of a type supported by the implementation. It is expected that the DocumentEvent interface will be implemented on the same object which implements the Document interface in an implementation which supports the Event model.

See also the Document Object Model (DOM) Level 2 Events Specification.

Since:
DOM Level 2

Method Summary
Modifier and Type | Method and Description
Event | createEvent(String eventType)

Method Detail

createEvent

Event createEvent(String eventType)
                  throws DOMException
Parameters:
eventType - The eventType parameter specifies the type of Event interface to be created. If the Event interface specified is supported by the implementation this method will return a new Event of the interface type requested. If the Event is to be dispatched via the dispatchEvent method the appropriate event init method must be called after creation in order to initialize the Event's values. As an example, a user wishing to synthesize some kind of UIEvent would call createEvent with the parameter "UIEvents". The initUIEvent method could then be called on the newly created UIEvent to set the specific type of UIEvent to be dispatched and set its context information.The createEvent method is used in creating Events when it is either inconvenient or unnecessary for the user to create an Event themselves. In cases where the implementation provided Event is insufficient, users may supply their own Event implementations for use with the dispatchEvent method.
Returns:
The newly created Event
Throws:
DOMException - NOT_SUPPORTED_ERR: Raised if the implementation does not support the type of Event interface requested
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Event (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom.events
Interface Event

All Known Subinterfaces:
LSLoadEvent, LSProgressEvent, MouseEvent, MutationEvent, UIEvent
public interface Event

The Event interface is used to provide contextual information about an event to the handler processing the event. An object which implements the Event interface is generally passed as the first parameter to an event handler. More specific context information is passed to event handlers by deriving additional interfaces from Event which contain information directly relating to the type of event they accompany. These derived interfaces are also implemented by the object passed to the event listener.

See also the Document Object Model (DOM) Level 2 Events Specification.

Since:
DOM Level 2

Field Summary
Modifier and Type | Field and Description
static short | AT_TARGET The event is currently being evaluated at the target EventTarget.
static short | BUBBLING_PHASE The current event phase is the bubbling phase.
static short | CAPTURING_PHASE The current event phase is the capturing phase.
Method Summary
Modifier and Type | Method and Description
boolean | getBubbles() Used to indicate whether or not an event is a bubbling event.
boolean | getCancelable() Used to indicate whether or not an event can have its default action prevented.
EventTarget | getCurrentTarget() Used to indicate the EventTarget whose EventListeners are currently being processed.
short | getEventPhase() Used to indicate which phase of event flow is currently being evaluated.
EventTarget | getTarget() Used to indicate the EventTarget to which the event was originally dispatched.
long | getTimeStamp() Used to specify the time (in milliseconds relative to the epoch) at which the event was created.
String | getType() The name of the event (case-insensitive).
void | initEvent(String eventTypeArg, boolean canBubbleArg, boolean cancelableArg) The initEvent method is used to initialize the value of an Event created through the DocumentEvent interface.
void | preventDefault() If an event is cancelable, the preventDefault method is used to signify that the event is to be canceled, meaning any default action normally taken by the implementation as a result of the event will not occur.
void | stopPropagation() The stopPropagation method is used prevent further propagation of an event during event flow.

Field Detail

CAPTURING_PHASE

static final short CAPTURING_PHASE
The current event phase is the capturing phase.

See Also:
Constant Field Values

AT_TARGET

static final short AT_TARGET
The event is currently being evaluated at the target EventTarget.

See Also:
Constant Field Values

BUBBLING_PHASE

static final short BUBBLING_PHASE
The current event phase is the bubbling phase.

See Also:
Constant Field Values
Method Detail

getType

String getType()
The name of the event (case-insensitive). The name must be an XML name.

getTarget

EventTarget getTarget()
Used to indicate the EventTarget to which the event was originally dispatched.

getCurrentTarget

EventTarget getCurrentTarget()
Used to indicate the EventTarget whose EventListeners are currently being processed. This is particularly useful during capturing and bubbling.

getEventPhase

short getEventPhase()
Used to indicate which phase of event flow is currently being evaluated.

getBubbles

boolean getBubbles()
Used to indicate whether or not an event is a bubbling event. If the event can bubble the value is true, else the value is false.

getCancelable

boolean getCancelable()
Used to indicate whether or not an event can have its default action prevented. If the default action can be prevented the value is true, else the value is false.

getTimeStamp

long getTimeStamp()
Used to specify the time (in milliseconds relative to the epoch) at which the event was created. Due to the fact that some systems may not provide this information the value of timeStamp may be not available for all events. When not available, a value of 0 will be returned. Examples of epoch time are the time of the system start or 0:0:0 UTC 1st January 1970.

stopPropagation

void stopPropagation()
The stopPropagation method is used prevent further propagation of an event during event flow. If this method is called by any EventListener the event will cease propagating through the tree. The event will complete dispatch to all listeners on the current EventTarget before event flow stops. This method may be used during any stage of event flow.

preventDefault

void preventDefault()
If an event is cancelable, the preventDefault method is used to signify that the event is to be canceled, meaning any default action normally taken by the implementation as a result of the event will not occur. If, during any stage of event flow, the preventDefault method is called the event is canceled. Any default action associated with the event will not occur. Calling this method for a non-cancelable event has no effect. Once preventDefault has been called it will remain in effect throughout the remainder of the event's propagation. This method may be used during any stage of event flow.

initEvent

void initEvent(String eventTypeArg,
               boolean canBubbleArg,
               boolean cancelableArg)
The initEvent method is used to initialize the value of an Event created through the DocumentEvent interface. This method may only be called before the Event has been dispatched via the dispatchEvent method, though it may be called multiple times during that phase if necessary. If called multiple times the final invocation takes precedence. If called from a subclass of Event interface only the values specified in the initEvent method are modified, all other attributes are left unchanged.

Parameters:
eventTypeArg - Specifies the event type. This type may be any event type currently defined in this specification or a new event type.. The string must be an XML name. Any new event type must not begin with any upper, lower, or mixed case version of the string "DOM". This prefix is reserved for future DOM event sets. It is also strongly recommended that third parties adding their own events use their own prefix to avoid confusion and lessen the probability of conflicts with other new events.
canBubbleArg - Specifies whether or not the event can bubble.
cancelableArg - Specifies whether or not the event's default action can be prevented.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


EventException (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom.events
Class EventException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.w3c.dom.events.EventException
All Implemented Interfaces:
Serializable
public class EventException
extends RuntimeException

Event operations may throw an EventException as specified in their method descriptions.

See also the Document Object Model (DOM) Level 2 Events Specification.

Since:
DOM Level 2
See Also:
Serialized Form

Field Summary
Modifier and Type | Field and Description
short | code
static short | UNSPECIFIED_EVENT_TYPE_ERR If the Event's type was not specified by initializing the event before the method was called.
Constructor Summary
Constructor and Description
EventException(short code, String message)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

code

public short code

UNSPECIFIED_EVENT_TYPE_ERR

public static final short UNSPECIFIED_EVENT_TYPE_ERR
If the Event's type was not specified by initializing the event before the method was called. Specification of the Event's type as null or an empty string will also trigger this exception.

See Also:
Constant Field Values
Constructor Detail

EventException

public EventException(short code,
                      String message)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


EventListener (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom.events
Interface EventListener

public interface EventListener

The EventListener interface is the primary method for handling events. Users implement the EventListener interface and register their listener on an EventTarget using the AddEventListener method. The users should also remove their EventListener from its EventTarget after they have completed using the listener.

When a Node is copied using the cloneNode method the EventListeners attached to the source Node are not attached to the copied Node. If the user wishes the same EventListeners to be added to the newly created copy the user must add them manually.

See also the Document Object Model (DOM) Level 2 Events Specification.

Since:
DOM Level 2

Method Summary
Modifier and Type | Method and Description
void | handleEvent(Event evt) This method is called whenever an event occurs of the type for which the EventListener interface was registered.

Method Detail

handleEvent

void handleEvent(Event evt)
This method is called whenever an event occurs of the type for which the EventListener interface was registered.

Parameters:
evt - The Event contains contextual information about the event. It also contains the stopPropagation and preventDefault methods which are used in determining the event's flow and default action.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


EventTarget (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom.events
Interface EventTarget

public interface EventTarget

The EventTarget interface is implemented by all Nodes in an implementation which supports the DOM Event Model. Therefore, this interface can be obtained by using binding-specific casting methods on an instance of the Node interface. The interface allows registration and removal of EventListeners on an EventTarget and dispatch of events to that EventTarget.

See also the Document Object Model (DOM) Level 2 Events Specification.

Since:
DOM Level 2

Method Summary
Modifier and Type | Method and Description
void | addEventListener(String type, EventListener listener, boolean useCapture) This method allows the registration of event listeners on the event target.
boolean | dispatchEvent(Event evt) This method allows the dispatch of events into the implementations event model.
void | removeEventListener(String type, EventListener listener, boolean useCapture) This method allows the removal of event listeners from the event target.

Method Detail

addEventListener

void addEventListener(String type,
                      EventListener listener,
                      boolean useCapture)
This method allows the registration of event listeners on the event target. If an EventListener is added to an EventTarget while it is processing an event, it will not be triggered by the current actions but may be triggered during a later stage of event flow, such as the bubbling phase.
If multiple identical EventListeners are registered on the same EventTarget with the same parameters the duplicate instances are discarded. They do not cause the EventListener to be called twice and since they are discarded they do not need to be removed with the removeEventListener method.

Parameters:
type - The event type for which the user is registering
listener - The listener parameter takes an interface implemented by the user which contains the methods to be called when the event occurs.
useCapture - If true, useCapture indicates that the user wishes to initiate capture. After initiating capture, all events of the specified type will be dispatched to the registered EventListener before being dispatched to any EventTargets beneath them in the tree. Events which are bubbling upward through the tree will not trigger an EventListener designated to use capture.

removeEventListener

void removeEventListener(String type,
                         EventListener listener,
                         boolean useCapture)
This method allows the removal of event listeners from the event target. If an EventListener is removed from an EventTarget while it is processing an event, it will not be triggered by the current actions. EventListeners can never be invoked after being removed.
Calling removeEventListener with arguments which do not identify any currently registered EventListener on the EventTarget has no effect.

Parameters:
type - Specifies the event type of the EventListener being removed.
listener - The EventListener parameter indicates the EventListener to be removed.
useCapture - Specifies whether the EventListener being removed was registered as a capturing listener or not. If a listener was registered twice, one with capture and one without, each must be removed separately. Removal of a capturing listener does not affect a non-capturing version of the same listener, and vice versa.

dispatchEvent

boolean dispatchEvent(Event evt)
                      throws EventException
This method allows the dispatch of events into the implementations event model. Events dispatched in this manner will have the same capturing and bubbling behavior as events dispatched directly by the implementation. The target of the event is the EventTarget on which dispatchEvent is called.

Parameters:
evt - Specifies the event type, behavior, and contextual information to be used in processing the event.
Returns:
The return value of dispatchEvent indicates whether any of the listeners which handled the event called preventDefault. If preventDefault was called the value is false, else the value is true.
Throws:
EventException - UNSPECIFIED_EVENT_TYPE_ERR: Raised if the Event's type was not specified by initializing the event before dispatchEvent was called. Specification of the Event's type as null or an empty string will also trigger this exception.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


MouseEvent (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom.events
Interface MouseEvent

All Superinterfaces:
Event, UIEvent
public interface MouseEvent
extends UIEvent

The MouseEvent interface provides specific contextual information associated with Mouse events.

The detail attribute inherited from UIEvent indicates the number of times a mouse button has been pressed and released over the same screen location during a user action. The attribute value is 1 when the user begins this action and increments by 1 for each full sequence of pressing and releasing. If the user moves the mouse between the mousedown and mouseup the value will be set to 0, indicating that no click is occurring.

In the case of nested elements mouse events are always targeted at the most deeply nested element. Ancestors of the targeted element may use bubbling to obtain notification of mouse events which occur within its descendent elements.

See also the Document Object Model (DOM) Level 2 Events Specification.

Since:
DOM Level 2

Field Summary
Modifier and Type Field and Description
Fields inherited from interface org.w3c.dom.events.Event
AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE
Method Summary
Modifier and Type | Method and Description
boolean | getAltKey() Used to indicate whether the 'alt' key was depressed during the firing of the event.
short | getButton() During mouse events caused by the depression or release of a mouse button, button is used to indicate which mouse button changed state.
int | getClientX() The horizontal coordinate at which the event occurred relative to the DOM implementation's client area.
int | getClientY() The vertical coordinate at which the event occurred relative to the DOM implementation's client area.
boolean | getCtrlKey() Used to indicate whether the 'ctrl' key was depressed during the firing of the event.
boolean | getMetaKey() Used to indicate whether the 'meta' key was depressed during the firing of the event.
EventTarget | getRelatedTarget() Used to identify a secondary EventTarget related to a UI event.
int | getScreenX() The horizontal coordinate at which the event occurred relative to the origin of the screen coordinate system.
int | getScreenY() The vertical coordinate at which the event occurred relative to the origin of the screen coordinate system.
boolean | getShiftKey() Used to indicate whether the 'shift' key was depressed during the firing of the event.
void | initMouseEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, org.w3c.dom.views.AbstractView viewArg, int detailArg, int screenXArg, int screenYArg, int clientXArg, int clientYArg, boolean ctrlKeyArg, boolean altKeyArg, boolean shiftKeyArg, boolean metaKeyArg, short buttonArg, EventTarget relatedTargetArg) The initMouseEvent method is used to initialize the value of a MouseEvent created through the DocumentEvent interface.
Methods inherited from interface org.w3c.dom.events.UIEvent
getDetail, getView, initUIEvent
Methods inherited from interface org.w3c.dom.events.Event
getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

Method Detail

getScreenX

int getScreenX()
The horizontal coordinate at which the event occurred relative to the origin of the screen coordinate system.

getScreenY

int getScreenY()
The vertical coordinate at which the event occurred relative to the origin of the screen coordinate system.

getClientX

int getClientX()
The horizontal coordinate at which the event occurred relative to the DOM implementation's client area.

getClientY

int getClientY()
The vertical coordinate at which the event occurred relative to the DOM implementation's client area.

getCtrlKey

boolean getCtrlKey()
Used to indicate whether the 'ctrl' key was depressed during the firing of the event.

getShiftKey

boolean getShiftKey()
Used to indicate whether the 'shift' key was depressed during the firing of the event.

getAltKey

boolean getAltKey()
Used to indicate whether the 'alt' key was depressed during the firing of the event. On some platforms this key may map to an alternative key name.

getMetaKey

boolean getMetaKey()
Used to indicate whether the 'meta' key was depressed during the firing of the event. On some platforms this key may map to an alternative key name.

getButton

short getButton()
During mouse events caused by the depression or release of a mouse button, button is used to indicate which mouse button changed state. The values for button range from zero to indicate the left button of the mouse, one to indicate the middle button if present, and two to indicate the right button. For mice configured for left handed use in which the button actions are reversed the values are instead read from right to left.

getRelatedTarget

EventTarget getRelatedTarget()
Used to identify a secondary EventTarget related to a UI event. Currently this attribute is used with the mouseover event to indicate the EventTarget which the pointing device exited and with the mouseout event to indicate the EventTarget which the pointing device entered.

initMouseEvent

void initMouseEvent(String typeArg,
                    boolean canBubbleArg,
                    boolean cancelableArg,
                    org.w3c.dom.views.AbstractView viewArg,
                    int detailArg,
                    int screenXArg,
                    int screenYArg,
                    int clientXArg,
                    int clientYArg,
                    boolean ctrlKeyArg,
                    boolean altKeyArg,
                    boolean shiftKeyArg,
                    boolean metaKeyArg,
                    short buttonArg,
                    EventTarget relatedTargetArg)
The initMouseEvent method is used to initialize the value of a MouseEvent created through the DocumentEvent interface. This method may only be called before the MouseEvent has been dispatched via the dispatchEvent method, though it may be called multiple times during that phase if necessary. If called multiple times, the final invocation takes precedence.

Parameters:
typeArg - Specifies the event type.
canBubbleArg - Specifies whether or not the event can bubble.
cancelableArg - Specifies whether or not the event's default action can be prevented.
viewArg - Specifies the Event's AbstractView.
detailArg - Specifies the Event's mouse click count.
screenXArg - Specifies the Event's screen x coordinate
screenYArg - Specifies the Event's screen y coordinate
clientXArg - Specifies the Event's client x coordinate
clientYArg - Specifies the Event's client y coordinate
ctrlKeyArg - Specifies whether or not control key was depressed during the Event.
altKeyArg - Specifies whether or not alt key was depressed during the Event.
shiftKeyArg - Specifies whether or not shift key was depressed during the Event.
metaKeyArg - Specifies whether or not meta key was depressed during the Event.
buttonArg - Specifies the Event's mouse button.
relatedTargetArg - Specifies the Event's related EventTarget.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


MutationEvent (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom.events
Interface MutationEvent

All Superinterfaces:
Event
public interface MutationEvent
extends Event

The MutationEvent interface provides specific contextual information associated with Mutation events.

See also the Document Object Model (DOM) Level 2 Events Specification.

Since:
DOM Level 2

Field Summary
Modifier and Type | Field and Description
static short | ADDITION The Attr was just added.
static short | MODIFICATION The Attr was modified in place.
static short | REMOVAL The Attr was just removed.
Fields inherited from interface org.w3c.dom.events.Event
AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE
Method Summary
Modifier and Type | Method and Description
short | getAttrChange() attrChange indicates the type of change which triggered the DOMAttrModified event.
String | getAttrName() attrName indicates the name of the changed Attr node in a DOMAttrModified event.
String | getNewValue() newValue indicates the new value of the Attr node in DOMAttrModified events, and of the CharacterData node in DOMCharacterDataModified events.
String | getPrevValue() prevValue indicates the previous value of the Attr node in DOMAttrModified events, and of the CharacterData node in DOMCharacterDataModified events.
Node | getRelatedNode() relatedNode is used to identify a secondary node related to a mutation event.
void | initMutationEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, Node relatedNodeArg, String prevValueArg, String newValueArg, String attrNameArg, short attrChangeArg) The initMutationEvent method is used to initialize the value of a MutationEvent created through the DocumentEvent interface.
Methods inherited from interface org.w3c.dom.events.Event
getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

Field Detail

MODIFICATION

static final short MODIFICATION
The Attr was modified in place.

See Also:
Constant Field Values

ADDITION

static final short ADDITION
The Attr was just added.

See Also:
Constant Field Values

REMOVAL

static final short REMOVAL
The Attr was just removed.

See Also:
Constant Field Values
Method Detail

getRelatedNode

Node getRelatedNode()
relatedNode is used to identify a secondary node related to a mutation event. For example, if a mutation event is dispatched to a node indicating that its parent has changed, the relatedNode is the changed parent. If an event is instead dispatched to a subtree indicating a node was changed within it, the relatedNode is the changed node. In the case of the DOMAttrModified event it indicates the Attr node which was modified, added, or removed.

getPrevValue

String getPrevValue()
prevValue indicates the previous value of the Attr node in DOMAttrModified events, and of the CharacterData node in DOMCharacterDataModified events.

getNewValue

String getNewValue()
newValue indicates the new value of the Attr node in DOMAttrModified events, and of the CharacterData node in DOMCharacterDataModified events.

getAttrName

String getAttrName()
attrName indicates the name of the changed Attr node in a DOMAttrModified event.

getAttrChange

short getAttrChange()
attrChange indicates the type of change which triggered the DOMAttrModified event. The values can be MODIFICATION , ADDITION, or REMOVAL.

initMutationEvent

void initMutationEvent(String typeArg,
                       boolean canBubbleArg,
                       boolean cancelableArg,
                       Node relatedNodeArg,
                       String prevValueArg,
                       String newValueArg,
                       String attrNameArg,
                       short attrChangeArg)
The initMutationEvent method is used to initialize the value of a MutationEvent created through the DocumentEvent interface. This method may only be called before the MutationEvent has been dispatched via the dispatchEvent method, though it may be called multiple times during that phase if necessary. If called multiple times, the final invocation takes precedence.

Parameters:
typeArg - Specifies the event type.
canBubbleArg - Specifies whether or not the event can bubble.
cancelableArg - Specifies whether or not the event's default action can be prevented.
relatedNodeArg - Specifies the Event's related Node.
prevValueArg - Specifies the Event's prevValue attribute. This value may be null.
newValueArg - Specifies the Event's newValue attribute. This value may be null.
attrNameArg - Specifies the Event's attrName attribute. This value may be null.
attrChangeArg - Specifies the Event's attrChange attribute
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


org.w3c.dom.events (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.w3c.dom.events

Interface Summary
Interface | Description
DocumentEvent | The DocumentEvent interface provides a mechanism by which the user can create an Event of a type supported by the implementation.
Event | The Event interface is used to provide contextual information about an event to the handler processing the event.
EventListener | The EventListener interface is the primary method for handling events.
EventTarget | The EventTarget interface is implemented by all Nodes in an implementation which supports the DOM Event Model.
MouseEvent | The MouseEvent interface provides specific contextual information associated with Mouse events.
MutationEvent | The MutationEvent interface provides specific contextual information associated with Mutation events.
UIEvent | The UIEvent interface provides specific contextual information associated with User Interface events.

Exception Summary
Exception | Description
EventException | Event operations may throw an EventException as specified in their method descriptions.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


UIEvent (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.w3c.dom.events
Interface UIEvent

All Superinterfaces:
Event
All Known Subinterfaces:
MouseEvent
public interface UIEvent
extends Event

The UIEvent interface provides specific contextual information associated with User Interface events.

See also the Document Object Model (DOM) Level 2 Events Specification.

Since:
DOM Level 2

Field Summary
Modifier and Type Field and Description
Fields inherited from interface org.w3c.dom.events.Event
AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE
Method Summary
Modifier and Type | Method and Description
int | getDetail() Specifies some detail information about the Event, depending on the type of event.
org.w3c.dom.views.AbstractView | getView() The view attribute identifies the AbstractView from which the event was generated.
void | initUIEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, org.w3c.dom.views.AbstractView viewArg, int detailArg) The initUIEvent method is used to initialize the value of a UIEvent created through the DocumentEvent interface.
Methods inherited from interface org.w3c.dom.events.Event
getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

Method Detail

getView

org.w3c.dom.views.AbstractView getView()
The view attribute identifies the AbstractView from which the event was generated.

getDetail

int getDetail()
Specifies some detail information about the Event, depending on the type of event.

initUIEvent

void initUIEvent(String typeArg,
                 boolean canBubbleArg,
                 boolean cancelableArg,
                 org.w3c.dom.views.AbstractView viewArg,
                 int detailArg)
The initUIEvent method is used to initialize the value of a UIEvent created through the DocumentEvent interface. This method may only be called before the UIEvent has been dispatched via the dispatchEvent method, though it may be called multiple times during that phase if necessary. If called multiple times, the final invocation takes precedence.

Parameters:
typeArg - Specifies the event type.
canBubbleArg - Specifies whether or not the event can bubble.
cancelableArg - Specifies whether or not the event's default action can be prevented.
viewArg - Specifies the Event's AbstractView.
detailArg - Specifies the Event's detail.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DOMImplementationLS (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.w3c.dom.ls
Interface DOMImplementationLS

public interface DOMImplementationLS

DOMImplementationLS contains the factory methods for creating Load and Save objects.

The expectation is that an instance of the DOMImplementationLS interface can be obtained by using binding-specific casting methods on an instance of the DOMImplementation interface or, if the Document supports the feature "Core" version "3.0" defined in [DOM Level 3 Core] , by using the method DOMImplementation.getFeature with parameter values "LS" (or "LS-Async") and "3.0" (respectively).

See also the Document Object Model (DOM) Level 3 Load and Save Specification.

Field Summary
Modifier and Type | Field and Description
static short | MODE_ASYNCHRONOUS Create an asynchronous LSParser.
static short | MODE_SYNCHRONOUS Create a synchronous LSParser.
Method Summary
Modifier and Type | Method and Description
LSInput | createLSInput() Create a new empty input source object where LSInput.characterStream, LSInput.byteStream , LSInput.stringData LSInput.systemId, LSInput.publicId, LSInput.baseURI, and LSInput.encoding are null, and LSInput.certifiedText is false.
LSOutput | createLSOutput() Create a new empty output destination object where LSOutput.characterStream, LSOutput.byteStream, LSOutput.systemId, LSOutput.encoding are null.
LSParser | createLSParser(short mode, String schemaType) Create a new LSParser.
LSSerializer | createLSSerializer() Create a new LSSerializer object.

Field Detail

MODE_SYNCHRONOUS

static final short MODE_SYNCHRONOUS
Create a synchronous LSParser.

See Also:
Constant Field Values

MODE_ASYNCHRONOUS

static final short MODE_ASYNCHRONOUS
Create an asynchronous LSParser.

See Also:
Constant Field Values
Method Detail

createLSParser

LSParser createLSParser(short mode,
                        String schemaType)
                        throws DOMException
Create a new LSParser. The newly constructed parser may then be configured by means of its DOMConfiguration object, and used to parse documents by means of its parse method.

Parameters:
mode - The mode argument is either MODE_SYNCHRONOUS or MODE_ASYNCHRONOUS, if mode is MODE_SYNCHRONOUS then the LSParser that is created will operate in synchronous mode, if it's MODE_ASYNCHRONOUS then the LSParser that is created will operate in asynchronous mode.
schemaType - An absolute URI representing the type of the schema language used during the load of a Document using the newly created LSParser. Note that no lexical checking is done on the absolute URI. In order to create a LSParser for any kind of schema types (i.e. the LSParser will be free to use any schema found), use the value null.

Note: For W3C XML Schema [XML Schema Part 1] , applications must use the value "http://www.w3.org/2001/XMLSchema". For XML DTD [XML 1.0], applications must use the value "http://www.w3.org/TR/REC-xml". Other Schema languages are outside the scope of the W3C and therefore should recommend an absolute URI in order to use this method.

Returns:
The newly created LSParser object. This LSParser is either synchronous or asynchronous depending on the value of the mode argument.

Note: By default, the newly created LSParser does not contain a DOMErrorHandler, i.e. the value of the " error-handler" configuration parameter is null. However, implementations may provide a default error handler at creation time. In that case, the initial value of the "error-handler" configuration parameter on the new LSParser object contains a reference to the default error handler.

Throws:
DOMException - NOT_SUPPORTED_ERR: Raised if the requested mode or schema type is not supported.

createLSSerializer

LSSerializer createLSSerializer()
Create a new LSSerializer object.

Returns:
The newly created LSSerializer object.

Note: By default, the newly created LSSerializer has no DOMErrorHandler, i.e. the value of the "error-handler" configuration parameter is null. However, implementations may provide a default error handler at creation time. In that case, the initial value of the "error-handler" configuration parameter on the new LSSerializer object contains a reference to the default error handler.

createLSInput

LSInput createLSInput()
Create a new empty input source object where LSInput.characterStream, LSInput.byteStream , LSInput.stringData LSInput.systemId, LSInput.publicId, LSInput.baseURI, and LSInput.encoding are null, and LSInput.certifiedText is false.

Returns:
The newly created input object.

createLSOutput

LSOutput createLSOutput()
Create a new empty output destination object where LSOutput.characterStream, LSOutput.byteStream, LSOutput.systemId, LSOutput.encoding are null.

Returns:
The newly created output object.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


LSException (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom.ls
Class LSException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.w3c.dom.ls.LSException
All Implemented Interfaces:
Serializable
public class LSException
extends RuntimeException

Parser or write operations may throw an LSException if the processing is stopped. The processing can be stopped due to a DOMError with a severity of DOMError.SEVERITY_FATAL_ERROR or a non recovered DOMError.SEVERITY_ERROR, or if DOMErrorHandler.handleError() returned false.

Note: As suggested in the definition of the constants in the DOMError interface, a DOM implementation may choose to continue after a fatal error, but the resulting DOM tree is then implementation dependent.

See also the Document Object Model (DOM) Level 3 Load and Save Specification.

See Also:
Serialized Form

Field Summary
Modifier and Type | Field and Description
short | code
static short | PARSE_ERR If an attempt was made to load a document, or an XML Fragment, using LSParser and the processing has been stopped.
static short | SERIALIZE_ERR If an attempt was made to serialize a Node using LSSerializer and the processing has been stopped.
Constructor Summary
Constructor and Description
LSException(short code, String message)
Method Summary
Modifier and Type Method and Description
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

code

public short code

PARSE_ERR

public static final short PARSE_ERR
If an attempt was made to load a document, or an XML Fragment, using LSParser and the processing has been stopped.

See Also:
Constant Field Values

SERIALIZE_ERR

public static final short SERIALIZE_ERR
If an attempt was made to serialize a Node using LSSerializer and the processing has been stopped.

See Also:
Constant Field Values
Constructor Detail

LSException

public LSException(short code,
                   String message)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


LSInput (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom.ls
Interface LSInput

public interface LSInput

This interface represents an input source for data.

This interface allows an application to encapsulate information about an input source in a single object, which may include a public identifier, a system identifier, a byte stream (possibly with a specified encoding), a base URI, and/or a character stream.

The exact definitions of a byte stream and a character stream are binding dependent.

The application is expected to provide objects that implement this interface whenever such objects are needed. The application can either provide its own objects that implement this interface, or it can use the generic factory method DOMImplementationLS.createLSInput() to create objects that implement this interface.

The LSParser will use the LSInput object to determine how to read data. The LSParser will look at the different inputs specified in the LSInput in the following order to know which one to read from, the first one that is not null and not an empty string will be used:

  1. LSInput.characterStream
  2. LSInput.byteStream
  3. LSInput.stringData
  4. LSInput.systemId
  5. LSInput.publicId

If all inputs are null, the LSParser will report a DOMError with its DOMError.type set to "no-input-specified" and its DOMError.severity set to DOMError.SEVERITY_FATAL_ERROR.

LSInput objects belong to the application. The DOM implementation will never modify them (though it may make copies and modify the copies, if necessary).

See also the Document Object Model (DOM) Level 3 Load and Save Specification.

Method Summary
Modifier and Type | Method and Description
String | getBaseURI() The base URI to be used (see section 5.1.4 in [IETF RFC 2396]) for resolving a relative systemId to an absolute URI.
InputStream | getByteStream() An attribute of a language and binding dependent type that represents a stream of bytes.
boolean | getCertifiedText() If set to true, assume that the input is certified (see section 2.13 in [XML 1.1]) when parsing [XML 1.1].
Reader | getCharacterStream() An attribute of a language and binding dependent type that represents a stream of 16-bit units.
String | getEncoding() The character encoding, if known.
String | getPublicId() The public identifier for this input source.
String | getStringData() String data to parse.
String | getSystemId() The system identifier, a URI reference [IETF RFC 2396], for this input source.
void | setBaseURI(String baseURI) The base URI to be used (see section 5.1.4 in [IETF RFC 2396]) for resolving a relative systemId to an absolute URI.
void | setByteStream(InputStream byteStream) An attribute of a language and binding dependent type that represents a stream of bytes.
void | setCertifiedText(boolean certifiedText) If set to true, assume that the input is certified (see section 2.13 in [XML 1.1]) when parsing [XML 1.1].
void | setCharacterStream(Reader characterStream) An attribute of a language and binding dependent type that represents a stream of 16-bit units.
void | setEncoding(String encoding) The character encoding, if known.
void | setPublicId(String publicId) The public identifier for this input source.
void | setStringData(String stringData) String data to parse.
void | setSystemId(String systemId) The system identifier, a URI reference [IETF RFC 2396], for this input source.

Method Detail

getCharacterStream

Reader getCharacterStream()
An attribute of a language and binding dependent type that represents a stream of 16-bit units. The application must encode the stream using UTF-16 (defined in [Unicode] and in [ISO/IEC 10646]). It is not a requirement to have an XML declaration when using character streams. If an XML declaration is present, the value of the encoding attribute will be ignored.

setCharacterStream

void setCharacterStream(Reader characterStream)
An attribute of a language and binding dependent type that represents a stream of 16-bit units. The application must encode the stream using UTF-16 (defined in [Unicode] and in [ISO/IEC 10646]). It is not a requirement to have an XML declaration when using character streams. If an XML declaration is present, the value of the encoding attribute will be ignored.

getByteStream

InputStream getByteStream()
An attribute of a language and binding dependent type that represents a stream of bytes.
If the application knows the character encoding of the byte stream, it should set the encoding attribute. Setting the encoding in this way will override any encoding specified in an XML declaration in the data.

setByteStream

void setByteStream(InputStream byteStream)
An attribute of a language and binding dependent type that represents a stream of bytes.
If the application knows the character encoding of the byte stream, it should set the encoding attribute. Setting the encoding in this way will override any encoding specified in an XML declaration in the data.

getStringData

String getStringData()
String data to parse. If provided, this will always be treated as a sequence of 16-bit units (UTF-16 encoded characters). It is not a requirement to have an XML declaration when using stringData. If an XML declaration is present, the value of the encoding attribute will be ignored.

setStringData

void setStringData(String stringData)
String data to parse. If provided, this will always be treated as a sequence of 16-bit units (UTF-16 encoded characters). It is not a requirement to have an XML declaration when using stringData. If an XML declaration is present, the value of the encoding attribute will be ignored.

getSystemId

String getSystemId()
The system identifier, a URI reference [IETF RFC 2396], for this input source. The system identifier is optional if there is a byte stream, a character stream, or string data. It is still useful to provide one, since the application will use it to resolve any relative URIs and can include it in error messages and warnings. (The LSParser will only attempt to fetch the resource identified by the URI reference if there is no other input available in the input source.)
If the application knows the character encoding of the object pointed to by the system identifier, it can set the encoding using the encoding attribute.
If the specified system ID is a relative URI reference (see section 5 in [IETF RFC 2396]), the DOM implementation will attempt to resolve the relative URI with the baseURI as the base, if that fails, the behavior is implementation dependent.

setSystemId

void setSystemId(String systemId)
The system identifier, a URI reference [IETF RFC 2396], for this input source. The system identifier is optional if there is a byte stream, a character stream, or string data. It is still useful to provide one, since the application will use it to resolve any relative URIs and can include it in error messages and warnings. (The LSParser will only attempt to fetch the resource identified by the URI reference if there is no other input available in the input source.)
If the application knows the character encoding of the object pointed to by the system identifier, it can set the encoding using the encoding attribute.
If the specified system ID is a relative URI reference (see section 5 in [IETF RFC 2396]), the DOM implementation will attempt to resolve the relative URI with the baseURI as the base, if that fails, the behavior is implementation dependent.

getPublicId

String getPublicId()
The public identifier for this input source. This may be mapped to an input source using an implementation dependent mechanism (such as catalogues or other mappings). The public identifier, if specified, may also be reported as part of the location information when errors are reported.

setPublicId

void setPublicId(String publicId)
The public identifier for this input source. This may be mapped to an input source using an implementation dependent mechanism (such as catalogues or other mappings). The public identifier, if specified, may also be reported as part of the location information when errors are reported.

getBaseURI

String getBaseURI()
The base URI to be used (see section 5.1.4 in [IETF RFC 2396]) for resolving a relative systemId to an absolute URI.
If, when used, the base URI is itself a relative URI, an empty string, or null, the behavior is implementation dependent.

setBaseURI

void setBaseURI(String baseURI)
The base URI to be used (see section 5.1.4 in [IETF RFC 2396]) for resolving a relative systemId to an absolute URI.
If, when used, the base URI is itself a relative URI, an empty string, or null, the behavior is implementation dependent.

getEncoding

String getEncoding()
The character encoding, if known. The encoding must be a string acceptable for an XML encoding declaration ([XML 1.0] section 4.3.3 "Character Encoding in Entities").
This attribute has no effect when the application provides a character stream or string data. For other sources of input, an encoding specified by means of this attribute will override any encoding specified in the XML declaration or the Text declaration, or an encoding obtained from a higher level protocol, such as HTTP [IETF RFC 2616].

setEncoding

void setEncoding(String encoding)
The character encoding, if known. The encoding must be a string acceptable for an XML encoding declaration ([XML 1.0] section 4.3.3 "Character Encoding in Entities").
This attribute has no effect when the application provides a character stream or string data. For other sources of input, an encoding specified by means of this attribute will override any encoding specified in the XML declaration or the Text declaration, or an encoding obtained from a higher level protocol, such as HTTP [IETF RFC 2616].

getCertifiedText

boolean getCertifiedText()
If set to true, assume that the input is certified (see section 2.13 in [XML 1.1]) when parsing [XML 1.1].

setCertifiedText

void setCertifiedText(boolean certifiedText)
If set to true, assume that the input is certified (see section 2.13 in [XML 1.1]) when parsing [XML 1.1].

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


LSLoadEvent (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom.ls
Interface LSLoadEvent

All Superinterfaces:
Event
public interface LSLoadEvent
extends Event

This interface represents a load event object that signals the completion of a document load.

See also the Document Object Model (DOM) Level 3 Load and Save Specification.

Field Summary
Modifier and Type Field and Description
Fields inherited from interface org.w3c.dom.events.Event
AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE
Method Summary
Modifier and Type | Method and Description
LSInput | getInput() The input source that was parsed.
Document | getNewDocument() The document that finished loading.
Methods inherited from interface org.w3c.dom.events.Event
getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

Method Detail

getNewDocument

Document getNewDocument()
The document that finished loading.

getInput

LSInput getInput()
The input source that was parsed.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


LSOutput (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom.ls
Interface LSOutput

public interface LSOutput

This interface represents an output destination for data.

This interface allows an application to encapsulate information about an output destination in a single object, which may include a URI, a byte stream (possibly with a specified encoding), a base URI, and/or a character stream.

The exact definitions of a byte stream and a character stream are binding dependent.

The application is expected to provide objects that implement this interface whenever such objects are needed. The application can either provide its own objects that implement this interface, or it can use the generic factory method DOMImplementationLS.createLSOutput() to create objects that implement this interface.

The LSSerializer will use the LSOutput object to determine where to serialize the output to. The LSSerializer will look at the different outputs specified in the LSOutput in the following order to know which one to output to, the first one that is not null and not an empty string will be used:

  1. LSOutput.characterStream
  2. LSOutput.byteStream
  3. LSOutput.systemId

LSOutput objects belong to the application. The DOM implementation will never modify them (though it may make copies and modify the copies, if necessary).

See also the Document Object Model (DOM) Level 3 Load and Save Specification.

Method Summary
Modifier and Type | Method and Description
OutputStream | getByteStream() An attribute of a language and binding dependent type that represents a writable stream of bytes.
Writer | getCharacterStream() An attribute of a language and binding dependent type that represents a writable stream to which 16-bit units can be output.
String | getEncoding() The character encoding to use for the output.
String | getSystemId() The system identifier, a URI reference [IETF RFC 2396], for this output destination.
void | setByteStream(OutputStream byteStream) An attribute of a language and binding dependent type that represents a writable stream of bytes.
void | setCharacterStream(Writer characterStream) An attribute of a language and binding dependent type that represents a writable stream to which 16-bit units can be output.
void | setEncoding(String encoding) The character encoding to use for the output.
void | setSystemId(String systemId) The system identifier, a URI reference [IETF RFC 2396], for this output destination.

Method Detail

getCharacterStream

Writer getCharacterStream()
An attribute of a language and binding dependent type that represents a writable stream to which 16-bit units can be output.

setCharacterStream

void setCharacterStream(Writer characterStream)
An attribute of a language and binding dependent type that represents a writable stream to which 16-bit units can be output.

getByteStream

OutputStream getByteStream()
An attribute of a language and binding dependent type that represents a writable stream of bytes.

setByteStream

void setByteStream(OutputStream byteStream)
An attribute of a language and binding dependent type that represents a writable stream of bytes.

getSystemId

String getSystemId()
The system identifier, a URI reference [IETF RFC 2396], for this output destination.
If the system ID is a relative URI reference (see section 5 in [IETF RFC 2396]), the behavior is implementation dependent.

setSystemId

void setSystemId(String systemId)
The system identifier, a URI reference [IETF RFC 2396], for this output destination.
If the system ID is a relative URI reference (see section 5 in [IETF RFC 2396]), the behavior is implementation dependent.

getEncoding

String getEncoding()
The character encoding to use for the output. The encoding must be a string acceptable for an XML encoding declaration ([XML 1.0] section 4.3.3 "Character Encoding in Entities"), it is recommended that character encodings registered (as charsets) with the Internet Assigned Numbers Authority [IANA-CHARSETS] should be referred to using their registered names.

setEncoding

void setEncoding(String encoding)
The character encoding to use for the output. The encoding must be a string acceptable for an XML encoding declaration ([XML 1.0] section 4.3.3 "Character Encoding in Entities"), it is recommended that character encodings registered (as charsets) with the Internet Assigned Numbers Authority [IANA-CHARSETS] should be referred to using their registered names.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


LSParser (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom.ls
Interface LSParser

public interface LSParser

An interface to an object that is able to build, or augment, a DOM tree from various input sources.

LSParser provides an API for parsing XML and building the corresponding DOM document structure. A LSParser instance can be obtained by invoking the DOMImplementationLS.createLSParser() method.

As specified in [DOM Level 3 Core] , when a document is first made available via the LSParser:

  • there will never be two adjacent nodes of type NODE_TEXT, and there will never be empty text nodes.
  • it is expected that the value and nodeValue attributes of an Attr node initially return the XML 1.0 normalized value. However, if the parameters " validate-if-schema" and " datatype-normalization" are set to true, depending on the attribute normalization used, the attribute values may differ from the ones obtained by the XML 1.0 attribute normalization. If the parameters " datatype-normalization" is set to false, the XML 1.0 attribute normalization is guaranteed to occur, and if the attributes list does not contain namespace declarations, the attributes attribute on Element node represents the property [attributes] defined in [XML Information Set] .

Asynchronous LSParser objects are expected to also implement the events::EventTarget interface so that event listeners can be registered on asynchronous LSParser objects.

Events supported by asynchronous LSParser objects are:

load
The LSParser finishes to load the document. See also the definition of the LSLoadEvent interface.
progress
The LSParser signals progress as data is parsed. This specification does not attempt to define exactly when progress events should be dispatched. That is intentionally left as implementation-dependent. Here is one example of how an application might dispatch progress events: Once the parser starts receiving data, a progress event is dispatched to indicate that the parsing starts. From there on, a progress event is dispatched for every 4096 bytes of data that is received and processed. This is only one example, though, and implementations can choose to dispatch progress events at any time while parsing, or not dispatch them at all. See also the definition of the LSProgressEvent interface.

Note: All events defined in this specification use the namespace URI "http://www.w3.org/2002/DOMLS".

While parsing an input source, errors are reported to the application through the error handler (LSParser.domConfig's " error-handler" parameter). This specification does in no way try to define all possible errors that can occur while parsing XML, or any other markup, but some common error cases are defined. The types (DOMError.type) of errors and warnings defined by this specification are:

"check-character-normalization-failure" [error]
Raised if the parameter " check-character-normalization" is set to true and a string is encountered that fails normalization checking.
"doctype-not-allowed" [fatal]
Raised if the configuration parameter "disallow-doctype" is set to true and a doctype is encountered.
"no-input-specified" [fatal]
Raised when loading a document and no input is specified in the LSInput object.
"pi-base-uri-not-preserved" [warning]
Raised if a processing instruction is encountered in a location where the base URI of the processing instruction can not be preserved. One example of a case where this warning will be raised is if the configuration parameter " entities" is set to false and the following XML file is parsed:
 <!DOCTYPE root [ <!ENTITY e SYSTEM 'subdir/myentity.ent' ]>
 <root> &e; </root>
And subdir/myentity.ent contains:
<one> <two/> </one> <?pi 3.14159?>
 <more/>
"unbound-prefix-in-entity" [warning]
An implementation dependent warning that may be raised if the configuration parameter " namespaces" is set to true and an unbound namespace prefix is encountered in an entity's replacement text. Raising this warning is not enforced since some existing parsers may not recognize unbound namespace prefixes in the replacement text of entities.
"unknown-character-denormalization" [fatal]
Raised if the configuration parameter "ignore-unknown-character-denormalizations" is set to false and a character is encountered for which the processor cannot determine the normalization properties.
"unsupported-encoding" [fatal]
Raised if an unsupported encoding is encountered.
"unsupported-media-type" [fatal]
Raised if the configuration parameter "supported-media-types-only" is set to true and an unsupported media type is encountered.

In addition to raising the defined errors and warnings, implementations are expected to raise implementation specific errors and warnings for any other error and warning cases such as IO errors (file not found, permission denied,...), XML well-formedness errors, and so on.

See also the Document Object Model (DOM) Level 3 Load and Save Specification.

Field Summary
Modifier and Type | Field and Description
static short | ACTION_APPEND_AS_CHILDREN Append the result of the parse operation as children of the context node.
static short | ACTION_INSERT_AFTER Insert the result of the parse operation as the immediately following sibling of the context node.
static short | ACTION_INSERT_BEFORE Insert the result of the parse operation as the immediately preceding sibling of the context node.
static short | ACTION_REPLACE Replace the context node with the result of the parse operation.
static short | ACTION_REPLACE_CHILDREN Replace all the children of the context node with the result of the parse operation.
Method Summary
Modifier and Type | Method and Description
void | abort() Abort the loading of the document that is currently being loaded by the LSParser.
boolean | getAsync() true if the LSParser is asynchronous, false if it is synchronous.
boolean | getBusy() true if the LSParser is currently busy loading a document, otherwise false.
DOMConfiguration | getDomConfig() The DOMConfiguration object used when parsing an input source.
LSParserFilter | getFilter() When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure.
Document | parse(LSInput input) Parse an XML document from a resource identified by a LSInput.
Document | parseURI(String uri) Parse an XML document from a location identified by a URI reference [IETF RFC 2396].
Node | parseWithContext(LSInput input, Node contextArg, short action) Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments.
void | setFilter(LSParserFilter filter) When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure.

Field Detail

ACTION_APPEND_AS_CHILDREN

static final short ACTION_APPEND_AS_CHILDREN
Append the result of the parse operation as children of the context node. For this action to work, the context node must be an Element or a DocumentFragment.

See Also:
Constant Field Values

ACTION_REPLACE_CHILDREN

static final short ACTION_REPLACE_CHILDREN
Replace all the children of the context node with the result of the parse operation. For this action to work, the context node must be an Element, a Document, or a DocumentFragment.

See Also:
Constant Field Values

ACTION_INSERT_BEFORE

static final short ACTION_INSERT_BEFORE
Insert the result of the parse operation as the immediately preceding sibling of the context node. For this action to work the context node's parent must be an Element or a DocumentFragment.

See Also:
Constant Field Values

ACTION_INSERT_AFTER

static final short ACTION_INSERT_AFTER
Insert the result of the parse operation as the immediately following sibling of the context node. For this action to work the context node's parent must be an Element or a DocumentFragment.

See Also:
Constant Field Values

ACTION_REPLACE

static final short ACTION_REPLACE
Replace the context node with the result of the parse operation. For this action to work, the context node must have a parent, and the parent must be an Element or a DocumentFragment.

See Also:
Constant Field Values
Method Detail

getDomConfig

DOMConfiguration getDomConfig()
The DOMConfiguration object used when parsing an input source. This DOMConfiguration is specific to the parse operation. No parameter values from this DOMConfiguration object are passed automatically to the DOMConfiguration object on the Document that is created, or used, by the parse operation. The DOM application is responsible for passing any needed parameter values from this DOMConfiguration object to the DOMConfiguration object referenced by the Document object.
In addition to the parameters recognized in on the DOMConfiguration interface defined in [DOM Level 3 Core] , the DOMConfiguration objects for LSParser add or modify the following parameters:
"charset-overrides-xml-encoding"
true
[optional] (default) If a higher level protocol such as HTTP [IETF RFC 2616] provides an indication of the character encoding of the input stream being processed, that will override any encoding specified in the XML declaration or the Text declaration (see also section 4.3.3, "Character Encoding in Entities", in [XML 1.0]). Explicitly setting an encoding in the LSInput overrides any encoding from the protocol.
false
[required] The parser ignores any character set encoding information from higher-level protocols.
"disallow-doctype"
true
[optional] Throw a fatal "doctype-not-allowed" error if a doctype node is found while parsing the document. This is useful when dealing with things like SOAP envelopes where doctype nodes are not allowed.
false
[required] (default) Allow doctype nodes in the document.
"ignore-unknown-character-denormalizations"
true
[required] (default) If, while verifying full normalization when [XML 1.1] is supported, a processor encounters characters for which it cannot determine the normalization properties, then the processor will ignore any possible denormalizations caused by these characters. This parameter is ignored for [XML 1.0].
false
[optional] Report an fatal "unknown-character-denormalization" error if a character is encountered for which the processor cannot determine the normalization properties.
"infoset"
See the definition of DOMConfiguration for a description of this parameter. Unlike in [DOM Level 3 Core] , this parameter will default to true for LSParser.
"namespaces"
true
[required] (default) Perform the namespace processing as defined in [XML Namespaces] and [XML Namespaces 1.1] .
false
[optional] Do not perform the namespace processing.
"resource-resolver"
[required] A reference to a LSResourceResolver object, or null. If the value of this parameter is not null when an external resource (such as an external XML entity or an XML schema location) is encountered, the implementation will request that the LSResourceResolver referenced in this parameter resolves the resource.
"supported-media-types-only"
true
[optional] Check that the media type of the parsed resource is a supported media type. If an unsupported media type is encountered, a fatal error of type "unsupported-media-type" will be raised. The media types defined in [IETF RFC 3023] must always be accepted.
false
[required] (default) Accept any media type.
"validate"
See the definition of DOMConfiguration for a description of this parameter. Unlike in [DOM Level 3 Core] , the processing of the internal subset is always accomplished, even if this parameter is set to false.
"validate-if-schema"
See the definition of DOMConfiguration for a description of this parameter. Unlike in [DOM Level 3 Core] , the processing of the internal subset is always accomplished, even if this parameter is set to false.
"well-formed"
See the definition of DOMConfiguration for a description of this parameter. Unlike in [DOM Level 3 Core] , this parameter cannot be set to false.

getFilter

LSParserFilter getFilter()
When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure. The filter can choose to remove elements from the document being constructed, or to terminate the parsing early.
The filter is invoked after the operations requested by the DOMConfiguration parameters have been applied. For example, if " validate" is set to true, the validation is done before invoking the filter.

setFilter

void setFilter(LSParserFilter filter)
When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure. The filter can choose to remove elements from the document being constructed, or to terminate the parsing early.
The filter is invoked after the operations requested by the DOMConfiguration parameters have been applied. For example, if " validate" is set to true, the validation is done before invoking the filter.

getAsync

boolean getAsync()
true if the LSParser is asynchronous, false if it is synchronous.

getBusy

boolean getBusy()
true if the LSParser is currently busy loading a document, otherwise false.

parse

Document parse(LSInput input)
               throws DOMException,
                      LSException
Parse an XML document from a resource identified by a LSInput.

Parameters:
input - The LSInput from which the source of the document is to be read.
Returns:
If the LSParser is a synchronous LSParser, the newly created and populated Document is returned. If the LSParser is asynchronous, null is returned since the document object may not yet be constructed when this method returns.
Throws:
DOMException - INVALID_STATE_ERR: Raised if the LSParser's LSParser.busy attribute is true.
LSException - PARSE_ERR: Raised if the LSParser was unable to load the XML document. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.

parseURI

Document parseURI(String uri)
                  throws DOMException,
                         LSException
Parse an XML document from a location identified by a URI reference [IETF RFC 2396]. If the URI contains a fragment identifier (see section 4.1 in [IETF RFC 2396]), the behavior is not defined by this specification, future versions of this specification may define the behavior.

Parameters:
uri - The location of the XML document to be read.
Returns:
If the LSParser is a synchronous LSParser, the newly created and populated Document is returned, or null if an error occured. If the LSParser is asynchronous, null is returned since the document object may not yet be constructed when this method returns.
Throws:
DOMException - INVALID_STATE_ERR: Raised if the LSParser.busy attribute is true.
LSException - PARSE_ERR: Raised if the LSParser was unable to load the XML document. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.

parseWithContext

Node parseWithContext(LSInput input,
                      Node contextArg,
                      short action)
                      throws DOMException,
                             LSException
Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments. When parsing the input stream, the context node (or its parent, depending on where the result will be inserted) is used for resolving unbound namespace prefixes. The context node's ownerDocument node (or the node itself if the node of type DOCUMENT_NODE) is used to resolve default attributes and entity references.
As the new data is inserted into the document, at least one mutation event is fired per new immediate child or sibling of the context node.
If the context node is a Document node and the action is ACTION_REPLACE_CHILDREN, then the document that is passed as the context node will be changed such that its xmlEncoding, documentURI, xmlVersion, inputEncoding, xmlStandalone, and all other such attributes are set to what they would be set to if the input source was parsed using LSParser.parse().
This method is always synchronous, even if the LSParser is asynchronous (LSParser.async is true).
If an error occurs while parsing, the caller is notified through the ErrorHandler instance associated with the " error-handler" parameter of the DOMConfiguration.
When calling parseWithContext, the values of the following configuration parameters will be ignored and their default values will always be used instead: " validate", " validate-if-schema", and " element-content-whitespace". Other parameters will be treated normally, and the parser is expected to call the LSParserFilter just as if a whole document was parsed.

Parameters:
input - The LSInput from which the source document is to be read. The source document must be an XML fragment, i.e. anything except a complete XML document (except in the case where the context node of type DOCUMENT_NODE, and the action is ACTION_REPLACE_CHILDREN), a DOCTYPE (internal subset), entity declaration(s), notation declaration(s), or XML or text declaration(s).
contextArg - The node that is used as the context for the data that is being parsed. This node must be a Document node, a DocumentFragment node, or a node of a type that is allowed as a child of an Element node, e.g. it cannot be an Attribute node.
action - This parameter describes which action should be taken between the new set of nodes being inserted and the existing children of the context node. The set of possible actions is defined in ACTION_TYPES above.
Returns:
Return the node that is the result of the parse operation. If the result is more than one top-level node, the first one is returned.
Throws:
DOMException - HIERARCHY_REQUEST_ERR: Raised if the content cannot replace, be inserted before, after, or as a child of the context node (see also Node.insertBefore or Node.replaceChild in [DOM Level 3 Core] ).
NOT_SUPPORTED_ERR: Raised if the LSParser doesn't support this method, or if the context node is of type Document and the DOM implementation doesn't support the replacement of the DocumentType child or Element child.
NO_MODIFICATION_ALLOWED_ERR: Raised if the context node is a read only node and the content is being appended to its child list, or if the parent node of the context node is read only node and the content is being inserted in its child list.
INVALID_STATE_ERR: Raised if the LSParser.busy attribute is true.
LSException - PARSE_ERR: Raised if the LSParser was unable to load the XML fragment. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.

abort

void abort()
Abort the loading of the document that is currently being loaded by the LSParser. If the LSParser is currently not busy, a call to this method does nothing.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


LSParserFilter (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom.ls
Interface LSParserFilter

public interface LSParserFilter

LSParserFilters provide applications the ability to examine nodes as they are being constructed while parsing. As each node is examined, it may be modified or removed, or the entire parse may be terminated early.

At the time any of the filter methods are called by the parser, the owner Document and DOMImplementation objects exist and are accessible. The document element is never passed to the LSParserFilter methods, i.e. it is not possible to filter out the document element. Document, DocumentType, Notation, Entity, and Attr nodes are never passed to the acceptNode method on the filter. The child nodes of an EntityReference node are passed to the filter if the parameter " entities" is set to false. Note that, as described by the parameter " entities", unexpanded entity reference nodes are never discarded and are always passed to the filter.

All validity checking while parsing a document occurs on the source document as it appears on the input stream, not on the DOM document as it is built in memory. With filters, the document in memory may be a subset of the document on the stream, and its validity may have been affected by the filtering.

All default attributes must be present on elements when the elements are passed to the filter methods. All other default content must be passed to the filter methods.

DOM applications must not raise exceptions in a filter. The effect of throwing exceptions from a filter is DOM implementation dependent.

See also the Document Object Model (DOM) Level 3 Load and Save Specification.

Field Summary
Modifier and Type | Field and Description
static short | FILTER_ACCEPT Accept the node.
static short | FILTER_INTERRUPT Interrupt the normal processing of the document.
static short | FILTER_REJECT Reject the node and its children.
static short | FILTER_SKIP Skip this single node.
Method Summary
Modifier and Type | Method and Description
short | acceptNode(Node nodeArg) This method will be called by the parser at the completion of the parsing of each node.
int | getWhatToShow() Tells the LSParser what types of nodes to show to the method LSParserFilter.acceptNode.
short | startElement(Element elementArg) The parser will call this method after each Element start tag has been scanned, but before the remainder of the Element is processed.

Field Detail

FILTER_ACCEPT

static final short FILTER_ACCEPT
Accept the node.

See Also:
Constant Field Values

FILTER_REJECT

static final short FILTER_REJECT
Reject the node and its children.

See Also:
Constant Field Values

FILTER_SKIP

static final short FILTER_SKIP
Skip this single node. The children of this node will still be considered.

See Also:
Constant Field Values

FILTER_INTERRUPT

static final short FILTER_INTERRUPT
Interrupt the normal processing of the document.

See Also:
Constant Field Values
Method Detail

startElement

short startElement(Element elementArg)
The parser will call this method after each Element start tag has been scanned, but before the remainder of the Element is processed. The intent is to allow the element, including any children, to be efficiently skipped. Note that only element nodes are passed to the startElement function.
The element node passed to startElement for filtering will include all of the Element's attributes, but none of the children nodes. The Element may not yet be in place in the document being constructed (it may not have a parent node.)
A startElement filter function may access or change the attributes for the Element. Changing Namespace declarations will have no effect on namespace resolution by the parser.
For efficiency, the Element node passed to the filter may not be the same one as is actually placed in the tree if the node is accepted. And the actual node (node object identity) may be reused during the process of reading in and filtering a document.

Parameters:
elementArg - The newly encountered element. At the time this method is called, the element is incomplete - it will have its attributes, but no children.
Returns:
  • FILTER_ACCEPT if the Element should be included in the DOM document being built.
  • FILTER_REJECT if the Element and all of its children should be rejected.
  • FILTER_SKIP if the Element should be skipped. All of its children are inserted in place of the skipped Element node.
  • FILTER_INTERRUPT if the filter wants to stop the processing of the document. Interrupting the processing of the document does no longer guarantee that the resulting DOM tree is XML well-formed. The Element is rejected.
Returning any other values will result in unspecified behavior.

acceptNode

short acceptNode(Node nodeArg)
This method will be called by the parser at the completion of the parsing of each node. The node and all of its descendants will exist and be complete. The parent node will also exist, although it may be incomplete, i.e. it may have additional children that have not yet been parsed. Attribute nodes are never passed to this function.
From within this method, the new node may be freely modified - children may be added or removed, text nodes modified, etc. The state of the rest of the document outside this node is not defined, and the affect of any attempt to navigate to, or to modify any other part of the document is undefined.
For validating parsers, the checks are made on the original document, before any modification by the filter. No validity checks are made on any document modifications made by the filter.
If this new node is rejected, the parser might reuse the new node and any of its descendants.

Parameters:
nodeArg - The newly constructed element. At the time this method is called, the element is complete - it has all of its children (and their children, recursively) and attributes, and is attached as a child to its parent.
Returns:
  • FILTER_ACCEPT if this Node should be included in the DOM document being built.
  • FILTER_REJECT if the Node and all of its children should be rejected.
  • FILTER_SKIP if the Node should be skipped and the Node should be replaced by all the children of the Node.
  • FILTER_INTERRUPT if the filter wants to stop the processing of the document. Interrupting the processing of the document does no longer guarantee that the resulting DOM tree is XML well-formed. The Node is accepted and will be the last completely parsed node.

getWhatToShow

int getWhatToShow()
Tells the LSParser what types of nodes to show to the method LSParserFilter.acceptNode. If a node is not shown to the filter using this attribute, it is automatically included in the DOM document being built. See NodeFilter for definition of the constants. The constants SHOW_ATTRIBUTE , SHOW_DOCUMENT, SHOW_DOCUMENT_TYPE, SHOW_NOTATION, SHOW_ENTITY, and SHOW_DOCUMENT_FRAGMENT are meaningless here. Those nodes will never be passed to LSParserFilter.acceptNode.
The constants used here are defined in [DOM Level 2 Traversal and Range] .

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


LSProgressEvent (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom.ls
Interface LSProgressEvent

All Superinterfaces:
Event
public interface LSProgressEvent
extends Event

This interface represents a progress event object that notifies the application about progress as a document is parsed. It extends the Event interface defined in [DOM Level 3 Events] .

The units used for the attributes position and totalSize are not specified and can be implementation and input dependent.

See also the Document Object Model (DOM) Level 3 Load and Save Specification.

Field Summary
Modifier and Type Field and Description
Fields inherited from interface org.w3c.dom.events.Event
AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE
Method Summary
Modifier and Type | Method and Description
LSInput | getInput() The input source that is being parsed.
int | getPosition() The current position in the input source, including all external entities and other resources that have been read.
int | getTotalSize() The total size of the document including all external resources, this number might change as a document is being parsed if references to more external resources are seen.
Methods inherited from interface org.w3c.dom.events.Event
getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

Method Detail

getInput

LSInput getInput()
The input source that is being parsed.

getPosition

int getPosition()
The current position in the input source, including all external entities and other resources that have been read.

getTotalSize

int getTotalSize()
The total size of the document including all external resources, this number might change as a document is being parsed if references to more external resources are seen. A value of 0 is returned if the total size cannot be determined or estimated.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


LSResourceResolver (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom.ls
Interface LSResourceResolver

public interface LSResourceResolver

LSResourceResolver provides a way for applications to redirect references to external resources.

Applications needing to implement custom handling for external resources can implement this interface and register their implementation by setting the "resource-resolver" parameter of DOMConfiguration objects attached to LSParser and LSSerializer. It can also be register on DOMConfiguration objects attached to Document if the "LS" feature is supported.

The LSParser will then allow the application to intercept any external entities, including the external DTD subset and external parameter entities, before including them. The top-level document entity is never passed to the resolveResource method.

Many DOM applications will not need to implement this interface, but it will be especially useful for applications that build XML documents from databases or other specialized input sources, or for applications that use URNs.

Note: LSResourceResolver is based on the SAX2 [SAX] EntityResolver interface.

See also the Document Object Model (DOM) Level 3 Load and Save Specification.

Method Summary
Modifier and Type | Method and Description
LSInput | resolveResource(String type, String namespaceURI, String publicId, String systemId, String baseURI) Allow the application to resolve external resources.

Method Detail

resolveResource

LSInput resolveResource(String type,
                        String namespaceURI,
                        String publicId,
                        String systemId,
                        String baseURI)
Allow the application to resolve external resources.
The LSParser will call this method before opening any external resource, including the external DTD subset, external entities referenced within the DTD, and external entities referenced within the document element (however, the top-level document entity is not passed to this method). The application may then request that the LSParser resolve the external resource itself, that it use an alternative URI, or that it use an entirely different input source.
Application writers can use this method to redirect external system identifiers to secure and/or local URI, to look up public identifiers in a catalogue, or to read an entity from a database or other input source (including, for example, a dialog box).

Parameters:
type - The type of the resource being resolved. For XML [XML 1.0] resources (i.e. entities), applications must use the value "http://www.w3.org/TR/REC-xml". For XML Schema [XML Schema Part 1] , applications must use the value "http://www.w3.org/2001/XMLSchema". Other types of resources are outside the scope of this specification and therefore should recommend an absolute URI in order to use this method.
namespaceURI - The namespace of the resource being resolved, e.g. the target namespace of the XML Schema [XML Schema Part 1] when resolving XML Schema resources.
publicId - The public identifier of the external entity being referenced, or null if no public identifier was supplied or if the resource is not an entity.
systemId - The system identifier, a URI reference [IETF RFC 2396], of the external resource being referenced, or null if no system identifier was supplied.
baseURI - The absolute base URI of the resource being parsed, or null if there is no base URI.
Returns:
A LSInput object describing the new input source, or null to request that the parser open a regular URI connection to the resource.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


LSSerializer (Java Platform SE 7 b59)

DRAFT ea-b59

org.w3c.dom.ls
Interface LSSerializer

public interface LSSerializer

A LSSerializer provides an API for serializing (writing) a DOM document out into XML. The XML data is written to a string or an output stream. Any changes or fixups made during the serialization affect only the serialized data. The Document object and its children are never altered by the serialization operation.

During serialization of XML data, namespace fixup is done as defined in [DOM Level 3 Core] , Appendix B. [DOM Level 2 Core] allows empty strings as a real namespace URI. If the namespaceURI of a Node is empty string, the serialization will treat them as null, ignoring the prefix if any.

LSSerializer accepts any node type for serialization. For nodes of type Document or Entity, well-formed XML will be created when possible (well-formedness is guaranteed if the document or entity comes from a parse operation and is unchanged since it was created). The serialized output for these node types is either as a XML document or an External XML Entity, respectively, and is acceptable input for an XML parser. For all other types of nodes the serialized form is implementation dependent.

Within a Document, DocumentFragment, or Entity being serialized, Nodes are processed as follows

  • Document nodes are written, including the XML declaration (unless the parameter "xml-declaration" is set to false) and a DTD subset, if one exists in the DOM. Writing a Document node serializes the entire document.
  • Entity nodes, when written directly by LSSerializer.write, outputs the entity expansion but no namespace fixup is done. The resulting output will be valid as an external entity.
  • If the parameter " entities" is set to true, EntityReference nodes are serialized as an entity reference of the form " &entityName;" in the output. Child nodes (the expansion) of the entity reference are ignored. If the parameter " entities" is set to false, only the children of the entity reference are serialized. EntityReference nodes with no children (no corresponding Entity node or the corresponding Entity nodes have no children) are always serialized.
  • CDATAsections containing content characters that cannot be represented in the specified output encoding are handled according to the " split-cdata-sections" parameter. If the parameter is set to true, CDATAsections are split, and the unrepresentable characters are serialized as numeric character references in ordinary content. The exact position and number of splits is not specified. If the parameter is set to false, unrepresentable characters in a CDATAsection are reported as "wf-invalid-character" errors if the parameter " well-formed" is set to true. The error is not recoverable - there is no mechanism for supplying alternative characters and continuing with the serialization.
  • DocumentFragment nodes are serialized by serializing the children of the document fragment in the order they appear in the document fragment.
  • All other node types (Element, Text, etc.) are serialized to their corresponding XML source form.

Note: The serialization of a Node does not always generate a well-formed XML document, i.e. a LSParser might throw fatal errors when parsing the resulting serialization.

Within the character data of a document (outside of markup), any characters that cannot be represented directly are replaced with character references. Occurrences of '<' and '&' are replaced by the predefined entities &lt; and &amp;. The other predefined entities (&gt;, &apos;, and &quot;) might not be used, except where needed (e.g. using &gt; in cases such as ']]>'). Any characters that cannot be represented directly in the output character encoding are serialized as numeric character references (and since character encoding standards commonly use hexadecimal representations of characters, using the hexadecimal representation when serializing character references is encouraged).

To allow attribute values to contain both single and double quotes, the apostrophe or single-quote character (') may be represented as "&apos;", and the double-quote character (") as "&quot;". New line characters and other characters that cannot be represented directly in attribute values in the output character encoding are serialized as a numeric character reference.

Within markup, but outside of attributes, any occurrence of a character that cannot be represented in the output character encoding is reported as a DOMError fatal error. An example would be serializing the element <LaCa馻da/> with encoding="us-ascii". This will result with a generation of a DOMError "wf-invalid-character-in-node-name" (as proposed in " well-formed").

When requested by setting the parameter " normalize-characters" on LSSerializer to true, character normalization is performed according to the definition of fully normalized characters included in appendix E of [XML 1.1] on all data to be serialized, both markup and character data. The character normalization process affects only the data as it is being written; it does not alter the DOM's view of the document after serialization has completed.

Implementations are required to support the encodings "UTF-8", "UTF-16", "UTF-16BE", and "UTF-16LE" to guarantee that data is serializable in all encodings that are required to be supported by all XML parsers. When the encoding is UTF-8, whether or not a byte order mark is serialized, or if the output is big-endian or little-endian, is implementation dependent. When the encoding is UTF-16, whether or not the output is big-endian or little-endian is implementation dependent, but a Byte Order Mark must be generated for non-character outputs, such as LSOutput.byteStream or LSOutput.systemId. If the Byte Order Mark is not generated, a "byte-order-mark-needed" warning is reported. When the encoding is UTF-16LE or UTF-16BE, the output is big-endian (UTF-16BE) or little-endian (UTF-16LE) and the Byte Order Mark is not be generated. In all cases, the encoding declaration, if generated, will correspond to the encoding used during the serialization (e.g. encoding="UTF-16" will appear if UTF-16 was requested).

Namespaces are fixed up during serialization, the serialization process will verify that namespace declarations, namespace prefixes and the namespace URI associated with elements and attributes are consistent. If inconsistencies are found, the serialized form of the document will be altered to remove them. The method used for doing the namespace fixup while serializing a document is the algorithm defined in Appendix B.1, "Namespace normalization", of [DOM Level 3 Core] .

While serializing a document, the parameter "discard-default-content" controls whether or not non-specified data is serialized.

While serializing, errors and warnings are reported to the application through the error handler (LSSerializer.domConfig's " error-handler" parameter). This specification does in no way try to define all possible errors and warnings that can occur while serializing a DOM node, but some common error and warning cases are defined. The types ( DOMError.type) of errors and warnings defined by this specification are:

"no-output-specified" [fatal]
Raised when writing to a LSOutput if no output is specified in the LSOutput.
"unbound-prefix-in-entity-reference" [fatal]
Raised if the configuration parameter " namespaces" is set to true and an entity whose replacement text contains unbound namespace prefixes is referenced in a location where there are no bindings for the namespace prefixes.
"unsupported-encoding" [fatal]
Raised if an unsupported encoding is encountered.

In addition to raising the defined errors and warnings, implementations are expected to raise implementation specific errors and warnings for any other error and warning cases such as IO errors (file not found, permission denied,...) and so on.

See also the Document Object Model (DOM) Level 3 Load and Save Specification.

Method Summary
Modifier and Type | Method and Description
DOMConfiguration | getDomConfig() The DOMConfiguration object used by the LSSerializer when serializing a DOM node.
LSSerializerFilter | getFilter() When the application provides a filter, the serializer will call out to the filter before serializing each Node.
String | getNewLine() The end-of-line sequence of characters to be used in the XML being written out.
void | setFilter(LSSerializerFilter filter) When the application provides a filter, the serializer will call out to the filter before serializing each Node.
void | setNewLine(String newLine) The end-of-line sequence of characters to be used in the XML being written out.
boolean | write(Node nodeArg, LSOutput destination) Serialize the specified node as described above in the general description of the LSSerializer interface.
String | writeToString(Node nodeArg) Serialize the specified node as described above in the general description of the LSSerializer interface.
boolean | writeToURI(Node nodeArg, String uri) A convenience method that acts as if LSSerializer.write was called with a LSOutput with no encoding specified and LSOutput.systemId set to the uri argument.

Method Detail

getDomConfig

DOMConfiguration getDomConfig()
The DOMConfiguration object used by the LSSerializer when serializing a DOM node.
In addition to the parameters recognized by the DOMConfiguration interface defined in [DOM Level 3 Core] , the DOMConfiguration objects for LSSerializer adds, or modifies, the following parameters:
"canonical-form"
true
[optional] Writes the document according to the rules specified in [Canonical XML]. In addition to the behavior described in " canonical-form" [DOM Level 3 Core] , setting this parameter to true will set the parameters "format-pretty-print", "discard-default-content", and "xml-declaration ", to false. Setting one of those parameters to true will set this parameter to false. Serializing an XML 1.1 document when "canonical-form" is true will generate a fatal error.
false
[required] (default) Do not canonicalize the output.
"discard-default-content"
true
[required] (default) Use the Attr.specified attribute to decide what attributes should be discarded. Note that some implementations might use whatever information available to the implementation (i.e. XML schema, DTD, the Attr.specified attribute, and so on) to determine what attributes and content to discard if this parameter is set to true.
false
[required]Keep all attributes and all content.
"format-pretty-print"
true
[optional] Formatting the output by adding whitespace to produce a pretty-printed, indented, human-readable form. The exact form of the transformations is not specified by this specification. Pretty-printing changes the content of the document and may affect the validity of the document, validating implementations should preserve validity.
false
[required] (default) Don't pretty-print the result.
"ignore-unknown-character-denormalizations"
true
[required] (default) If, while verifying full normalization when [XML 1.1] is supported, a character is encountered for which the normalization properties cannot be determined, then raise a "unknown-character-denormalization" warning (instead of raising an error, if this parameter is not set) and ignore any possible denormalizations caused by these characters.
false
[optional] Report a fatal error if a character is encountered for which the processor cannot determine the normalization properties.
"normalize-characters"
This parameter is equivalent to the one defined by DOMConfiguration in [DOM Level 3 Core] . Unlike in the Core, the default value for this parameter is true. While DOM implementations are not required to support fully normalizing the characters in the document according to appendix E of [XML 1.1], this parameter must be activated by default if supported.
"xml-declaration"
true
[required] (default) If a Document, Element, or Entity node is serialized, the XML declaration, or text declaration, should be included. The version (Document.xmlVersion if the document is a Level 3 document and the version is non-null, otherwise use the value "1.0"), and the output encoding (see LSSerializer.write for details on how to find the output encoding) are specified in the serialized XML declaration.
false
[required] Do not serialize the XML and text declarations. Report a "xml-declaration-needed" warning if this will cause problems (i.e. the serialized data is of an XML version other than [XML 1.0], or an encoding would be needed to be able to re-parse the serialized data).

getNewLine

String getNewLine()
The end-of-line sequence of characters to be used in the XML being written out. Any string is supported, but XML treats only a certain set of characters sequence as end-of-line (See section 2.11, "End-of-Line Handling" in [XML 1.0], if the serialized content is XML 1.0 or section 2.11, "End-of-Line Handling" in [XML 1.1], if the serialized content is XML 1.1). Using other character sequences than the recommended ones can result in a document that is either not serializable or not well-formed).
On retrieval, the default value of this attribute is the implementation specific default end-of-line sequence. DOM implementations should choose the default to match the usual convention for text files in the environment being used. Implementations must choose a default sequence that matches one of those allowed by XML 1.0 or XML 1.1, depending on the serialized content. Setting this attribute to null will reset its value to the default value.

setNewLine

void setNewLine(String newLine)
The end-of-line sequence of characters to be used in the XML being written out. Any string is supported, but XML treats only a certain set of characters sequence as end-of-line (See section 2.11, "End-of-Line Handling" in [XML 1.0], if the serialized content is XML 1.0 or section 2.11, "End-of-Line Handling" in [XML 1.1], if the serialized content is XML 1.1). Using other character sequences than the recommended ones can result in a document that is either not serializable or not well-formed).
On retrieval, the default value of this attribute is the implementation specific default end-of-line sequence. DOM implementations should choose the default to match the usual convention for text files in the environment being used. Implementations must choose a default sequence that matches one of those allowed by XML 1.0 or XML 1.1, depending on the serialized content. Setting this attribute to null will reset its value to the default value.

getFilter

LSSerializerFilter getFilter()
When the application provides a filter, the serializer will call out to the filter before serializing each Node. The filter implementation can choose to remove the node from the stream or to terminate the serialization early.
The filter is invoked after the operations requested by the DOMConfiguration parameters have been applied. For example, CDATA sections won't be passed to the filter if " cdata-sections" is set to false.

setFilter

void setFilter(LSSerializerFilter filter)
When the application provides a filter, the serializer will call out to the filter before serializing each Node. The filter implementation can choose to remove the node from the stream or to terminate the serialization early.
The filter is invoked after the operations requested by the DOMConfiguration parameters have been applied. For example, CDATA sections won't be passed to the filter if " cdata-sections" is set to false.

write

boolean write(Node nodeArg,
              LSOutput destination)
              throws LSException
Serialize the specified node as described above in the general description of the LSSerializer interface. The output is written to the supplied LSOutput.
When writing to a LSOutput, the encoding is found by looking at the encoding information that is reachable through the LSOutput and the item to be written (or its owner document) in this order:
  1. LSOutput.encoding,
  2. Document.inputEncoding,
  3. Document.xmlEncoding.

If no encoding is reachable through the above properties, a default encoding of "UTF-8" will be used. If the specified encoding is not supported an "unsupported-encoding" fatal error is raised.
If no output is specified in the LSOutput, a "no-output-specified" fatal error is raised.
The implementation is responsible of associating the appropriate media type with the serialized data.
When writing to a HTTP URI, a HTTP PUT is performed. When writing to other types of URIs, the mechanism for writing the data to the URI is implementation dependent.

Parameters:
nodeArg - The node to serialize.
destination - The destination for the serialized DOM.
Returns:
Returns true if node was successfully serialized. Return false in case the normal processing stopped but the implementation kept serializing the document; the result of the serialization being implementation dependent then.
Throws:
LSException - SERIALIZE_ERR: Raised if the LSSerializer was unable to serialize the node. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.

writeToURI

boolean writeToURI(Node nodeArg,
                   String uri)
                   throws LSException
A convenience method that acts as if LSSerializer.write was called with a LSOutput with no encoding specified and LSOutput.systemId set to the uri argument.

Parameters:
nodeArg - The node to serialize.
uri - The URI to write to.
Returns:
Returns true if node was successfully serialized. Return false in case the normal processing stopped but the implementation kept serializing the document; the result of the serialization being implementation dependent then.
Throws:
LSException - SERIALIZE_ERR: Raised if the LSSerializer was unable to serialize the node. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.

writeToString

String writeToString(Node nodeArg)
                     throws DOMException,
                            LSException
Serialize the specified node as described above in the general description of the LSSerializer interface. The output is written to a DOMString that is returned to the caller. The encoding used is the encoding of the DOMString type, i.e. UTF-16. Note that no Byte Order Mark is generated in a DOMString object.

Parameters:
nodeArg - The node to serialize.
Returns:
Returns the serialized data.
Throws:
DOMException - DOMSTRING_SIZE_ERR: Raised if the resulting string is too long to fit in a DOMString.
LSException - SERIALIZE_ERR: Raised if the LSSerializer was unable to serialize the node. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


LSSerializerFilter (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.w3c.dom.ls
Interface LSSerializerFilter

All Superinterfaces:
org.w3c.dom.traversal.NodeFilter
public interface LSSerializerFilter
extends org.w3c.dom.traversal.NodeFilter

LSSerializerFilters provide applications the ability to examine nodes as they are being serialized and decide what nodes should be serialized or not. The LSSerializerFilter interface is based on the NodeFilter interface defined in [DOM Level 2 Traversal and Range] .

Document, DocumentType, DocumentFragment, Notation, Entity , and children of Attr nodes are not passed to the filter. The child nodes of an EntityReference node are only passed to the filter if the EntityReference node is skipped by the method LSParserFilter.acceptNode().

When serializing an Element, the element is passed to the filter before any of its attributes are passed to the filter. Namespace declaration attributes, and default attributes (except in the case when " discard-default-content" is set to false), are never passed to the filter.

The result of any attempt to modify a node passed to a LSSerializerFilter is implementation dependent.

DOM applications must not raise exceptions in a filter. The effect of throwing exceptions from a filter is DOM implementation dependent.

For efficiency, a node passed to the filter may not be the same as the one that is actually in the tree. And the actual node (node object identity) may be reused during the process of filtering and serializing a document.

See also the Document Object Model (DOM) Level 3 Load and Save Specification.

Field Summary
Modifier and Type Field and Description
Fields inherited from interface org.w3c.dom.traversal.NodeFilter
FILTER_ACCEPT, FILTER_REJECT, FILTER_SKIP, SHOW_ALL, SHOW_ATTRIBUTE, SHOW_CDATA_SECTION, SHOW_COMMENT, SHOW_DOCUMENT, SHOW_DOCUMENT_FRAGMENT, SHOW_DOCUMENT_TYPE, SHOW_ELEMENT, SHOW_ENTITY, SHOW_ENTITY_REFERENCE, SHOW_NOTATION, SHOW_PROCESSING_INSTRUCTION, SHOW_TEXT
Method Summary
Modifier and Type | Method and Description
int | getWhatToShow() Tells the LSSerializer what types of nodes to show to the filter.
Methods inherited from interface org.w3c.dom.traversal.NodeFilter
acceptNode

Method Detail

getWhatToShow

int getWhatToShow()
Tells the LSSerializer what types of nodes to show to the filter. If a node is not shown to the filter using this attribute, it is automatically serialized. See NodeFilter for definition of the constants. The constants SHOW_DOCUMENT , SHOW_DOCUMENT_TYPE, SHOW_DOCUMENT_FRAGMENT , SHOW_NOTATION, and SHOW_ENTITY are meaningless here, such nodes will never be passed to a LSSerializerFilter.
Unlike [DOM Level 2 Traversal and Range] , the SHOW_ATTRIBUTE constant indicates that the Attr nodes are shown and passed to the filter.
The constants used here are defined in [DOM Level 2 Traversal and Range] .

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.w3c.dom.ls (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.w3c.dom.ls

Interface Summary
Interface | Description
DOMImplementationLS | DOMImplementationLS contains the factory methods for creating Load and Save objects.
LSInput | This interface represents an input source for data.
LSLoadEvent | This interface represents a load event object that signals the completion of a document load.
LSOutput | This interface represents an output destination for data.
LSParser | An interface to an object that is able to build, or augment, a DOM tree from various input sources.
LSParserFilter | LSParserFilters provide applications the ability to examine nodes as they are being constructed while parsing.
LSProgressEvent | This interface represents a progress event object that notifies the application about progress as a document is parsed.
LSResourceResolver | LSResourceResolver provides a way for applications to redirect references to external resources.
LSSerializer | A LSSerializer provides an API for serializing (writing) a DOM document out into XML.
LSSerializerFilter | LSSerializerFilters provide applications the ability to examine nodes as they are being serialized and decide what nodes should be serialized or not.

Exception Summary
Exception | Description
LSException | Parser or write operations may throw an LSException if the processing is stopped.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


AttributeList (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.xml.sax
Interface AttributeList

All Known Implementing Classes:
AttributeListImpl
Deprecated. This interface has been replaced by the SAX2 Attributes interface, which includes Namespace support.

public interface AttributeList

Interface for an element's attribute specifications.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

This is the original SAX1 interface for reporting an element's attributes. Unlike the new Attributes interface, it does not support Namespace-related information.

When an attribute list is supplied as part of a startElement event, the list will return valid results only during the scope of the event; once the event handler returns control to the parser, the attribute list is invalid. To save a persistent copy of the attribute list, use the SAX1 AttributeListImpl helper class.

An attribute list includes only attributes that have been specified or defaulted: #IMPLIED attributes will not be included.

There are two ways for the SAX application to obtain information from the AttributeList. First, it can iterate through the entire list:

 public void startElement (String name, AttributeList atts) {
   for (int i = 0; i < atts.getLength(); i++) {
     String name = atts.getName(i);
     String type = atts.getType(i);
     String value = atts.getValue(i);
     [...]
   }
 }

(Note that the result of getLength() will be zero if there are no attributes.)

As an alternative, the application can request the value or type of specific attributes:

 public void startElement (String name, AttributeList atts) {
   String identifier = atts.getValue("id");
   String label = atts.getValue("label");
   [...]
 }

Since:
SAX 1.0
See Also:
startElement, AttributeListImpl

Method Summary
Modifier and Type | Method and Description
int | getLength() Deprecated. Return the number of attributes in this list.
String | getName(int i) Deprecated. Return the name of an attribute in this list (by position).
String | getType(int i) Deprecated. Return the type of an attribute in the list (by position).
String | getType(String name) Deprecated. Return the type of an attribute in the list (by name).
String | getValue(int i) Deprecated. Return the value of an attribute in the list (by position).
String | getValue(String name) Deprecated. Return the value of an attribute in the list (by name).

Method Detail

getLength

int getLength()
Deprecated.
Return the number of attributes in this list.

The SAX parser may provide attributes in any arbitrary order, regardless of the order in which they were declared or specified. The number of attributes may be zero.

Returns:
The number of attributes in the list.

getName

String getName(int i)
Deprecated.
Return the name of an attribute in this list (by position).

The names must be unique: the SAX parser shall not include the same attribute twice. Attributes without values (those declared #IMPLIED without a value specified in the start tag) will be omitted from the list.

If the attribute name has a namespace prefix, the prefix will still be attached.

Parameters:
i - The index of the attribute in the list (starting at 0).
Returns:
The name of the indexed attribute, or null if the index is out of range.
See Also:
getLength()

getType

String getType(int i)
Deprecated.
Return the type of an attribute in the list (by position).

The attribute type is one of the strings "CDATA", "ID", "IDREF", "IDREFS", "NMTOKEN", "NMTOKENS", "ENTITY", "ENTITIES", or "NOTATION" (always in upper case).

If the parser has not read a declaration for the attribute, or if the parser does not report attribute types, then it must return the value "CDATA" as stated in the XML 1.0 Recommentation (clause 3.3.3, "Attribute-Value Normalization").

For an enumerated attribute that is not a notation, the parser will report the type as "NMTOKEN".

Parameters:
i - The index of the attribute in the list (starting at 0).
Returns:
The attribute type as a string, or null if the index is out of range.
See Also:
getLength(), getType(java.lang.String)

getValue

String getValue(int i)
Deprecated.
Return the value of an attribute in the list (by position).

If the attribute value is a list of tokens (IDREFS, ENTITIES, or NMTOKENS), the tokens will be concatenated into a single string separated by whitespace.

Parameters:
i - The index of the attribute in the list (starting at 0).
Returns:
The attribute value as a string, or null if the index is out of range.
See Also:
getLength(), getValue(java.lang.String)

getType

String getType(String name)
Deprecated.
Return the type of an attribute in the list (by name).

The return value is the same as the return value for getType(int).

If the attribute name has a namespace prefix in the document, the application must include the prefix here.

Parameters:
name - The name of the attribute.
Returns:
The attribute type as a string, or null if no such attribute exists.
See Also:
getType(int)

getValue

String getValue(String name)
Deprecated.
Return the value of an attribute in the list (by name).

The return value is the same as the return value for getValue(int).

If the attribute name has a namespace prefix in the document, the application must include the prefix here.

Parameters:
name - the name of the attribute to return
Returns:
The attribute value as a string, or null if no such attribute exists.
See Also:
getValue(int)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Attributes (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax
Interface Attributes

All Known Subinterfaces:
Attributes2
All Known Implementing Classes:
Attributes2Impl, AttributesImpl
public interface Attributes

Interface for a list of XML attributes.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

This interface allows access to a list of attributes in three different ways:

  1. by attribute index;
  2. by Namespace-qualified name; or
  3. by qualified (prefixed) name.

The list will not contain attributes that were declared #IMPLIED but not specified in the start tag. It will also not contain attributes used as Namespace declarations (xmlns*) unless the http://xml.org/sax/features/namespace-prefixes feature is set to true (it is false by default). Because SAX2 conforms to the original "Namespaces in XML" recommendation, it normally does not give namespace declaration attributes a namespace URI.

Some SAX2 parsers may support using an optional feature flag (http://xml.org/sax/features/xmlns-uris) to request that those attributes be given URIs, conforming to a later backwards-incompatible revision of that recommendation. (The attribute's "local name" will be the prefix, or "xmlns" when defining a default element namespace.) For portability, handler code should always resolve that conflict, rather than requiring parsers that can change the setting of that feature flag.

If the namespace-prefixes feature (see above) is false, access by qualified name may not be available; if the http://xml.org/sax/features/namespaces feature is false, access by Namespace-qualified names may not be available.

This interface replaces the now-deprecated SAX1 AttributeList interface, which does not contain Namespace support. In addition to Namespace support, it adds the getIndex methods (below).

The order of attributes in the list is unspecified, and will vary from implementation to implementation.

Since:
SAX 2.0
See Also:
AttributesImpl, DeclHandler.attributeDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String)

Method Summary
Modifier and Type | Method and Description
int | getIndex(String qName) Look up the index of an attribute by XML qualified (prefixed) name.
int | getIndex(String uri, String localName) Look up the index of an attribute by Namespace name.
int | getLength() Return the number of attributes in the list.
String | getLocalName(int index) Look up an attribute's local name by index.
String | getQName(int index) Look up an attribute's XML qualified (prefixed) name by index.
String | getType(int index) Look up an attribute's type by index.
String | getType(String qName) Look up an attribute's type by XML qualified (prefixed) name.
String | getType(String uri, String localName) Look up an attribute's type by Namespace name.
String | getURI(int index) Look up an attribute's Namespace URI by index.
String | getValue(int index) Look up an attribute's value by index.
String | getValue(String qName) Look up an attribute's value by XML qualified (prefixed) name.
String | getValue(String uri, String localName) Look up an attribute's value by Namespace name.

Method Detail

getLength

int getLength()
Return the number of attributes in the list.

Once you know the number of attributes, you can iterate through the list.

Returns:
The number of attributes in the list.
See Also:
getURI(int), getLocalName(int), getQName(int), getType(int), getValue(int)

getURI

String getURI(int index)
Look up an attribute's Namespace URI by index.

Parameters:
index - The attribute index (zero-based).
Returns:
The Namespace URI, or the empty string if none is available, or null if the index is out of range.
See Also:
getLength()

getLocalName

String getLocalName(int index)
Look up an attribute's local name by index.

Parameters:
index - The attribute index (zero-based).
Returns:
The local name, or the empty string if Namespace processing is not being performed, or null if the index is out of range.
See Also:
getLength()

getQName

String getQName(int index)
Look up an attribute's XML qualified (prefixed) name by index.

Parameters:
index - The attribute index (zero-based).
Returns:
The XML qualified name, or the empty string if none is available, or null if the index is out of range.
See Also:
getLength()

getType

String getType(int index)
Look up an attribute's type by index.

The attribute type is one of the strings "CDATA", "ID", "IDREF", "IDREFS", "NMTOKEN", "NMTOKENS", "ENTITY", "ENTITIES", or "NOTATION" (always in upper case).

If the parser has not read a declaration for the attribute, or if the parser does not report attribute types, then it must return the value "CDATA" as stated in the XML 1.0 Recommendation (clause 3.3.3, "Attribute-Value Normalization").

For an enumerated attribute that is not a notation, the parser will report the type as "NMTOKEN".

Parameters:
index - The attribute index (zero-based).
Returns:
The attribute's type as a string, or null if the index is out of range.
See Also:
getLength()

getValue

String getValue(int index)
Look up an attribute's value by index.

If the attribute value is a list of tokens (IDREFS, ENTITIES, or NMTOKENS), the tokens will be concatenated into a single string with each token separated by a single space.

Parameters:
index - The attribute index (zero-based).
Returns:
The attribute's value as a string, or null if the index is out of range.
See Also:
getLength()

getIndex

int getIndex(String uri,
             String localName)
Look up the index of an attribute by Namespace name.

Parameters:
uri - The Namespace URI, or the empty string if the name has no Namespace URI.
localName - The attribute's local name.
Returns:
The index of the attribute, or -1 if it does not appear in the list.

getIndex

int getIndex(String qName)
Look up the index of an attribute by XML qualified (prefixed) name.

Parameters:
qName - The qualified (prefixed) name.
Returns:
The index of the attribute, or -1 if it does not appear in the list.

getType

String getType(String uri,
               String localName)
Look up an attribute's type by Namespace name.

See getType(int) for a description of the possible types.

Parameters:
uri - The Namespace URI, or the empty String if the name has no Namespace URI.
localName - The local name of the attribute.
Returns:
The attribute type as a string, or null if the attribute is not in the list or if Namespace processing is not being performed.

getType

String getType(String qName)
Look up an attribute's type by XML qualified (prefixed) name.

See getType(int) for a description of the possible types.

Parameters:
qName - The XML qualified name.
Returns:
The attribute type as a string, or null if the attribute is not in the list or if qualified names are not available.

getValue

String getValue(String uri,
                String localName)
Look up an attribute's value by Namespace name.

See getValue(int) for a description of the possible values.

Parameters:
uri - The Namespace URI, or the empty String if the name has no Namespace URI.
localName - The local name of the attribute.
Returns:
The attribute value as a string, or null if the attribute is not in the list.

getValue

String getValue(String qName)
Look up an attribute's value by XML qualified (prefixed) name.

See getValue(int) for a description of the possible values.

Parameters:
qName - The XML qualified name.
Returns:
The attribute value as a string, or null if the attribute is not in the list or if qualified names are not available.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ContentHandler (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax
Interface ContentHandler

All Known Subinterfaces:
TemplatesHandler, TransformerHandler, UnmarshallerHandler
All Known Implementing Classes:
DefaultHandler, DefaultHandler2, ValidatorHandler, XMLFilterImpl, XMLReaderAdapter
public interface ContentHandler

Receive notification of the logical content of a document.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

This is the main interface that most SAX applications implement: if the application needs to be informed of basic parsing events, it implements this interface and registers an instance with the SAX parser using the setContentHandler method. The parser uses the instance to report basic document-related events like the start and end of elements and character data.

The order of events in this interface is very important, and mirrors the order of information in the document itself. For example, all of an element's content (character data, processing instructions, and/or subelements) will appear, in order, between the startElement event and the corresponding endElement event.

This interface is similar to the now-deprecated SAX 1.0 DocumentHandler interface, but it adds support for Namespaces and for reporting skipped entities (in non-validating XML processors).

Implementors should note that there is also a ContentHandler class in the java.net package; that means that it's probably a bad idea to do

import java.net.*;
 import org.xml.sax.*;

In fact, "import ...*" is usually a sign of sloppy programming anyway, so the user should consider this a feature rather than a bug.

Since:
SAX 2.0
See Also:
XMLReader, DTDHandler, ErrorHandler

Method Summary
Modifier and Type | Method and Description
void | characters(char[] ch, int start, int length) Receive notification of character data.
void | endDocument() Receive notification of the end of a document.
void | endElement(String uri, String localName, String qName) Receive notification of the end of an element.
void | endPrefixMapping(String prefix) End the scope of a prefix-URI mapping.
void | ignorableWhitespace(char[] ch, int start, int length) Receive notification of ignorable whitespace in element content.
void | processingInstruction(String target, String data) Receive notification of a processing instruction.
void | setDocumentLocator(Locator locator) Receive an object for locating the origin of SAX document events.
void | skippedEntity(String name) Receive notification of a skipped entity.
void | startDocument() Receive notification of the beginning of a document.
void | startElement(String uri, String localName, String qName, Attributes atts) Receive notification of the beginning of an element.
void | startPrefixMapping(String prefix, String uri) Begin the scope of a prefix-URI Namespace mapping.

Method Detail

setDocumentLocator

void setDocumentLocator(Locator locator)
Receive an object for locating the origin of SAX document events.

SAX parsers are strongly encouraged (though not absolutely required) to supply a locator: if it does so, it must supply the locator to the application by invoking this method before invoking any of the other methods in the ContentHandler interface.

The locator allows the application to determine the end position of any document-related event, even if the parser is not reporting an error. Typically, the application will use this information for reporting its own errors (such as character content that does not match an application's business rules). The information returned by the locator is probably not sufficient for use with a search engine.

Note that the locator will return correct information only during the invocation SAX event callbacks after startDocument returns and before endDocument is called. The application should not attempt to use it at any other time.

Parameters:
locator - an object that can return the location of any SAX document event
See Also:
Locator

startDocument

void startDocument()
                   throws SAXException
Receive notification of the beginning of a document.

The SAX parser will invoke this method only once, before any other event callbacks (except for setDocumentLocator).

Throws:
SAXException - any SAX exception, possibly wrapping another exception
See Also:
endDocument()

endDocument

void endDocument()
                 throws SAXException
Receive notification of the end of a document.

There is an apparent contradiction between the documentation for this method and the documentation for ErrorHandler.fatalError(org.xml.sax.SAXParseException). Until this ambiguity is resolved in a future major release, clients should make no assumptions about whether endDocument() will or will not be invoked when the parser has reported a fatalError() or thrown an exception.

The SAX parser will invoke this method only once, and it will be the last method invoked during the parse. The parser shall not invoke this method until it has either abandoned parsing (because of an unrecoverable error) or reached the end of input.

Throws:
SAXException - any SAX exception, possibly wrapping another exception
See Also:
startDocument()

startPrefixMapping

void startPrefixMapping(String prefix,
                        String uri)
                        throws SAXException
Begin the scope of a prefix-URI Namespace mapping.

The information from this event is not necessary for normal Namespace processing: the SAX XML reader will automatically replace prefixes for element and attribute names when the http://xml.org/sax/features/namespaces feature is true (the default).

There are cases, however, when applications need to use prefixes in character data or in attribute values, where they cannot safely be expanded automatically; the start/endPrefixMapping event supplies the information to the application to expand prefixes in those contexts itself, if necessary.

Note that start/endPrefixMapping events are not guaranteed to be properly nested relative to each other: all startPrefixMapping events will occur immediately before the corresponding startElement event, and all endPrefixMapping events will occur immediately after the corresponding endElement event, but their order is not otherwise guaranteed.

There should never be start/endPrefixMapping events for the "xml" prefix, since it is predeclared and immutable.

Parameters:
prefix - the Namespace prefix being declared. An empty string is used for the default element namespace, which has no prefix.
uri - the Namespace URI the prefix is mapped to
Throws:
SAXException - the client may throw an exception during processing
See Also:
endPrefixMapping(java.lang.String), startElement(java.lang.String, java.lang.String, java.lang.String, org.xml.sax.Attributes)

endPrefixMapping

void endPrefixMapping(String prefix)
                      throws SAXException
End the scope of a prefix-URI mapping.

See startPrefixMapping for details. These events will always occur immediately after the corresponding endElement event, but the order of endPrefixMapping events is not otherwise guaranteed.

Parameters:
prefix - the prefix that was being mapped. This is the empty string when a default mapping scope ends.
Throws:
SAXException - the client may throw an exception during processing
See Also:
startPrefixMapping(java.lang.String, java.lang.String), endElement(java.lang.String, java.lang.String, java.lang.String)

startElement

void startElement(String uri,
                  String localName,
                  String qName,
                  Attributes atts)
                  throws SAXException
Receive notification of the beginning of an element.

The Parser will invoke this method at the beginning of every element in the XML document; there will be a corresponding endElement event for every startElement event (even when the element is empty). All of the element's content will be reported, in order, before the corresponding endElement event.

This event allows up to three name components for each element:

  1. the Namespace URI;
  2. the local name; and
  3. the qualified (prefixed) name.

Any or all of these may be provided, depending on the values of the http://xml.org/sax/features/namespaces and the http://xml.org/sax/features/namespace-prefixes properties:

  • the Namespace URI and local name are required when the namespaces property is true (the default), and are optional when the namespaces property is false (if one is specified, both must be);
  • the qualified name is required when the namespace-prefixes property is true, and is optional when the namespace-prefixes property is false (the default).

Note that the attribute list provided will contain only attributes with explicit values (specified or defaulted): #IMPLIED attributes will be omitted. The attribute list will contain attributes used for Namespace declarations (xmlns* attributes) only if the http://xml.org/sax/features/namespace-prefixes property is true (it is false by default, and support for a true value is optional).

Like characters(), attribute values may have characters that need more than one char value.

Parameters:
uri - the Namespace URI, or the empty string if the element has no Namespace URI or if Namespace processing is not being performed
localName - the local name (without prefix), or the empty string if Namespace processing is not being performed
qName - the qualified name (with prefix), or the empty string if qualified names are not available
atts - the attributes attached to the element. If there are no attributes, it shall be an empty Attributes object. The value of this object after startElement returns is undefined
Throws:
SAXException - any SAX exception, possibly wrapping another exception
See Also:
endElement(java.lang.String, java.lang.String, java.lang.String), Attributes, AttributesImpl

endElement

void endElement(String uri,
                String localName,
                String qName)
                throws SAXException
Receive notification of the end of an element.

The SAX parser will invoke this method at the end of every element in the XML document; there will be a corresponding startElement event for every endElement event (even when the element is empty).

For information on the names, see startElement.

Parameters:
uri - the Namespace URI, or the empty string if the element has no Namespace URI or if Namespace processing is not being performed
localName - the local name (without prefix), or the empty string if Namespace processing is not being performed
qName - the qualified XML name (with prefix), or the empty string if qualified names are not available
Throws:
SAXException - any SAX exception, possibly wrapping another exception

characters

void characters(char[] ch,
                int start,
                int length)
                throws SAXException
Receive notification of character data.

The Parser will call this method to report each chunk of character data. SAX parsers may return all contiguous character data in a single chunk, or they may split it into several chunks; however, all of the characters in any single event must come from the same external entity so that the Locator provides useful information.

The application must not attempt to read from the array outside of the specified range.

Individual characters may consist of more than one Java char value. There are two important cases where this happens, because characters can't be represented in just sixteen bits. In one case, characters are represented in a Surrogate Pair, using two special Unicode values. Such characters are in the so-called "Astral Planes", with a code point above U+FFFF. A second case involves composite characters, such as a base character combining with one or more accent characters.

Your code should not assume that algorithms using char-at-a-time idioms will be working in character units; in some cases they will split characters. This is relevant wherever XML permits arbitrary characters, such as attribute values, processing instruction data, and comments as well as in data reported from this method. It's also generally relevant whenever Java code manipulates internationalized text; the issue isn't unique to XML.

Note that some parsers will report whitespace in element content using the ignorableWhitespace method rather than this one (validating parsers must do so).

Parameters:
ch - the characters from the XML document
start - the start position in the array
length - the number of characters to read from the array
Throws:
SAXException - any SAX exception, possibly wrapping another exception
See Also:
ignorableWhitespace(char[], int, int), Locator

ignorableWhitespace

void ignorableWhitespace(char[] ch,
                         int start,
                         int length)
                         throws SAXException
Receive notification of ignorable whitespace in element content.

Validating Parsers must use this method to report each chunk of whitespace in element content (see the W3C XML 1.0 recommendation, section 2.10): non-validating parsers may also use this method if they are capable of parsing and using content models.

SAX parsers may return all contiguous whitespace in a single chunk, or they may split it into several chunks; however, all of the characters in any single event must come from the same external entity, so that the Locator provides useful information.

The application must not attempt to read from the array outside of the specified range.

Parameters:
ch - the characters from the XML document
start - the start position in the array
length - the number of characters to read from the array
Throws:
SAXException - any SAX exception, possibly wrapping another exception
See Also:
characters(char[], int, int)

processingInstruction

void processingInstruction(String target,
                           String data)
                           throws SAXException
Receive notification of a processing instruction.

The Parser will invoke this method once for each processing instruction found: note that processing instructions may occur before or after the main document element.

A SAX parser must never report an XML declaration (XML 1.0, section 2.8) or a text declaration (XML 1.0, section 4.3.1) using this method.

Like characters(), processing instruction data may have characters that need more than one char value.

Parameters:
target - the processing instruction target
data - the processing instruction data, or null if none was supplied. The data does not include any whitespace separating it from the target
Throws:
SAXException - any SAX exception, possibly wrapping another exception

skippedEntity

void skippedEntity(String name)
                   throws SAXException
Receive notification of a skipped entity. This is not called for entity references within markup constructs such as element start tags or markup declarations. (The XML recommendation requires reporting skipped external entities. SAX also reports internal entity expansion/non-expansion, except within markup constructs.)

The Parser will invoke this method each time the entity is skipped. Non-validating processors may skip entities if they have not seen the declarations (because, for example, the entity was declared in an external DTD subset). All processors may skip external entities, depending on the values of the http://xml.org/sax/features/external-general-entities and the http://xml.org/sax/features/external-parameter-entities properties.

Parameters:
name - the name of the skipped entity. If it is a parameter entity, the name will begin with '%', and if it is the external DTD subset, it will be the string "[dtd]"
Throws:
SAXException - any SAX exception, possibly wrapping another exception
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DocumentHandler (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax
Interface DocumentHandler

All Known Implementing Classes:
HandlerBase, ParserAdapter
Deprecated. This interface has been replaced by the SAX2 ContentHandler interface, which includes Namespace support.

public interface DocumentHandler

Receive notification of general document events.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

This was the main event-handling interface for SAX1; in SAX2, it has been replaced by ContentHandler, which provides Namespace support and reporting of skipped entities. This interface is included in SAX2 only to support legacy SAX1 applications.

The order of events in this interface is very important, and mirrors the order of information in the document itself. For example, all of an element's content (character data, processing instructions, and/or subelements) will appear, in order, between the startElement event and the corresponding endElement event.

Application writers who do not want to implement the entire interface can derive a class from HandlerBase, which implements the default functionality; parser writers can instantiate HandlerBase to obtain a default handler. The application can find the location of any document event using the Locator interface supplied by the Parser through the setDocumentLocator method.

Since:
SAX 1.0
See Also:
Parser.setDocumentHandler(org.xml.sax.DocumentHandler), Locator, HandlerBase

Method Summary
Modifier and Type | Method and Description
void | characters(char[] ch, int start, int length) Deprecated. Receive notification of character data.
void | endDocument() Deprecated. Receive notification of the end of a document.
void | endElement(String name) Deprecated. Receive notification of the end of an element.
void | ignorableWhitespace(char[] ch, int start, int length) Deprecated. Receive notification of ignorable whitespace in element content.
void | processingInstruction(String target, String data) Deprecated. Receive notification of a processing instruction.
void | setDocumentLocator(Locator locator) Deprecated. Receive an object for locating the origin of SAX document events.
void | startDocument() Deprecated. Receive notification of the beginning of a document.
void | startElement(String name, AttributeList atts) Deprecated. Receive notification of the beginning of an element.

Method Detail

setDocumentLocator

void setDocumentLocator(Locator locator)
Deprecated.
Receive an object for locating the origin of SAX document events.

SAX parsers are strongly encouraged (though not absolutely required) to supply a locator: if it does so, it must supply the locator to the application by invoking this method before invoking any of the other methods in the DocumentHandler interface.

The locator allows the application to determine the end position of any document-related event, even if the parser is not reporting an error. Typically, the application will use this information for reporting its own errors (such as character content that does not match an application's business rules). The information returned by the locator is probably not sufficient for use with a search engine.

Note that the locator will return correct information only during the invocation of the events in this interface. The application should not attempt to use it at any other time.

Parameters:
locator - An object that can return the location of any SAX document event.
See Also:
Locator

startDocument

void startDocument()
                   throws SAXException
Deprecated.
Receive notification of the beginning of a document.

The SAX parser will invoke this method only once, before any other methods in this interface or in DTDHandler (except for setDocumentLocator).

Throws:
SAXException - Any SAX exception, possibly wrapping another exception.

endDocument

void endDocument()
                 throws SAXException
Deprecated.
Receive notification of the end of a document.

The SAX parser will invoke this method only once, and it will be the last method invoked during the parse. The parser shall not invoke this method until it has either abandoned parsing (because of an unrecoverable error) or reached the end of input.

Throws:
SAXException - Any SAX exception, possibly wrapping another exception.

startElement

void startElement(String name,
                  AttributeList atts)
                  throws SAXException
Deprecated.
Receive notification of the beginning of an element.

The Parser will invoke this method at the beginning of every element in the XML document; there will be a corresponding endElement() event for every startElement() event (even when the element is empty). All of the element's content will be reported, in order, before the corresponding endElement() event.

If the element name has a namespace prefix, the prefix will still be attached. Note that the attribute list provided will contain only attributes with explicit values (specified or defaulted): #IMPLIED attributes will be omitted.

Parameters:
name - The element type name.
atts - The attributes attached to the element, if any.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
endElement(java.lang.String), AttributeList

endElement

void endElement(String name)
                throws SAXException
Deprecated.
Receive notification of the end of an element.

The SAX parser will invoke this method at the end of every element in the XML document; there will be a corresponding startElement() event for every endElement() event (even when the element is empty).

If the element name has a namespace prefix, the prefix will still be attached to the name.

Parameters:
name - The element type name
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.

characters

void characters(char[] ch,
                int start,
                int length)
                throws SAXException
Deprecated.
Receive notification of character data.

The Parser will call this method to report each chunk of character data. SAX parsers may return all contiguous character data in a single chunk, or they may split it into several chunks; however, all of the characters in any single event must come from the same external entity, so that the Locator provides useful information.

The application must not attempt to read from the array outside of the specified range.

Note that some parsers will report whitespace using the ignorableWhitespace() method rather than this one (validating parsers must do so).

Parameters:
ch - The characters from the XML document.
start - The start position in the array.
length - The number of characters to read from the array.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
ignorableWhitespace(char[], int, int), Locator

ignorableWhitespace

void ignorableWhitespace(char[] ch,
                         int start,
                         int length)
                         throws SAXException
Deprecated.
Receive notification of ignorable whitespace in element content.

Validating Parsers must use this method to report each chunk of ignorable whitespace (see the W3C XML 1.0 recommendation, section 2.10): non-validating parsers may also use this method if they are capable of parsing and using content models.

SAX parsers may return all contiguous whitespace in a single chunk, or they may split it into several chunks; however, all of the characters in any single event must come from the same external entity, so that the Locator provides useful information.

The application must not attempt to read from the array outside of the specified range.

Parameters:
ch - The characters from the XML document.
start - The start position in the array.
length - The number of characters to read from the array.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
characters(char[], int, int)

processingInstruction

void processingInstruction(String target,
                           String data)
                           throws SAXException
Deprecated.
Receive notification of a processing instruction.

The Parser will invoke this method once for each processing instruction found: note that processing instructions may occur before or after the main document element.

A SAX parser should never report an XML declaration (XML 1.0, section 2.8) or a text declaration (XML 1.0, section 4.3.1) using this method.

Parameters:
target - The processing instruction target.
data - The processing instruction data, or null if none was supplied.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DTDHandler (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax
Interface DTDHandler

All Known Subinterfaces:
TransformerHandler
All Known Implementing Classes:
DefaultHandler, DefaultHandler2, HandlerBase, XMLFilterImpl
public interface DTDHandler

Receive notification of basic DTD-related events.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

If a SAX application needs information about notations and unparsed entities, then the application implements this interface and registers an instance with the SAX parser using the parser's setDTDHandler method. The parser uses the instance to report notation and unparsed entity declarations to the application.

Note that this interface includes only those DTD events that the XML recommendation requires processors to report: notation and unparsed entity declarations.

The SAX parser may report these events in any order, regardless of the order in which the notations and unparsed entities were declared; however, all DTD events must be reported after the document handler's startDocument event, and before the first startElement event. (If the LexicalHandler is used, these events must also be reported before the endDTD event.)

It is up to the application to store the information for future use (perhaps in a hash table or object tree). If the application encounters attributes of type "NOTATION", "ENTITY", or "ENTITIES", it can use the information that it obtained through this interface to find the entity and/or notation corresponding with the attribute value.

Since:
SAX 1.0
See Also:
XMLReader.setDTDHandler(org.xml.sax.DTDHandler)

Method Summary
Modifier and Type | Method and Description
void | notationDecl(String name, String publicId, String systemId) Receive notification of a notation declaration event.
void | unparsedEntityDecl(String name, String publicId, String systemId, String notationName) Receive notification of an unparsed entity declaration event.

Method Detail

notationDecl

void notationDecl(String name,
                  String publicId,
                  String systemId)
                  throws SAXException
Receive notification of a notation declaration event.

It is up to the application to record the notation for later reference, if necessary; notations may appear as attribute values and in unparsed entity declarations, and are sometime used with processing instruction target names.

At least one of publicId and systemId must be non-null. If a system identifier is present, and it is a URL, the SAX parser must resolve it fully before passing it to the application through this event.

There is no guarantee that the notation declaration will be reported before any unparsed entities that use it.

Parameters:
name - The notation name.
publicId - The notation's public identifier, or null if none was given.
systemId - The notation's system identifier, or null if none was given.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String), Attributes

unparsedEntityDecl

void unparsedEntityDecl(String name,
                        String publicId,
                        String systemId,
                        String notationName)
                        throws SAXException
Receive notification of an unparsed entity declaration event.

Note that the notation name corresponds to a notation reported by the notationDecl event. It is up to the application to record the entity for later reference, if necessary; unparsed entities may appear as attribute values.

If the system identifier is a URL, the parser must resolve it fully before passing it to the application.

Parameters:
name - The unparsed entity's name.
publicId - The entity's public identifier, or null if none was given.
systemId - The entity's system identifier.
notationName - The name of the associated notation.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
notationDecl(java.lang.String, java.lang.String, java.lang.String), Attributes
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


EntityResolver (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax
Interface EntityResolver

All Known Subinterfaces:
EntityResolver2
All Known Implementing Classes:
DefaultHandler, DefaultHandler2, HandlerBase, XMLFilterImpl
public interface EntityResolver

Basic interface for resolving entities.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

If a SAX application needs to implement customized handling for external entities, it must implement this interface and register an instance with the SAX driver using the setEntityResolver method.

The XML reader will then allow the application to intercept any external entities (including the external DTD subset and external parameter entities, if any) before including them.

Many SAX applications will not need to implement this interface, but it will be especially useful for applications that build XML documents from databases or other specialised input sources, or for applications that use URI types other than URLs.

The following resolver would provide the application with a special character stream for the entity with the system identifier "http://www.myhost.com/today":

 import org.xml.sax.EntityResolver;
 import org.xml.sax.InputSource;

 public class MyResolver implements EntityResolver {
   public InputSource resolveEntity (String publicId, String systemId)
   {
     if (systemId.equals("http://www.myhost.com/today")) {
              // return a special input source
       MyReader reader = new MyReader();
       return new InputSource(reader);
     } else {
              // use the default behaviour
       return null;
     }
   }
 }

The application can also use this interface to redirect system identifiers to local URIs or to look up replacements in a catalog (possibly by using the public identifier).

Since:
SAX 1.0
See Also:
XMLReader.setEntityResolver(org.xml.sax.EntityResolver), InputSource

Method Summary
Modifier and Type | Method and Description
InputSource | resolveEntity(String publicId, String systemId) Allow the application to resolve external entities.

Method Detail

resolveEntity

InputSource resolveEntity(String publicId,
                          String systemId)
                          throws SAXException,
                                 IOException
Allow the application to resolve external entities.

The parser will call this method before opening any external entity except the top-level document entity. Such entities include the external DTD subset and external parameter entities referenced within the DTD (in either case, only if the parser reads external parameter entities), and external general entities referenced within the document element (if the parser reads external general entities). The application may request that the parser locate the entity itself, that it use an alternative URI, or that it use data provided by the application (as a character or byte input stream).

Application writers can use this method to redirect external system identifiers to secure and/or local URIs, to look up public identifiers in a catalogue, or to read an entity from a database or other input source (including, for example, a dialog box). Neither XML nor SAX specifies a preferred policy for using public or system IDs to resolve resources. However, SAX specifies how to interpret any InputSource returned by this method, and that if none is returned, then the system ID will be dereferenced as a URL.

If the system identifier is a URL, the SAX parser must resolve it fully before reporting it to the application.

Parameters:
publicId - The public identifier of the external entity being referenced, or null if none was supplied.
systemId - The system identifier of the external entity being referenced.
Returns:
An InputSource object describing the new input source, or null to request that the parser open a regular URI connection to the system identifier.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
IOException - A Java-specific IO exception, possibly the result of creating a new InputStream or Reader for the InputSource.
See Also:
InputSource
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ErrorHandler (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax
Interface ErrorHandler

All Known Implementing Classes:
DefaultHandler, DefaultHandler2, HandlerBase, XMLFilterImpl
public interface ErrorHandler

Basic interface for SAX error handlers.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

If a SAX application needs to implement customized error handling, it must implement this interface and then register an instance with the XML reader using the setErrorHandler method. The parser will then report all errors and warnings through this interface.

WARNING: If an application does not register an ErrorHandler, XML parsing errors will go unreported, except that SAXParseExceptions will be thrown for fatal errors. In order to detect validity errors, an ErrorHandler that does something with error() calls must be registered.

For XML processing errors, a SAX driver must use this interface in preference to throwing an exception: it is up to the application to decide whether to throw an exception for different types of errors and warnings. Note, however, that there is no requirement that the parser continue to report additional errors after a call to fatalError. In other words, a SAX driver class may throw an exception after reporting any fatalError. Also parsers may throw appropriate exceptions for non-XML errors. For example, XMLReader.parse() would throw an IOException for errors accessing entities or the document.

Since:
SAX 1.0
See Also:
XMLReader.setErrorHandler(org.xml.sax.ErrorHandler), SAXParseException

Method Summary
Modifier and Type | Method and Description
void | error(SAXParseException exception) Receive notification of a recoverable error.
void | fatalError(SAXParseException exception) Receive notification of a non-recoverable error.
void | warning(SAXParseException exception) Receive notification of a warning.

Method Detail

warning

void warning(SAXParseException exception)
             throws SAXException
Receive notification of a warning.

SAX parsers will use this method to report conditions that are not errors or fatal errors as defined by the XML recommendation. The default behaviour is to take no action.

The SAX parser must continue to provide normal parsing events after invoking this method: it should still be possible for the application to process the document through to the end.

Filters may use this method to report other, non-XML warnings as well.

Parameters:
exception - The warning information encapsulated in a SAX parse exception.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
SAXParseException

error

void error(SAXParseException exception)
           throws SAXException
Receive notification of a recoverable error.

This corresponds to the definition of "error" in section 1.2 of the W3C XML 1.0 Recommendation. For example, a validating parser would use this callback to report the violation of a validity constraint. The default behaviour is to take no action.

The SAX parser must continue to provide normal parsing events after invoking this method: it should still be possible for the application to process the document through to the end. If the application cannot do so, then the parser should report a fatal error even if the XML recommendation does not require it to do so.

Filters may use this method to report other, non-XML errors as well.

Parameters:
exception - The error information encapsulated in a SAX parse exception.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
SAXParseException

fatalError

void fatalError(SAXParseException exception)
                throws SAXException
Receive notification of a non-recoverable error.

There is an apparent contradiction between the documentation for this method and the documentation for ContentHandler.endDocument(). Until this ambiguity is resolved in a future major release, clients should make no assumptions about whether endDocument() will or will not be invoked when the parser has reported a fatalError() or thrown an exception.

This corresponds to the definition of "fatal error" in section 1.2 of the W3C XML 1.0 Recommendation. For example, a parser would use this callback to report the violation of a well-formedness constraint.

The application must assume that the document is unusable after the parser has invoked this method, and should continue (if at all) only for the sake of collecting additional error messages: in fact, SAX parsers are free to stop reporting any other events once this method has been invoked.

Parameters:
exception - The error information encapsulated in a SAX parse exception.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
SAXParseException
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


HandlerBase (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax
Class HandlerBase

java.lang.Object
    extended by  org.xml.sax.HandlerBase
All Implemented Interfaces:
DocumentHandler, DTDHandler, EntityResolver, ErrorHandler
Deprecated. This class works with the deprecated DocumentHandler interface. It has been replaced by the SAX2 DefaultHandler class.

public class HandlerBase
extends Object
implements EntityResolver, DTDHandler, DocumentHandler, ErrorHandler

Default base class for handlers.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

This class implements the default behaviour for four SAX1 interfaces: EntityResolver, DTDHandler, DocumentHandler, and ErrorHandler. It is now obsolete, but is included in SAX2 to support legacy SAX1 applications. SAX2 applications should use the DefaultHandler class instead.

Application writers can extend this class when they need to implement only part of an interface; parser writers can instantiate this class to provide default handlers when the application has not supplied its own.

Note that the use of this class is optional.

Since:
SAX 1.0
See Also:
EntityResolver, DTDHandler, DocumentHandler, ErrorHandler

Constructor Summary
Constructor and Description
HandlerBase()
Deprecated.
Method Summary
Modifier and Type | Method and Description
void | characters(char[] ch, int start, int length) Deprecated. Receive notification of character data inside an element.
void | endDocument() Deprecated. Receive notification of the end of the document.
void | endElement(String name) Deprecated. Receive notification of the end of an element.
void | error(SAXParseException e) Deprecated. Receive notification of a recoverable parser error.
void | fatalError(SAXParseException e) Deprecated. Report a fatal XML parsing error.
void | ignorableWhitespace(char[] ch, int start, int length) Deprecated. Receive notification of ignorable whitespace in element content.
void | notationDecl(String name, String publicId, String systemId) Deprecated. Receive notification of a notation declaration.
void | processingInstruction(String target, String data) Deprecated. Receive notification of a processing instruction.
InputSource | resolveEntity(String publicId, String systemId) Deprecated. Resolve an external entity.
void | setDocumentLocator(Locator locator) Deprecated. Receive a Locator object for document events.
void | startDocument() Deprecated. Receive notification of the beginning of the document.
void | startElement(String name, AttributeList attributes) Deprecated. Receive notification of the start of an element.
void | unparsedEntityDecl(String name, String publicId, String systemId, String notationName) Deprecated. Receive notification of an unparsed entity declaration.
void | warning(SAXParseException e) Deprecated. Receive notification of a parser warning.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HandlerBase

public HandlerBase()
Deprecated.
Method Detail

resolveEntity

public InputSource resolveEntity(String publicId,
                                 String systemId)
                          throws SAXException
Deprecated.
Resolve an external entity.

Always return null, so that the parser will use the system identifier provided in the XML document. This method implements the SAX default behaviour: application writers can override it in a subclass to do special translations such as catalog lookups or URI redirection.

Specified by:
resolveEntity in interface EntityResolver
Parameters:
publicId - The public identifer, or null if none is available.
systemId - The system identifier provided in the XML document.
Returns:
The new input source, or null to require the default behaviour.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
EntityResolver.resolveEntity(java.lang.String, java.lang.String)

notationDecl

public void notationDecl(String name,
                         String publicId,
                         String systemId)
Deprecated.
Receive notification of a notation declaration.

By default, do nothing. Application writers may override this method in a subclass if they wish to keep track of the notations declared in a document.

Specified by:
notationDecl in interface DTDHandler
Parameters:
name - The notation name.
publicId - The notation public identifier, or null if not available.
systemId - The notation system identifier.
See Also:
DTDHandler.notationDecl(java.lang.String, java.lang.String, java.lang.String)

unparsedEntityDecl

public void unparsedEntityDecl(String name,
                               String publicId,
                               String systemId,
                               String notationName)
Deprecated.
Receive notification of an unparsed entity declaration.

By default, do nothing. Application writers may override this method in a subclass to keep track of the unparsed entities declared in a document.

Specified by:
unparsedEntityDecl in interface DTDHandler
Parameters:
name - The entity name.
publicId - The entity public identifier, or null if not available.
systemId - The entity system identifier.
notationName - The name of the associated notation.
See Also:
DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

setDocumentLocator

public void setDocumentLocator(Locator locator)
Deprecated.
Receive a Locator object for document events.

By default, do nothing. Application writers may override this method in a subclass if they wish to store the locator for use with other document events.

Specified by:
setDocumentLocator in interface DocumentHandler
Parameters:
locator - A locator for all SAX document events.
See Also:
DocumentHandler.setDocumentLocator(org.xml.sax.Locator), Locator

startDocument

public void startDocument()
                   throws SAXException
Deprecated.
Receive notification of the beginning of the document.

By default, do nothing. Application writers may override this method in a subclass to take specific actions at the beginning of a document (such as allocating the root node of a tree or creating an output file).

Specified by:
startDocument in interface DocumentHandler
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
DocumentHandler.startDocument()

endDocument

public void endDocument()
                 throws SAXException
Deprecated.
Receive notification of the end of the document.

By default, do nothing. Application writers may override this method in a subclass to take specific actions at the end of a document (such as finalising a tree or closing an output file).

Specified by:
endDocument in interface DocumentHandler
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
DocumentHandler.endDocument()

startElement

public void startElement(String name,
                         AttributeList attributes)
                  throws SAXException
Deprecated.
Receive notification of the start of an element.

By default, do nothing. Application writers may override this method in a subclass to take specific actions at the start of each element (such as allocating a new tree node or writing output to a file).

Specified by:
startElement in interface DocumentHandler
Parameters:
name - The element type name.
attributes - The specified or defaulted attributes.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)

endElement

public void endElement(String name)
                throws SAXException
Deprecated.
Receive notification of the end of an element.

By default, do nothing. Application writers may override this method in a subclass to take specific actions at the end of each element (such as finalising a tree node or writing output to a file).

Specified by:
endElement in interface DocumentHandler
Parameters:
name - the element name
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
DocumentHandler.endElement(java.lang.String)

characters

public void characters(char[] ch,
                       int start,
                       int length)
                throws SAXException
Deprecated.
Receive notification of character data inside an element.

By default, do nothing. Application writers may override this method to take specific actions for each chunk of character data (such as adding the data to a node or buffer, or printing it to a file).

Specified by:
characters in interface DocumentHandler
Parameters:
ch - The characters.
start - The start position in the character array.
length - The number of characters to use from the character array.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
DocumentHandler.characters(char[], int, int)

ignorableWhitespace

public void ignorableWhitespace(char[] ch,
                                int start,
                                int length)
                         throws SAXException
Deprecated.
Receive notification of ignorable whitespace in element content.

By default, do nothing. Application writers may override this method to take specific actions for each chunk of ignorable whitespace (such as adding data to a node or buffer, or printing it to a file).

Specified by:
ignorableWhitespace in interface DocumentHandler
Parameters:
ch - The whitespace characters.
start - The start position in the character array.
length - The number of characters to use from the character array.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
DocumentHandler.ignorableWhitespace(char[], int, int)

processingInstruction

public void processingInstruction(String target,
                                  String data)
                           throws SAXException
Deprecated.
Receive notification of a processing instruction.

By default, do nothing. Application writers may override this method in a subclass to take specific actions for each processing instruction, such as setting status variables or invoking other methods.

Specified by:
processingInstruction in interface DocumentHandler
Parameters:
target - The processing instruction target.
data - The processing instruction data, or null if none is supplied.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
DocumentHandler.processingInstruction(java.lang.String, java.lang.String)

warning

public void warning(SAXParseException e)
             throws SAXException
Deprecated.
Receive notification of a parser warning.

The default implementation does nothing. Application writers may override this method in a subclass to take specific actions for each warning, such as inserting the message in a log file or printing it to the console.

Specified by:
warning in interface ErrorHandler
Parameters:
e - The warning information encoded as an exception.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
ErrorHandler.warning(org.xml.sax.SAXParseException), SAXParseException

error

public void error(SAXParseException e)
           throws SAXException
Deprecated.
Receive notification of a recoverable parser error.

The default implementation does nothing. Application writers may override this method in a subclass to take specific actions for each error, such as inserting the message in a log file or printing it to the console.

Specified by:
error in interface ErrorHandler
Parameters:
e - The warning information encoded as an exception.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
ErrorHandler.warning(org.xml.sax.SAXParseException), SAXParseException

fatalError

public void fatalError(SAXParseException e)
                throws SAXException
Deprecated.
Report a fatal XML parsing error.

The default implementation throws a SAXParseException. Application writers may override this method in a subclass if they need to take specific actions for each fatal error (such as collecting all of the errors into a single report): in any case, the application must stop all regular processing when this method is invoked, since the document is no longer reliable, and the parser may no longer report parsing events.

Specified by:
fatalError in interface ErrorHandler
Parameters:
e - The error information encoded as an exception.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
ErrorHandler.fatalError(org.xml.sax.SAXParseException), SAXParseException
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


InputSource (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax
Class InputSource

java.lang.Object
    extended by  org.xml.sax.InputSource

public class InputSource
extends Object

A single input source for an XML entity.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

This class allows a SAX application to encapsulate information about an input source in a single object, which may include a public identifier, a system identifier, a byte stream (possibly with a specified encoding), and/or a character stream.

There are two places that the application can deliver an input source to the parser: as the argument to the Parser.parse method, or as the return value of the EntityResolver.resolveEntity method.

The SAX parser will use the InputSource object to determine how to read XML input. If there is a character stream available, the parser will read that stream directly, disregarding any text encoding declaration found in that stream. If there is no character stream, but there is a byte stream, the parser will use that byte stream, using the encoding specified in the InputSource or else (if no encoding is specified) autodetecting the character encoding using an algorithm such as the one in the XML specification. If neither a character stream nor a byte stream is available, the parser will attempt to open a URI connection to the resource identified by the system identifier.

An InputSource object belongs to the application: the SAX parser shall never modify it in any way (it may modify a copy if necessary). However, standard processing of both byte and character streams is to close them on as part of end-of-parse cleanup, so applications should not attempt to re-use such streams after they have been handed to a parser.

Since:
SAX 1.0
See Also:
XMLReader.parse(org.xml.sax.InputSource), EntityResolver.resolveEntity(java.lang.String, java.lang.String), InputStream, Reader

Constructor Summary
Constructor and Description
InputSource()
Zero-argument default constructor.
InputSource(InputStream byteStream)
Create a new input source with a byte stream.
InputSource(Reader characterStream)
Create a new input source with a character stream.
InputSource(String systemId)
Create a new input source with a system identifier.
Method Summary
Modifier and Type | Method and Description
InputStream | getByteStream() Get the byte stream for this input source.
Reader | getCharacterStream() Get the character stream for this input source.
String | getEncoding() Get the character encoding for a byte stream or URI.
String | getPublicId() Get the public identifier for this input source.
String | getSystemId() Get the system identifier for this input source.
void | setByteStream(InputStream byteStream) Set the byte stream for this input source.
void | setCharacterStream(Reader characterStream) Set the character stream for this input source.
void | setEncoding(String encoding) Set the character encoding, if known.
void | setPublicId(String publicId) Set the public identifier for this input source.
void | setSystemId(String systemId) Set the system identifier for this input source.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InputSource

public InputSource()
Zero-argument default constructor.

See Also:
setPublicId(java.lang.String),
setSystemId(java.lang.String),
setByteStream(java.io.InputStream),
setCharacterStream(java.io.Reader),
setEncoding(java.lang.String)

InputSource

public InputSource(String systemId)
Create a new input source with a system identifier.

Applications may use setPublicId to include a public identifier as well, or setEncoding to specify the character encoding, if known.

If the system identifier is a URL, it must be fully resolved (it may not be a relative URL).

Parameters:
systemId - The system identifier (URI).
See Also:
setPublicId(java.lang.String),
setSystemId(java.lang.String),
setByteStream(java.io.InputStream),
setEncoding(java.lang.String),
setCharacterStream(java.io.Reader)

InputSource

public InputSource(InputStream byteStream)
Create a new input source with a byte stream.

Application writers should use setSystemId() to provide a base for resolving relative URIs, may use setPublicId to include a public identifier, and may use setEncoding to specify the object's character encoding.

Parameters:
byteStream - The raw byte stream containing the document.
See Also:
setPublicId(java.lang.String),
setSystemId(java.lang.String),
setEncoding(java.lang.String),
setByteStream(java.io.InputStream),
setCharacterStream(java.io.Reader)

InputSource

public InputSource(Reader characterStream)
Create a new input source with a character stream.

Application writers should use setSystemId() to provide a base for resolving relative URIs, and may use setPublicId to include a public identifier.

The character stream shall not include a byte order mark.

See Also:
setPublicId(java.lang.String),
setSystemId(java.lang.String),
setByteStream(java.io.InputStream),
setCharacterStream(java.io.Reader)
Method Detail

setPublicId

public void setPublicId(String publicId)
Set the public identifier for this input source.

The public identifier is always optional: if the application writer includes one, it will be provided as part of the location information.

Parameters:
publicId - The public identifier as a string.
See Also:
getPublicId(),
Locator.getPublicId(),
SAXParseException.getPublicId()

getPublicId

public String getPublicId()
Get the public identifier for this input source.

Returns:
The public identifier, or null if none was supplied.
See Also:
setPublicId(java.lang.String)

setSystemId

public void setSystemId(String systemId)
Set the system identifier for this input source.

The system identifier is optional if there is a byte stream or a character stream, but it is still useful to provide one, since the application can use it to resolve relative URIs and can include it in error messages and warnings (the parser will attempt to open a connection to the URI only if there is no byte stream or character stream specified).

If the application knows the character encoding of the object pointed to by the system identifier, it can register the encoding using the setEncoding method.

If the system identifier is a URL, it must be fully resolved (it may not be a relative URL).

Parameters:
systemId - The system identifier as a string.
See Also:
setEncoding(java.lang.String),
getSystemId(),
Locator.getSystemId(),
SAXParseException.getSystemId()

getSystemId

public String getSystemId()
Get the system identifier for this input source.

The getEncoding method will return the character encoding of the object pointed to, or null if unknown.

If the system ID is a URL, it will be fully resolved.

Returns:
The system identifier, or null if none was supplied.
See Also:
setSystemId(java.lang.String), getEncoding()

setByteStream

public void setByteStream(InputStream byteStream)
Set the byte stream for this input source.

The SAX parser will ignore this if there is also a character stream specified, but it will use a byte stream in preference to opening a URI connection itself.

If the application knows the character encoding of the byte stream, it should set it with the setEncoding method.

Parameters:
byteStream - A byte stream containing an XML document or other entity.
See Also:
setEncoding(java.lang.String),
getByteStream(),
getEncoding(),
InputStream

getByteStream

public InputStream getByteStream()
Get the byte stream for this input source.

The getEncoding method will return the character encoding for this byte stream, or null if unknown.

Returns:
The byte stream, or null if none was supplied.
See Also:
getEncoding(), setByteStream(java.io.InputStream)

setEncoding

public void setEncoding(String encoding)
Set the character encoding, if known.

The encoding must be a string acceptable for an XML encoding declaration (see section 4.3.3 of the XML 1.0 recommendation).

This method has no effect when the application provides a character stream.

Parameters:
encoding - A string describing the character encoding.
See Also:
setSystemId(java.lang.String),
setByteStream(java.io.InputStream),
getEncoding()

getEncoding

public String getEncoding()
Get the character encoding for a byte stream or URI. This value will be ignored when the application provides a character stream.

Returns:
The encoding, or null if none was supplied.
See Also:
setByteStream(java.io.InputStream),
getSystemId(),
getByteStream()

setCharacterStream

public void setCharacterStream(Reader characterStream)
Set the character stream for this input source.

If there is a character stream specified, the SAX parser will ignore any byte stream and will not attempt to open a URI connection to the system identifier.

Parameters:
characterStream - The character stream containing the XML document or other entity.
See Also:
getCharacterStream(), Reader

getCharacterStream

public Reader getCharacterStream()
Get the character stream for this input source.

Returns:
The character stream, or null if none was supplied.
See Also:
setCharacterStream(java.io.Reader)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


Locator (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax
Interface Locator

All Known Subinterfaces:
Locator2
All Known Implementing Classes:
Locator2Impl, LocatorImpl
public interface Locator

Interface for associating a SAX event with a document location.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

If a SAX parser provides location information to the SAX application, it does so by implementing this interface and then passing an instance to the application using the content handler's setDocumentLocator method. The application can use the object to obtain the location of any other SAX event in the XML source document.

Note that the results returned by the object will be valid only during the scope of each callback method: the application will receive unpredictable results if it attempts to use the locator at any other time, or after parsing completes.

SAX parsers are not required to supply a locator, but they are very strongly encouraged to do so. If the parser supplies a locator, it must do so before reporting any other document events. If no locator has been set by the time the application receives the startDocument event, the application should assume that a locator is not available.

Since:
SAX 1.0
See Also:
ContentHandler.setDocumentLocator(org.xml.sax.Locator)

Method Summary
Modifier and Type | Method and Description
int | getColumnNumber() Return the column number where the current document event ends.
int | getLineNumber() Return the line number where the current document event ends.
String | getPublicId() Return the public identifier for the current document event.
String | getSystemId() Return the system identifier for the current document event.

Method Detail

getPublicId

String getPublicId()
Return the public identifier for the current document event.

The return value is the public identifier of the document entity or of the external parsed entity in which the markup triggering the event appears.

Returns:
A string containing the public identifier, or null if none is available.
See Also:
getSystemId()

getSystemId

String getSystemId()
Return the system identifier for the current document event.

The return value is the system identifier of the document entity or of the external parsed entity in which the markup triggering the event appears.

If the system identifier is a URL, the parser must resolve it fully before passing it to the application. For example, a file name must always be provided as a file:... URL, and other kinds of relative URI are also resolved against their bases.

Returns:
A string containing the system identifier, or null if none is available.
See Also:
getPublicId()

getLineNumber

int getLineNumber()
Return the line number where the current document event ends. Lines are delimited by line ends, which are defined in the XML specification.

Warning: The return value from the method is intended only as an approximation for the sake of diagnostics; it is not intended to provide sufficient information to edit the character content of the original XML document. In some cases, these "line" numbers match what would be displayed as columns, and in others they may not match the source text due to internal entity expansion.

The return value is an approximation of the line number in the document entity or external parsed entity where the markup triggering the event appears.

If possible, the SAX driver should provide the line position of the first character after the text associated with the document event. The first line is line 1.

Returns:
The line number, or -1 if none is available.
See Also:
getColumnNumber()

getColumnNumber

int getColumnNumber()
Return the column number where the current document event ends. This is one-based number of Java char values since the last line end.

Warning: The return value from the method is intended only as an approximation for the sake of diagnostics; it is not intended to provide sufficient information to edit the character content of the original XML document. For example, when lines contain combining character sequences, wide characters, surrogate pairs, or bi-directional text, the value may not correspond to the column in a text editor's display.

The return value is an approximation of the column number in the document entity or external parsed entity where the markup triggering the event appears.

If possible, the SAX driver should provide the line position of the first character after the text associated with the document event. The first column in each line is column 1.

Returns:
The column number, or -1 if none is available.
See Also:
getLineNumber()
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


org.xml.sax (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.xml.sax

This package provides the core SAX APIs.

See:
Description

Interface Summary
Interface | Description
AttributeList | Deprecated. This interface has been replaced by the SAX2 Attributes interface, which includes Namespace support.
Attributes | Interface for a list of XML attributes.
ContentHandler | Receive notification of the logical content of a document.
DocumentHandler | Deprecated. This interface has been replaced by the SAX2 ContentHandler interface, which includes Namespace support.
DTDHandler | Receive notification of basic DTD-related events.
EntityResolver | Basic interface for resolving entities.
ErrorHandler | Basic interface for SAX error handlers.
Locator | Interface for associating a SAX event with a document location.
Parser | Deprecated. This interface has been replaced by the SAX2 XMLReader interface, which includes Namespace support.
XMLFilter | Interface for an XML filter.
XMLReader | Interface for reading an XML document using callbacks.

Class Summary
Class | Description
HandlerBase | Deprecated. This class works with the deprecated DocumentHandler interface.
InputSource | A single input source for an XML entity.

Exception Summary
Exception | Description
SAXException | Encapsulate a general SAX error or warning.
SAXNotRecognizedException | Exception class for an unrecognized identifier.
SAXNotSupportedException | Exception class for an unsupported operation.
SAXParseException | Encapsulate an XML parse error or warning.

Package org.xml.sax Description

This package provides the core SAX APIs. Some SAX1 APIs are deprecated to encourage integration of namespace-awareness into designs of new applications and into maintenance of existing infrastructure.

See http://www.saxproject.org for more information about SAX.

SAX2 Standard Feature Flags

One of the essential characteristics of SAX2 is that it added feature flags which can be used to examine and perhaps modify parser modes, in particular modes such as validation. Since features are identified by (absolute) URIs, anyone can define such features. Currently defined standard feature URIs have the prefix http://xml.org/sax/features/ before an identifier such as validation. Turn features on or off using setFeature. Those standard identifiers are:

Feature ID | Access | Default | Description
external-general-entities | read/write | unspecified | Reports whether this parser processes external general entities; always true if validating.
external-parameter-entities | read/write | unspecified | Reports whether this parser processes external parameter entities; always true if validating.
is-standalone | (parsing) read-only, (not parsing) none | not applicable | May be examined only during a parse, after the startDocument() callback has been completed; read-only. The value is true if the document specified standalone="yes" in its XML declaration, and otherwise is false.
lexical-handler/parameter-entities | read/write | unspecified | A value of "true" indicates that the LexicalHandler will report the beginning and end of parameter entities.
namespaces | read/write | true | A value of "true" indicates namespace URIs and unprefixed local names for element and attribute names will be available.
namespace-prefixes | read/write | false | A value of "true" indicates that XML qualified names (with prefixes) and attributes (including xmlns* attributes) will be available.
resolve-dtd-uris read/write true A value of "true" indicates that system IDs in declarations will be absolutized (relative to their base URIs) before reporting. (That is the default behavior for all SAX2 XML parsers.) A value of "false" indicates those IDs will not be absolutized; parsers will provide the base URI from Locator.getSystemId(). This applies to system IDs passed in
  • DTDHandler.notationDecl(),
  • DTDHandler.unparsedEntityDecl(), and
  • DeclHandler.externalEntityDecl().
It does not apply to EntityResolver.resolveEntity(), which is not used to report declarations, or to LexicalHandler.startDTD(), which already provides the non-absolutized URI.
string-interning | read/write | unspecified | Has a value of "true" if all XML names (for elements, prefixes, attributes, entities, notations, and local names), as well as Namespace URIs, will have been interned using java.lang.String.intern. This supports fast testing of equality/inequality against string constants, rather than forcing slower calls to String.equals().
unicode-normalization-checking | read/write | false | Controls whether the parser reports Unicode normalization errors as described in section 2.13 and Appendix B of the XML 1.1 Recommendation. If true, Unicode normalization errors are reported using the ErrorHandler.error() callback. Such errors are not fatal in themselves (though, obviously, other Unicode-related encoding errors may be).
use-attributes2 | read-only | not applicable | Returns "true" if the Attributes objects passed by this parser in ContentHandler.startElement() implement the org.xml.sax.ext.Attributes2 interface. That interface exposes additional DTD-related information, such as whether the attribute was specified in the source text rather than defaulted.
use-locator2 | read-only | not applicable | Returns "true" if the Locator objects passed by this parser in ContentHandler.setDocumentLocator() implement the org.xml.sax.ext.Locator2 interface. That interface exposes additional entity information, such as the character encoding and XML version used.
use-entity-resolver2 | read/write | true | Returns "true" if, when setEntityResolver is given an object implementing the org.xml.sax.ext.EntityResolver2 interface, those new methods will be used. Returns "false" to indicate that those methods will not be used.
validation | read/write | unspecified | Controls whether the parser is reporting all validity errors; if true, all external entities will be read.
xmlns-uris | read/write | false | Controls whether, when the namespace-prefixes feature is set, the parser treats namespace declaration attributes as being in the http://www.w3.org/2000/xmlns/ namespace. By default, SAX2 conforms to the original "Namespaces in XML" Recommendation, which explicitly states that such attributes are not in any namespace. Setting this optional flag to "true" makes the SAX2 events conform to a later backwards-incompatible revision of that recommendation, placing those attributes in a namespace.
xml-1.1 | read-only | not applicable | Returns "true" if the parser supports both XML 1.1 and XML 1.0. Returns "false" if the parser supports only XML 1.0.

Support for the default values of the namespaces and namespace-prefixes properties is required. Support for any other feature flags is entirely optional.

For default values not specified by SAX2, each XMLReader implementation specifies its default, or may choose not to expose the feature flag. Unless otherwise specified here, implementations may support changing current values of these standard feature flags, but not while parsing.

SAX2 Standard Handler and Property IDs

For parser interface characteristics that are described as objects, a separate namespace is defined. The objects in this namespace are again identified by URI, and the standard property URIs have the prefix http://xml.org/sax/properties/ before an identifier such as lexical-handler or dom-node. Manage those properties using setProperty(). Those identifiers are:

Property ID | Description
declaration-handler | Used to see most DTD declarations except those treated as lexical ("document element name is ...") or which are mandatory for all SAX parsers (DTDHandler). The Object must implement org.xml.sax.ext.DeclHandler.
document-xml-version | May be examined only during a parse, after the startDocument() callback has been completed; read-only. This property is a literal string describing the actual XML version of the document, such as "1.0" or "1.1".
dom-node | For "DOM Walker" style parsers, which ignore their parser.parse() parameters, this is used to specify the DOM (sub)tree being walked by the parser. The Object must implement the org.w3c.dom.Node interface.
lexical-handler | Used to see some syntax events that are essential in some applications: comments, CDATA delimiters, selected general entity inclusions, and the start and end of the DTD (and declaration of document element name). The Object must implement org.xml.sax.ext.LexicalHandler.
xml-string | Readable only during a parser callback, this exposes a TBS chunk of characters responsible for the current event.

All of these standard properties are optional; XMLReader implementations need not support them.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


Parser (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax
Interface Parser

All Known Implementing Classes:
XMLReaderAdapter
Deprecated. This interface has been replaced by the SAX2 XMLReader interface, which includes Namespace support.

public interface Parser

Basic interface for SAX (Simple API for XML) parsers.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

This was the main event supplier interface for SAX1; it has been replaced in SAX2 by XMLReader, which includes Namespace support and sophisticated configurability and extensibility.

All SAX1 parsers must implement this basic interface: it allows applications to register handlers for different types of events and to initiate a parse from a URI, or a character stream.

All SAX1 parsers must also implement a zero-argument constructor (though other constructors are also allowed).

SAX1 parsers are reusable but not re-entrant: the application may reuse a parser object (possibly with a different input source) once the first parse has completed successfully, but it may not invoke the parse() methods recursively within a parse.

Since:
SAX 1.0
See Also:
EntityResolver, DTDHandler, DocumentHandler, ErrorHandler, HandlerBase, InputSource

Method Summary
Modifier and Type | Method and Description
void | parse(InputSource source) Deprecated. Parse an XML document.
void | parse(String systemId) Deprecated. Parse an XML document from a system identifier (URI).
void | setDocumentHandler(DocumentHandler handler) Deprecated. Allow an application to register a document event handler.
void | setDTDHandler(DTDHandler handler) Deprecated. Allow an application to register a DTD event handler.
void | setEntityResolver(EntityResolver resolver) Deprecated. Allow an application to register a custom entity resolver.
void | setErrorHandler(ErrorHandler handler) Deprecated. Allow an application to register an error event handler.
void | setLocale(Locale locale) Deprecated. Allow an application to request a locale for errors and warnings.

Method Detail

setLocale

void setLocale(Locale locale)
               throws SAXException
Deprecated.
Allow an application to request a locale for errors and warnings.

SAX parsers are not required to provide localisation for errors and warnings; if they cannot support the requested locale, however, they must throw a SAX exception. Applications may not request a locale change in the middle of a parse.

Parameters:
locale - A Java Locale object.
Throws:
SAXException - Throws an exception (using the previous or default locale) if the requested locale is not supported.
See Also:
SAXException, SAXParseException

setEntityResolver

void setEntityResolver(EntityResolver resolver)
Deprecated.
Allow an application to register a custom entity resolver.

If the application does not register an entity resolver, the SAX parser will resolve system identifiers and open connections to entities itself (this is the default behaviour implemented in HandlerBase).

Applications may register a new or different entity resolver in the middle of a parse, and the SAX parser must begin using the new resolver immediately.

Parameters:
resolver - The object for resolving entities.
See Also:
EntityResolver, HandlerBase

setDTDHandler

void setDTDHandler(DTDHandler handler)
Deprecated.
Allow an application to register a DTD event handler.

If the application does not register a DTD handler, all DTD events reported by the SAX parser will be silently ignored (this is the default behaviour implemented by HandlerBase).

Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

Parameters:
handler - The DTD handler.
See Also:
DTDHandler, HandlerBase

setDocumentHandler

void setDocumentHandler(DocumentHandler handler)
Deprecated.
Allow an application to register a document event handler.

If the application does not register a document handler, all document events reported by the SAX parser will be silently ignored (this is the default behaviour implemented by HandlerBase).

Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

Parameters:
handler - The document handler.
See Also:
DocumentHandler, HandlerBase

setErrorHandler

void setErrorHandler(ErrorHandler handler)
Deprecated.
Allow an application to register an error event handler.

If the application does not register an error event handler, all error events reported by the SAX parser will be silently ignored, except for fatalError, which will throw a SAXException (this is the default behaviour implemented by HandlerBase).

Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

Parameters:
handler - The error handler.
See Also:
ErrorHandler, SAXException, HandlerBase

parse

void parse(InputSource source)
           throws SAXException,
                  IOException
Deprecated.
Parse an XML document.

The application can use this method to instruct the SAX parser to begin parsing an XML document from any valid input source (a character stream, a byte stream, or a URI).

Applications may not invoke this method while a parse is in progress (they should create a new Parser instead for each additional XML document). Once a parse is complete, an application may reuse the same Parser object, possibly with a different input source.

Parameters:
source - The input source for the top-level of the XML document.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
See Also:
InputSource,
parse(java.lang.String),
setEntityResolver(org.xml.sax.EntityResolver),
setDTDHandler(org.xml.sax.DTDHandler),
setDocumentHandler(org.xml.sax.DocumentHandler),
setErrorHandler(org.xml.sax.ErrorHandler)

parse

void parse(String systemId)
           throws SAXException,
                  IOException
Deprecated.
Parse an XML document from a system identifier (URI).

This method is a shortcut for the common case of reading a document from a system identifier. It is the exact equivalent of the following:

 parse(new InputSource(systemId));

If the system identifier is a URL, it must be fully resolved by the application before it is passed to the parser.

Parameters:
systemId - The system identifier (URI).
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
See Also:
parse(org.xml.sax.InputSource)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


SAXException (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax
Class SAXException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.xml.sax.SAXException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
SAXNotRecognizedException, SAXNotSupportedException, SAXParseException
public class SAXException
extends Exception

Encapsulate a general SAX error or warning.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

This class can contain basic error or warning information from either the XML parser or the application: a parser writer or application writer can subclass it to provide additional functionality. SAX handlers may throw this exception or any exception subclassed from it.

If the application needs to pass through other types of exceptions, it must wrap those exceptions in a SAXException or an exception derived from a SAXException.

If the parser or application needs to include information about a specific location in an XML document, it should use the SAXParseException subclass.

Since:
SAX 1.0
See Also:
SAXParseException, Serialized Form

Constructor Summary
Constructor and Description
SAXException()
Create a new SAXException.
SAXException(Exception e)
Create a new SAXException wrapping an existing exception.
SAXException(String message)
Create a new SAXException.
SAXException(String message, Exception e)
Create a new SAXException from an existing exception.
Method Summary
Modifier and Type | Method and Description
Exception | getException() Return the embedded exception, if any.
String | getMessage() Return a detail message for this exception.
String | toString() Override toString to pick up any embedded exception.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SAXException

public SAXException()
Create a new SAXException.

SAXException

public SAXException(String message)
Create a new SAXException.

Parameters:
message - The error or warning message.

SAXException

public SAXException(Exception e)
Create a new SAXException wrapping an existing exception.

The existing exception will be embedded in the new one, and its message will become the default message for the SAXException.

Parameters:
e - The exception to be wrapped in a SAXException.

SAXException

public SAXException(String message,
                    Exception e)
Create a new SAXException from an existing exception.

The existing exception will be embedded in the new one, but the new exception will have its own message.

Parameters:
message - The detail message.
e - The exception to be wrapped in a SAXException.
Method Detail

getMessage

public String getMessage()
Return a detail message for this exception.

If there is an embedded exception, and if the SAXException has no detail message of its own, this method will return the detail message from the embedded exception.

Overrides:
getMessage in class Throwable
Returns:
The error or warning message.

getException

public Exception getException()
Return the embedded exception, if any.

Returns:
The embedded exception, or null if there is none.

toString

public String toString()
Override toString to pick up any embedded exception.

Overrides:
toString in class Throwable
Returns:
A string representation of this exception.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


SAXNotRecognizedException (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax
Class SAXNotRecognizedException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.xml.sax.SAXException
                extended by  org.xml.sax.SAXNotRecognizedException
All Implemented Interfaces:
Serializable
public class SAXNotRecognizedException
extends SAXException

Exception class for an unrecognized identifier.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

An XMLReader will throw this exception when it finds an unrecognized feature or property identifier; SAX applications and extensions may use this class for other, similar purposes.

Since:
SAX 2.0
See Also:
SAXNotSupportedException, Serialized Form

Constructor Summary
Constructor and Description
SAXNotRecognizedException()
Default constructor.
SAXNotRecognizedException(String message)
Construct a new exception with the given message.
Method Summary
Modifier and Type Method and Description
Methods inherited from class org.xml.sax.SAXException
getException, getMessage, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SAXNotRecognizedException

public SAXNotRecognizedException()
Default constructor.

SAXNotRecognizedException

public SAXNotRecognizedException(String message)
Construct a new exception with the given message.

Parameters:
message - The text message of the exception.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


SAXNotSupportedException (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax
Class SAXNotSupportedException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.xml.sax.SAXException
                extended by  org.xml.sax.SAXNotSupportedException
All Implemented Interfaces:
Serializable
public class SAXNotSupportedException
extends SAXException

Exception class for an unsupported operation.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

An XMLReader will throw this exception when it recognizes a feature or property identifier, but cannot perform the requested operation (setting a state or value). Other SAX2 applications and extensions may use this class for similar purposes.

Since:
SAX 2.0
See Also:
SAXNotRecognizedException, Serialized Form

Constructor Summary
Constructor and Description
SAXNotSupportedException()
Construct a new exception with no message.
SAXNotSupportedException(String message)
Construct a new exception with the given message.
Method Summary
Modifier and Type Method and Description
Methods inherited from class org.xml.sax.SAXException
getException, getMessage, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SAXNotSupportedException

public SAXNotSupportedException()
Construct a new exception with no message.

SAXNotSupportedException

public SAXNotSupportedException(String message)
Construct a new exception with the given message.

Parameters:
message - The text message of the exception.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


SAXParseException (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax
Class SAXParseException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  org.xml.sax.SAXException
                extended by  org.xml.sax.SAXParseException
All Implemented Interfaces:
Serializable
public class SAXParseException
extends SAXException

Encapsulate an XML parse error or warning.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

This exception may include information for locating the error in the original XML document, as if it came from a Locator object. Note that although the application will receive a SAXParseException as the argument to the handlers in the ErrorHandler interface, the application is not actually required to throw the exception; instead, it can simply read the information in it and take a different action.

Since this exception is a subclass of SAXException, it inherits the ability to wrap another exception.

Since:
SAX 1.0
See Also:
SAXException, Locator, ErrorHandler, Serialized Form

Constructor Summary
Constructor and Description
SAXParseException(String message, Locator locator)
Create a new SAXParseException from a message and a Locator.
SAXParseException(String message, Locator locator, Exception e)
Wrap an existing exception in a SAXParseException.
SAXParseException(String message, String publicId, String systemId, int lineNumber, int columnNumber)
Create a new SAXParseException.
SAXParseException(String message, String publicId, String systemId, int lineNumber, int columnNumber, Exception e)
Create a new SAXParseException with an embedded exception.
Method Summary
Modifier and Type | Method and Description
int | getColumnNumber() The column number of the end of the text where the exception occurred.
int | getLineNumber() The line number of the end of the text where the exception occurred.
String | getPublicId() Get the public identifier of the entity where the exception occurred.
String | getSystemId() Get the system identifier of the entity where the exception occurred.
Methods inherited from class org.xml.sax.SAXException
getException, getMessage, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SAXParseException

public SAXParseException(String message,
                         Locator locator)
Create a new SAXParseException from a message and a Locator.

This constructor is especially useful when an application is creating its own exception from within a ContentHandler callback.

Parameters:
message - The error or warning message.
locator - The locator object for the error or warning (may be null).
See Also:
Locator

SAXParseException

public SAXParseException(String message,
                         Locator locator,
                         Exception e)
Wrap an existing exception in a SAXParseException.

This constructor is especially useful when an application is creating its own exception from within a ContentHandler callback, and needs to wrap an existing exception that is not a subclass of SAXException.

Parameters:
message - The error or warning message, or null to use the message from the embedded exception.
locator - The locator object for the error or warning (may be null).
e - Any exception.
See Also:
Locator

SAXParseException

public SAXParseException(String message,
                         String publicId,
                         String systemId,
                         int lineNumber,
                         int columnNumber)
Create a new SAXParseException.

This constructor is most useful for parser writers.

All parameters except the message are as if they were provided by a Locator. For example, if the system identifier is a URL (including relative filename), the caller must resolve it fully before creating the exception.

Parameters:
message - The error or warning message.
publicId - The public identifier of the entity that generated the error or warning.
systemId - The system identifier of the entity that generated the error or warning.
lineNumber - The line number of the end of the text that caused the error or warning.
columnNumber - The column number of the end of the text that cause the error or warning.

SAXParseException

public SAXParseException(String message,
                         String publicId,
                         String systemId,
                         int lineNumber,
                         int columnNumber,
                         Exception e)
Create a new SAXParseException with an embedded exception.

This constructor is most useful for parser writers who need to wrap an exception that is not a subclass of SAXException.

All parameters except the message and exception are as if they were provided by a Locator. For example, if the system identifier is a URL (including relative filename), the caller must resolve it fully before creating the exception.

Parameters:
message - The error or warning message, or null to use the message from the embedded exception.
publicId - The public identifier of the entity that generated the error or warning.
systemId - The system identifier of the entity that generated the error or warning.
lineNumber - The line number of the end of the text that caused the error or warning.
columnNumber - The column number of the end of the text that cause the error or warning.
e - Another exception to embed in this one.
Method Detail

getPublicId

public String getPublicId()
Get the public identifier of the entity where the exception occurred.

Returns:
A string containing the public identifier, or null if none is available.
See Also:
Locator.getPublicId()

getSystemId

public String getSystemId()
Get the system identifier of the entity where the exception occurred.

If the system identifier is a URL, it will have been resolved fully.

Returns:
A string containing the system identifier, or null if none is available.
See Also:
Locator.getSystemId()

getLineNumber

public int getLineNumber()
The line number of the end of the text where the exception occurred.

The first line is line 1.

Returns:
An integer representing the line number, or -1 if none is available.
See Also:
Locator.getLineNumber()

getColumnNumber

public int getColumnNumber()
The column number of the end of the text where the exception occurred.

The first column in a line is position 1.

Returns:
An integer representing the column number, or -1 if none is available.
See Also:
Locator.getColumnNumber()
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


XMLFilter (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax
Interface XMLFilter

All Superinterfaces:
XMLReader
All Known Implementing Classes:
XMLFilterImpl
public interface XMLFilter
extends XMLReader

Interface for an XML filter.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

An XML filter is like an XML reader, except that it obtains its events from another XML reader rather than a primary source like an XML document or database. Filters can modify a stream of events as they pass on to the final application.

The XMLFilterImpl helper class provides a convenient base for creating SAX2 filters, by passing on all EntityResolver, DTDHandler, ContentHandler and ErrorHandler events automatically.

Since:
SAX 2.0
See Also:
XMLFilterImpl

Method Summary
Modifier and Type | Method and Description
XMLReader | getParent() Get the parent reader.
void | setParent(XMLReader parent) Set the parent reader.
Methods inherited from interface org.xml.sax.XMLReader
getContentHandler, getDTDHandler, getEntityResolver, getErrorHandler, getFeature, getProperty, parse, parse, setContentHandler, setDTDHandler, setEntityResolver, setErrorHandler, setFeature, setProperty

Method Detail

setParent

void setParent(XMLReader parent)
Set the parent reader.

This method allows the application to link the filter to a parent reader (which may be another filter). The argument may not be null.

Parameters:
parent - The parent reader.

getParent

XMLReader getParent()
Get the parent reader.

This method allows the application to query the parent reader (which may be another filter). It is generally a bad idea to perform any operations on the parent reader directly: they should all pass through this filter.

Returns:
The parent filter, or null if none has been set.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


XMLReader (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.xml.sax
Interface XMLReader

All Known Subinterfaces:
XMLFilter
All Known Implementing Classes:
ParserAdapter, XMLFilterImpl
public interface XMLReader

Interface for reading an XML document using callbacks.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

Note: despite its name, this interface does not extend the standard Java Reader interface, because reading XML is a fundamentally different activity than reading character data.

XMLReader is the interface that an XML parser's SAX2 driver must implement. This interface allows an application to set and query features and properties in the parser, to register event handlers for document processing, and to initiate a document parse.

All SAX interfaces are assumed to be synchronous: the parse methods must not return until parsing is complete, and readers must wait for an event-handler callback to return before reporting the next event.

This interface replaces the (now deprecated) SAX 1.0 Parser interface. The XMLReader interface contains two important enhancements over the old Parser interface (as well as some minor ones):

  1. it adds a standard way to query and set features and properties; and
  2. it adds Namespace support, which is required for many higher-level XML standards.

There are adapters available to convert a SAX1 Parser to a SAX2 XMLReader and vice-versa.

Since:
SAX 2.0
See Also:
XMLFilter, ParserAdapter, XMLReaderAdapter

Method Summary
Modifier and Type | Method and Description
ContentHandler | getContentHandler() Return the current content handler.
DTDHandler | getDTDHandler() Return the current DTD handler.
EntityResolver | getEntityResolver() Return the current entity resolver.
ErrorHandler | getErrorHandler() Return the current error handler.
boolean | getFeature(String name) Look up the value of a feature flag.
Object | getProperty(String name) Look up the value of a property.
void | parse(InputSource input) Parse an XML document.
void | parse(String systemId) Parse an XML document from a system identifier (URI).
void | setContentHandler(ContentHandler handler) Allow an application to register a content event handler.
void | setDTDHandler(DTDHandler handler) Allow an application to register a DTD event handler.
void | setEntityResolver(EntityResolver resolver) Allow an application to register an entity resolver.
void | setErrorHandler(ErrorHandler handler) Allow an application to register an error event handler.
void | setFeature(String name, boolean value) Set the value of a feature flag.
void | setProperty(String name, Object value) Set the value of a property.

Method Detail

getFeature

boolean getFeature(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
Look up the value of a feature flag.

The feature name is any fully-qualified URI. It is possible for an XMLReader to recognize a feature name but temporarily be unable to return its value. Some feature values may be available only in specific contexts, such as before, during, or after a parse. Also, some feature values may not be programmatically accessible. (In the case of an adapter for SAX1 Parser, there is no implementation-independent way to expose whether the underlying parser is performing validation, expanding external entities, and so forth.)

All XMLReaders are required to recognize the http://xml.org/sax/features/namespaces and the http://xml.org/sax/features/namespace-prefixes feature names.

Typical usage is something like this:

 XMLReader r = new MySAXDriver();

                         // try to activate validation
 try {
   r.setFeature("http://xml.org/sax/features/validation", true);
 } catch (SAXException e) {
   System.err.println("Cannot activate validation.");
 }

                         // register event handlers
 r.setContentHandler(new MyContentHandler());
 r.setErrorHandler(new MyErrorHandler());

                         // parse the first document
 try {
   r.parse("http://www.foo.com/mydoc.xml");
 } catch (IOException e) {
   System.err.println("I/O exception reading XML document");
 } catch (SAXException e) {
   System.err.println("XML exception reading document.");
 }

Implementors are free (and encouraged) to invent their own features, using names built on their own URIs.

Parameters:
name - The feature name, which is a fully-qualified URI.
Returns:
The current value of the feature (true or false).
Throws:
SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
SAXNotSupportedException - When the XMLReader recognizes the feature name but cannot determine its value at this time.
See Also:
setFeature(java.lang.String, boolean)

setFeature

void setFeature(String name,
                boolean value)
                throws SAXNotRecognizedException,
                       SAXNotSupportedException
Set the value of a feature flag.

The feature name is any fully-qualified URI. It is possible for an XMLReader to expose a feature value but to be unable to change the current value. Some feature values may be immutable or mutable only in specific contexts, such as before, during, or after a parse.

All XMLReaders are required to support setting http://xml.org/sax/features/namespaces to true and http://xml.org/sax/features/namespace-prefixes to false.

Parameters:
name - The feature name, which is a fully-qualified URI.
value - The requested value of the feature (true or false).
Throws:
SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
SAXNotSupportedException - When the XMLReader recognizes the feature name but cannot set the requested value.
See Also:
getFeature(java.lang.String)

getProperty

Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
Look up the value of a property.

The property name is any fully-qualified URI. It is possible for an XMLReader to recognize a property name but temporarily be unable to return its value. Some property values may be available only in specific contexts, such as before, during, or after a parse.

XMLReaders are not required to recognize any specific property names, though an initial core set is documented for SAX2.

Implementors are free (and encouraged) to invent their own properties, using names built on their own URIs.

Parameters:
name - The property name, which is a fully-qualified URI.
Returns:
The current value of the property.
Throws:
SAXNotRecognizedException - If the property value can't be assigned or retrieved.
SAXNotSupportedException - When the XMLReader recognizes the property name but cannot determine its value at this time.
See Also:
setProperty(java.lang.String, java.lang.Object)

setProperty

void setProperty(String name,
                 Object value)
                 throws SAXNotRecognizedException,
                        SAXNotSupportedException
Set the value of a property.

The property name is any fully-qualified URI. It is possible for an XMLReader to recognize a property name but to be unable to change the current value. Some property values may be immutable or mutable only in specific contexts, such as before, during, or after a parse.

XMLReaders are not required to recognize setting any specific property names, though a core set is defined by SAX2.

This method is also the standard mechanism for setting extended handlers.

Parameters:
name - The property name, which is a fully-qualified URI.
value - The requested value for the property.
Throws:
SAXNotRecognizedException - If the property value can't be assigned or retrieved.
SAXNotSupportedException - When the XMLReader recognizes the property name but cannot set the requested value.

setEntityResolver

void setEntityResolver(EntityResolver resolver)
Allow an application to register an entity resolver.

If the application does not register an entity resolver, the XMLReader will perform its own default resolution.

Applications may register a new or different resolver in the middle of a parse, and the SAX parser must begin using the new resolver immediately.

Parameters:
resolver - The entity resolver.
See Also:
getEntityResolver()

getEntityResolver

EntityResolver getEntityResolver()
Return the current entity resolver.

Returns:
The current entity resolver, or null if none has been registered.
See Also:
setEntityResolver(org.xml.sax.EntityResolver)

setDTDHandler

void setDTDHandler(DTDHandler handler)
Allow an application to register a DTD event handler.

If the application does not register a DTD handler, all DTD events reported by the SAX parser will be silently ignored.

Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

Parameters:
handler - The DTD handler.
See Also:
getDTDHandler()

getDTDHandler

DTDHandler getDTDHandler()
Return the current DTD handler.

Returns:
The current DTD handler, or null if none has been registered.
See Also:
setDTDHandler(org.xml.sax.DTDHandler)

setContentHandler

void setContentHandler(ContentHandler handler)
Allow an application to register a content event handler.

If the application does not register a content handler, all content events reported by the SAX parser will be silently ignored.

Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

Parameters:
handler - The content handler.
See Also:
getContentHandler()

getContentHandler

ContentHandler getContentHandler()
Return the current content handler.

Returns:
The current content handler, or null if none has been registered.
See Also:
setContentHandler(org.xml.sax.ContentHandler)

setErrorHandler

void setErrorHandler(ErrorHandler handler)
Allow an application to register an error event handler.

If the application does not register an error handler, all error events reported by the SAX parser will be silently ignored; however, normal processing may not continue. It is highly recommended that all SAX applications implement an error handler to avoid unexpected bugs.

Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

Parameters:
handler - The error handler.
See Also:
getErrorHandler()

getErrorHandler

ErrorHandler getErrorHandler()
Return the current error handler.

Returns:
The current error handler, or null if none has been registered.
See Also:
setErrorHandler(org.xml.sax.ErrorHandler)

parse

void parse(InputSource input)
           throws IOException,
                  SAXException
Parse an XML document.

The application can use this method to instruct the XML reader to begin parsing an XML document from any valid input source (a character stream, a byte stream, or a URI).

Applications may not invoke this method while a parse is in progress (they should create a new XMLReader instead for each nested XML document). Once a parse is complete, an application may reuse the same XMLReader object, possibly with a different input source. Configuration of the XMLReader object (such as handler bindings and values established for feature flags and properties) is unchanged by completion of a parse, unless the definition of that aspect of the configuration explicitly specifies other behavior. (For example, feature flags or properties exposing characteristics of the document being parsed.)

During the parse, the XMLReader will provide information about the XML document through the registered event handlers.

This method is synchronous: it will not return until parsing has ended. If a client application wants to terminate parsing early, it should throw an exception.

Parameters:
input - The input source for the top-level of the XML document.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
See Also:
InputSource,
parse(java.lang.String),
setEntityResolver(org.xml.sax.EntityResolver),
setDTDHandler(org.xml.sax.DTDHandler),
setContentHandler(org.xml.sax.ContentHandler),
setErrorHandler(org.xml.sax.ErrorHandler)

parse

void parse(String systemId)
           throws IOException,
                  SAXException
Parse an XML document from a system identifier (URI).

This method is a shortcut for the common case of reading a document from a system identifier. It is the exact equivalent of the following:

 parse(new InputSource(systemId));

If the system identifier is a URL, it must be fully resolved by the application before it is passed to the parser.

Parameters:
systemId - The system identifier (URI).
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
See Also:
parse(org.xml.sax.InputSource)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Attributes2 (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.xml.sax.ext
Interface Attributes2

All Superinterfaces:
Attributes
All Known Implementing Classes:
Attributes2Impl
public interface Attributes2
extends Attributes

SAX2 extension to augment the per-attribute information provided though Attributes. If an implementation supports this extension, the attributes provided in ContentHandler.startElement() will implement this interface, and the http://xml.org/sax/features/use-attributes2 feature flag will have the value true.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

XMLReader implementations are not required to support this information, and it is not part of core-only SAX2 distributions.

Note that if an attribute was defaulted (!isSpecified()) it will of necessity also have been declared (isDeclared()) in the DTD. Similarly if an attribute's type is anything except CDATA, then it must have been declared.

Since:
SAX 2.0 (extensions 1.1 alpha)

Method Summary
Modifier and Type | Method and Description
boolean | isDeclared(int index) Returns false unless the attribute was declared in the DTD.
boolean | isDeclared(String qName) Returns false unless the attribute was declared in the DTD.
boolean | isDeclared(String uri, String localName) Returns false unless the attribute was declared in the DTD.
boolean | isSpecified(int index) Returns true unless the attribute value was provided by DTD defaulting.
boolean | isSpecified(String qName) Returns true unless the attribute value was provided by DTD defaulting.
boolean | isSpecified(String uri, String localName) Returns true unless the attribute value was provided by DTD defaulting.
Methods inherited from interface org.xml.sax.Attributes
getIndex, getIndex, getLength, getLocalName, getQName, getType, getType, getType, getURI, getValue, getValue, getValue

Method Detail

isDeclared

boolean isDeclared(int index)
Returns false unless the attribute was declared in the DTD. This helps distinguish two kinds of attributes that SAX reports as CDATA: ones that were declared (and hence are usually valid), and those that were not (and which are never valid).

Parameters:
index - The attribute index (zero-based).
Returns:
true if the attribute was declared in the DTD, false otherwise.
Throws:
ArrayIndexOutOfBoundsException - When the supplied index does not identify an attribute.

isDeclared

boolean isDeclared(String qName)
Returns false unless the attribute was declared in the DTD. This helps distinguish two kinds of attributes that SAX reports as CDATA: ones that were declared (and hence are usually valid), and those that were not (and which are never valid).

Parameters:
qName - The XML qualified (prefixed) name.
Returns:
true if the attribute was declared in the DTD, false otherwise.
Throws:
IllegalArgumentException - When the supplied name does not identify an attribute.

isDeclared

boolean isDeclared(String uri,
                   String localName)
Returns false unless the attribute was declared in the DTD. This helps distinguish two kinds of attributes that SAX reports as CDATA: ones that were declared (and hence are usually valid), and those that were not (and which are never valid).

Remember that since DTDs do not "understand" namespaces, the namespace URI associated with an attribute may not have come from the DTD. The declaration will have applied to the attribute's qName.

Parameters:
uri - The Namespace URI, or the empty string if the name has no Namespace URI.
localName - The attribute's local name.
Returns:
true if the attribute was declared in the DTD, false otherwise.
Throws:
IllegalArgumentException - When the supplied names do not identify an attribute.

isSpecified

boolean isSpecified(int index)
Returns true unless the attribute value was provided by DTD defaulting.

Parameters:
index - The attribute index (zero-based).
Returns:
true if the value was found in the XML text, false if the value was provided by DTD defaulting.
Throws:
ArrayIndexOutOfBoundsException - When the supplied index does not identify an attribute.

isSpecified

boolean isSpecified(String uri,
                    String localName)
Returns true unless the attribute value was provided by DTD defaulting.

Remember that since DTDs do not "understand" namespaces, the namespace URI associated with an attribute may not have come from the DTD. The declaration will have applied to the attribute's qName.

Parameters:
uri - The Namespace URI, or the empty string if the name has no Namespace URI.
localName - The attribute's local name.
Returns:
true if the value was found in the XML text, false if the value was provided by DTD defaulting.
Throws:
IllegalArgumentException - When the supplied names do not identify an attribute.

isSpecified

boolean isSpecified(String qName)
Returns true unless the attribute value was provided by DTD defaulting.

Parameters:
qName - The XML qualified (prefixed) name.
Returns:
true if the value was found in the XML text, false if the value was provided by DTD defaulting.
Throws:
IllegalArgumentException - When the supplied name does not identify an attribute.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Attributes2Impl (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax.ext
Class Attributes2Impl

java.lang.Object
    extended by  org.xml.sax.helpers.AttributesImpl
        extended by  org.xml.sax.ext.Attributes2Impl
All Implemented Interfaces:
Attributes, Attributes2
public class Attributes2Impl
extends AttributesImpl
implements Attributes2

SAX2 extension helper for additional Attributes information, implementing the Attributes2 interface.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

This is not part of core-only SAX2 distributions.

The specified flag for each attribute will always be true, unless it has been set to false in the copy constructor or using setSpecified(int, boolean). Similarly, the declared flag for each attribute will always be false, except for defaulted attributes (specified is false), non-CDATA attributes, or when it is set to true using setDeclared(int, boolean). If you change an attribute's type by hand, you may need to modify its declared flag to match.

Since:
SAX 2.0 (extensions 1.1 alpha)

Constructor Summary
Constructor and Description
Attributes2Impl()
Construct a new, empty Attributes2Impl object.
Attributes2Impl(Attributes atts)
Copy an existing Attributes or Attributes2 object.
Method Summary
Modifier and Type | Method and Description
void | addAttribute(String uri, String localName, String qName, String type, String value) Add an attribute to the end of the list, setting its "specified" flag to true.
boolean | isDeclared(int index) Returns the current value of the attribute's "declared" flag.
boolean | isDeclared(String qName) Returns the current value of the attribute's "declared" flag.
boolean | isDeclared(String uri, String localName) Returns the current value of the attribute's "declared" flag.
boolean | isSpecified(int index) Returns the current value of an attribute's "specified" flag.
boolean | isSpecified(String qName) Returns the current value of an attribute's "specified" flag.
boolean | isSpecified(String uri, String localName) Returns the current value of an attribute's "specified" flag.
void | removeAttribute(int index) Remove an attribute from the list.
void | setAttributes(Attributes atts) Copy an entire Attributes object.
void | setDeclared(int index, boolean value) Assign a value to the "declared" flag of a specific attribute.
void | setSpecified(int index, boolean value) Assign a value to the "specified" flag of a specific attribute.
Methods inherited from class org.xml.sax.helpers.AttributesImpl
clear, getIndex, getIndex, getLength, getLocalName, getQName, getType, getType, getType, getURI, getValue, getValue, getValue, setAttribute, setLocalName, setQName, setType, setURI, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.xml.sax.Attributes
getIndex, getIndex, getLength, getLocalName, getQName, getType, getType, getType, getURI, getValue, getValue, getValue

Constructor Detail

Attributes2Impl

public Attributes2Impl()
Construct a new, empty Attributes2Impl object.

Attributes2Impl

public Attributes2Impl(Attributes atts)
Copy an existing Attributes or Attributes2 object. If the object implements Attributes2, values of the specified and declared flags for each attribute are copied. Otherwise the flag values are defaulted to assume no DTD was used, unless there is evidence to the contrary (such as attributes with type other than CDATA, which must have been declared).

This constructor is especially useful inside a startElement event.

Parameters:
atts - The existing Attributes object.
Method Detail

isDeclared

public boolean isDeclared(int index)
Returns the current value of the attribute's "declared" flag.

Specified by:
isDeclared in interface Attributes2
Parameters:
index - The attribute index (zero-based).
Returns:
true if the attribute was declared in the DTD, false otherwise.

isDeclared

public boolean isDeclared(String uri,
                          String localName)
Returns the current value of the attribute's "declared" flag.

Specified by:
isDeclared in interface Attributes2
Parameters:
uri - The Namespace URI, or the empty string if the name has no Namespace URI.
localName - The attribute's local name.
Returns:
true if the attribute was declared in the DTD, false otherwise.

isDeclared

public boolean isDeclared(String qName)
Returns the current value of the attribute's "declared" flag.

Specified by:
isDeclared in interface Attributes2
Parameters:
qName - The XML qualified (prefixed) name.
Returns:
true if the attribute was declared in the DTD, false otherwise.

isSpecified

public boolean isSpecified(int index)
Returns the current value of an attribute's "specified" flag.

Specified by:
isSpecified in interface Attributes2
Parameters:
index - The attribute index (zero-based).
Returns:
current flag value
Throws:
ArrayIndexOutOfBoundsException - When the supplied index does not identify an attribute.

isSpecified

public boolean isSpecified(String uri,
                           String localName)
Returns the current value of an attribute's "specified" flag.

Specified by:
isSpecified in interface Attributes2
Parameters:
uri - The Namespace URI, or the empty string if the name has no Namespace URI.
localName - The attribute's local name.
Returns:
current flag value
Throws:
IllegalArgumentException - When the supplied names do not identify an attribute.

isSpecified

public boolean isSpecified(String qName)
Returns the current value of an attribute's "specified" flag.

Specified by:
isSpecified in interface Attributes2
Parameters:
qName - The XML qualified (prefixed) name.
Returns:
current flag value
Throws:
IllegalArgumentException - When the supplied name does not identify an attribute.

setAttributes

public void setAttributes(Attributes atts)
Copy an entire Attributes object. The "specified" flags are assigned as true, and "declared" flags as false (except when an attribute's type is not CDATA), unless the object is an Attributes2 object. In that case those flag values are all copied.

Overrides:
setAttributes in class AttributesImpl
Parameters:
atts - The attributes to copy.
See Also:
AttributesImpl.setAttributes(org.xml.sax.Attributes)

addAttribute

public void addAttribute(String uri,
                         String localName,
                         String qName,
                         String type,
                         String value)
Add an attribute to the end of the list, setting its "specified" flag to true. To set that flag's value to false, use setSpecified(int, boolean).

Unless the attribute type is CDATA, this attribute is marked as being declared in the DTD. To set that flag's value to true for CDATA attributes, use setDeclared(int, boolean).

Overrides:
addAttribute in class AttributesImpl
Parameters:
uri - The Namespace URI, or the empty string if none is available or Namespace processing is not being performed.
localName - The local name, or the empty string if Namespace processing is not being performed.
qName - The qualified (prefixed) name, or the empty string if qualified names are not available.
type - The attribute type as a string.
value - The attribute value.
See Also:
AttributesImpl.addAttribute(java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String)

removeAttribute

public void removeAttribute(int index)
Description copied from class: AttributesImpl
Remove an attribute from the list.

Overrides:
removeAttribute in class AttributesImpl
Parameters:
index - The index of the attribute (zero-based).

setDeclared

public void setDeclared(int index,
                        boolean value)
Assign a value to the "declared" flag of a specific attribute. This is normally needed only for attributes of type CDATA, including attributes whose type is changed to or from CDATA.

Parameters:
index - The index of the attribute (zero-based).
value - The desired flag value.
Throws:
ArrayIndexOutOfBoundsException - When the supplied index does not identify an attribute.
See Also:
AttributesImpl.setType(int, java.lang.String)

setSpecified

public void setSpecified(int index,
                         boolean value)
Assign a value to the "specified" flag of a specific attribute. This is the only way this flag can be cleared, except clearing by initialization with the copy constructor.

Parameters:
index - The index of the attribute (zero-based).
value - The desired flag value.
Throws:
ArrayIndexOutOfBoundsException - When the supplied index does not identify an attribute.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DeclHandler (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax.ext
Interface DeclHandler

All Known Implementing Classes:
DefaultHandler2
public interface DeclHandler

SAX2 extension handler for DTD declaration events.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

This is an optional extension handler for SAX2 to provide more complete information about DTD declarations in an XML document. XML readers are not required to recognize this handler, and it is not part of core-only SAX2 distributions.

Note that data-related DTD declarations (unparsed entities and notations) are already reported through the DTDHandler interface.

If you are using the declaration handler together with a lexical handler, all of the events will occur between the startDTD and the endDTD events.

To set the DeclHandler for an XML reader, use the setProperty method with the property name http://xml.org/sax/properties/declaration-handler and an object implementing this interface (or null) as the value. If the reader does not report declaration events, it will throw a SAXNotRecognizedException when you attempt to register the handler.

Since:
SAX 2.0 (extensions 1.0)

Method Summary
Modifier and Type | Method and Description
void | attributeDecl(String eName, String aName, String type, String mode, String value) Report an attribute type declaration.
void | elementDecl(String name, String model) Report an element type declaration.
void | externalEntityDecl(String name, String publicId, String systemId) Report a parsed external entity declaration.
void | internalEntityDecl(String name, String value) Report an internal entity declaration.

Method Detail

elementDecl

void elementDecl(String name,
                 String model)
                 throws SAXException
Report an element type declaration.

The content model will consist of the string "EMPTY", the string "ANY", or a parenthesised group, optionally followed by an occurrence indicator. The model will be normalized so that all parameter entities are fully resolved and all whitespace is removed,and will include the enclosing parentheses. Other normalization (such as removing redundant parentheses or simplifying occurrence indicators) is at the discretion of the parser.

Parameters:
name - The element type name.
model - The content model as a normalized string.
Throws:
SAXException - The application may raise an exception.

attributeDecl

void attributeDecl(String eName,
                   String aName,
                   String type,
                   String mode,
                   String value)
                   throws SAXException
Report an attribute type declaration.

Only the effective (first) declaration for an attribute will be reported. The type will be one of the strings "CDATA", "ID", "IDREF", "IDREFS", "NMTOKEN", "NMTOKENS", "ENTITY", "ENTITIES", a parenthesized token group with the separator "|" and all whitespace removed, or the word "NOTATION" followed by a space followed by a parenthesized token group with all whitespace removed.

The value will be the value as reported to applications, appropriately normalized and with entity and character references expanded.

Parameters:
eName - The name of the associated element.
aName - The name of the attribute.
type - A string representing the attribute type.
mode - A string representing the attribute defaulting mode ("#IMPLIED", "#REQUIRED", or "#FIXED") or null if none of these applies.
value - A string representing the attribute's default value, or null if there is none.
Throws:
SAXException - The application may raise an exception.

internalEntityDecl

void internalEntityDecl(String name,
                        String value)
                        throws SAXException
Report an internal entity declaration.

Only the effective (first) declaration for each entity will be reported. All parameter entities in the value will be expanded, but general entities will not.

Parameters:
name - The name of the entity. If it is a parameter entity, the name will begin with '%'.
value - The replacement text of the entity.
Throws:
SAXException - The application may raise an exception.
See Also:
externalEntityDecl(java.lang.String, java.lang.String, java.lang.String), DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

externalEntityDecl

void externalEntityDecl(String name,
                        String publicId,
                        String systemId)
                        throws SAXException
Report a parsed external entity declaration.

Only the effective (first) declaration for each entity will be reported.

If the system identifier is a URL, the parser must resolve it fully before passing it to the application.

Parameters:
name - The name of the entity. If it is a parameter entity, the name will begin with '%'.
publicId - The entity's public identifier, or null if none was given.
systemId - The entity's system identifier.
Throws:
SAXException - The application may raise an exception.
See Also:
internalEntityDecl(java.lang.String, java.lang.String), DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DefaultHandler2 (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax.ext
Class DefaultHandler2

java.lang.Object
    extended by  org.xml.sax.helpers.DefaultHandler
        extended by  org.xml.sax.ext.DefaultHandler2
All Implemented Interfaces:
ContentHandler, DTDHandler, EntityResolver, ErrorHandler, DeclHandler, EntityResolver2, LexicalHandler
public class DefaultHandler2
extends DefaultHandler
implements LexicalHandler, DeclHandler, EntityResolver2

This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions. Except for overriding the original SAX1 resolveEntity() method the added handler methods just return. Subclassers may override everything on a method-by-method basis.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

Note: this class might yet learn that the ContentHandler.setDocumentLocator() call might be passed a Locator2 object, and that the ContentHandler.startElement() call might be passed a Attributes2 object.

Since:
SAX 2.0 (extensions 1.1 alpha)

Constructor Summary
Constructor and Description
DefaultHandler2()
Constructs a handler which ignores all parsing events.
Method Summary
Modifier and Type Method and Description
 void attributeDecl(String eName, String aName, String type, String mode, String value)
Report an attribute type declaration.
 void comment(char[] ch, int start, int length)
Report an XML comment anywhere in the document.
 void elementDecl(String name, String model)
Report an element type declaration.
 void endCDATA()
Report the end of a CDATA section.
 void endDTD()
Report the end of DTD declarations.
 void endEntity(String name)
Report the end of an entity.
 void externalEntityDecl(String name, String publicId, String systemId)
Report a parsed external entity declaration.
 InputSource getExternalSubset(String name, String baseURI)
Tells the parser that if no external subset has been declared in the document text, none should be used.
 void internalEntityDecl(String name, String value)
Report an internal entity declaration.
 InputSource resolveEntity(String publicId, String systemId)
Invokes EntityResolver2.resolveEntity() with null entity name and base URI.
 InputSource resolveEntity(String name, String publicId, String baseURI, String systemId)
Tells the parser to resolve the systemId against the baseURI and read the entity text from that resulting absolute URI.
 void startCDATA()
Report the start of a CDATA section.
 void startDTD(String name, String publicId, String systemId)
Report the start of DTD declarations, if any.
 void startEntity(String name)
Report the beginning of some internal and external XML entities.
Methods inherited from class org.xml.sax.helpers.DefaultHandler
characters, endDocument, endElement, endPrefixMapping, error, fatalError, ignorableWhitespace, notationDecl, processingInstruction, setDocumentLocator, skippedEntity, startDocument, startElement, startPrefixMapping, unparsedEntityDecl, warning
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultHandler2

public DefaultHandler2()
Constructs a handler which ignores all parsing events.

Method Detail

startCDATA

public void startCDATA()
                throws SAXException
Description copied from interface: LexicalHandler
Report the start of a CDATA section.

The contents of the CDATA section will be reported through the regular characters event; this event is intended only to report the boundary.

Specified by:
startCDATA in interface LexicalHandler
Throws:
SAXException - The application may raise an exception.
See Also:
LexicalHandler.endCDATA()

endCDATA

public void endCDATA()
              throws SAXException
Description copied from interface: LexicalHandler
Report the end of a CDATA section.

Specified by:
endCDATA in interface LexicalHandler
Throws:
SAXException - The application may raise an exception.
See Also:
LexicalHandler.startCDATA()

startDTD

public void startDTD(String name,
                     String publicId,
                     String systemId)
              throws SAXException
Description copied from interface: LexicalHandler
Report the start of DTD declarations, if any.

This method is intended to report the beginning of the DOCTYPE declaration; if the document has no DOCTYPE declaration, this method will not be invoked.

All declarations reported through DTDHandler or DeclHandler events must appear between the startDTD and endDTD events. Declarations are assumed to belong to the internal DTD subset unless they appear between startEntity and endEntity events. Comments and processing instructions from the DTD should also be reported between the startDTD and endDTD events, in their original order of (logical) occurrence; they are not required to appear in their correct locations relative to DTDHandler or DeclHandler events, however.

Note that the start/endDTD events will appear within the start/endDocument events from ContentHandler and before the first startElement event.

Specified by:
startDTD in interface LexicalHandler
Parameters:
name - The document type name.
publicId - The declared public identifier for the external DTD subset, or null if none was declared.
systemId - The declared system identifier for the external DTD subset, or null if none was declared. (Note that this is not resolved against the document base URI.)
Throws:
SAXException - The application may raise an exception.
See Also:
LexicalHandler.endDTD(), LexicalHandler.startEntity(java.lang.String)

endDTD

public void endDTD()
            throws SAXException
Description copied from interface: LexicalHandler
Report the end of DTD declarations.

This method is intended to report the end of the DOCTYPE declaration; if the document has no DOCTYPE declaration, this method will not be invoked.

Specified by:
endDTD in interface LexicalHandler
Throws:
SAXException - The application may raise an exception.
See Also:
LexicalHandler.startDTD(java.lang.String, java.lang.String, java.lang.String)

startEntity

public void startEntity(String name)
                 throws SAXException
Description copied from interface: LexicalHandler
Report the beginning of some internal and external XML entities.

The reporting of parameter entities (including the external DTD subset) is optional, and SAX2 drivers that report LexicalHandler events may not implement it; you can use the http://xml.org/sax/features/lexical-handler/parameter-entities feature to query or control the reporting of parameter entities.

General entities are reported with their regular names, parameter entities have '%' prepended to their names, and the external DTD subset has the pseudo-entity name "[dtd]".

When a SAX2 driver is providing these events, all other events must be properly nested within start/end entity events. There is no additional requirement that events from DeclHandler or DTDHandler be properly ordered.

Note that skipped entities will be reported through the skippedEntity event, which is part of the ContentHandler interface.

Because of the streaming event model that SAX uses, some entity boundaries cannot be reported under any circumstances:

  • general entities within attribute values
  • parameter entities within declarations

These will be silently expanded, with no indication of where the original entity boundaries were.

Note also that the boundaries of character references (which are not really entities anyway) are not reported.

All start/endEntity events must be properly nested.

Specified by:
startEntity in interface LexicalHandler
Parameters:
name - The name of the entity. If it is a parameter entity, the name will begin with '%', and if it is the external DTD subset, it will be "[dtd]".
Throws:
SAXException - The application may raise an exception.
See Also:
LexicalHandler.endEntity(java.lang.String),
DeclHandler.internalEntityDecl(java.lang.String, java.lang.String),
DeclHandler.externalEntityDecl(java.lang.String, java.lang.String, java.lang.String)

endEntity

public void endEntity(String name)
               throws SAXException
Description copied from interface: LexicalHandler
Report the end of an entity.

Specified by:
endEntity in interface LexicalHandler
Parameters:
name - The name of the entity that is ending.
Throws:
SAXException - The application may raise an exception.
See Also:
LexicalHandler.startEntity(java.lang.String)

comment

public void comment(char[] ch,
                    int start,
                    int length)
             throws SAXException
Description copied from interface: LexicalHandler
Report an XML comment anywhere in the document.

This callback will be used for comments inside or outside the document element, including comments in the external DTD subset (if read). Comments in the DTD must be properly nested inside start/endDTD and start/endEntity events (if used).

Specified by:
comment in interface LexicalHandler
Parameters:
ch - An array holding the characters in the comment.
start - The starting position in the array.
length - The number of characters to use from the array.
Throws:
SAXException - The application may raise an exception.

attributeDecl

public void attributeDecl(String eName,
                          String aName,
                          String type,
                          String mode,
                          String value)
                   throws SAXException
Description copied from interface: DeclHandler
Report an attribute type declaration.

Only the effective (first) declaration for an attribute will be reported. The type will be one of the strings "CDATA", "ID", "IDREF", "IDREFS", "NMTOKEN", "NMTOKENS", "ENTITY", "ENTITIES", a parenthesized token group with the separator "|" and all whitespace removed, or the word "NOTATION" followed by a space followed by a parenthesized token group with all whitespace removed.

The value will be the value as reported to applications, appropriately normalized and with entity and character references expanded.

Specified by:
attributeDecl in interface DeclHandler
Parameters:
eName - The name of the associated element.
aName - The name of the attribute.
type - A string representing the attribute type.
mode - A string representing the attribute defaulting mode ("#IMPLIED", "#REQUIRED", or "#FIXED") or null if none of these applies.
value - A string representing the attribute's default value, or null if there is none.
Throws:
SAXException - The application may raise an exception.

elementDecl

public void elementDecl(String name,
                        String model)
                 throws SAXException
Description copied from interface: DeclHandler
Report an element type declaration.

The content model will consist of the string "EMPTY", the string "ANY", or a parenthesised group, optionally followed by an occurrence indicator. The model will be normalized so that all parameter entities are fully resolved and all whitespace is removed,and will include the enclosing parentheses. Other normalization (such as removing redundant parentheses or simplifying occurrence indicators) is at the discretion of the parser.

Specified by:
elementDecl in interface DeclHandler
Parameters:
name - The element type name.
model - The content model as a normalized string.
Throws:
SAXException - The application may raise an exception.

externalEntityDecl

public void externalEntityDecl(String name,
                               String publicId,
                               String systemId)
                        throws SAXException
Description copied from interface: DeclHandler
Report a parsed external entity declaration.

Only the effective (first) declaration for each entity will be reported.

If the system identifier is a URL, the parser must resolve it fully before passing it to the application.

Specified by:
externalEntityDecl in interface DeclHandler
Parameters:
name - The name of the entity. If it is a parameter entity, the name will begin with '%'.
publicId - The entity's public identifier, or null if none was given.
systemId - The entity's system identifier.
Throws:
SAXException - The application may raise an exception.
See Also:
DeclHandler.internalEntityDecl(java.lang.String, java.lang.String), DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

internalEntityDecl

public void internalEntityDecl(String name,
                               String value)
                        throws SAXException
Description copied from interface: DeclHandler
Report an internal entity declaration.

Only the effective (first) declaration for each entity will be reported. All parameter entities in the value will be expanded, but general entities will not.

Specified by:
internalEntityDecl in interface DeclHandler
Parameters:
name - The name of the entity. If it is a parameter entity, the name will begin with '%'.
value - The replacement text of the entity.
Throws:
SAXException - The application may raise an exception.
See Also:
DeclHandler.externalEntityDecl(java.lang.String, java.lang.String, java.lang.String), DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

getExternalSubset

public InputSource getExternalSubset(String name,
                                     String baseURI)
                              throws SAXException,
                                     IOException
Tells the parser that if no external subset has been declared in the document text, none should be used.

Specified by:
getExternalSubset in interface EntityResolver2
Parameters:
name - Identifies the document root element. This name comes from a DOCTYPE declaration (where available) or from the actual root element.
baseURI - The document's base URI, serving as an additional hint for selecting the external subset. This is always an absolute URI, unless it is null because the XMLReader was given an InputSource without one.
Returns:
An InputSource object describing the new external subset to be used by the parser, or null to indicate that no external subset is provided.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
IOException - Probably indicating a failure to create a new InputStream or Reader, or an illegal URL.

resolveEntity

public InputSource resolveEntity(String name,
                                 String publicId,
                                 String baseURI,
                                 String systemId)
                          throws SAXException,
                                 IOException
Tells the parser to resolve the systemId against the baseURI and read the entity text from that resulting absolute URI. Note that because the older DefaultHandler.resolveEntity(), method is overridden to call this one, this method may sometimes be invoked with null name and baseURI, and with the systemId already absolutized.

Specified by:
resolveEntity in interface EntityResolver2
Parameters:
name - Identifies the external entity being resolved. Either "[dtd]" for the external subset, or a name starting with "%" to indicate a parameter entity, or else the name of a general entity. This is never null when invoked by a SAX2 parser.
publicId - The public identifier of the external entity being referenced (normalized as required by the XML specification), or null if none was supplied.
baseURI - The URI with respect to which relative systemIDs are interpreted. This is always an absolute URI, unless it is null (likely because the XMLReader was given an InputSource without one). This URI is defined by the XML specification to be the one associated with the "<" starting the relevant declaration.
systemId - The system identifier of the external entity being referenced; either a relative or absolute URI. This is never null when invoked by a SAX2 parser; only declared entities, and any external subset, are resolved by such parsers.
Returns:
An InputSource object describing the new input source to be used by the parser. Returning null directs the parser to resolve the system ID against the base URI and open a connection to resulting URI.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
IOException - Probably indicating a failure to create a new InputStream or Reader, or an illegal URL.

resolveEntity

public InputSource resolveEntity(String publicId,
                                 String systemId)
                          throws SAXException,
                                 IOException
Invokes EntityResolver2.resolveEntity() with null entity name and base URI. You only need to override that method to use this class.

Specified by:
resolveEntity in interface EntityResolver
Overrides:
resolveEntity in class DefaultHandler
Parameters:
publicId - The public identifier, or null if none is available.
systemId - The system identifier provided in the XML document.
Returns:
The new input source, or null to require the default behaviour.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
IOException - A Java-specific IO exception, possibly the result of creating a new InputStream or Reader for the InputSource.
See Also:
EntityResolver.resolveEntity(java.lang.String, java.lang.String)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


EntityResolver2 (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax.ext
Interface EntityResolver2

All Superinterfaces:
EntityResolver
All Known Implementing Classes:
DefaultHandler2
public interface EntityResolver2
extends EntityResolver

Extended interface for mapping external entity references to input sources, or providing a missing external subset. The XMLReader.setEntityResolver() method is used to provide implementations of this interface to parsers. When a parser uses the methods in this interface, the EntityResolver2.resolveEntity() method (in this interface) is used instead of the older (SAX 1.0) EntityResolver.resolveEntity() method.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

If a SAX application requires the customized handling which this interface defines for external entities, it must ensure that it uses an XMLReader with the http://xml.org/sax/features/use-entity-resolver2 feature flag set to true (which is its default value when the feature is recognized). If that flag is unrecognized, or its value is false, or the resolver does not implement this interface, then only the EntityResolver method will be used.

That supports three categories of application that modify entity resolution. Old Style applications won't know about this interface; they will provide an EntityResolver. Transitional Mode provide an EntityResolver2 and automatically get the benefit of its methods in any systems (parsers or other tools) supporting it, due to polymorphism. Both Old Style and Transitional Mode applications will work with any SAX2 parser. New style applications will fail to run except on SAX2 parsers that support this particular feature. They will insist that feature flag have a value of "true", and the EntityResolver2 implementation they provide might throw an exception if the original SAX 1.0 style entity resolution method is invoked.

Since:
SAX 2.0 (extensions 1.1 alpha)
See Also:
XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

Method Summary
Modifier and Type | Method and Description
InputSource | getExternalSubset(String name, String baseURI) Allows applications to provide an external subset for documents that don't explicitly define one.
InputSource | resolveEntity(String name, String publicId, String baseURI, String systemId) Allows applications to map references to external entities into input sources, or tell the parser it should use conventional URI resolution.
Methods inherited from interface org.xml.sax.EntityResolver
resolveEntity

Method Detail

getExternalSubset

InputSource getExternalSubset(String name,
                              String baseURI)
                              throws SAXException,
                                     IOException
Allows applications to provide an external subset for documents that don't explicitly define one. Documents with DOCTYPE declarations that omit an external subset can thus augment the declarations available for validation, entity processing, and attribute processing (normalization, defaulting, and reporting types including ID). This augmentation is reported through the startDTD() method as if the document text had originally included the external subset; this callback is made before any internal subset data or errors are reported.

This method can also be used with documents that have no DOCTYPE declaration. When the root element is encountered, but no DOCTYPE declaration has been seen, this method is invoked. If it returns a value for the external subset, that root element is declared to be the root element, giving the effect of splicing a DOCTYPE declaration at the end the prolog of a document that could not otherwise be valid. The sequence of parser callbacks in that case logically resembles this:

 ... comments and PIs from the prolog (as usual)
 startDTD ("rootName", source.getPublicId (), source.getSystemId ());
 startEntity ("[dtd]");
 ... declarations, comments, and PIs from the external subset
 endEntity ("[dtd]");
 endDTD ();
 ... then the rest of the document (as usual)
 startElement (..., "rootName", ...);

Note that the InputSource gets no further resolution. Implementations of this method may wish to invoke resolveEntity() to gain benefits such as use of local caches of DTD entities. Also, this method will never be used by a (non-validating) processor that is not including external parameter entities.

Uses for this method include facilitating data validation when interoperating with XML processors that would always require undesirable network accesses for external entities, or which for other reasons adopt a "no DTDs" policy. Non-validation motives include forcing documents to include DTDs so that attributes are handled consistently. For example, an XPath processor needs to know which attibutes have type "ID" before it can process a widely used type of reference.

Warning: Returning an external subset modifies the input document. By providing definitions for general entities, it can make a malformed document appear to be well formed.

Parameters:
name - Identifies the document root element. This name comes from a DOCTYPE declaration (where available) or from the actual root element.
baseURI - The document's base URI, serving as an additional hint for selecting the external subset. This is always an absolute URI, unless it is null because the XMLReader was given an InputSource without one.
Returns:
An InputSource object describing the new external subset to be used by the parser, or null to indicate that no external subset is provided.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
IOException - Probably indicating a failure to create a new InputStream or Reader, or an illegal URL.

resolveEntity

InputSource resolveEntity(String name,
                          String publicId,
                          String baseURI,
                          String systemId)
                          throws SAXException,
                                 IOException
Allows applications to map references to external entities into input sources, or tell the parser it should use conventional URI resolution. This method is only called for external entities which have been properly declared. This method provides more flexibility than the EntityResolver interface, supporting implementations of more complex catalogue schemes such as the one defined by the OASIS XML Catalogs specification.

Parsers configured to use this resolver method will call it to determine the input source to use for any external entity being included because of a reference in the XML text. That excludes the document entity, and any external entity returned by getExternalSubset(). When a (non-validating) processor is configured not to include a class of entities (parameter or general) through use of feature flags, this method is not invoked for such entities.

Note that the entity naming scheme used here is the same one used in the LexicalHandler, or in the ContentHandler.skippedEntity() method.

Parameters:
name - Identifies the external entity being resolved. Either "[dtd]" for the external subset, or a name starting with "%" to indicate a parameter entity, or else the name of a general entity. This is never null when invoked by a SAX2 parser.
publicId - The public identifier of the external entity being referenced (normalized as required by the XML specification), or null if none was supplied.
baseURI - The URI with respect to which relative systemIDs are interpreted. This is always an absolute URI, unless it is null (likely because the XMLReader was given an InputSource without one). This URI is defined by the XML specification to be the one associated with the "<" starting the relevant declaration.
systemId - The system identifier of the external entity being referenced; either a relative or absolute URI. This is never null when invoked by a SAX2 parser; only declared entities, and any external subset, are resolved by such parsers.
Returns:
An InputSource object describing the new input source to be used by the parser. Returning null directs the parser to resolve the system ID against the base URI and open a connection to resulting URI.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
IOException - Probably indicating a failure to create a new InputStream or Reader, or an illegal URL.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


LexicalHandler (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax.ext
Interface LexicalHandler

All Known Subinterfaces:
TransformerHandler
All Known Implementing Classes:
DefaultHandler2
public interface LexicalHandler

SAX2 extension handler for lexical events.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

This is an optional extension handler for SAX2 to provide lexical information about an XML document, such as comments and CDATA section boundaries. XML readers are not required to recognize this handler, and it is not part of core-only SAX2 distributions.

The events in the lexical handler apply to the entire document, not just to the document element, and all lexical handler events must appear between the content handler's startDocument and endDocument events.

To set the LexicalHandler for an XML reader, use the setProperty method with the property name http://xml.org/sax/properties/lexical-handler and an object implementing this interface (or null) as the value. If the reader does not report lexical events, it will throw a SAXNotRecognizedException when you attempt to register the handler.

Since:
SAX 2.0 (extensions 1.0)

Method Summary
Modifier and Type | Method and Description
void | comment(char[] ch, int start, int length) Report an XML comment anywhere in the document.
void | endCDATA() Report the end of a CDATA section.
void | endDTD() Report the end of DTD declarations.
void | endEntity(String name) Report the end of an entity.
void | startCDATA() Report the start of a CDATA section.
void | startDTD(String name, String publicId, String systemId) Report the start of DTD declarations, if any.
void | startEntity(String name) Report the beginning of some internal and external XML entities.

Method Detail

startDTD

void startDTD(String name,
              String publicId,
              String systemId)
              throws SAXException
Report the start of DTD declarations, if any.

This method is intended to report the beginning of the DOCTYPE declaration; if the document has no DOCTYPE declaration, this method will not be invoked.

All declarations reported through DTDHandler or DeclHandler events must appear between the startDTD and endDTD events. Declarations are assumed to belong to the internal DTD subset unless they appear between startEntity and endEntity events. Comments and processing instructions from the DTD should also be reported between the startDTD and endDTD events, in their original order of (logical) occurrence; they are not required to appear in their correct locations relative to DTDHandler or DeclHandler events, however.

Note that the start/endDTD events will appear within the start/endDocument events from ContentHandler and before the first startElement event.

Parameters:
name - The document type name.
publicId - The declared public identifier for the external DTD subset, or null if none was declared.
systemId - The declared system identifier for the external DTD subset, or null if none was declared. (Note that this is not resolved against the document base URI.)
Throws:
SAXException - The application may raise an exception.
See Also:
endDTD(), startEntity(java.lang.String)

endDTD

void endDTD()
            throws SAXException
Report the end of DTD declarations.

This method is intended to report the end of the DOCTYPE declaration; if the document has no DOCTYPE declaration, this method will not be invoked.

Throws:
SAXException - The application may raise an exception.
See Also:
startDTD(java.lang.String, java.lang.String, java.lang.String)

startEntity

void startEntity(String name)
                 throws SAXException
Report the beginning of some internal and external XML entities.

The reporting of parameter entities (including the external DTD subset) is optional, and SAX2 drivers that report LexicalHandler events may not implement it; you can use the http://xml.org/sax/features/lexical-handler/parameter-entities feature to query or control the reporting of parameter entities.

General entities are reported with their regular names, parameter entities have '%' prepended to their names, and the external DTD subset has the pseudo-entity name "[dtd]".

When a SAX2 driver is providing these events, all other events must be properly nested within start/end entity events. There is no additional requirement that events from DeclHandler or DTDHandler be properly ordered.

Note that skipped entities will be reported through the skippedEntity event, which is part of the ContentHandler interface.

Because of the streaming event model that SAX uses, some entity boundaries cannot be reported under any circumstances:

  • general entities within attribute values
  • parameter entities within declarations

These will be silently expanded, with no indication of where the original entity boundaries were.

Note also that the boundaries of character references (which are not really entities anyway) are not reported.

All start/endEntity events must be properly nested.

Parameters:
name - The name of the entity. If it is a parameter entity, the name will begin with '%', and if it is the external DTD subset, it will be "[dtd]".
Throws:
SAXException - The application may raise an exception.
See Also:
endEntity(java.lang.String),
DeclHandler.internalEntityDecl(java.lang.String, java.lang.String),
DeclHandler.externalEntityDecl(java.lang.String, java.lang.String, java.lang.String)

endEntity

void endEntity(String name)
               throws SAXException
Report the end of an entity.

Parameters:
name - The name of the entity that is ending.
Throws:
SAXException - The application may raise an exception.
See Also:
startEntity(java.lang.String)

startCDATA

void startCDATA()
                throws SAXException
Report the start of a CDATA section.

The contents of the CDATA section will be reported through the regular characters event; this event is intended only to report the boundary.

Throws:
SAXException - The application may raise an exception.
See Also:
endCDATA()

endCDATA

void endCDATA()
              throws SAXException
Report the end of a CDATA section.

Throws:
SAXException - The application may raise an exception.
See Also:
startCDATA()

comment

void comment(char[] ch,
             int start,
             int length)
             throws SAXException
Report an XML comment anywhere in the document.

This callback will be used for comments inside or outside the document element, including comments in the external DTD subset (if read). Comments in the DTD must be properly nested inside start/endDTD and start/endEntity events (if used).

Parameters:
ch - An array holding the characters in the comment.
start - The starting position in the array.
length - The number of characters to use from the array.
Throws:
SAXException - The application may raise an exception.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


Locator2 (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax.ext
Interface Locator2

All Superinterfaces:
Locator
All Known Implementing Classes:
Locator2Impl
public interface Locator2
extends Locator

SAX2 extension to augment the entity information provided though a Locator. If an implementation supports this extension, the Locator provided in ContentHandler.setDocumentLocator() will implement this interface, and the http://xml.org/sax/features/use-locator2 feature flag will have the value true.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

XMLReader implementations are not required to support this information, and it is not part of core-only SAX2 distributions.

Since:
SAX 2.0 (extensions 1.1 alpha)

Method Summary
Modifier and Type | Method and Description
String | getEncoding() Returns the name of the character encoding for the entity.
String | getXMLVersion() Returns the version of XML used for the entity.
Methods inherited from interface org.xml.sax.Locator
getColumnNumber, getLineNumber, getPublicId, getSystemId

Method Detail

getXMLVersion

String getXMLVersion()
Returns the version of XML used for the entity. This will normally be the identifier from the current entity's <?xml version='...' ...?> declaration, or be defaulted by the parser.

Returns:
Identifier for the XML version being used to interpret the entity's text, or null if that information is not yet available in the current parsing state.

getEncoding

String getEncoding()
Returns the name of the character encoding for the entity. If the encoding was declared externally (for example, in a MIME Content-Type header), that will be the name returned. Else if there was an <?xml ...encoding='...'?> declaration at the start of the document, that encoding name will be returned. Otherwise the encoding will been inferred (normally to be UTF-8, or some UTF-16 variant), and that inferred name will be returned.

When an InputSource is used to provide an entity's character stream, this method returns the encoding provided in that input stream.

Note that some recent W3C specifications require that text in some encodings be normalized, using Unicode Normalization Form C, before processing. Such normalization must be performed by applications, and would normally be triggered based on the value returned by this method.

Encoding names may be those used by the underlying JVM, and comparisons should be case-insensitive.

Returns:
Name of the character encoding being used to interpret * the entity's text, or null if this was not provided for a * character stream passed through an InputSource or is otherwise not yet available in the current parsing state.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


Locator2Impl (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.xml.sax.ext
Class Locator2Impl

java.lang.Object
    extended by  org.xml.sax.helpers.LocatorImpl
        extended by  org.xml.sax.ext.Locator2Impl
All Implemented Interfaces:
Locator2, Locator
public class Locator2Impl
extends LocatorImpl
implements Locator2

SAX2 extension helper for holding additional Entity information, implementing the Locator2 interface.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

This is not part of core-only SAX2 distributions.

Since:
SAX 2.0.2

Constructor Summary
Constructor and Description
Locator2Impl()
Construct a new, empty Locator2Impl object.
Locator2Impl(Locator locator)
Copy an existing Locator or Locator2 object.
Method Summary
Modifier and Type | Method and Description
String | getEncoding() Returns the current value of the encoding property.
String | getXMLVersion() Returns the current value of the version property.
void | setEncoding(String encoding) Assigns the current value of the encoding property.
void | setXMLVersion(String version) Assigns the current value of the version property.
Methods inherited from class org.xml.sax.helpers.LocatorImpl
getColumnNumber, getLineNumber, getPublicId, getSystemId, setColumnNumber, setLineNumber, setPublicId, setSystemId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.xml.sax.Locator
getColumnNumber, getLineNumber, getPublicId, getSystemId

Constructor Detail

Locator2Impl

public Locator2Impl()
Construct a new, empty Locator2Impl object. This will not normally be useful, since the main purpose of this class is to make a snapshot of an existing Locator.

Locator2Impl

public Locator2Impl(Locator locator)
Copy an existing Locator or Locator2 object. If the object implements Locator2, values of the encoding and versionstrings are copied, otherwise they set to null.

Parameters:
locator - The existing Locator object.
Method Detail

getXMLVersion

public String getXMLVersion()
Returns the current value of the version property.

Specified by:
getXMLVersion in interface Locator2
Returns:
Identifier for the XML version being used to interpret the entity's text, or null if that information is not yet available in the current parsing state.
See Also:
setXMLVersion(java.lang.String)

getEncoding

public String getEncoding()
Returns the current value of the encoding property.

Specified by:
getEncoding in interface Locator2
Returns:
Name of the character encoding being used to interpret * the entity's text, or null if this was not provided for a * character stream passed through an InputSource or is otherwise not yet available in the current parsing state.
See Also:
setEncoding(java.lang.String)

setXMLVersion

public void setXMLVersion(String version)
Assigns the current value of the version property.

Parameters:
version - the new "version" value
See Also:
getXMLVersion()

setEncoding

public void setEncoding(String encoding)
Assigns the current value of the encoding property.

Parameters:
encoding - the new "encoding" value
See Also:
getEncoding()
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.xml.sax.ext (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.xml.sax.ext

This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

See:
Description

Interface Summary
Interface | Description
Attributes2 | SAX2 extension to augment the per-attribute information provided though Attributes.
DeclHandler | SAX2 extension handler for DTD declaration events.
EntityResolver2 | Extended interface for mapping external entity references to input sources, or providing a missing external subset.
LexicalHandler | SAX2 extension handler for lexical events.
Locator2 | SAX2 extension to augment the entity information provided though a Locator.

Class Summary
Class | Description
Attributes2Impl | SAX2 extension helper for additional Attributes information, implementing the Attributes2 interface.
DefaultHandler2 | This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.
Locator2Impl | SAX2 extension helper for holding additional Entity information, implementing the Locator2 interface.

Package org.xml.sax.ext Description

This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

See http://www.saxproject.org for more information about SAX.

This package is independent of the SAX2 core, though the functionality exposed generally needs to be implemented within a parser core. That independence has several consequences:

  • SAX2 drivers are not required to recognize these handlers.
  • You cannot assume that the class files will be present in every SAX2 installation.
  • This package may be updated independently of SAX2 (i.e. new handlers and classes may be added without updating SAX2 itself).
  • The new handlers are not implemented by the SAX2 org.xml.sax.helpers.DefaultHandler or org.xml.sax.helpers.XMLFilterImpl classes. You can subclass these if you need such behavior, or use the helper classes found here.
  • The handlers need to be registered differently than core SAX2 handlers.

This package, SAX2-ext, is a standardized extension to SAX2. It is designed both to allow SAX parsers to pass certain types of information to applications, and to serve as a simple model for other SAX2 parser extension packages. Not all such extension packages should need to be recognized directly by parsers, however. As an example, most validation systems can be cleanly layered on top of parsers supporting the standardized SAX2 interfaces.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


AttributeListImpl (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.xml.sax.helpers
Class AttributeListImpl

java.lang.Object
    extended by  org.xml.sax.helpers.AttributeListImpl
All Implemented Interfaces:
AttributeList
Deprecated. This class implements a deprecated interface, AttributeList; that interface has been replaced by Attributes, which is implemented in the AttributesImpl helper class.

public class AttributeListImpl
extends Object
implements AttributeList

Default implementation for AttributeList.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

AttributeList implements the deprecated SAX1 AttributeList interface, and has been replaced by the new SAX2 AttributesImpl interface.

This class provides a convenience implementation of the SAX AttributeList interface. This implementation is useful both for SAX parser writers, who can use it to provide attributes to the application, and for SAX application writers, who can use it to create a persistent copy of an element's attribute specifications:

 private AttributeList myatts;

 public void startElement (String name, AttributeList atts)
 {
              // create a persistent copy of the attribute list
              // for use outside this method
   myatts = new AttributeListImpl(atts);
   [...]
 }

Please note that SAX parsers are not required to use this class to provide an implementation of AttributeList; it is supplied only as an optional convenience. In particular, parser writers are encouraged to invent more efficient implementations.

Since:
SAX 1.0
See Also:
AttributeList, DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)

Constructor Summary
Constructor and Description
AttributeListImpl()
Deprecated. Create an empty attribute list.
AttributeListImpl(AttributeList atts)
Deprecated. Construct a persistent copy of an existing attribute list.
Method Summary
Modifier and Type | Method and Description
void | addAttribute(String name, String type, String value) Deprecated. Add an attribute to an attribute list.
void | clear() Deprecated. Clear the attribute list.
int | getLength() Deprecated. Return the number of attributes in the list.
String | getName(int i) Deprecated. Get the name of an attribute (by position).
String | getType(int i) Deprecated. Get the type of an attribute (by position).
String | getType(String name) Deprecated. Get the type of an attribute (by name).
String | getValue(int i) Deprecated. Get the value of an attribute (by position).
String | getValue(String name) Deprecated. Get the value of an attribute (by name).
void | removeAttribute(String name) Deprecated. Remove an attribute from the list.
void | setAttributeList(AttributeList atts) Deprecated. Set the attribute list, discarding previous contents.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AttributeListImpl

public AttributeListImpl()
Deprecated.
Create an empty attribute list.

This constructor is most useful for parser writers, who will use it to create a single, reusable attribute list that can be reset with the clear method between elements.

See Also:
addAttribute(java.lang.String, java.lang.String, java.lang.String), clear()

AttributeListImpl

public AttributeListImpl(AttributeList atts)
Deprecated.
Construct a persistent copy of an existing attribute list.

This constructor is most useful for application writers, who will use it to create a persistent copy of an existing attribute list.

Parameters:
atts - The attribute list to copy
See Also:
DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)
Method Detail

setAttributeList

public void setAttributeList(AttributeList atts)
Deprecated.
Set the attribute list, discarding previous contents.

This method allows an application writer to reuse an attribute list easily.

Parameters:
atts - The attribute list to copy.

addAttribute

public void addAttribute(String name,
                         String type,
                         String value)
Deprecated.
Add an attribute to an attribute list.

This method is provided for SAX parser writers, to allow them to build up an attribute list incrementally before delivering it to the application.

Parameters:
name - The attribute name.
type - The attribute type ("NMTOKEN" for an enumeration).
value - The attribute value (must not be null).
See Also:
removeAttribute(java.lang.String), DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)

removeAttribute

public void removeAttribute(String name)
Deprecated.
Remove an attribute from the list.

SAX application writers can use this method to filter an attribute out of an AttributeList. Note that invoking this method will change the length of the attribute list and some of the attribute's indices.

If the requested attribute is not in the list, this is a no-op.

Parameters:
name - The attribute name.
See Also:
addAttribute(java.lang.String, java.lang.String, java.lang.String)

clear

public void clear()
Deprecated.
Clear the attribute list.

SAX parser writers can use this method to reset the attribute list between DocumentHandler.startElement events. Normally, it will make sense to reuse the same AttributeListImpl object rather than allocating a new one each time.

See Also:
DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)

getLength

public int getLength()
Deprecated.
Return the number of attributes in the list.

Specified by:
getLength in interface AttributeList
Returns:
The number of attributes in the list.
See Also:
AttributeList.getLength()

getName

public String getName(int i)
Deprecated.
Get the name of an attribute (by position).

Specified by:
getName in interface AttributeList
Parameters:
i - The position of the attribute in the list.
Returns:
The attribute name as a string, or null if there is no attribute at that position.
See Also:
AttributeList.getName(int)

getType

public String getType(int i)
Deprecated.
Get the type of an attribute (by position).

Specified by:
getType in interface AttributeList
Parameters:
i - The position of the attribute in the list.
Returns:
The attribute type as a string ("NMTOKEN" for an enumeration, and "CDATA" if no declaration was read), or null if there is no attribute at that position.
See Also:
AttributeList.getType(int)

getValue

public String getValue(int i)
Deprecated.
Get the value of an attribute (by position).

Specified by:
getValue in interface AttributeList
Parameters:
i - The position of the attribute in the list.
Returns:
The attribute value as a string, or null if there is no attribute at that position.
See Also:
AttributeList.getValue(int)

getType

public String getType(String name)
Deprecated.
Get the type of an attribute (by name).

Specified by:
getType in interface AttributeList
Parameters:
name - The attribute name.
Returns:
The attribute type as a string ("NMTOKEN" for an enumeration, and "CDATA" if no declaration was read).
See Also:
AttributeList.getType(java.lang.String)

getValue

public String getValue(String name)
Deprecated.
Get the value of an attribute (by name).

Specified by:
getValue in interface AttributeList
Parameters:
name - The attribute name.
Returns:
The attribute value as a string, or null if no such attribute exists.
See Also:
AttributeList.getValue(java.lang.String)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AttributesImpl (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax.helpers
Class AttributesImpl

java.lang.Object
    extended by  org.xml.sax.helpers.AttributesImpl
All Implemented Interfaces:
Attributes
Direct Known Subclasses:
Attributes2Impl
public class AttributesImpl
extends Object
implements Attributes

Default implementation of the Attributes interface.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

This class provides a default implementation of the SAX2 Attributes interface, with the addition of manipulators so that the list can be modified or reused.

There are two typical uses of this class:

  1. to take a persistent snapshot of an Attributes object in a startElement event; or
  2. to construct or modify an Attributes object in a SAX2 driver or filter.

This class replaces the now-deprecated SAX1 AttributeListImpl class; in addition to supporting the updated Attributes interface rather than the deprecated AttributeList interface, it also includes a much more efficient implementation using a single array rather than a set of Vectors.

Since:
SAX 2.0

Constructor Summary
Constructor and Description
AttributesImpl()
Construct a new, empty AttributesImpl object.
AttributesImpl(Attributes atts)
Copy an existing Attributes object.
Method Summary
Modifier and Type | Method and Description
void | addAttribute(String uri, String localName, String qName, String type, String value) Add an attribute to the end of the list.
void | clear() Clear the attribute list for reuse.
int | getIndex(String qName) Look up an attribute's index by qualified (prefixed) name.
int | getIndex(String uri, String localName) Look up an attribute's index by Namespace name.
int | getLength() Return the number of attributes in the list.
String | getLocalName(int index) Return an attribute's local name.
String | getQName(int index) Return an attribute's qualified (prefixed) name.
String | getType(int index) Return an attribute's type by index.
String | getType(String qName) Look up an attribute's type by qualified (prefixed) name.
String | getType(String uri, String localName) Look up an attribute's type by Namespace-qualified name.
String | getURI(int index) Return an attribute's Namespace URI.
String | getValue(int index) Return an attribute's value by index.
String | getValue(String qName) Look up an attribute's value by qualified (prefixed) name.
String | getValue(String uri, String localName) Look up an attribute's value by Namespace-qualified name.
void | removeAttribute(int index) Remove an attribute from the list.
void | setAttribute(int index, String uri, String localName, String qName, String type, String value) Set an attribute in the list.
void | setAttributes(Attributes atts) Copy an entire Attributes object.
void | setLocalName(int index, String localName) Set the local name of a specific attribute.
void | setQName(int index, String qName) Set the qualified name of a specific attribute.
void | setType(int index, String type) Set the type of a specific attribute.
void | setURI(int index, String uri) Set the Namespace URI of a specific attribute.
void | setValue(int index, String value) Set the value of a specific attribute.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AttributesImpl

public AttributesImpl()
Construct a new, empty AttributesImpl object.

AttributesImpl

public AttributesImpl(Attributes atts)
Copy an existing Attributes object.

This constructor is especially useful inside a startElement event.

Parameters:
atts - The existing Attributes object.
Method Detail

getLength

public int getLength()
Return the number of attributes in the list.

Specified by:
getLength in interface Attributes
Returns:
The number of attributes in the list.
See Also:
Attributes.getLength()

getURI

public String getURI(int index)
Return an attribute's Namespace URI.

Specified by:
getURI in interface Attributes
Parameters:
index - The attribute's index (zero-based).
Returns:
The Namespace URI, the empty string if none is available, or null if the index is out of range.
See Also:
Attributes.getURI(int)

getLocalName

public String getLocalName(int index)
Return an attribute's local name.

Specified by:
getLocalName in interface Attributes
Parameters:
index - The attribute's index (zero-based).
Returns:
The attribute's local name, the empty string if none is available, or null if the index if out of range.
See Also:
Attributes.getLocalName(int)

getQName

public String getQName(int index)
Return an attribute's qualified (prefixed) name.

Specified by:
getQName in interface Attributes
Parameters:
index - The attribute's index (zero-based).
Returns:
The attribute's qualified name, the empty string if none is available, or null if the index is out of bounds.
See Also:
Attributes.getQName(int)

getType

public String getType(int index)
Return an attribute's type by index.

Specified by:
getType in interface Attributes
Parameters:
index - The attribute's index (zero-based).
Returns:
The attribute's type, "CDATA" if the type is unknown, or null if the index is out of bounds.
See Also:
Attributes.getType(int)

getValue

public String getValue(int index)
Return an attribute's value by index.

Specified by:
getValue in interface Attributes
Parameters:
index - The attribute's index (zero-based).
Returns:
The attribute's value or null if the index is out of bounds.
See Also:
Attributes.getValue(int)

getIndex

public int getIndex(String uri,
                    String localName)
Look up an attribute's index by Namespace name.

In many cases, it will be more efficient to look up the name once and use the index query methods rather than using the name query methods repeatedly.

Specified by:
getIndex in interface Attributes
Parameters:
uri - The attribute's Namespace URI, or the empty string if none is available.
localName - The attribute's local name.
Returns:
The attribute's index, or -1 if none matches.
See Also:
Attributes.getIndex(java.lang.String,java.lang.String)

getIndex

public int getIndex(String qName)
Look up an attribute's index by qualified (prefixed) name.

Specified by:
getIndex in interface Attributes
Parameters:
qName - The qualified name.
Returns:
The attribute's index, or -1 if none matches.
See Also:
Attributes.getIndex(java.lang.String)

getType

public String getType(String uri,
                      String localName)
Look up an attribute's type by Namespace-qualified name.

Specified by:
getType in interface Attributes
Parameters:
uri - The Namespace URI, or the empty string for a name with no explicit Namespace URI.
localName - The local name.
Returns:
The attribute's type, or null if there is no matching attribute.
See Also:
Attributes.getType(java.lang.String,java.lang.String)

getType

public String getType(String qName)
Look up an attribute's type by qualified (prefixed) name.

Specified by:
getType in interface Attributes
Parameters:
qName - The qualified name.
Returns:
The attribute's type, or null if there is no matching attribute.
See Also:
Attributes.getType(java.lang.String)

getValue

public String getValue(String uri,
                       String localName)
Look up an attribute's value by Namespace-qualified name.

Specified by:
getValue in interface Attributes
Parameters:
uri - The Namespace URI, or the empty string for a name with no explicit Namespace URI.
localName - The local name.
Returns:
The attribute's value, or null if there is no matching attribute.
See Also:
Attributes.getValue(java.lang.String,java.lang.String)

getValue

public String getValue(String qName)
Look up an attribute's value by qualified (prefixed) name.

Specified by:
getValue in interface Attributes
Parameters:
qName - The qualified name.
Returns:
The attribute's value, or null if there is no matching attribute.
See Also:
Attributes.getValue(java.lang.String)

clear

public void clear()
Clear the attribute list for reuse.

Note that little memory is freed by this call: the current array is kept so it can be reused.

setAttributes

public void setAttributes(Attributes atts)
Copy an entire Attributes object.

It may be more efficient to reuse an existing object rather than constantly allocating new ones.

Parameters:
atts - The attributes to copy.

addAttribute

public void addAttribute(String uri,
                         String localName,
                         String qName,
                         String type,
                         String value)
Add an attribute to the end of the list.

For the sake of speed, this method does no checking to see if the attribute is already in the list: that is the responsibility of the application.

Parameters:
uri - The Namespace URI, or the empty string if none is available or Namespace processing is not being performed.
localName - The local name, or the empty string if Namespace processing is not being performed.
qName - The qualified (prefixed) name, or the empty string if qualified names are not available.
type - The attribute type as a string.
value - The attribute value.

setAttribute

public void setAttribute(int index,
                         String uri,
                         String localName,
                         String qName,
                         String type,
                         String value)
Set an attribute in the list.

For the sake of speed, this method does no checking for name conflicts or well-formedness: such checks are the responsibility of the application.

Parameters:
index - The index of the attribute (zero-based).
uri - The Namespace URI, or the empty string if none is available or Namespace processing is not being performed.
localName - The local name, or the empty string if Namespace processing is not being performed.
qName - The qualified name, or the empty string if qualified names are not available.
type - The attribute type as a string.
value - The attribute value.
Throws:
ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

removeAttribute

public void removeAttribute(int index)
Remove an attribute from the list.

Parameters:
index - The index of the attribute (zero-based).
Throws:
ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

setURI

public void setURI(int index,
                   String uri)
Set the Namespace URI of a specific attribute.

Parameters:
index - The index of the attribute (zero-based).
uri - The attribute's Namespace URI, or the empty string for none.
Throws:
ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

setLocalName

public void setLocalName(int index,
                         String localName)
Set the local name of a specific attribute.

Parameters:
index - The index of the attribute (zero-based).
localName - The attribute's local name, or the empty string for none.
Throws:
ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

setQName

public void setQName(int index,
                     String qName)
Set the qualified name of a specific attribute.

Parameters:
index - The index of the attribute (zero-based).
qName - The attribute's qualified name, or the empty string for none.
Throws:
ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

setType

public void setType(int index,
                    String type)
Set the type of a specific attribute.

Parameters:
index - The index of the attribute (zero-based).
type - The attribute's type.
Throws:
ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

setValue

public void setValue(int index,
                     String value)
Set the value of a specific attribute.

Parameters:
index - The index of the attribute (zero-based).
value - The attribute's value.
Throws:
ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


DefaultHandler (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax.helpers
Class DefaultHandler

java.lang.Object
    extended by  org.xml.sax.helpers.DefaultHandler
All Implemented Interfaces:
ContentHandler, DTDHandler, EntityResolver, ErrorHandler
Direct Known Subclasses:
DefaultHandler2
public class DefaultHandler
extends Object
implements EntityResolver, DTDHandler, ContentHandler, ErrorHandler

Default base class for SAX2 event handlers.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

This class is available as a convenience base class for SAX2 applications: it provides default implementations for all of the callbacks in the four core SAX2 handler classes:

  • EntityResolver
  • DTDHandler
  • ContentHandler
  • ErrorHandler

Application writers can extend this class when they need to implement only part of an interface; parser writers can instantiate this class to provide default handlers when the application has not supplied its own.

This class replaces the deprecated SAX1 HandlerBase class.

Since:
SAX 2.0
See Also:
EntityResolver, DTDHandler, ContentHandler, ErrorHandler

Constructor Summary
Constructor and Description
DefaultHandler()
Method Summary
Modifier and Type | Method and Description
void | characters(char[] ch, int start, int length) Receive notification of character data inside an element.
void | endDocument() Receive notification of the end of the document.
void | endElement(String uri, String localName, String qName) Receive notification of the end of an element.
void | endPrefixMapping(String prefix) Receive notification of the end of a Namespace mapping.
void | error(SAXParseException e) Receive notification of a recoverable parser error.
void | fatalError(SAXParseException e) Report a fatal XML parsing error.
void | ignorableWhitespace(char[] ch, int start, int length) Receive notification of ignorable whitespace in element content.
void | notationDecl(String name, String publicId, String systemId) Receive notification of a notation declaration.
void | processingInstruction(String target, String data) Receive notification of a processing instruction.
InputSource | resolveEntity(String publicId, String systemId) Resolve an external entity.
void | setDocumentLocator(Locator locator) Receive a Locator object for document events.
void | skippedEntity(String name) Receive notification of a skipped entity.
void | startDocument() Receive notification of the beginning of the document.
void | startElement(String uri, String localName, String qName, Attributes attributes) Receive notification of the start of an element.
void | startPrefixMapping(String prefix, String uri) Receive notification of the start of a Namespace mapping.
void | unparsedEntityDecl(String name, String publicId, String systemId, String notationName) Receive notification of an unparsed entity declaration.
void | warning(SAXParseException e) Receive notification of a parser warning.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultHandler

public DefaultHandler()
Method Detail

resolveEntity

public InputSource resolveEntity(String publicId,
                                 String systemId)
                          throws IOException,
                                 SAXException
Resolve an external entity.

Always return null, so that the parser will use the system identifier provided in the XML document. This method implements the SAX default behaviour: application writers can override it in a subclass to do special translations such as catalog lookups or URI redirection.

Specified by:
resolveEntity in interface EntityResolver
Parameters:
publicId - The public identifier, or null if none is available.
systemId - The system identifier provided in the XML document.
Returns:
The new input source, or null to require the default behaviour.
Throws:
IOException - If there is an error setting up the new input source.
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
EntityResolver.resolveEntity(java.lang.String, java.lang.String)

notationDecl

public void notationDecl(String name,
                         String publicId,
                         String systemId)
                  throws SAXException
Receive notification of a notation declaration.

By default, do nothing. Application writers may override this method in a subclass if they wish to keep track of the notations declared in a document.

Specified by:
notationDecl in interface DTDHandler
Parameters:
name - The notation name.
publicId - The notation public identifier, or null if not available.
systemId - The notation system identifier.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
DTDHandler.notationDecl(java.lang.String, java.lang.String, java.lang.String)

unparsedEntityDecl

public void unparsedEntityDecl(String name,
                               String publicId,
                               String systemId,
                               String notationName)
                        throws SAXException
Receive notification of an unparsed entity declaration.

By default, do nothing. Application writers may override this method in a subclass to keep track of the unparsed entities declared in a document.

Specified by:
unparsedEntityDecl in interface DTDHandler
Parameters:
name - The entity name.
publicId - The entity public identifier, or null if not available.
systemId - The entity system identifier.
notationName - The name of the associated notation.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

setDocumentLocator

public void setDocumentLocator(Locator locator)
Receive a Locator object for document events.

By default, do nothing. Application writers may override this method in a subclass if they wish to store the locator for use with other document events.

Specified by:
setDocumentLocator in interface ContentHandler
Parameters:
locator - A locator for all SAX document events.
See Also:
ContentHandler.setDocumentLocator(org.xml.sax.Locator), Locator

startDocument

public void startDocument()
                   throws SAXException
Receive notification of the beginning of the document.

By default, do nothing. Application writers may override this method in a subclass to take specific actions at the beginning of a document (such as allocating the root node of a tree or creating an output file).

Specified by:
startDocument in interface ContentHandler
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
ContentHandler.startDocument()

endDocument

public void endDocument()
                 throws SAXException
Receive notification of the end of the document.

By default, do nothing. Application writers may override this method in a subclass to take specific actions at the end of a document (such as finalising a tree or closing an output file).

Specified by:
endDocument in interface ContentHandler
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
ContentHandler.endDocument()

startPrefixMapping

public void startPrefixMapping(String prefix,
                               String uri)
                        throws SAXException
Receive notification of the start of a Namespace mapping.

By default, do nothing. Application writers may override this method in a subclass to take specific actions at the start of each Namespace prefix scope (such as storing the prefix mapping).

Specified by:
startPrefixMapping in interface ContentHandler
Parameters:
prefix - The Namespace prefix being declared.
uri - The Namespace URI mapped to the prefix.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
ContentHandler.startPrefixMapping(java.lang.String, java.lang.String)

endPrefixMapping

public void endPrefixMapping(String prefix)
                      throws SAXException
Receive notification of the end of a Namespace mapping.

By default, do nothing. Application writers may override this method in a subclass to take specific actions at the end of each prefix mapping.

Specified by:
endPrefixMapping in interface ContentHandler
Parameters:
prefix - The Namespace prefix being declared.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
ContentHandler.endPrefixMapping(java.lang.String)

startElement

public void startElement(String uri,
                         String localName,
                         String qName,
                         Attributes attributes)
                  throws SAXException
Receive notification of the start of an element.

By default, do nothing. Application writers may override this method in a subclass to take specific actions at the start of each element (such as allocating a new tree node or writing output to a file).

Specified by:
startElement in interface ContentHandler
Parameters:
uri - The Namespace URI, or the empty string if the element has no Namespace URI or if Namespace processing is not being performed.
localName - The local name (without prefix), or the empty string if Namespace processing is not being performed.
qName - The qualified name (with prefix), or the empty string if qualified names are not available.
attributes - The attributes attached to the element. If there are no attributes, it shall be an empty Attributes object.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
ContentHandler.startElement(java.lang.String, java.lang.String, java.lang.String, org.xml.sax.Attributes)

endElement

public void endElement(String uri,
                       String localName,
                       String qName)
                throws SAXException
Receive notification of the end of an element.

By default, do nothing. Application writers may override this method in a subclass to take specific actions at the end of each element (such as finalising a tree node or writing output to a file).

Specified by:
endElement in interface ContentHandler
Parameters:
uri - The Namespace URI, or the empty string if the element has no Namespace URI or if Namespace processing is not being performed.
localName - The local name (without prefix), or the empty string if Namespace processing is not being performed.
qName - The qualified name (with prefix), or the empty string if qualified names are not available.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
ContentHandler.endElement(java.lang.String, java.lang.String, java.lang.String)

characters

public void characters(char[] ch,
                       int start,
                       int length)
                throws SAXException
Receive notification of character data inside an element.

By default, do nothing. Application writers may override this method to take specific actions for each chunk of character data (such as adding the data to a node or buffer, or printing it to a file).

Specified by:
characters in interface ContentHandler
Parameters:
ch - The characters.
start - The start position in the character array.
length - The number of characters to use from the character array.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
ContentHandler.characters(char[], int, int)

ignorableWhitespace

public void ignorableWhitespace(char[] ch,
                                int start,
                                int length)
                         throws SAXException
Receive notification of ignorable whitespace in element content.

By default, do nothing. Application writers may override this method to take specific actions for each chunk of ignorable whitespace (such as adding data to a node or buffer, or printing it to a file).

Specified by:
ignorableWhitespace in interface ContentHandler
Parameters:
ch - The whitespace characters.
start - The start position in the character array.
length - The number of characters to use from the character array.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
ContentHandler.ignorableWhitespace(char[], int, int)

processingInstruction

public void processingInstruction(String target,
                                  String data)
                           throws SAXException
Receive notification of a processing instruction.

By default, do nothing. Application writers may override this method in a subclass to take specific actions for each processing instruction, such as setting status variables or invoking other methods.

Specified by:
processingInstruction in interface ContentHandler
Parameters:
target - The processing instruction target.
data - The processing instruction data, or null if none is supplied.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
ContentHandler.processingInstruction(java.lang.String, java.lang.String)

skippedEntity

public void skippedEntity(String name)
                   throws SAXException
Receive notification of a skipped entity.

By default, do nothing. Application writers may override this method in a subclass to take specific actions for each processing instruction, such as setting status variables or invoking other methods.

Specified by:
skippedEntity in interface ContentHandler
Parameters:
name - The name of the skipped entity.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
ContentHandler.processingInstruction(java.lang.String, java.lang.String)

warning

public void warning(SAXParseException e)
             throws SAXException
Receive notification of a parser warning.

The default implementation does nothing. Application writers may override this method in a subclass to take specific actions for each warning, such as inserting the message in a log file or printing it to the console.

Specified by:
warning in interface ErrorHandler
Parameters:
e - The warning information encoded as an exception.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
ErrorHandler.warning(org.xml.sax.SAXParseException), SAXParseException

error

public void error(SAXParseException e)
           throws SAXException
Receive notification of a recoverable parser error.

The default implementation does nothing. Application writers may override this method in a subclass to take specific actions for each error, such as inserting the message in a log file or printing it to the console.

Specified by:
error in interface ErrorHandler
Parameters:
e - The error information encoded as an exception.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
ErrorHandler.warning(org.xml.sax.SAXParseException), SAXParseException

fatalError

public void fatalError(SAXParseException e)
                throws SAXException
Report a fatal XML parsing error.

The default implementation throws a SAXParseException. Application writers may override this method in a subclass if they need to take specific actions for each fatal error (such as collecting all of the errors into a single report): in any case, the application must stop all regular processing when this method is invoked, since the document is no longer reliable, and the parser may no longer report parsing events.

Specified by:
fatalError in interface ErrorHandler
Parameters:
e - The error information encoded as an exception.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
ErrorHandler.fatalError(org.xml.sax.SAXParseException), SAXParseException
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


LocatorImpl (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax.helpers
Class LocatorImpl

java.lang.Object
    extended by  org.xml.sax.helpers.LocatorImpl
All Implemented Interfaces:
Locator
Direct Known Subclasses:
Locator2Impl
public class LocatorImpl
extends Object
implements Locator

Provide an optional convenience implementation of Locator.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

This class is available mainly for application writers, who can use it to make a persistent snapshot of a locator at any point during a document parse:

 Locator locator;
 Locator startloc;

 public void setLocator (Locator locator)
 {
         // note the locator
   this.locator = locator;
 }

 public void startDocument ()
 {
         // save the location of the start of the document
         // for future use.
   Locator startloc = new LocatorImpl(locator);
 }

Normally, parser writers will not use this class, since it is more efficient to provide location information only when requested, rather than constantly updating a Locator object.

Since:
SAX 1.0
See Also:
Locator

Constructor Summary
Constructor and Description
LocatorImpl()
Zero-argument constructor.
LocatorImpl(Locator locator)
Copy constructor.
Method Summary
Modifier and Type | Method and Description
int | getColumnNumber() Return the saved column number (1-based).
int | getLineNumber() Return the saved line number (1-based).
String | getPublicId() Return the saved public identifier.
String | getSystemId() Return the saved system identifier.
void | setColumnNumber(int columnNumber) Set the column number for this locator (1-based).
void | setLineNumber(int lineNumber) Set the line number for this locator (1-based).
void | setPublicId(String publicId) Set the public identifier for this locator.
void | setSystemId(String systemId) Set the system identifier for this locator.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LocatorImpl

public LocatorImpl()
Zero-argument constructor.

This will not normally be useful, since the main purpose of this class is to make a snapshot of an existing Locator.

LocatorImpl

public LocatorImpl(Locator locator)
Copy constructor.

Create a persistent copy of the current state of a locator. When the original locator changes, this copy will still keep the original values (and it can be used outside the scope of DocumentHandler methods).

Parameters:
locator - The locator to copy.
Method Detail

getPublicId

public String getPublicId()
Return the saved public identifier.

Specified by:
getPublicId in interface Locator
Returns:
The public identifier as a string, or null if none is available.
See Also:
Locator.getPublicId(), setPublicId(java.lang.String)

getSystemId

public String getSystemId()
Return the saved system identifier.

Specified by:
getSystemId in interface Locator
Returns:
The system identifier as a string, or null if none is available.
See Also:
Locator.getSystemId(), setSystemId(java.lang.String)

getLineNumber

public int getLineNumber()
Return the saved line number (1-based).

Specified by:
getLineNumber in interface Locator
Returns:
The line number as an integer, or -1 if none is available.
See Also:
Locator.getLineNumber(), setLineNumber(int)

getColumnNumber

public int getColumnNumber()
Return the saved column number (1-based).

Specified by:
getColumnNumber in interface Locator
Returns:
The column number as an integer, or -1 if none is available.
See Also:
Locator.getColumnNumber(), setColumnNumber(int)

setPublicId

public void setPublicId(String publicId)
Set the public identifier for this locator.

Parameters:
publicId - The new public identifier, or null if none is available.
See Also:
getPublicId()

setSystemId

public void setSystemId(String systemId)
Set the system identifier for this locator.

Parameters:
systemId - The new system identifier, or null if none is available.
See Also:
getSystemId()

setLineNumber

public void setLineNumber(int lineNumber)
Set the line number for this locator (1-based).

Parameters:
lineNumber - The line number, or -1 if none is available.
See Also:
getLineNumber()

setColumnNumber

public void setColumnNumber(int columnNumber)
Set the column number for this locator (1-based).

Parameters:
columnNumber - The column number, or -1 if none is available.
See Also:
getColumnNumber()
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


NamespaceSupport (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax.helpers
Class NamespaceSupport

java.lang.Object
    extended by  org.xml.sax.helpers.NamespaceSupport

public class NamespaceSupport
extends Object

Encapsulate Namespace logic for use by applications using SAX, or internally by SAX drivers.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

This class encapsulates the logic of Namespace processing: it tracks the declarations currently in force for each context and automatically processes qualified XML names into their Namespace parts; it can also be used in reverse for generating XML qnames from Namespaces.

Namespace support objects are reusable, but the reset method must be invoked between each session.

Here is a simple session:

 String parts[] = new String[3];
 NamespaceSupport support = new NamespaceSupport();

 support.pushContext();
 support.declarePrefix("", "http://www.w3.org/1999/xhtml");
 support.declarePrefix("dc", "http://www.purl.org/dc#");

 parts = support.processName("p", parts, false);
 System.out.println("Namespace URI: " + parts[0]);
 System.out.println("Local name: " + parts[1]);
 System.out.println("Raw name: " + parts[2]);

 parts = support.processName("dc:title", parts, false);
 System.out.println("Namespace URI: " + parts[0]);
 System.out.println("Local name: " + parts[1]);
 System.out.println("Raw name: " + parts[2]);

 support.popContext();

Note that this class is optimized for the use case where most elements do not contain Namespace declarations: if the same prefix/URI mapping is repeated for each context (for example), this class will be somewhat less efficient.

Although SAX drivers (parsers) may choose to use this class to implement namespace handling, they are not required to do so. Applications must track namespace information themselves if they want to use namespace information.

Since:
SAX 2.0

Field Summary
Modifier and Type | Field and Description
static String | NSDECL The namespace declaration URI as a constant.
static String | XMLNS The XML Namespace URI as a constant.
Constructor Summary
Constructor and Description
NamespaceSupport()
Create a new Namespace support object.
Method Summary
Modifier and Type Method and Description
 boolean declarePrefix(String prefix, String uri)
Declare a Namespace prefix.
 Enumeration getDeclaredPrefixes()
Return an enumeration of all prefixes declared in this context.
 String getPrefix(String uri)
Return one of the prefixes mapped to a Namespace URI.
 Enumeration getPrefixes()
Return an enumeration of all prefixes whose declarations are active in the current context.
 Enumeration getPrefixes(String uri)
Return an enumeration of all prefixes for a given URI whose declarations are active in the current context.
 String getURI(String prefix)
Look up a prefix and get the currently-mapped Namespace URI.
 boolean isNamespaceDeclUris()
Returns true if namespace declaration attributes are placed into a namespace.
 void popContext()
Revert to the previous Namespace context.
 String[] processName(String qName, String[] parts, boolean isAttribute)
Process a raw XML qualified name, after all declarations in the current context have been handled by declarePrefix().
 void pushContext()
Start a new Namespace context.
 void reset()
Reset this Namespace support object for reuse.
 void setNamespaceDeclUris(boolean value)
Controls whether namespace declaration attributes are placed into the NSDECL namespace by processName().
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

XMLNS

public static final String XMLNS
The XML Namespace URI as a constant. The value is http://www.w3.org/XML/1998/namespace as defined in the "Namespaces in XML" * recommendation.

This is the Namespace URI that is automatically mapped to the "xml" prefix.

See Also:
Constant Field Values

NSDECL

public static final String NSDECL
The namespace declaration URI as a constant. The value is http://www.w3.org/xmlns/2000/, as defined in a backwards-incompatible erratum to the "Namespaces in XML" recommendation. Because that erratum postdated SAX2, SAX2 defaults to the original recommendation, and does not normally use this URI.

This is the Namespace URI that is optionally applied to xmlns and xmlns:* attributes, which are used to declare namespaces.

Since:
SAX 2.1alpha
See Also:
setNamespaceDeclUris(boolean), isNamespaceDeclUris(), Constant Field Values
Constructor Detail

NamespaceSupport

public NamespaceSupport()
Create a new Namespace support object.

Method Detail

reset

public void reset()
Reset this Namespace support object for reuse.

It is necessary to invoke this method before reusing the Namespace support object for a new session. If namespace declaration URIs are to be supported, that flag must also be set to a non-default value.

See Also:
setNamespaceDeclUris(boolean)

pushContext

public void pushContext()
Start a new Namespace context. The new context will automatically inherit the declarations of its parent context, but it will also keep track of which declarations were made within this context.

Event callback code should start a new context once per element. This means being ready to call this in either of two places. For elements that don't include namespace declarations, the ContentHandler.startElement() callback is the right place. For elements with such a declaration, it'd done in the first ContentHandler.startPrefixMapping() callback. A boolean flag can be used to track whether a context has been started yet. When either of those methods is called, it checks the flag to see if a new context needs to be started. If so, it starts the context and sets the flag. After ContentHandler.startElement() does that, it always clears the flag.

Normally, SAX drivers would push a new context at the beginning of each XML element. Then they perform a first pass over the attributes to process all namespace declarations, making ContentHandler.startPrefixMapping() callbacks. Then a second pass is made, to determine the namespace-qualified names for all attributes and for the element name. Finally all the information for the ContentHandler.startElement() callback is available, so it can then be made.

The Namespace support object always starts with a base context already in force: in this context, only the "xml" prefix is declared.

See Also:
ContentHandler, popContext()

popContext

public void popContext()
Revert to the previous Namespace context.

Normally, you should pop the context at the end of each XML element. After popping the context, all Namespace prefix mappings that were previously in force are restored.

You must not attempt to declare additional Namespace prefixes after popping a context, unless you push another context first.

See Also:
pushContext()

declarePrefix

public boolean declarePrefix(String prefix,
                             String uri)
Declare a Namespace prefix. All prefixes must be declared before they are referenced. For example, a SAX driver (parser) would scan an element's attributes in two passes: first for namespace declarations, then a second pass using processName() to interpret prefixes against (potentially redefined) prefixes.

This method declares a prefix in the current Namespace context; the prefix will remain in force until this context is popped, unless it is shadowed in a descendant context.

To declare the default element Namespace, use the empty string as the prefix.

Note that there is an asymmetry in this library: getPrefix will not return the "" prefix, even if you have declared a default element namespace. To check for a default namespace, you have to look it up explicitly using getURI. This asymmetry exists to make it easier to look up prefixes for attribute names, where the default prefix is not allowed.

Parameters:
prefix - The prefix to declare, or the empty string to indicate the default element namespace. This may never have the value "xml" or "xmlns".
uri - The Namespace URI to associate with the prefix.
Returns:
true if the prefix was legal, false otherwise
See Also:
processName(java.lang.String, java.lang.String[], boolean),
getURI(java.lang.String),
getPrefix(java.lang.String)

processName

public String[] processName(String qName,
                            String[] parts,
                            boolean isAttribute)
Process a raw XML qualified name, after all declarations in the current context have been handled by declarePrefix().

This method processes a raw XML qualified name in the current context by removing the prefix and looking it up among the prefixes currently declared. The return value will be the array supplied by the caller, filled in as follows:

parts[0]
The Namespace URI, or an empty string if none is in use.
parts[1]
The local name (without prefix).
parts[2]
The original raw name.

All of the strings in the array will be internalized. If the raw name has a prefix that has not been declared, then the return value will be null.

Note that attribute names are processed differently than element names: an unprefixed element name will receive the default Namespace (if any), while an unprefixed attribute name will not.

Parameters:
qName - The XML qualified name to be processed.
parts - An array supplied by the caller, capable of holding at least three members.
isAttribute - A flag indicating whether this is an attribute name (true) or an element name (false).
Returns:
The supplied array holding three internalized strings representing the Namespace URI (or empty string), the local name, and the XML qualified name; or null if there is an undeclared prefix.
See Also:
declarePrefix(java.lang.String, java.lang.String), String.intern()

getURI

public String getURI(String prefix)
Look up a prefix and get the currently-mapped Namespace URI.

This method looks up the prefix in the current context. Use the empty string ("") for the default Namespace.

Parameters:
prefix - The prefix to look up.
Returns:
The associated Namespace URI, or null if the prefix is undeclared in this context.
See Also:
getPrefix(java.lang.String), getPrefixes()

getPrefixes

public Enumeration getPrefixes()
Return an enumeration of all prefixes whose declarations are active in the current context. This includes declarations from parent contexts that have not been overridden.

Note: if there is a default prefix, it will not be returned in this enumeration; check for the default prefix using the getURI with an argument of "".

Returns:
An enumeration of prefixes (never empty).
See Also:
getDeclaredPrefixes(), getURI(java.lang.String)

getPrefix

public String getPrefix(String uri)
Return one of the prefixes mapped to a Namespace URI.

If more than one prefix is currently mapped to the same URI, this method will make an arbitrary selection; if you want all of the prefixes, use the getPrefixes() method instead.

Note: this will never return the empty (default) prefix; to check for a default prefix, use the getURI method with an argument of "".

Parameters:
uri - the namespace URI
Returns:
one of the prefixes currently mapped to the URI supplied, or null if none is mapped or if the URI is assigned to the default namespace
See Also:
getPrefixes(java.lang.String), getURI(java.lang.String)

getPrefixes

public Enumeration getPrefixes(String uri)
Return an enumeration of all prefixes for a given URI whose declarations are active in the current context. This includes declarations from parent contexts that have not been overridden.

This method returns prefixes mapped to a specific Namespace URI. The xml: prefix will be included. If you want only one prefix that's mapped to the Namespace URI, and you don't care which one you get, use the getPrefix method instead.

Note: the empty (default) prefix is never included in this enumeration; to check for the presence of a default Namespace, use the getURI method with an argument of "".

Parameters:
uri - The Namespace URI.
Returns:
An enumeration of prefixes (never empty).
See Also:
getPrefix(java.lang.String),
getDeclaredPrefixes(),
getURI(java.lang.String)

getDeclaredPrefixes

public Enumeration getDeclaredPrefixes()
Return an enumeration of all prefixes declared in this context.

The empty (default) prefix will be included in this enumeration; note that this behaviour differs from that of getPrefix(java.lang.String) and getPrefixes().

Returns:
An enumeration of all prefixes declared in this context.
See Also:
getPrefixes(), getURI(java.lang.String)

setNamespaceDeclUris

public void setNamespaceDeclUris(boolean value)
Controls whether namespace declaration attributes are placed into the NSDECL namespace by processName(). This may only be changed before any contexts have been pushed.

Throws:
IllegalStateException - when attempting to set this after any context has been pushed.
Since:
SAX 2.1alpha

isNamespaceDeclUris

public boolean isNamespaceDeclUris()
Returns true if namespace declaration attributes are placed into a namespace. This behavior is not the default.

Since:
SAX 2.1alpha
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


org.xml.sax.helpers (Java Platform SE 7 b59)

DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.xml.sax.helpers

This package contains "helper" classes, including support for bootstrapping SAX-based applications.

See:
Description

Class Summary
Class | Description
AttributeListImpl | Deprecated. This class implements a deprecated interface, AttributeList; that interface has been replaced by Attributes, which is implemented in the AttributesImpl helper class.
AttributesImpl | Default implementation of the Attributes interface.
DefaultHandler | Default base class for SAX2 event handlers.
LocatorImpl | Provide an optional convenience implementation of Locator.
NamespaceSupport | Encapsulate Namespace logic for use by applications using SAX, or internally by SAX drivers.
ParserAdapter | Adapt a SAX1 Parser as a SAX2 XMLReader.
ParserFactory | Deprecated. This class works with the deprecated Parser interface.
XMLFilterImpl | Base class for deriving an XML filter.
XMLReaderAdapter | Adapt a SAX2 XMLReader as a SAX1 Parser.
XMLReaderFactory | Factory for creating an XML reader.

Package org.xml.sax.helpers Description

This package contains "helper" classes, including support for bootstrapping SAX-based applications.

See http://www.saxproject.org for more information about SAX.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


ParserAdapter (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax.helpers
Class ParserAdapter

java.lang.Object
    extended by  org.xml.sax.helpers.ParserAdapter
All Implemented Interfaces:
DocumentHandler, XMLReader
public class ParserAdapter
extends Object
implements XMLReader, DocumentHandler

Adapt a SAX1 Parser as a SAX2 XMLReader.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

This class wraps a SAX1 Parser and makes it act as a SAX2 XMLReader, with feature, property, and Namespace support. Note that it is not possible to report skippedEntity events, since SAX1 does not make that information available.

This adapter does not test for duplicate Namespace-qualified attribute names.

Since:
SAX 2.0
See Also:
XMLReaderAdapter, XMLReader, Parser

Constructor Summary
Constructor and Description
ParserAdapter()
Construct a new parser adapter.
ParserAdapter(Parser parser)
Construct a new parser adapter.
Method Summary
Modifier and Type | Method and Description
void | characters(char[] ch, int start, int length) Adapter implementation method; do not call.
void | endDocument() Adapter implementation method; do not call.
void | endElement(String qName) Adapter implementation method; do not call.
ContentHandler | getContentHandler() Return the current content handler.
DTDHandler | getDTDHandler() Return the current DTD handler.
EntityResolver | getEntityResolver() Return the current entity resolver.
ErrorHandler | getErrorHandler() Return the current error handler.
boolean | getFeature(String name) Check a parser feature flag.
Object | getProperty(String name) Get a parser property.
void | ignorableWhitespace(char[] ch, int start, int length) Adapter implementation method; do not call.
void | parse(InputSource input) Parse an XML document.
void | parse(String systemId) Parse an XML document.
void | processingInstruction(String target, String data) Adapter implementation method; do not call.
void | setContentHandler(ContentHandler handler) Set the content handler.
void | setDocumentLocator(Locator locator) Adapter implementation method; do not call.
void | setDTDHandler(DTDHandler handler) Set the DTD handler.
void | setEntityResolver(EntityResolver resolver) Set the entity resolver.
void | setErrorHandler(ErrorHandler handler) Set the error handler.
void | setFeature(String name, boolean value) Set a feature flag for the parser.
void | setProperty(String name, Object value) Set a parser property.
void | startDocument() Adapter implementation method; do not call.
void | startElement(String qName, AttributeList qAtts) Adapter implementation method; do not call.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ParserAdapter

public ParserAdapter()
              throws SAXException
Construct a new parser adapter.

Use the "org.xml.sax.parser" property to locate the embedded SAX1 driver.

Throws:
SAXException - If the embedded driver cannot be instantiated or if the org.xml.sax.parser property is not specified.

ParserAdapter

public ParserAdapter(Parser parser)
Construct a new parser adapter.

Note that the embedded parser cannot be changed once the adapter is created; to embed a different parser, allocate a new ParserAdapter.

Parameters:
parser - The SAX1 parser to embed.
Throws:
NullPointerException - If the parser parameter is null.
Method Detail

setFeature

public void setFeature(String name,
                       boolean value)
                throws SAXNotRecognizedException,
                       SAXNotSupportedException
Set a feature flag for the parser.

The only features recognized are namespaces and namespace-prefixes.

Specified by:
setFeature in interface XMLReader
Parameters:
name - The feature name, as a complete URI.
value - The requested feature value.
Throws:
SAXNotRecognizedException - If the feature can't be assigned or retrieved.
SAXNotSupportedException - If the feature can't be assigned that value.
See Also:
XMLReader.setFeature(java.lang.String, boolean)

getFeature

public boolean getFeature(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
Check a parser feature flag.

The only features recognized are namespaces and namespace-prefixes.

Specified by:
getFeature in interface XMLReader
Parameters:
name - The feature name, as a complete URI.
Returns:
The current feature value.
Throws:
SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
SAXNotSupportedException - If the feature is not currently readable.
See Also:
XMLReader.setFeature(java.lang.String, boolean)

setProperty

public void setProperty(String name,
                        Object value)
                 throws SAXNotRecognizedException,
                        SAXNotSupportedException
Set a parser property.

No properties are currently recognized.

Specified by:
setProperty in interface XMLReader
Parameters:
name - The property name.
value - The property value.
Throws:
SAXNotRecognizedException - If the property value can't be assigned or retrieved.
SAXNotSupportedException - If the property can't be assigned that value.
See Also:
XMLReader.setProperty(java.lang.String, java.lang.Object)

getProperty

public Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
Get a parser property.

No properties are currently recognized.

Specified by:
getProperty in interface XMLReader
Parameters:
name - The property name.
Returns:
The property value.
Throws:
SAXNotRecognizedException - If the property value can't be assigned or retrieved.
SAXNotSupportedException - If the property value is not currently readable.
See Also:
XMLReader.getProperty(java.lang.String)

setEntityResolver

public void setEntityResolver(EntityResolver resolver)
Set the entity resolver.

Specified by:
setEntityResolver in interface XMLReader
Parameters:
resolver - The new entity resolver.
See Also:
XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

getEntityResolver

public EntityResolver getEntityResolver()
Return the current entity resolver.

Specified by:
getEntityResolver in interface XMLReader
Returns:
The current entity resolver, or null if none was supplied.
See Also:
XMLReader.getEntityResolver()

setDTDHandler

public void setDTDHandler(DTDHandler handler)
Set the DTD handler.

Specified by:
setDTDHandler in interface XMLReader
Parameters:
handler - the new DTD handler
See Also:
XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

getDTDHandler

public DTDHandler getDTDHandler()
Return the current DTD handler.

Specified by:
getDTDHandler in interface XMLReader
Returns:
the current DTD handler, or null if none was supplied
See Also:
XMLReader.getEntityResolver()

setContentHandler

public void setContentHandler(ContentHandler handler)
Set the content handler.

Specified by:
setContentHandler in interface XMLReader
Parameters:
handler - the new content handler
See Also:
XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

getContentHandler

public ContentHandler getContentHandler()
Return the current content handler.

Specified by:
getContentHandler in interface XMLReader
Returns:
The current content handler, or null if none was supplied.
See Also:
XMLReader.getEntityResolver()

setErrorHandler

public void setErrorHandler(ErrorHandler handler)
Set the error handler.

Specified by:
setErrorHandler in interface XMLReader
Parameters:
handler - The new error handler.
See Also:
XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

getErrorHandler

public ErrorHandler getErrorHandler()
Return the current error handler.

Specified by:
getErrorHandler in interface XMLReader
Returns:
The current error handler, or null if none was supplied.
See Also:
XMLReader.getEntityResolver()

parse

public void parse(String systemId)
           throws IOException,
                  SAXException
Parse an XML document.

Specified by:
parse in interface XMLReader
Parameters:
systemId - The absolute URL of the document.
Throws:
IOException - If there is a problem reading the raw content of the document.
SAXException - If there is a problem processing the document.
See Also:
parse(org.xml.sax.InputSource), Parser.parse(java.lang.String)

parse

public void parse(InputSource input)
           throws IOException,
                  SAXException
Parse an XML document.

Specified by:
parse in interface XMLReader
Parameters:
input - An input source for the document.
Throws:
IOException - If there is a problem reading the raw content of the document.
SAXException - If there is a problem processing the document.
See Also:
parse(java.lang.String), Parser.parse(org.xml.sax.InputSource)

setDocumentLocator

public void setDocumentLocator(Locator locator)
Adapter implementation method; do not call. Adapt a SAX1 document locator event.

Specified by:
setDocumentLocator in interface DocumentHandler
Parameters:
locator - A document locator.
See Also:
ContentHandler.setDocumentLocator(org.xml.sax.Locator)

startDocument

public void startDocument()
                   throws SAXException
Adapter implementation method; do not call. Adapt a SAX1 start document event.

Specified by:
startDocument in interface DocumentHandler
Throws:
SAXException - The client may raise a processing exception.
See Also:
DocumentHandler.startDocument()

endDocument

public void endDocument()
                 throws SAXException
Adapter implementation method; do not call. Adapt a SAX1 end document event.

Specified by:
endDocument in interface DocumentHandler
Throws:
SAXException - The client may raise a processing exception.
See Also:
DocumentHandler.endDocument()

startElement

public void startElement(String qName,
                         AttributeList qAtts)
                  throws SAXException
Adapter implementation method; do not call. Adapt a SAX1 startElement event.

If necessary, perform Namespace processing.

Specified by:
startElement in interface DocumentHandler
Parameters:
qName - The qualified (prefixed) name.
qAtts - The XML attribute list (with qnames).
Throws:
SAXException - The client may raise a processing exception.
See Also:
DocumentHandler.endElement(java.lang.String), AttributeList

endElement

public void endElement(String qName)
                throws SAXException
Adapter implementation method; do not call. Adapt a SAX1 end element event.

Specified by:
endElement in interface DocumentHandler
Parameters:
qName - The qualified (prefixed) name.
Throws:
SAXException - The client may raise a processing exception.
See Also:
DocumentHandler.endElement(java.lang.String)

characters

public void characters(char[] ch,
                       int start,
                       int length)
                throws SAXException
Adapter implementation method; do not call. Adapt a SAX1 characters event.

Specified by:
characters in interface DocumentHandler
Parameters:
ch - An array of characters.
start - The starting position in the array.
length - The number of characters to use.
Throws:
SAXException - The client may raise a processing exception.
See Also:
DocumentHandler.characters(char[], int, int)

ignorableWhitespace

public void ignorableWhitespace(char[] ch,
                                int start,
                                int length)
                         throws SAXException
Adapter implementation method; do not call. Adapt a SAX1 ignorable whitespace event.

Specified by:
ignorableWhitespace in interface DocumentHandler
Parameters:
ch - An array of characters.
start - The starting position in the array.
length - The number of characters to use.
Throws:
SAXException - The client may raise a processing exception.
See Also:
DocumentHandler.ignorableWhitespace(char[], int, int)

processingInstruction

public void processingInstruction(String target,
                                  String data)
                           throws SAXException
Adapter implementation method; do not call. Adapt a SAX1 processing instruction event.

Specified by:
processingInstruction in interface DocumentHandler
Parameters:
target - The processing instruction target.
data - The remainder of the processing instruction
Throws:
SAXException - The client may raise a processing exception.
See Also:
DocumentHandler.processingInstruction(java.lang.String, java.lang.String)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


ParserFactory (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax.helpers
Class ParserFactory

java.lang.Object
    extended by  org.xml.sax.helpers.ParserFactory
Deprecated. This class works with the deprecated Parser interface.

public class ParserFactory
extends Object

Java-specific class for dynamically loading SAX parsers.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

Note: This class is designed to work with the now-deprecated SAX1 Parser class. SAX2 applications should use XMLReaderFactory instead.

ParserFactory is not part of the platform-independent definition of SAX; it is an additional convenience class designed specifically for Java XML application writers. SAX applications can use the static methods in this class to allocate a SAX parser dynamically at run-time based either on the value of the `org.xml.sax.parser' system property or on a string containing the class name.

Note that the application still requires an XML parser that implements SAX1.

Since:
SAX 1.0

Method Summary
Modifier and Type | Method and Description
static Parser | makeParser() Deprecated. Create a new SAX parser using the `org.xml.sax.parser' system property.
static Parser | makeParser(String className) Deprecated. Create a new SAX parser object using the class name provided.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

makeParser

public static Parser makeParser()
                         throws ClassNotFoundException,
                                IllegalAccessException,
                                InstantiationException,
                                NullPointerException,
                                ClassCastException
Deprecated.
Create a new SAX parser using the `org.xml.sax.parser' system property.

The named class must exist and must implement the Parser interface.

Throws:
NullPointerException - There is no value for the `org.xml.sax.parser' system property.
ClassNotFoundException - The SAX parser class was not found (check your CLASSPATH).
IllegalAccessException - The SAX parser class was found, but you do not have permission to load it.
InstantiationException - The SAX parser class was found but could not be instantiated.
ClassCastException - The SAX parser class was found and instantiated, but does not implement org.xml.sax.Parser.
See Also:
makeParser(java.lang.String), Parser

makeParser

public static Parser makeParser(String className)
                         throws ClassNotFoundException,
                                IllegalAccessException,
                                InstantiationException,
                                ClassCastException
Deprecated.
Create a new SAX parser object using the class name provided.

The named class must exist and must implement the Parser interface.

Parameters:
className - A string containing the name of the SAX parser class.
Throws:
ClassNotFoundException - The SAX parser class was not found (check your CLASSPATH).
IllegalAccessException - The SAX parser class was found, but you do not have permission to load it.
InstantiationException - The SAX parser class was found but could not be instantiated.
ClassCastException - The SAX parser class was found and instantiated, but does not implement org.xml.sax.Parser.
See Also:
makeParser(), Parser
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


XMLFilterImpl (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax.helpers
Class XMLFilterImpl

java.lang.Object
    extended by  org.xml.sax.helpers.XMLFilterImpl
All Implemented Interfaces:
ContentHandler, DTDHandler, EntityResolver, ErrorHandler, XMLFilter, XMLReader
public class XMLFilterImpl
extends Object
implements XMLFilter, EntityResolver, DTDHandler, ContentHandler, ErrorHandler

Base class for deriving an XML filter.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

This class is designed to sit between an XMLReader and the client application's event handlers. By default, it does nothing but pass requests up to the reader and events on to the handlers unmodified, but subclasses can override specific methods to modify the event stream or the configuration requests as they pass through.

Since:
SAX 2.0
See Also:
XMLFilter, XMLReader, EntityResolver, DTDHandler, ContentHandler, ErrorHandler

Constructor Summary
Constructor and Description
XMLFilterImpl()
Construct an empty XML filter, with no parent.
XMLFilterImpl(XMLReader parent)
Construct an XML filter with the specified parent.
Method Summary
Modifier and Type | Method and Description
void | characters(char[] ch, int start, int length) Filter a character data event.
void | endDocument() Filter an end document event.
void | endElement(String uri, String localName, String qName) Filter an end element event.
void | endPrefixMapping(String prefix) Filter an end Namespace prefix mapping event.
void | error(SAXParseException e) Filter an error event.
void | fatalError(SAXParseException e) Filter a fatal error event.
ContentHandler | getContentHandler() Get the content event handler.
DTDHandler | getDTDHandler() Get the current DTD event handler.
EntityResolver | getEntityResolver() Get the current entity resolver.
ErrorHandler | getErrorHandler() Get the current error event handler.
boolean | getFeature(String name) Look up the value of a feature.
XMLReader | getParent() Get the parent reader.
Object | getProperty(String name) Look up the value of a property.
void | ignorableWhitespace(char[] ch, int start, int length) Filter an ignorable whitespace event.
void | notationDecl(String name, String publicId, String systemId) Filter a notation declaration event.
void | parse(InputSource input) Parse a document.
void | parse(String systemId) Parse a document.
void | processingInstruction(String target, String data) Filter a processing instruction event.
InputSource | resolveEntity(String publicId, String systemId) Filter an external entity resolution.
void | setContentHandler(ContentHandler handler) Set the content event handler.
void | setDocumentLocator(Locator locator) Filter a new document locator event.
void | setDTDHandler(DTDHandler handler) Set the DTD event handler.
void | setEntityResolver(EntityResolver resolver) Set the entity resolver.
void | setErrorHandler(ErrorHandler handler) Set the error event handler.
void | setFeature(String name, boolean value) Set the value of a feature.
void | setParent(XMLReader parent) Set the parent reader.
void | setProperty(String name, Object value) Set the value of a property.
void | skippedEntity(String name) Filter a skipped entity event.
void | startDocument() Filter a start document event.
void | startElement(String uri, String localName, String qName, Attributes atts) Filter a start element event.
void | startPrefixMapping(String prefix, String uri) Filter a start Namespace prefix mapping event.
void | unparsedEntityDecl(String name, String publicId, String systemId, String notationName) Filter an unparsed entity declaration event.
void | warning(SAXParseException e) Filter a warning event.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XMLFilterImpl

public XMLFilterImpl()
Construct an empty XML filter, with no parent.

This filter will have no parent: you must assign a parent before you start a parse or do any configuration with setFeature or setProperty, unless you use this as a pure event consumer rather than as an XMLReader.

See Also:
XMLReader.setFeature(java.lang.String, boolean),
XMLReader.setProperty(java.lang.String, java.lang.Object),
setParent(org.xml.sax.XMLReader)

XMLFilterImpl

public XMLFilterImpl(XMLReader parent)
Construct an XML filter with the specified parent.

See Also:
setParent(org.xml.sax.XMLReader), getParent()
Method Detail

setParent

public void setParent(XMLReader parent)
Set the parent reader.

This is the XMLReader from which this filter will obtain its events and to which it will pass its configuration requests. The parent may itself be another filter.

If there is no parent reader set, any attempt to parse or to set or get a feature or property will fail.

Specified by:
setParent in interface XMLFilter
Parameters:
parent - The parent XML reader.
See Also:
getParent()

getParent

public XMLReader getParent()
Get the parent reader.

Specified by:
getParent in interface XMLFilter
Returns:
The parent XML reader, or null if none is set.
See Also:
setParent(org.xml.sax.XMLReader)

setFeature

public void setFeature(String name,
                       boolean value)
                throws SAXNotRecognizedException,
                       SAXNotSupportedException
Set the value of a feature.

This will always fail if the parent is null.

Specified by:
setFeature in interface XMLReader
Parameters:
name - The feature name.
value - The requested feature value.
Throws:
SAXNotRecognizedException - If the feature value can't be assigned or retrieved from the parent.
SAXNotSupportedException - When the parent recognizes the feature name but cannot set the requested value.
See Also:
XMLReader.getFeature(java.lang.String)

getFeature

public boolean getFeature(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
Look up the value of a feature.

This will always fail if the parent is null.

Specified by:
getFeature in interface XMLReader
Parameters:
name - The feature name.
Returns:
The current value of the feature.
Throws:
SAXNotRecognizedException - If the feature value can't be assigned or retrieved from the parent.
SAXNotSupportedException - When the parent recognizes the feature name but cannot determine its value at this time.
See Also:
XMLReader.setFeature(java.lang.String, boolean)

setProperty

public void setProperty(String name,
                        Object value)
                 throws SAXNotRecognizedException,
                        SAXNotSupportedException
Set the value of a property.

This will always fail if the parent is null.

Specified by:
setProperty in interface XMLReader
Parameters:
name - The property name.
value - The requested property value.
Throws:
SAXNotRecognizedException - If the property value can't be assigned or retrieved from the parent.
SAXNotSupportedException - When the parent recognizes the property name but cannot set the requested value.

getProperty

public Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
Look up the value of a property.

Specified by:
getProperty in interface XMLReader
Parameters:
name - The property name.
Returns:
The current value of the property.
Throws:
SAXNotRecognizedException - If the property value can't be assigned or retrieved from the parent.
SAXNotSupportedException - When the parent recognizes the property name but cannot determine its value at this time.
See Also:
XMLReader.setProperty(java.lang.String, java.lang.Object)

setEntityResolver

public void setEntityResolver(EntityResolver resolver)
Set the entity resolver.

Specified by:
setEntityResolver in interface XMLReader
Parameters:
resolver - The new entity resolver.
See Also:
XMLReader.getEntityResolver()

getEntityResolver

public EntityResolver getEntityResolver()
Get the current entity resolver.

Specified by:
getEntityResolver in interface XMLReader
Returns:
The current entity resolver, or null if none was set.
See Also:
XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

setDTDHandler

public void setDTDHandler(DTDHandler handler)
Set the DTD event handler.

Specified by:
setDTDHandler in interface XMLReader
Parameters:
handler - the new DTD handler
See Also:
XMLReader.getDTDHandler()

getDTDHandler

public DTDHandler getDTDHandler()
Get the current DTD event handler.

Specified by:
getDTDHandler in interface XMLReader
Returns:
The current DTD handler, or null if none was set.
See Also:
XMLReader.setDTDHandler(org.xml.sax.DTDHandler)

setContentHandler

public void setContentHandler(ContentHandler handler)
Set the content event handler.

Specified by:
setContentHandler in interface XMLReader
Parameters:
handler - the new content handler
See Also:
XMLReader.getContentHandler()

getContentHandler

public ContentHandler getContentHandler()
Get the content event handler.

Specified by:
getContentHandler in interface XMLReader
Returns:
The current content handler, or null if none was set.
See Also:
XMLReader.setContentHandler(org.xml.sax.ContentHandler)

setErrorHandler

public void setErrorHandler(ErrorHandler handler)
Set the error event handler.

Specified by:
setErrorHandler in interface XMLReader
Parameters:
handler - the new error handler
See Also:
XMLReader.getErrorHandler()

getErrorHandler

public ErrorHandler getErrorHandler()
Get the current error event handler.

Specified by:
getErrorHandler in interface XMLReader
Returns:
The current error handler, or null if none was set.
See Also:
XMLReader.setErrorHandler(org.xml.sax.ErrorHandler)

parse

public void parse(InputSource input)
           throws SAXException,
                  IOException
Parse a document.

Specified by:
parse in interface XMLReader
Parameters:
input - The input source for the document entity.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
See Also:
InputSource,
XMLReader.parse(java.lang.String),
XMLReader.setEntityResolver(org.xml.sax.EntityResolver),
XMLReader.setDTDHandler(org.xml.sax.DTDHandler),
XMLReader.setContentHandler(org.xml.sax.ContentHandler),
XMLReader.setErrorHandler(org.xml.sax.ErrorHandler)

parse

public void parse(String systemId)
           throws SAXException,
                  IOException
Parse a document.

Specified by:
parse in interface XMLReader
Parameters:
systemId - The system identifier as a fully-qualified URI.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
See Also:
XMLReader.parse(org.xml.sax.InputSource)

resolveEntity

public InputSource resolveEntity(String publicId,
                                 String systemId)
                          throws SAXException,
                                 IOException
Filter an external entity resolution.

Specified by:
resolveEntity in interface EntityResolver
Parameters:
publicId - The entity's public identifier, or null.
systemId - The entity's system identifier.
Returns:
A new InputSource or null for the default.
Throws:
SAXException - The client may throw an exception during processing.
IOException - The client may throw an I/O-related exception while obtaining the new InputSource.
See Also:
InputSource

notationDecl

public void notationDecl(String name,
                         String publicId,
                         String systemId)
                  throws SAXException
Filter a notation declaration event.

Specified by:
notationDecl in interface DTDHandler
Parameters:
name - The notation name.
publicId - The notation's public identifier, or null.
systemId - The notation's system identifier, or null.
Throws:
SAXException - The client may throw an exception during processing.
See Also:
DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String), Attributes

unparsedEntityDecl

public void unparsedEntityDecl(String name,
                               String publicId,
                               String systemId,
                               String notationName)
                        throws SAXException
Filter an unparsed entity declaration event.

Specified by:
unparsedEntityDecl in interface DTDHandler
Parameters:
name - The entity name.
publicId - The entity's public identifier, or null.
systemId - The entity's system identifier, or null.
notationName - The name of the associated notation.
Throws:
SAXException - The client may throw an exception during processing.
See Also:
DTDHandler.notationDecl(java.lang.String, java.lang.String, java.lang.String), Attributes

setDocumentLocator

public void setDocumentLocator(Locator locator)
Filter a new document locator event.

Specified by:
setDocumentLocator in interface ContentHandler
Parameters:
locator - The document locator.
See Also:
Locator

startDocument

public void startDocument()
                   throws SAXException
Filter a start document event.

Specified by:
startDocument in interface ContentHandler
Throws:
SAXException - The client may throw an exception during processing.
See Also:
ContentHandler.endDocument()

endDocument

public void endDocument()
                 throws SAXException
Filter an end document event.

Specified by:
endDocument in interface ContentHandler
Throws:
SAXException - The client may throw an exception during processing.
See Also:
ContentHandler.startDocument()

startPrefixMapping

public void startPrefixMapping(String prefix,
                               String uri)
                        throws SAXException
Filter a start Namespace prefix mapping event.

Specified by:
startPrefixMapping in interface ContentHandler
Parameters:
prefix - The Namespace prefix.
uri - The Namespace URI.
Throws:
SAXException - The client may throw an exception during processing.
See Also:
ContentHandler.endPrefixMapping(java.lang.String), ContentHandler.startElement(java.lang.String, java.lang.String, java.lang.String, org.xml.sax.Attributes)

endPrefixMapping

public void endPrefixMapping(String prefix)
                      throws SAXException
Filter an end Namespace prefix mapping event.

Specified by:
endPrefixMapping in interface ContentHandler
Parameters:
prefix - The Namespace prefix.
Throws:
SAXException - The client may throw an exception during processing.
See Also:
ContentHandler.startPrefixMapping(java.lang.String, java.lang.String), ContentHandler.endElement(java.lang.String, java.lang.String, java.lang.String)

startElement

public void startElement(String uri,
                         String localName,
                         String qName,
                         Attributes atts)
                  throws SAXException
Filter a start element event.

Specified by:
startElement in interface ContentHandler
Parameters:
uri - The element's Namespace URI, or the empty string.
localName - The element's local name, or the empty string.
qName - The element's qualified (prefixed) name, or the empty string.
atts - The element's attributes.
Throws:
SAXException - The client may throw an exception during processing.
See Also:
ContentHandler.endElement(java.lang.String, java.lang.String, java.lang.String), Attributes, AttributesImpl

endElement

public void endElement(String uri,
                       String localName,
                       String qName)
                throws SAXException
Filter an end element event.

Specified by:
endElement in interface ContentHandler
Parameters:
uri - The element's Namespace URI, or the empty string.
localName - The element's local name, or the empty string.
qName - The element's qualified (prefixed) name, or the empty string.
Throws:
SAXException - The client may throw an exception during processing.

characters

public void characters(char[] ch,
                       int start,
                       int length)
                throws SAXException
Filter a character data event.

Specified by:
characters in interface ContentHandler
Parameters:
ch - An array of characters.
start - The starting position in the array.
length - The number of characters to use from the array.
Throws:
SAXException - The client may throw an exception during processing.
See Also:
ContentHandler.ignorableWhitespace(char[], int, int), Locator

ignorableWhitespace

public void ignorableWhitespace(char[] ch,
                                int start,
                                int length)
                         throws SAXException
Filter an ignorable whitespace event.

Specified by:
ignorableWhitespace in interface ContentHandler
Parameters:
ch - An array of characters.
start - The starting position in the array.
length - The number of characters to use from the array.
Throws:
SAXException - The client may throw an exception during processing.
See Also:
ContentHandler.characters(char[], int, int)

processingInstruction

public void processingInstruction(String target,
                                  String data)
                           throws SAXException
Filter a processing instruction event.

Specified by:
processingInstruction in interface ContentHandler
Parameters:
target - The processing instruction target.
data - The text following the target.
Throws:
SAXException - The client may throw an exception during processing.

skippedEntity

public void skippedEntity(String name)
                   throws SAXException
Filter a skipped entity event.

Specified by:
skippedEntity in interface ContentHandler
Parameters:
name - The name of the skipped entity.
Throws:
SAXException - The client may throw an exception during processing.

warning

public void warning(SAXParseException e)
             throws SAXException
Filter a warning event.

Specified by:
warning in interface ErrorHandler
Parameters:
e - The warning as an exception.
Throws:
SAXException - The client may throw an exception during processing.
See Also:
SAXParseException

error

public void error(SAXParseException e)
           throws SAXException
Filter an error event.

Specified by:
error in interface ErrorHandler
Parameters:
e - The error as an exception.
Throws:
SAXException - The client may throw an exception during processing.
See Also:
SAXParseException

fatalError

public void fatalError(SAXParseException e)
                throws SAXException
Filter a fatal error event.

Specified by:
fatalError in interface ErrorHandler
Parameters:
e - The error as an exception.
Throws:
SAXException - The client may throw an exception during processing.
See Also:
SAXParseException
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


XMLReaderAdapter (Java Platform SE 7 b59)

DRAFT ea-b59

org.xml.sax.helpers
Class XMLReaderAdapter

java.lang.Object
    extended by  org.xml.sax.helpers.XMLReaderAdapter
All Implemented Interfaces:
ContentHandler, Parser
public class XMLReaderAdapter
extends Object
implements Parser, ContentHandler

Adapt a SAX2 XMLReader as a SAX1 Parser.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

This class wraps a SAX2 XMLReader and makes it act as a SAX1 Parser. The XMLReader must support a true value for the http://xml.org/sax/features/namespace-prefixes property or parsing will fail with a SAXException; if the XMLReader supports a false value for the http://xml.org/sax/features/namespaces property, that will also be used to improve efficiency.

Since:
SAX 2.0
See Also:
Parser, XMLReader

Constructor Summary
Constructor and Description
XMLReaderAdapter()
Create a new adapter.
XMLReaderAdapter(XMLReader xmlReader)
Create a new adapter.
Method Summary
Modifier and Type | Method and Description
void | characters(char[] ch, int start, int length) Adapt a SAX2 characters event.
void | endDocument() End document event.
void | endElement(String uri, String localName, String qName) Adapt a SAX2 end element event.
void | endPrefixMapping(String prefix) Adapt a SAX2 end prefix mapping event.
void | ignorableWhitespace(char[] ch, int start, int length) Adapt a SAX2 ignorable whitespace event.
void | parse(InputSource input) Parse the document.
void | parse(String systemId) Parse the document.
void | processingInstruction(String target, String data) Adapt a SAX2 processing instruction event.
void | setDocumentHandler(DocumentHandler handler) Register the SAX1 document event handler.
void | setDocumentLocator(Locator locator) Set a document locator.
void | setDTDHandler(DTDHandler handler) Register the DTD event handler.
void | setEntityResolver(EntityResolver resolver) Register the entity resolver.
void | setErrorHandler(ErrorHandler handler) Register the error event handler.
void | setLocale(Locale locale) Set the locale for error reporting.
void | skippedEntity(String name) Adapt a SAX2 skipped entity event.
void | startDocument() Start document event.
void | startElement(String uri, String localName, String qName, Attributes atts) Adapt a SAX2 start element event.
void | startPrefixMapping(String prefix, String uri) Adapt a SAX2 start prefix mapping event.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XMLReaderAdapter

public XMLReaderAdapter()
                 throws SAXException
Create a new adapter.

Use the "org.xml.sax.driver" property to locate the SAX2 driver to embed.

Throws:
SAXException - If the embedded driver cannot be instantiated or if the org.xml.sax.driver property is not specified.

XMLReaderAdapter

public XMLReaderAdapter(XMLReader xmlReader)
Create a new adapter.

Create a new adapter, wrapped around a SAX2 XMLReader. The adapter will make the XMLReader act like a SAX1 Parser.

Parameters:
xmlReader - The SAX2 XMLReader to wrap.
Throws:
NullPointerException - If the argument is null.
Method Detail

setLocale

public void setLocale(Locale locale)
               throws SAXException
Set the locale for error reporting.

This is not supported in SAX2, and will always throw an exception.

Specified by:
setLocale in interface Parser
Parameters:
locale - the locale for error reporting.
Throws:
SAXException - Thrown unless overridden.
See Also:
Parser.setLocale(java.util.Locale)

setEntityResolver

public void setEntityResolver(EntityResolver resolver)
Register the entity resolver.

Specified by:
setEntityResolver in interface Parser
Parameters:
resolver - The new resolver.
See Also:
Parser.setEntityResolver(org.xml.sax.EntityResolver)

setDTDHandler

public void setDTDHandler(DTDHandler handler)
Register the DTD event handler.

Specified by:
setDTDHandler in interface Parser
Parameters:
handler - The new DTD event handler.
See Also:
Parser.setDTDHandler(org.xml.sax.DTDHandler)

setDocumentHandler

public void setDocumentHandler(DocumentHandler handler)
Register the SAX1 document event handler.

Note that the SAX1 document handler has no Namespace support.

Specified by:
setDocumentHandler in interface Parser
Parameters:
handler - The new SAX1 document event handler.
See Also:
Parser.setDocumentHandler(org.xml.sax.DocumentHandler)

setErrorHandler

public void setErrorHandler(ErrorHandler handler)
Register the error event handler.

Specified by:
setErrorHandler in interface Parser
Parameters:
handler - The new error event handler.
See Also:
Parser.setErrorHandler(org.xml.sax.ErrorHandler)

parse

public void parse(String systemId)
           throws IOException,
                  SAXException
Parse the document.

This method will throw an exception if the embedded XMLReader does not support the http://xml.org/sax/features/namespace-prefixes property.

Specified by:
parse in interface Parser
Parameters:
systemId - The absolute URL of the document.
Throws:
IOException - If there is a problem reading the raw content of the document.
SAXException - If there is a problem processing the document.
See Also:
parse(org.xml.sax.InputSource), Parser.parse(java.lang.String)

parse

public void parse(InputSource input)
           throws IOException,
                  SAXException
Parse the document.

This method will throw an exception if the embedded XMLReader does not support the http://xml.org/sax/features/namespace-prefixes property.

Specified by:
parse in interface Parser
Parameters:
input - An input source for the document.
Throws:
IOException - If there is a problem reading the raw content of the document.
SAXException - If there is a problem processing the document.
See Also:
parse(java.lang.String), Parser.parse(org.xml.sax.InputSource)

setDocumentLocator

public void setDocumentLocator(Locator locator)
Set a document locator.

Specified by:
setDocumentLocator in interface ContentHandler
Parameters:
locator - The document locator.
See Also:
ContentHandler.setDocumentLocator(org.xml.sax.Locator)

startDocument

public void startDocument()
                   throws SAXException
Start document event.

Specified by:
startDocument in interface ContentHandler
Throws:
SAXException - The client may raise a processing exception.
See Also:
ContentHandler.startDocument()

endDocument

public void endDocument()
                 throws SAXException
End document event.

Specified by:
endDocument in interface ContentHandler
Throws:
SAXException - The client may raise a processing exception.
See Also:
ContentHandler.endDocument()

startPrefixMapping

public void startPrefixMapping(String prefix,
                               String uri)
Adapt a SAX2 start prefix mapping event.

Specified by:
startPrefixMapping in interface ContentHandler
Parameters:
prefix - The prefix being mapped.
uri - The Namespace URI being mapped to.
See Also:
ContentHandler.startPrefixMapping(java.lang.String, java.lang.String)

endPrefixMapping

public void endPrefixMapping(String prefix)
Adapt a SAX2 end prefix mapping event.

Specified by:
endPrefixMapping in interface ContentHandler
Parameters:
prefix - The prefix being mapped.
See Also:
ContentHandler.endPrefixMapping(java.lang.String)

startElement

public void startElement(String uri,
                         String localName,
                         String qName,
                         Attributes atts)
                  throws SAXException
Adapt a SAX2 start element event.

Specified by:
startElement in interface ContentHandler
Parameters:
uri - The Namespace URI.
localName - The Namespace local name.
qName - The qualified (prefixed) name.
atts - The SAX2 attributes.
Throws:
SAXException - The client may raise a processing exception.
See Also:
ContentHandler.endDocument()

endElement

public void endElement(String uri,
                       String localName,
                       String qName)
                throws SAXException
Adapt a SAX2 end element event.

Specified by:
endElement in interface ContentHandler
Parameters:
uri - The Namespace URI.
localName - The Namespace local name.
qName - The qualified (prefixed) name.
Throws:
SAXException - The client may raise a processing exception.
See Also:
ContentHandler.endElement(java.lang.String, java.lang.String, java.lang.String)

characters

public void characters(char[] ch,
                       int start,
                       int length)
                throws SAXException
Adapt a SAX2 characters event.

Specified by:
characters in interface ContentHandler
Parameters:
ch - An array of characters.
start - The starting position in the array.
length - The number of characters to use.
Throws:
SAXException - The client may raise a processing exception.
See Also:
ContentHandler.characters(char[], int, int)

ignorableWhitespace

public void ignorableWhitespace(char[] ch,
                                int start,
                                int length)
                         throws SAXException
Adapt a SAX2 ignorable whitespace event.

Specified by:
ignorableWhitespace in interface ContentHandler
Parameters:
ch - An array of characters.
start - The starting position in the array.
length - The number of characters to use.
Throws:
SAXException - The client may raise a processing exception.
See Also:
ContentHandler.ignorableWhitespace(char[], int, int)

processingInstruction

public void processingInstruction(String target,
                                  String data)
                           throws SAXException
Adapt a SAX2 processing instruction event.

Specified by:
processingInstruction in interface ContentHandler
Parameters:
target - The processing instruction target.
data - The remainder of the processing instruction
Throws:
SAXException - The client may raise a processing exception.
See Also:
ContentHandler.processingInstruction(java.lang.String, java.lang.String)

skippedEntity

public void skippedEntity(String name)
                   throws SAXException
Adapt a SAX2 skipped entity event.

Specified by:
skippedEntity in interface ContentHandler
Parameters:
name - The name of the skipped entity.
Throws:
SAXException - Throwable by subclasses.
See Also:
ContentHandler.skippedEntity(java.lang.String)
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform


XMLReaderFactory (Java Platform SE 7 b59)

DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.xml.sax.helpers
Class XMLReaderFactory

java.lang.Object
    extended by  org.xml.sax.helpers.XMLReaderFactory

public final class XMLReaderFactory
extends Object

Factory for creating an XML reader.

This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

This class contains static methods for creating an XML reader from an explicit class name, or based on runtime defaults:

 try {
   XMLReader myReader = XMLReaderFactory.createXMLReader();
 } catch (SAXException e) {
   System.err.println(e.getMessage());
 }

Note to Distributions bundled with parsers: You should modify the implementation of the no-arguments createXMLReader to handle cases where the external configuration mechanisms aren't set up. That method should do its best to return a parser when one is in the class path, even when nothing bound its class name to org.xml.sax.driver so those configuration mechanisms would see it.

Since:
SAX 2.0

Method Summary
Modifier and Type | Method and Description
static XMLReader | createXMLReader() Attempt to create an XMLReader from system defaults.
static XMLReader | createXMLReader(String className) Attempt to create an XML reader from a class name.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

createXMLReader

public static XMLReader createXMLReader()
                                 throws SAXException
Attempt to create an XMLReader from system defaults. In environments which can support it, the name of the XMLReader class is determined by trying each these options in order, and using the first one which succeeds:

  • If the system property org.xml.sax.driver has a value, that is used as an XMLReader class name.
  • The JAR "Services API" is used to look for a class name in the META-INF/services/org.xml.sax.driver file in jarfiles available to the runtime.
  • SAX parser distributions are strongly encouraged to provide a default XMLReader class name that will take effect only when previous options (on this list) are not successful.
  • Finally, if ParserFactory.makeParser() can return a system default SAX1 parser, that parser is wrapped in a ParserAdapter. (This is a migration aid for SAX1 environments, where the org.xml.sax.parser system property will often be usable.)

In environments such as small embedded systems, which can not support that flexibility, other mechanisms to determine the default may be used.

Note that many Java environments allow system properties to be initialized on a command line. This means that in most cases setting a good value for that property ensures that calls to this method will succeed, except when security policies intervene. This will also maximize application portability to older SAX environments, with less robust implementations of this method.

Returns:
A new XMLReader.
Throws:
SAXException - If no default XMLReader class can be identified and instantiated.
See Also:
createXMLReader(java.lang.String)

createXMLReader

public static XMLReader createXMLReader(String className)
                                 throws SAXException
Attempt to create an XML reader from a class name.

Given a class name, this method attempts to load and instantiate the class as an XML reader.

Note that this method will not be usable in environments where the caller (perhaps an applet) is not permitted to load classes dynamically.

Returns:
A new XML reader.
Throws:
SAXException - If the class cannot be loaded, instantiated, and cast to XMLReader.
See Also:
createXMLReader()
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


All Classes (Java Platform SE 7 b59)

 All Classes
AbstractAction
AbstractAnnotationValueVisitor6
AbstractBorder
AbstractButton
AbstractCellEditor
AbstractCollection
AbstractColorChooserPanel
AbstractDocument
AbstractDocument.AttributeContext
AbstractDocument.Content
AbstractDocument.ElementEdit
AbstractElementVisitor6
AbstractExecutorService
AbstractInterruptibleChannel
AbstractLayoutCache
AbstractLayoutCache.NodeDimensions
AbstractList
AbstractListModel
AbstractMap
AbstractMap.SimpleEntry
AbstractMap.SimpleImmutableEntry
AbstractMarshallerImpl
AbstractMethodError
AbstractOwnableSynchronizer
AbstractPath
AbstractPreferences
AbstractProcessor
AbstractQueue
AbstractQueuedLongSynchronizer
AbstractQueuedSynchronizer
AbstractScriptEngine
AbstractSelectableChannel
AbstractSelectionKey
AbstractSelector
AbstractSequentialList
AbstractSet
AbstractSpinnerModel
AbstractTableModel
AbstractTypeVisitor6
AbstractUndoableEdit
AbstractUnmarshallerImpl
AbstractWriter
AcceptPendingException
AccessControlContext
AccessControlException
AccessController
AccessDeniedException
AccessException
Accessible
AccessibleAction
AccessibleAttributeSequence
AccessibleBundle
AccessibleComponent
AccessibleContext
AccessibleEditableText
AccessibleExtendedComponent
AccessibleExtendedTable
AccessibleExtendedText
AccessibleHyperlink
AccessibleHypertext
AccessibleIcon
AccessibleKeyBinding
AccessibleObject
AccessibleRelation
AccessibleRelationSet
AccessibleResourceBundle
AccessibleRole
AccessibleSelection
AccessibleState
AccessibleStateSet
AccessibleStreamable
AccessibleTable
AccessibleTableModelChange
AccessibleText
AccessibleTextSequence
AccessibleValue
AccessMode
AccountException
AccountExpiredException
AccountLockedException
AccountNotFoundException
Acl
AclEntry
AclEntry
AclEntry.Builder
AclEntryFlag
AclEntryPermission
AclEntryType
AclFileAttributeView
AclNotFoundException
Action
Action
ActionEvent
ActionListener
ActionMap
ActionMapUIResource
Activatable
ActivateFailedException
ActivationDataFlavor
ActivationDesc
ActivationException
ActivationGroup
ActivationGroup_Stub
ActivationGroupDesc
ActivationGroupDesc.CommandEnvironment
ActivationGroupID
ActivationID
ActivationInstantiator
ActivationMonitor
ActivationSystem
Activator
ACTIVE
ActiveEvent
ACTIVITY_COMPLETED
ACTIVITY_REQUIRED
ActivityCompletedException
ActivityRequiredException
AdapterActivator
AdapterActivatorOperations
AdapterAlreadyExists
AdapterAlreadyExistsHelper
AdapterInactive
AdapterInactiveHelper
AdapterManagerIdHelper
AdapterNameHelper
AdapterNonExistent
AdapterNonExistentHelper
AdapterStateHelper
AddressHelper
Addressing
AddressingFeature
Adjustable
AdjustmentEvent
AdjustmentListener
Adler32
AffineTransform
AffineTransformOp
AlgorithmMethod
AlgorithmParameterGenerator
AlgorithmParameterGeneratorSpi
AlgorithmParameters
AlgorithmParameterSpec
AlgorithmParametersSpi
AllPermission
AlphaComposite
AlreadyBound
AlreadyBoundException
AlreadyBoundException
AlreadyBoundHelper
AlreadyBoundHolder
AlreadyConnectedException
AncestorEvent
AncestorListener
AnnotatedElement
Annotation
Annotation
AnnotationFormatError
AnnotationMirror
AnnotationTypeMismatchException
AnnotationValue
AnnotationValueVisitor
Any
AnyHolder
AnySeqHelper
AnySeqHelper
AnySeqHolder
AppConfigurationEntry
AppConfigurationEntry.LoginModuleControlFlag
Appendable
Applet
AppletContext
AppletInitializer
AppletStub
ApplicationException
Arc2D
Arc2D.Double
Arc2D.Float
Area
AreaAveragingScaleFilter
ARG_IN
ARG_INOUT
ARG_OUT
ArithmeticException
Array
Array
ArrayBlockingQueue
ArrayDeque
ArrayIndexOutOfBoundsException
ArrayList
Arrays
ArrayStoreException
ArrayType
ArrayType
AssertionError
AsyncBoxView
AsyncHandler
AsynchronousByteChannel
AsynchronousChannel
AsynchronousChannelGroup
AsynchronousChannelProvider
AsynchronousCloseException
AsynchronousDatagramChannel
AsynchronousFileChannel
AsynchronousServerSocketChannel
AsynchronousSocketChannel
AtomicBoolean
AtomicInteger
AtomicIntegerArray
AtomicIntegerFieldUpdater
AtomicLong
AtomicLongArray
AtomicLongFieldUpdater
AtomicMarkableReference
AtomicMoveNotSupportedException
AtomicReference
AtomicReferenceArray
AtomicReferenceFieldUpdater
AtomicStampedReference
AttachmentMarshaller
AttachmentPart
AttachmentUnmarshaller
Attr
Attribute
Attribute
Attribute
Attribute
AttributeChangeNotification
AttributeChangeNotificationFilter
AttributedCharacterIterator
AttributedCharacterIterator.Attribute
AttributedString
AttributeException
AttributeInUseException
AttributeList
AttributeList
AttributeList
AttributeListImpl
AttributeModificationException
AttributeNotFoundException
Attributes
Attributes
Attributes
Attributes
Attributes.Name
Attributes2
Attributes2Impl
AttributeSet
AttributeSet
AttributeSet.CharacterAttribute
AttributeSet.ColorAttribute
AttributeSet.FontAttribute
AttributeSet.ParagraphAttribute
AttributeSetUtilities
AttributesImpl
AttributeValueExp
AttributeView
AudioClip
AudioFileFormat
AudioFileFormat.Type
AudioFileReader
AudioFileWriter
AudioFormat
AudioFormat.Encoding
AudioInputStream
AudioPermission
AudioSystem
AuthenticationException
AuthenticationException
AuthenticationNotSupportedException
Authenticator
Authenticator.RequestorType
AuthorizeCallback
AuthPermission
AuthProvider
Autoscroll
AWTError
AWTEvent
AWTEventListener
AWTEventListenerProxy
AWTEventMulticaster
AWTException
AWTKeyStroke
AWTPermission
BackingStoreException
BAD_CONTEXT
BAD_INV_ORDER
BAD_OPERATION
BAD_PARAM
BAD_POLICY
BAD_POLICY_TYPE
BAD_POLICY_VALUE
BAD_QOS
BAD_TYPECODE
BadAttributeValueExpException
BadBinaryOpValueExpException
BadKind
BadLocationException
BadPaddingException
BadStringOperationException
BandCombineOp
BandedSampleModel
BaseRowSet
BasicArrowButton
BasicAttribute
BasicAttributes
BasicBorders
BasicBorders.ButtonBorder
BasicBorders.FieldBorder
BasicBorders.MarginBorder
BasicBorders.MenuBarBorder
BasicBorders.RadioButtonBorder
BasicBorders.RolloverButtonBorder
BasicBorders.SplitPaneBorder
BasicBorders.ToggleButtonBorder
BasicButtonListener
BasicButtonUI
BasicCheckBoxMenuItemUI
BasicCheckBoxUI
BasicColorChooserUI
BasicComboBoxEditor
BasicComboBoxEditor.UIResource
BasicComboBoxRenderer
BasicComboBoxRenderer.UIResource
BasicComboBoxUI
BasicComboPopup
BasicControl
BasicDesktopIconUI
BasicDesktopPaneUI
BasicDirectoryModel
BasicEditorPaneUI
BasicFileAttributes
BasicFileAttributeView
BasicFileChooserUI
BasicFormattedTextFieldUI
BasicGraphicsUtils
BasicHTML
BasicIconFactory
BasicInternalFrameTitlePane
BasicInternalFrameUI
BasicLabelUI
BasicListUI
BasicLookAndFeel
BasicMenuBarUI
BasicMenuItemUI
BasicMenuUI
BasicOptionPaneUI
BasicOptionPaneUI.ButtonAreaLayout
BasicPanelUI
BasicPasswordFieldUI
BasicPermission
BasicPopupMenuSeparatorUI
BasicPopupMenuUI
BasicProgressBarUI
BasicRadioButtonMenuItemUI
BasicRadioButtonUI
BasicRootPaneUI
BasicScrollBarUI
BasicScrollPaneUI
BasicSeparatorUI
BasicSliderUI
BasicSpinnerUI
BasicSplitPaneDivider
BasicSplitPaneUI
BasicStroke
BasicTabbedPaneUI
BasicTableHeaderUI
BasicTableUI
BasicTextAreaUI
BasicTextFieldUI
BasicTextPaneUI
BasicTextUI
BasicTextUI.BasicCaret
BasicTextUI.BasicHighlighter
BasicToggleButtonUI
BasicToolBarSeparatorUI
BasicToolBarUI
BasicToolTipUI
BasicTreeUI
BasicViewportUI
BatchUpdateException
BeanContext
BeanContextChild
BeanContextChildComponentProxy
BeanContextChildSupport
BeanContextContainerProxy
BeanContextEvent
BeanContextMembershipEvent
BeanContextMembershipListener
BeanContextProxy
BeanContextServiceAvailableEvent
BeanContextServiceProvider
BeanContextServiceProviderBeanInfo
BeanContextServiceRevokedEvent
BeanContextServiceRevokedListener
BeanContextServices
BeanContextServicesListener
BeanContextServicesSupport
BeanContextServicesSupport.BCSSServiceProvider
BeanContextSupport
BeanContextSupport.BCSIterator
BeanDescriptor
BeanInfo
Beans
BevelBorder
Bidi
BigDecimal
BigInteger
BinaryRefAddr
Binder
BindException
Binding
Binding
Binding
BindingHelper
BindingHolder
BindingIterator
BindingIteratorHelper
BindingIteratorHolder
BindingIteratorOperations
BindingIteratorPOA
BindingListHelper
BindingListHolder
BindingProvider
Bindings
BindingType
BindingType
BindingTypeHelper
BindingTypeHolder
BitSet
Blob
BlockingDeque
BlockingQueue
BlockView
BMPImageWriteParam
Book
Boolean
BooleanControl
BooleanControl.Type
BooleanHolder
BooleanSeqHelper
BooleanSeqHolder
Border
BorderFactory
BorderLayout
BorderUIResource
BorderUIResource.BevelBorderUIResource
BorderUIResource.CompoundBorderUIResource
BorderUIResource.EmptyBorderUIResource
BorderUIResource.EtchedBorderUIResource
BorderUIResource.LineBorderUIResource
BorderUIResource.MatteBorderUIResource
BorderUIResource.TitledBorderUIResource
BoundedRangeModel
Bounds
Bounds
Box
Box.Filler
BoxedValueHelper
BoxLayout
BoxView
BreakIterator
BreakIteratorProvider
BrokenBarrierException
Buffer
BufferCapabilities
BufferCapabilities.FlipContents
BufferedImage
BufferedImageFilter
BufferedImageOp
BufferedInputStream
BufferedOutputStream
BufferedReader
BufferedWriter
BufferOverflowException
BufferPoolMXBean
BufferStrategy
BufferUnderflowException
Button
ButtonGroup
ButtonModel
ButtonUI
Byte
ByteArrayInputStream
ByteArrayOutputStream
ByteBuffer
ByteChannel
ByteHolder
ByteLookupTable
ByteOrder
C14NMethodParameterSpec
CachedRowSet
CacheRequest
CacheResponse
Calendar
Callable
CallableStatement
Callback
CallbackHandler
CallSite
CancelablePrintJob
CancellationException
CancelledKeyException
CannotProceed
CannotProceedException
CannotProceedHelper
CannotProceedHolder
CannotRedoException
CannotUndoException
CanonicalizationMethod
Canvas
CardLayout
Caret
CaretEvent
CaretListener
CDATASection
CellEditor
CellEditorListener
CellRendererPane
Certificate
Certificate
Certificate
Certificate.CertificateRep
CertificateEncodingException
CertificateEncodingException
CertificateException
CertificateException
CertificateExpiredException
CertificateExpiredException
CertificateFactory
CertificateFactorySpi
CertificateNotYetValidException
CertificateNotYetValidException
CertificateParsingException
CertificateParsingException
CertificateRevokedException
CertPath
CertPath.CertPathRep
CertPathBuilder
CertPathBuilderException
CertPathBuilderResult
CertPathBuilderSpi
CertPathParameters
CertPathTrustManagerParameters
CertPathValidator
CertPathValidatorException
CertPathValidatorException.BasicReason
CertPathValidatorException.Reason
CertPathValidatorResult
CertPathValidatorSpi
CertSelector
CertStore
CertStoreException
CertStoreParameters
CertStoreSpi
ChangedCharSetException
ChangeEvent
ChangeListener
Channel
ChannelBinding
Channels
Character
Character.Subset
Character.UnicodeBlock
CharacterCodingException
CharacterData
CharacterIterator
Characters
CharArrayReader
CharArrayWriter
CharBuffer
CharConversionException
CharHolder
CharSeqHelper
CharSeqHolder
CharSequence
Charset
CharsetDecoder
CharsetEncoder
CharsetProvider
Checkbox
CheckboxGroup
CheckboxMenuItem
CheckedInputStream
CheckedOutputStream
Checksum
Choice
ChoiceCallback
ChoiceFormat
Chromaticity
Cipher
CipherInputStream
CipherOutputStream
CipherSpi
Class
ClassCastException
ClassCircularityError
ClassDefinition
ClassDesc
ClassFileTransformer
ClassFormatError
ClassLoader
ClassLoaderRepository
ClassLoadingMXBean
ClassNotFoundException
ClientContext
ClientInfoStatus
ClientRequestInfo
ClientRequestInfoOperations
ClientRequestInterceptor
ClientRequestInterceptorOperations
Clip
Clipboard
ClipboardOwner
Clob
Cloneable
CloneNotSupportedException
Closeable
ClosedByInterruptException
ClosedChannelException
ClosedDirectoryStreamException
ClosedFileSystemException
ClosedSelectorException
ClosedWatchServiceException
CMMException
Codec
CodecFactory
CodecFactoryHelper
CodecFactoryOperations
CodecOperations
CoderMalfunctionError
CoderResult
CODESET_INCOMPATIBLE
CodeSets
CodeSigner
CodeSource
CodingErrorAction
CollapsedStringAdapter
CollationElementIterator
CollationKey
Collator
CollatorProvider
Collection
CollectionCertStoreParameters
Collections
Color
ColorChooserComponentFactory
ColorChooserUI
ColorConvertOp
ColorModel
ColorSelectionModel
ColorSpace
ColorSupported
ColorType
ColorUIResource
ComboBoxEditor
ComboBoxModel
ComboBoxUI
ComboPopup
COMM_FAILURE
CommandInfo
CommandMap
CommandObject
Comment
Comment
CommonDataSource
CommunicationException
Comparable
Comparator
Compilable
CompilationMXBean
CompiledScript
Compiler
Completion
CompletionHandler
Completions
CompletionService
CompletionStatus
CompletionStatusHelper
Component
Component.BaselineResizeBehavior
ComponentAdapter
ComponentColorModel
ComponentEvent
ComponentIdHelper
ComponentInputMap
ComponentInputMapUIResource
ComponentListener
ComponentOrientation
ComponentSampleModel
ComponentUI
ComponentView
Composite
CompositeContext
CompositeData
CompositeDataInvocationHandler
CompositeDataSupport
CompositeDataView
CompositeName
CompositeType
CompositeView
CompoundBorder
CompoundControl
CompoundControl.Type
CompoundEdit
CompoundName
Compression
ConcurrentHashMap
ConcurrentLinkedQueue
ConcurrentMap
ConcurrentModificationException
ConcurrentNavigableMap
ConcurrentSkipListMap
ConcurrentSkipListSet
Condition
Configuration
Configuration.Parameters
ConfigurationException
ConfigurationSpi
ConfirmationCallback
ConnectException
ConnectException
ConnectIOException
Connection
ConnectionEvent
ConnectionEventListener
ConnectionPendingException
ConnectionPoolDataSource
Console
ConsoleHandler
Constructor
ConstructorProperties
Container
ContainerAdapter
ContainerEvent
ContainerListener
ContainerOrderFocusTraversalPolicy
ContentHandler
ContentHandler
ContentHandlerFactory
ContentModel
Context
Context
ContextList
ContextNotEmptyException
ContextualRenderedImageFactory
Control
Control
Control.Type
ControlFactory
ControllerEventListener
ConvolveOp
CookieHandler
CookieHolder
CookieManager
CookiePolicy
CookieStore
Copies
CopiesSupported
CopyOnWriteArrayList
CopyOnWriteArraySet
CopyOption
CountDownLatch
CounterMonitor
CounterMonitorMBean
CRC32
CredentialException
CredentialExpiredException
CredentialNotFoundException
CRL
CRLException
CRLReason
CRLSelector
CropImageFilter
CSS
CSS.Attribute
CTX_RESTRICT_SCOPE
CubicCurve2D
CubicCurve2D.Double
CubicCurve2D.Float
Currency
CurrencyNameProvider
Current
Current
Current
CurrentHelper
CurrentHelper
CurrentHelper
CurrentHolder
CurrentOperations
CurrentOperations
CurrentOperations
Cursor
Customizer
CustomMarshal
CustomValue
CyclicBarrier
Data
DATA_CONVERSION
DatabaseMetaData
DataBindingException
DataBuffer
DataBufferByte
DataBufferDouble
DataBufferFloat
DataBufferInt
DataBufferShort
DataBufferUShort
DataContentHandler
DataContentHandlerFactory
DataFlavor
DataFormatException
DatagramChannel
DatagramPacket
DatagramSocket
DatagramSocketImpl
DatagramSocketImplFactory
DataHandler
DataInput
DataInputStream
DataInputStream
DataLine
DataLine.Info
DataOutput
DataOutputStream
DataOutputStream
DataSource
DataSource
DataTruncation
DatatypeConfigurationException
DatatypeConstants
DatatypeConstants.Field
DatatypeConverter
DatatypeConverterInterface
DatatypeFactory
Date
Date
DateFormat
DateFormat.Field
DateFormatProvider
DateFormatSymbols
DateFormatSymbolsProvider
DateFormatter
DateTimeAtCompleted
DateTimeAtCreation
DateTimeAtProcessing
DateTimeSyntax
DebugGraphics
DecimalFormat
DecimalFormatSymbols
DecimalFormatSymbolsProvider
DeclaredType
DeclHandler
DefaultBoundedRangeModel
DefaultButtonModel
DefaultCaret
DefaultCellEditor
DefaultColorSelectionModel
DefaultComboBoxModel
DefaultDesktopManager
DefaultEditorKit
DefaultEditorKit.BeepAction
DefaultEditorKit.CopyAction
DefaultEditorKit.CutAction
DefaultEditorKit.DefaultKeyTypedAction
DefaultEditorKit.InsertBreakAction
DefaultEditorKit.InsertContentAction
DefaultEditorKit.InsertTabAction
DefaultEditorKit.PasteAction
DefaultFocusManager
DefaultFocusTraversalPolicy
DefaultFormatter
DefaultFormatterFactory
DefaultHandler
DefaultHandler2
DefaultHighlighter
DefaultHighlighter.DefaultHighlightPainter
DefaultKeyboardFocusManager
DefaultListCellRenderer
DefaultListCellRenderer.UIResource
DefaultListModel
DefaultListSelectionModel
DefaultLoaderRepository
DefaultLoaderRepository
DefaultMenuLayout
DefaultMetalTheme
DefaultMutableTreeNode
DefaultPersistenceDelegate
DefaultRowSorter
DefaultRowSorter.ModelWrapper
DefaultSingleSelectionModel
DefaultStyledDocument
DefaultStyledDocument.AttributeUndoableEdit
DefaultStyledDocument.ElementSpec
DefaultTableCellRenderer
DefaultTableCellRenderer.UIResource
DefaultTableColumnModel
DefaultTableModel
DefaultTextUI
DefaultTreeCellEditor
DefaultTreeCellRenderer
DefaultTreeModel
DefaultTreeSelectionModel
DefaultValidationEventHandler
DefinitionKind
DefinitionKindHelper
Deflater
DeflaterInputStream
DeflaterOutputStream
Delayed
DelayQueue
Delegate
Delegate
Delegate
DelegationPermission
Deprecated
Deque
Description
Descriptor
DescriptorAccess
DescriptorFields
DescriptorKey
DescriptorRead
DescriptorSupport
DESedeKeySpec
DesignMode
DESKeySpec
Desktop
Desktop.Action
DesktopIconUI
DesktopManager
DesktopPaneUI
Destination
Destroyable
DestroyFailedException
Detail
DetailEntry
DGC
DHGenParameterSpec
DHKey
DHParameterSpec
DHPrivateKey
DHPrivateKeySpec
DHPublicKey
DHPublicKeySpec
Diagnostic
Diagnostic.Kind
DiagnosticCollector
DiagnosticListener
Dialog
Dialog.ModalExclusionType
Dialog.ModalityType
DialogTypeSelection
Dictionary
DigestException
DigestInputStream
DigestMethod
DigestMethodParameterSpec
DigestOutputStream
Dimension
Dimension2D
DimensionUIResource
DirContext
DirectColorModel
DirectoryManager
DirectoryNotEmptyException
DirectoryStream
DirectoryStream.Filter
DirectoryStreamFilters
DirObjectFactory
DirStateFactory
DirStateFactory.Result
DISCARDING
Dispatch
DisplayMode
DnDConstants
Doc
DocAttribute
DocAttributeSet
DocFlavor
DocFlavor.BYTE_ARRAY
DocFlavor.CHAR_ARRAY
DocFlavor.INPUT_STREAM
DocFlavor.READER
DocFlavor.SERVICE_FORMATTED
DocFlavor.STRING
DocFlavor.URL
DocPrintJob
Document
Document
DocumentBuilder
DocumentBuilderFactory
Documented
DocumentEvent
DocumentEvent
DocumentEvent.ElementChange
DocumentEvent.EventType
DocumentFilter
DocumentFilter.FilterBypass
DocumentFragment
DocumentHandler
DocumentListener
DocumentName
DocumentParser
DocumentType
DomainCombiner
DomainManager
DomainManagerOperations
DOMConfiguration
DOMCryptoContext
DOMError
DOMErrorHandler
DOMException
DomHandler
DOMImplementation
DOMImplementationList
DOMImplementationLS
DOMImplementationRegistry
DOMImplementationSource
DOMLocator
DOMLocator
DOMResult
DOMSignContext
DOMSource
DOMStringList
DOMStructure
DOMURIReference
DOMValidateContext
DosFileAttributes
DosFileAttributeView
Double
DoubleBuffer
DoubleHolder
DoubleSeqHelper
DoubleSeqHolder
DragGestureEvent
DragGestureListener
DragGestureRecognizer
DragSource
DragSourceAdapter
DragSourceContext
DragSourceDragEvent
DragSourceDropEvent
DragSourceEvent
DragSourceListener
DragSourceMotionListener
Driver
DriverManager
DriverPropertyInfo
DropMode
DropTarget
DropTarget.DropTargetAutoScroller
DropTargetAdapter
DropTargetContext
DropTargetDragEvent
DropTargetDropEvent
DropTargetEvent
DropTargetListener
DSAKey
DSAKeyPairGenerator
DSAParameterSpec
DSAParams
DSAPrivateKey
DSAPrivateKeySpec
DSAPublicKey
DSAPublicKeySpec
DTD
DTD
DTDConstants
DTDHandler
DuplicateFormatFlagsException
DuplicateName
DuplicateNameHelper
Duration
DynamicImplementation
DynamicImplementation
DynamicMBean
DynamicWrapperMBean
DynAny
DynAny
DynAnyFactory
DynAnyFactoryHelper
DynAnyFactoryOperations
DynAnyHelper
DynAnyOperations
DynAnySeqHelper
DynArray
DynArray
DynArrayHelper
DynArrayOperations
DynEnum
DynEnum
DynEnumHelper
DynEnumOperations
DynFixed
DynFixed
DynFixedHelper
DynFixedOperations
DynSequence
DynSequence
DynSequenceHelper
DynSequenceOperations
DynStruct
DynStruct
DynStructHelper
DynStructOperations
DynUnion
DynUnion
DynUnionHelper
DynUnionOperations
DynValue
DynValue
DynValueBox
DynValueBoxOperations
DynValueCommon
DynValueCommonOperations
DynValueHelper
DynValueOperations
ECField
ECFieldF2m
ECFieldFp
ECGenParameterSpec
ECKey
ECParameterSpec
ECPoint
ECPrivateKey
ECPrivateKeySpec
ECPublicKey
ECPublicKeySpec
EditorKit
Element
Element
Element
Element
Element
ElementFilter
ElementIterator
ElementKind
ElementKindVisitor6
Elements
ElementScanner6
ElementType
ElementVisitor
Ellipse2D
Ellipse2D.Double
Ellipse2D.Float
EllipticCurve
EmptyBorder
EmptyStackException
EncodedKeySpec
Encoder
Encoding
ENCODING_CDR_ENCAPS
EncryptedPrivateKeyInfo
EndDocument
EndElement
Endpoint
EndpointReference
Entity
Entity
EntityDeclaration
EntityReference
EntityReference
EntityResolver
EntityResolver2
Enum
EnumConstantNotPresentException
EnumControl
EnumControl.Type
Enumeration
EnumMap
EnumSet
EnumSyntax
Environment
EOFException
Error
ErrorHandler
ErrorListener
ErrorManager
ErrorType
EtchedBorder
Event
Event
EventClient
EventClientDelegate
EventClientDelegateMBean
EventClientNotFoundException
EventConsumer
EventContext
EventDirContext
EventException
EventFilter
EventForwarder
EventHandler
EventListener
EventListener
EventListenerList
EventListenerProxy
EventObject
EventQueue
EventReaderDelegate
EventReceiver
EventRelay
EventSetDescriptor
EventSubscriber
EventTarget
ExcC14NParameterSpec
Exception
ExceptionDetailMessage
ExceptionInInitializerError
ExceptionList
ExceptionListener
Exchanger
ExecutableElement
ExecutableType
ExecutionException
Executor
ExecutorCompletionService
Executors
ExecutorService
ExemptionMechanism
ExemptionMechanismException
ExemptionMechanismSpi
ExpandVetoException
ExportException
Expression
ExtendedRequest
ExtendedResponse
Extension
Externalizable
FactoryConfigurationError
FactoryConfigurationError
FailedLoginException
FaultAction
FeatureDescriptor
FetchingEventForwarder
FetchingEventRelay
Fidelity
Field
FieldNameHelper
FieldNameHelper
FieldPosition
FieldView
File
FileAction
FileAlreadyExistsException
FileAttribute
FileAttributeView
FileCacheImageInputStream
FileCacheImageOutputStream
FileChannel
FileChannel.MapMode
FileChooserUI
FileDataSource
FileDescriptor
FileDialog
FileFilter
FileFilter
FileHandler
FileImageInputStream
FileImageOutputStream
FileInputStream
FileLock
FileLockInterruptionException
FileNameExtensionFilter
FilenameFilter
FileNameMap
FileNotFoundException
FileObject
FileOutputStream
FileOwnerAttributeView
FilePermission
Filer
FileReader
FileRef
FilerException
Files
FileStore
FileStoreAttributeView
FileStoreSpaceAttributes
FileStoreSpaceAttributeView
FileSystem
FileSystemAlreadyExistsException
FileSystemException
FileSystemNotFoundException
FileSystemProvider
FileSystems
FileSystemView
FileTypeDetector
FileTypeMap
FileView
FileVisitOption
FileVisitor
FileVisitResult
FileWriter
Filter
FilteredImageSource
FilteredRowSet
FilterInputStream
FilterOutputStream
FilterReader
FilterWriter
Finishings
FixedHeightLayoutCache
FixedHolder
FlatteningPathIterator
FlavorEvent
FlavorException
FlavorListener
FlavorMap
FlavorTable
Float
FloatBuffer
FloatControl
FloatControl.Type
FloatHolder
FloatSeqHelper
FloatSeqHolder
FlowLayout
FlowView
FlowView.FlowStrategy
Flushable
FocusAdapter
FocusEvent
FocusListener
FocusManager
FocusTraversalPolicy
Font
FontFormatException
FontMetrics
FontRenderContext
FontUIResource
Format
Format.Field
FormatConversionProvider
FormatFlagsConversionMismatchException
FormatMismatch
FormatMismatchHelper
Formattable
FormattableFlags
Formatter
Formatter
Formatter.BigDecimalLayoutForm
FormatterClosedException
FormSubmitEvent
FormSubmitEvent.MethodType
FormView
ForwardingFileObject
ForwardingJavaFileManager
ForwardingJavaFileObject
ForwardRequest
ForwardRequest
ForwardRequestHelper
ForwardRequestHelper
Frame
FREE_MEM
Future
FutureTask
GapContent
GarbageCollectorMXBean
GatheringByteChannel
GaugeMonitor
GaugeMonitorMBean
GeneralPath
GeneralSecurityException
Generated
GenericArrayType
GenericDeclaration
GenericMBeanException
GenericSignatureFormatError
GlyphJustificationInfo
GlyphMetrics
GlyphVector
GlyphView
GlyphView.GlyphPainter
GradientPaint
GraphicAttribute
Graphics
Graphics2D
GraphicsConfigTemplate
GraphicsConfiguration
GraphicsDevice
GraphicsDevice.WindowTranslucency
GraphicsEnvironment
GrayFilter
GregorianCalendar
GridBagConstraints
GridBagLayout
GridBagLayoutInfo
GridLayout
Group
GroupLayout
GroupLayout.Alignment
GroupPrincipal
GSSContext
GSSCredential
GSSException
GSSManager
GSSName
Guard
GuardedObject
GZIPInputStream
GZIPOutputStream
Handler
Handler
HandlerBase
HandlerChain
HandlerResolver
HandshakeCompletedEvent
HandshakeCompletedListener
HasControls
HashAttributeSet
HashDocAttributeSet
HashMap
HashPrintJobAttributeSet
HashPrintRequestAttributeSet
HashPrintServiceAttributeSet
HashSet
Hashtable
HeadlessException
HexBinaryAdapter
HierarchyBoundsAdapter
HierarchyBoundsListener
HierarchyEvent
HierarchyListener
Highlighter
Highlighter.Highlight
Highlighter.HighlightPainter
HMACParameterSpec
Holder
HOLDING
HostnameVerifier
HTML
HTML.Attribute
HTML.Tag
HTML.UnknownTag
HTMLDocument
HTMLDocument.Iterator
HTMLEditorKit
HTMLEditorKit.HTMLFactory
HTMLEditorKit.HTMLTextAction
HTMLEditorKit.InsertHTMLTextAction
HTMLEditorKit.LinkController
HTMLEditorKit.Parser
HTMLEditorKit.ParserCallback
HTMLFrameHyperlinkEvent
HTMLWriter
HTTPBinding
HttpCookie
HTTPException
HttpRetryException
HttpsURLConnection
HttpURLConnection
HyperlinkEvent
HyperlinkEvent.EventType
HyperlinkListener
ICC_ColorSpace
ICC_Profile
ICC_ProfileGray
ICC_ProfileRGB
Icon
IconUIResource
IconView
ID_ASSIGNMENT_POLICY_ID
ID_UNIQUENESS_POLICY_ID
IdAssignmentPolicy
IdAssignmentPolicyOperations
IdAssignmentPolicyValue
IdentifierHelper
Identity
IdentityHashMap
IdentityMBeanServerForwarder
IdentityScope
IDLEntity
IDLType
IDLTypeHelper
IDLTypeOperations
IDN
IdUniquenessPolicy
IdUniquenessPolicyOperations
IdUniquenessPolicyValue
IIOByteBuffer
IIOException
IIOImage
IIOInvalidTreeException
IIOMetadata
IIOMetadataController
IIOMetadataFormat
IIOMetadataFormatImpl
IIOMetadataNode
IIOParam
IIOParamController
IIOReadProgressListener
IIOReadUpdateListener
IIOReadWarningListener
IIORegistry
IIOServiceProvider
IIOWriteProgressListener
IIOWriteWarningListener
IllegalAccessError
IllegalAccessException
IllegalArgumentException
IllegalBlockingModeException
IllegalBlockSizeException
IllegalChannelGroupException
IllegalCharsetNameException
IllegalClassFormatException
IllegalComponentStateException
IllegalFormatCodePointException
IllegalFormatConversionException
IllegalFormatException
IllegalFormatFlagsException
IllegalFormatPrecisionException
IllegalFormatWidthException
IllegalMonitorStateException
IllegalPathStateException
IllegalSelectorException
IllegalStateException
IllegalThreadStateException
Image
ImageCapabilities
ImageConsumer
ImageFilter
ImageGraphicAttribute
ImageIcon
ImageInputStream
ImageInputStreamImpl
ImageInputStreamSpi
ImageIO
ImageObserver
ImageOutputStream
ImageOutputStreamImpl
ImageOutputStreamSpi
ImageProducer
ImageReader
ImageReaderSpi
ImageReaderWriterSpi
ImageReadParam
ImageTranscoder
ImageTranscoderSpi
ImageTypeSpecifier
ImageView
ImageWriteParam
ImageWriter
ImageWriterSpi
ImagingOpException
ImmutableDescriptor
IMP_LIMIT
Impact
IMPLICIT_ACTIVATION_POLICY_ID
ImplicitActivationPolicy
ImplicitActivationPolicyOperations
ImplicitActivationPolicyValue
INACTIVE
IncompatibleClassChangeError
IncompleteAnnotationException
InconsistentTypeCode
InconsistentTypeCode
InconsistentTypeCodeHelper
IndexColorModel
IndexedPropertyChangeEvent
IndexedPropertyDescriptor
IndexOutOfBoundsException
IndirectionException
Inet4Address
Inet6Address
InetAddress
InetSocketAddress
Inflater
InflaterInputStream
InflaterOutputStream
InheritableThreadLocal
Inherited
InitialContext
InitialContextFactory
InitialContextFactoryBuilder
InitialDirContext
INITIALIZE
InitialLdapContext
InitParam
InlineView
InputContext
InputEvent
InputMap
InputMapUIResource
InputMethod
InputMethodContext
InputMethodDescriptor
InputMethodEvent
InputMethodHighlight
InputMethodListener
InputMethodRequests
InputMismatchException
InputSource
InputStream
InputStream
InputStream
InputStreamReader
InputSubset
InputVerifier
Insets
InsetsUIResource
InstanceAlreadyExistsException
InstanceNotFoundException
InstantiationError
InstantiationException
Instrument
Instrumentation
InsufficientResourcesException
IntBuffer
Integer
IntegerSyntax
Interceptor
InterceptorOperations
InterfaceAddress
INTERNAL
InternalError
InternalFrameAdapter
InternalFrameEvent
InternalFrameFocusTraversalPolicy
InternalFrameListener
InternalFrameUI
InternationalFormatter
InterruptedByTimeoutException
InterruptedException
InterruptedIOException
InterruptedNamingException
InterruptibleChannel
INTF_REPOS
IntHolder
IntrospectionException
IntrospectionException
Introspector
INV_FLAG
INV_IDENT
INV_OBJREF
INV_POLICY
Invalid
INVALID_ACTIVITY
INVALID_TRANSACTION
InvalidActivityException
InvalidAddress
InvalidAddressHelper
InvalidAddressHolder
InvalidAlgorithmParameterException
InvalidApplicationException
InvalidAttributeIdentifierException
InvalidAttributesException
InvalidAttributeValueException
InvalidAttributeValueException
InvalidClassException
InvalidDnDOperationException
InvalidKeyException
InvalidKeyException
InvalidKeySpecException
InvalidMarkException
InvalidMidiDataException
InvalidName
InvalidName
InvalidName
InvalidNameException
InvalidNameHelper
InvalidNameHelper
InvalidNameHolder
InvalidObjectException
InvalidOpenTypeException
InvalidParameterException
InvalidParameterSpecException
InvalidPathException
InvalidPolicy
InvalidPolicyHelper
InvalidPreferencesFormatException
InvalidPropertiesFormatException
InvalidRelationIdException
InvalidRelationServiceException
InvalidRelationTypeException
InvalidRoleInfoException
InvalidRoleValueException
InvalidSearchControlsException
InvalidSearchFilterException
InvalidSeq
InvalidSlot
InvalidSlotHelper
InvalidTargetObjectTypeException
InvalidTransactionException
InvalidTypeForEncoding
InvalidTypeForEncodingHelper
InvalidValue
InvalidValue
InvalidValueHelper
Invocable
InvocationEvent
InvocationHandler
InvocationTargetException
InvokeDynamic
InvokeDynamicBootstrapError
InvokeHandler
IOError
IOException
IOR
IORHelper
IORHolder
IORInfo
IORInfoOperations
IORInterceptor
IORInterceptor_3_0
IORInterceptor_3_0Helper
IORInterceptor_3_0Holder
IORInterceptor_3_0Operations
IORInterceptorOperations
IRObject
IRObjectOperations
IstringHelper
ItemEvent
ItemListener
ItemSelectable
Iterable
Iterator
IvParameterSpec
JApplet
JarEntry
JarException
JarFile
JarInputStream
JarOutputStream
JarURLConnection
JavaCompiler
JavaCompiler.CompilationTask
JavaFileManager
JavaFileManager.Location
JavaFileObject
JavaFileObject.Kind
JavaMethodHandle
JAXB
JAXBContext
JAXBElement
JAXBElement.GlobalScope
JAXBException
JAXBIntrospector
JAXBResult
JAXBSource
JButton
JCheckBox
JCheckBoxMenuItem
JColorChooser
JComboBox
JComboBox.KeySelectionManager
JComponent
JdbcRowSet
JDesktopPane
JDialog
JEditorPane
JFileChooser
JFormattedTextField
JFormattedTextField.AbstractFormatter
JFormattedTextField.AbstractFormatterFactory
JFrame
JInternalFrame
JInternalFrame.JDesktopIcon
JLabel
JLayeredPane
JList
JList.DropLocation
JMenu
JMenuBar
JMenuItem
JMException
JMRuntimeException
JMX
JMX.MBeanOptions
JMX.ProxyOptions
JMXAddressable
JMXAuthenticator
JMXConnectionNotification
JMXConnector
JMXConnectorFactory
JMXConnectorProvider
JMXConnectorServer
JMXConnectorServerFactory
JMXConnectorServerMBean
JMXConnectorServerProvider
JMXDomain
JMXNamespace
JMXNamespaceMBean
JMXNamespacePermission
JMXNamespaces
JMXNamespaceView
JMXPrincipal
JMXProviderException
JMXRemoteNamespace
JMXRemoteNamespaceMBean
JMXServerErrorException
JMXServiceURL
JobAttributes
JobAttributes.DefaultSelectionType
JobAttributes.DestinationType
JobAttributes.DialogType
JobAttributes.MultipleDocumentHandlingType
JobAttributes.SidesType
JobHoldUntil
JobImpressions
JobImpressionsCompleted
JobImpressionsSupported
JobKOctets
JobKOctetsProcessed
JobKOctetsSupported
JobMediaSheets
JobMediaSheetsCompleted
JobMediaSheetsSupported
JobMessageFromOperator
JobName
JobOriginatingUserName
JobPriority
JobPrioritySupported
JobSheets
JobState
JobStateReason
JobStateReasons
Joinable
JoinRowSet
JOptionPane
JPanel
JPasswordField
JPEGHuffmanTable
JPEGImageReadParam
JPEGImageWriteParam
JPEGQTable
JPopupMenu
JPopupMenu.Separator
JProgressBar
JRadioButton
JRadioButtonMenuItem
JRootPane
JScrollBar
JScrollPane
JSeparator
JSlider
JSpinner
JSpinner.DateEditor
JSpinner.DefaultEditor
JSpinner.ListEditor
JSpinner.NumberEditor
JSplitPane
JTabbedPane
JTable
JTable.DropLocation
JTable.PrintMode
JTableHeader
JTextArea
JTextComponent
JTextComponent.DropLocation
JTextComponent.KeyBinding
JTextField
JTextPane
JToggleButton
JToggleButton.ToggleButtonModel
JToolBar
JToolBar.Separator
JToolTip
JTree
JTree.DropLocation
JTree.DynamicUtilTreeNode
JTree.EmptySelectionModel
JViewport
JWindow
KerberosKey
KerberosPrincipal
KerberosTicket
Kernel
Key
KeyAdapter
KeyAgreement
KeyAgreementSpi
KeyAlreadyExistsException
KeyboardFocusManager
KeyEvent
KeyEventDispatcher
KeyEventPostProcessor
KeyException
KeyFactory
KeyFactorySpi
KeyGenerator
KeyGeneratorSpi
KeyInfo
KeyInfoFactory
KeyListener
KeyManagementException
KeyManager
KeyManagerFactory
KeyManagerFactorySpi
Keymap
KeyName
KeyPair
KeyPairGenerator
KeyPairGeneratorSpi
KeyRep
KeyRep.Type
KeySelector
KeySelector.Purpose
KeySelectorException
KeySelectorResult
KeySpec
KeyStore
KeyStore.Builder
KeyStore.CallbackHandlerProtection
KeyStore.Entry
KeyStore.LoadStoreParameter
KeyStore.PasswordProtection
KeyStore.PrivateKeyEntry
KeyStore.ProtectionParameter
KeyStore.SecretKeyEntry
KeyStore.TrustedCertificateEntry
KeyStoreBuilderParameters
KeyStoreException
KeyStoreSpi
KeyStroke
KeyValue
Label
LabelUI
LabelView
LanguageCallback
LastOwnerException
LayeredHighlighter
LayeredHighlighter.LayerPainter
LayoutFocusTraversalPolicy
LayoutManager
LayoutManager2
LayoutPath
LayoutQueue
LayoutStyle
LayoutStyle.ComponentPlacement
LDAPCertStoreParameters
LdapContext
LdapName
LdapReferralException
Lease
Level
LexicalHandler
LIFESPAN_POLICY_ID
LifespanPolicy
LifespanPolicyOperations
LifespanPolicyValue
LimitExceededException
Line
Line.Info
Line2D
Line2D.Double
Line2D.Float
LinearGradientPaint
LineBorder
LineBreakMeasurer
LineEvent
LineEvent.Type
LineListener
LineMetrics
LineNumberInputStream
LineNumberReader
LineUnavailableException
Linkage
LinkageError
LinkagePermission
LinkedBlockingDeque
LinkedBlockingQueue
LinkedHashMap
LinkedHashSet
LinkedList
LinkException
LinkLoopException
LinkOption
LinkPermission
LinkRef
List
List
ListCellRenderer
ListDataEvent
ListDataListener
ListenerInfo
ListenerNotFoundException
ListIterator
ListModel
ListResourceBundle
ListSelectionEvent
ListSelectionListener
ListSelectionModel
ListUI
ListView
LoaderHandler
Locale
LocaleNameProvider
LocaleServiceProvider
LocalObject
LocateRegistry
Location
LOCATION_FORWARD
Locator
Locator2
Locator2Impl
LocatorImpl
Lock
LockInfo
LockSupport
Logger
LoggingMXBean
LoggingPermission
LogicalHandler
LogicalMessage
LogicalMessageContext
LoginContext
LoginException
LoginModule
LogManager
LogRecord
LogStream
Long
LongBuffer
LongHolder
LongLongSeqHelper
LongLongSeqHolder
LongSeqHelper
LongSeqHolder
LookAndFeel
LookupOp
LookupTable
LSException
LSInput
LSLoadEvent
LSOutput
LSParser
LSParserFilter
LSProgressEvent
LSResourceResolver
LSSerializer
LSSerializerFilter
Mac
MacSpi
MailcapCommandMap
MalformedInputException
MalformedLinkException
MalformedObjectNameException
MalformedParameterizedTypeException
MalformedURLException
ManagedAttribute
ManagedOperation
ManagementFactory
ManagementPermission
ManageReferralControl
ManagerFactoryParameters
Manifest
Manifest
Map
Map.Entry
MappedByteBuffer
MARSHAL
MarshalException
MarshalException
MarshalException
MarshalledObject
Marshaller
Marshaller.Listener
MaskFormatter
Matcher
MatchResult
Math
MathContext
MatteBorder
MBean
MBeanAttributeInfo
MBeanConstructorInfo
MBeanException
MBeanFeatureInfo
MBeanInfo
MBeanNotificationInfo
MBeanOperationInfo
MBeanParameterInfo
MBeanPermission
MBeanRegistration
MBeanRegistrationException
MBeanServer
MBeanServerBuilder
MBeanServerConnection
MBeanServerConnectionWrapper
MBeanServerDelegate
MBeanServerDelegateMBean
MBeanServerFactory
MBeanServerForwarder
MBeanServerInvocationHandler
MBeanServerNotification
MBeanServerNotificationFilter
MBeanServerPermission
MBeanServerSupport
MBeanTrustPermission
Media
MediaName
MediaPrintableArea
MediaSize
MediaSize.Engineering
MediaSize.ISO
MediaSize.JIS
MediaSize.NA
MediaSize.Other
MediaSizeName
MediaTracker
MediaTray
Member
MembershipKey
MemoryCacheImageInputStream
MemoryCacheImageOutputStream
MemoryHandler
MemoryImageSource
MemoryManagerMXBean
MemoryMXBean
MemoryNotificationInfo
MemoryPoolMXBean
MemoryType
MemoryUsage
Menu
MenuBar
MenuBarUI
MenuComponent
MenuContainer
MenuDragMouseEvent
MenuDragMouseListener
MenuElement
MenuEvent
MenuItem
MenuItemUI
MenuKeyEvent
MenuKeyListener
MenuListener
MenuSelectionManager
MenuShortcut
MessageContext
MessageContext.Scope
MessageDigest
MessageDigestSpi
MessageFactory
MessageFormat
MessageFormat.Field
MessageProp
Messager
MetaEventListener
MetalBorders
MetalBorders.ButtonBorder
MetalBorders.Flush3DBorder
MetalBorders.InternalFrameBorder
MetalBorders.MenuBarBorder
MetalBorders.MenuItemBorder
MetalBorders.OptionDialogBorder
MetalBorders.PaletteBorder
MetalBorders.PopupMenuBorder
MetalBorders.RolloverButtonBorder
MetalBorders.ScrollPaneBorder
MetalBorders.TableHeaderBorder
MetalBorders.TextFieldBorder
MetalBorders.ToggleButtonBorder
MetalBorders.ToolBarBorder
MetalButtonUI
MetalCheckBoxIcon
MetalCheckBoxUI
MetalComboBoxButton
MetalComboBoxEditor
MetalComboBoxEditor.UIResource
MetalComboBoxIcon
MetalComboBoxUI
MetalDesktopIconUI
MetalFileChooserUI
MetalIconFactory
MetalIconFactory.FileIcon16
MetalIconFactory.FolderIcon16
MetalIconFactory.PaletteCloseIcon
MetalIconFactory.TreeControlIcon
MetalIconFactory.TreeFolderIcon
MetalIconFactory.TreeLeafIcon
MetalInternalFrameTitlePane
MetalInternalFrameUI
MetalLabelUI
MetalLookAndFeel
MetalMenuBarUI
MetalPopupMenuSeparatorUI
MetalProgressBarUI
MetalRadioButtonUI
MetalRootPaneUI
MetalScrollBarUI
MetalScrollButton
MetalScrollPaneUI
MetalSeparatorUI
MetalSliderUI
MetalSplitPaneUI
MetalTabbedPaneUI
MetalTextFieldUI
MetalTheme
MetalToggleButtonUI
MetalToolBarUI
MetalToolTipUI
MetalTreeUI
MetaMessage
Method
MethodDescriptor
MethodHandle
MethodHandles
MethodHandles.Lookup
MethodType
MGF1ParameterSpec
MidiChannel
MidiDevice
MidiDevice.Info
MidiDeviceProvider
MidiEvent
MidiFileFormat
MidiFileReader
MidiFileWriter
MidiMessage
MidiSystem
MidiUnavailableException
MimeHeader
MimeHeaders
MimeType
MimeTypeParameterList
MimeTypeParseException
MimeTypeParseException
MimetypesFileTypeMap
MinimalHTMLWriter
MirroredTypeException
MirroredTypesException
MissingFormatArgumentException
MissingFormatWidthException
MissingResourceException
Mixer
Mixer.Info
MixerProvider
MLet
MLetContent
MLetMBean
ModelMBean
ModelMBeanAttributeInfo
ModelMBeanConstructorInfo
ModelMBeanInfo
ModelMBeanInfoSupport
ModelMBeanNotificationBroadcaster
ModelMBeanNotificationInfo
ModelMBeanOperationInfo
ModificationItem
Modifier
Modifier
Monitor
MonitorInfo
MonitorMBean
MonitorNotification
MonitorSettingException
MouseAdapter
MouseDragGestureRecognizer
MouseEvent
MouseEvent
MouseInfo
MouseInputAdapter
MouseInputListener
MouseListener
MouseMotionAdapter
MouseMotionListener
MouseWheelEvent
MouseWheelListener
MTOM
MTOMFeature
MultiButtonUI
MulticastChannel
MulticastSocket
MultiColorChooserUI
MultiComboBoxUI
MultiDesktopIconUI
MultiDesktopPaneUI
MultiDoc
MultiDocPrintJob
MultiDocPrintService
MultiFileChooserUI
MultiInternalFrameUI
MultiLabelUI
MultiListUI
MultiLookAndFeel
MultiMenuBarUI
MultiMenuItemUI
MultiOptionPaneUI
MultiPanelUI
MultiPixelPackedSampleModel
MultipleComponentProfileHelper
MultipleComponentProfileHolder
MultipleDocumentHandling
MultipleGradientPaint
MultipleGradientPaint.ColorSpaceType
MultipleGradientPaint.CycleMethod
MultipleMaster
MultiPopupMenuUI
MultiProgressBarUI
MultiRootPaneUI
MultiScrollBarUI
MultiScrollPaneUI
MultiSeparatorUI
MultiSliderUI
MultiSpinnerUI
MultiSplitPaneUI
MultiTabbedPaneUI
MultiTableHeaderUI
MultiTableUI
MultiTextUI
MultiToolBarUI
MultiToolTipUI
MultiTreeUI
MultiViewportUI
MutableAttributeSet
MutableComboBoxModel
MutableTreeNode
MutationEvent
MXBean
MXBeanMapping
MXBeanMappingClass
MXBeanMappingFactory
MXBeanMappingFactoryClass
Name
Name
Name
NameAlreadyBoundException
NameCallback
NameClassPair
NameComponent
NameComponentHelper
NameComponentHolder
NamedNodeMap
NamedValue
NameDynAnyPair
NameDynAnyPairHelper
NameDynAnyPairSeqHelper
NameHelper
NameHolder
NameList
NameNotFoundException
NameParser
Namespace
NamespaceChangeListener
NamespaceContext
NamespaceSupport
NameValuePair
NameValuePair
NameValuePairHelper
NameValuePairHelper
NameValuePairSeqHelper
Naming
NamingContext
NamingContextExt
NamingContextExtHelper
NamingContextExtHolder
NamingContextExtOperations
NamingContextExtPOA
NamingContextHelper
NamingContextHolder
NamingContextOperations
NamingContextPOA
NamingEnumeration
NamingEvent
NamingException
NamingExceptionEvent
NamingListener
NamingManager
NamingSecurityException
NavigableMap
NavigableSet
NavigationFilter
NavigationFilter.FilterBypass
NClob
NegativeArraySizeException
NestingKind
NetPermission
NetworkChannel
NetworkInterface
NO_IMPLEMENT
NO_MEMORY
NO_PERMISSION
NO_RESOURCES
NO_RESPONSE
NoAccessException
NoClassDefFoundError
NoConnectionPendingException
NoContext
NoContextHelper
Node
Node
NodeChangeEvent
NodeChangeListener
NodeList
NodeSetData
NoInitialContextException
NON_EXISTENT
NoninvertibleTransformException
NonReadableChannelException
NonWritableChannelException
NoPermissionException
NormalizedStringAdapter
Normalizer
Normalizer.Form
NoRouteToHostException
NoServant
NoServantHelper
NoSuchAlgorithmException
NoSuchAttributeException
NoSuchElementException
NoSuchFieldError
NoSuchFieldException
NoSuchFileException
NoSuchMechanismException
NoSuchMethodError
NoSuchMethodException
NoSuchObjectException
NoSuchPaddingException
NoSuchProviderException
NotActiveException
Notation
NotationDeclaration
NotBoundException
NotCompliantMBeanException
NotContextException
NotDirectoryException
NotEmpty
NotEmptyHelper
NotEmptyHolder
NotFound
NotFoundHelper
NotFoundHolder
NotFoundReason
NotFoundReasonHelper
NotFoundReasonHolder
NotIdentifiableEvent
NotIdentifiableEventImpl
Notification
NotificationBroadcaster
NotificationBroadcasterSupport
NotificationEmitter
NotificationFilter
NotificationFilterSupport
NotificationInfo
NotificationInfos
NotificationListener
NotificationManager
NotificationResult
NotLinkException
NotOwnerException
NotSerializableException
NotYetBoundException
NotYetConnectedException
NoType
NullCipher
NullPointerException
NullType
Number
NumberFormat
NumberFormat.Field
NumberFormatException
NumberFormatProvider
NumberFormatter
NumberOfDocuments
NumberOfInterveningJobs
NumberUp
NumberUpSupported
NumericShaper
NVList
OAEPParameterSpec
OBJ_ADAPTER
Object
Object
OBJECT_NOT_EXIST
ObjectAlreadyActive
ObjectAlreadyActiveHelper
ObjectChangeListener
ObjectFactory
ObjectFactoryBuilder
ObjectHelper
ObjectHolder
ObjectIdHelper
ObjectIdHelper
ObjectImpl
ObjectImpl
ObjectInput
ObjectInputStream
ObjectInputStream.GetField
ObjectInputValidation
ObjectInstance
ObjectName
ObjectNameTemplate
ObjectNotActive
ObjectNotActiveHelper
ObjectOutput
ObjectOutputStream
ObjectOutputStream.PutField
ObjectReferenceFactory
ObjectReferenceFactoryHelper
ObjectReferenceFactoryHolder
ObjectReferenceTemplate
ObjectReferenceTemplateHelper
ObjectReferenceTemplateHolder
ObjectReferenceTemplateSeqHelper
ObjectReferenceTemplateSeqHolder
ObjectStreamClass
ObjectStreamConstants
ObjectStreamException
ObjectStreamField
ObjectView
ObjID
Observable
Observer
OceanTheme
OctetSeqHelper
OctetSeqHolder
OctetStreamData
Oid
OMGVMCID
Oneway
OpenDataException
OpenMBeanAttributeInfo
OpenMBeanAttributeInfoSupport
OpenMBeanConstructorInfo
OpenMBeanConstructorInfoSupport
OpenMBeanInfo
OpenMBeanInfoSupport
OpenMBeanOperationInfo
OpenMBeanOperationInfoSupport
OpenMBeanParameterInfo
OpenMBeanParameterInfoSupport
OpenOption
OpenType
OpenType
OperatingSystemMXBean
Operation
OperationNotSupportedException
OperationsException
Option
OptionalDataException
OptionChecker
OptionPaneUI
ORB
ORB
ORBIdHelper
ORBInitializer
ORBInitializerOperations
ORBInitInfo
ORBInitInfoOperations
OrientationRequested
OutOfMemoryError
OutputDeviceAssigned
OutputKeys
OutputStream
OutputStream
OutputStream
OutputStreamWriter
OverlappingFileLockException
OverlayLayout
Override
Owner
Pack200
Pack200.Packer
Pack200.Unpacker
Package
PackageElement
PackedColorModel
Pageable
PageAttributes
PageAttributes.ColorType
PageAttributes.MediaType
PageAttributes.OrientationRequestedType
PageAttributes.OriginType
PageAttributes.PrintQualityType
PagedResultsControl
PagedResultsResponseControl
PageFormat
PageRanges
PagesPerMinute
PagesPerMinuteColor
Paint
PaintContext
Painter
PaintEvent
Panel
PanelUI
Paper
ParagraphView
ParagraphView
Parameter
ParameterBlock
ParameterDescriptor
Parameterizable
ParameterizedType
ParameterMetaData
ParameterMode
ParameterModeHelper
ParameterModeHolder
ParseConversionEvent
ParseConversionEventImpl
ParseException
ParsePosition
Parser
Parser
ParserAdapter
ParserConfigurationException
ParserDelegator
ParserFactory
PartialResultException
PasswordAuthentication
PasswordCallback
PasswordView
Patch
Path
Path2D
Path2D.Double
Path2D.Float
PathIterator
PathMatcher
Paths
Pattern
PatternSyntaxException
PBEKey
PBEKeySpec
PBEParameterSpec
PDLOverrideSupported
Permission
Permission
PermissionCollection
Permissions
PERSIST_STORE
PersistenceDelegate
PersistentMBean
PGPData
PhantomReference
Pipe
Pipe.SinkChannel
Pipe.SourceChannel
PipedInputStream
PipedOutputStream
PipedReader
PipedWriter
PixelGrabber
PixelInterleavedSampleModel
PKCS8EncodedKeySpec
PKIXBuilderParameters
PKIXCertPathBuilderResult
PKIXCertPathChecker
PKIXCertPathValidatorResult
PKIXParameters
PKIXReason
PlainDocument
PlainView
PlatformManagedObject
POA
POAHelper
POAManager
POAManagerOperations
POAOperations
Point
Point2D
Point2D.Double
Point2D.Float
PointerInfo
Policy
Policy
Policy
Policy.Parameters
PolicyError
PolicyErrorCodeHelper
PolicyErrorHelper
PolicyErrorHolder
PolicyFactory
PolicyFactoryOperations
PolicyHelper
PolicyHolder
PolicyListHelper
PolicyListHolder
PolicyNode
PolicyOperations
PolicyQualifierInfo
PolicySpi
PolicyTypeHelper
Polygon
PooledConnection
Popup
PopupFactory
PopupMenu
PopupMenuEvent
PopupMenuListener
PopupMenuUI
Port
Port.Info
PortableRemoteObject
PortableRemoteObjectDelegate
PortInfo
PortUnreachableException
Position
Position.Bias
PosixFileAttributes
PosixFileAttributeView
PosixFilePermission
PosixFilePermissions
PostConstruct
PreDestroy
Predicate
PreferenceChangeEvent
PreferenceChangeListener
Preferences
PreferencesFactory
PreparedStatement
PresentationDirection
PrimitiveType
Principal
Principal
PrincipalHolder
Printable
PrintConversionEvent
PrintConversionEventImpl
PrinterAbortException
PrinterException
PrinterGraphics
PrinterInfo
PrinterIOException
PrinterIsAcceptingJobs
PrinterJob
PrinterLocation
PrinterMakeAndModel
PrinterMessageFromOperator
PrinterMoreInfo
PrinterMoreInfoManufacturer
PrinterName
PrinterResolution
PrinterState
PrinterStateReason
PrinterStateReasons
PrinterURI
PrintEvent
PrintException
PrintGraphics
PrintJob
PrintJobAdapter
PrintJobAttribute
PrintJobAttributeEvent
PrintJobAttributeListener
PrintJobAttributeSet
PrintJobEvent
PrintJobListener
PrintQuality
PrintRequestAttribute
PrintRequestAttributeSet
PrintService
PrintServiceAttribute
PrintServiceAttributeEvent
PrintServiceAttributeListener
PrintServiceAttributeSet
PrintServiceLookup
PrintStream
PrintWriter
PriorityBlockingQueue
PriorityQueue
PRIVATE_MEMBER
PrivateClassLoader
PrivateCredentialPermission
PrivateKey
PrivateMLet
PrivilegedAction
PrivilegedActionException
PrivilegedExceptionAction
Process
ProcessBuilder
ProcessBuilder.Redirect
ProcessBuilder.Redirect.Type
ProcessingEnvironment
ProcessingInstruction
ProcessingInstruction
Processor
ProfileDataException
ProfileIdHelper
ProgressBarUI
ProgressMonitor
ProgressMonitorInputStream
Properties
PropertyChangeEvent
PropertyChangeListener
PropertyChangeListenerProxy
PropertyChangeSupport
PropertyDescriptor
PropertyEditor
PropertyEditorManager
PropertyEditorSupport
PropertyException
PropertyPermission
PropertyResourceBundle
PropertyVetoException
ProtectionDomain
ProtocolException
ProtocolException
ProtocolFamily
Provider
Provider
Provider
Provider.Service
ProviderException
ProviderMismatchException
ProviderNotFoundException
Proxy
Proxy
Proxy.Type
ProxySelector
PSource
PSource.PSpecified
PSSParameterSpec
PUBLIC_MEMBER
PublicKey
PushbackInputStream
PushbackReader
QName
QuadCurve2D
QuadCurve2D.Double
QuadCurve2D.Float
QualifiedNameable
Query
QueryEval
QueryExp
QueryNotificationFilter
Queue
QueuedJobCount
RadialGradientPaint
Random
RandomAccess
RandomAccessFile
Raster
RasterFormatException
RasterOp
RC2ParameterSpec
RC5ParameterSpec
Rdn
Readable
ReadableByteChannel
Reader
ReadOnlyBufferException
ReadOnlyFileSystemException
ReadPendingException
ReadWriteLock
RealmCallback
RealmChoiceCallback
REBIND
Receiver
Rectangle
Rectangle2D
Rectangle2D.Double
Rectangle2D.Float
RectangularShape
ReentrantLock
ReentrantReadWriteLock
ReentrantReadWriteLock.ReadLock
ReentrantReadWriteLock.WriteLock
Ref
RefAddr
Reference
Reference
Reference
Referenceable
ReferenceQueue
ReferenceType
ReferenceUriSchemesSupported
ReferralException
ReflectionException
ReflectPermission
Refreshable
RefreshFailedException
Region
RegisterableService
Registry
RegistryHandler
RejectedExecutionException
RejectedExecutionHandler
Relation
RelationException
RelationNotFoundException
RelationNotification
RelationService
RelationServiceMBean
RelationServiceNotRegisteredException
RelationSupport
RelationSupportMBean
RelationType
RelationTypeNotFoundException
RelationTypeSupport
RemarshalException
Remote
RemoteCall
RemoteException
RemoteObject
RemoteObjectInvocationHandler
RemoteRef
RemoteServer
RemoteStub
RenderableImage
RenderableImageOp
RenderableImageProducer
RenderContext
RenderedImage
RenderedImageFactory
Renderer
RenderingHints
RenderingHints.Key
RepaintManager
ReplicateScaleFilter
RepositoryIdHelper
Request
REQUEST_PROCESSING_POLICY_ID
RequestInfo
RequestInfoOperations
RequestingUserName
RequestProcessingPolicy
RequestProcessingPolicyOperations
RequestProcessingPolicyValue
RequestWrapper
RequiredModelMBean
RescaleOp
ResolutionSyntax
Resolver
ResolveResult
Resource
Resource.AuthenticationType
ResourceBundle
ResourceBundle.Control
Resources
RespectBinding
RespectBindingFeature
Response
ResponseCache
ResponseHandler
ResponseWrapper
Result
ResultSet
ResultSetMetaData
Retention
RetentionPolicy
RetrievalMethod
ReverbType
RGBImageFilter
RMIClassLoader
RMIClassLoaderSpi
RMIClientSocketFactory
RMIConnection
RMIConnectionImpl
RMIConnectionImpl_Stub
RMIConnector
RMIConnectorServer
RMICustomMaxStreamFormat
RMIFailureHandler
RMIIIOPServerImpl
RMIJRMPServerImpl
RMIPushEventForwarder
RMIPushEventRelay
RMIPushServer
RMISecurityException
RMISecurityManager
RMIServer
RMIServerImpl
RMIServerImpl_Stub
RMIServerSocketFactory
RMISocketFactory
Robot
Role
RoleInfo
RoleInfoNotFoundException
RoleList
RoleNotFoundException
RoleResult
RoleStatus
RoleUnresolved
RoleUnresolvedList
RootPaneContainer
RootPaneUI
RoundEnvironment
RoundingMode
RoundRectangle2D
RoundRectangle2D.Double
RoundRectangle2D.Float
RowFilter
RowFilter.ComparisonType
RowFilter.Entry
RowId
RowIdLifetime
RowMapper
RowSet
RowSetEvent
RowSetInternal
RowSetListener
RowSetMetaData
RowSetMetaDataImpl
RowSetReader
RowSetWarning
RowSetWriter
RowSorter
RowSorter.SortKey
RowSorterEvent
RowSorterEvent.Type
RowSorterListener
RSAKey
RSAKeyGenParameterSpec
RSAMultiPrimePrivateCrtKey
RSAMultiPrimePrivateCrtKeySpec
RSAOtherPrimeInfo
RSAPrivateCrtKey
RSAPrivateCrtKeySpec
RSAPrivateKey
RSAPrivateKeySpec
RSAPublicKey
RSAPublicKeySpec
RTFEditorKit
RuleBasedCollator
Runnable
RunnableFuture
RunnableScheduledFuture
Runtime
RunTime
RuntimeErrorException
RuntimeException
RuntimeMBeanException
RuntimeMXBean
RunTimeOperations
RuntimeOperationsException
RuntimePermission
SAAJMetaFactory
SAAJResult
SampleModel
Sasl
SaslClient
SaslClientFactory
SaslException
SaslServer
SaslServerFactory
Savepoint
SAXException
SAXNotRecognizedException
SAXNotSupportedException
SAXParseException
SAXParser
SAXParserFactory
SAXResult
SAXSource
SAXTransformerFactory
Scanner
ScatteringByteChannel
ScheduledExecutorService
ScheduledFuture
ScheduledThreadPoolExecutor
Schema
SchemaFactory
SchemaFactoryLoader
SchemaOutputResolver
SchemaViolationException
ScriptContext
ScriptEngine
ScriptEngineFactory
ScriptEngineManager
ScriptException
Scrollable
Scrollbar
ScrollBarUI
ScrollPane
ScrollPaneAdjustable
ScrollPaneConstants
ScrollPaneLayout
ScrollPaneLayout.UIResource
ScrollPaneUI
SealedObject
SearchControls
SearchResult
SecretKey
SecretKeyFactory
SecretKeyFactorySpi
SecretKeySpec
SecureCacheResponse
SecureClassLoader
SecureDirectoryStream
SecureRandom
SecureRandomSpi
Security
SecurityException
SecurityManager
SecurityPermission
SeekableByteChannel
Segment
SelectableChannel
SelectionKey
Selector
SelectorProvider
Semaphore
SendNotification
SeparatorUI
Sequence
SequenceInputStream
Sequencer
Sequencer.SyncMode
SerialArray
SerialBlob
SerialClob
SerialDatalink
SerialException
Serializable
SerializablePermission
SerialJavaObject
SerialRef
SerialStruct
Servant
SERVANT_RETENTION_POLICY_ID
ServantActivator
ServantActivatorHelper
ServantActivatorOperations
ServantActivatorPOA
ServantAlreadyActive
ServantAlreadyActiveHelper
ServantLocator
ServantLocatorHelper
ServantLocatorOperations
ServantLocatorPOA
ServantManager
ServantManagerOperations
ServantNotActive
ServantNotActiveHelper
ServantObject
ServantRetentionPolicy
ServantRetentionPolicyOperations
ServantRetentionPolicyValue
ServerCloneException
ServerError
ServerException
ServerIdHelper
ServerNotActiveException
ServerRef
ServerRequest
ServerRequestInfo
ServerRequestInfoOperations
ServerRequestInterceptor
ServerRequestInterceptorOperations
ServerRuntimeException
ServerSocket
ServerSocketChannel
ServerSocketFactory
Service
Service.Mode
ServiceConfigurationError
ServiceContext
ServiceContextHelper
ServiceContextHolder
ServiceContextListHelper
ServiceContextListHolder
ServiceDelegate
ServiceDetail
ServiceDetailHelper
ServiceIdHelper
ServiceInformation
ServiceInformationHelper
ServiceInformationHolder
ServiceLoader
ServiceMode
ServiceNotFoundException
ServicePermission
ServiceRegistry
ServiceRegistry.Filter
ServiceUI
ServiceUIFactory
ServiceUnavailableException
Set
SetOfIntegerSyntax
SetOverrideType
SetOverrideTypeHelper
Severity
Shape
ShapeGraphicAttribute
SheetCollate
Short
ShortBuffer
ShortBufferException
ShortHolder
ShortLookupTable
ShortMessage
ShortSeqHelper
ShortSeqHolder
ShutdownChannelGroupException
Sides
Signature
SignatureException
SignatureMethod
SignatureMethodParameterSpec
SignatureProperties
SignatureProperty
SignatureSpi
SignedInfo
SignedObject
Signer
SimpleAnnotationValueVisitor6
SimpleAttributeSet
SimpleBeanInfo
SimpleBindings
SimpleDateFormat
SimpleDoc
SimpleElementVisitor6
SimpleFileVisitor
SimpleFormatter
SimpleJavaFileObject
SimpleScriptContext
SimpleTimeZone
SimpleType
SimpleTypeVisitor6
SinglePixelPackedSampleModel
SingleSelectionModel
Size2DSyntax
SizeLimitExceededException
SizeRequirements
SizeSequence
Skeleton
SkeletonMismatchException
SkeletonNotFoundException
SliderUI
SOAPBinding
SOAPBinding
SOAPBinding.ParameterStyle
SOAPBinding.Style
SOAPBinding.Use
SOAPBody
SOAPBodyElement
SOAPConnection
SOAPConnectionFactory
SOAPConstants
SOAPElement
SOAPElementFactory
SOAPEnvelope
SOAPException
SOAPFactory
SOAPFault
SOAPFaultElement
SOAPFaultException
SOAPHandler
SOAPHeader
SOAPHeaderElement
SOAPMessage
SOAPMessageContext
SOAPMessageHandler
SOAPMessageHandlers
SOAPPart
Socket
SocketAddress
SocketChannel
SocketException
SocketFactory
SocketHandler
SocketImpl
SocketImplFactory
SocketOption
SocketOptions
SocketPermission
SocketSecurityException
SocketTimeoutException
SoftBevelBorder
SoftReference
SortControl
SortedMap
SortedSet
SortingFocusTraversalPolicy
SortKey
SortOrder
SortResponseControl
Soundbank
SoundbankReader
SoundbankResource
Source
SourceDataLine
SourceLocator
SourceVersion
SpinnerDateModel
SpinnerListModel
SpinnerModel
SpinnerNumberModel
SpinnerUI
SplashScreen
SplitPaneUI
Spring
SpringLayout
SpringLayout.Constraints
SQLClientInfoException
SQLData
SQLDataException
SQLException
SQLFeatureNotSupportedException
SQLInput
SQLInputImpl
SQLIntegrityConstraintViolationException
SQLInvalidAuthorizationSpecException
SQLNonTransientConnectionException
SQLNonTransientException
SQLOutput
SQLOutputImpl
SQLPermission
SQLRecoverableException
SQLSyntaxErrorException
SQLTimeoutException
SQLTransactionRollbackException
SQLTransientConnectionException
SQLTransientException
SQLWarning
SQLXML
SSLContext
SSLContextSpi
SSLEngine
SSLEngineResult
SSLEngineResult.HandshakeStatus
SSLEngineResult.Status
SSLException
SSLHandshakeException
SSLKeyException
SSLParameters
SSLPeerUnverifiedException
SSLPermission
SSLProtocolException
SslRMIClientSocketFactory
SslRMIServerSocketFactory
SSLServerSocket
SSLServerSocketFactory
SSLSession
SSLSessionBindingEvent
SSLSessionBindingListener
SSLSessionContext
SSLSocket
SSLSocketFactory
Stack
StackOverflowError
StackTraceElement
StandardCopyOption
StandardEmitterMBean
StandardJavaFileManager
StandardLocation
StandardMBean
StandardMBean.Options
StandardOpenOption
StandardProtocolFamily
StandardSocketOption
StandardWatchEventKind
StartDocument
StartElement
StartTlsRequest
StartTlsResponse
State
StateEdit
StateEditable
StateFactory
Statement
Statement
StatementEvent
StatementEventListener
StAXResult
StAXSource
Streamable
StreamableValue
StreamCorruptedException
StreamFilter
StreamHandler
StreamPrintService
StreamPrintServiceFactory
StreamReaderDelegate
StreamResult
StreamSource
StreamTokenizer
StrictMath
String
StringBuffer
StringBufferInputStream
StringBuilder
StringCharacterIterator
StringContent
StringHolder
StringIndexOutOfBoundsException
StringMonitor
StringMonitorMBean
StringNameHelper
StringReader
StringRefAddr
StringSelection
StringSeqHelper
StringSeqHolder
StringTokenizer
StringValueExp
StringValueHelper
StringWriter
Stroke
Struct
StructMember
StructMemberHelper
Stub
StubDelegate
StubNotFoundException
Style
StyleConstants
StyleConstants.CharacterConstants
StyleConstants.ColorConstants
StyleConstants.FontConstants
StyleConstants.ParagraphConstants
StyleContext
StyledDocument
StyledEditorKit
StyledEditorKit.AlignmentAction
StyledEditorKit.BoldAction
StyledEditorKit.FontFamilyAction
StyledEditorKit.FontSizeAction
StyledEditorKit.ForegroundAction
StyledEditorKit.ItalicAction
StyledEditorKit.StyledTextAction
StyledEditorKit.UnderlineAction
StyleSheet
StyleSheet.BoxPainter
StyleSheet.ListPainter
Subject
SubjectDelegationPermission
SubjectDomainCombiner
SUCCESSFUL
SupportedAnnotationTypes
SupportedOptions
SupportedSourceVersion
SupportedValuesAttribute
SuppressWarnings
SwingConstants
SwingPropertyChangeSupport
SwingUtilities
SwingWorker
SwingWorker.StateValue
SYNC_WITH_TRANSPORT
SyncFactory
SyncFactoryException
SyncFailedException
SynchronousQueue
SyncProvider
SyncProviderException
SyncResolver
SyncScopeHelper
SynthConstants
SynthContext
Synthesizer
SynthGraphicsUtils
SynthLookAndFeel
SynthPainter
SynthStyle
SynthStyleFactory
SysexMessage
System
SYSTEM_EXCEPTION
SystemColor
SystemException
SystemFlavorMap
SystemTray
TabableView
TabbedPaneUI
TabExpander
TableCellEditor
TableCellRenderer
TableColumn
TableColumnModel
TableColumnModelEvent
TableColumnModelListener
TableHeaderUI
TableModel
TableModelEvent
TableModelListener
TableRowSorter
TableStringConverter
TableUI
TableView
TabSet
TabStop
TabularData
TabularDataSupport
TabularType
TAG_ALTERNATE_IIOP_ADDRESS
TAG_CODE_SETS
TAG_INTERNET_IOP
TAG_JAVA_CODEBASE
TAG_MULTIPLE_COMPONENTS
TAG_ORB_TYPE
TAG_POLICIES
TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
TagElement
TaggedComponent
TaggedComponentHelper
TaggedComponentHolder
TaggedProfile
TaggedProfileHelper
TaggedProfileHolder
Target
TargetDataLine
TargetedNotification
TCKind
Templates
TemplatesHandler
Text
Text
TextAction
TextArea
TextAttribute
TextComponent
TextEvent
TextField
TextHitInfo
TextInputCallback
TextLayout
TextLayout.CaretPolicy
TextListener
TextMeasurer
TextOutputCallback
TextSyntax
TextUI
TexturePaint
Thread
Thread.State
Thread.UncaughtExceptionHandler
THREAD_POLICY_ID
ThreadDeath
ThreadFactory
ThreadGroup
ThreadInfo
ThreadLocal
ThreadMXBean
ThreadPolicy
ThreadPolicyOperations
ThreadPolicyValue
ThreadPoolExecutor
ThreadPoolExecutor.AbortPolicy
ThreadPoolExecutor.CallerRunsPolicy
ThreadPoolExecutor.DiscardOldestPolicy
ThreadPoolExecutor.DiscardPolicy
Throwable
Tie
TileObserver
Time
TimeLimitExceededException
TIMEOUT
TimeoutException
Timer
Timer
Timer
TimerMBean
TimerNotification
TimerTask
Timestamp
Timestamp
TimeUnit
TimeZone
TimeZoneNameProvider
TitledBorder
Tool
ToolBarUI
Toolkit
ToolProvider
ToolTipManager
ToolTipUI
TooManyListenersException
Track
TRANSACTION_MODE
TRANSACTION_REQUIRED
TRANSACTION_ROLLEDBACK
TRANSACTION_UNAVAILABLE
TransactionalWriter
TransactionRequiredException
TransactionRolledbackException
TransactionService
Transferable
TransferHandler
TransferHandler.DropLocation
TransferHandler.TransferSupport
Transform
TransformAttribute
Transformer
TransformerConfigurationException
TransformerException
TransformerFactory
TransformerFactoryConfigurationError
TransformerHandler
TransformException
TransformParameterSpec
TransformService
Transient
TRANSIENT
Transmitter
Transparency
TRANSPORT_RETRY
TrayIcon
TrayIcon.MessageType
TreeCellEditor
TreeCellRenderer
TreeExpansionEvent
TreeExpansionListener
TreeMap
TreeModel
TreeModelEvent
TreeModelListener
TreeNode
TreePath
TreeSelectionEvent
TreeSelectionListener
TreeSelectionModel
TreeSet
TreeUI
TreeWillExpandListener
TrustAnchor
TrustManager
TrustManagerFactory
TrustManagerFactorySpi
Type
TypeCode
TypeCodeHolder
TypeConstraintException
TypeElement
TypeInfo
TypeInfoProvider
TypeKind
TypeKindVisitor6
TypeMirror
TypeMismatch
TypeMismatch
TypeMismatch
TypeMismatchHelper
TypeMismatchHelper
TypeNotPresentException
TypeParameterElement
Types
Types
TypeVariable
TypeVariable
TypeVisitor
UID
UIDefaults
UIDefaults.ActiveValue
UIDefaults.LazyInputMap
UIDefaults.LazyValue
UIDefaults.ProxyLazyValue
UIEvent
UIManager
UIManager.LookAndFeelInfo
UIResource
ULongLongSeqHelper
ULongLongSeqHolder
ULongSeqHelper
ULongSeqHolder
UndeclaredThrowableException
UndoableEdit
UndoableEditEvent
UndoableEditListener
UndoableEditSupport
UndoManager
UnexpectedException
UnicastRemoteObject
UnionMember
UnionMemberHelper
UNKNOWN
UNKNOWN
UnknownAnnotationValueException
UnknownElementException
UnknownEncoding
UnknownEncodingHelper
UnknownEntityException
UnknownError
UnknownException
UnknownFormatConversionException
UnknownFormatFlagsException
UnknownGroupException
UnknownHostException
UnknownHostException
UnknownObjectException
UnknownServiceException
UnknownTypeException
UnknownUserException
UnknownUserExceptionHelper
UnknownUserExceptionHolder
UnmappableCharacterException
UnmarshalException
UnmarshalException
Unmarshaller
Unmarshaller.Listener
UnmarshallerHandler
UnmodifiableClassException
UnmodifiableSetException
UnrecoverableEntryException
UnrecoverableKeyException
Unreferenced
UnresolvedAddressException
UnresolvedPermission
UnsatisfiedLinkError
UnsolicitedNotification
UnsolicitedNotificationEvent
UnsolicitedNotificationListener
UNSUPPORTED_POLICY
UNSUPPORTED_POLICY_VALUE
UnsupportedAddressTypeException
UnsupportedAudioFileException
UnsupportedCallbackException
UnsupportedCharsetException
UnsupportedClassVersionError
UnsupportedDataTypeException
UnsupportedEncodingException
UnsupportedFlavorException
UnsupportedLookAndFeelException
UnsupportedOperationException
URI
URIDereferencer
URIException
URIParameter
URIReference
URIReferenceException
URIResolver
URISyntax
URISyntaxException
URL
URLClassLoader
URLConnection
URLDataSource
URLDecoder
URLEncoder
URLStreamHandler
URLStreamHandlerFactory
URLStringHelper
USER_EXCEPTION
UserDataHandler
UserDefinedFileAttributeView
UserException
UserPrincipal
UserPrincipalLookupService
UserPrincipalNotFoundException
UShortSeqHelper
UShortSeqHolder
UTFDataFormatException
Util
UtilDelegate
Utilities
UUID
ValidationEvent
ValidationEventCollector
ValidationEventHandler
ValidationEventImpl
ValidationEventLocator
ValidationEventLocatorImpl
ValidationException
Validator
Validator
ValidatorHandler
ValueBase
ValueBaseHelper
ValueBaseHolder
ValueExp
ValueFactory
ValueHandler
ValueHandlerMultiFormat
ValueInputStream
ValueMember
ValueMemberHelper
ValueOutputStream
VariableElement
VariableHeightLayoutCache
Vector
VerifyError
VersionSpecHelper
VetoableChangeListener
VetoableChangeListenerProxy
VetoableChangeSupport
View
ViewFactory
ViewportLayout
ViewportUI
VirtualEventManager
VirtualMachineError
Visibility
VisibilityHelper
VM_ABSTRACT
VM_CUSTOM
VM_NONE
VM_TRUNCATABLE
VMID
VoiceStatus
Void
VolatileImage
W3CDomHandler
W3CEndpointReference
W3CEndpointReferenceBuilder
Watchable
WatchEvent
WatchEvent.Kind
WatchEvent.Modifier
WatchKey
WatchService
WCharSeqHelper
WCharSeqHolder
WeakHashMap
WeakReference
WebEndpoint
WebFault
WebMethod
WebParam
WebParam.Mode
WebResult
WebRowSet
WebService
WebServiceClient
WebServiceContext
WebServiceException
WebServiceFeature
WebServiceFeatureAnnotation
WebServicePermission
WebServiceProvider
WebServiceRef
WebServiceRefs
WildcardType
WildcardType
Window
WindowAdapter
WindowConstants
WindowEvent
WindowFocusListener
WindowListener
WindowStateListener
WrappedPlainView
Wrapper
WritableByteChannel
WritableRaster
WritableRenderedImage
WriteAbortedException
WritePendingException
Writer
WrongAdapter
WrongAdapterHelper
WrongMethodTypeException
WrongPolicy
WrongPolicyHelper
WrongTransaction
WrongTransactionHelper
WrongTransactionHolder
WStringSeqHelper
WStringSeqHolder
WStringValueHelper
X500Principal
X500PrivateCredential
X509Certificate
X509Certificate
X509CertSelector
X509CRL
X509CRLEntry
X509CRLSelector
X509Data
X509EncodedKeySpec
X509ExtendedKeyManager
X509Extension
X509IssuerSerial
X509KeyManager
X509TrustManager
XAConnection
XADataSource
XAException
XAResource
Xid
XmlAccessOrder
XmlAccessorOrder
XmlAccessorType
XmlAccessType
XmlAdapter
XmlAnyAttribute
XmlAnyElement
XmlAttachmentRef
XmlAttribute
XMLConstants
XMLCryptoContext
XMLDecoder
XmlElement
XmlElement.DEFAULT
XmlElementDecl
XmlElementDecl.GLOBAL
XmlElementRef
XmlElementRef.DEFAULT
XmlElementRefs
XmlElements
XmlElementWrapper
XMLEncoder
XmlEnum
XmlEnumValue
XMLEvent
XMLEventAllocator
XMLEventConsumer
XMLEventFactory
XMLEventReader
XMLEventWriter
XMLFilter
XMLFilterImpl
XMLFormatter
XMLGregorianCalendar
XmlID
XmlIDREF
XmlInlineBinaryData
XMLInputFactory
XmlJavaTypeAdapter
XmlJavaTypeAdapter.DEFAULT
XmlJavaTypeAdapters
XmlList
XmlMimeType
XmlMixed
XmlNs
XmlNsForm
XMLObject
XMLOutputFactory
XMLParseException
XmlReader
XMLReader
XMLReaderAdapter
XMLReaderFactory
XmlRegistry
XMLReporter
XMLResolver
XmlRootElement
XmlSchema
XmlSchemaType
XmlSchemaType.DEFAULT
XmlSchemaTypes
XmlSeeAlso
XMLSignature
XMLSignature.SignatureValue
XMLSignatureException
XMLSignatureFactory
XMLSignContext
XMLStreamConstants
XMLStreamException
XMLStreamReader
XMLStreamWriter
XMLStructure
XmlTransient
XmlType
XmlType.DEFAULT
XMLValidateContext
XmlValue
XmlWriter
XPath
XPathConstants
XPathException
XPathExpression
XPathExpressionException
XPathFactory
XPathFactoryConfigurationException
XPathFilter2ParameterSpec
XPathFilterParameterSpec
XPathFunction
XPathFunctionException
XPathFunctionResolver
XPathType
XPathType.Filter
XPathVariableResolver
XSLTTransformParameterSpec
ZipEntry
ZipError
ZipException
ZipFile
ZipInputStream
ZipOutputStream
ZoneView
_BindingIteratorImplBase
_BindingIteratorStub
_DynAnyFactoryStub
_DynAnyStub
_DynArrayStub
_DynEnumStub
_DynFixedStub
_DynSequenceStub
_DynStructStub
_DynUnionStub
_DynValueStub
_IDLTypeStub
_NamingContextExtStub
_NamingContextImplBase
_NamingContextStub
_PolicyStub
_Remote_Stub
_ServantActivatorStub
_ServantLocatorStub


Constant Field Values (Java Platform SE 7 b59)

DRAFT ea-b59
PREV NEXT FRAMES NO FRAMES

Constant Field Values

Contents
  • java.awt.*
  • java.beans.*
  • java.io.*
  • java.lang.*
  • java.math.*
  • java.net.*
  • java.nio.*
  • java.rmi.*
  • java.security.*
  • java.sql.*
  • java.text.*
  • java.util.*
  • javax.accessibility.*
  • javax.crypto.*
  • javax.imageio.*
  • javax.management.*
  • javax.naming.*
  • javax.print.*
  • javax.script.*
  • javax.security.*
  • javax.sound.*
  • javax.sql.*
  • javax.swing.*
  • javax.tools.*
  • javax.transaction.*
  • javax.xml.*
  • org.ietf.*
  • org.omg.*
  • org.w3c.*
  • org.xml.*
java.awt.*

java.awt.Adjustable
Modifier and Type | Constant Field | Value
public static final int | HORIZONTAL | 0
public static final int | NO_ORIENTATION | 2
public static final int | VERTICAL | 1

java.awt.AlphaComposite
Modifier and Type | Constant Field | Value
public static final int | CLEAR | 1
public static final int | DST | 9
public static final int | DST_ATOP | 11
public static final int | DST_IN | 6
public static final int | DST_OUT | 8
public static final int | DST_OVER | 4
public static final int | SRC | 2
public static final int | SRC_ATOP | 10
public static final int | SRC_IN | 5
public static final int | SRC_OUT | 7
public static final int | SRC_OVER | 3
public static final int | XOR | 12

java.awt.AWTEvent
Modifier and Type | Constant Field | Value
public static final long | ACTION_EVENT_MASK | 128L
public static final long | ADJUSTMENT_EVENT_MASK | 256L
public static final long | COMPONENT_EVENT_MASK | 1L
public static final long | CONTAINER_EVENT_MASK | 2L
public static final long | FOCUS_EVENT_MASK | 4L
public static final long | HIERARCHY_BOUNDS_EVENT_MASK | 65536L
public static final long | HIERARCHY_EVENT_MASK | 32768L
public static final long | INPUT_METHOD_EVENT_MASK | 2048L
public static final long | INVOCATION_EVENT_MASK | 16384L
public static final long | ITEM_EVENT_MASK | 512L
public static final long | KEY_EVENT_MASK | 8L
public static final long | MOUSE_EVENT_MASK | 16L
public static final long | MOUSE_MOTION_EVENT_MASK | 32L
public static final long | MOUSE_WHEEL_EVENT_MASK | 131072L
public static final long | PAINT_EVENT_MASK | 8192L
public static final int | RESERVED_ID_MAX | 1999
public static final long | TEXT_EVENT_MASK | 1024L
public static final long | WINDOW_EVENT_MASK | 64L
public static final long | WINDOW_FOCUS_EVENT_MASK | 524288L
public static final long | WINDOW_STATE_EVENT_MASK | 262144L

java.awt.BasicStroke
Modifier and Type | Constant Field | Value
public static final int | CAP_BUTT | 0
public static final int | CAP_ROUND | 1
public static final int | CAP_SQUARE | 2
public static final int | JOIN_BEVEL | 2
public static final int | JOIN_MITER | 0
public static final int | JOIN_ROUND | 1

java.awt.BorderLayout
Modifier and Type | Constant Field | Value
public static final String | AFTER_LAST_LINE | "Last"
public static final String | AFTER_LINE_ENDS | "After"
public static final String | BEFORE_FIRST_LINE | "First"
public static final String | BEFORE_LINE_BEGINS | "Before"
public static final String | CENTER | "Center"
public static final String | EAST | "East"
public static final String | LINE_END | "After"
public static final String | LINE_START | "Before"
public static final String | NORTH | "North"
public static final String | PAGE_END | "Last"
public static final String | PAGE_START | "First"
public static final String | SOUTH | "South"
public static final String | WEST | "West"

java.awt.Component
Modifier and Type | Constant Field | Value
public static final float | BOTTOM_ALIGNMENT | 1.0f
public static final float | CENTER_ALIGNMENT | 0.5f
public static final float | LEFT_ALIGNMENT | 0.0f
public static final float | RIGHT_ALIGNMENT | 1.0f
public static final float | TOP_ALIGNMENT | 0.0f

java.awt.Cursor
Modifier and Type | Constant Field | Value
public static final int | CROSSHAIR_CURSOR | 1
public static final int | CUSTOM_CURSOR | -1
public static final int | DEFAULT_CURSOR | 0
public static final int | E_RESIZE_CURSOR | 11
public static final int | HAND_CURSOR | 12
public static final int | MOVE_CURSOR | 13
public static final int | N_RESIZE_CURSOR | 8
public static final int | NE_RESIZE_CURSOR | 7
public static final int | NW_RESIZE_CURSOR | 6
public static final int | S_RESIZE_CURSOR | 9
public static final int | SE_RESIZE_CURSOR | 5
public static final int | SW_RESIZE_CURSOR | 4
public static final int | TEXT_CURSOR | 2
public static final int | W_RESIZE_CURSOR | 10
public static final int | WAIT_CURSOR | 3

java.awt.DisplayMode
Modifier and Type | Constant Field | Value
public static final int | BIT_DEPTH_MULTI | -1
public static final int | REFRESH_RATE_UNKNOWN | 0

java.awt.Event
Modifier and Type | Constant Field | Value
public static final int | ACTION_EVENT | 1001
public static final int | ALT_MASK | 8
public static final int | BACK_SPACE | 8
public static final int | CAPS_LOCK | 1022
public static final int | CTRL_MASK | 2
public static final int | DELETE | 127
public static final int | DOWN | 1005
public static final int | END | 1001
public static final int | ENTER | 10
public static final int | ESCAPE | 27
public static final int | F1 | 1008
public static final int | F10 | 1017
public static final int | F11 | 1018
public static final int | F12 | 1019
public static final int | F2 | 1009
public static final int | F3 | 1010
public static final int | F4 | 1011
public static final int | F5 | 1012
public static final int | F6 | 1013
public static final int | F7 | 1014
public static final int | F8 | 1015
public static final int | F9 | 1016
public static final int | GOT_FOCUS | 1004
public static final int | HOME | 1000
public static final int | INSERT | 1025
public static final int | KEY_ACTION | 403
public static final int | KEY_ACTION_RELEASE | 404
public static final int | KEY_PRESS | 401
public static final int | KEY_RELEASE | 402
public static final int | LEFT | 1006
public static final int | LIST_DESELECT | 702
public static final int | LIST_SELECT | 701
public static final int | LOAD_FILE | 1002
public static final int | LOST_FOCUS | 1005
public static final int | META_MASK | 4
public static final int | MOUSE_DOWN | 501
public static final int | MOUSE_DRAG | 506
public static final int | MOUSE_ENTER | 504
public static final int | MOUSE_EXIT | 505
public static final int | MOUSE_MOVE | 503
public static final int | MOUSE_UP | 502
public static final int | NUM_LOCK | 1023
public static final int | PAUSE | 1024
public static final int | PGDN | 1003
public static final int | PGUP | 1002
public static final int | PRINT_SCREEN | 1020
public static final int | RIGHT | 1007
public static final int | SAVE_FILE | 1003
public static final int | SCROLL_ABSOLUTE | 605
public static final int | SCROLL_BEGIN | 606
public static final int | SCROLL_END | 607
public static final int | SCROLL_LINE_DOWN | 602
public static final int | SCROLL_LINE_UP | 601
public static final int | SCROLL_LOCK | 1021
public static final int | SCROLL_PAGE_DOWN | 604
public static final int | SCROLL_PAGE_UP | 603
public static final int | SHIFT_MASK | 1
public static final int | TAB | 9
public static final int | UP | 1004
public static final int | WINDOW_DEICONIFY | 204
public static final int | WINDOW_DESTROY | 201
public static final int | WINDOW_EXPOSE | 202
public static final int | WINDOW_ICONIFY | 203
public static final int | WINDOW_MOVED | 205

java.awt.FileDialog
Modifier and Type | Constant Field | Value
public static final int | LOAD | 0
public static final int | SAVE | 1

java.awt.FlowLayout
Modifier and Type | Constant Field | Value
public static final int | CENTER | 1
public static final int | LEADING | 3
public static final int | LEFT | 0
public static final int | RIGHT | 2
public static final int | TRAILING | 4

java.awt.Font
Modifier and Type | Constant Field | Value
public static final int | BOLD | 1
public static final int | CENTER_BASELINE | 1
public static final String | DIALOG | "Dialog"
public static final String | DIALOG_INPUT | "DialogInput"
public static final int | HANGING_BASELINE | 2
public static final int | ITALIC | 2
public static final int | LAYOUT_LEFT_TO_RIGHT | 0
public static final int | LAYOUT_NO_LIMIT_CONTEXT | 4
public static final int | LAYOUT_NO_START_CONTEXT | 2
public static final int | LAYOUT_RIGHT_TO_LEFT | 1
public static final String | MONOSPACED | "Monospaced"
public static final int | PLAIN | 0
public static final int | ROMAN_BASELINE | 0
public static final String | SANS_SERIF | "SansSerif"
public static final String | SERIF | "Serif"
public static final int | TRUETYPE_FONT | 0
public static final int | TYPE1_FONT | 1

java.awt.Frame
Modifier and Type | Constant Field | Value
public static final int | CROSSHAIR_CURSOR | 1
public static final int | DEFAULT_CURSOR | 0
public static final int | E_RESIZE_CURSOR | 11
public static final int | HAND_CURSOR | 12
public static final int | ICONIFIED | 1
public static final int | MAXIMIZED_BOTH | 6
public static final int | MAXIMIZED_HORIZ | 2
public static final int | MAXIMIZED_VERT | 4
public static final int | MOVE_CURSOR | 13
public static final int | N_RESIZE_CURSOR | 8
public static final int | NE_RESIZE_CURSOR | 7
public static final int | NORMAL | 0
public static final int | NW_RESIZE_CURSOR | 6
public static final int | S_RESIZE_CURSOR | 9
public static final int | SE_RESIZE_CURSOR | 5
public static final int | SW_RESIZE_CURSOR | 4
public static final int | TEXT_CURSOR | 2
public static final int | W_RESIZE_CURSOR | 10
public static final int | WAIT_CURSOR | 3

java.awt.GraphicsConfigTemplate
Modifier and Type | Constant Field | Value
public static final int | PREFERRED | 2
public static final int | REQUIRED | 1
public static final int | UNNECESSARY | 3

java.awt.GraphicsDevice
Modifier and Type | Constant Field | Value
public static final int | TYPE_IMAGE_BUFFER | 2
public static final int | TYPE_PRINTER | 1
public static final int | TYPE_RASTER_SCREEN | 0

java.awt.GridBagConstraints
Modifier and Type | Constant Field | Value
public static final int | ABOVE_BASELINE | 1024
public static final int | ABOVE_BASELINE_LEADING | 1280
public static final int | ABOVE_BASELINE_TRAILING | 1536
public static final int | BASELINE | 256
public static final int | BASELINE_LEADING | 512
public static final int | BASELINE_TRAILING | 768
public static final int | BELOW_BASELINE | 1792
public static final int | BELOW_BASELINE_LEADING | 2048
public static final int | BELOW_BASELINE_TRAILING | 2304
public static final int | BOTH | 1
public static final int | CENTER | 10
public static final int | EAST | 13
public static final int | FIRST_LINE_END | 24
public static final int | FIRST_LINE_START | 23
public static final int | HORIZONTAL | 2
public static final int | LAST_LINE_END | 26
public static final int | LAST_LINE_START | 25
public static final int | LINE_END | 22
public static final int | LINE_START | 21
public static final int | NONE | 0
public static final int | NORTH | 11
public static final int | NORTHEAST | 12
public static final int | NORTHWEST | 18
public static final int | PAGE_END | 20
public static final int | PAGE_START | 19
public static final int | RELATIVE | -1
public static final int | REMAINDER | 0
public static final int | SOUTH | 15
public static final int | SOUTHEAST | 14
public static final int | SOUTHWEST | 16
public static final int | VERTICAL | 3
public static final int | WEST | 17

java.awt.GridBagLayout
Modifier and Type | Constant Field | Value
protected static final int | MAXGRIDSIZE | 512
protected static final int | MINSIZE | 1
protected static final int | PREFERREDSIZE | 2

java.awt.Image
Modifier and Type | Constant Field | Value
public static final int | SCALE_AREA_AVERAGING | 16
public static final int | SCALE_DEFAULT | 1
public static final int | SCALE_FAST | 2
public static final int | SCALE_REPLICATE | 8
public static final int | SCALE_SMOOTH | 4

java.awt.KeyboardFocusManager
Modifier and Type | Constant Field | Value
public static final int | BACKWARD_TRAVERSAL_KEYS | 1
public static final int | DOWN_CYCLE_TRAVERSAL_KEYS | 3
public static final int | FORWARD_TRAVERSAL_KEYS | 0
public static final int | UP_CYCLE_TRAVERSAL_KEYS | 2

java.awt.Label
Modifier and Type | Constant Field | Value
public static final int | CENTER | 1
public static final int | LEFT | 0
public static final int | RIGHT | 2

java.awt.MediaTracker
Modifier and Type | Constant Field | Value
public static final int | ABORTED | 2
public static final int | COMPLETE | 8
public static final int | ERRORED | 4
public static final int | LOADING | 1

java.awt.Scrollbar
Modifier and Type | Constant Field | Value
public static final int | HORIZONTAL | 0
public static final int | VERTICAL | 1

java.awt.ScrollPane
Modifier and Type | Constant Field | Value
public static final int | SCROLLBARS_ALWAYS | 1
public static final int | SCROLLBARS_AS_NEEDED | 0
public static final int | SCROLLBARS_NEVER | 2

java.awt.SystemColor
Modifier and Type | Constant Field | Value
public static final int | ACTIVE_CAPTION | 1
public static final int | ACTIVE_CAPTION_BORDER | 3
public static final int | ACTIVE_CAPTION_TEXT | 2
public static final int | CONTROL | 17
public static final int | CONTROL_DK_SHADOW | 22
public static final int | CONTROL_HIGHLIGHT | 19
public static final int | CONTROL_LT_HIGHLIGHT | 20
public static final int | CONTROL_SHADOW | 21
public static final int | CONTROL_TEXT | 18
public static final int | DESKTOP | 0
public static final int | INACTIVE_CAPTION | 4
public static final int | INACTIVE_CAPTION_BORDER | 6
public static final int | INACTIVE_CAPTION_TEXT | 5
public static final int | INFO | 24
public static final int | INFO_TEXT | 25
public static final int | MENU | 10
public static final int | MENU_TEXT | 11
public static final int | NUM_COLORS | 26
public static final int | SCROLLBAR | 23
public static final int | TEXT | 12
public static final int | TEXT_HIGHLIGHT | 14
public static final int | TEXT_HIGHLIGHT_TEXT | 15
public static final int | TEXT_INACTIVE_TEXT | 16
public static final int | TEXT_TEXT | 13
public static final int | WINDOW | 7
public static final int | WINDOW_BORDER | 8
public static final int | WINDOW_TEXT | 9

java.awt.TextArea
Modifier and Type | Constant Field | Value
public static final int | SCROLLBARS_BOTH | 0
public static final int | SCROLLBARS_HORIZONTAL_ONLY | 2
public static final int | SCROLLBARS_NONE | 3
public static final int | SCROLLBARS_VERTICAL_ONLY | 1

java.awt.Transparency
Modifier and Type | Constant Field | Value
public static final int | BITMASK | 2
public static final int | OPAQUE | 1
public static final int | TRANSLUCENT | 3

java.awt.color.ColorSpace
Modifier and Type | Constant Field | Value
public static final int | CS_CIEXYZ | 1001
public static final int | CS_GRAY | 1003
public static final int | CS_LINEAR_RGB | 1004
public static final int | CS_PYCC | 1002
public static final int | CS_sRGB | 1000
public static final int | TYPE_2CLR | 12
public static final int | TYPE_3CLR | 13
public static final int | TYPE_4CLR | 14
public static final int | TYPE_5CLR | 15
public static final int | TYPE_6CLR | 16
public static final int | TYPE_7CLR | 17
public static final int | TYPE_8CLR | 18
public static final int | TYPE_9CLR | 19
public static final int | TYPE_ACLR | 20
public static final int | TYPE_BCLR | 21
public static final int | TYPE_CCLR | 22
public static final int | TYPE_CMY | 11
public static final int | TYPE_CMYK | 9
public static final int | TYPE_DCLR | 23
public static final int | TYPE_ECLR | 24
public static final int | TYPE_FCLR | 25
public static final int | TYPE_GRAY | 6
public static final int | TYPE_HLS | 8
public static final int | TYPE_HSV | 7
public static final int | TYPE_Lab | 1
public static final int | TYPE_Luv | 2
public static final int | TYPE_RGB | 5
public static final int | TYPE_XYZ | 0
public static final int | TYPE_YCbCr | 3
public static final int | TYPE_Yxy | 4

java.awt.color.ICC_Profile
Modifier and Type | Constant Field | Value
public static final int | CLASS_ABSTRACT | 5
public static final int | CLASS_COLORSPACECONVERSION | 4
public static final int | CLASS_DEVICELINK | 3
public static final int | CLASS_DISPLAY | 1
public static final int | CLASS_INPUT | 0
public static final int | CLASS_NAMEDCOLOR | 6
public static final int | CLASS_OUTPUT | 2
public static final int | icAbsoluteColorimetric | 3
public static final int | icCurveCount | 8
public static final int | icCurveData | 12
public static final int | icHdrAttributes | 56
public static final int | icHdrCmmId | 4
public static final int | icHdrColorSpace | 16
public static final int | icHdrCreator | 80
public static final int | icHdrDate | 24
public static final int | icHdrDeviceClass | 12
public static final int | icHdrFlags | 44
public static final int | icHdrIlluminant | 68
public static final int | icHdrMagic | 36
public static final int | icHdrManufacturer | 48
public static final int | icHdrModel | 52
public static final int | icHdrPcs | 20
public static final int | icHdrPlatform | 40
public static final int | icHdrProfileID | 84
public static final int | icHdrRenderingIntent | 64
public static final int | icHdrSize | 0
public static final int | icHdrVersion | 8
public static final int | icICCAbsoluteColorimetric | 3
public static final int | icMediaRelativeColorimetric | 1
public static final int | icPerceptual | 0
public static final int | icRelativeColorimetric | 1
public static final int | icSaturation | 2
public static final int | icSigAbstractClass | 1633842036
public static final int | icSigAToB0Tag | 1093812784
public static final int | icSigAToB1Tag | 1093812785
public static final int | icSigAToB2Tag | 1093812786
public static final int | icSigBlueColorantTag | 1649957210
public static final int | icSigBlueMatrixColumnTag | 1649957210
public static final int | icSigBlueTRCTag | 1649693251
public static final int | icSigBToA0Tag | 1110589744
public static final int | icSigBToA1Tag | 1110589745
public static final int | icSigBToA2Tag | 1110589746
public static final int | icSigCalibrationDateTimeTag | 1667329140
public static final int | icSigCharTargetTag | 1952543335
public static final int | icSigChromaticAdaptationTag | 1667785060
public static final int | icSigChromaticityTag | 1667789421
public static final int | icSigCmyData | 1129142560
public static final int | icSigCmykData | 1129142603
public static final int | icSigColorantOrderTag | 1668051567
public static final int | icSigColorantTableTag | 1668051572
public static final int | icSigColorSpaceClass | 1936744803
public static final int | icSigCopyrightTag | 1668313716
public static final int | icSigCrdInfoTag | 1668441193
public static final int | icSigDeviceMfgDescTag | 1684893284
public static final int | icSigDeviceModelDescTag | 1684890724
public static final int | icSigDeviceSettingsTag | 1684371059
public static final int | icSigDisplayClass | 1835955314
public static final int | icSigGamutTag | 1734438260
public static final int | icSigGrayData | 1196573017
public static final int | icSigGrayTRCTag | 1800688195
public static final int | icSigGreenColorantTag | 1733843290
public static final int | icSigGreenMatrixColumnTag | 1733843290
public static final int | icSigGreenTRCTag | 1733579331
public static final int | icSigHead | 1751474532
public static final int | icSigHlsData | 1212961568
public static final int | icSigHsvData | 1213421088
public static final int | icSigInputClass | 1935896178
public static final int | icSigLabData | 1281450528
public static final int | icSigLinkClass | 1818848875
public static final int | icSigLuminanceTag | 1819635049
public static final int | icSigLuvData | 1282766368
public static final int | icSigMeasurementTag | 1835360627
public static final int | icSigMediaBlackPointTag | 1651208308
public static final int | icSigMediaWhitePointTag | 2004119668
public static final int | icSigNamedColor2Tag | 1852009522
public static final int | icSigNamedColorClass | 1852662636
public static final int | icSigOutputClass | 1886549106
public static final int | icSigOutputResponseTag | 1919251312
public static final int | icSigPreview0Tag | 1886545200
public static final int | icSigPreview1Tag | 1886545201
public static final int | icSigPreview2Tag | 1886545202
public static final int | icSigProfileDescriptionTag | 1684370275
public static final int | icSigProfileSequenceDescTag | 1886610801
public static final int | icSigPs2CRD0Tag | 1886610480
public static final int | icSigPs2CRD1Tag | 1886610481
public static final int | icSigPs2CRD2Tag | 1886610482
public static final int | icSigPs2CRD3Tag | 1886610483
public static final int | icSigPs2CSATag | 1886597747
public static final int | icSigPs2RenderingIntentTag | 1886597737
public static final int | icSigRedColorantTag | 1918392666
public static final int | icSigRedMatrixColumnTag | 1918392666
public static final int | icSigRedTRCTag | 1918128707
public static final int | icSigRgbData | 1380401696
public static final int | icSigScreeningDescTag | 1935897188
public static final int | icSigScreeningTag | 1935897198
public static final int | icSigSpace2CLR | 843271250
public static final int | icSigSpace3CLR | 860048466
public static final int | icSigSpace4CLR | 876825682
public static final int | icSigSpace5CLR | 893602898
public static final int | icSigSpace6CLR | 910380114
public static final int | icSigSpace7CLR | 927157330
public static final int | icSigSpace8CLR | 943934546
public static final int | icSigSpace9CLR | 960711762
public static final int | icSigSpaceACLR | 1094929490
public static final int | icSigSpaceBCLR | 1111706706
public static final int | icSigSpaceCCLR | 1128483922
public static final int | icSigSpaceDCLR | 1145261138
public static final int | icSigSpaceECLR | 1162038354
public static final int | icSigSpaceFCLR | 1178815570
public static final int | icSigTechnologyTag | 1952801640
public static final int | icSigUcrBgTag | 1650877472
public static final int | icSigViewingCondDescTag | 1987405156
public static final int | icSigViewingConditionsTag | 1986618743
public static final int | icSigXYZData | 1482250784
public static final int | icSigYCbCrData | 1497588338
public static final int | icSigYxyData | 1501067552
public static final int | icTagReserved | 4
public static final int | icTagType | 0
public static final int | icXYZNumberX | 8

java.awt.color.ICC_ProfileRGB
Modifier and Type | Constant Field | Value
public static final int | BLUECOMPONENT | 2
public static final int | GREENCOMPONENT | 1
public static final int | REDCOMPONENT | 0

java.awt.datatransfer.DataFlavor
Modifier and Type | Constant Field | Value
public static final String | javaJVMLocalObjectMimeType | "application/x-java-jvm-local-objectref"
public static final String | javaRemoteObjectMimeType | "application/x-java-remote-object"
public static final String | javaSerializedObjectMimeType | "application/x-java-serialized-object"

java.awt.dnd.DnDConstants
Modifier and Type | Constant Field | Value
public static final int | ACTION_COPY | 1
public static final int | ACTION_COPY_OR_MOVE | 3
public static final int | ACTION_LINK | 1073741824
public static final int | ACTION_MOVE | 2
public static final int | ACTION_NONE | 0
public static final int | ACTION_REFERENCE | 1073741824

java.awt.dnd.DragSourceContext
Modifier and Type | Constant Field | Value
protected static final int | CHANGED | 3
protected static final int | DEFAULT | 0
protected static final int | ENTER | 1
protected static final int | OVER | 2

java.awt.event.ActionEvent
Modifier and Type | Constant Field | Value
public static final int | ACTION_FIRST | 1001
public static final int | ACTION_LAST | 1001
public static final int | ACTION_PERFORMED | 1001
public static final int | ALT_MASK | 8
public static final int | CTRL_MASK | 2
public static final int | META_MASK | 4
public static final int | SHIFT_MASK | 1

java.awt.event.AdjustmentEvent
Modifier and Type | Constant Field | Value
public static final int | ADJUSTMENT_FIRST | 601
public static final int | ADJUSTMENT_LAST | 601
public static final int | ADJUSTMENT_VALUE_CHANGED | 601
public static final int | BLOCK_DECREMENT | 3
public static final int | BLOCK_INCREMENT | 4
public static final int | TRACK | 5
public static final int | UNIT_DECREMENT | 2
public static final int | UNIT_INCREMENT | 1

java.awt.event.ComponentEvent
Modifier and Type | Constant Field | Value
public static final int | COMPONENT_FIRST | 100
public static final int | COMPONENT_HIDDEN | 103
public static final int | COMPONENT_LAST | 103
public static final int | COMPONENT_MOVED | 100
public static final int | COMPONENT_RESIZED | 101
public static final int | COMPONENT_SHOWN | 102

java.awt.event.ContainerEvent
Modifier and Type | Constant Field | Value
public static final int | COMPONENT_ADDED | 300
public static final int | COMPONENT_REMOVED | 301
public static final int | CONTAINER_FIRST | 300
public static final int | CONTAINER_LAST | 301

java.awt.event.FocusEvent
Modifier and Type | Constant Field | Value
public static final int | FOCUS_FIRST | 1004
public static final int | FOCUS_GAINED | 1004
public static final int | FOCUS_LAST | 1005
public static final int | FOCUS_LOST | 1005

java.awt.event.HierarchyEvent
Modifier and Type | Constant Field | Value
public static final int | ANCESTOR_MOVED | 1401
public static final int | ANCESTOR_RESIZED | 1402
public static final int | DISPLAYABILITY_CHANGED | 2
public static final int | HIERARCHY_CHANGED | 1400
public static final int | HIERARCHY_FIRST | 1400
public static final int | HIERARCHY_LAST | 1402
public static final int | PARENT_CHANGED | 1
public static final int | SHOWING_CHANGED | 4

java.awt.event.InputEvent
Modifier and Type | Constant Field | Value
public static final int | ALT_DOWN_MASK | 512
public static final int | ALT_GRAPH_DOWN_MASK | 8192
public static final int | ALT_GRAPH_MASK | 32
public static final int | ALT_MASK | 8
public static final int | BUTTON1_DOWN_MASK | 1024
public static final int | BUTTON1_MASK | 16
public static final int | BUTTON2_DOWN_MASK | 2048
public static final int | BUTTON2_MASK | 8
public static final int | BUTTON3_DOWN_MASK | 4096
public static final int | BUTTON3_MASK | 4
public static final int | CTRL_DOWN_MASK | 128
public static final int | CTRL_MASK | 2
public static final int | META_DOWN_MASK | 256
public static final int | META_MASK | 4
public static final int | SHIFT_DOWN_MASK | 64
public static final int | SHIFT_MASK | 1

java.awt.event.InputMethodEvent
Modifier and Type | Constant Field | Value
public static final int | CARET_POSITION_CHANGED | 1101
public static final int | INPUT_METHOD_FIRST | 1100
public static final int | INPUT_METHOD_LAST | 1101
public static final int | INPUT_METHOD_TEXT_CHANGED | 1100

java.awt.event.InvocationEvent
Modifier and Type | Constant Field | Value
public static final int | INVOCATION_DEFAULT | 1200
public static final int | INVOCATION_FIRST | 1200
public static final int | INVOCATION_LAST | 1200

java.awt.event.ItemEvent
Modifier and Type | Constant Field | Value
public static final int | DESELECTED | 2
public static final int | ITEM_FIRST | 701
public static final int | ITEM_LAST | 701
public static final int | ITEM_STATE_CHANGED | 701
public static final int | SELECTED | 1

java.awt.event.KeyEvent
Modifier and Type | Constant Field | Value
public static final char | CHAR_UNDEFINED | 65535
public static final int | KEY_FIRST | 400
public static final int | KEY_LAST | 402
public static final int | KEY_LOCATION_LEFT | 2
public static final int | KEY_LOCATION_NUMPAD | 4
public static final int | KEY_LOCATION_RIGHT | 3
public static final int | KEY_LOCATION_STANDARD | 1
public static final int | KEY_LOCATION_UNKNOWN | 0
public static final int | KEY_PRESSED | 401
public static final int | KEY_RELEASED | 402
public static final int | KEY_TYPED | 400
public static final int | VK_0 | 48
public static final int | VK_1 | 49
public static final int | VK_2 | 50
public static final int | VK_3 | 51
public static final int | VK_4 | 52
public static final int | VK_5 | 53
public static final int | VK_6 | 54
public static final int | VK_7 | 55
public static final int | VK_8 | 56
public static final int | VK_9 | 57
public static final int | VK_A | 65
public static final int | VK_ACCEPT | 30
public static final int | VK_ADD | 107
public static final int | VK_AGAIN | 65481
public static final int | VK_ALL_CANDIDATES | 256
public static final int | VK_ALPHANUMERIC | 240
public static final int | VK_ALT | 18
public static final int | VK_ALT_GRAPH | 65406
public static final int | VK_AMPERSAND | 150
public static final int | VK_ASTERISK | 151
public static final int | VK_AT | 512
public static final int | VK_B | 66
public static final int | VK_BACK_QUOTE | 192
public static final int | VK_BACK_SLASH | 92
public static final int | VK_BACK_SPACE | 8
public static final int | VK_BEGIN | 65368
public static final int | VK_BRACELEFT | 161
public static final int | VK_BRACERIGHT | 162
public static final int | VK_C | 67
public static final int | VK_CANCEL | 3
public static final int | VK_CAPS_LOCK | 20
public static final int | VK_CIRCUMFLEX | 514
public static final int | VK_CLEAR | 12
public static final int | VK_CLOSE_BRACKET | 93
public static final int | VK_CODE_INPUT | 258
public static final int | VK_COLON | 513
public static final int | VK_COMMA | 44
public static final int | VK_COMPOSE | 65312
public static final int | VK_CONTEXT_MENU | 525
public static final int | VK_CONTROL | 17
public static final int | VK_CONVERT | 28
public static final int | VK_COPY | 65485
public static final int | VK_CUT | 65489
public static final int | VK_D | 68
public static final int | VK_DEAD_ABOVEDOT | 134
public static final int | VK_DEAD_ABOVERING | 136
public static final int | VK_DEAD_ACUTE | 129
public static final int | VK_DEAD_BREVE | 133
public static final int | VK_DEAD_CARON | 138
public static final int | VK_DEAD_CEDILLA | 139
public static final int | VK_DEAD_CIRCUMFLEX | 130
public static final int | VK_DEAD_DIAERESIS | 135
public static final int | VK_DEAD_DOUBLEACUTE | 137
public static final int | VK_DEAD_GRAVE | 128
public static final int | VK_DEAD_IOTA | 141
public static final int | VK_DEAD_MACRON | 132
public static final int | VK_DEAD_OGONEK | 140
public static final int | VK_DEAD_SEMIVOICED_SOUND | 143
public static final int | VK_DEAD_TILDE | 131
public static final int | VK_DEAD_VOICED_SOUND | 142
public static final int | VK_DECIMAL | 110
public static final int | VK_DELETE | 127
public static final int | VK_DIVIDE | 111
public static final int | VK_DOLLAR | 515
public static final int | VK_DOWN | 40
public static final int | VK_E | 69
public static final int | VK_END | 35
public static final int | VK_ENTER | 10
public static final int | VK_EQUALS | 61
public static final int | VK_ESCAPE | 27
public static final int | VK_EURO_SIGN | 516
public static final int | VK_EXCLAMATION_MARK | 517
public static final int | VK_F | 70
public static final int | VK_F1 | 112
public static final int | VK_F10 | 121
public static final int | VK_F11 | 122
public static final int | VK_F12 | 123
public static final int | VK_F13 | 61440
public static final int | VK_F14 | 61441
public static final int | VK_F15 | 61442
public static final int | VK_F16 | 61443
public static final int | VK_F17 | 61444
public static final int | VK_F18 | 61445
public static final int | VK_F19 | 61446
public static final int | VK_F2 | 113
public static final int | VK_F20 | 61447
public static final int | VK_F21 | 61448
public static final int | VK_F22 | 61449
public static final int | VK_F23 | 61450
public static final int | VK_F24 | 61451
public static final int | VK_F3 | 114
public static final int | VK_F4 | 115
public static final int | VK_F5 | 116
public static final int | VK_F6 | 117
public static final int | VK_F7 | 118
public static final int | VK_F8 | 119
public static final int | VK_F9 | 120
public static final int | VK_FINAL | 24
public static final int | VK_FIND | 65488
public static final int | VK_FULL_WIDTH | 243
public static final int | VK_G | 71
public static final int | VK_GREATER | 160
public static final int | VK_H | 72
public static final int | VK_HALF_WIDTH | 244
public static final int | VK_HELP | 156
public static final int | VK_HIRAGANA | 242
public static final int | VK_HOME | 36
public static final int | VK_I | 73
public static final int | VK_INPUT_METHOD_ON_OFF | 263
public static final int | VK_INSERT | 155
public static final int | VK_INVERTED_EXCLAMATION_MARK | 518
public static final int | VK_J | 74
public static final int | VK_JAPANESE_HIRAGANA | 260
public static final int | VK_JAPANESE_KATAKANA | 259
public static final int | VK_JAPANESE_ROMAN | 261
public static final int | VK_K | 75
public static final int | VK_KANA | 21
public static final int | VK_KANA_LOCK | 262
public static final int | VK_KANJI | 25
public static final int | VK_KATAKANA | 241
public static final int | VK_KP_DOWN | 225
public static final int | VK_KP_LEFT | 226
public static final int | VK_KP_RIGHT | 227
public static final int | VK_KP_UP | 224
public static final int | VK_L | 76
public static final int | VK_LEFT | 37
public static final int | VK_LEFT_PARENTHESIS | 519
public static final int | VK_LESS | 153
public static final int | VK_M | 77
public static final int | VK_META | 157
public static final int | VK_MINUS | 45
public static final int | VK_MODECHANGE | 31
public static final int | VK_MULTIPLY | 106
public static final int | VK_N | 78
public static final int | VK_NONCONVERT | 29
public static final int | VK_NUM_LOCK | 144
public static final int | VK_NUMBER_SIGN | 520
public static final int | VK_NUMPAD0 | 96
public static final int | VK_NUMPAD1 | 97
public static final int | VK_NUMPAD2 | 98
public static final int | VK_NUMPAD3 | 99
public static final int | VK_NUMPAD4 | 100
public static final int | VK_NUMPAD5 | 101
public static final int | VK_NUMPAD6 | 102
public static final int | VK_NUMPAD7 | 103
public static final int | VK_NUMPAD8 | 104
public static final int | VK_NUMPAD9 | 105
public static final int | VK_O | 79
public static final int | VK_OPEN_BRACKET | 91
public static final int | VK_P | 80
public static final int | VK_PAGE_DOWN | 34
public static final int | VK_PAGE_UP | 33
public static final int | VK_PASTE | 65487
public static final int | VK_PAUSE | 19
public static final int | VK_PERIOD | 46
public static final int | VK_PLUS | 521
public static final int | VK_PREVIOUS_CANDIDATE | 257
public static final int | VK_PRINTSCREEN | 154
public static final int | VK_PROPS | 65482
public static final int | VK_Q | 81
public static final int | VK_QUOTE | 222
public static final int | VK_QUOTEDBL | 152
public static final int | VK_R | 82
public static final int | VK_RIGHT | 39
public static final int | VK_RIGHT_PARENTHESIS | 522
public static final int | VK_ROMAN_CHARACTERS | 245
public static final int | VK_S | 83
public static final int | VK_SCROLL_LOCK | 145
public static final int | VK_SEMICOLON | 59
public static final int | VK_SEPARATER | 108
public static final int | VK_SEPARATOR | 108
public static final int | VK_SHIFT | 16
public static final int | VK_SLASH | 47
public static final int | VK_SPACE | 32
public static final int | VK_STOP | 65480
public static final int | VK_SUBTRACT | 109
public static final int | VK_T | 84
public static final int | VK_TAB | 9
public static final int | VK_U | 85
public static final int | VK_UNDEFINED | 0
public static final int | VK_UNDERSCORE | 523
public static final int | VK_UNDO | 65483
public static final int | VK_UP | 38
public static final int | VK_V | 86
public static final int | VK_W | 87
public static final int | VK_WINDOWS | 524
public static final int | VK_X | 88
public static final int | VK_Y | 89
public static final int | VK_Z | 90

java.awt.event.MouseEvent
Modifier and Type | Constant Field | Value
public static final int | BUTTON1 | 1
public static final int | BUTTON2 | 2
public static final int | BUTTON3 | 3
public static final int | MOUSE_CLICKED | 500
public static final int | MOUSE_DRAGGED | 506
public static final int | MOUSE_ENTERED | 504
public static final int | MOUSE_EXITED | 505
public static final int | MOUSE_FIRST | 500
public static final int | MOUSE_LAST | 507
public static final int | MOUSE_MOVED | 503
public static final int | MOUSE_PRESSED | 501
public static final int | MOUSE_RELEASED | 502
public static final int | MOUSE_WHEEL | 507
public static final int | NOBUTTON | 0

java.awt.event.MouseWheelEvent
Modifier and Type | Constant Field | Value
public static final int | WHEEL_BLOCK_SCROLL | 1
public static final int | WHEEL_UNIT_SCROLL | 0

java.awt.event.PaintEvent
Modifier and Type | Constant Field | Value
public static final int | PAINT | 800
public static final int | PAINT_FIRST | 800
public static final int | PAINT_LAST | 801
public static final int | UPDATE | 801

java.awt.event.TextEvent
Modifier and Type | Constant Field | Value
public static final int | TEXT_FIRST | 900
public static final int | TEXT_LAST | 900
public static final int | TEXT_VALUE_CHANGED | 900

java.awt.event.WindowEvent
Modifier and Type | Constant Field | Value
public static final int | WINDOW_ACTIVATED | 205
public static final int | WINDOW_CLOSED | 202
public static final int | WINDOW_CLOSING | 201
public static final int | WINDOW_DEACTIVATED | 206
public static final int | WINDOW_DEICONIFIED | 204
public static final int | WINDOW_FIRST | 200
public static final int | WINDOW_GAINED_FOCUS | 207
public static final int | WINDOW_ICONIFIED | 203
public static final int | WINDOW_LAST | 209
public static final int | WINDOW_LOST_FOCUS | 208
public static final int | WINDOW_OPENED | 200
public static final int | WINDOW_STATE_CHANGED | 209

java.awt.font.GlyphJustificationInfo
Modifier and Type | Constant Field | Value
public static final int | PRIORITY_INTERCHAR | 2
public static final int | PRIORITY_KASHIDA | 0
public static final int | PRIORITY_NONE | 3
public static final int | PRIORITY_WHITESPACE | 1

java.awt.font.GlyphMetrics
Modifier and Type | Constant Field | Value
public static final byte | COMBINING | 2
public static final byte | COMPONENT | 3
public static final byte | LIGATURE | 1
public static final byte | STANDARD | 0
public static final byte | WHITESPACE | 4

java.awt.font.GlyphVector
Modifier and Type | Constant Field | Value
public static final int | FLAG_COMPLEX_GLYPHS | 8
public static final int | FLAG_HAS_POSITION_ADJUSTMENTS | 2
public static final int | FLAG_HAS_TRANSFORMS | 1
public static final int | FLAG_MASK | 15
public static final int | FLAG_RUN_RTL | 4

java.awt.font.GraphicAttribute
Modifier and Type | Constant Field | Value
public static final int | BOTTOM_ALIGNMENT | -2
public static final int | CENTER_BASELINE | 1
public static final int | HANGING_BASELINE | 2
public static final int | ROMAN_BASELINE | 0
public static final int | TOP_ALIGNMENT | -1

java.awt.font.NumericShaper
Modifier and Type | Constant Field | Value
public static final int | ALL_RANGES | 524287
public static final int | ARABIC | 2
public static final int | BENGALI | 16
public static final int | DEVANAGARI | 8
public static final int | EASTERN_ARABIC | 4
public static final int | ETHIOPIC | 65536
public static final int | EUROPEAN | 1
public static final int | GUJARATI | 64
public static final int | GURMUKHI | 32
public static final int | KANNADA | 1024
public static final int | KHMER | 131072
public static final int | LAO | 8192
public static final int | MALAYALAM | 2048
public static final int | MONGOLIAN | 262144
public static final int | MYANMAR | 32768
public static final int | ORIYA | 128
public static final int | TAMIL | 256
public static final int | TELUGU | 512
public static final int | THAI | 4096
public static final int | TIBETAN | 16384

java.awt.font.OpenType
Modifier and Type | Constant Field | Value
public static final int | TAG_ACNT | 1633906292
public static final int | TAG_AVAR | 1635148146
public static final int | TAG_BASE | 1111577413
public static final int | TAG_BDAT | 1650745716
public static final int | TAG_BLOC | 1651273571
public static final int | TAG_BSLN | 1651731566
public static final int | TAG_CFF | 1128678944
public static final int | TAG_CMAP | 1668112752
public static final int | TAG_CVAR | 1668702578
public static final int | TAG_CVT | 1668707360
public static final int | TAG_DSIG | 1146308935
public static final int | TAG_EBDT | 1161970772
public static final int | TAG_EBLC | 1161972803
public static final int | TAG_EBSC | 1161974595
public static final int | TAG_FDSC | 1717859171
public static final int | TAG_FEAT | 1717920116
public static final int | TAG_FMTX | 1718449272
public static final int | TAG_FPGM | 1718642541
public static final int | TAG_FVAR | 1719034226
public static final int | TAG_GASP | 1734439792
public static final int | TAG_GDEF | 1195656518
public static final int | TAG_GLYF | 1735162214
public static final int | TAG_GPOS | 1196445523
public static final int | TAG_GSUB | 1196643650
public static final int | TAG_GVAR | 1735811442
public static final int | TAG_HDMX | 1751412088
public static final int | TAG_HEAD | 1751474532
public static final int | TAG_HHEA | 1751672161
public static final int | TAG_HMTX | 1752003704
public static final int | TAG_JSTF | 1246975046
public static final int | TAG_JUST | 1786082164
public static final int | TAG_KERN | 1801810542
public static final int | TAG_LCAR | 1818452338
public static final int | TAG_LOCA | 1819239265
public static final int | TAG_LTSH | 1280594760
public static final int | TAG_MAXP | 1835104368
public static final int | TAG_MMFX | 1296909912
public static final int | TAG_MMSD | 1296913220
public static final int | TAG_MORT | 1836020340
public static final int | TAG_NAME | 1851878757
public static final int | TAG_OPBD | 1836020340
public static final int | TAG_OS2 | 1330851634
public static final int | TAG_PCLT | 1346587732
public static final int | TAG_POST | 1886352244
public static final int | TAG_PREP | 1886545264
public static final int | TAG_PROP | 1886547824
public static final int | TAG_TRAK | 1953653099
public static final int | TAG_TYP1 | 1954115633
public static final int | TAG_VDMX | 1447316824
public static final int | TAG_VHEA | 1986553185
public static final int | TAG_VMTX | 1986884728

java.awt.font.ShapeGraphicAttribute
Modifier and Type | Constant Field | Value
public static final boolean | FILL | false
public static final boolean | STROKE | true

java.awt.geom.AffineTransform
Modifier and Type | Constant Field | Value
public static final int | TYPE_FLIP | 64
public static final int | TYPE_GENERAL_ROTATION | 16
public static final int | TYPE_GENERAL_SCALE | 4
public static final int | TYPE_GENERAL_TRANSFORM | 32
public static final int | TYPE_IDENTITY | 0
public static final int | TYPE_MASK_ROTATION | 24
public static final int | TYPE_MASK_SCALE | 6
public static final int | TYPE_QUADRANT_ROTATION | 8
public static final int | TYPE_TRANSLATION | 1
public static final int | TYPE_UNIFORM_SCALE | 2

java.awt.geom.Arc2D
Modifier and Type | Constant Field | Value
public static final int | CHORD | 1
public static final int | OPEN | 0
public static final int | PIE | 2

java.awt.geom.Path2D
Modifier and Type | Constant Field | Value
public static final int | WIND_EVEN_ODD | 0
public static final int | WIND_NON_ZERO | 1

java.awt.geom.PathIterator
Modifier and Type | Constant Field | Value
public static final int | SEG_CLOSE | 4
public static final int | SEG_CUBICTO | 3
public static final int | SEG_LINETO | 1
public static final int | SEG_MOVETO | 0
public static final int | SEG_QUADTO | 2
public static final int | WIND_EVEN_ODD | 0
public static final int | WIND_NON_ZERO | 1

java.awt.geom.Rectangle2D
Modifier and Type | Constant Field | Value
public static final int | OUT_BOTTOM | 8
public static final int | OUT_LEFT | 1
public static final int | OUT_RIGHT | 4
public static final int | OUT_TOP | 2

java.awt.im.InputMethodHighlight
Modifier and Type | Constant Field | Value
public static final int | CONVERTED_TEXT | 1
public static final int | RAW_TEXT | 0

java.awt.image.AffineTransformOp
Modifier and Type | Constant Field | Value
public static final int | TYPE_BICUBIC | 3
public static final int | TYPE_BILINEAR | 2
public static final int | TYPE_NEAREST_NEIGHBOR | 1

java.awt.image.BufferedImage
Modifier and Type | Constant Field | Value
public static final int | TYPE_3BYTE_BGR | 5
public static final int | TYPE_4BYTE_ABGR | 6
public static final int | TYPE_4BYTE_ABGR_PRE | 7
public static final int | TYPE_BYTE_BINARY | 12
public static final int | TYPE_BYTE_GRAY | 10
public static final int | TYPE_BYTE_INDEXED | 13
public static final int | TYPE_CUSTOM | 0
public static final int | TYPE_INT_ARGB | 2
public static final int | TYPE_INT_ARGB_PRE | 3
public static final int | TYPE_INT_BGR | 4
public static final int | TYPE_INT_RGB | 1
public static final int | TYPE_USHORT_555_RGB | 9
public static final int | TYPE_USHORT_565_RGB | 8
public static final int | TYPE_USHORT_GRAY | 11

java.awt.image.ConvolveOp
Modifier and Type | Constant Field | Value
public static final int | EDGE_NO_OP | 1
public static final int | EDGE_ZERO_FILL | 0

java.awt.image.DataBuffer
Modifier and Type | Constant Field | Value
public static final int | TYPE_BYTE | 0
public static final int | TYPE_DOUBLE | 5
public static final int | TYPE_FLOAT | 4
public static final int | TYPE_INT | 3
public static final int | TYPE_SHORT | 2
public static final int | TYPE_UNDEFINED | 32
public static final int | TYPE_USHORT | 1

java.awt.image.ImageConsumer
Modifier and Type | Constant Field | Value
public static final int | COMPLETESCANLINES | 4
public static final int | IMAGEABORTED | 4
public static final int | IMAGEERROR | 1
public static final int | RANDOMPIXELORDER | 1
public static final int | SINGLEFRAME | 16
public static final int | SINGLEFRAMEDONE | 2
public static final int | SINGLEPASS | 8
public static final int | STATICIMAGEDONE | 3
public static final int | TOPDOWNLEFTRIGHT | 2

java.awt.image.ImageObserver
Modifier and Type | Constant Field | Value
public static final int | ABORT | 128
public static final int | ALLBITS | 32
public static final int | ERROR | 64
public static final int | FRAMEBITS | 16
public static final int | HEIGHT | 2
public static final int | PROPERTIES | 4
public static final int | SOMEBITS | 8
public static final int | WIDTH | 1

java.awt.image.VolatileImage
Modifier and Type | Constant Field | Value
public static final int | IMAGE_INCOMPATIBLE | 2
public static final int | IMAGE_OK | 0
public static final int | IMAGE_RESTORED | 1

java.awt.image.renderable.RenderableImage
Modifier and Type | Constant Field | Value
public static final String | HINTS_OBSERVED | "HINTS_OBSERVED"

java.awt.print.Pageable
Modifier and Type | Constant Field | Value
public static final int | UNKNOWN_NUMBER_OF_PAGES | -1

java.awt.print.PageFormat
Modifier and Type | Constant Field | Value
public static final int | LANDSCAPE | 0
public static final int | PORTRAIT | 1
public static final int | REVERSE_LANDSCAPE | 2

java.awt.print.Printable
Modifier and Type | Constant Field | Value
public static final int | NO_SUCH_PAGE | 1
public static final int | PAGE_EXISTS | 0

java.beans.*

java.beans.BeanInfo
Modifier and Type | Constant Field | Value
public static final int | ICON_COLOR_16x16 | 1
public static final int | ICON_COLOR_32x32 | 2
public static final int | ICON_MONO_16x16 | 3
public static final int | ICON_MONO_32x32 | 4

java.beans.DesignMode
Modifier and Type | Constant Field | Value
public static final String | PROPERTYNAME | "designTime"

java.beans.Introspector
Modifier and Type | Constant Field | Value
public static final int | IGNORE_ALL_BEANINFO | 3
public static final int | IGNORE_IMMEDIATE_BEANINFO | 2
public static final int | USE_ALL_BEANINFO | 1

java.io.*

java.io.ObjectStreamConstants
Modifier and Type | Constant Field | Value
public static final int | baseWireHandle | 8257536
public static final int | PROTOCOL_VERSION_1 | 1
public static final int | PROTOCOL_VERSION_2 | 2
public static final byte | SC_BLOCK_DATA | 8
public static final byte | SC_ENUM | 16
public static final byte | SC_EXTERNALIZABLE | 4
public static final byte | SC_SERIALIZABLE | 2
public static final byte | SC_WRITE_METHOD | 1
public static final short | STREAM_MAGIC | -21267
public static final short | STREAM_VERSION | 5
public static final byte | TC_ARRAY | 117
public static final byte | TC_BASE | 112
public static final byte | TC_BLOCKDATA | 119
public static final byte | TC_BLOCKDATALONG | 122
public static final byte | TC_CLASS | 118
public static final byte | TC_CLASSDESC | 114
public static final byte | TC_ENDBLOCKDATA | 120
public static final byte | TC_ENUM | 126
public static final byte | TC_EXCEPTION | 123
public static final byte | TC_LONGSTRING | 124
public static final byte | TC_MAX | 126
public static final byte | TC_NULL | 112
public static final byte | TC_OBJECT | 115
public static final byte | TC_PROXYCLASSDESC | 125
public static final byte | TC_REFERENCE | 113
public static final byte | TC_RESET | 121
public static final byte | TC_STRING | 116

java.io.PipedInputStream
Modifier and Type | Constant Field | Value
protected static final int | PIPE_SIZE | 1024

java.io.StreamTokenizer
Modifier and Type | Constant Field | Value
public static final int | TT_EOF | -1
public static final int | TT_EOL | 10
public static final int | TT_NUMBER | -2
public static final int | TT_WORD | -3

java.lang.*

java.lang.Byte
Modifier and Type | Constant Field | Value
public static final byte | MAX_VALUE | 127
public static final byte | MIN_VALUE | -128
public static final int | SIZE | 8

java.lang.Character
Modifier and Type | Constant Field | Value
public static final byte | COMBINING_SPACING_MARK | 8
public static final byte | CONNECTOR_PUNCTUATION | 23
public static final byte | CONTROL | 15
public static final byte | CURRENCY_SYMBOL | 26
public static final byte | DASH_PUNCTUATION | 20
public static final byte | DECIMAL_DIGIT_NUMBER | 9
public static final byte | DIRECTIONALITY_ARABIC_NUMBER | 6
public static final byte | DIRECTIONALITY_BOUNDARY_NEUTRAL | 9
public static final byte | DIRECTIONALITY_COMMON_NUMBER_SEPARATOR | 7
public static final byte | DIRECTIONALITY_EUROPEAN_NUMBER | 3
public static final byte | DIRECTIONALITY_EUROPEAN_NUMBER_SEPARATOR | 4
public static final byte | DIRECTIONALITY_EUROPEAN_NUMBER_TERMINATOR | 5
public static final byte | DIRECTIONALITY_LEFT_TO_RIGHT | 0
public static final byte | DIRECTIONALITY_LEFT_TO_RIGHT_EMBEDDING | 14
public static final byte | DIRECTIONALITY_LEFT_TO_RIGHT_OVERRIDE | 15
public static final byte | DIRECTIONALITY_NONSPACING_MARK | 8
public static final byte | DIRECTIONALITY_OTHER_NEUTRALS | 13
public static final byte | DIRECTIONALITY_PARAGRAPH_SEPARATOR | 10
public static final byte | DIRECTIONALITY_POP_DIRECTIONAL_FORMAT | 18
public static final byte | DIRECTIONALITY_RIGHT_TO_LEFT | 1
public static final byte | DIRECTIONALITY_RIGHT_TO_LEFT_ARABIC | 2
public static final byte | DIRECTIONALITY_RIGHT_TO_LEFT_EMBEDDING | 16
public static final byte | DIRECTIONALITY_RIGHT_TO_LEFT_OVERRIDE | 17
public static final byte | DIRECTIONALITY_SEGMENT_SEPARATOR | 11
public static final byte | DIRECTIONALITY_UNDEFINED | -1
public static final byte | DIRECTIONALITY_WHITESPACE | 12
public static final byte | ENCLOSING_MARK | 7
public static final byte | END_PUNCTUATION | 22
public static final byte | FINAL_QUOTE_PUNCTUATION | 30
public static final byte | FORMAT | 16
public static final byte | INITIAL_QUOTE_PUNCTUATION | 29
public static final byte | LETTER_NUMBER | 10
public static final byte | LINE_SEPARATOR | 13
public static final byte | LOWERCASE_LETTER | 2
public static final byte | MATH_SYMBOL | 25
public static final int | MAX_CODE_POINT | 1114111
public static final char | MAX_HIGH_SURROGATE | 56319
public static final char | MAX_LOW_SURROGATE | 57343
public static final int | MAX_RADIX | 36
public static final char | MAX_SURROGATE | 57343
public static final char | MAX_VALUE | 65535
public static final int | MIN_CODE_POINT | 0
public static final char | MIN_HIGH_SURROGATE | 55296
public static final char | MIN_LOW_SURROGATE | 56320
public static final int | MIN_RADIX | 2
public static final int | MIN_SUPPLEMENTARY_CODE_POINT | 65536
public static final char | MIN_SURROGATE | 55296
public static final char | MIN_VALUE | 0
public static final byte | MODIFIER_LETTER | 4
public static final byte | MODIFIER_SYMBOL | 27
public static final byte | NON_SPACING_MARK | 6
public static final byte | OTHER_LETTER | 5
public static final byte | OTHER_NUMBER | 11
public static final byte | OTHER_PUNCTUATION | 24
public static final byte | OTHER_SYMBOL | 28
public static final byte | PARAGRAPH_SEPARATOR | 14
public static final byte | PRIVATE_USE | 18
public static final int | SIZE | 16
public static final byte | SPACE_SEPARATOR | 12
public static final byte | START_PUNCTUATION | 21
public static final byte | SURROGATE | 19
public static final byte | TITLECASE_LETTER | 3
public static final byte | UNASSIGNED | 0
public static final byte | UPPERCASE_LETTER | 1

java.lang.Double
Modifier and Type | Constant Field | Value
public static final int | MAX_EXPONENT | 1023
public static final double | MAX_VALUE | 1.7976931348623157E308
public static final int | MIN_EXPONENT | -1022
public static final double | MIN_NORMAL | 2.2250738585072014E-308
public static final double | MIN_VALUE | 4.9E-324
public static final double | NaN | 0d/0d
public static final double | NEGATIVE_INFINITY | -1d/0d
public static final double | POSITIVE_INFINITY | 1d/0d
public static final int | SIZE | 64

java.lang.Float
Modifier and Type | Constant Field | Value
public static final int | MAX_EXPONENT | 127
public static final float | MAX_VALUE | 3.4028234663852886E38f
public static final int | MIN_EXPONENT | -126
public static final float | MIN_NORMAL | 1.1754943508222875E-38f
public static final float | MIN_VALUE | 1.401298464324817E-45f
public static final float | NaN | 0f/0f
public static final float | NEGATIVE_INFINITY | -1f/0f
public static final float | POSITIVE_INFINITY | 1f/0f
public static final int | SIZE | 32

java.lang.Integer
Modifier and Type | Constant Field | Value
public static final int | MAX_VALUE | 2147483647
public static final int | MIN_VALUE | -2147483648
public static final int | SIZE | 32

java.lang.Long
Modifier and Type | Constant Field | Value
public static final long | MAX_VALUE | 9223372036854775807L
public static final long | MIN_VALUE | -9223372036854775808L
public static final int | SIZE | 64

java.lang.Math
Modifier and Type | Constant Field | Value
public static final double | E | 2.718281828459045
public static final double | PI | 3.141592653589793

java.lang.Short
Modifier and Type | Constant Field | Value
public static final short | MAX_VALUE | 32767
public static final short | MIN_VALUE | -32768
public static final int | SIZE | 16

java.lang.StrictMath
Modifier and Type | Constant Field | Value
public static final double | E | 2.718281828459045
public static final double | PI | 3.141592653589793

java.lang.Thread
Modifier and Type | Constant Field | Value
public static final int | MAX_PRIORITY | 10
public static final int | MIN_PRIORITY | 1
public static final int | NORM_PRIORITY | 5

java.lang.management.ManagementFactory
Modifier and Type | Constant Field | Value
public static final String | CLASS_LOADING_MXBEAN_NAME | "java.lang:type=ClassLoading"
public static final String | COMPILATION_MXBEAN_NAME | "java.lang:type=Compilation"
public static final String | GARBAGE_COLLECTOR_MXBEAN_DOMAIN_TYPE | "java.lang:type=GarbageCollector"
public static final String | MEMORY_MANAGER_MXBEAN_DOMAIN_TYPE | "java.lang:type=MemoryManager"
public static final String | MEMORY_MXBEAN_NAME | "java.lang:type=Memory"
public static final String | MEMORY_POOL_MXBEAN_DOMAIN_TYPE | "java.lang:type=MemoryPool"
public static final String | OPERATING_SYSTEM_MXBEAN_NAME | "java.lang:type=OperatingSystem"
public static final String | RUNTIME_MXBEAN_NAME | "java.lang:type=Runtime"
public static final String | THREAD_MXBEAN_NAME | "java.lang:type=Threading"

java.lang.management.MemoryNotificationInfo
Modifier and Type | Constant Field | Value
public static final String | MEMORY_COLLECTION_THRESHOLD_EXCEEDED | "java.management.memory.collection.threshold.exceeded"
public static final String | MEMORY_THRESHOLD_EXCEEDED | "java.management.memory.threshold.exceeded"

java.lang.reflect.Member
Modifier and Type | Constant Field | Value
public static final int | DECLARED | 1
public static final int | PUBLIC | 0

java.lang.reflect.Modifier
Modifier and Type | Constant Field | Value
public static final int | ABSTRACT | 1024
public static final int | FINAL | 16
public static final int | INTERFACE | 512
public static final int | NATIVE | 256
public static final int | PRIVATE | 2
public static final int | PROTECTED | 4
public static final int | PUBLIC | 1
public static final int | STATIC | 8
public static final int | STRICT | 2048
public static final int | SYNCHRONIZED | 32
public static final int | TRANSIENT | 128
public static final int | VOLATILE | 64

java.math.*

java.math.BigDecimal
Modifier and Type | Constant Field | Value
public static final int | ROUND_CEILING | 2
public static final int | ROUND_DOWN | 1
public static final int | ROUND_FLOOR | 3
public static final int | ROUND_HALF_DOWN | 5
public static final int | ROUND_HALF_EVEN | 6
public static final int | ROUND_HALF_UP | 4
public static final int | ROUND_UNNECESSARY | 7
public static final int | ROUND_UP | 0

java.net.*

java.net.HttpURLConnection
Modifier and Type | Constant Field | Value
public static final int | HTTP_ACCEPTED | 202
public static final int | HTTP_BAD_GATEWAY | 502
public static final int | HTTP_BAD_METHOD | 405
public static final int | HTTP_BAD_REQUEST | 400
public static final int | HTTP_CLIENT_TIMEOUT | 408
public static final int | HTTP_CONFLICT | 409
public static final int | HTTP_CREATED | 201
public static final int | HTTP_ENTITY_TOO_LARGE | 413
public static final int | HTTP_FORBIDDEN | 403
public static final int | HTTP_GATEWAY_TIMEOUT | 504
public static final int | HTTP_GONE | 410
public static final int | HTTP_INTERNAL_ERROR | 500
public static final int | HTTP_LENGTH_REQUIRED | 411
public static final int | HTTP_MOVED_PERM | 301
public static final int | HTTP_MOVED_TEMP | 302
public static final int | HTTP_MULT_CHOICE | 300
public static final int | HTTP_NO_CONTENT | 204
public static final int | HTTP_NOT_ACCEPTABLE | 406
public static final int | HTTP_NOT_AUTHORITATIVE | 203
public static final int | HTTP_NOT_FOUND | 404
public static final int | HTTP_NOT_IMPLEMENTED | 501
public static final int | HTTP_NOT_MODIFIED | 304
public static final int | HTTP_OK | 200
public static final int | HTTP_PARTIAL | 206
public static final int | HTTP_PAYMENT_REQUIRED | 402
public static final int | HTTP_PRECON_FAILED | 412
public static final int | HTTP_PROXY_AUTH | 407
public static final int | HTTP_REQ_TOO_LONG | 414
public static final int | HTTP_RESET | 205
public static final int | HTTP_SEE_OTHER | 303
public static final int | HTTP_SERVER_ERROR | 500
public static final int | HTTP_UNAUTHORIZED | 401
public static final int | HTTP_UNAVAILABLE | 503
public static final int | HTTP_UNSUPPORTED_TYPE | 415
public static final int | HTTP_USE_PROXY | 305
public static final int | HTTP_VERSION | 505

java.net.IDN
Modifier and Type | Constant Field | Value
public static final int | ALLOW_UNASSIGNED | 1
public static final int | USE_STD3_ASCII_RULES | 2

java.net.SocketOptions
Modifier and Type | Constant Field | Value
public static final int | IP_MULTICAST_IF | 16
public static final int | IP_MULTICAST_IF2 | 31
public static final int | IP_MULTICAST_LOOP | 18
public static final int | IP_TOS | 3
public static final int | SO_BINDADDR | 15
public static final int | SO_BROADCAST | 32
public static final int | SO_KEEPALIVE | 8
public static final int | SO_LINGER | 128
public static final int | SO_OOBINLINE | 4099
public static final int | SO_RCVBUF | 4098
public static final int | SO_REUSEADDR | 4
public static final int | SO_SNDBUF | 4097
public static final int | SO_TIMEOUT | 4102
public static final int | TCP_NODELAY | 1

java.nio.*

java.nio.channels.SelectionKey
Modifier and Type | Constant Field | Value
public static final int | OP_ACCEPT | 16
public static final int | OP_CONNECT | 8
public static final int | OP_READ | 1
public static final int | OP_WRITE | 4

java.rmi.*

java.rmi.activation.ActivationSystem
Modifier and Type | Constant Field | Value
public static final int | SYSTEM_PORT | 1098

java.rmi.registry.Registry
Modifier and Type | Constant Field | Value
public static final int | REGISTRY_PORT | 1099

java.rmi.server.LoaderHandler
Modifier and Type | Constant Field | Value
public static final String | packagePrefix | "sun.rmi.server"

java.rmi.server.LogStream
Modifier and Type | Constant Field | Value
public static final int | BRIEF | 10
public static final int | SILENT | 0
public static final int | VERBOSE | 20

java.rmi.server.ObjID
Modifier and Type | Constant Field | Value
public static final int | ACTIVATOR_ID | 1
public static final int | DGC_ID | 2
public static final int | REGISTRY_ID | 0

java.rmi.server.RemoteRef
Modifier and Type | Constant Field | Value
public static final String | packagePrefix | "sun.rmi.server"
public static final long | serialVersionUID | 3632638527362204081L

java.rmi.server.ServerRef
Modifier and Type | Constant Field | Value
public static final long | serialVersionUID | -4557750989390278438L

java.security.*

java.security.Key
Modifier and Type | Constant Field | Value
public static final long | serialVersionUID | 6603384152749567654L

java.security.PrivateKey
Modifier and Type | Constant Field | Value
public static final long | serialVersionUID | 6034044314589513430L

java.security.PublicKey
Modifier and Type | Constant Field | Value
public static final long | serialVersionUID | 7187392471159151072L

java.security.Signature
Modifier and Type | Constant Field | Value
protected static final int | SIGN | 2
protected static final int | UNINITIALIZED | 0
protected static final int | VERIFY | 3

java.security.interfaces.DSAPrivateKey
Modifier and Type | Constant Field | Value
public static final long | serialVersionUID | 7776497482533790279L

java.security.interfaces.DSAPublicKey
Modifier and Type | Constant Field | Value
public static final long | serialVersionUID | 1234526332779022332L

java.security.interfaces.ECPrivateKey
Modifier and Type | Constant Field | Value
public static final long | serialVersionUID | -7896394956925609184L

java.security.interfaces.ECPublicKey
Modifier and Type | Constant Field | Value
public static final long | serialVersionUID | -3314988629879632826L

java.security.interfaces.RSAMultiPrimePrivateCrtKey
Modifier and Type | Constant Field | Value
public static final long | serialVersionUID | 618058533534628008L

java.security.interfaces.RSAPrivateCrtKey
Modifier and Type | Constant Field | Value
public static final long | serialVersionUID | -5682214253527700368L

java.security.interfaces.RSAPrivateKey
Modifier and Type | Constant Field | Value
public static final long | serialVersionUID | 5187144804936595022L

java.security.interfaces.RSAPublicKey
Modifier and Type | Constant Field | Value
public static final long | serialVersionUID | -8727434096241101194L

java.sql.*

java.sql.Connection
Modifier and Type | Constant Field | Value
public static final int | TRANSACTION_NONE | 0
public static final int | TRANSACTION_READ_COMMITTED | 2
public static final int | TRANSACTION_READ_UNCOMMITTED | 1
public static final int | TRANSACTION_REPEATABLE_READ | 4
public static final int | TRANSACTION_SERIALIZABLE | 8

java.sql.DatabaseMetaData
Modifier and Type | Constant Field | Value
public static final short | attributeNoNulls | 0
public static final short | attributeNullable | 1
public static final short | attributeNullableUnknown | 2
public static final int | bestRowNotPseudo | 1
public static final int | bestRowPseudo | 2
public static final int | bestRowSession | 2
public static final int | bestRowTemporary | 0
public static final int | bestRowTransaction | 1
public static final int | bestRowUnknown | 0
public static final int | columnNoNulls | 0
public static final int | columnNullable | 1
public static final int | columnNullableUnknown | 2
public static final int | functionColumnIn | 1
public static final int | functionColumnInOut | 2
public static final int | functionColumnOut | 3
public static final int | functionColumnResult | 5
public static final int | functionColumnUnknown | 0
public static final int | functionNoNulls | 0
public static final int | functionNoTable | 1
public static final int | functionNullable | 1
public static final int | functionNullableUnknown | 2
public static final int | functionResultUnknown | 0
public static final int | functionReturn | 4
public static final int | functionReturnsTable | 2
public static final int | importedKeyCascade | 0
public static final int | importedKeyInitiallyDeferred | 5
public static final int | importedKeyInitiallyImmediate | 6
public static final int | importedKeyNoAction | 3
public static final int | importedKeyNotDeferrable | 7
public static final int | importedKeyRestrict | 1
public static final int | importedKeySetDefault | 4
public static final int | importedKeySetNull | 2
public static final int | procedureColumnIn | 1
public static final int | procedureColumnInOut | 2
public static final int | procedureColumnOut | 4
public static final int | procedureColumnResult | 3
public static final int | procedureColumnReturn | 5
public static final int | procedureColumnUnknown | 0
public static final int | procedureNoNulls | 0
public static final int | procedureNoResult | 1
public static final int | procedureNullable | 1
public static final int | procedureNullableUnknown | 2
public static final int | procedureResultUnknown | 0
public static final int | procedureReturnsResult | 2
public static final int | sqlStateSQL | 2
public static final int | sqlStateSQL99 | 2
public static final int | sqlStateXOpen | 1
public static final short | tableIndexClustered | 1
public static final short | tableIndexHashed | 2
public static final short | tableIndexOther | 3
public static final short | tableIndexStatistic | 0
public static final int | typeNoNulls | 0
public static final int | typeNullable | 1
public static final int | typeNullableUnknown | 2
public static final int | typePredBasic | 2
public static final int | typePredChar | 1
public static final int | typePredNone | 0
public static final int | typeSearchable | 3
public static final int | versionColumnNotPseudo | 1
public static final int | versionColumnPseudo | 2
public static final int | versionColumnUnknown | 0

java.sql.ParameterMetaData
Modifier and Type | Constant Field | Value
public static final int | parameterModeIn | 1
public static final int | parameterModeInOut | 2
public static final int | parameterModeOut | 4
public static final int | parameterModeUnknown | 0
public static final int | parameterNoNulls | 0
public static final int | parameterNullable | 1
public static final int | parameterNullableUnknown | 2

java.sql.ResultSet
Modifier and Type | Constant Field | Value
public static final int | CLOSE_CURSORS_AT_COMMIT | 2
public static final int | CONCUR_READ_ONLY | 1007
public static final int | CONCUR_UPDATABLE | 1008
public static final int | FETCH_FORWARD | 1000
public static final int | FETCH_REVERSE | 1001
public static final int | FETCH_UNKNOWN | 1002
public static final int | HOLD_CURSORS_OVER_COMMIT | 1
public static final int | TYPE_FORWARD_ONLY | 1003
public static final int | TYPE_SCROLL_INSENSITIVE | 1004
public static final int | TYPE_SCROLL_SENSITIVE | 1005

java.sql.ResultSetMetaData
Modifier and Type | Constant Field | Value
public static final int | columnNoNulls | 0
public static final int | columnNullable | 1
public static final int | columnNullableUnknown | 2

java.sql.Statement
Modifier and Type | Constant Field | Value
public static final int | CLOSE_ALL_RESULTS | 3
public static final int | CLOSE_CURRENT_RESULT | 1
public static final int | EXECUTE_FAILED | -3
public static final int | KEEP_CURRENT_RESULT | 2
public static final int | NO_GENERATED_KEYS | 2
public static final int | RETURN_GENERATED_KEYS | 1
public static final int | SUCCESS_NO_INFO | -2

java.sql.Types
Modifier and Type | Constant Field | Value
public static final int | ARRAY | 2003
public static final int | BIGINT | -5
public static final int | BINARY | -2
public static final int | BIT | -7
public static final int | BLOB | 2004
public static final int | BOOLEAN | 16
public static final int | CHAR | 1
public static final int | CLOB | 2005
public static final int | DATALINK | 70
public static final int | DATE | 91
public static final int | DECIMAL | 3
public static final int | DISTINCT | 2001
public static final int | DOUBLE | 8
public static final int | FLOAT | 6
public static final int | INTEGER | 4
public static final int | JAVA_OBJECT | 2000
public static final int | LONGNVARCHAR | -16
public static final int | LONGVARBINARY | -4
public static final int | LONGVARCHAR | -1
public static final int | NCHAR | -15
public static final int | NCLOB | 2011
public static final int | NULL | 0
public static final int | NUMERIC | 2
public static final int | NVARCHAR | -9
public static final int | OTHER | 1111
public static final int | REAL | 7
public static final int | REF | 2006
public static final int | ROWID | -8
public static final int | SMALLINT | 5
public static final int | SQLXML | 2009
public static final int | STRUCT | 2002
public static final int | TIME | 92
public static final int | TIMESTAMP | 93
public static final int | TINYINT | -6
public static final int | VARBINARY | -3
public static final int | VARCHAR | 12

java.text.*

java.text.Bidi
Modifier and Type | Constant Field | Value
public static final int | DIRECTION_DEFAULT_LEFT_TO_RIGHT | -2
public static final int | DIRECTION_DEFAULT_RIGHT_TO_LEFT | -1
public static final int | DIRECTION_LEFT_TO_RIGHT | 0
public static final int | DIRECTION_RIGHT_TO_LEFT | 1

java.text.BreakIterator
Modifier and Type | Constant Field | Value
public static final int | DONE | -1

java.text.CharacterIterator
Modifier and Type | Constant Field | Value
public static final char | DONE | 65535

java.text.CollationElementIterator
Modifier and Type | Constant Field | Value
public static final int | NULLORDER | -1

java.text.Collator
Modifier and Type | Constant Field | Value
public static final int | CANONICAL_DECOMPOSITION | 1
public static final int | FULL_DECOMPOSITION | 2
public static final int | IDENTICAL | 3
public static final int | NO_DECOMPOSITION | 0
public static final int | PRIMARY | 0
public static final int | SECONDARY | 1
public static final int | TERTIARY | 2

java.text.DateFormat
Modifier and Type | Constant Field | Value
public static final int | AM_PM_FIELD | 14
public static final int | DATE_FIELD | 3
public static final int | DAY_OF_WEEK_FIELD | 9
public static final int | DAY_OF_WEEK_IN_MONTH_FIELD | 11
public static final int | DAY_OF_YEAR_FIELD | 10
public static final int | DEFAULT | 2
public static final int | ERA_FIELD | 0
public static final int | FULL | 0
public static final int | HOUR_OF_DAY0_FIELD | 5
public static final int | HOUR_OF_DAY1_FIELD | 4
public static final int | HOUR0_FIELD | 16
public static final int | HOUR1_FIELD | 15
public static final int | LONG | 1
public static final int | MEDIUM | 2
public static final int | MILLISECOND_FIELD | 8
public static final int | MINUTE_FIELD | 6
public static final int | MONTH_FIELD | 2
public static final int | SECOND_FIELD | 7
public static final int | SHORT | 3
public static final int | TIMEZONE_FIELD | 17
public static final int | WEEK_OF_MONTH_FIELD | 13
public static final int | WEEK_OF_YEAR_FIELD | 12
public static final int | YEAR_FIELD | 1

java.text.NumberFormat
Modifier and Type | Constant Field | Value
public static final int | FRACTION_FIELD | 1
public static final int | INTEGER_FIELD | 0

java.util.*

java.util.Calendar
Modifier and Type | Constant Field | Value
public static final int | ALL_STYLES | 0
public static final int | AM | 0
public static final int | AM_PM | 9
public static final int | APRIL | 3
public static final int | AUGUST | 7
public static final int | DATE | 5
public static final int | DAY_OF_MONTH | 5
public static final int | DAY_OF_WEEK | 7
public static final int | DAY_OF_WEEK_IN_MONTH | 8
public static final int | DAY_OF_YEAR | 6
public static final int | DECEMBER | 11
public static final int | DST_OFFSET | 16
public static final int | ERA | 0
public static final int | FEBRUARY | 1
public static final int | FIELD_COUNT | 17
public static final int | FRIDAY | 6
public static final int | HOUR | 10
public static final int | HOUR_OF_DAY | 11
public static final int | JANUARY | 0
public static final int | JULY | 6
public static final int | JUNE | 5
public static final int | LONG | 2
public static final int | MARCH | 2
public static final int | MAY | 4
public static final int | MILLISECOND | 14
public static final int | MINUTE | 12
public static final int | MONDAY | 2
public static final int | MONTH | 2
public static final int | NOVEMBER | 10
public static final int | OCTOBER | 9
public static final int | PM | 1
public static final int | SATURDAY | 7
public static final int | SECOND | 13
public static final int | SEPTEMBER | 8
public static final int | SHORT | 1
public static final int | SUNDAY | 1
public static final int | THURSDAY | 5
public static final int | TUESDAY | 3
public static final int | UNDECIMBER | 12
public static final int | WEDNESDAY | 4
public static final int | WEEK_OF_MONTH | 4
public static final int | WEEK_OF_YEAR | 3
public static final int | YEAR | 1
public static final int | ZONE_OFFSET | 15

java.util.FormattableFlags
Modifier and Type | Constant Field | Value
public static final int | ALTERNATE | 4
public static final int | LEFT_JUSTIFY | 1
public static final int | UPPERCASE | 2

java.util.GregorianCalendar
Modifier and Type | Constant Field | Value
public static final int | AD | 1
public static final int | BC | 0

java.util.ResourceBundle.Control
Modifier and Type | Constant Field | Value
public static final long | TTL_DONT_CACHE | -1L
public static final long | TTL_NO_EXPIRATION_CONTROL | -2L

java.util.SimpleTimeZone
Modifier and Type | Constant Field | Value
public static final int | STANDARD_TIME | 1
public static final int | UTC_TIME | 2
public static final int | WALL_TIME | 0

java.util.TimeZone
Modifier and Type | Constant Field | Value
public static final int | LONG | 1
public static final int | SHORT | 0

java.util.jar.JarEntry
Modifier and Type | Constant Field | Value
public static final int | CENATT | 36
public static final int | CENATX | 38
public static final int | CENCOM | 32
public static final int | CENCRC | 16
public static final int | CENDSK | 34
public static final int | CENEXT | 30
public static final int | CENFLG | 8
public static final int | CENHDR | 46
public static final int | CENHOW | 10
public static final int | CENLEN | 24
public static final int | CENNAM | 28
public static final int | CENOFF | 42
public static final long | CENSIG | 33639248L
public static final int | CENSIZ | 20
public static final int | CENTIM | 12
public static final int | CENVEM | 4
public static final int | CENVER | 6
public static final int | ENDCOM | 20
public static final int | ENDHDR | 22
public static final int | ENDOFF | 16
public static final long | ENDSIG | 101010256L
public static final int | ENDSIZ | 12
public static final int | ENDSUB | 8
public static final int | ENDTOT | 10
public static final int | EXTCRC | 4
public static final int | EXTHDR | 16
public static final int | EXTLEN | 12
public static final long | EXTSIG | 134695760L
public static final int | EXTSIZ | 8
public static final int | LOCCRC | 14
public static final int | LOCEXT | 28
public static final int | LOCFLG | 6
public static final int | LOCHDR | 30
public static final int | LOCHOW | 8
public static final int | LOCLEN | 22
public static final int | LOCNAM | 26
public static final long | LOCSIG | 67324752L
public static final int | LOCSIZ | 18
public static final int | LOCTIM | 10
public static final int | LOCVER | 4

java.util.jar.JarFile
Modifier and Type | Constant Field | Value
public static final int | CENATT | 36
public static final int | CENATX | 38
public static final int | CENCOM | 32
public static final int | CENCRC | 16
public static final int | CENDSK | 34
public static final int | CENEXT | 30
public static final int | CENFLG | 8
public static final int | CENHDR | 46
public static final int | CENHOW | 10
public static final int | CENLEN | 24
public static final int | CENNAM | 28
public static final int | CENOFF | 42
public static final long | CENSIG | 33639248L
public static final int | CENSIZ | 20
public static final int | CENTIM | 12
public static final int | CENVEM | 4
public static final int | CENVER | 6
public static final int | ENDCOM | 20
public static final int | ENDHDR | 22
public static final int | ENDOFF | 16
public static final long | ENDSIG | 101010256L
public static final int | ENDSIZ | 12
public static final int | ENDSUB | 8
public static final int | ENDTOT | 10
public static final int | EXTCRC | 4
public static final int | EXTHDR | 16
public static final int | EXTLEN | 12
public static final long | EXTSIG | 134695760L
public static final int | EXTSIZ | 8
public static final int | LOCCRC | 14
public static final int | LOCEXT | 28
public static final int | LOCFLG | 6
public static final int | LOCHDR | 30
public static final int | LOCHOW | 8
public static final int | LOCLEN | 22
public static final int | LOCNAM | 26
public static final long | LOCSIG | 67324752L
public static final int | LOCSIZ | 18
public static final int | LOCTIM | 10
public static final int | LOCVER | 4
public static final String | MANIFEST_NAME | "META-INF/MANIFEST.MF"

java.util.jar.JarInputStream
Modifier and Type | Constant Field | Value
public static final int | CENATT | 36
public static final int | CENATX | 38
public static final int | CENCOM | 32
public static final int | CENCRC | 16
public static final int | CENDSK | 34
public static final int | CENEXT | 30
public static final int | CENFLG | 8
public static final int | CENHDR | 46
public static final int | CENHOW | 10
public static final int | CENLEN | 24
public static final int | CENNAM | 28
public static final int | CENOFF | 42
public static final long | CENSIG | 33639248L
public static final int | CENSIZ | 20
public static final int | CENTIM | 12
public static final int | CENVEM | 4
public static final int | CENVER | 6
public static final int | ENDCOM | 20
public static final int | ENDHDR | 22
public static final int | ENDOFF | 16
public static final long | ENDSIG | 101010256L
public static final int | ENDSIZ | 12
public static final int | ENDSUB | 8
public static final int | ENDTOT | 10
public static final int | EXTCRC | 4
public static final int | EXTHDR | 16
public static final int | EXTLEN | 12
public static final long | EXTSIG | 134695760L
public static final int | EXTSIZ | 8
public static final int | LOCCRC | 14
public static final int | LOCEXT | 28
public static final int | LOCFLG | 6
public static final int | LOCHDR | 30
public static final int | LOCHOW | 8
public static final int | LOCLEN | 22
public static final int | LOCNAM | 26
public static final long | LOCSIG | 67324752L
public static final int | LOCSIZ | 18
public static final int | LOCTIM | 10
public static final int | LOCVER | 4

java.util.jar.JarOutputStream
Modifier and Type | Constant Field | Value
public static final int | CENATT | 36
public static final int | CENATX | 38
public static final int | CENCOM | 32
public static final int | CENCRC | 16
public static final int | CENDSK | 34
public static final int | CENEXT | 30
public static final int | CENFLG | 8
public static final int | CENHDR | 46
public static final int | CENHOW | 10
public static final int | CENLEN | 24
public static final int | CENNAM | 28
public static final int | CENOFF | 42
public static final long | CENSIG | 33639248L
public static final int | CENSIZ | 20
public static final int | CENTIM | 12
public static final int | CENVEM | 4
public static final int | CENVER | 6
public static final int | ENDCOM | 20
public static final int | ENDHDR | 22
public static final int | ENDOFF | 16
public static final long | ENDSIG | 101010256L
public static final int | ENDSIZ | 12
public static final int | ENDSUB | 8
public static final int | ENDTOT | 10
public static final int | EXTCRC | 4
public static final int | EXTHDR | 16
public static final int | EXTLEN | 12
public static final long | EXTSIG | 134695760L
public static final int | EXTSIZ | 8
public static final int | LOCCRC | 14
public static final int | LOCEXT | 28
public static final int | LOCFLG | 6
public static final int | LOCHDR | 30
public static final int | LOCHOW | 8
public static final int | LOCLEN | 22
public static final int | LOCNAM | 26
public static final long | LOCSIG | 67324752L
public static final int | LOCSIZ | 18
public static final int | LOCTIM | 10
public static final int | LOCVER | 4

java.util.jar.Pack200.Packer
Modifier and Type | Constant Field | Value
public static final String | CLASS_ATTRIBUTE_PFX | "pack.class.attribute."
public static final String | CODE_ATTRIBUTE_PFX | "pack.code.attribute."
public static final String | DEFLATE_HINT | "pack.deflate.hint"
public static final String | EFFORT | "pack.effort"
public static final String | ERROR | "error"
public static final String | FALSE | "false"
public static final String | FIELD_ATTRIBUTE_PFX | "pack.field.attribute."
public static final String | KEEP | "keep"
public static final String | KEEP_FILE_ORDER | "pack.keep.file.order"
public static final String | LATEST | "latest"
public static final String | METHOD_ATTRIBUTE_PFX | "pack.method.attribute."
public static final String | MODIFICATION_TIME | "pack.modification.time"
public static final String | PASS | "pass"
public static final String | PASS_FILE_PFX | "pack.pass.file."
public static final String | PROGRESS | "pack.progress"
public static final String | SEGMENT_LIMIT | "pack.segment.limit"
public static final String | STRIP | "strip"
public static final String | TRUE | "true"
public static final String | UNKNOWN_ATTRIBUTE | "pack.unknown.attribute"

java.util.jar.Pack200.Unpacker
Modifier and Type | Constant Field | Value
public static final String | DEFLATE_HINT | "unpack.deflate.hint"
public static final String | FALSE | "false"
public static final String | KEEP | "keep"
public static final String | PROGRESS | "unpack.progress"
public static final String | TRUE | "true"

java.util.logging.ErrorManager
Modifier and Type | Constant Field | Value
public static final int | CLOSE_FAILURE | 3
public static final int | FLUSH_FAILURE | 2
public static final int | FORMAT_FAILURE | 5
public static final int | GENERIC_FAILURE | 0
public static final int | OPEN_FAILURE | 4
public static final int | WRITE_FAILURE | 1

java.util.logging.Logger
Modifier and Type | Constant Field | Value
public static final String | GLOBAL_LOGGER_NAME | "global"

java.util.logging.LogManager
Modifier and Type | Constant Field | Value
public static final String | LOGGING_MXBEAN_NAME | "java.util.logging:type=Logging"

java.util.prefs.Preferences
Modifier and Type | Constant Field | Value
public static final int | MAX_KEY_LENGTH | 80
public static final int | MAX_NAME_LENGTH | 80
public static final int | MAX_VALUE_LENGTH | 8192

java.util.regex.Pattern
Modifier and Type | Constant Field | Value
public static final int | CANON_EQ | 128
public static final int | CASE_INSENSITIVE | 2
public static final int | COMMENTS | 4
public static final int | DOTALL | 32
public static final int | LITERAL | 16
public static final int | MULTILINE | 8
public static final int | UNICODE_CASE | 64
public static final int | UNIX_LINES | 1

java.util.zip.Deflater
Modifier and Type | Constant Field | Value
public static final int | BEST_COMPRESSION | 9
public static final int | BEST_SPEED | 1
public static final int | DEFAULT_COMPRESSION | -1
public static final int | DEFAULT_STRATEGY | 0
public static final int | DEFLATED | 8
public static final int | FILTERED | 1
public static final int | HUFFMAN_ONLY | 2
public static final int | NO_COMPRESSION | 0

java.util.zip.GZIPInputStream
Modifier and Type | Constant Field | Value
public static final int | GZIP_MAGIC | 35615

java.util.zip.ZipEntry
Modifier and Type | Constant Field | Value
public static final int | CENATT | 36
public static final int | CENATX | 38
public static final int | CENCOM | 32
public static final int | CENCRC | 16
public static final int | CENDSK | 34
public static final int | CENEXT | 30
public static final int | CENFLG | 8
public static final int | CENHDR | 46
public static final int | CENHOW | 10
public static final int | CENLEN | 24
public static final int | CENNAM | 28
public static final int | CENOFF | 42
public static final long | CENSIG | 33639248L
public static final int | CENSIZ | 20
public static final int | CENTIM | 12
public static final int | CENVEM | 4
public static final int | CENVER | 6
public static final int | DEFLATED | 8
public static final int | ENDCOM | 20
public static final int | ENDHDR | 22
public static final int | ENDOFF | 16
public static final long | ENDSIG | 101010256L
public static final int | ENDSIZ | 12
public static final int | ENDSUB | 8
public static final int | ENDTOT | 10
public static final int | EXTCRC | 4
public static final int | EXTHDR | 16
public static final int | EXTLEN | 12
public static final long | EXTSIG | 134695760L
public static final int | EXTSIZ | 8
public static final int | LOCCRC | 14
public static final int | LOCEXT | 28
public static final int | LOCFLG | 6
public static final int | LOCHDR | 30
public static final int | LOCHOW | 8
public static final int | LOCLEN | 22
public static final int | LOCNAM | 26
public static final long | LOCSIG | 67324752L
public static final int | LOCSIZ | 18
public static final int | LOCTIM | 10
public static final int | LOCVER | 4
public static final int | STORED | 0

java.util.zip.ZipFile
Modifier and Type | Constant Field | Value
public static final int | CENATT | 36
public static final int | CENATX | 38
public static final int | CENCOM | 32
public static final int | CENCRC | 16
public static final int | CENDSK | 34
public static final int | CENEXT | 30
public static final int | CENFLG | 8
public static final int | CENHDR | 46
public static final int | CENHOW | 10
public static final int | CENLEN | 24
public static final int | CENNAM | 28
public static final int | CENOFF | 42
public static final long | CENSIG | 33639248L
public static final int | CENSIZ | 20
public static final int | CENTIM | 12
public static final int | CENVEM | 4
public static final int | CENVER | 6
public static final int | ENDCOM | 20
public static final int | ENDHDR | 22
public static final int | ENDOFF | 16
public static final long | ENDSIG | 101010256L
public static final int | ENDSIZ | 12
public static final int | ENDSUB | 8
public static final int | ENDTOT | 10
public static final int | EXTCRC | 4
public static final int | EXTHDR | 16
public static final int | EXTLEN | 12
public static final long | EXTSIG | 134695760L
public static final int | EXTSIZ | 8
public static final int | LOCCRC | 14
public static final int | LOCEXT | 28
public static final int | LOCFLG | 6
public static final int | LOCHDR | 30
public static final int | LOCHOW | 8
public static final int | LOCLEN | 22
public static final int | LOCNAM | 26
public static final long | LOCSIG | 67324752L
public static final int | LOCSIZ | 18
public static final int | LOCTIM | 10
public static final int | LOCVER | 4
public static final int | OPEN_DELETE | 4
public static final int | OPEN_READ | 1

java.util.zip.ZipInputStream
Modifier and Type | Constant Field | Value
public static final int | CENATT | 36
public static final int | CENATX | 38
public static final int | CENCOM | 32
public static final int | CENCRC | 16
public static final int | CENDSK | 34
public static final int | CENEXT | 30
public static final int | CENFLG | 8
public static final int | CENHDR | 46
public static final int | CENHOW | 10
public static final int | CENLEN | 24
public static final int | CENNAM | 28
public static final int | CENOFF | 42
public static final long | CENSIG | 33639248L
public static final int | CENSIZ | 20
public static final int | CENTIM | 12
public static final int | CENVEM | 4
public static final int | CENVER | 6
public static final int | ENDCOM | 20
public static final int | ENDHDR | 22
public static final int | ENDOFF | 16
public static final long | ENDSIG | 101010256L
public static final int | ENDSIZ | 12
public static final int | ENDSUB | 8
public static final int | ENDTOT | 10
public static final int | EXTCRC | 4
public static final int | EXTHDR | 16
public static final int | EXTLEN | 12
public static final long | EXTSIG | 134695760L
public static final int | EXTSIZ | 8
public static final int | LOCCRC | 14
public static final int | LOCEXT | 28
public static final int | LOCFLG | 6
public static final int | LOCHDR | 30
public static final int | LOCHOW | 8
public static final int | LOCLEN | 22
public static final int | LOCNAM | 26
public static final long | LOCSIG | 67324752L
public static final int | LOCSIZ | 18
public static final int | LOCTIM | 10
public static final int | LOCVER | 4

java.util.zip.ZipOutputStream
Modifier and Type | Constant Field | Value
public static final int | CENATT | 36
public static final int | CENATX | 38
public static final int | CENCOM | 32
public static final int | CENCRC | 16
public static final int | CENDSK | 34
public static final int | CENEXT | 30
public static final int | CENFLG | 8
public static final int | CENHDR | 46
public static final int | CENHOW | 10
public static final int | CENLEN | 24
public static final int | CENNAM | 28
public static final int | CENOFF | 42
public static final long | CENSIG | 33639248L
public static final int | CENSIZ | 20
public static final int | CENTIM | 12
public static final int | CENVEM | 4
public static final int | CENVER | 6
public static final int | DEFLATED | 8
public static final int | ENDCOM | 20
public static final int | ENDHDR | 22
public static final int | ENDOFF | 16
public static final long | ENDSIG | 101010256L
public static final int | ENDSIZ | 12
public static final int | ENDSUB | 8
public static final int | ENDTOT | 10
public static final int | EXTCRC | 4
public static final int | EXTHDR | 16
public static final int | EXTLEN | 12
public static final long | EXTSIG | 134695760L
public static final int | EXTSIZ | 8
public static final int | LOCCRC | 14
public static final int | LOCEXT | 28
public static final int | LOCFLG | 6
public static final int | LOCHDR | 30
public static final int | LOCHOW | 8
public static final int | LOCLEN | 22
public static final int | LOCNAM | 26
public static final long | LOCSIG | 67324752L
public static final int | LOCSIZ | 18
public static final int | LOCTIM | 10
public static final int | LOCVER | 4
public static final int | STORED | 0

javax.accessibility.*

javax.accessibility.AccessibleContext
Modifier and Type | Constant Field | Value
public static final String | ACCESSIBLE_ACTION_PROPERTY | "accessibleActionProperty"
public static final String | ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY | "AccessibleActiveDescendant"
public static final String | ACCESSIBLE_CARET_PROPERTY | "AccessibleCaret"
public static final String | ACCESSIBLE_CHILD_PROPERTY | "AccessibleChild"
public static final String | ACCESSIBLE_COMPONENT_BOUNDS_CHANGED | "accessibleComponentBoundsChanged"
public static final String | ACCESSIBLE_DESCRIPTION_PROPERTY | "AccessibleDescription"
public static final String | ACCESSIBLE_HYPERTEXT_OFFSET | "AccessibleHypertextOffset"
public static final String | ACCESSIBLE_INVALIDATE_CHILDREN | "accessibleInvalidateChildren"
public static final String | ACCESSIBLE_NAME_PROPERTY | "AccessibleName"
public static final String | ACCESSIBLE_SELECTION_PROPERTY | "AccessibleSelection"
public static final String | ACCESSIBLE_STATE_PROPERTY | "AccessibleState"
public static final String | ACCESSIBLE_TABLE_CAPTION_CHANGED | "accessibleTableCaptionChanged"
public static final String | ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED | "accessibleTableColumnDescriptionChanged"
public static final String | ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED | "accessibleTableColumnHeaderChanged"
public static final String | ACCESSIBLE_TABLE_MODEL_CHANGED | "accessibleTableModelChanged"
public static final String | ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED | "accessibleTableRowDescriptionChanged"
public static final String | ACCESSIBLE_TABLE_ROW_HEADER_CHANGED | "accessibleTableRowHeaderChanged"
public static final String | ACCESSIBLE_TABLE_SUMMARY_CHANGED | "accessibleTableSummaryChanged"
public static final String | ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED | "accessibleTextAttributesChanged"
public static final String | ACCESSIBLE_TEXT_PROPERTY | "AccessibleText"
public static final String | ACCESSIBLE_VALUE_PROPERTY | "AccessibleValue"
public static final String | ACCESSIBLE_VISIBLE_DATA_PROPERTY | "AccessibleVisibleData"

javax.accessibility.AccessibleExtendedText
Modifier and Type | Constant Field | Value
public static final int | ATTRIBUTE_RUN | 5
public static final int | LINE | 4

javax.accessibility.AccessibleRelation
Modifier and Type | Constant Field | Value
public static final String | CHILD_NODE_OF | "childNodeOf"
public static final String | CHILD_NODE_OF_PROPERTY | "childNodeOfProperty"
public static final String | CONTROLLED_BY_PROPERTY | "controlledByProperty"
public static final String | CONTROLLER_FOR_PROPERTY | "controllerForProperty"
public static final String | EMBEDDED_BY | "embeddedBy"
public static final String | EMBEDDED_BY_PROPERTY | "embeddedByProperty"
public static final String | EMBEDS | "embeds"
public static final String | EMBEDS_PROPERTY | "embedsProperty"
public static final String | FLOWS_FROM | "flowsFrom"
public static final String | FLOWS_FROM_PROPERTY | "flowsFromProperty"
public static final String | FLOWS_TO | "flowsTo"
public static final String | FLOWS_TO_PROPERTY | "flowsToProperty"
public static final String | LABEL_FOR_PROPERTY | "labelForProperty"
public static final String | LABELED_BY_PROPERTY | "labeledByProperty"
public static final String | MEMBER_OF_PROPERTY | "memberOfProperty"
public static final String | PARENT_WINDOW_OF | "parentWindowOf"
public static final String | PARENT_WINDOW_OF_PROPERTY | "parentWindowOfProperty"
public static final String | SUBWINDOW_OF | "subwindowOf"
public static final String | SUBWINDOW_OF_PROPERTY | "subwindowOfProperty"

javax.accessibility.AccessibleTableModelChange
Modifier and Type | Constant Field | Value
public static final int | DELETE | -1
public static final int | INSERT | 1
public static final int | UPDATE | 0

javax.accessibility.AccessibleText
Modifier and Type | Constant Field | Value
public static final int | CHARACTER | 1
public static final int | SENTENCE | 3
public static final int | WORD | 2

javax.crypto.*

javax.crypto.Cipher
Modifier and Type | Constant Field | Value
public static final int | DECRYPT_MODE | 2
public static final int | ENCRYPT_MODE | 1
public static final int | PRIVATE_KEY | 2
public static final int | PUBLIC_KEY | 1
public static final int | SECRET_KEY | 3
public static final int | UNWRAP_MODE | 4
public static final int | WRAP_MODE | 3

javax.crypto.SecretKey
Modifier and Type | Constant Field | Value
public static final long | serialVersionUID | -4795878709595146952L

javax.crypto.interfaces.DHPrivateKey
Modifier and Type | Constant Field | Value
public static final long | serialVersionUID | 2211791113380396553L

javax.crypto.interfaces.DHPublicKey
Modifier and Type | Constant Field | Value
public static final long | serialVersionUID | -6628103563352519193L

javax.crypto.interfaces.PBEKey
Modifier and Type | Constant Field | Value
public static final long | serialVersionUID | -1430015993304333921L

javax.crypto.spec.DESedeKeySpec
Modifier and Type | Constant Field | Value
public static final int | DES_EDE_KEY_LEN | 24

javax.crypto.spec.DESKeySpec
Modifier and Type | Constant Field | Value
public static final int | DES_KEY_LEN | 8

javax.imageio.*

javax.imageio.ImageWriteParam
Modifier and Type | Constant Field | Value
public static final int | MODE_COPY_FROM_METADATA | 3
public static final int | MODE_DEFAULT | 1
public static final int | MODE_DISABLED | 0
public static final int | MODE_EXPLICIT | 2

javax.imageio.metadata.IIOMetadataFormat
Modifier and Type | Constant Field | Value
public static final int | CHILD_POLICY_ALL | 1
public static final int | CHILD_POLICY_CHOICE | 3
public static final int | CHILD_POLICY_EMPTY | 0
public static final int | CHILD_POLICY_MAX | 5
public static final int | CHILD_POLICY_REPEAT | 5
public static final int | CHILD_POLICY_SEQUENCE | 4
public static final int | CHILD_POLICY_SOME | 2
public static final int | DATATYPE_BOOLEAN | 1
public static final int | DATATYPE_DOUBLE | 4
public static final int | DATATYPE_FLOAT | 3
public static final int | DATATYPE_INTEGER | 2
public static final int | DATATYPE_STRING | 0
public static final int | VALUE_ARBITRARY | 1
public static final int | VALUE_ENUMERATION | 16
public static final int | VALUE_LIST | 32
public static final int | VALUE_NONE | 0
public static final int | VALUE_RANGE | 2
public static final int | VALUE_RANGE_MAX_INCLUSIVE | 10
public static final int | VALUE_RANGE_MAX_INCLUSIVE_MASK | 8
public static final int | VALUE_RANGE_MIN_INCLUSIVE | 6
public static final int | VALUE_RANGE_MIN_INCLUSIVE_MASK | 4
public static final int | VALUE_RANGE_MIN_MAX_INCLUSIVE | 14

javax.imageio.metadata.IIOMetadataFormatImpl
Modifier and Type | Constant Field | Value
public static final String | standardMetadataFormatName | "javax_imageio_1.0"

javax.management.*

javax.management.AttributeChangeNotification
Modifier and Type | Constant Field | Value
public static final String | ATTRIBUTE_CHANGE | "jmx.attribute.change"

javax.management.ClientContext
Modifier and Type | Constant Field | Value
public static final String | LOCALE_KEY | "jmx.locale"
public static final String | NAMESPACE | "jmx.context"

javax.management.JMX
Modifier and Type | Constant Field | Value
public static final String | DEFAULT_VALUE_FIELD | "defaultValue"
public static final String | DESCRIPTION_RESOURCE_BUNDLE_BASE_NAME_FIELD | "descriptionResourceBundleBaseName"
public static final String | DESCRIPTION_RESOURCE_KEY_FIELD | "descriptionResourceKey"
public static final String | EXCEPTIONS_FIELD | "exceptions"
public static final String | IMMUTABLE_INFO_FIELD | "immutableInfo"
public static final String | INTERFACE_CLASS_NAME_FIELD | "interfaceClassName"
public static final String | LEGAL_VALUES_FIELD | "legalValues"
public static final String | LOCALE_FIELD | "locale"
public static final String | MAX_VALUE_FIELD | "maxValue"
public static final String | MIN_VALUE_FIELD | "minValue"
public static final String | MXBEAN_FIELD | "mxbean"
public static final String | MXBEAN_MAPPING_FACTORY_CLASS_FIELD | "mxbeanMappingFactoryClass"
public static final String | OBJECT_NAME_TEMPLATE | "objectNameTemplate"
public static final String | OPEN_TYPE_FIELD | "openType"
public static final String | ORIGINAL_TYPE_FIELD | "originalType"
public static final String | SET_EXCEPTIONS_FIELD | "setExceptions"

javax.management.MBeanOperationInfo
Modifier and Type | Constant Field | Value
public static final int | ACTION | 1
public static final int | ACTION_INFO | 2
public static final int | INFO | 0
public static final int | UNKNOWN | 3

javax.management.MBeanServerFactory
Modifier and Type | Constant Field | Value
public static final String | DEFAULT_MBEANSERVER_NAME | "default"

javax.management.MBeanServerNotification
Modifier and Type | Constant Field | Value
public static final String | REGISTRATION_NOTIFICATION | "JMX.mbean.registered"
public static final String | UNREGISTRATION_NOTIFICATION | "JMX.mbean.unregistered"

javax.management.ObjectName
Modifier and Type | Constant Field | Value
public static final String | NAMESPACE_SEPARATOR | "//"

javax.management.Query
Modifier and Type | Constant Field | Value
public static final int | DIV | 3
public static final int | EQ | 4
public static final int | GE | 2
public static final int | GT | 0
public static final int | LE | 3
public static final int | LT | 1
public static final int | MINUS | 1
public static final int | PLUS | 0
public static final int | TIMES | 2

javax.management.event.EventClient
Modifier and Type | Constant Field | Value
public static final long | DEFAULT_REQUESTED_LEASE_TIME | 300000L
public static final String | FAILED | "jmx.event.service.failed"
public static final String | NONFATAL | "jmx.event.service.nonfatal"
public static final String | NOTIFS_LOST | "jmx.event.service.notifs.lost"

javax.management.event.EventClientDelegateMBean
Modifier and Type | Constant Field | Value
public static final int | EVENT_CLIENT_LISTENER_ID | -100
public static final String | OBJECT_NAME_STRING | "javax.management.event:type=EventClientDelegate"

javax.management.event.FetchingEventRelay
Modifier and Type | Constant Field | Value
public static final int | DEFAULT_BUFFER_SIZE | 1000
public static final int | DEFAULT_MAX_NOTIFICATIONS | 1000
public static final long | DEFAULT_WAITING_TIMEOUT | 60000L

javax.management.monitor.Monitor
Modifier and Type | Constant Field | Value
protected static final int | capacityIncrement | 16
protected static final int | OBSERVED_ATTRIBUTE_ERROR_NOTIFIED | 2
protected static final int | OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED | 4
protected static final int | OBSERVED_OBJECT_ERROR_NOTIFIED | 1
protected static final int | RESET_FLAGS_ALREADY_NOTIFIED | 0
protected static final int | RUNTIME_ERROR_NOTIFIED | 8

javax.management.monitor.MonitorNotification
Modifier and Type | Constant Field | Value
public static final String | OBSERVED_ATTRIBUTE_ERROR | "jmx.monitor.error.attribute"
public static final String | OBSERVED_ATTRIBUTE_TYPE_ERROR | "jmx.monitor.error.type"
public static final String | OBSERVED_OBJECT_ERROR | "jmx.monitor.error.mbean"
public static final String | RUNTIME_ERROR | "jmx.monitor.error.runtime"
public static final String | STRING_TO_COMPARE_VALUE_DIFFERED | "jmx.monitor.string.differs"
public static final String | STRING_TO_COMPARE_VALUE_MATCHED | "jmx.monitor.string.matches"
public static final String | THRESHOLD_ERROR | "jmx.monitor.error.threshold"
public static final String | THRESHOLD_HIGH_VALUE_EXCEEDED | "jmx.monitor.gauge.high"
public static final String | THRESHOLD_LOW_VALUE_EXCEEDED | "jmx.monitor.gauge.low"
public static final String | THRESHOLD_VALUE_EXCEEDED | "jmx.monitor.counter.threshold"

javax.management.namespace.JMXDomain
Modifier and Type | Constant Field | Value
public static final String | TYPE | "JMXDomain"
public static final String | TYPE_ASSIGNMENT | "type=JMXDomain"

javax.management.namespace.JMXNamespace
Modifier and Type | Constant Field | Value
public static final String | TYPE | "JMXNamespace"
public static final String | TYPE_ASSIGNMENT | "type=JMXNamespace"

javax.management.namespace.JMXNamespaces
Modifier and Type | Constant Field | Value
public static final String | NAMESPACE_SEPARATOR | "//"

javax.management.relation.RelationNotification
Modifier and Type | Constant Field | Value
public static final String | RELATION_BASIC_CREATION | "jmx.relation.creation.basic"
public static final String | RELATION_BASIC_REMOVAL | "jmx.relation.removal.basic"
public static final String | RELATION_BASIC_UPDATE | "jmx.relation.update.basic"
public static final String | RELATION_MBEAN_CREATION | "jmx.relation.creation.mbean"
public static final String | RELATION_MBEAN_REMOVAL | "jmx.relation.removal.mbean"
public static final String | RELATION_MBEAN_UPDATE | "jmx.relation.update.mbean"

javax.management.relation.RoleInfo
Modifier and Type | Constant Field | Value
public static final int | ROLE_CARDINALITY_INFINITY | -1

javax.management.relation.RoleStatus
Modifier and Type | Constant Field | Value
public static final int | LESS_THAN_MIN_ROLE_DEGREE | 4
public static final int | MORE_THAN_MAX_ROLE_DEGREE | 5
public static final int | NO_ROLE_WITH_NAME | 1
public static final int | REF_MBEAN_NOT_REGISTERED | 7
public static final int | REF_MBEAN_OF_INCORRECT_CLASS | 6
public static final int | ROLE_NOT_READABLE | 2
public static final int | ROLE_NOT_WRITABLE | 3

javax.management.remote.JMXConnectionNotification
Modifier and Type | Constant Field | Value
public static final String | CLOSED | "jmx.remote.connection.closed"
public static final String | FAILED | "jmx.remote.connection.failed"
public static final String | NOTIFS_LOST | "jmx.remote.connection.notifs.lost"
public static final String | OPENED | "jmx.remote.connection.opened"

javax.management.remote.JMXConnector
Modifier and Type | Constant Field | Value
public static final String | CREDENTIALS | "jmx.remote.credentials"
public static final String | USE_EVENT_SERVICE | "jmx.remote.use.event.service"

javax.management.remote.JMXConnectorFactory
Modifier and Type | Constant Field | Value
public static final String | DEFAULT_CLASS_LOADER | "jmx.remote.default.class.loader"
public static final String | PROTOCOL_PROVIDER_CLASS_LOADER | "jmx.remote.protocol.provider.class.loader"
public static final String | PROTOCOL_PROVIDER_PACKAGES | "jmx.remote.protocol.provider.pkgs"

javax.management.remote.JMXConnectorServer
Modifier and Type | Constant Field | Value
public static final String | AUTHENTICATOR | "jmx.remote.authenticator"
public static final String | CONTEXT_FORWARDER | "jmx.remote.context.forwarder"
public static final String | DELEGATE_TO_EVENT_SERVICE | "jmx.remote.delegate.event.service"
public static final String | EVENT_CLIENT_DELEGATE_FORWARDER | "jmx.remote.event.client.delegate.forwarder"
public static final String | LOCALIZE_MBEAN_INFO_FORWARDER | "jmx.remote.localize.mbean.info"

javax.management.remote.JMXConnectorServerFactory
Modifier and Type | Constant Field | Value
public static final String | DEFAULT_CLASS_LOADER | "jmx.remote.default.class.loader"
public static final String | DEFAULT_CLASS_LOADER_NAME | "jmx.remote.default.class.loader.name"
public static final String | PROTOCOL_PROVIDER_CLASS_LOADER | "jmx.remote.protocol.provider.class.loader"
public static final String | PROTOCOL_PROVIDER_PACKAGES | "jmx.remote.protocol.provider.pkgs"

javax.management.remote.rmi.RMIConnectorServer
Modifier and Type | Constant Field | Value
public static final String | JNDI_REBIND_ATTRIBUTE | "jmx.remote.jndi.rebind"
public static final String | RMI_CLIENT_SOCKET_FACTORY_ATTRIBUTE | "jmx.remote.rmi.client.socket.factory"
public static final String | RMI_SERVER_SOCKET_FACTORY_ATTRIBUTE | "jmx.remote.rmi.server.socket.factory"

javax.management.timer.Timer
Modifier and Type | Constant Field | Value
public static final long | ONE_DAY | 86400000L
public static final long | ONE_HOUR | 3600000L
public static final long | ONE_MINUTE | 60000L
public static final long | ONE_SECOND | 1000L
public static final long | ONE_WEEK | 604800000L

javax.naming.*

javax.naming.Context
Modifier and Type | Constant Field | Value
public static final String | APPLET | "java.naming.applet"
public static final String | AUTHORITATIVE | "java.naming.authoritative"
public static final String | BATCHSIZE | "java.naming.batchsize"
public static final String | DNS_URL | "java.naming.dns.url"
public static final String | INITIAL_CONTEXT_FACTORY | "java.naming.factory.initial"
public static final String | LANGUAGE | "java.naming.language"
public static final String | OBJECT_FACTORIES | "java.naming.factory.object"
public static final String | PROVIDER_URL | "java.naming.provider.url"
public static final String | REFERRAL | "java.naming.referral"
public static final String | SECURITY_AUTHENTICATION | "java.naming.security.authentication"
public static final String | SECURITY_CREDENTIALS | "java.naming.security.credentials"
public static final String | SECURITY_PRINCIPAL | "java.naming.security.principal"
public static final String | SECURITY_PROTOCOL | "java.naming.security.protocol"
public static final String | STATE_FACTORIES | "java.naming.factory.state"
public static final String | URL_PKG_PREFIXES | "java.naming.factory.url.pkgs"

javax.naming.Name
Modifier and Type | Constant Field | Value
public static final long | serialVersionUID | -3617482732056931635L

javax.naming.directory.Attribute
Modifier and Type | Constant Field | Value
public static final long | serialVersionUID | 8707690322213556804L

javax.naming.directory.DirContext
Modifier and Type | Constant Field | Value
public static final int | ADD_ATTRIBUTE | 1
public static final int | REMOVE_ATTRIBUTE | 3
public static final int | REPLACE_ATTRIBUTE | 2

javax.naming.directory.SearchControls
Modifier and Type | Constant Field | Value
public static final int | OBJECT_SCOPE | 0
public static final int | ONELEVEL_SCOPE | 1
public static final int | SUBTREE_SCOPE | 2

javax.naming.event.EventContext
Modifier and Type | Constant Field | Value
public static final int | OBJECT_SCOPE | 0
public static final int | ONELEVEL_SCOPE | 1
public static final int | SUBTREE_SCOPE | 2

javax.naming.event.NamingEvent
Modifier and Type | Constant Field | Value
public static final int | OBJECT_ADDED | 0
public static final int | OBJECT_CHANGED | 3
public static final int | OBJECT_REMOVED | 1
public static final int | OBJECT_RENAMED | 2

javax.naming.ldap.Control
Modifier and Type | Constant Field | Value
public static final boolean | CRITICAL | true
public static final boolean | NONCRITICAL | false

javax.naming.ldap.LdapContext
Modifier and Type | Constant Field | Value
public static final String | CONTROL_FACTORIES | "java.naming.factory.control"

javax.naming.ldap.ManageReferralControl
Modifier and Type | Constant Field | Value
public static final String | OID | "2.16.840.1.113730.3.4.2"

javax.naming.ldap.PagedResultsControl
Modifier and Type | Constant Field | Value
public static final String | OID | "1.2.840.113556.1.4.319"

javax.naming.ldap.PagedResultsResponseControl
Modifier and Type | Constant Field | Value
public static final String | OID | "1.2.840.113556.1.4.319"

javax.naming.ldap.SortControl
Modifier and Type | Constant Field | Value
public static final String | OID | "1.2.840.113556.1.4.473"

javax.naming.ldap.SortResponseControl
Modifier and Type | Constant Field | Value
public static final String | OID | "1.2.840.113556.1.4.474"

javax.naming.ldap.StartTlsRequest
Modifier and Type | Constant Field | Value
public static final String | OID | "1.3.6.1.4.1.1466.20037"

javax.naming.ldap.StartTlsResponse
Modifier and Type | Constant Field | Value
public static final String | OID | "1.3.6.1.4.1.1466.20037"

javax.naming.spi.NamingManager
Modifier and Type | Constant Field | Value
public static final String | CPE | "java.naming.spi.CannotProceedException"

javax.print.*

javax.print.ServiceUIFactory
Modifier and Type | Constant Field | Value
public static final int | ABOUT_UIROLE | 1
public static final int | ADMIN_UIROLE | 2
public static final String | DIALOG_UI | "java.awt.Dialog"
public static final String | JCOMPONENT_UI | "javax.swing.JComponent"
public static final String | JDIALOG_UI | "javax.swing.JDialog"
public static final int | MAIN_UIROLE | 3
public static final String | PANEL_UI | "java.awt.Panel"
public static final int | RESERVED_UIROLE | 99

javax.print.URIException
Modifier and Type | Constant Field | Value
public static final int | URIInaccessible | 1
public static final int | URIOtherProblem | -1
public static final int | URISchemeNotSupported | 2

javax.print.attribute.ResolutionSyntax
Modifier and Type | Constant Field | Value
public static final int | DPCM | 254
public static final int | DPI | 100

javax.print.attribute.Size2DSyntax
Modifier and Type | Constant Field | Value
public static final int | INCH | 25400
public static final int | MM | 1000

javax.print.attribute.standard.MediaPrintableArea
Modifier and Type | Constant Field | Value
public static final int | INCH | 25400
public static final int | MM | 1000

javax.print.event.PrintJobEvent
Modifier and Type | Constant Field | Value
public static final int | DATA_TRANSFER_COMPLETE | 106
public static final int | JOB_CANCELED | 101
public static final int | JOB_COMPLETE | 102
public static final int | JOB_FAILED | 103
public static final int | NO_MORE_EVENTS | 105
public static final int | REQUIRES_ATTENTION | 104

javax.script.*

javax.script.ScriptContext
Modifier and Type | Constant Field | Value
public static final int | ENGINE_SCOPE | 100
public static final int | GLOBAL_SCOPE | 200

javax.script.ScriptEngine
Modifier and Type | Constant Field | Value
public static final String | ARGV | "javax.script.argv"
public static final String | ENGINE | "javax.script.engine"
public static final String | ENGINE_VERSION | "javax.script.engine_version"
public static final String | FILENAME | "javax.script.filename"
public static final String | LANGUAGE | "javax.script.language"
public static final String | LANGUAGE_VERSION | "javax.script.language_version"
public static final String | NAME | "javax.script.name"

javax.security.*

javax.security.auth.callback.ConfirmationCallback
Modifier and Type | Constant Field | Value
public static final int | CANCEL | 2
public static final int | ERROR | 2
public static final int | INFORMATION | 0
public static final int | NO | 1
public static final int | OK | 3
public static final int | OK_CANCEL_OPTION | 2
public static final int | UNSPECIFIED_OPTION | -1
public static final int | WARNING | 1
public static final int | YES | 0
public static final int | YES_NO_CANCEL_OPTION | 1
public static final int | YES_NO_OPTION | 0

javax.security.auth.callback.TextOutputCallback
Modifier and Type | Constant Field | Value
public static final int | ERROR | 2
public static final int | INFORMATION | 0
public static final int | WARNING | 1

javax.security.auth.kerberos.KerberosPrincipal
Modifier and Type | Constant Field | Value
public static final int | KRB_NT_PRINCIPAL | 1
public static final int | KRB_NT_SRV_HST | 3
public static final int | KRB_NT_SRV_INST | 2
public static final int | KRB_NT_SRV_XHST | 4
public static final int | KRB_NT_UID | 5
public static final int | KRB_NT_UNKNOWN | 0

javax.security.auth.x500.X500Principal
Modifier and Type | Constant Field | Value
public static final String | CANONICAL | "CANONICAL"
public static final String | RFC1779 | "RFC1779"
public static final String | RFC2253 | "RFC2253"

javax.security.sasl.Sasl
Modifier and Type | Constant Field | Value
public static final String | CREDENTIALS | "javax.security.sasl.credentials"
public static final String | MAX_BUFFER | "javax.security.sasl.maxbuffer"
public static final String | POLICY_FORWARD_SECRECY | "javax.security.sasl.policy.forward"
public static final String | POLICY_NOACTIVE | "javax.security.sasl.policy.noactive"
public static final String | POLICY_NOANONYMOUS | "javax.security.sasl.policy.noanonymous"
public static final String | POLICY_NODICTIONARY | "javax.security.sasl.policy.nodictionary"
public static final String | POLICY_NOPLAINTEXT | "javax.security.sasl.policy.noplaintext"
public static final String | POLICY_PASS_CREDENTIALS | "javax.security.sasl.policy.credentials"
public static final String | QOP | "javax.security.sasl.qop"
public static final String | RAW_SEND_SIZE | "javax.security.sasl.rawsendsize"
public static final String | REUSE | "javax.security.sasl.reuse"
public static final String | SERVER_AUTH | "javax.security.sasl.server.authentication"
public static final String | STRENGTH | "javax.security.sasl.strength"

javax.sound.*

javax.sound.midi.MetaMessage
Modifier and Type | Constant Field | Value
public static final int | META | 255

javax.sound.midi.MidiFileFormat
Modifier and Type | Constant Field | Value
public static final int | UNKNOWN_LENGTH | -1

javax.sound.midi.Sequence
Modifier and Type | Constant Field | Value
public static final float | PPQ | 0.0f
public static final float | SMPTE_24 | 24.0f
public static final float | SMPTE_25 | 25.0f
public static final float | SMPTE_30 | 30.0f
public static final float | SMPTE_30DROP | 29.969999313354492f

javax.sound.midi.Sequencer
Modifier and Type | Constant Field | Value
public static final int | LOOP_CONTINUOUSLY | -1

javax.sound.midi.ShortMessage
Modifier and Type | Constant Field | Value
public static final int | ACTIVE_SENSING | 254
public static final int | CHANNEL_PRESSURE | 208
public static final int | CONTINUE | 251
public static final int | CONTROL_CHANGE | 176
public static final int | END_OF_EXCLUSIVE | 247
public static final int | MIDI_TIME_CODE | 241
public static final int | NOTE_OFF | 128
public static final int | NOTE_ON | 144
public static final int | PITCH_BEND | 224
public static final int | POLY_PRESSURE | 160
public static final int | PROGRAM_CHANGE | 192
public static final int | SONG_POSITION_POINTER | 242
public static final int | SONG_SELECT | 243
public static final int | START | 250
public static final int | STOP | 252
public static final int | SYSTEM_RESET | 255
public static final int | TIMING_CLOCK | 248
public static final int | TUNE_REQUEST | 246

javax.sound.midi.SysexMessage
Modifier and Type | Constant Field | Value
public static final int | SPECIAL_SYSTEM_EXCLUSIVE | 247
public static final int | SYSTEM_EXCLUSIVE | 240

javax.sound.sampled.AudioSystem
Modifier and Type | Constant Field | Value
public static final int | NOT_SPECIFIED | -1

javax.sound.sampled.Clip
Modifier and Type | Constant Field | Value
public static final int | LOOP_CONTINUOUSLY | -1

javax.sql.*

javax.sql.rowset.BaseRowSet
Modifier and Type | Constant Field | Value
public static final int | ASCII_STREAM_PARAM | 2
public static final int | BINARY_STREAM_PARAM | 1
public static final int | UNICODE_STREAM_PARAM | 0

javax.sql.rowset.CachedRowSet
Modifier and Type | Constant Field | Value
public static final boolean | COMMIT_ON_ACCEPT_CHANGES | true

javax.sql.rowset.JoinRowSet
Modifier and Type | Constant Field | Value
public static final int | CROSS_JOIN | 0
public static final int | FULL_JOIN | 4
public static final int | INNER_JOIN | 1
public static final int | LEFT_OUTER_JOIN | 2
public static final int | RIGHT_OUTER_JOIN | 3

javax.sql.rowset.WebRowSet
Modifier and Type | Constant Field | Value
public static final String | PUBLIC_XML_SCHEMA | "--//Sun Microsystems, Inc.//XSD Schema//EN"
public static final String | SCHEMA_SYSTEM_ID | "http://java.sun.com/xml/ns/jdbc/webrowset.xsd"

javax.sql.rowset.spi.SyncResolver
Modifier and Type | Constant Field | Value
public static final int | DELETE_ROW_CONFLICT | 1
public static final int | INSERT_ROW_CONFLICT | 2
public static final int | NO_ROW_CONFLICT | 3
public static final int | UPDATE_ROW_CONFLICT | 0

javax.swing.*

javax.swing.AbstractButton
Modifier and Type | Constant Field | Value
public static final String | BORDER_PAINTED_CHANGED_PROPERTY | "borderPainted"
public static final String | CONTENT_AREA_FILLED_CHANGED_PROPERTY | "contentAreaFilled"
public static final String | DISABLED_ICON_CHANGED_PROPERTY | "disabledIcon"
public static final String | DISABLED_SELECTED_ICON_CHANGED_PROPERTY | "disabledSelectedIcon"
public static final String | FOCUS_PAINTED_CHANGED_PROPERTY | "focusPainted"
public static final String | HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY | "horizontalAlignment"
public static final String | HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY | "horizontalTextPosition"
public static final String | ICON_CHANGED_PROPERTY | "icon"
public static final String | MARGIN_CHANGED_PROPERTY | "margin"
public static final String | MNEMONIC_CHANGED_PROPERTY | "mnemonic"
public static final String | MODEL_CHANGED_PROPERTY | "model"
public static final String | PRESSED_ICON_CHANGED_PROPERTY | "pressedIcon"
public static final String | ROLLOVER_ENABLED_CHANGED_PROPERTY | "rolloverEnabled"
public static final String | ROLLOVER_ICON_CHANGED_PROPERTY | "rolloverIcon"
public static final String | ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY | "rolloverSelectedIcon"
public static final String | SELECTED_ICON_CHANGED_PROPERTY | "selectedIcon"
public static final String | TEXT_CHANGED_PROPERTY | "text"
public static final String | VERTICAL_ALIGNMENT_CHANGED_PROPERTY | "verticalAlignment"
public static final String | VERTICAL_TEXT_POSITION_CHANGED_PROPERTY | "verticalTextPosition"

javax.swing.Action
Modifier and Type | Constant Field | Value
public static final String | ACCELERATOR_KEY | "AcceleratorKey"
public static final String | ACTION_COMMAND_KEY | "ActionCommandKey"
public static final String | DEFAULT | "Default"
public static final String | DISPLAYED_MNEMONIC_INDEX_KEY | "SwingDisplayedMnemonicIndexKey"
public static final String | LARGE_ICON_KEY | "SwingLargeIconKey"
public static final String | LONG_DESCRIPTION | "LongDescription"
public static final String | MNEMONIC_KEY | "MnemonicKey"
public static final String | NAME | "Name"
public static final String | SELECTED_KEY | "SwingSelectedKey"
public static final String | SHORT_DESCRIPTION | "ShortDescription"
public static final String | SMALL_ICON | "SmallIcon"

javax.swing.BoxLayout
Modifier and Type | Constant Field | Value
public static final int | LINE_AXIS | 2
public static final int | PAGE_AXIS | 3
public static final int | X_AXIS | 0
public static final int | Y_AXIS | 1

javax.swing.DebugGraphics
Modifier and Type | Constant Field | Value
public static final int | BUFFERED_OPTION | 4
public static final int | FLASH_OPTION | 2
public static final int | LOG_OPTION | 1
public static final int | NONE_OPTION | -1

javax.swing.DefaultButtonModel
Modifier and Type | Constant Field | Value
public static final int | ARMED | 1
public static final int | ENABLED | 8
public static final int | PRESSED | 4
public static final int | ROLLOVER | 16
public static final int | SELECTED | 2

javax.swing.FocusManager
Modifier and Type | Constant Field | Value
public static final String | FOCUS_MANAGER_CLASS_PROPERTY | "FocusManagerClassName"

javax.swing.GroupLayout
Modifier and Type | Constant Field | Value
public static final int | DEFAULT_SIZE | -1
public static final int | PREFERRED_SIZE | -2

javax.swing.JCheckBox
Modifier and Type | Constant Field | Value
public static final String | BORDER_PAINTED_FLAT_CHANGED_PROPERTY | "borderPaintedFlat"

javax.swing.JColorChooser
Modifier and Type | Constant Field | Value
public static final String | CHOOSER_PANELS_PROPERTY | "chooserPanels"
public static final String | PREVIEW_PANEL_PROPERTY | "previewPanel"
public static final String | SELECTION_MODEL_PROPERTY | "selectionModel"

javax.swing.JComponent
Modifier and Type | Constant Field | Value
public static final String | TOOL_TIP_TEXT_KEY | "ToolTipText"
public static final int | UNDEFINED_CONDITION | -1
public static final int | WHEN_ANCESTOR_OF_FOCUSED_COMPONENT | 1
public static final int | WHEN_FOCUSED | 0
public static final int | WHEN_IN_FOCUSED_WINDOW | 2

javax.swing.JDesktopPane
Modifier and Type | Constant Field | Value
public static final int | LIVE_DRAG_MODE | 0
public static final int | OUTLINE_DRAG_MODE | 1

javax.swing.JEditorPane
Modifier and Type | Constant Field | Value
public static final String | HONOR_DISPLAY_PROPERTIES | "JEditorPane.honorDisplayProperties"
public static final String | W3C_LENGTH_UNITS | "JEditorPane.w3cLengthUnits"

javax.swing.JFileChooser
Modifier and Type | Constant Field | Value
public static final String | ACCEPT_ALL_FILE_FILTER_USED_CHANGED_PROPERTY | "acceptAllFileFilterUsedChanged"
public static final String | ACCESSORY_CHANGED_PROPERTY | "AccessoryChangedProperty"
public static final String | APPROVE_BUTTON_MNEMONIC_CHANGED_PROPERTY | "ApproveButtonMnemonicChangedProperty"
public static final String | APPROVE_BUTTON_TEXT_CHANGED_PROPERTY | "ApproveButtonTextChangedProperty"
public static final String | APPROVE_BUTTON_TOOL_TIP_TEXT_CHANGED_PROPERTY | "ApproveButtonToolTipTextChangedProperty"
public static final int | APPROVE_OPTION | 0
public static final String | APPROVE_SELECTION | "ApproveSelection"
public static final int | CANCEL_OPTION | 1
public static final String | CANCEL_SELECTION | "CancelSelection"
public static final String | CHOOSABLE_FILE_FILTER_CHANGED_PROPERTY | "ChoosableFileFilterChangedProperty"
public static final String | CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY | "ControlButtonsAreShownChangedProperty"
public static final int | CUSTOM_DIALOG | 2
public static final String | DIALOG_TITLE_CHANGED_PROPERTY | "DialogTitleChangedProperty"
public static final String | DIALOG_TYPE_CHANGED_PROPERTY | "DialogTypeChangedProperty"
public static final int | DIRECTORIES_ONLY | 1
public static final String | DIRECTORY_CHANGED_PROPERTY | "directoryChanged"
public static final int | ERROR_OPTION | -1
public static final String | FILE_FILTER_CHANGED_PROPERTY | "fileFilterChanged"
public static final String | FILE_HIDING_CHANGED_PROPERTY | "FileHidingChanged"
public static final String | FILE_SELECTION_MODE_CHANGED_PROPERTY | "fileSelectionChanged"
public static final String | FILE_SYSTEM_VIEW_CHANGED_PROPERTY | "FileSystemViewChanged"
public static final String | FILE_VIEW_CHANGED_PROPERTY | "fileViewChanged"
public static final int | FILES_AND_DIRECTORIES | 2
public static final int | FILES_ONLY | 0
public static final String | MULTI_SELECTION_ENABLED_CHANGED_PROPERTY | "MultiSelectionEnabledChangedProperty"
public static final int | OPEN_DIALOG | 0
public static final int | SAVE_DIALOG | 1
public static final String | SELECTED_FILE_CHANGED_PROPERTY | "SelectedFileChangedProperty"
public static final String | SELECTED_FILES_CHANGED_PROPERTY | "SelectedFilesChangedProperty"

javax.swing.JFormattedTextField
Modifier and Type | Constant Field | Value
public static final int | COMMIT | 0
public static final int | COMMIT_OR_REVERT | 1
public static final int | PERSIST | 3
public static final int | REVERT | 2

javax.swing.JFrame
Modifier and Type | Constant Field | Value
public static final int | EXIT_ON_CLOSE | 3

javax.swing.JInternalFrame
Modifier and Type | Constant Field | Value
public static final String | CONTENT_PANE_PROPERTY | "contentPane"
public static final String | FRAME_ICON_PROPERTY | "frameIcon"
public static final String | GLASS_PANE_PROPERTY | "glassPane"
public static final String | IS_CLOSED_PROPERTY | "closed"
public static final String | IS_ICON_PROPERTY | "icon"
public static final String | IS_MAXIMUM_PROPERTY | "maximum"
public static final String | IS_SELECTED_PROPERTY | "selected"
public static final String | LAYERED_PANE_PROPERTY | "layeredPane"
public static final String | MENU_BAR_PROPERTY | "JMenuBar"
public static final String | ROOT_PANE_PROPERTY | "rootPane"
public static final String | TITLE_PROPERTY | "title"

javax.swing.JLayeredPane
Modifier and Type | Constant Field | Value
public static final String | LAYER_PROPERTY | "layeredContainerLayer"

javax.swing.JList
Modifier and Type | Constant Field | Value
public static final int | HORIZONTAL_WRAP | 2
public static final int | VERTICAL | 0
public static final int | VERTICAL_WRAP | 1

javax.swing.JOptionPane
Modifier and Type | Constant Field | Value
public static final int | CANCEL_OPTION | 2
public static final int | CLOSED_OPTION | -1
public static final int | DEFAULT_OPTION | -1
public static final int | ERROR_MESSAGE | 0
public static final String | ICON_PROPERTY | "icon"
public static final int | INFORMATION_MESSAGE | 1
public static final String | INITIAL_SELECTION_VALUE_PROPERTY | "initialSelectionValue"
public static final String | INITIAL_VALUE_PROPERTY | "initialValue"
public static final String | INPUT_VALUE_PROPERTY | "inputValue"
public static final String | MESSAGE_PROPERTY | "message"
public static final String | MESSAGE_TYPE_PROPERTY | "messageType"
public static final int | NO_OPTION | 1
public static final int | OK_CANCEL_OPTION | 2
public static final int | OK_OPTION | 0
public static final String | OPTION_TYPE_PROPERTY | "optionType"
public static final String | OPTIONS_PROPERTY | "options"
public static final int | PLAIN_MESSAGE | -1
public static final int | QUESTION_MESSAGE | 3
public static final String | SELECTION_VALUES_PROPERTY | "selectionValues"
public static final String | VALUE_PROPERTY | "value"
public static final String | WANTS_INPUT_PROPERTY | "wantsInput"
public static final int | WARNING_MESSAGE | 2
public static final int | YES_NO_CANCEL_OPTION | 1
public static final int | YES_NO_OPTION | 0
public static final int | YES_OPTION | 0

javax.swing.JRootPane
Modifier and Type | Constant Field | Value
public static final int | COLOR_CHOOSER_DIALOG | 5
public static final int | ERROR_DIALOG | 4
public static final int | FILE_CHOOSER_DIALOG | 6
public static final int | FRAME | 1
public static final int | INFORMATION_DIALOG | 3
public static final int | NONE | 0
public static final int | PLAIN_DIALOG | 2
public static final int | QUESTION_DIALOG | 7
public static final int | WARNING_DIALOG | 8

javax.swing.JSplitPane
Modifier and Type | Constant Field | Value
public static final String | BOTTOM | "bottom"
public static final String | CONTINUOUS_LAYOUT_PROPERTY | "continuousLayout"
public static final String | DIVIDER | "divider"
public static final String | DIVIDER_LOCATION_PROPERTY | "dividerLocation"
public static final String | DIVIDER_SIZE_PROPERTY | "dividerSize"
public static final int | HORIZONTAL_SPLIT | 1
public static final String | LAST_DIVIDER_LOCATION_PROPERTY | "lastDividerLocation"
public static final String | LEFT | "left"
public static final String | ONE_TOUCH_EXPANDABLE_PROPERTY | "oneTouchExpandable"
public static final String | ORIENTATION_PROPERTY | "orientation"
public static final String | RESIZE_WEIGHT_PROPERTY | "resizeWeight"
public static final String | RIGHT | "right"
public static final String | TOP | "top"
public static final int | VERTICAL_SPLIT | 0

javax.swing.JTabbedPane
Modifier and Type | Constant Field | Value
public static final int | SCROLL_TAB_LAYOUT | 1
public static final int | WRAP_TAB_LAYOUT | 0

javax.swing.JTable
Modifier and Type | Constant Field | Value
public static final int | AUTO_RESIZE_ALL_COLUMNS | 4
public static final int | AUTO_RESIZE_LAST_COLUMN | 3
public static final int | AUTO_RESIZE_NEXT_COLUMN | 1
public static final int | AUTO_RESIZE_OFF | 0
public static final int | AUTO_RESIZE_SUBSEQUENT_COLUMNS | 2

javax.swing.JTextField
Modifier and Type | Constant Field | Value
public static final String | notifyAction | "notify-field-accept"

javax.swing.JTree
Modifier and Type | Constant Field | Value
public static final String | ANCHOR_SELECTION_PATH_PROPERTY | "anchorSelectionPath"
public static final String | CELL_EDITOR_PROPERTY | "cellEditor"
public static final String | CELL_RENDERER_PROPERTY | "cellRenderer"
public static final String | EDITABLE_PROPERTY | "editable"
public static final String | EXPANDS_SELECTED_PATHS_PROPERTY | "expandsSelectedPaths"
public static final String | INVOKES_STOP_CELL_EDITING_PROPERTY | "invokesStopCellEditing"
public static final String | LARGE_MODEL_PROPERTY | "largeModel"
public static final String | LEAD_SELECTION_PATH_PROPERTY | "leadSelectionPath"
public static final String | ROOT_VISIBLE_PROPERTY | "rootVisible"
public static final String | ROW_HEIGHT_PROPERTY | "rowHeight"
public static final String | SCROLLS_ON_EXPAND_PROPERTY | "scrollsOnExpand"
public static final String | SELECTION_MODEL_PROPERTY | "selectionModel"
public static final String | SHOWS_ROOT_HANDLES_PROPERTY | "showsRootHandles"
public static final String | TOGGLE_CLICK_COUNT_PROPERTY | "toggleClickCount"
public static final String | TREE_MODEL_PROPERTY | "model"
public static final String | VISIBLE_ROW_COUNT_PROPERTY | "visibleRowCount"

javax.swing.JViewport
Modifier and Type | Constant Field | Value
public static final int | BACKINGSTORE_SCROLL_MODE | 2
public static final int | BLIT_SCROLL_MODE | 1
public static final int | SIMPLE_SCROLL_MODE | 0

javax.swing.ListSelectionModel
Modifier and Type | Constant Field | Value
public static final int | MULTIPLE_INTERVAL_SELECTION | 2
public static final int | SINGLE_INTERVAL_SELECTION | 1
public static final int | SINGLE_SELECTION | 0

javax.swing.ScrollPaneConstants
Modifier and Type | Constant Field | Value
public static final String | COLUMN_HEADER | "COLUMN_HEADER"
public static final String | HORIZONTAL_SCROLLBAR | "HORIZONTAL_SCROLLBAR"
public static final int | HORIZONTAL_SCROLLBAR_ALWAYS | 32
public static final int | HORIZONTAL_SCROLLBAR_AS_NEEDED | 30
public static final int | HORIZONTAL_SCROLLBAR_NEVER | 31
public static final String | HORIZONTAL_SCROLLBAR_POLICY | "HORIZONTAL_SCROLLBAR_POLICY"
public static final String | LOWER_LEADING_CORNER | "LOWER_LEADING_CORNER"
public static final String | LOWER_LEFT_CORNER | "LOWER_LEFT_CORNER"
public static final String | LOWER_RIGHT_CORNER | "LOWER_RIGHT_CORNER"
public static final String | LOWER_TRAILING_CORNER | "LOWER_TRAILING_CORNER"
public static final String | ROW_HEADER | "ROW_HEADER"
public static final String | UPPER_LEADING_CORNER | "UPPER_LEADING_CORNER"
public static final String | UPPER_LEFT_CORNER | "UPPER_LEFT_CORNER"
public static final String | UPPER_RIGHT_CORNER | "UPPER_RIGHT_CORNER"
public static final String | UPPER_TRAILING_CORNER | "UPPER_TRAILING_CORNER"
public static final String | VERTICAL_SCROLLBAR | "VERTICAL_SCROLLBAR"
public static final int | VERTICAL_SCROLLBAR_ALWAYS | 22
public static final int | VERTICAL_SCROLLBAR_AS_NEEDED | 20
public static final int | VERTICAL_SCROLLBAR_NEVER | 21
public static final String | VERTICAL_SCROLLBAR_POLICY | "VERTICAL_SCROLLBAR_POLICY"
public static final String | VIEWPORT | "VIEWPORT"

javax.swing.Spring
Modifier and Type | Constant Field | Value
public static final int | UNSET | -2147483648

javax.swing.SpringLayout
Modifier and Type | Constant Field | Value
public static final String | BASELINE | "Baseline"
public static final String | EAST | "East"
public static final String | HEIGHT | "Height"
public static final String | HORIZONTAL_CENTER | "HorizontalCenter"
public static final String | NORTH | "North"
public static final String | SOUTH | "South"
public static final String | VERTICAL_CENTER | "VerticalCenter"
public static final String | WEST | "West"
public static final String | WIDTH | "Width"

javax.swing.SwingConstants
Modifier and Type | Constant Field | Value
public static final int | BOTTOM | 3
public static final int | CENTER | 0
public static final int | EAST | 3
public static final int | HORIZONTAL | 0
public static final int | LEADING | 10
public static final int | LEFT | 2
public static final int | NEXT | 12
public static final int | NORTH | 1
public static final int | NORTH_EAST | 2
public static final int | NORTH_WEST | 8
public static final int | PREVIOUS | 13
public static final int | RIGHT | 4
public static final int | SOUTH | 5
public static final int | SOUTH_EAST | 4
public static final int | SOUTH_WEST | 6
public static final int | TOP | 1
public static final int | TRAILING | 11
public static final int | VERTICAL | 1
public static final int | WEST | 7

javax.swing.TransferHandler
Modifier and Type | Constant Field | Value
public static final int | COPY | 1
public static final int | COPY_OR_MOVE | 3
public static final int | LINK | 1073741824
public static final int | MOVE | 2
public static final int | NONE | 0

javax.swing.WindowConstants
Modifier and Type | Constant Field | Value
public static final int | DISPOSE_ON_CLOSE | 2
public static final int | DO_NOTHING_ON_CLOSE | 0
public static final int | EXIT_ON_CLOSE | 3
public static final int | HIDE_ON_CLOSE | 1

javax.swing.border.BevelBorder
Modifier and Type | Constant Field | Value
public static final int | LOWERED | 1
public static final int | RAISED | 0

javax.swing.border.EtchedBorder
Modifier and Type | Constant Field | Value
public static final int | LOWERED | 1
public static final int | RAISED | 0

javax.swing.border.TitledBorder
Modifier and Type | Constant Field | Value
public static final int | ABOVE_BOTTOM | 4
public static final int | ABOVE_TOP | 1
public static final int | BELOW_BOTTOM | 6
public static final int | BELOW_TOP | 3
public static final int | BOTTOM | 5
public static final int | CENTER | 2
public static final int | DEFAULT_JUSTIFICATION | 0
public static final int | DEFAULT_POSITION | 0
protected static final int | EDGE_SPACING | 2
public static final int | LEADING | 4
public static final int | LEFT | 1
public static final int | RIGHT | 3
protected static final int | TEXT_INSET_H | 5
protected static final int | TEXT_SPACING | 2
public static final int | TOP | 2
public static final int | TRAILING | 5

javax.swing.event.AncestorEvent
Modifier and Type | Constant Field | Value
public static final int | ANCESTOR_ADDED | 1
public static final int | ANCESTOR_MOVED | 3
public static final int | ANCESTOR_REMOVED | 2

javax.swing.event.InternalFrameEvent
Modifier and Type | Constant Field | Value
public static final int | INTERNAL_FRAME_ACTIVATED | 25554
public static final int | INTERNAL_FRAME_CLOSED | 25551
public static final int | INTERNAL_FRAME_CLOSING | 25550
public static final int | INTERNAL_FRAME_DEACTIVATED | 25555
public static final int | INTERNAL_FRAME_DEICONIFIED | 25553
public static final int | INTERNAL_FRAME_FIRST | 25549
public static final int | INTERNAL_FRAME_ICONIFIED | 25552
public static final int | INTERNAL_FRAME_LAST | 25555
public static final int | INTERNAL_FRAME_OPENED | 25549

javax.swing.event.ListDataEvent
Modifier and Type | Constant Field | Value
public static final int | CONTENTS_CHANGED | 0
public static final int | INTERVAL_ADDED | 1
public static final int | INTERVAL_REMOVED | 2

javax.swing.event.TableModelEvent
Modifier and Type | Constant Field | Value
public static final int | ALL_COLUMNS | -1
public static final int | DELETE | -1
public static final int | HEADER_ROW | -1
public static final int | INSERT | 1
public static final int | UPDATE | 0

javax.swing.plaf.basic.BasicComboPopup
Modifier and Type | Constant Field | Value
protected static final int | SCROLL_DOWN | 1
protected static final int | SCROLL_UP | 0

javax.swing.plaf.basic.BasicHTML
Modifier and Type | Constant Field | Value
public static final String | documentBaseKey | "html.base"
public static final String | propertyKey | "html"

javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener
Modifier and Type | Constant Field | Value
protected final int | RESIZE_NONE | 0

javax.swing.plaf.basic.BasicListUI
Modifier and Type | Constant Field | Value
protected static final int | cellRendererChanged | 64
protected static final int | fixedCellHeightChanged | 16
protected static final int | fixedCellWidthChanged | 8
protected static final int | fontChanged | 4
protected static final int | modelChanged | 1
protected static final int | prototypeCellValueChanged | 32
protected static final int | selectionModelChanged | 2

javax.swing.plaf.basic.BasicOptionPaneUI
Modifier and Type | Constant Field | Value
public static final int | MinimumHeight | 90
public static final int | MinimumWidth | 262

javax.swing.plaf.basic.BasicScrollBarUI
Modifier and Type | Constant Field | Value
protected static final int | DECREASE_HIGHLIGHT | 1
protected static final int | INCREASE_HIGHLIGHT | 2
protected static final int | NO_HIGHLIGHT | 0

javax.swing.plaf.basic.BasicSliderUI
Modifier and Type | Constant Field | Value
public static final int | MAX_SCROLL | 2
public static final int | MIN_SCROLL | -2
public static final int | NEGATIVE_SCROLL | -1
public static final int | POSITIVE_SCROLL | 1

javax.swing.plaf.basic.BasicSplitPaneDivider
Modifier and Type | Constant Field | Value
protected static final int | ONE_TOUCH_OFFSET | 2
protected static final int | ONE_TOUCH_SIZE | 6

javax.swing.plaf.basic.BasicSplitPaneUI
Modifier and Type | Constant Field | Value
protected static final String | NON_CONTINUOUS_DIVIDER | "nonContinuousDivider"

javax.swing.plaf.metal.MetalIconFactory
Modifier and Type | Constant Field | Value
public static final boolean | DARK | false
public static final boolean | LIGHT | true

javax.swing.plaf.metal.MetalScrollBarUI
Modifier and Type | Constant Field | Value
public static final String | FREE_STANDING_PROP | "JScrollBar.isFreeStanding"

javax.swing.plaf.metal.MetalSliderUI
Modifier and Type | Constant Field | Value
protected final String | SLIDER_FILL | "JSlider.isFilled"
protected final int | TICK_BUFFER | 4

javax.swing.plaf.metal.MetalToolTipUI
Modifier and Type | Constant Field | Value
public static final int | padSpaceBetweenStrings | 12

javax.swing.plaf.synth.SynthConstants
Modifier and Type | Constant Field | Value
public static final int | DEFAULT | 1024
public static final int | DISABLED | 8
public static final int | ENABLED | 1
public static final int | FOCUSED | 256
public static final int | MOUSE_OVER | 2
public static final int | PRESSED | 4
public static final int | SELECTED | 512

javax.swing.table.TableColumn
Modifier and Type | Constant Field | Value
public static final String | CELL_RENDERER_PROPERTY | "cellRenderer"
public static final String | COLUMN_WIDTH_PROPERTY | "columWidth"
public static final String | HEADER_RENDERER_PROPERTY | "headerRenderer"
public static final String | HEADER_VALUE_PROPERTY | "headerValue"

javax.swing.text.AbstractDocument
Modifier and Type | Constant Field | Value
protected static final String | BAD_LOCATION | "document location failure"
public static final String | BidiElementName | "bidi level"
public static final String | ContentElementName | "content"
public static final String | ElementNameAttribute | "$ename"
public static final String | ParagraphElementName | "paragraph"
public static final String | SectionElementName | "section"

javax.swing.text.AbstractWriter
Modifier and Type | Constant Field | Value
protected static final char | NEWLINE | 10

javax.swing.text.DefaultCaret
Modifier and Type | Constant Field | Value
public static final int | ALWAYS_UPDATE | 2
public static final int | NEVER_UPDATE | 1
public static final int | UPDATE_WHEN_ON_EDT | 0

javax.swing.text.DefaultEditorKit
Modifier and Type | Constant Field | Value
public static final String | backwardAction | "caret-backward"
public static final String | beepAction | "beep"
public static final String | beginAction | "caret-begin"
public static final String | beginLineAction | "caret-begin-line"
public static final String | beginParagraphAction | "caret-begin-paragraph"
public static final String | beginWordAction | "caret-begin-word"
public static final String | copyAction | "copy-to-clipboard"
public static final String | cutAction | "cut-to-clipboard"
public static final String | defaultKeyTypedAction | "default-typed"
public static final String | deleteNextCharAction | "delete-next"
public static final String | deleteNextWordAction | "delete-next-word"
public static final String | deletePrevCharAction | "delete-previous"
public static final String | deletePrevWordAction | "delete-previous-word"
public static final String | downAction | "caret-down"
public static final String | endAction | "caret-end"
public static final String | endLineAction | "caret-end-line"
public static final String | EndOfLineStringProperty | "__EndOfLine__"
public static final String | endParagraphAction | "caret-end-paragraph"
public static final String | endWordAction | "caret-end-word"
public static final String | forwardAction | "caret-forward"
public static final String | insertBreakAction | "insert-break"
public static final String | insertContentAction | "insert-content"
public static final String | insertTabAction | "insert-tab"
public static final String | nextWordAction | "caret-next-word"
public static final String | pageDownAction | "page-down"
public static final String | pageUpAction | "page-up"
public static final String | pasteAction | "paste-from-clipboard"
public static final String | previousWordAction | "caret-previous-word"
public static final String | readOnlyAction | "set-read-only"
public static final String | selectAllAction | "select-all"
public static final String | selectionBackwardAction | "selection-backward"
public static final String | selectionBeginAction | "selection-begin"
public static final String | selectionBeginLineAction | "selection-begin-line"
public static final String | selectionBeginParagraphAction | "selection-begin-paragraph"
public static final String | selectionBeginWordAction | "selection-begin-word"
public static final String | selectionDownAction | "selection-down"
public static final String | selectionEndAction | "selection-end"
public static final String | selectionEndLineAction | "selection-end-line"
public static final String | selectionEndParagraphAction | "selection-end-paragraph"
public static final String | selectionEndWordAction | "selection-end-word"
public static final String | selectionForwardAction | "selection-forward"
public static final String | selectionNextWordAction | "selection-next-word"
public static final String | selectionPreviousWordAction | "selection-previous-word"
public static final String | selectionUpAction | "selection-up"
public static final String | selectLineAction | "select-line"
public static final String | selectParagraphAction | "select-paragraph"
public static final String | selectWordAction | "select-word"
public static final String | upAction | "caret-up"
public static final String | writableAction | "set-writable"

javax.swing.text.DefaultStyledDocument
Modifier and Type | Constant Field | Value
public static final int | BUFFER_SIZE_DEFAULT | 4096

javax.swing.text.DefaultStyledDocument.ElementSpec
Modifier and Type | Constant Field | Value
public static final short | ContentType | 3
public static final short | EndTagType | 2
public static final short | JoinFractureDirection | 7
public static final short | JoinNextDirection | 5
public static final short | JoinPreviousDirection | 4
public static final short | OriginateDirection | 6
public static final short | StartTagType | 1

javax.swing.text.Document
Modifier and Type | Constant Field | Value
public static final String | StreamDescriptionProperty | "stream"
public static final String | TitleProperty | "title"

javax.swing.text.JTextComponent
Modifier and Type | Constant Field | Value
public static final String | DEFAULT_KEYMAP | "default"
public static final String | FOCUS_ACCELERATOR_KEY | "focusAcceleratorKey"

javax.swing.text.PlainDocument
Modifier and Type | Constant Field | Value
public static final String | lineLimitAttribute | "lineLimit"
public static final String | tabSizeAttribute | "tabSize"

javax.swing.text.StyleConstants
Modifier and Type | Constant Field | Value
public static final int | ALIGN_CENTER | 1
public static final int | ALIGN_JUSTIFIED | 3
public static final int | ALIGN_LEFT | 0
public static final int | ALIGN_RIGHT | 2
public static final String | ComponentElementName | "component"
public static final String | IconElementName | "icon"

javax.swing.text.StyleContext
Modifier and Type | Constant Field | Value
public static final String | DEFAULT_STYLE | "default"

javax.swing.text.TabStop
Modifier and Type | Constant Field | Value
public static final int | ALIGN_BAR | 5
public static final int | ALIGN_CENTER | 2
public static final int | ALIGN_DECIMAL | 4
public static final int | ALIGN_LEFT | 0
public static final int | ALIGN_RIGHT | 1
public static final int | LEAD_DOTS | 1
public static final int | LEAD_EQUALS | 5
public static final int | LEAD_HYPHENS | 2
public static final int | LEAD_NONE | 0
public static final int | LEAD_THICKLINE | 4
public static final int | LEAD_UNDERLINE | 3

javax.swing.text.View
Modifier and Type | Constant Field | Value
public static final int | BadBreakWeight | 0
public static final int | ExcellentBreakWeight | 2000
public static final int | ForcedBreakWeight | 3000
public static final int | GoodBreakWeight | 1000
public static final int | X_AXIS | 0
public static final int | Y_AXIS | 1

javax.swing.text.html.HTML
Modifier and Type | Constant Field | Value
public static final String | NULL_ATTRIBUTE_VALUE | "#DEFAULT"

javax.swing.text.html.HTMLDocument
Modifier and Type | Constant Field | Value
public static final String | AdditionalComments | "AdditionalComments"

javax.swing.text.html.HTMLEditorKit
Modifier and Type | Constant Field | Value
public static final String | BOLD_ACTION | "html-bold-action"
public static final String | COLOR_ACTION | "html-color-action"
public static final String | DEFAULT_CSS | "default.css"
public static final String | FONT_CHANGE_BIGGER | "html-font-bigger"
public static final String | FONT_CHANGE_SMALLER | "html-font-smaller"
public static final String | IMG_ALIGN_BOTTOM | "html-image-align-bottom"
public static final String | IMG_ALIGN_MIDDLE | "html-image-align-middle"
public static final String | IMG_ALIGN_TOP | "html-image-align-top"
public static final String | IMG_BORDER | "html-image-border"
public static final String | ITALIC_ACTION | "html-italic-action"
public static final String | LOGICAL_STYLE_ACTION | "html-logical-style-action"
public static final String | PARA_INDENT_LEFT | "html-para-indent-left"
public static final String | PARA_INDENT_RIGHT | "html-para-indent-right"

javax.swing.text.html.parser.DTD
Modifier and Type | Constant Field | Value
public static final int | FILE_VERSION | 1

javax.swing.text.html.parser.DTDConstants
Modifier and Type | Constant Field | Value
public static final int | ANY | 19
public static final int | CDATA | 1
public static final int | CONREF | 4
public static final int | CURRENT | 3
public static final int | DEFAULT | 131072
public static final int | EMPTY | 17
public static final int | ENDTAG | 14
public static final int | ENTITIES | 3
public static final int | ENTITY | 2
public static final int | FIXED | 1
public static final int | GENERAL | 65536
public static final int | ID | 4
public static final int | IDREF | 5
public static final int | IDREFS | 6
public static final int | IMPLIED | 5
public static final int | MD | 16
public static final int | MODEL | 18
public static final int | MS | 15
public static final int | NAME | 7
public static final int | NAMES | 8
public static final int | NMTOKEN | 9
public static final int | NMTOKENS | 10
public static final int | NOTATION | 11
public static final int | NUMBER | 12
public static final int | NUMBERS | 13
public static final int | NUTOKEN | 14
public static final int | NUTOKENS | 15
public static final int | PARAMETER | 262144
public static final int | PI | 12
public static final int | PUBLIC | 10
public static final int | RCDATA | 16
public static final int | REQUIRED | 2
public static final int | SDATA | 11
public static final int | STARTTAG | 13
public static final int | SYSTEM | 17

javax.swing.tree.DefaultTreeSelectionModel
Modifier and Type | Constant Field | Value
public static final String | SELECTION_MODE_PROPERTY | "selectionMode"

javax.swing.tree.TreeSelectionModel
Modifier and Type | Constant Field | Value
public static final int | CONTIGUOUS_TREE_SELECTION | 2
public static final int | DISCONTIGUOUS_TREE_SELECTION | 4
public static final int | SINGLE_TREE_SELECTION | 1

javax.swing.undo.AbstractUndoableEdit
Modifier and Type | Constant Field | Value
protected static final String | RedoName | "Redo"
protected static final String | UndoName | "Undo"

javax.swing.undo.StateEdit
Modifier and Type | Constant Field | Value
protected static final String | RCSID | "$Id: StateEdit.java,v 1.6 1997/10/01 20:05:51 sandipc Exp $"

javax.swing.undo.StateEditable
Modifier and Type | Constant Field | Value
public static final String | RCSID | "$Id: StateEditable.java,v 1.2 1997/09/08 19:39:08 marklin Exp $"

javax.tools.*

javax.tools.Diagnostic<S>
Modifier and Type | Constant Field | Value
public static final long | NOPOS | -1L

javax.transaction.*

javax.transaction.xa.XAException
Modifier and Type | Constant Field | Value
public static final int | XA_HEURCOM | 7
public static final int | XA_HEURHAZ | 8
public static final int | XA_HEURMIX | 5
public static final int | XA_HEURRB | 6
public static final int | XA_NOMIGRATE | 9
public static final int | XA_RBBASE | 100
public static final int | XA_RBCOMMFAIL | 101
public static final int | XA_RBDEADLOCK | 102
public static final int | XA_RBEND | 107
public static final int | XA_RBINTEGRITY | 103
public static final int | XA_RBOTHER | 104
public static final int | XA_RBPROTO | 105
public static final int | XA_RBROLLBACK | 100
public static final int | XA_RBTIMEOUT | 106
public static final int | XA_RBTRANSIENT | 107
public static final int | XA_RDONLY | 3
public static final int | XA_RETRY | 4
public static final int | XAER_ASYNC | -2
public static final int | XAER_DUPID | -8
public static final int | XAER_INVAL | -5
public static final int | XAER_NOTA | -4
public static final int | XAER_OUTSIDE | -9
public static final int | XAER_PROTO | -6
public static final int | XAER_RMERR | -3
public static final int | XAER_RMFAIL | -7

javax.transaction.xa.XAResource
Modifier and Type | Constant Field | Value
public static final int | TMENDRSCAN | 8388608
public static final int | TMFAIL | 536870912
public static final int | TMJOIN | 2097152
public static final int | TMNOFLAGS | 0
public static final int | TMONEPHASE | 1073741824
public static final int | TMRESUME | 134217728
public static final int | TMSTARTRSCAN | 16777216
public static final int | TMSUCCESS | 67108864
public static final int | TMSUSPEND | 33554432
public static final int | XA_OK | 0
public static final int | XA_RDONLY | 3

javax.transaction.xa.Xid
Modifier and Type | Constant Field | Value
public static final int | MAXBQUALSIZE | 64
public static final int | MAXGTRIDSIZE | 64

javax.xml.*

javax.xml.XMLConstants
Modifier and Type | Constant Field | Value
public static final String | DEFAULT_NS_PREFIX | ""
public static final String | FEATURE_SECURE_PROCESSING | "http://javax.xml.XMLConstants/feature/secure-processing"
public static final String | NULL_NS_URI | ""
public static final String | RELAXNG_NS_URI | "http://relaxng.org/ns/structure/1.0"
public static final String | W3C_XML_SCHEMA_INSTANCE_NS_URI | "http://www.w3.org/2001/XMLSchema-instance"
public static final String | W3C_XML_SCHEMA_NS_URI | "http://www.w3.org/2001/XMLSchema"
public static final String | W3C_XPATH_DATATYPE_NS_URI | "http://www.w3.org/2003/11/xpath-datatypes"
public static final String | XML_DTD_NS_URI | "http://www.w3.org/TR/REC-xml"
public static final String | XML_NS_PREFIX | "xml"
public static final String | XML_NS_URI | "http://www.w3.org/XML/1998/namespace"
public static final String | XMLNS_ATTRIBUTE | "xmlns"
public static final String | XMLNS_ATTRIBUTE_NS_URI | "http://www.w3.org/2000/xmlns/"

javax.xml.bind.JAXBContext
Modifier and Type | Constant Field | Value
public static final String | JAXB_CONTEXT_FACTORY | "javax.xml.bind.context.factory"

javax.xml.bind.Marshaller
Modifier and Type | Constant Field | Value
public static final String | JAXB_ENCODING | "jaxb.encoding"
public static final String | JAXB_FORMATTED_OUTPUT | "jaxb.formatted.output"
public static final String | JAXB_FRAGMENT | "jaxb.fragment"
public static final String | JAXB_NO_NAMESPACE_SCHEMA_LOCATION | "jaxb.noNamespaceSchemaLocation"
public static final String | JAXB_SCHEMA_LOCATION | "jaxb.schemaLocation"

javax.xml.bind.ValidationEvent
Modifier and Type | Constant Field | Value
public static final int | ERROR | 1
public static final int | FATAL_ERROR | 2
public static final int | WARNING | 0

javax.xml.bind.annotation.XmlSchema
Modifier and Type | Constant Field | Value
public static final String | NO_LOCATION | "##generate"

javax.xml.crypto.dsig.CanonicalizationMethod
Modifier and Type | Constant Field | Value
public static final String | EXCLUSIVE | "http://www.w3.org/2001/10/xml-exc-c14n#"
public static final String | EXCLUSIVE_WITH_COMMENTS | "http://www.w3.org/2001/10/xml-exc-c14n#WithComments"
public static final String | INCLUSIVE | "http://www.w3.org/TR/2001/REC-xml-c14n-20010315"
public static final String | INCLUSIVE_WITH_COMMENTS | "http://www.w3.org/TR/2001/REC-xml-c14n-20010315#WithComments"

javax.xml.crypto.dsig.DigestMethod
Modifier and Type | Constant Field | Value
public static final String | RIPEMD160 | "http://www.w3.org/2001/04/xmlenc#ripemd160"
public static final String | SHA1 | "http://www.w3.org/2000/09/xmldsig#sha1"
public static final String | SHA256 | "http://www.w3.org/2001/04/xmlenc#sha256"
public static final String | SHA512 | "http://www.w3.org/2001/04/xmlenc#sha512"

javax.xml.crypto.dsig.Manifest
Modifier and Type | Constant Field | Value
public static final String | TYPE | "http://www.w3.org/2000/09/xmldsig#Manifest"

javax.xml.crypto.dsig.SignatureMethod
Modifier and Type | Constant Field | Value
public static final String | DSA_SHA1 | "http://www.w3.org/2000/09/xmldsig#dsa-sha1"
public static final String | HMAC_SHA1 | "http://www.w3.org/2000/09/xmldsig#hmac-sha1"
public static final String | RSA_SHA1 | "http://www.w3.org/2000/09/xmldsig#rsa-sha1"

javax.xml.crypto.dsig.SignatureProperties
Modifier and Type | Constant Field | Value
public static final String | TYPE | "http://www.w3.org/2000/09/xmldsig#SignatureProperties"

javax.xml.crypto.dsig.Transform
Modifier and Type | Constant Field | Value
public static final String | BASE64 | "http://www.w3.org/2000/09/xmldsig#base64"
public static final String | ENVELOPED | "http://www.w3.org/2000/09/xmldsig#enveloped-signature"
public static final String | XPATH | "http://www.w3.org/TR/1999/REC-xpath-19991116"
public static final String | XPATH2 | "http://www.w3.org/2002/06/xmldsig-filter2"
public static final String | XSLT | "http://www.w3.org/TR/1999/REC-xslt-19991116"

javax.xml.crypto.dsig.XMLObject
Modifier and Type | Constant Field | Value
public static final String | TYPE | "http://www.w3.org/2000/09/xmldsig#Object"

javax.xml.crypto.dsig.XMLSignature
Modifier and Type | Constant Field | Value
public static final String | XMLNS | "http://www.w3.org/2000/09/xmldsig#"

javax.xml.crypto.dsig.keyinfo.KeyValue
Modifier and Type | Constant Field | Value
public static final String | DSA_TYPE | "http://www.w3.org/2000/09/xmldsig#DSAKeyValue"
public static final String | RSA_TYPE | "http://www.w3.org/2000/09/xmldsig#RSAKeyValue"

javax.xml.crypto.dsig.keyinfo.PGPData
Modifier and Type | Constant Field | Value
public static final String | TYPE | "http://www.w3.org/2000/09/xmldsig#PGPData"

javax.xml.crypto.dsig.keyinfo.X509Data
Modifier and Type | Constant Field | Value
public static final String | RAW_X509_CERTIFICATE_TYPE | "http://www.w3.org/2000/09/xmldsig#rawX509Certificate"
public static final String | TYPE | "http://www.w3.org/2000/09/xmldsig#X509Data"

javax.xml.crypto.dsig.spec.ExcC14NParameterSpec
Modifier and Type | Constant Field | Value
public static final String | DEFAULT | "#default"

javax.xml.datatype.DatatypeConstants
Modifier and Type | Constant Field | Value
public static final int | APRIL | 4
public static final int | AUGUST | 8
public static final int | DECEMBER | 12
public static final int | EQUAL | 0
public static final int | FEBRUARY | 2
public static final int | FIELD_UNDEFINED | -2147483648
public static final int | GREATER | 1
public static final int | INDETERMINATE | 2
public static final int | JANUARY | 1
public static final int | JULY | 7
public static final int | JUNE | 6
public static final int | LESSER | -1
public static final int | MARCH | 3
public static final int | MAX_TIMEZONE_OFFSET | -840
public static final int | MAY | 5
public static final int | MIN_TIMEZONE_OFFSET | 840
public static final int | NOVEMBER | 11
public static final int | OCTOBER | 10
public static final int | SEPTEMBER | 9

javax.xml.datatype.DatatypeFactory
Modifier and Type | Constant Field | Value
public static final String | DATATYPEFACTORY_PROPERTY | "javax.xml.datatype.DatatypeFactory"

javax.xml.soap.SOAPConstants
Modifier and Type | Constant Field | Value
public static final String | DEFAULT_SOAP_PROTOCOL | "SOAP 1.1 Protocol"
public static final String | DYNAMIC_SOAP_PROTOCOL | "Dynamic Protocol"
public static final String | SOAP_1_1_CONTENT_TYPE | "text/xml"
public static final String | SOAP_1_1_PROTOCOL | "SOAP 1.1 Protocol"
public static final String | SOAP_1_2_CONTENT_TYPE | "application/soap+xml"
public static final String | SOAP_1_2_PROTOCOL | "SOAP 1.2 Protocol"
public static final String | SOAP_ENV_PREFIX | "env"
public static final String | URI_NS_SOAP_1_1_ENVELOPE | "http://schemas.xmlsoap.org/soap/envelope/"
public static final String | URI_NS_SOAP_1_2_ENCODING | "http://www.w3.org/2003/05/soap-encoding"
public static final String | URI_NS_SOAP_1_2_ENVELOPE | "http://www.w3.org/2003/05/soap-envelope"
public static final String | URI_NS_SOAP_ENCODING | "http://schemas.xmlsoap.org/soap/encoding/"
public static final String | URI_NS_SOAP_ENVELOPE | "http://schemas.xmlsoap.org/soap/envelope/"
public static final String | URI_SOAP_1_2_ROLE_NEXT | "http://www.w3.org/2003/05/soap-envelope/role/next"
public static final String | URI_SOAP_1_2_ROLE_NONE | "http://www.w3.org/2003/05/soap-envelope/role/none"
public static final String | URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER | "http://www.w3.org/2003/05/soap-envelope/role/ultimateReceiver"
public static final String | URI_SOAP_ACTOR_NEXT | "http://schemas.xmlsoap.org/soap/actor/next"

javax.xml.soap.SOAPMessage
Modifier and Type | Constant Field | Value
public static final String | CHARACTER_SET_ENCODING | "javax.xml.soap.character-set-encoding"
public static final String | WRITE_XML_DECLARATION | "javax.xml.soap.write-xml-declaration"

javax.xml.stream.XMLInputFactory
Modifier and Type | Constant Field | Value
public static final String | ALLOCATOR | "javax.xml.stream.allocator"
public static final String | IS_COALESCING | "javax.xml.stream.isCoalescing"
public static final String | IS_NAMESPACE_AWARE | "javax.xml.stream.isNamespaceAware"
public static final String | IS_REPLACING_ENTITY_REFERENCES | "javax.xml.stream.isReplacingEntityReferences"
public static final String | IS_SUPPORTING_EXTERNAL_ENTITIES | "javax.xml.stream.isSupportingExternalEntities"
public static final String | IS_VALIDATING | "javax.xml.stream.isValidating"
public static final String | REPORTER | "javax.xml.stream.reporter"
public static final String | RESOLVER | "javax.xml.stream.resolver"
public static final String | SUPPORT_DTD | "javax.xml.stream.supportDTD"

javax.xml.stream.XMLOutputFactory
Modifier and Type | Constant Field | Value
public static final String | IS_REPAIRING_NAMESPACES | "javax.xml.stream.isRepairingNamespaces"

javax.xml.stream.XMLStreamConstants
Modifier and Type | Constant Field | Value
public static final int | ATTRIBUTE | 10
public static final int | CDATA | 12
public static final int | CHARACTERS | 4
public static final int | COMMENT | 5
public static final int | DTD | 11
public static final int | END_DOCUMENT | 8
public static final int | END_ELEMENT | 2
public static final int | ENTITY_DECLARATION | 15
public static final int | ENTITY_REFERENCE | 9
public static final int | NAMESPACE | 13
public static final int | NOTATION_DECLARATION | 14
public static final int | PROCESSING_INSTRUCTION | 3
public static final int | SPACE | 6
public static final int | START_DOCUMENT | 7
public static final int | START_ELEMENT | 1

javax.xml.transform.OutputKeys
Modifier and Type | Constant Field | Value
public static final String | CDATA_SECTION_ELEMENTS | "cdata-section-elements"
public static final String | DOCTYPE_PUBLIC | "doctype-public"
public static final String | DOCTYPE_SYSTEM | "doctype-system"
public static final String | ENCODING | "encoding"
public static final String | INDENT | "indent"
public static final String | MEDIA_TYPE | "media-type"
public static final String | METHOD | "method"
public static final String | OMIT_XML_DECLARATION | "omit-xml-declaration"
public static final String | STANDALONE | "standalone"
public static final String | VERSION | "version"

javax.xml.transform.Result
Modifier and Type | Constant Field | Value
public static final String | PI_DISABLE_OUTPUT_ESCAPING | "javax.xml.transform.disable-output-escaping"
public static final String | PI_ENABLE_OUTPUT_ESCAPING | "javax.xml.transform.enable-output-escaping"

javax.xml.transform.dom.DOMResult
Modifier and Type | Constant Field | Value
public static final String | FEATURE | "http://javax.xml.transform.dom.DOMResult/feature"

javax.xml.transform.dom.DOMSource
Modifier and Type | Constant Field | Value
public static final String | FEATURE | "http://javax.xml.transform.dom.DOMSource/feature"

javax.xml.transform.sax.SAXResult
Modifier and Type | Constant Field | Value
public static final String | FEATURE | "http://javax.xml.transform.sax.SAXResult/feature"

javax.xml.transform.sax.SAXSource
Modifier and Type | Constant Field | Value
public static final String | FEATURE | "http://javax.xml.transform.sax.SAXSource/feature"

javax.xml.transform.sax.SAXTransformerFactory
Modifier and Type | Constant Field | Value
public static final String | FEATURE | "http://javax.xml.transform.sax.SAXTransformerFactory/feature"
public static final String | FEATURE_XMLFILTER | "http://javax.xml.transform.sax.SAXTransformerFactory/feature/xmlfilter"

javax.xml.transform.stax.StAXResult
Modifier and Type | Constant Field | Value
public static final String | FEATURE | "http://javax.xml.transform.stax.StAXResult/feature"

javax.xml.transform.stax.StAXSource
Modifier and Type | Constant Field | Value
public static final String | FEATURE | "http://javax.xml.transform.stax.StAXSource/feature"

javax.xml.transform.stream.StreamResult
Modifier and Type | Constant Field | Value
public static final String | FEATURE | "http://javax.xml.transform.stream.StreamResult/feature"

javax.xml.transform.stream.StreamSource
Modifier and Type | Constant Field | Value
public static final String | FEATURE | "http://javax.xml.transform.stream.StreamSource/feature"

javax.xml.ws.BindingProvider
Modifier and Type | Constant Field | Value
public static final String | ENDPOINT_ADDRESS_PROPERTY | "javax.xml.ws.service.endpoint.address"
public static final String | PASSWORD_PROPERTY | "javax.xml.ws.security.auth.password"
public static final String | SESSION_MAINTAIN_PROPERTY | "javax.xml.ws.session.maintain"
public static final String | SOAPACTION_URI_PROPERTY | "javax.xml.ws.soap.http.soapaction.uri"
public static final String | SOAPACTION_USE_PROPERTY | "javax.xml.ws.soap.http.soapaction.use"
public static final String | USERNAME_PROPERTY | "javax.xml.ws.security.auth.username"

javax.xml.ws.Endpoint
Modifier and Type | Constant Field | Value
public static final String | WSDL_PORT | "javax.xml.ws.wsdl.port"
public static final String | WSDL_SERVICE | "javax.xml.ws.wsdl.service"

javax.xml.ws.RespectBindingFeature
Modifier and Type | Constant Field | Value
public static final String | ID | "javax.xml.ws.RespectBindingFeature"

javax.xml.ws.handler.MessageContext
Modifier and Type | Constant Field | Value
public static final String | HTTP_REQUEST_HEADERS | "javax.xml.ws.http.request.headers"
public static final String | HTTP_REQUEST_METHOD | "javax.xml.ws.http.request.method"
public static final String | HTTP_RESPONSE_CODE | "javax.xml.ws.http.response.code"
public static final String | HTTP_RESPONSE_HEADERS | "javax.xml.ws.http.response.headers"
public static final String | INBOUND_MESSAGE_ATTACHMENTS | "javax.xml.ws.binding.attachments.inbound"
public static final String | MESSAGE_OUTBOUND_PROPERTY | "javax.xml.ws.handler.message.outbound"
public static final String | OUTBOUND_MESSAGE_ATTACHMENTS | "javax.xml.ws.binding.attachments.outbound"
public static final String | PATH_INFO | "javax.xml.ws.http.request.pathinfo"
public static final String | QUERY_STRING | "javax.xml.ws.http.request.querystring"
public static final String | REFERENCE_PARAMETERS | "javax.xml.ws.reference.parameters"
public static final String | SERVLET_CONTEXT | "javax.xml.ws.servlet.context"
public static final String | SERVLET_REQUEST | "javax.xml.ws.servlet.request"
public static final String | SERVLET_RESPONSE | "javax.xml.ws.servlet.response"
public static final String | WSDL_DESCRIPTION | "javax.xml.ws.wsdl.description"
public static final String | WSDL_INTERFACE | "javax.xml.ws.wsdl.interface"
public static final String | WSDL_OPERATION | "javax.xml.ws.wsdl.operation"
public static final String | WSDL_PORT | "javax.xml.ws.wsdl.port"
public static final String | WSDL_SERVICE | "javax.xml.ws.wsdl.service"

javax.xml.ws.http.HTTPBinding
Modifier and Type | Constant Field | Value
public static final String | HTTP_BINDING | "http://www.w3.org/2004/08/wsdl/http"

javax.xml.ws.soap.AddressingFeature
Modifier and Type | Constant Field | Value
public static final String | ID | "http://www.w3.org/2005/08/addressing/module"

javax.xml.ws.soap.MTOMFeature
Modifier and Type | Constant Field | Value
public static final String | ID | "http://www.w3.org/2004/08/soap/features/http-optimization"

javax.xml.ws.soap.SOAPBinding
Modifier and Type | Constant Field | Value
public static final String | SOAP11HTTP_BINDING | "http://schemas.xmlsoap.org/wsdl/soap/http"
public static final String | SOAP11HTTP_MTOM_BINDING | "http://schemas.xmlsoap.org/wsdl/soap/http?mtom=true"
public static final String | SOAP12HTTP_BINDING | "http://www.w3.org/2003/05/soap/bindings/HTTP/"
public static final String | SOAP12HTTP_MTOM_BINDING | "http://www.w3.org/2003/05/soap/bindings/HTTP/?mtom=true"

javax.xml.ws.spi.Provider
Modifier and Type | Constant Field | Value
public static final String | JAXWSPROVIDER_PROPERTY | "javax.xml.ws.spi.Provider"

javax.xml.ws.wsaddressing.W3CEndpointReference
Modifier and Type | Constant Field | Value
protected static final String | NS | "http://www.w3.org/2005/08/addressing"

javax.xml.xpath.XPathConstants
Modifier and Type | Constant Field | Value
public static final String | DOM_OBJECT_MODEL | "http://java.sun.com/jaxp/xpath/dom"

javax.xml.xpath.XPathFactory
Modifier and Type | Constant Field | Value
public static final String | DEFAULT_OBJECT_MODEL_URI | "http://java.sun.com/jaxp/xpath/dom"
public static final String | DEFAULT_PROPERTY_NAME | "javax.xml.xpath.XPathFactory"

org.ietf.*

org.ietf.jgss.GSSContext
Modifier and Type | Constant Field | Value
public static final int | DEFAULT_LIFETIME | 0
public static final int | INDEFINITE_LIFETIME | 2147483647

org.ietf.jgss.GSSCredential
Modifier and Type | Constant Field | Value
public static final int | ACCEPT_ONLY | 2
public static final int | DEFAULT_LIFETIME | 0
public static final int | INDEFINITE_LIFETIME | 2147483647
public static final int | INITIATE_AND_ACCEPT | 0
public static final int | INITIATE_ONLY | 1

org.ietf.jgss.GSSException
Modifier and Type | Constant Field | Value
public static final int | BAD_BINDINGS | 1
public static final int | BAD_MECH | 2
public static final int | BAD_MIC | 6
public static final int | BAD_NAME | 3
public static final int | BAD_NAMETYPE | 4
public static final int | BAD_QOP | 14
public static final int | BAD_STATUS | 5
public static final int | CONTEXT_EXPIRED | 7
public static final int | CREDENTIALS_EXPIRED | 8
public static final int | DEFECTIVE_CREDENTIAL | 9
public static final int | DEFECTIVE_TOKEN | 10
public static final int | DUPLICATE_ELEMENT | 17
public static final int | DUPLICATE_TOKEN | 19
public static final int | FAILURE | 11
public static final int | GAP_TOKEN | 22
public static final int | NAME_NOT_MN | 18
public static final int | NO_CONTEXT | 12
public static final int | NO_CRED | 13
public static final int | OLD_TOKEN | 20
public static final int | UNAUTHORIZED | 15
public static final int | UNAVAILABLE | 16
public static final int | UNSEQ_TOKEN | 21

org.omg.*

org.omg.CORBA.ARG_IN
Modifier and Type | Constant Field | Value
public static final int | value | 1

org.omg.CORBA.ARG_INOUT
Modifier and Type | Constant Field | Value
public static final int | value | 3

org.omg.CORBA.ARG_OUT
Modifier and Type | Constant Field | Value
public static final int | value | 2

org.omg.CORBA.BAD_POLICY
Modifier and Type | Constant Field | Value
public static final short | value | 0

org.omg.CORBA.BAD_POLICY_TYPE
Modifier and Type | Constant Field | Value
public static final short | value | 2

org.omg.CORBA.BAD_POLICY_VALUE
Modifier and Type | Constant Field | Value
public static final short | value | 3

org.omg.CORBA.CompletionStatus
Modifier and Type | Constant Field | Value
public static final int | _COMPLETED_MAYBE | 2
public static final int | _COMPLETED_NO | 1
public static final int | _COMPLETED_YES | 0

org.omg.CORBA.CTX_RESTRICT_SCOPE
Modifier and Type | Constant Field | Value
public static final int | value | 15

org.omg.CORBA.DefinitionKind
Modifier and Type | Constant Field | Value
public static final int | _dk_AbstractInterface | 24
public static final int | _dk_Alias | 9
public static final int | _dk_all | 1
public static final int | _dk_Array | 16
public static final int | _dk_Attribute | 2
public static final int | _dk_Constant | 3
public static final int | _dk_Enum | 12
public static final int | _dk_Exception | 4
public static final int | _dk_Fixed | 19
public static final int | _dk_Interface | 5
public static final int | _dk_Module | 6
public static final int | _dk_Native | 23
public static final int | _dk_none | 0
public static final int | _dk_Operation | 7
public static final int | _dk_Primitive | 13
public static final int | _dk_Repository | 17
public static final int | _dk_Sequence | 15
public static final int | _dk_String | 14
public static final int | _dk_Struct | 10
public static final int | _dk_Typedef | 8
public static final int | _dk_Union | 11
public static final int | _dk_Value | 20
public static final int | _dk_ValueBox | 21
public static final int | _dk_ValueMember | 22
public static final int | _dk_Wstring | 18

org.omg.CORBA.OMGVMCID
Modifier and Type | Constant Field | Value
public static final int | value | 1330446336

org.omg.CORBA.ParameterMode
Modifier and Type | Constant Field | Value
public static final int | _PARAM_IN | 0
public static final int | _PARAM_INOUT | 2
public static final int | _PARAM_OUT | 1

org.omg.CORBA.PRIVATE_MEMBER
Modifier and Type | Constant Field | Value
public static final short | value | 0

org.omg.CORBA.PUBLIC_MEMBER
Modifier and Type | Constant Field | Value
public static final short | value | 1

org.omg.CORBA.SetOverrideType
Modifier and Type | Constant Field | Value
public static final int | _ADD_OVERRIDE | 1
public static final int | _SET_OVERRIDE | 0

org.omg.CORBA.TCKind
Modifier and Type | Constant Field | Value
public static final int | _tk_abstract_interface | 32
public static final int | _tk_alias | 21
public static final int | _tk_any | 11
public static final int | _tk_array | 20
public static final int | _tk_boolean | 8
public static final int | _tk_char | 9
public static final int | _tk_double | 7
public static final int | _tk_enum | 17
public static final int | _tk_except | 22
public static final int | _tk_fixed | 28
public static final int | _tk_float | 6
public static final int | _tk_long | 3
public static final int | _tk_longdouble | 25
public static final int | _tk_longlong | 23
public static final int | _tk_native | 31
public static final int | _tk_null | 0
public static final int | _tk_objref | 14
public static final int | _tk_octet | 10
public static final int | _tk_Principal | 13
public static final int | _tk_sequence | 19
public static final int | _tk_short | 2
public static final int | _tk_string | 18
public static final int | _tk_struct | 15
public static final int | _tk_TypeCode | 12
public static final int | _tk_ulong | 5
public static final int | _tk_ulonglong | 24
public static final int | _tk_union | 16
public static final int | _tk_ushort | 4
public static final int | _tk_value | 29
public static final int | _tk_value_box | 30
public static final int | _tk_void | 1
public static final int | _tk_wchar | 26
public static final int | _tk_wstring | 27

org.omg.CORBA.UNSUPPORTED_POLICY
Modifier and Type | Constant Field | Value
public static final short | value | 1

org.omg.CORBA.UNSUPPORTED_POLICY_VALUE
Modifier and Type | Constant Field | Value
public static final short | value | 4

org.omg.CORBA.VM_ABSTRACT
Modifier and Type | Constant Field | Value
public static final short | value | 2

org.omg.CORBA.VM_CUSTOM
Modifier and Type | Constant Field | Value
public static final short | value | 1

org.omg.CORBA.VM_NONE
Modifier and Type | Constant Field | Value
public static final short | value | 0

org.omg.CORBA.VM_TRUNCATABLE
Modifier and Type | Constant Field | Value
public static final short | value | 3

org.omg.CosNaming.BindingType
Modifier and Type | Constant Field | Value
public static final int | _ncontext | 1
public static final int | _nobject | 0

org.omg.CosNaming.NamingContextPackage.NotFoundReason
Modifier and Type | Constant Field | Value
public static final int | _missing_node | 0
public static final int | _not_context | 1
public static final int | _not_object | 2

org.omg.IOP.CodeSets
Modifier and Type | Constant Field | Value
public static final int | value | 1

org.omg.IOP.ENCODING_CDR_ENCAPS
Modifier and Type | Constant Field | Value
public static final short | value | 0

org.omg.IOP.ExceptionDetailMessage
Modifier and Type | Constant Field | Value
public static final int | value | 14

org.omg.IOP.RMICustomMaxStreamFormat
Modifier and Type | Constant Field | Value
public static final int | value | 17

org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS
Modifier and Type | Constant Field | Value
public static final int | value | 3

org.omg.IOP.TAG_CODE_SETS
Modifier and Type | Constant Field | Value
public static final int | value | 1

org.omg.IOP.TAG_INTERNET_IOP
Modifier and Type | Constant Field | Value
public static final int | value | 0

org.omg.IOP.TAG_JAVA_CODEBASE
Modifier and Type | Constant Field | Value
public static final int | value | 25

org.omg.IOP.TAG_MULTIPLE_COMPONENTS
Modifier and Type | Constant Field | Value
public static final int | value | 1

org.omg.IOP.TAG_ORB_TYPE
Modifier and Type | Constant Field | Value
public static final int | value | 0

org.omg.IOP.TAG_POLICIES
Modifier and Type | Constant Field | Value
public static final int | value | 2

org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
Modifier and Type | Constant Field | Value
public static final int | value | 38

org.omg.IOP.TransactionService
Modifier and Type | Constant Field | Value
public static final int | value | 0

org.omg.Messaging.SYNC_WITH_TRANSPORT
Modifier and Type | Constant Field | Value
public static final short | value | 1

org.omg.PortableInterceptor.ACTIVE
Modifier and Type | Constant Field | Value
public static final short | value | 1

org.omg.PortableInterceptor.DISCARDING
Modifier and Type | Constant Field | Value
public static final short | value | 2

org.omg.PortableInterceptor.HOLDING
Modifier and Type | Constant Field | Value
public static final short | value | 0

org.omg.PortableInterceptor.INACTIVE
Modifier and Type | Constant Field | Value
public static final short | value | 3

org.omg.PortableInterceptor.LOCATION_FORWARD
Modifier and Type | Constant Field | Value
public static final short | value | 3

org.omg.PortableInterceptor.NON_EXISTENT
Modifier and Type | Constant Field | Value
public static final short | value | 4

org.omg.PortableInterceptor.SUCCESSFUL
Modifier and Type | Constant Field | Value
public static final short | value | 0

org.omg.PortableInterceptor.SYSTEM_EXCEPTION
Modifier and Type | Constant Field | Value
public static final short | value | 1

org.omg.PortableInterceptor.TRANSPORT_RETRY
Modifier and Type | Constant Field | Value
public static final short | value | 4

org.omg.PortableInterceptor.UNKNOWN
Modifier and Type | Constant Field | Value
public static final short | value | 5

org.omg.PortableInterceptor.USER_EXCEPTION
Modifier and Type | Constant Field | Value
public static final short | value | 2

org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID
Modifier and Type | Constant Field | Value
public static final int | value | 19

org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID
Modifier and Type | Constant Field | Value
public static final int | value | 18

org.omg.PortableServer.IdAssignmentPolicyValue
Modifier and Type | Constant Field | Value
public static final int | _SYSTEM_ID | 1
public static final int | _USER_ID | 0

org.omg.PortableServer.IdUniquenessPolicyValue
Modifier and Type | Constant Field | Value
public static final int | _MULTIPLE_ID | 1
public static final int | _UNIQUE_ID | 0

org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID
Modifier and Type | Constant Field | Value
public static final int | value | 20

org.omg.PortableServer.ImplicitActivationPolicyValue
Modifier and Type | Constant Field | Value
public static final int | _IMPLICIT_ACTIVATION | 0
public static final int | _NO_IMPLICIT_ACTIVATION | 1

org.omg.PortableServer.LIFESPAN_POLICY_ID
Modifier and Type | Constant Field | Value
public static final int | value | 17

org.omg.PortableServer.LifespanPolicyValue
Modifier and Type | Constant Field | Value
public static final int | _PERSISTENT | 1
public static final int | _TRANSIENT | 0

org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID
Modifier and Type | Constant Field | Value
public static final int | value | 22

org.omg.PortableServer.RequestProcessingPolicyValue
Modifier and Type | Constant Field | Value
public static final int | _USE_ACTIVE_OBJECT_MAP_ONLY | 0
public static final int | _USE_DEFAULT_SERVANT | 1
public static final int | _USE_SERVANT_MANAGER | 2

org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID
Modifier and Type | Constant Field | Value
public static final int | value | 21

org.omg.PortableServer.ServantRetentionPolicyValue
Modifier and Type | Constant Field | Value
public static final int | _NON_RETAIN | 1
public static final int | _RETAIN | 0

org.omg.PortableServer.THREAD_POLICY_ID
Modifier and Type | Constant Field | Value
public static final int | value | 16

org.omg.PortableServer.ThreadPolicyValue
Modifier and Type | Constant Field | Value
public static final int | _ORB_CTRL_MODEL | 0
public static final int | _SINGLE_THREAD_MODEL | 1

org.omg.PortableServer.POAManagerPackage.State
Modifier and Type | Constant Field | Value
public static final int | _ACTIVE | 1
public static final int | _DISCARDING | 2
public static final int | _HOLDING | 0
public static final int | _INACTIVE | 3

org.w3c.*

org.w3c.dom.DOMError
Modifier and Type | Constant Field | Value
public static final short | SEVERITY_ERROR | 2
public static final short | SEVERITY_FATAL_ERROR | 3
public static final short | SEVERITY_WARNING | 1

org.w3c.dom.DOMException
Modifier and Type | Constant Field | Value
public static final short | DOMSTRING_SIZE_ERR | 2
public static final short | HIERARCHY_REQUEST_ERR | 3
public static final short | INDEX_SIZE_ERR | 1
public static final short | INUSE_ATTRIBUTE_ERR | 10
public static final short | INVALID_ACCESS_ERR | 15
public static final short | INVALID_CHARACTER_ERR | 5
public static final short | INVALID_MODIFICATION_ERR | 13
public static final short | INVALID_STATE_ERR | 11
public static final short | NAMESPACE_ERR | 14
public static final short | NO_DATA_ALLOWED_ERR | 6
public static final short | NO_MODIFICATION_ALLOWED_ERR | 7
public static final short | NOT_FOUND_ERR | 8
public static final short | NOT_SUPPORTED_ERR | 9
public static final short | SYNTAX_ERR | 12
public static final short | TYPE_MISMATCH_ERR | 17
public static final short | VALIDATION_ERR | 16
public static final short | WRONG_DOCUMENT_ERR | 4

org.w3c.dom.Node
Modifier and Type | Constant Field | Value
public static final short | ATTRIBUTE_NODE | 2
public static final short | CDATA_SECTION_NODE | 4
public static final short | COMMENT_NODE | 8
public static final short | DOCUMENT_FRAGMENT_NODE | 11
public static final short | DOCUMENT_NODE | 9
public static final short | DOCUMENT_POSITION_CONTAINED_BY | 16
public static final short | DOCUMENT_POSITION_CONTAINS | 8
public static final short | DOCUMENT_POSITION_DISCONNECTED | 1
public static final short | DOCUMENT_POSITION_FOLLOWING | 4
public static final short | DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC | 32
public static final short | DOCUMENT_POSITION_PRECEDING | 2
public static final short | DOCUMENT_TYPE_NODE | 10
public static final short | ELEMENT_NODE | 1
public static final short | ENTITY_NODE | 6
public static final short | ENTITY_REFERENCE_NODE | 5
public static final short | NOTATION_NODE | 12
public static final short | PROCESSING_INSTRUCTION_NODE | 7
public static final short | TEXT_NODE | 3

org.w3c.dom.TypeInfo
Modifier and Type | Constant Field | Value
public static final int | DERIVATION_EXTENSION | 2
public static final int | DERIVATION_LIST | 8
public static final int | DERIVATION_RESTRICTION | 1
public static final int | DERIVATION_UNION | 4

org.w3c.dom.UserDataHandler
Modifier and Type | Constant Field | Value
public static final short | NODE_ADOPTED | 5
public static final short | NODE_CLONED | 1
public static final short | NODE_DELETED | 3
public static final short | NODE_IMPORTED | 2
public static final short | NODE_RENAMED | 4

org.w3c.dom.bootstrap.DOMImplementationRegistry
Modifier and Type | Constant Field | Value
public static final String | PROPERTY | "org.w3c.dom.DOMImplementationSourceList"

org.w3c.dom.events.Event
Modifier and Type | Constant Field | Value
public static final short | AT_TARGET | 2
public static final short | BUBBLING_PHASE | 3
public static final short | CAPTURING_PHASE | 1

org.w3c.dom.events.EventException
Modifier and Type | Constant Field | Value
public static final short | UNSPECIFIED_EVENT_TYPE_ERR | 0

org.w3c.dom.events.MutationEvent
Modifier and Type | Constant Field | Value
public static final short | ADDITION | 2
public static final short | MODIFICATION | 1
public static final short | REMOVAL | 3

org.w3c.dom.ls.DOMImplementationLS
Modifier and Type | Constant Field | Value
public static final short | MODE_ASYNCHRONOUS | 2
public static final short | MODE_SYNCHRONOUS | 1

org.w3c.dom.ls.LSException
Modifier and Type | Constant Field | Value
public static final short | PARSE_ERR | 81
public static final short | SERIALIZE_ERR | 82

org.w3c.dom.ls.LSParser
Modifier and Type | Constant Field | Value
public static final short | ACTION_APPEND_AS_CHILDREN | 1
public static final short | ACTION_INSERT_AFTER | 4
public static final short | ACTION_INSERT_BEFORE | 3
public static final short | ACTION_REPLACE | 5
public static final short | ACTION_REPLACE_CHILDREN | 2

org.w3c.dom.ls.LSParserFilter
Modifier and Type | Constant Field | Value
public static final short | FILTER_ACCEPT | 1
public static final short | FILTER_INTERRUPT | 4
public static final short | FILTER_REJECT | 2
public static final short | FILTER_SKIP | 3

org.xml.*

org.xml.sax.helpers.NamespaceSupport
Modifier and Type | Constant Field | Value
public static final String | NSDECL | "http://www.w3.org/xmlns/2000/"
public static final String | XMLNS | "http://www.w3.org/XML/1998/namespace"

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV NEXT FRAMES NO FRAMES


Deprecated List (Java Platform SE 7 b59)

DRAFT ea-b59
PREV NEXT FRAMES NO FRAMES

Deprecated API

Contents
  • Deprecated Interfaces
  • Deprecated Classes
  • Deprecated Exceptions
  • Deprecated Annotation Types
  • Deprecated Fields
  • Deprecated Methods
  • Deprecated Constructors
  • Deprecated Annotation Type Elements
Deprecated Interfaces
Interface and Description
org.xml.sax.AttributeList
This interface has been replaced by the SAX2 Attributes interface, which includes Namespace support.
java.security.Certificate
A new certificate handling package is created in the Java platform. This Certificate interface is entirely deprecated and is here to allow for a smooth transition to the new package.
org.xml.sax.DocumentHandler
This interface has been replaced by the SAX2 ContentHandler interface, which includes Namespace support.
org.omg.CORBA.DynAny
Use the new DynAny instead
org.omg.CORBA.DynArray
Use the new DynArray instead
org.omg.CORBA.DynEnum
Use the new DynEnum instead
org.omg.CORBA.DynFixed
Use the new DynFixed instead
org.omg.CORBA.DynSequence
Use the new DynSequence instead
org.omg.CORBA.DynStruct
Use the new DynStruct instead
org.omg.CORBA.DynUnion
Use the new DynUnion instead
org.omg.CORBA.DynValue
Use the new DynValue instead
java.rmi.server.LoaderHandler
no replacement
org.xml.sax.Parser
This interface has been replaced by the SAX2 XMLReader interface, which includes Namespace support.
java.rmi.registry.RegistryHandler
no replacement
java.rmi.server.RemoteCall
no replacement.
java.rmi.server.Skeleton
no replacement. Skeletons are no longer required for remote method calls in the Java 2 platform v1.2 and greater.
javax.xml.bind.Validator
since JAXB 2.0

Deprecated Classes
Class and Description
javax.accessibility.AccessibleResourceBundle
This class is deprecated as of version 1.3 of the Java Platform.
org.xml.sax.helpers.AttributeListImpl
This class implements a deprecated interface, AttributeList; that interface has been replaced by Attributes, which is implemented in the AttributesImpl helper class.
javax.management.DefaultLoaderRepository
Use MBeanServer.getClassLoaderRepository() instead.
javax.management.loading.DefaultLoaderRepository
Use MBeanServer.getClassLoaderRepository()} instead.
javax.swing.text.DefaultTextUI
org.omg.CORBA.DynamicImplementation
org.omg.CORBA.DynamicImplementation
org.xml.sax.HandlerBase
This class works with the deprecated DocumentHandler interface. It has been replaced by the SAX2 DefaultHandler class.
java.security.Identity
This class is no longer used. Its functionality has been replaced by java.security.KeyStore, the java.security.cert package, and java.security.Principal.
java.security.IdentityScope
This class is no longer used. Its functionality has been replaced by java.security.KeyStore, the java.security.cert package, and java.security.Principal.
java.io.LineNumberInputStream
This class incorrectly assumes that bytes adequately represent characters. As of JDK 1.1, the preferred way to operate on character streams is via the new character-stream classes, which include a class for counting line numbers.
java.rmi.server.LogStream
no replacement
javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup
As of Java 2 platform v1.4.
java.rmi.server.Operation
no replacement
org.xml.sax.helpers.ParserFactory
This class works with the deprecated Parser interface.
javax.security.auth.Policy
as of JDK version 1.4 -- Replaced by java.security.Policy. java.security.Policy has a method:
      public PermissionCollection getPermissions
          (java.security.ProtectionDomain pd)
and ProtectionDomain has a constructor:
      public ProtectionDomain
          (CodeSource cs,
           PermissionCollection permissions,
           ClassLoader loader,
           Principal[] principals)
These two APIs provide callers the means to query the Policy for Principal-based Permission entries.
org.omg.CORBA.Principal
Deprecated by CORBA 2.2.
org.omg.CORBA.PrincipalHolder
Deprecated by CORBA 2.2.
java.security.Signer
This class is no longer used. Its functionality has been replaced by java.security.KeyStore, the java.security.cert package, and java.security.Principal.
javax.xml.soap.SOAPElementFactory
- Use javax.xml.soap.SOAPFactory for creating SOAPElements.
java.io.StringBufferInputStream
This class does not properly convert characters into bytes. As of JDK 1.1, the preferred way to create a stream from a string is via the StringReader class.
javax.swing.text.TableView.TableCell
A table cell can now be any View implementation.

Deprecated Exceptions
Exceptions and Description
java.rmi.RMISecurityException
Use SecurityException instead. Application code should never directly reference this class, and RMISecurityManager no longer throws this subclass of java.lang.SecurityException.
java.rmi.ServerRuntimeException
no replacement
java.rmi.server.SkeletonMismatchException
no replacement. Skeletons are no longer required for remote method calls in the Java 2 platform v1.2 and greater.
java.rmi.server.SkeletonNotFoundException
no replacement. Skeletons are no longer required for remote method calls in the Java 2 platform v1.2 and greater.

Deprecated Annotation Types
Annotation Type and Description
javax.jws.soap.InitParam
As of JSR-181 2.0 with no replacement.
javax.jws.soap.SOAPMessageHandler
As of JSR-181 2.0 with no replacement.
javax.jws.soap.SOAPMessageHandlers
As of JSR-181 2.0 with no replacement.

Deprecated Fields
Field and Description
javax.management.openmbean.OpenType.ALLOWED_CLASSNAMES
Use ALLOWED_CLASSNAMES_LIST instead.
javax.management.monitor.Monitor.alreadyNotified
equivalent to Monitor.alreadyNotifieds[0].
javax.swing.JViewport.backingStore
As of Java 2 platform v1.3
javax.swing.plaf.basic.BasicDesktopPaneUI.closeKey
As of 1.3.
java.awt.Frame.CROSSHAIR_CURSOR
replaced by Cursor.CROSSHAIR_CURSOR.
javax.management.monitor.Monitor.dbgTag
No replacement.
java.awt.Frame.DEFAULT_CURSOR
replaced by Cursor.DEFAULT_CURSOR.
javax.swing.JRootPane.defaultPressAction
As of Java 2 platform v1.3.
javax.swing.JRootPane.defaultReleaseAction
As of Java 2 platform v1.3.
javax.swing.plaf.basic.BasicSplitPaneUI.dividerResizeToggleKey
As of Java 2 platform v1.3.
javax.swing.plaf.basic.BasicToolBarUI.downKey
As of Java 2 platform v1.3.
javax.swing.plaf.basic.BasicTabbedPaneUI.downKey
As of Java 2 platform v1.3.
javax.swing.plaf.basic.BasicSplitPaneUI.downKey
As of Java 2 platform v1.3.
java.awt.Frame.E_RESIZE_CURSOR
replaced by Cursor.E_RESIZE_CURSOR.
javax.swing.plaf.basic.BasicSplitPaneUI.endKey
As of Java 2 platform v1.3.
java.util.logging.Logger.global
Initialization of this field is prone to deadlocks. The field must be initialized by the Logger class initialization which may cause deadlocks with the LogManager class initialization. In such cases two class initialization wait for each other to complete. The preferred way to get the global logger object is via the call Logger.getGlobal(). For compatibility with old JDK versions where the Logger.getGlobal() is not available use the call Logger.getLogger(Logger.GLOBAL_LOGGER_NAME) or Logger.getLogger("global").
java.awt.Frame.HAND_CURSOR
replaced by Cursor.HAND_CURSOR.
javax.swing.plaf.basic.BasicSplitPaneUI.homeKey
As of Java 2 platform v1.3.
java.net.HttpURLConnection.HTTP_SERVER_ERROR
it is misplaced and shouldn't have existed.
java.lang.SecurityManager.inCheck
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.
javax.swing.plaf.basic.BasicSplitPaneUI.keyboardDownRightListener
As of Java 2 platform v1.3.
javax.swing.plaf.basic.BasicSplitPaneUI.keyboardEndListener
As of Java 2 platform v1.3.
javax.swing.plaf.basic.BasicSplitPaneUI.keyboardHomeListener
As of Java 2 platform v1.3.
javax.swing.plaf.basic.BasicSplitPaneUI.keyboardResizeToggleListener
As of Java 2 platform v1.3.
javax.swing.plaf.basic.BasicSplitPaneUI.keyboardUpLeftListener
As of Java 2 platform v1.3.
javax.swing.plaf.basic.BasicToolBarUI.leftKey
As of Java 2 platform v1.3.
javax.swing.plaf.basic.BasicTabbedPaneUI.leftKey
As of Java 2 platform v1.3.
javax.swing.plaf.basic.BasicSplitPaneUI.leftKey
As of Java 2 platform v1.3.
javax.swing.plaf.basic.BasicDesktopPaneUI.maximizeKey
As of 1.3.
javax.swing.plaf.basic.BasicDesktopPaneUI.minimizeKey
As of 1.3.
java.awt.Frame.MOVE_CURSOR
replaced by Cursor.MOVE_CURSOR.
java.awt.Frame.N_RESIZE_CURSOR
replaced by Cursor.N_RESIZE_CURSOR.
javax.swing.plaf.basic.BasicDesktopPaneUI.navigateKey
As of 1.3.
javax.swing.plaf.basic.BasicDesktopPaneUI.navigateKey2
As of 1.3.
java.awt.Frame.NE_RESIZE_CURSOR
replaced by Cursor.NE_RESIZE_CURSOR.
java.awt.Frame.NW_RESIZE_CURSOR
replaced by Cursor.NW_RESIZE_CURSOR.
javax.swing.plaf.basic.BasicInternalFrameUI.openMenuKey
As of Java 2 platform v1.3.
java.awt.datatransfer.DataFlavor.plainTextFlavor
as of 1.3. Use DataFlavor.getReaderForText(Transferable) instead of Transferable.getTransferData(DataFlavor.plainTextFlavor).
javax.swing.text.html.FormView.RESET
As of 1.3, value comes from UIManager UIManager property FormView.resetButtonText
javax.swing.table.TableColumn.resizedPostingDisableCount
as of Java 2 platform v1.3
javax.swing.plaf.basic.BasicToolBarUI.rightKey
As of Java 2 platform v1.3.
javax.swing.plaf.basic.BasicTabbedPaneUI.rightKey
As of Java 2 platform v1.3.
javax.swing.plaf.basic.BasicSplitPaneUI.rightKey
As of Java 2 platform v1.3.
java.awt.Frame.S_RESIZE_CURSOR
replaced by Cursor.S_RESIZE_CURSOR.
java.awt.Frame.SE_RESIZE_CURSOR
replaced by Cursor.SE_RESIZE_CURSOR.
javax.swing.text.html.FormView.SUBMIT
As of 1.3, value now comes from UIManager property FormView.submitButtonText
java.lang.Character.UnicodeBlock.SURROGATES_AREA
As of J2SE 5, use Character.UnicodeBlock.HIGH_SURROGATES, Character.UnicodeBlock.HIGH_PRIVATE_USE_SURROGATES, and Character.UnicodeBlock.LOW_SURROGATES. These new constants match the block definitions of the Unicode Standard. The Character.UnicodeBlock.of(char) and Character.UnicodeBlock.of(int) methods return the new constants, not SURROGATES_AREA.
java.awt.Frame.SW_RESIZE_CURSOR
replaced by Cursor.SW_RESIZE_CURSOR.
java.awt.Frame.TEXT_CURSOR
replaced by Cursor.TEXT_CURSOR.
javax.swing.plaf.basic.BasicToolBarUI.upKey
As of Java 2 platform v1.3.
javax.swing.plaf.basic.BasicTabbedPaneUI.upKey
As of Java 2 platform v1.3.
javax.swing.plaf.basic.BasicSplitPaneUI.upKey
As of Java 2 platform v1.3.
java.awt.Frame.W_RESIZE_CURSOR
replaced by Cursor.W_RESIZE_CURSOR.
java.awt.Frame.WAIT_CURSOR
replaced by Cursor.WAIT_CURSOR.

Deprecated Methods
Method and Description
java.awt.Component.action(Event, Object)
As of JDK version 1.1, should register this component as ActionListener on component which fires action events.
java.awt.List.addItem(String)
replaced by add(String).
java.awt.List.addItem(String, int)
replaced by add(String, int).
java.awt.CardLayout.addLayoutComponent(String, Component)
replaced by addLayoutComponent(Component, Object).
java.awt.BorderLayout.addLayoutComponent(String, Component)
replaced by addLayoutComponent(Component, Object).
java.awt.List.allowsMultipleSelections()
As of JDK version 1.1, replaced by isMultipleMode().
java.lang.ThreadGroup.allowThreadSuspension(boolean)
The definition of this call depends on ThreadGroup.suspend(), which is deprecated. Further, the behavior of this call was never specified.
java.awt.TextArea.appendText(String)
As of JDK version 1.1, replaced by append(String).
java.awt.Window.applyResourceBundle(ResourceBundle)
As of J2SE 1.4, replaced by Component.applyComponentOrientation.
java.awt.Window.applyResourceBundle(String)
As of J2SE 1.4, replaced by Component.applyComponentOrientation.
java.awt.Component.bounds()
As of JDK version 1.1, replaced by getBounds().
java.lang.SecurityManager.checkMulticast(InetAddress, byte)
Use #checkPermission(java.security.Permission) instead
java.lang.SecurityManager.classDepth(String)
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.
java.lang.SecurityManager.classLoaderDepth()
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.
java.awt.List.clear()
As of JDK version 1.1, replaced by removeAll().
java.awt.image.renderable.RenderContext.concetenateTransform(AffineTransform)
replaced by concatenateTransform(AffineTransform).
java.awt.Container.countComponents()
As of JDK version 1.1, replaced by getComponentCount().
java.awt.Menu.countItems()
As of JDK version 1.1, replaced by getItemCount().
java.awt.List.countItems()
As of JDK version 1.1, replaced by getItemCount().
java.awt.Choice.countItems()
As of JDK version 1.1, replaced by getItemCount().
java.awt.MenuBar.countMenus()
As of JDK version 1.1, replaced by getMenuCount().
java.lang.Thread.countStackFrames()
The definition of this call depends on Thread.suspend(), which is deprecated. Further, the results of this call were never well-defined.
org.omg.CORBA.ORB.create_basic_dyn_any(TypeCode)
Use the new DynAnyFactory API instead
org.omg.CORBA.ORB.create_dyn_any(Any)
Use the new DynAnyFactory API instead
org.omg.CORBA.ORB.create_dyn_array(TypeCode)
Use the new DynAnyFactory API instead
org.omg.CORBA.ORB.create_dyn_enum(TypeCode)
Use the new DynAnyFactory API instead
org.omg.CORBA.ORB.create_dyn_sequence(TypeCode)
Use the new DynAnyFactory API instead
org.omg.CORBA.ORB.create_dyn_struct(TypeCode)
Use the new DynAnyFactory API instead
org.omg.CORBA.ORB.create_dyn_union(TypeCode)
Use the new DynAnyFactory API instead
org.omg.CORBA.ORB.create_recursive_sequence_tc(int, int)
Use a combination of create_recursive_tc and create_sequence_tc instead
javax.xml.soap.SOAPElementFactory.create(Name)
Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
javax.xml.soap.SOAPElementFactory.create(String)
Use javax.xml.soap.SOAPFactory.createElement(String localName) instead
javax.xml.soap.SOAPElementFactory.create(String, String, String)
Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead
javax.swing.plaf.basic.BasicSplitPaneUI.createKeyboardDownRightListener()
As of Java 2 platform v1.3.
javax.swing.plaf.basic.BasicSplitPaneUI.createKeyboardEndListener()
As of Java 2 platform v1.3.
javax.swing.plaf.basic.BasicSplitPaneUI.createKeyboardHomeListener()
As of Java 2 platform v1.3.
javax.swing.plaf.basic.BasicSplitPaneUI.createKeyboardResizeToggleListener()
As of Java 2 platform v1.3.
javax.swing.plaf.basic.BasicSplitPaneUI.createKeyboardUpLeftListener()
As of Java 2 platform v1.3.
javax.swing.JTable.createScrollPaneForTable(JTable)
As of Swing version 1.0.2, replaced by new JScrollPane(aTable).
javax.swing.text.TableView.createTableCell(Element)
Table cells can now be any arbitrary View implementation and should be produced by the ViewFactory rather than the table.
javax.xml.bind.JAXBContext.createValidator()
since JAXB2.0
java.lang.SecurityManager.currentClassLoader()
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.
java.lang.SecurityManager.currentLoadedClass()
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.
java.net.URLDecoder.decode(String)
The resulting string may vary depending on the platform's default encoding. Instead, use the decode(String,String) method to specify the encoding.
java.lang.ClassLoader.defineClass(byte[], int, int)
Replaced by defineClass(String, byte[], int, int)
java.awt.List.delItem(int)
replaced by remove(String) and remove(int).
java.awt.List.delItems(int, int)
As of JDK version 1.1, Not for public use in the future. This method is expected to be retained only as a package private method.
java.awt.Container.deliverEvent(Event)
As of JDK version 1.1, replaced by dispatchEvent(AWTEvent e)
java.awt.Component.deliverEvent(Event)
As of JDK version 1.1, replaced by dispatchEvent(AWTEvent e).
javax.management.MBeanServer.deserialize(ObjectName, byte[])
Use getClassLoaderFor to obtain the appropriate class loader for deserialization.
javax.management.namespace.MBeanServerSupport.deserialize(ObjectName, byte[])
javax.management.namespace.MBeanServerConnectionWrapper.deserialize(ObjectName, byte[])
see MBeanServer
javax.management.remote.IdentityMBeanServerForwarder.deserialize(ObjectName, byte[])
javax.management.MBeanServer.deserialize(String, byte[])
Use MBeanServer.getClassLoaderRepository() to obtain the class loader repository and use it to deserialize.
javax.management.namespace.MBeanServerSupport.deserialize(String, byte[])
javax.management.namespace.MBeanServerConnectionWrapper.deserialize(String, byte[])
see MBeanServer
javax.management.remote.IdentityMBeanServerForwarder.deserialize(String, byte[])
javax.management.MBeanServer.deserialize(String, ObjectName, byte[])
Use getClassLoader to obtain the class loader for deserialization.
javax.management.namespace.MBeanServerSupport.deserialize(String, ObjectName, byte[])
javax.management.namespace.MBeanServerConnectionWrapper.deserialize(String, ObjectName, byte[])
see MBeanServer
javax.management.remote.IdentityMBeanServerForwarder.deserialize(String, ObjectName, byte[])
java.lang.Thread.destroy()
This method was originally designed to destroy this thread without any cleanup. Any monitors it held would have remained locked. However, the method was never implemented. If if were to be implemented, it would be deadlock-prone in much the manner of Thread.suspend(). If the target thread held a lock protecting a critical system resource when it was destroyed, no thread could ever access this resource again. If another thread ever attempted to lock this resource, deadlock would result. Such deadlocks typically manifest themselves as "frozen" processes. For more information, see Why are Thread.stop, Thread.suspend and Thread.resume Deprecated?.
java.awt.MenuItem.disable()
As of JDK version 1.1, replaced by setEnabled(boolean).
java.awt.Component.disable()
As of JDK version 1.1, replaced by setEnabled(boolean).
javax.swing.JComponent.disable()
As of JDK version 1.1, replaced by java.awt.Component.setEnabled(boolean).
javax.swing.table.TableColumn.disableResizedPosting()
as of Java 2 platform v1.3
javax.swing.FocusManager.disableSwingFocusManager()
as of 1.4, replaced by KeyboardFocusManager.setDefaultFocusTraversalPolicy(FocusTraversalPolicy)
java.rmi.server.Skeleton.dispatch(Remote, RemoteCall, int, long)
no replacement
java.rmi.server.RemoteCall.done()
no replacement
java.rmi.server.RemoteRef.done(RemoteCall)
1.2 style stubs no longer use this method. Instead of using a sequence of method calls to the remote reference (newCall, invoke, and done), a stub uses a single method, invoke(Remote, Method, Object[], int), on the remote reference to carry out parameter marshalling, remote method executing and unmarshalling of the return value.
javax.swing.plaf.metal.MetalComboBoxUI.editablePropertyChanged(PropertyChangeEvent)
As of Java 2 platform v1.4.
java.awt.MenuItem.enable()
As of JDK version 1.1, replaced by setEnabled(boolean).
java.awt.Component.enable()
As of JDK version 1.1, replaced by setEnabled(boolean).
javax.swing.JComponent.enable()
As of JDK version 1.1, replaced by java.awt.Component.setEnabled(boolean).
java.awt.MenuItem.enable(boolean)
As of JDK version 1.1, replaced by setEnabled(boolean).
java.awt.Component.enable(boolean)
As of JDK version 1.1, replaced by setEnabled(boolean).
javax.swing.table.TableColumn.enableResizedPosting()
as of Java 2 platform v1.3
java.net.URLEncoder.encode(String)
The resulting string may vary depending on the platform's default encoding. Instead, use the encode(String,String) method to specify the encoding.
java.security.SignatureSpi.engineGetParameter(String)
java.security.SignatureSpi.engineSetParameter(String, Object)
Replaced by engineSetParameter.
java.awt.datatransfer.DataFlavor.equals(String)
As inconsistent with hashCode() contract, use isMimeTypeEqual(String) instead.
org.omg.CORBA.ServerRequest.except(Any)
use set_exception()
java.rmi.server.RemoteCall.executeCall()
no replacement
org.omg.CORBA.Any.extract_Principal()
Deprecated by CORBA 2.2.
javax.swing.SwingUtilities.findFocusOwner(Component)
As of 1.4, replaced by KeyboardFocusManager.getFocusOwner().
org.omg.CORBA.ORB.get_current()
use resolve_initial_references.
java.security.Security.getAlgorithmProperty(String, String)
This method used to return the value of a proprietary property in the master file of the "SUN" Cryptographic Service Provider in order to determine how to parse algorithm-specific parameters. Use the new provider-based and algorithm-independent AlgorithmParameters and KeyFactory engine classes (introduced in the J2SE version 1.2 platform) instead.
java.sql.ResultSet.getBigDecimal(int, int)
java.sql.CallableStatement.getBigDecimal(int, int)
use getBigDecimal(int parameterIndex) or getBigDecimal(String parameterName)
java.sql.ResultSet.getBigDecimal(String, int)
java.awt.Polygon.getBoundingBox()
As of JDK version 1.1, replaced by getBounds().
java.lang.String.getBytes(int, int, byte[], int)
This method does not properly convert characters into bytes. As of JDK 1.1, the preferred way to do this is via the String.getBytes() method, which uses the platform's default charset.
java.awt.Graphics.getClipRect()
As of JDK version 1.1, replaced by getClipBounds().
javax.swing.JPopupMenu.getComponentAtIndex(int)
replaced by Container.getComponent(int)
javax.swing.JMenuBar.getComponentAtIndex(int)
replaced by getComponent(int i)
java.awt.CheckboxGroup.getCurrent()
As of JDK version 1.1, replaced by getSelectedCheckbox().
java.awt.Frame.getCursorType()
As of JDK version 1.1, replaced by Component.getCursor().
java.sql.Time.getDate()
java.util.Date.getDate()
As of JDK version 1.1, replaced by Calendar.get(Calendar.DAY_OF_MONTH).
java.sql.Time.getDay()
java.util.Date.getDay()
As of JDK version 1.1, replaced by Calendar.get(Calendar.DAY_OF_WEEK).
java.net.URLConnection.getDefaultRequestProperty(String)
The instance specific getRequestProperty method should be used after an appropriate instance of URLConnection is obtained.
java.rmi.server.LogStream.getDefaultStream()
no replacement
javax.management.monitor.StringMonitorMBean.getDerivedGauge()
As of JMX 1.2, replaced by StringMonitorMBean.getDerivedGauge(ObjectName)
javax.management.monitor.StringMonitor.getDerivedGauge()
As of JMX 1.2, replaced by StringMonitor.getDerivedGauge(ObjectName)
javax.management.monitor.GaugeMonitorMBean.getDerivedGauge()
As of JMX 1.2, replaced by GaugeMonitorMBean.getDerivedGauge(ObjectName)
javax.management.monitor.GaugeMonitor.getDerivedGauge()
As of JMX 1.2, replaced by GaugeMonitor.getDerivedGauge(ObjectName)
javax.management.monitor.CounterMonitorMBean.getDerivedGauge()
As of JMX 1.2, replaced by CounterMonitorMBean.getDerivedGauge(ObjectName)
javax.management.monitor.CounterMonitor.getDerivedGauge()
As of JMX 1.2, replaced by CounterMonitor.getDerivedGauge(ObjectName)
javax.management.monitor.StringMonitorMBean.getDerivedGaugeTimeStamp()
As of JMX 1.2, replaced by StringMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)
javax.management.monitor.StringMonitor.getDerivedGaugeTimeStamp()
As of JMX 1.2, replaced by StringMonitor.getDerivedGaugeTimeStamp(ObjectName)
javax.management.monitor.GaugeMonitorMBean.getDerivedGaugeTimeStamp()
As of JMX 1.2, replaced by GaugeMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)
javax.management.monitor.GaugeMonitor.getDerivedGaugeTimeStamp()
As of JMX 1.2, replaced by GaugeMonitor.getDerivedGaugeTimeStamp(ObjectName)
javax.management.monitor.CounterMonitorMBean.getDerivedGaugeTimeStamp()
As of JMX 1.2, replaced by CounterMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)
javax.management.monitor.CounterMonitor.getDerivedGaugeTimeStamp()
As of JMX 1.2, replaced by CounterMonitor.getDerivedGaugeTimeStamp(ObjectName)
javax.swing.plaf.basic.BasicSplitPaneUI.getDividerBorderSize()
As of Java 2 platform v1.3, instead set the border on the divider.
javax.xml.bind.Validator.getEventHandler()
since JAXB2.0
java.awt.Toolkit.getFontList()
see GraphicsEnvironment.getAvailableFontFamilyNames()
javax.swing.text.LabelView.getFontMetrics()
FontMetrics are not used for glyph rendering when running in the JDK.
java.awt.Toolkit.getFontMetrics(Font)
As of JDK version 1.2, replaced by the Font method getLineMetrics.
java.awt.Toolkit.getFontPeer(String, int)
see java.awt.GraphicsEnvironment#getAllFonts
java.sql.Date.getHours()
java.util.Date.getHours()
As of JDK version 1.1, replaced by Calendar.get(Calendar.HOUR_OF_DAY).
java.lang.SecurityManager.getInCheck()
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.
java.rmi.server.RemoteCall.getInputStream()
no replacement
javax.swing.KeyStroke.getKeyStroke(char, boolean)
use getKeyStroke(char)
javax.swing.AbstractButton.getLabel()
- Replaced by getText
java.awt.Scrollbar.getLineIncrement()
As of JDK version 1.1, replaced by getUnitIncrement().
java.lang.Runtime.getLocalizedInputStream(InputStream)
As of JDK 1.1, the preferred way to translate a byte stream in the local encoding into a character stream in Unicode is via the InputStreamReader and BufferedReader classes.
java.lang.Runtime.getLocalizedOutputStream(OutputStream)
As of JDK 1.1, the preferred way to translate a Unicode character stream into a byte stream in the local encoding is via the OutputStreamWriter, BufferedWriter, and PrintWriter classes.
java.sql.DriverManager.getLogStream()
java.awt.FontMetrics.getMaxDecent()
As of JDK version 1.1.1, replaced by getMaxDescent().
javax.swing.JRootPane.getMenuBar()
As of Swing version 1.0.3 replaced by getJMenuBar().
javax.swing.JInternalFrame.getMenuBar()
As of Swing version 1.0.3, replaced by getJMenuBar().
java.sql.Date.getMinutes()
java.util.Date.getMinutes()
As of JDK version 1.1, replaced by Calendar.get(Calendar.MINUTE).
java.sql.Time.getMonth()
java.util.Date.getMonth()
As of JDK version 1.1, replaced by Calendar.get(Calendar.MONTH).
javax.swing.JComponent.getNextFocusableComponent()
As of 1.4, replaced by FocusTraversalPolicy.
javax.management.monitor.MonitorMBean.getObservedObject()
As of JMX 1.2, replaced by MonitorMBean.getObservedObjects()
javax.management.monitor.Monitor.getObservedObject()
As of JMX 1.2, replaced by Monitor.getObservedObjects()
java.rmi.server.Operation.getOperation()
no replacement
java.rmi.server.Skeleton.getOperations()
no replacement
java.awt.ComponentOrientation.getOrientation(ResourceBundle)
As of J2SE 1.4, use ComponentOrientation.getOrientation(java.util.Locale).
java.rmi.server.RemoteCall.getOutputStream()
no replacement
java.rmi.server.LogStream.getOutputStream()
no replacement
java.awt.Scrollbar.getPageIncrement()
As of JDK version 1.1, replaced by getBlockIncrement().
java.security.Signature.getParameter(String)
java.awt.MenuComponent.getPeer()
As of JDK version 1.1, programs should not directly manipulate peers.
java.awt.Font.getPeer()
Font rendering is now platform independent.
java.awt.Component.getPeer()
As of JDK version 1.1, programs should not directly manipulate peers; replaced by boolean isDisplayable().
javax.xml.bind.Validator.getProperty(String)
since JAXB2.0
java.rmi.server.RemoteCall.getResultStream(boolean)
no replacement
java.sql.Date.getSeconds()
java.util.Date.getSeconds()
As of JDK version 1.1, replaced by Calendar.get(Calendar.SECOND).
java.rmi.server.RMIClassLoader.getSecurityContext(ClassLoader)
no replacement. As of the Java 2 platform v1.2, RMI no longer uses this method to obtain a class loader's security context.
java.rmi.server.LoaderHandler.getSecurityContext(ClassLoader)
no replacement
javax.swing.JPasswordField.getText()
As of Java 2 platform v1.2, replaced by getPassword.
javax.swing.JPasswordField.getText(int, int)
As of Java 2 platform v1.2, replaced by getPassword.
javax.management.monitor.CounterMonitorMBean.getThreshold()
As of JMX 1.2, replaced by CounterMonitorMBean.getThreshold(ObjectName)
javax.management.monitor.CounterMonitor.getThreshold()
As of JMX 1.2, replaced by CounterMonitor.getThreshold(ObjectName)
java.util.Date.getTimezoneOffset()
As of JDK version 1.1, replaced by -(Calendar.get(Calendar.ZONE_OFFSET) + Calendar.get(Calendar.DST_OFFSET)) / (60 * 1000).
java.net.MulticastSocket.getTTL()
use the getTimeToLive method instead, which returns an int instead of a byte.
java.net.DatagramSocketImpl.getTTL()
use getTimeToLive instead.
java.sql.ResultSet.getUnicodeStream(int)
use getCharacterStream in place of getUnicodeStream
java.sql.ResultSet.getUnicodeStream(String)
use getCharacterStream instead
javax.swing.ScrollPaneLayout.getViewportBorderBounds(JScrollPane)
As of JDK version Swing1.1 replaced by JScrollPane.getViewportBorderBounds().
java.awt.Scrollbar.getVisible()
As of JDK version 1.1, replaced by getVisibleAmount().
java.sql.Time.getYear()
java.util.Date.getYear()
As of JDK version 1.1, replaced by Calendar.get(Calendar.YEAR) - 1900.
java.awt.Component.gotFocus(Event, Object)
As of JDK version 1.1, replaced by processFocusEvent(FocusEvent).
java.awt.Component.handleEvent(Event)
As of JDK version 1.1 replaced by processEvent(AWTEvent).
java.awt.Window.hide()
As of JDK version 1.5, replaced by Window.setVisible(boolean).
java.awt.Dialog.hide()
As of JDK version 1.5, replaced by setVisible(boolean).
java.awt.Component.hide()
As of JDK version 1.1, replaced by setVisible(boolean).
java.lang.SecurityManager.inClass(String)
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.
java.lang.SecurityManager.inClassLoader()
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.
org.omg.CORBA.Any.insert_Principal(Principal)
Deprecated by CORBA 2.2.
javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction.insertAtBoundry(JEditorPane, HTMLDocument, int, Element, String, HTML.Tag, HTML.Tag)
As of Java 2 platform v1.3, use insertAtBoundary
java.awt.TextArea.insertText(String, int)
As of JDK version 1.1, replaced by insert(String, int).
java.awt.Container.insets()
As of JDK version 1.1, replaced by getInsets().
java.awt.Rectangle.inside(int, int)
As of JDK version 1.1, replaced by contains(int, int).
java.awt.Polygon.inside(int, int)
As of JDK version 1.1, replaced by contains(int, int).
java.awt.Component.inside(int, int)
As of JDK version 1.1, replaced by contains(int, int).
java.rmi.server.RemoteRef.invoke(RemoteCall)
1.2 style stubs no longer use this method. Instead of using a sequence of method calls to the remote reference (newCall, invoke, and done), a stub uses a single method, invoke(Remote, Method, Object[], int), on the remote reference to carry out parameter marshalling, remote method executing and unmarshalling of the return value.
org.omg.CORBA.DynamicImplementation.invoke(ServerRequest)
Deprecated by Portable Object Adapter
javax.swing.JViewport.isBackingStoreEnabled()
As of Java 2 platform v1.3, replaced by getScrollMode().
javax.swing.FocusManager.isFocusManagerEnabled()
As of 1.4, replaced by KeyboardFocusManager.getDefaultFocusTraversalPolicy()
java.awt.Component.isFocusTraversable()
As of 1.4, replaced by isFocusable().
java.lang.Character.isJavaLetter(char)
Replaced by isJavaIdentifierStart(char).
java.lang.Character.isJavaLetterOrDigit(char)
Replaced by isJavaIdentifierPart(char).
javax.swing.JComponent.isManagingFocus()
As of 1.4, replaced by Component.setFocusTraversalKeys(int, Set) and Container.setFocusCycleRoot(boolean).
java.awt.List.isSelected(int)
As of JDK version 1.1, replaced by isIndexSelected(int).
java.lang.Character.isSpace(char)
Replaced by isWhitespace(char).
java.rmi.dgc.VMID.isUnique()
javax.xml.bind.Unmarshaller.isValidating()
since JAXB2.0, please see Unmarshaller.getSchema()
java.awt.Component.keyDown(Event, int)
As of JDK version 1.1, replaced by processKeyEvent(KeyEvent).
java.awt.Component.keyUp(Event, int)
As of JDK version 1.1, replaced by processKeyEvent(KeyEvent).
java.awt.ScrollPane.layout()
As of JDK version 1.1, replaced by doLayout().
java.awt.Container.layout()
As of JDK version 1.1, replaced by doLayout().
java.awt.Component.layout()
As of JDK version 1.1, replaced by doLayout().
java.rmi.server.RMIClassLoader.loadClass(String)
replaced by loadClass(String,String) method
java.rmi.server.LoaderHandler.loadClass(String)
no replacement
java.rmi.server.LoaderHandler.loadClass(URL, String)
no replacement
java.awt.Container.locate(int, int)
As of JDK version 1.1, replaced by getComponentAt(int, int).
java.awt.Component.locate(int, int)
As of JDK version 1.1, replaced by getComponentAt(int, int).
java.awt.Component.location()
As of JDK version 1.1, replaced by getLocation().
java.rmi.server.LogStream.log(String)
no replacement
java.awt.Component.lostFocus(Event, Object)
As of JDK version 1.1, replaced by processFocusEvent(FocusEvent).
java.awt.TextField.minimumSize()
As of JDK version 1.1, replaced by getMinimumSize().
java.awt.TextArea.minimumSize()
As of JDK version 1.1, replaced by getMinimumSize().
java.awt.List.minimumSize()
As of JDK version 1.1, replaced by getMinimumSize().
java.awt.Container.minimumSize()
As of JDK version 1.1, replaced by getMinimumSize().
java.awt.Component.minimumSize()
As of JDK version 1.1, replaced by getMinimumSize().
java.awt.TextField.minimumSize(int)
As of JDK version 1.1, replaced by getMinimumSize(int).
java.awt.List.minimumSize(int)
As of JDK version 1.1, replaced by getMinimumSize(int).
java.awt.TextArea.minimumSize(int, int)
As of JDK version 1.1, replaced by getMinimumSize(int, int).
javax.swing.text.View.modelToView(int, Shape)
java.awt.Component.mouseDown(Event, int, int)
As of JDK version 1.1, replaced by processMouseEvent(MouseEvent).
java.awt.Component.mouseDrag(Event, int, int)
As of JDK version 1.1, replaced by processMouseMotionEvent(MouseEvent).
java.awt.Component.mouseEnter(Event, int, int)
As of JDK version 1.1, replaced by processMouseEvent(MouseEvent).
java.awt.Component.mouseExit(Event, int, int)
As of JDK version 1.1, replaced by processMouseEvent(MouseEvent).
java.awt.Component.mouseMove(Event, int, int)
As of JDK version 1.1, replaced by processMouseMotionEvent(MouseEvent).
java.awt.Component.mouseUp(Event, int, int)
As of JDK version 1.1, replaced by processMouseEvent(MouseEvent).
java.awt.Rectangle.move(int, int)
As of JDK version 1.1, replaced by setLocation(int, int).
java.awt.Component.move(int, int)
As of JDK version 1.1, replaced by setLocation(int, int).
org.omg.CORBA.Principal.name()
Deprecated by CORBA 2.2.
org.omg.CORBA.Principal.name(byte[])
Deprecated by CORBA 2.2.
java.rmi.server.RemoteRef.newCall(RemoteObject, Operation[], int, long)
1.2 style stubs no longer use this method. Instead of using a sequence of method calls on the stub's the remote reference (newCall, invoke, and done), a stub uses a single method, invoke(Remote, Method, Object[], int), on the remote reference to carry out parameter marshalling, remote method executing and unmarshalling of the return value.
java.awt.Component.nextFocus()
As of JDK version 1.1, replaced by transferFocus().
java.awt.datatransfer.DataFlavor.normalizeMimeType(String)
javax.activation.ActivationDataFlavor.normalizeMimeType(String)
java.awt.datatransfer.DataFlavor.normalizeMimeTypeParameter(String, String)
javax.activation.ActivationDataFlavor.normalizeMimeTypeParameter(String, String)
org.omg.CORBA.ServerRequest.op_name()
use operation()
org.omg.CORBA.ServerRequest.params(NVList)
use the method arguments
java.util.Date.parse(String)
As of JDK version 1.1, replaced by DateFormat.parse(String s).
java.rmi.server.LogStream.parseLevel(String)
no replacement
java.awt.Window.postEvent(Event)
As of JDK version 1.1 replaced by dispatchEvent(AWTEvent).
java.awt.MenuContainer.postEvent(Event)
As of JDK version 1.1 replaced by dispatchEvent(AWTEvent).
java.awt.MenuComponent.postEvent(Event)
As of JDK version 1.1, replaced by dispatchEvent.
java.awt.Component.postEvent(Event)
As of JDK version 1.1, replaced by dispatchEvent(AWTEvent).
java.awt.image.renderable.RenderContext.preConcetenateTransform(AffineTransform)
replaced by preConcatenateTransform(AffineTransform).
java.awt.TextField.preferredSize()
As of JDK version 1.1, replaced by getPreferredSize().
java.awt.TextArea.preferredSize()
As of JDK version 1.1, replaced by getPreferredSize().
java.awt.List.preferredSize()
As of JDK version 1.1, replaced by getPreferredSize().
java.awt.Container.preferredSize()
As of JDK version 1.1, replaced by getPreferredSize().
java.awt.Component.preferredSize()
As of JDK version 1.1, replaced by getPreferredSize().
java.awt.TextField.preferredSize(int)
As of JDK version 1.1, replaced by getPreferredSize(int).
java.awt.List.preferredSize(int)
As of JDK version 1.1, replaced by getPreferredSize(int).
java.awt.TextArea.preferredSize(int, int)
As of JDK version 1.1, replaced by getPreferredSize(int, int).
org.omg.CORBA.portable.InputStream.read_Principal()
Deprecated by CORBA 2.2.
java.io.ObjectInputStream.readLine()
This method does not properly convert bytes to characters. see DataInputStream for the details and alternatives.
java.io.DataInputStream.readLine()
This method does not properly convert bytes to characters. As of JDK 1.1, the preferred way to read lines of text is via the BufferedReader.readLine() method. Programs that use the DataInputStream class to read lines can be converted to use the BufferedReader class by replacing code of the form:
     DataInputStream d = new DataInputStream(in);
with:
     BufferedReader d
          = new BufferedReader(new InputStreamReader(in));
java.rmi.registry.RegistryHandler.registryImpl(int)
no replacement. As of the Java 2 platform v1.2, RMI no longer uses the RegistryHandler to obtain the registry's implementation.
java.rmi.registry.RegistryHandler.registryStub(String, int)
no replacement. As of the Java 2 platform v1.2, RMI no longer uses the RegistryHandler to obtain the registry's stub.
java.rmi.server.RemoteCall.releaseInputStream()
no replacement
java.rmi.server.RemoteCall.releaseOutputStream()
no replacement
javax.swing.plaf.metal.MetalComboBoxUI.removeListeners()
As of Java 2 platform v1.4.
java.awt.TextArea.replaceText(String, int, int)
As of JDK version 1.1, replaced by replaceRange(String, int, int).
javax.swing.JComponent.requestDefaultFocus()
As of 1.4, replaced by FocusTraversalPolicy.getDefaultComponent(Container).requestFocus()
java.awt.Window.reshape(int, int, int, int)
As of JDK version 1.1, replaced by setBounds(int, int, int, int).
java.awt.Rectangle.reshape(int, int, int, int)
As of JDK version 1.1, replaced by setBounds(int, int, int, int).
java.awt.Component.reshape(int, int, int, int)
As of JDK version 1.1, replaced by setBounds(int, int, int, int).
javax.swing.JComponent.reshape(int, int, int, int)
As of JDK 5, replaced by Component.setBounds(int, int, int, int).

Moves and resizes this component.

java.awt.Component.resize(Dimension)
As of JDK version 1.1, replaced by setSize(Dimension).
java.awt.Rectangle.resize(int, int)
As of JDK version 1.1, replaced by setSize(int, int).
java.awt.Component.resize(int, int)
As of JDK version 1.1, replaced by setSize(int, int).
org.omg.CORBA.ServerRequest.result(Any)
use the method set_result
java.lang.ThreadGroup.resume()
This method is used solely in conjunction with Thread.suspend and ThreadGroup.suspend, both of which have been deprecated, as they are inherently deadlock-prone. See Thread.suspend() for details.
java.lang.Thread.resume()
This method exists solely for use with Thread.suspend(), which has been deprecated because it is deadlock-prone. For more information, see Why are Thread.stop, Thread.suspend and Thread.resume Deprecated?.
java.lang.System.runFinalizersOnExit(boolean)
This method is inherently unsafe. It may result in finalizers being called on live objects while other threads are concurrently manipulating those objects, resulting in erratic behavior or deadlock.
java.lang.Runtime.runFinalizersOnExit(boolean)
This method is inherently unsafe. It may result in finalizers being called on live objects while other threads are concurrently manipulating those objects, resulting in erratic behavior or deadlock.
java.util.Properties.save(OutputStream, String)
This method does not throw an IOException if an I/O error occurs while saving the property list. The preferred way to save a properties list is via the store(OutputStream out, String comments) method or the storeToXML(OutputStream os, String comment) method.
java.net.MulticastSocket.send(DatagramPacket, byte)
Use the following code or its equivalent instead: ...... int ttl = mcastSocket.getTimeToLive(); mcastSocket.setTimeToLive(newttl); mcastSocket.send(p); mcastSocket.setTimeToLive(ttl); ......
javax.swing.JViewport.setBackingStoreEnabled(boolean)
As of Java 2 platform v1.3, replaced by setScrollMode().
java.awt.CheckboxGroup.setCurrent(Checkbox)
As of JDK version 1.1, replaced by setSelectedCheckbox(Checkbox).
java.awt.Frame.setCursor(int)
As of JDK version 1.1, replaced by Component.setCursor(Cursor).
java.sql.Time.setDate(int)
java.util.Date.setDate(int)
As of JDK version 1.1, replaced by Calendar.set(Calendar.DAY_OF_MONTH, int date).
java.net.URLConnection.setDefaultRequestProperty(String, String)
The instance specific setRequestProperty method should be used after an appropriate instance of URLConnection is obtained. Invoking this method will have no effect.
java.rmi.server.LogStream.setDefaultStream(PrintStream)
no replacement
java.awt.TextField.setEchoCharacter(char)
As of JDK version 1.1, replaced by setEchoChar(char).
javax.xml.bind.Validator.setEventHandler(ValidationEventHandler)
since JAXB2.0
java.sql.Date.setHours(int)
java.util.Date.setHours(int)
As of JDK version 1.1, replaced by Calendar.set(Calendar.HOUR_OF_DAY, int hours).
javax.swing.AbstractButton.setLabel(String)
- Replaced by setText(text)
java.awt.Scrollbar.setLineIncrement(int)
As of JDK version 1.1, replaced by setUnitIncrement(int).
java.sql.DriverManager.setLogStream(PrintStream)
javax.management.ValueExp.setMBeanServer(MBeanServer)
This method is not needed because a ValueExp can access the MBean server in which it is being evaluated by using QueryEval.getMBeanServer().
javax.management.StringValueExp.setMBeanServer(MBeanServer)
javax.management.AttributeValueExp.setMBeanServer(MBeanServer)
This method has no effect. The MBean Server used to obtain an attribute value is QueryEval.getMBeanServer().
javax.swing.JRootPane.setMenuBar(JMenuBar)
As of Swing version 1.0.3 replaced by setJMenuBar(JMenuBar menu).
javax.swing.JInternalFrame.setMenuBar(JMenuBar)
As of Swing version 1.0.3 replaced by setJMenuBar(JMenuBar m).
java.sql.Date.setMinutes(int)
java.util.Date.setMinutes(int)
As of JDK version 1.1, replaced by Calendar.set(Calendar.MINUTE, int minutes).
java.awt.event.KeyEvent.setModifiers(int)
as of JDK1.1.4
java.sql.Time.setMonth(int)
java.util.Date.setMonth(int)
As of JDK version 1.1, replaced by Calendar.set(Calendar.MONTH, int month).
java.awt.List.setMultipleSelections(boolean)
As of JDK version 1.1, replaced by setMultipleMode(boolean).
javax.swing.JComponent.setNextFocusableComponent(Component)
As of 1.4, replaced by FocusTraversalPolicy
javax.management.monitor.MonitorMBean.setObservedObject(ObjectName)
As of JMX 1.2, replaced by MonitorMBean.addObservedObject(javax.management.ObjectName)
javax.management.monitor.Monitor.setObservedObject(ObjectName)
As of JMX 1.2, replaced by Monitor.addObservedObject(javax.management.ObjectName)
java.rmi.server.LogStream.setOutputStream(OutputStream)
no replacement
java.awt.Scrollbar.setPageIncrement(int)
As of JDK version 1.1, replaced by setBlockIncrement().
java.security.Signature.setParameter(String, Object)
Use setParameter.
javax.xml.bind.Validator.setProperty(String, Object)
since JAXB2.0
java.rmi.server.RemoteStub.setRef(RemoteStub, RemoteRef)
no replacement. The setRef method is not needed since RemoteStubs can be created with the RemoteStub(RemoteRef) constructor.
java.sql.Date.setSeconds(int)
java.util.Date.setSeconds(int)
As of JDK version 1.1, replaced by Calendar.set(Calendar.SECOND, int seconds).
javax.management.monitor.CounterMonitorMBean.setThreshold(Number)
As of JMX 1.2, replaced by CounterMonitorMBean.setInitThreshold(java.lang.Number)
javax.management.monitor.CounterMonitor.setThreshold(Number)
As of JMX 1.2, replaced by CounterMonitor.setInitThreshold(java.lang.Number)
java.net.MulticastSocket.setTTL(byte)
use the setTimeToLive method instead, which uses int instead of byte as the type for ttl.
java.net.DatagramSocketImpl.setTTL(byte)
use setTimeToLive instead.
java.sql.PreparedStatement.setUnicodeStream(int, InputStream, int)
javax.sql.rowset.BaseRowSet.setUnicodeStream(int, InputStream, int)
getCharacterStream should be used in its place
java.net.URLStreamHandler.setURL(URL, String, String, int, String, String)
Use setURL(URL, String, String, int, String, String, String, String);
javax.xml.bind.Unmarshaller.setValidating(boolean)
since JAXB2.0, please see Unmarshaller.setSchema(javax.xml.validation.Schema)
java.sql.Time.setYear(int)
java.util.Date.setYear(int)
As of JDK version 1.1, replaced by Calendar.set(Calendar.YEAR, year + 1900).
java.awt.Window.show()
As of JDK version 1.5, replaced by Window.setVisible(boolean).
java.awt.Dialog.show()
As of JDK version 1.5, replaced by setVisible(boolean).
java.awt.Component.show()
As of JDK version 1.1, replaced by setVisible(boolean).
java.awt.Component.show(boolean)
As of JDK version 1.1, replaced by setVisible(boolean).
java.awt.Component.size()
As of JDK version 1.1, replaced by getSize().
javax.swing.JTable.sizeColumnsToFit(boolean)
As of Swing version 1.0.3, replaced by doLayout().
java.lang.ThreadGroup.stop()
This method is inherently unsafe. See Thread.stop() for details.
java.lang.Thread.stop()
This method is inherently unsafe. Stopping a thread with Thread.stop causes it to unlock all of the monitors that it has locked (as a natural consequence of the unchecked ThreadDeath exception propagating up the stack). If any of the objects previously protected by these monitors were in an inconsistent state, the damaged objects become visible to other threads, potentially resulting in arbitrary behavior. Many uses of stop should be replaced by code that simply modifies some variable to indicate that the target thread should stop running. The target thread should check this variable regularly, and return from its run method in an orderly fashion if the variable indicates that it is to stop running. If the target thread waits for long periods (on a condition variable, for example), the interrupt method should be used to interrupt the wait. For more information, see Why are Thread.stop, Thread.suspend and Thread.resume Deprecated?.
java.lang.Thread.stop(Throwable)
This method is inherently unsafe. See Thread.stop() for details. An additional danger of this method is that it may be used to generate exceptions that the target thread is unprepared to handle (including checked exceptions that the thread could not possibly throw, were it not for this method). For more information, see Why are Thread.stop, Thread.suspend and Thread.resume Deprecated?.
java.lang.ThreadGroup.suspend()
This method is inherently deadlock-prone. See Thread.suspend() for details.
java.lang.Thread.suspend()
This method has been deprecated, as it is inherently deadlock-prone. If the target thread holds a lock on the monitor protecting a critical system resource when it is suspended, no thread can access this resource until the target thread is resumed. If the thread that would resume the target thread attempts to lock this monitor prior to calling resume, deadlock results. Such deadlocks typically manifest themselves as "frozen" processes. For more information, see Why are Thread.stop, Thread.suspend and Thread.resume Deprecated?.
java.util.Date.toGMTString()
As of JDK version 1.1, replaced by DateFormat.format(Date date), using a GMT TimeZone.
java.util.Date.toLocaleString()
As of JDK version 1.1, replaced by DateFormat.format(Date date).
java.rmi.server.Operation.toString()
no replacement
java.rmi.server.LogStream.toString()
no replacement
java.io.ByteArrayOutputStream.toString(int)
This method does not properly convert bytes into characters. As of JDK 1.1, the preferred way to do this is via the toString(String enc) method, which takes an encoding-name argument, or the toString() method, which uses the platform's default character encoding.
java.io.File.toURL()
This method does not automatically escape characters that are illegal in URLs. It is recommended that new code convert an abstract pathname into a URL by first converting it into a URI, via the toURI method, and then converting the URI into a URL via the URI.toURL method.
java.util.Date.UTC(int, int, int, int, int, int)
As of JDK version 1.1, replaced by Calendar.set(year + 1900, month, date, hrs, min, sec) or GregorianCalendar(year + 1900, month, date, hrs, min, sec), using a UTC TimeZone, followed by Calendar.getTime().getTime().
javax.xml.bind.Validator.validate(Object)
since JAXB2.0
javax.xml.bind.Validator.validateRoot(Object)
since JAXB2.0
javax.swing.text.View.viewToModel(float, float, Shape)
org.omg.CORBA.portable.OutputStream.write_Principal(Principal)
Deprecated by CORBA 2.2.
java.rmi.server.LogStream.write(byte[], int, int)
no replacement
java.rmi.server.LogStream.write(int)
no replacement
java.io.ObjectOutputStream.PutField.write(ObjectOutput)
This method does not write the values contained by this PutField object in a proper format, and may result in corruption of the serialization stream. The correct way to write PutField data is by calling the ObjectOutputStream.writeFields() method.

Deprecated Constructors
Constructor and Description
javax.management.AttributeValueExp()
An instance created with this constructor cannot be used in a query.
java.sql.Date(int, int, int)
instead use the constructor Date(long date)
java.util.Date(int, int, int)
As of JDK version 1.1, replaced by Calendar.set(year + 1900, month, date) or GregorianCalendar(year + 1900, month, date).
java.util.Date(int, int, int, int, int)
As of JDK version 1.1, replaced by Calendar.set(year + 1900, month, date, hrs, min) or GregorianCalendar(year + 1900, month, date, hrs, min).
java.util.Date(int, int, int, int, int, int)
As of JDK version 1.1, replaced by Calendar.set(year + 1900, month, date, hrs, min, sec) or GregorianCalendar(year + 1900, month, date, hrs, min, sec).
java.util.Date(String)
As of JDK version 1.1, replaced by DateFormat.parse(String s).
java.awt.event.KeyEvent(Component, int, long, int, int)
as of JDK1.1
java.rmi.server.Operation(String)
no replacement
java.rmi.RMISecurityException(String)
no replacement
java.rmi.RMISecurityException(String, String)
no replacement
java.rmi.ServerRuntimeException(String, Exception)
no replacement
java.rmi.server.SkeletonMismatchException(String)
no replacement
java.net.Socket(InetAddress, int, boolean)
Use DatagramSocket instead for UDP transport.
java.net.Socket(String, int, boolean)
Use DatagramSocket instead for UDP transport.
java.io.StreamTokenizer(InputStream)
As of JDK version 1.1, the preferred way to tokenize an input stream is to convert it into a character stream, for example:
   Reader r = new BufferedReader(new InputStreamReader(is));
   StreamTokenizer st = new StreamTokenizer(r);
java.lang.String(byte[], int)
This method does not properly convert bytes into characters. As of JDK 1.1, the preferred way to do this is via the String constructors that take a Charset, charset name, or that use the platform's default charset.
java.lang.String(byte[], int, int, int)
This method does not properly convert bytes into characters. As of JDK 1.1, the preferred way to do this is via the String constructors that take a Charset, charset name, or that use the platform's default charset.
org.omg.CORBA.TCKind(int)
Do not use this constructor as this method should be private according to the OMG specification. Use TCKind.from_int(int) instead.
java.sql.Time(int, int, int)
Use the constructor that takes a milliseconds value in place of this constructor
java.sql.Timestamp(int, int, int, int, int, int, int)
instead use the constructor Timestamp(long millis)

Deprecated Annotation Type Elements
Annotation Type Element and Description
javax.jws.HandlerChain.name
As of JSR-181 2.0 with no replacement.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV NEXT FRAMES NO FRAMES


Easy CHM - http://www.eTextWizard.com

您现在使用的CHM文件由Easy CHM的未注册版本制作.
注册版本不会在CHM里自动添加此页面

Easy CHM 软件 软件出品: 国华软件 中国北京 |  | 截屏图片
 | 文件大小: 2989k - 2.84MB | 软件类型: 共享软件 购买注册: 这里
关键词: make chm, create chm, chm制作工具, chm电子书制作工具,chm帮助文件制作工具

描述:

Easy CHM是国华软件推出的一款强大的CHM电子书或CHM帮助文件的快速制作工具。使用EasyCHM只需要三个步骤就可以完成CHM的制作：1、用户指定一个目录，EasyCHM会自动导入全部目录及文件；2、设置CHM编译选项；3、开始制作。EasyCHM非常适合个人和单位制作高压缩比的带有全文检索及高亮显示搜索结果的网页集锦、CHM帮助文件、产品说明、公司介绍、CHM电子书等等。

主要功能：

  • 全自动的目录及文件导入（可以包括子目录）；
  • EasyCHM支持导入任意的文件类型；
  • EasyCHM操作速度快，性能稳定，EasyCHM因为上手容易深得广大用户好评；
  • EasyCHM自动生成CHM的目录列表并自动生成所有目录项；
  • 为CHM的目录列表自动添加多级编号；
  • 在编辑目录项、索引项时用到的移动、拖拽、替换等操作中Easy CHM完全支持多选操作，避免了一项一项地操作，极大的减少用户手工 － 非常适合企业维护CHM帮助文档；
  • 支持批量查找替换多级目录各项的标题文字内容；
  • 允许用户指定从文本文件的第N行自动截取标题；
  • 易用的目录编辑器；
  • 丰富实用的CHM制作选项帮助用户制作更加个性化的专业CHM电子书或CHM帮助文件；
  • EasyCHM自动生成输出Alias和Map头文件；
  • EasyCHM自动生成上下文相关的帮助文件（ContextID），适合于制作专业的支持Help Context ID的专业帮助文件；
  • EasyCHM可以保存工程文件，方便企业用户编辑维护文档。
  • 批量更换CHM目录各项的图标；
  • 内嵌CHM反编译工具；

EasyCHM未注册版本的主要限制：

  1. EasyCHM的未注册版本可以制作带任意层级目录的CHM，但是每个CHM的工具栏上都会自动添加一个ABOUT按钮，以提醒用户注册。注册版本不会添加ABOUT按钮。
  2. EasyCHM的未注册版本无法保存CHM的通用工程文件，如*.HHP、*.HHC、*.HHK等，未注册版本的EasyCHM会自动删除*.HHP、*.HHC、*.HHK这几个文件。

注册版本无任何限制。
如果EasyCHM可以为您的工作和学习提供帮助，请注册购买，感谢您给予软件作者的支持。
联系方式:
国华软件站点一: http://www.etextwizard.com
国华软件站点二: http://www.zipghost.com
技术支持信箱: webmaster@etextwizard.com
购买方式:
在线购买:（可提供发票，支持很多种支付方式，包括邮政汇款）
单用户企业版 299元 人民币 ：通过“共享软件注册中心”购买

单用户家庭版 99元 人民币： 通过“共享软件注册中心”购买
直接向作者注册（共3种方式）：
1、招商银行划款:
开户行： 招商银行北京分行双榆树支行
帐 号： 001015570093
户 名： 冯国华
2、中国农业银行金穗卡转帐（注意是卡号）：
金穗卡卡号： 95599 8001 42061 34216
收 款 人： 冯国华
3、中国工商银行牡丹灵通卡转帐：

开户城市：北京
牡丹灵通卡卡号：9558 8202 0000 3186295 （注意是卡号9558820200003186295）
收 款 人： 冯国华

注意事项：
直接向作者注册的用户请在汇出足额的注册费后以EMAIL形式通知作者，同时请尽量提供

  • 汇款日期

  • 汇出城市

  • 您汇到作者哪个帐号？

  • 汇款人姓名

  • 用于接收注册码的信箱（请确保可以接收邮件，最好多提供）

  • 您希望的注册用户名

  • 要注册的软件及套数

您提供的资料详细些会比较方便确认。
作者在确认支付已完成后将会马上发出注册码。
用户在收到注册信后请尽量给软件作者发个类似“已收到注册码”的确认信 - 感谢您的配合！
下载地址:

系统需求: Win98,WinME,WinXP,Windows2000,WinVista
安装支持: 支持安装及卸载


API Help (Java Platform SE 7 b59)

DRAFT ea-b59
PREV NEXT FRAMES NO FRAMES

How This API Document Is Organized

This API (Application Programming Interface) document has pages corresponding to the items in the navigation bar, described as follows.

Overview

The Overview page is the front page of this API document and provides a list of all packages with a summary for each. This page can also contain an overall description of the set of packages.

Package

Each package has a page that contains a list of its classes and interfaces, with a summary for each. This page can contain four categories:

  • Interfaces (italic)
  • Classes
  • Enums
  • Exceptions
  • Errors
  • Annotation Types

Class/Interface

Each class, interface, nested class and nested interface has its own separate page. Each of these pages has three sections consisting of a class/interface description, summary tables, and detailed member descriptions:

  • Class inheritance diagram
  • Direct Subclasses
  • All Known Subinterfaces
  • All Known Implementing Classes
  • Class/interface declaration
  • Class/interface description

  • Nested Class Summary
  • Field Summary
  • Constructor Summary
  • Method Summary

  • Field Detail
  • Constructor Detail
  • Method Detail
Each summary entry contains the first sentence from the detailed description for that item. The summary entries are alphabetical, while the detailed descriptions are in the order they appear in the source code. This preserves the logical groupings established by the programmer.

Annotation Type

Each annotation type has its own separate page with the following sections:

  • Annotation Type declaration
  • Annotation Type description
  • Required Element Summary
  • Optional Element Summary
  • Element Detail

Enum

Each enum has its own separate page with the following sections:

  • Enum declaration
  • Enum description
  • Enum Constant Summary
  • Enum Constant Detail

Use

Each documented package, class and interface has its own Use page. This page describes what packages, classes, methods, constructors and fields use any part of the given class or package. Given a class or interface A, its Use page includes subclasses of A, fields declared as A, methods that return A, and methods and constructors with parameters of type A. You can access this page by first going to the package, class or interface, then clicking on the "Use" link in the navigation bar.

Tree (Class Hierarchy)

There is a Class Hierarchy page for all packages, plus a hierarchy for each package. Each hierarchy page contains a list of classes and a list of interfaces. The classes are organized by inheritance structure starting with java.lang.Object. The interfaces do not inherit from java.lang.Object.
  • When viewing the Overview page, clicking on "Tree" displays the hierarchy for all packages.
  • When viewing a particular package, class or interface page, clicking "Tree" displays the hierarchy for only that package.

Deprecated API

The Deprecated API page lists all of the API that have been deprecated. A deprecated API is not recommended for use, generally due to improvements, and a replacement API is usually given. Deprecated APIs may be removed in future implementations.

Index

The Index contains an alphabetic list of all classes, interfaces, constructors, methods, and fields.

Prev/Next

These links take you to the next or previous class, interface, package, or related page.

Frames/No Frames

These links show and hide the HTML frames. All pages are available with or without frames.

Serialized Form

Each serializable or externalizable class has a description of its serialization fields and methods. This information is of interest to re-implementors, not to developers using the API. While there is no link in the navigation bar, you can get to this information by going to any serialized class and clicking "Serialized Form" in the "See also" section of the class description.

Constant Field Values

The Constant Field Values page lists the static final fields and their values.

This help file applies to API documentation generated using the standard doclet.

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV NEXT FRAMES NO FRAMES


Java Platform SE 7 b59

Frame Alert

This document is designed to be viewed using the frames feature. If you see this message, you are using a non-frame-capable web client.
Link toNon-frame version.


Overview List (Java Platform SE 7 b59)

DRAFT ea-b59
All Classes

Packages
java.applet
java.awt
java.awt.color
java.awt.datatransfer
java.awt.dnd
java.awt.event
java.awt.font
java.awt.geom
java.awt.im
java.awt.im.spi
java.awt.image
java.awt.image.renderable
java.awt.print
java.beans
java.beans.beancontext
java.dyn
java.io
java.lang
java.lang.annotation
java.lang.instrument
java.lang.management
java.lang.ref
java.lang.reflect
java.math
java.net
java.nio
java.nio.channels
java.nio.channels.spi
java.nio.charset
java.nio.charset.spi
java.nio.file
java.nio.file.attribute
java.nio.file.spi
java.rmi
java.rmi.activation
java.rmi.dgc
java.rmi.registry
java.rmi.server
java.security
java.security.acl
java.security.cert
java.security.interfaces
java.security.spec
java.sql
java.text
java.text.spi
java.util
java.util.concurrent
java.util.concurrent.atomic
java.util.concurrent.locks
java.util.jar
java.util.logging
java.util.prefs
java.util.regex
java.util.spi
java.util.zip
javax.accessibility
javax.activation
javax.activity
javax.annotation
javax.annotation.processing
javax.crypto
javax.crypto.interfaces
javax.crypto.spec
javax.imageio
javax.imageio.event
javax.imageio.metadata
javax.imageio.plugins.bmp
javax.imageio.plugins.jpeg
javax.imageio.spi
javax.imageio.stream
javax.jws
javax.jws.soap
javax.lang.model
javax.lang.model.element
javax.lang.model.type
javax.lang.model.util
javax.management
javax.management.event
javax.management.loading
javax.management.modelmbean
javax.management.monitor
javax.management.namespace
javax.management.openmbean
javax.management.relation
javax.management.remote
javax.management.remote.rmi
javax.management.timer
javax.naming
javax.naming.directory
javax.naming.event
javax.naming.ldap
javax.naming.spi
javax.net
javax.net.ssl
javax.print
javax.print.attribute
javax.print.attribute.standard
javax.print.event
javax.rmi
javax.rmi.CORBA
javax.rmi.ssl
javax.script
javax.security.auth
javax.security.auth.callback
javax.security.auth.kerberos
javax.security.auth.login
javax.security.auth.spi
javax.security.auth.x500
javax.security.cert
javax.security.sasl
javax.sound.midi
javax.sound.midi.spi
javax.sound.sampled
javax.sound.sampled.spi
javax.sql
javax.sql.rowset
javax.sql.rowset.serial
javax.sql.rowset.spi
javax.swing
javax.swing.border
javax.swing.colorchooser
javax.swing.event
javax.swing.filechooser
javax.swing.plaf
javax.swing.plaf.basic
javax.swing.plaf.metal
javax.swing.plaf.multi
javax.swing.plaf.synth
javax.swing.table
javax.swing.text
javax.swing.text.html
javax.swing.text.html.parser
javax.swing.text.rtf
javax.swing.tree
javax.swing.undo
javax.tools
javax.transaction
javax.transaction.xa
javax.xml
javax.xml.bind
javax.xml.bind.annotation
javax.xml.bind.annotation.adapters
javax.xml.bind.attachment
javax.xml.bind.helpers
javax.xml.bind.util
javax.xml.crypto
javax.xml.crypto.dom
javax.xml.crypto.dsig
javax.xml.crypto.dsig.dom
javax.xml.crypto.dsig.keyinfo
javax.xml.crypto.dsig.spec
javax.xml.datatype
javax.xml.namespace
javax.xml.parsers
javax.xml.soap
javax.xml.stream
javax.xml.stream.events
javax.xml.stream.util
javax.xml.transform
javax.xml.transform.dom
javax.xml.transform.sax
javax.xml.transform.stax
javax.xml.transform.stream
javax.xml.validation
javax.xml.ws
javax.xml.ws.handler
javax.xml.ws.handler.soap
javax.xml.ws.http
javax.xml.ws.soap
javax.xml.ws.spi
javax.xml.ws.wsaddressing
javax.xml.xpath
org.ietf.jgss
org.omg.CORBA
org.omg.CORBA_2_3
org.omg.CORBA_2_3.portable
org.omg.CORBA.DynAnyPackage
org.omg.CORBA.ORBPackage
org.omg.CORBA.portable
org.omg.CORBA.TypeCodePackage
org.omg.CosNaming
org.omg.CosNaming.NamingContextExtPackage
org.omg.CosNaming.NamingContextPackage
org.omg.Dynamic
org.omg.DynamicAny
org.omg.DynamicAny.DynAnyFactoryPackage
org.omg.DynamicAny.DynAnyPackage
org.omg.IOP
org.omg.IOP.CodecFactoryPackage
org.omg.IOP.CodecPackage
org.omg.Messaging
org.omg.PortableInterceptor
org.omg.PortableInterceptor.ORBInitInfoPackage
org.omg.PortableServer
org.omg.PortableServer.CurrentPackage
org.omg.PortableServer.POAManagerPackage
org.omg.PortableServer.POAPackage
org.omg.PortableServer.portable
org.omg.PortableServer.ServantLocatorPackage
org.omg.SendingContext
org.omg.stub.java.rmi
org.w3c.dom
org.w3c.dom.bootstrap
org.w3c.dom.events
org.w3c.dom.ls
org.xml.sax
org.xml.sax.ext
org.xml.sax.helpers


Class Hierarchy (Java Platform SE 7 b59)

DRAFT ea-b59
PREV NEXT FRAMES NO FRAMES

Hierarchy For All Packages

Package Hierarchies:
java.applet, java.awt, java.awt.color, java.awt.datatransfer, java.awt.dnd, java.awt.event, java.awt.font, java.awt.geom, java.awt.im, java.awt.im.spi, java.awt.image, java.awt.image.renderable, java.awt.print, java.beans, java.beans.beancontext, java.dyn, java.io, java.lang, java.lang.annotation, java.lang.instrument, java.lang.management, java.lang.ref, java.lang.reflect, java.math, java.net, java.nio, java.nio.channels, java.nio.channels.spi, java.nio.charset, java.nio.charset.spi, java.nio.file, java.nio.file.attribute, java.nio.file.spi, java.rmi, java.rmi.activation, java.rmi.dgc, java.rmi.registry, java.rmi.server, java.security, java.security.acl, java.security.cert, java.security.interfaces, java.security.spec, java.sql, java.text, java.text.spi, java.util, java.util.concurrent, java.util.concurrent.atomic, java.util.concurrent.locks, java.util.jar, java.util.logging, java.util.prefs, java.util.regex, java.util.spi, java.util.zip, javax.accessibility, javax.activation, javax.activity, javax.annotation, javax.annotation.processing, javax.crypto, javax.crypto.interfaces, javax.crypto.spec, javax.imageio, javax.imageio.event, javax.imageio.metadata, javax.imageio.plugins.bmp, javax.imageio.plugins.jpeg, javax.imageio.spi, javax.imageio.stream, javax.jws, javax.jws.soap, javax.lang.model, javax.lang.model.element, javax.lang.model.type, javax.lang.model.util, javax.management, javax.management.event, javax.management.loading, javax.management.modelmbean, javax.management.monitor, javax.management.namespace, javax.management.openmbean, javax.management.relation, javax.management.remote, javax.management.remote.rmi, javax.management.timer, javax.naming, javax.naming.directory, javax.naming.event, javax.naming.ldap, javax.naming.spi, javax.net, javax.net.ssl, javax.print, javax.print.attribute, javax.print.attribute.standard, javax.print.event, javax.rmi, javax.rmi.CORBA, javax.rmi.ssl, javax.script, javax.security.auth, javax.security.auth.callback, javax.security.auth.kerberos, javax.security.auth.login, javax.security.auth.spi, javax.security.auth.x500, javax.security.cert, javax.security.sasl, javax.sound.midi, javax.sound.midi.spi, javax.sound.sampled, javax.sound.sampled.spi, javax.sql, javax.sql.rowset, javax.sql.rowset.serial, javax.sql.rowset.spi, javax.swing, javax.swing.border, javax.swing.colorchooser, javax.swing.event, javax.swing.filechooser, javax.swing.plaf, javax.swing.plaf.basic, javax.swing.plaf.metal, javax.swing.plaf.multi, javax.swing.plaf.synth, javax.swing.table, javax.swing.text, javax.swing.text.html, javax.swing.text.html.parser, javax.swing.text.rtf, javax.swing.tree, javax.swing.undo, javax.tools, javax.transaction, javax.transaction.xa, javax.xml, javax.xml.bind, javax.xml.bind.annotation, javax.xml.bind.annotation.adapters, javax.xml.bind.attachment, javax.xml.bind.helpers, javax.xml.bind.util, javax.xml.crypto, javax.xml.crypto.dom, javax.xml.crypto.dsig, javax.xml.crypto.dsig.dom, javax.xml.crypto.dsig.keyinfo, javax.xml.crypto.dsig.spec, javax.xml.datatype, javax.xml.namespace, javax.xml.parsers, javax.xml.soap, javax.xml.stream, javax.xml.stream.events, javax.xml.stream.util, javax.xml.transform, javax.xml.transform.dom, javax.xml.transform.sax, javax.xml.transform.stax, javax.xml.transform.stream, javax.xml.validation, javax.xml.ws, javax.xml.ws.handler, javax.xml.ws.handler.soap, javax.xml.ws.http, javax.xml.ws.soap, javax.xml.ws.spi, javax.xml.ws.wsaddressing, javax.xml.xpath, org.ietf.jgss, org.omg.CORBA, org.omg.CORBA_2_3, org.omg.CORBA_2_3.portable, org.omg.CORBA.DynAnyPackage, org.omg.CORBA.ORBPackage, org.omg.CORBA.portable, org.omg.CORBA.TypeCodePackage, org.omg.CosNaming, org.omg.CosNaming.NamingContextExtPackage, org.omg.CosNaming.NamingContextPackage, org.omg.Dynamic, org.omg.DynamicAny, org.omg.DynamicAny.DynAnyFactoryPackage, org.omg.DynamicAny.DynAnyPackage, org.omg.IOP, org.omg.IOP.CodecFactoryPackage, org.omg.IOP.CodecPackage, org.omg.Messaging, org.omg.PortableInterceptor, org.omg.PortableInterceptor.ORBInitInfoPackage, org.omg.PortableServer, org.omg.PortableServer.CurrentPackage, org.omg.PortableServer.POAManagerPackage, org.omg.PortableServer.POAPackage, org.omg.PortableServer.portable, org.omg.PortableServer.ServantLocatorPackage, org.omg.SendingContext, org.omg.stub.java.rmi, org.w3c.dom, org.w3c.dom.bootstrap, org.w3c.dom.events, org.w3c.dom.ls, org.xml.sax, org.xml.sax.ext, org.xml.sax.helpers

Class Hierarchy

  • java.lang.Object
    • javax.swing.AbstractAction (implements javax.swing.Action, java.lang.Cloneable, java.io.Serializable)
      • javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction
      • javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction
      • javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction
      • javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction
      • javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction
      • javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction
      • javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction
      • javax.swing.plaf.basic.BasicSliderUI.ActionScroller
      • javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction
      • javax.swing.plaf.basic.BasicTreeUI.TreePageAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction
      • javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxAction
      • javax.swing.text.TextAction
        • javax.swing.text.DefaultEditorKit.BeepAction
        • javax.swing.text.DefaultEditorKit.CopyAction
        • javax.swing.text.DefaultEditorKit.CutAction
        • javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction
        • javax.swing.text.DefaultEditorKit.InsertBreakAction
        • javax.swing.text.DefaultEditorKit.InsertContentAction
        • javax.swing.text.DefaultEditorKit.InsertTabAction
        • javax.swing.text.DefaultEditorKit.PasteAction
        • javax.swing.text.StyledEditorKit.StyledTextAction
          • javax.swing.text.html.HTMLEditorKit.HTMLTextAction
            • javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
          • javax.swing.text.StyledEditorKit.AlignmentAction
          • javax.swing.text.StyledEditorKit.BoldAction
          • javax.swing.text.StyledEditorKit.FontFamilyAction
          • javax.swing.text.StyledEditorKit.FontSizeAction
          • javax.swing.text.StyledEditorKit.ForegroundAction
          • javax.swing.text.StyledEditorKit.ItalicAction
          • javax.swing.text.StyledEditorKit.UnderlineAction
    • javax.lang.model.util.AbstractAnnotationValueVisitor6<R,P> (implements javax.lang.model.element.AnnotationValueVisitor<R,P>)
      • javax.lang.model.util.SimpleAnnotationValueVisitor6<R,P>
    • javax.swing.border.AbstractBorder (implements javax.swing.border.Border, java.io.Serializable)
      • javax.swing.plaf.basic.BasicBorders.ButtonBorder (implements javax.swing.plaf.UIResource)
        • javax.swing.plaf.basic.BasicBorders.RadioButtonBorder
        • javax.swing.plaf.basic.BasicBorders.RolloverButtonBorder
        • javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder
      • javax.swing.plaf.basic.BasicBorders.FieldBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.basic.BasicBorders.MarginBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.basic.BasicBorders.MenuBarBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.border.BevelBorder
        • javax.swing.plaf.BorderUIResource.BevelBorderUIResource (implements javax.swing.plaf.UIResource)
        • javax.swing.border.SoftBevelBorder
      • javax.swing.border.CompoundBorder
        • javax.swing.plaf.BorderUIResource.CompoundBorderUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.border.EmptyBorder (implements java.io.Serializable)
        • javax.swing.plaf.BorderUIResource.EmptyBorderUIResource (implements javax.swing.plaf.UIResource)
        • javax.swing.border.MatteBorder
          • javax.swing.plaf.BorderUIResource.MatteBorderUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.border.EtchedBorder
        • javax.swing.plaf.BorderUIResource.EtchedBorderUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.border.LineBorder
        • javax.swing.plaf.BorderUIResource.LineBorderUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.ButtonBorder (implements javax.swing.plaf.UIResource)
        • javax.swing.plaf.metal.MetalBorders.RolloverButtonBorder
        • javax.swing.plaf.metal.MetalBorders.ToggleButtonBorder
      • javax.swing.plaf.metal.MetalBorders.Flush3DBorder (implements javax.swing.plaf.UIResource)
        • javax.swing.plaf.metal.MetalBorders.TextFieldBorder
      • javax.swing.plaf.metal.MetalBorders.InternalFrameBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.MenuBarBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.MenuItemBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.OptionDialogBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.PaletteBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.PopupMenuBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.TableHeaderBorder
      • javax.swing.plaf.metal.MetalBorders.ToolBarBorder (implements javax.swing.SwingConstants, javax.swing.plaf.UIResource)
      • javax.swing.border.TitledBorder
        • javax.swing.plaf.BorderUIResource.TitledBorderUIResource (implements javax.swing.plaf.UIResource)
    • javax.swing.AbstractButton.ButtonChangeListener (implements javax.swing.event.ChangeListener, java.io.Serializable)
    • javax.swing.AbstractCellEditor (implements javax.swing.CellEditor, java.io.Serializable)
      • javax.swing.DefaultCellEditor (implements javax.swing.table.TableCellEditor, javax.swing.tree.TreeCellEditor)
    • java.util.AbstractCollection<E> (implements java.util.Collection<E>)
      • java.util.AbstractList<E> (implements java.util.List<E>)
        • java.util.AbstractSequentialList<E>
          • java.util.LinkedList<E> (implements java.lang.Cloneable, java.util.Deque<E>, java.util.List<E>, java.io.Serializable)
        • java.util.ArrayList<E> (implements java.lang.Cloneable, java.util.List<E>, java.util.RandomAccess, java.io.Serializable)
          • javax.management.AttributeList
          • javax.management.relation.RoleList
          • javax.management.relation.RoleUnresolvedList
        • java.util.Vector<E> (implements java.lang.Cloneable, java.util.List<E>, java.util.RandomAccess, java.io.Serializable)
          • java.util.Stack<E>
      • java.util.AbstractQueue<E> (implements java.util.Queue<E>)
        • java.util.concurrent.ArrayBlockingQueue<E> (implements java.util.concurrent.BlockingQueue<E>, java.io.Serializable)
        • java.util.concurrent.ConcurrentLinkedQueue<E> (implements java.util.Queue<E>, java.io.Serializable)
        • java.util.concurrent.DelayQueue<E> (implements java.util.concurrent.BlockingQueue<E>)
        • java.util.concurrent.LinkedBlockingDeque<E> (implements java.util.concurrent.BlockingDeque<E>, java.io.Serializable)
        • java.util.concurrent.LinkedBlockingQueue<E> (implements java.util.concurrent.BlockingQueue<E>, java.io.Serializable)
        • java.util.concurrent.PriorityBlockingQueue<E> (implements java.util.concurrent.BlockingQueue<E>, java.io.Serializable)
        • java.util.PriorityQueue<E> (implements java.io.Serializable)
        • java.util.concurrent.SynchronousQueue<E> (implements java.util.concurrent.BlockingQueue<E>, java.io.Serializable)
      • java.util.AbstractSet<E> (implements java.util.Set<E>)
        • java.util.concurrent.ConcurrentSkipListSet<E> (implements java.lang.Cloneable, java.util.NavigableSet<E>, java.io.Serializable)
        • java.util.concurrent.CopyOnWriteArraySet<E> (implements java.io.Serializable)
        • java.util.EnumSet<E> (implements java.lang.Cloneable, java.io.Serializable)
        • java.util.HashSet<E> (implements java.lang.Cloneable, java.io.Serializable, java.util.Set<E>)
          • javax.print.attribute.standard.JobStateReasons (implements javax.print.attribute.PrintJobAttribute)
          • java.util.LinkedHashSet<E> (implements java.lang.Cloneable, java.io.Serializable, java.util.Set<E>)
        • java.util.TreeSet<E> (implements java.lang.Cloneable, java.util.NavigableSet<E>, java.io.Serializable)
      • java.util.ArrayDeque<E> (implements java.lang.Cloneable, java.util.Deque<E>, java.io.Serializable)
    • javax.swing.text.AbstractDocument (implements javax.swing.text.Document, java.io.Serializable)
      • javax.swing.text.DefaultStyledDocument (implements javax.swing.text.StyledDocument)
        • javax.swing.text.html.HTMLDocument
      • javax.swing.text.PlainDocument
    • javax.swing.text.AbstractDocument.AbstractElement (implements javax.swing.text.Element, javax.swing.text.MutableAttributeSet, java.io.Serializable, javax.swing.tree.TreeNode)
      • javax.swing.text.AbstractDocument.BranchElement
        • javax.swing.text.DefaultStyledDocument.SectionElement
        • javax.swing.text.html.HTMLDocument.BlockElement
      • javax.swing.text.AbstractDocument.LeafElement
        • javax.swing.text.html.HTMLDocument.RunElement
    • javax.lang.model.util.AbstractElementVisitor6<R,P> (implements javax.lang.model.element.ElementVisitor<R,P>)
      • javax.lang.model.util.ElementScanner6<R,P>
      • javax.lang.model.util.SimpleElementVisitor6<R,P>
        • javax.lang.model.util.ElementKindVisitor6<R,P>
    • java.util.concurrent.AbstractExecutorService (implements java.util.concurrent.ExecutorService)
      • java.util.concurrent.ThreadPoolExecutor
        • java.util.concurrent.ScheduledThreadPoolExecutor (implements java.util.concurrent.ScheduledExecutorService)
    • java.nio.channels.spi.AbstractInterruptibleChannel (implements java.nio.channels.Channel, java.nio.channels.InterruptibleChannel)
      • java.nio.channels.FileChannel (implements java.nio.channels.GatheringByteChannel, java.nio.channels.ScatteringByteChannel, java.nio.channels.SeekableByteChannel)
      • java.nio.channels.SelectableChannel (implements java.nio.channels.Channel)
        • java.nio.channels.spi.AbstractSelectableChannel
          • java.nio.channels.DatagramChannel (implements java.nio.channels.ByteChannel, java.nio.channels.GatheringByteChannel, java.nio.channels.MulticastChannel, java.nio.channels.ScatteringByteChannel)
          • java.nio.channels.Pipe.SinkChannel (implements java.nio.channels.GatheringByteChannel, java.nio.channels.WritableByteChannel)
          • java.nio.channels.Pipe.SourceChannel (implements java.nio.channels.ReadableByteChannel, java.nio.channels.ScatteringByteChannel)
          • java.nio.channels.ServerSocketChannel (implements java.nio.channels.NetworkChannel)
          • java.nio.channels.SocketChannel (implements java.nio.channels.ByteChannel, java.nio.channels.GatheringByteChannel, java.nio.channels.NetworkChannel, java.nio.channels.ScatteringByteChannel)
    • javax.swing.tree.AbstractLayoutCache (implements javax.swing.tree.RowMapper)
      • javax.swing.tree.FixedHeightLayoutCache
      • javax.swing.tree.VariableHeightLayoutCache
    • javax.swing.tree.AbstractLayoutCache.NodeDimensions
      • javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler
    • javax.swing.AbstractListModel (implements javax.swing.ListModel, java.io.Serializable)
      • javax.swing.plaf.basic.BasicDirectoryModel (implements java.beans.PropertyChangeListener)
      • javax.swing.DefaultComboBoxModel (implements javax.swing.MutableComboBoxModel, java.io.Serializable)
      • javax.swing.DefaultListModel
      • javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel (implements javax.swing.ComboBoxModel)
      • javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel (implements javax.swing.ComboBoxModel, java.beans.PropertyChangeListener)
    • java.util.AbstractMap<K,V> (implements java.util.Map<K,V>)
      • java.util.concurrent.ConcurrentHashMap<K,V> (implements java.util.concurrent.ConcurrentMap<K,V>, java.io.Serializable)
      • java.util.concurrent.ConcurrentSkipListMap<K,V> (implements java.lang.Cloneable, java.util.concurrent.ConcurrentNavigableMap<K,V>, java.io.Serializable)
      • java.util.EnumMap<K,V> (implements java.lang.Cloneable, java.io.Serializable)
      • java.util.HashMap<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • java.util.LinkedHashMap<K,V> (implements java.util.Map<K,V>)
        • javax.print.attribute.standard.PrinterStateReasons (implements javax.print.attribute.PrintServiceAttribute)
      • java.util.IdentityHashMap<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
      • java.util.TreeMap<K,V> (implements java.lang.Cloneable, java.util.NavigableMap<K,V>, java.io.Serializable)
      • java.util.WeakHashMap<K,V> (implements java.util.Map<K,V>)
    • java.util.AbstractMap.SimpleEntry<K,V> (implements java.util.Map.Entry<K,V>, java.io.Serializable)
    • java.util.AbstractMap.SimpleImmutableEntry<K,V> (implements java.util.Map.Entry<K,V>, java.io.Serializable)
    • javax.xml.bind.helpers.AbstractMarshallerImpl (implements javax.xml.bind.Marshaller)
    • java.util.concurrent.locks.AbstractOwnableSynchronizer (implements java.io.Serializable)
      • java.util.concurrent.locks.AbstractQueuedLongSynchronizer (implements java.io.Serializable)
      • java.util.concurrent.locks.AbstractQueuedSynchronizer (implements java.io.Serializable)
    • javax.annotation.processing.AbstractProcessor (implements javax.annotation.processing.Processor)
    • java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject (implements java.util.concurrent.locks.Condition, java.io.Serializable)
    • java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject (implements java.util.concurrent.locks.Condition, java.io.Serializable)
    • javax.script.AbstractScriptEngine (implements javax.script.ScriptEngine)
    • javax.swing.AbstractSpinnerModel (implements java.io.Serializable, javax.swing.SpinnerModel)
      • javax.swing.SpinnerDateModel (implements java.io.Serializable)
      • javax.swing.SpinnerListModel (implements java.io.Serializable)
      • javax.swing.SpinnerNumberModel (implements java.io.Serializable)
    • javax.swing.table.AbstractTableModel (implements java.io.Serializable, javax.swing.table.TableModel)
      • javax.swing.table.DefaultTableModel (implements java.io.Serializable)
    • javax.lang.model.util.AbstractTypeVisitor6<R,P> (implements javax.lang.model.type.TypeVisitor<R,P>)
      • javax.lang.model.util.SimpleTypeVisitor6<R,P>
        • javax.lang.model.util.TypeKindVisitor6<R,P>
    • javax.swing.undo.AbstractUndoableEdit (implements java.io.Serializable, javax.swing.undo.UndoableEdit)
      • javax.swing.text.AbstractDocument.ElementEdit (implements javax.swing.event.DocumentEvent.ElementChange)
      • javax.swing.undo.CompoundEdit
        • javax.swing.text.AbstractDocument.DefaultDocumentEvent (implements javax.swing.event.DocumentEvent)
        • javax.swing.undo.UndoManager (implements javax.swing.event.UndoableEditListener)
      • javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit
      • javax.swing.undo.StateEdit
    • javax.xml.bind.helpers.AbstractUnmarshallerImpl (implements javax.xml.bind.Unmarshaller)
    • javax.swing.text.AbstractWriter
      • javax.swing.text.html.HTMLWriter
      • javax.swing.text.html.MinimalHTMLWriter
    • java.security.AccessControlContext
    • java.security.AccessController
    • javax.accessibility.AccessibleAttributeSequence
    • javax.accessibility.AccessibleBundle
      • javax.accessibility.AccessibleRelation
      • javax.accessibility.AccessibleRole
      • javax.accessibility.AccessibleState
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent (implements javax.accessibility.AccessibleComponent, java.io.Serializable)
        • javax.swing.Box.Filler.AccessibleBoxFiller
        • java.awt.Button.AccessibleAWTButton (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleValue)
        • java.awt.Canvas.AccessibleAWTCanvas
        • java.awt.Checkbox.AccessibleAWTCheckbox (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleValue, java.awt.event.ItemListener)
        • java.awt.Choice.AccessibleAWTChoice (implements javax.accessibility.AccessibleAction)
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.Box.AccessibleBox
          • javax.swing.CellRendererPane.AccessibleCellRendererPane
          • javax.swing.JComponent.AccessibleJComponent (implements javax.accessibility.AccessibleExtendedComponent)
            • javax.swing.AbstractButton.AccessibleAbstractButton (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleExtendedComponent, javax.accessibility.AccessibleText, javax.accessibility.AccessibleValue)
              • javax.swing.JButton.AccessibleJButton
              • javax.swing.JMenuItem.AccessibleJMenuItem (implements javax.swing.event.ChangeListener)
                • javax.swing.JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
                • javax.swing.JMenu.AccessibleJMenu (implements javax.accessibility.AccessibleSelection)
                • javax.swing.JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
              • javax.swing.JToggleButton.AccessibleJToggleButton (implements java.awt.event.ItemListener)
                • javax.swing.JCheckBox.AccessibleJCheckBox
                • javax.swing.JRadioButton.AccessibleJRadioButton
            • javax.swing.JColorChooser.AccessibleJColorChooser
            • javax.swing.JComboBox.AccessibleJComboBox (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleSelection)
            • javax.swing.JDesktopPane.AccessibleJDesktopPane
            • javax.swing.JFileChooser.AccessibleJFileChooser
            • javax.swing.JInternalFrame.AccessibleJInternalFrame (implements javax.accessibility.AccessibleValue)
            • javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon (implements javax.accessibility.AccessibleValue)
            • javax.swing.JLabel.AccessibleJLabel (implements javax.accessibility.AccessibleExtendedComponent, javax.accessibility.AccessibleText)
            • javax.swing.JLayeredPane.AccessibleJLayeredPane
            • javax.swing.JList.AccessibleJList (implements javax.accessibility.AccessibleSelection, javax.swing.event.ListDataListener, javax.swing.event.ListSelectionListener, java.beans.PropertyChangeListener)
            • javax.swing.JMenuBar.AccessibleJMenuBar (implements javax.accessibility.AccessibleSelection)
            • javax.swing.JOptionPane.AccessibleJOptionPane
            • javax.swing.JPanel.AccessibleJPanel
            • javax.swing.JPopupMenu.AccessibleJPopupMenu (implements java.beans.PropertyChangeListener)
            • javax.swing.JProgressBar.AccessibleJProgressBar (implements javax.accessibility.AccessibleValue)
            • javax.swing.JRootPane.AccessibleJRootPane
            • javax.swing.JScrollBar.AccessibleJScrollBar (implements javax.accessibility.AccessibleValue)
            • javax.swing.JScrollPane.AccessibleJScrollPane (implements javax.swing.event.ChangeListener, java.beans.PropertyChangeListener)
            • javax.swing.JSeparator.AccessibleJSeparator
            • javax.swing.JSlider.AccessibleJSlider (implements javax.accessibility.AccessibleValue)
            • javax.swing.JSpinner.AccessibleJSpinner (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleEditableText, javax.accessibility.AccessibleText, javax.accessibility.AccessibleValue, javax.swing.event.ChangeListener)
            • javax.swing.JSplitPane.AccessibleJSplitPane (implements javax.accessibility.AccessibleValue)
            • javax.swing.JTabbedPane.AccessibleJTabbedPane (implements javax.accessibility.AccessibleSelection, javax.swing.event.ChangeListener)
            • javax.swing.JTable.AccessibleJTable (implements javax.accessibility.AccessibleExtendedTable, javax.accessibility.AccessibleSelection, javax.swing.event.CellEditorListener, javax.swing.event.ListSelectionListener, java.beans.PropertyChangeListener, javax.swing.event.TableColumnModelListener, javax.swing.event.TableModelListener)
            • javax.swing.table.JTableHeader.AccessibleJTableHeader
            • javax.swing.text.JTextComponent.AccessibleJTextComponent (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleEditableText, javax.accessibility.AccessibleExtendedText, javax.accessibility.AccessibleText, javax.swing.event.CaretListener, javax.swing.event.DocumentListener)
              • javax.swing.JEditorPane.AccessibleJEditorPane
                • javax.swing.JEditorPane.AccessibleJEditorPaneHTML
                • javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport (implements javax.accessibility.AccessibleHypertext)
              • javax.swing.JTextArea.AccessibleJTextArea
              • javax.swing.JTextField.AccessibleJTextField
                • javax.swing.JPasswordField.AccessibleJPasswordField
            • javax.swing.JToolBar.AccessibleJToolBar
            • javax.swing.JToolTip.AccessibleJToolTip
            • javax.swing.JTree.AccessibleJTree (implements javax.accessibility.AccessibleSelection, javax.swing.event.TreeExpansionListener, javax.swing.event.TreeModelListener, javax.swing.event.TreeSelectionListener)
            • javax.swing.JViewport.AccessibleJViewport
          • java.awt.Panel.AccessibleAWTPanel
            • java.applet.Applet.AccessibleApplet
              • javax.swing.JApplet.AccessibleJApplet
          • java.awt.ScrollPane.AccessibleAWTScrollPane
          • java.awt.Window.AccessibleAWTWindow
            • java.awt.Dialog.AccessibleAWTDialog
              • javax.swing.JDialog.AccessibleJDialog
            • java.awt.Frame.AccessibleAWTFrame
              • javax.swing.JFrame.AccessibleJFrame
            • javax.swing.JWindow.AccessibleJWindow
        • java.awt.Label.AccessibleAWTLabel
        • java.awt.List.AccessibleAWTList (implements javax.accessibility.AccessibleSelection, java.awt.event.ActionListener, java.awt.event.ItemListener)
        • java.awt.List.AccessibleAWTList.AccessibleAWTListChild (implements javax.accessibility.Accessible)
        • java.awt.Scrollbar.AccessibleAWTScrollBar (implements javax.accessibility.AccessibleValue)
        • java.awt.TextComponent.AccessibleAWTTextComponent (implements javax.accessibility.AccessibleText, java.awt.event.TextListener)
          • java.awt.TextArea.AccessibleAWTTextArea
          • java.awt.TextField.AccessibleAWTTextField
      • javax.swing.ImageIcon.AccessibleImageIcon (implements javax.accessibility.AccessibleIcon, java.io.Serializable)
      • javax.swing.JList.AccessibleJList.AccessibleJListChild (implements javax.accessibility.Accessible, javax.accessibility.AccessibleComponent)
      • javax.swing.JTable.AccessibleJTable.AccessibleJTableCell (implements javax.accessibility.Accessible, javax.accessibility.AccessibleComponent)
      • javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry (implements javax.accessibility.Accessible, javax.accessibility.AccessibleComponent)
      • javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode (implements javax.accessibility.Accessible, javax.accessibility.AccessibleAction, javax.accessibility.AccessibleComponent, javax.accessibility.AccessibleSelection)
      • java.awt.MenuComponent.AccessibleAWTMenuComponent (implements javax.accessibility.AccessibleComponent, javax.accessibility.AccessibleSelection, java.io.Serializable)
        • java.awt.MenuBar.AccessibleAWTMenuBar
        • java.awt.MenuItem.AccessibleAWTMenuItem (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleValue)
          • java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleValue)
          • java.awt.Menu.AccessibleAWTMenu
            • java.awt.PopupMenu.AccessibleAWTPopupMenu
      • javax.swing.ProgressMonitor.AccessibleProgressMonitor (implements javax.accessibility.AccessibleText, javax.swing.event.ChangeListener, java.beans.PropertyChangeListener)
    • javax.accessibility.AccessibleHyperlink (implements javax.accessibility.AccessibleAction)
      • javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
    • java.lang.reflect.AccessibleObject (implements java.lang.reflect.AnnotatedElement)
      • java.lang.reflect.Constructor<T> (implements java.lang.reflect.GenericDeclaration, java.lang.reflect.Member)
      • java.lang.reflect.Field (implements java.lang.reflect.Member)
      • java.lang.reflect.Method (implements java.lang.reflect.GenericDeclaration, java.lang.reflect.Member)
    • javax.accessibility.AccessibleRelationSet
    • javax.accessibility.AccessibleStateSet
    • javax.accessibility.AccessibleTextSequence
    • java.nio.file.attribute.AclEntry
    • java.nio.file.attribute.AclEntry.Builder
    • javax.swing.ActionMap (implements java.io.Serializable)
      • javax.swing.plaf.ActionMapUIResource (implements javax.swing.plaf.UIResource)
    • java.rmi.activation.ActivationDesc (implements java.io.Serializable)
    • java.rmi.activation.ActivationGroupDesc (implements java.io.Serializable)
    • java.rmi.activation.ActivationGroupDesc.CommandEnvironment (implements java.io.Serializable)
    • java.rmi.activation.ActivationGroupID (implements java.io.Serializable)
    • java.rmi.activation.ActivationID (implements java.io.Serializable)
    • org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper
    • org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper
    • org.omg.PortableInterceptor.AdapterManagerIdHelper
    • org.omg.PortableInterceptor.AdapterNameHelper
    • org.omg.PortableServer.POAPackage.AdapterNonExistentHelper
    • org.omg.PortableInterceptor.AdapterStateHelper
    • org.omg.CosNaming.NamingContextExtPackage.AddressHelper
    • java.util.zip.Adler32 (implements java.util.zip.Checksum)
    • java.awt.geom.AffineTransform (implements java.lang.Cloneable, java.io.Serializable)
    • java.awt.image.AffineTransformOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • java.security.AlgorithmParameterGenerator
    • java.security.AlgorithmParameterGeneratorSpi
    • java.security.AlgorithmParameters
    • java.security.AlgorithmParametersSpi
    • java.awt.AlphaComposite (implements java.awt.Composite)
    • org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper
    • org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder (implements org.omg.CORBA.portable.Streamable)
    • java.text.Annotation
    • org.omg.CORBA.Any (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.AnyHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.AnySeqHelper
    • org.omg.DynamicAny.AnySeqHelper
    • org.omg.CORBA.AnySeqHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.security.auth.login.AppConfigurationEntry
    • javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag
    • java.awt.geom.Area (implements java.lang.Cloneable, java.awt.Shape)
    • java.lang.reflect.Array
    • java.util.Arrays
    • javax.swing.text.AsyncBoxView.ChildLocator
    • javax.swing.text.AsyncBoxView.ChildState (implements java.lang.Runnable)
    • java.nio.channels.AsynchronousChannelGroup
    • java.nio.channels.spi.AsynchronousChannelProvider
    • java.nio.channels.AsynchronousDatagramChannel (implements java.nio.channels.AsynchronousByteChannel, java.nio.channels.MulticastChannel)
    • java.nio.channels.AsynchronousFileChannel (implements java.nio.channels.AsynchronousChannel)
    • java.nio.channels.AsynchronousServerSocketChannel (implements java.nio.channels.AsynchronousChannel, java.nio.channels.NetworkChannel)
    • java.nio.channels.AsynchronousSocketChannel (implements java.nio.channels.AsynchronousByteChannel, java.nio.channels.NetworkChannel)
    • java.util.concurrent.atomic.AtomicBoolean (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicIntegerArray (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicIntegerFieldUpdater<T>
    • java.util.concurrent.atomic.AtomicLongArray (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicLongFieldUpdater<T>
    • java.util.concurrent.atomic.AtomicMarkableReference<V>
    • java.util.concurrent.atomic.AtomicReference<V> (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicReferenceArray<E> (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicReferenceFieldUpdater<T,V>
    • java.util.concurrent.atomic.AtomicStampedReference<V>
    • javax.xml.bind.attachment.AttachmentMarshaller
    • javax.xml.soap.AttachmentPart
    • javax.xml.bind.attachment.AttachmentUnmarshaller
    • javax.management.Attribute (implements java.io.Serializable)
    • javax.management.AttributeChangeNotificationFilter (implements javax.management.NotificationFilter)
    • java.text.AttributedCharacterIterator.Attribute (implements java.io.Serializable)
      • java.text.Format.Field
        • java.text.DateFormat.Field
        • java.text.MessageFormat.Field
        • java.text.NumberFormat.Field
      • java.awt.font.TextAttribute
    • java.text.AttributedString
    • javax.swing.text.html.parser.AttributeList (implements javax.swing.text.html.parser.DTDConstants, java.io.Serializable)
    • org.xml.sax.helpers.AttributeListImpl (implements org.xml.sax.AttributeList)
    • java.nio.file.attribute.Attributes
    • java.util.jar.Attributes (implements java.lang.Cloneable, java.util.Map<K,V>)
    • java.util.jar.Attributes.Name
    • javax.print.attribute.AttributeSetUtilities
    • org.xml.sax.helpers.AttributesImpl (implements org.xml.sax.Attributes)
      • org.xml.sax.ext.Attributes2Impl (implements org.xml.sax.ext.Attributes2)
    • javax.management.AttributeValueExp (implements javax.management.ValueExp)
    • javax.sound.sampled.AudioFileFormat
    • javax.sound.sampled.AudioFileFormat.Type
    • javax.sound.sampled.spi.AudioFileReader
    • javax.sound.sampled.spi.AudioFileWriter
    • javax.sound.sampled.AudioFormat
    • javax.sound.sampled.AudioFormat.Encoding
    • javax.sound.sampled.AudioSystem
    • java.net.Authenticator
    • javax.security.sasl.AuthorizeCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • java.awt.AWTEventMulticaster (implements java.awt.event.ActionListener, java.awt.event.AdjustmentListener, java.awt.event.ComponentListener, java.awt.event.ContainerListener, java.awt.event.FocusListener, java.awt.event.HierarchyBoundsListener, java.awt.event.HierarchyListener, java.awt.event.InputMethodListener, java.awt.event.ItemListener, java.awt.event.KeyListener, java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.awt.event.MouseWheelListener, java.awt.event.TextListener, java.awt.event.WindowFocusListener, java.awt.event.WindowListener, java.awt.event.WindowStateListener)
    • java.awt.AWTKeyStroke (implements java.io.Serializable)
      • javax.swing.KeyStroke
    • java.awt.image.BandCombineOp (implements java.awt.image.RasterOp)
    • javax.sql.rowset.BaseRowSet (implements java.lang.Cloneable, java.io.Serializable)
    • javax.naming.directory.BasicAttribute (implements javax.naming.directory.Attribute)
    • javax.naming.directory.BasicAttributes (implements javax.naming.directory.Attributes)
    • javax.swing.plaf.basic.BasicBorders
    • javax.swing.plaf.basic.BasicBorders.SplitPaneBorder (implements javax.swing.border.Border, javax.swing.plaf.UIResource)
    • javax.swing.plaf.basic.BasicButtonListener (implements javax.swing.event.ChangeListener, java.awt.event.FocusListener, java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicColorChooserUI.PropertyHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicComboBoxEditor (implements javax.swing.ComboBoxEditor, java.awt.event.FocusListener)
      • javax.swing.plaf.basic.BasicComboBoxEditor.UIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalComboBoxEditor
        • javax.swing.plaf.metal.MetalComboBoxEditor.UIResource (implements javax.swing.plaf.UIResource)
    • javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager (implements java.awt.LayoutManager)
      • javax.swing.plaf.metal.MetalComboBoxUI.MetalComboBoxLayoutManager
    • javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler (implements java.awt.event.ItemListener)
    • javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler (implements javax.swing.event.ListDataListener)
    • javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
      • javax.swing.plaf.metal.MetalComboBoxUI.MetalPropertyChangeListener
    • javax.swing.plaf.basic.BasicComboPopup.ItemHandler (implements java.awt.event.ItemListener)
    • javax.swing.plaf.basic.BasicComboPopup.ListDataHandler (implements javax.swing.event.ListDataListener)
    • javax.swing.plaf.basic.BasicComboPopup.ListSelectionHandler (implements javax.swing.event.ListSelectionListener)
    • javax.swing.plaf.basic.BasicComboPopup.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.naming.ldap.BasicControl (implements javax.naming.ldap.Control)
      • javax.naming.ldap.ManageReferralControl
      • javax.naming.ldap.PagedResultsControl
      • javax.naming.ldap.PagedResultsResponseControl
      • javax.naming.ldap.SortControl
      • javax.naming.ldap.SortResponseControl
    • javax.swing.plaf.basic.BasicFileChooserUI.SelectionListener (implements javax.swing.event.ListSelectionListener)
    • javax.swing.plaf.basic.BasicGraphicsUtils
    • javax.swing.plaf.basic.BasicHTML
    • javax.swing.plaf.basic.BasicIconFactory (implements java.io.Serializable)
    • javax.swing.plaf.basic.BasicInternalFrameTitlePane.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener (implements javax.swing.event.InternalFrameListener)
    • javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler (implements java.awt.event.ComponentListener)
    • javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicInternalFrameUI.InternalFramePropertyChangeListener (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicListUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicListUI.ListDataHandler (implements javax.swing.event.ListDataListener)
    • javax.swing.plaf.basic.BasicListUI.ListSelectionHandler (implements javax.swing.event.ListSelectionListener)
    • javax.swing.plaf.basic.BasicListUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicListUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicMenuUI.ChangeHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicOptionPaneUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicProgressBarUI.ChangeHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicScrollBarUI.ModelListener (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicScrollBarUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.HSBChangeListener (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.MouseWheelHandler (implements java.awt.event.MouseWheelListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.ViewportChangeHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.VSBChangeListener (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicSliderUI.ChangeHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicSliderUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
      • javax.swing.plaf.metal.MetalSliderUI.MetalPropertyListener
    • javax.swing.plaf.basic.BasicSliderUI.ScrollListener (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
      • javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController
    • javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager (implements java.awt.LayoutManager2)
      • javax.swing.plaf.basic.BasicSplitPaneUI.BasicVerticalLayoutManager
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.PropertyHandler (implements java.beans.PropertyChangeListener)
    • java.awt.BasicStroke (implements java.awt.Stroke)
    • javax.swing.plaf.basic.BasicTabbedPaneUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout (implements java.awt.LayoutManager)
      • javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout
    • javax.swing.plaf.basic.BasicTabbedPaneUI.TabSelectionHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicTableUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicTableUI.KeyHandler (implements java.awt.event.KeyListener)
    • javax.swing.plaf.basic.BasicTableUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicToolBarUI.DockingListener (implements javax.swing.event.MouseInputListener)
      • javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener
    • javax.swing.plaf.basic.BasicToolBarUI.PropertyListener (implements java.beans.PropertyChangeListener)
      • javax.swing.plaf.metal.MetalToolBarUI.MetalRolloverListener
    • javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener (implements java.awt.event.ContainerListener)
      • javax.swing.plaf.metal.MetalToolBarUI.MetalContainerListener
    • javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler (implements javax.swing.event.CellEditorListener)
    • javax.swing.plaf.basic.BasicTreeUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicTreeUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicTreeUI.SelectionModelPropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler (implements javax.swing.event.TreeExpansionListener)
    • javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler (implements javax.swing.event.TreeModelListener)
    • javax.swing.plaf.basic.BasicTreeUI.TreeSelectionHandler (implements javax.swing.event.TreeSelectionListener)
    • java.beans.beancontext.BeanContextChildSupport (implements java.beans.beancontext.BeanContextChild, java.beans.beancontext.BeanContextServicesListener, java.io.Serializable)
      • java.beans.beancontext.BeanContextSupport (implements java.beans.beancontext.BeanContext, java.beans.PropertyChangeListener, java.io.Serializable, java.beans.VetoableChangeListener)
        • java.beans.beancontext.BeanContextServicesSupport (implements java.beans.beancontext.BeanContextServices)
    • java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider (implements java.beans.beancontext.BeanContextServiceProvider, java.beans.beancontext.BeanContextServiceRevokedListener)
    • java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider (implements java.io.Serializable)
    • java.beans.beancontext.BeanContextSupport.BCSChild (implements java.io.Serializable)
      • java.beans.beancontext.BeanContextServicesSupport.BCSSChild
    • java.beans.beancontext.BeanContextSupport.BCSIterator (implements java.util.Iterator<E>)
    • java.beans.Beans
    • java.text.Bidi
    • javax.xml.bind.Binder<XmlNode>
    • org.omg.CosNaming.Binding (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.BindingHelper
    • org.omg.CosNaming.BindingHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.BindingIteratorHelper
    • org.omg.CosNaming.BindingIteratorHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.BindingListHelper
    • org.omg.CosNaming.BindingListHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.BindingType (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.BindingTypeHelper
    • org.omg.CosNaming.BindingTypeHolder (implements org.omg.CORBA.portable.Streamable)
    • java.util.BitSet (implements java.lang.Cloneable, java.io.Serializable)
    • java.awt.print.Book (implements java.awt.print.Pageable)
    • java.lang.Boolean (implements java.lang.Comparable<T>, java.io.Serializable)
    • org.omg.CORBA.BooleanHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.BooleanSeqHelper
    • org.omg.CORBA.BooleanSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.swing.BorderFactory
    • java.awt.BorderLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • javax.swing.plaf.BorderUIResource (implements javax.swing.border.Border, java.io.Serializable, javax.swing.plaf.UIResource)
    • javax.swing.BoxLayout (implements java.awt.LayoutManager2, java.io.Serializable)
      • javax.swing.plaf.basic.DefaultMenuLayout (implements javax.swing.plaf.UIResource)
    • java.text.BreakIterator (implements java.lang.Cloneable)
    • java.nio.Buffer
      • java.nio.ByteBuffer (implements java.lang.Comparable<T>)
        • java.nio.MappedByteBuffer
      • java.nio.CharBuffer (implements java.lang.Appendable, java.lang.CharSequence, java.lang.Comparable<T>, java.lang.Readable)
      • java.nio.DoubleBuffer (implements java.lang.Comparable<T>)
      • java.nio.FloatBuffer (implements java.lang.Comparable<T>)
      • java.nio.IntBuffer (implements java.lang.Comparable<T>)
      • java.nio.LongBuffer (implements java.lang.Comparable<T>)
      • java.nio.ShortBuffer (implements java.lang.Comparable<T>)
    • java.awt.BufferCapabilities (implements java.lang.Cloneable)
    • java.awt.BufferCapabilities.FlipContents
    • java.awt.image.BufferStrategy
      • java.awt.Component.BltBufferStrategy
      • java.awt.Component.FlipBufferStrategy
    • javax.swing.ButtonGroup (implements java.io.Serializable)
    • org.omg.CORBA.ByteHolder (implements org.omg.CORBA.portable.Streamable)
    • java.nio.ByteOrder
    • java.net.CacheRequest
    • java.net.CacheResponse
      • java.net.SecureCacheResponse
    • java.util.Calendar (implements java.lang.Cloneable, java.lang.Comparable<T>, java.io.Serializable)
      • java.util.GregorianCalendar
    • java.dyn.CallSite
    • org.omg.CosNaming.NamingContextPackage.CannotProceedHelper
    • org.omg.CosNaming.NamingContextPackage.CannotProceedHolder (implements org.omg.CORBA.portable.Streamable)
    • java.awt.CardLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • java.security.cert.Certificate (implements java.io.Serializable)
      • java.security.cert.X509Certificate (implements java.security.cert.X509Extension)
    • javax.security.cert.Certificate
      • javax.security.cert.X509Certificate
    • java.security.cert.Certificate.CertificateRep (implements java.io.Serializable)
    • java.security.cert.CertificateFactory
    • java.security.cert.CertificateFactorySpi
    • java.security.cert.CertPath (implements java.io.Serializable)
    • java.security.cert.CertPath.CertPathRep (implements java.io.Serializable)
    • java.security.cert.CertPathBuilder
    • java.security.cert.CertPathBuilderSpi
    • javax.net.ssl.CertPathTrustManagerParameters (implements javax.net.ssl.ManagerFactoryParameters)
    • java.security.cert.CertPathValidator
    • java.security.cert.CertPathValidatorSpi
    • java.security.cert.CertStore
    • java.security.cert.CertStoreSpi
    • org.ietf.jgss.ChannelBinding
    • java.nio.channels.Channels
    • java.lang.Character (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.lang.Character.Subset
      • java.lang.Character.UnicodeBlock
      • java.awt.im.InputSubset
    • org.omg.CORBA.CharHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.CharSeqHelper
    • org.omg.CORBA.CharSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • java.nio.charset.Charset (implements java.lang.Comparable<T>)
    • java.nio.charset.CharsetDecoder
    • java.nio.charset.CharsetEncoder
    • java.nio.charset.spi.CharsetProvider
    • java.awt.CheckboxGroup (implements java.io.Serializable)
    • javax.security.auth.callback.ChoiceCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
      • javax.security.sasl.RealmChoiceCallback
    • javax.crypto.Cipher
      • javax.crypto.NullCipher
    • javax.crypto.CipherSpi
    • java.lang.Class<T> (implements java.lang.reflect.AnnotatedElement, java.lang.reflect.GenericDeclaration, java.io.Serializable, java.lang.reflect.Type)
    • java.lang.instrument.ClassDefinition
    • javax.rmi.CORBA.ClassDesc (implements java.io.Serializable)
    • java.lang.ClassLoader
      • java.security.SecureClassLoader
        • java.net.URLClassLoader (implements java.io.Closeable)
          • javax.management.loading.MLet (implements java.io.Externalizable, javax.management.MBeanRegistration, javax.management.loading.MLetMBean)
            • javax.management.loading.PrivateMLet (implements javax.management.loading.PrivateClassLoader)
    • javax.management.ClientContext
    • java.awt.datatransfer.Clipboard
    • org.omg.IOP.CodecFactoryHelper
    • java.nio.charset.CoderResult
    • java.security.CodeSigner (implements java.io.Serializable)
    • java.security.CodeSource (implements java.io.Serializable)
    • java.nio.charset.CodingErrorAction
    • java.text.CollationElementIterator
    • java.text.CollationKey (implements java.lang.Comparable<T>)
    • java.text.Collator (implements java.lang.Cloneable, java.util.Comparator<T>)
      • java.text.RuleBasedCollator
    • java.security.cert.CollectionCertStoreParameters (implements java.security.cert.CertStoreParameters)
    • java.util.Collections
    • java.awt.Color (implements java.awt.Paint, java.io.Serializable)
      • javax.swing.plaf.ColorUIResource (implements javax.swing.plaf.UIResource)
      • java.awt.SystemColor (implements java.io.Serializable)
    • javax.swing.colorchooser.ColorChooserComponentFactory
    • java.awt.image.ColorConvertOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • java.awt.image.ColorModel (implements java.awt.Transparency)
      • java.awt.image.ComponentColorModel
      • java.awt.image.IndexColorModel
      • java.awt.image.PackedColorModel
        • java.awt.image.DirectColorModel
    • java.awt.color.ColorSpace (implements java.io.Serializable)
      • java.awt.color.ICC_ColorSpace
    • javax.swing.plaf.synth.ColorType
    • javax.activation.CommandInfo
    • javax.activation.CommandMap
      • javax.activation.MailcapCommandMap
    • javax.script.CompiledScript
    • java.lang.Compiler
    • javax.annotation.processing.Completions
    • org.omg.CORBA.CompletionStatus (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.CompletionStatusHelper
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Button (implements javax.accessibility.Accessible)
      • java.awt.Canvas (implements javax.accessibility.Accessible)
      • java.awt.Checkbox (implements javax.accessibility.Accessible, java.awt.ItemSelectable)
      • java.awt.Choice (implements javax.accessibility.Accessible, java.awt.ItemSelectable)
      • java.awt.Container
        • javax.swing.plaf.basic.BasicSplitPaneDivider (implements java.beans.PropertyChangeListener)
        • javax.swing.CellRendererPane (implements javax.accessibility.Accessible)
        • javax.swing.tree.DefaultTreeCellEditor.EditorContainer
        • javax.swing.JComponent (implements java.io.Serializable)
          • javax.swing.AbstractButton (implements java.awt.ItemSelectable, javax.swing.SwingConstants)
            • javax.swing.JButton (implements javax.accessibility.Accessible)
              • javax.swing.plaf.basic.BasicArrowButton (implements javax.swing.SwingConstants)
                • javax.swing.plaf.metal.MetalScrollButton
              • javax.swing.plaf.metal.MetalComboBoxButton
            • javax.swing.JMenuItem (implements javax.accessibility.Accessible, javax.swing.MenuElement)
              • javax.swing.JCheckBoxMenuItem (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
              • javax.swing.JMenu (implements javax.accessibility.Accessible, javax.swing.MenuElement)
              • javax.swing.JRadioButtonMenuItem (implements javax.accessibility.Accessible)
            • javax.swing.JToggleButton (implements javax.accessibility.Accessible)
              • javax.swing.JCheckBox (implements javax.accessibility.Accessible)
              • javax.swing.JRadioButton (implements javax.accessibility.Accessible)
          • javax.swing.plaf.basic.BasicInternalFrameTitlePane
            • javax.swing.plaf.metal.MetalInternalFrameTitlePane
          • javax.swing.Box (implements javax.accessibility.Accessible)
          • javax.swing.Box.Filler (implements javax.accessibility.Accessible)
          • javax.swing.JColorChooser (implements javax.accessibility.Accessible)
          • javax.swing.JComboBox (implements javax.accessibility.Accessible, java.awt.event.ActionListener, java.awt.ItemSelectable, javax.swing.event.ListDataListener)
          • javax.swing.JFileChooser (implements javax.accessibility.Accessible)
          • javax.swing.JInternalFrame (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer, javax.swing.WindowConstants)
          • javax.swing.JInternalFrame.JDesktopIcon (implements javax.accessibility.Accessible)
          • javax.swing.JLabel (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
            • javax.swing.plaf.basic.BasicComboBoxRenderer (implements javax.swing.ListCellRenderer, java.io.Serializable)
              • javax.swing.plaf.basic.BasicComboBoxRenderer.UIResource (implements javax.swing.plaf.UIResource)
            • javax.swing.DefaultListCellRenderer (implements javax.swing.ListCellRenderer, java.io.Serializable)
              • javax.swing.DefaultListCellRenderer.UIResource (implements javax.swing.plaf.UIResource)
              • javax.swing.plaf.metal.MetalFileChooserUI.FileRenderer
              • javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxRenderer
            • javax.swing.table.DefaultTableCellRenderer (implements java.io.Serializable, javax.swing.table.TableCellRenderer)
              • javax.swing.table.DefaultTableCellRenderer.UIResource (implements javax.swing.plaf.UIResource)
            • javax.swing.tree.DefaultTreeCellRenderer (implements javax.swing.tree.TreeCellRenderer)
          • javax.swing.JLayeredPane (implements javax.accessibility.Accessible)
            • javax.swing.JDesktopPane (implements javax.accessibility.Accessible)
          • javax.swing.JList (implements javax.accessibility.Accessible, javax.swing.Scrollable)
          • javax.swing.JMenuBar (implements javax.accessibility.Accessible, javax.swing.MenuElement)
            • javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar
          • javax.swing.JOptionPane (implements javax.accessibility.Accessible)
          • javax.swing.JPanel (implements javax.accessibility.Accessible)
            • javax.swing.colorchooser.AbstractColorChooserPanel
            • javax.swing.JSpinner.DefaultEditor (implements javax.swing.event.ChangeListener, java.awt.LayoutManager, java.beans.PropertyChangeListener)
              • javax.swing.JSpinner.DateEditor
              • javax.swing.JSpinner.ListEditor
              • javax.swing.JSpinner.NumberEditor
          • javax.swing.JPopupMenu (implements javax.accessibility.Accessible, javax.swing.MenuElement)
            • javax.swing.plaf.basic.BasicComboPopup (implements javax.swing.plaf.basic.ComboPopup)
              • javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup
          • javax.swing.JProgressBar (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
          • javax.swing.JRootPane (implements javax.accessibility.Accessible)
          • javax.swing.JScrollBar (implements javax.accessibility.Accessible, java.awt.Adjustable)
            • javax.swing.JScrollPane.ScrollBar (implements javax.swing.plaf.UIResource)
          • javax.swing.JScrollPane (implements javax.accessibility.Accessible, javax.swing.ScrollPaneConstants)
          • javax.swing.JSeparator (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
            • javax.swing.JPopupMenu.Separator
            • javax.swing.JToolBar.Separator
          • javax.swing.JSlider (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
          • javax.swing.JSpinner (implements javax.accessibility.Accessible)
          • javax.swing.JSplitPane (implements javax.accessibility.Accessible)
          • javax.swing.JTabbedPane (implements javax.accessibility.Accessible, java.io.Serializable, javax.swing.SwingConstants)
          • javax.swing.JTable (implements javax.accessibility.Accessible, javax.swing.event.CellEditorListener, javax.swing.event.ListSelectionListener, javax.swing.event.RowSorterListener, javax.swing.Scrollable, javax.swing.event.TableColumnModelListener, javax.swing.event.TableModelListener)
          • javax.swing.table.JTableHeader (implements javax.accessibility.Accessible, javax.swing.event.TableColumnModelListener)
          • javax.swing.text.JTextComponent (implements javax.accessibility.Accessible, javax.swing.Scrollable)
            • javax.swing.JEditorPane
              • javax.swing.JTextPane
            • javax.swing.JTextArea
            • javax.swing.JTextField (implements javax.swing.SwingConstants)
              • javax.swing.tree.DefaultTreeCellEditor.DefaultTextField
              • javax.swing.JFormattedTextField
              • javax.swing.JPasswordField
          • javax.swing.JToolBar (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
          • javax.swing.JToolTip (implements javax.accessibility.Accessible)
          • javax.swing.JTree (implements javax.accessibility.Accessible, javax.swing.Scrollable)
          • javax.swing.JViewport (implements javax.accessibility.Accessible)
        • java.awt.Panel (implements javax.accessibility.Accessible)
          • java.applet.Applet
            • javax.swing.JApplet (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer)
        • java.awt.ScrollPane (implements javax.accessibility.Accessible)
        • java.awt.Window (implements javax.accessibility.Accessible)
          • javax.swing.plaf.basic.BasicToolBarUI.DragWindow
          • java.awt.Dialog
            • java.awt.FileDialog
            • javax.swing.JDialog (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer, javax.swing.WindowConstants)
          • java.awt.Frame (implements java.awt.MenuContainer)
            • javax.swing.JFrame (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer, javax.swing.WindowConstants)
          • javax.swing.JWindow (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer)
      • java.awt.Label (implements javax.accessibility.Accessible)
      • java.awt.List (implements javax.accessibility.Accessible, java.awt.ItemSelectable)
      • java.awt.Scrollbar (implements javax.accessibility.Accessible, java.awt.Adjustable)
      • java.awt.TextComponent (implements javax.accessibility.Accessible)
        • java.awt.TextArea
        • java.awt.TextField
    • java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler (implements java.awt.event.ComponentListener)
    • java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler (implements java.awt.event.FocusListener)
    • java.awt.event.ComponentAdapter (implements java.awt.event.ComponentListener)
      • javax.swing.plaf.basic.BasicSliderUI.ComponentHandler
      • javax.swing.plaf.basic.BasicTreeUI.ComponentHandler (implements java.awt.event.ActionListener)
      • javax.swing.JViewport.ViewListener (implements java.io.Serializable)
    • org.omg.IOP.ComponentIdHelper
    • java.awt.ComponentOrientation (implements java.io.Serializable)
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.basic.BasicButtonUI
          • javax.swing.plaf.basic.BasicToggleButtonUI
            • javax.swing.plaf.basic.BasicRadioButtonUI
              • javax.swing.plaf.basic.BasicCheckBoxUI
              • javax.swing.plaf.metal.MetalRadioButtonUI
                • javax.swing.plaf.metal.MetalCheckBoxUI
            • javax.swing.plaf.metal.MetalToggleButtonUI
          • javax.swing.plaf.metal.MetalButtonUI
        • javax.swing.plaf.MenuItemUI
          • javax.swing.plaf.basic.BasicMenuItemUI
            • javax.swing.plaf.basic.BasicCheckBoxMenuItemUI
            • javax.swing.plaf.basic.BasicMenuUI
            • javax.swing.plaf.basic.BasicRadioButtonMenuItemUI
          • javax.swing.plaf.multi.MultiMenuItemUI
        • javax.swing.plaf.multi.MultiButtonUI
      • javax.swing.plaf.ColorChooserUI
        • javax.swing.plaf.basic.BasicColorChooserUI
        • javax.swing.plaf.multi.MultiColorChooserUI
      • javax.swing.plaf.ComboBoxUI
        • javax.swing.plaf.basic.BasicComboBoxUI
          • javax.swing.plaf.metal.MetalComboBoxUI
        • javax.swing.plaf.multi.MultiComboBoxUI
      • javax.swing.plaf.DesktopIconUI
        • javax.swing.plaf.basic.BasicDesktopIconUI
          • javax.swing.plaf.metal.MetalDesktopIconUI
        • javax.swing.plaf.multi.MultiDesktopIconUI
      • javax.swing.plaf.DesktopPaneUI
        • javax.swing.plaf.basic.BasicDesktopPaneUI
        • javax.swing.plaf.multi.MultiDesktopPaneUI
      • javax.swing.plaf.FileChooserUI
        • javax.swing.plaf.basic.BasicFileChooserUI
          • javax.swing.plaf.metal.MetalFileChooserUI
        • javax.swing.plaf.multi.MultiFileChooserUI
      • javax.swing.plaf.InternalFrameUI
        • javax.swing.plaf.basic.BasicInternalFrameUI
          • javax.swing.plaf.metal.MetalInternalFrameUI
        • javax.swing.plaf.multi.MultiInternalFrameUI
      • javax.swing.plaf.LabelUI
        • javax.swing.plaf.basic.BasicLabelUI (implements java.beans.PropertyChangeListener)
          • javax.swing.plaf.metal.MetalLabelUI
        • javax.swing.plaf.multi.MultiLabelUI
      • javax.swing.plaf.ListUI
        • javax.swing.plaf.basic.BasicListUI
        • javax.swing.plaf.multi.MultiListUI
      • javax.swing.plaf.MenuBarUI
        • javax.swing.plaf.basic.BasicMenuBarUI
          • javax.swing.plaf.metal.MetalMenuBarUI
        • javax.swing.plaf.multi.MultiMenuBarUI
      • javax.swing.plaf.OptionPaneUI
        • javax.swing.plaf.basic.BasicOptionPaneUI
        • javax.swing.plaf.multi.MultiOptionPaneUI
      • javax.swing.plaf.PanelUI
        • javax.swing.plaf.basic.BasicPanelUI
        • javax.swing.plaf.multi.MultiPanelUI
      • javax.swing.plaf.PopupMenuUI
        • javax.swing.plaf.basic.BasicPopupMenuUI
        • javax.swing.plaf.multi.MultiPopupMenuUI
      • javax.swing.plaf.ProgressBarUI
        • javax.swing.plaf.basic.BasicProgressBarUI
          • javax.swing.plaf.metal.MetalProgressBarUI
        • javax.swing.plaf.multi.MultiProgressBarUI
      • javax.swing.plaf.RootPaneUI
        • javax.swing.plaf.basic.BasicRootPaneUI (implements java.beans.PropertyChangeListener)
          • javax.swing.plaf.metal.MetalRootPaneUI
        • javax.swing.plaf.multi.MultiRootPaneUI
      • javax.swing.plaf.ScrollBarUI
        • javax.swing.plaf.basic.BasicScrollBarUI (implements java.awt.LayoutManager, javax.swing.SwingConstants)
          • javax.swing.plaf.metal.MetalScrollBarUI
        • javax.swing.plaf.multi.MultiScrollBarUI
      • javax.swing.plaf.ScrollPaneUI
        • javax.swing.plaf.basic.BasicScrollPaneUI (implements javax.swing.ScrollPaneConstants)
          • javax.swing.plaf.metal.MetalScrollPaneUI
        • javax.swing.plaf.multi.MultiScrollPaneUI
      • javax.swing.plaf.SeparatorUI
        • javax.swing.plaf.basic.BasicSeparatorUI
          • javax.swing.plaf.basic.BasicPopupMenuSeparatorUI
          • javax.swing.plaf.basic.BasicToolBarSeparatorUI
          • javax.swing.plaf.metal.MetalSeparatorUI
            • javax.swing.plaf.metal.MetalPopupMenuSeparatorUI
        • javax.swing.plaf.multi.MultiSeparatorUI
      • javax.swing.plaf.SliderUI
        • javax.swing.plaf.basic.BasicSliderUI
          • javax.swing.plaf.metal.MetalSliderUI
        • javax.swing.plaf.multi.MultiSliderUI
      • javax.swing.plaf.SpinnerUI
        • javax.swing.plaf.basic.BasicSpinnerUI
        • javax.swing.plaf.multi.MultiSpinnerUI
      • javax.swing.plaf.SplitPaneUI
        • javax.swing.plaf.basic.BasicSplitPaneUI
          • javax.swing.plaf.metal.MetalSplitPaneUI
        • javax.swing.plaf.multi.MultiSplitPaneUI
      • javax.swing.plaf.TabbedPaneUI
        • javax.swing.plaf.basic.BasicTabbedPaneUI (implements javax.swing.SwingConstants)
          • javax.swing.plaf.metal.MetalTabbedPaneUI
        • javax.swing.plaf.multi.MultiTabbedPaneUI
      • javax.swing.plaf.TableHeaderUI
        • javax.swing.plaf.basic.BasicTableHeaderUI
        • javax.swing.plaf.multi.MultiTableHeaderUI
      • javax.swing.plaf.TableUI
        • javax.swing.plaf.basic.BasicTableUI
        • javax.swing.plaf.multi.MultiTableUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI (implements javax.swing.text.ViewFactory)
          • javax.swing.plaf.basic.BasicEditorPaneUI
            • javax.swing.plaf.basic.BasicTextPaneUI
          • javax.swing.plaf.basic.BasicTextAreaUI
          • javax.swing.plaf.basic.BasicTextFieldUI
            • javax.swing.plaf.basic.BasicFormattedTextFieldUI
            • javax.swing.plaf.basic.BasicPasswordFieldUI
            • javax.swing.plaf.metal.MetalTextFieldUI
          • javax.swing.text.DefaultTextUI
        • javax.swing.plaf.multi.MultiTextUI
      • javax.swing.plaf.ToolBarUI
        • javax.swing.plaf.basic.BasicToolBarUI (implements javax.swing.SwingConstants)
          • javax.swing.plaf.metal.MetalToolBarUI
        • javax.swing.plaf.multi.MultiToolBarUI
      • javax.swing.plaf.ToolTipUI
        • javax.swing.plaf.basic.BasicToolTipUI
          • javax.swing.plaf.metal.MetalToolTipUI
        • javax.swing.plaf.multi.MultiToolTipUI
      • javax.swing.plaf.TreeUI
        • javax.swing.plaf.basic.BasicTreeUI
          • javax.swing.plaf.metal.MetalTreeUI
        • javax.swing.plaf.multi.MultiTreeUI
      • javax.swing.plaf.ViewportUI
        • javax.swing.plaf.basic.BasicViewportUI
        • javax.swing.plaf.multi.MultiViewportUI
    • javax.management.openmbean.CompositeDataInvocationHandler (implements java.lang.reflect.InvocationHandler)
    • javax.management.openmbean.CompositeDataSupport (implements javax.management.openmbean.CompositeData, java.io.Serializable)
    • javax.naming.CompositeName (implements javax.naming.Name)
    • javax.naming.CompoundName (implements javax.naming.Name)
    • javax.security.auth.login.Configuration
    • javax.security.auth.login.ConfigurationSpi
    • javax.security.auth.callback.ConfirmationCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • java.io.Console (implements java.io.Flushable)
    • java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler (implements java.awt.event.ContainerListener)
    • java.awt.event.ContainerAdapter (implements java.awt.event.ContainerListener)
    • java.net.ContentHandler
    • javax.swing.text.html.parser.ContentModel (implements java.io.Serializable)
    • org.omg.CORBA.Context
    • org.omg.CORBA.ContextList
    • javax.sound.sampled.Control
      • javax.sound.sampled.BooleanControl
      • javax.sound.sampled.CompoundControl
      • javax.sound.sampled.EnumControl
      • javax.sound.sampled.FloatControl
    • javax.sound.sampled.Control.Type
      • javax.sound.sampled.BooleanControl.Type
      • javax.sound.sampled.CompoundControl.Type
      • javax.sound.sampled.EnumControl.Type
      • javax.sound.sampled.FloatControl.Type
    • javax.naming.ldap.ControlFactory
    • java.awt.image.ConvolveOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • java.net.CookieHandler
      • java.net.CookieManager
    • org.omg.PortableServer.ServantLocatorPackage.CookieHolder (implements org.omg.CORBA.portable.Streamable)
    • java.util.concurrent.CopyOnWriteArrayList<E> (implements java.lang.Cloneable, java.util.List<E>, java.util.RandomAccess, java.io.Serializable)
    • java.util.concurrent.CountDownLatch
    • java.util.zip.CRC32 (implements java.util.zip.Checksum)
    • java.security.cert.CRL
      • java.security.cert.X509CRL (implements java.security.cert.X509Extension)
    • javax.swing.text.html.CSS (implements java.io.Serializable)
    • javax.swing.text.html.CSS.Attribute
    • java.awt.geom.CubicCurve2D (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.CubicCurve2D.Double (implements java.io.Serializable)
      • java.awt.geom.CubicCurve2D.Float (implements java.io.Serializable)
    • java.util.Currency (implements java.io.Serializable)
    • org.omg.CORBA.CurrentHelper
    • org.omg.PortableServer.CurrentHelper
    • org.omg.PortableInterceptor.CurrentHelper
    • org.omg.CORBA.CurrentHolder (implements org.omg.CORBA.portable.Streamable)
    • java.awt.Cursor (implements java.io.Serializable)
    • java.util.concurrent.CyclicBarrier
    • java.awt.image.DataBuffer
      • java.awt.image.DataBufferByte
      • java.awt.image.DataBufferDouble
      • java.awt.image.DataBufferFloat
      • java.awt.image.DataBufferInt
      • java.awt.image.DataBufferShort
      • java.awt.image.DataBufferUShort
    • java.awt.datatransfer.DataFlavor (implements java.lang.Cloneable, java.io.Externalizable)
      • javax.activation.ActivationDataFlavor
    • java.net.DatagramPacket
    • java.net.DatagramSocket (implements java.io.Closeable)
      • java.net.MulticastSocket
    • java.net.DatagramSocketImpl (implements java.net.SocketOptions)
    • javax.activation.DataHandler (implements java.awt.datatransfer.Transferable)
    • javax.xml.datatype.DatatypeConstants
    • javax.xml.datatype.DatatypeConstants.Field
    • javax.xml.bind.DatatypeConverter
    • javax.xml.datatype.DatatypeFactory
    • java.util.Date (implements java.lang.Cloneable, java.lang.Comparable<T>, java.io.Serializable)
      • java.sql.Date
      • java.sql.Time
      • java.sql.Timestamp
    • java.text.DateFormatSymbols (implements java.lang.Cloneable, java.io.Serializable)
    • javax.print.attribute.DateTimeSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.DateTimeAtCompleted (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.DateTimeAtCreation (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.DateTimeAtProcessing (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobHoldUntil (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • java.text.DecimalFormatSymbols (implements java.lang.Cloneable, java.io.Serializable)
    • javax.swing.DefaultBoundedRangeModel (implements javax.swing.BoundedRangeModel, java.io.Serializable)
    • javax.swing.DefaultButtonModel (implements javax.swing.ButtonModel, java.io.Serializable)
      • javax.swing.JToggleButton.ToggleButtonModel
    • javax.swing.DefaultCellEditor.EditorDelegate (implements java.awt.event.ActionListener, java.awt.event.ItemListener, java.io.Serializable)
    • javax.swing.colorchooser.DefaultColorSelectionModel (implements javax.swing.colorchooser.ColorSelectionModel, java.io.Serializable)
    • javax.swing.DefaultDesktopManager (implements javax.swing.DesktopManager, java.io.Serializable)
    • org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • org.xml.sax.ext.DefaultHandler2 (implements org.xml.sax.ext.DeclHandler, org.xml.sax.ext.EntityResolver2, org.xml.sax.ext.LexicalHandler)
    • javax.swing.DefaultListSelectionModel (implements java.lang.Cloneable, javax.swing.ListSelectionModel, java.io.Serializable)
    • javax.management.DefaultLoaderRepository
    • javax.management.loading.DefaultLoaderRepository
    • javax.swing.tree.DefaultMutableTreeNode (implements java.lang.Cloneable, javax.swing.tree.MutableTreeNode, java.io.Serializable)
      • javax.swing.JTree.DynamicUtilTreeNode
    • javax.swing.DefaultRowSorter.ModelWrapper<M,I>
    • javax.swing.DefaultSingleSelectionModel (implements java.io.Serializable, javax.swing.SingleSelectionModel)
    • javax.swing.text.DefaultStyledDocument.ElementBuffer (implements java.io.Serializable)
    • javax.swing.text.DefaultStyledDocument.ElementSpec
    • javax.swing.table.DefaultTableColumnModel (implements javax.swing.event.ListSelectionListener, java.beans.PropertyChangeListener, java.io.Serializable, javax.swing.table.TableColumnModel)
    • javax.swing.tree.DefaultTreeCellEditor (implements java.awt.event.ActionListener, javax.swing.tree.TreeCellEditor, javax.swing.event.TreeSelectionListener)
    • javax.swing.tree.DefaultTreeModel (implements java.io.Serializable, javax.swing.tree.TreeModel)
    • javax.swing.tree.DefaultTreeSelectionModel (implements java.lang.Cloneable, java.io.Serializable, javax.swing.tree.TreeSelectionModel)
      • javax.swing.JTree.EmptySelectionModel
    • javax.xml.bind.helpers.DefaultValidationEventHandler (implements javax.xml.bind.ValidationEventHandler)
    • org.omg.CORBA.DefinitionKind (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DefinitionKindHelper
    • java.util.zip.Deflater
    • org.omg.CORBA.portable.Delegate
      • org.omg.CORBA_2_3.portable.Delegate
    • javax.management.modelmbean.DescriptorSupport (implements javax.management.Descriptor)
    • javax.crypto.spec.DESedeKeySpec (implements java.security.spec.KeySpec)
    • javax.crypto.spec.DESKeySpec (implements java.security.spec.KeySpec)
    • java.awt.Desktop
    • javax.crypto.spec.DHGenParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.DHParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.DHPrivateKeySpec (implements java.security.spec.KeySpec)
    • javax.crypto.spec.DHPublicKeySpec (implements java.security.spec.KeySpec)
    • javax.tools.DiagnosticCollector<S> (implements javax.tools.DiagnosticListener<S>)
    • java.util.Dictionary<K,V>
      • java.util.Hashtable<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • java.util.Properties
          • java.security.Provider
            • java.security.AuthProvider
        • javax.swing.UIDefaults
    • java.awt.geom.Dimension2D (implements java.lang.Cloneable)
      • java.awt.Dimension (implements java.io.Serializable)
        • javax.swing.plaf.DimensionUIResource (implements javax.swing.plaf.UIResource)
    • java.nio.file.DirectoryStreamFilters
    • javax.naming.spi.DirStateFactory.Result
    • java.awt.DisplayMode
    • java.awt.dnd.DnDConstants
    • javax.print.DocFlavor (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.DocFlavor.BYTE_ARRAY
      • javax.print.DocFlavor.CHAR_ARRAY
      • javax.print.DocFlavor.INPUT_STREAM
      • javax.print.DocFlavor.READER
      • javax.print.DocFlavor.SERVICE_FORMATTED
      • javax.print.DocFlavor.STRING
      • javax.print.DocFlavor.URL
    • javax.xml.parsers.DocumentBuilder
    • javax.xml.parsers.DocumentBuilderFactory
    • javax.swing.event.DocumentEvent.EventType
    • javax.swing.text.DocumentFilter
    • javax.swing.text.DocumentFilter.FilterBypass
    • javax.xml.crypto.dom.DOMCryptoContext (implements javax.xml.crypto.XMLCryptoContext)
      • javax.xml.crypto.dsig.dom.DOMSignContext (implements javax.xml.crypto.dsig.XMLSignContext)
      • javax.xml.crypto.dsig.dom.DOMValidateContext (implements javax.xml.crypto.dsig.XMLValidateContext)
    • org.w3c.dom.bootstrap.DOMImplementationRegistry
    • javax.xml.transform.dom.DOMResult (implements javax.xml.transform.Result)
      • javax.xml.soap.SAAJResult
    • javax.xml.transform.dom.DOMSource (implements javax.xml.transform.Source)
    • javax.xml.crypto.dom.DOMStructure (implements javax.xml.crypto.XMLStructure)
    • org.omg.CORBA.DoubleHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.DoubleSeqHelper
    • org.omg.CORBA.DoubleSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • java.awt.dnd.DragGestureRecognizer (implements java.io.Serializable)
      • java.awt.dnd.MouseDragGestureRecognizer (implements java.awt.event.MouseListener, java.awt.event.MouseMotionListener)
    • java.awt.dnd.DragSource (implements java.io.Serializable)
    • java.awt.dnd.DragSourceAdapter (implements java.awt.dnd.DragSourceListener, java.awt.dnd.DragSourceMotionListener)
    • java.awt.dnd.DragSourceContext (implements java.awt.dnd.DragSourceListener, java.awt.dnd.DragSourceMotionListener, java.io.Serializable)
    • java.sql.DriverManager
    • java.sql.DriverPropertyInfo
    • java.awt.dnd.DropTarget (implements java.awt.dnd.DropTargetListener, java.io.Serializable)
    • java.awt.dnd.DropTarget.DropTargetAutoScroller (implements java.awt.event.ActionListener)
    • java.awt.dnd.DropTargetAdapter (implements java.awt.dnd.DropTargetListener)
    • java.awt.dnd.DropTargetContext (implements java.io.Serializable)
    • java.awt.dnd.DropTargetContext.TransferableProxy (implements java.awt.datatransfer.Transferable)
    • java.security.spec.DSAParameterSpec (implements java.security.spec.AlgorithmParameterSpec, java.security.interfaces.DSAParams)
    • java.security.spec.DSAPrivateKeySpec (implements java.security.spec.KeySpec)
    • java.security.spec.DSAPublicKeySpec (implements java.security.spec.KeySpec)
    • javax.swing.text.html.parser.DTD (implements javax.swing.text.html.parser.DTDConstants)
    • org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper
    • javax.xml.datatype.Duration
    • org.omg.DynamicAny.DynAnyFactoryHelper
    • org.omg.DynamicAny.DynAnyHelper
    • org.omg.DynamicAny.DynAnySeqHelper
    • org.omg.DynamicAny.DynArrayHelper
    • org.omg.DynamicAny.DynEnumHelper
    • org.omg.DynamicAny.DynFixedHelper
    • org.omg.DynamicAny.DynSequenceHelper
    • org.omg.DynamicAny.DynStructHelper
    • org.omg.DynamicAny.DynUnionHelper
    • org.omg.DynamicAny.DynValueHelper
    • java.security.spec.ECFieldF2m (implements java.security.spec.ECField)
    • java.security.spec.ECFieldFp (implements java.security.spec.ECField)
    • java.security.spec.ECGenParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.security.spec.ECParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.security.spec.ECPoint
    • java.security.spec.ECPrivateKeySpec (implements java.security.spec.KeySpec)
    • java.security.spec.ECPublicKeySpec (implements java.security.spec.KeySpec)
    • javax.swing.text.EditorKit (implements java.lang.Cloneable, java.io.Serializable)
      • javax.swing.text.DefaultEditorKit
        • javax.swing.text.StyledEditorKit
          • javax.swing.text.html.HTMLEditorKit (implements javax.accessibility.Accessible)
          • javax.swing.text.rtf.RTFEditorKit
    • javax.swing.text.html.parser.Element (implements javax.swing.text.html.parser.DTDConstants, java.io.Serializable)
    • javax.lang.model.util.ElementFilter
    • javax.swing.text.ElementIterator (implements java.lang.Cloneable)
    • java.security.spec.EllipticCurve
    • java.security.spec.EncodedKeySpec (implements java.security.spec.KeySpec)
      • java.security.spec.PKCS8EncodedKeySpec
      • java.security.spec.X509EncodedKeySpec
    • java.beans.Encoder
      • java.beans.XMLEncoder
    • org.omg.IOP.Encoding (implements org.omg.CORBA.portable.IDLEntity)
    • javax.crypto.EncryptedPrivateKeyInfo
    • javax.xml.ws.Endpoint
    • javax.xml.ws.EndpointReference
      • javax.xml.ws.wsaddressing.W3CEndpointReference
    • javax.swing.text.html.parser.Entity (implements javax.swing.text.html.parser.DTDConstants)
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
    • javax.print.attribute.EnumSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.Chromaticity (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.ColorSupported (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.Compression (implements javax.print.attribute.DocAttribute)
      • javax.print.attribute.standard.DialogTypeSelection (implements javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.Fidelity (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.Finishings (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobSheets (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobState (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobStateReason (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.Media (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
        • javax.print.attribute.standard.MediaName (implements javax.print.attribute.Attribute)
        • javax.print.attribute.standard.MediaSizeName
        • javax.print.attribute.standard.MediaTray (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.MultipleDocumentHandling (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.OrientationRequested (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.PDLOverrideSupported (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PresentationDirection (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.PrinterIsAcceptingJobs (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterState (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterStateReason (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.PrintQuality (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.ReferenceUriSchemesSupported (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.Severity (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.SheetCollate (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.Sides (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • org.omg.CORBA.Environment
    • java.util.logging.ErrorManager
    • java.awt.Event (implements java.io.Serializable)
    • javax.management.event.EventClient (implements javax.management.event.EventConsumer, javax.management.event.NotificationManager)
    • javax.management.event.EventClientDelegate (implements javax.management.event.EventClientDelegateMBean)
    • java.beans.EventHandler (implements java.lang.reflect.InvocationHandler)
    • javax.swing.event.EventListenerList (implements java.io.Serializable)
    • java.util.EventListenerProxy<T> (implements java.util.EventListener)
      • java.awt.event.AWTEventListenerProxy (implements java.awt.event.AWTEventListener)
      • java.beans.PropertyChangeListenerProxy (implements java.beans.PropertyChangeListener)
      • java.beans.VetoableChangeListenerProxy (implements java.beans.VetoableChangeListener)
    • java.util.EventObject (implements java.io.Serializable)
      • java.awt.AWTEvent
        • java.awt.event.ActionEvent
        • java.awt.event.AdjustmentEvent
        • javax.swing.event.AncestorEvent
        • java.awt.event.ComponentEvent
          • java.awt.event.ContainerEvent
          • java.awt.event.FocusEvent
          • java.awt.event.InputEvent
            • java.awt.event.KeyEvent
              • javax.swing.event.MenuKeyEvent
            • java.awt.event.MouseEvent
              • javax.swing.event.MenuDragMouseEvent
              • java.awt.event.MouseWheelEvent
          • java.awt.event.PaintEvent
          • java.awt.event.WindowEvent
        • java.awt.event.HierarchyEvent
        • java.awt.event.InputMethodEvent
        • javax.swing.event.InternalFrameEvent
        • java.awt.event.InvocationEvent (implements java.awt.ActiveEvent)
        • java.awt.event.ItemEvent
        • java.awt.event.TextEvent
      • java.beans.beancontext.BeanContextEvent
        • java.beans.beancontext.BeanContextMembershipEvent
        • java.beans.beancontext.BeanContextServiceAvailableEvent
        • java.beans.beancontext.BeanContextServiceRevokedEvent
      • javax.swing.event.CaretEvent
      • javax.swing.event.ChangeEvent
      • javax.sql.ConnectionEvent
      • java.awt.dnd.DragGestureEvent
      • java.awt.dnd.DragSourceEvent
        • java.awt.dnd.DragSourceDragEvent
        • java.awt.dnd.DragSourceDropEvent
      • java.awt.dnd.DropTargetEvent
        • java.awt.dnd.DropTargetDragEvent
        • java.awt.dnd.DropTargetDropEvent
      • java.awt.datatransfer.FlavorEvent
      • javax.net.ssl.HandshakeCompletedEvent
      • javax.swing.event.HyperlinkEvent
        • javax.swing.text.html.HTMLFrameHyperlinkEvent
          • javax.swing.text.html.FormSubmitEvent
      • javax.sound.sampled.LineEvent
      • javax.swing.event.ListDataEvent
      • javax.swing.event.ListSelectionEvent
      • javax.swing.event.MenuEvent
      • javax.naming.event.NamingEvent
      • javax.naming.event.NamingExceptionEvent
      • java.util.prefs.NodeChangeEvent
      • javax.management.Notification (implements java.lang.Cloneable)
        • javax.management.AttributeChangeNotification
        • javax.management.remote.JMXConnectionNotification
        • javax.management.MBeanServerNotification
        • javax.management.monitor.MonitorNotification
        • javax.management.relation.RelationNotification
        • javax.management.timer.TimerNotification
      • javax.swing.event.PopupMenuEvent
      • java.util.prefs.PreferenceChangeEvent
      • javax.print.event.PrintEvent
        • javax.print.event.PrintJobAttributeEvent
        • javax.print.event.PrintJobEvent
        • javax.print.event.PrintServiceAttributeEvent
      • java.beans.PropertyChangeEvent
        • java.beans.IndexedPropertyChangeEvent
      • javax.sql.RowSetEvent
      • javax.swing.event.RowSorterEvent
      • javax.net.ssl.SSLSessionBindingEvent
      • javax.sql.StatementEvent
      • javax.swing.event.TableColumnModelEvent
      • javax.swing.event.TableModelEvent
      • javax.swing.event.TreeExpansionEvent
      • javax.swing.event.TreeModelEvent
      • javax.swing.event.TreeSelectionEvent
      • javax.swing.event.UndoableEditEvent
      • javax.naming.ldap.UnsolicitedNotificationEvent
    • java.awt.EventQueue
    • javax.xml.stream.util.EventReaderDelegate (implements javax.xml.stream.XMLEventReader)
    • javax.management.event.EventSubscriber (implements javax.management.event.EventConsumer)
    • javax.xml.crypto.dsig.spec.ExcC14NParameterSpec (implements javax.xml.crypto.dsig.spec.C14NMethodParameterSpec)
    • org.omg.CORBA.ExceptionList
    • java.util.concurrent.Exchanger<V>
    • java.util.concurrent.ExecutorCompletionService<V> (implements java.util.concurrent.CompletionService<V>)
    • java.util.concurrent.Executors
    • javax.crypto.ExemptionMechanism
    • javax.crypto.ExemptionMechanismSpi
    • java.beans.FeatureDescriptor
      • java.beans.BeanDescriptor
      • java.beans.EventSetDescriptor
      • java.beans.MethodDescriptor
      • java.beans.ParameterDescriptor
      • java.beans.PropertyDescriptor
        • java.beans.IndexedPropertyDescriptor
    • javax.management.event.FetchingEventForwarder (implements javax.management.event.EventForwarder)
    • javax.management.event.FetchingEventRelay (implements javax.management.event.EventRelay)
    • org.omg.CORBA.FieldNameHelper
    • org.omg.DynamicAny.FieldNameHelper
    • java.text.FieldPosition
    • java.io.File (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.nio.channels.FileChannel.MapMode
    • javax.activation.FileDataSource (implements javax.activation.DataSource)
    • java.io.FileDescriptor
    • javax.swing.filechooser.FileFilter
      • javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter
      • javax.swing.filechooser.FileNameExtensionFilter
    • java.nio.channels.FileLock
    • java.nio.file.Files
    • java.nio.file.FileStore
    • java.nio.file.FileSystem (implements java.io.Closeable)
    • java.nio.file.spi.FileSystemProvider
    • java.nio.file.FileSystems
    • javax.swing.filechooser.FileSystemView
    • java.nio.file.spi.FileTypeDetector
    • javax.activation.FileTypeMap
      • javax.activation.MimetypesFileTypeMap
    • javax.swing.filechooser.FileView
      • javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView
    • java.awt.image.FilteredImageSource (implements java.awt.image.ImageProducer)
    • org.omg.CORBA.FixedHolder (implements org.omg.CORBA.portable.Streamable)
    • java.awt.geom.FlatteningPathIterator (implements java.awt.geom.PathIterator)
    • org.omg.CORBA.FloatHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.FloatSeqHelper
    • org.omg.CORBA.FloatSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • java.awt.FlowLayout (implements java.awt.LayoutManager, java.io.Serializable)
    • javax.swing.text.FlowView.FlowStrategy
    • java.awt.event.FocusAdapter (implements java.awt.event.FocusListener)
      • javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler
      • javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler
    • java.awt.FocusTraversalPolicy
      • java.awt.ContainerOrderFocusTraversalPolicy (implements java.io.Serializable)
        • java.awt.DefaultFocusTraversalPolicy
      • javax.swing.InternalFrameFocusTraversalPolicy
        • javax.swing.SortingFocusTraversalPolicy
          • javax.swing.LayoutFocusTraversalPolicy (implements java.io.Serializable)
    • java.awt.Font (implements java.io.Serializable)
      • javax.swing.plaf.FontUIResource (implements javax.swing.plaf.UIResource)
    • java.awt.FontMetrics (implements java.io.Serializable)
    • java.awt.font.FontRenderContext
    • java.text.Format (implements java.lang.Cloneable, java.io.Serializable)
      • java.text.DateFormat
        • java.text.SimpleDateFormat
      • java.text.MessageFormat
      • java.text.NumberFormat
        • java.text.ChoiceFormat
        • java.text.DecimalFormat
    • javax.sound.sampled.spi.FormatConversionProvider
    • org.omg.IOP.CodecPackage.FormatMismatchHelper
    • java.util.FormattableFlags
    • java.util.Formatter (implements java.io.Closeable, java.io.Flushable)
    • java.util.logging.Formatter
      • java.util.logging.SimpleFormatter
      • java.util.logging.XMLFormatter
    • javax.tools.ForwardingFileObject<F> (implements javax.tools.FileObject)
      • javax.tools.ForwardingJavaFileObject<F> (implements javax.tools.JavaFileObject)
    • javax.tools.ForwardingJavaFileManager<M> (implements javax.tools.JavaFileManager)
    • org.omg.PortableServer.ForwardRequestHelper
    • org.omg.PortableInterceptor.ForwardRequestHelper
    • java.util.concurrent.FutureTask<V> (implements java.util.concurrent.RunnableFuture<V>)
    • javax.swing.text.GapContent (implements javax.swing.text.AbstractDocument.Content, java.io.Serializable)
    • java.awt.font.GlyphJustificationInfo
    • java.awt.font.GlyphMetrics
    • java.awt.font.GlyphVector (implements java.lang.Cloneable)
    • javax.swing.text.GlyphView.GlyphPainter
    • java.awt.GradientPaint (implements java.awt.Paint)
    • java.awt.font.GraphicAttribute
      • java.awt.font.ImageGraphicAttribute
      • java.awt.font.ShapeGraphicAttribute
    • java.awt.Graphics
      • javax.swing.DebugGraphics
      • java.awt.Graphics2D
    • java.awt.GraphicsConfigTemplate (implements java.io.Serializable)
    • java.awt.GraphicsConfiguration
    • java.awt.GraphicsDevice
    • java.awt.GraphicsEnvironment
    • java.awt.GridBagConstraints (implements java.lang.Cloneable, java.io.Serializable)
    • java.awt.GridBagLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • java.awt.GridBagLayoutInfo (implements java.io.Serializable)
    • java.awt.GridLayout (implements java.awt.LayoutManager, java.io.Serializable)
    • javax.swing.GroupLayout (implements java.awt.LayoutManager2)
    • javax.swing.GroupLayout.Group
      • javax.swing.GroupLayout.ParallelGroup
      • javax.swing.GroupLayout.SequentialGroup
    • org.ietf.jgss.GSSManager
    • java.security.GuardedObject (implements java.io.Serializable)
    • java.util.logging.Handler
      • java.util.logging.MemoryHandler
      • java.util.logging.StreamHandler
        • java.util.logging.ConsoleHandler
        • java.util.logging.FileHandler
        • java.util.logging.SocketHandler
    • org.xml.sax.HandlerBase (implements org.xml.sax.DocumentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
    • javax.print.attribute.HashAttributeSet (implements javax.print.attribute.AttributeSet, java.io.Serializable)
      • javax.print.attribute.HashDocAttributeSet (implements javax.print.attribute.DocAttributeSet, java.io.Serializable)
      • javax.print.attribute.HashPrintJobAttributeSet (implements javax.print.attribute.PrintJobAttributeSet, java.io.Serializable)
      • javax.print.attribute.HashPrintRequestAttributeSet (implements javax.print.attribute.PrintRequestAttributeSet, java.io.Serializable)
      • javax.print.attribute.HashPrintServiceAttributeSet (implements javax.print.attribute.PrintServiceAttributeSet, java.io.Serializable)
    • java.awt.event.HierarchyBoundsAdapter (implements java.awt.event.HierarchyBoundsListener)
    • javax.xml.crypto.dsig.spec.HMACParameterSpec (implements javax.xml.crypto.dsig.spec.SignatureMethodParameterSpec)
    • javax.xml.ws.Holder<T>
    • javax.swing.text.html.HTML
    • javax.swing.text.html.HTML.Attribute
    • javax.swing.text.html.HTML.Tag
      • javax.swing.text.html.HTML.UnknownTag (implements java.io.Serializable)
    • javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction
        • javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction
        • javax.swing.text.html.HTMLDocument.HTMLReader.PreAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction
        • javax.swing.text.html.HTMLDocument.HTMLReader.FormAction
    • javax.swing.text.html.HTMLDocument.Iterator
    • javax.swing.text.html.HTMLEditorKit.HTMLFactory (implements javax.swing.text.ViewFactory)
    • javax.swing.text.html.HTMLEditorKit.Parser
      • javax.swing.text.html.parser.ParserDelegator (implements java.io.Serializable)
    • javax.swing.text.html.HTMLEditorKit.ParserCallback
      • javax.swing.text.html.HTMLDocument.HTMLReader
    • java.net.HttpCookie (implements java.lang.Cloneable)
    • javax.swing.event.HyperlinkEvent.EventType
    • java.awt.color.ICC_Profile (implements java.io.Serializable)
      • java.awt.color.ICC_ProfileGray
      • java.awt.color.ICC_ProfileRGB
    • javax.swing.plaf.IconUIResource (implements javax.swing.Icon, java.io.Serializable, javax.swing.plaf.UIResource)
    • org.omg.PortableServer.IdAssignmentPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.IdentifierHelper
    • java.security.Identity (implements java.security.Principal, java.io.Serializable)
      • java.security.IdentityScope
      • java.security.Signer
    • javax.management.remote.IdentityMBeanServerForwarder (implements javax.management.remote.MBeanServerForwarder)
    • org.omg.CORBA.IDLTypeHelper
    • java.net.IDN
    • org.omg.PortableServer.IdUniquenessPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • javax.imageio.stream.IIOByteBuffer
    • javax.imageio.IIOImage
    • javax.imageio.metadata.IIOMetadata
    • javax.imageio.metadata.IIOMetadataFormatImpl (implements javax.imageio.metadata.IIOMetadataFormat)
    • javax.imageio.metadata.IIOMetadataNode (implements org.w3c.dom.Element, org.w3c.dom.NodeList)
    • javax.imageio.IIOParam
      • javax.imageio.ImageReadParam
        • javax.imageio.plugins.jpeg.JPEGImageReadParam
      • javax.imageio.ImageWriteParam
        • javax.imageio.plugins.bmp.BMPImageWriteParam
        • javax.imageio.plugins.jpeg.JPEGImageWriteParam
    • javax.imageio.spi.IIOServiceProvider (implements javax.imageio.spi.RegisterableService)
      • javax.imageio.spi.ImageInputStreamSpi
      • javax.imageio.spi.ImageOutputStreamSpi
      • javax.imageio.spi.ImageReaderWriterSpi
        • javax.imageio.spi.ImageReaderSpi
        • javax.imageio.spi.ImageWriterSpi
      • javax.imageio.spi.ImageTranscoderSpi
    • java.awt.Image
      • java.awt.image.BufferedImage (implements java.awt.Transparency, java.awt.image.WritableRenderedImage)
      • java.awt.image.VolatileImage (implements java.awt.Transparency)
    • java.awt.ImageCapabilities (implements java.lang.Cloneable)
    • java.awt.image.ImageFilter (implements java.lang.Cloneable, java.awt.image.ImageConsumer)
      • java.awt.image.BufferedImageFilter (implements java.lang.Cloneable)
      • java.awt.image.CropImageFilter
      • java.awt.image.ReplicateScaleFilter
        • java.awt.image.AreaAveragingScaleFilter
      • java.awt.image.RGBImageFilter
        • javax.swing.GrayFilter
    • javax.swing.ImageIcon (implements javax.accessibility.Accessible, javax.swing.Icon, java.io.Serializable)
    • javax.imageio.stream.ImageInputStreamImpl (implements javax.imageio.stream.ImageInputStream)
      • javax.imageio.stream.FileCacheImageInputStream
      • javax.imageio.stream.FileImageInputStream
      • javax.imageio.stream.ImageOutputStreamImpl (implements javax.imageio.stream.ImageOutputStream)
        • javax.imageio.stream.FileCacheImageOutputStream
        • javax.imageio.stream.FileImageOutputStream
        • javax.imageio.stream.MemoryCacheImageOutputStream
      • javax.imageio.stream.MemoryCacheImageInputStream
    • javax.imageio.ImageIO
    • javax.imageio.ImageReader
    • javax.imageio.ImageTypeSpecifier
    • javax.imageio.ImageWriter (implements javax.imageio.ImageTranscoder)
    • javax.management.ImmutableDescriptor (implements javax.management.Descriptor)
    • org.omg.PortableServer.ImplicitActivationPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper
    • java.net.InetAddress (implements java.io.Serializable)
      • java.net.Inet4Address
      • java.net.Inet6Address
    • java.util.zip.Inflater
    • javax.naming.InitialContext (implements javax.naming.Context)
      • javax.naming.directory.InitialDirContext (implements javax.naming.directory.DirContext)
        • javax.naming.ldap.InitialLdapContext (implements javax.naming.ldap.LdapContext)
    • java.awt.im.InputContext
    • javax.swing.InputMap (implements java.io.Serializable)
      • javax.swing.ComponentInputMap
        • javax.swing.plaf.ComponentInputMapUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.InputMapUIResource (implements javax.swing.plaf.UIResource)
    • java.awt.im.InputMethodHighlight
    • org.xml.sax.InputSource
    • java.io.InputStream (implements java.io.Closeable)
      • javax.sound.sampled.AudioInputStream
      • java.io.ByteArrayInputStream
      • java.io.FileInputStream
      • java.io.FilterInputStream
        • java.io.BufferedInputStream
        • java.util.zip.CheckedInputStream
        • javax.crypto.CipherInputStream
        • java.io.DataInputStream (implements java.io.DataInput)
        • java.util.zip.DeflaterInputStream
        • java.security.DigestInputStream
        • java.util.zip.InflaterInputStream
          • java.util.zip.GZIPInputStream
          • java.util.zip.ZipInputStream
            • java.util.jar.JarInputStream
        • java.io.LineNumberInputStream
        • javax.swing.ProgressMonitorInputStream
        • java.io.PushbackInputStream
      • org.omg.CORBA.portable.InputStream
        • org.omg.CORBA_2_3.portable.InputStream
      • java.io.ObjectInputStream (implements java.io.ObjectInput, java.io.ObjectStreamConstants)
      • java.io.PipedInputStream
      • java.io.SequenceInputStream
      • java.io.StringBufferInputStream
    • javax.swing.InputVerifier
    • java.awt.Insets (implements java.lang.Cloneable, java.io.Serializable)
      • javax.swing.plaf.InsetsUIResource (implements javax.swing.plaf.UIResource)
    • javax.print.attribute.IntegerSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.Copies (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobImpressions (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobImpressionsCompleted (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobKOctets (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobKOctetsProcessed (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobMediaSheets (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobMediaSheetsCompleted (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobPriority (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobPrioritySupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.NumberOfDocuments (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.NumberOfInterveningJobs (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.NumberUp (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.PagesPerMinute (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PagesPerMinuteColor (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.QueuedJobCount (implements javax.print.attribute.PrintServiceAttribute)
    • java.net.InterfaceAddress
    • javax.swing.event.InternalFrameAdapter (implements javax.swing.event.InternalFrameListener)
    • org.omg.CORBA.IntHolder (implements org.omg.CORBA.portable.Streamable)
    • java.beans.Introspector
    • org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper
    • org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.InvalidNameHelper
    • org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper
    • org.omg.CosNaming.NamingContextPackage.InvalidNameHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableServer.POAPackage.InvalidPolicyHelper
    • org.omg.PortableInterceptor.InvalidSlotHelper
    • org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper
    • org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper
    • java.dyn.InvokeDynamic
    • org.omg.IOP.IOR (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.IORHelper
    • org.omg.IOP.IORHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.IORInterceptor_3_0Helper
    • org.omg.PortableInterceptor.IORInterceptor_3_0Holder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.IstringHelper
    • javax.crypto.spec.IvParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.xml.bind.JAXB
    • javax.xml.bind.JAXBContext
    • javax.xml.bind.JAXBElement<T> (implements java.io.Serializable)
    • javax.xml.bind.JAXBElement.GlobalScope
    • javax.xml.bind.JAXBIntrospector
    • javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler (implements java.awt.event.ContainerListener)
    • javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.JFormattedTextField.AbstractFormatter (implements java.io.Serializable)
      • javax.swing.text.DefaultFormatter (implements java.lang.Cloneable, java.io.Serializable)
        • javax.swing.text.InternationalFormatter
          • javax.swing.text.DateFormatter
          • javax.swing.text.NumberFormatter
        • javax.swing.text.MaskFormatter
    • javax.swing.JFormattedTextField.AbstractFormatterFactory
      • javax.swing.text.DefaultFormatterFactory (implements java.io.Serializable)
    • javax.management.JMX
    • javax.management.JMX.MBeanOptions (implements java.lang.Cloneable, java.io.Serializable)
      • javax.management.JMX.ProxyOptions
      • javax.management.StandardMBean.Options
    • javax.management.remote.JMXConnectorFactory
    • javax.management.remote.JMXConnectorServerFactory
    • javax.management.namespace.JMXNamespace (implements javax.management.namespace.JMXNamespaceMBean, javax.management.MBeanRegistration)
      • javax.management.namespace.JMXDomain
      • javax.management.namespace.JMXRemoteNamespace (implements javax.management.namespace.JMXRemoteNamespaceMBean, javax.management.NotificationEmitter)
    • javax.management.namespace.JMXNamespaces
    • javax.management.namespace.JMXNamespaceView
    • javax.management.remote.JMXPrincipal (implements java.security.Principal, java.io.Serializable)
    • javax.management.remote.JMXServiceURL (implements java.io.Serializable)
    • java.awt.JobAttributes (implements java.lang.Cloneable)
    • java.awt.JobAttributes.DefaultSelectionType
    • java.awt.JobAttributes.DestinationType
    • java.awt.JobAttributes.DialogType
    • java.awt.JobAttributes.MultipleDocumentHandlingType
    • java.awt.JobAttributes.SidesType
    • javax.imageio.plugins.jpeg.JPEGHuffmanTable
    • javax.imageio.plugins.jpeg.JPEGQTable
    • javax.swing.JRootPane.RootLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • javax.swing.JTabbedPane.ModelListener (implements javax.swing.event.ChangeListener, java.io.Serializable)
    • javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange (implements javax.accessibility.AccessibleTableModelChange)
    • javax.swing.text.JTextComponent.KeyBinding
    • javax.swing.JTree.TreeModelHandler (implements javax.swing.event.TreeModelListener)
    • javax.swing.JTree.TreeSelectionRedirector (implements java.io.Serializable, javax.swing.event.TreeSelectionListener)
    • javax.security.auth.kerberos.KerberosKey (implements javax.security.auth.Destroyable, javax.crypto.SecretKey)
    • javax.security.auth.kerberos.KerberosPrincipal (implements java.security.Principal, java.io.Serializable)
    • javax.security.auth.kerberos.KerberosTicket (implements javax.security.auth.Destroyable, javax.security.auth.Refreshable, java.io.Serializable)
    • java.awt.image.Kernel (implements java.lang.Cloneable)
    • java.awt.event.KeyAdapter (implements java.awt.event.KeyListener)
      • javax.swing.plaf.basic.BasicComboBoxUI.KeyHandler
      • javax.swing.plaf.basic.BasicComboPopup.InvocationKeyHandler
      • javax.swing.plaf.basic.BasicTreeUI.KeyHandler
    • javax.crypto.KeyAgreement
    • javax.crypto.KeyAgreementSpi
    • java.awt.KeyboardFocusManager (implements java.awt.KeyEventDispatcher, java.awt.KeyEventPostProcessor)
      • java.awt.DefaultKeyboardFocusManager
        • javax.swing.FocusManager
          • javax.swing.DefaultFocusManager
    • java.security.KeyFactory
    • java.security.KeyFactorySpi
    • javax.crypto.KeyGenerator
    • javax.crypto.KeyGeneratorSpi
    • javax.xml.crypto.dsig.keyinfo.KeyInfoFactory
    • javax.net.ssl.KeyManagerFactory
    • javax.net.ssl.KeyManagerFactorySpi
    • java.security.KeyPair (implements java.io.Serializable)
    • java.security.KeyPairGeneratorSpi
      • java.security.KeyPairGenerator
    • java.security.KeyRep (implements java.io.Serializable)
    • javax.xml.crypto.KeySelector
    • javax.xml.crypto.KeySelector.Purpose
    • java.security.KeyStore
    • java.security.KeyStore.Builder
    • java.security.KeyStore.CallbackHandlerProtection (implements java.security.KeyStore.ProtectionParameter)
    • java.security.KeyStore.PasswordProtection (implements javax.security.auth.Destroyable, java.security.KeyStore.ProtectionParameter)
    • java.security.KeyStore.PrivateKeyEntry (implements java.security.KeyStore.Entry)
    • java.security.KeyStore.SecretKeyEntry (implements java.security.KeyStore.Entry)
    • java.security.KeyStore.TrustedCertificateEntry (implements java.security.KeyStore.Entry)
    • javax.net.ssl.KeyStoreBuilderParameters (implements javax.net.ssl.ManagerFactoryParameters)
    • java.security.KeyStoreSpi
    • javax.security.auth.callback.LanguageCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.swing.text.LayeredHighlighter (implements javax.swing.text.Highlighter)
      • javax.swing.text.DefaultHighlighter
        • javax.swing.plaf.basic.BasicTextUI.BasicHighlighter (implements javax.swing.plaf.UIResource)
    • javax.swing.text.LayeredHighlighter.LayerPainter (implements javax.swing.text.Highlighter.HighlightPainter)
      • javax.swing.text.DefaultHighlighter.DefaultHighlightPainter
    • java.awt.font.LayoutPath
    • javax.swing.text.LayoutQueue
    • javax.swing.LayoutStyle
    • java.security.cert.LDAPCertStoreParameters (implements java.security.cert.CertStoreParameters)
    • javax.naming.ldap.LdapName (implements javax.naming.Name)
    • java.rmi.dgc.Lease (implements java.io.Serializable)
    • java.util.logging.Level (implements java.io.Serializable)
    • org.omg.PortableServer.LifespanPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • javax.sound.sampled.Line.Info
      • javax.sound.sampled.DataLine.Info
      • javax.sound.sampled.Port.Info
    • java.awt.geom.Line2D (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.Line2D.Double (implements java.io.Serializable)
      • java.awt.geom.Line2D.Float (implements java.io.Serializable)
    • java.awt.font.LineBreakMeasurer
    • javax.sound.sampled.LineEvent.Type
    • java.awt.font.LineMetrics
    • java.dyn.Linkage
    • javax.management.event.ListenerInfo
    • java.util.Locale (implements java.lang.Cloneable, java.io.Serializable)
    • java.util.spi.LocaleServiceProvider
      • java.text.spi.BreakIteratorProvider
      • java.text.spi.CollatorProvider
      • java.util.spi.CurrencyNameProvider
      • java.text.spi.DateFormatProvider
      • java.text.spi.DateFormatSymbolsProvider
      • java.text.spi.DecimalFormatSymbolsProvider
      • java.util.spi.LocaleNameProvider
      • java.text.spi.NumberFormatProvider
      • java.util.spi.TimeZoneNameProvider
    • org.omg.CORBA.LocalObject (implements org.omg.CORBA.Object)
    • java.rmi.registry.LocateRegistry
    • org.xml.sax.helpers.LocatorImpl (implements org.xml.sax.Locator)
      • org.xml.sax.ext.Locator2Impl (implements org.xml.sax.ext.Locator2)
    • java.lang.management.LockInfo
      • java.lang.management.MonitorInfo
    • java.util.concurrent.locks.LockSupport
    • java.util.logging.Logger
    • javax.security.auth.login.LoginContext
    • java.util.logging.LogManager
    • java.util.logging.LogRecord (implements java.io.Serializable)
    • org.omg.CORBA.LongHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.LongLongSeqHelper
    • org.omg.CORBA.LongLongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.LongSeqHelper
    • org.omg.CORBA.LongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.swing.LookAndFeel
      • javax.swing.plaf.basic.BasicLookAndFeel (implements java.io.Serializable)
        • javax.swing.plaf.metal.MetalLookAndFeel
        • javax.swing.plaf.synth.SynthLookAndFeel
      • javax.swing.plaf.multi.MultiLookAndFeel
    • java.awt.image.LookupOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • java.awt.image.LookupTable
      • java.awt.image.ByteLookupTable
      • java.awt.image.ShortLookupTable
    • javax.crypto.Mac (implements java.lang.Cloneable)
    • javax.crypto.MacSpi
    • java.lang.management.ManagementFactory
    • java.util.jar.Manifest (implements java.lang.Cloneable)
    • java.rmi.MarshalledObject<T> (implements java.io.Serializable)
    • javax.xml.bind.Marshaller.Listener
    • java.util.regex.Matcher (implements java.util.regex.MatchResult)
    • java.lang.Math
    • java.math.MathContext (implements java.io.Serializable)
    • javax.management.MBeanFeatureInfo (implements javax.management.DescriptorRead, java.io.Serializable)
      • javax.management.MBeanAttributeInfo (implements java.lang.Cloneable)
        • javax.management.modelmbean.ModelMBeanAttributeInfo (implements javax.management.DescriptorAccess)
        • javax.management.openmbean.OpenMBeanAttributeInfoSupport (implements javax.management.openmbean.OpenMBeanAttributeInfo)
      • javax.management.MBeanConstructorInfo (implements java.lang.Cloneable)
        • javax.management.modelmbean.ModelMBeanConstructorInfo (implements javax.management.DescriptorAccess)
        • javax.management.openmbean.OpenMBeanConstructorInfoSupport (implements javax.management.openmbean.OpenMBeanConstructorInfo)
      • javax.management.MBeanNotificationInfo (implements java.lang.Cloneable)
        • javax.management.modelmbean.ModelMBeanNotificationInfo (implements javax.management.DescriptorAccess)
      • javax.management.MBeanOperationInfo (implements java.lang.Cloneable)
        • javax.management.modelmbean.ModelMBeanOperationInfo (implements javax.management.DescriptorAccess)
        • javax.management.openmbean.OpenMBeanOperationInfoSupport (implements javax.management.openmbean.OpenMBeanOperationInfo)
      • javax.management.MBeanParameterInfo (implements java.lang.Cloneable)
        • javax.management.openmbean.OpenMBeanParameterInfoSupport (implements javax.management.openmbean.OpenMBeanParameterInfo)
    • javax.management.MBeanInfo (implements java.lang.Cloneable, javax.management.DescriptorRead, java.io.Serializable)
      • javax.management.modelmbean.ModelMBeanInfoSupport (implements javax.management.modelmbean.ModelMBeanInfo)
      • javax.management.openmbean.OpenMBeanInfoSupport (implements javax.management.openmbean.OpenMBeanInfo)
    • javax.management.MBeanServerBuilder
    • javax.management.namespace.MBeanServerConnectionWrapper (implements javax.management.MBeanServer)
    • javax.management.MBeanServerDelegate (implements javax.management.MBeanServerDelegateMBean, javax.management.NotificationEmitter)
    • javax.management.MBeanServerFactory
    • javax.management.MBeanServerInvocationHandler (implements java.lang.reflect.InvocationHandler)
    • javax.management.namespace.MBeanServerSupport (implements javax.management.MBeanServer)
    • javax.print.attribute.standard.MediaPrintableArea (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • javax.print.attribute.standard.MediaSize.Engineering
    • javax.print.attribute.standard.MediaSize.ISO
    • javax.print.attribute.standard.MediaSize.JIS
    • javax.print.attribute.standard.MediaSize.NA
    • javax.print.attribute.standard.MediaSize.Other
    • java.awt.MediaTracker (implements java.io.Serializable)
    • java.nio.channels.MembershipKey
    • java.awt.image.MemoryImageSource (implements java.awt.image.ImageProducer)
    • java.lang.management.MemoryNotificationInfo
    • java.lang.management.MemoryUsage
    • java.awt.MenuComponent (implements java.io.Serializable)
      • java.awt.MenuBar (implements javax.accessibility.Accessible, java.awt.MenuContainer)
      • java.awt.MenuItem (implements javax.accessibility.Accessible)
        • java.awt.CheckboxMenuItem (implements javax.accessibility.Accessible, java.awt.ItemSelectable)
        • java.awt.Menu (implements javax.accessibility.Accessible, java.awt.MenuContainer)
          • java.awt.PopupMenu
    • javax.swing.MenuSelectionManager
    • java.awt.MenuShortcut (implements java.io.Serializable)
    • java.security.MessageDigestSpi
      • java.security.MessageDigest
    • javax.xml.soap.MessageFactory
    • org.ietf.jgss.MessageProp
    • javax.swing.plaf.metal.MetalBorders
    • javax.swing.plaf.metal.MetalCheckBoxIcon (implements javax.swing.Icon, java.io.Serializable, javax.swing.plaf.UIResource)
    • javax.swing.plaf.metal.MetalComboBoxIcon (implements javax.swing.Icon, java.io.Serializable)
    • javax.swing.plaf.metal.MetalIconFactory (implements java.io.Serializable)
    • javax.swing.plaf.metal.MetalIconFactory.FileIcon16 (implements javax.swing.Icon, java.io.Serializable)
      • javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon
    • javax.swing.plaf.metal.MetalIconFactory.FolderIcon16 (implements javax.swing.Icon, java.io.Serializable)
      • javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon
    • javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon (implements javax.swing.Icon, java.io.Serializable, javax.swing.plaf.UIResource)
    • javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon (implements javax.swing.Icon, java.io.Serializable)
    • javax.swing.plaf.metal.MetalTheme
      • javax.swing.plaf.metal.DefaultMetalTheme
        • javax.swing.plaf.metal.OceanTheme
    • sun.dyn.MethodHandleImpl
      • java.dyn.MethodHandle
        • sun.dyn.BoundMethodHandle
          • java.dyn.JavaMethodHandle
    • java.dyn.MethodHandles
    • java.dyn.MethodHandles.Lookup
    • java.dyn.MethodType
    • java.security.spec.MGF1ParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.sound.midi.MidiDevice.Info
    • javax.sound.midi.spi.MidiDeviceProvider
    • javax.sound.midi.MidiEvent
    • javax.sound.midi.MidiFileFormat
    • javax.sound.midi.spi.MidiFileReader
    • javax.sound.midi.spi.MidiFileWriter
    • javax.sound.midi.MidiMessage (implements java.lang.Cloneable)
      • javax.sound.midi.MetaMessage
      • javax.sound.midi.ShortMessage
      • javax.sound.midi.SysexMessage
    • javax.sound.midi.MidiSystem
    • javax.xml.soap.MimeHeader
    • javax.xml.soap.MimeHeaders
    • javax.activation.MimeType (implements java.io.Externalizable)
    • javax.activation.MimeTypeParameterList
    • javax.sound.sampled.Mixer.Info
    • javax.sound.sampled.spi.MixerProvider
    • javax.management.loading.MLetContent
    • javax.naming.directory.ModificationItem (implements java.io.Serializable)
    • java.lang.reflect.Modifier
    • java.awt.event.MouseAdapter (implements java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.awt.event.MouseWheelListener)
      • javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler
      • javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler
      • javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener
      • javax.swing.plaf.basic.BasicScrollBarUI.ArrowButtonListener
      • javax.swing.plaf.basic.BasicScrollBarUI.TrackListener (implements java.awt.event.MouseMotionListener)
      • javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler (implements java.awt.event.MouseMotionListener)
      • javax.swing.plaf.basic.BasicTabbedPaneUI.MouseHandler
      • javax.swing.plaf.basic.BasicTreeUI.MouseHandler (implements java.awt.event.MouseMotionListener)
      • javax.swing.text.html.FormView.MouseEventListener
      • javax.swing.text.html.HTMLEditorKit.LinkController (implements java.awt.event.MouseMotionListener, java.io.Serializable)
      • javax.swing.plaf.metal.MetalFileChooserUI.SingleClickListener
      • javax.swing.event.MouseInputAdapter (implements javax.swing.event.MouseInputListener)
        • javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler
        • javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener (implements javax.swing.SwingConstants)
        • javax.swing.plaf.basic.BasicSliderUI.TrackListener
      • javax.swing.ToolTipManager (implements java.awt.event.MouseMotionListener)
    • java.awt.MouseInfo
    • java.awt.event.MouseMotionAdapter (implements java.awt.event.MouseMotionListener)
      • javax.swing.plaf.basic.BasicComboPopup.InvocationMouseMotionHandler
      • javax.swing.plaf.basic.BasicComboPopup.ListMouseMotionHandler
    • org.omg.IOP.MultipleComponentProfileHelper
    • org.omg.IOP.MultipleComponentProfileHolder (implements org.omg.CORBA.portable.Streamable)
    • java.awt.MultipleGradientPaint (implements java.awt.Paint)
      • java.awt.LinearGradientPaint
      • java.awt.RadialGradientPaint
    • javax.management.openmbean.MXBeanMapping
    • javax.management.openmbean.MXBeanMappingFactory
    • javax.security.auth.callback.NameCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.naming.NameClassPair (implements java.io.Serializable)
      • javax.naming.Binding
        • javax.naming.directory.SearchResult
    • org.omg.CosNaming.NameComponent (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.NameComponentHelper
    • org.omg.CosNaming.NameComponentHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.NamedValue
    • org.omg.DynamicAny.NameDynAnyPair (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.NameDynAnyPairHelper
    • org.omg.DynamicAny.NameDynAnyPairSeqHelper
    • org.omg.CosNaming.NameHelper
    • org.omg.CosNaming.NameHolder (implements org.omg.CORBA.portable.Streamable)
    • org.xml.sax.helpers.NamespaceSupport
    • org.omg.CORBA.NameValuePair (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.NameValuePair (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.NameValuePairHelper
    • org.omg.DynamicAny.NameValuePairHelper
    • org.omg.DynamicAny.NameValuePairSeqHelper
    • java.rmi.Naming
    • org.omg.CosNaming.NamingContextExtHelper
    • org.omg.CosNaming.NamingContextExtHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextHelper
    • org.omg.CosNaming.NamingContextHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.naming.spi.NamingManager
      • javax.naming.spi.DirectoryManager
    • javax.swing.text.NavigationFilter
    • javax.swing.text.NavigationFilter.FilterBypass
    • java.net.NetworkInterface
    • org.omg.PortableServer.CurrentPackage.NoContextHelper
    • java.text.Normalizer
    • org.omg.PortableServer.POAPackage.NoServantHelper
    • org.omg.CosNaming.NamingContextPackage.NotEmptyHelper
    • org.omg.CosNaming.NamingContextPackage.NotEmptyHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.NotFoundHelper
    • org.omg.CosNaming.NamingContextPackage.NotFoundHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.NotFoundReason (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper
    • org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.management.NotificationBroadcasterSupport (implements javax.management.NotificationEmitter, javax.management.SendNotification)
      • javax.management.remote.JMXConnectorServer (implements javax.management.remote.JMXAddressable, javax.management.remote.JMXConnectorServerMBean, javax.management.MBeanRegistration)
        • javax.management.remote.rmi.RMIConnectorServer
      • javax.management.monitor.Monitor (implements javax.management.MBeanRegistration, javax.management.monitor.MonitorMBean)
        • javax.management.monitor.CounterMonitor (implements javax.management.monitor.CounterMonitorMBean)
        • javax.management.monitor.GaugeMonitor (implements javax.management.monitor.GaugeMonitorMBean)
        • javax.management.monitor.StringMonitor (implements javax.management.monitor.StringMonitorMBean)
      • javax.management.relation.RelationService (implements javax.management.MBeanRegistration, javax.management.NotificationListener, javax.management.relation.RelationServiceMBean)
      • javax.management.timer.Timer (implements javax.management.MBeanRegistration, javax.management.timer.TimerMBean)
    • javax.management.NotificationFilterSupport (implements javax.management.NotificationFilter)
      • javax.management.relation.MBeanServerNotificationFilter
    • javax.management.remote.NotificationResult (implements java.io.Serializable)
    • java.lang.Number (implements java.io.Serializable)
      • java.util.concurrent.atomic.AtomicInteger (implements java.io.Serializable)
      • java.util.concurrent.atomic.AtomicLong (implements java.io.Serializable)
      • java.math.BigDecimal (implements java.lang.Comparable<T>)
      • java.math.BigInteger (implements java.lang.Comparable<T>)
      • java.lang.Byte (implements java.lang.Comparable<T>)
      • java.lang.Double (implements java.lang.Comparable<T>)
      • java.lang.Float (implements java.lang.Comparable<T>)
      • java.lang.Integer (implements java.lang.Comparable<T>)
      • java.lang.Long (implements java.lang.Comparable<T>)
      • java.lang.Short (implements java.lang.Comparable<T>)
    • java.awt.font.NumericShaper (implements java.io.Serializable)
    • org.omg.CORBA.NVList
    • javax.crypto.spec.OAEPParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper
    • org.omg.CORBA.ObjectHelper
    • org.omg.CORBA.ObjectHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ObjectIdHelper
    • org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.CosNaming._BindingIteratorStub (implements org.omg.CosNaming.BindingIterator)
      • org.omg.DynamicAny._DynAnyFactoryStub (implements org.omg.DynamicAny.DynAnyFactory)
      • org.omg.DynamicAny._DynAnyStub (implements org.omg.DynamicAny.DynAny)
      • org.omg.DynamicAny._DynArrayStub (implements org.omg.DynamicAny.DynArray)
      • org.omg.DynamicAny._DynEnumStub (implements org.omg.DynamicAny.DynEnum)
      • org.omg.DynamicAny._DynFixedStub (implements org.omg.DynamicAny.DynFixed)
      • org.omg.DynamicAny._DynSequenceStub (implements org.omg.DynamicAny.DynSequence)
      • org.omg.DynamicAny._DynStructStub (implements org.omg.DynamicAny.DynStruct)
      • org.omg.DynamicAny._DynUnionStub (implements org.omg.DynamicAny.DynUnion)
      • org.omg.DynamicAny._DynValueStub (implements org.omg.DynamicAny.DynValue)
      • org.omg.CORBA._IDLTypeStub (implements org.omg.CORBA.IDLType)
      • org.omg.CosNaming._NamingContextExtStub (implements org.omg.CosNaming.NamingContextExt)
      • org.omg.CosNaming._NamingContextStub (implements org.omg.CosNaming.NamingContext)
      • org.omg.CORBA._PolicyStub (implements org.omg.CORBA.Policy)
      • org.omg.PortableServer._ServantActivatorStub (implements org.omg.PortableServer.ServantActivator)
      • org.omg.PortableServer._ServantLocatorStub (implements org.omg.PortableServer.ServantLocator)
      • org.omg.CORBA.DynamicImplementation
        • org.omg.CosNaming._BindingIteratorImplBase (implements org.omg.CosNaming.BindingIterator)
        • org.omg.CosNaming._NamingContextImplBase (implements org.omg.CosNaming.NamingContext)
      • org.omg.CORBA_2_3.portable.ObjectImpl
        • javax.rmi.CORBA.Stub (implements java.io.Serializable)
          • org.omg.stub.java.rmi._Remote_Stub (implements java.rmi.Remote)
    • java.io.ObjectInputStream.GetField
    • javax.management.ObjectInstance (implements java.io.Serializable)
    • javax.management.ObjectName (implements java.lang.Comparable<T>, javax.management.QueryExp)
    • org.omg.PortableServer.POAPackage.ObjectNotActiveHelper
    • java.io.ObjectOutputStream.PutField
    • org.omg.PortableInterceptor.ObjectReferenceFactoryHelper
    • org.omg.PortableInterceptor.ObjectReferenceFactoryHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ObjectReferenceTemplateHelper
    • org.omg.PortableInterceptor.ObjectReferenceTemplateHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper
    • org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • java.io.ObjectStreamClass (implements java.io.Serializable)
    • java.io.ObjectStreamField (implements java.lang.Comparable<T>)
    • java.rmi.server.ObjID (implements java.io.Serializable)
    • java.util.Observable
    • org.omg.CORBA.OctetSeqHelper
    • org.omg.CORBA.OctetSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.xml.crypto.OctetStreamData (implements javax.xml.crypto.Data)
    • org.ietf.jgss.Oid
    • javax.management.openmbean.OpenType<T> (implements java.io.Serializable)
      • javax.management.openmbean.ArrayType<T>
      • javax.management.openmbean.CompositeType
      • javax.management.openmbean.SimpleType<T>
      • javax.management.openmbean.TabularType
    • java.rmi.server.Operation
    • javax.swing.text.html.Option (implements java.io.Serializable)
    • org.omg.CORBA.ORB
      • org.omg.CORBA_2_3.ORB
    • org.omg.PortableInterceptor.ORBIdHelper
    • javax.xml.transform.OutputKeys
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • java.io.ByteArrayOutputStream
      • java.io.FileOutputStream
      • java.io.FilterOutputStream
        • java.io.BufferedOutputStream
        • java.util.zip.CheckedOutputStream
        • javax.crypto.CipherOutputStream
        • java.io.DataOutputStream (implements java.io.DataOutput)
        • java.util.zip.DeflaterOutputStream
          • java.util.zip.GZIPOutputStream
          • java.util.zip.ZipOutputStream
            • java.util.jar.JarOutputStream
        • java.security.DigestOutputStream
        • java.util.zip.InflaterOutputStream
        • java.io.PrintStream (implements java.lang.Appendable, java.io.Closeable)
          • java.rmi.server.LogStream
      • java.io.ObjectOutputStream (implements java.io.ObjectOutput, java.io.ObjectStreamConstants)
      • org.omg.CORBA.portable.OutputStream
        • org.omg.CORBA_2_3.portable.OutputStream
      • java.io.PipedOutputStream
    • javax.swing.OverlayLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • java.util.jar.Pack200
    • java.lang.Package (implements java.lang.reflect.AnnotatedElement)
    • java.awt.PageAttributes (implements java.lang.Cloneable)
    • java.awt.PageAttributes.ColorType
    • java.awt.PageAttributes.MediaType
    • java.awt.PageAttributes.OrientationRequestedType
    • java.awt.PageAttributes.OriginType
    • java.awt.PageAttributes.PrintQualityType
    • java.awt.print.PageFormat (implements java.lang.Cloneable)
    • java.awt.print.Paper (implements java.lang.Cloneable)
    • org.omg.Dynamic.Parameter (implements org.omg.CORBA.portable.IDLEntity)
    • java.awt.image.renderable.ParameterBlock (implements java.lang.Cloneable, java.io.Serializable)
    • org.omg.CORBA.ParameterMode (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ParameterModeHelper
    • org.omg.CORBA.ParameterModeHolder (implements org.omg.CORBA.portable.Streamable)
    • java.text.ParsePosition
    • javax.swing.text.html.parser.Parser (implements javax.swing.text.html.parser.DTDConstants)
      • javax.swing.text.html.parser.DocumentParser
    • org.xml.sax.helpers.ParserAdapter (implements org.xml.sax.DocumentHandler, org.xml.sax.XMLReader)
    • org.xml.sax.helpers.ParserFactory
    • java.net.PasswordAuthentication
    • javax.security.auth.callback.PasswordCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.sound.midi.Patch
    • java.nio.file.Path (implements java.lang.Comparable<T>, java.nio.file.FileRef, java.lang.Iterable<T>, java.nio.file.Watchable)
      • java.nio.file.spi.AbstractPath
    • java.awt.geom.Path2D (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.Path2D.Double (implements java.io.Serializable)
      • java.awt.geom.Path2D.Float (implements java.io.Serializable)
        • java.awt.geom.GeneralPath
    • java.nio.file.Paths
    • java.util.regex.Pattern (implements java.io.Serializable)
    • javax.crypto.spec.PBEKeySpec (implements java.security.spec.KeySpec)
    • javax.crypto.spec.PBEParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.AllPermission
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.sound.sampled.AudioPermission
        • javax.security.auth.AuthPermission
        • java.awt.AWTPermission
        • javax.security.auth.kerberos.DelegationPermission (implements java.io.Serializable)
        • java.dyn.LinkagePermission
        • java.nio.file.LinkPermission
        • java.util.logging.LoggingPermission
        • java.lang.management.ManagementPermission
        • javax.management.MBeanServerPermission
        • javax.management.MBeanTrustPermission
        • java.net.NetPermission
        • java.util.PropertyPermission
        • java.lang.reflect.ReflectPermission
        • java.lang.RuntimePermission
        • java.security.SecurityPermission
        • java.io.SerializablePermission
        • java.sql.SQLPermission
        • javax.net.ssl.SSLPermission
        • javax.management.remote.SubjectDelegationPermission
        • javax.xml.ws.WebServicePermission
      • java.io.FilePermission (implements java.io.Serializable)
      • javax.management.namespace.JMXNamespacePermission
      • javax.management.MBeanPermission
      • javax.security.auth.PrivateCredentialPermission
      • javax.security.auth.kerberos.ServicePermission (implements java.io.Serializable)
      • java.net.SocketPermission (implements java.io.Serializable)
      • java.security.UnresolvedPermission (implements java.io.Serializable)
    • java.security.PermissionCollection (implements java.io.Serializable)
      • java.security.Permissions (implements java.io.Serializable)
    • java.beans.PersistenceDelegate
      • java.beans.DefaultPersistenceDelegate
    • java.nio.channels.Pipe
    • java.awt.image.PixelGrabber (implements java.awt.image.ImageConsumer)
    • java.security.cert.PKIXCertPathChecker (implements java.lang.Cloneable)
    • java.security.cert.PKIXCertPathValidatorResult (implements java.security.cert.CertPathValidatorResult)
      • java.security.cert.PKIXCertPathBuilderResult (implements java.security.cert.CertPathBuilderResult)
    • java.security.cert.PKIXParameters (implements java.security.cert.CertPathParameters)
      • java.security.cert.PKIXBuilderParameters
    • org.omg.PortableServer.POAHelper
    • java.awt.geom.Point2D (implements java.lang.Cloneable)
      • java.awt.Point (implements java.io.Serializable)
      • java.awt.geom.Point2D.Double (implements java.io.Serializable)
      • java.awt.geom.Point2D.Float (implements java.io.Serializable)
    • java.awt.PointerInfo
    • java.security.Policy
    • javax.security.auth.Policy
    • org.omg.CORBA.PolicyErrorCodeHelper
    • org.omg.CORBA.PolicyErrorHelper
    • org.omg.CORBA.PolicyErrorHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.PolicyHelper
    • org.omg.CORBA.PolicyHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.PolicyListHelper
    • org.omg.CORBA.PolicyListHolder (implements org.omg.CORBA.portable.Streamable)
    • java.security.cert.PolicyQualifierInfo
    • java.security.PolicySpi
    • org.omg.CORBA.PolicyTypeHelper
    • java.awt.Polygon (implements java.io.Serializable, java.awt.Shape)
    • javax.swing.Popup
    • javax.swing.PopupFactory
    • javax.rmi.PortableRemoteObject
    • javax.swing.text.Position.Bias
    • java.nio.file.attribute.PosixFilePermissions
    • java.util.prefs.Preferences
      • java.util.prefs.AbstractPreferences
    • org.omg.CORBA.Principal
    • org.omg.CORBA.PrincipalHolder (implements org.omg.CORBA.portable.Streamable)
    • java.awt.print.PrinterJob
    • java.awt.PrintJob
    • javax.print.event.PrintJobAdapter (implements javax.print.event.PrintJobListener)
    • javax.print.PrintServiceLookup
    • java.lang.Process
    • java.lang.ProcessBuilder
    • java.lang.ProcessBuilder.Redirect
    • org.omg.IOP.ProfileIdHelper
    • javax.swing.ProgressMonitor (implements javax.accessibility.Accessible)
    • java.beans.PropertyChangeSupport (implements java.io.Serializable)
      • javax.swing.event.SwingPropertyChangeSupport
    • java.beans.PropertyEditorManager
    • java.beans.PropertyEditorSupport (implements java.beans.PropertyEditor)
    • java.security.ProtectionDomain
    • javax.xml.ws.spi.Provider
    • java.security.Provider.Service
    • java.lang.reflect.Proxy (implements java.io.Serializable)
    • java.net.Proxy
    • java.net.ProxySelector
    • javax.crypto.spec.PSource
      • javax.crypto.spec.PSource.PSpecified
    • java.security.spec.PSSParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.xml.namespace.QName (implements java.io.Serializable)
    • java.awt.geom.QuadCurve2D (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.QuadCurve2D.Double (implements java.io.Serializable)
      • java.awt.geom.QuadCurve2D.Float (implements java.io.Serializable)
    • javax.management.Query
    • javax.management.QueryEval (implements java.io.Serializable)
    • javax.management.QueryNotificationFilter (implements javax.management.NotificationFilter)
    • java.util.Random (implements java.io.Serializable)
      • java.security.SecureRandom
    • java.io.RandomAccessFile (implements java.io.Closeable, java.io.DataInput, java.io.DataOutput)
    • java.awt.image.Raster
      • java.awt.image.WritableRaster
    • javax.crypto.spec.RC2ParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.RC5ParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.naming.ldap.Rdn (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.io.Reader (implements java.io.Closeable, java.lang.Readable)
      • java.io.BufferedReader
        • java.io.LineNumberReader
      • java.io.CharArrayReader
      • java.io.FilterReader
        • java.io.PushbackReader
      • java.io.InputStreamReader
        • java.io.FileReader
      • java.io.PipedReader
      • java.io.StringReader
    • java.awt.geom.RectangularShape (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.Arc2D
        • java.awt.geom.Arc2D.Double (implements java.io.Serializable)
        • java.awt.geom.Arc2D.Float (implements java.io.Serializable)
      • java.awt.geom.Ellipse2D
        • java.awt.geom.Ellipse2D.Double (implements java.io.Serializable)
        • java.awt.geom.Ellipse2D.Float (implements java.io.Serializable)
      • java.awt.geom.Rectangle2D
        • java.awt.Rectangle (implements java.io.Serializable, java.awt.Shape)
          • javax.swing.text.DefaultCaret (implements javax.swing.text.Caret, java.awt.event.FocusListener, java.awt.event.MouseListener, java.awt.event.MouseMotionListener)
            • javax.swing.plaf.basic.BasicTextUI.BasicCaret (implements javax.swing.plaf.UIResource)
        • java.awt.geom.Rectangle2D.Double (implements java.io.Serializable)
        • java.awt.geom.Rectangle2D.Float (implements java.io.Serializable)
      • java.awt.geom.RoundRectangle2D
        • java.awt.geom.RoundRectangle2D.Double (implements java.io.Serializable)
        • java.awt.geom.RoundRectangle2D.Float (implements java.io.Serializable)
    • java.util.concurrent.locks.ReentrantLock (implements java.util.concurrent.locks.Lock, java.io.Serializable)
    • java.util.concurrent.locks.ReentrantReadWriteLock (implements java.util.concurrent.locks.ReadWriteLock, java.io.Serializable)
    • java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock (implements java.util.concurrent.locks.Lock, java.io.Serializable)
    • java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock (implements java.util.concurrent.locks.Lock, java.io.Serializable)
    • javax.naming.RefAddr (implements java.io.Serializable)
      • javax.naming.BinaryRefAddr
      • javax.naming.StringRefAddr
    • java.lang.ref.Reference<T>
      • java.lang.ref.PhantomReference<T>
      • java.lang.ref.SoftReference<T>
      • java.lang.ref.WeakReference<T>
    • javax.naming.Reference (implements java.lang.Cloneable, java.io.Serializable)
      • javax.naming.LinkRef
    • java.lang.ref.ReferenceQueue<T>
    • javax.swing.plaf.synth.Region
    • javax.management.relation.RelationSupport (implements javax.management.MBeanRegistration, javax.management.relation.RelationSupportMBean)
    • javax.management.relation.RelationTypeSupport (implements javax.management.relation.RelationType)
    • java.rmi.server.RemoteObject (implements java.rmi.Remote, java.io.Serializable)
      • java.rmi.server.RemoteObjectInvocationHandler (implements java.lang.reflect.InvocationHandler)
      • java.rmi.server.RemoteServer
        • java.rmi.activation.Activatable
        • java.rmi.server.UnicastRemoteObject
          • java.rmi.activation.ActivationGroup (implements java.rmi.activation.ActivationInstantiator)
      • java.rmi.server.RemoteStub
        • java.rmi.activation.ActivationGroup_Stub (implements java.rmi.activation.ActivationInstantiator, java.rmi.Remote)
        • javax.management.remote.rmi.RMIConnectionImpl_Stub (implements javax.management.remote.rmi.RMIConnection)
        • javax.management.remote.rmi.RMIServerImpl_Stub (implements javax.management.remote.rmi.RMIServer)
    • java.awt.image.renderable.RenderableImageOp (implements java.awt.image.renderable.RenderableImage)
    • java.awt.image.renderable.RenderableImageProducer (implements java.awt.image.ImageProducer, java.lang.Runnable)
    • java.awt.image.renderable.RenderContext (implements java.lang.Cloneable)
    • java.awt.RenderingHints (implements java.lang.Cloneable, java.util.Map<K,V>)
    • java.awt.RenderingHints.Key
    • javax.swing.RepaintManager
    • org.omg.CORBA.RepositoryIdHelper
    • org.omg.CORBA.Request
    • org.omg.PortableServer.RequestProcessingPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • javax.management.modelmbean.RequiredModelMBean (implements javax.management.DynamicWrapperMBean, javax.management.MBeanRegistration, javax.management.modelmbean.ModelMBean, javax.management.NotificationEmitter)
    • java.awt.image.RescaleOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • javax.print.attribute.ResolutionSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.PrinterResolution (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • javax.naming.spi.ResolveResult (implements java.io.Serializable)
    • java.util.ResourceBundle
      • java.util.ListResourceBundle
        • javax.accessibility.AccessibleResourceBundle
      • java.util.PropertyResourceBundle
    • java.util.ResourceBundle.Control
    • java.net.ResponseCache
    • javax.sound.sampled.ReverbType
    • java.rmi.server.RMIClassLoader
    • java.rmi.server.RMIClassLoaderSpi
    • javax.management.remote.rmi.RMIConnectionImpl (implements javax.management.remote.rmi.RMIConnection, java.rmi.server.Unreferenced)
    • javax.management.remote.rmi.RMIConnector (implements javax.management.remote.JMXAddressable, javax.management.remote.JMXConnector, java.io.Serializable)
    • javax.management.event.RMIPushEventForwarder (implements javax.management.event.EventForwarder)
    • javax.management.event.RMIPushEventRelay (implements javax.management.event.EventRelay)
    • javax.management.remote.rmi.RMIServerImpl (implements java.io.Closeable, javax.management.remote.rmi.RMIServer)
      • javax.management.remote.rmi.RMIIIOPServerImpl
      • javax.management.remote.rmi.RMIJRMPServerImpl
    • java.rmi.server.RMISocketFactory (implements java.rmi.server.RMIClientSocketFactory, java.rmi.server.RMIServerSocketFactory)
    • java.awt.Robot
    • javax.management.relation.Role (implements java.io.Serializable)
    • javax.management.relation.RoleInfo (implements java.io.Serializable)
    • javax.management.relation.RoleResult (implements java.io.Serializable)
    • javax.management.relation.RoleStatus
    • javax.management.relation.RoleUnresolved (implements java.io.Serializable)
    • javax.swing.RowFilter<M,I>
    • javax.swing.RowFilter.Entry<M,I>
    • javax.sql.rowset.RowSetMetaDataImpl (implements javax.sql.RowSetMetaData, java.io.Serializable)
    • javax.swing.RowSorter<M>
      • javax.swing.DefaultRowSorter<M,I>
        • javax.swing.table.TableRowSorter<M>
    • javax.swing.RowSorter.SortKey
    • java.security.spec.RSAKeyGenParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.security.spec.RSAOtherPrimeInfo
    • java.security.spec.RSAPrivateKeySpec (implements java.security.spec.KeySpec)
      • java.security.spec.RSAMultiPrimePrivateCrtKeySpec
      • java.security.spec.RSAPrivateCrtKeySpec
    • java.security.spec.RSAPublicKeySpec (implements java.security.spec.KeySpec)
    • java.lang.Runtime
    • javax.xml.soap.SAAJMetaFactory
    • java.awt.image.SampleModel
      • java.awt.image.ComponentSampleModel
        • java.awt.image.BandedSampleModel
        • java.awt.image.PixelInterleavedSampleModel
      • java.awt.image.MultiPixelPackedSampleModel
      • java.awt.image.SinglePixelPackedSampleModel
    • javax.security.sasl.Sasl
    • javax.xml.parsers.SAXParser
    • javax.xml.parsers.SAXParserFactory
    • javax.xml.transform.sax.SAXResult (implements javax.xml.transform.Result)
      • javax.xml.bind.util.JAXBResult
    • javax.xml.transform.sax.SAXSource (implements javax.xml.transform.Source)
      • javax.xml.bind.util.JAXBSource
    • java.util.Scanner (implements java.util.Iterator<E>)
    • javax.xml.validation.Schema
    • javax.xml.validation.SchemaFactory
    • javax.xml.validation.SchemaFactoryLoader
    • javax.xml.bind.SchemaOutputResolver
    • javax.script.ScriptEngineManager
    • java.awt.ScrollPaneAdjustable (implements java.awt.Adjustable, java.io.Serializable)
    • javax.swing.ScrollPaneLayout (implements java.awt.LayoutManager, javax.swing.ScrollPaneConstants, java.io.Serializable)
      • javax.swing.ScrollPaneLayout.UIResource (implements javax.swing.plaf.UIResource)
    • javax.crypto.SealedObject (implements java.io.Serializable)
    • javax.naming.directory.SearchControls (implements java.io.Serializable)
    • javax.crypto.SecretKeyFactory
    • javax.crypto.SecretKeyFactorySpi
    • javax.crypto.spec.SecretKeySpec (implements java.security.spec.KeySpec, javax.crypto.SecretKey)
    • java.nio.file.SecureDirectoryStream (implements java.nio.file.DirectoryStream<T>)
    • java.security.SecureRandomSpi (implements java.io.Serializable)
    • java.security.Security
    • java.lang.SecurityManager
      • java.rmi.RMISecurityManager
    • javax.swing.text.Segment (implements java.text.CharacterIterator, java.lang.CharSequence, java.lang.Cloneable)
    • java.nio.channels.SelectionKey
      • java.nio.channels.spi.AbstractSelectionKey
    • java.nio.channels.Selector
      • java.nio.channels.spi.AbstractSelector
    • java.nio.channels.spi.SelectorProvider
    • java.util.concurrent.Semaphore (implements java.io.Serializable)
    • javax.sound.midi.Sequence
    • javax.sound.midi.Sequencer.SyncMode
    • javax.sql.rowset.serial.SerialArray (implements java.sql.Array, java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialBlob (implements java.sql.Blob, java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialClob (implements java.sql.Clob, java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialDatalink (implements java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialJavaObject (implements java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialRef (implements java.lang.Cloneable, java.sql.Ref, java.io.Serializable)
    • javax.sql.rowset.serial.SerialStruct (implements java.lang.Cloneable, java.io.Serializable, java.sql.Struct)
    • org.omg.PortableServer.Servant
      • org.omg.CosNaming.BindingIteratorPOA (implements org.omg.CosNaming.BindingIteratorOperations, org.omg.CORBA.portable.InvokeHandler)
      • org.omg.PortableServer.DynamicImplementation
      • org.omg.CosNaming.NamingContextExtPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.CosNaming.NamingContextExtOperations)
      • org.omg.CosNaming.NamingContextPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.CosNaming.NamingContextOperations)
      • org.omg.PortableServer.ServantActivatorPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocatorPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.PortableServer.ServantLocatorOperations)
    • org.omg.PortableServer.ServantActivatorHelper
    • org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper
    • org.omg.PortableServer.ServantLocatorHelper
    • org.omg.PortableServer.POAPackage.ServantNotActiveHelper
    • org.omg.CORBA.portable.ServantObject
    • org.omg.PortableServer.ServantRetentionPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.ServerIdHelper
    • org.omg.CORBA.ServerRequest
    • java.net.ServerSocket (implements java.io.Closeable)
      • javax.net.ssl.SSLServerSocket
    • javax.net.ServerSocketFactory
      • javax.net.ssl.SSLServerSocketFactory
    • javax.xml.ws.Service
    • org.omg.IOP.ServiceContext (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.ServiceContextHelper
    • org.omg.IOP.ServiceContextHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.ServiceContextListHelper
    • org.omg.IOP.ServiceContextListHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.xml.ws.spi.ServiceDelegate
    • org.omg.CORBA.ServiceDetail (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ServiceDetailHelper
    • org.omg.IOP.ServiceIdHelper
    • org.omg.CORBA.ServiceInformation (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ServiceInformationHelper
    • org.omg.CORBA.ServiceInformationHolder (implements org.omg.CORBA.portable.Streamable)
    • java.util.ServiceLoader<S> (implements java.lang.Iterable<T>)
    • javax.imageio.spi.ServiceRegistry
      • javax.imageio.spi.IIORegistry
    • javax.print.ServiceUI
    • javax.print.ServiceUIFactory
    • javax.print.attribute.SetOfIntegerSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.CopiesSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.JobImpressionsSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.JobKOctetsSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.JobMediaSheetsSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.NumberUpSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.PageRanges (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • org.omg.CORBA.SetOverrideType (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.SetOverrideTypeHelper
    • org.omg.CORBA.ShortHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ShortSeqHelper
    • org.omg.CORBA.ShortSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • java.security.SignatureSpi
      • java.security.Signature
    • java.security.SignedObject (implements java.io.Serializable)
    • javax.swing.text.SimpleAttributeSet (implements java.lang.Cloneable, javax.swing.text.MutableAttributeSet, java.io.Serializable)
    • java.beans.SimpleBeanInfo (implements java.beans.BeanInfo)
    • javax.script.SimpleBindings (implements javax.script.Bindings)
    • javax.print.SimpleDoc (implements javax.print.Doc)
    • java.nio.file.SimpleFileVisitor<T> (implements java.nio.file.FileVisitor<T>)
    • javax.tools.SimpleJavaFileObject (implements javax.tools.JavaFileObject)
    • javax.script.SimpleScriptContext (implements javax.script.ScriptContext)
    • javax.print.attribute.Size2DSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.MediaSize (implements javax.print.attribute.Attribute)
    • javax.swing.SizeRequirements (implements java.io.Serializable)
    • javax.swing.SizeSequence
    • javax.xml.soap.SOAPConnection
    • javax.xml.soap.SOAPConnectionFactory
    • javax.xml.soap.SOAPElementFactory
    • javax.xml.soap.SOAPFactory
    • javax.xml.soap.SOAPMessage
    • javax.xml.soap.SOAPPart (implements org.w3c.dom.Document, javax.xml.soap.Node)
    • java.net.Socket (implements java.io.Closeable)
      • javax.net.ssl.SSLSocket
    • java.net.SocketAddress (implements java.io.Serializable)
      • java.net.InetSocketAddress
    • javax.net.SocketFactory
      • javax.net.ssl.SSLSocketFactory
    • java.net.SocketImpl (implements java.net.SocketOptions)
    • javax.naming.ldap.SortKey
    • javax.sound.midi.spi.SoundbankReader
    • javax.sound.midi.SoundbankResource
      • javax.sound.midi.Instrument
    • java.awt.SplashScreen
    • javax.swing.Spring
    • javax.swing.SpringLayout (implements java.awt.LayoutManager2)
    • javax.swing.SpringLayout.Constraints
    • javax.sql.rowset.serial.SQLInputImpl (implements java.sql.SQLInput)
    • javax.sql.rowset.serial.SQLOutputImpl (implements java.sql.SQLOutput)
    • javax.net.ssl.SSLContext
    • javax.net.ssl.SSLContextSpi
    • javax.net.ssl.SSLEngine
    • javax.net.ssl.SSLEngineResult
    • javax.net.ssl.SSLParameters
    • javax.rmi.ssl.SslRMIClientSocketFactory (implements java.rmi.server.RMIClientSocketFactory, java.io.Serializable)
    • javax.rmi.ssl.SslRMIServerSocketFactory (implements java.rmi.server.RMIServerSocketFactory)
    • java.lang.StackTraceElement (implements java.io.Serializable)
    • javax.management.StandardMBean (implements javax.management.DynamicWrapperMBean, javax.management.MBeanRegistration)
      • javax.management.StandardEmitterMBean (implements javax.management.NotificationEmitter, javax.management.SendNotification)
    • java.net.StandardSocketOption
    • java.nio.file.StandardWatchEventKind
    • javax.naming.ldap.StartTlsRequest (implements javax.naming.ldap.ExtendedRequest)
    • javax.naming.ldap.StartTlsResponse (implements javax.naming.ldap.ExtendedResponse)
    • org.omg.PortableServer.POAManagerPackage.State (implements org.omg.CORBA.portable.IDLEntity)
    • java.beans.Statement
      • java.beans.Expression
    • javax.xml.transform.stax.StAXResult (implements javax.xml.transform.Result)
    • javax.xml.transform.stax.StAXSource (implements javax.xml.transform.Source)
    • javax.print.StreamPrintService (implements javax.print.PrintService)
    • javax.print.StreamPrintServiceFactory
    • javax.xml.stream.util.StreamReaderDelegate (implements javax.xml.stream.XMLStreamReader)
    • javax.xml.transform.stream.StreamResult (implements javax.xml.transform.Result)
    • javax.xml.transform.stream.StreamSource (implements javax.xml.transform.Source)
    • java.io.StreamTokenizer
    • java.lang.StrictMath
    • java.lang.String (implements java.lang.CharSequence, java.lang.Comparable<T>, java.io.Serializable)
    • java.lang.StringBuffer (implements java.lang.CharSequence, java.io.Serializable)
    • java.lang.StringBuilder (implements java.lang.CharSequence, java.io.Serializable)
    • java.text.StringCharacterIterator (implements java.text.CharacterIterator)
    • javax.swing.text.StringContent (implements javax.swing.text.AbstractDocument.Content, java.io.Serializable)
    • org.omg.CORBA.StringHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextExtPackage.StringNameHelper
    • java.awt.datatransfer.StringSelection (implements java.awt.datatransfer.ClipboardOwner, java.awt.datatransfer.Transferable)
    • org.omg.CORBA.StringSeqHelper
    • org.omg.CORBA.StringSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • java.util.StringTokenizer (implements java.util.Enumeration<E>)
    • javax.management.StringValueExp (implements javax.management.ValueExp)
    • org.omg.CORBA.StringValueHelper (implements org.omg.CORBA.portable.BoxedValueHelper)
    • org.omg.CORBA.StructMember (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.StructMemberHelper
    • javax.swing.text.StyleConstants
      • javax.swing.text.StyleConstants.CharacterConstants (implements javax.swing.text.AttributeSet.CharacterAttribute)
      • javax.swing.text.StyleConstants.ColorConstants (implements javax.swing.text.AttributeSet.CharacterAttribute, javax.swing.text.AttributeSet.ColorAttribute)
      • javax.swing.text.StyleConstants.FontConstants (implements javax.swing.text.AttributeSet.CharacterAttribute, javax.swing.text.AttributeSet.FontAttribute)
      • javax.swing.text.StyleConstants.ParagraphConstants (implements javax.swing.text.AttributeSet.ParagraphAttribute)
    • javax.swing.text.StyleContext (implements javax.swing.text.AbstractDocument.AttributeContext, java.io.Serializable)
      • javax.swing.text.html.StyleSheet
    • javax.swing.text.StyleContext.NamedStyle (implements java.io.Serializable, javax.swing.text.Style)
    • javax.swing.text.StyleContext.SmallAttributeSet (implements javax.swing.text.AttributeSet)
    • javax.swing.text.html.StyleSheet.BoxPainter (implements java.io.Serializable)
    • javax.swing.text.html.StyleSheet.ListPainter (implements java.io.Serializable)
    • javax.security.auth.Subject (implements java.io.Serializable)
    • javax.security.auth.SubjectDomainCombiner (implements java.security.DomainCombiner)
    • javax.swing.SwingUtilities (implements javax.swing.SwingConstants)
    • javax.swing.SwingWorker<T,V> (implements java.util.concurrent.RunnableFuture<V>)
    • javax.sql.rowset.spi.SyncFactory
    • javax.sql.rowset.spi.SyncProvider
    • org.omg.Messaging.SyncScopeHelper
    • javax.swing.plaf.synth.SynthContext
    • javax.swing.plaf.synth.SynthGraphicsUtils
    • javax.swing.plaf.synth.SynthPainter
    • javax.swing.plaf.synth.SynthStyle
    • javax.swing.plaf.synth.SynthStyleFactory
    • java.lang.System
    • java.awt.datatransfer.SystemFlavorMap (implements java.awt.datatransfer.FlavorMap, java.awt.datatransfer.FlavorTable)
    • java.awt.SystemTray
    • javax.swing.table.TableColumn (implements java.io.Serializable)
    • javax.swing.table.TableStringConverter
    • javax.swing.text.TabSet (implements java.io.Serializable)
    • javax.swing.text.TabStop (implements java.io.Serializable)
    • javax.management.openmbean.TabularDataSupport (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable, javax.management.openmbean.TabularData)
    • javax.swing.text.html.parser.TagElement
    • org.omg.IOP.TaggedComponent (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.TaggedComponentHelper
    • org.omg.IOP.TaggedComponentHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.TaggedProfile (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.TaggedProfileHelper
    • org.omg.IOP.TaggedProfileHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.management.remote.TargetedNotification (implements java.io.Serializable)
    • org.omg.CORBA.TCKind
    • java.awt.font.TextHitInfo
    • javax.security.auth.callback.TextInputCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
      • javax.security.sasl.RealmCallback
    • java.awt.font.TextLayout (implements java.lang.Cloneable)
    • java.awt.font.TextLayout.CaretPolicy
    • java.awt.font.TextMeasurer (implements java.lang.Cloneable)
    • javax.security.auth.callback.TextOutputCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.print.attribute.TextSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.DocumentName (implements javax.print.attribute.DocAttribute)
      • javax.print.attribute.standard.JobMessageFromOperator (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobName (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobOriginatingUserName (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.OutputDeviceAssigned (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.PrinterInfo (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterLocation (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterMakeAndModel (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterMessageFromOperator (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterName (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.RequestingUserName (implements javax.print.attribute.PrintRequestAttribute)
    • java.awt.TexturePaint (implements java.awt.Paint)
    • java.lang.Thread (implements java.lang.Runnable)
    • java.lang.ThreadGroup (implements java.lang.Thread.UncaughtExceptionHandler)
    • java.lang.management.ThreadInfo
    • java.lang.ThreadLocal<T>
      • java.lang.InheritableThreadLocal<T>
    • org.omg.PortableServer.ThreadPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • java.util.concurrent.ThreadPoolExecutor.AbortPolicy (implements java.util.concurrent.RejectedExecutionHandler)
    • java.util.concurrent.ThreadPoolExecutor.CallerRunsPolicy (implements java.util.concurrent.RejectedExecutionHandler)
    • java.util.concurrent.ThreadPoolExecutor.DiscardOldestPolicy (implements java.util.concurrent.RejectedExecutionHandler)
    • java.util.concurrent.ThreadPoolExecutor.DiscardPolicy (implements java.util.concurrent.RejectedExecutionHandler)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • java.lang.annotation.AnnotationFormatError
        • java.lang.AssertionError
        • java.awt.AWTError
        • java.nio.charset.CoderMalfunctionError
        • javax.xml.parsers.FactoryConfigurationError
        • javax.xml.stream.FactoryConfigurationError
        • java.io.IOError
        • java.lang.LinkageError
          • java.lang.ClassCircularityError
          • java.lang.ClassFormatError
            • java.lang.reflect.GenericSignatureFormatError
            • java.lang.UnsupportedClassVersionError
          • java.lang.ExceptionInInitializerError
          • java.lang.IncompatibleClassChangeError
            • java.lang.AbstractMethodError
            • java.lang.IllegalAccessError
            • java.lang.InstantiationError
            • java.lang.NoSuchFieldError
            • java.lang.NoSuchMethodError
          • java.dyn.InvokeDynamicBootstrapError
          • java.lang.NoClassDefFoundError
          • java.lang.UnsatisfiedLinkError
          • java.lang.VerifyError
        • java.util.ServiceConfigurationError
        • java.lang.ThreadDeath
        • javax.xml.transform.TransformerFactoryConfigurationError
        • java.lang.VirtualMachineError
          • java.lang.InternalError
            • java.util.zip.ZipError
          • java.lang.OutOfMemoryError
          • java.lang.StackOverflowError
          • java.lang.UnknownError
      • java.lang.Exception
        • java.security.acl.AclNotFoundException
        • java.rmi.activation.ActivationException
          • java.rmi.activation.UnknownGroupException
          • java.rmi.activation.UnknownObjectException
        • java.rmi.AlreadyBoundException
        • org.omg.CORBA.portable.ApplicationException
        • java.awt.AWTException
        • java.util.prefs.BackingStoreException
        • javax.management.BadAttributeValueExpException
        • javax.management.BadBinaryOpValueExpException
        • javax.swing.text.BadLocationException
        • javax.management.BadStringOperationException
        • java.util.concurrent.BrokenBarrierException
        • javax.security.cert.CertificateException
          • javax.security.cert.CertificateEncodingException
          • javax.security.cert.CertificateExpiredException
          • javax.security.cert.CertificateNotYetValidException
          • javax.security.cert.CertificateParsingException
        • java.lang.ClassNotFoundException
        • java.lang.CloneNotSupportedException
          • java.rmi.server.ServerCloneException
        • java.util.zip.DataFormatException
        • javax.xml.datatype.DatatypeConfigurationException
        • javax.security.auth.DestroyFailedException
        • java.util.concurrent.ExecutionException
        • javax.swing.tree.ExpandVetoException
        • java.awt.FontFormatException
        • java.security.GeneralSecurityException
          • javax.crypto.BadPaddingException
          • java.security.cert.CertificateException
            • java.security.cert.CertificateEncodingException
            • java.security.cert.CertificateExpiredException
            • java.security.cert.CertificateNotYetValidException
            • java.security.cert.CertificateParsingException
            • java.security.cert.CertificateRevokedException
          • java.security.cert.CertPathBuilderException
          • java.security.cert.CertPathValidatorException
          • java.security.cert.CertStoreException
          • java.security.cert.CRLException
          • java.security.DigestException
          • javax.crypto.ExemptionMechanismException
          • javax.crypto.IllegalBlockSizeException
          • java.security.InvalidAlgorithmParameterException
          • java.security.spec.InvalidKeySpecException
          • java.security.spec.InvalidParameterSpecException
          • java.security.KeyException
            • java.security.InvalidKeyException
            • java.security.KeyManagementException
          • java.security.KeyStoreException
          • javax.security.auth.login.LoginException
            • javax.security.auth.login.AccountException
              • javax.security.auth.login.AccountExpiredException
              • javax.security.auth.login.AccountLockedException
              • javax.security.auth.login.AccountNotFoundException
            • javax.security.auth.login.CredentialException
              • javax.security.auth.login.CredentialExpiredException
              • javax.security.auth.login.CredentialNotFoundException
            • javax.security.auth.login.FailedLoginException
          • java.security.NoSuchAlgorithmException
          • javax.crypto.NoSuchPaddingException
          • java.security.NoSuchProviderException
          • javax.crypto.ShortBufferException
          • java.security.SignatureException
          • java.security.UnrecoverableEntryException
            • java.security.UnrecoverableKeyException
        • org.ietf.jgss.GSSException
        • java.lang.IllegalAccessException
        • java.lang.instrument.IllegalClassFormatException
        • java.lang.InstantiationException
        • java.lang.InterruptedException
        • java.beans.IntrospectionException
        • javax.management.InvalidApplicationException
        • javax.sound.midi.InvalidMidiDataException
        • java.util.prefs.InvalidPreferencesFormatException
        • javax.management.modelmbean.InvalidTargetObjectTypeException
        • java.lang.reflect.InvocationTargetException
        • java.io.IOException
          • javax.swing.text.ChangedCharSetException
          • java.nio.charset.CharacterCodingException
            • java.nio.charset.MalformedInputException
            • java.nio.charset.UnmappableCharacterException
          • java.io.CharConversionException
          • java.nio.channels.ClosedChannelException
            • java.nio.channels.AsynchronousCloseException
              • java.nio.channels.ClosedByInterruptException
          • java.io.EOFException
          • java.nio.channels.FileLockInterruptionException
          • java.io.FileNotFoundException
          • javax.annotation.processing.FilerException
          • java.nio.file.FileSystemException
            • java.nio.file.AccessDeniedException
            • java.nio.file.AtomicMoveNotSupportedException
            • java.nio.file.DirectoryNotEmptyException
            • java.nio.file.FileAlreadyExistsException
            • java.nio.file.NoSuchFileException
            • java.nio.file.NotDirectoryException
            • java.nio.file.NotLinkException
          • java.net.HttpRetryException
          • javax.imageio.IIOException
            • javax.imageio.metadata.IIOInvalidTreeException
          • java.nio.channels.InterruptedByTimeoutException
          • java.io.InterruptedIOException
            • java.net.SocketTimeoutException
          • java.util.InvalidPropertiesFormatException
          • javax.management.remote.JMXProviderException
          • javax.management.remote.JMXServerErrorException
          • java.net.MalformedURLException
          • java.io.ObjectStreamException
            • java.io.InvalidClassException
            • java.io.InvalidObjectException
            • java.io.NotActiveException
            • java.io.NotSerializableException
            • java.io.OptionalDataException
            • java.io.StreamCorruptedException
            • java.io.WriteAbortedException
          • java.net.ProtocolException
          • java.rmi.RemoteException
            • java.rmi.AccessException
            • java.rmi.activation.ActivateFailedException
            • javax.activity.ActivityCompletedException
            • javax.activity.ActivityRequiredException
            • java.rmi.ConnectException
            • java.rmi.ConnectIOException
            • java.rmi.server.ExportException
              • java.rmi.server.SocketSecurityException
            • javax.activity.InvalidActivityException
            • javax.transaction.InvalidTransactionException
            • java.rmi.MarshalException
            • java.rmi.NoSuchObjectException
            • java.rmi.ServerError
            • java.rmi.ServerException
            • java.rmi.ServerRuntimeException
            • java.rmi.server.SkeletonMismatchException
            • java.rmi.server.SkeletonNotFoundException
            • java.rmi.StubNotFoundException
            • javax.transaction.TransactionRequiredException
            • javax.transaction.TransactionRolledbackException
            • java.rmi.UnexpectedException
            • java.rmi.UnknownHostException
            • java.rmi.UnmarshalException
          • javax.security.sasl.SaslException
            • javax.security.sasl.AuthenticationException
          • java.net.SocketException
            • java.net.BindException
            • java.net.ConnectException
            • java.net.NoRouteToHostException
            • java.net.PortUnreachableException
          • javax.net.ssl.SSLException
            • javax.net.ssl.SSLHandshakeException
            • javax.net.ssl.SSLKeyException
            • javax.net.ssl.SSLPeerUnverifiedException
            • javax.net.ssl.SSLProtocolException
          • java.io.SyncFailedException
          • java.net.UnknownHostException
          • java.net.UnknownServiceException
          • javax.activation.UnsupportedDataTypeException
          • java.io.UnsupportedEncodingException
          • java.nio.file.attribute.UserPrincipalNotFoundException
          • java.io.UTFDataFormatException
          • java.util.zip.ZipException
            • java.util.jar.JarException
        • javax.xml.bind.JAXBException
          • javax.xml.bind.MarshalException
          • javax.xml.bind.PropertyException
          • javax.xml.bind.UnmarshalException
          • javax.xml.bind.ValidationException
        • javax.management.JMException
          • javax.management.event.EventClientNotFoundException
          • javax.management.MBeanException
            • javax.management.GenericMBeanException
            • javax.management.MBeanRegistrationException
          • javax.management.openmbean.OpenDataException
          • javax.management.OperationsException
            • javax.management.AttributeNotFoundException
            • javax.management.InstanceAlreadyExistsException
            • javax.management.InstanceNotFoundException
            • javax.management.IntrospectionException
            • javax.management.InvalidAttributeValueException
            • javax.management.ListenerNotFoundException
            • javax.management.MalformedObjectNameException
            • javax.management.NotCompliantMBeanException
            • javax.management.ServiceNotFoundException
          • javax.management.ReflectionException
          • javax.management.relation.RelationException
            • javax.management.relation.InvalidRelationIdException
            • javax.management.relation.InvalidRelationServiceException
            • javax.management.relation.InvalidRelationTypeException
            • javax.management.relation.InvalidRoleInfoException
            • javax.management.relation.InvalidRoleValueException
            • javax.management.relation.RelationNotFoundException
            • javax.management.relation.RelationServiceNotRegisteredException
            • javax.management.relation.RelationTypeNotFoundException
            • javax.management.relation.RoleInfoNotFoundException
            • javax.management.relation.RoleNotFoundException
        • javax.xml.crypto.KeySelectorException
        • java.security.acl.LastOwnerException
        • javax.sound.sampled.LineUnavailableException
        • javax.xml.crypto.MarshalException
        • javax.sound.midi.MidiUnavailableException
        • java.awt.datatransfer.MimeTypeParseException
        • javax.activation.MimeTypeParseException
        • javax.naming.NamingException
          • javax.naming.directory.AttributeInUseException
          • javax.naming.directory.AttributeModificationException
          • javax.naming.CannotProceedException
          • javax.naming.CommunicationException
          • javax.naming.ConfigurationException
          • javax.naming.ContextNotEmptyException
          • javax.naming.InsufficientResourcesException
          • javax.naming.InterruptedNamingException
          • javax.naming.directory.InvalidAttributeIdentifierException
          • javax.naming.directory.InvalidAttributesException
          • javax.naming.directory.InvalidAttributeValueException
          • javax.naming.InvalidNameException
          • javax.naming.directory.InvalidSearchControlsException
          • javax.naming.directory.InvalidSearchFilterException
          • javax.naming.LimitExceededException
            • javax.naming.SizeLimitExceededException
            • javax.naming.TimeLimitExceededException
          • javax.naming.LinkException
            • javax.naming.LinkLoopException
            • javax.naming.MalformedLinkException
          • javax.naming.NameAlreadyBoundException
          • javax.naming.NameNotFoundException
          • javax.naming.NamingSecurityException
            • javax.naming.AuthenticationException
            • javax.naming.AuthenticationNotSupportedException
            • javax.naming.NoPermissionException
          • javax.naming.NoInitialContextException
          • javax.naming.directory.NoSuchAttributeException
          • javax.naming.NotContextException
          • javax.naming.OperationNotSupportedException
          • javax.naming.PartialResultException
          • javax.naming.ReferralException
            • javax.naming.ldap.LdapReferralException
          • javax.naming.directory.SchemaViolationException
          • javax.naming.ServiceUnavailableException
        • java.awt.geom.NoninvertibleTransformException
        • java.lang.NoSuchFieldException
        • java.lang.NoSuchMethodException
        • java.rmi.NotBoundException
        • java.security.acl.NotOwnerException
        • java.text.ParseException
        • javax.xml.parsers.ParserConfigurationException
        • java.awt.print.PrinterException
          • java.awt.print.PrinterAbortException
          • java.awt.print.PrinterIOException
        • javax.print.PrintException
        • java.security.PrivilegedActionException
        • java.beans.PropertyVetoException
        • javax.security.auth.RefreshFailedException
        • org.omg.CORBA.portable.RemarshalException
        • java.lang.RuntimeException
          • java.lang.annotation.AnnotationTypeMismatchException
          • java.lang.ArithmeticException
          • java.lang.ArrayStoreException
          • java.nio.BufferOverflowException
          • java.nio.BufferUnderflowException
          • javax.swing.undo.CannotRedoException
          • javax.swing.undo.CannotUndoException
          • java.lang.ClassCastException
          • java.awt.color.CMMException
          • java.util.ConcurrentModificationException
          • javax.xml.bind.DataBindingException
          • org.w3c.dom.DOMException
          • java.util.EmptyStackException
          • java.lang.EnumConstantNotPresentException
          • org.w3c.dom.events.EventException
          • java.nio.file.FileSystemAlreadyExistsException
          • java.nio.file.FileSystemNotFoundException
          • java.lang.IllegalArgumentException
            • java.nio.channels.IllegalChannelGroupException
            • java.nio.charset.IllegalCharsetNameException
            • java.util.IllegalFormatException
              • java.util.DuplicateFormatFlagsException
              • java.util.FormatFlagsConversionMismatchException
              • java.util.IllegalFormatCodePointException
              • java.util.IllegalFormatConversionException
              • java.util.IllegalFormatFlagsException
              • java.util.IllegalFormatPrecisionException
              • java.util.IllegalFormatWidthException
              • java.util.MissingFormatArgumentException
              • java.util.MissingFormatWidthException
              • java.util.UnknownFormatConversionException
              • java.util.UnknownFormatFlagsException
            • java.nio.channels.IllegalSelectorException
            • java.lang.IllegalThreadStateException
            • javax.management.openmbean.InvalidKeyException
            • javax.management.openmbean.InvalidOpenTypeException
            • java.security.InvalidParameterException
            • java.nio.file.InvalidPathException
            • javax.management.openmbean.KeyAlreadyExistsException
            • java.lang.NumberFormatException
            • java.util.regex.PatternSyntaxException
            • java.nio.file.ProviderMismatchException
            • java.nio.channels.UnresolvedAddressException
            • java.nio.channels.UnsupportedAddressTypeException
            • java.nio.charset.UnsupportedCharsetException
          • java.lang.IllegalMonitorStateException
          • java.awt.geom.IllegalPathStateException
          • java.lang.IllegalStateException
            • java.nio.channels.AcceptPendingException
            • java.nio.channels.AlreadyBoundException
            • java.nio.channels.AlreadyConnectedException
            • java.util.concurrent.CancellationException
            • java.nio.channels.CancelledKeyException
            • java.nio.file.ClosedDirectoryStreamException
            • java.nio.file.ClosedFileSystemException
            • java.nio.channels.ClosedSelectorException
            • java.nio.file.ClosedWatchServiceException
            • java.nio.channels.ConnectionPendingException
            • java.util.FormatterClosedException
            • java.nio.channels.IllegalBlockingModeException
            • java.awt.IllegalComponentStateException
            • java.awt.dnd.InvalidDnDOperationException
            • java.nio.InvalidMarkException
            • java.nio.channels.NoConnectionPendingException
            • java.nio.channels.NonReadableChannelException
            • java.nio.channels.NonWritableChannelException
            • java.nio.channels.NotYetBoundException
            • java.nio.channels.NotYetConnectedException
            • java.nio.channels.OverlappingFileLockException
            • java.nio.channels.ReadPendingException
            • java.nio.channels.ShutdownChannelGroupException
            • java.nio.channels.WritePendingException
          • java.awt.image.ImagingOpException
          • java.lang.annotation.IncompleteAnnotationException
          • java.lang.IndexOutOfBoundsException
            • java.lang.ArrayIndexOutOfBoundsException
            • java.lang.StringIndexOutOfBoundsException
          • javax.management.JMRuntimeException
            • javax.management.monitor.MonitorSettingException
            • javax.management.RuntimeErrorException
            • javax.management.RuntimeMBeanException
            • javax.management.RuntimeOperationsException
          • org.w3c.dom.ls.LSException
          • java.lang.reflect.MalformedParameterizedTypeException
          • javax.lang.model.type.MirroredTypeException
          • javax.lang.model.type.MirroredTypesException
          • java.util.MissingResourceException
          • java.lang.NegativeArraySizeException
          • java.dyn.NoAccessException
          • java.util.NoSuchElementException
            • java.util.InputMismatchException
          • javax.xml.crypto.NoSuchMechanismException
          • java.lang.NullPointerException
          • java.awt.color.ProfileDataException
          • java.security.ProviderException
          • java.nio.file.ProviderNotFoundException
          • java.awt.image.RasterFormatException
          • java.util.concurrent.RejectedExecutionException
          • java.lang.SecurityException
            • java.security.AccessControlException
            • java.rmi.RMISecurityException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.ACTIVITY_COMPLETED
            • org.omg.CORBA.ACTIVITY_REQUIRED
            • org.omg.CORBA.BAD_CONTEXT
            • org.omg.CORBA.BAD_INV_ORDER
            • org.omg.CORBA.BAD_OPERATION
            • org.omg.CORBA.BAD_PARAM
            • org.omg.CORBA.BAD_QOS
            • org.omg.CORBA.BAD_TYPECODE
            • org.omg.CORBA.CODESET_INCOMPATIBLE
            • org.omg.CORBA.COMM_FAILURE
            • org.omg.CORBA.DATA_CONVERSION
            • org.omg.CORBA.FREE_MEM
            • org.omg.CORBA.IMP_LIMIT
            • org.omg.CORBA.portable.IndirectionException
            • org.omg.CORBA.INITIALIZE
            • org.omg.CORBA.INTERNAL
            • org.omg.CORBA.INTF_REPOS
            • org.omg.CORBA.INV_FLAG
            • org.omg.CORBA.INV_IDENT
            • org.omg.CORBA.INV_OBJREF
            • org.omg.CORBA.INV_POLICY
            • org.omg.CORBA.INVALID_ACTIVITY
            • org.omg.CORBA.INVALID_TRANSACTION
            • org.omg.CORBA.MARSHAL
            • org.omg.CORBA.NO_IMPLEMENT
            • org.omg.CORBA.NO_MEMORY
            • org.omg.CORBA.NO_PERMISSION
            • org.omg.CORBA.NO_RESOURCES
            • org.omg.CORBA.NO_RESPONSE
            • org.omg.CORBA.OBJ_ADAPTER
            • org.omg.CORBA.OBJECT_NOT_EXIST
            • org.omg.CORBA.PERSIST_STORE
            • org.omg.CORBA.REBIND
            • org.omg.CORBA.TIMEOUT
            • org.omg.CORBA.TRANSACTION_MODE
            • org.omg.CORBA.TRANSACTION_REQUIRED
            • org.omg.CORBA.TRANSACTION_ROLLEDBACK
            • org.omg.CORBA.TRANSACTION_UNAVAILABLE
            • org.omg.CORBA.TRANSIENT
            • org.omg.CORBA.UNKNOWN
            • org.omg.CORBA.portable.UnknownException
          • javax.xml.bind.TypeConstraintException
          • java.lang.TypeNotPresentException
          • java.lang.reflect.UndeclaredThrowableException
          • javax.lang.model.UnknownEntityException
            • javax.lang.model.element.UnknownAnnotationValueException
            • javax.lang.model.element.UnknownElementException
            • javax.lang.model.type.UnknownTypeException
          • javax.print.attribute.UnmodifiableSetException
          • java.lang.UnsupportedOperationException
            • java.awt.HeadlessException
            • java.nio.ReadOnlyBufferException
            • java.nio.file.ReadOnlyFileSystemException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
              • javax.xml.ws.http.HTTPException
              • javax.xml.ws.soap.SOAPFaultException
          • java.dyn.WrongMethodTypeException
        • org.xml.sax.SAXException
          • org.xml.sax.SAXNotRecognizedException
          • org.xml.sax.SAXNotSupportedException
          • org.xml.sax.SAXParseException
        • javax.script.ScriptException
        • java.rmi.server.ServerNotActiveException
        • javax.xml.soap.SOAPException
        • java.sql.SQLException (implements java.lang.Iterable<T>)
          • java.sql.BatchUpdateException
          • javax.sql.rowset.RowSetWarning
          • javax.sql.rowset.serial.SerialException
          • java.sql.SQLClientInfoException
          • java.sql.SQLNonTransientException
            • java.sql.SQLDataException
            • java.sql.SQLFeatureNotSupportedException
            • java.sql.SQLIntegrityConstraintViolationException
            • java.sql.SQLInvalidAuthorizationSpecException
            • java.sql.SQLNonTransientConnectionException
            • java.sql.SQLSyntaxErrorException
          • java.sql.SQLRecoverableException
          • java.sql.SQLTransientException
            • java.sql.SQLTimeoutException
            • java.sql.SQLTransactionRollbackException
            • java.sql.SQLTransientConnectionException
          • java.sql.SQLWarning
            • java.sql.DataTruncation
          • javax.sql.rowset.spi.SyncFactoryException
          • javax.sql.rowset.spi.SyncProviderException
        • java.util.concurrent.TimeoutException
        • java.util.TooManyListenersException
        • javax.xml.transform.TransformerException
          • javax.xml.transform.TransformerConfigurationException
        • javax.xml.crypto.dsig.TransformException
        • java.lang.instrument.UnmodifiableClassException
        • javax.sound.sampled.UnsupportedAudioFileException
        • javax.security.auth.callback.UnsupportedCallbackException
        • java.awt.datatransfer.UnsupportedFlavorException
        • javax.swing.UnsupportedLookAndFeelException
        • javax.xml.crypto.URIReferenceException
        • java.net.URISyntaxException
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableServer.POAPackage.AdapterAlreadyExists
          • org.omg.PortableServer.POAManagerPackage.AdapterInactive
          • org.omg.PortableServer.POAPackage.AdapterNonExistent
          • org.omg.CosNaming.NamingContextPackage.AlreadyBound
          • org.omg.CORBA.TypeCodePackage.BadKind
          • org.omg.CORBA.Bounds
          • org.omg.CORBA.TypeCodePackage.Bounds
          • org.omg.CosNaming.NamingContextPackage.CannotProceed
          • org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName
          • org.omg.IOP.CodecPackage.FormatMismatch
          • org.omg.PortableServer.ForwardRequest
          • org.omg.PortableInterceptor.ForwardRequest
          • org.omg.CORBA.ORBPackage.InconsistentTypeCode
          • org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode
          • org.omg.CORBA.DynAnyPackage.Invalid
          • org.omg.CosNaming.NamingContextExtPackage.InvalidAddress
          • org.omg.CORBA.ORBPackage.InvalidName
          • org.omg.CosNaming.NamingContextPackage.InvalidName
          • org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName
          • org.omg.PortableServer.POAPackage.InvalidPolicy
          • org.omg.CORBA.DynAnyPackage.InvalidSeq
          • org.omg.PortableInterceptor.InvalidSlot
          • org.omg.IOP.CodecPackage.InvalidTypeForEncoding
          • org.omg.CORBA.DynAnyPackage.InvalidValue
          • org.omg.DynamicAny.DynAnyPackage.InvalidValue
          • org.omg.PortableServer.CurrentPackage.NoContext
          • org.omg.PortableServer.POAPackage.NoServant
          • org.omg.CosNaming.NamingContextPackage.NotEmpty
          • org.omg.CosNaming.NamingContextPackage.NotFound
          • org.omg.PortableServer.POAPackage.ObjectAlreadyActive
          • org.omg.PortableServer.POAPackage.ObjectNotActive
          • org.omg.CORBA.PolicyError
          • org.omg.PortableServer.POAPackage.ServantAlreadyActive
          • org.omg.PortableServer.POAPackage.ServantNotActive
          • org.omg.CORBA.DynAnyPackage.TypeMismatch
          • org.omg.IOP.CodecPackage.TypeMismatch
          • org.omg.DynamicAny.DynAnyPackage.TypeMismatch
          • org.omg.IOP.CodecFactoryPackage.UnknownEncoding
          • org.omg.CORBA.UnknownUserException
          • org.omg.PortableServer.POAPackage.WrongAdapter
          • org.omg.PortableServer.POAPackage.WrongPolicy
          • org.omg.CORBA.WrongTransaction
        • javax.transaction.xa.XAException
        • javax.management.modelmbean.XMLParseException
        • javax.xml.crypto.dsig.XMLSignatureException
        • javax.xml.stream.XMLStreamException
        • javax.xml.xpath.XPathException
          • javax.xml.xpath.XPathExpressionException
            • javax.xml.xpath.XPathFunctionException
          • javax.xml.xpath.XPathFactoryConfigurationException
    • java.util.Timer
    • javax.swing.Timer (implements java.io.Serializable)
    • java.util.TimerTask (implements java.lang.Runnable)
    • java.security.Timestamp (implements java.io.Serializable)
    • java.util.TimeZone (implements java.lang.Cloneable, java.io.Serializable)
      • java.util.SimpleTimeZone
    • java.awt.Toolkit
    • javax.tools.ToolProvider
    • javax.swing.ToolTipManager.insideTimerAction (implements java.awt.event.ActionListener)
    • javax.swing.ToolTipManager.outsideTimerAction (implements java.awt.event.ActionListener)
    • javax.swing.ToolTipManager.stillInsideTimerAction (implements java.awt.event.ActionListener)
    • javax.sound.midi.Track
    • javax.swing.TransferHandler (implements java.io.Serializable)
    • javax.swing.TransferHandler.DropLocation
      • javax.swing.JList.DropLocation
      • javax.swing.JTable.DropLocation
      • javax.swing.text.JTextComponent.DropLocation
      • javax.swing.JTree.DropLocation
    • javax.swing.TransferHandler.TransferSupport
    • java.awt.font.TransformAttribute (implements java.io.Serializable)
    • javax.xml.transform.Transformer
    • javax.xml.transform.TransformerFactory
      • javax.xml.transform.sax.SAXTransformerFactory
    • javax.xml.crypto.dsig.TransformService (implements javax.xml.crypto.dsig.Transform)
    • java.awt.TrayIcon
    • javax.swing.tree.TreePath (implements java.io.Serializable)
    • java.security.cert.TrustAnchor
    • javax.net.ssl.TrustManagerFactory
    • javax.net.ssl.TrustManagerFactorySpi
    • org.omg.CORBA.TypeCode (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.TypeCodeHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.xml.validation.TypeInfoProvider
    • org.omg.IOP.CodecPackage.TypeMismatchHelper
    • org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper
    • java.sql.Types
    • java.rmi.server.UID (implements java.io.Serializable)
    • javax.swing.UIDefaults.LazyInputMap (implements javax.swing.UIDefaults.LazyValue)
    • javax.swing.UIDefaults.ProxyLazyValue (implements javax.swing.UIDefaults.LazyValue)
    • javax.swing.UIManager (implements java.io.Serializable)
    • javax.swing.UIManager.LookAndFeelInfo
    • org.omg.CORBA.ULongLongSeqHelper
    • org.omg.CORBA.ULongLongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ULongSeqHelper
    • org.omg.CORBA.ULongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.swing.undo.UndoableEditSupport
    • org.omg.CORBA.UnionMember (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.UnionMemberHelper
    • org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper
    • org.omg.CORBA.UnknownUserExceptionHelper
    • org.omg.CORBA.UnknownUserExceptionHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.xml.bind.Unmarshaller.Listener
    • java.net.URI (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.security.URIParameter (implements javax.security.auth.login.Configuration.Parameters, java.security.Policy.Parameters)
    • javax.print.attribute.URISyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.Destination (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.PrinterMoreInfo (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterMoreInfoManufacturer (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterURI (implements javax.print.attribute.PrintServiceAttribute)
    • java.net.URL (implements java.io.Serializable)
    • java.net.URLConnection
      • java.net.HttpURLConnection
        • javax.net.ssl.HttpsURLConnection
      • java.net.JarURLConnection
    • javax.activation.URLDataSource (implements javax.activation.DataSource)
    • java.net.URLDecoder
    • java.net.URLEncoder
    • java.net.URLStreamHandler
    • org.omg.CosNaming.NamingContextExtPackage.URLStringHelper
    • java.nio.file.attribute.UserPrincipalLookupService
    • org.omg.CORBA.UShortSeqHelper
    • org.omg.CORBA.UShortSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.rmi.CORBA.Util
    • javax.swing.text.Utilities
    • java.util.UUID (implements java.lang.Comparable<T>, java.io.Serializable)
    • javax.xml.bind.util.ValidationEventCollector (implements javax.xml.bind.ValidationEventHandler)
    • javax.xml.bind.helpers.ValidationEventImpl (implements javax.xml.bind.ValidationEvent)
      • javax.xml.bind.helpers.NotIdentifiableEventImpl (implements javax.xml.bind.NotIdentifiableEvent)
      • javax.xml.bind.helpers.ParseConversionEventImpl (implements javax.xml.bind.ParseConversionEvent)
      • javax.xml.bind.helpers.PrintConversionEventImpl (implements javax.xml.bind.PrintConversionEvent)
    • javax.xml.bind.helpers.ValidationEventLocatorImpl (implements javax.xml.bind.ValidationEventLocator)
    • javax.xml.validation.Validator
    • javax.xml.validation.ValidatorHandler (implements org.xml.sax.ContentHandler)
    • org.omg.CORBA.ValueBaseHelper
    • org.omg.CORBA.ValueBaseHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ValueMember (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ValueMemberHelper
    • org.omg.CORBA.VersionSpecHelper
    • java.beans.VetoableChangeSupport (implements java.io.Serializable)
    • javax.swing.text.View (implements javax.swing.SwingConstants)
      • javax.swing.text.AsyncBoxView
      • javax.swing.text.ComponentView
        • javax.swing.text.html.FormView (implements java.awt.event.ActionListener)
        • javax.swing.text.html.ObjectView
      • javax.swing.text.CompositeView
        • javax.swing.text.BoxView
          • javax.swing.text.html.BlockView
            • javax.swing.text.html.ListView
          • javax.swing.text.FlowView
            • javax.swing.text.ParagraphView (implements javax.swing.text.TabExpander)
              • javax.swing.text.html.ParagraphView
          • javax.swing.text.TableView
          • javax.swing.text.TableView.TableCell
          • javax.swing.text.TableView.TableRow
          • javax.swing.text.WrappedPlainView (implements javax.swing.text.TabExpander)
          • javax.swing.text.ZoneView
      • javax.swing.text.GlyphView (implements java.lang.Cloneable, javax.swing.text.TabableView)
        • javax.swing.text.LabelView (implements javax.swing.text.TabableView)
          • javax.swing.text.html.InlineView
      • javax.swing.text.IconView
      • javax.swing.text.html.ImageView
      • javax.swing.text.PlainView (implements javax.swing.text.TabExpander)
        • javax.swing.text.FieldView
          • javax.swing.text.PasswordView
    • javax.swing.ViewportLayout (implements java.awt.LayoutManager, java.io.Serializable)
    • javax.management.namespace.VirtualEventManager (implements javax.management.event.EventConsumer)
    • org.omg.CORBA.VisibilityHelper
    • java.rmi.dgc.VMID (implements java.io.Serializable)
    • javax.sound.midi.VoiceStatus
    • java.lang.Void
    • javax.xml.bind.annotation.W3CDomHandler (implements javax.xml.bind.annotation.DomHandler<ElementT,ResultT>)
    • javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder
    • java.nio.file.WatchEvent<T>
    • java.nio.file.WatchKey
    • java.nio.file.WatchService (implements java.io.Closeable)
    • org.omg.CORBA.WCharSeqHelper
    • org.omg.CORBA.WCharSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.xml.ws.WebServiceFeature
      • javax.xml.ws.soap.AddressingFeature
      • javax.xml.ws.soap.MTOMFeature
      • javax.xml.ws.RespectBindingFeature
    • java.awt.event.WindowAdapter (implements java.awt.event.WindowFocusListener, java.awt.event.WindowListener, java.awt.event.WindowStateListener)
      • javax.swing.plaf.basic.BasicToolBarUI.FrameListener
      • javax.swing.JMenu.WinListener (implements java.io.Serializable)
    • java.io.Writer (implements java.lang.Appendable, java.io.Closeable, java.io.Flushable)
      • java.io.BufferedWriter
      • java.io.CharArrayWriter
      • java.io.FilterWriter
      • java.io.OutputStreamWriter
        • java.io.FileWriter
      • java.io.PipedWriter
      • java.io.PrintWriter
      • java.io.StringWriter
    • org.omg.PortableServer.POAPackage.WrongAdapterHelper
    • org.omg.PortableServer.POAPackage.WrongPolicyHelper
    • org.omg.CORBA.WrongTransactionHelper
    • org.omg.CORBA.WrongTransactionHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.WStringSeqHelper
    • org.omg.CORBA.WStringSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.WStringValueHelper (implements org.omg.CORBA.portable.BoxedValueHelper)
    • javax.security.auth.x500.X500Principal (implements java.security.Principal, java.io.Serializable)
    • javax.security.auth.x500.X500PrivateCredential (implements javax.security.auth.Destroyable)
    • java.security.cert.X509CertSelector (implements java.security.cert.CertSelector)
    • java.security.cert.X509CRLEntry (implements java.security.cert.X509Extension)
    • java.security.cert.X509CRLSelector (implements java.security.cert.CRLSelector)
    • javax.net.ssl.X509ExtendedKeyManager (implements javax.net.ssl.X509KeyManager)
    • javax.xml.bind.annotation.adapters.XmlAdapter<ValueType,BoundType>
      • javax.xml.bind.annotation.adapters.CollapsedStringAdapter
      • javax.xml.bind.annotation.adapters.HexBinaryAdapter
      • javax.xml.bind.annotation.adapters.NormalizedStringAdapter
    • javax.xml.XMLConstants
    • java.beans.XMLDecoder
    • javax.xml.bind.annotation.XmlElement.DEFAULT
    • javax.xml.bind.annotation.XmlElementDecl.GLOBAL
    • javax.xml.bind.annotation.XmlElementRef.DEFAULT
    • javax.xml.stream.XMLEventFactory
    • org.xml.sax.helpers.XMLFilterImpl (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler, org.xml.sax.XMLFilter)
    • javax.xml.datatype.XMLGregorianCalendar (implements java.lang.Cloneable)
    • javax.xml.stream.XMLInputFactory
    • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT
    • javax.xml.stream.XMLOutputFactory
    • org.xml.sax.helpers.XMLReaderAdapter (implements org.xml.sax.ContentHandler, org.xml.sax.Parser)
    • org.xml.sax.helpers.XMLReaderFactory
    • javax.xml.bind.annotation.XmlSchemaType.DEFAULT
    • javax.xml.crypto.dsig.XMLSignatureFactory
    • javax.xml.bind.annotation.XmlType.DEFAULT
    • javax.xml.xpath.XPathConstants
    • javax.xml.xpath.XPathFactory
    • javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec (implements javax.xml.crypto.dsig.spec.TransformParameterSpec)
    • javax.xml.crypto.dsig.spec.XPathFilterParameterSpec (implements javax.xml.crypto.dsig.spec.TransformParameterSpec)
    • javax.xml.crypto.dsig.spec.XPathType
    • javax.xml.crypto.dsig.spec.XPathType.Filter
    • javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec (implements javax.xml.crypto.dsig.spec.TransformParameterSpec)
    • java.util.zip.ZipEntry (implements java.lang.Cloneable)
      • java.util.jar.JarEntry
    • java.util.zip.ZipFile
      • java.util.jar.JarFile

Interface Hierarchy

  • javax.swing.text.AbstractDocument.AttributeContext
  • javax.swing.text.AbstractDocument.Content
  • javax.accessibility.Accessible
  • javax.accessibility.AccessibleAction
  • javax.accessibility.AccessibleComponent
    • javax.accessibility.AccessibleExtendedComponent
  • javax.accessibility.AccessibleExtendedText
  • javax.accessibility.AccessibleIcon
  • javax.accessibility.AccessibleKeyBinding
  • javax.accessibility.AccessibleSelection
  • javax.accessibility.AccessibleStreamable
  • javax.accessibility.AccessibleTable
    • javax.accessibility.AccessibleExtendedTable
  • javax.accessibility.AccessibleTableModelChange
  • javax.accessibility.AccessibleText
    • javax.accessibility.AccessibleEditableText
    • javax.accessibility.AccessibleHypertext
  • javax.accessibility.AccessibleValue
  • org.omg.PortableInterceptor.ACTIVE
  • java.awt.ActiveEvent
  • org.omg.PortableServer.AdapterActivatorOperations
    • org.omg.PortableServer.AdapterActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • java.awt.Adjustable
  • javax.xml.crypto.AlgorithmMethod
    • javax.xml.crypto.dsig.CanonicalizationMethod
    • javax.xml.crypto.dsig.DigestMethod (also extends javax.xml.crypto.XMLStructure)
    • javax.xml.crypto.dsig.SignatureMethod (also extends javax.xml.crypto.XMLStructure)
    • javax.xml.crypto.dsig.Transform (also extends javax.xml.crypto.XMLStructure)
      • javax.xml.crypto.dsig.CanonicalizationMethod
  • java.security.spec.AlgorithmParameterSpec
    • javax.xml.crypto.dsig.spec.C14NMethodParameterSpec
    • javax.xml.crypto.dsig.spec.DigestMethodParameterSpec
    • javax.xml.crypto.dsig.spec.SignatureMethodParameterSpec
    • javax.xml.crypto.dsig.spec.TransformParameterSpec
      • javax.xml.crypto.dsig.spec.C14NMethodParameterSpec
  • java.lang.reflect.AnnotatedElement
  • java.lang.annotation.Annotation
  • javax.lang.model.element.AnnotationMirror
  • javax.lang.model.element.AnnotationValue
  • javax.lang.model.element.AnnotationValueVisitor<R,P>
  • java.lang.Appendable
  • java.applet.AppletContext
  • java.beans.AppletInitializer
  • java.applet.AppletStub
  • org.omg.CORBA.ARG_IN
  • org.omg.CORBA.ARG_INOUT
  • org.omg.CORBA.ARG_OUT
  • java.sql.Array
  • javax.xml.ws.AsyncHandler<T>
  • javax.print.AttributeException
  • org.xml.sax.AttributeList
  • org.xml.sax.Attributes
    • org.xml.sax.ext.Attributes2
  • javax.print.attribute.AttributeSet
    • javax.print.attribute.DocAttributeSet
    • javax.print.attribute.PrintJobAttributeSet
    • javax.print.attribute.PrintRequestAttributeSet
    • javax.print.attribute.PrintServiceAttributeSet
  • javax.swing.text.AttributeSet
    • javax.swing.text.MutableAttributeSet
      • javax.swing.text.Style
    • javax.swing.text.Style
  • javax.swing.text.AttributeSet.CharacterAttribute
  • javax.swing.text.AttributeSet.ColorAttribute
  • javax.swing.text.AttributeSet.FontAttribute
  • javax.swing.text.AttributeSet.ParagraphAttribute
  • java.nio.file.attribute.AttributeView
    • java.nio.file.attribute.AclFileAttributeView
    • java.nio.file.attribute.BasicFileAttributeView
      • java.nio.file.attribute.DosFileAttributeView
      • java.nio.file.attribute.PosixFileAttributeView (also extends java.nio.file.attribute.FileOwnerAttributeView)
    • java.nio.file.attribute.DosFileAttributeView
    • java.nio.file.attribute.FileAttributeView
      • java.nio.file.attribute.AclFileAttributeView
      • java.nio.file.attribute.BasicFileAttributeView
        • java.nio.file.attribute.DosFileAttributeView
        • java.nio.file.attribute.PosixFileAttributeView (also extends java.nio.file.attribute.FileOwnerAttributeView)
      • java.nio.file.attribute.DosFileAttributeView
      • java.nio.file.attribute.FileOwnerAttributeView
        • java.nio.file.attribute.AclFileAttributeView
        • java.nio.file.attribute.PosixFileAttributeView (also extends java.nio.file.attribute.BasicFileAttributeView)
      • java.nio.file.attribute.PosixFileAttributeView (also extends java.nio.file.attribute.BasicFileAttributeView, java.nio.file.attribute.FileOwnerAttributeView)
      • java.nio.file.attribute.UserDefinedFileAttributeView
    • java.nio.file.attribute.FileOwnerAttributeView
      • java.nio.file.attribute.AclFileAttributeView
      • java.nio.file.attribute.PosixFileAttributeView (also extends java.nio.file.attribute.BasicFileAttributeView)
    • java.nio.file.attribute.FileStoreAttributeView
      • java.nio.file.attribute.FileStoreSpaceAttributeView
    • java.nio.file.attribute.FileStoreSpaceAttributeView
    • java.nio.file.attribute.PosixFileAttributeView (also extends java.nio.file.attribute.BasicFileAttributeView, java.nio.file.attribute.FileOwnerAttributeView)
    • java.nio.file.attribute.UserDefinedFileAttributeView
  • java.applet.AudioClip
  • java.awt.dnd.Autoscroll
  • org.omg.CORBA.BAD_POLICY
  • org.omg.CORBA.BAD_POLICY_TYPE
  • org.omg.CORBA.BAD_POLICY_VALUE
  • java.nio.file.attribute.BasicFileAttributes
    • java.nio.file.attribute.DosFileAttributes
    • java.nio.file.attribute.PosixFileAttributes
  • java.beans.beancontext.BeanContextChild
    • java.beans.beancontext.BeanContext (also extends java.util.Collection<E>, java.beans.DesignMode, java.beans.Visibility)
      • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContextServicesListener)
    • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContext, java.beans.beancontext.BeanContextServicesListener)
  • java.beans.beancontext.BeanContextChildComponentProxy
  • java.beans.beancontext.BeanContextContainerProxy
  • java.beans.beancontext.BeanContextProxy
  • java.beans.beancontext.BeanContextServiceProvider
  • java.beans.BeanInfo
    • java.beans.beancontext.BeanContextServiceProviderBeanInfo
  • javax.xml.ws.Binding
    • javax.xml.ws.http.HTTPBinding
    • javax.xml.ws.soap.SOAPBinding
  • org.omg.CosNaming.BindingIteratorOperations
    • org.omg.CosNaming.BindingIterator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • javax.xml.ws.BindingProvider
    • javax.xml.ws.Dispatch<T>
  • java.sql.Blob
  • javax.swing.border.Border
  • javax.swing.BoundedRangeModel
  • org.omg.CORBA.portable.BoxedValueHelper
  • java.awt.image.BufferedImageOp
  • java.util.concurrent.Callable<V>
    • javax.tools.JavaCompiler.CompilationTask
  • javax.security.auth.callback.Callback
  • javax.security.auth.callback.CallbackHandler
  • javax.swing.text.Caret
  • javax.swing.CellEditor
    • javax.swing.table.TableCellEditor
    • javax.swing.tree.TreeCellEditor
  • java.security.Certificate
  • java.lang.CharSequence
    • javax.lang.model.element.Name
  • java.util.zip.Checksum
  • java.lang.instrument.ClassFileTransformer
  • javax.management.loading.ClassLoaderRepository
  • java.awt.datatransfer.ClipboardOwner
  • java.sql.Clob
    • java.sql.NClob
  • java.lang.Cloneable
    • java.security.acl.AclEntry
    • javax.naming.directory.Attribute (also extends java.io.Serializable)
    • java.text.AttributedCharacterIterator
    • javax.naming.directory.Attributes (also extends java.io.Serializable)
    • java.security.cert.CertPathBuilderResult
    • java.security.cert.CertPathParameters
    • java.security.cert.CertPathValidatorResult
    • java.security.cert.CertSelector
    • java.security.cert.CertStoreParameters
    • java.text.CharacterIterator
      • java.text.AttributedCharacterIterator
    • java.security.cert.CRLSelector
    • javax.management.Descriptor (also extends java.io.Serializable)
    • org.ietf.jgss.GSSCredential
    • javax.naming.Name (also extends java.lang.Comparable<T>, java.io.Serializable)
  • java.io.Closeable
    • java.nio.channels.AsynchronousByteChannel
    • java.nio.channels.AsynchronousChannel
      • java.nio.channels.AsynchronousByteChannel
    • java.nio.channels.ByteChannel (also extends java.nio.channels.ReadableByteChannel, java.nio.channels.WritableByteChannel)
      • java.nio.channels.SeekableByteChannel
    • java.nio.channels.Channel
      • java.nio.channels.AsynchronousByteChannel
      • java.nio.channels.AsynchronousChannel
        • java.nio.channels.AsynchronousByteChannel
      • java.nio.channels.ByteChannel (also extends java.nio.channels.ReadableByteChannel, java.nio.channels.WritableByteChannel)
        • java.nio.channels.SeekableByteChannel
      • java.nio.channels.GatheringByteChannel
      • java.nio.channels.InterruptibleChannel
      • java.nio.channels.MulticastChannel
      • java.nio.channels.NetworkChannel
        • java.nio.channels.MulticastChannel
      • java.nio.channels.ReadableByteChannel
        • java.nio.channels.ByteChannel (also extends java.nio.channels.WritableByteChannel)
          • java.nio.channels.SeekableByteChannel
        • java.nio.channels.ScatteringByteChannel
        • java.nio.channels.SeekableByteChannel
      • java.nio.channels.ScatteringByteChannel
      • java.nio.channels.SeekableByteChannel
      • java.nio.channels.WritableByteChannel
        • java.nio.channels.ByteChannel (also extends java.nio.channels.ReadableByteChannel)
          • java.nio.channels.SeekableByteChannel
        • java.nio.channels.GatheringByteChannel
        • java.nio.channels.SeekableByteChannel
    • java.nio.file.DirectoryStream<T> (also extends java.lang.Iterable<T>)
    • java.nio.channels.GatheringByteChannel
    • java.nio.channels.InterruptibleChannel
    • javax.tools.JavaFileManager (also extends java.io.Flushable, javax.tools.OptionChecker)
      • javax.tools.StandardJavaFileManager
    • javax.management.remote.JMXConnector
    • java.nio.channels.MulticastChannel
    • java.nio.channels.NetworkChannel
      • java.nio.channels.MulticastChannel
    • java.nio.channels.ReadableByteChannel
      • java.nio.channels.ByteChannel (also extends java.nio.channels.WritableByteChannel)
        • java.nio.channels.SeekableByteChannel
      • java.nio.channels.ScatteringByteChannel
      • java.nio.channels.SeekableByteChannel
    • javax.management.remote.rmi.RMIConnection (also extends java.rmi.Remote)
    • java.nio.channels.ScatteringByteChannel
    • java.nio.channels.SeekableByteChannel
    • javax.tools.StandardJavaFileManager
    • java.nio.channels.WritableByteChannel
      • java.nio.channels.ByteChannel (also extends java.nio.channels.ReadableByteChannel)
        • java.nio.channels.SeekableByteChannel
      • java.nio.channels.GatheringByteChannel
      • java.nio.channels.SeekableByteChannel
  • org.omg.IOP.CodecFactoryOperations
    • org.omg.IOP.CodecFactory (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.IOP.CodecOperations
    • org.omg.IOP.Codec (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.IOP.CodeSets
  • javax.swing.colorchooser.ColorSelectionModel
  • javax.swing.ComboBoxEditor
  • javax.swing.plaf.basic.ComboPopup
  • javax.activation.CommandObject
  • javax.sql.CommonDataSource
    • javax.sql.ConnectionPoolDataSource
    • javax.sql.DataSource (also extends java.sql.Wrapper)
    • javax.sql.XADataSource
  • java.lang.Comparable<T>
    • java.util.concurrent.Delayed
      • java.util.concurrent.RunnableScheduledFuture<V> (also extends java.util.concurrent.RunnableFuture<V>, java.util.concurrent.ScheduledFuture<V>)
      • java.util.concurrent.ScheduledFuture<V> (also extends java.util.concurrent.Future<V>)
        • java.util.concurrent.RunnableScheduledFuture<V> (also extends java.util.concurrent.RunnableFuture<V>)
    • javax.naming.Name (also extends java.lang.Cloneable, java.io.Serializable)
    • java.util.concurrent.RunnableScheduledFuture<V> (also extends java.util.concurrent.RunnableFuture<V>, java.util.concurrent.ScheduledFuture<V>)
    • java.util.concurrent.ScheduledFuture<V> (also extends java.util.concurrent.Delayed, java.util.concurrent.Future<V>)
      • java.util.concurrent.RunnableScheduledFuture<V> (also extends java.util.concurrent.RunnableFuture<V>)
  • java.util.Comparator<T>
  • javax.script.Compilable
  • javax.annotation.processing.Completion
  • java.nio.channels.CompletionHandler<V,A>
  • java.util.concurrent.CompletionService<V>
  • java.awt.Composite
  • java.awt.CompositeContext
  • javax.management.openmbean.CompositeData
  • javax.management.openmbean.CompositeDataView
  • java.util.concurrent.locks.Condition
  • javax.security.auth.login.Configuration.Parameters
  • org.xml.sax.ContentHandler
    • javax.xml.transform.sax.TemplatesHandler
    • javax.xml.transform.sax.TransformerHandler (also extends org.xml.sax.DTDHandler, org.xml.sax.ext.LexicalHandler)
    • javax.xml.bind.UnmarshallerHandler
  • java.net.ContentHandlerFactory
  • javax.naming.Context
    • javax.naming.directory.DirContext
      • javax.naming.event.EventDirContext (also extends javax.naming.event.EventContext)
      • javax.naming.ldap.LdapContext
    • javax.naming.event.EventContext
      • javax.naming.event.EventDirContext (also extends javax.naming.directory.DirContext)
    • javax.naming.event.EventDirContext (also extends javax.naming.directory.DirContext, javax.naming.event.EventContext)
    • javax.naming.ldap.LdapContext
  • java.net.CookiePolicy
  • java.net.CookieStore
  • java.nio.file.CopyOption
  • org.omg.CORBA.CTX_RESTRICT_SCOPE
  • org.omg.CORBA.CurrentOperations
    • org.omg.CORBA.Current (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.Current (also extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.Current (also extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.Current (also extends org.omg.CORBA.Current, org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.Current (also extends org.omg.CORBA.Current, org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.CurrentOperations
      • org.omg.PortableServer.Current (also extends org.omg.CORBA.Current, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.CurrentOperations
      • org.omg.PortableInterceptor.Current (also extends org.omg.CORBA.Current, org.omg.CORBA.portable.IDLEntity)
  • java.beans.Customizer
  • org.omg.CORBA.CustomMarshal
    • org.omg.CORBA.portable.CustomValue (also extends org.omg.CORBA.portable.ValueBase)
  • javax.xml.crypto.Data
    • javax.xml.crypto.NodeSetData
  • javax.activation.DataContentHandler
  • javax.activation.DataContentHandlerFactory
  • java.net.DatagramSocketImplFactory
  • java.io.DataInput
    • javax.imageio.stream.ImageInputStream
      • javax.imageio.stream.ImageOutputStream (also extends java.io.DataOutput)
    • javax.imageio.stream.ImageOutputStream (also extends java.io.DataOutput, javax.imageio.stream.ImageInputStream)
    • java.io.ObjectInput
  • java.io.DataOutput
    • javax.imageio.stream.ImageOutputStream (also extends javax.imageio.stream.ImageInputStream)
    • java.io.ObjectOutput
  • javax.activation.DataSource
  • javax.xml.bind.DatatypeConverterInterface
  • org.xml.sax.ext.DeclHandler
  • org.omg.PortableServer.portable.Delegate
  • javax.management.DescriptorRead
    • javax.management.DescriptorAccess
  • java.beans.DesignMode
    • java.beans.beancontext.BeanContext (also extends java.beans.beancontext.BeanContextChild, java.util.Collection<E>, java.beans.Visibility)
      • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContextServicesListener)
    • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContext, java.beans.beancontext.BeanContextServicesListener)
  • javax.swing.DesktopManager
  • javax.security.auth.Destroyable
  • javax.crypto.interfaces.DHKey
    • javax.crypto.interfaces.DHPrivateKey (also extends java.security.PrivateKey)
    • javax.crypto.interfaces.DHPublicKey (also extends java.security.PublicKey)
  • javax.tools.Diagnostic<S>
  • javax.tools.DiagnosticListener<S>
  • java.nio.file.DirectoryStream.Filter<T>
  • org.omg.PortableInterceptor.DISCARDING
  • javax.print.Doc
  • javax.print.DocPrintJob
    • javax.print.CancelablePrintJob
    • javax.print.MultiDocPrintJob
  • javax.swing.text.Document
    • javax.swing.text.StyledDocument
  • javax.swing.event.DocumentEvent
  • org.w3c.dom.events.DocumentEvent
  • javax.swing.event.DocumentEvent.ElementChange
  • org.xml.sax.DocumentHandler
  • java.security.DomainCombiner
  • org.omg.CORBA.DomainManagerOperations
    • org.omg.CORBA.DomainManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.w3c.dom.DOMConfiguration
  • org.w3c.dom.DOMError
  • org.w3c.dom.DOMErrorHandler
  • javax.xml.bind.annotation.DomHandler<ElementT,ResultT>
  • org.w3c.dom.DOMImplementation
  • org.w3c.dom.DOMImplementationList
  • org.w3c.dom.ls.DOMImplementationLS
  • org.w3c.dom.DOMImplementationSource
  • org.w3c.dom.DOMLocator
  • org.w3c.dom.DOMStringList
  • java.sql.Driver
  • java.security.interfaces.DSAKey
    • java.security.interfaces.DSAPrivateKey (also extends java.security.PrivateKey)
    • java.security.interfaces.DSAPublicKey (also extends java.security.PublicKey)
  • java.security.interfaces.DSAKeyPairGenerator
  • java.security.interfaces.DSAParams
  • javax.swing.text.html.parser.DTDConstants
  • org.xml.sax.DTDHandler
    • javax.xml.transform.sax.TransformerHandler (also extends org.xml.sax.ContentHandler, org.xml.sax.ext.LexicalHandler)
  • javax.management.DynamicMBean
    • javax.management.DynamicWrapperMBean
    • javax.management.modelmbean.ModelMBean (also extends javax.management.modelmbean.ModelMBeanNotificationBroadcaster, javax.management.PersistentMBean)
  • org.omg.DynamicAny.DynAnyFactoryOperations
    • org.omg.DynamicAny.DynAnyFactory (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.DynamicAny.DynAnyOperations
    • org.omg.DynamicAny.DynAny (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynArrayOperations
      • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynEnumOperations
      • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynFixedOperations
      • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynSequenceOperations
      • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynStructOperations
      • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynUnionOperations
      • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueBoxOperations
      • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueCommonOperations
      • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBoxOperations
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueOperations
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueOperations
      • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
  • java.security.spec.ECField
  • java.security.interfaces.ECKey
    • java.security.interfaces.ECPrivateKey (also extends java.security.PrivateKey)
    • java.security.interfaces.ECPublicKey (also extends java.security.PublicKey)
  • javax.lang.model.element.Element
    • javax.lang.model.element.ExecutableElement (also extends javax.lang.model.element.Parameterizable)
    • javax.lang.model.element.PackageElement (also extends javax.lang.model.element.QualifiedNameable)
    • javax.lang.model.element.Parameterizable
      • javax.lang.model.element.ExecutableElement (also extends javax.lang.model.element.Element)
      • javax.lang.model.element.TypeElement (also extends javax.lang.model.element.Element, javax.lang.model.element.QualifiedNameable)
    • javax.lang.model.element.QualifiedNameable
      • javax.lang.model.element.PackageElement (also extends javax.lang.model.element.Element)
      • javax.lang.model.element.TypeElement (also extends javax.lang.model.element.Element, javax.lang.model.element.Parameterizable)
    • javax.lang.model.element.TypeElement (also extends javax.lang.model.element.Parameterizable, javax.lang.model.element.QualifiedNameable)
    • javax.lang.model.element.TypeParameterElement
    • javax.lang.model.element.VariableElement
  • javax.swing.text.Element
  • javax.xml.bind.Element
  • javax.lang.model.util.Elements
  • javax.lang.model.element.ElementVisitor<R,P>
  • org.omg.IOP.ENCODING_CDR_ENCAPS
  • org.xml.sax.EntityResolver
    • org.xml.sax.ext.EntityResolver2
  • java.util.Enumeration<E>
    • javax.naming.NamingEnumeration<T>
  • org.xml.sax.ErrorHandler
  • javax.xml.transform.ErrorListener
  • org.w3c.dom.events.Event
    • org.w3c.dom.ls.LSLoadEvent
    • org.w3c.dom.ls.LSProgressEvent
    • org.w3c.dom.events.MouseEvent
    • org.w3c.dom.events.MutationEvent
    • org.w3c.dom.events.UIEvent
      • org.w3c.dom.events.MouseEvent
  • javax.management.event.EventClientDelegateMBean
  • javax.management.event.EventConsumer
  • javax.xml.stream.EventFilter
  • javax.management.event.EventForwarder
  • java.util.EventListener
    • javax.swing.Action
    • java.awt.event.ActionListener
      • javax.swing.Action
    • java.awt.event.AdjustmentListener
    • javax.swing.event.AncestorListener
    • java.awt.event.AWTEventListener
    • java.beans.beancontext.BeanContextMembershipListener
    • java.beans.beancontext.BeanContextServiceRevokedListener
      • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContext, java.beans.beancontext.BeanContextServicesListener)
      • java.beans.beancontext.BeanContextServicesListener
        • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContext)
    • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContext, java.beans.beancontext.BeanContextServicesListener)
    • java.beans.beancontext.BeanContextServicesListener
      • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContext)
    • javax.swing.event.CaretListener
    • javax.swing.event.CellEditorListener
    • javax.swing.event.ChangeListener
    • java.awt.event.ComponentListener
    • javax.sql.ConnectionEventListener
    • java.awt.event.ContainerListener
    • javax.sound.midi.ControllerEventListener
    • javax.swing.event.DocumentListener
    • java.awt.dnd.DragGestureListener
    • java.awt.dnd.DragSourceListener
    • java.awt.dnd.DragSourceMotionListener
    • java.awt.dnd.DropTargetListener
    • java.awt.datatransfer.FlavorListener
    • java.awt.event.FocusListener
    • javax.net.ssl.HandshakeCompletedListener
    • java.awt.event.HierarchyBoundsListener
    • java.awt.event.HierarchyListener
    • javax.swing.event.HyperlinkListener
    • javax.imageio.event.IIOReadProgressListener
    • javax.imageio.event.IIOReadUpdateListener
    • javax.imageio.event.IIOReadWarningListener
    • javax.imageio.event.IIOWriteProgressListener
    • javax.imageio.event.IIOWriteWarningListener
    • java.awt.event.InputMethodListener
    • javax.swing.event.InternalFrameListener
    • java.awt.event.ItemListener
    • java.awt.event.KeyListener
    • javax.sound.sampled.LineListener
    • javax.swing.event.ListDataListener
    • javax.swing.event.ListSelectionListener
    • javax.swing.event.MenuDragMouseListener
    • javax.swing.event.MenuKeyListener
    • javax.swing.event.MenuListener
    • javax.sound.midi.MetaEventListener
    • javax.swing.event.MouseInputListener (also extends java.awt.event.MouseListener, java.awt.event.MouseMotionListener)
    • java.awt.event.MouseListener
      • javax.swing.event.MouseInputListener (also extends java.awt.event.MouseMotionListener)
    • java.awt.event.MouseMotionListener
      • javax.swing.event.MouseInputListener (also extends java.awt.event.MouseListener)
    • java.awt.event.MouseWheelListener
    • javax.naming.event.NamespaceChangeListener
    • javax.naming.event.NamingListener
      • javax.naming.event.NamespaceChangeListener
      • javax.naming.event.ObjectChangeListener
      • javax.naming.ldap.UnsolicitedNotificationListener
    • java.util.prefs.NodeChangeListener
    • javax.management.NotificationListener
    • javax.naming.event.ObjectChangeListener
    • javax.swing.event.PopupMenuListener
    • java.util.prefs.PreferenceChangeListener
    • java.beans.PropertyChangeListener
    • javax.sql.RowSetListener
    • javax.swing.event.RowSorterListener
    • javax.net.ssl.SSLSessionBindingListener
    • javax.sql.StatementEventListener
    • javax.swing.event.TableColumnModelListener
    • javax.swing.event.TableModelListener
    • java.awt.event.TextListener
    • javax.swing.event.TreeExpansionListener
    • javax.swing.event.TreeModelListener
    • javax.swing.event.TreeSelectionListener
    • javax.swing.event.TreeWillExpandListener
    • javax.swing.event.UndoableEditListener
    • javax.naming.ldap.UnsolicitedNotificationListener
    • java.beans.VetoableChangeListener
    • java.awt.event.WindowFocusListener
    • java.awt.event.WindowListener
    • java.awt.event.WindowStateListener
  • org.w3c.dom.events.EventListener
  • javax.management.event.EventReceiver
  • javax.management.event.EventRelay
  • org.w3c.dom.events.EventTarget
  • org.omg.IOP.ExceptionDetailMessage
  • java.beans.ExceptionListener
  • java.util.concurrent.Executor
    • java.util.concurrent.ExecutorService
      • java.util.concurrent.ScheduledExecutorService
    • java.util.concurrent.ScheduledExecutorService
  • java.security.cert.Extension
  • java.nio.file.FileAction<T>
  • java.nio.file.attribute.FileAttribute<T>
  • java.io.FileFilter
  • java.io.FilenameFilter
  • java.net.FileNameMap
  • javax.tools.FileObject
    • javax.tools.JavaFileObject
  • javax.annotation.processing.Filer
  • java.nio.file.FileRef
  • java.nio.file.attribute.FileStoreSpaceAttributes
  • java.nio.file.FileVisitor<T>
  • java.util.logging.Filter
  • javax.print.FlavorException
  • java.awt.datatransfer.FlavorMap
    • java.awt.datatransfer.FlavorTable
  • java.io.Flushable
    • javax.tools.JavaFileManager (also extends java.io.Closeable, javax.tools.OptionChecker)
      • javax.tools.StandardJavaFileManager
    • javax.tools.StandardJavaFileManager
  • java.util.Formattable
  • java.util.concurrent.Future<V>
    • javax.xml.ws.Response<T>
    • java.util.concurrent.RunnableFuture<V> (also extends java.lang.Runnable)
      • java.util.concurrent.RunnableScheduledFuture<V> (also extends java.util.concurrent.ScheduledFuture<V>)
    • java.util.concurrent.RunnableScheduledFuture<V> (also extends java.util.concurrent.RunnableFuture<V>, java.util.concurrent.ScheduledFuture<V>)
    • java.util.concurrent.ScheduledFuture<V> (also extends java.util.concurrent.Delayed)
      • java.util.concurrent.RunnableScheduledFuture<V> (also extends java.util.concurrent.RunnableFuture<V>)
  • java.lang.reflect.GenericDeclaration
  • org.ietf.jgss.GSSContext
  • org.ietf.jgss.GSSName
  • java.security.Guard
  • javax.xml.ws.handler.Handler<C>
    • javax.xml.ws.handler.LogicalHandler<C>
    • javax.xml.ws.handler.soap.SOAPHandler<T>
  • javax.xml.ws.handler.HandlerResolver
  • javax.naming.ldap.HasControls
    • javax.naming.ldap.UnsolicitedNotification (also extends javax.naming.ldap.ExtendedResponse)
  • javax.swing.text.Highlighter
  • javax.swing.text.Highlighter.Highlight
  • javax.swing.text.Highlighter.HighlightPainter
  • org.omg.PortableInterceptor.HOLDING
  • javax.net.ssl.HostnameVerifier
  • javax.swing.Icon
  • org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID
  • org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID
  • javax.imageio.metadata.IIOMetadataController
  • javax.imageio.metadata.IIOMetadataFormat
  • javax.imageio.IIOParamController
  • java.awt.image.ImageConsumer
  • java.awt.image.ImageObserver
  • java.awt.image.ImageProducer
  • javax.imageio.ImageTranscoder
  • org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID
  • org.omg.PortableInterceptor.INACTIVE
  • javax.naming.spi.InitialContextFactory
  • javax.naming.spi.InitialContextFactoryBuilder
  • java.awt.im.spi.InputMethod
  • java.awt.im.spi.InputMethodDescriptor
  • java.awt.im.InputMethodRequests
    • java.awt.im.spi.InputMethodContext
  • java.lang.instrument.Instrumentation
  • org.omg.PortableInterceptor.InterceptorOperations
    • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
    • org.omg.PortableInterceptor.ClientRequestInterceptorOperations
      • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
    • org.omg.PortableInterceptor.Interceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.IORInterceptorOperations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
    • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
    • org.omg.PortableInterceptor.IORInterceptor_3_0Operations
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor)
    • org.omg.PortableInterceptor.IORInterceptorOperations
      • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0Operations
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor)
    • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.PortableInterceptor.ServerRequestInterceptorOperations
      • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
  • javax.script.Invocable
  • java.lang.reflect.InvocationHandler
  • org.omg.CORBA.portable.InvokeHandler
    • javax.rmi.CORBA.Tie
  • org.omg.PortableInterceptor.IORInfoOperations
    • org.omg.PortableInterceptor.IORInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.CORBA.IRObjectOperations
    • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations, org.omg.CORBA.IRObject)
    • org.omg.CORBA.IDLTypeOperations
      • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IRObject)
    • org.omg.CORBA.IRObject (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations)
  • java.awt.ItemSelectable
    • javax.swing.ButtonModel
  • java.lang.Iterable<T>
    • java.beans.beancontext.BeanContext (also extends java.beans.beancontext.BeanContextChild, java.util.Collection<E>, java.beans.DesignMode, java.beans.Visibility)
      • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContextServicesListener)
    • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContext, java.beans.beancontext.BeanContextServicesListener)
    • java.util.concurrent.BlockingDeque<E> (also extends java.util.concurrent.BlockingQueue<E>, java.util.Deque<E>)
    • java.util.concurrent.BlockingQueue<E>
      • java.util.concurrent.BlockingDeque<E> (also extends java.util.Deque<E>)
    • java.util.Collection<E>
      • java.beans.beancontext.BeanContext (also extends java.beans.beancontext.BeanContextChild, java.beans.DesignMode, java.beans.Visibility)
        • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContextServicesListener)
      • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContext, java.beans.beancontext.BeanContextServicesListener)
      • java.util.concurrent.BlockingDeque<E> (also extends java.util.concurrent.BlockingQueue<E>, java.util.Deque<E>)
      • java.util.concurrent.BlockingQueue<E>
        • java.util.concurrent.BlockingDeque<E> (also extends java.util.Deque<E>)
      • java.util.Deque<E>
        • java.util.concurrent.BlockingDeque<E> (also extends java.util.concurrent.BlockingQueue<E>)
      • java.util.List<E>
      • java.util.NavigableSet<E>
      • java.util.Queue<E>
        • java.util.concurrent.BlockingDeque<E> (also extends java.util.concurrent.BlockingQueue<E>, java.util.Deque<E>)
        • java.util.concurrent.BlockingQueue<E>
          • java.util.concurrent.BlockingDeque<E> (also extends java.util.Deque<E>)
        • java.util.Deque<E>
          • java.util.concurrent.BlockingDeque<E> (also extends java.util.concurrent.BlockingQueue<E>)
      • java.util.Set<E>
        • java.util.NavigableSet<E>
        • java.util.SortedSet<E>
          • java.util.NavigableSet<E>
      • java.util.SortedSet<E>
        • java.util.NavigableSet<E>
    • java.util.Deque<E>
      • java.util.concurrent.BlockingDeque<E> (also extends java.util.concurrent.BlockingQueue<E>)
    • java.nio.file.DirectoryStream<T> (also extends java.io.Closeable)
    • java.util.List<E>
    • java.util.NavigableSet<E>
    • java.util.Queue<E>
      • java.util.concurrent.BlockingDeque<E> (also extends java.util.concurrent.BlockingQueue<E>, java.util.Deque<E>)
      • java.util.concurrent.BlockingQueue<E>
        • java.util.concurrent.BlockingDeque<E> (also extends java.util.Deque<E>)
      • java.util.Deque<E>
        • java.util.concurrent.BlockingDeque<E> (also extends java.util.concurrent.BlockingQueue<E>)
    • java.util.Set<E>
      • java.util.NavigableSet<E>
      • java.util.SortedSet<E>
        • java.util.NavigableSet<E>
    • java.util.SortedSet<E>
      • java.util.NavigableSet<E>
  • java.util.Iterator<E>
    • java.util.ListIterator<E>
    • javax.xml.stream.XMLEventReader
  • javax.tools.JavaFileManager.Location
  • javax.swing.JComboBox.KeySelectionManager
  • javax.management.remote.JMXAddressable
  • javax.management.remote.JMXAuthenticator
  • javax.management.remote.JMXConnectorProvider
  • javax.management.remote.JMXConnectorServerMBean
  • javax.management.remote.JMXConnectorServerProvider
  • javax.management.namespace.JMXNamespaceMBean
    • javax.management.namespace.JMXRemoteNamespaceMBean
  • javax.sql.rowset.Joinable
    • javax.sql.rowset.CachedRowSet (also extends javax.sql.RowSet)
      • javax.sql.rowset.FilteredRowSet
      • javax.sql.rowset.JoinRowSet
      • javax.sql.rowset.WebRowSet
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
    • javax.sql.rowset.FilteredRowSet
    • javax.sql.rowset.JdbcRowSet (also extends javax.sql.RowSet)
    • javax.sql.rowset.JoinRowSet
    • javax.sql.rowset.WebRowSet
      • javax.sql.rowset.FilteredRowSet
      • javax.sql.rowset.JoinRowSet
  • java.awt.KeyEventDispatcher
  • java.awt.KeyEventPostProcessor
  • javax.net.ssl.KeyManager
    • javax.net.ssl.X509KeyManager
  • javax.swing.text.Keymap
  • javax.xml.crypto.KeySelectorResult
  • java.security.spec.KeySpec
  • java.security.KeyStore.Entry
  • java.security.KeyStore.LoadStoreParameter
  • java.security.KeyStore.ProtectionParameter
  • java.awt.LayoutManager
    • java.awt.LayoutManager2
  • org.xml.sax.ext.LexicalHandler
    • javax.xml.transform.sax.TransformerHandler (also extends org.xml.sax.ContentHandler, org.xml.sax.DTDHandler)
  • org.omg.PortableServer.LIFESPAN_POLICY_ID
  • javax.sound.sampled.Line
    • javax.sound.sampled.Clip
    • javax.sound.sampled.DataLine
      • javax.sound.sampled.Clip
      • javax.sound.sampled.SourceDataLine
      • javax.sound.sampled.TargetDataLine
    • javax.sound.sampled.Mixer
    • javax.sound.sampled.Port
    • javax.sound.sampled.SourceDataLine
    • javax.sound.sampled.TargetDataLine
  • javax.swing.ListCellRenderer
  • javax.swing.ListModel
    • javax.swing.ComboBoxModel
      • javax.swing.MutableComboBoxModel
    • javax.swing.MutableComboBoxModel
  • javax.swing.ListSelectionModel
  • java.rmi.server.LoaderHandler
  • javax.xml.stream.Location
  • org.omg.PortableInterceptor.LOCATION_FORWARD
  • org.xml.sax.Locator
    • org.xml.sax.ext.Locator2
  • java.util.concurrent.locks.Lock
  • javax.xml.ws.LogicalMessage
  • javax.security.auth.spi.LoginModule
  • org.w3c.dom.ls.LSInput
  • org.w3c.dom.ls.LSOutput
  • org.w3c.dom.ls.LSParser
  • org.w3c.dom.ls.LSParserFilter
  • org.w3c.dom.ls.LSResourceResolver
  • org.w3c.dom.ls.LSSerializer
  • javax.net.ssl.ManagerFactoryParameters
  • java.util.Map<K,V>
    • javax.script.Bindings
    • java.util.concurrent.ConcurrentMap<K,V>
      • java.util.concurrent.ConcurrentNavigableMap<K,V> (also extends java.util.NavigableMap<K,V>)
    • java.util.concurrent.ConcurrentNavigableMap<K,V> (also extends java.util.concurrent.ConcurrentMap<K,V>, java.util.NavigableMap<K,V>)
    • javax.xml.ws.handler.LogicalMessageContext
    • javax.xml.ws.handler.MessageContext
      • javax.xml.ws.handler.LogicalMessageContext
      • javax.xml.ws.handler.soap.SOAPMessageContext
    • java.util.NavigableMap<K,V>
      • java.util.concurrent.ConcurrentNavigableMap<K,V> (also extends java.util.concurrent.ConcurrentMap<K,V>)
    • javax.xml.ws.handler.soap.SOAPMessageContext
    • java.util.SortedMap<K,V>
      • java.util.concurrent.ConcurrentNavigableMap<K,V> (also extends java.util.concurrent.ConcurrentMap<K,V>, java.util.NavigableMap<K,V>)
      • java.util.NavigableMap<K,V>
        • java.util.concurrent.ConcurrentNavigableMap<K,V> (also extends java.util.concurrent.ConcurrentMap<K,V>)
  • java.util.Map.Entry<K,V>
  • javax.xml.bind.Marshaller
  • java.util.regex.MatchResult
  • javax.management.MBeanRegistration
  • javax.management.MBeanServerDelegateMBean
  • java.lang.reflect.Member
  • java.awt.MenuContainer
  • javax.swing.MenuElement
  • javax.annotation.processing.Messager
  • javax.sound.midi.MidiChannel
  • javax.sound.midi.MidiDevice
    • javax.sound.midi.Sequencer
    • javax.sound.midi.Synthesizer
  • javax.management.loading.MLetMBean
  • javax.management.modelmbean.ModelMBeanInfo
  • javax.management.monitor.MonitorMBean
    • javax.management.monitor.CounterMonitorMBean
    • javax.management.monitor.GaugeMonitorMBean
    • javax.management.monitor.StringMonitorMBean
  • javax.print.MultiDoc
  • java.awt.font.MultipleMaster
  • javax.xml.soap.Name
  • org.w3c.dom.NamedNodeMap
  • org.w3c.dom.NameList
  • javax.naming.NameParser
  • javax.xml.namespace.NamespaceContext
  • org.omg.CosNaming.NamingContextOperations
    • org.omg.CosNaming.NamingContext (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextExtOperations)
    • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContext, org.omg.CosNaming.NamingContextExtOperations)
    • org.omg.CosNaming.NamingContextExtOperations
      • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContext)
  • org.w3c.dom.Node
    • org.w3c.dom.Attr
    • org.w3c.dom.CDATASection
    • org.w3c.dom.CharacterData
      • org.w3c.dom.CDATASection
      • org.w3c.dom.Comment
      • org.w3c.dom.Text
        • org.w3c.dom.CDATASection
        • javax.xml.soap.Text (also extends javax.xml.soap.Node)
      • javax.xml.soap.Text (also extends javax.xml.soap.Node, org.w3c.dom.Text)
    • org.w3c.dom.Comment
    • javax.xml.soap.Detail
    • javax.xml.soap.DetailEntry
    • org.w3c.dom.Document
    • org.w3c.dom.DocumentFragment
    • org.w3c.dom.DocumentType
    • org.w3c.dom.Element
      • javax.xml.soap.Detail
      • javax.xml.soap.DetailEntry
      • javax.xml.soap.SOAPBody
      • javax.xml.soap.SOAPBodyElement
        • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPElement (also extends javax.xml.soap.Node)
        • javax.xml.soap.Detail
        • javax.xml.soap.DetailEntry
        • javax.xml.soap.SOAPBody
        • javax.xml.soap.SOAPBodyElement
          • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPEnvelope
        • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPFaultElement
          • javax.xml.soap.Detail
        • javax.xml.soap.SOAPHeader
        • javax.xml.soap.SOAPHeaderElement
      • javax.xml.soap.SOAPEnvelope
      • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPFaultElement
        • javax.xml.soap.Detail
      • javax.xml.soap.SOAPHeader
      • javax.xml.soap.SOAPHeaderElement
    • org.w3c.dom.Entity
    • org.w3c.dom.EntityReference
    • javax.xml.soap.Node
      • javax.xml.soap.Detail
      • javax.xml.soap.DetailEntry
      • javax.xml.soap.SOAPBody
      • javax.xml.soap.SOAPBodyElement
        • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPElement (also extends org.w3c.dom.Element)
        • javax.xml.soap.Detail
        • javax.xml.soap.DetailEntry
        • javax.xml.soap.SOAPBody
        • javax.xml.soap.SOAPBodyElement
          • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPEnvelope
        • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPFaultElement
          • javax.xml.soap.Detail
        • javax.xml.soap.SOAPHeader
        • javax.xml.soap.SOAPHeaderElement
      • javax.xml.soap.SOAPEnvelope
      • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPFaultElement
        • javax.xml.soap.Detail
      • javax.xml.soap.SOAPHeader
      • javax.xml.soap.SOAPHeaderElement
      • javax.xml.soap.Text (also extends org.w3c.dom.Text)
    • org.w3c.dom.Notation
    • org.w3c.dom.ProcessingInstruction
    • javax.xml.soap.SOAPBody
    • javax.xml.soap.SOAPBodyElement
      • javax.xml.soap.SOAPFault
    • javax.xml.soap.SOAPElement (also extends org.w3c.dom.Element, javax.xml.soap.Node)
      • javax.xml.soap.Detail
      • javax.xml.soap.DetailEntry
      • javax.xml.soap.SOAPBody
      • javax.xml.soap.SOAPBodyElement
        • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPEnvelope
      • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPFaultElement
        • javax.xml.soap.Detail
      • javax.xml.soap.SOAPHeader
      • javax.xml.soap.SOAPHeaderElement
    • javax.xml.soap.SOAPEnvelope
    • javax.xml.soap.SOAPFault
    • javax.xml.soap.SOAPFaultElement
      • javax.xml.soap.Detail
    • javax.xml.soap.SOAPHeader
    • javax.xml.soap.SOAPHeaderElement
    • org.w3c.dom.Text
      • org.w3c.dom.CDATASection
      • javax.xml.soap.Text (also extends javax.xml.soap.Node)
    • javax.xml.soap.Text (also extends javax.xml.soap.Node, org.w3c.dom.Text)
  • org.w3c.dom.traversal.NodeFilter
    • org.w3c.dom.ls.LSSerializerFilter
  • org.w3c.dom.NodeList
  • org.omg.PortableInterceptor.NON_EXISTENT
  • javax.management.NotificationBroadcaster
    • javax.management.modelmbean.ModelMBean (also extends javax.management.DynamicMBean, javax.management.modelmbean.ModelMBeanNotificationBroadcaster, javax.management.PersistentMBean)
    • javax.management.modelmbean.ModelMBeanNotificationBroadcaster
      • javax.management.modelmbean.ModelMBean (also extends javax.management.DynamicMBean, javax.management.PersistentMBean)
    • javax.management.NotificationEmitter
  • javax.management.event.NotificationManager
    • javax.management.MBeanServer
      • javax.management.remote.MBeanServerForwarder
    • javax.management.MBeanServerConnection
      • javax.management.MBeanServer
        • javax.management.remote.MBeanServerForwarder
      • javax.management.remote.MBeanServerForwarder
    • javax.management.remote.MBeanServerForwarder
  • org.omg.CORBA.Object
    • org.omg.PortableServer.AdapterActivator (also extends org.omg.PortableServer.AdapterActivatorOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.BindingIterator (also extends org.omg.CosNaming.BindingIteratorOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo)
    • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
    • org.omg.IOP.Codec (also extends org.omg.IOP.CodecOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.CodecFactory (also extends org.omg.IOP.CodecFactoryOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.Current (also extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.Current (also extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.Current (also extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.Current (also extends org.omg.CORBA.Current, org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.Current (also extends org.omg.CORBA.Current, org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DomainManager (also extends org.omg.CORBA.DomainManagerOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynAny
      • org.omg.CORBA.DynArray (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynEnum (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynFixed (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynSequence (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynStruct (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynUnion (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynValue (also extends org.omg.CORBA.Object)
    • org.omg.DynamicAny.DynAny (also extends org.omg.DynamicAny.DynAnyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynAnyFactory (also extends org.omg.DynamicAny.DynAnyFactoryOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynArray (also extends org.omg.CORBA.DynAny)
    • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynEnum (also extends org.omg.CORBA.DynAny)
    • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynFixed (also extends org.omg.CORBA.DynAny)
    • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynSequence (also extends org.omg.CORBA.DynAny)
    • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynStruct (also extends org.omg.CORBA.DynAny)
    • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynUnion (also extends org.omg.CORBA.DynAny)
    • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynValue (also extends org.omg.CORBA.DynAny)
    • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations, org.omg.CORBA.IRObject)
    • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.PortableInterceptor.Interceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.InterceptorOperations)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.PortableInterceptor.IORInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInfoOperations)
    • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.IORInterceptorOperations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
    • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
    • org.omg.CORBA.IRObject (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IRObjectOperations)
      • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations)
    • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.CosNaming.NamingContext (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextOperations)
      • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextExtOperations)
    • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContext, org.omg.CosNaming.NamingContextExtOperations)
    • org.omg.PortableInterceptor.ORBInitializer (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ORBInitializerOperations)
    • org.omg.PortableInterceptor.ORBInitInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ORBInitInfoOperations)
    • org.omg.PortableServer.POA (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.POAOperations)
    • org.omg.PortableServer.POAManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.POAManagerOperations)
    • org.omg.CORBA.Policy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.PolicyOperations)
      • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
      • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
      • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
    • org.omg.PortableInterceptor.PolicyFactory (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.PolicyFactoryOperations)
    • org.omg.PortableInterceptor.RequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfoOperations)
      • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
    • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.RequestProcessingPolicyOperations)
    • org.omg.SendingContext.RunTime (also extends org.omg.CORBA.portable.IDLEntity, org.omg.SendingContext.RunTimeOperations)
    • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantManagerOperations)
      • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
    • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.ServantRetentionPolicyOperations)
    • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo, org.omg.PortableInterceptor.ServerRequestInfoOperations)
    • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.ThreadPolicyOperations)
  • javax.naming.spi.ObjectFactory
    • javax.naming.spi.DirObjectFactory
  • javax.naming.spi.ObjectFactoryBuilder
  • java.io.ObjectInputValidation
  • java.io.ObjectStreamConstants
  • java.util.Observer
  • org.omg.CORBA.OMGVMCID
  • javax.management.openmbean.OpenMBeanConstructorInfo
  • javax.management.openmbean.OpenMBeanInfo
  • javax.management.openmbean.OpenMBeanOperationInfo
  • javax.management.openmbean.OpenMBeanParameterInfo
    • javax.management.openmbean.OpenMBeanAttributeInfo
  • java.nio.file.OpenOption
  • java.awt.font.OpenType
  • javax.tools.OptionChecker
    • javax.tools.JavaCompiler (also extends javax.tools.Tool)
    • javax.tools.JavaFileManager (also extends java.io.Closeable, java.io.Flushable)
      • javax.tools.StandardJavaFileManager
    • javax.tools.StandardJavaFileManager
  • org.omg.PortableInterceptor.ORBInitializerOperations
    • org.omg.PortableInterceptor.ORBInitializer (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableInterceptor.ORBInitInfoOperations
    • org.omg.PortableInterceptor.ORBInitInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • java.security.acl.Owner
    • java.security.acl.Acl
  • java.util.jar.Pack200.Packer
  • java.util.jar.Pack200.Unpacker
  • java.awt.print.Pageable
  • java.awt.PaintContext
  • javax.swing.Painter<T>
  • org.xml.sax.Parser
  • java.awt.geom.PathIterator
  • java.nio.file.PathMatcher
  • java.security.acl.Permission
  • javax.management.PersistentMBean
    • javax.management.modelmbean.ModelMBean (also extends javax.management.DynamicMBean, javax.management.modelmbean.ModelMBeanNotificationBroadcaster)
  • java.lang.management.PlatformManagedObject
    • java.nio.BufferPoolMXBean
    • java.lang.management.ClassLoadingMXBean
    • java.lang.management.CompilationMXBean
    • java.lang.management.GarbageCollectorMXBean
    • java.util.logging.LoggingMXBean
    • java.lang.management.MemoryManagerMXBean
      • java.lang.management.GarbageCollectorMXBean
    • java.lang.management.MemoryMXBean
    • java.lang.management.MemoryPoolMXBean
    • java.lang.management.OperatingSystemMXBean
    • java.lang.management.RuntimeMXBean
    • java.lang.management.ThreadMXBean
  • org.omg.PortableServer.POAManagerOperations
    • org.omg.PortableServer.POAManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableServer.POAOperations
    • org.omg.PortableServer.POA (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • java.security.Policy.Parameters
  • org.omg.PortableInterceptor.PolicyFactoryOperations
    • org.omg.PortableInterceptor.PolicyFactory (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • java.security.cert.PolicyNode
  • org.omg.CORBA.PolicyOperations
    • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.IdAssignmentPolicyOperations
      • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.PortableServer.IdUniquenessPolicyOperations
      • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ImplicitActivationPolicyOperations
      • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.PortableServer.LifespanPolicyOperations
      • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.CORBA.Policy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
      • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
      • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
    • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.RequestProcessingPolicyOperations)
    • org.omg.PortableServer.RequestProcessingPolicyOperations
      • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.ServantRetentionPolicyOperations)
    • org.omg.PortableServer.ServantRetentionPolicyOperations
      • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.ThreadPolicyOperations)
    • org.omg.PortableServer.ThreadPolicyOperations
      • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
  • javax.sql.PooledConnection
    • javax.sql.XAConnection
  • javax.rmi.CORBA.PortableRemoteObjectDelegate
  • javax.xml.ws.handler.PortInfo
  • javax.swing.text.Position
  • javax.sql.rowset.Predicate
  • java.util.prefs.PreferencesFactory
  • java.security.Principal
    • java.security.acl.Group
    • java.nio.file.attribute.GroupPrincipal
    • java.nio.file.attribute.UserPrincipal
      • java.nio.file.attribute.GroupPrincipal
  • java.awt.print.Printable
  • java.awt.print.PrinterGraphics
  • java.awt.PrintGraphics
  • javax.print.event.PrintJobAttributeListener
  • javax.print.event.PrintJobListener
  • javax.print.PrintService
    • javax.print.MultiDocPrintService
  • javax.print.event.PrintServiceAttributeListener
  • org.omg.CORBA.PRIVATE_MEMBER
  • javax.management.loading.PrivateClassLoader
  • java.security.PrivilegedAction<T>
  • java.security.PrivilegedExceptionAction<T>
  • javax.annotation.processing.ProcessingEnvironment
  • javax.annotation.processing.Processor
  • java.beans.PropertyEditor
  • java.net.ProtocolFamily
  • javax.xml.ws.Provider<T>
  • org.omg.CORBA.PUBLIC_MEMBER
  • java.util.RandomAccess
  • java.awt.image.RasterOp
  • java.lang.Readable
  • java.util.concurrent.locks.ReadWriteLock
  • javax.sound.midi.Receiver
  • java.sql.Ref
  • javax.naming.Referenceable
  • javax.security.auth.Refreshable
  • javax.imageio.spi.RegisterableService
  • java.rmi.registry.RegistryHandler
  • java.util.concurrent.RejectedExecutionHandler
  • javax.management.relation.Relation
    • javax.management.relation.RelationSupportMBean
  • javax.management.relation.RelationServiceMBean
  • java.rmi.Remote
    • java.rmi.activation.ActivationInstantiator
    • java.rmi.activation.ActivationMonitor
    • java.rmi.activation.ActivationSystem
    • java.rmi.activation.Activator
    • java.rmi.dgc.DGC
    • java.rmi.registry.Registry
    • javax.management.remote.rmi.RMIConnection (also extends java.io.Closeable)
    • javax.management.event.RMIPushServer
    • javax.management.remote.rmi.RMIServer
  • java.rmi.server.RemoteCall
  • java.awt.image.renderable.RenderableImage
  • java.awt.image.RenderedImage
    • java.awt.image.WritableRenderedImage
  • java.awt.image.renderable.RenderedImageFactory
    • java.awt.image.renderable.ContextualRenderedImageFactory
  • javax.swing.Renderer
  • org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID
  • org.omg.PortableInterceptor.RequestInfoOperations
    • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo)
    • org.omg.PortableInterceptor.ClientRequestInfoOperations
      • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo)
    • org.omg.PortableInterceptor.RequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
    • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo, org.omg.PortableInterceptor.ServerRequestInfoOperations)
    • org.omg.PortableInterceptor.ServerRequestInfoOperations
      • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo)
  • javax.naming.spi.Resolver
  • org.omg.CORBA.portable.ResponseHandler
  • javax.xml.transform.Result
  • java.rmi.server.RMIClientSocketFactory
  • org.omg.IOP.RMICustomMaxStreamFormat
  • java.rmi.server.RMIFailureHandler
  • java.rmi.server.RMIServerSocketFactory
  • javax.swing.RootPaneContainer
  • javax.annotation.processing.RoundEnvironment
  • java.sql.RowId
  • javax.swing.tree.RowMapper
  • javax.sql.RowSetInternal
  • javax.sql.RowSetReader
    • javax.sql.rowset.spi.XmlReader
  • javax.sql.RowSetWriter
    • javax.sql.rowset.spi.TransactionalWriter
    • javax.sql.rowset.spi.XmlWriter
  • java.security.interfaces.RSAKey
    • java.security.interfaces.RSAMultiPrimePrivateCrtKey
    • java.security.interfaces.RSAPrivateCrtKey
    • java.security.interfaces.RSAPrivateKey (also extends java.security.PrivateKey)
      • java.security.interfaces.RSAMultiPrimePrivateCrtKey
      • java.security.interfaces.RSAPrivateCrtKey
    • java.security.interfaces.RSAPublicKey (also extends java.security.PublicKey)
  • java.lang.Runnable
    • java.util.concurrent.RunnableFuture<V> (also extends java.util.concurrent.Future<V>)
      • java.util.concurrent.RunnableScheduledFuture<V> (also extends java.util.concurrent.ScheduledFuture<V>)
    • java.util.concurrent.RunnableScheduledFuture<V> (also extends java.util.concurrent.RunnableFuture<V>, java.util.concurrent.ScheduledFuture<V>)
  • org.omg.SendingContext.RunTimeOperations
    • org.omg.SendingContext.RunTime (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • javax.security.sasl.SaslClient
  • javax.security.sasl.SaslClientFactory
  • javax.security.sasl.SaslServer
  • javax.security.sasl.SaslServerFactory
  • java.sql.Savepoint
  • javax.script.ScriptContext
  • javax.script.ScriptEngine
  • javax.script.ScriptEngineFactory
  • javax.swing.Scrollable
  • javax.swing.ScrollPaneConstants
  • javax.management.SendNotification
  • java.io.Serializable
    • org.omg.PortableServer.AdapterActivator (also extends org.omg.PortableServer.AdapterActivatorOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
    • javax.naming.directory.Attribute (also extends java.lang.Cloneable)
    • javax.print.attribute.Attribute
      • javax.print.attribute.DocAttribute
      • javax.print.attribute.PrintJobAttribute
      • javax.print.attribute.PrintRequestAttribute
      • javax.print.attribute.PrintServiceAttribute
      • javax.print.attribute.SupportedValuesAttribute
    • javax.naming.directory.Attributes (also extends java.lang.Cloneable)
    • org.omg.CosNaming.BindingIterator (also extends org.omg.CosNaming.BindingIteratorOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
    • java.security.cert.CertPathValidatorException.Reason
    • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo)
    • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
    • org.omg.IOP.Codec (also extends org.omg.IOP.CodecOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
    • org.omg.IOP.CodecFactory (also extends org.omg.IOP.CodecFactoryOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
    • javax.naming.ldap.Control
    • org.omg.CORBA.Current (also extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.Current (also extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.Current (also extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.Current (also extends org.omg.CORBA.Current, org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.Current (also extends org.omg.CORBA.Current, org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.portable.CustomValue (also extends org.omg.CORBA.CustomMarshal, org.omg.CORBA.portable.ValueBase)
    • org.omg.CORBA.DataInputStream
    • org.omg.CORBA.DataOutputStream
    • javax.management.Descriptor (also extends java.lang.Cloneable)
    • javax.crypto.interfaces.DHPrivateKey (also extends javax.crypto.interfaces.DHKey, java.security.PrivateKey)
    • javax.crypto.interfaces.DHPublicKey (also extends javax.crypto.interfaces.DHKey, java.security.PublicKey)
    • javax.print.attribute.DocAttribute
    • org.omg.CORBA.DomainManager (also extends org.omg.CORBA.DomainManagerOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
    • java.security.interfaces.DSAPrivateKey (also extends java.security.interfaces.DSAKey, java.security.PrivateKey)
    • java.security.interfaces.DSAPublicKey (also extends java.security.interfaces.DSAKey, java.security.PublicKey)
    • org.omg.DynamicAny.DynAny (also extends org.omg.DynamicAny.DynAnyOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynAnyFactory (also extends org.omg.DynamicAny.DynAnyFactoryOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
    • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • java.security.interfaces.ECPrivateKey (also extends java.security.interfaces.ECKey, java.security.PrivateKey)
    • java.security.interfaces.ECPublicKey (also extends java.security.interfaces.ECKey, java.security.PublicKey)
    • javax.naming.ldap.ExtendedRequest
    • javax.naming.ldap.ExtendedResponse
      • javax.naming.ldap.UnsolicitedNotification (also extends javax.naming.ldap.HasControls)
    • java.io.Externalizable
      • java.rmi.server.RemoteRef
        • java.rmi.server.ServerRef
      • java.rmi.server.ServerRef
    • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.PortableServer.AdapterActivator (also extends org.omg.PortableServer.AdapterActivatorOperations, org.omg.CORBA.Object)
      • org.omg.CosNaming.BindingIterator (also extends org.omg.CosNaming.BindingIteratorOperations, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.PortableInterceptor.RequestInfo)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.PortableInterceptor.Interceptor)
      • org.omg.IOP.Codec (also extends org.omg.IOP.CodecOperations, org.omg.CORBA.Object)
      • org.omg.IOP.CodecFactory (also extends org.omg.IOP.CodecFactoryOperations, org.omg.CORBA.Object)
      • org.omg.CORBA.Current (also extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.Object)
        • org.omg.PortableServer.Current (also extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableInterceptor.Current (also extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.Current (also extends org.omg.CORBA.Current, org.omg.PortableServer.CurrentOperations)
      • org.omg.PortableInterceptor.Current (also extends org.omg.CORBA.Current, org.omg.PortableInterceptor.CurrentOperations)
      • org.omg.CORBA.portable.CustomValue (also extends org.omg.CORBA.CustomMarshal, org.omg.CORBA.portable.ValueBase)
      • org.omg.CORBA.DataInputStream
      • org.omg.CORBA.DataOutputStream
      • org.omg.CORBA.DomainManager (also extends org.omg.CORBA.DomainManagerOperations, org.omg.CORBA.Object)
      • org.omg.DynamicAny.DynAny (also extends org.omg.DynamicAny.DynAnyOperations, org.omg.CORBA.Object)
        • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
          • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
          • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynAnyFactory (also extends org.omg.DynamicAny.DynAnyFactoryOperations, org.omg.CORBA.Object)
      • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynArrayOperations)
      • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynEnumOperations)
      • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynFixedOperations)
      • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynSequenceOperations)
      • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynStructOperations)
      • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynUnionOperations)
      • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations)
      • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon)
      • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynValueCommonOperations)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.CORBA.IDLType (also extends org.omg.CORBA.IDLTypeOperations, org.omg.CORBA.IRObject)
      • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.PortableServer.IdUniquenessPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.PortableServer.ImplicitActivationPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.PortableInterceptor.Interceptor (also extends org.omg.PortableInterceptor.InterceptorOperations, org.omg.CORBA.Object)
        • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
          • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
        • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
      • org.omg.PortableInterceptor.IORInfo (also extends org.omg.PortableInterceptor.IORInfoOperations, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.CORBA.IRObject (also extends org.omg.CORBA.IRObjectOperations, org.omg.CORBA.Object)
        • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations)
      • org.omg.PortableServer.LifespanPolicy (also extends org.omg.PortableServer.LifespanPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.CosNaming.NamingContext (also extends org.omg.CosNaming.NamingContextOperations, org.omg.CORBA.Object)
        • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextExtOperations)
      • org.omg.CosNaming.NamingContextExt (also extends org.omg.CosNaming.NamingContext, org.omg.CosNaming.NamingContextExtOperations)
      • org.omg.PortableInterceptor.ObjectReferenceFactory
        • org.omg.PortableInterceptor.ObjectReferenceTemplate
      • org.omg.PortableInterceptor.ObjectReferenceTemplate
      • org.omg.PortableInterceptor.ORBInitializer (also extends org.omg.CORBA.Object, org.omg.PortableInterceptor.ORBInitializerOperations)
      • org.omg.PortableInterceptor.ORBInitInfo (also extends org.omg.CORBA.Object, org.omg.PortableInterceptor.ORBInitInfoOperations)
      • org.omg.PortableServer.POA (also extends org.omg.CORBA.Object, org.omg.PortableServer.POAOperations)
      • org.omg.PortableServer.POAManager (also extends org.omg.CORBA.Object, org.omg.PortableServer.POAManagerOperations)
      • org.omg.CORBA.Policy (also extends org.omg.CORBA.Object, org.omg.CORBA.PolicyOperations)
        • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
        • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
        • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
        • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
        • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
        • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
      • org.omg.PortableInterceptor.PolicyFactory (also extends org.omg.CORBA.Object, org.omg.PortableInterceptor.PolicyFactoryOperations)
      • org.omg.PortableInterceptor.RequestInfo (also extends org.omg.CORBA.Object, org.omg.PortableInterceptor.RequestInfoOperations)
        • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.Policy, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.SendingContext.RunTime (also extends org.omg.CORBA.Object, org.omg.SendingContext.RunTimeOperations)
      • org.omg.PortableServer.ServantActivator (also extends org.omg.PortableServer.ServantActivatorOperations, org.omg.PortableServer.ServantManager)
      • org.omg.PortableServer.ServantLocator (also extends org.omg.PortableServer.ServantLocatorOperations, org.omg.PortableServer.ServantManager)
      • org.omg.PortableServer.ServantManager (also extends org.omg.CORBA.Object, org.omg.PortableServer.ServantManagerOperations)
        • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
        • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.Policy, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.PortableInterceptor.RequestInfo, org.omg.PortableInterceptor.ServerRequestInfoOperations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
      • org.omg.CORBA.portable.StreamableValue (also extends org.omg.CORBA.portable.Streamable, org.omg.CORBA.portable.ValueBase)
      • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.Policy, org.omg.PortableServer.ThreadPolicyOperations)
      • org.omg.CORBA.portable.ValueBase
        • org.omg.CORBA.portable.CustomValue (also extends org.omg.CORBA.CustomMarshal)
        • org.omg.CORBA.DataInputStream
        • org.omg.CORBA.DataOutputStream
        • org.omg.PortableInterceptor.ObjectReferenceFactory
          • org.omg.PortableInterceptor.ObjectReferenceTemplate
        • org.omg.PortableInterceptor.ObjectReferenceTemplate
        • org.omg.CORBA.portable.StreamableValue (also extends org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations, org.omg.CORBA.IRObject)
    • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.PortableInterceptor.Interceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.InterceptorOperations, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.PortableInterceptor.IORInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInfoOperations, org.omg.CORBA.Object)
    • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.IORInterceptorOperations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
    • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
    • org.omg.CORBA.IRObject (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IRObjectOperations, org.omg.CORBA.Object)
      • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations)
    • java.security.Key
      • javax.crypto.interfaces.DHPrivateKey (also extends javax.crypto.interfaces.DHKey, java.security.PrivateKey)
      • javax.crypto.interfaces.DHPublicKey (also extends javax.crypto.interfaces.DHKey, java.security.PublicKey)
      • java.security.interfaces.DSAPrivateKey (also extends java.security.interfaces.DSAKey, java.security.PrivateKey)
      • java.security.interfaces.DSAPublicKey (also extends java.security.interfaces.DSAKey, java.security.PublicKey)
      • java.security.interfaces.ECPrivateKey (also extends java.security.interfaces.ECKey, java.security.PrivateKey)
      • java.security.interfaces.ECPublicKey (also extends java.security.interfaces.ECKey, java.security.PublicKey)
      • javax.crypto.interfaces.PBEKey
      • java.security.PrivateKey
        • javax.crypto.interfaces.DHPrivateKey (also extends javax.crypto.interfaces.DHKey)
        • java.security.interfaces.DSAPrivateKey (also extends java.security.interfaces.DSAKey)
        • java.security.interfaces.ECPrivateKey (also extends java.security.interfaces.ECKey)
        • java.security.interfaces.RSAMultiPrimePrivateCrtKey
        • java.security.interfaces.RSAPrivateCrtKey
        • java.security.interfaces.RSAPrivateKey (also extends java.security.interfaces.RSAKey)
          • java.security.interfaces.RSAMultiPrimePrivateCrtKey
          • java.security.interfaces.RSAPrivateCrtKey
      • java.security.PublicKey
        • javax.crypto.interfaces.DHPublicKey (also extends javax.crypto.interfaces.DHKey)
        • java.security.interfaces.DSAPublicKey (also extends java.security.interfaces.DSAKey)
        • java.security.interfaces.ECPublicKey (also extends java.security.interfaces.ECKey)
        • java.security.interfaces.RSAPublicKey (also extends java.security.interfaces.RSAKey)
      • java.security.interfaces.RSAMultiPrimePrivateCrtKey
      • java.security.interfaces.RSAPrivateCrtKey
      • java.security.interfaces.RSAPrivateKey (also extends java.security.PrivateKey, java.security.interfaces.RSAKey)
        • java.security.interfaces.RSAMultiPrimePrivateCrtKey
        • java.security.interfaces.RSAPrivateCrtKey
      • java.security.interfaces.RSAPublicKey (also extends java.security.PublicKey, java.security.interfaces.RSAKey)
      • javax.crypto.SecretKey
        • javax.crypto.interfaces.PBEKey
    • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations, org.omg.CORBA.Policy)
    • javax.naming.Name (also extends java.lang.Cloneable, java.lang.Comparable<T>)
    • org.omg.CosNaming.NamingContext (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextOperations, org.omg.CORBA.Object)
      • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextExtOperations)
    • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContext, org.omg.CosNaming.NamingContextExtOperations)
    • javax.management.NotificationFilter
    • org.omg.PortableInterceptor.ObjectReferenceFactory
      • org.omg.PortableInterceptor.ObjectReferenceTemplate
    • org.omg.PortableInterceptor.ObjectReferenceTemplate
    • org.omg.PortableInterceptor.ORBInitializer (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.PortableInterceptor.ORBInitializerOperations)
    • org.omg.PortableInterceptor.ORBInitInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.PortableInterceptor.ORBInitInfoOperations)
    • javax.crypto.interfaces.PBEKey
    • org.omg.PortableServer.POA (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.PortableServer.POAOperations)
    • org.omg.PortableServer.POAManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.PortableServer.POAManagerOperations)
    • org.omg.CORBA.Policy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.CORBA.PolicyOperations)
      • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
      • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
      • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
    • org.omg.PortableInterceptor.PolicyFactory (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.PortableInterceptor.PolicyFactoryOperations)
    • javax.print.attribute.PrintJobAttribute
    • javax.print.attribute.PrintRequestAttribute
    • javax.print.attribute.PrintServiceAttribute
    • java.security.PrivateKey
      • javax.crypto.interfaces.DHPrivateKey (also extends javax.crypto.interfaces.DHKey)
      • java.security.interfaces.DSAPrivateKey (also extends java.security.interfaces.DSAKey)
      • java.security.interfaces.ECPrivateKey (also extends java.security.interfaces.ECKey)
      • java.security.interfaces.RSAMultiPrimePrivateCrtKey
      • java.security.interfaces.RSAPrivateCrtKey
      • java.security.interfaces.RSAPrivateKey (also extends java.security.interfaces.RSAKey)
        • java.security.interfaces.RSAMultiPrimePrivateCrtKey
        • java.security.interfaces.RSAPrivateCrtKey
    • java.security.PublicKey
      • javax.crypto.interfaces.DHPublicKey (also extends javax.crypto.interfaces.DHKey)
      • java.security.interfaces.DSAPublicKey (also extends java.security.interfaces.DSAKey)
      • java.security.interfaces.ECPublicKey (also extends java.security.interfaces.ECKey)
      • java.security.interfaces.RSAPublicKey (also extends java.security.interfaces.RSAKey)
    • javax.management.QueryExp
    • javax.management.relation.RelationType
    • java.rmi.server.RemoteRef
      • java.rmi.server.ServerRef
    • org.omg.PortableInterceptor.RequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.PortableInterceptor.RequestInfoOperations)
      • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
    • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.RequestProcessingPolicyOperations)
    • java.security.interfaces.RSAMultiPrimePrivateCrtKey
    • java.security.interfaces.RSAPrivateCrtKey
    • java.security.interfaces.RSAPrivateKey (also extends java.security.PrivateKey, java.security.interfaces.RSAKey)
      • java.security.interfaces.RSAMultiPrimePrivateCrtKey
      • java.security.interfaces.RSAPrivateCrtKey
    • java.security.interfaces.RSAPublicKey (also extends java.security.PublicKey, java.security.interfaces.RSAKey)
    • org.omg.SendingContext.RunTime (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.SendingContext.RunTimeOperations)
    • javax.crypto.SecretKey
      • javax.crypto.interfaces.PBEKey
    • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.PortableServer.ServantManagerOperations)
      • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
    • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.ServantRetentionPolicyOperations)
    • java.rmi.server.ServerRef
    • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo, org.omg.PortableInterceptor.ServerRequestInfoOperations)
    • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.CORBA.portable.StreamableValue (also extends org.omg.CORBA.portable.Streamable, org.omg.CORBA.portable.ValueBase)
    • javax.print.attribute.SupportedValuesAttribute
    • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.ThreadPolicyOperations)
    • javax.naming.ldap.UnsolicitedNotification (also extends javax.naming.ldap.ExtendedResponse, javax.naming.ldap.HasControls)
    • org.omg.CORBA.portable.ValueBase
      • org.omg.CORBA.portable.CustomValue (also extends org.omg.CORBA.CustomMarshal)
      • org.omg.CORBA.DataInputStream
      • org.omg.CORBA.DataOutputStream
      • org.omg.PortableInterceptor.ObjectReferenceFactory
        • org.omg.PortableInterceptor.ObjectReferenceTemplate
      • org.omg.PortableInterceptor.ObjectReferenceTemplate
      • org.omg.CORBA.portable.StreamableValue (also extends org.omg.CORBA.portable.Streamable)
    • javax.management.ValueExp
  • org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID
  • org.omg.PortableServer.ServantManagerOperations
    • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantActivatorOperations
      • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantLocatorOperations
      • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
  • javax.imageio.spi.ServiceRegistry.Filter
  • java.awt.Shape
  • javax.swing.SingleSelectionModel
  • java.rmi.server.Skeleton
  • javax.xml.soap.SOAPConstants
  • java.net.SocketImplFactory
  • java.net.SocketOption<T>
  • java.net.SocketOptions
  • javax.sound.midi.Soundbank
  • javax.xml.transform.Source
  • javax.xml.transform.SourceLocator
    • javax.xml.transform.dom.DOMLocator
  • javax.swing.SpinnerModel
  • java.sql.SQLData
  • java.sql.SQLInput
  • java.sql.SQLOutput
  • java.sql.SQLXML
  • javax.net.ssl.SSLSession
  • javax.net.ssl.SSLSessionContext
  • javax.swing.undo.StateEditable
  • javax.naming.spi.StateFactory
    • javax.naming.spi.DirStateFactory
  • org.omg.CORBA.portable.Streamable
    • org.omg.CORBA.portable.StreamableValue (also extends org.omg.CORBA.portable.ValueBase)
  • javax.xml.stream.StreamFilter
  • java.awt.Stroke
  • java.sql.Struct
  • javax.rmi.CORBA.StubDelegate
  • org.omg.PortableInterceptor.SUCCESSFUL
  • javax.swing.SwingConstants
  • org.omg.Messaging.SYNC_WITH_TRANSPORT
  • javax.swing.plaf.synth.SynthConstants
  • org.omg.PortableInterceptor.SYSTEM_EXCEPTION
  • javax.swing.text.TabableView
  • javax.swing.text.TabExpander
  • javax.swing.table.TableCellRenderer
  • javax.swing.table.TableColumnModel
  • javax.swing.table.TableModel
  • javax.management.openmbean.TabularData
  • org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS
  • org.omg.IOP.TAG_CODE_SETS
  • org.omg.IOP.TAG_INTERNET_IOP
  • org.omg.IOP.TAG_JAVA_CODEBASE
  • org.omg.IOP.TAG_MULTIPLE_COMPONENTS
  • org.omg.IOP.TAG_ORB_TYPE
  • org.omg.IOP.TAG_POLICIES
  • org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
  • javax.xml.transform.Templates
  • org.omg.PortableServer.THREAD_POLICY_ID
  • java.lang.Thread.UncaughtExceptionHandler
  • java.util.concurrent.ThreadFactory
  • java.awt.image.TileObserver
  • javax.management.timer.TimerMBean
  • javax.tools.Tool
    • javax.tools.JavaCompiler (also extends javax.tools.OptionChecker)
  • org.omg.IOP.TransactionService
  • java.awt.datatransfer.Transferable
  • javax.sound.midi.Transmitter
  • java.awt.Transparency
    • java.awt.Paint
  • org.omg.PortableInterceptor.TRANSPORT_RETRY
  • javax.swing.tree.TreeCellRenderer
  • javax.swing.tree.TreeModel
  • javax.swing.tree.TreeNode
    • javax.swing.tree.MutableTreeNode
  • javax.swing.tree.TreeSelectionModel
  • javax.net.ssl.TrustManager
    • javax.net.ssl.X509TrustManager
  • java.lang.reflect.Type
    • java.lang.reflect.GenericArrayType
    • java.lang.reflect.ParameterizedType
    • java.lang.reflect.TypeVariable<D>
    • java.lang.reflect.WildcardType
  • org.w3c.dom.TypeInfo
  • javax.lang.model.type.TypeMirror
    • javax.lang.model.type.ArrayType
    • javax.lang.model.type.DeclaredType
      • javax.lang.model.type.ErrorType
    • javax.lang.model.type.ErrorType
    • javax.lang.model.type.ExecutableType
    • javax.lang.model.type.NoType
    • javax.lang.model.type.NullType
    • javax.lang.model.type.PrimitiveType
    • javax.lang.model.type.ReferenceType
      • javax.lang.model.type.ArrayType
      • javax.lang.model.type.DeclaredType
        • javax.lang.model.type.ErrorType
      • javax.lang.model.type.ErrorType
      • javax.lang.model.type.NullType
      • javax.lang.model.type.TypeVariable
    • javax.lang.model.type.TypeVariable
    • javax.lang.model.type.WildcardType
  • javax.lang.model.util.Types
  • javax.lang.model.type.TypeVisitor<R,P>
  • javax.swing.UIDefaults.ActiveValue
  • javax.swing.UIDefaults.LazyValue
  • javax.swing.plaf.UIResource
  • javax.swing.undo.UndoableEdit
  • org.omg.PortableInterceptor.UNKNOWN
  • javax.xml.bind.Unmarshaller
  • java.rmi.server.Unreferenced
  • org.omg.CORBA.UNSUPPORTED_POLICY
  • org.omg.CORBA.UNSUPPORTED_POLICY_VALUE
  • javax.xml.crypto.URIDereferencer
  • javax.print.URIException
  • javax.xml.crypto.URIReference
    • javax.xml.crypto.dom.DOMURIReference
    • javax.xml.crypto.dsig.Reference (also extends javax.xml.crypto.XMLStructure)
    • javax.xml.crypto.dsig.keyinfo.RetrievalMethod (also extends javax.xml.crypto.XMLStructure)
  • javax.xml.transform.URIResolver
  • java.net.URLStreamHandlerFactory
  • org.omg.PortableInterceptor.USER_EXCEPTION
  • org.w3c.dom.UserDataHandler
  • javax.rmi.CORBA.UtilDelegate
  • javax.xml.bind.ValidationEvent
    • javax.xml.bind.NotIdentifiableEvent
    • javax.xml.bind.ParseConversionEvent
    • javax.xml.bind.PrintConversionEvent
  • javax.xml.bind.ValidationEventHandler
  • javax.xml.bind.ValidationEventLocator
  • javax.xml.bind.Validator
  • org.omg.CORBA.portable.ValueFactory
  • javax.rmi.CORBA.ValueHandler
    • javax.rmi.CORBA.ValueHandlerMultiFormat
  • org.omg.CORBA.portable.ValueInputStream
  • org.omg.CORBA.portable.ValueOutputStream
  • javax.swing.text.ViewFactory
  • java.beans.Visibility
    • java.beans.beancontext.BeanContext (also extends java.beans.beancontext.BeanContextChild, java.util.Collection<E>, java.beans.DesignMode)
      • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContextServicesListener)
    • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContext, java.beans.beancontext.BeanContextServicesListener)
  • org.omg.CORBA.VM_ABSTRACT
  • org.omg.CORBA.VM_CUSTOM
  • org.omg.CORBA.VM_NONE
  • org.omg.CORBA.VM_TRUNCATABLE
  • java.nio.file.Watchable
  • java.nio.file.WatchEvent.Kind<T>
  • java.nio.file.WatchEvent.Modifier
  • javax.xml.ws.WebServiceContext
  • javax.swing.WindowConstants
  • java.sql.Wrapper
    • javax.sql.rowset.CachedRowSet (also extends javax.sql.rowset.Joinable, javax.sql.RowSet)
      • javax.sql.rowset.FilteredRowSet
      • javax.sql.rowset.JoinRowSet
      • javax.sql.rowset.WebRowSet
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
    • java.sql.CallableStatement
    • java.sql.Connection
    • java.sql.DatabaseMetaData
    • javax.sql.DataSource (also extends javax.sql.CommonDataSource)
    • javax.sql.rowset.FilteredRowSet
    • javax.sql.rowset.JdbcRowSet (also extends javax.sql.rowset.Joinable, javax.sql.RowSet)
    • javax.sql.rowset.JoinRowSet
    • java.sql.ParameterMetaData
    • java.sql.PreparedStatement
      • java.sql.CallableStatement
    • java.sql.ResultSet
      • javax.sql.rowset.CachedRowSet (also extends javax.sql.rowset.Joinable, javax.sql.RowSet)
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
        • javax.sql.rowset.WebRowSet
          • javax.sql.rowset.FilteredRowSet
          • javax.sql.rowset.JoinRowSet
      • javax.sql.rowset.FilteredRowSet
      • javax.sql.rowset.JdbcRowSet (also extends javax.sql.rowset.Joinable, javax.sql.RowSet)
      • javax.sql.rowset.JoinRowSet
      • javax.sql.RowSet
        • javax.sql.rowset.CachedRowSet (also extends javax.sql.rowset.Joinable)
          • javax.sql.rowset.FilteredRowSet
          • javax.sql.rowset.JoinRowSet
          • javax.sql.rowset.WebRowSet
            • javax.sql.rowset.FilteredRowSet
            • javax.sql.rowset.JoinRowSet
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JdbcRowSet (also extends javax.sql.rowset.Joinable)
        • javax.sql.rowset.JoinRowSet
        • javax.sql.rowset.spi.SyncResolver
        • javax.sql.rowset.WebRowSet
          • javax.sql.rowset.FilteredRowSet
          • javax.sql.rowset.JoinRowSet
      • javax.sql.rowset.spi.SyncResolver
      • javax.sql.rowset.WebRowSet
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
    • java.sql.ResultSetMetaData
      • javax.sql.RowSetMetaData
    • javax.sql.RowSet
      • javax.sql.rowset.CachedRowSet (also extends javax.sql.rowset.Joinable)
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
        • javax.sql.rowset.WebRowSet
          • javax.sql.rowset.FilteredRowSet
          • javax.sql.rowset.JoinRowSet
      • javax.sql.rowset.FilteredRowSet
      • javax.sql.rowset.JdbcRowSet (also extends javax.sql.rowset.Joinable)
      • javax.sql.rowset.JoinRowSet
      • javax.sql.rowset.spi.SyncResolver
      • javax.sql.rowset.WebRowSet
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
    • javax.sql.RowSetMetaData
    • java.sql.Statement
      • java.sql.CallableStatement
      • java.sql.PreparedStatement
        • java.sql.CallableStatement
    • javax.sql.rowset.spi.SyncResolver
    • javax.sql.rowset.WebRowSet
      • javax.sql.rowset.FilteredRowSet
      • javax.sql.rowset.JoinRowSet
  • java.security.cert.X509Extension
  • javax.transaction.xa.XAResource
  • javax.transaction.xa.Xid
  • javax.xml.crypto.XMLCryptoContext
    • javax.xml.crypto.dsig.XMLSignContext
    • javax.xml.crypto.dsig.XMLValidateContext
  • javax.xml.stream.util.XMLEventAllocator
  • javax.xml.stream.util.XMLEventConsumer
    • javax.xml.stream.XMLEventWriter
  • org.xml.sax.XMLReader
    • org.xml.sax.XMLFilter
  • javax.xml.stream.XMLReporter
  • javax.xml.stream.XMLResolver
  • javax.xml.stream.XMLStreamConstants
    • javax.xml.stream.events.Attribute
      • javax.xml.stream.events.Namespace
    • javax.xml.stream.events.Characters
    • javax.xml.stream.events.Comment
    • javax.xml.stream.events.DTD
    • javax.xml.stream.events.EndDocument
    • javax.xml.stream.events.EndElement
    • javax.xml.stream.events.EntityDeclaration
    • javax.xml.stream.events.EntityReference
    • javax.xml.stream.events.Namespace
    • javax.xml.stream.events.NotationDeclaration
    • javax.xml.stream.events.ProcessingInstruction
    • javax.xml.stream.events.StartDocument
    • javax.xml.stream.events.StartElement
    • javax.xml.stream.events.XMLEvent
      • javax.xml.stream.events.Attribute
        • javax.xml.stream.events.Namespace
      • javax.xml.stream.events.Characters
      • javax.xml.stream.events.Comment
      • javax.xml.stream.events.DTD
      • javax.xml.stream.events.EndDocument
      • javax.xml.stream.events.EndElement
      • javax.xml.stream.events.EntityDeclaration
      • javax.xml.stream.events.EntityReference
      • javax.xml.stream.events.Namespace
      • javax.xml.stream.events.NotationDeclaration
      • javax.xml.stream.events.ProcessingInstruction
      • javax.xml.stream.events.StartDocument
      • javax.xml.stream.events.StartElement
    • javax.xml.stream.XMLStreamReader
  • javax.xml.stream.XMLStreamWriter
  • javax.xml.crypto.XMLStructure
    • javax.xml.crypto.dsig.CanonicalizationMethod
    • javax.xml.crypto.dsig.DigestMethod (also extends javax.xml.crypto.AlgorithmMethod)
    • javax.xml.crypto.dsig.keyinfo.KeyInfo
    • javax.xml.crypto.dsig.keyinfo.KeyName
    • javax.xml.crypto.dsig.keyinfo.KeyValue
    • javax.xml.crypto.dsig.Manifest
    • javax.xml.crypto.dsig.keyinfo.PGPData
    • javax.xml.crypto.dsig.Reference (also extends javax.xml.crypto.URIReference)
    • javax.xml.crypto.dsig.keyinfo.RetrievalMethod (also extends javax.xml.crypto.URIReference)
    • javax.xml.crypto.dsig.SignatureMethod (also extends javax.xml.crypto.AlgorithmMethod)
    • javax.xml.crypto.dsig.SignatureProperties
    • javax.xml.crypto.dsig.SignatureProperty
    • javax.xml.crypto.dsig.SignedInfo
    • javax.xml.crypto.dsig.Transform (also extends javax.xml.crypto.AlgorithmMethod)
      • javax.xml.crypto.dsig.CanonicalizationMethod
    • javax.xml.crypto.dsig.keyinfo.X509Data
    • javax.xml.crypto.dsig.keyinfo.X509IssuerSerial
    • javax.xml.crypto.dsig.XMLObject
    • javax.xml.crypto.dsig.XMLSignature
    • javax.xml.crypto.dsig.XMLSignature.SignatureValue
  • javax.xml.xpath.XPath
  • javax.xml.xpath.XPathExpression
  • javax.xml.xpath.XPathFunction
  • javax.xml.xpath.XPathFunctionResolver
  • javax.xml.xpath.XPathVariableResolver

Annotation Type Hierarchy

  • java.beans.Transient (implements java.lang.annotation.Annotation)
  • java.beans.ConstructorProperties (implements java.lang.annotation.Annotation)
  • java.lang.SuppressWarnings (implements java.lang.annotation.Annotation)
  • java.lang.Override (implements java.lang.annotation.Annotation)
  • java.lang.Deprecated (implements java.lang.annotation.Annotation)
  • java.lang.annotation.Target (implements java.lang.annotation.Annotation)
  • java.lang.annotation.Retention (implements java.lang.annotation.Annotation)
  • java.lang.annotation.Inherited (implements java.lang.annotation.Annotation)
  • java.lang.annotation.Documented (implements java.lang.annotation.Annotation)
  • javax.annotation.Resources (implements java.lang.annotation.Annotation)
  • javax.annotation.Resource (implements java.lang.annotation.Annotation)
  • javax.annotation.PreDestroy (implements java.lang.annotation.Annotation)
  • javax.annotation.PostConstruct (implements java.lang.annotation.Annotation)
  • javax.annotation.Generated (implements java.lang.annotation.Annotation)
  • javax.annotation.processing.SupportedSourceVersion (implements java.lang.annotation.Annotation)
  • javax.annotation.processing.SupportedOptions (implements java.lang.annotation.Annotation)
  • javax.annotation.processing.SupportedAnnotationTypes (implements java.lang.annotation.Annotation)
  • javax.jws.WebService (implements java.lang.annotation.Annotation)
  • javax.jws.WebResult (implements java.lang.annotation.Annotation)
  • javax.jws.WebParam (implements java.lang.annotation.Annotation)
  • javax.jws.WebMethod (implements java.lang.annotation.Annotation)
  • javax.jws.Oneway (implements java.lang.annotation.Annotation)
  • javax.jws.HandlerChain (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPMessageHandlers (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPMessageHandler (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPBinding (implements java.lang.annotation.Annotation)
  • javax.jws.soap.InitParam (implements java.lang.annotation.Annotation)
  • javax.management.ObjectNameTemplate (implements java.lang.annotation.Annotation)
  • javax.management.NotificationInfos (implements java.lang.annotation.Annotation)
  • javax.management.NotificationInfo (implements java.lang.annotation.Annotation)
  • javax.management.ManagedOperation (implements java.lang.annotation.Annotation)
  • javax.management.ManagedAttribute (implements java.lang.annotation.Annotation)
  • javax.management.MBean (implements java.lang.annotation.Annotation)
  • javax.management.DescriptorFields (implements java.lang.annotation.Annotation)
  • javax.management.Description (implements java.lang.annotation.Annotation)
  • javax.management.MXBean (implements java.lang.annotation.Annotation)
  • javax.management.DescriptorKey (implements java.lang.annotation.Annotation)
  • javax.management.openmbean.MXBeanMappingFactoryClass (implements java.lang.annotation.Annotation)
  • javax.management.openmbean.MXBeanMappingClass (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSeeAlso (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlValue (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlTransient (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchemaTypes (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchemaType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchema (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlRootElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlRegistry (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlNs (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlMixed (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlMimeType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlList (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlInlineBinaryData (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlIDREF (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlID (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlEnumValue (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlEnum (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElements (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementRefs (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementRef (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementDecl (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAttribute (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAttachmentRef (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAnyElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAnyAttribute (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAccessorType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAccessorOrder (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter (implements java.lang.annotation.Annotation)
  • javax.xml.ws.RespectBinding (implements java.lang.annotation.Annotation)
  • javax.xml.ws.FaultAction (implements java.lang.annotation.Annotation)
  • javax.xml.ws.Action (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceRefs (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceRef (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceProvider (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceClient (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebFault (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebEndpoint (implements java.lang.annotation.Annotation)
  • javax.xml.ws.ServiceMode (implements java.lang.annotation.Annotation)
  • javax.xml.ws.ResponseWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.ws.RequestWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.ws.BindingType (implements java.lang.annotation.Annotation)
  • javax.xml.ws.soap.MTOM (implements java.lang.annotation.Annotation)
  • javax.xml.ws.soap.Addressing (implements java.lang.annotation.Annotation)
  • javax.xml.ws.spi.WebServiceFeatureAnnotation (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.awt.TrayIcon.MessageType
      • java.awt.MultipleGradientPaint.CycleMethod
      • java.awt.MultipleGradientPaint.ColorSpaceType
      • java.awt.GraphicsDevice.WindowTranslucency
      • java.awt.Dialog.ModalityType
      • java.awt.Dialog.ModalExclusionType
      • java.awt.Desktop.Action
      • java.awt.Component.BaselineResizeBehavior
      • java.lang.Thread.State
      • java.lang.ProcessBuilder.Redirect.Type
      • java.lang.annotation.RetentionPolicy
      • java.lang.annotation.ElementType
      • java.lang.management.MemoryType
      • java.math.RoundingMode
      • java.net.StandardProtocolFamily (implements java.net.ProtocolFamily)
      • java.net.Proxy.Type
      • java.net.Authenticator.RequestorType
      • java.nio.file.StandardOpenOption (implements java.nio.file.OpenOption)
      • java.nio.file.StandardCopyOption (implements java.nio.file.CopyOption)
      • java.nio.file.LinkOption (implements java.nio.file.CopyOption, java.nio.file.OpenOption)
      • java.nio.file.FileVisitResult
      • java.nio.file.FileVisitOption
      • java.nio.file.AccessMode
      • java.nio.file.attribute.PosixFilePermission
      • java.nio.file.attribute.AclEntryType
      • java.nio.file.attribute.AclEntryPermission
      • java.nio.file.attribute.AclEntryFlag
      • java.security.KeyRep.Type
      • java.security.cert.PKIXReason (implements java.security.cert.CertPathValidatorException.Reason)
      • java.security.cert.CRLReason
      • java.security.cert.CertPathValidatorException.BasicReason (implements java.security.cert.CertPathValidatorException.Reason)
      • java.sql.RowIdLifetime
      • java.sql.ClientInfoStatus
      • java.text.Normalizer.Form
      • java.util.Formatter.BigDecimalLayoutForm
      • java.util.concurrent.TimeUnit
      • javax.annotation.Resource.AuthenticationType
      • javax.jws.WebParam.Mode
      • javax.jws.soap.SOAPBinding.Style
      • javax.jws.soap.SOAPBinding.Use
      • javax.jws.soap.SOAPBinding.ParameterStyle
      • javax.lang.model.SourceVersion
      • javax.lang.model.element.NestingKind
      • javax.lang.model.element.Modifier
      • javax.lang.model.element.ElementKind
      • javax.lang.model.type.TypeKind
      • javax.management.Impact
      • javax.net.ssl.SSLEngineResult.Status
      • javax.net.ssl.SSLEngineResult.HandshakeStatus
      • javax.swing.SwingWorker.StateValue
      • javax.swing.SortOrder
      • javax.swing.RowFilter.ComparisonType
      • javax.swing.LayoutStyle.ComponentPlacement
      • javax.swing.JTable.PrintMode
      • javax.swing.GroupLayout.Alignment
      • javax.swing.DropMode
      • javax.swing.event.RowSorterEvent.Type
      • javax.swing.text.html.FormSubmitEvent.MethodType
      • javax.tools.StandardLocation (implements javax.tools.JavaFileManager.Location)
      • javax.tools.JavaFileObject.Kind
      • javax.tools.Diagnostic.Kind
      • javax.xml.bind.annotation.XmlNsForm
      • javax.xml.bind.annotation.XmlAccessType
      • javax.xml.bind.annotation.XmlAccessOrder
      • javax.xml.ws.Service.Mode
      • javax.xml.ws.handler.MessageContext.Scope
Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV NEXT FRAMES NO FRAMES


Serialized Form (Java Platform SE 7 b59)

DRAFT ea-b59
PREV NEXT FRAMES NO FRAMES

Serialized Form

Package java.applet

Class java.applet.Applet extends Panel implements Serializable

serialVersionUID: -5836846270535785031L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
Read an applet from an object input stream.

Throws:
HeadlessException - if GraphicsEnvironment.isHeadless() returns true
ClassNotFoundException
IOException
Since:
1.4
See Also:
GraphicsEnvironment.isHeadless()
Serialized Fields

accessibleContext

AccessibleContext accessibleContext

Class java.applet.Applet.AccessibleApplet extends Panel.AccessibleAWTPanel implements Serializable

serialVersionUID: 8127374778187708896L

Package java.awt

Class java.awt.AWTError extends Error implements Serializable

serialVersionUID: -1819846354050686206L

Class java.awt.AWTEvent extends EventObject implements Serializable

serialVersionUID: -1825314779160409405L

Serialized Fields

bdata

byte[] bdata

id

int id
The event's id.

See Also:
AWTEvent.getID(), AWTEvent.AWTEvent(java.lang.Object, int)

consumed

boolean consumed
Controls whether or not the event is sent back down to the peer once the source has processed it - false means it's sent to the peer; true means it's not. Semantic events always have a 'true' value since they were generated by the peer in response to a low-level event.

See Also:
AWTEvent.consume(), AWTEvent.isConsumed()

Class java.awt.AWTException extends Exception implements Serializable

serialVersionUID: -1900414231151323879L

Class java.awt.AWTKeyStroke extends Object implements Serializable

serialVersionUID: -6430539691155161871L

Serialization Methods

readResolve

protected Object readResolve()
                      throws ObjectStreamException
Returns a cached instance of AWTKeyStroke (or a subclass of AWTKeyStroke) which is equal to this instance.

Throws:
ObjectStreamException
Serialized Fields

keyChar

char keyChar

keyCode

int keyCode

modifiers

int modifiers

onKeyRelease

boolean onKeyRelease

Class java.awt.AWTPermission extends BasicPermission implements Serializable

serialVersionUID: 8890392402588814465L

Class java.awt.BorderLayout extends Object implements Serializable

serialVersionUID: -8658291919501921765L

Serialized Fields

hgap

int hgap
Constructs a border layout with the horizontal gaps between components. The horizontal gap is specified by hgap.

See Also:
BorderLayout.getHgap(), BorderLayout.setHgap(int)

vgap

int vgap
Constructs a border layout with the vertical gaps between components. The vertical gap is specified by vgap.

See Also:
BorderLayout.getVgap(), BorderLayout.setVgap(int)

north

Component north
Constant to specify components location to be the north portion of the border layout.

See Also:
BorderLayout.getChild(String, boolean),
BorderLayout.addLayoutComponent(java.awt.Component, java.lang.Object),
BorderLayout.getLayoutAlignmentX(java.awt.Container),
BorderLayout.getLayoutAlignmentY(java.awt.Container),
BorderLayout.removeLayoutComponent(java.awt.Component)

west

Component west
Constant to specify components location to be the west portion of the border layout.

See Also:
BorderLayout.getChild(String, boolean),
BorderLayout.addLayoutComponent(java.awt.Component, java.lang.Object),
BorderLayout.getLayoutAlignmentX(java.awt.Container),
BorderLayout.getLayoutAlignmentY(java.awt.Container),
BorderLayout.removeLayoutComponent(java.awt.Component)

east

Component east
Constant to specify components location to be the east portion of the border layout.

See Also:
BorderLayout.getChild(String, boolean),
BorderLayout.addLayoutComponent(java.awt.Component, java.lang.Object),
BorderLayout.getLayoutAlignmentX(java.awt.Container),
BorderLayout.getLayoutAlignmentY(java.awt.Container),
BorderLayout.removeLayoutComponent(java.awt.Component)

south

Component south
Constant to specify components location to be the south portion of the border layout.

See Also:
BorderLayout.getChild(String, boolean),
BorderLayout.addLayoutComponent(java.awt.Component, java.lang.Object),
BorderLayout.getLayoutAlignmentX(java.awt.Container),
BorderLayout.getLayoutAlignmentY(java.awt.Container),
BorderLayout.removeLayoutComponent(java.awt.Component)

center

Component center
Constant to specify components location to be the center portion of the border layout.

See Also:
BorderLayout.getChild(String, boolean),
BorderLayout.addLayoutComponent(java.awt.Component, java.lang.Object),
BorderLayout.getLayoutAlignmentX(java.awt.Container),
BorderLayout.getLayoutAlignmentY(java.awt.Container),
BorderLayout.removeLayoutComponent(java.awt.Component)

firstLine

Component firstLine
A relative positioning constant, that can be used instead of north, south, east, west or center. mixing the two types of constants can lead to unpredicable results. If you use both types, the relative constants will take precedence. For example, if you add components using both the NORTH and BEFORE_FIRST_LINE constants in a container whose orientation is LEFT_TO_RIGHT, only the BEFORE_FIRST_LINE will be layed out. This will be the same for lastLine, firstItem, lastItem.

lastLine

Component lastLine
A relative positioning constant, that can be used instead of north, south, east, west or center. Please read Description for firstLine.

firstItem

Component firstItem
A relative positioning constant, that can be used instead of north, south, east, west or center. Please read Description for firstLine.

lastItem

Component lastItem
A relative positioning constant, that can be used instead of north, south, east, west or center. Please read Description for firstLine.

Class java.awt.Button extends Component implements Serializable

serialVersionUID: -8774683716313001058L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
Reads the ObjectInputStream and if it isn't null adds a listener to receive action events fired by the button. Unrecognized keys or values will be ignored.

Throws:
HeadlessException - if GraphicsEnvironment.isHeadless returns true
ClassNotFoundException
IOException
See Also:
Button.removeActionListener(ActionListener),
Button.addActionListener(ActionListener),
GraphicsEnvironment.isHeadless(),
Button.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Writes default serializable fields to stream. Writes a list of serializable ActionListeners as optional data. The non-serializable ActionListeners are detected and no attempt is made to serialize them.

Serial Data:
null terminated sequence of 0 or more pairs: the pair consists of a String and an Object; the String indicates the type of object and is one of the following: actionListenerK indicating an ActionListener object
Throws:
IOException
See Also:
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.actionListenerK, Button.readObject(ObjectInputStream)
Serialized Fields

label

String label
The button's label. This value may be null.

See Also:
Button.getLabel(), Button.setLabel(String)

actionCommand

String actionCommand
The action to be performed once a button has been pressed. This value may be null.

See Also:
Button.getActionCommand(), Button.setActionCommand(String)

buttonSerializedDataVersion

int buttonSerializedDataVersion

Class java.awt.Button.AccessibleAWTButton extends Component.AccessibleAWTComponent implements Serializable

serialVersionUID: -5932203980244017102L

Class java.awt.Canvas extends Component implements Serializable

serialVersionUID: -2284879212465893870L

Class java.awt.Canvas.AccessibleAWTCanvas extends Component.AccessibleAWTComponent implements Serializable

serialVersionUID: -6325592262103146699L

Class java.awt.CardLayout extends Object implements Serializable

serialVersionUID: -4328196481005934313L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
Reads serializable fields from stream.

Throws:
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Writes serializable fields to stream.

Throws:
IOException
Serialized Fields

currentCard

int currentCard

hgap

int hgap

tab

Hashtable<K,V> tab
deprectated, for forward compatibility only

vector

Vector<E> vector

vgap

int vgap

Class java.awt.Checkbox extends Component implements Serializable

serialVersionUID: 7270714317450821763L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
Reads the ObjectInputStream and if it isn't null adds a listener to receive item events fired by the Checkbox. Unrecognized keys or values will be ignored.

Throws:
HeadlessException - if GraphicsEnvironment.isHeadless returns true
ClassNotFoundException
IOException
See Also:
Checkbox.removeItemListener(ItemListener),
Checkbox.addItemListener(ItemListener),
GraphicsEnvironment.isHeadless(),
Checkbox.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Writes default serializable fields to stream. Writes a list of serializable ItemListeners as optional data. The non-serializable ItemListeners are detected and no attempt is made to serialize them.

Serial Data:
null terminated sequence of 0 or more pairs; the pair consists of a String and an Object; the String indicates the type of object and is one of the following: itemListenerK indicating an ItemListener object
Throws:
IOException
See Also:
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.itemListenerK, Checkbox.readObject(ObjectInputStream)
Serialized Fields

label

String label
The label of the Checkbox. This field can be null.

See Also:
Checkbox.getLabel(), Checkbox.setLabel(String)

state

boolean state
The state of the Checkbox.

See Also:
Checkbox.getState(), Checkbox.setState(boolean)

group

CheckboxGroup group
The check box group. This field can be null indicating that the checkbox is not a group checkbox.

See Also:
Checkbox.getCheckboxGroup(), Checkbox.setCheckboxGroup(CheckboxGroup)

checkboxSerializedDataVersion

int checkboxSerializedDataVersion

Class java.awt.Checkbox.AccessibleAWTCheckbox extends Component.AccessibleAWTComponent implements Serializable

serialVersionUID: 7881579233144754107L

Class java.awt.CheckboxGroup extends Object implements Serializable

serialVersionUID: 3729780091441768983L

Serialized Fields

selectedCheckbox

Checkbox selectedCheckbox
The current choice.

See Also:
CheckboxGroup.getCurrent(), CheckboxGroup.setCurrent(Checkbox)

Class java.awt.CheckboxMenuItem extends MenuItem implements Serializable

serialVersionUID: 6190621106981774043L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
Throws:
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Writes default serializable fields to stream. Writes a list of serializable ItemListeners as optional data. The non-serializable ItemListeners are detected and no attempt is made to serialize them.

Serial Data:
null terminated sequence of 0 or more pairs; the pair consists of a String and an Object; the String indicates the type of object and is one of the following: itemListenerK indicating an ItemListener object
Throws:
IOException
See Also:
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.itemListenerK, CheckboxMenuItem.readObject(ObjectInputStream)
Serialized Fields

state

boolean state
The state of a checkbox menu item

See Also:
CheckboxMenuItem.getState(), CheckboxMenuItem.setState(boolean)

checkboxMenuItemSerializedDataVersion

int checkboxMenuItemSerializedDataVersion

Class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem extends MenuItem.AccessibleAWTMenuItem implements Serializable

serialVersionUID: -1122642964303476L

Class java.awt.Choice extends Component implements Serializable

serialVersionUID: -4075310674757313071L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
Reads the ObjectInputStream and if it isn't null adds a listener to receive item events fired by the Choice item. Unrecognized keys or values will be ignored.

Throws:
HeadlessException - if GraphicsEnvironment.isHeadless returns true
ClassNotFoundException
IOException
See Also:
Choice.removeItemListener(ItemListener),
Choice.addItemListener(ItemListener),
GraphicsEnvironment.isHeadless(),
Choice.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Writes default serializable fields to stream. Writes a list of serializable ItemListeners as optional data. The non-serializable ItemListeners are detected and no attempt is made to serialize them.

Serial Data:
null terminated sequence of 0 or more pairs; the pair consists of a String and an Object; the String indicates the type of object and is one of the following: itemListenerK indicating an ItemListener object
Throws:
IOException
See Also:
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.itemListenerK, Choice.readObject(ObjectInputStream)
Serialized Fields

pItems

Vector<E> pItems
The items for the Choice. This can be a null value.

See Also:
Choice.add(String),
Choice.addItem(String),
Choice.getItem(int),
Choice.getItemCount(),
Choice.insert(String, int),
Choice.remove(String)

selectedIndex

int selectedIndex
The index of the current choice for this Choice or -1 if nothing is selected.

See Also:
Choice.getSelectedItem(), Choice.select(int)

choiceSerializedDataVersion

int choiceSerializedDataVersion

Class java.awt.Choice.AccessibleAWTChoice extends Component.AccessibleAWTComponent implements Serializable

serialVersionUID: 7175603582428509322L

Class java.awt.Color extends Object implements Serializable

serialVersionUID: 118526816881161077L

Serialized Fields

value

int value
The color value.

See Also:
Color.getRGB()

frgbvalue

float[] frgbvalue
The color value in the default sRGB ColorSpace as float components (no alpha). If null after object construction, this must be an sRGB color constructed with 8-bit precision, so compute from the int color value.

See Also:
Color.getRGBColorComponents(float[]), Color.getRGBComponents(float[])

fvalue

float[] fvalue
The color value in the native ColorSpace as float components (no alpha). If null after object construction, this must be an sRGB color constructed with 8-bit precision, so compute from the int color value.

See Also:
Color.getRGBColorComponents(float[]), Color.getRGBComponents(float[])

falpha

float falpha
The alpha value as a float component. If frgbvalue is null, this is not valid data, so compute from the int color value.

See Also:
Color.getRGBComponents(float[]), Color.getComponents(float[])

cs

ColorSpace cs
The ColorSpace. If null, then it's default is sRGB.

See Also:
Color.getColor(java.lang.String),
Color.getColorSpace(),
Color.getColorComponents(float[])

Class java.awt.Component extends Object implements Serializable

serialVersionUID: -7644114512714619750L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
Reads the ObjectInputStream and if it isn't null adds a listener to receive a variety of events fired by the component. Unrecognized keys or values will be ignored.

Throws:
ClassNotFoundException
IOException
See Also:
Component.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Writes default serializable fields to stream. Writes a variety of serializable listeners as optional data. The non-serializable listeners are detected and no attempt is made to serialize them.

Serial Data:
null terminated sequence of 0 or more pairs; the pair consists of a String and an Object; the String indicates the type of object and is one of the following (as of 1.4): componentListenerK indicating an ComponentListener object; focusListenerK indicating an FocusListener object; keyListenerK indicating an KeyListener object; mouseListenerK indicating an MouseListener object; mouseMotionListenerK indicating an MouseMotionListener object; inputMethodListenerK indicating an InputMethodListener object; hierarchyListenerK indicating an HierarchyListener object; hierarchyBoundsListenerK indicating an HierarchyBoundsListener object; mouseWheelListenerK indicating an MouseWheelListener object, an optional ComponentOrientation (after inputMethodListener, as of 1.2)
Throws:
IOException
See Also:
AWTEventMulticaster.save(java.io.ObjectOutputStream, java.lang.String, java.util.EventListener), Component.componentListenerK, Component.focusListenerK, Component.keyListenerK, Component.mouseListenerK, Component.mouseMotionListenerK, Component.inputMethodListenerK, Component.hierarchyListenerK, Component.hierarchyBoundsListenerK, Component.mouseWheelListenerK, Component.readObject(ObjectInputStream)
Serialized Fields

x

int x
The x position of the component in the parent's coordinate system.

See Also:
Component.getLocation()

y

int y
The y position of the component in the parent's coordinate system.

See Also:
Component.getLocation()

width

int width
The width of the component.

See Also:
Component.getSize()

height

int height
The height of the component.

See Also:
Component.getSize()

foreground

Color foreground
The foreground color for this component. foreground can be null.

See Also:
Component.getForeground(), Component.setForeground(java.awt.Color)

background

Color background
The background color for this component. background can be null.

See Also:
Component.getBackground(), Component.setBackground(java.awt.Color)

font

Font font
The font used by this component. The font can be null.

See Also:
Component.getFont(), Component.setFont(java.awt.Font)

peerFont

Font peerFont
The font which the peer is currently using. (null if no peer exists.)

cursor

Cursor cursor
The cursor displayed when pointer is over this component. This value can be null.

See Also:
Component.getCursor(), Component.setCursor(java.awt.Cursor)

locale

Locale locale
The locale for the component.

See Also:
Component.getLocale(), Component.setLocale(java.util.Locale)

ignoreRepaint

boolean ignoreRepaint
True when the object should ignore all repaint events.

Since:
1.4
See Also:
Component.setIgnoreRepaint(boolean), Component.getIgnoreRepaint()

visible

boolean visible
True when the object is visible. An object that is not visible is not drawn on the screen.

See Also:
Component.isVisible(), Component.setVisible(boolean)

enabled

boolean enabled
True when the object is enabled. An object that is not enabled does not interact with the user.

See Also:
Component.isEnabled(), Component.setEnabled(boolean)

valid

boolean valid
True when the object is valid. An invalid object needs to be layed out. This flag is set to false when the object size is changed.

See Also:
Component.isValid(),
Component.validate(),
Component.invalidate()

dropTarget

DropTarget dropTarget
The DropTarget associated with this component.

Since:
1.2
See Also:
Component.setDropTarget(java.awt.dnd.DropTarget), Component.getDropTarget()

popups

Vector<E> popups
See Also:
Component.add(java.awt.PopupMenu)

name

String name
A component's name. This field can be null.

See Also:
Component.getName(), Component.setName(String)

nameExplicitlySet

boolean nameExplicitlySet
A bool to determine whether the name has been set explicitly. nameExplicitlySet will be false if the name has not been set and true if it has.

See Also:
Component.getName(), Component.setName(String)

focusable

boolean focusable
Indicates whether this Component can be focused.

Since:
1.4
See Also:
Component.setFocusable(boolean), Component.isFocusable()

isFocusTraversableOverridden

int isFocusTraversableOverridden
Tracks whether this Component is relying on default focus travesability.

Since:
1.4

focusTraversalKeys

Set<E>[] focusTraversalKeys
The focus traversal keys. These keys will generate focus traversal behavior for Components for which focus traversal keys are enabled. If a value of null is specified for a traversal key, this Component inherits that traversal key from its parent. If all ancestors of this Component have null specified for that traversal key, then the current KeyboardFocusManager's default traversal key is used.

Since:
1.4
See Also:
Component.setFocusTraversalKeys(int, java.util.Set), Component.getFocusTraversalKeys(int)

focusTraversalKeysEnabled

boolean focusTraversalKeysEnabled
Indicates whether focus traversal keys are enabled for this Component. Components for which focus traversal keys are disabled receive key events for focus traversal keys. Components for which focus traversal keys are enabled do not see these events; instead, the events are automatically converted to traversal operations.

Since:
1.4
See Also:
Component.setFocusTraversalKeysEnabled(boolean), Component.getFocusTraversalKeysEnabled()

minSize

Dimension minSize
Minimum size. (This field perhaps should have been transient).

minSizeSet

boolean minSizeSet
Whether or not setMinimumSize has been invoked with a non-null value.

prefSize

Dimension prefSize
Preferred size. (This field perhaps should have been transient).

prefSizeSet

boolean prefSizeSet
Whether or not setPreferredSize has been invoked with a non-null value.

maxSize

Dimension maxSize
Maximum size

maxSizeSet

boolean maxSizeSet
Whether or not setMaximumSize has been invoked with a non-null value.

newEventsOnly

boolean newEventsOnly
newEventsOnly will be true if the event is one of the event types enabled for the component. It will then allow for normal processing to continue. If it is false the event is passed to the component's parent and up the ancestor tree until the event has been consumed.

See Also:
Component.dispatchEvent(java.awt.AWTEvent)

eventMask

long eventMask
The eventMask is ONLY set by subclasses via enableEvents. The mask should NOT be set when listeners are registered so that we can distinguish the difference between when listeners request events and subclasses request them. One bit is used to indicate whether input methods are enabled; this bit is set by enableInputMethods and is on by default.

See Also:
Component.enableInputMethods(boolean), AWTEvent

changeSupport

PropertyChangeSupport changeSupport
If any PropertyChangeListeners have been registered, the changeSupport field describes them.

Since:
1.2
See Also:
Component.addPropertyChangeListener(java.beans.PropertyChangeListener),
Component.removePropertyChangeListener(java.beans.PropertyChangeListener),
Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

isPacked

boolean isPacked

boundsOp

int boundsOp
Pseudoparameter for direct Geometry API (setLocation, setBounds setSize to signal setBounds what's changing. Should be used under TreeLock. This is only needed due to the inability to change the cross-calling order of public and deprecated methods.

autoFocusTransferOnDisposal

boolean autoFocusTransferOnDisposal

componentSerializedDataVersion

int componentSerializedDataVersion
Component Serialized Data Version.

accessibleContext

AccessibleContext accessibleContext

Class java.awt.Component.AccessibleAWTComponent extends AccessibleContext implements Serializable

serialVersionUID: 642321655757800191L

Serialized Fields

accessibleAWTComponentHandler

ComponentListener accessibleAWTComponentHandler

accessibleAWTFocusHandler

FocusListener accessibleAWTFocusHandler

Class java.awt.ComponentOrientation extends Object implements Serializable

serialVersionUID: -4113291392143563828L

Serialized Fields

orientation

int orientation

Class java.awt.Container extends Component implements Serializable

serialVersionUID: 4613797578919906343L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
Deserializes this Container from the specified ObjectInputStream.
  • Reads default serializable fields from the stream.
  • Reads a list of serializable ContainerListener(s) as optional data. If the list is null, no Listeners are installed.
  • Reads this Container's FocusTraversalPolicy, which may be null, as optional data.

Throws:
ClassNotFoundException
IOException
See Also:
Container.addContainerListener(java.awt.event.ContainerListener), Container.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Serializes this Container to the specified ObjectOutputStream.
  • Writes default serializable fields to the stream.
  • Writes a list of serializable ContainerListener(s) as optional data. The non-serializable ContainerListner(s) are detected and no attempt is made to serialize them.
  • Write this Container's FocusTraversalPolicy if and only if it is Serializable; otherwise, null is written.

Serial Data:
null terminated sequence of 0 or more pairs; the pair consists of a String and Object; the String indicates the type of object and is one of the following: containerListenerK indicating an ContainerListener object; the Container's FocusTraversalPolicy, or null
Throws:
IOException
See Also:
AWTEventMulticaster.save(java.io.ObjectOutputStream, java.lang.String, java.util.EventListener), Component.containerListenerK, Container.readObject(ObjectInputStream)
Serialized Fields

component

Component[] component
The components in this container.

containerSerializedDataVersion

int containerSerializedDataVersion
Container Serial Data Version.

dispatcher

java.awt.LightweightDispatcher dispatcher
Event router for lightweight components. If this container is native, this dispatcher takes care of forwarding and retargeting the events to lightweight components contained (if any).

focusCycleRoot

boolean focusCycleRoot
Indicates whether this Component is the root of a focus traversal cycle. Once focus enters a traversal cycle, typically it cannot leave it via focus traversal unless one of the up- or down-cycle keys is pressed. Normal traversal is limited to this Container, and all of this Container's descendants that are not descendants of inferior focus cycle roots.

focusTraversalPolicyProvider

boolean focusTraversalPolicyProvider
Stores the value of focusTraversalPolicyProvider property.

layoutMgr

LayoutManager layoutMgr
Layout manager for this container.

maxSize

Dimension maxSize
Maximum size of this Container.

ncomponents

int ncomponents
The number of components in this container. This value can be null.

Class java.awt.Container.AccessibleAWTContainer extends Component.AccessibleAWTComponent implements Serializable

serialVersionUID: 5081320404842566097L

Serialized Fields

accessibleContainerHandler

ContainerListener accessibleContainerHandler

Class java.awt.ContainerOrderFocusTraversalPolicy extends FocusTraversalPolicy implements Serializable

serialVersionUID: 486933713763926351L

Serialized Fields

FORWARD_TRAVERSAL

int FORWARD_TRAVERSAL

BACKWARD_TRAVERSAL

int BACKWARD_TRAVERSAL

implicitDownCycleTraversal

boolean implicitDownCycleTraversal

Class java.awt.Cursor extends Object implements Serializable

serialVersionUID: 8028237497568985504L

Serialized Fields

type

int type
The chosen cursor type initially set to the DEFAULT_CURSOR.

See Also:
Cursor.getType()

name

String name
The user-visible name of the cursor.

See Also:
Cursor.getName()

Class java.awt.DefaultFocusTraversalPolicy extends ContainerOrderFocusTraversalPolicy implements Serializable

serialVersionUID: 8876966522510157497L

Class java.awt.Dialog extends Window implements Serializable

serialVersionUID: 5920926903803293709L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
Throws:
ClassNotFoundException
IOException
HeadlessException
Serialized Fields

resizable

boolean resizable
A dialog's resizable property. Will be true if the Dialog is to be resizable, otherwise it will be false.

See Also:
Dialog.setResizable(boolean)

undecorated

boolean undecorated
This field indicates whether the dialog is undecorated. This property can only be changed while the dialog is not displayable. undecorated will be true if the dialog is undecorated, otherwise it will be false.

Since:
1.4
See Also:
Dialog.setUndecorated(boolean),
Dialog.isUndecorated(),
Component.isDisplayable()

modal

boolean modal
True if this dialog is modal, false is the dialog is modeless. A modal dialog blocks user input to some application top-level windows. This field is kept only for backwards compatibility. Use the ModalityType enum instead.

See Also:
Dialog.isModal(), Dialog.setModal(boolean), Dialog.getModalityType(), Dialog.setModalityType(java.awt.Dialog.ModalityType), Dialog.ModalityType, Dialog.ModalityType.MODELESS, Dialog.DEFAULT_MODALITY_TYPE

modalityType

Dialog.ModalityType modalityType
Modality type of this dialog. If the dialog's modality type is not ModalityType.MODELESS, it blocks all user input to some application top-level windows.

Since:
1.6
See Also:
Dialog.ModalityType, Dialog.getModalityType(), Dialog.setModalityType(java.awt.Dialog.ModalityType)

title

String title
Specifies the title of the Dialog. This field can be null.

See Also:
Dialog.getTitle(), Dialog.setTitle(String)

Class java.awt.Dialog.AccessibleAWTDialog extends Window.AccessibleAWTWindow implements Serializable

serialVersionUID: 4837230331833941201L

Class java.awt.Dimension extends Dimension2D implements Serializable

serialVersionUID: 4723952579491349524L

Serialized Fields

width

int width
The width dimension; negative values can be used.

Since:
1.0
See Also:
Dimension.getSize(), Dimension.setSize(double, double)

height

int height
The height dimension; negative values can be used.

Since:
1.0
See Also:
Dimension.getSize(), Dimension.setSize(double, double)

Class java.awt.Event extends Object implements Serializable

serialVersionUID: 5488922509400504703L

Serialized Fields

target

Object target
The target component. This indicates the component over which the event occurred or with which the event is associated. This object has been replaced by AWTEvent.getSource()

See Also:
EventObject.getSource()

when

long when
The time stamp. Replaced by InputEvent.getWhen().

See Also:
InputEvent.getWhen()

id

int id
Indicates which type of event the event is, and which other Event variables are relevant for the event. This has been replaced by AWTEvent.getID()

See Also:
AWTEvent.getID()

x

int x
The x coordinate of the event. Replaced by MouseEvent.getX()

See Also:
MouseEvent.getX()

y

int y
The y coordinate of the event. Replaced by MouseEvent.getY()

See Also:
MouseEvent.getY()

key

int key
The key code of the key that was pressed in a keyboard event. This has been replaced by KeyEvent.getKeyCode()

See Also:
KeyEvent.getKeyCode()

modifiers

int modifiers
The state of the modifier keys. This is replaced with InputEvent.getModifiers() In java 1.1 MouseEvent and KeyEvent are subclasses of InputEvent.

See Also:
InputEvent.getModifiers()

clickCount

int clickCount
For MOUSE_DOWN events, this field indicates the number of consecutive clicks. For other events, its value is 0. This field has been replaced by MouseEvent.getClickCount().

See Also:
MouseEvent.getClickCount().

arg

Object arg
An arbitrary argument of the event. The value of this field depends on the type of event. arg has been replaced by event specific property.

evt

Event evt
The next event. This field is set when putting events into a linked list. This has been replaced by EventQueue.

See Also:
EventQueue

consumed

boolean consumed
This field controls whether or not the event is sent back down to the peer once the target has processed it - false means it's sent to the peer, true means it's not.

See Also:
Event.isConsumed()

Class java.awt.FileDialog extends Dialog implements Serializable

serialVersionUID: 5035145889651310422L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
Reads the ObjectInputStream and performs a backwards compatibility check by converting either a dir or a file equal to an empty string to null.

Throws:
ClassNotFoundException
IOException
Serialized Fields

mode

int mode

dir

String dir

file

String file

filter

FilenameFilter filter

Class java.awt.FlowLayout extends Object implements Serializable

serialVersionUID: -7262534875583282631L

Serialization Methods

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
Reads this object out of a serialization stream, handling objects written by older versions of the class that didn't contain all of the fields we use now..

Throws:
IOException
ClassNotFoundException
Serialized Fields

align

int align
align is the property that determines how each row distributes empty space. It can be one of the following values:
    LEFT RIGHT CENTER

See Also:
FlowLayout.getAlignment(), FlowLayout.setAlignment(int)

newAlign

int newAlign
newAlign is the property that determines how each row distributes empty space for the Java 2 platform, v1.2 and greater. It can be one of the following three values:
    LEFT RIGHT CENTER LEADING TRAILING

Since:
1.2
See Also:
FlowLayout.getAlignment(), FlowLayout.setAlignment(int)

hgap

int hgap
The flow layout manager allows a seperation of components with gaps. The horizontal gap will specify the space between components and between the components and the borders of the Container.

See Also:
FlowLayout.getHgap(), FlowLayout.setHgap(int)

vgap

int vgap
The flow layout manager allows a seperation of components with gaps. The vertical gap will specify the space between rows and between the the rows and the borders of the Container.

See Also:
FlowLayout.getHgap(), FlowLayout.setHgap(int)

alignOnBaseline

boolean alignOnBaseline
If true, components will be aligned on their baseline.

serialVersionOnStream

int serialVersionOnStream
This represent the currentSerialVersion which is bein used. It will be one of two values : 0 versions before Java 2 platform v1.2.. 1 versions after Java 2 platform v1.2..

Since:
1.2

Class java.awt.Font extends Object implements Serializable

serialVersionUID: -4206021311591459213L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
Reads the ObjectInputStream. Unrecognized keys or values will be ignored.

Throws:
ClassNotFoundException
IOException
See Also:
Font.writeObject(java.io.ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws ClassNotFoundException,
                         IOException
Writes default serializable fields to a stream.

Throws:
ClassNotFoundException
IOException
See Also:
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Font.readObject(java.io.ObjectInputStream)
Serialized Fields

fRequestedAttributes

Hashtable<K,V> fRequestedAttributes
This is now only used during serialization. Typically it is null.

See Also:
Font.getAttributes()

name

String name
The logical name of this Font, as passed to the constructor.

Since:
JDK1.0
See Also:
Font.getName()

style

int style
The style of this Font, as passed to the constructor. This style can be PLAIN, BOLD, ITALIC, or BOLD+ITALIC.

Since:
JDK1.0
See Also:
Font.getStyle()

size

int size
The point size of this Font, rounded to integer.

Since:
JDK1.0
See Also:
Font.getSize()

pointSize

float pointSize
The point size of this Font in float.

See Also:
Font.getSize(), Font.getSize2D()

fontSerializedDataVersion

int fontSerializedDataVersion
The Font Serializable Data Form.

Class java.awt.FontFormatException extends Exception implements Serializable

serialVersionUID: -4481290147811361272L

Class java.awt.FontMetrics extends Object implements Serializable

serialVersionUID: 1681126225205050147L

Serialized Fields

font

Font font
The actual Font from which the font metrics are created. This cannot be null.

See Also:
FontMetrics.getFont()

Class java.awt.Frame extends Window implements Serializable

serialVersionUID: 2673458971256075116L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
Reads the ObjectInputStream. Tries to read an icon Image, which is optional data available as of 1.4. If an icon Image is not available, but anything other than an EOF is detected, an OptionalDataException will be thrown. Unrecognized keys or values will be ignored.

Throws:
OptionalDataException - if an icon Image is not available, but anything other than an EOF is detected
HeadlessException - if GraphicsEnvironment.isHeadless returns true
ClassNotFoundException
IOException
See Also:
GraphicsEnvironment.isHeadless(),
Image,
Frame.getIconImage(),
Frame.setIconImage(Image),
Frame.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Writes default serializable fields to stream. Writes an optional serializable icon Image, which is available as of 1.4.

Serial Data:
an optional icon Image
Throws:
IOException
See Also:
Image,
Frame.getIconImage(),
Frame.setIconImage(Image),
Frame.readObject(ObjectInputStream)
Serialized Fields

maximizedBounds

Rectangle maximizedBounds
Maximized bounds for this frame.

Since:
1.4
See Also:
Frame.setMaximizedBounds(Rectangle), Frame.getMaximizedBounds()

title

String title
This is the title of the frame. It can be changed at any time. title can be null and if this is the case the title = "".

See Also:
Frame.getTitle(), Frame.setTitle(String)

menuBar

MenuBar menuBar
The frames menubar. If menuBar = null the frame will not have a menubar.

See Also:
Frame.getMenuBar(), Frame.setMenuBar(MenuBar)

resizable

boolean resizable
This field indicates whether the frame is resizable. This property can be changed at any time. resizable will be true if the frame is resizable, otherwise it will be false.

See Also:
Frame.isResizable()

undecorated

boolean undecorated
This field indicates whether the frame is undecorated. This property can only be changed while the frame is not displayable. undecorated will be true if the frame is undecorated, otherwise it will be false.

Since:
1.4
See Also:
Frame.setUndecorated(boolean),
Frame.isUndecorated(),
Component.isDisplayable()

mbManagement

boolean mbManagement
mbManagement is only used by the Motif implementation.

state

int state

ownedWindows

Vector<E> ownedWindows

frameSerializedDataVersion

int frameSerializedDataVersion
Frame's Serialized Data Version.

Class java.awt.Frame.AccessibleAWTFrame extends Window.AccessibleAWTWindow implements Serializable

serialVersionUID: -6172960752956030250L

Class java.awt.GraphicsConfigTemplate extends Object implements Serializable

serialVersionUID: -8061369279557787079L

Class java.awt.GridBagConstraints extends Object implements Serializable

serialVersionUID: -1000070633030801713L

Serialized Fields

gridx

int gridx
Specifies the cell containing the leading edge of the component's display area, where the first cell in a row has gridx=0. The leading edge of a component's display area is its left edge for a horizontal, left-to-right container and its right edge for a horizontal, right-to-left container. The value RELATIVE specifies that the component be placed immediately following the component that was added to the container just before this component was added.

The default value is RELATIVE. gridx should be a non-negative value.

See Also:
GridBagConstraints.clone(), GridBagConstraints.gridy, ComponentOrientation

gridy

int gridy
Specifies the cell at the top of the component's display area, where the topmost cell has gridy=0. The value RELATIVE specifies that the component be placed just below the component that was added to the container just before this component was added.

The default value is RELATIVE. gridy should be a non-negative value.

See Also:
GridBagConstraints.clone(), GridBagConstraints.gridx

gridwidth

int gridwidth
Specifies the number of cells in a row for the component's display area.

Use REMAINDER to specify that the component's display area will be from gridx to the last cell in the row. Use RELATIVE to specify that the component's display area will be from gridx to the next to the last one in its row.

gridwidth should be non-negative and the default value is 1.

See Also:
GridBagConstraints.clone(), GridBagConstraints.gridheight

gridheight

int gridheight
Specifies the number of cells in a column for the component's display area.

Use REMAINDER to specify that the component's display area will be from gridy to the last cell in the column. Use RELATIVE to specify that the component's display area will be from gridy to the next to the last one in its column.

gridheight should be a non-negative value and the default value is 1.

See Also:
GridBagConstraints.clone(), GridBagConstraints.gridwidth

weightx

double weightx
Specifies how to distribute extra horizontal space.

The grid bag layout manager calculates the weight of a column to be the maximum weightx of all the components in a column. If the resulting layout is smaller horizontally than the area it needs to fill, the extra space is distributed to each column in proportion to its weight. A column that has a weight of zero receives no extra space.

If all the weights are zero, all the extra space appears between the grids of the cell and the left and right edges.

The default value of this field is 0. weightx should be a non-negative value.

See Also:
GridBagConstraints.clone(), GridBagConstraints.weighty

weighty

double weighty
Specifies how to distribute extra vertical space.

The grid bag layout manager calculates the weight of a row to be the maximum weighty of all the components in a row. If the resulting layout is smaller vertically than the area it needs to fill, the extra space is distributed to each row in proportion to its weight. A row that has a weight of zero receives no extra space.

If all the weights are zero, all the extra space appears between the grids of the cell and the top and bottom edges.

The default value of this field is 0. weighty should be a non-negative value.

See Also:
GridBagConstraints.clone(), GridBagConstraints.weightx

anchor

int anchor
This field is used when the component is smaller than its display area. It determines where, within the display area, to place the component.

There are three kinds of possible values: orientation relative, baseline relative and absolute. Orientation relative values are interpreted relative to the container's component orientation property, baseline relative values are interpreted relative to the baseline and absolute values are not. The absolute values are: CENTER, NORTH, NORTHEAST, EAST, SOUTHEAST, SOUTH, SOUTHWEST, WEST, and NORTHWEST. The orientation relative values are: PAGE_START, PAGE_END, LINE_START, LINE_END, FIRST_LINE_START, FIRST_LINE_END, LAST_LINE_START and LAST_LINE_END. The baseline relvative values are: BASELINE, BASELINE_LEADING, BASELINE_TRAILING, ABOVE_BASELINE, ABOVE_BASELINE_LEADING, ABOVE_BASELINE_TRAILING, BELOW_BASELINE, BELOW_BASELINE_LEADING, and BELOW_BASELINE_TRAILING. The default value is CENTER.

See Also:
GridBagConstraints.clone(), ComponentOrientation

fill

int fill
This field is used when the component's display area is larger than the component's requested size. It determines whether to resize the component, and if so, how.

The following values are valid for fill:

  • NONE: Do not resize the component.
  • HORIZONTAL: Make the component wide enough to fill its display area horizontally, but do not change its height.
  • VERTICAL: Make the component tall enough to fill its display area vertically, but do not change its width.
  • BOTH: Make the component fill its display area entirely.

The default value is NONE.

See Also:
GridBagConstraints.clone()

insets

Insets insets
This field specifies the external padding of the component, the minimum amount of space between the component and the edges of its display area.

The default value is new Insets(0, 0, 0, 0).

See Also:
GridBagConstraints.clone()

ipadx

int ipadx
This field specifies the internal padding of the component, how much space to add to the minimum width of the component. The width of the component is at least its minimum width plus ipadx pixels.

The default value is 0.

See Also:
GridBagConstraints.clone(), GridBagConstraints.ipady

ipady

int ipady
This field specifies the internal padding, that is, how much space to add to the minimum height of the component. The height of the component is at least its minimum height plus ipady pixels.

The default value is 0.

See Also:
GridBagConstraints.clone(), GridBagConstraints.ipadx

tempX

int tempX
Temporary place holder for the x coordinate.

tempY

int tempY
Temporary place holder for the y coordinate.

tempWidth

int tempWidth
Temporary place holder for the Width of the component.

tempHeight

int tempHeight
Temporary place holder for the Height of the component.

minWidth

int minWidth
The minimum width of the component. It is used to calculate ipady, where the default will be 0.

See Also:
GridBagConstraints.ipady

minHeight

int minHeight
The minimum height of the component. It is used to calculate ipadx, where the default will be 0.

See Also:
GridBagConstraints.ipadx

Class java.awt.GridBagLayout extends Object implements Serializable

serialVersionUID: 8838754796412211005L

Serialized Fields

comptable

Hashtable<K,V> comptable
This hashtable maintains the association between a component and its gridbag constraints. The Keys in comptable are the components and the values are the instances of GridBagConstraints.

See Also:
GridBagConstraints

defaultConstraints

GridBagConstraints defaultConstraints
This field holds a gridbag constraints instance containing the default values, so if a component does not have gridbag constraints associated with it, then the component will be assigned a copy of the defaultConstraints.

See Also:
GridBagLayout.getConstraints(Component),
GridBagLayout.setConstraints(Component, GridBagConstraints),
GridBagLayout.lookupConstraints(Component)

layoutInfo

GridBagLayoutInfo layoutInfo
This field holds the layout information for the gridbag. The information in this field is based on the most recent validation of the gridbag. If layoutInfo is null this indicates that there are no components in the gridbag or if there are components, they have not yet been validated.

See Also:
GridBagLayout.getLayoutInfo(Container, int)

columnWidths

int[] columnWidths
This field holds the overrides to the column minimum width. If this field is non-null the values are applied to the gridbag after all of the minimum columns widths have been calculated. If columnWidths has more elements than the number of columns, columns are added to the gridbag to match the number of elements in columnWidth.

See Also:
GridBagLayout.getLayoutDimensions()

rowHeights

int[] rowHeights
This field holds the overrides to the row minimum heights. If this field is non-null the values are applied to the gridbag after all of the minimum row heights have been calculated. If rowHeights has more elements than the number of rows, rowa are added to the gridbag to match the number of elements in rowHeights.

See Also:
GridBagLayout.getLayoutDimensions()

columnWeights

double[] columnWeights
This field holds the overrides to the column weights. If this field is non-null the values are applied to the gridbag after all of the columns weights have been calculated. If columnWeights[i] > weight for column i, then column i is assigned the weight in columnWeights[i]. If columnWeights has more elements than the number of columns, the excess elements are ignored - they do not cause more columns to be created.

rowWeights

double[] rowWeights
This field holds the overrides to the row weights. If this field is non-null the values are applied to the gridbag after all of the rows weights have been calculated. If rowWeights[i] > weight for row i, then row i is assigned the weight in rowWeights[i]. If rowWeights has more elements than the number of rows, the excess elements are ignored - they do not cause more rows to be created.

componentAdjusting

Component componentAdjusting
The component being positioned. This is set before calling into adjustForGravity.

Class java.awt.GridBagLayoutInfo extends Object implements Serializable

serialVersionUID: -4899416460737170217L

Serialized Fields

width

int width

height

int height

startx

int startx

starty

int starty

minWidth

int[] minWidth

minHeight

int[] minHeight

weightX

double[] weightX

weightY

double[] weightY

hasBaseline

boolean hasBaseline

baselineType

short[] baselineType

maxAscent

int[] maxAscent

maxDescent

int[] maxDescent

Class java.awt.GridLayout extends Object implements Serializable

serialVersionUID: -7411804673224730901L

Serialized Fields

hgap

int hgap
This is the horizontal gap (in pixels) which specifies the space between columns. They can be changed at any time. This should be a non-negative integer.

See Also:
GridLayout.getHgap(), GridLayout.setHgap(int)

vgap

int vgap
This is the vertical gap (in pixels) which specifies the space between rows. They can be changed at any time. This should be a non negative integer.

See Also:
GridLayout.getVgap(), GridLayout.setVgap(int)

rows

int rows
This is the number of rows specified for the grid. The number of rows can be changed at any time. This should be a non negative integer, where '0' means 'any number' meaning that the number of Rows in that dimension depends on the other dimension.

See Also:
GridLayout.getRows(), GridLayout.setRows(int)

cols

int cols
This is the number of columns specified for the grid. The number of columns can be changed at any time. This should be a non negative integer, where '0' means 'any number' meaning that the number of Columns in that dimension depends on the other dimension.

See Also:
GridLayout.getColumns(), GridLayout.setColumns(int)

Class java.awt.HeadlessException extends UnsupportedOperationException implements Serializable

serialVersionUID: 167183644944358563L

Class java.awt.IllegalComponentStateException extends IllegalStateException implements Serializable

serialVersionUID: -1889339587208144238L

Class java.awt.Insets extends Object implements Serializable

serialVersionUID: -2272572637695466749L

Serialized Fields

top

int top
The inset from the top. This value is added to the Top of the rectangle to yield a new location for the Top.

See Also:
Insets.clone()

left

int left
The inset from the left. This value is added to the Left of the rectangle to yield a new location for the Left edge.

See Also:
Insets.clone()

bottom

int bottom
The inset from the bottom. This value is subtracted from the Bottom of the rectangle to yield a new location for the Bottom.

See Also:
Insets.clone()

right

int right
The inset from the right. This value is subtracted from the Right of the rectangle to yield a new location for the Right edge.

See Also:
Insets.clone()

Class java.awt.Label extends Component implements Serializable

serialVersionUID: 3094126758329070636L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
Read a label from an object input stream.

Throws:
HeadlessException - if GraphicsEnvironment.isHeadless() returns true
ClassNotFoundException
IOException
Since:
1.4
See Also:
GraphicsEnvironment.isHeadless()
Serialized Fields

text

String text
The text of this label. This text can be modified by the program but never by the user.

See Also:
Label.getText(), Label.setText(String)

alignment

int alignment
The label's alignment. The default alignment is set to be left justified.

See Also:
Label.getAlignment(), Label.setAlignment(int)

Class java.awt.Label.AccessibleAWTLabel extends Component.AccessibleAWTComponent implements Serializable

serialVersionUID: -3568967560160480438L

Class java.awt.List extends Component implements Serializable

serialVersionUID: -3304312411574666869L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
Reads the ObjectInputStream and if it isn't null adds a listener to receive both item events and action events (as specified by the key stored in the stream) fired by the List. Unrecognized keys or values will be ignored.

Throws:
HeadlessException - if GraphicsEnvironment.isHeadless returns true
ClassNotFoundException
IOException
See Also:
List.removeItemListener(ItemListener),
List.addItemListener(ItemListener),
GraphicsEnvironment.isHeadless(),
List.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Writes default serializable fields to stream. Writes a list of serializable ItemListeners and ActionListeners as optional data. The non-serializable listeners are detected and no attempt is made to serialize them.

Serial Data:
null terminated sequence of 0 or more pairs; the pair consists of a String and an Object; the String indicates the type of object and is one of the following: itemListenerK indicating an ItemListener object; actionListenerK indicating an ActionListener object
Throws:
IOException
See Also:
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.itemListenerK, Component.actionListenerK, List.readObject(ObjectInputStream)
Serialized Fields

items

Vector<E> items
A vector created to contain items which will become part of the List Component.

See Also:
List.addItem(String), List.getItem(int)

rows

int rows
This field will represent the number of visible rows in the List Component. It is specified only once, and that is when the list component is actually created. It will never change.

See Also:
List.getRows()

multipleMode

boolean multipleMode
multipleMode is a variable that will be set to true if a list component is to be set to multiple selection mode, that is where the user can select more than one item in a list at one time. multipleMode will be set to false if the list component is set to single selection, that is where the user can only select one item on the list at any one time.

See Also:
List.isMultipleMode(), List.setMultipleMode(boolean)

selected

int[] selected
selected is an array that will contain the indices of items that have been selected.

See Also:
List.getSelectedIndexes(), List.getSelectedIndex()

visibleIndex

int visibleIndex
This variable contains the value that will be used when trying to make a particular list item visible.

See Also:
List.makeVisible(int)

listSerializedDataVersion

int listSerializedDataVersion
The List component's Serialized Data Version.

Class java.awt.List.AccessibleAWTList extends Component.AccessibleAWTComponent implements Serializable

serialVersionUID: 7924617370136012829L

Class java.awt.List.AccessibleAWTList.AccessibleAWTListChild extends Component.AccessibleAWTComponent implements Serializable

serialVersionUID: 4412022926028300317L

Serialized Fields

parent

List parent

indexInParent

int indexInParent

Class java.awt.MediaTracker extends Object implements Serializable

serialVersionUID: -483174189758638095L

Serialized Fields

target

Component target
A given Component that will be tracked by a media tracker where the image will eventually be drawn.

See Also:
MediaTracker.MediaTracker(Component)

head

java.awt.MediaEntry head
The head of the list of Images that is being tracked by the MediaTracker.

See Also:
MediaTracker.addImage(Image, int), MediaTracker.removeImage(Image)

Class java.awt.Menu extends MenuItem implements Serializable

serialVersionUID: -8809584163345499784L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException,
                        HeadlessException
Reads the ObjectInputStream. Unrecognized keys or values will be ignored.

Throws:
HeadlessException - if GraphicsEnvironment.isHeadless returns true
IOException
ClassNotFoundException
See Also:
GraphicsEnvironment.isHeadless(), Menu.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Writes default serializable fields to stream.

Throws:
IOException
See Also:
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Menu.readObject(ObjectInputStream)
Serialized Fields

items

Vector<E> items
A vector of the items that will be part of the Menu.

See Also:
Menu.countItems()

tearOff

boolean tearOff
This field indicates whether the menu has the tear of property or not. It will be set to true if the menu has the tear off property and it will be set to false if it does not. A torn off menu can be deleted by a user when it is no longer needed.

See Also:
Menu.isTearOff()

isHelpMenu

boolean isHelpMenu
This field will be set to true if the Menu in question is actually a help menu. Otherwise it will be set to false.

menuSerializedDataVersion

int menuSerializedDataVersion
The menu serialized Data Version.

Class java.awt.Menu.AccessibleAWTMenu extends MenuItem.AccessibleAWTMenuItem implements Serializable

serialVersionUID: 5228160894980069094L

Class java.awt.MenuBar extends MenuComponent implements Serializable

serialVersionUID: -4930327919388951260L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
Reads the ObjectInputStream. Unrecognized keys or values will be ignored.

Throws:
HeadlessException - if GraphicsEnvironment.isHeadless returns true
ClassNotFoundException
IOException
See Also:
GraphicsEnvironment.isHeadless(), MenuBar.writeObject(java.io.ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws ClassNotFoundException,
                         IOException
Writes default serializable fields to stream.

Throws:
ClassNotFoundException
IOException
See Also:
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), MenuBar.readObject(java.io.ObjectInputStream)
Serialized Fields

menus

Vector<E> menus
This field represents a vector of the actual menus that will be part of the MenuBar.

See Also:
MenuBar.countMenus()

helpMenu

Menu helpMenu
This menu is a special menu dedicated to help. The one thing to note about this menu is that on some platforms it appears at the right edge of the menubar.

See Also:
MenuBar.getHelpMenu(), MenuBar.setHelpMenu(Menu)

menuBarSerializedDataVersion

int menuBarSerializedDataVersion
The MenuBar's serialized data version.

Class java.awt.MenuBar.AccessibleAWTMenuBar extends MenuComponent.AccessibleAWTMenuComponent implements Serializable

serialVersionUID: -8577604491830083815L

Class java.awt.MenuComponent extends Object implements Serializable

serialVersionUID: -4536902356223894379L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
Reads the menu component from an object input stream.

Throws:
HeadlessException - if GraphicsEnvironment.isHeadless returns true
ClassNotFoundException
IOException
See Also:
GraphicsEnvironment.isHeadless()
Serialized Fields

font

Font font
The menu component's font. This value can be null at which point a default will be used. This defaults to null.

See Also:
MenuComponent.setFont(Font), MenuComponent.getFont()

name

String name
The menu component's name, which defaults to null.

See Also:
MenuComponent.getName(), MenuComponent.setName(String)

nameExplicitlySet

boolean nameExplicitlySet
A variable to indicate whether a name is explicitly set. If true the name will be set explicitly. This defaults to false.

See Also:
MenuComponent.setName(String)

newEventsOnly

boolean newEventsOnly
Defaults to false.

See Also:
MenuComponent.dispatchEvent(AWTEvent)

accessibleContext

AccessibleContext accessibleContext

Class java.awt.MenuComponent.AccessibleAWTMenuComponent extends AccessibleContext implements Serializable

serialVersionUID: -4269533416223798698L

Class java.awt.MenuItem extends MenuComponent implements Serializable

serialVersionUID: -21757335363267194L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
Reads the ObjectInputStream and if it isn't null adds a listener to receive action events fired by the Menu Item. Unrecognized keys or values will be ignored.

Throws:
HeadlessException - if GraphicsEnvironment.isHeadless returns true
ClassNotFoundException
IOException
See Also:
MenuItem.removeActionListener(ActionListener),
MenuItem.addActionListener(ActionListener),
MenuItem.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Writes default serializable fields to stream. Writes a list of serializable ActionListeners as optional data. The non-serializable listeners are detected and no attempt is made to serialize them.

Serial Data:
null terminated sequence of 0 or more pairs; the pair consists of a String and an Object; the String indicates the type of object and is one of the following: actionListenerK indicating an ActionListener object
Throws:
IOException
See Also:
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), MenuItem.readObject(ObjectInputStream)
Serialized Fields

enabled

boolean enabled
A value to indicate whether a menu item is enabled or not. If it is enabled, enabled will be set to true. Else enabled will be set to false.

See Also:
MenuItem.isEnabled(), MenuItem.setEnabled(boolean)

label

String label
label is the label of a menu item. It can be any string.

See Also:
MenuItem.getLabel(), MenuItem.setLabel(String)

actionCommand

String actionCommand
This field indicates the command tha has been issued by a particular menu item. By default the actionCommand is the label of the menu item, unless it has been set using setActionCommand.

See Also:
MenuItem.setActionCommand(String), MenuItem.getActionCommand()

eventMask

long eventMask
The eventMask is ONLY set by subclasses via enableEvents. The mask should NOT be set when listeners are registered so that we can distinguish the difference between when listeners request events and subclasses request them.

shortcut

MenuShortcut shortcut
A sequence of key stokes that ia associated with a menu item. Note :in 1.1.2 you must use setActionCommand() on a menu item in order for its shortcut to work.

See Also:
MenuItem.getShortcut(),
MenuItem.setShortcut(MenuShortcut),
MenuItem.deleteShortcut()

menuItemSerializedDataVersion

int menuItemSerializedDataVersion
Menu item serialized data version.

Class java.awt.MenuItem.AccessibleAWTMenuItem extends MenuComponent.AccessibleAWTMenuComponent implements Serializable

serialVersionUID: -217847831945965825L

Class java.awt.MenuShortcut extends Object implements Serializable

serialVersionUID: 143448358473180225L

Serialized Fields

key

int key
The virtual keycode for the menu shortcut. This is the keycode with which the menu shortcut will be created. Note that it is a virtual keycode, not a character, e.g. KeyEvent.VK_A, not 'a'. Note: in 1.1.x you must use setActionCommand() on a menu item in order for its shortcut to work, otherwise it will fire a null action command.

Since:
JDK1.1
See Also:
MenuShortcut.getKey(), MenuShortcut.usesShiftModifier(), KeyEvent

usesShift

boolean usesShift
Indicates whether the shft key was pressed. If true, the shift key was pressed. If false, the shift key was not pressed

Since:
JDK1.1
See Also:
MenuShortcut.usesShiftModifier()

Class java.awt.Panel extends Container implements Serializable

serialVersionUID: -2728009084054400034L

Class java.awt.Panel.AccessibleAWTPanel extends Container.AccessibleAWTContainer implements Serializable

serialVersionUID: -6409552226660031050L

Class java.awt.Point extends Point2D implements Serializable

serialVersionUID: -5276940640259749850L

Serialized Fields

x

int x
The X coordinate of this Point. If no X coordinate is set it will default to 0.

Since:
1.0
See Also:
Point.getLocation(), Point.move(int, int)

y

int y
The Y coordinate of this Point. If no Y coordinate is set it will default to 0.

Since:
1.0
See Also:
Point.getLocation(), Point.move(int, int)

Class java.awt.Polygon extends Object implements Serializable

serialVersionUID: -6460061437900069969L

Serialized Fields

npoints

int npoints
The total number of points. The value of npoints represents the number of valid points in this Polygon and might be less than the number of elements in xpoints or ypoints. This value can be NULL.

Since:
1.0
See Also:
Polygon.addPoint(int, int)

xpoints

int[] xpoints
The array of X coordinates. The number of elements in this array might be more than the number of X coordinates in this Polygon. The extra elements allow new points to be added to this Polygon without re-creating this array. The value of npoints is equal to the number of valid points in this Polygon.

Since:
1.0
See Also:
Polygon.addPoint(int, int)

ypoints

int[] ypoints
The array of Y coordinates. The number of elements in this array might be more than the number of Y coordinates in this Polygon. The extra elements allow new points to be added to this Polygon without re-creating this array. The value of npoints is equal to the number of valid points in this Polygon.

Since:
1.0
See Also:
Polygon.addPoint(int, int)

bounds

Rectangle bounds
The bounds of this Polygon. This value can be null.

Since:
1.0
See Also:
Polygon.getBoundingBox(), Polygon.getBounds()

Class java.awt.PopupMenu extends Menu implements Serializable

serialVersionUID: -4620452533522760060L

Class java.awt.PopupMenu.AccessibleAWTPopupMenu extends Menu.AccessibleAWTMenu implements Serializable

serialVersionUID: -4282044795947239955L

Class java.awt.Rectangle extends Rectangle2D implements Serializable

serialVersionUID: -4345857070255674764L

Serialized Fields

x

int x
The X coordinate of the upper-left corner of the Rectangle.

Since:
1.0
See Also:
Rectangle.setLocation(int, int), Rectangle.getLocation()

y

int y
The Y coordinate of the upper-left corner of the Rectangle.

Since:
1.0
See Also:
Rectangle.setLocation(int, int), Rectangle.getLocation()

width

int width
The width of the Rectangle.

Since:
1.0
See Also:
Rectangle.setSize(int, int), Rectangle.getSize()

height

int height
The height of the Rectangle.

Since:
1.0
See Also:
Rectangle.setSize(int, int), Rectangle.getSize()

Class java.awt.Scrollbar extends Component implements Serializable

serialVersionUID: 8451667562882310543L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
Reads the ObjectInputStream and if it isn't null adds a listener to receive adjustment events fired by the Scrollbar. Unrecognized keys or values will be ignored.

Throws:
HeadlessException - if GraphicsEnvironment.isHeadless returns true
ClassNotFoundException
IOException
See Also:
GraphicsEnvironment.isHeadless(), Scrollbar.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Writes default serializable fields to stream. Writes a list of serializable AdjustmentListeners as optional data. The non-serializable listeners are detected and no attempt is made to serialize them.

Serial Data:
null terminated sequence of 0 or more pairs; the pair consists of a String and an Object; the String indicates the type of object and is one of the following: adjustmentListenerK indicating an AdjustmentListener object
Throws:
IOException
See Also:
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.adjustmentListenerK, Scrollbar.readObject(ObjectInputStream)
Serialized Fields

value

int value
The value of the Scrollbar. This property must be greater than or equal to minimum and less than or equal to maximum - visibleAmount

See Also:
Scrollbar.getValue(), Scrollbar.setValue(int)

maximum

int maximum
The maximum value of the Scrollbar. This value must be greater than the minimum value.

See Also:
Scrollbar.getMaximum(), Scrollbar.setMaximum(int)

minimum

int minimum
The minimum value of the Scrollbar. This value must be less than the maximum value.

See Also:
Scrollbar.getMinimum(), Scrollbar.setMinimum(int)

visibleAmount

int visibleAmount
The size of the Scrollbar's bubble. When a scroll bar is used to select a range of values, the visibleAmount represents the size of this range. This is visually indicated by the size of the bubble.

See Also:
Scrollbar.getVisibleAmount(), Scrollbar.setVisibleAmount(int)

orientation

int orientation
The Scrollbar's orientation--being either horizontal or vertical. This value should be specified when the scrollbar is created.
orientation can be either : VERTICAL or HORIZONTAL only.

See Also:
Scrollbar.getOrientation(), Scrollbar.setOrientation(int)

lineIncrement

int lineIncrement
The amount by which the scrollbar value will change when going up or down by a line. This value must be greater than zero.

See Also:
Scrollbar.getLineIncrement(), Scrollbar.setLineIncrement(int)

pageIncrement

int pageIncrement
The amount by which the scrollbar value will change when going up or down by a page. This value must be greater than zero.

See Also:
Scrollbar.getPageIncrement(), Scrollbar.setPageIncrement(int)

scrollbarSerializedDataVersion

int scrollbarSerializedDataVersion
The scroll bar's serialized Data Version.

Class java.awt.Scrollbar.AccessibleAWTScrollBar extends Component.AccessibleAWTComponent implements Serializable

serialVersionUID: -344337268523697807L

Class java.awt.ScrollPane extends Container implements Serializable

serialVersionUID: 7956609840827222915L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
Reads default serializable fields to stream.

Throws:
HeadlessException - if GraphicsEnvironment.isHeadless() returns true
ClassNotFoundException
IOException
See Also:
GraphicsEnvironment.isHeadless()

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Writes default serializable fields to stream.

Throws:
IOException
Serialized Fields

scrollbarDisplayPolicy

int scrollbarDisplayPolicy
There are 3 ways in which a scroll bar can be displayed. This integer will represent one of these 3 displays - (SCROLLBARS_ALWAYS, SCROLLBARS_AS_NEEDED, SCROLLBARS_NEVER)

See Also:
ScrollPane.getScrollbarDisplayPolicy()

vAdjustable

ScrollPaneAdjustable vAdjustable
An adjustable vertical scrollbar. It is important to note that you must NOT call 3 Adjustable methods, namely: setMinimum(), setMaximum(), setVisibleAmount().

See Also:
ScrollPane.getVAdjustable()

hAdjustable

ScrollPaneAdjustable hAdjustable
An adjustable horizontal scrollbar. It is important to note that you must NOT call 3 Adjustable methods, namely: setMinimum(), setMaximum(), setVisibleAmount().

See Also:
ScrollPane.getHAdjustable()

wheelScrollingEnabled

boolean wheelScrollingEnabled
Indicates whether or not scrolling should take place when a MouseWheelEvent is received.

Since:
1.4

Class java.awt.ScrollPane.AccessibleAWTScrollPane extends Container.AccessibleAWTContainer implements Serializable

serialVersionUID: 6100703663886637L

Class java.awt.ScrollPaneAdjustable extends Object implements Serializable

serialVersionUID: -3359745691033257079L

Serialized Fields

sp

ScrollPane sp
The ScrollPane this object is a scrollbar of.

orientation

int orientation
Orientation of this scrollbar.

See Also:
ScrollPaneAdjustable.getOrientation(), Adjustable.HORIZONTAL, Adjustable.VERTICAL

value

int value
The value of this scrollbar. value should be greater than minimum and less than maximum

See Also:
ScrollPaneAdjustable.getValue(), ScrollPaneAdjustable.setValue(int)

minimum

int minimum
The minimum value of this scrollbar. This value can only be set by the ScrollPane.

ATTN: In current implementation minimum is always 0. This field can only be altered via setSpan method and ScrollPane always calls that method with 0 for the minimum. getMinimum method always returns 0 without checking this field.

See Also:
ScrollPaneAdjustable.getMinimum(), ScrollPaneAdjustable.setSpan(int, int, int)

maximum

int maximum
The maximum value of this scrollbar. This value can only be set by the ScrollPane.

See Also:
ScrollPaneAdjustable.getMaximum(), ScrollPaneAdjustable.setSpan(int, int, int)

visibleAmount

int visibleAmount
The size of the visible portion of this scrollbar. This value can only be set by the ScrollPane.

See Also:
ScrollPaneAdjustable.getVisibleAmount(), ScrollPaneAdjustable.setSpan(int, int, int)

unitIncrement

int unitIncrement
The amount by which the scrollbar value will change when going up or down by a line. This value should be a non negative integer.

See Also:
ScrollPaneAdjustable.getUnitIncrement(), ScrollPaneAdjustable.setUnitIncrement(int)

blockIncrement

int blockIncrement
The amount by which the scrollbar value will change when going up or down by a page. This value should be a non negative integer.

See Also:
ScrollPaneAdjustable.getBlockIncrement(), ScrollPaneAdjustable.setBlockIncrement(int)

adjustmentListener

AdjustmentListener adjustmentListener

Class java.awt.SystemColor extends Color implements Serializable

serialVersionUID: 4503142729533789064L

Serialization Methods

readResolve

private Object readResolve()
The design of the SystemColor class assumes that the SystemColor object instances stored in the static final fields above are the only instances that can be used by developers. This method helps maintain those limits on instantiation by using the index stored in the value field of the serialized form of the object to replace the serialized object with the equivalent static object constant field of SystemColor. See the SystemColor.writeReplace() method for more information on the serialized form of these objects.

writeReplace

private Object writeReplace()
                     throws ObjectStreamException
Returns a specialized version of the SystemColor object for writing to the serialized stream.

Serial Data:
The value field of a serialized SystemColor object contains the array index of the system color instead of the rgb data for the system color. This index is used by the SystemColor.readResolve() method to resolve the deserialized objects back to the original static constant versions to ensure unique instances of each SystemColor object.
Throws:
ObjectStreamException

Class java.awt.TextArea extends TextComponent implements Serializable

serialVersionUID: 3692302836626095722L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
Read the ObjectInputStream.

Throws:
HeadlessException - if GraphicsEnvironment.isHeadless() returns true
ClassNotFoundException
IOException
See Also:
GraphicsEnvironment.isHeadless()
Serialized Fields

rows

int rows
The number of rows in the TextArea. This parameter will determine the text area's height. Guaranteed to be non-negative.

See Also:
TextArea.getRows(), TextArea.setRows(int)

columns

int columns
The number of columns in the TextArea. A column is an approximate average character width that is platform-dependent. This parameter will determine the text area's width. Guaranteed to be non-negative.

See Also:
TextArea.setColumns(int), TextArea.getColumns()

scrollbarVisibility

int scrollbarVisibility
Determines which scrollbars are created for the text area. It can be one of four values : SCROLLBARS_BOTH = both scrollbars.
SCROLLBARS_HORIZONTAL_ONLY = Horizontal bar only.
SCROLLBARS_VERTICAL_ONLY = Vertical bar only.
SCROLLBARS_NONE = No scrollbars.

See Also:
TextArea.getScrollbarVisibility()

textAreaSerializedDataVersion

int textAreaSerializedDataVersion
The textArea Serialized Data Version.

Class java.awt.TextArea.AccessibleAWTTextArea extends TextComponent.AccessibleAWTTextComponent implements Serializable

serialVersionUID: 3472827823632144419L

Class java.awt.TextComponent extends Component implements Serializable

serialVersionUID: -2214773872412987419L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
Read the ObjectInputStream, and if it isn't null, add a listener to receive text events fired by the TextComponent. Unrecognized keys or values will be ignored.

Throws:
HeadlessException - if GraphicsEnvironment.isHeadless() returns true
ClassNotFoundException
IOException
See Also:
TextComponent.removeTextListener(java.awt.event.TextListener),
TextComponent.addTextListener(java.awt.event.TextListener),
GraphicsEnvironment.isHeadless()

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Writes default serializable fields to stream. Writes a list of serializable TextListener(s) as optional data. The non-serializable TextListener(s) are detected and no attempt is made to serialize them.

Serial Data:
Null terminated sequence of zero or more pairs. A pair consists of a String and Object. The String indicates the type of object and is one of the following : textListenerK indicating and TextListener object.
Throws:
IOException
See Also:
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.textListenerK
Serialized Fields

text

String text
The value of the text. A null value is the same as "".

See Also:
TextComponent.setText(String), TextComponent.getText()

editable

boolean editable
A boolean indicating whether or not this TextComponent is editable. It will be true if the text component is editable and false if not.

See Also:
TextComponent.isEditable()

selectionStart

int selectionStart
The selection refers to the selected text, and the selectionStart is the start position of the selected text.

See Also:
TextComponent.getSelectionStart(), TextComponent.setSelectionStart(int)

selectionEnd

int selectionEnd
The selection refers to the selected text, and the selectionEnd is the end position of the selected text.

See Also:
TextComponent.getSelectionEnd(), TextComponent.setSelectionEnd(int)

backgroundSetByClientCode

boolean backgroundSetByClientCode

textComponentSerializedDataVersion

int textComponentSerializedDataVersion
The textComponent SerializedDataVersion.

checkForEnableIM

boolean checkForEnableIM

Class java.awt.TextComponent.AccessibleAWTTextComponent extends Component.AccessibleAWTComponent implements Serializable

serialVersionUID: 3631432373506317811L

Class java.awt.TextField extends TextComponent implements Serializable

serialVersionUID: -2966288784432217853L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
Read the ObjectInputStream and if it isn't null, add a listener to receive action events fired by the TextField. Unrecognized keys or values will be ignored.

Throws:
HeadlessException - if GraphicsEnvironment.isHeadless() returns true
ClassNotFoundException
IOException
See Also:
TextField.removeActionListener(ActionListener),
TextField.addActionListener(ActionListener),
GraphicsEnvironment.isHeadless()

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Writes default serializable fields to stream. Writes a list of serializable ActionListener(s) as optional data. The non-serializable ActionListener(s) are detected and no attempt is made to serialize them.

Serial Data:
Null terminated sequence of zero or more pairs. A pair consists of a String and Object. The String indicates the type of object and is one of the following : ActionListenerK indicating and ActionListener object.
Throws:
IOException
See Also:
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.actionListenerK
Serialized Fields

columns

int columns
The number of columns in the text field. A column is an approximate average character width that is platform-dependent. Guaranteed to be non-negative.

See Also:
TextField.setColumns(int), TextField.getColumns()

echoChar

char echoChar
The echo character, which is used when the user wishes to disguise the characters typed into the text field. The disguises are removed if echoChar = 0.

See Also:
TextField.getEchoChar(),
TextField.setEchoChar(char),
TextField.echoCharIsSet()

textFieldSerializedDataVersion

int textFieldSerializedDataVersion
The textField Serialized Data Version.

Class java.awt.TextField.AccessibleAWTTextField extends TextComponent.AccessibleAWTTextComponent implements Serializable

serialVersionUID: 6219164359235943158L

Class java.awt.Window extends Container implements Serializable

serialVersionUID: 4497834738069338734L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
Reads the ObjectInputStream and an optional list of listeners to receive various events fired by the component; also reads a list of (possibly null) child windows. Unrecognized keys or values will be ignored.

Throws:
HeadlessException - if GraphicsEnvironment.isHeadless returns true
ClassNotFoundException
IOException
See Also:
GraphicsEnvironment.isHeadless(), Window.writeObject(java.io.ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Writes default serializable fields to stream. Writes a list of serializable WindowListeners and WindowFocusListeners as optional data. Writes a list of child windows as optional data. Writes a list of icon images as optional data

Serial Data:
null terminated sequence of 0 or more pairs; the pair consists of a String and and Object; the String indicates the type of object and is one of the following: windowListenerK indicating a WindowListener object; windowFocusWindowK indicating a WindowFocusListener object; ownedWindowK indicating a child Window object
Throws:
IOException
See Also:
AWTEventMulticaster.save(java.io.ObjectOutputStream, java.lang.String, java.util.EventListener), Component.windowListenerK, Component.windowFocusListenerK, Component.ownedWindowK, Window.readObject(ObjectInputStream)
Serialized Fields

warningString

String warningString
This represents the warning message that is to be displayed in a non secure window. ie : a window that has a security manager installed for which calling SecurityManager.checkTopLevelWindow() is false. This message can be displayed anywhere in the window.

See Also:
Window.getWarningString()

syncLWRequests

boolean syncLWRequests

state

int state
An Integer value representing the Window State.

Since:
1.2
See Also:
Window.show()

alwaysOnTop

boolean alwaysOnTop
A boolean value representing Window always-on-top state

Since:
1.5
See Also:
Window.setAlwaysOnTop(boolean), Window.isAlwaysOnTop()

modalExclusionType

Dialog.ModalExclusionType modalExclusionType
Since:
1.6
See Also:
Dialog.ModalExclusionType, Window.getModalExclusionType(), Window.setModalExclusionType(java.awt.Dialog.ModalExclusionType)

focusMgr

java.awt.FocusManager focusMgr
Unused. Maintained for serialization backward-compatibility.

Since:
1.2

focusableWindowState

boolean focusableWindowState
Indicates whether this Window can become the focused Window.

Since:
1.4
See Also:
Window.getFocusableWindowState(), Window.setFocusableWindowState(boolean)

autoRequestFocus

boolean autoRequestFocus
Indicates whether this window should receive focus on subsequently being shown (with a call to setVisible(true)), or being moved to the front (with a call to toFront()).

Since:
1.7
See Also:
Window.setAutoRequestFocus(boolean), Window.isAutoRequestFocus()

opacity

float opacity

shape

Shape shape

windowSerializedDataVersion

int windowSerializedDataVersion
The window serialized data version.

locationByPlatform

boolean locationByPlatform

Class java.awt.Window.AccessibleAWTWindow extends Container.AccessibleAWTContainer implements Serializable

serialVersionUID: 4215068635060671780L

Package java.awt.color

Class java.awt.color.CMMException extends RuntimeException implements Serializable

Class java.awt.color.ColorSpace extends Object implements Serializable

serialVersionUID: -409452704308689724L

Serialized Fields

type

int type

numComponents

int numComponents

Class java.awt.color.ICC_ColorSpace extends ColorSpace implements Serializable

serialVersionUID: 3455889114070431483L

Serialized Fields

thisProfile

ICC_Profile thisProfile

minVal

float[] minVal

maxVal

float[] maxVal

diffMinMax

float[] diffMinMax

invDiffMinMax

float[] invDiffMinMax

needScaleInit

boolean needScaleInit

Class java.awt.color.ICC_Profile extends Object implements Serializable

serialVersionUID: -3938515861990936766L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reads default serializable fields from the stream. Reads from the stream a string and an array of bytes as additional data.

Serial Data:
The String is the name of one of CS_* constants defined in the ColorSpace class if the profile object is a profile for a predefined color space (for example "CS_sRGB"). The string is null otherwise.

The byte[] array is the profile data for the profile. It will usually be null for the predefined profiles.

If the string is recognized as a constant name for predefined color space the object will be resolved into profile obtained with getInstance(int cspace) and the profile data are ignored. Otherwise the object will be resolved into profile obtained with getInstance(byte[] data).

Throws:
IOException - thrown by ObjectInputStream.
ClassNotFoundException - thrown by ObjectInputStream.
See Also:
ICC_Profile.readResolve(),
ICC_Profile.getInstance(int),
ICC_Profile.getInstance(byte[])

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Writes default serializable fields to the stream. Writes a string and an array of bytes to the stream as additional data.

Serial Data:
The String is the name of one of CS_* constants defined in the ColorSpace class if the profile object is a profile for a predefined color space (for example "CS_sRGB"). The string is null otherwise.

The byte[] array is the profile data for the profile. For predefined color spaces null is written instead of the profile data. If in the future versions of Java API new predefined color spaces will be added, future versions of this class may choose to write for new predefined color spaces not only the color space name, but the profile data as well so that older versions could still deserialize the object.

Throws:
IOException - thrown by ObjectInputStream.

readResolve

protected Object readResolve()
                      throws ObjectStreamException
Resolves instances being deserialized into instances registered with CMM.

Throws:
ObjectStreamException - never thrown, but mandated by the serialization spec.
Since:
1.3
Serialized Fields

iccProfileSerializedDataVersion

int iccProfileSerializedDataVersion
Version of the format of additional serialized data in the stream. Version 1 corresponds to Java 2 Platform, v1.3.

Since:
1.3

Class java.awt.color.ICC_ProfileGray extends ICC_Profile implements Serializable

serialVersionUID: -1124721290732002649L

Class java.awt.color.ICC_ProfileRGB extends ICC_Profile implements Serializable

serialVersionUID: 8505067385152579334L

Class java.awt.color.ProfileDataException extends RuntimeException implements Serializable

Package java.awt.datatransfer

Class java.awt.datatransfer.DataFlavor extends Object implements Serializable

serialVersionUID: 8367026044764648243L

Serialization Methods

readExternal

public void readExternal(ObjectInput is)
                  throws IOException,
                         ClassNotFoundException
Restores this DataFlavor from a Serialized state.

Throws:
IOException - if I/O errors occur
ClassNotFoundException - If the class for an object being restored cannot be found.

writeExternal

public void writeExternal(ObjectOutput os)
                   throws IOException
Serializes this DataFlavor.

Throws:
IOException - Includes any I/O exceptions that may occur

Class java.awt.datatransfer.FlavorEvent extends EventObject implements Serializable

Class java.awt.datatransfer.UnsupportedFlavorException extends Exception implements Serializable

serialVersionUID: 5383814944251665601L

Package java.awt.dnd

Class java.awt.dnd.DragGestureEvent extends EventObject implements Serializable

serialVersionUID: 9080172649166731306L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
Deserializes this DragGestureEvent. This method first performs default deserialization for all non-transient fields. An attempt is then made to deserialize this object's List of gesture events as well. This is first attempted by deserializing the field events, because, in releases prior to 1.4, a non-transient field of this name stored the List of gesture events. If this fails, the next object in the stream is used instead. If the resulting List is null, this object's List of gesture events is set to an empty List.

Throws:
ClassNotFoundException
IOException
Since:
1.4

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Serializes this DragGestureEvent. Performs default serialization and then writes out this object's List of gesture events if and only if the List can be serialized. If not, null is written instead. In this case, a DragGestureEvent created from the resulting deserialized stream will contain an empty List of gesture events.

Serial Data:
The default serializable fields, in alphabetical order, followed by either a List instance, or null.
Throws:
IOException
Since:
1.4
Serialized Fields

dragSource

DragSource dragSource
The DragSource associated with this DragGestureEvent.

component

Component component
The Component associated with this DragGestureEvent.

origin

Point origin
The origin of the drag.

action

int action
The user's preferred action.

Class java.awt.dnd.DragGestureRecognizer extends Object implements Serializable

serialVersionUID: 8996673345831063337L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
Deserializes this DragGestureRecognizer. This method first performs default deserialization for all non-transient fields. This object's DragGestureListener is then deserialized as well by using the next object in the stream.

Throws:
ClassNotFoundException
IOException
Since:
1.4

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Serializes this DragGestureRecognizer. This method first performs default serialization. Then, this object's DragGestureListener is written out if and only if it can be serialized. If not, null is written instead.

Serial Data:
The default serializable fields, in alphabetical order, followed by either a DragGestureListener, or null.
Throws:
IOException
Since:
1.4
Serialized Fields

dragSource

DragSource dragSource
The DragSource associated with this DragGestureRecognizer.

component

Component component
The Component associated with this DragGestureRecognizer.

sourceActions

int sourceActions
An int representing the type(s) of action(s) used in this Drag and Drop operation.

events

ArrayList<E> events
The list of events (in order) that the DragGestureRecognizer "recognized" as a "gesture" that triggers a drag.

Class java.awt.dnd.DragSource extends Object implements Serializable

serialVersionUID: 6236096958971414066L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
Deserializes this DragSource. This method first performs default deserialization. Next, this object's FlavorMap is deserialized by using the next object in the stream. If the resulting FlavorMap is null, this object's FlavorMap is set to the default FlavorMap for this thread's ClassLoader. Next, this object's listeners are deserialized by reading a null-terminated sequence of 0 or more key/value pairs from the stream:
  • If a key object is a String equal to dragSourceListenerK, a DragSourceListener is deserialized using the corresponding value object and added to this DragSource.
  • If a key object is a String equal to dragSourceMotionListenerK, a DragSourceMotionListener is deserialized using the corresponding value object and added to this DragSource.
  • Otherwise, the key/value pair is skipped.

Throws:
ClassNotFoundException
IOException
Since:
1.4
See Also:
SystemFlavorMap.getDefaultFlavorMap()

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Serializes this DragSource. This method first performs default serialization. Next, it writes out this object's FlavorMap if and only if it can be serialized. If not, null is written instead. Next, it writes out Serializable listeners registered with this object. Listeners are written in a null-terminated sequence of 0 or more pairs. The pair consists of a String and an Object; the String indicates the type of the Object and is one of the following:
  • dragSourceListenerK indicating a DragSourceListener object;
  • dragSourceMotionListenerK indicating a DragSourceMotionListener object.

Serial Data:
Either a FlavorMap instance, or null, followed by a null-terminated sequence of 0 or more pairs; the pair consists of a String and an Object; the String indicates the type of the Object and is one of the following:
  • dragSourceListenerK indicating a DragSourceListener object;
  • dragSourceMotionListenerK indicating a DragSourceMotionListener object.
.
Throws:
IOException
Since:
1.4

Class java.awt.dnd.DragSourceContext extends Object implements Serializable

serialVersionUID: -115407898692194719L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
Deserializes this DragSourceContext. This method first performs default deserialization for all non-transient fields. This object's Transferable and DragSourceListener are then deserialized as well by using the next two objects in the stream. If the resulting Transferable is null, this object's Transferable is set to a dummy Transferable which supports no DataFlavors.

Throws:
ClassNotFoundException
IOException
Since:
1.4

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Serializes this DragSourceContext. This method first performs default serialization. Next, this object's Transferable is written out if and only if it can be serialized. If not, null is written instead. In this case, a DragSourceContext created from the resulting deserialized stream will contain a dummy Transferable which supports no DataFlavors. Finally, this object's DragSourceListener is written out if and only if it can be serialized. If not, null is written instead.

Serial Data:
The default serializable fields, in alphabetical order, followed by either a Transferable instance, or null, followed by either a DragSourceListener instance, or null.
Throws:
IOException
Since:
1.4
Serialized Fields

trigger

DragGestureEvent trigger
The event which triggered the start of the drag.

cursor

Cursor cursor
The current drag cursor.

useCustomCursor

boolean useCustomCursor
true if the custom drag cursor is used instead of the default one.

sourceActions

int sourceActions
A bitwise mask of DnDConstants that represents the set of drop actions supported by the drag source for the drag operation associated with this DragSourceContext.

Class java.awt.dnd.DragSourceDragEvent extends DragSourceEvent implements Serializable

serialVersionUID: 481346297933902471L

Serialized Fields

targetActions

int targetActions
The target drop action.

dropAction

int dropAction
The user drop action.

gestureModifiers

int gestureModifiers
The state of the input device modifiers associated with the user gesture.

invalidModifiers

boolean invalidModifiers
Indicates whether the gestureModifiers are invalid.

Class java.awt.dnd.DragSourceDropEvent extends DragSourceEvent implements Serializable

serialVersionUID: -5571321229470821891L

Serialized Fields

dropSuccess

boolean dropSuccess
true if the drop was successful.

dropAction

int dropAction
The drop action.

Class java.awt.dnd.DragSourceEvent extends EventObject implements Serializable

serialVersionUID: -763287114604032641L

Serialized Fields

locationSpecified

boolean locationSpecified
The boolean indicating whether the cursor location is specified for this event.

x

int x
The horizontal coordinate for the cursor location at the moment this event occured if the cursor location is specified for this event; otherwise zero.

y

int y
The vertical coordinate for the cursor location at the moment this event occured if the cursor location is specified for this event; otherwise zero.

Class java.awt.dnd.DropTarget extends Object implements Serializable

serialVersionUID: -6283860791671019047L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
Deserializes this DropTarget. This method first performs default deserialization for all non-transient fields. An attempt is then made to deserialize this object's DropTargetListener as well. This is first attempted by deserializing the field dtListener, because, in releases prior to 1.4, a non-transient field of this name stored the DropTargetListener. If this fails, the next object in the stream is used instead.

Throws:
ClassNotFoundException
IOException
Since:
1.4

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Serializes this DropTarget. Performs default serialization, and then writes out this object's DropTargetListener if and only if it can be serialized. If not, null is written instead.

Serial Data:
The default serializable fields, in alphabetical order, followed by either a DropTargetListener instance, or null.
Throws:
IOException
Since:
1.4
Serialized Fields

dropTargetContext

DropTargetContext dropTargetContext
The DropTargetContext associated with this DropTarget.

component

Component component
The Component associated with this DropTarget.

actions

int actions
Default permissible actions supported by this DropTarget.

See Also:
DropTarget.setDefaultActions(int), DropTarget.getDefaultActions()

active

boolean active
true if the DropTarget is accepting Drag & Drop operations.

Class java.awt.dnd.DropTargetContext extends Object implements Serializable

serialVersionUID: -634158968993743371L

Serialized Fields

dropTarget

DropTarget dropTarget
The DropTarget associated with this DropTargetContext.

Class java.awt.dnd.DropTargetDragEvent extends DropTargetEvent implements Serializable

serialVersionUID: -8422265619058953682L

Serialized Fields

location

Point location
The location of the drag cursor's hotspot in Component coordinates.

actions

int actions
The source drop actions.

dropAction

int dropAction
The user drop action.

Class java.awt.dnd.DropTargetDropEvent extends DropTargetEvent implements Serializable

serialVersionUID: -1721911170440459322L

Serialized Fields

location

Point location
The location of the drag cursor's hotspot in Component coordinates.

actions

int actions
The source drop actions.

dropAction

int dropAction
The user drop action.

isLocalTx

boolean isLocalTx
true if the source is in the same JVM as the target.

Class java.awt.dnd.DropTargetEvent extends EventObject implements Serializable

serialVersionUID: 2821229066521922993L

Serialized Fields

context

DropTargetContext context
The DropTargetContext associated with this DropTargetEvent.

Class java.awt.dnd.InvalidDnDOperationException extends IllegalStateException implements Serializable

Class java.awt.dnd.MouseDragGestureRecognizer extends DragGestureRecognizer implements Serializable

serialVersionUID: 6220099344182281120L

Package java.awt.event

Class java.awt.event.ActionEvent extends AWTEvent implements Serializable

serialVersionUID: -7671078796273832149L

Serialized Fields

actionCommand

String actionCommand
The nonlocalized string that gives more details of what actually caused the event. This information is very specific to the component that fired it.

See Also:
ActionEvent.getActionCommand()

when

long when
Timestamp of when this event occurred. Because an ActionEvent is a high- level, semantic event, the timestamp is typically the same as an underlying InputEvent.

See Also:
ActionEvent.getWhen()

modifiers

int modifiers
This represents the key modifier that was selected, and is used to determine the state of the selected key. If no modifier has been selected it will default to zero.

See Also:
ActionEvent.getModifiers()

Class java.awt.event.AdjustmentEvent extends AWTEvent implements Serializable

serialVersionUID: 5700290645205279921L

Serialized Fields

adjustable

Adjustable adjustable
The adjustable object that fired the event.

See Also:
AdjustmentEvent.getAdjustable()

value

int value
value will contain the new value of the adjustable object. This value will always be in a range associated adjustable object.

See Also:
AdjustmentEvent.getValue()

adjustmentType

int adjustmentType
The adjustmentType describes how the adjustable object value has changed. This value can be increased/decreased by a block or unit amount where the block is associated with page increments/decrements, and a unit is associated with line increments/decrements.

See Also:
AdjustmentEvent.getAdjustmentType()

isAdjusting

boolean isAdjusting
The isAdjusting is true if the event is one of the series of multiple adjustment events.

Since:
1.4
See Also:
AdjustmentEvent.getValueIsAdjusting()

Class java.awt.event.ComponentEvent extends AWTEvent implements Serializable

serialVersionUID: 8101406823902992965L

Class java.awt.event.ContainerEvent extends ComponentEvent implements Serializable

serialVersionUID: -4114942250539772041L

Serialized Fields

child

Component child
The non-null component that is being added or removed from the Container.

See Also:
ContainerEvent.getChild()

Class java.awt.event.FocusEvent extends ComponentEvent implements Serializable

serialVersionUID: 523753786457416396L

Serialized Fields

temporary

boolean temporary
A focus event can have two different levels, permanent and temporary. It will be set to true if some operation takes away the focus temporarily and intends on getting it back once the event is completed. Otherwise it will be set to false.

See Also:
FocusEvent.isTemporary()

Class java.awt.event.HierarchyEvent extends AWTEvent implements Serializable

serialVersionUID: -5337576970038043990L

Serialized Fields

changed

Component changed

changedParent

Container changedParent

changeFlags

long changeFlags

Class java.awt.event.InputEvent extends ComponentEvent implements Serializable

serialVersionUID: -2482525981698309786L

Serialized Fields

when

long when
The input event's Time stamp in UTC format. The time stamp indicates when the input event was created.

See Also:
InputEvent.getWhen()

modifiers

int modifiers
The state of the modifier mask at the time the input event was fired.

See Also:
InputEvent.getModifiers(), InputEvent.getModifiersEx(), KeyEvent, MouseEvent

Class java.awt.event.InputMethodEvent extends AWTEvent implements Serializable

serialVersionUID: 4727190874778922661L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
Initializes the when field if it is not present in the object input stream. In that case, the field will be initialized by invoking EventQueue.getMostRecentEventTime().

Throws:
ClassNotFoundException
IOException
Serialized Fields

when

long when
The time stamp that indicates when the event was created.

Since:
1.4
See Also:
InputMethodEvent.getWhen()

Class java.awt.event.InvocationEvent extends AWTEvent implements Serializable

serialVersionUID: 436056344909459450L

Serialized Fields

runnable

Runnable runnable
The Runnable whose run() method will be called.

notifier

Object notifier
The (potentially null) Object whose notifyAll() method will be called immediately after the Runnable.run() method returns.

catchExceptions

boolean catchExceptions
Set to true if dispatch() catches Throwable and stores it in the exception instance variable. If false, Throwables are propagated up to the EventDispatchThread's dispatch loop.

exception

Exception exception
The (potentially null) Exception thrown during execution of the Runnable.run() method. This variable will also be null if a particular instance does not catch exceptions.

throwable

Throwable throwable
The (potentially null) Throwable thrown during execution of the Runnable.run() method. This variable will also be null if a particular instance does not catch exceptions.

when

long when
The timestamp of when this event occurred.

See Also:
InvocationEvent.getWhen()

Class java.awt.event.ItemEvent extends AWTEvent implements Serializable

serialVersionUID: -608708132447206933L

Serialized Fields

item

Object item
The item whose selection state has changed.

See Also:
ItemEvent.getItem()

stateChange

int stateChange
stateChange indicates whether the item was selected or deselected.

See Also:
ItemEvent.getStateChange()

Class java.awt.event.KeyEvent extends InputEvent implements Serializable

serialVersionUID: -2352130953028126954L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Sets new modifiers by the old ones. The key modifiers override overlaping mouse modifiers.

Throws:
IOException
ClassNotFoundException
Serialized Fields

isProxyActive

boolean isProxyActive
Stores the state of native event dispatching system - true, if when the event was created event proxying mechanism was active - false, if it was inactive Used in Component.dispatchEventImpl to correctly dispatch events when proxy is active

keyCode

int keyCode
The unique value assigned to each of the keys on the keyboard. There is a common set of key codes that can be fired by most keyboards. The symbolic name for a key code should be used rather than the code value itself.

See Also:
KeyEvent.getKeyCode(), KeyEvent.setKeyCode(int)

keyChar

char keyChar
keyChar is a valid unicode character that is fired by a key or a key combination on a keyboard.

See Also:
KeyEvent.getKeyChar(), KeyEvent.setKeyChar(char)

keyLocation

int keyLocation
The location of the key on the keyboard. Some keys occur more than once on a keyboard, e.g. the left and right shift keys. Additionally, some keys occur on the numeric keypad. This variable is used to distinguish such keys. The only legal values are KEY_LOCATION_UNKNOWN, KEY_LOCATION_STANDARD, KEY_LOCATION_LEFT, KEY_LOCATION_RIGHT, and KEY_LOCATION_NUMPAD.

See Also:
KeyEvent.getKeyLocation()

Class java.awt.event.MouseEvent extends InputEvent implements Serializable

serialVersionUID: -991214153494842848L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Sets new modifiers by the old ones.

Throws:
IOException
ClassNotFoundException
Serialized Fields

x

int x
The mouse event's x coordinate. The x value is relative to the component that fired the event.

See Also:
MouseEvent.getX()

y

int y
The mouse event's y coordinate. The y value is relative to the component that fired the event.

See Also:
MouseEvent.getY()

xAbs

int xAbs
The mouse event's x absolute coordinate. In a virtual device multi-screen environment in which the desktop area could span multiple physical screen devices, this coordinate is relative to the virtual coordinate system. Otherwise, this coordinate is relative to the coordinate system associated with the Component's GraphicsConfiguration.

yAbs

int yAbs
The mouse event's y absolute coordinate. In a virtual device multi-screen environment in which the desktop area could span multiple physical screen devices, this coordinate is relative to the virtual coordinate system. Otherwise, this coordinate is relative to the coordinate system associated with the Component's GraphicsConfiguration.

clickCount

int clickCount
Indicates the number of quick consecutive clicks of a mouse button. clickCount will be valid for only three mouse events :
MOUSE_CLICKED, MOUSE_PRESSED and MOUSE_RELEASED. For the above, the clickCount will be at least 1. For all other events the count will be 0.

See Also:
MouseEvent.getClickCount().

button

int button
Indicates which, if any, of the mouse buttons has changed state. The valid values are ranged from 0 to the value returned by the MouseInfo.getNumberOfButtons() method. This range already includes constants NOBUTTON, BUTTON1, BUTTON2, and BUTTON3 if these buttons are present. So it is allowed to use these constants too. For example, for a mouse with two buttons this field may contain the following values:
  • 0 (NOBUTTON)
  • 1 (BUTTON1)
  • 2 (BUTTON2)
If a mouse has 5 buttons, this field may contain the following values:
  • 0 (NOBUTTON)
  • 1 (BUTTON1)
  • 2 (BUTTON2)
  • 3 (BUTTON3)
  • 4
  • 5
If support for extended mouse buttons is Toolkit.areExtraMouseButtonsEnabled() disabled by Java then the field may not contain the value larger than BUTTON3.

See Also:
MouseEvent.getButton(), Toolkit.areExtraMouseButtonsEnabled()

popupTrigger

boolean popupTrigger
A property used to indicate whether a Popup Menu should appear with a certain gestures. If popupTrigger = false, no popup menu should appear. If it is true then a popup menu should appear.

See Also:
PopupMenu, MouseEvent.isPopupTrigger()

Class java.awt.event.MouseWheelEvent extends MouseEvent implements Serializable

serialVersionUID: 6459879390515399677L

Serialized Fields

scrollType

int scrollType
Indicates what sort of scrolling should take place in response to this event, based on platform settings. Legal values are:
  • WHEEL_UNIT_SCROLL
  • WHEEL_BLOCK_SCROLL

See Also:
MouseWheelEvent.getScrollType()

scrollAmount

int scrollAmount
Only valid for scrollType WHEEL_UNIT_SCROLL. Indicates number of units that should be scrolled per click of mouse wheel rotation, based on platform settings.

See Also:
MouseWheelEvent.getScrollAmount(), MouseWheelEvent.getScrollType()

wheelRotation

int wheelRotation
Indicates how far the mouse wheel was rotated.

See Also:
MouseWheelEvent.getWheelRotation()

preciseWheelRotation

double preciseWheelRotation
Indicates how far the mouse wheel was rotated.

See Also:
MouseWheelEvent.getPreciseWheelRotation()

Class java.awt.event.PaintEvent extends ComponentEvent implements Serializable

serialVersionUID: 1267492026433337593L

Serialized Fields

updateRect

Rectangle updateRect
This is the rectangle that represents the area on the source component that requires a repaint. This rectangle should be non null.

See Also:
Rectangle, PaintEvent.setUpdateRect(Rectangle), PaintEvent.getUpdateRect()

Class java.awt.event.TextEvent extends AWTEvent implements Serializable

serialVersionUID: 6269902291250941179L

Class java.awt.event.WindowEvent extends ComponentEvent implements Serializable

serialVersionUID: -1567959133147912127L

Serialized Fields

oldState

int oldState
TBS

newState

int newState
Package java.awt.font

Class java.awt.font.NumericShaper extends Object implements Serializable

Serialized Fields

key

int key
index of context for contextual shaping - values range from 0 to 18

mask

int mask
flag indicating whether to shape contextually (high bit) and which digit ranges to shape (bits 0-18)

Class java.awt.font.TextAttribute extends AttributedCharacterIterator.Attribute implements Serializable

serialVersionUID: 7744112784117861702L

Serialization Methods

readResolve

protected Object readResolve()
                      throws InvalidObjectException
Resolves instances being deserialized to the predefined constants.

Throws:
InvalidObjectException

Class java.awt.font.TransformAttribute extends Object implements Serializable

serialVersionUID: 3356247357827709530L

Serialization Methods

writeObject

private void writeObject(ObjectOutputStream s)
                  throws ClassNotFoundException,
                         IOException
Throws:
ClassNotFoundException
IOException

readResolve

private Object readResolve()
                    throws ObjectStreamException
Throws:
ObjectStreamException
Serialized Fields

transform

AffineTransform transform
The AffineTransform for this TransformAttribute, or null if AffineTransform is the identity transform.

Package java.awt.geom

Class java.awt.geom.AffineTransform extends Object implements Serializable

serialVersionUID: 1330973210523860834L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
Throws:
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws ClassNotFoundException,
                         IOException
Throws:
ClassNotFoundException
IOException
Serialized Fields

m00

double m00
The X coordinate scaling element of the 3x3 affine transformation matrix.

m10

double m10
The Y coordinate shearing element of the 3x3 affine transformation matrix.

m01

double m01
The X coordinate shearing element of the 3x3 affine transformation matrix.

m11

double m11
The Y coordinate scaling element of the 3x3 affine transformation matrix.

m02

double m02
The X coordinate of the translation element of the 3x3 affine transformation matrix.

m12

double m12
The Y coordinate of the translation element of the 3x3 affine transformation matrix.

Class java.awt.geom.Arc2D.Double extends Arc2D implements Serializable

serialVersionUID: 728264085846882001L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
Reads the default serializable fields from the ObjectInputStream followed by a byte indicating the arc type of this Arc2D instance.

Serial Data:
  1. The default serializable fields.
  2. followed by a byte indicating the arc type Arc2D.OPEN, Arc2D.CHORD, or Arc2D.PIE.
Throws:
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Writes the default serializable fields to the ObjectOutputStream followed by a byte indicating the arc type of this Arc2D instance.

Serial Data:
  1. The default serializable fields.
  2. followed by a byte indicating the arc type Arc2D.OPEN, Arc2D.CHORD, or Arc2D.PIE.
Throws:
IOException
Serialized Fields

x

double x
The X coordinate of the upper-left corner of the framing rectangle of the arc.

Since:
1.2

y

double y
The Y coordinate of the upper-left corner of the framing rectangle of the arc.

Since:
1.2

width

double width
The overall width of the full ellipse of which this arc is a partial section (not considering the angular extents).

Since:
1.2

height

double height
The overall height of the full ellipse of which this arc is a partial section (not considering the angular extents).

Since:
1.2

start

double start
The starting angle of the arc in degrees.

Since:
1.2

extent

double extent
The angular extent of the arc in degrees.

Since:
1.2

Class java.awt.geom.Arc2D.Float extends Arc2D implements Serializable

serialVersionUID: 9130893014586380278L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
Reads the default serializable fields from the ObjectInputStream followed by a byte indicating the arc type of this Arc2D instance.

Serial Data:
  1. The default serializable fields.
  2. followed by a byte indicating the arc type Arc2D.OPEN, Arc2D.CHORD, or Arc2D.PIE.
Throws:
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Writes the default serializable fields to the ObjectOutputStream followed by a byte indicating the arc type of this Arc2D instance.

Serial Data:
  1. The default serializable fields.
  2. followed by a byte indicating the arc type Arc2D.OPEN, Arc2D.CHORD, or Arc2D.PIE.
Throws:
IOException
Serialized Fields

x

float x
The X coordinate of the upper-left corner of the framing rectangle of the arc.

Since:
1.2

y

float y
The Y coordinate of the upper-left corner of the framing rectangle of the arc.

Since:
1.2

width

float width
The overall width of the full ellipse of which this arc is a partial section (not considering the angular extents).

Since:
1.2

height

float height
The overall height of the full ellipse of which this arc is a partial section (not considering the angular extents).

Since:
1.2

start

float start
The starting angle of the arc in degrees.

Since:
1.2

extent

float extent
The angular extent of the arc in degrees.

Since:
1.2

Class java.awt.geom.CubicCurve2D.Double extends CubicCurve2D implements Serializable

serialVersionUID: -4202960122839707295L

Serialized Fields

x1

double x1
The X coordinate of the start point of the cubic curve segment.

Since:
1.2

y1

double y1
The Y coordinate of the start point of the cubic curve segment.

Since:
1.2

ctrlx1

double ctrlx1
The X coordinate of the first control point of the cubic curve segment.

Since:
1.2

ctrly1

double ctrly1
The Y coordinate of the first control point of the cubic curve segment.

Since:
1.2

ctrlx2

double ctrlx2
The X coordinate of the second control point of the cubic curve segment.

Since:
1.2

ctrly2

double ctrly2
The Y coordinate of the second control point of the cubic curve segment.

Since:
1.2

x2

double x2
The X coordinate of the end point of the cubic curve segment.

Since:
1.2

y2

double y2
The Y coordinate of the end point of the cubic curve segment.

Since:
1.2

Class java.awt.geom.CubicCurve2D.Float extends CubicCurve2D implements Serializable

serialVersionUID: -1272015596714244385L

Serialized Fields

x1

float x1
The X coordinate of the start point of the cubic curve segment.

Since:
1.2

y1

float y1
The Y coordinate of the start point of the cubic curve segment.

Since:
1.2

ctrlx1

float ctrlx1
The X coordinate of the first control point of the cubic curve segment.

Since:
1.2

ctrly1

float ctrly1
The Y coordinate of the first control point of the cubic curve segment.

Since:
1.2

ctrlx2

float ctrlx2
The X coordinate of the second control point of the cubic curve segment.

Since:
1.2

ctrly2

float ctrly2
The Y coordinate of the second control point of the cubic curve segment.

Since:
1.2

x2

float x2
The X coordinate of the end point of the cubic curve segment.

Since:
1.2

y2

float y2
The Y coordinate of the end point of the cubic curve segment.

Since:
1.2

Class java.awt.geom.Ellipse2D.Double extends Ellipse2D implements Serializable

serialVersionUID: 5555464816372320683L

Serialized Fields

x

double x
The X coordinate of the upper-left corner of the framing rectangle of this Ellipse2D.

Since:
1.2

y

double y
The Y coordinate of the upper-left corner of the framing rectangle of this Ellipse2D.

Since:
1.2

width

double width
The overall width of this Ellipse2D.

Since:
1.2

height

double height
The overall height of the Ellipse2D.

Since:
1.2

Class java.awt.geom.Ellipse2D.Float extends Ellipse2D implements Serializable

serialVersionUID: -6633761252372475977L

Serialized Fields

x

float x
The X coordinate of the upper-left corner of the framing rectangle of this Ellipse2D.

Since:
1.2

y

float y
The Y coordinate of the upper-left corner of the framing rectangle of this Ellipse2D.

Since:
1.2

width

float width
The overall width of this Ellipse2D.

Since:
1.2

height

float height
The overall height of this Ellipse2D.

Since:
1.2

Class java.awt.geom.GeneralPath extends Path2D.Float implements Serializable

serialVersionUID: -8327096662768731142L

Class java.awt.geom.IllegalPathStateException extends RuntimeException implements Serializable

Class java.awt.geom.Line2D.Double extends Line2D implements Serializable

serialVersionUID: 7979627399746467499L

Serialized Fields

x1

double x1
The X coordinate of the start point of the line segment.

Since:
1.2

y1

double y1
The Y coordinate of the start point of the line segment.

Since:
1.2

x2

double x2
The X coordinate of the end point of the line segment.

Since:
1.2

y2

double y2
The Y coordinate of the end point of the line segment.

Since:
1.2

Class java.awt.geom.Line2D.Float extends Line2D implements Serializable

serialVersionUID: 6161772511649436349L

Serialized Fields

x1

float x1
The X coordinate of the start point of the line segment.

Since:
1.2

y1

float y1
The Y coordinate of the start point of the line segment.

Since:
1.2

x2

float x2
The X coordinate of the end point of the line segment.

Since:
1.2

y2

float y2
The Y coordinate of the end point of the line segment.

Since:
1.2

Class java.awt.geom.NoninvertibleTransformException extends Exception implements Serializable

Class java.awt.geom.Path2D.Double extends Path2D implements Serializable

serialVersionUID: 1826762518450014216L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
Reads the default serializable fields from the ObjectInputStream followed by an explicit serialization of the path segments stored in this path.

There are no default serializable fields as of 1.6.

The serial data for this object is described in the writeObject method.

Throws:
ClassNotFoundException
IOException
Since:
1.6

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Writes the default serializable fields to the ObjectOutputStream followed by an explicit serialization of the path segments stored in this path.

Serial Data:
  1. The default serializable fields. There are no default serializable fields as of 1.6.
  2. followed by a byte indicating the storage type of the original object as a hint (SERIAL_STORAGE_DBL_ARRAY)
  3. followed by an integer indicating the number of path segments to follow (NP) or -1 to indicate an unknown number of path segments follows
  4. followed by an integer indicating the total number of coordinates to follow (NC) or -1 to indicate an unknown number of coordinates follows (NC should always be even since coordinates always appear in pairs representing an x,y pair)
  5. followed by a byte indicating the winding rule (WIND_EVEN_ODD or WIND_NON_ZERO)
  6. followed by NP (or unlimited if NP < 0) sets of values consisting of a single byte indicating a path segment type followed by one or more pairs of float or double values representing the coordinates of the path segment
  7. followed by a byte indicating the end of the path (SERIAL_PATH_END).

The following byte value constants are used in the serialized form of Path2D objects:

Constant Name | Byte Value | Followed by | Description
SERIAL_STORAGE_FLT_ARRAY | 0x30 | A hint that the original Path2D object stored the coordinates in a Java array of floats.
SERIAL_STORAGE_DBL_ARRAY | 0x31 | A hint that the original Path2D object stored the coordinates in a Java array of doubles.
SERIAL_SEG_FLT_MOVETO | 0x40 | 2 floats | A moveTo path segment follows.
SERIAL_SEG_FLT_LINETO | 0x41 | 2 floats | A lineTo path segment follows.
SERIAL_SEG_FLT_QUADTO | 0x42 | 4 floats | A quadTo path segment follows.
SERIAL_SEG_FLT_CUBICTO | 0x43 | 6 floats | A curveTo path segment follows.
SERIAL_SEG_DBL_MOVETO | 0x50 | 2 doubles | A moveTo path segment follows.
SERIAL_SEG_DBL_LINETO | 0x51 | 2 doubles | A lineTo path segment follows.
SERIAL_SEG_DBL_QUADTO | 0x52 | 4 doubles | A curveTo path segment follows.
SERIAL_SEG_DBL_CUBICTO | 0x53 | 6 doubles | A curveTo path segment follows.
SERIAL_SEG_CLOSE | 0x60 | A closePath path segment.
SERIAL_PATH_END | 0x61 | There are no more path segments following.
Throws:
IOException
Since:
1.6

Class java.awt.geom.Path2D.Float extends Path2D implements Serializable

serialVersionUID: 6990832515060788886L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
Reads the default serializable fields from the ObjectInputStream followed by an explicit serialization of the path segments stored in this path.

There are no default serializable fields as of 1.6.

The serial data for this object is described in the writeObject method.

Throws:
ClassNotFoundException
IOException
Since:
1.6

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Writes the default serializable fields to the ObjectOutputStream followed by an explicit serialization of the path segments stored in this path.

Serial Data:
  1. The default serializable fields. There are no default serializable fields as of 1.6.
  2. followed by a byte indicating the storage type of the original object as a hint (SERIAL_STORAGE_FLT_ARRAY)
  3. followed by an integer indicating the number of path segments to follow (NP) or -1 to indicate an unknown number of path segments follows
  4. followed by an integer indicating the total number of coordinates to follow (NC) or -1 to indicate an unknown number of coordinates follows (NC should always be even since coordinates always appear in pairs representing an x,y pair)
  5. followed by a byte indicating the winding rule (WIND_EVEN_ODD or WIND_NON_ZERO)
  6. followed by NP (or unlimited if NP < 0) sets of values consisting of a single byte indicating a path segment type followed by one or more pairs of float or double values representing the coordinates of the path segment
  7. followed by a byte indicating the end of the path (SERIAL_PATH_END).

The following byte value constants are used in the serialized form of Path2D objects:

Constant Name | Byte Value | Followed by | Description
SERIAL_STORAGE_FLT_ARRAY | 0x30 | A hint that the original Path2D object stored the coordinates in a Java array of floats.
SERIAL_STORAGE_DBL_ARRAY | 0x31 | A hint that the original Path2D object stored the coordinates in a Java array of doubles.
SERIAL_SEG_FLT_MOVETO | 0x40 | 2 floats | A moveTo path segment follows.
SERIAL_SEG_FLT_LINETO | 0x41 | 2 floats | A lineTo path segment follows.
SERIAL_SEG_FLT_QUADTO | 0x42 | 4 floats | A quadTo path segment follows.
SERIAL_SEG_FLT_CUBICTO | 0x43 | 6 floats | A curveTo path segment follows.
SERIAL_SEG_DBL_MOVETO | 0x50 | 2 doubles | A moveTo path segment follows.
SERIAL_SEG_DBL_LINETO | 0x51 | 2 doubles | A lineTo path segment follows.
SERIAL_SEG_DBL_QUADTO | 0x52 | 4 doubles | A curveTo path segment follows.
SERIAL_SEG_DBL_CUBICTO | 0x53 | 6 doubles | A curveTo path segment follows.
SERIAL_SEG_CLOSE | 0x60 | A closePath path segment.
SERIAL_PATH_END | 0x61 | There are no more path segments following.
Throws:
IOException
Since:
1.6

Class java.awt.geom.Point2D.Double extends Point2D implements Serializable

serialVersionUID: 6150783262733311327L

Serialized Fields

x

double x
The X coordinate of this Point2D.

Since:
1.2

y

double y
The Y coordinate of this Point2D.

Since:
1.2

Class java.awt.geom.Point2D.Float extends Point2D implements Serializable

serialVersionUID: -2870572449815403710L

Serialized Fields

x

float x
The X coordinate of this Point2D.

Since:
1.2

y

float y
The Y coordinate of this Point2D.

Since:
1.2

Class java.awt.geom.QuadCurve2D.Double extends QuadCurve2D implements Serializable

serialVersionUID: 4217149928428559721L

Serialized Fields

x1

double x1
The X coordinate of the start point of the quadratic curve segment.

Since:
1.2

y1

double y1
The Y coordinate of the start point of the quadratic curve segment.

Since:
1.2

ctrlx

double ctrlx
The X coordinate of the control point of the quadratic curve segment.

Since:
1.2

ctrly

double ctrly
The Y coordinate of the control point of the quadratic curve segment.

Since:
1.2

x2

double x2
The X coordinate of the end point of the quadratic curve segment.

Since:
1.2

y2

double y2
The Y coordinate of the end point of the quadratic curve segment.

Since:
1.2

Class java.awt.geom.QuadCurve2D.Float extends QuadCurve2D implements Serializable

serialVersionUID: -8511188402130719609L

Serialized Fields

x1

float x1
The X coordinate of the start point of the quadratic curve segment.

Since:
1.2

y1

float y1
The Y coordinate of the start point of the quadratic curve segment.

Since:
1.2

ctrlx

float ctrlx
The X coordinate of the control point of the quadratic curve segment.

Since:
1.2

ctrly

float ctrly
The Y coordinate of the control point of the quadratic curve segment.

Since:
1.2

x2

float x2
The X coordinate of the end point of the quadratic curve segment.

Since:
1.2

y2

float y2
The Y coordinate of the end point of the quadratic curve segment.

Since:
1.2

Class java.awt.geom.Rectangle2D.Double extends Rectangle2D implements Serializable

serialVersionUID: 7771313791441850493L

Serialized Fields

x

double x
The X coordinate of this Rectangle2D.

Since:
1.2

y

double y
The Y coordinate of this Rectangle2D.

Since:
1.2

width

double width
The width of this Rectangle2D.

Since:
1.2

height

double height
The height of this Rectangle2D.

Since:
1.2

Class java.awt.geom.Rectangle2D.Float extends Rectangle2D implements Serializable

serialVersionUID: 3798716824173675777L

Serialized Fields

x

float x
The X coordinate of this Rectangle2D.

Since:
1.2

y

float y
The Y coordinate of this Rectangle2D.

Since:
1.2

width

float width
The width of this Rectangle2D.

Since:
1.2

height

float height
The height of this Rectangle2D.

Since:
1.2

Class java.awt.geom.RoundRectangle2D.Double extends RoundRectangle2D implements Serializable

serialVersionUID: 1048939333485206117L

Serialized Fields

x

double x
The X coordinate of this RoundRectangle2D.

Since:
1.2

y

double y
The Y coordinate of this RoundRectangle2D.

Since:
1.2

width

double width
The width of this RoundRectangle2D.

Since:
1.2

height

double height
The height of this RoundRectangle2D.

Since:
1.2

arcwidth

double arcwidth
The width of the arc that rounds off the corners.

Since:
1.2

archeight

double archeight
The height of the arc that rounds off the corners.

Since:
1.2

Class java.awt.geom.RoundRectangle2D.Float extends RoundRectangle2D implements Serializable

serialVersionUID: -3423150618393866922L

Serialized Fields

x

float x
The X coordinate of this RoundRectangle2D.

Since:
1.2

y

float y
The Y coordinate of this RoundRectangle2D.

Since:
1.2

width

float width
The width of this RoundRectangle2D.

Since:
1.2

height

float height
The height of this RoundRectangle2D.

Since:
1.2

arcwidth

float arcwidth
The width of the arc that rounds off the corners.

Since:
1.2

archeight

float archeight
The height of the arc that rounds off the corners.

Since:
1.2
Package java.awt.image

Class java.awt.image.ImagingOpException extends RuntimeException implements Serializable

Class java.awt.image.RasterFormatException extends RuntimeException implements Serializable

Package java.awt.image.renderable

Class java.awt.image.renderable.ParameterBlock extends Object implements Serializable

Serialized Fields

sources

Vector<E> sources
A Vector of sources, stored as arbitrary Objects.

parameters

Vector<E> parameters
A Vector of non-source parameters, stored as arbitrary Objects.

Package java.awt.print

Class java.awt.print.PrinterAbortException extends PrinterException implements Serializable

Class java.awt.print.PrinterException extends Exception implements Serializable

Class java.awt.print.PrinterIOException extends PrinterException implements Serializable

serialVersionUID: 5850870712125932846L

Serialized Fields

mException

IOException mException
The IO error that terminated the print job.

Package java.beans

Class java.beans.IndexedPropertyChangeEvent extends PropertyChangeEvent implements Serializable

serialVersionUID: -320227448495806870L

Serialized Fields

index

int index

Class java.beans.IntrospectionException extends Exception implements Serializable

serialVersionUID: -3728150539969542619L

Class java.beans.PropertyChangeEvent extends EventObject implements Serializable

serialVersionUID: 7042693688939648123L

Serialized Fields

propertyName

String propertyName
name of the property that changed. May be null, if not known.

newValue

Object newValue
New value for property. May be null if not known.

oldValue

Object oldValue
Previous value for property. May be null if not known.

propagationId

Object propagationId
Propagation ID. May be null.

See Also:
PropertyChangeEvent.getPropagationId()

Class java.beans.PropertyChangeSupport extends Object implements Serializable

serialVersionUID: 6401253773779951803L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
Throws:
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Serial Data:
Null terminated list of PropertyChangeListeners.

At serialization time we skip non-serializable listeners and only serialize the serializable listeners.

Throws:
IOException
Serialized Fields

children

Hashtable<K,V> children

propertyChangeSupportSerializedDataVersion

int propertyChangeSupportSerializedDataVersion

source

Object source
The object to be provided as the "source" for any generated events.

Class java.beans.PropertyVetoException extends Exception implements Serializable

serialVersionUID: 129596057694162164L

Serialized Fields

evt

PropertyChangeEvent evt
A PropertyChangeEvent describing the vetoed change.

Class java.beans.VetoableChangeSupport extends Object implements Serializable

serialVersionUID: -5090210921595982017L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
Throws:
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Serial Data:
Null terminated list of VetoableChangeListeners.

At serialization time we skip non-serializable listeners and only serialize the serializable listeners.

Throws:
IOException
Serialized Fields

children

Hashtable<K,V> children

propertyChangeSupportSerializedDataVersion

int propertyChangeSupportSerializedDataVersion

source

Object source
The object to be provided as the "source" for any generated events.
Package java.beans.beancontext

Class java.beans.beancontext.BeanContextChildSupport extends Object implements Serializable

serialVersionUID: 6328947014421475877L

Serialization Methods

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
Restore a persistent object, must wait for subsequent setBeanContext() to fully restore any resources obtained from the new nesting BeanContext

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
Write the persistence state of the object.

Throws:
IOException
Serialized Fields

beanContextChildPeer

BeanContextChild beanContextChildPeer
The BeanContext in which this BeanContextChild is nested.

pcSupport

PropertyChangeSupport pcSupport
The PropertyChangeSupport associated with this BeanContextChildSupport.

vcSupport

VetoableChangeSupport vcSupport
The VetoableChangeSupport associated with this BeanContextChildSupport.

Class java.beans.beancontext.BeanContextEvent extends EventObject implements Serializable

serialVersionUID: 7267998073569045052L

Serialized Fields

propagatedFrom

BeanContext propagatedFrom
The BeanContext from which this event was propagated

Class java.beans.beancontext.BeanContextMembershipEvent extends BeanContextEvent implements Serializable

serialVersionUID: 3499346510334590959L

Serialized Fields

children

Collection<E> children
The list of children affected by this event notification.

Class java.beans.beancontext.BeanContextServiceAvailableEvent extends BeanContextEvent implements Serializable

serialVersionUID: -5333985775656400778L

Serialized Fields

serviceClass

Class<T> serviceClass
A Class reference to the newly available service

Class java.beans.beancontext.BeanContextServiceRevokedEvent extends BeanContextEvent implements Serializable

serialVersionUID: -1295543154724961754L

Serialized Fields

serviceClass

Class<T> serviceClass
A Class reference to the service that is being revoked.

invalidateRefs

boolean invalidateRefs

Class java.beans.beancontext.BeanContextServicesSupport extends BeanContextSupport implements Serializable

serialVersionUID: -8494482757288719206L

Serialization Methods

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
deserialize the instance

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
serialize the instance

Throws:
IOException

Class java.beans.beancontext.BeanContextServicesSupport.BCSSChild extends BeanContextSupport.BCSChild implements Serializable

serialVersionUID: -3263851306889194873L

Class java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider extends Object implements Serializable

serialVersionUID: 861278251667444782L

Serialized Fields

serviceProvider

BeanContextServiceProvider serviceProvider

Class java.beans.beancontext.BeanContextSupport extends BeanContextChildSupport implements Serializable

serialVersionUID: -4879613978649577204L

Serialization Methods

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
deserialize contents ... if this instance has a distinct peer the children are *not* serialized here, the peer's readObject() must call readChildren() after deserializing this instance.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException,
                         ClassNotFoundException
Serialize the BeanContextSupport, if this instance has a distinct peer (that is this object is acting as a delegate for another) then the children of this instance are not serialized here due to a 'chicken and egg' problem that occurs on deserialization of the children at the same time as this instance. Therefore in situations where there is a distinct peer to this instance it should always call writeObject() followed by writeChildren() and readObject() followed by readChildren().

Throws:
IOException
ClassNotFoundException
Serialized Fields

serializable

int serializable

locale

Locale locale
The current locale of this BeanContext.

okToUseGui

boolean okToUseGui
A boolean indicating if this instance may now render a GUI.

designTime

boolean designTime
A boolean indicating whether or not this object is currently in design time mode.

Class java.beans.beancontext.BeanContextSupport.BCSChild extends Object implements Serializable

serialVersionUID: -5815286101609939109L

Serialized Fields

child

Object child

proxyPeer

Object proxyPeer
Package java.dyn

Class java.dyn.InvokeDynamicBootstrapError extends LinkageError implements Serializable

Class java.dyn.LinkagePermission extends BasicPermission implements Serializable

Class java.dyn.NoAccessException extends RuntimeException implements Serializable

Class java.dyn.WrongMethodTypeException extends RuntimeException implements Serializable

Package java.io

Class java.io.CharConversionException extends IOException implements Serializable

serialVersionUID: -8680016352018427031L

Class java.io.EOFException extends IOException implements Serializable

serialVersionUID: 6433858223774886977L

Class java.io.File extends Object implements Serializable

serialVersionUID: 301077366599181567L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
readObject is called to restore this filename. The original separator character is read. If it is different than the separator character on this system, then the old separator is replaced by the local separator.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
WriteObject is called to save this filename. The separator character is saved also so it can be replaced in case the path is reconstituted on a different host type.

Serial Data:
Default fields followed by separator character.
Throws:
IOException
Serialized Fields

path

String path
This abstract pathname's normalized pathname string. A normalized pathname string uses the default name-separator character and does not contain any duplicate or redundant separators.

Class java.io.FileNotFoundException extends IOException implements Serializable

serialVersionUID: -897856973823710492L

Class java.io.FilePermissionCollection extends PermissionCollection implements Serializable

serialVersionUID: 2202956749081564585L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serial Data:
"permissions" field (a Vector containing the FilePermissions).
Throws:
IOException
Serialized Fields

permissions

Vector<E> permissions
A list of FilePermission objects.

Class java.io.InterruptedIOException extends IOException implements Serializable

serialVersionUID: 4020568460727500567L

Serialized Fields

bytesTransferred

int bytesTransferred
Reports how many bytes had been transferred as part of the I/O operation before it was interrupted.

Class java.io.InvalidClassException extends ObjectStreamException implements Serializable

serialVersionUID: -4333316296251054416L

Serialized Fields

classname

String classname
Name of the invalid class.

Name of the invalid class.

Class java.io.InvalidObjectException extends ObjectStreamException implements Serializable

serialVersionUID: 3233174318281839583L

Class java.io.IOError extends Error implements Serializable

serialVersionUID: 67100927991680413L

Class java.io.IOException extends Exception implements Serializable

serialVersionUID: 7818375828146090155L

Class java.io.NotActiveException extends ObjectStreamException implements Serializable

serialVersionUID: -3893467273049808895L

Class java.io.NotSerializableException extends ObjectStreamException implements Serializable

serialVersionUID: 2906642554793891381L

Class java.io.ObjectStreamClass extends Object implements Serializable

serialVersionUID: -6120832682080437368L

Serialized Fields

Class java.io.ObjectStreamException extends IOException implements Serializable

serialVersionUID: 7260898174833392607L

Class java.io.OptionalDataException extends ObjectStreamException implements Serializable

serialVersionUID: -8011121865681257820L

Serialized Fields

length

int length
The number of bytes of primitive data available to be read in the current buffer.

eof

boolean eof
True if there is no more data in the buffered part of the stream.

Class java.io.SerializablePermission extends BasicPermission implements Serializable

serialVersionUID: 8537212141160296410L

Serialized Fields

actions

String actions

Class java.io.StreamCorruptedException extends ObjectStreamException implements Serializable

serialVersionUID: 8983558202217591746L

Class java.io.SyncFailedException extends IOException implements Serializable

serialVersionUID: -2353342684412443330L

Class java.io.UnsupportedEncodingException extends IOException implements Serializable

serialVersionUID: -4274276298326136670L

Class java.io.UTFDataFormatException extends IOException implements Serializable

serialVersionUID: 420743449228280612L

Class java.io.WriteAbortedException extends ObjectStreamException implements Serializable

serialVersionUID: -3326426625597282442L

Serialized Fields

detail

Exception detail
Exception that was caught while writing the ObjectStream.

This field predates the general-purpose exception chaining facility. The Throwable.getCause() method is now the preferred means of obtaining this information.

Package java.lang

Class java.lang.AbstractMethodError extends IncompatibleClassChangeError implements Serializable

serialVersionUID: -1654391082989018462L

Class java.lang.ArithmeticException extends RuntimeException implements Serializable

serialVersionUID: 2256477558314496007L

Class java.lang.ArrayIndexOutOfBoundsException extends IndexOutOfBoundsException implements Serializable

serialVersionUID: -5116101128118950844L

Class java.lang.ArrayStoreException extends RuntimeException implements Serializable

serialVersionUID: -4522193890499838241L

Class java.lang.AssertionError extends Error implements Serializable

serialVersionUID: -5013299493970297370L

Class java.lang.Boolean extends Object implements Serializable

serialVersionUID: -3665804199014368530L

Serialized Fields

value

boolean value
The value of the Boolean.

Class java.lang.Byte extends Number implements Serializable

serialVersionUID: -7183698231559129828L

Serialized Fields

value

byte value
The value of the Byte.

Class java.lang.Character extends Object implements Serializable

serialVersionUID: 3786198910865385080L

Serialized Fields

value

char value
The value of the Character.

Class java.lang.Class extends Object implements Serializable

serialVersionUID: 3206093459760846163L

Serialization Overview
Class Class is special cased within the Serialization Stream Protocol. A Class instance is written initially into an ObjectOutputStream in the following format:
      TC_CLASS ClassDescriptor
      A ClassDescriptor is a special cased serialization of
      a java.io.ObjectStreamClass instance.
A new handle is generated for the initial time the class descriptor is written into the stream. Future references to the class descriptor are written as references to the initial class descriptor instance.

See Also:
ObjectStreamClass
Serialized Fields

Class java.lang.ClassCastException extends RuntimeException implements Serializable

serialVersionUID: -9223365651070458532L

Class java.lang.ClassCircularityError extends LinkageError implements Serializable

serialVersionUID: 1054362542914539689L

Class java.lang.ClassFormatError extends LinkageError implements Serializable

serialVersionUID: -8420114879011949195L

Class java.lang.ClassNotFoundException extends Exception implements Serializable

serialVersionUID: 9176873029745254542L

Serialized Fields

ex

Throwable ex
This field holds the exception ex if the ClassNotFoundException(String s, Throwable ex) constructor was used to instantiate the object

Since:
1.2

Class java.lang.CloneNotSupportedException extends Exception implements Serializable

serialVersionUID: 5195511250079656443L

Class java.lang.Double extends Number implements Serializable

serialVersionUID: -9172774392245257468L

Serialized Fields

value

double value
The value of the Double.

Class java.lang.Enum extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
prevent default deserialization

Throws:
IOException
ClassNotFoundException

readObjectNoData

private void readObjectNoData()
                       throws ObjectStreamException
Throws:
ObjectStreamException
Serialized Fields

name

String name
The name of this enum constant, as declared in the enum declaration. Most programmers should use the Enum.toString() method rather than accessing this field.

ordinal

int ordinal
The ordinal of this enumeration constant (its position in the enum declaration, where the initial constant is assigned an ordinal of zero). Most programmers will have no use for this field. It is designed for use by sophisticated enum-based data structures, such as EnumSet and EnumMap.

Class java.lang.EnumConstantNotPresentException extends RuntimeException implements Serializable

serialVersionUID: -6046998521960521108L

Serialized Fields

enumType

Class<T> enumType
The type of the missing enum constant.

constantName

String constantName
The name of the missing enum constant.

Class java.lang.Error extends Throwable implements Serializable

serialVersionUID: 4980196508277280342L

Class java.lang.Exception extends Throwable implements Serializable

serialVersionUID: -3387516993124229948L

Class java.lang.ExceptionInInitializerError extends LinkageError implements Serializable

serialVersionUID: 1521711792217232256L

Serialized Fields

exception

Throwable exception
This field holds the exception if the ExceptionInInitializerError(Throwable thrown) constructor was used to instantiate the object

Class java.lang.Float extends Number implements Serializable

serialVersionUID: -2671257302660747028L

Serialized Fields

value

float value
The value of the Float.

Class java.lang.IllegalAccessError extends IncompatibleClassChangeError implements Serializable

serialVersionUID: -8988904074992417891L

Class java.lang.IllegalAccessException extends Exception implements Serializable

serialVersionUID: 6616958222490762034L

Class java.lang.IllegalArgumentException extends RuntimeException implements Serializable

serialVersionUID: -5365630128856068164L

Class java.lang.IllegalMonitorStateException extends RuntimeException implements Serializable

serialVersionUID: 3713306369498869069L

Class java.lang.IllegalStateException extends RuntimeException implements Serializable

serialVersionUID: -1848914673093119416L

Class java.lang.IllegalThreadStateException extends IllegalArgumentException implements Serializable

serialVersionUID: -7626246362397460174L

Class java.lang.IncompatibleClassChangeError extends LinkageError implements Serializable

serialVersionUID: -4914975503642802119L

Class java.lang.IndexOutOfBoundsException extends RuntimeException implements Serializable

serialVersionUID: 234122996006267687L

Class java.lang.InstantiationError extends IncompatibleClassChangeError implements Serializable

serialVersionUID: -4885810657349421204L

Class java.lang.InstantiationException extends Exception implements Serializable

serialVersionUID: -8441929162975509110L

Class java.lang.Integer extends Number implements Serializable

serialVersionUID: 1360826667806852920L

Serialized Fields

value

int value
The value of the Integer.

Class java.lang.InternalError extends VirtualMachineError implements Serializable

serialVersionUID: -9062593416125562365L

Class java.lang.InterruptedException extends Exception implements Serializable

serialVersionUID: 6700697376100628473L

Class java.lang.LinkageError extends Error implements Serializable

serialVersionUID: 3579600108157160122L

Class java.lang.Long extends Number implements Serializable

serialVersionUID: 4290774380558885855L

Serialized Fields

value

long value
The value of the Long.

Class java.lang.NegativeArraySizeException extends RuntimeException implements Serializable

serialVersionUID: -8960118058596991861L

Class java.lang.NoClassDefFoundError extends LinkageError implements Serializable

serialVersionUID: 9095859863287012458L

Class java.lang.NoSuchFieldError extends IncompatibleClassChangeError implements Serializable

serialVersionUID: -3456430195886129035L

Class java.lang.NoSuchFieldException extends Exception implements Serializable

serialVersionUID: -6143714805279938260L

Class java.lang.NoSuchMethodError extends IncompatibleClassChangeError implements Serializable

serialVersionUID: -3765521442372831335L

Class java.lang.NoSuchMethodException extends Exception implements Serializable

serialVersionUID: 5034388446362600923L

Class java.lang.NullPointerException extends RuntimeException implements Serializable

serialVersionUID: 5162710183389028792L

Class java.lang.Number extends Object implements Serializable

serialVersionUID: -8742448824652078965L

Class java.lang.NumberFormatException extends IllegalArgumentException implements Serializable

serialVersionUID: -2848938806368998894L

Class java.lang.OutOfMemoryError extends VirtualMachineError implements Serializable

serialVersionUID: 8228564086184010517L

Class java.lang.RuntimeException extends Exception implements Serializable

serialVersionUID: -7034897190745766939L

Class java.lang.RuntimePermission extends BasicPermission implements Serializable

serialVersionUID: 7399184964622342223L

Class java.lang.SecurityException extends RuntimeException implements Serializable

serialVersionUID: 6878364983674394167L

Class java.lang.Short extends Number implements Serializable

serialVersionUID: 7515723908773894738L

Serialized Fields

value

short value
The value of the Short.

Class java.lang.StackOverflowError extends VirtualMachineError implements Serializable

serialVersionUID: 8609175038441759607L

Class java.lang.StackTraceElement extends Object implements Serializable

serialVersionUID: 6992337162326171013L

Serialized Fields

declaringClass

String declaringClass

methodName

String methodName

fileName

String fileName

lineNumber

int lineNumber

Class java.lang.String extends Object implements Serializable

serialVersionUID: -6849794470754667710L

Serialization Overview
Class String is special cased within the Serialization Stream Protocol. A String instance is written initially into an ObjectOutputStream in the following format:
      TC_STRING (utf String)
The String is written by method DataOutput.writeUTF. A new handle is generated to refer to all future references to the string instance within the stream.

Serialized Fields

Class java.lang.StringBuffer extends java.lang.AbstractStringBuilder implements Serializable

serialVersionUID: 3388685877147921107L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
readObject is called to restore the state of the StringBuffer from a stream.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
readObject is called to restore the state of the StringBuffer from a stream.

Throws:
IOException
Serialization Overview
Serializable fields for StringBuffer.

Serialized Fields

count

int count
The number of characters in this StringBuffer.

shared

boolean shared
A flag indicating whether the backing array is shared. The value is ignored upon deserialization.

value

char[] value
The backing character array of this StringBuffer.

Class java.lang.StringBuilder extends java.lang.AbstractStringBuilder implements Serializable

serialVersionUID: 4383685877147921099L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
readObject is called to restore the state of the StringBuffer from a stream.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Save the state of the StringBuilder instance to a stream (that is, serialize it).

Serial Data:
the number of characters currently stored in the string builder (int), followed by the characters in the string builder (char[]). The length of the char array may be greater than the number of characters currently stored in the string builder, in which case extra characters are ignored.
Throws:
IOException

Class java.lang.StringIndexOutOfBoundsException extends IndexOutOfBoundsException implements Serializable

serialVersionUID: -6762910422159637258L

Class java.lang.ThreadDeath extends Error implements Serializable

serialVersionUID: -4417128565033088268L

Class java.lang.Throwable extends Object implements Serializable

serialVersionUID: -3042686055658047285L

Serialization Methods

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Throws:
IOException
Serialized Fields

detailMessage

String detailMessage
Specific details about the Throwable. For example, for FileNotFoundException, this contains the name of the file that could not be found.

cause

Throwable cause
The throwable that caused this throwable to get thrown, or null if this throwable was not caused by another throwable, or if the causative throwable is unknown. If this field is equal to this throwable itself, it indicates that the cause of this throwable has not yet been initialized.

Since:
1.4

stackTrace

StackTraceElement[] stackTrace
The stack trace, as returned by Throwable.getStackTrace().

Since:
1.4

Class java.lang.TypeNotPresentException extends RuntimeException implements Serializable

serialVersionUID: -5101214195716534496L

Serialized Fields

typeName

String typeName

Class java.lang.UnknownError extends VirtualMachineError implements Serializable

serialVersionUID: 2524784860676771849L

Class java.lang.UnsatisfiedLinkError extends LinkageError implements Serializable

serialVersionUID: -4019343241616879428L

Class java.lang.UnsupportedClassVersionError extends ClassFormatError implements Serializable

serialVersionUID: -7123279212883497373L

Class java.lang.UnsupportedOperationException extends RuntimeException implements Serializable

serialVersionUID: -1242599979055084673L

Class java.lang.VerifyError extends LinkageError implements Serializable

serialVersionUID: 7001962396098498785L

Class java.lang.VirtualMachineError extends Error implements Serializable

Package java.lang.annotation

Class java.lang.annotation.AnnotationFormatError extends Error implements Serializable

serialVersionUID: -4256701562333669892L

Class java.lang.annotation.AnnotationTypeMismatchException extends RuntimeException implements Serializable

serialVersionUID: 8125925355765570191L

Serialized Fields

element

Method element
The Method object for the annotation element.

foundType

String foundType
The (erroneous) type of data found in the annotation. This string may, but is not required to, contain the value as well. The exact format of the string is unspecified.

Class java.lang.annotation.IncompleteAnnotationException extends RuntimeException implements Serializable

serialVersionUID: 8445097402741811912L

Serialized Fields

annotationType

Class<T> annotationType

elementName

String elementName
Package java.lang.instrument

Class java.lang.instrument.IllegalClassFormatException extends Exception implements Serializable

serialVersionUID: -3841736710924794009L

Class java.lang.instrument.UnmodifiableClassException extends Exception implements Serializable

serialVersionUID: 1716652643585309178L

Package java.lang.management

Class java.lang.management.ManagementPermission extends BasicPermission implements Serializable

serialVersionUID: 1897496590799378737L

Package java.lang.reflect

Class java.lang.reflect.GenericSignatureFormatError extends ClassFormatError implements Serializable

serialVersionUID: 6709919147137911034L

Class java.lang.reflect.InvocationTargetException extends Exception implements Serializable

serialVersionUID: 4085088731926701167L

Serialized Fields

target

Throwable target
This field holds the target if the InvocationTargetException(Throwable target) constructor was used to instantiate the object

Class java.lang.reflect.MalformedParameterizedTypeException extends RuntimeException implements Serializable

serialVersionUID: -5696557788586220964L

Class java.lang.reflect.Proxy extends Object implements Serializable

serialVersionUID: -2222568056686623797L

Serialized Fields

h

InvocationHandler h
the invocation handler for this proxy instance.

Class java.lang.reflect.ReflectPermission extends BasicPermission implements Serializable

serialVersionUID: 7412737110241507485L

Class java.lang.reflect.UndeclaredThrowableException extends RuntimeException implements Serializable

serialVersionUID: 330127114055056639L

Serialized Fields

undeclaredThrowable

Throwable undeclaredThrowable
the undeclared checked exception that was thrown

Package java.math

Class java.math.BigDecimal extends Number implements Serializable

serialVersionUID: 6108874887143696463L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reconstitute the BigDecimal instance from a stream (that is, deserialize it).

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Serialize this BigDecimal to the stream in question

Throws:
IOException
Serialized Fields

intVal

BigInteger intVal
The unscaled value of this BigDecimal, as returned by BigDecimal.unscaledValue().

See Also:
BigDecimal.unscaledValue()

scale

int scale
The scale of this BigDecimal, as returned by BigDecimal.scale.

See Also:
BigDecimal.scale

Class java.math.BigInteger extends Number implements Serializable

serialVersionUID: -8287574255936472291L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reconstitute the BigInteger instance from a stream (that is, deserialize it). The magnitude is read in as an array of bytes for historical reasons, but it is converted to an array of ints and the byte array is discarded.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Save the BigInteger instance to a stream. The magnitude of a BigInteger is serialized as a byte array for historical reasons.

Serial Data:
two necessary fields are written as well as obsolete fields for compatibility with older versions.
Throws:
IOException
Serialization Overview
Serializable fields for BigInteger.

Serialized Fields

bitCount

int bitCount
number of bits in this BigInteger

bitLength

int bitLength
the number of bits in the minimal two's-complement representation of this BigInteger

lowestSetBit

int lowestSetBit
lowest set bit in the twos complement representation

magnitude

int[] magnitude
magnitude array of this BigInteger.

signum

int signum
signum of this BigInteger.

Class java.math.MathContext extends Object implements Serializable

serialVersionUID: 5579720004786848255L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reconstitute the MathContext instance from a stream (that is, deserialize it).

Throws:
IOException
ClassNotFoundException
Serialized Fields

precision

int precision
The number of digits to be used for an operation. A value of 0 indicates that unlimited precision (as many digits as are required) will be used. Note that leading zeros (in the coefficient of a number) are never significant.

precision will always be non-negative.

roundingMode

RoundingMode roundingMode
The rounding algorithm to be used for an operation.

See Also:
RoundingMode
Package java.net

Class java.net.BindException extends SocketException implements Serializable

serialVersionUID: -5945005768251722951L

Class java.net.ConnectException extends SocketException implements Serializable

serialVersionUID: 3831404271622369215L

Class java.net.HttpRetryException extends IOException implements Serializable

serialVersionUID: -9186022286469111381L

Serialized Fields

responseCode

int responseCode

location

String location

Class java.net.Inet4Address extends InetAddress implements Serializable

serialVersionUID: 3286316764910316507L

Serialization Methods

writeReplace

private Object writeReplace()
                     throws ObjectStreamException
Replaces the object to be serialized with an InetAddress object.

Throws:
ObjectStreamException - if a new object replacing this object could not be created

Class java.net.Inet6Address extends InetAddress implements Serializable

serialVersionUID: 6880410070516793377L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
restore the state of this object from stream including the scope information, only if the scoped interface name is valid on this system

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
default behavior is overridden in order to write the scope_ifname field as a String, rather than a NetworkInterface which is not serializable

Throws:
IOException
Serialized Fields

ipaddress

byte[] ipaddress
Holds a 128-bit (16 bytes) IPv6 address.

scope_id

int scope_id
scope_id. The scope specified when the object is created. If the object is created with an interface name, then the scope_id is not determined until the time it is needed.

scope_id_set

boolean scope_id_set
This will be set to true when the scope_id field contains a valid integer scope_id.

scope_ifname_set

boolean scope_ifname_set
set if the object is constructed with a scoped interface instead of a numeric scope id.

ifname

String ifname
Following field is only used during (de)/serialization

Class java.net.InetAddress extends Object implements Serializable

serialVersionUID: 3286316764910316507L

Serialization Methods

readResolve

private Object readResolve()
                    throws ObjectStreamException
Replaces the de-serialized object with an Inet4Address object.

Throws:
ObjectStreamException - if a new object replacing this object could not be created
Serialized Fields

hostName

String hostName

address

int address
Holds a 32-bit IPv4 address.

family

int family
Specifies the address family type, for instance, '1' for IPv4 addresses, and '2' for IPv6 addresses.

Class java.net.InetSocketAddress extends SocketAddress implements Serializable

serialVersionUID: 5076001401234631237L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Throws:
IOException
ClassNotFoundException
Serialized Fields

hostname

String hostname

addr

InetAddress addr

port

int port

Class java.net.MalformedURLException extends IOException implements Serializable

serialVersionUID: -182787522200415866L

Class java.net.NetPermission extends BasicPermission implements Serializable

serialVersionUID: -8343910153355041693L

Class java.net.NoRouteToHostException extends SocketException implements Serializable

serialVersionUID: -1897550894873493790L

Class java.net.PortUnreachableException extends SocketException implements Serializable

serialVersionUID: 8462541992376507323L

Class java.net.ProtocolException extends IOException implements Serializable

serialVersionUID: -6098449442062388080L

Class java.net.SocketAddress extends Object implements Serializable

Class java.net.SocketException extends IOException implements Serializable

serialVersionUID: -5935874303556886934L

Class java.net.SocketPermissionCollection extends PermissionCollection implements Serializable

serialVersionUID: 2787186408602843674L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serial Data:
"permissions" field (a Vector containing the SocketPermissions).
Throws:
IOException
Serialized Fields

permissions

Vector<E> permissions
A list of the SocketPermissions for this set.

Class java.net.SocketTimeoutException extends InterruptedIOException implements Serializable

serialVersionUID: -8846654841826352300L

Class java.net.UnknownHostException extends IOException implements Serializable

serialVersionUID: -4639126076052875403L

Class java.net.UnknownServiceException extends IOException implements Serializable

serialVersionUID: -4169033248853639508L

Class java.net.URI extends Object implements Serializable

serialVersionUID: -6052424284110960213L

Serialization Methods

readObject

private void readObject(ObjectInputStream is)
                 throws ClassNotFoundException,
                        IOException
Reconstitutes a URI from the given serial stream.

The ObjectInputStream.defaultReadObject() method is invoked to read the value of the string field. The result is then parsed in the usual way.

Throws:
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream os)
                  throws IOException
Saves the content of this URI to the given serial stream.

The only serializable field of a URI instance is its string field. That field is given a value, if it does not have one already, and then the ObjectOutputStream.defaultWriteObject() method of the given object-output stream is invoked.

Throws:
IOException
Serialized Fields

string

String string
The string form of this URI.

Class java.net.URISyntaxException extends Exception implements Serializable

serialVersionUID: 2137979680897488891L

Serialized Fields

input

String input

index

int index

Class java.net.URL extends Object implements Serializable

serialVersionUID: -7627629688361524110L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
readObject is called to restore the state of the URL from the stream. It reads the components of the URL and finds the local stream handler.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
WriteObject is called to save the state of the URL to an ObjectOutputStream. The handler is not saved since it is specific to this system.

Serial Data:
the default write object value. When read back in, the reader must ensure that calling getURLStreamHandler with the protocol variable returns a valid URLStreamHandler and throw an IOException if it does not.
Throws:
IOException
Serialized Fields

protocol

String protocol
The protocol to use (ftp, http, nntp, ... etc.) .

host

String host
The host name to connect to.

port

int port
The protocol port to connect to.

file

String file
The specified file name on that host. file is defined as path[?query]

authority

String authority
The authority part of this URL.

ref

String ref
# reference.

hashCode

int hashCode
Package java.nio

Class java.nio.BufferOverflowException extends RuntimeException implements Serializable

serialVersionUID: -5484897634319144535L

Class java.nio.BufferUnderflowException extends RuntimeException implements Serializable

serialVersionUID: -1713313658691622206L

Class java.nio.InvalidMarkException extends IllegalStateException implements Serializable

serialVersionUID: 1698329710438510774L

Class java.nio.ReadOnlyBufferException extends UnsupportedOperationException implements Serializable

serialVersionUID: -1210063976496234090L

Package java.nio.channels

Class java.nio.channels.AcceptPendingException extends IllegalStateException implements Serializable

serialVersionUID: 2721339977965416421L

Class java.nio.channels.AlreadyBoundException extends IllegalStateException implements Serializable

serialVersionUID: 6796072983322737592L

Class java.nio.channels.AlreadyConnectedException extends IllegalStateException implements Serializable

serialVersionUID: -7331895245053773357L

Class java.nio.channels.AsynchronousCloseException extends ClosedChannelException implements Serializable

serialVersionUID: 6891178312432313966L

Class java.nio.channels.CancelledKeyException extends IllegalStateException implements Serializable

serialVersionUID: -8438032138028814268L

Class java.nio.channels.ClosedByInterruptException extends AsynchronousCloseException implements Serializable

serialVersionUID: -4488191543534286750L

Class java.nio.channels.ClosedChannelException extends IOException implements Serializable

serialVersionUID: 882777185433553857L

Class java.nio.channels.ClosedSelectorException extends IllegalStateException implements Serializable

serialVersionUID: 6466297122317847835L

Class java.nio.channels.ConnectionPendingException extends IllegalStateException implements Serializable

serialVersionUID: 2008393366501760879L

Class java.nio.channels.FileLockInterruptionException extends IOException implements Serializable

serialVersionUID: 7104080643653532383L

Class java.nio.channels.IllegalBlockingModeException extends IllegalStateException implements Serializable

serialVersionUID: -3335774961855590474L

Class java.nio.channels.IllegalChannelGroupException extends IllegalArgumentException implements Serializable

serialVersionUID: -2495041211157744253L

Class java.nio.channels.IllegalSelectorException extends IllegalArgumentException implements Serializable

serialVersionUID: -8406323347253320987L

Class java.nio.channels.InterruptedByTimeoutException extends IOException implements Serializable

serialVersionUID: -4268008601014042947L

Class java.nio.channels.NoConnectionPendingException extends IllegalStateException implements Serializable

serialVersionUID: -8296561183633134743L

Class java.nio.channels.NonReadableChannelException extends IllegalStateException implements Serializable

serialVersionUID: -3200915679294993514L

Class java.nio.channels.NonWritableChannelException extends IllegalStateException implements Serializable

serialVersionUID: -7071230488279011621L

Class java.nio.channels.NotYetBoundException extends IllegalStateException implements Serializable

serialVersionUID: 4640999303950202242L

Class java.nio.channels.NotYetConnectedException extends IllegalStateException implements Serializable

serialVersionUID: 4697316551909513464L

Class java.nio.channels.OverlappingFileLockException extends IllegalStateException implements Serializable

serialVersionUID: 2047812138163068433L

Class java.nio.channels.ReadPendingException extends IllegalStateException implements Serializable

serialVersionUID: 1986315242191227217L

Class java.nio.channels.ShutdownChannelGroupException extends IllegalStateException implements Serializable

serialVersionUID: -3903801676350154157L

Class java.nio.channels.UnresolvedAddressException extends IllegalArgumentException implements Serializable

serialVersionUID: 6136959093620794148L

Class java.nio.channels.UnsupportedAddressTypeException extends IllegalArgumentException implements Serializable

serialVersionUID: -2964323842829700493L

Class java.nio.channels.WritePendingException extends IllegalStateException implements Serializable

serialVersionUID: 7031871839266032276L

Package java.nio.charset

Class java.nio.charset.CharacterCodingException extends IOException implements Serializable

serialVersionUID: 8421532232154627783L

Class java.nio.charset.CoderMalfunctionError extends Error implements Serializable

serialVersionUID: -1151412348057794301L

Class java.nio.charset.IllegalCharsetNameException extends IllegalArgumentException implements Serializable

serialVersionUID: 1457525358470002989L

Serialized Fields

charsetName

String charsetName

Class java.nio.charset.MalformedInputException extends CharacterCodingException implements Serializable

serialVersionUID: -3438823399834806194L

Serialized Fields

inputLength

int inputLength

Class java.nio.charset.UnmappableCharacterException extends CharacterCodingException implements Serializable

serialVersionUID: -7026962371537706123L

Serialized Fields

inputLength

int inputLength

Class java.nio.charset.UnsupportedCharsetException extends IllegalArgumentException implements Serializable

serialVersionUID: 1490765524727386367L

Serialized Fields

charsetName

String charsetName
Package java.nio.file

Class java.nio.file.AccessDeniedException extends FileSystemException implements Serializable

serialVersionUID: 4943049599949219617L

Class java.nio.file.AtomicMoveNotSupportedException extends FileSystemException implements Serializable

serialVersionUID: 5402760225333135579L

Class java.nio.file.ClosedDirectoryStreamException extends IllegalStateException implements Serializable

serialVersionUID: 4228386650900895400L

Class java.nio.file.ClosedFileSystemException extends IllegalStateException implements Serializable

serialVersionUID: -8158336077256193488L

Class java.nio.file.ClosedWatchServiceException extends IllegalStateException implements Serializable

serialVersionUID: 1853336266231677732L

Class java.nio.file.DirectoryNotEmptyException extends FileSystemException implements Serializable

serialVersionUID: 3056667871802779003L

Class java.nio.file.FileAlreadyExistsException extends FileSystemException implements Serializable

serialVersionUID: 7579540934498831181L

Class java.nio.file.FileSystemAlreadyExistsException extends RuntimeException implements Serializable

serialVersionUID: -5438419127181131148L

Class java.nio.file.FileSystemException extends IOException implements Serializable

serialVersionUID: -3055425747967319812L

Serialized Fields

file

String file

other

String other

Class java.nio.file.FileSystemNotFoundException extends RuntimeException implements Serializable

serialVersionUID: 7999581764446402397L

Class java.nio.file.InvalidPathException extends IllegalArgumentException implements Serializable

serialVersionUID: 4355821422286746137L

Serialized Fields

input

String input

index

int index

Class java.nio.file.LinkPermission extends BasicPermission implements Serializable

serialVersionUID: -1441492453772213220L

Class java.nio.file.NoSuchFileException extends FileSystemException implements Serializable

serialVersionUID: -1390291775875351931L

Class java.nio.file.NotDirectoryException extends FileSystemException implements Serializable

serialVersionUID: -9011457427178200199L

Class java.nio.file.NotLinkException extends FileSystemException implements Serializable

serialVersionUID: -388655596416518021L

Class java.nio.file.ProviderMismatchException extends IllegalArgumentException implements Serializable

serialVersionUID: 4990847485741612530L

Class java.nio.file.ProviderNotFoundException extends RuntimeException implements Serializable

serialVersionUID: -1880012509822920354L

Class java.nio.file.ReadOnlyFileSystemException extends UnsupportedOperationException implements Serializable

serialVersionUID: -6822409595617487197L

Package java.nio.file.attribute

Class java.nio.file.attribute.UserPrincipalNotFoundException extends IOException implements Serializable

serialVersionUID: -5369283889045833024L

Serialized Fields

name

String name
Package java.rmi

Class java.rmi.AccessException extends RemoteException implements Serializable

serialVersionUID: 6314925228044966088L

Class java.rmi.AlreadyBoundException extends Exception implements Serializable

serialVersionUID: 9218657361741657110L

Class java.rmi.ConnectException extends RemoteException implements Serializable

serialVersionUID: 4863550261346652506L

Class java.rmi.ConnectIOException extends RemoteException implements Serializable

serialVersionUID: -8087809532704668744L

Class java.rmi.MarshalException extends RemoteException implements Serializable

serialVersionUID: 6223554758134037936L

Class java.rmi.MarshalledObject extends Object implements Serializable

serialVersionUID: 8988374069173025854L

Serialized Fields

objBytes

byte[] objBytes
Bytes of serialized representation. If objBytes is null then the object marshalled was a null reference.

locBytes

byte[] locBytes
Bytes of location annotations, which are ignored by equals. If locBytes is null, there were no non-null annotations during marshalling.

hash

int hash
Stored hash code of contained object.
See Also:
MarshalledObject.hashCode()

Class java.rmi.NoSuchObjectException extends RemoteException implements Serializable

serialVersionUID: 6619395951570472985L

Class java.rmi.NotBoundException extends Exception implements Serializable

serialVersionUID: -1857741824849069317L

Class java.rmi.RemoteException extends IOException implements Serializable

serialVersionUID: -5148567311918794206L

Serialized Fields

detail

Throwable detail
The cause of the remote exception.

This field predates the general-purpose exception chaining facility. The Throwable.getCause() method is now the preferred means of obtaining this information.

Class java.rmi.RMISecurityException extends SecurityException implements Serializable

serialVersionUID: -8433406075740433514L

Class java.rmi.ServerError extends RemoteException implements Serializable

serialVersionUID: 8455284893909696482L

Class java.rmi.ServerException extends RemoteException implements Serializable

serialVersionUID: -4775845313121906682L

Class java.rmi.ServerRuntimeException extends RemoteException implements Serializable

serialVersionUID: 7054464920481467219L

Class java.rmi.StubNotFoundException extends RemoteException implements Serializable

serialVersionUID: -7088199405468872373L

Class java.rmi.UnexpectedException extends RemoteException implements Serializable

serialVersionUID: 1800467484195073863L

Class java.rmi.UnknownHostException extends RemoteException implements Serializable

serialVersionUID: -8152710247442114228L

Class java.rmi.UnmarshalException extends RemoteException implements Serializable

serialVersionUID: 594380845140740218L

Package java.rmi.activation

Class java.rmi.activation.ActivateFailedException extends RemoteException implements Serializable

serialVersionUID: 4863550261346652506L

Class java.rmi.activation.ActivationDesc extends Object implements Serializable

serialVersionUID: 7455834104417690957L

Serialized Fields

groupID

ActivationGroupID groupID
the group's identifier

className

String className
the object's class name

location

String location
the object's code location

data

MarshalledObject<T> data
the object's initialization data

restart

boolean restart
indicates whether the object should be restarted

Class java.rmi.activation.ActivationException extends Exception implements Serializable

serialVersionUID: -4320118837291406071L

Serialized Fields

detail

Throwable detail
The cause of the activation exception.

This field predates the general-purpose exception chaining facility. The Throwable.getCause() method is now the preferred means of obtaining this information.

Class java.rmi.activation.ActivationGroup extends UnicastRemoteObject implements Serializable

serialVersionUID: -7696947875314805420L

Serialized Fields

groupID

ActivationGroupID groupID
the group's identifier

monitor

ActivationMonitor monitor
the group's monitor

incarnation

long incarnation
the group's incarnation number

Class java.rmi.activation.ActivationGroup_Stub extends RemoteStub implements Serializable

Class java.rmi.activation.ActivationGroupDesc extends Object implements Serializable

serialVersionUID: -4936225423168276595L

Serialized Fields

className

String className
The group's fully package qualified class name.

location

String location
The location from where to load the group's class.

data

MarshalledObject<T> data
The group's initialization data.

env

ActivationGroupDesc.CommandEnvironment env
The controlling options for executing the VM in another process.

props

Properties props
A properties map which will override those set by default in the subprocess environment.

Class java.rmi.activation.ActivationGroupDesc.CommandEnvironment extends Object implements Serializable

serialVersionUID: 6165754737887770191L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
readObject for custom serialization.

This method reads this object's serialized form for this class as follows:

This method first invokes defaultReadObject on the specified object input stream, and if options is null, then options is set to a zero-length array of String.

Throws:
IOException
ClassNotFoundException
Serialized Fields

command

String command

options

String[] options

Class java.rmi.activation.ActivationGroupID extends Object implements Serializable

serialVersionUID: -1648432278909740833L

Serialized Fields

system

ActivationSystem system
The group's activation system.

uid

UID uid
The group's unique id.

Class java.rmi.activation.ActivationID extends Object implements Serializable

serialVersionUID: -4608673054848209235L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
readObject for custom serialization.

This method reads this object's serialized form for this class as follows:

The readObject method is invoked on in to read this object's unique identifier (a UID instance).

Next, the readUTF method is invoked on in to read the external ref type name of the RemoteRef instance for this object's activator. Next, the RemoteRef instance is created of an implementation-specific class corresponding to the external ref type name (returned by readUTF), and the readExternal method is invoked on that RemoteRef instance to read the external form corresponding to the external ref type name.

Note: If the external ref type name is "UnicastRef", "UnicastServerRef", "UnicastRef2", "UnicastServerRef2", or "ActivatableRef", a corresponding implementation-specific class must be found, and its readExternal method must read the serial data for that external ref type name as specified to be written in the serialData documentation for this class. If the external ref type name is any other string (of non-zero length), a ClassNotFoundException will be thrown, unless the implementation provides an implementation-specific class corresponding to that external ref type name, in which case the RemoteRef will be an instance of that implementation-specific class.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException,
                         ClassNotFoundException
writeObject for custom serialization.

This method writes this object's serialized form for this class as follows:

The writeObject method is invoked on out passing this object's unique identifier (a UID instance) as the argument.

Next, the getRefClass method is invoked on the activator's RemoteRef instance to obtain its external ref type name. Next, the writeUTF method is invoked on out with the value returned by getRefClass, and then the writeExternal method is invoked on the RemoteRef instance passing out as the argument.

Serial Data:
The serialized data for this class comprises a java.rmi.server.UID (written with ObjectOutput.writeObject) followed by the external ref type name of the activator's RemoteRef instance (a string written with ObjectOutput.writeUTF), followed by the external form of the RemoteRef instance as written by its writeExternal method.

The external ref type name of the RemoteRef instance is determined using the definitions of external ref type names specified in the RemoteObject writeObject method serialData specification. Similarly, the data written by the writeExternal method and read by the readExternal method of RemoteRef implementation classes corresponding to each of the defined external ref type names is specified in the RemoteObject writeObject method serialData specification.

Throws:
IOException
ClassNotFoundException

Class java.rmi.activation.UnknownGroupException extends ActivationException implements Serializable

serialVersionUID: 7056094974750002460L

Class java.rmi.activation.UnknownObjectException extends ActivationException implements Serializable

serialVersionUID: 3425547551622251430L

Package java.rmi.dgc

Class java.rmi.dgc.Lease extends Object implements Serializable

serialVersionUID: -5713411624328831948L

Serialized Fields

vmid

VMID vmid
Virtual Machine ID with which this Lease is associated.
See Also:
Lease.getVMID()

value

long value
Duration of this lease.
See Also:
Lease.getValue()

Class java.rmi.dgc.VMID extends Object implements Serializable

serialVersionUID: -538642295484486218L

Serialized Fields

addr

byte[] addr
array of bytes uniquely identifying host created on

uid

UID uid
unique identifier with respect to host created on
Package java.rmi.server

Class java.rmi.server.ExportException extends RemoteException implements Serializable

serialVersionUID: -9155485338494060170L

Class java.rmi.server.ObjID extends Object implements Serializable

serialVersionUID: -6386392263968365220L

Serialized Fields

objNum

long objNum
object number
See Also:
ObjID.hashCode()

space

UID space
address space identifier (unique to host over time)

Class java.rmi.server.RemoteObject extends Object implements Serializable

serialVersionUID: -3215090123894869218L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
readObject for custom serialization.

This method reads this object's serialized form for this class as follows:

The readUTF method is invoked on in to read the external ref type name for the RemoteRef instance to be filled in to this object's ref field. If the string returned by readUTF has length zero, the readObject method is invoked on in, and than the value returned by readObject is cast to RemoteRef and this object's ref field is set to that value. Otherwise, this object's ref field is set to a RemoteRef instance that is created of an implementation-specific class corresponding to the external ref type name returned by readUTF, and then the readExternal method is invoked on this object's ref field.

If the external ref type name is "UnicastRef", "UnicastServerRef", "UnicastRef2", "UnicastServerRef2", or "ActivatableRef", a corresponding implementation-specific class must be found, and its readExternal method must read the serial data for that external ref type name as specified to be written in the serialData documentation for this class. If the external ref type name is any other string (of non-zero length), a ClassNotFoundException will be thrown, unless the implementation provides an implementation-specific class corresponding to that external ref type name, in which case this object's ref field will be set to an instance of that implementation-specific class.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException,
                         ClassNotFoundException
writeObject for custom serialization.

This method writes this object's serialized form for this class as follows:

The getRefClass method is invoked on this object's ref field to obtain its external ref type name. If the value returned by getRefClass was a non-null string of length greater than zero, the writeUTF method is invoked on out with the value returned by getRefClass, and then the writeExternal method is invoked on this object's ref field passing out as the argument; otherwise, the writeUTF method is invoked on out with a zero-length string (""), and then the writeObject method is invoked on out passing this object's ref field as the argument.

Serial Data:
The serialized data for this class comprises a string (written with ObjectOutput.writeUTF) that is either the external ref type name of the contained RemoteRef instance (the ref field) or a zero-length string, followed by either the external form of the ref field as written by its writeExternal method if the string was of non-zero length, or the serialized form of the ref field as written by passing it to the serialization stream's writeObject if the string was of zero length.

If this object is an instance of RemoteStub or RemoteObjectInvocationHandler that was returned from any of the UnicastRemoteObject.exportObject methods and custom socket factories are not used, the external ref type name is "UnicastRef". If this object is an instance of RemoteStub or RemoteObjectInvocationHandler that was returned from any of the UnicastRemoteObject.exportObject methods and custom socket factories are used, the external ref type name is "UnicastRef2". If this object is an instance of RemoteStub or RemoteObjectInvocationHandler that was returned from any of the java.rmi.activation.Activatable.exportObject methods, the external ref type name is "ActivatableRef". If this object is an instance of RemoteStub or RemoteObjectInvocationHandler that was returned from the RemoteObject.toStub method (and the argument passed to toStub was not itself a RemoteStub), the external ref type name is a function of how the remote object passed to toStub was exported, as described above. If this object is an instance of RemoteStub or RemoteObjectInvocationHandler that was originally created via deserialization, the external ref type name is the same as that which was read when this object was deserialized.

If this object is an instance of java.rmi.server.UnicastRemoteObject that does not use custom socket factories, the external ref type name is "UnicastServerRef". If this object is an instance of UnicastRemoteObject that does use custom socket factories, the external ref type name is "UnicastServerRef2".

Following is the data that must be written by the writeExternal method and read by the readExternal method of RemoteRef implementation classes that correspond to the each of the defined external ref type names:

For "UnicastRef":

  • the hostname of the referenced remote object, written by DataOutput.writeUTF(String)
  • the port of the referenced remote object, written by DataOutput.writeInt(int)
  • the data written as a result of calling {link java.rmi.server.ObjID#write(java.io.ObjectOutput)} on the ObjID instance contained in the reference
  • the boolean value false, written by DataOutput.writeBoolean(boolean)

For "UnicastRef2" with a null client socket factory:

  • the byte value 0x00 (indicating null client socket factory), written by DataOutput.writeByte(int)
  • the hostname of the referenced remote object, written by DataOutput.writeUTF(String)
  • the port of the referenced remote object, written by DataOutput.writeInt(int)
  • the data written as a result of calling {link java.rmi.server.ObjID#write(java.io.ObjectOutput)} on the ObjID instance contained in the reference
  • the boolean value false, written by DataOutput.writeBoolean(boolean)

For "UnicastRef2" with a non-null client socket factory:

  • the byte value 0x01 (indicating non-null client socket factory), written by DataOutput.writeByte(int)
  • the hostname of the referenced remote object, written by DataOutput.writeUTF(String)
  • the port of the referenced remote object, written by DataOutput.writeInt(int)
  • a client socket factory (object of type java.rmi.server.RMIClientSocketFactory), written by passing it to an invocation of writeObject on the stream instance
  • the data written as a result of calling {link java.rmi.server.ObjID#write(java.io.ObjectOutput)} on the ObjID instance contained in the reference
  • the boolean value false, written by DataOutput.writeBoolean(boolean)

For "ActivatableRef" with a null nested remote reference:

  • an instance of java.rmi.activation.ActivationID, written by passing it to an invocation of writeObject on the stream instance
  • a zero-length string (""), written by DataOutput.writeUTF(String)

For "ActivatableRef" with a non-null nested remote reference:

  • an instance of java.rmi.activation.ActivationID, written by passing it to an invocation of writeObject on the stream instance
  • the external ref type name of the nested remote reference, which must be "UnicastRef2", written by DataOutput.writeUTF(String)
  • the external form of the nested remote reference, written by invoking its writeExternal method with the stream instance (see the description of the external form for "UnicastRef2" above)

For "UnicastServerRef" and "UnicastServerRef2", no data is written by the writeExternal method or read by the readExternal method.

Throws:
IOException
ClassNotFoundException

Class java.rmi.server.RemoteObjectInvocationHandler extends RemoteObject implements Serializable

serialVersionUID: 2L

Serialization Methods

readObjectNoData

private void readObjectNoData()
                       throws InvalidObjectException
Throws:
InvalidObjectException - unconditionally

Class java.rmi.server.RemoteServer extends RemoteObject implements Serializable

serialVersionUID: -4100238210092549637L

Class java.rmi.server.RemoteStub extends RemoteObject implements Serializable

serialVersionUID: -1585587260594494182L

Class java.rmi.server.ServerCloneException extends CloneNotSupportedException implements Serializable

serialVersionUID: 6617456357664815945L

Serialized Fields

detail

Exception detail
The cause of the exception.

This field predates the general-purpose exception chaining facility. The Throwable.getCause() method is now the preferred means of obtaining this information.

Class java.rmi.server.ServerNotActiveException extends Exception implements Serializable

serialVersionUID: 4687940720827538231L

Class java.rmi.server.SkeletonMismatchException extends RemoteException implements Serializable

serialVersionUID: -7780460454818859281L

Class java.rmi.server.SkeletonNotFoundException extends RemoteException implements Serializable

serialVersionUID: -7860299673822761231L

Class java.rmi.server.SocketSecurityException extends ExportException implements Serializable

serialVersionUID: -7622072999407781979L

Class java.rmi.server.UID extends Object implements Serializable

serialVersionUID: 1086053664494604050L

Serialized Fields

unique

int unique
number that uniquely identifies the VM that this UID was generated in with respect to its host and at the given time

time

long time
a time (as returned by System.currentTimeMillis()) at which the VM that this UID was generated in was alive

count

short count
16-bit number to distinguish UID instances created in the same VM with the same time value

Class java.rmi.server.UnicastRemoteObject extends RemoteServer implements Serializable

serialVersionUID: 4974527148936298033L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Re-export the remote object when it is deserialized.

Throws:
IOException
ClassNotFoundException
Serialized Fields

port

int port
port number on which to export object

csf

RMIClientSocketFactory csf
client-side socket factory (if any)

ssf

RMIServerSocketFactory ssf
server-side socket factory (if any) to use when exporting object
Package java.security

Class java.security.AccessControlException extends SecurityException implements Serializable

serialVersionUID: 5138225684096988535L

Serialized Fields

perm

Permission perm

Class java.security.AllPermissionCollection extends PermissionCollection implements Serializable

serialVersionUID: -4023755556366636806L

Serialized Fields

all_allowed

boolean all_allowed

Class java.security.AuthProvider extends Provider implements Serializable

Class java.security.BasicPermission extends Permission implements Serializable

serialVersionUID: 6279438298436773498L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
readObject is called to restore the state of the BasicPermission from a stream.

Throws:
IOException
ClassNotFoundException

Class java.security.BasicPermissionCollection extends PermissionCollection implements Serializable

serialVersionUID: 739301742472979399L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
readObject is called to restore the state of the BasicPermissionCollection from a stream.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serial Data:
Default fields.
Throws:
IOException
Serialized Fields

all_allowed

boolean all_allowed
This is set to true if this BasicPermissionCollection contains a BasicPermission with '*' as its permission name.

permClass

Class<T> permClass
The class to which all BasicPermissions in this BasicPermissionCollection belongs.

permissions

Hashtable<K,V> permissions
The BasicPermissions in this BasicPermissionCollection. All BasicPermissions in the collection must belong to the same class. The Hashtable is indexed by the BasicPermission name; the value of the Hashtable entry is the permission.

Class java.security.CodeSigner extends Object implements Serializable

serialVersionUID: 6819288105193937581L

Serialized Fields

signerCertPath

CertPath signerCertPath
The signer's certificate path.

timestamp

Timestamp timestamp

Class java.security.CodeSource extends Object implements Serializable

serialVersionUID: 4977541819976013951L

Serialization Methods

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
Restores this object from a stream (i.e., deserializes it).

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
Writes this object out to a stream (i.e., serializes it).

Serial Data:
An initial URL is followed by an int indicating the number of certificates to follow (a value of "zero" denotes that there are no certificates associated with this object). Each certificate is written out starting with a String denoting the certificate type, followed by an int specifying the length of the certificate encoding, followed by the certificate encoding itself which is written out as an array of bytes. Finally, if any code signers are present then the array of code signers is serialized and written out too.
Throws:
IOException
Serialized Fields

location

URL location
The code location.

Class java.security.DigestException extends GeneralSecurityException implements Serializable

serialVersionUID: 5821450303093652515L

Class java.security.GeneralSecurityException extends Exception implements Serializable

serialVersionUID: 894798122053539237L

Class java.security.GuardedObject extends Object implements Serializable

serialVersionUID: -5240450096227834308L

Serialization Methods

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
Writes this object out to a stream (i.e., serializes it). We check the guard if there is one.

Throws:
IOException
Serialized Fields

object

Object object

guard

Guard guard

Class java.security.Identity extends Object implements Serializable

serialVersionUID: 3609922007826600659L

Serialized Fields

name

String name
Deprecated.
The name for this identity.

publicKey

PublicKey publicKey
Deprecated.
The public key for this identity.

info

String info
Deprecated.
Generic, descriptive information about the identity.

scope

IdentityScope scope
Deprecated.
The scope of the identity.

certificates

Vector<E> certificates
Deprecated.
The certificates for this identity.

Class java.security.IdentityScope extends Identity implements Serializable

serialVersionUID: -2337346281189773310L

Class java.security.InvalidAlgorithmParameterException extends GeneralSecurityException implements Serializable

serialVersionUID: 2864672297499471472L

Class java.security.InvalidKeyException extends KeyException implements Serializable

serialVersionUID: 5698479920593359816L

Class java.security.InvalidParameterException extends IllegalArgumentException implements Serializable

serialVersionUID: -857968536935667808L

Class java.security.KeyException extends GeneralSecurityException implements Serializable

serialVersionUID: -7483676942812432108L

Class java.security.KeyManagementException extends KeyException implements Serializable

serialVersionUID: 947674216157062695L

Class java.security.KeyPair extends Object implements Serializable

serialVersionUID: -7565189502268009837L

Serialized Fields

privateKey

PrivateKey privateKey

publicKey

PublicKey publicKey

Class java.security.KeyRep extends Object implements Serializable

serialVersionUID: -4757683898830641853L

Serialization Methods

readResolve

protected Object readResolve()
                      throws ObjectStreamException
Resolve the Key object.

This method supports three Type/format combinations:

  • Type.SECRET/"RAW" - returns a SecretKeySpec object constructed using encoded key bytes and algorithm
  • Type.PUBLIC/"X.509" - gets a KeyFactory instance for the key algorithm, constructs an X509EncodedKeySpec with the encoded key bytes, and generates a public key from the spec
  • Type.PRIVATE/"PKCS#8" - gets a KeyFactory instance for the key algorithm, constructs a PKCS8EncodedKeySpec with the encoded key bytes, and generates a private key from the spec

Throws:
ObjectStreamException - if the Type/format combination is unrecognized, if the algorithm, key format, or encoded key bytes are unrecognized/invalid, of if the resolution of the key fails for any reason
Serialized Fields

type

KeyRep.Type type
Either one of Type.SECRET, Type.PUBLIC, or Type.PRIVATE

algorithm

String algorithm
The Key algorithm

format

String format
The Key encoding format

encoded

byte[] encoded
The encoded Key bytes

Class java.security.KeyStoreException extends GeneralSecurityException implements Serializable

serialVersionUID: -1119353179322377262L

Class java.security.NoSuchAlgorithmException extends GeneralSecurityException implements Serializable

serialVersionUID: -7443947487218346562L

Class java.security.NoSuchProviderException extends GeneralSecurityException implements Serializable

serialVersionUID: 8488111756688534474L

Class java.security.Permission extends Object implements Serializable

serialVersionUID: -5636570222231596674L

Serialized Fields

name

String name

Class java.security.PermissionCollection extends Object implements Serializable

serialVersionUID: -6727011328946861783L

Serialized Fields

readOnly

boolean readOnly

Class java.security.PermissionsHash extends PermissionCollection implements Serializable

serialVersionUID: -8491988220802933440L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serial Data:
Default fields.
Throws:
IOException
Serialized Fields

perms

Hashtable<K,V> perms
A table of the Permissions (both key and value are same).

Class java.security.PrivilegedActionException extends Exception implements Serializable

serialVersionUID: 4724086851538908602L

Serialized Fields

exception

Exception exception

Class java.security.Provider extends Properties implements Serializable

serialVersionUID: -4298000515446427739L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Throws:
IOException
ClassNotFoundException
Serialized Fields

name

String name
The provider name.

info

String info
A description of the provider and its services.

version

double version
The provider version number.

Class java.security.ProviderException extends RuntimeException implements Serializable

serialVersionUID: 5256023526693665674L

Class java.security.SecureRandom extends Random implements Serializable

serialVersionUID: 4940670005562187L

Serialized Fields

provider

Provider provider
The provider.

Since:
1.2

secureRandomSpi

SecureRandomSpi secureRandomSpi
The provider implementation.

Since:
1.2

algorithm

String algorithm

state

byte[] state

digest

MessageDigest digest

randomBytes

byte[] randomBytes
We know that the MessageDigest class does not implement java.io.Serializable. However, since this field is no longer used, it will always be NULL and won't affect the serialization of the SecureRandom class itself.

randomBytesUsed

int randomBytesUsed

counter

long counter

Class java.security.SecureRandomSpi extends Object implements Serializable

serialVersionUID: -2991854161009191830L

Class java.security.SecurityPermission extends BasicPermission implements Serializable

serialVersionUID: 5236109936224050470L

Class java.security.SignatureException extends GeneralSecurityException implements Serializable

serialVersionUID: 7509989324975124438L

Class java.security.SignedObject extends Object implements Serializable

serialVersionUID: 720502720485447167L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
readObject is called to restore the state of the SignedObject from a stream.

Throws:
IOException
ClassNotFoundException
Serialized Fields

content

byte[] content

signature

byte[] signature

thealgorithm

String thealgorithm

Class java.security.Signer extends Identity implements Serializable

serialVersionUID: -1763464102261361480L

Serialized Fields

privateKey

PrivateKey privateKey
Deprecated.
The signer's private key.

Class java.security.Timestamp extends Object implements Serializable

serialVersionUID: -5502683707821851294L

Serialized Fields

timestamp

Date timestamp
The timestamp's date and time

signerCertPath

CertPath signerCertPath
The TSA's certificate path.

Class java.security.UnrecoverableEntryException extends GeneralSecurityException implements Serializable

serialVersionUID: -4527142945246286535L

Class java.security.UnrecoverableKeyException extends UnrecoverableEntryException implements Serializable

serialVersionUID: 7275063078190151277L

Class java.security.UnresolvedPermission extends Permission implements Serializable

serialVersionUID: -4821973115467008846L

Serialization Methods

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
Restores this object from a stream (i.e., deserializes it).

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
Writes this object out to a stream (i.e., serializes it).

Serial Data:
An initial String denoting the type is followed by a String denoting the name is followed by a String denoting the actions is followed by an int indicating the number of certificates to follow (a value of "zero" denotes that there are no certificates associated with this object). Each certificate is written out starting with a String denoting the certificate type, followed by an int specifying the length of the certificate encoding, followed by the certificate encoding itself which is written out as an array of bytes.
Throws:
IOException
Serialized Fields

type

String type
The class name of the Permission class that will be created when this unresolved permission is resolved.

name

String name
The permission name.

actions

String actions
The actions of the permission.

Class java.security.UnresolvedPermissionCollection extends PermissionCollection implements Serializable

serialVersionUID: -7176153071733132400L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serial Data:
Default field.
Throws:
IOException
Serialized Fields

permissions

Hashtable<K,V> permissions
A table of the UnresolvedPermissions keyed on type, value is Vector of permissions
Package java.security.acl

Class java.security.acl.AclNotFoundException extends Exception implements Serializable

serialVersionUID: 5684295034092681791L

Class java.security.acl.LastOwnerException extends Exception implements Serializable

serialVersionUID: -5141997548211140359L

Class java.security.acl.NotOwnerException extends Exception implements Serializable

serialVersionUID: -5555597911163362399L

Package java.security.cert

Class java.security.cert.Certificate extends Object implements Serializable

serialVersionUID: -3585440601605666277L

Serialization Methods

writeReplace

protected Object writeReplace()
                       throws ObjectStreamException
Replace the Certificate to be serialized.

Throws:
ObjectStreamException - if a new object representing this Certificate could not be created
Since:
1.3
Serialized Fields

type

String type

Class java.security.cert.Certificate.CertificateRep extends Object implements Serializable

serialVersionUID: -8563758940495660020L

Serialization Methods

readResolve

protected Object readResolve()
                      throws ObjectStreamException
Resolve the Certificate Object.

Throws:
ObjectStreamException - if the Certificate could not be resolved
Serialized Fields

type

String type

data

byte[] data

Class java.security.cert.CertificateEncodingException extends CertificateException implements Serializable

serialVersionUID: 6219492851589449162L

Class java.security.cert.CertificateException extends GeneralSecurityException implements Serializable

serialVersionUID: 3192535253797119798L

Class java.security.cert.CertificateExpiredException extends CertificateException implements Serializable

serialVersionUID: 9071001339691533771L

Class java.security.cert.CertificateNotYetValidException extends CertificateException implements Serializable

serialVersionUID: 4355919900041064702L

Class java.security.cert.CertificateParsingException extends CertificateException implements Serializable

serialVersionUID: -7989222416793322029L

Class java.security.cert.CertificateRevokedException extends CertificateException implements Serializable

serialVersionUID: 7839996631571608627L

Serialization Methods

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
Deserialize the CertificateRevokedException instance.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
Serialize this CertificateRevokedException instance.

Serial Data:
the size of the extensions map (int), followed by all of the extensions in the map, in no particular order. For each extension, the following data is emitted: the OID String (Object), the criticality flag (boolean), the length of the encoded extension value byte array (int), and the encoded extension value bytes.
Throws:
IOException
Serialized Fields

revocationDate

Date revocationDate
the date on which the certificate was revoked

reason

CRLReason reason
the revocation reason

authority

X500Principal authority
the name of the authority that signed the certificate's revocation status information

Class java.security.cert.CertPath extends Object implements Serializable

serialVersionUID: 6068470306649138683L

Serialization Methods

writeReplace

protected Object writeReplace()
                       throws ObjectStreamException
Replaces the CertPath to be serialized with a CertPathRep object.

Throws:
ObjectStreamException - if a CertPathRep object representing this certification path could not be created
Serialized Fields

type

String type

Class java.security.cert.CertPath.CertPathRep extends Object implements Serializable

serialVersionUID: 3015633072427920915L

Serialization Methods

readResolve

protected Object readResolve()
                      throws ObjectStreamException
Returns a CertPath constructed from the type and data.

Throws:
ObjectStreamException - if a CertPath could not be constructed
Serialized Fields

type

String type
The Certificate type

data

byte[] data
The encoded form of the cert path

Class java.security.cert.CertPathBuilderException extends GeneralSecurityException implements Serializable

serialVersionUID: 5316471420178794402L

Class java.security.cert.CertPathValidatorException extends GeneralSecurityException implements Serializable

serialVersionUID: -3083180014971893139L

Serialization Methods

readObject

private void readObject(ObjectInputStream stream)
                 throws ClassNotFoundException,
                        IOException
Throws:
ClassNotFoundException
IOException
Serialized Fields

index

int index
the index of the certificate in the certification path that caused the exception to be thrown

certPath

CertPath certPath
the CertPath that was being validated when the exception was thrown

reason

CertPathValidatorException.Reason reason
the reason the validation failed

Class java.security.cert.CertStoreException extends GeneralSecurityException implements Serializable

serialVersionUID: 2395296107471573245L

Class java.security.cert.CRLException extends GeneralSecurityException implements Serializable

serialVersionUID: -6694728944094197147L

Class java.security.cert.X509Certificate extends Certificate implements Serializable

serialVersionUID: -2491127588187038216L

Package java.security.interfaces
Package java.security.spec

Class java.security.spec.InvalidKeySpecException extends GeneralSecurityException implements Serializable

serialVersionUID: 3546139293998810778L

Class java.security.spec.InvalidParameterSpecException extends GeneralSecurityException implements Serializable

serialVersionUID: -970468769593399342L

Package java.sql

Class java.sql.BatchUpdateException extends SQLException implements Serializable

serialVersionUID: 5977529877145521757L

Serialized Fields

updateCounts

int[] updateCounts
The array that describes the outcome of a batch execution.

Since:
1.2

Class java.sql.DataTruncation extends SQLWarning implements Serializable

serialVersionUID: 6464298989504059473L

Serialized Fields

index

int index

parameter

boolean parameter

read

boolean read

dataSize

int dataSize

transferSize

int transferSize

Class java.sql.Date extends Date implements Serializable

serialVersionUID: 1511598038487230103L

Class java.sql.SQLClientInfoException extends SQLException implements Serializable

serialVersionUID: -4319604256824655880L

Serialized Fields

failedProperties

Map<K,V> failedProperties

Class java.sql.SQLDataException extends SQLNonTransientException implements Serializable

serialVersionUID: -6889123282670549800L

Class java.sql.SQLException extends Exception implements Serializable

serialVersionUID: 2135244094396331484L

Serialized Fields

SQLState

String SQLState

vendorCode

int vendorCode

next

SQLException next

Class java.sql.SQLFeatureNotSupportedException extends SQLNonTransientException implements Serializable

serialVersionUID: -1026510870282316051L

Class java.sql.SQLIntegrityConstraintViolationException extends SQLNonTransientException implements Serializable

serialVersionUID: 8033405298774849169L

Class java.sql.SQLInvalidAuthorizationSpecException extends SQLNonTransientException implements Serializable

serialVersionUID: -64105250450891498L

Class java.sql.SQLNonTransientConnectionException extends SQLNonTransientException implements Serializable

serialVersionUID: -5852318857474782892L

Class java.sql.SQLNonTransientException extends SQLException implements Serializable

serialVersionUID: -9104382843534716547L

Class java.sql.SQLPermission extends BasicPermission implements Serializable

serialVersionUID: -1439323187199563495L

Class java.sql.SQLRecoverableException extends SQLException implements Serializable

serialVersionUID: -4144386502923131579L

Class java.sql.SQLSyntaxErrorException extends SQLNonTransientException implements Serializable

serialVersionUID: -1843832610477496053L

Class java.sql.SQLTimeoutException extends SQLTransientException implements Serializable

serialVersionUID: -4487171280562520262L

Class java.sql.SQLTransactionRollbackException extends SQLTransientException implements Serializable

serialVersionUID: 5246680841170837229L

Class java.sql.SQLTransientConnectionException extends SQLTransientException implements Serializable

serialVersionUID: -2520155553543391200L

Class java.sql.SQLTransientException extends SQLException implements Serializable

serialVersionUID: -9042733978262274539L

Class java.sql.SQLWarning extends SQLException implements Serializable

serialVersionUID: 3917336774604784856L

Class java.sql.Time extends Date implements Serializable

serialVersionUID: 8397324403548013681L

Class java.sql.Timestamp extends Date implements Serializable

serialVersionUID: 2745179027874758501L

Serialized Fields

nanos

int nanos
Package java.text

Class java.text.AttributedCharacterIterator.Attribute extends Object implements Serializable

serialVersionUID: -9142742483513960612L

Serialization Methods

readResolve

protected Object readResolve()
                      throws InvalidObjectException
Resolves instances being deserialized to the predefined constants.

Throws:
InvalidObjectException
Serialized Fields

name

String name
The name of this Attribute. The name is used primarily by readResolve to look up the corresponding predefined instance when deserializing an instance.

Class java.text.ChoiceFormat extends NumberFormat implements Serializable

serialVersionUID: 1795184449645032964L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
After reading an object from the input stream, do a simple verification to maintain class invariants.

Throws:
InvalidObjectException - if the objects read from the stream is invalid.
IOException
ClassNotFoundException
Serialized Fields

choiceLimits

double[] choiceLimits
A list of lower bounds for the choices. The formatter will return choiceFormats[i] if the number being formatted is greater than or equal to choiceLimits[i] and less than choiceLimits[i+1].

choiceFormats

String[] choiceFormats
A list of choice strings. The formatter will return choiceFormats[i] if the number being formatted is greater than or equal to choiceLimits[i] and less than choiceLimits[i+1].

Class java.text.DateFormat extends Format implements Serializable

serialVersionUID: 7218322306649953788L

Serialized Fields

calendar

Calendar calendar
The calendar that DateFormat uses to produce the time field values needed to implement date and time formatting. Subclasses should initialize this to a calendar appropriate for the locale associated with this DateFormat.

numberFormat

NumberFormat numberFormat
The number formatter that DateFormat uses to format numbers in dates and times. Subclasses should initialize this to a number format appropriate for the locale associated with this DateFormat.

Class java.text.DateFormat.Field extends Format.Field implements Serializable

serialVersionUID: 7441350119349544720L

Serialization Methods

readResolve

protected Object readResolve()
                      throws InvalidObjectException
Resolves instances being deserialized to the predefined constants.

Throws:
InvalidObjectException - if the constant could not be resolved.
Serialized Fields

calendarField

int calendarField
Calendar field.

Class java.text.DateFormatSymbols extends Object implements Serializable

serialVersionUID: -5987973545549424702L

Serialization Methods

writeObject

private void writeObject(ObjectOutputStream stream)
                  throws IOException
Write out the default serializable data, after ensuring the zoneStrings field is initialized in order to make sure the backward compatibility.

Throws:
IOException
Since:
1.6
Serialized Fields

eras

String[] eras
Era strings. For example: "AD" and "BC". An array of 2 strings, indexed by Calendar.BC and Calendar.AD.

months

String[] months
Month strings. For example: "January", "February", etc. An array of 13 strings (some calendars have 13 months), indexed by Calendar.JANUARY, Calendar.FEBRUARY, etc.

shortMonths

String[] shortMonths
Short month strings. For example: "Jan", "Feb", etc. An array of 13 strings (some calendars have 13 months), indexed by Calendar.JANUARY, Calendar.FEBRUARY, etc.

weekdays

String[] weekdays
Weekday strings. For example: "Sunday", "Monday", etc. An array of 8 strings, indexed by Calendar.SUNDAY, Calendar.MONDAY, etc. The element weekdays[0] is ignored.

shortWeekdays

String[] shortWeekdays
Short weekday strings. For example: "Sun", "Mon", etc. An array of 8 strings, indexed by Calendar.SUNDAY, Calendar.MONDAY, etc. The element shortWeekdays[0] is ignored.

ampms

String[] ampms
AM and PM strings. For example: "AM" and "PM". An array of 2 strings, indexed by Calendar.AM and Calendar.PM.

zoneStrings

String[][] zoneStrings
Localized names of time zones in this locale. This is a two-dimensional array of strings of size n by m, where m is at least 5. Each of the n rows is an entry containing the localized names for a single TimeZone. Each such row contains (with i ranging from 0..n-1):
  • zoneStrings[i][0] - time zone ID
  • zoneStrings[i][1] - long name of zone in standard time
  • zoneStrings[i][2] - short name of zone in standard time
  • zoneStrings[i][3] - long name of zone in daylight saving time
  • zoneStrings[i][4] - short name of zone in daylight saving time
The zone ID is not localized; it's one of the valid IDs of the TimeZone class that are not custom IDs. All other entries are localized names.

See Also:
TimeZone

localPatternChars

String localPatternChars
Localized date-time pattern characters. For example, a locale may wish to use 'u' rather than 'y' to represent years in its date format pattern strings. This string must be exactly 18 characters long, with the index of the characters described by DateFormat.ERA_FIELD, DateFormat.YEAR_FIELD, etc. Thus, if the string were "Xz...", then localized patterns would use 'X' for era and 'z' for year.

locale

Locale locale
The locale which is used for initializing this DateFormatSymbols object.

Since:
1.6

Class java.text.DecimalFormat extends NumberFormat implements Serializable

serialVersionUID: 864413376551465018L

Serialization Methods

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
Reads the default serializable fields from the stream and performs validations and adjustments for older serialized versions. The validations and adjustments are:
  1. Verify that the superclass's digit count fields correctly reflect the limits imposed on formatting numbers other than BigInteger and BigDecimal objects. These limits are stored in the superclass for serialization compatibility with older versions, while the limits for BigInteger and BigDecimal objects are kept in this class. If, in the superclass, the minimum or maximum integer digit count is larger than DOUBLE_INTEGER_DIGITS or if the minimum or maximum fraction digit count is larger than DOUBLE_FRACTION_DIGITS, then the stream data is invalid and this method throws an InvalidObjectException.
  2. If serialVersionOnStream is less than 4, initialize roundingMode to RoundingMode.HALF_EVEN. This field is new with version 4.
  3. If serialVersionOnStream is less than 3, then call the setters for the minimum and maximum integer and fraction digits with the values of the corresponding superclass getters to initialize the fields in this class. The fields in this class are new with version 3.
  4. If serialVersionOnStream is less than 1, indicating that the stream was written by JDK 1.1, initialize useExponentialNotation to false, since it was not present in JDK 1.1.
  5. Set serialVersionOnStream to the maximum allowed value so that default serialization will work properly if this object is streamed out again.

Stream versions older than 2 will not have the affix pattern variables posPrefixPattern etc. As a result, they will be initialized to null, which means the affix strings will be taken as literal values. This is exactly what we want, since that corresponds to the pre-version-2 behavior.

Throws:
IOException
ClassNotFoundException
Serialized Fields

positivePrefix

String positivePrefix
The symbol used as a prefix when formatting positive numbers, e.g. "+".

See Also:
DecimalFormat.getPositivePrefix()

positiveSuffix

String positiveSuffix
The symbol used as a suffix when formatting positive numbers. This is often an empty string.

See Also:
DecimalFormat.getPositiveSuffix()

negativePrefix

String negativePrefix
The symbol used as a prefix when formatting negative numbers, e.g. "-".

See Also:
DecimalFormat.getNegativePrefix()

negativeSuffix

String negativeSuffix
The symbol used as a suffix when formatting negative numbers. This is often an empty string.

See Also:
DecimalFormat.getNegativeSuffix()

posPrefixPattern

String posPrefixPattern
The prefix pattern for non-negative numbers. This variable corresponds to positivePrefix.

This pattern is expanded by the method expandAffix() to positivePrefix to update the latter to reflect changes in symbols. If this variable is null then positivePrefix is taken as a literal value that does not change when symbols changes. This variable is always null for DecimalFormat objects older than stream version 2 restored from stream.

Since:
1.3

posSuffixPattern

String posSuffixPattern
The suffix pattern for non-negative numbers. This variable corresponds to positiveSuffix. This variable is analogous to posPrefixPattern; see that variable for further documentation.

Since:
1.3

negPrefixPattern

String negPrefixPattern
The prefix pattern for negative numbers. This variable corresponds to negativePrefix. This variable is analogous to posPrefixPattern; see that variable for further documentation.

Since:
1.3

negSuffixPattern

String negSuffixPattern
The suffix pattern for negative numbers. This variable corresponds to negativeSuffix. This variable is analogous to posPrefixPattern; see that variable for further documentation.

Since:
1.3

multiplier

int multiplier
The multiplier for use in percent, per mille, etc.

See Also:
DecimalFormat.getMultiplier()

groupingSize

byte groupingSize
The number of digits between grouping separators in the integer portion of a number. Must be greater than 0 if NumberFormat.groupingUsed is true.

See Also:
DecimalFormat.getGroupingSize(), NumberFormat.isGroupingUsed()

decimalSeparatorAlwaysShown

boolean decimalSeparatorAlwaysShown
If true, forces the decimal separator to always appear in a formatted number, even if the fractional part of the number is zero.

See Also:
DecimalFormat.isDecimalSeparatorAlwaysShown()

parseBigDecimal

boolean parseBigDecimal
If true, parse returns BigDecimal wherever possible.

Since:
1.5
See Also:
DecimalFormat.isParseBigDecimal()

symbols

DecimalFormatSymbols symbols
The DecimalFormatSymbols object used by this format. It contains the symbols used to format numbers, e.g. the grouping separator, decimal separator, and so on.

See Also:
DecimalFormat.setDecimalFormatSymbols(java.text.DecimalFormatSymbols), DecimalFormatSymbols

useExponentialNotation

boolean useExponentialNotation
True to force the use of exponential (i.e. scientific) notation when formatting numbers.

Since:
1.2

minExponentDigits

byte minExponentDigits
The minimum number of digits used to display the exponent when a number is formatted in exponential notation. This field is ignored if useExponentialNotation is not true.

Since:
1.2

maximumIntegerDigits

int maximumIntegerDigits
The maximum number of digits allowed in the integer portion of a BigInteger or BigDecimal number. maximumIntegerDigits must be greater than or equal to minimumIntegerDigits.

Since:
1.5
See Also:
DecimalFormat.getMaximumIntegerDigits()

minimumIntegerDigits

int minimumIntegerDigits
The minimum number of digits allowed in the integer portion of a BigInteger or BigDecimal number. minimumIntegerDigits must be less than or equal to maximumIntegerDigits.

Since:
1.5
See Also:
DecimalFormat.getMinimumIntegerDigits()

maximumFractionDigits

int maximumFractionDigits
The maximum number of digits allowed in the fractional portion of a BigInteger or BigDecimal number. maximumFractionDigits must be greater than or equal to minimumFractionDigits.

Since:
1.5
See Also:
DecimalFormat.getMaximumFractionDigits()

minimumFractionDigits

int minimumFractionDigits
The minimum number of digits allowed in the fractional portion of a BigInteger or BigDecimal number. minimumFractionDigits must be less than or equal to maximumFractionDigits.

Since:
1.5
See Also:
DecimalFormat.getMinimumFractionDigits()

roundingMode

RoundingMode roundingMode
The RoundingMode used in this DecimalFormat.

Since:
1.6

serialVersionOnStream

int serialVersionOnStream
The internal serial version which says which version was written. Possible values are:
  • 0 (default): versions before the Java 2 platform v1.2
  • 1: version for 1.2, which includes the two new fields useExponentialNotation and minExponentDigits.
  • 2: version for 1.3 and later, which adds four new fields: posPrefixPattern, posSuffixPattern, negPrefixPattern, and negSuffixPattern.
  • 3: version for 1.5 and later, which adds five new fields: maximumIntegerDigits, minimumIntegerDigits, maximumFractionDigits, minimumFractionDigits, and parseBigDecimal.
  • 4: version for 1.6 and later, which adds one new field: roundingMode.

Since:
1.2

Class java.text.DecimalFormatSymbols extends Object implements Serializable

serialVersionUID: 5772796243397350300L

Serialization Methods

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
Reads the default serializable fields, provides default values for objects in older serial versions, and initializes non-serializable fields. If serialVersionOnStream is less than 1, initializes monetarySeparator to be the same as decimalSeparator and exponential to be 'E'. If serialVersionOnStream is less than 2, initializes localeto the root locale, and initializes If serialVersionOnStream is less than 3, it initializes exponentialSeparator using exponential. Sets serialVersionOnStream back to the maximum allowed value so that default serialization will work properly if this object is streamed out again. Initializes the currency from the intlCurrencySymbol field.

Throws:
IOException
ClassNotFoundException
Since:
JDK 1.1.6
Serialized Fields

zeroDigit

char zeroDigit
Character used for zero.

See Also:
DecimalFormatSymbols.getZeroDigit()

groupingSeparator

char groupingSeparator
Character used for thousands separator.

See Also:
DecimalFormatSymbols.getGroupingSeparator()

decimalSeparator

char decimalSeparator
Character used for decimal sign.

See Also:
DecimalFormatSymbols.getDecimalSeparator()

perMill

char perMill
Character used for per mille sign.

See Also:
DecimalFormatSymbols.getPerMill()

percent

char percent
Character used for percent sign.

See Also:
DecimalFormatSymbols.getPercent()

digit

char digit
Character used for a digit in a pattern.

See Also:
DecimalFormatSymbols.getDigit()

patternSeparator

char patternSeparator
Character used to separate positive and negative subpatterns in a pattern.

See Also:
DecimalFormatSymbols.getPatternSeparator()

infinity

String infinity
String used to represent infinity.

See Also:
DecimalFormatSymbols.getInfinity()

NaN

String NaN
String used to represent "not a number".

See Also:
DecimalFormatSymbols.getNaN()

minusSign

char minusSign
Character used to represent minus sign.

See Also:
DecimalFormatSymbols.getMinusSign()

currencySymbol

String currencySymbol
String denoting the local currency, e.g. "$".

See Also:
DecimalFormatSymbols.getCurrencySymbol()

intlCurrencySymbol

String intlCurrencySymbol
ISO 4217 currency code denoting the local currency, e.g. "USD".

See Also:
DecimalFormatSymbols.getInternationalCurrencySymbol()

monetarySeparator

char monetarySeparator
The decimal separator used when formatting currency values.

Since:
JDK 1.1.6
See Also:
DecimalFormatSymbols.getMonetaryDecimalSeparator()

exponential

char exponential
The character used to distinguish the exponent in a number formatted in exponential notation, e.g. 'E' for a number such as "1.23E45".

Note that the public API provides no way to set this field, even though it is supported by the implementation and the stream format. The intent is that this will be added to the API in the future.

Since:
JDK 1.1.6

exponentialSeparator

String exponentialSeparator
The string used to separate the mantissa from the exponent. Examples: "x10^" for 1.23x10^4, "E" for 1.23E4.

If both exponential and exponentialSeparator exist, this exponentialSeparator has the precedence.

Since:
1.6

locale

Locale locale
The locale of these currency format symbols.

Since:
1.4

serialVersionOnStream

int serialVersionOnStream
Describes the version of DecimalFormatSymbols present on the stream. Possible values are:
  • 0 (or uninitialized): versions prior to JDK 1.1.6.
  • 1: Versions written by JDK 1.1.6 or later, which include two new fields: monetarySeparator and exponential.
  • 2: Versions written by J2SE 1.4 or later, which include a new locale field.
  • 3: Versions written by J2SE 1.6 or later, which include a new exponentialSeparator field.
When streaming out a DecimalFormatSymbols, the most recent format (corresponding to the highest allowable serialVersionOnStream) is always written.

Since:
JDK 1.1.6

Class java.text.Format extends Object implements Serializable

serialVersionUID: -299282585814624189L

Class java.text.Format.Field extends AttributedCharacterIterator.Attribute implements Serializable

serialVersionUID: 276966692217360283L

Class java.text.MessageFormat extends Format implements Serializable

serialVersionUID: 6479157306784022952L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
After reading an object from the input stream, do a simple verification to maintain class invariants.

Throws:
InvalidObjectException - if the objects read from the stream is invalid.
IOException
ClassNotFoundException
Serialized Fields

locale

Locale locale
The locale to use for formatting numbers and dates.

pattern

String pattern
The string that the formatted values are to be plugged into. In other words, this is the pattern supplied on construction with all of the {} expressions taken out.

formats

Format[] formats
An array of formatters, which are used to format the arguments.

offsets

int[] offsets
The positions where the results of formatting each argument are to be inserted into the pattern.

argumentNumbers

int[] argumentNumbers
The argument numbers corresponding to each formatter. (The formatters are stored in the order they occur in the pattern, not in the order in which the arguments are specified.)

maxOffset

int maxOffset
One less than the number of entries in offsets. Can also be thought of as the index of the highest-numbered element in offsets that is being used. All of these arrays should have the same number of elements being used as offsets does, and so this variable suffices to tell us how many entries are in all of them.

Class java.text.MessageFormat.Field extends Format.Field implements Serializable

serialVersionUID: 7899943957617360810L

Serialization Methods

readResolve

protected Object readResolve()
                      throws InvalidObjectException
Resolves instances being deserialized to the predefined constants.

Throws:
InvalidObjectException - if the constant could not be resolved.

Class java.text.NumberFormat extends Format implements Serializable

serialVersionUID: -2308460125733713944L

Serialization Methods

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
First, read in the default serializable data. Then, if serialVersionOnStream is less than 1, indicating that the stream was written by JDK 1.1, set the int fields such as maximumIntegerDigits to be equal to the byte fields such as maxIntegerDigits, since the int fields were not present in JDK 1.1. Finally, set serialVersionOnStream back to the maximum allowed value so that default serialization will work properly if this object is streamed out again.

If minimumIntegerDigits is greater than maximumIntegerDigits or minimumFractionDigits is greater than maximumFractionDigits, then the stream data is invalid and this method throws an InvalidObjectException. In addition, if any of these values is negative, then this method throws an InvalidObjectException.

Throws:
IOException
ClassNotFoundException
Since:
1.2

writeObject

private void writeObject(ObjectOutputStream stream)
                  throws IOException
Write out the default serializable data, after first setting the byte fields such as maxIntegerDigits to be equal to the int fields such as maximumIntegerDigits (or to Byte.MAX_VALUE, whichever is smaller), for compatibility with the JDK 1.1 version of the stream format.

Throws:
IOException
Since:
1.2
Serialized Fields

groupingUsed

boolean groupingUsed
True if the grouping (i.e. thousands) separator is used when formatting and parsing numbers.

See Also:
NumberFormat.isGroupingUsed()

maxIntegerDigits

byte maxIntegerDigits
The maximum number of digits allowed in the integer portion of a number. maxIntegerDigits must be greater than or equal to minIntegerDigits.

Note: This field exists only for serialization compatibility with JDK 1.1. In Java platform 2 v1.2 and higher, the new int field maximumIntegerDigits is used instead. When writing to a stream, maxIntegerDigits is set to maximumIntegerDigits or Byte.MAX_VALUE, whichever is smaller. When reading from a stream, this field is used only if serialVersionOnStream is less than 1.

See Also:
NumberFormat.getMaximumIntegerDigits()

minIntegerDigits

byte minIntegerDigits
The minimum number of digits allowed in the integer portion of a number. minimumIntegerDigits must be less than or equal to maximumIntegerDigits.

Note: This field exists only for serialization compatibility with JDK 1.1. In Java platform 2 v1.2 and higher, the new int field minimumIntegerDigits is used instead. When writing to a stream, minIntegerDigits is set to minimumIntegerDigits or Byte.MAX_VALUE, whichever is smaller. When reading from a stream, this field is used only if serialVersionOnStream is less than 1.

See Also:
NumberFormat.getMinimumIntegerDigits()

maxFractionDigits

byte maxFractionDigits
The maximum number of digits allowed in the fractional portion of a number. maximumFractionDigits must be greater than or equal to minimumFractionDigits.

Note: This field exists only for serialization compatibility with JDK 1.1. In Java platform 2 v1.2 and higher, the new int field maximumFractionDigits is used instead. When writing to a stream, maxFractionDigits is set to maximumFractionDigits or Byte.MAX_VALUE, whichever is smaller. When reading from a stream, this field is used only if serialVersionOnStream is less than 1.

See Also:
NumberFormat.getMaximumFractionDigits()

minFractionDigits

byte minFractionDigits
The minimum number of digits allowed in the fractional portion of a number. minimumFractionDigits must be less than or equal to maximumFractionDigits.

Note: This field exists only for serialization compatibility with JDK 1.1. In Java platform 2 v1.2 and higher, the new int field minimumFractionDigits is used instead. When writing to a stream, minFractionDigits is set to minimumFractionDigits or Byte.MAX_VALUE, whichever is smaller. When reading from a stream, this field is used only if serialVersionOnStream is less than 1.

See Also:
NumberFormat.getMinimumFractionDigits()

parseIntegerOnly

boolean parseIntegerOnly
True if this format will parse numbers as integers only.

See Also:
NumberFormat.isParseIntegerOnly()

maximumIntegerDigits

int maximumIntegerDigits
The maximum number of digits allowed in the integer portion of a number. maximumIntegerDigits must be greater than or equal to minimumIntegerDigits.

Since:
1.2
See Also:
NumberFormat.getMaximumIntegerDigits()

minimumIntegerDigits

int minimumIntegerDigits
The minimum number of digits allowed in the integer portion of a number. minimumIntegerDigits must be less than or equal to maximumIntegerDigits.

Since:
1.2
See Also:
NumberFormat.getMinimumIntegerDigits()

maximumFractionDigits

int maximumFractionDigits
The maximum number of digits allowed in the fractional portion of a number. maximumFractionDigits must be greater than or equal to minimumFractionDigits.

Since:
1.2
See Also:
NumberFormat.getMaximumFractionDigits()

minimumFractionDigits

int minimumFractionDigits
The minimum number of digits allowed in the fractional portion of a number. minimumFractionDigits must be less than or equal to maximumFractionDigits.

Since:
1.2
See Also:
NumberFormat.getMinimumFractionDigits()

serialVersionOnStream

int serialVersionOnStream
Describes the version of NumberFormat present on the stream. Possible values are:
  • 0 (or uninitialized): the JDK 1.1 version of the stream format. In this version, the int fields such as maximumIntegerDigits were not present, and the byte fields such as maxIntegerDigits are used instead.
  • 1: the 1.2 version of the stream format. The values of the byte fields such as maxIntegerDigits are ignored, and the int fields such as maximumIntegerDigits are used instead.
When streaming out a NumberFormat, the most recent format (corresponding to the highest allowable serialVersionOnStream) is always written.

Since:
1.2

Class java.text.NumberFormat.Field extends Format.Field implements Serializable

serialVersionUID: 7494728892700160890L

Serialization Methods

readResolve

protected Object readResolve()
                      throws InvalidObjectException
Resolves instances being deserialized to the predefined constants.

Throws:
InvalidObjectException - if the constant could not be resolved.

Class java.text.ParseException extends Exception implements Serializable

Serialized Fields

errorOffset

int errorOffset
The zero-based character offset into the string being parsed at which the error was found during parsing.

Class java.text.SimpleDateFormat extends DateFormat implements Serializable

serialVersionUID: 4774881970558875024L

Serialization Methods

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
After reading an object from the input stream, the format pattern in the object is verified.

Throws:
InvalidObjectException - if the pattern is invalid
IOException
ClassNotFoundException
Serialized Fields

serialVersionOnStream

int serialVersionOnStream
The version of the serialized data on the stream. Possible values:
  • 0 or not present on stream: JDK 1.1.3. This version has no defaultCenturyStart on stream.
  • 1 JDK 1.1.4 or later. This version adds defaultCenturyStart.
When streaming out this class, the most recent format and the highest allowable serialVersionOnStream is written.

Since:
JDK1.1.4

pattern

String pattern
The pattern string of this formatter. This is always a non-localized pattern. May not be null. See class documentation for details.

formatData

DateFormatSymbols formatData
The symbols used by this formatter for week names, month names, etc. May not be null.

See Also:
DateFormatSymbols

defaultCenturyStart

Date defaultCenturyStart
We map dates with two-digit years into the century starting at defaultCenturyStart, which may be any date. May not be null.

Since:
JDK1.1.4

locale

Locale locale
The Locale used to instantiate this SimpleDateFormat. The value may be null if this object has been created by an older SimpleDateFormat and deserialized.

Since:
1.6
Package java.util

Class java.util.AbstractMap.SimpleEntry extends Object implements Serializable

serialVersionUID: -8499721149061103585L

Serialized Fields

key

Object key

value

Object value

Class java.util.AbstractMap.SimpleImmutableEntry extends Object implements Serializable

serialVersionUID: 7138329143949025153L

Serialized Fields

key

Object key

value

Object value

Class java.util.ArrayDeque extends AbstractCollection<E> implements Serializable

serialVersionUID: 2340985798034038923L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Deserialize this deque.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Serialize this deque.

Serial Data:
The current size (int) of the deque, followed by all of its elements (each an object reference) in first-to-last order.
Throws:
IOException

Class java.util.ArrayList extends AbstractList<E> implements Serializable

serialVersionUID: 8683452581122892189L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reconstitute the ArrayList instance from a stream (that is, deserialize it).

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Save the state of the ArrayList instance to a stream (that is, serialize it).

Serial Data:
The length of the array backing the ArrayList instance is emitted (int), followed by all of its elements (each an Object) in the proper order.
Throws:
IOException
Serialized Fields

size

int size
The size of the ArrayList (the number of elements it contains).

Class java.util.Arrays.ArrayList extends AbstractList<E> implements Serializable

serialVersionUID: -2764017481108945198L

Serialized Fields

a

Object[] a

Class java.util.BitSet extends Object implements Serializable

serialVersionUID: 7997698588986878753L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reconstitute the BitSet instance from a stream (i.e., deserialize it).

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Save the state of the BitSet instance to a stream (i.e., serialize it).

Throws:
IOException
Serialized Fields

bits

long[] bits
The bits in this BitSet. The ith bit is stored in bits[i/64] at bit position i % 64 (where bit position 0 refers to the least significant bit and 63 refers to the most significant bit).

Class java.util.Calendar extends Object implements Serializable

serialVersionUID: -1807547505821590642L

Serialization Methods

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
Reconstitutes this object from a stream (i.e., deserialize it).

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream stream)
                  throws IOException
Save the state of this object to a stream (i.e., serialize it). Ideally, Calendar would only write out its state data and the current time, and not write any field data out, such as fields[], isTimeSet, areFieldsSet, and isSet[]. nextStamp also should not be part of the persistent state. Unfortunately, this didn't happen before JDK 1.1 shipped. To be compatible with JDK 1.1, we will always have to write out the field values and state flags. However, nextStamp can be removed from the serialization stream; this will probably happen in the near future.

Throws:
IOException
Serialized Fields

fields

int[] fields
The calendar field values for the currently set time for this calendar. This is an array of FIELD_COUNT integers, with index values ERA through DST_OFFSET.

isSet

boolean[] isSet
The flags which tell if a specified calendar field for the calendar is set. A new object has no fields set. After the first call to a method which generates the fields, they all remain set after that. This is an array of FIELD_COUNT booleans, with index values ERA through DST_OFFSET.

time

long time
The currently set time for this calendar, expressed in milliseconds after January 1, 1970, 0:00:00 GMT.

See Also:
Calendar.isTimeSet

isTimeSet

boolean isTimeSet
True if then the value of time is valid. The time is made invalid by a change to an item of field[].

See Also:
Calendar.time

areFieldsSet

boolean areFieldsSet
True if fields[] are in sync with the currently set time. If false, then the next attempt to get the value of a field will force a recomputation of all fields from the current value of time.

lenient

boolean lenient
True if this calendar allows out-of-range field values during computation of time from fields[].

See Also:
Calendar.setLenient(boolean), Calendar.isLenient()

zone

TimeZone zone
The TimeZone used by this calendar. Calendar uses the time zone data to translate between locale and GMT time.

firstDayOfWeek

int firstDayOfWeek
The first day of the week, with possible values SUNDAY, MONDAY, etc. This is a locale-dependent value.

minimalDaysInFirstWeek

int minimalDaysInFirstWeek
The number of days required for the first week in a month or year, with possible values from 1 to 7. This is a locale-dependent value.

nextStamp

int nextStamp
The next available value for stamp[], an internal array. This actually should not be written out to the stream, and will probably be removed from the stream in the near future. In the meantime, a value of MINIMUM_USER_STAMP should be used.

serialVersionOnStream

int serialVersionOnStream
The version of the serialized data on the stream. Possible values:
0 or not present on stream
JDK 1.1.5 or earlier.
1
JDK 1.1.6 or later. Writes a correct 'time' value as well as compatible values for other fields. This is a transitional format.
When streaming out this class, the most recent format and the highest allowable serialVersionOnStream is written.

Since:
JDK1.1.6

Class java.util.Collections.AsLIFOQueue extends AbstractQueue<E> implements Serializable

serialVersionUID: 1802017725587941708L

Serialized Fields

q

Deque<E> q

Class java.util.Collections.CheckedCollection extends Object implements Serializable

serialVersionUID: 1578914078182001775L

Serialized Fields

c

Collection<E> c

type

Class<T> type

zeroLengthElementArray

Object[] zeroLengthElementArray

Class java.util.Collections.CheckedList extends java.util.Collections.CheckedCollection<E> implements Serializable

serialVersionUID: 65247728283967356L

Serialized Fields

list

List<E> list

Class java.util.Collections.CheckedMap extends Object implements Serializable

serialVersionUID: 5742860141034234728L

Serialized Fields

m

Map<K,V> m

keyType

Class<T> keyType

valueType

Class<T> valueType

Class java.util.Collections.CheckedRandomAccessList extends java.util.Collections.CheckedList<E> implements Serializable

serialVersionUID: 1638200125423088369L

Class java.util.Collections.CheckedSet extends java.util.Collections.CheckedCollection<E> implements Serializable

serialVersionUID: 4694047833775013803L

Class java.util.Collections.CheckedSortedMap extends java.util.Collections.CheckedMap<K,V> implements Serializable

serialVersionUID: 1599671320688067438L

Serialized Fields

sm

SortedMap<K,V> sm

Class java.util.Collections.CheckedSortedSet extends java.util.Collections.CheckedSet<E> implements Serializable

serialVersionUID: 1599911165492914959L

Serialized Fields

ss

SortedSet<E> ss

Class java.util.Collections.CopiesList extends AbstractList<E> implements Serializable

serialVersionUID: 2739099268398711800L

Serialized Fields

n

int n

element

Object element

Class java.util.Collections.EmptyList extends AbstractList<E> implements Serializable

serialVersionUID: 8842843931221139166L

Serialization Methods

readResolve

private Object readResolve()

Class java.util.Collections.EmptyMap extends AbstractMap<K,V> implements Serializable

serialVersionUID: 6428348081105594320L

Serialization Methods

readResolve

private Object readResolve()

Class java.util.Collections.EmptySet extends AbstractSet<E> implements Serializable

serialVersionUID: 1582296315990362920L

Serialization Methods

readResolve

private Object readResolve()

Class java.util.Collections.ReverseComparator extends Object implements Serializable

serialVersionUID: 7207038068494060240L

Serialization Methods

readResolve

private Object readResolve()

Class java.util.Collections.ReverseComparator2 extends Object implements Serializable

serialVersionUID: 4374092139857L

Serialized Fields

cmp

Comparator<T> cmp
The comparator specified in the static factory. This will never be null, as the static factory returns a ReverseComparator instance if its argument is null.

Class java.util.Collections.SetFromMap extends AbstractSet<E> implements Serializable

serialVersionUID: 2454657854757543876L

Serialization Methods

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
Throws:
IOException
ClassNotFoundException
Serialized Fields

m

Map<K,V> m

Class java.util.Collections.SingletonList extends AbstractList<E> implements Serializable

serialVersionUID: 3093736618740652951L

Serialized Fields

element

Object element

Class java.util.Collections.SingletonMap extends AbstractMap<K,V> implements Serializable

serialVersionUID: -6979724477215052911L

Serialized Fields

k

Object k

v

Object v

Class java.util.Collections.SingletonSet extends AbstractSet<E> implements Serializable

serialVersionUID: 3193687207550431679L

Serialized Fields

element

Object element

Class java.util.Collections.SynchronizedCollection extends Object implements Serializable

serialVersionUID: 3053995032091335093L

Serialization Methods

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Throws:
IOException
Serialized Fields

c

Collection<E> c

mutex

Object mutex

Class java.util.Collections.SynchronizedList extends java.util.Collections.SynchronizedCollection<E> implements Serializable

serialVersionUID: -7754090372962971524L

Serialization Methods

readResolve

private Object readResolve()
SynchronizedRandomAccessList instances are serialized as SynchronizedList instances to allow them to be deserialized in pre-1.4 JREs (which do not have SynchronizedRandomAccessList). This method inverts the transformation. As a beneficial side-effect, it also grafts the RandomAccess marker onto SynchronizedList instances that were serialized in pre-1.4 JREs. Note: Unfortunately, SynchronizedRandomAccessList instances serialized in 1.4.1 and deserialized in 1.4 will become SynchronizedList instances, as this method was missing in 1.4.

Serialized Fields

list

List<E> list

Class java.util.Collections.SynchronizedMap extends Object implements Serializable

serialVersionUID: 1978198479659022715L

Serialization Methods

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Throws:
IOException
Serialized Fields

m

Map<K,V> m

mutex

Object mutex

Class java.util.Collections.SynchronizedRandomAccessList extends java.util.Collections.SynchronizedList<E> implements Serializable

serialVersionUID: 1530674583602358482L

Serialization Methods

writeReplace

private Object writeReplace()
Allows instances to be deserialized in pre-1.4 JREs (which do not have SynchronizedRandomAccessList). SynchronizedList has a readResolve method that inverts this transformation upon deserialization.

Class java.util.Collections.SynchronizedSet extends java.util.Collections.SynchronizedCollection<E> implements Serializable

serialVersionUID: 487447009682186044L

Class java.util.Collections.SynchronizedSortedMap extends java.util.Collections.SynchronizedMap<K,V> implements Serializable

serialVersionUID: -8798146769416483793L

Serialized Fields

sm

SortedMap<K,V> sm

Class java.util.Collections.SynchronizedSortedSet extends java.util.Collections.SynchronizedSet<E> implements Serializable

serialVersionUID: 8695801310862127406L

Serialized Fields

ss

SortedSet<E> ss

Class java.util.Collections.UnmodifiableCollection extends Object implements Serializable

serialVersionUID: 1820017752578914078L

Serialized Fields

c

Collection<E> c

Class java.util.Collections.UnmodifiableList extends java.util.Collections.UnmodifiableCollection<E> implements Serializable

serialVersionUID: -283967356065247728L

Serialization Methods

readResolve

private Object readResolve()
UnmodifiableRandomAccessList instances are serialized as UnmodifiableList instances to allow them to be deserialized in pre-1.4 JREs (which do not have UnmodifiableRandomAccessList). This method inverts the transformation. As a beneficial side-effect, it also grafts the RandomAccess marker onto UnmodifiableList instances that were serialized in pre-1.4 JREs. Note: Unfortunately, UnmodifiableRandomAccessList instances serialized in 1.4.1 and deserialized in 1.4 will become UnmodifiableList instances, as this method was missing in 1.4.

Serialized Fields

list

List<E> list

Class java.util.Collections.UnmodifiableMap extends Object implements Serializable

serialVersionUID: -1034234728574286014L

Serialized Fields

m

Map<K,V> m

Class java.util.Collections.UnmodifiableMap.UnmodifiableEntrySet extends java.util.Collections.UnmodifiableSet<Map.Entry<K,V>> implements Serializable

serialVersionUID: 7854390611657943733L

Class java.util.Collections.UnmodifiableRandomAccessList extends java.util.Collections.UnmodifiableList<E> implements Serializable

serialVersionUID: -2542308836966382001L

Serialization Methods

writeReplace

private Object writeReplace()
Allows instances to be deserialized in pre-1.4 JREs (which do not have UnmodifiableRandomAccessList). UnmodifiableList has a readResolve method that inverts this transformation upon deserialization.

Class java.util.Collections.UnmodifiableSet extends java.util.Collections.UnmodifiableCollection<E> implements Serializable

serialVersionUID: -9215047833775013803L

Class java.util.Collections.UnmodifiableSortedMap extends java.util.Collections.UnmodifiableMap<K,V> implements Serializable

serialVersionUID: -8806743815996713206L

Serialized Fields

sm

SortedMap<K,V> sm

Class java.util.Collections.UnmodifiableSortedSet extends java.util.Collections.UnmodifiableSet<E> implements Serializable

serialVersionUID: -4929149591599911165L

Serialized Fields

ss

SortedSet<E> ss

Class java.util.ConcurrentModificationException extends RuntimeException implements Serializable

serialVersionUID: -3666751008965953603L

Class java.util.Currency extends Object implements Serializable

serialVersionUID: -158308464356906721L

Serialization Methods

readResolve

private Object readResolve()
Resolves instances being deserialized to a single instance per currency.

Serialized Fields

currencyCode

String currencyCode
ISO 4217 currency code for this currency.

Class java.util.Date extends Object implements Serializable

serialVersionUID: 7523967970034938905L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reconstitute this object from a stream (i.e., deserialize it).

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Save the state of this object to a stream (i.e., serialize it).

Serial Data:
The value returned by getTime() is emitted (long). This represents the offset from January 1, 1970, 00:00:00 GMT in milliseconds.
Throws:
IOException

Class java.util.DuplicateFormatFlagsException extends IllegalFormatException implements Serializable

serialVersionUID: 18890531L

Serialized Fields

flags

String flags

Class java.util.EmptyStackException extends RuntimeException implements Serializable

serialVersionUID: 5084686378493302095L

Class java.util.EnumMap extends AbstractMap<K extends Enum<K>,V> implements Serializable

serialVersionUID: 458661240069192865L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reconstitute the EnumMap instance from a stream (i.e., deserialize it).

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Save the state of the EnumMap instance to a stream (i.e., serialize it).

Serial Data:
The size of the enum map (the number of key-value mappings) is emitted (int), followed by the key (Object) and value (Object) for each key-value mapping represented by the enum map.
Throws:
IOException
Serialized Fields

keyType

Class<T> keyType
The Class object for the enum type of all the keys of this map.

Class java.util.EnumSet.SerializationProxy extends Object implements Serializable

serialVersionUID: 362491234563181265L

Serialization Methods

readResolve

private Object readResolve()
Serialized Fields

elementType

Class<T> elementType
The element type of this enum set.

elements

Enum<E extends Enum<E>>[] elements
The elements contained in this enum set.

Class java.util.EventObject extends Object implements Serializable

serialVersionUID: 5516075349620653480L

Class java.util.FormatFlagsConversionMismatchException extends IllegalFormatException implements Serializable

serialVersionUID: 19120414L

Serialized Fields

f

String f

c

char c

Class java.util.FormatterClosedException extends IllegalStateException implements Serializable

serialVersionUID: 18111216L

Class java.util.GregorianCalendar extends Calendar implements Serializable

serialVersionUID: -8125100834729963327L

Serialization Methods

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
Updates internal state.

Throws:
IOException
ClassNotFoundException
Serialized Fields

gregorianCutover

long gregorianCutover
The point at which the Gregorian calendar rules are used, measured in milliseconds from the standard epoch. Default is October 15, 1582 (Gregorian) 00:00:00 UTC or -12219292800000L. For this value, October 4, 1582 (Julian) is followed by October 15, 1582 (Gregorian). This corresponds to Julian day number 2299161.

Class java.util.HashMap extends AbstractMap<K,V> implements Serializable

serialVersionUID: 362498820763181265L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reconstitute the HashMap instance from a stream (i.e., deserialize it).

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Save the state of the HashMap instance to a stream (i.e., serialize it).

Serial Data:
The capacity of the HashMap (the length of the bucket array) is emitted (int), followed by the size (an int, the number of key-value mappings), followed by the key (Object) and value (Object) for each key-value mapping. The key-value mappings are emitted in no particular order.
Throws:
IOException
Serialized Fields

threshold

int threshold
The next size value at which to resize (capacity * load factor).

loadFactor

float loadFactor
The load factor for the hash table.

Class java.util.HashSet extends AbstractSet<E> implements Serializable

serialVersionUID: -5024744406713321676L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reconstitute the HashSet instance from a stream (that is, deserialize it).

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Save the state of this HashSet instance to a stream (that is, serialize it).

Serial Data:
The capacity of the backing HashMap instance (int), and its load factor (float) are emitted, followed by the size of the set (the number of elements it contains) (int), followed by all of its elements (each an Object) in no particular order.
Throws:
IOException

Class java.util.Hashtable extends Dictionary<K,V> implements Serializable

serialVersionUID: 1421746759512286392L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reconstitute the Hashtable from a stream (i.e., deserialize it).

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Save the state of the Hashtable to a stream (i.e., serialize it).

Serial Data:
The capacity of the Hashtable (the length of the bucket array) is emitted (int), followed by the size of the Hashtable (the number of key-value mappings), followed by the key (Object) and value (Object) for each key-value mapping represented by the Hashtable The key-value mappings are emitted in no particular order.
Throws:
IOException
Serialized Fields

threshold

int threshold
The table is rehashed when its size exceeds this threshold. (The value of this field is (int)(capacity * loadFactor).)

loadFactor

float loadFactor
The load factor for the hashtable.

Class java.util.IdentityHashMap extends AbstractMap<K,V> implements Serializable

serialVersionUID: 8188218128353913216L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reconstitute the IdentityHashMap instance from a stream (i.e., deserialize it).

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Save the state of the IdentityHashMap instance to a stream (i.e., serialize it).

Serial Data:
The size of the HashMap (the number of key-value mappings) (int), followed by the key (Object) and value (Object) for each key-value mapping represented by the IdentityHashMap. The key-value mappings are emitted in no particular order.
Throws:
IOException
Serialized Fields

size

int size
The number of key-value mappings contained in this identity hash map.

Class java.util.IllegalFormatCodePointException extends IllegalFormatException implements Serializable

serialVersionUID: 19080630L

Serialized Fields

c

int c

Class java.util.IllegalFormatConversionException extends IllegalFormatException implements Serializable

serialVersionUID: 17000126L

Serialized Fields

c

char c

arg

Class<T> arg

Class java.util.IllegalFormatException extends IllegalArgumentException implements Serializable

serialVersionUID: 18830826L

Class java.util.IllegalFormatFlagsException extends IllegalFormatException implements Serializable

serialVersionUID: 790824L

Serialized Fields

flags

String flags

Class java.util.IllegalFormatPrecisionException extends IllegalFormatException implements Serializable

serialVersionUID: 18711008L

Serialized Fields

p

int p

Class java.util.IllegalFormatWidthException extends IllegalFormatException implements Serializable

serialVersionUID: 16660902L

Serialized Fields

w

int w

Class java.util.InputMismatchException extends NoSuchElementException implements Serializable

serialVersionUID: 8811230760997066428L

Class java.util.LinkedHashMap extends HashMap<K,V> implements Serializable

serialVersionUID: 3801124242820219131L

Serialized Fields

accessOrder

boolean accessOrder
The iteration ordering method for this linked hash map: true for access-order, false for insertion-order.

Class java.util.LinkedHashSet extends HashSet<E> implements Serializable

serialVersionUID: -2851667679971038690L

Class java.util.LinkedList extends AbstractSequentialList<E> implements Serializable

serialVersionUID: 876323262645176354L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reconstitute this LinkedList instance from a stream (that is deserialize it).

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Save the state of this LinkedList instance to a stream (that is, serialize it).

Serial Data:
The size of the list (the number of elements it contains) is emitted (int), followed by all of its elements (each an Object) in the proper order.
Throws:
IOException

Class java.util.Locale extends Object implements Serializable

serialVersionUID: 9149081749638150636L

Serialization Methods

readResolve

private Object readResolve()
                    throws ObjectStreamException
Replace the deserialized Locale object with a newly created object. Newer language codes are replaced with older ISO codes. The country and variant codes are replaced with internalized String copies.

Throws:
ObjectStreamException
Serialized Fields

language

String language
See Also:
Locale.getLanguage()

country

String country
See Also:
Locale.getCountry()

variant

String variant
See Also:
Locale.getVariant()

hashcode

int hashcode
Placeholder for the object's hash code. Always -1.

Class java.util.MissingFormatArgumentException extends IllegalFormatException implements Serializable

serialVersionUID: 19190115L

Serialized Fields

s

String s

Class java.util.MissingFormatWidthException extends IllegalFormatException implements Serializable

serialVersionUID: 15560123L

Serialized Fields

s

String s

Class java.util.MissingResourceException extends RuntimeException implements Serializable

serialVersionUID: -4876345176062000401L

Serialized Fields

className

String className
The class name of the resource bundle requested by the user.

key

String key
The name of the specific resource requested by the user.

Class java.util.NoSuchElementException extends RuntimeException implements Serializable

serialVersionUID: 6769829250639411880L

Class java.util.PriorityQueue extends AbstractQueue<E> implements Serializable

serialVersionUID: -7720805057305804111L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reconstitutes the PriorityQueue instance from a stream (that is, deserializes it).

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Saves the state of the instance to a stream (that is, serializes it).

Serial Data:
The length of the array backing the instance is emitted (int), followed by all of its elements (each an Object) in the proper order.
Throws:
IOException
Serialized Fields

size

int size
The number of elements in the priority queue.

comparator

Comparator<T> comparator
The comparator, or null if priority queue uses elements' natural ordering.

Class java.util.Properties extends Hashtable<Object,Object> implements Serializable

serialVersionUID: 4112578634029874840L

Serialized Fields

defaults

Properties defaults
A property list that contains default values for any keys not found in this property list.

Class java.util.PropertyPermissionCollection extends PermissionCollection implements Serializable

serialVersionUID: 7015263904581634791L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serial Data:
Default fields.
Throws:
IOException
Serialized Fields

all_allowed

boolean all_allowed
boolean saying if "*" is in the collection.

permissions

Hashtable<K,V> permissions
A table of the PropertyPermissions.

Class java.util.Random extends Object implements Serializable

serialVersionUID: 3905348978240129619L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reconstitute the Random instance from a stream (that is, deserialize it).

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Save the Random instance to a stream.

Throws:
IOException
Serialization Overview
Serializable fields for Random.

Serialized Fields

haveNextNextGaussian

boolean haveNextNextGaussian
nextNextGaussian is valid

nextNextGaussian

double nextNextGaussian
next Gaussian to be returned

seed

long seed
seed for random computations

Class java.util.ServiceConfigurationError extends Error implements Serializable

serialVersionUID: 74132770414881L

Class java.util.SimpleTimeZone extends TimeZone implements Serializable

serialVersionUID: -403250971215465050L

Serialization Methods

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
Reconstitute this object from a stream (i.e., deserialize it). We handle both JDK 1.1 binary formats and full formats with a packed byte array.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream stream)
                  throws IOException
Save the state of this object to a stream (i.e., serialize it).

Serial Data:
We write out two formats, a JDK 1.1 compatible format, using DOW_IN_MONTH_MODE rules, in the required section, followed by the full rules, in packed format, in the optional section. The optional section will be ignored by JDK 1.1 code upon stream in.

Contents of the optional section: The length of a byte array is emitted (int); this is 4 as of this release. The byte array of the given length is emitted. The contents of the byte array are the true values of the fields startDay, startDayOfWeek, endDay, and endDayOfWeek. The values of these fields in the required section are approximate values suited to the rule mode DOW_IN_MONTH_MODE, which is the only mode recognized by JDK 1.1.

Throws:
IOException
Serialized Fields

startMonth

int startMonth
The month in which daylight saving time starts. This value must be between Calendar.JANUARY and Calendar.DECEMBER inclusive. This value must not equal endMonth.

If useDaylight is false, this value is ignored.

startDay

int startDay
This field has two possible interpretations:
startMode == DOW_IN_MONTH
startDay indicates the day of the month of startMonth on which daylight saving time starts, from 1 to 28, 30, or 31, depending on the startMonth.
startMode != DOW_IN_MONTH
startDay indicates which startDayOfWeek in the month startMonth daylight saving time starts on. For example, a value of +1 and a startDayOfWeek of Calendar.SUNDAY indicates the first Sunday of startMonth. Likewise, +2 would indicate the second Sunday, and -1 the last Sunday. A value of 0 is illegal.

If useDaylight is false, this value is ignored.

startDayOfWeek

int startDayOfWeek
The day of the week on which daylight saving time starts. This value must be between Calendar.SUNDAY and Calendar.SATURDAY inclusive.

If useDaylight is false or startMode == DAY_OF_MONTH, this value is ignored.

startTime

int startTime
The time in milliseconds after midnight at which daylight saving time starts. This value is expressed as wall time, standard time, or UTC time, depending on the setting of startTimeMode.

If useDaylight is false, this value is ignored.

startTimeMode

int startTimeMode
The format of startTime, either WALL_TIME, STANDARD_TIME, or UTC_TIME.

Since:
1.3

endMonth

int endMonth
The month in which daylight saving time ends. This value must be between Calendar.JANUARY and Calendar.UNDECIMBER. This value must not equal startMonth.

If useDaylight is false, this value is ignored.

endDay

int endDay
This field has two possible interpretations:
endMode == DOW_IN_MONTH
endDay indicates the day of the month of endMonth on which daylight saving time ends, from 1 to 28, 30, or 31, depending on the endMonth.
endMode != DOW_IN_MONTH
endDay indicates which endDayOfWeek in th month endMonth daylight saving time ends on. For example, a value of +1 and a endDayOfWeek of Calendar.SUNDAY indicates the first Sunday of endMonth. Likewise, +2 would indicate the second Sunday, and -1 the last Sunday. A value of 0 is illegal.

If useDaylight is false, this value is ignored.

endDayOfWeek

int endDayOfWeek
The day of the week on which daylight saving time ends. This value must be between Calendar.SUNDAY and Calendar.SATURDAY inclusive.

If useDaylight is false or endMode == DAY_OF_MONTH, this value is ignored.

endTime

int endTime
The time in milliseconds after midnight at which daylight saving time ends. This value is expressed as wall time, standard time, or UTC time, depending on the setting of endTimeMode.

If useDaylight is false, this value is ignored.

endTimeMode

int endTimeMode
The format of endTime, either WALL_TIME, STANDARD_TIME, or UTC_TIME.

Since:
1.3

startYear

int startYear
The year in which daylight saving time is first observed. This is an AD value. If this value is less than 1 then daylight saving time is observed for all AD years.

If useDaylight is false, this value is ignored.

rawOffset

int rawOffset
The offset in milliseconds between this zone and GMT. Negative offsets are to the west of Greenwich. To obtain local standard time, add the offset to GMT time. To obtain local wall time it may also be necessary to add dstSavings.

useDaylight

boolean useDaylight
A boolean value which is true if and only if this zone uses daylight saving time. If this value is false, several other fields are ignored.

monthLength

byte[] monthLength
This field was serialized in JDK 1.1, so we have to keep it that way to maintain serialization compatibility. However, there's no need to recreate the array each time we create a new time zone.

An array of bytes containing the values {31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31}. This is ignored as of the Java 2 platform v1.2, however, it must be streamed out for compatibility with JDK 1.1.

startMode

int startMode
Variables specifying the mode of the start rule. Takes the following values:
DOM_MODE
Exact day of week; e.g., March 1.
DOW_IN_MONTH_MODE
Day of week in month; e.g., last Sunday in March.
DOW_GE_DOM_MODE
Day of week after day of month; e.g., Sunday on or after March 15.
DOW_LE_DOM_MODE
Day of week before day of month; e.g., Sunday on or before March 15.
The setting of this field affects the interpretation of the startDay field.

If useDaylight is false, this value is ignored.

Since:
1.1.4

endMode

int endMode
Variables specifying the mode of the end rule. Takes the following values:
DOM_MODE
Exact day of week; e.g., March 1.
DOW_IN_MONTH_MODE
Day of week in month; e.g., last Sunday in March.
DOW_GE_DOM_MODE
Day of week after day of month; e.g., Sunday on or after March 15.
DOW_LE_DOM_MODE
Day of week before day of month; e.g., Sunday on or before March 15.
The setting of this field affects the interpretation of the endDay field.

If useDaylight is false, this value is ignored.

Since:
1.1.4

dstSavings

int dstSavings
A positive value indicating the amount of time saved during DST in milliseconds. Typically one hour (3600000); sometimes 30 minutes (1800000).

If useDaylight is false, this value is ignored.

Since:
1.1.4

serialVersionOnStream

int serialVersionOnStream
The version of the serialized data on the stream. Possible values:
0 or not present on stream
JDK 1.1.3 or earlier.
1
JDK 1.1.4 or later. Includes three new fields: startMode, endMode, and dstSavings.
2
JDK 1.3 or later. Includes two new fields: startTimeMode and endTimeMode.
When streaming out this class, the most recent format and the highest allowable serialVersionOnStream is written.

Since:
1.1.4

Class java.util.Stack extends Vector<E> implements Serializable

serialVersionUID: 1224463164541339165L

Class java.util.TimeZone extends Object implements Serializable

serialVersionUID: 3581463369166924961L

Serialized Fields

ID

String ID
The string identifier of this TimeZone. This is a programmatic identifier used internally to look up TimeZone objects from the system table and also to map them to their localized display names. ID values are unique in the system table but may not be for dynamically created zones.

Class java.util.TooManyListenersException extends Exception implements Serializable

serialVersionUID: 5074640544770687831L

Class java.util.TreeMap extends AbstractMap<K,V> implements Serializable

serialVersionUID: 919286545866124006L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reconstitute the TreeMap instance from a stream (i.e., deserialize it).

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Save the state of the TreeMap instance to a stream (i.e., serialize it).

Serial Data:
The size of the TreeMap (the number of key-value mappings) is emitted (int), followed by the key (Object) and value (Object) for each key-value mapping represented by the TreeMap. The key-value mappings are emitted in key-order (as determined by the TreeMap's Comparator, or by the keys' natural ordering if the TreeMap has no Comparator).
Throws:
IOException
Serialized Fields

comparator

Comparator<T> comparator
The comparator used to maintain order in this tree map, or null if it uses the natural ordering of its keys.

Class java.util.TreeMap.AscendingSubMap extends java.util.TreeMap.NavigableSubMap<K,V> implements Serializable

serialVersionUID: 912986545866124060L

Class java.util.TreeMap.DescendingSubMap extends java.util.TreeMap.NavigableSubMap<K,V> implements Serializable

serialVersionUID: 912986545866120460L

Serialized Fields

reverseComparator

Comparator<T> reverseComparator

Class java.util.TreeMap.NavigableSubMap extends AbstractMap<K,V> implements Serializable

Serialized Fields

m

TreeMap<K,V> m
The backing map.

lo

Object lo
Endpoints are represented as triples (fromStart, lo, loInclusive) and (toEnd, hi, hiInclusive). If fromStart is true, then the low (absolute) bound is the start of the backing map, and the other values are ignored. Otherwise, if loInclusive is true, lo is the inclusive bound, else lo is the exclusive bound. Similarly for the upper bound.

hi

Object hi
Endpoints are represented as triples (fromStart, lo, loInclusive) and (toEnd, hi, hiInclusive). If fromStart is true, then the low (absolute) bound is the start of the backing map, and the other values are ignored. Otherwise, if loInclusive is true, lo is the inclusive bound, else lo is the exclusive bound. Similarly for the upper bound.

fromStart

boolean fromStart

toEnd

boolean toEnd

loInclusive

boolean loInclusive

hiInclusive

boolean hiInclusive

Class java.util.TreeMap.SubMap extends AbstractMap<K,V> implements Serializable

serialVersionUID: -6520786458950516097L

Serialization Methods

readResolve

private Object readResolve()
Serialized Fields

fromStart

boolean fromStart

toEnd

boolean toEnd

fromKey

Object fromKey

toKey

Object toKey

Class java.util.TreeSet extends AbstractSet<E> implements Serializable

serialVersionUID: -2479143000061671589L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reconstitute the TreeSet instance from a stream (that is, deserialize it).

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Save the state of the TreeSet instance to a stream (that is, serialize it).

Serial Data:
Emits the comparator used to order this set, or null if it obeys its elements' natural ordering (Object), followed by the size of the set (the number of elements it contains) (int), followed by all of its elements (each an Object) in order (as determined by the set's Comparator, or by the elements' natural ordering if the set has no Comparator).
Throws:
IOException

Class java.util.UnknownFormatConversionException extends IllegalFormatException implements Serializable

serialVersionUID: 19060418L

Serialized Fields

s

String s

Class java.util.UnknownFormatFlagsException extends IllegalFormatException implements Serializable

serialVersionUID: 19370506L

Serialized Fields

flags

String flags

Class java.util.UUID extends Object implements Serializable

serialVersionUID: -4856846361193249489L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Reconstitute the UUID instance from a stream (that is, deserialize it). This is necessary to set the transient fields to their correct uninitialized value so they will be recomputed on demand.

Throws:
IOException
ClassNotFoundException
Serialized Fields

mostSigBits

long mostSigBits

leastSigBits

long leastSigBits

Class java.util.Vector extends AbstractList<E> implements Serializable

serialVersionUID: -2767605614048989439L

Serialization Methods

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Save the state of the Vector instance to a stream (that is, serialize it). This method is present merely for synchronization. It just calls the default writeObject method.

Throws:
IOException
Serialized Fields

elementData

Object[] elementData
The array buffer into which the components of the vector are stored. The capacity of the vector is the length of this array buffer, and is at least large enough to contain all the vector's elements.

Any array elements following the last element in the Vector are null.

elementCount

int elementCount
The number of valid components in this Vector object. Components elementData[0] through elementData[elementCount-1] are the actual items.

capacityIncrement

int capacityIncrement
The amount by which the capacity of the vector is automatically incremented when its size becomes greater than its capacity. If the capacity increment is less than or equal to zero, the capacity of the vector is doubled each time it needs to grow.

Package java.util.concurrent

Class java.util.concurrent.ArrayBlockingQueue extends AbstractQueue<E> implements Serializable

serialVersionUID: -817911632652898426L

Serialized Fields

items

Object[] items
The queued items

takeIndex

int takeIndex
items index for next take, poll or remove

putIndex

int putIndex
items index for next put, offer, or add.

count

int count
Number of items in the queue

lock

ReentrantLock lock
Main lock guarding all access

notEmpty

Condition notEmpty
Condition for waiting takes

notFull

Condition notFull
Condition for waiting puts

Class java.util.concurrent.BrokenBarrierException extends Exception implements Serializable

serialVersionUID: 7117394618823254244L

Class java.util.concurrent.CancellationException extends IllegalStateException implements Serializable

serialVersionUID: -9202173006928992231L

Class java.util.concurrent.ConcurrentHashMap extends AbstractMap<K,V> implements Serializable

serialVersionUID: 7249069246763182397L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reconstitute the ConcurrentHashMap instance from a stream (i.e., deserialize it).

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Save the state of the ConcurrentHashMap instance to a stream (i.e., serialize it).

Serial Data:
the key (Object) and value (Object) for each key-value mapping, followed by a null pair. The key-value mappings are emitted in no particular order.
Throws:
IOException
Serialized Fields

segmentMask

int segmentMask
Mask value for indexing into segments. The upper bits of a key's hash code are used to choose the segment.

segmentShift

int segmentShift
Shift value for indexing within segments.

segments

java.util.concurrent.ConcurrentHashMap.Segment<K,V>[] segments
The segments, each of which is a specialized hash table

Class java.util.concurrent.ConcurrentLinkedQueue extends AbstractQueue<E> implements Serializable

serialVersionUID: 196745693267521676L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reconstitute the Queue instance from a stream (that is, deserialize it).

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Save the state to a stream (that is, serialize it).

Serial Data:
All of the elements (each an E) in the proper order, followed by a null
Throws:
IOException

Class java.util.concurrent.ConcurrentSkipListMap extends AbstractMap<K,V> implements Serializable

serialVersionUID: -8627078645895051609L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reconstitute the map from a stream.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Save the state of this map to a stream.

Serial Data:
The key (Object) and value (Object) for each key-value mapping represented by the map, followed by null. The key-value mappings are emitted in key-order (as determined by the Comparator, or by the keys' natural ordering if no Comparator).
Throws:
IOException
Serialized Fields

comparator

Comparator<T> comparator
The comparator used to maintain order in this map, or null if using natural ordering.

Class java.util.concurrent.ConcurrentSkipListMap.SubMap extends AbstractMap<K,V> implements Serializable

serialVersionUID: -7647078645895051609L

Serialized Fields

m

ConcurrentSkipListMap<K,V> m
Underlying map

lo

Object lo
lower bound key, or null if from start

hi

Object hi
upper bound key, or null if to end

loInclusive

boolean loInclusive
inclusion flag for lo

hiInclusive

boolean hiInclusive
inclusion flag for hi

isDescending

boolean isDescending
direction

Class java.util.concurrent.ConcurrentSkipListSet extends AbstractSet<E> implements Serializable

serialVersionUID: -2479143111061671589L

Serialized Fields

m

ConcurrentNavigableMap<K,V> m
The underlying map. Uses Boolean.TRUE as value for each element. This field is declared final for the sake of thread safety, which entails some ugliness in clone()

Class java.util.concurrent.CopyOnWriteArrayList extends Object implements Serializable

serialVersionUID: 8673264195747942595L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reconstitute the list from a stream (i.e., deserialize it).

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Save the state of the list to a stream (i.e., serialize it).

Serial Data:
The length of the array backing the list is emitted (int), followed by all of its elements (each an Object) in the proper order.
Throws:
IOException

Class java.util.concurrent.CopyOnWriteArraySet extends AbstractSet<E> implements Serializable

serialVersionUID: 5457747651344034263L

Serialized Fields

al

CopyOnWriteArrayList<E> al

Class java.util.concurrent.ExecutionException extends Exception implements Serializable

serialVersionUID: 7830266012832686185L

Class java.util.concurrent.LinkedBlockingDeque extends AbstractQueue<E> implements Serializable

serialVersionUID: -387911632671998426L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reconstitute this deque from a stream (that is, deserialize it).

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Save the state of this deque to a stream (that is, serialize it).

Serial Data:
The capacity (int), followed by elements (each an Object) in the proper order, followed by a null
Throws:
IOException
Serialized Fields

capacity

int capacity
Maximum number of items in the deque

lock

ReentrantLock lock
Main lock guarding all access

notEmpty

Condition notEmpty
Condition for waiting takes

notFull

Condition notFull
Condition for waiting puts

Class java.util.concurrent.LinkedBlockingQueue extends AbstractQueue<E> implements Serializable

serialVersionUID: -6903933977591709194L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reconstitute this queue instance from a stream (that is, deserialize it).

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Save the state to a stream (that is, serialize it).

Serial Data:
The capacity is emitted (int), followed by all of its elements (each an Object) in the proper order, followed by a null
Throws:
IOException
Serialized Fields

capacity

int capacity
The capacity bound, or Integer.MAX_VALUE if none

count

AtomicInteger count
Current number of elements

takeLock

ReentrantLock takeLock
Lock held by take, poll, etc

notEmpty

Condition notEmpty
Wait queue for waiting takes

putLock

ReentrantLock putLock
Lock held by put, offer, etc

notFull

Condition notFull
Wait queue for waiting puts

Class java.util.concurrent.PriorityBlockingQueue extends AbstractQueue<E> implements Serializable

serialVersionUID: 5595510919245408276L

Serialization Methods

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Saves the state to a stream (that is, serializes it). This merely wraps default serialization within lock. The serialization strategy for items is left to underlying Queue. Note that locking is not needed on deserialization, so readObject is not defined, just relying on default.

Throws:
IOException
Serialized Fields

q

PriorityQueue<E> q

lock

ReentrantLock lock

notEmpty

Condition notEmpty

Class java.util.concurrent.RejectedExecutionException extends RuntimeException implements Serializable

serialVersionUID: -375805702767069545L

Class java.util.concurrent.Semaphore extends Object implements Serializable

serialVersionUID: -3222578661600680210L

Serialized Fields

sync

java.util.concurrent.Semaphore.Sync sync
All mechanics via AbstractQueuedSynchronizer subclass

Class java.util.concurrent.SynchronousQueue extends AbstractQueue<E> implements Serializable

serialVersionUID: -3223113410248163686L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Save the state to a stream (that is, serialize it).

Throws:
IOException
Serialized Fields

qlock

ReentrantLock qlock

waitingProducers

java.util.concurrent.SynchronousQueue.WaitQueue waitingProducers

waitingConsumers

java.util.concurrent.SynchronousQueue.WaitQueue waitingConsumers

Class java.util.concurrent.TimeoutException extends Exception implements Serializable

serialVersionUID: 1900926677490660714L

Package java.util.concurrent.atomic

Class java.util.concurrent.atomic.AtomicBoolean extends Object implements Serializable

serialVersionUID: 4654671469794556979L

Serialized Fields

value

int value

Class java.util.concurrent.atomic.AtomicInteger extends Number implements Serializable

serialVersionUID: 6214790243416807050L

Serialized Fields

value

int value

Class java.util.concurrent.atomic.AtomicIntegerArray extends Object implements Serializable

serialVersionUID: 2862133569453604235L

Serialized Fields

array

int[] array

Class java.util.concurrent.atomic.AtomicLong extends Number implements Serializable

serialVersionUID: 1927816293512124184L

Serialized Fields

value

long value

Class java.util.concurrent.atomic.AtomicLongArray extends Object implements Serializable

serialVersionUID: -2308431214976778248L

Serialized Fields

array

long[] array

Class java.util.concurrent.atomic.AtomicReference extends Object implements Serializable

serialVersionUID: -1848883965231344442L

Serialized Fields

value

Object value

Class java.util.concurrent.atomic.AtomicReferenceArray extends Object implements Serializable

serialVersionUID: -6209656149925076980L

Serialized Fields

array

Object[] array
Package java.util.concurrent.locks

Class java.util.concurrent.locks.AbstractOwnableSynchronizer extends Object implements Serializable

serialVersionUID: 3737899427754241961L

Class java.util.concurrent.locks.AbstractQueuedLongSynchronizer extends AbstractOwnableSynchronizer implements Serializable

serialVersionUID: 7373984972572414692L

Serialized Fields

state

long state
The synchronization state.

Class java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject extends Object implements Serializable

serialVersionUID: 1173984872572414699L

Class java.util.concurrent.locks.AbstractQueuedSynchronizer extends AbstractOwnableSynchronizer implements Serializable

serialVersionUID: 7373984972572414691L

Serialized Fields

state

int state
The synchronization state.

Class java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject extends Object implements Serializable

serialVersionUID: 1173984872572414699L

Class java.util.concurrent.locks.ReentrantLock extends Object implements Serializable

serialVersionUID: 7373984872572414699L

Serialized Fields

sync

java.util.concurrent.locks.ReentrantLock.Sync sync
Synchronizer providing all implementation mechanics

Class java.util.concurrent.locks.ReentrantReadWriteLock extends Object implements Serializable

serialVersionUID: -6992448646407690164L

Serialized Fields

readerLock

ReentrantReadWriteLock.ReadLock readerLock
Inner class providing readlock

writerLock

ReentrantReadWriteLock.WriteLock writerLock
Inner class providing writelock

sync

java.util.concurrent.locks.ReentrantReadWriteLock.Sync sync
Performs all synchronization mechanics

Class java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock extends Object implements Serializable

serialVersionUID: -5992448646407690164L

Serialized Fields

sync

java.util.concurrent.locks.ReentrantReadWriteLock.Sync sync

Class java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock extends Object implements Serializable

serialVersionUID: -4992448646407690164L

Serialized Fields

sync

java.util.concurrent.locks.ReentrantReadWriteLock.Sync sync
Package java.util.jar

Class java.util.jar.JarException extends ZipException implements Serializable

serialVersionUID: 7159778400963954473L

Package java.util.logging

Class java.util.logging.Level extends Object implements Serializable

serialVersionUID: -8176160795706313070L

Serialization Methods

readResolve

private Object readResolve()
Serialized Fields

name

String name
The non-localized name of the level.

value

int value
The integer value of the level.

resourceBundleName

String resourceBundleName
The resource bundle name to be used in localizing the level name.

Class java.util.logging.LoggingPermission extends BasicPermission implements Serializable

serialVersionUID: 63564341580231582L

Class java.util.logging.LogRecord extends Object implements Serializable

serialVersionUID: 5372048053134512534L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serial Data:
Default fields, followed by a two byte version number (major byte, followed by minor byte), followed by information on the log record parameter array. If there is no parameter array, then -1 is written. If there is a parameter array (possible of zero length) then the array length is written as an integer, followed by String values for each parameter. If a parameter is null, then a null String is written. Otherwise the output of Object.toString() is written.
Throws:
IOException
Serialized Fields

level

Level level
Logging message level

sequenceNumber

long sequenceNumber
Sequence number

sourceClassName

String sourceClassName
Class that issued logging call

sourceMethodName

String sourceMethodName
Method that issued logging call

message

String message
Non-localized raw message text

threadID

int threadID
Thread ID for thread that issued logging call.

millis

long millis
Event time in milliseconds since 1970

thrown

Throwable thrown
The Throwable (if any) associated with log message

loggerName

String loggerName
Name of the source Logger.

resourceBundleName

String resourceBundleName
Resource bundle name to localized log message.
Package java.util.prefs

Class java.util.prefs.BackingStoreException extends Exception implements Serializable

serialVersionUID: 859796500401108469L

Class java.util.prefs.InvalidPreferencesFormatException extends Exception implements Serializable

serialVersionUID: -791715184232119669L

Package java.util.regex

Class java.util.regex.Pattern extends Object implements Serializable

serialVersionUID: 5073258162644648461L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Recompile the Pattern instance from a stream. The original pattern string is read in and the object tree is recompiled from it.

Throws:
IOException
ClassNotFoundException
Serialized Fields

pattern

String pattern
The original regular-expression pattern string.

flags

int flags
The original pattern flags.

Class java.util.regex.PatternSyntaxException extends IllegalArgumentException implements Serializable

serialVersionUID: -3864639126226059218L

Serialized Fields

desc

String desc

pattern

String pattern

index

int index
Package java.util.zip

Class java.util.zip.DataFormatException extends Exception implements Serializable

serialVersionUID: 2219632870893641452L

Class java.util.zip.ZipError extends InternalError implements Serializable

serialVersionUID: 853973422266861979L

Class java.util.zip.ZipException extends IOException implements Serializable

serialVersionUID: 8000196834066748623L

Package javax.activation

Class javax.activation.ActivationDataFlavor extends DataFlavor implements Serializable

Serialization Methods

readExternal

public void readExternal(ObjectInput is)
                  throws IOException,
                         ClassNotFoundException
Restores this DataFlavor from a Serialized state.

Throws:
IOException - if I/O errors occur
ClassNotFoundException - If the class for an object being restored cannot be found.

writeExternal

public void writeExternal(ObjectOutput os)
                   throws IOException
Serializes this DataFlavor.

Throws:
IOException - Includes any I/O exceptions that may occur

Class javax.activation.MimeType extends Object implements Serializable

Serialization Methods

readExternal

public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException
The object implements the readExternal method to restore its contents by calling the methods of DataInput for primitive types and readObject for objects, strings and arrays. The readExternal method must read the values in the same sequence and with the same types as were written by writeExternal.

Throws:
ClassNotFoundException - If the class for an object being restored cannot be found.
IOException - if I/O errors occur

writeExternal

public void writeExternal(ObjectOutput out)
                   throws IOException
The object implements the writeExternal method to save its contents by calling the methods of DataOutput for its primitive values or calling the writeObject method of ObjectOutput for objects, strings and arrays.

Throws:
IOException - Includes any I/O exceptions that may occur

Class javax.activation.MimeTypeParseException extends Exception implements Serializable

Class javax.activation.UnsupportedDataTypeException extends IOException implements Serializable

Package javax.activity

Class javax.activity.ActivityCompletedException extends RemoteException implements Serializable

Class javax.activity.ActivityRequiredException extends RemoteException implements Serializable

Class javax.activity.InvalidActivityException extends RemoteException implements Serializable

Package javax.annotation.processing

Class javax.annotation.processing.FilerException extends IOException implements Serializable

serialVersionUID: 8426423106453163293L

Package javax.crypto

Class javax.crypto.BadPaddingException extends GeneralSecurityException implements Serializable

serialVersionUID: -5315033893984728443L

Class javax.crypto.ExemptionMechanismException extends GeneralSecurityException implements Serializable

serialVersionUID: 1572699429277957109L

Class javax.crypto.IllegalBlockSizeException extends GeneralSecurityException implements Serializable

serialVersionUID: -1965144811953540392L

Class javax.crypto.NoSuchPaddingException extends GeneralSecurityException implements Serializable

serialVersionUID: -4572885201200175466L

Class javax.crypto.SealedObject extends Object implements Serializable

serialVersionUID: 4482838265551344752L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Restores the state of the SealedObject from a stream.

Throws:
NullPointerException - if s is null.
IOException
ClassNotFoundException
Serialized Fields

encryptedContent

byte[] encryptedContent
The serialized object contents in encrypted format.

sealAlg

String sealAlg
The algorithm that was used to seal this object.

paramsAlg

String paramsAlg
The algorithm of the parameters used.

encodedParams

byte[] encodedParams
The cryptographic parameters used by the sealing Cipher, encoded in the default format.

That is, cipher.getParameters().getEncoded().

Class javax.crypto.ShortBufferException extends GeneralSecurityException implements Serializable

serialVersionUID: 8427718640832943747L

Package javax.crypto.interfaces
Package javax.crypto.spec

Class javax.crypto.spec.SecretKeySpec extends Object implements Serializable

serialVersionUID: 6577238317307289933L

Serialized Fields

key

byte[] key
The secret key.

algorithm

String algorithm
The name of the algorithm associated with this key.

Package javax.imageio

Class javax.imageio.IIOException extends IOException implements Serializable

Package javax.imageio.metadata

Class javax.imageio.metadata.IIOInvalidTreeException extends IIOException implements Serializable

Serialized Fields

offendingNode

Node offendingNode
The Node that led to the parsing error, or null.

Package javax.lang.model

Class javax.lang.model.UnknownEntityException extends RuntimeException implements Serializable

serialVersionUID: 269L

Package javax.lang.model.element

Class javax.lang.model.element.UnknownAnnotationValueException extends UnknownEntityException implements Serializable

serialVersionUID: 269L

Class javax.lang.model.element.UnknownElementException extends UnknownEntityException implements Serializable

serialVersionUID: 269L

Package javax.lang.model.type

Class javax.lang.model.type.MirroredTypeException extends RuntimeException implements Serializable

serialVersionUID: 269L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Explicitly set all transient fields.

Throws:
IOException
ClassNotFoundException

Class javax.lang.model.type.MirroredTypesException extends RuntimeException implements Serializable

serialVersionUID: 269L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Explicitly set all transient fields.

Throws:
IOException
ClassNotFoundException

Class javax.lang.model.type.UnknownTypeException extends UnknownEntityException implements Serializable

serialVersionUID: 269L

Package javax.management

Class javax.management.AndQueryExp extends QueryEval implements Serializable

serialVersionUID: -1081892073854801359L

Serialized Fields

exp1

QueryExp exp1
The first QueryExp of the conjunction

exp2

QueryExp exp2
The second QueryExp of the conjunction

Class javax.management.Attribute extends Object implements Serializable

serialVersionUID: 2484220110589082382L

Serialized Fields

name

String name
Attribute name.

value

Object value
Attribute value

Class javax.management.AttributeChangeNotification extends Notification implements Serializable

serialVersionUID: 535176054565814134L

Serialized Fields

attributeName

String attributeName
The MBean attribute name.

attributeType

String attributeType
The MBean attribute type.

oldValue

Object oldValue
The MBean attribute old value.

newValue

Object newValue
The MBean attribute new value.

Class javax.management.AttributeChangeNotificationFilter extends Object implements Serializable

serialVersionUID: -6347317584796410029L

Serialized Fields

enabledAttributes

Vector<E> enabledAttributes
Vector that contains the enabled attribute names. The default value is an empty vector.

Class javax.management.AttributeList extends ArrayList<Object> implements Serializable

serialVersionUID: -4077085769279709076L

Class javax.management.AttributeNotFoundException extends OperationsException implements Serializable

serialVersionUID: 6511584241791106926L

Class javax.management.AttributeValueExp extends Object implements Serializable

serialVersionUID: -7768025046539163385L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws ClassNotFoundException,
                        IOException
Throws:
ClassNotFoundException
IOException
Serialized Fields

attr

String attr
The name of the attribute

Class javax.management.BadAttributeValueExpException extends Exception implements Serializable

serialVersionUID: -3105272988410493376L

Serialized Fields

val

Object val
The attribute value that originated this exception

Class javax.management.BadBinaryOpValueExpException extends Exception implements Serializable

serialVersionUID: 5068475589449021227L

Serialized Fields

exp

ValueExp exp
the ValueExp that originated this exception

Class javax.management.BadStringOperationException extends Exception implements Serializable

serialVersionUID: 7802201238441662100L

Serialized Fields

op

String op
The description of the operation that originated this exception

Class javax.management.BetweenQueryExp extends QueryEval implements Serializable

serialVersionUID: -2933597532866307444L

Serialized Fields

exp1

ValueExp exp1
The checked value

exp2

ValueExp exp2
The lower bound value

exp3

ValueExp exp3
The upper bound value

Class javax.management.BinaryOpValueExp extends QueryEval implements Serializable

serialVersionUID: 1216286847881456786L

Serialized Fields

op

int op
The operator

exp1

ValueExp exp1
The first value

exp2

ValueExp exp2
The second value

Class javax.management.BinaryRelQueryExp extends QueryEval implements Serializable

serialVersionUID: -5690656271650491000L

Serialized Fields

relOp

int relOp
The operator

exp1

ValueExp exp1
The first value

exp2

ValueExp exp2
The second value

Class javax.management.BooleanValueExp extends QueryEval implements Serializable

serialVersionUID: 7754922052666594581L

Serialized Fields

val

boolean val
The boolean value

Class javax.management.ClassAttributeValueExp extends AttributeValueExp implements Serializable

Serialized Fields

attr

String attr
The name of the attribute

The serialVersionUID of this class is -1081892073854801359L.

Class javax.management.GenericMBeanException extends MBeanException implements Serializable

serialVersionUID: -1560202003985932823L

Serialization Methods

writeReplace

Object writeReplace()

Instances of this class are serialized as instances of MBeanException. MBeanException has private fields that can not be set by its public constructors. They can only be set in objects returned by this method. When an MBeanException instance is deserialized, if those fields are present then its readResolve method will substitute a GenericMBeanException equivalent to this one.

Class javax.management.ImmutableDescriptor extends Object implements Serializable

serialVersionUID: 8853308591080540165L

Serialization Methods

readResolve

private Object readResolve()
                    throws InvalidObjectException
This method can replace a deserialized instance of this class with another instance. For example, it might replace a deserialized empty ImmutableDescriptor with ImmutableDescriptor.EMPTY_DESCRIPTOR.

Throws:
InvalidObjectException - if the read object has invalid fields.
Serialized Fields

names

String[] names
The names of the fields in this ImmutableDescriptor with their original case. The names must be in alphabetical order as determined by String.CASE_INSENSITIVE_ORDER.

values

Object[] values
The values of the fields in this ImmutableDescriptor. The elements in this array match the corresponding elements in the names array.

Class javax.management.InQueryExp extends QueryEval implements Serializable

serialVersionUID: -5801329450358952434L

Serialized Fields

val

ValueExp val
The ValueExp to be found

valueList

ValueExp[] valueList
The array of ValueExp to be searched

Class javax.management.InstanceAlreadyExistsException extends OperationsException implements Serializable

serialVersionUID: 8893743928912733931L

Class javax.management.InstanceNotFoundException extends OperationsException implements Serializable

serialVersionUID: -882579438394773049L

Class javax.management.InstanceOfQueryExp extends QueryEval implements Serializable

serialVersionUID: -1081892073854801359L

Serialized Fields

classNameValue

StringValueExp classNameValue
The StringValueExp returning the name of the class of which selected MBeans should be instances.

Class javax.management.IntrospectionException extends OperationsException implements Serializable

serialVersionUID: 1054516935875481725L

Class javax.management.InvalidApplicationException extends Exception implements Serializable

serialVersionUID: -3048022274675537269L

Serialized Fields

val

Object val
The object representing the class of the MBean

Class javax.management.InvalidAttributeValueException extends OperationsException implements Serializable

serialVersionUID: 2164571879317142449L

Class javax.management.JMException extends Exception implements Serializable

serialVersionUID: 350520924977331825L

Class javax.management.JMRuntimeException extends RuntimeException implements Serializable

serialVersionUID: 6573344628407841861L

Class javax.management.JMX.MBeanOptions extends Object implements Serializable

serialVersionUID: -6380842449318177843L

Serialized Fields

mappingFactory

MXBeanMappingFactory mappingFactory

Class javax.management.JMX.ProxyOptions extends JMX.MBeanOptions implements Serializable

serialVersionUID: 7238804866098386559L

Serialized Fields

notificationEmitter

boolean notificationEmitter

Class javax.management.ListenerNotFoundException extends OperationsException implements Serializable

serialVersionUID: -7242605822448519061L

Class javax.management.MalformedObjectNameException extends OperationsException implements Serializable

serialVersionUID: -572689714442915824L

Class javax.management.MatchQueryExp extends QueryEval implements Serializable

serialVersionUID: -7156603696948215014L

Serialized Fields

exp

AttributeValueExp exp
The attribute value to be matched

pattern

String pattern
The pattern to be matched

Class javax.management.MBeanAttributeInfo extends MBeanFeatureInfo implements Serializable

Serialized Fields

attributeType

String attributeType
The actual attribute type.

isWrite

boolean isWrite
The attribute write right.

isRead

boolean isRead
The attribute read right.

is

boolean is
Indicates if this method is a "is"

Class javax.management.MBeanConstructorInfo extends MBeanFeatureInfo implements Serializable

serialVersionUID: 4433990064191844427L

Serialized Fields

signature

MBeanParameterInfo[] signature
The signature of the method, that is, the class names of the arguments.

Class javax.management.MBeanException extends JMException implements Serializable

serialVersionUID: 4066342430588744142L

Serialization Methods

readResolve

Object readResolve()
This method is invoked when deserializing instances of this class. If the errorCode field of the deserialized instance is not null, this method returns an instance of GenericMBeanException instead. Otherwise it returns this.

Serialized Fields

errorCode

String errorCode
This field is null for instances of this class that were produced by its public constructors. It is non-null for instances of this class that represent serialized instances of GenericMBeanException.
See Also:
GenericMBeanException.getErrorCode()

userData

CompositeData userData
This field is null for instances of this class that were produced by its public constructors. It may be non-null for instances of this class that represent serialized instances of GenericMBeanException.
See Also:
GenericMBeanException.getUserData()

exception

Exception exception
Encapsulated Exception

Class javax.management.MBeanFeatureInfo extends Object implements Serializable

serialVersionUID: 3952882688968447265L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes an MBeanFeatureInfo from an ObjectInputStream.

Serial Data:
For compatibility reasons, an object of this class is deserialized as follows.
    The method defaultReadObject() is called first to deserialize the object except the field descriptor, which is not serialized in the default way. Then the method read() is called to read a byte, the field descriptor is deserialized according to the value of the byte value:
    • 1. The method readObject() is called twice to obtain the field names (a String[]) and the field values (a Object[]) of the descriptor. The two obtained values then are used to construct an ImmutableDescriptor instance for the field descriptor;
    • 0. The value for the field descriptor is obtained directly by calling the method readObject(). If the obtained value is null, the field descriptor is set to EMPTY_DESCRIPTOR;
    • -1. This means that there is no byte to read and that the object is from an earlier version of the JMX API. The field descriptor is set to EMPTY_DESCRIPTOR
    • Any other value. A StreamCorruptedException is thrown.
Throws:
IOException
ClassNotFoundException
Since:
1.6

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes an MBeanFeatureInfo to an ObjectOutputStream.

Serial Data:
For compatibility reasons, an object of this class is serialized as follows.
    The method defaultWriteObject() is called first to serialize the object except the field descriptor which is declared as transient. The field descriptor is serialized as follows:
    • If descriptor is an instance of the class ImmutableDescriptor, the method write(int val) is called to write a byte with the value 1, then the method writeObject(Object obj) is called twice to serialize the field names and the field values of the descriptor, respectively as a String[] and an Object[];
    • Otherwise, the method write(int val) is called to write a byte with the value 0, then the method writeObject(Object obj) is called to serialize directly the field descriptor.
Throws:
IOException
Since:
1.6
Serialized Fields

name

String name
The name of the feature. It is recommended that subclasses call MBeanFeatureInfo.getName() rather than reading this field, and that they not change it.

The name of the feature.

description

String description
The human-readable description of the feature. It is recommended that subclasses call MBeanFeatureInfo.getDescription() rather than reading this field, and that they not change it.

The human-readable description of the feature.

Class javax.management.MBeanInfo extends Object implements Serializable

serialVersionUID: -6451021435135161911L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes an MBeanInfo from an ObjectInputStream.

Serial Data:
For compatibility reasons, an object of this class is deserialized as follows.
    The method defaultReadObject() is called first to deserialize the object except the field descriptor, which is not serialized in the default way. Then the method read() is called to read a byte, the field descriptor is deserialized according to the value of the byte value:
    • 1. The method readObject() is called twice to obtain the field names (a String[]) and the field values (a Object[]) of the descriptor. The two obtained values then are used to construct an ImmutableDescriptor instance for the field descriptor;
    • 0. The value for the field descriptor is obtained directly by calling the method readObject(). If the obtained value is null, the field descriptor is set to EMPTY_DESCRIPTOR;
    • -1. This means that there is no byte to read and that the object is from an earlier version of the JMX API. The field descriptor is set to EMPTY_DESCRIPTOR.
    • Any other value. A StreamCorruptedException is thrown.
Throws:
IOException
ClassNotFoundException
Since:
1.6

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes an MBeanInfo to an ObjectOutputStream.

Serial Data:
For compatibility reasons, an object of this class is serialized as follows.
    The method defaultWriteObject() is called first to serialize the object except the field descriptor which is declared as transient. The field descriptor is serialized as follows:
    • If descriptor is an instance of the class ImmutableDescriptor, the method write(int val) is called to write a byte with the value 1, then the method writeObject(Object obj) is called twice to serialize the field names and the field values of the descriptor, respectively as a String[] and an Object[];
    • Otherwise, the method write(int val) is called to write a byte with the value 0, then the method writeObject(Object obj) is called to serialize the field descriptor directly.
Throws:
IOException
Since:
1.6
Serialized Fields

description

String description
The human readable description of the class.

className

String className
The MBean qualified name.

attributes

MBeanAttributeInfo[] attributes
The MBean attribute descriptors.

operations

MBeanOperationInfo[] operations
The MBean operation descriptors.

constructors

MBeanConstructorInfo[] constructors
The MBean constructor descriptors.

notifications

MBeanNotificationInfo[] notifications
The MBean notification descriptors.

Class javax.management.MBeanNotificationInfo extends MBeanFeatureInfo implements Serializable

serialVersionUID: -3888371564530107064L

Serialized Fields

types

String[] types
The different types of the notification.

Class javax.management.MBeanOperationInfo extends MBeanFeatureInfo implements Serializable

serialVersionUID: -6178860474881375330L

Serialized Fields

type

String type
The method's return value.

signature

MBeanParameterInfo[] signature
The signature of the method, that is, the class names of the arguments.

impact

int impact
The impact of the method, one of INFO, ACTION, ACTION_INFO, UNKNOWN

Class javax.management.MBeanParameterInfo extends MBeanFeatureInfo implements Serializable

serialVersionUID: 7432616882776782338L

Serialized Fields

type

String type
The type or class name of the data.

Class javax.management.MBeanPermission extends Permission implements Serializable

serialVersionUID: -2416928705275160661L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserialize this object based on its name and actions.

Throws:
IOException
ClassNotFoundException
Serialized Fields

actions

String actions
The actions string.

Class javax.management.MBeanRegistrationException extends MBeanException implements Serializable

serialVersionUID: 4482382455277067805L

Class javax.management.MBeanServerNotification extends Notification implements Serializable

serialVersionUID: 2876477500475969677L

Serialized Fields

objectName

ObjectName objectName
The object names of the MBeans concerned by this notification

Class javax.management.MBeanServerPermission extends BasicPermission implements Serializable

serialVersionUID: -5661980843569388590L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Throws:
IOException
ClassNotFoundException

Class javax.management.MBeanServerPermissionCollection extends PermissionCollection implements Serializable

serialVersionUID: -5661980843569388590L

Serialized Fields

collectionPermission

MBeanServerPermission collectionPermission
Null if no permissions in collection, otherwise a single permission that is the union of all permissions that have been added.

Class javax.management.MBeanTrustPermission extends BasicPermission implements Serializable

serialVersionUID: -2952178077029018140L

Class javax.management.NotCompliantMBeanException extends OperationsException implements Serializable

serialVersionUID: 5175579583207963577L

Class javax.management.Notification extends EventObject implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a Notification from an ObjectInputStream.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a Notification to an ObjectOutputStream.

Throws:
IOException
Serialized Fields

message

String message
The notification message.

sequenceNumber

long sequenceNumber
The notification sequence number. A serial number which identify particular instance of notification in the context of the notification source.

source

Object source
The object on which the notification initially occurred.

timeStamp

long timeStamp
The notification timestamp. Indicating when the notification was generated

type

String type
The notification type. A string expressed in a dot notation similar to Java properties. An example of a notification type is network.alarm.router

userData

Object userData
The notification user data. Used for whatever other data the notification source wishes to communicate to its consumers

Class javax.management.NotificationFilterSupport extends Object implements Serializable

serialVersionUID: 6579080007561786969L

Serialized Fields

enabledTypes

List<E> enabledTypes
Vector that contains the enabled notification types. The default value is an empty vector.

Class javax.management.NotQueryExp extends QueryEval implements Serializable

serialVersionUID: 5269643775896723397L

Serialized Fields

exp

QueryExp exp
The negated QueryExp

Class javax.management.NumericValueExp extends QueryEval implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a NumericValueExp from an ObjectInputStream.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a NumericValueExp to an ObjectOutputStream.

Throws:
IOException
Serialized Fields

val

Number val
The numeric value

The serialVersionUID of this class is -4679739485102359104L.

Class javax.management.ObjectInstance extends Object implements Serializable

serialVersionUID: -4099952623687795850L

Serialized Fields

name

ObjectName name
Object name.

className

String className
Class name.

Class javax.management.ObjectName extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes an ObjectName from an ObjectInputStream.

Serial Data:
  • In the current serial form (value of property jmx.serial.form differs from 1.0): the string "<domain>:<properties><wild>", where:
    • <domain> represents the domain part of the ObjectName
    • <properties> represents the list of properties, as returned by ObjectName.getKeyPropertyListString()
    • <wild> is empty if not isPropertyPattern, or is the character "*" if isPropertyPattern and <properties> is empty, or is ",*" if isPropertyPattern and <properties> is not empty.
    The intent is that this string could be supplied to the ObjectName.ObjectName(String) constructor to produce an equivalent ObjectName.
  • In the old serial form (value of property jmx.serial.form is 1.0): <domain> <propertyList> <propertyListString> <canonicalName> <pattern> <propertyPattern>, where:
    • <domain> represents the domain part of the ObjectName
    • <propertyList> is the Hashtable that contains all the pairs (key,value) for this ObjectName
    • <propertyListString> is the String representation of the list of properties in any order (not mandatorily a canonical representation)
    • <canonicalName> is the String containing this ObjectName's canonical name
    • <pattern> is a boolean which is true if this ObjectName contains a pattern
    • <propertyPattern> is a boolean which is true if this ObjectName contains a pattern in the list of properties
Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes an ObjectName to an ObjectOutputStream.

Serial Data:
  • In the current serial form (value of property jmx.serial.form differs from 1.0): the string "<domain>:<properties><wild>", where:
    • <domain> represents the domain part of the ObjectName
    • <properties> represents the list of properties, as returned by ObjectName.getKeyPropertyListString()
    • <wild> is empty if not isPropertyPattern, or is the character "*" if this isPropertyPattern and <properties> is empty, or is ",*" if isPropertyPattern and <properties> is not empty.
    The intent is that this string could be supplied to the ObjectName.ObjectName(String) constructor to produce an equivalent ObjectName.
  • In the old serial form (value of property jmx.serial.form is 1.0): <domain> <propertyList> <propertyListString> <canonicalName> <pattern> <propertyPattern>, where:
    • <domain> represents the domain part of the ObjectName
    • <propertyList> is the Hashtable that contains all the pairs (key,value) for this ObjectName
    • <propertyListString> is the String representation of the list of properties in any order (not mandatorily a canonical representation)
    • <canonicalName> is the String containing this ObjectName's canonical name
    • <pattern> is a boolean which is true if this ObjectName contains a pattern
    • <propertyPattern> is a boolean which is true if this ObjectName contains a pattern in the list of properties
Throws:
IOException
Serialized Fields

Class javax.management.OperationsException extends JMException implements Serializable

serialVersionUID: -4967597595580536216L

Class javax.management.OrQueryExp extends QueryEval implements Serializable

serialVersionUID: 2962973084421716523L

Serialized Fields

exp1

QueryExp exp1
The left query expression

exp2

QueryExp exp2
The right query expression

Class javax.management.QualifiedAttributeValueExp extends AttributeValueExp implements Serializable

serialVersionUID: 8832517277410933254L

Serialized Fields

className

String className
The attribute class name

Class javax.management.QueryEval extends Object implements Serializable

serialVersionUID: 2675899265640874796L

Class javax.management.QueryNotificationFilter extends Object implements Serializable

serialVersionUID: -8408613922660635231L

Serialized Fields

query

QueryExp query

Class javax.management.ReflectionException extends JMException implements Serializable

serialVersionUID: 9170809325636915553L

Serialized Fields

exception

Exception exception
The wrapped Exception

Class javax.management.RuntimeErrorException extends JMRuntimeException implements Serializable

serialVersionUID: 704338937753949796L

Serialized Fields

error

Error error
The encapsulated Error

Class javax.management.RuntimeMBeanException extends JMRuntimeException implements Serializable

serialVersionUID: 5274912751982730171L

Serialized Fields

runtimeException

RuntimeException runtimeException
The encapsulated RuntimeException

Class javax.management.RuntimeOperationsException extends JMRuntimeException implements Serializable

serialVersionUID: -8408923047489133588L

Serialized Fields

runtimeException

RuntimeException runtimeException
The encapsulated RuntimeException

Class javax.management.ServiceNotFoundException extends OperationsException implements Serializable

serialVersionUID: -3990675661956646827L

Class javax.management.StandardMBean.Options extends JMX.MBeanOptions implements Serializable

serialVersionUID: 5107355471177517164L

Serialized Fields

wrappedVisible

boolean wrappedVisible

forwardRegistration

boolean forwardRegistration

Class javax.management.StringValueExp extends Object implements Serializable

serialVersionUID: -3256390509806284044L

Serialized Fields

val

String val
The string literal
Package javax.management.event

Class javax.management.event.EventClientNotFoundException extends JMException implements Serializable

serialVersionUID: -3910667345840643089L

Package javax.management.loading

Class javax.management.loading.MLet extends URLClassLoader implements Serializable

serialVersionUID: 3636148327800330130L

Serialization Methods

readExternal

public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException,
                         UnsupportedOperationException

Restore this MLet's contents from the given ObjectInput. Not all implementations support this method. Those that do not throw UnsupportedOperationException. A subclass may override this method to support it or to change the format of the read data.

The format of the read data is not specified, but if an implementation supports MLet.readExternal(java.io.ObjectInput) it must also support MLet.writeExternal(java.io.ObjectOutput) in such a way that what is written by the latter can be read by the former.

Throws:
IOException - if a problem occurred while reading.
ClassNotFoundException - if the class for the object being restored cannot be found.
UnsupportedOperationException - if this implementation does not support this operation.

writeExternal

public void writeExternal(ObjectOutput out)
                   throws IOException,
                          UnsupportedOperationException

Save this MLet's contents to the given ObjectOutput. Not all implementations support this method. Those that do not throw UnsupportedOperationException. A subclass may override this method to support it or to change the format of the written data.

The format of the written data is not specified, but if an implementation supports MLet.writeExternal(java.io.ObjectOutput) it must also support MLet.readExternal(java.io.ObjectInput) in such a way that what is written by the former can be read by the latter.

Throws:
IOException - If a problem occurred while writing.
UnsupportedOperationException - If this implementation does not support this operation.

Class javax.management.loading.PrivateMLet extends MLet implements Serializable

serialVersionUID: 2503458973393711979L

Serialization Methods

readExternal

public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException,
                         UnsupportedOperationException

Restore this MLet's contents from the given ObjectInput. Not all implementations support this method. Those that do not throw UnsupportedOperationException. A subclass may override this method to support it or to change the format of the read data.

The format of the read data is not specified, but if an implementation supports MLet.readExternal(java.io.ObjectInput) it must also support MLet.writeExternal(java.io.ObjectOutput) in such a way that what is written by the latter can be read by the former.

Throws:
IOException - if a problem occurred while reading.
ClassNotFoundException - if the class for the object being restored cannot be found.
UnsupportedOperationException - if this implementation does not support this operation.

writeExternal

public void writeExternal(ObjectOutput out)
                   throws IOException,
                          UnsupportedOperationException

Save this MLet's contents to the given ObjectOutput. Not all implementations support this method. Those that do not throw UnsupportedOperationException. A subclass may override this method to support it or to change the format of the written data.

The format of the written data is not specified, but if an implementation supports MLet.writeExternal(java.io.ObjectOutput) it must also support MLet.readExternal(java.io.ObjectInput) in such a way that what is written by the former can be read by the latter.

Throws:
IOException - If a problem occurred while writing.
UnsupportedOperationException - If this implementation does not support this operation.
Package javax.management.modelmbean

Class javax.management.modelmbean.DescriptorSupport extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a DescriptorSupport from an ObjectInputStream.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a DescriptorSupport to an ObjectOutputStream.

Throws:
IOException
Serialized Fields

descriptor

HashMap<K,V> descriptor
The collection of fields representing this descriptor

Class javax.management.modelmbean.InvalidTargetObjectTypeException extends Exception implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes an InvalidTargetObjectTypeException from an ObjectInputStream.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes an InvalidTargetObjectTypeException to an ObjectOutputStream.

Throws:
IOException
Serialized Fields

exception

Exception exception
Encapsulated {@link Exception}

Class javax.management.modelmbean.ModelMBeanAttributeInfo extends MBeanAttributeInfo implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a ModelMBeanAttributeInfo from an ObjectInputStream.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a ModelMBeanAttributeInfo to an ObjectOutputStream.

Throws:
IOException
Serialized Fields

attrDescriptor

Descriptor attrDescriptor
The {@link Descriptor} containing the metadata corresponding to this attribute

Class javax.management.modelmbean.ModelMBeanConstructorInfo extends MBeanConstructorInfo implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a ModelMBeanConstructorInfo from an ObjectInputStream.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a ModelMBeanConstructorInfo to an ObjectOutputStream.

Throws:
IOException
Serialized Fields

consDescriptor

Descriptor consDescriptor
The {@link Descriptor} containing the metadata for this instance

Class javax.management.modelmbean.ModelMBeanInfoSupport extends MBeanInfo implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a ModelMBeanInfoSupport from an ObjectInputStream.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a ModelMBeanInfoSupport to an ObjectOutputStream.

Throws:
IOException
Serialized Fields

modelMBeanAttributes

ModelMBeanAttributeInfo[] modelMBeanAttributes
The array of {@link ModelMBeanAttributeInfo} objects which have descriptors

modelMBeanConstructors

MBeanConstructorInfo[] modelMBeanConstructors
The array of {@link ModelMBeanConstructorInfo} objects which have descriptors

modelMBeanDescriptor

Descriptor modelMBeanDescriptor
The descriptor containing MBean wide policy

modelMBeanNotifications

MBeanNotificationInfo[] modelMBeanNotifications
The array of {@link ModelMBeanNotificationInfo} objects which have descriptors

modelMBeanOperations

MBeanOperationInfo[] modelMBeanOperations
The array of {@link ModelMBeanOperationInfo} objects which have descriptors

Class javax.management.modelmbean.ModelMBeanNotificationInfo extends MBeanNotificationInfo implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a ModelMBeanNotificationInfo from an ObjectInputStream.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a ModelMBeanNotificationInfo to an ObjectOutputStream.

Throws:
IOException
Serialized Fields

notificationDescriptor

Descriptor notificationDescriptor
The descriptor containing the appropriate metadata for this instance

Class javax.management.modelmbean.ModelMBeanOperationInfo extends MBeanOperationInfo implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a ModelMBeanOperationInfo from an ObjectInputStream.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a ModelMBeanOperationInfo to an ObjectOutputStream.

Throws:
IOException
Serialized Fields

operationDescriptor

Descriptor operationDescriptor
The descriptor containing the appropriate metadata for this instance

Class javax.management.modelmbean.XMLParseException extends Exception implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes an XMLParseException from an ObjectInputStream.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes an XMLParseException to an ObjectOutputStream.

Throws:
IOException
Serialized Fields
Package javax.management.monitor

Class javax.management.monitor.MonitorNotification extends Notification implements Serializable

serialVersionUID: -4608189663661929204L

Serialized Fields

observedObject

ObjectName observedObject
Monitor notification observed object.

observedAttribute

String observedAttribute
Monitor notification observed attribute.

derivedGauge

Object derivedGauge
Monitor notification derived gauge.

trigger

Object trigger
Monitor notification release mechanism. This value is used to keep the threshold/string (depending on the monitor type) that triggered off this notification.

Class javax.management.monitor.MonitorSettingException extends JMRuntimeException implements Serializable

serialVersionUID: -8807913418190202007L

Package javax.management.namespace

Class javax.management.namespace.JMXNamespacePermission extends Permission implements Serializable

serialVersionUID: -2416928705275160661L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserialize this object based on its name and actions.

Throws:
IOException
ClassNotFoundException
Serialized Fields

actions

String actions
The actions string.

Package javax.management.openmbean

Class javax.management.openmbean.ArrayType extends OpenType<T> implements Serializable

serialVersionUID: 720504429830309770L

Serialization Methods

readResolve

private Object readResolve()
                    throws ObjectStreamException
Replace/resolve the object read from the stream before it is returned to the caller.

Serial Data:
The new serial form of this class defines a new serializable boolean field primitiveArray. In order to guarantee the interoperability with previous versions of this class the new serial form must continue to refer to primitive wrapper types even when the ArrayType instance describes a primitive type array. So when primitiveArray is true the className, typeName and description serializable fields are converted into primitive types before the deserialized ArrayType instance is return to the caller. The elementType field always returns the SimpleType corresponding to the primitive wrapper type of the array's primitive type.

Therefore the following serializable fields are deserialized as follows:

  • if primitiveArray is true the className field is deserialized by replacing the array's component primitive wrapper type by the corresponding array's component primitive type, e.g. "[[Ljava.lang.Integer;" will be deserialized as "[[I".
  • if primitiveArray is true the typeName field is deserialized by replacing the array's component primitive wrapper type by the corresponding array's component primitive type, e.g. "[[Ljava.lang.Integer;" will be deserialized as "[[I".
  • if primitiveArray is true the description field is deserialized by replacing the array's component primitive wrapper type by the corresponding array's component primitive type, e.g. "2-dimension array of java.lang.Integer" will be deserialized as "2-dimension array of int".
Throws:
ObjectStreamException
Since:
1.6

writeReplace

private Object writeReplace()
                     throws ObjectStreamException
Nominate a replacement for this object in the stream before the object is written.

Serial Data:
The new serial form of this class defines a new serializable boolean field primitiveArray. In order to guarantee the interoperability with previous versions of this class the new serial form must continue to refer to primitive wrapper types even when the ArrayType instance describes a primitive type array. So when primitiveArray is true the className, typeName and description serializable fields are converted into wrapper types before the serialized ArrayType instance is written to the stream. The elementType field always returns the SimpleType corresponding to the primitive wrapper type of the array's primitive type.

Therefore the following serializable fields are serialized as follows:

  • if primitiveArray is true the className field is serialized by replacing the array's component primitive type by the corresponding array's component primitive wrapper type, e.g. "[[I" will be serialized as "[[Ljava.lang.Integer;".
  • if primitiveArray is true the typeName field is serialized by replacing the array's component primitive type by the corresponding array's component primitive wrapper type, e.g. "[[I" will be serialized as "[[Ljava.lang.Integer;".
  • if primitiveArray is true the description field is serialized by replacing the array's component primitive type by the corresponding array's component primitive wrapper type, e.g. "2-dimension array of int" will be serialized as "2-dimension array of java.lang.Integer".
Throws:
ObjectStreamException
Since:
1.6
Serialized Fields

dimension

int dimension
The dimension of arrays described by this ArrayType instance.

elementType

OpenType<T> elementType
The open type of element values contained in the arrays described by this ArrayType instance.

primitiveArray

boolean primitiveArray
This flag indicates whether this ArrayType describes a primitive array.
Since:
1.6

Class javax.management.openmbean.CompositeDataSupport extends Object implements Serializable

serialVersionUID: 8003518976613702244L

Serialized Fields

contents

SortedMap<K,V> contents
Internal representation of the mapping of item names to their respective values. A SortedMap is used for faster retrieval of elements.

compositeType

CompositeType compositeType
The composite type of this composite data instance.

Class javax.management.openmbean.CompositeType extends OpenType<CompositeData> implements Serializable

serialVersionUID: -5366242454346948798L

Serialized Fields

nameToDescription

TreeMap<K,V> nameToDescription
Sorted mapping of the item names to their descriptions

nameToType

TreeMap<K,V> nameToType
Sorted mapping of the item names to their open types

Class javax.management.openmbean.InvalidKeyException extends IllegalArgumentException implements Serializable

serialVersionUID: 4224269443946322062L

Class javax.management.openmbean.InvalidOpenTypeException extends IllegalArgumentException implements Serializable

serialVersionUID: -2837312755412327534L

Class javax.management.openmbean.KeyAlreadyExistsException extends IllegalArgumentException implements Serializable

serialVersionUID: 1845183636745282866L

Class javax.management.openmbean.OpenDataException extends JMException implements Serializable

serialVersionUID: 8346311255433349870L

Class javax.management.openmbean.OpenMBeanAttributeInfoSupport extends MBeanAttributeInfo implements Serializable

serialVersionUID: -4867215622149721849L

Serialization Methods

readResolve

private Object readResolve()
An object serialized in a version of the API before Descriptors were added to this class will have an empty or null Descriptor. For consistency with our behavior in this version, we must replace the object with one where the Descriptors reflect the same values of openType, defaultValue, etc.

Serialized Fields

openType

OpenType<T> openType
The open mbean attribute's open type

defaultValue

Object defaultValue
The open mbean attribute's default value

legalValues

Set<E> legalValues
The open mbean attribute's legal values. This Set is unmodifiable

minValue

Comparable<T> minValue
The open mbean attribute's min value

maxValue

Comparable<T> maxValue
The open mbean attribute's max value

Class javax.management.openmbean.OpenMBeanConstructorInfoSupport extends MBeanConstructorInfo implements Serializable

serialVersionUID: -4400441579007477003L

Class javax.management.openmbean.OpenMBeanInfoSupport extends MBeanInfo implements Serializable

serialVersionUID: 4349395935420511492L

Class javax.management.openmbean.OpenMBeanOperationInfoSupport extends MBeanOperationInfo implements Serializable

serialVersionUID: 4996859732565369366L

Serialization Methods

readResolve

private Object readResolve()
An object serialized in a version of the API before Descriptors were added to this class will have an empty or null Descriptor. For consistency with our behavior in this version, we must replace the object with one where the Descriptors reflect the same value of returned openType.

Serialized Fields

returnOpenType

OpenType<T> returnOpenType
The open type of the values returned by the operation described by this OpenMBeanOperationInfo instance

Class javax.management.openmbean.OpenMBeanParameterInfoSupport extends MBeanParameterInfo implements Serializable

serialVersionUID: -7235016873758443122L

Serialization Methods

readResolve

private Object readResolve()
An object serialized in a version of the API before Descriptors were added to this class will have an empty or null Descriptor. For consistency with our behavior in this version, we must replace the object with one where the Descriptors reflect the same values of openType, defaultValue, etc.

Serialized Fields

openType

OpenType<T> openType
The open mbean parameter's open type

defaultValue

Object defaultValue
The open mbean parameter's default value

legalValues

Set<E> legalValues
The open mbean parameter's legal values. This Set is unmodifiable

minValue

Comparable<T> minValue
The open mbean parameter's min value

maxValue

Comparable<T> maxValue
The open mbean parameter's max value

Class javax.management.openmbean.OpenType extends Object implements Serializable

serialVersionUID: -9195195325186646468L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes an OpenType from an ObjectInputStream.

Throws:
IOException
ClassNotFoundException
Serialized Fields

className

String className
The fully qualified Java class name of open data values this type describes.

description

String description
The type description (should not be null or empty).

typeName

String typeName
The name given to this type (should not be null or empty).

Class javax.management.openmbean.SimpleType extends OpenType<T> implements Serializable

serialVersionUID: 2215577471957694503L

Serialization Methods

readResolve

public Object readResolve()
                   throws ObjectStreamException
Replace an object read from an ObjectInputStream with the unique instance for that value.

Throws:
ObjectStreamException - if the read object cannot be resolved.

Class javax.management.openmbean.TabularDataSupport extends Object implements Serializable

serialVersionUID: 5720150593236309827L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a TabularDataSupport from an ObjectInputStream.

Throws:
IOException
ClassNotFoundException
Serialized Fields

dataMap

Map<K,V> dataMap
This tabular data instance's contents: a HashMap

tabularType

TabularType tabularType
This tabular data instance's tabular type

Class javax.management.openmbean.TabularType extends OpenType<TabularData> implements Serializable

serialVersionUID: 6554071860220659261L

Serialized Fields

rowType

CompositeType rowType
The composite type of rows

indexNames

List<E> indexNames
The items used to index each row element, kept in the order the user gave This is an unmodifiable ArrayList
Package javax.management.relation

Class javax.management.relation.InvalidRelationIdException extends RelationException implements Serializable

serialVersionUID: -7115040321202754171L

Class javax.management.relation.InvalidRelationServiceException extends RelationException implements Serializable

serialVersionUID: 3400722103759507559L

Class javax.management.relation.InvalidRelationTypeException extends RelationException implements Serializable

serialVersionUID: 3007446608299169961L

Class javax.management.relation.InvalidRoleInfoException extends RelationException implements Serializable

serialVersionUID: 7517834705158932074L

Class javax.management.relation.InvalidRoleValueException extends RelationException implements Serializable

serialVersionUID: -2066091747301983721L

Class javax.management.relation.MBeanServerNotificationFilter extends NotificationFilterSupport implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes an MBeanServerNotificationFilter from an ObjectInputStream.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes an MBeanServerNotificationFilter to an ObjectOutputStream.

Throws:
IOException
Serialized Fields

deselectedNames

List<E> deselectedNames
List of {@link ObjectName}s with no interest
  • null means that all {@link ObjectName}s are implicitly deselected (check for explicit selections))
  • Empty vector means that no {@link ObjectName} is explicitly deselected

selectedNames

List<E> selectedNames
List of {@link ObjectName}s of interest
  • null means that all {@link ObjectName}s are implicitly selected (check for explicit deselections)
  • Empty vector means that no {@link ObjectName} is explicitly selected

Class javax.management.relation.RelationException extends JMException implements Serializable

serialVersionUID: 5434016005679159613L

Class javax.management.relation.RelationNotFoundException extends RelationException implements Serializable

serialVersionUID: -3793951411158559116L

Class javax.management.relation.RelationNotification extends Notification implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a RelationNotification from an ObjectInputStream.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a RelationNotification to an ObjectOutputStream.

Throws:
IOException
Serialized Fields

newRoleValue

List<E> newRoleValue
New role value ({@link ArrayList} of {@link ObjectName}s) (only for role update)

oldRoleValue

List<E> oldRoleValue
Old role value ({@link ArrayList} of {@link ObjectName}s) (only for role update)

relationId

String relationId
Relation identifier of created/removed/updated relation

relationObjName

ObjectName relationObjName
{@link ObjectName} of the relation MBean of created/removed/updated relation (only if the relation is represented by an MBean)

relationTypeName

String relationTypeName
Relation type name of created/removed/updated relation

roleName

String roleName
Name of updated role (only for role update)

unregisterMBeanList

List<E> unregisterMBeanList
List of {@link ObjectName}s of referenced MBeans to be unregistered due to relation removal

Class javax.management.relation.RelationServiceNotRegisteredException extends RelationException implements Serializable

serialVersionUID: 8454744887157122910L

Class javax.management.relation.RelationTypeNotFoundException extends RelationException implements Serializable

serialVersionUID: 1274155316284300752L

Class javax.management.relation.RelationTypeSupport extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a RelationTypeSupport from an ObjectInputStream.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a RelationTypeSupport to an ObjectOutputStream.

Throws:
IOException
Serialized Fields

isInRelationService

boolean isInRelationService
Flag specifying whether the relation type has been declared in the Relation Service (so can no longer be updated)

roleName2InfoMap

Map<K,V> roleName2InfoMap
{@link Map} holding the mapping: <role name ({@link String})> -> <role info ({@link RoleInfo} object)>

typeName

String typeName
Relation type name

Class javax.management.relation.Role extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a Role from an ObjectInputStream.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a Role to an ObjectOutputStream.

Throws:
IOException
Serialized Fields

name

String name
Role name

objectNameList

List<E> objectNameList
{@link List} of {@link ObjectName}s of referenced MBeans

Class javax.management.relation.RoleInfo extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a RoleInfo from an ObjectInputStream.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a RoleInfo to an ObjectOutputStream.

Throws:
IOException
Serialized Fields

description

String description
Role description

isReadable

boolean isReadable
Read access mode: true if role is readable

isWritable

boolean isWritable
Write access mode: true if role is writable

maxDegree

int maxDegree
Maximum degree (i.e. maximum number of referenced MBeans in corresponding role)

minDegree

int minDegree
Minimum degree (i.e. minimum number of referenced MBeans in corresponding role)

name

String name
Role name

referencedMBeanClassName

String referencedMBeanClassName
Name of class of MBean(s) expected to be referenced in corresponding role

Class javax.management.relation.RoleInfoNotFoundException extends RelationException implements Serializable

serialVersionUID: 4394092234999959939L

Class javax.management.relation.RoleList extends ArrayList<Object> implements Serializable

serialVersionUID: 5568344346499649313L

Class javax.management.relation.RoleNotFoundException extends RelationException implements Serializable

serialVersionUID: -2986406101364031481L

Class javax.management.relation.RoleResult extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a RoleResult from an ObjectInputStream.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a RoleResult to an ObjectOutputStream.

Throws:
IOException
Serialized Fields

roleList

RoleList roleList
List of roles successfully accessed

unresolvedRoleList

RoleUnresolvedList unresolvedRoleList
List of roles unsuccessfully accessed

Class javax.management.relation.RoleUnresolved extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a RoleUnresolved from an ObjectInputStream.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a RoleUnresolved to an ObjectOutputStream.

Throws:
IOException
Serialized Fields

problemType

int problemType
Problem type

roleName

String roleName
Role name

roleValue

List<E> roleValue
Role value ({@link List} of {@link ObjectName} objects)

Class javax.management.relation.RoleUnresolvedList extends ArrayList<Object> implements Serializable

serialVersionUID: 4054902803091433324L

Package javax.management.remote

Class javax.management.remote.JMXConnectionNotification extends Notification implements Serializable

serialVersionUID: -2331308725952627538L

Serialized Fields

connectionId

String connectionId
The connection ID to which this notification pertains.
See Also:
JMXConnectionNotification.getConnectionId()

Class javax.management.remote.JMXPrincipal extends Object implements Serializable

serialVersionUID: -4184480100214577411L

Serialized Fields

name

String name
The JMX Remote API name for the identity represented by this JMXPrincipal object.
See Also:
JMXPrincipal.getName()

Class javax.management.remote.JMXProviderException extends IOException implements Serializable

serialVersionUID: -3166703627550447198L

Serialized Fields

cause

Throwable cause
An exception that caused this exception to be thrown. This field may be null.
See Also:
JMXProviderException.getCause()

Class javax.management.remote.JMXServerErrorException extends IOException implements Serializable

serialVersionUID: 3996732239558744666L

Serialized Fields

cause

Error cause
An Error that caused this exception to be thrown.
See Also:
JMXServerErrorException.getCause()

Class javax.management.remote.JMXServiceURL extends Object implements Serializable

serialVersionUID: 8173364409860779292L

Serialized Fields

protocol

String protocol
The value returned by JMXServiceURL.getProtocol().

host

String host
The value returned by JMXServiceURL.getHost().

port

int port
The value returned by JMXServiceURL.getPort().

urlPath

String urlPath
The value returned by JMXServiceURL.getURLPath().

Class javax.management.remote.NotificationResult extends Object implements Serializable

serialVersionUID: 1191800228721395279L

Serialized Fields

earliestSequenceNumber

long earliestSequenceNumber

nextSequenceNumber

long nextSequenceNumber

targetedNotifications

TargetedNotification[] targetedNotifications

Class javax.management.remote.SubjectDelegationPermission extends BasicPermission implements Serializable

serialVersionUID: 1481618113008682343L

Class javax.management.remote.TargetedNotification extends Object implements Serializable

serialVersionUID: 7676132089779300926L

Serialized Fields

notif

Notification notif
A notification to transmit to the other side.
See Also:
TargetedNotification.getNotification()

id

Integer id
The ID of the listener to which the notification is targeted.
See Also:
TargetedNotification.getListenerID()
Package javax.management.remote.rmi

Class javax.management.remote.rmi._RMIConnection_Stub extends Stub implements Serializable

Class javax.management.remote.rmi._RMIServer_Stub extends Stub implements Serializable

Class javax.management.remote.rmi.RMIConnectionImpl_Stub extends RemoteStub implements Serializable

serialVersionUID: 2L

Class javax.management.remote.rmi.RMIConnector extends Object implements Serializable

serialVersionUID: 817323035842634473L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Read RMIConnector fields from an ObjectInputStream. Calls s.defaultReadObject() and then initializes all transient variables that need initializing.

Throws:
InvalidObjectException - if none of rmiServer stub or jmxServiceURL are set.
IOException
ClassNotFoundException
See Also:
RMIConnector.RMIConnector(JMXServiceURL,Map), RMIConnector.RMIConnector(RMIServer,Map)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Writes the RMIConnector fields to an ObjectOutputStream.

Connects the underlying RMIServer stub to an ORB, if needed, before serializing it. This is done using the environment map that was provided to the constructor, if any, and as documented in javax.management.remote.rmi.

This method then calls s.defaultWriteObject(). Usually, rmiServer is null if this object was constructed with a JMXServiceURL, and jmxServiceURL is null if this object is constructed with a RMIServer stub.

Note that the environment Map is not serialized, since the objects it contains are assumed to be contextual and relevant only with respect to the local environment (class loader, ORB, etc...).

After an RMIConnector is deserialized, it is assumed that the user will call RMIConnector.connect(Map), providing a new Map that can contain values which are contextually relevant to the new local environment.

Since connection to the ORB is needed prior to serializing, and since the ORB to connect to is one of those contextual parameters, it is not recommended to re-serialize a just de-serialized object - as the de-serialized object has no map. Thus, when an RMIConnector object is needed for serialization or transmission to a remote application, it is recommended to obtain a new RMIConnector stub by calling RMIConnectorServer.toJMXConnector(Map).

Throws:
InvalidObjectException - if none of rmiServer stub or jmxServiceURL are set.
IOException
See Also:
RMIConnector.RMIConnector(JMXServiceURL,Map), RMIConnector.RMIConnector(RMIServer,Map)
Serialized Fields

rmiServer

RMIServer rmiServer
The RMIServer stub of the RMI JMX Connector server to which this client connector is (or will be) connected. This field can be null when jmxServiceURL is not null. This includes the case where jmxServiceURL contains a serialized RMIServer stub. If both rmiServer and jmxServiceURL are null then serialization will fail.
See Also:
RMIConnector.RMIConnector(RMIServer,Map)

jmxServiceURL

JMXServiceURL jmxServiceURL
The JMXServiceURL of the RMI JMX Connector server to which this client connector will be connected. This field can be null when rmiServer is not null. If both rmiServer and jmxServiceURL are null then serialization will fail.
See Also:
RMIConnector.RMIConnector(JMXServiceURL,Map)

eventServiceEnabled

boolean eventServiceEnabled

Class javax.management.remote.rmi.RMIServerImpl_Stub extends RemoteStub implements Serializable

serialVersionUID: 2L

Package javax.management.timer

Class javax.management.timer.TimerNotification extends Notification implements Serializable

serialVersionUID: 1798492029603825750L

Serialized Fields

notificationID

Integer notificationID
Timer notification identifier. This identifier is used to retrieve a timer notification from the timer list of notifications.
Package javax.naming

Class javax.naming.AuthenticationException extends NamingSecurityException implements Serializable

serialVersionUID: 3678497619904568096L

Class javax.naming.AuthenticationNotSupportedException extends NamingSecurityException implements Serializable

serialVersionUID: -7149033933259492300L

Class javax.naming.BinaryRefAddr extends RefAddr implements Serializable

serialVersionUID: -3415254970957330361L

Serialized Fields

buf

byte[] buf
Contains the bytes of the address. This field is initialized by the constructor and returned using getAddressBytes() and getAddressContents().

Class javax.naming.Binding extends NameClassPair implements Serializable

serialVersionUID: 8839217842691845890L

Serialized Fields

boundObj

Object boundObj
Contains this binding's object. It is initialized by the constuctor and can be updated using setObject.

See Also:
Binding.getObject(), Binding.setObject(java.lang.Object)

Class javax.naming.CannotProceedException extends NamingException implements Serializable

serialVersionUID: 1219724816191576813L

Serialized Fields

remainingNewName

Name remainingNewName
Contains the remaining unresolved part of the second "name" argument to Context.rename(). This information necessary for continuing the Context.rename() operation.

This field is initialized to null. It should not be manipulated directly: it should be accessed and updated using getRemainingName() and setRemainingName().

See Also:
CannotProceedException.getRemainingNewName(), CannotProceedException.setRemainingNewName(javax.naming.Name)

environment

Hashtable<K,V> environment
Contains the environment relevant for the Context or DirContext method that cannot proceed.

This field is initialized to null. It should not be manipulated directly: it should be accessed and updated using getEnvironment() and setEnvironment().

See Also:
CannotProceedException.getEnvironment(), CannotProceedException.setEnvironment(java.util.Hashtable)

altName

Name altName
Contains the name of the resolved object, relative to the context altNameCtx. It is a composite name. If null, then no name is specified. See the javax.naming.spi.ObjectFactory.getObjectInstance method for details on how this is used.

This field is initialized to null. It should not be manipulated directly: it should be accessed and updated using getAltName() and setAltName().

See Also:
CannotProceedException.getAltName(), CannotProceedException.setAltName(javax.naming.Name), CannotProceedException.altNameCtx, ObjectFactory.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)

altNameCtx

Context altNameCtx
Contains the context relative to which altName is specified. If null, then the default initial context is implied. See the javax.naming.spi.ObjectFactory.getObjectInstance method for details on how this is used.

This field is initialized to null. It should not be manipulated directly: it should be accessed and updated using getAltNameCtx() and setAltNameCtx().

See Also:
CannotProceedException.getAltNameCtx(), CannotProceedException.setAltNameCtx(javax.naming.Context), CannotProceedException.altName, ObjectFactory.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)

Class javax.naming.CommunicationException extends NamingException implements Serializable

serialVersionUID: 3618507780299986611L

Class javax.naming.CompositeName extends Object implements Serializable

serialVersionUID: 1667768148915813118L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Overridden to avoid implementation dependency.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Overridden to avoid implementation dependency.

Serial Data:
The number of components (an int) followed by the individual components (each a String).
Throws:
IOException

Class javax.naming.CompoundName extends Object implements Serializable

serialVersionUID: 3513100557083972036L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Overridden to avoid implementation dependency.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Overridden to avoid implementation dependency.

Serial Data:
The syntax Properties, followed by the number of components (an int), and the individual components (each a String).
Throws:
IOException

Class javax.naming.ConfigurationException extends NamingException implements Serializable

serialVersionUID: -2535156726228855704L

Class javax.naming.ContextNotEmptyException extends NamingException implements Serializable

serialVersionUID: 1090963683348219877L

Class javax.naming.InsufficientResourcesException extends NamingException implements Serializable

serialVersionUID: 6227672693037844532L

Class javax.naming.InterruptedNamingException extends NamingException implements Serializable

serialVersionUID: 6404516648893194728L

Class javax.naming.InvalidNameException extends NamingException implements Serializable

serialVersionUID: -8370672380823801105L

Class javax.naming.LimitExceededException extends NamingException implements Serializable

serialVersionUID: -776898738660207856L

Class javax.naming.LinkException extends NamingException implements Serializable

serialVersionUID: -7967662604076777712L

Serialized Fields

linkResolvedName

Name linkResolvedName
Contains the part of the link that has been successfully resolved. It is a composite name and can be null. This field is initialized by the constructors. You should access and manipulate this field through its get and set methods.

See Also:
LinkException.getLinkResolvedName(), LinkException.setLinkResolvedName(javax.naming.Name)

linkResolvedObj

Object linkResolvedObj
Contains the object to which resolution of the part of the link was successful. Can be null. This field is initialized by the constructors. You should access and manipulate this field through its get and set methods.

See Also:
LinkException.getLinkResolvedObj(), LinkException.setLinkResolvedObj(java.lang.Object)

linkRemainingName

Name linkRemainingName
Contains the remaining link name that has not been resolved yet. It is a composite name and can be null. This field is initialized by the constructors. You should access and manipulate this field through its get and set methods.

See Also:
LinkException.getLinkRemainingName(), LinkException.setLinkRemainingName(javax.naming.Name)

linkExplanation

String linkExplanation
Contains the exception of why resolution of the link failed. Can be null. This field is initialized by the constructors. You should access and manipulate this field through its get and set methods.

See Also:
LinkException.getLinkExplanation(), LinkException.setLinkExplanation(java.lang.String)

Class javax.naming.LinkLoopException extends LinkException implements Serializable

serialVersionUID: -3119189944325198009L

Class javax.naming.LinkRef extends Reference implements Serializable

serialVersionUID: -5386290613498931298L

Class javax.naming.MalformedLinkException extends LinkException implements Serializable

serialVersionUID: -3066740437737830242L

Class javax.naming.NameAlreadyBoundException extends NamingException implements Serializable

serialVersionUID: -8491441000356780586L

Class javax.naming.NameClassPair extends Object implements Serializable

serialVersionUID: 5620776610160863339L

Serialized Fields

name

String name
Contains the name of this NameClassPair. It is initialized by the constructor and can be updated using setName().

See Also:
NameClassPair.getName(), NameClassPair.setName(java.lang.String)

className

String className
Contains the class name contained in this NameClassPair. It is initialized by the constructor and can be updated using setClassName().

See Also:
NameClassPair.getClassName(), NameClassPair.setClassName(java.lang.String)

fullName

String fullName
Contains the full name of this NameClassPair within its own namespace. It is initialized using setNameInNamespace()

See Also:
NameClassPair.getNameInNamespace(), NameClassPair.setNameInNamespace(java.lang.String)

isRel

boolean isRel
Records whether the name of this NameClassPair is relative to the target context. It is initialized by the constructor and can be updated using setRelative().

See Also:
NameClassPair.isRelative(),
NameClassPair.setRelative(boolean),
NameClassPair.getName(),
NameClassPair.setName(java.lang.String)

Class javax.naming.NameNotFoundException extends NamingException implements Serializable

serialVersionUID: -8007156725367842053L

Class javax.naming.NamingException extends Exception implements Serializable

serialVersionUID: -1299181962103167177L

Serialized Fields

resolvedName

Name resolvedName
Contains the part of the name that has been successfully resolved. It is a composite name and can be null. This field is initialized by the constructors. You should access and manipulate this field through its get and set methods.

See Also:
NamingException.getResolvedName(), NamingException.setResolvedName(javax.naming.Name)

resolvedObj

Object resolvedObj
Contains the object to which resolution of the part of the name was successful. Can be null. This field is initialized by the constructors. You should access and manipulate this field through its get and set methods.

See Also:
NamingException.getResolvedObj(), NamingException.setResolvedObj(java.lang.Object)

remainingName

Name remainingName
Contains the remaining name that has not been resolved yet. It is a composite name and can be null. This field is initialized by the constructors. You should access and manipulate this field through its get, set, "append" methods.

See Also:
NamingException.getRemainingName(),
NamingException.setRemainingName(javax.naming.Name),
NamingException.appendRemainingName(javax.naming.Name),
NamingException.appendRemainingComponent(java.lang.String)

rootException

Throwable rootException
Contains the original exception that caused this NamingException to be thrown. This field is set if there is additional information that could be obtained from the original exception, or if the original exception could not be mapped to a subclass of NamingException. Can be null.

This field predates the general-purpose exception chaining facility. The NamingException.initCause(Throwable) and NamingException.getCause() methods are now the preferred means of accessing this information.

See Also:
NamingException.getRootCause(),
NamingException.setRootCause(Throwable),
NamingException.initCause(Throwable),
NamingException.getCause()

Class javax.naming.NamingSecurityException extends NamingException implements Serializable

serialVersionUID: 5855287647294685775L

Class javax.naming.NoInitialContextException extends NamingException implements Serializable

serialVersionUID: -3413733186901258623L

Class javax.naming.NoPermissionException extends NamingSecurityException implements Serializable

serialVersionUID: 8395332708699751775L

Class javax.naming.NotContextException extends NamingException implements Serializable

serialVersionUID: 849752551644540417L

Class javax.naming.OperationNotSupportedException extends NamingException implements Serializable

serialVersionUID: 5493232822427682064L

Class javax.naming.PartialResultException extends NamingException implements Serializable

serialVersionUID: 2572144970049426786L

Class javax.naming.RefAddr extends Object implements Serializable

serialVersionUID: -1468165120479154358L

Serialized Fields

addrType

String addrType
Contains the type of this address.

Class javax.naming.Reference extends Object implements Serializable

serialVersionUID: -1673475790065791735L

Serialized Fields

className

String className
Contains the fully-qualified name of the class of the object to which this Reference refers.

See Also:
Class.getName()

addrs

Vector<E> addrs
Contains the addresses contained in this Reference. Initialized by constructor.

classFactory

String classFactory
Contains the name of the factory class for creating an instance of the object to which this Reference refers. Initialized to null.

classFactoryLocation

String classFactoryLocation
Contains the location of the factory class. Initialized to null.

Class javax.naming.ReferralException extends NamingException implements Serializable

serialVersionUID: -2881363844695698876L

Class javax.naming.ServiceUnavailableException extends NamingException implements Serializable

serialVersionUID: -4996964726566773444L

Class javax.naming.SizeLimitExceededException extends LimitExceededException implements Serializable

serialVersionUID: 7129289564879168579L

Class javax.naming.StringRefAddr extends RefAddr implements Serializable

serialVersionUID: -8913762495138505527L

Serialized Fields

contents

String contents
Contains the contents of this address. Can be null.

Class javax.naming.TimeLimitExceededException extends LimitExceededException implements Serializable

serialVersionUID: -3597009011385034696L

Package javax.naming.directory

Class javax.naming.directory.AttributeInUseException extends NamingException implements Serializable

serialVersionUID: 4437710305529322564L

Class javax.naming.directory.AttributeModificationException extends NamingException implements Serializable

serialVersionUID: 8060676069678710186L

Serialized Fields

unexecs

ModificationItem[] unexecs
Contains the possibly null list of unexecuted modifications.

Class javax.naming.directory.BasicAttribute extends Object implements Serializable

serialVersionUID: 6743528196119291326L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Overridden to avoid exposing implementation details.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Overridden to avoid exposing implementation details

Serial Data:
Default field (the attribute ID -- a String), followed by the number of values (an int), and the individual values.
Throws:
IOException
Serialized Fields

attrID

String attrID
Holds the attribute's id. It is initialized by the public constructor and cannot be null unless methods in BasicAttribute that use attrID have been overridden.

ordered

boolean ordered
A flag for recording whether this attribute's values are ordered.

Class javax.naming.directory.BasicAttributes extends Object implements Serializable

serialVersionUID: 4980164073184639448L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Overridden to avoid exposing implementation details.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Overridden to avoid exposing implementation details.

Serial Data:
Default field (ignoreCase flag -- a boolean), followed by the number of attributes in the set (an int), and then the individual Attribute objects.
Throws:
IOException
Serialized Fields

ignoreCase

boolean ignoreCase
Indicates whether case of attribute ids is ignored.

Class javax.naming.directory.InvalidAttributeIdentifierException extends NamingException implements Serializable

serialVersionUID: -9036920266322999923L

Class javax.naming.directory.InvalidAttributesException extends NamingException implements Serializable

serialVersionUID: 2607612850539889765L

Class javax.naming.directory.InvalidAttributeValueException extends NamingException implements Serializable

serialVersionUID: 8720050295499275011L

Class javax.naming.directory.InvalidSearchControlsException extends NamingException implements Serializable

serialVersionUID: -5124108943352665777L

Class javax.naming.directory.InvalidSearchFilterException extends NamingException implements Serializable

serialVersionUID: 2902700940682875441L

Class javax.naming.directory.ModificationItem extends Object implements Serializable

serialVersionUID: 7573258562534746850L

Serialized Fields

mod_op

int mod_op
Contains an integer identify the modification to be performed.

attr

Attribute attr
Contains the attribute identifying the attribute and/or its value to be applied for the modification.

Class javax.naming.directory.NoSuchAttributeException extends NamingException implements Serializable

serialVersionUID: 4836415647935888137L

Class javax.naming.directory.SchemaViolationException extends NamingException implements Serializable

serialVersionUID: -3041762429525049663L

Class javax.naming.directory.SearchControls extends Object implements Serializable

serialVersionUID: -2480540967773454797L

Serialized Fields

searchScope

int searchScope
Contains the scope with which to apply the search. One of ONELEVEL_SCOPE, OBJECT_SCOPE, or SUBTREE_SCOPE.

timeLimit

int timeLimit
Contains the milliseconds to wait before returning from search.

derefLink

boolean derefLink
Indicates whether JNDI links are dereferenced during search.

returnObj

boolean returnObj
Indicates whether object is returned in SearchResult.

countLimit

long countLimit
Contains the maximum number of SearchResults to return.

attributesToReturn

String[] attributesToReturn
Contains the list of attributes to be returned in SearchResult for each matching entry of search. null indicates that all attributes are to be returned.

Class javax.naming.directory.SearchResult extends Binding implements Serializable

serialVersionUID: -9158063327699723172L

Serialized Fields

attrs

Attributes attrs
Contains the attributes returned with the object.

Package javax.naming.event

Class javax.naming.event.NamingEvent extends EventObject implements Serializable

serialVersionUID: -7126752885365133499L

Serialized Fields

changeInfo

Object changeInfo
Contains information about the change that generated this event.

type

int type
Contains the type of this event.

See Also:
NamingEvent.OBJECT_ADDED, NamingEvent.OBJECT_REMOVED, NamingEvent.OBJECT_RENAMED, NamingEvent.OBJECT_CHANGED

oldBinding

Binding oldBinding
Contains information about the object before the change.

newBinding

Binding newBinding
Contains information about the object after the change.

Class javax.naming.event.NamingExceptionEvent extends EventObject implements Serializable

serialVersionUID: -4877678086134736336L

Serialized Fields

exception

NamingException exception
Contains the exception that was thrown

Package javax.naming.ldap

Class javax.naming.ldap.BasicControl extends Object implements Serializable

serialVersionUID: -4233907508771791687L

Serialized Fields

id

String id
The control's object identifier string.

criticality

boolean criticality
The control's criticality.

value

byte[] value
The control's ASN.1 BER encoded value.

Class javax.naming.ldap.LdapName extends Object implements Serializable

serialVersionUID: -1595520034788997356L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Serializes only the unparsed DN, for compactness and to avoid any implementation dependency.

Serial Data:
The DN string
Throws:
IOException

Class javax.naming.ldap.LdapReferralException extends ReferralException implements Serializable

serialVersionUID: -1668992791764950804L

Class javax.naming.ldap.ManageReferralControl extends BasicControl implements Serializable

serialVersionUID: 3017756160149982566L

Class javax.naming.ldap.PagedResultsControl extends BasicControl implements Serializable

serialVersionUID: 6684806685736844298L

Class javax.naming.ldap.PagedResultsResponseControl extends BasicControl implements Serializable

serialVersionUID: -8819778744844514666L

Serialized Fields

resultSize

int resultSize
An estimate of the number of entries in the search result.

cookie

byte[] cookie
A server-generated cookie.

Class javax.naming.ldap.Rdn extends Object implements Serializable

serialVersionUID: -5994465067210009656L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Serializes only the unparsed RDN, for compactness and to avoid any implementation dependency.

Serial Data:
The RDN string
Throws:
IOException

Class javax.naming.ldap.SortControl extends BasicControl implements Serializable

serialVersionUID: -1965961680233330744L

Class javax.naming.ldap.SortResponseControl extends BasicControl implements Serializable

serialVersionUID: 5142939176006310877L

Serialized Fields

resultCode

int resultCode
The sort result code.

badAttrId

String badAttrId
The ID of the attribute that caused the sort to fail.

Class javax.naming.ldap.StartTlsRequest extends Object implements Serializable

serialVersionUID: 4441679576360753397L

Class javax.naming.ldap.StartTlsResponse extends Object implements Serializable

serialVersionUID: 8372842182579276418L

Class javax.naming.ldap.UnsolicitedNotificationEvent extends EventObject implements Serializable

serialVersionUID: -2382603380799883705L

Serialized Fields

notice

UnsolicitedNotification notice
The notification that caused this event to be fired.

Package javax.naming.spi

Class javax.naming.spi.ResolveResult extends Object implements Serializable

serialVersionUID: -4552108072002407559L

Serialized Fields

resolvedObj

Object resolvedObj
Field containing the Object that was resolved to successfully. It can be null only when constructed using a subclass. Constructors should always initialize this.

remainingName

Name remainingName
Field containing the remaining name yet to be resolved. It can be null only when constructed using a subclass. Constructors should always initialize this.

Package javax.net.ssl

Class javax.net.ssl.HandshakeCompletedEvent extends EventObject implements Serializable

serialVersionUID: 7914963744257769778L

Class javax.net.ssl.SSLException extends IOException implements Serializable

serialVersionUID: 4511006460650708967L

Class javax.net.ssl.SSLHandshakeException extends SSLException implements Serializable

serialVersionUID: -5045881315018326890L

Class javax.net.ssl.SSLKeyException extends SSLException implements Serializable

serialVersionUID: -8071664081941937874L

Class javax.net.ssl.SSLPeerUnverifiedException extends SSLException implements Serializable

serialVersionUID: -8919512675000600547L

Class javax.net.ssl.SSLPermission extends BasicPermission implements Serializable

serialVersionUID: -3456898025505876775L

Class javax.net.ssl.SSLProtocolException extends SSLException implements Serializable

serialVersionUID: 5445067063799134928L

Class javax.net.ssl.SSLSessionBindingEvent extends EventObject implements Serializable

serialVersionUID: 3989172637106345L

Serialized Fields

name

String name
The name to which the object is being bound or unbound
Package javax.print

Class javax.print.DocFlavor extends Object implements Serializable

serialVersionUID: -4512080796965449721L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
Reconstitute an instance from a stream (that is, deserialize it).

Serial Data:
The serialised form of a DocFlavor is the String naming the representation class followed by the String representing the canonical form of the mime type.
Throws:
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Write the instance to a stream (ie serialize the object).

Throws:
IOException
Serialized Fields

myClassName

String myClassName
Representation class name.

Class javax.print.DocFlavor.BYTE_ARRAY extends DocFlavor implements Serializable

serialVersionUID: -9065578006593857475L

Class javax.print.DocFlavor.CHAR_ARRAY extends DocFlavor implements Serializable

serialVersionUID: -8720590903724405128L

Class javax.print.DocFlavor.INPUT_STREAM extends DocFlavor implements Serializable

serialVersionUID: -7045842700749194127L

Class javax.print.DocFlavor.READER extends DocFlavor implements Serializable

serialVersionUID: 7100295812579351567L

Class javax.print.DocFlavor.SERVICE_FORMATTED extends DocFlavor implements Serializable

serialVersionUID: 6181337766266637256L

Class javax.print.DocFlavor.STRING extends DocFlavor implements Serializable

serialVersionUID: 4414407504887034035L

Class javax.print.DocFlavor.URL extends DocFlavor implements Serializable

Class javax.print.PrintException extends Exception implements Serializable

Package javax.print.attribute

Class javax.print.attribute.AttributeSetUtilities.SynchronizedAttributeSet extends Object implements Serializable

Serialized Fields

attrset

AttributeSet attrset

Class javax.print.attribute.AttributeSetUtilities.SynchronizedDocAttributeSet extends javax.print.attribute.AttributeSetUtilities.SynchronizedAttributeSet implements Serializable

Class javax.print.attribute.AttributeSetUtilities.SynchronizedPrintJobAttributeSet extends javax.print.attribute.AttributeSetUtilities.SynchronizedAttributeSet implements Serializable

Class javax.print.attribute.AttributeSetUtilities.SynchronizedPrintRequestAttributeSet extends javax.print.attribute.AttributeSetUtilities.SynchronizedAttributeSet implements Serializable

Class javax.print.attribute.AttributeSetUtilities.SynchronizedPrintServiceAttributeSet extends javax.print.attribute.AttributeSetUtilities.SynchronizedAttributeSet implements Serializable

Class javax.print.attribute.AttributeSetUtilities.UnmodifiableAttributeSet extends Object implements Serializable

Serialized Fields

attrset

AttributeSet attrset

Class javax.print.attribute.AttributeSetUtilities.UnmodifiableDocAttributeSet extends javax.print.attribute.AttributeSetUtilities.UnmodifiableAttributeSet implements Serializable

Class javax.print.attribute.AttributeSetUtilities.UnmodifiablePrintJobAttributeSet extends javax.print.attribute.AttributeSetUtilities.UnmodifiableAttributeSet implements Serializable

Class javax.print.attribute.AttributeSetUtilities.UnmodifiablePrintRequestAttributeSet extends javax.print.attribute.AttributeSetUtilities.UnmodifiableAttributeSet implements Serializable

Class javax.print.attribute.AttributeSetUtilities.UnmodifiablePrintServiceAttributeSet extends javax.print.attribute.AttributeSetUtilities.UnmodifiableAttributeSet implements Serializable

Class javax.print.attribute.DateTimeSyntax extends Object implements Serializable

serialVersionUID: -1400819079791208582L

Serialized Fields

value

Date value
This date-time attribute'sjava.util.Date value.

Class javax.print.attribute.EnumSyntax extends Object implements Serializable

serialVersionUID: -2739521845085831642L

Serialization Methods

readResolve

protected Object readResolve()
                      throws ObjectStreamException
During object input, convert this deserialized enumeration instance to the proper enumeration value defined in the enumeration attribute class.

Throws:
ObjectStreamException - if the stream can't be deserialised
InvalidObjectException - Thrown if the enumeration value table is null, this enumeration value's integer value does not correspond to an element in the enumeration value table, or the corresponding element in the enumeration value table is null. (Note: InvalidObjectException is a subclass of ObjectStreamException, which readResolve() is declared to throw.)
Serialized Fields

value

int value
This enumeration value's integer value.

Class javax.print.attribute.HashAttributeSet extends Object implements Serializable

serialVersionUID: 5311560590283707917L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
Reconstitute an instance from a stream that is, deserialize it).

Throws:
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Write the instance to a stream (ie serialize the object)

Serial Data:
The serialized form of an attribute set explicitly writes the number of attributes in the set, and each of the attributes. This does not guarantee equality of serialized forms since the order in which the attributes are written is not defined.
Throws:
IOException
Serialized Fields

myInterface

Class<T> myInterface
The interface of which all members of this attribute set must be an instance. It is assumed to be interface Attribute or a subinterface thereof.

Class javax.print.attribute.HashDocAttributeSet extends HashAttributeSet implements Serializable

serialVersionUID: -1128534486061432528L

Class javax.print.attribute.HashPrintJobAttributeSet extends HashAttributeSet implements Serializable

serialVersionUID: -4204473656070350348L

Class javax.print.attribute.HashPrintRequestAttributeSet extends HashAttributeSet implements Serializable

serialVersionUID: 2364756266107751933L

Class javax.print.attribute.HashPrintServiceAttributeSet extends HashAttributeSet implements Serializable

serialVersionUID: 6642904616179203070L

Class javax.print.attribute.IntegerSyntax extends Object implements Serializable

serialVersionUID: 3644574816328081943L

Serialized Fields

value

int value
This integer attribute's integer value.

Class javax.print.attribute.ResolutionSyntax extends Object implements Serializable

serialVersionUID: 2706743076526672017L

Serialized Fields

crossFeedResolution

int crossFeedResolution
Cross feed direction resolution in units of dots per 100 inches (dphi).

feedResolution

int feedResolution
Feed direction resolution in units of dots per 100 inches (dphi).

Class javax.print.attribute.SetOfIntegerSyntax extends Object implements Serializable

serialVersionUID: 3666874174847632203L

Serialized Fields

members

int[][] members
This set's members in canonical array form.

Class javax.print.attribute.Size2DSyntax extends Object implements Serializable

serialVersionUID: 5584439964938660530L

Serialized Fields

x

int x
X dimension in units of micrometers (µm).

y

int y
Y dimension in units of micrometers (µm).

Class javax.print.attribute.TextSyntax extends Object implements Serializable

serialVersionUID: -8130648736378144102L

Serialized Fields

value

String value
String value of this text attribute.

locale

Locale locale
Locale of this text attribute.

Class javax.print.attribute.UnmodifiableSetException extends RuntimeException implements Serializable

Class javax.print.attribute.URISyntax extends Object implements Serializable

serialVersionUID: -7842661210486401678L

Serialized Fields

uri

URI uri
URI value of this URI attribute.

Package javax.print.attribute.standard

Class javax.print.attribute.standard.Chromaticity extends EnumSyntax implements Serializable

serialVersionUID: 4660543931355214012L

Class javax.print.attribute.standard.ColorSupported extends EnumSyntax implements Serializable

serialVersionUID: -2700555589688535545L

Class javax.print.attribute.standard.Compression extends EnumSyntax implements Serializable

serialVersionUID: -5716748913324997674L

Class javax.print.attribute.standard.Copies extends IntegerSyntax implements Serializable

serialVersionUID: -6426631521680023833L

Class javax.print.attribute.standard.CopiesSupported extends SetOfIntegerSyntax implements Serializable

serialVersionUID: 6927711687034846001L

Class javax.print.attribute.standard.DateTimeAtCompleted extends DateTimeSyntax implements Serializable

serialVersionUID: 6497399708058490000L

Class javax.print.attribute.standard.DateTimeAtCreation extends DateTimeSyntax implements Serializable

serialVersionUID: -2923732231056647903L

Class javax.print.attribute.standard.DateTimeAtProcessing extends DateTimeSyntax implements Serializable

serialVersionUID: -3710068197278263244L

Class javax.print.attribute.standard.Destination extends URISyntax implements Serializable

serialVersionUID: 6776739171700415321L

Class javax.print.attribute.standard.DialogTypeSelection extends EnumSyntax implements Serializable

Class javax.print.attribute.standard.DocumentName extends TextSyntax implements Serializable

serialVersionUID: 7883105848533280430L

Class javax.print.attribute.standard.Fidelity extends EnumSyntax implements Serializable

serialVersionUID: 6320827847329172308L

Class javax.print.attribute.standard.Finishings extends EnumSyntax implements Serializable

serialVersionUID: -627840419548391754L

Class javax.print.attribute.standard.JobHoldUntil extends DateTimeSyntax implements Serializable

serialVersionUID: -1664471048860415024L

Class javax.print.attribute.standard.JobImpressions extends IntegerSyntax implements Serializable

serialVersionUID: 8225537206784322464L

Class javax.print.attribute.standard.JobImpressionsCompleted extends IntegerSyntax implements Serializable

serialVersionUID: 6722648442432393294L

Class javax.print.attribute.standard.JobImpressionsSupported extends SetOfIntegerSyntax implements Serializable

serialVersionUID: -4887354803843173692L

Class javax.print.attribute.standard.JobKOctets extends IntegerSyntax implements Serializable

serialVersionUID: -8959710146498202869L

Class javax.print.attribute.standard.JobKOctetsProcessed extends IntegerSyntax implements Serializable

serialVersionUID: -6265238509657881806L

Class javax.print.attribute.standard.JobKOctetsSupported extends SetOfIntegerSyntax implements Serializable

serialVersionUID: -2867871140549897443L

Class javax.print.attribute.standard.JobMediaSheets extends IntegerSyntax implements Serializable

serialVersionUID: 408871131531979741L

Class javax.print.attribute.standard.JobMediaSheetsCompleted extends IntegerSyntax implements Serializable

serialVersionUID: 1739595973810840475L

Class javax.print.attribute.standard.JobMediaSheetsSupported extends SetOfIntegerSyntax implements Serializable

serialVersionUID: 2953685470388672940L

Class javax.print.attribute.standard.JobMessageFromOperator extends TextSyntax implements Serializable

serialVersionUID: -4620751846003142047L

Class javax.print.attribute.standard.JobName extends TextSyntax implements Serializable

serialVersionUID: 4660359192078689545L

Class javax.print.attribute.standard.JobOriginatingUserName extends TextSyntax implements Serializable

serialVersionUID: -8052537926362933477L

Class javax.print.attribute.standard.JobPriority extends IntegerSyntax implements Serializable

serialVersionUID: -4599900369040602769L

Class javax.print.attribute.standard.JobPrioritySupported extends IntegerSyntax implements Serializable

serialVersionUID: 2564840378013555894L

Class javax.print.attribute.standard.JobSheets extends EnumSyntax implements Serializable

serialVersionUID: -4735258056132519759L

Class javax.print.attribute.standard.JobState extends EnumSyntax implements Serializable

serialVersionUID: 400465010094018920L

Class javax.print.attribute.standard.JobStateReason extends EnumSyntax implements Serializable

serialVersionUID: -8765894420449009168L

Class javax.print.attribute.standard.JobStateReasons extends HashSet<JobStateReason> implements Serializable

serialVersionUID: 8849088261264331812L

Class javax.print.attribute.standard.Media extends EnumSyntax implements Serializable

serialVersionUID: -2823970704630722439L

Class javax.print.attribute.standard.MediaName extends Media implements Serializable

serialVersionUID: 4653117714524155448L

Class javax.print.attribute.standard.MediaPrintableArea extends Object implements Serializable

serialVersionUID: -1597171464050795793L

Serialized Fields

x

int x

y

int y

w

int w

h

int h

units

int units

Class javax.print.attribute.standard.MediaSize extends Size2DSyntax implements Serializable

serialVersionUID: -1967958664615414771L

Serialized Fields

mediaName

MediaSizeName mediaName

Class javax.print.attribute.standard.MediaSizeName extends Media implements Serializable

serialVersionUID: 2778798329756942747L

Class javax.print.attribute.standard.MediaTray extends Media implements Serializable

serialVersionUID: -982503611095214703L

Class javax.print.attribute.standard.MultipleDocumentHandling extends EnumSyntax implements Serializable

serialVersionUID: 8098326460746413466L

Class javax.print.attribute.standard.NumberOfDocuments extends IntegerSyntax implements Serializable

serialVersionUID: 7891881310684461097L

Class javax.print.attribute.standard.NumberOfInterveningJobs extends IntegerSyntax implements Serializable

serialVersionUID: 2568141124844982746L

Class javax.print.attribute.standard.NumberUp extends IntegerSyntax implements Serializable

serialVersionUID: -3040436486786527811L

Class javax.print.attribute.standard.NumberUpSupported extends SetOfIntegerSyntax implements Serializable

serialVersionUID: -1041573395759141805L

Class javax.print.attribute.standard.OrientationRequested extends EnumSyntax implements Serializable

serialVersionUID: -4447437289862822276L

Class javax.print.attribute.standard.OutputDeviceAssigned extends TextSyntax implements Serializable

serialVersionUID: 5486733778854271081L

Class javax.print.attribute.standard.PageRanges extends SetOfIntegerSyntax implements Serializable

serialVersionUID: 8639895197656148392L

Class javax.print.attribute.standard.PagesPerMinute extends IntegerSyntax implements Serializable

serialVersionUID: -6366403993072862015L

Class javax.print.attribute.standard.PagesPerMinuteColor extends IntegerSyntax implements Serializable

serialVersionUID: 1684993151687470944L

Class javax.print.attribute.standard.PDLOverrideSupported extends EnumSyntax implements Serializable

serialVersionUID: -4393264467928463934L

Class javax.print.attribute.standard.PresentationDirection extends EnumSyntax implements Serializable

serialVersionUID: 8294728067230931780L

Class javax.print.attribute.standard.PrinterInfo extends TextSyntax implements Serializable

serialVersionUID: 7765280618777599727L

Class javax.print.attribute.standard.PrinterIsAcceptingJobs extends EnumSyntax implements Serializable

serialVersionUID: -5052010680537678061L

Class javax.print.attribute.standard.PrinterLocation extends TextSyntax implements Serializable

serialVersionUID: -1598610039865566337L

Class javax.print.attribute.standard.PrinterMakeAndModel extends TextSyntax implements Serializable

serialVersionUID: 4580461489499351411L

Class javax.print.attribute.standard.PrinterMessageFromOperator extends TextSyntax implements Serializable

serialVersionUID: -4486871203218629318L

Class javax.print.attribute.standard.PrinterMoreInfo extends URISyntax implements Serializable

serialVersionUID: 4555850007675338574L

Class javax.print.attribute.standard.PrinterMoreInfoManufacturer extends URISyntax implements Serializable

serialVersionUID: 3323271346485076608L

Class javax.print.attribute.standard.PrinterName extends TextSyntax implements Serializable

serialVersionUID: 299740639137803127L

Class javax.print.attribute.standard.PrinterResolution extends ResolutionSyntax implements Serializable

serialVersionUID: 13090306561090558L

Class javax.print.attribute.standard.PrinterState extends EnumSyntax implements Serializable

serialVersionUID: -649578618346507718L

Class javax.print.attribute.standard.PrinterStateReason extends EnumSyntax implements Serializable

serialVersionUID: -1623720656201472593L

Class javax.print.attribute.standard.PrinterStateReasons extends HashMap<PrinterStateReason,Severity> implements Serializable

serialVersionUID: -3731791085163619457L

Class javax.print.attribute.standard.PrinterURI extends URISyntax implements Serializable

serialVersionUID: 7923912792485606497L

Class javax.print.attribute.standard.PrintQuality extends EnumSyntax implements Serializable

serialVersionUID: -3072341285225858365L

Class javax.print.attribute.standard.QueuedJobCount extends IntegerSyntax implements Serializable

serialVersionUID: 7499723077864047742L

Class javax.print.attribute.standard.ReferenceUriSchemesSupported extends EnumSyntax implements Serializable

serialVersionUID: -8989076942813442805L

Class javax.print.attribute.standard.RequestingUserName extends TextSyntax implements Serializable

serialVersionUID: -2683049894310331454L

Class javax.print.attribute.standard.Severity extends EnumSyntax implements Serializable

serialVersionUID: 8781881462717925380L

Class javax.print.attribute.standard.SheetCollate extends EnumSyntax implements Serializable

serialVersionUID: 7080587914259873003L

Class javax.print.attribute.standard.Sides extends EnumSyntax implements Serializable

serialVersionUID: -6890309414893262822L

Package javax.print.event

Class javax.print.event.PrintEvent extends EventObject implements Serializable

serialVersionUID: 2286914924430763847L

Class javax.print.event.PrintJobAttributeEvent extends PrintEvent implements Serializable

serialVersionUID: -6534469883874742101L

Serialized Fields

attributes

PrintJobAttributeSet attributes

Class javax.print.event.PrintJobEvent extends PrintEvent implements Serializable

serialVersionUID: -1711656903622072997L

Serialized Fields

reason

int reason

Class javax.print.event.PrintServiceAttributeEvent extends PrintEvent implements Serializable

serialVersionUID: -7565987018140326600L

Serialized Fields

attributes

PrintServiceAttributeSet attributes
Package javax.rmi.CORBA

Class javax.rmi.CORBA.ClassDesc extends Object implements Serializable

Serialized Fields

repid

String repid
The class's RepositoryId.

codebase

String codebase
A space-separated list of codebase URLs.

Class javax.rmi.CORBA.Stub extends ObjectImpl implements Serializable

serialVersionUID: 1087775603798577179L

Serialization Methods

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
Serialization method to restore the IOR state.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream stream)
                  throws IOException
Serialization method to save the IOR state.

Serial Data:
The length of the IOR type ID (int), followed by the IOR type ID (byte array encoded using ISO8859-1), followed by the number of IOR profiles (int), followed by the IOR profiles. Each IOR profile is written as a profile tag (int), followed by the length of the profile data (int), followed by the profile data (byte array).
Throws:
IOException
Package javax.rmi.ssl

Class javax.rmi.ssl.SslRMIClientSocketFactory extends Object implements Serializable

serialVersionUID: -8310631444933958385L

Package javax.script

Class javax.script.ScriptException extends Exception implements Serializable

Serialized Fields

fileName

String fileName

lineNumber

int lineNumber

columnNumber

int columnNumber
Package javax.security.auth

Class javax.security.auth.AuthPermission extends BasicPermission implements Serializable

serialVersionUID: 5806031445061587174L

Class javax.security.auth.DestroyFailedException extends Exception implements Serializable

serialVersionUID: -7790152857282749162L

Class javax.security.auth.PrivateCredentialPermission extends Permission implements Serializable

serialVersionUID: 5284372143517237068L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reads this object from a stream (i.e., deserializes it)

Throws:
IOException
ClassNotFoundException
Serialized Fields

credentialClass

String credentialClass

principals

Set<E> principals
The Principals associated with this permission. The set contains elements of type, PrivateCredentialPermission.CredOwner.

testing

boolean testing

Class javax.security.auth.PrivateCredentialPermission.CredOwner extends Object implements Serializable

serialVersionUID: -5607449830436408266L

Serialized Fields

principalClass

String principalClass

principalName

String principalName

Class javax.security.auth.RefreshFailedException extends Exception implements Serializable

serialVersionUID: 5058444488565265840L

Class javax.security.auth.Subject extends Object implements Serializable

serialVersionUID: -8308522755600156056L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Reads this object from a stream (i.e., deserializes it)

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
Writes this object out to a stream (i.e., serializes it).

Throws:
IOException
Serialized Fields

principals

Set<E> principals
A Set that provides a view of all of this Subject's Principals

Each element in this set is a java.security.Principal. The set is a Subject.SecureSet.

readOnly

boolean readOnly
Whether this Subject is read-only

Class javax.security.auth.Subject.SecureSet extends AbstractSet<E> implements Serializable

serialVersionUID: 7911754171111800359L

Serialization Methods

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
Writes this object out to a stream (i.e., serializes it).

Serial Data:
If this is a private credential set, a security check is performed to ensure that the caller has permission to access each credential in the set. If the security check passes, the set is serialized.
Throws:
IOException
Serialized Fields

elements

LinkedList<E> elements
The elements in this set.

this$0

Subject this$0
The outer Subject instance.
Package javax.security.auth.callback

Class javax.security.auth.callback.ChoiceCallback extends Object implements Serializable

serialVersionUID: -3975664071579892167L

Serialized Fields

prompt

String prompt
Since:
1.4

choices

String[] choices
the list of choices
Since:
1.4

defaultChoice

int defaultChoice
the choice to be used as the default choice
Since:
1.4

multipleSelectionsAllowed

boolean multipleSelectionsAllowed
whether multiple selections are allowed from the list of choices
Since:
1.4

selections

int[] selections
the selected choices, represented as indexes into the choices list.
Since:
1.4

Class javax.security.auth.callback.ConfirmationCallback extends Object implements Serializable

serialVersionUID: -9095656433782481624L

Serialized Fields

prompt

String prompt
Since:
1.4

messageType

int messageType
Since:
1.4

optionType

int optionType
Since:
1.4

defaultOption

int defaultOption
Since:
1.4

options

String[] options
Since:
1.4

selection

int selection
Since:
1.4

Class javax.security.auth.callback.LanguageCallback extends Object implements Serializable

serialVersionUID: 2019050433478903213L

Serialized Fields

locale

Locale locale
Since:
1.4

Class javax.security.auth.callback.NameCallback extends Object implements Serializable

serialVersionUID: 3770938795909392253L

Serialized Fields

prompt

String prompt
Since:
1.4

defaultName

String defaultName
Since:
1.4

inputName

String inputName
Since:
1.4

Class javax.security.auth.callback.PasswordCallback extends Object implements Serializable

serialVersionUID: 2267422647454909926L

Serialized Fields

prompt

String prompt
Since:
1.4

echoOn

boolean echoOn
Since:
1.4

inputPassword

char[] inputPassword
Since:
1.4

Class javax.security.auth.callback.TextInputCallback extends Object implements Serializable

serialVersionUID: -8064222478852811804L

Serialized Fields

prompt

String prompt
Since:
1.4

defaultText

String defaultText
Since:
1.4

inputText

String inputText
Since:
1.4

Class javax.security.auth.callback.TextOutputCallback extends Object implements Serializable

serialVersionUID: 1689502495511663102L

Serialized Fields

messageType

int messageType
Since:
1.4

message

String message
Since:
1.4

Class javax.security.auth.callback.UnsupportedCallbackException extends Exception implements Serializable

serialVersionUID: -6873556327655666839L

Serialized Fields

callback

Callback callback
Package javax.security.auth.kerberos

Class javax.security.auth.kerberos.DelegationPermission extends BasicPermission implements Serializable

serialVersionUID: 883133252142523922L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
readObject is called to restore the state of the DelegationPermission from a stream.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
WriteObject is called to save the state of the DelegationPermission to a stream. The actions are serialized, and the superclass takes care of the name.

Throws:
IOException

Class javax.security.auth.kerberos.KerberosKey extends Object implements Serializable

serialVersionUID: -4625402278148246993L

Serialized Fields

principal

KerberosPrincipal principal
The principal that this secret key belongs to.

versionNum

int versionNum
the version number of this secret key

key

javax.security.auth.kerberos.KeyImpl key
KeyImpl is serialized by writing out the ASN1 Encoded bytes of the encryption key. The ASN1 encoding is defined in RFC4120 and as follows:
 EncryptionKey   ::= SEQUENCE {
           keytype   [0] Int32 -- actually encryption type --,
           keyvalue  [1] OCTET STRING
 }

Class javax.security.auth.kerberos.KerberosPrincipal extends Object implements Serializable

serialVersionUID: -7374788026156829911L

Serialization Methods

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
Reads this object from a stream (i.e., deserializes it)

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
Save the KerberosPrincipal object to a stream

Serial Data:
this KerberosPrincipal is serialized by writing out the PrincipalName and the realm in their DER-encoded form as specified in Section 5.2.2 of RFC4120.
Throws:
IOException

Class javax.security.auth.kerberos.KerberosTicket extends Object implements Serializable

serialVersionUID: 7395334370157380539L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
Throws:
IOException
ClassNotFoundException
Serialized Fields

asn1Encoding

byte[] asn1Encoding
ASN.1 DER Encoding of the Ticket as defined in the Kerberos Protocol Specification RFC4120.

sessionKey

javax.security.auth.kerberos.KeyImpl sessionKey
KeyImpl is serialized by writing out the ASN1 Encoded bytes of the encryption key. The ASN1 encoding is defined in RFC4120 and as follows:
 EncryptionKey   ::= SEQUENCE {
          keytype    [0] Int32 -- actually encryption type --,
          keyvalue   [1] OCTET STRING
 }

flags

boolean[] flags
Ticket Flags as defined in the Kerberos Protocol Specification RFC4120.

authTime

Date authTime
Time of initial authentication

startTime

Date startTime
Time after which the ticket is valid.

endTime

Date endTime
Time after which the ticket will not be honored. (its expiration time).

renewTill

Date renewTill
For renewable Tickets it indicates the maximum endtime that may be included in a renewal. It can be thought of as the absolute expiration time for the ticket, including all renewals. This field may be null for tickets that are not renewable.

client

KerberosPrincipal client
Client that owns the service ticket

server

KerberosPrincipal server
The service for which the ticket was issued.

clientAddresses

InetAddress[] clientAddresses
The addresses from where the ticket may be used by the client. This field may be null when the ticket is usable from any address.

Class javax.security.auth.kerberos.KeyImpl extends Object implements Serializable

serialVersionUID: -7889313790214321193L

Serialization Methods

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream ois)
                  throws IOException
Serial Data:
this KeyImpl is serialized by writing out the ASN1 Encoded bytes of the encryption key. The ASN1 encoding is defined in RFC4120 and as follows: EncryptionKey ::= SEQUENCE { keytype [0] Int32 -- actually encryption type --, keyvalue [1] OCTET STRING }
Throws:
IOException

Class javax.security.auth.kerberos.ServicePermission extends Permission implements Serializable

serialVersionUID: -1227585031618624935L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
readObject is called to restore the state of the ServicePermission from a stream.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
WriteObject is called to save the state of the ServicePermission to a stream. The actions are serialized, and the superclass takes care of the name.

Throws:
IOException
Serialized Fields

actions

String actions
the actions string.

Package javax.security.auth.login

Class javax.security.auth.login.AccountException extends LoginException implements Serializable

serialVersionUID: -2112878680072211787L

Class javax.security.auth.login.AccountExpiredException extends AccountException implements Serializable

serialVersionUID: -6064064890162661560L

Class javax.security.auth.login.AccountLockedException extends AccountException implements Serializable

serialVersionUID: 8280345554014066334L

Class javax.security.auth.login.AccountNotFoundException extends AccountException implements Serializable

serialVersionUID: 1498349563916294614L

Class javax.security.auth.login.CredentialException extends LoginException implements Serializable

serialVersionUID: -4772893876810601859L

Class javax.security.auth.login.CredentialExpiredException extends CredentialException implements Serializable

serialVersionUID: -5344739593859737937L

Class javax.security.auth.login.CredentialNotFoundException extends CredentialException implements Serializable

serialVersionUID: -7779934467214319475L

Class javax.security.auth.login.FailedLoginException extends LoginException implements Serializable

serialVersionUID: 802556922354616286L

Class javax.security.auth.login.LoginException extends GeneralSecurityException implements Serializable

serialVersionUID: -4679091624035232488L

Package javax.security.auth.x500

Class javax.security.auth.x500.X500Principal extends Object implements Serializable

serialVersionUID: -500463348111345721L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        NotActiveException,
                        ClassNotFoundException
Reads this object from a stream (i.e., deserializes it).

Throws:
IOException
NotActiveException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Save the X500Principal object to a stream.

Serial Data:
this X500Principal is serialized by writing out its DER-encoded form (the value of getEncoded is serialized).
Throws:
IOException
Package javax.security.cert

Class javax.security.cert.CertificateEncodingException extends CertificateException implements Serializable

Class javax.security.cert.CertificateException extends Exception implements Serializable

Class javax.security.cert.CertificateExpiredException extends CertificateException implements Serializable

Class javax.security.cert.CertificateNotYetValidException extends CertificateException implements Serializable

Class javax.security.cert.CertificateParsingException extends CertificateException implements Serializable

Package javax.security.sasl

Class javax.security.sasl.AuthenticationException extends SaslException implements Serializable

serialVersionUID: -3579708765071815007L

Class javax.security.sasl.AuthorizeCallback extends Object implements Serializable

serialVersionUID: -2353344186490470805L

Serialized Fields

authenticationID

String authenticationID
The (authenticated) authentication id to check.

authorizationID

String authorizationID
The authorization id to check.

authorizedID

String authorizedID
The id of the authorized entity. If null, the id of the authorized entity is authorizationID.

authorized

boolean authorized
A flag indicating whether the authentication id is allowed to act on behalf of the authorization id.

Class javax.security.sasl.RealmCallback extends TextInputCallback implements Serializable

serialVersionUID: -4342673378785456908L

Class javax.security.sasl.RealmChoiceCallback extends ChoiceCallback implements Serializable

serialVersionUID: -8588141348846281332L

Class javax.security.sasl.SaslException extends IOException implements Serializable

serialVersionUID: 4579784287983423626L

Serialized Fields

_exception

Throwable _exception
The possibly null root cause exception.

Package javax.sound.midi

Class javax.sound.midi.InvalidMidiDataException extends Exception implements Serializable

Class javax.sound.midi.MidiUnavailableException extends Exception implements Serializable

Package javax.sound.sampled

Class javax.sound.sampled.AudioPermission extends BasicPermission implements Serializable

Class javax.sound.sampled.LineUnavailableException extends Exception implements Serializable

Class javax.sound.sampled.UnsupportedAudioFileException extends Exception implements Serializable

Package javax.sql

Class javax.sql.ConnectionEvent extends EventObject implements Serializable

serialVersionUID: -4843217645290030002L

Serialized Fields

ex

SQLException ex
The SQLException that the driver will throw to the application when an error occurs and the pooled connection is no longer usable.

Class javax.sql.RowSetEvent extends EventObject implements Serializable

serialVersionUID: -1875450876546332005L

Class javax.sql.StatementEvent extends EventObject implements Serializable

Serialized Fields

exception

SQLException exception

statement

PreparedStatement statement
Package javax.sql.rowset

Class javax.sql.rowset.BaseRowSet extends Object implements Serializable

serialVersionUID: 4886719666485113312L

Serialized Fields

binaryStream

InputStream binaryStream
The InputStream object that will be returned by the method getBinaryStream, which is specified in the ResultSet interface.

unicodeStream

InputStream unicodeStream
The InputStream object that will be returned by the method getUnicodeStream, which is specified in the ResultSet interface.

asciiStream

InputStream asciiStream
The InputStream object that will be returned by the method getAsciiStream, which is specified in the ResultSet interface.

charStream

Reader charStream
The Reader object that will be returned by the method getCharacterStream, which is specified in the ResultSet interface.

command

String command
The query that will be sent to the DBMS for execution when the method execute is called.

URL

String URL
The JDBC URL the reader, writer, or both supply to the method DriverManager.getConnection when the DriverManager is used to get a connection.

The JDBC URL identifies the driver to be used to make the conndection. This URL can be found in the documentation supplied by the driver vendor.

dataSource

String dataSource
The logical name of the data source that the reader/writer should use in order to retrieve a DataSource object from a Java Directory and Naming Interface (JNDI) naming service.

rowSetType

int rowSetType
A constant indicating the type of this JDBC RowSet object. It must be one of the following ResultSet constants: TYPE_FORWARD_ONLY, TYPE_SCROLL_INSENSITIVE, or TYPE_SCROLL_SENSITIVE.

showDeleted

boolean showDeleted
A boolean indicating whether deleted rows are visible in this JDBC RowSet object .

queryTimeout

int queryTimeout
The maximum number of seconds the driver will wait for a command to execute. This limit applies while this JDBC RowSet object is connected to its data source, that is, while it is populating itself with data and while it is writing data back to the data source.

maxRows

int maxRows
The maximum number of rows the reader should read.

maxFieldSize

int maxFieldSize
The maximum field size the reader should read.

concurrency

int concurrency
A constant indicating the concurrency of this JDBC RowSet object. It must be one of the following ResultSet constants: CONCUR_READ_ONLY or CONCUR_UPDATABLE.

readOnly

boolean readOnly
A boolean indicating whether this JDBC RowSet object is read-only. true indicates that it is read-only; false that it is writable.

escapeProcessing

boolean escapeProcessing
A boolean indicating whether the reader for this JDBC RowSet object should perform escape processing. true means that escape processing is turned on; false that it is not. The default is true.

isolation

int isolation
A constant indicating the isolation level of the connection for this JDBC RowSet object . It must be one of the following Connection constants: TRANSACTION_NONE, TRANSACTION_READ_UNCOMMITTED, TRANSACTION_READ_COMMITTED, TRANSACTION_REPEATABLE_READ or TRANSACTION_SERIALIZABLE.

fetchDir

int fetchDir
A constant used as a hint to the driver that indicates the direction in which data from this JDBC RowSet object is going to be fetched. The following ResultSet constants are possible values: FETCH_FORWARD, FETCH_REVERSE, FETCH_UNKNOWN.

Unused at this time.

fetchSize

int fetchSize
A hint to the driver that indicates the expected number of rows in this JDBC RowSet object .

Unused at this time.

map

Map<K,V> map
The java.util.Map object that contains entries mapping SQL type names to classes in the Java programming language for the custom mapping of user-defined types.

listeners

Vector<E> listeners
A Vector object that holds the list of listeners that have registered with this RowSet object.

params

Hashtable<K,V> params
A Vector object that holds the parameters set for this RowSet object's current command.

Class javax.sql.rowset.RowSetMetaDataImpl extends Object implements Serializable

serialVersionUID: 6893806403181801867L

Serialized Fields

colCount

int colCount
The number of columns in the RowSet object that created this RowSetMetaDataImpl object.

colInfo

javax.sql.rowset.RowSetMetaDataImpl.ColInfo[] colInfo
An array of ColInfo objects used to store information about each column in the RowSet object for which this RowSetMetaDataImpl object was created. The first ColInfo object in this array contains information about the first column in the RowSet object, the second element contains information about the second column, and so on.

Class javax.sql.rowset.RowSetWarning extends SQLException implements Serializable

serialVersionUID: 6678332766434564774L

Serialized Fields

rwarning

RowSetWarning rwarning
RowSetWarning object handle.

Package javax.sql.rowset.serial

Class javax.sql.rowset.serial.SerialArray extends Object implements Serializable

serialVersionUID: -8466174297270688520L

Serialized Fields

elements

Object[] elements
A serialized array in which each element is an Object in the Java programming language that represents an element in the SQL ARRAY value.

baseType

int baseType
The SQL type of the elements in this SerialArray object. The type is expressed as one of the constants from the class java.sql.Types.

baseTypeName

String baseTypeName
The type name used by the DBMS for the elements in the SQL ARRAY value that this SerialArray object represents.

len

int len
The number of elements in this SerialArray object, which is also the number of elements in the SQL ARRAY value that this SerialArray object represents.

Class javax.sql.rowset.serial.SerialBlob extends Object implements Serializable

serialVersionUID: -8144641928112860441L

Serialized Fields

buf

byte[] buf
A serialized array of uninterpreted bytes representing the value of this SerialBlob object.

blob

Blob blob
The internal representation of the Blob object on which this SerialBlob object is based.

len

long len
The number of bytes in this SerialBlob object's array of bytes.

origLen

long origLen
The orginal number of bytes in this SerialBlob object's array of bytes when it was first established.

Class javax.sql.rowset.serial.SerialClob extends Object implements Serializable

serialVersionUID: -1662519690087375313L

Serialized Fields

buf

char[] buf
A serialized array of characters containing the data of the SQL CLOB value that this SerialClob object represents.

clob

Clob clob
Internal Clob representation if SerialClob is intialized with a Clob

len

long len
The length in characters of this SerialClob object's internal array of characters.

origLen

long origLen
The original length in characters of tgus SerialClob objects internal array of characters.

Class javax.sql.rowset.serial.SerialDatalink extends Object implements Serializable

serialVersionUID: 2826907821828733626L

Serialized Fields

url

URL url
The extracted URL field retrieved from the DATALINK field.

baseType

int baseType
The SQL type of the elements in this SerialDatalink object. The type is expressed as one of the contants from the class java.sql.Types.

baseTypeName

String baseTypeName
The type name used by the DBMS for the elements in the SQL DATALINK value that this SerialDatalink object represents.

Class javax.sql.rowset.serial.SerialException extends SQLException implements Serializable

serialVersionUID: -489794565168592690L

Class javax.sql.rowset.serial.SerialJavaObject extends Object implements Serializable

serialVersionUID: -1465795139032831023L

Serialized Fields

obj

Object obj
Placeholder for object to be serialized.

chain

Vector<E> chain
A container for the warnings issued on this SerialJavaObject object. When there are multiple warnings, each warning is chained to the previous warning.

Class javax.sql.rowset.serial.SerialRef extends Object implements Serializable

serialVersionUID: -4727123500609662274L

Serialized Fields

baseTypeName

String baseTypeName
String containing the base type name.

object

Object object
This will store the type Ref as an Object.

reference

Ref reference
Private copy of the Ref reference.

Class javax.sql.rowset.serial.SerialStruct extends Object implements Serializable

serialVersionUID: -8322445504027483372L

Serialized Fields

SQLTypeName

String SQLTypeName
The SQL type name for the structured type that this SerialStruct object represents. This is the name used in the SQL definition of the SQL structured type.

attribs

Object[] attribs
An array of Object instances in which each element is an attribute of the SQL structured type that this SerialStruct object represents. The attributes are ordered according to their order in the definition of the SQL structured type.

Package javax.sql.rowset.spi

Class javax.sql.rowset.spi.SyncFactoryException extends SQLException implements Serializable

serialVersionUID: -4354595476433200352L

Class javax.sql.rowset.spi.SyncProviderException extends SQLException implements Serializable

serialVersionUID: -939908523620640692L

Serialized Fields

syncResolver

SyncResolver syncResolver
The instance of javax.sql.rowset.spi.SyncResolver that this SyncProviderException object will return when its getSyncResolver method is called.

Package javax.transaction

Class javax.transaction.InvalidTransactionException extends RemoteException implements Serializable

Class javax.transaction.TransactionRequiredException extends RemoteException implements Serializable

Class javax.transaction.TransactionRolledbackException extends RemoteException implements Serializable

Package javax.transaction.xa

Class javax.transaction.xa.XAException extends Exception implements Serializable

Serialized Fields

errorCode

int errorCode
The error code with which to create the SystemException.

The error code for the exception
Package javax.xml.bind

Class javax.xml.bind.DataBindingException extends RuntimeException implements Serializable

Class javax.xml.bind.JAXBElement extends Object implements Serializable

serialVersionUID: 1L

Serialized Fields

name

QName name
xml element tag name

declaredType

Class<T> declaredType
Java datatype binding for xml element declaration's type.

scope

Class<T> scope
Scope of xml element declaration representing this xml element instance. Can be one of the following values: - JAXBElement.GlobalScope for global xml element declaration. - local element declaration has a scope set to the Java class representation of complex type defintion containing xml element declaration.

value

Object value
xml element value. Represents content model and attributes of an xml element instance.

nil

boolean nil
true iff the xml element instance has xsi:nil="true".

Class javax.xml.bind.JAXBException extends Exception implements Serializable

serialVersionUID: -5621384651494307979L

Serialized Fields

errorCode

String errorCode
Vendor specific error code

linkedException

Throwable linkedException
Exception reference

Class javax.xml.bind.MarshalException extends JAXBException implements Serializable

Class javax.xml.bind.PropertyException extends JAXBException implements Serializable

Class javax.xml.bind.TypeConstraintException extends RuntimeException implements Serializable

Serialized Fields

errorCode

String errorCode
Vendor specific error code

linkedException

Throwable linkedException
Exception reference

Class javax.xml.bind.UnmarshalException extends JAXBException implements Serializable

Class javax.xml.bind.ValidationException extends JAXBException implements Serializable

Package javax.xml.crypto

Class javax.xml.crypto.KeySelectorException extends Exception implements Serializable

serialVersionUID: -7480033639322531109L

Serialized Fields

cause

Throwable cause
The throwable that caused this exception to get thrown, or null if this exception was not caused by another throwable or if the causative throwable is unknown.

Class javax.xml.crypto.MarshalException extends Exception implements Serializable

serialVersionUID: -863185580332643547L

Serialized Fields

cause

Throwable cause
The throwable that caused this exception to get thrown, or null if this exception was not caused by another throwable or if the causative throwable is unknown.

Class javax.xml.crypto.NoSuchMechanismException extends RuntimeException implements Serializable

serialVersionUID: 4189669069570660166L

Serialized Fields

cause

Throwable cause
The throwable that caused this exception to get thrown, or null if this exception was not caused by another throwable or if the causative throwable is unknown.

Class javax.xml.crypto.URIReferenceException extends Exception implements Serializable

serialVersionUID: 7173469703932561419L

Serialized Fields

cause

Throwable cause
The throwable that caused this exception to get thrown, or null if this exception was not caused by another throwable or if the causative throwable is unknown.

uriReference

URIReference uriReference
Package javax.xml.crypto.dsig

Class javax.xml.crypto.dsig.TransformException extends Exception implements Serializable

serialVersionUID: 5082634801360427800L

Serialized Fields

cause

Throwable cause
The throwable that caused this exception to get thrown, or null if this exception was not caused by another throwable or if the causative throwable is unknown.

Class javax.xml.crypto.dsig.XMLSignatureException extends Exception implements Serializable

serialVersionUID: -3438102491013869995L

Serialized Fields

cause

Throwable cause
The throwable that caused this exception to get thrown, or null if this exception was not caused by another throwable or if the causative throwable is unknown.

Package javax.xml.datatype

Class javax.xml.datatype.DatatypeConfigurationException extends Exception implements Serializable

Package javax.xml.namespace

Class javax.xml.namespace.QName extends Object implements Serializable

Serialized Fields

namespaceURI

String namespaceURI

Namespace URI of this QName.

localPart

String localPart

local part of this QName.

prefix

String prefix

prefix of this QName.

Package javax.xml.parsers

Class javax.xml.parsers.FactoryConfigurationError extends Error implements Serializable

Serialized Fields

exception

Exception exception
Exception that represents the error.

Class javax.xml.parsers.ParserConfigurationException extends Exception implements Serializable

Package javax.xml.soap

Class javax.xml.soap.SOAPException extends Exception implements Serializable

Serialized Fields

cause

Throwable cause
Package javax.xml.stream

Class javax.xml.stream.FactoryConfigurationError extends Error implements Serializable

Serialized Fields

nested

Exception nested

Class javax.xml.stream.XMLStreamException extends Exception implements Serializable

Serialized Fields

nested

Throwable nested

location

Location location
Package javax.xml.transform

Class javax.xml.transform.TransformerConfigurationException extends TransformerException implements Serializable

Class javax.xml.transform.TransformerException extends Exception implements Serializable

Serialized Fields

locator

SourceLocator locator
Field locator specifies where the error occured

containedException

Throwable containedException
Field containedException specifies a wrapped exception. May be null.

Class javax.xml.transform.TransformerFactoryConfigurationError extends Error implements Serializable

Serialized Fields

exception

Exception exception
Exception for the TransformerFactoryConfigurationError.

Package javax.xml.ws

Class javax.xml.ws.ProtocolException extends WebServiceException implements Serializable

Class javax.xml.ws.WebServiceException extends RuntimeException implements Serializable

Class javax.xml.ws.WebServicePermission extends BasicPermission implements Serializable

serialVersionUID: -146474640053770988L

Package javax.xml.ws.http

Class javax.xml.ws.http.HTTPException extends ProtocolException implements Serializable

Serialized Fields

statusCode

int statusCode
Package javax.xml.ws.soap

Class javax.xml.ws.soap.SOAPFaultException extends ProtocolException implements Serializable

Serialized Fields

fault

SOAPFault fault
Package javax.xml.xpath

Class javax.xml.xpath.XPathException extends Exception implements Serializable

serialVersionUID: -1837080260374986980L

Serialized Fields

cause

Throwable cause

Class javax.xml.xpath.XPathExpressionException extends XPathException implements Serializable

serialVersionUID: -1837080260374986980L

Class javax.xml.xpath.XPathFactoryConfigurationException extends XPathException implements Serializable

serialVersionUID: -1837080260374986980L

Class javax.xml.xpath.XPathFunctionException extends XPathExpressionException implements Serializable

serialVersionUID: -1837080260374986980L

Package org.ietf.jgss

Class org.ietf.jgss.GSSException extends Exception implements Serializable

serialVersionUID: -2706218945227726672L

Serialized Fields

major

int major
The major code for this exception

minor

int minor
The minor code for this exception

minorMessage

String minorMessage
The text string for minor code

majorString

String majorString
Alternate text string for major code

Package org.omg.CosNaming

Class org.omg.CosNaming._BindingIteratorImplBase extends DynamicImplementation implements Serializable

Class org.omg.CosNaming._BindingIteratorStub extends ObjectImpl implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException
Throws:
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Throws:
IOException

Class org.omg.CosNaming._NamingContextExtStub extends ObjectImpl implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException
Throws:
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Throws:
IOException

Class org.omg.CosNaming._NamingContextImplBase extends DynamicImplementation implements Serializable

Class org.omg.CosNaming._NamingContextStub extends ObjectImpl implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException
Throws:
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
Throws:
IOException

Class org.omg.CosNaming.Binding extends Object implements Serializable

Serialized Fields

binding_name

NameComponent[] binding_name

binding_type

BindingType binding_type

Class org.omg.CosNaming.BindingType extends Object implements Serializable

Serialized Fields

__value

int __value

Class org.omg.CosNaming.NameComponent extends Object implements Serializable

Serialized Fields

id

String id

kind

String kind
Package org.w3c.dom

Class org.w3c.dom.DOMException extends RuntimeException implements Serializable

serialVersionUID: 6627732366795969916L

Serialized Fields

code

short code
Package org.w3c.dom.events

Class org.w3c.dom.events.EventException extends RuntimeException implements Serializable

Serialized Fields

code

short code
Package org.w3c.dom.ls

Class org.w3c.dom.ls.LSException extends RuntimeException implements Serializable

Serialized Fields

code

short code
Package org.xml.sax

Class org.xml.sax.SAXException extends Exception implements Serializable

serialVersionUID: 583241635256073760L

Serialized Fields

exception

Exception exception
The embedded exception if tunnelling, or null.

Class org.xml.sax.SAXNotRecognizedException extends SAXException implements Serializable

serialVersionUID: 5440506620509557213L

Class org.xml.sax.SAXNotSupportedException extends SAXException implements Serializable

serialVersionUID: -1422818934641823846L

Class org.xml.sax.SAXParseException extends SAXException implements Serializable

serialVersionUID: -5651165872476709336L

Serialized Fields

publicId

String publicId
The public identifier, or null.
See Also:
SAXParseException.getPublicId()

systemId

String systemId
The system identifier, or null.
See Also:
SAXParseException.getSystemId()

lineNumber

int lineNumber
The line number, or -1.
See Also:
SAXParseException.getLineNumber()

columnNumber

int columnNumber
The column number, or -1.
See Also:
SAXParseException.getColumnNumber()

Overview Package Class Use Tree Deprecated Index Help
Java™ Platform
Standard Ed. 7
DRAFT ea-b59
PREV NEXT FRAMES NO FRAMES