.NET(dotnet)教程

w3school 在线教程
  • HTML教程
  • XML教程
  • 浏览器脚本
  • 服务器脚本
  • dot net教程
  • 多媒体教程
  • 建站手册
  • .NET Microsoft
  • .NET ASP
  • .NET Mobile

.NET(dotnet) 教程

从左侧的菜单选择你需要的教程！

Microsoft.NET
Microsoft .NET 是微软新的因特网战略。

在你完成对本教程的学习之后，你将了解什么是 .NET。

同时你会认识到：.NET 将会影响未来创建 WEB 应用程序的方式。

开始学习Microsoft.NET！

ASP.NET

ASP.NET 是 ASP（微软动态服务器网页技术）的最新版本.

ASP.NET 是 Microsoft.NET 框架的组成部分，同时也是创建动态交换网页的强有力的工具。

开始学习 ASP.NET ！

.NET Mobile

.NET Mobile 是微软 ASP.NET 和微软的 .NET 框架的一个扩展。

.NET Mobile 是一套针对诸如 web 电话和 PDA 来构建应用程序的服务器端 Web 窗体控件（Web Forms Controls ）。

在本教程中，你将学习移动 .NET（.NET Mobile）。

本教程的主要内容是：如何利用 .NET 框架的扩展来创建移动应用程序，这种扩展被称为微软移动因特网工具包（MMIT）或者简易 .NET Mobile。

开始学习 .NET Mobile ！

参考手册

  • ASP.NET

W3School提供的内容仅用于培训。我们不保证内容的正确性。通过使用本站内容随之而来的风险与本站无关。当使用本站时，代表您已接受了本站的使用条款和隐私条款。

版权所有，保留一切权利。未经书面许可，不得转载。W3School 简体中文版的所有内容仅供测试，对任何法律问题及风险不承担任何责任。上海赢科投资公司。


HTML 系列教程

  • 浏览器脚本
  • 服务器脚本
  • dot net教程
  • 多媒体教程
  • 建站手册
  • HTML
  • XHTML
  • CSS
  • TCP/IP

HTML 系列教程

从左侧的菜单选择你需要的教程！

HTML
HTML 指超文本标签语言。

在我们的 HTML 教程中，您将学习如何使用 HTML 来创建站点。

HTML 非常容易学习！你会喜欢它的！现在开始学习 HTML ！

XHTML
XHTML 是更严谨更纯净的 HTML 版本。

在此教程中,我们会为您讲解 HTML 与 XHTML 之间的差异，同时也会为您展示将该站点升级到 XHTML 的方法。

现在开始学习 XHTML ！

CSS
CSS 指层叠样式表（Cascading Style Sheets）。

通过使用 CSS 来提升工作效率！在我们的 CSS 教程中，您会学到如何使用 CSS 同时控制多重网页的样式和布局。

开始学习 CSS ！

TCP/IP
TCP/IP 是针对因特网的通信协议。

在此教程中，你将了解到什么是 TCP/IP，以及它如何工作。

开始学习 TCP/IP ！

参考手册

  • HTML 4.01
  • XHTML 1.0
  • HTML 5
  • CSS 2.0
  • HTML 颜色
  • HTML ASCII
  • HTML Latin-1
  • HTML 符号

实例/案例

  • HTML 实例
  • CSS 实例

测验/考试

  • HTML 测验
  • XHTML 测验
  • CSS 测验

代码验证

  • 验证 HTML
  • 验证 CSS
  • 验证 XHTML


  • HTML 教程
  • XML 教程
  • 浏览器脚本
  • 服务器脚本
  • dot net 教程
  • 多媒体教程
  • 建站手册

HTML教程

  • HTML
  • XHTML
  • CSS
  • TCP/IP

XML教程

  • XML
  • DTD
  • XML DOM
  • XSL
  • XSLT
  • XSL-FO
  • XPath
  • XQuery
  • XLink
  • XPointer
  • Schema
  • XForms
  • SOAP
  • WSDL
  • RDF
  • RSS
  • WAP
  • Web Services

浏览器脚本

  • JavaScript
  • HTML DOM
  • DHTML
  • VBScript
  • AJAX
  • E4X
  • WMLScript

服务器脚本

  • SQL
  • ASP
  • ADO
  • PHP

.NET(dotnet)

  • .NET Microsoft
  • .NET ASP
  • .NET Mobile

多媒体

  • Media
  • SMIL
  • SVG

建站手册

  • 网站构建
  • 万维网联盟 (W3C)
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

领先的 Web 技术教程 - 全部免费

在w3school，你可以找到你所需要的所有的网站建设教程。

从基础的HTML到XHTML，乃至进阶的XML、SQL、数据库、多媒体和WAP。

从左侧的菜单选择你需要的教程！

完整的网站技术参考手册

我们的参考手册涵盖了网站技术的方方面面。

其中包括W3C的标准技术：HTML、XHTML、CSS、XML 。以及其他的技术，诸如JavaScript、PHP、ASP、SQL等等。

在线实例测试工具

在w3school，我们提供上千个实例。

通过使用我们的在线编辑器，你可以编辑这些例子，并对代码进行实验。

快捷易懂的学习方式

一寸光阴一寸金，因此，我们为您提供快捷易懂的学习内容。

在这里，您可以通过一种易懂的便利的模式获得您需要的任何知识。

从何入手？

什么是一个Web建设者需要学习的知识呢？

W3School将为您回答这个问题，在您成为专业Web开发者的路上助一臂之力，从而更好地应对未来的挑战。

如果您是初学者，请您阅读《网站构建初级教程》。

如果您是开发者，请您阅读《网站构建高级教程》。

W3School 新闻

Google Chrome 浏览器正式版发布 Internet Explorer 8 Public Beta 发布 W3C 发布 HTML 5 工作草案

W3School 更新信息

XML DOM cloneRange() 方法 XML DOM collapse() 方法

参考手册

  • HTML 4.01
  • XHTML 1.0
  • HTML 5
  • CSS 2.0
  • JavaScript
  • VBScript
  • HTML DOM
  • XML DOM
  • ASP
  • ADO
  • ASP.NET
  • PHP 5.1
  • XSLT 1.0
  • XPath 2.0
  • XSL-FO
  • WML 1.1
  • HTML 颜色

字符集

  • HTML ASCII
  • HTML Latin-1
  • HTML 符号

实例/案例

  • HTML 实例
  • CSS 实例
  • XML 实例
  • JavaScript 实例
  • JavaScript 对象实例
  • HTML DOM 实例
  • XML DOM 实例
  • DHTML 实例
  • AJAX 实例
  • VBScript 实例
  • ASP 实例
  • ADO 实例
  • SVG 实例
  • WAP 实例

测验/考试

  • HTML 测验
  • XHTML 测验
  • CSS 测验
  • XML 测验
  • JavaScript 测验
  • SQL 测验
  • ASP 测验

代码验证

  • 验证HTML
  • 验证CSS
  • 验证XHTML
  • 验证XML
  • 验证WML


XML系列教程

  • 多媒体教程
  • 建站手册
  • XML
  • XSL
  • XSLT
  • XSL-FO
  • XPath
  • XQuery
  • XLink
  • XPointer
  • DTD
  • Schema
  • XML DOM
  • XForms
  • SOAP
  • WSDL
  • RDF
  • RSS
  • WAP
  • Web Services

XML 系列教程

“当 XML（扩展标记语言）于 1998 年 2 月被引入软件工业界时，它给整个行业带来了一场风暴。有史以来第一次，这个世界拥有了一种用来结构化文档和数据的通用且适应性强的格式，它不仅仅可以用于 WEB，而且可以被用于任何地方。”

---《Designing With Web Standards Second Edition》, Jeffrey Zeldman

在本系列教程中，我们为您提供全面的 XML 学习资源。

请首先阅读下方的教程简介。也可以从左侧的菜单直接选择你需要的教程！

XML
XML 指扩展标记语言。

在我们的 XML 教程中，你将了解什么是 XML，以及 XML 与 HTML 之间的差异。同时你将学习如何开始在应用程序中使用 XML。

开始学习 XML ！

XSL
XSL 指扩展样式表语言。XSLT 指 XSL 转换。

在此教程中，你将学习如何使用 XSLT 将 XML 文档转换为其他文档，比如 XHTML。

开始学习 XSL！

XSL-FO
XSL-FO 指可扩展样式表语言格式化对象（Extensible Stylesheet Language Formatting Objects）

在我们的 XSL-FO 教程中，您将学习如何使用 XSL-FO 对用于输出的 XML 文档进行格式化。

开始学习 XSL-FO！

XPath

XPath 是一门在 XML 文档中查找信息的语言。XPath 可用来在 XML 文档中对元素和属性进行遍历。

XPath 是 W3C XSLT 标准的主要元素，并且 XQuery 和 XPointer 同时被构建于 XPath 表达之上。

因此，对 XPath 的理解是很多高级 XML 应用的基础。开始学习 XPath ！

XLink 和 XPointer

XLink 定义在 XML 文档中创建超级链接的标准方法。

XPointer 允许这些超级链接指向 XML 文档中的更多具体部分（片断）。

开始学习 XLink 和 XPointer ！

DTD

DTD（文档类型定义）的作用是定义 XML 文档的合法构建模块。

它使用一系列的合法元素来定义文档结构。

开始学习 DTD ！

XML Schema

XML Schema 是基于 XML 的 DTD 替代者。

XML Schema 描述 XML 文档的结构。

XML Schema 语言也称作 XML Schema 定义（XML Schema Definition，XSD）。

在此教程中，你将学习如何在应用程序中读取和创建 XML Schema 语言，XML Schema 为何比 DTD 更加强大，以及如何在您的应用程序中使用 XML Schema。

开始学习 XML Schema ！

DOM

XML 文档对象模型定义访问和操作XML文档的标准方法。

DOM 将 XML 文档作为一个树形结构，而树叶被定义为节点。

开始学习 DOM ！

XForms
XForms 是下一代的 HTML 表单。

在我们的 XForms 教程中，您将学习如何在应用程序中开始应用 XForms。

开始学习 XForms ！

SOAP
SOAP 是一种简单的基于 XML 的协议，它使应用程序通过 HTTP 来交换信息。

在我们的 SOAP 教程中，你将了解到什么是 SOAP，以及它如何在应用程序之间交换信息。

开始学习 SOAP ！

WSDL
WSDL（网络服务描述语言，Web Services Description Language）是一门基于 XML 的语言，用于描述 Web Services 以及如何对它们进行访问。

开始学习 WSDL ！

RDF

资源描述框架 (RDF) 是描述网络中资源的 W3C 标准。

RDF 是一个框架，用来描述网络资源，诸如网页的标题、作者、修改日期、内容以及版权信息等。

开始学习 RDF ！

RSS

通过使用 RSS，您可以有选择地浏览您感兴趣的以及与您的工作相关的新闻。

通过使用 RSS，您可以把需要的信息从不需要的信息（兜售信息，垃圾邮件等）中分离出来。

通过使用 RSS，您可以创建自己的新闻频道，并将之发布到因特网。

开始学习 RSS ！

WAP

WAP 协议被设计为用来在诸如移动电话之类的无线客户端上展示因特网内容。

WML 是用来创建供 WAP 浏览器显示的页面的语言。

在我们的 WAP 教程，你将学习关于 WAP 和 WML 的知识。

你将学习如何将网页转换为袖珍的格式（pocket format），这样你的信息就可以被诸如移动电话之类的无线客户端访问到。

开始学习WAP / WML ！

Web Services

Web Services 可以将应用程序转换为网络应用程序。

Web Services 可以被其他应用程序利用。

基本的 Web Services 平台是 XML+HTTP。

在本教程中，我们把一个 ASP.NET 程序转换为了 Web Services。开始学习 Web Services ！

参考手册:

  • XSLT 1.0
  • XPath 2.0
  • XSL-FO
  • WML 1.1

实例/案例

  • XML 实例
  • XML DOM 实例
  • WAP 实例

测验/考试

  • XML 测验

代码验证:

  • 验证 XML


多媒体系列教程

  • Media
  • SMIL
  • SVG

多媒体系列教程

从左侧的菜单选择你需要的教程！

Media
多媒体（Multimedia）指图片、声音、音乐、动画和视频。

在本教程中，您将学到如何向网页添加多媒体内容（音频和视频）。

开始学习网络多媒体教程 ！

SMIL
SMIL 是一种易学的、类似 HTML 的、描述视听内容的语言。

您学习本教程后，将了解到什么是 SMIL，如何创建基于多媒体内容的页面，其中包含了音频、视频、图片、文本以及其他媒介类型。

开始学习 SMIL ！

SVG

SVG 意为可缩放矢量图形（Scalable Vector Graphics）。

SVG 使用 XML 格式定义图像。

在我们的 SVG 教程中，你将学习 SVG 的相关知识。

开始学习 SVG ！

实例/案例

  • SVG 实例


服务器脚本系列教程

  • SQL
  • ASP
  • ADO
  • PHP

服务器脚本系列教程

从左侧的菜单选择你需要的教程！

SQL
SQL 是用于访问和处理数据库的标准的计算机语言。

在本教程中，您将学到如何使用 SQL 访问和处理数据系统中的数据，这类数据库包括：Oracle, Sybase, SQL Server, DB2, Access 等等。

开始学习 SQL ！

ASP
ASP 指 Active Server Pages （动态服务器页面）。

在我们的 ASP 教程中，您将学到 ASP 的相关知识，以及如何在服务器端执行脚本。

您会发现，ASP 是一种生成动态交互性网页的强大工具。

开始学习 ASP ！

ADO
ADO 指 ActiveX 数据对象（ActiveX Data Objects）。

在我们的 ADO 教程中，您将学到有关 ADO 的知识，以及如何使用 ADO 从您的网站访问数据库。

开始学习 ADO ！

PHP
PHP 指 PHP : 超文本预处理器。

PHP 是一种创建动态交互性站点的强有力的服务器端脚本语言。

PHP 是免费的，并且使用非常广泛。同时，对于像微软 ASP 这样的竞争者来说，PHP 无疑是另一种高效率的选项。PHP 极其适合网站开发，其代码可以直接嵌入 HTML 代码。

PHP 语法非常类似于 Perl 和 C。PHP 常常搭配 Apache (web 服务器) 一起使用。不过它也支持 ISAPI，并且可以工作在 Windows 的微软 IIS 平台。

开始学习 PHP ！

参考手册

  • ASP reference
  • ADO reference
  • PHP 5.1

实例/案例

  • ASP 实例
  • ADO 实例

测验/考试

  • SQL 测验
  • ASP 测验


网站构建手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

网站构建手册

从左侧的菜单选择你需要的教程！

W3C

当您将我们的《W3C 教程》学习完毕，您会对 W3C 有一个全面的了解。

您将了解到万维网联盟，以及 WEB 是如何被标准化的。开始学习！

网站构建

当您将我们的《网站构建教程》学习完毕，您将掌握如何建设一个专业的网站。

您也会学到如何做好面向未来的准备，以及如何使用诸如 XHTML 和 XML 之类的新技术。

开始学习！

浏览器信息

对于网站开发人员来说，浏览器信息和统计数据的非常重要的。

开始学习！

网站品质保证

在本教程中，您将学到如何将您的网站质量提升至最高。

您将学习使用最新的 WEB 标准。

您还将学习如何使网站的易用性更强、更易读。开始学习！

语义网
语义网=有意义的网络

“如果说 HTML 和 WEB 将整个在线文档变成了一本巨大的书，那么 RDF, schema, 和 inference languages 将会使世界上所有的数据变成一个巨大的数据库。” --- Tim Berners-Lee, Weaving the Web, 1999

开始学习！

职业规划
构建您的网络职业生涯

今天，甚至过去，大多数人都是由自己来设计他们的职业生涯的。

无论你正要启程，还是已经奋斗多年，以下内容都会对您的职业生涯有所助益。

开始学习！

网站主机

如果您希望向全世界发布自己的网站，那么您的网站就需要被放置于一个 WEB 服务器。

在本教程中，您将学到：什么是网站主机，以及网站主机提供什么服务。

开始学习！


浏览器脚本系列教程

  • JavaScript
  • HTML DOM
  • DHTML
  • VBScript
  • AJAX
  • E4X
  • WMLScript

浏览器脚本系列教程

从左侧的菜单选择你需要的教程！

JavaScript

JavaScript 是属于网络的脚本语言！

JavaScript 是因特网上最流行的脚本语言。

JavaScript 很容易使用！你一定会喜欢它的！开始学习 JavaScript ！

HTML DOM

HTML DOM 定义了访问和操作HTML文档的标准方法。

HTML DOM 把 HTML 文档呈现为带有元素、属性和文本的树结构（节点树）。

开始学习 HTML DOM ！

DHTML

DHTML 是一种使 HTML 页面具有动态特性的艺术。

DHTML 是一种创建动态和交互 WEB 站点的技术集。

对大多数人来说，DHTML 意味着 HTML、样式表和 JavaScript 的组合。

开始学习 DHTML ！

VBScript
VBScript是微软公司出品的脚本语言。

在我们的 VBScript 教程中，你可以学习如何编写 VBScript，以及如何在你的 HTML 文件中插入这些代码，以使得这些 WEB 页面动态性和交互性更强。

开始学习 VBScript ！

AJAX

AJAX 指异步 JavaScript 及 XML（Asynchronous JavaScript And XML）。

AJAX 是一种在 2005 年由 Google 推广开来的编程模式。

AJAX 不是一种新的编程语言，而是一种使用现有标准的新方法。

通过 AJAX，你可以创建更好、更快以及更友好的 WEB 应用程序。

AJAX 基于 JavaScript 和 HTTP 请求（HTTP requests）。

开始学习 AJAX ！

E4X

E4X 是对 JavaScript 的新扩展。

E4X 向 JavaScript 添加了对 XML 的直接支持。

E4X 是正式的 JavaScript 标准。

开始学习 E4X ！

WMLScript

WMLScript 是用于 WML 页面的脚本语言。

WML 页面可以在 WAP 浏览器中显示。

WMLScript 用于验证用户输入、生成对话框、显示出错消息以及访问用户代理设备等等。

开始学习 WMLScript ！

参考手册:

  • JavaScript
  • VBScript
  • HTML DOM

实例/案例

  • JavaScript 实例
  • JavaScript 对象实例
  • HTML DOM 实例
  • DHTML 实例
  • AJAX 实例
  • VBScript 实例

测验/考试

  • JavaScript 测验


帮助 W3School

关于 W3School

  • 关于帮助
  • 关于 FAQ
  • 关于评论
  • 关于版权
  • 关于隐私

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

帮助 W3School

  • Previous Page
  • Next Page

感谢您对 W3School 的关注和支持，你的任何帮助都将使其他用户共同受益！

W3School 对您的承诺

尽管在 Web 技术飞速发展的背景下，维护一个高水准的技术教程站点会耗费我们大量的精力和资源，W3School 仍然将致力于为 Web 开发者提供永久免费的 Web 技术教程。

目前为您提供的内容虽然经历了近一年时间的制作，但这只是一个起点。我们会与时俱进，不断对内容进行更新和改善。

我们对您的承诺：

  • 专注于 Web 技术教程的开发
  • 坚持对网站内容的更新、完善和升级
  • 提供快速、稳定的访问环境
  • 不发布与 Web 技术无关的产品和服务

推荐 W3School

向您的朋友、同事或同学推荐 W3School，让更多人利用 W3School 来提升技术水平和生产力。

帮助我们更正 W3School 的错误和断链

我们正努力工作，使 W3School 更权威、实用和有趣。如果您发现了断开的链接，请及时通知我们。

也请您在第一时间告知我们您所发现的遣词造句或技术方面的错误。

如需进行纠错，请给我们发电子邮件：

service#w3school.com.cn （请把 # 改为 @）

很抱歉，本邮件不接受技术问题的咨询，这样我们才会有更多的时间来制作更多更好的教程。

添加指向 W3School 的链接

请在您力所能及的情况下，添加一个指向 W3School 的链接。比如您的个人网站，你就读的大学的网站，或者你就职的公司网站。

通过您的努力，让更多人发现 W3School 吧！

文本链接

代码规范：

<a href="http://www.w3school.com.cn/">W3School 在线教程</a>

按钮链接

代码规范：

<a href="http://www.w3school.com.cn/">
<img src="/images/w3school.gif" alt="W3School 在线教程" />
</a>

banner 链接的代码规范：

<a href="http://www.w3school.com.cn/">
<img src="/images/w3school.gif" alt="W3School 在线教程" />
</a>
  • Previous Page
  • Next Page


关于 W3School

关于 W3School

  • 关于帮助
  • 关于 FAQ
  • 关于评论
  • 关于版权
  • 关于隐私

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

关于 W3School

  • Next Page

这里提供了有关 W3School 的信息。

内容目录

关于帮助 W3School
您如何帮助 W3School ？
关于 FAQ
有关 W3School 的常见问题和回答。
关于评论
来自用户的评论。
关于版权
有关 W3School 内容的版权声明。
关于隐私
W3School 有关用户隐私的法律声明。

W3School 新闻

W3School 测试版本号升级为 alpha

  • Next Page


ADO ActiveConnection 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO ActiveConnection 属性

返回 ADO Command 对象参考手册

定义和用法

ActiveConnection 属性可指示 Command 对象当前所属的 Connection 对象。

如果连接被关闭，它可设置或返回连接的定义。如果连接打开，它会设置或返回当前的 Connection 对象。

语法

objcommand.ActiveConnection

实例

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set comm=Server.CreateObject("ADODB.Command")
comm.ActiveConnection=conn
response.write(comm.ActiveConnection)

conn.close
%>

返回 ADO Command 对象参考手册

ADO 参考手册
ADO 实例

W3School提供的内容仅用于培训。我们不保证内容的正确性。通过使用本站内容随之而来的风险与本站无关。当使用本站时，代表您已接受了本站的使用条款和隐私条款。


ADO AppendChunk 方法

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO AppendChunk 方法

返回 ADO Field 对象参考手册

定义和用法

AppendChunk 用于将数据追加到大的文本或二进制数据 Field 或追加到 Parameter 对象。

提示：使用 Field 或 Parameter 对象的 AppendChunk 方法用长二进制或字符数据填充。在系统内存有限的情况下，可使用 AppendChunk 方法操作部分而非全部的 Long 值

对象 | AppendChunk 方法的描述
Parameter | 如果 Parameter 对象的 Attributes 属性中的 adFldLong 位设置为 True，可以对该参数使用 AppendChunk 方法。 在 Parameter 对象上的第一个 AppendChunk 调用将数据写入参数，覆盖任何现有数据。Parameter 对象上的后续 AppendChunk 调用向现有参数数据中添加数据。传送 Null 值的 AppendChunk 调用放弃所有参数数据。
Field | 如果 Field 对象的 Attributes 属性中的 adFldLong 位设置为 True，可以对该字段使用 AppendChunk 方法。 在 Field 对象上的第一个 AppendChunk 调用将数据写入字段，覆盖任何现有数据。后续的 AppendChunk 调用向现有数据中添加数据。如果要将数据追加到一个字段然后在当前记录中设置或读取其他字段的值，ADO 会认为已完成向第一个字段追加数据。如果在第一个字段上再次调用 AppendChunk 方法，ADO 将把这次调用解释为新的 AppendChunk 操作并覆盖现有数据。访问其他 Recordset 对象（并非第一个 Recordset 对象的副本）中的字段将不会中断 AppendChunk 操作。 在 Field 对象上调用 AppendChunk 时，如果没有当前记录，将发生错误。 注意：AppendChunk 方法对 Record 对象的 Field 对象不起作用。它不执行任何操作并将产生运行时错误。

语法

objectname.AppendChunk data
参数 | 描述
data | Variant，包含要追加到对象的数据。

返回 ADO Field 对象参考手册

ADO 参考手册
ADO 实例


ADO AppendChunk 方法

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO AppendChunk 方法

返回 ADO Parameter 对象参考手册

定义和用法

AppendChunk 用于将数据追加到大的文本或二进制数据 Field 或追加到 Parameter 对象。

提示：使用 Field 或 Parameter 对象的 AppendChunk 方法用长二进制或字符数据填充。在系统内存有限的情况下，可使用 AppendChunk 方法操作部分而非全部的 Long 值

对象 | AppendChunk 方法的描述
Parameter | 如果 Parameter 对象的 Attributes 属性中的 adFldLong 位设置为 True，可以对该参数使用 AppendChunk 方法。 在 Parameter 对象上的第一个 AppendChunk 调用将数据写入参数，覆盖任何现有数据。Parameter 对象上的后续 AppendChunk 调用向现有参数数据中添加数据。传送 Null 值的 AppendChunk 调用放弃所有参数数据。
Field | 如果 Field 对象的 Attributes 属性中的 adFldLong 位设置为 True，可以对该字段使用 AppendChunk 方法。 在 Field 对象上的第一个 AppendChunk 调用将数据写入字段，覆盖任何现有数据。后续的 AppendChunk 调用向现有数据中添加数据。如果要将数据追加到一个字段然后在当前记录中设置或读取其他字段的值，ADO 会认为已完成向第一个字段追加数据。如果在第一个字段上再次调用 AppendChunk 方法，ADO 将把这次调用解释为新的 AppendChunk 操作并覆盖现有数据。访问其他 Recordset 对象（并非第一个 Recordset 对象的副本）中的字段将不会中断 AppendChunk 操作。 在 Field 对象上调用 AppendChunk 时，如果没有当前记录，将发生错误。 注意：AppendChunk 方法对 Record 对象的 Field 对象不起作用。它不执行任何操作并将产生运行时错误。

语法

objectname.AppendChunk data
参数 | 描述
data | Variant，包含要追加到对象的数据。

返回 ADO Parameter 对象参考手册

ADO 参考手册
ADO 实例


ADO Attributes 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Attributes 属性

返回 ADO Connection 对象参考手册

定义和用法

Attributes 属性可设置或返回 Long 值，该值可指示对象的一项或多项特性。

注释：设置多个属性时，可以将适当的常量相加。如果将属性值设置为包括不兼容常量的和，将会发生错误。

对象 | Attributes 属性的描述
Connection | Attributes 属性对 Connection 对象拥有读写权限。并且其值可以是一个或多个 XactAttributeEnum 值的和。默认值为零 (0)。
Parameter | Attributes 属性对Parameter 对象拥有读写权限。并且其值可以是任意一个或多个 ParameterAttributesEnum 值的和。默认值为 adParamSigned。
Field | 当 Attributes 属性被用于创建 Recordset 时，它拥有读写权限，但是当您打开一个已有的 Recordset 时，它是只读的。Attributes 属性可以是一个或多个 FieldAttributeEnum 值的和。
Property | 对于 Property 对象，Attributes 属性是只读的。并且其值可以是任意一个或多个 PropertyAttributesEnum 值的和。

语法

object.Attributes

实例

针对 Connection 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

response.write(conn.Attributes)

conn.close
%>

针对 Field 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

set f=Server.CreateObject("ADODB.Field")

'Display the field attributes of the Orders Table
for each f in rs.Fields
  response.write("Attr:" & f.Attributes & "<br />")
  response.write("Name:" & f.Name & "<br />")
  response.write("Value:" & f.Value & "<br />")
Next

rs.Close
conn.close
set rs=nothing
set conn=nothing
%>

针对 Property 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

set prop=Server.CreateObject("ADODB.Property")

'Display the property attributes of the Orders Table
for each prop in rs.Properties
  response.write("Attr:" & prop.Attributes & "<br />")
  response.write("Name:" & prop.Name & "<br />")
  response.write("Value:" & prop.Value & "<br />")
next

rs.close
conn.close
set rs=nothing
set conn=nothing
%>

XactAttributeEnum 值

常量 | 值 | 描述
adXactAbortRetaining | 262144 | 当调用 RollbackTrans，自动启动一个新事务。
adXactCommitRetaining | 131072 | 当调用 CommitTrans，自动启动新事务。

ParameterAttributesEnum Values

常量 | 值 | 描述
adParamSigned | 16 | 该参数接受带符号的值。
adParamNullable | 64 | 该参数接受 Null 值。
adParamLong | 128 | 该参数接受长二进制数据。

FieldAttributeEnum Values

常量 | 值 | 描述
adFldCacheDeferred | 0x1000 | 指示提供者缓存字段值，并且指示对缓存的进行读取。
adFldFixed | 0x10 | 指示该字段包含定长数据。
adFldIsChapter | 0x2000 | 指示该字段包含一个子集值，指定与此父字段有关的特定子记录集。通常子集字段与数据构形或过滤器一起使用。
adFldIsCollection | 0x40000 | 该字段指定由记录表示的资源是其他资源的集合（如文件夹）而不仅是简单资源（如文本文件）。
adFldIsDefaultStream | 0x20000 | 该字段包含由记录表示的资源的默认流。例如，默认流可以是 Web 站点根文件夹的 HTML 内容，在指定根 URL 时自动提供。
adFldIsNullable | 0x20 | 该字段接受 Null 值。
adFldIsRowURL | 0x10000 | 该字段包含 URL，它命名了记录表示的数据存储中的资源。
adFldKeyColumn | 0x8000 | 该字段是基本行集合的主键。还可指示该字段是复合主键的一部分。
adFldLong | 0x80 | 该字段是长二进制字段。还指示能够使用 AppendChunk 和 GetChunk 方法。
adFldMayBeNull | 0x40 | 可从该字段读取 Null 值。
adFldMayDefer | 0x2 | 该字段被延期，即该字段值不是和整个记录一起从数据源检索，而是在显式访问它们时检索。
adFldNegativeScale | 0x4000 | 该字段表示来自支持负范围值的列的数字值。该范围由 NumericScale 属性指定。
adFldRowID | 0x100 | 该字段包含持久行标识符，该标识符无法被写入，并且除了标识行以外没有任何意义，例如记录编号、唯一标识符等。
adFldRowVersion | 0x200 | 该字段包含用于跟踪更新的某种时间或日期戳。
adFldUnknownUpdatable | 0x8 | 提供者无法确定用户是否可以写入字段。
adFldUnspecified
  • -1
  • 0xFFFFFFFF
 提供者没有指定字段属性。
adFldUpdatable | 0x4 | 用户可以写入字段。

PropertyAttributesEnum Values

常量 | 值 | 描述
adPropNotSupported | 0 | 提供者不支持该属性。
adPropRequired | 1 | 在初始化数据源之前用户必须指定该属性的值。
adPropOptional | 2 | 在初始化数据源之前用户不必指定该属性的值。
adPropRead | 512 | 户可以读取该属性。
adPropWrite | 1024 | 用户可以设置该属性。

返回 ADO Connection 对象参考手册

ADO 参考手册
ADO 实例


ADO Attributes 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Attributes 属性

返回 ADO Field 对象参考手册

定义和用法

Attributes 属性可设置或返回 Long 值，该值可指示对象的一项或多项特性。

注释：设置多个属性时，可以将适当的常量相加。如果将属性值设置为包括不兼容常量的和，将会发生错误。

对象 | Attributes 属性的描述
Connection | Attributes 属性对 Connection 对象拥有读写权限。并且其值可以是一个或多个 XactAttributeEnum 值的和。默认值为零 (0)。
Parameter | Attributes 属性对Parameter 对象拥有读写权限。并且其值可以是任意一个或多个 ParameterAttributesEnum 值的和。默认值为 adParamSigned。
Field | 当 Attributes 属性被用于创建 Recordset 时，它拥有读写权限，但是当您打开一个已有的 Recordset 时，它是只读的。Attributes 属性可以是一个或多个 FieldAttributeEnum 值的和。
Property | 对于 Property 对象，Attributes 属性是只读的。并且其值可以是任意一个或多个 PropertyAttributesEnum 值的和。

语法

object.Attributes

实例

针对 Connection 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

response.write(conn.Attributes)

conn.close
%>

针对 Field 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

set f=Server.CreateObject("ADODB.Field")

'Display the field attributes of the Orders Table
for each f in rs.Fields
  response.write("Attr:" & f.Attributes & "<br />")
  response.write("Name:" & f.Name & "<br />")
  response.write("Value:" & f.Value & "<br />")
Next

rs.Close
conn.close
set rs=nothing
set conn=nothing
%>

针对 Property 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

set prop=Server.CreateObject("ADODB.Property")

'Display the property attributes of the Orders Table
for each prop in rs.Properties
  response.write("Attr:" & prop.Attributes & "<br />")
  response.write("Name:" & prop.Name & "<br />")
  response.write("Value:" & prop.Value & "<br />")
next

rs.close
conn.close
set rs=nothing
set conn=nothing
%>

XactAttributeEnum 值

常量 | 值 | 描述
adXactAbortRetaining | 262144 | 当调用 RollbackTrans，自动启动一个新事务。
adXactCommitRetaining | 131072 | 当调用 CommitTrans，自动启动新事务。

ParameterAttributesEnum Values

常量 | 值 | 描述
adParamSigned | 16 | 该参数接受带符号的值。
adParamNullable | 64 | 该参数接受 Null 值。
adParamLong | 128 | 该参数接受长二进制数据。

FieldAttributeEnum Values

常量 | 值 | 描述
adFldCacheDeferred | 0x1000 | 指示提供者缓存字段值，并且指示对缓存的进行读取。
adFldFixed | 0x10 | 指示该字段包含定长数据。
adFldIsChapter | 0x2000 | 指示该字段包含一个子集值，指定与此父字段有关的特定子记录集。通常子集字段与数据构形或过滤器一起使用。
adFldIsCollection | 0x40000 | 该字段指定由记录表示的资源是其他资源的集合（如文件夹）而不仅是简单资源（如文本文件）。
adFldIsDefaultStream | 0x20000 | 该字段包含由记录表示的资源的默认流。例如，默认流可以是 Web 站点根文件夹的 HTML 内容，在指定根 URL 时自动提供。
adFldIsNullable | 0x20 | 该字段接受 Null 值。
adFldIsRowURL | 0x10000 | 该字段包含 URL，它命名了记录表示的数据存储中的资源。
adFldKeyColumn | 0x8000 | 该字段是基本行集合的主键。还可指示该字段是复合主键的一部分。
adFldLong | 0x80 | 该字段是长二进制字段。还指示能够使用 AppendChunk 和 GetChunk 方法。
adFldMayBeNull | 0x40 | 可从该字段读取 Null 值。
adFldMayDefer | 0x2 | 该字段被延期，即该字段值不是和整个记录一起从数据源检索，而是在显式访问它们时检索。
adFldNegativeScale | 0x4000 | 该字段表示来自支持负范围值的列的数字值。该范围由 NumericScale 属性指定。
adFldRowID | 0x100 | 该字段包含持久行标识符，该标识符无法被写入，并且除了标识行以外没有任何意义，例如记录编号、唯一标识符等。
adFldRowVersion | 0x200 | 该字段包含用于跟踪更新的某种时间或日期戳。
adFldUnknownUpdatable | 0x8 | 提供者无法确定用户是否可以写入字段。
adFldUnspecified
  • -1
  • 0xFFFFFFFF
 提供者没有指定字段属性。
adFldUpdatable | 0x4 | 用户可以写入字段。

PropertyAttributesEnum Values

常量 | 值 | 描述
adPropNotSupported | 0 | 提供者不支持该属性。
adPropRequired | 1 | 在初始化数据源之前用户必须指定该属性的值。
adPropOptional | 2 | 在初始化数据源之前用户不必指定该属性的值。
adPropRead | 512 | 户可以读取该属性。
adPropWrite | 1024 | 用户可以设置该属性。

返回 ADO Field 对象参考手册

ADO 参考手册
ADO 实例


ADO Attributes 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Attributes 属性

返回 ADO Parameter 对象参考手册

定义和用法

Attributes 属性可设置或返回 Long 值，该值可指示对象的一项或多项特性。

注释：设置多个属性时，可以将适当的常量相加。如果将属性值设置为包括不兼容常量的和，将会发生错误。

对象 | Attributes 属性的描述
Connection | Attributes 属性对 Connection 对象拥有读写权限。并且其值可以是一个或多个 XactAttributeEnum 值的和。默认值为零 (0)。
Parameter | Attributes 属性对Parameter 对象拥有读写权限。并且其值可以是任意一个或多个 ParameterAttributesEnum 值的和。默认值为 adParamSigned。
Field | 当 Attributes 属性被用于创建 Recordset 时，它拥有读写权限，但是当您打开一个已有的 Recordset 时，它是只读的。Attributes 属性可以是一个或多个 FieldAttributeEnum 值的和。
Property | 对于 Property 对象，Attributes 属性是只读的。并且其值可以是任意一个或多个 PropertyAttributesEnum 值的和。

语法

object.Attributes

实例

针对 Connection 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

response.write(conn.Attributes)

conn.close
%>

针对 Field 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

set f=Server.CreateObject("ADODB.Field")

'Display the field attributes of the Orders Table
for each f in rs.Fields
  response.write("Attr:" & f.Attributes & "<br />")
  response.write("Name:" & f.Name & "<br />")
  response.write("Value:" & f.Value & "<br />")
Next

rs.Close
conn.close
set rs=nothing
set conn=nothing
%>

针对 Property 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

set prop=Server.CreateObject("ADODB.Property")

'Display the property attributes of the Orders Table
for each prop in rs.Properties
  response.write("Attr:" & prop.Attributes & "<br />")
  response.write("Name:" & prop.Name & "<br />")
  response.write("Value:" & prop.Value & "<br />")
next

rs.close
conn.close
set rs=nothing
set conn=nothing
%>

XactAttributeEnum 值

常量 | 值 | 描述
adXactAbortRetaining | 262144 | 当调用 RollbackTrans，自动启动一个新事务。
adXactCommitRetaining | 131072 | 当调用 CommitTrans，自动启动新事务。

ParameterAttributesEnum Values

常量 | 值 | 描述
adParamSigned | 16 | 该参数接受带符号的值。
adParamNullable | 64 | 该参数接受 Null 值。
adParamLong | 128 | 该参数接受长二进制数据。

FieldAttributeEnum Values

常量 | 值 | 描述
adFldCacheDeferred | 0x1000 | 指示提供者缓存字段值，并且指示对缓存的进行读取。
adFldFixed | 0x10 | 指示该字段包含定长数据。
adFldIsChapter | 0x2000 | 指示该字段包含一个子集值，指定与此父字段有关的特定子记录集。通常子集字段与数据构形或过滤器一起使用。
adFldIsCollection | 0x40000 | 该字段指定由记录表示的资源是其他资源的集合（如文件夹）而不仅是简单资源（如文本文件）。
adFldIsDefaultStream | 0x20000 | 该字段包含由记录表示的资源的默认流。例如，默认流可以是 Web 站点根文件夹的 HTML 内容，在指定根 URL 时自动提供。
adFldIsNullable | 0x20 | 该字段接受 Null 值。
adFldIsRowURL | 0x10000 | 该字段包含 URL，它命名了记录表示的数据存储中的资源。
adFldKeyColumn | 0x8000 | 该字段是基本行集合的主键。还可指示该字段是复合主键的一部分。
adFldLong | 0x80 | 该字段是长二进制字段。还指示能够使用 AppendChunk 和 GetChunk 方法。
adFldMayBeNull | 0x40 | 可从该字段读取 Null 值。
adFldMayDefer | 0x2 | 该字段被延期，即该字段值不是和整个记录一起从数据源检索，而是在显式访问它们时检索。
adFldNegativeScale | 0x4000 | 该字段表示来自支持负范围值的列的数字值。该范围由 NumericScale 属性指定。
adFldRowID | 0x100 | 该字段包含持久行标识符，该标识符无法被写入，并且除了标识行以外没有任何意义，例如记录编号、唯一标识符等。
adFldRowVersion | 0x200 | 该字段包含用于跟踪更新的某种时间或日期戳。
adFldUnknownUpdatable | 0x8 | 提供者无法确定用户是否可以写入字段。
adFldUnspecified
  • -1
  • 0xFFFFFFFF
 提供者没有指定字段属性。
adFldUpdatable | 0x4 | 用户可以写入字段。

PropertyAttributesEnum Values

常量 | 值 | 描述
adPropNotSupported | 0 | 提供者不支持该属性。
adPropRequired | 1 | 在初始化数据源之前用户必须指定该属性的值。
adPropOptional | 2 | 在初始化数据源之前用户不必指定该属性的值。
adPropRead | 512 | 户可以读取该属性。
adPropWrite | 1024 | 用户可以设置该属性。

返回 ADO Parameter 对象参考手册

ADO 参考手册
ADO 实例


ADO BeginTrans, CommitTran 以及 RollbackTrans 方法

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO BeginTrans, CommitTran 以及 RollbackTrans 方法

返回 ADO Connection 对象参考手册

定义和用法

这三个方法与 Connection 对象使用，来保存或取消对数据源所做的更改。

注释：并非所有提供者都支持事务。

注释：BeginTrans、CommitTrans 和 RollbackTrans 方法在客户端 Connection 对象上无效。

BeginTrans

BeginTrans 方法可开始一个新事务。

CommitTrans

CommitTrans 方法可保存自最后一个 BeginTrans 方法调用以来的所有更改，并结束当前事务。它也可能启动新事务。

RollbackTrans

RollbackTrans 方法可取消自最后一次 BeginTrans 方法调用以来的所有更改，并结束该事务。它也可能启动新事务。

说明

对于支持嵌套事务的提供者，在打开的事务中调用 BeginTrans 方法将启动新的嵌套事务。返回值将指示嵌套层次：返回值为“1”指示打开了顶层事务（即此事务未嵌套在其他事务中），返回值为“2”指示打开了第二层事务（嵌套在顶层事务中的事务），依此类推。调用 CommitTrans 或 RollbackTrans 只影响最新打开的事务；在处理任何更高层事务之前必须关闭或回卷当前事务。

语法

level=objconn.BeginTrans()

objconn.BeginTrans

objconn.CommitTrans

objconn.RollbackTrans

返回 ADO Connection 对象参考手册

ADO 参考手册
ADO 实例


ADO BeginTransComplete, CommitTransComplete 以及 RollbackTransComplete 事件

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO BeginTransComplete, CommitTransComplete 以及 RollbackTransComplete 事件

返回 ADO Connection 对象参考手册

定义和用法

事件是某个具体的操作发生后被自动调用的子例程。

  • BeginTransComplete 事件在 BeginTrans 调用被完成后触发。
  • CommitTransComplete 事件在 CommitTrans 调用被完成后触发。
  • RollbackTransComplete 事件在 RollbackTrans 调用被完成后触发。

语法

BeginTransComplete translevel,objerror,status,objconn

CommitTransComplete objerror,status,objconn

RollbackTransComplete objerror,status,objconn

参数 | 描述
translevel | Long 值，包含引发此事件的 BeginTrans 的新事务级别。
objerror | 包含所发生错误的 Error 对象。 注释：EventStatusEnum 值必需设置为 adStatusErrorsOccurred ，以创建 Error 对象。
status | 规定事件执行的状态。取 EventStatusEnum 状态值。
objconn | 引发此事件的 Connection 对象。

EventStatusEnum 值

常量 | 值 | 描述
adStatusOK | 1 | 引发该事件的操作成功。
adStatusErrorsOccurred | 2 | 引发该事件的操作失败。
adStatusCantDeny | 3 | 不能取消挂起操作。
adStatusCancel | 4 | 取消导致事件发生的操作。
adStatusUnwantedEvent | 5 | 在事件方法执行结束之前禁止后续的通知。

返回 ADO Connection 对象参考手册

ADO 参考手册
ADO 实例


ADO Cancel 方法

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Cancel 方法

返回 ADO Connection 对象参考手册

定义和用法

Cancel 方法可取消方法调用的执行。

Cancel 方法可为不同的对象终止不同的任务。下面的表格列出了当此方法被调用时被终止的任务：

对象 | 被终止的任务
Command | Execute。 注释：在 Cancel 方法被调用之前，Execute 方法的 Options 参数必须被设置为 adAsyncExecute 或者 adAsyncFetch，否则会发生 run-time 错误。
Connection | Execute 或 Open。 注释：在 Cancel 方法被调用之前，Open 方法的 Options 参数必须被设置为 adSyncConnect，Execute 方法的 Options 参数必须被设置为 adAsyncExecute 或者 adAsyncFetch，否则会发生 run-time 错误。
Record | CopyRecord, DeleteRecord, MoveRecord, 或者 Open。
Recordset | Open
Stream | Open

语法

object.Cancel

返回 ADO Connection 对象参考手册

ADO 参考手册
ADO 实例


ADO Cancel 方法

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Cancel 方法

返回 ADO Command 对象参考手册

定义和用法

Cancel 方法可取消方法调用的执行。

Cancel 方法可为不同的对象终止不同的任务。下面的表格列出了当此方法被调用时被终止的任务：

对象 | 被终止的任务
Command | Execute。 注释：在 Cancel 方法被调用之前，Execute 方法的 Options 参数必须被设置为 adAsyncExecute 或者 adAsyncFetch，否则会发生 run-time 错误。
Connection | Execute 或 Open。 注释：在 Cancel 方法被调用之前，Open 方法的 Options 参数必须被设置为 adSyncConnect，Execute 方法的 Options 参数必须被设置为 adAsyncExecute 或者 adAsyncFetch，否则会发生 run-time 错误。
Record | CopyRecord, DeleteRecord, MoveRecord, 或者 Open。
Recordset | Open
Stream | Open

语法

object.Cancel

返回 ADO Command 对象参考手册

ADO 参考手册
ADO 实例


ADO Close 方法

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Close 方法

返回 ADO Connection 对象参考手册

定义和用法

Close 方法用于关闭 Connection 对象、Record 对象、Recordset 对象或者 Stream 对象，以释放系统资源。

注释：关闭对象不会将其从内存中删除；随后可以更改其属性设置并再次将其打开。要从内存中彻底清除对象，请在关闭对象后将对象变量设置为 Nothing（在 Visual Basic 中）。

语法

object.Close

实例

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs=Server.CreateObject("ADODB.recordset")
rs.Open "Customers", conn

rs.Close
conn.Close
%>

返回 ADO Connection 对象参考手册

ADO 参考手册
ADO 实例


ADO Command 对象

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Command 对象

  • Previous Page
  • Next Page

Command 对象

ADO Command 对象用于执行面向数据库的一次简单查询。此查询可执行诸如创建、添加、取回、删除或更新记录等动作。

如果该查询用于取回数据，此数据将以一个 RecordSet 对象返回。这意味着被取回的数据能够被 RecordSet 对象的属性、集合、方法或事件进行操作。

Command 对象的主要特性是有能力使用存储查询和带有参数的存储过程。

ProgID

set objCommand=Server.CreateObject("ADODB.command")

属性

属性 | 描述
ActiveConnection | 设置或返回包含了定义连接或 Connection 对象的字符串。
CommandText | 设置或返回包含提供者（provider）命令（如 SOL 语句、表格名称或存储的过程调用）的字符串值。默认值为 ""（零长度字符串）。
CommandTimeout | 设置或返回长整型值，该值指示等待命令执行的时间（单位为秒）。默认值为 30。
CommandType | 设置或返回一个 Command 对象的类型
Name | 设置或返回一个 Command 对象的名称
Prepared | 指示执行前是否保存命令的编译版本（已经准备好的版本）。
State | 返回一个值，此值可描述该 Command 对象处于打开、关闭、连接、执行还是取回数据的状态。

方法

方法 | 描述
Cancel | 取消一个方法的一次执行。
CreateParameter | 创建一个新的 Parameter 对象
Execute | 执行 CommandText 属性中的查询、SQL 语句或存储过程。

集合

集合 | 描述
Parameters | 包含一个 Command 对象的所有 Parameter 对象。
Properties | 包含一个 Command 对象的所有 Property 对象。
  • Previous Page
  • Next Page

ADO 参考手册
ADO 实例


ADO CommandText 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO CommandText 属性

返回 ADO Command 对象参考手册

定义和用法

CommandText 属性可设置或返回一个字符串，该字符串包含一个 provider 命令，比如一条 SQL 语句、一个表名称、一个相对 URL、或者一个存储过程调用。默认值为零 ""（零长度字符串）。

语法

objcommand.CommandText

实例

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set comm=Server.CreateObject("ADODB.Command")
comm.CommandText="orders"
response.write(comm.CommandText)

conn.close
%>

返回 ADO Command 对象参考手册

ADO 参考手册
ADO 实例


ADO CommandTimeout 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO CommandTimeout 属性

返回 ADO Command 对象参考手册

定义和用法

CommandTimeout 属性可设置或返回执行命令期间在终止尝试和产生错误之前需等待的时间。

设置或返回 Long 值，该值指示等待命令执行的秒数。默认值为 30。

语法

object.CommandTimeout

实例

针对 Command 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set comm=Server.CreateObject("ADODB.Command")
comm.CommandTimeout=10
response.write(comm.CommandTimeout)

conn.close
%>

针对 Connection 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

conn.CommandTimeout=10
response.write(conn.CommandTimeout)

conn.close
%>

返回 ADO Command 对象参考手册

ADO 参考手册
ADO 实例


ADO CommandTimeout 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO CommandTimeout 属性

返回 ADO Connection 对象参考手册

定义和用法

CommandTimeout 属性可设置或返回执行命令期间在终止尝试和产生错误之前需等待的时间。默认值为 30。

语法

object.CommandTimeout

实例

针对 Command 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set comm=Server.CreateObject("ADODB.Command")
comm.CommandTimeout=10
response.write(comm.CommandTimeout)

conn.close
%>

针对 Connection 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

conn.CommandTimeout=10
response.write(conn.CommandTimeout)

conn.close
%>

返回 ADO Connection 对象参考手册

ADO 参考手册
ADO 实例


ADO CommandType 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO CommandType 属性

返回 ADO Command 对象参考手册

定义和用法

CommandType 属性可设置或返回一个 CommandTypeEnum 值，该值可定义 Command 对象的类型。默认是 adCmdUnknown。

如果您没有规定此类型，ADO 将需要联系 provider 以确定命令的类型。如果您定义了该类型，则 ADO 将有能力更快地处理此命令。

语法

objcommand.CommandType

实例

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set comm=Server.CreateObject("ADODB.Command")
comm.CommandText="orders"
comm.CommandType=adCmdTable
response.write(comm.CommandType)

conn.close
%>

返回 ADO Command 对象参考手册

ADO 参考手册
ADO 实例


ADO Connection 对象

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Connection 对象

  • Previous Page
  • Next Page

Connection 对象

ADO Connection 对象用于创建一个到达某个数据源的开放连接。通过此连接，您可以对一个数据库进行访问和操作。

如果需要多次访问某个数据库，您应当使用 Connection 对象来建立一个连接。您也可以经由一个 Command 或 Recordset 对象传递一个连接字符串来创建某个连接。不过，此类连接仅仅适合一次具体的简单的查询。

ProgID

set objConnection=Server.CreateObject("ADODB.connection")

属性

属性 | 描述
Attributes | 设置或返回 Connection 对象的属性。
CommandTimeout | 指示在终止尝试和产生错误之前执行命令期间需等待的时间。
ConnectionString | 设置或返回用于建立连接数据源的细节信息。
ConnectionTimeout | 指示在终止尝试和产生错误前建立连接期间所等待的时间。
CursorLocation | 设置或返回游标服务的位置。
DefaultDatabase | 指示 Connection 对象的默认数据库。
IsolationLevel | 指示 Connection 对象的隔离级别。
Mode | 设置或返回 provider 的访问权限。
Provider | 设置或返回 Connection 对象提供者的名称。
State | 返回一个描述连接是打开还是关闭的值。
Version | 返回 ADO 的版本号。

方法

方法 | 描述
BeginTrans | 开始一个新事务。
Cancel | 取消一次执行。
Close | 关闭一个连接。
CommitTrans | 保存任何更改并结束当前事务。
Execute | 执行查询、SQL 语句、存储过程或 provider 具体文本。
Open | 打开一个连接。
OpenSchema | 从 provider 返回有关数据源的 schema 信息。
RollbackTrans | 取消当前事务中所作的任何更改并结束事务。

事件

注释：您无法使用 VBScript or JScript 来处理事件（仅能使用 Visual Basic、Visual C++ 以及 Visual J++ 语言处理事件）。

事件 | 描述
BeginTransComplete | 在 BeginTrans 操作之后被触发。
CommitTransComplete | 在 CommitTrans 操作之后被触发。
ConnectComplete | 在一个连接开始后被触发。
Disconnect | 在一个连接结束之后被触发。
ExecuteComplete | 在一条命令执行完毕后被触发。
InfoMessage | 假如在一个 ConnectionEvent 操作过程中警告发生，则触发该事件。
RollbackTransComplete | 在 RollbackTrans 操作之后被触发。
WillConnect | 在一个连接开始之前被触发。
WillExecute | 在一条命令被执行之前被触发。

集合

集合 | 描述
Errors | 包含 Connection 对象的所有 Error 对象。
Properties | 包含 Connection 对象的所有 Property 对象。
  • Previous Page
  • Next Page

ADO 参考手册
ADO 实例


ADO ConnectionString 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO ConnectionString 属性

返回 ADO Connection 对象参考手册

定义和用法

ConnectionString 属性可设置或返回用于建立到数据源的连接的信息。

注释：您不能同时使用 Provider 和 File Name 参数。

语法

objconn.ConnectionString="para1=value;para2=value;etc;"

ConnectionString 属性有 5 个参数：

参数 | 描述
Provider | 用于连接的提供者的名称。
File Name | 提供者特有的文件（例如，持久保留的数据源对象）的名称，这些文件中包含预置的连接信息。
Remote Provider | 当打开客户端连接时使用的提供者的名称。（仅限于远程数据服务。）
Remote Server | 当打开客户端连接时使用的服务器的路径名称。（仅限于远程数据服务。）
url | 标识资源（比如文件或目录）的绝对 URL。

实例

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.ConnectionString="Provider=Microsoft.Jet.OLEDB.4.0"
conn.open server.mappath("database.mdb")

conn.close
%>

返回 ADO Connection 对象参考手册

ADO 参考手册
ADO 实例


ADO ConnectionTimeout 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO ConnectionTimeout 属性

返回 ADO Connection 对象参考手册

定义和用法

ConnectionTimeout 属性可设置或返回在终止尝试和产生错误之前打开连接需要等待的秒数。默认是 15 秒。

语法

objconn.ConnectionTimeout

实例

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.ConnectionString="Provider=Microsoft.Jet.OLEDB.4.0"
conn.ConnectionTimeout=30
conn.open server.mappath("database.mdb")

conn.close
%>

返回 ADO Connection 对象参考手册

ADO 参考手册
ADO 实例


ADO CreateParameter 方法

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO CreateParameter 方法

返回 ADO Command 对象参考手册

定义和用法

CreateParameter 方法可创建和返回一个 Parameter 对象，该对象包含指定的属性，比如名称、类型、方向、大小和值。

注释：此方法不会将 Parameter 对象自动追加到 Command 对象的 Parameters 集合。如需向 Parameters 集合添加 Parameter 对象，请使用 Append 属性。

语法

Set objparameter=objcommand.CreateParameter
(name,type,direction,size,value)
参数 | 描述
name | 可选。Parameter 对象的名称。
type | 可选。DataTypeEnum 常量之一，指定 Parameter 对象的数据类型。默认是 adEmpty。如果你选择可变长度的数据类型，则需要规定 Size 参数或 Size 属性。如果规定 adDecimal 或者 adNumeric 数据类型，则必须设置 Parameter 对象的NumericScale 和 Precision 属性。
direction | 可选。ParameterDirectionEnum 常量之一，定义 Parameter 对象的方向。默认是 adParamInput。
size | 可选。规定可变数据类型的长度，假如此类类型被声明于 Type 参数中。默认是 0。
value | 可选。Parameter 对象的值。

返回 ADO Command 对象参考手册

ADO 参考手册
ADO 实例


ADO CursorLocation 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO CursorLocation 属性

返回 ADO Connection 对象参考手册

定义和用法

CursorLocation 属性可设置或返回一个 long 值，该值指示游标服务的位置。可被设置为 CursorLocationEnum 值之一。默认值是 AdUseServer。

游标用于：

  • 控制记录定位
  • 控制其他用户对数据库所作的更改的可视性
  • 控制数据可更新性

注释：Recordset 对象将从与它们相关联的连接上自动继承此设置。

注释：此属性在 Connection 或已关闭的 Recordset 上为读/写，在打开的 Recordset 上为只读。

语法

objConnection.CursorLocation
objRecordset.CursorLocation

实例

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open(Server.Mappath("northwind.mdb"))
set rs=Server.CreateObject("ADODB.recordset")
sql="SELECT * FROM Customers"

rs.CursorLocation=adUseClient
rs.CursorType=adOpenStatic
rs.LockType=adLockBatchOptimistic

rs.Open sql,conn

rs.Close
conn.Close
%>

返回 ADO Connection 对象参考手册

ADO 参考手册
ADO 实例


ADO DefaultDatabase 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO DefaultDatabase 属性

返回 ADO Connection 对象参考手册

定义和用法

DefaultDatabase 属性可设置或返回一个字符串值，该值是特定 Connection 对象上的默认数据库的名称。

语法

objconn.DefaultDatabase

实例

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.DefaultDatabase="northwind"

set rs=Server.CreateObject("ADODB.Recordset")
rs.Open "customers",conn

....

rs.Close
conn.close
%>

返回 ADO Connection 对象参考手册

ADO 参考手册
ADO 实例


ADO DefinedSize 和 ActualSize 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO DefinedSize 和 ActualSize 属性

返回 ADO Field 对象参考手册

定义和用法

DefinedSize 属性会返回一个 long 值，该值指示一个字段被定义的长度（字节）。

ActualSize 属性是一个只读属性。它会返回一个 long 值，该值指示某个字段的值的实际长度。如果 ADO 无法确定该 Field 对象的值的长度，则返回 adUnknown。

使用 DefinedSize 属性可确定 Field 对象的数据容量，而 ActualSize 则表明其实际长度。

语法

objrs.Fields(number).DefinedSize
objrs.Fields(number).ActualSize

实例

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs=Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

response.write(rs.Fields(0).DefinedSize)
response.write(rs.Fields(0).ActualSize)

rs.Close
conn.close
%>

返回 ADO Field 对象参考手册

ADO 参考手册
ADO 实例


ADO Delete 方法

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Delete 方法

返回 ADO Parameter 对象参考手册

定义和用法

Delete 方法可从 Parameters 集合中删除某个对象。

注释：此方法只能用在 Command 对象的 Parameters 集合上。

在调用 Delete 方法时您必须使用 Parameter 对象的 Name 属性或其集合索引 —— 对象变量不是有效的参数。

语法

objparameter.Delete index
参数 | 描述
index | String 值，该值包含要删除的对象的名称，或者对象在集合中的顺序位置（索引）。

返回 ADO Parameter 对象参考手册

ADO 参考手册
ADO 实例


ADO Description 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Description 属性

返回 ADO Error 对象参考手册

定义和用法

Description 属性可返回一个字符串，该字符串包含对错误的描述。

这是 Error 对象的默认属性。提供者和 ADO 均可成为错误源。

提供者负责向 ADO 传递特定的错误文本。对于接收到的每一个提供者错误或警告，ADO 都会向 Errors 集合中添加一个 Error 对象。枚举 Errors 集合以跟踪提供者传递的错误。

语法

strErrorText=objErr.Description

实例

<%
for each objErr in objConn.Errors
  response.write("<p>")
  response.write("Description: ")
  response.write(objErr.Description & "<br />")
  response.write("Help context: ")
  response.write(objErr.HelpContext & "<br />")
  response.write("Help file: ")
  response.write(objErr.HelpFile & "<br />")
  response.write("Native error: ")
  response.write(objErr.NativeError & "<br />")
  response.write("Error number: ")
  response.write(objErr.Number & "<br />")
  response.write("Error source: ")
  response.write(objErr.Source & "<br />")
  response.write("SQL state: ")
  response.write(objErr.SQLState & "<br />")
  response.write("</p>")
next
%>

返回 ADO Error 对象参考手册

ADO 参考手册
ADO 实例


ADO Direction 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Direction 属性

返回 ADO Parameter 对象参考手册

定义和用法

Direction 属性可设置或返回一个 ParameterDirectionEnum 值，指示 Parameter 所表示的是输入参数、输出参数还是两者都表示，或者指示参数是否是存储过程的返回值。默认值是 adParamInput。

Direction 属性为读/写，它允许用户使用不返回此信息的提供者，或者在不希望 ADO 为检索参数信息而额外调用提供者时设置此信息。

并非所有提供者都能在其存储过程中确定参数的方向。在这种情况下，必须在执行查询前设置 Direction 属性。

语法

objparameter.Direction

实例

<%
set comm=Server.CreateObject("ADODB.Command")
set para=Server.CreateObject("ADODB.Parameter")

para.Type=adVarChar
para.Size=25
para.Direction=adParamInput
para.Value=varfname

comm.Parameters.Append para
%>

ParameterDirectionEnum Values

常量 | 值 | 描述
adParamUnknown | 0 | 指示该参数的方向未知。
adParamInput | 1 | 默认值。指示该参数是输入参数。
adParamInputOutput | 3 | 指示该参数既是输入参数，又是输出参数。
adParamOutput | 2 | 指示该参数是输出参数。
adParamReturnValue | 4 | 指示该参数是返回值。

返回 ADO Parameter 对象参考手册

ADO 参考手册
ADO 实例


ADO Error 对象

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Error 对象

  • Previous Page
  • Next Page

Error 对象

ADO Error 对象包含与单个操作（涉及提供者）有关的数据访问错误的详细信息。

ADO 会因每次错误产生一个 Error 对象。每个 Error 对象包含具体错误的详细信息，且 Error 对象被存储在 Errors 集合中。要访问这些错误，就必须引用某个具体的连接。

循环遍历 Errors 集合：

<%
for each objErr in objConn.Errors
  response.write("<p>")
  response.write("Description: ")
  response.write(objErr.Description & "<br />")
  response.write("Help context: ")
  response.write(objErr.HelpContext & "<br />")
  response.write("Help file: ")
  response.write(objErr.HelpFile & "<br />")
  response.write("Native error: ")
  response.write(objErr.NativeError & "<br />")
  response.write("Error number: ")
  response.write(objErr.Number & "<br />")
  response.write("Error source: ")
  response.write(objErr.Source & "<br />")
  response.write("SQL state: ")
  response.write(objErr.SQLState & "<br />")
  response.write("</p>")
next
%>

语法

objErr.property

属性

属性 | 描述
Description | 返回一个错误描述。
HelpContext | 返回 Microsoft Windows help system 中某个主题的内容 ID。
HelpFile | 返回 Microsoft Windows help system 中帮助文件的完整路径。
NativeError | 返回来自 provider 或数据源的错误代码。
Number | 返回可标识错误的一个唯一的数字。
Source | 返回产生错误的对象或应用程序的名称。
SQLState | 返回一个 5 字符的 SQL 错误码。
  • Previous Page
  • Next Page

ADO 参考手册
ADO 实例


ADO Execute 方法

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Execute 方法

返回 ADO Command 对象参考手册

定义和用法

Execute 方法可执行 Command 对象的 CommandText 属性中指定的查询、SQL 语句或存储过程。

如果 CommandText 属性指定以行返回的查询，执行产生的任何结果都将存储在新的 Recordset 对象中。如果此命令不是以行返回的查询，提供者将返回关闭的 Recordset 对象。

语法：对于以行返回的 Command：

Set rs=objcommand.Execute(ra,parameters,options)

语法：对于不是以行返回的 Command：

objcommand.Execute ra,parameters,options
参数 | 描述
ra | 可选。返回受查询影响的记录的数目。对于以行返回的查询，请使用 Recordset 对象的 RecordCount 属性来计算该对象中的记录数量。
parameters | 可选。用 SQL 语句传递的参数值。用于更改、更新或向 Parameters 集合插入新的参数值。
options | 可选。指示提供者应如何计算 Command 对象的 CommandText 属性。可以是一个或者多个 CommandTypeEnum 或 ExecuteOptionEnum 值。默认是 adCmdUnspecified。

实例

<%
Set objcommand.Text="SELECT * FROM Customers"
objCommand.Execute
%>

或者：

<%
Set objcommand.Text="Customers"
objCommand.Execute(,,adCmdTableDirect)
%>

返回 ADO Command 对象参考手册

ADO 参考手册
ADO 实例


ADO Execute 方法

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Execute 方法

返回 ADO Connection 对象参考手册

定义和用法

Execute 方法可执行指定查询、SQL 语句、存储过程或提供者特有的文本。

如果 CommandText 参数指定按行返回的查询，那么执行产生的任何结果都将存储在新的 Recordset 对象中。如果此命令不是以行返回的查询，提供者将返回关闭的 Recordset 对象。

注释：返回的 Recordset 对象始终是只读的、仅向前的游标。

提示：如果需要具有更多功能的 Recordset 对象，应首先创建 Recordset 对象，设置所需属性，然后使用 Recordset 对象的 Open 方法执行查询并返回所需的游标类型。

语法：对于以行返回的命令字符串：

Set objrs=objconn.Execute(commandtext,ra,options)

语法：对于不是以行返回的命令字符串：

objconn.Execute commandtext,ra,options
参数 | 描述
commandtext | 必需。要执行的 SQL 语句、表名称、存储过程、URL 或提供者特有的文本。
ra | 可选。受查询影响的记录数目。
options | 可选。设置提供者应当如何设置计算 commandtext 参数。可以是一个或多个 CommandTypeEnum 或 ExecuteOptionEnum 值。默认是 adCmdUnspecified。

实例

<%
sql="SELECT companyname FROM Customers"
Set rs=conn.Execute(sql)
%>

返回 ADO Connection 对象参考手册

ADO 参考手册
ADO 实例


ADO Field 对象

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Field 对象

  • Previous Page
  • Next Page

Field 对象

ADO Field 对象包含有关 Recordset 对象中某一列的信息。Recordset 中的每一列对应一个 Field 对象。

ProgID

set objField=Server.CreateObject("ADODB.field")

属性

属性 | 描述
ActualSize | 返回一个字段值的实际长度。
Attributes | 设置或返回 Field 对象的属性。
DefinedSize | 返回Field 对象被定义的大小
Name | 设置或返回 Field 对象的名称。
NumericScale | 设置或返回 Field 对象中的值所允许的小数位数。
OriginalValue | 返回某个字段的原始值。
Precision | 设置或返回当表示 Field 对象中的数值时所允许的数字的最大数。
Status | 返回 Field 对象的状态。
Type | 设置或返回 Field 对象的类型。
UnderlyingValue | 返回一个字段的当前值。
Value | 设置或返回 Field 对象的值。

方法

方法 | 描述
AppendChunk | 把大型的二进制或文本数据追加到 Field 对象
GetChunk | 返回大型二进制或文本 Field 对象的全部或部分内容。

集合

集合 | 描述
Properties | 包含一个 Field 对象的所有 Property 对象。
  • Previous Page
  • Next Page

ADO 参考手册
ADO 实例


ADO GetChunk 方法

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO GetChunk 方法

返回 ADO Field 对象参考手册

定义和用法

GetChunk 方法可返回一个 variant 值，该值包含大的文本或二进制数据 Field 对象的全部或部分内容。

使用 Field 对象的 GetChunk 方法来检索其中的部分或全部长二进制或字符数据。在系统内存有限的情况下，可使用 GetChunk 方法操作部分而非全部 Long 值。

GetChunk 调用返回的数据将被分配给 variable。如果 Size 大于剩余的数据，GetChunk 方法仅返回剩余的数据而不用空格填充 variable。如果该字段为空，GetChunk 方法将返回 Null 值。

每个后续的 GetChunk 调用将从上一次 GetChunk 调用停止处开始检索数据。但是，如果在当前记录中检索一个字段中的数据然后设置或读取另一个字段的值，ADO 将认为已经完成对第一个字段中的数据的检索。如果在第一个字段上再次调用 GetChunk 方法，ADO 将把这次调用解释为新的 GetChunk 操作，并从数据的开始处读取。访问其他 Recordset 对象（并非第一个 Recordset 对象的副本）中的字段将不会中断 GetChunk 操作。

如果 Field 对象的 Attributes 属性中的 adFldLong 位设置为 True，可以对该字段使用 GetChunk 方法。

注释：如果使用 Field 对象的 Getchunk 方法时没有当前记录，将产生错误 3021（没有当前记录）。

注释：GetChunk 方法在 Record 对象的 Field 对象上不起作用。它不执行任何操作并将产生运行时错误。

语法

variable_name=field.GetChunk(size)
参数 | 描述
size | Long 表达式，等于要检索的字节或字符数。

返回 ADO Field 对象参考手册

ADO 参考手册
ADO 实例


ADO HelpContext 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO HelpContext 属性

返回 ADO Error 对象参考手册

定义和用法

HelpContext 属性可返回一个 long 值，该值帮助文件中主题的上下文 ID。

该属性允许您与 Windows 帮助系统结合，例如，您可以调用 Windows 的 API 帮助函数。

如果没有与Windows help system 结合的权限，HelpContext 属性将返回零

语法

lngErrorContext=objErr.HelpContext

实例

<%
for each objErr in objConn.Errors
  response.write("<p>")
  response.write("Description: ")
  response.write(objErr.Description & "<br />")
  response.write("Help context: ")
  response.write(objErr.HelpContext & "<br />")
  response.write("Help file: ")
  response.write(objErr.HelpFile & "<br />")
  response.write("Native error: ")
  response.write(objErr.NativeError & "<br />")
  response.write("Error number: ")
  response.write(objErr.Number & "<br />")
  response.write("Error source: ")
  response.write(objErr.Source & "<br />")
  response.write("SQL state: ")
  response.write(objErr.SQLState & "<br />")
  response.write("</p>")
next
%>

返回 ADO Error 对象参考手册

ADO 参考手册
ADO 实例


ADO HelpFile 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO HelpFile 属性

返回 ADO Error 对象参考手册

定义和用法

HelpFile 属性可返回一个字符串，该字符串包含 Microsoft Windows help system 中帮助文件的完整路径。

该属性允许您与 Windows 帮助系统结合，例如，您可以调用 Windows 的 API 帮助函数。

如果没有与Windows help system 结合的权限，HelpContext 属性将返回""。

语法

strErrorFile=objErr.HelpFile

实例

<%
for each objErr in objConn.Errors
  response.write("<p>")
  response.write("Description: ")
  response.write(objErr.Description & "<br />")
  response.write("Help context: ")
  response.write(objErr.HelpContext & "<br />")
  response.write("Help file: ")
  response.write(objErr.HelpFile & "<br />")
  response.write("Native error: ")
  response.write(objErr.NativeError & "<br />")
  response.write("Error number: ")
  response.write(objErr.Number & "<br />")
  response.write("Error source: ")
  response.write(objErr.Source & "<br />")
  response.write("SQL state: ")
  response.write(objErr.SQLState & "<br />")
  response.write("</p>")
next
%>

返回 ADO Error 对象参考手册

ADO 参考手册
ADO 实例


ADO InfoMessage 事件

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO InfoMessage 事件

返回 ADO Connection 对象参考手册

定义和用法

事件是某个具体的操作发生后被自动调用的子例程。

InfoMessage 事件在连接操作期间出现警告时调用。

语法

InfoMessage objerror,status,objconn
参数 | 描述
objerror | Error 对象。此参数包含返回的任何错误。
status | 一个 EventStatusEnum 值。如果出现警告，status 将被设置为 adStatusOK，并且 objerror 中包含该警告。
objconn | Connection 对象。引发警告的连接。

EventStatusEnum 值

常量 | 值 | 描述
adStatusOK | 1 | 引发该事件的操作成功。
adStatusErrorsOccurred | 2 | 引发该事件的操作失败。
adStatusCantDeny | 3 | 不能取消挂起操作。
adStatusCancel | 4 | 取消导致事件发生的操作。
adStatusUnwantedEvent | 5 | 在事件方法执行结束之前禁止后续的通知。

返回 ADO Connection 对象参考手册

ADO 参考手册
ADO 实例


ADO IsolationLevel 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO IsolationLevel 属性

返回 ADO Connection 对象参考手册

定义和用法

IsolationLevel 属性可设置或返回 Connection 对象的隔离级别。该值是一个 IsolationLevelEnum 值。默认是 adXactChaos。

注释：IsolationLevel 设置直到下次调用 BeginTrans 方法时才生效。

语法

objconn.IsolationLevel

实例

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.IsolationLevel=adXactIsolated
conn.Open(Server.Mappath("northwind.mdb"))

response.write(conn.IsolationLevel)

conn.Close
%>

IsolationLevelEnum

常量 | 值 | 描述
adXactUnspecified | -1 | 无法使用指定的隔离级别，因为提供者正在使用不同的隔离级别，而且该级别无法被确定。
adXactChaos | 16 | 无法覆盖更高级别的事务。
adXactBrowse | 256 | 可以从一个事务中查看其他事务中未提交的更改。
adXactReadUncommitted | 256 | 与 adXactBrowse 相同。
adXactCursorStability | 4096 | 只能从一个事务中查看其他事务中提交的更改。
adXactReadCommitted | 4096 | 与 adXactCursorStability 相同。
adXactRepeatableRead | 65536 | 不能从一个事务中查看其他事务中所作的修改，但是重新查询可以检索新的 Recordset 对象。
adXactIsolated | 1048576 | 该事务与其他事务隔离执行。
adXactSerializable | 1048576 | 与 adXactIsolated 相同。

返回 ADO Connection 对象参考手册

ADO 参考手册
ADO 实例


ADO Mode 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Mode 属性

返回 ADO Connection 对象参考手册

定义和用法

Mode 属性可设置或返回一个 ConnectModeEnum 值，该值指示在 Connection, Record 或 Stream 对象中修改数据的权限。在对象关闭时，此属性为读写，在对象打开时为只读。

  • Connection 对象 - 默认是 adModeUnknown
  • Record 对象 - 默认是 adModeRead
  • Stream 对象 - 默认是 adModeRead 或 adModeUnknown

注释：该属性只能在 Connection 对象关闭时设置。

语法

object.Mode

实例

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Mode=adModeReadWrite
conn.Open(Server.Mappath("northwind.mdb"))

response.write(conn.Mode)

conn.Close
%>

ConnectModeEnum

常量 | 值 | 描述
adModeUnknown | 0 | 默认值。权限尚未设置或不能确定权限。
adModeRead | 1 | 只读权限。
adModeWrite | 2 | 只写权限。
adModeReadWrite | 3 | 读/写权限。
adModeShareDenyRead | 4 | 禁止其他人以读权限打开连接。
adModeShareDenyWrite | 8 | 禁止其他人以写权限打开连接。
adModeShareExclusive | 12 | 禁止其他人打开连接。
adModeShareDenyNone | 16 | 允许其他人以任何权限打开连接。不拒绝其他人的读或写访问。
adModeRecursive | 0x400000 | 与 adModeShareDenyNone, adModeShareDenyWrite 或 adModeShareDenyRead 一起使用，对当前 Record 的所有子记录设置权限。

返回 ADO Connection 对象参考手册

ADO 参考手册
ADO 实例


ADO Name 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Name 属性

返回 ADO Command 对象参考手册

定义和用法

Name 属性可设置或返回一个字符串，该值包含 Command、Property、Field 或者 Parameter 对象的名称。

对象 | Name 属性的描述
Command | Name 属性拥有对 Command 对象的读写权限。
Property | Name 属性拥有对 Property 属性的只读权限。
Field | 在被用于创建 Recordset 时 Name 属性拥有读写权限，但是当您打开一个已有的 Recordset 时是只读的。
Parameter | 对于尚未追加到 Parameters 集合的 Parameter 对象，Name 属性为读/写。对于已追加的 Parameter 对象和所有其他对象，Name 属性为只读。名称在集合中不必是唯一的。

语法

object.Name

实例

针对 Command 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set comm=Server.CreateObject("ADODB.Command")
comm.Name="xx"
response.write(comm.Name)

conn.close
%>

针对 Field 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

set f=Server.CreateObject("ADODB.Field")

'Display the field attributes of the Orders Table
for each f in rs.Fields
  response.write("Attr:" & f.Attributes & "<br />")
  response.write("Name:" & f.Name & "<br />")
  response.write("Value:" & f.Value & "<br />")
next

rs.Close
conn.close
set rs=nothing
set conn=nothing
%>

针对 Property 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

set prop=Server.CreateObject("ADODB.Property")

'Display the property attributes of the Orders Table
for each prop in rs.Properties
  response.write("Attr:" & prop.Attributes & "<br />")
  response.write("Name:" & prop.Name & "<br />")
  response.write("Value:" & prop.Value & "<br />")
next

rs.close
conn.close
set rs=nothing
set conn=nothing
%>

返回 ADO Command 对象参考手册

ADO 参考手册
ADO 实例


ADO Name 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Name 属性

返回 ADO Field 对象参考手册

定义和用法

Name 属性可设置或返回一个字符串，该值包含 Command、Property、Field 或者 Parameter 对象的名称。

对象 | Name 属性的描述
Command | Name 属性拥有对 Command 对象的读写权限。
Property | Name 属性拥有对 Property 属性的只读权限。
Field | 在被用于创建 Recordset 时 Name 属性拥有读写权限，但是当您打开一个已有的 Recordset 时是只读的。
Parameter | 对于尚未追加到 Parameters 集合的 Parameter 对象，Name 属性为读/写。对于已追加的 Parameter 对象和所有其他对象，Name 属性为只读。名称在集合中不必是唯一的。

语法

object.Name

实例

针对 Command 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set comm=Server.CreateObject("ADODB.Command")
comm.Name="xx"
response.write(comm.Name)

conn.close
%>

针对 Field 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

set f=Server.CreateObject("ADODB.Field")

'Display the field attributes of the Orders Table
for each f in rs.Fields
  response.write("Attr:" & f.Attributes & "<br />")
  response.write("Name:" & f.Name & "<br />")
  response.write("Value:" & f.Value & "<br />")
next

rs.Close
conn.close
set rs=nothing
set conn=nothing
%>

针对 Property 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

set prop=Server.CreateObject("ADODB.Property")

'Display the property attributes of the Orders Table
for each prop in rs.Properties
  response.write("Attr:" & prop.Attributes & "<br />")
  response.write("Name:" & prop.Name & "<br />")
  response.write("Value:" & prop.Value & "<br />")
next

rs.close
conn.close
set rs=nothing
set conn=nothing
%>

返回 ADO Field 对象参考手册

ADO 参考手册
ADO 实例


ADO Name 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Name 属性

返回 ADO Parameter 对象参考手册

定义和用法

Name 属性可设置或返回一个字符串，该值包含 Command、Property、Field 或者 Parameter 对象的名称。

对象 | Name 属性的描述
Command | Name 属性拥有对 Command 对象的读写权限。
Property | Name 属性拥有对 Property 属性的只读权限。
Field | 在被用于创建 Recordset 时 Name 属性拥有读写权限，但是当您打开一个已有的 Recordset 时是只读的。
Parameter | 对于尚未追加到 Parameters 集合的 Parameter 对象，Name 属性为读/写。对于已追加的 Parameter 对象和所有其他对象，Name 属性为只读。名称在集合中不必是唯一的。

语法

object.Name

实例

针对 Command 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set comm=Server.CreateObject("ADODB.Command")
comm.Name="xx"
response.write(comm.Name)

conn.close
%>

针对 Field 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

set f=Server.CreateObject("ADODB.Field")

'Display the field attributes of the Orders Table
for each f in rs.Fields
  response.write("Attr:" & f.Attributes & "<br />")
  response.write("Name:" & f.Name & "<br />")
  response.write("Value:" & f.Value & "<br />")
next

rs.Close
conn.close
set rs=nothing
set conn=nothing
%>

针对 Property 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

set prop=Server.CreateObject("ADODB.Property")

'Display the property attributes of the Orders Table
for each prop in rs.Properties
  response.write("Attr:" & prop.Attributes & "<br />")
  response.write("Name:" & prop.Name & "<br />")
  response.write("Value:" & prop.Value & "<br />")
next

rs.close
conn.close
set rs=nothing
set conn=nothing
%>

返回 ADO Parameter 对象参考手册

ADO 参考手册
ADO 实例


ADO NativeError 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO NativeError 属性

返回 ADO Error 对象参考手册

定义和用法

NativeError 属性可返回一个 long 值，该值是由提供者或数据源返回 ADO 的错误代码。

使用 NativeError 属性对某个 Error 对象检索数据库特有的错误信息。例如，当配合使用 Microsoft ODBC Provider for OLE DB 和 Microsoft SQL Server 数据库时，从 SQL Server 产生的原生错误代码将通过 ODBC 和 ODBC Provider 传递到 ADO NativeError 属性。

语法

lngErrorNative=objErr.NativeError

实例

<%
for each objErr in objConn.Errors
  response.write("<p>")
  response.write("Description: ")
  response.write(objErr.Description & "<br />")
  response.write("Help context: ")
  response.write(objErr.HelpContext & "<br />")
  response.write("Help file: ")
  response.write(objErr.HelpFile & "<br />")
  response.write("Native error: ")
  response.write(objErr.NativeError & "<br />")
  response.write("Error number: ")
  response.write(objErr.Number & "<br />")
  response.write("Error source: ")
  response.write(objErr.Source & "<br />")
  response.write("SQL state: ")
  response.write(objErr.SQLState & "<br />")
  response.write("</p>")
next
%>

返回 ADO Error 对象参考手册

ADO 参考手册
ADO 实例


ADO Number 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Number 属性

返回 ADO Error 对象参考手册

定义和用法

Number 属性指示唯一标识 Error 对象的数字。

返回 Long 值，该值可能对应于一个 ErrorValueEnum 常量。

使用 Number 属性确定发生了哪个错误。属性的值是与错误条件对应的唯一数字。

Errors 集合以十六进制格式（例如 0x80004005）或以 Long 值（例如 2147467259）返回 HRESULT。这些 HRESULT 由基本组件生成，如 OLE DB，甚至是 OLE 本身。

语法

lngErrorNumber=objErr.Number

实例

<%
for each objErr in objConn.Errors
  response.write("<p>")
  response.write("Description: ")
  response.write(objErr.Description & "<br />")
  response.write("Help context: ")
  response.write(objErr.HelpContext & "<br />")
  response.write("Help file: ")
  response.write(objErr.HelpFile & "<br />")
  response.write("Native error: ")
  response.write(objErr.NativeError & "<br />")
  response.write("Error number: ")
  response.write(objErr.Number & "<br />")
  response.write("Error source: ")
  response.write(objErr.Source & "<br />")
  response.write("SQL state: ")
  response.write(objErr.SQLState & "<br />")
  response.write("</p>")
next
%>

返回 ADO Error 对象参考手册

ADO 参考手册
ADO 实例


ADO NumericScale 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO NumericScale 属性

返回 ADO Field 对象参考手册

定义和用法

NumericScale 属性设置或返回 Byte 值，指示 Field 或 Parameter 对象的数字值要精确的小数位数。

对象 | NumericScale 属性的描述
Field | 对于 Field 对象，NumericScale 通常为只读。但是，对于已追加到 Record 的 Fields 集合中的新 Field 对象，只有当 Field 的 Value 属性已被指定并且数据提供者通过调用 Fields 集合的 Update 方法成功添加了新的 Field 时，NumericScale 才为读/写。
Parameter | 对于 Parameter 对象，NumericScale 属性拥有读/写权限。

语法

object.NumericScale

实例

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

response.write(rs.Fields(0).NumericScale)

rs.Close
conn.close
%>

返回 ADO Field 对象参考手册

ADO 参考手册
ADO 实例


ADO NumericScale 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO NumericScale 属性

返回 ADO Parameter 对象参考手册

定义和用法

NumericScale 属性设置或返回 Byte 值，指示 Field 或 Parameter 对象的数字值要精确的小数位数。

对象 | NumericScale 属性的描述
Field | 对于 Field 对象，NumericScale 通常为只读。但是，对于已追加到 Record 的 Fields 集合中的新 Field 对象，只有当 Field 的 Value 属性已被指定并且数据提供者通过调用 Fields 集合的 Update 方法成功添加了新的 Field 时，NumericScale 才为读/写。
Parameter | 对于 Parameter 对象，NumericScale 属性拥有读/写权限。

语法

object.NumericScale

实例

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

response.write(rs.Fields(0).NumericScale)

rs.Close
conn.close
%>

返回 ADO Parameter 对象参考手册

ADO 参考手册
ADO 实例


ADO Open 方法

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Open 方法

返回 ADO Connection 对象参考手册

定义和用法

Open 方法可打开一个到数据源的连接。当连接打开时，您可以对数据源执行命令。

语法

connection.Open connectionstring,userID,password,options
参数 | 描述
connectionstring | 可选。一个包含有关连接的信息的字符串值。该字符串由一系列被分号隔开的 parameter=value 语句组成的。 有关有效设置的详细信息，请参阅 ConnectionString 属性。
userID | 可选。一个字符串值，包含建立连接时要使用的用户名称。
password | 可选。一个字符串值，包含建立连接时要使用的密码。
options | 可选。一个 ConnectOptionEnum 值，确定应在建立连接之后（同步）还是应在建立连接之前（异步）返回本方法。

实例

DSN-less 连接：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"
%>

带有 userID 和 password 的 DSN-less 连接（请把 conn.open 语句写在一行中）：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Open "Provider=Microsoft.Jet.OLEDB.4.0;
data source=c:/webdata/northwind.mdb;
userID=xxx;
password=yyy"
%>

ODBC 数据库连接：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Open "northwind"
%>

ConnectOptionEnum

常数 | 值 | 描述
adConnectUnspecified | -1 | 默认值。同步打开连接。
adAsyncConnect | 16 | 异步打开连接。ConnectComplete 事件可以用来确定连接何时可用。

返回 ADO Connection 对象参考手册

ADO 参考手册
ADO 实例


ADO OpenSchema 方法

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO OpenSchema 方法

返回 ADO Connection 对象参考手册

定义和用法

OpenSchema 方法可返回 Recordset 对象，该对象包含有关数据源的模式信息。举例，schema 信息可包括表的名称，表中的列名，每列的数据类型。Recordset 将以只读、静态游标模式打开。

语法

Set rs=objconn.OpenSchema(querytype,criteria,schemaid)
参数 | 描述
querytype | 必需。任意 SchemaEnum 值，表示要运行的模式查询的类型。 注释：OLEDB 规范只要求三个 SchemaEnum 值得到支持：adSchemaTables, adSchemaColumns 以及 adSchemaProviderTypes。
criteria | 可选。每个 QueryType 选项的查询约束的数组，如 SchemaEnum 中列出的内容。
schemaid | OLE DB 规范未定义的提供者模式查询的 GUID。如果 QueryType 被设置为 adSchemaProviderSpecific，则需要此参数。否则，将不使用它。

返回 ADO Connection 对象参考手册

ADO 参考手册
ADO 实例


ADO OriginalValue 和 UnderlyingValue 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO OriginalValue 和 UnderlyingValue 属性

返回 ADO Field 对象参考手册

定义和用法

OriginalValue 属性可返回一个 variant 值，该值包含最后一次 Update 或 UpdateBatch 方法调用之前已经存在的字段值。

UnderlyingValue 属性可返回一个 variant 值，该值包含某个字段的当前值。该值不会必要地显示由其他用户造成的更改，且也许不是最新的值。

提示：请使用 Recordset 对象的 Resync 属性来获得 Fields 集合中所有 Field 对象的最新值。

提示：这两种属性可以配合使用可以解决批更新时出现的冲突。

语法

objField.OriginalValue
objField.UnderlyingValue

实例

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "customers", conn

set objfield=rs.fields("companyname")

'Some code..................

'Check for changes
rs.movefirst
while rs.eof=false
  if objfield.OriginalValue<>objfield.UnderlyingValue then
    response.write("Data has changed!<br />")
    response.write("Original value: ")
    response.write(objfield.OriginalValue & "<br />")
    response.write("Current value: ")
    response.write(objfield.UnderlyingValue & "<br />")
  end if
  rs.movenext
next

'More code...................

rs.Close
conn.close
%>

返回 ADO Field 对象参考手册

ADO 参考手册
ADO 实例


ADO Parameter 对象

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Parameter 对象

  • Previous Page
  • Next Page

Parameter 对象

ADO Parameter 对象可提供有关被用于存储过程或查询中的一个单个参数的信息。

Parameter 对象在其被创建时被添加到 Parameters 集合。Parameters 集合与一个具体的 Command 对象相关联，Command 对象使用此集合在存储过程和查询内外传递参数。

参数被用来创建参数化的命令。这些命令（在它们已被定义和存储之后）使用参数在命令执行前来改变命令的某些细节。例如，SQL SELECT 语句可使用参数定义 WHERE 子句的匹配条件，而使用另一个参数来定义 SORT BY 子句的列的名称。

有四种类型的参数：input 参数、output 参数、input/output 参数 以及 return 参数。

语法

objectname.property
objectname.method

属性

属性 | 描述
Attributes | 设置或返回一个 Parameter 对象的属性。
Direction | 设置或返回某个参数如何传递到存储过程或从存储过程传递回来。
Name | 设置或返回一个 Parameter 对象的名称。
NumericScale | 设置或返回一个 Parameter 对象的数值的小数点右侧的数字数目。
Precision | 设置或返回当表示一个参数中数值时所允许数字的最大数目。
Size | 设置或返回 Parameter 对象中的值的最大大小（按字节或字符）。
Type | 设置或返回一个 Parameter 对象的类型。
Value | 设置或返回一个 Parameter 对象的值。

方法

方法 | 描述
AppendChunk | 把长二进制或字符数据追加到一个 Parameter 对象。
Delete | 从 Parameters 集合中删除一个对象。
  • Previous Page
  • Next Page

ADO 参考手册
ADO 实例


ADO Precision 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Precision 属性

返回 ADO Field 对象参考手册

定义和用法

Precision 属性可设置或返回一个 byte 值，该值是表示 Parameter 或 Field 对象中的数值时所允许的最大位数。

语法

objectname.Precision
对象 | Precision 属性的描述
Field | 对于 Field 对象，Precision 通常为只读。但是，对于已追加到 Record 的 Fields 集合的新 Field 对象，只有当已指定 Field 的 Value 属性并且数据提供者通过调用 Fields 集合的 Update 方法成功添加了新 Field 时，Precision 才为读/写。
Parameter | 对于 Parameter 对象，Precision属性拥有读/写权限。

实例

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

response.write(rs.Fields(0).Precision)

rs.Close
conn.close
%>

返回 ADO Field 对象参考手册

ADO 参考手册
ADO 实例


ADO Precision 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Precision 属性

返回 ADO Parameter 对象参考手册

定义和用法

Precision 属性可设置或返回一个 byte 值，该值是表示 Parameter 或 Field 对象中的数值时所允许的最大位数。

语法

objectname.Precision
对象 | Precision 属性的描述
Field | 对于 Field 对象，Precision 通常为只读。但是，对于已追加到 Record 的 Fields 集合的新 Field 对象，只有当已指定 Field 的 Value 属性并且数据提供者通过调用 Fields 集合的 Update 方法成功添加了新 Field 时，Precision 才为读/写。
Parameter | 对于 Parameter 对象，Precision属性拥有读/写权限。

实例

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

response.write(rs.Fields(0).Precision)

rs.Close
conn.close
%>

返回 ADO Parameter 对象参考手册

ADO 参考手册
ADO 实例


ADO Prepared 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Prepared 属性

返回 ADO Command 对象参考手册

定义和用法

Prepared 属性可返回或设置一个布尔值，如果设置为 True，则指示该命令应该保存查询的一个准备好的（或已编译的）版本, 该查询是第一次执行 Command 对象前在 CommandText 属性中指定的。

这会降低命令的首次执行速度，但是在第一次执行执行后，provider 将使用已编译的版本，这样就可以加快执行速度。

如果该属性为 False，提供者将直接执行 Command 对象而不创建编译版本。

如果提供者不支持命令准备，则一旦将此属性设置为 True，提供者便可能返回错误。如果它不返回错误，则仅忽略准备命令的请求，并将 Prepared 属性设置为 False。

语法

objcommand.Prepared=true or false

实例

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set comm=Server.CreateObject("ADODB.Command")
comm.ActiveConnection=conn
comm.CommandText="orders"
comm.Prepared=true
response.write(comm.Prepared)

conn.close
%>

返回 ADO Command 对象参考手册

ADO 参考手册
ADO 实例


ADO Property 对象

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Property 对象

  • Previous Page
  • Next Page

Property 对象

ADO 对象有两种类型的属性：内置属性和动态属性。

内置属性是在 ADO 中实现并立即可用于任何新对象的属性，此时使用 MyObject.Property 语法。它们不会作为 Property 对象出现在对象的 Properties 集合中，因此，虽然可以更改它们的值，但无法更改它们的特性。

ADO Property 对象表示 ADO 对象的动态特性，这种动态特性是被 provider 定义的。

每个与 ADO 对话的 provider 拥有不同的方式与 ADO 进行交互。所以，ADO 需要通过某种方式来存储有关 provider 的信息。解决方法是 provider 为 ADO 提供具体的信息（动态属性）。ADO 把每个 provider 属性存储在一个 Property 对象中，而 Property 对象相应地也被存储在 Properties 集合中。此集合会被分配到 Command 对象、Connection 对象、Field 对象 或者 Recordset 对象。

例如，指定给提供者的属性可能会指示 Recordset 对象是否支持事务或更新。这些附加的属性将作为 Property 对象出现在该 Recordset 对象的 Properties 集合中。

ProgID

set objProperty=Server.CreateObject("ADODB.property")

属性

属性 | 描述
Attributes | 返回一个 Property 对象的属性
Name | 设置或返回一个 Property 对象的名称
Type | 返回 Property 的类型
Value | 设置或返回 一个 Property 对象的值
  • Previous Page
  • Next Page

ADO 参考手册
ADO 实例


ADO Provider 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Provider 属性

返回 ADO Connection 对象参考手册

定义和用法

Provider 属性可设置或返回包含特定 Connection 对象的提供者名称的字符串值。默认是 MSDASQL (Microsoft OLE DB provider for ODBC)。请参阅 Provider 代码。

在连接关闭时，此属性是可读写的。

提供者名称也可通过 Connection 对象的 ConnectionString 属性或者 Open 方法的 ConnectionString 参数来设置。

注释：请不要在多个地方为特定的 Connection 设置 provider。

语法

connobj.Provider

实例

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

response.write(conn.Provider)

conn.close
%>

Provider 代码

Provider 代码 | Provider
ADSDSOObject | Active Directory Services
Microsoft.Jet.OLEDB.4.0 | Microsoft Jet databases
MSDAIPP.DSO.1 | Microsoft Internet Publishing
MSDAORA | Oracle databases
MSDAOSP | Simple text files
MSDASQL | Microsoft OLE DB provider for ODBC
MSDataShape | Microsoft Data Shape
MSPersist | Locally saved files
SQLOLEDB | Microsoft SQL Server

返回 ADO Connection 对象参考手册

ADO 参考手册
ADO 实例


ADO Record 对象

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Record 对象

  • Previous Page
  • Next Page

Record 对象 (ADO version 2.5)

ADO Record 对象用于容纳记录集中的一行、或文件系统的一个文件或一个目录。

ADO 2.5 之前的版本仅能够访问结构化的数据库。在一个结构化的数据库中，每个表在每一行均有确切相同的列数，并且每一列都由相同的数据类型组成。

Record 对象允许访问行与行之间的列数且/或数据类型不同的数据集。

语法

objectname.property
objectname.method

属性

属性 | 描述
ActiveConnection | 设置或返回 Record 对象当前所属的 Connection 对象。
Mode | 设置或返回在Record 对象中修改数据的有效权限。
ParentURL | 返回父 Record 的绝对URL。
RecordType | 返回 Record 对象的类型。
Source | 设置或返回 Record 对象的 Open 方法的 src 参数。
State | 返回 Record 对象的状态。

方法

方法 | 描述
Cancel | 取消一次 CopyRecord、DeleteRecord、MoveRecord 或 Open 调用的执行。
Close | 关闭一个 Record 对象。
CopyRecord | 把文件或目录拷贝到另外一个位置。
DeleteRecord | 删除一个文件或目录。
GetChildren | 返回一个 Recordset 对象，其中的每一行表示目录中的文件或子目录。
MoveRecord | 把文件或目录移动到另外一个位置。
Open | 打开一个已有的 Record 对象或创建一个新的文件或目录。

集合

集合 | 描述
Properties | 特定提供者属性的一个集合。
Fields | 包含 Record 对象中的所有 Field 对象。

Fields 集合的属性

属性 描述
Count

返回 fields 集合中的项目数。起始值为 0。

例子：

countfields = rec.Fields.Count
Item(named_item/number)

返回 fields 集合中的某个指定的项目。

例子：

itemfields = rec.Fields.Item(1)
或者
itemfields = rec.Fields.Item("Name")
  • Previous Page
  • Next Page

ADO 参考手册
ADO 实例


ADO Recordset 对象

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Recordset 对象

  • Previous Page
  • Next Page

实例

GetRows
本例演示如何使用 GetRows 方法。

Recordset 对象

ADO Recordset 对象用于容纳一个来自数据库表的记录集。一个 Recordset 对象由记录和列（字段）组成。

在 ADO 中，此对象是最重要且最常用于对数据库的数据进行操作的对象。

ProgID

set objRecordset=Server.CreateObject("ADODB.recordset")

当您首次打开一个 Recordset 时，当前记录指针将指向第一个记录，同时 BOF 和 EOF 属性为 False。如果没有记录，BOF 和 EOF 属性为 True。

Recordset 对象能够支持两种更新类型：

    立即更新 - 一旦调用 Update 方法，所有更改被立即写入数据库。 批更新 - provider 将缓存多个更改，然后使用 UpdateBatch 方法把这些更改传送到数据库。

在 ADO，定义了 4 中不同的游标（指针）类型：

  • 动态游标 - 允许您查看其他用户所作的添加、更改和删除
  • 键集游标 - 类似动态游标，不同的是您无法查看有其他用户所做的添加，并且它会防止您访问其他用户已删除的记录。其他用户所做的数据更改仍然是可见的。
  • 静态游标 - 提供记录集的静态副本，可用来查找数据或生成报告。此外，由其他用户所做的添加、更改和删除将是不可见的。当您打开一个客户端 Recordset 对象时，这是唯一被允许的游标类型。
  • 仅向前游标 - 只允许在 Recordset 中向前滚动。此外，由其他用户所做的添加、更改和删除将是不可见的。

可通过 CursorType 属性或 Open 方法中的 CursorType 参数来设置游标的类型。

注释：并非所有的提供者（providers）支持 Recordset 对象的所有方法和属性。

属性

属性 | 描述
AbsolutePage | 设置或返回一个可指定 Recordset 对象中页码的值。
AbsolutePosition | 设置或返回一个值，此值可指定 Recordset 对象中当前记录的顺序位置（序号位置）。
ActiveCommand | 返回与 Recordset 对象相关联的 Command 对象。
ActiveConnection | 如果连接被关闭，设置或返回连接的定义，如果连接打开，设置或返回当前的 Connection 对象。
BOF | 如果当前的记录位置在第一条记录之前，则返回 true，否则返回 fasle。
Bookmark | 设置或返回一个书签。此书签保存当前记录的位置。
CacheSize | 设置或返回能够被缓存的记录的数目。
CursorLocation | 设置或返回游标服务的位置。
CursorType | 设置或返回一个 Recordset 对象的游标类型。
DataMember | 设置或返回要从 DataSource 属性所引用的对象中检索的数据成员的名称。
DataSource | 指定一个包含要被表示为 Recordset 对象的数据的对象。
EditMode | 返回当前记录的编辑状态。
EOF | 如果当前记录的位置在最后的记录之后，则返回 true，否则返回 fasle。
Filter | 返回一个针对 Recordset 对象中数据的过滤器。
Index | 设置或返回 Recordset 对象的当前索引的名称。
LockType | 设置或返回当编辑 Recordset 中的一条记录时，可指定锁定类型的值。
MarshalOptions | 设置或返回一个值，此值指定哪些记录被返回服务器。
MaxRecords | 设置或返回从一个查询返回 Recordset 对象的的最大记录数目。
PageCount | 返回一个 Recordset 对象中的数据页数。
PageSize | 设置或返回 Recordset 对象的一个单一页面上所允许的最大记录数。
RecordCount | 返回一个 Recordset 对象中的记录数目。
Sort | 设置或返回一个或多个作为 Recordset 排序基准的字段名。
Source | 设置一个字符串值，或一个 Command 对象引用，或返回一个字符串值，此值可指示 Recordset 对象的数据源。
State | 返回一个值，此值可描述是否 Recordset 对象是打开、关闭、正在连接、正在执行或正在取回数据。
Status | 返回有关批更新或其他大量操作的当前记录的状态。
StayInSync | 设置或返回当父记录位置改变时对子记录的引用是否改变。

方法

方法 | 描述
AddNew | 创建一条新记录。
Cancel | 撤销一次执行。
CancelBatch | 撤销一次批更新。
CancelUpdate | 撤销对 Recordset 对象的一条记录所做的更改。
Clone | 创建一个已有 Recordset 的副本。
Close | 关闭一个 Recordset。
CompareBookmarks | 比较两个书签。
Delete | 删除一条记录或一组记录。
Find | 搜索一个 Recordset 中满足指定某个条件的一条记录。
GetRows | 把多条记录从一个 Recordset 对象中拷贝到一个二维数组中。
GetString | 将 Recordset 作为字符串返回。
Move | 在 Recordset 对象中移动记录指针。
MoveFirst | 把记录指针移动到第一条记录。
MoveLast | 把记录指针移动到最后一条记录。
MoveNext | 把记录指针移动到下一条记录。
MovePrevious | 把记录指针移动到上一条记录。
NextRecordset | 通过执行一系列命令清除当前 Recordset 对象并返回下一个 Recordset。
Open | 打开一个数据库元素，此元素可提供对表的记录、查询的结果或保存的 Recordset 的访问。
Requery | 通过重新执行对象所基于的查询来更新 Recordset 对象中的数据。
Resync | 从原始数据库刷新当前 Recordset 中的数据。
Save | 把 Recordset 对象保存到 file 或 Stream 对象中。
Seek | 搜索 Recordset 的索引以快速定位与指定的值相匹配的行，并使其成为当前行。
Supports | 返回一个布尔值，此值可定义 Recordset 对象是否支持特定类型的功能。
Update | 保存所有对 Recordset 对象中的一条单一记录所做的更改。
UpdateBatch | 把所有 Recordset 中的更改存入数据库。请在批更新模式中使用。

事件

Note: You cannot handle events using VBScript or JScript (only Visual Basic, Visual C++, and Visual J++ languages can handle events).

事件 | 描述
EndOfRecordset | 当试图移动到超过 Recordset 结尾的行时被触发。
FetchComplete | 当异步操作中的所有记录均被读取后被触发。
FetchProgress | 在异步操作期间被定期地触发，报告已读取多少记录。
FieldChangeComplete | Field 对象的值更改被触发。
MoveComplete | Recordset 中的当前位置更改后被触发。
RecordChangeComplete | 一条记录更改之后被触发。
RecordsetChangeComplete | 在 Recordset 更改之后被触发。
WillChangeField | 在 Field 对象的值更改之前被触发
WillChangeRecord | 在一条记录更改之前被触发。
WillChangeRecordset | 在 Recordset 更改之前被触发。
WillMove | 在 Recordset 中的当前位置更改之前被触发。

集合

集合 | 描述
Fields | 指示在此 Recordset 对象中 Field 对象的数目。
Properties | 包含所有 Recordset 对象中的 Property 对象。

Fields 集合的属性

属性 描述
Count

返回 fields 集合中项目的数目。以 0 起始。

例子：

countfields = rs.Fields.Count
Item(named_item/number)

返回 fields 集合中的某个指定的项目。

例子：

itemfields = rs.Fields.Item(1)
或者
itemfields = rs.Fields.Item("Name")

Properties 集合的属性

属性 描述
Count

返回 properties 集合中项目的数目。以 0 起始。

例子：

countprop = rs.Properties.Count
Item(named_item/number)

返回 properties 集合中某个指定的项目。

例子：

itemprop = rs.Properties.Item(1)
或者
itemprop = rs.Properties.Item("Name")
  • Previous Page
  • Next Page

ADO 参考手册
ADO 实例


ADO Recordset（记录集）

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Recordset（记录集）

  • Previous Page
  • Next Page

如需读取数据库的数据，那么其中的数据必须首先被载入一个记录集中。

创建一个 ADO 表记录集（ADO Table Recordset）

在 ADO 数据库连接创建之后，如上一章所述，接下来就可以建立一个 ADO 记录集了。

假设我们有一个名为 "Northwind" 的数据库，我们可以通过下面的代码访问数据库中的 "Customers" 表：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs=Server.CreateObject("ADODB.recordset")
rs.Open "Customers", conn
%>

创建一个 ADO SQL 记录集 （ADO SQL Recordset）

我们也可使用 SQL 访问 "Customers" 表中的数据：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs=Server.CreateObject("ADODB.recordset")
rs.Open "Select * from Customers", conn
%>

从记录集中提取数据

在记录集被打开后，我们可以从记录集中提取数据。

假设我们用一个名为 "Northwind" 的数据库，我们可以通过下面的代码访问数据库中 "Customers" 表：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs=Server.CreateObject("ADODB.recordset")
rs.Open "Select * from Customers", conn

for each x in rs.fields
   response.write(x.name)
   response.write(" = ")
   response.write(x.value)
next
%>

ADO 记录集对象（ADO Recordset Object）

ADO Recordset 对象可被用来容纳来自数据库表的记录集。

查看 ADO Recordset 对象的所有方法和属性。

  • Previous Page
  • Next Page

ADO 参考手册
ADO 实例


ADO Size 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Size 属性

返回 ADO Parameter 对象参考手册

定义和用法

Size 属性可设置或返回一个 long 值，该值指示 Parameter 对象中的值的最大尺寸（字节或字符）。

语法

objparameter.Size

说明

如果要指定 Parameter 对象的变长数据类型（例如所有 String 类型，如 adVarChar），必须先设置对象的 Size 属性，然后再将该对象追加到 Parameters 集合。否则，将会产生错误。

如果已经将 Parameter 对象追加到 Command 对象的 Parameters 集合中，并将其类型更改为变长数据类型，则必须先设置 Parameter 对象的 Size 属性，然后再执行 Command 对象。否则，将发生错误。

如果使用 Refresh 方法从提供者获取参数信息，并且返回一个或多个变长数据类型 Parameter 对象，ADO 可能会根据其可能的最大尺寸为这些参数分配内存空间，这在执行过程中可能会导致错误。若要避免错误，在执行命令前应显式地设置这些参数的 Size 属性。

Size 属性为读/写。

实例

<%
set comm=Server.CreateObject("ADODB.Command")
set para=Server.CreateObject("ADODB.Parameter")

para.Type=adVarChar
para.Size=25
para.Direction=adParamInput
para.Value=varfname

comm.Parameters.Append para
%>

返回 ADO Parameter 对象参考手册

ADO 参考手册
ADO 实例


ADO Source 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Source 属性

返回 ADO Error 对象参考手册

定义和用法

Source 属性可返回一个字符串值，指示最初产生错误的对象或应用程序的名称。

语法

strErrorSource=objErr.Source

实例

<%
for each objErr in objConn.Errors
  response.write("<p>")
  response.write("Description: ")
  response.write(objErr.Description & "<br />")
  response.write("Help context: ")
  response.write(objErr.HelpContext & "<br />")
  response.write("Help file: ")
  response.write(objErr.HelpFile & "<br />")
  response.write("Native error: ")
  response.write(objErr.NativeError & "<br />")
  response.write("Error number: ")
  response.write(objErr.Number & "<br />")
  response.write("Error source: ")
  response.write(objErr.Source & "<br />")
  response.write("SQL state: ")
  response.write(objErr.SQLState & "<br />")
  response.write("</p>")
next
%>

返回 ADO Error 对象参考手册

ADO 参考手册
ADO 实例


ADO SQLState 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO SQLState 属性

返回 ADO Error 对象参考手册

定义和用法

SQLState 属性可返回一个字符串，该字符串包含由提供者返回的五个字符的 SQL 错误代码。

语法

strErrorSQL=objErr.SQLState

实例

<%
for each objErr in objConn.Errors
  response.write("<p>")
  response.write("Description: ")
  response.write(objErr.Description & "<br />")
  response.write("Help context: ")
  response.write(objErr.HelpContext & "<br />")
  response.write("Help file: ")
  response.write(objErr.HelpFile & "<br />")
  response.write("Native error: ")
  response.write(objErr.NativeError & "<br />")
  response.write("Error number: ")
  response.write(objErr.Number & "<br />")
  response.write("Error source: ")
  response.write(objErr.Source & "<br />")
  response.write("SQL state: ")
  response.write(objErr.SQLState & "<br />")
  response.write("</p>")
next
%>

返回 ADO Error 对象参考手册

ADO 参考手册
ADO 实例


ADO State 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO State 属性

返回 ADO Command 对象参考手册

定义和用法

State 属性可返回一个值，该值描述对象的当前状态是打开、关闭、正在连接、正在执行还是正在检索数据。该值返回 ObjectStateEnum 值。默认值为 adStateClosed。

此属性可用于 Command, Connection, Record, Recordset 以及 Stream 对象。

State 属性可以是值的组合。例如，如果正在执行某个语句，此属性将有一个 adStateOpen 和 adStateExecuting 的组合值。

State 属性为只读。

语法

object.State

实例

针对 Command 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set comm=Server.CreateObject("ADODB.Command")
response.write(comm.State)

conn.close
%>

针对 Connection 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

response.write(conn.State)

conn.close
%>

返回 ADO Command 对象参考手册

ADO 参考手册
ADO 实例


ADO State 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO State 属性

返回 ADO Connection 对象参考手册

定义和用法

State 属性可返回一个值，该值描述对象的当前状态是打开、关闭、正在连接、正在执行还是正在检索数据。该值返回 ObjectStateEnum 值。默认值为 adStateClosed。

此属性可用于 Command, Connection, Record, Recordset 以及 Stream 对象。

State 属性可以是值的组合。例如，如果正在执行某个语句，此属性将有一个 adStateOpen 和 adStateExecuting 的组合值。

State 属性为只读。

语法

object.State

实例

针对 Command 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set comm=Server.CreateObject("ADODB.Command")
response.write(comm.State)

conn.close
%>

针对 Connection 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

response.write(conn.State)

conn.close
%>

返回 ADO Connection 对象参考手册

ADO 参考手册
ADO 实例


ADO Status 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Status 属性

返回 ADO Field 对象参考手册

定义和用法

Status 属性可返回一个 FieldStatusEnum 值，该值指示 Field 对象的状态。默认值是 adFieldOK。

如果更新失败，将返回错误，并且 Status 属性会指示该操作的组合值和错误状态代码。每个 Field 的 Status 属性均可用于确定该 Field 未被添加、修改或删除的原因。

添加、修改或删除某个 Field 的问题会通过此属性进行报告。举例，如果用户删除一个字段，它将在 Fields 集合中被标记为删除。如果由于用户试图删除其没有权限删除的 Field，使得 Update 调用返回错误，那么该字段的 Status 将是 adFieldPermissionDenied 或 adFieldPendingDelete。

语法

objfield.Status

实例

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

response.write(rs.Fields(0).Status)

rs.Close
conn.close
%>

FieldStatusEnum 值

常量 | 值 | 描述
adFieldOK | 0 | 默认。指示已成功添加或删除该字段。
adFieldCantConvertValue | 2 | 指示无法在不损失数据的情况下检索或存储该字段。
adFieldIsNull | 3 | 指示提供者返回了 Null 值。
adFieldTruncated | 4 | 指示从数据源读取时，变长数据被截断。
adFieldSignMismatch | 5 | 指示由提供者返回的数据值带符号，而 ADO 字段值的数据类型不带符号。
adFieldDataOverflow | 6 | 指示从提供者返回的数据超出了字段的数据类型。
adFieldCantCreate | 7 | 指示因为提供者超过了限制（如所允许的字段数量），所以不能添加该字段。
adFieldUnavailable | 8 | 指示从数据源读取时，提供者不能确定值。例如，行刚被创建，列的默认值无法使用，并且还没有指定新值。
adFieldPermissionDenied | 9 | 指示由于该字段被定义为只读，因此无法对其进行修改。
adFieldIntegrityViolation | 10 | 指示由于该字段是计算或派生的项目，因此无法对其进行修改。
adFieldSchemaViolation | 11 | 指示值违反了字段的数据源模式限制。
adFieldBadStatus | 12 | 指示从 ADO 向 OLE DB 提供者发送了无效状态值。原因可能是 OLE DB 1.0 或 1.1 提供者，或者是 Value 与 Status 的组合不恰当。
adFieldDefault | 13 | 指示在设置数据时使用了字段的默认值。
adFieldIgnore | 15 | 指示在设置源中的数据值时，此字段被跳过。提供者未设置任何值。
adFieldDoesNotExist | 16 | 指示指定的字段不存在。
adFieldInvalidURL | 17 | 指示数据源 URL 包含无效的字符。
adFieldResourceLocked | 18 | 指示因为数据源被一个或多个其他应用程序或进程锁定，所以提供者不能执行操作。
adFieldResourceExists | 19 | 指示因为对象已在目标 URL 中存在，而且不能被覆盖，所以提供者不能执行操作。
adFieldCannotComplete | 20 | 指示由 Source 指定 URL 的服务器不能完成操作。
adFieldVolumeNotFound | 21 | 指示提供者不能定位 URL 指示的存储量。
adFieldOutOfSpace | 22 | 指示提供者无法获取足够的存储空间来完成移动或复制操作。
adFieldCannotDeleteSource | 23 | 指示在移动操作中，树或子树被移动到新的位置，但是源不能被删除。
adFieldReadOnly | 24 | 指示数据源中的字段被定义为只读。
adFieldResourceOutOfScope | 25 | 指示源或目标 URL 超出了当前记录的范围。
adFieldAlreadyExists | 26 | 指示指定的字段已存在。
adFieldPendingInsert | 0x10000 | 指示 Append 操作导致需要设置状态。Field 被标记为在调用 Update 方法后添加到 Fields 集合。
adFieldPendingDelete | 0x20000 | 指示 Delete 操作导致需要设置状态。该字段被标记为在调用 Update 方法后从 Fields 集合删除。
adFieldPendingChange | 0x40000 | 指示该字段被删除后又被重新添加（可能数据类型不同），或者指示以前具有 adFieldOK 状态的字段的值已经被更改。字段的最终格式将在调用 Update 方法之后修改 Fields 集合。
adFieldPendingUnknown | 0x80000 | 指示提供者无法确定哪个操作导致需要设置状态。
adFieldPendingUnknownDelete | 0x100000 | 指示提供者无法确定哪个操作导致需要设置字段状态，以及在调用 Update 方法后，该字段将被从 Fields 集合中删除。

返回 ADO Field 对象参考手册

ADO 参考手册
ADO 实例


ADO Stream 对象

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Stream 对象

  • Previous Page
  • Next Page

Stream 对象 (ADO version 2.5)

ADO Stream 对象用于读写以及处理二进制数据或文本流。

Stream 对象可通过三种方法获得：

  • 通过指向包含二进制或文本数据的对象（通常是文件）的 URL。此对象可以是简单的文档、表示结构化文档的 Record 对象或文件夹。
  • 通过将 Stream 对象实例化。这些 Stream 对象可用来存储用于应用程序的数据。跟与 URL 相关联的 Stream 或 Record 的默认 Stream 不同，实例化的 Stream 在默认情况下与基本源没有关联。
  • 通过打开与 Record 对象相关联的默认 Stream 对象。打开 Record 时便可获取与 Record 对象相关联的默认流。只需打开该流便可删除一个往返过程。

语法

objectname.property
objectname.method

属性

属性 | 描述
CharSet | 指定用于存储 Stream 的字符集。
EOS | 返回当前位置是否位于流的结尾。
LineSeparator | 设置或返回用在文本 Stream 对象中的分行符。
Mode | 设置或返回供修改数据的可用权限。
Position | 设置或返回从 Stream 对象开始处的当前位置（按字节计算）。
Size | 返回一个打开的 Stream 对象的大小。
State | 返回一个描述 Stream 是打开还是关闭的值。
Type | 设置或返回 Stream 对象中的数据的类型。

方法

方法 | 描述
Cancel | 取消对 Stream 对象的 Open 调用的执行。
Close | 关闭一个 Stream 对象。
CopyTo | 把指定数目的字符/比特从一个 Stream 对象拷贝到另外一个 Stream 对象。
Flush | 把 Stream 缓冲区中的内容发送到相关联的下层对象。
LoadFromFile | 把文件的内容载入 Stream 对象。
Open | 打开一个 Stream 对象。
Read | 从一个二进制 Stream 对象读取全部流或指定的字节数。
ReadText | 从一个文本 Stream 对象中读取全部流、一行或指定的字节数。
SaveToFile | 把一个 Stream 对象的二进制内容保存到某个文件。
SetEOS | 设置当前位置为流的结尾 (EOS)
SkipLine | 在读取一个文本流时跳过一行。
Write | 把二进制数据写到一个二进制 Stream 对象。
WriteText | 把字符数据写到一个文本 Stream 对象。
  • Previous Page
  • Next Page

ADO 参考手册
ADO 实例


ADO Type 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Type 属性

返回 ADO Field 对象参考手册

定义和用法

Type 属性可设置或返回一个 DataTypeEnum 值，该值可指示 Parameter, Field 或 Property 对象的类型。

对象 | Type 对象的描述
Parameter | 对于 Parameter 对象，Type 属性拥有读/写权限。
Field | 对于已追加到 Record 的 Fields 集合中的新 Field 对象，只有当 Field 的 Value 属性已被指定并且数据提供者通过调用 Fields 集合的 Update 方法成功添加了新的 Field 时，Type 才为读/写。
Property | 对于 Property 对象，Type 属性是只读的。

语法

objectname.Type

实例

针对 Field 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

response.write(rs.Fields(0).Type)

rs.Close
conn.close
%>

针对 Parameter 对象：

<%
set comm=Server.CreateObject("ADODB.Command")
set para=Server.CreateObject("ADODB.Parameter")

para.Type=adVarChar
para.Size=25
para.Direction=adParamInput
para.Value=varfname

comm.Parameters.Append para
%>

针对 Property 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

set prop=Server.CreateObject("ADODB.Property")

'Display the property attributes of the Orders Table
for each prop in rs.Properties
  response.write("Attr:" & prop.Attributes & "<br />")
  response.write("Name:" & prop.Name & "<br />")
  response.write("Value:" & prop.Value & "<br />")
  response.write("Type:" & prop.Type & "<br />")
next

rs.close
conn.close
set rs=nothing
set conn=nothing
%>

返回 ADO Field 对象参考手册

ADO 参考手册
ADO 实例


ADO Type 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Type 属性

返回 ADO Parameter 对象参考手册

定义和用法

Type 属性可设置或返回一个 DataTypeEnum 值，该值可指示 Parameter, Field 或 Property 对象的类型。

对象 | Type 对象的描述
Parameter | 对于 Parameter 对象，Type 属性拥有读/写权限。
Field | 对于已追加到 Record 的 Fields 集合中的新 Field 对象，只有当 Field 的 Value 属性已被指定并且数据提供者通过调用 Fields 集合的 Update 方法成功添加了新的 Field 时，Type 才为读/写。
Property | 对于 Property 对象，Type 属性是只读的。

语法

objectname.Type

实例

针对 Field 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

response.write(rs.Fields(0).Type)

rs.Close
conn.close
%>

针对 Parameter 对象：

<%
set comm=Server.CreateObject("ADODB.Command")
set para=Server.CreateObject("ADODB.Parameter")

para.Type=adVarChar
para.Size=25
para.Direction=adParamInput
para.Value=varfname

comm.Parameters.Append para
%>

针对 Property 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

set prop=Server.CreateObject("ADODB.Property")

'Display the property attributes of the Orders Table
for each prop in rs.Properties
  response.write("Attr:" & prop.Attributes & "<br />")
  response.write("Name:" & prop.Name & "<br />")
  response.write("Value:" & prop.Value & "<br />")
  response.write("Type:" & prop.Type & "<br />")
next

rs.close
conn.close
set rs=nothing
set conn=nothing
%>

返回 ADO Parameter 对象参考手册

ADO 参考手册
ADO 实例


ADO Value 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Value 属性

返回 ADO Field 对象参考手册

定义和用法

Value 属性可设置或返回 Parameter, Field 或 Property 对象的值。

对象 | Value 属性的描述
Parameter | Value 值可设置或返回一个 variant 值，该值指示 Parameter 对象的值。 注释：在读取 Value 属性之前，应当关闭 Recordset 对象。对于 Parameter 对象，ADO 只从提供者读取 Value 属性一次。
Field | Value 属性可设置或返回一个 variant 值，该值指示 Field 对象的当前值。 注释：对于被添加到 Record 的 Fields 集合的新的 Field 对象，在设置任何其他属性之前，您必须首先设置 Value 属性，并且调用 Fields 集合的 Update。
Property | Value 属性可设置或返回一个 variant 值，该值指示 Property 对象的当前值。 注释：您无法为只读属性设置 Value。

语法

objectname.Value

实例

针对 Field 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

response.write(rs.Fields(0).Value)

rs.Close
conn.close
%>

针对 Parameter 对象：

<%
set comm=Server.CreateObject("ADODB.Command")
set para=Server.CreateObject("ADODB.Parameter")

para.Type=adVarChar
para.Size=25
para.Direction=adParamInput
para.Value=varfname

comm.Parameters.Append para
%>

针对 Property 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

set prop=Server.CreateObject("ADODB.Property")

'Display the property attributes of the Orders Table
for each prop in rs.Properties
  response.write("Attr:" & prop.Attributes & "<br />")
  response.write("Name:" & prop.Name & "<br />")
  response.write("Value:" & prop.Value & "<br />")
next

rs.close
conn.close
set rs=nothing
set conn=nothing
%>

返回 ADO Field 对象参考手册

ADO 参考手册
ADO 实例


ADO Value 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Value 属性

返回 ADO Parameter 对象参考手册

定义和用法

Value 属性可设置或返回 Parameter, Field 或 Property 对象的值。

对象 | Value 属性的描述
Parameter | Value 值可设置或返回一个 variant 值，该值指示 Parameter 对象的值。 注释：在读取 Value 属性之前，应当关闭 Recordset 对象。对于 Parameter 对象，ADO 只从提供者读取 Value 属性一次。
Field | Value 属性可设置或返回一个 variant 值，该值指示 Field 对象的当前值。 注释：对于被添加到 Record 的 Fields 集合的新的 Field 对象，在设置任何其他属性之前，您必须首先设置 Value 属性，并且调用 Fields 集合的 Update。
Property | Value 属性可设置或返回一个 variant 值，该值指示 Property 对象的当前值。 注释：您无法为只读属性设置 Value。

语法

objectname.Value

实例

针对 Field 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

response.write(rs.Fields(0).Value)

rs.Close
conn.close
%>

针对 Parameter 对象：

<%
set comm=Server.CreateObject("ADODB.Command")
set para=Server.CreateObject("ADODB.Parameter")

para.Type=adVarChar
para.Size=25
para.Direction=adParamInput
para.Value=varfname

comm.Parameters.Append para
%>

针对 Property 对象：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.Recordset")
rs.open "Select * from orders", conn

set prop=Server.CreateObject("ADODB.Property")

'Display the property attributes of the Orders Table
for each prop in rs.Properties
  response.write("Attr:" & prop.Attributes & "<br />")
  response.write("Name:" & prop.Name & "<br />")
  response.write("Value:" & prop.Value & "<br />")
next

rs.close
conn.close
set rs=nothing
set conn=nothing
%>

返回 ADO Parameter 对象参考手册

ADO 参考手册
ADO 实例


ADO Version 属性

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO Version 属性

返回 ADO Connection 对象参考手册

定义和用法

Version 属性可返回 ADO 的版本号。

语法

version=objconn.Version

实例

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

response.write(conn.Version)

conn.close
%>

返回 ADO Connection 对象参考手册

ADO 参考手册
ADO 实例


ADO WillConnect, ConnectComplete 以及 Disconnect 事件

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO WillConnect, ConnectComplete 以及 Disconnect 事件

返回 ADO Connection 对象参考手册

定义和用法

事件是某个具体的操作发生后被自动调用的子例程。

  • WillConnect 事件在连接开始之前被触发。
  • ConnectComplete 事件在连接开始之后被触发。
  • Disconnect 事件在连接结束后被触发。

语法

WillConnect ConnectionString,userid,psword,options,status,objcon

ConnectComplete objerror,status,objconn

Disconnect status,objconn

参数 | 描述
ConnectionString | 一个包含用于连接的信息的字符串。
userid | 一个包含用于连接的用户名的字符串。
psword | 一个包含用于连接的密码的字符串。
options | Long 值，指示提供者计算 ConnectionString 的方式。唯一的选项是 adAsyncOpen。
objerror | 包含所发生错误的 Error 对象。 注释：EventStatusEnum 值必需设置为 adStatusErrorsOccurred ，以创建 Error 对象。
status | 一个 EventStatusEnum 值。默认是 adStatusOK。 当调用 ConnectComplete 时，如果 WillConnect 事件请求取消挂起的连接，此参数将设置为 adStatusCancel。
objconn | 应用此事件的 Connection 对象。

EventStatusEnum 值

常量 | 值 | 描述
adStatusOK | 1 | 引发该事件的操作成功。
adStatusErrorsOccurred | 2 | 引发该事件的操作失败。
adStatusCantDeny | 3 | 不能取消挂起操作。
adStatusCancel | 4 | 取消导致事件发生的操作。
adStatusUnwantedEvent | 5 | 在事件方法执行结束之前禁止后续的通知。

返回 ADO Connection 对象参考手册

ADO 参考手册
ADO 实例


ADO WillExecute 和 ExecuteComplete 事件

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO WillExecute 和 ExecuteComplete 事件

返回 ADO Connection 对象参考手册

定义和用法

事件是某个具体的操作发生后被自动调用的子例程。

  • WillExecute 事件在调用 objcomm.Execute, objconn.Execute 或者 objrs.Open 之前会被触发
  • ExecuteComplete 事件会在完成对 objcomm.Execute, objconn.Execute, objrs.Open, objrs.Requery 或 objrs.NextRecordset 的调用之后被触发

语法

WillExecute src,cursortyp,locktyp,options,status,objcomm,objrs,objconn

ExecuteComplete recaffected,objerror,status,objcomm,objrs,objconn

参数 | 描述
src | 字符串，包含 SQL 命令或存储过程名称。
cursortyp | 规定要使用的游标类型。CursorTypeEnum 值之一。
locktyp | 规定要使用的锁定类型。LockTypeEnum 值之一。
options | 一个或多个 CommandTypeEnum 或 ExecuteOptionEnum 值
recaffected | Long 值，该命令影响的记录的数目。
objerror | 包含已发生的错误的 Error 对象。 注释：EventStatusEnum 值必须被设置为 adStatusErrorsOccurred，以创建该 Error 对象。
status | 一个 EventStatusEnum 值。
objcomm | 对于 WillExecute：如果此事件由 Command.Execute 引发，objcomm 参数将引用 Command 对象，objrs 参数将设置为 Nothing。 对于 ExecuteComplete：被执行的 Command 对象。
objrs | 对于 WillExecute：如果此事件由 Recordset.Open 引发，objrs 参数将引用 Recordset 对象，pCommand 参数将设置为 Nothing。 对于 ExecuteComplete：Recordset 对象，是命令执行的结果。
objconn | 与命令执行相关联的 Connection 对象。

EventStatusEnum 值

常量 | 值 | 描述
adStatusOK | 1 | 引发该事件的操作成功。
adStatusErrorsOccurred | 2 | 引发该事件的操作失败。
adStatusCantDeny | 3 | 不能取消挂起操作。
adStatusCancel | 4 | 取消导致事件发生的操作。
adStatusUnwantedEvent | 5 | 在事件方法执行结束之前禁止后续的通知。

返回 ADO Connection 对象参考手册

ADO 参考手册
ADO 实例


ADO 参考手册

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO 参考手册

  • Next Page

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • Next Page

ADO 参考手册
ADO 实例


ADO 查询

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO 查询

  • Previous Page
  • Next Page

我们可以使用 SQL 来创建查询，这样就可以指定仅查看选定的记录和字段。

实例

显示 "Companyname" 以 A 开头的记录
如何仅仅显示 "Customers" 表的 "Companyname" 字段中以 A 开头的记录。
显示 "Companyname" 大于 E 的记录
如何仅仅显示 "Customers" 表的 "Companyname" 字段中大于 E 的记录。
仅显示西班牙的客户
如何仅仅显示 "Customers" 表中的西班牙客户。
让用户来选择筛选标准
让用户根据国别来选择客户

显示选定的数据

我们希望仅仅显示 "Customers" 表的 "Companyname" 字段中以 A 开头的记录：

<html>
<body>

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs=Server.CreateObject("ADODB.recordset")
sql="SELECT Companyname, Contactname FROM Customers
WHERE CompanyName LIKE 'A%'"
rs.Open sql, conn
%>

<table border="1" width="100%">
  <tr>
  <%for each x in rs.Fields
    response.write("<th>" & x.name & "</th>")
  next%>
  </tr>
  <%do until rs.EOF%>
    <tr>
    <%for each x in rs.Fields%>
      <td><%Response.Write(x.value)%></td>
    <%next
    rs.MoveNext%>
    </tr>
  <%loop
  rs.close
  conn.close%>
</table>

</body>
</html>
  • Previous Page
  • Next Page

ADO 参考手册
ADO 实例


ADO 更新记录

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO 更新记录

  • Previous Page
  • Next Page

我们可使用 SQL 的 UPDATE 来更新数据库表中的某条记录。

更新数据库表中的记录

我们希望更新 Northwind 数据中 Customers 表的某条记录。首先我们需要创建一个表格，来列出 Customers 中的所有记录。

<html>
<body>
<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"
set rs=Server.CreateObject("ADODB.Recordset")
rs.open "SELECT * FROM customers",conn
%>

<h2>List Database</h2>
<table border="1" width="100%">
<tr>
<%
for each x in rs.Fields
  response.write("<th>" & ucase(x.name) & "</th>")
next
%>
</tr>
<% do until rs.EOF %>
<tr>
<form method="post" action="demo_update.asp">
<%
for each x in rs.Fields
  if lcase(x.name)="customerid" then%>
    <td>
    <input type="submit" name="customerID" value="<%=x.value%>">
    </td>
  <%else%>
    <td><%Response.Write(x.value)%></td>
  <%end if
next
%>
</form>
<%rs.MoveNext%>
</tr>
<%
loop
conn.close
%>
</table>

</body>
</html>

如果用户点击 "customerID" 列中的按钮，会打开一个新文件 "demo_update.asp"。此文件包含了创建输入域的源代码，这些输入域基于数据库中记录的字段，同时也含有一个保存修改的“更新按钮”：

<html>
<body>

<h2>Update Record</h2>
<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

cid=Request.Form("customerID")

if Request.form("companyname")="" then
  set rs=Server.CreateObject("ADODB.Recordset")
  rs.open "SELECT * FROM customers WHERE customerID='" & cid & "'",conn
  %>
  <form method="post" action="demo_update.asp">
  <table>
  <%for each x in rs.Fields%>
  <tr>
  <td><%=x.name%></td>
  <td><input name="<%=x.name%>" value="<%=x.value%>"></td>
  <%next%>
  </tr>
  </table>
  <br /><br />
  <input type="submit" value="Update record">
  </form>
<%
else
  sql="UPDATE customers SET "
  sql=sql & "companyname='" & Request.Form("companyname") & "',"
  sql=sql & "contactname='" & Request.Form("contactname") & "',"
  sql=sql & "address='" & Request.Form("address") & "',"
  sql=sql & "city='" & Request.Form("city") & "',"
  sql=sql & "postalcode='" & Request.Form("postalcode") & "',"
  sql=sql & "country='" & Request.Form("country") & "'"
  sql=sql & " WHERE customerID='" & cid & "'"
  on error resume next
  conn.Execute sql
  if err<>0 then
    response.write("No update permissions!")
  else
    response.write("Record " & cid & " was updated!")
  end if
end if
conn.close
%>

</body>
</html>
  • Previous Page
  • Next Page

ADO 参考手册
ADO 实例


ADO 简介

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO 简介

  • Previous Page
  • Next Page

ADO 被用于从网页访问数据库。

您应当具备的基础知识

在继续学习之前，您需要对下面的知识有基本的了解：

  • WWW、HTML 以及对网站构建的基本了解
  • ASP（动态服务器页面）
  • SQL（结构化查询语言）

如果您希望首先学习这些项目，请在我们的 首页 访问这些教程。

什么是 ADO？

  • ADO 是一项微软的技术
  • ADO 指 ActiveX 数据对象（ActiveX Data Objects）
  • ADO 是一个微软的 Active-X 组件
  • ADO 会随微软的 IIS 被自动安装
  • ADO 是一个访问数据库中数据的编程接口

从 ASP 页面访问数据库

从一个 ASP 页面内部访问数据库的通常的方法是：

  1. 创建一个到数据库的 ADO 连接
  2. 打开数据库连接
  3. 创建 ADO 记录集
  4. 从记录集提取您需要的数据
  5. 关闭记录集
  6. 关闭连接
  • Previous Page
  • Next Page

ADO 参考手册
ADO 实例


ADO 教程

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO 教程

  • Next Page

在我们的 ADO 教程中，您将学到有关 ADO 的知识，以及如何使用 ADO 从您的网站访问数据库。

开始学习 ADO ！

ADO 参考手册

在 W3School，我们为您提供完整的 ADO 参考手册，其中包括内建对象，以及它们的属性和方法。

ADO 参考手册

ADO 实例

通过实例来学习！因为 ASP 脚本只能在服务器端执行，所以你无法在浏览器中查看 ASP 代码，你能看到的仅仅是由 ASP 输出的纯粹的 HTML 代码。

在 W3School，每个实例均可显示出以往被隐藏的 ASP 代码。这样，您就可以更容易理解它们的工作原理。

ADO 实例

  • Next Page

ADO 参考手册
ADO 实例


ADO 排序

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO 排序

  • Previous Page
  • Next Page

我们可以使用SQL来规定如何对记录集中的数据进行排序。

实例

根据指定的字段名处对记录进行升序排序
如何根据指定字段名对数据进行排序
根据指定的字段名处对记录进行降序排序
如何根据指定字段名对数据进行排序
让用户来选择根据哪列进行排序
让用户来选择根据哪列进行排序

对数据进行排序

我们希望显示 "Customers" 表中的"Companyname"和"Contactname"字段，并根据"Companyname"进行排序（请记得用.asp为后缀保存）：

<html>
<body>

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.recordset")
sql="SELECT Companyname, Contactname FROM
Customers ORDER BY CompanyName"
rs.Open sql, conn
%>

<table border="1" width="100%">
  <tr>
  <%for each x in rs.Fields
    response.write("<th>" & x.name & "</th>")
  next%>
  </tr>
  <%do until rs.EOF%>
    <tr>
    <%for each x in rs.Fields%>
      <td><%Response.Write(x.value)%></td>
    <%next
    rs.MoveNext%>
    </tr>
  <%loop
  rs.close
  conn.close%>
</table>

</body>
</html>
  • Previous Page
  • Next Page

ADO 参考手册
ADO 实例


ADO 删除记录

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO 删除记录

  • Previous Page
  • Next Page

我们可使用 SQL 的 DELETE 命令来删除数据库表中的某条记录。

删除表中的记录

我们希望删除 Northwind 数据库的 Customers 表中的一条记录。首先我们需要创建一个表格，来列出 Customers 中的所有记录。

<html>
<body>
<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"
set rs=Server.CreateObject("ADODB.Recordset")
rs.open "SELECT * FROM customers",conn
%>

<h2>List Database</h2>
<table border="1" width="100%">
<tr>
<%
for each x in rs.Fields
  response.write("<th>" & ucase(x.name) & "</th>")
next
%>
</tr>
<% do until rs.EOF %>
<tr>
<form method="post" action="demo_delete.asp">
<%
for each x in rs.Fields
  if x.name="customerID" then%>
    <td>
    <input type="submit" name="customerID" value="<%=x.value%>">
    </td>
  <%else%>
    <td><%Response.Write(x.value)%></td>
  <%end if
next
%>
</form>
<%rs.MoveNext%>
</tr>
<%
loop
conn.close
%>
</table>

</body>
</html>

假如用户点击 "customerID" 列中的按钮，会打开新文件 "demo_delete.asp"。此文件包含了创建输入域的源代码，这些输入域基于数据库中记录的字段，同时也含有一个删除当前记录的“删除按钮”：

<html>
<body>

<h2>Delete Record</h2>
<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

cid=Request.Form("customerID"

if Request.form("companyname")="" then
  set rs=Server.CreateObject("ADODB.Recordset")
  rs.open "SELECT * FROM customers WHERE customerID='" & cid & "'",conn
  %>
  <form method="post" action="demo_delete.asp">
  <table>
  <%for each x in rs.Fields%>
  <tr>
  <td><%=x.name%></td>
  <td><input name="<%=x.name%>" value="<%=x.value%>"></td>
  <%next%>
  </tr>
  </table>
  <br /><br />
  <input type="submit" value="Delete record">
  </form>
<%
else
  sql="DELETE FROM customers"
  sql=sql & " WHERE customerID='" & cid & "'"
  on error resume next
  conn.Execute sql
  if err<>0 then
    response.write("No update permissions!")
  else
    response.write("Record " & cid & " was deleted!")
  end if
end if
conn.close
%>

</body>
</html>
  • Previous Page
  • Next Page

ADO 参考手册
ADO 实例


ADO 数据库连接

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO 数据库连接

  • Previous Page
  • Next Page

在从某个网页访问数据之前，必须先建立一个数据库连接。

创建一个 DSN-less 数据库连接

连接到某一个数据库的最简单的方法是使用一个 DSN-less 连接。DSN-less 连接可被用于您的站点上的任何微软 Access 数据库。

假设您拥有一个名为 "northwind.mdb" 的数据库位于 "c:/webdata/" 的 web 目录中，您可以使用下面的 ASP 代码连接到此数据库：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"
%>

注意，在上面的例子中，您必须规定微软的 Access 数据库驱动程序（Provider），以及此数据库在计算机上的物理路径。

创建一个 ODBC 数据库连接

假设您拥有一个名为 "northwind" 的 ODBC 数据库，您可以使用下面的 ASP 代码连接到此数据库：

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Open "northwind"
%>

通过一个 ODBC 连接，您可以连接到您的网络中任何计算机上的任何数据库，只要 ODBC 连接是可用的。

到 MS Access 数据库的 ODBC 连接

下面为您讲解如何创建到一个 MS Access 数据库的连接：

  1. 打开控制面板中的 ODBC 图标
  2. 选择系统 ODBC 选项卡
  3. 点击 ODBC 选项卡中的添加按钮
  4. 选择 Driver to Microsoft Access，然后点击完成按钮
  5. 在下一个窗口中点击“选择”按钮来定位数据库
  6. 为此数据库赋予一个数据源名称（Data Source Name，DSN）
  7. 点击"确定"

注意：此配置必须在您的网站所在的计算机上完成。假如您正在自己的计算机上运行PWS或者IIS，此架构是可以运行的，但是假如您的网站位于一台远程的服务器，您就必须拥有此服务器的物理访问权限，或者请您的 web 主机提供商为您做这些事情。

ADO 连接对象（ADO Connection Object）

ADO 连接对象用来创建到某个数据源的开放连接。通过此连接，您可以对此数据库进行访问和操作。

查看此连接对象的所有方法和属性。

  • Previous Page
  • Next Page

ADO 参考手册
ADO 实例


ADO 数据类型

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO 数据类型

  • Previous Page
  • Next Page

下面的表格列出了 Access、SQL Server 与 Oracle 之间的数据类型映射：

DataType Enum | Value | Access | SQLServer | Oracle
adBigInt | 20 |  | BigInt (SQL Server 2000 +) |
adBinary | 128 |  | Binary TimeStamp | Raw *
adBoolean | 11 | YesNo | Bit |
adChar | 129 |  | Char | Char
adCurrency | 6 | Currency | Money SmallMoney |
adDate | 7 | Date | DateTime |
adDBTimeStamp | 135 | DateTime (Access 97 (ODBC)) | DateTime SmallDateTime | Date
adDecimal | 14 |  |  | Decimal *
adDouble | 5 | Double | Float | Float
adGUID | 72 | ReplicationID (Access 97 (OLEDB)), (Access 2000 (OLEDB)) | UniqueIdentifier (SQL Server 7.0 +) |
adIDispatch | 9 |  |  |
adInteger | 3 | AutoNumber Integer Long | Identity (SQL Server 6.5) Int | Int *
adLongVarBinary | 205 | OLEObject | Image | Long Raw * Blob (Oracle 8.1.x)
adLongVarChar | 201 | Memo (Access 97) Hyperlink (Access 97) | Text | Long * Clob (Oracle 8.1.x)
adLongVarWChar | 203 | Memo (Access 2000 (OLEDB)) Hyperlink (Access 2000 (OLEDB)) | NText (SQL Server 7.0 +) | NClob (Oracle 8.1.x)
adNumeric | 131 | Decimal (Access 2000 (OLEDB)) | Decimal Numeric | Decimal Integer Number SmallInt
adSingle | 4 | Single | Real |
adSmallInt | 2 | Integer | SmallInt |
adUnsignedTinyInt | 17 | Byte | TinyInt |
adVarBinary | 204 | ReplicationID (Access 97) | VarBinary |
adVarChar | 200 | Text (Access 97) | VarChar | VarChar
adVariant | 12 |  | Sql_Variant (SQL Server 2000 +) | VarChar2
adVarWChar | 202 | Text (Access 2000 (OLEDB)) | NVarChar (SQL Server 7.0 +) | NVarChar2
adWChar | 130 |  | NChar (SQL Server 7.0 +) |

* 在 Oracle 8.0.x 中 - decimal 和 int 等于 number 和 number(10)。

  • Previous Page
  • Next Page

ADO 参考手册
ADO 实例


ADO 添加记录

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO 添加记录

  • Previous Page
  • Next Page

我们可以使用 SQL 的 INSERT INTO 命令向数据库中的表添加记录。

向数据库中的表添加记录

我们希望向 Northwind 数据库中的 Customers 表添加一条新的记录。我们首先要创建一个表单，这个表单包含了我们需要从中搜集数据的输入域：

<html>
<body>

<form method="post" action="demo_add.asp">
<table>
<tr>
<td>CustomerID:</td>
<td><input name="custid"></td>
</tr><tr>
<td>Company Name:</td>
<td><input name="compname"></td>
</tr><tr>
<td>Contact Name:</td>
<td><input name="contname"></td>
</tr><tr>
<td>Address:</td>
<td><input name="address"></td>
</tr><tr>
<td>City:</td>
<td><input name="city"></td>
</tr><tr>
<td>Postal Code:</td>
<td><input name="postcode"></td>
</tr><tr>
<td>Country:</td>
<td><input name="country"></td>
</tr>
</table>
<br /><br />
<input type="submit" value="Add New">
<input type="reset" value="Cancel">
</form>

</body>
</html>

当用户按下确认按钮时，这个表单就会被送往名为 "demo_add.asp" 的文件。文件 "demo_add.asp" 中含有可向 Customers 表添加一条新记录的代码：

<html>
<body>

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

sql="INSERT INTO customers (customerID,companyname,"
sql=sql & "contactname,address,city,postalcode,country)"
sql=sql & " VALUES "
sql=sql & "('" & Request.Form("custid") & "',"
sql=sql & "'" & Request.Form("compname") & "',"
sql=sql & "'" & Request.Form("contname") & "',"
sql=sql & "'" & Request.Form("address") & "',"
sql=sql & "'" & Request.Form("city") & "',"
sql=sql & "'" & Request.Form("postcode") & "',"
sql=sql & "'" & Request.Form("country") & "')"

on error resume next
conn.Execute sql,recaffected
if err<>0 then
  Response.Write("No update permissions!")
else
  Response.Write("<h3>" & recaffected & " record added</h3>")
end if
conn.close
%>

</body>
</html>

重要事项

在您使用 INSERT command 命令时，请注意以下事项：

  • 如果表含有一个主键，请确保向主键字段添加的值是唯一且非空的（否则，provider 就不会追加此记录，亦或发生错误）
  • 如果表含有一个自动编号的字段，请不要在 INSERT 命令中涉及此字段（这个字段的值是由 provider 负责的）

关于无数据字段

在 MS Access 数据库中，假如您将 AllowZeroLength 属性设置为 “Yes”，您可以在文本、超链接以及备忘字段输入零长度的字符串 ("")。

注释：并非所有的数据库都支持零长度的字符串，因而当添加带有空白字段的记录时可能会产生错误。因此，检查您使用的数据库所支持的数据类型是很重要的。

  • Previous Page
  • Next Page

ADO 参考手册
ADO 实例


ADO 通过 GetString() 加速脚本

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO 通过 GetString() 加速脚本

  • Previous Page
  • Next Page

请使用 GetString() 方法来加速您的 ASP 脚本（来代替多行的 Response.Write）。

实例

使用 GetString()
如何使用 GetString() 在 HTML 表格中显示记录集中的数据。

多行 Response.Write

下面的例子演示了在 HTML 表格中显示数据库查询的一种方法：

<html>
<body>

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.recordset")
rs.Open "SELECT Companyname, Contactname FROM Customers", conn
%>

<table border="1" width="100%">
<%do until rs.EOF%>
   <tr>
      <td><%Response.Write(rs.fields("Companyname"))%></td>
      <td><%Response.Write(rs.fields("Contactname"))%></td>
   </tr>
<%rs.MoveNext
loop%>
</table>

<%
rs.close
conn.close
set rs = Nothing
set conn = Nothing
%>

</body>
</html>

对于一个大型的查询来说，这样做会增加脚本的处理时间，这是由于服务器需要处理大量的 Response.Write 命令。

解决的办法是创建全部字符串，从 <table> 到 </table>，然后将其输出 - 只使用一次 Response.Write。

GetString() 方法

GetString() 方法使我们有能力仅使用一次 Response.Write，就可以显示所有的字符串。同时它甚至不需要 do..loop 代码以及条件测试来检查记录集是否处于 EOF。

语法

str = rs.GetString(format,rows,coldel,rowdel,nullexpr)

如需使用来自记录集的数据创建一个 HTML 表格，我们仅仅需要使用以上参数中的三个（所有的参数都是可选的）：

  • coldel - 用作列分隔符的 HTML
  • rowdel - 用作行分隔符的 HTML
  • nullexpr - 当列为空时所使用的 HTML

注释：GetString() 方法是 ADO 2.0 的特性。您可从下面的地址下载 ADO 2.0：http://www.microsoft.com/data/download.htm

在下面的例子中，我们将使用 GetString() 方法，把记录集存为一个字符串：

<html>
<body>

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.recordset")
rs.Open "SELECT Companyname, Contactname FROM Customers", conn

str=rs.GetString(,,"</td><td>","</td></tr><tr><td>","&nbsp;")
%>

<table border="1" width="100%">
  <tr>
    <td><%Response.Write(str)%></td>
  </tr>
</table>

<%
rs.close
conn.close
set rs = Nothing
set conn = Nothing
%>
</body>
</html>

上面的变量 str 包含着由 SELECT 语句返回的所有列和行的一个字符串。在每列之间会出现 </td><td>，在每行之间会出现 </td></tr><tr><td>。这样，仅使用一次 Response.Write，我们就得到了需要的 HTML。

  • Previous Page
  • Next Page

ADO 参考手册
ADO 实例


ADO 显示

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO 显示

  • Previous Page
  • Next Page

显示来自记录集中的数据的最常用的方法，就是把数据显示在 HTML 表格中。

实例

显示记录
如何首先创建一个数据库连接，然后创建一个记录集，然后把其中的数据显示在HTML中。
在 HTML 表格中显示记录
如何把数据表中的数据显示在HTML表格中。
向 HTML 表格添加标题
如何向HTML表格添加标题，以使其可读性更强。
向 HTML 表格添加颜色
如何向HTML表格添加颜色，以使其更加美观。

显示字段名称和字段值

我们有一个名为 "Northwind" 的数据库，并且我们希望显示出 "Customers" 表中的数据（记得以 .asp 为扩展名来保存这个文件）：

<html>
<body>

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.recordset")
rs.Open "SELECT * FROM Customers", conn

do until rs.EOF
  for each x in rs.Fields
    Response.Write(x.name)
    Response.Write(" = ")
    Response.Write(x.value & "<br />")
  next
  Response.Write("<br />")
  rs.MoveNext
loop

rs.close
conn.close
%>

</body>
</html>

在一个 HTML 表格中显示字段名称和字段的值

我们也可以通过下面的代码把表 "Customers" 中的数据显示在一个 HTML 表格中：

<html>
<body>

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.recordset")
rs.Open "SELECT Companyname, Contactname FROM Customers", conn
%>

<table border="1" width="100%">
<%do until rs.EOF%>
   <tr>
   <%for each x in rs.Fields%>
      <td><%Response.Write(x.value)%></td>
   <%next
   rs.MoveNext%>
   </tr>
<%loop
rs.close
conn.close
%>
</table>

</body>
</html>

向 HTML 表格添加标题

我们希望为这个 HTML 表格添加标题，这样它就更易读了：

<html>
<body>

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"

set rs = Server.CreateObject("ADODB.recordset")
sql="SELECT Companyname, Contactname FROM Customers"
rs.Open sql, conn
%>

<table border="1" width="100%">
  <tr>
  <%for each x in rs.Fields
    response.write("<th>" & x.name & "</th>")
  next%>
  </tr>
  <%do until rs.EOF%>
    <tr>
    <%for each x in rs.Fields%>
      <td><%Response.Write(x.value)%></td>
    <%next
    rs.MoveNext%>
    </tr>
  <%loop
  rs.close
  conn.close
  %>
</table>

</body>
</html>
  • Previous Page
  • Next Page

ADO 参考手册
ADO 实例


您已经学习了 ADO，下一步呢？

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

您已经学习了 ADO，下一步呢？

  • Previous Page
  • Next Page

ADO 概述

本教程已经向您讲解了如何从网站访问数据库中的数据。

您已经学习了如何在网站上显示来自数据库的数据，以及如何通过 ADO 来编辑、添加及删除这些数据。

如需更多有关 ADO 的信息，请参阅我们的 ADO 实例。

您已经学习了 ADO，下一步呢？

下一步应该学习 SQL。

SQL 是一门用于访问和操作数据库系统的标准计算机语言。

SQL 语句用于检索和更新数据库中的数据。SQL 可以和这些数据库系统配合工作：MS Access, DB2, Informix, MS SQL Server, Oracle, Sybase, 以及其他的数据库系统。

如果您需要学习更多有关 SQL 的知识，请访问我们的 SQL 教程。

  • Previous Page
  • Next Page

ADO 参考手册
ADO 实例


AJAX - XMLHttpRequest 对象

AJAX 基础

  • AJAX 首页
  • AJAX 简介
  • AJAX HTTP 请求
  • AJAX 实例
  • AJAX 浏览器支持
  • AJAX XMLHttpRequest
  • AJAX 请求服务器
  • AJAX 服务器脚本

AJAX 高级

  • AJAX 请求实例
  • AJAX 请求源代码
  • AJAX 数据库实例
  • AJAX XML 实例
  • AJAX ResponseXML

AJAX 实例

  • AJAX 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

AJAX - XMLHttpRequest 对象

  • Previous Page
  • Next Page

AJAX - 更多有关 XMLHttpRequest 对象的知识

在向服务器发送数据之前，我们有必要解释一下 XMLHttpRequest 对象的三个重要的属性。

onreadystatechange 属性

onreadystatechange 属性存有处理服务器响应的函数。下面的代码定义一个空的函数，可同时对 onreadystatechange 属性进行设置：

xmlHttp.onreadystatechange=function()
  {
  // 我们需要在这里写一些代码
  }

readyState 属性

readyState 属性存有服务器响应的状态信息。每当 readyState 改变时，onreadystatechange 函数就会被执行。

这是 readyState 属性可能的值：

状态 | 描述
0 | 请求未初始化（在调用 open() 之前）
1 | 请求已提出（调用 send() 之前）
2 | 请求已发送（这里通常可以从响应得到内容头部）
3 | 请求处理中（响应中通常有部分数据可用，但是服务器还没有完成响应）
4 | 请求已完成（可以访问服务器响应并使用它）

我们要向这个 onreadystatechange 函数添加一条 If 语句，来测试我们的响应是否已完成（意味着可获得数据）：

xmlHttp.onreadystatechange=function()
  {
  if(xmlHttp.readyState==4)
    {
    // 从服务器的response获得数据
    }
  }

responseText 属性

可以通过 responseText 属性来取回由服务器返回的数据。

在我们的代码中，我们将把时间文本框的值设置为等于 responseText：

xmlHttp.onreadystatechange=function()
  {
  if(xmlHttp.readyState==4)
    {
    document.myForm.time.value=xmlHttp.responseText;
    }
  }

下一节，我们会介绍如何向服务器请求数据！

  • Previous Page
  • Next Page


AJAX - 请求服务器

AJAX 基础

  • AJAX 首页
  • AJAX 简介
  • AJAX HTTP 请求
  • AJAX 实例
  • AJAX 浏览器支持
  • AJAX XMLHttpRequest
  • AJAX 请求服务器
  • AJAX 服务器脚本

AJAX 高级

  • AJAX 请求实例
  • AJAX 请求源代码
  • AJAX 数据库实例
  • AJAX XML 实例
  • AJAX ResponseXML

AJAX 实例

  • AJAX 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

AJAX - 请求服务器

  • Previous Page
  • Next Page

AJAX - 向服务器发送一个请求

要想把请求发送到服务器，我们就需要使用 open() 方法和 send() 方法。

open() 方法需要三个参数。第一个参数定义发送请求所使用的方法（GET 还是 POST）。第二个参数规定服务器端脚本的 URL。第三个方法规定应当对请求进行异步地处理。

send() 方法可将请求送往服务器。如果我们假设 HTML 文件和 ASP 文件位于相同的目录，那么代码是这样的：

xmlHttp.open("GET","time.asp",true);
xmlHttp.send(null);

现在，我们必须决定何时执行 AJAX 函数。当用户在用户名文本框中键入某些内容时，我们会令函数“在幕后”执行。

<html>
<body>

<script type="text/javascript">

function ajaxFunction()
 {
 var xmlHttp;

 try
    {
   // Firefox, Opera 8.0+, Safari
    xmlHttp=new XMLHttpRequest();
    }
 catch (e)
    {

  // Internet Explorer
   try
      {
      xmlHttp=new ActiveXObject("Msxml2.XMLHTTP");
      }
   catch (e)
      {

      try
         {
         xmlHttp=new ActiveXObject("Microsoft.XMLHTTP");
         }
      catch (e)
         {
         alert("您的浏览器不支持AJAX！");
         return false;
         }
      }
    }

    xmlHttp.onreadystatechange=function()
      {
      if(xmlHttp.readyState==4)
        {
         document.myForm.time.value=xmlHttp.responseText;
        }
      }
    xmlHttp.open("GET","time.asp",true);
    xmlHttp.send(null);

 }
</script>

<form name="myForm">
用户: <input type="text" name="username" onkeyup="ajaxFunction();" />
时间: <input type="text" name="time" />
</form>

</body>
</html>

下一节介绍 "time.asp" 的脚本，这样我们完整的 AJAX 应用程序就搞定了。

  • Previous Page
  • Next Page


AJAX -服务器端的脚本

AJAX 基础

  • AJAX 首页
  • AJAX 简介
  • AJAX HTTP 请求
  • AJAX 实例
  • AJAX 浏览器支持
  • AJAX XMLHttpRequest
  • AJAX 请求服务器
  • AJAX 服务器脚本

AJAX 高级

  • AJAX 请求实例
  • AJAX 请求源代码
  • AJAX 数据库实例
  • AJAX XML 实例
  • AJAX ResponseXML

AJAX 实例

  • AJAX 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

AJAX -服务器端的脚本

  • Previous Page
  • Next Page

AJAX - 服务器端的脚本

现在，我们要创建可显示当前服务器时间的脚本。

responseText 属性会存储从服务器返回的数据。在这里，我们希望传回当前的时间。这是 "time.asp" 的代码：

<%
response.expires=-1
response.write(time)
%>

注释：Expires 属性可设置在页面缓存失效前页面被缓存的时间（分钟）。Response.Expires=-1 指示页面不会被缓存。

运行您的 AJAX 应用程序

请在下面的文本框中键入一些文本，然后单击时间文本框：

时间文本框可在不加载页面的情况下从 "time.asp" 获得服务器的时间！

  • Previous Page
  • Next Page


AJAX Http 请求

AJAX 基础

  • AJAX 首页
  • AJAX 简介
  • AJAX HTTP 请求
  • AJAX 实例
  • AJAX 浏览器支持
  • AJAX XMLHttpRequest
  • AJAX 请求服务器
  • AJAX 服务器脚本

AJAX 高级

  • AJAX 请求实例
  • AJAX 请求源代码
  • AJAX 数据库实例
  • AJAX XML 实例
  • AJAX ResponseXML

AJAX 实例

  • AJAX 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

AJAX Http 请求

  • Previous Page
  • Next Page

AJAX 使用 Http 请求

在传统的 JavaScript 编程中，假如您希望从服务器上的文件或数据库中得到任何的信息，或者向服务器发送信息的话，就必须利用一个 HTML 表单向服务器 GET 或 POST 数据。而用户则需要单击“提交”按钮来发送/获取信息，等待服务器的响应，然后一张新的页面会加载结果。

由于每当用户提交输入后服务器都会返回一张新的页面，传统的 web 应用程序变得运行缓慢，且越来越不友好。

通过利用 AJAX，您的 JavaScript 会通过 JavaScript 的 XMLHttpRequest 对象，直接与服务器来通信。

通过使用 HTTP 请求，web 页可向服务器进行请求，并得到来自服务器的响应，而不加载页面。用户可以停留在同一个页面，他或她不会注意到脚本在后台请求过页面，或向服务器发送过数据。

XMLHttpRequest 对象

通过使用 XMLHttpRequest 对象，web 开发者可以做到在页面已加载后从服务器更新页面！

在 2005 年 AJAX 被 Google 推广开来（Google Suggest）。

Google 建议使用 XMLHttpRequest 对象来创建一种动态性极强的 web 界面：当您开始在 Google 的搜索框中输入查询时，JavaScript 会向某个服务器发出这些字词，然后服务器会返回一系列的搜索建议。

XMLHttpRequest 对象得到下列浏览器的支持：Internet Explorer 5.0+、Safari 1.2、Mozilla 1.0 / Firefox、Opera 8+ 以及 Netscape 7。

  • Previous Page
  • Next Page


AJAX ResponseXML 实例

AJAX 基础

  • AJAX 首页
  • AJAX 简介
  • AJAX HTTP 请求
  • AJAX 实例
  • AJAX 浏览器支持
  • AJAX XMLHttpRequest
  • AJAX 请求服务器
  • AJAX 服务器脚本

AJAX 高级

  • AJAX 请求实例
  • AJAX 请求源代码
  • AJAX 数据库实例
  • AJAX XML 实例
  • AJAX ResponseXML

AJAX 实例

  • AJAX 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

AJAX ResponseXML 实例

  • Previous Page
  • Next Page

与 responseText 以字符串返回 HTTP 响应不同，responseXML 以 XML 返回响应。

ResponseXML 属性返回 XML 文档对象，可使用 W3C DOM 节点树的方法和属性来检查和解析该对象。

AJAX ResponseXML 实例

在下面的 AJAX 实例中，我们将演示网页如何使用 AJAX 技术从数据库中读取信息。这次，这些从数据库中选取的数据将被转换为 XML 文档，然后我们将使用 DOM 来提取要显示的值。

选取下拉列表中的名称

AJAX 实例解释

上面的例子包含一个 HTML 表单，若干个保留所返回数据的 <span> 元素，以及指向一段 JavaScript 的链接：

<html>
<head>
<script src="selectcustomer_xml.js"></script>
</head>
<body>

<form action="">
<label>选择客户：
<select name="customers" onchange="showCustomer(this.value)">
<option value="ALFKI">Alfreds Futterkiste</option>
<option value="NORTS ">North/South</option>
<option value="WOLZA">Wolski Zajazd</option>
</select></label>
</form>

<b><span id="companyname"></span></b><br />
<span id="contactname"></span><br />
<span id="address"></span>
<span id="city"></span><br/>
<span id="country"></span>

</body>
</html>

上面的例子包含了一个 HTML 表单，该表单带有一个名为 "customers" 下拉框。

当用户选取下拉框中的客户时，函数 "showCustomer()" 就会被执行。事件 "onchange" 会触发该函数执行。换句话说，每当用户改变下拉框中的值时，函数 showCustomer() 就会被调用。

下面列出了 JavaScript 代码。

AJAX JavaScript

这是存储在文件 "selectcustomer_xml.js" 中的 JavaScript 代码：

var xmlHttp

function showCustomer(str)
{
xmlHttp=GetXmlHttpObject();
if (xmlHttp==null)
  {
  alert ("Your browser does not support AJAX!");
  return;
  }
var url="getcustomer_xml.asp";
url=url+"?q="+str;
url=url+"&sid="+Math.random();
xmlHttp.onreadystatechange=stateChanged;
xmlHttp.open("GET",url,true);
xmlHttp.send(null);
}

function stateChanged()
{
if (xmlHttp.readyState==4)
{
var xmlDoc=xmlHttp.responseXML.documentElement;
document.getElementById("companyname").innerHTML=
xmlDoc.getElementsByTagName("compname")[0].childNodes[0].nodeValue;
document.getElementById("contactname").innerHTML=
xmlDoc.getElementsByTagName("contname")[0].childNodes[0].nodeValue;
document.getElementById("address").innerHTML=
xmlDoc.getElementsByTagName("address")[0].childNodes[0].nodeValue;
document.getElementById("city").innerHTML=
xmlDoc.getElementsByTagName("city")[0].childNodes[0].nodeValue;
document.getElementById("country").innerHTML=
xmlDoc.getElementsByTagName("country")[0].childNodes[0].nodeValue;
}
}

function GetXmlHttpObject()
{
var xmlHttp=null;
try
  {
  // Firefox, Opera 8.0+, Safari
  xmlHttp=new XMLHttpRequest();
  }
catch (e)
  {
  // Internet Explorer
  try
    {
    xmlHttp=new ActiveXObject("Msxml2.XMLHTTP");
    }
  catch (e)
    {
    xmlHttp=new ActiveXObject("Microsoft.XMLHTTP");
    }
  }
return xmlHttp;
}

showCustomer() 和 GetXmlHttpObject() 与上一节相同。stateChanged() 函数稍早前也在本教程中使用过。不过，这次我们通过 responseXML 以 XML 文档返回结果，并使用 DOM 来提取要显示的值。

AJAX 服务器页面

这个被 JavaScript 调用的服务器页面，是名为 "getcustomer_xml.asp" 的简单 ASP 文件。

该页面使用 VBScript 编写，针对 Internet 信息服务器 (IIS)。可以用 PHP 或其他服务器语言，简单地重写该页面。

请看在 PHP 中对应的例子（测试：缺具体页面）。

这段代码执行针对数据库的 SQL 查询，并以 XML 文档返回结果：

<%
response.expires=-1
response.contenttype="text/xml"

sql="SELECT * FROM CUSTOMERS "
sql=sql & " WHERE CUSTOMERID='" & request.querystring("q") & "'"

on error resume next
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open(Server.Mappath("/db/northwind.mdb"))
set rs=Server.CreateObject("ADODB.recordset")
rs.Open sql, conn

if err <> 0 then
response.write(err.description)
set rs=nothing
set conn=nothing
else
response.write("<?xml version='1.0' encoding='ISO-8859-1'?>")
response.write("<company>")
response.write("<compname>" &rs.fields("companyname")& "</compname>")
response.write("<contname>" &rs.fields("contactname")& "</contname>")
response.write("<address>" &rs.fields("address")& "</address>")
response.write("<city>" &rs.fields("city")& "</city>")
response.write("<country>" &rs.fields("country")& "</country>")
response.write("</company>")
end if
on error goto 0
%>

请注意上面的 ASP 代码中的第二行：response.contenttype="text/xml"。ContentType 属性为 response 对象设置了 HTTP 内容类型。该属性的默认值是 "text/html"。这次我们把内容类型设置为 XML。

然后我们从数据库中选取数据，并使用这些数据构建 XML 文档。

  • Previous Page
  • Next Page


AJAX XML 实例

AJAX 基础

  • AJAX 首页
  • AJAX 简介
  • AJAX HTTP 请求
  • AJAX 实例
  • AJAX 浏览器支持
  • AJAX XMLHttpRequest
  • AJAX 请求服务器
  • AJAX 服务器脚本

AJAX 高级

  • AJAX 请求实例
  • AJAX 请求源代码
  • AJAX 数据库实例
  • AJAX XML 实例
  • AJAX ResponseXML

AJAX 实例

  • AJAX 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

AJAX XML 实例

  • Previous Page
  • Next Page

AJAX 可用来与 XML 文件进行交互式通信。

AJAX XML 实例

在下面的 AJAX 实例中，我们将演示如何通过使用 AJAX 技术，从 XML 文件中读取信息。

在下面的下列列表中选择一个 CD

在此列出 CD 信息。

AJAX 实例解释

上面的例子包含了一个简单的 HTML 表单，以及指向一段 JavaScript 的链接：

<html>
<head>
<script src="selectcd.js"></script>
</head>

<body>

<form>
选择 CD：
<select name="cds" onchange="showCD(this.value)">
<option value="Bob Dylan">Bob Dylan</option>
<option value="Bonnie Tyler">Bonnie Tyler</option>
<option value="Dolly Parton">Dolly Parton</option>
</select>
</form>

<p>
<div id="txtHint"><em>在此列出 CD 信息。</em></div>
</p>

</body>
</html>

正如您所看到的，它只是一个带有名为 "cds" 的下拉列表的简单 HTML 表单。

表单下面的段落包含一个名为 "txtHint" 的 div。该 div 用作从 web 服务器接受的数据的位置占位符。

当用户选择列表时，名为 "showCD" 的函数就会被执行。该函数的执行是 "onchange" 事件触发的。换句话说，每当用户改变了下拉列表的值，这个 showCD 函数就会被调用。

下面列出了 JavaScript 代码。

AJAX JavaScript

这是存储在文件 "selectcd.js" 中的 JavaScript 代码：

var xmlHttp

function showCD(str)
{
xmlHttp=GetXmlHttpObject();
if (xmlHttp==null)
  {
  alert ("Your browser does not support AJAX!");
  return;
  }
var url="getcd.asp";
url=url+"?q="+str;
url=url+"&sid="+Math.random();
xmlHttp.onreadystatechange=stateChanged;
xmlHttp.open("GET",url,true);
xmlHttp.send(null);
}

function stateChanged()
{
if (xmlHttp.readyState==4)
{
document.getElementById("txtHint").innerHTML=xmlHttp.responseText;
}
}

function GetXmlHttpObject()
{
var xmlHttp=null;
try
  {
  // Firefox, Opera 8.0+, Safari
  xmlHttp=new XMLHttpRequest();
  }
catch (e)
  {
  // Internet Explorer
  try
    {
    xmlHttp=new ActiveXObject("Msxml2.XMLHTTP");
    }
  catch (e)
    {
    xmlHttp=new ActiveXObject("Microsoft.XMLHTTP");
    }
  }
return xmlHttp;
}

AJAX 服务器页面

被 JavaScript 调用的服务器页面，是名为 "getcd.asp" 的简单 ASP 文件。

该页面使用 VBScript 编写，针对 Internet 信息服务器 (IIS)。可以用 PHP 或其他服务器语言，简单地重写该页面。

请看在 PHP 中对应的例子（测试：缺具体页面）。

该代码执行针对 XML 文件的查询，并以 HTML 返回结果：

<%
response.expires=-1
q=request.querystring("q")

set xmlDoc=Server.CreateObject("Microsoft.XMLDOM")
xmlDoc.async="false"
xmlDoc.load(Server.MapPath("cd_catalog.xml"))

set nodes=xmlDoc.selectNodes("CATALOG/CD[ARTIST='" & q & "']")

for each x in nodes
  for each y in x.childnodes
    response.write("<b>" & y.nodename & ":</b> ")
    response.write(y.text)
    response.write("<br />")
  next
next
%>
  • Previous Page
  • Next Page


AJAX 简介

AJAX 基础

  • AJAX 首页
  • AJAX 简介
  • AJAX HTTP 请求
  • AJAX 实例
  • AJAX 浏览器支持
  • AJAX XMLHttpRequest
  • AJAX 请求服务器
  • AJAX 服务器脚本

AJAX 高级

  • AJAX 请求实例
  • AJAX 请求源代码
  • AJAX 数据库实例
  • AJAX XML 实例
  • AJAX ResponseXML

AJAX 实例

  • AJAX 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

AJAX 简介

  • Previous Page
  • Next Page

AJAX 指异步 JavaScript 及 XML（Asynchronous JavaScript And XML）。

您应当具备的基础知识

在继续学习之前，您需要对下面的知识有基本的了解：

  • HTML / XHTML
  • JavaScript

如果您希望首先学习这些项目，请在我们的首页访问这些教程。

AJAX = 异步 JavaScript 及 XML（Asynchronous JavaScript and XML）

AJAX 不是一种新的编程语言，而是一种用于创建更好更快以及交互性更强的 Web 应用程序的技术。

通过 AJAX，您的 JavaScript 可使用 JavaScript 的 XMLHttpRequest 对象来直接与服务器进行通信。通过这个对象，您的 JavaScript 可在不重载页面的情况与 Web 服务器交换数据。

AJAX 在浏览器与 Web 服务器之间使用异步数据传输（HTTP 请求），这样就可使网页从服务器请求少量的信息，而不是整个页面。

AJAX 可使因特网应用程序更小、更快，更友好。

AJAX 是一种独立于 Web 服务器软件的浏览器技术。

AJAX 基于 Web 标准

AJAX 基于下列 Web 标准：

  • JavaScript
  • XML
  • HTML
  • CSS

在 AJAX 中使用的 Web 标准已被良好定义，并被所有的主流浏览器支持。AJAX 应用程序独立于浏览器和平台。

AJAX 事关更优秀的应用程序

Web 应用程序较桌面应用程序有诸多优势；它们能够涉及广大的用户，它们更易安装及维护，也更易开发。

不过，因特网应用程序并不像传统的桌面应用程序那样完善且友好。

通过 AJAX，因特网应用程序可以变得更完善，更友好。

今天您就可以使用 AJAX

没有什么新东西可学。

AJAX 基于已有的标准。这些标准已被大多数开发者使用多年。

  • Previous Page
  • Next Page


AJAX 教程

AJAX 基础

  • AJAX 首页
  • AJAX 简介
  • AJAX HTTP 请求
  • AJAX 实例
  • AJAX 浏览器支持
  • AJAX XMLHttpRequest
  • AJAX 请求服务器
  • AJAX 服务器脚本

AJAX 高级

  • AJAX 请求实例
  • AJAX 请求源代码
  • AJAX 数据库实例
  • AJAX XML 实例
  • AJAX ResponseXML

AJAX 实例

  • AJAX 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

AJAX 教程

  • Next Page

AJAX 指异步 JavaScript 及 XML（Asynchronous JavaScript And XML）。

AJAX 是一种在 2005 年由 Google 推广开来的编程模式。

AJAX 不是一种新的编程语言，而是一种使用现有标准的新方法。

通过 AJAX，你可以创建更好、更快以及更友好的 WEB 应用程序。

AJAX 基于 JavaScript 和 HTTP 请求（HTTP requests）。

现在就开始学习 AJAX！

  • Next Page


AJAX 请求 源代码

AJAX 基础

  • AJAX 首页
  • AJAX 简介
  • AJAX HTTP 请求
  • AJAX 实例
  • AJAX 浏览器支持
  • AJAX XMLHttpRequest
  • AJAX 请求服务器
  • AJAX 服务器脚本

AJAX 高级

  • AJAX 请求实例
  • AJAX 请求源代码
  • AJAX 数据库实例
  • AJAX XML 实例
  • AJAX ResponseXML

AJAX 实例

  • AJAX 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

AJAX 请求 源代码

  • Previous Page
  • Next Page

AJAX Suggest 源代码的实例

下面的源代码属于上一节的 AJAX 实例。

您可以拷贝粘贴这些代码，然后亲自测试一下。

AJAX HTML 页面

这是 HTML 页面。它包含了一个简单的 HTML 表单，以及一个指向 JavaScript 的链接。

<html>
<head>
<script src="clienthint.js"></script>
</head>

<body>

<form>
First Name:<input type="text" id="txt1" onkeyup="showHint(this.value)" />
</form>

<p>Suggestions: <span id="txtHint"></span></p>

</body>
</html>

下面列出了 JavaScript 代码。

AJAX JavaScript

这是 JavaScript 代码，存储在文件 "clienthint.js" 中：

var xmlHttp

function showHint(str)
{

  if (str.length==0)
    {
    document.getElementById("txtHint").innerHTML="";
    return;
    }

  xmlHttp=GetXmlHttpObject()

  if (xmlHttp==null)
    {
    alert ("您的浏览器不支持AJAX！");
    return;
    }

  var url="gethint.asp";
  url=url+"?q="+str;
  url=url+"&sid="+Math.random();
  xmlHttp.onreadystatechange=stateChanged;
  xmlHttp.open("GET",url,true);
  xmlHttp.send(null);
}

function stateChanged()
{
if (xmlHttp.readyState==4)
{
document.getElementById("txtHint").innerHTML=xmlHttp.responseText;
}
}

function GetXmlHttpObject()
{
  var xmlHttp=null;
  try
    {
    // Firefox, Opera 8.0+, Safari
    xmlHttp=new XMLHttpRequest();
    }
  catch (e)
    {
    // Internet Explorer
    try
      {
      xmlHttp=new ActiveXObject("Msxml2.XMLHTTP");
      }
    catch (e)
      {
      xmlHttp=new ActiveXObject("Microsoft.XMLHTTP");
      }
    }
return xmlHttp;
}

AJAX 服务器页面 - ASP 和 PHP

其实不存在什么“AJAX 服务器”。AJAX 页面可以由任一因特网服务器提供服务。

在上一节的例子中被 JavaScript 调用的服务器页面是一个简单的名为 "gethint.asp" 的 ASP 文件。

下面我们列出了这个服务器页面代码的实例，使用 ASP 来编写。

AJAX ASP 实例

"gethint.asp" 页面中的代码针对 IIS 使用 VBScript 编写。它会检查一个名字数组，然后向客户端返回相应的名字：

<%
response.expires=-1
dim a(30)

'用名字为数组赋值
a(1)="Anna"
a(2)="Brittany"
a(3)="Cinderella"
a(4)="Diana"
a(5)="Eva"
a(6)="Fiona"
a(7)="Gunda"
a(8)="Hege"
a(9)="Inga"
a(10)="Johanna"
a(11)="Kitty"
a(12)="Linda"
a(13)="Nina"
a(14)="Ophelia"
a(15)="Petunia"
a(16)="Amanda"
a(17)="Raquel"
a(18)="Cindy"
a(19)="Doris"
a(20)="Eve"
a(21)="Evita"
a(22)="Sunniva"
a(23)="Tove"
a(24)="Unni"
a(25)="Violet"
a(26)="Liza"
a(27)="Elizabeth"
a(28)="Ellen"
a(29)="Wenche"
a(30)="Vicky"

'从URL取得参数q
q=ucase(request.querystring("q"))

'如果q的长度大于0，则查找所有的hint
if len(q)>0 then
  hint=""
  for i=1 to 30
    if q=ucase(mid(a(i),1,len(q))) then
      if hint="" then
        hint=a(i)
      else
        hint=hint & " , " & a(i)
      end if
    end if
  next
end if

'如果找不到hint，则输出"no suggestion"
'或者输出正确的值
if hint="" then
  response.write("no suggestion")
else
  response.write(hint)
end if
%>
  • Previous Page
  • Next Page


AJAX 请求实例

AJAX 基础

  • AJAX 首页
  • AJAX 简介
  • AJAX HTTP 请求
  • AJAX 实例
  • AJAX 浏览器支持
  • AJAX XMLHttpRequest
  • AJAX 请求服务器
  • AJAX 服务器脚本

AJAX 高级

  • AJAX 请求实例
  • AJAX 请求源代码
  • AJAX 数据库实例
  • AJAX XML 实例
  • AJAX ResponseXML

AJAX 实例

  • AJAX 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

AJAX 请求实例

  • Previous Page
  • Next Page

我们已看到 AJAX 可被用来创建更多交互性的应用程序。

AJAX Suggest实例

在下面的 AJAX 例子中，我们会演示当用户向一个标准的 HTML 表单中输入数据时网页如何与 web 服务器进行通信。

在下面的文本框中输入名字：

Suggestions：

例子解释 - HTML表单

表单的 HTML 代码：

<form>
First Name:<input type="text" id="txt1" onkeyup="showHint(this.value)" />
</form>

<p>Suggestions: <span id="txtHint"></span></p>

正如您看到的，这是一个简单的带有名为 "txt1" 输入域的 HTML 表单。输入域的事件属性定义了一个由 onkeyup 事件触发的函数。

表单下面的段落包含了一个名为 "txtHint" 的 span，这个 span 充当了由 web 服务器所取回的数据的位置占位符。

当用户输入数据时，名为 "showHint()" 的函数就会被执行。函数的执行是由 "onkeyup" 事件触发的。另外需要说明的是，当用户在文本域中输入数据时把手指从键盘按键上移开时，函数 showHint 就会被调用。

例子解释 - showHint() 函数

showHint() 函数是一个位于 HTML 页面 head 部分的很简单的 JavaScript 函数。

此函数包含以下代码：

function showHint(str)
{

  if (str.length==0)
    {
    document.getElementById("txtHint").innerHTML="";
    return;
    }

  xmlHttp=GetXmlHttpObject()

  if (xmlHttp==null)
    {
    alert ("您的浏览器不支持AJAX！");
    return;
    }

var url="gethint.asp";
url=url+"?q="+str;
url=url+"&sid="+Math.random();
xmlHttp.onreadystatechange=stateChanged;
xmlHttp.open("GET",url,true);
xmlHttp.send(null);
}

每当有字符输入文本框时，此函数就会执行。

假如文本域中存在某些输入，函数就会执行：

  • 定义回传数据的服务器的 url（文件名）
  • 使用文本框的内容向 url 添加参数（q）
  • 添加一个随机的数字，以防止服务器使用某个已缓存的文件
  • 创建一个 XMLHTTP 对象，并告知此对象当某个改变被触发时执行名为 stateChanged 的函数
  • 向服务器发送一个 HTTP 请求
  • 如果输入域为空，此函数仅仅会清空 txtHint 占位符的内容

例子解释 - GetXmlHttpObject() 函数

上面的例子可调用名为 GetXmlHttpObject() 的函数。

此函数的作用是解决为不同浏览器创建不同的 XMLHTTP 对象的问题。

这是此函数的代码：

function GetXmlHttpObject()
{
  var xmlHttp=null;
  try
    {
    // Firefox, Opera 8.0+, Safari
    xmlHttp=new XMLHttpRequest();
    }
  catch (e)
    {
    // Internet Explorer
    try
      {
      xmlHttp=new ActiveXObject("Msxml2.XMLHTTP");
      }
    catch (e)
      {
      xmlHttp=new ActiveXObject("Microsoft.XMLHTTP");
      }
    }
  return xmlHttp;
}

例子解释 - stateChanged() 函数

stateChanged() 函数包含下面的代码：

function stateChanged()
{
  if (xmlHttp.readyState==4)
  {
  document.getElementById("txtHint").innerHTML=xmlHttp.responseText;
  }
}

每当 XMLHTTP 对象的状态发生改变时，stateChanged() 函数就会执行。

当状态变更为 4（“完成”）时，txtHint 占位符的内容就被响应文本来填充。

  • Previous Page
  • Next Page


AJAX 实例

AJAX 基础

  • AJAX 首页
  • AJAX 简介
  • AJAX HTTP 请求
  • AJAX 实例
  • AJAX 浏览器支持
  • AJAX XMLHttpRequest
  • AJAX 请求服务器
  • AJAX 服务器脚本

AJAX 高级

  • AJAX 请求实例
  • AJAX 请求源代码
  • AJAX 数据库实例
  • AJAX XML 实例
  • AJAX ResponseXML

AJAX 实例

  • AJAX 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

AJAX 实例

  • Previous Page
  • Next Page

您的第一个 AJAX 应用程序

为了让您理解 AJAX 的工作原理，我们将创建一个小型的 AJAX 应用程序。

首先，我们需要一个带有两个文本框的 HTML 表单：用户名和时间。用户名文本框由用户填写，而时间文本框使用 AJAX 进行填写。

此 HTML 文件名为 "testAjax.htm"（请注意这个 HTML 表单没有提交按钮！）：

<html>
<body>

<form name="myForm">
用户: <input type="text" name="username" />
时间: <input type="text" name="time" />
</form>

</body>
</html>

我们将在下一节解释 AJAX 的基本原理。

  • Previous Page
  • Next Page


AJAX 数据库实例

AJAX 基础

  • AJAX 首页
  • AJAX 简介
  • AJAX HTTP 请求
  • AJAX 实例
  • AJAX 浏览器支持
  • AJAX XMLHttpRequest
  • AJAX 请求服务器
  • AJAX 服务器脚本

AJAX 高级

  • AJAX 请求实例
  • AJAX 请求源代码
  • AJAX 数据库实例
  • AJAX XML 实例
  • AJAX ResponseXML

AJAX 实例

  • AJAX 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

AJAX 数据库实例

  • Previous Page
  • Next Page

AJAX 可用来与数据库进行动态地通信。

AJAX 数据库实例

在下面的 AJAX 例子中，我们将演示如何使用 AJAX 技术令网页从数据库读取信息。

在下面的框中选择一个名字

客户信息将在此处列出。

AJAX 实例解释

上面的实例包含了一个简单的 HTML 表单以及执行 JavaScript 的链接：

<html>
<head>
<script src="selectcustomer.js"></script>
</head>

<body>

<form>
请选择一位客户：
<select name="customers" onchange="showCustomer(this.value)">
<option value="ALFKI">Alfreds Futterkiste
<option value="NORTS ">North/South
<option value="WOLZA">Wolski Zajazd
</select>
</form>

<p>
<div id="txtHint"><b>客户信息将在此处列出。</b></div>
</p>

</body>
</html>

正如您看到的，这是一个简单的带有一个名为 "customers" 下拉列表的 HTML 表单。

表单以下的段落包含了一个名为 "txtHint" 的 div，这个 div 充当了由 web 服务器所取回的信息的位置占位符。

当用户选择数据时，名为 "showCustomer()" 的函数会被执行。函数的执行会被 "onchange" 事件触发。另外需要说明的是：每当用户改变下拉列表中的值，函数 showCustomer 就会被调用。

下面列出了 JavaScript 代码。

AJAX JavaScript

这是存储在文件 "selectcustomer.js" 中的 JavaScript 代码：

var xmlHttp

function showCustomer(str)
{
xmlHttp=GetXmlHttpObject();
if (xmlHttp==null)
  {
  alert ("您的浏览器不支持AJAX！");
  return;
  }
var url="getcustomer.asp";
url=url+"?q="+str;
url=url+"&sid="+Math.random();
xmlHttp.onreadystatechange=stateChanged;
xmlHttp.open("GET",url,true);
xmlHttp.send(null);
}

function stateChanged()
{
if (xmlHttp.readyState==4)
{
document.getElementById("txtHint").innerHTML=xmlHttp.responseText;
}
}

function GetXmlHttpObject()
{
var xmlHttp=null;
try
  {
  // Firefox, Opera 8.0+, Safari
  xmlHttp=new XMLHttpRequest();
  }
catch (e)
  {
  // Internet Explorer
  try
    {
    xmlHttp=new ActiveXObject("Msxml2.XMLHTTP");
    }
  catch (e)
    {
    xmlHttp=new ActiveXObject("Microsoft.XMLHTTP");
    }
  }
return xmlHttp;
}

AJAX 服务器页面

这个被 JavaScript 调用的服务器页面，是一个名为 "getcustomer.asp" 的简单的 ASP 文件。

此页面使用 VBScript 针对 IIS 编写。可以使用 PHP 或其他服务器语言对它进行改写。

此代码可运行针对某个数据库的 SQL，并以 HTML 表格返回结果：

<%
response.expires=-1
sql="SELECT * FROM CUSTOMERS WHERE CUSTOMERID="
sql=sql & "'" & request.querystring("q") & "'"

set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open(Server.Mappath("/db/northwind.mdb"))
set rs = Server.CreateObject("ADODB.recordset")
rs.Open sql, conn

response.write("<table>")
do until rs.EOF
  for each x in rs.Fields
    response.write("<tr><td><em>" & x.name & "</em></td>")
    response.write("<td>" & x.value & "</td></tr>")
  next
  rs.MoveNext
loop

response.write("</table>")
%>
  • Previous Page
  • Next Page


AJAX 浏览器支持

AJAX 基础

  • AJAX 首页
  • AJAX 简介
  • AJAX HTTP 请求
  • AJAX 实例
  • AJAX 浏览器支持
  • AJAX XMLHttpRequest
  • AJAX 请求服务器
  • AJAX 服务器脚本

AJAX 高级

  • AJAX 请求实例
  • AJAX 请求源代码
  • AJAX 数据库实例
  • AJAX XML 实例
  • AJAX ResponseXML

AJAX 实例

  • AJAX 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

AJAX 浏览器支持

  • Previous Page
  • Next Page

AJAX - 浏览器支持

AJAX 的要点是 XMLHttpRequest 对象。

不同的浏览器创建 XMLHttpRequest 对象的方法是有差异的。

IE 浏览器使用 ActiveXObject，而其他的浏览器使用名为 XMLHttpRequest 的 JavaScript 内建对象。

如需针对不同的浏览器来创建此对象，我们要使用一条 "try and catch" 语句。您可以在我们的 JavaScript 教程中阅读更多有关 try 和 catch 语句 的内容。

让我们用这段创建 XMLHttpRequest 对象的 JavaScript 来更新一下我们的 "testAjax.htm" 文件：

<html>
<body>

<script type="text/javascript">

function ajaxFunction()
 {
 var xmlHttp;

 try
    {
   // Firefox, Opera 8.0+, Safari
    xmlHttp=new XMLHttpRequest();
    }
 catch (e)
    {

  // Internet Explorer
   try
      {
      xmlHttp=new ActiveXObject("Msxml2.XMLHTTP");
      }
   catch (e)
      {

      try
         {
         xmlHttp=new ActiveXObject("Microsoft.XMLHTTP");
         }
      catch (e)
         {
         alert("您的浏览器不支持AJAX！");
         return false;
         }
      }
    }
 }
</script>

<form name="myForm">
用户: <input type="text" name="username" />
时间: <input type="text" name="time" />
</form></body>
</html>

例子解释：

首先声明一个保存 XMLHttpRequest 对象的 xmlHttp 变量。

然后使用 XMLHttp=new XMLHttpRequest() 来创建此对象。这条语句针对 Firefox、Opera 以及 Safari 浏览器。假如失败，则尝试针对 Internet Explorer 6.0+ 的 xmlHttp=new ActiveXObject("Msxml2.XMLHTTP")，假如也不成功，则尝试针对 Internet Explorer 5.5+ 的 xmlHttp=new ActiveXObject("Microsoft.XMLHTTP")。

假如这三种方法都不起作用，那么这个用户所使用的浏览器已经太过时了，他或她会看到一个声明此浏览器不支持 AJAX 的提示。

注释：上面这些浏览器定制的代码很长，也很复杂。不过，每当您希望创建 XMLHttpRequest 对象时，这些代码就能派上用场，因此您可以在任何需要使用的时间拷贝粘贴这些代码。上面这些代码兼容所有的主流浏览器：Internet Explorer、Opera、Firefox 以及 Safari。

下一节为您展示如何使用 XMLHttpRequest 对象与服务器进行通信。

  • Previous Page
  • Next Page


ADO 简介

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO 简介

  • Previous Page
  • Next Page

ADO 用于从网页访问数据库。

从 ASP 页面访问数据库

从 ASP 文件内部访问数据库的通常途径是：

  1. 创建至数据库的 ADO 连接（ADO connection）
  2. 打开数据库连接
  3. 创建 ADO 记录集（ADO recordset）
  4. 打开记录集（recordset）
  5. 从数据集中提取你所需要的数据
  6. 关闭数据集
  7. 关闭连接

什么是 ADO?

  • ADO 是一项微软公司的技术
  • ADO 指 ActiveX Data Objects
  • ADO 是一个微软的 Active-X 组件
  • ADO 会随着微软 IIS 自动安装
  • ADO 是用以访问数据库中数据的编程接口

下一步学习什么内容？

假如您希望学习更多关于 ADO 的知识，请阅读我们的 ADO 教程。

  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP Abandon 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Abandon 方法

返回 Session 对象参考手册

定义和用法

Abandon 方法终结用户的会话。

注释：当此方法被调用时，当前的 Session 对象直到当前页面上所有的脚本被处理完后才会被删除。此意味着当调用 Abandon 时可以在同一页面访问 session 变量，但是从另外的网页是不可以访问的。

语法

Session.Abandon

实例

File1.asp:

<%
Session("name")="Hege"
Session.Abandon
Response.Write(Session("name"))
%>

输出：

Hege

File2.asp:

<%
Response.Write(Session("name"))
%>

输出：

(none)

返回 Session 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Add 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Add 方法

返回 Dictionary 对象参考手册

定义和用法

Add 方法向 Dictionary 对象添加一个新的 key/item 对。

注释：如果 key 已经存在，则会出现错误。

语法：

DictionaryObject.Add(key,item)
Parameter | Description
key | 必需的。与 item 相关联的 key 值。
item | 必需的。与 key 相关联的 item 值。

实例

<%
Dim d
Set d=Server.CreateObject("Scripting.Dictionary")
d.Add "re","Red"
d.Add "gr","Green"
d.Add "bl","Blue"
d.Add "pi","Pink"
Response.Write("The value of key gr is: " & d.Item("gr"))
%>

输出：

The value of key gr is: Green

返回 Dictionary 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP AddHeader 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP AddHeader 方法

返回 response 对象参考手册

AddHeader 方法向 HTTP 响应添加一个新的 HTTP 头部和值。

注释：一旦头部被添加，就无法删除。

注释：在 IIS 4.0 中，您调用此方法需要在任何的输出送往浏览器之前。在 IIS 5.0 中，您可以在脚本中的任何点调用 AddHeader 方法，只要它先于对 response.Flush 方法的调用。

语法

response.AddHeader name,value
参数 | 描述
name | 必需。新头部变量的名称 (不能包含下划线)
value | 必需。新头部变量的初始值。

实例

<%Response.AddHeader "WARNING","Error message text"%>

返回 response 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP AdRotator 组件

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP AdRotator 组件

  • Previous Page
  • Next Page

实例

简单的 AdRotator 实例
本例展示：每当用户访问网站或者刷新一次页面，如何使用 AdRotator 组件来显示一幅不同的广告图像。
AdRotator - 图片链接
本例展示：每当用户访问网站或者刷新一次页面，如何使用 AdRotator 组件来显示一幅不同的广告图像。此外，图片本身就是链接。

ASP AdRotator 组件

每当用户进入网站或刷新页面时，ASP AdRotator 组件就会创建一个 AdRotator 对象来显示一幅不同的图片。

语法：

<%
set adrotator=server.createobject("MSWC.AdRotator")
adrotator.GetAdvertisement("textfile.txt")
%>

实例

假设我们有一个文件名为 "banners.asp"。它类似于这样：

<html%>
<body%>
<%
set adrotator=Server.CreateObject("MSWC.AdRotator")
response.write(adrotator.GetAdvertisement("ads.txt"))
%>
</body%>
</html%>

文件 "ads.txt" 类似这样：

*
w3school.gif
http://www.w3school.com.cn/
Visit W3School
80
microsoft.gif
http://www.microsoft.com/
Visit Microsoft
20

"ads.txt" 文件中星号下面的代码定义了如何显示这些图像，链接地址，图像的替换文本，在每百次点击中的显示几率。我们可以看到，W3School 图片的显示几率是 80%，而 Microsoft 图片的显示几率是 20%。

注释：为了使这些链接在用户点击时可以正常工作，我们需要对文件 "ads.txt" 进行一点点小小的修改：

REDIRECT banners.asp
*
w3school.gif
http://www.w3school.com.cn/
Visit W3School
80
microsoft.gif
http://www.microsoft.com/
Visit Microsoft
20

转向页面会接收到名为 url 的变量的查询字符串，其中含有供转向的 URL。

注释：如需规定图像的高度、宽度和边框，我们可以在 REDIRECT 下面插入这些代码：

REDIRECT banners.asp
WIDTH 468
HEIGHT 60
BORDER 0
*
w3school.gif
...
...

最后要做的是把这些代码加入文件"banners.asp"中：

<%
url=Request.QueryString("url")
If url<>"" then Response.Redirect(url)
%>
<html>
<body>
<%
set adrotator=Server.CreateObject("MSWC.AdRotator")
response.write(adrotator.GetAdvertisement("textfile.txt"))
%>
</body>
</html>

好了，这就是全部的内容！

AdRotator 组件的属性

Border 属性

规定围绕广告的边框的尺寸。

<%
set adrot=Server.CreateObject("MSWC.AdRotator")
adrot.Border="2"
Response.Write(adrot.GetAdvertisement("ads.txt"))
%>

Clickable 属性

规定广告本身是否是超级链接。

<%
set adrot=Server.CreateObject("MSWC.AdRotator")
adrot.Clickable=false
Response.Write(adrot.GetAdvertisement("ads.txt"))
%>

TargetFrame 属性

显示广告的框架名称。

<%
set adrot=Server.CreateObject("MSWC.AdRotator")
adrot.TargetFrame="target='_blank'"
Response.Write(adrot.GetAdvertisement("ads.txt"))
%>

AdRotator 组件的方法

GetAdvertisement 方法

返回在页面中显示广告的 HTML。

<%
set adrot=Server.CreateObject("MSWC.AdRotator")
Response.Write(adrot.GetAdvertisement("ads.txt"))
%>
  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP AppendToLog 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP AppendToLog 方法

返回 response 对象参考手册

AppendToLog 方法向服务器日志文件的末端添加字符串。您可在脚本文件中多次调用此方法。当它每次被调用，就会向日志追加指定的字符串。

语法

response.AppendToLog string
参数 | 描述
string | 必需的。向日志文件追加的文本。 (不能包含任何逗号字符)

实例

<%Response.AppendToLog "My log message"%>

返回 response 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Application_OnStart 和 Application_OnEnd 事件

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Application_OnStart 和 Application_OnEnd 事件

返回 Application 对象参考手册

定义和用法

Application_OnStart 事件

Application_OnStart 事件发生在第一个新的会话创建之前 (当 Application 对象第一次被引用时)。

此事件放置在 Global.asa 文件中。

注释：在 Application_OnStart 事件脚本中引用 Session、Request 或者 Response 对象会引发错误。

Application_OnEnd 事件

Application_OnEnd 事件发生在应用程序结束时 (当 web 服务器停止运行时)。

此事件放置在 Global.asa 文件中。

注释：MapPath 方法无法用于 Application_OnEnd 代码中。

语法

<script language="vbscript" runat="server">

Sub Application_OnStart
. . .
End Sub

Sub Application_OnEnd
. . .
End Sub

</script>

实例

Global.asa:

<script language="vbscript" runat="server">

Sub Application_OnEnd()
Application("totvisitors")=Application("visitors")
End Sub

Sub Application_OnStart
Application("visitors")=0
End Sub

Sub Session_OnStart
Application.Lock
Application("visitors")=Application("visitors")+1
Application.UnLock
End Sub

Sub Session_OnEnd
Application.Lock
Application("visitors")=Application("visitors")-1
Application.UnLock
End Sub

</script>

在 ASP 文件中显示当前访问者的数目：

<html>
<head>
</head>
<body>
<p>
There are <%response.write(Application("visitors"))%>
online now!
</p>
</body>
</html>

返回 Application 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Application 对象

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Application 对象

  • Previous Page
  • Next Page

在一起协同工作以完成某项任务的一组 ASP 文件称作应用程序（application）。ASP 中的 Application 对象用于将这些文件捆绑在一起。

Application 对象

web 上的一个应用程序可以是一组 ASP 文件。这些 ASP 文件一起协同工作来完成某项任务。ASP 中的 Application 对象用来把这些文件捆绑在一起。

Application 对象用于存储和访问来自任何页面的变量，类似于 session 对象。不同之处在于，所有的用户分享一个 Application 对象，而 session 对象和用户的关系是一一对应的。

Application 对象握有会被应用程序中的许多页面使用的信息（比如数据库连接信息）。这意味着可以从任何的页面访问这些信息。同时也意味着你可在一个地点改变这些信息，然后这些改变会自动反映在所有的页面上。

存储和取回 Application 变量

Application 变量可被应用程序中的任何页面访问和改变。

可以像这样在 "Global.asa" 中创建 Application 变量：

<script language="vbscript" runat="server">

Sub Application_OnStart
application("vartime")=""
application("users")=1
End Sub

</script>

在上面的例子中，我们创建了两个 Application 变量："vartime" 和 "users"。

可以像这样访问 Application 变量的值：

There are
<%
Response.Write(Application("users"))
%>
active connections.

遍历 Contents 集合

Contents 集合包含着所有的 application 变量。我们可以通过对 contents 集合进行遍历，来查看其中存储的变量：

<%
dim i
For Each i in Application.Contents
  Response.Write(i & "<br />")
Next
%>

如果你不清楚 contents 集中的项目数量，可使用 count 属性：

<%
dim i
dim j
j=Application.Contents.Count
For i=1 to j
  Response.Write(Application.Contents(i) & "<br />")
Next
%>

遍历 StaticObjects 集合

可通过循环 StaticObjects 集合，来查看所有存储于 Application 对象中的对象的值：

<%
dim i
For Each i in Application.StaticObjects
  Response.Write(i & "<br />")
Next
%>

锁定和解锁

我们可以使用 "Lock" 方法来锁定应用程序。当应用程序锁定后，用户们就无法改变 Application 变量了（除了正在访问 Application 变量的用户）。我们也可使用 "Unlock" 方法来对应用程序进行解锁。这个方法会移除对 Application 变量的锁定：

<%
Application.Lock
  'do some application object operations
Application.Unlock
%>
  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP Application 对象

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Application 对象

  • Previous Page
  • Next Page

在一起协同工作以完成某项任务的一组 ASP 文件称为一个应用程序。而 ASP 中的 Application 对象的作用是把这些文件捆绑在一起。

Application 对象

Web 上的一个应用程序可以是一组 ASP 文件。这些 ASP 在一起协同工作来完成一项任务。而 ASP 中的 Application 对象的作用是把这些文件捆绑在一起。

Application 对象用于存储和访问来自任意页面的变量，类似 Session 对象。不同之处在于所有的用户分享一个 Application 对象，而 session 对象和用户的关系是一一对应的。

Application 对象掌握的信息会被应用程序中的很多页面使用（比如数据库连接信息）。这就意味我们可以从任意页面访问这些信息。也意味着你可以在在一个页面上改变这些信息，随后这些改变会自动地反映到所有的页面中。

Application 对象的集合、方法和事件的描述如下：

集合

集合 | 描述
Contents | 包含所有通过脚本命令追加到应用程序中的项目。
StaticObjects | 包含所有使用 HTML 的 <object> 标签追加到应用程序中的对象。

方法

方法 | 描述
Contents.Remove | 从 Contents 集合中删除一个项目。
Contents.RemoveAll() | 从 Contents 集合中删除所有的项目。
Lock | 防止其余的用户修改 Application 对象中的变量。
Unlock | 使其他的用户可以修改 Application 对象中的变量（在被 Lock 方法锁定之后）。

事件

事件 | 描述
Application_OnEnd | 当所有用户的 session 都结束，并且应用程序结束时，此事件发生。
Application_OnStart | 在首个新的 session 被创建之前（这时 Application 对象被首次引用），此事件会发生。
  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP ASPError 对象

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP ASPError 对象

  • Previous Page
  • Next Page

ASPError 对象用于显示在 ASP 文件的脚本中发生的任何错误的详细信息。

ASP ASPError 对象

ASP 3.0 提供这个对象，且在 IIS5 及更高版本中可用。

ASPError 对象用于显示在 ASP 文件的脚本中发生的任何错误的详细信息。当 Server.GetLastError 被调用时，ASPError 对象就会被创建，因此只能通过使用 Server.GetLastError 方法来访问错误信息。

ASPError 对象的属性描述如下（所有属性都是可读的）：

注释：下面的属性只能 Server.GetLastError() 方法来访问。

属性

属性 | 描述
ASPCode | 返回由 IIS 生成的错误代码。
ASPDescription | 返回有关错误的详细信息。（假如错误和 ASP 相关。）
Category | 返回错误来源。(是由 ASP、脚本语言还是对象引起的？）
Column | 返回在出错文件中的列位置。
Description | 返回关于错误的简短描述。
File | 返回出错 ASP 文件的文件名。
Line | 返回错误所在的行数。
Number | 返回关于错误的标准 COM 错误代码。
Source | 返回错误所在行的实际的源代码
  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP ASPError 对象的属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP ASPError 对象的属性

返回 ASP ASPError 对象参考手册

ASPCode

ASPCode 属性返回由 IIS 生成的错误代码。

ASPDescription

ASPDescription 属性返回错误的详细描述。

Category

Category 属性返回错误源（错误是由 IIS 、脚本语言还是组件产生的？）

Column

Column 属性返回产生错误的 ASP 文件中的列位置。

Description

Description 属性返回关于错误的简要描述。

File

File 属性返回产生错误的 ASP 文件的名称。

Line

Line 属性返回产生错误的 ASP 文件中的行位置。

Number

Number 属性返回错误的标准 COM 错误代码。

Source

Source 属性返回错误发生行的实际源代码。

语法

ASPError.ASPCode()
ASPError.ASPDescription()
ASPError.Category()
ASPError.Column()
ASPError.Description()
ASPError.File()
ASPError.Line()
ASPError.Number()
ASPError.Source()

实例

<%
dim objErr
set objErr=Server.GetLastError()

response.write("ASPCode=" & objErr.ASPCode)
response.write("<br />")
response.write("ASPDescription=" & objErr.ASPDescription)
response.write("<br />")
response.write("Category=" & objErr.Category)
response.write("<br />")
response.write("Column=" & objErr.Column)
response.write("<br />")
response.write("Description=" & objErr.Description)
response.write("<br />")
response.write("File=" & objErr.File)
response.write("<br />")
response.write("Line=" & objErr.Line)
response.write("<br />")
response.write("Number=" & objErr.Number)
response.write("<br />")
response.write("Source=" & objErr.Source)
%>
返回 ASP ASPError 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP AtEndOfLine 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP AtEndOfLine 属性

返回 Textstream 对象参考手册

定义和用法

AtEndOfLine 属性返回一个布尔值。True 指示文件指针紧靠行末标记之前，否则返回 False 。

Note:此属性仅工作于以只读方式打开的 TextStream 对象。

语法：

TextStreamObject.AtEndOfLine

实例

<%
dim fs,f,t,x
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.CreateTextFile("c:\test.txt")
f.write("Hello World!")
f.close

set t=fs.OpenTextFile("c:\test.txt",1,false)
do while t.AtEndOfLine<>true
  x=t.Read(1)
loop
t.close
Response.Write("The last character is: " & x)
%>

输出：

The last character of the first line in the text file is: !

返回 Textstream 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP AtEndOfStream 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP AtEndOfStream 属性

返回 Textstream 对象参考手册

定义和用法

如果文件指针位于 TextStream 文件的末尾，AtEndOfStream 属性返回 True ，否则返回 False 。

注释：此属性仅工作于以只读方式打开的 TextStream 对象。

语法：

TextStreamObject.AtEndOfStream

实例

<%
dim fs,f,t,x
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.CreateTextFile("c:\test.txt")
f.write("Hello World!")
f.close

set t=fs.OpenTextFile("c:\test.txt",1,false)
do while t.AtEndOfStream<>true
  x=t.Read(1)
loop
t.close
Response.Write("The last character is: " & x)
%>

输出：

The last character in the text file is: !

返回 Textstream 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Attributes 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Attributes 属性

返回 File 对象参考手册

定义和用法

Attributes 属性用于设置或返回指定文件或文件夹的属性。

语法：

FileObject.Attributes[=newattributes]
FolderObject.Attributes[=newattributes]
参数 描述
newattributes

可选的。规定文件或文件夹的属性值。

可采用下列值之一或者下列值的组合：

  • 0 = 普通文件。没有设置任何属性。
  • 1 = 只读文件。可读写。
  • 2 = 隐藏文件。可读写。
  • 4 = 系统文件。可读写。
  • 16 = 文件夹或目录。只读。
  • 32 = 上次备份后已更改的文件。可读写。
  • 1024 = 链接或快捷方式。只读。
  • 2048 = 压缩文件。只读。

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:\test.txt")
Response.Write("The attributes of the file are: ")
Response.Write(f.Attributes)
set f=nothing
set fs=nothing
%>

输出：

The attributes of the file are: 32

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\test")
Response.Write("The attributes of the folder are: ")
Response.Write(fo.Attributes)
set fo=nothing
set fs=nothing
%>

输出：

The attributes of the folder are: 16

返回 File 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Attributes 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Attributes 属性

返回 Folder 对象参考手册

定义和用法

Attributes 属性可用来设置或返回指定的文件或文件夹的属性。

语法：

FileObject.Attributes[=newattributes]
FolderObject.Attributes[=newattributes]
参数 描述
newattributes

可选的。规定文件或文件夹的属性值。

才采用下列的值之一或下列值的组合：

  • 0 = 常规文件
  • 1 = 只读文件
  • 2 = 隐藏文件
  • 4 = 系统文件
  • 16 = 文件夹或目录
  • 32 = 自从上次备份,文件已经改变
  • 1024 = 链接或快捷方式
  • 2048 = 压缩文件

实例

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:\test.txt")
Response.Write("The attributes of the file are: ")
Response.Write(f.Attributes)
set f=nothing
set fs=nothing
%>

输出：

The attributes of the file are: 32

返回 Folder 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP AvailableSpace 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP AvailableSpace 属性

返回 Drive 对象参考手册

定义和用法

AvailableSpace 属性返回在指定的驱动器或网络共享上对于用户的可用空间量。

注释：返回的值通常等于由 FreeSpace 属性返回的值。对于支持限额的计算机系统来说，这两个属性返回的值有所差异。

语法：

DriveObject.AvailableSpace

实例

<%
Dim fs,d
Set fs=Server.CreateObject("Scripting.FileSystemObject")
Set d=fs.GetDrive("c:")
Response.Write("Drive " & d)
Response.Write(" Available space in bytes: " & d.AvailableSpace)
set d=nothing
set fs=nothing
%>

输出：

Drive c: Available space in bytes: 668865153

返回 Drive 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP AvailableSpace 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP AvailableSpace 属性

返回 Drive 对象参考手册

定义和用法

DriveLetter 属性返回标示本地驱动器或网络共享的大写字母（驱动器号）。

注释：如果指定的驱动器没有与驱动器号相关联（例如，一个网络共享未映射驱动器号），则 DriveLetter 属性返回零长度字符串 ("")。

语法：

DriveObject.DriveLetter

实例

<%
dim fs,d
set fs=Server.CreateObject("Scripting.FileSystemObject")
set d=fs.GetDrive("d:")
Response.Write("The drive letter is: " & d.driveletter)
set d=nothing
set fs=nothing
%>

输出：

The drive letter is: D

返回 Drive 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP BinaryRead 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP BinaryRead 方法

返回 Request 对象参考手册

BinaryRead 方法用于获取作为 POST 请求的部分从客户机发送到服务器的数据。

注释：请在调用 BinaryRead 之后调用 Request.Form ，否则会引起错误。

语法

Request.BinaryRead(count)
参数 | 描述
count | 必需。规定要从客户机读取多少字节。

实例

下面的例子使用 BinaryRead 方法把一个请求的内容放入了一个安全的数组：

<%
dim a,b
a=Request.TotalBytes
b=Request.BinaryRead(a)
%>

返回 Request 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP BinaryWrite 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP BinaryWrite 方法

返回 response 对象参考手册

BinaryWrite 方法在不进行字符转换的情况下直接向输出写数据。

注释：此方法可用于从数据库向浏览器向属性数据 (BLOB) 。

语法

response.BinaryWrite data
参数 | 描述
data | 必需。被发送的二进制信息。

实例

例子 1

如果您有一个可生成字节数组的对象，可使用 BinaryWrite 向应用程序发送字节：

<%
Set objBinaryGen=Server.CreateObject("MyComponents.BinaryGenerator")
pic=objBinaryGen.MakePicture
response.BinaryWrite pic
%>

返回 response 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Browser Capabilities 组件

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Browser Capabilities 组件

  • Previous Page
  • Next Page

实例

Browser Capabilities 组件
本例演示如何测定每一个访问网站的浏览器的类型、性能以及版本号。

ASP Browser Capabilities 组件

ASP Browser Capabilities 组件会创建一个 BrowserType 对象，这个对象可测定访问者浏览器的类型、性能以及版本号。

当浏览器连接到服务器时，就会向服务器发送一个 HTTP User Agent 报头。这个报头包含着有关浏览器的信息（比如浏览器类型和版本号）。BrowserType 对象会把报头中的信息与服务器上名为 "Browscap.ini" 的文件中的信息作比较。

如果标题中被发送的浏览器类型和版本号和 "Browsercap.ini" 文件中信息可以匹配，那么我们就可以使用 BrowserType 对象列出这个匹配的浏览器的相关属性。如果上述情况不匹配，这个对象会把每个属性设置为 "UNKNOWN"。

语法

<%
Set MyBrow=Server.CreateObject("MSWC.BrowserType")
%>

下面的例子对在 ASP 文件中创建一个 BrowserType 对象，并显示一个展示当前浏览器性能的表格：

<html>
<body>

<%
Set MyBrow=Server.CreateObject("MSWC.BrowserType")
%>

<table border="1" width="100%">
<tr>
<th>Client OS</th>
<th><%=MyBrow.platform%></th>
</tr><tr>
<td >Web Browser</td>
<td ><%=MyBrow.browser%></td>
</tr><tr>
<td>Browser version</td>
<td><%=MyBrow.version%></td>
</tr><tr>
<td>Frame support?</td>
<td><%=MyBrow.frames%></td>
</tr><tr>
<td>Table support?</td>
<td><%=MyBrow.tables%></td>
</tr><tr>
<td>Sound support?</td>
<td><%=MyBrow.backgroundsounds%></td>
</tr><tr>
<td>Cookies support?</td>
<td><%=MyBrow.cookies%></td>
</tr><tr>
<td>VBScript support?</td>
<td><%=MyBrow.vbscript%></td>
</tr><tr>
<td>JavaScript support?</td>
<td><%=MyBrow.javascript%></td>
</tr>
</table>

</body>
</html>

输出：

Client OS | WinNT
Web Browser | IE
Browser version | 5.0
Frame support? | True
Table support? | True
Sound support? | True
Cookies support? | True
VBScript support? | True
JavaScript support? | True

Browscap.ini文件

"Browsercap.ini" 文件用于声明属性，并设置各浏览器的默认值。

本节内容不是关于如何 Browscap.ini 文件的教程，我们只提供一些关于 "Browsercap.ini" 的基础知识和概念。

"Browsercap.ini" 文件可包含下面的信息：

[;comments]
[HTTPUserAgentHeader]
[parent=browserDefinition]
[property1=value1]
[propertyN=valueN]
[Default Browser Capability Settings]
[defaultProperty1=defaultValue1]
[defaultPropertyN=defaultValueN]
参数 | 描述
comments | 可选项。任何起始于分号的代码行都被 BrowserType 对象忽略
HTTPUserAgentHeader | 可选项。规定与在 propertyN 中设定的 browser-property 值声明相关的 HTTP User Agent 报头。允许使用通配符。
browserDefinition | 可选项。规定作为父浏览器使用的某个浏览器的 HTTP User Agent header-string。当前浏览器的定义会继承在父浏览器的定义中所有声明过的属性值。
propertyN 可选项。规定浏览器的属性。下面的表格列出了某些可能的属性：
  • ActiveXControls - 是否支持ActiveX控件?
  • Backgroundsounds - 是否支持背景声音?
  • Cdf - 是否支持针对网络广播（Webcasting）的频道定义格式（Channel Definition Format）?
  • Tables - 是否支持表格?
  • Cookies - 是否支持cookies?
  • Frames - 是否支持框架?
  • Javaapplets - 是否支持Java applets?
  • Javascript - 是否支持JScript?
  • Vbscript - 是否支持VBScript?
  • Browser - 定义浏览器的名称
  • Beta - 浏览器是否为beta软件?
  • Platform - 规定浏览器运行的平台
  • Version - 规定浏览器的版本号。
valueN | 可选项。规定 propertyN 的值。可为字符串、整数（前缀为#）或者逻辑值。
defaultPropertyN | 可选项。规定浏览器属性的名称，假如已定义的 HTTPUserAgentHeader 值中没有值能与浏览器发送的 HTTP 用户代理报头相匹配，则为这个属性分配一个默认的值。
defaultValueN | Optional. 规定 defaultPropertyN 的值。可为字符串、整数（前缀为 #）或者逻辑值。

"Browsercap.ini"文件会类似这样：

;IE 5.0
[IE 5.0]
browser=IE
Version=5.0
majorver=#5
minorver=#0
frames=TRUE
tables=TRUE
cookies=TRUE
backgroundsounds=TRUE
vbscript=TRUE
javascript=TRUE
javaapplets=TRUE
ActiveXControls=TRUE
beta=False;DEFAULT BROWSER
[*]
browser=Default
frames=FALSE
tables=TRUE
cookies=FALSE
backgroundsounds=FALSE
vbscript=FALSE
javascript=FALSE
  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP Buffer 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Buffer 属性

返回 response 对象参考手册

Buffer 属性可规定是否对输出进行缓冲。通常情况下，ASP 脚本在服务器端执行，每句的执行结果都会发送到客户端的浏览器上显示出来。当输出设置缓存时，服务器会阻止向浏览器的响应，直到所有的服务器脚本均被处理，或者直到脚本调用了 Flush 或 End 方法。

注释：如果要设置此属性，它应当位于 .asp 文件中的 <html> 标签之前。

语法：

response.Buffer[=flag]
参数 | 描述
flag | 布尔值，规定是否缓冲页面输出。 False 指示不缓存，服务器会一边处理一边发送输出。IIS version 4.0 默认为 False，而 IIS version 5.0 及更高的版本默认为 true。 True 指示缓冲。服务器不会发送输出，直到页面上的所有脚本被处理，或者直到 Flush 或 End 方法被调用。

实例

例子 1

在这个例子中，在循环结束前不会被浏览器发送输出。如果 buffer 被设置为 False ，会每循环一次就向浏览器输出一行。

<%response.Buffer=true%>
<html>
<body>
<%
for i=1 to 100
  response.write(i & "<br />")
next
%>
</body>
</html>

例子 2

<%response.Buffer=true%>
<html>
<body>
<p>I write some text, but I will control when
the text will be sent to the browser.</p>
<p>The text is not sent yet. I hold it back!</p>
<p>OK, let it go!</p>
<%response.Flush%>
</body>
</html>

例子 3

<%response.Buffer=true%>
<html>
<body>
<p>This is some text I want to send to the user.</p>
<p>No, I changed my mind. I want to clear the text.</p>
<%response.Clear%>
</body>
</html>

返回 response 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP BuildPath 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP BuildPath 方法

返回 Filesystem 对象参考手册

定义和用法

BuildPath 方法向已有的路径添加名称。

语法：

[newpath=]FileSystemObject.BuildPath(path,name)
参数 | 描述
path | 必需的。要追加名称的路径。
name | 必需的。追加到路径的名称。

实例

<%
dim fs,path
set fs=Server.CreateObject("Scripting.FileSystemObject")
path=fs.BuildPath("c:\mydocuments","test")
response.write(path)
set fs=nothing
%>

输出：

c:\mydocuments\test

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP CacheControl 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP CacheControl 属性

返回 response 对象参考手册

CacheControl 属性设置是否可缓存由 ASP 生成的输出。默认地，代理服务器不会保持缓存副本。

语法：

response.CacheControl[=control_header]
参数 | 描述
control_header | 缓存的 control header ，可被设置为 "Public" 或 "Private"。 Private 是默认的，仅有私人缓存可以缓存此页。如果为此设置，代理服务器就不会缓存页面。 Public 指示公共缓存。如果为此设置，代理服务器会缓存页面。

实例

<%response.CacheControl="Public"%>

或者：

<%response.CacheControl="Private"%>

返回 response 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Charset 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Charset 属性

返回 response 对象参考手册

Charset 属性向 Response 对象中 content-type 头部追加字符集名称。

注释：此属性可接受任何字符串，不论是否为合法的字符集名称。

语法：

response.Charset(charsetname)
参数 | 描述
charsetname | 为页面规定字符集的字符串。

实例

如果 ASP 页面没有设置 Charset 属性，那么 content-type 头部会是这样的：

content-type:text/html

如果我们使用了 Charset 属性：

<%response.Charset="ISO-8859-1"%>

content-type 头部会是这样的：

content-type:text/html; charset=ISO-8859-1

返回 response 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Clear 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Clear 方法

返回 response 对象参考手册

Clear 方法清空任何已缓冲的 HTML 输出。

注释：此方法无法清除响应的头部，只能清空响应的正文。

注释：假如 response.Buffer 为 false，那么此方法会引起一个 run-time 错误。

语法

response.Clear

实例

<%
response.Buffer=true
%>
<html>
<body>
<p>This is some text I want to send to the user.</p>
<p>No, I changed my mind. I want to clear the text.</p>
<%
response.Clear
%>
</body>
</html>

输出：

(nothing)

返回 response 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Close 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Close 方法

返回 Textstream 对象参考手册

定义和用法

Close 方法关闭一个打开的 TextStream 文件。

语法：

TextStreamObject.Close

实例

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.CreateTextFile("c:\test.txt",true)
f.WriteLine("Hello World!")
f.Close
set f=nothing
set fs=nothing
%>

返回 Textstream 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP CodePage 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP CodePage 属性

返回 Session 对象参考手册

定义和用法

CodePage 属性规定在显示动态内容时所使用的字符集。

例子：

  • 1252 - 美国英语和大多数欧洲语言
  • 932 - 日本汉字

语法

Session.CodePage(=Codepage)
参数 | 描述
codepage | 为运行脚本引擎的系统定义代码页面（字符集）。/td>

实例

<%
Response.Write(Session.CodePage)
%>

输出：

936

返回 Session 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Column 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Column 属性

返回 Textstream 对象参考手册

定义和用法

Column 属性返回输入流中当前字符位置的列号。

注释：此属性在新行字符 (new line character ) 被写入之后为 1 （在其他字符被写入前）。

语法：

TextStreamObject.AtEndOfStream

实例

<%
dim fs,f,t,x,y
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.CreateTextFile("c:\test.txt")
f.write("Hello World!")
f.close

set t=fs.OpenTextFile("c:\test.txt",1,false)
do while t.AtEndOfStream<>true
  x=t.Read(1)
  y=t.Column-1
loop
t.close
Response.Write("The last character in the text file is: " & x)
Response.Write("<br /> at character position: " & y)
%>

输出：

The last character in the text file is: !
at character position: 12

返回 Textstream 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP CompareMode 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP CompareMode 属性

返回 Dictionary 对象参考手册

定义和用法

CompareMode 属性设置或返回在 Dictionary 对象中的比较键的比较模式。

语法：

DictionaryObject.CompareMode[=compare]
参数 描述
compare

可选的。规定比较模式。

可采用下列的值：

  • 0 = vbBinaryCompare - 二进制比较
  • 1 = vbTextCompare - 文本比较
  • 2 = vbDatabaseCompare - 数据库比较

实例

<%
dim d
set d=Server.CreateObject("Scripting.Dictionary")
d.CompareMode=1
d.Add "c","China"
d.Add "i","Italy"

'下面的 add 方法会失败

d.Add "I","Ireland" '字母 i 已经存在
%>

返回 Dictionary 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Content Linking 组件

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Content Linking 组件

  • Previous Page
  • Next Page

实例

Content Linking 组件
本例会构建一个内容列表。
Content Linking 组件 2
本例使用 Content Linking 组件在一个文本文件所列的页面间进行导航。

ASP Content Linking 组件

ASP Content Linking 组件用于创建快捷便利的导航系统。

Content Linking 组件会返回一个 Nextlink 对象，这个对象用于容纳需要导航网页的一个列表。

语法

<%
Set nl=Server.CreateObject( "MSWC.NextLink" )
%>

首先，我们会创建文本文件 - "links.txt"。此文件包含需要导航的页面的相关信息。页面的排列顺序应该与它们的显示顺序相同，并包含对每个文件的描述（使用制表符来分隔文件名和描述信息）。

注释：如果你希望向列表添加文件信息，或者改变在列表中的页面顺序，那么你需要做的所有事情仅仅是修改这个文本文件而已！然后导航系统会自动地更新！

"links.txt":

asp_intro.asp ASP 简介
asp_syntax.asp ASP 语法
asp_variables.asp ASP 变量
asp_procedures.asp ASP 程序

请在上面列出的页面中放置这行代码：<!-- #include file="nlcode.inc"-->。这行代码会在 "links.txt" 中列出每个页面上引用下面这段代码，这样导航就可以工作了。

"nlcode.inc":

<%
'Use the Content Linking Component
'to navigate between the pages listed
'in links.txt

dim nl
Set nl=Server.CreateObject("MSWC.NextLink")
if (nl.GetListIndex("links.txt")>1) then
  Response.Write("<a href='" & nl.GetPreviousURL("links.txt"))
  Response.Write("'>Previous Page</a>")
end if
Response.Write("<a href='" & nl.GetNextURL("links.txt"))
Response.Write("'>Next Page</a>")
%>

ASP Content Linking 组件的方法

GetListCount 方法

返回内容链接列表文件中所列项目的数目：

<%
dim nl,c
Set nl=Server.CreateObject("MSWC.NextLink")
c=nl.GetListCount("links.txt")
Response.Write("There are ")
Response.Write(c)
Response.Write(" items in the list")
%>

输出：

There are 4 items in the list

GetListIndex 方法

返回在内容链接列表文件中当前文件的索引号。第一个条目的索引号是 1。假如当前页面不在列表文件中，则返回 0。

例子

<%
dim nl,c
Set nl=Server.CreateObject("MSWC.NextLink")
c=nl.GetListIndex("links.txt")
Response.Write("Item number ")
Response.Write(c)
%>

输出：

Item number 3

GetNextDescription 方法

返回在内容链接列表文件中所列的下一个条目的文本描述。假如在列表文件中没有找到当前文件，则列表中最后一个页面的文本描述。

例子

<%
dim nl,c
Set nl=Server.CreateObject("MSWC.NextLink")
c=nl.GetNextDescription("links.txt")
Response.Write("Next ")
Response.Write("description is: ")
Response.Write(c)
%>

输出：Next description is: ASP Variables

GetNextURL 方法

返回在内容链接列表文件中所列的下一个条目的 URL。假如在列表文件中没有找到当前文件，则列表中最后一个页面的 URL。

例子

<%
dim nl,c
Set nl=Server.CreateObject("MSWC.NextLink")
c=nl.GetNextURL("links.txt")
Response.Write("Next ")
Response.Write("URL is: ")
Response.Write(c)
%>

输出：Next URL is: asp_variables.asp

GetNthDescription 方法

返在内容链接列表文件中所列的第 N 个页面的描述信息。

例子

<%
dim nl,c
Set nl=Server.CreateObject("MSWC.NextLink")
c=nl.GetNthDescription("links.txt",3)
Response.Write("Third ")
Response.Write("description is: ")
Response.Write(c)
%>

输出：Third description is: ASP Variables

GetNthURL 方法

返在内容链接列表文件中所列的第 N 个页面的 URL。

例子

<%
dim nl,c
Set nl=Server.CreateObject("MSWC.NextLink")
c=nl.GetNthURL("links.txt",3)
Response.Write("Third ")
Response.Write("URL is: ")
Response.Write(c)
%>

输出：Third URL is: asp_variables.asp

GetPreviousDescription 方法

返回在内容链接列表文件中所列前一个条目的文本描述。假如在列表文件中没有找到当前文件，则列表中第一个页面的文本描述。

例子

<%
dim nl,c
Set nl=Server.CreateObject("MSWC.NextLink")
c=nl.GetPreviousDescription("links.txt")
Response.Write("Previous ")
Response.Write("description is: ")
Response.Write(c)
%>

输出：Previous description is: ASP Variables

GetPreviousURL 方法

返回在内容链接列表文件中所列前一个条目的 URL。假如在列表文件中没有找到当前文件，则列表中第一个页面的URL。

例子

<%
dim nl,c
Set nl=Server.CreateObject("MSWC.NextLink")
c=nl.GetPreviousURL("links.txt")
Response.Write("Previous ")
Response.Write("URL is: ")
Response.Write(c)
%>

输出：Previous URL is: asp_variables.asp

  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP Content Rotator

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Content Rotator (ASP 3.0)

  • Previous Page
  • Next Page

实例

Content Rotator 组件
每当用户访问或者刷新页面时，该组件就会显示不同的 HTML 内容字符串。

ASP Content Rotator 组件

ASP Content Rotator 组件会创建一个 ContentRotator 对象，每当用户访问或者刷新某个页面时，该对象就会显示一段不同的 HTML 内容字符串。一个名为内容目录文件（Content Schedule File）的文本文件包含着有关内容字符串的信息。

内容字符串可包含 HTML 标签，这样你就可以显示 HTML 可呈现的任何内容：文本、图像、颜色或者超级链接。

语法

<%
Set cr=Server.CreateObject( "MSWC.ContentRotator" )
%>

每当某用户查看网页时，下面这个例子就会显示不同的内容。首先在站点根目录的子文件夹 text 中创建一个名为 "textads.txt" 的文件。

"textads.txt":

%% #1
This is a great day!!

%% #2
<h1>Smile</h1>

%% #3
<img src="smiley.gif">

%% #4
Here's a <a href="http://www.w3school.com.cn">link</a>

注意：在每个内容字符串起始位置的#号码。这个号码是一个可选的参数，用来 HTML 内容字符串的相对权重。在本例中，Content Rotator 有十分之一的几率显示第一个内容字符串，有十分之二的几率显示第二个内容字符串，有十分之三的几率显示第三个字符串，而第四个字符串为十分之四的几率。

然后，创建一个 ASP 文件，并插入下面的代码：

<html>
<body>

<%
set cr=server.createobject("MSWC.ContentRotator")
response.write(cr.ChooseContent("text/textads.txt"))
%>

</body>
</html>

ASP Content Rotator 组件的方法

方法 描述 实例
ChooseContent 获取并显示某个内容字符串
<%
dim cr
Set cr=Server.CreateObject("MSWC.ContentRotator")
response.write(cr.ChooseContent("text/textads.txt"))
%>

输出：
GetAllContent 取回并显示文本文件中所有的内容字符串
<%
dim cr
Set cr=Server.CreateObject("MSWC.ContentRotator")
response.write(cr.GetAllContent("text/textads.txt"))
%>

输出：
  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP Contents 集合

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Contents 集合

返回 Application 对象参考手册

Contents 集合包含着通过脚本命令添加到 application/session 的所有项目。

提示：要从 Contents 集合中删除项目，请使用 Remove 和 RemoveAll 方法。

语法

Application.Contents(Key)

Session.Contents(Key)
参数 | 描述
key | 必需。要取回的项目的名称。

针对 Application 对象的实例

例子 1

请注意，name 和 objtest 都会被追加到 Contents 集合中：

<%
Application("name")="W3School"
Set Application("objtest")=Server.CreateObject("ADODB.Connection")
%>

例子 2

遍历 Contents 集合：

<%
for each x in Application.Contents
  Response.Write(x & "=" & Application.Contents(x) & "<br />")
next
%>

或者：

<%
For i=1 to Application.Contents.Count
  Response.Write(i & "=" & Application.Contents(i) & "<br />")
Next
%>

例子 3

<%
Application("date")="2001/05/05"
Application("author")="W3School"

for each x in Application.Contents
  Response.Write(x & "=" & Application.Contents(x) & "<br />")
next
%>

输出：

date=2001/05/05
author=W3School

针对 Session 对象的实例

例子 1

请注意，name 和 objtest 都会被追加到 Contents 集合中：

<%
Session("name")="Hege"
Set Session("objtest")=Server.CreateObject("ADODB.Connection")
%>

例子 2

遍历 Contents 集合：

<%
for each x in Session.Contents
  Response.Write(x & "=" & Session.Contents(x) & "<br />")
next
%>

或者：

<%
For i=1 to Session.Contents.Count
  Response.Write(i & "=" & Session.Contents(i) & "<br />")
Next
%>

例子 3

<%
Session("name")="Hege"
Session("date")="2001/05/05"

for each x in Session.Contents
  Response.Write(x & "=" & Session.Contents(x) & "<br />")
next
%>

输出：

name=Hege
date=2001/05/05

返回 Application 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Contents.Remove 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Contents.Remove 方法

返回 Application 对象参考手册

Contents.Remove 方法从 Contents 集合中删除一个项目。

语法

Application.Contents.Remove(name|index)

Session.Contents.Remove(name|index)
参数 | 描述
name | 要删除的项目的名称。
index | 要删除的项目的索引号。

针对 Application 对象的实例

实例 1

<%
Application("test1")=("First test")
Application("test2")=("Second test")
Application("test3")=("Third test")

Application.Contents.Remove("test2")

for each x in Application.Contents
 Response.Write(x & "=" & Application.Contents(x) & "<br />")
next
%>

输出：

test1=First test
test3=Third test

实例 2

<%
Application("test1")=("First test")
Application("test2")=("Second test")
Application("test3")=("Third test")

Application.Contents.Remove(2)

for each x in Application.Contents
 Response.Write(x & "=" & Application.Contents(x) & "<br />")
next
%>

输出：

test1=First test
test3=Third test

针对 Session 对象的实例：

实例 1

<%
Session("test1")=("First test")
Session("test2")=("Second test")
Session("test3")=("Third test")

Session.Contents.Remove("test2")

for each x in Session.Contents
 Response.Write(x & "=" & Session.Contents(x) & "<br />")
next
%>

输出：

test1=First test
test3=Third test

实例 2

<%
Session("test1")=("First test")
Session("test2")=("Second test")
Session("test3")=("Third test")

Session.Contents.Remove(2)

for each x in Session.Contents
 Response.Write(x & "=" & Session.Contents(x) & "<br />")
next
%>

输出：

test1=First test
test3=Third test

返回 Application 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Contents.RemoveAll 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Contents.RemoveAll 方法

返回 Application 对象参考手册

定义和用法

Contents.RemoveAll 方法可从 Contents 集合删除所有的项目。

语法

Application.Contents.RemoveAll()

Session.Contents.RemoveAll()

针对 Application 对象的例子

<%
Application.Contents.RemoveAll()
%>

针对 Session 对象的例子

<%
Session.Contents.RemoveAll()
%>

返回 Application 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP ContentType 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP ContentType 属性

返回 response 对象参考手册

ContentType 属性为 response 对象设置 HTTP 内容类型。

语法：

response.ContentType[=contenttype]
参数 | 描述
contenttype | 描述内容类型的字符串。 如需完整的内容类型列表，请参阅您的浏览器文档或 HTTP 规范。

实例

如果 ASP 页面没有设置 ContentType 属性，那么默认的 content-type 头部是这样的：

content-type:text/html

其他一些常用的 ContentType 值：

<%response.ContentType="text/HTML"%>
<%response.ContentType="image/GIF"%>
<%response.ContentType="image/JPEG"%>
<%response.ContentType="text/plain"%>
<%response.ContentType="image/JPEG"%>

此例会在浏览器中打开一个 Excel 电子表格（如果用户已经安装了 Excel ）：

<%response.ContentType="application/vnd.ms-excel"%>
<html>
<body>
<table>
<tr>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
</tr>
<tr>
<td>5</td>
<td>6</td>
<td>7</td>
<td>8</td>
</tr>
</table>
</body>
</html>

返回 response 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Cookie

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Cookie

  • Previous Page
  • Next Page

cookie 常用来对用户进行识别。

实例：

Welcome cookie
如何创建欢迎 cookie。

什么是 Cookie?

cookie 常用来对用户进行识别。cookie 是一种服务器留在用户电脑中的小文件。每当同一台电脑通过浏览器请求页面时，这台电脑就会发送 cookie。通过 ASP，您能够创建并取回 cookie 的值。

如何创建 cookie?

"Response.Cookies" 命令用于创建 cookie。

注意：Response.Cookies 命令必须位于 <html> 标签之前。

在下面的例子中，我们会创建一个名为 "firstname" 的 cookie，并向其赋值 "Alex"：

<%
Response.Cookies("firstname")="Alex"
%>

向 cookie 分配属性也是可以的，比如设置 cookie 的失效时间：

<%
Response.Cookies("firstname")="Alex"
Response.Cookies("firstname").Expires=#May 10,2002#
%>

如何取回 cookie 的值？

"Request.Cookies" 命令用于取回 cookie 的值。

在下面的例子中，我们取回了名为 "firstname" 的 cookie 的值，并把值显示到了页面上：

<%
fname=Request.Cookies("firstname")
response.write("Firstname=" & fname)
%>

输出：

Firstname=Alex

带有键的 cookie

如果一个 cookie 包含多个值的一个集合，我们就可以说 cookie 拥有键（Keys）。

在下面的例子中，我们会创建一个名为 "user" 的 cookie 集。"user" cookie 拥有包含用户信息的键：

<%
Response.Cookies("user")("firstname")="John"
Response.Cookies("user")("lastname")="Adams"
Response.Cookies("user")("country")="UK"
Response.Cookies("user")("age")="25"
%>

读取所有的 cookie

请阅读下面的代码：

<%
Response.Cookies("firstname")="Alex"
Response.Cookies("user")("firstname")="John"
Response.Cookies("user")("lastname")="Adams"
Response.Cookies("user")("country")="UK"
Response.Cookies("user")("age")="25"
%>

假设您的服务器将所有的这些 cookie 传给了某个用户。

现在，我们需要读取这些 cookie。下面的例子向您展示如何做到这一点（请注意，下面的代码会使用 HasKeys 检查 cookie 是否拥有键）：

<html>
<body>

<%
dim x,y

 for each x in Request.Cookies
  response.write("<p>")
  if Request.Cookies(x).HasKeys then
    for each y in Request.Cookies(x)
      response.write(x & ":" & y & "=" & Request.Cookies(x)(y))
      response.write("<br />")
    next
  else
    Response.Write(x & "=" & Request.Cookies(x) & "<br />")
  end if
  response.write "</p>"
next
%>

</body>
</html>

输出：

firstname=Alex

user:firstname=John
user:lastname=Adams
user:country=UK
user:age=25

如何应对不支持 cookie 的浏览器？

如果您的应用程序需要和不支持 cookie 的浏览器打交道，那么您不得不使用其他的办法在您的应用程序中的页面之间传递信息。这里有两种办法：

1. 向 URL 添加参数

您可以向 URL 添加参数：

<a href="welcome.asp?fname=John&lname=Adams">
Go to Welcome Page
</a>

然后在类似于下面这个 "welcome.asp" 文件中取回这些值：

<%
fname=Request.querystring("fname")
lname=Request.querystring("lname")
response.write("<p>Hello " & fname & " " & lname & "!</p>")
response.write("<p>Welcome to my Web site!</p>")
%>

2. 使用表单

您还可以使用表单。当用户点击提交按钮时，表单会把用户输入的数据提交给 "welcome.asp" ：

<form method="post" action="welcome.asp">
First Name:  <input type="text" name="fname" value="">
Last Name: <input type="text" name="lname" value="">
<input type="submit" value="Submit">
</form>

然后在 "welcome.asp" 文件中取回这些值，就像这样：

<%
fname=Request.form("fname")
lname=Request.form("lname")
response.write("<p>Hello " & fname & " " & lname & "!</p>")
response.write("<p>Welcome to my Web site!</p>")
%>
  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP Cookies 集合

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Cookies 集合

返回 response 对象参考手册

Cookies 集合用于设置或取得 cookie 的值。如果 cookie 不存，就创建它，并赋予它规定的值。

注释：Response.Cookies 命令必须位于 <html> 标签之前。

语法：

Response.Cookies(name)[(key)|.attribute]=value

variablename=Request.Cookies(name)[(key)|.attribute]
参数 | 描述
name | 必需。cookie 的名称。
value | 必需（对于 Response.Cookies 命令）。cookie 的值。
attribute

可选。规定有关 cookie 的信息。可以是下面的参数之一。

  • Domain - 只写；cookie 仅送往到达该域的请求。
  • Expires - 只写；cookie 的失效日期。如果没有规定日期，cookie 会在 session 结束时失效。
  • HasKeys - 只读；规定 cookie 是否拥有 key（这是唯一一个可与 Request.Cookies 命令使用的属性）
  • Path - 只写；如果设置，cookie 仅送往到达此路径的请求。如果没有设置，则使用应用程序的路径。
  • Secure - 只写；指示 cookie 是否安全。
key | 可选。规定在何处赋值的 key。

实例

"Response.Cookies" 命令用于创建 cookie 或者设置 cookie 的值：

<%
Response.Cookies("firstname")="Alex"
%>

在上面的代码中，我们创建了一个名为 "firstname" 的 cookie，并为它赋值 alex 。

也可以为 cookie 设置属性，比如设置 cookie 的失效时间：

<%
Response.Cookies("firstname")="Alex"
Response.Cookies("firstname").Expires=#May 10,2002#
%>

现在，名为 "firstname" 的 cookie 的值是 "Alex"，同时它在用户电脑中的失效日期是 2002 年 5 月 10 日。

"Request.Cookies" 命令用于取回 cookie 的值。

在下面的例子中，我们取回了 cookie "firstname" 的值，并把它显示到页面上：

<%
fname=Request.Cookies("firstname")
response.write("Firstname=" & fname)
%>

输出：

Firstname=Alex

一个 cookie 可以包含一个多值的集合。我们称之为 cookie 拥有 key 。

在下面的例子中，我们要创建一个名为 "user" 的 cookie 集合。"user" cookie 拥有包含有关用户信息的 key 。

<%
Response.Cookies("user")("firstname")="John"
Response.Cookies("user")("lastname")="Adams"
Response.Cookies("user")("country")="UK"
Response.Cookies("user")("age")="25"
%>

下面的代码可读出所有服务器已向用户发送的 cookie 。请注意，我们使用了 HasKeys 属性来判断 cookie 是否拥有 key ：

<html>
<body>

<%
dim x,y

for each x in Request.Cookies
  response.write("<p>")
  if Request.Cookies(x).HasKeys then
    for each y in Request.Cookies(x)
      response.write(x & ":" & y & "=" & Request.Cookies(x)(y))
      response.write("<br /")
    next
  else
    Response.Write(x & "=" & Request.Cookies(x) & "<br />")
  end if
  response.write "</p>"
next
%>

</body>
</html>
%>

输出：

firstname=Alex
user:firstname=John
user:lastname=Adams
user:
country=UK
user:
age=25

返回 response 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Cookies 集合

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Cookies 集合

返回 Request 对象参考手册

Cookies 集合用于设置或取得 cookie 的值。如果 cookie 不存，就创建它，并赋予它规定的值。

注释：Response.Cookies 命令必须位于 <html> 标签之前。

语法：

Response.Cookies(name)[(key)|.attribute]=value

variablename=Request.Cookies(name)[(key)|.attribute]
参数 | 描述
name | 必需。cookie 的名称。
value | 必需（对于 Response.Cookies 命令）。cookie 的值。
attribute

可选。规定有关 cookie 的信息。可以是下面的参数之一。

  • Domain - 只写；cookie 仅送往到达该域的请求。
  • Expires - 只写；cookie 的失效日期。如果没有规定日期，cookie 会在 session 结束时失效。
  • HasKeys - 只读；规定 cookie 是否拥有 key（这是唯一一个可与 Request.Cookies 命令使用的属性）
  • Path - 只写；如果设置，cookie 仅送往到达此路径的请求。如果没有设置，则使用应用程序的路径。
  • Secure - 只写；指示 cookie 是否安全。
key | 可选。规定在何处赋值的 key。

实例

"Response.Cookies" 命令用于创建 cookie 或者设置 cookie 的值：

<%
Response.Cookies("firstname")="Alex"
%>

在上面的代码中，我们创建了一个名为 "firstname" 的 cookie，并为它赋值 alex 。

也可以为 cookie 设置属性，比如设置 cookie 的失效时间：

<%
Response.Cookies("firstname")="Alex"
Response.Cookies("firstname").Expires=#May 10,2002#
%>

现在，名为 "firstname" 的 cookie 的值是 "Alex"，同时它在用户电脑中的失效日期是 2002 年 5 月 10 日。

"Request.Cookies" 命令用于取回 cookie 的值。

在下面的例子中，我们取回了 cookie "firstname" 的值，并把它显示到页面上：

<%
fname=Request.Cookies("firstname")
response.write("Firstname=" & fname)
%>

输出：

Firstname=Alex

一个 cookie 可以包含一个多值的集合。我们称之为 cookie 拥有 key 。

在下面的例子中，我们要创建一个名为 "user" 的 cookie 集合。"user" cookie 拥有包含有关用户信息的 key 。

<%
Response.Cookies("user")("firstname")="John"
Response.Cookies("user")("lastname")="Adams"
Response.Cookies("user")("country")="UK"
Response.Cookies("user")("age")="25"
%>

下面的代码可读出所有服务器已向用户发送的 cookie 。请注意，我们使用了 HasKeys 属性来判断 cookie 是否拥有 key ：

<html>
<body>

<%
dim x,y

for each x in Request.Cookies
  response.write("<p>")
  if Request.Cookies(x).HasKeys then
    for each y in Request.Cookies(x)
      response.write(x & ":" & y & "=" & Request.Cookies(x)(y))
      response.write("<br /")
    next
  else
    Response.Write(x & "=" & Request.Cookies(x) & "<br />")
  end if
  response.write "</p>"
next
%>

</body>
</html>
%>

输出：

firstname=Alex
user:firstname=John
user:lastname=Adams
user:
country=UK
user:
age=25

返回 Request 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Copy 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Copy 方法

返回 File 对象参考手册

定义和用法

Copy 方法可把指定的文件或文件夹从一个位置拷贝到另外一个位置。

注释：对 File 或 Folder 应用 Copy 方法的结果与使用 FileSystemObject.CopyFile 或 FileSystemObject.CopyFolder 执行的操作完全相同。在 FileSystemObject.CopyFile 或 FileSystemObject.CopyFolder 中，使用 object 引用文件或文件夹，并将文件或文件夹作为参数传递给 FileSystemObject.CopyFile 或 FileSystemObject.CopyFolder。然而，应该注意的是 FileSystemObject.CopyFile 或 FileSystemObject.CopyFolder 方法可以复制多个文件或文件夹。

语法：

FileObject.Copy(destination[,overwrite])
FolderObject.Copy(destination[,overwrite])
参数 | 描述
destination | 必需的。复制文件或文件夹的目的地。不允许使用通配符。
overwrite | 可选的。指示是否可覆盖已有的文件或文件夹的布尔值。True 表示文件/文件夹可被覆盖，false 表示文件/文件夹不可以被覆盖。默认是 true 。

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:\test.txt")
f.Copy("c:\new_test.txt",false)
set f=nothing
set fs=nothing
%>

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\test")
fo.Copy("c:\new_test",false)
set fo=nothing
set fs=nothing
%>

返回 File 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Copy 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Copy 方法

返回 Folder 对象参考手册

定义和用法

Copy 方法把文件或文件夹从一个位置拷贝到另一个位置。

语法：

FileObject.Copy(destination[,overwrite])
FolderObject.Copy(destination[,overwrite])
参数 | 描述
destination | 必需的。复制文件或文件夹的目的地。不允许使用通配符。
overwrite | 可选的。指示是否可覆盖已有文件或文件夹的布尔值。True 表示文件或文件夹可被覆盖，false 表示文件或文件不能被覆盖。默认是 true。

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:\test.txt")
f.Copy("d:\new_file.txt",false)
set f=nothing
set fs=nothing
%>

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\test")
fo.Copy("d:\new_file",false)
set fo=nothing
set fs=nothing
%>

返回 Folder 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP CopyFile 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP CopyFile 方法

返回 Filesystem 对象参考手册

定义和用法

CopyFile 方法从一个位置向另一个位置拷贝一个或多个文件。

语法：

FileSystemObject.CopyFile source,destination[,overwrite]
参数 | 描述
source | 必需的。要拷贝的文件（可使用通配符）。
destination | 必需的。拷贝文件的目的地（不能使用通配符）。
overwrite | 可选的。规定是否可覆盖已有的文件。True 允许覆盖已有文件，False 可防止已有文件被覆盖。默认为 True 。

实例

<%
dim fs
set fs=Server.CreateObject("Scripting.FileSystemObject")
fs.CopyFile "c:\mydocuments\web\*.htm","c:\webpages\"
set fs=nothing
%>

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP CopyFolder 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP CopyFolder 方法

返回 Filesystem 对象参考手册

定义和用法

CopyFolder 方法从一个位置向另外一个位置复制一个或多个文件夹。

语法：

FileSystemObject.CopyFolder source,destination[,overwrite]
参数 | 描述
source | 可选的。需拷贝的文件夹（可使用通配符）。
destination | 必需的。拷贝文件夹的目的地（不可使用通配符）。
overwrite | 可选的。规定是否可覆盖已有的文件夹。True 允许覆盖已有文件夹，False 可防止已有文件夹被覆盖。默认为 True 。

实例

把 c:\mydocuments\web 中的所有文件夹拷贝到文件夹 c:\webpages 中：

<%
dim fs
set fs=Server.CreateObject("Scripting.FileSystemObject")
fs.CopyFolder "c:\mydocuments\web\*","c:\webpages\"
set fs=nothing
%>

仅把文件夹 test 从 c:\mydocuments\web 拷贝到文件夹 c:\webpages 中：

<%
dim fs
set fs=Server.CreateObject("Scripting.FileSystemObject")
fs.CopyFolder "c:\mydocuments\web\test","c:\webpages\"
set fs=nothing
%>

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Count 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Count 属性

返回 Dictionary 对象参考手册

定义和用法

Count 属性返回在 Dictionary 对象中 key/item 对的数目。

语法：

DictionaryObject.Count

实例

<%
dim d
set d=Server.CreateObject("Scripting.Dictionary")
d.Add "c","China"
d.Add "i","Italy"
d.Add "s","Sweden"
Response.Write("The number of key/item pairs: " & d.Count)
set d=nothing
%>

输出：

The number of key/item pairs: 3

返回 Dictionary 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP CreateFolder 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP CreateFolder 方法

返回 Filesystem 对象参考手册

定义和用法

CreateFolder 方法创建一个新文件夹。

语法：

FileSystemObject.CreateFolder(name)
参数 | 描述
name | 必需的。需创建的文件夹名称。

实例

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.CreateFolder("c:\asp")
set f=nothing
set fs=nothing
%>

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP CreateObject 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP CreateObject 方法

返回 Server 对象参考手册

定义和用法

CreateObject 方法创建对象的实例。

注释：使用此方法创建的对象是有页面作用域的。这就是说，在当前 ASP 页处理完成之后，服务器将自动破坏这些对象。要创建有 session 或 application 作用域的对象，可以在 Global.asa 文件中使用 <object> 标记并设置 session 或 application 的 SCOPE 属性，也可以在 session 或者 application 变量中存储该对象。

语法

Server.CreateObject(progID)
参数 | 描述
progID | 必需。要创建的对象的类型。

实例

例子 1

本例创建服务器组件 MSWC.AdRotator 的一个实例：

<%
Set adrot=Server.CreateObject("MSWC.AdRotator")
%>

例子 2

当会话结束时，存储在 session 变量中的对象就会被破坏。然而，您还可以通过把变量设置为 Nothing 或新的值来破坏对象：

<%
Session("ad")=Nothing
%>

或者：

<%
Session("ad")="a new value"
%>

例子 3

不能创建与内建对象同名的对象实例。例如，下列脚本将返回错误：

<%
Set Application=Server.CreateObject("Application")
%>

返回 Server 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP CreateTextFile 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP CreateTextFile 方法

返回 Filesystem 对象参考手册

定义和用法

CreateTextFile 方法可在当前文件夹中创建新的文本文件，并返回可用于读或写文件的 TextStream 对象。

语法：

FileSystemObject.CreateTextFile(filename[,overwrite[,unicode]])
FolderObject.CreateTextFile(filename[,overwrite[,unicode]])
参数 | 描述
filename | 必需的。需创建文件的名称。
overwrite | 可选的。指示能否覆盖已有文件的布尔值。True 指示可覆盖文件，False 指示不能覆盖文件。默认是 True 。
unicode | 可选的。指示文件是作为 Unicode 还是 ASCII 文件来创建的布尔值。True 指示文件作为 Unicode 文件创建，而 False 指示文件被作为 ASCII 文件创建。默认是 False。

针对 FileSystemObject 对象的实例

<%
dim fs,tfile
set fs=Server.CreateObject("Scripting.FileSystemObject")
set tfile=fs.CreateTextFile("c:\somefile.txt")
tfile.WriteLine("Hello World!")
tfile.close
set tfile=nothing
set fs=nothing
%>

针对 Folder 对象的实例

<%
dim fs,fo,tfile
Set fs=Server.CreateObject("Scripting.FileSystemObject")
Set fo=fs.GetFolder("c:\test")
Set tfile=fo.CreateTextFile("test.txt",false)
tfile.WriteLine("Hello World!")
tfile.Close
set tfile=nothing
set fo=nothing
set fs=nothing
%>

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP CreateTextFile 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP CreateTextFile 方法

返回 Folder 对象参考手册

定义和用法

CreateTextFile 方法在当前文件夹创建一个新的文本文件，并返回供读写此文件的一个 TextStream 对象。

语法：

FileSystemObject.CreateTextFile(filename[,overwrite[,unicode]])
FolderObject.CreateTextFile(filename[,overwrite[,unicode]])
参数 | 描述
filename | 必需的。需要创建的文件的名称。
overwrite | 可选的。指示是否可覆盖已有文件的布尔值。True 表示可覆盖此文件，而 False 表示不可覆盖此文件。默认是 True。
unicode | 可选的。指示以 Unicode 格式还是 ASCII 格式创建文件。True 指示以 Unicode 格式创建文件，False 指示以 ASCII 格式创建文件。默认是 False。

实例

针对 File 对象的例子

<%
dim fs,tfile
set fs=Server.CreateObject("Scripting.FileSystemObject")
set tfile=fs.CreateTextFile("d:\somefile.txt")
tfile.WriteLine("Hello World!")
tfile.close
set tfile=nothing
set fs=nothing
%>

针对 Folder 对象的例子

<%
dim fs,fo,tfile
Set fs=Server.CreateObject("Scripting.FileSystemObject")
Set fo=fs.GetFolder("d:\test")
Set tfile=fo.CreateTextFile("somefile.txt",false)
tfile.WriteLine("Hello World!")
tfile.Close
set tfile=nothing
set fo=nothing
set fs=nothing
%>

返回 Folder 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP DateCreated 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP DateCreated 属性

返回 File 对象参考手册

定义和用法

DateCreated 属性用于返回指定的文件或文件夹的创建日期和时间。

语法：

FileObject.DateCreated
FolderObject.DateCreated

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:\test.txt")
Response.Write("File created: ")
Response.Write(f.DateCreated)
set f=nothing
set fs=nothing
%>

输出：

File created: 8/8/2008 10:01:19 AM

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\test")
Response.Write("Folder created: ")
Response.Write(fo.DateCreated)
set fo=nothing
set fs=nothing
%>

输出：

Folder created: 8/8/2008 10:01:19 AM

返回 File 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP DateCreated 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP DateCreated 属性

返回 Folder 对象参考手册

定义和用法

DateCreated 属性用于返回指定的文件或文件夹被创建的日期和时间。

语法：

FileObject.DateCreated
FolderObject.DateCreated

实例

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:\test.txt")
Response.Write("File created: ")
Response.Write(f.DateCreated)
set f=nothing
set fs=nothing
%>

输出：

File created: 8/8/2008 8:8:00 PM

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\test")
Response.Write("Folder created: ")
Response.Write(fo.DateCreated)
set fo=nothing
set fs=nothing
%>

输出：

Folder created: 8/8/2008 8:8:00 PM

返回 Folder 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP DateLastAccessed 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP DateLastAccessed 属性

返回 File 对象参考手册

定义和用法

DateLastAccessed 属性用于返回指定的文件或文件夹最后被访问的日期和时间。

语法：

FileObject.DateLastAccessed
FolderObject.DateLastAccessed

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:\test.txt")
Response.Write("File last accessed on: ")
Response.Write(f.DateLastAccessed)
set f=nothing
set fs=nothing
%>

输出：

File last accessed on: 8/8/2008 10:21:23 AM

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\test")
Response.Write("Folder last accessed on: ")
Response.Write(fo.DateLastAccessed)
set fo=nothing
set fs=nothing
%>

输出：

Folder last accessed on: 8/8/2008 10:01:19 AM

返回 File 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP DateLastAccessed 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP DateCreated 属性

返回 Folder 对象参考手册

定义和用法

DateLastAccessed 属性用于返回指定的文件或文件夹最后被访问的日期和时间。

语法：

FileObject.DateLastAccessed
FolderObject.DateLastAccessed

实例

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:\test.txt")
Response.Write("File last accessed on: ")
Response.Write(f.DateLastAccessed)
set f=nothing
set fs=nothing
%>

输出：

File last accessed on: 8/8/2008 8:8:00 PM

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\test")
Response.Write("Folder last accessed on: ")
Response.Write(fo.DateLastAccessed)
set fo=nothing
set fs=nothing
%>

输出：

Folder last accessed on: 8/8/2008 8:8:00 PM

返回 Folder 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP DateLastModified 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP DateLastModified 属性

返回 File 对象参考手册

定义和用法

DateLastModified 属性可用于返回指定的文件或文件夹最后被修改的日期和时间。

语法：

FileObject.DateLastModified
FolderObject.DateLastModified

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:\test.txt")
Response.Write("File last modified on: ")
Response.Write(f.DateLastModified)
set f=nothing
set fs=nothing
%>

输出：

File last modified on: 8/8/2008 10:20:19 AM

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\test")
Response.Write("Folder last modified on: ")
Response.Write(fo.DateLastModified)
set fo=nothing
set fs=nothing
%>

输出：

Folder last modified on: 8/8/2008 10:20:19 AM

返回 File 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP DateLastModified 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP DateLastModified 属性

返回 Folder 对象参考手册

定义和用法

DateLastModified 属性用于返回指定的文件或文件夹最后被修改的日期和时间。

语法：

FileObject.DateLastModified
FolderObject.DateLastModified

实例

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:\test.txt")
Response.Write("File last modified on: ")
Response.Write(f.DateLastModified)
set f=nothing
set fs=nothing
%>

输出：

File last modified on: 8/8/2008 8:8:00 PM

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\test")
Response.Write("Folder last modified on: ")
Response.Write(fo.DateLastModified)
set fo=nothing
set fs=nothing
%>

输出：

Folder last modified on: 8/8/2008 8:8:00 PM

返回 Folder 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Delete 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Delete 方法

返回 File 对象参考手册

定义和用法

Delete 方法可删除指定的文件或文件夹。

注释：若指定文件或文件夹不存在，错误发生。有内容的文件夹和无内容的文件夹所使用的Delete方法无异。无论有无内容，指定文件夹皆被删除。对 File 或 Folder 应用 Delete 方法的结果与使用 FileSystemObject.DeleteFile 或 FileSystemObject.DeleteFolder 执行的操作完全相同。

语法：

FileObject.Delete[(force)]
FolderObject.Delete[(force)]
参数 | 描述
force | 可选的。指示是否可删除只读文件或文件夹的布尔值。True 指示只读文件/文件夹可被删除，false 指示文件/文件夹不可被删除。默认是 false。

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:\test.txt")
f.Delete
set f=nothing
set fs=nothing
%>

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\test")
fo.Delete
set fo=nothing
set fs=nothing
%>

返回 File 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Delete 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Delete 方法

返回 Folder 对象参考手册

定义和用法

Delete 方法删除指定的文件或文件夹。

语法：

FileObject.Delete[(force)]
FolderObject.Delete[(force)]
参数 | 描述
force | 可选的。指示只读文件或文件夹是否可被删除的布尔值。True 表示文件/文件夹会被删除，而 false 表示不会被删除。默认是 false。

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("d:\test.txt")
f.Delete
set f=nothing
set fs=nothing
%>

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("d:\test")
fo.Delete
set fo=nothing
set fs=nothing
%>

返回 Folder 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP DeleteFile 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP DeleteFile 方法

返回 Filesystem 对象参考手册

定义和用法

DeleteFile 方法删除一个或多个指定的文件。

注释：假如您试图删除不存在的文件，会引发错误。

语法：

FileSystemObject.DeleteFile(filename[,force])
参数 | 描述
filename | 必需的。需删除文件的名称（可使用通配符）。
force | 可选的。指示是否可删除只读文件的布尔值。True 指示可删除只读文件，而 False 指示不可删除只读文件。默认是 False。

实例

<%
dim fs
Set fs=Server.CreateObject("Scripting.FileSystemObject")
fs.CreateTextFile("c:\test.txt",True)
if fs.FileExists("c:\test.txt") then
  fs.DeleteFile("c:\test.txt")
end if
set fs=nothing
%>

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP DeleteFolder 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP DeleteFolder 方法

返回 Filesystem 对象参考手册

定义和用法

DeleteFolder 方法删除一个或多个指定的文件夹。

注释：假如您试图删除不存在的文件夹，会引发错误。

语法：

FileSystemObject.DeleteFolder(foldername[,force])
参数 | 描述
foldername | 必需的。需删除文件夹的名称（可使用通配符）。
force | 可选的。指示是否可删除只读文件夹的布尔值。True 指示删除只读文件夹，而 False 指示不删除只读文件夹。默认的 False。

实例

<%
dim fs
set fs=Server.CreateObject("Scripting.FileSystemObject")
if fs.FolderExists("c:\temp") then
  fs.DeleteFolder("c:\temp")
end if
set fs=nothing
%>

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Dictionary 对象

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Dictionary 对象

  • Previous Page
  • Next Page

Dictionary 对象用于在结对的名称/值中存储信息（等同于键和项目）。

实例

指定的键存在吗？
本例演示如何受首先创建一个 Dictionary 对象，然后使用 Exists 方法来检查指定的键是否存在。
返回一个所有项目的数组
本例演示如何使用 Items 方法来返回所有项目的一个数组。
返回一个所有键的数组
本例演示如何使用 Keys 方法来返回所有键的一个数组。
返回某个项目的值
本例演示如何使用 Item 属性来返回一个项目的值。
设置一个键
本例演示如何使用 Key 属性来在 Dictionary 对象中设置一个键。
返回键/项目对的数目
本例演示如何使用 Count 属性来返回键/项目对的数目。

Dictionary 对象

Dictionary 对象用于在结对的名称/值中存储信息（(等同于键和项目）。Dictionary 对象看似比数组更为简单，然而，Dictionary 对象却是更令人满意的处理关联数据的解决方案。

比较 Dictionary 和数组：

  • 键用于识别 Dictionary 对象中的项目
  • 无需调用 ReDim 来改变 Dictionary 对象的尺寸
  • 当从 Dictionary 删除一个项目时，其余的项目会自动上移
  • Dictionary 不是多维，而数组是
  • Dictionary 与数组相比，有更多的内建对象
  • Dictionary 在频繁地访问随机元素时，比数组工作得更好
  • Dictionary 在根据它们的内容定位项目时，比数组工作得更好

下面的例子创建了一个 Dictionary 对象，并向对象添加了一些键/项目对，然后取回了键 bl 的值：

<%
Dim d
Set d=Server.CreateObject("Scripting.Dictionary")
d.Add "re","Red"
d.Add "gr","Green"
d.Add "bl","Blue"
d.Add "pi","Pink"
Response.Write("The value of key bl is: " & d.Item("bl"))
%>

输出：

The value of key bl is: Blue

Dictionary 对象的属性和方法描述如下：

属性

属性 | 描述
CompareMode | 设置或返回用于在 Dictionary 对象中比较键的比较模式。
Count | 返回 Dictionary 对象中键/项目对的数目。
Item | 设置或返回 Dictionary 对象中一个项目的值。
Key | 为 Dictionary 对象中已有的键值设置新的键值。

方法

方法 | 描述
Add | 向 Dictionary 对象添加新的键/项目对。
Exists | 返回一个逻辑值，这个值可指示指定的键是否存在于 Dictionary 对象中。
Items | 返回 Dictionary 对象中所有项目的一个数组。
Keys | 返回 Dictionary 对象中所有键的一个数组。
Remove | 从 Dictionary 对象中删除指定的键/项目对。
RemoveAll | 删除 Dictionary 对象中所有的键/项目对。
  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP Drive 对象

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Drive 对象

  • Previous Page
  • Next Page

Drive 对象用于返回关于本地磁盘驱动器或者网络共享驱动器的信息。

实例

取得指定驱动器的可用空间数
本例演示如何首先创建一个 FileSystemObject 对象，然后使用 AvailableSpace 属性来获得指定驱动器的可用空间。
取得指定驱动器的剩余空间容量
本例演示如何使用 FreeSpace 空间属性来取得指定驱动器的剩余空间。
取得指定驱动器的总容量
本例演示如何使用 TotalSize 属性来获得指定驱动器的总容量。
取得指定驱动器的驱动器字母
本例演示如何使用 DriveLetter 属性来获得指定驱动器的驱动器字母。
取得指定驱动器的驱动器类型
本例演示如何使用 DriveType 属性来获得指定驱动器的驱动器类型。
取得指定驱动器的文件系统信息
本例演示如何使用 FileSystem 来取得指定驱动器的文件系统类型。
驱动器是否已就绪？
本例演示如何使用 IsReady 属性来检查指定的驱动器是否已就绪。
取得指定驱动器的路径
本例演示如何使用 Path 属性来取得指定驱动器的路径。
取得指定驱动器的根文件夹
本例演示如何使用 RootFolder 属性来取得指定驱动器的根文件夹。
取得指定驱动器的序列号
本例演示如何使用 Serialnumber 属性来取得指定驱动器的序列号。

Drive 对象

Drive 对象用于返回关于本地磁盘驱动器或者网络共享驱动器的信息。Drive 对象可以返回有关驱动器的文件系统、剩余容量、序列号、卷标名等信息。

注释：无法通过 Drive 对象返回有关驱动器内容的信息。要达到这个目的，请使用 Folder 对象。

如需操作 Drive 对象的相关属性，我们需要创建通过 FileSystemObject 对象来创建 Drive 对象的实例。首先，创建一个 FileSystemObject 对象，然后通过 FileSystemObject 对象的 GetDrive 方法或者 Drives 属性来例示 Drive 对象。

下面的例子使用 FileSystemObject 对象的 GetDrive 方法来例示 Drive 对象，并使用 TotalSize 属性来返回指定驱动器 (c:) 的容量总数（字节）：

<%
Dim fs,d
Set fs=Server.CreateObject("Scripting.FileSystemObject")
Set d=fs.GetDrive("c:")
Response.Write("Drive " & d & ":")
Response.Write("Total size in bytes: " & d.TotalSize)
set d=nothing
set fs=nothing
%>

输出：

Drive c: Total size in bytes: 5893563398

Drive 对象的属性

属性 | 描述
AvailableSpace | 向用户返回在指定的驱动器或网络共享驱动器上的可用空间容量。
DriveLetter | 返回识别本地驱动器或网络共享驱动器的大写字母。
DriveType | 返回指定驱动器的类型。
FileSystem | 返回指定驱动器所使用的文件系统类型。
FreeSpace | 向用户返回在指定的驱动器或网络共享驱动器上的剩余空间容量。
IsReady | 如果指定驱动器已就绪，则返回 true。否则返回 false。
Path | 返回其后有一个冒号的大写字母，用来指示指定驱动器的路径名。
RootFolder | 返回一个文件夹对象，该文件夹代表指定驱动器的根文件夹。
SerialNumber | 返回指定驱动器的序列号。
ShareName | 返回指定驱动器的网络共享名。
TotalSize | 返回指定的驱动器或网络共享驱动器的总容量
VolumeName | 设置或者返回指定驱动器的卷标名
  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP Drive 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Drive 属性

返回 File 对象参考手册

定义和用法

Drive 属性可用于返回指定的文件或文件夹所在的驱动器的驱动器字母（驱动器号）。

语法：

FileObject.Drive
FolderObject.Drive

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:\test.txt")
Response.Write("File resides on drive: ")
Response.Write(f.Drive)
set f=nothing
set fs=nothing
%>

输出：

File resides on drive: c:

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\test")
Response.Write("Folder resides on drive: ")
Response.Write(fo.Drive)
set fo=nothing
set fs=nothing
%>

输出：

Folder resides on drive: c:

返回 File 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Drive 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Drive 属性

返回 Folder 对象参考手册

定义和用法

Drive 属性用于返回指定的文件或文件夹所处的驱动器的驱动器字母（驱动器号）。

语法：

FileObject.Drive
FolderObject.Drive

实例

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("d:\test.txt")
Response.Write("File resides on drive: ")
Response.Write(f.Drive)
set f=nothing
set fs=nothing
%>

输出：

File resides on drive: d:

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("d:\test")
Response.Write("Folder resides on drive: ")
Response.Write(fo.Drive)
set fo=nothing
set fs=nothing
%>

输出：

Folder resides on drive: d:

返回 Folder 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP DriveExists 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP DriveExists 方法

返回 Filesystem 对象参考手册

定义和用法

DriveExists 方法返回指示指定的驱动器是否存在的布尔值。如果驱动器存在则返回 True ，否则，返回 False。

语法：

FileSystemObject.DriveExists(drive)
参数 | 描述
drive | 必需的。驱动器字母或者完整的路径规定。

实例

<%
dim fs
set fs=Server.CreateObject("Scripting.FileSystemObject")
if fs.DriveExists("c:")=true then
  response.write("Drive c: exists!")
else
  response.write("Drive c: does not exist.")
end If
set fs=nothing
%>

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Drives 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Drives 属性

返回 Filesystem 对象参考手册

定义和用法

Drives 属性返回计算机上所有 Drive 对象的一个集合。

语法：

[drivecoll=]FileSystemObject.Drives

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP DriveType 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP DriveType 属性

返回 Drive 对象参考手册

定义和用法

DriveType 属性返回一个指示驱动器类型的值。

此属性可返回下列值之一：

  • 0 = unknown
  • 1 = removable
  • 2 = fixed
  • 3 = network
  • 4 = CD-ROM
  • 5 = RAM disk

语法：

DriveObject.DriveType

实例

<%
dim fs,d
set fs=Server.CreateObject("Scripting.FileSystemObject")
set d=fs.GetDrive("a:")
Response.Write("The drive type is: " & d.DriveType)
set d=nothing
set fs=nothing
%>

输出：

The drive type is: 1

返回 Drive 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP End 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP End 方法

返回 response 对象参考手册

End 方法停止对脚本的处理，并返回当前的结果。

注释：如果 Response.Buffer 被设置为 true ，此方法会输出缓存的内容。如果您不希望向用户返回任何任何输出，应该首先调用 Response.Clear 。

语法

Response.End

实例

<html>
<body>
<p>I am writing some text. This text will never be
<%
Response.End
%>
finished! It's too late to write more!</p>
</body>
</html>

输出：

I am writing some text. This text will never be

返回 response 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Execute 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Execute 方法

返回 Server 对象参考手册

定义和用法

Execute 方法从另外一个 ASP 文件中执行 ASP 文件。在被调用的 .asp 文件执行完毕后，控制权会返回原始的 .asp 文件。

语法

Server.Execute(path)
参数 | 描述
path | 必需。要执行的 ASP 文件的位置。

实例

File1.asp:

<%
response.write("I am in File 1!<br />")
Server.Execute("file2.asp")
response.write("I am back in File 1!")
%>

File2.asp:

<%
response.write("I am in File 2!<br />")
%>

输出：

I am in File 1!
I am in File 2!
I am back in File 1!

请参阅 Server.Transfer 方法，了解一下 Server.Execute 与 Server.Transfer 方法的区别。

返回 Server 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Exists 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Exists 方法

返回 Dictionary 对象参考手册

定义和用法

Exists 方法返回在 Dictionary 对象中是否存在指定的 key 的布尔值。如果存在，返回 true，否则返回 false。

语法：

DictionaryObject.Exists(key)
参数 | 描述
key | 必需的。需搜索的 key 值。

实例

<%
dim d
set d=Server.CreateObject("Scripting.Dictionary")
d.Add "c","China"
d.Add "i","Italy"
d.Add "s","Sweden"

if d.Exists("c")=true then
  Response.Write("Key exists!")
else
  Response.Write("Key does not exist!")
end if

set d=nothing
%>

输出：

Key exists!

返回 Dictionary 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Expires 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Expires 属性

返回 response 对象参考手册

Expires 属性设置页面在失效前被缓存的时间。如果用户在页面失效前返回同一页面，缓存的版本将显示出来。

语法：

response.Expires[=number]
参数 | 描述
number | 页面过期前的时间（分钟）

实例

例子 1

下面的代码指示页面不会被缓存：

<%response.Expires=-1%>

例子 2

下面的代码指示，页面会在 1660 分钟后失效：

<%response.Expires=1660%>

返回 response 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP ExpiresAbsolute 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP ExpiresAbsolute 属性

返回 response 对象参考手册

ExpiresAbsolute 属性设置缓存页面在浏览器上的失效日期和时间。如果用户在此日期 / 时间之前返回同一张页面，那么会显示出缓存的版本。

语法：

response.ExpiresAbsolute[=[date][time]]
参数 | 描述
date | 规定页面的失效日期。 如果不规定此参数，那么页面会在脚本运行当日的指定时间失效。
time | 规定页面的失效时间。 如果不规定此参数，那么页面会在指定日期的午夜失效。

实例

下面的代码指示，页面会在 2003 年 10 月 11 月 4:00 PM 失效：

<%response.ExpiresAbsolute=#October 11,2003 16:00:00#%>

返回 response 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP File 对象

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP File 对象

  • Previous Page
  • Next Page

File 对象用于返回关于指定文件的信息。

实例

文件何时被创建？
本例演示如何首先创建 FileSystemObject 对象，然后使用 File 对象的 DateCreated 属性来取得指定文件被创建的日期和时间。
此文件何时被修改？
本例演示如何使用 DateLastModified 属性来取得指定文件被修改的日期和时间。
此文件何时被访问过？
此例演示如何使用 DateLastAccessed 属性来取得指定文件最后被访问的日期和时间。
返回指定文件的属性
本例演示如何使用 Attributes 来返回指定文件的属性。

File 对象

File 对象用于返回有关指定文件的信息。

如需操作 File 对象的相关属性和方法，我们需要通过 FileSystemObject 来创建 File 对象的实例。首先，创建一个 FileSystemObject 对象，然后通过 FileSystemObject 对象的 GetFile 方法，或者通过 Folder 对象的 Files 属性来例示此 File 对象。

下面的代码使用 FileSystemObject 对象的 GetFile 方法来例示这个 File 对象，并使用 DateCreated 属性来返回指定文件被创建的日期：

<%
Dim fs,f
Set fs=Server.CreateObject("Scripting.FileSystemObject")
Set f=fs.GetFile("c:\test.txt")
Response.Write("File created: " & f.DateCreated)
set f=nothing
set fs=nothing
%>

输出：

File created: 8/8/2008 10:01:19 AM

File 对象的属性和方法

属性

属性 | 描述
Attributes | 设置或返回指定文件的属性。
DateCreated | 返回指定文件创建的日期和时间。
DateLastAccessed | 返回指定文件最后被访问的日期和时间。
DateLastModified | 返回指定文件最后被修改的日期和时间。
Drive | 返回指定文件或文件夹所在的驱动器的驱动器字母。
Name | 设置或返回指定文件的名称。
ParentFolder | 返回指定文件或文件夹的父文件夹对象。
Path | 返回指定文件的路径。
ShortName | 返回指定文件的短名称（8.3 命名约定）。
ShortPath | 返回指定文件的短路径（8.3 命名约定）。
Size | 返回指定文件的尺寸（字节）。
Type | 返回指定文件的类型。

方法

方法 | 描述
Copy | 把指定文件从一个位置拷贝到另一个位置。
Delete | 删除指定文件。
Move | 把指定文件从一个位置移动到另一个位置。
OpenAsTextStream | 打开指定文件，并返回一个 TextStream 对象以便访问此文件。
  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP FileExists 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP FileExists 方法

返回 Filesystem 对象参考手册

定义和用法

FileExists 方法可返回指示指定的文件是否存在的布尔值。如果存在，则返回 Ture，否则返回 False。

语法：

FileSystemObject.FileExists(filename)
参数 | 描述
filename | 必需的。需检测是否存在的文件的名称。

实例

<%
dim fs
set fs=Server.CreateObject("Scripting.FileSystemObject")
if fs.FileExists("c:\asp\introduction.asp")=true then
  response.write("File c:\asp\introduction.asp exists!")
else
   response.write("File c:\asp\introduction.asp does not exist!")
end if
set fs=nothing
%>

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Files 集合

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Files 集合

返回 Folder 对象参考手册

定义和用法

Files 集合返回指定的文件夹中所有文件的一个集合。

语法：

FolderObject.Files

实例

<%
dim fs,fo,x
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\test\")

for each x in fo.files
  'Print the name of all files in the test folder
  Response.write(x.Name & "<br />")
next

set fo=nothing
set fs=nothing
%>

输出类似这样：

file_01.txt
file_02.txt
file_03.txt
file_04.txt
file_05.txt
file_06.txt

返回 Folder 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP FileSystem 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP FileSystem 属性

返回 Drive 对象参考手册

定义和用法

FileSystem 属性返回指定的驱动器所使用的文件系统。

此属性可返回下列的值：

  • FAT - 可移动驱动器
  • CDFS - CD-ROM 驱动器
  • FAT, FAT32 或 NTFS - 在 Windows 2000 或 Windows NT 上的硬盘驱动器
  • FAT 或 FAT32 - 在 Windows 9x 上的硬盘驱动器

语法：

DriveObject.FileSystem

实例

<%
dim fs,d
set fs=Server.CreateObject("Scripting.FileSystemObject")
set d=fs.GetDrive("c:")
Response.Write("The file system in use is: " & d.FileSystem)
set d=nothing
set fs=nothing
%>

输出：

The file system in use is: FAT

返回 Drive 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP FileSystemObject 对象

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP FileSystemObject 对象

  • Previous Page
  • Next Page

FileSystemObject 对象用于访问服务器上的文件系统。

实例

指定的文件存在吗？
本例演示如何首先创建 FileSystemObject 对象，然后使用 FileExists 方法来探测某文件是否存在。
指定的文件夹存在吗？
本例演示如何使用 FolderExists 方法探测某文件夹是否存在。
指定的驱动器存在吗？
本例演示如何使用 DriveExists 方法来探测某个驱动器是否存在。
取得某个指定驱动器的名称
本例演示如何使用 GetDriveName 方法来取得某个指定的驱动器的名称。
取得某个指定路径的父文件夹的名称
本例演示如何使用 GetParentFolderName 方法来取得某个指定的路径的父文件夹的名称。
取得文件夹扩展名
本例演示如何使用 GetExtensionName 方法来取得指定的路径中的最后一个成分的文件扩展名。
取得文件名
本例演示如何使用 GetFileName 方法来取得指定的路径中的最后一个成分的文件名。
取得文件或文件夹的基名称
本例演示如何使用 GetBaseName 方法来返回在指定的路径中文件或者文件夹的基名称。

FileSystemObject 对象

FileSystemObject 对象用于访问服务器上的文件系统。此对象可对文件、文件夹以及目录路径进行操作。也可通过此对象获取文件系统的信息。

下面的代码会创建一个文本文件 (c:\test.txt)，然后向这个文件写一些文本：

<%
dim fs,fname
      set fs=Server.CreateObject("Scripting.FileSystemObject")
      set fname=fs.CreateTextFile("c:\test.txt",true)
      fname.WriteLine("Hello World!")
      fname.Close
set fname=nothing
set fs=nothing
%>

FileSystemObject 对象的属性和方法描述如下：

属性

属性 | 描述
Drives | 返回本地计算机上所有驱动器对象的集合。

方法

方法 | 描述
BuildPath | 将一个名称追加到已有的路径后
CopyFile | 从一个位置向另一个位置拷贝一个或多个文件。
CopyFolder | 从一个位置向另一个位置拷贝一个或多个文件夹。
CreateFolder | 创建新文件夹。
CreateTextFile | 创建文本文件，并返回一个 TextStream 对象。
DeleteFile | 删除一个或者多个指定的文件。
DeleteFolder | 删除一个或者多个指定的文件夹。
DriveExists | 检查指定的驱动器是否存在。
FileExists | 检查指定的文件是否存在。
FolderExists | 检查某个文件夹是否存在。
GetAbsolutePathName | 针对指定的路径返回从驱动器根部起始的完整路径。
GetBaseName | 返回指定文件或者文件夹的基名称。
GetDrive | 返回指定路径中所对应的驱动器的 Drive 对象。
GetDriveName | 返回指定的路径的驱动器名称。
GetExtensionName | 返回在指定的路径中最后一个成分的文件扩展名。
GetFile | 返回一个针对指定路径的 File 对象。
GetFileName | 返回在指定的路径中最后一个成分的文件名。
GetFolder | 返回一个针对指定路径的 Folder 对象。
GetParentFolderName | 返回在指定的路径中最后一个成分的父文件名称。
GetSpecialFolder | 返回某些 Windows 的特殊文件夹的路径。
GetTempName | 返回一个随机生成的文件或文件夹。
MoveFile | 从一个位置向另一个位置移动一个或多个文件。
MoveFolder | 从一个位置向另一个位置移动一个或多个文件夹。
OpenTextFile | 打开文件，并返回一个用于访问此文件的 TextStream 对象。
  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP Flush 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Flush 方法

返回 response 对象参考手册

Flush 方法立即发送已缓存的 HTML 输出。

注释：假如 response.Buffer 为 false ，此方法会引起一个 run-time 错误

语法

Response.Flush

实例

<%
Response.Buffer=true
%>
<html>
<body>
<p>I write some text, but I will control when the
text will be sent to the browser.</p>
<p>The text is not sent yet. I hold it back!</p>
<p>OK, let it go!</p>
<%
Response.Flush
%>
</body>
</html>

输出：

I write some text, but I will control when the
text will be sent to the browser.

The text is not sent yet. I hold it back!

OK, let it go!

返回 response 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Folder 对象

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Folder 对象

  • Previous Page
  • Next Page

Folder 对象用来返回有关指定文件夹的信息。

Folder 对象

Folder 对象用于返回有关指定文件夹的信息。

如需操作 Folder 对象，我们需要通过 FileSystemObject 对象来创建 Folder 对象的实例。首先，创建一个 FileSystemObject 对象，然后通过 FileSystemObject 对象的 GetFolder 方法来例示这个 Folder 对象。

下面的代码使用 FileSystemObject 对象的 GetFolder 方法来例示这个 Folder 对象，并使用 DateCreated 属性来返回指定文件的创建日期：

<%
Dim fs,fo
Set fs=Server.CreateObject("Scripting.FileSystemObject")
Set fo=fs.GetFolder("c:\test")
Response.Write("Folder created: " & fo.DateCreated)
set fo=nothing
set fs=nothing
%>

输出：

Folder created: 10/22/2001 10:01:19 AM

Folder 对象的集合、属性以及方法

集合

集合 | 描述
Files | 返回指定文件夹中所有文件夹的集合。
SubFolders | 返回指定文件夹中所有子文件夹的集合。

属性

属性 | 描述
Attributes | 设置或返回指定文件夹的属性。
DateCreated | 返回指定文件夹被创建的日期和时间。
DateLastAccessed | 返回指定文件夹最后被访问的日期和时间。
DateLastModified | 返回指定文件夹最后被修改的日期和时间。
Drive | 返回指定文件夹所在的驱动器的驱动器字母。
IsRootFolder | 假如文件夹是根文件夹，则返回 ture，否则返回 false。
Name | 设置或返回指定文件夹的名称。
ParentFolder | 返回指定文件夹的父文件夹。
Path | 返回指定文件的路径。
ShortName | 返回指定文件夹的短名称。（8.3 命名约定）
ShortPath | 返回指定文件夹的短路径。（8.3 命名约定）
Size | 返回指定文件夹的大小。
Type | 返回指定文件夹的类型。

方法

方法 | 描述
Copy | 把指定的文件夹从一个位置拷贝到另一个位置。
Delete | 删除指定文件夹。
Move | 把指定的文件夹从一个位置移动到另一个位置。
CreateTextFile | 在指定的文件夹创建一个新的文本文件，并返回一个 TextStream 对象以访问这个文件。
  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP FolderExists 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP FolderExists 方法

返回 Filesystem 对象参考手册

定义和用法

FolderExists 方法可返回指示指定的文件夹是否存在的布尔值。如果存在则返回 Ture，否则返回 Fasle。

语法：

FileSystemObject.FolderExists(foldername)
参数 | 描述
foldername | 必需的。需检测是否存在的文件夹的名称。

实例

<%
dim fs
set fs=Server.CreateObject("Scripting.FileSystemObject")
if fs.FolderExists("c:\asp")=true then
  response.write("Folder c:\asp exists!")
else
  response.write("Folder c:\asp does not exist!")
end if
set fs=nothing
%>

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Form 集合

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Form 集合

返回 Request 对象参考手册

Form 集合用于从使用 POST 方法的表单获取表单元素的值。

注释：如果您需要 post 大量的数据（超过 100kb），就不能使用 Request.Form 。

语法

Request.Form(element)[(index)|.Count]
参数 | 描述
element | 必需。表单元素的名称，此集合从中取回值。
index | 可选。规定一个参数的多个值中的一个。从 1 到 Request.Form(parameter).Count。

实例

例子 1

您可以遍历表单请求中的所有值。假设用户通过指定两个值来填写了表单 - 蓝色和绿色 - 您能够这样取回这些值：

<%
for i=1 to Request.Form("color").Count
Response.Write(Request.Form("color")(i) & "<br />")
next
%>

输出：

Blue
Green

例子 2

请认真看一下这个表单：

<form action="submit.asp" method="post">
<p>First name: <input name="firstname"></p>
<p>Last name: <input name="lastname"></p>
<p>Your favorite color:
<select name="color">
<option>Blue</option>
<option>Green</option>
<option>Red</option>
<option>Yellow</option>
<option>Pink</option>
</select>
</p>
<p><input type="submit"></p>
</form>

假设，发送了下面的请求：

firstname=John&lastname=Dove&color=Red

现在，我们可以通过一段脚本来使用表单中的信息了：

Hi, <%=Request.Form("firstname")%>.
Your favorite color is <%=Request.Form("color")%>.

输出：

Hi, John. Your favorite color is Red.

如果您不规定要显示的元素：

Form data is: <%=Request.Form%>

那么输出会成为这样：

Form data is: firstname=John&lastname=Dove&color=Red

返回 Request 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP FreeSpace 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP FreeSpace 属性

返回 Drive 对象参考手册

定义和用法

FreeSpace 属性返回在指定驱动器或网络共享上对于用户的剩余空间量。

注释：返回的值通常等于由 AvailableSpace 属性返回的值。对于支持限额的计算机系统来说，这两个属性返回的值有所差异。

语法：

DriveObject.FreeSpace

实例

<%
dim fs,d
set fs=Server.CreateObject("Scripting.FileSystemObject")
set d=fs.GetDrive("c:")
Response.Write("Drive " & d)
Response.Write(" Free space in bytes: " & d.FreeSpace)
set d=nothing
set fs=nothing
%>

输出：

Drive c: Free space in bytes: 669965663

返回 Drive 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP GetAbsolutePathName 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP GetAbsolutePathName 方法

返回 Filesystem 对象参考手册

定义和用法

GetAbsolutePathName 方法为指定路径返回从根驱动器开始的完整路径。

语法：

FileSystemObject.GetAbsolutePathName(path)
参数 | 描述
path | 必需的。需修改为完整路径的路径。

实例

例子 1

<%
dim fs,path
set fs=Server.CreateObject("Scripting.FileSystemObject")
path=fs.GetAbsolutePathName("c:")
response.write(path)
%>

输出：

c:\temp\test

例子 2

<%
dim fs,path
set fs=Server.CreateObject("Scripting.FileSystemObject")
path=fs.GetAbsolutePathName("mydoc.txt")
response.write(path)
%>

输出：

c:\temp\test\mydoc.txt

例子 3

<%
dim fs,path
set fs=Server.CreateObject("Scripting.FileSystemObject")
path=fs.GetAbsolutePathName("private\mydoc.txt")
response.write(path)
%>

输出：

c:\temp\test\private\mydoc.txt

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP GetBaseName 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP GetBaseName 方法

返回 Filesystem 对象参考手册

定义和用法

GetBaseName 方法返回指定路径中的文件或文件夹的基准名称。

语法：

FileSystemObject.GetBaseName(path)
参数 | 描述
path | 必需的。其基准名称需被返回的文件或文件夹的路径。

实例

<%
dim fs
set fs=Server.CreateObject("Scripting.FileSystemObject")
Response.Write(fs.GetBaseName("c:\winnt\cursors\3dgarro.cur"))
set fs=nothing
%>

输出：

3dgarro

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP GetDrive 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP GetDrive 方法

返回 Filesystem 对象参考手册

定义和用法

GetDrive 方法可返回由 drivespec 参数规定的 Drive 对象。

语法：

FileSystemObject.GetDrive(drivespec)
参数 | 描述
drivespec | 必需的。可以是驱动器字母 (c)，或者带有冒号的驱动器字母，或者带有冒号和路径分隔符的驱动器字母，或者任何网络共享规范 (\\computer2\share1)。

实例

<%
dim fs,d
set fs=Server.CreateObject("Scripting.FileSystemObject")
set d=fs.GetDrive("c:\")
set fs=nothing
%>

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP GetDriveName 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP GetDriveName 方法

返回 Filesystem 对象参考手册

定义和用法

GetDriveName 方法返回一个字符串，该值是指定路径的驱动器名称。

语法：

FileSystemObject.GetDriveName(path)
参数 | 描述
path | 必需的。可返回驱动器名称的路径。

实例

<%
dim fs,dname
set fs=Server.CreateObject("Scripting.FileSystemObject")
dname=fs.GetDriveName("c:\test\test.htm")
Response.Write(dname)
set fs=nothing
%>

输出：

c:

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP GetExtensionName 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP GetExtensionName 方法

返回 Filesystem 对象参考手册

定义和用法

GetExtensionName 方法返回包含指定路径中最后成分的文件扩展名的字符串。

语法：

FileSystemObject.GetExtensionName(path)
参数 | 描述
path | 必需的。需返回文件扩展名的文件的路径。

实例

<%
dim fs
set fs=Server.CreateObject("Scripting.FileSystemObject")
Response.Write(fs.GetExtensionName("c:\test\test.htm"))
set fs=nothing
%>

输出：

htm

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP GetFile 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP GetFile 方法

返回 Filesystem 对象参考手册

定义和用法

GetFile 方法返回指定路径的 File 对象。

语法：

FileSystemObject.GetFile(path)
参数 | 描述
path | 必需的。指向具体文件的路径。

实例

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:\test\test.htm")
Response.Write("The file was last modified on: ")
Response.Write(f.DateLastModified)
set f=nothing
set fs=nothing
%>

输出：

The file was last modified on 01/01/20 4:23:56 AM

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP GetFileName 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP GetFileName 方法

返回 Filesystem 对象参考手册

定义和用法

GetFileName 方法返回包含指定路径中最后成分的文件名或文件夹名的字符串。

语法：

FileSystemObject.GetFileName(path)
参数 | 描述
path | 必需的。指向具体文件或文件夹的路径。

实例

例子 1

<%
dim fs,p
set fs=Server.CreateObject("Scripting.FileSystemObject")
p=fs.getfilename("c:\test\test.htm")
response.write(p)
set fs=nothing
%>

输出：

test.htm

例子 2

<%
dim fs,p
set fs=Server.CreateObject("Scripting.FileSystemObject")
p=fs.getfilename("c:\test\")
response.write(p)
set fs=nothing
%>

输出：

test

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP GetFolder 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP GetFolder 方法

返回 Filesystem 对象参考手册

定义和用法

GetFolder 方法返回指定路径的 Folder 对象。

语法：

FileSystemObject.GetFolder(path)
参数 | 描述
path | 必需的。指向具体文件夹的路径。

实例

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFolder("c:\test\")
Response.Write("The folder was last modified on: ")
Response.Write(f.DateLastModified)
set f=nothing
set fs=nothing
%>

输出：

The folder was last modified on 01/01/20 4:23:56 AM

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP GetLastError() 方法 (ASP 3.0)

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP GetLastError() 方法 (ASP 3.0)

返回 Server 对象参考手册

定义和用法

GetLastError 方法返回 ASPError 对象，描述发生错误的原因。

默认地，网站会使用文件 \iishelp\common\500-100.asp 来处理 ASP 错误。您即可以使用此文件，也可以创建自己的文件。如果您希望改变处理 500;100 custom errors 的 ASP 文件，请使用 IIS snap-in 。

注释：如果在 IIS 处理 ASP 文件或应用程序的 Global.asa 时碰到错误，就会生成500;100 custom error。

注释：此方法仅在 ASP 文件发送任何内容到浏览器之前可用。

语法

Server.GetLastError()

实例

例子 1

在本例中，在 IIS 试图引用文件，而 include 语句没有使用 file 参数时，错误就会发生：

<!--#include f="header.inc" -->
<%
response.write("sometext")
%>

例子 2

在本例中，当编译脚本时，由于关键词 "next" 被遗漏，就会发生错误：

<%
dim i
for i=1 to 10
  ........
nxt
%>

例子 3

在本例中，由于脚本试图用 0 来除一个数，就会发生错误：

<%
dim i,tot,j
i=0
tot=0
j=0

for i=1 to 10
  tot=tot+1
next

tot=tot/j
%>

返回 Server 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP GetParentFolderName 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP GetParentFolderName 方法

返回 Filesystem 对象参考手册

定义和用法

GetParentFolderName 方法返回指定的路径中最后成分的父文件夹的名称。

语法：

FileSystemObject.GetParentFolderName(path)
参数 | 描述
path | 必需的。需返回其父文件夹的文件或文件夹的路径。

实例

<%
dim fs,p
set fs=Server.CreateObject("Scripting.FileSystemObject")
p=fs.GetParentFolderName("c:\winnt\cursors\3dgarro.cur")
Response.Write(p)
set fs=nothing
%>

输出：

c:\winnt\cursors

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP GetSpecialFolder 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP GetSpecialFolder 方法

返回 Filesystem 对象参考手册

定义和用法

GetSpecialFolder 方法返回 Windows 的特殊文件夹的路径。

语法：

FileSystemObject.GetSpecialFolder(foldername)
参数 描述
foldername 必需的。要返回的文件夹。
  • 0 = WindowsFolder - 包含由 Windows 操作系统安装的文件。
  • 1 = SystemFolder - 包含库、字体和设备驱动。
  • 2 = TemporaryFolder - 用于存储临时文件。

实例

<%
dim fs,p
set fs=Server.CreateObject("Scripting.FileSystemObject")
set p=fs.GetSpecialFolder(1)
Response.Write(p)
set p=nothing
set fs=nothing
%>

输出：

C:\WINNT\system32

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP GetTempName 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP GetTempName 方法

返回 Filesystem 对象参考手册

定义和用法

GetTempName 方法返回一个随机产生的临时文件或文件夹。

语法：

FileSystemObject.GetTempName

实例

<%
dim fs,tfolder,tname, tfile
Set fs=Server.CreateObject("Scripting.FileSystemObject")
Set tfolder=fs.GetSpecialFolder(2)
tname=fs.GetTempName
Set tfile=tfolder.CreateTextFile(tname)
Response.write (tfile)
%>

输出：

trb2007.tmp

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Global.asa 文件

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Global.asa 文件

  • Previous Page
  • Next Page

Global.asa 文件是一个可选的文件，它可包含可被 ASP 应用程序中每个页面访问的对象、变量以及方法的声明。

Global.asa 文件

Global.asa 文件是一个可选的文件，它可包含可被 ASP 应用程序中每个页面访问的对象、变量以及方法的声明。所有合法的浏览器脚本都能在 Global.asa 中使用。

Global.asa 文件可包含下列内容：

  • Application 事件
  • Session 事件
  • <object> 声明
  • TypeLibrary 声明
  • #include 命令

注释：Global.asa 文件须存放于 ASP 应用程序的根目录中，且每个应用程序只能有一个 Global.asa 文件。

Global.asa 中的事件

在 Global.asa 中，我们可以告知 application 和 session 对象在启动和结束时做什么事情。完成此项任务的代码被放置在事件操作器中。Global.asa 文件能包含四种类型的事件：

Application_OnStart - 此事件会在首位用户从 ASP 应用程序调用第一个页面时发生。此事件会在 web 服务器重起或者 Global.asa 文件被编辑之后发生。"Session_OnStart" 事件会在此事件发生之后立即发生。

Session_OnStart - 此事件会在每当新用户请求他或她的在 ASP 应用程序中的首个页面时发生。

Session_OnEnd - 此事件会在每当用户结束 session 时发生。在规定的时间（默认的事件为 20 分钟）内如果没有页面被请求，session 就会结束。

Application_OnEnd - 此事件会在最后一位用户结束其 session 之后发生。典型的情况是，此事件会在 Web 服务器停止时发生。此子程序用于在应用程序停止后清除设置，比如删除记录或者向文本文件写信息。

Global.asa 文件可能类似这样：

<script language="vbscript" runat="server">

sub Application_OnStart
  'some code
end sub

sub Application_OnEnd
  'some code
end sub

sub Session_OnStart
  'some code
end sub

sub Session_OnEnd
  'some code
end sub

</script>

注释：由于无法使用 ASP 的脚本分隔符 (<% 和 %>) 在 Global.asa 文件中插入脚本，我们需使用 HTML 的 <script> 元素。

<object> 声明

可通过使用 <object> 标签在 Global.asa 文件中创建带有 session 或者 application 作用域的对象。

注释：<object> 标签应位于 <script> 标签之外。

语法：

<object runat="server" scope="scope" id="id"
{progid="progID"|classid="classID"}>
....
</object>
参数 | 描述
scope | 设置对象的作用域（作用范围）（Session 或者 Application）。
id | 为对象指定一个唯一的 id。
ProgID | 与 ClassID 关联的 id。ProgID 的格式是：[Vendor.]Component[.Version]。 ProgID 或 ClassID 必需被指定。
ClassID | 为 COM 类对象指定唯一的 id。 ProgID 或 ClassID 必需被指定。

实例

第一个实例创建了一个名为 "MyAd" 且使用 ProgID 参数的 session 作用域对象：

<object runat="server" scope="session" id="MyAd" progid="MSWC.AdRotator">
</object>

第二个实例创建了名为 "MyConnection" 且使用 ClassID 参数的

<object runat="server" scope="application" id="MyConnection"
classid="Clsid:8AD3067A-B3FC-11CF-A560-00A0C9081C21">
</object>

在此 Global.asa 文件中声明的这些对象可被应用程序中的任何脚本使用。

GLOBAL.ASA:

<object runat="server" scope="session" id="MyAd" progid="MSWC.AdRotator">
</object>

您可以从 ASP 应用程序中的任意页面引用此 "MyAd" 对象：

某个 .ASP 文件:

<%=MyAd.GetAdvertisement("/banners/adrot.txt")%>

TypeLibrary 声明

TypeLibrary （类型库）是一个容器，其中装有对应于 COM 对象的 DLL 文件。通过在 Global.asa 中包含对 TypeLibrary 的调用，可以访问 COM 对象的常量，同时 ASP 代码也能更好地报告错误。假如您的站点的应用程序依赖于已在类型库中声明过数据类型的 COM 对象，您可以在 Global.asa 中对类型库进行声明。

语法：

<!--METADATA TYPE="TypeLib"
file="filename"
uuid="typelibraryuuid"
version="versionnumber"
lcid="localeid"
-->
参数 | 描述
file | 规定指向类型库的绝对路径。参数 file 或者 uuid，两者缺一不可。
uuid | 规定了针对类型库的唯一的标识符。参数 file 或者 uuid，两者缺一不可。
version | 可选。用于选择版本。假如没有找到指定的版本，将使用最接近的版本。
lcid | 可选。用于类型库的地区标识符。

错误值

服务器会返回以下的错误消息之一：

错误 | 代码 | 描述
ASP | 0222 | Invalid type library specification
ASP | 0223 | Type library not found
ASP | 0224 | Type library cannot be loaded
ASP | 0225 | Type library cannot be wrapped

注释：METADATA 标签可位于 Global.asa 文件中的任何位置（在 <script> 标签的内外均可）。不过，我们还是推荐将 METADATA 标签放置于 Global.asa 文件的顶部。

限定

关于可以在 Global.asa 文件中引用的内容的限定：

你无法显示 Global.asa 文件中的文本。此文件无法显示信息。

你只能在 Application_OnStart 和 Application_OnEnd 子例程中使用 Server 和 Application 对象。在 Session_OnEnd 子例程中，你可以使用 Server、Application 和 Session 对象。在 Session_OnStart 子例程中，你可使用任何内建的对象。

如何使用子例程

Global.asa 常用于对变量进行初始化。

下面的例子展示如何检测访问者首次到达站点的确切时间。时间存储在名为 "started" 的 Session 对象中，并且 "started" 变量的值可被应用程序中的任何 ASP 页面访问：

<script language="vbscript" runat="server">
sub Session_OnStart
Session("started")=now()
end sub
</script>

Global.asa 也可用于控制页面访问。

下面的例子展示如何把每位新的访问者重定向到另一个页面，在这个例子中会定向到 "newpage.asp" 这个页面：

<script language="vbscript" runat="server">
sub Session_OnStart
Response.Redirect("newpage.asp")
end sub
</script>

我们还可以在 Global.asa 中包含函数。

在下面的例子中，当 Web 服务器启动时，Application_OnStart 子例程也会启动。随后，Application_OnStart 子例程会调用另一个名为 "getcustomers" 的子例程。"getcustomers" 子例程会打开一个数据库，然后从 "customers" 表中取回一个记录集。此记录集会赋值给一个数组，在不查询数据库的情况下，任何 ASP 页面都能够访问这个数组：

<script language="vbscript" runat="server">

sub Application_OnStart
getcustomers
end sub

sub getcustomers
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open "c:/webdata/northwind.mdb"
set rs=conn.execute("select name from customers")
Application("customers")=rs.GetRows
rs.Close
conn.Close
end sub

</script>

Global.asa 实例

在这个例子中，我们要创建一个可计算当前访客的 Global.asa 文件。

Application_OnStart 设置当服务器启动时，Application 变量 "visitors" 的值为 0。

每当有新用户访问时，Session_OnStart 子例程就会给变量 "visitors" 加 1。

每当 Session_OnEnd 子例程被触发时，此子例程就会从变量 "visitors" 减 1。

Global.asa 文件：

<script language="vbscript" runat="server">

Sub Application_OnStart
Application("visitors")=0
End Sub

Sub Session_OnStart
Application.Lock
Application("visitors")=Application("visitors")+1
Application.UnLock
End Sub

Sub Session_OnEnd
Application.Lock
Application("visitors")=Application("visitors")-1
Application.UnLock
End Sub

</script>

此 ASP 文件会显示当前用户的数目：

<html>
<head>
</head>
<body>
<p>There are <%response.write(Application("visitors"))%> online now!</p>
</body>
</html>
  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP HTMLEncode 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP HTMLEncode 方法

返回 Server 对象参考手册

定义和用法

HTMLEncode 方法对一段指定的字符串应用 HTML 编码。

语法

Server.HTMLEncode(string)
参数 | 描述
string | 必需。要编码的字符串。

实例

脚本：

<%
response.write(Server.HTMLEncode("The image tag: <img>"))
%>

输出：

The image tag: &lt;img&gt;

浏览器的输出：

The image tag: <img>

返回 Server 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP IsClientConnected 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP IsClientConnected 属性

返回 response 对象参考手册

IsClientConnected 属性指示出客户机是否已与服务器断开连接。

语法

response.IsClientConnected

实例

<%
If response.IsClientConnected=true then
  response.write("The user is still connected!")
else
  response.write("The user is not connected!")
end if
%>

返回 response 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP IsReady 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP IsReady 属性

返回 Drive 对象参考手册

定义和用法

IsReady 属性返回指定驱动器是否就绪。就绪为 true，未就绪为 false。

注释：对于可移动媒体驱动器和 CD-ROM 驱动器，仅当插入相应的媒体并准备接受访问时，IsReady 返回 True。

语法：

DriveObject.IsReady

实例

<%
dim fs,d,n
set fs=Server.CreateObject("Scripting.FileSystemObject")
set d=fs.GetDrive("a:")
n = "The " & d.DriveLetter
if d.IsReady=true then
  n=n & " drive is ready!"
else
  n=n & " drive is not ready!"
end if
Response.Write(n)
set d=nothing
set fs=nothing
%>

输出：

The A drive is not ready!

返回 Drive 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP IsRootFolder 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP IsRootFolder 属性

返回 Folder 对象参考手册

定义和用法

IsRootFolder 属性返回指定的文件夹是否为根文件夹。如果是，返回 True；否则返回 False。

语法：

FolderObject.IsRootFolder

实例

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\asp\test")
if fo.IsRootFolder=true then
   Response.Write("The folder is the root folder!")
else
   Response.Write("The folder is not the root folder!")
end if
set fo=nothing
set fs=nothing
%>

输出：

The folder is not the root folder!

返回 Folder 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Item 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Item 属性

返回 Dictionary 对象参考手册

定义和用法

Item 属性设置或返回 Dictionary 对象中某个项目的值。

语法：

DictionaryObject.Item(key)[=newitem]
参数 | 描述
key | 必需的。与 item 相关联的 key。
newitem | 可选的。规定与 key 相关联的值。

实例

<%
Dim d
Set d=Server.CreateObject("Scripting.Dictionary")
d.Add "re","Red"
d.Add "gr","Green"
d.Add "bl","Blue"
d.Add "pi","Pink"
Response.Write("The value of key bl is: " & d.Item("bl"))
%>

输出：

The value of key bl is: Blue

返回 Dictionary 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Items 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Items 方法

返回 Dictionary 对象参考手册

定义和用法

Items 方法返回包含 Dictionary 对象中的所有项目的一个数组。

语法：

DictionaryObject.Items

实例

<%
dim d,a,i
set d=Server.CreateObject("Scripting.Dictionary")
d.Add "c","China"
d.Add "i","Italy"
d.Add "s","Sweden"

Response.Write("<p>Item values:</p>")
a=d.Items
for i=0 to d.Count-1
  Response.Write(a(i))
  Response.Write("<br />")
next

set d=nothing
%>

输出：

Item values:
China
Italy
Sweden

返回 Dictionary 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Key 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Key 属性

返回 Dictionary 对象参考手册

定义和用法

Key 属性在 Dictionary 对象中为已有的 key 设置新值。

语法：

DictionaryObject.Key(key)=newkey
Parameter | Description
key | 必需的。需修改的 key 的名称。
newkey | 必需的。key 的新名称。

实例

<%
Dim d
Set d=Server.CreateObject("Scripting.Dictionary")
d.Add "re","Red"
d.Add "gr","Green"
d.Add "bl","Blue"
d.Add "pi","Pink"
d.Key("re")="r"
Response.Write("The value of key r is: " & d.Item("r"))
%>

输出：

The value of key r is: r

返回 Dictionary 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Keys 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Keys 方法

返回 Dictionary 对象参考手册

定义和用法

Keys 方法返回包含 Dictionary 对象中所有 key 的数组。

语法：

DictionaryObject.Keys

实例

<%
dim d,a,i
set d=Server.CreateObject("Scripting.Dictionary")
d.Add "c","China"
d.Add "i","Italy"
d.Add "s","Sweden"

Response.Write("<p>Key values:</p>")
a=d.Keys
for i=0 to d.Count-1
  Response.Write(a(i))
  Response.Write("<br />")
next

set d=nothing
%>

输出：

Key values:
c
i
s

返回 Dictionary 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP LCID 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP LCID 属性

返回 Session 对象参考手册

定义和用法

LCID 属性设置或返回一个规定位置或地区的整数。诸如日期、时间以及货币等内容都会根据位置或地区来显示。

语法

Session.LCID(=LCID)
参数 | 描述
LCID | 地区标识符。

实例

<%
response.write("<p>")
response.write("Default LCID is: " & Session.LCID & "<br />")
response.write("Date format is: " & date() & "<br />")
response.write("Currency format is: " & FormatCurrency(350))
response.write("</p>")

Session.LCID=1036

response.write("<p>")
response.write("LCID is now: " & Session.LCID & "<br />")
response.write("Date format is: " & date() & "<br />")
response.write("Currency format is: " & FormatCurrency(350))
response.write("</p>")

Session.LCID=3079

response.write("<p>")
response.write("LCID is now: " & Session.LCID & "<br />")
response.write("Date format is: " & date() & "<br />")
response.write("Currency format is: " & FormatCurrency(350))
response.write("</p>")

Session.LCID=2057

response.write("<p>")
response.write("LCID is now: " & Session.LCID & "<br />")
response.write("Date format is: " & date() & "<br />")
response.write("Currency format is: " & FormatCurrency(350))
response.write("</p>")
%>

输出：

Default LCID is: 2057
Date format is: 28/01/2009
Currency format is: ￡350.00

LCID is now: 1036
Date format is: 28/01/2009
Currency format is: 350,00 F

LCID is now: 3079
Date format is: 28.01.2009
Currency format is: ?S 350,00

LCID is now: 2057
Date format is: 28/01/2009
Currency format is: ￡350.00

返回 Session 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Line 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Line 属性

返回 Textstream 对象参考手册

定义和用法

Line 属性返回在 TextStream 文件中的当前行号（从 1 开始）。

语法：

TextStreamObject.Line

实例

<%
dim fs,f,t
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.CreateTextFile("c:\test.txt",true)
f.WriteLine("Hello World!")
f.WriteLine("How are you today?")
f.WriteLine("Goodbye!")
f.close

Set t=fs.OpenTextFile("c:\test.txt",1)
do while t.AtEndOfStream=false
  Response.Write("Line " & t.Line & ": ")
  Response.Write(t.ReadLine)
  Response.Write("<br>")
loop
t.Close
%>

输出：

Line 1: Hello World!
Line 2: How are you today?
Line 3: Goodbye!

返回 Textstream 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Lock 和 Unlock 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Lock 和 Unlock 方法

返回 Application 对象参考手册

定义和用法

Lock 方法

Lock 方法阻止其他用户修改 Application 对象中的变量 (用来确保同一时间只有一位用户可修改 Application 变量)。

Unlock 方法

Unlock 方法使其他用户能够修改存储在 Application 对象中的变量 (在它被使用 Lock 方法锁定之后)。

语法

Application.Lock

Application.Unlock

实例

下面的例子用 Lock 方法来防止一个以上的用户在同一时间访问变量 visits，用 Unlock 方法来对已锁定的对象进行解锁，这样下一个用户就可以增加变量 visits 的值：

<%
Application.Lock
Application("visits")=Application("visits")+1
Application.Unlock
%>

This page has been visited
<%=Application("visits")%> times!

返回 Application 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP MapPath 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP MapPath 方法

返回 Server 对象参考手册

定义和用法

MapPath 方法可把指定的路径影射到服务器上相应的物理路径上。

注释：此方法不能用于 Session.OnEnd 和 Application.OnEnd 中。

Syntax

Server.MapPath(path)
参数 | 描述
path | 必需。映射为物理路径的相对路径或绝对路径。如果该参数以 / 或 \ 开头，则返回完整的虚拟路径。如果该参数不以 / 或 \ 开头，则返回相对于正在被处理的 .asp 文件的路径。

实例

实例 1

举例，文件 test.asp 位于 C:\Inetpub\wwwroot\Script。

文件 Test.asp (位于 C:\Inetpub\wwwroot\Script) 包含下列代码：

<%
response.write(Server.MapPath("test.asp") & "<br />")
response.write(Server.MapPath("script/test.asp") & "<br />")
response.write(Server.MapPath("/script/test.asp") & "<br />")
response.write(Server.MapPath("\script") & "<br />")
response.write(Server.MapPath("/") & "<br />")
response.write(Server.MapPath("\") & "<br />")
%>

输出：

c:\inetpub\wwwroot\script\test.asp
c:\inetpub\wwwroot\script\script\test.asp
c:\inetpub\wwwroot\script\test.asp
c:\inetpub\wwwroot\script
c:\inetpub\wwwroot
c:\inetpub\wwwroot

例子 2

如何使用一个相对路径来返回到达正在浏览器中查看的页面的相对物理路径：

<%
response.write(Server.MapPath("../"))
%>

或者：

<%
response.write(Server.MapPath("..\"))
%>

返回 Server 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Move 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Move 方法

返回 File 对象参考手册

定义和用法

Move 方法把指定的文件或文件从一个位置移动到另外一个位置。

注释：对 File 或 Folder 应用 Move 方法的结果与使用 FileSystemObject.MoveFile 或 FileSystemObject.MoveFolder 执行的操作完全相同。然而，要注意的是 FileSystemObject.MoveFile 或 FileSystemObject.MoveFolder 方法可移动多个文件或文件夹。

语法：

FileObject.Move(destination)
FolderObject.Move(destination)
参数 | 描述
destination | 必需的。移动文件或文件夹的目的地。允许使用通配符。

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
Set f=fs.GetFile("c:\test.txt")
f.Move("c:\test\test.txt")
set f=nothing
set fs=nothing
%>

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\test")
fo.Move("c:\asp\test")
set fo=nothing
set fs=nothing
%>

返回 File 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Move 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Move 方法

返回 Folder 对象参考手册

定义和用法

Move 方法把指定的文件或文件夹从一个位置移动到另一个位置。

语法：

FileObject.Move(destination)
FolderObject.Move(destination)
参数 | 描述
destination | 必需的。移动文件/文件夹的目的地。不允许使用通配符。

实例

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
Set f=fs.GetFile("d:\test.txt")
f.Move("d:\test\test.txt")
set f=nothing
set fs=nothing
%>

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("d:\test")
fo.Move("d:\asp\test")
set fo=nothing
set fs=nothing
%>

返回 Folder 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP MoveFile 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP MoveFile 方法

返回 Filesystem 对象参考手册

定义和用法

MoveFile 方法把一个或多个文件从一个位置移动到另一个位置。

语法：

FileSystemObject.MoveFile source,destination
参数 | 描述
source | 必需的。指向要移动的文件的路径。可在最后的成分中包含通配符。
destination | 必需的。移动文件的目的地。不能包含通配符。

实例

<%
dim fs
set fs=Server.CreateObject("Scripting.FileSystemObject")
fs.MoveFile "c:\web\*.gif","c:\images\"
set fs=nothing
%>

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP MoveFolder 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP MoveFolder 方法

返回 Filesystem 对象参考手册

定义和用法

MoveFolder 方法从一个位置向另一个位置移动一个或多个文件夹。

语法：

FileSystemObject.MoveFolder source,destination
参数 | 描述
source | 必需的。指向需被移动的文件夹的路径。可在最后的成分中包含通配符。
destination | 必需的。移动文件夹的目的地。不能包含通配符。

实例

<%
dim fs
set fs=Server.CreateObject("Scripting.FileSystemObject")
fs.MoveFolder "c:\test\web\","c:\windows\"
set fs=nothing
%>

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP MoveFolder 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP OpenTextFile 方法

返回 Filesystem 对象参考手册

定义和用法

OpenTextFile 方法打开指定的文件，并返回可用来访问此文件的 TextStream 对象。

语法：

FileSystemObject.OpenTextFile(fname,mode,create,format)
参数 | 描述
fname | 必需的。要打开的文件的名称。
mode 可选的。如何打开文件。
  • 1=ForReading - 打开文件用于读取数据。您无法向此文件写数据。
  • 2=ForWriting - 打开文件用于写数据。
  • 8=ForAppending - 打开文件，并向文件的末尾写数据。
create | 可选的。设置如果文件名不存在，是否创建新文件。True 指示可创建新文件，而 False 指示新文件不会被创建。False 是默认的。
format 可选的。文件的格式。
  • 0=TristateFalse - 以 ASCII 打开文件。默认。
  • -1=TristateTrue - 以 Unicode 打开文件。
  • -2=TristateUseDefault - 使用系统默认格式打开文件。

实例

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.OpenTextFile(Server.MapPath("testread.txt"),8,true)
f.WriteLine("This text will be added to the end of file")
f.Close
set f=Nothing
set fs=Nothing
%>

返回 Filesystem 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Name 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Name 属性

返回 File 对象参考手册

定义和用法

Name 属性用来设置或返回指定的文件或文件夹的名称。

语法：

FileObject.Name[=newname]
FolderObject.Name[=newname]
参数 | 描述
newname | 可选的。规定文件或文件夹的名称。

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:\help.txt")
Response.Write("The file's name: ")
Response.Write(f.Name)
set f=nothing
set fs=nothing
%>

输出：

The file's name: help.txt

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\help")
Response.Write("The folder's name: ")
Response.Write(fo.Name)
set fo=nothing
set fs=nothing
%>

输出：

The folder's name: help

返回 File 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Name 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Name 属性

返回 Folder 对象参考手册

定义和用法

Name 属性用于设置或返回指定的文件或文件夹的名称。

语法：

FileObject.Name[=newname]
FolderObject.Name[=newname]
参数 | 描述
newname | 可选的。规定文件或文件夹的名称。

实例

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("d:\test.txt")
Response.Write("The file's name: ")
Response.Write(f.Name)
set f=nothing
set fs=nothing
%>

输出：

The file's name: test.txt

返回 Folder 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP OpenAsTextStream 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP OpenAsTextStream 方法

返回 File 对象参考手册

定义和用法

OpenAsTextStream 方法打开指定的文件，并返回一个供访问此文件的 TextStream 对象。

语法：

FileObject.OpenAsTextStream(mode,format)
参数 描述
mode 可选的。如何打开文件（输入/输出模式）。
  • 1 = ForReading - 以只读模式打开文件。不能对此文件进行写操作。
  • 2 = ForWriting - 以可读写模式打开文件。如果已存在同名的文件，则覆盖旧的文件。
  • 8 = ForAppending - 打开文件并在文件末尾进行写操作。
format 可选的。以何种格式打开文件。忽略此参数，则文件以 ASCII 格式打开。
  • 0 = TristateFalse - 默认。以 ASCII 格式打开文件。
  • -1 = TristateTrue - 以 Unicode 文件打开文件。
  • -2 = TristateUseDefault - 使用系统默认格式打开文件。

实例

<%
dim fs,f,ts
set fs=Server.CreateObject("Scripting.FileSystemObject")
Set f=fs.GetFile("c:\test.txt")
Set ts=f.OpenAsTextStream(ForWriting)
ts.Write("Hello World!")
ts.Close

Set ts=f.OpenAsTextStream(ForReading)
Response.Write(ts.ReadAll)
ts.Close
set ts=nothing
set f=nothing
set fs=nothing
%>

输出：

Hello World!

返回 File 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP ParentFolder 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP ParentFolder 属性

返回 File 对象参考手册

定义和用法

ParentFolder 属性用于为指定的文件或文件夹的父级返回 folder 对象。

语法：

FileObject.ParentFolder
FolderObject.ParentFolder

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:\asp\test.asp")
Response.Write("The file test.asp is in the folder: ")
Response.Write(f.ParentFolder)
set f=nothing
set fs=nothing
%>

输出：

The file test.asp is in the folder: C:\asp

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\asp\test")
Response.Write("The folder test is in the folder: ")
Response.Write(fo.ParentFolder)
set fo=nothing
set fs=nothing
%>

输出：

The folder test is in the folder: C:\asp

返回 File 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP ParentFolder 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP ParentFolder 属性

返回 Folder 对象参考手册

定义和用法

ParentFolder 属性用于为指定的文件或文件夹的父文件夹返回 folder 对象。

语法：

FileObject.ParentFolder
FolderObject.ParentFolder

实例

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("d:\asp\test\test.asp")
Response.Write("The file test.asp is in the folder: ")
Response.Write(f.ParentFolder)
set f=nothing
set fs=nothing
%>

输出：

The file test.asp is in the folder: D:\asp\test

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("d:\asp\test")
Response.Write("The folder test is in the folder: ")
Response.Write(fo.ParentFolder)
set fo=nothing
set fs=nothing
%>

输出：

The folder test is in the folder: D:\asp

返回 Folder 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Path 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Path 属性

返回 Drive 对象参考手册

定义和用法

Path 属性用于返回指定驱动器、文件或文件夹的路径。

注释：对于驱动器，路径不包含根目录。例如，C 驱动器的路径是 C:，而不是 C:\。

语法：

DriveObject.Path
FileObject.Path
FolderObject.Path

针对 Drive 对象的例子

<%
dim fs,d
set fs=Server.CreateObject("Scripting.FileSystemObject")
set d=fs.GetDrive("c:")
Response.Write("The path is " & d.Path)
set d=nothing
set fs=nothing
%>

输出：

The path is C:

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:\asp\test\test.asp")
Response.Write("The path is: " & f.Path)
set f=nothing
set fs=nothing
%>

输出：

The path is: C:\asp\test\test.asp

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\asp\test")
Response.Write("The path is: " & fo.Path)
set fo=nothing
set fs=nothing
%>

输出：

The path is: C:\asp\test

返回 Drive 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Path 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Path 属性

返回 File 对象参考手册

定义和用法

Path 属性用于为指定的驱动器、文件或文件夹返回路径。

语法：

DriveObject.Path
FileObject.Path
FolderObject.Path

针对 Drive 对象的例子

<%
dim fs,d
set fs=Server.CreateObject("Scripting.FileSystemObject")
set d=fs.GetDrive("e:")
Response.Write("The path is " & d.Path)
set d=nothing
set fs=nothing
%>

输出：

The path is E:

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:\asp\test.asp")
Response.Write("The path is: " & f.Path)
set f=nothing
set fs=nothing
%>

输出：

The path is: C:\asp\test.asp

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\asp\test")
Response.Write("The path is: " & fo.Path)
set fo=nothing
set fs=nothing
%>

输出：

The path is: C:\asp\test

返回 File 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Path 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Path 属性

返回 Folder 对象参考手册

定义和用法

Path 属性用于返回指定的驱动器、文件或者文件的路径。

注释：对于驱动器，路径不包含根目录。例如，C 驱动器的路径是 C:，而不是 C:\。

语法：

DriveObject.Path
FileObject.Path
FolderObject.Path

实例

针对 Drive 对象的例子

<%
dim fs,d
set fs=Server.CreateObject("Scripting.FileSystemObject")
set d=fs.GetDrive("c:")
Response.Write("The path is " & d.Path)
set d=nothing
set fs=nothing
%>

输出：

The path is C:

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("d:\asp\test\test.asp")
Response.Write("The path is: " & f.Path)
set f=nothing
set fs=nothing
%>

输出：

The path is: D:\asp\test\test.asp

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("d:\asp\test")
Response.Write("The path is: " & fo.Path)
set fo=nothing
set fs=nothing
%>

输出：

The path is: D:\asp\test

返回 Folder 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP PICS 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP PICS 属性

返回 response 对象参考手册

PICS 属性可向响应头部的 PICS 标记追加值。

注释：此属性可接受任何字符串值，无论是否是合法的 PICS 标记。

什么是 PICS ？

PICS (Platform for Internet Content Selection) 分级系统用于对网站内的内容进行分级。它看起来类似这样：

PICS-1.1 "http://www.rsac.org/ratingsv01.html" by "your@name.com" for
"http://www.somesite.com" on "2002.10.05T02:15-0800" r (n 0 s 0 v
0 l 0)

部分 | 描述
PICS-1.1 | PICS 版本号
"http://www.rsac.org/ratingsv01.html" | 分级机构
by "your@name.com" | 标记的作者
for "http://www.somesite.com" | 已被分级的文档的 URL
on "2002.10.05T02:15-0800" | 失效日期
r (n 0 s 0 v 0 l 0) | 等级

最流行的分级系统之一是 RSACi (Recreational Software Advisory Council on the Internet) 。RSACi 使用四种类型：violence（暴力）、nudity（裸体）、 sex（性）以及language（不雅言论）。数字从 0 到 4分别分配给了这四种类型。0 表示页面不包含任何攻击性的内容，4 表示潜在攻击性内容的最高级别。

级别 | 暴力分级 | 裸体分级 | 性分级 | 言论分级
0 | None of the below or sports related | None of the below | None of the below or innocent kissing; romance | None of the below
1 | Injury to human being | Revealing attire | Passionate kissing | Mild expletives
2 | Destruction of realistic objects | Partial nudity | Clothed sexual touching | Moderate expletives or profanity
3 | Aggressive violence or death to humans | Frontal nudity | Non-explicit sexual acts | Strong language or hate speech
4 | Rape or wanton, gratuitous violence | Frontal nudity (qualifying as provocative display) | Explicit sexual acts or sex crimes | Crude, vulgar language or extreme hate speech

您有两种方式为您的网站获得评级。您可以自己为网站评级，或者利用一个评级提供者，比如 RSACi 。他们会要求您填写一些问题。在填写完成后，您会得到用于您的网站的分级标记。

Microsoft IE 3.0 及更高的版本和 Netscape 4.5 及更高的版本均支持内容分级。您可以在 IE 5 中设置分级，选择工具菜单中的 Internet 选项。选择内容选项卡，然后单击启用。当等级超过了所定义的级别，内容顾问就会阻止此网站。

我们可以使用 META 标签或者 response.PICS 属性为网站添加分级。

语法

response.PICS(picslabel)
参数 | 描述
picslabel | A properly formatted PICS label

实例

ASP 文件包含以下代码：

注释：由于 PICS 标记含有引号，您必须把引号替换为" & chr(34) & "

<%
response.PICS("(PICS-1.1 <http://www.rsac.org/ratingv01.html>
by " & chr(34) & "your@name.com" & chr(34) &
" for " & chr(34) & "http://www.somesite.com" & chr(34) &
" on " & chr(34) & "2002.10.05T02:15-0800" & chr(34) &
" r (n 2 s 0 v 1 l 2))")
%>

被添加的头部：

PICS-label:(PICS-1.1 <http://www.rsac.org/ratingv01.html>
by "your@name.com"
for "http://www.somesite.com"
on "2002.10.05T02:15-0800"
r (n 2 s 0 v 1 l 2))

返回 response 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP QueryString 集合

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP QueryString 集合

返回 Request 对象参考手册

定义和用法

QueryString 集合用于取回 HTTP 查询字符串中的变量值。

HTTP 查询字符串 (HTTP query string) 是由问号 (?) 之后的值规定的，比如：

<a href="test.asp?txt=this is a query string test">带有查询字符串的链接</a>

上面的代码可生成一个名为 txt 且值为 "this is a query string test"的变量。

查询字符串同样可以通过表单提交来生成，或者通过用户在浏览器的地址栏中输入查询。

语法

Request.QueryString(variable)[(index)|.Count]
参数 | 描述
variable | 必需。在 HTTP 查询字符串中要取回的变量名称。
index | 可选。为一个变量规定多个值之一。从 1 到 Request.QueryString(variable).Count

实例

例子 1

遍历查询字符串中所有变量 n 的值：

假设，这是被送出的请求：

http://www.w3school.com.cn/test/names.asp?n=John&n=Susan

而 names.asp 包含以下代码：

<%
for i=1 to Request.QueryString("n").Count
  Response.Write(Request.QueryString("n")(i) & "<br />")
next
%>

文件 names.asp 会显示出：

John
Susan

例子 2

假设，这是被送出的字符串：

http://www.w3school.com.cn/test/names.asp?name=John&age=30

上面的代码产生了以下 QUERY_STRING 值：

name=John&age=30

现在，我们可以通过脚本使用这些信息：

Hi, <%=Request.QueryString("name")%>.
Your age is <%= Request.QueryString("age")%>.

输出：

Hi, John. Your age is 30.

假如您没有规定任何要显示的变量值，比如这样：

Query string is: <%=Request.QueryString%>

输出将成为这样：

Query string is: name=John&age=30

返回 Request 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Read 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Read 方法

返回 Textstream 对象参考手册

定义和用法

Read 方法从 TextStream 文件中读取指定数量的字符，并以字符串返回结果。

语法：

TextStreamObject.Read(numchar)
参数 | 描述
numchar | 必需的。需从文件中读取字符的数目。

实例

<%
dim fs,f,t,x
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.CreateTextFile("c:\test.txt")
f.write("Hello World!")
f.close

set t=fs.OpenTextFile("c:\test.txt",1,false)
x=t.Read(5)
t.close
Response.Write("The first five characters are: " & x)
%>

输出：

The first five characters are: Hello

返回 Textstream 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP ReadAll 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP ReadAll 方法

返回 Textstream 对象参考手册

定义和用法

ReadAll 方法可读取整个 TextStream 文件，并以字符串返回结果。

注释：此方法不适合大型文件（会浪费内存资源）。

语法：

TextStreamObject.ReadAll

实例

<%
dim fs,f,t,x
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.CreateTextFile("c:\test.txt")
f.write("Hello World!")
f.close

set t=fs.OpenTextFile("c:\test.txt",1,false)
x=t.ReadAll
t.close
Response.Write("The text in the file is: " & x)
%>

输出：

The text in the file is: Hello World!

返回 Textstream 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP ReadLine 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP ReadLine 方法

返回 Textstream 对象参考手册

定义和用法

ReadLine 方法可从 TextStream 文件中读取一整行字符，并以字符串返回结果。

语法：

TextStreamObject.ReadLine

实例

<%
dim fs,f,t,x
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.CreateTextFile("c:\test.txt")
f.writeline("Line 1")
f.writeline("Line 2")
f.writeline("Line 3")
f.close

set t=fs.OpenTextFile("c:\test.txt",1,false)
x=t.ReadLine
t.close
Response.Write("The first line in the file ")
Response.Write("contains this text: " & x)
%>

输出：

The first line in the file contains this text: Line 1

返回 Textstream 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Redirect 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Redirect 方法

返回 response 对象参考手册

Redirect 方法把用户重定向到一个不同的 URL 。

语法

Response.Redirect URL
参数 | 描述
URL | 必需。用户浏览器被重定向的 URL。

实例

<%
Response.Redirect "http://www.w3school.com.cn"
%>

返回 response 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Remove 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Remove 方法

返回 Dictionary 对象参考手册

定义和用法

Remove 方法从 Dictionary 对象中删除指定的 key/item 对。

语法：

DictionaryObject.Remove(key)
参数 | 描述
key | 必需的。与需要删除的 key/item 对相关联的 key。

实例

<%
dim d,a,i
set d=Server.CreateObject("Scripting.Dictionary")
d.Add "c","China"
d.Add "i","Italy"
d.Add "s","Sweden"

d.Remove("s")

Response.Write("<p>Key values:</p>")
a=d.Keys
for i=0 to d.Count-1
  Response.Write(a(i))
  Response.Write("<br />")
next

set d=nothing
%>

输出：

Key values:
c
i

返回 Dictionary 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP RemoveAll 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP RemoveAll 方法

返回 Dictionary 对象参考手册

定义和用法

RemoveAll 方法从一个 Dictionary 对象中删除所有的 key/item 对。

语法：

DictionaryObject.RemoveAll

实例

<%
dim d,a,i
set d=Server.CreateObject("Scripting.Dictionary")
d.Add "c","China"
d.Add "i","Italy"
d.Add "s","Sweden"

d.RemoveAll

Response.Write("<p>Key values:</p>")
a=d.Keys
for i=0 to d.Count-1
  Response.Write(a(i))
  Response.Write("<br />")
next

set d=nothing
%>

输出：

Key values:
(nothing)

返回 Dictionary 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Request 对象

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Request 对象

  • Previous Page
  • Next Page

ASP Request 对象用于从用户那里取得信息。

实例

QueryString 集合 实例

当用户点击链接时发送查询信息
本例演示如何在链接中向页面发送一些额外的查询信息，并在目标页面中取回这些信息（在本例中是同一页面）。
对 QueryString 集合的简单应用
本例演示 QueryString 集合如何从表单取回值。此表单使用 GET 方法，这意外着所发送的信息对用户来说是可见的（在地址中）。GET 方法还会限制所发送信息的数量。
如何使用从表单传来的信息
本例演示如何使用从表单取回的值。我们会使用 QueryString 集合。此表单使用 GET 方法。
来自表单的更多信息
本例演示假如输入字段包含若干相同的名称的话，QueryString 会包含什么内容。它将展示如何把这些相同的名称分隔开来。它也会展示如何使用 count 关键词来对 "name" 属性进行计数。此表单使用 GET 方法。

Form 集合 实例

一个 Form 集合的简单应用
本例演示 Form 集合如何从表单取回值。此表单使用 POST 方法，这意味着发送的信息对用户来说是不可见的，并且对所发送信息的量没有限制（可发送大量的信息）。
如何使用来自表单的信息
本例演示如何使用从表单取回的信息。我们使用了 Form 集合。表单使用了 POST 方法。
来自表单的更多信息
本例演示假如若干的输入域使用了相同的名称，Form 集合会包含什么信息。它将展示如何把这些相同的名称分割开来。它也会展示如何使用 count 关键词来对 "name" 属性进行计数。此表单使用 POST 方法。
带有单选按钮的表单
本例演示如何使用 Form 集合通过单选按钮与用户进行交互。此表单使用 POST 方法。
带有复选按钮的表单
本例演示如何使用 Form 集合通过复选按钮与用户进行交互。此表单使用 POST 方法。

其他实例

获取用户信息
如何查明访问者的浏览器类型、IP 地址等信息。
获取服务器变量
本例演示如何使用 ServerVariables 集合取得访问者的浏览器类型、IP 地址等信息。
创建 welcome cookie
本例演示如何使用 Cookies 集合创建一个欢迎 cookie。
探测用户发送的字节总数
本例演示如何使用 TotalBytes 属性来取得用户在 Request 对象中发送的字节总数。

Request 对象

当浏览器向服务器请求页面时，这个行为就被称为一个 request（请求）。

ASP Request 对象用于从用户那里获取信息。它的集合、属性和方法描述如下：

集合

集合 | 描述
ClientCertificate | 包含了存储于客户证书中的域值（field values）
Cookies | 包含了 HTTP 请求中发送的所有 cookie 值
Form | 包含了使用 post 方法由表单发送的所有的表单（输入）值
QueryString | 包含了 HTTP 查询字符串中所有的变量值
ServerVariables | 包含了所有的服务器变量值

属性

属性 | 描述
TotalBytes | 返回在请求正文中客户端所发送的字节总数

方法

方法 | 描述
BinaryRead | 取回作为 post 请求的一部分而从客户端送往服务器的数据，并把它存放到一个安全的数组之中。
  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP Response 对象

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Response 对象

  • Previous Page
  • Next Page

ASP Response 对象用于从服务器向用户发送输出的结果。

实例

使用 ASP 写文本
本例演示如何使用 ASP 来写文本。
在 ASP 中使用 HTML 标签格式化文本
本例演示如何使用 ASP 将文本和 HTML 标签结合起来。
将用户重定向至不同的 URL
本例演示如何将用户重定向至另一个的 URL。
显示随机的链接
本例演示一个超级链接，当您每次载入页面时，它将显示两个链接中的其中一个。
控制缓存
本例演示如何控制缓存。
清空缓存
本例演示如何清空缓存。
在处理过程中终止脚本并返回结果
本例演示如何在处理过程中中断脚本的运行。
设置在页面失效前把页面在浏览器中缓存多少分钟
本例演示如何规定页面在失效前在浏览器中的缓存时间。
设置页面缓存在浏览器中的失效日期或时间
本例演示如何规定页面在浏览器中的缓存时间日期或时间
检查用户是否仍然与服务器相连
本例演示如何检查用户是否已与服务器断开。
设置内容类型
本例演示如何规定内容的类型。
设置字符集
本例演示如何规定字符集的名称。

Response 对象

ASP Response 对象用于从服务器向用户发送输出的结果。它的集合、属性和方法如下：

集合

集合 | 描述
Cookies | 设置 cookie 的值。假如不存在，就创建 cookie ，然后设置指定的值。

属性

属性 | 描述
Buffer | 规定是否缓存页面的输出。
CacheControl | 设置代理服务器是否可以缓存由 ASP 产生的输出。
Charset | 将字符集的名称追加到 Response 对象中的 content-type 报头。
ContentType | 设置 Response 对象的 HTTP 内容类型。
Expires | 设置页面在失效前的浏览器缓存时间（分钟）。
ExpiresAbsolute | 设置浏览器上页面缓存失效的日期和时间。
IsClientConnected | 指示客户端是否已从服务器断开。
Pics | 向 response 报头的 PICS 标志追加值。
Status | 规定由服务器返回的状态行的值。

方法

方法 | 描述
AddHeader | 向 HTTP 响应添加新的 HTTP 报头和值。
AppendToLog | 向服务器记录项目（server log entry）的末端添加字符串。
BinaryWrite | 在没有任何字符转换的情况下直接向输出写数据。
Clear | 清除已缓存的 HTML 输出。
End | 停止处理脚本，并返回当前的结果。
Flush | 立即发送已缓存的 HTML 输出。
Redirect | 把用户重定向到另一个 URL。
Write | 向输出写指定的字符串。
  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP RootFolder 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP RootFolder 属性

返回 Drive 对象参考手册

定义和用法

RootFolder 属性返回一个 Folder 对象，代表指定驱动器的根文件夹 。

注释：使用返回的 Folder 对象，可以访问指定驱动器包含的所有文件和文件夹。

语法：

DriveObject.RootFolder

例子

<%
dim fs,d
set fs=Server.CreateObject("Scripting.FileSystemObject")
set d=fs.GetDrive("d:")
Response.Write("The root folder is: " & d.RootFolder)
set d=nothing
set fs=nothing
%>

输出：

The root folder is: D:\

返回 Drive 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP ScriptTimeout 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP ScriptTimeout 属性

返回 Server 对象参考手册

定义和用法

ScriptTimeout 属性设置或返回脚本在被终止前可运行的最大秒数。

语法

Server.ScriptTimeout[=NumSeconds]
参数 | 描述
NumSeconds | 脚本在被终止前可运行的最大秒数。默认是 90 秒。

实例

例子 1

设置脚本的超时：

<%
Server.ScriptTimeout=200
%>

例子 2

取回 ScriptTimeout 属性的当前值：

<%
response.write(Server.ScriptTimeout)
%>

返回 Server 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP SerialNumber 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP SerialNumber 属性

返回 Drive 对象参考手册

定义和用法

SerialNumber 属性返回指定驱动器的序列号。

注释：可以使用 SerialNumber 属性以确保在可移动媒介驱动器中插入正确的磁盘。

语法：

DriveObject.SerialNumber

例子

<%
dim fs,d
set fs=Server.CreateObject("Scripting.FileSystemObject")
set d=fs.GetDrive("c:")
Response.Write("The serial number is: " & d.SerialNumber)
set d=nothing
set fs=nothing
%>

输出：

The serial number is: 578680518

返回 Drive 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Server 对象

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Server 对象

  • Previous Page
  • Next Page

ASP Server 对象的作用是访问有关服务器的属性和方法。

实例

此文件最后被修改的时间是？
探测文件的最后更新时间。
打开并读取某个文本文件
本例会打开文件 "Textfile.txt" 以供读取。
自制的点击计数器
本例可从一个文件中读取一个数字，并在此数字上累加 1，然后将此数写回这个文件。

Server 对象

ASP Server 对象的作用是访问有关服务器的属性和方法。其属性和方法描述如下：

属性

属性 | 描述
ScriptTimeout | 设置或返回在一段脚本终止前它所能运行时间（秒）的最大值。

方法

方法 | 描述
CreateObject | 创建对象的实例（instance）。
Execute | 从另一个 ASP 文件中执行一个 ASP 文件。
GetLastError() | 返回可描述已发生错误状态的 ASPError 对象。
HTMLEncode | 将 HTML 编码应用到某个指定的字符串。
MapPath | 将一个指定的地址映射到一个物理地址。
Transfer | 把一个 ASP 文件中创建的所有信息传输到另一个 ASP 文件。
URLEncode | 把 URL 编码规则应用到指定的字符串。
  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP ServerVariables 集合

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP ServerVariables 集合

返回 Request 对象参考手册

定义和用法

ServerVariables 集合用于取回服务器变量的值。

语法

Request.ServerVariables (server_variable)
参数 | 描述
server_variable | 必需。要取回的服务器变量的名称。

服务器变量

变量 | 描述
ALL_HTTP | Returns all HTTP headers sent by the client. Always prefixed with HTTP_ and capitalized
ALL_RAW | Returns all headers in raw form
APPL_MD_PATH | Returns the meta base path for the application for the ISAPI DLL
APPL_PHYSICAL_PATH | Returns the physical path corresponding to the meta base path
AUTH_PASSWORD | Returns the value entered in the client's authentication dialog
AUTH_TYPE | The authentication method that the server uses to validate users
AUTH_USER | Returns the raw authenticated user name
CERT_COOKIE | Returns the unique ID for client certificate as a string
CERT_FLAGS | bit0 is set to 1 if the client certificate is present and bit1 is set to 1 if the cCertification authority of the client certificate is not valid
CERT_ISSUER | Returns the issuer field of the client certificate
CERT_KEYSIZE | Returns the number of bits in Secure Sockets Layer connection key size
CERT_SECRETKEYSIZE | Returns the number of bits in server certificate private key
CERT_SERIALNUMBER | Returns the serial number field of the client certificate
CERT_SERVER_ISSUER | Returns the issuer field of the server certificate
CERT_SERVER_SUBJECT | Returns the subject field of the server certificate
CERT_SUBJECT | Returns the subject field of the client certificate
CONTENT_LENGTH | Returns the length of the content as sent by the client
CONTENT_TYPE | Returns the data type of the content
GATEWAY_INTERFACE | Returns the revision of the CGI specification used by the server
HTTP_<HeaderName> | Returns the value stored in the header HeaderName
HTTP_ACCEPT | Returns the value of the Accept header
HTTP_ACCEPT_LANGUAGE | Returns a string describing the language to use for displaying content
HTTP_COOKIE | Returns the cookie string included with the request
HTTP_REFERER | Returns a string containing the URL of the page that referred the request to the current page using an <a> tag. If the page is redirected, HTTP_REFERER is empty
HTTP_USER_AGENT | Returns a string describing the browser that sent the request
HTTPS | Returns ON if the request came in through secure channel or OFF if the request came in through a non-secure channel
HTTPS_KEYSIZE | Returns the number of bits in Secure Sockets Layer connection key size
HTTPS_SECRETKEYSIZE | Returns the number of bits in server certificate private key
HTTPS_SERVER_ISSUER | Returns the issuer field of the server certificate
HTTPS_SERVER_SUBJECT | Returns the subject field of the server certificate
INSTANCE_ID | The ID for the IIS instance in text format
INSTANCE_META_PATH | The meta base path for the instance of IIS that responds to the request
LOCAL_ADDR | Returns the server address on which the request came in
LOGON_USER | Returns the Windows account that the user is logged into
PATH_INFO | Returns extra path information as given by the client
PATH_TRANSLATED | A translated version of PATH_INFO that takes the path and performs any necessary virtual-to-physical mapping
QUERY_STRING | Returns the query information stored in the string following the question mark (?) in the HTTP request
REMOTE_ADDR | Returns the IP address of the remote host making the request
REMOTE_HOST | Returns the name of the host making the request
REMOTE_USER | Returns an unmapped user-name string sent in by the user
REQUEST_METHOD | Returns the method used to make the request
SCRIPT_NAME | Returns a virtual path to the script being executed
SERVER_NAME | Returns the server's host name, DNS alias, or IP address as it would appear in self-referencing URLs
SERVER_PORT | Returns the port number to which the request was sent
SERVER_PORT_SECURE | Returns a string that contains 0 or 1. If the request is being handled on the secure port, it will be 1. Otherwise, it will be 0
SERVER_PROTOCOL | Returns the name and revision of the request information protocol
SERVER_SOFTWARE | Returns the name and version of the server software that answers the request and runs the gateway
URL | Returns the base portion of the URL

实例

例子 1

您可以像这样来循环遍历所有的服务器变量：

<%
for each x in Request.ServerVariables
response.write(x & "<br />")
next
%>

例子 2

本例演示了如何查明访问者浏览器的类型、IP 地址等等：

<html>
<body>
<p>
<b>You are browsing this site with:</b>
<%Response.Write(Request.ServerVariables("http_user_agent"))%>
</p>
<p>
<b>Your IP address is:</b>
<%Response.Write(Request.ServerVariables("remote_addr"))%>
</p>
<p>
<b>The DNS lookup of the IP address is:</b>
<%Response.Write(Request.ServerVariables("remote_host"))%>
</p>
<p>
<b>The method used to call the page:</b>
<%Response.Write(Request.ServerVariables("request_method"))%>
</p>
<p>
<b>The server's domain name:</b>
<%Response.Write(Request.ServerVariables("server_name"))%>
</p>
<p>
<b>The server's port:</b>
<%Response.Write(Request.ServerVariables("server_port"))%>
</p>
<p>
<b>The server's software:</b>
<%Response.Write(Request.ServerVariables("server_software"))%>
</p>
</body>
</html>

返回 Request 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Session_OnStart 和 Session_OnEnd 事件

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Session_OnStart 和 Session_OnEnd 事件

返回 Session 对象参考手册

定义和用法

Session_OnStart Event

Session_OnStart 事件在服务器创建新会话时发生。

此事件放置在 Global.asa 文件中。

Session_OnEnd Event

Session_OnEnd 事件在会话结束时发生。 (会话被放弃或超时的时候).

此事件放置在 Global.asa 文件中。

注释：MapPath 方法不能用在 Session_OnEnd 代码中。

语法

<script language="vbscript" runat="server">

Sub Session_OnStart
. . .
End Sub

Sub Session_OnEnd
. . .
End Sub

</script>

实例

Global.asa:

<script language="vbscript" runat="server">

Sub Application_OnEnd()
Application("totvisitors")=Application("visitors")
End Sub

Sub Application_OnStart
Application("visitors")=0
End Sub

Sub Session_OnStart
Application.Lock
Application("visitors")=Application("visitors")+1
Application.UnLock
End Sub

Sub Session_OnEnd
Application.Lock
Application("visitors")=Application("visitors")-1
Application.UnLock
End Sub

</script>

在 ASP 文件中显示当前的访客数：

<html>
<head>
</head>
<body>
<p>
There are <%response.write(Application("visitors"))%>
online now!
</p>
</body>
</html>

返回 Session 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Session 对象

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Session 对象

  • Previous Page
  • Next Page

Session 对象用于存储用户的信息。存储于 session 对象中的变量握有单一用户的信息，并且对于一个应用程序中的所有页面都是可用的。

Session 对象

当您操作某个应用程序时，您打开它，做些改变，然后将它关闭。这很像一次对话（Session）。计算机知道您是谁。它清楚您在何时打开和关闭应用程序。但是在因特网上有一个问题：由于 HTTP 地址无法存留状态，web 服务器并不知道您是谁以及您做什么。

ASP 通过为每位用户创建一个唯一的 cookie 的方式解决了这个问题。cookie 被传送至客户端，它含有可识别用户的信息。这种接口被称作 Session 对象。

Session 对象用于存储关于用户的信息，或者为一个用户的 session 更改设置。存储于 session 对象中的变量握有单一用户的信息，并且对于应用程序中的所有页面都是可用的。存储于 session 对象中的信息通常是 name、id 以及参数。服务器会为每个新的用户创建一个新的 Session，并在 session 到期时撤销掉这个 Session 对象。

Session 何时开始？

Session 开始于：

  • 当某个新用户请求了一个 ASP 文件，并且 Global.asa 文件引用了 Session_OnStart 子程序时；
  • 当某个值存储在 Session 变量中时；
  • 当某个用户请求了一个 ASP 文件，并且 Global.asa 使用 <object> 标签通过 session 的 scope 来例示某个对象时；

Session 何时结束?

假如用户没有在规定的时间内在应用程序中请求或者刷新页面，session 就会结束。默认值为 20 分钟。

如果您希望将超时的时间间隔设置得更长或更短，可以设置 Timeout 属性。

下面的例子设置了 5 分钟的超时时间间隔：

<%
Session.Timeout=5
%>

要立即结束 session，可使用 Abandon 方法：

<%
Session.Abandon
%>

注意：使用 session 时主要的问题是它们该在何时结束。我们不会知道用户最近的请求是否是最后的请求。因此我们不清楚该让 session“ 存活”多久。为某个空闲的 session 等待太久会耗尽服务器的资源。然而假如 session 被过早地删除，那么用户就不得不一遍又一遍地重新开始，这是因为服务器已经删除了所有的信息。寻找合适的超时间隔时间是很困难的。

提示：如果您正在使用 session 变量，请不要在其中存储大量的数据。

存储和取回 session 变量

Session 对象最大的优点是可在其中存储变量，以供后续的网页读取，其应用范围是很广的。

下面的例子把 "Donald Duck" 赋值给名为 username 的 session 变量，并把 "50" 赋值给名为 age 的 session 变量：

<%
Session("username")="Donald Duck"
Session("age")=50
%>

一旦值被存入 session 变量，它就能被 ASP 应用程序中的任何页面使用：

Welcome <%Response.Write(Session("username"))%>

上面这行程序返回的结果是: "Welcome Donald Duck"。

也可以在 session 对象中保存用户参数，然后通过访问这些参数来决定向用户返回什么页面。

下面的例子规定，假如用户使用低显示器分辨率，则返回纯文本版本的页面：

<%If Session("screenres")="low" Then%>
  This is the text version of the page
<%Else%>
  This is the multimedia version of the page
<%End If%>

移除 session 变量

contents 集合包含所有的 session 变量。

可通过 remove 方法来移除 session 变量。

在下面的例子中，假如 session 变量 "age" 的值小于 18，则移除 session 变量 "sale"：

<%
If Session.Contents("age")<18 then
  Session.Contents.Remove("sale")
End If
%>

如需移除 session 中的所有变量，请使用 RemoveAll 方法：

<%
Session.Contents.RemoveAll()
%>

遍历 contents 集合

contents 集合包含所有的 session 变量。可通过遍历 contents 集合，来查看其中存储的变量：

<%
Session("username")="Donald Duck"
Session("age")=50

dim i
For Each i in Session.Contents
  Response.Write(i & "<br />")
Next
%>

结果：

username
age

如果需要了解 contents 集合中的项目数量，可使用 count 属性：

<%
dim i
dim j
j=Session.Contents.Count
Response.Write("Session variables: " & j)
For i=1 to j
  Response.Write(Session.Contents(i) & "<br />")
Next
%>

结果：

Session variables: 2
Donald Duck
50

遍历 StaticObjects 集合

可通过循环 StaticObjects 集合，来查看存储在 session 对象中所有对象的值：

<%
dim i
For Each i in Session.StaticObjects
  Response.Write(i & "<br />")
Next
%>
  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP Session 对象

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Session 对象

  • Previous Page
  • Next Page

Session 对象用于存储关于某个用户会话（session）的信息，或者修改相关的设置。存储在 session 对象中的变量掌握着单一用户的信息，同时这些信息对于页面中的所有页面都是可用的。

实例

设置并返回 LCID
本例演示 "LCID" 属性。此属性设置并返回一个指示位置或者地区的整数。类似于日期、时间以及货币等内容都要根据位置或者地区来显示。
返回 SessionID
本例演示 "SessionID" 属性。该属性为每位用户返回一个唯一的 id。这个 id 由服务器生成。
session 的超时
本例演示 "Timeout" 属性。这个例子设置并返回 session 的超时时间（分钟）。

Session 对象

当您正在操作一个应用程序时，您会启动它，然后做些改变，随后关闭它。这个过程很像一次对话（Session）。计算机知道你是谁。它也知道你在何时启动和关闭这个应用程序。但是在因特网上，问题出现了：web 服务器不知道你是谁，也不知道你做什么，这是由于 HTTP 地址无法留存状态（信息）。

ASP 通过为每个用户创一个唯一的 cookie 解决了这个问题。cookie 发送到服务器，它包含了可识别用户的信息。这个接口称作 Session 对象。

Session 对象用于存储关于某个用户会话（session）的信息，或者修改相关的设置。存储在 session 对象中的变量掌握着单一用户的信息，同时这些信息对于页面中的所有页面都是可用的。存储于 session 变量中的信息通常是 name、id 以及参数等。服务器会为每位新用户创建一个新的 Session 对象，并在 session 到期后撤销这个对象。

下面是 Session 对象的集合、属性、方法以及事件：

集合

集合 | 描述
Contents | 包含所有通过脚本命令追加到 session 的条目。
StaticObjects | 包含了所有使用 HTML 的 <object> 标签追加到 session 的对象。

属性

属性 | 描述
CodePage | 规定显示动态内容时使用的字符集
LCID | 设置或返回指定位置或者地区的一个整数。诸如日期、时间以及货币的内容会根据位置或者地区来显示。
SessionID | 为每个用户返回一个唯一的 id。此 id 由服务器生成。
Timeout | 设置或返回应用程序中的 session 对象的超时时间（分钟）。

方法

方法 | 描述
Abandon | 撤销一个用户的 session。
Contents.Remove | 从 Contents 集合删除一个项目。
Contents.RemoveAll() | 从 Contents 集合删除全部项目。

事件

事件 | 描述
Session_OnEnd | 当一个会话结束时此事件发生。
Session_OnStart | 当一个会话开始时此事件发生。
  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP SessionID 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP SessionID 属性

返回 Session 对象参考手册

定义和用法

SessionID 属性为每个用户返回一个唯一的 id 。此 id 由服务器生成。

语法

Session.SessionID

实例

<%
Response.Write(Session.SessionID)
%>

输出了您的 SessionID ：

965150612

返回 Session 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP SessionID 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP SessionID 属性

返回 Session 对象参考手册

定义和用法

Timeout 属性按分钟设置或返回应用程序的 Session 对象的超时周期。如果用户在此超时周期内没有刷新或请求页面，会话就会被终止。

语法

Session.Timeout[=nMinutes]
参数 | 描述
nMinutes | session 在服务器终止它之前可保持空闲的分钟值。默认是 20 分钟。

实例

<%
response.write("<p>")
response.write("Default Timeout is: " & Session.Timeout)
response.write("</p>")

Session.Timeout=30

response.write("<p>")
response.write("Timeout is now: " & Session.Timeout)
response.write("</p>")
%>

输出：

Default Timeout is: 20
Timeout is now: 30

返回 Session 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP ShareName 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP ShareName 属性

返回 Drive 对象参考手册

定义和用法

ShareName 属性返回指定驱动器的网络共享名称。

注释：如果对象不是一个网络驱动器，则 ShareName 属性返回零长度字符串 ("")。

语法：

DriveObject.ShareName

例子

<%
dim fs,d
set fs=Server.CreateObject("Scripting.FileSystemObject")
set d=fs.GetDrive("c:")
Response.Write("The sharename is: " & d.ShareName)
set d=nothing
set fs=nothing
%>

返回 Drive 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP ShortName 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP ShortName 属性

返回 File 对象参考手册

定义和用法

ShortName 属性用于指定的文件或文件夹的短名称 (8.3 文件命名约定)。

语法：

FileObject.ShortName
FolderObject.ShortName

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:\hitcounterfile.txt"))
Response.Write("Name: " & f.Name)
Response.Write("<br />ShortName: " & f.ShortName)
set f=nothing
set fs=nothing
%>

输出：

Name: hitcounterfile.txt
ShortName: HITCOU~1.TXT

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\asp_test_web")
Response.Write("Name: " & fo.Name)
Response.Write("<br />ShortName: " & fo.ShortName)
set fo=nothing
set fs=nothing
%>

输出：

Name: asp_test_web
ShortName: ASP_TE~1

返回 File 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP ShortName 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP ShortName 属性

返回 Folder 对象参考手册

定义和用法

ShortName 属性用于返回指定的文件或文件夹的短名称 (8.3 命名约定)。

语法：

FileObject.ShortName
FolderObject.ShortName

实例

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:\hitcounterfile.txt"))
Response.Write("Name: " & f.Name)
Response.Write("<br />ShortName: " & f.ShortName)
set f=nothing
set fs=nothing
%>

输出：

Name: hitcounterfile.txt
ShortName: HITCOU~1.TXT

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\asp_test_web")
Response.Write("Name: " & fo.Name)
Response.Write("<br />ShortName: " & fo.ShortName)
set fo=nothing
set fs=nothing
%>

输出：

Name: asp_test_web
ShortName: ASP_TE~1

返回 Folder 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP ShortPath 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP ShortPath 属性

返回 File 对象参考手册

定义和用法

ShortPath 属性用于返回指定的文件或文件夹的短路径。(8.3 文件命名约定)。

语法：

FileObject.ShortPath
FolderObject.ShortPath

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:\asp_test_web\hitcounterfile.txt")
Response.Write("Path: " & f.Path)
Response.Write("<br />ShortPath: " & f.ShortPath)
set f=nothing
set fs=nothing
%>

输出：

Path: C:\asp_test_web\hitcounterfile.txt
ShortPath: C:\ASP_TE~1\HITCOU~1.TXT

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\asp_test_web")
Response.Write("Path: " & fo.Path)
Response.Write("<br />ShortPath: " & fo.ShortPath)
set fo=nothing
set fs=nothing
%>

输出：

Path: C:\asp_test_web
ShortPath: C:\ASP_TE~1

返回 File 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP ShortPath 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP ShortPath 属性

返回 Folder 对象参考手册

定义和用法

ShortPath 属性用于返回指定的文件或文件夹的短路径 (8.3 命名约定)。

语法：

FileObject.ShortPath
FolderObject.ShortPath

实例

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:\asp_test_web\hitcounterfile.txt")
Response.Write("Path: " & f.Path)
Response.Write("<br />ShortPath: " & f.ShortPath)
set f=nothing
set fs=nothing
%>

输出：

Path: C:\asp_test_web\hitcounterfile.txt
ShortPath: C:\ASP_TE~1\HITCOU~1.TXT

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\asp_test_web")
Response.Write("Path: " & fo.Path)
Response.Write("<br />ShortPath: " & fo.ShortPath)
set fo=nothing
set fs=nothing
%>

输出：

Path: C:\asp_test_web
ShortPath: C:\ASP_TE~1

返回 Folder 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Size 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Size 属性

返回 File 对象参考手册

定义和用法

Size 属性用于返回指定文件或文件夹的字节数。

语法：

FileObject.Size
FolderObject.Size

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:\help.asp")
Response.Write("The size of test.asp is: ")
Response.Write(f.Size & " bytes.")
set f=nothing
set fs=nothing
%>

输出：

The size of help.asp is: 15606 bytes.

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\help")
Response.Write("The size of the folder test is: ")
Response.Write(fo.Size & " bytes.")
set fo=nothing
set fs=nothing
%>

输出：

The size of the folder help is: 123456 bytes.

返回 File 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Size 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Size 属性

返回 Folder 对象参考手册

定义和用法

Size 属性用于返回指定的文件或文件夹的字节数。

语法：

FileObject.Size
FolderObject.Size

实例

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:\test.asp")
Response.Write("The size of test.asp is: ")
Response.Write(f.Size & " bytes.")
set f=nothing
set fs=nothing
%>

输出：

The size of test.asp is: 18665 bytes.

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\test")
Response.Write("The size of the folder test is: ")
Response.Write(fo.Size & " bytes.")
set fo=nothing
set fs=nothing
%>

输出：

The size of the folder test is: 652398 bytes.

返回 Folder 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Skip 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Skip 方法

返回 Textstream 对象参考手册

定义和用法

Skip 方法在读取 TextStream 文件时跳过指定的字符数目。

语法：

TextStreamObject.Skip(numchar)
参数 | 描述
numchar | 必需的。需要跳过的字符数目。

实例

<%
dim fs,f,t,x
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.CreateTextFile("c:\test.txt")
f.write("Hello World!")
f.close

set t=fs.OpenTextFile("c:\test.txt",1,false)
t.Skip(7)
x=t.ReadAll
t.close
Response.Write("The output after skipping some characters: " & x)
%>

输出：

The output after skipping some characters: orld!

返回 Textstream 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP SkipLine 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP SkipLine 方法

返回 Textstream 对象参考手册

定义和用法

SkipLine 方法在读取 TextStream 文件时跳过一行。

语法：

TextStreamObject.SkipLine

实例

<%
dim fs,f,t,x
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.CreateTextFile("c:\test.txt")
f.writeline("Line 1")
f.writeline("Line 2")
f.writeline("Line 3")
f.close

set t=fs.OpenTextFile("c:\test.txt",1,false)
t.SkipLine
x=t.ReadAll
t.close
Response.Write("Output after skipping the first ")
Response.Write(" line in the file: " & x)
%>

输出：

Output after skipping the first line in the file: Line 2
Line 3

返回 Textstream 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP StaticObjects 集合

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP StaticObjects 集合

返回 Application 对象参考手册

定义和用法

StaticObjects 集合包含所有使用 HTML 的 <object> 标签追加到 application/session 的对象。

语法

Application.StaticObjects(Key)

Session.StaticObjects(Key)
参数 | 描述
key | 必需。要取回的项目的名称。

针对 Application 对象的实例

例子 1

循环遍历 StaticObjects 集合：

<%
for each x in Application.StaticObjects
  Response.Write(x & "<br />")
next
%>

例子 2

在 Global.asa 中：

<object runat="server" scope="application"
id="MsgBoard" progid="msgboard.MsgBoard">
</object>

<object runat="server" scope="application"
id="AdRot" progid="MSWC.AdRotator">
</object>

在 ASP 文件中：

<%
for each x in Application.StaticObjects
  Response.Write(x & "<br />")
next
%>

输出：

MsgBoard
AdRot

针对 Session 对象的实例：

例子 1

循环遍历 StaticObjects 集合：

<%
for each x in Session.StaticObjects
  Response.Write(x & "<br />")
next
%>

例子 2

在 Global.asa 中：

<object runat="server" scope="session"
id="MsgBoard" progid="msgboard.MsgBoard">
</object>

<object runat="server" scope="session"
id="AdRot" progid="MSWC.AdRotator">
</object>

在 ASP 文件中：

<%
for each x in Session.StaticObjects
  Response.Write(x & "<br />")
next
%>

输出：

MsgBoard
AdRot

返回 Application 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Status 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Status 属性

返回 response 对象参考手册

Status 属性规定由服务器返回的状态行的值。

提示：请使用此属性来修改由服务器返回的状态行。

语法

response.Status=statusdescription
参数 | 描述
statusdescription | 三位数的数字，以及代码的描述，比如 404 Not Found 。 注释：状态值是在 HTTP 规范中定义的。

实例

<%
ip=request.ServerVariables("REMOTE_ADDR")
if ip<>"194.248.333.500" then
  response.Status="401 Unauthorized"
  response.Write(response.Status)
  response.End
end if
%>

返回 response 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP SubFolders 集合

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP SubFolders 集合

返回 Folder 对象参考手册

定义和用法

SubFolders 集合可返回指定的文件夹中所有子文件夹组成的的一个集合。

语法：

FolderObject.SubFolders

实例

<%
dim fs,fo,x
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\test\")

for each x in fo.SubFolders
  'Print the name of all subfolders in the test folder
  Response.write(x.Name & "<br />")
next

set fo=nothing
set fs=nothing
%>

输出类似这样：

css
html
xml
asp
JavaScript

返回 Folder 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP TextStream 对象

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP TextStream 对象

  • Previous Page
  • Next Page

TextStream 对象用于访问文本文件的内容。

实例

读文件
本例演示如何使用 FileSystemObject 的 OpenTextFile 方法来创建一个 TextStream 对象。TextStream 对象的 ReadAll 方法会从已打开的文本文件中取得内容。
读文本文件中的一个部分
本例演示如何仅仅读取一个文本流文件的部分内容。
读文本文件中的一行
本例演示如何从一个文本流文件中读取一行内容。
读取文本文件的所有行
本例演示如何从文本流文件中读取所有的行。
略过文本文件的一部分
本例演示如何在读取文本流文件时跳过指定的字符数。
略过文本文件的一行
本例演示如何在读取文本流文件时跳过一行。
返回行数
本例演示如何返回在文本流文件中的当前行号。
取得列数
本例演示如何取得在文件中当前字符的列号。

TextStream 对象

TextStream 对象用于访问文本文件的内容。

下面的代码会创建一个文本文件 (c:\test.txt)，然后向此文件写一些文本（变量 f 是 TextStream 对象的一个实例）：

<%
dim fs, f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.CreateTextFile("c:\test.txt",true)
f.WriteLine("Hello World!")
f.Close
set f=nothing
set fs=nothing
%>

如需创建TextStream对象的一个实例，我们可以使用 FileSystemObject 对象的 CreateTextFile 方法或者 OpenTextFile 方法，也可以使用 File 对象的 OpenAsTextStream 方法。

TextStream 对象的属性和方法描述如下：

属性

属性 | 描述
AtEndOfLine | 在 TextStream 文件中，如果文件指针正好位于行尾标记的前面，那么该属性值返回 True；否则返回 False。
AtEndOfStream | 如果文件指针在 TextStream 文件末尾，则该属性值返回 True；否则返回 False。
Column | 返回 TextStream 文件中当前字符位置的列号。
Line | 返回 TextStream 文件中的当前行号。

方法

方法 | 描述
Close | 关闭一个打开的 TextStream 文件。
Read | 从一个 TextStream 文件中读取指定数量的字符并返回结果（得到的字符串）。
ReadAll | 读取整个 TextStream 文件并返回结果。
ReadLine | 从一个 TextStream 文件读取一整行（到换行符但不包括换行符）并返回结果。
Skip | 当读一个 TextStream 文件时跳过指定数量的字符。
SkipLine | 当读一个 TextStream 文件时跳过下一行。
Write | 写一段指定的文本（字符串）到一个 TextStream 文件。
WriteLine | 写入一段指定的文本（字符串）和换行符到一个 TextStream 文件中。
WriteBlankLines | 写入指定数量的换行符到一个 TextStream 文件中。
  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP TotalBytes 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP TotalBytes 属性

返回 Request 对象参考手册

定义和用法

TotalBytes 属性是一个只读的属性，可返回在客户端发送的请求正文中的字节总数。

语法

varbytes=Request.Totalbytes

Example

下面的代码把一个变量设置为请求正文发送的字节总数：

<%
dim a
a=Request.TotalBytes
%>

返回 Request 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP TotalSize 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP TotalSize 属性

返回 Drive 对象参考手册

定义和用法

TotalSize 属性返回指定驱动器或网络共享的总字节数。

语法：

DriveObject.TotalSize

例子

<%
dim fs,d
set fs=Server.CreateObject("Scripting.FileSystemObject")
set d=fs.GetDrive("c:")
Response.Write("The total size in bytes is: " & d.TotalSize)
set d=nothing
set fs=nothing
%>

输出：

The total size in bytes is: 9693563395

返回 Drive 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Transfer 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Transfer 方法

返回 Server 对象参考手册

定义和用法

Transfer 方法把一个 ASP 文件中创建的所有状态信息（所有 application/session 变量以及所有 request 集合中的项目）发送（传输）到另一个 ASP 文件中。

当第二个 ASP 完成任何时，它不会返回到第一个 ASP 页面。

注释：Transfer 方法是 Response.Redirect 的一个高效的替代方案。重定向强制 Web 服务器处理额外的请求，而 Server.Transfer 在服务器上向另外的 ASP 页面传输执行，避免了额外的周折。

语法

Server.Transfer(path)
参数 | 描述
path | 必需。ASP 文件的位置。向这个 ASP 文件转移控制权。

实例

File1.asp:

<%
response.write("Line 1 in File 1<br />")
Server.Transfer("file2.asp")
response.write("Line 2 in File 1<br />")
%>

File2.asp:

<%
response.write("Line 1 in File 2<br />")
response.write("Line 2 in File 2<br />")
%>

输出：

Line 1 in File 1
Line 1 in File 2
Line 2 in File 2

返回 Server 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Type 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Type 属性

返回 File 对象参考手册

定义和用法

Type 属性用于返回指定的文件或文件夹的类型。

语法：

FileObject.Type
FolderObject.Type

针对 File 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:help.txt")
Response.Write("The file test.txt is of type: ")
Response.Write(f.Type)
set f=nothing
set fs=nothing
%>

输出：

The file help.txt is of type: Text Document

针对 Folder 对象的例子

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:help.asp")
Response.Write("The file test.asp is of type: ")
Response.Write(f.Type)
set f=nothing
set fs=nothing
%>

输出：

The file help.asp is of type: Active Server Document

返回 File 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Type 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Type 属性

返回 Folder 对象参考手册

定义和用法

Type 属性用于返回指定的文件或文件夹的类型。

语法：

FileObject.Type
FolderObject.Type

针对 File 对象的例子

例子 1

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:test.txt")
Response.Write("The file test.txt is of type: ")
Response.Write(f.Type)
set f=nothing
set fs=nothing
%>

输出：

The file test.txt is of type: Text Document

例子 2

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile("c:test.asp")
Response.Write("The file test.asp is of type: ")
Response.Write(f.Type)
set f=nothing
set fs=nothing
%>

输出：

The file test.asp is of type: Active Server Document

针对 Folder 对象的例子

<%
dim fs,fo
set fs=Server.CreateObject("Scripting.FileSystemObject")
set fo=fs.GetFolder("c:\test")
Response.Write("The folder test is of type: ")
Response.Write(fo.Type)
set fo=nothing
set fs=nothing
%>

输出：

The folder test is of type: File Folder

返回 Folder 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP URLEncode 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP URLEncode 方法

返回 Server 对象参考手册

定义和用法

URLEncode 方法把 URL 编码规则应用到指定的字符串。

Syntax

Server.URLEncode(string)
参数 | 描述
string | 必需。要编码的字符串。

实例

<%
response.write(Server.URLEncode("http://www.w3school.com.cn"))
%>

输出

http%3A%2F%2Fwww%2Ew3school%2Ecom%2Ecn

返回 Server 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP VolumeName 属性

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP VolumeName 属性

返回 Drive 对象参考手册

定义和用法

VolumeName 属性设置或返回指定驱动器的卷标。可读写。

语法：

DriveObject.VolumeName[=newname]
参数 | 描述
newname | 可选的。设置指定驱动器的新名称。

例子

<%
dim fs,d
set fs=Server.CreateObject("Scripting.FileSystemObject")
set d=fs.GetDrive("c:")
Response.Write("The volume name is: " & d.VolumeName)
set d=nothing
set fs=nothing
%>

返回 Drive 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Write 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Write 方法

返回 response 对象参考手册

Write 方法向输出写一段指定的字符串。

语法

Response.Write variant
参数 | 描述
variant | 必需。要写的数据。

实例

例子 1

<%
Response.Write "Hello World"
%>

输出：

Hello World

例子 2

<%
name="John"
Response.Write(name)
%>

输出：

John

例子 3

<%
Response.Write("Hello<br />World")
%>

输出：

Hello
World

返回 response 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP Write 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP Write 方法

返回 Textstream 对象参考手册

定义和用法

Write 方法向 TextStream 文件写入指定的文本。

注释：此方法向 TextStream 文件写入的文本在每个字符串之间不带有空格或折行。

语法：

TextStreamObject.Write(text)
参数 | 描述
text | 必需的。需要写入文件夹的文本。

实例

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.CreateTextFile("c:\test.txt",true)
f.write("Hello World!")
f.write("How are you today?")
f.close
set f=nothing
set fs=nothing
%>

在执行上面的代码后，文件 test.txt 是这样的：

Hello World!How are you today?

返回 Textstream 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP WriteBlankLines 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP WriteBlankLines 方法

返回 Textstream 对象参考手册

定义和用法

WriteBlankLines 方法向 TextStream 文件写入指定数目的新行字符。

语法：

TextStreamObject.WriteBlankLines(numlines)
参数 | 描述
numlines | 必需的。要写入文件的新行字符的数目。

实例

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.CreateTextFile("c:\test.txt",true)
f.WriteLine("Hello World!")
f.WriteBlankLines(2)
f.WriteLine("How are you today?")
f.close
set f=nothing
set fs=nothing
%>

在执行上面的代码后，文件 test.txt 是这样的：

Hello World!

How are you today?

返回 Textstream 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP WriteLine 方法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP WriteLine 方法

返回 Textstream 对象参考手册

定义和用法

WriteLine 方法向 TextStream 文件写入一段指定的文本以及一个新行字符。

语法：

TextStreamObject.WriteLine(text)
参数 | 描述
text | 可选的。需要写入文件的文本。如果您不规定此参数，那么一个新行字符会被写入文件。

实例

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.CreateTextFile("c:\test.txt",true)
f.WriteLine("Hello World!")
f.WriteLine("How are you today?")
f.WriteLine("Goodbye!")
f.close
set f=nothing
set fs=nothing
%>

在执行上面的代码后，文件 test.txt 是这样的：

Hello World!
How are you today?
Goodbye!

返回 Textstream 对象参考手册

ASP 参考手册
ASP 实例
ASP 测验


ASP 变量

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP 变量

  • Previous Page
  • Next Page

变量用于存储信息。

假如在子程序之外声明变量，那么这个变量可被 ASP 文件中的任何脚本改变。假如在子程序中声明变量，那么当子程序每次执行时，它才会被创建和撤销。

实例：

声明变量
变量用于存储信息。本例演示如何声明变量，为变量赋值，并在程序中使用这个变量
声明数组
数组用于存储一系列相关的数据项目。本例演示如何声明一个存储名字的数组。
循环生成 HTML 标题
如何循环生成 6 个不同的 HTML 标题。
使用 Vbscript 制作基于时间的问候语
本例将根据服务器时间向用户显示不同的消息。
使用 JavaScript 制作基于时间的问候语
本例同上，只是语法不同而已。

变量的生存期

在子程序外声明的变量可被 ASP 文件中的任何脚本访问和修改。

在子程序中声明的变量只有当子程序每次执行时才会被创建和撤销。子程序外的脚本无法访问和修改该变量。

如需声明供多个 ASP 文件使用的变量，请将变量声明为 session 变量或者 application 变量。

Session 变量

Session 变量用于存储单一用户的信息，并且对一个应用程序中的所有页面均有效。存储于 session 中的典型数据是姓名、id 或参数。

Application 变量

Application 变量同样对一个应用程序中的所有页面均有效。Application 变量用于存储一个特定的应用程序中所有用户的信息。

  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP 表单和用户输入

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP 表单和用户输入

  • Previous Page
  • Next Page

Request.QueryString 和 Request.Form 命令可用于从表单取回信息，比如用户的输入。

实例：

使用 method="get" 的表单
如何使用 Request.QueryString 命令与用户进行交互。
使用 method="post" 的表单
如何使用 Request.Form 命令与用户进行交互。
使用单选按钮的表单
如何使用 Request.Form 通过单选按钮与用户进行交互。

用户输入

Request 对象可用于从表单取回用户信息。

表单实例：

<form method="get" action="simpleform.asp">
First Name: <input type="text" name="fname" />
<br />
Last Name: <input type="text" name="lname" />
<br /><br />
<input type="submit" value="Submit" />
</form>

用户输入的信息可通过两种方式取回：Request.QueryString 或 Request.Form。

Request.QueryString

Request.QueryString 命令用于搜集使用 method="get" 的表单中的值。使用 GET 方法从表单传送的信息对所有的用户都是可见的（出现在浏览器的地址栏），并且对所发送信息的量也有限制。

如果用户在上面的表单实例中输入 "Bill" 和 "Gates"，发送至服务器的 URL 会类似这样：

http://www.w3school.com.cn/simpleform.asp?fname=Bill&lname=Gates

假设 ASP 文件 "simpleform.asp" 包含下面的代码：

<body>
Welcome
<%
response.write(request.querystring("fname"))
response.write(" " & request.querystring("lname"))
%>
</body>

浏览器将显示如下：

Welcome Bill Gates

Request.Form

Request.Form 命令用于搜集使用 "post" 方法的表单中的值。使用 POST 方法从表单传送的信息对用户是不可见的，并且对所发送信息的量也没有限制。

如果用户在上面的表单实例中输入 "Bill" 和 "Gates"，发送至服务器的 URL 会类似这样：

http://www.w3school.com.cn/simpleform.asp

假设 ASP 文件 "simpleform.asp" 包含下面的代码：

<body>
Welcome
<%
response.write(request.form("fname"))
response.write(" " & request.form("lname"))
%>
</body>

浏览器将显示如下：

Welcome Bill Gates

表单验证

只要有可能，就应该对用户输入的数据进行验证（通过客户端的脚本）。浏览器端的验证速度更快，并可以减少服务器的负载。

如果用户数据会输入到数据库中，那么你应该考虑使用服务器端的验证。有一种在服务器端验证表单的好的方式，就是将（验证过的）表单传回表单页面，而不是转至不同的页面。用户随后就可以在同一个页面中得到错误的信息。这样做的话，用户就更容易发现错误了。

  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP 参考手册

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP 参考手册

  • Next Page

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP 测验

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP 测验

  • Previous Page
  • Next Page

您可以通过W3SCHOOL的测验程序来测试您的ASP技能。

关于本测验

本测验包含20道题，每道题的最长答题时间是20分钟（这是由于每个session的默认有效时间是20钟）。

本测验是非官方的测试，它仅仅提供了一个了解您对ASP的掌握程度的工具。

测验会被记分

每道题的分值是1分。在您完成全部的20道题之后，系统会为您的测验打分，并提供您做错的题目的正确答案。其中，绿色为正确答案，而红色为错误答案。

现在就开始测验！祝您好运。

  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP 简介

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP 简介

  • Previous Page
  • Next Page

ASP 文件可包含文本、 HTML 标签和脚本。ASP 文件中的脚本可在服务器上执行。

在学习之前，应具备的知识：

在继续学习之前，您需要对以下知识有基本的了解：

  • HTML / XHTML
  • 脚本语言，比如 JavaScript 或者 VBScript

如果希望学习上面的项目，请在我们的 首页 访问这些教程。

ASP 是什么？

  • ASP 指 Active Server Pages （动态服务器页面）
  • ASP 是运行于 IIS 之中的程序
  • IIS 指 Internet Information Services （Internet 信息服务）
  • IIS 是 Windows 2000 及 Windows 2003 的免费组件
  • IIS 同时也是 Windows NT 4.0 的可选组件
  • 此可选组件可通过因特网下载
  • PWS 的体积更小 - 不过拥有 IIS 的完整功能
  • PWS 可在 Windows 95/98 的安装 CD 中找到

ASP 兼容性

  • ASP 是微软公司推出的一种技术
  • 运行 IIS，需要 Windows NT 4.0 或更高的版本。
  • 运行 PWS ，需要 Windows 95 或者更高的版本。
  • ChiliASP 是一种在非 Windows 操作系统上运行 ASP 的技术
  • InstantASP 是另一种在非 Windows 操作系统上运行 ASP 的技术

ASP 文件是什么？

  • ASP 文件和 HTML 文件类似
  • ASP 文件可包含文本、HTML、XML 和脚本
  • ASP 文件中的脚本可在服务器上执行。
  • ASP 文件的扩展名是 ".asp"

ASP 和 HTML 有何不同？

  • 当浏览器请求某个 HTML 文件时，服务器会返回这个文件
  • 而当浏览器请求某个 ASP 文件时，IIS 将这个请求传递至 ASP 引擎。ASP 引擎会逐行地读取这个文件，并执行文件中的脚本。最后，ASP 文件将以纯 HTML 的形式返回到浏览器。

ASP 能为你做什么？

  • 动态地编辑、改变或者添加页面的任何内容
  • 对由用户从 HTML 表单提交的查询或者数据作出响应
  • 访问数据或者数据库，并向浏览器返回结果
  • 为不同的用户定制网页，提高这些页面的可用性
  • 用 ASP 替代 CGI 和 Perl 的优势在于它的简易性和速度
  • 由于 ASP 代码无法从来浏览器端察看，ASP 确保了站点的安全性。
  • 优秀的 ASP 编程可将网络负载降至最低

重要事项：由于 ASP 在服务器运行，浏览器无需支持客户端脚本就可以显示 ASP 文件！

  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP 教程

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP 教程

  • Next Page

在我们的 ASP 教程中，您将学到 ASP 的相关知识，以及如何在服务器端执行脚本。

您会发现，ASP 是一种生成动态交互性网页的强有力工具。

开始学习 ASP ！

ASP 参考手册

在 W3School，我们为您提供完整的 ASP 参考手册，其中包括内建对象和组件，以及它们的属性和方法。

ASP 参考手册

ASP 实例

通过实例来学习！因为 ASP 脚本只能在服务器端执行，所以你无法在浏览器中查看 ASP 代码，你能看到的仅仅是由 ASP 输出的纯粹的 HTML 代码。在 W3School，每个实例均可显示出以往被隐藏的 ASP 代码。这样，您就可以更容易地理解它们的工作原理。

ASP 实例

ASP 测验

在 W3School 测试你的 ASP 技能!

开始 ASP 测验！

  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP 快速参考

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP 快速参考

  • Previous Page
  • Next Page

暂无内容，请阅读下一节。。。

  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP 使用 CDOSYS 发送电子邮件

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP 使用 CDOSYS 发送电子邮件

  • Previous Page
  • Next Page

CDOSYS 是 ASP 中的内置组件。此组建用于通过 ASP 来发送电子邮件。

使用 CDOSYS 发送电子邮件

CDO (Collaboration Data Objects) 是一项微软的技术，设计目的是用来简化通信程序的创建。

CDOSYS 是 ASP 中的内置组件。我们将会您展示如何使用该组件来发送电子邮件。

CDONTs 怎么样？

微软已经在 Windows 2000、Windows XP 以及 Windows 2003 中淘汰了 CDONTs。如果您还在应用程序中使用 CDONTs，就需要更新代码，并使用新的 CDO 技术。

使用 CDOSYS 的实例

发送电子邮件：

<%
Set myMail=CreateObject("CDO.Message")
myMail.Subject="Sending email with CDO"
myMail.From="mymail@mydomain.com"
myMail.To="someone@somedomain.com"
myMail.TextBody="This is a message."
myMail.Send
set myMail=nothing
%>

使用 Bcc 和 CC 域来发送文本邮件:

<%
Set myMail=CreateObject("CDO.Message")
myMail.Subject="Sending email with CDO"
myMail.From="mymail@mydomain.com"
myMail.To="someone@somedomain.com"
myMail.Bcc="someoneelse@somedomain.com"
myMail.Cc="someoneelse2@somedomain.com"
myMail.TextBody="This is a message."
myMail.Send
set myMail=nothing
%>

发送 HTML 邮件:

<%
Set myMail=CreateObject("CDO.Message")
myMail.Subject="Sending email with CDO"
myMail.From="mymail@mydomain.com"
myMail.To="someone@somedomain.com"
myMail.HTMLBody = "<h1>This is a message.</h1>"
myMail.Send
set myMail=nothing
%>

发送一封由网站传送网页的 HTML 邮件：

<%
Set myMail=CreateObject("CDO.Message")
myMail.Subject="Sending email with CDO"
myMail.From="mymail@mydomain.com"
myMail.To="someone@somedomain.com"
myMail.CreateMHTMLBody "http://www.w3school.com.cn/asp/"
myMail.Send
set myMail=nothing
%>

发送一封从您的电脑中的文件来传送网页的 HTML 邮件：

<%
Set myMail=CreateObject("CDO.Message")
myMail.Subject="Sending email with CDO"
myMail.From="mymail@mydomain.com"
myMail.To="someone@somedomain.com"
myMail.CreateMHTMLBody "file://c:/mydocuments/test.htm"
myMail.Send
set myMail=nothing
%>

发送一封带有附件的电子邮件：

<%
Set myMail=CreateObject("CDO.Message")
myMail.Subject="Sending email with CDO"
myMail.From="mymail@mydomain.com"
myMail.To="someone@somedomain.com"
myMail.TextBody="This is a message."
myMail.AddAttachment "c:\mydocuments\test.txt"
myMail.Send
set myMail=nothing
%>

使用远程服务器发送一封文本邮件：

<%
Set myMail=CreateObject("CDO.Message")
myMail.Subject="Sending email with CDO"
myMail.From="mymail@mydomain.com"
myMail.To="someone@somedomain.com"
myMail.TextBody="This is a message."
myMail.Configuration.Fields.Item _
("http://schemas.microsoft.com/cdo/configuration/sendusing")=2
'Name or IP of remote SMTP server
myMail.Configuration.Fields.Item _
("http://schemas.microsoft.com/cdo/configuration/smtpserver") _
="smtp.server.com"
'Server port
myMail.Configuration.Fields.Item _
("http://schemas.microsoft.com/cdo/configuration/smtpserverport") _
=25
myMail.Configuration.Fields.Update
myMail.Send
set myMail=nothing
%>
  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP 文件引用

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP 文件引用

  • Previous Page
  • Next Page

#include 命令用于在多重页面上创建需重复使用的函数、页眉、页脚或者其他元素等。

#include 命令

通过使用 #include 命令，我们可以在服务器执行 ASP 文件之前，把另一个ASP文件插入这个文件中。#include 命令用于在多重页面上创建需重复使用的函数、页眉、页脚或者其他元素等。

如何使用 #include 命令

这里有一个名为 "mypage.asp" 的文件:

<html>
<body>
<h2>Words of Wisdom:</h2>
<p><!--#include file="wisdom.inc"--></p>
<h2>The time is:</h2>
<p><!--#include file="time.inc"--></p>
</body>
</html>

这是 "wisdom.inc" 文件:

"One should never increase, beyond what is necessary,
the number of entities required to explain anything."

这是 "time.inc" 文件:

<%
Response.Write(Time)
%>

在浏览器中查看的源代码应该类似这样：

<html>
<body>
<h2>Words of Wisdom:</h2>
<p>"One should never increase, beyond what is necessary,
the number of entities required to explain anything."</p>
<h2>The time is:</h2>
<p>11:33:42 AM</p>
</body>
</html>

Including 文件的语法：

如需在 ASP 中引用文件，请把 #include 命令置于注释标签之中：

<!--#include virtual="somefilename"-->

或者：

<!--#include file ="somefilename"-->

关键词 Virtual

关键词 virtual 指示路径以虚拟目录开始。

如果名为 "header.inc" 位于名为 /html 的虚拟目录中，下面这行代码会插入文件 "header.inc" 中的内容：

<!-- #include virtual ="/html/header.inc" -->

关键词 File

关键词 File 指示一个相对的路径。相对路径起始于含有引用文件的目录。

假设文件位于 html 文件夹的子文件夹 headers 中，下面这段代码可引用 "header.inc" 文件的内容：

<!-- #include file ="headers\header.inc" -->

注意：被引用文件的路径是相对于引用文件的。假如包含 #include 声明的文件不在 html 目录中，这个声明就不会起效。

您同样可以使用关键词 file 和语法 (..\) 来引用上级目录中的文件。

提示和注释

在上面的一节中，我们使用 ".inc" 来作为被引用文件的后缀。注意：假如用户尝试直接浏览 INC 文件，这个文件中内容就会暴露。假如被引用的文件中的内容涉及机密，那么最好还是使用 "asp" 作为后缀。ASP 文件中的源代码被编译后是不可见的。被引用的文件也可引用其他文件，同时一个 ASP 文件可以对同一个文件引用多次。

重要事项：在脚本执行前，被引用的文件就会被处理和插入。

下面的代码无法执行，这是由于 ASP 会在为变量赋值之前执行 #include 命令：

<%
fname="header.inc"
%>
<!--#include file="<%=fname%>"-->

不能在脚本分隔符之间包含文件引用：

<%
For i = 1 To n
  <!--#include file="count.inc"-->
Next
%>

但是这段脚本可以工作：

<% For i = 1 to n %>
<!--#include file="count.inc" -->
<% Next %>
  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP 语法

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP 语法

  • Previous Page
  • Next Page

在浏览器中通过查看源代码的方式是无法看到 ASP 源代码的，你只能看到由 ASP 文件输出的结果，而那些只是纯粹的 HTML 而已。这是因为，在结果被送回浏览器前，脚本已经在服务器上执行了。

在我们的 ASP 教程中，每个例子都提供隐藏的 ASP 代码。这样会使您更容易理解它们的工作原理。

实例：

用 ASP 写文本
如果使用 ASP 生成文本。
向文本添加 HTML
如果同时生成 HTML 标签和纯文本。

基本的 ASP 语法规则

通常情况下，ASP 文件包含着 HTML 标签，类似 HTML 文件。不过，ASP 文件也可包含服务器端脚本，这些脚本被 <% 和 %> 包围起来。服务器脚本在服务器端执行，可包含合法的表达式、语句、或者运算符。

向浏览器写输出

response.write 命令用来向浏览器写输出。下面的例子向浏览器传送了一段文本："Hello World"。

<html>
<body>
<%
response.write("Hello World!")
%>
</body>
</html>

还有一种 response.write 命令的简写方法。下面的例子和上面的例子是等效的：

<html>
<body>
<%="Hello World!"%>
</body>
</html>

VBScript

你可以在 ASP 中使用若干种脚本语言。不过，默认的脚本语言是 VBScript：

<html>
<body>
<%
response.write("Hello World!")
%>
</body>
</html>

上面的例子向文档的 body 部分写入了文本 "Hello World!"。

JavaScript

如果需要使用 JavaScript 作为某个特定页面的默认脚本语言，就必须在页面的顶端插入一行语言设定：

<%@ language="javascript"%>
<html>
<body>
<%
Response.Write("Hello World!")
%>
</body>
</html>

注意：与 VBScript 不同 - JavaScript 对大小写敏感。所以你需要根据 JavaScript 的需要使用不同的大小写字母编写 ASP 代码。

提示：如果您需要了解更多有关 JavaScript 的知识，请学习我们的 JavaScript 教程。

其他的脚本语言

ASP 与 VBScript 和 JScript 的配合是原生性的。如果你需要使用其他语言编写脚本，比如 PERL、REXX 或者 Python，那就必须安装相应的脚步引擎。

重要事项：因为脚本在服务器端执行，所以显示 ASP 文件的浏览器根本无需支持脚本。

  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP 子程序

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP 子程序

  • Previous Page
  • Next Page

在 ASP 中，你可通过 VBScript 和其他方式调用子程序。

实例：

调用使用 VBScript 的子程序
如何从 ASP 调用以 VBScript 编写的子程序。
调用使用 JavaScript 的子程序
如何从 ASP 调用以 JavaScript 编写的子程序。
调用使用 VBScript 和 JavaScript 的子程序
如何在一个 ASP 文件中调用以 VBScript 和 JavaScript 编写的子程序。

子程序

ASP 源代码可包含子程序和函数：

<html>
<head>
<%
sub vbproc(num1,num2)
response.write(num1*num2)
end sub
%>
</head>

<body>
<p>Result: <%call vbproc(3,4)%></p>
</body>

</html>

将 <%@ language="language" %> 这一行写到 <html> 标签的上面，就可以使用另外一种脚本语言来编写子程序或者函数：

<%@ language="javascript" %>
<html>
<head>
<%
function jsproc(num1,num2)
{
Response.Write(num1*num2)
}
%>
</head>

<body>
<p>Result: <%jsproc(3,4)%></p>
</body>

</html>

VBScript 与 JavaScript 之间的差异

当从一个用 VBScript 编写的 ASP 文件中调用 VBScript 或者 JavaScript 子程序时，可以使用关键词 "call"，后面跟着子程序名称。假如子程序需要参数，当使用关键词 "call" 时必须使用括号包围参数。假如省略 "call"，参数则不必由括号包围。假如子程序没有参数，那么括号则是可选项。

当从一个用 JavaScript 编写的 ASP 文件中调用 VBScript 或者 JavaScript 子程序时，必须在子程序名后使用括号。

  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


您已经学习了 ASP，下一步学习什么内容呢？

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

您已经学习了 ASP，下一步学习什么内容呢？

  • Previous Page
  • Next Page

ASP 概要

本教程已经为您讲解了如何为您的网站添加服务器端脚本，使得您网站的动态性和交互性更强。

我们已经学习了如何动态地编辑、改变或者添加网页内容，对来自 HTML 表单的数据提交进行响应，访问数据或数据库并向浏览器返回结果，为不同的用户定制页面，从而使这些页面的可用性更强。

如需更多关于 ASP 的信息，请阅读我们的 ASP 实例。

现在我们已经学习了 ASP，下一步学习什么呢？

下一步应该学习的内容是 SQL 和 ADO。

SQL

SQL 是用于访问和处理数据库系统的标准的计算机语言。

SQL 语句用于取回和更新数据库中的数据。SQL 与数据库程序协同工作，比如 MS Access、DB2、Informix、MS SQL Server、Oracle、Sybase 以及其他数据库系统。

假如您希望学习更多关于 SQL 的知识，请访问我们的 SQL 教程。

ADO

ADO 是从网站访问数据库中数据的编程接口。

ADO 使用 SQL 来查询数据库中的数据。

如果您希望学习更多关于 ADO 的知识，请访问我们的 ADO 教程。

  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


在您的 PC 上运行 ASP

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

在您的 PC 上运行 ASP

  • Previous Page
  • Next Page

如果没有一个外部的服务器，你可以在自己的 PC 上运行 ASP 。要做点这一点，你就必须安装微软的 PWS 或者 IIS 。

如何在自己的 PC 上运行 ASP

如果没有一个外部的服务器，你可以在自己的 PC 上运行 ASP。要做点这一点，你就必须安装微软的 PWS(Personal Web Server) 或者 IIS (Internet Information Services)。

假如你希望很好地学习 ASP 的话，我们推荐你至少要使用 Windows 98 的第二版。

如果有可能的，Windows 2000 或者更高的版本是最好的选择（包括Windows XP Professional、Windows Server 2003 或者 windows vista 操作系统）。

如何在 Windows 2000 上安装 IIS 并运行ASP

  1. 开始按钮 - 设置 - 控制面板
  2. 在控制面板中选择添加/删除程序
  3. 在添加/删除程序中选择添加/删除Windows组件
  4. 在向导窗口中选中 Internet 信息服务，然后点击确定
  5. Inetpub 文件夹会在硬盘中被创建
  6. 打开 Inetpub 文件夹，找到名为 wwwroot 的文件夹
  7. 在 wwwroot 下创建一个新文件夹，比如 "MyWeb"
  8. 使用文本编辑器编写几行 ASP 代码，将这个文件取名为 "test1.asp" 保存在 "MyWeb" 文件夹。
  9. 确保你的服务器正在运行 - 安装程序会在系统托盘创建一个IIS的图标。点击这个图标，然后在出现的新窗口中按开始按钮。
  10. 打开浏览器，在地址栏键入 "http://localhost/MyWeb/test1.asp"，就可以看到你的第一个 ASP 页面了。

如何在 Windows XP Professional 上安装 IIS 并运行 ASP

  1. 在 CD-Rom 驱动器中插入 Windows XP Professional CD-Rom
  2. 开始菜单，设置，控制面板
  3. 在控制面板选择添加/删除程序
  4. 在添加/删除程序中选择添加/删除 Windows 组件
  5. 在向导窗口中选中 Internet Information Services，然后点击确定
  6. Inetpub 文件夹会在硬盘中创建
  7. 打开 Inetpub 文件夹，找到名为 wwwroot 的文件夹
  8. 在 wwwroot下创建一个新文件夹，比如 "MyWeb"
  9. 使用文本编辑器编写几行 ASP 代码，将这个文件取名为 "test1.asp" 保存在 "MyWeb" 文件夹。
  10. 确保你的服务器正在运行，使用下面的方法确认它的运行状态：进入控制面板，然后是管理工具，然后双击“IIS 管理器”图标。
  11. 打开浏览器，在地址栏键入 "http://localhost/MyWeb/test1.asp"，就可以看到你的第一个 ASP 页面了。

提示：Windows XP Home Edition 无法运行 ASP。

如何在 Windows Server 2003 上安装 IIS 并运行 ASP

  1. 当你启动 Windows Server 2003 后，会看到服务器管理向导
  2. 如果向导没有显示，可以打开管理工具，然后选择“配置您的服务器向导”
  3. 出现提示后，点击下一步
  4. 随后会出现一个“预备步骤”的提示，点击下一步，随后系统自动搜索已在本机安装了的系统服务组件
  5. 在随后出现的服务器角色窗口中选择应用程序服务器，然后点击下一步
  6. 选中启用ASP.NET
  7. 随后向导会提示这个组件的大概安装过程，请点击下一步
  8. 现在，向导会请求 Server 2003 CD。请插入CD后继续运行向导。
  9. 最后，向导会提示“此服务器目前是一台应用程序服务器”。
  10. 点击完成后，你会发现“应用程序服务器”已在管理你的服务器角色窗口中出现
  11. 点击“管理此应用程序服务器”会打在应用程序服务器管理控制台(MMC)
  12. 展开Internet 信息服务 (IIS)管理器，然后展开你的服务器，然后是站点文件夹。
  13. 你会看到默认的网站，并且它的状态应该是运行中。
  14. 在Internet 信息服务 (IIS)管理器中点击“Web服务扩展”，你会看到 Active Server Pages 是被禁止的。
  15. 选中Active Server Pages，然后点击允许按钮，这样 ASP 就被激活了！

如何在老版本的 Windows 操作系统中运行 ASP

如何在 Windows 95 上安装 PWS 并运行 ASP

Windows 95 不包含 PWS！！

要想在 Windows 95 上运行 ASP，就必须从微软的站点下载 “Windows NT 4.0 Option Pack”。

下载"Windows NT 4.0 Option Pack"

如何在 Windows NT 上安装 PWS 并运行 ASP

Windows NT 同样不包含 PWS！！

要想在 Windows NT 上运行 ASP，就必须从微软的站点下载 “Windows NT 4.0 Option Pack”。

下载"Windows NT 4.0 Option Pack"

如何在 Windows 98 上安装 PWS 并运行 ASP

  1. 打开 Windows 98 CD 上的 Add-ons 文件夹，找到PWS文件夹并运行其中的 setup.exe 文件。
  2. 安装程序会在硬盘创建一个 Inetpub 文件夹。打开这个文件夹，找到 wwwroot 文件夹。
  3. 然后在 wwwroot 文件夹下面创建一个新的文件夹，比如 "MyWeb"。
  4. 使用文本编辑器编写几行 ASP 代码，将这个文件取名为 "test1.asp" 保存在 "MyWeb" 文件夹。
  5. 确保你的服务器正在运行 - 安装程序会在系统托盘创建一个PWS的图标。点击这个图标，然后在出现的新窗口中按开始按钮。
  6. 打开浏览器，在地址栏键入 "http://localhost/MyWeb/test1.asp"，就可以看到你的第一个 ASP 页面了。

如何在 Windows ME 上安装 PWS 并运行 ASP

Windows ME 同样不包含 PWS！！

阅读微软站点的信息

来自 Bill James 的安装方法。

  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


ASP .NET - TextBox 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP .NET - TextBox 控件

  • Previous Page
  • Next Page

TextBox 控件用于创建用户可输入文本的文本框。

TextBox 控件

TextBox 控件用于创建用户可输入文本的文本框。

TextBox 控件的属性列在我们的 TextBox 控件参考手册中。

下面的例子演示了您可能在 TextBox 控件中使用到的一些属性：

TIY

<html>
<body>

<form runat="server">

A basic TextBox:
<asp:TextBox id="tb1" runat="server" />
<br /><br />

A password TextBox:
<asp:TextBox id="tb2" TextMode="password" runat="server" />
<br /><br />

A TextBox with text:
<asp:TextBox id="tb4" Text="Hello World!" runat="server" />
<br /><br />

A multiline TextBox:
<asp:TextBox id="tb3" TextMode="multiline" runat="server" />
<br /><br />

A TextBox with height:
<asp:TextBox id="tb6" rows="5" TextMode="multiline"
runat="server" />
<br /><br />

A TextBox with width:
<asp:TextBox id="tb5" columns="30" runat="server" />

</form>

</body>
</html>

添加脚本

当表单被提交时，TextBox 控件的内容和设置可通过服务器脚本进行修改。可通过点击一个按钮或当用户更改 TextBox 控件中的值对表单进行提交。

在下面的例子中，我们在一个 .aspx 文件中声明了一个 TextBox 控件、一个 Button 控件和一个 Label 控件。当提交按钮被触发时，submit 子例程就会被执行。submit 子例程会向 Label 控件写一条文本：

<script runat="server">
Sub submit(sender As Object, e As EventArgs)
lbl1.Text="Your name is " & txt1.Text
End Sub
</script>

<html>
<body>

<form runat="server">
Enter your name:
<asp:TextBox id="txt1" runat="server" />
<asp:Button OnClick="submit" Text="Submit" runat="server" />
<p><asp:Label id="lbl1" runat="server" /></p>
</form>

</body>
</html>

TIY

在下面的例子中，我们在一个 .aspx 文件中声明了一个 TextBox 控件和一个 Label 控件。当您更改了 TextBox 中的值，并且在 TextBox 外单击时，change 子例程就会被执行。change 子例程会向 Label 控件写一条文本：

<script runat="server">
Sub change(sender As Object, e As EventArgs)
lbl1.Text="You changed text to " & txt1.Text
End Sub
</script>

<html>
<body>

<form runat="server">
Enter your name:
<asp:TextBox id="txt1" runat="server"
text="Hello World!"
ontextchanged="change" autopostback="true"/>
<p><asp:Label id="lbl1" runat="server" /></p>
</form>

</body>
</html>

TIY

  • Previous Page
  • Next Page

ASP.NET 参考手册


ASP .NET - XML 文件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP .NET - XML 文件

  • Previous Page
  • Next Page

我们可以把 XML 文件绑定到列表控件。

实例

例子 1 - XML RadiobuttonList

一个 XML 文件

这里有一个名为 "countries.xml" 的 XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>

<countries>

<country>
<text>China</text>
<value>C</value>
</country>

<country>
<text>Sweden</text>
<value>S</value>
</country>

<country>
<text>France</text>
<value>F</value>
</country>

<country>
<text>Italy</text>
<value>I</value>
</country>

</countries>

请查看该文件：countries.xml

把 DataSet 绑定到 List 控件

首先，导入 "System.Data" 命名空间。我们需要该命名空间与 DataSet 对象一起工作。把下面这条指令包含在 .aspx 页面的顶部：

<%@ Import Namespace="System.Data" %>

接下来，为这个 XML 文件创建一个 DataSet，并在页面首先加载时把这个 XML 文件载入该 DataSet：

<script runat="server">
sub Page_Load
if Not Page.IsPostBack then
  dim mycountries=New DataSet
  mycountries.ReadXml(MapPath("countries.xml"))
end if
end sub

如需把该 DataSet 绑定到 RadioButtonList 控件，首先请在 .aspx 页面中创建一个 RadioButtonList 控件（没有任何 asp:ListItem 元素）：

<html>
<body>

<form runat="server">
<asp:RadioButtonList id="rb" runat="server"
AutoPostBack="True" />
</form>

</body>
</html>

然后添加构建这个 XML DataSet 的脚本：

<%@ Import Namespace="System.Data" %>

<script runat="server">
sub Page_Load
if Not Page.IsPostBack then
  dim mycountries=New DataSet
  mycountries.ReadXml(MapPath("countries.xml"))
  rb.DataSource=mycountries
  rb.DataValueField="value"
  rb.DataTextField="text"
  rb.DataBind()
end if
end sub
</script>

<html>
<body>

<form runat="server">
<asp:RadioButtonList id="rb" runat="server"
AutoPostBack="True" onSelectedIndexChanged="displayMessage" />
</form>

</body>
</html>

然后，我们添加一个子例程，该子例程会在用户点击 RadioButtonList 控件中的项目时执行。当用户点击某个单选按钮时，label 中会出现一条文本：

<%@ Import Namespace="System.Data" %>

<script runat="server">
sub Page_Load
if Not Page.IsPostBack then
  dim mycountries=New DataSet
  mycountries.ReadXml(MapPath("countries.xml"))
  rb.DataSource=mycountries
  rb.DataValueField="value"
  rb.DataTextField="text"
  rb.DataBind()
end if
end sub

sub displayMessage(s as Object,e As EventArgs)
lbl1.text="Your favorite country is: " & rb.SelectedItem.Text
end sub
</script>

<html>
<body>

<form runat="server">
<asp:RadioButtonList id="rb" runat="server"
AutoPostBack="True" onSelectedIndexChanged="displayMessage" />
<p><asp:label id="lbl1" runat="server" /></p>
</form>

</body>
</html>
  • Previous Page
  • Next Page

ASP.NET 参考手册


ASP NET - ArrayList 对象

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP NET - ArrayList 对象

  • Previous Page
  • Next Page

ArrayList 对象是包含单一数据值的项目的集合。

实例

例子 1 - ArrayList RadioButtonList

例子 2 - ArrayList DropDownList

创建 ArrayList

ArrayList 对象是包含单一数据值的项目的集合。

通过 Add() 方法向 ArrayList 添加项目。

下面的代码创建了一个新的 ArrayList 对象，名为 mycountries，并添加了四个项目：

<script runat="server">
Sub Page_Load
if Not Page.IsPostBack then
  dim mycountries=New ArrayList
  mycountries.Add("China")
  mycountries.Add("Sweden")
  mycountries.Add("France")
  mycountries.Add("Italy")
end if
end sub
</script>

默认地，一个 ArrayList 对象包含 16 个条目。可通过 TrimToSize() 方法把 ArrayList 调整为最终尺寸：

<script runat="server">
Sub Page_Load
if Not Page.IsPostBack then
  dim mycountries=New ArrayList
  mycountries.Add("China")
  mycountries.Add("Sweden")
  mycountries.Add("France")
  mycountries.Add("Italy")
  mycountries.TrimToSize()
end if
end sub
</script>

通过 Sort() 方法，ArrayList 也能够按照字母顺序或者数字顺序进行排序：

<script runat="server">
Sub Page_Load
if Not Page.IsPostBack then
  dim mycountries=New ArrayList
  mycountries.Add("China")
  mycountries.Add("Sweden")
  mycountries.Add("France")
  mycountries.Add("Italy")
  mycountries.TrimToSize()
  mycountries.Sort()
end if
end sub
</script>

要实现颠倒的排序，请在 Sort() 方法后应用 Reverse() 方法：

<script runat="server">
Sub Page_Load
if Not Page.IsPostBack then
  dim mycountries=New ArrayList
  mycountries.Add("China")
  mycountries.Add("Sweden")
  mycountries.Add("France")
  mycountries.Add("Italy")
  mycountries.TrimToSize()
  mycountries.Sort()
  mycountries.Reverse()
end if
end sub
</script>

把数据绑定到 ArrayList

ArrayList 对象可向下面这些控件自动地生成文本和值：

  • asp:RadioButtonList
  • asp:CheckBoxList
  • asp:DropDownList
  • asp:Listbox

如需把数据绑定到一个 RadioButtonList 控件，首先请在一个 .aspx 页面中创建 RadioButtonList 控件（请注意，没有任何 asp:ListItem 元素）：

<html>
<body>

<form runat="server">
<asp:RadioButtonList id="rb" runat="server" />
</form>

</body>
</html>

然后添加构建列表的脚本，并把列表中的值绑定到该 RadioButtonList 控件：

<script runat="server">
Sub Page_Load
if Not Page.IsPostBack then
  dim mycountries=New ArrayList
  mycountries.Add("China")
  mycountries.Add("Sweden")
  mycountries.Add("France")
  mycountries.Add("Italy")
  mycountries.TrimToSize()
  mycountries.Sort()
  rb.DataSource=mycountries
  rb.DataBind()
end if
end sub
</script>

<html>
<body>

<form runat="server">
<asp:RadioButtonList id="rb" runat="server" />
</form>

</body>
</html>

RadioButtonList 控件的 DataSource 属性被设置为该 ArrayList，它定义了这个 RadioButtonList 控件的数据源。RadioButtonList 控件的 DataBind() 方法把 RadioButtonList 控件与数据源绑定在一起。

注释：数据值作为控件的 Text 和 Value 属性来使用。如需添加不同于 Text 的 Value，既可以使用 Hashtable 对象，也可以使用 SortedList 对象。

  • Previous Page
  • Next Page

ASP.NET 参考手册


ASP 与 ASP.NET 之间的差异

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP 与 ASP.NET 之间的差异

  • Previous Page
  • Next Page

ASP.NET 拥有更好的语言支持，一整套新的控件，基于 XML 的组件，以及更好的用户身份验证。

ASP.NET 通过允许编译的代码，提供了更强的性能。

ASP.NET 代码不完全向后兼容 ASP。

ASP.NET 的新特性

  • 更好的语言支持
  • 可编程的控件
  • 事件驱动的编程
  • 基于 XML 的组件
  • 用户身份验证，带有帐号和角色
  • 更高的可伸缩性
  • 更强的性能 - 编译代码
  • 更容易配置和开发
  • 不完全的 ASP 兼容

语言支持

ASP.NET 使用新的 ADO.NET。

ASP.NET 支持完整的 Visual Basic，而非 VBScript。

ASP.NET 支持 C# (C sharp) 和 C++。

ASP.NET 支持 JScript，和以前一样。

ASP.NET 控件

ASP.NET 包含大量 HTML 控件。几乎所有页面中的 HTML 元素都能被定义为 ASP.NET 控件，而这些控件都能由脚本控制。

ASP.NET 同时包含一系列新的面向对象的输入控件，比如可编程的列表框和验证控件。

新的 data grid 控件支持分类、数据分页，以及您对一个数据集控件所期待的一切。

事件驱动的控件

所有 Web 页面上的 ASP.NET 对象都能够发生可被 ASP.NET 代码处理的事件。

可由代码处理的加载、点击和更改事件使得编程更轻松，更有条理。

ASP.NET 组件

ASP.NET 组件深入地基于 XML。比如新的 AD Rotator，它使用 XML 来存储广告信息和配置。

用户身份验证

ASP.NET 支持基于表单的用户身份验证，包括 cookie 管理和自动的非授权登录重定向。

（您仍然能够定制自己的登陆页面和用户验证程序）。

User 帐户和角色

ASP.NET 允许用户帐户和角色，赋予每个用户（带有一个给定的角色）不同的服务器代码访问权限。

高可伸缩性

ASP.NET 在提供更大的可伸缩性方面已有非常多的改善。

服务器对服务器的通信已得到极大的增强，这使得在若干个服务器上按比例分配一个应用程序成为可能。关于这一点的一个例子是，我们有能力在不同的服务器上运行 XML 解析器、XSL 转换，甚至耗费资源的 session 对象。

编译代码

对服务器上 ASP.NET 页面的第一个请求是编译其 ASP.NET 代码，并在内存中保存一份缓存的备份。这样做的结果当然极大地提高了性能。

易于配置

通过纯文本文件就可完成对 ASP.NET 的配置。

配置文件可在应用程序运行时进行上传和修改。无需重起服务器。也没有 metabase 和注册方面的难题。

易于开发

不需要重起服务器来配置和替换已编译的代码。ASP.NET 会简单地把所有新的请求重定向到新的代码。

兼容性

ASP.NET 不完全兼容早期的 ASP 版本，所有大部分旧的 ASP 代码需要进行修改才能在 ASP.NET 下运行。

为了解决这个问题，ASP.NET 使用了一个新的文件后缀 ".aspx"。这样就使 ASP.NET 应用程序与 ASP 应用程序能够一起运行在同一个服务器上。

  • Previous Page
  • Next Page

ASP.NET 参考手册


ASP.NET - Button 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET - Button 控件

  • Previous Page
  • Next Page

Button 控件用于显示一个按钮。

Button 控件

Button 控件用于显示一个按钮。按钮可以是提交按钮或命令按钮，而该控件是一个提交按钮。

submit 按钮没有命令名称，当它被点击时，它把页面传回服务器。可以编写一些事件句柄，在提交按钮被点击时来控制动作的执行。

command 按钮拥有命名名称，且允许你在页面上创建多个 Button 控件。可以编写一些事件句柄，在 command 按钮被点击时来控制动作的执行。

Button 控件的属性列在我们的 Button 控件参考手册中。

下面的例子演示了一个简单的 Button 控件：

<html>
<body>

<form runat="server">
<asp:Button id="b1" Text="Submit" runat="server" />
</form>

</body>
</html>

添加脚本

表单通常通过点击按钮进行提交。

在下面的例子中，我们在 .aspx 文件中声明了一个 TextBox 控件、一个 Button 控件以及一个 Label 控件。当这个提交按钮被点击时，submit 子例程就会被执行。该 submit 子例程会向 Label 控件写一条文本：

<script runat="server">
Sub submit(sender As Object, e As EventArgs)
lbl1.Text="Your name is " & txt1.Text
End Sub
</script>

<html>
<body>

<form runat="server">
Enter your name:
<asp:TextBox id="txt1" runat="server" />
<asp:Button OnClick="submit" Text="Submit" runat="server" />
<p><asp:Label id="lbl1" runat="server" /></p>
</form>

</body>
</html>

TIY

  • Previous Page
  • Next Page

ASP.NET 参考手册


ASP.NET - DataList 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET - DataList 控件

  • Previous Page
  • Next Page

DataList 控件，类似于 Repeater 控件，用于显示限制于该控件的项目的重复列表。不过，DataList 控件会默认地在数据项目上添加表格。

实例

DataList 控件
带有样式的 DataList 控件
带有 <AlternatingItemTemplate> 的 DataList 控件

把 DataSet 绑定到 DataList 控件

DataList 控件，类似于 Repeater 控件，用于显示限制于该控件的项目的重复列表。不过，DataList 控件会默认地在数据项目上添加表格。DataList 控件可被绑定到数据库表、XML 文件或者其他项目列表。这里，我们将展示如何把 XML 文件绑定到一个 DataList 控件。

我们将在例子中使用下面的 XML 文件 ("cdcatalog.xml")：

<?xml version="1.0" encoding="ISO-8859-1"?>

<catalog>
<cd>
<title>Empire Burlesque</title>
<artist>Bob Dylan</artist>
<country>USA</country>
<company>Columbia</company>
<price>10.90</price>
<year>1985</year>
</cd>
<cd>
<title>Hide your heart</title>
<artist>Bonnie Tyler</artist>
<country>UK</country>
<company>CBS Records</company>
<price>9.90</price>
<year>1988</year>
</cd>
<cd>
<title>Greatest Hits</title>
<artist>Dolly Parton</artist>
<country>USA</country>
<company>RCA</company>
<price>9.90</price>
<year>1982</year>
</cd>
<cd>
<title>Still got the blues</title>
<artist>Gary Moore</artist>
<country>UK</country>
<company>Virgin records</company>
<price>10.20</price>
<year>1990</year>
</cd>
<cd>
<title>Eros</title>
<artist>Eros Ramazzotti</artist>
<country>EU</country>
<company>BMG</company>
<price>9.90</price>
<year>1997</year>
</cd>
</catalog>

请查看该 XML 文件：cdcatalog.xml

首先，导入 "System.Data" 命名空间。我们需要此命名空间与 DataSet 对象一同工作。在 .aspx 页面的顶部包含下面这条指令：

<%@ Import Namespace="System.Data" %>

接下来，为这个 XML 文件创建一个 DataSet，并把此 XML 文件在页面首次加载时载入 DataSet：

<script runat="server">
sub Page_Load
if Not Page.IsPostBack then
  dim mycdcatalog=New DataSet
  mycdcatalog.ReadXml(MapPath("cdcatalog.xml"))
end if
end sub

然后我们在 .aspx 页面中创建一个 DataList 控件。<HeaderTemplate> 元素中的内容在输出中仅出现一次，而 <ItemTemplate> 元素的内容会对应 DataSet 中的 "record" 重复出现，最后，<FooterTemplate> 的内容在输出中仅出现一次：

<html>
<body>

<form runat="server">
<asp:DataList id="cdcatalog" runat="server">

<HeaderTemplate>
...
</HeaderTemplate>

<ItemTemplate>
...
</ItemTemplate>

<FooterTemplate>
...
</FooterTemplate>

</asp:DataList>
</form>

</body>
</html>

然后我们添加可创建 DataSet 的脚本，并把这个 mycdcatalog DataSet 绑定到 DataList 控件。我们同样使用这些元素来填充该 DataList 控件：包含表头的 <HeaderTemplate>，包含要显示的数据项的 <ItemTemplate>，以及包含文本的 <FooterTemplate>。请注意，DataList 的 gridlines 属性被设置为 "both"，以显示表格边框：

<%@ Import Namespace="System.Data" %>

<script runat="server">
sub Page_Load
if Not Page.IsPostBack then
  dim mycdcatalog=New DataSet
  mycdcatalog.ReadXml(MapPath("cdcatalog.xml"))
  cdcatalog.DataSource=mycdcatalog
  cdcatalog.DataBind()
end if
end sub
</script>

<html>
<body>

<form runat="server">
<asp:DataList id="cdcatalog"
gridlines="both" runat="server">

<HeaderTemplate>
My CD Catalog
</HeaderTemplate>

<ItemTemplate>
"<%#Container.DataItem("title")%>" of
<%#Container.DataItem("artist")%> -
$<%#Container.DataItem("price")%>
</ItemTemplate>

<FooterTemplate>
Copyright w3school.com.cn
</FooterTemplate>

</asp:DataList>
</form>

</body>
</html>

使用样式

您也可以向 DataList 控件添加样式，让它更加时髦：

<%@ Import Namespace="System.Data" %>

<script runat="server">
sub Page_Load
if Not Page.IsPostBack then
  dim mycdcatalog=New DataSet
  mycdcatalog.ReadXml(MapPath("cdcatalog.xml"))
  cdcatalog.DataSource=mycdcatalog
  cdcatalog.DataBind()
end if
end sub
</script>

<html>
<body>

<form runat="server">
<asp:DataList id="cdcatalog"
runat="server"
cellpadding="2"
cellspacing="2"
borderstyle="inset"
backcolor="#e8e8e8"
width="100%"
headerstyle-font-name="Verdana"
headerstyle-font-size="12pt"
headerstyle-horizontalalign="center"
headerstyle-font-bold="true"
itemstyle-backcolor="#778899"
itemstyle-forecolor="#ffffff"
footerstyle-font-size="9pt"
footerstyle-font-italic="true">

<HeaderTemplate>
My CD Catalog
</HeaderTemplate>

<ItemTemplate>
"<%#Container.DataItem("title")%>" of
<%#Container.DataItem("artist")%> -
$<%#Container.DataItem("price")%>
</ItemTemplate>

<FooterTemplate>
Copyright w3school.com.cn
</FooterTemplate>

</asp:DataList>
</form>

</body>
</html>

使用 <AlternatingItemTemplate>

您可以在 <ItemTemplate> 元素后添加 <AlternatingItemTemplate> 元素，这样就可以描述交替行的外观了。您可以在 DataList 控件内部对 <AlternatingItemTemplate> 部分的数据进行样式化处理：

<%@ Import Namespace="System.Data" %>

<script runat="server">
sub Page_Load
if Not Page.IsPostBack then
dim mycdcatalog=New DataSet
mycdcatalog.ReadXml(MapPath("cdcatalog.xml"))
cdcatalog.DataSource=mycdcatalog
cdcatalog.DataBind()
end if
end sub
</script>

<html>
<body>

<form runat="server">
<asp:DataList id="cdcatalog"
runat="server"
cellpadding="2"
cellspacing="2"
borderstyle="inset"
backcolor="#e8e8e8"
width="100%"
headerstyle-font-name="Verdana"
headerstyle-font-size="12pt"
headerstyle-horizontalalign="center"
headerstyle-font-bold="True"
itemstyle-backcolor="#778899"
itemstyle-forecolor="#ffffff"
alternatingitemstyle-backcolor="#e8e8e8"
alternatingitemstyle-forecolor="#000000"
footerstyle-font-size="9pt"
footerstyle-font-italic="True">

<HeaderTemplate>
My CD Catalog
</HeaderTemplate>

<ItemTemplate>
"<%#Container.DataItem("title")%>" of
<%#Container.DataItem("artist")%> -
$<%#Container.DataItem("price")%>
</ItemTemplate>

<AlternatingItemTemplate>
"<%#Container.DataItem("title")%>" of
<%#Container.DataItem("artist")%> -
$<%#Container.DataItem("price")%>
</AlternatingItemTemplate>

<FooterTemplate>
&copy; w3school.com.cn
</FooterTemplate>

</asp:DataList>
</form>

</body>
</html>
  • Previous Page
  • Next Page

ASP.NET 参考手册


ASP.NET - Hashtable 对象

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET - Hashtable 对象

  • Previous Page
  • Next Page

Hashtable 对象包含用键/值对表示的项目。

实例

例子 1 - Hashtable RadioButtonList

例子 2 - Hashtable RadiobuttonList

例子 3 - Hashtable DropDownList

创建 Hashtable

Hashtable 对象包含用键/值对表示的项目。键被用作索引，通过搜索其键，可以实现对值的快速搜索。

通过 Add() 方法向 Hashtable 添加项目。

下面的代码创建一个名为 mycountries 的 Hashtable，并添加了四个元素：

<script runat="server">
Sub Page_Load
if Not Page.IsPostBack then
  dim mycountries=New Hashtable
  mycountries.Add("C","China")
  mycountries.Add("S","Sweden")
  mycountries.Add("F","France")
  mycountries.Add("I","Italy")
end if
end sub
</script>

数据绑定

Hashtable 对象可为下面这些控件自动地生成文本和值：

  • asp:RadioButtonList
  • asp:CheckBoxList
  • asp:DropDownList
  • asp:Listbox

如需把数据绑定到某个 RadioButtonList 控件，首先请在一个 .aspx 页面中创建 RadioButtonList 控件（没有任何 asp:ListItem 元素）

<html>
<body>

<form runat="server">
<asp:RadioButtonList id="rb" runat="server" AutoPostBack="True" />

</form>

</body>
</html>

然后添加构建列表的脚本：

<script runat="server">
sub Page_Load
if Not Page.IsPostBack then
  dim mycountries=New Hashtable
  mycountries.Add("C","China")
  mycountries.Add("S","Sweden")
  mycountries.Add("F","France")
  mycountries.Add("I","Italy")
  rb.DataSource=mycountries
  rb.DataValueField="Key"
  rb.DataTextField="Value"
  rb.DataBind()
end if
end sub
</script>

<html>
<body>

<form runat="server">
<asp:RadioButtonList id="rb" runat="server" AutoPostBack="True" />
</form>

</body>
</html>

然后我们添加一个子例程，该例程会在用户点击 RadioButtonList 控件中的某个项目时被执行。当某个单选按钮被点击，label 中会出现一条文本：

<script runat="server">
sub Page_Load
if Not Page.IsPostBack then
  dim mycountries=New Hashtable
  mycountries.Add("C","China")
  mycountries.Add("S","Sweden")
  mycountries.Add("F","France")
  mycountries.Add("I","Italy")
  rb.DataSource=mycountries
  rb.DataValueField="Key"
  rb.DataTextField="Value"
  rb.DataBind()
end if
end sub

sub displayMessage(s as Object,e As EventArgs)
lbl1.text="Your favorite country is: " & rb.SelectedItem.Text
end sub
</script>

<html>
<body>

<form runat="server">
<asp:RadioButtonList id="rb" runat="server"
AutoPostBack="True" onSelectedIndexChanged="displayMessage" />
<p><asp:label id="lbl1" runat="server" /></p>
</form>

</body>
</html>

注释：您无法选择添加到 Hashtable 的项目的排序方式。如需对项目进行字母排序或数字排序，请使用 SortedList 对象。

  • Previous Page
  • Next Page

ASP.NET 参考手册


ASP.NET - Repeater 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET - Repeater 控件

  • Previous Page
  • Next Page

Repeater 控件用于显示重复的项目列表，这些项目被限制在该控件。

实例

Repeater 控件
带有 <AlternatingItemTemplate> 的 Repeater 控件
带有 <SeparatorTemplate> Repeater 控件

把 DataSet 绑定到 Repeater 控件

Repeater 空间用于显示重复的项目列表，这些项目被限制在该控件。Repeater 控件可被绑定到数据库表、XML 文件或者其他项目列表。这里，我们将展示如何把 XML 文件绑定到一个 Repeater 控件。

我们将在例子中使用下面的 XML 文件("cdcatalog.xml")：

<?xml version="1.0" encoding="ISO-8859-1"?>

<catalog>
<cd>
<title>Empire Burlesque</title>
<artist>Bob Dylan</artist>
<country>USA</country>
<company>Columbia</company>
<price>10.90</price>
<year>1985</year>
</cd>
<cd>
<title>Hide your heart</title>
<artist>Bonnie Tyler</artist>
<country>UK</country>
<company>CBS Records</company>
<price>9.90</price>
<year>1988</year>
</cd>
<cd>
<title>Greatest Hits</title>
<artist>Dolly Parton</artist>
<country>USA</country>
<company>RCA</company>
<price>9.90</price>
<year>1982</year>
</cd>
<cd>
<title>Still got the blues</title>
<artist>Gary Moore</artist>
<country>UK</country>
<company>Virgin records</company>
<price>10.20</price>
<year>1990</year>
</cd>
<cd>
<title>Eros</title>
<artist>Eros Ramazzotti</artist>
<country>EU</country>
<company>BMG</company>
<price>9.90</price>
<year>1997</year>
</cd>
</catalog>

请查看该 XML 文件：cdcatalog.xml

首先，导入 "System.Data" 命名空间。我们需要此命名空间与 DataSet 对象一同工作。在 .aspx 页面的顶部包含下面这条指令：

<%@ Import Namespace="System.Data" %>

接下来，为这个 XML 文件创建一个 DataSet，并把此 XML 文件在页面首次加载时载入 DataSet：

<script runat="server">
sub Page_Load
if Not Page.IsPostBack then
  dim mycdcatalog=New DataSet
  mycdcatalog.ReadXml(MapPath("cdcatalog.xml"))
end if
end sub

然后我们在 .aspx 页面中创建一个 Repeater 控件。<HeaderTemplate> 元素中的内容在输出中仅出现一次，而 <ItemTemplate> 元素的内容会对应 DataSet 中的 "record" 重复出现，最后，<FooterTemplate> 的内容在输出中仅出现一次：

<html>
<body>

<form runat="server">
<asp:Repeater id="cdcatalog" runat="server">

<HeaderTemplate>
...
</HeaderTemplate>

<ItemTemplate>
...
</ItemTemplate>

<FooterTemplate>
...
</FooterTemplate>

</asp:Repeater>
</form>

</body>
</html>

然后我们添加可创建 DataSet 的脚本，并把这个 mycdcatalog DataSet 绑定到 Repeater 控件。我们同样用 HTML 标签来填充这个 Repeater 控件，并通过 <%#Container.DataItem("fieldname")%> 方法把数据项目绑定到 <ItemTemplate> 部分内的单元格：

<%@ Import Namespace="System.Data" %>

<script runat="server">
sub Page_Load
if Not Page.IsPostBack then
  dim mycdcatalog=New DataSet
  mycdcatalog.ReadXml(MapPath("cdcatalog.xml"))
  cdcatalog.DataSource=mycdcatalog
  cdcatalog.DataBind()
end if
end sub
</script>

<html>
<body>

<form runat="server">
<asp:Repeater id="cdcatalog" runat="server">

<HeaderTemplate>
<table border="1" width="100%">
<tr>
<th>Title</th>
<th>Artist</th>
<th>Country</th>
<th>Company</th>
<th>Price</th>
<th>Year</th>
</tr>
</HeaderTemplate>

<ItemTemplate>
<tr>
<td><%#Container.DataItem("title")%></td>
<td><%#Container.DataItem("artist")%></td>
<td><%#Container.DataItem("country")%></td>
<td><%#Container.DataItem("company")%></td>
<td><%#Container.DataItem("price")%></td>
<td><%#Container.DataItem("year")%></td>
</tr>
</ItemTemplate>

<FooterTemplate>
</table>
</FooterTemplate>

</asp:Repeater>
</form>

</body>
</html>

使用 <AlternatingItemTemplate>

您可以在 <ItemTemplate> 元素后添加 <AlternatingItemTemplate> 元素，这样就可以描述交替行的外观了。在下面的例子中，该表格中每隔一行就会显示为浅灰色的背景：

<%@ Import Namespace="System.Data" %>

<script runat="server">
sub Page_Load
if Not Page.IsPostBack then
  dim mycdcatalog=New DataSet
  mycdcatalog.ReadXml(MapPath("cdcatalog.xml"))
  cdcatalog.DataSource=mycdcatalog
  cdcatalog.DataBind()
end if
end sub
</script>

<html>
<body>

<form runat="server">
<asp:Repeater id="cdcatalog" runat="server">

<HeaderTemplate>
<table border="1" width="100%">
<tr>
<th>Title</th>
<th>Artist</th>
<th>Country</th>
<th>Company</th>
<th>Price</th>
<th>Year</th>
</tr>
</HeaderTemplate>

<ItemTemplate>
<tr>
<td><%#Container.DataItem("title")%></td>
<td><%#Container.DataItem("artist")%></td>
<td><%#Container.DataItem("country")%></td>
<td><%#Container.DataItem("company")%></td>
<td><%#Container.DataItem("price")%></td>
<td><%#Container.DataItem("year")%></td>
</tr>
</ItemTemplate>

<AlternatingItemTemplate>
<tr bgcolor="#e8e8e8">

<td><%#Container.DataItem("title")%></td>
<td><%#Container.DataItem("artist")%></td>
<td><%#Container.DataItem("country")%></td>
<td><%#Container.DataItem("company")%></td>
<td><%#Container.DataItem("price")%></td>
<td><%#Container.DataItem("year")%></td>
</tr>
</AlternatingItemTemplate>

<FooterTemplate>
</table>
</FooterTemplate>

</asp:Repeater>
</form>

</body>
</html>

使用 <SeparatorTemplate>

<SeparatorTemplate> 元素能够用于描述每个记录之间的分隔符。下面的例子在每个表格行之间插入了一条水平线：

<%@ Import Namespace="System.Data" %>

<script runat="server">
sub Page_Load
if Not Page.IsPostBack then
  dim mycdcatalog=New DataSet
  mycdcatalog.ReadXml(MapPath("cdcatalog.xml"))
  cdcatalog.DataSource=mycdcatalog
  cdcatalog.DataBind()
end if
end sub
</script>

<html>
<body>

<form runat="server">
<asp:Repeater id="cdcatalog" runat="server">

<HeaderTemplate>
<table border="0" width="100%">
<tr>
<th>Title</th>
<th>Artist</th>
<th>Country</th>
<th>Company</th>
<th>Price</th>
<th>Year</th>
</tr>
</HeaderTemplate>

<ItemTemplate>
<tr>
<td><%#Container.DataItem("title")%></td>
<td><%#Container.DataItem("artist")%></td>
<td><%#Container.DataItem("country")%></td>
<td><%#Container.DataItem("company")%></td>
<td><%#Container.DataItem("price")%></td>
<td><%#Container.DataItem("year")%></td>
</tr>
</ItemTemplate>

<SeparatorTemplate>
<tr>
<td colspan="6"><hr /></td>
</tr>
</SeparatorTemplate>

<FooterTemplate>
</table>
</FooterTemplate>

</asp:Repeater>
</form>

</body>
</html>
  • Previous Page
  • Next Page

ASP.NET 参考手册


ASP.NET - SortedList 对象

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET - SortedList 对象

  • Previous Page
  • Next Page

SortedList 对象兼有 ArrayList 和 Hashtable 对象的特性。

实例

例子 1 - SortedList RadioButtonList
例子 2 - SortedList RadiobuttonList
例子 3 - SortedList DropDownList

SortedList 对象

SortedList 对象包含用键/值对表示的项目。SortedList 对象可按照字符顺序或数字顺序自动地对项目进行排序。

通过 Add() 方法向 SortedList 添加项目。SortedList 可通过 TrimToSize() 方法调整为最终尺寸。

下面的代码创建了一个名为 mycountries 的 SortedList，并添加了四个元素：

<script runat="server">
sub Page_Load
if Not Page.IsPostBack then
  dim mycountries=New SortedList
  mycountries.Add("C","China")
  mycountries.Add("S","Sweden")
  mycountries.Add("F","France")
  mycountries.Add("I","Italy")
end if
end sub
</script>

数据绑定

SortedList 对象可自动地为下面的控件生成文本和值：

  • asp:RadioButtonList
  • asp:CheckBoxList
  • asp:DropDownList
  • asp:Listbox

如需把数据绑定到 RadioButtonList 控件，首先请在 aspx 文件中创建一个 RadioButtonList 控件（没有任何 asp:ListItem 元素）：

<html>
<body>

<form runat="server">
<asp:RadioButtonList id="rb" runat="server" AutoPostBack="True" />

</form>

</body>
</html>

然后添加构建列表的脚本：

<script runat="server">
sub Page_Load
if Not Page.IsPostBack then
  dim mycountries=New SortedList
  mycountries.Add("C","China")
  mycountries.Add("S","Sweden")
  mycountries.Add("F","France")
  mycountries.Add("I","Italy")
  rb.DataSource=mycountries
  rb.DataValueField="Key"
  rb.DataTextField="Value"
  rb.DataBind()
end if
end sub
</script>

<html>
<body>

<form runat="server">
<asp:RadioButtonList id="rb" runat="server" AutoPostBack="True" />

</form>

</body>
</html>

然后我们添加一个子例程，该子例程会在用户点击 RadioButtonList 控件中的项目时执行。当单选按钮被点击时，文本将出现在 label 中：

<script runat="server">
sub Page_Load
if Not Page.IsPostBack then
  dim mycountries=New SortedList
  mycountries.Add("C","China")
  mycountries.Add("S","Sweden")
  mycountries.Add("F","France")
  mycountries.Add("I","Italy")
  rb.DataSource=mycountries
  rb.DataValueField="Key"
  rb.DataTextField="Value"
  rb.DataBind()
end if
end sub

sub displayMessage(s as Object,e As EventArgs)
lbl1.text="Your favorite country is: " & rb.SelectedItem.Text
end sub
</script>

<html>
<body>

<form runat="server">
<asp:RadioButtonList id="rb" runat="server"
AutoPostBack="True" onSelectedIndexChanged="displayMessage" />
<p><asp:label id="lbl1" runat="server" /></p>
</form>

</body>
</html>
  • Previous Page
  • Next Page

ASP.NET 参考手册


ASP.NET - Web 页面

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET - Web 页面

  • Previous Page
  • Next Page

一个简单的 ASP.NET 页面看上去类似一张普通的 HTML 页面。

Hello W3School

为了开始我们的 ASP.NET 学习之旅，首先我们将构造一张简单的 HTML 页面，这张页面将在浏览器中显示 "Hello W3School"：

用 HTML 编写的 Hello W3School

这张 HTML 页面的 HTML 代码：

<html>
<body bgcolor="yellow">
<center>
<h2>Hello W3School!</h2>
</center>
</body>
</html>

如果您希望亲自试一试，可以把这些代码保存在名为 "firstpage.html" 的文件中，然后创建一个到此文件的链接，就像这样：firstpage.html。

用 ASP.NET 编写的 Hello W3School

把 HTML 页面转换为 ASP.NET 的最简单的方法是，把这个 HTML 文件拷贝为带有 .aspx 后缀的新文件。

这些将把我们的例子显示为一个 ASP.NET 页面：

<html>
<body bgcolor="yellow">
<center>
<h2>Hello W3School!</h2>
</center>
</body>
</html>

如果您希望亲自试一试，请把这些代码保存在一个名为 "firstpage.aspx" 的文件中，并创建一个到此文件的链接：firstpage.aspx。

它如何工作？

从根本上讲，ASP.NET 页面与 HTML 完全相同。

HTML 页面的扩展名是 .htm 或 .html。假如浏览器从服务器请求某张 HTML 页面，服务器不进行任何修改，就会把该页面发往浏览器。

ASP.NET 页面的扩展名是 .aspx。如果浏览器请求某张 ASP.NET 页面，那么在把结果发回浏览器之前，服务器首先会处理页面中的可执行代码。

上面的 ASP.NET 页面不包含任何可执行的代码，因此也不会执行任何代码。在下面的例子中，我们将向页面添加一些可执行代码，以便向您演示静态 HTML 页面与动态 ASP 页面的不同之处。

经典的 ASP

Active Server Pages (ASP) 已经流行很多年了。通过 ASP，可以把可执行代码放置于 HTML 页面内部。

ASP.NET 之前的 ASP 版本经常被称为经典 ASP（Classic ASP）。

ASP.NET 不完全兼容 Classic ASP，但是通过少量的修改，Classic ASP 可以良好地作为 ASP.NET 进行工作。

如果您希望学习更多有关 Classic ASP 的知识，请访问我们的 ASP 教程。

用 Classic ASP 编写的动态页面

为了向您演示如何使用动态内容显示页面，我们向上面的例子添加了一些可执行代码：

<html>
<body bgcolor="yellow">
<center>
<h2>Hello W3School!</h2>
<p><%Response.Write(now())%></p>
</center>
</body>
</html>

<% --%> 标签内的代码在服务器上执行。

Response.Write 是 ASP 代码，用来向 HTML 输出流文本。

Now() 是一个可返回服务器当前日期和时间的函数。

如果您希望亲自试一试，可以把这些代码保存在名为 "dynpage.asp" 的文件中，并创建一个指向该文件的链接：dynpage.asp。

用 ASP .NET 编写的动态页面

下面的代码可把我们的例子显示为一个 ASP.NET 页面：

<html>
<body bgcolor="yellow">
<center>
<h2>Hello W3School!</h2>
<p><%Response.Write(now())%></p>
</center>
</body>
</html>

如果您希望亲自试一试，请把这些代码保存在名为 "dynpage.aspx" 的文件中，然后创建到此文件的链接：dynpage.aspx。

ASP.NET vs Classic ASP

上面的例子无法展示出 ASP.NET 与 Classic ASP 之间的不同之处。

正如您在最后的两个例子中看到的，在这个两个 ASP 和 ASP.NET 页面之间，没有什么不同之处。

在下面的章节，您会看到，服务器控件如何使 ASP.NET 比 Classic ASP 更加强大。

  • Previous Page
  • Next Page

ASP.NET 参考手册


ASP.NET - 服务器控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET - 服务器控件

  • Previous Page
  • Next Page

服务器控件是服务器可以理解的标签。

Classic ASP 的局限性

下面列出的代码是从上一节中拷贝的：

<html>
<body bgcolor="yellow">
<center>
<h2>Hello W3School!</h2>
<p><%Response.Write(now())%></p>
</center>
</body>
</html>

上面的代码能够反映出 Classic ASP 的局限性：代码块必须放置在需要进行输出的位置。

通过 Classic ASP，我们是无法将可执行代码与 HTML 本身进行分离的。这使得页面难以阅读，也难以维护。

ASP.NET - 服务器控件

通过服务器控件，ASP.NET 已经解决了上面所描述的“意大利面条式代码”的问题。

服务器控件是可被服务器理解的标签。

有三种类型的服务器控件：

  • HTML 服务器控件 - 传统的 HTML 标签
  • Web 服务器控件 - 新的 ASP.NET 标签
  • Validation 服务器控件 - 用于输入验证

ASP.NET - HTML 服务器控件

HTML 服务器控件是服务器可理解的 HTML 标签。

ASP.NET 中的 HTML 元素是作为文本来进行处理的。要想使这些元素可编程，就需要向这些 HTML 元素添加 runat="server" 属性。该属性指示，此元素是一个服务器控件。同时要添加 id 属性来标识该服务器控件。id 引用可用于操作运行时的服务器控件。

注释：所有 HTML 服务器控件必须位于带有 runat="server" 属性的 <form> 标签内。runat="server" 属性指示该表单应在服务器进行处理。它同时指示其包括在内的控件可被服务器脚本访问。

在下面的例子中，我们在 .aspx 文件中声明了一个 HtmlAnchor 服务器控件。然后我们在一个事件句柄中操作该 HtmlAnchor 控件的 HRef 属性。Page_Load 事件是众多 ASP.NET 可理解的事件中的一种类型：

注释：事件句柄（event handler）是一种针对给定事件执行代码的子例程。

<script runat="server">
Sub Page_Load
link1.HRef="http://www.w3school.com.cn"
End Sub
</script>

<html>
<body>

<form runat="server">
<a id="link1" runat="server">Visit W3School!</a>
</form>

</body>
</html>

提示：可执行代码本身已被移到 HTML 之外了。

ASP.NET - Web 服务器控件

Web 服务器控件是服务器可理解的特殊 ASP.NET 标签。

类似 HTML 服务器控件，Web 服务器控件也在服务器上创建，它们同样需要 runat="server" 属性以使其生效。不过，Web 服务器控件没有必要映射任何已存在的 HTML 元素，它们代表更复杂的元素。

创建 Web 服务器控件的语法是：

<asp:control_name id="some_id" runat="server" />

在下面的例子中，我们在 .aspx 文件中的声明了一个 Button 服务器控件。然后我们为 Click 事件创建了一个事件句柄，它可修改按钮上的文本：

<script runat="server">
Sub submit(Source As Object, e As EventArgs)
button1.Text="You clicked me!"
End Sub
</script>

<html>
<body>

<form runat="server">
<asp:Button id="button1" Text="Click me!" runat="server" OnClick="submit"/>
</form>

</body>
</html>

ASP.NET - Validation 服务器控件

Validation 服务器控件用于验证用户输入。如果用户输入没有通过验证，将给用户显示一条错误消息。

每种 validation 控件执行一种特定的验证类型（比如验证某个具体的值或者某个范围的值）。

默认地，当点击 Button, ImageButton 或 LinkButton 时，页面验证才会被执行。您可通过把 CausesValidation 属性设置为 false，来阻止某个按钮控件被点击时进行验证。

创建 Validation 服务器控件的语法是：

<asp:control_name id="some_id" runat="server" />

在下面的例子中，我们在 .aspx 文件中声明了一个 TextBox 控件，一个 Button 控件，以及一个 RangeValidator 控件。如果验证失败，文本 "The value must be from 1 to 100!" 将显示在 RangeValidator 控件中：

<html>
<body>
<form runat="server">

<p>Enter a number from 1 to 100:
<asp:TextBox id="tbox1" runat="server" />
<br /><br />
<asp:Button Text="Submit" runat="server" />
</p>

<p>
<asp:RangeValidator
ControlToValidate="tbox1"
MinimumValue="1"
MaximumValue="100"
Type="Integer"
Text="The value must be from 1 to 100!"
runat="server" />
</p>

</form>
</body>
</html>

TIY

  • Previous Page
  • Next Page

ASP.NET 参考手册


ASP.NET - 事件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET - 事件

  • Previous Page
  • Next Page

事件句柄（event handler）是一种针对给定事件来执行代码的子例程。

ASP.NET - 事件句柄

请看下面的代码：

<%
lbl1.Text="The date and time is " & now()
%>

<html>
<body>
<form runat="server">
<h3><asp:label id="lbl1" runat="server" /></h3>
</form>
</body>
</html>

上面的代码什么时候会被执行？答案是：“我不知道. . .”

Page_Load 事件

Page_Load 事件是众多 ASP.NET 可理解的事件之一。Page_Load 事件会在页面加载时被触发，然后 ASP.NET 会自动调用子例程 Page_Load，并执行其中的代码：

<script runat="server">
Sub Page_Load
lbl1.Text="The date and time is " & now()
End Sub
</script>

<html>
<body>
<form runat="server">
<h3><asp:label id="lbl1" runat="server" /></h3>
</form>
</body>
</html>

注释：该 Page_Load 事件不包含对象引用或事件参数！

TIY

Page.IsPostBack 属性

Page_Load 子例程会在页面每次加载时运行。如果您仅希望在页面第一次加载时执行 Page_Load 子例程中的代码，您可以使用 Page.IsPostBack 属性。如果 Page.IsPostBack 属性为 false，则页面第一次被载入，如果为 true，则页面传回服务器（例如，通过点击表单上的按钮）：

<script runat="server">
Sub Page_Load
if Not Page.IsPostBack then
  lbl1.Text="The date and time is " & now()
end if
End Sub

Sub Submit(s As Object, e As EventArgs)
lbl2.Text="Hello World!"
End Sub
</script>

<html>
<body>
<form runat="server">
<h3><asp:label id="lbl1" runat="server" /></h3>
<h3><asp:label id="lbl2" runat="server" /></h3>
<asp:button text="Submit" onclick="submit" runat="server" />
</form>
</body>
</html>

上面的例子仅在页面初次加载时创建 "The date and time is...." 这条消息。当用户点击 Submit 按钮时，submit 子例程将在第二个 label 创建 "Hello World!"，但第一个 label 中的日期和时间不会改变。

TIY

  • Previous Page
  • Next Page

ASP.NET 参考手册


ASP.NET - 数据绑定

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET - 数据绑定

  • Previous Page
  • Next Page

我们可以使用数据绑定（Data Binding）来完成带有可选项目的列表，这些可选项目来自某个导入的数据源，比如数据库、XML 文件或脚本。

数据绑定

下面的控件是支持数据绑定的列表控件：

  • asp:RadioButtonList
  • asp:CheckBoxList
  • asp:DropDownList
  • asp:Listbox

通常在一个或多个 asp:ListItem 控件中定义以上每个控件中的可选项目，类似这样：

<html>
<body>

<form runat="server">
<asp:RadioButtonList id="countrylist" runat="server">
<asp:ListItem value="C" text="China" />
<asp:ListItem value="S" text="Sweden" />
<asp:ListItem value="F" text="France" />
<asp:ListItem value="I" text="Italy" />
</asp:RadioButtonList>
</form>

</body>
</html>

不过，我们可以使用某种独立的源进行数据绑定，比如数据库、XML 文件或脚本来完成带有可选项目的列表。

通过使用导入的源，数据从 HTML 分离了出来，并且对项目的任何改变都是在独立的数据源中完成的。

在下面的三节中，我们将描述如何从脚本化的数据源中绑定数据。

  • Previous Page
  • Next Page

ASP.NET 参考手册


ASP.NET - 数据库连接

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET - 数据库连接

  • Previous Page
  • Next Page

ADO.NET 同样是 .NET 框架的组成部分。ADO.NET 的职能是处理数据访问。通过 ADO.NET，您就可以操作数据库了。

实例

数据库连接 - 绑定到 Repeater 控件
数据库连接 - 绑定到 DataList 控件

什么是 ADO.NET？

  • ADO.NET 是 .NET 框架的组成部分
  • ADO.NET 由一系列用于操作数据访问的类组成
  • ADO.NET 完全基于 XML
  • ADO.NET 没有 Recordset 对象，这一点与 ADO 不同

创建数据库连接

我们计划使用曾经使用过的 Northwind 数据库。

首先，导入命名空间 "System.Data.OleDb"。我们需要该命名空间，以便可以操作 Microsoft Access 以及其他的 OLE DB 数据库提供者。我们将在 Page_Load 子例程中创建对此数据库的连接。我们创建了一个 dbconn 变量，并把新的 OleDbConnection 类赋值给这个变量，这个 OleDbConnection 类带有一个连接字符串，可以指示 OLE DB 以及数据库的位置。然后我们打开此数据库连接：

<%@ Import Namespace="System.Data.OleDb" %>

<script runat="server">
sub Page_Load
dim dbconn
dbconn=New OleDbConnection("Provider=Microsoft.Jet.OLEDB.4.0;
data source=" & server.mappath("northwind.mdb"))
dbconn.Open()
end sub
</script>

注释：这个连接字符串必须是没有折行的连续字符串！

创建数据库命令

为了指定需从数据库取回的记录，我们将创建一个 dbcomm 变量，并为其赋值一个新的 OleDbCommand。这个 OleDbCommand 类用于发出针对数据库表的 SQL 查询：

<%@ Import Namespace="System.Data.OleDb" %>

<script runat="server">
sub Page_Load
dim dbconn,sql,dbcomm
dbconn=New OleDbConnection("Provider=Microsoft.Jet.OLEDB.4.0;
data source=" & server.mappath("northwind.mdb"))
dbconn.Open()
sql="SELECT * FROM customers"
dbcomm=New OleDbCommand(sql,dbconn)
end sub
</script>

创建 DataReader

OleDbDataReader 类用于从数据源中读取记录流。通过调用 OleDbCommand 对象的 ExecuteReader 方法，就可以创建 DataReader：

<%@ Import Namespace="System.Data.OleDb" %>

<script runat="server">
sub Page_Load
dim dbconn,sql,dbcomm,dbread
dbconn=New OleDbConnection("Provider=Microsoft.Jet.OLEDB.4.0;
data source=" & server.mappath("northwind.mdb"))
dbconn.Open()
sql="SELECT * FROM customers"
dbcomm=New OleDbCommand(sql,dbconn)
dbread=dbcomm.ExecuteReader()
end sub
</script>

绑定到 Repeater 控件

然后，我们把这个 DataReader 绑定到一个 Repeater 控件：

<%@ Import Namespace="System.Data.OleDb" %>

<script runat="server">
sub Page_Load
dim dbconn,sql,dbcomm,dbread
dbconn=New OleDbConnection("Provider=Microsoft.Jet.OLEDB.4.0;
data source=" & server.mappath("northwind.mdb"))
dbconn.Open()
sql="SELECT * FROM customers"
dbcomm=New OleDbCommand(sql,dbconn)
dbread=dbcomm.ExecuteReader()
customers.DataSource=dbread
customers.DataBind()
dbread.Close()
dbconn.Close()
end sub
</script>

<html>
<body>

<form runat="server">
<asp:Repeater id="customers" runat="server">

<HeaderTemplate>
<table border="1" width="100%">
<tr>
<th>Companyname</th>
<th>Contactname</th>
<th>Address</th>
<th>City</th>
</tr>
</HeaderTemplate>

<ItemTemplate>
<tr>
<td><%#Container.DataItem("companyname")%></td>
<td><%#Container.DataItem("contactname")%></td>
<td><%#Container.DataItem("address")%></td>
<td><%#Container.DataItem("city")%></td>
</tr>
</ItemTemplate>

<FooterTemplate>
</table>
</FooterTemplate>

</asp:Repeater>
</form>

</body>
</html>

关闭数据库连接

在不在需要访问数据库后，请记得始终将 DataReader 和数据库连接关闭：

dbread.Close()
dbconn.Close()
  • Previous Page
  • Next Page

ASP.NET 参考手册


ASP.NET - 维持 ViewState

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET - 维持 ViewState

  • Previous Page
  • Next Page

通过在 Web 表单中维持对象的 ViewState （视图状态），您可以省去大量的编码工作。

维持 ViewState （视图状态）

当 classic ASP 中的表单被提交时，所有的表单值都会被清空。设想一下，您提交了一张带有大量信息的表单，而服务器返回了一个错误。您将不得不返回表单，然后更正其中的信息。您点击后退按钮，然后会发生什么呢... 所有的表单值都被清空了，而您将不得不重新开始所有的一切。站点不会维持您的 ViewState。

当 ASP .NET 中的表单被提交时，表单会随所有表单值一同重新出现。如何做到的呢？这是由于 ASP .NET 维持了您的 ViewState。ViewState 会在页面被提交到服务器时指示其状态。通过在每张页面中的一个 <form runat="server"> 控件中放置一个隐藏域，我们就可以定义页面的状态了。源代码可能类似这样：

<form name="_ctl0" method="post" action="page.aspx" id="_ctl0">
<input type="hidden" name="__VIEWSTATE"
value="dDwtNTI0ODU5MDE1Ozs+ZBCF2ryjMpeVgUrY2eTj79HNl4Q=" />

.....some code

</form>

维持 ViewState 是 ASP.NET Web 表单的默认设置。如果您不希望维持 ViewState，请在 .aspx 页面的顶部包含指令： <%@ Page EnableViewState="false" %>，或为任意控件添加属性：EnableViewState="false"。

请看下面的 .aspx 文件。它演示了老的运行方式。当您单击提交按钮时，表单值就会消失：

<html>
<body>

<form action="demo_classicasp.aspx" method="post">
Your name: <input type="text" name="fname" size="20">
<input type="submit" value="Submit">
</form>
<%
dim fname
fname=Request.Form("fname")
If fname<>"" Then
Response.Write("Hello " & fname & "!")
End If
%>

</body>
</html>

TIY

这是新的 ASP .NET 方式。当您点击提交按钮时，表单值不会消失：

<script runat="server">
Sub submit(sender As Object, e As EventArgs)
lbl1.Text="Hello " & txt1.Text & "!"
End Sub
</script>

<html>
<body>

<form runat="server">
Your name: <asp:TextBox id="txt1" runat="server" />
<asp:Button OnClick="submit" Text="Submit" runat="server" />
<p><asp:Label id="lbl1" runat="server" /></p>
</form>

</body>
</html>

TIY （请在右边的框架中点击“查看原文档”，您可以看到 ASP .NET 已经向表单中添加了一个隐藏域，这样就可以维持 ViewState。）

  • Previous Page
  • Next Page

ASP.NET 参考手册


ASP.NET 2.0 - 导航（Navigation）

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET 2.0 - 导航（Navigation）

  • Previous Page
  • Next Page

ASP.NET 2.0 拥有内建的导航控件。

网站导航

维护大型站点的导航菜单是很困难，也很费时的。

在 ASP.NET 2.0 中，菜单可存储在文件中，这样维护起来更加方便。这个文件通常名为 web.sitemap，被存放在网站的根目录中。

此外，ASP.NET 2.0 拥有三种新的导航控件：

  • Dynamic menus
  • TreeViews
  • Site Map Path

Sitemap 文件

本教程使用下面的 sitemap 文件：

<?xml version="1.0" encoding="ISO-8859-1" ?>
<siteMap>
  <siteMapNode title="Home" url="/aspnet/w3home.aspx">
  <siteMapNode title="Services" url="/aspnet/w3services.aspx">
    <siteMapNode title="Training" url="/aspnet/w3training.aspx"/>
    <siteMapNode title="Support" url="/aspnet/w3support.aspx"/>
  </siteMapNode>
  </siteMapNode>
</siteMap>

创建 sitemap 文件的规则：

  • XML 文件必须包含围绕内容的 <siteMap> 标签
  • <siteMap> 标签只能有一个 <siteMapNode> 子节点 ("home" page)
  • 每个 <siteMapNode> 可以有多个子节点 (web pages)
  • 每个 <siteMapNode> 拥有定义页面标题和 URL 的属性

注释：sitemap 文件必须存放在站点的根目录中，URL 属性必须相对于该根目录。

Dynamic Menu

<asp:Menu> 控件可显示标准的站点导航菜单。

代码实例：

<asp:SiteMapDataSource id="nav1" runat="server" />

<form runat="server">
<asp:Menu runat="server" DataSourceId="nav1" />
</form>

在上面的例子中的 <asp:Menu> 控件是一个供服务器创建导航菜单的占位符。

控件的数据源由 DataSourceId 属性进行定义。id="nav1" 把它连接到 <asp:SiteMapDataSource> 控件。

<asp:SiteMapDataSource> 控件会自动连接默认的 sitemap 文件(web.sitemap)。

点击此处查看 Menu、TreeView 以及 SiteMapPath 的 DEMO。

TreeView

<asp:TreeView> 控件可显示多级导航菜单。

这种菜单看上去像一棵带有枝叶的树，可通过 + 或 - 符号来打开或关闭。

代码实例：

<asp:SiteMapDataSource id="nav1" runat="server" />

<form runat="server">
<asp:TreeView runat="server" DataSourceId="nav1" />
</form>

上面例子中的 <asp:TreeView> 控件是一个供服务器创建导航菜单的占位符。

控件的数据源由 DataSourceId 属性进行定义。id="nav1" 把它连接到 <asp:SiteMapDataSource> 控件。

<asp:SiteMapDataSource> 控件会自动连接默认的 sitemap 文件(web.sitemap)。

点击此处查看 Menu、TreeView 以及 SiteMapPath 的 DEMO。

SiteMapPath

SiteMapPath 控件可显示指向当前页面的指针（导航路径）。该路径显示为指向上级页面的可点击链接。

与 TreeView 和 Menu 控件不同，SiteMapPath 控件不使用 SiteMapDataSource。SiteMapPath 控件默认使用 web.sitemap 文件。

提示：如果 SiteMapPath 没有正确显示，很可能是由于 web.sitemap 文件中存在 URL 错误。

代码实例：

<form runat="server">
<asp:SiteMapPath runat="server" />
</form>

上面例子中的 <asp:SiteMapPath> 控件是一个供服务器创建导航菜单的占位符。

点击此处查看 Menu、TreeView 以及 SiteMapPath 的 DEMO。

  • Previous Page
  • Next Page

ASP.NET 参考手册


ASP.NET 2.0 - 母版页（Master Pages）

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET 2.0 - 母版页（Master Pages）

  • Previous Page
  • Next Page

母版页（Master Pages）为网站内的其他页面提供模版。

母版页（Master Pages）

Master Page 使您有能力为 web 应用程序中的所有页面（或页面组）创建一致的外观和行为。

Master Page 为其他页面提供了模版，带有共享的布局和功能。Master Page 为内容定义了可被内容页面覆盖的占位符。而输出结果就是 Master Page 和内容页面的组合。

内容页包含您希望显示的内容。

当用户请求内容页时，ASP.NET 会对页面进行合并以生成输出，输出结果对 Master Page 的布局和内容页面的内容进行了合并。

Master Page 实例：

<%@ Master %>

<html>
<body>
<h1>Standard Header For All Pages</h1>

<asp:ContentPlaceHolder id="CPH1" runat="server">
</asp:ContentPlaceHolder>

</body>
</html>

Master Page 是一张为其他页面设计的普通 HTML 模版页。

@ Master 指令把它定义为一个张 master page。

这个 master page 为单独的内容包含了一个占位符标签 <asp:ContentPlaceHolder>。

id="CPH1" 属性标识该占位符，在相同的 master page 中允许多个占位符。

该 master page 被保存为 "master1.master"。

注释：该 master page 也能够包含代码，允许动态的内容。

内容页实例：

<%@ Page MasterPageFile="master1.master" %>

<asp:Content ContentPlaceHolderId="CPH1" runat="server">

<h2>Individual Content</h2>
<p>Paragrap 1</p>
<p>Paragrap 2</p>

</asp:Content>

上面的内容页是独立的内容页面之一。

@ Page 指令把它定义为一张标准的内容页面。

该内容页面包含了一个内容标签<asp:Content>，该标签引用了母版页(ContentPlaceHolderId="CPH1")。

该内容页被保存为 "mypage1.aspx"。

当用户请求该页面时，ASP.NET 就会将母版页与内容页进行合并。

点击这里显示 mypage1.aspx。

注释：内容文本必须位于 <asp:Content> 标签内。该标签外的文本是不被允许的。

带有控件的内容页

<%@ Page MasterPageFile="master1.master" %>

<asp:Content ContentPlaceHolderId="CPH1" runat="server">

<h2>W3School</h2>
<form runat="server">
<asp:TextBox id="textbox1" runat="server" />
<asp:Button id="button1" runat="server" text="Button" />
</form>
</asp:Content>

上面的内容页演示了如何把 .NET 控件插入内容页，就像插入一个普通的页面中。

点击这里显示 mypage2.aspx。

  • Previous Page
  • Next Page

ASP.NET 参考手册


ASP.NET 2.0 - 新特性

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET 2.0 - 新特性

  • Previous Page
  • Next Page

通过增加若干新的特性，ASP.NET 2.0 对 ASP.NET 进行了改进。

ASP.NET 2.0 中的改进

ASP.NET 2.0 的设计目的是为了使 web 开发更容易，更快捷。

ASP.NET 2.0 的设计目标：

  • 消除 70% 的代码量，以提高生产力
  • 为所有类型的设备使用相同的控件
  • 提供更快更好的 web 服务器平台
  • 简化编译和安装
  • 简化 web 应用程序的管理

ASP.NET 2.0 中的新特性

ASP.NET 2.0 中的某些新特性是：

  • 母版页(Master Pages)、主题以及 Web 部件
  • 针对导航的标准控件
  • 针对安全的标准控件
  • 角色、个性化和国际化服务
  • 改进并简化的数据访问控件
  • 对 XML 标准的完整支持，比如 XHTML、XML 以及 WSDL
  • 改进的编译和部署（安装）
  • 改进的站点管理
  • 新的改进的开发工具

下面开始描述这些新特性。

母版页(Master Pages)

过去，ASP.NET 没有能力为一个完整的站点应用一致的外观或观感。

ASP.NET 2.0 中的 Master Pages 解决了这个问题。

master page 是一套应用到其他页面的模版，带有共享的布局和功能性。master page 为内容页面定义了占位符。而结果页面是 master page 和内容页面的组合（合并）。

阅读更多有关 master page 的内容。

主题（Themes）

主题是另一项 ASP.NET 2.0 的特性。主题，或皮肤，允许开发者为 web 应用程序创建定制的外观。

ASP.NET 2.0 主题的设计目标：

  • 使站点外观的定制变得容易
  • 允许主题被应用到控件、页面以及整个站点
  • 允许定制所有可见的元素

Web 部件（Web Parts）

ASP.NET 2.0 的 Web 部件能够为站点提供一致的外观，同时仍然允许用户定制样式和内容。

新控件：

  • Zone 控件 - 页面上内容一致的区域
  • Web part 控件 - 每个 zone 的内容区域

导航（Navigation）

ASP.NET 2.0 拥有内建的导航控件，比如：

  • Site Maps
  • Dynamic HTML menus
  • Tree Views

安全（Security）

对于保护机密以及个人的信息来说，安全性非常重要。

在 ASP.NET 2.0，已经添加了下面这些控件：

  • Login 控件，提供登录功能
  • LoginStatus 控件，控制登录状态
  • LoginName 控件，显示当前用户名
  • LoginView 控件，根据登录状态提供不同的视图
  • CreateUser wizard，进行用户帐户的创建
  • PasswordRecovery 控件，提供“忘记密码”功能

角色和个性化（Roles and Personalization）

因特网社区越来越流行。

ASP.NET 2.0 拥有可存储用户细节信息的个性化特性。该特性为自定义用户（以及用户组）的属性的提供了便捷的方法。

国际化（Internationalization）

当您拥有更庞大的受众时，通过不同的语言服务用户是很重要的。

ASP.NET 2.0 已经改进了对多语言的支持。

数据访问（Data Access）

许多网站都是靠数据驱动的，它们使用数据库或 XML 文件作为数据源。

在使用 ASP.NET 的过程中，相关代码，以及相同的的代码经常被重复使用在不同的网页中。

ASP.NET 2.0 的一个核心目标，就是简化了数据源的使用。

ASP.NET 2.0 拥有新的数据控件，无需太多编程以及深入的数据库连接方面的知识。

Mobility Support

移动设备的问题是屏幕的尺寸以及显示能力。

在 ASP.NET 中，微软的移动因特网套件 (Microsoft Mobile Internet Toolkit，MMIT) 提供了这方面的支持。

在 ASP.NET 2.0 中，不再需要 MMIT，因为所有的控件都内建了移动支持。

图像（Images）

ASP.NET 2.0 拥有用于处理图像的新控件：

  • ImageMap 控件 - 图像映射支持
  • DynamicImage 控件 - 对不同浏览器的图像支持

这些空间对移动设备上更优化的图像显示非常重要，比如手持电脑和移动电话。

自动编译（Automatic Compilation）

ASP.NET 2.0 提供了自动编译。所有同一目录中的文件会在首次运行时进行编译，包含对 WSDL 以及 XSD 文件的支持。

已编译的部署方式（安装）以及源代码保护

ASP.NET 2.0 同时提供了预编译（pre-compilation）。能够对整个站点进行预编译。这就提供了一种部署（上传到服务器）已编译应用程序的简易方法，同时由于只有已编译的文件能够进行部署，源代码也受到了保护。

站点管理（Site Management）

ASP.NET 2.0 有三种配置管理站点的新特性：

  • 新的本地管理控制台
  • 新的可编程管理功能 (API)
  • 新的基于 web 的管理工具

开发工具（Development Tools）

Visual Studio 2005 的核心设计特性包括：

  • 对以上所描述的特性的支持
  • 从任何地点上传文件（FTP、文件系统、Front Page....）
  • 没有项目文件，允许代码在 Visual Studio 之外使用
  • 整合了网站管理工具
  • 没有“构建”步骤 - 首次运行时进行编译的能力

而对于没有能力使用 Visual Studio.NET 的非企业开发者来说，Visual Web Developer 是一个新的免费的 ASP.NET 2.0 工具。

  • Previous Page
  • Next Page

ASP.NET 参考手册


ASP.NET AdRotator 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET AdRotator 控件

返回 Web 服务器控件参考手册

定义和用法

AdRotator 控件用于显示图像序列。

该控件使用 XML 文件来存储 ad 信息。XML 文件使用 <Advertisements> 开始和结束。在 <Advertisements> 标签内部，应该有若干个定义每条 ad 的 <Ad> 标签。

<Ad> 标签中预定义的元素被列在下面：

属性 | 描述
<ImageUrl> | 可选。图像文件的路径。
<NavigateUrl> | 可选。用户点击该 ad 时所链接的 URL。
<AlternateText> | 可选。图像的可选文本。
<Keyword> | 可选。ad 的类别。
<Impressions> | 可选。显示概率。

属性

属性 | 描述 | .NET
AdvertisementFile | 包含 ad 信息的 XML 文件的路径。 | 1.0
AlternateTextField | 代替广告的 Alt 文本而使用的数据字段。 | 2.0
ImageUrlField | 代替广告的 ImageURL 属性而使用的数据字段。 | 2.0
KeywordFilter | 根据类别对广告进行过滤。 | 1.0
NavigateUrlField | 代替广告的 NavigateUrl 属性而使用的数据字段。 | 2.0
runat | 规定该控件是服务器控件。必须设置为 "server"。 | 1.0
Target | 在何处打开 URL。 | 1.0

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

实例

AdRotator
在本例中，我们在 .aspx 文件中声明了一个 AdRotator 控件。然后我们再 .aspx 文件中为 AdCreated 事件创建了一个事件句柄，来覆盖 XML 文件中 NavigateUrl 元素的值。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET BulletedList 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET BulletedList 控件

返回 Web 服务器控件参考手册

定义和用法

BulletedList 能够以项目符号的格式来创建列表。

BulletedList 控件中的每个项目都由 ListItem 元素来定义！

注释：它是 ASP.NET 2.0 中的新类。

属性

属性 | 描述 | .NET
BulletImageUrl | 规定定制的列表项目图形符号的 URL。 在 "BulletStyle" 为 "CustomImage" 时使用。 | 2.0
BulletStyle | 规定项目符号列表的样式。 | 2.0
DisplayMode | 规定被显示的列表的类型。 | 2.0
FirstBulletNumber | 规定在有序列表中列表项目的起始数字。 | 2.0
runat | 必需。规定此控件是服务器控件。必须设置为 "server"。 | 1.0
Target | 规定在何处打开目标 URL。 | 2.0

ListControl 标准属性

AppendDataBoundItems, AutoPostBack, CausesValidation, DataTextField,
DataTextFormatString, DataValueField, Items, runat, SelectedIndex, SelectedItem,
SelectedValue, TagKey, Text, ValidationGroup, OnSelectedIndexChanged

ListControl 控件包括列表控件的所有基本功能。继承自此控件的控件包括：CheckBoxList, DropDownList, ListBox 以及 RadioButtonList 控件。

如需完整描述，请访问 ListControl 标准属性。

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET Button 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET Button 控件

返回 Web 服务器控件参考手册

定义和用法

Button 控件用于显示按钮。按钮可以是提交按钮或命令按钮。默认地，该控件是提交按钮。

提交按钮没有命令名称，在它被点击时它会把网页传回服务器。可以编写事件句柄来控制提交按钮被点击时执行的动作。

命令按钮拥有命令名称，且允许您在页面上创建多个按钮控件。可以编写事件句柄来控制命令按钮被点击时执行的动作。

属性

属性 | 描述 | .NET
CausesValidation | 规定当 Button 被点击时是否验证页面。 | 1.0
CommandArgument | 有关要执行的命令的附加信息。 | 1.0
CommandName | 与 Command 相关的命令。 | 1.0
OnClientClick | 当按钮被点击时被执行的函数的名称。 | 2.0
PostBackUrl | 当 Button 控件被点击时从当前页面传送数据的目标页面 URL。 | 2.0
runat | 规定该控件是服务器控件。必须设置为 "server"。 | 1.0
Text | 按钮上的文本。 | 1.0
UseSubmitBehavior | 一个值 ，该值指示 Button 控件使用浏览器的提交机制，还是使用 ASP.NET 的 postback 机制。 | 2.0
ValidationGroup | 当 Button 控件回传服务器时，该 Button 所属的哪个控件组引发了验证。 | 2.0

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

实例

Button
在本例中，我们在 .aspx 文件中声明了一个提交 Button 控件。然后我们创建了一个事件句柄，在 Click 事件发生时可更改按钮上的文本。
Button 2
在本例中，我们在 .aspx 文件中声明了一个提交 Button 控件。然后我们创建了一个事件句柄，在 Click 事件发生时可更改按钮的文本和样式。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET Calendar 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET Calendar 控件

返回 Web 服务器控件参考手册

定义和用法

Calendar 控件用于在浏览器中显示日历。

该控件可显示某个月的日历，允许用户选择日期，也可以跳到前一个或下一个月。

属性

属性 | 描述 | .NET
Caption | 日历的标题。 | 2.0
CaptionAlign | 日历标题文本的对齐方式。 | 2.0
CellPadding | 单元格边框与内容之间的空白，以像素计。 | 1.0
CellSpacing | 单元格之间的空白，以像素计。 | 1.0
DayHeaderStyle | 显示一周中某天的名称的样式。 | 1.0
DayNameFormat | 显示周中各天的名称格式。 | 1.0
DayStyle | 显示日期的样式。 | 1.0
FirstDayOfWeek | 哪天是周的第一天。 | 1.0
NextMonthText | 显示下一月链接的文本。 | 1.0
NextPrevFormat | 下一月和上一月链接的格式。 | 1.0
NextPrevStyle | 显示下一月和上一月链接的样式。 | 1.0
OtherMonthDayStyle | 显示不在当前月中的日期的样式。 | 1.0
PrevMonthText | 显示上一月链接的文本。 | 1.0
runat | 规定该控件是服务器控件。必须设置为 "server"。 | 1.0
SelectedDate | 选定的日期。 | 1.0
SelectedDates | 选定的日期。 | 1.0
SelectedDayStyle | 选定日期的样式。 | 1.0
SelectionMode | 允许用户如何选择日期。 | 1.0
SelectMonthText | 显示为月份选择链接的文本。 | 1.0
SelectorStyle | 月份和周的选择链接的样式。 | 1.0
SelectWeekText | 显示为周的选择链接的文本。 | 1.0
ShowDayHeader | 布尔值，该值指示是否显示一周中各天的标头。 | 1.0
ShowGridLines | 布尔值，规定是否显示日期之间的网格线。 | 1.0
ShowNextPrevMonth | 布尔值，规定是否显示下一月和上一月链接。 | 1.0
ShowTitle | 布尔值，规定是否现实日期的标题。 | 1.0
TitleFormat | 日期标题的格式。 | 1.0
TitleStyle | 日期标题的样式。 | 1.0
TodayDayStyle | 当天的日期的样式。 | 1.0
TodaysDate | 获取或设置今天的日期的值。 | 1.0
UseAccessibleHeader | 规定是否使用 <th> 来代替 <td> 元素用于日的头部。 | 2.0
VisibleDate | 获取或设置指定要在 Calendar 控件上显示的月份的日期。 | 1.0
WeekendDayStyle | 周末的样式。 | 1.0
OnDayRender | 当每一天的单元格被创建时，所执行的函数的名称。 |
OnSelectionChanged | 当用户选择天、周或月时 ，所执行的函数的名称。 |
OnVisibleMonthChanged | 当用户导航到不同的月时，所执行的函数的名称。 |

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

实例

Calendar
在本例中，我们在 .aspx 文件中声明了一个使用最为简单的 Calendar 控件。
Calendar 2
在本例中，我们在 .aspx 文件中声明一个 Calendar 控件。日期以蓝色的完整名称显示，周末以黄色背景红色文字显示，而当前日期使用绿色背景显示。
Calendar 3
在本例中，我们在 .aspx 文件声明了一个 Calendar 控件。日期以完整名称显示，用户可以选择一天、一周或整个月，被选的天/周/月使用灰色背景色来显示。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET CalendarDay 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET CalendarDay 控件

返回 Web 服务器控件参考手册

定义和用法

CalendarDay 控件代表 calendar 控件中的一天。

属性

属性 | 描述 | .NET
Date | 该控件的日期变量。 | 1.0
DayNumberText | 日期的日期编号（字符串）。 | 1.0
IsOtherMonth | 规定该日期是否是显示在日历中的月份以外的另一个月份中的日期。 | 1.0
IsSelectable | 规定日期是否可选。 | 1.0
IsSelected | 规定日期是否被选定。 | 1.0
IsToday | 规定日期是否是今天的日期。 | 1.0
IsWeekend | 规定日期是否是星期六或星期日。 | 1.0

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET CheckBox 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET CheckBox 控件

返回 Web 服务器控件参考手册

定义和用法

CheckBox 控件用于显示复选框。

属性

属性 | 描述 | .NET
AutoPostBack | 规定在 Checked 属性已改变后，是否立即向服务器回传表单。默认是 false。 | 1.0
CausesValidation | 规定点击 Button 控件时是否执行验证。 | 2.0
Checked | 规定是否已选中该复选框。 | 1.0
InputAttributes | 该 CheckBox 控件的 Input 元素所用的属性名和值的集合。 | 2.0
LabelAttributes | 该 CheckBox 控件的 Label 元素所用的属性名和值的集合。 | 2.0
runat | 规定该控件是服务器控件。必须被设置为 "server"。 | 1.0
Text | 与 CheckBox 关联的文本标签。 | 1.0
TextAlign | 与 CheckBox 控件关联的文本标签的对齐方式。(right 或 left) | 1.0
ValidationGroup | 在 CheckBox 控件回发到服务器时要进行验证的控件组。 | 2.0
OnCheckedChanged | 当 Checked 属性被改变时，被执行函数的名称。 |

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

实例

Checkbox
在本例中，我们在 .aspx 文件中声明了两个 TextBox 控件和一个 CheckBox 控件。然后，我们为 CheckedChanged 事件创建一个事件句柄，把包含 home phone 的文本框的内容复制到包含 work phone 的文本框中。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET CheckBoxList 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET CheckBoxList 控件

返回 Web 服务器控件参考手册

定义和用法

CheckBoxList 控件用于创建多选的复选框组。

每个 CheckBoxList 控件中的可选项都是由 ListItem 元素定义的！

提示：该控件支持数据绑定！

属性

属性 | 描述 | .NET
CellPadding | 表格单元格的边框与内容之间的像素数。 | 1.0
CellSpacing | 表格单元格之间的像素数。 | 1.0
RepeatColumns | 当显示复选框组时所用的列数。 | 1.0
RepeatDirection | 规定复选框组水平重复还是垂直重复。 | 1.0
RepeatLayout | 复选框组的布局。 | 1.0
runat | 规定该控件是服务器控件。必须设置为 "server"。 | 1.0
TextAlign | 文本出现在复选框的那一侧。 | 1.0

ListControl 标准属性

AppendDataBoundItems, AutoPostBack, CausesValidation, DataTextField,
DataTextFormatString, DataValueField, Items, runat, SelectedIndex, SelectedItem,
SelectedValue, TagKey, Text, ValidationGroup, OnSelectedIndexChanged

ListControl 控件包括列表控件的所有基本功能。继承自此控件的控件包括：CheckBoxList, DropDownList, ListBox 以及 RadioButtonList 控件。

如需完整描述，请访问 ListControl 标准属性。

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

实例

CheckBoxList
在本例中，我们在 .aspx 文件中声明了一个 CheckBoxList 控件。然后我们为 SelectedIndexChanged 事件创建了一个事件句柄。这个可选列表包含六个复选框。当用户选中其中之一，页面会自动传回服务器，并执行 Check 子例程。该子例程会遍历控件的 Items 集合，并测试每个项目的 Selected 属性。被选的项目会显示在 Label 控件中。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET CompareValidator 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET CompareValidator 控件

返回 Validation 服务器控件

定义和用法

CompareValidator 控件用于将由用户输入到输入控件的值与输入到其他输入控件的值或常数值进行比较。

注释：如果输入控件为空，则不会调用任何验证函数，并且验证将成功。使用 RequiredFieldValidator 控件使字段成为必选字段。

属性

属性 | 描述
BackColor | CompareValidator 控件的背景颜色。
ControlToCompare | 要与所验证的输入控件进行比较的输入控件。
ControlToValidate | 要验证的输入控件的 ID。
Display

验证控件中错误信息的显示行为。

合法值是：

  • None 验证消息从不内联显示。
  • Static 在页面布局中分配用于显示验证消息的空间。
  • Dynamic 如果验证失败，将用于显示验证消息的空间动态添加到页面。
EnableClientScript | 布尔值，规定是否启用客户端验证。
Enabled | 布尔值，规定是否启用验证控件。
ErrorMessage

当验证失败时在 ValidationSummary 控件中显示的文本。

注释：如果未设置 Text 属性，此文本将显示在验证控件中。
ForeColor | 控件的前景颜色。
id | 控件的唯一 ID。
IsValid | 布尔值，指示由 ControlToValidate 指定的输入控件是否通过验证。
Operator

要执行的比较操作的类型。

运算符是：

  • Equal
  • GreaterThan
  • GreaterThanEqual
  • LessThan
  • LessThanEqual
  • NotEqual
  • DataTypeCheck
runat | 规定控件是服务器控件。必须设置为 "server"。
Text | 当验证失败时显示的消息。
Type

规定要对比的值的数据类型。

类型有：

  • Currency
  • Date
  • Double
  • Integer
  • String
ValueToCompare | 一个常数值，该值要与由用户输入到所验证的输入控件中的值进行比较。

实例

CompareValidator
在此例中，我们在 .aspx 文件中声明了两个 TextBox 控件，一个 Button 控件，以及一个 CompareValidator 控件。如果验证失败，将在 CompareValidator 控件中使用黄色背景红色文本显示 "Validation Failed!"。
CompareValidator 2
在此例中，我们在 .aspx 文件中声明了两个 TextBox，一个 ListBox 控件，一个 Button 控件，以及一个 CompareValidator 控件。check_operator() 函数把 ListBox 控件中选取的运算符设置为 CompareValidator 控件的运算符，然后对 CompareValidator 控件进行验证。如果验证失败，将在 CompareValidator 控件中使用黄色背景和红色文本显示 "Validation Failed!"。

返回 Validation 服务器控件

ASP.NET 参考手册


ASP.NET CustomValidator 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET CustomValidator 控件

返回 Validation 服务器控件

定义和用法

CustomValidator 控件可对输入控件执行用户定义的验证。

属性

属性 | 描述
BackColor | CustomValidator 控件的背景颜色。
ClientValidationFunction

规定用于验证的自定义客户端脚本函数的名称。

注释：脚本必须用浏览器支持的语言编写，比如 VBScript 或 JScript

使用 VBScript 的话，函数必须位于表单中：

Sub FunctionName (source, arguments)

使用 JScript 的话，函数必须位于表单中：

Function FunctionName (source, arguments)
ControlToValidate | 要验证的输入控件的 id。
Display

验证控件中错误信息的显示行为。

合法的值有：

  • None - 验证消息从不内联显示。
  • Static - 在页面布局中分配用于显示验证消息的空间。
  • Dynamic - 如果验证失败，将用于显示验证消息的空间动态添加到页面。
EnableClientScript | 布尔值，该值指示是否启用客户端验证。
Enabled | 布尔值，该值指示是否启用验证控件。
ErrorMessage

验证失败时 ValidationSummary 控件中显示的错误信息的文本。

注释：如果设置了 ErrorMessage 属性但没有设置 Text 属性，则验证控件中也将显示 ErrorMessage 属性的值。
ForeColor | 控件的前景色。
id | 控件的唯一 id。
IsValid | 布尔值，该值指示关联的输入控件是否通过验证。
OnServerValidate | 规定被执行的服务器端验证脚本函数的名称。
runat | 规定该控件是服务器控件。必须设置为 "server"。
Text | 当验证失败时显示的文本。

实例

CustomValidator
在本例中，我们在 .aspx 文件中声明了两个 Label 控件，一个 TextBox 控件，一个 Button 控件，以及一个 CustomValidator 控件。user() 函数可检测输入值的长度。如果长度小于 8 或大于 16，将在 CustomValidator 控件中显示文本 "A username must be between 8 and 16 characters!"。

返回 Validation 服务器控件

ASP.NET 参考手册


ASP.NET DropDownList 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET DropDownList 控件

返回 Web 服务器控件参考手册

定义和用法

DropDownList 控件用于创建下拉列表。

DropDownList 控件中的每个可选项都是由 ListItem 元素定义的！

提示：该控件支持数据绑定！

属性

属性 | 描述 | .NET
SelectedIndex | 可选项的索引号 | 1.0
OnSelectedIndexChanged | 当被选项目的 index 被更改时被执行的函数的名称。 | 1.0
runat | 规定该控件是服务器控件。必须设置为 "server"。 | 1.0

ListControl 标准属性

AppendDataBoundItems, AutoPostBack, CausesValidation, DataTextField,
DataTextFormatString, DataValueField, Items, runat, SelectedIndex, SelectedItem,
SelectedValue, TagKey, Text, ValidationGroup, OnSelectedIndexChanged

ListControl 控件包括列表控件的所有基本功能。继承自此控件的控件包括：CheckBoxList, DropDownList, ListBox 以及 RadioButtonList 控件。

如需完整描述，请访问 ListControl 标准属性。

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

实例

DropdownList
在本例中，我们在 .aspx 文件中声明了一个 DropDownList 控件。然后创建了一个事件句柄，在 Click 事件发生时在 Label 控件中显示文本和被选项目。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET HtmlAnchor 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET HtmlAnchor 控件

返回 HTML 服务器控件参考手册

定义和用法

HtmlAnchor 控件用于控制 <a> 元素。在 HTML 中，<a> 元素用于创建超链接。超链接可链接到书签或其他页面。

属性
属性 | 描述
Attributes | 返回该元素的所有属性名称和值对。
Disabled | 布尔值，指示是否禁用该控件。默认是 false。
HRef | 链接的 URL。
id | 该控件的唯一 id。
InnerHtml | 设置或返回该 HTML 元素的开始标签和结束标签之间的内容。特殊字符不会被自动转换为 HTML 实体。
InnerText | 设置或返回该 HTML 元素的开始标签和结束标签之间的所有文本。特殊字符会被自动转换为 HTML 实体。
Name | 锚的名称。
OnServerClick | 当该链接被点击时被执行的函数的名称。
runat | 规定该控件是一个服务器控件。必须被设置为 "server"。
Style | 设置或返回被应用到控件的 CSS 属性。
TagName | 返回元素的标签名。
Target | 要打开的目标窗口。
Title | 由浏览器显示的标题（比如 img 元素的 alt 属性）。
Visible | 布尔值，指示该控件是否可见。

实例

HTMLAnchor
在本例中，我们在 .aspx 文件中声明了两个 HtmlAnchor 控件（记得把这个控件嵌套在 HtmlForm 控件中）。然后我们在事件句柄中修改这个 HtmlAnchor 控件的 URL、target 以及 title。Page_Load 事件是 ASP.NET 可理解的众多事件之一。

返回 HTML 服务器控件参考手册

ASP.NET 参考手册


ASP.NET HtmlButton 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET HtmlButton 控件

返回 HTML 服务器控件参考手册

定义和用法

HtmlButton 控件用于控制 <button> 元素。在 HTML 中，<button> 元素用于创建按钮。

属性

属性 | 描述
Attributes | 返回该元素的所有属性名称和值对。
Disabled | 布尔值，指示是否禁用该控件。默认是 false。
id | 该控件的唯一 id。
InnerHtml | 设置或返回该 HTML 元素的开始标签和结束标签之间的内容。特殊字符不会被自动转换为 HTML 实体。
InnerText | 设置或返回该 HTML 元素的开始标签和结束标签之间的所有文本。特殊字符会被自动转换为 HTML 实体。
OnServerClick | 当该按钮被点击时被执行的函数的名称。
runat | 规定该控件是一个服务器控件。必须被设置为 "server"。
Style | 设置或返回被应用到控件的 CSS 属性。
TagName | 返回元素的标签名。
Visible | 布尔值，指示该控件是否可见。

实例

HTMLButton
在本例中，我们声明了两个 HtmlButton 控件（记得把这个控件嵌套在 HtmlForm 控件中）。然后，我们编写一个事件句柄，来规定在按钮被点击时执行的动作。

返回 HTML 服务器控件参考手册

ASP.NET 参考手册


ASP.NET HtmlForm 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET HtmlForm 控件

返回 HTML 服务器控件参考手册

定义和用法

HtmlForm 控件用于控制 <form> 元素。在 HTML 中，<form> 元素用于创建表单。

注释：所有 HTML 服务器控件必须位于 HtmlForm 控件内部！

注释：在一张页面内，您只能使用一个 HtmlForm 控件！

属性

属性 | 描述
Action | URL，定义当提交表单时把数据送往何处。 注释：该属性总是设置为页面自身的 URL！
Attributes | 返回该元素的所有属性名称和值对。
Disabled | 布尔值，指示是否禁用该控件。默认是 false。
EncType | 用来编码表单内容的 MIME 类型。
id | 控件的唯一 id。
InnerHtml | 设置或返回该 HTML 元素的开始标签和结束标签之间的内容。特殊字符不会被自动转换为 HTML 实体。
InnerText | 设置或返回该 HTML 元素的开始标签和结束标签之间的所有文本。特殊字符会被自动转换为 HTML 实体。
Method | 表单向服务器传送数据的方式。合法的值是 "post" 和 "get"。默认是 "post"。
Name | 表单的名称。
runat | 规定该控件是一个服务器控件。必须被设置为 "server"。
Style | 设置或返回被应用到控件的 CSS 属性。
TagName | 返回元素的标签名。
Target | 加载 URL 的目标窗口。
Visible | 布尔值，指示该控件是否可见。

实例

HTMLForm
在本例中，我们在 .aspx 文件中声明了一个 HtmlInputText 控件，一个 HtmlInputButton 控件，以及一个 HtmlGeneric 控件（记得把这个控件嵌套在 HtmlForm 控件中）。当 submit 按钮被触发时，就会执行 submit 子例程。这个 submit 子例程会向 p 元素写一条欢迎消息。

返回 HTML 服务器控件参考手册

ASP.NET 参考手册


ASP.NET HtmlGeneric 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET HtmlGeneric 控件

返回 HTML 服务器控件参考手册

定义和用法

HtmlGeneric 控件用于控制未被具体的 HTML 服务器控件规定的其他 HTML 元素，比如 <body> 、<div> 、<span> 、<font> 、<p> 等等。

属性

属性 | 描述
Attributes | 返回该元素的所有属性名称和值对。
Disabled | 布尔值，指示是否禁用该控件。默认是 false。
id | 控件的唯一 id。
InnerHtml | 设置或返回该 HTML 元素的开始标签和结束标签之间的内容。特殊字符不会被自动转换为 HTML 实体。
InnerText | 设置或返回该 HTML 元素的开始标签和结束标签之间的所有文本。特殊字符会被自动转换为 HTML 实体。
runat | 规定该控件是一个服务器控件。必须被设置为 "server"。
Style | 设置或返回被应用到该控件的 CSS 属性。
TagName | 返回元素的标签名。
Visible | 布尔值，指示该控件是否可见。

实例

HTMLGeneric
在本例中，我们在 .aspx 文件中声明了一个 HtmlInputText 控件，一个 HtmlInputButton 控件，以及一个 HtmlGeneric 控件（<p> 标签）（请记得把这个控件嵌套在 HtmlForm 控件中）当提交按钮被触发时，会执行 submit 子例程。submit 子例程会向 p 元素写一段欢迎消息。

返回 HTML 服务器控件参考手册

ASP.NET 参考手册


ASP.NET HtmlImage 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET HtmlImage 控件

返回 HTML 服务器控件参考手册

定义和用法

HtmlImage 控件用于控制 <img> 元素。在 HTML 中，<img> 元素用于显示图像。

属性

属性 | 描述
Align

如何根据周围的元素排列图像。合法的值有：

  • top
  • middle
  • bottom
  • left
  • right
Alt | 关于图像的简短描述。
Attributes | 返回该元素的所有属性名称和值对。
Border | 图像周围的边框的宽度。
Disabled | 布尔值，指示是否禁用该控件。默认是 false。
Height | 图像的高度。
id | 控件的唯一 id。
runat | 规定该控件是一个服务器控件。必须被设置为 "server"。
Src | 要显示的图像的 URL。
Style | 设置或返回被应用到该控件的 CSS 属性。
TagName | 返回元素的标签名。
Visible | 布尔值，指示该控件是否可见。
Width | 图像的宽度。

实例

HTMLImage
在本例中，我们在 .aspx 文件中声明了一个 HtmlImage 控件。然后我们在一个事件句柄中修改这个 HtmlImage 控件的 src, alt and border 属性。Page_Load 事件是 ASP .NET 可理解的众多事件之一。
HTMLImage 2
在本例中，我们在 .aspx 文件中声明了一个 HtmlImage 控件和一个 HTMLSelect 控件。然后我们会基于用户的选择来修改 HtmlImage 控件的 src 属性。在 HtmlSelect 控件中被选的值决定显示哪幅图像。

返回 HTML 服务器控件参考手册

ASP.NET 参考手册


ASP.NET HtmlInputButton 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET HtmlInputButton 控件

返回 HTML 服务器控件参考手册

定义和用法

HtmlInputButton 控件用于控制 <input type="button"> 、<input type="submit"> 以及 <input type="reset"> 元素。在 HTML 中，这个元素用于创建按钮、提交按钮以及重置按钮。

属性

属性 | 描述
Attributes | 返回该元素的所有属性名称和值对。
Disabled | 布尔值，指示是否禁用该控件。默认是 false。
id | 该控件的唯一 id。
Name | 元素的名称。
OnServerClick | 当该按钮被点击时被执行的函数的名称。
runat | 规定该控件是一个服务器控件。必须被设置为 "server"。
Style | 设置或返回被应用到控件的 CSS 属性。
TagName | 返回元素的标签名。
Type | 该元素的类型。
Value | 元素的值。
Visible | 布尔值，指示该控件是否可见。

实例

HTMLInputbutton
在本例中，我们在 .aspx 文件中声明了一个 HtmlInputText 控件，一个 HtmlInputButton 控件，以及一个 HtmlGeneric 控件。当提交按钮被触发时，会执行 submit 子例程。这个 submit 子例程会向 p 元素写一条欢迎消息。

返回 HTML 服务器控件参考手册

ASP.NET 参考手册


ASP.NET HtmlInputCheckBox 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET HtmlInputCheckBox 控件

返回 HTML 服务器控件参考手册

定义和用法

HtmlInputCheckBox 控件用于控制 <input type="checkbox"> 元素。在 HTML 中，该元素用于创建复选框。

属性和事件

属性 | 描述
Attributes | 返回该元素的所有属性名称和值对。
Checked | 布尔值，规定是否选中该元素。
Disabled | 布尔值，指示是否禁用该控件。默认是 false。
id | 该控件的唯一 id。
Name | 该元素的名称。
runat | 规定该控件是一个服务器控件。必须被设置为 "server"。
Style | 设置或返回被应用到控件的 CSS 属性。
TagName | 返回元素的标签名。
Type | 该元素的类型。
Value | 元素的值。
Visible | 布尔值，指示该控件是否可见。
事件 | 描述
ServerChange | 当控件状态改变时发生此事件。

实例

HTMLInputCheckbox
在本例中，我们在 .aspx 文件中声明了两个 HtmlInputCheckBox 控件，一个 HtmlInputButton 控件，以及一个 HtmlGeneric 控件。当提交按钮被触发时，就会执行 submit 子例程。这个 submit 子例程有两种响应方式：如果 "red" 复选框被选中，则服务器会向 p 元素发送消息 "You prefer red!"。如果 "blue" 复选框被选中，则服务器会向 p 元素发送消息 "You prefer blue!"。

返回 HTML 服务器控件参考手册

ASP.NET 参考手册


ASP.NET HtmlInputFile 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET HtmlInputFile 控件

返回 HTML 服务器控件参考手册

定义和用法

HtmlInputFile 控件用于控制 <input type="file"> 元素，该元素用于向服务器上传文件。

属性

属性 | 描述
Accept | 可接受的 MIME 类型的列表。
Attributes | 返回该元素的所有属性名称和值对。
Disabled | 布尔值，指示是否禁用该控件。默认是 false。
id | 该控件的唯一 id。
MaxLength | 该元素中所允许的最大字符数。
Name | 元素的名称。
PostedFile | 获取对由客户端指定的上载文件的访问。
runat | 规定该控件是一个服务器控件。必须被设置为 "server"。
Size | 元素的宽度。
Style | 设置或返回被应用到控件的 CSS 属性。
TagName | 返回元素的标签名。
Type | 元素的类型。
Value | 元素的值。
Visible | 布尔值，指示该控件是否可见。

实例

在本例中，我们在 .aspx 文件中声明了一个 HtmlInputFile 控件，一个 HtmlInputButton 控件，以及三个 HtmlGeneric 控件。当提交按钮被触发时，会执行 submit 子例程。当文件本身被上传到服务器的 c 目录时，会在页面显示文件名和文件类型：

<script runat="server">
Sub submit(Sender as Object, e as EventArgs)
  fname.InnerHtml=MyFile.PostedFile.FileName
  clength.InnerHtml=MyFile.PostedFile.ContentLength
  MyFile.PostedFile.SaveAs("c:\uploadfile.txt")
End Sub
</script>

<html>
<body>

<form method="post"
enctype="multipart/form-data" runat="server">
<p>
Select file to upload to server:
<input id="MyFile" type="file" size="40" runat="server">
</p>
<p>
<input type="submit" value="Upload!" OnServerclick="submit" runat="server">
</p>
<p>
<div runat="server">
  FileName: <span id="fname" runat="server"/><br />
  ContentLength: <span id="clength" runat="server"/> bytes
</div>
</p>
</form>

</body>
</html>

返回 HTML 服务器控件参考手册

ASP.NET 参考手册


ASP.NET HtmlInputHidden 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET HtmlInputHidden 控件

返回 HTML 服务器控件参考手册

定义和用法

HtmlInputHidden 控件用于控制 <input type="hidden"> 元素。在 HTML 中，该元素用于创建隐藏输入域。

属性和事件

属性 | 描述
Attributes | 返回该元素的所有属性名称和值对。
Disabled | 布尔值，指示是否禁用该控件。默认是 false。
id | 控件的唯一 id。
Name | 元素的名称。
runat | 规定该控件是一个服务器控件。必须被设置为 "server"。
Style | 设置或返回被应用到该控件的 CSS 属性。
TagName | 返回元素的标签名。
Type | 元素的类型。
Value | 元素的值。
Visible | 布尔值，指示该控件是否可见。
事件 | 描述
ServerChange | 当该元素的内容被更改时。

实例

HTMLInputHidden
在本例中，我们在 .aspx 文件中声明了一个 HtmlInputHidden 控件，一个 HtmlInputText 控件，一个 HtmlInputButton 控件，以及一个 HtmlGeneric 控件。当 submit 按钮被触发时，会执行 submit 子例程。这个 submit 子例程会把隐藏域的值设置为输入域的值，并在 p 元素中显示隐藏域的值。

返回 HTML 服务器控件参考手册

ASP.NET 参考手册


ASP.NET HtmlInputImage 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET HtmlInputImage 控件

返回 HTML 服务器控件参考手册

定义和用法

HtmlInputImage 控件用于控制 <input type="image"> 元素。在 HTML 中，该元素用于创建使用图像的按钮，可代替常规的按钮。

属性

属性 | 描述
Align | 图像的对齐方式。
Alt | 供显示的图像替代文本。
Attributes | 返回该元素的所有属性名称和值对。
Border | 元素周围的边框的宽度。
Disabled | 布尔值，指示是否禁用该控件。默认是 false。
id | 控件的唯一 id。
Name | 元素的名称。
OnServerClick | 当图像被点击时被执行的函数的名称。
runat | 规定该控件是一个服务器控件。必须被设置为 "server"。
Src | 图像的源。
Style | 设置或返回被应用到该控件的 CSS 属性。
TagName | 返回元素的标签名。
Type | 元素的类型。
Value | 元素的值。
Visible | 布尔值，指示该控件是否可见。

实例

HTMLInputImage
在本例中，我们在 .aspx 文件中声明了两个 HtmlInputImage 控件，一个 HtmlGeneric 控件。如果用户点击第一个图像，会执行 button1 子例程。该子例程会向 p 元素发送消息 "You clicked the smiley button!"。如果用户点击了第二个图像，则会执行 button2 子例程。这个子例程会向 p 元素发送消息 "You clicked the angry button!"。

返回 HTML 服务器控件参考手册

ASP.NET 参考手册


ASP.NET HtmlInputRadioButton 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET HtmlInputRadioButton 控件

返回 HTML 服务器控件参考手册

定义和用法

HtmlInputRadioButton 控件用于控制 <input type="radio"> 元素。在 HTML 中，该元素用于创建单选按钮。

属性

属性 | 描述
Attributes | 返回该元素的所有属性名称和值对。
Checked | 布尔值，规定该元素是否被选中。
Disabled | 布尔值，指示是否禁用该控件。默认是 false。
id | 控件的唯一 id。
Name | 单选按钮组的名称
runat | 规定该控件是一个服务器控件。必须被设置为 "server"。
Style | 设置或返回被应用到该控件的 CSS 属性。
TagName | 返回元素的标签名。
Type | 元素的类型。
Value | 元素的值。
Visible | 布尔值，指示该控件是否可见。

实例

HTMLInputRadiobutton
在本例中，我们在 .aspx 文件中声明了三个 HtmlInputRadioButton 控件，一个 HtmlInputButton 控件，一个 HtmlGeneric 控件。当提交按钮被触发时，会执行 submit 子例程。submit 子例程有三种响应方式：如果选择了带有 id="r1" 的单选按钮，则服务器向 p 元素发送消息 "Your favorite color is red"。如果选择了带有 id="r2" 的单选按钮，则服务器向 p 元素发送消息 "Your favorite color is green"。如果选择了带有 id="r3" 的单选按钮，则服务器向 p 元素发送消息 "Your favorite color is blue"。

返回 HTML 服务器控件参考手册

ASP.NET 参考手册


ASP.NET HtmlInputText 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET HtmlInputText 控件

返回 HTML 服务器控件参考手册

定义和用法

HtmlInputText 控件用于控制 <input type="text"> 和 <input type="password"> 元素。在 HTML 中，这些元素用于创建文本域和密码域。

属性

属性 | 描述
Attributes | 返回该元素的所有属性名称和值对。
Disabled | 布尔值，指示是否禁用该控件。默认是 false。
id | 该元素的唯一 id。
MaxLength | 该元素中可允许字符的最大数目。
Name | 元素的名称。
runat | 规定该控件是一个服务器控件。必须被设置为 "server"。
Size | 元素的宽度。
Style | 设置或返回被应用到该控件的 CSS 属性。
TagName | 返回元素的标签名。
Type | 元素的类型。
Value | 元素的值。
Visible | 布尔值，指示该控件是否可见。

实例

HTMLInputText
在本例中，我们在 .aspx 文件中声明了一个 HtmlInputText 控件，一个 HtmlInputButton 控件，以及一个 HtmlGeneric 控件。当提交按钮被触发时，会执行 submit 子例程。这个 submit 子例程会向 p 元素写一条欢迎消息。

返回 HTML 服务器控件参考手册

ASP.NET 参考手册


ASP.NET HtmlSelect 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET HtmlSelect 控件

返回 HTML 服务器控件参考手册

定义和用法

HtmlSelect 控件用于控制 <select> 元素。在 HTML 中，<select> 元素用于创建下拉列表。

属性

属性 | 描述
Attributes | 返回该元素的所有属性名称和值对。
DataMember | 要使用的数据表格的名称。
DataSource | 要使用的数据源。
DataTextField | 要显示在此下拉列表中的数据源中的字段。
DataValueField | 规定此下拉列表中每个可选项的值的数据源中的字段。
Disabled | 布尔值，指示是否禁用该控件。默认是 false。
id | 控件的唯一 id。
InnerHtml | 设置或返回该 HTML 元素的开始标签和结束标签之间的内容。特殊字符不会被自动转换为 HTML 实体。
InnerText | 设置或返回该 HTML 元素的开始标签和结束标签之间的所有文本。特殊字符会被自动转换为 HTML 实体。
Items | 下拉列表中的项目的列表。
Multiple | 是否能同时选择多个项目。
OnServerChange | 当被选项目被更改时被执行的函数的名称。
runat | 规定该控件是一个服务器控件。必须被设置为 "server"。
SelectedIndex | 当前被选项目的索引号。
Size | 下拉列表中可见项目的数目。
Style | 设置或返回被应用到该控件的 CSS 属性。
TagName | 返回元素的标签名。
Value | 当前被选项目的值。
Visible | 布尔值，指示该控件是否可见。

实例

HTMLSelect
在本例中，我们在 .aspx 文件中声明一个 HtmlImage 控件以及一个 HTMLSelect 控件。然后我们会根据用户的选择来修改 HtmlImage 控件的 src 属性。在 HtmlSelect 控件中选择的值决定了显示哪幅图像。

返回 HTML 服务器控件参考手册

ASP.NET 参考手册


ASP.NET HtmlTable 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET HtmlTable 控件

返回 HTML 服务器控件参考手册

定义和用法

HtmlSelect 控件用于控制 <select> 元素。在 HTML 中，<select> 元素用于创建下拉列表。

属性

属性 | 描述
Align | 规定此表格的对齐方式。
Attributes | 返回该元素的所有属性名称和值对。
BGColor | 规定表格的背景颜色。
Border | 规定边框的宽度。 提示：设置 border="0" 可显示不带边框的表格。
BorderColor | 规定边框的颜色。
CellPadding | 规定单元格边框与内容之间的空白。
CellSpacing | 规定单元格之间的空白。
Disabled | 布尔值，指示是否禁用该控件。默认是 false。
Height | 规定表格的高度。
id | 控件的唯一 id。
InnerHtml | 设置或返回该 HTML 元素的开始标签和结束标签之间的内容。特殊字符不会被自动转换为 HTML 实体。
InnerText | 设置或返回该 HTML 元素的开始标签和结束标签之间的所有文本。特殊字符会被自动转换为 HTML 实体。
Rows | 返回表示表格中所有行的 HtmlRowCollection 对象。
runat | 规定该控件是一个服务器控件。必须被设置为 "server"。
Style | 设置或返回被应用到该控件的 CSS 属性。
TagName | 返回元素的标签名。
Visible | 布尔值，指示该控件是否可见。
Width | 规定表格的宽度。

实例

HTMLTable
在本例中,我们在 .aspx 文件中声明了两个 HtmlSelect 控件,一个 HtmlInputButton 控件,以及一个 HtmlTable 控件。用户可选择单元和行的数目。当提交按钮被触发时，会执行 submit 子例程。submit 子例程会根据用户的输入来生成表格。
HTMLTable 2
在本例中，我们在 .aspx 文件中声明了一个 HtmlTable 控件以及一个 HtmlInputButton 控件。当触发提交按钮时，会执行 submit 子例程。submit 子例程会修改表格的背景颜色和边框颜色，它也会修改单元格的内容。

返回 HTML 服务器控件参考手册

ASP.NET 参考手册


ASP.NET HtmlTableCell 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET HtmlTableCell 控件

返回 HTML 服务器控件参考手册

定义和用法

HtmlTableCell 控件用于控制 <td> 和 <th> 元素。在 HTML 中，这些元素用于创建表格单元格和表头单元格。

属性

属性 | 描述
Align | 单元格内容的水平对齐方式。
Attributes | 返回该元素的所有属性名称和值对。
BGColor | 单元格的背景颜色。
BorderColor | 边框的颜色。
ColSpan | 该单元格应横跨的列数。
Disabled | 布尔值，指示是否禁用该控件。默认是 false。
Height | 该单元格的高度。
id | 该控件的唯一 id。
InnerHtml | 设置或返回该 HTML 元素的开始标签和结束标签之间的内容。特殊字符不会被自动转换为 HTML 实体。
InnerText | 设置或返回该 HTML 元素的开始标签和结束标签之间的所有文本。特殊字符会被自动转换为 HTML 实体。
Nowrap | 布尔值，规定该控件内的文本是否换行。
RowSpan | 该单元格应横跨的行数。
runat | 规定该控件是一个服务器控件。必须被设置为 "server"。
Style | 设置或返回被应用到该控件的 CSS 属性。
TagName | 返回元素的标签名。
VAlign | 单元格内容的垂直排列方式。
Visible | 布尔值，指示该控件是否可见。
Width | 单元格的宽度。

实例

HTMLTable
在本例中,我们在 .aspx 文件中声明了两个 HtmlSelect 控件,一个 HtmlInputButton 控件,以及一个 HtmlTable 控件。用户可选择单元和行的数目。当提交按钮被触发时，会执行 submit 子例程。submit 子例程会根据用户的输入来生成表格。
HTMLTable 2
在本例中，我们在 .aspx 文件中声明了一个 HtmlTable 控件以及一个 HtmlInputButton 控件。当触发提交按钮时，会执行 submit 子例程。submit 子例程会修改表格的背景颜色和边框颜色，它也会修改单元格的内容。

返回 HTML 服务器控件参考手册

ASP.NET 参考手册


ASP.NET HtmlTableRow 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET HtmlTableRow 控件

返回 HTML 服务器控件参考手册

定义和用法

HtmlTableRow 控件用于控制 <tr> 元素。在 HTML 中，<tr> 元素用于创建表格行。

属性

属性 | 描述
Align | 行的对齐方式。
Attributes | 返回该元素的所有属性名称和值对。
BGColor | 行的背景颜色。
BorderColor | 边框的颜色。
Cells | 返回该行中的单元格。
Disabled | 布尔值，指示是否禁用该控件。默认是 false。
Height | 行的高度。
id | 控件的唯一 id。
InnerHtml | 设置或返回该 HTML 元素的开始标签和结束标签之间的内容。特殊字符不会被自动转换为 HTML 实体。
InnerText | 设置或返回该 HTML 元素的开始标签和结束标签之间的所有文本。特殊字符会被自动转换为 HTML 实体。
runat | 规定该控件是一个服务器控件。必须被设置为 "server"。
Style | 设置或返回被应用到该控件的 CSS 属性。
TagName | 返回元素的标签名。
VAlign | 行中单元格的垂直排列方式。
Visible | 布尔值，指示该控件是否可见。

实例

HTMLTable
在本例中,我们在 .aspx 文件中声明了两个 HtmlSelect 控件,一个 HtmlInputButton 控件,以及一个 HtmlTable 控件。用户可选择单元和行的数目。当提交按钮被触发时，会执行 submit 子例程。submit 子例程会根据用户的输入来生成表格。
HTMLTable 2
在本例中，我们在 .aspx 文件中声明了一个 HtmlTable 控件以及一个 HtmlInputButton 控件。当触发提交按钮时，会执行 submit 子例程。submit 子例程会修改表格的背景颜色和边框颜色，它也会修改单元格的内容。

返回 HTML 服务器控件参考手册

ASP.NET 参考手册


ASP.NET HtmlTextArea 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET HtmlTextArea 控件

返回 HTML 服务器控件参考手册

定义和用法

HtmlTextArea 控件用于控制 <textarea> 元素。在 HTML 中，<textarea> 元素用于创建文本域。

属性

属性 | 描述
Attributes | 返回该元素的所有属性名称和值对。
Cols | 文本域的列数。
Disabled | 布尔值，指示是否禁用该控件。默认是 false。
id | 该控件的唯一 id。
InnerHtml | 设置或返回该 HTML 元素的开始标签和结束标签之间的内容。特殊字符不会被自动转换为 HTML 实体。
InnerText | 设置或返回该 HTML 元素的开始标签和结束标签之间的所有文本。特殊字符会被自动转换为 HTML 实体。
Name | 该文本域的唯一名称。
OnServerChange | 当该文本域的内容被修改时被执行的函数的名称。
Rows | 文本域的可见行数。
runat | 规定该控件是一个服务器控件。必须被设置为 "server"。
Style | 设置或返回被应用到该控件的 CSS 属性。
TagName | 返回元素的标签名。
Value | 该文本域的值。
Visible | 布尔值，指示该控件是否可见。

实例

HTMLTextarea
在本例中，我们在 .aspx 文件中声明了一个 HtmlTextarea 控件，一个 HtmlInputButton 控件，以及一个 HtmlGeneric 控件。当触发提交按钮时，会执行 submit 子例程。这个 submit 子例程会向 p 元素发送消息 "You wrote: " 以及用户在文本框中输入的文本。

返回 HTML 服务器控件参考手册

ASP.NET 参考手册


ASP.NET HyperLink 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET HyperLink 控件

返回 Web 服务器控件参考手册

定义和用法

HyperLink 控件用于创建超链接。

属性

属性 | 描述 | .NET
ImageUrl | 显示此链接的图像的 URL | 1.0
NavigateUrl | 该链接的目标 URL | 1.0
runat | 规定该控件是服务器控件。必须被设置为 "server"。 | 1.0
Target | URL 的目标框架。 | 1.0
Text | 显示该链接的文本。 | 1.0

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

实例

Hyperlink
在本例中，我们在 .aspx 文件中声明了一个 HyperLink 控件。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET Image 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET Image 控件

返回 Web 服务器控件参考手册

定义和用法

Image 控件用于显示图像。

属性

属性 | 描述 | .NET
AlternateText | 图形的替代文本。 | 1.0
DescriptionUrl | 对图像进行详细描述的位置。 | 2.0
GenerateEmptyAlternateText | 规定该控件是否创建一个作为替代文本的空字符串。 | 2.0
ImageAlign | 规定图像的排列方式。 | 1.0
ImageUrl | 要使用的图像的 URL。 | 1.0
runat | 规定该控件是服务器控件。必须设置为 "server"。 | 1.0

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

实例

Image
在本例中，我们在 .aspx 文件中声明了一个 Image 控件。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET ImageButton 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET ImageButton 控件

返回 Web 服务器控件参考手册

定义和用法

ImageButton 控件用于显示可点击的图像。

属性

属性 | 描述 | .NET
CausesValidation | 规定在 ImageButton 控件被点击时，是否验证页面。 | 1.0
CommandArgument | 有关要执行的命令的附加信息。 | 1.0
CommandName | 与 Command 事件相关的命令。 | 1.0
GenerateEmptyAlternateText | 规定该控件是否创建空字符串作为替代文本。 | 2.0
OnClientClick | 当图像被点击时要执行的函数的名称。 | 2.0
PostBackUrl | 当 ImageButton 被点击时，从当前页面进行回传的目标页面的 URL。 | 2.0
runat | 规定该控件是一个服务器控件。必须被设置为 "server"。 | 1.0
TagKey |  | 1.0
ValidationGroup | 当 ImageButton 回传服务器时，该 ImageButton 控件引起验证所针对的控件组。 | 2.0

注释：Image 控件的属性也能够用在 ImageButton 控件上。

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

实例

ImageButton
在本例中，我们在 .aspx 文件中声明了一个 ImageButton 控件和一个 Label 控件。在用户点击此图像时，会执行 subroutine 子例程。这个子例程会把消息 "Coordinates: " 以及单击的 x 和 y 坐标发送到 Label 控件。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET Label 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET Label 控件

返回 Web 服务器控件参考手册

定义和用法

Label 控件用于在页面上显示文本。该文本是可编程的。

注释：该控件允许您为内容应用样式！

属性

属性 | 描述
runat | 规定该控件是一个服务器控件。必须设置为 "server"。
Text | 在 label 中显示的文本。

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

实例

Label
在本例中，我们在 .aspx 文件中声明了一个 Label 控件，一个 TextBox 控件，以及一个 Button 控件。当用户点击按钮时，会执行 submit 子例程。这个子例程会把 TextBox 控件的内容拷贝到 Label 控件。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET LinkButton 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET LinkButton 控件

返回 Web 服务器控件参考手册

定义和用法

LinkButton 控件用于创建超链接样式的按钮。

注释：该控件的外观与 HyperLink 控件相同，但其功能与 Button 控件一样。

属性

属性 | 描述 | .NET
CausesValidation | 规定当 LinkButton 控件被点击时是否验证页面。 | 1.0
CommandArgument | 有关所执行命令的附加信息。 | 1.0
CommandName | 与 Command 事件相关的命令。 | 1.0
OnClientClick | 当 LinkButton 控件被点击时被执行的函数的名称。 | 2.0
PostBackUrl | 当 LinkButton 控件被点击时从当前页面进行回传的目标页面的 URL。 | 2.0
runat | 规定该控件是服务器控件。必须设置为 "server"。 | 1.0
Text | LinkButton 上的文本。 | 1.0
ValidationGroup | 当其回传服务器时，该 LinkButton 控件引起的验证所针对的控件组。 | 2.0

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

实例

LinkButton
在本例中，我们在 .aspx 文件中声明了一个 LinkButton 控件，以及一个 Label 控件。当用户点击这个链接时，会执行 lbClick 子例程。这个子例程会像 Label 控件发送文本 "You clicked the LinkButton control"。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET ListBox 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET ListBox 控件

返回 Web 服务器控件参考手册

定义和用法

ListBox 控件用于创建但选货多选的下拉列表。

ListBox 控件中的可选项目是通过 ListItem 元素定义的！

提示：该控件支持数据绑定！

属性

属性 | 描述 | .NET
Rows | 在列表中显示的行数。 | 1.0
SelectionMode | 允许单选还是多选。 | 1.0

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

实例

Listbox
在本例中，我们在 .aspx 文件中声明一个 ListBox 控件。然后我们创建了一个事件句柄，当发生 Click 事件时，该句柄会在 Label 控件中显示文本和被选项目。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET ListItem 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET ListItem 控件

返回 Web 服务器控件参考手册

定义和用法

ListItem 控件可创建列表中的一个项目。

此控件与这些列表控件一同使用：<asp:ListBox> 、<asp:RadioButtonList> 以及 <asp:BulletedList>。

语法

<asp:ListItem
Enabled="True|False"
Selected="True|False"
Text="label"
Value="value" />

属性

属性 | 描述 | .NET
Attributes | 可选的。此类不直接支持的 ListItem 的属性名和值对的集合。 | 1.0
Enabled | 可选的。规定是否禁用或启用项目。 | 2.0
Selected | 可选的。规定是否选定该项。 | 1.0
Text | 可选的。在 ListItem 中显示的文本。 | 1.0
Value | 可选的。ListItem 的值。 | 1.0

ListControl 标准属性

AppendDataBoundItems, AutoPostBack, CausesValidation, DataTextField,
DataTextFormatString, DataValueField, Items, runat, SelectedIndex, SelectedItem,
SelectedValue, TagKey, Text, ValidationGroup, OnSelectedIndexChanged

ListControl 控件包括列表控件的所有基本功能。继承自此控件的控件包括：CheckBoxList, DropDownList, ListBox 以及 RadioButtonList 控件。

如需完整描述，请访问 ListControl 标准属性。

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

有可能使用 Text 或 Value 属性以及 inner HTML 文本来设置显示列表项的文本。

例子

<asp:ListItem Value="Text1" Text="Text2">Text3</asp:ListItem>

根据 Text 或 Value 属性以及 inner HTML 文本的组合，可显示不同的文本，并可使用不同的值。下面的表格列出了所有可能的组合以及它们的值：

内部 HTML 内容 | 文本属性 | 值属性 | 呈现的“内部 HTML”内容 | 呈现的“值”属性
已设置 | 已设置 | 已设置 | 内部 HTML 内容 | 值属性
已设置 | 已设置 | 未设置 | 内部 HTML 内容 | 内部 HTML 内容
已设置 | 未设置 | 已设置 | 内部 HTML 内容 | 值属性
已设置 | 未设置 | 未设置 | 内部 HTML 内容 | “内部 HTML”文本
未设置 | 已设置 | 已设置 | 文本属性 | 值属性
未设置 | 已设置 | 未设置 | 文本属性 | 文本属性
未设置 | 未设置 | 已设置 | 值属性 | 值属性
未设置 | 未设置 | 未设置 | 未设置 | 未设置

提示和注释

注释：由于 Text 和 Value 属性都具有空字符串默认值，所以列表控件中可能有空列表项。

实例

在 BulletedList 中的基本 ListItem
本例展示了 .aspx 文件中带有两个 ListItems 的 BulletedList 控件。
ListBox 中带有不同属性的 ListItem
本例展示了 .aspx 文件中带有几个 ListItem 的 ListBox 控件。列表中的文本使用了不同的属性来显示列表项的文本。
ListItem disabled in ListBox
本例展示了一个带有被禁用的列表项的 ListBox 控件。
ListItem selected in RadioButtonList
本例展示了一个带有已选列表项的 RadioButtonList 控件。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET Literal 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET Literal 控件

返回 Web 服务器控件参考手册

定义和用法

Literal 控件用于在页面上显示文本。此文本是可编程的。

注释：该控件不允许您向其内容应用样式！

属性

属性 | 描述 | .NET
Mode |  | 2.0
runat | 规定该控件是服务器控件。必须设置为 "server"。 | 1.0
Text | 规定要显示的文本。 | 1.0

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

实例

Literal
在本例中，我们在 .aspx 文件中声明了一个显示静态文本的 Literal 控件。
Literal 2
在本例中，我们在 .aspx 文件中声明了一个 Literal 控件和一个 Button 控件。当用户点击按钮时，会执行 submit 子例程。这个子例程会更改 Literal 控件的文本。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET Panel 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET Panel 控件

返回 Web 服务器控件参考手册

定义和用法

Panel 控件用作其它控件的容器。

提示：此控件常用于以编程方式生成控件，或显示或隐藏控件组。

注释：在 IE 中，此控件呈现为 HTML 的 <div> 元素，在 Mozilla 中呈现为 <table> 标签。

属性

属性 | 描述 | .NET
BackImageUrl | 规定显示控件背景的图像文件的 URL。 | 1.0
DefaultButton | 规定 Panel 中默认按钮的 ID。 | 2.0
Direction | 规定 Panel 的内容显示方向。 | 2.0
GroupingText | 规定 Panel 中控件组的标题。 | 2.0
HorizontalAlign | 规定内容的水平对齐方式。 | 1.0
runat | 规定控件是服务器。必须设置为 "server"。 | 1.0
ScrollBars | 规定 Panel 中滚动栏的位置和可见性。 | 2.0
Wrap | 规定内容是否折行。 | 1.0

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

实例

Panel
在本例中，我们在 .aspx 文件中声明了一个 Panel 控件，一个 CheckBox 控件，以及一个 Button 控件。当用户选中 CheckBox 控件并点击刷新按钮时，Panel 控件将隐藏起来。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET PlaceHolder 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET PlaceHolder 控件

返回 Web 服务器控件参考手册

定义和用法

PlaceHolder 控件用于为代码添加的控件预留空间。

注释：PlaceHolder 不会产生任何可见的输出（仅仅是网页上其它控件的容器）。

属性

属性 | 描述 | .NET
runat | 规定控件是服务器。必须设置为 "server"。 | 1.0

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET RadioButton 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET RadioButton 控件

返回 Web 服务器控件参考手册

定义和用法

RadioButton 控件用于显示单选按钮。

提示：如需创建一系列使用数据绑定的单选按钮，请使用 RadioButtonList 控件！

属性

属性 | 描述
AutoPostBack | 布尔值，规定在 Checked 属性被改变后，是否立即回传表单。默认是 false。
Checked | 布尔值，规定是否选定单选按钮。
id | 控件的唯一 id。
GroupName | 该单选按钮所属控件组的名称。
OnCheckedChanged | 当 Checked 被改变时，被执行的函数的名称。
runat | 规定该控件是服务器控件。必须设置为 "server"。
Text | 单选按钮旁边的文本。
TextAlign | 文本应出现在单选按钮的哪一侧（左侧还是右侧）。

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

实例

Radiobutton
在本例中，我们在 .aspx 文件中声明了三个 RadioButton 控件，一个 Button 控件，以及一个 Label 控件。当提交按钮被触发时，会执行 submit 子例程。submit 子例程会以三种方式进行响应：假如带有 id="red" 属性的 radiobutton 被选中，服务器向 Label 控件发送消息 "You selected Red"；假如带有 id="green" 属性的 radiobutton 被选中，服务器向 Label 控件发送消息 "You selected Green"；假如带有 id="blue" 属性的 radiobutton 被选中，服务器向 Label 控件发送消息 "You selected Blue"。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET RadioButtonList 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET RadioButtonList 控件

返回 Web 服务器控件参考手册

定义和用法

RadioButtonList 控件用于创建单选按钮组。

RadioButtonList 控件中的每个可选项是通过 ListItem 元素来定义的！

提示：该控件支持数据绑定！

属性

属性 | 描述 | .NET
CellPadding | 单元格边框与内容之间的像素数。 | 1.0
CellSpacing | 表格单元格之间的像素数。 | 1.0
RepeatColumns | 当显示单选按钮组时要使用的列数。 | 1.0
RepeatDirection | 规定单选按钮组应水平重复还是垂直重复。 | 1.0
RepeatLayout | 单选按钮组的布局。 | 1.0
runat | 规定该控件是服务器控件。必须设置为 "server"。 | 1.0
TextAlign | 文本应出现在单选按钮的哪一侧（左侧还是右侧）。 | 1.0

ListControl 标准属性

AppendDataBoundItems, AutoPostBack, CausesValidation, DataTextField,
DataTextFormatString, DataValueField, Items, runat, SelectedIndex, SelectedItem,
SelectedValue, TagKey, Text, ValidationGroup, OnSelectedIndexChanged

ListControl 控件包括列表控件的所有基本功能。继承自此控件的控件包括：CheckBoxList, DropDownList, ListBox 以及 RadioButtonList 控件。

如需完整描述，请访问 ListControl 标准属性。

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

实例

RadiobuttonList
在本例中，我们在 .aspx 文件中声明了一个 RadioButtonList 控件，一个 Button 控件，以及一个 Label 控件。然后，我们创建了一个事件句柄，当发生 Click 事件时，会把文本和被选项目显示在 Label 控件中。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET RangeValidator 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET RangeValidator 控件

返回 Validation 服务器控件

定义和用法

RangeValidator 控件用于检测用户输入的值是否介于两个值之间。可以对不同类型的值进行比较，比如数字、日期以及字符。

注释：如果输入控件为空，验证不会失败。请使用 RequiredFieldValidator 控件，使字段成为必选字段。

注释：如果输入值无法转换为指定的数据类型，验证也不会失败。请使用 CompareValidator 控件，将其 Operator 属性设置为 ValidationCompareOperator.DataTypeCheck，这样就可以校验输入值的数据类型了。

属性

属性 | 描述
BackColor | RangeValidator 控件的背景颜色
ControlToValidate | 要验证的控件的 id
Display 验证控件的显示行为。

合法的值有：

  • None - 验证消息从不内联显示。
  • Static - 在页面布局中分配用于显示验证消息的空间。
  • Dynamic - 如果验证失败，将用于显示验证消息的空间动态添加到页面。
EnableClientScript | 布尔值，规定是否启用客户端验证。
Enabled | 布尔值，规定是否启用验证控件。
ErrorMessage

当验证失败时，在 ValidationSummary 控件中显示的文本。

注释：如果未设置 Text 属性，文本也会显示在该验证控件中。
ForeColor | 该控件的前景色。
id | 控件的唯一 id。
IsValid | 布尔值，指示关联的输入控件是否通过验证。
MaximumValue | 规定输入控件的最大值。
MinimumValue | 规定输入控件的最小值。
runat | 规定该控件是一个服务器控件。必须设置为 "server"。
Type

规定要检测的值的数据类型。类型有：

  • Currency
  • Date
  • Double
  • Integer
  • String
Text | 当验证失败时显示的消息。

实例

RangeValidator
在本例中，我们在 .aspx 文件中声明了一个 TextBox 控件，一个 Button 控件，以及一个 RangeValidator 控件。如果验证失败，将在 RangeValidator 控件中显示文本 "The date must be between 1/1/2002 and 31/5/2002!"。
RangeValidator 2
在本例中，我们在 .aspx 文件中声明了一个 TextBox 控件，一个 Button 控件，一个 Label 控件，以及一个 RangeValidator 控件。submit() 函数可检测页面是否有效。如果有效，则在 Label 控件中返回 "The page is valid!"。如果无效，则在 Label 控件中返回 "The page is not valid!"。如果验证失败，则在 RangeValidator 控件中显示 "The value must be from 1 to 100!"。

返回 Validation 服务器控件

ASP.NET 参考手册


ASP.NET RegularExpressionValidator 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET RegularExpressionValidator 控件

返回 Validation 服务器控件

定义和用法

RegularExpressionValidator 控件用于验证输入值是否匹配正则表达式指定的模式。

注释：除非浏览器不支持客户端验证或 EnableClientScript 被设置为 false，否则将同时执行服务器端和客户端验证。

注释：如果输入控件为空，验证将失败。请使用 RequiredFieldValidator 控件，使字段成为必选字段。

属性

属性 | 描述
BackColor | RangeValidator 控件的背景颜色
ControlToValidate | 要验证的控件的 id
Display 验证控件的显示行为。

合法的值有：

  • None - 验证消息从不内联显示。
  • Static - 在页面布局中分配用于显示验证消息的空间。
  • Dynamic - 如果验证失败，将用于显示验证消息的空间动态添加到页面。
EnableClientScript | 布尔值，规定是否启用客户端验证。
Enabled | 布尔值，规定是否启用验证控件。
ErrorMessage

当验证失败时，在 ValidationSummary 控件中显示的文本。

注释：如果未设置 Text 属性，文本也会显示在该验证控件中。
ForeColor | 该控件的前景色。
id | 控件的唯一 id。
IsValid | 布尔值，指示关联的输入控件是否通过验证。
runat | 规定该控件是一个服务器控件。必须设置为 "server"。
Text | 当验证失败时显示的消息。
ValidationExpression | 规定验证输入控件的正则表达式。在客户端和服务器上，表达式的语法是不同的。

实例

RegularExpressionValidator
在本例中，我们在 .aspx 文件中声明了一个 TextBox 控件，一个 Button 控件，一个 Label 控件，以及一个 RegularExpressionValidator 控件。submit() 函数会检测页面是否有效。如果有效，则在 Label 控件中返回 "The page is valid!"。如果无效，则在 Label 控件中返回 "The page is not valid!"。如果验证失败，将在 RegularExpressionValidator 控件中显示文本 "The zip code must be 5 numeric digits!"。

返回 Validation 服务器控件

ASP.NET 参考手册


ASP.NET RequiredFieldValidator 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET RequiredFieldValidator 控件

返回 Validation 服务器控件

定义和用法

RequiredFieldValidator 控件用于使输入控件成为一个必选字段。

通过该控件，如果输入值的初始值未改变，那么验证将失败。默认地，初始值是空字符串 ("")。

注释：输入值的开头和结尾的空格将在验证前被删除。

注释：InitialValue 不为输入控件设置默认值。它指示了您不希望用户在输入控件中输入的值。

属性

属性 | 描述
BackColor | RangeValidator 控件的背景颜色
ControlToValidate | 要验证的控件的 id
Display 验证控件的显示行为。

合法的值有：

  • None - 验证消息从不内联显示。
  • Static - 在页面布局中分配用于显示验证消息的空间。
  • Dynamic - 如果验证失败，将用于显示验证消息的空间动态添加到页面。
EnableClientScript | 布尔值，规定是否启用客户端验证。
Enabled | 布尔值，规定是否启用验证控件。
ErrorMessage

当验证失败时，在 ValidationSummary 控件中显示的文本。

注释：如果未设置 Text 属性，文本也会显示在该验证控件中。
ForeColor | 该控件的前景色。
id | 控件的唯一 id。
InitialValue | 规定输入控件的初始值（开始值）。默认是 ""。
IsValid | 布尔值，指示关联的输入控件是否通过验证。
runat | 规定该控件是一个服务器控件。必须设置为 "server"。
Text | 当验证失败时显示的消息。

实例

RequiredFieldValidator
在本例中，我们在 .aspx 文件中声明了两个 TextBox 控件，一个 Button 控件，以及一个 RequiredFieldValidator 控件。它展示了如何使用 RequiredFieldValidator 控件使 "txt_name" 文本框成为必选字段。

返回 Validation 服务器控件

ASP.NET 参考手册


ASP.NET Style 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET Style 控件

返回 Web 服务器控件参考手册

定义和用法

Style 控件用于设置 web 控件的样式。

属性

属性 | 描述 | .NET
BackColor | 控件的背景色。 | 1.0
BorderColor | 控件的边框色。 | 1.0
BorderStyle | 控件的边框样式。 | 1.0
BorderWidth | 控件的边框宽度。 | 1.0
CssClass | 由 Web 服务器控件在客户端呈现的级联样式表 (CSS) 类。 | 1.0
Font | 控件的字符属性。 | 1.0
ForeColor | 控件的前景色（通常是文本颜色）。 | 1.0
Height | 控件的高度。 | 1.0
RegisteredCssClass | 已向控件注册的级联样式表 (CSS) 类。 | 2.0
Width | 控件的宽度。 | 1.0

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET Table 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET Table 控件

返回 Web 服务器控件参考手册

定义和用法

Table 控件与 TableCell 控件和 TableRow 控件配合，用于创建表格。

属性

属性 | 描述 | .NET
BackImageUrl | 表格的背景图像的 URL。 | 1.0
Caption | 表格的标题（caption）。 | 2.0
CaptionAlign | caption 文本的对齐方式。 | 2.0
CellPadding | 单元格边框与内容的间距。 | 1.0
CellSpacing | 单元格间距。 | 1.0
GridLines | The gridline format in the table | 1.0
HorizontalAlign | 表格在页面中的水平对齐方式。 | 1.0
Rows | 表格中的行集合。 | 1.0
runat | 规定该控件是服务器控件。必须设置为 "server"。 | 1.0

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

实例

Table
在本例中，我们在 .aspx 文件中声明了两个 Table 控件。
Table 2
在本例中，我们在 .aspx 文件中声明了一个 Table 控件，三个 TableRow 控件，以及两个 TableCell 控件。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET TableCell 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET TableCell 控件

返回 Web 服务器控件参考手册

定义和用法

TableCell 控件与 Table 控件和 TableRow 控件结合，用于创建表格中的单元。

提示：每行的单元均存储在 TableRow 控件的 Cells 集合中。

属性

属性 | 描述 | .NET
AssociatedHeaderCellID | 与 TableCell 控件关联的表标题单元格列表。 | 2.0
ColumnSpan | 单元格跨越的列数。 | 1.0
HorizontalAlign | 单元格中内容的水平对齐方式。 | 1.0
RowSpan | 单元格跨越的行数。 | 1.0
runat | 规定该控件是服务器控件。必须设置为 "server"。 | 1.0
Text | 规定单元格的文本内容。 | 1.0
VerticalAlign | 单元格中内容的垂直对齐方式。 | 1.0
Wrap | 规定单元格内容是否换行。 | 1.0

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

实例

Table
在本例中，我们在 .aspx 文件中声明了两个 Table 控件。
Table 2
在本例中，我们在 .aspx 文件中声明了一个 Table 控件，三个 TableRow 控件，以及两个 TableCell 控件。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET TableRow 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET TableRow 控件

返回 Web 服务器控件参考手册

定义和用法

TableRow 控件与 TableCell 控件和 Table 控件一起使用，来创建表格中的行。

提示：表格的行存储在 Table 控件中的 Rows 集合中。

属性

属性 | 描述 | .NET
Cells | TableCell 对象的集合，这些对象表示 Table 控件中的行的单元格。 |
HorizontalAlign | 表格行中内容的水平对齐方式。 | 1.0
TableSection | Table 控件中 TableRow 对象的位置。 | 2.0
VerticalAlign | 行内容的垂直对齐方式。 | 1.0

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

实例

Table
在本例中，我们在 .aspx 文件中声明了两个 Table 控件。
Table 2
在本例中，我们在 .aspx 文件中声明了一个 Table 控件，三个 TableRow 控件，以及两个 TableCell 控件。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET TextBox 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET TextBox 控件

返回 Web 服务器控件参考手册

定义和用法

TextBox 控件用于创建用户可输入文本的文本框。

属性

属性 | 描述 | .NET
AutoCompleteType | 规定 TextBox 控件的 AutoComplete 行为。 | 2.0
AutoPostBack | 布尔值，规定当内容改变时，是否回传到服务器。默认是 false。 | 1.0
CausesValidation | 规定当 Postback 发生时，是否验证页面。 | 2.0
Columns | textbox 的宽度。 | 1.0
MaxLength | 在 textbox 中所允许的最大字符数。 | 1.0
ReadOnly | 规定能否改变文本框中的文本。 | 1.0
Rows | textbox 的高度（仅在 TextMode="Multiline" 时使用）。 | 1.0
runat | 规定该控件是否是服务器控件。必须设置为 "server"。 |
TagKey |  |
Text | textbox 的内容。 | 1.0
TextMode | 规定 TextBox 的行为模式（单行、多行或密码）。 | 1.0
ValidationGroup | 当 Postback 发生时，被验证的控件组。 |
Wrap | 布尔值，指示 textbox 的内容是否换行。 | 1.0
OnTextChanged | 当 textbox 中的文本被更改时，被执行的函数的名称。 |

Web 控件标准属性

AccessKey, Attributes, BackColor, BorderColor, BorderStyle, BorderWidth,
CssClass, Enabled, Font, EnableTheming, ForeColor, Height, IsEnabled,
SkinID, Style, TabIndex, ToolTip, Width

如需完整描述，请访问 Web 控件标准属性。

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

实例

Textbox
在本例中，我们在 .aspx 文件中声明了一个 TextBox 控件，一个 Button 控件，以及一个 Label 控件。当提交按钮被触发时，会执行 submit 子例程。这个 submit 子例程会向 Label 控件输出文本。
Textbox 2
在本例中，我们在 .aspx 文件中声明了一个 TextBox 控件，一个 Button 控件，以及一个 Label 控件。当提交按钮被触发时，会执行 submit 子例程。这个 submit 子例程会把文本框的内容拷贝到 Label 控件。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET ValidationSummary 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET ValidationSummary 控件

返回 Validation 服务器控件

定义和用法

ValidationSummary 控件用于在网页、消息框或在这两者中内联显示所有验证错误的摘要。

在该控件中显示的错误消息是由每个验证控件的 ErrorMessage 属性规定的。如果未设置验证控件的 ErrorMessage 属性，就不会为那个验证控件显示错误消息。

属性

属性 | 描述
DisplayMode

如何显示摘要。合法值有：

  • BulletList
  • List
  • SingleParagraph
EnableClientScript | 布尔值，规定是否启用客户端验证。
Enabled | 布尔值，规定是否启用验证控件。
ForeColor | 该控件的前景色。
HeaderText | ValidationSummary 控件中的标题文本。
id | 控件的唯一 id。
runat | 规定该控件是一个服务器控件。必须设置为 "server"。
ShowMessageBox | 布尔值，指示是否在消息框中显示验证摘要。
ShowSummary | 布尔值，规定是否显示验证摘要。

实例

Validationsummary
在本例中，我们使用 ValidationSummary 控件生成了一个用户未填的必选字段的列表。
Validationsummary 2
在本例中，我们使用 ValidationSummary 控件显示了一个提示用户未填的必选字段的消息框。

返回 Validation 服务器控件

ASP.NET 参考手册


ASP.NET Web 窗体

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET Web 窗体

  • Previous Page
  • Next Page

所有服务器控件必须出现在 <form> 标签内，同时 <form> 标签必须包含 runat="server" 属性。

ASP.NET Web 表单

所有服务器控件必须出现在 <form> 标签内，同时 <form> 标签必须包含 runat="server" 属性。runat="server" 属性指示该表单必须在服务器进行处理。它还指示装入其中的控件能否被服务器脚本访问：

<form runat="server">...HTML + server controls</form>

注释：该表单总是向自身页面进行提交。如果您规定了一个 action 属性，它会被忽略。如果您省略了 method 属性，它将被默认地设置为 method="post"。同时，如果您没有规定 name 和 id 属性，它们则由 ASP.NET 自动分配。

注释：一个 .aspx 仅能包含一个 <form runat="server"> 控件！

如果您查看一个 .aspx 页面的源代码，而其中包含的表单不带有 name, method, action 或 id 属性，那么您将看到 ASP.NET 已经把这些属性添加到该表单。类似这样：

<form name="_ctl0" method="post" action="page.aspx" id="_ctl0">...some code</form>

提交表单

表单通常通过点击一个按钮来提交。ASP.NET 中的 Button 服务器控件的格式是这样的：

<asp:Button id="id" text="label" OnClick="sub" runat="server" />

id 属性为按钮定义了一个唯一的名称，而 text 属性则为按钮分配了一个 label。onClick 事件句柄规定了一个要执行的子例程。

在下面的例子中，我们在一个 .aspx 文件中声明了一个按钮控件。一次鼠标单击就可以运行一个子例程，可以更改该按钮上的文本。

TIY

  • Previous Page
  • Next Page

ASP.NET 参考手册


ASP.NET XML 控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET XML 控件

返回 Web 服务器控件参考手册

定义和用法

XML 控件用于显示 XML 文档或 XSL 转换的结果。

属性

通过设置 Document、DocumentContent 或 DocumentSource 这三个属性之一来指定要显示的 XML 文档。这三个属性表示可以显示的不同类型的 XML 文档。通过设置适当的属性，可以显示 System.Xml.XmlDocument、XML 字符串或 XML 文件。

通过设置 Transform、TransformSource 这两个属性之一，可以选择指定 XSL 转换 (XSLT) 样式表，该样式表在 XML 文档被写入输出流之前对其进行格式化。这两个属性表示可用于格式化 XML 文档的不同类型的 XSL 转换样式表。通过设置适当的属性，可以用 System.Xml.Xsl.XslCompiledTransform 对象或 XSL 转换样式表文件来格式化 XML 文档。如果未指定 XSL 转换样式表，则使用默认格式显示 XML 文档。

Xml 类还提供 TransformArgumentList 属性，该属性使您得以提供具有可选参数的 XSL 转换样式表。这些参数可以是 XSL 转换 (XSLT) 参数或扩展对象。

属性 | 描述 | .NET
Document | 不赞成使用。规定使用 System.Xml.XmlDocument 对象的 XML 文档。 | 1.0
DocumentContent | 规定 XML 字符串。 | 1.0
DocumentSource | 规定在 Xml 控件中显示的 XML 文档的路径。 | 1.0
runat | 规定该控件是服务器控件。必须设置为 "server"。 | 1.0
Transform | 使用 System.Xml.Xsl.XslTransform 对象来格式化 XML 文档。 | 1.0
TransformArgumentList | 包含传递给样式表并在扩展样式表语言转换 (XSLT) 中使用的可选参数列表。 |
TransformSource | 规定 XSL 转换文件的路径。 |
XPathNavigator | 用于导航和编辑与 Xml 控件关联的 XML 数据的光标模型。 |

控件标准属性

AppRelativeTemplateSourceDirectory, BindingContainer, ClientID, Controls,
EnableTheming, EnableViewState, ID, NamingContainer, Page, Parent, Site,
TemplateControl, TemplateSourceDirectory, UniqueID, Visible

如需完整描述，请访问控件标准属性。

实例

XML
本例展示了如何使用 XML 控件来显示 XSL 转换的结果。

返回 Web 服务器控件参考手册

ASP.NET 参考手册


ASP.NET 参考手册

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET 参考手册

W3School 提供完整的 ASP.NET 服务器控件参考手册。

HTML 服务器控件

ASP.NET 文件中的 HTML 元素默认作为文本进行处理。为了使这些元素可编程化，需要向 HTML 元素添加 runat="server" 属性。该属性指示该元素应作为服务器控件进行处理。

注释：所有 HTML 服务器控件必须位于带有 runat="server" 属性的 <form> 标签内！

注释：ASP.NET 要求所有 HTML 元素必须正确关闭和嵌套。

HTML 服务器控件参考手册

Web 服务器控件

类似 HTML 服务器控件，Web 服务器控件同样在服务器创建，且需要 runat="server" 属性才能工作。不过，Web 服务器控件不必映射任何已有的 HTML 元素，它们可代表更复杂的元素。

创建一个 Web 服务器控件的语法是：

<asp:control_name id="some_id" runat="server" />

Web 服务器控件参考手册

Validation 服务器控件

Validation 服务器控件用于验证输入控件的数据。如果数据未通过验证，则向用户显示错误消息。

创建 Validation 服务器控件的语法是：

<asp:control_name id="some_id" runat="server" />

Validation 服务器控件参考手册

ASP.NET 参考手册


ASP.NET 简介

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET 简介

  • Previous Page
  • Next Page

ASP.NET 是微软的 ASP 技术的最新版本。

您应当具备的基础知识

在继续学习之前，您需要对下面的知识有基本的了解：

  • WWW, HTML 以及网站构建的基础知识
  • 脚本语言 比如 JavaScript 或者 VBScript
  • 有关服务器脚本的基础知识

如果您希望首先学习这些项目，请在我们的首页访问这些教程。

什么是 ASP？

ASP 是一种使嵌入网页中的脚本可由因特网服务器执行的服务器端脚本技术。

  • ASP 是一项微软公司的技术
  • ASP 指 Active Server Pages（动态服务器页面）
  • ASP 是运行于 IIS 之中的程序
  • IIS 指 Internet Information Services（因特网信息服务）
  • IIS 是 Windows 2000 捆绑的免费组件
  • IIS同时也是 Windows NT 4.0 的可选组件
  • 此可选组件可通过因特网下载
  • PWS 的体积更小 - 不过拥有 IIS 的完整功能
  • PWS 可在 Windows 95/98 的安装 CD 中找到

ASP 文件是什么？

  • ASP 文件和 HTML文件类似
  • ASP 文件可包含文本、HTML、XML 和脚本
  • ASP 文件中的脚本可在服务器上执行。
  • ASP 文件的扩展名是 ".asp"

它如何工作？

  • 当浏览器请求某个 HTML 文件时，服务器会返回这个文件
  • 而当浏览器请求某个 ASP 文件时，IIS 将这个请求传递至 ASP 引擎
  • ASP 引擎会逐行地读取这个文件，并执行文件中的脚本
  • 最后，ASP 文件将以纯 HTML 的形式返回到浏览器

在您继续学习 ASP .NET 之前，拥有对微软 ASP 技术的基本了解释有帮助的。

如需学习更多 ASP，请访问我们的《ASP 教程》。

什么是 ASP+？

ASP+ 等同于 ASP.NET。

ASP+ 是微软研发 ASP.NET 期间所使用的早期名称。

什么是 ASP.NET？

ASP 3.0 是 ASP 的最新版本，但不会再有 ASP 4.0 版本了。

ASP.NET 是下一代的 ASP，但是不能把 ASP.NET 称为 ASP 的升级版本。ASP.NET 是全新的服务器端 ASP 脚本。

ASP.NET 是 .NET 框架的组成部分。微软耗时三年从底层重写了 ASP.NET，而 ASP.NET 无法完全向后兼容 ASP 3.0。

您会在本教程的下一节了解到 ASP 与 ASP.NET 之间的差异所在。

.NET 框架（.NET Framework）

.NET 框架是微软 .NET 平台的基础结构。

.NET 框架是构建、开发及运行 Web 应用程序和 Web 服务的一种环境。

.NET 框架含有公共语言运行库和公共类库 - 比如 ADO.NET、ASP.NET 以及 Windows 窗体 - 来提供可整合入各种计算机系统的高级标准服务。

.NET 框架可提供特性丰富的应用程序环境、简化的开发以及众多开发语言之间的轻松整合。

.NET 框架中立于语言。目前，它支持 C++、C#、Visual Basic 以及 JScript（微软的 JavaScript 版本）。

微软的 Visual Studio.NET 是针对 NET Framework 的公共开发环境。

  • Previous Page
  • Next Page

ASP.NET 参考手册


ASP.NET 教程

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP.NET 教程

  • Next Page

ASP.NET 是 ASP（微软动态服务器网页技术）的最新版本。

ASP.NET 是 Microsoft.NET 框架的组成部分，同时也是创建动态交互网页的强有力的工具。

开始学习 ASP.NET！

ASP.NET 参考手册

在 W3School，我们提供完整的 ASP.NET 参考手册，其中包括内建对象和组件，以及它们的属性和方法。

ASP.NET 实例

ASP.NET 实例
一系列的 ASP.NET 实例。

内容目录

ASP.NET 简介
本章解释 ASP.NET 的概念。
ASP.NET vs ASP
本章阐述 ASP.NET 和 ASP 之间的差异。
ASP.NET 页面
本章介绍如何创建您的第一个简单的 ASP.NET 页面。
ASP.NET 服务器控件
本章介绍 ASP.NET 服务器控件。
ASP.NET 事件
本章介绍一些 ASP.NET 事件句柄。

ASP.NET Forms

ASP.NET WEB 表单
本章介绍 ASP.NET 的 WEB 表单。
ASP.NET 维持 ViewState
本文讲解如何维持 ViewState。
ASP.NET 文本框控件
本章阐述 ASP 的基础：文本框控件。
ASP.NET 按钮控件
本章阐述 ASP 的基础：按钮控件。

ASP.NET Binding

ASP.NET 数据绑定
本文介绍 ASP.NET 数据绑定。
ASP.NET ArrayList 对象
本文讲解 ASP.NET ArrayList 对象。
ASP.NET Hashtable 对象
本文讲解 ASP.NET Hashtable 对象
ASP.NET SortedList 对象
本文讲解 ASP.NET SortedList 对象
ASP.NET XML 文件
本章介绍如何将数据绑定到一个 XML 文件。
ASP.NET asp:Repeater 控件
本章介绍如何通过 Repeater 控件将数据绑定到一个 XML 文件。
ASP.NET asp:DataList 控件
本文讲解使用 DataList 控件把数据绑定到 XML 文件。

ASP.NET Database

ASP.NET 数据库连接
本章介绍 ADO.NET 以及连接到数据库。

ASP.NET 2.0

ASP.NET 2.0 新特性
本节介绍 ASP.NET 2.0 中的新特性。
ASP.NET 2.0 母版页
本节解释母版页（Master Pages）的概念。
ASP.NET 2.0 导航
本节讲解 ASP.NET 2.0 的导航控件。

ASP.NET 参考手册

ASP.NET HTML Server 控件参考
完整的 HTML 服务器控件参考手册，包括其属性、方法以及事件。
ASP.NET Web Server 控件参考
完整的 Web 服务器控件参考手册，包括其属性、方法以及事件。
ASP.NET Validation Server 控件参考
完整的 Validation 服务器控件参考手册，包括其属性、方法以及事件。

ASP.NET 实例

ASP.NET 实例
一系列 ASP.NET 实例。
  • Next Page

ASP.NET 参考手册


Hello W3School!

28/01/2009 16:13:41


Empire Burlesque

 Empire Burlesque Bob Dylan USA Columbia 10.90 1985 Hide your heart Bonnie Tyler UK CBS Records 9.90 1988 Greatest Hits Dolly Parton USA RCA 9.90 1982 Still got the blues Gary Moore UK Virgin records 10.20 1990 Eros Eros Ramazzotti EU BMG 9.90 1997


Hello W3School!


HTML 服务器控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 服务器控件

  • Previous Page
  • Next Page

HTML 服务器控件是服务器可理解的 HTML 标签。

HTML 服务器控件

ASP.NET 文件中的 HTML 元素默认作为文本进行处理。为了使这些元素可编程化，需要向 HTML 元素添加 runat="server" 属性。该属性指示该元素应作为服务器控件进行处理。

注释：所有 HTML 服务器控件必须位于带有 runat="server" 属性的 <form> 标签内！

注释：ASP.NET 要求所有 HTML 元素必须正确关闭和嵌套。

HTML 服务器控件 | 描述
HtmlAnchor | 控制 <a> HTML 元素
HtmlButton | 控制 <button> HTML 元素
HtmlForm | 控制 <form> HTML 元素
HtmlGeneric | 控制其他未被具体的 HTML 服务器控件规定的 HTML 元素，比如 <body>, <div>, <span> 等等。
HtmlImage | 控制 <image> HTML 元素
HtmlInputButton | 控制 <input type="button"> 、<input type="submit"> 以及 <input type="reset"> HTML 元素
HtmlInputCheckBox | 控制 <input type="checkbox"> HTML 元素
HtmlInputFile | 控制 <input type="file"> HTML 元素
HtmlInputHidden | 控制 <input type="hidden"> HTML 元素
HtmlInputImage | 控制 <input type="image"> HTML 元素
HtmlInputRadioButton | 控制 <input type="radio"> HTML 元素
HtmlInputText | 控制 <input type="text"> 和 <input type="password"> HTML 元素
HtmlSelect | 控制 <select> HTML 元素
HtmlTable | 控制 <table> HTML 元素
HtmlTableCell | 控制 <td> 和 <th> HTML 元素
HtmlTableRow | 控制 <tr> HTML 元素
HtmlTextArea | 控制 <textarea> HTML 元素
  • Previous Page
  • Next Page

ASP.NET 参考手册


Validation 服务器控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Validation 服务器控件

  • Previous Page
  • Next Page

Validation 服务器控件用于用于验证用户输入。

Validation 服务器控件

Validation 服务器控件用于验证输入控件的数据。如果数据未通过验证，则向用户显示错误消息。

创建 Validation 服务器控件的语法是：

<asp:control_name id="some_id" runat="server" />
Validation 服务器控件 | 描述
CompareValidator | 把一个输入控件的值与另一个输入控件或一个固定的值进行对比。
CustomValidator | 允许您编写一个方法，来处理输入值的验证。
RangeValidator | 在两个值的范围内检查输入的值。
RegularExpressionValidator | 确保输入控件的值匹配指定的模式。
RequiredFieldValidator | 是输入控件成为必需（必填）的字段。
ValidationSummary | 显示网页中所有验证错误的报告。
  • Previous Page
  • Next Page

ASP.NET 参考手册


Web 服务器控件

ASP.NET 教程

  • ASP.NET 首页
  • ASP.NET 简介
  • ASP.NET vs ASP
  • ASP.NET 页面
  • ASP.NET 控件
  • ASP.NET 事件

ASP.NET 窗体

  • ASP.NET 窗体
  • ASP.NET ViewState
  • asp:TextBox
  • asp:Button

ASP.NET 绑定

  • 数据绑定
  • ArrayList
  • Hashtable
  • SortedList
  • XML 文件
  • asp:Repeater
  • asp:DataList

ASP.NET 数据库

  • 数据库连接

ASP.NET 2.0

  • 2.0 新特性
  • 2.0 母版页
  • 2.0 导航

参考手册

  • HTML 控件
  • Web 控件
  • Validation 控件

实例

  • ASP.NET 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Web 服务器控件

  • Previous Page
  • Next Page

Web 服务器控件是可被服务器理解的特殊 ASP.NET 标签。

Web 服务器控件

类似 HTML 服务器控件，Web 服务器控件同样在服务器创建，且需要 runat="server" 属性才能工作。不过，Web 服务器控件不必映射任何已有的 HTML 元素，它们可代表更复杂的元素。

创建一个 Web 服务器控件的语法是：

<asp:control_name id="some_id" runat="server" />
Web 服务器控件 | 描述
AdRotator | 显示一个图形序列
Button | 显示按钮
Calendar | 显示日历
CalendarDay | calendar 控件中的一天
CheckBox | 显示复选框
CheckBoxList | 创建多选的复选框组
DataGrid | 显示 grid 中数据源的字段
DataList | 通过使用模版显示数据源中的项目
DropDownList | 创建下拉列表
HyperLink | 创建超链接
Image | 显示图像
ImageButton | 显示可点击的图像
Label | 显示可编程的静态内容（使您对其内容应用样式）
LinkButton | 创建超链接按钮
ListBox | 创建单选或多选的下拉列表
ListItem | 创建列表中的一条项目
Literal | 显示可编程的静态内容（无法使您对其内容应用样式）
Panel | 为其他控件提供容器
PlaceHolder | 为由代码添加的空间预留空间
RadioButton | 创建单选按钮
RadioButtonList | 创建单选按钮组
BulletedList | 创建项目符号格式的列表
Repeater | 显示绑定到控件的重复列表项
Style | 设置控件的样式
Table | 创建表格
TableCell | 创建表格单元
TableRow | 创建表格行
TextBox | 创建文本框
Xml | 显示 XML 文件或 XSL 转换的结果
  • Previous Page
  • Next Page

ASP.NET 参考手册


Firefox 浏览器

浏览器信息

  • 教程首页
  • Explorer
  • Netscape
  • Mozilla
  • Firefox
  • Opera
  • Chrome

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Firefox 浏览器

  • Previous Page
  • Next Page

Firefox 是由 Mozilla 开发的开源 web 浏览器。

Firefox 是什么？

Firefox 是一款免费的可用于 Windows、Linux 和 Mac 的开源 web 浏览器。它小巧快速，可提供弹窗阻止和标签式浏览等许多新特性。

Firefox 基于 Mozilla 代码，是标准兼容性最好的浏览器之一。

Firefox 可用于 Windows 98、Windows 2000、Windows XP、Mac OS X 以及 Linux。

Firefox 3

Mozilla 的最新版浏览器，Firefox 3，于 2008 年 6 月 17 日发布了。

Firefox 3 拥有众多新特性，比如密码管理、一键保存书签、智能地址栏、全屏缩放、快速网站 ID 信息、平台原生外观等等。

对于 Mozilla 来说一项很重要的特性，是对性能的提升。Firefox 3 可以使您更快地浏览网页，同时占用更少的计算机内存资源。

Mozilla 是什么？

Mozilla 是一个开源的 web 开发项目。

Mozilla 应用程序套件（也称为 SeaMonkey）是一套完整的 web 应用程序；浏览器、电子邮件客户端、新闻客户端、聊天客户端等等。

而 Firefox 仅仅是一款浏览器。您无法使用 Firefox 来聊天或阅读电邮或新闻组。这使它更小、更快，更易使用（但却使得聊天、电邮以及新闻组更难使用？）

提示：您可以在上一节阅读更多有关 Mozilla 的内容。

Firefox 和 Mozilla

在过去 Firefox 被称为 Mozilla Firebird（而 Mozilla Firebird 过去被称为 Phoenix，Phoenix 过去被称为 Mozilla）。

要解决名称混乱的问题，就必须建立合法的发行号（我这么认为）。您可以在上一节阅读更多有关 Mozilla 演变改变的内容。

Firefox预期会成为完整版 Mozilla 套件的默认浏览器。

Firefox 的特性

Firefox 可自动进行弹窗阻止。这一点用于对付讨厌的弹出广告是很有效的。

标签式的浏览是一种现代的省时的的特性。它可以做到在同一个浏览器窗口查看多个页面。

Google Search 也被嵌入 Firefox 的工具栏中。

Keywords for bookmarks with quick searches (e.g., type "goo xml tutorial" into the location bar and get a Google search page on "xml tutorial" in one step).

词典工具提示 - 双击任意单词就会看到其定义。

Firefox增强了安全性能。它没有与操作系统整合，不支持 ActiveX 控件和 VBScripts （以安全漏洞闻名的特性）。

内置的现代下载管理器可在后台把文件下载到桌面。

Firefox 拥有可定制的工具栏，允许用户添加或删除项目，也可创建新的工具栏。

通过主题管理器，用户可以改变 Firefox 的外观。

Firefox 可自我更新。智能更新可在后台进行搜索，并通知用户可用的更新。

Firefox 产品页面

  • Previous Page
  • Next Page


Google Chrome 浏览器

浏览器信息

  • 教程首页
  • Explorer
  • Netscape
  • Mozilla
  • Firefox
  • Opera
  • Chrome

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Google Chrome 浏览器

  • Previous Page
  • Next Page

chrome 是免费的开源 web 浏览器，它由 Google 开发。

Chrome 是什么？

当 Google 决定开发一款浏览器时，他们需要彻底地重新谋划这款浏览器，这是因为如今的浏览器与仅需要浏览简单的文本页面时有很大的不同，现在，我们在浏览器上发邮件、购物、付账单，以及运行其他的大型应用程序。

下载 Google Chrome

新特性

在经过 15 个 Beta 测试版之后，2008 年 12 月 12日 Google Chrome 浏览器发布了第一个正式版，版本号 1.0.154.36。

Google Chrome 目前仅可用于 Windows，但是已经拥有了不少聪明的特性。

Google Chrome 的标签页是彼此独立运行的，这样就可以防止互相冲突，即使某一个应用程序崩溃，也不会影响到其他任何进程。当某个标签页被关闭后，它所用的内存也会被清空。

Google 添加了更强大的 JavaScript 引擎，V8，它可使大型应用程序得到更好的执行。

开始页提供了新的功能，有点像 Opera，它带有九个最常访问的网页，一个最近访问页面的列表，以及您喜欢的搜索引擎等等。

由于它是开源项目，将来还会有新的特性被添加进去。

正式版的新特性

  1. 更好的插件稳定性和性能，特别是视频和音频方面。
  2. 更快的速度。JavaScript V8 引擎的测试成绩有了明显的提高。
  3. 加强了书签管理和隐私控制。

了解更多信息，请访问下面的网址（中文）：

http://www.google.com/chrome/intl/zh-CN/features.html?hl=zh-CN

Google 还制作了一个展示 Google Chrome 的连环漫画（英文）：

http://www.google.com/googlebooks/chrome/

  • Previous Page
  • Next Page


Internet Explorer

浏览器信息

  • 教程首页
  • Explorer
  • Netscape
  • Mozilla
  • Firefox
  • Opera
  • Chrome

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Internet Explorer

  • Previous Page
  • Next Page

Internet Explorer 是目前使用最为广泛的因特网浏览器。

Internet Explorer 8

Internet Explorer 8 public beta 1 于 2008 年 3 月 5 日发布。

微软宣称在默认的情况下，Internet Explorer 8 将按照严格的 W3C 标准来解释网页。

之前，微软曾宣称 IE 8 会默认使用 “IE 标准”，而按照严格 W3C 标准来解释网页将是第二选项。这在 web 开发社团中激起了强烈的反应，因为 "IE 7 standard" 并不完全遵循 W3C 标准。

不过，现在微软已经调转了这个决定，看起来 Internet Explorer 8 将真正地兼容标准。

IE 8 完全支持 CSS 2.1。此外，它修正了“许多跨浏览器的不一致性，比如 get/set/removeAttribute, default attributes, Attribute object 以及 < Q > 标签”。

新特性：

活动 (Activity) 提供对网络服务的快速访问。用户能够从 web 查找并发送信息。在一个餐馆网站，举例来说，用户可以在网页内点击，就可以获得关于该餐厅的地图、新闻和信息，有关它的 blog，或者在 Facebook 上共享它。

源剪辑 (WebSlices) 是类似 RSS 的特性，允许用户直接在网页内订阅内容。

更多信息，请访问：http://www.microsoft.com/windows/ie/ie8/welcome/zh-cn/default.html

Internet Explorer 7

Internet Explorer 7.0 发布于 2006 年 11 月。

Internet Explorer 7 提供改进的导航、通过工具栏进行 web 搜索、高级打印、即时搜索以及RSS提要。

新特性：

高级打印
Internet Explorer 7 将自动缩放要打印的网页，以便整个网页都在打印的页面中。 打印选项还包括可调整的边距、可自定义的页面布局、可删除的页眉和页脚以及仅打印选定文本的选项。
即时搜索框
使用您喜爱的搜索提供程序的 Web 搜索现在可被添加到工具栏的搜索框中，消除了多个独立工具栏同时存在的混乱现象。 您可以方便地从下拉列表中选择提供程序或添加更多提供程序。
收藏中心
快捷方便地访问收藏夹、选项卡组、浏览历史记录和 RSS 提要订阅。 收藏中心可根据需要进行扩展，并可随意定位以方便访问。
RSS 提要
Internet Explorer 7 可自动检测站点上的 RSS 提要并使工具栏上的图标亮起。 您可以单击图标来任意预览和订阅 RSS 提要，那么您在内容更新后将自动获得通知。 您可以在浏览器中直接阅读 RSS 提要，浏览重要事件，以及使用搜索项或特定站点类别筛选视图。
选项卡式浏览
在单个浏览器窗口中查看多个站点。 通过浏览器框顶部的选项卡轻松地从一个站点切换到其他站点。
快速选项卡
通过在单个窗口中显示所有缩略图，您可以在打开的选项卡之间轻松选择和定位。
选项卡组
选项卡可按逻辑类别进行分组和保存，以便您单击一下鼠标即可打开多个选项卡。 选项卡组可方便地设为主页组，以便每次启动 Internet Explorer 时都可以打开整个选项卡组。
页面缩放
放大单个页面，包括文本和图片，以便您可以关注特定内容或者使视觉障碍者可以将内容看得更加清楚。

Internet Explorer 6

Internet Explorer 6.0 是 Windows XP 中的标准浏览器。发布于 2001 年 8 月。

Windows XP 基于 Windows 2000，是 Windows 98、Millennium 以及 Windows 2000 的继任者。

Internet Explorer 5

Internet Explorer 5 是首个支持 XML 的主流浏览器。

Version 5.5 (2000 年 7 月) 用于 Windows 95、98、NT 4.0 以及 Windows 2000。支持 XML/XSL, CSS, 打印(打印预览)和 HTC 行为。

Version 5.01 (1999 年 11 月) 主要是修正了 5.0 的一个 bug。

Version 5.0 (1999 年 3 月) 是首个支持 XML 的主流浏览器。

更老的 Internet Explorer 版本

大多数用户都不在使用更老的 Internet Explorer 版本。Web 开发者会忽略它们。而它们的功能也过时了。

Version 4.0 (发布于 1997) 的使用率不到 1% 。它对 CSS 和 DOM 的支持非常好，但不支持 XML。

Version 3.0 (发布于 1996) 的使用率不到 0.1%。

Version 2.0 (发布于 1995)。这个版本太老了，已经没有人使用它了。

Version 1.0 (发布于 1995)。还有人记得它吗？

Internet Explorer for Macintosh

Version 5.1.7 是最后一个用于 Mac OS 8 和 9 的 Internet Explorer，发布于 2003 年 7 月。

Version 5.2.3 是最后一个用于 Mac OS X 的 Internet Explorer，发布于 2003 年 6 月。

注释：version 5.2.3 需要 Mac OS X 中的特殊特性。Mac OS 8 和 9 的用户必须下载 version 5.1.7。

Microsoft Internet Explorer 下载

下载免费的 Internet Explorer：http://www.microsoft.com/windows/products/winfamily/ie/default.mspx。

下载最新的安全更新和漏洞修复：http://www.microsoft.com/windows/downloads/ie/getitnow.mspx。

微软公司不再对 Internet Explorer for Mac 提供下载！

2003 年 6 月，微软公司的 Macintosh Business Unit 宣布不对为 MAC 版的 Internet Explorer 进行进一步的开发，并于 2005 年停止对其的技术支持。在 2005 年 12 月 31 日，微软停止了对 Internet Explorer for Mac 的支持。相应地，2006 年 1 月 31 日，微软的站点也已经停止了 INTERNET EXPLORER FOR MAC 的下载，并建议 Macintosh 用户迁移到更新的 web 浏览技术，比如 Apple 的 Safari。

Microsoft Internet Explorer 资源

微软的 Internet Explorer 站点
微软的 Internet Explorer 支持站点
微软的可搜索知识库、下载中心、产品 FAQ 以及辅助支持目录
  • Previous Page
  • Next Page


Mozilla 项目

浏览器信息

  • 教程首页
  • Explorer
  • Netscape
  • Mozilla
  • Firefox
  • Opera
  • Chrome

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Mozilla 项目

  • Previous Page
  • Next Page

Mozilla 是一个构建 web 应用程序的框架。

什么是Mozilla？

Mozilla 不是一款 web 浏览器。

Mozilla 是一个使用诸如 CSS、XML、RD F等 web 标准来构建 web 应用程序的框架。

Mozilla 的代码被用于各类型的 web 应用程序，包括 Netscape 6 和 7 浏览器、其他类型的浏览器比如 Firefox 和 Camino、聊天客户端、新闻客户端、邮件客户端、游戏以及其他用于 windows、linux 以及 mac 的 web 应用程序。

Mozilla 是一项开发用在 Mozilla 应用套件中的程序代码的开源 web 开发项目。

Mozilla 应用程序套件是一套完整的 web 应用程序（浏览器、聊天客户端、新闻客户端、邮件客户端等等）。

目前，基于 Mozilla 代码的浏览器是因特网上的第二大浏览器家族，承担着大约 30% 的因特网通信。Mozilla 浏览器由于其对 web 标准的良好支持而闻名。

Mozilla 项目

Mozilla 项目被创建的目的是把 Netscape 作为一个开源项目来发展。

在 1998 年 11 月，AOL（美国在线）收购了 Netscape。

Netscape 的核心引擎的开发被转移到一个名为 "The Mozilla Project" 的开源项目。

在 2006 年 4 月之后，在 Mozilla 基金会是主要目标是逐步地淘汰 Mozilla 套件，并把主要的焦点集中于 Firefox/Thunderbird/SeaMonkey 项目的背景下，此项目被重命名为 SeaMonkey。

Mozilla 基金会

Mozilla 基金会创建于 2003 年 7 月，这是在那时，AOL 解雇了介入 Mozilla 开源浏览器团队的雇员。

Mozilla 基金会的路线图

Mozilla 决定制定一个新的开发路线图。下面列出了新路线图中的一些要点：

  • 专注于独立的应用程序（FireFox 浏览器、Thunderbird 邮件/新闻应用程序以及独立的设计器）
  • 使 Firefox 和 Thunderbird 成为 Mozilla 的首要产品
  • 用大型的 Mozilla 部署来维护针对企业和组织的SeaMonkey（现在的 Mozilla 浏览器）应用程序套件
  • 使用一年的研发周期把 Mozilla 1.4 分支作为由组织使用的 "distributor/vendor" 分支来进行维护
  • 修复至关重要的 Gecko layout architecture 的漏洞。所有的 Mozilla 应用程序都得益于这些 Gecko 的改进。
  • 精益求精。做得更少，但要做得更好！

Mozilla的产品

  • Mozilla - 应用程序套件
  • Firefox - 独立的浏览器
  • Thunderbird - 一个电子邮件和新闻组客户端
  • Camino - 用于MAC的浏览器
  • Composer - 网页编辑器

用于 Windows、Linux 以及 Mac 的版本可通过下面的地址来下载：

http://www.mozilla.org

令人混淆的 Mozilla 名称

正是第一款 Netscape 浏览器使用了名为 Mozilla 的代码引擎。Netscape 1.0 是依靠名为 Mozilla 1.0 的代码引擎来驱动的。Netscape 2.0 使用 Mozilla 2.0，Netscape 3.0 使用 Mozilla 3.0，而 Netscape 4.0 使用了 Mozilla 4.0。

在 1998 年，Netscape 4 将其源代码公开 - 同时对 Netscape 5 的开发被确立一个开源项目。

这个创建 Netscape 5 的开源项目被称为 "The Mozilla Project"。奇怪的是，这个 Mozilla 项目的代码引擎被称为 Gecko。

不幸的是，在 4.0 发布之后，对下一代浏览器的研发耗费了 Netscape 超过三年半的时间。这次延迟破坏了 Netscape 作为微软 IE 浏览器的可靠的备选方案的可能性。就在 Mozilla 项目启动不久，微软就发布了它的 IE 5.0，而在 Netscape 设法发布一款可工作的浏览器之前，微软的 IE 6.0 也就绪了。

基于 Gecko M18 (Milestone 18) 的 Netscape 6.0 于 2000 年 11 月发布。

在 Netscape 6.0 发布之后，Mozilla 项目开始研发基于名为 Gecko 1.0 引擎的 Netscape 7。

Netscape 6 和 7均构建于 Mozilla 之上，Netscape 和 Mozilla 是几乎相同的应用程序套件。

Netscape 7 声称其使用了名为 Gecko 1.0 的代码引擎。

此刻，Mozilla 项目正在开发一款名为 Firefox 的新浏览器。在过去，Firefox 被称为 Mozilla Firebird（而 Mozilla Firebird 过去被称为 Phoenix，它声称是 Mozilla 的一个新版本）。

感到困惑吗？起码我这么觉得。

要解决名称混乱的问题，就必须建立合法的发行号（我这么认为）。

Mozilla 发布的版本

Mozilla 基金已发布了下面这些版本的 Mozilla：

版本号 | 发布时间
Mozilla 1.8 Alpha 5 | November 22, 2004
Mozilla 1.8 Alpha 4 | September 28, 2004
Mozilla 1.8 Alpha 3 | August 18, 2004
Mozilla 1.8 Alpha 2 | July 14, 2004
Mozilla 1.8 Alpha 1 | May 20, 2004
Mozilla 1.7.3 | September 13, 2004
Mozilla 1.7.2 | August 4, 2004
Mozilla 1.7.1 | July 8, 2004
Mozilla 1.7 | June 17, 2004
Mozilla 1.7 RC3 | June 8, 2004
Mozilla 1.7 RC2 | May 17, 2004
Mozilla 1.7 RC1 | April 21, 2004
Mozilla 1.7 Beta | March 18, 2004
Mozilla 1.7 Alpha | February 23, 2004
Mozilla 1.6 | January 15, 2004
Mozilla 1.6 Beta | December 9, 2003
Mozilla 1.6 Alpha | October 31, 2003
Mozilla 1.5.1 | November 26, 2003
Mozilla 1.5 | October 15, 2003
Mozilla 1.5 RC2 | September 26, 2003
Mozilla 1.5 RC1 | September 17, 2003
Mozilla 1.5 Beta | August 27, 2003
Mozilla 1.5 Alpha | July 22, 2003
Mozilla 1.4.1 | October 10, 2003
Mozilla 1.4 | June 30, 2003

引用源: http://www.mozilla.org/releases/

  • Previous Page
  • Next Page


Netscape 浏览器

浏览器信息

  • 教程首页
  • Explorer
  • Netscape
  • Mozilla
  • Firefox
  • Opera
  • Chrome

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Netscape 浏览器

  • Previous Page
  • Next Page

Netscape Navigator 9

Netscape Navigator 9 (Beta 1) 于 2007 年 6 月发布。它基于 Mozilla Firefox 2。

Navigator 9 中的一些新特性：

Mozilla 特性
由于 Navigator 9 基于 Mozilla，它拥有所有最新的 Mozilla 特性。
URL 纠错
Navigator 9 会自动校正 URL。
Link Pad
一个新的 sidebar 特性，允许在不搞乱书签的情况下保存新闻日后访问的链接/URL。
扩展兼容性
Navigator 9 允许你安装与 Firefox 2 兼容的插件。
Sidebar Mini Browser
可以在 sidebar 中打开书签和链接。
Resizeable Textarea
拖动文本框的右下角，可以增加更多键入的空间。
选项卡历史
在新选项卡中打开一个链接，可获得与原选项卡中相同的历史记录。
OPML Support
Navigator 9 支持以 OPML 格式导入和导出书签。
合并 Stop/Reload 按钮
为了节省工具栏中的空间，合并了停止和刷新按钮。

Netscape 8

Netscape 8.1.2 发布于 2006 年 9 月。

Netscape 8 允许您对安全级别进行调节（Java、JavaScript、cookies 设置），同时允许您在需要时切换使用 Internet Explorer 引擎来绘制页面。

Netscape 8 中的新特性：

  • 站点控制（双重绘制引擎）
  • 多栏（动态工具栏）
  • 表单填写 / passcard
  • Live Content
  • 改进的标签浏览
  • 动态安全中心

注释：Netscape 8 没有包含 e-mail 客户程序。对于那些需要一个电子邮件客户端的用户，请使用 Mozilla Thunderbird、Mozilla Suite 1.7.x 或者 SeaMonkey，或者为了 email 功能继续使用您的 Netscape 7.2。

Netscape 7

Netscape 7 基于开源引擎 Gecko 以及对 Netscape 6 的微调。

据报告，Netscape 7 非常稳定，速度也很快。

Netscape 6

Netscape 6 发布于 2000 年 11 月。此版本是第一款有力支持 CSS 和 XML 的 Netscape 浏览器。

Netscape 6 基于开源引擎 Gecko，Netscape Communicator 4.8 也在使用这个最初发布于 1994 年晚期的引擎。

Netscape 的问题

Netscape's 4.x 系列的浏览器对 CSS 的支持很差，也不支持 XML。

在 4.0 之后，Netscape 花了将近三年半的时间研发其下一代的浏览器。这次延迟明显地减少了 Netscape 垄断浏览器市场的可能性。延伸阅读。

我们的浏览器统计报告显示，Netscape 正在输掉这场浏览器战争。

更老的 Netscape 版本

Netscape 8.0 - 发布于 2005 年 5 月。

Netscape 7.0 - 发布于 2002 年 9 月。

Netscape 6.0 - 发布于 2000 年 11 月（基于 Mozillas Gecko 引擎）。您可以在 www.mozilla.org 阅读更多有关的内容，同时可以在 http://www.mozilla.org/status 找到有关 Mozilla 项目的信息。

Netscape 5.0 - Netscape 跳过了 version 5。

Netscape Communicator 4.0 (发布于1997年) 第一款部分支持 CSS 的 Netscape 浏览器。

Netscape Navigator 3.0 (发布于 1996 年)。太老了，请勿使用。

Netscape Navigator 2.0 (发布于 1996 年)。太老了，请勿使用。

Netscape 1.0 (发布于 1994 年)。太老了，请勿使用。

Netscape 下载

免费下载最新的 Netscape 浏览器：http://browser.netscape.com

Netscape 在线资源

Netscape Devedge
Netscape自己的开发人员站点。拥有开发会员、文档、教程、工具、插件以及Web开发参考。
Netscape's Devedge 技术中心
此区域拥有：与 Netscape 和开发技术相关的信息和资源，包括开发人员工具、产品以及软件开发工具包，下设的子中心：Strategy、CSS、DOM、Gecko、HTML、JavaScript、Plugins、Securit 以及 XML.

注释：美国在线于 2004 年关闭了 Netscape Devedge，部份 DevEdge 的内容已重新发布到 Mozilla Developer Center 网站。

  • Previous Page
  • Next Page


挪威的 Opera

浏览器信息

  • 教程首页
  • Explorer
  • Netscape
  • Mozilla
  • Firefox
  • Opera
  • Chrome

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

挪威的 Opera

  • Previous Page
  • Next Page

最近发布的 Opera

Opera 9 (用于 Windows、Mac、Linux、FreeBSD 以及 Solaris) - 发布于 2006 年 6 月。

Opera 8.5 (用于 Windows、Mac 以及 Linux) - 发布于 2005 年 9 月

Opera 8 (用于 Windows) - 发布于 2005 年 4 月。

关于 Opera

Opera 是作为挪威电信公司 Telenor 的一个研究项目于 1994 年启动的，并于 1995 发展为一个独立的开发公司，Opera Software ASA。

Opera Software ASA 研发了 Opera web 浏览器，是桌面和设备市场的 web 浏览器开发领域的业界领导者。

Opera 浏览器（被称为继 IE 和 firefox 之后的“第三选择”），由于其较之其他浏览器具有更快、更小且标准兼容性性更强的优点，已经得到来自终端用户和业界的国际性赞誉。

它是免费的吗?

是的，Opera 浏览器是免费的！早期的旗帜广告和许可费已经被撤销了！

Web 标准兼容性

如果您使用 Opera 来测试您的站点，就可以确保您的站点是具有很好的易用性和开放性。仅仅使用兼容标准的代码来编写您的页面，就可以保证您的站点工作于所有的主流浏览器，并支持所有的主流平台和操作系统。

Opera 支持目前正在使用的所有主要 Web 标准，包括 CSS 2.1、HTML 4.01、XHTML1.1、HTTP1.1、DOM 2、ECMAScript (JavaScript)、PNG、WML 2.0、SVG 1.1 tiny、Unicode、以及 Unicode Bidirectional Algorithm。

Opera 的特性

Opera 可以自动进行弹窗阻止。这对于阻止令人讨厌的弹出广告是很有效的。

标签式浏览是一种现代的省时的特性。它使我们能够在同一个浏览器窗口查看多个网页。

Transfers Panel 是 Opera 的下载管理器，可以快速地访问正在进行的以及最近完成的下载。

Opera 的用户界面被译为多种语言，并可以中途切换语言。

Opera 拥有可定制的工具栏，允许用户添加和删除项目，也可创建新的工具栏。

通过选择不同的皮肤，用户可以改变 Opera 的外观和感觉。

Opera 可以直接访问 google 的“相关页面”，导航菜单提供了这个功能。

双击页面上的某个单词会弹出一个菜单，菜单中提供了与所选文本相关的选项，比如网页、词典或百科搜索。

Opera 为 web 创作者提供了对页面验证的直接访问，这样就鼓励了 Web 上良好的习惯做法。

更有有关 Opera 的信息

Opera Software ASA 一直是一个私有公司 - 总部位于挪威的奥斯陆 - 直到 2004 年 3 月它成为一家上市公司。

更多信息以及 Opera 下载地址：www.opera.com。

Opera Software ASA 的简体中文网站：cn.opera.com

  • Previous Page
  • Next Page


浏览器信息

浏览器信息

  • 教程首页
  • Explorer
  • Netscape
  • Mozilla
  • Firefox
  • Opera
  • Chrome

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

浏览器信息

  • Next Page

对于网站开发人员来说，浏览器信息和统计数据的非常重要的。

内容目录

Internet Explorer
微软的 Internet Explorer(IE) 是当今最流行的因特网浏览器。它发布于 1995 年，并于 1998 年在使用人数上超过了 Netscape。
Netscape
Netscape 是首个商业化的因特网浏览器。它发布于 1994 年。在 IE 的竞争下，Netscape 逐渐丧失了它的市场份额。
Mozilla
Mozilla 项目是从 Netscape 的基础上发展起来的。今天，基于 Mozilla 的浏览器已经演变为因特网上第二大的浏览器家族，市场份额为大约 20%。
Firefox
Firefox 是由 Mozilla 发展而来的新式浏览器。它发布于 2004 年，并已成长为因特网上第二大最流行的浏览器。
Opera
Opera 是挪威人发明的因特网浏览器。它以下列特性而闻名于世：快速小巧、符合工业标准、适用于多种操作系统。对于一系列小型设备诸如手机和掌上电脑来说，Opera 无疑是首选的浏览器。
chrome
chrome 是免费的开源 web 浏览器，它由 Google 开发。该浏览器于 2008 年 9 月发布。
  • Next Page


职业规划

职业规划

  • 教程首页
  • 职业规划提示
  • 职业履历
  • 职业资源

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

职业规划

  • Next Page

构建您的网络职业生涯

今天，甚至过去，大多数人都是由自己来设计他们的职业生涯的。

无论你正要启程，还是已经奋斗多年，以下内容都会对您的职业生涯有所助益。

内容目录

职业规划提示
本章为您提供 9 条有价值的职业规划提示。
职业履历
本章内容：什么是简历（CV），以及如何撰写自己的履历。
职业资源
本章列出了一些重要的职业资源。
  • Next Page


职业规划提示

职业规划

  • 教程首页
  • 职业规划提示
  • 职业履历
  • 职业资源

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

职业规划提示

  • Previous Page
  • Next Page

九项重要的职业规划提示。

1. 学习的步伐不停止

古人说，活到老，学到老。终身学习应该是您的座右铭。

世界在不断变化，每个人都在寻找各自的事业途径。

您只有保证了足够的技能储备，才能确保能够得到一份足够满意的工作。

为了保证您的职业发展，您应当定期地更新您的技能和知识。

2. 学会问、学会听，学会学习

一个好的倾听者可以习得更多。

多听取来自同事、老板以及上级的声音。您可以从他们的经历中学到更多。

问一些您感兴趣的话题，然后听听他们怎么说。让他们告诉您事业如何运作，以及如何可以做得更好。

大多数都是乐意帮助您的。

3. 为目前的工作全力以赴

您目前的工作可能是开始您职业生涯的最好起点。

从本职工作做起，从现在做起，做好当前的工作，没有保留地尽到自己的职责，证明自己是一名有价值的员工。

您所做的工作终究会得到回报。

4. 构建人际网络

您的下一个职业阶段很可能得益于您的人际网络。

您知道吗，超过50%的工作都是通过关系网络获得的。

如果您拥有一张良好的人际网络，那么它会助您发现未来的职业，开拓新的方向，获得新的机会。

请在新的关系上多花些时间吧，同时请不要忽略对已有关系的保持。

从您的人际网络获得有价值信息的最佳途径之一是，定期地问候您的交际人，他们正在做什么，以及有关其职业的新情况。

5. 识别你的工作

识别真正重要的工作，而不是去假设。

一定要确定你目前所做的工作不是因假设得来的。那样会浪费您很多时间和才华。

当您着手一份新的工作时，一定要和主管聊聊首要的那些工作。如果您无法确定哪方面是重要的，就去询问他吧。多谈几次也没关系。您会经常对事实上的重要任务与您所作的假设之间差距感到惊讶。

6. 慎重决定下一个工作

在您开始未来的职业生涯之前，一定要认真考虑您理想中的工作。

您理想的职业应该是什么样的呢？ 最关键的是，您一定要乐在其中。

您是否乐于为其它的同事承担责任？您喜欢和人打交道还是摆弄技术？你希望自己创业吗？您希望成为一位艺术家、一位设计师、一名熟练的工程师，还是一名管理人员？

在您为构建未来的职业生涯之前，请明确您的目标。

7. 为未来做准备

为了明天的梦想，今天就要进行准备。

一刻也不要耽搁。现在就更新您的履历，并且定期持续对其更新。

明天您也许就会看到梦想实现的曙光。为此，您需要准备一份专业的履历，准备好为您的雇主展现潜力无穷的你吧！

如果您不清楚如何写一份履历，或者任何描述自己，请现在就开始学习吧。

8. 量力而行

选择适合个人能力的任务。

您可以通过不同的方式来构建未来的职业生涯。在 W3School 学习是件容易的事情。而获得硕士学位则会困难一些。

您可以通过学习各类型的书籍和教程（比如您在 W3School 所找到的）来为职业添砖加瓦。参加一些带有认证测试的短期培训应该可以为您的履历增加不少分量。同时不要忘了：培养新技术所需要的最具价值的资源是您目前从事的工作。

不要为自己设置不可能完成的任务！

9. 实现您的梦想

把梦想落实为行动！

不要让繁忙的工作扼杀您的梦想。假如您有着更高远的目标，请现在就付诸行动吧！

如果您计划接受更高的教育，获得更好的工作，或者开一间属于自己的公司等等，请不要以日常的工作作为等待的借口。您的日常工作会变得越来越忙，您会陷入激烈的竞争中，并耗尽自己的能量。

如果您此刻就存有能量，那么现在就使用它去实现您的梦想吧！

  • Previous Page
  • Next Page


职业履历（CV）

职业规划

  • 教程首页
  • 职业规划提示
  • 职业履历
  • 职业资源

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

职业履历（CV）

  • Previous Page
  • Next Page

履历（CV）是向雇主推销自己的“广告”。

什么是 CV ？

  • CV 指的是 "Curriculum Vitae"
  • Curriculum vitae 在拉丁语中的意思是“生命的故事”
  • CV 经常被称为 "Resume"

一份 CV 中包含哪些内容？

一份 CV 至少要包含下列内容：

  • 个人信息
  • 工作经历
  • 技能
  • 教育水平
  • 个人简介和兴趣
  • 推荐

您的个人信息

个人信息应该包括姓名、住址、电话和电子邮件。我建议您把这些信息放到 CV 的顶部，让它看上去像信笺的抬头。

您的工作经历

列出你做过的工作 - 在开头列出您最近的工作经历。

以及简短的工作描述和您的职责。

确保工作经历位于 CV 的第一页。这些些信息概括了您的技能和优势。其它附加的信息应当位于后面的位置。

您的技能

技能最好使用列表来描述。

列出您的技能 - 最重要的和最相关的。

您的教育水平

教育最好使用列表来描述。

列出您学习的内容 - 在开头列出您最近所受的教育。

不要忘记学科选项、特殊的项目、课程或者荣誉证书。

您的推荐

列出一些人的名字 - 比如您学习所在学校的教授、公司的主管 - 确保可以很容易地联系到他们，并且他们愿意为你作积极的推荐。

您的个人简介

个人简介应包括有关年龄、兴趣爱好以及其它相关信息的的附加信息，且这些信息有助于塑造您的正面形象。我建议您把这些内容放到 CV 的最后。

由于这些内容可以展现您的特质，所以雇主会有兴趣了解这些内容。但需要小心，不要过度地描述您的兴趣，也不要描述那些可能影响到工作的兴趣。假设您正在为一个足球队作教练，不要写赢得比赛的次数。如果他们感兴趣的话，让他们在以后的面试中与您聊这些好了。

  • Previous Page
  • Next Page


职业资源

职业规划

  • 教程首页
  • 职业规划提示
  • 职业履历
  • 职业资源

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

职业资源

  • Previous Page
  • Next Page

推荐了重要的求职、职涯规划以及教育方面的资源。

蓝色理想经典论坛 - 企业招聘

提供了大量企业招聘信息，提供的职位主要集中在网站的设计师和开发人员。

地址：http://bbs.blueidea.com/forum-19-1.html

蓝色理想简介

成立于 1999 年 10 月。国内最大的设计类站点之一。重要的网站设计与开发人员社区。

除了人气极高的经典论坛，还提供经典作品集、经典桌面以及 Think.Pages 等多种产品。

ZDNet China 至顶网 - CIO 频道

CIO 的英文全称是Chief Information Officer。中文意思是首席信息官或信息主管

至顶网的 CIO 频道是 CIO 职业发展的重要工具。

地址：http://cio.zdnet.com.cn/

职涯发展栏目：http://cio.zdnet.com.cn/cio/more/3_842.shtml

ZDNet China 至顶网简介

国内最大的也是唯一企业级 IT 门户，著名科技专业品牌 ZDNet 旗下的网站。

网站平台内容已全面覆盖到 IT 从业者关注的相关内容，包含新闻、网络安全、存储、软件、产品，以及软件下载与技术白皮书下载服务。

重要的 IT 教育站点

CSDN : http://www.csdn.net/

中国 IT 实验室 : http://www.chinaitlab.com/

  • Previous Page
  • Next Page


CSS :active 伪类

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS :active 伪类

返回 CSS 参考手册

定义

:active 伪类向激活（在鼠标点击与释放之间发生的事件）的元素添加特殊的样式。

这个伪类应用于处于激活状态的元素。最常见的例子就是在 HTML 文档中点击一个超链接：在鼠标按钮按下期间，这个链接是激活的。还有其他一些方式来激活元素，另外从理论上讲其他元素也可以被激活，不过 CSS 对此没有定义。

例子

激活的、已访问的、未访问的或者当有鼠标悬停在其上的链接，它们会在支持 CSS 的浏览器中以不同的方式显示出来：

a:link {color: #FF0000}     /* 未访问的链接 */
a:visited {color: #00FF00}  /* 已访问的链接 */
a:hover {color: #FF00FF}    /* 当有鼠标悬停在链接上 */
a:active {color: #0000FF}   /* 被选择的链接 */

注释：为了产生预期的效果，在 CSS 定义中，a:hover 必须位于 a:link 和 a:visited 之后！！

注释：为了产生预期的效果，在 CSS 定义中，a:active 必须位于 a:hover 之后！！

注释：Pseudo-class（伪类）的名称对大小写不敏感。

注释：伪类可与 CSS 类配合使用：

a.red:visited {color: #FF0000}

<a class="red" href="css_syntax.asp">CSS Syntax</a>

如果上面这个例子中的链接已访问过，那么它会显示为红色。

TIY 实例

超链接
本例演示如何向文档中的超链接添加不同的颜色。
超链接 2
本例演示如何向超链接添加其他样式。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS :after 伪元素

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS :after 伪元素

返回 CSS 参考手册

定义

:after 伪元素在元素内容之后插入内容。

这个伪元素允许创作人员在元素内容的最后面插入生成内容。默认地，这个伪元素是行内元素，不过可以使用属性 display 改变这一点。

例子

此样式会在每个 h1 元素之后播放一段声音：

h1:after
{
content: url(beep.wav)
}

TIY 实例

使用 :after 在元素内容之后插入内容
本例演示如何使用 :after 在元素内容之后插入图像。（在 IE 中无效）

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS :before 伪元素

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS :before 伪元素

返回 CSS 参考手册

定义

:before 伪元素在元素内容之前插入内容。

这个伪元素允许创作人员在元素内容的最前面插入生成内容。默认地，这个伪元素是行内元素，不过可以使用属性 display 改变这一点。

例子

此样式会在每个 h1 元素之前播放一段声音：

h1:before
{
content: url(beep.wav)
}

TIY 实例

使用 :before 在元素内容之前插入内容
本例演示如何使用 :before 在元素内容之前插入图像。（在 IE 中无效）

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS :first-child 伪类

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS :first-child 伪类

返回 CSS 参考手册

定义

:first-child 伪类向属于其他元素的第一个子元素的一个元素添加特殊样式。

说明

利用 :first-child 这个伪类，只有当元素是另一个元素的第一个子元素时才能匹配。例如，p:first-child 会选择作为另外某个元素第一个子元素的所有 p 元素。一般可能认为这会选择作为段落第一个子元素的元素，但事实上并非如此，如果要选择段落的第一个子元素，应当写为 p > *:first-child。

例子

例子 1 - 匹配第一个 <p> 元素

在下面的例子中，选择器匹配属于任意元素的第一个子元素的 <p> 元素：

<style type="text/css">
p:first-child
{
font-weight:bold
}
</style>

<p>I am a <em>strong</em> man. I am a <em>strong</em> man.</p>
<p>I am a <em>strong</em> man. I am a <em>strong</em> man.</p>

TIY

例子 2 - 匹配所有 <p> 元素中的第一个 <em> 元素

在本例中，选择器匹配属于 <p> 元素中的第一个子元素的 <em> 元素：

<style type="text/css">
p > em:first-child
{
font-weight:bold
}
</style>

<p>I am a <em>strong</em> man. I am a <em>strong</em> man.</p>
<p>I am a <em>strong</em> man. I am a <em>strong</em> man.</p>

TIY

例子 3 - 匹配所有第一个子元素 <p> 元素中的所有 <em> 元素

在下面的例子中，选择器匹配属于其他元素的第一个子元素的 <p> 元素中的所有 <em>：

<style type="text/css">
p:first-child em
{
font-weight:bold
}
</style>

<p>I am a <em>strong</em> man. I am a <em>strong</em> man.</p>
<p>I am a <em>strong</em> man. I am a <em>strong</em> man.</p>

TIY

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS :first-letter 伪元素

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS :first-letter 伪元素

返回 CSS 参考手册

定义

:first-letter 伪元素向文本的第一个字母添加特殊样式。

这个伪元素用于指定一个元素第一个字母的样式。所有前导标点符号应当与第一个字母一同应用该样式。某些语言有一些要处理为单个字符的字母组合，如果是这样，用户代理可能会把首字母同时应用到这个字母组合。

在 CSS2.1 之前，:first-letter 只能与块级元素关联。CSS2.1 扩大了这个范围，可以与任何元素关联。可以应用到首字母的属性是有限的。

例子

p {font-size: 12pt}
p:first-letter {color:#ff0000;font-size:xx-large}

<p>The first words of an article...</p>

注释：下列属性应用于 :first-letter 伪元素：

  • font 属性
  • color 属性
  • background 属性
  • margin 属性
  • padding 属性
  • border 属性
  • text-decoration
  • vertical-align (仅当 'float' 为 'none' 时)
  • text-transform
  • line-height
  • float
  • clear

伪元素可与 CSS 类结合：

p.article:first-line {color: #FF0000}

<p class="article">A paragraph in an article</p>

本例将把所有 class="article" 的段落的第一个字母设置为 red。

TIY 实例

向首字母添加样式
向首字母和首行添加样式

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS :first-line 伪元素

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS :first-line 伪元素

返回 CSS 参考手册

定义

:first-line 伪元素向文本的首行添加特殊样式。

这个伪元素用于设置元素中的第一行文本的样式，而不论该行出现多少单词。

:first-line 只能与块级元素关联。可以应用到首字母的属性是有限的。

例子

p {font-size: 12pt}
p:first-line {color: #FF0000;font-variant:small-caps}

<p>Some text that ends up on two or more lines</p>

注释：下列属性应用于 :first-line 伪元素：

  • font 属性
  • color 属性
  • background 属性
  • word-spacing
  • letter-spacing
  • text-decoration
  • vertical-align
  • text-transform
  • line-height
  • clear

伪元素可与 CSS 类结合：

p.article:first-line {color: #FF0000}

<p class="article">A paragraph in an article</p>

本例将把所有 class="article" 的段落的第一个字母设置为 red。

TIY 实例

向首字母添加样式
向首字母和首行添加样式

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS :focus 伪类

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS :focus 伪类

返回 CSS 参考手册

定义

:focus 伪类在元素获得焦点时向元素添加特殊的样式。

注释：IE 浏览器不支持此属性。

说明

这个伪类应用于有焦点的元素。例如 HTML 中一个有文本输入焦点的输入框，其中出现了文本输入光标；也就是说，在用户开始键入时，文本会输入到这个输入框。其他元素（如超链接）也可以有焦点，不过 CSS 没有定义哪些元素可以有焦点。

例子

a:link {color: #FF0000}     /* 未访问的链接 */
a:focus {color: #00FF00}  /* 获得焦点的链接 */

注释：伪类的名称对大小写不敏感。

注释：伪类可与 CSS 类配合使用：

a.red:visited {color: #FF0000}

<a class="red" href="css_syntax.asp">CSS Syntax</a>

如果上面这个例子中的链接已被访问过，那么它会显示为红色。

TIY 实例

超链接：:focus 的使用
本例演示如何使用 :focus 伪类（无法在 IE 中工作）。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS :hover 伪类

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS :hover 伪类

返回 CSS 参考手册

定义

:hover 伪类鼠标移到元素上时向此元素添加特殊的样式。

说明

这个伪类应用处于“悬停状态”的元素。悬停定义为用户指示了一个元素但没有将其激活。对此最常见的例子是将鼠标指针移到 HTML 文档中一个超链接的边界范围内。理论上，其他元素也可以处于悬停状态，不过 CSS 没有定义究竟是哪些元素。

例子

激活的、已访问的、未访问的或者当有鼠标悬停在其上的链接，它们会在支持 CSS 的浏览器中以不同的方式显示出来：

a:link {color: #FF0000}     /* 未访问的链接 */
a:visited {color: #00FF00}  /* 已访问的链接 */
a:hover {color: #FF00FF}    /* 当有鼠标悬停在链接上 */
a:active {color: #0000FF}   /* 被选择的链接 */

注释：为了产生预期的效果，在 CSS 定义中，a:hover 必须位于 a:link 和 a:visited 之后！！

注释：为了产生预期的效果，在 CSS 定义中，a:active 必须位于 a:hover 之后！！

注释：Pseudo-class（伪类）的名称对大小写不敏感。

注释：伪类可与 CSS 类配合使用：

a.red:visited {color: #FF0000}

<a class="red" href="css_syntax.asp">CSS Syntax</a>

如果上面这个例子中的链接已访问过，那么它会显示为红色。

TIY 实例

超链接
本例演示如何向文档中的超链接添加不同的颜色。
超链接 2
本例演示如何向超链接添加其他样式。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS :lang 伪类

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS :lang 伪类

返回 CSS 参考手册

定义

:lang 伪类根据元素的语言编码匹配元素。这种语言信息必须包含在文档中，或者与文档关联，不能从 CSS 指定。:lang 的处理与 |= 选择器相同。

例子

:lang 伪类允许您为不同的语言定义特殊的规则。在下面的例子中，:lang 类为带有值为 "no" 的 lang 属性的 q 元素定义引号的类型：

<html>
<head>
<style type="text/css">
q:lang(no)
  {
  quotes: "~" "~"
  }
</style>
</head>

<body>
<p>Some text <q lang="no">A quote in a paragraph</q> Some text.</p>
</body>

</html>

TIY 实例

:lang
本例演示 :lang 伪类的用法。（在 IE 中无效）

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS :link 伪类

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS :link 伪类

返回 CSS 参考手册

定义

:link 伪类向未访问的链接添加特殊的样式。

这个伪类应用于尚未访问过的链接；也就是说，链接所指的 URI 尚未出现在用户代理的历史中。这种状态与 :visited 状态是互斥的。

例子

激活的、已访问的、未访问的或者当有鼠标悬停在其上的链接，它们会在支持 CSS 的浏览器中以不同的方式显示出来：

a:link {color: #FF0000}     /* 未访问的链接 */
a:visited {color: #00FF00}  /* 已访问的链接 */
a:hover {color: #FF00FF}    /* 当有鼠标悬停在链接上 */
a:active {color: #0000FF}   /* 被选择的链接 */

注释：为了产生预期的效果，在 CSS 定义中，a:hover 必须位于 a:link 和 a:visited 之后！！

注释：为了产生预期的效果，在 CSS 定义中，a:active 必须位于 a:hover 之后！！

注释：Pseudo-class（伪类）的名称对大小写不敏感。

注释：伪类可与 CSS 类配合使用：

a.red:visited {color: #FF0000}

<a class="red" href="css_syntax.asp">CSS Syntax</a>

如果上面这个例子中的链接已访问过，那么它会显示为红色。

TIY 实例

超链接
本例演示如何向文档中的超链接添加不同的颜色。
超链接 2
本例演示如何向超链接添加其他样式。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS :visited 伪类

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS :visited 伪类

返回 CSS 参考手册

定义

:visited 伪类向已访问的链接添加特殊的样式。

例子

激活的、已访问的、未访问的或者当有鼠标悬停在其上的链接，它们会在支持 CSS 的浏览器中以不同的方式显示出来：

a:link {color: #FF0000}     /* 未访问的链接 */
a:visited {color: #00FF00}  /* 已访问的链接 */
a:hover {color: #FF00FF}    /* 当有鼠标悬停在链接上 */
a:active {color: #0000FF}   /* 被选择的链接 */

注释：为了产生预期的效果，在 CSS 定义中，a:hover 必须位于 a:link 和 a:visited 之后！！

注释：为了产生预期的效果，在 CSS 定义中，a:active 必须位于 a:hover 之后！！

注释：Pseudo-class（伪类）的名称对大小写不敏感。

注释：伪类可与 CSS 类配合使用：

a.red:visited {color: #FF0000}

<a class="red" href="css_syntax.asp">CSS Syntax</a>

如果上面这个例子中的链接已访问过，那么它会显示为红色。

TIY 实例

超链接
本例演示如何向文档中的超链接添加不同的颜色。
超链接 2
本例演示如何向超链接添加其他样式。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS background 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS background 属性

返回 CSS 参考手册

定义

background 是用于在一个声明中设置所有背景属性的一个简写属性。

通常建议使用这个属性，而不是分别使用单个属性，因为这个属性在较老的浏览器中能够得到更好的支持，而且需要键入的字母也更少。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.background = "#FF0000"

在我们的 HTML DOM 教程中，您可以找到更多有关 background 属性的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

body
  {
  background: #FF0000
  }

body
  {
  background: url(stars.gif) no-repeat top
  }

body
  {
  background: #00FF00 url(stars.gif) no-repeat fixed top
  }

可能的值

值 描述
  • background-color
  • background-image
  • background-repeat
  • background-attachment
  • background-position

您可以在此声明中声明1到5个背景属性

默认值：未定义。

TIY 实例

所有背景属性在一个声明之中
本例演示如何使用简写属性来将所有背景属性设置在一个声明之中。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS background-attachment 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS background-attachment 属性

返回 CSS 参考手册

定义

background-attachment 属性设置背景图像是否固定或者随着页面的其余部分滚动。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.backgroundAttachment = "fixed"

在我们的 HTML DOM 教程中，您可以找到更多有关 backgroundAttachment 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

body
  {
  background-image: url(stars.gif);
  background-attachment: fixed
  }

可能的值

值 | 描述
scroll | 默认。背景图像会随着页面其余部分的滚动而移动。
fixed | 当页面的其余部分滚动时，背景图像不会移动。

TIY 实例

如何设置固定的背景图像
本例演示如何设置固定的背景图像。图像不会随着页面的其他部分滚动。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS background-color 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS background-color 属性

返回 CSS 参考手册

定义

background-color 属性设置元素的背景颜色。

继承性：No

说明

background-color 属性为元素设置一种纯色。这种颜色会填充元素的内容、内边距和边框区域，扩展到元素边框的外边界。如果边框有透明部分（如虚线边框），会透过这些透明部分显示出背景色。

transparent

尽管在大多数情况下，没有必要使用 transparent。不过如果您不希望某元素拥有背景色，同时又不希望用户对浏览器的颜色设置影响到您的设计，那么设置 transparent 值还是有必要的。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.backgroundColor="#00FF00"

在我们的 HTML DOM 教程中，您可以找到更多有关 backgroundColor 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  background-color: #00FF00
  }

可能的值

值 | 描述
color | 颜色值可以是颜色名称、rgb 值或者十六进制数。
transparent | 默认。背景颜色为透明。

TIY 实例

设置背景颜色
本例演示如何为元素设置背景颜色。
设置文本的背景颜色
本例颜色如何设置部分文本的背景颜色。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS background-image 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS background-image 属性

返回 CSS 参考手册

定义

background-image 属性把图像设置为背景。

提示：请设置一种可用的背景颜色，这样的话，假如背景图像不可用，页面也可获得良好的视觉效果。

继承性：No

说明

background-image 属性会在元素的背景中设置一个图像。

根据 background-repeat 属性的值，图像可以无限平铺、沿着某个轴（x 轴或 y 轴）平铺，或者根本不平铺。

初始背景图像（原图像）根据 background-position 属性的值放置。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.backgroundImage="url(stars.gif)"

在我们的 HTML DOM 教程中，您可以找到更多有关 backgroundImage 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

body
  {
  background-image: url(stars.gif);
  background-color: #000000
  }

可能的值

值 | 描述
url(URL) | 指向图像的路径。
none | 默认。无背景图像。

TIY 实例

将图像设置为背景
本例演示如何将图像设置为背景。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS background-position 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS background-position 属性

返回 CSS 参考手册

定义

background-position 属性设置背景图像的起始位置。

继承性：No

说明

这个属性设置背景原图像（由 background-image 定义）的位置，背景图像如果要重复，将从这一点开始。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.backgroundPosition="bottom center"

在我们的 HTML DOM 教程中，您可以找到更多有关 backgroundPosition 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

body
  {
  background-image: url(stars.gif);
  background-repeat: no-repeat;
  background-position: top left
  }

body
  {
  background-image: url(stars.gif);
  background-repeat: no-repeat;
  background-position: 0% 0%
  }

可能的值

值 描述
  • top left
  • top center
  • top right
  • center left
  • center center
  • center right
  • bottom left
  • bottom center
  • bottom right

如果您仅规定了一个关键词，那么第二个值将是"center"。

默认值：0% 0%。
x% y%

第一个值是水平位置，第二个值是垂直位置。

左上角是 0% 0%。右下角是 100% 100%。

如果您仅规定了一个值，另一个值将是 50%。
xpos ypos

第一个值是水平位置，第二个值是垂直位置。

左上角是 0 0。单位是像素 (0px 0px) 或任何其他的 CSS 单位。

如果您仅规定了一个值，另一个值将是50%。

您可以混合使用 % 和 position 值。

TIY 实例

如何放置背景图像
本例演示如何在页面上放置背景图像。
如何使用%来定位背景图像
本例演示如何使用百分比来在页面上定位背景图像。
如何使用像素来定位背景图像
本例演示如何使用像素来在页面上定位背景图像。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS background-repeat 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS background-repeat 属性

返回 CSS 参考手册

定义

background-repeat 属性设置是否及如何重复背景图像。

继承性：No

说明

background-repeat 属性定义了图像的平铺模式。

从原图像开始重复，原图像由 background-image 定义，并根据 background-position 的值放置。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.backgroundRepeat="repeat-y"

在我们的 HTML DOM 教程中，您可以找到更多有关 backgroundRepeat 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

body
  {
  background-image: url(stars.gif);
  background-repeat: repeat-x
  }

可能的值

值 | 描述
repeat | 默认。背景图像将在垂直方向和水平方向重复。
repeat-x | 背景图像将在水平方向重复。
repeat-y | 背景图像将在垂直方向重复。
no-repeat | 背景图像将仅显示一次。

TIY 实例

如何重复背景图像
本例演示如何重复背景图像。
如何在垂直方向重复背景图像
本例演示如何垂直地重复背景图像。
如何在水平方向重复背景图像
本例演示如何水平地重复背景图像。
如何仅显示一次背景图像
本例演示如何仅显示一次背景图像。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS border 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS border 属性

返回 CSS 参考手册

定义

border 属性是一个简写属性，用于把针对四个边的属性设置在一个声明。

注释：此属性无法为边框的每个边设置不同的值，比如"margin" 和 "padding"。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.border="thick solid #0000FF"

在我们的 HTML DOM 教程中，您可以找到更多有关 border 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  border: thin dotted #00FF00
  }

span
  {
  border: solid #0000FF
  }

可能的值

值 描述
  • border-width
  • border-style
  • border-color
 设置针对四条边框的属性。

TIY 实例

所有边框属性在一个声明之中
本例演示用简写属性来将所有四个边框属性设置于同一声明中。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS border-bottom 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS border-bottom 属性

返回 CSS 参考手册

定义

border-bottom 属性是一个简写属性，用于把下边框的所有属性设置到一个声明中。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.borderBottom="thick solid blue"

在我们的 HTML DOM 教程中，您可以找到更多有关 borderBottom 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

table
  {
  border-bottom: thin dotted #00FF00
  }

span
  {
  border-bottom: solid #0000FF
  }

可能的值

值 描述
  • border-bottom-width
  • border-style
  • border-color
 为底边框设置属性。

TIY 实例

所有下边框属性在一个声明中
本例演示用简写属性来将所有下边框属性设置在同一声明中。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS border-bottom-color 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS border-bottom-color 属性

返回 CSS 参考手册

定义

border-bottom-color 可设置元素的下边框的颜色。

只能定义纯色，而且只有当边框的样式是一个非 none 或 hidden 的值时边框才可能出现。

注释：请始终把 border-style 属性声明到 border-color 属性之前。元素必须在您改变其颜色之前获得边框。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.borderBottomColor="blue"

在我们的 HTML DOM 教程中，您可以找到更多有关 borderBottomColor 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  border-style: solid;
  border-bottom-color: #ff0000
  }

p
  {
  border-style: solid;
  border-bottom-color: rgb(255,0,0)
  }

可能的值

值 | 描述
color | 颜色值可以是颜色名称、rgb 值或者十六进制数。
transparent | 边框是透明的。

TIY 实例

设置下边框的颜色
本例演示如何设置下边框的颜色。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS border-bottom-style 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS border-bottom-style 属性

返回 CSS 参考手册

定义

border-bottom-style 设置元素下边框的样式。

只有当这个值不是 none 时边框才可能出现。

在 CSS1 中，HTML 用户代理只需支持 solid 和 none。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.borderBottomStyle="dotted"

在我们的 HTML DOM 教程中，您可以找到更多有关 borderBottomStyle 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

table
  {
  border-bottom-style: solid
  }

可能的值

值 | 描述
none | 定义无边框。
hidden | 与 "none" 相同。不过应用于表时除外，对于表，hidden 用于解决边框冲突。
dotted | 定义点状边框。在大多数浏览器中呈现为实线。
dashed | 定义虚线。在大多数浏览器中呈现为实线。
solid | 定义实线。
double | 定义双线。双线的宽度等于 border-width 的值。
groove | 定义 3D 凹槽边框。其效果取决于 border-color 的值。
ridge | 定义 3D 垄状边框。其效果取决于 border-color 的值。
inset | 定义 3D inset 边框。其效果取决于 border-color 的值。
outset | 定义 3D outset 边框。其效果取决于 border-color 的值。

TIY 实例

设置下边框的样式
本例演示如何设置下边框的样式。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS border-bottom-width 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS border-bottom-width 属性

返回 CSS 参考手册

定义

border-bottom-width 属性设置元素的下边框的宽度。

只有当边框样式不是 none 时才起作用。如果边框样式是 none，边框宽度实际上会重置为 0。不允许指定负长度值。

注释：请始终把 border-style 属性声明到 border-width 属性之前。元素只有在获得边框之后，才能改变其边框的宽度。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.borderBottomWidth="thick"

在我们的 HTML DOM 教程中，您可以找到更多有关 borderBottomWidth 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

table
  {
  border-style: solid;
  border-bottom-width: thin
  }

table
  {
  border-style: solid;
  border-bottom-width: 0.5px
  }

可能的值

值 | 描述
thin | 定义细的下边框。
medium | 默认。定义中等的下边框。
thick | 定义粗的下边框。
length | 允许您自定义下边框的宽度。

TIY 实例

设置下边框的宽度
本例演示如何设置下边框的宽度。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS border-collapse 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS border-collapse 属性

返回 CSS 参考手册

定义

border-collapse 属性设置表格的边框是否被合并为一个单一的边框，还是象在标准的 HTML 中那样分开显示。

继承性：Yes

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.borderCollapse="collapse"

在我们的 HTML DOM 教程中，您可以找到更多有关 borderCollapse 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

table
      {
        border-collapse: separate;
      }

可能的值

值 | 描述
separate | 边框会被分开。
collapse | 默认。如果可能，边框会被合并为一个单一的边框。

TIY 实例

合并表格边框
本例演示是否把表格边框显示为一条单独的边框，还是像标准的 HTML 中那样分开显示。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS border-color 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS border-color 属性

返回 CSS 参考手册

定义

border-color 属性设置四条边框的颜色。此属性可设置 1 到 4 种颜色。

border-color 属性是一个简写属性，可设置一个元素的所有边框中可见部分的颜色，或者为 4 个边分别设置不同的颜色。

要记住，边框的样式不能为 none 或 hidden，否则边框不会出现。

注释：请始终把 border-style 属性声明到 border-color 属性之前。元素必须在您改变其颜色之前获得边框。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.borderColor="#0000FF #00FF00"

在我们的 HTML DOM 教程中，您可以找到更多有关 borderColor 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

四边框均为红色：

table {border-color: red}

顶边框和底边框为红色，左边框和右边框为绿色：

table {border-color: red green}

顶边框为红色，左边框和右边框为绿色，而底边框为蓝色：

table {border-color: red green blue}

顶边框为红色，右边框为绿色，底边框为蓝色，而左边框为黄色：

table {border-color: red green blue yellow}

可能的值

值 | 描述
color | 颜色值可以是颜色名称、rgb 值或者十六进制数。
transparent | 边框是透明的。

TIY 实例

设置四个边框的颜色
本例演示如何设置四个边框的颜色。可以设置一到四个颜色。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS border-left 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS border-left 属性

返回 CSS 参考手册

定义

border-left 属性是一个简写属性，用于把左边框的所有属性设置到一个声明中。

与 border 属性类似，如果不设置边框样式，则不会出现边框。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.borderLeft="thick solid #0000FF"

在我们的 HTML DOM 教程中，您可以找到更多有关 borderLeft 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

table
  {
  border-left: thin dotted #00FF00
  }

table
  {
  border-left: thick #0000FF
  }

可能的值

值 描述
  • border-left-width
  • border-style
  • border-color
 为左边框设置属性。

TIY 实例

所有左边框属性在一个声明之中
所有左边框属性在一个声明之中

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS border-left-color 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS border-left-color 属性

返回 CSS 参考手册

定义

border-left-color 设置元素的左边框的颜色。

只能定义纯色，而且只有当边框的样式是一个非 none 或 hidden 的值时边框才可能出现。

注释：请始终把 border-style 属性声明到 border-color 属性之前。元素必须在您改变其颜色之前获得边框。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.borderLeftColor="#0000FF"

在我们的 HTML DOM 教程中，您可以找到更多有关 borderLeftColor 属性的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  border-style: solid;
  border-left-color: #ff0000
  }

p
  {
  border-style: solid;
  border-left-color: rgb(255,0,0)
  }

可能的值

值 | 描述
color | 颜色值可以是颜色名称、rgb 值或者十六进制数。
transparent | 边框是透明的。

TIY 实例

设置左边框的颜色
本例演示如何设置左边框的颜色。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS border-left-style 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS border-left-style 属性

返回 CSS 参考手册

定义

border-left-style 设置元素左边框的样式。

只有当这个值不是 none 时边框才可能出现。

在 CSS1 中，HTML 用户代理只需支持 solid 和 none。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.borderLeftStyle="dotted"

在我们的 HTML DOM 教程中，您可以找到更多有关 borderLeftStyle 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

table
  {
  border-left-style: solid
  }

可能的值

值 | 描述
none | 定义无边框。
hidden | 与 "none" 相同。不过应用于表时除外，对于表，hidden 用于解决边框冲突。
dotted | 定义点状边框。在大多数浏览器中呈现为实线。
dashed | 定义虚线。在大多数浏览器中呈现为实线。
solid | 定义实线。
double | 定义双线。双线的宽度等于 border-width 的值。
groove | 定义 3D 凹槽边框。其效果取决于 border-color 的值。
ridge | 定义 3D 垄状边框。其效果取决于 border-color 的值。
inset | 定义 3D inset 边框。其效果取决于 border-color 的值。
outset | 定义 3D outset 边框。其效果取决于 border-color 的值。

TIY 实例

设置左边框的样式
本例演示如何设置左边框的样式。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS border-left-width 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS border-left-width 属性

返回 CSS 参考手册

定义

border-left-width 属性设置元素的左边框的宽度。

只有当边框样式不是 none 时才起作用。如果边框样式是 none，边框宽度实际上会重置为 0。不允许指定负长度值。

注释：请始终把 border-style 属性声明到 border-width 属性之前。元素只有在获得边框之后，才能改变其边框的宽度。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.borderLeftWidth="thick"

在我们的 HTML DOM 教程中，您可以找到更多有关 borderLeftWidth 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

table
  {
  border-style: solid;
  border-left-width: thin
  }

table
  {
  border-style: solid;
  border-left-width: 0.5px
  }

可能的值

值 | 描述
thin | 定义细的左边框。
medium | 默认。定义中等的左边框。
thick | 定义粗的左边框。
length | 允许您自定义左边框的宽度。

TIY 实例

设置左边框的宽度
本例演示如何设置左边框的宽度。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS border-right 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS border-right 属性

返回 CSS 参考手册

定义

border-right 属性是一个简写属性，用于把右边框的所有属性设置到一个声明中。

与 border 属性类似，如果不设置边框样式，则不会出现边框。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.borderRight="thick solid #0000FF"

在我们的 HTML DOM 教程中，您可以找到更多有关 borderRight 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

table
  {
  border-right: thin dotted #00FF00
  }

table
  {
  border-right: thick #0000FF
  }

可能的值

值 描述
  • border-right-width
  • border-style
  • border-color
 为右边框设置属性。

TIY 实例

所有右边框属性在一个声明之中
本例演示一个简写属性，用于把所有右边框属性设置在一条声明中。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS border-right-color 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS border-right-color 属性

返回 CSS 参考手册

定义

border-right-color 可设置元素的右边框的颜色。

只能定义纯色，而且只有当边框的样式是一个非 none 或 hidden 的值时边框才可能出现。

注释：请始终把 border-style 属性声明到 border-color 属性之前。元素必须在您改变其颜色之前获得边框。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.borderRightColor="#0000FF"

在我们的 HTML DOM 教程中，您可以找到更多有关 borderRightColor 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  border-style: solid;
  border-right-color: #ff0000
  }

p
  {
  border-style: solid;
  border-right-color: rgb(255,0,0)
  }

可能的值

值 | 描述
color | 颜色值可以是颜色名称、rgb 值或者十六进制数。
transparent | 边框是透明的。

TIY 实例

设置右边框的颜色
本例演示如何设置右边框的颜色。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS border-right-style 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS border-right-style 属性

返回 CSS 参考手册

定义

border-right-style 设置元素右边框的样式。

只有当这个值不是 none 时边框才可能出现。

在 CSS1 中，HTML 用户代理只需支持 solid 和 none。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.borderRightStyle="dotted"

在我们的 HTML DOM 教程中，您可以找到更多有关 borderRightStyle 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

table
  {
  border-right-style: solid
  }

可能的值

值 | 描述
none | 定义无边框。
hidden | 与 "none" 相同。不过应用于表时除外，对于表，hidden 用于解决边框冲突。
dotted | 定义点状边框。在大多数浏览器中呈现为实线。
dashed | 定义虚线。在大多数浏览器中呈现为实线。
solid | 定义实线。
double | 定义双线。双线的宽度等于 border-width 的值。
groove | 定义 3D 凹槽边框。其效果取决于 border-color 的值。
ridge | 定义 3D 垄状边框。其效果取决于 border-color 的值。
inset | 定义 3D inset 边框。其效果取决于 border-color 的值。
outset | 定义 3D outset 边框。其效果取决于 border-color 的值。

TIY 实例

设置右边框的样式
本例演示如何设置右边框的样式。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS border-right-width 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS border-right-width 属性

返回 CSS 参考手册

定义

border-right-width 属性设置元素的右边框的宽度。

只有当边框样式不是 none 时才起作用。如果边框样式是 none，边框宽度实际上会重置为 0。不允许指定负长度值。

注释：请始终把 border-style 属性声明到 border-width 属性之前。元素只有在获得边框之后，才能改变其边框的宽度。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.borderRightWidth="thick"

在我们的 HTML DOM 教程中，您可以找到更多有关 borderRightWidth 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

table
  {
  border-style: solid;
  border-right-width: thin
  }

table
  {
  border-style: solid;
  border-right-width: 0.5cm
  }

可能的值

值 | 描述
thin | 定义细的右边框。
medium | 默认。定义中等的右边框。
thick | 定义粗的右边框。
length | 允许您自定义右边框的宽度。

TIY 实例

设置右边框的宽度
本例演示如何设置右边框的宽度。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS border-spacing 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS border-spacing 属性

返回 CSS 参考手册

定义

border-spacing 属性设置相邻单元格的边框间的距离（仅用于"边框分离"模式）。

注释：某些版本的IE浏览器不支持此属性。

继承性：Yes

说明

该属性指定分隔边框模型中单元格边界之间的距离。在指定的两个长度值中，第一个是水平间隔，第二个是垂直间隔。除非 border-collapse 被设置为 separate，否则将忽略这个属性。尽管这个属性只应用于表，不过它可以由表中的所有元素继承。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.borderSpacing="15px"

在我们的 HTML DOM 教程中，您可以找到更多有关 borderSpacing 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

table
      {
        border-spacing: 10px;
      }

可能的值

值 | 描述
length length | 使用 px、cm 等单位定义距离。如果定义一个 length 参数，那么定义的是水平和垂直间距。如果定义了两个 length 参数，那么第一个设置水平间距，而第二个设置垂直间距。length 不能为负值。

TIY 实例

设置表格边框之间的空白
本例演示如何设置单元格边框之间的距离。（请在非 IE 浏览器中浏览）

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS border-style 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS border-style 属性

返回 CSS 参考手册

定义

border-style 属性用于设置元素所有边框的样式，或者单独地为各边设置边框样式。

只有当这个值不是 none 时边框才可能出现。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.borderStyle="dotted double"

在我们的 HTML DOM 教程中，您可以找到更多有关 borderStyle 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

四边框均为点状：

table {border-style: dotted}

上边框和下边框为点状，左边框和右边框为虚线：

table {border-style: dotted dashed}

上边框为点状，左边框和右边框为虚线，下边框为实线：

table {border-style: dotted dashed solid}

上边框为点状，右边框为虚线，下边框为实线，左边框为双线：

table {border-style: dotted dashed solid double}

可能的值

值 | 描述
none | 定义无边框。
hidden | 与 "none" 相同。不过应用于表时除外，对于表，hidden 用于解决边框冲突。
dotted | 定义点状边框。在大多数浏览器中呈现为实线。
dashed | 定义虚线。在大多数浏览器中呈现为实线。
solid | 定义实线。
double | 定义双线。双线的宽度等于 border-width 的值。
groove | 定义 3D 凹槽边框。其效果取决于 border-color 的值。
ridge | 定义 3D 垄状边框。其效果取决于 border-color 的值。
inset | 定义 3D inset 边框。其效果取决于 border-color 的值。
outset | 定义 3D outset 边框。其效果取决于 border-color 的值。

描述

最不可预测的边框样式是 double。它定义为两条线的宽度再加上这两条线之间的空间等于 border-width 值。不过，CSS 规范并没有说其中一条线是否比另一条粗或者两条线是否应该是一样的粗，也没有指出线之间的空间是否应当比线粗。所有这些都有用户代理决定，创作人员对这个决定没有任何影响。

TIY 实例

设置四边框样式
本例演示如何设置四边框样式。
设置每一边的不同边框
本例演示如何在元素的各边设置不同的边框。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS border-top 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS border-top 属性

返回 CSS 参考手册

定义

border-top是一个简写属性，用于把上边框的所有属性设置到一个声明中。

与 border 属性类似，如果不设置边框样式，则不会出现边框。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.borderTop="thick solid #0000FF"

在我们的 HTML DOM 教程中，您可以找到更多有关 borderTop 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

table
  {
  border-top: thin dotted #00FF00
  }

span
  {
  border-top: solid #0000FF
  }

可能的值

值 描述
  • border-bottom-width
  • border-style
  • border-color
 为上边框设置属性。

TIY 实例

所有上边框属性在一个声明之中
本例演示用简写属性来将所有上边框属性设置于同一声明之中。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS border-top-color 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS border-top-color 属性

返回 CSS 参考手册

定义

border-top-color 设置元素的上边框的颜色。

只能定义纯色，而且只有当边框的样式是一个非 none 或 hidden 的值时边框才可能出现。

注释：请始终把 border-style 属性声明到 border-color 属性之前。元素必须在您改变其颜色之前获得边框。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.borderTopColor="#0000FF"

在我们的 HTML DOM 教程中，您可以找到更多有关 borderTopColor 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  border-style: solid;
  border-top-color: #ff0000
  }

p
  {
  border-style: solid;
  border-top-color: rgb(255,0,0)
  }

可能的值

值 | 描述
color | 颜色值可以是颜色名称、rgb 值或者十六进制数。
transparent | 边框是透明的。

TIY 实例

设置上边框的颜色
本例演示如何设置上边框的颜色。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS border-top-style 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS border-top-style 属性

返回 CSS 参考手册

定义

border-top-style 设置元素上边框的样式。

只有当这个值不是 none 时边框才可能出现。

在 CSS1 中，HTML 用户代理只需支持 solid 和 none。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.borderTopStyle="dotted"

在我们的 HTML DOM 教程中，您可以找到更多有关 borderTopStyle 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

table
  {
  border-bottom-style: solid
  }

可能的值

值 | 描述
none | 定义无边框。
hidden | 与 "none" 相同。不过应用于表时除外，对于表，hidden 用于解决边框冲突。
dotted | 定义点状边框。在大多数浏览器中呈现为实线。
dashed | 定义虚线。在大多数浏览器中呈现为实线。
solid | 定义实线。
double | 定义双线。双线的宽度等于 border-width 的值。
groove | 定义 3D 凹槽边框。其效果取决于 border-color 的值。
ridge | 定义 3D 垄状边框。其效果取决于 border-color 的值。
inset | 定义 3D inset 边框。其效果取决于 border-color 的值。
outset | 定义 3D outset 边框。其效果取决于 border-color 的值。

TIY 实例

设置上边框的样式
本例演示如何设置上边框的样式。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS border-top-width 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS border-top-width 属性

返回 CSS 参考手册

定义

border-top-width 属性设置元素的上边框的宽度。

只有当边框样式不是 none 时才起作用。如果边框样式是 none，边框宽度实际上会重置为 0。不允许指定负长度值。

注释：请始终把 border-style 属性声明到 border-width 属性之前。元素只有在获得边框之后，才能改变其边框的宽度。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.borderTopWidth="thick"

在我们的 HTML DOM 教程中，您可以找到更多有关 borderTopWidth 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

table
  {
  border-style: solid;
  border-top-width: thin
  }

table
  {
  border-style: solid;
  border-top-width: 0.5px
  }

可能的值

值 | 描述
thin | 定义细的上边框。
medium | 默认。定义中等的上边框。
thick | 定义粗的上边框。
length | 允许您来定义上边框的宽度。

TIY 实例

设置上边框的宽度
本例演示如何设置上边框的宽度。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS border-width 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS border-width 属性

返回 CSS 参考手册

定义

border-width 是一个简写属性，用于为元素的所有边框设置宽度，或者单独地为各边边框设置宽度。

只有当边框样式不是 none 时才起作用。如果边框样式是 none，边框宽度实际上会重置为 0。不允许指定负长度值。

继承性：No

JavaScript 语法

CSS属性也可通过一段JavaScript被动态地改变。

脚本语法：

object.style.borderWidth="thick thin"

在我们的 HTML DOM 教程中，您可以找到更多有关 borderWidth 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

四边均为细线边框：

table {border-width: thin}

顶边框和底边框为细线，左边框和右边框为中等边框：

table {border-width: thin medium}

顶边框为细线，左边框和右边框为中等边框，而底边框为粗边框：

table {border-width: thin medium thick}

顶边框为细线，右边框为中等边框，底边框为粗边框，而左边没有边框：

table {border-width: thin medium thick none}

可能的值

值 | 描述
thin | 定义细的边框。
medium | 默认。定义中等的边框。
thick | 定义粗的边框。
length | 允许您自定义边框的宽度。

TIY 实例

所有边框宽度属性在一个声明之中
本例演示用简写属性来将所有边框宽度属性设置于同一声明中。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS bottom 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS bottom 属性

返回 CSS 参考手册

定义

bottom 属性规定元素的底部边缘。

这个元素定义了定位元素下外边距边界与其包含块下边界之间的偏移。

注释：如果 "position" 属性的值为 "static"，那么设置 "bottom" 属性不会产生任何效果。

继承性：No

说明

对于 static 元素，为 auto；对于长度值，则为相应的绝对长度；对于百分比数值，为指定值；否则为 auto。

对于相对定义元素，如果 bottom 和 top 都是 auto，其计算值则都是 0；如果其中之一为 auto，则取另一个值的相反数；如果二者都不是 auto，bottom 将取 top 值的相反数。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.bottom="100px"

在我们的 HTML DOM 教程中，您可以找到更多有关 bottom 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

此例可把段落的底边设置为距离窗口底边之上 20 像素：

p
  {
  position: absolute;
  bottom: 20px
  }

此例可把段落的底边设置为距离窗口底边之下 20 像素：

p
  {
  position: absolute;
  bottom: -20px
  }

可能的值

值 | 描述
auto | 默认。通过浏览器计算底部的位置。
% | 设置元素的底边到最近一个具有定位设置父元素的底部边缘的百分比位置。
length | 使用 px、cm 等单位设置元素的底边到最近一个具有定位设置父元素的底部边缘的位置。可使用负值。

TIY 实例

使用像素值设置图像的底部边缘
本例演示如何使用像素值设置图像的底部边缘。
使用百分比设置图像的底部边缘
本例演示如何使用百分比值设置图像的底部边缘。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS caption-side 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS caption-side 属性

返回 CSS 参考手册

定义

caption-side 属性设置表格标题的位置。

注释：某些版本的 IE 浏览器不支持此属性。

继承性：Yes

说明

该属性指定了表标题相对于表框的放置位置。表标题显示为好像它是表之前（或之后）的一个块级元素。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.captionSide="left"

在我们的 HTML DOM 教程中，您可以找到更多有关 captionSide 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

table
      {
        caption-side: left;
      }

可能的值

值 | 描述
top | 默认。把表格标题定位在表格之上。
bottom | 把表格标题定位在表格之下。
left | 把表格标题定位在表格的左边。
right | 把表格标题定位在表格的右边。

TIY 实例

设置表格标题的位置
本例演示如何定位表格的标题。（请在非 IE 浏览器中浏览）

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS clear 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS clear 属性

返回 CSS 参考手册

定义

出现在其他元素中的图形和文本元素称为浮动元素（floating element）。

clear 属性设置一个元素的侧面是否允许其他的浮动元素。

继承性：No

说明

clear 属性定义了元素的哪边上不允许出现浮动元素。在 CSS1 和 CSS2 中，这是通过自动为清除元素（即设置了 clear 属性的元素）增加上外边距实现的。在 CSS2.1 中，会在元素上外边距之上增加清除空间，而外边距本身并不改变。不论哪一种改变，最终结果都一样，如果声明为左边或右边清除，会使元素的上外边框边界刚好在该边上浮动元素的下外边距边界之下。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.clear="left"

在我们的 HTML DOM 教程中，您可以找到更多有关 clear 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

h2
  {
  clear: right
  }

address
  {
  clear: both
  }

可能的值

值 | 描述
left | 在左侧不允许浮动元素
right | 在右侧不允许浮动元素
both | 在左右两侧均不允许浮动元素
none | 默认。允许浮动元素出现在两侧。

TIY 实例

清除元素的侧面
本例演示如何使用清除元素侧面的浮动元素。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS clip 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS clip 属性

返回 CSS 参考手册

定义

clip 属性设置元素的形状。

当一幅图像的尺寸大于包含它的元素时会发生什么呢？"clip" 属性允许您规定一个元素的可见尺寸，这样此元素就会被修剪并显示为这个形状。

继承性：No

说明

这个属性用于定义一个剪裁矩形。对于一个绝对定义元素，在这个矩形内的内容才可见。出了这个剪裁区域的内容会根据 overflow 的值来处理。剪裁区域可能比元素的内容区大，也可能比内容区小。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.clip="rect(0px,50px,50px,0px)"

在我们的 HTML DOM 教程中，您可以找到更多有关 clip 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

img
  {
  clip: rect(10px, 5px, 10px, 5px)
  }

可能的值

值 | 描述
shape | 设置元素的形状。合法的形状值是：rect (top, right, bottom, left)
auto | 默认。浏览器可设置元素的形状。

TIY 实例

设置元素的形状
本例演示如何设置元素的形状。此元素被剪入形状中，然后显示出来。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS color 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS color 属性

返回 CSS 参考手册

定义

color 属性可设置文本的颜色。

这个属性设置了一个元素的前景色（在 HTML 表现中，就是元素文本的颜色）；光栅图像不受 color 影响。这个颜色还会应用到元素的所有边框，除非被 border-color 或另外某个边框颜色属性覆盖。

要设置一个元素的前景色，最容易的方法是使用 color 属性。

继承性：Yes

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.color="#FF0000"

在我们的 HTML DOM 教程中，您可以找到更多有关 color 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

body
  {
  color: rgb(255,255,0)
  }

可能的值

值 | 描述
color | 颜色值可以是颜色名称、rgb 值或者十六进制数。 默认值：取决于浏览器。

TIY 实例

设置文本颜色
本例演示如何设置文本的颜色。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS content 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS content 属性

返回 CSS 参考手册

定义

content 属性与 :befor 及 :after 伪元素配合使用，来生成贴附于某个 CSS 选择器之前或之后的内容。

继承性：No

说明

该属性用于定义元素之前或之后放置的生成内容。默认地，这往往是行内内容，不过该内容创建的框类型可以用属性 display 控制。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.content="url(beep.wav)"

在我们的 HTML DOM 教程中，您可以找到更多有关 content 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p:before
{
content: url("beep.wav")
}

img:before
{
content: attr(alt)
}

可能的值

值 | 描述
string | 定义文本内容。默认值是""。
url | 定义一个 URL （绝对 URI）。
  • counter(name)
  • counter(name, list-style-type)
  • counters(name, string)
  • counters(name, string, list-style-type)
attr(X) | 定义可显示在某个选择器之前或之后的选择器属性。
  • open-quote
  • close-quote
  • no-open-quote
  • no-close-quote

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS counter-increment 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS counter-increment 属性

返回 CSS 参考手册

定义

counter-increment 属性设置某个选取器每次出现的计数器增量。默认增量是 1。

注释：如果使用了 "display: none"，则无法增加计数。如使用 "visibility: hidden"，则可增加计数。

继承性：No

说明

利用这个属性，计数器可以递增（或递减）某个值，这可以是正值或负值。如果没有提供 number 值，则默认为 1。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.counterIncrement="section 2"

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

A way to number sections with "Section 1", "Section 2", "Section 3"etc.:
h1:before
{
content: "Section " counter(section) " ";
/* Add 1 to section */
counter-increment: section;
}

A way to number sections with "Section 1", "Section 3", "Section 5" etc.:

h1:before
{
content: "Section " counter(section) " ";
/* Add 2 to section */
counter-increment: section 2;
}

可能的值

值 | 描述
none | 默认。选择器无计数器增量。
identifier number | identifier 定义将增加计数的选择器、id 或 class。 number 定义增量。number 可以是正数、零或者负数。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS counter-reset 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS counter-reset 属性

返回 CSS 参考手册

定义

counter-reset 属性设置某个选择器出现次数的计数器的值。默认为 0。

利用这个属性，计数器可以设置或重置为任何值，可以是正值或负值。如果没有提供 number，则默认为 0。

注释：如果使用 "display: none"，则无法重置计数器。如果使用 "visibility: hidden"，则可以重置计数器。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.counterReset="sub-section 2"

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

A way to number sections and sub-sections with "Section 1", "1.1", "1.2", etc.

h1:before
{
content: "Section " counter(section) ". ";
/* Add 1 to section */
counter-increment: section;
/* Set sub-section to 0 */
counter-reset: sub-section;
}

h2:before
{
content: counter(section) "." counter(sub-section) " ";
counter-increment: sub-section;
}

可能的值

值 | 描述
none | 默认。不能对选择器的计数器进行重置。
identifier number | identifier 定义重置计数器的选择器、id 或 class。 number 可设置此选择器出现次数的计数器的值。可以是正数、零或负数。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS cursor 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS cursor 属性

返回 CSS 参考手册

定义

cursor 属性规定当指向某元素之上时显示的指针类型。

该属性定义了鼠标指针放在一个元素边界范围内时所用的光标形状（不过 CSS2.1 没有定义由哪个边界确定这个范围）。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.cursor="text"

在我们的 HTML DOM 教程中，您可以找到更多有关 cursor 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

h2
  {
  cursor: crosshair
  }
p
  {
  cursor: url("first.cur"), url("second.cur"), pointer
  }

可能的值

值 | 描述
url | 需被使用的自定义光标的URL 注释：请在此列表的末端始终定义一种普通的光标，以防没有由 URL 定义的可用光标。
default | 默认光标（通常是一个箭头）
auto | 默认。浏览器设置的光标。
crosshair | 光标呈现为十字线。
pointer | 光标呈现为指示链接的指针（一只手）
move | 此光标指示某对象可被移动。
e-resize | 此光标指示矩形框的边缘可被向右（东）移动。
ne-resize | 此光标指示矩形框的边缘可被向上及向右移动（北/东）。
nw-resize | 此光标指示矩形框的边缘可被向上及向左移动（北/西）。
n-resize | 此光标指示矩形框的边缘可被向上（北）移动。
se-resize | 此光标指示矩形框的边缘可被向下及向右移动（南/东）。
sw-resize | 此光标指示矩形框的边缘可被向下及向左移动（南/西）。
s-resize | 此光标指示矩形框的边缘可被向下移动（北/西）。
w-resize | 此光标指示矩形框的边缘可被向左移动（西）。
text | 此光标指示文本。
wait | 此光标指示程序正忙（通常是一只表或沙漏）。
help | 此光标指示可用的帮助（通常是一个问号或一个气球）。

TIY 实例

改变光标
本例演示如何改变光标。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS direction 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS direction 属性

返回 CSS 参考手册

定义

direction 属性设置文本的方向。

该属性指定了块的基本书写方向，以及针对 Unicode 双向算法的嵌入和覆盖方向。不支持双向文本的用户代理可以忽略这个属性。

继承性：Yes

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.direction="rtl"

在我们的 HTML DOM 教程中，您可以找到更多有关 direction 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

div
  {
  direction: rtl
  }

可能的值

值 | 描述
ltr | 默认。文本方向从左到右。
rtl | 文本方向从右到左。

TIY 实例

设置文本的方向
本例演示如何设置文本的方向。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS display 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS display 属性

返回 CSS 参考手册

定义

display 属性设置是否及如何显示元素。

继承性：No

说明

这个属性用于定义建立布局时元素生成的显示框类型。对于 HTML 等文档类型，如果使用 display 不谨慎会很危险，因为可能违反 HTML 中已经定义的显示层次结构。对于 XML，由于 XML 没有内置的这种层次结构，所有 display 是绝对必要的。

注释：CSS2 中有值 compact 和 marker，不过由于缺乏广泛的支持，已经从 CSS2.1 中去除了。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.display="none"

在我们的 HTML DOM 教程中，您可以找到更多有关 display 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  display: block
  }

li
  {
  display: list-item
  }

table
  {
  display: table
  }

td, th
  {
  display: table-cell
  }

可能的值

值 | 描述
none | 此元素不会被显示。
block | 此元素将显示为块级元素，此元素前后会带有换行符。
inline | 默认。此元素会被显示为内联元素，元素前后没有换行符。
inline-block | 行内块元素。（CSS2.1 新增的值）
list-item | 此元素会作为列表显示。
run-in | 此元素会根据上下文作为块级元素或内联元素显示。
compact | CSS 中有值 compact，不过由于缺乏广泛支持，已经从 CSS2.1 中删除。
marker | CSS 中有值 marker，不过由于缺乏广泛支持，已经从 CSS2.1 中删除。
table | 此元素会作为块级表格来显示（类似 <table>），表格前后带有换行符。
inline-table | 此元素会作为内联表格来显示（类似 <table>），表格前后没有换行符。
table-row-group | 此元素会作为一个或多个行的分组来显示（类似 <tbody>）。
table-header-group | 此元素会作为一个或多个行的分组来显示（类似 <thead>）。
table-footer-group | 此元素会作为一个或多个行的分组来显示（类似 <tfoot>）。
table-row | 此元素会作为一个表格行显示（类似 <tr>）。
table-column-group | 此元素会作为一个或多个列的分组来显示（类似 <colgroup>）。
table-column | 此元素会作为一个单元格列显示（类似 <col>）
table-cell | 此元素会作为一个表格单元格显示（类似 <td> 和 <th>）
table-caption | 此元素会作为一个表格标题显示（类似 <caption>）

TIY 实例

如何把元素显示为内联元素
本例演示如何把元素显示为内联元素。
如何把元素显示为块级元素
本例演示如何把元素显示为块级元素。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS Don't

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS Don't

  • Previous Page
  • Next Page

本节列出了在使用 CSS 时尽量避免使用的技术。

Internet Explorer Behaviors

它是什么？Internet Explorer 5 引入了行为 (behaviors)。behaviors 是一种通过使用 CSS 向 HTML 元素添加行为的方法。

为什么要避免它？只有 Internet Explorer 支持 behavior 属性。

用什么代替？请使用 JavaScript 和 HTML DOM 取而代之。

例子 1 - Mouseover Highlight

下面的 HTML 文件中有一个 <style> 元素，它为 <h1> 元素定义了一个行为：

<html>
<head>
<style type="text/css">
h1 { behavior: url(behave.htc) }
</style>
</head>

<body>
<h1>Mouse over me!!!</h1>
</body>
</html>

下面是 XML 文档 "behave.htc"：

<attach for="element" event="onmouseover" handler="hig_lite" />
<attach for="element" event="onmouseout" handler="low_lite" />

<script type="text/javascript">
function hig_lite()
{
element.style.color='red';
}

function low_lite()
{
element.style.color='blue';
}
</script>

behavior 文件包含了针对元素的 JavaScript 和 事件句柄。

如果您使用 Internet Explorer，可以亲自试一下（把鼠标放在例子中的文本上）。

例子 2 - Typewriter Simulation

下面的 HTML 文件中有一个 <style> 元素，它为 id 为 "typing" 的元素定义了一个行为：

<html>
<head>
<style type="text/css">
#typing
{
behavior:url(behave_typing.htc);
font-family:'courier new';
}
</style>
</head>

<body>
<span id="typing" speed="100">IE5 introduced DHTML behaviors.
Behaviors are a way to add DHTML functionality to HTML elements
with the ease of CSS.<br /><br />How do behaviors work?<br />
By using XML we can link behaviors to any element in a web page
and manipulate that element.</p>
</span>
</body>
</html>

下面是 XML 文档 "behave.htc"：

<attach for="window" event="onload" handler="beginTyping" />
<method name="type" />

<script type="text/javascript">
var i,text1,text2,textLength,t;

function beginTyping()
{
i=0;
text1=element.innerText;
textLength=text1.length;
element.innerText="";
text2="";
t=window.setInterval(element.id+".type()",speed);
}

function type()
{
text2=text2+text1.substring(i,i+1);
element.innerText=text2;
i=i+1;
if (i==textLength)
  {
  clearInterval(t);
  }
}
</script>

如果您使用 Internet Explorer，可以亲自试一下。

  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS empty-cells 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS empty-cells 属性

返回 CSS 参考手册

定义

empty-cells 属性设置是否显示表格中的空单元格（仅用于“分离边框”模式）。

注释：某些版本的IE浏览器不支持此属性。

继承性：Yes

说明

该属性定义了不包含任何内容的表单元格如何表示。如果显示，就会绘制出单元格的边框和背景。除非 border-collapse 设置为 separate，否则将忽略这个属性。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.emptyCells="show"

在我们的 HTML DOM 教程中，您可以找到更多有关 emptyCells 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

table
      {
        empty-cells: show;
      }

可能的值

值 | 描述
hide | 默认。不在空单元格周围绘制边框。
show | 在空单元格周围绘制边框。

TIY 实例

显示表格中的空单元
本例演示是否显示表格中的空单元。（请在非 IE 浏览器中浏览）

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS float 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS float 属性

返回 CSS 参考手册

定义

float 属性定义元素在哪个方向浮动。以往这个属性总应用于图像，使文本围绕在图像周围，不过在 CSS 中，任何元素都可以浮动。浮动元素会生成一个块级框，而不论它本身是何种元素。

浮动非替换元素要指定一个明确的宽度；否则，它们会尽可能地窄。

注释：假如在一行之上只有极少的空间可供浮动元素，那么这个元素会跳至下一行，这个过程会持续到某一行拥有足够的空间为止。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.cssFloat="left"

在我们的 HTML DOM 教程中，您可以找到更多有关 cssFloat 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

img
  {
  float: left
  }

可能的值

值 | 描述
left | 文本或图像会移至父元素中的左侧。
right | 文本或图像会移至父元素中的右侧。
none | 默认。文本或图像会显示于它在文档中出现的位置。

TIY 实例

float 属性的简单应用
使图像浮动于一个段落的右侧。
将带有边框和边界的图像浮动于段落的右侧
使图像浮动于段落的右侧。向图像添加边框和边界。
带标题的图像浮动于右侧
使带有标题的图像浮动于右侧
使段落的首字母浮动于左侧
使段落的首字母浮动于左侧，并向这个字母添加样式。
创建水平菜单
使用具有一栏超链接的浮动来创建水平菜单。
创建无表格的首页
使用浮动来创建拥有页眉、页脚、左侧目录和主体内容的首页。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS font 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS font 属性

返回 CSS 参考手册

定义

除了某些系统字体，font 属性这个简写属性用于在一个声明中设置针对一个字体的所有属性。

注释：此属性也有第六个值："line-height"，可设置行间距。

继承性：Yes

说明

这个简写属性用于一次设置元素字体的两个或更多方面。使用 icon 等关键字可以适当地设置元素的字体，使之与用户计算机环境中的某个方面一致。注意，如果没有使用这些关键词，至少要指定字体大小和字体系列。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.font="italic bold 12px arial,serif"

在我们的 HTML DOM 教程中，您可以找到更多有关 font 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  font: 12px arial
  }

p
  {
  font: italic small-caps bold 12px arial
  }

p
  {
  font: oblique small-caps 900 12px/14px arial
  }

p
  {
  font: menu
  }

可能的值

值 | 描述
  • font-style
  • font-variant
  • font-weight
  • font-size/line-height
  • font-family

设置针对字体的属性。line-height 值可设置行间的空白，此值可以是一个数字、一个百分比或者一个字号。

默认值：取决于浏览器。
caption | 定义被有标题的控件使用的字体（比如按钮、下拉列表等）。
icon | 定义被图标标记使用的字体。
menu | 定义被下拉列表使用的字体。
message-box | 定义被对话框使用的字体。
small-caption
status-bar | 定义被窗口状态栏使用的字体。

TIY 实例

所有字体属性在一个声明之内
本例演示如何使用简写属性将字体属性设置在一个声明之内。
设置使用 "caption" 值的段落字体
本例演示如何设置使用 "caption" 值的段落字体。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS font-family 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS font-family 属性

返回 CSS 参考手册

定义

font-family 属性是用于某个元素的字体族名称或/及类族名称的一个优先表。浏览器会使用它可识别的第一个值。

注释：使用逗号分割每个值，并始终提供一个类族名称作为最后的选择。

继承性：Yes

说明

这个属性定义用于元素文本显示的字体系列。注意，使用某种特定的字体系列（Geneva）完全取决于用户机器上该字体系列是否可用；这个属性没有指示任何字体下载。因此，强烈推荐使用一个通用字体系列名作为后路。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.fontFamily="arial, sans-serif"

在我们的 HTML DOM 教程中，您可以找到更多有关 fontFamily 属性的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

body
  {
  font-family: courier, serif
  }

p
  {
  font-family: arial, "lucida console", sans-serif
  }

<p style="font-family: arial, 'lucida console', sans-serif">

可能的值

值 描述
  • family-name
  • generic-family

用于某个元素的字体族名称或/及类族名称的一个优先表。

默认值：取决于浏览器。

TIY 实例

设置文本的字体
本例演示如何设置文本字体。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS font-size 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS font-size 属性

返回 CSS 参考手册

定义

font-size 属性可设置字体的尺寸。

继承性：Yes

说明

该属性设置元素的字体大小。注意，实际上它设置的是字体中字符框的高度；实际的字符字形可能比这些框高或矮（通常会矮）。

各关键字对应的字体必须比一个最小关键字相应字体要高，并且要小于下一个最大关键字对应的字体。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.fontSize="larger"

在我们的 HTML DOM 教程中，您可以找到更多有关 fontSize 属性的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

body
  {
  font-size: x-large
  }

p
  {
  font-size: 10px
  }

可能的值

值 | 描述
  • xx-small
  • x-small
  • small
  • medium
  • large
  • x-large
  • xx-large

把字体的尺寸设置为不同的尺寸，从 xx-small 到 xx-large。

默认值：medium。
smaller | 把 font-size 设置为比父元素更小的尺寸。
larger | 把 font-size 设置为比父元素更大的尺寸。
length | 把 font-size 设置为一个固定的值。
% 把 font-size 设置为基于父元素的一个百分比。

TIY 实例

设置字体尺寸
本例演示如何设置字体尺寸。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS font-size-adjust 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS font-size-adjust 属性

返回 CSS 参考手册

定义

字体的小写字母 "x" 的高度与 "font-size" 高度之间的比率被称为一个字体的 aspect 值。当字体拥有高的 aspect 值时，那么当此字体被设置为很小的尺寸时会更易阅读。举例：Verdana 的 aspect 值是 0.58（意味着当字体尺寸为 100px 时，它的 x-height 是 58px ）。Times New Roman 的 aspect 值是 0.46。这就意味着 Verdana 在小尺寸时比 Times New Roman 更易阅读。

font-size-adjust 属性可为某个元素规定一个 aspect 值，这样就可以保持首选字体的 x-height。

继承性：Yes

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.fontSizeAdjust="0.70"

在我们的 HTML DOM 教程中，您可以找到更多有关 fontSizeAdjust 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

h1
  {
  font-size-adjust: 0.58
  }

p
  {
  font-size: 10px
  }

可能的值

值 | 描述
none | 默认。如果此字体不可用，则不保持此字体的 x-height。
number

定义字体的 aspect 值比率。

可使用的公式：

首选字体的字体尺寸 * （font-size-adjust 值 / 可用字体的 aspect 值）=可应用到可用字体的字体尺寸

举例：

如果 14px 的 Verdana（aspect 值是 0.58）不可用，但是某个可用的字体的 aspect 值是 0.46，那么替代字体的尺寸将是 14 * (0.58/0.46) = 17.65px。

TIY 实例

使用 font-size-adjust 设置字体尺寸
本例演示如何使用 font-size-adjust 设置字体尺寸。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS font-stretch 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS font-stretch 属性

返回 CSS 参考手册

定义

font-stretch 属性可对当前的 font-family 进行伸缩变形。

继承性：Yes

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.fontWeight="900"

在我们的 HTML DOM 教程中，您可以找到更多有关 fontStretch 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

h1
  {
  font-stretch: ultra-condensed
  }

可能的值

值 | 描述
normal | 默认。把缩放比例设置为标准。
wider | 把伸展比例设置为更进一步的伸展值
narrower | 把收缩比例设置为更进一步的收缩值
  • ultra-condensed
  • extra-condensed
  • condensed
  • semi-condensed
  • semi-expanded
  • expanded
  • extra-expanded
  • ultra-expanded
 设置 font-family 的缩放比例。"ultra-condensed" 是最宽的值，而 "ultra-expanded" 是最窄的值。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS font-style 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS font-style 属性

返回 CSS 参考手册

定义

font-style 属性可定义字体的风格。

继承性：Yes

说明

该属性设置使用斜体、倾斜或正常字体。斜体字体通常定义为字体系列中的一个单独的字体。理论上讲，用户代理可以根据正常字体计算一个斜体字体。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.fontStyle="italic"

在我们的 HTML DOM 教程中，您可以找到更多有关 fontStyle 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

body
  {
  font-style: italic
  }

可能的值

值 | 描述
normal | 默认。浏览器显示一个标准的字体。
italic | 浏览器会显示一个斜体的字体。
oblique | 浏览器会显示一个倾斜的字体。

TIY 实例

设置字体风格
本例演示如何设置字体风格。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS font-variant 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS font-variant 属性

返回 CSS 参考手册

定义

font-variant 属性用于设置小型大写字母的字体显示文本，这意味着所有的小写字母均会被转换为大写，但是所有使用小型大写字体的字母与其余文本相比，其字体尺寸更小。

继承性：Yes

说明

该属性主要用于定义小型大写字母文本。理论上，用户代理可以根据正常字体计算出小型大写字母字体。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.fontVariant="small-caps"

在我们的 HTML DOM 教程中，您可以找到更多有关 fontVariant 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  font-variant: small-caps
  }

可能的值

值 | 描述
normal | 默认。浏览器会显示一个标准的字体。
small-caps | 浏览器会显示小型大写字母的字体。

TIY 实例

设置字体的异体
本例演示如何设置字体的异体。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS font-weight 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS font-weight 属性

返回 CSS 参考手册

定义

font-weight 属性设置文本的粗细。

继承性：Yes

说明

该属性用于设置显示元素的文本中所用的字体加粗。数字值 400 相当于 关键字 normal，700 等价于 bold。每个数字值对应的字体加粗必须至少与下一个最小数字一样细，而且至少与下一个最大数字一样粗。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.fontWeight="900"

在我们的 HTML DOM 教程中，您可以找到更多有关 fontWeight 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  font-weight: bold
  }

可能的值

值 | 描述
normal | 默认。定义标准的字符。
bold | 定义粗体字符。
bolder | 定义更粗的字符。
lighter | 定义更细的字符。
  • 100
  • 200
  • 300
  • 400
  • 500
  • 600
  • 700
  • 800
  • 900
 定义由粗到细的字符。400 等同于 normal，而 700 等同于 bold。

TIY 实例

设置字体的粗细
本例演示如何设置字体的粗细。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS height 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS height 属性

返回 CSS 参考手册

定义

height 属性设置一个元素的高度。

继承性：No

说明

这个属性定义元素内容区的高度，在内容区外面可以增加内边距、边框和外边距。

行内非替换元素会忽略这个属性。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.height="50px"

在我们的 HTML DOM 教程中，您可以找到更多有关 height 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

img
  {
  height: 230px
  }

可能的值

值 | 描述
auto | 默认。浏览器会计算出实际的高度。
length | 使用 px、cm 等单位定义高度。
% | 基于包含它的块级对象的百分比高度。

TIY 实例

使用像素值设置图像的高度
本例演示如何使用像素值设置元素的高度。
使用百分比设置图像的高度
本例演示如何使用百分比值来设置元素的高度。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS id 选择器

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS id 选择器

  • Previous Page
  • Next Page

id 选择器

id 选择器可以为标有特定 id 的 HTML 元素指定特定的样式。

id 选择器以 "#" 来定义。

下面的两个 id 选择器，第一个可以定义元素的颜色为红色，第二个定义元素的颜色为绿色：

#red {color:red;}
#green {color:green;}

下面的 HTML 代码中，id 属性为 red 的 p 元素显示为红色，而 id 属性为 green 的 p 元素显示为绿色。

<p id="red">这个段落是红色。</p>
<p id="green">这个段落是绿色。</p>

注意：id 属性只能在每个 HTML 文档中出现一次。想知道原因吗，请参阅 XHTML:网站重构。

id 选择器和派生选择器

在现代布局中，id 选择器常常用于建立派生选择器。

#sidebar p {
    font-style: italic;
    text-align: right;
    margin-top: 0.5em;
    }

上面的样式只会应用于出现在 id 是 sidebar 的元素内的段落。这个元素很可能是 div 或者是表格单元，尽管它也可能是一个表格或者其他块级元素。它甚至可以是一个内联元素，比如 <em></em> 或者 <span></span>，不过这样的用法是非法的，因为不可以在内联元素 <span> 中嵌入 <p> （如果你忘记了原因，请参阅 XHTML:网站重构）。

一个选择器，多种用法

即使被标注为 sidebar 的元素只能在文档中出现一次，这个 id 选择器作为派生选择器也可以被使用很多次：

#sidebar p {
    font-style: italic;
    text-align: right;
    margin-top: 0.5em;
    }

#sidebar h2 {
    font-size: 1em;
    font-weight: normal;
    font-style: italic;
    margin: 0;
    line-height: 1.5;
    text-align: right;
    }

在这里，与页面中的其他 p 元素明显不同的是，sidebar 内的 p 元素得到了特殊的处理，同时，与页面中其他所有 h2 元素明显不同的是，sidebar 中的 h2 元素也得到了不同的特殊处理。

单独的选择器

id 选择器即使不被用来创建派生选择器，它也可以独立发挥作用：

#sidebar {
    border: 1px dotted #000;
    padding: 10px;
    }

根据这条规则，id 为 sidebar 的元素将拥有一个像素宽的黑色点状边框，同时其周围会有 10 个像素宽的内边距（padding，内部空白）。老版本的 Windows/IE 浏览器可能会忽略这条规则，除非你特别地定义这个选择器所属的元素：

div#sidebar {
    border: 1px dotted #000;
    padding: 10px;
    }
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS left 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS left 属性

返回 CSS 参考手册

定义

left 属性规定元素的左边缘。

这个元素定义了定位元素左外边距边界与其包含块左边界之间的偏移。

注释：如果 "position" 属性的值为 "static"，那么设置 "left" 属性不会产生任何效果。

继承性：No

说明

对于 static 元素，为 auto；对于长度值，则为相应的绝对长度；对于百分比数值，为指定值；否则为 auto。

对于相对定义元素，left 的计算值始终等于 right。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.left="100px"

在我们的 HTML DOM 教程中，您可以找到更多有关 left 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

本例可把段落的左边缘设置到距离窗口左边缘的右侧 20 像素：

p
  {
  position: absolute;
  left: 20px
  }

本例可把段落的左边缘设置到距离窗口左边缘的左侧 20 像素：

p
  {
  position: absolute;
  left: -20px
  }

可能的值

值 | 描述
auto | 默认。通过浏览器来计算左侧的位置。
% | 设置元素的左边到最近一个具有定位设置父元素的左边缘的百分比位置。
length | 使用 px、cm 等单位设置元素的左边到最近一个具有定位设置父元素的左边缘的位置。可使用负值。

TIY 实例

使用固定值设置图像的左边缘
本例演示如何使用固定值设置图像的左边缘。
使用百分比设置图像的左边缘
本例演示如何使用百分比值设置图像的左边缘。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS letter-spacing 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS letter-spacing 属性

返回 CSS 参考手册

定义

letter-spacing 属性增加或减少字符间的空白。

该属性定义了在文本字符框之间插入多少空间。由于字符字形通常比其字符框要窄，指定长度值时，会调整字母之间通常的间隔。因此，normal 就相当于值为 0。

注释：允许使用负值，这会让字母之间挤得更紧。

继承性：Yes

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.letterSpacing="3px"

在我们的 HTML DOM 教程中，您可以找到更多有关 letterSpacing 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  letter-spacing: 12px
  }

p
  {
  letter-spacing: -0.5px
  }

可能的值

值 | 描述
normal | 默认。定义字符间的标准空间。
length | 定义字符间的固定空间。

TIY 实例

规定字符间距
本例演示如何增加或减少字符间距。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS line-height 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS line-height 属性

返回 CSS 参考手册

定义

line-height 属性设置行间的距离。

注释：不允许使用负值。

继承性：Yes

说明

该属性会影响行框的布局。在应用到一个块级元素时，它定义了该元素中基线之间的最小距离而不是最大距离。

line-height 与 font-size 的计算值之差（在 CSS 中成为“行间距”）分为两半，分别加到一个文本行内容的顶部和底部。可以包含这些内容的最小框就是行框。

原始数字值指定了一个缩放因子，后代元素会继承这个缩放因子而不是计算值。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.lineHeight="2"

在我们的 HTML DOM 教程中，您可以找到更多有关 lineHeight 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  line-height: 1.4
  }

p
  {
  line-height: 14pt
  }

p
  {
  line-height: 140%
  }

可能的值

值 | 描述
normal | 默认。设置合理的行间距。
number | 设置数字，此数字会与当前的字体尺寸相乘来设置行间距。
length | 设置固定的行间距。
% | 基于当前字体尺寸的百分比行间距。

TIY 实例

使用百分比设置行间距
本例演示如何使用百分比值来设置段落中的行间距。
使用像素值设置行间距
本例演示如何使用像素值来设置段落中的行间距。
使用数值来设置行间距
本例演示如何使用一个数值来设置段落中的行间距。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS list-style 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS list-style 属性

返回 CSS 参考手册

定义

list-style 属性是用于在一个声明中设置一个列表的所有属性的简写属性。

继承性：Yes

说明

该属性是一个简写属性，涵盖了所有其他列表样式属性。由于它应用到所有 display 为 list-item 的元素，所以在普通的 HTML 和 XHTML 中只能用于 li 元素，不过实际上它可以应用到任何元素，并由 list-item 元素继承。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.listStyle="decimal inside"

在我们的 HTML DOM 教程中，您可以找到更多有关 listStyle 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

ul
  {
  list-style: disc outside
  }

ol
  {
  list-style: decimal inside
  }

可能的值

值 描述
  • list-style-type
  • list-style-position
  • list-style-image
 设置列表的属性。默认值：未定义。

TIY 实例

在一个声明中定义所有的列表属性
本例演示将所有针对列表的属性设置于一个简写属性。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS list-style-image 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS list-style-image 属性

返回 CSS 参考手册

定义

list-style-image 属性使用一幅图像来替换列表项的标记。

注释：请始终规定一个 "list-style-type" 属性以防图像不可用。

继承性：Yes

说明

这个属性指定作为一个有序或无序列表项标志的图像。图像相对于列表项内容的放置位置通常使用 list-style-position 属性控制。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.listStyleImage="url('blueball.gif')"

在我们的 HTML DOM 教程中，您可以找到更多有关 listStyleImage 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

ol
  {
  list-style-image: url(blueball.gif);
  list-style-type: circle
  }

可能的值

值 | 描述
url | 图像的路径。
none | 默认。无图形被显示。

TIY 实例

将图像作为列表项标记
本例演示如何将图像作为列表项标记。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS list-style-position 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS list-style-position 属性

返回 CSS 参考手册

定义

list-style-position 放置列表中的列表项标记。

继承性：Yes

说明

该属性用于声明列表标志相对于列表项内容的位置。外部 (outside) 标志会放在离列表项边框边界一定距离处，不过这距离在 CSS 中未定义。内部 (inside) 标志处理为好像它们是插入在列表项内容最前面的行内元素一样。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.listStylePosition="inside"

在我们的 HTML DOM 教程中，您可以找到更多有关 listStylePosition 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

ol
  {
  list-style-position: inside
  }

可能的值

值 | 描述
inside | 列表项目标记放置在文本以内，且环绕文本根据标记对齐。
outside | 默认。保持标记位于文本的左侧。列表项目标记放置在文本以外，且环绕文本不根据标记对齐。

TIY 实例

放置列表标记
本例演示在何处放置列表标记。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS list-style-type 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS list-style-type 属性

返回 CSS 参考手册

定义

list-style-type 属性设置列表项标记的类型。

注释：某些浏览器仅支持 "disc" 值。

继承性：Yes

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.listStyleType="square"

在我们的 HTML DOM 教程中，您可以找到更多有关 listStyleType 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

ul
{
list-style-type: disc;
}

可能的值

CSS2 的值：

值 | 描述
none | 无标记。
disc | 默认。标记是实心圆。
circle | 标记是空心圆。
square | 标记是实心方块。
decimal | 标记是数字。
decimal-leading-zero | 0开头的数字标记。(01, 02, 03, 等。)
lower-roman | 小写罗马数字(i, ii, iii, iv, v, 等。)
upper-roman | 大写罗马数字(I, II, III, IV, V, 等。)
lower-alpha | 小写英文字母The marker is lower-alpha (a, b, c, d, e, 等。)
upper-alpha | 大写英文字母The marker is upper-alpha (A, B, C, D, E, 等。)
lower-greek | 小写希腊字母(alpha, beta, gamma, 等。)
lower-latin | 小写拉丁字母(a, b, c, d, e, 等。)
upper-latin | 大写拉丁字母(A, B, C, D, E, 等。)
hebrew | 传统的希伯来编号方式
armenian | 传统的亚美尼亚编号方式
georgian | 传统的乔治亚编号方式(an, ban, gan, 等。)
cjk-ideographic | 简单的表意数字
hiragana | 标记是：a, i, u, e, o, ka, ki, 等。（日文片假名）
katakana | 标记是：A, I, U, E, O, KA, KI, 等。（日文片假名）
hiragana-iroha | 标记是：i, ro, ha, ni, ho, he, to, 等。（日文片假名）
katakana-iroha | 标记是：I, RO, HA, NI, HO, HE, TO, 等。（日文片假名）

CSS2.1 的值：

disc | circle | square | decimal | decimal-leading-zero |
lower-roman | upper-roman | lower-greek | lower-latin | upper-latin |
armenian | georgian | none | inherit

TIY 实例

在无序列表中的不同类型的列表标记
本例演示在CSS中不同类型的列表项标记。
在有序列表中不同类型的列表项标记
本例演示在CSS中不同类型的列表项标记。
所有的列表样式类型
本例演示在CSS中所有不同类型的列表项标记。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS margin 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS margin 属性

返回 CSS 参考手册

定义

margin 属性是用于在一个声明中设置四个外边距的所有属性的简写属性。

注释：允许使用负值。

继承性：No

说明

这个简写属性设置一个元素所有外边距的宽度，或者设置各边上外边距的宽度。

块级元素的垂直相邻外边距会合并，而行内元素实际上不占上下外边距。行内元素的的左右外边距不会合并。同样地，浮动元素的外边距也不会合并。允许指定负的外边距值，不过使用时要小心。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.margin="100px"

在我们的 HTML DOM 教程中，您可以找到更多有关 margin 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style对象参考手册。

例子

四个边距均为10px：

h1 {margin: 10px}

顶边距和底边距为10px，左边距和右边距是父元素宽度的2%：

h1 {margin: 10px 2%}

顶边距为10px，左边距和右边距是父元素宽度的2%，底边距是-10px：

h1 {margin: 10px 2% -10px}

顶边距为10px，右边距是父元素宽度的2%，底边距是-10px，而左边距由浏览器设置：

h1 {margin: 10px 2% -10px auto}

可能的值

值 描述
  • margin-top
  • margin-right
  • margin-bottom
  • margin-left

设置针对边距的属性。

值可以是：

  • 百分比（基于父对象总高度或宽度的百分比）
  • 长度值（定义一个固定的边距）
  • auto（浏览器设定的值）。

默认值：未定义。

TIY 实例

所有的边距属性在一个声明中
本例演示如何将所有的边距属性设置于一个声明中。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS margin-bottom 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS margin-bottom 属性

返回 CSS 参考手册

定义

margin-bottom 属性设置元素的下外边距。

注释：允许使用负值。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.marginBottom="32px"

在我们的 HTML DOM 教程中，您可以找到更多有关 marginBottom 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

h1
  {
  margin-bottom: 10px
  }

h2
  {
  margin-bottom: -20px
  }

可能的值

值 | 描述
auto | 浏览器设置的一个下外边距。
length | 定义一个固定的下外边距。默认值是0。
% | 定义基于父对象总高度的百分比下外边距。

TIY 实例

设置文本的下外边距 1
本例演示如何使用厘米值来设置文本的下外边距。
设置文本的下外边距 2
本例演示如何使用百分比值来设置文本的下外边距。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS margin-left 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS margin-left 属性

返回 CSS 参考手册

定义

margin-left 属性设置元素的左外边距。

注释：允许使用负值。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.marginLeft="10px"

在我们的 HTML DOM 教程中，您可以找到更多有关 marginLeft 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

h1
  {
  margin-top: 10px
  }

h2
  {
  margin-top: -20px
  }

可能的值

值 | 描述
auto | 浏览器设置的左外边距。
length | 定义固定的左外边距。默认值是0。
% | 定义基于父对象总高度的百分比左外边距。

TIY 实例

设置文本的左外边距 1
本例演示如何使用厘米值来设置文本的左边距。
设置文本的左外边距 2
本例演示如何使用百分比值来设置文本的左边距。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS margin-right 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS margin-right 属性

返回 CSS 参考手册

定义

margin-right 属性设置元素的外右边距。

注释：允许使用负值。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.marginRight="10px"

在我们的 HTML DOM 教程中，您可以找到更多有关 marginRight 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

h1
  {
  margin-right: 10px
  }

h2
  {
  margin-right: -20px
  }

可能的值

值 | 描述
auto | 浏览器设置的外右边距。
length | 定义固定的外右边距。默认值是 0。
% | 定义基于父对象总高度的百分比外右边距。

TIY 实例

设置文本的外右边距 1
本例演示如何使用厘米值来设置文本的右边距。
设置文本的外右边距 2
本例演示如何使用百分比值来设置文本的右边距。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS margin-top 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS margin-top 属性

返回 CSS 参考手册

定义

margin-top 属性设置元素的上外边距。

注释：允许使用负值。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.marginTop="10px"

在我们的 HTML DOM 教程中，您可以找到更多有关 marginTop 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

h1
  {
  margin-top: 10px
  }

h2
  {
  margin-top: -20px
  }

可能的值

值 | 描述
auto | 浏览器设置的上外边距。
length | 定义固定的上外边距。默认值是 0。
% | 定义基于父对象总高度的百分比上外边距。

TIY 实例

设置文本的上外边距 1
本例演示如何使用厘米值来设置文本的顶边距。
设置文本的上外边距 2
本例演示如何使用百分比值来设置文本的顶边距。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS max-height 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS max-height 属性

返回 CSS 参考手册

定义

max-height 属性设置元素的最大高度。

继承性：No

说明

该属性值会对元素的高度设置一个最高限制。因此，元素可以比指定值矮，但不能比其高。不允许指定负值。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.maxHeight="10px"

在我们的 HTML DOM 教程中，您可以找到更多有关 maxHeight 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  max-height: 100px
  }

可能的值

值 | 描述
none | 默认。定义对元素被允许的最大高度没有限制。
length | 定义元素的最大高度值。
% | 定义基于包含它的块级对象的百分比最大高度。

TIY 实例

设置元素的最大高度
本例演示如何设置一个元素的最大高度。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS max-width 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS max-width 属性

返回 CSS 参考手册

定义

max-width 定义元素的最大宽度。

继承性：No

说明

该属性值会对元素的宽度设置一个最高限制。因此，元素可以比指定值窄，但不能比其宽。不允许指定负值。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.maxWidth="10px"

在我们的 HTML DOM 教程中，您可以找到更多有关 maxWidth 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  max-width: 500px
  }

可能的值

值 | 描述
none | 默认。定义对元素的最大宽度没有限制。
length | 定义元素的最大宽度值。
% | 定义基于包含它的块级对象的百分比最大宽度。

TIY 实例

使用像素值来设置元素的最大宽度
本例演示如何使用像素值来设置元素的最大高度。
使用百分比来设置元素的最大宽度
本例演示如何使用百分比值来设置元素的最大高度。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS min-height 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS min-height 属性

返回 CSS 参考手册

定义

min-height 属性设置元素的最小高度。

继承性：No

说明

该属性值会对元素的高度设置一个最低限制。因此，元素可以比指定值高，但不能比其矮。不允许指定负值。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.minHeight="200px"

在我们的 HTML DOM 教程中，您可以找到更多有关 minHeight 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  min-height: 10px
  }

可能的值

值 | 描述
length | 定义元素的最小高度。默认值是 0。
% | 定义基于包含它的块级对象的百分比最小高度。

TIY 实例

使用像素值来设置元素的最小高度
本例演示如何使用像素值来设置元素的最小高度。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS min-width 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS min-width 属性

返回 CSS 参考手册

定义

min-width 属性设置元素的最小宽度。

继承性：No

说明

该属性值会对元素的宽度设置一个最小限制。因此，元素可以比指定值宽，但不能比其窄。不允许指定负值。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.minWidth="1000px"

在我们的 HTML DOM 教程中，您可以找到更多有关 minWidth 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

h2
  {
  min-width: 50px
  }

可能的值

值 | 描述
length | 定义元素的最小宽度值。默认值：取决于浏览器。
% | 定义基于包含它的块级对象的百分比最小宽度。

TIY 实例

使用像素值来设置元素的最小宽度
本例演示如何使用像素值来设置元素的最小宽度。
使用百分比来设置元素的最小宽度
本例演示如何使用百分比值来设置元素的最小宽度。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS outline 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS outline 属性

返回 CSS 参考手册

定义

outline （轮廓）是绘制于元素周围的一条线，位于边框边缘的外围，可起到突出元素的作用。

outline 属性是一个简写属性，用于设置元素周围的轮廓线。

注释：轮廓线不会占据空间，也不一定是矩形。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.outline="#0000FF dotted thin"

在我们的 HTML DOM 教程中，您可以找到更多有关 outline 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

button
{
outline: red solid thin
}

可能的值

值 描述
  • outline-color
  • outline-style
  • outline-width

在一个声明中设置所有 outline 属性的简写属性。

默认值：invert none medium

TIY 实例

在元素周围画线
本例演示使用 outline 属性在元素周围画一条线。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS outline-color 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS outline-color 属性

返回 CSS 参考手册

定义

outline （轮廓）是绘制于元素周围的一条线，位于边框边缘的外围，可起到突出元素的作用。outline 属性可设置元素周围的轮廓线。

注释：请始终在 outline-color 属性之前声明 outline-style 属性。元素只有获得轮廓以后才能改变其轮廓的颜色。

注释：轮廓线不会占据空间，也不一定是矩形。

继承性：No

说明

outline-color 属性设置一个元素整个轮廓中可见部分的颜色。要记住，轮廓的样式不能是 none，否则轮廓不会出现。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.outlineColor="#00FF00"

在我们的 HTML DOM 教程中，您可以找到更多有关 outlineColor 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

button
{
outline-style: solid;
outline-color: red;
}

可能的值

值 | 描述
invert | 默认。执行颜色反转（逆向的颜色）。这么做是为了使边框在不同的背景颜色中都是可见的。
color | 可以是颜色名 (如 red)，rgb 值(如 rgb(255,0,0)) 或十六进制值 (如 #ff0000)。

TIY 实例

设置轮廓的颜色
本例演示如何设置轮廓的颜色。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS outline-style 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS outline-style 属性

返回 CSS 参考手册

定义

outline-style 属性用于设置一个元素的整个轮廓的样式。样式不能是 none，否则轮廓不会出现。

outline （轮廓）是绘制于元素周围的一条线，位于边框边缘的外围，可起到突出元素的作用。outline 属性设置元素周围的轮廓线。

注释：请始终在 outline-color 属性之前声明 outline-style 属性。元素只有获得轮廓以后才能改变其轮廓的颜色。

注释：轮廓线不会占据空间，也不一定是矩形。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.outlineStyle="dotted"

在我们的 HTML DOM 教程中，您可以找到更多有关 outlineStyle 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

button
  {
  outline-style: solid
  }

可能的值

值 | 描述
none | 默认。定义无轮廓。
dotted | 定义一个点状的轮廓。
dashed | 定义一个虚线轮廓。
solid | 定义一个实线轮廓。
double | 定义一个双线轮廓。双线的宽度等同于 outline-width 的值。
groove | 定义一个 3D 凹槽轮廓。此效果取决于 outline-color 值。
ridge | 定义一个 3D 凸槽轮廓。此效果取决于 outline-color 值。
inset | 定义一个 3D 凹边轮廓。此效果取决于 outline-color 值。
outset | 定义一个 3D 凸边轮廓。此效果取决于 outline-color 值。

TIY 实例

设置轮廓的样式
本例演示如何设置轮廓的样式。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS outline-width 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS outline-width 属性

返回 CSS 参考手册

定义

outline-width 属性设置元素整个轮廓的宽度，只有当轮廓样式不是 none 时，这个宽度才会起作用。如果样式为 none，宽度实际上会重置为 0。不允许设置负长度值。

outline（轮廓）是绘制于元素周围的一条线，位于边框边缘的外围，可起到突出元素的作用。outline 属性设置元素周围的轮廓线。

注释：请始终在 outline-width 属性之前声明 outline-style 属性。元素只有获得轮廓以后才能改变其轮廓的颜色。

注释：轮廓线不会占据空间，也不一定是矩形。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.outlineWidth="thin"

在我们的 HTML DOM 教程中，您可以找到更多有关 outlineWidth 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  outline-style: solid;
  outline-width: medium
  }

可能的值

值 | 描述
thin | 定义细轮廓。
medium | 默认。定义中等的轮廓。
thick | 定义粗的轮廓。
length | 允许您定义轮廓粗细的值。

TIY 实例

设置轮廓的宽度
本例演示如何设置轮廓的宽度。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS overflow 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS overflow 属性

返回 CSS 参考手册

定义

overflow 属性设置当元素的内容溢出其区域时发生的事情。

继承性：No

说明

这个属性定义溢出元素内容区的内容会如何处理。如果值为 scroll，不论是否需要，用户代理都会提供一种滚动机制。因此，有可能即使元素框中可以放下所有内容也会出现滚动条。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.overflow="hidden"

在我们的 HTML DOM 教程中，您可以找到更多有关 overflow 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  overflow: scroll
  }

可能的值

值 | 描述
visible | 默认。内容不会被修剪，会呈现在元素之外。
hidden | 内容会被修剪，但是浏览器不会显示供查看内容的滚动条。
scroll | 内容会被修剪，但是浏览器会显示滚动条以便查看其余的内容。
auto | 如果内容被修剪，则浏览器会显示滚动条以便查看其余的内容。

TIY 实例

如何使用滚动条来显示元素内溢出的内容
本例演示当元素内容太大而超出规定区域时，如何设置溢出属性来规定相应的动作。
如何隐藏溢出元素中溢出的内容
本例演示在元素中的内容太大以至于无法适应指定的区域时，如何设置 overflow 属性来隐藏其内容。
如何设置浏览器来自动地处理溢出
本例演示如何设置浏览器来自动地处理溢出。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS padding 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS padding 属性

返回 CSS 参考手册

定义

padding 属性是用于在一个声明中设置所有 padding 属性的简写属性。

注释：不允许使用负值。

继承性：No

说明

这个简写属性设置元素所有内边距的宽度，或者设置各边上内边距的宽度。行内非替换元素上设置的内边距不会影响行高计算；因此，如果一个元素既有内边距又有背景，从视觉上看可能会延伸到其他行，有可能还会与其他内容重叠。元素的背景会延伸穿过内边距。不允许指定负边距值。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.padding="2cm"

在我们的 HTML DOM 教程中，您可以找到更多有关 padding 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

四个边的 padding 均为 10px：

h1 {padding: 10px}

上边和下边的 padding 为 10px，左边和右边的 padding 是父元素宽度的 2%：

h1 {padding: 10px 2%}

上边的 padding 为 10px，左边和右边的 padding 是父元素宽度的 2%，下边的 padding 是 15px：

h1 {padding: 10px 2% 15px}

上边的 padding 为 10px，右边的 padding 是父元素宽度的 2%，下边的 padding 是 15px，而左边的 padding 是 20px：

h1 {padding: 10px 2% 15px 20px}

可能的值

值 描述
  • padding-top
  • padding-right
  • padding-bottom
  • padding-left

设置内边距。

值可以是：

  • 百分比（基于父元素宽度的百分比）
  • 长度值（固定的padding值）

默认值：未定义。

TIY 实例

所有填充属性在一个声明中
本例演示使用简写属性将所有的填充属性设置于一个声明中，可以有一到四个值。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS padding-bottom 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS padding-bottom 属性

返回 CSS 参考手册

定义

padding-bottom 属性设置元素下内边距（底部空白）。

注释：不允许使用负值。

继承性：No

说明

该属性设置元素下内边距的宽度。行内非替换元素上设置的下内边距不会影响行高计算，因此，如果一个元素既有内边距又有背景，从视觉上看可能延伸到其他行，有可能还会与其他内容重叠。不允许指定负内边距值。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.paddingBottom="2cm"

在我们的 HTML DOM 教程中，您可以找到更多有关 paddingBottom 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

h1
  {
  padding-bottom: 10px
  }

可能的值

值 | 描述
length | 定义固定的下内边距值。默认值是 0。
% | 定义基于父元素高度的百分比下内边距。此值不会如预期的那样工作于所有的浏览器中。

TIY 实例

设置下内边距 1
本例演示如何使用厘米值来设置单元格的下内边距。
设置下内边距 2
本例演示如何使用百分比值来设置单元格的下内边距。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS padding-left 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS padding-left 属性

返回 CSS 参考手册

定义

padding-left 属性设置元素左内边距（空白）。

注释：不允许使用负值。

继承性：No

说明

该属性设置元素左内边距的宽度。行内非替换元素上设置的左内边距仅在元素所生成的第一个行内框的左边出现.

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.paddingLeft="2cm"

在我们的 HTML DOM 教程中，您可以找到更多有关 paddingLeft 属性 的细节。

在我们的HTML DOM教程中，您也可以找到完整的 Style 对象参考手册。

例子

h1
  {
  padding-left: 10px
  }

可能的值

值 | 描述
length | 定义固定的左内边距值。默认值是 0。
% | 定义基于父元素高度的百分比左内边距。此值不会如预期的那样工作于所有的浏览器中。

TIY 实例

设置左内边距 1
本例演示如何使用厘米值来设置单元格的左内边距。
设置左内边距 2
本例演示如何使用百分比值来设置单元格的左内边距。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS padding-right 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS padding-right 属性

返回 CSS 参考手册

定义

padding-left 属性设置元素右内边距（空白）。

注释：不允许使用负值。

继承性：No

说明

该属性设置元素右内边距的宽度。行内非替换元素上设置的右内边距仅在元素所生成的第一个行内框的右边出现.

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.paddingRight="2cm"

在我们的 HTML DOM 教程中，您可以找到更多有关 paddingRight 属性 的细节。

在我们的HTML DOM教程中，您也可以找到完整的 Style 对象参考手册。

例子

h1
  {
  padding-right: 10px
  }

可能的值

值 | 描述
length | 定义固定的右内边距值。默认值是 0。
% | 定义基于父元素高度的百分比右内边距。此值不会如预期的那样工作于所有的浏览器中。

TIY 实例

设置右内边距 1
本例演示如何使用厘米值来设置单元格的右内边距。
设置右内边距 2
本例演示如何使用百分比值来设置单元格的右内边距。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS padding-top 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS padding-top 属性

返回 CSS 参考手册

定义

padding-top 属性设置元素的上内边距（空间）。

注释：不允许使用负值。

继承性：No

说明

该属性设置元素上内边距的宽度。行内非替换元素上设置的上内边距不会影响行高计算，因此，如果一个元素既有内边距又有背景，从视觉上看可能延伸到其他行，有可能还会与其他内容重叠。不允许指定负内边距值。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.paddingTop="2cm"

在我们的 HTML DOM 教程中，您可以找到更多有关 paddingTop 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

h1
  {
  padding-top: 10px
  }

可能的值

值 | 描述
length | 定义固定的上内边距值。默认值是 0。
% | 定义基于父元素高度的百分比上内边距。此值不会如预期的那样工作于所有的浏览器中。

TIY 实例

设置上内边距 1
本例演示如何使用厘米值来设置单元格的上内边距。
设置上内边距 2
本例演示如何使用百分比值来设置单元格的上内边距。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS page-break-after 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS page-break-after 属性

返回 CSS 参考手册

定义

page-break-after 属性设置元素后否应当放置分页符。

尽管可以用 always 强制放上分页符，但是无法保证避免分页符的插入，创作人员最多只能要求用户代理尽可能避免插入分页。

应用于：position 值为 relative 或 static 的非浮动块级元素。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.pageBreakAfter="always"

在我们的 HTML DOM 教程中，您可以找到更多有关 pageBreakAfter 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

table
{
page-break-after: always;
}

可能的值

值 | 描述
auto | 默认。如果必要则在元素后插入分页符。
always | 在元素后插入分页符。
avoid | 避免在元素后插入分页符。
left | 在元素之后足够的分页符，一直到一张空白的左页为止。
right | 在元素之后足够的分页符，一直到一张空白的右页为止。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS page-break-before 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS page-break-before 属性

返回 CSS 参考手册

定义

page-break-before 属性声明一个元素前是否应当放置分页符。

尽管可以用 always 强制放上分页符，但是无法保证避免分页符的插入，创作人员最多只能要求用户代理尽可能避免插入分页。

应用于：position 值为 relative 或 static 的非浮动块级元素。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.pageBreakBefore="always"

在我们的 HTML DOM 教程中，您可以找到更多有关 pageBreakBefore 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

table
{
page-break-before: always;
}

可能的值

值 | 描述
auto | 默认。如果必要则在元素前插入分页符。
always | 在元素前插入分页符。
avoid | 避免在元素前插入分页符。
left | 在元素之前足够的分页符，一直到一张空白的左页为止。
right | 在元素之前足够的分页符，一直到一张空白的右页为止。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS page-break-inside 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS page-break-inside 属性

返回 CSS 参考手册

定义

page-break-inside 属性声明一个元素内部是否应当放置分页符。

由于元素可能比页框高，所以无法保证避免分页符的插入；创作人员最多只能要求用户代理尽可能避免插入分页。

应用于：position 值为 relative 或 static 的非浮动块级元素。

继承性：No

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.pageBreakInside="avoid"

在我们的 HTML DOM 教程中，您可以找到更多有关 pageBreakInside 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

table
{
page-break-inside: avoid;
}

可能的值

值 | 描述
auto | 默认。如果必要则在元素内部插入分页符。
avoid | 避免在元素内部插入分页符。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS position 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS position 属性

返回 CSS 参考手册

定义

position 属性把元素放置到一个静态的、相对的、绝对的、或固定的位置中。

继承性：No

说明

这个属性定义建立元素布局所用的定位机制。任何元素都可以定位，不过绝对或固定元素会生成一个块级框，而不论该元素本身是什么类型。相对定位元素会相对于它在正常流中的默认位置偏移。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.position="absolute"

在我们的 HTML DOM 教程中，您可以找到更多有关 position 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

h1
  {
  position: absolute;
  left: 100px;
  top: 150px;
  }

可能的值

值 | 描述
static | 默认。位置设置为 static 的元素，它始终会处于页面流给予的位置（static 元素会忽略任何 top、bottom、left 或 right 声明）。
relative | 位置被设置为 relative 的元素，可将其移至相对于其正常位置的地方，因此 "left:20" 会将元素移至元素正常位置左边 20 个像素的位置。
absolute | 位置设置为 absolute 的元素，可定位于相对于包含它的元素的指定坐标。此元素的位置可通过 "left"、"top"、"right" 以及"bottom" 属性来规定。
fixed | 位置被设置为 fixed 的元素，可定位于相对于浏览器窗口的指定坐标。此元素的位置可通过 "left"、"top"、"right" 以及"bottom" 属性来规定。不论窗口滚动与否，元素都会留在那个位置。工作于 IE7（strict 模式）。

TIY 实例

定位：相对定位
本例演示如何相对于一个元素的正常位置来对其定位。
定位：绝对定位
本例演示如何使用绝对值来对元素进行定位。
定位：固定定位
本例演示如何相对于浏览器窗口来对元素进行定位。
设置元素的形状
本例演示如何设置元素的形状。此元素被剪裁到这个形状内，并显示出来。
Z-index
Z-index可被用于将在一个元素放置于另一元素之后。
Z-index
上面的例子中的元素已经更改了Z-index。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS quotes 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS quotes 属性

返回 CSS 参考手册

定义

quotes 属性设置嵌入引用的引号类型。

继承性：Yes

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.quotes="none"

在我们的 HTML DOM 教程中，您可以找到更多有关 quotes 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

例子 1

q:lang(en)
{
quotes: '"' '"' "'" "'"
}

HTML 代码：

<html lang="en">
<head>
</head>
<body>
<p><q>This is a <q>big</q> quote</q></p>
</body>
</html>

输出：

"This is a 'big' quote"

可能的值

值 | 描述
none | 规定 "content" 属性的 "open-quote" 和 "close-quote" 的值不会产生任何引号。
string string string string | 定义要使用的引号。前两个值规定第一级引用嵌套，后两个值规定下一级引号嵌套。

引号字符

Quotation Mark Characters

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS right 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS right 属性

返回 CSS 参考手册

定义

right 属性规定元素的右边缘。

这个元素定义了定位元素右外边距边界与其包含块右边界之间的偏移。

注释：如果 "position" 属性的值为 "static"，那么设置 "right" 属性不会产生任何效果。

继承性：No

说明

对于 static 元素，为 auto；对于长度值，则为相应的绝对长度；对于百分比数值，为指定值；否则为 auto。

对于相对定义元素，left 的计算值始终等于 right。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.right="100px"

在我们的 HTML DOM 教程中，您可以找到更多有关 right 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

本例可把段落的右边缘设置到距离窗口右边缘的左侧 20 像素：

p
  {
  position: absolute;
  right: 20px
  }

本例可把段落的右边缘设置到距离窗口右边缘的右侧 20 像素：

p
  {
  position: absolute;
  right: -20px
  }

可能的值

值 | 描述
auto | 默认。通过浏览器来计算右侧的位置。
% | 设置元素的右边到最近一个具有定位设置父元素的右边缘的百分比位置。
length | 使用 px、cm 等单位设置元素的右边到最近一个具有定位设置父元素的右边缘的位置。可使用负值。

TIY 实例

使用固定值设置图像的右边缘
本例演示如何使用固定值设置图像的右边缘。
使用百分比设置图像的右边缘
本例演示如何使用百分比值设置图像的右边缘。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS table-layout 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS table-layout 属性

返回 CSS 参考手册

定义

tableLayout 属性用来显示表格单元格、行、列的算法规则。

固定表格布局：

固定表格布局与自动表格布局相比，允许浏览器更快地对表格进行布局。

在固定表格布局中，水平布局仅取决于表格宽度、列宽度、表格边框宽度、单元格间距，而与单元格的内容无关。

通过使用固定表格布局，用户代理在接收到第一行后就可以显示表格。

自动表格布局：

在自动表格布局中，列的宽度是由列单元格中没有折行的最宽的内容设定的。

此算法有时会较慢，这是由于它需要在确定最终的布局之前访问表格中所有的内容。

继承性：Yes

说明

该属性指定了完成表布局时所用的布局算法。固定布局算法比较快，但是不太灵活，而自动算法比较慢，不过更能反映传统的 HTML 表。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.tableLayout="fixed"

在我们的 HTML DOM 教程中，您可以找到更多有关 tableLayout 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

table
      {
        table-layout : fixed;
      }

可能的值

值 | 描述
automatic | 默认。列宽度由单元格内容设定。
fixed | 列宽由表格宽度和列宽度设定。

TIY 实例

设置表格的布局
本例演示如何设置表格的布局。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS text-align 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS text-align 属性

返回 CSS 参考手册

定义

text-align 属性对齐元素中的文本。

该属性通过指定行框与哪个点对其，从而设置块级元素内文本的水平对齐方式。通过允许用户代理调整行内容中字母和字之间的间隔，可以支持值 justify；不同用户代理可能会得到不同的结果。

继承性：Yes

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.textAlign="right"

在我们的 HTML DOM 教程中，您可以找到更多有关 textAlign 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  text-align: center
  }

可能的值

值 | 描述
left | 把文本排列到左边。默认值：由浏览器决定。
right | 把文本排列到右边。
center | 把文本排列到中间。
justify |

TIY 实例

对齐文本
本例演示如何对齐文本。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS text-decoration 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS text-decoration 属性

返回 CSS 参考手册

定义

text-decoration 属性对文本进行修饰。

注释：修饰的颜色由 "color" 属性设置。

继承性：No

说明

这个属性允许对文本设置某种效果，如加下划线。如果后代元素没有自己的装饰，祖先元素上设置的装饰会“延伸”到后代元素中。不要求用户代理支持 blink。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.textDecoration="overline"

在我们的 HTML DOM 教程中，您可以找到更多有关 textDecoration 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  text-decoration: underline
  }

可能的值

值 | 描述
none | 默认。定义标准的文本。
underline | 定义文本下的一条线。
overline | 定义文本上的一条线。
line-through | 定义穿过文本下的一条线。
blink | 定义闪烁的文本（无法运行在 IE 和 Opera 中）。

TIY 实例

修饰文本
本例演示如何向文本添加修饰。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS text-indent 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS text-indent 属性

返回 CSS 参考手册

定义

text-indent 属性缩进元素中的首行文本。

注释：允许使用负值。如果使用负值，那么首行会被缩进到左边。

继承性：Yes

说明

用于定义块级元素中第一个内容行的缩进。这最常用于建立一个“标签页”效果。允许指定负值，这会产生一种“悬挂缩进”的效果。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.textIndent="50px"

在我们的 HTML DOM 教程中，您可以找到更多有关 textIndent 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  text-indent: 20px
  }

p
  {
  text-indent: -12px
  }

可能的值

值 | 描述
length | 定义固定的缩进。默认值：0。
% | 定义基于父元素宽度的百分比的缩进。

TIY 实例

缩进文本
本例演示如何缩进文本首行。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS text-transform 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS text-transform 属性

返回 CSS 参考手册

定义

text-transform 对元素中的字母进行控制。

继承性：Yes

说明

这个属性会改变元素中的字母大小写，而不论源文档中文本的大小写。如果值为 capitalize，则要对某些字母大写，但是并没有明确定义如何确定哪些字母要大写，这取决于用户代理如何识别出各个“词”。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.textTransform="capitalize"

在我们的 HTML DOM 教程中，您可以找到更多有关 textTransform 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  text-transform: uppercase
  }

可能的值

值 | 描述
none | 默认。定义带有小写字母和大写字母的标准的文本。
capitalize | 文本中的每个单词以大写字母开头。
uppercase | 定义仅有大写字母。
lowercase | 定义无大写字母，仅有小写字母。

TIY 实例

控制文本中的字母
本例演示如何控制文本中的字母。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS top 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS top 属性

返回 CSS 参考手册

定义

top 属性规定元素的顶部边缘。

这个属性定义了一个定位元素的上外边距边界与其包含块上边界之间的偏移。

注释：如果 "position" 属性的值为 "static"，那么设置 "top" 属性不会产生任何效果。

继承性：No

说明

对于 static 元素，为 auto；对于长度值，则为相应的绝对长度；对于百分比数值，为指定值；否则为 auto。

对于相对定义元素，如果 top 和 bottom 都是 auto，其计算值则都是 0；如果其中之一为 auto，则取另一个值的相反数；如果二者都不是 auto，bottom 将取 top 值的相反数。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.top="100px"

在我们的 HTML DOM 教程中，您可以找到更多有关 top 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

本例可把段落的顶部边缘设置到距离窗口顶部边缘的下方 20 像素：

p
  {
  position: absolute;
  top: 20px
  }

本例可把段落的顶部边缘设置到距离窗口顶部边缘的上方 20 像素：

p
  {
  position: absolute;
  top: -20px
  }

可能的值

值 | 描述
auto | 默认。通过浏览器来计算顶部的位置。
% | 设置元素的顶部到最近一个具有定位设置父元素的上边缘的百分比位置。
length | 使用 px、cm 等单位设置元素的顶部到最近一个具有定位设置上边缘的顶部的位置。可使用负值。

TIY 实例

使用固定值设置图像的上边缘
本例演示如何使用固定值设置图像的上边缘。
使用百分比设置图像的上边缘
本例演示如何使用百分比值设置图像的上边缘。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS vertical-align 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS vertical-align 属性

返回 CSS 参考手册

定义

vertical-align 属性设置元素的垂直排列。

继承性：No

说明

该属性定义行内元素的基线相对于该元素所在行的基线的垂直对齐。允许指定负长度值和百分比值。这会使元素降低而不是升高。在表单元格中，这个属性会设置单元格框中的单元格内容的对齐方式。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.verticalAlign="bottom"

在我们的 HTML DOM 教程中，您可以找到更多有关 verticalAlign属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

img
  {
  vertical-align: bottom
  }

可能的值

值 | 描述
baseline | 默认。元素放置在父元素的基线上。
sub | 垂直对齐文本的下标。
super | 垂直对齐文本的上标
top | 把元素的顶端与行中最高元素的顶端对齐
text-top | 把元素的顶端与父元素字体的顶端对齐
middle | 把此元素放置在父元素的中部。
bottom | 把元素的顶端与行中最低的元素的顶端对齐。
text-bottom | 把元素的底端与父元素字体的底端对齐。
length |
% | 使用 "line-height" 属性的百分比值来排列此元素。允许使用负值。

TIY 实例

垂直排列图象
本例演示如何在文本中垂直排列图象。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS visibility 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS visibility 属性

返回 CSS 参考手册

定义

visibility 属性设置元素是否可见或不可见。

提示：即使不可见的元素也会占据页面上的空间。请使用 "display" 属性来创建不占据页面空间的不可见元素。

继承性：No

说明

这个属性指定是否显示一个元素生成的元素框。这意味着元素仍占据其本来的空间，不过可以完全不可见。值 collapse 在表中用于从表布局中删除列或行。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.visibility="hidden"

在我们的 HTML DOM 教程中，您可以找到更多有关 visibility 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  visibility: hidden
  }

可能的值

值 | 描述
visible | 元素是可见的。
hidden | 元素是不可见的。
collapse | 当在表格元素中使用时，此值可删除一行或一列，但是它不会影响表格的布局。被行或列占据的空间会留给其他内容使用。如果此值被用在其他的元素上，会呈现为 "hidden"。

TIY 实例

如何使元素不可见
本例演示如何使元素不可见。你希望元素被显示出来，还是不呢？
把表格元素设置为 collapse（请在非 IE 的浏览器中查看）
本例演示如何使表格元素叠加？

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS white-space 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS white-space 属性

返回 CSS 参考手册

定义

white-space 属性设置如何处理元素内的空白。

这个属性声明建立布局过程中如何处理元素中的空白符。值 pre-wrap 和 pre-line 是 CSS 2.1 中新增的。

继承性：Yes

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.whiteSpace="nowrap"

在我们的 HTML DOM 教程中，您可以找到更多有关 whiteSpace 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  white-space: normal
  }

可能的值

值 | 描述
normal | 默认。空白会被浏览器忽略。
pre | 空白会被浏览器保留。其行为方式类似 HTML 中的 <pre> 标签。
nowrap | 文本不会换行，文本会在在同一行上继续，直到遇到 <br> 标签为止。

TIY 实例

在元素中禁止文本折行
本例演示如何禁止在元素中的文本折行。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS width 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS width 属性

返回 CSS 参考手册

定义

width 属性设置一个元素的宽度。

继承性：No

说明

这个属性定义元素内容区的宽度，在内容区外面可以增加内边距、边框和外边距。

行内非替换元素会忽略这个属性。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.width="300px"

在我们的 HTML DOM 教程中，您可以找到更多有关 width 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

img
  {
  width: 100%
  }

可能的值

值 | 描述
auto | 默认。浏览器可计算出实际的宽度。
% | 定义基于父元素宽度的百分比宽度。
length | 使用 px、cm 等单位定义宽度。

TIY 实例

使用像素值来设置元素的宽度
本例演示如何使用像素值来设置元素的宽度。
使用百分比来设置元素的宽度
本例演示如何使用百分比值来设置元素的宽度。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS word-spacing 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS word-spacing 属性

返回 CSS 参考手册

定义

word-spacing 属性增加或减少单词间的空白。

该属性定义元素中字之间插入多少空白符。针对这个属性，“字” 定义为由空白符包围的一个字符串。如果指定为长度值，会调整字之间的通常间隔；所以，normal 就等同于设置为 0。允许指定负长度值，这会让字之间挤得更紧。

注释：允许使用负值。

继承性：Yes

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.wordSpacing="10px"

在我们的 HTML DOM 教程中，您可以找到更多有关 wordSpacing 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

p
  {
  word-spacing: 30px
  }

p
  {
  word-spacing -0.5px
  }

可能的值

值 | 描述
normal | 默认。定义单词间的标准空间。
length | 定义单词间的固定空间。

TIY 实例

增加单词间距
本例演示如何增加段落中单词间的距离。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS z-index 属性

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS z-index 属性

返回 CSS 参考手册

定义

z-index 属性设置元素的堆叠顺序。拥有更高堆叠顺序的元素总是会处于堆叠顺序较低的元素的前面。

注释：元素可拥有负的 z-index 属性值。

注释：Z-index 仅能在定位元素上奏效（例如 position:absolute;）！

继承性：No

说明

该属性设置一个定位元素沿 z 轴的位置，z 轴定义为垂直延伸到显示区的轴。如果为正数，则离用户更近，为负数则表示离用户更远。

JavaScript 语法

CSS 属性也可通过一段 JavaScript 被动态地改变。

脚本语法：

object.style.zIndex="1"

在我们的 HTML DOM 教程中，您可以找到更多有关 zIndex 属性 的细节。

在我们的 HTML DOM 教程中，您也可以找到完整的 Style 对象参考手册。

例子

img
  {
  z-index: -1
  }

可能的值

值 | 描述
auto | 默认。堆叠顺序与父元素相等。
number | 设置元素的堆叠顺序。

TIY 实例

Z-index
Z-index 可用于将在一个元素放置于另一元素之后。
Z-index
上例中的元素已经更改了 Z-index。

返回 CSS 参考手册

CSS 参考手册
CSS 实例
CSS 测验


CSS 背景

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 背景

  • Previous Page
  • Next Page

CSS 允许应用纯色作为背景，也允许使用背景图像创建相当复杂的效果。

CSS 在这方面的能力远远在 HTML 之上。

背景色

可以使用 background-color 属性为元素设置背景色。这个属性接受任何合法的颜色值。

这条规则把元素的背景设置为灰色：

p {background-color: gray;}

如果您希望背景色从元素中的文本向外少有延伸，只需增加一些内边距：

p {background-color: gray; padding: 20px;}

如需查看本例的效果，可以亲自试一试！

可以为所有元素设置背景色，这包括 body 一直到 em 和 a 等行内元素。

background-color 不能继承，其默认值是 transparent。transparent 有“透明”之意。也就是说，如果一个元素没有指定背景色，那么背景就是透明的，这样其祖先元素的背景才能可见。

背景图像

要把图像放入背景，需要使用 background-image 属性。background-image 属性的默认值是 none，表示背景上没有放置任何图像。

如果需要设置一个背景图像，必须为这个属性设置一个 URL 值：

body {background-image: url(/i/eg_bg_04.gif);}

大多数背景都应用到 body 元素，不过并不仅限于此。

下面例子为一个段落应用了一个背景，而不会对文档的其他部分应用背景：

p.flower {background-image: url(/i/eg_bg_03.gif);}

您甚至可以为行内元素设置背景图像，下面的例子为一个链接设置了背景图像：

a.radio {background-image: url(/i/eg_bg_07.gif);}

如需查看上述例子的效果，可以亲自试一试！

理论上讲，甚至可以向 textareas 和 select 等替换元素的背景应用图像，不过并不是所有用户代理都能很好地处理这种情况。

另外还要补充一点，background-image 也不能继承。事实上，所有背景属性都不能继承。

背景重复

如果需要在页面上对背景图像进行平铺，可以使用 background-repeat 属性。

属性值 repeat 导致图像在水平垂直方向上都平铺，就像以往背景图像的通常做法一样。repeat-x 和 repeat-y 分别导致图像只在水平或垂直方向上重复，no-repeat 则不允许图像在任何方向上平铺。

默认地，背景图像将从一个元素的左上角开始。请看下面的例子：

body
  {
  background-image: url(/i/eg_bg_03.gif);
  background-repeat: repeat-y;
  }

如需查看上例的效果，可以亲自试一试。

背景定位

可以利用 background-position 属性改变图像在背景中的位置。

下面的例子在 body 元素中将一个背景图像居中放置：

body
  {
    background-image:url('/i/eg_bg_03.gif');
    background-repeat:no-repeat;
    background-position:center;
  }

为 background-position 属性提供值有很多方法。首先，可以使用一些关键字：top、bottom、left、right 和 center。通常，这些关键字会成对出现，不过也不总是这样。还可以使用长度值，如 100px 或 5cm，最后也可以使用百分数值。不同类型的值对于背景图像的放置稍有差异。

关键字

图像放置关键字最容易理解，其作用如其名称所表明的。例如，top right 使图像放置在元素内边距区的右上角。

根据规范，位置关键字可以按任何顺序出现，只要保证不超过两个关键字 - 一个对应水平方向，另一个对象垂直方向。

如果只出现一个关键字，则认为另一个关键字是 center。

所以，如果希望每个段落的中部上方出现一个图像，只需声明如下：

p
  {
    background-image:url('bgimg.gif');
    background-repeat:no-repeat;
    background-position:top;
  }

下面是等价的位置关键字：

单一关键字 | 等价的关键字
center | center center
top | top center 或 center top
bottom | bottom center 或 center bottom
right | right center 或 center right
left | left center 或 center left

百分数值

百分数值的表现方式更为复杂。假设你希望用百分数值将图像在其元素中居中，这很容易：

body
  {
    background-image:url('/i/eg_bg_03.gif');
    background-repeat:no-repeat;
    background-position:50% 50%;
  }

这会导致图像适当放置，其中心与其元素的中心对齐。换句话说，百分数值同时应用于元素和图像。也就是说，图像中描述为 50% 50% 的点（中心点）与元素中描述为 50% 50% 的点（中心点）对齐。

如果图像位于 0% 0%，其左上角将放在元素内边距区的左上角。如果图像位置是 100% 100%，会使图像的右下角放在右边距的右下角。

因此，如果你想把一个图像放在水平方向 2/3、垂直方向 1/3 处，可以这样声明：

body
  {
    background-image:url('/i/eg_bg_03.gif');
    background-repeat:no-repeat;
    background-position:66% 33%;
  }

如果只提供一个百分数值，所提供的这个值将用作水平值，垂直值将假设为 50%。这一点与关键字类似。

background-position 的默认值是 0% 0%，在功能上相当于 top left。这就解释了背景图像为什么总是从元素内边距区的左上角开始平铺，除非您设置了不同的位置值。

长度值

长度值解释的是元素内边距区左上角的偏移。偏移点是图像的左上角。

比如，如果设置值为 50px 100px，图像的左上角将在元素内边距区左上角向右 50 像素、向下 100 像素的位置上：

body
  {
    background-image:url('/i/eg_bg_03.gif');
    background-repeat:no-repeat;
    background-position:50px 100px;
  }

注意，这一点与百分数值不同，因为偏移只是从一个左上角到另一个左上角。也就是说，图像的左上角与 background-position 声明中的指定的点对齐。

背景关联

如果文档比较长，那么当文档向下滚动时，背景图像也会随之滚动。当文档滚动到超过图像的位置时，图像就会消失。

您可以通过 background-attachment 属性防止这种滚动。通过这个属性，可以声明图像相对于可视区是固定的（fixed），因此不会受到滚动的影响：

body
  {
  background-image:url(/i/eg_bg_02.gif);
  background-repeat:no-repeat;
  background-attachment:fixed
  }

如需查看上例的效果，可以亲自试一试。

background-attachment 属性的默认值是 scroll，也就是说，在默认的情况下，背景会随文档滚动。

CSS 背景实例

设置背景颜色
本例演示如何为元素设置背景颜色。
设置文本的背景颜色
本例颜色如何设置部分文本的背景颜色。
将图像设置为背景
本例演示如何将图像设置为背景。
将图像设置为背景 2
本例演示如何为多个元素同时设置背景图像。
如何重复背景图像
本例演示如何重复背景图像。
如何在垂直方向重复背景图像
本例演示如何垂直地重复背景图像。
如何在水平方向重复背景图像
本例演示如何水平地重复背景图像。
如何仅显示一次背景图像
本例演示如何仅显示一次背景图像。
如何放置背景图像
本例演示如何在页面上放置背景图像。
如何使用%来定位背景图像
本例演示如何使用百分比来在页面上定位背景图像。
如何使用像素来定位背景图像
本例演示如何使用像素来在页面上定位背景图像。
如何设置固定的背景图像
本例演示如何设置固定的背景图像。图像不会随着页面的其他部分滚动。
所有背景属性在一个声明之中
本例演示如何使用简写属性来将所有背景属性设置在一个声明之中。

CSS 背景属性

属性 | 描述
background | 简写属性，作用是将背景属性设置在一个声明中。
background-attachment | 背景图像是否固定或者随着页面的其余部分滚动。
background-color | 设置元素的背景颜色。
background-image | 把图像设置为背景。
background-position | 设置背景图像的起始位置。
background-repeat | 设置背景图像是否及如何重复。
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 边框

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 边框

  • Previous Page
  • Next Page

元素的边框 (border) 是围绕元素内容和内边距的一条或多条线。

CSS border 属性允许你规定元素边框的样式、宽度和颜色。

CSS 边框

在 HTML 中，我们使用表格来创建文本周围的边框，但是通过使用 CSS 边框属性，我们可以创建出效果出色的边框，并且可以应用于任何元素。

元素外边距内就是元素的的边框 (border)。元素的边框就是围绕元素内容和内边据的一条或多条线。

每个边框有 3 个方面：宽度、样式，以及颜色。在下面的篇幅，我们会为您详细讲解这三个方面。

边框与背景

CSS 规范指出，边框绘制在“元素的背景之上”。这很重要，因为有些边框是“间断的”（例如，点线边框或虚线框），元素的背景应当出现在边框的可见部分之间。

CSS2 指出背景只延伸到内边距，而不是边框。后来 CSS2.1 进行了更正：元素的背景是内容、内边距和边框区的背景。大多数浏览器都遵循 CSS2.1 定义，不过一些较老的浏览器可能会有不同的表现。

边框的样式

样式是边框最重要的一个方面，这不是因为样式控制着边框的显示（当然，样式确实控制着边框的显示），而是因为如果没有样式，将根本没有边框。

CSS 的 border-style 属性定义了 10 个不同的非 inherit 样式，包括 none。

例如，您可以为把一幅图片的边框定义为 outset，使之看上去像是“凸起按钮”：

a:link img {border-style: outset;}

定义多种样式

您可以为一个边框定义多个样式，例如：

p.aside {border-style: solid dotted dashed double;}

上面这条规则为类名为 aside 的段落定义了四种边框样式：实线上边框、点线有边框、虚线下边框和一个双线左边框。

我们又看到了这里的值采用了 top-right-bottom-left 的顺序，讨论用多个值设置不同内边距时也见过这个顺序。

定义单边样式

如果您希望为元素框的某一个边设置边框样式，而不是设置所有 4 个边的边框样式，可以使用下面的单边边框样式属性：

  • border-top-style
  • border-right-style
  • border-bottom-style
  • border-left-style

因此这两种方法是等价的：

p {border-style: solid solid solid none;}
p {border-style: solid; border-left-style: none;}

注意：如果要使用第二种方法，必须把单边属性放在简写属性之后。因为如果把单边属性放在 border-style 之前，简写属性的值就会覆盖单边值 none。

边框的宽度

您可以通过 border-width 属性为边框指定宽度。

为边框指定宽度有两种方法：可以指定长度值，比如 2px 或 0.1em；或者使用 3 个关键字之一，它们分别是 thin 、medium（默认值） 和 thick。

注释：CSS 没有定义 3 个关键字的具体宽度，所以一个用户代理可能把 thin 、medium 和 thick 分别设置为等于 5px、3px 和 2px，而另一个用户代理则分别设置为 3px、2px 和 1px。

所以，我们可以这样设置边框的宽度：

p {border-style: solid; border-width: 5px;}

或者：

p {border-style: solid; border-width: thick;}

定义单边宽度

您可以按照 top-right-bottom-left 的顺序设置元素的各边边框：

p {border-style: solid; border-width: 15px 5px 15px 5px;}

上面的例子也可以简写为（这样写法称为值复制）：

p {border-style: solid; border-width: 15px 5px;}

您也可以通过下列属性分别设置边框各边的宽度：

  • border-top-width
  • border-right-width
  • border-bottom-width
  • border-left-width

因此，下面的规则与上面的例子是等价的：

p {
  border-style: solid;
  border-top-width: 15px;
  border-right-width: 5px;
  border-bottom-width: 15px;
  border-left-width: 5px;
  }

没有边框

在前面的例子中，您已经看到，如果希望显示某种边框，就必须设置边框样式，比如 solid 或 outset。

那么如果把 border-style 设置为 none 会出现什么情况：

p {border-style: none; border-width: 50px;}

尽管边框的宽度是 50px，但是边框样式设置为 none。再这种情况下，不仅边框的样式没有了，其宽度也会变成 0。边框消失了，为什么呢？

这是因为如果边框宽度为 0，即边框根本不存在，那么边框就不可能有宽度，因此边框宽度自动设置为 0，而不论您原先定义的是什么？

记住这一点非常重要。事实上，忘记声明边框样式是一个常犯的错误。根据以下规则，所有 h1 元素都不会有任何边框，更不用说 20 像素宽了：

h1 {border-width: 20px;}

由于 border-style 的默认值是 none，如果没有声明样式，就相当于 border-style: none。因此，如果您希望边框出现，就必须声明一个边框样式。

边框的颜色

设置边框颜色非常简单。CSS 使用一个简单的 border-color 属性，它一次可以接受最多 4 个颜色值。

可以使用任何类型的颜色值，例如可以是命名颜色，也可以是十六进制和 RGB 值：

p {
  border-style: solid;
  border-color: blue rgb(25%,35%,45%) #909090 red;
  }

如果颜色值小于 4 个，值复制就会起作用。例如下面的规则声明了段落的上下边框是蓝色，左右边框是红色：

p {
  border-style: solid;
  border-color: blue red;
  }

注释：默认的边框颜色是元素本身的前景色。如果没有为边框声明颜色，它将与元素的文本颜色相同。另一方面，如果元素没有任何文本，假设它是一个表格，其中只包含图像，那么该表的边框颜色就是其父元素的文本颜色（因为 color 可以继承）。这个父元素很可能是 body、div 或另一个 table。

定义单边颜色

还有一些单边边框颜色属性。它们的原理与单边样式和宽度属性相同：

  • border-top-color
  • border-right-color
  • border-bottom-color
  • border-left-color

要为 h1 元素指定实线黑色边框，而右边框为实线红色，可以这样指定：

h1 {
  border-style: solid;
  border-color: black;
  border-right-color: red;
  }

透明边框

我们刚才讲过，如果边框没有样式，就没有宽度。不过有些情况下您可能希望创建一个不可见的边框。

CSS2 引入了边框颜色值 transparent。这个值用于创建有宽度的不可见边框。请看下面的例子：

<a href="#">AAA</a>
<a href="#">BBB</a>
<a href="#">CCC</a>

我们为上面的链接定义了如下样式：

a:link, a:visited {
  border-style: solid;
  border-width: 5px;
  border-color: transparent;
  }
a:hover {border-color: gray;}

如需查看以上样式的效果，请点击：TIY。

从某种意义上说，利用 transparent，使用边框就像是额外的内边距一样；此外还有一个好处，就是能在你需要的使用使其可见。这种透明边框相当于内边距，因为元素的背景会延伸到边框区域（如果有可见背景的话）。

重要事项：在 IE7 之前，IE/WIN 没有提供对 transparent 的支持。在以前的版本，IE 会根据元素的 color 值来设置边框颜色。

CSS 边框实例：

所有边框属性在一个声明之中
本例演示用简写属性来将所有四个边框属性设置于同一声明中。
设置四边框样式
本例演示如何设置四边框样式。
设置每一边的不同边框
本例演示如何在元素的各边设置不同的边框。
所有边框宽度属性在一个声明之中
本例演示用简写属性来将所有边框宽度属性设置于同一声明中。
设置四个边框的颜色
本例演示如何设置四个边框的颜色。可以设置一到四个颜色。
所有下边框属性在一个声明中
本例演示用简写属性来将所有下边框属性设置在同一声明中。
设置下边框的颜色
本例演示如何设置下边框的颜色。
设置下边框的样式
本例演示如何设置下边框的样式。
设置下边框的宽度
本例演示如何设置下边框的宽度。
所有左边框属性在一个声明之中
所有左边框属性在一个声明之中
设置左边框的颜色
本例演示如何设置左边框的颜色。
设置左边框的样式
本例演示如何设置左边框的样式。
设置左边框的宽度
本例演示如何设置左边框的宽度。
所有右边框属性在一个声明之中
本例演示一个简写属性，用于把所有右边框属性设置在一条声明中。
设置右边框的颜色
本例演示如何设置右边框的颜色。
设置右边框的样式
本例演示如何设置右边框的样式。
设置右边框的宽度
本例演示如何设置右边框的宽度。
所有上边框属性在一个声明之中
本例演示用简写属性来将所有上边框属性设置于同一声明之中。
设置上边框的颜色
本例演示如何设置上边框的颜色。
设置上边框的样式
本例演示如何设置上边框的样式。
设置上边框的宽度
本例演示如何设置上边框的宽度。

CSS 边框属性

属性 | 描述
border | 简写属性，用于把针对四个边的属性设置在一个声明。
border-style | 用于设置元素所有边框的样式，或者单独地为各边设置边框样式。
border-width | 简写属性，用于为元素的所有边框设置宽度，或者单独地为各边边框设置宽度。
border-color | 简写属性，设置元素的所有边框中可见部分的颜色，或为 4 个边分别设置颜色。
border-bottom | 简写属性，用于把下边框的所有属性设置到一个声明中。
border-bottom-color | 设置元素的下边框的颜色。
border-bottom-style | 设置元素的下边框的样式。
border-bottom-width | 设置元素的下边框的宽度。
border-left | 简写属性，用于把左边框的所有属性设置到一个声明中。
border-left-color | 设置元素的左边框的颜色。
border-left-style | 设置元素的左边框的样式。
border-left-width | 设置元素的左边框的宽度。
border-right | 简写属性，用于把右边框的所有属性设置到一个声明中。
border-right-color | 设置元素的右边框的颜色。
border-right-style | 设置元素的右边框的样式。
border-right-width | 设置元素的右边框的宽度。
border-top | 简写属性，用于把上边框的所有属性设置到一个声明中。
border-top-color | 设置元素的上边框的颜色。
border-top-style | 设置元素的上边框的样式。
border-top-width | 设置元素的上边框的宽度。
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 表格

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 表格

  • Previous Page
  • Next Page

CSS 表格属性允许你设置表格的布局。

实例：

设置表格的布局
本例演示如何设置表格的布局。
显示表格中的空单元
本例演示是否显示表格中的空单元。（请在非 IE 浏览器中浏览）
合并表格边框
本例演示是否把表格边框显示为一条单独的边框，还是像标准的 HTML 中那样分开显示。
设置表格边框之间的空白
本例演示如何设置单元格边框之间的距离。（请在非 IE 浏览器中浏览）
设置表格标题的位置
本例演示如何定位表格的标题。（请在非 IE 浏览器中浏览）

CSS Table 属性

CSS 表格属性允许你设置表格的布局。（请注意，本节介绍的不是如何使用表来建立布局，而是要介绍 CSS 中表本身如何布局。）

属性 | 描述
border-collapse | 设置是否把表格边框合并为单一的边框。
border-spacing | 设置分隔单元格边框的距离。（仅用于 "separated borders" 模型）
caption-side | 设置表格标题的位置。
empty-cells | 设置是否显示表格中的空单元格。（仅用于 "separated borders" 模型）
table-layout | 设置显示单元、行和列的算法。
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 测验

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 测验

  • Previous Page
  • Next Page

您可以通过 W3SCHOOL 的测验程序来测试您的 CSS 技能。

关于本测验

本测验包含 20 道题，每道题的最长答题时间是 20 分钟（这是由于每个 session 的默认有效时间是 20 钟）。

本测验是非官方的测试，它仅仅提供了一个了解您对 CSS 的掌握程度的工具。

测验会被记分

每道题的分值是 1 分。在您完成全部的 20 道题之后，系统会为您的测验打分，并提供您做错的题目的正确答案。其中，绿色为正确答案，而红色为错误答案。

现在就开始测验！祝您好运。

  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 尺寸

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 尺寸 (Dimension)

  • Previous Page
  • Next Page

CSS 尺寸 (Dimension) 属性允许你控制元素的高度和宽度。同样，它允许你增加行间距。

CSS 尺寸实例：

使用像素值设置图像的高度
本例演示如何使用像素值设置元素的高度。
使用百分比设置图像的高度
本例演示如何使用百分比值来设置元素的高度。
使用像素值来设置元素的宽度
本例演示如何使用像素值来设置元素的宽度。
使用百分比来设置元素的宽度
本例演示如何使用百分比值来设置元素的宽度。
设置元素的最大高度
本例演示如何设置一个元素的最大高度。
使用像素值来设置元素的最大宽度
本例演示如何使用像素值来设置元素的最大高度。
使用百分比来设置元素的最大宽度
本例演示如何使用百分比值来设置元素的最大高度。
使用像素值来设置元素的最小高度
本例演示如何使用像素值来设置元素的最小高度。
使用像素值来设置元素的最小宽度
本例演示如何使用像素值来设置元素的最小宽度。
使用百分比来设置元素的最小宽度
本例演示如何使用百分比值来设置元素的最小宽度。
使用百分比设置行间距
本例演示如何使用百分比值来设置段落中的行间距。
使用像素值设置行间距
本例演示如何使用像素值来设置段落中的行间距。
使用数值来设置行间距
本例演示如何使用一个数值来设置段落中的行间距。

CSS 尺寸属性

CSS 尺寸属性允许你控制元素的高度和宽度。同样，还允许你增加行间距。

属性 | 描述
height | 设置元素的高度。
line-height | 设置行高。
max-height | 设置元素的最大高度。
max-width | 设置元素的最大宽度。
min-height | 设置元素的最小高度。
min-width | 设置元素的最小宽度。
width | 设置元素的宽度。
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 单位

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 单位

  • Previous Page
  • Next Page

尺寸

单位 | 描述
% | 百分比
in | 英寸
cm | 厘米
mm | 毫米
em | 1em等于当前的字体尺寸。2em等于当前字体尺寸的两倍。例如，如果某元素以12pt显示，那么2em是24pt。在CSS中，em是非常有用的单位，因为它可以自动适应用户所使用的字体。
ex | 一个ex既是一个字体的x-height。 (x-height通常是字体尺寸的一半。)
pt | 磅 (1 pt 等于 1/72 英寸)
pc | 12点活字 (1 pc 等于 12 点)
px | 像素 (计算机屏幕上的一个点)

颜色

单位 | 描述
(颜色名) | 颜色名称 (比如 red)
rgb(x,x,x) | RGB 值 (比如 rgb(255,0,0))
rgb(x%, x%, x%) | RGB 百分比值 (比如 rgb(100%,0%,0%))
#rrggbb | 十六进制数 (比如 #ff0000)
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 定位

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 定位 (Positioning)

  • Previous Page
  • Next Page

CSS 定位 (Positioning) 属性允许你对元素进行定位。

CSS 定位和浮动

CSS 为定位和浮动提供了一些属性，利用这些属性，可以建立列式布局，将布局的一部分与另一部分重叠，还可以完成多年来通常需要使用多个表格才能完成的任务。

定位的基本思想很简单，它允许你定义元素框相对于其正常位置应该出现的位置，或者相对于父元素、另一个元素甚至浏览器窗口本身的位置。显然，这个功能非常强大，也很让人吃惊。要知道，用户代理对 CSS2 中定位的支持远胜于对其它方面的支持，对此不应感到奇怪。

另一方面，CSS1 中首次提出了浮动，它以 Netscape 在 Web 发展初期增加的一个功能为基础。浮动不完全是定位，不过，它当然也不是正常流布局。我们会在后面的章节中明确浮动的含义。

一切皆为框

div、h1 或 p 元素常常被称为块级元素。这意味着这些元素显示为一块内容，即“块框”。与之相反，span 和 strong 等元素称为“行内元素”，这是因为它们的内容显示在行中，即“行内框”。

您可以使用 display 属性改变生成的框的类型。这意味着，通过将 display 属性设置为 block，可以让行内元素（比如 <a> 元素）表现得像块级元素一样。还可以通过把 display 设置为 none，让生成的元素根本没有框。这样的话，该框及其所有内容就不再显示，不占用文档中的空间。

但是在一种情况下，即使没有进行显式定义，也会创建块级元素。这种情况发生在把一些文本添加到一个块级元素（比如 div）的开头。即使没有把这些文本定义为段落，它也会被当作段落对待：

<div>
some text
<p>Some more text.</p>
</div>

在这种情况下，这个框称为无名块框，因为它不与专门定义的元素相关联。

块级元素的文本行也会发生类似的情况。假设有一个包含三行文本的段落。每行文本形成一个无名框。无法直接对无名块或行框应用样式，因为没有可以应用样式的地方（注意，行框和行内框是两个概念）。但是，这有助于理解在屏幕上看到的所有东西都形成某种框。

CSS 定位机制

CSS 有三种基本的定位机制：普通流、浮动和绝对定位。

除非专门指定，否则所有框都在普通流中定位。也就是说，普通流中的元素的位置由元素在 X(HTML) 中的位置决定。

块级框从上到下一个接一个地排列，框之间的垂直距离是由框的垂直外边距计算出来。

行内框在一行中水平布置。可以使用水平内边距、边框和外边距调整它们的间距。但是，垂直内边距、边框和外边距不影响行内框的高度。由一行形成的水平框称为行框（Line Box），行框的高度总是足以容纳它包含的所有行内框。不过，设置行高可以增加这个框的高度。

在下面的章节，我们会为您详细讲解相对定位、绝对定位和浮动。

CSS position 属性

通过使用 position 属性，我们可以选择 4 中不同类型的定位，这会影响元素框生成的方式。

position 属性值的含义：

static
元素框正常生成。块级元素生成一个矩形框，作为文档流的一部分，行内元素则会创建一个或多个行框，置于其父元素中。
relative
元素框偏移某个距离。元素仍保持其未定位前的形状，它原本所占的空间仍保留。
absolute
元素框从文档流完全删除，并相对于其包含块定位。包含块可能是文档中的另一个元素或者是初始包含块。元素原先在正常文档流中所占的空间会关闭，就好像元素原来不存在一样。元素定位后生成一个块级框，而不论原来它在正常流中生成何种类型的框。
fixed
元素框的表现类似于将 position 设置为 absolute，不过其包含块是视窗本身。

提示：相对定位实际上被看作普通流定位模型的一部分，因为元素的位置相对于它在普通流中的位置。

实例

定位：相对定位
本例演示如何相对于一个元素的正常位置来对其定位。
定位：绝对定位
本例演示如何使用绝对值来对元素进行定位。
定位：固定定位
本例演示如何相对于浏览器窗口来对元素进行定位。
使用固定值设置图像的上边缘
本例演示如何使用固定值设置图像的上边缘。
使用百分比设置图像的上边缘
本例演示如何使用百分比值设置图像的上边缘。
使用像素值设置图像的底部边缘
本例演示如何使用像素值设置图像的底部边缘。
使用百分比设置图像的底部边缘
本例演示如何使用百分比值设置图像的底部边缘。
使用固定值设置图像的左边缘
本例演示如何使用固定值设置图像的左边缘。
使用百分比设置图像的左边缘
本例演示如何使用百分比值设置图像的左边缘。
使用固定值设置图像的右边缘
本例演示如何使用固定值设置图像的右边缘。
使用百分比设置图像的右边缘
本例演示如何使用百分比值设置图像的右边缘。
如何使用滚动条来显示元素内溢出的内容
本例演示当元素内容太大而超出规定区域时，如何设置溢出属性来规定相应的动作。
如何隐藏溢出元素中溢出的内容
本例演示在元素中的内容太大以至于无法适应指定的区域时，如何设置 overflow 属性来隐藏其内容。
如何设置浏览器来自动地处理溢出
本例演示如何设置浏览器来自动地处理溢出。
设置元素的形状
本例演示如何设置元素的形状。此元素被剪裁到这个形状内，并显示出来。
垂直排列图象
本例演示如何在文本中垂直排列图象。
Z-index
Z-index可被用于将在一个元素放置于另一元素之后。
Z-index
上面的例子中的元素已经更改了Z-index。

CSS 定位属性

CSS 定位属性允许你对元素进行定位。

属性 | 描述
position | 把元素放置到一个静态的、相对的、绝对的、或固定的位置中。
top | 定义了一个定位元素的上外边距边界与其包含块上边界之间的偏移。
right | 定义了定位元素右外边距边界与其包含块右边界之间的偏移。
bottom | 定义了定位元素下外边距边界与其包含块下边界之间的偏移。
left | 定义了定位元素左外边距边界与其包含块左边界之间的偏移。
overflow | 设置当元素的内容溢出其区域时发生的事情。
clip | 设置元素的形状。元素被剪入这个形状之中，然后显示出来。
vertical-align | 设置元素的垂直对齐方式。
z-index | 设置元素的堆叠顺序。
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 分类

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 分类 (Classification)

  • Previous Page
  • Next Page

CSS 分类属性允许你规定如何以及在何处显示元素。

CSS分类(Classification)实例：

如何把元素显示为内联元素
本例演示如何把元素显示为内联元素。
如何把元素显示为块级元素
本例演示如何把元素显示为块级元素。
float 属性的简单应用
使图像浮动于一个段落的右侧。
将带有边框和边界的图像浮动于段落的右侧
使图像浮动于段落的右侧。向图像添加边框和边界。
带标题的图像浮动于右侧
使带有标题的图像浮动于右侧
使段落的首字母浮动于左侧
使段落的首字母浮动于左侧，并向这个字母添加样式。
创建水平菜单
使用具有一栏超链接的浮动来创建水平菜单。
创建无表格的首页
使用浮动来创建拥有页眉、页脚、左侧目录和主体内容的首页。
定位：相对定位
本例演示如何相对于一个元素的正常位置来对其定位。
定位：绝对定位
本例演示如何使用绝对值来对元素进行定位。
定位：固定定位
本例演示如何相对于浏览器窗口来对元素进行定位。
如何使元素不可见
本例演示如何使元素不可见。你希望元素被显示出来，还是不呢？
把表格元素设置为 collapse（请在非 IE 的浏览器中查看）
本例演示如何使表格元素叠加？
改变光标
本例演示如何改变光标。
清除元素的侧面
本例演示如何使用清除元素侧面的浮动元素。

CSS 分类属性 (Classification)

CSS 分类属性允许你控制如何显示元素，设置图像显示于另一元素中的何处，相对于其正常位置来定位元素，使用绝对值来定位元素，以及元素的可见度。

属性 | 描述
clear | 设置一个元素的侧面是否允许其他的浮动元素。
cursor | 规定当指向某元素之上时显示的指针类型。
display | 设置是否及如何显示元素。
float | 定义元素在哪个方向浮动。
position | 把元素放置到一个静态的、相对的、绝对的、或固定的位置中。
visibility | 设置元素是否可见或不可见。
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 浮动

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 浮动

  • Previous Page
  • Next Page

浮动的框可以向左或向右移动，直到它的外边缘碰到包含框或另一个浮动框的边框为止。

由于浮动框不在文档的普通流中，所以文档的普通流中的块框表现得就像浮动框不存在一样。

CSS 浮动

请看下图，当把框 1 向右浮动时，它脱离文档流并且向右移动，直到它的右边缘碰到包含框的右边缘：

CSS 浮动实例 - 向右浮动的元素

再请看下图，当框 1 向左浮动时，它脱离文档流并且向左移动，直到它的左边缘碰到包含框的左边缘。因为它不再处于文档流中，所以它不占据空间，实际上覆盖住了框 2，使框 2 从视图中消失。

如果把所有三个框都向左移动，那么框 1 向左浮动直到碰到包含框，另外两个框向左浮动直到碰到前一个浮动框。

CSS 浮动实例 - 向左浮动的元素

如下图所示，如果包含框太窄，无法容纳水平排列的三个浮动元素，那么其它浮动块向下移动，直到有足够的空间。如果浮动元素的高度不同，那么当它们向下移动时可能被其它浮动元素“卡住”：

CSS 浮动实例 2 - 向左浮动的元素

CSS float 属性

在 CSS 中，我们通过 float 属性实现元素的浮动。

如需更多有关 float 属性的知识，请访问参考手册：CSS float 属性。

行框和清理

浮动框旁边的行框被缩短，从而给浮动框留出空间，行框围绕浮动框。

因此，创建浮动框可以使文本围绕图像：

要想阻止行框围绕浮动框，需要对该框应用 clear 属性。clear 属性的值可以是 left、right、both 或 none，它表示框的哪些边不应该挨着浮动框。

为了实现这种效果，在被清理的元素的上外边距上添加足够的空间，使元素的顶边缘垂直下降到浮动框下面：

clear 属性实例 - 对行框应用 clear

这是一个有用的工具，它让周围的元素为浮动元素留出空间。

让我们更详细地看看浮动和清理。假设希望让一个图片浮动到文本块的左边，并且希望这幅图片和文本包含在另一个具有背景颜色和边框的元素中。您可能编写下面的代码：

.news {
  background-color: gray;
  border: solid 1px black;
  }

.news img {
  float: left;
  }

.news p {
  float: right;
  }

<div class="news">
<img src="news-pic.jpg" />
<p>some text</p>
</div>

这种情况下，出现了一个问题。因为浮动元素脱离了文档流，所以包围图片和文本的 div 不占据空间。

如何让包围元素在视觉上包围浮动元素呢？需要在这个元素中的某个地方应用 clear：

clear 属性实例 - 对空元素应用清理

不幸的是出现了一个新的问题，由于没有现有的元素可以应用清理，所以我们只能添加一个空元素并且清理它。

.news {
  background-color: gray;
  border: solid 1px black;
  }

.news img {
  float: right;
  }

.news p {
  float: right;
  }

.clear {
  clear: both;
  }

<div class="news">
<img src="news-pic.jpg" />
<p>some text</p>
<div class="clear"></div>
</div>

这样可以实现我们希望的效果，但是需要添加多余的代码。常常有元素可以应用 clear，但是有时候不得不为了进行布局而添加无意义的标记。

不过我们还有另一种办法，那就是对容器 div 进行浮动：

.news {
  background-color: gray;
  border: solid 1px black;
  float: left;
  }

.news img {
  float: right;
  }

.news p {
  float: right;
  }

<div class="news">
<img src="news-pic.jpg" />
<p>some text</p>
</div>

这样会得到我们希望的效果。不幸的是，下一个元素会受到这个浮动元素的影响。为了解决这个问题，有些人选择对布局中的所有东西进行浮动，然后使用适当的有意义的元素（常常是站点的页脚）对这些浮动进行清理。这有助于减少或消除不必要的标记。

事实上，W3School 站点上的所有页面都采用了这种技术，如果您打开我们使用 CSS 文件，您会看到我们对页脚的 div 进行了清理，而页脚上面的三个 div 都向左浮动。

CSS clear 属性

我们刚才详细讨论了 CSS 清理的工作原理和 clear 属性应用方法。如果您希望学习更多有关 clear 属性的知识，请访问参考手册：CSS clear 属性。

浮动和清理 实例

float 属性的简单应用
使图像浮动于一个段落的右侧。
将带有边框和边界的图像浮动于段落的右侧
使图像浮动于段落的右侧。向图像添加边框和边界。
带标题的图像浮动于右侧
使带有标题的图像浮动于右侧
使段落的首字母浮动于左侧
使段落的首字母浮动于左侧，并向这个字母添加样式。
创建水平菜单
使用具有一栏超链接的浮动来创建水平菜单。
创建无表格的首页
使用浮动来创建拥有页眉、页脚、左侧目录和主体内容的首页。
清除元素的侧面
本例演示如何使用清除元素侧面的浮动元素。
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 高级语法

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 高级语法

  • Previous Page
  • Next Page

选择器的分组

你可以对选择器进行分组，这样，被分组的选择器就可以分享相同的声明。用逗号将需要分组的选择器分开。在下面的例子中，我们对所有的标题元素进行了分组。所有的标题元素都是绿色的。

h1,h2,h2,h3,h5,h6 {
  color: green;
  }

继承及其问题

根据 CSS，子元素从父元素继承属性。但是它并不总是按此方式工作。看看下面这条规则：

body {
     font-family: Verdana, sans-serif;
     }

根据上面这条规则，站点的 body 元素将使用 Verdana 字体（假如访问者的系统中存在该字体的话）。

通过 CSS 继承，子元素将继承最高级元素（在本例中是 body）所拥有的属性（这些子元素诸如 p, td, ul, ol, ul, li, dl, dt,和 dd）。不需要另外的规则，所有 body 的子元素都应该显示 Verdana 字体，子元素的子元素也一样。并且在大部分的现代浏览器中，也确实是这样的。

但是在那个浏览器大战的血腥年代里，这种情况就未必会发生，那时候对标准的支持并不是企业的优先选择。比方说，Netscape 4 就不支持继承，它不仅忽略继承，而且也忽略应用于 body 元素的规则。IE/Windows 直到 IE6 还存在相关的问题，在表格内的字体样式会被忽略。我们又该如何是好呢？

友善地对待Netscape 4

幸运地是，你可以通过使用我们称为 "Be Kind to Netscape 4" 的冗余法则来处理旧式浏览器无法理解继承的问题。

body  {
     font-family: Verdana, sans-serif;
     }

p, td, ul, ol, li, dl, dt, dd  {
     font-family: Verdana, sans-serif;
     }

4.0 浏览器无法理解继承，不过他们可以理解组选择器。这么做虽然会浪费一些用户的带宽，但是如果需要对 Netscape 4 用户进行支持，就不得不这么做。

继承是一个诅咒吗？

如果你不希望 "Verdana, sans-serif" 字体被所有的子元素继承，又该怎么做呢？比方说，你希望段落的字体是 Times。没问题。创建一个针对 p 的特殊规则，这样它就会摆脱父元素的规则：

body  {
     font-family: Verdana, sans-serif;
     }

td, ul, ol, ul, li, dl, dt, dd  {
     font-family: Verdana, sans-serif;
     }

p  {
     font-family: Times, "Times New Roman", serif;
     }
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 基础语法

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 基础语法

  • Previous Page
  • Next Page

CSS 语法

CSS 语法由三部分构成：选择器、属性和值：

selector {property: value}

选择器 (selector) 通常是你希望定义的 HTML 元素或标签，属性 (property) 是你希望改变的属性，并且每个属性都有一个值。属性和值被冒号分开，并由花括号包围，这样就组成了一个完整的样式声明（declaration）：

body {color: blue}

上面这行代码的作用是将 body 元素内的文字颜色定义为蓝色。在上述例子中，body 是选择器，而包括在花括号内的的部分是声明。声明依次由两部分构成：属性和值，color 为属性，blue 为值。

值的不同写法和单位

除了英文单词 red，我们还可以使用十六进制的颜色值 #ff0000：

p { color: #ff0000; }

为了节约字节，我们可以使用 CSS 的缩写形式：

p { color: #f00; }

我们还可以通过两种方法使用 RGB 值：

p { color: rgb(255,0,0); }
p { color: rgb(100%,0%,0%); }

请注意，当使用 RGB 百分比时，即使当值为 0 时也要写百分比符号。但是在其他的情况下就不需要这么做了。比如说，当尺寸为 0 像素时，0 之后不需要使用 px 单位，因为 0 就是 0，无论单位是什么。

记得写引号

提示：如果值为若干单词，则要给值加引号：

p {font-family: "sans serif";}

多重声明：

提示：如果要定义不止一个声明，则需要用分号将每个声明分开。下面的例子展示出如何定义一个红色文字的居中段落。最后一条规则是不需要加分号的，因为分号在英语中是一个分隔符号，不是结束符号。然而，大多数有经验的设计师会在每条声明的末尾都加上分号，这么的好处是，当你从现有的规则中增减声明时，会尽可能的减少出错的可能性。就像这样：

p {text-align:center; color:red;}

你应该在每行只描述一个属性，这样可以增强样式定义的可读性，就像这样：

p {
  text-align: center;
  color: black;
  font-family: arial;
}

空格和大小写敏感

大多数样式表包含不止一条规则，而大多数规则包含不止一个声明。多重声明和空格的使用使得样式表更容易被编辑：

body {
  color: #000;
  background: #fff;
  margin: 0;
  padding: 0;
  font-family: Georgia, Palatino, serif;
  }

是否包含空格不会影响 CSS 在浏览器的工作效果，同样，与 XHTML 不同，CSS 对大小写不敏感。不过存在一个例外：如果涉及到与 HTML 文档一起工作的话，class 和 id 名称对大小写是敏感的。

  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 简介

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 简介

  • Previous Page
  • Next Page

需要具备的基础知识

在继续学习之前，你需要对下面的知识有基本的了解：

  • HTML
  • XHTML

如果你希望首先学习这些项目，请在 首页 访问相关教程。

CSS 概述

  • CSS 指层叠样式表 (Cascading Style Sheets)
  • 样式定义如何显示 HTML 元素
  • 样式通常存储在样式表中
  • 把样式添加到 HTML 4.0 中，是为了解决内容与表现分离的问题
  • 外部样式表可以极大提高工作效率
  • 外部样式表通常存储在 CSS 文件中
  • 多个样式定义可层叠为一

样式解决了一个普遍的问题

HTML 标签原本被设计为用于定义文档内容。通过使用 <h1>、<p>、<table> 这样的标签，HTML 的初衷是表达“这是标题”、“这是段落”、“这是表格”之类的信息。同时文档布局由浏览器来完成，而不使用任何的格式化标签。

由于两种主要的浏览器（Netscape 和 Internet Explorer）不断地将新的 HTML 标签和属性（比如字体标签和颜色属性）添加到 HTML 规范中，创建文档内容清晰地独立于文档表现层的站点变得越来越困难。

为了解决这个问题，万维网联盟（W3C），这个非营利的标准化联盟，肩负起了 HTML 标准化的使命，并在 HTML 4.0 之外创造出样式（Style）。

所有的主流浏览器均支持层叠样式表。

样式表极大地提高了工作效率

样式表定义如何显示 HTML 元素，就像 HTML 3.2 的字体标签和颜色属性所起的作用那样。样式通常保存在外部的 .css 文件中。通过仅仅编辑一个简单的 CSS 文档，外部样式表使你有能力同时改变站点中所有页面的布局和外观。

由于允许同时控制多重页面的样式和布局，CSS 可以称得上 WEB 设计领域的一个突破。作为网站开发者，你能够为每个 HTML 元素定义样式，并将之应用于你希望的任意多的页面中。如需进行全局的更新，只需简单地改变样式，然后网站中的所有元素均会自动地更新。

多重样式将层叠为一个

样式表允许以多种方式规定样式信息。样式可以规定在单个的 HTML 元素中，在 HTML 页的头元素中，或在一个外部的 CSS 文件中。甚至可以在同一个 HTML 文档内部引用多个外部样式表。

层叠次序

当同一个 HTML 元素被不止一个样式定义时，会使用哪个样式呢？

一般而言，所有的样式会根据下面的规则层叠于一个新的虚拟样式表中，其中数字 4 拥有最高的优先权。

  1. 浏览器缺省设置
  2. 外部样式表
  3. 内部样式表（位于 <head> 标签内部）
  4. 内联样式（在 HTML 元素内部）

因此，内联样式（在 HTML 元素内部）拥有最高的优先权，这意味着它将优先于以下的样式声明：<head> 标签中的样式声明，外部样式表中的样式声明，或者浏览器中的样式声明（缺省值）。

  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 教程

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 教程

  • Next Page

CSS 教程

通过使用 CSS 来提升工作效率！

在我们的 CSS 教程中，您会学到如何使用 CSS 同时控制多重网页的样式和布局。

开始学习 CSS ！

CSS 实例

学习 70 个实例。您可以对 CSS 代码进行编辑，然后单击测试按钮来查看结果。

亲自试一下吧 ！

CSS 测验

在 W3School 测试您的 CSS 技能！

开始 CSS 测验！

CSS 参考手册

在 W3School，我们提供完整的 CSS2 参考手册（已升级为 CSS2.1）。

CSS2 参考手册

  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 绝对定位

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 绝对定位

  • Previous Page
  • Next Page

设置为绝对定位的元素框从文档流完全删除，并相对于其包含块定位，包含块可能是文档中的另一个元素或者是初始包含块。元素原先在正常文档流中所占的空间会关闭，就好像该元素原来不存在一样。元素定位后生成一个块级框，而不论原来它在正常流中生成何种类型的框。

CSS 绝对定位

绝对定位使元素的位置与文档流无关，因此不占据空间。这一点与相对定位不同，相对定位实际上被看作普通流定位模型的一部分，因为元素的位置相对于它在普通流中的位置。

普通流中其它元素的布局就像绝对定位的元素不存在一样：

#box_relative {
  position: absolute;
  left: 30px;
  top: 20px;
}

如下图所示：

绝对定位的元素的位置相对于最近的已定位祖先元素，如果元素没有已定位的祖先元素，那么它的位置相对于最初的包含块。

对于定位的主要问题是要记住每种定位的意义。所以，现在让我们复习一下学过的知识吧：相对定位是“相对于”元素在文档中的初始位置，而绝对定位是“相对于”最近的已定位祖先元素，如果不存在已定位的祖先元素，那么“相对于”最初的包含块。

注释：根据用户代理的不同，最初的包含块可能是画布或 HTML 元素。

提示：因为绝对定位的框与文档流无关，所以它们可以覆盖页面上的其它元素。可以通过设置 z-index 属性来控制这些框的堆放次序。

CSS 绝对定位实例

定位：绝对定位
本例演示如何使用绝对值来对元素进行定位。
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 框模型概述

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 框模型概述

  • Previous Page
  • Next Page

CSS 框模型 (Box Model) 规定了元素框处理元素内容、内边距、边框 和 外边距 的方式。

CSS 框模型概述

元素框的最内部分是实际的内容，直接包围内容的是内边距。内边距呈现了元素的背景。内边距的边缘是边框。边框以外是外边距，外边距默认是透明的，因此不会遮挡其后的任何元素。

内边距、边框和外边距都是可选的，默认值是零。但是，许多元素将由用户代理样式表设置外边距和内边距。可以通过将元素的 margin 和 padding 设置为零来覆盖这些浏览器样式。这可以分别进行，也可以使用通用选择器对所有元素进行设置：

* {
  margin: 0;
  padding: 0;
}

在 CSS 中，width 和 height 指的是内容区域的宽度和高度。增加内边距、边框和外边距不会影响内容区域的尺寸，但是会增加元素框的尺寸。

假设框的每个边上有 10 个像素的外边距和 5 个像素的内边距。如果希望这个元素框达到 100 个像素，就需要将内容的宽度设置为 70 像素，请看下图：

#box {
  width: 70px;
  margin: 10px;
  padding: 5px;
}

提示：内边距、边框和外边距可以应用于一个元素的所有边，也可以应用于单独的边。

提示：外边距可以是负值，而且在很多情况下都要使用负值的外边距。

浏览器兼容性

一旦为页面设置了恰当的 DTD，大多数浏览器都会按照上面的图示来呈现内容。然而 IE 5 和 6 的呈现却是不正确的。根据 W3C 的规范，元素内容占据的空间是由 width 属性设置的，而内容周围的 padding 和 border 值是另外计算的。不幸的是，IE5.X 和 6 在怪异模式中使用自己的非标准模型。这些浏览器的 width 属性不是内容的宽度，而是内容、内边距和边框的宽度的总和。

虽然有方法解决这个问题。但是目前最好的解决方案是回避这个问题。也就是，不要给元素添加具有指定宽度的内边距，而是尝试将内边距或外边距添加到元素的父元素和子元素。

术语翻译

  • element : 元素。
  • padding : 内边距，也有资料将其翻译为填充。
  • border : 边框。
  • margin : 外边距，也有资料将其翻译为空白或空白边。

在 w3school，我们把 padding 和 margin 统一地称为内边距和外边距。边框内的空白是内边距，边框外的空白是外边距，很容易记吧：）

  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 列表

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 列表

  • Previous Page
  • Next Page

CSS 列表属性允许你放置、改变列表项标志，或者将图像作为列表项标志。

CSS 列表

从某种意义上讲，不是描述性的文本的任何内容都可以认为是列表。人口普查、太阳系、家谱、参观菜单，甚至你的所有朋友都可以表示为一个列表或者是列表的列表。

由于列表如此多样，这使得列表相当重要，所以说，CSS 中列表样式不太丰富确实是一大憾事。

列表类型

要影响列表的样式，最简单（同时支持最充分）的办法就是改变其标志类型。

例如，在一个无序列表中，列表项的标志 (marker) 是出现在各列表项旁边的圆点。在有序列表中，标志可能是字母、数字或另外某种计数体系中的一个符号。

要修改用于列表项的标志类型，可以使用属性 list-style-type：

ul {list-style-type : square}

上面的声明把无序列表中的列表项标志设置为方块。

列表项图像

有时，常规的标志是不够的。你可能想对各标志使用一个图像，这可以利用 list-style-image 属性做到：

ul li {list-style-image : url(xxx.gif)}

只需要简单地使用一个 url() 值，就可以使用图像作为标志。

列表标志位置

CSS2.1 可以确定标志出现在列表项内容之外还是内容内部。这是利用 list-style-position 完成的。

简写列表样式

为简单起见，可以将以上 3 个列表样式属性合并为一个方便的属性：list-style，就像这样：

li {list-style : url(example.gif) square inside}

list-style 的值可以按任何顺序列出，而且这些值都可以忽略。只要提供了一个值，其它的就会填入其默认值。

CSS 列表实例：

在无序列表中的不同类型的列表标记
本例演示在CSS中不同类型的列表项标记。
在有序列表中不同类型的列表项标记
本例演示在CSS中不同类型的列表项标记。
所有的列表样式类型
本例演示在CSS中所有不同类型的列表项标记。
将图像作为列表项标记
本例演示如何将图像作为列表项标记。
放置列表标记
本例演示在何处放置列表标记。
在一个声明中定义所有的列表属性
本例演示将所有针对列表的属性设置于一个简写属性。

CSS 列表属性(list)

属性 | 描述
list-style | 简写属性。用于把所有用于列表的属性设置于一个声明中。
list-style-image | 将图象设置为列表项标志。
list-style-position | 设置列表中列表项标志的位置。
list-style-type | 设置列表项标志的类型。
marker-offset |
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 内边距

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 内边距

  • Previous Page
  • Next Page

元素的内边距在边框和内容区之间。控制该区域最简单的属性是 padding 属性。

CSS padding 属性定义元素边框与元素内容之间的空白区域。

CSS padding 属性

CSS padding 属性定义元素的内边距。padding 属性接受长度值或百分比值，但不允许使用负值。

例如，如果您希望所有 h1 元素的各边都有 10 像素的内边距，只需要这样：

h1 {padding: 10px;}

您还可以按照上、右、下、左的顺序分别设置各边的内边距，各边均可以使用不同的单位或百分比值：

h1 {padding: 10px 0.25em 2ex 20%;}

单边内边距属性

也通过使用下面四个单独的属性，分别设置上、右、下、左内边距：

  • padding-top
  • padding-right
  • padding-bottom
  • padding-left

您也许已经想到了，下面的规则实现的效果与上面的简写规则是完全相同的：

h1 {
  padding-top: 10px;
  padding-right: 0.25em;
  padding-bottom: 2ex;
  padding-left: 20%;
  }

内边距的百分比数值

前面提到过，可以为元素的内边距设置百分数值。百分数值是相对于其父元素的 width 计算的，这一点与外边距一样。所以，如果父元素的 width 改变，它们也会改变。

下面这条规则把段落的内边距设置为父元素 width 的 10%：

p {padding: 10%;}

例如：如果一个段落的父元素是 div 元素，那么它的内边距要根据 div 的 width 计算。

<div style="width: 200px;">
<p>This paragragh is contained within a DIV that has a width of 200 pixels.</p>
</div>

注意：上下内边距与左右内边距一致；即上下内边距的百分数会相对于父元素宽度设置，而不是相对于高度。

CSS 内边距实例：

所有内边距属性在一个声明中
本例演示使用简写属性将所有的内边距属性设置于一个声明中，可以有一到四个值。
设置下内边距 1
本例演示如何使用厘米值来设置单元格的下内边距。
设置下内边距 2
本例演示如何使用百分比值来设置单元格的下内边距。
设置左内边距 1
本例演示如何使用厘米值来设置单元格的左内边距。
设置左内边距 2
本例演示如何使用百分比值来设置单元格的左内边距。
设置右内边距 1
本例演示如何使用厘米值来设置单元格的右内边距。
设置右内边距 2
本例演示如何使用百分比值来设置单元格的右内边距。
设置上内边距 1
本例演示如何使用厘米值来设置单元格的上内边距。
设置上内边距 2
本例演示如何使用百分比值来设置单元格的上内边距。

CSS 内边距属性

属性 | 描述
padding | 简写属性。作用是在一个声明中设置元素的所内边距属性。
padding-bottom | 设置元素的下内边距。
padding-left | 设置元素的左内边距。
padding-right | 设置元素的右内边距。
padding-top | 设置元素的上内边距。
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 派生选择器

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 派生选择器

  • Previous Page
  • Next Page

派生选择器

通过依据元素在其位置的上下文关系来定义样式，你可以使标记更加简洁。

在 CSS1 中，通过这种方式来应用规则的选择器被称为上下文选择器 (contextual selectors)，这是由于它们依赖于上下文关系来应用或者避免某项规则。在 CSS2 中，它们称为派生选择器，但是无论你如何称呼它们，它们的作用都是相同的。

派生选择器允许你根据文档的上下文关系来确定某个标签的样式。通过合理地使用派生选择器，我们可以使 HTML 代码变得更加整洁。

比方说，你希望列表中的 strong 元素变为斜体字，而不是通常的粗体字，可以这样定义一个派生选择器：

li strong {
    font-style: italic;
    font-weight: normal;
  }

请注意标记为 <strong> 的蓝色代码的上下文关系：

<p><strong>我是粗体字，不是斜体字，因为我不在列表当中，所以这个规则对我不起作用</strong></p>

<ol>
<li><strong>我是斜体字。这是因为 strong 元素位于 li 元素内。</strong></li>
<li>我是正常的字体。</li>
</ol>

在上面的例子中，只有 li 元素中的 strong 元素的样式为斜体字，无需为 strong 元素定义特别的 class 或 id，代码更加简洁。

再看看下面的 CSS 规则：

strong {
     color: red;
     }

h2 {
     color: red;
     }

h2 strong {
     color: blue;
     }

下面是它施加影响的 HTML：

<p>The strongly emphasized word in this paragraph is<strong>red</strong>.</p>
<h2>This subhead is also red.</h2>
<h2>The strongly emphasized word in this subhead is<strong>blue</strong>.</h2>
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 外边距

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 外边距

  • Previous Page
  • Next Page

围绕在元素边框的空白区域是外边距。设置外边距会在元素外创建额外的“空白”。

设置外边距的最简单的方法就是使用 margin 属性，这个属性接受任何长度单位、百分数值甚至负值。

CSS margin 属性

设置外边距的最简单的方法就是使用 margin 属性。

margin 属性接受任何长度单位，可以是像素、英寸、毫米或 em。

margin 可以设置为 auto。更常见的做法是为外边距设置长度值。下面的声明在 h1 元素的各个边上设置了 1/4 英寸宽的空白：

h1 {margin : 0.25in;}

下面的例子为 h1 元素的四个边分别定义了不同的外边距，所使用的长度单位是像素 (px)：

h1 {margin : 10px 0px 15px 5px;}

与内边距的设置相同，这些值的顺序是从上外边距 (top) 开始围着元素顺时针旋转的：

margin: top right bottom left

另外，还可以为 margin 设置一个百分比数值：

p {margin : 10%;}

百分数是相对于父元素的 width 计算的。上面这个例子为 p 元素设置的外边距是其父元素的 width 的 10%。

margin 的默认值是 0，所以如果没有为 margin 声明一个值，就不会出现外边距。但是，在实际中，浏览器对许多元素已经提供了预定的样式，外边距也不例外。例如，在支持 CSS 的浏览器中，外边距会在每个段落元素的上面和下面生成“空行”。因此，如果没有为 p 元素声明外边距，浏览器可能会自己应用一个外边距。当然，只要你特别作了声明，就会覆盖默认样式。

值复制

还记得吗？我们曾经在前两节中提到过值复制。下面我们为您讲解如何使用值复制。

有时，我们会输入一些重复的值：

p {margin: 0.5em 1em 0.5em 1em;}

通过值复制，您可以不必重复地键入这对数字。上面的规则与下面的规则是等价的：

p {margin: 0.5em 1em;}

这两个值可以取代前面 4 个值。这是如何做到的呢？CSS 定义了一些规则，允许为外边距指定少于 4 个值。规则如下：

  • 如果缺少左外边距的值，则使用右外边距的值。
  • 如果缺少下外边距的值，则使用上外边距的值。
  • 如果缺少右外边距的值，则使用上外边距的值。

下图提供了更直观的方法来了解这一点：

换句话说，如果为外边距指定了 3 个值，则第 4 个值（即左外边距）会从第 2 个值（右外边距）复制得到。如果给定了两个值，第 4 个值会从第 2 个值复制得到，第 3 个值（下外边距）会从第 1 个值（上外边距）复制得到。最后一个情况，如果只给定一个值，那么其他 3 个外边距都由这个值（上外边距）复制得到。

利用这个简单的机制，您只需指定必要的值，而不必全部都应用 4 个值，例如：

h1 {margin: 0.25em 1em 0.5em;}	/* 等价于 0.25em 1em 0.5em 1em */
h2 {margin: 0.5em 1em;}		/* 等价于 0.5em 1em 0.5em 1em */
p {margin: 1px;}			/* 等价于 1px 1px 1px 1px */

这种办法有一个小缺点，您最后肯定会遇到这个问题。假设希望把 p 元素的上外边距和左外边距设置为 20 像素，下外边距和右外边距设置为 30 像素。在这种情况下，必须写作：

p {margin: 20px 30px 30px 20px;}

这样才能得到您想要的结果。遗憾的是，在这种情况下，所需值的个数没有办法更少了。

再来看另外一个例子。如果希望除了左外边距以外所有其他外边距都是 auto（左外边距是 20px）：

p {margin: auto auto auto 20px;}

同样的，这样才能得到你想要的效果。问题在于，键入这些 auto 有些麻烦。如果您只是希望控制元素单边上的外边距，请使用单边外边距属性。

单边外边距属性

您可以使用单边外边距属性为元素单边上的外边距设置值。假设您希望把 p 元素的左外边距设置为 20px。不必使用 margin（需要键入很多 auto），而是可以采用以下方法：

p {margin-left: 20px;}

您可以使用下列任何一个属性来只设置相应上的外边距，而不会直接影响所有其他外边距：

  • margin-top
  • margin-right
  • margin-bottom
  • margin-left

一个规则中可以使用多个这种单边属性，例如：

h2 {
  margin-top: 20px;
  margin-right: 30px;
  margin-bottom: 30px;
  margin-left: 20px;
  }

当然，对于这种情况，使用 margin 可能更容易一些：

p {margin: 20px 30px 30px 20px;}

不论使用单边属性还是使用 margin，得到的结果都一样。一般来说，如果希望为多个边设置外边距，使用 margin 会更容易一些。不过，从文档显示的角度看，实际上使用哪种方法都不重要，所以应该选择对自己来说更容易的一种方法。

提示和注释

提示：Netscape 和 IE 对 body 标签定义的默认边距（margin）值是 8px。而 Opera 不是这样。相反地，Opera 将内部填充（padding）的默认值定义为 8px，因此如果希望对整个网站的边缘部分进行调整，并将之正确显示于 Opera 中，那么必须对 body 的 padding 进行自定义。

CSS 外边距实例：

设置文本的左外边距
本例演示如何设置文本的左外边距。
设置文本的右外边距
本例演示如何设置文本的右外边距。
设置文本的上外边距
本例演示如何设置文本的上外边距。
设置文本的下外边距
本例演示如何设置文本的下外边距。
所有的外边距属性在一个声明中。
本例演示如何将所有的外边距属性设置于一个声明中。

CSS 外边距属性

属性 | 描述
margin | 简写属性。在一个声明中设置所有外边距属性。
margin-bottom | 设置元素的下外边距。
margin-left | 设置元素的左外边距。
margin-right | 设置元素的右外边距。
margin-top | 设置元素的上外边距。
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 外边距合并

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 外边距合并

  • Previous Page
  • Next Page

外边距合并指的是，当两个垂直外边距相遇时，它们将形成一个外边距。

合并后的外边距的高度等于两个发生合并的外边距的高度中的较大者。

外边距合并

外边距合并（叠加）是一个相当简单的概念。但是，在实践中对网页进行布局是，它会造成许多混淆。

简单地说，外边距合并指的是，当两个垂直外边距相遇时，它们将形成一个外边距。合并后的外边距的高度等于两个发生合并的外边距的高度中的较大者。

当一个元素出现在另一个元素上面时，第一个元素的下外边距与第二个元素的上外边距会发生合并。请看下图：

CSS 外边距合并实例 1

当一个元素包含在另一个元素中时（假设没有内边距或边框把外边距分隔开），它们的上和/或下外边距也会发生合并。请看下图：

CSS 外边距合并实例 2

尽管看上去有些奇怪，但是外边距甚至可以与自身发生合并。

假设有一个空元素，它有外边距，但是没有边框或填充。在这种情况下，上外边距与下外边距就碰到了一起，它们会发生合并：

CSS 外边距合并实例 3

如果这个外边距遇到另一个元素的外边距，它还会发生合并：

CSS 外边距合并实例 4

这就是一系列的段落元素占用空间非常小的原因，因为它们的所有外边距都合并到一起，形成了一个小的外边距。

外边距合并初看上去可能有点奇怪，但是实际上，它是有意义的。以由几个段落组成的典型文本页面为例。第一个段落上面的空间等于段落的上外边距。如果没有外边距合并，后续所有段落之间的外边距都将是相邻上外边距和下外边距的和。这意味着段落之间的空间是页面顶部的两倍。如果发生外边距合并，段落之间的上外边距和下外边距就合并在一起，这样各处的距离就一致了。

注释：只有普通文档流中块框的垂直外边距才会发生外边距合并。行内框、浮动框或绝对定位之间的外边距不会合并。

  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 伪类

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 伪类 (Pseudo-classes)

  • Previous Page
  • Next Page

CSS 伪类用于向某些选择器添加特殊的效果。

CSS 伪类 (Pseudo-classes)实例：

超链接
本例演示如何向文档中的超链接添加不同的颜色。
超链接 2
本例演示如何向超链接添加其他样式。
超链接 - :focus 的使用
本例演示如何对超链接应用 :focus 伪类（无法在 IE 中工作）。
:first-child（首个子对象）
本例演示 :first-child 伪类的用法。
:lang（语言）
本例演示 :lang 伪类的用法。

语法

伪类的语法：

selector : pseudo-class {property: value}

CSS 类也可与伪类搭配使用。

selector.class : pseudo-class {property: value}

锚伪类

在支持 CSS 的浏览器中，链接的不同状态都可以不同的方式显示，这些状态包括：活动状态，已被访问状态，未被访问状态，和鼠标悬停状态。

a:link {color: #FF0000}	/* 未访问的链接 */
a:visited {color: #00FF00}	/* 已访问的链接 */
a:hover {color: #FF00FF}	/* 鼠标移动到链接上 */
a:active {color: #0000FF}	/* 选定的链接 */

提示：在 CSS 定义中，a:hover 必须被置于 a:link 和 a:visited 之后，才是有效的。

提示：在 CSS 定义中，a:active 必须被置于 a:hover 之后，才是有效的。

提示：伪类名称对大小写不敏感。

伪类与 CSS 类

伪类可以与 CSS 类配合使用：

a.red : visited {color: #FF0000}

<a class="red" href="css_syntax.asp">CSS Syntax</a>

假如上面的例子中的链接被访问过，那么它将显示为红色。

CSS2 - :first-child 伪类

您可以使用 :first-child 伪类来选择元素的第一个子元素。这个特定伪类很容易遭到误解，所以有必要举例来说明。考虑以下标记：

<div>
<p>These are the necessary steps:</p>
<ul>
<li>Intert Key</li>
<li>Turn key <strong>clockwise</strong></li>
<li>Push accelerator</li>
</ul>
<p>Do <em>not</em> push the brake at the same time as the accelerator.</p>
</div>

在上面的例子中，作为第一个元素的元素包括第一个 p、第一个 li 和 strong 和 em 元素。

给定以下规则：

p:first-child {font-weight: bold;}
li:first-child {text-transform:uppercase;}

第一个规则将作为某元素第一个子元素的所有 p 元素设置为粗体。第二个规则将作为某个元素（在 HTML 中，这肯定是 ol 或 ul 元素）第一个子元素的所有 li 元素变成大写。

请访问该链接，来查看这个 :first-child 实例的效果。

提示：最常见的错误是认为 p:first-child 之类的选择器会选择 p 元素的第一个子元素。

注释：必须声明 <!DOCTYPE>，这样 :first-child 才能在 IE 中生效。

为了使您更透彻地理解 :first-child 伪类，我们另外提供了 3 个例子：

例子 1 - 匹配第一个 <p> 元素

在下面的例子中，选择器匹配作为任何元素的第一个子元素的 p 元素：

<html>
<head>
<style type="text/css">
p:first-child {
  color: red;
  }
</style>
</head>

<body>
<p>some text</p>
<p>some text</p>
</body>
</html>

TIY

例子 2 - 匹配所有 <p> 元素中的第一个 <i> 元素

在下面的例子中，选择器匹配所有 <p> 元素中的第一个 <i> 元素：

<html>
<head>
<style type="text/css">
p > i:first-child {
  font-weight:bold;
  }
</style>
</head>

<body>
<p>some <i>text</i>. some <i>text</i>.</p>
<p>some <i>text</i>. some <i>text</i>.</p>
</body>
</html>

TIY

例子 3 - 匹配所有作为第一个子元素的 <p> 元素中的所有 <i> 元素

在下面的例子中，选择器匹配所有作为元素的第一个子元素的 <p> 元素中的所有 <i> 元素：

<html>
<head>
<style type="text/css">
p:first-child i {
  color:blue;
  }
</style>
</head>

<body>
<p>some <i>text</i>. some <i>text</i>.</p>
<p>some <i>text</i>. some <i>text</i>.</p>
</body>
</html>

TIY

CSS2 - :lang 伪类

:lang 伪类使你有能力为不同的语言定义特殊的规则。在下面的例子中，:lang 类为属性值为 no 的 q 元素定义引号的类型：

<html>
<head>

<style type="text/css">
q:lang(no)
   {
   quotes: "~" "~"
   }
</style>

</head>

<body>
<p>文字<q lang="no">段落中的引用的文字</q>文字</p>
</body></html>

伪类

浏览器支持：IE Internet Explorer, F: Firefox, N: Netscape。

W3C：“W3C” 列的数字显示出伪类属性由哪个 CSS 标准定义（CSS1 还是 CSS2）。

伪类 | 作用 | IE | F | N | W3C
:active | 将样式添加到被激活的元素 | 4 | 1 | 8 | 1
:focus | 将样式添加到被选中的元素 | - | - | - | 2
:hover | 当鼠标悬浮在元素上方时，向元素添加样式 | 4 | 1 | 7 | 1
:link | 将特殊的样式添加到未被访问过的链接 | 3 | 1 | 4 | 1
:visited | 将特殊的样式添加到被访问过的链接 | 3 | 1 | 4 | 1
:first-child | 将特殊的样式添加到元素的第一个子元素 |  | 1 | 7 | 2
:lang | 允许创作者来定义指定的元素中使用的语言 |  | 1 | 8 | 2
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 伪元素

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 伪元素 (Pseudo-elements)

  • Previous Page
  • Next Page

CSS 伪元素用于将特殊的效果添加到某些选择器。

CSS 伪元素 (Pseudo-elements)实例：

制作首字母特效
本例演示如何向文本的首字母添加特效。
制作首行特效
本例演示如何向文本的首行添加特效。

语法：

伪元素的语法：

选择器 : 伪元素 { 属性: 值 }

CSS 类也可以与伪元素配合使用：

选择器 . 类: 伪元素 { 属性: 值 }

:first-line 伪元素

"first-line" 伪元素用于向某个选择器中的文字的首行添加特殊样式：

p {font-size: 12pt}
p:first-line {color: #0000FF; font-variant: small-caps}

<p>Some text that ends up on two or more lines</p>

在上面的例子中，浏览器显示根据 first-line 伪元素格式化的第一行。浏览器是依靠浏览器窗口的尺寸来进行分行的。

提示：first-line 伪元素仅能被用于块级元素。

提示：下面的属性可以被应用到 first-line 伪元素。

  • font 属性
  • color 属性
  • background 属性
  • word-spacing
  • letter-spacing
  • text-decoration
  • vertical-align
  • text-transform
  • line-height
  • clear

:first-letter 伪元素

first-letter 伪元素用于向某个选择器中的文本的首字母添加特殊的样式：

p {font-size: 12pt}
p:first-letter {font-size: 200%; float: left}

<p>The first words of an article.</p>

输出的效果类似于：

___
  |  he first
  |  words of an
article.
  • font 属性
  • color 属性
  • background 属性
  • margin 属性
  • padding 属性
  • border 属性
  • text-decoration
  • vertical-align (仅当float为none时)
  • text-transform
  • line-height
  • float
  • clear

伪元素和 CSS 类

伪元素可以与 CSS 类配合使用：

p.article:first-letter {color: #FF0000}
<p class="article">文章中的一个段落。</p>

上面的例子会使所有 class 为 article 的段落的首字母变为红色。

多重伪元素

多个伪元素可以配合在一起使用：

p {font-size: 12pt;}
p:first-letter {color: #FF0000; font-size: 24pt;}
p:first-line {color: #0000FF;}
<p>The first words of an article</p>

输出的效果类似于：

__
  |  he first
  |  words of an
article.

在上面的例子中，段落的首字母将是字号为 24pt 的红色。首行的其余部分将会是蓝色，而段落的其余部分会是默认的颜色。

CSS2 - :before 伪元素

before 伪元素可用于在某个元素之前插入某些内容。

下面的样式会在标题之前播放音频：

h1:before
{
content: url(beep.wav)
}

CSS2 - :after 伪元素

after 伪类可用于在某个元素之后插入某些内容。

下面的样式会在标题之后播放音频：

h1:after
{
content: url(beep.wav)
}

伪元素

浏览器支持：IE: Internet Explorer, F: Firefox, N: Netscape。

W3C：“W3C”列的数字显示出属性背景由哪个CSS标准定义（CSS1还是CSS2）。

伪元素 | 作用 | IE | F | N | W3C
:first-letter | 将特殊的样式添加到文本的首字母 | 5 | 1 | 8 | 1
:first-line | 将特殊的样式添加到文本的首行 | 5 | 1 | 8 | 1
:before | 在某元素之前插入某些内容 |  | 1.5 | 8 | 2
:after | 在某元素之后插入某些内容 |  | 1.5 | 8 | 2
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 文本

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 文本

  • Previous Page
  • Next Page

CSS 文本属性可定义文本的外观。

通过文本属性，您可以改变文本的颜色、字符间距，对齐文本，装饰文本，对文本进行缩进，等等。

CSS 文本实例：

设置文本颜色
本例演示如何设置文本的颜色。
设置文本的背景颜色
本例颜色如何设置部分文本的背景颜色。
规定字符间距
本例演示如何增加或减少字符间距。
使用百分比设置行间距
本例演示如何使用百分比值来设置段落中的行间距。
使用像素值设置行间距
本例演示如何使用像素值来设置段落中的行间距。
使用数值来设置行间距
本例演示如何使用一个数值来设置段落中的行间距。
对齐文本
本例演示如何对齐文本。
修饰文本
本例演示如何向文本添加修饰。
缩进文本
本例演示如何缩进文本首行。
控制文本中的字母
本例演示如何控制文本中的字母。
在元素中禁止文本折行
本例演示如何禁止在元素中的文本折行。
增加单词间距
本例演示如何增加段落中单词间的距离。

CSS 文本属性

属性 | 描述
color | 设置文本颜色
direction | 设置文本方向。
line-height | 设置行高。
letter-spacing | 设置字符间距。
text-align | 对齐元素中的文本。
text-decoration | 向文本添加修饰。
text-indent | 缩进元素中文本的首行。
text-shadow | 设置文本阴影。CSS2 包含该属性，但是 CSS2.1 没有保留该属性。
text-transform | 控制元素中的字母。
unicode-bidi | 设置文本方向。
white-space | 设置元素中空白的处理方式。
word-spacing | 设置字间距。
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 相对定位

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 相对定位

  • Previous Page
  • Next Page

设置为相对定位的元素框会偏移某个距离。元素仍然保持其未定位前的形状，它原本所占的空间仍保留。

CSS 相对定位

相对定位是一个非常容易掌握的概念。如果对一个元素进行相对定位，它将出现在它所在的位置上。然后，可以通过设置垂直或水平位置，让这个元素“相对于”它的起点进行移动。

如果将 top 设置为 20px，那么框将在原位置顶部下面 20 像素的地方。如果 left 设置为 30 像素，那么会在元素左边创建 30 像素的空间，也就是将元素向右移动。

#box_relative {
  position: relative;
  left: 30px;
  top: 20px;
}

如下图所示：

注意，在使用相对定位时，无论是否进行移动，元素仍然占据原来的空间。因此，移动元素会导致它覆盖其它框。

CSS 相对定位实例

定位：相对定位
本例演示如何相对于一个元素的正常位置来对其定位。
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 语法

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 类选择器

  • Previous Page
  • Next Page

在 CSS 中，类选择器以一个点号显示：

.center {text-align: center}

在上面的例子中，所有拥有 center 类的 HTML 元素均为居中。

在下面的 HTML 代码中，h1 和 p 元素都有 center 类。这意味着两者都将遵守 ".center" 选择器中的规则。

<h1 class="center">
This heading will be center-aligned
</h1>

<p class="center">
This paragraph will also be center-aligned.
</p>

注意：类名的第一个字符不能使用数字！它无法在 Mozilla 或 Firefox 中起作用。

和 id 一样，class 也可被用作派生选择器：

.fancy td {
    color: #f60;
    background: #666;
    }

在上面这个例子中，类名为 fancy 的更大的元素内部的表格单元都会以灰色背景显示橙色文字。（名为 fancy 的更大的元素可能是一个表格或者一个 div）

元素也可以基于它们的类而被选择：

td.fancy {
    color: #f60;
    background: #666;
    }

在上面的例子中，类名为 fancy 的表格单元将是带有灰色背景的橙色。

<td class="fancy">

你可以将类 fancy 分配给任何一个表格元素任意多的次数。那些以 fancy 标注的单元格都会是带有灰色背景的橙色。那些没有被分配名为 fancy 的类的单元格不会受这条规则的影响。还有一点值得注意，class 为 fancy 的段落也不会是带有灰色背景的橙色，当然，任何其他被标注为 fancy 的元素也不会受这条规则的影响。这都是由于我们书写这条规则的方式，这个效果被限制于被标注为 fancy 的表格单元（即使用 td 元素来选择 fancy 类）。

  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 字体

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 字体

  • Previous Page
  • Next Page

CSS 字体 (font) 属性定义文本中的字体。

设置字体属性是样式表的最常见用途之一。CSS 字体属性允许您设置字体系列 (font-family) 和字体加粗 (font-weight)，您还可以设置字体的大小、字体风格（如斜体）和字体变形（如小型大写字母）。

指定字体

可以使用 font-family 属性在文档中采用某种字体系列。

使用通用字体系列

如果你希望文档使用一种 sans-serif 字体，但是你并不关心是哪一种字体，以下就是一个合适的声明：

body {font-family: sans-serif;}

这样用户代理就会从 sans-serif 字体系列中选择一个字体（如 Helvetica），并将其应用到 body 元素。因为有继承，这种字体选择还将应用到 body 元素中包含的所有元素，除非有一种更特定的选择器将其覆盖。

指定字体系列

除了指定通用的字体系列，您还可以通过 font-family 属性设置更具体的字体。

下面的例子为所有 h1 元素设置了 Verdana 字体：

h1 {font-family: Georgia;}

这样的规则同时会产生另外一个问题，如果用户代理上没有安装 Georgia 字体，就只能使用用户代理的默认字体来显示 h1 元素。

我们可以通过结合特定字体名和通用字体系列来解决这个问题：

h1 {font-family: Georgia, serif;}

如果读者没有安装 Georgia，但安装了 Times 字体（serif 字体系列中的一种字体），用户代理就可能对 h1 元素使用 Times。尽管 Times 与 Georgia 并不完全匹配，但至少足够接近。

因此，我们建议在所有 font-family 规则中都提供一个通用字体系列。这样就提供了一条后路，在用户代理无法提供与规则匹配的特定字体时，就可以选择一个候选字体。

如果您对字体非常熟悉，也可以为给定的元素指定一系列类似的字体。要做到这一点，需要把这些字体按照优先顺序排列，然后用逗号进行连接：

p {font-family: Times, TimesNR, 'New Century Schoolbook',
     Georgia, 'New York', serif;}

根据这个列表，用户代理会按所列的顺序查找这些字体。如果列出的所有字体都不可用，就会简单地选择一种可用的 serif 字体。

使用引号

您也许已经注意到了，上面的例子中使用了单引号。只有当一个字体名中有一个或多个空格（比如 New York），或者如果字体名包括 # 或 $ 之类的符号，才需要在 font-family 声明中加引号。

单引号或双引号都可以接受。但是，如果把一个 font-family 属性放在 HTML 的 style 属性中，则需要使用该属性本身未使用的那种引号。

CSS 字体实例：

设置文本的字体
本例演示如何设置文本字体。
设置字体尺寸
本例演示如何设置字体尺寸。
设置字体风格
本例演示如何设置字体风格。
设置字体的异体
本例演示如何设置字体的异体。
设置字体的粗细
本例演示如何设置字体的粗细。
所有字体属性在一个声明之内
本例演示如何使用简写属性将字体属性设置在一个声明之内。

CSS 字体属性

属性 | 描述
font | 简写属性。作用是把所有针对字体的属性设置在一个声明中。
font-family | 设置字体系列。
font-size | 设置字体的尺寸。
font-size-adjust | 当首选字体不可用时，对替换字体进行智能缩放。（CSS2.1 已删除该属性。）
font-stretch | 对字体进行水平拉伸。（CSS2.1 已删除该属性。）
font-style | 设置字体风格。
font-variant | 以小型大写字体或者正常字体显示文本。
font-weight | 设置字体的粗细。
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS 字体系列

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 字体系列

混乱的字体命名问题

设置字体属性是样式表的最常见的用途之一。不过，尽管字体选择很重要，但是目前还没有一种办法能确保在 Web 上一致地使用字体，因为没有一种统一描述字体和字体的变形的方法。

例如，字体 Times、Times New Roman 和 TimesNR 可能很类似，甚至完全相同，不过用户代理怎么能知道这一点呢？创作人员可能在一个文档中指定字体为 TimesNR，但是如果用户机器上没有安装这种字体，用户查看文档会看到什么呢？即使安装了 Times New Roman，用户代理也不知道这两个字体（Times New Roman 和 TimesNR）实际上是可以互换的。如果你希望一个浏览器上一定采用某种字体，请别妄想了。

与文字处理软件相比，CSS 对字体并没有提供更多的最终控制；比如加载你创建的一个 Microsoft Office 文档时，其显示可能取决于他已经安装的字体。如果他安装的字体与你的字体不同，那么文档看上去会大不相同。使用 CSS 设计的文档也是如此。

涉及到各种繁杂的字体变形时，如粗体或斜体文本，字体命名的问题就更是混乱。大多数人都知道，斜体文本看上去很像，但是很少有人能解释它与倾斜文本有什么区别，甚至不知道二者之间存在区别。

Slanted 并不是斜体风格（italic-style）文本的唯一别名，例如，你可能还会看到 oblique、incline（或 inclined）、cursive 和 kursiv 等待字眼。因此，一种字体可能有一个 TimesItalic 变形，而另一种字体可能使用 GeorgiaOblique 作为变形。尽管这两种字体实际上就相当于 Times 和 Georgia 字体的“斜体形式”，但是它们的“称呼”有很大的不同。类似地，字体变形词 bold、black 和 heavy 可能表示同一个意思，也可能不同。

通用字体系列

前面讨论过，实际上相同的字体可能有很多不同的称呼，不过 CSS 迈出了勇敢的一步，力图帮助用户代理把这种混乱状况理清楚。

我们所认为的“字体”可能有许多字体变形组成，分别用来描述粗体、斜体文本，等等。例如，你可能已经对字体 Times 很熟悉。不过，Times 实际上是多种变形的一个组合，包括 TimesRegular、TimesBold、TimesItalic、TimesOblique、TimesBoldItalic、TimesBoldOblique，等等。Times 的每种变形都是一个具体的字体风格（font face），而我们通常认为的 Times 是所有这些变形字体的一个组合。换句话说，Times 实际上是一个字体系列（font family），而不只是单个的字体，尽管我们大多数人都认为字体就是某一种字体。

除了各种特定字体系列外（如 Times、Verdana、Helvetica 或 Arial），CSS 还定义了 5 种通用字体系列：

Serif 字体
这些字体成比例，而且有上下短线。如果字体中的所有字符根据其不同大小有不同的宽度，则成该字符是成比例的。例如，小写 i 和小写 m 的宽度就不同。上下短线是每个字符笔划末端的装饰，比如小写 l 顶部和底部的短线，或大写 A 两条腿底部的短线。Serif 字体的例子包括 Times、Georgia 和 New Century Schoolbook。
Sans-serif 字体
这些字体是成比例的，而且没有上下短线。Sans-serif 字体的例子包括 Helvetica、Geneva、Verdana、Arial 或 Univers。
Monospace 字体
Monospace 字体并不是成比例的。它们通常用于模拟打字机打出的文本、老式点阵打印机的输出，甚至更老式的视频显示终端。采用这些字体，每个字符的宽度都必须完全相同，所以小写的 i 和小写的 m 有相同的宽度。这些字体可能有上下短线，也可能没有。如果一个字体的字符宽度完全相同，则归类为 Monospace 字体，而不论是否有上下短线。Monospace 字体的例子包括 Courier、Courier New 和 Andale Mono。
Cursive 字体
这些字体试图模仿人的手写体。通常，它们主要由曲线和 Serif 字体中没有的笔划装饰组成。例如，大写 A 再其左腿底部可能有一个小弯，或者完全由花体部分和小的弯曲部分组成。Cursive 字体的例子包括 Zapf Chancery、Author 和 Comic Sans。
Fantasy 字体
这些字体无法用任何特征来定义，只有一点是确定的，那就是我们无法很容易地将其规划到任何一种其他的字体系列当中。这样的字体包括 Western、Woodblock 和 Klingon。

理论上讲，用户安装的任何字体系列都会落入到上述某种通用系列中，但实际上可能并非如此，不过例外情况（如果有的话）往往很少。

CSS 参考手册
CSS 实例
CSS 测验


CSS2 参考手册

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS2 参考手册

  • Previous Page
  • Next Page

点击表格中属性列的链接，可以查看相关属性的详细信息。

快速导航：

  • 背景
  • 文本
  • 字体
  • 边框
  • 外边距
  • 内边距
  • 列表和标记
  • 内容生成
  • 轮廓
  • 尺寸
  • 分类
  • 定位
  • 表格
  • 伪类
  • 伪元素

缩写：

浏览器支持：IE: Internet Explorer, F: Firefox, N: Netscape。

W3C：“W3C” 列的数字显示出属性由哪个 CSS 标准定义（CSS1 还是 CSS2）。

CSS 背景属性

属性 描述 值 IE F N W3C
background 简写属性，作用是将背景属性设置在一个声明中。
  • background-color
  • background-image
  • background-repeat
  • background-attachment
  • background-position
 4 1 6 1
background-attachment 背景图像是否固定或者随着页面的其余部分滚动。
  • scroll
  • fixed
 4 1 6 1
background-color 设置元素的背景颜色。
  • color-rgb
  • color-hex
  • color-name
  • transparent
 4 1 4 1
background-image 把图像设置为背景。
  • url
  • none
 4 1 4 1
background-position 设置背景图像的起始位置。
  • top left
  • top center
  • top right
  • center left
  • center center
  • center right
  • bottom left
  • bottom center
  • bottom right
  • x-% y-%
  • x-pos y-pos
 4 1 6 1
background-repeat 设置背景图像是否及如何重复。
  • repeat
  • repeat-x
  • repeat-y
  • no-repeat
 4 1 4 1

CSS 边框属性 (border)

属性 | 描述 | 值 | IE | F | N | W3C
border 简写属性。作用是在一个声明中用来设置四个边框的所有属性。
  • border-width
  • border-style
  • border-color
 4 1 4 1
border-bottom 简写属性。作用是在一个声明中用来设置下边框的所有属性。
  • border-bottom-width
  • border-style
  • border-color
 4 1 6 1
border-bottom-color | 设置下边框的颜色。 | border-color | 4 | 1 | 6 | 2
border-bottom-style | 设置下边框的样式。 | border-style | 4 | 1 | 6 | 2
border-bottom-width 设置下边框的宽度。
  • thin
  • medium
  • thick
  • length
 4 1 4 1
border-color | 设置四个边框的颜色，可以设置一到四个颜色。 | color | 4 | 1 | 6 | 1
border-left 简写属性。用于在一个声明中设置左边框的所有属性。
  • border-left-width
  • border-style
  • border-color
 4 1 6 1
border-left-color | 设置左边框的颜色。 | border-color | 4 | 1 | 6 | 2
border-left-style | 设置左边框的样式。 | border-style | 4 | 1 | 6 | 2
border-left-width 设置左边框的宽度。
  • thin
  • medium
  • thick
  • length
 4 1 4 1
border-right 简写属性。将所有用于右边框的属性设置于一个声明中。
  • border-right-width
  • border-style
  • border-color
 4 1 6 1
border-right-color | 设置右边框的颜色 | border-color | 4 | 1 | 6 | 2
border-right-style | 设置右边框的样式 | border-style | 4 | 1 | 6 | 2
border-right-width 设置右边框的宽度。
  • thin
  • medium
  • thick
  • length
 4 1 4 1
border-style 设置四个边框的样式，可以设置一到四个样式。
  • none
  • hidden
  • dotted
  • dashed
  • solid
  • double
  • groove
  • ridge
  • inset
  • outset
 4 1 6 1
border-top 简写属性。将所有用于上边框的属性设置于一个声明中。
  • border-top-width
  • border-style
  • border-color
 4 1 6 1
border-top-color | 设置上边框的颜色。 | border-color | 4 | 1 | 6 | 2
border-top-style | 设置上边框的样式。 | border-style | 4 | 1 | 6 | 2
border-top-width 设置上边框的宽度。
  • thin
  • medium
  • thick
  • length
 4 1 4 1
border-width 简写属性。在一个声明中设置四个边框的宽度，可以设置一到四个值。
  • thin
  • medium
  • thick
  • length
 4 1 4 1

CSS 文本属性

属性 | 描述 | 值 | IE | F | N | W3C
color | 设置文本颜色。 | color | 3 | 1 | 4 | 1
direction 设置文本方向。
  • ltr
  • rtl
 6 1 6 2
letter-spacing 设置字符间距。
  • normal
  • length
 4 1 6 1
text-align 对齐元素中的文本。
  • left
  • right
  • center
  • justify
 4 1 4 1
text-decoration 向文本添加修饰。
  • none
  • underline
  • overline
  • line-through
  • blink
 4 1 4 1
text-indent 缩进元素中文本的首行。
  • length
  • %
 4 1 4 1
text-shadow
  • none
  • color
  • length
text-transform 控制元素中的字母。
  • none
  • capitalize
  • uppercase
  • lowercase
 4 1 4 1
unicode-bidi 设置文本方向。
  • normal
  • embed
  • bidi-override
 5 2
white-space 设设置元素中空白的处理方式。
  • normal
  • pre
  • nowrap
 5 1 4 1
word-spacing 设置字间距。
  • normal
  • length
 6 1 6 1

CSS 字体属性 (font)

属性 描述 值 IE F N W3C
font 简写属性。作用是将所有针对字体的属性设置在一个声明中。
  • font-style
  • font-variant
  • font-weight
  • font-size/line-height
  • font-family
  • caption
  • icon
  • menu
  • message-box
  • small-caption
  • status-bar
 4 1 4 1
font-family 字体类型名称或者针对某元素的类属族名名称的优先列表。
  • family-name
  • generic-family
 3 1 4 1
font-size 设置字体的尺寸。
  • xx-small
  • x-small
  • small
  • medium
  • large
  • x-large
  • xx-large
  • smaller
  • larger
  • length
  • %
 3 1 4 1
font-size-adjust 为元素规定 aspect 值。 none number - - - 2
font-stretch 收缩或拉伸当前的字体族。
  • normal
  • wider
  • narrower
  • ultra-condensed
  • extra-condensed
  • condensed
  • semi-condensed
  • semi-expanded
  • expanded
  • extra-expanded
  • ultra-expanded
 - - - 2
font-style 设置字体样式。
  • normal
  • italic
  • oblique
 4 1 4 1
font-variant 以小型小写字体或者正常字体显示文本
  • normal
  • small-caps
 4 1 6 1
font-weight 设置字体的粗细。
  • normal
  • bold
  • bolder
  • lighter
  • 100
  • 200
  • 300
  • 400
  • 500
  • 600
  • 700
  • 800
  • 900
 4 1 4 1

CSS 外边距属性 (margin)

属性 描述 值 IE F N W3C
margin 简写属性。在一个声明中设置外边距属性。
  • margin-top
  • margin-right
  • margin-bottom
  • margin-left
 4 1 4 1

margin-bottom

 设置元素的下外边距。
  • auto
  • length
  • %
 4 1 4 1

margin-left

 设置元素的左外边距。
  • auto
  • length
  • %
 3 1 4 1

margin-right

 设置元素的右外边距。
  • auto
  • length
  • %
 3 1 4 1
margin-top 设置元素的上外边距。
  • auto
  • length
  • %
 3 1 4 1

CSS 内边距属性 (padding)

属性 描述 值 IE F N W3C
padding 简写属性。作用是在一个声明中设置元素的内边距属性。
  • padding-top
  • padding-right
  • padding-bottom
  • padding-left
 4 1 4 1

padding-bottom

 设置元素的下内边距。
  • length
  • %
 4 1 4 1

padding-left

 设置元素的左内边距。
  • length
  • %
 4 1 4 1

padding-right

 设置元素的右内边距。
  • length
  • %
 4 1 4 1
padding-top 设置元素的上内边距。
  • length
  • %
 4 1 4 1

CSS 列表属性 (list)

属性 描述 值 IE F N W3C
list-style 简写属性。用于将所有用于列表的属性设置于一个声明之中。
  • list-style-type
  • list-style-position
  • list-style-image
 4 1 6 1
list-style-image 将图象设置为列表项标记。
  • none
  • url
 4 1 6 1
list-style-position 设置列表中列表项标记被放置的位置。
  • inside
  • outside
 4 1 6 1
list-style-type 设置列表项标记的类型。
  • none
  • disc
  • circle
  • square
  • decimal
  • decimal-leading-zero
  • lower-roman
  • upper-roman
  • lower-alpha
  • upper-alpha
  • lower-greek
  • lower-latin
  • upper-latin
  • hebrew
  • armenian
  • georgian
  • cjk-ideographic
  • hiragana
  • katakana
  • hiragana-iroha
  • katakana-iroha
 4 1 4 1
marker-offset
  • auto
  • length
 1 7 2

内容生成

属性 | 描述 | 值 | IE | F | N | W3C
content | 生成文档中的内容。与 :before 以及 :after 伪元素配合使用。 | string url counter(name) counter(name, list-style-type) counters(name, string) counters(name, string, list-style-type) attr(X) open-quote close-quote no-open-quote no-close-quote |  | 1 | 6 | 2
counter-increment | 设置某个选取器每次出现的计数器增量。 | none identifier number |  |  |  | 2
counter-reset | 设置某个选择器出现次数的计数器的值。 | none identifier number |  |  |  | 2
quotes | 设置引号的类型。 | none string string | - | 1 | 6 | 2

轮廓

属性 | 描述 | 值 | IE | F | N | W3C
outline | 简写属性。用来在一个声明中设置所有的 outline 属性。 | outline-color outline-style outline-width | - | 1.5 | - | 2
outline-color | 设置围绕元素的轮廓的颜色。 | color invert | - | 1.5 | - | 2
outline-style | 设置围绕元素的轮廓的样式。 | none dotted dashed solid double groove ridge inset outset | - | 1.5 | - | 2
outline-width | 设置围绕元素的轮廓的宽度。 | thin medium thick length | - | 1.5 | - | 2

CSS 尺寸属性 (Dimension)

属性 描述 值 IE F N W3C
height 设置元素高度。
  • auto
  • length
  • %
 4 1 6 1
line-height 设置行间距。
  • normal
  • number
  • length
  • %
 4 1 4 1
max-height 设置元素的最大高度。
  • none
  • length
  • %
 - 1 6 2
max-width 设置元素的最大宽度。
  • none
  • length
  • %
 - 1 6 2
min-height 设置元素的最小高度。
  • length
  • %
 - 1 6 2
min-width 设置元素的最小宽度。
  • length
  • %
 - 1 6 2
width 设置元素的宽度。
  • auto
  • %
  • length
 4 1 4 1

CSS 分类属性 (Classification)

属性 描述 值 IE F N W3C
clear 设置不允许存在浮动对象的边
  • left
  • right
  • both
  • none
 4 1 4 1
cursor 规定光标类型（形状）
  • url
  • auto
  • crosshair
  • default
  • pointer
  • move
  • e-resize
  • ne-resize
  • nw-resize
  • n-resize
  • se-resize
  • sw-resize
  • s-resize
  • w-resize
  • text
  • wait
  • help
 4 1 6 2
display 设置如何及是否显示某元素
  • none
  • inline
  • block
  • list-item
  • run-in
  • compact
  • marker
  • table
  • inline-table
  • table-row-group
  • table-header-group
  • table-footer-group
  • table-row
  • table-column-group
  • table-column
  • table-cell
  • table-caption
 4 1 4 1
float 设置图像或文本出现于另一元素中的何处
  • left
  • right
  • none
 4 1 4 1
position 元素的定位方式：静态、相对定位、绝对定位、固定定位
  • static
  • relative
  • absolute
  • fixed
 4 1 4 2
visibility 设置元素可见或不可见
  • visible
  • hidden
  • collapse
 4 1 6 2

CSS 定位属性 (Positioning)

属性 描述 值 IE F N W3C
bottom 设置定位元素下外边距边界与其包含块下边界之间的偏移。
  • auto
  • %
  • length
 5 1 6 2
clip 设置元素的形状。
  • shape
  • auto
 4 1 6 2
left 设置定位元素左外边距边界与其包含块左边界之间的偏移。
  • auto
  • %
  • length
 4 1 4 2
overflow 设置当元素的内容溢出其区域时发生的事情。
  • visible
  • hidden
  • scroll
  • auto
 4 1 6 2
position 把元素放置到一个静态的、相对的、绝对的、或固定的位置中。
  • static
  • relative
  • absolute
  • fixed
 4 1 4 2
right 设置定位元素右外边距边界与其包含块右边界之间的偏移。
  • auto
  • %
  • length
 5 1 6 2
top 设置定位元素的上外边距边界与其包含块上边界之间的偏移。
  • auto
  • %
  • length
 4 1 4 2
vertical-align 设置元素的垂直排列。
  • baseline
  • sub
  • super
  • top
  • text-top
  • middle
  • bottom
  • text-bottom
  • length
  • %
 4 1 4 1
z-index 设置元素的堆叠顺序。
  • auto
  • number
 4 1 6 2

CSS 表格属性

属性 | 描述
border-collapse | 设置是否把表格边框合并为单一的边框。
border-spacing | 设置分隔单元格边框的距离。（仅用于 "separated borders" 模型）
caption-side | 设置表格标题的位置。
empty-cells | 设置是否显示表格中的空单元格。（仅用于 "separated borders" 模型）
table-layout | 设置显示单元、行和列的算法。

CSS 伪类

伪类 | 作用 | IE | F | N | W3C
:active | 将样式添加到被激活的元素。 | 4 | 1 | 8 | 1
:focus | 将样式添加到被选中的元素。 | - | - | - | 2
:hover | 当鼠标悬浮在元素上方时，向元素添加样式。 | 4 | 1 | 7 | 1
:link | 将特殊的样式添加到未被访问过的链接。 | 3 | 1 | 4 | 1
:visited | 将特殊的样式添加到被访问过的链接。 | 3 | 1 | 4 | 1
:first-child | 将特殊的样式添加到元素的第一个子元素。 |  | 1 | 7 | 2
:lang | 允许创作者来定义指定的元素中使用的语言。 |  | 1 | 8 | 2

CSS 伪元素

伪元素 | 作用 | IE | F | N | W3C
:first-letter | 向文本的第一个字母添加特殊样式。 | 5 | 1 | 8 | 1
:first-line | 向文本的首行添加特殊样式。 | 5 | 1 | 8 | 1
:before | 在元素内容之前插入内容。 |  | 1.5 | 8 | 2
:after | 在元素内容之后插入内容。 |  | 1.5 | 8 | 2
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS2 打印参考

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS2 打印参考

  • Previous Page
  • Next Page

打印属性

打印 HTML 文档总是会出现问题。在 CSS2 中，我们可以借助打印属性让打印 web 内容更容易一些。

属性 | 描述 | 值
orphans | 设置元素放在页面底部时所允许的最少文本行数。 | number
marks

设置是否在内容区之外但是在画布的可打印区域内放“十字标志”。

请注意，CSS2.1 已删除该属性。
  • none
  • crop
  • cross
page

这个属性与 size 属性结合可以指定打印一个元素时所用的特定页面类型。

请注意，CSS2.1 已删除该属性。

 auto identifier
page-break-after 设置元素后是否应当放置分页符。
  • auto
  • always
  • avoid
  • left
  • right
page-break-before 设置元素前否应当放置分页符。
  • auto
  • always
  • avoid
  • left
  • right
page-break-inside 设置元素内部是否应当放置分页符。
  • auto
  • avoid
size

利用这个属性，创作人员可以声明打印一个元素时所用页框的大小和方向。它可以与 page 结合使用。不过并不要求一定如此。

请注意，CSS2.1 已删除该属性。
  • auto
  • portrait
  • landscape
widows | 设置元素放在页面顶部时所允许的最少文本行数。 | number
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS2 媒介类型

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS2 媒介类型

  • Previous Page
  • Next Page

媒介类型(Media Types)允许你定义以何种媒介来提交文档。文档可以被显示在显示器、纸媒介或者听觉浏览器等等。

媒介类型

某些 CSS 属性仅仅被设计为针对某些媒介。比方说 "voice-family" 属性被设计为针对听觉用户终端。其他的属性可被用于不同的媒介。例如，"font-size" 属性可被用于显示器以及印刷媒介，但是也许会带有不同的值。显示器上面的显示的文档通常会需要比纸媒介文档更大的字号，同时，在显示器上，sans-serif 字体更易阅读，而在纸媒介上，serif 字体更易阅读。

@media规则

@media 规则使你有能力在相同的样式表中，使用不同的样式规则来针对不同的媒介。

下面这个例子中的样式告知浏览器在显示器上显示 14 像素的 Verdana 字体。但是假如页面需要被打印，将使用 10 个像素的 Times 字体。注意：font-weight 被设置为粗体，不论显示器还是纸媒介：

<html>
<head>

<style>
@media screen
{
p.test {font-family:verdana,sans-serif; font-size:14px}
}

@media print
{
p.test {font-family:times,serif; font-size:10px}
}

@media screen,print
{
p.test {font-weight:bold}
}
</style>

</head>

<body>....</body>

</html>

不同的媒介类型

注释：媒介类型名称对大小写不敏感。

浏览器支持：IE: Internet Explorer, F: Firefox, N: Netscape。

W3C：“W3C” 列的数字显示出属性背景由哪个 CSS 标准定义（CSS1 还是 CSS2）。

媒介类型 | 描述
all | 用于所有的媒介设备。
aural | 用于语音和音频合成器。
braille | 用于盲人用点字法触觉回馈设备。
embossed | 用于分页的盲人用点字法打印机。
handheld | 用于小的手持的设备。
print | 用于打印机。
projection | 用于方案展示，比如幻灯片。
screen | 用于电脑显示器。
tty | 用于使用固定密度字母栅格的媒介，比如电传打字机和终端。
tv | 用于电视机类型的设备。
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS2 听觉参考

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS2 听觉参考

  • Previous Page
  • Next Page

听觉样式表

听觉样式表可把语音合成与音响效果相组合，使用户可以听到信息，而无需进行阅读。

听觉呈现可用于：

  • 视觉能力低弱的人士
  • 帮助用户学习阅读
  • 帮助有阅读障碍的用户
  • 家庭娱乐
  • 在汽车中使用

听觉呈现通常会把文档转化为纯文本，然后传给屏幕阅读器（可读出屏幕上所有字符的一种程序）。

听觉样式表的一个例子：

h1, h2, h3, h4
{
voice-family: male;
richness: 80;
cue-before: url("beep.au")
}

上面的例子可以让语音合成器演奏一段声音，然后用男性的声音读出标题。

CSS2 听觉参考

W3C : "W3C" 列的数字显示出属性由哪个 CSS 标准定义（CSS1 还是 CSS2）。

属性 描述 值 W3C
azimuth Sets where the sound/voices should come from (horizontally)
  • angle
  • left-side
  • far-left
  • left
  • center-left
  • center
  • center-right
  • right
  • far-right
  • right-side
  • behind
  • leftwards
  • rightwards
 2
cue A shorthand property for setting the cue-before and cue-after properties in one declaration
  • cue-before
  • cue-after
 2
cue-after Specifies a sound to be played after speaking an element's content to delimit it from other
  • none
  • url
 2
cue-before Specifies a sound to be played before speaking an element's content to delimit it from other
  • none
  • url
 2
elevation Sets where the sound/voices should come from (vertically)
  • angle
  • below
  • level
  • above
  • higher
  • lower
2
pause A shorthand property for setting the pause-before and pause-after properties in one declaration
  • pause-before
  • pause-after
 2
pause-after Specifies a pause after speaking an element's content
  • time
  • %
 2
pause-before Specifies a pause before speaking an element's content
  • time
  • %
 2
pitch Specifies the speaking voice
  • frequency
  • x-low
  • low
  • medium
  • high
  • x-high
2
pitch-range Specifies the variation in the speaking voice. (Monotone voice or animated voice?)
  • number
 2
play-during Specifies a sound to be played while speaking an element's content
  • auto
  • none
  • url
  • mix
  • repeat
 2
richness Specifies the richness in the speaking voice. (Rich voice or thin voice?)
  • number
 2
speak Specifies whether content will render aurally
  • normal
  • none
  • spell-out
 2
speak-header Specifies how to handle table headers. Should the headers be spoken before every cell, or only before a cell with a different header than the previous cell
  • always
  • once
 2
speak-numeral Specifies how to speak numbers
  • digits
  • continuous
 2
speak-punctuation Specifies how to speak punctuation characters
  • none
  • code
 2
speech-rate Specifies the speed of the speaking
  • number
  • x-slow
  • slow
  • medium
  • fast
  • x-fast
  • faster
  • slower
2
stress Specifies the "stress" in the speaking voice
  • number
 2
voice-family A prioritized list of voice family names that contain specific voices
  • specific-voice
  • generic-voice
 2
volume Specifies the volume of the speaking
  • number
  • %
  • silent
  • x-soft
  • soft
  • medium
  • loud
  • x-loud
2
  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


CSS2 总结

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

你已经学习了 CSS，下一步学习什么呢？

  • Previous Page
  • Next Page

CSS 概要

本教程已向你讲解了如何创建样式表来同时控制多重页面的样式和布局。

你已经学会如何使用 CSS 来添加背景、格式化文本、以及格式化边框，并定义元素的填充和边距。

同时，你也学会了如何定位元素、控制元素的可见性和尺寸、设置元素的形状、将一个元素置于另一个之后，以及向某些选择器添加特殊的效果，比如链接。

如果需要更多关于 CSS 的信息，请参阅我们对 CSS 实例 和 CSS 参考手册 。

你已经学习了 CSS，下一步学习什么呢？

下一步是 XHTML 和 JavaScript 。

XHTML

XHTML 是新的 HTML。最新的 HTML 标准是 HTML 4.01，也是最终的版本。

HTML 将被 XHTML 取而代之，而 XHTTML 是更严格更纯净的 HTML。

加入你希望学习更多关于 XHTML 的知识，请访问我们对 XHTML 教程 。

JavaScript

JavaScript 可使你的站点动态性更强。

当你只是希望展示单一的内容时，静态站点也可以应付得了。但是动态的站点可以对事件作出反应，并允许用户进行交互。

JavaScript 是因特网上最流行的脚本语言，它可以工作于所有的主流浏览器中。

加入你希望学习更多关于 JavaScript 的知识，请访问我们的 JavaScript 教程 。

  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


如何创建 CSS

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

如何创建 CSS

  • Previous Page
  • Next Page

如何插入样式表

当读到一个样式表时，浏览器会根据它来格式化 HTML 文档。插入样式表的方法有三种：

外部样式表

当样式需要应用于很多页面时，外部样式表将是理想的选择。在使用外部样式表的情况下，你可以通过改变一个文件来改变整个站点的外观。每个页面使用 <link> 标签链接到样式表。<link> 标签在（文档的）头部：

<head>
<link rel="stylesheet" type="text/css" href="mystyle.css" />
</head>

浏览器会从文件 mystyle.css 中读到样式声明，并根据它来格式文档。

外部样式表可以在任何文本编辑器中进行编辑。文件不能包含任何的 html 标签。样式表应该以 .css 扩展名进行保存。下面是一个样式表文件的例子：

hr {color: sienna;}
p {margin-left: 20px;}
body {background-image: url("images/back40.gif");}

不要在属性值与单位之间留有空格。假如你使用 “margin-left: 20 px” 而不是 “margin-left: 20px” ，它仅在 IE 6 中有效，但是在 Mozilla/Firefox 或 Netscape 中却无法正常工作。

内部样式表

当单个文档需要特殊的样式时，就应该使用内部样式表。你可以使用 <style> 标签在文档头部定义内部样式表，就像这样:

<head>
<style type="text/css">
  hr {color: sienna;}
  p {margin-left: 20px;}
  body {background-image: url("images/back40.gif");}
</style>
</head>

内联样式

由于要将表现和内容混杂在一起，内联样式会损失掉样式表的许多优势。请慎用这种方法，例如当样式仅需要在一个元素上应用一次时。

要使用内联样式，你需要在相关的标签内使用样式（style）属性。Style 属性可以包含任何 CSS 属性。本例展示如何改变段落的颜色和左外边距：

<p style="color: sienna; margin-left: 20px">
This is a paragraph
</p>

多重样式

如果某些属性在不同的样式表中被同样的选择器定义，那么属性值将从更具体的样式表中被继承过来。

例如，外部样式表拥有针对 h3 选择器的三个属性：

h3 {
  color: red;
  text-align: left;
  font-size: 8pt;
  }

而内部样式表拥有针对 h3 选择器的两个属性：

h3 {
  text-align: right;
  font-size: 20pt;
  }

假如拥有内部样式表的这个页面同时与外部样式表链接，那么 h3 得到的样式是：

color: red;
text-align: right;
font-size: 20pt;

即颜色属性将被继承于外部样式表，而文字排列（text-alignment）和字体尺寸（font-size）会被内部样式表中的规则取代。

  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


DHTML CSS Positioning (CSS-P)

DHTML 教程

  • DHTML 首页
  • DHTML 简介
  • DHTML CSS
  • DHTML DOM
  • DHTML 事件
  • DHTML 总结

DHTML DOM

  • DOM 参考手册

DHTML 实例

  • DHTML 实例
  • DOM 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

DHTML CSS Positioning (CSS-P)

  • Previous Page
  • Next Page

CSS 用于为 HTML 元素添加样式。

实例

注释：大多数 DHTML 实例需要IE 4.0+、Netscape 7+ 或者 Opera 7+！

position:relative
如何相对于元素的正常位置来定位这个元素。
position:relative
如何相对其正常位置来定位所有的标题。
position:absolute
如何使用一个绝对值来定义一个元素。

您可以在页面下方找到更多的例子。

哪些属性可与 CSS-P 一同使用？

首先，此元素必须指定 position 属性（relative 或 absolute）。

然后，我就可以设置下列 CSS-P 属性了：

  • left - 元素的左侧位置
  • top - 元素的顶端位置
  • visibility - 指定元素应当可见还是隐藏
  • z-index - 元素的堆叠次序
  • clip - 元素裁剪
  • overflow - 如何处理溢出的内容

Position

CSS 的 position 属性允许您控制文档中某个元素的定位。

position:relative

position:relative 属性可向对于一个元素的当前位置来定位此元素。

下面的例子把这个 div 元素定位到距离其正常位置右方 10 像素的位置：

div
{
position:relative;
left:10;
}

position:absolute

position:absolute 属性根据距离窗口的 margin 来定位一个元素。

下面的例子把这个 div 元素定位到距离其包含块左侧 margin 的右方 10 像素的位置：

div
{
position:absolute;
left:10;
}

Visibility

visibility 属性可决定一个元素是否可见。

visibility:visible

visibility:visible 属性可使元素可见。

h1
{
visibility:visible;
}

visibility:hidden

visibility:hidden 属性可使元素不可见。

h1
{
visibility:hidden;
}

Z-index

z-index 属性用于把一个元素放置于另一个元素之后。z-index 的默认值是 0。值越高，其优先权也越高。z-index: -1 更低的优先权。

h1
{
z-index:1;
}

h2
{
z-index:2;
}

在上面的例子中，如果 h1 和 h2 彼此叠加，则 h2 元素会位于 h1 的上面。

Filters

filter 属性允许您向文本和图像添加更多的样式效果。

h1
{
width:100%;
filter:glow;
}

注释：若需要使用 filter 属性，请始终指定元素的宽度。

上面的例子产生下面的输出：

Header

不同的滤镜

注释：除非 background-color 属性被设置为 transparent，否则某些 Filter 属性将无法工作！

属性 | 参数 | 描述 | 例子
alpha
  • opacity
  • finishopacity
  • style
  • startx
  • starty
  • finishx
  • finishy
 允许您设置元素的透明度
filter:alpha(
opacity=20,
finishopacity=100,
style=1,
startx=0,
starty=0,
finishx=140,
finishy=270)
blur
  • add
  • direction
  • strength
 使元素模糊
filter:blur(
add=true,
direction=90,
strength=6);
chroma color 使指定的颜色透明
filter:chroma(
color=#ff0000)
fliph | none | 水平反转元素 | filter:fliph;
flipv | none | 垂直反转元素 | filter:flipv;
glow
  • color
  • strength
 使元素发光
filter:glow(
color=#ff0000,
strength=5);
gray | none | 用黑白色来呈现元素 | filter:gray;
invert | none | 用反转的颜色和亮度值来呈现元素 | filter:invert;
mask color 呈现带有指定背景色和透明前景色的元素
filter:mask(
color=#ff0000);
shadow
  • color
  • direction
 呈现带有阴影的元素
filter:shadow
(color=#ff0000,
direction=90);
dropshadow
  • color
  • offx
  • offy
  • positive
 呈现带有阴影的元素
filter:dropshadow
(color=#ff0000,
offx=5,
offy=5,
positive=true);
wave
  • add
  • freq
  • lightstrength
  • phase
  • strength
 把元素呈现为波浪状
filter:wave(
add=true,
freq=1,
lightstrength=3,
phase=0,
strength=5)
xray | none | 使用黑白色显示带有反转色和亮度值的元素 | filter:xray;

Background

background 属性允许您选用自己的背景。

background-attachment:scroll

背景随页面滚动。

background-attachment:fixed

背景不会随页面滚动。

更多实例

Visibility
如何使某个元素不可见。你希望此元素显示还是不显示？
Z-index
Z-index 可用于把一个元素放置于另一个元素之后，通过使用 Z-index 次序。
Z-index
请看一下，元素的 Z-index 次序已经改变了。
Cursors
通过 CSS 来改变鼠标指针的样式。
Filters
使用 filter 属性来改变标题的样式。
Filters on Images
filter 属性也可以应用于图像，这里有一些已应用了 filter 属性的图像例子。
Watermark
当页面滚动时不会移动的背景图片。
  • Previous Page
  • Next Page

HTML DOM 参考手册
DHTML 实例


DHTML DOM（Document Object Model）

DHTML 教程

  • DHTML 首页
  • DHTML 简介
  • DHTML CSS
  • DHTML DOM
  • DHTML 事件
  • DHTML 总结

DHTML DOM

  • DOM 参考手册

DHTML 实例

  • DHTML 实例
  • DOM 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

DHTML DOM（Document Object Model）

  • Previous Page
  • Next Page

DOM （文档对象模型）是我们有能力访问一个文档中的每个元素。

实例

注释：大多数 DHTML 实例需要IE 4.0+、Netscape 7+ 或者 Opera 7+！

元素访问
如何访问一个元素并改变它的样式。
属性改变
如何访问一个图像元素并修改 "src" 属性。
innerHTML
如何访问并修改一个元素的内容。

如何访问一个元素？

元素必须拥有被定义的 id 属性，且需要一段脚本语言。JavaScript 是浏览器兼容性最好的脚本语言，所以我们使用 JavaScript。

<html>
<body>

<h1 id="header">My header</h1>

<script type="text/javascript">
document.getElementById('header').style.color="red"
</script>

</body>
</html>

这段脚本可改变标题元素的颜色，并生成输出。

My header
  • Previous Page
  • Next Page

HTML DOM 参考手册
DHTML 实例


DHTML 简介

DHTML 教程

  • DHTML 首页
  • DHTML 简介
  • DHTML CSS
  • DHTML DOM
  • DHTML 事件
  • DHTML 总结

DHTML DOM

  • DOM 参考手册

DHTML 实例

  • DHTML 实例
  • DOM 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

DHTML 简介

  • Previous Page
  • Next Page

您应当具备的基础知识

在继续学习之前，您需要对下面的知识有基本的了解：

  • HTML
  • CSS
  • JavaScript

如果您希望首先学习这些项目，请在我们的 首页 访问这些教程。

DHTML 不是 W3C 标准

DHTML 指动态 HTML（Dynamic HTML）。

DHTML 不是由万维网联盟（W3C）规定的标准。DHTML 是一个营销术语 - 被网景公司（Netscape）和微软公司用来描述 4.x 代浏览器应当支持的新技术。

DHTML 是一种用来创建动态站点的技术组合物。

对大多数人来说，DHTML 意味着 HTML 4.0、样式表以及 JavaScript 的结合物。

W3C 曾讲过：“动态HTML是一个被某些厂商用来描述可使文档动态性更强的HTML、样式表以及脚本的结合物的术语。”

DHTML 技术

通过 DHTML，Web 开发者可控制如何在浏览器窗口中显示和定位 HTML 元素。

HTML 4.0

通过 HTML 4.0，所有的格式化（信息）可移出HTML文档，并写入一个独立的样式表中。因为 HTML 4.0 可以把文档的表现从其结构中分离，我们可以在不搞乱文档内容的情况下完全地控制表现层。

层叠样式表（CSS）

通过 CSS，我们得到了一种用于 HTML 文档的样式和布局模型。

由于 CSS 使开发者有能力同时控制多个网页的样式和布局，CSS 可以称作 Web 设计领域的一个突破。作为开发者，您可以为每个 HTML 元素定义样式，并把它应用到您希望的任意多的页面上。如果需要做一个全局的改变，只需简单地改变样式，Web 中所有的元素都会被自动地更新。

文档对象模型（DOM）

DOM 指文档对象模型。

HTML DOM 是针对 HTML 的文档对象模型。

HTML DOM 定义了针对 HTML 的一套标准的对象，以及访问和处理 HTML 对象的标准方法。

“W3C 文档对象模型（DOM）是一个中立于语言和平台的接口，它允许程序和脚本动态地访问和更新文档的内容、结构以及样式”。

JavaScript

使您有能力编写可控制所有 HTML 元素的代码。

在 Netscape 4.x 以及 Internet Explorer 4.x 的 DHTML 技术

Netscape 4.x 跨浏览器 DHTML Internet Explorer 4.x
  • JSS（JavaScript 样式表）（允许您控制不同的 HTML 元素如何显示）
  • Layers（允许您控制元素的定位和可见性）
  • CSS1
  • CSS2（允许您控制不同的 HTML 元素如何显示）
  • CSS Positioning (允许您控制元素的定位和可见性)
  • JavaScript
  • 可视滤镜（允许您向文本和图形应用可视效果）
  • 动态 CSS（允许您控制元素的定位和可见性）

注释：只要各种浏览器所创建的属性特征和技术不被其他的浏览器支持，使用 DHTML 进行编码就会产生问题。某个网页在一款浏览器中看上去很棒，在另一款中却非常糟糕。

  • Previous Page
  • Next Page

HTML DOM 参考手册
DHTML 实例


DHTML 教程

DHTML 教程

  • DHTML 首页
  • DHTML 简介
  • DHTML CSS
  • DHTML DOM
  • DHTML 事件
  • DHTML 总结

DHTML DOM

  • DOM 参考手册

DHTML 实例

  • DHTML 实例
  • DOM 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

DHTML 教程

  • Next Page

DHTML 是一种使 HTML 页面具有动态特性的艺术。

DHTML 是一种创建动态和交互 WEB 站点的技术集。

对大多数人来说，DHTML 意味着 HTML、样式表和 JavaScript 的组合。

开始学习 DHTML ！

DHTML 参考手册

在 W3School，你能找到所有 DOM 对象的完整 DHTML DOM 参考手册，以及它们的属性和方法。

HTML DOM 参考手册

DHTML 实例

学习 100 个实例！使用我们的编辑器，你可以编辑源代码，单击 test 按钮来查看结果。

DHTML 实例

DHTML DOM 实例

  • Next Page

HTML DOM 参考手册
DHTML 实例


DHTML 事件句柄（Event Handlers）

DHTML 教程

  • DHTML 首页
  • DHTML 简介
  • DHTML CSS
  • DHTML DOM
  • DHTML 事件
  • DHTML 总结

DHTML DOM

  • DOM 参考手册

DHTML 实例

  • DHTML 实例
  • DOM 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

DHTML 事件句柄（Event Handlers）

  • Previous Page
  • Next Page

您可以在某个事件发生时通过一个事件句柄对某个元素进行某种操作。

实例

注释：大多数 DHTML 实例需要IE 4.0+、Netscape 7+ 或者 Opera 7+！

onmouseover 和 onmouseout
如何在鼠标指针移到并移开一个元素时改变一个元素的颜色。
onclick
把灯点亮。如何当您单击一副图像时改变图像，然后再次单击它时换回原来的图像。
onmousedown 和 onmouseup
这次只有当你按住鼠标按钮时灯才会亮。
onload
当页面完成加载时显示一个提示框。

事件句柄

通过一个事件句柄，您可以在某个事件发生时对某个元素进行某种操作：当用户点击元素时，当页面加载时，当一个表单被提交时，等等。

<h1 onclick="style.color='red'">Click on this text</h1>

上面的例子可定义当用户点击一个标题时标题变为红色。

您也可以在页面的 head 部分添加一段较恩，然后从事件句柄调用函数：

<html>

<head>
<script type="text/javascript">
function changecolor()
{
document.getElementById('header').style.color="red"
}
</script>
</head>

<body>
<h1 id="header" onclick="changecolor()">Click on this text</h1>
</body>

</html>

HTML 4.0 事件句柄

事件 | 当...时发生
onabort | 用户终止页面加载。
onblur | 用户离开对象。
onchange | 用户改变对象的值。
onclick | 用户点击对象。
ondblclick | 用户双击对象。
onfocus | 用户激活对象。
onkeydown | 按下键盘。
onkeypress | 按压键盘。
onkeyup | 松开键盘。
onload | 页面完成加载。 注释：在 Netscape 中，当页面加载时会发生该事件。
onmousedown | 用户按鼠标按钮。
onmousemove | 鼠标指针在对象上移动。
onmouseover | 鼠标指针移动到对象上。
onmouseout | 鼠标指针移出对象。
onmouseup | 用户释放鼠标按钮。
onreset | 用户重置表单。
onselect | 用户选取页面上的内容。
onsubmit | 用户提交表单。
onunload | 用户关闭页面。
  • Previous Page
  • Next Page

HTML DOM 参考手册
DHTML 实例


您已经学习了 DHTML，下一步呢？

DHTML 教程

  • DHTML 首页
  • DHTML 简介
  • DHTML CSS
  • DHTML DOM
  • DHTML 事件
  • DHTML 总结

DHTML DOM

  • DOM 参考手册

DHTML 实例

  • DHTML 实例
  • DOM 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

您已经学习了 DHTML，下一步呢？

  • Previous Page
  • Next Page

DHTML 概要

本教程已经向您讲解了如何使用 DHTML 来创建动态性和交互性更强调网站。

您已经学习到如何通过 HTML、CSS 以及 JavaScript 使用 HTML 文档更有动感。

如需更多有关 DHTML 方面的知识，请看参阅我们的 DHTML 实例 和 HTML DOM 参考手册。

您已经学习了 DHTML，下一步呢？

下一步应该学习 HTML DOM 和 ASP。

HTML DOM

HTML DOM 定义了一套访问和处理 HTML 文档的标准方法。

HTML DOM 独立于平台和语言，可被诸如 Java, JavaScript 以及 VBScript 等编程语言使用。

如果您希望学习更多有关 DOM 的知识，请访问我们的 HTML DOM 教程。

ASP

与一个 HTML 文件中的脚本在客户机（浏览器）中执行不同，APS 文件中的脚本在服务器上执行。

通过 ASP，您能够动态地编辑、修改或添加一张网页的任何内容，对被提交自 HTML 表单的数据进行响应，访问任何数据或数据库并向浏览器返回结果，为不同的用户定制更具价值的页面。

由于 ASP 文件以纯粹的 HTML 返回结果，它们可通过任何浏览器来查看。

如果您希望学习更多有关 ASP 的知识，请访问我们的 ASP 教程。

  • Previous Page
  • Next Page

HTML DOM 参考手册
DHTML 实例


.NET Mobile 简介

.NET Mobile

  • Mobile 教程
  • Mobile 简介
  • Mobile 实例
  • Mobile 模拟器
  • Mobile 窗体
  • Mobile 事件
  • Mobile 输入
  • Mobile 验证
  • Mobile 列表
  • Mobile 选择
  • Mobile 图像
  • Mobile Utilities

参考手册

  • Mobile 参考
  • Mobile 设备
  • Mobile 更新

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

.NET Mobile 简介

  • Previous Page
  • Next Page

背景

移动电话已成为我们的生活方式的组成部分，而且新的移动设备也即将加入这个行列。

有关这些新移动设备的令人激动的一件事情是，它们有能力连接到因特网并执行 Web 应用程序。

目前开发的移动应用程序能够向世界上的任何位置上的任何用户提供任何类型的数据！

不同的移动设备支持不同的编程语言。某些支持 WAP 和 WML，某些支持 HTML 和限制版本的 HTML，而另一些则同时支持两者或者另外的语言。

为了支持所有类型的移动设备，开发者必须为每中语言创建不同的应用程序。

通过 .NET Mobile，微软引入了开发移动应用程序的新平台。

本教程的内容是关于如何使用 .NET 框架的一个扩展来开发移动应用程序，这个扩展名为微软移动因特网工具包或者简易 .NET Mobile（Microsoft Mobile Internet Toolkit (MMIT) 或者 simply .NET Mobile）。

您应当具备的基础知识

在继续学习之前，您需要对下面的知识有基本的了解：

  • HTML / XHTML
  • 命名空间（Namespaces）
  • ASP.NET

如果您希望首先学习这些项目，请在我们的首页访问这些教程。

.NET Mobile

.NET Mobile 是微软 ASP.NET 和微软的 .NET 框架的一个扩展。

.NET Mobile 是一套针对诸如 web 电话和 PDA 来构建应用程序的服务器端 Web 窗体控件（Web Forms Controls ）。

这些控件通过生成 WML 1.1、HTML 3.2 或者紧凑 HTML 的方式，为不同的设备生成提供不同的输出。

它如何工作？

下面的陈述展示出 .NET Mobile 如何工作：

移动设备
因特网
因特网信息服务（IIS）
.NET 框架
.NET Mobile
  1. web 客户端请求网页
  2. 请求经因特网传输
  3. 请求被 IIS 接收
  4. 请求被 .NET 框架处理
  5. 所请求的页面被 ASP.NET 编译
  6. .NET Mobile 处理任何移动设备的请求
  7. 页面被返回客户端

软件要求

如需通过 .NET Mobile 开发移动应用，您必须拥有以下组件：

  • Windows 2000 Professional/Server with IIS 5
  • All Windows 2000 service packs
  • The ASP.NET framework
  • Microsoft Mobile Internet Toolkit (MMIT)
  • Internet Explorer 6.0 or 5.5
  • A WAP simulator

您需要 Windows 2000 来开发 .NET 应用程序。IIS 5 (Internet Information Services) 是 Windows 2000 的一部分。

假如您需要获得更多有关如何安装 .NET 的信息，请访问我们对 ASP.NET 教程。

同时您也需要安装 MMIT (.NET Mobile)和 Internet Explorer 5.5 或 6.0。

可从 Microsoft MSDN 下载 Internet Explorer 和 MMIT。

如何开始

使用 ASP.NET 来开发移动 web 应用程序是很简单的：

  • 创建 ASP.NET 页面
  • 包含 System.Mobile.UI
  • 向页面添加移动控件（Mobile Controls）

请在下面的章节学习相关细节。

  • Previous Page
  • Next Page


.NET Mobile 教程

.NET Mobile

  • Mobile 教程
  • Mobile 简介
  • Mobile 实例
  • Mobile 模拟器
  • Mobile 窗体
  • Mobile 事件
  • Mobile 输入
  • Mobile 验证
  • Mobile 列表
  • Mobile 选择
  • Mobile 图像
  • Mobile Utilities

参考手册

  • Mobile 参考
  • Mobile 设备
  • Mobile 更新

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

.NET Mobile 教程

  • Next Page

在本教程中，你将学习移动 .NET（.NET Mobile）。

本教程的主要内容是：如何利用 .NET 框架的扩展来创建移动应用程序，这种扩展被称为微软移动因特网工具包（MMIT）或者简易 .NET Mobile。

开始学习 .NET Mobile ！

内容目录

.NET Mobile 简介
本章阐述 ASP.NET Mobile 的概念，以及如何被使用。
.NET Mobile 实例
这个简单的例子演示出 ASP.NET Mobile 的力量所在。
.NET Mobile Emulators
本章介绍一些用来测试移动应用程序的模拟器。
.NET Mobile Forms
本章向你解释移动表单的使用。
.NET Mobile 事件
本章介绍移动表单中事件的使用。
.NET Mobile 输入
本章介绍移动输入控件的使用。
.NET Mobile 验证
本章介绍移动输入验证的使用。
.NET Mobile Lists
本章介绍移动列表控件的使用。
.NET Mobile Selection
本章介绍移动选项列表控件的使用。
.NET Mobile Images
本章介绍移动图像控件的使用。
.NET Mobile Utilities
本文讲解 mobile utility 控件的使用，比如 AdRotator 和 PhoneCall 控件。
.NET Mobile 参考手册
完整的移动控件对象的参考索引，包括属性、方法和事件。
.NET Mobile 设备
本章列出了 1.0 版本支持的移动设备。
.NET Mobile 更新
本章列出了对移动设备进行支持的更新。
  • Next Page


DTD - XML 构建模块

DTD 教程

  • DTD 首页
  • DTD 简介
  • DTD 构建模块
  • DTD 元素
  • DTD 属性
  • DTD 实体
  • DTD 验证
  • DTD 实例
  • DTD 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

DTD - XML 构建模块

  • Previous Page
  • Next Page

XML 以及 HTML 文档的主要构建模块是类似 <body>....</body> 这样的标签。

XML 文档构建模块

所有的 XML 文档（以及 HTML 文档）均由以下简单的构建模块构成：

  • 元素
  • 属性
  • 实体
  • PCDATA
  • CDATA

下面是每个构建模块的简要描述。

元素

元素是 XML 以及 HTML 文档的主要构建模块。

HTML 元素的例子是 "body" 和 "table"。XML 元素的例子是 "note" 和 "message" 。元素可包含文本、其他元素或者是空的。空的 HTML 元素的例子是 "hr"、"br" 以及 "img"。

实例：

<body>body text in between</body>
<message>some message in between</message>

属性

属性可提供有关元素的额外信息。

属性总是被置于某元素的开始标签中。属性总是以名称/值的形式成对出现的。下面的 "img" 元素拥有关于源文件的额外信息：

<img src="computer.gif" />

元素的名称是 "img"。属性的名称是 "src"。属性的值是 "computer.gif"。由于元素本身为空，它被一个 " /" 关闭。

实体

实体是用来定义普通文本的变量。实体引用是对实体的引用。

大多数同学都了解这个 HTML 实体引用："&nbsp;"。这个“无折行空格”实体在 HTML 中被用于在某个文档中插入一个额外的空格。

当文档被 XML 解析器解析时，实体就会被展开。

下面的实体在 XML 中被预定义：

实体引用 | 字符
&lt; | <
&gt; | >
&amp; | &
&quot; | "
&apos; | '

PCDATA

PCDATA 的意思是被解析的字符数据（parsed character data）。

可把字符数据想象为 XML 元素的开始标签与结束标签之间的文本。

PDATA 是会被解析器解析的文本。这些文本将被解析器检查实体以及标记。

文本中的标签会被当作标记来处理，而实体会被展开。

不过，被解析的字符数据不应当包含任何 &、< 或者 > 字符；需要使用 &amp;、&lt; 以及 &gt; 实体来分别替换它们。

CDATA

CDATA 的意思是字符数据（character data）。

CDATA 是不会被解析器解析的文本。在这些文本中的标签不会被当作标记来对待，其中的实体也不会被展开。

  • Previous Page
  • Next Page


DTD - 来自网络的实例

DTD 教程

  • DTD 首页
  • DTD 简介
  • DTD 构建模块
  • DTD 元素
  • DTD 属性
  • DTD 实体
  • DTD 验证
  • DTD 实例
  • DTD 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

DTD - 来自网络的实例

  • Previous Page
  • Next Page

电视节目表 DTD

由 David Moisan 创造。拷贝自：http://www.davidmoisan.org/

<!DOCTYPE TVSCHEDULE [

<!ELEMENT TVSCHEDULE (CHANNEL+)>
<!ELEMENT CHANNEL (BANNER,DAY+)>
<!ELEMENT BANNER (#PCDATA)>
<!ELEMENT DAY (DATE,(HOLIDAY|PROGRAMSLOT+)+)>
<!ELEMENT HOLIDAY (#PCDATA)>
<!ELEMENT DATE (#PCDATA)>
<!ELEMENT PROGRAMSLOT (TIME,TITLE,DESCRIPTION?)>
<!ELEMENT TIME (#PCDATA)>
<!ELEMENT TITLE (#PCDATA)>
<!ELEMENT DESCRIPTION (#PCDATA)>

<!ATTLIST TVSCHEDULE NAME CDATA #REQUIRED>
<!ATTLIST CHANNEL CHAN CDATA #REQUIRED>
<!ATTLIST PROGRAMSLOT VTR CDATA #IMPLIED>
<!ATTLIST TITLE RATING CDATA #IMPLIED>
<!ATTLIST TITLE LANGUAGE CDATA #IMPLIED>

]>

报纸文章 DTD

拷贝自：http://www.vervet.com/

<!DOCTYPE NEWSPAPER [

<!ELEMENT NEWSPAPER (ARTICLE+)>
<!ELEMENT ARTICLE (HEADLINE,BYLINE,LEAD,BODY,NOTES)>
<!ELEMENT HEADLINE (#PCDATA)>
<!ELEMENT BYLINE (#PCDATA)>
<!ELEMENT LEAD (#PCDATA)>
<!ELEMENT BODY (#PCDATA)>
<!ELEMENT NOTES (#PCDATA)>

<!ATTLIST ARTICLE AUTHOR CDATA #REQUIRED>
<!ATTLIST ARTICLE EDITOR CDATA #IMPLIED>
<!ATTLIST ARTICLE DATE CDATA #IMPLIED>
<!ATTLIST ARTICLE EDITION CDATA #IMPLIED>

<!ENTITY NEWSPAPER "Vervet Logic Times">
<!ENTITY PUBLISHER "Vervet Logic Press">
<!ENTITY COPYRIGHT "Copyright 1998 Vervet Logic Press">

]>

产品目录 DTD

拷贝自：http://www.vervet.com/

<!DOCTYPE CATALOG [

<!ENTITY AUTHOR "John Doe">
<!ENTITY COMPANY "JD Power Tools, Inc.">
<!ENTITY EMAIL "jd@jd-tools.com">

<!ELEMENT CATALOG (PRODUCT+)>

<!ELEMENT PRODUCT
(SPECIFICATIONS+,OPTIONS?,PRICE+,NOTES?)>
<!ATTLIST PRODUCT
NAME CDATA #IMPLIED
CATEGORY (HandTool|Table|Shop-Professional) "HandTool"
PARTNUM CDATA #IMPLIED
PLANT (Pittsburgh|Milwaukee|Chicago) "Chicago"
INVENTORY (InStock|Backordered|Discontinued) "InStock">

<!ELEMENT SPECIFICATIONS (#PCDATA)>
<!ATTLIST SPECIFICATIONS
WEIGHT CDATA #IMPLIED
POWER CDATA #IMPLIED>

<!ELEMENT OPTIONS (#PCDATA)>
<!ATTLIST OPTIONS
FINISH (Metal|Polished|Matte) "Matte"
ADAPTER (Included|Optional|NotApplicable) "Included"
CASE (HardShell|Soft|NotApplicable) "HardShell">

<!ELEMENT PRICE (#PCDATA)>
<!ATTLIST PRICE
MSRP CDATA #IMPLIED
WHOLESALE CDATA #IMPLIED
STREET CDATA #IMPLIED
SHIPPING CDATA #IMPLIED>

<!ELEMENT NOTES (#PCDATA)>

]>
  • Previous Page
  • Next Page


DTD - 实体

DTD 教程

  • DTD 首页
  • DTD 简介
  • DTD 构建模块
  • DTD 元素
  • DTD 属性
  • DTD 实体
  • DTD 验证
  • DTD 实例
  • DTD 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

DTD - 实体

  • Previous Page
  • Next Page

实体是用于定义用于定义引用普通文本或特殊字符的快捷方式的变量。

实体引用是对实体的引用。

实体可在内部或外部进行声明。

一个内部实体声明

语法：

<!ENTITY 实体名称 "实体的值">

例子：

DTD 例子:

<!ENTITY writer "Bill Gates">
<!ENTITY copyright "Copyright W3School.com.cn">

XML 例子:

<author>&writer;&copyright;</author>

注释: 一个实体由三部分构成: 一个和号 (&), 一个实体名称, 以及一个分号 (;)。

一个外部实体声明

语法：

<!ENTITY 实体名称 SYSTEM "URI/URL">

例子：

DTD 例子:

<!ENTITY writer SYSTEM "http://www.w3school.com.cn/dtd/entities.dtd">
<!ENTITY copyright SYSTEM "http://www.w3school.com.cn/dtd/entities.dtd">

XML 例子:

<author>&writer;&copyright;</author>
  • Previous Page
  • Next Page


DTD - 属性

DTD 教程

  • DTD 首页
  • DTD 简介
  • DTD 构建模块
  • DTD 元素
  • DTD 属性
  • DTD 实体
  • DTD 验证
  • DTD 实例
  • DTD 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

DTD - 属性

  • Previous Page
  • Next Page

在 DTD 中，属性通过 ATTLIST 声明来进行声明。

声明属性

属性声明拥使用下列语法：

<!ATTLIST 元素名称 属性名称 属性类型 默认值>

DTD 实例:

<!ATTLIST payment type CDATA "check">

XML 实例:

<payment type="check" />

以下是属性类型的选项：

类型 | 描述
CDATA | 值为字符数据 (character data)
(en1|en2|..) | 此值是枚举列表中的一个值
ID | 值为唯一的 id
IDREF | 值为另外一个元素的 id
IDREFS | 值为其他 id 的列表
NMTOKEN | 值为合法的 XML 名称
NMTOKENS | 值为合法的 XML 名称的列表
ENTITY | 值是一个实体
ENTITIES | 值是一个实体列表
NOTATION | 此值是符号的名称
xml: | 值是一个预定义的 XML 值

默认值参数可使用下列值：

值 | 解释
值 | 属性的默认值
#REQUIRED | 属性值是必需的
#IMPLIED | 属性不是必需的
#FIXED value | 属性值是固定的

规定一个默认的属性值

DTD:

<!ELEMENT square EMPTY>
<!ATTLIST square width CDATA "0">

合法的 XML:

<square width="100" />

在上面的例子中，"square" 被定义为带有 CDATA 类型的 "width" 属性的空元素。如果宽度没有被设定，其默认值为0 。

#IMPLIED

语法

<!ATTLIST 元素名称 属性名称 属性类型 #IMPLIED>

例子

DTD:

<!ATTLIST contact fax CDATA #IMPLIED>

合法的 XML:

<contact fax="555-667788" />

合法的 XML:

<contact />

假如您不希望强制作者包含属性，并且您没有默认值选项的话，请使用关键词 #IMPLIED。

#REQUIRED

语法

<!ATTLIST 元素名称 属性名称 属性类型 #REQUIRED>

例子

DTD:

<!ATTLIST person number CDATA #REQUIRED>

合法的 XML:

<person number="5677" />

非法的 XML:

<person />

假如您没有默认值选项，但是仍然希望强制作者提交属性的话，请使用关键词 #REQUIRED。

#FIXED

语法

<!ATTLIST 元素名称 属性名称 属性类型 #FIXED "value">

例子

DTD:

<!ATTLIST sender company CDATA #FIXED "Microsoft">

合法的 XML:

<sender company="Microsoft" />

非法的 XML:

<sender company="W3School" />

如果您希望属性拥有固定的值，并不允许作者改变这个值，请使用 #FIXED 关键词。如果作者使用了不同的值，XML 解析器会返回错误。

列举属性值

语法：

<!ATTLIST 元素名称 属性名称 (en1|en2|..) 默认值>

DTD 例子:

<!ATTLIST payment type (check|cash) "cash">

XML 例子:

<payment type="check" />

或者

<payment type="cash" />

如果您希望属性值为一系列固定的合法值之一，请使用列举属性值。

  • Previous Page
  • Next Page


DTD - 元素

DTD 教程

  • DTD 首页
  • DTD 简介
  • DTD 构建模块
  • DTD 元素
  • DTD 属性
  • DTD 实体
  • DTD 验证
  • DTD 实例
  • DTD 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

DTD - 元素

  • Previous Page
  • Next Page

在一个 DTD 中，元素通过元素声明来进行声明。

声明一个元素

在 DTD 中，XML 元素通过元素声明来进行声明。元素声明使用下面的语法：

<!ELEMENT 元素名称 类别>

或者

<!ELEMENT 元素名称 (元素内容)>

空元素

空元素通过类别关键词EMPTY进行声明：

<!ELEMENT 元素名称 EMPTY>

例子：

<!ELEMENT br EMPTY>

XML例子：

<br />

只有 PCDATA 的元素

只有 PCDATA 的元素通过圆括号中的 #PCDATA 进行声明：

<!ELEMENT 元素名称 (#PCDATA)>

例子：

<!ELEMENT from (#PCDATA)>

带有任何内容的元素

通过类别关键词 ANY 声明的元素，可包含任何可解析数据的组合：

<!ELEMENT 元素名称 ANY>

例子：

<!ELEMENT note ANY>

带有子元素（序列）的元素

带有一个或多个子元素的元素通过圆括号中的子元素名进行声明：

<!ELEMENT 元素名称 (子元素名称 1)>

或者

<!ELEMENT 元素名称 (子元素名称 1,子元素名称 2,.....)>

例子：

<!ELEMENT note (to,from,heading,body)>

当子元素按照由逗号分隔开的序列进行声明时，这些子元素必须按照相同的顺序出现在文档中。在一个完整的声明中，子元素也必须被声明，同时子元素也可拥有子元素。"note" 元素的完整声明是：

<!ELEMENT note (to,from,heading,body)>
<!ELEMENT to      (#PCDATA)>
<!ELEMENT from    (#PCDATA)>
<!ELEMENT heading (#PCDATA)>
<!ELEMENT body    (#PCDATA)>

声明只出现一次的元素

<!ELEMENT 元素名称 (子元素名称)>

例子：

<!ELEMENT note (message)>

上面的例子声明了：message 子元素必须出现一次，并且必须只在 "note" 元素中出现一次。

声明最少出现一次的元素

<!ELEMENT 元素名称 (子元素名称+)>

例子：

<!ELEMENT note (message+)>

上面的例子中的加号声明了：message 子元素必须在 "note" 元素内出现至少一次。

声明出现零次或多次的元素

<!ELEMENT 元素名称 (子元素名称*)>

例子：

<!ELEMENT note (message*)>

上面的例子中的星号声明了：子元素 message 可在 "note" 元素内出现零次或多次。

声明出现零次或一次的元素

<!ELEMENT 元素名称 (子元素名称?)>

例子：

<!ELEMENT note (message?)>

上面的例子中的问号声明了：子元素 message 可在 "note" 元素内出现零次或一次。

声明“非.../既...”类型的内容

例子：

<!ELEMENT note (to,from,header,(message|body))>

上面的例子声明了："note" 元素必须包含 "to" 元素、"from" 元素、"header" 元素，以及非 "message" 元素既 "body" 元素。

声明混合型的内容

例子：

<!ELEMENT note (#PCDATA|to|from|header|message)*>

上面的例子声明了："note" 元素可包含出现零次或多次的 PCDATA、"to"、"from"、"header" 或者 "message"。

  • Previous Page
  • Next Page


DTD 简介

DTD 教程

  • DTD 首页
  • DTD 简介
  • DTD 构建模块
  • DTD 元素
  • DTD 属性
  • DTD 实体
  • DTD 验证
  • DTD 实例
  • DTD 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

DTD 简介

  • Previous Page
  • Next Page

文档类型定义（DTD）可定义合法的XML文档构建模块。它使用一系列合法的元素来定义文档的结构。

DTD 可被成行地声明于 XML 文档中，也可作为一个外部引用。

内部的 DOCTYPE 声明

假如 DTD 被包含在您的 XML 源文件中，它应当通过下面的语法包装在一个 DOCTYPE 声明中：

<!DOCTYPE 根元素 [元素声明]>

带有 DTD 的 XML 文档实例（请在 IE5 以及更高的版本打开，并选择查看源代码）：

<?xml version="1.0"?>
<!DOCTYPE note [
  <!ELEMENT note (to,from,heading,body)>
  <!ELEMENT to      (#PCDATA)>
  <!ELEMENT from    (#PCDATA)>
  <!ELEMENT heading (#PCDATA)>
  <!ELEMENT body    (#PCDATA)>
]>
<note>
  <to>George</to>
  <from>John</from>
  <heading>Reminder</heading>
  <body>Don't forget the meeting!</body>
</note>

在您的浏览器中打开此 XML 文件，并选择“查看源代码”命令。

以上 DTD 解释如下：

!DOCTYPE note (第二行)定义此文档是 note 类型的文档。

!ELEMENT note (第三行)定义 note 元素有四个元素："to、from、heading,、body"

!ELEMENT to (第四行)定义 to 元素为 "#PCDATA" 类型

!ELEMENT from (第五行)定义 frome 元素为 "#PCDATA" 类型

!ELEMENT heading (第六行)定义 heading 元素为 "#PCDATA" 类型

!ELEMENT body (第七行)定义 body 元素为 "#PCDATA" 类型

外部文档声明

假如 DTD 位于 XML 源文件的外部，那么它应通过下面的语法被封装在一个 DOCTYPE 定义中：

<!DOCTYPE 根元素 SYSTEM "文件名">

这个 XML 文档和上面的 XML 文档相同，但是拥有一个外部的 DTD: （在 IE5 中打开，并选择“查看源代码”命令。）

<?xml version="1.0"?>
<!DOCTYPE note SYSTEM "note.dtd">
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

这是包含 DTD 的 "note.dtd" 文件：

<!ELEMENT note (to,from,heading,body)>
<!ELEMENT to (#PCDATA)>
<!ELEMENT from (#PCDATA)>
<!ELEMENT heading (#PCDATA)>
<!ELEMENT body (#PCDATA)>

为什么使用 DTD？

通过 DTD，您的每一个 XML 文件均可携带一个有关其自身格式的描述。

通过 DTD，独立的团体可一致地使用某个标准的 DTD 来交换数据。

而您的应用程序也可使用某个标准的 DTD 来验证从外部接收到的数据。

您还可以使用 DTD 来验证您自身的数据。

  • Previous Page
  • Next Page


DTD 教程

DTD 教程

  • DTD 首页
  • DTD 简介
  • DTD 构建模块
  • DTD 元素
  • DTD 属性
  • DTD 实体
  • DTD 验证
  • DTD 实例
  • DTD 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

DTD 教程

  • Next Page

DTD（文档类型定义）的作用是定义 XML 文档的合法构建模块。

它使用一系列的合法元素来定义文档结构。

开始学习 DTD ！

内容目录

DTD 简介
对 XML DTD 的简介，以及使用它的原因。
DTD - XML 构建模块
可以在 DTD 中定义的 XML 构建模块。
DTD 元素
如何使用 DTD 定义 XML 文档的合法元素。
DTD 属性
如何使用 DTD 定义 XML 元素的合法属性。
DTD 实体
如何使用 DTD 定义 XML 实体。
DTD 验证
如何在载入 XML 文档时，检验 DTD 错误。
DTD 实例
一些真实的 DTD 案例。
DTD 总结
本文包括在本教程所学内容的一个总结，以及我们向您推荐的下一步应该学习的内容。
  • Next Page


DTD 验证

DTD 教程

  • DTD 首页
  • DTD 简介
  • DTD 构建模块
  • DTD 元素
  • DTD 属性
  • DTD 实体
  • DTD 验证
  • DTD 实例
  • DTD 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

DTD 验证

  • Previous Page
  • Next Page

Internet Explorer 5.0 可根据某个 DTD 来验证您的 XML。

通过 XML 解析器进行验证

当您试图打开某个 XML 文档时，XML 解析器有可能会产生错误。通过访问 parseError 对象，就可以取回引起错误的确切代码、文本甚至所在的行。

注释：load( ) 方法用于文件，而 loadXML( ) 方法用于字符串。

var xmlDoc = new ActiveXObject("Microsoft.XMLDOM")
xmlDoc.async="false"
xmlDoc.validateOnParse="true"
xmlDoc.load("note_dtd_error.xml")

document.write("<br>Error Code: ")
document.write(xmlDoc.parseError.errorCode)
document.write("<br>Error Reason: ")
document.write(xmlDoc.parseError.reason)
document.write("<br>Error Line: ")
document.write(xmlDoc.parseError.line)

Try it Yourself 或者 仅仅看一下这个 XML 文件。

关闭验证

通过把 XML 解析器的 validateOnParse 设置为 "false"，就可以关闭验证。

var xmlDoc = new ActiveXObject("Microsoft.XMLDOM")
xmlDoc.async="false"
xmlDoc.validateOnParse="false"
xmlDoc.load("note_dtd_error.xml")

document.write("<br>Error Code: ")
document.write(xmlDoc.parseError.errorCode)
document.write("<br>Error Reason: ")
document.write(xmlDoc.parseError.reason)
document.write("<br>Error Line: ")
document.write(xmlDoc.parseError.line)

Try it Yourself

通用的 XML 验证器

为了帮助您验证 XML 文件，我们创建了此链接，这样你就可以验证任何 XML 文件了。

parseError 对象

您可以在我们的《XML DOM 教程》中阅读更多有关 parseError 对象的信息。

  • Previous Page
  • Next Page


 George John Reminder Don't forget the meeting!


]> George John Reminder Don't forget the meeting!


您已经学习了 DTD，下一步呢？

DTD 教程

  • DTD 首页
  • DTD 简介
  • DTD 构建模块
  • DTD 元素
  • DTD 属性
  • DTD 实体
  • DTD 验证
  • DTD 实例
  • DTD 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

您已经学习了 DTD，下一步呢？

  • Previous Page
  • Next Page

DTD 概要

本教程已经向您讲解了如何描述 XML 文档的结构。

您学习到了如何使用 DTD 来定义一个 XML 文档的合法元素，以及如何在您的 XML 内部或者作为一个外部引用来声明 DTD。

您已经学习了如何为 XML 文档声明合法的元素、属性、实体以及 CDATA 部分。

您也看到了如何根据某个 DTD 来验证一个 XML 文档。

您已经学习了 DTD，下一步学习什么内容呢？

下一步应当学习 XML Schema。

XML Schema 用于定义 XML 文档的合法元素，类似 DTD。我们认为 XML Schema 很快会将 DTD 取而代之，被用在大部分的网络应用程序中。

XML Schema 是基于 XML 的 DTD 替代物。

与 DTD 不同，XML Schema 支持数据类型和命名空间。

如果您希望学习更多有关 XML Schema 的知识，请访问我们的《XML Schema 教程》。

  • Previous Page
  • Next Page


E4X How To

E4X 教程

  • E4X 教程
  • E4X HowTo
  • E4X Why?
  • E4X 浏览器
  • E4X 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

E4X How To

  • Previous Page
  • Next Page

通过 E4X，您可以把 XML 文档定义为 JavaScript 对象。

E4X 实例

作为一个例子，我们可以解析并编辑一个表示便签的 XML 文档。

这个 XML 文档类似这样：

<note>
<date>2008-08-08</date>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

假如我们把这个 XML 文档存储在一个名为 note 的字符串中，那么通过编写下面的 JavaScript 语句，我们就可以把它载入一个名为 x 的 XML 对象变量中：

var x = new XML(note)

或者我们可以直接使用 XML 文本为该 XML 对象变量赋值：

var x = new XML()

x=
<note>
<date>2008-08-08</date>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

XML 是 JavaScript 对象

通过 E4X，您可以像声明 Date 或 Math 对象那样声明 XML 对象：

var x = new XML()

var y = new Date()

var z = new Array()

由于可以把 XML 文档作为 XML 对象进行声明，解析和操作 XML 文档是非常简单的。

按照上面的那个例子，编写一条 JavaScript 语句：

document.write(x.from)

将输出：

John

非常简单。您认为呢？

  • Previous Page
  • Next Page


E4X 教程

E4X 教程

  • E4X 教程
  • E4X HowTo
  • E4X Why?
  • E4X 浏览器
  • E4X 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

E4X 教程

  • Next Page

E4X 是对 JavaScript 的新扩展。

E4X 向 JavaScript 添加了对 XML 的直接支持。

E4X 是正式的 JavaScript 标准。

你之前应该掌握的知识：

在学习新内容之前，你应该对以下知识点有基本的了解。

  • HTML
  • JavaScript
  • XML

如果你有兴趣首先学习这些项目，你可以在首页找到有关这些项目的教程。

JavaScript = ECMAScript

ECMAScript 是对 JavaScript 的正式的命名。

ECMAScript 等同于 JavaScript。

ECMA（欧洲计算机工业协会）是 JavaScript 的标准化组织。

E4X = JavaScript for XML

E4X 意为“支持 XML 的 ECMAScript”（ECMAScript For XML）。它是对 ECMAScript 的标准扩展。

因此，在现实生活中，E4X意味着“支持XML的JavaScript”（JavaScript for XML）。

将 XML 作为 JavaScript 的对象

E4X 是添加了对 XML 支持的 JavaScript 正式标准。

通过 E4X，你可以像原先声明日期或数组对象变量的方法来声明 XML 对象变量

var x = new XML()

var y = new Date()

var z = new Array()

E4X 使创建针对 XML 的 JavaScript 非常容易。

在下一章，我们会为您提供一些实例。

E4X 是一个 WEB 标准

ECMA-262 (JavaScript 1.3) 于 1999 年 11 月被确立为标准。

E4X 是添加了对 XML 直接的支持的扩展了的 JavaScript。

ECMA-357 (E4X) 于 2004 年 6 月被确立为标准。

ECMA International

ECMA 国际于 1961 年建立。

ECMA 组织致力于信息通信技术（ICT）和消费类电子产品（CE）的标准化工作。

ECMA 已经确立了以下标准

  • JavaScript
  • C# Language（C# 语言）
  • International Character Sets（国际字符集）
  • Optical Disks（光盘）
  • Magnetic Tapes（磁带）
  • Data Compression（数据压缩）
  • Data Communication（数据通信）
  • 其他
  • Next Page


E4X 实例

E4X 教程

  • E4X 教程
  • E4X HowTo
  • E4X Why?
  • E4X 浏览器
  • E4X 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

E4X 实例

  • Previous Page
  • Next Page

E4X 使针对 XML 的脚本异常简单。

E4X 实例

作为一个例子，我们将和一个表示订单的 XML 文档打交道。

XML 文档类似这样：

<order>
<date>2005-08-01</date>
<customer>
  <firstname>John</firstname>
  <lastname>Johnson</lastname>
</customer>
<item>
  <name>Maxilaku</name>
  <qty>5</qty>
  <price>155.00</price>
</item>
</order>

假如我们把这个 XML 文档存储在名为 txt 的字符串中，那么通过编写下面的 JavaScript 语句，我们就可以把它载入名为 order 的 XML 对象中：

var order = new XML(txt)

或者我们可以直接使用 XML 文档对这个 XML 对象变量进行赋值：

var order = new XML()

order=<order id="555">
<date>2005-08-01</date>
<customer>
  <firstname>John</firstname>
  <lastname>Johnson</lastname>
</customer>
<item>
  <name>Maxilaku</name>
  <qty>5</qty>
  <price>155.00</price>
</item>
</order>

与数据打交道：

计算价格：

var total=order.item.qty * order.item.price

显示客户的全称：

document.write(order.customer.lastname)
document.write(",")
document.write(order.customer.firstname)

添加新项目：

order.item+=
<item>
  <name>Pavlova</name>
  <qty>10</qty>
  <price>128.00</price>
</item>

显示订单编号：

document.write(order.@id)

如果有多项订单，则计算总价：

var price=0
for each (i in order.item)
  {
  price+= i.qty*i.price
  }
  • Previous Page
  • Next Page


E4X 浏览器

E4X 教程

  • E4X 教程
  • E4X HowTo
  • E4X Why?
  • E4X 浏览器
  • E4X 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

E4X 浏览器

  • Previous Page
  • Next Page

浏览器对 E4X 的支持是有限的。

浏览器对 E4X 的有限支持

目前没有一款主流的浏览器支持 E4X。

Mozilla 引擎 (1.8) 的 beta 版拥有对 E4X 的有限支持。Firefox 1.1 被认为是第一款支持 E4X 的浏览器。

希望今后的 Internet Explorer 版本会支持 E4X。

Firefox 1.1

在 Firefox 的下个版本中，Firefox 1.1 被认为对 E4X 的支持相对较好。

在下一节中我们提供了一系列的例子，描绘了在 Firefox 1.1 中您可以通过 E4x 做的事情。

Internet Explorer 7

在 Internet Explorer 7 中，迄今为止依然没有支持 E4X 的迹象。

微软似乎打算支持其自己的 AJAX 方案。

AJAX 是一种使用 JavaScript, XML 以及 CSS 来创建交互 web 应用程序的新 web 开发技术。

您可以在 W3School 提供的 AJAX 教程 中学习更多内容。

  • Previous Page
  • Next Page


Why E4X?

E4X 教程

  • E4X 教程
  • E4X HowTo
  • E4X Why?
  • E4X 浏览器
  • E4X 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Why E4X?

  • Previous Page
  • Next Page

E4X 让我们对 XML 的使用更加容易。

E4X 更简单

如果您曾经尝试使用 JavaScript 来解析和操作 XML，您会发现 E4X 更容易使用。

如果没有 E4X，你必须使用 XML 库（或 XML 组件）来与 XML 打交道。

这些库或组件的语法以及它们在不同浏览器的工作方式都所不同。

如果没有 E4X

下面的例子是一个跨批功能团的浏览器实例，可以把 XML 文档 ("note.xml") 载入 XML 解析器，并显示出便签的消息：

var xmlDoc
//code for Internet Explorer
if (window.ActiveXObject)
{
xmlDoc = new ActiveXObject("Microsoft.XMLDOM")
xmlDoc.async=false;
xmlDoc.load("note.xml")
displaymessage()
}
// code for Mozilla, Firefox, etc.
else (document.implementation && document.implementation.createDocument)
{
xmlDoc= document.implementation.createDocument("","",null)
xmlDoc.load("note.xml");
xmlDoc.onload=displaymessage
}

function displaymessage()
{
document.write(xmlDoc.getElementsByTagName("body")[0].firstChild.nodeValue)
}

TIY

使用 E4X

这个例子与上面的例子作用相同，不过使用了 E4X：

var xmlDoc=new XML()
xmlDoc.load("note.xml")
document.write(xmlDoc.body)

是不是更简单呢？

  • Previous Page
  • Next Page


ADO 实例

ADO 教程

  • ADO 首页
  • ADO 简介
  • ADO 连接
  • ADO 记录集
  • ADO 显示
  • ADO 查询
  • ADO 排序
  • ADO 添加
  • ADO 更新
  • ADO 删除
  • ADO 加速

ADO 对象

  • ADO Command
  • ADO Connection
  • ADO Error
  • ADO Field
  • ADO Parameter
  • ADO Property
  • ADO Record
  • ADO Recordset
  • ADO Stream
  • ADO 数据类型
  • ADO 总结

实例

  • ADO 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ADO 实例

  • Previous Page
  • Next Page

显示

显示记录
在 HTML 表格中显示记录
向 HTML 表添添加标题
向 HTML 表格添加颜色

查询

显示 "Companyname" 以 A 开头的记录
显示 "Companyname" 大于 E 的记录
仅显示中国的客户
让用户来选择过滤条件

排序

根据指定的字段名称进行升序排序
根据指定的字段名称进行降序排序
让用户来选择根据那一列来进行排序

Recordset 对象

GetRows
GetString
  • Previous Page
  • Next Page

ADO 参考手册
ADO 实例


AJAX 实例

AJAX 基础

  • AJAX 首页
  • AJAX 简介
  • AJAX HTTP 请求
  • AJAX 实例
  • AJAX 浏览器支持
  • AJAX XMLHttpRequest
  • AJAX 请求服务器
  • AJAX 服务器脚本

AJAX 高级

  • AJAX 请求实例
  • AJAX 请求源代码
  • AJAX 数据库实例
  • AJAX XML 实例
  • AJAX ResponseXML

AJAX 实例

  • AJAX 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

AJAX 实例

  • Previous Page
  • Next Page

本例演示与 XML 一起使用的 JavaScript (AJAX)。

使用 XMLHttpRequest 对象的实例

通过 XML HTTP 把文本文件载入 HTML 元素

通过 XML HTTP 加载 XML 文件

通过 XML HTTP 进行一次 HEAD 请求

通过 XML HTTP 进行一次指定的 HEAD 请求

把 XML 文件显示为 HTML 表格

例子解释

当用户在文本框中键入内容时，使用 XMLHttp：

当用户键入文本时，通过使用 XML HTTP 与服务器进行在线通信

例子解释

  • Previous Page
  • Next Page


ASP 实例

ASP 教程

  • ASP 首页
  • ASP 简介
  • ASP 安装
  • ASP 语法
  • ASP 变量
  • ASP 程序
  • ASP 表单
  • ASP Cookies
  • ASP Session
  • ASP Application
  • ASP #include
  • ASP Global.asa
  • ASP e-mail

ASP 对象

  • ASP Response
  • ASP Request
  • ASP Application
  • ASP Session
  • ASP Server
  • ASP Error
  • ASP FileSystem
  • ASP TextStream
  • ASP Drive
  • ASP File
  • ASP Folder
  • ASP Dictionary
  • ASP ADO

ASP 组件

  • ASP AdRotator
  • ASP BrowserCap
  • ASP Content Linking
  • ASP Content Rotator

ASP 教程总结

  • ASP 快速参考
  • ASP 总结

实例/测验

  • ASP 实例
  • ASP 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP 实例

  • Previous Page
  • Next Page

基础：

用ASP写文本
如果使用ASP生成文本。
向文本添加HTML
如果同时生成HTML标签和纯文本。

变量：

声明变量
变量用于存储信息。本例演示如何声明变量，为变量赋值，并在程序中使用这个变量
声明数组
数组用于存储一系列相关的数据项目。本例演示如何声明一个存储名字的数组。
循环生成HTML标题
如何循环生成6个不同的HTML标题。
使用Vbscript制作基于时间的问候语
本例将根据服务器时间向用户显示不同的消息。
使用JavaScript制作基于时间的问候语
本例同上，只是语法不同而已。

程序：

调用使用VBScript的子程序
如何从ASP调用以VBScript编写的子程序。
调用使用JavaScript的子程序
如何从ASP调用以JavaScript编写的子程序。
调用使用VBScript和JavaScript的子程序
如何在一个ASP文件中调用以VBScript和JavaScript编写的子程序。

表单：

使用method="get"的表单
如何使用Request.QueryString命令与用户进行交互。
使用method="post"的表单
如何使用Request.Form命令与用户进行交互。
使用单选按钮的表单
如何使用Request.Form通过单选按钮与用户进行交互。

Cookie：

Welcome cookie
如何创建欢迎cookie。

Response 对象：

使用ASP写文本
本例演示如何使用ASP来写文本。
在ASP中使用HTML标签格式化文本
本例演示如何使用ASP将文本和HTML标签结合起来。
将用户重定向至不同的URL
本例演示如何将用户重定向至另一个的URL。
显示随机的链接
本例演示一个超级链接，当您每次载入页面时，它将显示两个链接中的其中一个。
控制缓存
本例演示如何控制缓存。
清空缓存
本例演示如何清空缓存。
在处理过程中终止脚本并返回结果
本例演示如何在处理过程中中断脚本的运行。
设置在页面失效前把页面在浏览器中缓存多少分钟
本例演示如何规定页面在失效前在浏览器中的缓存时间。
设置页面缓存在浏览器中的失效日期或时间
本例演示如何规定页面在浏览器中的缓存时间日期或时间
检查用户是否仍然与服务器相连
本例演示如何检查用户是否已与服务器断开。
设置内容类型
本例演示如何规定内容的类型。
设置字符集
本例演示如何规定字符集的名称。

QueryString集合 实例

当某用户点击链接时发送查询信息
本例演示如何在在链接中向页面发送一些额外的查询信息，并在目标页面中取回这些信息（在本例中是同一个页面）。
对QueryString集合的简单应用
本例演示QueryString集合如何从表单取回值。此表单使用GET方法，这意外着被发送的信息对用户来说是可见的（在地址中）。GET方法还会限制所发送信息的数量。
如何使用从表单传来的信息
本例演示如何使用从表单那里取回的值。我们会使用QueryString集合。此表单使用GET方法。
来自表单的更多信息
本例演示假如输入域包含若干相同的名称的话QueryString会包含什么内容。它将展示如何把这些相同的名称分割开来。它也会展示如何使用count关键词来对"name"属性进行计数。此表单使用GET方法。

Form集合 实例

一个Form集合的简单应用
本例演示Form集合如何从表单取回值。此表单使用POST方法，这意味着发送的信息对用户来说是不可见的，并且对对所发送信息的量没有限制（可发送大量的信息）。
如何使用来自表单的信息
本例演示如何使用从表单取回的信息。我们使用了Form集合。表单使用了POST方法。
来自表单的更多信息
本例演示假如若干的输入域使用了相同的名称，Form集合会包含什么信息。它将展示如何把这些相同的名称分割开来。它也会展示如何使用count关键词来对"name"属性进行计数。此表单使用POST方法。
带有单选按钮的表单
本例演示如何使用Form集合通过单选按钮与用户进行交互。此表单使用POST方法。
带有复选按钮的表单
本例演示如何使用Form集合通过复选按钮与用户进行交互。此表单使用POST方法。

其他实例

取得用户信息
如何查明访问者的浏览器类型、IP地址等信息
取得服务器变量
本例演示如何使用ServerVariables集合取得访问者的浏览器类型、IP地址等信息。
创建welcome cookie
本例演示如何使用Cookies集合创建一个欢迎cookie。
探测用户发送的字节总数
本例演示如何使用TotalBytes属性来取得用户在Request对象中发送的字节总数。

Session 对象

设置并返回LCID
本例演示"LCID"属性。此属性设置并返回一个指明位置或者地区的整数。类似于日期、时间以及货币等内容都要根据位置或者地区来显示。
返回SessionID
本例演示"SessionID"属性。该属性为每位用户返回一个唯一的id。这个id由服务器生成。
session的超时
本例演示"Timeout"属性。这个例子设置并返回session的超时时间（分钟）。

Server 对象

此文件最后被修改的时间是？
探测文件的最后更新时间。
打开并读取某个文本文件
本例会打开文件"Textfile.txt"以供读取。
自制的点击计数器
本例可从某文件中读取一个数字，并在此数字上累加1，然后将此数写回这个文件。

FileSystemObject 对象

指定的文件存在吗？
本例演示如何首先创建FileSystemObject对象，然后使用FileExists方法来探测某文件是否存在。
指定的文件夹存在吗？
本例演示如何使用FolderExists方法探测某文件夹是否存在。
指定的驱动器存在吗？
本例演示如何使用DriveExists方法来探测某个驱动器是否存在。
取得某个指定驱动器的名称
本例演示如何使用GetDriveName方法来取得某个指定的驱动器的名称。
取得某个指定路径的父文件夹的名称
本例演示如何使用GetParentFolderName方法来取得某个指定的路径的父文件夹的名称。
取得文件夹扩展名
本例演示如何使用GetExtensionName方法来取得指定的路径中的最后一个成分的文件扩展名。
取得文件名
本例演示如何使用GetFileName方法来取得指定的路径中的最后一个成分的文件名。
取得文件或文件夹的基名称
本例演示如何使用GetBaseName方法来返回在指定的路径中文件或者文件夹的基名称。

TextStream 对象

读文件
本例演示如何使用FileSystemObject的OpenTextFile方法来创建一个TextStream 对象。TextStream 对象的ReadAll方法会从已打开的文本文件中取得内容。
读文本文件中的一个部分
本例演示如何仅仅读取一个文本流文件的部分内容。
读文本文件中的一行
本例演示如何从一个文本流文件中读取一行内容。
读取文本文件的所有行
本例演示如何从文本流文件中读取所有的行。
略过文本文件的一部分
本例演示如何在读取文本流文件时跳过指定的字符数。
略过文本文件的一行
本例演示如何在读取文本流文件时跳过一行。
返回行数
本例演示如何返回在文本流文件中的当前行号。
取得列数
本例演示如何取得在文件中当前字符的列号。

Drive 对象

取得指定驱动器的可用空间数
本例演示如何首先创建一个FileSystemObject对象，然后使用AvailableSpace属性来获得指定驱动器的可用空间。
取得指定驱动器的剩余空间容量
本例演示如何使用FreeSpace空间属性来取得指定驱动器的剩余空间。
取得指定驱动器的总容量
本例演示如何使用TotalSize属性来获得指定驱动器的总容量。
取得指定驱动器的驱动器字母
本例演示如何使用DriveLetter属性来获得指定驱动器的驱动器字母。
取得指定驱动器的驱动器类型
本例演示如何使用DriveType属性来获得指定驱动器的驱动器类型。
取得指定驱动器的文件系统信息
本例演示如何使用FileSystem来取得指定驱动器的文件系统类型。
驱动器是否已就绪？
本例演示如何使用IsReady属性来检查指定的驱动器是否已就绪。
取得指定驱动器的路径
本例演示如何使用Path属性来取得指定驱动器的路径。
取得指定驱动器的根文件夹
本例演示如何使用RootFolder属性来取得指定驱动器的根文件夹。
取得指定驱动器的序列号
本例演示如何使用Serialnumber属性来取得指定驱动器的序列号。

File 对象

文件何时被创建？
本例演示如何首先创建FileSystemObject对象，然后使用File对象的DateCreated属性来取得指定文件被创建的日期和时间。
此文件何时被修改？
本例演示如何使用DateLastModified属性来取得指定文件被修改的日期和时间。
此文件何时被访问过？
此例演示如何使用DateLastAccessed属性来取得指定文件最后被访问的日期和时间。
返回指定文件的属性
本例演示如何使用Attributes来返回指定文件的属性。

Dictionary 对象

指定的键存在吗？
本例演示如何受首先创建一个Dictionary对象，然后使用Exists方法来检查指定的键是否存在。
返回一个所有项目的数组
本例演示如何使用Items方法来返回所有项目的一个数组。
返回一个所有键的数组
本例演示如何使用Keys方法来返回所有键的一个数组。
返回某个项目的值
本例演示如何使用Item属性来返回某个项目的值。
设置一个键
本例演示如何使用Key属性来在Dictionary对象中设置一个键。
返回键/项目对的数目
本例演示如何使用Count属性来返回键/项目对的数目。

AdRotator 组件

简单的AdRotator实例
本例展示：每当用户访问网站或者刷新一次页面，如何使用AdRotator组件来显示一幅不同的广告图像。
AdRotator - 图片链接
本例展示：每当用户访问网站或者刷新一次页面，如何使用AdRotator组件来显示一幅不同的广告图像。此外，图片本身就是链接。

Browser Capabilities 组件

Browser Capabilities 组件
本例演示如何测定每一个访问网站的浏览器的类型、性能以及版本号。

Content Linking 组件

Content Linking 组件
本例会构建一个内容列表。
Content Linking 组件 2
本例使用Content Linking 组件在一个文本文件所列的页面间进行导航。

Content Rotator (ASP 3.0)

Content Rotator 组件
每当用户访问或者刷新页面时，该组件就会显示不同的HTML内容字符串。
  • Previous Page
  • Next Page

ASP 参考手册
ASP 实例
ASP 测验


CSS 实例

CSS 基础

  • CSS 教程
  • CSS 简介
  • CSS 基础语法
  • CSS 高级语法
  • CSS 派生选择器
  • CSS id 选择器
  • CSS 类选择器
  • CSS How To
  • CSS 背景
  • CSS 文本
  • CSS 字体
  • CSS 列表
  • CSS 表格

CSS 框模型

  • CSS 框模型概述
  • CSS 内边距
  • CSS 边框
  • CSS 外边距
  • CSS 外边距合并

CSS 定位

  • CSS 定位概述
  • CSS 相对定位
  • CSS 绝对定位
  • CSS 浮动

CSS 高级

  • CSS 尺寸
  • CSS 分类
  • CSS 伪类
  • CSS 伪元素
  • CSS 媒介类型
  • CSS Don't
  • CSS 总结

CSS 实例

  • CSS 实例

参考手册

  • CSS2 参考手册
  • CSS2 打印
  • CSS2 听觉
  • CSS2 单位

CSS Quiz

  • CSS 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 实例

  • Previous Page
  • Next Page

提示：以下例子中的 CSS 代码均位于 HTML 的 head 部分，这样做的目的是为了利于演示例子本身。在实际的开发中，使用 CSS 最好的方式是引用外部样式表。

CSS 背景实例：

设置背景颜色
本例演示如何为元素设置背景颜色。
设置文本的背景颜色
本例颜色如何设置部分文本的背景颜色。
将图像设置为背景
本例演示如何将图像设置为背景。
如何重复背景图像
本例演示如何重复背景图像。
如何在垂直方向重复背景图像
本例演示如何垂直地重复背景图像。
如何在水平方向重复背景图像
本例演示如何水平地重复背景图像。
如何仅显示一次背景图像
本例演示如何仅显示一次背景图像。
如何放置背景图像
本例演示如何在页面上放置背景图像。
如何使用%来定位背景图像
本例演示如何使用百分比来在页面上定位背景图像。
如何使用像素来定位背景图像
本例演示如何使用像素来在页面上定位背景图像。
如何设置固定的背景图像
本例演示如何设置固定的背景图像。图像不会随着页面的其他部分滚动。
所有背景属性在一个声明之中
本例演示如何使用简写属性来将所有背景属性设置在一个声明之中。

例子解释

CSS 文本实例：

设置文本颜色
本例演示如何设置文本的颜色。
设置文本的背景颜色
本例颜色如何设置部分文本的背景颜色。
规定字符间距
本例演示如何增加或减少字符间距。
使用百分比设置行间距
本例演示如何使用百分比值来设置段落中的行间距。
使用像素值设置行间距
本例演示如何使用像素值来设置段落中的行间距。
使用数值来设置行间距
本例演示如何使用一个数值来设置段落中的行间距。
对齐文本
本例演示如何对齐文本。
修饰文本
本例演示如何向文本添加修饰。
缩进文本
本例演示如何缩进文本首行。
控制文本中的字母
本例演示如何控制文本中的字母。
在元素中禁止文本折行
本例演示如何禁止在元素中的文本折行。
增加单词间距
本例演示如何增加段落中单词间的距离。

例子解释

CSS 字体(font)实例：

设置文本的字体
本例演示如何设置文本字体。
设置字体尺寸
本例演示如何设置字体尺寸。
设置字体风格
本例演示如何设置字体风格。
设置字体的异体
本例演示如何设置字体的异体。
设置字体的粗细
本例演示如何设置字体的粗细。
所有字体属性在一个声明之内
本例演示如何使用简写属性将字体属性设置在一个声明之内。

例子解释

CSS 边框(border)实例：

所有边框属性在一个声明之中
本例演示用简写属性来将所有四个边框属性设置于同一声明中。
设置四边框样式
本例演示如何设置四边框样式。
设置每一边的不同边框
本例演示如何在元素的各边设置不同的边框。
所有边框宽度属性在一个声明之中
本例演示用简写属性来将所有边框宽度属性设置于同一声明中。
设置四个边框的颜色
本例演示如何设置四个边框的颜色。可以设置一到四个颜色。
所有下边框属性在一个声明中
本例演示用简写属性来将所有下边框属性设置在同一声明中。
设置下边框的颜色
本例演示如何设置下边框的颜色。
设置下边框的样式
本例演示如何设置下边框的样式。
设置下边框的宽度
本例演示如何设置下边框的宽度。
所有左边框属性在一个声明之中
所有左边框属性在一个声明之中
设置左边框的颜色
本例演示如何设置左边框的颜色。
设置左边框的样式
本例演示如何设置左边框的样式。
设置左边框的宽度
本例演示如何设置左边框的宽度。
所有右边框属性在一个声明之中
本例演示一个简写属性，用于把所有右边框属性设置在一条声明中。
设置右边框的颜色
本例演示如何设置右边框的颜色。
设置右边框的样式
本例演示如何设置右边框的样式。
设置右边框的宽度
本例演示如何设置右边框的宽度。
所有上边框属性在一个声明之中
本例演示用简写属性来将所有上边框属性设置于同一声明之中。
设置上边框的颜色
本例演示如何设置上边框的颜色。
设置上边框的样式
本例演示如何设置上边框的样式。
设置上边框的宽度
本例演示如何设置上边框的宽度。

例子解释

CSS 外边距 (margin) 实例：

设置文本的左外边距
本例演示如何设置文本的左外边距。
设置文本的右外边距
本例演示如何设置文本的右外边距。
设置文本的上外边距
本例演示如何设置文本的上外边距。
设置文本的下外边距
本例演示如何设置文本的下外边距。
所有的外边距属性在一个声明中。
本例演示如何将所有的外边距属性设置于一个声明中。

例子解释

CSS 内边距 (padding) 实例：

所有填充属性在一个声明中
本例演示使用简写属性将所有的填充属性设置于一个声明中，可以有一到四个值。
设置下内边距 1
本例演示如何使用厘米值来设置单元格的下内边距。
设置下内边距 2
本例演示如何使用百分比值来设置单元格的下内边距。
设置左内边距 1
本例演示如何使用厘米值来设置单元格的左内边距。
设置左内边距 2
本例演示如何使用百分比值来设置单元格的左内边距。
设置右内边距 1
本例演示如何使用厘米值来设置单元格的右内边距。
设置右内边距 2
本例演示如何使用百分比值来设置单元格的右内边距。
设置上内边距 1
本例演示如何使用厘米值来设置单元格的上内边距。
设置上内边距 2
本例演示如何使用百分比值来设置单元格的上内边距。

例子解释

CSS 列表实例：

在无序列表中的不同类型的列表标记
本例演示在CSS中不同类型的列表项标记。
在有序列表中不同类型的列表项标记
本例演示在CSS中不同类型的列表项标记。
所有的列表样式类型
本例演示在CSS中所有不同类型的列表项标记。
将图像作为列表项标记
本例演示如何将图像作为列表项标记。
放置列表标记
本例演示在何处放置列表标记。
在一个声明中定义所有的列表属性
本例演示将所有针对列表的属性设置于一个简写属性。

例子解释

CSS 表格实例：

设置表格的布局
本例演示如何设置表格的布局。
显示表格中的空单元
本例演示是否显示表格中的空单元。（请在非 IE 浏览器中浏览）
合并表格边框
本例演示是否把表格边框显示为一条单独的边框，还是像标准的 HTML 中那样分开显示。
设置表格边框之间的空白
本例演示如何设置单元格边框之间的距离。（请在非 IE 浏览器中浏览）
设置表格标题的位置
本例演示如何定位表格的标题。（请在非 IE 浏览器中浏览）

例子解释

轮廓（Outlin） 实例：

在元素周围画线
本例演示使用outline属性在元素周围画一条线。
设置轮廓的颜色
本例演示如何设置轮廓的颜色。
设置轮廓的样式
本例演示如何设置轮廓的样式。
设置轮廓的宽度
本例演示如何设置轮廓的宽度。

CSS 尺寸 (Dimension) 实例：

使用像素值设置图像的高度
本例演示如何使用像素值设置元素的高度。
使用百分比设置图像的高度
本例演示如何使用百分比值来设置元素的高度。
使用像素值来设置元素的宽度
本例演示如何使用像素值来设置元素的宽度。
使用百分比来设置元素的宽度
本例演示如何使用百分比值来设置元素的宽度。
设置元素的最大高度
本例演示如何设置一个元素的最大高度。
使用像素值来设置元素的最大宽度
本例演示如何使用像素值来设置元素的最大高度。
使用百分比来设置元素的最大宽度
本例演示如何使用百分比值来设置元素的最大高度。
使用像素值来设置元素的最小高度
本例演示如何使用像素值来设置元素的最小高度。
使用像素值来设置元素的最小宽度
本例演示如何使用像素值来设置元素的最小宽度。
使用百分比来设置元素的最小宽度
本例演示如何使用百分比值来设置元素的最小宽度。
使用百分比设置行间距
本例演示如何使用百分比值来设置段落中的行间距。
使用像素值设置行间距
本例演示如何使用像素值来设置段落中的行间距。
使用数值来设置行间距
本例演示如何使用一个数值来设置段落中的行间距。

例子解释

CSS 分类 (Classification) 实例：

如何把元素显示为内联元素
本例演示如何把元素显示为内联元素。
如何把元素显示为块级元素
本例演示如何把元素显示为块级元素。
浮动属性的简单应用
使图像浮动于一个段落的右侧。
将带有边框和边界的图像浮动于段落的右侧
使图像浮动于段落的右侧。向图像添加边框和边界。
带标题的图像浮动于右侧
使带有标题的图像浮动于右侧
使段落的首字母浮动于左侧
使段落的首字母浮动于左侧，并向这个字母添加样式。
创建水平菜单
使用具有一栏超链接的浮动来创建水平菜单。
创建无表格的首页
使用浮动来创建拥有页眉、页脚、左侧目录和主体内容的首页。
定位：相对定位
本例演示如何相对于一个元素的正常位置来对其定位。
定位：绝对定位
本例演示如何使用绝对值来对元素进行定位。
定位：固定定位
本例演示如何相对于浏览器窗口来对元素进行定位。
如何使元素不可见
本例演示如何使元素不可见。你希望元素被显示出来，还是不呢？
把表格元素设置为 collapse（请在非 IE 的浏览器中查看）
本例演示如何使表格元素叠加？
改变光标
本例演示如何改变光标。
清除元素的侧面
本例演示如何使用清除元素侧面的浮动元素。

例子解释

CSS 定位 (Positioning) 实例：

定位：相对定位
本例演示如何相对于一个元素的正常位置来对其定位。
定位：绝对定位
本例演示如何使用绝对值来对元素进行定位。
定位：固定定位
本例演示如何相对于浏览器窗口来对元素进行定位。
设置元素的形状
本例演示如何设置元素的形状。此元素被剪裁到这个形状内，并显示出来。
如何使用滚动条来显示元素内溢出的内容
本例演示当元素内容太大而超出规定区域时，如何设置溢出属性来规定相应的动作。
如何隐藏溢出元素中溢出的内容
本例演示在元素中的内容太大以至于无法适应指定的区域时，如何设置 overflow 属性来隐藏其内容。
如何设置浏览器来自动地处理溢出
本例演示如何设置浏览器来自动地处理溢出。
垂直排列图象
本例演示如何在文本中垂直排列图象。
Z-index
Z-index可被用于将在一个元素放置于另一元素之后。
Z-index
上面的例子中的元素已经更改了Z-index。
使用固定值设置图像的上边缘
本例演示如何使用固定值设置图像的上边缘。
使用百分比设置图像的上边缘
本例演示如何使用百分比值设置图像的上边缘。
使用像素值设置图像的底部边缘
本例演示如何使用像素值设置图像的底部边缘。
使用百分比设置图像的底部边缘
本例演示如何使用百分比值设置图像的底部边缘。
使用固定值设置图像的左边缘
本例演示如何使用固定值设置图像的左边缘。
使用百分比设置图像的左边缘
本例演示如何使用百分比值设置图像的左边缘。
使用固定值设置图像的右边缘
本例演示如何使用固定值设置图像的右边缘。
使用百分比设置图像的右边缘
本例演示如何使用百分比值设置图像的右边缘。

例子解释

CSS 伪类 (Pseudo-classes)实例：

超链接
本例演示如何向文档中的超链接添加不同的颜色。
超链接 2
本例演示如何向超链接添加其他样式。
超链接：:focus 的使用
本例演示如何使用 :focus 伪类（无法在 IE 中工作）。
:first-child（首个子对象）
本例演示 :first-child 伪类的用法。
:lang（语言）
本例演示 :lang 伪类的用法。

例子解释

CSS 伪元素 (Pseudo-elements)实例：

制作首字母特效
本例演示如何向文本的首字母添加特效。
制作首行特效
本例演示如何向文本的首行添加特效。

例子解释

  • Previous Page
  • Next Page

CSS 参考手册
CSS 实例
CSS 测验


DHTML 实例

DHTML 教程

  • DHTML 首页
  • DHTML 简介
  • DHTML CSS
  • DHTML DOM
  • DHTML 事件
  • DHTML 总结

DHTML DOM

  • DOM 参考手册

DHTML 实例

  • DHTML 实例
  • DOM 实例

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

DHTML 实例

  • Previous Page
  • Next Page

注释：大部分例子需要 IE 4.0+、Netscape 7+、Mozilla、Firefox 1.0 或者 Opera 7+！

CSS

位置:相对
位置:相对
位置:绝对
可见性
Z-index
Z-index（相反的）
鼠标指针
水印
改变背景颜色

CSS 滤镜属性（仅用于 IE）

滤镜
图像滤镜
滤镜：图像遮罩
滤镜:文本遮罩
光效滤镜
移动光效滤镜
燃烧的标题
阴影标题
从黑白到彩色
渐变显示图像
负片图像
X射线图像
遮罩滤镜
燃烧的链接
阴影链接
摇动的链接
阴影链接
Alpha图像链接
灰色图像链接

事件

onload
onunload
onchange
onsubmit
onreset
onselect
onblur
onfocus
onkeydown
onkeyup
onkeydown vs onkeyup
onkeypress
onmouseover 和 onmouseout
onclick
ondblclick
onmousedown 和 onmouseup
onmousemove
仅用右键 （仅用于 IE）

文本

元素访问
属性改变
内部 HTML 访问
改变内部的 HTML
改变位置
onmousemove
onload 和 onunload
提示工具
打字机效果的消息
更大的文本
滚动文字
闪动的标题

输入表单

同样的表单
同样的表单 2
改变输入栏的背景颜色
改变输入栏的文本颜色
向输入栏插入背景图像
改变单选按钮的背景颜色 （仅用于 IE 和 Opera）
向单选按钮插入背景图像 （仅用于 IE 和 Opera）
选取所有的复选框
改变复选框的背景颜色 （仅用于 Opera）
向复选框插入背景图像 （仅用于 IE 和 Opera）
改变按钮的背景颜色
改变按钮的文本颜色
向按钮插入背景图像
改变下拉列表的背景颜色
改变下拉列表的文本颜色
改变文本框的背景颜色
改变文本框的文本颜色
向文本框插入背景图像

图像

预加载图像
改变图像的尺寸
改变图像的来源
改变图像的来源和尺寸
改变图像的位置
改变背景图像
移动的图像
拖放图像 （仅用于 IE 和 Opera）
图像察看器
带有背景图像的按钮 （仅用于 IE 和 Opera）
摇动的图像
数字时钟

窗口

震动窗口

链接

文本转换
字母间隔
闪光的链接
震动的链接
随机banner

菜单

顶部导航 （仅用于 IE）
左侧导航 （仅用于 IE 和 Opera）
下拉导航 (select box)
顶部下拉
总是在顶部
插入边框 （仅用于 IE 和 Opera）
菜单描述
图像描述
指针描述
指针图像
灰色/彩色图像菜单（仅用于 IE）
垂直滑行 （仅用于 IE 和 Opera）
点击垂直滑行 （仅用于 IE 和 Opera）
水平滑行
点击水平滑行

指针

指针位置
指针文本
指针图像
指针轨迹 （仅用于 IE）

页面进入效果（仅用于 IE）

淡入
矩形回缩
矩形展开
圆形回缩
圆形展开
窗帘上卷
窗帘下放
窗帘右卷
窗帘左卷
垂直百叶窗
水平百叶窗
格子形垂直百叶窗
格子形水平百叶窗
粉粒状
电梯门关闭
电梯门打开
电梯门水平关闭
电梯门水平打开
对角线右上
对角线右下
对角线左上
对角线左下
水平线
垂直线
随机
  • Previous Page
  • Next Page

HTML DOM 参考手册
DHTML 实例


HTML DOM 实例

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM 实例

  • Previous Page
  • Next Page

Anchor 对象

更改一个链接的文本、URL 以及 target
使用 focus() 和 blur()
向超链接添加快捷键

Document 对象

使用 document.write() 向输出流写文本
使用 document.write() 向输出流写 HTML
返回当前文档的标题
返回当前文档的 URL
返回当前文档的 referrer
返回下载当前文档的服务器域名
使用 getElementById()
使用 getElementsByName()
打开一个新的文档，添加一些文本，然后关闭它。
返回文档中锚的数目
返回文档中第一个锚的 innerHTML
计算文档中表单的数目
访问集合中的项目
计算文档中的图像数目

Event 对象

哪个鼠标按钮被点击？
光标的坐标是？
被按的按键的 unicode 是？
相对于屏幕，光标的坐标是？
shift 键被按了吗？
哪个元素被点击了？
哪个事件类型发生了？

Form 和 Input 对象

更改表单的 action 属性
返回向服务器发送数据的 HTTP 方法
提示按钮的 id 和 类型 + 禁用按钮
选定以及不选定 checkbox
一个表单中的若干个 checkbox
Checkbox - 把文本转换为大写
使用单选按钮中的 value 属性
重置表单
提交表单
验证表单
设置和移开文本域上的焦点
选取文本域中的内容
表单中的下拉列表
另一个下拉列表
当达到文本域的最大字符数时跳至下一个域
为若干表单域添加快捷键

Frame、Frameset 以及 IFrame 对象

可调整大小和不可调整大小的框架
带有滚动条和不带有滚动条的框架
更改两个框架的源
跳出框架
更改两个框架的源

Image 对象

更改图像的高度和宽度
更改图像的 src

Location 对象

把用户带到一个新的地址
重新加载文档
跳出框架
锚的数组

Navigator

检测访问者的浏览器和版本号
有关访问者的浏览器的更多信息
有关访问者的浏览器的全部细节
根据浏览器来提醒用户

Option 和 Select 对象

禁用并启用下拉列表
取得包含该下拉列表的表单的 id
取得下拉列表中选项的数目
更改下拉列表中的可见行数
选择下拉列表中的多个选项
输出下拉列表中所有选项的文本（请使用非 IE 的浏览器进行测试）
取得下拉列表中所选的选项的索引位置
更改被选选项
从下拉列表中删除选项

Screen 对象

检测有关客户机的屏幕的细节

Table、TableHeader、TableRow、TableData 对象

更改表格边线的宽度
更改表格的 cellPadding 和 cellSpacing
规定表格的外部边框
规定表格的内部边线
某一行的 InnerHTML
表格单元的 InnerHTML
为表格创建了一个标题
从表格删除行
向表格添加新行 - 然后向其添加内容
向一个已有的行中插入单元格
对齐行中的单元格内容
垂直对齐行中的单元格内容
对齐单元格中的内容
垂直对齐单元格中的内容
更改表格单元格中的内容
更改表元横跨的列数

Window 对象

显示对话框
显示带有折行的对话框
显示确认框
显示提示框
通过点击按钮来打开一个窗口
打开一个新窗口，并控制其外观
通过一次点击打开多个窗口
把用户带到一个新的地址
重新加载文档
在窗口的状态栏设置文本
打印页面
跳出框架
调整窗口的大小
把窗口调整为指定的大小
滚动文档
把窗口滚动到指定的位置
简单的计时
另一个简单的计时
无穷循环中的计时
无穷循环中的计时 - 带有一个停止按钮
一个时钟
创建 pop-up
  • Previous Page
  • Next Page

HTML DOM 参考手册
HTML DOM 实例


HTML 实例

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 实例

  • Previous Page
  • Next Page

HTML 基础标签实例

一个简单的 HTML 文件
这个例子是一个很简单的 HTML 文件，使用了尽可能少的 HTML 标签。它向您演示了 body 元素中的内容是如何被浏览器显示的。
简单的段落
此例演示：段落元素中的文字如何被浏览器显示。
更多的段落
本例演示段落元素的某些缺省的行为。
“诗歌”问题
本例演示 HTML 格式化的某些问题。
折行
本例演示在 HTML 文档中折行的使用。
标题
本例演示在 HTML 文档中显示标题的标签。
居中排列的标题
本例演示一个居中排列的标题。
水平线
本例演示如何插入水平线。
隐藏的注释
本例演示如何在 HTML 源代码中插入隐藏的注释。
背景颜色
本例演示如何为 HTML 页面添加背景颜色。

例子解释

HTML 文本格式化实例

文本格式化
此例演示如何在一个 HTML 文件中对文本进行格式化
预格式文本
此例演示如何使用 pre 标签对空行和空格进行控制。
“计算机输出”标签
此例演示不同的“计算机输出”标签的显示效果。
地址
此例演示如何在 HTML 文件中写地址。
缩写和首字母缩写
此例演示如何实现缩写或首字母缩写。
文字方向
此例演示如何改变文字的方向。
块引用
此例演示如何实现长短不一的引用语。
删除字效果和插入字效果
此例演示如何标记删除文本和插入文本。

例子解释

HTML 链接实例

创建超级链接
本例演示如何在 HTML 文档中创建链接。
将图像作为链接
本例演示如何使用图像作为链接。
在新的浏览器窗口打开链接
本例演示如何在新窗口打开一个页面，这样的话访问者就无需离开你的站点了。
链接到同一个页面的不同位置
本例演示如何使用链接跳转至文档的另一个部分
跳出框架
本例演示如何跳出框架，假如你的页面被固定在框架之内。
创建电子邮件链接
本例演示如何如何链接到一个邮件。（本例在安装邮件客户端程序后才能工作。）
创建电子邮件链接 2
本例演示更加复杂的邮件链接。

例子解释

HTML 框架实例

垂直框架
本例演示：如何使用三份不同的文档制作一个垂直框架。
水平框架
本例演示：如何使用三份不同的文档制作一个水平框架。
如何使用 <noframes> 标签
本例演示：如何使用 <noframes> 标签。
混合框架结构
本例演示如何制作含有三份文档的框架结构，同时将他们混合置于行和列之中。
含有 noresize="noresize" 属性的框架结构
本例演示 noresize 属性。在本例中，框架是不可调整尺寸的。在框架间的边框上拖动鼠标，你会发现边框是无法移动的。
导航框架
本例演示如何制作导航框架。导航框架包含一个将第二个框架作为目标的链接列表。名为 "contents.htm" 的文件包含三个链接。
内联框架
本例演示如何创建内联框架（HTML 页中的框架）。
跳转至框架内的一个指定的节
本例演示两个框架。其中的一个框架设置了指向另一个文件内指定的节的链接。这个"link.htm"文件内指定的节使用 <a name="C10"> 进行标识。
使用框架导航跳转至指定的节
本例演示两个框架。左侧的导航框架包含了一个链接列表，这些链接将第二个框架作为目标。第二个框架显示被链接的文档。导航框架其中的链接指向目标文件中指定的节。

例子解释

HTML 表格实例

表格
这个例子演示如何在 HTML 文档中创建表格。
表格边框
本例演示各种类型的表格边框。
没有边框的表格
本例演示一个没有边框的表格。
表格中的表头(Heading)
本例演示如何显示表格表头。
空单元格
本例展示如何使用 "&nbsp;" 处理没有内容的单元格。
带有标题的表格
本例演示一个带标题 (caption) 的表格
跨行或跨列的表格单元格
本例演示如何定义跨行或跨列的表格单元格。
表格内的标签
本例演示如何显示在不同的元素内显示元素。
单元格边距(Cell padding)
本例演示如何使用 Cell padding 来创建单元格内容与其边框之间的空白。
单元格间距(Cell spacing)
本例演示如何使用 Cell spacing 增加单元格之间的距离。
向表格添加背景颜色或背景图像
本例演示如何向表格添加背景。
向表格单元添加背景颜色或者背景图像
本例演示如何向一个或者更多表格单元添加背景。
在表格单元中排列内容
本例演示如何使用 "align" 属性排列单元格内容,以便创建一个美观的表格。
框架(frame)属性
本例演示如何使用 "frame" 属性来控制围绕表格的边框。

例子解释

HTML 列表实例

无序列表
本例演示无序列表。
有序列表
本例演示有序列表。
不同类型的无序列表
本例演示一个无序列表。
不同类型的有序列表
本例演示不同类型的有序列表。
嵌套列表
本例演示如何嵌套列表。
嵌套列表 2
本例演示更复杂的嵌套列表。
定义列表
本例演示一个定义列表。

例子解释

HTML 表单与输入实例

文本域(Text fields)
本例演示如何在 HTML 页面创建文本域。用户可以在文本域中写入文本。
密码域
本例演示如何创建 HTML 的密码域。
复选框
本例演示如何在 HTML 页中创建复选框。用户可以选中或取消选取复选框。
单选按钮
本例演示如何在 HTML 中创建单选按钮。
简单的下拉列表
本例演示如何在 HTML 页面中创建简单的下拉列表框。下拉列表框是一个可选列表。
另一个下拉列表
本例演示如何创建一个简单的带有预选值的下拉列表。（译者注：预选值指预先指定的首选项。）
文本域(Textarea)
本例演示如何创建一个文本域（多行文本输入控件）。用户可以在文本域中写入文本。在文本域中，可写入的字符字数不受限制。
创建按钮
本例演示如何创建按钮。你可以对按钮上的文字进行自定义。
Fieldset around data
本例演示如何在数据周围绘制一个带标题的框。

表单实例

带有输入框和确认按钮的表单
本例演示如何向页面添加表单。此表单包含两个输入框和一个确认按钮。
带有复选框的表单
此表单包含两个复选框和一个确认按钮。
带有单选按钮的表单
此表单包含两个单选框和一个确认按钮。
从表单发送电子邮件
此例演示如何从表单发送电子邮件。

例子解释

HTML 图像实例

插入图像
本例演示如何在网页中显示图像。
从不同的位置插入图片
本例演示如何将其他文件夹或服务器的图片显示到网页中。
背景图片
本例演示如何向 HTML 页面添加背景图片。
排列图片
本例演示如何在文字中排列图像。
浮动图像
本例演示如何使图片浮动至段落的左边或右边。
调整图像尺寸
本例演示如何将图片调整到不同的尺寸。
为图片显示替换文本
本例演示如何为图片显示替换文本。在浏览器无法载入图像时，替换文本属性告诉读者们失去的信息。为页面上的图像都加上替换文本属性是个好习惯。
制作图像链接
本例演示如何将图像作为一个链接使用。
创建图像映射
本例显示如何创建带有可供点击区域的图像地图。其中的每个区域都是一个超级链接。
把图像转换为图像映射
本例显示如何把一幅普通的图像设置为图像映射。

例子解释

HTML 背景实例

搭配良好的背景和颜色
一个背景颜色和文字颜色搭配良好的例子，使页面中的文字易于阅读。
搭配得不好的背景和颜色
一个背景颜色和文字颜色搭配得不好的例子，使页面中的文字难于阅读。
可用性强的背景图像
背景图像和文字颜色使页面文本易于阅读的例子。
可用性强的背景图像 2
另一个背景图像和文字颜色使页面文本易于阅读的例子。
可用性差的背景图像
背景图像和文字颜色使页面文本不易阅读的例子。

例子解释

HTML 样式 (style) 实例

HTML中的样式
本例演示如何使用添加到 <head> 部分的样式信息对 HTML 进行格式化。
没有下划线的链接
本例演示如何使用样式属性做一个没有下划线的链接。
链接到一个外部样式表
本例演示如何 <link> 标签链接到一个外部样式表。

例子解释

HTML 头部 (head) 实例

文档的标题
头元素内部的标题信息不会显示在浏览器窗口中。
一个 target，所有的链接
本例显示如何使用 base 标签使页面中的所有标签在新窗口中打开。

例子解释

HTML 元信息 (meta) 实例

文档描述
Meta 元素中的信息可以描述 HTML 文档。
文档关键字
Meta 元素中的信息可以描述文档的关键词。
重定向
这个例子演示：在网址已经变更的情况下，将用户重定向到另外一个地址。

例子解释

HTML 脚本 (Script) 实例

插入一段脚本
本例演示如何将脚本插入 HTML 文档。
运行于不支持脚本的浏览器
本例演示如何对付不支持脚本的浏览器。

例子解释

  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


JavaScript 对象 实例

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 对象 实例

  • Previous Page
  • Next Page

JavaScript String（字符串）对象 实例

返回字符串的长度
为字符串添加样式
返回字符串中指定文本首次出现的位置 - indexOf()方法
查找字符串中特定的字符，若找到，则返回该字符 - match() 方法
替换字符串中的字符 - replace()

参阅： JavaScript String 对象参考手册。

JavaScript Date（日期）对象 实例

使用 Date() 方法来返回今天的日期和时间
使用 getTime() 计算从1970年到今天有多少年
使用 setFullYear() 设置具体的日期
使用 toUTCString() 把当日的日期（根据 UTC）转换为字符串
使用 getDay() 来显示星期，而不仅仅是数字
显示一个钟表

参阅： JavaScript Date 对象参考手册。

JavaScript Array（数组）实例

创建数组
使用 for...in 声明来遍历数组中的元素
合并两个数组 - concat()
用数组的元素组成字符串 - join()
文字数组 - sort()
数字数组 - sort()

参阅： JavaScript Array 对象的参考手册。

JavaScript Boolean（布尔）对象 实例

检查逻辑值

参阅： JavaScript Boolean 对象的参考手册。

JavaScript Math（算数对象）实例

使用 round() 对数字进行舍入
使用 random() 来返回 0 到 1 之间的随机数
使用 max() 来返回两个给定的数中的较大的数
使用 min() 来返回两个给定的数中的较小的数

参阅： JavaScript Math 对象的参考手册。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 实例

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 实例

  • Previous Page
  • Next Page

基础 JavaScript 实例

生成文本
生成普通文本和标签
head 部分
body 部分
外部 JavaScript

例子解释

JavaScript 语句、注释和代码块

JavaScript 语句
JavaScript 代码块
JavaScript 单行注释
JavaScript 多行注释
使用单行注释来防止执行
使用多行注释来防止执行

例子解释

JavaScript 变量

声明一个变量，为它赋值，然后显示出来

例子解释

JavaScript 条件语句 If ... Else

If 语句
If...else 语句
If..else if...else 语句
随机链接

例子解释

JavaScript 消息框

警告框
带有折行的警告框
确认框
提示框

例子解释

JavaScript 函数

函数
带有参数的函数
带有参数的函数 2
返回值的函数
带有参数并返回值的函数

例子解释

JavaScript 循环

For 循环
循环产生 HTML 标题
While 循环
Do while 循环
break 语句
continue 语句
使用 For...In 声明来遍历数组内的元素

例子解释

JavaScript 错误处理

try...catch 语句
带有确认框的 try...catch 语句
throw 声明
onerror 事件

例子解释

高级 JavaScript 实例

检测浏览器及版本
检测浏览器的更多信息
检测浏览器的全部信息
根据浏览器类型提醒用户
创建一个欢迎 cookie
按钮动画
添加了 JavaScript 的图像映射
简单的计时
另一个简单的计时
在一个无穷循环中的计时事件
带有停止按钮的无穷循环中的计时事件
使用计时事件制作的钟表
创建对象的实例
创建用于对象的模板
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


VBScript 实例

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript 实例

  • Previous Page
  • Next Page

基础

使用VBScript写文本
使用HTML标签格式化文本
head部分中的函数
body部分中的脚本

变量

创建一个变量
在一段文本中插入变量的值
创建数组

程序

子程序
函数程序

条件语句

If...then..else 语句
If...then..elseif 语句
Select case 语句
随机链接

循环

For..next 循环
循环输出HTML标题
For..each 循环
Do...While 循环

日期和时间函数

显示日期和时间
显示星期
显示月份
显示当前的月份和星期
倒记秒数到3000年
向日期增加一个时间间隔
格式化日期和时间
这是一个日期吗？

其他内建函数

大写或小写字符？
删除字符串端部的空格
颠倒字符顺序
对一个数字进行取整数操作
返回随机数
返回0-99之间的随机数
从一段字符串的左侧或右侧返回指定数目的字符
替换字符串中的某些字符
从一段字符串返回指定数目的字符
  • Previous Page
  • Next Page

VBScript 参考手册
VBScript 实例


XML DOM 实例

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM 实例

  • Previous Page
  • Next Page

XML DOM 解析

在下面的例子中使用的 XML 文件：books.xml

加载并解析 XML 文件
加载并解析 XML 字符串

例子解释

XML DOM 属性和方法

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

函数 loadXMLString()，位于外部 JavaScript 中，用于加载 XML 字符串。

加载并解析 XML 文件
加载并解析 XML 字符串

例子解释

XML DOM 访问节点

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

使用节点列表中的下标号来访问节点
使用 length 属性来循环节点
查看元素的节点类型
循环元素节点
使用节点的关系来循环元素节点

例子解释

XML DOM 节点信息

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

获取元素节点的节点名称
从文本节点获取文本
更改文本节点中的文本
获取元素节点的节点名称和类型

例子解释

XML DOM 节点列表和属性列表

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

从第一个 <title> 元素获取文本
通过使用 length 属性来循环节点
获取元素的属性

例子解释

XML DOM 遍历节点树

下面的例子使用 XML 文件 books.xml。

函数 loadXMLString()，位于外部 JavaScript 中，用于加载 XML 文件。

遍历一棵节点树
循环 <book> 元素的所有子节点。

例子解释

XML DOM 浏览器差异

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

显示节点列表的长度
本例显示了一个节点列表的长度。在 IE 和其他浏览器中，结果是不同的。
忽略节点间的空文本
本例检查节点的 nodeType，且仅处理元素节点。

例子解释

XML DOM 定位节点

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

获取节点的父节点
获取节点的首个子节点
获取节点的最后一个子节点
获取节点的下一个同级元素
获取节点的上一个同级元素

例子解释

XML DOM 获取节点值

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

获取元素的值
获取属性的值

例子解释

XML DOM 改变节点值

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

改变元素的文本节点
通过使用 setAttribute 来改变属性的值
通过使用 nodeValue 来改变属性值

例子解释

XML DOM 删除节点

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

删除元素节点
删除当前元素节点
删除文本节点
清空文本节点的文本
根据名称删除属性
根据对象删除属性

例子解释

XML DOM 替换节点

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

替换元素节点
替换文本节点中的数据

例子解释

XML DOM 创建节点

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

创建元素节点
通过使用 createAttribute 来创建属性节点
通过使用 setAttribute 来创建属性节点
创建文本节点
创建一个 CDATA section 节点
创建注释节点

例子解释

XML DOM 添加节点

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

在最后一个子节点之后添加一个节点
在指定的子节点之前添加一个节点
添加一个新属性
向文本节点添加数据

例子解释

XML DOM 克隆节点

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

复制一个节点，并把它追加到已有的节点
本例使用 cloneNode() 来复制一个节点，并把它追加到 XML 文档的根节点。

例子解释

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML 实例

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML 实例

  • Previous Page
  • Next Page

这些例子演示了 XML 文件、XML 格式化和 XML 转换（XSLT）。

还演示了与 XML 一起使用的 JavaScript （AJAX）。

查看 XML 文件

查看一个简单的 XML 文件
查看带有一个错误的 XML 文件
查看一个 XML 的 CD 目录
查看一个 XML 的植物目录
查看一个 XML 菜单

例子解释

XML 和 CSS

查看一个 XML 的 CD 目录
查看对应的 CSS 文件
显示这个由 CSS 文件格式化的 CD 目录

例子解释

XML 和 XSLT

查看 XML 菜单
查看对应的 XSLT 样式表
显示这个由 XSLT 样式表格式化的菜单 (IE6)
显示这个由 XSLT 样式表格式化的菜单 (IE5)

例子解释

通过 JavaScript 来解析 XML

查看一个简单的 XML 文件
加载并解析 XML 文件
加载并解析 XML 字符串
遍历 XML 节点树

例子解释

XML to HTML

查看一个 XML 的 CD 目录
把 XML 数据显示为 HTML 表格

例子解释

使用 XMLHttpRequest 对象

当键入文本时与服务器进行 XML HTTP 通信
通过 XML HTTP 加载一个 XML 文件 (JavaScript)
通过 XML HTTP 加载一个XML文件 (VBScript)
通过 XML HTTP 向一个 div 元素加载文本文件 (JavaScript)
通过 XML HTTP 进行一次报头（HEAD）请求 (JavaScript)
通过 XML HTTP 进行一次指定的报头（HEAD）请求 (JavaScript)
把 XML 文件显示为 HTML 表格

例子解释

XML 应用程序

查看一个 XML CD 目录
在 HTML 表格中显示 XML 数据
在 <div> 元素中显示 XML 数据
在 XML 记录中导航
一个简单的 CD 目录应用程序

例子解释

XML DOM 高级

获取 XML 元素的值
获取 XML 属性的值
改变 XML 元素的值
改变 XML 属性的值
创建新的 XML 元素
删除 XML 元素

例子解释

  • Previous Page
  • Next Page

XML 实例
XML 测验


 CustomerID = Nokia
CompanyName = Nokia Corporation
ContactName = Olli-Pekka Kallasvuo
Address = P.O. Box 226, FIN-00045 Nokia Group, Finland
City = Helsinki
PostalCode = none
Country = Finland

CustomerID = Google
CompanyName = Google, Inc.
ContactName = Larry Page
Address = 1600 Amphitheatre Parkway Mountain View, CA 94043
City = Mountain View
PostalCode = 94043
Country = USA

CustomerID = SONY
CompanyName = Sony Corporation of America
ContactName = Kazuo Hirai
Address = Park Ridge, NJ 07656
City = Park Ridge
PostalCode = 07656
Country = USA

CustomerID = APPLE
CompanyName = Apple Computer, Inc.
ContactName = Steven Jobs
Address = 1 Infinite Loop Cupertino, CA 95014
City = Cupertino
PostalCode = 95014
Country = USA

CustomerID = BAIDU
CompanyName = BAIDU, Inc
ContactName = Li YanHong
Address = Lixiang guoji dasha,No 58, beisihuanxilu
City = Beijing
PostalCode = 100080
Country = China

CustomerID = Canon
CompanyName = Canon USA, Inc.
ContactName = Tsuneji Uchida
Address = One Canon Plaza Lake Success, NY 11042
City = New York
PostalCode = 11042
Country = USA


Nokia Corporation | Olli-Pekka Kallasvuo
Google, Inc. | Larry Page
Sony Corporation of America | Kazuo Hirai
Apple Computer, Inc. | Steven Jobs
BAIDU, Inc | Li YanHong
Canon USA, Inc. | Tsuneji Uchida


Companyname | Contactname
Nokia Corporation | Olli-Pekka Kallasvuo
Google, Inc. | Larry Page
Sony Corporation of America | Kazuo Hirai
Apple Computer, Inc. | Steven Jobs
BAIDU, Inc | Li YanHong
Canon USA, Inc. | Tsuneji Uchida


This example returns the value of the first column in the first two records:

Nokia
Google

This example returns the value of the first three columns in the first record:

Nokia
Nokia Corporation
Olli-Pekka Kallasvuo


Companyname | Contactname
Apple Computer, Inc. | Steven Jobs


Companyname | Contactname
Nokia Corporation | Olli-Pekka Kallasvuo
Google, Inc. | Larry Page
Sony Corporation of America | Kazuo Hirai


Companyname Contactname


Choose Country


Companyname | Contactname
Apple Computer, Inc. | Steven Jobs
BAIDU, Inc | Li YanHong
Canon USA, Inc. | Tsuneji Uchida
Google, Inc. | Larry Page
Nokia Corporation | Olli-Pekka Kallasvuo
Sony Corporation of America | Kazuo Hirai


Companyname | Contactname
Sony Corporation of America | Kazuo Hirai
Nokia Corporation | Olli-Pekka Kallasvuo
Google, Inc. | Larry Page
Canon USA, Inc. | Tsuneji Uchida
BAIDU, Inc | Li YanHong
Apple Computer, Inc. | Steven Jobs


Apple Computer, Inc. | Steven Jobs
BAIDU, Inc | Li YanHong
Canon USA, Inc. | Tsuneji Uchida
Google, Inc. | Larry Page
Nokia Corporation | Olli-Pekka Kallasvuo
Sony Corporation of America | Kazuo Hirai


Sony Corporation of America | Kazuo Hirai
Google, Inc. | Larry Page
BAIDU, Inc | Li YanHong
Nokia Corporation | Olli-Pekka Kallasvuo
Apple Computer, Inc. | Steven Jobs
Canon USA, Inc. | Tsuneji Uchida


这是另一个文本文件 - 在不重新载入页面的情况下显示了出来。这就是 XML HTTP request 对象的工作原理！


这是一个通过使用 XML HTTP request 来显示文本文件的测试。
如果显示了文本，说明测试成功！


/example/aspe/demo_aspe_contentlinking2.asp		Page 1
/example/aspe/page2.asp							Page 2
/example/aspe/page3.asp							Page 3


*
/i/eg_banner_htmlref.gif
http://www.w3school.com.cn/html/html_reference.asp
Complete HTML 4.0 Reference
20
/i/eg_banner_w3school.gif
http://www.w3school.com.cn/
Web Tutorials from W3School
20
/i/eg_banner_jsref.gif
http://www.w3school.com.cn/js/js_reference.asp
JavaScript Reference
20


asp_intro.asp	ASP 简介
asp_syntax.asp	ASP 语法
asp_variables.asp	ASP 变量
asp_procedures.asp	ASP 程序


 Web Tutorials from W3School

注释：由于图像是随机变化的， 同时由于本页可供选择的图片很少， 因此经常会出现两次显示同一广告的情况。

查看 advertisements.txt


注释：由于图像是随机变化的， 同时由于本页可供选择的图片很少， 因此经常会出现两次显示同一广告的情况。

查看 advertisements2.txt


 George
John
Thomas
James
Adrew
Martin


 文件 testread.txt 的属性是：0


客户机操作系统 | WinNT
Web 浏览器 | IE
浏览器版本 | 5.0
框架支持 | True
表格支持 | True
音频支持 | True
Cookies 支持 | True
VBScript 支持 | True
JavaScript 支持 | True


当您的 response 缓存清空时，这段文本就会发送到浏览器。


This is some text


您喜欢哪些水果：

Apple
Orange
Banana


 He

指针目前位于文本文件中的位置 3。


下面的例子构建了一个内容列表：

  • ASP 简介
  • ASP 语法
  • ASP 变量
  • ASP 程序

文本文件包含页面 URL 的列表和链接描述。 每行文本针对一个页面。 请注意，URL 和描述必须由 TAB 字符分隔。

查看 links.txt


这是页面 1

下一页

本例使用 Content Linking 组件 对文本文件中的 URL 进行导航。

查看 links2.txt


注释：如果服务器未安装 ASP 3.0，则本例无法运行。

查看 textads.txt

注释：由于文本文件中的内容字符串是随机改变的， 同时本页只有四条内容可供选择， 因此，有时页面会连续显示两次相同的内容。


This is some text.


之前，您已经访问过本页面 2 次。


 key/item 对的数目是：2


 文件 testread.txt 的创建时间是：12/04/2007 21:34:17


 文件 testread.txt 的最后访问时间是：28/01/2009 15:34:04


 文件 testread.txt 的最后修改时间是：12/04/2007 21:34:17


 驱动器 c: 存在。
驱动器 g: 存在。


 驱动器字母是：C


 驱动器类型是：2


我正在写文本。这些文本不会被


 键存在。


每当被访问，本页都会被刷新！


本页面的缓存会在该日期失效：05, 2001 05:30:30！


 文件 c:\windows\cursors\xxx.cur 不存在。


 文件夹 c:\temp 不存在。


First name:
Last name:

来自上面的表单的信息：


您可以使用 HTML 标签来格式化文本

这段文本的样式是通过 style 属性添加的。


Header 1

Header 2

Header 3

Header 4

Header 5
Header 6


 abc
cursors
windows


 驱动器名称是：c:


 文件 3dgarro 的文件扩展名是：cur


 这个文件名的最后一个成分是：abc.cur


 c:\windows\cursors\abc.cur 的父文件夹名称是：c:\winnt\cursors


默认 Timeout 是：30 分钟。

现在的 Timeout 是 30 分钟。


本页已被访问了 13970 次。


 用户仍然保持连接。


 此 C 驱动器未就绪。


 项目 i 的值是：Italy


项目的值是：

China
Italy


结果：12


Wed Jan 28 16:19:38 UTC+0800 2009 (Beijing Time)

Good day!


 键 i 已设置为 it，其值是：Italy


键的值是：

c
i


 本文件的最后修改时间是：21/09/2008 20:42:29


这是文本文件中的所有行（带有行号）：

Line:1 Hello!
Line:2 How are you today?


 路径是：C:


请选择您喜欢的汽车：

Volvo
Saab
BMW


 W3School.com.cn!

本例演示一个链接，每当您加载本页时，就会显示两个链接之一：W3School.com.cn! 或 news.cn！各占百分之五十的几率。


这是从文本文件中读取的第一行：

Hello!


这是从文本文件中读取的所有行：

Hello!
How are you today?


这是从文本文件中读取的前 5 个字符：

Hello


这就是文本文件中的文本：

Hello! How are you today?


服务器实例
文本实例


您的姓名：


First name:
Last name:


您正在通过这款浏览器访问我们的站点： Mozilla/4.0 (compatible; MSIE 5.0; Windows NT 4.0)

您的 IP 地址是： 124.229.222.37

IP 地址的 DNS 查询是： 124.229.222.37

调用该页面所用的方法是： GET

服务器的域名： www.w3school.com.cn

服务器的端口： 80

服务器的软件： Microsoft-IIS/5.0


所有可能的服务器变量：

ALL_HTTP
ALL_RAW
APPL_MD_PATH
APPL_PHYSICAL_PATH
AUTH_PASSWORD
AUTH_TYPE
AUTH_USER
CERT_COOKIE
CERT_FLAGS
CERT_ISSUER
CERT_KEYSIZE
CERT_SECRETKEYSIZE
CERT_SERIALNUMBER
CERT_SERVER_ISSUER
CERT_SERVER_SUBJECT
CERT_SUBJECT
CONTENT_LENGTH
CONTENT_TYPE
GATEWAY_INTERFACE
HTTPS
HTTPS_KEYSIZE
HTTPS_SECRETKEYSIZE
HTTPS_SERVER_ISSUER
HTTPS_SERVER_SUBJECT
INSTANCE_ID
INSTANCE_META_PATH
LOCAL_ADDR
LOGON_USER
PATH_INFO
PATH_TRANSLATED
QUERY_STRING
REMOTE_ADDR
REMOTE_HOST
REMOTE_USER
REQUEST_METHOD
SCRIPT_NAME
SERVER_NAME
SERVER_PORT
SERVER_PORT_SECURE
SERVER_PROTOCOL
SERVER_SOFTWARE
URL
HTTP_ACCEPT
HTTP_ACCEPT_LANGUAGE
HTTP_CONNECTION
HTTP_HOST
HTTP_REFERER
HTTP_USER_AGENT
HTTP_COOKIE
HTTP_IF_MODIFIED_SINCE


 965150612


 Example color=green


 Example


文本文件中的前 4 个字符被略掉了：

o! How are you today?


文本文件中的第一行被略掉了：

How are you today?


 Hello World!


 Hello World line 1
Hello World line 2
Hello World line 3

查看此文本文件


请键入一些字符：


 My name is: Donald Duck


您可以像这样调用一个程序：

结果：12

或者，像这样：

结果：12


结果：12

结果：12


28/01/2009 16:19:37 (Beijing Time)

Good day!


Hello World line 1
Hello World line 2
Hello World line 3


这是页面 2

上一页

下一页


%% #1

This is a great day!!

%% #2

<h1>Smile</h1>

%% #3

<img src="smiley.gif">

%% #4

这是一个 <a href="http://www.w3school.com.cn">链接</a>。


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="blendtrans(duration=3.0)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=0)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=1)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=2)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=3)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=4)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=5)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=6)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=7)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=8)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=9)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=10)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=11)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=12)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=13)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=14)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=15)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=16)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=17)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=18)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=19)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=20)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=21)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=22)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


This page contains a "Page-Enter" meta tag

Insert the following code line into the <head> section, and your web page will achieve the same effect:

<meta http-equiv="Page-Enter" content="revealtrans(duration=2,transition=23)">
  • The content attribute describes the effect
  • The duration property describes how many seconds before the effect is completed
  • The transition property describes which actual effect your document will have, from 0-23


]> George John Reminder Don't forget the meeting! I love you


Right-click in this window and select "View source" to see the HTML source!

Anchor 0
  • BMW
  • Volvo
  • Saab
Anchor 1
  • Red
  • Green
  • Blue
Anchor 2
  • Jazz
  • Rock
  • Pop
Anchor 3
  • China
  • Italy
  • Spain


Frame A


Frame B


Frame C


Frame D


Try to resize the frames.


 没有锚的链接
带有锚的链接


 Frame a
Frame b
Frame c


Chapter 1

This chapter explains ba bla bla

Chapter 2

This chapter explains ba bla bla

Chapter 3

This chapter explains ba bla bla

Chapter 4

This chapter explains ba bla bla

Chapter 5

This chapter explains ba bla bla

Chapter 6

This chapter explains ba bla bla

Chapter 7

This chapter explains ba bla bla

Chapter 8

This chapter explains ba bla bla

Chapter 9

This chapter explains ba bla bla

Chapter 10

This chapter explains ba bla bla

Chapter 11

This chapter explains ba bla bla

Chapter 12

This chapter explains ba bla bla

Chapter 13

This chapter explains ba bla bla

Chapter 14

This chapter explains ba bla bla

Chapter 15

This chapter explains ba bla bla

Chapter 16

This chapter explains ba bla bla

Chapter 17

This chapter explains ba bla bla


最后一页

祝贺！

您已到达因特网的最后一页。祝您网上冲浪愉快。

现在，确实没有什么可浏览的内容了。您可以安全地关闭计算机，然后回到现实生活中。


Harry Potter

 Harry Potter J K. Rowling 2005 29.99 Everyday Italian Giada De Laurentiis 2005 30.00 Learning XML Erik T. Ray 2003 39.95 XQuery Kick Start James McGovern Per Bothner Kurt Cagle James Linn Vaidyanathan Nagarajan 2003 49.99


Empire Burlesque

 Empire Burlesque Bob Dylan USA Columbia 10.90 1985 Hide your heart Bonnie Tyler UK CBS Records 9.90 1988 Greatest Hits Dolly Parton USA RCA 9.90 1982 Still got the blues Gary Moore UK Virgin records 10.20 1990 Eros Eros Ramazzotti EU BMG 9.90 1997 One night only Bee Gees UK Polydor 10.90 1998 Sylvias Mother Dr.Hook UK CBS 8.10 1973 Maggie May Rod Stewart UK Pickwick 8.50 1990 Romanza Andrea Bocelli EU Polydor 10.80 1996 When a man loves a woman Percy Sledge USA Atlantic 8.70 1987 Black angel Savage Rose EU Mega 10.90 1995 1999 Grammy Nominees Many USA Grammy 10.20 1999 For the good times Kenny Rogers UK Mucik Master 8.70 1995 Big Willie style Will Smith USA Columbia 9.90 1997 Tupelo Honey Van Morrison UK Polydor 8.20 1971 The very best of Cat Stevens UK Island 8.90 1990 Stop Sam Brown UK A and M 8.90 1988 Bridge of Spies T'Pau UK Siren 7.90 1987 Private Dancer Tina Turner UK Capitol 8.90 1983 Midt om natten Kim Larsen EU Medley 7.80 1983 Pavarotti Gala Concert Luciano Pavarotti UK DECCA 9.90 1991 The dock of the bay Otis Redding USA Atlantic 7.90 1987 Picture book Simply Red EU Elektra 7.20 1985 Red The Communards UK London 7.80 1987 Unchain my heart Joe Cocker USA EMI 8.20 1987


Empire Burlesque

 Empire Burlesque Bob Dylan USA Columbia 10.90 1985 Hide your heart Bonnie Tyler UK CBS Records 9.90 1988 Greatest Hits Dolly Parton USA RCA 9.90 1982 Still got the blues Gary Moore UK Virgin records 10.20 1990 Eros Eros Ramazzotti EU BMG 9.90 1997 One night only Bee Gees UK Polydor 10.90 1998 Sylvias Mother Dr.Hook UK CBS 8.10 1973 Maggie May Rod Stewart UK Pickwick 8.50 1990 Romanza Andrea Bocelli EU Polydor 10.80 1996 When a man loves a woman Percy Sledge USA Atlantic 8.70 1987 Black angel Savage Rose EU Mega 10.90 1995 1999 Grammy Nominees Many USA Grammy 10.20 1999 For the good times Kenny Rogers UK Mucik Master 8.70 1995 Big Willie style Will Smith USA Columbia 9.90 1997 Tupelo Honey Van Morrison UK Polydor 8.20 1971 The very best of Cat Stevens UK Island 8.90 1990 Stop Sam Brown UK A and M 8.90 1988 Bridge of Spies T`Pau UK Siren 7.90 1987 Private Dancer Tina Turner UK Capitol 8.90 1983 Midt om natten Kim Larsen EU Medley 7.80 1983 Pavarotti Gala Concert Luciano Pavarotti UK DECCA 9.90 1991 The dock of the bay Otis Redding USA Atlantic 7.90 1987 Picture book Simply Red EU Elektra 7.20 1985 Red The Communards UK London 7.80 1987 Unchain my heart Joe Cocker USA EMI 8.20 1987


Everyday Italian

 Everyday Italian Giada De Laurentiis 2005 30.00 Harry Potter J K. Rowling 2005 29.99 XQuery Kick Start James McGovern Per Bothner Kurt Cagle James Linn Vaidyanathan Nagarajan 2003 49.99 Learning XML Erik T. Ray 2003 39.95


 George John Reminder French: êèé


 George John Reminder French: 觇�


-
( calories per serving)


This is a test of using an XML HTTP request to show a text file.
If this text is inside a textarea, it worked!


This is another text file that is shown in the textarea - WITHOUT re-loading the page! This is how the XML HTTP request object works!


电子商务主机

网站主机教程

  • 教程首页
  • 网站主机简介
  • 主机提供商
  • 域名
  • 主机性能
  • 电子邮件服务
  • 主机技术
  • 主机数据库
  • 主机类型
  • 电子商务主机

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

电子商务主机

  • Previous Page
  • Next Page

如果您的公司正在销售某种产品或服务，那么电子商务也许是做生意的一种好办法。

Internet 商业

电子商务就是在 Internet 上销售产品或服务。

如果您的公司正在销售某种产品或服务，那么电子商务也许是做生意的一种好办法。在 Internet 上，您可接触到大量的客户。

电子商务系统

对于小公司来说，自己建立一套电子商务系统不是一个理想的做法。构建一套电子商务系统是一个复杂的过程，其中可能会出现很多潜在的错误。

您可以购买一套现成的系统，在自己的服务器上运行。目前市场上有很多系统，其中大部分都可满足您的基本需要，比如订单管理和处理。但是还要指出的是，如果您对网站的主机不是很熟悉，最好不要马上就开始运行电子商务网站。

最好的解决方案，在我们的看来，就是选择一家能够提供电子商务解决方案的主机提供商。

主机提供商

电子商务可涵盖大范围的产品。而通过不同的提供商，您能够选择从极简单到极复杂的解决方案。

大多数提供商提供简单的价格不高的解决方案，您可借此来运行您自己的“虚拟商店”。

您的检验表

  • 如何处理客户信息？
  • 如何处理产品目录？
  • 如何处理订单？
  • 如何处理库存？
  • 如何处理延期交货？
  • 如何处理货运？
  • 如何处理帐目？
  • 如何处理支付？
  • 如何处理国外货币？
  • 如何处理信用卡？
  • 如何处理税务？
  • 如何解决安全问题？
  • 如何解决完整性问题（加密技术）？

还要检查一下这些相当费时的任务是否能够自动完成。比如自动开单据、发票处理、记帐以及报告生成。

  • Previous Page
  • Next Page


网站主机的服务器技术

网站主机教程

  • 教程首页
  • 网站主机简介
  • 主机提供商
  • 域名
  • 主机性能
  • 电子邮件服务
  • 主机技术
  • 主机数据库
  • 主机类型
  • 电子商务主机

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

网站主机的服务器技术

  • Previous Page
  • Next Page

本节介绍一些最常用的的主机技术。

Windows 主机

Windows 主机是运作在 Windows 操作系统上的主机服务。

如果您使用ASP作为服务器脚本，或者计划使用微软的 Access 或 SQL Server 数据库的话，就应该选择 Windows 平台的主机。另外，如果您计划使用 Microsoft Front Page 来开发网站的话，Windows 主机也是最佳的选择。

Unix 主机

Unix 主机是运作在 Unix 操作系统上的主机服务。

Unix 是首个（或最原始的）web 服务器操作系统，并以可靠性和稳定性而闻名。而且价格也通常低于 Windows 。

Linux 主机

Linux 主机是运作在 Linux 操作系统上的主机服务。

CGI

网页可作为 CGI 脚本来执行。CGI 脚本可在服务器上执行，来生成动态的交互性页面。

大多数的 ISP 都会提供对 CGI 的某种程度的支持。并且许多都提供了使用 CGI 编写的预先安装的可运行的留言簿、页面计数器以及聊天/论坛解决方案。

CGI 最常使用在 Unix 或 Linux 服务器。

ASP - Active Server Pages

ASP 是由微软公司研发的服务器端脚本技术。

通过把脚本代码放到 HTML 页面内，您可以使用 ASP 来创建动态的网页。在页面返回浏览器之前，代码会首先被服务器执行。而且 Visual Basic 和 JavaScript 都可使用。

ASP 是 Windows 95,98, 2000 以及 XP 中的标准组件。可在所有运行 Windows 的计算机上激活 ASP 。

许多的主机提供商都提供 ASP 支持，ASP 技术在中国已经很流行了。

如果您需要学习更多有关 ASP 的知识，请访问我们的 ASP 教程。

Chili!Soft ASP

微软的 ASP 技术只能运行在 Windows 平台。

不过，Chili!Soft ASP 则是一种使得 ASP 可运行在 UNIX 和其他平台的软件产品。

JSP

JSP 是一种由 SUN 开发的类似 ASP 的服务器端技术。

通过 JSP，您可以通过把 Java 代码放入 HTML 页面来创建动态页面。在页面返回浏览器之前，代码同样会首先被服务器执行。

由于 JSP 使用 Java，此技术不会受限于任何的服务器平台。

FrontPage

FrontPage 是由微软开发的网站设计工具。

在用户不具备深入的 web 开发知识的情况下，就可以使用FrontPage开发出一个网站。大多数 Windows 主机解决方案都支持 FrontPage 服务器扩展，这样用户就能使用 FrontPage 来开发他们的网站了。

如果您计划使用 FrontPage，就应该选择一套 Windows 主机解决方案（而不是Unix / Linux）。

PHP

类似 ASP，PHP 也是一门服务器端脚本语言，通过把脚本代码放到 HTML 页面内，您可以使用 PHP 来创建动态的网页。在页面返回浏览器之前，代码会首先被服务器执行。

Cold Fusion

Cold Fusion 是另一门用来创建动态网页的服务器端脚本语言。

Cold Fusion 是由 Macromedia 开发的。

  • Previous Page
  • Next Page


网站主机的类型

网站主机教程

  • 教程首页
  • 网站主机简介
  • 主机提供商
  • 域名
  • 主机性能
  • 电子邮件服务
  • 主机技术
  • 主机数据库
  • 主机类型
  • 电子商务主机

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

网站主机的类型

  • Previous Page
  • Next Page

网站主机的类型有：免费主机、虚拟（分享的）主机或独享主机。

免费主机

一些服务提供商会提供免费的网站主机。

免费主机适合小型的低流量站点，比如家庭站点或者业务爱好的站点。但是不推荐高流量或商业网站使用免费的主机，因为常会有技术上的限制，能够选择的选项也很少。

通常，您无法在免费主机上使用自己的域名。而不得不使用由主机提供的地址，类似这样：http://www.freesite/users/~yoursite.htm。这样的 URL 难写、难记，也很不专业。

优点 | 缺点
费用低。免费的 | 没有域名。
适合家庭、业务爱好或个人站点。 | 极少的、有限制的或根本没有软件选项。
通常会有免费的电子邮件。 | 有限的安全选项。
 | 有限的或没有数据库支持
 | 有限的技术支持

分享型的主机（虚拟主机）

虚拟主机是最常见的、也是最合算的。

使用虚拟主机的话，您的网站与其余的也许是 100 个网站会被寄存在同一个高性能的服务器上。在一个虚拟主机上，每一个网站都可以使用属于自己的域名。

虚拟主机通常会提供多种软件解决方案，比如电子邮件、数据库、许多不同的编辑选项。技术支持往往也不错。

优点 | 缺点
低成本。与其他用户分担费用。 | 由于许多站点在一台服务器上而降低的安全性。
适合小型的商业和中等的流量。 | 在流量上有限制。
多种软件选项。 | 有限制的数据库支持。
自己的域名。 | 有限制的软件支持。
良好的服务支持。 |

专享主机

您可以通过专享的主机服务把网站存放到一个专用的服务器上。

专享主机是最昂贵的主机类型。这种解决方案适合大型的高流量网站，以及使用特殊软件的网站。

专享主机的性能很强，也很安全，软件方案也几乎没有限制。

优点 | 缺点
适合大型商业网站。 | 昂贵。
适合高流量的昂站。 | 需要较高的技术。
可使用多个域名。 |
强大的电子邮件解决方案。 |
强大的数据库支持。 |
强有力的（没有限制的）软件支持。 |

托管主机

这种解决方案是把您自己的服务器放到服务提供商那里。

这很类似于在您自己的办公室来运行您的服务器，不同的是服务器被安放到一个专门为它设计的场所。

通常提供商都拥有专用的机房资源，比如防火防止故意破坏的高安全性、不间断电源、专用的 Internet 连接等等。

优点 | 缺点
高带宽。 | 昂贵
高正常运行时间。 | 需要更高的技术。
高安全性。 | 难以设置及修复漏洞。
无限制的软件选项。 |

您的检验表

在您选择网站主机之前，请首先确定下面的事项：

  • 符合您目前需求的主机类型
  • 主机类型的性价比
  • 能否升级到更好的服务器
  • 如果需要的话，能否升级到专享服务器

在您与主机提供商签合同之前，可以访问一下其服务器上的其它网站，感觉一下他们的网速。同时把其它的网站与您的网站做个对比，看一下是否您也有同样的需求。与其他的用户沟通一下也是不错的做法。

  • Previous Page
  • Next Page


网站主机的数据库技术

网站主机教程

  • 教程首页
  • 网站主机简介
  • 主机提供商
  • 域名
  • 主机性能
  • 电子邮件服务
  • 主机技术
  • 主机数据库
  • 主机类型
  • 电子商务主机

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

网站主机的数据库技术

  • Previous Page
  • Next Page

SQL Server 或 Oracle 用于高流量的数据库驱动型网站。

Access 或 MySQL 用于低流量的数据库访问。

Web 数据库

如果您的网站需要经由 web 来更新大量的信息，那么您就需要数据库来存储信息。

可用于网站主机的数据库系统有很多种类型。最常见的是 MS Access、MySQL、SQL Server 以及 Oracle。

使用 SQL 语言

SQL 是一门用于访问数据库的语言。

如果您希望您的网站有能力在数据库存储或检索数据，那么您的 web 服务器就需要使用 SQL 语言对数据库系统进行访问的权限。

如果您希望学习更多有关 SQL 的知识，请访问我们的 SQL 教程 。

SQL Server

微软的 SQL Server 是用于高流量的数据库驱动网站的最流行的数据库软件之一。

SQL Server 是非常强大、健壮且特性丰富的 SQL 数据库系统。

Oracle

Oracle 同样是非常流行的用于高流量数据库驱动网站的数据库软件。

Oracle 同样是非常强大、健壮且特性丰富的 SQL 数据库系统。

Access

如果网站需要的是一套简易的数据库解决方案，微软的 Access 应该是很受欢迎的选项。

Access 不适合高流量的网站，并且也没有 Oracle 或 SQL Server 那么强大。

MySQL

MySQL 同样是用于网站的流行数据库软件。

MySQL 是昂贵的 Microsoft 和 Oracle 解决方案的廉洁替代品。

  • Previous Page
  • Next Page


网站主机简介

网站主机教程

  • 教程首页
  • 网站主机简介
  • 主机提供商
  • 域名
  • 主机性能
  • 电子邮件服务
  • 主机技术
  • 主机数据库
  • 主机类型
  • 电子商务主机

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

网站主机简介

  • Previous Page
  • Next Page

Web 如何工作？如何制作属于您自己的网站？

什么是网站主机？什么是 Internet 服务提供商（ISP）？

什么是 World Wide Web ？

WWW 是一张遍布全球的计算机网络。

Web 中的所有计算机均可彼此相互通信。

所有的计算机都使用被称为 HTTP 的通信标准。

WWW 如何工作？

Web 信息存储于被称为网页的文档中。

网页是存储于名为 web 服务器的计算机中的文件。

读取网页的计算机可称为 web 客户机。

web 客户机通过名为 web 浏览器的程序来查看页面。

流行的浏览器有 Internet Explorer 和 Mozilla Firefox。

浏览器如何读取网页？

浏览器可以通过一个请求 (request) 从 web 服务器读取页面。

请求是包含页面地址的标准 HTTP 请求。

地址看上去类似这样：http://www.someone.com/page.htm。

浏览器如何显示网页？

所有的网页都含有供显示的指令。

浏览器通过读取这些指令来显示页面。

最常用的现实指令是 HTML 标签。

HTML 标签是类似这样的：<p>This is a Paragraph</p>

如果您需要学习更多有关 HTML 的内容，请访问我们的 HTML 教程。

什么是 Web 服务器？

您的所有网页的集合被称为网站。

要想让别人看到您的页面，就必须对网站进行发布。

您必须把网站拷贝到一台 web 服务器，才能完成对网站的发布。

如果您的 PC 连入网络的话，您也可以把它当作一台 web 服务器。

大多数的情况是使用由 ISP 提供的 web 主机。

什么是 ISP ？

ISP 指的是 Internet 服务提供商。

ISP 可提供 Internet 服务。

最常见的 Internet 服务是网站主机。

网站主机服务可把您的网站存放到一个公共的服务器上。

网站主机服务通常包括了域名注册服务。

总结

如果您希望其它人看到您的网站，就必须把网站拷贝到一个公共的服务器。即使您可以使用自己的 PC 来做 web 服务器，最常见的做法还是通过 ISP 来存放网站。

包含在 web 主机解决方案中的还有域名注册和标准的电子邮件服务。

您可以在接下来的章节阅读到更多有关域名注册、电子邮件和其他服务的内容。

  • Previous Page
  • Next Page


网站主机教程

网站主机教程

  • 教程首页
  • 网站主机简介
  • 主机提供商
  • 域名
  • 主机性能
  • 电子邮件服务
  • 主机技术
  • 主机数据库
  • 主机类型
  • 电子商务主机

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

网站主机教程

  • Next Page

如果您希望向全世界发布自己的网站，那么您的网站就需要被放置于一个 WEB 服务器。

在本教程中，您将学到：什么是网站主机，以及网站主机提供什么服务。

内容目录

网站主机简介
本章内容：万维网如何工作，如何发布站点，因特网服务提供商（ISP）提供什么服务。
主机提供商
本章内容：阐述了将站点放置于自己的服务器与放置于ISP的差异。
域名注册
本章内容：如何注册域名，以及如何充分利用它。
主机性能
本章内容：磁盘空间和带宽。
主机的电子邮件服务
本章介绍电子邮件服务--因特网服务提供商（ISP）提供的最普通的服务。
网站主机的服务器技术
本章介绍被普遍使用的主机技术。
网站主机的数据库技术
本章介绍一些最流行的网络数据库技术。
主机类型
本章介绍网络主机的不同类型。
电子商务主机
本章内容：电子商务主机。
  • Next Page


网站主机提供商

网站主机教程

  • 教程首页
  • 网站主机简介
  • 主机提供商
  • 域名
  • 主机性能
  • 电子邮件服务
  • 主机技术
  • 主机数据库
  • 主机类型
  • 电子商务主机

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

网站主机提供商

  • Previous Page
  • Next Page

如果您希望让全世界的人都看到您的网站，就必须把它存储在一个 web 服务器。

大多数小的企业和公司都把他们的网站存储在由某个 ISP 提供的服务器上。

使用自己的主机

在自己的服务器上存放网站始终都是一个选项。不过有些问题是需要考虑的：

硬件的费用

要运行一个“真正”的网站，你必须购买一些高性能的服务器硬件。不要指望低价的 PC 可以做这些工作。同时您还需要可以到达您办公室的不间断高速连接，而这种连接是很昂贵的。

软件费用

不要忘记为软件许可计算额外的费用。请记住服务器许可的价格通常会远高于客户机许可。同时还需要注意某些服务器软件的许可会限制并发用户的数量。

劳务费用

不要指望很低的劳务费用。请记住您不得不安装这些软件和硬件，还需要对付漏洞和病毒，并在一个“可能发生任何事情”的环境里保持服务器的不间断运行。

利用一个 ISP

从一个 ISP 租用服务器是最常见的做法。这么的好处有：

连接速度

大多数提供商都拥有极快的 Internet 连接，比如 full T3 fiber-optic 45Mps 连接等于大于 2000 个 28k 的调制解调器，等于 1000 个 56k 调制解调器。

强大的硬件

服务提供商通常拥有很多台可供多家公司分享的强大的 web 服务器。它们可提供负载平衡以及必要的备份服务。

安全和稳定性

ISP 是网站主机领域的专家。他们能够提供超过 99% 的正常服务时间、最新的软件漏洞补丁以及最好的病毒防护。

需要考虑的事情

24小时支持

要确保你选择的 ISP 提供24小时的支持。请不要把自己置于需要等待下一个工作日才能修复紧要问题的境地。如果您不希望花费大量的长途电话费，被叫免费电话也是很重要的。

每日的备份

要确保您选择的 ISP 提供每日例行的安全备份，否则你可能会损失不少有价值的数据。

流量限制

请研究一下提供商的流量限制条款。要确保如果您的网站开始受欢迎以后，您不必为未预料到的高流量付额外的费用。

带宽或内容限制

请研究一下提供商的带宽和内容限制条款。如果您计划发布图片、广播或者声音，要确定您是否有这样的权利。

电子邮件性能

请确保提供商可完全地支持您需要的电子邮件性能。（您可以在后面的章节获得更多有关电子邮件性能的信息）

Front Page 扩展

如果您计划使用 FrontPage 来开发网站的话，请确保您的提供商可完全地支持 FrontPage 服务器扩展。

数据库访问

如果您计划在您的网站使用数据库，请确保您的提供商完全地支持您所需要的数据库访问。（您可以在后面的章节阅读到更多数据库访问的内容）

  • Previous Page
  • Next Page


域名注册

网站主机教程

  • 教程首页
  • 网站主机简介
  • 主机提供商
  • 域名
  • 主机性能
  • 电子邮件服务
  • 主机技术
  • 主机数据库
  • 主机类型
  • 电子商务主机

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

域名注册

  • Previous Page
  • Next Page

域名是网站唯一的名称。

主机解决方案中应包括域名注册。

域名应该容易记、容易写。

什么是域名？

域名是网站的唯一名称，比如 microsoft.com 和 w3school.com.cn。

注册是需要注册的。当域名被注册后，就会被添加到大的域名注册商那里，连同与您的网站有关的信息 - 包括被保存在 DNS 服务器的 IP 信息。

DNS 指的是域名系统 (Domain Name System)。DNS 服务器负责向 internet 上的其他计算机通知有关你的域名和地址的信息。

注册域名

可以通过域名注册公司来注册域名，比如 www.net.cn 。

这些公司都提供了查询可用域名的接口，并提供可同时注册的域名后缀。

域名注册机构可提供多种域名后缀的注册，但是最容易记忆的域名是 .com 和 .net ，大多数带有这两个后缀的受欢迎的域名都已经被注册了。

选择您的域名

对于任何个人或组织来说，选择域名都是很重要的步骤。

在域名被大量注册的同时，新的域名后缀和创造性的思路仍然可提供数千种很棒的选择。当选择一个域名时，考虑好域名的用途是很重要的，这样使人们更容易找到你的网站。优秀的域名具有以下特征：

简短 - 人们都不喜欢打字！域名越短，就更容易被访问，用户发生输入错误的可能性也就越小。

简短 - 没有意义的短域名不见得好。34i4nh69.com 仅有8个字符长，但是既不易输入也不易记忆。所以，还是请您选择与您的网站相关且容易理解的域名吧。

清晰 - 在选择域名时，清晰也很重要。避免选择那些很难拼写或发音的域名。另外还要注意，您所选的域名听起来是不是顺耳，通过电话能否很快地交流。

曝光率 - 就像高档的房地产项目可获得极高的曝光率一样，短而容易记的域名也是一种资产。除了访问者使用您的域名以外，你还应该考虑到搜索引擎。搜索引擎是通过人们在线搜索项目的相关度来对您的网站进行索引和评级的。为了最大程度地使您的网站曝光，可以在域名中包含相关的搜索项。当然，前提仍然是你选择的域名应该是简短的、清晰的且有意义的。

子域名

大多数人们都没有意识到，但确实是每天都在使用着子域名。最常见的 "www" 其实就是典型的子域名。子域名可以在 DNS

服务器上创建，并且不需要通过域名注册机构来进行注册。当然，在创建子域名之前，还是需要首先注册原始域名的。在 internet 上可以见到很多子域名的例子：比如 store.apple.com 和 support.microsoft.com。

可请求您的网站主机提供商来创建子域名，也可以通过管理您的 DNS 服务器来创建。

虚假域名 - 目录列表

某些提供商可能会为您提供一个位于其域名之下的一个唯一的名称：www.theircompany.com/yourcompany/

这并不是一个真实的域名，而是一个目录 - 应当尽量避免这样的情况。

这样的 URL 是不值得要的，特别是对公司来说。所以还是避免使用它吧，如果您能够支付域名的费用的话。这种 URL 的典型运用是通过 ISP 用于个人网站或免费网站，其实就是分享一个独立域名的方式，可为用户提供属于自己的地址。

域名注册机构之间的完全竞争已经极大程度地降低了域名的注册费用，所有这种域名分享的方式越来越少见了，因为人们仅仅需要 15 美元就可以注册属于自己的域名了。

过期的域名

域名注册的另一个来源是过期的域名。当您注册了一个域名后，假设没有法律或商标方面的争议，那么只要您付清费用（您可以提前支付 10 年的费用），就可以自由地使用任意长的时间。某些人是利用域名进行投机的，希望以后可以卖掉它们，而另一些人本来计划使用某个域名却没有这么做。结果是之前已被注册的域名会定期地成为可注册的状态。您可以通过 http://www.dotdnr.com 这个网站查询最近的过期域名，如果希望注册的话，需要付的费用和注册新域名是相同的。

使用您的域名

在您已经选择 - 并注册了 - 属于自己的域名后，一定要把它用在您所有的网页上，还有所有的信件上，比如电子邮件和传统的信件。

让其他人知晓您的域名是很重要的，把您的域名告诉您的合作伙伴和客户吧。

  • Previous Page
  • Next Page


主机的电子邮件服务

网站主机教程

  • 教程首页
  • 网站主机简介
  • 主机提供商
  • 域名
  • 主机性能
  • 电子邮件服务
  • 主机技术
  • 主机数据库
  • 主机类型
  • 电子商务主机

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

主机的电子邮件服务

  • Previous Page
  • Next Page

主机服务应该包括一定的电子邮件帐号和电子邮件服务器。

电子邮件帐号

主机解决方案应该有能力为公司中的每个人提供一个电子邮件帐号。比如这样：

peter@mycompany.com

paul@mycompany.com

mary@mycompany.com

POP 电子邮件

POP 指的是邮局协议。POP 是一种用于发送和接收电子邮件的标准客户机/服务器协议。

电子邮件会被接收并保存到您的 internet 服务器上，直到您通过某个客户段邮件程序（比如 Outlook 和 Foxmail）来收取信件。

IMAP 电子邮件

IMAP 指的是 Internet 消息访问协议。IMAP 是另外一种用于发送和接收电子邮件的标准协议。

IMAP 在 POP 的基础上提供了一定的改进，即存储在 IMAP 服务器上的电子邮件可以由多台计算机处理，而无需在计算机间来回传输消息。而 POP 被设计为支持在一台单独的计算机上进行的邮件访问。

基于 web 的电子邮件

基于 web 的电子邮件使我们通过 web 浏览器就可以访问电子邮件。您通过 web 登陆到电子邮件帐户以后就可以发送和接收电子邮件了。能够从世界上的任何地方访问电子邮件是件很吸引人的事情。

基于 web 的电子邮件的典型例子有：Yahoo! Mail 和 Hotmail 。

邮件转发

电子邮件转发使我们能够拥有多个邮件名。

通过电子邮件转发功能，可以为别的邮件帐户设置别名：

例如：

可以把发往 postmaster@mycompany.com 的邮件转发到 peter@mycompany.com

把发往 sales@mycompany.com 的邮件转发到 mary@mycompany.com

邮件列表

某些服务器上会提供邮件列表功能。如果您希望向大量的用户发送邮件的话，这是一项有价值的功能。

  • Previous Page
  • Next Page


主机性能

网站主机教程

  • 教程首页
  • 网站主机简介
  • 主机提供商
  • 域名
  • 主机性能
  • 电子邮件服务
  • 主机技术
  • 主机数据库
  • 主机类型
  • 电子商务主机

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

主机性能

  • Previous Page
  • Next Page

首先要确定您所需要的磁盘空间和流量。

多少磁盘空间？

小型或中型的网站至少需要 10MB 到 100MB 的磁盘空间。

如果只考虑 HTML 页面的话，它们的平均尺寸是很小的。也许甚至不到 1KB。但是如果看一下在页面中使用的图形的尺寸，您会发现大多数图片的尺寸要比页面本身大得多。

加上图片和其他一些占用空间的元素，每张页面会占用 5KB 到 50KB 的服务器空间。

如果您计划使用大量的图像和图形元素（不涉及音频文件和视频文件），那么可能需要更多的磁盘空间。

在您挑选提供商之前，请首先明确您需要的磁盘空间。

月流量

小型或中型的网站每月至少需要 1GB 到 5GB 的数据传输量。

可以这样进行计算：把平均的页面尺寸乘以每月预期的页面浏览量。假设您的平均页面尺寸是 30KB，预期的页面浏览量是 50,000 张页面，那么您需要 0.03MB x 50,000 = 1.5GB 。

大型的商业站点每月通常会消耗掉不少于 100GB 的流量。

在与主机提供商签合同之前，需要搞清楚下面的事项：

  • 月流量限制是多少？
  • 如果超过限制，网站会被关闭吗？
  • 如果超过限制，需要付额外的费用吗？
  • 主机容易进行升级吗？

连接速度

访问者通常会使用调制解调器来访问您的访问，但是主机提供商则拥有极高的连接速度。

在 Internet 的早期，T1 连接被认为是非常快的连接。而今天的连接速度则要快得多。

1 个字节等于 8 个比特（这是传输一个字符的比特数目）。1 KB 是 1024 个比特。1 MB 是 1024 KB。1 GB 是 1024 MB。

这是目前在 Internet 上被使用到的连接速度：

名称 | 连接 | 每秒的速度
Modem | Analog | 14.4-56Kb
D0 | Digital(ISDN) | 64Kb
T1 | Digital | 1.55Mb
T3 | Digital | 43Mb
OC-1 | Optical Carrier | 52Mb
OC-2 | Optical Carrier | 156Mb
OC-12 | Optical Carrier | 622Mb
OC-24 | Optical Carrier | 1.244Gb
OC-48 | Optical Carrier | 2.488Gb

在签合同之前，可以试试提供商服务器上的其他网站，与其他的客户交流一下也是不错的做法。

  • Previous Page
  • Next Page


HTML 4.0 标准属性

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 4.0 标准属性

  • Previous Page
  • Next Page

HTML 标签可拥有属性。

这里列出的属性是通用于每个标签的核心属性和语言属性（有个别例外）。

我们在 HTML 4.01 / XHTML 1.0 参考手册 中提供了各标签特殊属性的详细信息。

核心属性 (Core Attributes)

以下标签不提供下面的属性：base, head, html, meta, param, script, style, 以及 title 元素。

属性 | 值 | 描述
class | class_rule 或 style_rule | 元素的类 (class)
id | id_name | 元素的特定 id
style | 样式定义 | 内联样式定义
title | 提示文本 | 显示于提示工具中的文本

语言属性 (Language Attributes)

以下标签不提供下面的属性：base, br, frame, frameset, hr, iframe, param, 以及 script 元素。

属性 | 值 | 描述
dir | ltr | rtl | 设置文本的方向
lang | 语言代码 | 设置语言代码

键盘属性 (Keyboard Attributes)

属性 | 值 | 描述
accesskey | 字符 | 设置访问某元素的键盘快捷键
tabindex | 数 | 设置某元素的 Tab 次序
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 4.0 事件属性

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 4.0 事件属性

  • Previous Page
  • Next Page

HTML 4.0 的新特性之一是使 HTML 事件触发浏览器中的行为，比方说当用户点击一个 HTML 元素时启动一段 JavaScript。以下就是可插入 HTML 标签以定义事件行为的一系列属性。

如果您需要学习如何使用这些事件进行编程，那么你应该学习我们的 JavaScript 教程 和 DHTML 教程。

窗口事件 (Window Events)

仅在 body 和 frameset 元素中有效。

属性 | 值 | 描述
onload | 脚本 | 当文档载入时执行脚本
onunload | 脚本 | 当文档卸载时执行脚本

表单元素事件 (Form Element Events)

仅在表单元素中有效。

属性 | 值 | 描述
onchange | 脚本 | 当元素改变时执行脚本
onsubmit | 脚本 | 当表单被提交时执行脚本
onreset | 脚本 | 当表单被重置时执行脚本
onselect | 脚本 | 当元素被选取时执行脚本
onblur | 脚本 | 当元素失去焦点时执行脚本
onfocus | 脚本 | 当元素获得焦点时执行脚本

键盘事件 (Keyboard Events)

在下列元素中无效：base, bdo, br, frame, frameset, head, html, iframe, meta, param, script, style, 以及 title 元素。

属性 | 值 | 描述
onkeydown | 脚本 | 当键盘被按下时执行脚本
onkeypress | 脚本 | 当键盘被按下后又松开时执行脚本
onkeyup | 脚本 | 当键盘被松开时执行脚本

鼠标事件 (Keyboard Events)

在下列元素中无效：base, bdo, br, frame, frameset, head, html, iframe, meta, param, script, style, title 元素。

属性 | 值 | 描述
onclick | 脚本 | 当鼠标被单击时执行脚本
ondblclick | 脚本 | 当鼠标被双击时执行脚本
onmousedown | 脚本 | 当鼠标按钮被按下时执行脚本
onmousemove | 脚本 | 当鼠标指针移动时执行脚本
onmouseout | 脚本 | 当鼠标指针移出某元素时执行脚本
onmouseover | 脚本 | 当鼠标指针悬停于某元素之上时执行脚本
onmouseup | 脚本 | 当鼠标按钮被松开时执行脚本
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#0

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#FF

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#8

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#10

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#18

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#20

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#28

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#30

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#38

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#40

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#48

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#50

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#58

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#60

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#68

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#70

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#78

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#80

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#88

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#90

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#98

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#A0

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#A8

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#B0

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#B8

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#C0

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#C8

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#D0

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#D8

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#E0

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#E8

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#F0

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML More Colors

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML More Colors

  • Next Page
此红色的十六进制值：#F8

在下面的色表中，垂直的数值是绿色值，水平的数值是蓝色值：

 | 00 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | A0 | B0 | C0 | D0 | E0 | F0 | FF
0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
18 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
20 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
28 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
38 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
40 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
48 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
50 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
60 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
68 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
70 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
78 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
80 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
88 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
90 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
98 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
A8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
D8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
E8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
F8 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
100 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 表单和输入

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 表单和输入

  • Previous Page
  • Next Page

HTML 表单用于搜集不同类型的用户输入。

实例

文本域(Text fields)
本例演示如何在 HTML 页面创建文本域。用户可以在文本域中写入文本。
密码域
本例演示如何创建 HTML 的密码域。

（可以在本页底端找到更多实例。）

表单

表单是一个包含表单元素的区域。

表单元素是允许用户在表单中（比如：文本域、下拉列表、单选框、复选框等等）输入信息的元素。

表单使用表单标签（<form>）定义。

<form>
  <input>
  <input>
</form>

输入

多数情况下被用到的表单标签是输入标签（<input>）。输入类型是由类型属性（type）定义的。大多数经常被用到的输入类型如下：

文本域（Text Fields）

当用户要在表单中键入字母、数字等内容时，就会用到文本域。

<form>
First name:
<input type="text" name="firstname">
<br>
Last name:
<input type="text" name="lastname">
</form>

浏览器显示如下：

First name: Last name:

注意，表单本身并不可见。同时，在大多数浏览器中，文本域的缺省宽度是20个字符。

单选按钮（Radio Buttons）

当用户从若干给定的的选择中选取其一时，就会用到单选框。

<form>
<input type="radio" name="sex" value="male"> Male
<input type="radio" name="sex" value="female"> Female
</form>

浏览器显示如下：

Male Female

注意，只能从中选取其一。

复选框（Checkboxes）

当用户需要从若干给定的选择中选取一个或若干选项时，就会用到复选框。

<form>
<input type="checkbox" name="bike">
I have a bike
<br>
<input type="checkbox" name="car">
I have a car
</form>

浏览器显示如下：

I have a bike I have a car

表单的动作属性（Action）和确认按钮

当用户单击确认按钮时，表单的内容会被传送到另一个文件。表单的动作属性定义了目的文件的文件名。由动作属性定义的这个文件通常会对接收到的输入数据进行相关的处理。

<form name="input" action="html_form_action.asp" method="get">
Username:
<input type="text" name="user">
<input type="submit" value="Submit">
</form>

浏览器显示如下：

Username:

假如你再上面的文本框内键入几个字母，并且点击确认按钮，那么输入数据会被传送到名为"html_form_action.asp"的页面。那一页将显示出输入的结果。

更多实例

复选框
本例演示如何在 HTML 页中创建复选框。用户可以选中或取消选取复选框。
单选按钮
本例演示如何在 HTML 中创建单选按钮。
简单的下拉列表
本例演示如何在 HTML 页面中创建简单的下拉列表框。下拉列表框是一个可选列表。
另一个下拉列表
本例演示如何创建一个简单的带有预选值的下拉列表。（译者注：预选值指预先指定的首选项。）
文本域(Textarea)
本例演示如何创建一个文本域（多行文本输入控件）。用户可以在文本域中写入文本。在文本域中，可写入的字符字数不受限制。
创建按钮
本例演示如何创建按钮。你可以对按钮上的文字进行自定义。
Fieldset around data
本例演示如何在数据周围绘制一个带标题的框。

表单实例

带有输入框和确认按钮的表单
本例演示如何向页面添加表单。此表单包含两个输入框和一个确认按钮。
带有复选框的表单
此表单包含两个复选框和一个确认按钮。
带有单选按钮的表单
此表单包含两个单选框和一个确认按钮。
从表单发送电子邮件
此例演示如何从表单发送电子邮件。

表单标签

标签 | 描述
<form> | 定义供用户输入的表单
<input> | 定义输入域
<textarea> | 定义文本域 (一个多行的输入控件)
<label> | 定义一个控制的标签
<fieldset> | 定义域
<legend> | 定义域的标题
<select> | 定义一个选择列表
<optgroup> | 定义选项组
<option> | 定义下拉列表中的选项
<button> | 定义一个按钮
<isindex> | 已废弃。有<input>代替。
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 表格

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 表格

  • Previous Page
  • Next Page

你可以使用 HTML 创建表格。

实例

表格
这个例子演示如何在 HTML 文档中创建表格。
表格边框
本例演示各种类型的表格边框。

（可以在本页底端找到更多实例。）

表格

表格由 <table> 标签来定义。每个表格均有若干行（由 <tr> 标签定义），每行被分割为若干单元格（由 <td> 标签定义）。字母 td 指表格数据（table data），即数据单元格的内容。数据单元格可以包含文本、图片、列表、段落、表单、水平线、表格等等。

<table border="1">
<tr>
<td>row 1, cell 1</td>
<td>row 1, cell 2</td>
</tr>
<tr>
<td>row 2, cell 1</td>
<td>row 2, cell 2</td>
</tr>
</table>

在浏览器显示如下：

row 1, cell 1 | row 1, cell 2
row 2, cell 1 | row 2, cell 2

表格和边框属性

如果不定义边框属性，表格将不显示边框。有时这很有用，但是大多数时候，我们希望显示边框。

使用边框属性来显示一个带有边框的表格

<table border="1">
<tr>
<td>Row 1, cell 1</td>
<td>Row 1, cell 2</td>
</tr>
</table>

表格的表头

表格的表头使用 <th> 标签进行定义。

<table border="1">
<tr>
<th>Heading</th>
<th>Another Heading</th>
</tr>
<tr>
<td>row 1, cell 1</td>
<td>row 1, cell 2</td>
</tr>
<tr>
<td>row 2, cell 1</td>
<td>row 2, cell 2</td>
</tr>
</table>

在浏览器显示如下：

Heading | Another Heading
row 1, cell 1 | row 1, cell 2
row 2, cell 1 | row 2, cell 2

表格中的空单元格

在大多数浏览器中，没有内容的表格单元显示得不太好。

<table border="1">
<tr>
<td>row 1, cell 1</td>
<td>row 1, cell 2</td>
</tr>
<tr>
<td>row 2, cell 1</td>
<td></td>
</tr>
</table>

在浏览器显示如下：

row 1, cell 1 | row 1, cell 2
row 2, cell 1 |

注意：这个空的单元格的边框没有被显示出来。（不过 Mozilla Firefox 可以将整个边框显示出来。） 为了避免这种情况，在空单元格中添加一个空格占位符，就可以将边框显示出来。

<table border="1">
<tr>
<td>row 1, cell 1</td>
<td>row 1, cell 2</td>
</tr>
<tr>
<td>row 2, cell 1</td>
<td>&nbsp;</td>
</tr>
</table>

在浏览器中显示如下：

row 1, cell 1 | row 1, cell 2
row 2, cell 1 |

基本的注意事项 - 有用的提示：

<thead>, <tbody> 和 <tfoot>很少被用到，这是由于浏览器对它们的支持不太好。希望这种情况在未来版本的 XHTML 中会有所改观。如果你使用 IE5.0 或者更新的版本，可以查看在我们的《XML教程》中的具体例子。

更多实例

没有边框的表格
本例演示一个没有边框的表格。
表格中的表头(Heading)
本例演示如何显示表格表头。
空单元格
本例展示如何使用 "&nbsp;" 处理没有内容的单元格。
带有标题的表格
本例演示一个带标题 (caption) 的表格
跨行或跨列的表格单元格
本例演示如何定义跨行或跨列的表格单元格。
表格内的标签
本例演示如何显示在不同的元素内显示元素。
单元格边距(Cell padding)
本例演示如何使用 Cell padding 来创建单元格内容与其边框之间的空白。
单元格间距(Cell spacing)
本例演示如何使用 Cell spacing 增加单元格之间的距离。
向表格添加背景颜色或背景图像
本例演示如何向表格添加背景。
向表格单元添加背景颜色或者背景图像
本例演示如何向一个或者更多表格单元添加背景。
在表格单元中排列内容
本例演示如何使用 "align" 属性排列单元格内容,以便创建一个美观的表格。
框架(frame)属性
本例演示如何使用 "frame" 属性来控制围绕表格的边框。

表格标签

表格 | 描述
<table> | 定义表格
<caption> | 定义表格标题。
<th> | 定义表格的表头。
<tr> | 定义表格的行。
<td> | 定义表格单元。
<thead> | 定义表格的页眉。
<tbody> | 定义表格的主体。
<tfoot> | 定义表格的页脚。
<col> | 定义用于表格列的属性。
<colgroup> | 定义表格列的组。
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 布局

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 布局

  • Previous Page
  • Next Page

在网络上，随处都可以看到像报纸那样的格式化分栏。

HTML布局 - 使用表格

One very common practice with HTML, is to use HTML tables to format the layout of an HTML page.

A part of this page is formatted with two columns, like a newspaper page.

As you can see on this page, there is a left column and a right column.

This text is displayed in the left column.

 An HTML <table> is used to divide a part of this Web page into two columns.

The trick is to use a table without borders, and maybe a little extra cell-padding.

No matter how much text you add to this page, it will stay inside its column borders.

同样的布局 - 添加了颜色

One very common practice with HTML, is to use HTML tables to format the layout of an HTML page.

A part of this page is formatted with two columns, like a newspaper page.

As you can see at this page, there is a left column and a right column.

 An HTML <table> is used to divide a part of this Web page into two columns.

This text is displayed in the right column.

The trick is to use a table without borders, and maybe a little extra cell-padding.

No matter how much text you add to this page, it will stay inside its column borders.

实例

将HTML页面的一部分分割为表格的列是很容易的。为了您可以亲自尝试它，我们为您准备了这个简单的例子。

  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 测验

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 测验

  • Previous Page
  • Next Page

您可以通过 W3SCHOOL 的测验程序来测试您的 HTML 技能。

关于本测验

本测验包含 20 道题，每道题的最长答题时间是 20 分钟（这是由于每个 session 的默认有效时间是20钟）。

本测验是非官方的测试，它仅仅提供了一个了解您对 HTML 的掌握程度的工具。

测验会被记分

每道题的分值是 1 分。在您完成全部的 20 道题之后，系统会为您的测验打分，并提供您做错的题目的正确答案。其中，绿色为正确答案，而红色为错误答案。

现在就开始测验！祝您好运。

  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 简介

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 简介

  • Previous Page
  • Next Page
什么是 HTML 文件？
  • HTML 指超文本标签语言。
  • HTML 文件是包含一些标签的文本文件。
  • 这些标签告诉 WEB 浏览器如何显示页面。
  • HTML 文件必须使用 htm 或者 html 作为文件扩展名。
  • HTML 文件可以通过简单的文本编辑器来创建。

做个实验如何？

第一步：如果您使用 Windows，请启动记事本。

如果您使用 Mac，请启动 SimpleText。

（在 OSX 中请使用 TextEdit，并设置一下参数：在参数设置中选择 Plain text 字体替代 Rich text 字体，然后选择“在 HTML 文件中忽略 rich text 命令”。这一点很重要，因为不这样的话，HTML 代码也许不能正常工作。）

第二步：键入以下文本：

<html>
<head>
<title>页面的标题</title>
</head>
<body>
<p>这是我的第一个页面。<b>这是粗体文本。</b></p>
</body>
</html>

第三步：将这个文件存为 "mypage.html"。

第四步：启动您的浏览器。在浏览器的文件菜单中选择“打开”或者“打开页面”。这时会弹出一个对话框。单击“浏览”或者“选择文件”，找到您刚才创建的文件 - "mypage.html"，选定它然后打开，现在您会看到对话框中有一行地址，比如："D:\mypage.html"。单击确定按钮，浏览器就会显示这个页面。

例子解释：

HTML 文件中的第一个标签是 <html>。这个标签告诉浏览器这个 HTML 文件的开始点。文件中最后一个标签是 </html>。这个标签告诉您的浏览器，这是 HTML 文件的结束点。

位于 <head> 标签和 </head> 标签之间的文本是头信息。头信息不会显示在浏览器窗口中。

<title> 标签中的文本是文件的标题。标题会显示在浏览器的标题栏。

<body> 标签中的文本是将被浏览器显示出来的文本。

<b> 和 </b> 标签中的文本将以粗体显示。

为什么我们要使用小写的标签？

我们刚才讲到：HTML 标签对大小写是不敏感的：<b> 和 <B> 的作用的相同的。当您在网上冲浪时，您会发现大多数教程在他们的例子中都使用大写的 HTML 标签。而我们总是使用小写。原因何在呢？

如果您希望为使用下一代 HTML 而做好准备，您就应该使用小写标签。万维网联盟 (W3C) 的标准是：建议在 HTML 4 中使用小写标签，而在 XHTML（下一代 HTML）中，必须使用小写标签。

HTM 还是 HTML 扩展名？

当您将一个 HTML 文件存盘时，您即可以使用 HTM 也可以使用 HTML 作为扩展名。我们刚才使用了 .htm 作为上面那个例子的扩展名。不过这样做也许是一个坏习惯，习惯于这样做的人也许是因为使用某些过时的软件而养成了这个坏习惯，这些软件只允许三个字母作为扩展名。

如果您使用新近的软件，我们认为使用 .html 是相当安全的做法。

关于 HTML 编辑器的注意事项:

您可以使用所见即所得的编辑器而不是纯文本编辑器，这样会更轻松的编辑 HTML 文件。比方说 FrontPage, Claris Home Page, 或者 Adobe PageMill，甚至更高阶的 Dreamweaver。

但是，如果您希望成为一名熟练的开发人员，我们强烈推荐您使用纯文本编辑器来学习我们的《HTML 基础教程》。

常见问题（FAQ）

Q：我已经编辑了一个 HTML 文件，但是浏览器无法显示出结果。为什么？

A：首先确定您使用了正确的文件名和扩展名存盘，比如说 "c:\mypage.htm"。然后看一下是否在浏览器中使用了同样的文件名来打开这个文件。

Q：我重新编辑了 HTML 文件，但是浏览器的显示没有任何变化。为什么？

A：为了不重复读取同一个页面，浏览器要对您的页面进行缓存。浏览器不会意识到您已经修改了页面。通过使用刷新或者重载按钮，您可以使浏览器读取编辑后的页面。

Q：我应该使用何种浏览器？

A：您可以使用任何一款通用浏览器进行训练，例如 Internet Explorer, Mozilla, Netscape,或者 Opera。不过，我们的高级课程中的某些例子需要最新版本的浏览器的支持。

Q：我的电脑必须运行 Windows 吗？使用 Mac 机可以吗？

A：您可以在非 Windows 系统上进行所有的训练，比如 Mac。

  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 脚本

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 脚本

  • Previous Page
  • Next Page

向 HTML 添加脚本（Script），使其动态性和交互性更强。

实例

插入一段脚本
本例演示如何将脚本插入 HTML 文档。
运行于不支持脚本的浏览器
本例演示如何对付不支持脚本的浏览器。

将脚本插入 HTML 页

HTML 中的脚本使用 <script> 标签进行定义。请注意你可以使用 type 属性来指定脚本语言。

<html>
<head>
</head>
<body>

<script type="text/javascript">
document.write("Hello World!")
</script>

</body>
</html>

上面的脚本输出以下结果：

Hello World!

提示：如果需要学习更多有关在 HTML 中编写脚本的知识，请访问我们的《JavaScript 教程》

如何应付老式的浏览器

如果浏览器压根没法识别 <script> 标签，那么 <script> 标签所包含的内容将以文本方式显示在页面上。为了避免这种情况发生，你应该将脚本隐藏在注释标签当中。那些老的浏览器（无法识别 <script> 标签的浏览器）将忽略这些注释，所以不会将标签的内容显示到页面上。而那些新的浏览器将读懂这些脚本并执行它们，即使代码被嵌套在注释标签内。

实例

JavaScript:

<script type="text/javascript">
<!--
document.write("Hello World!")
//-->
</script>

VBScript:

<script type="text/vbscript">
<!--
document.write("Hello World!")
'-->
</script>

<noscript> 标签

除了将脚本隐藏于注释中，你还可以添加 <noscript> 标签。<noscript> 标签用于定义假如脚本没有执行时的替代文本。这个标签被用于以下情况：如果浏览器能够识别 <script> 标签，但是不支持其中的脚本，那么这些浏览器将显示出 <noscript> 标签内部的文本。不过，如果浏览器支持 <script> 内的脚本，那么浏览器将忽略 <noscript> 标签。

JavaScript:

<script type="text/javascript">
<!--
document.write("Hello World!")
//-->
</script>
<noscript>Your browser does not support JavaScript!</noscript>

VBScript:

<script type="text/vbscript">
<!--
document.write("Hello World!")
'-->
</script>
<noscript>Your browser does not support VBScript!</noscript>

标签 | 描述
<script> | 定义脚本。
<noscript> | 定义在脚本无法执行的情况下的替代文本。
<object> | 定义嵌入的对象。
<param> | 为对象定义 run-time 设置(参数)。
<applet> | 不赞成使用。请使用 <object>。
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 教程

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 教程

  • Next Page

HTML 教程

在本教程中，你将学习如何使用 HTML 来创建站点。

HTML 很容易学习！你会喜欢它的！

现在开始学习 HTML ！

HTML 实例

学习 100 个实例！使用我们的编辑器，你可以编辑 HTML，然后点击测试按钮来查看结果。

亲自试一试吧！

HTML 测验

在 W3School 测试你的 HTML 技能！

开始 HTML 测验！

HTML 参考手册

在 W3School，我们提供完整的 HTML 参考手册，其中包括标签、属性、颜色、实体等等。

HTML 4.01 参考手册

  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 快速参考

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 4.01 快速参考

  • Previous Page
  • Next Page

来自 W3School 的 HTML 快速参考。可以打印它，以备日常使用。

HTML Basic Document

<html>
<head>
<title>Document name goes here</title>
</head>
<body>
Visible text goes here
</body>
</html>

Text Elements

<p>This is a paragraph</p>
<br> (line break)
<hr> (horizontal rule)
<pre>This text is preformatted</pre>

Logical Styles

<em>This text is emphasized</em>
<strong>This text is strong</strong>
<code>This is some computer code</code>

Physical Styles

<b>This text is bold</b>
<i>This text is italic</i>

Links, Anchors, and Image Elements

<a href="http://www.example.com/">This is a Link</a>
<a href="http://www.example.com/"><img src="URL"
alt="Alternate Text"></a>
<a href="mailto:webmaster@example.com">Send e-mail</a>A named anchor:
<a name="tips">Useful Tips Section</a>
<a href="#tips">Jump to the Useful Tips Section</a>

Unordered list

<ul>
<li>First item</li>
<li>Next item</li>
</ul>

Ordered list

<ol>
<li>First item</li>
<li>Next item</li>
</ol>

Definition list

<dl>
<dt>First term</dt>
<dd>Definition</dd>
<dt>Next term</dt>
<dd>Definition</dd>
</dl>

Tables

<table border="1">
<tr>
  <th>someheader</th>
  <th>someheader</th>
</tr>
<tr>
  <td>sometext</td>
  <td>sometext</td>
</tr>
</table>

Frames

<frameset cols="25%,75%">
  <frame src="page1.htm">
  <frame src="page2.htm">
</frameset>

Forms

<form action="http://www.example.com/test.asp" method="post/get">
<input type="text" name="lastname"
value="Nixon" size="30" maxlength="50">
<input type="password">
<input type="checkbox" checked="checked">
<input type="radio" checked="checked">
<input type="submit">
<input type="reset">
<input type="hidden">
<select>
<option>Apples
<option selected>Bananas
<option>Cherries
</select>
<textarea name="Comment" rows="60"
cols="20"></textarea>
</form>

Entities

&lt; is the same as <
&gt; is the same as >
&#169; is the same as ©

Other Elements

<!-- This is a comment -->
<blockquote>
Text quoted from some source.
</blockquote>
<address>
Address 1<br>
Address 2<br>
City<br>
</address>

Source : http://www.w3school.com.cn/html/html_quick.asp

  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 框架

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 框架

  • Previous Page
  • Next Page

通过使用框架，你可以在同一个浏览器窗口中显示不止一个页面。

实例

垂直框架
本例演示：如何使用三份不同的文档制作一个垂直框架。
水平框架
本例演示：如何使用三份不同的文档制作一个水平框架。

（可以在本页底端找到更多实例。）

框架

通过使用框架，你可以在同一个浏览器窗口中显示不止一个页面。每份HTML文档称为一个框架，并且每个框架都独立于其他的框架。

使用框架的坏处：

  • 开发人员必须同时跟踪更多的HTML文档
  • 很难打印整张页面
框架结构标签（<frameset>）
  • 框架结构标签（<frameset>）定义如何将窗口分割为框架
  • 每个 frameset 定义了一系列行或列
  • rows/columns 的值规定了每行或每列占据屏幕的面积

编者注：frameset 标签也被某些文章和书籍译为框架集。

框架标签（Frame）

Frame 标签定义了放置在每个框架中的 HTML 文档。

在下面的这个例子中，我们设置了一个两列的框架集。第一列被设置为占据浏览器窗口的 25%。第二列被设置为占据浏览器窗口的 75%。HTML 文档 "frame_a.htm" 被置于第一个列中，而 HTML 文档 "frame_b.htm" 被置于第二个列中：

<frameset cols="25%,75%">
   <frame src="frame_a.htm">
   <frame src="frame_b.htm">
</frameset>

基本的注意事项 - 有用的提示：

假如一个框架有可见边框，用户可以拖动边框来改变它的大小。为了避免这种情况发生，可以在 <frame> 标签中加入：noresize="noresize"。

为不支持框架的浏览器添加 <noframes> 标签。

重要提示：不能将 <body></body> 标签与 <frameset></frameset> 标签同时使用！不过，假如你添加包含一段文本的 <noframes> 标签，就必须将这段文字嵌套于 <body></body> 标签内。（在下面的第一个实例中，可以查看它是如何实现的。）

更多实例

如何使用 <noframes> 标签
本例演示：如何使用 <noframes> 标签。
混合框架结构
本例演示如何制作含有三份文档的框架结构，同时将他们混合置于行和列之中。
含有 noresize="noresize" 属性的框架结构
本例演示 noresize 属性。在本例中，框架是不可调整尺寸的。在框架间的边框上拖动鼠标，你会发现边框是无法移动的。
导航框架
本例演示如何制作导航框架。导航框架包含一个将第二个框架作为目标的链接列表。名为 "contents.htm" 的文件包含三个链接。
内联框架
本例演示如何创建内联框架（HTML 页中的框架）。
跳转至框架内的一个指定的节
本例演示两个框架。其中的一个框架设置了指向另一个文件内指定的节的链接。这个"link.htm"文件内指定的节使用 <a name="C10"> 进行标识。
使用框架导航跳转至指定的节
本例演示两个框架。左侧的导航框架包含了一个链接列表，这些链接将第二个框架作为目标。第二个框架显示被链接的文档。导航框架其中的链接指向目标文件中指定的节。
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 链接

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 链接

  • Previous Page
  • Next Page

HTML 使用超级链接与网络上的另一个文档相连。

实例

创建超级链接
本例演示如何在 HTML 文档中创建链接。
将图像作为链接
本例演示如何使用图像作为链接。

（可以在本页底端找到更多实例。）

锚标签和 Href 属性

HTML 使用 <a> （锚）标签来创建连接另一个文档的链接。

锚可以指向网络上的任何资源：一张 HTML 页面，一幅图像，一个声音或视频文件等等。

创建锚的语法：

<a href="url">Text to be displayed</a>

<a> 用来创建锚。href 属性用于定位需要链接的文档，锚的开始标签和结束标签之间的文字被作为超级链接来显示。

这个锚定义了指向 w3school 的链接：

<a href="http://www.w3school.com.cn/">Visit W3School!</a>

上面的这行在浏览器中显示为这样：Visit W3School!

Target 属性

使用 Target 属性，你可以定义被链接的文档在何处显示。

下面的这行会在新窗口打开文档：

<a href="http://www.w3school.com.cn/" target="_blank">Visit W3School!</a>

锚标签和 Name 属性

Name 属性用于创建被命名的锚（named anchors）。当使用命名锚（named anchors）时，我们可以创建直接跳至页面中某个节的链接，这样使用者就无需不停的滚动页面来寻找他们需要的信息。

以下是命名锚的语法：

<a name="label">Text to be displayed</a>

name 属性用于创建命名锚。锚的名称可以是任何你喜欢的名字。

下面这行定义了命名锚：

<a name="tips">Useful Tips Section</a>

你会注意到，命名锚会以特殊的方式来显示。

将 # 符号和锚名称添加到 URL 的末端，就可以直接链接到 tips 这个节，就像这样：

<a href="http://www.w3school.com.cn/html_links.asp#tips">
Jump to the Useful Tips Section
</a>

从文件 html_links.asp 内部链接到 Useful Tips 节的超级链接是这样的：

跳转到 有用的提示 部分

基本的注意事项 - 有用的提示：

总是将正斜杠添加到子文件夹。假如你这样书写链接的话：href="http://www.w3school.com.cn/html"，就会向服务器产生两次 HTTP 请求。这是因为服务器会添加正斜杠到这个地址，然后创建一个新的请求，就像这样：href="http://www.w3school.com.cn/html/"

命名锚经常被用在长的文档中创建目录。可以为每个章节赋予一个命名锚，然后连接到这些锚的链接被置于文档的上部。

假如浏览器找不到已定义的命名锚，那么就会定位到文档的顶端。不会有错误发生。

更多实例

在新的浏览器窗口打开链接
本例演示如何在新窗口打开一个页面，这样的话访问者就无需离开你的站点了。
链接到同一个页面的不同位置
本例演示如何使用链接跳转至文档的另一个部分
跳出框架
本例演示如何跳出框架，假如你的页面被固定在框架之内。
创建电子邮件链接
本例演示如何如何链接到一个邮件。（本例在安装邮件客户端程序后才能工作。）
创建电子邮件链接 2
本例演示更加复杂的邮件链接。

链接标签

标签 | 描述
<a> | 定义锚。
  • Previous Page
  • Next Page

延伸阅读

什么是超文本？

HTML 参考手册
HTML 实例
HTML 测验


HTML 列表

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 列表

  • Previous Page
  • Next Page

HTML 支持有序、无序和定义列表

实例

无序列表
本例演示无序列表。
有序列表
本例演示有序列表。

（可以在本页底端找到更多实例。）

无序列表

无序列表是一个项目的列表，此列项目使用粗体圆点（典型的小黑圆圈）进行标记。

无序列表始于 <ul> 标签。每个列表项始于 <li>。

<ul>
<li>Coffee</li>
<li>Milk</li>
</ul>

浏览器显示如下：

  • Coffee
  • Milk

列表项内部可以使用段落、换行符、图片、链接以及其他列表等等。

有序列表

同样，有序列表也是一列项目，列表项目使用数字进行标记。

有序列表始于 <ol> 标签。每个列表项始于 <li> 标签。

<ol>
<li>Coffee</li>
<li>Milk</li>
</ol>

浏览器显示如下：

  1. Coffee
  2. Milk

列表项内部可以使用段落、换行符、图片、链接以及其他列表等等。

定义列表

自定义列表不仅仅是一列项目，而是项目及其注释的组合。

自定义列表以 <dl> 标签开始。每个自定义列表项以 <dt> 开始。每个自定义列表项的定义以 <dd> 开始。

<dl>
<dt>Coffee</dt>
<dd>Black hot drink</dd>
<dt>Milk</dt>
<dd>White cold drink</dd>
</dl>

浏览器显示如下：

Coffee
Black hot drink
Milk
White cold drink

定义列表的列表项内部可以使用段落、换行符、图片、链接以及其他列表等等。

更多实例

不同类型的无序列表
本例演示一个无序列表。
不同类型的有序列表
本例演示不同类型的有序列表。
嵌套列表
本例演示如何嵌套列表。
嵌套列表 2
本例演示更复杂的嵌套列表。
定义列表
本例演示一个定义列表。

列表标签

标签 | 描述
<ol> | 定义有序列表。
<ul> | 定义无序列表。
<li> | 定义列表项。
<dl> | 定义定义列表。
<dt> | 定义定义项目。
<dd> | 定义定义的描述。
<dir> | 已废弃。使用 <ul> 代替它。
<menu> | 已废弃。使用 <ul> 代替它。
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 属性

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 属性

  • Previous Page
  • Next Page

属性为 HTML 元素提供附加信息。

HTML 标签的属性

HTML 标签拥有属性。属性为 HTML 元素提供附加信息。

属性总是以名称/值对的形式出现，比如：name="value"

属性总是在 HTML 元素的开始标签中规定。

属性例子 1:

<h1> 定义标题的开始。

<h1 align="center"> 拥有关于对齐方式的附加信息。

TIY : 居中排列标题

属性例子 2:

<body> 定义 HTML 文档的主体。

<body bgcolor="yellow"> 拥有关于背景颜色的附加信息。

TIY : 背景颜色

属性例子 3:

<table> 定义 HTML 表格。（您将在稍后的章节学习到更多有关 HTML 表格的内容）

<table border="1"> 拥有关于表格边框的附加信息。

使用小写属性

属性和属性值对大小写不敏感。不过，万维网联盟在其 HTML 4 推荐标准中推荐小写的属性/属性值，而 XHTML 要求使用小写属性/属性值。

始终为属性值加引号

属性值应该始终被包括在引号内。双引号是最常用的，不过使用单引号也没有问题。

在某些个别的情况下，比如属性值本身就含有双引号，那么您必须使用单引号，例如：

name='John "ShotGun" Nelson'
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 统一资源定位符

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML URL（统一资源定位器）

  • Previous Page
  • Next Page

HTML链接

当你单击 HTML 文档中的某个链接时，就像这个：最后一页，其中的 <a> 标签就会使用类似这样的 href 属性值指向一个网络上的地址：<a href="lastpage.htm">Last Page</a>

在这个例子中，Last Page 的链接地址是相对于你所浏览的网站而言的，你的浏览器会自动构建一个完整的网址来访问这个页面，比如 http://www.w3school.com.cn/html/lastpage.html。

URL（统一资源定位器）

一个称为 URL（统一资源定位器）的东西用于对万维网上的文档（或其他数据）进行寻址。一个完整的网址，例如：http://www.w3school.com.cn/html/lastpage.html，遵守如下语法规则：

scheme://host.domain:port/path/filename

Scheme 定义因特网服务的类型。最流行的类型是 http。

domain（域）定义因特网域名，比如：w3school.com.cn。

host（主机）定义此域中的主机。如果被省略，缺省的支持 http 的主机是 www。

:port(端口)定义主机的端口号。端口号通常是被省略的。缺省的端口号是 80。

path（路径）定义服务器上的路径（一个辅助的路径）。如果路径被省略，资源（文档）会被定位到网站的根目录。

filename（文件名）定义文档的名称。缺省的文件名一般会是 default.asp 或者 index.html，或者依据 WEB 服务器设置的其他文件名。

编者注：URL 的英文全称是 Uniform Resource Locator，中文也译为“统一资源定位符”。

URL Schemes

以下是其中一些最流行的 scheme：

Schemes | 访问
file | 本地 PC 上的文件。
ftp | FTP 服务器上的文件。
http | World Wide Web 服务器上的文件。
gopher | Gopher 服务器上的文件。
news | Usenet 新闻组。
telnet | Telnet 连接。
WAIS | WAIS 服务器上的文件。

访问新闻组

以下 HTML 代码创建一个指向新闻组的链接：

<a href="news:alt.html">HTML Newsgroup</a>

这个链接显示如下：HTML Newsgroup

使用 FTP 进行下载

以下 HTML 代码创建一个下载文件的链接：

<a href="ftp://www.w3school.com.cn/ftp/winzip.exe">Download WinZip</a>

这个链接显示如下：Download WinZip

（这个链接是无法工作的，它仅仅是个例子，所以无需尝试。我们没有提供 FTP 目录。）

链接到邮件系统

以下 HTML 代码创建一个指向您的邮件系统的链接：

<a href="mailto:someone@w3school.com.cn">someone@w3school.com.cn</a>

这个链接显示如下：someone@w3school.com.cn

  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 头部

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 头部

  • Previous Page
  • Next Page

实例

文档的标题
头元素内部的标题信息不会显示在浏览器窗口中。
一个 target，所有的链接
本例显示如何使用 base 标签使页面中的所有标签在新窗口中打开。

头元素

头元素包含关于文档的概要信息，也称为元信息（meta-information）。Meta 意为“关于某方面的信息”。

可以这么说，元数据（meta-data）是关于数据的信息，而元信息是关于信息的信息。

头元素内的信息

头元素内的元素不会被浏览器显示出来。

根据 HTML 标准，仅有几个标签在 HTML 的头部分是合法的。它们是：<base>, <link>, <meta>, <title>, <style> 和 <script>。

这是一个不合法的结构：

<head>
  <p>This is some text</p>
</head>

在这个案例中，浏览器有两种选择：

  • 显示文本，因为它在段落元素中。
  • 隐藏文本，因为它在头元素中。

假如你将 <h1> 或者 <p> 之类的 HTML 元素像这样置于头元素之中，大多数浏览器都会显示它，即使这是非法的。

浏览器真的应该忽略这个的错误吗？我们不这么认为。即使别人这么认为。

Head 标签

标签 | 描述
<head> | 定义关于文档的信息。
<title> | 定义文档标题。
<base> | 定义页面中所有链接的基准 URL。
<link> | 定义资源引用。
<meta> | 定义元信息。
标签 | 描述
<!DOCTYPE> | 定义文档类型。此标签须位于 html 标签之前。
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 图像

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 图像

  • Previous Page
  • Next Page

通过使用 HTML，可以在文档中显示图像。

实例

插入图像
本例演示如何在网页中显示图像。
从不同的位置插入图片
本例演示如何将其他文件夹或服务器的图片显示到网页中。

（可以在本页底端找到更多实例。）

图像标签（<img>）和源属性（Src）

在 HTML 中，图像由 <img> 标签定义。

<img> 是空标签，意思是说，它只包含属性，并且没有闭合标签。

要在页面上显示图像，你需要使用源属性（src）。src 指 "source"。源属性的值是图像的 URL 地址。

定义图像的语法是：

<img src="url" />

URL 指存储图像的位置。如果名为 "boat.gif" 的图像位于 www.w3school.com.cn 的 images 目录中，那么其 URL 为 http://www.w3school.com.cn/images/boat.gif。

浏览器将图像显示在文档中图像标签出现的地方。如果你将图像标签置于两个段落之间，那么浏览器会首先显示第一个段落，然后显示图片，最后显示第二段。

替换文本属性（Alt）

alt 属性用来为图像定义一串预备的可替换的文本。替换文本属性的值是用户定义的。

<img src="boat.gif" alt="Big Boat">

在浏览器无法载入图像时，替换文本属性告诉读者她们失去的信息。此时，浏览器将显示这个替代性的文本而不是图像。为页面上的图像都加上替换文本属性是个好习惯，这样有助于更好的显示信息，并且对于那些使用纯文本浏览器的人来说是非常有用的。

基本的注意事项 - 有用的提示：

假如某个 HTML 文件包含十个图像，那么为了正确显示这个页面，需要加载 11 个文件。加载图片是需要时间的，所以我们的建议是：慎用图片。

更多实例

背景图片
本例演示如何向 HTML 页面添加背景图片。
排列图片
本例演示如何在文字中排列图像。
浮动图像
本例演示如何使图片浮动至段落的左边或右边。
调整图像尺寸
本例演示如何将图片调整到不同的尺寸。
为图片显示替换文本
本例演示如何为图片显示替换文本。在浏览器无法载入图像时，替换文本属性告诉读者们失去的信息。为页面上的图像都加上替换文本属性是个好习惯。
制作图像链接
本例演示如何将图像作为一个链接使用。
创建图像映射
本例显示如何创建带有可供点击区域的图像地图。其中的每个区域都是一个超级链接。
把图像转换为图像映射
本例显示如何把一幅普通的图像设置为图像映射。

图像标签

标签 | 描述
<img> | 定义图像。
<map> | 定义图像地图。
<area> | 定义图像地图中的可点击区域。
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 文本格式化

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 文本格式化

  • Previous Page
  • Next Page

HTML 可定义很多供格式化输出的元素，比如粗体和斜体字。

下面有很多例子，您可以亲自试试：

HTML 文本格式化实例

文本格式化
此例演示如何在一个 HTML 文件中对文本进行格式化
预格式文本
此例演示如何使用 pre 标签对空行和空格进行控制。
“计算机输出”标签
此例演示不同的“计算机输出”标签的显示效果。
地址
此例演示如何在 HTML 文件中写地址。
缩写和首字母缩写
此例演示如何实现缩写或首字母缩写。
文字方向
此例演示如何改变文字的方向。
块引用
此例演示如何实现长短不一的引用语。
删除字效果和插入字效果
此例演示如何标记删除文本和插入文本。

如何查看 HTML 源码

您是否有过这样的经历，当你看到一个很棒的站点，你会很想知道开发人员是如何将它实现的？

你有没有看过一些网页，并且想知道它是如何做出来的呢？

要揭示一个网站的技术秘密，其实很简单。单击浏览器的“查看”菜单，选择“查看源文件”即可。随后你会看到一个弹出的窗口，窗口内就是实际的 HTML 代码。

文本格式化标签

标签 | 描述
<b> | 定义粗体文本。
<big> | 定义大号字。
<em> | 定义着重文字。
<i> | 定义斜体字。
<small> | 定义小号字。
<strong> | 定义加重语气。
<sub> | 定义下标字。
<sup> | 定义上标字。
<ins> | 定义插入字。
<del> | 定义删除字。
<s> | 不赞成使用。使用 <del> 代替。
<strike> | 不赞成使用。使用 <del> 代替。
<u> | 不赞成使用。使用样式（style）代替。

“计算机输出”标签

标签 | 描述
<code> | 定义计算机代码。
<kbd> | 定义键盘码。
<samp> | 定义计算机代码样本。
<tt> | 定义打字机代码。
<var> | 定义变量。
<pre> | 定义预格式文本。
<listing> | 不赞成使用。使用 <pre> 代替。
<plaintext> | 不赞成使用。使用 <pre> 代替。
<xmp> | 不赞成使用。使用 <pre> 代替。

引用、引用和术语定义

标签 | 描述
<abbr> | 定义缩写。
<acronym> | 定义首字母缩写。
<address> | 定义地址。
<bdo> | 定义文字方向。
<blockquote> | 定义长的引用。
<q> | 定义短的引用语。
<cite> | 定义引用、引证。
<dfn> | 定义一个定义项目。
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 颜色

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 颜色

  • Previous Page
  • Next Page

颜色由红色、绿色、蓝色混合而成。

颜色值

颜色由一个十六进制符号来定义，这个符号由红色、绿色和蓝色的值组成（RGB）。

每种颜色的最小值是0（十六进制：#00）。最大值是255（十六进制：#FF）。

这个表格给出了由三种颜色混合而成的具体效果：

Color | Color HEX | Color RGB
 | #000000 | rgb(0,0,0)
 | #FF0000 | rgb(255,0,0)
 | #00FF00 | rgb(0,255,0)
 | #0000FF | rgb(0,0,255)
 | #FFFF00 | rgb(255,255,0)
 | #00FFFF | rgb(0,255,255)
 | #FF00FF | rgb(255,0,255)
 | #C0C0C0 | rgb(192,192,192)
 | #FFFFFF | rgb(255,255,255)

颜色名

大多数的浏览器都支持颜色名集合。

提示：仅仅有 16 种颜色名被 W3C 的 HTML4.0 标准所支持。它们是：aqua, black, blue, fuchsia, gray, green, lime, maroon, navy, olive, purple, red, silver, teal, white, yellow。

如果需要使用其它的颜色，需要使用十六进制的颜色值。

Color | Color HEX | Color Name
 | #F0F8FF | AliceBlue
 | #FAEBD7 | AntiqueWhite
 | #7FFFD4 | Aquamarine
 | #000000 | Black
 | #0000FF | Blue
 | #8A2BE2 | BlueViolet
 | #A52A2A | Brown

Web安全色

数年以前，当大多数计算机仅支持 256 种颜色的时候，一系列 216 种 Web 安全色作为 Web 标准被建议使用。其中的原因是，微软和 Mac 操作系统使用了 40 种不同的保留的固定系统颜色（双方大约各使用 20 种）。

我们不确定如今这么做的意义有多大，因为越来越多的计算机有能力处理数百万种颜色，不过做选择还是你自己。

216 跨平台色

最初，216 跨平台 web 安全色被用来确保：当计算机使用 256 色调色板时，所有的计算机能够正确地显示所有的颜色。

000000 | 000033 | 000066 | 000099 | 0000CC | 0000FF
003300 | 003333 | 003366 | 003399 | 0033CC | 0033FF
006600 | 006633 | 006666 | 006699 | 0066CC | 0066FF
009900 | 009933 | 009966 | 009999 | 0099CC | 0099FF
00CC00 | 00CC33 | 00CC66 | 00CC99 | 00CCCC | 00CCFF
00FF00 | 00FF33 | 00FF66 | 00FF99 | 00FFCC | 00FFFF
330000 | 330033 | 330066 | 330099 | 3300CC | 3300FF
333300 | 333333 | 333366 | 333399 | 3333CC | 3333FF
336600 | 336633 | 336666 | 336699 | 3366CC | 3366FF
339900 | 339933 | 339966 | 339999 | 3399CC | 3399FF
33CC00 | 33CC33 | 33CC66 | 33CC99 | 33CCCC | 33CCFF
33FF00 | 33FF33 | 33FF66 | 33FF99 | 33FFCC | 33FFFF
660000 | 660033 | 660066 | 660099 | 6600CC | 6600FF
663300 | 663333 | 663366 | 663399 | 6633CC | 6633FF
666600 | 666633 | 666666 | 666699 | 6666CC | 6666FF
669900 | 669933 | 669966 | 669999 | 6699CC | 6699FF
66CC00 | 66CC33 | 66CC66 | 66CC99 | 66CCCC | 66CCFF
66FF00 | 66FF33 | 66FF66 | 66FF99 | 66FFCC | 66FFFF
990000 | 990033 | 990066 | 990099 | 9900CC | 9900FF
993300 | 993333 | 993366 | 993399 | 9933CC | 9933FF
996600 | 996633 | 996666 | 996699 | 9966CC | 9966FF
999900 | 999933 | 999966 | 999999 | 9999CC | 9999FF
99CC00 | 99CC33 | 99CC66 | 99CC99 | 99CCCC | 99CCFF
99FF00 | 99FF33 | 99FF66 | 99FF99 | 99FFCC | 99FFFF
CC0000 | CC0033 | CC0066 | CC0099 | CC00CC | CC00FF
CC3300 | CC3333 | CC3366 | CC3399 | CC33CC | CC33FF
CC6600 | CC6633 | CC6666 | CC6699 | CC66CC | CC66FF
CC9900 | CC9933 | CC9966 | CC9999 | CC99CC | CC99FF
CCCC00 | CCCC33 | CCCC66 | CCCC99 | CCCCCC | CCCCFF
CCFF00 | CCFF33 | CCFF66 | CCFF99 | CCFFCC | CCFFFF
FF0000 | FF0033 | FF0066 | FF0099 | FF00CC | FF00FF
FF3300 | FF3333 | FF3366 | FF3399 | FF33CC | FF33FF
FF6600 | FF6633 | FF6666 | FF6699 | FF66CC | FF66FF
FF9900 | FF9933 | FF9966 | FF9999 | FF99CC | FF99FF
FFCC00 | FFCC33 | FFCC66 | FFCC99 | FFCCCC | FFCCFF
FFFF00 | FFFF33 | FFFF66 | FFFF99 | FFFFCC | FFFFFF
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 颜色名

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 颜色名

  • Previous Page
  • Next Page

本页提供了被大多数浏览器支持的颜色名。

提示：仅有 16 种颜色名被 W3C 的 HTML 4.0 标准支持，它们是：aqua、black、blue、fuchsia、gray、green、lime、maroon、navy、olive、purple、red、silver、teal、white、yellow。

如果使用其它颜色的话，就应该使用十六进制的颜色值。

颜色名列表

单击一个颜色名或者 16 进制值,就可以查看与不同文字颜色搭配的背景颜色。

颜色名 | 十六进制颜色值 | 颜色
AliceBlue | #F0F8FF |
AntiqueWhite | #FAEBD7 |
Aqua | #00FFFF |
Aquamarine | #7FFFD4 |
Azure | #F0FFFF |
Beige | #F5F5DC |
Bisque | #FFE4C4 |
Black | #000000 |
BlanchedAlmond | #FFEBCD |
Blue | #0000FF |
BlueViolet | #8A2BE2 |
Brown | #A52A2A |
BurlyWood | #DEB887 |
CadetBlue | #5F9EA0 |
Chartreuse | #7FFF00 |
Chocolate | #D2691E |
Coral | #FF7F50 |
CornflowerBlue | #6495ED |
Cornsilk | #FFF8DC |
Crimson | #DC143C |
Cyan | #00FFFF |
DarkBlue | #00008B |
DarkCyan | #008B8B |
DarkGoldenRod | #B8860B |
DarkGray | #A9A9A9 |
DarkGreen | #006400 |
DarkKhaki | #BDB76B |
DarkMagenta | #8B008B |
DarkOliveGreen | #556B2F |
Darkorange | #FF8C00 |
DarkOrchid | #9932CC |
DarkRed | #8B0000 |
DarkSalmon | #E9967A |
DarkSeaGreen | #8FBC8F |
DarkSlateBlue | #483D8B |
DarkSlateGray | #2F4F4F |
DarkTurquoise | #00CED1 |
DarkViolet | #9400D3 |
DeepPink | #FF1493 |
DeepSkyBlue | #00BFFF |
DimGray | #696969 |
DodgerBlue | #1E90FF |
Feldspar | #D19275 |
FireBrick | #B22222 |
FloralWhite | #FFFAF0 |
ForestGreen | #228B22 |
Fuchsia | #FF00FF |
Gainsboro | #DCDCDC |
GhostWhite | #F8F8FF |
Gold | #FFD700 |
GoldenRod | #DAA520 |
Gray | #808080 |
Green | #008000 |
GreenYellow | #ADFF2F |
HoneyDew | #F0FFF0 |
HotPink | #FF69B4 |
IndianRed | #CD5C5C |
Indigo | #4B0082 |
Ivory | #FFFFF0 |
Khaki | #F0E68C |
Lavender | #E6E6FA |
LavenderBlush | #FFF0F5 |
LawnGreen | #7CFC00 |
LemonChiffon | #FFFACD |
LightBlue | #ADD8E6 |
LightCoral | #F08080 |
LightCyan | #E0FFFF |
LightGoldenRodYellow | #FAFAD2 |
LightGrey | #D3D3D3 |
LightGreen | #90EE90 |
LightPink | #FFB6C1 |
LightSalmon | #FFA07A |
LightSeaGreen | #20B2AA |
LightSkyBlue | #87CEFA |
LightSlateBlue | #8470FF |
LightSlateGray | #778899 |
LightSteelBlue | #B0C4DE |
LightYellow | #FFFFE0 |
Lime | #00FF00 |
LimeGreen | #32CD32 |
Linen | #FAF0E6 |
Magenta | #FF00FF |
Maroon | #800000 |
MediumAquaMarine | #66CDAA |
MediumBlue | #0000CD |
MediumOrchid | #BA55D3 |
MediumPurple | #9370D8 |
MediumSeaGreen | #3CB371 |
MediumSlateBlue | #7B68EE |
MediumSpringGreen | #00FA9A |
MediumTurquoise | #48D1CC |
MediumVioletRed | #C71585 |
MidnightBlue | #191970 |
MintCream | #F5FFFA |
MistyRose | #FFE4E1 |
Moccasin | #FFE4B5 |
NavajoWhite | #FFDEAD |
Navy | #000080 |
OldLace | #FDF5E6 |
Olive | #808000 |
OliveDrab | #6B8E23 |
Orange | #FFA500 |
OrangeRed | #FF4500 |
Orchid | #DA70D6 |
PaleGoldenRod | #EEE8AA |
PaleGreen | #98FB98 |
PaleTurquoise | #AFEEEE |
PaleVioletRed | #D87093 |
PapayaWhip | #FFEFD5 |
PeachPuff | #FFDAB9 |
Peru | #CD853F |
Pink | #FFC0CB |
Plum | #DDA0DD |
PowderBlue | #B0E0E6 |
Purple | #800080 |
Red | #FF0000 |
RosyBrown | #BC8F8F |
RoyalBlue | #4169E1 |
SaddleBrown | #8B4513 |
Salmon | #FA8072 |
SandyBrown | #F4A460 |
SeaGreen | #2E8B57 |
SeaShell | #FFF5EE |
Sienna | #A0522D |
Silver | #C0C0C0 |
SkyBlue | #87CEEB |
SlateBlue | #6A5ACD |
SlateGray | #708090 |
Snow | #FFFAFA |
SpringGreen | #00FF7F |
SteelBlue | #4682B4 |
Tan | #D2B48C |
Teal | #008080 |
Thistle | #D8BFD8 |
Tomato | #FF6347 |
Turquoise | #40E0D0 |
Violet | #EE82EE |
VioletRed | #D02090 |
Wheat | #F5DEB3 |
White | #FFFFFF |
WhiteSmoke | #F5F5F5 |
Yellow | #FFFF00 |
YellowGreen | #9ACD32 |
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 颜色值

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 颜色值

  • Previous Page
  • Next Page

颜色由红色、绿色、蓝色混合而成。

颜色值

颜色由一个十六进制符号来定义，这个符号由红色、绿色和蓝色的值组成（RGB）。每种颜色的最小值是 0（十六进制：#00）。最大值是 255（十六进制：#FF）。

关闭红色

如果将红色完全关闭,绿色和蓝色的组合有 65536 种（256 x 256）。

单击此处查看绿色和蓝色的不同组合。

打开红色

如果将红色设置为最大值,那么仍然存在 65536 种绿色和蓝色的不同组合。

单击此处查看绿色和蓝色的不同组合。

1600万种不同的颜色

通过计算 256 x 256 x 256，从 0 到 255 的红色、绿色和蓝色的值一共可以组合出 1600 万种不同的颜色。

大多数现代的显示器有能力显示出至少 16384 种不同的颜色。

你可以查看下面的色表，你会看到当绿色和蓝色的值为零时，红色值从 0 到 255 时的具体的颜色。

如需查看基于红色从 0 到 255 变化时的 16384 种不同的颜色，请单击下面的十六进制值或者 rgb 颜色值：

Red Light | HEX | RGB
 | #000000 | rgb(0,0,0)
 | #080000 | rgb(8,0,0)
 | #100000 | rgb(16,0,0)
 | #180000 | rgb(24,0,0)
 | #200000 | rgb(32,0,0)
 | #280000 | rgb(40,0,0)
 | #300000 | rgb(48,0,0)
 | #380000 | rgb(56,0,0)
 | #400000 | rgb(64,0,0)
 | #480000 | rgb(72,0,0)
 | #500000 | rgb(80,0,0)
 | #580000 | rgb(88,0,0)
 | #600000 | rgb(96,0,0)
 | #680000 | rgb(104,0,0)
 | #700000 | rgb(112,0,0)
 | #780000 | rgb(120,0,0)
 | #800000 | rgb(128,0,0)
 | #880000 | rgb(136,0,0)
 | #900000 | rgb(144,0,0)
 | #980000 | rgb(152,0,0)
 | #A00000 | rgb(160,0,0)
 | #A80000 | rgb(168,0,0)
 | #B00000 | rgb(176,0,0)
 | #B80000 | rgb(184,0,0)
 | #C00000 | rgb(192,0,0)
 | #C80000 | rgb(200,0,0)
 | #D00000 | rgb(208,0,0)
 | #D80000 | rgb(216,0,0)
 | #E00000 | rgb(224,0,0)
 | #E80000 | rgb(232,0,0)
 | #F00000 | rgb(240,0,0)
 | #F80000 | rgb(248,0,0)
 | #FF0000 | rgb(255,0,0)

灰阶

当所有颜色取相等的值时，灰色就可以被显示出来。为了使您更容易地选择合适的灰色，我们为您制作了一幅灰阶色表。

灰色 | RGB | HEX
 | RGB(0,0,0) | #000000
 | RGB(8,8,8) | #080808
 | RGB(16,16,16) | #101010
 | RGB(24,24,24) | #181818
 | RGB(32,32,32) | #202020
 | RGB(40,40,40) | #282828
 | RGB(48,48,48) | #303030
 | RGB(56,56,56) | #383838
 | RGB(64,64,64) | #404040
 | RGB(72,72,72) | #484848
 | RGB(80,80,80) | #505050
 | RGB(88,88,88) | #585858
 | RGB(96,96,96) | #606060
 | RGB(104,104,104) | #686868
 | RGB(112,112,112) | #707070
 | RGB(120,120,120) | #787878
 | RGB(128,128,128) | #808080
 | RGB(136,136,136) | #888888
 | RGB(144,144,144) | #909090
 | RGB(152,152,152) | #989898
 | RGB(160,160,160) | #A0A0A0
 | RGB(168,168,168) | #A8A8A8
 | RGB(176,176,176) | #B0B0B0
 | RGB(184,184,184) | #B8B8B8
 | RGB(192,192,192) | #C0C0C0
 | RGB(200,200,200) | #C8C8C8
 | RGB(208,208,208) | #D0D0D0
 | RGB(216,216,216) | #D8D8D8
 | RGB(224,224,224) | #E0E0E0
 | RGB(232,232,232) | #E8E8E8
 | RGB(240,240,240) | #F0F0F0
 | RGB(248,248,248) | #F8F8F8
 | RGB(255,255,255) | #FFFFFF
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 样式

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 样式

  • Previous Page
  • Next Page

通过使用 HTML4.0，所有的格式化代码均可移出 HTML 文档，然后移入一个独立的样式表。

实例

HTML中的样式
本例演示如何使用添加到 <head> 部分的样式信息对 HTML 进行格式化。
没有下划线的链接
本例演示如何使用样式属性做一个没有下划线的链接。
链接到一个外部样式表
本例演示如何 <link> 标签链接到一个外部样式表。

如何使用样式

当浏览器读到一个样式表，它就会按照这个样式表来对文档进行格式化。有以下三种方式来插入样式表：

外部样式表

当样式需要被应用到很多页面的时候，外部样式表将是理想的选择。使用外部样式表，你就可以通过更改一个文件来改变整个站点的外观。

<head>
<link rel="stylesheet" type="text/css" href="mystyle.css">
</head>

内部样式表

当单个文件需要特别样式时，就可以使用内部样式表。你可以在 head 部分通过 <style> 标签定义内部样式表。

<head>
<style type="text/css">
body {background-color: red}
p {margin-left: 20px}
</style>
</head>

内联样式

当特殊的样式需要应用到个别元素时，就可以使用内联样式。 使用内联样式的方法是在相关的标签中使用样式属性。样式属性可以包含任何 CSS 属性。以下实例显示出如何改变段落的颜色和左外边距。

<p style="color: red; margin-left: 20px">
This is a paragraph
</p>

访问我们的 CSS 教程，学习更多有关样式的知识。

标签 | 描述
<style> | 定义样式定义。
<link> | 定义资源引用。
<div> | 定义文档中的节或区域（块级）。
<span> | 定义文档中的行内的小块或区域。
<font> | 规定文本的字体、字体尺寸、字体颜色。不赞成使用。请使用样式。
<basefont> | 定义基准字体。不赞成使用。请使用样式。
<center> | 对文本进行水平居中。不赞成使用。请使用样式。
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 元素

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 元素

  • Previous Page
  • Next Page

HTML 文档是由 HTML 元素构成的文本文件。

HTML 元素是通过使用 HTML 标签进行定义的。

HTML 标签
  • HTML 标签是用来标记 HTML 元素的。
  • HTML 标签被 < 和 > 符号包围。
  • 这些包围的符号叫作尖括号。
  • HTML 标签是成对出现的。例如 <b> 和 </b>。
  • 位于起始标签和终止标签之间的文本是元素的内容。
  • HTML 标签对大小写不敏感，<b> 和 <B> 的作用的相同的。

HTML 元素

还记得上一节中的那个例子吗：

<html>

<head>
<title>页面的标题</title>
</head>

<body>
<p>这是我的第一个页面。</p>
<b>此文本是粗体的。</b>
</body>

</html>

这就是一个 HTML 元素：

<b>此文本是粗体的。</b>

这个 HTML 元素由起始标签 <b> 开始。

这个元素的内容是：“此文本是粗体的。”。

这个 HTML 元素由终止标签 </b> 结尾。

<b> 标签的作用是定义一个显示为粗体的 HTML 元素。

这也是一个 HTML 文档：

<body>
<p>这是我的第一个页面。</p>
<b>此文本是粗体的。</b>
</body>

这个 HTML 元素开始于 <body> 标签，结束于 </body> 标签。

<body> 标签的作用是定义 HTML 文件中的容纳 body 的 HTML 元素。

为什么我们要使用小写的标签？

我们刚才讲到：HTML 标签对大小写是不敏感的：<b> 和 <B> 的作用的相同的。当您在网上冲浪时，您会发现大多数教程在他们的例子中都使用大写的HTML标签。而我们总是使用小写。原因何在呢？

如果您希望为使用下一代HTML而做好准备，您就应该使用小写标签。万维网协会 (W3C) 的标准是：建议在 HTML 4 中使用小写标签，而在 XHTML（下一代 HTML）中，必须使用小写标签。

  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 元信息

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 元信息

  • Previous Page
  • Next Page

实例

文档描述
Meta 元素中的信息可以描述 HTML 文档。
文档关键字
Meta 元素中的信息可以描述文档的关键词。
重定向
这个例子演示：在网址已经变更的情况下，将用户重定向到另外一个地址。

Meta元素

正如在上一章中我们所解释的，头元素包含着关于文档的概要信息。

HTML 同样包含位于 head 元素内部的 meta 元素。Meta 元素的作用是提供文档的元信息。

大多数情况下，meta 元素用来提供与浏览器或者搜索引擎相关的信息，比方说描述文档的内容等等。

提示：W3C 声明说：某些用户程序支持使用 META 在设定好的几秒钟后来刷新当前的页面，并将之替换为另一个 url。开发人员不应使用此技术强迫用户转到不同的页面，因为这样会使页面的可用性变差。相反，应使用服务器端重定向来进行自动页面定向。

参阅：http://www.w3.org/TR/html4/struct/global.html#adef-http-equiv。

针对搜索引擎的关键字

某些万维网搜索引擎使用 meta 标签的 name 和 content 属性来索引页面。

这个 Meta 元素定义了对页面的描述:

<meta name="description"
content="Free Web tutorials on HTML, CSS, XML, and XHTML" />

这个 Meta 元素定义了页面的关键字:

<meta name="keywords"
content="HTML, DHTML, CSS, XML, XHTML, JavaScript, VBScript">

name 和 content 属性的作用是描述页面的内容。

然而，由于非常多的网管们使用 meta 标签制造垃圾信息，比方说在页面重复关键词以达到提高排名的目的，一些搜索引擎已经彻底放弃了使用它们。

请阅读我们的 网站构建教程，学习更多关于搜索引擎的知识。

陌生的Meta属性

有时你会发现一些对你来说很陌生的 meta 属性，比方说：

<meta name="security" content="low">。

其实你只需明白，这些东西对于站点或者开发人员来说具有某种特殊的意义，而也许对你来说没有什么关系。

你也可以在我们的完整的 HTML4.01 标签参考手册 中找到更多有关 meta 标签 的信息。

  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 字符实体

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 字符实体

  • Previous Page
  • Next Page

诸如 “<” 之类的符号在HTML中拥有特殊的含义，所以在文本中使用它们。

为了在 HTML 中显示小于号 (<)，我们需要使用字符实体。

字符实体

一些字符在 HTML 中拥有特殊的含义，比如小于号 (<) 用于定义 HTML 标签的开始。如果我们希望浏览器正确地显示这些字符，我们必须在 HTML 源码中插入字符实体。

字符实体有三部分：一个和号 (&)，一个实体名称，或者 # 和一个实体编号，以及一个分号 (;)。

要在 HTML 文档中显示小于号，我们需要这样写：&lt; 或者 &#60;

使用实体名称而不是实体编号的好处在于，名称相对来说更容易记忆。而这么做的坏处是，并不是所有的浏览器都支持最新的实体名称，然而几乎所有的浏览器对实体编号的支持都很好。

注意：实体对大小写敏感。

亲手实验一下字符实体。（仅支持IE）

空格

空格是 HTML 中最普通的字符实体。

通常情况下，HTML 会裁掉文档中的空格。假如你在文档中连续输入 10 个空格，那么 HTML 会去掉其中的9个。如果使用 &nbsp;，就可以在文档中增加空格。

最常用的字符实体

显示结果 | 描述 | 实体名称 | 实体编号
 | 空格 | &nbsp; | &#160;
< | 小于号 | &lt; | &#60;
> | 大于号 | &gt; | &#62;
& | 和号 | &amp; | &#38;
" | 引号 | &quot; | &#34;
' | 撇号 | &apos; (IE不支持) | &#39;

其他一些常用的字符实体

显示结果 | 描述 | 实体名称 | 实体编号
￠ | 分 | &cent; | &#162;
£ | 镑 | &pound; | &#163;
¥ | 日圆 | &yen; | &#165;
§ | 节 | &sect; | &#167;
© | 版权 | &copy; | &#169;
® | 注册商标 | &reg; | &#174;
× | 乘号 | &times; | &#215;
÷ | 除号 | &divide; | &#247;
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 字体

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 字体

  • Previous Page
  • Next Page

在 HTML 中，字体标签是不被支持的。一般都认为，在今后版本的 HTML 中，这个标签会被清除出去。

即使很多人都在用它，我们都应该尽量避免它，而使用样式取而代之。

字体标签font

使用类似下面的HTML代码，你可以定义浏览器输出的尺寸和类型：

<p>
<font size="2" face="Verdana">
This is a paragraph.
</font>
</p>

<p>
<font size="3" face="Times">
This is another paragraph.
</font>
</p>

TIY

字体属性

属性 | 例子 | 作用
size="number" | size="2" | 定义字体大小。
size="+number" | size="+1" | 增加字体的大小。
size="-number" | size="-1" | 减少字体的大小。
face="face-name" | face="Times" | 定义字体名称。
color="color-value" | color="#eeff00" | 定义字体颜色。
color="color-name" | color="red" | 定义字体颜色。

请不要使用字体标签

在最新的 HTML 版本（HTML 4 和 XHTML）中，字体标签已被废弃。

万维网联盟已从其标准中删除了字体标签，在未来，样式表（CSS）将用来定义布局，以及显示 HTML 元素的属性。

正确的方法 - 使用样式

设置文字的字体
本例演示如何设置文字的字体。
设置文字的尺寸
本例演示如何设置文字的尺寸。
设置文字的颜色
本例演示如何设置文字的颜色。
设置文字的字体、字体尺寸、字体颜色
本例演示如何设置文字的字体、字体尺寸、字体颜色.

在何处可以学习到样式表？

马上开始：把本教程完整地学习完毕！！！在随后的章节，我们将解释为什么类似 <font> 这样的标签会从标准中删除，以及如何在 HTML 文档中插入样式表。

学习更多关于样式表的知识：学习我们的 CSS 教程。

  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML背景

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 背景

  • Previous Page
  • Next Page

好的背景使站点看上去特别棒。

实例

搭配良好的背景和颜色
一个背景颜色和文字颜色搭配良好的例子，使页面中的文字易于阅读。
搭配得不好的背景和颜色
一个背景颜色和文字颜色搭配得不好的例子，使页面中的文字难于阅读。

（可以在本页底端找到更多实例。）

背景（Backgrounds）

<body> 拥有两个配置背景的标签。背景可以使颜色或者图像。

背景颜色（Bgcolor）

背景颜色属性将背景设置为某种颜色。属性值可以是十六进制数、RGB 值或颜色名。

<body bgcolor="#000000">
<body bgcolor="rgb(0,0,0)">
<body bgcolor="black">

以上的代码均将背景颜色设置为黑色。

背景（Background）

背景属性将背景设置为图像。属性值为图像的URL。如果图像尺寸小于浏览器窗口，那么图像将在整个浏览器窗口进行复制。

<body background="clouds.gif">
<body background="http://www.w3school.com.cn/clouds.gif">

URL可以是相对地址，如第一行代码。也可以使绝对地址，如第二行代码。

提示：如果你打算使用背景图片，你需要紧记一下几点：

  • 背景图像是否增加了页面的加载时间。小贴士：图像文件不应超过 10k。
  • 背景图像是否与页面中的其他图象搭配良好。
  • 背景图像是否与页面中的文字颜色搭配良好。
  • 图像在页面中平铺后，看上去还可以吗？
  • 对文字的注意力被背景图像喧宾夺主了吗？

基本的注意事项 - 有用的提示：

<body> 标签中的背景颜色（bgcolor）、背景（background）和文本（text）属性在最新的 HTML 标准（HTML4 和 XHTML）中已被废弃。W3C 在他们的推荐标准中已删除这些属性。

应该使用层叠样式表（CSS）来定义 HTML 元素的布局和显示属性。

更多实例

可用性强的背景图像
背景图像和文字颜色使页面文本易于阅读的例子。
可用性强的背景图像 2
另一个背景图像和文字颜色使页面文本易于阅读的例子。
可用性差的背景图像
背景图像和文字颜色使页面文本不易阅读的例子。
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


基本的 HTML 标签

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

基本的 HTML 标签

  • Previous Page
  • Next Page

HTML 中最重要的标签是定义标题、段落和换行的标签。

学习 HTML 最好的方式就是边学边做实验。我们为您准备了很好的 HTML 编辑器。使用这个编辑器，您可以任意编辑一段 HTML 源码，然后单击 TIY 按钮来查看结果。

实例

一个简单的 HTML 文件
这个例子是一个很简单的 HTML 文件，使用了尽可能少的 HTML 标签。它向您演示了 body 元素中的内容是如何被浏览器显示的。
简单的段落
此例演示：段落元素中的文字如何被浏览器显示。

（您可以在页面的底部找到更多实例）

标题

标题使用 <h1> 至 <h6> 标签进行定义。<h1> 定义最大的标题。<h6> 定义最小的标题。

<h1>This is a heading</h1>
<h2>This is a heading</h2>
<h3>This is a heading</h3>
<h4>This is a heading</h4>
<h5>This is a heading</h5>
<h6>This is a heading</h6>

HTML 会自动在标题前后添加一个额外的折行。

段落

段落使用 <p> 标签进行定义。

<p>This is a paragraph</p>
<p>This is another paragraph</p>

HTML 会自动在段落前后添加一个额外的空行。

不要忘记关闭标签

您可能注意到了，在编写段落时可以不带有 </p> 标签：

<p>This is a paragraph
<p>This is another paragraph

上面的例子在大多数浏览器中都可以工作，但是不要依赖这种做法。HTML 未来的版本不允许省略任何结束标签。

通过结束标签来关闭 HTML 是一种经得起未来考验的 HTML 编写方法。清楚地标记某个元素在何处开始，并在何处结束，不论对您还是对浏览器来说，都会使代码更容易理解。

换行符

当你打算结束一行，而又不想开始一个新段落时，<br> 标签就派上用场了。无论你将它置于何处，<br> 标签都会产生一个强制的换行。

<p>This <br> is a para<br>graph with line breaks</p>

<br> 标签是空白标签，由于关闭标签没有任何意义，因此它没有类似 </br> 的终止标签。

<br> 还是 <br />

您会越来越多地发现 <br> 与 <br /> 很相似。

由于 <br> 没有结束标签，它也就违反了未来的 HTML 的规则之一，即所有的元素都必须关闭。

把这个标签写为 <br /> 是经得起未来考验的做法，XHTML 和 XML 都接受在打开的标签内部来关闭标签的做法。

HTML 注释

注释标签用于在 HTML 源码中插入注释。注释会被浏览器忽略。您可以使用注释对您的代码进行解释，这么做在以后的日子里会对您的代码编辑产生帮助。

<!-- This is a comment -->

注意：左括号后需要写一个惊叹号，右括号前就不需要了。

对 HTML 元素的重新认识

  • 每个 HTML 元素都有一个元素名（比如 body、h1、p、br）
  • 开始标签是被括号包围的元素名
  • 结束标签是被括号包围的斜杠和元素名
  • 元素内容位于开始标签和结束标签之间
  • 某些 HTML 元素没有内容
  • 某些 HTML 元素没有结束标签

基本的注意事项 - 有益的提示

当您写 HTML 文本的时候，你永远也没法确定这些文本在另一台显示器上是如何显示的。一些人使用大显示器，而另一些使用小的。当用户调整视窗的分辨率时，这些文本就会被重新格式化。所以不要通过在文本中添加空行和空格的办法在你的编辑器中格式化文本。

HTML 会裁掉文本中所有的空格。任何数量的空格都被按一个空格计数。另外，在 HTML 中，一个空行也被当作一个空格。

使用空的段落标记 <p> 去插入一个空行是个坏习惯。用 <br> 标签代替它！（但是不要用 <br> 标签去创建列表。不要着急，您将在稍后的篇幅学习到 HTML 列表。）

您也许已经注意到了，在没有结束标签 </p> 的情况下，<p> 标签依然可以正常工作。不过不要这样做！下一个版本的 HTML 将不允许忽略任何的结束标签。

HTML 会自动地在某些元素前后添加一个额外的空行，比如段落、标题元素前后。

使用水平线 (<hr> 标签) 来分隔文章中的小节是一个办法（但并不是唯一的办法）。

更多实例

更多的段落
本例演示段落元素的某些缺省的行为。
“诗歌”问题
本例演示 HTML 格式化的某些问题。
折行
本例演示在 HTML 文档中折行的使用。
标题
本例演示在 HTML 文档中显示标题的标签。
水平线
本例演示如何插入水平线。
隐藏的注释
本例演示如何在 HTML 源代码中插入隐藏的注释。

基本的 HTML 标签

标签 | 描述
<html> | 定义 HTML 文档。
<body> | 定义文档的主体。
<h1> to <h6> | 定义标题 1 至标题 6。
<p> | 定义段落。
<br> | 插入折行。
<hr> | 定义水平线。
<!--> | 定义注释。
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


你已经将 HTML 教程学习完毕，下一步该学习什么呢？

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

你已经将 HTML 教程学习完毕，下一步该学习什么呢？

  • Previous Page
  • Next Page

HTML 概要

本教程已教你如何使用 HTML 创建站点。

HTML 是一种在 Web 上使用的通用标记语言。HTML 允许你格式化文本，添加图片，创建链接、输入表单、框架和表格等等，并可将之存为文本文件，浏览器即可读取和显示。

HTML 的关键是标签，其作用是指示将出现的内容。

如需更多关于 HTML 的信息，请查看我们的 HTML 实例 和 HTML 参考手册 。

现在，你已学完HTML，接下来该学习什么呢？

下一步，你应该学习 XHTML 和 CSS 。

XHTML

XHTML 是新的 HTML 。最新的HTML版本是 HTML 4.01，同时也是最终的版本。

HTML 将被 XHTML 取代，XHTML 是更严格且更纯净的 HTML 版本。

如需学习 XHTML，请访问我们的 XHTML 教程 。

CSS

CSS被用来同时控制多重网页的样式和布局。

通过使用 CSS，所有的格式化均可从 HTML 中剥离处来，并存储于一个独立的文件中。

CSS 给予你对布局的完全控制，同时不会弄乱文档内容。

如需学习如何创建样式表，请访问我们的 CSS 教程 。

  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


为什么使用 HTML4.0？

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

为什么使用 HTML4.0？

  • Previous Page
  • Next Page

HTML 3.2 真的是特别糟糕！

最初的 HTML 绝没有打算要包含支持格式化文档的标签。HTML 标签原打算用于定义文档的的内容。

<p>This is a paragraph</p>

<h1>This is a heading</h1>

当诸如 <font> 这样的标签和 color 属性被加入 HTML3.2 的规范当中，它开始成为开发者的一场噩梦。那些不得不将字体和文字信息添加到每个单一网页的站点，其开发过程最终变成了漫长、昂贵和极其痛苦的过程。

HTML4.0 的优秀特性

通过使用 HTML4.0，所有的格式化信息都可以从 HTML 文件中剥离，并植入一个独立的样式表。

因为 HTML4.0 将文档的表现与其结构分离，我们从而得到了我们一直需要的东西：在不把文档内容搞糟的情况下，对表现层进行完全的控制。

我们应该做些什么？

停止在 HTML 标签内部使用表现样式属性。

我们的完整的 HTML 标签参考手册对 HTML4.0 标签和属性进行了简要的说明。

请同时参阅我们的 CSS 教程，开始您崭新的开发生涯吧。

为 XHTML 做好准备

XHTML 是新的 HTML。你现在就应该为此做好准备。而您可以做的最重要的事情就是开始编写正确的 HTML4.01 代码。并且使用小写字母编写标签。记得关闭标签。决不要在没有 </p> 标签的情况下结束一个段落。

提示：官方的 HTML4.01 标准推荐使用小写的标签。

如果您希望学习如何将站点升级至 XHTML，请阅读我们的 XHTML 教程。

验证 HTML文件

HTML 文档是根据文档类型声明进行验证的。如果希望 HTML 文件被正确地验证，就要将恰当的 DTD 添加到文件的第一行。

HTML 4.01 Strict DTD 包含没有被反对使用或者不出现在框架中的元素和属性：

<!DOCTYPE HTML PUBLIC
"-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd">

HTML 4.01 Transitional DTD 包含 strict DTD 中所有的内容，外加被反对使用的元素和属性：

<!DOCTYPE HTML PUBLIC
"-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">

HTML 4.01 Frameset DTD 包含 transitional DTD 中所有的内容，外加对框架的支持：

<!DOCTYPE HTML PUBLIC
"-//W3C//DTD HTML 4.01 Frameset//EN"
"http://www.w3.org/TR/html4/frameset.dtd">

通过 W3C 的验证器来测试您的网页：

在下面的文本框中输入您的网址：（比如 http://www.w3school.com.cn/）

  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


准备好发布你的作品了吗？

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

准备好发布你的作品了吗？

  • Previous Page
  • Next Page

第一步：个人 WEB 服务器（PWS）

  • 如果你希望其他人访问你的页面，就必须发布它们。
  • 要发布你的作品，你就要将你的文件拷贝到 WEB 服务器。
  • 你自己的 PC 也可以作为 WEB 服务器使用，不过前提是它必须接入互联网。
  • 如果使用的是 Windows 98，你可以用 PWS (Personal Web Server)。
  • 你可以在 Windows 的安装 CD 的 PWS 文件夹中找到 PWS。

Personal Web Server (PWS)

PWS 可以将任何视窗计算机改造成 WEB 服务器。PWS 易于安装，同时也是开发和测试 WEB 应用程序的理想平台。PWS 为工作站进行了优化，不过仍然拥有一个完整的 WEB 服务器所有的必备条件。

如何安装 Personal Web Server (PWS):

  • 浏览你的 Windows 安装程序，看一下 PWS 已经被安装。
  • 如果没有，从 Windows 安装 CD 的 PWS 目录安装 PWS。
  • 根据安装提示进行安装，然后启动运行你的 PWS。

如需更多信息，请参阅微软站点：如何安装 Microsoft Personal Web Server。

提示：微软的 Windows XP 家庭版不提供对 PWS 的支持。

Internet Information Server (IIS)

Windows 2000 内置的 WEB 服务器 IIS，使得创建针对网络的大型应用程序变得简单。PWS 和 IIS 均包含 ASP，一种用于创建动态和交互性 WEB 应用程序的服务器端脚本标准。同时，IIS 也可以应用于 Windows NT 平台。

如果希望阅读更多关于 ASP 的内容，请阅读我们的 ASP 教程。

更多关于微软 Internet Information Services 的信息。

下一步: 专业的 Web Server ?

  • 假如你不打算使用 PWS 和 IIS，那么你需要将文件上传到一个公共的空间。
  • 大多数因特网服务提供商均提供网页寄存服务。
  • 如果你的老板有一个因特网的服务器，你也可以要求他为你寄存网页。
  • 当然，如果你对此极为认真的话，你应该搭建自己的因特网服务器。

在你选择一个 ISP 之前，一定要阅读我们的《网站主机教程》。

  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 5 <!DOCTYPE> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <!DOCTYPE> 标签

定义和用法

<!DOCTYPE> 声明是文档中的第一个成分，位于 <html> 标签之前。该标签告知浏览器文档所使用的 HTML 规范。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 4.01 中有 3 个不同的文档类型，在 HTML 5 中只有一个：<!DOCTYPE HTML>。

提示和注释：

注释：<!DOCTYPE> 标签没有结束标签！

提示：<!DOCTYPE> 对大小写不敏感。

HTML 5

在 HTML5 中，文档类型声明很简单：

<!DOCTYPE HTML>

在所有 HTML 文档中规定文档类型很重要，这样浏览器才能了解所预期的文档类型。

HTML 4.01 中的 doctype 需要引用一个 DTD，这是因为 HTML 4.01 基于 SGML。HTML 5 不基于 SGML，也不需要引用 DTD，但是需要声明文档类型让浏览器按照它们应该的方式来运行。

属性：NONE


HTML 5 <a> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <a> 标签

定义和用法

<a> 标签定义超链接，它用于从一个页面连接到另一个页面。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 4.01 中，<a> 标签既可以是超链接，也可以是锚。这取决于是否描述了 href 属性。

在 HTML 5 中，<a> 是超链接，但是假如没有 href 属性，它仅仅是超链接的一个占位符。

HTML 5 有一些新的属性，同时不再支持一些 HTML 4.01 的属性。

例子：

链接到 w3school：

<a href="http://www.w3school.com.cn">W3School</a>

在新窗口中打开 w3school：

<a href="http://www.w3school.com.cn" target="_blank">W3School</a>

属性

属性 | 描述 | 4 | 5
charset | 不赞成。规定目标 URL 的字符编码。 | 4 |
coords | 不赞成。规定适于 shape 属性的坐标，为图像映射定义图像的区域。 | 4 |
href | 链接的目标 URL。 | 4 | 5
hreflang | 规定目标 URL 的基准语言。仅在 href 属性存在时使用。 | 4 | 5
media | 规定目标 URL 的媒介类型。默认值：all。仅在 href 属性存在时使用。 |  | 5
name | 不赞成。命名一个锚。不支持。使用 id 代替。 | 4 |
ping | 由空格分隔的 URL 列表，当用户点击该链接时，这些 URL 会获得通知。 仅在 href 属性存在时使用。 |  | 5
rel | 规定当前文档与目标 URL 之间的关系。仅在 href 属性存在时使用。 | 4 | 5
rev | 不赞成。规定目标 URL 与当前文档之间的关系。 | 4 |
shape | 不赞成。为当前 area 标签中的映射定义的地区类型。与 coords 属性一起使用。 | 4 |
target | 在何处打开目标 URL。仅在 href 属性存在时使用。 | 4 | 5
type | 规定目标 URL 的 MIME 类型。仅在 href 属性存在时使用。 | 4 | 5

标准属性

class, contenteditable, contextmenu, dir, draggable, id,
irrelevant, lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。

TIY 实例

创建超级链接
本例演示如何在 HTML 文档中创建链接。
将图像作为链接
本例演示如何使用图像作为链接。
在新的浏览器窗口打开链接
本例演示如何在新窗口打开一个页面，这样的话访问者就无需离开你的站点了。
创建电子邮件链接
本例演示如何如何链接到一个邮件。（本例在安装邮件客户端程序后才能工作。）
创建电子邮件链接 2
本例演示更加复杂的邮件链接。


HTML 5 <abbr> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <abbr> 标签

定义和用法

表示一个缩写形式，比如 "Inc."、"etc."。通过对缩写词语进行标记，您就能够为浏览器、拼写检查程序、翻译系统以及搜索引擎分度器提供有用的信息。

<abbr> 标签最初是在 HTML 4.0 中引入的，表示它所包含的文本是一个更长的单词或短语的缩写形式。

浏览器可能会根据这个信息改变对这些文本的显示方式，或者用其他文本代替。也许当前流行的浏览器对 <abbr> 标签中包含的文本还没有任何处理方式，但是我们无法预测将来的版本将会如何实现该标签。

HTML 4.01 与 HTML 5 之间的差异

NONE

例子：

<abbr title="etcetera">etc.</abbr>

输出：

etc.

提示和注释：

注释：在某些浏览器中，当您把鼠标移至缩略词语上时，title 可被用来展示表达的完整版本。

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。

TIY 实例

缩写和首字母缩写
此例演示如何实现缩写或首字母缩写。


HTML 5 <acronym> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <acronym> 标签

定义和用法

<acronym> 标签定义首字母缩写词，比如 "NASA"。通过对只取首字母缩写进行标记，您就能够为浏览器、拼写检查程序、翻译系统以及搜索引擎分度器提供有用的信息。

HTML 4.01 与 HTML 5 之间的差异

HTML 5 不支持 <acronym>。请使用 <abbr> 代替。

例子：

<acronym title="World Wide Web">WWW</acronym>

输出：

WWW

提示和注释：

注释：在某些浏览器中，当您把鼠标移至缩略词语上时，title 可被用来展示表达的完整版本。


HTML 5 <address> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <address> 标签

定义和用法

<address> 标签为文档或 section 定义联系信息。

HTML 4.01 与 HTML 5 之间的差异

NONE

例子：

<address>
此文档的作者：<a href="mailto:bill@microsoft.com">Bill Gates</a>
</address>

提示和注释：

注释：address 通常被呈现为斜体。大多数浏览器会在 address 元素的前后添加一个换行符，不过如果有必要的话，您需要在地址文本的内容添加额外的换行符。

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。

TIY 实例

缩写和首字母缩写
此例演示如何实现缩写或首字母缩写。


HTML 5 <applet> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <applet> 标签

定义和用法

<applet> 定义嵌入的 applet。

HTML 4.01 与 HTML 5 之间的差异

HTML 4.01 中不赞成使用 applet 元素。

HTML 5 中不支持 applet 元素。

提示和注释：

提示：HTML 5 中不支持 applet 元素。请使用 <object> 代替。


HTML 5 <area> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <area> 标签

定义和用法

<area> 标签定义图像映射中的区域。

HTML 4.01 与 HTML 5 之间的差异

&HTML 5 有一些新的属性，且不再支持 HTML 4.01 的一些属性。

例子：

<img src ="planets.gif" alt="Planets" usemap ="#planetmap" />

<map id ="planetmap">
 <area shape ="rect" coords ="0,0,82,126" href ="sun.htm" alt="Sun" />
 <area shape ="circle" coords ="90,58,3" href ="mercur.htm" alt="Mercury" />
 <area shape ="circle" coords ="124,58,8" href ="venus.htm" alt="Venus" />
</map>

属性

属性 | 描述 | 4 | 5
alt | 定义此区域的替换文本。如果 href 存在，则该属性是必需的。 仅在 href 属性存在时使用。 | 4 | 5
coords | 定义可点击区域的坐标。 | 4 | 5
href | 定义此区域的目标 URL。 | 4 | 5
hreflang | 规定目标 URL 的基准语言。仅在 href 属性存在时使用。 | 4 | 5
nohref | 不赞成。从图像映射排除一个区域。 | 4 |
media | 规定目标 URL 的媒介类型。默认值：all。仅在 href 属性存在时使用。 |  | 5
ping | 由空格分隔的 URL 列表，当用户点击该链接时，这些 URL 会获得通知。 仅在 href 属性存在时使用。 |  | 5
rel | 规定当前文档与目标 URL 之间的关系。仅在 href 属性存在时使用。 |  | 5
shape | 规定区域的形状。 | 4 | 5
target | 在何处打开目标 URL。 | 4 | 5
type | 规定目标 URL 的 MIME 类型。仅在 href 属性存在时使用。 |  | 5

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。

TIY

创建图像映射
本例显示如何创建带有可供点击区域的图像映射。其中的每个区域都是一个超级链接。


HTML 5 <article> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <article> 标签

定义和用法

<article> 标签定义外部的内容。比如来自一个外部的新闻提供者的一篇新的文章，或者来自 blog 的文本，或者是来自论坛的文本。亦或是来自其他外部源内容。

HTML 4.01 与 HTML 5 之间的差异

<article> 标签是 HTML 5 的新标签。

例子：

<article>
<h2>Netscape Is Dead</h2>
AOL has now officially announced that they will end
the development and support of all Netscape browsers.
</article>

提示和注释：

注释：<article> 标签的内容独立于文档的其余部分。

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。


HTML 5 <aside> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <aside> 标签

定义和用法

<aside> 标签定义 article 以外的内容。aside 的内容应该与 article 的内容相关。

HTML 4.01 与 HTML 5 之间的差异

<aside> 标签是 HTML 5 的新标签。

例子：

<aside>Aside 的内容是独立的内容，但应与文档内容相关。</aside>

提示和注释：

注释：<aside> 的内容可用作文档的侧栏。

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。


HTML 5 <audio> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <audio> 标签

定义和用法

<audio> 标签定义声音，比如音乐或其他音频流。

HTML 4.01 与 HTML 5 之间的差异

<audio> 标签是 HTML 5 的新标签。

例子：

<audio src="someaudio.wav">您的浏览器不支持 audio 标签。</audio>

属性

属性 | 值 | 描述
autoplay | true | false | 如果是 true，则音频在就绪后马上播放。
controls | true | false | 如果是 true，则向用户显示控件，比如播放按钮。
end | numeric value | 定义播放器在音频流中的何处停止播放。默认地，声音会播放到结尾。
loopend | numeric value | 定义在音频流中循环播放停止的位置，默认是 end 属性的值。
loopstart | numeric value | 定义在音频流中循环播放的开始位置。默认是 start 属性的值。
playcount | numeric value | 定义音频片断播放多少次。默认是 1。
src | url | 所播放音频的 url。
start | numeric value | 定义播放器在音频流中开始播放的位置。默认地，声音在开头进行播放。

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。


HTML 5 <b> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <b> 标签

定义和用法

<b> 标签定义粗体的文本。

<b> 标签定义了文本中的部分比其余的部分更重要，并呈现为粗体。

HTML 4.01 与 HTML 5 之间的差异

没有区别。

但是在 HTML 4.01 中，我们的理解是使用 CSS 来制作粗体的文本。在 HTML 5 中，我们仍然可以这么理解，不过我们应该使用 <b> 标签定义文本中更重要的部分。

例子：

The house with the <b>red</b> door

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。


HTML 5 <base> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <base> 标签

定义和用法

<base> 标签规定页面中所有链接的基准 url。

HTML 4.01 与 HTML 5 之间的差异

None

例子：

假设图像的绝对地址是：

<img src="http://www.w3school.com.cn/i/pic.gif" />

现在我们在页面中的 head 部分插入 <base> 标签，规定页面中所有链接的基准 url：

<head>
<base href="http://www.w3school.com.cn/i/" />
</head>

在上例中的页面上插入图像时，我们必须规定相对的地址，浏览器会寻找文件所使用的完整 URL：

<img src="pic.gif" />

属性

属性 | 描述 | 5 | 4
href | 规定作为基准 URL 在页面中使用的 URL。 | 4 | 5
target | 在何处打开页面上的链接。该属性会被每个链接中的 target 属性覆盖。 | 4 | 5

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。


HTML 5 <basefont> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <basefont> 标签

定义和用法

<basefont> 标签定义基准字体。

HTML 4.01 与 HTML 5 之间的差异

HTML 5 不支持 <basefont> 标签。请用 CSS 代替。


HTML 5 <bdo> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <bdo> 标签

定义和用法

<bdo> 标签覆盖默认的文本方向。

HTML 4.01 与 HTML 5 之间的差异

NONE

例子：

<bdo dir="rtl">Here is some text</bdo>

属性

属性 值 描述 4 5
dir
  • ltr
  • rtl
 必需。定义文本方向。 4 5

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。

TIY 实例

文字方向
此例演示如何改变文字的方向。


HTML 5 <big> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <big> 标签

定义和用法

<big> 标签制作更大的文本。

HTML 4.01 与 HTML 5 之间的差异

HTML 5 不支持 <big> 标签。请用 CSS 代替。


HTML 5 <blockquote> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <blockquote> 标签

定义和用法

<blockquote> 标签定义引用。

HTML 4.01 与 HTML 5 之间的差异

无。

例子：

毛泽东说过：
<blockquote>帝国主义都是纸老虎 ... </blockquote>

属性

属性 | 值 | 描述 | 4 | 5
cite | URL | 引用的 URL，如果引用来自网络的话。 | 4 | 5

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。

TIY 实例

引用
此例演示如何实现长短不一的引用。


HTML 5 <body> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <body> 标签

定义和用法

body 元素定义文档的主体。其中包含文档的所有内容（比如文本、图像、颜色、图形等等）。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 5 中，删除了所有 <body> 的特殊属性。而那些属性在 HTML 4.01 中是不被赞成使用的。

例子：

<html>

  <head></head>

  <body>文档的内容 ......</body>

</html>

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。

TIY 实例

引用
此例演示如何实现长短不一的引用。


HTML 5 <br> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <br> 标签

定义和用法

<br> 标签插入简单的换行符。

<br> 标签是一个空标签，意味着它没有结束标签。所以这样是错误的：<br></br>

HTML 4.01 与 HTML 5 之间的差异

无。

例子：

This text contains<br />a line break

输出：

This text contains
a line break

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。

TIY 实例

换行
本例演示如何在文档中插入换行符。


HTML 5 <button> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <button> 标签

定义和用法

<button> 标签定义按钮。您可以在 button 元素中放置内容，比如文档或图像。这是该元素与由 input 元素创建的按钮的不同之处。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 5 中有一个新属性：autofocus。

例子：

<button>Click Me!</button>

属性

属性 | 值 | 描述 | 4 | 5
autofocus | true | false | 在页面加载时，是否让按钮获得焦点。 | 5
disabled | disabled | 禁用按钮 | 4 | 5
name | button_name | 为按钮规定为一的名称。 | 4 | 5
type
  • button
  • reset
  • submit
 定义按钮的类型。 4 5
value | some_value | 为按钮规定初始值。该值可通过脚本改变。 | 4 | 5

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。


HTML 5 <canvas> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <canvas> 标签

定义和用法

<canvas> 标签定义图形，比如图表和其他图像。

HTML 4.01 与 HTML 5 之间的差异

<canvas> 标签是 HTML 5 中的新标签。

<canvas> 的历史

这个 HTML 元素是为了客户端矢量图形而设计的。它自己没有行为，但却把一个绘图 API 展现给客户端 JavaScript 以使脚本能够把想绘制的东西都绘制到一块画布上。

<canvas> 标记由 Apple 在 Safari 1.3 Web 浏览器中引入。对 HTML 的这一根本扩展的原因在于，HTML 在 Safari 中的绘图能力也为 Mac OS X 桌面的 Dashboard 组件所使用，并且 Apple 希望有一种方式在 Dashboard 中支持脚本化的图形。

Firefox 1.5 和 Opera 9 都跟随了 Safari 的引领。这两个浏览器都支持 <canvas> 标记。

我们甚至可以在 IE 中使用 <canvas> 标记，并在 IE 的 VML 支持的基础上用开源的 JavaScript 代码（由 Google 发起）来构建兼容性的画布。 参见：http://excanvas.sourceforge.net/。

<canvas> 的标准化的努力由一个 Web 浏览器厂商的非正式协会在推进，目前 <canvas> 已经成为 HTML 5 草案中一个正式的标签。 参见：http://www.whatwg.org/specs/web-apps/current-work/

<canvas> 标记和 SVG 以及 VML 之间的差异

<canvas> 标记和 SVG 以及 VML 之间的一个重要的不同是，<canvas> 有一个基于 JavaScript 的绘图 API，而 SVG 和 VML 使用一个 XML 文档来描述绘图。

这两种方式在功能上是等同的，任何一种都可以用另一种来模拟。从表面上看，它们很不相同，可是，每一种都有强项和弱点。例如，SVG 绘图很容易编辑，只要从其描述中移除元素就行。

要从同一图形的一个 <canvas> 标记中移除元素，往往需要擦掉绘图重新绘制它。

如何使用 <canvas> 标记绘图

大多数 Canvas 绘图 API 都没有定义在 <canvas> 元素本身上，而是定义在通过画布的 getContext() 方法获得的一个“绘图环境”对象上。

Canvas API 也使用了路径的表示法。但是，路径由一系列的方法调用来定义，而不是描述为字母和数字的字符串，比如调用 beginPath() 和 arc() 方法。

一旦定义了路径，其他的方法，如 fill()，都是对此路径操作。绘图环境的各种属性，比如 fillStyle，说明了这些操作如何使用。

注释：Canvas API 非常紧凑的一个原因上它没有对绘制文本提供任何支持。要把文本加入到一个 <canvas> 图形，必须要么自己绘制它再用位图图像合并它，或者在 <canvas> 上方使用 CSS 定位来覆盖 HTML 文本。

例子：

<script type="text/javascript">
function drawCanvas()
{
var canvas=document.getElementById('myCanvas');
var ctx=canvas.getContext('2d');
ctx.fillStyle='#FF0000';
ctx.fillRect(0,0,80,100);
}
</script>
...

<canvas id="myCanvas">
your browser does not support the canvas tag
</canvas>

属性

属性 | 值 | 描述
height | pixels | 设置 canvas 的高度。
width | pixels | 设置 canvas 的宽度。

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。

参阅

HTML DOM Canvas 对象


HTML 5 <caption> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <caption> 标签

定义和用法

<caption> 标签定义表格标题。<caption> 标签必须紧随 <table> 标签之后。

HTML 4.01 与 HTML 5 之间的差异

HTML 4.01 不赞成使用 align 属性。在 HTML 5 中，不支持该标签。请使用 CSS 代替。

例子：

<table>
  <caption>This is a caption</caption>
  <tr>
  <td>Cell 1</td>
  <td>Cell 2</td>
  </tr>
</table>

属性

属性 值 描述 4 5
align
  • left
  • right
  • top
  • bottom
 如何对齐标题。不支持。请使用样式代替。 4

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。


HTML 5 <center> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <center> 标签

定义和用法

<center> 标签对其包围的文本进行水平居中处理。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 5 中，不支持该标签。请使用 CSS 代替。

提示和注释

提示：请使用 CSS 来居中文本。


HTML 5 <col> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <col> 标签

定义和用法

<col> 标签为表格中的一个或多个列定义属性值。您只能在表格或列组中使用该元素。

HTML 4.01 与 HTML 5 之间的差异

4.01 中的大多数属性都不再得到支持。

提示和注释

注释：col 元素是空元素。如需创建列，必须在 tr 元素内规定 td 元素。

提示：如果需要为一个或多个列规定属性值，请使用该元素。

提示：如果需要向一个列组规定相同的属性值，请使用 <colgroup> 元素。

例子：

 <table>
  <col style="color:blue" />
  <col span="2" style="color:yellow" />
  <tr>
    <td>1</td>
    <td>2</td>
    <td>3</td>
    <td>4</td>
  </tr>
  <tr>
    <td>1</td>
    <td>2</td>
    <td>3</td>
    <td>4</td>
  </tr>
</table>

属性

属性 | 值 | 描述 | 4 | 5
align
  • right
  • left
  • center
  • justify
  • char
 定义列中的单元格内容的水平对齐方式。 4
char character

定义一个字符，按照该字符对齐文本。

与 align="char" 使用。

 4
charoff
  • pixels
  • %
 规定第一个对齐字符的偏移量。 4
span | number | 定义 <col> 应当横跨的列数。 | 4 | 5
valign
  • top
  • middle
  • bottom
  • baseline
 定义列中的单元格内容的垂直对齐方式。 4
width
  • %
  • pixels
  • relative_length
 定义列的宽度。 4

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。


HTML 5 <colgroup> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <colgroup> 标签

定义和用法

<colgroup> 标签定义表格列的组。通过此标签，您可以对列进行组合，以便格式化。该元素只有在 <table> 中才是合法的。

HTML 4.01 与 HTML 5 之间的差异

4.01 中的大多数属性都不再得到支持。

提示和注释

注释：colgroup 元素只能包含 col 元素。

注释：colgroup 元素无法创建表格列。如需创建列，必须在 tr 元素内规定 td 元素。

提示：如果需要向一个列组规定相同的属性值，请使用该元素。

提示：如果需要为一个或多个列规定属性值，请使用 col 元素。

例子：

<table>
  <colgroup span="3" style="color:blue"></colgroup>
  <tr>
  <td>1</td>
  <td>2</td>
  <td>3</td>
  <td>4</td>
  </tr>
  <tr>
  <td>1</td>
  <td>2</td>
  <td>3</td>
  <td>4</td>
  </tr>
</table>

属性

属性 | 值 | 描述 | 4 | 5
align
  • right
  • left
  • center
  • justify
  • char
 定义列中的单元格内容的水平对齐方式。 4
char | character | 定义一个字符，按照该字符对齐文本。 | 4
charoff
  • pixels
  • %
 规定第一个对齐字符的偏移量。 4
span | number | 定义 <colgroup> 应当横跨的列数。 | 4 | 5
valign
  • top
  • middle
  • bottom
  • baseline
 定义列中的单元格内容的垂直对齐方式。 4
width
  • %
  • pixels
  • relative_length
 定义列的宽度。 4

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。


HTML 5 <command> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <command> 标签

定义和用法

<command> 标签定义命令按钮，比如单选按钮、复选框或按钮。

HTML 4.01 与 HTML 5 之间的差异

<command> 标签是 HTML 5 中的新标签。

属性

属性 | 值 | 描述
checked | true | false | 定义是否被选中。仅用于 radio 或 checkbox 类型。
default | true | false | 如果为 true，则被激活。仅用于该 command 位于菜单中时。
disabled | true | false | 定义 command 是否可用。
hidden | true | false | 定义 command 是否可见。
icon | url | 定义作为 command 来显示的图像的 url。
label | command name | 为 command 定义名称。label 是可见的。
radiogroup | name of radiogroup | 定义该 command 所属的 radiogroup 的名称。仅在类型为 radio 时使用。
type
  • checkbox
  • command
  • radio
 定义该 command 的类型。默认是 command。

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。


HTML 5 <datagrid> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <datagrid> 标签

定义和用法

<datagrid> 标签定义可选数据的列表。datagrid 作为树列表来显示。

HTML 4.01 与 HTML 5 之间的差异

<datagrid> 标签是 HTML 5 中的新标签。

提示和注释

提示：如果把 multiple 属性设置为 true，则可以在列表中选取一个以上的项目。

属性

属性 | 值 | 描述
disabled | true | false | 如果为 true，则禁用整个 datagrid。
multiple | true | false | 如果为 true，则可以在 datagrid 中选择一个以上的项目。

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。


HTML 5 <datalist> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <datalist> 标签

定义和用法

<datalist> 标签定义可选数据的列表。与 input 元素配合使用，就可以制作出输入值的下拉列表。

HTML 4.01 与 HTML 5 之间的差异

<datalist> 标签是 HTML 5 中的新标签。

例子

<input id="myCar" list="cars" />
<datalist id="cars">
  <option value="BMW">
  <option value="Ford">
  <option value="Volvo">
</datalist>

属性

属性 | 值 | 描述
data | value | 供自动插入数据。

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。


HTML 5 <datatemplate> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <datatemplate> 标签

定义和用法

<datatemplate> 标签定义数据模板的一个容器。该元素必须有定义模板的子元素：<rule> 元素。

HTML 4.01 与 HTML 5 之间的差异

<datatemplate> 标签是 HTML 5 中的新标签。

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。


HTML 5 <dd> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <dd> 标签

定义和用法

<dd> 标签定义一个定义列表中对项目的描述。

HTML 4.01 与 HTML 5 之间的差异

无。

<dl>
  <dt>Coffee</dt>
  <dd>Black hot drink</dd>
  <dt>Milk</dt>
  <dd>White cold drink</dd>
</dl>

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。

TIY 实例

定义列表
本例演示一个定义列表。


HTML 5 <del> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <del> 标签

定义和用法

<dd> 标签定义文档中已删除的文本。

HTML 4.01 与 HTML 5 之间的差异

无。

提示和注释

提示：与 <ins> 一起使用，描述文档中的更新和修正。

例子

a dozen is <del>21</del> 12 pieces

属性

属性 | 值 | 描述 | 4 | 5
cite | URL | 定义指向另一个文档的 URL，该文档解释了文本被删除或插入的原因。 | 4 | 5
datetime | YYYYMMDD | 定义文本被删除的日期和时间。 | 4 | 5

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。

TIY 实例

删除和插入文本
此例演示如何标记文档中删除和插入的文本。


HTML 5 <details> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <details> 标签

定义和用法

<details> 标签定义元素的细节，用户可进行查看，或通过点击进行隐藏。

HTML 4.01 与 HTML 5 之间的差异

<details> 标签是 HTML 5 中的新标签。

提示和注释

提示：与 <legend> 一起使用，来制作 detail 的标题。该标题对用户是可见的，当在其上点击时可打开或关闭 detail。

属性

属性 | 值 | 描述
open | true | false | 定义 details 是否可见。默认是 false。

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。


HTML 5 <dialog> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <dialog> 标签

定义和用法

<dialog> 标签定义对话，比如交谈。

HTML 4.01 与 HTML 5 之间的差异

<dialog> 标签是 HTML 5 中的新标签。

提示和注释

提示：对话中的每个句子都必须属于 <dt> 标签所定义的部分。请看下面的例子。

例子

<dialog>
  <dt>老师</dt>
  <dd>2+2 等于？</dd>
  <dt>学生</dt>
  <dd>4</dd>
  <dt>老师</dt>
  <dd>答对了！</dd>
</dialog>

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。


HTML 5 <dir> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <dir> 标签

定义和用法

<dir> 标签定义目录列表。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 4.01 中，不赞成使用 <dir> 标签。

HTML 5 不支持 <dir> 标签。请用 CSS 代替。


HTML 5 <div> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <div> 标签

定义和用法

<div> 标签定义文档中的 division/section。

HTML 4.01 与 HTML 5 之间的差异

HTML 4.01 中的 "align" 是不赞成使用的，在 HTML 5 中不支持该属性。

提示和注释

注释：浏览器通常会在 div 元素之前和之后插入换行符。

提示：请使用 <div> 标签对块级元素进行组合，这样就可以使用样式对它们进行格式化。

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。


HTML 5 <dl> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <dl> 标签

定义和用法

<dl> 标签定义一个定义列表。

HTML 4.01 与 HTML 5 之间的差异

无。

<dl>
  <dt>Coffee</dt>
  <dd>Black hot drink</dd>
  <dt>Milk</dt>
  <dd>White cold drink</dd>
</dl>

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。

TIY 实例

定义列表
如何创建定义列表。


HTML 5 <dt> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <dt> 标签

定义和用法

<dt> 标签定义一个定义列表中的一个项目，以及 dialog 中的角色。

HTML 4.01 与 HTML 5 之间的差异

HTML 5 引入了 <dialog> 标签。在 dialog 中，<dt> 标签定义句子所属的角色。参见例子 2。

例子

例子 1

<dl>
  <dt>Coffee</dt>
  <dd>Black hot drink</dd>
  <dt>Milk</dt>
  <dd>White cold drink</dd>
</dl>

例子 2

<dialog>
  <dt>老师</dt>
  <dd>2+2 等于？</dd>
  <dt>学生</dt>
  <dd>4</dd>
  <dt>老师</dt>
  <dd>答对了！</dd>
</dialog>

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。

TIY 实例

定义列表
如何创建定义列表。


HTML 5 <em> <strong> <dfn> <code> <samp> <kbd> <var> <cite> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <em> <strong> <dfn> <code> <samp> <kbd> <var> <cite> 标签

定义和用法

以下元素都是短语元素。并不返回使用它们，但是通过使用样式表，可能取得更丰富的效果。

<em> | 呈现为被强调的文本。
<strong> | 定义重要的文本。
<dfn> | 定义一个定义项目。
<code> | 定义计算机代码文本。
<samp> | 定义样本文本。
<kbd> | 定义键盘文本。它表示文本是从键盘上键入的。它经常用在与计算机相关的文档或手册中。
<var> | 定义变量。您可以将此标签与 <pre> 及 <code> 标签配合使用。
<cite> | 定义引用。可使用该标签对参考文献的引用进行定义，比如书籍或杂志的标题。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 4.01 中，<strong> 定义语气更重的强调文本，但是在 HTML 5 中，<strong> 定义重要的文本。

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。

HTML 文本格式化实例

文本格式化
此例演示如何在一个 HTML 文件中对文本进行格式化
“计算机输出”标签
此例演示不同的“计算机输出”标签的显示效果。


HTML 5 <embed> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <embed> 标签

定义和用法

<embed> 标签定义嵌入的内容，比如插件。

HTML 4.01 与 HTML 5 之间的差异

<embed> 标签是 HTML 5 中的新标签。

提示和注释

注释：<embed> 标签必须有 src 属性。

提示：您无法在开始标签和结束标签之间写文本，来说明旧式的浏览器不支持该标签，就像 <audio> 和 <video>。

例子

<embed src="horse.wav" />

属性

属性 | 值 | 描述
height | pixels | 设置嵌入内容的高度。
src | url | 嵌入内容的 URL。
type | type | 定义嵌入内容的类型。
width | pixels | 设置嵌入内容的宽度。

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。


HTML 5 <event-source> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <event-source> 标签

定义和用法

<event-source> 标签定义由服务器发送的事件的来源。

HTML 4.01 与 HTML 5 之间的差异

<event-source> 标签是 HTML 5 中的新标签。

属性

属性 | 值 | 描述
src | url | 其内容类型为 "application/x-dom-event-stream" 的源的 URL。

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。


HTML 5 <fieldset> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <fieldset> 标签

定义和用法

fieldset 元素可将表单内的相关元素分组。

<fieldset> 标签将表单内容的一部分打包，生成一组相关表单的字段。<fieldset> 标签没有必需的或唯一的属性。

当一组表单元素放到 <fieldset> 标签内时，浏览器会以特殊方式来显示它们，它们可能有特殊的边界、3D 效果，或者甚至可创建一个子表单来处理这些元素。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 5 中有一些新属性，同时不再支持 HTML 4.01 中的一些属性。

属性

属性 | 值 | 描述 | 4 | 5
disabled | true | false | 定义 fieldset 是否可见。 |  | 5
form | true | false | 定义该 fieldset 所属的一个或多个表单。 |  | 5

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。

TIY 实例

围绕数据的 Fieldset
本例演示如何在数据周围绘制一个带标题的框。


HTML 5 <figure> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <figure> 标签

定义和用法

<figure> 标签用于对元素进行组合。

HTML 4.01 与 HTML 5 之间的差异

<figure> 标签是 HTML 5 中的新标签。

提示和注释

提示：请使用 <legend> 元素为元素组添加标题。

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。


HTML 5 <font> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <font> 标签

定义和用法

<font> 标签规定文本的字体外观、字体尺寸和字体颜色。不要使用该元素，请使用 CSS 向元素添加样式。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 4.01 中，不赞成使用该元素。

在 HTML 5 中，不支持该元素，但是允许由所见即所得的编辑器来插入该元素 。

在 HTML 5 中，仅支持 style 属性。


HTML 5 <footer> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <footer> 标签

定义和用法

<footer> 标签定义 section 或 document 的页脚。典型地，它会包含创作者的姓名、文档的创作日期以及/或者联系信息。

HTML 4.01 与 HTML 5 之间的差异

<footer> 标签是 HTML 5 中的新标签。

提示和注释

提示：假如您使用 footer 来插入联系信息，应该使用 <address> 元素。

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。


HTML 5 <form> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <form> 标签

定义和用法

<form> 标签创建供用户输入的表单。

表单可包含文本域，复选框，单选按钮等等。表单用于向指定的 URL 传递用户数据。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 5 中有一些新属性，同时不再支持 HTML 4.01 中的一些属性。

在 HTML 5 中有一个新属性：replace。它定义表单被提交后所做的事情。

属性

属性 | 描述 | 4 | 5
action | 定义一个 URL。当点击提交按钮时，向这个 URL 发送数据。 | 4 | 5
data | 供自动插入数据。 |  | 5
replace | 定义表单提交时所做的事情。 |  | 5
accept | 处理该表单的服务器可正确处理的内容类型列表（用逗号分隔）。 | 4 | 5
accept-charset | 表单数据的可能的字符集列表（逗号分隔）。默认值是 "unknown"。 | 4 | 5
enctype | 用于对表单内容进行编码的 MIME 类型。 | 4 | 5
method | 用于向 action URL 发送数据的 HTTP 方法。默认是 get。 | 4 | 5
name | 为表单定义一个唯一的名称。不支持。用 id 代替。 | 4 |
target | 在何处打开目标 URL。 | 4 | 5

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。

TIY 实例

带有输入框和确认按钮的表单
本例演示如何向页面添加表单。此表单包含两个输入框和一个确认按钮。
带有复选框的表单
此表单包含两个复选框和一个确认按钮。
带有单选按钮的表单
此表单包含两个单选框和一个确认按钮。
从表单发送电子邮件
此例演示如何从表单发送电子邮件。


HTML 5 <frame> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <frame> 标签

定义和用法

<frame> 标签定义子窗口（框架）。

由于该标签对网页可用性的负面影响，在 HTML 5 中 <frame> 标签没有得到支持。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 5 中不支持 <frame> 标签。


HTML 5 <frameset> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <frameset> 标签

定义和用法

<frameset> 标签定义框架集。它用于组织多个窗口（框架）。每个框架存在一个独立的文档。在最简单的应用中，frameset 元素仅仅声明框架集中存在的列或行的数目。

由于该标签对网页可用性的负面影响，在 HTML 5 中 <frameset> 标签没有得到支持。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 5 中不支持 <frameset> 标签。


HTML 5 <h1> 至 <h6> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <h1> 至 <h6> 标签

定义和用法

<h1> - <h6> 标签可定义标题。<h1> 定义最大的标题。<h6> 定义最小的标题。

由于 h 元素拥有确切的语义，因此请您慎重地选择恰当的标签层级来构建文档的结构。因此，请不要利用标题标签来改变同一行中的字体大小。相反，我们应当使用层叠样式表定义来达到漂亮的显示效果。

如果您希望了解更多有关 HTML 标签选择和使用的信息，请阅读《Web 品质》。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 4.01 中，h1 - h6 元素的 "align" 属性不被赞成使用。

在 HTML 5 中，h1 - h6 元素的 "align" 属性不被支持。

例子

<h1>这是标题 1</h1>
<h1>这是标题 2</h1>
<h2>这是标题 3</h2>
<h4>这是标题 4</h4>
<h5>这是标题 5</h5>
<h6>这是标题 6</h6>

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。

TIY 实例

标题
本例演示在 HTML 文档中显示标题的标签。


HTML 5 <head> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <head> 标签

定义和用法

head 元素可包含关于文档的信息。浏览器不会向用户显示这些头部信息（"head information"）。下面这些标签可用在 head 部分：<base>, <link>, <meta>, <script>, <style>, 以及 <title>。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 5 中不再支持 profile 属性。

提示和注释：

提示：请记住始终为文档规定标题！

例子

<html>

<head>
  <title>文档的标题</title>
</head>

<body>
...
...
...
</body>
</html>

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

TIY 实例

文档的标题
头元素内部的标题信息不会被显示在浏览器窗口中。
一个target，所有的链接
本例显示如何使用 base 标签使页面中的所有标签在新窗口中打开。
HTML 中的样式
本例演示如何使用添加到 <head> 部分的样式信息对 HTML 进行格式化。
链接到一个外部样式表
本例演示如何通过 <link> 标签链接到一个外部样式表。
文档描述
Meta 元素中的信息可以描述 HTML 文档。
文档关键字
Meta 元素中的信息可以描述文档的关键词。


HTML 5 <header> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <header> 标签

定义和用法

<header> 标签定义 section 或 document 的页眉。

HTML 4.01 与 HTML 5 之间的差异

<header> 标签是 HTML 5 中的新标签。

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。


HTML 5 <hr> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <hr> 标签

定义和用法

<hr> 标签水平线，它应该定义内容中的主题变化。

HTML 4.01 与 HTML 5 之间的差异

属性：在 HTML 4.01 中，不赞成使用 align, noshade, size 以及 width 属性。在 HTML 5 中不再支持这些属性。

在 HTML 5 中，<hr> 标签定义内容中的主题变化，并显示为一条水平线。

在 HTML 4.01 中，它仅仅显示为一条水平线。

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。

TIY 实例

水平线
如何插入水平线。


HTML 5 <html> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <html> 标签

定义和用法

<html> 元素告知浏览器这是一个 HTML 文档。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 4.01 中的 xmlns 属性，在 XHTML 中是必须的。实际上它没有任何效果，但是出于验证的原因，在把 HTML 转换为 XHTML 的过程中，是很有帮助的。在 HTML 5 中，没有理由这么做，但是你仍然可以把 xmlns 属性定义为 "http://www.w3.org/1999/xhtml"。

在 HTML 5 中，有一个新属性：manifest。

提示和注释

注释：如果您出于某种原因，希望定义 xmlns 属性，唯一合法的值是 "http://www.w3.org/1999/xhtml"。

属性

属性 | 值 | 描述 | 4 | 5
manifest | url | 为脱机使用定义缓存信息。 |  | 5
xmlns | http://www.w3.org/1999/xhtml | 定义 XML namespace 属性。 在 HTML 5 中，不要使用该属性。 | 4 | 5

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

TIY 实例

一个简单的 HTML 文件
这个例子是一个很简单的 HTML 文件，使用了尽量少的 HTML 标签。它向您演示了 body 元素中的内容是如何被浏览器显示的。


HTML 5 <i> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <i> 标签

定义和用法

<i> 标签呈现斜体的文本。

<i> 标签定义与文本中其余部分不同的部分，并把这部分文本呈现为斜体文本。在没有其他元素可以使用时，比如 <b>, <cite>, <dfn>, <em>, <q>, <small>, <strong>，请使用 <i> 标签。

HTML 4.01 与 HTML 5 之间的差异

没有区别。

但是在 HTML 4.01 中，存在着一种理解，即应该使用 CSS 来制作斜体文本。在 HTML 5 中，情况没有改变，但是你应该使用 <i> 标签把部分文本定义为某种类型，而不只是利用它在布局中所呈现的样式。

例子

<p>The <i class="taxonomy">Felis silvestris catus</i> is cute.</p>
<p>The term <i>prose content</i> is defined above.</p>
<p>There is a certain <i lang="fr">je ne sais quoi</i> in the air.</p>

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。


HTML 5 <iframe> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <iframe> 标签

定义和用法

<iframe> 标签创建包含另一个文档的行内框架。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 5 中，仅仅支持 src 属性

例子

<iframe src="/index.html"></iframe>

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

内联框架
本例演示如何创建内联框架（HTML 页中的框架）。


HTML 5 <img> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <img> 标签

定义和用法

<img> 标签定义图像。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 4.01 中，图像的 "align", "border", "hspace" 以及 "vspace" 不赞成使用。在 HTML 5 中，不再支持这些属性。

例子

<img src="smile.gif" alt="smile" />

属性

属性 | 值 | 描述 | 4 | 5
alt | text | 定义有关图形的短的描述。 | 4 | 5
src | URL | 要显示的图像的 URL。 | 4 | 5
align
  • top
  • bottom
  • middle
  • left
  • right
 规定如何根据周围的文本来对齐图像。不支持。请使用 CSS 代替。 4
border | pixels | 定义图像周围的边框。不支持。请使用 CSS 代替。 | 4
height | pixels % | 定义图像的高度。 | 4 | 5
hspace | pixels | 定义图像左侧和右侧的空白。不支持。请使用 CSS 代替。 | 4
ismap | URL | 把图像定义为服务器端的图像映射。 | 4 | 5
longdesc | URL | 一个 URL，指向了描述该图像的文档。不支持。 | 4
usemap | URL | 定义作为客户端图像映射的一幅图像。请参阅 <map> 和 <area> 标签，了解其工作原理。 | 4 | 5
vspace | pixels | 定义图像顶部和底部的空白。不支持。请使用 CSS 代替。 | 4 | 5
width | pixels % | 设置图像的宽度。 | 4 | 5

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

插入图像
本例演示如何在网页中显示图像。
从不同的位置插入图片
本例演示如何将其他文件夹或服务器的图片显示到网页中。
浮动图像
本例演示如何使图片浮动至段落的左边或右边。
调整图像尺寸
本例演示如何将图片调整到不同的尺寸。
制作图像链接
本例演示如何将图像作为一个链接使用。
创建图像地图
本例显示如何创建带有可供点击区域的图像地图。其中的每个区域都是一个超级链接。


HTML 5 <input> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <input> 标签

定义和用法

<input> 标签定义输入字段，用户可在其中输入数据。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 5 中，该元素有很多新属性，同时不再支持 HTML 4.01 中的一些属性。

在 HTML 5 中，type 属性有很多新的值。

例子

注释：input 元素是空的，仅包含属性。

提示：请使用 label 元素为表单控件定义标注。

属性

属性 | 值 | 描述 | 4 | 5
accept | list_of_mime_types | 一个逗号分隔的 MIME 类型列表，指示文件传输的 MIME 类型。注释：仅可与 type="file" 配合使用。 | 4 | 5
align
  • left
  • right
  • top
  • texttop
  • middle
  • absmiddle
  • baseline
  • bottom
  • absbottom

定义图像之后的文本对齐方式。

不支持，请使用 CSS 代替。

 4
alt text

定义图像的替代文本。

注释：仅可与 type="image" 配合使用。

 4 5
autocomplete | 5
autofocus
  • true
  • false

当页面加载时，使输入字段获得焦点。

注释：type="hidden" 时，无法使用。

 5
checked
  • true
  • false

指示此 input 元素首次加载时应当被选中。

注释：请与 type="checkbox" 及 type="radio" 配合使用。

 4 5
disabled
  • true
  • false

当 input 元素首次加载时禁用此元素，这样用户就无法在其中写文本，或选定它。

注释：不能与 type="hidden" 一同使用。

 4 5
form
  • true
  • false
 定义输入字段属于一个或多个表单。 5
inputmode | inputmode | 定义预期的输入类型。 | 5
list | id of a datalist | 引用 datalist 元素。如果定义，则一个下拉列表可用于向输入字段插入值。 | 5
max | number | 输入字段的最大值。 | 5
maxlength | number | 定义文本域中所允许的字符最大数目。 | 4 | 5
min | number | 输入字段的最小值。 | 5
name | field_name | 为 input 元素定义唯一的名称。 | 4 | 5
pattern | 5
readonly | readonly | 指示是否可修改该字段的值。 | 4 | 5
replace | text | 定义当表单提交时如何处理该输入字段。 | 5
required
  • true
  • false

定义输入字段的值是否是必需的。

当使用下列类型时无法使用：hidden, image, button, submit, reset

 5
size | number_of_char | 定义 input 元素的大小。不再支持。 | 4
src URL

定义要显示的图像的 URL。

仅用于 type="image" 时。

 4 5
step | 5
template | template | 定义一个或多个模板。 | 5
type
  • button
  • checkbox
  • date
  • datetime
  • datetime-local
  • email
  • file
  • hidden
  • image
  • month
  • number
  • password
  • radio
  • range
  • reset
  • submit
  • text
  • time
  • url
  • week

指示 input 元素的类型。

默认值是 "text"

注释：该属性不是必需的。但是我们认为应该使用它。

 4 5
value value

对于按钮、重置按钮和确认按钮：定义按钮上的文本。

对于图像按钮：定义传递向某个脚本的此域的符号结果。

对于复选框和单选按钮：定义 input 元素被点击时的结果。

对于隐藏域、密码域以及文本域：定义元素的默认值。

注释：不能与 type="file" 一同使用。

注释：与 type="checkbox" 和 type="radio" 一同使用时，此元素是必需的。

 4 5

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

文本域 (Text fields)
本例演示如何在HTML页面创建文本域。用户可以在文本域写入文本。
密码域
本例演示如何创建 HTML 的密码域。
复选框
本例演示如何在 HTML 页中创建文本框。用户可以选中或取消选取复选框。
单选按钮
本例演示如何在 HTML 中创建单选按钮。
创建按钮
本例演示如何创建按钮。你可以对按钮上的文字进行自定义。
带有输入框和确认按钮的表单
本例演示如何向页面添加表单。此表单包含两个输入框和一个确认按钮。
带有复选框的表单
此表单包含两个复选框和一个确认按钮。
带有单选按钮的表单
此表单包含两个单选框和一个确认按钮。


HTML 5 <ins> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <ins> 标签

定义和用法

<ins> 标签定义文档的其余部分之外的插入文本。

HTML 4.01 与 HTML 5 之间的差异

没有。

例子

提示：请与 <del> 标签一起使用，来描述对文档的更新和修正。

属性

属性 | 值 | 描述 | 4 | 5
cite | URL | 指向另一个文档的 URL，该文档解释文本插入的原因。 | 4 | 5
datetime | YYYYMMDD | 定义文本插入的日期和时间。 | 4 | 5

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

删除字效果和插入字效果
此例演示如何标示删除文本和插入文本。


HTML 5 <label> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <label> 标签

定义和用法

<label> 标签定义控件的标注。如果您在 label 元素内点击文本，就会触发此控件。就是说，当用户选择该标签时，浏览器就会自动将焦点转到和标签相关的表单控件上。

HTML 4.01 与 HTML 5 之间的差异

没有。

提示和注释

注释："for" 属性可把 label 绑定到另外一个元素。请把 "for" 属性的值设置为相关元素的 id 属性的值。

属性

属性 | 值 | 描述 | 4 | 5
for | id_of_another_field | 定义 label 针对哪个表单元素。设置为表单元素的 id。 注释：如果此属性未被规定，那么 label 会关联其内容。 | 4 | 5

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

label
如何为控件定义标记。


HTML 5 <legend> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <legend> 标签

定义和用法

<legend> 标签为 <fieldset>、<figure> 以及 <details> 元素定义标题。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 4.01 中， <legend> 仅用于 <fieldset> 元素。

在 HTML 5 中， <legend> 标签应用于 <fieldset>、<figure> 以及 <details> 元素。

在 HTML 5 中，不支持 align 属性。请使用 CSS 代替。

例子

<fieldset>
<legend>健康信息：</legend>
<form>
<label>身高：<input type="text" /></label>
<label>体重：<input type="text" /></label>
</form>
</fieldset>

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

围绕数据的 Fieldset
本例演示如何在数据周围绘制一个带标题的框。


HTML 5 <li> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <li> 标签

定义和用法

<li> 标签定义列表项，有序列表和无序列表中都使用 <li> 标签。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 4.01 中， 不赞成使用 "type" 和 "value" 属性。

在 HTML 5 中，不再支持 "type" 属性。

在 HTML 5 中， 并没有不赞成使用 "value" 属性，但是仅能够与 <ol> 元素一起使用。

提示和注释

提示：请使用 CSS 来定义列表的类型。

例子

<ol>
   <li>Coffee</li>
   <li>Tea</li>
</ol>

<ol>
   <li value="8">Coffee</li>
   <li>Tea</li>
</ol>

<ul>
   <li>Coffee</li>
   <li>Tea</li>
</ul>

属性

属性 | 值 | 描述 | DTD
type
  • A
  • a
  • I
  • i
  • 1
  • disc
  • square
  • circle
 规定列表的类型。不赞成使用。请使用样式替代。 TF
value | number_of_list_item | 不赞成使用。请使用样式替代。 | TF

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

无序列表
本例演示一个无序列表。
有序列表
本例演示一个有序列表。
嵌套列表
本例演示如何嵌套列表。
嵌套列表 2
本例演示更复杂的嵌套列表。


HTML 5 <link> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <li> 标签

定义和用法

<link> 标签定义两个连接文档之间的关系。

HTML 4.01 与 HTML 5 之间的差异

不再支持 HTML 4.01 中的一些属性。

提示和注释：

注释：link 元素是空元素，它仅包含属性。

注释：此元素只能存在于 head 部分，不过它可出现任意次数。

例子

如何使用 <link> 来链接外部样式表：

<head>
<link rel="stylesheet" type="text/css" href="c1.css"   />
</head>

属性

属性 | 描述 | 4 | 5
charset | 定义目标 URL 的字符编码方式。默认值是 "ISO-8859-1"。不支持。 | 4 |
href | 目标文档或资源的 URL。 | 4 | 5
hreflang | 定义目标 URL 的基准语言。 | 4 | 5
media | 规定文档将显示在什么设备上。 | 4 | 5
rel | 定义当前文档与目标文档之间的关系。 | 4 | 5
rev | 定义目标文档与当前文档之间的关系。 | 4 |
target | 在何处打开目标 URL。 | 4 |
type | 规定目标 URL 的 MIME 类型。 | 4 | 5

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

链接到一个外部样式表
本例演示如何 <link> 标签链接到一个外部样式表。


HTML 5 <m> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <m> 标签

定义和用法

<m> 标签定义带有记号的文本。请在需要突出显示文本时使用 <m> 标签。

HTML 4.01 与 HTML 5 之间的差异

<m> 标签是 HTML 5 中的新标签。

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。


HTML 5 <map> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <map> 标签

定义和用法

<map> 标签定义客户端的图像映射。图像映射是带有可点击区域的图像。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 5 中，不再支持 name 属性。

提示和注释：

注释：area 元素永远嵌套在 map 元素内部。area 元素可定义图像映射中的区域。

属性

属性 | 值 | 描述 | 4 | 5
id | unique_name | 为 map 标签定义唯一的名称。 | 4 | 5
name | unique_name | 为 map 标签定义唯一的名称。不支持。 | 4 |

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

创建图像地图
本例显示如何创建带有可点击区域的图像地图。其中的每个区域都是一个超级链接。


HTML 5 <menu> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <menu> 标签

定义和用法

<menu> 标签定义菜单列表。当希望列出表单控件时使用该标签。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 4.01 中，不赞成使用 menu 元素。

在 HTML 5 中，重新定义了 menu 元素，且使用用于排列表单控件。

提示和注释

提示：请使用 CSS 来定义列表的类型。

例子

<menu>
<li><input type="checkbox" />Red</li>
<li><input type="checkbox" />blue</li>
</menu>

属性

属性 | 值 | 描述 | 4 | 5
autosubmit | true false | 如果为 true，那么当表单控件改变时会自动提交。 | 5
compact | compact_rendering | 不支持。请使用 CSS 代替。 | 4
label | menulabel | 为菜单定义一个可见的标注。 | 5
type
  • context
  • toolbar
  • list
 定义显示那种类型的菜单。默认值是 "list"。 5

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。


HTML 5 <meta> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <meta> 标签

定义和用法

<meta> 元素可提供有关页面的元信息（meta-information），比如针对搜索引擎和更新频度的描述和关键词。

<meta> 标签位于文档的头部，不包含任何内容。<meta> 标签的属性定义了与文档相关联的名称/值对。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 5 中，不再支持 scheme 属性。

在 HTML 5 中，有一个新的 charset 属性，它使字符集的定义更加容易。

在 HTML 4.01 中，不得不这么写：

<meta http-equiv="content-type" content="text/html; charset=ISO-8859-1">

在 HTML 5 中，这样就够了：

<meta charset="ISO-8859-1">

提示和注释

提示：请使用 CSS 来定义列表的类型。

例子

定义针对搜索引擎的关键词：

<meta name="keywords" content="HTML, CSS, XML, XHTML, JavaScript" />

定义对页面的描述：

<meta name="description" content="免费的 web 技术教程。" />

定义页面的最新版本：

<meta name="revised" content="David, 2008/8/8/" />

每 5 秒刷新一次页面：

<meta http-equiv="refresh" content="5" />

属性

属性 | 值 | 描述 | 4 | 5
charset | character encoding | 定义文档的字符编码。 | 5
content | some_text | 定义与 http-equiv 或 name 属性相关的元信息。 | 4 | 5
http-equiv
  • content-type
  • expires
  • refresh
  • set-cookie
 把 content 属性关联到 HTTP 头部。 4 5
name
  • author
  • description
  • keywords
  • generator
  • revised
  • others
 把 content 属性关联到一个名称。 4 5
scheme | some_text | 定义用于翻译 content 属性值的格式。不支持。 | 4

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

文档描述
Meta 元素中的信息可以描述 HTML 文档。
文档关键字
Meta 元素中的信息可以描述文档的关键词。
重定向
这个例子演示：在网址已经变更的情况下，将用户重定向到另外一个地址。


HTML 5 <meter> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <meter> 标签

定义和用法

<meter> 标签定义度量（单位）。仅用于已知最大和最小值的度量。

HTML 4.01 与 HTML 5 之间的差异

<meter> 标签是 HTML 5 中的新标签。

提示和注释

注释：必须定义度量的范围，既可以在 text 中，也可以在 min/max 属性中定义。

例子

<meter min="0" max="20">5</meter>

<meter>2 out of 10</meter>

<meter>30%</meter>

属性

属性 | 值 | 描述
high | number | 定义度量的值位于哪个点，被界定为高的值。
low | number | 定义度量的值位于哪个点，被界定为低的值。
max | number | 定义最大值。默认值是 1。
min | number | 定义最小值。默认值是 0。
optimum | number | 定义什么样的度量值是最佳的值。如果该值高于 "high" 属性，则意味着值越高越好。如果该值低于 "low" 属性的值，则意味着值越低越好。
value | number | 定义度量的值。

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。


HTML 5 <nav> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <nav> 标签

定义和用法

<nav> 标签定义导航链接的部分。

HTML 4.01 与 HTML 5 之间的差异

<nav> 标签是 HTML 5 中的新标签。

提示和注释

提示：如果文档中有“前后”按钮，则应该把它放到 <nav> 元素中。

例子

<nav>
  <a href="index.asp">w3school 在线教程</a>
  <a href="html5_meter.asp">上一页</a>
  <a href="html5_nest.asp">下一页</a>
</nav>

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。


HTML 5 <nest> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <nest> 标签

定义和用法

<nest> 标签在数据模板中为子元素定义嵌套点。与 <datatemplate> 和 <rule> 元素一同使用。

HTML 4.01 与 HTML 5 之间的差异

<nest> 标签是 HTML 5 中的新标签。

提示和注释

提示：插入的子节点必须匹配 <nest> 元素的 <rule> 元素。

属性

属性 | 值 | 描述
filter | selector | 定义能够进一步处理哪个子节点。
mode | mode | 定义数据模板的规则将拥有哪种模式。

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。


HTML 5 <noframes> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <noframes> 标签

定义和用法

<noframes> 标签向浏览器显示无法处理框架的提示文本。noframes 元素位于 frameset 元素中。

由于该标签对网页可用性的负面影响，在 HTML 5 中 <noframes> 标签没有得到支持。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 5 中不支持 <noframes> 标签。


HTML 5 <noscript> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <noscript> 标签

定义和用法

noscript 元素用来定义在脚本未被执行时的替代内容（文本）。

此标签用于可识别 <script> 标签但无法支持其中脚本的浏览器。

HTML 4.01 与 HTML 5 之间的差异

没有。

提示和注释

注释：如果浏览器支持脚本，那么它不会显示出 noscript 元素中的文本。

注释：无法识别 <script> 标签的浏览器会把标签的内容显示到页面上。为了避免浏览器这样做，您应当在注释标签中隐藏脚本。老式的（无法识别 <script> 标签的）浏览器会忽略注释，这样就不会把标签的内容写到页面上，而新式的浏览器则懂得执行这些脚本，即使它们被包围在注释标签中！

例子

JavaScript

<body>
  ...
  ...

  <script type="text/javascript">
    <!--
    document.write("Hello World!")
    //-->
  </script>

  <noscript>Your browser does not support JavaScript!</noscript>
  ...
  ...
</body>

VBScript

<body>
  ...
  ...
  <script type="text/vbscript">
   <!--
   document.write("Hello World!")
   '-->
  </script>

  <noscript>Your browser does not support VBScript!</noscript>
  ...
  ...
</body>

TIY 实例

运行于不支持脚本的浏览器
本例演示如何对付不支持脚本的浏览器。


HTML 5 <object> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <object> 标签

定义和用法

定义一个嵌入的对象。请使用此元素向您的 XHTML 页面添加多媒体。此元素运行您规定插入 HTML 文档中的对象的数据和参数，以及可用来显示和操作数据的代码。

HTML 4.01 与 HTML 5 之间的差异

不再支持 HTML 4.01 中的一些属性。

提示和注释

注释：object 元素可位于在 head 元素或 body 元素内部。<object> 与 </object> 之间的文本是替换文本，针对不支持此标签的浏览器。<param> 标签可定义用于对象的 run-time 设置。

提示：至于图像，请使用 <img> 标签代替 <object> 标签。

提示：至少必须定义 "data" 和 "type" 属性之一。

属性

属性 | 值 | 描述 | 4 | 5
align
  • left
  • right
  • top
  • bottom
 定义围绕该对象的文本对齐方式。不支持。使用 CSS 代替。 4
archive | URL | 一个空格分隔的指向档案文件的 URL 列表。这些档案文件包含了与对象相关的资源。不支持。 | 4
border | pixels | 定义对象周围的边框。不支持。使用 CSS 代替。 | 4
classid | class ID | 用于指定浏览器中包含的对象的位置。不支持。 | 4
codebase | URL | 定义在何处可找到对象所需的代码。不支持。 | 4
codetype | MIME type | 通过 classid 属性所引用的代码的 MIME 类型。不支持。 | 4
data | URL | 定义引用对象数据的 URL。 | 4 | 5
declare
  • true
  • false
 可定义此对象仅可被声明，但不能被创建或例示，直到此对象得到应用为止。不支持。 4
height | pixels | 定义对象的高度。 | 4 | 5
hspace | pixels | 定义对象周围水平方向的空白。不支持。使用 CSS 代替。 | 4
name | unique_name | 为对象定义唯一的名称（以便在脚本中使用）。不支持。使用 id 代替。 | 4
standby | text | 定义当对象正在加载时所显示的文本。不支持。 | 4
type | MIME_type | 定义被规定在 data 属性中指定的文件中出现的数据的 MIME 类型。 | 4 | 5
usemap | URL | 规定与对象一同使用的客户端图像映射的 URL。 | 4 | 5
vspace | pixels | 定义对象的垂直方向的空白。不支持。使用 CSS 代替。 | 4
width | pixels | 定义对象的宽度。 | 4 | 5

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。


HTML 5 <ol> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <ol> 标签

定义和用法

<ol> 标签定义有序列表。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 4.01 中，不赞成使用 "start" 属性，在 HTML 5 中是允许的。

在 HTML 4.01 中，不赞成使用 "compact" 和 "type" 属性，在 HTML 5 中，不再支持这两个属性。

提示和注释

提示：请使用 CSS 来定义列表的类型。

例子

<ol>
   <li>Coffee</li>
   <li>Tea</li>
</ol>

<ol>
   <li start="60">Coffee</li>
   <li>Tea</li>
</ol>

属性

属性 | 值 | 描述 | 4 | 5
compact | compact_rendering | 不赞成。使用 CSS 代替。 | 4
start | start_on_number | 规定起始数字。 | 4 | 5
type
  • A
  • a
  • I
  • i
  • 1
 规定列表的类型。不赞成。使用 CSS 代替。 4

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

有序列表
本例演示一个有序列表。


HTML 5 <optgroup> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <optgroup> 标签

定义和用法

<optgroup> 标签定义选项组。此元素允许您组合选项。当您使用一个长的选项列表时，对相关的选项进行组合会使处理更加容易。

HTML 4.01 与 HTML 5 之间的差异

没有。

例子

<select>
      <optgroup label="Swedish Cars">
      <option value ="volvo">Volvo</option>
      <option value ="saab">Saab</option>
      </optgroup>

      <optgroup label="German Cars">
      <option value ="mercedes">Mercedes</option>
      <option value ="audi">Audi</option>
      </optgroup>
</select>

属性

属性 | 值 | 描述 | 4 | 5
label | text_label | 定义选项组的标注。 | 4 | 5
disabled | disabled | 在其首次加载时，禁用该选项组。 | 4 | 5

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。


HTML 5 <option> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <option> 标签

定义和用法

<option> 标签定义下拉列表中的一个选项。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 5 中，<option> 标签也用于新元素 <datalist> 中。

提示和注释

注释：<option> 标签能够在不带任何属性的情况下使用，但是通常需要 value 属性，该属性定义了发送到服务器的数据。

注释：请与 <select> 或 <datalist> 标签结合使用。在其他地方，<option> 标签是无意义的。

例子

<select>
  <option value="volvo">Volvo</option>
  <option value="saab">Saab</option>
  <option value="opel" selected="selected">Opel</option>
  <option value="audi">Audi</option>
</select>

属性

属性 | 值 | 描述 | 4 | 5
disabled | disabled | 规定此选项应在首次加载时被禁用。 | 4 | 5
label | text | 定义当使用 <optgroup> 时所使用的标注。 | 4 | 5
selected | selected | 规定选项（在首次显示在列表中时）表现为选中状态。 | 4 | 5
value | text | 定义送往服务器的选项值。 | 4 | 5

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

简单的下拉列表
本例演示如何在 HTML 页面中创建简单的下拉列表框。下拉列表框是一个可选列表。
另一个下拉列表
本例演示如何创建一个简单的带有预选值的下拉列表。（注：预选值指预先指定的首选项。）


HTML 5 <output> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <output> 标签

定义和用法

<output> 标签定义不同类型的输出，比如脚本的输出。

HTML 4.01 与 HTML 5 之间的差异

<output> 标签是 HTML 5 中的新标签。

属性

属性 值 描述
form
  • true
  • false
 定义输入字段所属的一个或多个表单。

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。


HTML 5 <p> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <p> 标签

定义和用法

<p> 标签定义段落。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 4.01 中，不赞成使用 align 属性，在 HTML 5 中不再支持该属性。

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

简单的段落
此例演示：段落元素中的文字如何被浏览器显示。
更多的段落
本例演示段落元素的某些缺省的行为。
“诗歌”问题
本例演示 HTML 格式化的某些问题。


HTML 5 <param> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <param> 标签

定义和用法

param 元素允许您为插入 XHTML 文档的对象规定 run-time 设置，也就是说，此标签可为包含它的 <object> 标签提供参数。

HTML 4.01 与 HTML 5 之间的差异

不再支持 HTML 4.01 中的一些属性。

例子

<object id="Slider1" width="100" height="50">
  <param name="BorderStyle" value="1" />
  <param name="MousePointer" value="0" />
  <param name="Enabled" value="1" />
  <param name="Min" value="0" />
  <param name="Max" value="10" />
</object>

属性

属性 | 值 | 描述 | 4 | 5
name | unique_name | 定义参数的唯一的名称（唯一标识符）。 | 4 | 5
type | MIME type | 规定参数的 MIME 类型（internet media type）。不支持。 | 4
value | value | 规定参数的值。 | 4 | 5
valuetype
  • data
  • ref
  • object
 规定值的 MIME 类型。不支持。 4

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。


HTML 5 <pre> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <pre> 标签

定义和用法

pre 元素可定义预格式化的文本。被包围在 pre 元素中的文本通常会保留空格和换行符。而文本也会呈现为等宽字体。

<pre> 标签的一个常见应用就是用来表示计算机的源代码。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 4.01 中，不赞成使用 width 属性，在 HTML 5 中不再支持该属性。

提示和注释

提示：请使用 <pre> 标签来显示非常规的格式化内容，或者某类计算机代码。

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

预格式文本
此例演示如何使用 pre 标签对折行和空格进行控制。


HTML 5 <progress> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <progress> 标签

定义和用法

<progress> 标签运行中的进程。可以使用 <progress> 标签来显示 JavaScript 中耗费时间的函数的进程。

HTML 4.01 与 HTML 5 之间的差异

<progress> 标签是 HTML 5 中的新标签。

提示和注释

提示：请使用 <progress> 标签来显示下载的进程。

例子

对象的下载进程：
<progress><span id="objprogress">85</span>%</progress>

属性

属性 | 值 | 描述
max | number | 定义完成的值。
value | number | 定义进程的当前值。

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。


HTML 5 <q> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <q> 标签

定义和用法

<q> 标签定义一个短的引用。

HTML 4.01 与 HTML 5 之间的差异

没有。

提示和注释

提示：请使用 cite 属性来定义该引用的来源。

例子

这是一个短的引用：
<q>这是一个短的引用：</q>

属性

属性 | 值 | 描述 | 4 | 5
cite | url | 定义引用的引文。 | 4 | 5

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

引用
此例演示如何实现长短不一的引用语。


HTML 5 <rule> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <rule> 标签

定义和用法

<rule> 标签定义更新数据模板的规则。与 <datatemplate> 和 <nest> 元素一起使用。

HTML 4.01 与 HTML 5 之间的差异

<rule> 标签是 HTML 5 中的新标签。

属性

属性 | 值 | 描述
condition | selector | 定义将更新哪个元素。
mode | mode | 定义数据模板拥有的模式。

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。


HTML 5 <s> 和 <strike> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <s> 和 <strike> 标签

定义和用法

<s> 和 <strike> 标签定义加删除线的文本。HTML 5 中不再支持这两个标签。请使用 CSS 代替。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 4.01 中不赞成使用 <s> 和 <strike> 标签。

在 HTML 5 中不支持 <s> 和 <strike> 标签。

提示和注释

提示：请使用 <del> 标签代替。


HTML 5 <script> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <script> 标签

定义和用法

<script> 标签定义一段脚本，比如 JavaScript。

如果 async 属性为 true，则脚本会相对于文档的其余部分异步执行，这样脚本会可以在页面继续解析的过程中来执行。

如果 async 属性为 false，而 defer 属性为 true，则脚本会在页面完成解析时得到执行。

如果 async 和 defer 属性均为 false，那么脚本会立即执行，页面会在脚本执行完毕继续解析。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 5 中，有一些新属性，同时不再支持 HTML 4.01 中的一些属性。

提示和注释

提示：如果存在 src 属性，则 <script> 标签必须是空的。

例子

<script type="text/javascript">
document.write("Hello World!")
</script>

属性

属性 | 值 | 描述 | 4 | 5
async
  • true
  • false
 定义脚本是否异步执行。 5
type
  • text/ecmascript
  • text/javascript
  • application/ecmascript
  • application/javascript
  • text/vbscript
 指示脚本的 MIME 类型。 4 5
charset | charset | 定义脚本中使用的字符编码。不支持。 | 4
defer
  • true
  • false
 指示脚本不会生成任何的文档内容。浏览器可以继续解析并绘制页面。 4 5
language
  • javascript
  • livescript
  • vbscript
  • other
 规定脚本语言。不赞成使用。请使用 type 属性代替它。 4
src | URL | 定义指向包含脚本的文件的 URL（这样您就可以引用某个包含脚本的文件，而不是直接把脚本插入您的 HTML 文档中）。 | 4 | 5

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

插入一段脚本
本例演示如何将脚本插入 HTML 文档。
运行于不支持脚本的浏览器
本例演示如何对付不支持脚本的浏览器。


HTML 5 <section> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <section> 标签

定义和用法

<section> 标签定义文档中的节（section）。比如章节、页眉、页脚或文档中的其他部分。

HTML 4.01 与 HTML 5 之间的差异

<section> 标签是 HTML 5 中的新标签。

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。


HTML 5 <select> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <select> 标签

定义和用法

<select> 标签创建下拉列表。

HTML 4.01 与 HTML 5 之间的差异

HTML 5 有一些新的属性，同时不再支持一些 HTML 4.01 的属性。

提示和注释：

提示：请在 form 元素中使用此标签来接受用户的输入。

例子

<select>
  <option value="volvo">Volvo</option>
  <option value="saab">Saab</option>
  <option value="opel">Opel</option>
  <option value="audi">Audi</option>
</select>

属性

属性 | 值 | 描述 | 4 | 5
autofocus
  • true
  • false
 在页面加载时使这个 select 字段获得焦点。 5
data | url | 供自动插入数据。 | 5
disabled
  • true
  • false
 当该属性为 true 时，会禁用该菜单。 4 5
form
  • true
  • false
 定义 select 字段所属的一个或多个表单。 5
multiple
  • true
  • false
 当该属性为 true 时，规定可一次选定多个项目。 4 5
name | unique_name | 定义下拉列表的唯一标识符。 | 4 | 5
size | number | 定义菜单中可见项目的数目。不支持。 | 4

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

简单的下拉列表
本例演示如何在 HTML 页面中创建简单的下拉列表框。下拉列表框是一个可选列表。
另一个下拉列表
本例演示如何创建一个简单的带有预选值的下拉列表。（注：预选值指预先指定的首选项。）


HTML 5 <select> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <select> 标签

定义和用法

<span> 标签用于对文档中的行内元素进行组合。

HTML 4.01 与 HTML 5 之间的差异

没有。

提示和注释：

提示：请使用 span 元素对行内元素进行分组，以便通过样式对它们进行格式化。

例子

<p>This is a paragraph <span style="color:#00ff00;">This is a paragraph</span>
This is a paragraph</p>

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。


HTML 5 <small> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <small> 标签

定义和用法

<small> 标签制作更小字号的文本。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 5 中不支持 <small> 标签。


HTML 5 <source> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <source> 标签

定义和用法

<source> 标签为媒介元素（比如 <video> 和 <audio>）定义媒介资源。

HTML 4.01 与 HTML 5 之间的差异

<source> 标签是 HTML 5 中的新标签。

属性

属性 | 值 | 描述
media | media query | 定义媒介资源的类型，供浏览器决定是否下载。
src | url | 媒介的 URL。
type | numeric value | 定义播放器在音频流中的什么位置开始播放。默认地，音频从开头播放。

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。


HTML 5 <style> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <style> 标签

定义和用法

<style> 标签定义文档中的样式。

如果需要在文档中引用样式表，应该定义外部的样式表，然后使用 <link> 来连接这个样式表。

HTML 4.01 与 HTML 5 之间的差异

scoped 属性是 HTML 5 中的新属性，它允许我们为文档的指定部分定义样式，而不是整个文档。

提示和注释：

提示：如需学习更多有关样式表的内容，请访问我们的 CSS 教程。

提示：在 HTML 5 中，所有元素都不支持 style 属性，如需为一个元素添加样式，请在 style 元素中使用 scoped 属性。

注释：如果没有定义 scoped 属性，则 <style> 元素必须是 head 元素的子元素，或者是（属于 head 元素的子元素的） noscript 元素的子元素。

例子

<head>
    <style type="text/css">
    h1 {color: blue}
    h2 {color: red}
    </style>
</head>

属性

属性 | 值 | 描述 | 4 | 5
type | text/css | 定义内容类型。 | 4 | 5
media
  • screen
  • tty
  • tv
  • projection
  • handheld
  • print
  • braille
  • aural
  • all
 样式信息的目标媒介。 4 5
scoped
  • true
  • false
 如果设置为 true，则样式仅仅应用到 style 元素的父元素及其子元素。 4 5

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

HTML中的样式
本例演示如何使用添加到 <head> 部分的样式信息对 HTML 进行格式化。
没有下划线的链接
本例演示如何使用样式属性做一个没有下划线的链接。
链接到一个外部样式表
本例演示如何<link>标签链接到一个外部样式表。


HTML 5 <sub> 和 <sup> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <sub> 和 <sup> 标签

定义和用法

<sub> 标签可定义下标文本。<sup> 可定义上标文本。

HTML 4.01 与 HTML 5 之间的差异

没有。

例子

这段文本包含 <sub>下标</sub>

这段文本包含 <sup>上标</sup>

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

上标和下标
本例演示如何使用 sup 和 sub 元素。


HTML 5 <table> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <table> 标签

定义和用法

<table> 标签可定义表格。在 <table> 标签内部，你可以放置表格的标题、表格行、表格列、表格单元以及其他的表格。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 4.01 中，不赞成使用 "align" 和 "bgcolor" 属性。

在 HTML 5 中，不支持 <table> 标签的任何属性。

例子

<table>
<tr>
<td>Cell A</td>
<td>Cell B</td>
</tr>
</table>

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

表格
这个例子演示如何在 HTML 文档中创建表格。
表格中的标题(Headings)
本例演示如何显示表格标题。
空单元格
本例展示如何使用 "&nbsp;" 处理没有内容的单元格。
带有标题的表格
本例演示一个带标题 (caption) 的表格
跨行或跨列的表格单元格
本例演示如何定义跨行或跨列的表格单元格。
表格内的标签
本例演示如何在不同的元素内显示元素。


HTML 5 <tbody> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <tbody> 标签

定义和用法

定义一段表格主体（正文）。

使用 <tbody> 标签，可以将表格分为一个单独的部分。<tbody> 标签可将表格中的一行或几行合成一组。

虽然您可能想包括一个，甚至会在表格中包括两个或更多个 <tbody> 标签，但是我们建议最好在表格中没有 <tbody> 标签。

在 <tbody> 标签中，只有 <tr> 标签可以定义表格行。并且一旦定义，一个 <tbody> 标签就是表格中的一个独立的部分。例如不能从一个 <tbody> 跨越到另一个 <tbody> 中。

thead、tfoot 以及 tbody 元素使您有能力对表格中的行进行分组。当您创建某个表格时，您也许希望拥有一个标题行，一些带有数据的行，以及位于底部的一个总计行。这种划分使浏览器有能力支持独立于表格标题和页脚的表格正文滚动。当长的表格被打印时，表格的表头和页脚可被打印在包含表格数据的每张页面上。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 5 中，不支持 <tbody> 标签的任何属性。

提示和注释：

注释：<thead> 内部必须拥有 <tr> 标签！

注释：如果您使用 thead、tfoot 以及 tbody 元素，您就必须使用全部的元素。它们的出现次序是：thead、tfoot、tbody，这样浏览器就可以在收到所有数据前呈现页脚了。您必须在 table 元素内部使用这些标签。

例子

<table>

  <thead>
    <tr>
      <td>THEAD 中的文本</td>
    </tr>
  </thead>

  <tfoot>
    <tr>
      <td>TFOOT 中的文本</td>
    </tr>
  </tfoot>

  <tbody>
    <tr>
      <td>TBODY 中的文本</td>
    </tr>
  </tbody>

</table>

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。


HTML 5 <td> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <td> 标签

定义和用法

<td> 标签定义表格中的一个单元格。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 4.01 中，td 元素的 "bgcolor"、"height"、"width" 以及 "nowrap" 是不被赞成使用的。

在 HTML 5 中，仅仅支持 "colspan" 和 "rowspan" 属性。

例子

<table>
  <tr>
    <td>Cell A</td>
    <td>Cell B</td>
  </tr>
</table>

属性

属性 | 值 | 描述 | 4 | 5
abbr | abbr_text | 规定单元格中内容的缩写版本。不支持。 | 4
align
  • left
  • right
  • center
  • justify
  • char
 规定单元格内容的水平排列方式。不支持。请使用 CSS 代替。 4
axis | category_names | 为单元格定义一个名字。不支持。 | 4
bgcolor
  • rgb(x,x,x)
  • #xxxxxx
  • colorname
 规定单元格的背景颜色。不支持。请使用 CSS 代替。 4
char | character | 规定根据哪个字符来进行文本对齐。不支持。请使用 CSS 代替。 | 4
charoff
  • pixels
  • %
 规定第一个对齐字符的偏移量。不支持。请使用 CSS 代替。 4
colspan | number | 规定此单元格可横跨的列数。 | 4 | 5
headers | header_cells'_id | 空格分隔的单元格 ID 列表。不支持。 | 4
height | pixels | 规定表格单元格的高度。不支持。请使用 CSS 代替。 | 4
nowrap | nowrap | 是否禁用或启用单元格中的文本环绕。不支持。请使用 CSS 代替。 | 4
rowspan | number | 规定此单元格可横跨的行数。 | 4 | 5
scope
  • col
  • colgroup
  • row
  • rowgroup
 规定此单元格是否为以下部分提供表头信息：包含此单元格的行 row) 的其余部分，包含此单元格的列 (col) 的其余部分，包含此单元格的行组 (rowgroup) 的其余部分，包含此单元格的列组 (colgroup) 的其余部分。不支持。 4
valign
  • top
  • middle
  • bottom
  • baseline
 规定单元格内容的垂直排列方式。不支持。请使用 CSS 代替。 4
width
  • pixels
  • %
 规定表格单元格的宽度。不支持。请使用 CSS 代替。 4

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

表格
这个例子演示如何在 HTML 文档中创建表格。
表格中的标题(Headings)
本例演示如何显示表格标题。
空单元格
本例展示如何使用 "&nbsp;" 处理没有内容的单元格。
带有标题的表格
本例演示一个带标题 (caption) 的表格
跨行或跨列的表格单元格
本例演示如何定义跨行或跨列的表格单元格。
表格内的标签
本例演示如何在不同的元素内显示元素。


HTML 5 <textarea> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <textarea> 标签

定义和用法

定义一个文本区域 (text-area) （一个多行的文本输入区域）。用户可在此文本区域中写文本。在一个文本区中，您可输入无限数量的文本。文本区中的默认字体是等宽字体 (fixed pitch)。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 5 中有一些新属性，同时不再支持 HTML 4.01 中的一些属性。

例子

<textarea rows="3" cols="30">
这里是文本域中的文本 ... ... ... ...
</textarea>

属性

属性 | 值 | 描述 | 4 | 5
autofocus
  • true
  • false
 在页面加载时，使这个 textarea 获得焦点。 5
cols | number | 规定文本区内可见的列数。 | 4 | 5
disabled
  • true
  • false
 当此文本区首次加载时禁用此文本区。 4 5
form
  • true
  • false
 定义该 textarea 所属的一个或多个表单。 5
inputmode | inputmode | 定义该 textarea 所期望的输入类型。 | 5
name | name_of_textarea | 为此文本区规定的一个名称。 | 4 | 5
readonly
  • true
  • false
 指示用户无法修改文本区内的内容。 4 5
required
  • true
  • false
 定义为了提交该表单，该 textarea 的值是否是必需的。 5
rows | number | 规定文本区内可见的行数。 | 4 | 5

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

Textarea
如何创建 textarea。


HTML 5 <tfoot> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <tfoot> 标签

定义和用法

定义表格的页脚（脚注）。

thead、tfoot 以及 tbody 元素使您有能力对表格中的行进行分组。当您创建某个表格时，您也许希望拥有一个标题行，一些带有数据的行，以及位于底部的一个总计行。这种划分使浏览器有能力支持独立于表格标题和页脚的表格正文滚动。当长的表格被打印时，表格的表头和页脚可被打印在包含表格数据的每张页面上。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 5 中，不支持 <tfoot> 标签的任何属性。

提示和注释：

注释：<tfoot> 内部必须拥有 <tr> 标签！

注释：如果您使用 thead、tfoot 以及 tbody 元素，您就必须使用全部的元素。它们的出现次序是：thead、tfoot、tbody，这样浏览器就可以在收到所有数据前呈现页脚了。您必须在 table 元素内部使用这些标签。

例子

<table>

  <thead>
    <tr>
      <td>THEAD 中的文本</td>
    </tr>
  </thead>

  <tfoot>
    <tr>
      <td>TFOOT 中的文本</td>
    </tr>
  </tfoot>

  <tbody>
    <tr>
      <td>TBODY 中的文本</td>
    </tr>
  </tbody>

</table>

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。


HTML 5 <th> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <th> 标签

定义和用法

<th> 标签定义表格内的表头单元格。此 th 元素内部的文本通常会呈现为粗体。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 4.01 中，th 元素的 "bgcolor"、"height"、"width" 以及 "nowrap" 属性是不被赞成使用的。

在 HTML 5 中，仅仅支持 "colspan" 、 "rowspan" 以及 "scope" 属性。

例子

<table>
  <tr>
    <th>Header 1</th>
    <th>Header 2</th>
  </tr>

  <tr>
    <td>Cell A</td>
    <td>Cell B</td>
  </tr>
</table>

属性

属性 | 值 | 描述 | 4 | 5
abbr | abbr_text | 规定单元格中内容的缩写版本。不支持。 | 4
align
  • left
  • right
  • center
  • justify
  • char
 规定单元格内容的水平排列方式。不支持。请使用 CSS 代替。 4
axis | category_names | 为单元格定义一个名字。不支持。 | 4
bgcolor
  • rgb(x,x,x)
  • #xxxxxx
  • colorname
 规定单元格的背景颜色。不支持。请使用 CSS 代替。 4
char | character | 规定根据哪个字符来进行文本对齐。不支持。请使用 CSS 代替。 | 4
charoff
  • pixels
  • %
 规定第一个对齐字符的偏移量。不支持。请使用 CSS 代替。 4
colspan | number | 规定此单元格可横跨的列数。 | 4 | 5
headers | header_cells'_id | 空格分隔的单元格 ID 列表。不支持。 | 4
height | pixels | 规定表格单元格的高度。不支持。请使用 CSS 代替。 | 4
nowrap | nowrap | 是否禁用或启用单元格中的文本环绕。不支持。请使用 CSS 代替。 | 4
rowspan | number | 规定此单元格可横跨的行数。 | 4 | 5
scope
  • col
  • colgroup
  • row
  • rowgroup
 规定此单元格是否为以下部分提供表头信息：包含此单元格的行 row) 的其余部分，包含此单元格的列 (col) 的其余部分，包含此单元格的行组 (rowgroup) 的其余部分，包含此单元格的列组 (colgroup) 的其余部分。不支持。 4 5
valign
  • top
  • middle
  • bottom
  • baseline
 规定单元格内容的垂直排列方式。不支持。请使用 CSS 代替。 4
width
  • pixels
  • %
 规定表格单元格的宽度。不支持。请使用 CSS 代替。 4

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

表格
这个例子演示如何在 HTML 文档中创建表格。
表格中的标题(Headings)
本例演示如何显示表格标题。
空单元格
本例展示如何使用 "&nbsp;" 处理没有内容的单元格。
带有标题的表格
本例演示一个带标题 (caption) 的表格
跨行或跨列的表格单元格
本例演示如何定义跨行或跨列的表格单元格。
表格内的标签
本例演示如何在不同的元素内显示元素。


HTML 5 <thead> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <thead> 标签

定义和用法

定义表格的表头。

thead、tfoot 以及 tbody 元素使您有能力对表格中的行进行分组。当您创建某个表格时，您也许希望拥有一个标题行，一些带有数据的行，以及位于底部的一个总计行。这种划分使浏览器有能力支持独立于表格标题和页脚的表格正文滚动。当长的表格被打印时，表格的表头和页脚可被打印在包含表格数据的每张页面上。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 5 中，不支持 <thead> 标签的任何属性。

提示和注释：

注释：<thead> 内部必须拥有 <tr> 标签！

注释：如果您使用 thead、tfoot 以及 tbody 元素，您就必须使用全部的元素。它们的出现次序是：thead、tfoot、tbody，这样浏览器就可以在收到所有数据前呈现页脚了。您必须在 table 元素内部使用这些标签。

例子

<table>

  <thead>
    <tr>
      <td>THEAD 中的文本</td>
    </tr>
  </thead>

  <tfoot>
    <tr>
      <td>TFOOT 中的文本</td>
    </tr>
  </tfoot>

  <tbody>
    <tr>
      <td>TBODY 中的文本</td>
    </tr>
  </tbody>

</table>

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。


HTML 5 <time> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <time> 标签

定义和用法

<time> 标签定义日期或时间，或者两者。

HTML 4.01 与 HTML 5 之间的差异

<time> 标签是 HTML 5 中的新标签。

例子

我们在每天早上 <time>9:00</time> 开始营业。
我在 <time datetime="2008-02-14">情人节</time> 有个约会。

属性

属性 | 值 | 描述
datetime | datetime | 定义元素的日期和时间。 如果未定义该属性，则必须在元素的内容中规定日期或时间。

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。


HTML 5 <title> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <title> 标签

定义和用法

<title> 标签定义文档的标题。

HTML 4.01 与 HTML 5 之间的差异

没有。

提示和注释

注释：一个文档中不能有一个以上的 <title> 元素。

例子

<html>
<head>
<title>HTML 5 Tag Reference</title>
</head>

<body>
The content of the document......
</body>

</html>

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。


HTML 5 <tr> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <tr> 标签

定义和用法

<tr> 标签定义表格中的行。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 5 中，不支持 <tr> 标签的任何属性。

例子

<table>
  <tr>
    <td>Cell A</td>
    <td>Cell B</td>
  </tr>
</table>

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

表格
这个例子演示如何在 HTML 文档中创建表格。
表格中的标题(Headings)
本例演示如何显示表格标题。
空单元格
本例展示如何使用 "&nbsp;" 处理没有内容的单元格。
带有标题的表格
本例演示一个带标题 (caption) 的表格
跨行或跨列的表格单元格
本例演示如何定义跨行或跨列的表格单元格。
表格内的标签
本例演示如何在不同的元素内显示元素。


HTML 5 <tt> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <tt> 标签

定义和用法

<tt> 标签定义打字机文本。HTML 5 中不再支持该标签。请使用 CSS 代替。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 5 中不支持 <tt> 标签。

提示和注释

提示：请使用 CSS 向元素添加样式。


HTML 5 <u> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <u> 标签

定义和用法

<u> 标签定义下划线文本。HTML 5 中不再支持该标签。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 4.01 中不赞成使用 <u> 标签。

在 HTML 5 中不支持 <u> 标签。


HTML 5 <ul> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <ul> 标签

定义和用法

<ul> 标签无序列表。

HTML 4.01 与 HTML 5 之间的差异

在 HTML 4.01 中，ul 元素的 "compact" 和 "type" 属性是不被赞成使用的。在 HTML 5 中，不再支持这两个属性。

提示和注释

提示：请使用 CSS 来定义列表的类型。

例子

<ul>
   <li>Coffee</li>
   <li>Tea</li>
</ul>

属性

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访问 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访问 HTML 5 中事件属性。

TIY 实例

无序列表
本例演示一个无序列表。
嵌套列表
本例演示如何嵌套列表。
嵌套列表 2
本例演示更复杂的嵌套列表。


HTML 5 <video> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <video> 标签

定义和用法

<video> 标签定义视频，比如电影片段或其他视频流。

HTML 4.01 与 HTML 5 之间的差异

<video> 标签是 HTML 5 的新标签。

提示和注释

提示：可以在开始标签和结束标签之间放置文本内容，这样老的浏览器就可以显示出不支持该标签的信息。

例子：

<video src="somevideo.wmv">您的浏览器不支持 video 标签。</video>

属性

属性 | 值 | 描述
autoplay | true | false | 如果是 true，则视频在就绪后马上播放。
controls | true | false | 如果是 true，则向用户显示控件，比如播放按钮。
end | numeric value | 定义播放器在视频流中的何处停止播放。默认地，声音会播放到结尾。
height | pixels | 设置视频播放器的高度。
loopend | numeric value | 定义在视频流中循环播放停止的位置，默认是 end 属性的值。
loopstart | numeric value | 定义在视频流中循环播放的开始位置。默认是 start 属性的值
playcount | numeric value | 定义视频片段播放多少次。默认是 1。
poster | url | 在视频播放之前所显示的图片的 URL。
src | url | 要播放的视频的 URL。
start | numeric value | 定义播放器在音频流中开始播放的位置。默认地，声音在开头进行播放。
width | pixels | 设置视频播放器的宽度。

标准属性

class, contenteditable, contextmenu, dir, draggable, id, irrelevant,
lang, ref, registrationmark, tabindex, template, title

如需完整的描述，请访 HTML 5 中标准属性。

事件属性

onabort, onbeforeunload, onblur, onchange, onclick, oncontextmenu,
ondblclick, ondrag, ondragend, ondragenter, ondragleave, ondragover,
ondragstart, ondrop, onerror, onfocus, onkeydown, onkeypress, onkeyup,
onload, onmessage, onmousedown, onmousemove, onmouseover, onmouseout,
onmouseup, onmousewheel, onresize, onscroll, onselect, onsubmit, onunload

如需完整的描述，请访 HTML 5 中事件属性。


HTML 5 标准属性

HTML 5 参考手册

  • HTML 5 标签
  • HTML 5 属性
  • HTML 5 事件属性

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 5 标准属性

  • Previous Page
  • Next Page

HTML 标签拥有属性。您可以在每个标签的参考页中找到相应的特殊属性。这里列出的属性是通用于每个标签的核心属性和语言属性（有个别例外）。

HTML 4.01 与 HTML 5 之间的差异

HTML 5 中的新属性：contenteditable, contextmenu, draggable, irrelevant, ref, registrationmark, template。

HTML 4.01 中不再支持的属性：accesskey。

属性

属性 | 值 | 描述 | 4 | 5
acceskey | a character | 设置访问一个元素的键盘快捷键。不支持。 | 4 |
class | class_rule or style_rule | 元素的类名。 | 4 | 5
contenteditable | true false | 设置是否允许用户编辑元素。 |  | 5
contentextmenu | id of a menu element | 给元素设置一个上下文菜单。 |  | 5
dir | ltr rtl | 设置文本方向。 | 4 | 5
draggable | true false auto | 设置是否允许用户拖动元素。 |  | 5
id | id_name | 元素的唯一 id。 | 4 | 5
irrelevant | true false | 设置元素是否相关。不显示非相关的元素。 |  | 5
lang | language_code | 设置语言码。 | 4 | 5
ref | url or elementID | 引用另一个文档或本文档上另一个位置。仅在 template 属性设置时使用。 |  | 5
registrationmark | registration mark | 为元素设置拍照。可规定于任何 <rule> 元素的后代元素，除了 <nest> 元素。 |  | 5
style | style_definition | 行内的样式定义。 | 4 | 5
tabindex | number | 设置元素的 tab 顺序。 | 4 | 5
template | url or elementID | 引用应该应用到该元素的另一个文档或本文档上另一个位置。 |  | 5
title | tooltip_text | 显示在工具提示中的文本。 | 4 | 5
  • Previous Page
  • Next Page


HTML 5 参考手册

HTML 5 参考手册

  • HTML 5 标签
  • HTML 5 属性
  • HTML 5 事件属性

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 5 参考手册

  • Next Page

W3C 在 1 月 22 日发布了最新的 HTML 5 工作草案。HTML 5 工作组包括 AOL, Apple, Google, IBM, Microsoft, Mozilla, Nokia, Opera 以及数百个其他的开发商。HTML 5 中的一些新特性：嵌入音频、视频、图片的函数、客户端数据存储，以及交互式文档。其他特性包括新的页面元素，比如 <header>, <section>, <footer>, 以及 <figure>。

通过制定如何处理所有 HTML 元素以及如何从错误中恢复的精确规则，HTML 5 改进了互操作性，并减少了开发成本。

按字母顺序排列

  • 4: 指示在 HTML 4.01 中是否定义了该元素
  • 5: 指示在 HTML 5 中是否定义了该元素
标签 | 描述 | 4 | 5
<!--...--> | 定义注释。 | 4 | 5
<!DOCTYPE> | 定义文档类型。 | 4 | 5
<a> | 定义超链接。 | 4 | 5
<abbr> | 定义缩写。 | 4 | 5
<acronym> | 不支持。定义首字母缩写。 | 4 |
<address> | 定义地址元素。 | 4 | 5
<applet> | 不支持。定义 applet。 | 4 |
<area> | 定义图像映射中的区域。 | 4 | 5
<article> | 定义 article。 |  | 5
<aside> | 定义页面内容之外的内容。 |  | 5
<audio> | 定义声音内容。 |  | 5
<b> | 定义粗体文本。 | 4 | 5
<base> | 定义页面中所有链接的基准 URL。 | 4 | 5
<basefont> | 不支持。请使用 CSS 代替。 | 4 |
<bdo> | 定义文本显示的方向。 | 4 | 5
<big> | 不支持。定义大号文本。 | 4 |
<blockquote> | 定义长的引用。 | 4 | 5
<body> | 定义 body 元素。 | 4 | 5
<br> | 插入换行符。 | 4 | 5
<button> | 定义按钮。 | 4 | 5
<canvas> | 定义图形。 |  | 5
<caption> | 定义表格标题。 | 4 | 5
<center> | 不支持。定义居中的文本。 | 4 |
<cite> | 定义引用。 | 4 | 5
<code> | 定义计算机代码文本。 | 4 | 5
<col> | 定义表格列的属性。 | 4 | 5
<colgroup> | 定义表格列的分组。 | 4 | 5
<command> | 定义命令按钮。 |  | 5
<datagrid> | 定义树列表 (tree-list) 中的数据。 |  | 5
<datalist> | 定义下拉列表。 |  | 5
<datatemplate> | 定义数据模板。 |  | 5
<dd> | 定义定义的描述。 | 4 | 5
<del> | 定义删除文本。 | 4 | 5
<details> | 定义元素的细节。 |  | 5
<dialog> | 定义对话（会话）。 |  | 5
<dir> | 不支持。定义目录列表。 | 4 |
<div> | 定义文档中的一个部分。 | 4 | 5
<dfn> | 定义定义项目。 | 4 | 5
<dl> | 定义定义列表。 | 4 | 5
<dt> | 定义定义的项目。 | 4 | 5
<em> | 定义强调文本。 | 4 | 5
<embed> | 定义外部交互内容或插件。 |  | 5
<event-source> | 为服务器发送的事件定义目标。 |  | 5
<fieldset> | 定义 fieldset。 | 4 | 5
<figure> | 定义媒介内容的分组，以及它们的标题。 |  | 5
<font> | 不赞成。定义文本的字体、尺寸和颜色。 | 4 |
<footer> | 定义 section 或 page 的页脚。 |  | 5
<form> | 定义表单。 | 4 | 5
<frame> | 不支持。定义子窗口（框架）。 | 4 |
<frameset> | 不支持。定义框架的集。 | 4 |
<h1> to <h6> | 定义标题 1 到标题 6。 | 4 | 5
<head> | 定义关于文档的信息。 | 4 | 5
<header> | 定义 section 或 page 的页眉。 |  | 5
<hr> | 定义水平线。 | 4 | 5
<html> | 定义 html 文档。 | 4 | 5
<i> | 定义斜体文本。 | 4 | 5
<iframe> | 定义行内的子窗口（框架）。 | 4 | 5
<img> | 定义图像。 | 4 | 5
<input> | 定义输入域。 | 4 | 5
<ins> | 定义插入文本。 | 4 | 5
<isindex> | 不支持。定义单行的输入域。 | 4 |
<kbd> | 定义键盘文本。 | 4 | 5
<label> | 定义表单控件的标注。 | 4 | 5
<legend> | 定义 fieldset 中的标题。 | 4 | 5
<li> | 定义列表的项目。 | 4 | 5
<link> | 定义资源引用。 | 4 | 5
<m> | 定义有记号的文本。 |  | 5
<map> | 定义图像映射。 | 4 | 5
<menu> | 定义菜单列表。 | 4 | 5
<meta> | 定义元信息。 | 4 | 5
<meter> | 定义预定义范围内的度量。 |  | 5
<nav> | 定义导航链接。 |  | 5
<nest> | 定义数据模板中的嵌套点。 |  | 5
<noframes> | 不支持。定义 noframe 部分。 | 4 |
<noscript> | 不支持。定义 noscript 部分。 | 4 |
<object> | 定义嵌入对象。 | 4 | 5
<ol> | 定义有序列表。 | 4 | 5
<optgroup> | 定义选项组。 | 4 | 5
<option> | 定义下拉列表中的选项。 | 4 | 5
<output> | 定义输出的一些类型。 |  | 5
<p> | 定义段落。 | 4 | 5
<param> | 为对象定义参数。 | 4 | 5
<pre> | 定义预格式化文本。 | 4 | 5
<progress> | 定义任何类型的任务的进度。 |  | 5
<q> | 定义短的引用。 | 4 | 5
<rule> | 为升级模板定义规则。 |  | 5
<s> | 不支持。定义加删除线的文本。 | 4 |
<samp> | 定义样本计算机代码。 | 4 | 5
<script> | 定义脚本。 | 4 | 5
<section> | 定义 section。 |  | 5
<select> | 定义可选列表。 | 4 | 5
<small> | 不支持。定义小号文本。 | 4 | 5
<source> | 定义媒介源。 |  | 5
<span> | 定义文档中的 section。 | 4 | 5
<strike> | 不支持。定义加删除线的文本。 | 4 |
<strong> | 定义强调文本。 | 4 | 5
<style> | 定义样式定义。 | 4 | 5
<sub> | 定义上标文本。 | 4 | 5
<sup> | 定义下标文本。 | 4 | 5
<table> | 定义表格。 | 4 | 5
<tbody> | 定义表格的主体。 | 4 | 5
<td> | 定义表格单元。 | 4 | 5
<textarea> | 定义 textarea。 | 4 | 5
<tfoot> | 定义表格的脚注。 | 4 | 5
<th> | 定义表头。 | 4 | 5
<thead> | 定义表头。 | 4 | 5
<time> | 定义日期/时间。 |  | 5
<title> | 定义文档的标题。 | 4 | 5
<tr> | 定义表格行。 | 4 | 5
<tt> | 不支持。定义打字机文本。 | 4 |
<u> | 不支持。定义下划线文本。 | 4 |
<ul> | 定义无序列表。 | 4 | 5
<var> | 定义变量。 | 4 | 5
<video> | 定义视频。 |  | 5
<xmp> | 不支持。定义预格式文本。 | 4 | 5
  • Next Page


HTML 5 事件属性

HTML 5 参考手册

  • HTML 5 标签
  • HTML 5 属性
  • HTML 5 事件属性

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 5 事件属性

  • Previous Page
  • Next Page

HTML 元素可拥有事件属性，这些属性在浏览器中触发行为，比如当用户单击一个 HTML 元素时启动一段 JavaScript。下面列出的事件属性，可以把它们插入 HTML 标签来定义事件行为。

如果需要学习更多有关使用这些事件进行编程的内容，请学习我们的 JavaScript 教程 和 DHTML 教程。

HTML 4.01 与 HTML 5 之间的差异

HTML 5 中的新事件：onabort, onbeforeunload, oncontextmenu, ondrag, ondragend, ondragenter, ondragleave, ondragover, ondragstart, ondrop, onerror, onmessage, onmousewheel, onresize, onscroll, onunload。

不再支持的 HTML 4.01 属性：onreset。

属性

属性 | 值 | 描述 | 4 | 5
onabort | script | 发生 abort 事件时运行脚本。 |  | 5
onbeforeonload | script | 在元素加载前运行脚本。 |  | 5
onblur | script | 当元素失去焦点时运行脚本。 | 4 | 5
onchange | script | 当元素改变时运行脚本。 | 4 | 5
onclick | script | 在鼠标点击时允许脚本。 | 4 | 5
oncontextmenu | script | 当菜单被触发时运行脚本。 |  | 5
ondblclick | script | 当鼠标双击时运行脚本。 | 4 | 5
ondrag | script | 只要脚本在被拖动就允许脚本。 |  | 5
ondragend | script | 在拖动操作结束时运行脚本。 |  | 5
ondragenter | script | 当元素被拖动到一个合法的放置目标时，执行脚本。 |  | 5
ondragleave | script | 当元素离开合法的放置目标时。 |  | 5
ondragover | script | 只要元素正在合法的放置目标上拖动时，就执行脚本。 |  | 5
ondragstart | script | 在拖动操作开始时执行脚本。 |  | 5
ondrop | script | 当元素正在被拖动时执行脚本。 |  | 5
onerror | script | 当元素加载的过程中出现错误时执行脚本。 |  | 5
onfocus | script | 当元素获得焦点时执行脚本。 | 4 | 5
onkeydown | script | 当按钮按下时执行脚本。 | 4 | 5
onkeypress | script | 当按键被按下时执行脚本。 | 4 | 5
onkeyup | script | 当按钮松开时执行脚本。 | 4 | 5
onload | script | 当文档加载时执行脚本。 | 4 | 5
onmessage | script | 当 message 事件触发时执行脚本。 |  | 5
onmousedown | script | 当鼠标按钮按下时执行脚本。 | 4 | 5
onmousemove | script | 当鼠标指针移动时执行脚本。 | 4 | 5
onmouseover | script | 当鼠标指针移动到一个元素上时执行脚本。 | 4 | 5
onmouseout | script | 当鼠标指针移出元素时执行脚本。 | 4 | 5
onmouseup | script | 当鼠标按钮松开时执行脚本。 | 4 | 5
onmousewheel | script | 当鼠标滚轮滚动时执行脚本。 |  | 5
onreset | script | 当表单重置时执行脚本。不支持。 | 4 |
onresize | script | 当元素调整大小时运行脚本。 |  | 5
onscroll | script | 当元素滚动条被滚动时执行脚本。 |  | 5
onselect | script | 当元素被选中时执行脚本。 | 4 | 5
onsubmit | script | 当表单提交时运行脚本。 | 4 | 5
onunload | script | 当文档卸载时运行脚本。 |  | 5
  • Previous Page
  • Next Page


HTML <!--...--> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <article>
  • <aside>
  • <audio>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <canvas>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <command>
  • <datagrid>
  • <datalist>
  • <datatemplate>
  • <dd>
  • <del>
  • <details>
  • <dialog>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <embed>
  • <event-source>
  • <fieldset>
  • <figure>
  • <font>
  • <footer>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <header>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <m>
  • <map>
  • <menu>
  • <meta>
  • <meter>
  • <nav>
  • <nest>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <output>
  • <p>
  • <param>
  • <pre>
  • <progress>
  • <q>
  • <rule>
  • <s>
  • <samp>
  • <script>
  • <section>
  • <select>
  • <small>
  • <source>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <time>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>
  • <video>

HTML 5 <!--...--> 标签

定义和用法

注释标签用于在源文档中插入注释。注释会被浏览器忽略。您可使用注释对您的代码进行解释，这样做有助于您在以后的时间对代码的编辑。

您也可以在注释内容存储针对程序所定制的信息。在这种情况下，这些信息对用户是不可见的，但是对程序来说是可用的。一个好的习惯是把注释或样式元素放入注释文本中，这样就可避免不支持脚本或样式的老浏览器把它们显示为纯文本。

除了在源文档中有非常明显的作用外，许多 Web 服务器也利用注释来实现文档服务端软件特有的特性。这些服务器可以扫描文档，从传统的 HTML/XHTML 注释中找到特定的字符序列，然后再根据嵌在注释中的命令采取相应的动作。这些动作可能是简单的包括其他文件中的文本（即所谓的服务器端包含，server-inside include），也可能是复杂地执行其他命令去动态生成文档的内容。

HTML 4.01 与 HTML 5 之间的差异

NONE

例子：

<!--This text is a comment-->
<p>This is a regular paragraph</p>

属性：无

TIY 实例

隐藏的注释
本例演示如何在 HTML 源代码中插入隐藏的注释。


altKey 事件属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

altKey 事件属性

返回 Event 对象参考手册

定义和用法

altKey 事件属性返回一个布尔值。指示在指定的事件发生时，Alt 键是否被按下并保持住了。

语法

event.altKey=true|false|1|0

实例

下面的例子可提示当鼠标按键被点击时 "ALT" 键是否已被按住：

<html>
<head>
<script type="text/javascript">
function isKeyPressed(event)
{
  if (event.altKey==1)
    {
    alert("The ALT key was pressed!")
    }
  else
    {
    alert("The ALT key was NOT pressed!")
    }
  }
</script>
</head>

<body onmousedown="isKeyPressed(event)">

<p>Click somewhere in the document.
An alert box will tell you if you
pressed the ALT key or not.</p>

</body>
</html>

TIY

altKey
检测 ALT 键是否已被按住。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


bubbles 事件属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

bubbles 事件属性

返回 Event 对象参考手册

定义和用法

bubbles 事件属性返回一个布尔值，如果事件是起泡类型，则返回 true，否则返回 fasle。

语法

event.bubbles

事件传播

在 2 级 DOM 中，事件传播分为三个阶段：

第一，捕获阶段。事件从 Document 对象沿着文档树向下传递给目标节点。如果目标的任何一个先辈专门注册了捕获事件句柄，那么在事件传播过程中运行这些句柄。

第二个阶段发生在目标节点自身。直接注册砸目标上的适合的事件句柄将运行。这与 0 级事件模型提供的事件处理方法相似。

第三，起泡阶段。在此阶段，事件将从目标元素向上传播回或起泡回 Document 对象的文档层次。

实例

下面的例子可检测发生的事件是否是一个起泡事件：

<html>
<head>

<script type="text/javascript">
function getEventType(event)
  {
  alert(event.bubbles);
  }
</script>
</head>

<body onmousedown="getEventType(event)">

<p>Click somewhere in the document.
An alert box will tell if the event is a bubbling event.</p>

</body>
</html>

TIY

bubbling event
检测事件是否是起泡事件（IE 浏览器不支持）。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


button 事件属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

button 事件属性

返回 Event 对象参考手册

定义和用法

button 事件属性可返回一个整数，指示当事件被触发时哪个鼠标按键被点击。

语法

event.button=0|1|2
参数 | 描述
0 | 规定鼠标左键。
1 | 规定鼠标中键。
2 | 规定鼠标右键。

Internet Explorer 拥有不同的参数：

参数 | 描述
1 | 规定鼠标左键。
4 | 规定鼠标中键。
2 | 规定鼠标右键。

提示和注释

注释：对于惯用左手的鼠标配置，上面的参数是颠倒的。

提示：Mozilla 的 Ctrl–Click 参数是 2 （等价于右击）。

实例

The following example alerts which mouse button was clicked:

<html>
<head>
<script type="text/javascript">
function whichButton(event)
  {
    if (event.button==2)
      {
      alert("You clicked the right mouse button!")
      }
    else
      {
      alert("You clicked the left mouse button!")
      }
  }
</script>
</head>

<body onmousedown="whichButton(event)">

<p>Click in the document. An alert box will
alert which mouse button you clicked.</p>

</body>
</html>

TIY

button
检测哪个鼠标键被点击了。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


cancelable 事件属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

cancelable 事件属性

返回 Event 对象参考手册

定义和用法

cancelable 事件返回一个布尔值。如果用 preventDefault() 方法可以取消与事件关联的默认动作，则为 true，否则为 fasle。

语法

event.cancelable

实例

下面的例子讲检测发生的事件是否是一个 cancelable 事件：

<html>
<head>

<script type="text/javascript">
function isEventCancelable(event)
  {
  alert(event.cancelable);
  }
</script>
</head>

<body onmousedown="isEventCancelable(event)">

<p>Click somewhere in the document.
An alert box will tell if the
event is a cancelable event.</p>

</body>
</html>

TIY

cancelable event
检测事件是否是 cancelable 事件（IE 浏览器不支持）。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


clientX 事件属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

clientX 事件属性

返回 Event 对象参考手册

定义和用法

clientX 事件属性返回当事件被触发时鼠标指针向对于浏览器页面（或客户区）的水平坐标。

客户区指的是当前窗口。

语法

event.clientX

提示和注释

注释：2 级 DOM 没有提供把窗口坐标转换为文档坐标的标准方法。在 IE 以外的浏览器，使用 window.pageXOffset 和 window.pageYOffset 即可。

实例

下面的例子可显示出事件发生时鼠标指针的坐标：

<html>
<head>
<script type="text/javascript">
function show_coords(event)
  {
  x=event.clientX
  y=event.clientY
  alert("X coords: " + x + ", Y coords: " + y)
  }
</script>
</head>

<body onmousedown="show_coords(event)">

    <p>Click in the document. An alert box will alert
the x and y coordinates of the mouse pointer.</p>

</body>
</html>

TIY

clientX
显示鼠标指针的坐标。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


clientY 事件属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

clientY 事件属性

返回 Event 对象参考手册

定义和用法

clientY 事件属性返回当事件被触发时鼠标指针向对于浏览器页面（客户区）的垂直坐标。

客户区指的是当前窗口。

语法

event.clientY

提示和注释

注释：注意，该坐标不考虑文档的滚动。如果事件发生在窗口的顶部，无论文档滚了多远，clientY 的值都是 0。但是，2 级 DOM 没有提供把窗口坐标转换为文档坐标的标准方法。在 IE 以外的浏览器，使用 window.pageXOffset 和 window.pageYOffset 即可。

实例

下面的例子可显示出事件发生时鼠标指针的坐标：

<html>
<head>
<script type="text/javascript">
function show_coords(event)
  {
  x=event.clientX
  y=event.clientY
  alert("X coords: " + x + ", Y coords: " + y)
  }
</script>
</head>

<body onmousedown="show_coords(event)">

<p>Click in the document. An alert box will alert
the x and y coordinates of the mouse pointer.</p>

</body>
</html>

TIY

clientY
显示鼠标指针的坐标。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


ctrlKey 事件属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ctrlKey 事件属性

返回 Event 对象参考手册

定义和用法

ctrlKey 事件属性可返回一个布尔值，指示当事件发生时，Ctrl 键是否被按下并保持住。

语法

event.ctrlKey=true|false|1|0

实例

下面的例子可提示当鼠标按键被点击时 "CTRL" 键是否被按住：

<html>
<head>
<script type="text/javascript">
function isKeyPressed(event)
{
  if (event.ctrlKey==1)
    {
    alert("The CTRL key was pressed!")
    }
  else
    {
    alert("The CTRL key was NOT pressed!")
    }
  }
</script>
</head>

<body onmousedown="isKeyPressed(event)">

    <p>Click somewhere in the document.
An alert box will tell you if you
pressed the CTRL key or not.</p>

</body>
</html>

TIY

ctrlKey
检测 CTRL 键是否被按下了。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


currentTarget 事件属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

currentTarget 事件属性

返回 Event 对象参考手册

定义和用法

currentTarget 事件属性返回其监听器触发事件的节点，即当前处理该事件的元素、文档或窗口。

在捕获和起泡阶段，该属性是非常有用的，因为在这两个节点，它不同于 target 属性。

语法

event.currentTarget

实例

下面的例子可获得哪个元素的监听器触发了事件：

<html>
<head>

<script type="text/javascript">
function getEventTrigger(event)
  {
  x=event.currentTarget;
  alert("The id of the triggered element: "
  + x.id);
  }
</script>
</head>

<body >

<p id="p1" onmousedown="getEventTrigger(event)">
Click on this paragraph. An alert box will
show which element triggered the event.</p>

</body>
</html>

TIY

currenttarget event
获得其监听器触发了事件的那个元素。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


eventPhase 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

eventPhase 属性

返回 Event 对象参考手册

定义和用法

eventPhase 属性返回事件传播的当前阶段。它的值是下面的三个常量之一，它们分别表示捕获阶段、正常事件派发和起泡阶段。

eventPhase 常量

常量 | 值
Event.CAPTURING_PHASE | 1
Event.AT_TARGET | 2
Event.BUBBLING_PHASE | 3

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM abbr 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM abbr 属性

返回 HTML DOM TableCell 对象参考手册

定义和用法

abbr 属性可设置或返回表元中内容的缩写版本（针对非可视的媒介，比如语音和盲文）。

语法

tabledataObject.abbr=text

实例

下面的例子可提示某个单元格的 abbr：

<html>
<head>
<script type="text/javascript">
function alertAbbr()
  {
  alert(document.getElementById('td1').abbr);
  }
</script>
</head>
<body>

<table border="1">
<tr>
<th>Firstname</th>
<th>Lastname</th>
</tr>
<tr>
<td id="td1" abbr="Some text">Peter</td>
<td id="td2">Griffin</td>
</tr>
</table>
<br />
<input type="button" onclick="alertAbbr()"
value="Alert abbr" />

</body>
</html>

TIY

返回某个单元格的 abbr

返回 HTML DOM TableCell 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM acceptCharset 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM acceptCharset 属性

返回 HTML DOM Form 对象参考手册

定义和用法

acceptCharset 属性可设置或返回一个逗号分隔的列表，内容是服务器可接受的字符集。

语法

formObject.acceptCharset=charset

实例

下面的例子提示出表单数据可能的字符集：

<html>
<head>
<script type="text/javascript">
function showCharset()
  {
  var x=document.getElementById("myForm")
  alert(x.acceptCharset)
  }
</script>
</head>
<body>

<form id="myForm" acceptCharset="ISO-8859-1">
Text: <input type="text" value="Hello World!">
<input type="button" onclick="showCharset()"
value="Show charset">
</form>

</body>
</html>

TIY

取得表单数据可能的字符集

返回 HTML DOM Form 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM accessKey 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM accessKey 属性

返回 HTML DOM Anchor 对象参考手册

定义和用法

accessKey 属性可设置或返回访问一个链接的键盘按键。

注释：请使用 Alt + accessKey 为拥有指定快捷键的元素赋予焦点。

语法

anchorObject.accessKey=accessKey

实例

下面的例子将为链接设置快捷键：

<html>
<head>
<script type="text/javascript">
function accesskey()
  {
  document.getElementById('w3').accessKey="w"
  }
</script>
</head>

<body onload="accesskey()">

<a id="w3" href="http://www.w3school.com.cn/">W3School.com.cn</a>

</body>
</html>

TIY

向超链接添加快捷键

返回 HTML DOM Anchor 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM accessKey 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM accessKey 属性

返回 HTML DOM Area 对象参考手册

定义和用法

accessKey 属性可设置或返回访问某个区域的快捷键。

注释：请使用 Alt + accessKey 为拥有指定快捷键的元素赋予焦点。

语法

areaObject.accessKey=accessKey

实例

下面的例子可返回图像映射中 "Venus" 区域的快捷键：

<html>
<body>

<img src="planets.gif"
width="145" height="126"
usemap="#planetmap" />

<map name="planetmap">
<area id="venus" shape="circle"
coords="124,58,8"
alt="Venus"
href="venus.htm" accessKey="v" />
</map>

<p>Access key for "Venus" is:
<script type="text/javascript">
x=document.getElementById('venus');
document.write(x.accessKey);
</script>
</p>

</body>
</html>

TIY

返回图像映射中某个区域的快捷键

返回 HTML DOM Area 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM accessKey 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM accessKey 属性

返回 HTML DOM Button 对象参考手册

定义和用法

accessKey 属性可设置或返回访问一个按钮的键盘按键。

注释：请使用 Alt + accessKey 为拥有指定快捷键的元素赋予焦点。

语法

buttonObject.accessKey=accessKey

实例

下面的例子可返回一个按钮的快捷键：

<html>
<body>

<button id="button1" accessKey="a">
Click Me!</button>

<p>AccessKey for button is:
<script type="text/javascript">
x=document.getElementById('button1');
document.write(x.accessKey);
</script></p>

</body>
</html>

TIY

返回一个按钮的快捷键

返回 HTML DOM Button 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM accessKey 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM accessKey 属性

返回 HTML DOM Button 对象参考手册

定义和用法

accessKey 属性可设置或返回访问一个按钮的键盘按键。

注释：请使用 Alt + accessKey 为拥有指定快捷键的元素赋予焦点。

语法

buttonObject.accessKey=accessKey

实例

下面的例子可返回一个按钮的快捷键：

<html>
<body>

<form>
<input type="button" value="Click me!"
accesskey="b" id="button1" />
</form>

<p>AccessKey for button is:
<script type="text/javascript">
x=document.getElementById('button1');
document.write(x.accessKey);
</script></p>

</body>
</html>

TIY

返回一个按钮的快捷键

返回 HTML DOM Button 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM accessKey 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM accessKey 属性

返回 HTML DOM Checkbox 对象参考手册

定义和用法

accessKey 属性设置或返回 checkbox 的快捷键。

注释：请使用 Alt + accessKey 为拥有指定快捷键的元素赋予焦点。

语法

checkboxObject.accessKey=accessKey

实例

下面的例子返回了 checkbox 的快捷键：

<html>
<body>

<form>
<input type="checkbox" accesskey="c" id="check1" />
</from>

<p>AccessKey for checkbox is:
<script type="text/javascript">
x=document.getElementById('check1');
document.write(x.accessKey);
</script></p>

</body>
</html>

TIY

返回 checkbox 的快捷键

返回 HTML DOM Checkbox 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM AccessKey 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM AccessKey 属性

返回 HTML DOM Password 对象参考手册

定义和用法

accessKey 属性可设置或返回访问密码域的快捷键。

注释：请使用 Alt + accessKey 为拥有指定快捷键的元素赋予焦点。

语法

passwordObject.accessKey=accessKey

实例

下面的例子返回密码域的快捷键：

<html>
<body>

<form>
<input type="password" accesskey="p" id="password1" />
</form>

<p>AccessKey for password field is:
<script type="text/javascript">
x=document.getElementById('password1');
document.write(x.accessKey);
</script></p>

</body>
</html>

TIY

返回访问密码域的快捷键

返回 HTML DOM Password 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM AccessKey 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM AccessKey 属性

返回 HTML DOM Radio 对象参考手册

定义和用法

accessKey 属性可设置或返回访问单选按钮的快捷键。

注释：请使用 Alt + accessKey 为拥有指定快捷键的元素赋予焦点。

语法

radioObject.accessKey=accesskey

实例

下面的例子可返回单选按钮的快捷键：

<html>
<body>

<form>
Male: <input id="male" accesskey="m" type="radio"
name="Sex" value="Male" />
<br />
Female: <input id="female" accesskey="f" type="radio"
name="Sex" value="Female" />
</form>

<p>The access key for the radio buttons are:
<script type="text/javascript">
document.write(document.getElementById('male').accessKey);
document.write(" and ");
document.write(document.getElementById('female').accessKey);
</script></p>

</body>
</html>

TIY

返回单选按钮的快捷键

返回 HTML DOM Radio 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM accessKey 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM accessKey 属性

返回 HTML DOM Reset 对象参考手册

定义和用法

accessKey 属性可设置或返回访问重置按钮的快捷键。

注释：请使用 Alt + accessKey 为拥有指定快捷键的元素赋予焦点。

语法

resetObject.accessKey=accessKey

实例

下面的例子可返回重置按钮的快捷键：

<html>
<body>

<form>
<input type="reset" accesskey="r" id="reset1" />
</form>

<p>AccessKey for the reset button is:
<script type="text/javascript">
x=document.getElementById('reset1');
document.write(x.accessKey);
</script></p>

</body>
</html>

TIY

返回重置按钮的快捷键

返回 HTML DOM Reset 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM accessKey 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM accessKey 属性

返回 HTML DOM Submit 对象参考手册

定义和用法

accessKey 属性可设置或返回访问确认按钮的快捷键。

注释：请使用 Alt + accessKey 为拥有指定快捷键的元素赋予焦点。

语法

submitObject.accessKey=accessKey

实例

下面的例子可返回确认按钮的快捷键：

<html>
<body>

<form>
<input type="submit" accesskey="s" id="submit1" />
</form>

<p>AccessKey for the submit button is:
<script type="text/javascript">
x=document.getElementById('submit1');
document.write(x.accessKey);
</script></p>

</body>
</html>

TIY

返回确认按钮的快捷键

返回 HTML DOM Submit 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM accessKey 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM accessKey 属性

返回 HTML DOM Text 对象参考手册

定义和用法

accessKey 属性可设置或返回访问文本域的快捷键。

注释：请使用 Alt + accessKey 为拥有指定快捷键的元素赋予焦点。

语法

textObject.accessKey=accessKey

实例

下面的例子设置了文本域的快捷键：

<html>
<head>
<script type="text/javascript">
function setAccessKeys()
  {
  document.getElementById('fname').accessKey="n"
  document.getElementById('pwd').accessKey="p"
  }
</script>
</head>

<body onload="setAccessKeys()">
<form>
Name: <input id="fname" type="text" />
<br />
Password: <input id="pwd" type="password" />
</form>
</body>

</html>

TIY

为文本域添加快捷键
为若干表单域添加快捷键

返回 HTML DOM Text 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM accessKey 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM accessKey 属性

返回 HTML DOM Textarea 对象参考手册

定义和用法

accessKey 属性设置或返回访问文本框的键盘快捷字符。

注释：请使用 Alt + accessKey 为拥有指定快捷键的元素赋予焦点。

语法

textareaObject.accessKey=accessKey

实例

下面的例子为文本框规定了快捷键：

<html>
<head>
<script type="text/javascript">
function setAccessKey()
  {
  document.getElementById('txt1').accessKey="t"
  }
</script>
</head>
<body onload="setAccessKey()">

<textarea id="txt1">
Hello world....This is a text area
</textarea>

</body>
</html>

返回 HTML DOM Textarea 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM action 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM action 属性

返回 HTML DOM Form 对象参考手册

定义和用法

action 属性可设置或返回表单的 action 属性。

action 属性定义了当表单被提交时数据被送往何处。

语法

formObject.action=URL

实例

下面的例子可更改表单的 action URL：

<html>
<head>
<script type="text/javascript">
function changeAction()
  {
  var x=document.getElementById("myForm")
  alert("Original action: " + x.action)
  x.action="index.asp"
  alert("New action: " + x.action)
  x.submit()
  }
</script>
</head>
<body>

<form id="myForm" action="js_examples.asp">
Name: <input type="text" value="Mickey Mouse" />
<input type="button" onclick="changeAction()"
value="Change action attribute and submit form" />
</form>

</body>
</html>

TIY

更改表单的 action 属性

返回 HTML DOM Form 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM add() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM add() 方法

返回 HTML DOM Select 对象参考手册

定义和用法

add() 方法用于向 <select> 添加一个 <option> 元素。

语法

selectObject.add(option,before)
参数 | 描述
option | 必需。要添加选项元素。必需是 option 或 optgroup 元素。
before | 必需。在选项数组的该元素之前增加新的元素。如果该参数是null，元素添加到选项数组的末尾。

实例

下面的例子可向下拉列表的末尾添加一个 "kiwi" 选项：

<html>
<head>
<script type="text/javascript">
function insertOption()
  {
  var y=document.createElement('option');
  y.text='Kiwi'
  var x=document.getElementById("mySelect");
  try
    {
    x.add(y,null); // standards compliant
    }
  catch(ex)
    {
    x.add(y); // IE only
    }
  }
</script>
</head>
<body>

<form>
<select id="mySelect">
  <option>Apple</option>
  <option>Pear</option>
  <option>Banana</option>
  <option>Orange</option>
</select>
<input type="button" onclick="insertOption()"
value="Insert option" />
</form>

</body>
</html>

TIY

把一个选项添加到下拉列表的末尾
在下拉列表的被选选项之前添加选项

返回 HTML DOM Select 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM alert() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM alert() 方法

返回 HTML DOM Window 对象参考手册

定义和用法

alert() 方法用于显示带有一条指定消息和一个 OK 按钮的警告框。

语法

alert(message)
参数 | 描述
message | 要在 window 上弹出的对话框中显示的纯文本（而非 HTML 文本）

实例

<html>
<head>
<script type="text/javascript">
function display_alert()
  {
  alert("I am an alert box!!")
  }
</script>
</head>
<body>

<input type="button" onclick="display_alert()"
value="Display alert box" />

</body>
</html>

TIY

显示一个对话框
显示带有折行的对话框

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM align 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM align 属性

返回 HTML DOM Iframe 对象参考手册

定义和用法

align 属性可设置或返回如何根据周围的文本来排列 iframe。

语法

iframeObject.align=left|right|top|middle|bottom

实例

下面的例子将把 iframe 根据环绕文本排列到右侧：

<html>
<body>

<iframe src="frame_a.htm" id="frame1"></iframe>

<p>Some text. Some text. Some text. Some text.</p>

<script type="text/javascript">
document.getElementById("frame1").align="right";
</script>

</body>
</html>

TIY

设置 <iframe> 的排列方式

返回 HTML DOM Iframe 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM align 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM align 属性

返回 HTML DOM Image 对象参考手册

定义和用法

align 属性可设置返回与内联内容的对齐方式。

语法

imageObject.align=left|right|top|middle|bottom

实例

下面的例子把图像根据周围的文本进行右对齐：

<html>
<body>

<img id="compman" src="compman.gif" alt="Computerman" />

<p>Some text. Some text. Some text. Some text.</p>

<script type="text/javascript">
document.getElementById("compman").align="right";
</script>

</body>
</html>

TIY

设置 <image> 元素的对齐方式

返回 HTML DOM Image 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM align 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM align 属性

返回 HTML DOM TableCell 对象参考手册

定义和用法

align 属性可设置或返回表格单元内数据的水平排列方式。

语法

tabledataObject.align=left|right|center

实例

下面的例子把单元格的内容排列到了右边：

<html>
<head>
<script type="text/javascript">
function alignCell()
  {
  document.getElementById('td1').align="right"
  }
</script>
</head>
<body>

<table border="1">
<tr>
<th>Firstname</th>
<th>Lastname</th>
</tr>
<tr>
<td id="td1">Peter</td>
<td id="td2">Griffin</td>
</tr>
</table>
<br />
<input type="button" onclick="alignCell()"
value="Align cell" />

</body>
</html>

TIY

更改 <td> 元素的排列方式

返回 HTML DOM TableCell 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM align 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM align 属性

返回 HTML DOM Tablerow 对象参考手册

定义和用法

align 属性可设置或返回数据在行中的水平对齐方式。

语法

tablerowObject.align=left|center|right|justify|char

实例

下面的例子更改了数据在行中的水平对齐方式：

<html>
<head>
<script type="text/javascript">
function leftAlign()
  {
  document.getElementById('header').align="left";
  }
</script>
</head>
<body>

<table width="100%" border="1">
<tr id="header">
<th>Firstname</th>
<th>Lastname</th>
</tr>
<tr>
<td>Peter</td>
<td>Griffin</td>
</tr>
</table>
<br />
<input type="button" onclick="leftAlign()"
value="Left-align table row" />

</body>
</html>

TIY

对齐行中的单元格内容

返回 HTML DOM Tablerow 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM all 集合

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM all 集合

返回 HTML DOM Document 对象参考手册

定义和用法

all 集合返回对文档中所有 HTML 元素的引用。

语法

document.all[i]
document.all[name]
document.all.tags[tagname]

说明

all[] 是一个多功能的类似数组的对象，它提供了对文档中所有 HTML 元素的访问。all[] 数组源自 IE 4 并且已经被很多其他的浏览器所采用。

all[] 已经被 Document 接口的标准的 getElementByid() 方法和 getElementsByTagName() 方法以及 Document 对象的 getElementsByName() 方法所取代。尽管如此，这个 all[] 数组在已有的代码中仍然使用。

all[] 包含的元素保持了最初的顺序，如果你知道它们在数组中的确切数字化位置，可以直接从数组中提取它们。然而，更为常见的是使用 all[] 数组，根据它们的 HTML 属性 name 或 id 来访问元素。如果多个元素拥有指定的 name，将得到共享同一名称的元素的一个数组。

返回 HTML DOM Document 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM alt 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM alt 属性

返回 HTML DOM Area 对象参考手册

定义和用法

alt 属性可设置或返回当浏览器无法显示某个区域时所显示的替换文本。

语法

areaObject.alt=alternate_text

实例

下面的例子可返回图像映射中 "Venus" 区域的替换文本：

<html>
<body>

<img src="planets.gif"
width="145" height="126"
usemap="#planetmap" />

<map name="planetmap">
<area id="venus" shape="circle"
coords="124,58,8"
alt="The planet Venus"
href="venus.htm" />
</map>

<p>Alternate text for "Venus" is:
<script type="text/javascript">
x=document.getElementById('venus');
document.write(x.alt);
</script>
</p>

</body>
</html>

TIY

返回图像映射中某个区域的替换文本

返回 HTML DOM Area 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM alt 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM alt 属性

返回 HTML DOM Image 对象参考手册

定义和用法

alt 属性可设置或返回图像无法显示时的替代文本。

语法

imageObject.alt=alternate_text

实例

下面的例子将更改图像的替代文本：

<html>
<head>
<script type="text/javascript">
function changeAlt()
  {
  document.getElementById("compman").alt="Man using computer"
  }
function alertAlt()
  {
  alert(document.getElementById("compman").alt)
  }
</script>
</head>
<body>

<img id="compman" src="compman.gif" alt="Computerman" />
<br />
<input type="button" onclick="changeAlt()"
value="Change alt text">
<br /><br />
<input type="button" onclick="alertAlt()"
value="Alert alt text">

</body>
</html>

TIY

更改图像的替代文本

返回 HTML DOM Image 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM alt 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM alt 属性

返回 HTML DOM Button 对象参考手册

定义和用法

alt 属性可设置或返回当浏览器不支持按钮时要显示的替换文本。

语法

buttonObject.alt=alternate_text

实例

下面的例子可返回按钮的 alt 文本：

<html>
<body>

<form>
<input type="button" alt="Button" id="button1"
value="Click me" />
</form>

<p>The alt text for the button is:
<script type="text/javascript">
x=document.getElementById('button1');
document.write(x.alt);
</script></p>

</body>
</html>

TIY

返回按钮的替换文本

返回 HTML DOM Button 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM alt 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM alt 属性

返回 HTML DOM Checkbox 对象参考手册

定义和用法

alt 属性可设置或返回浏览器不支持 checkbox 时显示的替代文本。

语法

checkboxObject.alt=alternate_text

实例

下面的例子返回了 checkbox 的替代文本：

<html>
<body>

<form>
I have a bike: <input id="bike" alt="bike" type="checkbox" name="Bike" />
<br />
I have a car: <input id="car" alt="car" type="checkbox" name="Car" />
</form>

<p>The alt text for the checkboxes are:
<script type="text/javascript">
document.write(document.getElementById('bike').alt);
document.write(" and ");
document.write(document.getElementById('car').alt);
</script></p>

</body>
</html>

TIY

返回 checkbox 的 alt 文本

返回 HTML DOM Checkbox 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM alt 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM alt 属性

返回 HTML DOM Hidden 对象参考手册

定义和用法

alt 属性可设置或返回浏览器不支持隐藏域时显示的文本。

语法

hiddenObject.alt=alternate_text

实例

下面的例子返回了隐藏输入域的 alt 文本：

<html>
<body>

<form>
<input type="hidden" alt="Hidden field" id="hidden1" />
</form>

<p>The alt text for the hidden field is:
<script type="text/javascript">
x=document.getElementById('hidden1');
document.write(x.alt);
</script></p>

</body>
</html>

TIY

返回隐藏域的 alt 文本

返回 HTML DOM Hidden 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM alt 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM alt 属性

返回 HTML DOM Hidden 对象参考手册

定义和用法

form 属性可返回对包含隐藏输入域的表单对象的引用。

语法

hiddenObject.form

实例

下面的例子返回了该隐藏输入域所属的表单的 id：

<html>
<body>

<form id="form1">
<input type="hidden" id="hidden1" />
</form>

<p>The id of the form containing the hidden element is:
<script type="text/javascript">
x=document.getElementById('hidden1');
document.write(x.form.id);
</script></p>

</body>
</html>

TIY

取得隐藏输入域所属的表单的 id

返回 HTML DOM Hidden 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM alt 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM alt 属性

返回 HTML DOM Password 对象参考手册

定义和用法

alt 属性设置或返回在浏览器不支持密码域时显示的替代文本。

语法

passwordObject.alt=alternate_text

实例

下面的例子可返回密码域的替代文本：

<html>
<body>

<form>
<input type="password" alt="Password field" id="pwd1" />
</form>

<p>The alt text for the password field is:
<script type="text/javascript">
x=document.getElementById('pwd1');
document.write(x.alt);
</script></p>

</body>
</html>

TIY

返回密码域的 alt 文本

返回 HTML DOM Password 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM alt 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM alt 属性

返回 HTML DOM Radio 对象参考手册

定义和用法

alt 属性可设置或返回在浏览器不支持单选按钮时显示的替代文本。

语法

radioObject.alt=alternate_text

实例

下面的例子可返回单选按钮的 alt 文本：

<html>
<body>

<form>
Male: <input id="male" alt="male" type="radio"
name="Sex" value="Male" />
<br />
Female: <input id="female" alt="female" type="radio"
name="Sex" value="Female" />
</form>

<p>The alt text for the radio buttons are:
<script type="text/javascript">
document.write(document.getElementById('male').alt);
document.write(" and ");
document.write(document.getElementById('female').alt);
</script></p>

</body>
</html>

TIY

返回单选按钮的 alt 文本

返回 HTML DOM Radio 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM alt 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM alt 属性

返回 HTML DOM Reset 对象参考手册

定义和用法

alt 属性可设置或返回在浏览器不支持重置按钮时显示的替代文本。

语法

resetObject.alt=alternate_text

实例

下面的例子可返回重置按钮的 alt 文本：

<html>
<body>

<form>
<input type="reset" alt="Reset button" id="reset1" />
</form>

<p>The alt text for the reset button is:
<script type="text/javascript">
x=document.getElementById('reset1');
document.write(x.alt);
</script></p>

</body>
</html>

TIY

返回重置按钮的 alt 文本

返回 HTML DOM Reset 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM alt 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM alt 属性

返回 HTML DOM Submit 对象参考手册

定义和用法

alt 属性可设置或返回在浏览器不支持确认按钮时显示的替代文本。

语法

submitObject.alt=alternate_text

实例

下面的例子可返回确认按钮的 alt 文本：

<html>
<body>

<form>
<input type="submit" alt="submit button" id="submit1" />
</form>

<p>The alt text for the submit button is:
<script type="text/javascript">
x=document.getElementById('submit1');
document.write(x.alt);
</script></p>

</body>
</html>

TIY

返回确认按钮的 alt 文本

返回 HTML DOM Submit 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM alt 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM alt 属性

返回 HTML DOM Text 对象参考手册

定义和用法

alt 属性可设置或返回在浏览器不支持文本域时显示的替代文本。

语法

textObject.alt=alternate_text

实例

下面的例子可返回文本域的 alt 文本：

<html>
<body>

<form>
Email: <input type="text" alt="Email input field" id="email" />
</form>

<p>The alt text for the text field is:
<script type="text/javascript">
x=document.getElementById('email');
document.write(x.alt);
</script></p>

</body>
</html>

TIY

返回文本域的 alt 文本

返回 HTML DOM Text 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Anchor 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Anchor 对象

Anchor 对象

Anchor 对象代表一个 HTML 超链接。

在 HTML 文档中 <a> 标签每出现一次，Anchor 对象就会被创建。

锚可用于创建到另一个文档的链接（通过 href 属性），或者创建文档内的书签。

您可以通过搜索 Document 对象中的 anchors[] 数组来访问某个锚，或者使用 document.getElementById() 。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet Standard).

Anchor 对象的属性

属性 | 描述 | IE | F | O | W3C
accessKey | 设置或返回访问一个链接的快捷键。 | 5 | 1 | No | Yes
charset | 设置或返回被链接资源的字符集。 | 6 | 1 | 9 | Yes
coords | 设置或返回逗号分隔列表，其中包含了图像映射中一个链接的坐标。 | 6 | 1 | 9 | Yes
href | 设置或返回被链接资源的 URL。 | 5 | 1 | 9 | Yes
hreflang | 设置或返回被链接资源的语言代码。 | 6 | 1 | 9 | Yes
id | 设置或返回一个链接的 id。 | 4 | 1 | 9 | Yes
innerHTML | 设置或返回一个链接的内容。 | 4 | 1 | 9 | No
name | 设置或返回一个链接的名称。 | 4 | 1 | 9 | Yes
rel | 设置或返回当前文档与目标 URL 之间的关系。 | 5 | 1 | No | Yes
rev | 设置或返回目标 URL 与之间当前文档的关系。 | 5 | 1 | No | Yes
shape | 设置或返回图像映射中某个链接的形状。 | 6 | 1 | 9 | Yes
tabIndex | 设置或返回某个链接的 Tab 键控制次序。 | 6 | 1 | 9 | Yes
target | 设置或返回在何处打开链接。 | 5 | 1 | 9 | Yes
type | 设置或返回被链接资源的 MIME 类型。 | 6 | 1 | 9 | Yes

标准属性

Property | Description | IE | F | O | W3C
className | Sets or returns the class attribute of an element | 5 | 1 | 9 | Yes
dir | Sets or returns the direction of text | 5 | 1 | 9 | Yes
lang | Sets or returns the language code for an element | 5 | 1 | 9 | Yes
title | Sets or returns an element's advisory title | 5 | 1 | 9 | Yes

Anchor 对象的方法

Method | Description | IE | F | O | W3C
blur() | 把焦点从链接上移开 | 5 | 1 | 9 | Yes
focus() | 给链接应用焦点 | 5 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM anchors 集合

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM anchors 集合

返回 HTML DOM Document 对象参考手册

定义和用法

anchors 集合可返回对文档中所有 Anchor 对象的引用。

语法

document.anchors[]

实例

<html>

<body>
<a name="first">First anchor</a><br />
<a name="second">Second anchor</a><br />
<a name="third">Third anchor</a><br />
<br />

Number of anchors in this document:
<script type="text/javascript">
document.write(document.anchors.length)
</script>
</body>

</html>

TIY

返回文档中锚的数目
返回文档中第一个锚的 innerHTML

返回 HTML DOM Document 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM appCodeName 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM appCodeName 属性

返回 HTML DOM Navigator 对象参考手册

定义和用法

appCodeName 属性是一个只读字符串，声明了浏览器的代码名。

在所有以 Netscape 代码为基础的浏览器中，它的值是 "Mozilla"。为了兼容起见，在 Microsoft 的浏览器中，它的值也是 "Mozilla"。

语法

navigator.appCodeName

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>CodeName: ")
document.write(navigator.appCodeName + "</p>")
</script>
</body>

</html>

TIY

检测访问者的浏览器和版本号
有关访问者的浏览器的更多信息
有关访问者的浏览器的全部细节
根据浏览器来提醒用户

返回 HTML DOM Navigator 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM appMinorVersion 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM appMinorVersion 属性

返回 HTML DOM Navigator 对象参考手册

定义和用法

appMinorVersion 属性可返回浏览器的次要版本。

语法

navigator.appMinorVersion

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>MinorVersion: ")
document.write(navigator.appMinorVersion + "</p>")
</script>
</body>

</html>

TIY

检测访问者的浏览器和版本号
有关访问者的浏览器的更多信息
有关访问者的浏览器的全部细节
根据浏览器来提醒用户

返回 HTML DOM Navigator 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM appName 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM appName 属性

返回 HTML DOM Navigator 对象参考手册

定义和用法

appName 属性可返回浏览器的名称。

appName 属性是一个只读到字符串，声明了浏览器的名称。在基于 Netscape 的浏览器中，这个属性的值是 "Netscape"。在 IE 中，这个属性的值是 "Microsoft Internet Explorer"。其他浏览器可以正确地表示自己或者伪装成其他的浏览器以达到兼容性。

语法

navigator.appMinorVersion

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>Name: ")
document.write(navigator.appName + "</p>")
</script>
</body>

</html>

TIY

检测访问者的浏览器和版本号
有关访问者的浏览器的更多信息
有关访问者的浏览器的全部细节
根据浏览器来提醒用户

返回 HTML DOM Navigator 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM appVersion 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM appVersion 属性

返回 HTML DOM Navigator 对象参考手册

定义和用法

appVersion 属性可返回浏览器的平台和版本信息。该属性是一个只读的字符串。

该字符串的第一部分是版本号。把该字符串传递给 parseInt() 只能获取主版本号。该属性的其余部分提供了有关浏览器版本的其他细节，包括运行它的操作系统的信息。

语法

navigator.appVersion

提示和注释

注释：不同浏览器提供的信息的格式是不同的。

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>Version: ")
document.write(navigator.appVersion + "</p>")
</script>
</body>

</html>

TIY

检测访问者的浏览器和版本号
有关访问者的浏览器的更多信息
有关访问者的浏览器的全部细节
根据浏览器来提醒用户

返回 HTML DOM Navigator 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Area 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Area 对象

Area 对象

Area 对象代表图像映射的一个区域（图像映射指的是带有可点击区域的图像）

在 HTML 文档中 <area> 标签每出现一次，就会创建一个 Area 对象。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet Standard).

Area 对象的属性

属性 | 描述 | IE | F | O | W3C
accessKey | 设置或返回访问某个区域的快捷键。 | 5 | 1 | No | Yes
alt | 设置或返回当浏览器无法显示某个区域时的替换文字。 | 5 | 1 | 9 | Yes
coords | 设置或返回图像映射中可点击区域的坐标。 | 5 | 1 | 9 | Yes
hash | 设置或返回某个区域中 URL 的锚部分。 | 4 | 1 | No | No
host | 设置或返回某个区域中 URL 的主机名和端口。 | 4 | 1 | No | No
href | 设置或返回图像映射中链接的 URL。 | 4 | 1 | 9 | Yes
id | 设置或返回某个区域的 id。 | 4 | 1 | 9 | Yes
noHref | 设置或返回某个区域是否应是活动的还是非活动的。 | 5 | 1 | 9 | Yes
pathname | 设置或返回某个区域中的 URL 的路径名。 | 4 | 1 | 9 | No
protocol | 设置或返回某个区域中的 URL 的协议。 | 4 | 1 | 9 | No
search | 设置或返回某个区域中 URL 的查询字符串部分。 | 4 | 1 | 9 | No
shape | 设置或返回图像映射中某个区域的形状。 | 5 | 1 | 9 | Yes
tabIndex | 设置或返回某个区域的 tab 键控制次序。 | 5 | 1 | 9 | Yes
target | 设置或返回在何处打开区域中的 link-URL。 | 4 | 1 | 9 | Yes

标准属性

属性 | 描述 | IE | F | O | W3C
className | Sets or returns the class attribute of an element | 5 | 1 | 9 | Yes
dir | Sets or returns the direction of text | 5 | 1 | 9 | Yes
lang | Sets or returns the language code for an element | 5 | 1 | 9 | Yes
title | Sets or returns an element's advisory title | 5 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM assign() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM assign() 方法

返回 HTML DOM Location 对象参考手册

定义和用法

assign() 方法可加载一个新的文档。

语法

location.assign(URL)

实例

下面的例子将使用 assign() 来加载一个新的文档：

<html>
<head>
<script type="text/javascript">
function newDoc()
  {
  window.location.assign("http://www.w3school.com.cn")
  }
</script>
</head>
<body>

<input type="button" value="Load new document" onclick="newDoc()" />

</body>
</html>

TIY

使用 location 对象的 assign() 方法

返回 HTML DOM Location 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM availHeight 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM availHeight 属性

返回 HTML DOM Screen 对象参考手册

定义和用法

availHeight 属性声明了显示浏览器的屏幕的可用高度，以像素计。在 Windows 这样的操作系统中，这个可用高度不包括分配给半永久特性（如屏幕底部的任务栏）的垂直空间。

语法

screen.availHeight

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>Available Height: ")
document.write(screen.availHeight + "</p>")
</script>
</body>

</html>

TIY

检测有关客户机的屏幕的细节

返回 HTML DOM Screen 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM availWidth 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM availWidth 属性

返回 HTML DOM Screen 对象参考手册

定义和用法

availWidth 属性声明了显示浏览器的屏幕的可用宽度，以像素计。在 Windows 这样的操作系统中，这个可用高度不包括分配给半永久特性（如屏幕底部的任务栏）的垂直空间。

语法

screen.availWidth

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>Available Width: ")
document.write(screen.availWidth + "</p>")
</script>
</body>

</html>

TIY

检测有关客户机的屏幕的细节

返回 HTML DOM Screen 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM axis 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM axis 属性

返回 HTML DOM TableCell 对象参考手册

定义和用法

axis 属性可设置或返回一个由逗号分隔的列表，其中包含了一组类型（有关联的单元格）的名称。

axis 属性可为某个单元格定义类型名称。

语法

tabledataObject.axis=text

实例

下面的例子可返回单元格的 axis：

<<html>
<head>
<script type="text/javascript">
function alertAxis()
  {
  alert(document.getElementById('td3').axis);
  }
</script>
</head>
<body>

<table border="1">
<tr>
<th>Firstname</th>
<th>Lastname</th>
<th>City</th>
</tr>
<tr>
<td id="td1">Harry</td>
<td id="td2">Potter</td>
<td id="td3" axis="location">NY</td>
</tr>
<tr>
<td id="td4">Peter</td>
<td id="td5">Griffin</td>
<td id="td6" axis="location">Las Vegas</td>
</tr>
</table>
<br />
<input type="button" onclick="alertAxis()"
value="Alert axis" />

</body>
</html>

TIY

显示表元的 axis

返回 HTML DOM TableCell 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM back() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM back() 方法

返回 HTML DOM History 对象参考手册

定义和用法

back() 方法可加载历史列表中的前一个 URL（如果存在）。

调用该方法的效果等价于点击后退按钮或调用 history.go(-1)。

语法

history.back()

实例

下面的例子可在页面上创建一个后退按钮：

<html>
<head>
<script type="text/javascript">
function goBack()
  {
  window.history.back()
  }
</script>
</head>
<body>

<input type="button" value="Back" onclick="goBack()" />

</body>
</html>

返回 HTML DOM History 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM background 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM background 属性

返回HTML DOM Style 对象参考手册

定义和用法

background 属性在一个声明中设置所有的背景属性。

语法：

Object.style.background=background-color background-image
background-repeat background-attachment background-position
参数 描述 值
background-color 设置元素的背景色。
  • color-name
  • color-rgb
  • color-hex
  • transparent
background-image 设置背景图像。
  • url(URL)
  • none
background-repeat 设置背景图像是否及如何重复。
  • repeat
  • repeat-x
  • repeat-y
  • no-repeat
background-attachment 背景图像是否固定或者随着页面的其余部分滚动。
  • scroll
  • fixed
background-position 设置背景图像的起始位置。
  • top left
  • top center
  • top right
  • center left
  • center center
  • center right
  • bottom left
  • bottom center
  • bottom right
  • x% y%
  • xpos ypos

实例

下面的例子改变了文档背景的样式：

<html>
<head>
<script type="text/javascript">
function setStyle()
{
document.body.style.background="#FFCC80 url(bgdesert.jpg) repeat-y";
}
</script>
</head>
<body>

<input type="button" onclick="setStyle()"
value="Set background style" />

</body>
</html>

TIY

改变文档背景的样式

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM backgroundAttachment 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM backgroundAttachment 属性

返回HTML DOM Style 对象参考手册

定义和用法

backgroundAttachment 属性设置背景图像是否固定或者随着页面的其余部分滚动。

语法：

Object.style.backgroundAttachment=scroll|fixed

提示和注释

提示：请设置一种可用的背景颜色，这样的话，假如背景图像不可用，页面也可获得良好的视觉效果。

实例

本例设置在点击按钮后把背景图像设置为固定（不滚动）：

<html>
<head>
<style type="text/css">
body
{
background-color="#FFCC80";
background-image:url(bgdesert.jpg);
}
p
{
color:white;
}
</style>
<script type="text/javascript">
function changeAttachment()
{
document.body.style.backgroundAttachment="fixed";
}
</script>

</head>
<body>

<input type="button" onclick="changeAttachment()"
value="Set background-image to be fixed" />
<p>This is a paragraph</p>
<p>This is a paragraph</p>
<p>This is a paragraph</p>
<p>This is a paragraph</p>
<p>This is a paragraph</p>
<p>This is a paragraph</p>
<p>This is a paragraph</p>
<p>This is a paragraph</p>
<p>This is a paragraph</p>
<p>This is a paragraph</p>
<p>This is a paragraph</p>
<p>This is a paragraph</p>
<p>This is a paragraph</p>
<p>This is a paragraph</p>

</body>
</html>

TIY

把背景图像设置为固定

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM backgroundColor 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM backgroundColor 属性

返回HTML DOM Style 对象参考手册

定义和用法

backgroundColor 属性设置元素的背景颜色。

语法：

Object.style.backgroundColor=color-name|color-rgb
|color-hex|transparent

实例

本例设置 body 的背景色：

<html>
<head>
<style type="text/css">
body
{
background-color:#B8BFD8;
}
</style>
<script type="text/javascript">
function changeStyle()
{
document.body.style.backgroundColor="#FFCC80";
}
</script>
</head>
<body>

<input type="button" onclick="changeStyle()"
value="Change background color" />

</body>
</html>

TIY

改变背景色（十六进制）
改变背景色（颜色名）

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM backgroundImage 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM backgroundImage 属性

返回HTML DOM Style 对象参考手册

定义和用法

backgroundImage 属性设置元素的背景图像。

语法：

Object.style.backgroundImage=url(URL)|none
参数 | 描述
url(URL) | 图像的路径。
none | 无背景图像。

提示和注释

提示：请设置一种可用的背景颜色，这样的话，假如背景图像不可用，页面也可获得良好的视觉效果。

实例

本例设置了背景图像：

<html>
<head>
<script type="text/javascript">
function changeStyle()
{
document.body.style.backgroundColor="#FFCC80";
document.body.style.backgroundImage="url(bgdesert.jpg)";
}
</script>
</head>
<body>

<input type="button" onclick="changeStyle()"
value="Set background image" />

</body>
</html>

TIY

设置背景图像

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM backgroundPosition 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM backgroundPosition 属性

返回HTML DOM Style 对象参考手册

定义和用法

backgroundPosition 属性设置背景图像的位置。

语法：

Object.style.backgroundPosition=position
参数 描述
  • top left
  • top center
  • top right
  • center left
  • center center
  • center right
  • bottom left
  • bottom center
  • bottom right

如果您仅规定了一个关键词，那么第二个值将是"center"。

默认值：0% 0%。
x% y%

第一个值是水平位置，第二个值是垂直位置。

左上角是 0% 0%。右下角是 100% 100%。

如果您仅规定了一个值，另一个值将是 50%。
xpos ypos

第一个值是水平位置，第二个值是垂直位置。

左上角是 0 0。单位是像素 (0px 0px) 或任何其他的 CSS 单位。

如果您仅规定了一个值，另一个值将是50%。

您可以混合使用 % 和 position 值。

实例

本例改变背景图像的位置：

<html>
<head>
<style type="text/css">
body
{
background-color:#FFCC80;
background-image:url(bgdesert.jpg);
background-repeat:no-repeat
}
</style>
<script type="text/javascript">
function changePosition()
{
document.body.style.backgroundPosition="bottom center";
}
</script>
</head>
<body>

<input type="button" onclick="changePosition()"
value="Change background-image position" />

</body>
</html>

TIY

改变背景图像的位置

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM backgroundPositionX 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM backgroundPositionX 属性

返回HTML DOM Style 对象参考手册

定义和用法

backgroundPositionX 属性设置背景图像的水平位置。

语法：

Object.style.backgroundPositionX=position
参数 | 描述
  • left
  • center
  • right
 水平位置。
x% | 水平位置。左是 0%。右是 100%。
xpos | 水平位置。左是 0。单位是像素 (0px) 或其他 CSS 单位。

实例

本例改变了背景图像的水平位置：

<html>
<head>
<style type="text/css">
body
{
background-color:#FFCC80;
background-image:url(bgdesert.jpg);
background-repeat:no-repeat
}
</style>
<script type="text/javascript">
function changePosition()
{
document.body.style.backgroundPositionX="right";
}
</script>
</head>
<body>

<input type="button" onclick="changePosition()"
value="Change background-image's x-position" />

</body>
</html>

TIY

改变背景图像的水平位置

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM backgroundPositionY 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM backgroundPositionY 属性

返回HTML DOM Style 对象参考手册

定义和用法

backgroundPositionY 属性设置 background-image 的垂直位置。

语法：

Object.style.backgroundPositionY=position
参数 | 描述
  • top
  • center
  • bottom
 垂直位置。
y% | 垂直位置。Top 是 0%。Bottom 是 100%
ypos | 垂直位置。Top 是 0。单位是像素 (0px) 或其他 CSS 单位。

实例

下面的例子改变 background-image 的垂直位置：

<html>
<head>
<style type="text/css">
body
{
background-color:#FFCC80;
background-image:url(bgdesert.jpg);
background-repeat:no-repeat
}
</style>
<script type="text/javascript">
function changePosition()
{
document.body.style.backgroundPositionY="bottom";
}
</script>
</head>
<body>

<input type="button" onclick="changePosition()"
value="Change background-image's y-position" />

</body>
</html>

TIY

改变 background-image 的垂直位置

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM backgroundRepeat 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM backgroundRepeat 属性

返回HTML DOM Style 对象参考手册

定义和用法

backgroundRepeat 属性设置背景图像是否及如何重复。

语法：

Object.style.backgroundRepeat=repeat_value
参数 | 描述
repeat | 默认。背景图像将在垂直方向和水平方向重复。
repeat-x | 背景图像将在水平方向重复。
repeat-y | 背景图像将在垂直方向重复。
no-repeat | 背景图像将仅显示一次。

实例

本例仅在 y 轴重复背景图像：

<html>
<head>
<style type="text/css">
body
{
background-color:#FFCC80;
background-image:url(bgdesert.jpg);
}
</style>
<script type="text/javascript">
function changeRepeat()
{
document.body.style.backgroundRepeat="repeat-y";
}
</script>
</head>
<body>

<input type="button" onclick="changeRepeat()"
value="Repeat background-image only on the y-axis" />

</body>
</html>

TIY

改变 background-image 的 repeat 属性

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Base 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Base 对象

Base 对象

Base 对象代表 HTML 的 base 元素

在 HTML 文档中 <base> 每出现一次，Base 对象就会被创建。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet Standard).

Base 对象的属性

属性 | 描述 | IE | F | O | W3C
href | 设置或返回针对页面中所有链接的基准 URL | 5 | 1 | 9 | Yes
id | 设置或返回 <base> 元素的 id | 4 | 1 | 9 | Yes
target | 设置或返回针对页面中所有链接的默认目标框架 | 5 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM blur() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM blur() 方法

返回 HTML DOM Window 对象参考手册

定义和用法

blur() 方法可把键盘焦点从顶层窗口移开。

语法

window.blur()

说明

方法 blur() 可把键盘焦点从顶层浏览器窗口移走，整个窗口由 Window 对象指定。哪个窗口最终获得键盘焦点并没有指定。

提示和注释

注释：在某些浏览器上，该方法可能无效。

实例

<html>
<body>

<script type="text/javascript">
myWindow=window.open('','','width=200,height=100')
myWindow.document.write("This is 'myWindow'")
myWindow.blur()
</script>

</body>
</html>

TIY

把焦点移到新窗口
从新窗口移开焦点

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM blur() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM blur() 方法

返回 HTML DOM Anchor 对象参考手册

定义和用法

blur() 方法用于从链接上移开焦点。

语法

anchorObject.blur()

实例

<html>
<head>
<style type="text/css">
a:active {color:green}
</style>

<script type="text/javascript">
function getfocus()
{document.getElementById('myAnchor').focus()}

function losefocus()
{document.getElementById('myAnchor').blur()}
</script>
</head>

<body>
<a id="myAnchor"
href="http://www.w3school.com.cn">Visit W3School.com.cn</a>
<br /><br/>
<input type="button" onclick="getfocus()" value="Get focus">
<input type="button" onclick="losefocus()" value="Lose focus">
</body>

</html>

TIY

使用 focus() 和 blur()

返回 HTML DOM Anchor 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM blur() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM blur() 方法

返回 HTML DOM Button 对象参考手册

定义和用法

blur() 方法用于把焦点从按钮上移开。

语法

buttonObject.blur()

实例

下面的例子讲吧焦点从按钮上移开：

<html>
<head>
<script type="text/javascript">
function removeFocus()
  {
  document.getElementById('button1').blur()
  }
</script>
</head>
<body>

<form>
<input type="button" id="button1" value="Button1" />
<br />
<input type="button" onclick="removeFocus()"
value="Remove focus from Button 1" />
</form>

</body>
</html>

TIY

设置并从按钮上移开焦点

返回 HTML DOM Button 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM blur() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM blur() 方法

返回 HTML DOM Checkbox 对象参考手册

定义和用法

blur() 方法用于从 checkbox 上移开焦点。

语法

checkboxObject.blur()

实例

下面的例子可设置并移开 checkbox 上的焦点：

<html>
<head>
<script type="text/javascript">
function setFocus()
  {
  document.getElementById('check1').focus()
  }
function loseFocus()
  {
  document.getElementById('check1').blur()
  }
</script>
</head>
<body>

<form>
<input type="checkbox" id="check1" />
<br />
<input type="button" onclick="setFocus()" value="Set focus" />
<input type="button" onclick="loseFocus()" value="Lose focus" />
</form>

</body>
</html>

TIY

设置并移开 checkbox 上的焦点

返回 HTML DOM Checkbox 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM blur() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM blur() 方法

返回 HTML DOM Select 对象参考手册

定义和用法

blur() 方法用于从密码域移开焦点。

语法

passwordObject.blur()

实例

下面的例子可设置或返回密码域的焦点：

<html>
<head>
<script type="text/javascript">
function setFocus()
  {
  document.getElementById('password1').focus()
  }
function loseFocus()
  {
  document.getElementById('password1').blur()
  }
</script>
</head>
<body>

<form>
<input type="password" id="password1" value="thgrt456" />
<input type="button" onclick="setFocus()" value="Set focus" />
<input type="button" onclick="loseFocus()" value="Lose focus" />
</form>

</body>
</html>

TIY

设置或返回密码域的焦点

返回 HTML DOM Select 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM blur() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM blur() 方法

返回 HTML DOM Radio 对象参考手册

定义和用法

blur() 方法用于从单选按钮上移开焦点。

语法

radioObject.blur()

实例

下面的例子可设置或移开单选按钮上的焦点：

<html>
<head>
<script type="text/javascript">
function setFocus()
  {
  document.getElementById('male').focus()
  }
function loseFocus()
  {
  document.getElementById('male').blur()
  }
</script>
</head>
<body>

<form>
Male: <input id="male" type="radio" name="Sex" value="Male" />
<br />
Female: <input id="female" type="radio" name="Sex" value="Female" />
<br />
<input type="button" onclick="setFocus()" value="Set focus" />
<input type="button" onclick="loseFocus()" value="Lose focus" />
</form>

</body>
</html>

TIY

设置或移开单选按钮上的焦点

返回 HTML DOM Radio 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM blur() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM blur() 方法

返回 HTML DOM Text 对象参考手册

定义和用法

blur() 方法用于从文本域移开焦点。

语法

textObject.blur()

实例

下面的例子可设置和移开文本域上的焦点：

<html>
<head>
<script type="text/javascript">
function setFocus()
  {
  document.getElementById('text1').focus()
  }
function loseFocus()
  {
  document.getElementById('text1').blur()
  }
</script>
</head>
<body>

<form>
<input type="text" id="text1" />
<br />
<input type="button" onclick="setFocus()" value="Set focus" />
<input type="button" onclick="loseFocus()" value="Lose focus" />
</form>

</body>
</html>

TIY

设置和移开文本域上的焦点

返回 HTML DOM Text 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM blur() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM blur() 方法

返回 HTML DOM Select 对象参考手册

定义和用法

focus() 方法用于从下拉列表中移开焦点。

语法

selectObject.blur()

实例

下面的例子可设置或从下拉列表移开焦点：

<html>
<head>
<script type="text/javascript">
function setFocus()
  {
  document.getElementById('select1').focus()
  }
function loseFocus()
  {
  document.getElementById('select1').blur()
  }
</script>
</head>
<body>

<form>
<select id="select1">
  <option>Apple</option>
  <option>Pear</option>
  <option>Banana</option>
  <option>Orange</option>
</select>
<br /><br />
<input type="button" onclick="setFocus()" value="Set focus" />
<input type="button" onclick="loseFocus()" value="Lose focus" />
</form>

</body>
</html>

TIY

设置并从下拉列表移开焦点

返回 HTML DOM Select 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM blur() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM blur() 方法

返回 HTML DOM Textarea 对象参考手册

定义和用法

blur() 方法用于把键盘焦点从该元素上移开。

语法

textareaObject.blur()

实例

下面的例子设置并移开了文本框上的焦点：

<html>
<head>
<script type="text/javascript">
function setFocus()
  {
  document.getElementById('txt1').focus()
  }
function loseFocus()
  {
  document.getElementById('txt1').blur()
  }
</script>
</head>
<body>

<textarea id="txt1">Hello world....</textarea>
<br />
<input type="button" onclick="setFocus()" value="Set focus" />
<input type="button" onclick="loseFocus()" value="Lose focus" />

</body>
</html>

返回 HTML DOM Textarea 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Body 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Body 对象

Body 对象

Body 对象代表文档的主体 (HTML body) 。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet Standard).

Body 对象的属性

属性 | 描述 | IE | F | O | W3C
className | 设置或返回元素的 class 属性 | 5 | 1 | 9 | Yes
dir | 设置或返回文本的方向 | 5 | 1 | 9 | Yes
id | 设置或返回 body 的 id | 5 | 1 | 9 | Yes
lang | 设置或返回元素的语言代码 | 5 | 1 | 9 | Yes
title | 设置或返回元素的咨询性的标题 | 5 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM border 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM border 属性

返回 HTML DOM Image 对象参考手册

定义和用法

border 属性可设置或返回图像周围的边框宽度。

语法

imageObject.border=pixels

实例

下面的例子可更改图像的边框宽度：

<<html>
<head>
<script type="text/javascript">
function changeBorder()
  {
  document.getElementById("compman").border="3"
  }
</script>
</head>
<body>

<img id="compman" src="compman.gif" alt="Computerman" />
<br /><br />
<input type="button" onclick="changeBorder()"
value="Change border" />

</body>
</html>

TIY

更改图像周围的边框

返回 HTML DOM Image 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM border 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM border 属性

返回 HTML DOM Table 对象参考手册

定义和用法

border 属性可设置或返回表格边框的宽度（以像素为单位）。

语法

tableObject.border=pixels

实例

<html>
<head>
<script type="text/javascript">
function changeBorder()
  {
  document.getElementById('myTable').border="10"
  }
</script>
</head>
<body>

<table border="1" id="myTable">
<tr>
<td>100</td>
<td>200</td>
</tr>
<tr>
<td>300</td>
<td>400</td>
</tr>
</table>
<br />
<input type="button" onclick="changeBorder()"
value="Change Border">

</body>
</html>

TIY

更改表格边线的宽度

返回 HTML DOM Table 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM border 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM border 属性

返回HTML DOM Style 对象参考手册

定义和用法

border 属性在一个声明中设置所有边框属性。

语法：

Object.style.border=borderWidth borderStyle borderColor
值 描述 值
borderWidth 设置边框的宽度。
  • thin
  • medium
  • thick
  • length
borderStyle 设置边框的样式。
  • none
  • hidden
  • dotted
  • dashed
  • solid
  • double
  • groove
  • ridge
  • inset
  • outset
borderColor 设置边框的颜色。
  • color-name
  • color-rgb
  • color-hex
  • transparent

实例

本例改变元素的边框：

<html>
<head>
<style type="text/css">
p
{
border: thin dotted #FF0000
}
</style>
<script type="text/javascript">
function changeBorder()
{
document.getElementById("p1").style.border="thick solid #0000FF";
}
</script>
</head>
<body>

<input type="button" onclick="changeBorder()"
value="Change border" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

border - 改变元素的边框

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM borderBottom 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM borderBottom 属性

返回HTML DOM Style 对象参考手册

定义和用法

borderBottom 属性在一个声明中为下边框设置所有的属性。

语法：

Object.style.borderBottom=borderWidth borderStyle borderColor
值 描述 值
borderWidth 设置边框的宽度。
  • thin
  • medium
  • thick
  • length
borderStyle 设置边框的样式。
  • none
  • hidden
  • dotted
  • dashed
  • solid
  • double
  • groove
  • ridge
  • inset
  • outset
borderColor 设置边框的颜色。
  • color-name
  • color-rgb
  • color-hex
  • transparent

实例

下面的例子设置下边框：

<html>
<head>
<style type="text/css">
p {border: thin dotted #FF0000}
</style>
<script type="text/javascript">
function changeBorder()
{
document.getElementById("p1").style.borderBottom="thick solid blue";
}
</script>
</head>
<body>

<input type="button" onclick="changeBorder()"
value="Change bottom paragraph border" />
<p id="p1">This is a paragraph with a border</p>

</body>
</html>

TIY

borderBottom - 改变元素的下边框

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM borderBottomColor 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM borderBottomColor 属性

返回HTML DOM Style 对象参考手册

定义和用法

borderBottomColor 属性设置元素的下边框的颜色。

语法：

Object.style.borderBottomColor=color-name|color-rgb|color-hex

实例

本例改变下边框的颜色：

<html>
<head>
<style type="text/css">
p {border: thick solid #FF0000}
</style>
<script type="text/javascript">
function changeBorderColor()
{
document.getElementById("p1").style.borderBottomColor="blue";
}
</script>
</head>
<body>

<input type="button" onclick="changeBorderColor()"
value="Change border color" />
<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

borderBottomColor - 改变下边框的颜色

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM borderBottomStyle 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM borderBottomStyle 属性

返回HTML DOM Style 对象参考手册

定义和用法

borderBottomStyle 属性设置下边框的样式。

语法：

Object.style.borderBottomStyle=style
值 | 描述
none | 定义无边框。
hidden | 与 "none" 相同。不过应用于表时除外，对于表，hidden 用于解决边框冲突。
dotted | 定义点状边框。在大多数浏览器中呈现为实线。
dashed | 定义虚线。在大多数浏览器中呈现为实线。
solid | 定义实线。
double | 定义双线。双线的宽度等于 border-width 的值。
groove | 定义 3D 凹槽边框。其效果取决于 border-color 的值。
ridge | 定义 3D 垄状边框。其效果取决于 border-color 的值。
inset | 定义 3D inset 边框。其效果取决于 border-color 的值。
outset | 定义 3D outset 边框。其效果取决于 border-color 的值。

实例

本例改变下边框的样式：

<html>
<head>
<style type="text/css">
p
{
border: thick solid #FF0000
}
</style>
<script type="text/javascript">
function changeBorder()
{
document.getElementById("p1").style.borderBottomStyle="dotted";
}
</script>
</head>
<body>

<input type="button" onclick="changeBorder()"
value="Change bottom border" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

borderBottomStyle - 改变下边框的样式

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM borderBottomWidth 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM borderBottomWidth 属性

返回HTML DOM Style 对象参考手册

定义和用法

borderBottomWidth 属性设置下边框的宽度。

语法：

Object.style.borderBottomWidth=thin|medium|thick|length
值 | 描述
thin | 定义细的下边框。
medium | 默认。定义中等的下边框。
thick | 定义粗的下边框。
length | 允许您自定义下边框的宽度。

实例

本例改变下边框的宽度：

<html>
<head>
<style type="text/css">
p
{
border: thin solid #FF0000
}
</style>
<script type="text/javascript">
function changeBorderWidth()
{
document.getElementById("p1").style.borderBottomWidth="thick";
}
</script>
</head>
<body>

<input type="button" onclick="changeBorderWidth()"
value="Change bottom border" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

borderBottomWidth - 改变下边框的宽度

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM borderCollapse 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM borderCollapse 属性

返回HTML DOM Style 对象参考手册

定义和用法

borderCollapse 属性设置表格的边框是否被合并为一个单一的边框，还是象在标准的 HTML 中那样分开显示。

语法：

Object.style.borderCollapse=collapse|separate

可能的值

值 | 描述
separate | 边框会被分开。
collapse | 默认。如果可能，边框会被合并为一个单一的边框。

实例

下面的例子合并表格边框：

<html>
<head>
<script type="text/javascript">
function setBorderCollapse()
{
document.getElementById('myTable').style.borderCollapse="collapse"
}
</script>
</head>
<body>

<table border="1" id="myTable">
  <tr>
    <td>100</td>
    <td>200</td>
  </tr>
  <tr>
    <td>300</td>
    <td>400</td>
  </tr>
</table>
<br />
<input type="button" onclick="setBorderCollapse()"
value="Collapse border">

</body>
</html>

TIY

borderCollapse - 把表格边框合并为单一边框

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM borderColor 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM borderColor 属性

返回HTML DOM Style 对象参考手册

定义和用法

borderColor 属性设置元素周围边框的颜色。

本属性可使用 1 到 4 种颜色：

  • 如果规定一种颜色，比如 table {border-color: red} - 所有的边框都是红色。
  • 如果规定了两种颜色，比如 table {border-color: red green} - 上边框和下边框是红色，而左边框和右边框是绿色。
  • 如果规定了三种颜色，比如 table {border-color: red green blue}- 上边框是红色，左边框和右边框是绿色，下边框是蓝色。
  • 如果规定了四种颜色，比如 table {border-color: red green blue yellow} - 上边框是红色，右边框是绿色，下边框是蓝色，左边框是黄色。

语法：

Object.style.borderColor=color-name|color-rgb|color-hex|transparent

实例

本例改变边框的颜色：

<html>
<head>
<style type="text/css">
p
{
border: thick solid #FF0000
}
</style>
<script type="text/javascript">
function changeBorderColor()
{
document.getElementById("p1").style.borderColor="#0000FF #00FF00";
}
</script>
</head>
<body>

<input type="button" onclick="changeBorderColor()"
value="Change border color" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

borderColor - 改变边框的颜色

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM borderLeft 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM borderLeft 属性

返回HTML DOM Style 对象参考手册

定义和用法

borderLeft 属性在一个声明中为左边框设置所有属性。

语法：

Object.style.borderLeft=borderWidth borderStyle borderColor

可能的值：

值 描述 值
borderWidth 设置边框的宽度。
  • thin
  • medium
  • thick
  • length
borderStyle 设置边框的样式。
  • none
  • hidden
  • dotted
  • dashed
  • solid
  • double
  • groove
  • ridge
  • inset
  • outset
borderColor 设置边框的颜色。
  • color-name
  • color-rgb
  • color-hex
  • transparent

实例

本例改变左边框的宽度、样式和颜色：

<html>
<head>
<style type="text/css">
p
{
border: thin dotted #FF0000
}
</style>
<script type="text/javascript">
function changeBorder()
{
document.getElementById("p1").style.borderLeft="thick solid #0000FF";
}
</script>
</head>
<body>

<input type="button" onclick="changeBorder()"
value="Change left border" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

borderLeft - 改变左边框的宽度、样式和颜色

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM borderLeftColor 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM borderLeftColor 属性

返回HTML DOM Style 对象参考手册

定义和用法

borderLeftColor 属性设置元素的左边框的颜色。

语法：

Object.style.borderLeftColor=color-name|color-rgb|color-hex|transparent

实例

本例改变左边框的颜色：

<html>
<head>
<style type="text/css">
p
{
border: thick solid #FF0000
}
</style>
<script type="text/javascript">
function changeBorderColor()
{
document.getElementById("p1").style.borderLeftColor="#0000FF";
}
</script>
</head>
<body>

<input type="button" onclick="changeBorderColor()"
value="Change left border" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

borderleftColor - 改变左边框的颜色

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM borderLeftStyle 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM borderLeftStyle 属性

返回HTML DOM Style 对象参考手册

定义和用法

borderLeftStyle 属性设置左边框的样式。

语法：

Object.style.borderLeftStyle=style

可能的值：

值 | 描述
none | 定义无边框。
hidden | 与 "none" 相同。不过应用于表时除外，对于表，hidden 用于解决边框冲突。
dotted | 定义点状边框。在大多数浏览器中呈现为实线。
dashed | 定义虚线。在大多数浏览器中呈现为实线。
solid | 定义实线。
double | 定义双线。双线的宽度等于 border-width 的值。
groove | 定义 3D 凹槽边框。其效果取决于 border-color 的值。
ridge | 定义 3D 垄状边框。其效果取决于 border-color 的值。
inset | 定义 3D inset 边框。其效果取决于 border-color 的值。
outset | 定义 3D outset 边框。其效果取决于 border-color 的值。

实例

本例设置左边框的样式：

<html>
<head>
<style type="text/css">
p
{
border: thick solid #FF0000;
}
</style>
<script type="text/javascript">
function changeBorder()
{
document.getElementById("p1").style.borderLeftStyle="dotted";
}
</script>
</head>
<body>

<input type="button" onclick="changeBorder()"
value="Change left border" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

borderLeftStyle - 改变左边框的样式

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM borderLeftWidth 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM borderLeftWidth 属性

返回HTML DOM Style 对象参考手册

定义和用法

borderLeftWidth 属性设置左边框的宽度。

语法：

Object.style.borderLeftWidth=thin|medium|thick|length

可能的值：

值 | 描述
thin | 定义细的下边框。
medium | 默认。定义中等的下边框。
thick | 定义粗的下边框。
length | 允许您自定义下边框的宽度。

实例

本例改变左边框的宽度：

<html>
<head>
<style type="text/css">
p
{
border: thin solid #FF0000;
}
</style>
<script type="text/javascript">
function changeBorderWidth()
{
document.getElementById("p1").style.borderLeftWidth="thick";
}
</script>
</head>
<body>

<input type="button" onclick="changeBorderWidth()"
value="Change left border" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

borderLeftWidth - 改变左边框的宽度

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM borderRight 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM borderRight 属性

返回HTML DOM Style 对象参考手册

定义和用法

borderRight 属性在一个声明中为右边框设置所有属性。

语法：

Object.style.borderRight=borderWidth borderStyle borderColor

可能的值：

值 描述 值
borderWidth 设置边框的宽度。
  • thin
  • medium
  • thick
  • length
borderStyle 设置边框的样式。
  • none
  • hidden
  • dotted
  • dashed
  • solid
  • double
  • groove
  • ridge
  • inset
  • outset
borderColor 设置边框的颜色。
  • color-name
  • color-rgb
  • color-hex
  • transparent

实例

本例改变右边框的宽度、样式和颜色：

<html>
<head>
<style type="text/css">
p
{
border: thin dotted #FF0000
}
</style>
<script type="text/javascript">
function changeBorder()
{
document.getElementById("p1").style.borderRight="thick solid #0000FF";
}
</script>
</head>
<body>

<input type="button" onclick="changeBorder()"
value="Change right border" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

borderRight - 改变右边框的宽度、样式和颜色

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM borderRightColor 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM borderRightColor 属性

返回HTML DOM Style 对象参考手册

定义和用法

borderRightColor 属性设置右边框的颜色。

语法：

Object.style.borderRightColor=color-name|color-rgb|color-hex|transparent

实例

本例改变右边框的颜色：

<html>
<head>
<style type="text/css">
p
{
border: thick solid #FF0000;
}
</style>
<script type="text/javascript">
function changeBorderColor()
{
document.getElementById("p1").style.borderRightColor="#0000FF";
}
</script>
</head>
<body>

<input type="button" onclick="changeBorderColor()"
value="Change right border" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

borderRightColor - 改变右边框的颜色

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM borderRightStyle 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM borderRightStyle 属性

返回HTML DOM Style 对象参考手册

定义和用法

borderRightStyle 属性设置右边框的样式。

语法：

Object.style.borderRightStyle=style

可能的值：

值 | 描述
none | 定义无边框。
hidden | 与 "none" 相同。不过应用于表时除外，对于表，hidden 用于解决边框冲突。
dotted | 定义点状边框。在大多数浏览器中呈现为实线。
dashed | 定义虚线。在大多数浏览器中呈现为实线。
solid | 定义实线。
double | 定义双线。双线的宽度等于 border-width 的值。
groove | 定义 3D 凹槽边框。其效果取决于 border-color 的值。
ridge | 定义 3D 垄状边框。其效果取决于 border-color 的值。
inset | 定义 3D inset 边框。其效果取决于 border-color 的值。
outset | 定义 3D outset 边框。其效果取决于 border-color 的值。

实例

本例改变右边框的样式：

<html>
<head>
<style type="text/css">
p
{
border: thick solid #FF0000;
}
</style>
<script type="text/javascript">
function changeBorder()
{
document.getElementById("p1").style.borderRightStyle="dotted";
}
</script>
</head>
<body>

<input type="button" onclick="changeBorder()"
value="Change right border" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

borderRightStyle - 改变右边框的样式

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM borderRightWidth 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM borderRightWidth 属性

返回HTML DOM Style 对象参考手册

定义和用法

borderRightWidth 属性设置元素的右边框的宽度。

语法：

Object.style.borderRightWidth=thin|medium|thick|length

Possible Values

值 | 描述
thin | 定义细的下边框。
medium | 默认。定义中等的下边框。
thick | 定义粗的下边框。
length | 允许您自定义下边框的宽度。

实例

本例改变右边框的宽度：

<html>
<head>
<style type="text/css">
p
{
border: thin solid #FF0000
}
</style>
<script type="text/javascript">
function changeBorderWidth()
{
document.getElementById("p1").style.borderRightWidth="thick";
}
</script>
</head>
<body>

<input type="button" onclick="changeBorderWidth()"
value="Change right border width" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

borderRightWidth - 改变右边框的宽度

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM borderSpacing 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM borderSpacing 属性

返回HTML DOM Style 对象参考手册

定义和用法

borderSpacing 属性相邻单元格的边框之间的距离（仅用于"边框分离"模式）。

语法：

Object.style.borderSpacing=length,length

可能的值

值 | 描述
length length | 使用 px、cm 等单位定义距离。如果定义一个 length 参数，那么定义的是水平和垂直间距。如果定义了两个 length 参数，那么第一个设置水平间距，而第二个设置垂直间距。length 不能为负值。

实例

本例设置相邻单元格的边框之间的距离：

<html>
<head>
<script type="text/javascript">
function changeBorderSpacing()
{
document.getElementById('myTable').style.borderSpacing="10px"
}
</script>
</head>
<body>

<table border="1" id="myTable">
  <tr>
    <td>100</td>
    <td>200</td>
  </tr>
  <tr>
    <td>300</td>
    <td>400</td>
  </tr>
</table>

<input type="button" onclick="changeBorderSpacing()"
value="Change border spacing">

</body>
</html>

TIY

borderSpacing - 改变相邻单元格的边框之间的距离（请在非 IE 浏览器中查看）

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM borderStyle 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM borderStyle 属性

返回HTML DOM Style 对象参考手册

定义和用法

borderStyle 属性在一行声明中为所有四个设置或返回边框样式。

该属性可使用 1 到 4 种样式。

语法：

Object.style.borderStyle=style

可能的值：

值 | 描述
none | 定义无边框。
hidden | 与 "none" 相同。不过应用于表时除外，对于表，hidden 用于解决边框冲突。
dotted | 定义点状边框。在大多数浏览器中呈现为实线。
dashed | 定义虚线。在大多数浏览器中呈现为实线。
solid | 定义实线。
double | 定义双线。双线的宽度等于 border-width 的值。
groove | 定义 3D 凹槽边框。其效果取决于 border-color 的值。
ridge | 定义 3D 垄状边框。其效果取决于 border-color 的值。
inset | 定义 3D inset 边框。其效果取决于 border-color 的值。
outset | 定义 3D outset 边框。其效果取决于 border-color 的值。

实例

本例改变边框的样式：

<html>
<head>
<style>
p
{
border: thick solid #FF0000
}
</style>

<script type="text/javascript">
function changeBorder()
{
document.getElementById("p1").style.borderStyle="dotted double";
}
</script>

</head>
<body>

<form>
<input type="button" onclick="changeBorder()"
value="Change paragraph border style" />
</form>

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

改变边框的样式

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM borderTop 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM borderTop 属性

返回HTML DOM Style 对象参考手册

定义和用法

borderTop 属性在一行声明中为上边框设置所有的属性。

语法：

Object.style.borderTop=borderWidth borderStyle borderColor

可能的值：

值 描述 值
borderWidth 设置边框的宽度。
  • thin
  • medium
  • thick
  • length
borderStyle 设置边框的样式。
  • none
  • hidden
  • dotted
  • dashed
  • solid
  • double
  • groove
  • ridge
  • inset
  • outset
borderColor 设置边框的颜色。
  • color-name
  • color-rgb
  • color-hex
  • transparent

实例

本例改变上边框的宽度、样式和颜色：

<html>
<head>
<style type="text/css">
p
{
border: thin dotted #FF0000
}
</style>
<script type="text/javascript">
function changeBorder()
{
document.getElementById("p1").style.borderTop="thick solid #0000FF";
}
</script>
</head>
<body>

<input type="button" onclick="changeBorder()"
value="Change top border" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

borderTop - 改变上边框的宽度、样式和颜色

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM borderTopColor 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM borderTopColor 属性

返回HTML DOM Style 对象参考手册

定义和用法

borderTopColor 属性设置元素上边框的颜色。

语法：

Object.style.borderTopColor=color-name|color-RGB|color-hex

实例

本例改变段落的上边框的颜色：

<html>
<head>
<style type="text/css">
p
{
border: thick solid #FF0000
}
</style>
<script type="text/javascript">
function changeBorderColor()
{
document.getElementById("p1").style.borderTopColor="#0000FF";
}
</script>
</head>
<body>

<input type="button" onclick="changeBorderColor()"
value="Change paragraph border color" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

borderTopColor - 改变段落的上边框的颜色

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM borderTopStyle 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM borderTopStyle 属性

返回HTML DOM Style 对象参考手册

定义和用法

borderTopStyle 属性设置元素的上边框的样式。

语法：

Object.style.borderTopStyle=style

可能的值：

值 | 描述
none | 定义无边框。
hidden | 与 "none" 相同。不过应用于表时除外，对于表，hidden 用于解决边框冲突。
dotted | 定义点状边框。在大多数浏览器中呈现为实线。
dashed | 定义虚线。在大多数浏览器中呈现为实线。
solid | 定义实线。
double | 定义双线。双线的宽度等于 border-width 的值。
groove | 定义 3D 凹槽边框。其效果取决于 border-color 的值。
ridge | 定义 3D 垄状边框。其效果取决于 border-color 的值。
inset | 定义 3D inset 边框。其效果取决于 border-color 的值。
outset | 定义 3D outset 边框。其效果取决于 border-color 的值。

实例

本例更改段落的上边框的样式：

<html>
<head>
<style type="text/css">
p
{
border: thick solid #FF0000
}
</style>
<script type="text/javascript">
function changeBorder()
{
document.getElementById("p1").style.borderTopStyle="dotted";
}
</script>
</head>
<body>

<input type="button" onclick="changeBorder()"
value="Change border style" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

borderTopStyle - 改变上边框的样式

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM borderTopWidth 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM borderTopWidth 属性

返回HTML DOM Style 对象参考手册

定义和用法

borderTopWidth 属性设置元素的上边框的宽度。

语法：

Object.style.borderTopWidth=thin|medium|thick|length

可能的值：

值 | 描述
thin | 定义细的下边框。
medium | 默认。定义中等的下边框。
thick | 定义粗的下边框。
length | 允许您自定义下边框的宽度。

实例

下面的例子改变了上边框的宽度：

<html>
<head>
<style type="text/css">
p
{
border: thin solid #FF0000
}
</style>
<script type="text/javascript">
function changeBorderWidth()
{
document.getElementById("p1").style.borderTopWidth="thick";
}
</script>
</head>
<body>

<input type="button" onclick="changeBorderWidth()"
value="Change border width" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

borderTopWidth - 改变上边框的宽度

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM borderWidth 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM borderWidth 属性

返回HTML DOM Style 对象参考手册

定义和用法

borderWidth 属性设置所有四个边框的宽度。

该属性可使用 1 到 4 个值：

  • 如果规定一个值，比如 div {border-width: thick} - 所有四个边框都是粗线。
  • 如果规定两个值，比如 div {border-width: thick thin} - 上下边框是粗线，而左右边框是细线。
  • 如果规定三个值，比如 div {border-width: thick thin medium}- 上边框是粗线，左右边框是细线，下边框是中等 (medium) 的宽度。
  • 如果规定四个值，比如 div {border-width: thick thin medium 10px} - 上边框是粗线，右边框是细线，下边框是中等的宽度，而左边框是 10px 的宽度。

语法：

Object.style.borderWidth=thin|medium|thick|length

可能的值：

值 | 描述
thin | 定义细的下边框。
medium | 默认。定义中等的下边框。
thick | 定义粗的下边框。
length | 允许您自定义下边框的宽度。

实例

本例改变边框的宽度：

<html>
<head>
<style type="text/css">
p
{
border: thin solid #FF0000
}
</style>
<script type="text/javascript">
function changeBorderWidth()
{
document.getElementById("p1").style.borderWidth="thick thin";
}
</script>
</head>
<body>

<input type="button" onclick="changeBorderWidth()"
value="Change border widths" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

borderWidth - 改变所有四个边框的宽度

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM bottom 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM bottom 属性

返回HTML DOM Style 对象参考手册

定义和用法

bottom 属性设置定位元素下外边距边界与其包含块下边界之间的偏移。

语法：

Object.style.bottom=auto|%|length

可能的值

值 | 描述
auto | 默认。通过浏览器计算底部的位置。
% | 设置元素的底边到最近一个具有定位设置父元素的底部边缘的百分比位置。
length | 使用 px、cm 等单位设置元素的底边到最近一个具有定位设置父元素的底部边缘的位置。可使用负值。

提示和注释

Note:如果 "position" 属性的值为 "static"，那么设置 "bottom" 属性不会产生任何效果。

实例

本例对元素的下边进行设置：

<html>
<head>
<style type="text/css">
input
{
position:absolute;
}
</style>
<script type="text/javascript">
function setBottomEdge()
{
document.getElementById("b1").style.bottom="100px";
}
</script>
</head>
<body>

<input type="button" id="b1" onclick="setBottomEdge()"
value="Set bottom edge to 100 px" />

</body>
</html>

TIY

bottom - 对元素的下边进行设置

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM browserLanguage 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM browserLanguage 属性

返回 HTML DOM Navigator 对象参考手册

定义和用法

browserLanguage 属性可返回当前浏览器的语言。

语法

navigator.browserLanguage

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>BrowserLanguage: ")
document.write(navigator.browserLanguage + "</p>")
</script>
</body>

</html>

TIY

检测访问者的浏览器和版本号
有关访问者的浏览器的更多信息
有关访问者的浏览器的全部细节
根据浏览器来提醒用户

返回 HTML DOM Navigator 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM bufferDepth 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM bufferDepth 属性

返回 HTML DOM Screen 对象参考手册

定义和用法

bufferDepth 属性设置或返回在 off-screen bitmap buffer 中调色板的比特深度。

语法

screen.bufferDepth=number

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>Buffer Depth: ")
document.write(screen.bufferDepth + "</p>")
</script>
</body>

</html>

TIY

检测有关客户机的屏幕的细节

返回 HTML DOM Screen 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Button 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Button 对象

Button 对象

Button 对象代表一个按钮。

在 HTML 文档中 <button> 标签每出现一次，Button 对象就会被创建。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet 标准).

Button 对象的属性

属性 | 描述 | IE | F | O | W3C
accessKey | 设置或返回访问某个按钮的快捷键。 | 6 | 1 | 9 | Yes
disabled | 设置或返回是否禁用按钮。 | 6 | 1 | 9 | Yes
form | 返回对包含按钮的表单的引用。 | 6 | 1 | 9 | Yes
id | 设置或返回按钮的 id。 | 6 | 1 | 9 | Yes
name | 设置或返回按钮的名称。 | 6 | 1 | 9 | Yes
tabIndex | 设置或返回按钮的 Tab 键控制次序。 | 6 | 1 | 9 | Yes
type | 返回按钮的表单类型。 | 6 | 1 | 9 | Yes
value | 设置或返回显示在按钮上的文本。 | 6 | 1 | 9 | Yes

标准属性

Property | Description | IE | F | O | W3C
className | Sets or returns the class attribute of an element | 5 | 1 | 9 | Yes
dir | Sets or returns the direction of text | 5 | 1 | 9 | Yes
lang | Sets or returns the language code for an element | 5 | 1 | 9 | Yes
title | Sets or returns an element's advisory title | 5 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Button 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Button 对象

Button 对象

Button 对象代表 HTML 文档中的一个按钮。

该元素没有默认的行为，但是必须有一个 onclick 事件句柄以便使用。

在 HTML 文档中 <input type="button"> 标签每出现一次，一个 Button 对象 就会被创建。

您可以通过遍历表单的 elements[] 数组来访问某个按钮，或者通过使用 document.getElementById()。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet 标准).

Button 对象的属性

属性 | 描述 | IE | F | O | W3C
accessKey | 设置或返回访问按钮的快捷键。 | 5 | 1 | 9 | Yes
alt | 设置或返回当浏览器无法显示按钮时供显示的替代文本。 | 5 | 1 | 9 | Yes
disabled | 设置或返回是否禁用按钮。 | 5 | 1 | 9 | Yes
form | 返回对包含该按钮的表单对象的引用。 | 4 | 1 | 9 | Yes
id | 设置或返回按钮的 id。 | 4 | 1 | 9 | Yes
name | 设置或返回按钮的名称。 | 4 | 1 | 9 | Yes
tabIndex | 设置或返回按钮的 tab 键控制次序。 | 5 | 1 | 9 | Yes
type | 返回按钮的表单元素类型。 | 4 | 1 | 9 | Yes
value | 设置或返回在按钮上显示的文本。 | 4 | 1 | 9 | Yes

Standard Properties

属性 | 描述 | IE | F | O | W3C
className | Sets or returns the class attribute of an element | 5 | 1 | 9 | Yes
dir | Sets or returns the direction of text | 5 | 1 | 9 | Yes
lang | Sets or returns the language code for an element | 5 | 1 | 9 | Yes
title | Sets or returns an element's advisory title | 5 | 1 | 9 | Yes

Button 对象的方法

方法 | 描述 | IE | F | O | W3C
blur() | 把焦点从元素上移开。 | 4 | 1 | 9 | Yes
click() | 在某个按钮上模拟一次鼠标单击。 | 4 | 1 | 9 | Yes
focus() | 为某个按钮赋予焦点。 | 4 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Canvas 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Canvas 对象

Canvas 对象

Canvas 对象表示一个 HTML 画布元素 - <canvas>。它没有自己的行为，但是定义了一个 API 支持脚本化客户端绘图操作。

你可以直接在该对象上指定宽度和高度，但是，其大多数功能都可以通过 CanvasRenderingContext2D 对象获得。 这是通过 Canvas 对象的 getContext() 方法并且把直接量字符串 "2d" 作为唯一的参数传递给它而获得的。

<canvas> 标记在 Safari 1.3 中引入，在制作此参考页时，它在 Firefox 1.5 和 Opera 9 中也得到了支持。在 IE 中，<canvas> 标记及其 API 可以使用位于 excanvas.sourceforge.net 的 ExplorerCanvas 开源项目来模拟。

提示：如果希望学习如何使用 <canvas> 来绘制图形，可以访问 Mozilla 提供的 Canvas 教程（英文）。

Canvas 对象的属性

height 属性

画布的高度。和一幅图像一样，这个属性可以指定为一个整数像素值或者是窗口高度的百分比。当这个值改变的时候，在该画布上已经完成的任何绘图都会擦除掉。默认值是 300。

width 属性

画布的宽度。和一幅图像一样，这个属性可以指定为一个整数像素值或者是窗口宽度的百分比。当这个值改变的时候，在该画布上已经完成的任何绘图都会擦除掉。默认值是 300。

Canvas 对象的方法

方法 | 描述
getContext() | 返回一个用于在画布上绘图的环境。

参阅

HTML 5 <canvas> 标签

HTML DOM 参考手册
HTML DOM 实例


HTML DOM caption 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM caption 属性

返回 HTML DOM Table 对象参考手册

定义和用法

caption 属性设置或返回表格的 caption 元素。

<caption> 元素定义了一个表格标题。<caption> 标签必须紧跟在 <table> 标签之后，每个表格仅能规定一个 caption。通常，caption 会位于表格之上居中的位置。

语法

tableObject.caption=captionObject

实例

下面的例子可返回表格的 <caption> 元素的文本：

<html>
<head>
<script type="text/javascript">
function alertCaption()
  {
  alert(document.getElementById("table1").caption.innerHTML);
  }
</script>
</head>
<body>

<table id="table1" border="1">
<caption>This is a table caption</caption>
<tr>
<th>Firstname</th>
<th>Lastname</th>
</tr>
<tr>
<td>Peter</td>
<td>Griffin</td>
</tr>
</table>
<br />
<input type="button" onclick=alertCaption()
value="Alert table caption" />

</body>
</html>

TIY

取得表格的 <caption> 元素的文本

返回 HTML DOM Table 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM captionSide 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM captionSide 属性

返回HTML DOM Style 对象参考手册

定义和用法

captionSide 属性设置表格标题的位置。

语法：

Object.style.captionSide=top|bottom|left|right

可能的值

值 | 描述
top | 默认。把表格标题定位在表格之上。
bottom | 把表格标题定位在表格之下。
left | 把表格标题定位在表格的左边。
right | 把表格标题定位在表格的右边。

实例

本例移动表格标题：

<html>
<head>
<style type="text/css">
caption
{
caption-side:bottom;
}
</style>
<script type="text/javascript">
function moveCaption()
{
document.getElementById('myTable').style.captionSide="right"
}
</script>
</head>
<body>

<table border="1" id="myTable">
  <caption>This is a caption</caption>
  <tr>
    <td>100</td>
    <td>200</td>
  </tr>
  <tr>
    <td>300</td>
    <td>400</td>
  </tr>
</table>
<br />
<input type="button" onclick="moveCaption()"
value="Move table caption">

</body>
</html>

TIY

captionSide - 对表格标题进行定位（请在非 IE 浏览器中查看）

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM cellIndex 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM cellIndex 属性

返回 HTML DOM TableCell 对象参考手册

定义和用法

cellIndex 属性可返回一行的单元格集合中单元格的位置。

语法

tabledataObject.cellIndex

实例

下面的例子可返回两个单元格的位置（cell index）：

<html>
<head>
<script type="text/javascript">
function alertTd1()
  {
  alert(document.getElementById('td1').cellIndex);
  }
function alertTd2()
  {
  alert(document.getElementById('td2').cellIndex);
  }
</script>
</head>
<body>

<table border="1">
<tr>
<th>Firstname</th>
<th>Lastname</th>
</tr>
<tr>
<td id="td1">Peter</td>
<td id="td2">Griffin</td>
</tr>
</table>
<br />
<input type="button" onclick="alertTd1()"
value="Alert cell index of 'Peter'" />
<br />
<input type="button" onclick="alertTd2()"
value="Alert cell index of 'Griffin'" />

</body>
</html>

TIY

取得单元格的 cell index

返回 HTML DOM TableCell 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM cellPadding 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM cellPadding 属性

返回 HTML DOM Table 对象参考手册

定义和用法

cellPadding 属性可设置或返回单元格边框与单元格内容之间的空白量（以像素为单位）。

语法

tableObject.cellPadding=pixels

实例

The following example changes the cell padding of a table:

<html>
<head>
<script type="text/javascript">
function padding()
  {
  document.getElementById('myTable').cellPadding="15"
  }
</script>
</head>
<body>

<table id="myTable" border="1">
<tr>
<td>100</td>
<td>200</td>
</tr>
<tr>
<td>300</td>
<td>400</td>
</tr>
</table>
<br />
<input type="button" onclick="padding()" value="Change Cellpadding">

</body>
</html>

TIY

更改表格的 cellPadding 和 cellSpacing

返回 HTML DOM Table 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM cells 集合

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM cells 集合

返回 HTML DOM Table 对象参考手册

定义和用法

cells 集合返回表格中所有单元格的一个数组。

语法

tableObject.cells[]

实例

下面的例子使用 cells 来显示出第一个单元格的内容：

<html>
<head>
<script type="text/javascript">
function cell()
  {
  var x=document.getElementById('myTable').rows[0].cells;
  alert(x[0].innerHTML);
  }
</script>
</head>
<body>

<table id="myTable" border="1">
<tr>
<td>cell 1</td>
<td>cell 2</td>
</tr>
<tr>
<td>cell 3</td>
<td>cell 4</td>
</tr>
</table>
<br />
<input type="button" onclick="cell()" value="Alert first cell">

</body>
</html>

TIY

使用 cells[] 集合

返回 HTML DOM Table 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM cellSpacing 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM cellSpacing 属性

返回 HTML DOM Table 对象参考手册

定义和用法

cellSpacing 属性可设置或返回在表格中的单元格之间的空白量（以像素为单位）。

语法

tableObject.cellSpacing=pixels

实例

下面的例子更改了表格的 cellSpacing：

<html>
<head>
<script type="text/javascript">
function spacing()
  {
  document.getElementById('myTable').cellSpacing="15"
  }
</script>
</head>
<body>

<table id="myTable" border="1">
<tr>
<td>100</td>
<td>200</td>
</tr>
<tr>
<td>300</td>
<td>400</td>
</tr>
</table>
<br />
<input type="button" onclick="spacing()" value="Change Cellspacing">

</body>
</html>

TIY

更改表格的 cellPadding 和 cellSpacing

返回 HTML DOM Table 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM charset 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM charset 方法

返回 HTML DOM Link 对象参考手册

定义和用法

The charset property sets or returns the character encoding of the target URL.

语法

linkObject.charset=character-encoding

实例

The following example sets the character encoding of the target URL:

<html>
<head>
<link rel="stylesheet" type="text/css" id="style1"
href="try_dom_link.css" />
</head>
<body>

<script type="text/javascript">
x=document.getElementById("style1");
x.charset="ISO-8859-1";
document.write("Charset=" + x.charset);
</script>

</body>
</html>

TIY

Set the character encoding of a <link> element

返回 HTML DOM Link 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM charset 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM charset 属性

返回 HTML DOM Anchor 对象参考手册

定义和用法

charset 属性可设置或返回被链接资源的字符集。

语法

anchorObject.charset=charset

实例

下面的例子可设置被链资源的字符串：

<html>
<body>

<p>
<a id="myAnchor"
href="http://www.w3school.com.cn">W3School.com.cn</a>
</p>

<script type="text/javascript">
x=document.getElementById("myAnchor");
x.charset="ISO-8859-1";
</script>

</body>
</html>

TIY

设置被链资源的字符串

返回 HTML DOM Anchor 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Checkbox 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Checkbox 对象

Checkbox 对象

Checkbox 对象代表一个 HTML 表单中的 一个选择框。

在 HTML 文档中 <input type="checkbox"> 每出现一次，Checkbox 对象就会被创建。

您可以通过遍历表单的 elements[] 数组来访问某个选择框，或者通过使用 document.getElementById() 。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet 标准).

Checkbox 对象的属性

属性 | 描述 | IE | F | O | W3C
accessKey | 设置或返回访问 checkbox 的快捷键。 | 4 | 1 | 9 | Yes
alt | 设置或返回当浏览器不支持 checkbox 时供显示的替代文本。 | 5 | 1 | 9 | Yes
checked | 设置或返回 checkbox 是否应被选中。 | 4 | 1 | 9 | Yes
defaultChecked | 返回 checked 属性的默认值。 | 4 | 1 | 9 | Yes
disabled | 设置或返回 checkbox 是否应被禁用。 | 4 | 1 | 9 | Yes
form | 返回对包含 checkbox 的表单的引用。 | 4 | 1 | 9 | Yes
id | 设置或返回 checkbox 的 id。 | 4 | 1 | 9 | Yes
name | 设置或返回 checkbox 的名称。 | 4 | 1 | 9 | Yes
tabIndex | 设置或返回 checkbox 的 tab 键控制次序。 | 4 | 1 | 9 | Yes
type | 返回 checkbox 的表单元素类型。 | 4 | 1 | 9 | Yes
value | 设置或返回 checkbox 的 value 属性的值 | 4 | 1 | 9 | Yes

Standard Properties

Property | Description | IE | F | O | W3C
className | Sets or returns the class attribute of an element | 5 | 1 | 9 | Yes
dir | Sets or returns the direction of text | 5 | 1 | 9 | Yes
lang | Sets or returns the language code for an element | 5 | 1 | 9 | Yes
title | Sets or returns an element's advisory title | 5 | 1 | 9 | Yes

Checkbox 对象的方法

方法 | 描述 | IE | F | O | W3C
blur() | 从 checkbox 上移开焦点。 | 4 | 1 | 9 | Yes
click() | 模拟在 checkbox 中的一次鼠标点击。 | 4 | 1 | 9 | Yes
focus() | 为 checkbox 赋予焦点。 | 4 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM checked 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM checked 属性

返回 HTML DOM Checkbox 对象参考手册

定义和用法

checked 属性设置或返回 checkbox 是否应被选中。

语法

checkboxObject.checked=true|false

说明

该属性保存了 checkbox 的当前状态，不管何时，这个值发生变化的时候，onclick 事件句柄就会触发（也可能触发 onchange 事件句柄）。

实例

下面的例子可设置该 checkbox 的状态：

<html>
<head>
<script type="text/javascript">
function check()
  {
  document.getElementById("check1").checked=true
  }
function uncheck()
  {
  document.getElementById("check1").checked=false
  }
</script>
</head>
<body>

<form>
<input type="checkbox" id="check1" />
<input type="button" onclick="check()" value="Check Checkbox" />
<input type="button" onclick="uncheck()" value="Uncheck Checkbox" />
</form>

</body>
</html>

TIY

选定以及不选定 checkbox
一个表单中的若干个 checkbox
Checkbox - 把文本转换为大写

返回 HTML DOM Checkbox 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Checked 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Checked 属性

返回 HTML DOM Radio 对象参考手册

定义和用法

checked 属性可设置或返回某个单选按钮是否被选中。

语法

radioObject.checked=true|false

实例

下面的例子可对一个单选按钮进行选定和不选定：

<html>
<head>
<script type="text/javascript">
function check()
  {
  document.getElementById("radio1").checked=true
  }
function uncheck()
  {
  document.getElementById("radio1").checked=false
  }
</script>
</head>
<body>

<form>
<input type="radio" id="radio1" />
<input type="button" onclick="check()" value="Check" />
<input type="button" onclick="uncheck()" value="Uncheck" />
</form>

</body>
</html>

TIY

选定及不选定单选按钮

返回 HTML DOM Radio 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM className 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM className 属性

返回 HTML DOM Anchor 对象参考手册

定义和用法

className 属性设置或返回元素的 class 属性。

语法

object.className=classname

实例

本例展示了两种获得 <body> 元素的 class 属性的方法：

<html>
<body id="myid" class="mystyle">

<script type="text/javascript">
x=document.getElementsByTagName('body')[0];
document.write("Body CSS class: " + x.className);
document.write("<br />");
document.write("An alternate way: ");
document.write(document.getElementById('myid').className);
</script>

</body>
</html>

输出：

Body CSS class: mystyle
An alternate way: mystyle

TIY

返回 <body> 元素的 class 属性

返回 HTML DOM Anchor 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM className 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM className 属性

返回 HTML DOM Body 对象参考手册

定义和用法

className 属性可设置或返回元素的 class 属性。

语法

bodyObject.className=classname

实例

下面的例子将展示两种获取 <body> 元素的 class 属性的方法：

<html>
<body id="myid" class="mystyle">

<script type="text/javascript">
x=document.getElementsByTagName('body')[0];
document.write("Body CSS class: " + x.className);
document.write("<br />");
document.write("An alternate way: ");
document.write(document.getElementById('myid').className);
</script>

</body>
</html>

输出：

Body CSS class: mystyle
An alternate way: mystyle

TIY

返回 <body> 元素的 class 属性

返回 HTML DOM Body 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM clear 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM clear 属性

返回HTML DOM Style 对象参考手册

定义和用法

clear 属性设置一个元素的侧面是否允许其他的浮动元素。

语法：

Object.style.clear=left|right|both|none

可能的值

值 | 描述
left | 在左侧不允许浮动元素
right | 在右侧不允许浮动元素
both | 在左右两侧均不允许浮动元素
none | 默认。允许浮动元素出现在两侧。

实例

本例不允许文本左边的浮动元素：

<html>
<head>
<style type="text/css">
img
{
float:left;
}
</style>
<script type="text/javascript">
function clearLeft()
{
document.getElementById("p1").style.clear="left";
}
</script>
</head>
<body>

<img src="logocss.gif" width="95" height="84" />

<p id="p1">This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.</p>

<input type="button" onclick="clearLeft()"
value="Clear left side of text" />

</body>
</html>

TIY

清除文本左边的浮动元素

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM clearInterval() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM clearInterval() 方法

返回 HTML DOM Window 对象参考手册

定义和用法

clearInterval() 方法可取消由 setInterval() 设置的 timeout。

clearInterval() 方法的参数必须是由 setInterval() 返回的 ID 值。

语法

clearInterval(id_of_setinterval)
参数 | 描述
id_of_setinterval | 由 setInterval() 返回的 ID 值。

实例

下面这个例子将每隔 50 毫秒调用 clock() 函数。您也可以使用一个按钮来停止这个 clock：

<html>
<body>

<input type="text" id="clock" size="35" />
<script language=javascript>
var int=self.setInterval("clock()",50)
function clock()
  {
  var t=new Date()
  document.getElementById("clock").value=t
  }
</script>
</form>
<button onclick="int=window.clearInterval(int)">
Stop interval</button>

</body>
</html>

TIY

使用 setInterval() 和 clearInterval()

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM clearTimeout() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM clearTimeout() 方法

返回 HTML DOM Window 对象参考手册

定义和用法

clearTimeout() 方法可取消由 setTimeout() 方法设置的 timeout。

语法

clearTimeout(id_of_settimeout)
参数 | 描述
id_of_setinterval | 由 setTimeout() 返回的 ID 值。该值标识要取消的延迟执行代码块。

实例

下面的例子每秒调用一次 timedCount() 函数。您也可以使用一个按钮来终止这个定时消息：

<html>
<head>
<script type="text/javascript">
var c=0
var t
function timedCount()
  {
  document.getElementById('txt').value=c
  c=c+1
  t=setTimeout("timedCount()",1000)
  }
function stopCount()
  {
  clearTimeout(t)
  }
</script>
</head>
<body>

<form>
<input type="button" value="Start count!" onClick="timedCount()">
<input type="text" id="txt">
<input type="button" value="Stop count!" onClick="stopCount()">
</form>

</body>
</html>

TIY

带有停止按钮的计时程序

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM click() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM click() 方法

返回 HTML DOM Button 对象参考手册

定义和用法

click() 方法可模拟在按钮上的一次鼠标单击。

语法

buttonObject.click()

实例

下面的例子将在 body onload 上模拟在按钮上的一次鼠标单击：

<html>
<head>
<script type="text/javascript">
function clickButton()
  {
  document.getElementById('button1').click()
  }
function alertMsg()
  {
  alert("Button 1 was clicked!")
  }
</script>
</head>
<body onload="clickButton()">

<form>
<input type="button" id="button1" onclick="alertMsg()"
value="Button 1" />
</form>

</body>
</html>

TIY

模拟在按钮上的一次鼠标单击

返回 HTML DOM Button 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM click() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM click() 方法

返回 HTML DOM Checkbox 对象参考手册

定义和用法

click() 方法用于在 checkbox 上模拟一次鼠标单击。

语法

checkboxObject.click()

实例

下面的例子可在 checkbox 上模拟一次鼠标点击：

<html>
<head>
<script type="text/javascript">
function clickCheckbox()
  {
  document.getElementById('check1').click()
  }
</script>
</head>
<body>

<form>
<input type="checkbox" id="check1" />
<br />
<input type="button" onclick="clickCheckbox()" value="Click checkbox" />
</form>

</body>
</html>

TIY

在 checkbox 上模拟一次鼠标点击

返回 HTML DOM Checkbox 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM click() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM click() 方法

返回 HTML DOM Radio 对象参考手册

定义和用法

click() 方法用于在单选按钮上模拟一次鼠标点击：

语法

radioObject.click()

实例

下面的例子可在单选按钮上模拟一次鼠标点击：

<html>
<head>
<script type="text/javascript">
function clickRadio()
  {
  document.getElementById('radio1').click()
  }
</script>
</head>
<body>

<form>
<input type="radio" id="radio1" />
<br />
<input type="button" onclick="clickRadio()"
value="Click radio button" />
</form>

</body>
</html>

TIY

在单选按钮上模拟一次鼠标点击

返回 HTML DOM Radio 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM clip 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM clip 属性

返回HTML DOM Style 对象参考手册

定义和用法

clip 属性设置元素的形状。

当图像大于它所在的元素时会发生什么？"clip" 属性允许你规定元素的可见尺寸，以及元素被裁剪和显示的形状。

语法：

Object.style.clip=rect(top,right,bottom,left)|auto

可能的值

值 | 描述
rect(top,right,bottom,left) | 设置元素的形状。
auto | 浏览器设置元素的形状。

提示和注释

注释：该属性不能用于 "overflow" 设置为 "visible" 的元素。

实例

本例把图像裁剪为指定的形状：

<html>
<head>
<style type="text/css">
img
{
position:absolute;
top:100px;
}
</style>
<script type="text/javascript">
function clipImage()
{
document.getElementById("img1").style.clip="rect(0px,50px,50px,0px)";
}
</script>
</head>
<body>

<img id="img1" border="0" src="logocss.gif" width="95" height="84" />

<input type="button" onclick=clipImage() value="Clip image" />

</body>
</html>

TIY

把图像裁剪为指定的形状

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM close() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM close() 方法

返回 HTML DOM Window 对象参考手册

定义和用法

close() 方法用于关闭浏览器窗口。

语法

window.close()

说明

方法 close() 将关闭有 window 指定的顶层浏览器窗口。某个窗口可以通过调用 self.close() 或只调用 close() 来关闭其自身。

只有通过 JavaScript 代码打开的窗口才能够由 JavaScript 代码关闭。这阻止了恶意的脚本终止用户的浏览器。

实例

下面的例子可关闭新的浏览器：

<html>
<head>
<script type="text/javascript">
function closeWin()
  {
  myWindow.close()
  }
</script>
</head>
<body>

<script type="text/javascript">
myWindow=window.open('','','width=200,height=100')
myWindow.document.write("This is 'myWindow'")
</script>

<input type="button" value="Close 'myWindow'"
onclick="closeWin()" />

</body>
</html>

TIY

在点击按钮时关闭浏览器

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM close() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM close() 方法

返回 HTML DOM Document 对象参考手册

定义和用法

close() 方法可关闭一个由 document.open 方法打开的输出流，并显示选定的数据。

语法

document.close()

说明

该方法将关闭 open() 方法打开的文档流，并强制地显示出所有缓存的输出内容。如果您使用 write() 方法动态地输出一个文档，必须记住当你这么做的时候要调用 close() 方法，以确保所有文档内容都能显示。

一旦调用了 close()，就不应该再次调用 write()，因为这会隐式地调用 open() 来擦除当前文档并开始一个新的文档。

实例

<html>
<head>
<script type="text/javascript">
function createNewDoc()
  {
  var newDoc=document.open("text/html","replace");
  var txt="<html><body>Learning about the DOM is FUN!</body></html>";
  newDoc.write(txt);
  newDoc.close();
  }
</script>
</head>
<body>

<input type="button" value="Write to a new document"
onclick="createNewDoc()">

</body>
</html>

TIY

打开一个新的文档，添加一些文本，然后关闭它。
在新窗口打开新的文档，并添加一些文本。

返回 HTML DOM Document 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM closed 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM closed 属性

返回 HTML DOM Window 对象参考手册

定义和用法

closed 属性可返回一个布尔值，该值声明了窗口是否已经关闭。该属性为只读。

当浏览器窗口关闭时，表示该窗口的 Windows 对象并不会消失，它将继续存在，不过它的 closed 属性将设置为 true。

语法

window.closed

实例

下面的例子可检测新窗口是否已被关闭：

<html>
<head>
<script type="text/javascript">
function ifClosed()
  {
  document.write("'myWindow' has been closed!")
  }

function ifNotClosed()
  {
  document.write("'myWindow' has not been closed!")
  }

function checkWin()
  {
  if (myWindow.closed)
    ifClosed()
  else
    ifNotClosed()
  }
</script>
</head>
<body>

<script type="text/javascript">
myWindow=window.open('','','width=200,height=100')
myWindow.document.write("This is 'myWindow'")
</script>

<input type="button" value="Has 'myWindow' been closed?"
onclick="checkWin()">

</body>
</html>

TIY

检测窗口是否已关闭

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM color 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM color 属性

返回HTML DOM Style 对象参考手册

定义和用法

color 属性设置文本的颜色（元素的前景色）。

语法：

Object.style.color=color

可能的值

值 | 描述
color | 颜色值可以是颜色名称、rgb 值或者十六进制数。 默认值：取决于浏览器。

实例

本例改变文本的颜色：

<html>
<head>
<script type="text/javascript">
function setColor()
{
document.getElementById("p1").style.color="#ff0000";
document.getElementById("p2").style.color="magenta";
}
</script>
</head>
<body>

<p id="p1">This is an example paragraph</p>
<p id="p2">This is also an example paragraph</p>

<input type="button" onclick="setColor()"
value="Change color of text" />

</body>
</html>

TIY

改变文本的颜色

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM colorDepth 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM colorDepth 属性

返回 HTML DOM Screen 对象参考手册

定义和用法

colorDepth 属性返回目标设备或缓冲器上的调色板的比特深度。

语法

screen.colorDepth

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>Color Depth: ")
document.write(screen.colorDepth + "</p>")
</script>
</body>

</html>

TIY

检测有关客户机的屏幕的细节

返回 HTML DOM Screen 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM cols 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM cols 属性

返回 HTML DOM Frameset 对象参考手册

定义和用法

cols 属性可设置或返回框架集中列的数目和尺寸。

由逗号分割的像素或百分比列表定义了列的数目和宽度：

语法

framesetObject.cols=col1,col2,col3....

实例

在我们的例子中，首先将创建包含带有两个列的框架集的 HTML 文档。每列设置为浏览器窗口的 50%：

<html>
<frameset cols="50%,50%">
  <frame src="frame_cols.htm">
  <frame src="frame_a.htm">
</frameset>
</html>

HTML 文档 "frame_cols.htm" 被放入第一列，而 HTML 文档 "frame_a.htm" 被放入第二列。

下面是 "frame_cols.htm" 的源代码：

<html>
<head>
<script type="text/javascript">
function changeCols()
  {
  parent.document.getElementById("main").cols="30%,70%"
  }

function restoreCols()
  {
  parent.document.getElementById("main").cols="50%,50%"
  }
</script>
</head>
<body>

<input type="button" onclick="changeCols()"
value="Change column size" />
<input type="button" onclick="restoreCols()"
value="Restore column size" />

</body>
</html>

TIY

更改框架集的列尺寸

返回 HTML DOM Frameset 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM cols 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM cols 属性

返回 HTML DOM Textarea 对象参考手册

定义和用法

cols 属性设置或返回文本框的字符列的宽度。

语法

textareaObject.cols=number_of_columns

实例

下面的例子更改的文本框的宽度：

<html>
<head>
<script type="text/javascript">
function changeCols()
  {
  document.getElementById('txt1').cols="20";
  }
</script>
</head>
<body>

<textarea id="txt1">
Hello world....This is a text area
</textarea>
<br />
<input type="button" onclick="changeCols()" value="Change width" />

</body>
</html>

返回 HTML DOM Textarea 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM colSpan 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM colSpan 属性

返回 HTML DOM TableCell 对象参考手册

定义和用法

colSpan 属性可设置或返回表元横跨的列数。

语法

tabledataObject.colSpan=number_of_columns

实例

下面的例子更改了表元横跨的列数：

<html>
<head>
<script type="text/javascript">
function changeColSpan()
  {
  document.getElementById("td1").colSpan="2";
  }
</script>
</head>
<body>

<table border="1">
<tr>
<th>Firstname</th>
<th>Lastname</th>
</tr>
<tr>
<td id="td1">Peter</td>
<td id="td2">Griffin</td>
</tr>
</table>
<br />
<input type="button" onclick=changeColSpan()
value="Change colspan" />

</body>
</html>

TIY

更改表元横跨的列数

返回 HTML DOM TableCell 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM complete 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM complete 属性

返回 HTML DOM Image 对象参考手册

定义和用法

complete 属性可返回浏览器是否已完成对图像的加载。

如果加载完成，则返回 true，否则返回 fasle。

语法

imageObject.complete

实例

下面的例子可检测图形是否已完成加载：

<html>
<head>
<script type="text/javascript">
function alertComplete()
{
alert(document.getElementById("compman").complete)
}
</script>
</head>
<body onload="alertComplete()">

<img id="compman" src="compman.gif" alt="Computerman"
width="107" height="98" />

</body>
</html>

TIY

检测图形是否已完成加载

返回 HTML DOM Image 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM confirm() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM confirm() 方法

返回 HTML DOM Window 对象参考手册

定义和用法

confirm() 方法用于显示一个带有指定消息和 OK 及取消按钮的对话框。

语法

confirm(message)
参数 | 描述
message | 要在 window 上弹出的对话框中显示的纯文本（而非 HTML 文本）

说明

如果用户点击确定按钮，则 confirm() 返回 true。如果点击取消按钮，则 confirm() 返回 false。

在用户点击确定按钮或取消按钮把对话框关闭之前，它将阻止用户对浏览器的所有输入。在调用 confirm() 时，将暂停对 JavaScript 代码的执行，在用户作出响应之前，不会执行下一条语句。

提示和注释

提示：对话框按钮的文字是不可改变的，因此请小心地编写问题或消息，使它适合用确认和取消来回答。

实例

<html>
<head>
<script type="text/javascript">
function disp_confirm()
  {
  var r=confirm("Press a button")
  if (r==true)
    {
    document.write("You pressed OK!")
    }
  else
    {
    document.write("You pressed Cancel!")
    }
  }
</script>
</head>
<body>

<input type="button" onclick="disp_confirm()"
value="Display a confirm box" />

</body>
</html>

TIY

显示一个确认框

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM content 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM content 属性

返回 HTML DOM Meta 对象参考手册

定义和用法

content 属性设置或返回 <meta> 元素的 content 属性的值。

语法

metaObject.content=text

实例

本例的 <meta> 标签为搜索引擎定义了一些关键词。以下代码返回 content 属性的值：

<html>
<head>
<meta name="keywords" content="HTML,DHTML,CSS,JavaScript" />
</head>
<body>

<script type="text/javascript">
x=document.getElementsByTagName("meta")[0];
document.write("Meta content: " + x.content);
</script>

</body>
</html>

TIY

获得 <meta> 元素的 content 属性的值

返回 HTML DOM Meta 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM content 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM content 属性

返回HTML DOM Style 对象参考手册

定义和用法

content 属性设置文本或图像出现（浮动）在另一个元素中的什么地方。

语法：

Object.style.content=value

可能的值

值 | 描述
string | 定义文本内容。
url | 定义 url。
  • counter(name)
  • counter(name, list-style-type)
  • counters(name, string)
  • counters(name, string, list-style-type)
attr(X) | 定义显示在该选择器之前或之后的选择器的属性。
open-quote
close-quote
no-open-quote
no-close-quote

提示和注释

注释：如果在一行中对于浮动元素而言空间太少，则这个元素会跳到下一行，这个过程会持续到有足够空间的一行为止。

注释：行内元素的内容、背景和边框应该出现在浮动元素之前。块级元素的背景和边框应当出现在浮动元素之后，但是块级元素的内容应当在浮动元素的前面。

实例

本例设置图像浮动于左边：

<html>
<head>
<script type="text/javascript">
function setFloatLeft()
{
document.getElementById("img1").style.cssFloat="left";
}
</script>

</head>
<body>

<img id="img1" src="logocss.gif" width="95" height="84" />

<p>This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.</p>

<form>
<input type="button" onclick="setFloatLeft()" value="Set image to float left" />
</form>

</body>
</html>

TIY

设置图像浮动于文字的左边

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM contentDocument 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM contentDocument 属性

返回 HTML DOM Frame 对象参考手册

定义和用法

contentDocument 属性以 HTML 对象返回框架容纳的文档。

可以通过所有标准的 DOM 方法来处理被返回的对象。

语法

frameObject.contentDocument

实例

在我们的例子中，首先将创建包含带有两个列的框架集的 HTML 文档。每列设置为浏览器窗口的 50%：

<html>
  <frameset cols="50%,50%">
    <frame id="leftFrame" src="frame_cdoc.htm">
    <frame id="rightFrame" src="frame_a.htm">
  </frameset>
</html>

HTML 文档 "frame_cdoc.htm" 被放入第一列，而 HTML 文档 "frame_a.htm" 被放入第二列。

下面是 "frame_cdoc.htm" 的源代码：

<html>
<head>
<script type="text/javascript">
function showCDoc()
  {
  var x=parent.document.getElementById("leftFrame")
  alert(x.contentDocument.documentElement.tagName)
  }
</script>
</head>
<body>

<input type="button" onclick="showCDoc()"
value="Show content-document's first tag" />

</body>
</html>

TIY

返回作为 HTML 对象的框架文档。

返回 HTML DOM Frame 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM contentDocument 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM contentDocument 属性

返回 HTML DOM Iframe 对象参考手册

定义和用法

contentDocument 属性能够以 HTML 对象来返回 iframe 中的文档。

可以通过所有标准的 DOM 方法来处理被返回的对象。

语法

iframeObject.contentDocument

实例

下面的例子可从载入 iframe 的文档的第一个 <h2> 元素中提取文本：

<html>
<head>
<script type="text/javascript">
function getTextNode()
{
var x=document.getElementById("frame1").contentDocument;
alert(x.getElementsByTagName("h2")[0].childNodes[0].nodeValue);
}
</script>
</head>

<body>
<iframe src="frame_a.htm" id="frame1"></iframe>
<br /><br />
<input type="button" onclick="getTextNode()" value="Get text" />

</body>
</html>

TIY

从 iframe 文档中提取文本节点

返回 HTML DOM Iframe 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM cookie 集合

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM cookie 属性

返回 HTML DOM Document 对象参考手册

定义和用法

cookie 属性可设置或查询与当前文档相关的所有 cookie。

语法

document.cookie

说明

该属性是一个可读可写的字符串，可使用该属性对当前文档的 cookie 进行读取、创建、修改和删除操作。

提示和注释

提示：该属性的行为与普通的读/写属性是不同的。

实例

<html>
<body>

The cookies associated with this document is:
<script type="text/javascript">
document.write(document.cookie)
</script>

</body>
</html>

TIY

返回与当前文档相关的 cookie

返回 HTML DOM Document 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM cookieEnabled 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM cookieEnabled 属性

返回 HTML DOM Navigator 对象参考手册

定义和用法

cookieEnabled 属性可返回一个布尔值，如果浏览器启用了 cookie，该属性值为 true。如果禁用了 cookie，则值为 false。

语法

navigator.cookieEnabled

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>CookieEnabled: ")
document.write(navigator.cookieEnabled + "</p>")
</script>
</body>

</html>

TIY

检测访问者的浏览器和版本号
有关访问者的浏览器的更多信息
有关访问者的浏览器的全部细节
根据浏览器来提醒用户

返回 HTML DOM Navigator 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM coords 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM coords 属性

返回 HTML DOM Anchor 对象参考手册

定义和用法

coords 属性设置或返回一个逗号分隔列表，其中包含了图像映射中一个链接的坐标。

语法

anchorObject.coords=coordinates

实例

下面的例子可返回图像映射中一个链接的坐标：

<html>
<body>

<img src="planets.gif"
width="145" height="126"
usemap="#planetmap" />

<map name="planetmap">
<area id="venus" shape="circle"
coords="124,58,8"
alt="Venus"
href="venus.htm" />
</map>

<p>Venus coordinates:
<script type="text/javascript">
x=document.getElementById("venus");
document.write(x.coords);
</script>
</p>

</body>
</html>

TIY

取得图像映射中一个链接的坐标

返回 HTML DOM Anchor 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM coords 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM coords 属性

返回 HTML DOM Area 对象参考手册

定义和用法

coords 属性可设置或返回图像映射中某个可点击区域的坐标。

语法

areaObject.coords=coordinates

实例

下面的例子可返回图像映射中某个可点击区域的坐标：

<html>
<body>

<img src="planets.gif"
width="145" height="126"
usemap="#planetmap" />

<map name="planetmap">
<area id="venus" shape="circle"
coords="124,58,8"
alt="Venus"
href="venus.htm" />
</map>

<p>Venus coordinates:
<script type="text/javascript">
x=document.getElementById("venus");
document.write(x.coords);
</script>
</p>

</body>
</html>

TIY

返回图像映射中某个可点击区域的坐标

返回 HTML DOM Area 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM cpuClass 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM cpuClass 属性

返回 HTML DOM Navigator 对象参考手册

定义和用法

cpuClass 属性可返回浏览器系统的 CPU 等级。

语法

navigator.cpuClassd

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>CPUClass: ")
document.write(navigator.cpuClass + "</p>")
</script>
</body>

</html>

TIY

检测访问者的浏览器和版本号
有关访问者的浏览器的更多信息
有关访问者的浏览器的全部细节
根据浏览器来提醒用户

返回 HTML DOM Navigator 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM createCaption() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM createCaption() 方法

返回 HTML DOM Table 对象参考手册

定义和用法

createCaption() 方法用于在表格中获取或创建 <caption> 元素。

语法

tableObject.createCaption()

返回值

返回一个 HTMLElement 对象，表示该表的 <caption> 元素。如果该表格已经有了标题，则返回它。如果该表没有 <caption> 元素，则创建一个新的空 <caption> 元素，把它插入表格，并返回它。

实例

下面的例子为表格创建了一个标题：

<html>
<head>
<script type="text/javascript">
function createCaption()
{
var x=document.getElementById('myTable').createCaption()
x.innerHTML="My table caption"
}
</script>
</head>
<body>

<table id="myTable" border="1">
<tr>
<td>Row1 cell1</td>
<td>Row1 cell2</td>
</tr>
<tr>
<td>Row2 cell1</td>
<td>Row2 cell2</td>
</tr>
</table>
<br />
<input type="button" onclick="createCaption()"
value="Create caption">

</body>
</html>

TIY

为表格创建了一个标题

返回 HTML DOM Table 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM createPopup() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM createPopup() 方法

返回 HTML DOM Window 对象参考手册

定义和用法

createPopup() 方法用于创建一个 pop-up 窗口。

语法

window.createPopup()

实例

<html>
<head>
<script type="text/javascript">
function show_popup()
{
var p=window.createPopup()
var pbody=p.document.body
pbody.style.backgroundColor="lime"
pbody.style.border="solid black 1px"
pbody.innerHTML="This is a pop-up! Click outside to close."
p.show(150,150,200,50,document.body)
}
</script>
</head>

<body>
<button onclick="show_popup()">Create pop-up!</button>
</body>

</html>

TIY

创建 pop-up

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM createTFoot() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM createTFoot() 方法

返回 HTML DOM Table 对象参考手册

定义和用法

createTFoot() 方法用于在表格中获取或创建 <tfoot> 元素。

语法

tableObject.createTFoot()

返回值

返回一个 TableSection，表示该表的 <tfoot> 元素。如果该表格已经有了脚注，则返回它。如果该表没有脚注，则创建一个新的空 <tfoot> 元素，把它插入表格，并返回它。

实例

下面的例子为表格创建了一个脚注：

<html>
<head>
<script type="text/javascript">
function createCaption()
{
var x=document.getElementById('myTable').createTFoot()
x.innerHTML="My table foot"
}
</script>
</head>
<body>

<table id="myTable" border="1">
<tr>
<td>Row1 cell1</td>
<td>Row1 cell2</td>
</tr>
<tr>
<td>Row2 cell1</td>
<td>Row2 cell2</td>
</tr>
</table>
<br />
<input type="button" onclick="createCaption()"
value="Create caption">

</body>
</html>

TIY

为表格创建了一个脚注

返回 HTML DOM Table 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM createTHead() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM createTHead() 方法

返回 HTML DOM Table 对象参考手册

定义和用法

createTHead() 方法用于在表格中获取或创建 <thead> 元素。

语法

tableObject.createTHead()

返回值

返回一个 TableSection，表示该表的 <thead> 元素。如果该表格已经有了表头，则返回它。如果该表没有表头，则创建一个新的空 <thead> 元素，把它插入表格，并返回它。

实例

下面的例子为表格创建了一个脚注：

<html>
<head>
<script type="text/javascript">
function createCaption()
{
var x=document.getElementById('myTable').createTHead()
x.innerHTML="My table head"
}
</script>
</head>
<body>

<table id="myTable" border="1">
<tr>
<td>Row1 cell1</td>
<td>Row1 cell2</td>
</tr>
<tr>
<td>Row2 cell1</td>
<td>Row2 cell2</td>
</tr>
</table>
<br />
<input type="button" onclick="createCaption()"
value="Create caption">

</body>
</html>

TIY

为表格创建了一个表头

返回 HTML DOM Table 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM cssFloat 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM cssFloat 属性

返回HTML DOM Style 对象参考手册

定义和用法

设置文本或图像出现（浮动）在另一个元素中的什么地方。

语法：

Object.style.cssFloat=left|right|none

可能的值

值 | 描述
left | 图像或文本浮动在父元素的左边。
right | 图像或文本浮动在父元素的右边。
none | 图像或文本浮动显示在它在父元素中出现的位置。

提示和注释

注释：如果在一行中对于浮动元素而言空间太少，则这个元素会跳到下一行，这个过程会持续到有足够空间的一行为止。

实例

本例设置图像浮动于左边：

<html>
<head>
<script type="text/javascript">
function setFloat()
{
document.getElementById("img1").style.cssFloat="left";
}
</script>
</head>
<body>

<img id="img1" src="logocss.gif" />

<p>This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.</p>

<input type="button" onclick="setFloat()"
value="Set image to float to the left" />

</body>
</html>

TIY

cssFloat - 设置图像浮动于文字的左边（请在非 IE 浏览器中查看）

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM cursor 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM cursor 属性

返回HTML DOM Style 对象参考手册

定义和用法

cursor 属性规定所显示的指针（光标）的类型。

语法：

Object.style.cursor=cursortype

可能的值

值 | 描述
url | 需被使用的自定义光标的URL 注释：请在此列表的末端始终定义一种普通的光标，以防没有由 URL 定义的可用光标。
default | 默认光标（通常是一个箭头）
auto | 默认。浏览器设置的光标。
crosshair | 光标呈现为十字线。
pointer | 光标呈现为指示链接的指针（一只手）
move | 此光标指示某对象可被移动。
e-resize | 此光标指示矩形框的边缘可被向右（东）移动。
ne-resize | 此光标指示矩形框的边缘可被向上及向右移动（北/东）。
nw-resize | 此光标指示矩形框的边缘可被向上及向左移动（北/西）。
n-resize | 此光标指示矩形框的边缘可被向上（北）移动。
se-resize | 此光标指示矩形框的边缘可被向下及向右移动（南/东）。
sw-resize | 此光标指示矩形框的边缘可被向下及向左移动（南/西）。
s-resize | 此光标指示矩形框的边缘可被向下移动（北/西）。
w-resize | 此光标指示矩形框的边缘可被向左移动（西）。
text | 此光标指示文本。
wait | 此光标指示程序正忙（通常是一只表或沙漏）。
help | 此光标指示可用的帮助（通常是一个问号或一个气球）。

实例

本例改变指针：

<html>
<head>
<script type="text/javascript">
function changeCursor()
{
document.body.style.cursor="crosshair";
document.getElementById("p1").style.cursor="text";
}
</script>
</head>
<body>

<p id="p1">This is some text. This is some text.
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
This is some text.</p>

<input type="button" onclick="changeCursor()"
value="Change cursor" />

</body>
</html>

TIY

cursor - 改变指针

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM defaultChecked 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM defaultChecked 属性

返回 HTML DOM Checkbox 对象参考手册

定义和用法

defaultChecked 属性可返回 checked 属性的默认值。

该属性在 checkbox 默认被选定时返回 true，否则返回 false。

语法

checkboxObject.defaultChecked

实例

下面的例子可返回 checked 属性的值：

<html>
<body>

<form>
<input type="checkbox" id="myCheck" checked="checked" />
</form>

<script type="text/javascript">
alert(document.getElementById("myCheck").defaultChecked)
</script>

</body>
</html>

TIY

返回 checkbox 是否默认被选中
选定以及不选定 checkbox

返回 HTML DOM Checkbox 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM defaultChecked 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM defaultChecked 属性

返回 HTML DOM Radio 对象参考手册

定义和用法

defaultChecked 属性可返回 checked 属性的默认值。

如果单选按钮的默认状态是选中，则返回 true，否则返回 fasle。

语法

radioObject.defaultChecked

实例

下面的例子返回了 checked 属性的默认值：

<html>
<body>

<form>
<input type="radio" id="radio1" checked="checked" />
</form>

<script type="text/javascript">
alert(document.getElementById("radio1").defaultChecked);
</script>

</body>
</html>

TIY

返回单选按钮的默认状态

返回 HTML DOM Radio 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM defaultSelected 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM defaultSelected 属性

返回 HTML DOM Option 对象参考手册

定义和用法

defaultSelected 属性可返回 selected 属性的初始值。

如果选择了默认的选项，则返回 true，否则返回 fasle。

如果表单被重置，则 selected 属性重置为该属性的值。这个该属性也会设置 selected 属性的值。

注释：默认的选项将显示在第一位。

语法

optionObject.defaultSelected

实例

下面的例子可检测所选项是否是默认选项：

<html>
<head>
<script type="text/javascript">
function alertDefaultSelected()
  {
  var x=document.getElementById("mySelect").selectedIndex;
  var y=document.getElementsByTagName("option");
  var txt="Is " + y[x].text + " selected by default? ";
  txt=txt + y[x].defaultSelected;
  alert(txt);
  }
</script>
</head>
<body>

<form>
Select your favorite fruit:
<select id="mySelect">
  <option>Apple</option>
  <option>Orange</option>
  <option selected="selected">Pineapple</option>
  <option>Banana</option>
</select>
<br />
<br />
<input type="button" onclick="alertDefaultSelected()"
value="Is the chosen fruit selected by default?">
</form>

</body>
</html>

TIY

检测所选项是否是默认选项

返回 HTML DOM Option 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM defaultStatus 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM defaultStatus 属性

返回 HTML DOM Window 对象参考手册

定义和用法

defaultStatus 属性可设置或返回窗口状态栏中的默认文本。该属性可读可写。

该文本会在页面加载时被显示。

语法

window.defaultStatus=sometext

实例

下面的例子讲在状态栏设置文本：

<html>
<body>

<script type="text/javascript">
window.defaultStatus="This is the default text in the status bar!!";
</script>

<p>Look at the text in the statusbar.</p>

</body>
</html>

TIY

在状态栏设置默认的文本

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM defaultValue 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM defaultValue 属性

返回 HTML DOM Password 对象参考手册

定义和用法

defaultValue 属性可设置或返回密码域的默认值。

注释：该默认值是在 HTML "value" 属性中规定的默认值。

语法

passwordObject.defaultValue=somevalue

实例

下面的例子可获得密码域的默认值：

<html>
<head>
<script type="text/javascript">
function alertValue()
  {
  alert(document.getElementById("password1").defaultValue)
  }
</script>
</head>
<body>

<form>
<input type="password" id="password1" value="thgrt456" />
<input type="button" id="button1" onclick="alertValue()"
value="Show default value" />
</form>

</body>
</html>

TIY

获得密码域的默认值

返回 HTML DOM Password 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM defaultValue 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM defaultValue 属性

返回 HTML DOM Text 对象参考手册

定义和用法

defaultValue 属性可设置或返回文本域的默认值。

注释：该默认值是规定于 HTML "value" 属性的值。

语法

textObject.defaultValue=somevalue

实例

下面的例子可获得该文本域的默认文本：

<html>
<head>
<script type="text/javascript">
function alertValue()
{
alert(document.getElementById("text1").defaultValue)
}
</script>
</head>
<body>

<form>
<input type="text" id="text1" value="Hello World!" />
<input type="button" id="button1" onclick="alertValue()"
value="Show default value" />
</form>

</body>
</html>

TIY

获得该文本域的默认文本

返回 HTML DOM Text 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM defaultValue 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM defaultValue 属性

返回 HTML DOM Textarea 对象参考手册

定义和用法

defaultValue 属性设置或返回文本框的初始内容。

注释：文本框的初始值是位于 <textarea> 和 </textarea> 标签之间的文本。在表单被重置时，文本框将被恢复为整个值。改变这个属性的值会改变文本框中当前显示的文本。

语法

textareaObject.defaultValue=text

实例

下面的例子提示出了文本框的默认值：

<html>
<head>
<script type="text/javascript">
function alertDefaultValue()
  {
  alert(document.getElementById('txt1').defaultValue);
  }
</script>
</head>
<body>

<textarea id="txt1">
Hello world....This is a text area
</textarea>
<br />
<input type="button" onclick="alertDefaultValue()"
value="Alert default value" />

</body>
</html>

返回 HTML DOM Textarea 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM deleteCaption() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM deleteCaption() 方法

返回 HTML DOM Table 对象参考手册

定义和用法

deleteCaption() 方法用于删除表格的 caption 元素及其内容。

语法

tableObject.deleteCaption()

说明

如果该表有 <caption> 元素，则从文档树种删除它。否则，什么也不做。

实例

下面的例子删除表格的标题：

<html>
<head>
<script type="text/javascript">
function deleteCaption()
  {
  document.getElementById('myTable').deleteCaption()
  }
</script>
</head>
<body>

<table id="myTable" border="1">
<caption>My table caption</caption>
<tr>
<th>Firstname</th>
<th>Lastname</th>
</tr>
<tr>
<td>Peter</td>
<td>Griffin</td>
</tr>
</table>
<br />
<input type="button" onclick="deleteCaption()"
value="Delete caption" />

</body>
</html>

TIY

删除表格的标题

返回 HTML DOM Table 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM deleteCell() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM deleteCell() 方法

返回 HTML DOM Tablerow 对象参考手册

定义和用法

deleteCell() 方法用于删除表格行中的单元格（<td> 元素）。

语法

tablerowObject.deleteCell(index)

说明

参数 index 是要删除的表元在行中的位置。

该方法将删除表行中指定位置的表元。

抛出

若参数 index 小于 0 或大于等于行中的的表元数，该方法将抛出代码为 INDEX_SIZE_ERR 的 DOMException 异常。

实例

下面的例子从行中删除了一个单元格：

<html>
<head>
<script type="text/javascript">
function delCell()
  {
  document.getElementById('tr2').deleteCell(0)
  }
</script>
</head>
<body>

<table border="1">
<tr id="tr1">
<th>Firstname</th>
<th>Lastname</th>
</tr>
<tr id="tr2">
<td>Peter</td>
<td>Griffin</td>
</tr>
</table>
<br />
<input type="button" onclick="delCell()" value="Delete cell">

</body>
</html>

TIY

删除行中的一个单元格

返回 HTML DOM Tablerow 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM deleteRow() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM deleteRow() 方法

返回 HTML DOM Table 对象参考手册

定义和用法

deleteRow() 方法用于从表格删除指定位置的行。

语法

tableObject.deleteRow(index)

说明

参数 index 指定了要删除的行在表中的位置。行的编码顺序就是他们在文档源代码中出现的顺序。<thead> 和 <tfoot> 中的行与表中其它行一起编码。

实例

The following example deletes the first row of the table:

<html>
<head>
<script type="text/javascript">
function delRow()
  {
  document.getElementById('myTable').deleteRow(0)
  }
</script>
</head>
<body>

<table id="myTable" border="1">
<tr>
<td>Row1 cell1</td>
<td>Row1 cell2</td>
</tr>
<tr>
<td>Row2 cell1</td>
<td>Row2 cell2</td>
</tr>
</table>
<br />
<input type="button" onclick="delRow()"
value="Delete first row">

</body>
</html>

TIY

从表格删除行

返回 HTML DOM Table 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM deleteTFoot() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM deleteTFoot() 方法

返回 HTML DOM Table 对象参考手册

定义和用法

deleteTFoot() 方法用于从表格删除 <tfoot> 元素。

语法

tableObject.deleteTFoot()

说明

如果该表有 <tfoot> 元素，则将它从文档树种删除，否则什么也不做。

实例

下面的例子删除表的脚注：

<html>
<head>
<script type="text/javascript">
function delRow()
  {
  document.getElementById('myTable').deleteTFoot()
  }
</script>
</head>
<body>

<table id="myTable" border="1">
<tr>
<td>Row1 cell1</td>
<td>Row1 cell2</td>
</tr>
<tr>
<td>Row2 cell1</td>
<td>Row2 cell2</td>
</tr>
<tfoot><td>my table foot</td></tfoot>
</table>
<br />
<input type="button" onclick="delRow()"
value="Delete table foot">

</body>
</html>

TIY

从表格删除脚注

返回 HTML DOM Table 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM deleteTHead() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM deleteTHead() 方法

返回 HTML DOM Table 对象参考手册

定义和用法

deleteTHead() 方法用于从表格删除 <thead> 元素。

语法

tableObject.deleteTHead()

说明

如果该表有 <thead> 元素，则将它从文档树种删除，否则什么也不做。

实例

下面的例子删除表的脚注：

<html>
<head>
<script type="text/javascript">
function delRow()
  {
  document.getElementById('myTable').deleteTHead()
  }
</script>
</head>
<body>

<table id="myTable" border="1">
<thead><td>my table head</td></thead>
<tr>
<td>Row1 cell1</td>
<td>Row1 cell2</td>
</tr>
<tr>
<td>Row2 cell1</td>
<td>Row2 cell2</td>
</tr>
</table>
<br />
<input type="button" onclick="delRow()"
value="Delete table foot">

</body>
</html>

TIY

从表格删除表头

返回 HTML DOM Table 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM deviceXDPI 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM deviceXDPI 属性

返回 HTML DOM Screen 对象参考手册

定义和用法

deviceXDPI 属性返回显示屏幕的每英寸水平点数。

语法

screen.deviceXDPI

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>Device XDPI: ")
document.write(screen.deviceXDPI + "</p>")
</script>
</body>

</html>

TIY

检测有关客户机的屏幕的细节

返回 HTML DOM Screen 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM deviceYDPI 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM deviceYDPI 属性

返回 HTML DOM Screen 对象参考手册

定义和用法

deviceYDPI 属性返回显示屏幕的每英寸垂直点数。

语法

screen.deviceYDPI

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>Device YDPI: ")
document.write(screen.deviceYDPI + "</p>")
</script>
</body>

</html>

TIY

检测有关客户机的屏幕的细节

返回 HTML DOM Screen 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM dir 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM dir 属性

返回HTML DOM Style 对象参考手册

定义和用法

dir 属性设置或返回元素的文字方向。

语法：

object.dir=text-direction

实例

本例展示了两种获取 <body> 元素的文本方向的方法：

<html>
<body id="myid" dir="rtl">

<script type="text/javascript">
x=document.getElementsByTagName('body')[0];
document.write("Text direction: " + x.dir);
document.write("<br />");
document.write("An alternate way: ");
document.write(document.getElementById('myid').dir);
</script>

</body>
</html>

TIY

<body> 元素的文本方向

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM dir 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM dir 属性

返回 HTML DOM Body 对象参考手册

定义和用法

dir 属性可设置或返回元素的文本方向。

语法

bodyObject.dir=text-direction

实例

下面的例子可展示两种设置 <body> 元素的文本方向的方法：

<html>
<body id="myid" dir="rtl">

<script type="text/javascript">
x=document.getElementsByTagName('body')[0];
document.write("Text direction: " + x.dir);
document.write("<br />");
document.write("An alternate way: ");
document.write(document.getElementById('myid').dir);
</script>

</body>
</html>

输出：

Text direction: rtl
An alternate way: rtl

TIY

返回 <body> 元素的文本方向

返回 HTML DOM Body 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM direction 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM direction 属性

返回HTML DOM Style 对象参考手册

定义和用法

direction 属性设置元素的文本方向。

语法：

Object.style.direction=ltr|rtl|inherit

Possible Values

值 | 描述
ltr | 默认。内容从左向右流动。
rtl | 内容从右向左流动。
inherit | 内容流动从父元素继承。

实例

本例把文本设置为从右向左流动：

<html>
<head>
<script type="text/javascript">
function changeTextDirection()
{
document.getElementById("p1").style.direction="rtl";
}
</script>
</head>
<body>

<p id="p1">This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.</p>

<input type="button" onclick="changeTextDirection()"
value="Set text to flow right to left" />

</body>
</html>

TIY

direction - 把文本设置为从右向左流动

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM disabled 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM disabled 属性

返回 HTML DOM Button 对象参考手册

定义和用法

disabled 属性可设置或返回是否禁用按钮。

语法

buttonObject.disabled=true|false

实例

下面的例子将禁用按钮：

<html>
<head>
<script type="text/javascript">
function disableButton()
{
document.getElementById("myButton").disabled=true
}
</script>
</head>

<body>
<form>
<button id="myButton" onClick="disableButton()">
Click Me!</button>
</form>
</body>

</html>

TIY

提示按钮的 id 和 类型 + 禁用按钮

返回 HTML DOM Button 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM disabled 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM disabled 属性

返回 HTML DOM Button 对象参考手册

定义和用法

disabled 属性可设置或返回是否禁用按钮。

语法

buttonObject.disabled=true|false

实例

下面的例子可在点击按钮时禁用该按钮：

<html>
<head>
<script type="text/javascript">
function disableButton()
  {
  document.getElementById("myButton").disabled=true
  }
</script>
</head>

<body>
<form>
<input type="button" id="myButton"
value="Click me!" onclick="disableButton()" />
</form>
</body>

</html>

TIY

提示按钮的 id、类型和值 + 禁用按钮

返回 HTML DOM Button 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM disabled 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM disabled 属性

返回 HTML DOM Checkbox 对象参考手册

定义和用法

disabled 属性可设置或返回是否禁用 checkbox。

语法

checkboxObject.disabled=true|false

实例

下面的例子禁用了该 checkbox：

<html>
<head>
<script type="text/javascript">
function disable()
  {
  document.getElementById("check1").disabled=true
  }
</script>
</head>
<body>

<form>
<input type="checkbox" id="check1" />
<input type="button" onclick="disable()" value="Disable Checkbox" />
</form>

</body>
</html>

TIY

禁用 checkbox

返回 HTML DOM Checkbox 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM disabled 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM disabled 属性

返回 HTML DOM Password 对象参考手册

定义和用法

disabled 属性可设置或返回是否禁用密码域。

语法

passwordObject.disabled=true|false

实例

下面的例子仅用了该密码域：

<html>
<head>
<script type="text/javascript">
function disablePassword()
  {
  document.getElementById("password1").disabled=true
  }
</script>
</head>
<body>

<form>
<input type="password" id="password1" />
<input type="button" id="button1" onClick="disablePassword()"
value="Disable password field" />
</form>

</body>
</html>

TIY

禁用一个密码域

返回 HTML DOM Password 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM disabled 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM disabled 属性

返回 HTML DOM Password 对象参考手册

定义和用法

form 属性可返回对包含该密码域的表单的引用。

若成功，该属性将返回一个表单对象。

语法

passwordObject.form

实例

下面的例子取得了该密码域所属的表单的 id：

<html>
<body>

<form id="form1">
<input type="password" id="password1" />
</form>

<p>The id of the form containing the password field is:
<script type="text/javascript">
x=document.getElementById('password1');
document.write(x.form.id);
</script></p>

</body>
</html>

TIY

取得密码域所属的表单的 id

返回 HTML DOM Password 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM disabled 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM disabled 属性

返回 HTML DOM Radio 对象参考手册

定义和用法

disabled 属性可设置或返回是否禁用单选按钮。

语法

radioObject.disabled=true|false

实例

下面的例子禁用了该单选按钮：

<html>
<head>
<script type="text/javascript">
function disable()
  {
  document.getElementById("gnome").disabled=true
  }
</script>
</head>
<body>

<form>
Human: <input id="human" type="radio" name="creature" value="Human" />
<br />
Animal: <input id="animal" type="radio" name="creature" value="Animal" />
<br />
Gnome: <input id="gnome" type="radio" name="creature" value="Gnome" />
<br /><br />
<input type="button" onclick="disable()" value="Disable choice" />
</form>

</body>
</html>

TIY

禁用某个单选按钮

返回 HTML DOM Radio 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM disabled 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM disabled 属性

返回 HTML DOM Reset 对象参考手册

定义和用法

disabled 属性可设置或返回是否禁用重置按钮。

语法

resetObject.disabled=true|false

实例

下面的例子会在单击重置按钮时将其禁用：

<html>
<head>
<script type="text/javascript">
function disableButton()
  {
  document.getElementById("reset1").disabled=true
  }
</script>
</head>

<body>
<form>
<input type="reset" id="reset1" onclick="disableButton()" />
</form>
</body>

</html>

TIY

提示重置按钮的 id、类型和值 + 禁用按钮

返回 HTML DOM Reset 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM disabled 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM disabled 属性

返回 HTML DOM Submit 对象参考手册

定义和用法

disabled 属性可设置或返回是否禁用确认按钮

语法

submitObject.disabled=true|false

实例

下面的例子会在单击确认按钮时将其禁用：

<html>
<head>
<script type="text/javascript">
function disableButton()
  {
  document.getElementById("submit1").disabled=true
  }
</script>
</head>

<body>
<form>
<input type="submit" id="submit1" onclick="disableButton()" />
</form>
</body>

</html>

TIY

提示确认按钮的 id、类型和值 + 禁用按钮

返回 HTML DOM Submit 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM disabled 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM disabled 属性

返回 HTML DOM Text 对象参考手册

定义和用法

disabled 属性可设置或返回是否禁用文本域。

语法

textObject.disabled=true|false

实例

下面的例子禁用了一个文本域：

<html>
<head>
<script type="text/javascript">
function disableField()
  {
  document.getElementById("text1").disabled=true
  }
</script>
</head>
<body>

<form>
<input type="text" id="text1" value="Hello world!" />
<input type="button" id="button1" onclick="disableField()"
value="Disable text field" />
</form>

</body>
</html>

TIY

禁用了文本域

返回 HTML DOM Text 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM disabled 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM disabled 属性

返回 HTML DOM Link 对象参考手册

定义和用法

The disabled property sets or returns whether or not the target URL should be disabled.

语法

linkObject.disabled=true|false

实例

The following example disables the style sheet:

<html>
<head>
<link rel="stylesheet" type="text/css"
id="style1" href="try_dom_link.css" />

<script type="text/javascript">
function disableStyle()
  {
  document.getElementById("style1").disabled=true
  }
</script>
</head>
<body>

<form>
<input type="button" id="button1" onclick="disableStyle()"
value="Disable style sheet" />
</form>

</body>
</html>

TIY

Disable a style sheet

返回 HTML DOM Link 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM disabled 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM disabled 属性

返回 HTML DOM Option 对象参考手册

定义和用法

disabled 属性可设置或返回是否默认地禁用某个 <option> 元素。

注释：该 disabled 属性在 IE 中不起作用。

如果该属性为 true，则该 <option> 元素将被禁用，用户就无法选择它了。

该属性映射 HTML 属性 disabled。

语法

optionObject.disabled=true|false

实例

下面的例子可提示所选的水果是否被默认地禁用：

<html>
<head>
<script type="text/javascript">
function alertDefaultDisabled()
  {
  var x=document.getElementById("mySelect").selectedIndex;
  var y=document.getElementsByTagName("option");
  alert("Is " + y[x].text + " disabled by default? " + y[x].disabled);
  }
</script>
</head>
<body>

<form>
Select your favorite fruit:
<select id="mySelect">
<option>Apple</option>
<option>Orange</option>
<option disabled="disabled">Pineapple</option>
<option>Banana</option>
</select>
<br />
<br />
<input type="button" onclick="alertDefaultDisabled()"
value="Is the chosen fruit disabled by default?">
</form>

</body>
</html>

TIY

检测某个选项是否被默认地禁用
通过 id 禁用某个选项

返回 HTML DOM Option 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM disabled 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM disabled 属性

返回 HTML DOM Select 对象参考手册

定义和用法

disabled 属性可设置或返回是否金融下拉列表。

语法

selectObject.disabled=true|false

实例

下面的例子可禁用并启用下拉列表：

<html>
<head>
<script type="text/javascript">
function disable()
  {
  document.getElementById("mySelect").disabled=true
  }
function enable()
  {
  document.getElementById("mySelect").disabled=false
  }
</script>
</head>
<body>

<form>
<select id="mySelect">
  <option>Apple</option>
  <option>Pear</option>
  <option>Banana</option>
  <option>Orange</option>
</select>
<br /><br />
<input type="button" onclick="disable()" value="Disable list">
<input type="button" onclick="enable()" value="Enable list">
</form>

</body>
</html>

TIY

禁用并启用下拉列表

返回 HTML DOM Select 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM disabled 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM disabled 属性

返回 HTML DOM Textarea 对象参考手册

定义和用法

disabled 属性可设置或返回是否应禁用文本框。

语法

textareaObject.disabled=true|false

实例

下面的例子可禁用并启用文本框：

<html>
<head>
<script type="text/javascript">
function disable()
  {
  document.getElementById('txt1').disabled=true;
  }
function enable()
  {
  document.getElementById('txt1').disabled=false;
  }
</script>
</head>
<body>

<textarea id="txt1">
Hello world....This is a text area
</textarea>
<br />
<input type="button" onclick="disable()" value="Disable" />
<input type="button" onclick="enable()" value="Enable" />

</body>
</html>

返回 HTML DOM Textarea 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM display 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM display 属性

返回HTML DOM Style 对象参考手册

定义和用法

display 属性设置元素如何显示。

语法：

Object.style.display=value

Possible Values

值 | 描述
none | 此元素不会被显示。
block | 此元素将显示为块级元素，此元素前后会带有换行符。
inline | 默认。此元素会被显示为内联元素，元素前后没有换行符。
list-item | 此元素会作为列表显示。
run-in | 此元素会根据上下文作为块级元素或内联元素显示。
compact | 此元素会根据上下文作为块级元素或内联元素显示。
marker |
table | 此元素会作为块级表格来显示（类似 <table>），表格前后带有换行符。
inline-table | 此元素会作为内联表格来显示（类似 <table>），表格前后没有换行符。
table-row-group | 此元素会作为一个或多个行的分组来显示（类似 <tbody>）。
table-header-group | 此元素会作为一个或多个行的分组来显示（类似 <thead>）。
table-footer-group | 此元素会作为一个或多个行的分组来显示（类似 <tfoot>）。
table-row | 此元素会作为一个表格行显示（类似 <tr>）。
table-column-group | 此元素会作为一个或多个列的分组来显示（类似 <colgroup>）。
table-column | 此元素会作为一个单元格列显示（类似 <col>）
table-cell | 此元素会作为一个表格单元格显示（类似 <td> 和 <th>）
table-caption | 此元素会作为一个表格标题显示（类似 <caption>）

实例

本例设置不显示元素：

<html>
<head>
<script type="text/javascript">
function removeElement()
{
document.getElementById("p1").style.display="none";
}
</script>
</head>
<body>

<h1>Hello</h1>

<p id="p1">This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.</p>

<input type="button" onclick="removeElement()"
value="Do not display paragraph" />

</body>
</html>

TIY

display - 设置不显示元素

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Document 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Document 对象

Document 对象

Document 对象代表整个 HTML 文档，可用来访问页面中的所有元素。

Document 对象是 Window 对象的一个部分，可通过 window.document 属性来访问。

有关 Document 对象的详细描述。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet 标准).

Document 对象的集合

集合 | 描述 | IE | F | O | W3C
all[] | 提供对文档中所有 HTML 元素的访问。 | 4 | 1 | 9 | Yes
anchors[] | 返回对文档中所有 Anchor 对象的引用。 | 4 | 1 | 9 | Yes
applets | 返回对文档中所有 Applet 对象的引用。 | - | - | - | -
forms[] | 返回对文档中所有 Form 对象引用。 | 4 | 1 | 9 | Yes
images[] | 返回对文档中所有 Image 对象引用。 | 4 | 1 | 9 | Yes
links[] | 返回对文档中所有 Area 和 Link 对象引用。 | 4 | 1 | 9 | Yes

Document 对象的属性

属性 | 描述 | IE | F | O | W3C
body | 提供对 <body> 元素的直接访问。对于定义了框架集的文档，该属性引用最外层的 <frameset>。 |  |  |  |
cookie | 设置或返回与当前文档有关的所有 cookie。 | 4 | 1 | 9 | Yes
domain | 返回当前文档的域名。 | 4 | 1 | 9 | Yes
lastModified | 返回文档被最后修改的日期和时间。 | 4 | 1 | No | No
referrer | 返回载入当前文档的文档的 URL。 | 4 | 1 | 9 | Yes
title | 返回当前文档的标题。 | 4 | 1 | 9 | Yes
URL | 返回当前文档的 URL。 | 4 | 1 | 9 | Yes

Document 对象的方法

方法 | 描述 | IE | F | O | W3C
close() | 关闭用 document.open() 方法打开的输出流，并显示选定的数据。 | 4 | 1 | 9 | Yes
getElementById() | 返回对拥有指定 id 的第一个对象的引用。 | 5 | 1 | 9 | Yes
getElementsByName() | 返回带有指定名称的对象集合。 | 5 | 1 | 9 | Yes
getElementsByTagName() | 返回带有指定标签名的对象集合。 | 5 | 1 | 9 | Yes
open() | 打开一个流，以收集来自任何 document.write() 或 document.writeln() 方法的输出。 | 4 | 1 | 9 | Yes
write() | 向文档写 HTML 表达式 或 JavaScript 代码。 | 4 | 1 | 9 | Yes
writeln() | 等同于 write() 方法，不同的是在每个表达式之后写一个换行符。 | 4 | 1 | 9 | Yes

Document 对象的描述

HTMLDocument 接口对 DOM Document 接口进行了扩展，定义 HTML 专用的属性和方法。

很多属性和方法都是 HTMLCollection 对象（实际上是可以用数组或名称索引的只读数组），其中保存了对锚、表单、链接以及其他可脚本元素的引用。

这些集合属性都源自于 0 级 DOM。它们已经被 Document.getElementsByTagName() 所取代，但是仍然常常使用，因为他们很方便。

write() 方法值得注意，在文档载入和解析的时候，它允许一个脚本向文档中插入动态生成的内容。

注意，在 1 级 DOM 中，HTMLDocument 定义了一个名为 getElementById() 的非常有用的方法。在 2 级 DOM 中，该方法已经被转移到了 Document 接口，它现在由 HTMLDocument 继承而不是由它定义了。

HTML DOM 参考手册
HTML DOM 实例


HTML DOM domain 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM domain 属性

返回 HTML DOM Document 对象参考手册

定义和用法

domain 属性可返回下载当前文档的服务器域名。

语法

document.domain

说明

该属性是一个只读的字符串，包含了载入当前文档的 web 服务器的主机名。

提示和注释

提示：domain 属性可以解决因同源安全策略带来的不同文档的属性共享问题。

点击这里，了解同源安全策略的详细信息。

实例

<html>
<body>

The domain name for this document is:
<script type="text/javascript">
document.write(document.domain)
</script>

</body>
</html>

TIY

返回下载当前文档的服务器域名

返回 HTML DOM Document 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM elements 集合

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM elements 集合

返回 HTML DOM Form 对象参考手册

定义和用法

elements 集合可返回包含表单中所有元素的数组。

元素在数组中出现的顺序和它们在表单的HTML 源代码中出现的顺序相同。

每个元素都有一个 type 属性，其字符串值说明了元素的类型。

语法

formObject.elements[].property

提示和注释

提示：如果 elements[] 数组具有名称（input 标签的 id 或 name 属性），那么该元素的名称就是 formObject 的一个属性，因此可以使用名称而不是数字来引用 input 对象。

举例，假设 x 是一个 form 对象，其中的一个 input 对象的名称是 fname，则可以使用 x.fname 来引用该对象。

实例

下面的例子输出了所有表单元素的值和类型：

<html>
<body>

<form id="myForm">
Firstname: <input id="fname" type="text" value="Mickey" />
Lastname: <input id="lname" type="text" value="Mouse" />
<input id="sub" type="button" value="Submit" />
</form>

<p>Get the value of all the elements in the form:<br />
<script type="text/javascript">
var x=document.getElementById("myForm");
for (var i=0;i<x.length;i++)
  {
  document.write(x.elements[i].value);
  document.write("<br />");
  document.write(x.elements[i].type);
  document.write("<br />");
  }
</script>
</p>

</body>
</html>

TIY

取得所有表单元素的值和类型

返回 HTML DOM Form 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM emptyCells 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM emptyCells 属性

返回HTML DOM Style 对象参考手册

定义和用法

emptyCells 属性设置是否显示表格中的空单元格（仅用于“分离边框”模式）。

语法：

Object.style.emptyCells=hide|show

可能的值

值 | 描述
hide | 默认。不在空单元格周围绘制边框。
show | 在空单元格周围绘制边框。

实例

本例改变空单元格的显示方式：

<html>
<head>
<script type="text/javascript">
function showEmptyCells()
{
document.getElementById('myTable').style.emptyCells="show"
}
</script>
</head>
<body>

<table border="1" id="myTable">
<tr>
<td>100</td>
<td>200</td>
</tr>
<tr>
<td>300</td>
<td></td>
</tr>
</table>

<input type="button" onclick="showEmptyCells()"
value="Show empty cells">

</body>
</html>

TIY

改变空单元格的显示方式

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM enctype 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM enctype 属性

返回 HTML DOM Form 对象参考手册

定义和用法

enctype 属性可设置或返回用于编码表单内容的 MIME 类型。

如果表单没有 enctype 属性，那么当提交文本时的默认值是 "application/x-www-form-urlencoded"。

当 input type 是 "file" 时，值是 "multipart/form-data"。

语法

formObject.encoding=encoding

实例

下面的例子可返回表单的编码类型：

<html>
<head>
<script type="text/javascript">
function showEnctype()
  {
  var x=document.getElementById("myForm")
  alert(x.enctype)
  }
</script>
</head>
<body>

<form id="myForm" enctype="application/x-www-form-urlencoded">
Name: <input type="text" value="Mickey Mouse" />
<input type="button" onclick="showEnctype()"
value="Show enctype" />
</form>

</body>
</html>

TIY

取得表单的编码类型。

返回 HTML DOM Form 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Event 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Event 对象

实例

哪个鼠标按钮被点击？

光标的坐标是？

被按的按键的 unicode 是？

相对于屏幕，光标的坐标是？

shift 键被按了吗？

哪个元素被点击了？

哪个事件类型发生了？

Event 对象

Event 对象代表事件的状态，比如事件在其中发生的元素、键盘按键的状态、鼠标的位置、鼠标按钮的状态。

事件通常与函数结合使用，函数不会在事件发生前被执行！

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet 标准).

事件句柄　(Event Handlers)

HTML 4.0 的新特性之一是能够使 HTML 事件触发浏览器中的行为，比如当用户点击某个 HTML 元素时启动一段 JavaScript。下面是一个属性列表，可将之插入 HTML 标签以定义事件的行为。

属性 | 此事件发生在何时... | IE | F | O | W3C
onabort | 图像的加载被中断。 | 4 | 1 | 9 | Yes
onblur | 元素失去焦点。 | 3 | 1 | 9 | Yes
onchange | 域的内容被改变。 | 3 | 1 | 9 | Yes
onclick | 当用户点击某个对象时调用的事件句柄。 | 3 | 1 | 9 | Yes
ondblclick | 当用户双击某个对象时调用的事件句柄。 | 4 | 1 | 9 | Yes
onerror | 在加载文档或图像时发生错误。 | 4 | 1 | 9 | Yes
onfocus | 元素获得焦点。 | 3 | 1 | 9 | Yes
onkeydown | 某个键盘按键被按下。 | 3 | 1 | No | Yes
onkeypress | 某个键盘按键被按下并松开。 | 3 | 1 | 9 | Yes
onkeyup | 某个键盘按键被松开。 | 3 | 1 | 9 | Yes
onload | 一张页面或一幅图像完成加载。 | 3 | 1 | 9 | Yes
onmousedown | 鼠标按钮被按下。 | 4 | 1 | 9 | Yes
onmousemove | 鼠标被移动。 | 3 | 1 | 9 | Yes
onmouseout | 鼠标从某元素移开。 | 4 | 1 | 9 | Yes
onmouseover | 鼠标移到某元素之上。 | 3 | 1 | 9 | Yes
onmouseup | 鼠标按键被松开。 | 4 | 1 | 9 | Yes
onreset | 重置按钮被点击。 | 4 | 1 | 9 | Yes
onresize | 窗口或框架被重新调整大小。 | 4 | 1 | 9 | Yes
onselect | 文本被选中。 | 3 | 1 | 9 | Yes
onsubmit | 确认按钮被点击。 | 3 | 1 | 9 | Yes
onunload | 用户退出页面。 | 3 | 1 | 9 | Yes

鼠标 / 键盘属性

属性 | 描述 | IE | F | O | W3C
altKey | 返回当事件被触发时，"ALT" 是否被按下。 | 6 | 1 | 9 | Yes
button | 返回当事件被触发时，哪个鼠标按钮被点击。 | 6 | 1 | 9 | Yes
clientX | 返回当事件被触发时，鼠标指针的水平坐标。 | 6 | 1 | 9 | Yes
clientY | 返回当事件被触发时，鼠标指针的垂直坐标。 | 6 | 1 | 9 | Yes
ctrlKey | 返回当事件被触发时，"CTRL" 键是否被按下。 | 6 | 1 | 9 | Yes
metaKey | 返回当事件被触发时，"meta" 键是否被按下。 | No | 1 | 9 | Yes
relatedTarget | 返回与事件的目标节点相关的节点。 | No | 1 | 9 | Yes
screenX | 返回当某个事件被触发时，鼠标指针的水平坐标。 | 6 | 1 | 9 | Yes
screenY | 返回当某个事件被触发时，鼠标指针的垂直坐标。 | 6 | 1 | 9 | Yes
shiftKey | 返回当事件被触发时，"SHIFT" 键是否被按下。 | 6 | 1 | 9 | Yes

IE 属性

除了上面的鼠标/事件属性，IE 浏览器还支持下面的属性：

属性 | 描述
cancelBubble | 如果事件句柄想阻止事件传播到包容对象，必须把该属性设为 true。
fromElement | 对于 mouseover 和 mouseout 事件，fromElement 引用移出鼠标的元素。
keyCode | 对于 keypress 事件，该属性声明了被敲击的键生成的 Unicode 字符码。对于 keydown 和 keyup 事件，它指定了被敲击的键的虚拟键盘码。虚拟键盘码可能和使用的键盘的布局相关。
offsetX,offsetY | 发生事件的地点在事件源元素的坐标系统中的 x 坐标和 y 坐标。
returnValue | 如果设置了该属性，它的值比事件句柄的返回值优先级高。把这个属性设置为 fasle，可以取消发生事件的源元素的默认动作。
srcElement | 对于生成事件的 Window 对象、Document 对象或 Element 对象的引用。
toElement | 对于 mouseover 和 mouseout 事件，该属性引用移入鼠标的元素。
x,y | 事件发生的位置的 x 坐标和 y 坐标，它们相对于用CSS动态定位的最内层包容元素。

标准 Event 属性

下面列出了 2 级 DOM 事件标准定义的属性。

属性 | 描述 | IE | F | O | W3C
bubbles | 返回一个布尔值，指示事件是否是起泡事件类型。 | No | 1 | 9 | Yes
cancelable | 返回一个指示布尔值，指示事件是否可拥可取消的默认动作。 | No | 1 | 9 | Yes
currentTarget | 返回其事件监听器触发该事件的元素。 | No | 1 | 9 | Yes
eventPhase | 返回事件传播的当前阶段。 |  |  |  | Yes
target | 返回触发此事件的元素（事件的目标节点）。 | No | 1 | 9 | Yes
timeStamp | 返回事件生成的日期和时间。 | No | 1 | 9 | Yes
type | 返回当前 Event 对象表示的事件的名称。 | 6 | 1 | 9 | Yes

标准 Event 方法

下面列出了 2 级 DOM 事件标准定义的方法。IE 的事件模型不支持这些方法：

方法 | 描述 | IE | F | O | W3C
initEvent() | 初始化新创建的 Event 对象的属性。 | No | 1 | 9 | Yes
preventDefault() | 通知浏览器不要执行与事件关联的默认动作。 | No | 1 | 9 | Yes
stopPropagation() | 终止事件在传播过程的捕获、目标处理或起泡阶段进一步传播。调用该方法后，该节点上处理该事件的处理程序将被调用，事件不再被分派到其他节点。 | No | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM FileUpload 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM FileUpload 对象

FileUpload 对象

在 HTML 文档中 <input type="file"> 标签每出现一次，一个 FileUpload 对象就会被创建。

该元素包含一个文本输入字段，用来输入文件名，还有一个按钮，用来打开文件选择对话框以便图形化选择文件。

该元素的 value 属性保存了用户指定的文件的名称，但是当包含一个 file-upload 元素的表单被提交的时候，浏览器会向服务器发送选中的文件的内容而不仅仅是发送文件名。

为安全起见，file-upload 元素不允许 HTML 作者或 JavaScript 程序员指定一个默认的文件名。HTML value 属性被忽略，并且对于此类元素来说，value 属性是只读的，这意味着只有用户可以输入一个文件名。当用户选择或编辑一个文件名，file-upload 元素触发 onchange 事件句柄。

您可以通过遍历表单的 elements[] 数组，或者通过使用 document.getElementById()来访问 FileUpload 对象。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet 标准).

FileUpload 对象的属性

属性 | 描述 | IE | F | O | W3C
accept | 设置或返回指示文件传输的 MIME 类型的 MIME 类型列表（逗号分隔）。 |  |  |  | Yes
accessKey | 设置或返回访问 FileUpload 对象的快捷键。 | 4 |  |  | Yes
alt | 设置或返回当浏览器不支持 <input type="file"> 时供显示的替代文字。 |  |  |  | Yes
defaultValue | 设置或返回 FileUpload 对象的初始值。 | 4 | 1 |  | Yes
disabled | 设置或返回是否禁用 FileUpload 对象。 | 4 |  |  | Yes
form | 返回对包含 FileUpload 对象的表单的引用。 | 4 | 1 |  | Yes
id | 设置或返回 FileUpload 对象的 id。 | 4 | 1 |  | Yes
name | 设置或返回 FileUpload 对象的名称。 | 4 | 1 |  | Yes
tabIndex | 设置或返回定义 FileUpload 对象的 tab 键控制次序的索引号。 | 4 |  |  | Yes
type | 返回表单元素的类型。对于 FileUpload ，则是 "file" 。 | 4 | 1 |  | Yes
value | 返回由用户输入设置的文本后，FileUpload 对象的文件名。 | 4 | 1 |  | Yes

Standard Properties

Property | Description | IE | F | O | W3C
className | Sets or returns the class attribute of an element | 5 | 1 | 9 | Yes
dir | Sets or returns the direction of text | 5 | 1 | 9 | Yes
lang | Sets or returns the language code for an element | 5 | 1 | 9 | Yes
title | Sets or returns an element's advisory title | 5 | 1 | 9 | Yes

FileUpload 对象的方法

方法 | 描述 | IE | F | O | W3C
blur() | 从 FileUpload 对象上移开焦点。 | 4 | 1 |  | Yes
focus() | 为 FileUpload 对象赋予焦点。 | 4 | 1 |  | Yes
select() | 选取 FileUpload 对象。 | 4 |  |  | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM focus() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM focus() 方法

返回 HTML DOM Window 对象参考手册

定义和用法

focus() 方法可把键盘焦点给予一个窗口。

语法

window.focus()

实例

下面的例子可确保新的窗口得到焦点：

<html>
<body>

<script type="text/javascript">
myWindow=window.open('','','width=200,height=100')
myWindow.document.write("This is 'myWindow'")
myWindow.focus()
</script>

</body>
</html>

TIY

把焦点给予新窗口
从新窗口移开焦点

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM focus() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM focus() 方法

返回 HTML DOM Anchor 对象参考手册

定义和用法

focus() 方法用于给予链接焦点。

语法

anchorObject.focus()

说明

该方法可滚动文档以使 Anchor 对象的位置变为可见。

实例

<html>
<head>
<style type="text/css">
a:active {color:green}
</style>

<script type="text/javascript">
function getfocus()
{document.getElementById('myAnchor').focus()}

function losefocus()
{document.getElementById('myAnchor').blur()}
</script>
</head>

<body>
<a id="myAnchor"
href="http://www.w3school.com.cn">Visit W3School.com.cn</a>
<br /><br/>
<input type="button" onclick="getfocus()" value="Get focus">
<input type="button" onclick="losefocus()" value="Lose focus">
</body>

</html>

TIY

使用 focus() 和 blur()

返回 HTML DOM Anchor 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM focus() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM focus() 方法

返回 HTML DOM Button 对象参考手册

定义和用法

focus() 方法用于向按钮赋予焦点。

语法

buttonObject.focus()

实例

下面的例子将在按钮上设置焦点：

<html>
<head>
<script type="text/javascript">
function setFocus()
  {
  document.getElementById('button1').focus()
  }
</script>
</head>
<body>

<form>
<input type="button" id="button1" value="Button1" />
<br />
<input type="button" onclick="setFocus()"
value="Set focus to Button 1" />
</form>

</body>
</html>

TIY

设置并从按钮上移开焦点

返回 HTML DOM Button 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM focus() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM focus() 方法

返回 HTML DOM Checkbox 对象参考手册

定义和用法

focus() 方法用于为 checkbox 赋予焦点。

语法

checkboxObject.focus()

实例

下面的例子设置或移开 checkbox 上的焦点：

<html>
<head>
<script type="text/javascript">
function setFocus()
  {
  document.getElementById('check1').focus()
  }
function loseFocus()
  {
  document.getElementById('check1').blur()
  }
</script>
</head>
<body>

<form>
<input type="checkbox" id="check1" />
<br />
<input type="button" onclick="setFocus()" value="Set focus" />
<input type="button" onclick="loseFocus()" value="Lose focus" />
</form>

</body>
</html>

TIY

设置并移开 checkbox 上的焦点

返回 HTML DOM Checkbox 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM focus() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM focus() 方法

返回 HTML DOM Select 对象参考手册

定义和用法

focus() 方法用于在密码域上设置焦点。

语法

passwordObject.focus()

实例

下面的例子可设置或移开密码域上的焦点：

<html>
<head>
<script type="text/javascript">
function setFocus()
  {
  document.getElementById('password1').focus()
  }
function loseFocus()
  {
  document.getElementById('password1').blur()
  }
</script>
</head>
<body>

<form>
<input type="password" id="password1" value="thgrt456" />
<input type="button" onclick="setFocus()" value="Set focus" />
<input type="button" onclick="loseFocus()" value="Lose focus" />
</form>

</body>
</html>

TIY

设置或移开密码域上的焦点

返回 HTML DOM Select 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM focus() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM focus() 方法

返回 HTML DOM Radio 对象参考手册

定义和用法

focus() 方法用于赋予单选按钮焦点。

语法

radioObject.focus()

实例

下面的例子可为 "Male" 单选按钮设置焦点：

<html>
<body>

<form>
Male: <input id="male" type="radio" name="Sex" value="Male" />
<br />
Female: <input id="female" type="radio" name="Sex" value="Female" />
</form>

<script type="text/javascript">
document.getElementById('male').focus();
</script>

</body>
</html>

TIY

向单选按钮设置焦点

返回 HTML DOM Radio 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM focus() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM focus() 方法

返回 HTML DOM Text 对象参考手册

定义和用法

focus() 方法用于赋予文本域焦点。

语法

textObject.focus()

实例

下面的例子可设置和移开文本域上的焦点：

<html>
<head>
<script type="text/javascript">
function setFocus()
  {
  document.getElementById('text1').focus()
  }
function loseFocus()
  {
  document.getElementById('text1').blur()
  }
</script>
</head>
<body>

<form>
<input type="text" id="text1" />
<br />
<input type="button" onclick="setFocus()" value="Set focus" />
<input type="button" onclick="loseFocus()" value="Lose focus" />
</form>

</body>
</html>

TIY

设置和移开文本域上的焦点

返回 HTML DOM Text 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM focus() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM focus() 方法

返回 HTML DOM Select 对象参考手册

定义和用法

focus() 方法用于赋予下拉列表焦点。

语法

selectObject.focus()

实例

下面的例子可为下拉列表设置焦点：

<html>
<head>
<script type="text/javascript">
function setFocus()
  {
  document.getElementById('select1').focus()
  }
</script>
</head>
<body>

<form>
<select id="select1">
  <option>Apple</option>
  <option>Pear</option>
  <option>Banana</option>
  <option>Orange</option>
</select>
<br /><br />
<input type="button" onclick="setFocus()" value="Set focus" />
</form>

</body>
</html>

TIY

设置并从下拉列表移开焦点

返回 HTML DOM Select 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM focus() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM focus() 方法

返回 HTML DOM Textarea 对象参考手册

定义和用法

focus() 方法用于给予该元素焦点。这样用户不必点击它，就能编辑显示的文本了。

语法

textareaObject.focus()

实例

下面的例子设置并移开了文本框上的焦点：

<html>
<head>
<script type="text/javascript">
function setFocus()
  {
  document.getElementById('txt1').focus()
  }
function loseFocus()
  {
  document.getElementById('txt1').blur()
  }
</script>
</head>
<body>

<textarea id="txt1">Hello world....</textarea>
<br />
<input type="button" onclick="setFocus()" value="Set focus" />
<input type="button" onclick="loseFocus()" value="Lose focus" />

</body>
</html>

返回 HTML DOM Textarea 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM font 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM font 属性

返回HTML DOM Style 对象参考手册

定义和用法

font 属性在一个声明中设置所有字体属性。

语法：

Object.style.font=value

可能的值

值 | 描述
  • fontStyle
  • fontVariant
  • fontWeight
  • fontSize/lineHeight
  • fontFamily
 设置字体的属性。
caption | 为控件定义字体（比如按钮、下拉列表等）。
icon | 定义用于标注图标的字体。
menu | 定义菜单中使用的字体。
message-box | 定义对话框中使用的字体。
small-caption | 定义用于标注小型控件的字体。
status-bar | 定义在窗口状态栏中使用的字体。

实例

本例改变文本的字体：

<html>
<head>
<script type="text/javascript">
function setFont()
{
document.getElementById("p1").style.font="italic bold 12px arial,serif";
}
</script>
</head>
<body>

<p id="p1">This is an example paragraph.</p>

<input type="button" onclick="setFont()" value="Change paragraph style" />

</body>
</html>

TIY

改变文本的字体

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM fontFamily 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM fontFamily 属性

返回HTML DOM Style 对象参考手册

定义和用法

fontFamily 属性定义用于元素文本显示的字体系列。

语法：

Object.style.fontFamily=font1,font2,....

可能的值

Value | Description
font1, font2,.... | 字体族名称或类组名称的列表，由逗号分割。

提示和注释

提示：使用逗号分割每个值，并始终提供一个类族名称作为最后的选择。

注释：如果字体族名称中含有空格，请为其加上引号。

实例

本例改变文本的字体系列：

<html>
<head>
<script type="text/javascript">
function setFont()
{
document.getElementById("p1").style.fontFamily="arial,sans-serif";
}
</script>
</head>
<body>

<p id="p1">This is an example paragraph.</p>

<input type="button" onclick="setFont()" value="Change font" />

</body>
</html>

TIY

fontFamily - 改变文本的字体系列

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM fontSize 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM fontSize 属性

返回HTML DOM Style 对象参考手册

定义和用法

fontSize 属性设置元素的字体大小。

语法：

Object.style.fontSize=value

可能的值

值 | 描述
  • xx-small
  • x-small
  • small
  • medium
  • large
  • x-large
  • xx-large

把字体的尺寸设置为不同的尺寸，从 xx-small 到 xx-large。

默认值：medium。
smaller | 把 font-size 设置为比父元素更小的尺寸。
larger | 把 font-size 设置为比父元素更大的尺寸。
length | 把 font-size 设置为一个固定的值。
% 把 font-size 设置为基于父元素的一个百分比。

实例

本例改变文本的字体大小：

<html>
<head>
<script type="text/javascript">
function setFontSize()
{
document.getElementById("p1").style.fontSize="larger";
}
</script>
</head>
<body>

<p id="p1">This is an example paragraph.</p>

<input type="button" onclick="setFontSize()"
value="Change font-size" />

</body>
</html>

TIY

fontSize - 改变文本的字体大小

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM fontSizeAdjust 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM fontSizeAdjust 属性

返回HTML DOM Style 对象参考手册

定义和用法

fontSizeAdjust 属性设置文本的尺寸。

字体的小写字母 "x" 的高度与 "font-size" 高度之间的比率被称为一个字体的 aspect 值。当字体拥有高的 aspect 值时，那么当此字体被设置为很小的尺寸时会更易阅读。举例：Verdana 的 aspect 值是 0.58（意味着当字体尺寸为 100px 时，它的 x-height 是 58px ）。Times New Roman 的 aspect 值是 0.46。这就意味着 Verdana 在小尺寸时比 Times New Roman 更易阅读。

该可为某个元素规定一个 aspect 值，这样就可以保持首选字体的 x-height。

语法：

Object.style.fontSizeAdjust=none|number

可能的值

值 | 描述
none | 默认。如果此字体不可用，则不保持此字体的 x-height。
number

定义字体的 aspect 值比率。

可使用的公式：

首选字体的字体尺寸 * （font-size-adjust 值 / 可用字体的 aspect 值）=可应用到可用字体的字体尺寸

举例：

如果 14px 的 Verdana（aspect 值是 0.58）不可用，但是某个可用的字体的 aspect 值是 0.46，那么替代字体的尺寸将是 14 * (0.58/0.46) = 17.65px。

实例

本例调节字体的大小：

<html>
<head>
<script type="text/javascript">
function adjustFontSize()
{
document.getElementById("p1").style.fontSizeAdjust="0.70";
}
</script>
</head>
<body>

<p id="p1">This is an example paragraph</p>

<input type="button" onclick="adjustFontSize()"
value="Adjust font-size" />

</body>
</html>

TIY

fontSizeAdjust - 调节字体的大小

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM fontSmoothingEnabled 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM fontSmoothingEnabled 属性

返回 HTML DOM Screen 对象参考手册

定义和用法

fontSmoothingEnabled 属性返回用户是否在显示控制面板中启用了字体平滑。

语法

sscreen.fontSmoothingEnabled

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>FontSmoothingEnabled: ")
document.write(screen.fontSmoothingEnabled + "</p>")
</script>
</body>

</html>

TIY

检测有关客户机的屏幕的细节

返回 HTML DOM Screen 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM fontStretch 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM fontStretch 属性

返回HTML DOM Style 对象参考手册

定义和用法

fontStretch 属性用于对当前的 font-family 进行伸缩变形。

语法：

Object.style.fontStretch=value

可能的值

值 | 描述
normal | 默认。把缩放比例设置为标准。
wider | 把伸展比例设置为更进一步的伸展值
narrower | 把收缩比例设置为更进一步的收缩值
  • ultra-condensed
  • extra-condensed
  • condensed
  • semi-condensed
  • semi-expanded
  • expanded
  • extra-expanded
  • ultra-expanded
 设置 font-family 的缩放比例。"ultra-condensed" 是最宽的值，而 "ultra-expanded" 是最窄的值。

实例

本例对字体进行伸展：

<html>
<head>
<script type="text/javascript">
function setFontStretch()
{
document.getElementById("p1").style.fontStretch="ultra-expanded";
}
</script>
</head>
<body>

<p id="p1">This is an example paragraph.</p>

<input type="button" onclick="setFontStretch()"
value="Stretch font" />

</body>
</html>

TIY

fontStretch - 伸展字体

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM fontStyle 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM fontStyle 属性

返回HTML DOM Style 对象参考手册

定义和用法

fontStyle 属性设置字体的风格。

语法：

Object.style.fontStyle=normal|italic|oblique

可能的值

值 | 描述
normal | 默认。浏览器显示一个标准的字体。
italic | 浏览器会显示一个斜体的字体。
oblique | 浏览器会显示一个倾斜的字体。

实例

本例向文本添加斜体样式：

<html>
<head>
<script type="text/javascript">
function setFontStyle()
{
document.getElementById("p1").style.fontStyle="italic";
}
</script>
</head>
<body>

<p id="p1">This is an example paragraph.</p>

<input type="button" onclick="setFontStyle()"
value="Change font-style" />

</body>
</html>

TIY

fontStyle - 改变文本的风格

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM fontVariant 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM fontVariant 属性

返回HTML DOM Style 对象参考手册

定义和用法

fontVariant 属性用于设置小型大写字母的字体显示文本

语法：

Object.style.fontVariant=normal|small-caps

可能的值

值 | 描述
normal | 默认。浏览器会显示一个标准的字体。
small-caps | 浏览器会显示小型大写字母的字体。

实例

本例把第一段设置为小型大写字母：

<html>
<head>
<script type="text/javascript">
function setSmallCaps()
{
document.getElementById("p1").style.fontVariant="small-caps";
}
</script>
</head>
<body>

<p id="p1">This is an example paragraph.</p>
<p>This is another example paragraph.</p>

<input type="button" onclick="setSmallCaps()"
value="Display small-caps font" />

</body>
</html>

TIY

fontVariant - 把文本设置为小型大写字母

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM fontWeight 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM fontWeight 属性

返回HTML DOM Style 对象参考手册

定义和用法

fontWeight 属性设置字符的粗细。

语法：

Object.style.fontWeight=value

可能的值

值 | 描述
normal | 默认。定义标准的字符。
bold | 定义粗体字符。
bolder | 定义更粗的字符。
lighter | 定义更细的字符。
  • 100
  • 200
  • 300
  • 400
  • 500
  • 600
  • 700
  • 800
  • 900
 定义由粗到细的字符。400 等同于 normal，而 700 等同于 bold。

实例

本例把第一段设置为粗体：

<html>
<head>
<script type="text/javascript">
function setFontWeight()
{
document.getElementById("p1").style.fontWeight="900";
}
</script>
</head>
<body>

<p id="p1">This is an example paragraph.</p>
<p>This is another example paragraph.</p>

<input type="button" onclick="setFontWeight()"
value="Display bold text" />

</body>
</html>

TIY

fontWeight - 把文本设置为粗体

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Form 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Form 对象

Form 对象

Form 对象代表一个 HTML 表单。

在 HTML 文档中 <form> 每出现一次，Form 对象就会被创建。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet 标准).

Form 对象的集合

集合 | 描述 | IE | F | O | W3C
elements[] | 包含表单中所有元素的数组。 | 5 | 1 | 9 | Yes

Form 对象的属性

属性 | 描述 | IE | F | O | W3C
acceptCharset | 服务器可接受的字符集。 | No | No | No | Yes
action | 设置或返回表单的 action 属性。 | 5 | 1 | 9 | Yes
enctype | 设置或返回表单用来编码内容的 MIME 类型。 | 6 | 1 | 9 | Yes
id | 设置或返回表单的 id。 | 5 | 1 | 9 | Yes
length | 返回表单中的元素数目。 | 5 | 1 | 9 | Yes
method | 设置或返回将数据发送到服务器的 HTTP 方法。 | 5 | 1 | 9 | Yes
name | 设置或返回表单的名称。 | 5 | 1 | 9 | Yes
target | 设置或返回表单提交结果的 Frame 或 Window 名。 | 5 | 1 | 9 | Yes

Standard Properties

属性 | 描述 | IE | F | O | W3C
className | Sets or returns the class attribute of an element | 5 | 1 | 9 | Yes
dir | Sets or returns the direction of text | 5 | 1 | 9 | Yes
lang | Sets or returns the language code for an element | 5 | 1 | 9 | Yes
title | Sets or returns an element's advisory title | 5 | 1 | 9 | Yes

Form 对象的方法

方法 | 描述 | IE | F | O | W3C
reset() | 把表单的所有输入元素重置为它们的默认值。 | 5 | 1 | 9 | Yes
submit() | 提交表单。 | 5 | 1 | 9 | Yes

Form 对象的事件句柄

事件句柄 | 描述 | IE | F | O | W3C
onreset | 在重置表单元素之前调用。 | 5 | 1 | 9 | Yes
onsubmit | 在提交表单之前调用。 | 5 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM form 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM form 属性

返回 HTML DOM Button 对象参考手册

定义和用法

form 属性可返回对包含该按钮的表单的引用。

如果包含该按钮，则返回一个 form 对象，如果未包含该按钮，则返回 null。

语法

buttonObject.form

实例

下面的例子可返回该按钮所属的表单的 id：

<html>
<body>

<form id="form1">
<button id="button1">Click me!</button>
</form>

<p>The form containing the button is:
<script type="text/javascript">
x=document.getElementById('button1');
document.write(x.form.id);
</script></p>

</body>
</html>

TIY

返回按钮所属的表单的 id

返回 HTML DOM Button 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM form 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM form 属性

返回 HTML DOM Button 对象参考手册

定义和用法

form 属性可返回对包含该按钮的表单的引用。

如果包含该按钮，则返回一个 form 对象，如果未包含该按钮，则返回 null。

语法

buttonObject.form

实例

下面的例子可返回包含按钮的表单的 id：

<html>
<body>

<form id="form1">
<input type="button" value="Click me!" id="button1" />
</form>

<p>The id of the form containing the button is:
<script type="text/javascript">
x=document.getElementById('button1');
document.write(x.form.id);
</script></p>

</body>
</html>

TIY

返回包含按钮的表单的 id

返回 HTML DOM Button 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM form 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM form 属性

返回 HTML DOM Checkbox 对象参考手册

定义和用法

form 属性返回对包含该元素的表单对象的引用。

语法

checkboxObject.form

实例

下面的例子返回了该 checkbox 所属的表单的 id：

<html>
<body>

<form id="form1">
<input type="checkbox" id="check1" />
</form>

<p>The form containing the checkbox is:
<script type="text/javascript">
x=document.getElementById('check1');
document.write(x.form.id);
</script></p>

</body>
</html>

TIY

取得 checkbox 所属的表单的 id

返回 HTML DOM Checkbox 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM form 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM form 属性

返回 HTML DOM Radio 对象参考手册

定义和用法

form 属性可返回对包含该按钮的表单的引用。

若成功，该属性返回一个表单对象。

语法

radioObject.form

实例

下面的例子将返回该单选按钮所属的表单的 id：

<html>
<body>

<form id="form1">
<input type="radio" id="radio1" />
</form>

<p>The id of the form containing the radio button is:
<script type="text/javascript">
x=document.getElementById('radio1');
document.write(x.form.id);
</script></p>

</body>
</html>

TIY

取得单选按钮所属的表单的 id

返回 HTML DOM Radio 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM form 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM form 属性

返回 HTML DOM Reset 对象参考手册

定义和用法

form 属性可返回对包含该重置按钮的表单的引用。

若成功，该属性返回一个表单对象。

语法

resetObject.form

实例

下面的例子将返回该重置按钮所属的表单的 id：

<html>
<body>

<form id="form1">
<input type="reset" id="reset1" />
</form>

<p>The id of the form containing the reset button is:
<script type="text/javascript">
x=document.getElementById('reset1');
document.write(x.form.id);
</script></p>

</body>
</html>

TIY

取得重置按钮所属的表单的 id

返回 HTML DOM Reset 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM form 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM form 属性

返回 HTML DOM Submit 对象参考手册

定义和用法

form 属性可返回对包含该确认按钮的表单的引用。

若成功，该属性返回一个表单对象。

语法

submitObject.form

实例

下面的例子将返回该确认按钮所属的表单的 id：

<html>
<body>

<form id="form1">
<input type="submit" id="submit1" />
</form>

<p>The id of the form containing the submit button is:
<script type="text/javascript">
x=document.getElementById('submit1');
document.write(x.form.id);
</script></p>

</body>
</html>

TIY

取得确认按钮所属的表单的 id

返回 HTML DOM Submit 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM form 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM disabled 属性

返回 HTML DOM Text 对象参考手册

定义和用法

form 属性可返回队包含该文本域的表单的引用。

若成功，该属性返回一个表单对象。

语法

textObject.form

实例

下面的例子为文本域所属的表单设置了 id：

<html>
<body>

<form id="form1">
<input type="text" id="text1" />
</form>

<p>The id of the form containing the text field is:
<script type="text/javascript">
x=document.getElementById('text1');
document.write(x.form.id);
</script></p>

</body>
</html>

TIY

获得文本域所属的表单的 id

返回 HTML DOM Text 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM form 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM disabled 属性

返回 HTML DOM Text 对象参考手册

定义和用法

id 属性设置或返回文本域的 id。

语法

textObject.id=id

实例

本例设置了该文本域的 id：

<html>
<body>

<form>
<input type="text" id="text1" />
</form>

<p>The id of the text field is:
<script type="text/javascript">
x=document.getElementById('text1');
document.write(x.id);
</script></p>

</body>
</html>

TIY

获得文本域的 id

返回 HTML DOM Text 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM form 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM form 属性

返回 HTML DOM Option 对象参考手册

定义和用法

form 属性可返回对包含选项的表单的引用。

语法

optionObject.form

实例

<html>
<body>

<form id="myForm">
<select id="mySelect">
  <option id="apple">Apple</option>
  <option id="orange">Orange</option>
  <option id="pineapple">Pineapple</option>
  <option id="banana">Banana</option>
</select>
</form>

<p>The id of the form is:
<script type="text/javascript">
document.write(document.getElementById("apple").form.id)
</script>
</p>

</body>
</html>

TIY

取得包含列表中选项的表单的 id

返回 HTML DOM Option 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM form 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM form 属性

返回 HTML DOM Select 对象参考手册

定义和用法

form 属性可返回对包含该下拉列表的表单元素的引用。

语法

selectObject.form

实例

<html>
<body>

<form id="myForm">
<select id="mySelect">
  <option>Apple</option>
  <option>Pear</option>
  <option>Banana</option>
  <option>Orange</option>
</select>
</form>

<p>The id of the form is:
<script type="text/javascript">
document.write(document.getElementById("mySelect").form.id)
</script>
</p>

</body>
</html>

TIY

取得包含该下拉列表的表单的 id

返回 HTML DOM Select 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM form 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM form 属性

返回 HTML DOM Select 对象参考手册

定义和用法

id 属性可设置或返回下拉列表的 id。

语法

selectObject.id=id

实例

下面的例子可返回下拉列表的 id：

<html>
<body>

<form id="myForm">
<select id="mySelect">
  <option>Apple</option>
  <option>Pear</option>
  <option>Banana</option>
  <option>Orange</option>
</select>
</form>

<p>The id of the dropdown list is:
<script type="text/javascript">
document.write(document.getElementById("mySelect").id)
</script>
</p>

</body>
</html>

TIY

取得下拉列表的 id

返回 HTML DOM Select 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM form 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM form 属性

返回 HTML DOM Textarea 对象参考手册

定义和用法

form 属性返回对包含该 text area 的 表单的引用。

若成功，则该属性返回一个 form 对象。

语法

textareaObject.form

实例

本例返回 text area 所属的表单的 id：

<html>
<body>

<form id="form1">
<textarea id="txt1">
Hello world....This is a text area
</textarea>
</form>

<p>The id of the form containing the text area is:
<script type="text/javascript">
x=document.getElementById('txt1');
document.write(x.form.id);
</script>
</p>

</body>
</html>

返回 HTML DOM Textarea 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM forms 集合

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM forms 集合

返回 HTML DOM Document 对象参考手册

定义和用法

forms 集合可返回对文档中所有 Form 对象的引用。

语法

document.forms[]

实例

<html>
<body>

<form name="Form1"></form>
<form name="Form2"></form>
<form name="Form3"></form>

<script type="text/javascript">
document.write("This document contains: ")
document.write(document.forms.length + " forms.")
</script>

</body>
</html>

TIY

计算文档中表单的数目
访问集合中的项目

返回 HTML DOM Document 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM forward() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM forward() 方法

返回 HTML DOM History 对象参考手册

定义和用法

forward() 方法可加载历史列表中的下一个 URL。

调用该方法的效果等价于点击前进按钮或调用 history.go(1)。

语法

history.forward()

实例

下面的例子可以在页面上创建一个前进按钮：

<html>
<head>
<script type="text/javascript">
function goForward()
  {
  window.history.forward()
  }
</script>
</head>
<body>

<input type="button" value="Forward" onclick="goForward()" />

</body>
</html>

返回 HTML DOM History 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Frame 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Frame 对象

Frame 对象

Frame 对象代表一个 HTML 框架。

在 HTML 文档中 <frame> 每出现一次，就会创建一个 Frame对象。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet 标准).

Frame 对象的属性

属性 | 描述 | IE | F | O | W3C
contentDocument | 容纳框架的内容的文档。 | No | 1 | 9 | Yes
frameBorder | 设置或返回是否显示框架周围的边框。 | 5 | 1 | 9 | Yes
id | 设置或返回框架的 id。 | 4 | 1 | 9 | Yes
longDesc | 设置或返回指向一个包含框架内容描述的文档的 URL。 | 6 | 1 | 9 | Yes
marginHeight | 设置或返回框架的顶部和底部页空白。 | 5 | 1 | 9 | Yes
marginWidth | 设置或返回框架的左边缘和右边缘的空白。 | 5 | 1 | 9 | Yes
name | 设置或返回框架的名称。 | 5 | 1 | 9 | Yes
noResize | 设置或返回框架是否可调整大小。 | 5 | 1 | 9 | Yes
scrolling | 设置或返回框架是否可拥有滚动条。 | No | 1 | No | Yes
src | 设置或返回应被加载到框架中的文档的 URL。 | 5 | 1 | 9 | Yes

Standard Properties

Property | Description | IE | F | O | W3C
className | Sets or returns the class attribute of an element | 5 | 1 | 9 | Yes
dir | Sets or returns the direction of text | 5 | 1 | 9 | Yes
lang | Sets or returns the language code for an element | 5 | 1 | 9 | Yes
title | Sets or returns an element's advisory title | 5 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM frame 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM frame 属性

返回 HTML DOM Table 对象参考手册

定义和用法

frame 属性可设置或返回表格的外部边框。

语法

tableObject.frame=void|above|below|hsides|vsides|lhs|rhs|box|border

实例

下面的例子设置了表格的两种不同的边框：

<html>
<head>
<script type="text/javascript">
function aboveFrames()
  {
  document.getElementById('myTable').frame="above"
  }
function belowFrames()
  {
  document.getElementById('myTable').frame="below"
  }
</script>
</head>
<body>

<table id="myTable">
<tr>
<td>100</td>
<td>200</td>
</tr>
<tr>
<td>300</td>
<td>400</td>
</tr>
</table>
<br />
<input type="button" onclick="aboveFrames()"
value="Show above frames">
<input type="button" onclick="belowFrames()"
value="Show below frames">

</body>
</html>

TIY

规定表格的外部边框

返回 HTML DOM Table 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM frameBorder 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM frameBorder 属性

返回 HTML DOM Frame 对象参考手册

定义和用法

frameBorder 属性设置或返回是否显示框架周围的边框。

如果不希望出现框架的边框，请把该属性设置为 0。

语法

frameObject.frameBorder=1|0

实例

在我们的例子中，首先将创建包含带有两个列的框架集的 HTML 文档。每列设置为浏览器窗口的 50%：

<html>
<frameset cols="50%,50%">
  <frame id="leftFrame" frameBorder="1"
  src="frame_frameborder.htm">
  <frame id="rightFrame" frameBorder="0" src="frame_a.htm" >
</frameset>
</html>

HTML 文档 "frame_frameborder.htm" 被放入第一列，而 HTML 文档 "frame_a.htm" 被放入第二列。

下面是 "frame_frameborder.htm" 的源代码：

<html>
<body>

<script type="text/javascript">
x=parent.document.getElementById("leftFrame");
y=parent.document.getElementById("rightFrame");

document.write("Frame border for leftFrame is: ");
document.write(x.frameBorder);

document.write("<br />Frame border for rightFrame is: ");
document.write(y.frameBorder);
</script>

</body>
</html>

TIY

返回框架的 frameBorder 属性

返回 HTML DOM Frame 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM frameBorder 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM frameBorder 属性

返回 HTML DOM Iframe 对象参考手册

定义和用法

frameBorder 属性可设置或返回是否显示 iframe 周围的边框。

把该属性设置为 0，可以获得无边框的框架。

语法

iframeObject.frameBorder=1|0

实例

本例可设置 iframe 是否拥有边框：

<html>
<head>
<script type="text/javascript">
function removeBorder()
  {
  document.getElementById("frame1").frameBorder="0";
  }
function restoreBorder()
  {
  document.getElementById("frame1").frameBorder="1";
  }
</script>
</head>
<body>

<iframe src="frame_a.htm" id="frame1"></iframe>
<br /><br />
<input type="button" onclick="removeBorder()"
value="Remove border" />
<input type="button" onclick="restoreBorder()"
value="Restore border" />

</body>
</html>

TIY

更改 iframe 的边框

返回 HTML DOM Iframe 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Frameset 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Frameset 对象

Frameset 对象

Frameset 对象代表一个 HTML 框架集。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet 标准).

Frameset 对象的属性

属性 | 描述 | IE | F | O | W3C
cols | 设置或返回框架集中列的数目。 | 5 | 1 | 9 | Yes
id | 设置或返回框架集的 id。 | 4 | 1 | 9 | Yes
rows | 设置或返回框架集中行的数目。 | 5 | 1 | 9 | Yes

Standard Properties

属性 | 描述 | IE | F | O | W3C
className | Sets or returns the class attribute of an element | 5 | 1 | 9 | Yes
dir | Sets or returns the direction of text | 5 | 1 | 9 | Yes
lang | Sets or returns the language code for an element | 5 | 1 | 9 | Yes
title | Sets or returns an element's advisory title | 5 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM getContext() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM getContext() 方法

返回 HTML DOM Canvas 对象参考手册

定义和用法

getContext() 方法返回一个用于在画布上绘图的环境。

语法

Canvas.getContext(contextID)

参数

参数 contextID 指定了您想要在画布上绘制的类型。当前唯一的合法值是 "2d"，它指定了二维绘图，并且导致这个方法返回一个环境对象，该对象导出一个二维绘图 API。

提示：在未来，如果 <canvas> 标签扩展到支持 3D 绘图，getContext() 方法可能允许传递一个 "3d" 字符串参数。

返回值

一个 CanvasRenderingContext2D 对象，使用它可以绘制到 Canvas 元素中。

描述

返回一个表示用来绘制的环境类型的环境。其本意是要为不同的绘制类型（2 维、3 维）提供不同的环境。当前，唯一支持的是 "2d"，它返回一个 CanvasRenderingContext2D 对象，该对象实现了一个画布所使用的大多数方法。

返回 HTML DOM Canvas 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM getElementById() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM getElementById() 方法

返回 HTML DOM Document 对象参考手册

定义和用法

getElementById() 方法可返回对拥有指定 ID 的第一个对象的引用。

语法

document.getElementById(id)

说明

HTML DOM 定义了多种查找元素的方法，除了 getElementById() 之外，还有 getElementsByName() 和 getElementsByTagName()。

不过，如果您需要查找文档中的一个特定的元素，最有效的方法是 getElementById()。

在操作文档的一个特定的元素时，最好给该元素一个 id 属性，为它指定一个（在文档中）唯一的名称，然后就可以用该 ID 查找想要的元素。

实例

例子 1

<html>
<head>
<script type="text/javascript">
function getValue()
  {
  var x=document.getElementById("myHeader")
  alert(x.innerHTML)
  }
</script>
</head>
<body>

<h1 id="myHeader" onclick="getValue()">This is a header</h1>
<p>Click on the header to alert its value</p>

</body>
</html>

例子 2

getElementById() 是一个重要的方法，在 DOM 程序设计中，它的使用非常常见。我们为您定义了一个工具函数，这样您就可以通过一个较短的名字来使用 getElementById() 方法了：

function id(x) {
  if (typeof x == "string") return document.getElementById(x);
  return x;
  }

上面这个函数接受元素 ID 作为它们的参数。对于每个这样的参数，您只要在使用前编写 x = id(x) 就可以了。

TIY

使用 getElementById()

返回 HTML DOM Document 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM getElementsByName() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM getElementsByName() 方法

返回 HTML DOM Document 对象参考手册

定义和用法

getElementsByName() 方法可返回带有指定名称的对象的集合。

语法

document.getElementsByName(name)

该方法与 getElementById() 方法相似，但是它查询元素的 name 属性，而不是 id 属性。

另外，因为一个文档中的 name 属性可能不唯一（如 HTML 表单中的单选按钮通常具有相同的 name 属性），所有 getElementsByName() 方法返回的是元素的数组，而不是一个元素。

实例

<html>
<head>
<script type="text/javascript">
function getElements()
  {
  var x=document.getElementsByName("myInput");
  alert(x.length);
  }
</script>
</head>
<body>

<input name="myInput" type="text" size="20" /><br />
<input name="myInput" type="text" size="20" /><br />
<input name="myInput" type="text" size="20" /><br />
<br />
<input type="button" onclick="getElements()"
value="How many elements named 'myInput'?" />

</body>
</html>

TIY

使用 getElementsByName()

返回 HTML DOM Document 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM getElementsByTagName() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM getElementsByTagName() 方法

返回 HTML DOM Document 对象参考手册

定义和用法

getElementsByTagName() 方法可返回带有指定标签名的对象的集合。

语法

document.getElementsByTagName(tagname)

说明

getElementsByTagName() 方法返回元素的顺序是它们在文档中的顺序。

如果把特殊字符串 "*" 传递给 getElementsByTagName() 方法，它将返回文档中所有元素的列表，元素排列的顺序就是它们在文档中的顺序。

提示和注释

注释：传递给 getElementsByTagName() 方法的字符串可以不区分大小写。

实例

例子 1

<html>
<head>
<script type="text/javascript">
function getElements()
  {
  var x=document.getElementsByTagName("input");
  alert(x.length);
  }
</script>
</head>
<body>

<input name="myInput" type="text" size="20" /><br />
<input name="myInput" type="text" size="20" /><br />
<input name="myInput" type="text" size="20" /><br />
<br />
<input type="button" onclick="getElements()"
value="How many input elements?" />

</body>
</html>

例子 2

可以用 getElementsByTagName() 方法获取任何类型的 HTML 元素的列表。例如，下面的代码可获取文档中所有的表：

var tables = document.getElementsByTagName("table");
alert ("This document contains " + tables.length + " tables");

例子 3

如果您非常了解文档的结构，也可以使用 getElementsByTagName() 方法获取文档中的一个特定的元素。例如，下面的代码可以获得文档中的第四个段落：

var myParagragh = document.getElementsByTagName("p")[3];

不过，我们还是认为，如果您需要操作某个特定的元素，使用 getElementById() 方法将更为有效。

TIY

使用 getElementsByTagName()

返回 HTML DOM Document 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM go() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM go() 方法

返回 HTML DOM History 对象参考手册

定义和用法

go() 方法可加载历史列表中的某个具体的页面。

语法

history.go(number|URL)

说明

URL 参数使用的是要访问的 URL，或 URL 的子串。而 number 参数使用的是要访问的 URL 在 History 的 URL 列表中的相对位置。

实例

下面例子会加载历史列表中的前一个页面：

<html>
<head>
<script type="text/javascript">
function goBack()
  {
  window.history.go(-1)
  }
</script>
</head>
<body>

<input type="button" value="Back" onclick="goBack()" />

</body>
</html>

返回 HTML DOM History 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM hash 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM hash 属性

返回 HTML DOM Location 对象参考手册

定义和用法

hash 属性是一个可读可写的字符串，该字符串是 URL 的锚部分（从 # 号开始的部分）。

语法

location.hash=anchorname

实例

假设当前的 URL 是: http://example.com:1234/test.htm#part2：

<html>
<body>

<script type="text/javascript">
document.write(location.hash);
</script>

</body>
</html>

输出：

#part2

TIY

使用 location 对象的 hash 属性
锚的数组
本例打开两个窗口。第一个窗口中包含四个按钮。第二个窗口定义了四个锚。当点击第一个窗口中的某个按钮时，onclick 事件句柄会到达第二个窗口指定的锚。

返回 HTML DOM Location 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM hash 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM hash 属性

返回 HTML DOM Area 对象参考手册

定义和用法

hash 属性可设置或返回一个区域中 URL 的锚部分。

语法

areaObject.hash=anchorname

实例

下面的例子可把 URL 的锚部分 #top 更改为 #bottom：

<html>
<head>
<script type="text/javascript">
function changeLink()
  {
  document.getElementById('venus').hash="bottom"
  }
</script>
</head>
<body>

<img src="planets.gif"
width="145" height="126"
usemap="#planetmap" />

<map name="planetmap">
<area id="venus" shape="circle"
coords="124,58,8"
alt="Venus"
href="venus2.htm#top" />
</map>

<input type="button" onclick="changeLink()" value="Change link" />

</body>
</html>

TIY

更改一个区域中 URL 的锚部分

返回 HTML DOM Area 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM height 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM height 属性

返回 HTML DOM Screen 对象参考手册

定义和用法

height 属性声明了显示浏览器的屏幕的高度，以像素计。

语法

screen.height

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>Height: ")
document.write(screen.height + "</p>")
</script>
</body>

</html>

TIY

检测有关客户机的屏幕的细节

返回 HTML DOM Screen 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM height 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM height 属性

返回 HTML DOM Iframe 对象参考手册

定义和用法

height 属性可设置或返回 iframe 的高度（以像素或百分比为单位）。

语法

iframeObject.height=pixels

实例

下面的例子可更改 iframe 的高度：

<html>
<head>
<script type="text/javascript">
function changeHeight()
  {
  document.getElementById("frame1").height="200";
  }
</script>
</head>
<body>

<iframe src="frame_a.htm" id="frame1" height="100"></iframe>
<br /><br />

<input type="button" onclick="changeHeight()"
value="Change height" />

</body>
</html>

TIY

更改 iframe 的高度和宽度

返回 HTML DOM Iframe 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM height 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM height 属性

返回 HTML DOM Image 对象参考手册

定义和用法

height 属性可设置或返回图像的高度。

语法

imageObject.height=pixels

实例

下面的例子可设置图像的高度和宽度：

<html>
<head>
<script type="text/javascript">
function changeSize()
{
document.getElementById("compman").height="250"
document.getElementById("compman").width="300"
}
</script>
</head>

<body>
<img id="compman" src="compman.gif" width="107" height="98" />
<br /><br />
<input type="button" onclick="changeSize()"
value="Change size of image">
</body>

</html>

TIY

更改图像的高度和宽度

返回 HTML DOM Image 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM height 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM height 属性

返回HTML DOM Style 对象参考手册

定义和用法

height 属性设置元素的高度。

语法：

Object.style.height=auto|length|%

可能的值

值 | 描述
auto | 默认。浏览器会计算出实际的高度。
length | 使用 px、cm 等单位定义高度。
% | 基于其包含块的百分比高度。

实例

本例设置按钮的高度：

<html>
<head>
<script type="text/javascript">
function setHeight()
{
document.getElementById("b1").style.height="50px";
}
</script>
</head>
<body>

<input type="button" id="b1" onclick="setHeight()"
value="Change height of button to 50 px" />

</body>
</html>

TIY

height - 设置元素的高度

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Hidden 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Hidden 对象

Hidden 对象

Hidden 对象代表一个 HTML 表单中的某个隐藏输入域。

这种类型的输入元素实际上是隐藏的。这个不可见的表单元素的 value 属性保存了一个要提交给 Web 服务器的任意字符串。如果想要提交并非用户直接输入的数据的话，就是用这种类型的元素。

在 HTML 表单中 <input type="hidden"> 标签每出现一次，一个 Hidden object就会被创建。

您可通过遍历表单的 elements[] 数组来访问某个隐藏输入域，或者通过使用document.getElementById()。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet 标准).

Hidden 对象的属性

属性 | 描述 | IE | F | O | W3C
alt | 设置或返回当浏览器不支持隐藏输入域时供显示的替代文本。 | 5 | 1 | 9 | Yes
form | 返回一个对包含隐藏域的表单的引用。 | 4 | 1 | 9 | Yes
id | 设置或返回隐藏域的 id。 | 4 | 1 | 9 | Yes
name | 设置或返回隐藏域的名称。 | 4 | 1 | 9 | Yes
type | 返回隐藏输入域的表单类型。 | 4 | 1 | 9 | Yes
value | 设置或返回隐藏域的 value 属性的值。 | 4 | 1 | 9 | Yes

Standard Properties

Property | Description | IE | F | O | W3C
className | Sets or returns the class attribute of an element | 5 | 1 | 9 | Yes
dir | Sets or returns the direction of text | 5 | 1 | 9 | Yes
lang | Sets or returns the language code for an element | 5 | 1 | 9 | Yes
title | Sets or returns an element's advisory title | 5 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM History 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM History 对象

History 对象

History 对象实际上是 JavaScript 对象，而不是 HTML DOM 对象。

History 对象是由 JavaScript runtime engine 自动创建的，由一系列的 URL 组成。这些 URL 是用户在一个浏览器窗口内已访问的 URL 。

History 对象最初设计来表示窗口的浏览历史。但出于隐私方面的原因，History 对象不再允许脚本访问已经访问过的实际 URL。唯一保持使用的功能只有 back()、forward() 和 go() 方法。

History 对象是 window 对象的一部分，可通过 window.history 属性对其进行访问。

IE: Internet Explorer, F: Firefox, O: Opera.

History 对象的属性

属性 | 描述 | IE | F | O
length | 返回浏览器历史列表中的 URL 数量 | 4 | 1 | 9

History 对象的方法

方法 | 描述 | IE | F | O
back() | 加载 history 列表中的前一个 URL | 4 | 1 | 9
forward() | 加载 history 列表中的下一个 URL | 4 | 1 | 9
go() | 加载 history 列表中的某个具体页面 | 4 | 1 | 9

HTML DOM 参考手册
HTML DOM 实例


HTML DOM host 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM host 属性

返回 HTML DOM Location 对象参考手册

定义和用法

host 属性是一个可读可写的字符串，可设置或返回当前 URL 的主机名称和端口号。

语法

location.host

实例

假设当前的 URL 是: http://example.com:1234/test.htm#part2：

<html>
<body>

<script type="text/javascript">
document.write(location.host);
</script>

</body>
</html>

输出：

example.com:1234

TIY

使用 location 对象的 host 属性

返回 HTML DOM Location 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM host 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM host 属性

返回 HTML DOM Area 对象参考手册

定义和用法

host 属性可设置或返回 URL 的主机名和端口。

语法

areaObject.host=host

实例

下面的例子可返回 "Venus" 区域的主机名和端口：

<html>
<body>

<img src="planets.gif"
width="145" height="126"
usemap="#planetmap" />

<map name="planetmap">
<area id="venus" shape="circle"
coords="124,58,8"
alt="Venus"
href="venus.htm" />
</map>

<p>The hostname and port for the "Venus" area are:
<script type="text/javascript">
x=document.getElementById('venus');
document.write(x.host);
</script>
</p>

</body>
</html>

TIY

返回图像映射中某个区域的链接的主机名和端口

返回 HTML DOM Area 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM hostname 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM hostname 属性

返回 HTML DOM Location 对象参考手册

定义和用法

hostname 属性是一个可读可写的字符串，可设置或返回当前 URL 的主机名。

语法

location.hostname

实例

假设当前的 URL 是: http://example.com:1234/test.htm#part2：

<html>
<body>

<script type="text/javascript">
document.write(location.hostname);
</script>

</body>
</html>

输出：

example.com

TIY

使用 location 对象的 hostname 属性

返回 HTML DOM Location 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM href 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM href 属性

返回 HTML DOM Location 对象参考手册

定义和用法

href 属性是一个可读可写的字符串，可设置或返回当前显示的文档的完整 URL。

因此，我们可以通过为该属性设置新的 URL，使浏览器读取并显示新的 URL 的内容。

语法

location.href=URL

实例

假设当前的 URL 是: http://example.com:1234/test.htm#part2：

<html>
<body>

<script type="text/javascript">
document.write(location.href);
</script>

</body>
</html>

输出：

http://example.com:1234/test.htm#part2

TIY

使用 location 对象的 href 属性

返回 HTML DOM Location 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM href 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM href 属性

返回 HTML DOM Anchor 对象参考手册

定义和用法

href 属性可设置或返回被链资源的 URL。

语法

anchorObject.href=URL

实例

下面的例子将更改一个链接的文本、URL 以及 target：

<html>
<head>
<script type="text/javascript">
function changeLink()
{
document.getElementById('myAnchor').innerHTML="W3School";
document.getElementById('myAnchor').href="http://www.w3school.com.cn";
document.getElementById('myAnchor').target="_blank";
}
</script>
</head>

<body>
<a id="myAnchor" href="http://www.microsoft.com">Microsoft</a>
<input type="button" onclick="changeLink()" value="Change link">
</body>

</html>

TIY

更改一个链接的文本、URL 以及 target

返回 HTML DOM Anchor 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM href 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM href 属性

返回 HTML DOM Area 对象参考手册

定义和用法

href 属性可设置或返回图像映射中链接的 URL。

语法

areaObject.href=URL

实例

下面的例子讲更改图像映射中某个区域的链接：

<html>
<head>
<script type="text/javascript">
function changeLink()
  {
  document.getElementById('venus').href="http://www.w3school.com.cn"
  }
</script>
</head>
<body>

<img src="planets.gif"
width="145" height="126"
usemap="#planetmap" />

<map name="planetmap">
<area id="venus" shape="circle"
coords="124,58,8"
alt="Venus"
href="venus.htm" />
</map>

<input type="button" onclick="changeLink()" value="Change link" />

</body>
</html>

TIY

图像映射中某个链接的 URL

返回 HTML DOM Area 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM href 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM href 属性

返回 HTML DOM Base 对象参考手册

定义和用法

href 属性可设置或返回页面中所有链接的基准 URL。

语法

baseObject.href=URL

实例

下面的例子可返回基准 URL：

<html>
<head>
<base id="myBaseId" href="http://www.w3school.com.cn/htmldom/" />
</head>

<body>
<p>Base URL:
<script type="text/javascript">
x=document.getElementById('myBaseId');
document.write(x.href);
</script>
</p>

</body>
</html>

输出：

Base URL: http://www.w3school.com.cn/htmldom/

TIY

取得 HTML 文档的基准 URL

返回 HTML DOM Base 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM href 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM href 属性

返回 HTML DOM Link 对象参考手册

定义和用法

The href property sets or returns the URL of the linked resource.

语法

linkObject.href=URL

实例

The following example changes style sheet:

<html>
<head>
<link rel="stylesheet" type="text/css"
id="style1" href="try_dom_link.css" />

<script type="text/javascript">
function changeStyle()
{
document.getElementById("style1").href="try_dom_link2.css"
}
</script>
</head>
<body>

<form>
<input type="button" id="button1" onclick="changeStyle()"
value="Change style sheet" />
</form>

</body>
</html>

TIY

Change a style sheet link

返回 HTML DOM Link 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM hreflang 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM hreflang 属性

返回 HTML DOM Anchor 对象参考手册

定义和用法

hreflang 属性可设置或返回被链资源的语言代码。

语法

anchorObject.hreflang=languagecode

实例

下面的例子将返回被链资源的语言代码：

<html>
<body>

<p><a id="myAnchor" hreflang="zh-cn"
href="http://www.w3school.com.cn">W3School.com.cn</a></p>

<script type="text/javascript">
x=document.getElementById("myAnchor");
document.write(x.hreflang);
</script>

</body>
</html>

TIY

取得被链资源的语言代码

返回 HTML DOM Anchor 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM hreflang 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM hreflang 属性

返回 HTML DOM Link 对象参考手册

定义和用法

The hreflang property sets or returns the base language of the target URL.

语法

linkObject.hreflang=languagecode

实例

The following example returns the language code of the link element:

<html>
<head>
<link rel="stylesheet" type="text/css"
hreflang="us-en" id="style1" href="try_dom_link.css" />
</head>
<body>

<script type="text/javascript">
x=document.getElementById("style1");
document.write("Language code=" + x.hreflang);
</script>

</body>
</html>

TIY

Get the language code of a <link> element

返回 HTML DOM Link 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM hspace 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM hspace 属性

返回 HTML DOM Image 对象参考手册

定义和用法

hspace 属性可设置或返回图像的左边缘和右边缘的空白。

hspace 和 vspace 属性可与 align 一同使用，来设置图像与周围文本的距离。

语法

imageObject.hspace=pixels

实例

下面的例子将设置图像的 hspace 和 vspace 属性：

<html>
<head>
<script type="text/javascript">
function setSpace()
{
document.getElementById("compman").hspace="50"
document.getElementById("compman").vspace="50"
}
</script>
</head>
<body>

<img id="compman" src="compman.gif" alt="Computerman" align="right" />

<p>Some text. Some text. Some text. Some text.</p>

<input type="button" onclick="setSpace()"
value="Set hspace and vspace">

</body>
</html>

TIY

设置图像的水平和垂直定位

返回 HTML DOM Image 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM httpEquiv 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM httpEquiv 属性

返回 HTML DOM Meta 对象参考手册

定义和用法

httpEquiv 属性把 content 属性连接到 HTTP 头部。

语法

metaObject.httpEquiv=content-type|expires|refresh|set-cookie

实例

本例每 5 秒刷新页面：

<html>
<head>
<meta http-equiv="refresh" content="5" />
</head>
<body>

<script type="text/javascript">
x=document.getElementsByTagName("meta")[0];
document.write("Http equiv: " + x.httpEquiv);
</script>

</body>
</html>

TIY

每 5 秒刷新页面
5 秒后重定向页面

返回 HTML DOM Meta 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM Anchor 对象参考手册

定义和用法

id 属性可返回一个链接的 id。

语法

anchorObject.id=ide

实例

下面的例子可输出一个链接的 id：

<html>
<body>

<p><a id="myAnchor"
href="http://www.w3school.com.cn">Visit W3School.com.cn</a></p>

<script type="text/javascript">
x=document.getElementById("myAnchor");
document.write(x.id);
</script>

</body>
</html>

TIY

取得链接的 id

返回 HTML DOM Anchor 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM Area 对象参考手册

定义和用法

id 属性可设置或返回图像映射中某个区域的 id。

语法

areaObject.id=id

实例

下面的例子可返回图像映射中 "Venus" 区域的 id：

<html>
<body>

<img src="planets.gif"
width="145" height="126"
usemap="#planetmap" />

<map name="planetmap">
<area id="venus" shape="circle"
coords="124,58,8"
alt="Venus"
href="venus.htm" />
</map>

<p>"Venus" area id =
<script type="text/javascript">
x=document.getElementById('venus');
document.write(x.id);
</script>
</p>

</body>
</html>

TIY

返回图像映射中某个区域的 id

返回 HTML DOM Area 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM Base 对象参考手册

定义和用法

id 属性可设置或返回 <base> 元素的 id。

语法

baseObject.id=id

实例

下面的例子可返回 <base> 元素的 id：

<html>
<head>
<base id="myBaseId" href="http://www.w3school.com.cn/htmldom/" />
</head>

<body>
<p>Base id:
<script type="text/javascript">
x=document.getElementsByTagName('base')[0];
document.write(x.id);
</script>
</body>

</html>

输出：

Base id: myBaseId

TIY

取得 HTML 文档的 base id

返回 HTML DOM Base 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM Body 对象参考手册

定义和用法

id 属性设置或返回 body 元素的 id。

语法

bodyObject.id=id

实例

下面的例子将展示设置 <body> 元素的 id 的两种方法：

<html>
<body id="myid">

<script type="text/javascript">
x=document.getElementsByTagName('body')[0];
document.write("Body id: " + x.id);
document.write("<br />");
document.write("An alternate way: ");
document.write(document.getElementById('myid').id);
</script>

</body>
</html>

输出：

Body id: myid
An alternate way: myid

TIY

返回 <body> 元素的 id

返回 HTML DOM Body 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM Button 对象参考手册

定义和用法

id 属性可设置或返回按钮的 id。

语法

buttonObject.id=id

实例

下面的例子可设置按钮的 id：

<html>
<head>
<script type="text/javascript">
function alertId()
{
alert(document.getElementById("myButton").id)
}
</script>
</head>
<body>

<form>
<button id="myButton" onClick="alertId()">
Click me!</button>
</form>

</body>
</html>

TIY

提示按钮的 id 和 类型 + 禁用按钮

返回 HTML DOM Button 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM Form 对象参考手册

定义和用法

id 属性可设置或返回表单的 id。

语法

formObject.id=id

实例

下面的例子展示了两种返回 <form> 元素的 id 的方法：

<html>
<body>

<form id="myForm">
Text: <input type="text" size="20" value="Hello World" />
</form>

<script type="text/javascript">
x=document.getElementsByTagName('form')[0];
document.write("Form id: " + x.id);
document.write("<br />");
document.write("An alternate way: ");
document.write(document.getElementById('myForm').id);
</script>

</body>
</html>

TIY

从 <form> 元素取得 id

返回 HTML DOM Form 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM Frame 对象参考手册

定义和用法

id 属性可返回框架的 id。

语法

frameObject.id=id

实例

在我们的例子中，首先将创建包含带有两个列的框架集的 HTML 文档。每列设置为浏览器窗口的 50%：

<html>
<frameset cols="50%,50%">
  <frame id="leftFrame" src="frame_id.htm">
  <frame id="rightFrame" src="frame_a.htm" >
</frameset>
</html>

HTML 文档 "frame_id.htm" 被放入第一列，而 HTML 文档 "frame_a.htm" 被放入第二列。

下面是 "frame_id.htm" 的源代码：

<html>
<body>

<script type="text/javascript">
x=parent.document.getElementsByTagName("frame")[0];
y=parent.document.getElementsByTagName("frame")[1];

document.write("The id for the left frame is: ");
document.write(x.id);

document.write("<br />The id for the right frame is: ");
document.write(y.id);
</script>

</body>
</html>

TIY

返回框架的 id

返回 HTML DOM Frame 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM Frameset 对象参考手册

定义和用法

id 属性可设置或返回框架集的 id。

语法

framesetObject.id=id

实例

在我们的例子中，首先将创建包含带有两个列的框架集的 HTML 文档。每列设置为浏览器窗口的 50%：

<html>
<frameset id="main" cols="50%,50%">
  <frame id="leftFrame" src="frame_frameset_id.htm">
  <frame id="rightFrame" src="frame_a.htm" >
</frameset>
</html>

HTML 文档 "frame_frameset_id.htm" 被放入第一列，而 HTML 文档 "frame_a.htm" 被放入第二列。

下面是 "frame_frameset_id.htm" 的源代码：

<html>
<head>
<script type="text/javascript">
function showFrameId()
  {
  var txt="Frameset Id: "
  txt=txt + parent.document.getElementById("main").id
  alert(txt)
  }
</script>
</head>
<body>

<input type="button" onclick="showFrameId()"
value="Show Frameset Id" />

</body>
</html>

TIY

取得 <frameset> 元素的 id

返回 HTML DOM Frameset 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM Iframe 对象参考手册

定义和用法

id 属性可设置或返回 iframe 的 id。

语法

iframeObject.id=id

实例

本例展示了两种返回 iframe 的 id 的方法：

<html>
<body>

<iframe src="frame_a.htm" id="frame1"></iframe>
<br /><br />

<script type="text/javascript">
document.write("The iframe's id: ");
document.write(document.getElementsByTagName("iframe")[0].id);
document.write("<br /><br />");

document.write("An alternate way: ");
document.write("<br />");
document.write("The iframe's id: ");
document.write(document.getElementById("frame1").id);
</script>

</body>
</html>

TIY

返回 <iframe> 元素的 id

返回 HTML DOM Iframe 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM Image 对象参考手册

定义和用法

id 属性可设置或返回图像的 id。

语法

imageObject.id=id

实例

下面的例子将通过两种方法来返回图像的 id：

<html>
<body>
<img id="compman" src="compman.gif" alt="Computerman" />
<br />

<script type="text/javascript">
x=document.getElementsByTagName('img')[0];
document.write("Image id: " + x.id);
document.write("<br />");
document.write("An alternate way: ");
document.write(document.getElementById('compman').id);
</script>

</body>
</html>

TIY

取得图像的 id

返回 HTML DOM Image 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM Button 对象参考手册

定义和用法

id 属性可设置或返回按钮的 id。

语法

buttonObject.id=id

实例

下面的例子可获取按钮的 id：

<html>
<head>
<script type="text/javascript">
function alertId()
{
alert(document.getElementById("myButton").id)
}
</script>
</head>

<body>
<form>
<input type="button" value="Click me!" id="myButton"
onclick="alertId()" />
</form>
</body>

</html>

TIY

提示按钮的 id、类型和值 + 禁用按钮

返回 HTML DOM Button 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM Checkbox 对象参考手册

定义和用法

id 属性可设置或返回 checkbox 的 id。

语法

checkboxObject.id=id

实例

下面的例子可输出 checkbox 的 id：

<html>
<body>

<form>
<input type="checkbox" id="check1" />
</form>

<p>The id of the checkbox is:
<script type="text/javascript">
document.write(document.getElementById("check1").id)
</script>
</p>

</body>
</html>

TIY

取得 checkbox 的 id

返回 HTML DOM Checkbox 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM Hidden 对象参考手册

定义和用法

id 属性可设置或返回隐藏输入域的 id。

语法

hiddenObject.id=id

实例

下面的例子可取得隐藏输入域的 id：

<html>
<body>

<form>
<input type="hidden" id="hidden1" />
</form>

<p>The id of the hidden field is:
<script type="text/javascript">
x=document.getElementById('hidden1');
document.write(x.id);
</script></p>

</body>
</html>

TIY

取得隐藏输入域的 id

返回 HTML DOM Hidden 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM Password 对象参考手册

定义和用法

id 属性设置或返回密码域的 id。

语法

passwordObject.id=id

实例

下面的例子返回了该密码域的 id：

<html>
<body>

<form id="form1">
<input type="password" id="password1" />
</form>

<p>The id of the password field is:
<script type="text/javascript">
x=document.getElementById('password1');
document.write(x.id);
</script></p>

</body>
</html>

TIY

取得密码域的 id

返回 HTML DOM Password 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM Radio 对象参考手册

定义和用法

id 属性可设置或返回单选按钮的 id。

语法

radioObject.id=id

实例

下面的例子可提示出单选按钮的 id：

<html>
<body>

<form>
<input type="radio" id="radio1" />
</form>

<p>The id of the radio button is:
<script type="text/javascript">
x=document.getElementById('radio1');
document.write(x.id);
</script>
</p>

</body>
</html>

TIY

显示出一个单选按钮的 id、类型和值

返回 HTML DOM Radio 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM Radio 对象参考手册

定义和用法

name 属性可设置或返回单选按钮的名称。

语法

radioObject.name=name

实例

下面的例子可显示出该单选按钮的名称：

<html>
<body>

<form>
<input type="radio" id="radio1" name="radio1" />
</form>

<p>The name of the radio button is:
<script type="text/javascript">
x=document.getElementById('radio1');
document.write(x.name);
</script></p>

</body>
</html>

TIY

取得一个单选按钮的名称

返回 HTML DOM Radio 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM Reset 对象参考手册

定义和用法

id 属性可设置或返回重置按钮的 id。

语法

resetObject.id=id

实例

下面的例子可获得出重置按钮的 id：

<html>
<head>
<script type="text/javascript">
function alertId()
{
alert(document.getElementById("reset1").id)
}
</script>
</head>

<body>
<form>
<input type="reset" id="reset1" onclick="alertId()" />
</form>
</body>

</html>

TIY

提示重置按钮的 id、类型和值 + 禁用按钮

返回 HTML DOM Reset 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM Submit 对象参考手册

定义和用法

id 属性可设置或返回确认按钮的 id。

语法

submitObject.id=id

实例

下面的例子可提示出确认按钮的 id：

<html>
<head>
<script type="text/javascript">
function alertId()
{
alert(document.getElementById("submit1").id)
}
</script>
</head>

<body>
<form>
<input type="submit" id="submit1" onclick="alertId()" />
</form>
</body>

</html>

TIY

提示确认按钮的 id、类型和值 + 禁用按钮

返回 HTML DOM Submit 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM Link 对象参考手册

定义和用法

The id property sets or returns the id of a link element.

语法

linkObject.id=id

实例

The following example outputs the id of a link element:

<html>
<head>
<link rel="stylesheet" type="text/css"
id="style1" href="try_dom_link.css" />
</head>
<body>

<script type="text/javascript">
x=document.getElementById("style1");
document.write("Id of link=" + x.id);
</script>

</body>
</html>

TIY

Get the id of a <link> element

返回 HTML DOM Link 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM Option 对象参考手册

定义和用法

id 属性可设置或返回下拉列表中选项的 id。

语法

optionObject.id=id

实例

下面的例子可返回下拉列表中所选选项的 id：

<html>
<head>
<script type="text/javascript">
function alertOptionId()
{
var x=document.getElementById("mySelect").selectedIndex;
alert(document.getElementsByTagName("option")[x].id);
}
</script>
</head>
<body>

<form>
Select your favorite fruit:
<select id="mySelect">
  <option id="apple">Apple</option>
  <option id="orange">Orange</option>
  <option id="pineapple">Pineapple</option>
  <option id="banana">Banana</option>
</select>
<br /><br />
<input type="button" onclick="alertOptionId()" value="Alert id">
</form>

</body>
</html>

TIY

取得下拉列表中所选选项的 id

返回 HTML DOM Option 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM Table 对象参考手册

定义和用法

idr 属性可设置或返回表格的 id。

语法

tableObject.id=id

实例

<html>
<head>
<script type="text/javascript">
function alertId()
  {
  alert(document.getElementById("table1").id);
  }
</script>
</head>
<body>

<table id="table1" border="1">
<tr>
<th>Firstname</th>
<th>Lastname</th>
</tr>
<tr>
<td>Peter</td>
<td>Griffin</td>
</tr>
</table>
<br />
<input type="button" onclick=alertId()
value="Alert id of table" />

</body>
</html>

TIY

提示一个表格的 id

返回 HTML DOM Table 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM TableCell 对象参考手册

定义和用法

id 属性可设置或返回表元的 id。

语法

tabledataObject.id=id

实例

下面的例子返回的表元的 id：

<html>
<head>
<script type="text/javascript">
function alertId()
  {
  alert(document.getElementById("td1").id);
  }
</script>
</head>
<body>

<table border="1">
<tr>
<th>Firstname</th>
<th>Lastname</th>
</tr>
<tr>
<td id="td1">Peter</td>
<td id="td2">Griffin</td>
</tr>
</table>
<br />
<input type="button" onclick=alertId() value="Alert ID" />

</body>
</html>

TIY

取得表元的 id

返回 HTML DOM TableCell 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM Tablerow 对象参考手册

定义和用法

id 属性设置或返回表格行的 id。

语法

tablerowObject.id=id

实例

下面的例子返回了表格行的 id：

<html>
<head>
<script type="text/javascript">
function alertId()
  {
  alert(document.getElementById('tr1').id);
  }
</script>
</head>

<body>
<table border="1">
<tr id="tr1">
<th>Firstname</th>
<th>Lastname</th>
</tr>
<tr id="tr2">
<td>Peter</td>
<td>Griffin</td>
</tr>
</table>
<br />
<input type="button" onclick="alertId()"
value="Alert table row ID" />

</body>
</html>

TIY

取得表格行的 id

返回 HTML DOM Tablerow 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM id 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM id 属性

返回 HTML DOM Textarea 对象参考手册

定义和用法

id 属性设置或返回 textarea 的 id。

语法

textareaObject.id=id

实例

本例获取 textarea 的 id：

<html>
<head>
<script type="text/javascript">
function alertId()
  {
  alert(document.getElementById('txt1').id);
  }
</script>
</head>
<body>

<textarea id="txt1">
Hello world....This is a textarea
</textarea>
<br />
<input type="button" onclick="alertId()" value="Alert ID" />

</body>
</html>

返回 HTML DOM Textarea 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM IFrame 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM IFrame 对象

IFrame 对象

IFrame 对象代表一个 HTML 的内联框架。

在 HTML 文档中 <iframe> 每出现一次，一个 IFrame 对象就会被创建。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet 标准).

IFrame 对象的属性

属性 | 描述 | IE | F | O | W3C
align | 根据周围的文字排列 iframe。 | 6 | 1 | 9 | Yes
contentDocument | 容纳框架的内容的文档。 | No | 1 | 9 | Yes
frameBorder | 设置或返回是否显示 iframe 周围的边框。 | No | 1 | 9 | Yes
height | 设置或返回 iframe 的高度。 | 5 | 1 | 9 | Yes
id | 设置或返回 iframe 的 id。 | 4 | 1 | 9 | Yes
longDesc | 设置或返回描述 iframe 内容的文档的 URL。 | 6 | 1 | 9 | Yes
marginHeight | 设置或返回 iframe 的顶部和底部的页空白。 | 5 | 1 | 9 | Yes
marginWidth | 设置或返回 iframe 的左侧和右侧的页空白。 | 5 | 1 | 9 | Yes
name | 设置或返回 iframe 的名称。 | 5 | 1 | 9 | Yes
scrolling | 设置或返回 iframe 是否可拥有滚动条。 | No | 1 | No | Yes
src | 设置或返回应载入 iframe 中的文档的 URL。 | 5 | 1 | 9 | Yes
width | 设置或返回 iframe 的宽度。 | 5 | 1 | 9 | Yes

Standard Properties

Property | Description | IE | F | O | W3C
className | Sets or returns the class attribute of an element | 5 | 1 | 9 | Yes
dir | Sets or returns the direction of text | 5 | 1 | 9 | Yes
lang | Sets or returns the language code for an element | 5 | 1 | 9 | Yes
title | Sets or returns an element's advisory title | 5 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Image 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Image 对象

Image 对象

Image 对象代表一幅嵌入的图像。

<img> 标签每出现一次，一个 Image 对象就会被创建。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet 标准).

Image 对象的属性

属性 | 描述 | IE | F | O | W3C
align | 设置或返回与内联内容的对齐方式。 | 5 | 1 | 9 | Yes
alt | 设置或返回无法显示图像时的替代文本。 | 5 | 1 | 9 | Yes
border | 设置或返回图像周围的边框。 | 4 | 1 | 9 | Yes
complete | 返回浏览器是否已完成对图像的加载。 | 4 | 1 | 9 | No
height | 设置或返回图像的高度。 | 4 | 1 | 9 | Yes
hspace | 设置或返回图像左侧和右侧的空白。 | 4 | 1 | 9 | Yes
id | 设置或返回图像的 id。 | 4 | 1 | 9 | Yes
isMap | 返回图像是否是服务器端的图像映射。 | 5 | 1 | 9 | Yes
longDesc | 设置或返回指向包含图像描述的文档的 URL。 | 6 | 1 | 9 | Yes
lowsrc | 设置或返回指向图像的低分辨率版本的 URL。 | 4 | 1 | 9 | No
name | 设置或返回图像的名称。 | 4 | 1 | 9 | Yes
src | 设置或返回图像的 URL。 | 4 | 1 | 9 | Yes
useMap | 设置或返回客户端图像映射的 usemap 属性的值。 | 5 | 1 | 9 | Yes
vspace | 设置或返回图像的顶部和底部的空白。 | 4 | 1 | 9 | Yes
width | 设置或返回图像的宽度。 | 4 | 1 | 9 | Yes

Standard Properties

Property | Description | IE | F | O | W3C
className | Sets or returns the class attribute of an element | 5 | 1 | 9 | Yes
title | Sets or returns an element's advisory title | 5 | 1 | 9 | Yes

Image 对象的事件句柄

事件句柄 | 描述 | IE | F | O | W3C
onabort | 当用户放弃图像的装载时调用的事件句柄。 | 5 | 1 | 9 | Yes
onerror | 在装载图像的过程中发生错误时调用的事件句柄。 | 5 | 1 | 9 | Yes
onload | 当图像装载完毕时调用的事件句柄。 | 5 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM images 集合

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM images 集合

返回 HTML DOM Document 对象参考手册

定义和用法

images 集合可返回对文档中所有 Image 对象的引用。

语法

document.images[]

提示和注释

注释：为了与 0 级 DOM 兼容，该集合不包括由 <object> 标记定义的图像。

实例

<html>

<body>
<img border="0" src="hackanm.gif" width="48" height="48">
<br />
<img border="0" src="compman.gif" width="107" height="98">
<br /><br />

<script type="text/javascript">
document.write("This document contains: ")
document.write(document.images.length + " images.")
</script>
</body>

</html>

TIY

计算文档中的图像数目

返回 HTML DOM Document 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM index 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM index 属性

返回 HTML DOM Option 对象参考手册

定义和用法

index 属性可返回下拉列表中选项的索引位置。

语法

optionObject.index

实例

本例可返回下拉列表中所选的选项的索引位置：

<<html>
<head>
<script type="text/javascript">
function alertIndex()
{
var x=document.getElementById("mySelect").selectedIndex;
var y=document.getElementsByTagName("option");
alert(y[x].text + " has the index of: " + y[x].index);
}
</script>
</head>
<body>

<form>
Select your favorite fruit:
<select id="mySelect">
  <option>Apple</option>
  <option>Orange</option>
  <option>Pineapple</option>
  <option>Banana</option>
</select>
<br />
<br />
<input type="button" onclick="alertIndex()"
value="Show index of the chosen fruit">
</form>

</body>
</html>

TIY

取得下拉列表中所选的选项的索引位置

返回 HTML DOM Option 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM innerheight、innerwidth 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM innerheight、innerwidth 属性

返回 HTML DOM Window 对象参考手册

定义和用法

只读属性，声明了窗口的文档显示区的高度和宽度，以像素计。

这里的宽度和高度不包括菜单栏、工具栏以及滚动条等的高度。

IE 不支持这些属性。它用 document.documentElement 或 ducument.body （与 IE 的版本相关）的 clientWidth 和 clientHeight 属性作为替代。

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM innerHTML 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM innerHTML 属性

返回 HTML DOM Anchor 对象参考手册

定义和用法

innerHTML 属性设置或返回一个链接的内容。

语法

anchorObject.innerHTML=text

实例

下面的例子将更改一个链接的文本、URL 以及 target：

<html>
<head>
<script type="text/javascript">
function changeLink()
{
document.getElementById('myAnchor').innerHTML="W3School";
document.getElementById('myAnchor').href="http://www.w3school.com.cn";
document.getElementById('myAnchor').target="_blank";
}
</script>
</head>

<body>
<a id="myAnchor" href="http://www.microsoft.com">Microsoft</a>
<input type="button" onclick="changeLink()" value="Change link">
</body>

</html>

TIY

更改一个链接的文本、URL 以及 target

返回 HTML DOM Anchor 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM innerHTML 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM innerHTML 属性

返回 HTML DOM TableCell 对象参考手册

定义和用法

innerHTML 属性可设置或返回单元格的开始标签和结束标签之间的 HTML。

语法

tabledataObject.innerHTML=text

实例

下面的例子返回了表元的 inner HTML：

<html>
<head>
<script type="text/javascript">
function alertInnerHTML()
  {
  alert(document.getElementById("td1").innerHTML);
  }
</script>
</head>
<body>

<table border="1">
<tr>
<th>Firstname</th>
<th>Lastname</th>
</tr>
<tr>
<td id="td1">Peter</td>
<td id="td1">Griffin</td>
</tr>
</table>
<br />
<input type="button" onclick=alertInnerHTML()
value="Alert innerHTML" />
</body>
</html>

TIY

取得表元的 inner HTML

返回 HTML DOM TableCell 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM innerHTML 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM innerHTML 属性

返回 HTML DOM Tablerow 对象参考手册

定义和用法

innerHTML 属性设置或返回表格行的开始和结束标签之间的 HTML。

语法

tablerowObject.innerHTML=HTML

实例

下面的例子返回了表格行的 inner HTML：

<html>
<head>
<script type="text/javascript">
function getInnerHTML()
  {
  alert(document.getElementById("tr1").innerHTML);
  }
</script>
</head>
<body>

<table border="1">
<tr id="tr1">
<th>Firstname</th>
<th>Lastname</th>
</tr>
<tr id="tr2">
<td>Peter</td>
<td>Griffin</td>
</tr>
</table>
<br />
<input type="button" onclick="getInnerHTML()"
value="Alert innerHTML of table row" />

</body>
</html>

TIY

取得表格行的 inner HTML

返回 HTML DOM Tablerow 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM insertCell() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM insertCell() 方法

返回 HTML DOM Tablerow 对象参考手册

定义和用法

insertCell() 方法用于在 HTML 表的一行的指定位置插入一个空的 <td> 元素。

语法

tablerowObject.insertCell(index)

返回值

一个 TableCell 对象，表示新创建并被插入的 <td> 元素。

说明

该方法将创建一个新的 <td> 元素，把它插入行中指定的位置。新单元格将被插入当前位于 index 指定位置的表元之前。如果 index 等于行中的单元格数，则新单元格被附加在行的末尾。

请注意，该方法只能插入 <td> 数据表元。若需要给行添加头表元，必须用 Document.createElement() 方法和 Node.insertBefore() 方法（或相关的方法）创建并插入一个 <th> 元素。

抛出

若参数 index 小于 0 或大于等于行中的的表元数，该方法将抛出代码为 INDEX_SIZE_ERR 的 DOMException 异常。

实例

下面的例子在表格行中插入了一个单元格：

<html>
<head>
<script type="text/javascript">
function insCell()
  {
  var x=document.getElementById('tr2').insertCell(0)
  x.innerHTML="John"
  }
</script>
</head>
<body>

<table border="1">
<tr id="tr1">
<th>Firstname</th>
<th>Lastname</th>
</tr>
<tr id="tr2">
<td>Peter</td>
<td>Griffin</td>
</tr>
</table>
<br />
<input type="button" onclick="insCell()" value="Insert cell">

</body>
</html>

TIY

向一个已有的行中插入单元格
向表格添加新行 - 然后添加单元格和内容

返回 HTML DOM Tablerow 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM insertRow() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM insertRow() 方法

返回 HTML DOM Table 对象参考手册

定义和用法

insertRow() 方法用于在表格中的指定位置插入一个新行。

语法

tableObject.insertRow(index)

返回值

返回一个 TableRow，表示新插入的行。

说明

该方法创建一个新的 TableRow 对象，表示一个新的 <tr> 标记，并把它插入表中的指定位置。

新行将被插入 index 所在行之前。若 index 等于表中的行数，则新行将被附加到表的末尾。

如果表是空的，则新行将被插入到一个新的 <tbody> 段，该段自身会被插入表中。

抛出

若参数 index 小于 0 或大于等于表中的行数，该方法将抛出代码为 INDEX_SIZE_ERR 的 DOMException 异常。

提示和注释

提示：可以用 TableRow.insertCell() 方法给新创建的行添加内容。

实例

下面的例子在表格的开头插入一个新行：

<html>
<head>
<script type="text/javascript">
function insRow()
  {
  document.getElementById('myTable').insertRow(0)
  }
</script>
</head>

<body>
<table id="myTable" border="1">
<tr>
<td>Row1 cell1</td>
<td>Row1 cell2</td>
</tr>
<tr>
<td>Row2 cell1</td>
<td>Row2 cell2</td>
</tr>
</table>
<br />
<input type="button" onclick="insRow()"
value="Insert new row">

</body>
</html>

TIY

向表格添加新行 - 然后向其添加内容

返回 HTML DOM Table 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM isMap 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM isMap 属性

返回 HTML DOM Image 对象参考手册

定义和用法

isMap 属性返回图像是否是服务器端图像映射。

语法

imageObject.isMap

实例

下面的例子可检测图像是否是服务器端图像映射：

<html>
<body>

<img id="planets" src="planets.gif"
width="145" height="126"
usemap="#planetmap" />

<map name="planetmap">
<area id="venus" shape="circle"
coords="124,58,8"
alt="The planet Venus"
href="venus.htm" />
</map>

<p>Is the image a server-side image map?
<script type="text/javascript">
x=document.getElementById('planets');
document.write(x.isMap);
</script>
</p>

</body>
</html>

TIY

检测图像是否是服务器端图像映射

返回 HTML DOM Image 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM javaEnabled() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM javaEnabled() 方法

返回 HTML DOM Navigator 对象参考手册

定义和用法

javaEnabled() 方法可返回一个布尔值，该值指示浏览器是否支持并启用了 Java。如果是，则返回 true，否则返回 false。

语法

navigator.javaEnabled()

提示和注释

提示：可以使用 navigator.javaEnabled() 来检测当前浏览器是否支持 Java，从而知道浏览器是否能显示 Java 小程序。

实例

下面的例子讲返回当前浏览器是否已启用 Java 的布尔值：

<html>
<body>

<script type="text/javascript">
alert(navigator.javaEnabled())
</script>

</body>
</html>

输出：

true

TIY

使用 navigator 对象的 javaEnabled() 方法

返回 HTML DOM Navigator 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM lang 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM lang 属性

返回HTML DOM Style 对象参考手册

定义和用法

lang 属性设置或返回元素的语言。

语法：

object.lang=language-code

实例

本例展示了两种获取 <body> 元素的语言的方法：

<html>
<body id="myid" lang="en-us">

<script type="text/javascript">
x=document.getElementsByTagName('body')[0];
document.write("Body language: " + x.lang);
document.write("<br />");
document.write("An alternate way: ");
document.write(document.getElementById('myid').lang);
</script>

</body>
</html>

TIY

<body> 元素的语言代码

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM lang 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM lang 属性

返回 HTML DOM Body 对象参考手册

定义和用法

lang 属性可设置或返回元素的预言代码。

语法

bodyObject.lang=language-code

实例

下面的例子将展示获取 <body> 元素的语言代码的两种方法：

<html>
<body id="myid" lang="en-us">

<script type="text/javascript">
x=document.getElementsByTagName('body')[0];
document.write("Body language: " + x.lang);
document.write("<br />");
document.write("An alternate way: ");
document.write(document.getElementById('myid').lang);
</script>

</body>
</html>

输出：

Body language: en-us
An alternate way: en-us

TIY

返回 <body> 元素的语言代码

返回 HTML DOM Body 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM lastModified 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM lastModified 属性

返回 HTML DOM Document 对象参考手册

定义和用法

lastModified 属性可返回文档最后被修改的日期和时间。

语法

document.lastModified

说明

该值来自于 Last-Modified HTTP 头部，它是由 Web 服务器发送的可选项。

实例

<html>
<body>

This document was last modified on:
<script type="text/javascript">
document.write(document.lastModified)
</script>

</body>
</html>

TIY

返回文档最近被修改的日期和时间

返回 HTML DOM Document 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM left 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM left 属性

返回HTML DOM Style 对象参考手册

定义和用法

left 属性设置定位元素左外边距边界与其包含块左边界之间的偏移。

语法：

Object.style.left=auto|%|length

可能的值

值 | 描述
auto | 默认。通过浏览器来计算左侧的位置。
% | 设置元素的左边到最近一个具有定位设置父元素的左边缘的百分比位置。
length | 使用 px、cm 等单位设置元素的左边到最近一个具有定位设置父元素的左边缘的位置。可使用负值。

提示和注释

注释：如果 "position" 属性的值为 "static"，那么设置 "left" 属性不会产生任何效果。

实例

下面的例子对按钮的左边进行设置：

<html>
<head>
<style type="text/css">
input
{
position:absolute;
}
</style>
<script type="text/javascript">
function setLeftEdge()
{
document.getElementById("b1").style.left="100px";
}
</script>
</head>
<body>

<input type="button" id="b1" onclick="setLeftEdge()"
value="Set left edge to 100 px" />

</body>
</html>

TIY

left - 对元素的左边进行设置

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM length 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM length 属性

返回 HTML DOM History 对象参考手册

定义和用法

length 属性声明了浏览器历史列表中的元素数量。

注释：IE 6 和 Opera 9 以 0 开始，而 Firefox 1.5 以 1 开始。

语法

history.length

实例

<html>
<body>

<script type="text/javascript">
document.write(history.length);
</script>

</body>
</html>

输出类似：

3

TIY

使用 history 对象的 length 属性

返回 HTML DOM History 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM length 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM length 属性

返回 HTML DOM Form 对象参考手册

定义和用法

length 属性可返回表单中元素的数目。

语法

formObject.length

实例

下面的例子可返回表单中元素的数目：

<html>
<body>

<form id="myForm" method="get">
Name: <input type="text" size="20" value="Peter Griffin" /><br />
Text: <input type="text" size="20" value="Hello World" />
</form>

<script type="text/javascript">
document.write("Number of elements in myForm: ");
document.write(document.getElementById('myForm').length);
</script>

</body>
</html>

TIY

取得表单中元素的数目

返回 HTML DOM Form 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM length 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM length 属性

返回 HTML DOM Select 对象参考手册

定义和用法

length 属性可返回下拉列表中选项的数目。

语法

selectObject.length=number

实例

下面的例子可返回下拉列表的 id：

<html>
<head>
<script type="text/javascript">
function getLength()
  {
  alert(document.getElementById("mySelect").length)
  }
</script>
</head>
<body>

<form>
<select id="mySelect">
  <option>Apple</option>
  <option>Pear</option>
  <option>Banana</option>
  <option>Orange</option>
</select>
<input type="button" onclick="getLength()"
value="How many options in the list?">
</form>

</body>
</html>

TIY

取得下拉列表中选项的数目

返回 HTML DOM Select 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM letterSpacing 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM letterSpacing 属性

返回HTML DOM Style 对象参考手册

定义和用法

letterSpacing 属性设置字符之间的空白。

语法：

Object.style.letterSpacing=normal|length

可能的值

值 | 描述
normal | 默认。定义字符间的标准空间。
length | 定义字符间的固定空间。

实例

本例改变字符之间的空白：

<html>
<head>
<script type="text/javascript">
function changeLetterSpacing()
{
document.getElementById("p1").style.letterSpacing="3";
document.getElementById("p2").style.letterSpacing="-1";
}
</script>
</head>
<body>

<p id="p1">This is an example paragraph.</p>
<p id="p2">This is another example paragraph.</p>

<input type="button" onclick="changeLetterSpacing()"
value="Change letter-spacing" />

</body>
</html>

TIY

letterSpacing - 改变字符之间的空白

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM lineHeight 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM lineHeight 属性

返回HTML DOM Style 对象参考手册

定义和用法

lineHeight 属性设置行之间的距离（行高）。

语法：

Object.style.lineHeight=normal|number|length|%

可能的值

值 | 描述
normal | 默认。设置合理的行间距。
number | 设置数字，此数字会与当前的字体尺寸相乘来设置行间距。
length | 设置固定的行间距。
% | 基于当前字体尺寸的百分比行间距。

实例

本例改变行高：

<html>
<head>
<script type="text/javascript">
function changeLineHeight()
{
document.getElementById("div1").style.lineHeight="2";
}
</script>
</head>
<body>

<div id="div1">
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
</div>
<br />
<input type="button" onclick="changeLineHeight()"
value="Change line-height" />

</body>
</html>

TIY

lineHeight - 改变行高

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Link 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Link 对象

Link 对象

Link 对象代表某个 HTML 的 <link> 元素。<link> 元素可定义两个链接文档之间的关系。

<link> 元素被定义于 HTML 文档的 head 部分。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet Standard).

Link Object Properties

属性 | 描述 | IE | F | O | W3C
charset | 设置或返回目标 URL 的字符编码 | 4 | 1 | 9 | Yes
disabled | 设置或返回目标 URL 是否当被禁用 | 4 | 1 | 9 | Yes
href | 设置或返回被链接资源的 URL | 4 | 1 | 9 | Yes
hreflang | 设置或返回目标 URL 的基准语言 | 4 | 1 | 9 | Yes
id | 设置或返回某个 <link> 元素的 id | 4 | 1 | 9 | Yes
media | 设置或返回文档显示的设备类型 | 6 | 1 | 9 | Yes
name | 设置或返回 <link> 元素的名称 | 4 | No | No | Yes
rel | 设置或返回当前文档与目标 URL之间的关系 | 4 | 1 | 9 | Yes
rev | 设置或返回目标 URL 与当前文档之间的关系 | 4 | 1 | 9 | Yes
type | 设置或返回目标 URL 的 MIME 类型 | 4 | 1 | 9 | Yes

Standard Properties

Property | Description | IE | F | O | W3C
dir | Sets or returns the direction of text | 5 | 1 | 9 | Yes
lang | Sets or returns the language code for an element | 5 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM links 集合

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM links 集合

返回 HTML DOM Document 对象参考手册

定义和用法

links 集合可返回对文档中所有 Area 和 Link 对象的引用。

语法

document.links[]

实例

<html>
<body>

<img src="planets.gif"
width="145" height="126"
usemap="#planetmap" />

<map name="planetmap">
<area id="venus" shape="circle"
coords="124,58,8"
alt="Venus"
href="venus.htm" />
</map>
<br />

Number of links in this document:
<script type="text/javascript">
document.write(document.links.length)
</script>

</body>
</html>

TIY

返回文档中链接的数目
返回文档中第一个链接的 id

返回 HTML DOM Document 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM listStyle 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM listStyle 属性

返回HTML DOM Style 对象参考手册

定义和用法

listStyle 属性在一个声明中设置所有列表属性。

语法：

Object.style.listStyle=listStyleType listStylePosition listStyleImage

Possible Values

值 描述 值
listStyleType

设置列表项标志的类型。

注释：并非右列中的所有值在所有浏览器中都有效。
  • none
  • disc
  • circle
  • square
  • decimal
  • decimal-leading-zero
  • lower-roman
  • upper-roman
  • lower-alpha
  • upper-alpha
  • lower-greek
  • lower-latin
  • upper-latin
  • hebrew
  • armenian
  • georgian
  • cjk-ideographic
  • hiragana
  • katakana
  • hiragana-iroha
  • katakana-iroha
listStylePosition 对列表项标志进行定位。
  • outside
  • inside
listStyleImage 把图像设置为列表项标志。
  • none
  • url(url)

实例

本例改变列表的类型：

<html>
<head>
<script type="text/javascript">
function changeList()
  {
  document.getElementById("ul1").style.listStyle="decimal inside";
  }
</script>
</head>
<body>

<ul id="ul1">
  <li>Coffee</li>
  <li>Tea</li>
  <li>Water</li>
  <li>Soda</li>
</ul>

<input type="button" onclick="changeList()"
value="Change list style" />

</body>
</html>

TIY

listStyle - 改变列表的类型

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM listStyleImage 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM listStyleImage 属性

返回HTML DOM Style 对象参考手册

定义和用法

listStyleImage 属性把图像设置为列表项标志。

语法：

Object.style.listStyleImage=url|none

可能的值

值 | 描述
url | 图形的路径。
none | 不会显示图像。

实例

下面的例子改变列表的列表项标志：

<html>
<head>
<script type="text/javascript">
function changeList()
{
document.getElementById("ul1").style.listStyleImage="url('blueb.gif')";
}
</script>
</head>
<body>

<ul id="ul1">
  <li>Coffee</li>
  <li>Tea</li>
  <li>Water</li>
  <li>Soda</li>
</ul>

<input type="button" onclick="changeList()"
value="Change list-item marker" />

</body>
</html>

TIY

listStyleImage - 改变列表的列表项标志

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM listStylePosition 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM listStylePosition 属性

返回HTML DOM Style 对象参考手册

定义和用法

listStylePosition 属性对列表中的列表项标记进行定位。

语法：

Object.style.listStylePosition=inside|outside

可能的值

值 | 描述
inside | 列表项目标记放置在文本以内，且环绕文本根据标记对齐。
outside | 默认。保持标记位于文本的左侧。列表项目标记放置在文本以外，且环绕文本不根据标记对齐。

实例

本例改变列表项标志的位置：

<html>
<head>
<script type="text/javascript">
function changeList()
{
document.getElementById("ul1").style.listStylePosition="inside";
}
</script>
</head>
<body>

<ul id="ul1">
  <li>Coffee</li>
  <li>Tea</li>
  <li>Water</li>
  <li>Soda</li>
</ul>

<input type="button" onclick="changeList()"
value="Change list-item marker position" />

</body>
</html>

TIY

listStylePosition - 改变列表项标志的位置

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM listStyleType 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM listStyleType 属性

返回HTML DOM Style 对象参考手册

定义和用法

listStyleType 属性设置列表项标志的类型。

语法：

Object.style.listStyleType=value

可能的值

CSS2 的值：

值 | 描述
none | 无标记。
disc | 默认。标记是实心圆。
circle | 标记是空心圆。
square | 标记是实心方块。
decimal | 标记是数字。
decimal-leading-zero | 0开头的数字标记。(01, 02, 03, 等。)
lower-roman | 小写罗马数字(i, ii, iii, iv, v, 等。)
upper-roman | 大写罗马数字(I, II, III, IV, V, 等。)
lower-alpha | 小写英文字母The marker is lower-alpha (a, b, c, d, e, 等。)
upper-alpha | 大写英文字母The marker is upper-alpha (A, B, C, D, E, 等。)
lower-greek | 小写希腊字母(alpha, beta, gamma, 等。)
lower-latin | 小写拉丁字母(a, b, c, d, e, 等。)
upper-latin | 大写拉丁字母(A, B, C, D, E, 等。)
hebrew | 传统的希伯来编号方式
armenian | 传统的亚美尼亚编号方式
georgian | 传统的乔治亚编号方式(an, ban, gan, 等。)
cjk-ideographic | 简单的表意数字
hiragana | 标记是：a, i, u, e, o, ka, ki, 等。（日文片假名）
katakana | 标记是：A, I, U, E, O, KA, KI, 等。（日文片假名）
hiragana-iroha | 标记是：i, ro, ha, ni, ho, he, to, 等。（日文片假名）
katakana-iroha | 标记是：I, RO, HA, NI, HO, HE, TO, 等。（日文片假名）

CSS2.1 的值：

disc | circle | square | decimal | decimal-leading-zero |
lower-roman | upper-roman | lower-greek | lower-latin | upper-latin |
armenian | georgian | none | inherit

实例

本例改变列表项的类型：

<html>
<head>
<script type="text/javascript">
function changeList()
{
document.getElementById("ul1").style.listStyleType="square";
}
</script>
</head>
<body>

<ul id="ul1">
  <li>Coffee</li>
  <li>Tea</li>
  <li>Water</li>
  <li>Soda</li>
</ul>

<input type="button" onclick="changeList()"
value="Change list-item marker type" />

</body>
</html>

TIY

listStyleType - 改变列表项的类型

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Location 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Location 对象

Location 对象

Location 对象实际上是 JavaScript 对象，而不是 HTML DOM 对象。

Location 对象是由 JavaScript runtime engine 自动创建的，包含有关当前 URL 的信息。

例子：把用户带到一个新的地址

Location 对象是 Window 对象的一个部分，可通过 window.location 属性来访问。

有关 Location 对象的详细描述。

IE: Internet Explorer, F: Firefox, O: Opera.

Location 对象的属性

属性 | 描述 | IE | F | O
hash | 设置或返回从井号 (#) 开始的 URL（锚）。 | 4 | 1 | 9
host | 设置或返回主机名和当前 URL 的端口号。 | 4 | 1 | 9
hostname | 设置或返回当前 URL 的主机名。 | 4 | 1 | 9
href | 设置或返回完整的 URL。 | 4 | 1 | 9
pathname | 设置或返回当前 URL 的路径部分。 | 4 | 1 | 9
port | 设置或返回当前 URL 的端口号。 | 4 | 1 | 9
protocol | 设置或返回当前 URL 的协议。 | 4 | 1 | 9
search | 设置或返回从问号 (?) 开始的 URL（查询部分）。 | 4 | 1 | 9

Location 对象的方法

方法 | 描述 | IE | F | O
assign() | 加载新的文档。 | 4 | 1 | 9
reload() | 重新加载当前文档。 | 4 | 1 | 9
replace() | 用新的文档替换当前文档。 | 4 | 1 | 9

Location 对象的描述

Location 对象存储在 Window 对象的 Location 属性中，表示那个窗口中当前显示的文档的 Web 地址。它的 href 属性存放的是文档的完整 URL，其他属性则分别描述了 URL 的各个部分。这些属性与 Anchor 对象（或 Area 对象）的 URL 属性非常相似。当一个 Location 对象被转换成字符串，href 属性的值被返回。这意味着你可以使用表达式 location 来替代 location.href。

不过 Anchor 对象表示的是文档中的超链接，Location 对象表示的却是浏览器当前显示的文档的 URL（或位置）。但是 Location 对象所能做的远远不止这些，它还能控制浏览器显示的文档的位置。如果把一个含有 URL 的字符串赋予 Location 对象或它的 href 属性，浏览器就会把新的 URL 所指的文档装载进来，并显示出来。

除了设置 location 或 location.href 用完整的 URL 替换当前的 URL 之外，还可以修改部分 URL，只需要给 Location 对象的其他属性赋值即可。这样做就会创建新的 URL，其中的一部分与原来的 URL 不同，浏览器会将它装载并显示出来。例如，假设设置了Location对象的 hash 属性，那么浏览器就会转移到当前文档中的一个指定的位置。同样，如果设置了 search 属性，那么浏览器就会重新装载附加了新的查询字符串的 URL。

除了 URL 属性外，Location 对象的 reload() 方法可以重新装载当前文档，replace() 可以装载一个新文档而无须为它创建一个新的历史记录，也就是说，在浏览器的历史列表中，新文档将替换当前文档。

HTML DOM 参考手册
HTML DOM 实例


HTML DOM logicalXDPI 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM logicalXDPI 属性

返回 HTML DOM Screen 对象参考手册

定义和用法

logicalXDPI 属性可返回显示屏幕每英寸的水平方向的常规点数。

语法

screen.logicalXDPI

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>Logical XDPI: ")
document.write(screen.logicalXDPI + "</p>")
</script>
</body>

</html>

TIY

检测有关客户机的屏幕的细节

返回 HTML DOM Screen 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM logicalYDPI 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM logicalYDPI 属性

返回 HTML DOM Screen 对象参考手册

定义和用法

logicalYDPI 属性可返回显示屏幕每英寸的垂直方向的常规点数。

语法

screen.logicalYDPI

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>Logical YDPI: ")
document.write(screen.logicalYDPI + "</p>")
</script>
</body>

</html>

TIY

检测有关客户机的屏幕的细节

返回 HTML DOM Screen 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM longDesc 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM longDesc 属性

返回 HTML DOM Frame 对象参考手册

定义和用法

longDesc 属性可设置或返回一个框架内容描述的 URL。

提示：对那么不支持框架的浏览器使用该属性。

语法

frameObject.longDesc=URL

实例

在我们的例子中，首先将创建包含带有两个列的框架集的 HTML 文档。每列设置为浏览器窗口的 50%：

<html>
  <frameset cols="50%,50%">
    <frame id="leftFrame" src="frame_longdesc.htm"
    longdesc="frame_description.htm">
    <frame id="rightFrame" src="frame_a.htm">
  </frameset>
</html>

HTML 文档 "frame_longdesc.htm" 被放入第一列，而 HTML 文档 "frame_a.htm" 被放入第二列。

下面是 "frame_longdesc.htm" 的源代码：

<html>
<body>

<script type="text/javascript">
x=parent.document.getElementById("leftFrame");

document.write("Description for this frame: ");
document.write('<a href="' + x.longDesc
+ '">Description</a>');
</script>

</body>
</html>

TIY

使用 <frame> 元素中的 longdesc 属性

返回 HTML DOM Frame 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM longDesc 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM longDesc 属性

返回 HTML DOM Iframe 对象参考手册

定义和用法

longDesc 属性可设置或返回包含 iframe 内容描述的文档的 URL。

提示：请把该属性用于不支持框架的浏览器。

语法

iframeObject.longDesc=URL

实例

下面的例子创建了一个指向一个描述页面的链接：

<html>
<body>
<iframe src="frame_a.htm" id="frame1"
longdesc="frame_description.htm"></iframe>
<br />

<script type="text/javascript">
x=document.getElementById("frame1");
document.write("Description for frame contents: ");
document.write('<a href="' + x.longDesc + '">Description</a>');
</script>

</body>
</html>

TIY

使用 <iframe> 元素中的 longdesc 属性

返回 HTML DOM Iframe 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM longDesc 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM longDesc 属性

返回 HTML DOM Image 对象参考手册

定义和用法

longDesc　属性可设置或返回包含图像描述的文档的 URL。

该描述是对 "alt" 属性的补充，可对非可视的用户代理很有用。

语法

imageObject.longDesc=URL

实例

下面的例子将创建一个指向图像描述的链接：

<html>
<body>
<img id="compman" src="compman.gif"
longdesc="compman_description.htm" alt="Computerman" />
<br />

<script type="text/javascript">
var x=document.getElementById("compman");
document.write("Description for image: ");
document.write('<a href="' + x.longDesc + '">Description</a>');
</script>

</body>
</html>

TIY

创建一个较长的图像描述的链接

返回 HTML DOM Image 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM lowsrc 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM lowsrc 属性

返回 HTML DOM Image 对象参考手册

定义和用法

lowsrc 属性可设置或返回图像的低分辨率版本的 URL。

语法

imageObject.lowsrc=URL

实例

下面的例子可创建一个指向图像的低分辨率版本的链接：

<html>
<body>
<img id="compman" src="compman.gif"
lowsrc="compman_lowres.gif" alt="Computerman" />
<br />

<script type="text/javascript">
var x=document.getElementById("compman");
document.write('<a href="' + x.lowsrc + '">Low resolution</a>');
</script>

</body>
</html>

TIY

创建一个指向图像的低分辨率版本的链接

返回 HTML DOM Image 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM margin 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM margin 属性

返回HTML DOM Style 对象参考手册

定义和用法

margin 属性设置元素的外边距。

该属性可使用 1 到 4 个值：

  • 如果规定一个值，比如 div {margin: 50px} - 所有的外边距都是 50 px
  • 如果规定两个值，比如 div {margin: 50px 10px} - 上下外边距是 50px，左右外边距是 10 px。
  • 如果规定三个值，比如 div {margin: 50px 10px 20px}- 上外边距是 50 px，而左右外边距是 10 px，下外边距是 20 px。
  • 如果规定四个值，比如 div {margin: 50px 10px 20px 30px} - 上外边距是 50 px，右外边距是 10 px，下外边距是 20 px，左外边距是 30 px。

语法：

Object.style.margin=margin

可能的值：

值 描述
margin

设置外边距。

值可以是：

  • 百分比（基于父对象总高度或宽度的百分比）
  • 长度值（定义一个固定的边距）
  • auto（浏览器设定的值）。

实例

下面的例子改变了段落的外边距：

<html>
<head>
<script type="text/javascript">
function changeMargin()
{
document.getElementById("p1").style.margin="100px";
}
</script>
</head>
<body>

<input type="button" onclick="changeMargin()"
value="Change margins of a paragraph" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

margin - 改变段落的外边距

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM marginBottom 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM marginBottom 属性

返回HTML DOM Style 对象参考手册

定义和用法

marginBottom 属性设置元素的下外边距。

语法：

Object.style.marginBottom=auto|length|%

可能的值：

值 | 描述
auto | 浏览器设置的一个下外边距。
length | 定义一个固定的下外边距。默认值是0。
% | 定义基于父对象总高度的百分比下外边距。

实例

本例改变段落的下外边距：

<html>
<head>
<script type="text/javascript">
function changeMargin()
{
document.getElementById("p1").style.marginBottom="32px";
}
</script>
</head>
<body>

<input type="button" onclick="changeMargin()"
value="Change the bottom margin of a paragraph" />

<p>This is a paragraph</p>
<p id="p1">This is a paragraph</p>
<p>This is a paragraph</p>

</body>
</html>

TIY

marginBottom - 改变元素的下外边距

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM marginHeight 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM marginHeight 属性

返回 HTML DOM Frame 对象参考手册

定义和用法

marginHeight 属性可设置或返回框架的顶部和底部页空白（以像素为单位）。

语法

frameObject.marginHeight=pixels

实例

在我们的例子中，首先将创建包含带有两个列的框架集的 HTML 文档。每列设置为浏览器窗口的 50%：

<html>
  <frameset cols="50%,50%">
    <frame id="leftFrame" marginheight="50"
    src="frame_marginheight.htm">
    <frame id="rightFrame" marginheight="100"
    src="frame_a.htm">
  </frameset>
</html>

HTML 文档 "frame_marginheight.htm" 被放入第一列，而 HTML 文档 "frame_a.htm" 被放入第二列。

下面是 "frame_marginheight.htm" 的源代码：

<html>
<body>

script type="text/javascript">
x=parent.document.getElementById("leftFrame");
y=parent.document.getElementById("rightFrame");

document.write("Top/Bottom margins for leftFrame: ");
document.write(x.marginHeight);
document.write("<br />Top/Bottom margins for rightFrame: ");
document.write(y.marginHeight);
</script>

</body>
</html>

TIY

返回框架的顶部和底部页空白

返回 HTML DOM Frame 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM marginHeight 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM marginHeight 属性

返回 HTML DOM Iframe 对象参考手册

定义和用法

marginHeight 属性可设置或返回框架顶部和底部的页面空白（以像素计）。

语法

iframeObject.marginHeight=pixels

实例

下面的例子可返回 iframe 顶部和底部的页面空白：

<html>
<body>
<iframe src="frame_a.htm" id="frame1" marginheight="50"></iframe>
<br />

<script type="text/javascript">
x=document.getElementById("frame1");
document.write("Top and bottom margins of the iframe are: ");
document.write(x.marginHeight);
</script>

</body>
</html>

TIY

返回 iframe 的顶部和底部页空白

返回 HTML DOM Iframe 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM marginLeft 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM marginLeft 属性

返回HTML DOM Style 对象参考手册

定义和用法

marginLeft 属性设置元素的左外边距。

语法：

Object.style.marginLeft=auto|length|%

可能的值：

值 | 描述
auto | 浏览器设置的左外边距。
length | 定义固定的左外边距。默认值是0。
% | 定义基于父对象总高度的百分比左外边距。

实例

本例更改了段落的左外边距：

<html>
<head>
<script type="text/javascript">
function changeMargin()
{
document.getElementById("p1").style.marginLeft="32px";
}
</script>
</head>
<body>

<input type="button" onclick="changeMargin()"
value="Change the left margin of a paragraph" />

<p>This is a paragraph</p>
<p id="p1">This is a paragraph</p>
<p>This is a paragraph</p>

</body>
</html>

TIY

marginLeft - 改变元素的左外边距

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM marginRight 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM marginRight 属性

返回HTML DOM Style 对象参考手册

定义和用法

marginRight 属性设置元素的右外边距。

语法：

Object.style.marginRight=auto|length|%

可能的值

值 | 描述
auto | 浏览器设置的外右边距。
length | 定义固定的外右边距。默认值是 0。
% | 定义基于父对象总高度的百分比外右边距。

实例

下面的例子改变了段落的右外边距：

<html>
<head>
<style type="text/css">
p
{
text-align: right
}
</style>
<script type="text/javascript">
function changeMargin()
{
document.getElementById("p1").style.marginRight="32px";
}
</script>
</head>
<body>

<input type="button" onclick="changeMargin()"
value="Change the right margin of a paragraph" />

<p>This is a paragraph</p>
<p id="p1">This is a paragraph</p>
<p>This is a paragraph</p>

</body>
</html>

TIY

marginRight - 改变段落的右外边距

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM marginTop 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM marginTop 属性

返回HTML DOM Style 对象参考手册

定义和用法

marginTop 属性设置元素的上外边距。

语法：

Object.style.marginTop=auto|length|%

可能的值

值 | 描述
auto | 浏览器设置的上外边距。
length | 定义固定的上外边距。默认值是 0。
% | 定义基于父对象总高度的百分比上外边距。

实例

本例改变段落的上外边距：

<html>
<head>
<script type="text/javascript">
function changeMargin()
{
document.getElementById("p1").style.marginTop="32px";
}
</script>
</head>
<body>

<input type="button" onclick="changeMargin()"
value="Change the top margin of a paragraph" />

<p>This is a paragraph</p>
<p id="p1">This is a paragraph</p>
<p>This is a paragraph</p>

</body>
</html>

TIY

marginTop - 改变段落的上外边距

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM marginWidth 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM marginWidth 属性

返回 HTML DOM Frame 对象参考手册

定义和用法

marginWidth 属性可设置或返回框架的左边缘和右边缘的页空白（以像素为单位）。

语法

frameObject.marginWidth=pixels

实例

在我们的例子中，首先将创建包含带有两个列的框架集的 HTML 文档。每列设置为浏览器窗口的 50%：

<html>
  <frameset cols="50%,50%">
    <frame id="leftFrame" marginwidth="50"
    src="frame_marginwidth.htm">
    <frame id="rightFrame" marginwidth="20"
    src="frame_a.htm">
  </frameset>
</html>

HTML 文档 "frame_marginwidth.htm" 被放入第一列，而 HTML 文档 "frame_a.htm" 被放入第二列。

下面是 "frame_marginwidth.htm" 的源代码：

<html>
<body>

script type="text/javascript">
x=parent.document.getElementById("leftFrame");
y=parent.document.getElementById("rightFrame");

document.write("Left/Right margins for leftFrame: ");
document.write(x.marginWidth);
document.write("<br />Left/Right margins for rightFrame: ");
document.write(y.marginWidth);
</script>

</body>
</html>

TIY

返回框架的左侧和右侧的空白

返回 HTML DOM Frame 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM marginWidth 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM marginWidth 属性

返回 HTML DOM Iframe 对象参考手册

定义和用法

marginWidth 属性可设置或返回框架的左侧和右侧边缘的页面空白（以像素为单位）。

语法

iframeObject.marginWidth=pixels

实例

下面的例子将返回 iframe 的左边缘和右边缘的页空白：

<html>
<body>
<iframe src="frame_a.htm" id="frame1" marginwidth="50"></iframe>
<br /><br />

<script type="text/javascript">
x=document.getElementById("frame1");
document.write("Left and right margins of the iframe are: ");
document.write(x.marginWidth);
</script>

</body>
</html>

TIY

返回 iframe 的左边缘和右边缘的页空白

返回 HTML DOM Iframe 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM maxHeight 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM maxHeight 属性

返回HTML DOM Style 对象参考手册

定义和用法

maxHeight 属性设置元素的最大高度。

语法：

Object.style.maxHeight=length|%

可能的值

值 | 描述
length | 定义元素的最大高度值。
% | 定义基于其包含块的百分比最大高度。

实例

本例设置元素框的最大高度：

<html>
<head>
<script type="text/javascript">
function setMaxHeight()
{
document.getElementById("p1").style.maxHeight="10px";
}
</script>
</head>
<body>

<p id="p1">This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.</p>

<input type="button" onclick="setMaxHeight()"
value="Set max height" />

</body>
</html>

TIY

maxHeight - 设置元素框的最大高度

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM maxLength 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM maxLength 属性

返回 HTML DOM Password 对象参考手册

定义和用法

maxLength 属性可设置或返回密码域中所允许的最大字符数。

语法

passwordObject.maxLength=number_of_chars

实例

下面的例子可显示指定的密码域中所允许的最大字符数：

<html>
<head>
<script type="text/javascript">
function alertLength()
  {
  alert(document.getElementById("password1").maxLength)
  }
</script>
</head>
<body>

<form>
<input type="password" id="password1" maxLength="8" />
<input type="button" id="button1" onclick="alertLength()"
value="Alert maxLength" />
</form>

</body>
</html>

TIY

获得密码域中所允许的最大字符数

返回 HTML DOM Password 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM maxLength 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM maxLength 属性

返回 HTML DOM Text 对象参考手册

定义和用法

maxLength 属性可设置或返回文本域中的最大字符数。

语法

textObject.maxLength=number_of_char

实例

下面的例子显示出该文本域的最大字符数：

<html>
<head>
<script type="text/javascript">
function maxLen()
  {
  alert(document.getElementById("name").maxLength)
  }
</script>
</head>

<body>
<form>
Name:
<input type="text" id="name" value="Mickey Mouse" size="20" maxlength="30" />
<br /><br />
<input type="button" onclick="maxLen()" value="Alert maxlength" />
</form>
</body>

</html>

TIY

提示出文本域的尺寸和最大字符数
当达到文本域的最大字符数时跳至下一个域

返回 HTML DOM Text 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM maxWidth 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM maxWidth 属性

返回HTML DOM Style 对象参考手册

定义和用法

maxWidth 属性设置元素的最大宽度。

语法：

Object.style.maxWidth=length|%

可能的值

值 | 描述
length | 定义元素的最大宽度值。
% | 定义基于其包含块的百分比最大宽度。

实例

本例设置元素框的最大宽度：

<html>
<head>
<script type="text/javascript">
function setMaxWidth()
{
document.getElementById("p1").style.maxWidth="10px";
}
</script>
</head>
<body>

<p id="p1">This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.</p>

<input type="button" onclick="setMaxWidth()"
value="Set max width" />

</body>
</html>

TIY

maxWidth - 设置元素框的最大宽度

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM media 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM media 属性

返回 HTML DOM Link 对象参考手册

定义和用法

The media property sets or returns on what device the document will be displayed.

The destination medium is important for style information. The style might be different for computers and mobile devices.

语法

linkObject.media=device

Device can have one of the following values:

值 | 描述
screen | For non-paged computer screens
tty | For media using a fixed-pitch character grid (like teletypes, terminals, or devices with limited display capabilities)
tv | For TV-type devices (low resolution, limited scrollability)
projection | For projectors
handheld | For handheld devices (small screen, limited bandwidth)
print | For paged and for documents viewed on screen in print preview mode
braille | For braille tactile feedback devices
aural | For speech synthesizers
all | For all devices

实例

The following example gets the media type the link element is intended for:

<html>
<head>
<link rel="stylesheet" type="text/css" media="screen"
id="style1" href="try_dom_link.css" />
</head>
<body>

<script type="text/javascript">
x=document.getElementById("style1");
document.write("Intended media type=" + x.media);
</script>

</body>
</html>

TIY

Get the media type the <link> element is intended for

返回 HTML DOM Link 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Meta 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Meta 对象

Meta 对象

Meta 对象代表 HTML 的 一个 <meta> 元素。

<meta> 元素可提供有关某个 HTML 元素的元信息 (meta-information)，比如描述、针对搜索引擎的关键词以及刷新频率。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: 万维网联盟 (Internet 标准)。

Meta Object Properties

属性 | 描述 | IE | F | O | W3C
content | 设置或返回 <meta> 元素的 content 属性的值。 | 5 | 1 | 9 | Yes
httpEquiv | 把 content 属性连接到一个 HTTP 头部。 | 5 | 1 | 9 | Yes
name | 把 content 属性连接到某个名称。 | 5 | 1 | 9 | Yes
scheme | 设置或返回用于解释 content 属性的值的格式。 | 6 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM method 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM method 属性

返回 HTML DOM Form 对象参考手册

定义和用法

method 属性可设置或返回用于表单提交的 HTTP 方法。

语法

formObject.method=get|post

实例

下面的例子弹出的对话框中显示了发送表单数据所使用的 HTTP 方法：

<html>
<head>
<script type="text/javascript">
function showMethod()
  {
  var x=document.getElementById("myForm")
  alert(x.method)
  }
</script>
</head>
<body>

<form id="myForm" method="post">
Name: <input type="text" size="20" value="Mickey Mouse" />
<input type="button" onclick="showMethod()" value="Show method" />
</form>

</body>
</html>

TIY

返回向服务器发送数据的 HTTP 方法

返回 HTML DOM Form 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM minHeight 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM minHeight 属性

返回HTML DOM Style 对象参考手册

定义和用法

minHeight 属性设置元素的最小高度。

语法：

Object.style.minHeight=length|%

可能的值

值 | 描述
length | 定义元素的最小高度值。
% | 定义基于其包含块的百分比最小高度。

实例

本例设置元素框的最小高度：

<html>
<head>
<script type="text/javascript">
function setMinHeight()
{
document.getElementById("p1").style.minHeight="200px";
}
</script>
</head>
<body>

<p id="p1">This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.</p>

<input type="button" onclick="setMinHeight()"
value="Set min height" />

</body>
</html>

TIY

minHeight - 设置元素框的最小高度

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM minHeight 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM minWidth 属性

返回HTML DOM Style 对象参考手册

定义和用法

minWidth 属性设置元素框的最小宽度。

语法：

Object.style.minWidth=length|%

可能的值

值 | 描述
length | 定义元素的最小宽度值。
% | 定义基于其包含块的百分比最小宽度。

实例

本例设置元素框的最小宽度：

<html>
<head>
<script type="text/javascript">
function setMinWidth()
{
document.getElementById("p1").style.minWidth="1000px";
}
</script>
</head>
<body>

<p id="p1">This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.</p>

<input type="button" onclick="setMinWidth()" value="Set min width" />

</body>
</html>

TIY

minWidth - 设置元素框的最小宽度

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM moveBy() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM moveBy() 方法

返回 HTML DOM Window 对象参考手册

定义和用法

moveBy() 方法可相对窗口的当前坐标把它移动指定的像素。

语法

window.moveBy(x,y)
参数 | 描述
x | 要把窗口右移的像素数
y | 要把窗口下移的像素数

实例

下面的例子将把窗口相对其当前位置移动 50 个像素：

<html>
<head>
<script type="text/javascript">
function moveWin()
  {
  myWindow.moveBy(50,50)
  }
</script>
</head>
<body>

<script type="text/javascript">
myWindow=window.open('','','width=200,height=100')
myWindow.document.write("This is 'myWindow'")
</script>

<input type="button" value="Move 'myWindow'"
onclick="moveWin()" />

</body>
</html>

TIY

通过 moveBy() 移动窗口

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM moveTo() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM moveTo() 方法

返回 HTML DOM Window 对象参考手册

定义和用法

moveTo() 方法可把窗口的左上角移动到一个指定的坐标。

语法

window.moveTo(x,y)
参数 | 描述
x | 窗口新位置的 x 坐标
y | 窗口新位置的 y 坐标

提示和注释

注释：出于安全方面的原因，浏览器限制此方法使其不能把窗口移出屏幕。

实例

下面的例子讲把新窗口移动到指定的坐标：

<html>
<head>
<script type="text/javascript">
function moveWin()
  {
  myWindow.moveTo(50,50)
  }
</script>
</head>
<body>

<script type="text/javascript">
myWindow=window.open('','','width=200,height=100')
myWindow.document.write("This is 'myWindow'")
</script>

<input type="button" value="Move 'myWindow'"
onclick="moveWin()" />

</body>
</html>

TIY

通过 moveTo() 移动窗口

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM multiple 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM multiple 属性

返回 HTML DOM Select 对象参考手册

定义和用法

multiple 属性可设置或返回是否可有多个选项被选中。

注释：Opera 9 无法在脚本中设置该属性，仅能返回它。

语法

selectObject.multiple=true|false

实例

The following example returns the id of the dropdown list:

<html>
<head>
<script type="text/javascript">
function selectMultiple()
  {
  document.getElementById("mySelect").multiple=true
  }
</script>
</head>
<body>

<form>
<select id="mySelect" size="4">
  <option>Apple</option>
  <option>Pear</option>
  <option>Banana</option>
  <option>Orange</option>
</select>
<input type="button" onclick="selectMultiple()"
value="Select multiple">
</form>

</body>
</html>

TIY

选择下拉列表中的多个选项

返回 HTML DOM Select 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM name 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM name 属性

返回 HTML DOM Window 对象参考手册

定义和用法

name 属性可设置或返回存放窗口的名称的一个字符串。

该名称是在 open() 方法创建窗口时指定的或者使用一个 <frame> 标记的 name 属性指定的。

窗口的名称可以用作一个 <a> 或者 <form> 标记的 target 属性的值。以这种方式使用 target 属性声明了超链接文档或表单提交结果应该显示于指定的窗口或框架中。

语法

window.name=name

实例

下面的例子可返回新窗口的名称：

<html>
<head>
<script type="text/javascript">
function checkWin()
  {
  document.write(myWindow.name)
  }
</script>
</head>
<body>

<script type="text/javascript">
myWindow=window.open('','MyName','width=200,height=100')
myWindow.document.write("This is 'myWindow'")
</script>

<input type="button" value="What's the name of 'myWindow'?"
onclick="checkWin()">

</body>
</html>

TIY

返回新窗口的名称

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM name 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM name 属性

返回 HTML DOM Anchor 对象参考手册

定义和用法

name 属性可设置或返回链接的名称。

语法

anchorObject.name=name

实例

下面的例子可返回链接的名称：

<html>
<body>

<p><a id="myAnchor" name="myAnchor"
href="http://www.w3school.com.cn">Visit W3School.com.cn</a></p>

<script type="text/javascript">
x=document.getElementById("myAnchor");
document.write(x.name);
</script>

</body>
</html>

TIY

取得链接的名称

返回 HTML DOM Anchor 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM name 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM name 属性

返回 HTML DOM Button 对象参考手册

定义和用法

name 属性可设置或返回按钮的名称。

语法

buttonObject.name=name

实例

下面的例子可返回按钮的名称：

<html>
<body>

<button id="button1" name="button1">
Click Me!</button>

<p>The name of the button is:
<script type="text/javascript">
x=document.getElementById('button1');
document.write(x.name);
</script></p>

</body>
</html>

TIY

获取按钮的名称

返回 HTML DOM Button 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM name 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM name 属性

返回 HTML DOM Form 对象参考手册

定义和用法

length 属性可设置或返回表单的名称。

语法

formObject.name=formname

实例

下面的例子可返回表单的名称：

<html>
<body>
<form id="myForm" method="get" name="myForm">
Name: <input type="text" size="20" value="Peter Griffin" />
</form>

<script type="text/javascript">
document.write("Form name: ");
document.write(document.getElementById('myForm').name);
</script>

</body>
</html>

TIY

取得 <form> 元素的名称

返回 HTML DOM Form 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM name 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM name 属性

返回 HTML DOM Frame 对象参考手册

定义和用法

name 属性可设置或返回框架的名称。

语法

frameObject.name=name

实例

在我们的例子中，首先将创建包含带有两个列的框架集的 HTML 文档。每列设置为浏览器窗口的 50%：

<html>
  <frameset cols="50%,50%">
    <frame id="leftFrame" name="toc" src="frame_name.htm">
    <frame id="rightFrame" name="main" src="frame_a.htm">
  </frameset>
</html>

HTML 文档 "frame_name.htm" 被放入第一列，而 HTML 文档 "frame_a.htm" 被放入第二列。

下面是 "frame_name.htm" 的源代码：

<html>
<body>

<script type="text/javascript">
x=parent.document.getElementById("leftFrame");
y=parent.document.getElementById("rightFrame");

document.write("The name of leftFrame is: ");
document.write(x.name);

document.write("<br />The name of rightFrame is: ");
document.write(y.name);
</script>

</body>
</html>

TIY

返回框架的名称

返回 HTML DOM Frame 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM name 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM name 属性

返回 HTML DOM Iframe 对象参考手册

定义和用法

name 属性可设置或返回 iframe 的名称。

语法

iframeObject.name=name

实例

下面的例子可返回 iframe 的名称：

<html>
<body>
<iframe src="frame_a.htm" id="frame1" name="iframe">
</iframe><br />

<script type="text/javascript">
x=document.getElementById("frame1");
document.write("The iframe's name is: ");
document.write(x.name);
</script>

</body>
</html>

TIY

返回 <iframe> 的名称

返回 HTML DOM Iframe 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM name 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM name 属性

返回 HTML DOM Image 对象参考手册

定义和用法

name 属性可设置或返回图像的名称。

如果一个 <img> 有一个 name 属性，就可以把相应的 Image 对象作为 Document 对象的命名属性来访问。

语法

imageObject.name=name

实例

下面的例子可返回图像的名称：

<html>
<body>
<img id="compman" name="compman"
src="compman.gif" alt="Computerman" width="107" height="98" />
<br />

<script type="text/javascript">
document.write("Image name: ");
document.write(document.getElementById('compman').name);
</script>

</body>
</html>

TIY

取得图像的名称

返回 HTML DOM Image 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM name 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM name 属性

返回 HTML DOM Button 对象参考手册

定义和用法

name 属性可设置或返回按钮的名称。

语法

buttonObject.name=name

实例

下面的例子可返回按钮的名称：

<html>
<body>

<form>
<input type="button" id="button1"
name="button1" value="Click Me!" />
</form>

<p>The name of the button is:
<script type="text/javascript">
x=document.getElementById('button1');
document.write(x.name);
</script></p>

</body>
</html>

TIY

返回按钮的名称

返回 HTML DOM Button 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM name 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM name 属性

返回 HTML DOM Checkbox 对象参考手册

定义和用法

name 属性可设置或返回 checkbox 的名称。

语法

checkboxObject.name=name

实例

下面的例子可输出 checkbox 的名称：

<html>
<body>

<form>
<input type="checkbox" id="check1" name="check1" />
</form>

<p>The name of the checkbox is:
<script type="text/javascript">
document.write(document.getElementById("check1").name)
</script>
</p>

</body>
</html>

TIY

取得 checkbox 的名称

返回 HTML DOM Checkbox 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM name 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM name 属性

返回 HTML DOM Hidden 对象参考手册

定义和用法

name 属性可设置或返回隐藏输入域的名称。

语法

hiddenObject.name=name

实例

下面的例子可返回隐藏输入域的名称：

<html>
<body>

<form>
<input type="hidden" id="hidden1" name="hidden1" />
</form>

<p>The name of the hidden field is:
<script type="text/javascript">
alert(document.getElementById("hidden1").name)
</script></p>

</body>
</html>

TIY

取得隐藏输入域的名称

返回 HTML DOM Hidden 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM name 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM name 属性

返回 HTML DOM Password 对象参考手册

定义和用法

name 属性可设置或返回密码域的名称。

语法

passwordObject.name=name

实例

下面的例子可获得密码域的名称：

<html>
<body>

<form id="form1">
<input type="password" id="password1" name="password1" />
</form>

<p>The name of the password field is:
<script type="text/javascript">
x=document.getElementById('password1');
document.write(x.name);
</script></p>

</body>
</html>

TIY

获得密码域的名称

返回 HTML DOM Password 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM name 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM name 属性

返回 HTML DOM Reset 对象参考手册

定义和用法

name 属性可设置或返回重置按钮的名称。

语法

resetObject.name=name

实例

下面的例子将返回重置按钮的名称：

<html>
<body>

<form>
<input type="reset" id="reset1" name="reset1" />
</form>

<p>The name of the reset button is:
<script type="text/javascript">
x=document.getElementById('reset1');
document.write(x.name);
</script></p>

</body>
</html>

TIY

返回重置按钮的名称

返回 HTML DOM Reset 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM name 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM name 属性

返回 HTML DOM Reset 对象参考手册

定义和用法

tabIndex 属性可设置或返回重置按钮的 tab 键控制次序。

语法

resetObject.tabIndex=tabIndex

实例

下面的例子可显示表单元素的 tab 键控制次序：

<html>
<head>
<script type="text/javascript">
function showTabIndex()
  {
  var email=document.getElementById('email').tabIndex;
  var r1=document.getElementById('reset1').tabIndex;
  document.write("Tab index of email: " + email);
  document.write("<br />");
  document.write("Tab index of reset button: " + r1);
  }
</script>
</head>
<body>

<form>
Email: <input type="text" id="email" tabindex="1"
size="25" value="someone@example.com" />
<br />
<input type="reset" id="reset1" tabindex="2" />
<br /><br />
<input type="button" onclick="showTabIndex()"
value="Show tabIndex" />
</form>

</body>
</html>

TIY

显示表单元素的 tab 键控制次序

返回 HTML DOM Reset 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM name 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM name 属性

返回 HTML DOM Submit 对象参考手册

定义和用法

name 属性可设置或返回确认按钮的名称。

语法

submitObject.name=name

实例

下面的例子可显示出该确认按钮的名称：

<html>
<body>

<form>
<input type="submit" id="submit1" name="submit1" />
</form>

<p>The name of the submit button is:
<script type="text/javascript">
x=document.getElementById('submit1');
document.write(x.name);
</script></p>

</body>
</html>

TIY

取得一个确认按钮的名称

返回 HTML DOM Submit 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM name 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM name 属性

返回 HTML DOM Text 对象参考手册

定义和用法

name 属性设置或返回文本域的名称。

语法

textObject.name=name

实例

下面的例子获得了文本域的名称：

<html>
<body>

<form>
Email: <input type="text" id="email" name="email" />
</form>

<p>The name of the text field is:
<script type="text/javascript">
x=document.getElementById('text1');
document.write(x.name);
</script></p>

</body>
</html>

TIY

获得文本域的名称

返回 HTML DOM Text 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM name 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM name 属性

返回 HTML DOM Link 对象参考手册

定义和用法

The name property sets or returns the name of a element.

语法

linkObject.name=name

实例

The following example outputs the name of a link element:

<html>
<head>
<link rel="stylesheet" type="text/css" name="stylesheet"
id="style1" href="try_dom_link.css" />

<script type="text/javascript">
function alertName()
  {
  alert(document.getElementById("style1").name);
  }
</script>
</head>
<body>

<form>
<input type="button" onclick="alertName()"
value="Alert name attribute" />
</form>

</body>
</html>

TIY

Get the name attribute of a <link> element

返回 HTML DOM Link 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM name 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM name 属性

返回 HTML DOM Meta 对象参考手册

定义和用法

name 属性把 content 属性连接到 name。

语法

metaObject.name=author|description|keywords|generator|revised|others

实例

本例的 <meta> 标签为搜索引擎定义了一些关键词。以下代码返回 content 属性的值：

<html>
<head>
<meta name="keywords" content="HTML,DHTML,CSS,JavaScript" />
</head>
<body>

<script type="text/javascript">
x=document.getElementsByTagName("meta")[0];
document.write("Meta name: " + x.name);
</script>

</body>
</html>

TIY

获得 <meta> 元素的 content 属性的名称

返回 HTML DOM Meta 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM name 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM name 属性

返回 HTML DOM Select 对象参考手册

定义和用法

name 属性可设置或返回下拉列表的名称。

语法

selectObject.name=name

实例

下面的例子可提示下拉列表的名称：

<html>
<head>
<script type="text/javascript">
function getName()
  {
  alert(document.getElementById("mySelect").name)
  }
</script>
</head>
<body>

<form>
<select name="mySelect" id="mySelect">
  <option>Apple</option>
  <option>Pear</option>
  <option>Banana</option>
  <option>Orange</option>
</select>
<input type="button" onclick="getName()"
value="Alert name">
</form>

</body>
</html>

TIY

取得下拉列表的名称

返回 HTML DOM Select 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM name 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM name 属性

返回 HTML DOM Textarea 对象参考手册

定义和用法

name 属性设置或返回 textarea 的名称。

语法

textareaObject.name=text

实例

本例设置 textarea 的名称：

<html>
<head>
<script type="text/javascript">
function alertName()
  {
  alert(document.getElementById('txt1').name);
  }
</script>
</head>
<body>

<textarea id="txt1" name="textarea1">
Hello world....This is a text area
</textarea>
<br />
<input type="button" onclick="alertName()" value="Alert name" />

</body>
</html>

返回 HTML DOM Textarea 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Navigator 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Navigator 对象

Navigator 对象

Navigator 对象实际上是一个 JavaScript 对象,而不是 HTML DOM 对象。

Navigator 对象是由 JavaScript runtime engine 自动创建的，包含有关客户机浏览器的信息。

IE: Internet Explorer, F: Firefox, O: Opera.

Navigator 对象的集合

集合 | 描述 | IE | F | O
plugins[] | 返回对文档中所有嵌入式对象的引用。 该集合是一个 Plugin 对象的数组，其中的元素代表浏览器已经安装的插件。Plug-in 对象提供的是有关插件的信息，其中包括它所支持的 MIME 类型的列表。 虽然 plugins[] 数组是由 IE 4 定义的，但是在 IE 4 中它却总是空的，因为 IE 4 不支持插件和 Plugin 对象。 | 4 | 1 | 9

Navigator 对象的属性

属性 | 描述 | IE | F | O
appCodeName | 返回浏览器的代码名。 | 4 | 1 | 9
appMinorVersion | 返回浏览器的次级版本。 | 4 | No | No
appName | 返回浏览器的名称。 | 4 | 1 | 9
appVersion | 返回浏览器的平台和版本信息。 | 4 | 1 | 9
browserLanguage | 返回当前浏览器的语言。 | 4 | No | 9
cookieEnabled | 返回指明浏览器中是否启用 cookie 的布尔值。 | 4 | 1 | 9
cpuClass | 返回浏览器系统的 CPU 等级。 | 4 | No | No
onLine | 返回指明系统是否处于脱机模式的布尔值。 | 4 | No | No
platform | 返回运行浏览器的操作系统平台。 | 4 | 1 | 9
systemLanguage | 返回 OS 使用的默认语言。 | 4 | No | No
userAgent | 返回由客户机发送服务器的 user-agent 头部的值。 | 4 | 1 | 9
userLanguage | 返回 OS 的自然语言设置。 | 4 | No | 9

Navigator 对象的方法

方法 | 描述 | IE | F | O
javaEnabled() | 规定浏览器是否启用 Java。 | 4 | 1 | 9
taintEnabled() | 规定浏览器是否启用数据污点 (data tainting)。 | 4 | 1 | 9

HTML DOM 参考手册
HTML DOM 实例


HTML DOM noHref 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM noHref 属性

返回 HTML DOM Area 对象参考手册

定义和用法

noHref 属性可设置或返回某个区域是活动的还是非活动的。

语法

areaObject.noHref=true|false

说明

<area> 标签的 nohref 属性在客户端图像映射中定义了一个对鼠标敏感的区域，而该区域不会在用户选取它时采取任何操作。你必须为每个 <area> 标签都包含一个 href 或 nohref 属性。

实例

下面的例子可返回图像映射中 "Venus" 区域的 "noHref" 状态：

<html>
<body>

<img src="planets.gif"
width="145" height="126"
usemap="#planetmap" />

<map name="planetmap">
<area id="venus" shape="circle"
coords="124,58,8"
alt="Venus"
href="venus.htm" />
</map>

<p>noHref status:
<script type="text/javascript">
x=document.getElementById('venus');
document.write(x.noHref);
</script>
</p>

</script>
</body>
</html>

TIY

返回图像映射中某个区域的 noHref 状态

返回 HTML DOM Area 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM noResize 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM noResize 属性

返回 HTML DOM Frame 对象参考手册

定义和用法

noResize 属性可设置或返回是否可调整框架的大小。

语法

frameObject.noResize=true|false

实例

在我们的例子中，首先将创建包含带有两个列的框架集的 HTML 文档。每列设置为浏览器窗口的 50%：

<html>
  <frameset cols="50%,50%">
    <frame id="leftFrame" src="frame_noresize.htm">
    <frame id="rightFrame" src="frame_a.htm">
  </frameset>
</html>

HTML 文档 "frame_noresize.htm" 被放入第一列，而 HTML 文档 "frame_a.htm" 被放入第二列。

下面是 "frame_noresize.htm" 的源代码：

<html>
<head>
<script type="text/javascript">
function disableResize()
  {
  parent.document.getElementById("leftFrame").noResize=true
  parent.document.getElementById("rightFrame").noResize=true
  }
function enableResize()
  {
  parent.document.getElementById("leftFrame").noResize=false
  parent.document.getElementById("rightFrame").noResize=false
  }
</script>
</head>

<body>
<input type="button" onclick="disableResize()" value="No resize" />
<input type="button" onclick="enableResize()" value="Resize" />
</body>

</html>

TIY

可调整大小和不可调整大小的框架

返回 HTML DOM Frame 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Object 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Object 对象

Link 对象

Object 对象代表 HTML 的 <object> 元素。

<object> 元素用于嵌入的可执行内容。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet Standard).

Link Object Properties

属性 | 描述 | IE | F | O | W3C
align | Sets or returns the alignment of the object according to the surrounding text | 5 | 1 | 9 | Yes
archive | Sets or returns a string that can be used to implement your own archive functionality for the object | 6 | 1 | 9 | Yes
border | Sets or returns the border around the object |  |  |  | Yes
code | Sets or returns the URL of the file that contains the compiled Java class | 5 | 1 | 9 | Yes
codeBase | Sets or returns the URL of the component | 5 | 1 | 9 | Yes
codeType |  |  |  |  | Yes
data |  |  | 1 | 9 | Yes
declare |  |  |  |  | Yes
form | Returns a reference to the object's parent form |  |  |  | Yes
height | Sets or returns the height of the object |  | 1 | 9 | Yes
hspace | Sets or returns the horizontal margin of the object | 5 | 1 | 9 | Yes
id | Sets or returns the id of the object | 4 | 1 | 9 | Yes
name | Sets or returns the name of the object | 5 | 1 | 9 | Yes
standby | Sets or returns a message when loading the object |  |  |  | Yes
tabIndex | Sets or returns the tab order for the object | 5 |  |  | Yes
type | Sets or returns the content type for data downloaded via the data attribute |  | 1 | 9 | Yes
useMap |  |  | 1 | 9 | Yes
vspace | Sets or returns the vertical margin of the object | 5 | 1 | 9 | Yes
width | Sets or returns the width of the object |  | 1 | 9 | Yes

Standard Properties

Property | Description | IE | F | O | W3C
className | Sets or returns the class attribute of an element | 5 | 1 | 9 | Yes
dir | Sets or returns the direction of text | 5 | 1 | 9 | Yes
lang | Sets or returns the language code for an element | 5 | 1 | 9 | Yes
title | Sets or returns an element's advisory title | 5 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM onabort 事件句柄

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM onabort 事件句柄

返回 HTML DOM Image 对象参考手册

定义和用法

当用户放弃图像的装载时调用的事件句柄。

语法

imageObject.onabort

说明

Image 对象的属性 onabort 声明了一个事件句柄函数，当用户在图像完成载入之前放弃图像的装载（如单击了 Stop 按钮）时，就会调用这个句柄。

返回 HTML DOM Image 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM onchange 事件句柄

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM onchange 事件句柄

返回 HTML DOM Select 对象参考手册

定义和用法

当改变选择时调用的事件句柄。

语法

selectObject.onchange

说明

Select 对象的 onchange 属性引用了一个事件句柄函数。当用户选中一个选项，或者取消了对一个选项的选定时，就会调用该句柄。这个事件不会指定新的选项是什么，必须通过 Select 对象的 selectedIndex 属性，或者各个 Option 对象的 selected 属性来确定这一点。

返回 HTML DOM Select 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM onchange 事件句柄

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM onchange 事件句柄

返回 HTML DOM Textarea 对象参考手册

定义和用法

select() 方法用于选择该元素中的文本。

语法

textareaObject.onchange

说明

Textarea 的 onchange 属性引用了一个事件句柄函数，当用户改变文本区域的值然后通过把键盘焦点移动到其他地方“确认”这些改变的时候，调用该句柄。

请注意，当一个 Text 对象的 value 属性通过 JavaScript 设置的时候，onchange 事件句柄不会调用。还要注意，该句柄是为了处理对输入值的一次完整改变，因此，它不会在逐个按键的基础上调用。

返回 HTML DOM Textarea 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM onerror 事件句柄

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM onerror 事件句柄

返回 HTML DOM Image 对象参考手册

定义和用法

在装载图像的过程中发生错误时调用的事件句柄。

语法

imageObject.onerror

说明

Image 对象的属性 onerror 声明了一个事件句柄函数，当装载图像的过程中发生了错误时就会调用这个句柄。

返回 HTML DOM Image 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM onLine 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM onLine 属性

返回 HTML DOM Navigator 对象参考手册

定义和用法

onLine 属性是一个只读的布尔值，声明了系统是否处于脱机模式。

注释：在 IE 4+ 中，用户可以在浏览器中选择脱机工作的状态。当脱机工作被选后，系统就进入了脱机状态，内容将从缓存进行读取。

语法

navigator.onLine

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>OnLine: ")
document.write(navigator.onLine + "</p>")
</script>
</body>

</html>

TIY

检测访问者的浏览器和版本号
有关访问者的浏览器的更多信息
有关访问者的浏览器的全部细节
根据浏览器来提醒用户

返回 HTML DOM Navigator 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM onload 事件句柄

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM onload 事件句柄

返回 HTML DOM Image 对象参考手册

定义和用法

当图像装载完毕时调用的事件句柄。

语法

imageObject.onload

说明

Image 对象的属性 onload 声明了一个事件句柄函数，当图像装载完毕的时候就会调用这个句柄。

返回 HTML DOM Image 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM onreset 事件句柄

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM onreset 事件句柄

返回 HTML DOM Form 对象参考手册

定义和用法

在重置表单时调用的处理器。

语法

form.onreset

说明

Form 对象的 onreset 属性指定了一个事件句柄函数。当用户单击了表单中的 Reset 按钮而提交一个重置时，就会调用这个事件句柄函数。注意，这个句柄不会作为 Form.reset() 方法响应而被调用。如果 onreset 句柄返回 fasle，表单的元素就不会重置。

返回 HTML DOM Form 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM onsubmit 事件句柄

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM onsubmit 事件句柄

返回 HTML DOM Form 对象参考手册

定义和用法

在提交表单时调用的事件句柄。

语法

form.onsubmit

说明

Form 对象的 onsubmit 属性指定了一个事件句柄函数。当用户单击了表单中的 Reset 按钮而提交一个重置时，就会调用这个事件句柄函数。注意，当调用方法Form.submit() 时，该处理器函数不会被调用。

如果 onsubmit 句柄返回 fasle，表单的元素就不会提交。如果该函数返回其他值或什么都没有返回，则表单会被提交。

提示和注释

提示：由于 onsubmit 句柄可以取消表单的提交，所以它对于进行表单验证是十分理想的。

返回 HTML DOM Form 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM open() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM open() 方法

返回 HTML DOM Window 对象参考手册

定义和用法

open() 方法用于打开一个新的浏览器窗口或查找一个已命名的窗口。

语法

window.open(URL,name,features,replace)
参数 | 描述
URL | 一个可选的字符串，声明了要在新窗口中显示的文档的 URL。如果省略了这个参数，或者它的值是空字符串，那么新窗口就不会显示任何文档。
name | 一个可选的字符串，该字符串是一个由逗号分隔的特征列表，其中包括数字、字母和下划线，该字符声明了新窗口的名称。这个名称可以用作标记 <a> 和 <form> 的属性 target 的值。如果该参数指定了一个已经存在的窗口，那么 open() 方法就不再创建一个新窗口，而只是返回对指定窗口的引用。在这种情况下，features 将被忽略。
features | 一个可选的字符串，声明了新窗口要显示的标准浏览器的特征。如果省略该参数，新窗口将具有所有标准特征。在窗口特征这个表格中，我们对该字符串的格式进行了详细的说明。
replace

一个可选的布尔值。规定了装载到窗口的 URL 是在窗口的浏览历史中创建一个新条目，还是替换浏览历史中的当前条目。支持下面的值：

  • true - URL 替换浏览历史中的当前条目。
  • false - URL 在浏览历史中创建新的条目。

提示和注释

重要事项：请不要混淆方法 Window.open() 与方法 Document.open()，这两者的功能完全不同。为了使您的代码清楚明白，请使用 Window.open()，而不要使用 open()。

实例 1

下面的例子讲在新浏览器窗口中打开 www.w3school.com.cn ：

<html>
<head>
<script type="text/javascript">
function open_win()
{
window.open("http://www.w3school.com.cn")
}
</script>
</head>
<body>

<input type=button value="Open Window" onclick="open_win()" />

</body>
</html>

实例 2

下面的例子讲在新浏览器窗口中打开 about:blank 页：

<html>
<body>

<script type="text/javascript">
myWindow=window.open('','','width=200,height=100')
myWindow.document.write("This is 'myWindow'")
myWindow.focus()
</script>

</body>
</html>

TIY

通过点击按钮来打开一个窗口
打开一个新窗口，并控制其外观
通过一次点击打开多个窗口
打开一个新窗口

窗口特征（Window Features）

channelmode=yes|no|1|0 | 是否使用剧院模式显示窗口。默认为 no。
directories=yes|no|1|0 | 是否添加目录按钮。默认为 yes。
fullscreen=yes|no|1|0 | 是否使用全屏模式显示浏览器。默认是 no。处于全屏模式的窗口必须同时处于剧院模式。
height=pixels | 窗口文档显示区的高度。以像素计。
left=pixels | 窗口的 x 坐标。以像素计。
location=yes|no|1|0 | 是否显示地址字段。默认是 yes。
menubar=yes|no|1|0 | 是否显示菜单栏。默认是 yes。
resizable=yes|no|1|0 | 窗口是否可调节尺寸。默认是 yes。
scrollbars=yes|no|1|0 | 是否显示滚动条。默认是 yes。
status=yes|no|1|0 | 是否添加状态栏。默认是 yes。
titlebar=yes|no|1|0 | 是否显示标题栏。默认是 yes。
toolbar=yes|no|1|0 | 是否显示浏览器的工具栏。默认是 yes。
top=pixels | 窗口的 y 坐标。
width=pixels | 窗口的文档显示区的宽度。以像素计。

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM open() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM open() 方法

返回 HTML DOM Document 对象参考手册

定义和用法

open() 方法可打开一个新文档，并擦除当前文档的内容。

语法

document.open(mimetype,replace)
参数 | 描述
mimetype | 可选。规定正在写的文档的类型。默认值是 "text/html"。
replace | 可选。当此参数设置后，可引起新文档从父文档继承历史条目。

说明

该方法将擦除当前 HTML 文档的内容，开始一个新的文档，新文档用 write() 方法或 writeln() 方法编写。

提示和注释

重要事项：调用 open() 方法打开一个新文档并且用 write() 方法设置文档内容后，必须记住用 close 方法关闭文档，并迫使其内容显示出来。

注释：属于被覆盖的文档的一部分的脚本或事件句柄不能调用该方法，因为脚本或事件句柄自身也会被覆盖。

实例

<html>
<head>
<script type="text/javascript">
function createNewDoc()
  {
  var newDoc=document.open("text/html","replace");
  var txt="<html><body>Learning about the DOM is FUN!</body></html>";
  newDoc.write(txt);
  newDoc.close();
  }
</script>
</head>
<body>

<input type="button" value="Write to a new document"
onclick="createNewDoc()">

</body>
</html>

TIY

打开一个新的文档，添加一些文本，然后关闭它。
在新窗口打开新的文档，并添加一些文本。

返回 HTML DOM Document 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM opener 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM opener 属性

返回 HTML DOM Window 对象参考手册

定义和用法

opener 属性是一个可读可写的属性，可返回对创建该窗口的 Window 对象的引用。

opener 属性非常有用，创建的窗口可以引用创建它的窗口所定义的属性和函数。

语法

window.opener

提示和注释

注释：只有表示顶层窗口的 Window 对象的 operner 属性才有效，表示框架的 Window 对象的 operner 属性无效。

实例

下面的例子可向 opener 窗口写文本（父窗口）：

<html>
<body>

<script type="text/javascript">
myWindow=window.open('','MyName','width=200,height=100')
myWindow.document.write("This is 'myWindow'")
myWindow.focus()
myWindow.opener.document.write("This is the parent window")
</script>

</body>
</html>

TIY

向 opener 窗口写文本

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Option 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Option 对象

Option 对象

Option 对象代表 HTML 表单中下拉列表中的一个选项。

在 HTML 表单中 <option> 标签每出现一次，一个 Option 对象就会被创建。

您可通过表单的 elements[] 数组访问一个 Option 对象，或者通过使用 document.getElementById()。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet 标准).

Option 对象的属性

属性 | 描述 | IE | F | O | W3C
defaultSelected | 返回 selected 属性的默认值。 | 4 | 1 | 9 | Yes
disabled | 设置或返回选项是否应被禁用。 | 4 | 1 | 9 | Yes
form | 返回对包含该元素的 <form> 元素的引用。 | 4 | 1 | 9 | Yes
id | 设置或返回选项的 id。 | 4 | 1 | 9 | Yes
index | 返回下拉列表中某个选项的索引位置。 | 4 | 1 | 9 | Yes
label | 设置或返回选项的标记(仅用于选项组option-groups)。 | 6 |  |  | Yes
selected | 设置或返回 selected 属性的值。 | 4 | 1 | 9 | Yes
text | 设置或返回某个选项的纯文本值。 | 4 | 1 | 9 | Yes
value | 设置或返回被送往服务器的值。 | 4 | 1 | 9 | Yes

Standard Properties

Property | Description | IE | F | O | W3C
className | Sets or returns the class attribute of an element | 5 | 1 | 9 | Yes
dir | Sets or returns the direction of text | 5 | 1 | 9 | Yes
lang | Sets or returns the language code for an element | 5 | 1 | 9 | Yes
title | Sets or returns an element's advisory title | 5 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM options 集合

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM options 集合

返回 HTML DOM Select 对象参考手册

定义和用法

option 集合可返回包含 <select> 元素中所有 <option> 的一个数组。

注释：数组中的每个元素对应一个 <option> 标签 - 由 0 起始。

语法

selectObject.options[]

说明

options[] 集合并非一个普通的 HTMLcollection。为了和早期的浏览器向后兼容，这个集合有某种特殊的行为：允许通过 Select 对象来改变显示的选项：

  • 如果把 options.length 属性设置为 0,Select 对象中所有选项都会被清除。
  • 如果 options.length 属性的值比当前值小，出现在数组尾部的元素就会被丢弃。
  • 如果把 options[] 数组中的一个元素设置为 null，那么选项就会从 Select 对象中删除。
  • 可以通过构造函数 Option() 来创建一个新的 option 对象（需要设置 options.length 属性）。

实例

下面的例子可输出下拉列表中所有选项的文本：

<html>
<head>
<script type="text/javascript">
function getOptions()
  {
  var x=document.getElementById("mySelect");
  for (i=0;i<x.length;i++)
    {
    document.write(x.options[i].text)
    document.write("<br />")
    }
  }
</script>
</head>
<body>

<form>
Select your favorite fruit:
<select id="mySelect">
  <option>Apple</option>
  <option>Orange</option>
  <option>Pineapple</option>
  <option>Banana</option>
</select>
<br /><br />
<input type="button" onclick="getOptions()"
value="Output all options">
</form>

</body>
</html>

TIY

输出下拉列表中所有选项的文本
设置下拉列表中被选选项的文本

返回 HTML DOM Select 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM outerheight 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM outerheight 属性

返回 HTML DOM Window 对象参考手册

定义和用法

outerheight 属性是一个只读的整数，声明了整个窗口的高度。

语法

window.outerheight=pixels

提示和注释

提示：IE 不支持此属性，且没有提供替代的属性。

实例

下面的例子可把新窗口设置为 100x100 像素：

<html>
<body>

<script type="text/javascript">
myWindow=window.open('','')
myWindow.outerheight="100"
myWindow.outerwidth="100"
myWindow.document.write("This is 'myWindow'")
myWindow.focus()
</script>

</body>
</html>

TIY

设置窗口的高度和宽度

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM outerwidth 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM outerwidth 属性

返回 HTML DOM Window 对象参考手册

定义和用法

outerwidth 属性是一个只读的整数，声明了整个窗口的宽度。

语法

window.outerwidth=pixels

提示和注释

提示：IE 不支持此属性，且没有提供替代的属性。

实例

下面的例子可把新窗口设置为 100x100 像素：

<html>
<body>

<script type="text/javascript">
myWindow=window.open('','')
myWindow.outerheight="100"
myWindow.outerwidth="100"
myWindow.document.write("This is 'myWindow'")
myWindow.focus()
</script>

</body>
</html>

TIY

设置窗口的高度和宽度

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM outline 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM outline 属性

返回HTML DOM Style 对象参考手册

定义和用法

outline 属性在一个声明中设置所有轮廓属性。

语法：

Object.style.outline = outlineWidth outlineStyle outlineColor

可能的值

值 描述 值
outlineWidth 设置轮廓的宽度。
  • thin
  • medium
  • thick
  • length
outlineStyle 设置轮廓的样式。
  • none
  • hidden
  • dotted
  • dashed
  • solid
  • double
  • groove
  • ridge
  • inset
  • outset
outlineColor 设置轮廓的颜色。
  • color-name
  • color-rgb
  • color-hex
  • transparent

实例

下面的例子改变段落周围的轮廓：

<html>
<head>
<style type="text/css">
p
{
border: thin solid #00FF00;
outline: thick solid #FF0000;
}
</style>
<script type="text/javascript">
function changeOutline()
{
document.getElementById("p1").style.outline="thin dotted #0000FF";
}
</script>
</head>
<body>

<input type="button" onclick="changeOutline()"
value="Change outline" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

outline - 改变元素周围的轮廓（请在非 IE 浏览器中浏览）

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM outlineColor 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM outlineColor 属性

返回HTML DOM Style 对象参考手册

定义和用法

outlineColor 属性设置元素周围的轮廓的颜色。

语法：

Object.style.outlineColor=color-name|color-rgb|color-hex

实例

本例改变轮廓的颜色：

<html>
<head>
<style type="text/css">
p
{
border: thin solid #00FF00;
outline: thick solid #FF0000;
}
</style>
<script type="text/javascript">
function changeOutlineColor()
{
document.getElementById("p1").style.outlineColor="#00FF00";
}
</script>
</head>
<body>

<input type="button" onclick="changeOutlineColor()"
value="Change outline color" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

outlineColor - 改变围绕元素的轮廓的颜色（请在非 IE 浏览器中浏览）

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM outlineStyle 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM outlineStyle 属性

返回HTML DOM Style 对象参考手册

定义和用法

outlineStyle 属性设置围绕元素的轮廓的样式。

语法：

Object.style.outlineStyle=style

可能的值

值 | 描述
none | 默认。定义无轮廓。
dotted | 定义一个点状的轮廓。
dashed | 定义一个虚线轮廓。
solid | 定义一个实线轮廓。
double | 定义一个双线轮廓。双线的宽度等同于 outline-width 的值。
groove | 定义一个 3D 凹槽轮廓。此效果取决于 outline-color 值。
ridge | 定义一个 3D 凸槽轮廓。此效果取决于 outline-color 值。
inset | 定义一个 3D 凹边轮廓。此效果取决于 outline-color 值。
outset | 定义一个 3D 凸边轮廓。此效果取决于 outline-color 值。

实例

下面的例子改变轮廓的样式：

<html>
<head>
<style type="text/css">
p
{
border: thin solid #00FF00;
outline: thick solid #FF0000;
}
</style>
<script type="text/javascript">
function changeOutline()
{
document.getElementById("p1").style.outlineStyle="dotted";
}
</script>
</head>
<body>

<input type="button" onclick="changeOutline()"
value="Change outline style" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

outlineStyle - 改变围绕元素的轮廓的样式（请在非 IE 浏览器中浏览）

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM outlineWidth 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM outlineWidth 属性

返回HTML DOM Style 对象参考手册

定义和用法

outlineWidth 属性设置围绕元素的轮廓的宽度。

语法：

Object.style.outlineWidth=thin|medium|thick|length

可能的值

值 | 描述
thin | 定义细轮廓。
medium | 默认。定义中等的轮廓。
thick | 定义粗的轮廓。
length | 允许您定义轮廓粗细的值。

实例

本例改变轮廓的宽度：

<html>
<head>
<style type="text/css">
p
{
border: thin solid #00FF00;
outline: thick solid #FF0000;
}
</style>
<script type="text/javascript">
function changeOutlineWidth()
{
document.getElementById("p1").style.outlineWidth="thin";
}
</script>
</head>
<body>

<input type="button" onclick="changeOutlineWidth()"
value="Change outline width" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

outlineWidth - 改变围绕元素的轮廓的宽度（请在非 IE 浏览器中浏览）

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM overflow 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM overflow 属性

返回HTML DOM Style 对象参考手册

定义和用法

overflow 属性规定如何处理如何处理不符合元素框的内容。

语法：

Object.style.overflow=visible|hidden|scroll|auto

可能的值

值 | 描述
visible | 内容不会被修剪，会呈现在元素框之外。
hidden | 内容会被修剪，但是浏览器不会显示供查看内容的滚动条。
scroll | 内容会被修剪，但是浏览器会显示滚动条以便查看其余的内容。
auto | 由浏览器决定如何显示。如果需要，则显示滚动条。

实例

本例使用 overflow 来显示溢出元素框的内容：

<html>
<head>
<style type="text/css">
div
{
border:thin solid green;
width:100px;
height:100px;
}
</style>
<script type="text/javascript">
function hideOverflow()
{
document.getElementById("div1").style.overflow="hidden";
}
</script>
</head>
<body>

<div id="div1">
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
</div>
<br />
<input type="button" onclick="hideOverflow()"
value="Hide overflow" />

</body>
</html>

TIY

overflow - 隐藏内容溢出

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM padding 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM padding 属性

返回HTML DOM Style 对象参考手册

定义和用法

padding 属性设置元素的内边距。

padding 属性定义元素边框与元素内容之间的空间。

该属性可采取 4 个值：

  • 如果规定一个值，比如 div {padding: 50px} - 所有四个边的 padding 都是 50 px。
  • 如果规定两个值，比如 div {padding: 50px 10px} - 上下内边距是 50 px，左右内边距是 10 px。
  • 如果规定三个值，比如 div {padding: 50px 10px 20px} - 上内边距是 50 px，左右内边距是 10 px，下内边距是 20 px。
  • 如果规定四个值，比如 div {padding: 50px 10px 20px 30px} - 上内边距是 50 px，右内边距是 10 px，下内边距是 20 px，左内边距是 30 px。

语法：

Object.style.padding=padding

Possible Values

值 描述
padding

设置内边距。

值可以是：

  • 百分比（基于父对象总高度或宽度的百分比）
  • 长度值（定义一个固定的边距）
  • auto（浏览器设定的值）。

实例

本例改变元素的内边距：

<html>
<head>
<style type="text/css">
p
{
border: thin dotted #FF0000;
}
</style>
<script type="text/javascript">
function changePadding()
{
document.getElementById("p1").style.padding="2cm";
}
</script>
</head>
<body>

<input type="button" onclick="changePadding()"
value="Change padding" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

padding - 改变元素的内边距

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM paddingBottom 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM paddingBottom 属性

返回HTML DOM Style 对象参考手册

定义和用法

paddingBottom 属性设置元素的下内边距。

padding 属性定义元素边框与元素内容之间的空间。

语法：

Object.style.paddingBottom=length|%

可能的值

值 | 描述
length | 定义固定的下内边距值。默认值是 0。
% | 定义基于父元素高度的百分比下内边距。此值不会如预期的那样工作于所有的浏览器中。

实例

下面的例子改变元素的下内边距：

<html>
<head>
<style type="text/css">
p
{
border: thin dotted #FF0000;
}
</style>
<script type="text/javascript">
function changePadding()
{
document.getElementById("p1").style.paddingBottom="2cm";
}
</script>
</head>
<body>

<input type="button" onclick="changePadding()"
value="Change bottom padding" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

paddingBottom - 改变元素的下内边距

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM paddingLeft 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM paddingLeft 属性

返回HTML DOM Style 对象参考手册

定义和用法

paddingLeft 属性设置元素的左内边距。

padding 属性定义元素边框与元素内容之间的空间。

语法：

Object.style.paddingLeft=length|%

可能的值

值 | 描述
length | 定义固定的下内边距值。默认值是 0。
% | 定义基于父元素高度的百分比下内边距。此值不会如预期的那样工作于所有的浏览器中。

实例

本例改变元素的左内边距：

<html>
<head>
<style type="text/css">
p
{
border: thin dotted #FF0000;
}
</style>
<script type="text/javascript">
function changePadding()
{
document.getElementById("p1").style.paddingLeft="2cm";
}
</script>
</head>
<body>

<input type="button" onclick="changePadding()"
value="Change left padding" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

paddingLeft - 改变元素的左内边距

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM paddingRight 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM paddingRight 属性

返回HTML DOM Style 对象参考手册

定义和用法

paddingRight 属性设置元素的右内边距。

padding 属性定义元素边框与元素内容之间的空间。

语法：

Object.style.paddingRight=auto|length|%

可能的值

值 | 描述
length | 定义固定的下内边距值。默认值是 0。
% | 定义基于父元素高度的百分比下内边距。此值不会如预期的那样工作于所有的浏览器中。

实例

本例改变元素的右内边距：

<html>
<head>
<style type="text/css">
p
{
border: thin dotted #FF0000;
}
</style>
<script type="text/javascript">
function changePadding()
{
document.getElementById("p1").style.paddingRight="2cm";
}
</script>
</head>
<body>

<input type="button" onclick="changePadding()"
value="Change right padding" />

<p id="p1">This is a paragraph. This is a paragraph.
This is a paragraph. This is a paragraph.
This is a paragraph. This is a paragraph.</p>

</body>
</html>

TIY

paddingRight - 改变元素的右内边距

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM paddingTop 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM paddingTop 属性

返回HTML DOM Style 对象参考手册

定义和用法

padding 属性设置元素的上内边距。

padding 属性定义元素边框与元素内容之间的空间。

语法：

Object.style.paddingTop=length|%

可能的值

值 | 描述
length | 定义固定的下内边距值。默认值是 0。
% | 定义基于父元素高度的百分比下内边距。此值不会如预期的那样工作于所有的浏览器中。

实例

本例改变元素的上内边距：

<html>
<head>
<style type="text/css">
p
{
border: thin dotted #FF0000;
}
</style>
<script type="text/javascript">
function changePadding()
{
document.getElementById("p1").style.paddingTop="2cm";
}
</script>
</head>
<body>

<input type="button" onclick="changePadding()"
value="Change top padding" />

<p id="p1">This is a paragraph</p>

</body>
</html>

TIY

paddingTop - 改变元素的上内边距

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM pageBreakAfter 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM pageBreakAfter 属性

返回HTML DOM Style 对象参考手册

定义和用法

pageBreakAfter 属性设置元素后否应当放置分页符。

语法：

Object.style.pageBreakAfter=auto|always|avoid|left|right

可能的值

值 | 描述
auto | 默认。如果必要则在元素后插入分页符。
always | 在元素后插入分页符。
avoid | 避免在元素后插入分页符。
left | 在元素之后足够的分页符，一直到一张空白的左页为止。
right | 在元素之后足够的分页符，一直到一张空白的右页为止。

实例

本例在 id 为 p1 的段落之后设置了一个 page-break：

<html>
<head>
<script type="text/javascript">
function setPageBreak()
{
document.getElementById("p1").style.pageBreakAfter="always";
}
</script>
</head>
<body>

<p id="p1">This is a test paragraph.</p>

<input type="button" onclick="setPageBreak()"
value="Set page-break" />

<p>This is also a test paragraph.</p>

</body>
</html>

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM pageBreakBefore 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM pageBreakBefore 属性

返回HTML DOM Style 对象参考手册

定义和用法

pageBreakBefore 属性声明一个元素前是否应当放置分页符。

语法：

Object.style.pageBreakBefore=auto|always|avoid|left|right

可能的值

值 | 描述
auto | 默认。如果必要则在元素前插入分页符。
always | 在元素前插入分页符。
avoid | 避免在元素前插入分页符。
left | 在元素之前足够的分页符，一直到一张空白的左页为止。
right | 在元素之前足够的分页符，一直到一张空白的右页为止。

实例

本例在 id 为 p2 的段落之前设置一个 page-break：

<html>
<head>

<script type="text/javascript">
function setPageBreak()
{
document.getElementById("p2").style.pageBreakBefore="always";
}
</script>
</head>
<body>

<p>This is a test paragraph.</p>

<input type="button" onclick="setPageBreak()"
value="Set page-break" />

<p id="p2">This is also a test paragraph.</p>

</body>
</html>

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM pageBreakInside 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM pageBreakInside 属性

返回HTML DOM Style 对象参考手册

定义和用法

pageBreakInside 声明一个元素内部是否应当放置分页符。

语法：

Object.style.pageBreakInside=auto|avoid

可能的值

值 | 描述
auto | 默认。如果必要则在元素内部插入分页符。
avoid | 避免在元素内部插入分页符。

实例

本例避免在 id 为 p2 的段落中的 page-break：

<html>
<head>
<script type="text/javascript">
function setPageBreak()
{
document.getElementById("p2").style.pageBreakInside="avoid";
}
</script>
</head>
<body>

<p>This is a test paragraph.</p>

<input type="button" onclick="setPageBreak()"
value="Set page to not break inside the second paragraph" />

<p id="p2">This is also a test paragraph. We need some
more text here. This is just filler text.</p>

</body>
</html>

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Password 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Password 对象

Password 对象

Password 对象代表 HTML 表单中的密码域。

HTML 的 <input type="password"> 标签在表单上每出现一次，一个 Password 对象就会被创建。

该文本输入字段供用户输入某些敏感的数据，比如密码等。当用户输入的时候，他的输入是被掩盖的（例如使用星号*），以防止旁边的人从他背后看到输入的内容。不过需要注意的是，当表单提交时，输入是用明文发送的。

与类型为 "text" 的元素类似，当用户改变显示值时，它会触发 onchange 事件句柄。

您可以通过遍历表单的 elements[] array 来访问密码域，或者通过使用 document.getElementById() 。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet 标准).

Password 对象的属性

属性 | 描述 | IE | F | O | W3C
accessKey | 设置或返回访问密码域的快捷键。 | 4 | 1 | 9 | Yes
alt | 设置或返回当浏览器不支持密码域时供显示的替代文字。 | 5 | 1 | 9 | Yes
defaultValue | 设置或返回密码域的默认值。 | 4 | 1 | 9 | Yes
disabled | 设置或返回是否应被禁用密码域。 | 5 | 1 | 9 | Yes
form | 返回一个对包含此密码域的表单的引用。 | 4 | 1 | 9 | Yes
id | 设置或返回密码域的 id。 | 4 | 1 | 9 | Yes
maxLength | 设置或返回密码域中字符的最大数目。 | 4 | 1 | 9 | Yes
name | 设置或返回密码域的名称。 | 4 | 1 | 9 | Yes
readOnly | 设置或返回密码域是否应当是只读的。 | 4 | 1 | 9 | Yes
size | 设置或返回密码域的长度。 | 4 | 1 | 9 | Yes
tabIndex | 设置或返回密码域的 tab 键控制次序。 | 4 | 1 | 9 | Yes
type | 返回密码域的表单元素类型。 | 4 | 1 | 9 | Yes
value | 设置或返回密码域的 value 属性的值。 | 4 | 1 | 9 | Yes

Standard Properties

属性 | 描述 | IE | F | O | W3C
className | Sets or returns the class attribute of an element | 5 | 1 | 9 | Yes
dir | Sets or returns the direction of text | 5 | 1 | 9 | Yes
lang | Sets or returns the language code for an element | 5 | 1 | 9 | Yes
title | Sets or returns an element's advisory title | 5 | 1 | 9 | Yes

Password 对象的方法

方法 | 描述 | IE | F | O | W3C
blur() | 从密码域移开焦点。 | 4 | 1 | 9 | Yes
focus() | 为密码域赋予焦点。 | 4 | 1 | 9 | Yes
select() | 选取密码域中的文本。 | 4 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM pathname 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM pathname 属性

返回 HTML DOM Location 对象参考手册

定义和用法

pathname 属性是一个可读可写的字符串，可设置或返回当前 URL 的路径部分。

语法

location.pathname=path

实例

假设当前的 URL 是: http://example.com:1234/test/test.htm#part2：

<html>
<body>

<script type="text/javascript">
document.write(location.pathname);
</script>

</body>
</html>

输出：

/test/test.htm

TIY

使用 location 对象的 href 属性

返回 HTML DOM Location 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM pathname 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM pathname 属性

返回 HTML DOM Area 对象参考手册

定义和用法

pathname 属性可设置或返回某个区域中 link-URL 的路径名。

语法

areaObject.pathname=pathnamee

实例

下面的例子可返回 "Venus" 区域中 link-URL 的路径名：

<html>
<body>

<img src="planets.gif"
width="145" height="126"
usemap="#planetmap" />

<map name="planetmap">
<area id="venus" shape="circle"
coords="124,58,8"
alt="Venus"
href="venus.htm" />
</map>

<p>Venus' pathname:
<script type="text/javascript">
x=document.getElementById('venus');
document.write(x.pathname);
</script>
</p>

</body>
</html>

TIY

取得图像映射中某个区域的 link-URL 的路径名

返回 HTML DOM Area 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM pixelDepth 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM pixelDepth 属性

返回 HTML DOM Screen 对象参考手册

定义和用法

pixelDepth 属性返回显示屏幕的颜色分辨率（比特每像素）。

语法

screen.pixelDepth

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>Pixel Depth: ")
document.write(screen.pixelDepth + "</p>")
</script>
</body>

</html>

TIY

检测有关客户机的屏幕的细节

返回 HTML DOM Screen 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM platform 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM platform 属性

返回 HTML DOM Navigator 对象参考手册

定义和用法

platform 属性是一个只读的字符串，声明了运行浏览器的操作系统和（或）硬件平台。

虽然该属性没有标准的值集合，但它有些常用值，比如 "Win32"、"MacPPC" 以及 "Linuxi586"，等等。

语法

navigator.platform

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>Platform: ")
document.write(navigator.platform + "</p>")
</script>
</body>

</html>

TIY

检测访问者的浏览器和版本号
有关访问者的浏览器的更多信息
有关访问者的浏览器的全部细节
根据浏览器来提醒用户

返回 HTML DOM Navigator 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM port 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM port 属性

返回 HTML DOM Location 对象参考手册

定义和用法

port 属性是一个可读可写的字符串，可设置或返回当前 URL 的端口部分。

语法

location.port=portnumber

实例

假设当前的 URL 是: http://example.com:1234/test.htm#part2：

<html>
<body>

<script type="text/javascript">
document.write(location.port);
</script>

</body>
</html>

输出：

1234

TIY

使用 location 对象的 port 属性

返回 HTML DOM Location 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM position 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM position 属性

返回HTML DOM Style 对象参考手册

定义和用法

position 属性把元素放置到一个静态的、相对的、绝对的、或固定的位置中。

语法：

Object.style.position=static|relative|absolute|fixed

可能的值

值 | 描述
static | 默认。位置设置为 static 的元素，它始终会处于页面流给予的位置（static 元素会忽略任何 top、bottom、left 或 right 声明）。
relative | 位置被设置为 relative 的元素，可将其移至相对于其正常位置的地方，因此 "left:20" 会将元素移至元素正常位置左边 20 个像素的位置。
absolute | 位置设置为 absolute 的元素，可定位于相对于包含它的元素的指定坐标。此元素的位置可通过 "left"、"top"、"right" 以及 "bottom" 属性来规定。
fixed | 位置被设置为 fixed 的元素，可定位于相对于浏览器窗口的指定坐标。此元素的位置可通过 "left"、"top"、"right" 以及"bottom" 属性来规定。不论窗口滚动与否，元素都会留在那个位置。工作于 IE7（strict 模式）。

实例

本例把元素位置由相对改为绝对：

<html>
<head>
<style type="text/css">
input
{
position:relative;
}
</style>
<script type="text/javascript">
function setPositionAbsolute()
{
document.getElementById("b1").style.position="absolute";
document.getElementById("b1").style.top="10px";
}
</script>
</head>
<body>

<p>This is an example paragraph</p>
<p>This is an example paragraph</p>

<input type="button" id="b1" onclick="setPositionAbsolute()"
value="Set button position to be absolute" />

</body>
</html>

TIY

position - 改变元素的位置

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM print() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM print() 方法

返回 HTML DOM Window 对象参考手册

定义和用法

print() 方法用于打印当前窗口的内容。

调用 print() 方法所引发的行为就像用户单击浏览器的打印按钮。通常，这会产生一个对话框，让用户可以取消或定制打印请求。

语法

window.print()

实例 1

<html>
<head>
<script type="text/javascript">
function printpage()
  {
  window.print()
  }
</script>
</head>
<body>

<input type="button" value="Print this page"
onclick="printpage()" />

</body>
</html>

TIY

打印页面

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM prompt() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM prompt() 方法

返回 HTML DOM Window 对象参考手册

定义和用法

prompt() 方法用于显示可提示用户进行输入的对话框。

语法

prompt(text,defaultText)
参数 | 描述
text | 可选。要在对话框中显示的纯文本（而不是 HTML 格式的文本）。
defaultText | 可选。默认的输入文本。

说明

如果用户单击提示框的取消按钮，则返回 null。如果用户单击确认按钮，则返回输入字段当前显示的文本。

在用户点击确定按钮或取消按钮把对话框关闭之前，它将阻止用户对浏览器的所有输入。在调用 prompt() 时，将暂停对 JavaScript 代码的执行，在用户作出响应之前，不会执行下一条语句。

实例 1

<html>
<head>
<script type="text/javascript">
function disp_prompt()
  {
  var name=prompt("Please enter your name","")
  if (name!=null && name!="")
    {
    document.write("Hello " + name + "!")
    }
  }
</script>
</head>
<body>

<input type="button" onclick="disp_prompt()"
value="Display a prompt box" />

</body>
</html>

TIY

显示提示框

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM protocol 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM protocol 属性

返回 HTML DOM Location 对象参考手册

定义和用法

protocol 属性是一个可读可写的字符串，可设置或返回当前 URL 的协议。

语法

location.protocol=path

实例

假设当前的 URL 是: http://example.com:1234/test.htm#part2：

<html>
<body>

<script type="text/javascript">
document.write(location.protocol);
</script>

</body>
</html>

输出：

http:

TIY

使用 location 对象的 protocol 属性

返回 HTML DOM Location 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM protocol 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM protocol 属性

返回 HTML DOM Area 对象参考手册

定义和用法

protocol 属性可设置或返回某个区域中 link-URL 的协议。

语法

areaObject.protocol=protocol

实例

下面的例子可返回 "Venus" 区域中 link-URL 的协议：

<html>
<body>

<img src="planets.gif"
width="145" height="126"
usemap="#planetmap" />

<map name="planetmap">
<area id="venus" shape="circle"
coords="124,58,8"
alt="Venus"
href="venus.htm" />
</map>

<p>Venus' protocol:
<script type="text/javascript">
x=document.getElementById('venus');
document.write(x.protocol);
</script>
</p>

</body>
</html>

TIY

取得图像地图中某个区域的 link-URL 所用的协议

返回 HTML DOM Area 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM quotes 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM quotes 属性

返回HTML DOM Style 对象参考手册

定义和用法

quotes 属性设置嵌入引用的引号类型。

语法：

Object.style.quotes=none|string string string string

可能的值

值 | 描述
none | 规定 "content" 属性的 "open-quote" 和 "close-quote" 的值不会产生任何引号。
string string string string | 定义要使用的引号。前两个值规定第一级引用嵌套，后两个值规定下一级引号嵌套。

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Radio 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Radio 对象

Radio 对象

Radio 对象代表 HTML 表单中的单选按钮。

在 HTML 表单中 <input type="radio"> 每出现一次，一个 Radio 对象就会被创建。

单选按钮是表示一组互斥选项按钮中的一个。当一个按钮被选中，之前选中的按钮就变为非选中的。

当单选按钮被选中或不选中时，该按钮就会触发 onclick 事件句柄。

您可通过遍历表单的 elements[] 数组来访问 Radio 对象，或者通过使用 document.getElementById()。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet 标准).

Radio 对象的属性

属性 | 描述 | IE | F | O | W3C
accessKey | 设置或返回访问单选按钮的快捷键。 | 4 | 1 | 9 | Yes
alt | 设置或返回在浏览器不支持单选按钮时供显示的替代文本。 | 5 | 1 | 9 | Yes
checked | 设置或返回单选按钮的状态。 | 4 | 1 | 9 | Yes
defaultChecked | 返回单选按钮的默认状态。 | 4 | 1 | 9 | Yes
disabled | 设置或返回是否禁用单选按钮。 | 5 | 1 | 9 | Yes
form | 返回一个对包含此单选按钮的表单的引用。 | 4 | 1 | 9 | Yes
id | 设置或返回单选按钮的 id。 | 4 | 1 | 9 | Yes
name | 设置或返回单选按钮的名称。 | 4 | 1 | 9 | Yes
tabIndex | 设置或返回单选按钮的 tab 键控制次序。 | 4 | 1 | 9 | Yes
type | 返回单选按钮的表单类型。 | 4 | 1 | 9 | Yes
value | 设置或返回单选按钮的 value 属性的值。 | 4 | 1 | 9 | Yes

Standard Properties

属性 | 描述 | IE | F | O | W3C
className | Sets or returns the class attribute of an element | 5 | 1 | 9 | Yes
dir | Sets or returns the direction of text | 5 | 1 | 9 | Yes
lang | Sets or returns the language code for an element | 5 | 1 | 9 | Yes
title | Sets or returns an element's advisory title | 5 | 1 | 9 | Yes

Radio 对象的方法

方法 | 描述 | IE | F | O | W3C
blur() | 从单选按钮移开焦点。 | No | 1 | 9 | Yes
click() | 在单选按钮上模拟一次鼠标点击。 | No | 2 | 9 | Yes
focus() | 为单选按钮赋予焦点。 | No | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM readOnly 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM readOnly 属性

返回 HTML DOM Password 对象参考手册

定义和用法

readOnly 属性可设置或返回密码域是否为只读。

语法

passwordObject.readOnly=true|false

实例

下面的例子把密码域设置为只读：

<html>
<head>
<script type="text/javascript">
function makeReadOnly()
  {
  document.getElementById("password1").readOnly=true
  }
</script>
</head>
<body>

<form>
<input type="password" id="password1" value="thgrt456" />
<input type="button" onclick="makeReadOnly()"
value="Make read-only" />
</form>

</body>
</html>

TIY

把密码域设置为只读

返回 HTML DOM Password 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM readOnly 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM readOnly 属性

返回 HTML DOM Text 对象参考手册

定义和用法

readOnly 属性设置或返回文本域是否为只读。

语法

textObject.readOnly=true|false

实例

下面的例子将文本域设置为只读：

<html>
<head>
<script type="text/javascript">
function makeReadOnly()
  {
  document.getElementById("text1").readOnly=true
  }
</script>
</head>
<body>

<form>
<input type="text" id="text1" value="Hello World!" />
<input type="button" onclick="makeReadOnly()" value="Make read-only" />
</form>

</body>
</html>

TIY

将文本域设置为只读

返回 HTML DOM Text 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM readOnly 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM readOnly 属性

返回 HTML DOM Textarea 对象参考手册

定义和用法

readOnly 属性设置或返回 textarea 是否为只读。

语法

textareaObject.readOnly=true|false

实例

本例把 textarea 设置为只读：

<html>
<head>
<script type="text/javascript">
function setReadOnly()
  {
  document.getElementById('txt1').readOnly=true;
  }
</script>
</head>
<body>

<textarea id="txt1">
Hello world....This is a text area
</textarea>
<br />
<input type="button" onclick="setReadOnly()"
value="Make read-only" />

</body>
</html>

返回 HTML DOM Textarea 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM referrer 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM referrer 属性

返回 HTML DOM Document 对象参考手册

定义和用法

referrer 属性可返回载入当前文档的文档的 URL。

语法

document.referrer

说明

如果当前文档不是通过超级链接访问的，则为 null。这个属性允许客户端 JavaScript 访问 HTTP 引用头部。

实例

<html>
<body>

The referrer of this document is:
<script type="text/javascript">
document.write(document.referrer)
</script>

</body>
</html>

TIY

返回当前文档的 referrer

返回 HTML DOM Document 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM rel 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM rel 属性

返回 HTML DOM Anchor 对象参考手册

定义和用法

rel 属性可设置或返回到目标文档的关系。

rel 和 rev 属性可以同时在 <a> 标签中使用。

rel (relationship) 属性规定了从源文档到目标文档的关系。rev (reverse) 属性规定了从目标文档到当前文档的反向关系。

浏览器可以使用它们改变锚内容的外观，或者自动构建文档浏览菜单。其他工具也可以使用这些属性构建特殊的链接集合、目录和索引等。

语法

anchorObject.rel=relationship

两个属性均可采用下面的值：

值 | 描述
appendix | 链接到文档的附录页。
alternate | 链接到一个备选的源。
bookmark | 链接到一个书签。在 web blogs 中常用于 "permalink"。
chapter | 从当前文档链接到一个章节。
contents | 链接到当前文档的内容目录。
copyright | 链接到当前文档的版权或隐私页面。
glossary | 链接到当前文档术语表。
index | 链接到当前文档的索引。
next | 链接到集合中的下一个文档。
prev | 链接到集合中的前一个文档。
section | 链接到文档列表中的一个小节。
start | 链接到当前文档的第一页。
subsection | 链接到当前文档列表中的子小节。（一个小节可拥有多个子小节。）
head | 链接到集合中的顶级文档。
toc | 链接到集合的目录。
parent | 链接到源上面的文档。
child | 链接到源下面的文档。

实例

下面的例子可返回链接的关系：

<html>
<body>

<p><a id="myAnchor" rel="index"
href="http://www.w3school.com.cn">Visit W3School.com.cn</a></p>

<script type="text/javascript">
x=document.getElementById("myAnchor");
document.write(x.rel);
</script>

</body>
</html>

TIY

取得链接的关系

返回 HTML DOM Anchor 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM rel 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM rel 属性

返回 HTML DOM Link 对象参考手册

定义和用法

The rel property sets or returns the relationship between the current document and the target URL.

The rel and rev properties work together. Those two properties are used by search engines to provide a linked navigation menu.

语法

linkObject.rel=relationship

The rel property can have one of the following values:

Value | Description
appendix | Link to the appendix page of the document
alternate | Link to an alternative source of the document
bookmark | Link to a bookmark
chapter | Link to a chapter
contents | Link to the table of contents of the document
copyright | Link to copyright or the policy of the document
glossary | Link to the glossary page of the document
index | Link to the index page of the document
next | Link to the next page
prev | Link to the previous page
section | Link to a section in a list of documents
start | Link to the first page (used by search engines to show the first page)
stylesheet | Link to the style sheet of the document.
subsection | Link to a sub-section in a list of current documents

实例

The following example returns the relationship between the current document and the target URL:

<html>
<head>
<link rel="stylesheet" type="text/css"
id="style1" href="try_dom_link.css" />
</head>
<body>

<script type="text/javascript">
x=document.getElementById("style1");
document.write("Relationship: " + x.rel);
</script>

</body>
</html>

TIY

Return the relationship of a <link> element

返回 HTML DOM Link 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM reload() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM reload() 方法

返回 HTML DOM Location 对象参考手册

定义和用法

reload() 方法用于重新加载当前文档。

语法

location.reload(force)

说明

如果该方法没有规定参数，或者参数是 false，它就会用 HTTP 头 If-Modified-Since 来检测服务器上的文档是否已改变。如果文档已改变，reload() 会再次下载该文档。如果文档未改变，则该方法将从缓存中装载文档。这与用户单击浏览器的刷新按钮的效果是完全一样的。

如果把该方法的参数设置为 true，那么无论文档的最后修改日期是什么，它都会绕过缓存，从服务器上重新下载该文档。这与用户在单击浏览器的刷新按钮时按住 Shift 健的效果是完全一样。

实例

<html>
<head>
<script type="text/javascript">
function reloadPage()
  {
  window.location.reload()
  }
</script>
</head>

<body>
<input type="button" value="Reload page"
onclick="reloadPage()" />
</body>

</html>

TIY

使用 location 的 reload() 方法

返回 HTML DOM Location 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM remove() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM remove() 方法

返回 HTML DOM Select 对象参考手册

定义和用法

remove() 方法用于从下拉列表删除选项。

语法

selectObject.remove(index)
参数 | 描述
index | 必需。规定要删除的选项的索引号。

说明

该方法从选项数组的指定位置移除 <option> 元素。如果指定的下标比 0 小，或者大于或等于选项的数目，remove() 方法会忽略它并什么也不做。

实例

下面的例子可从列表中删除被选的选项：

<html>
<head>
<script type="text/javascript">
function removeOption()
  {
  var x=document.getElementById("mySelect")
  x.remove(x.selectedIndex)
  }
</script>
</head>
<body>

<form>
<select id="mySelect">
  <option>Apple</option>
  <option>Pear</option>
  <option>Banana</option>
  <option>Orange</option>
</select>
<input type="button" onclick="removeOption()"
value="Remove option">
</form>

</body>
</html>

TIY

从下拉列表中删除被选的选项
从下拉列表中删除最后的选项

返回 HTML DOM Select 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM replace() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM replace() 方法

返回 HTML DOM Location 对象参考手册

定义和用法

replace() 方法可用一个新文档取代当前文档。

语法

location.replace(newURL)

说明

replace() 方法不会在 History 对象中生成一个新的纪录。当使用该方法时，新的 URL 将覆盖 History 对象中的当前纪录。

实例

下面的例子将使用 replace() 方法来替换当前文档：

<html>
<head>
<script type="text/javascript">
function replaceDoc()
  {
  window.location.replace("http://www.w3school.com.cn")
  }
</script>
</head>
<body>

<input type="button" value="Replace document" onclick="replaceDoc()" />

</body>
</html>

TIY

使用 location 对象的 replace() 方法

返回 HTML DOM Location 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Reset 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Reset 对象

Reset 对象

Reset 对象代表 HTML 表单中的一个重置按钮。

在 HTML 表单中 <input type="reset"> 标签每出现一次，一个 Reset 对象就会被创建。

当重置按钮被点击，包含它的表单中所有输入元素的值都重置为它们的默认值。默认值由 HTML value 属性或 JavaScript 的 defaultValue 属性指定。

重置按钮在重置表单之前触发 onclick 句柄，并且这个句柄可以通过返回 fasle 来取消。

参阅 Form.reset() 方法 和 Form.onreset 事件句柄。

您可以通过遍历表单的 elements[] 数组来访问某个重置按钮，或者通过使用document.getElementById()。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet 标准).

Reset 对象的属性

属性 | 描述 | IE | F | O | W3C
accesskey | 设置或返回访问重置按钮的快捷键。 | 4 | 1 | 9 | Yes
alt | 设置或返回当浏览器不支持重置按钮时供显示的替代文本。 | 5 | 1 | 9 | Yes
disabled | 设置或返回重置按钮是否应被禁用。 | 5 | 1 | 9 | Yes
form | 返回一个对包含此重置按钮的表单对象的引用。 | 4 | 1 | 9 | Yes
id | 设置或返回重置按钮的 id。 | 4 | 1 | 9 | Yes
name | 设置或返回重置按钮的名称。 | 4 | 1 | 9 | Yes
tabIndex | 设置或返回重置按钮的 tab 键控制次序。 | 4 | 1 | 9 | Yes
type | 返回重置按钮的表单元素类型。 | 4 | 1 | 9 | Yes
value | 设置或返回重置按钮上显示的文本。 | 4 | 1 | 9 | Yes

Standard Properties

Property | Description | IE | F | O | W3C
className | Sets or returns the class attribute of an element | 5 | 1 | 9 | Yes
dir | Sets or returns the direction of text | 5 | 1 | 9 | Yes
lang | Sets or returns the language code for an element | 5 | 1 | 9 | Yes
title | Sets or returns an element's advisory title | 5 | 1 | 9 | Yes

Reset 对象的方法

方法 | 描述 | IE | F | O | W3C
blur() | 从重置按钮上移开焦点。 | 4 | 1 | 9 | Yes
click() | 在重置按钮上模拟一次鼠标点击。 | 4 | 1 | 9 | Yes
focus() | 为重置按钮赋予焦点。 | 4 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM reset() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM reset() 方法

返回 HTML DOM Form 对象参考手册

定义和用法

reset() 方法可把表单中的元素重置为它们的默认值。

语法

formObject.reset()

说明

调用该方法的结果类似用户单击了 Reset 按钮的结果，只是表单的事件句柄 onreset 不会被调用。

实例

<html>
<head>
<script type="text/javascript">
function formReset()
  {
  document.getElementById("myForm").reset()
  }
</script>
</head>

<form id="myForm">
Name: <input type="text" size="20"><br />
Age: <input type="text" size="20"><br />
<br />
<input type="button" onclick="formReset()" value="Reset">
</form>
</body>

</html>

TIY

重置表单

返回 HTML DOM Form 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM resizeBy() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM resizeBy() 方法

返回 HTML DOM Window 对象参考手册

定义和用法

resizeBy() 方法用于根据指定的像素来调整窗口的大小。

语法

resizeBy(width,height)
参数 | 描述
width | 必需。要使窗口宽度增加的像素数。可以是正、负数值。
height | 可选。要使窗口高度增加的像素数。可以是正、负数值。

实例 1

<html>
<head>
<script type="text/javascript">
function resizeWindow()
  {
  window.resizeBy(-100,-100)
  }
</script>
</head>
<body>

<input type="button" onclick="resizeWindow()"
value="Resize window">

</body>
</html>

TIY

调整窗口的大小

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM resizeTo() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM resizeTo() 方法

返回 HTML DOM Window 对象参考手册

定义和用法

resizeTo() 方法用于把窗口大小调整为指定的宽度和高度。

语法

resizeTo(width,height)
参数 | 描述
width | 必需。想要调整到的窗口的宽度。以像素计。
height | 可选。想要调整到的窗口的高度。以像素计。

实例

<html>
<head>
<script type="text/javascript">
function resizeWindow()
  {
  window.resizeTo(500,300)
  }
</script>
</head>
<body>

<input type="button" onclick="resizeWindow()"
value="Resize window">

</body>
</html>

TIY

把窗口调整为指定的大小

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM rev 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM rev 属性

返回 HTML DOM Anchor 对象参考手册

定义和用法

rev 属性可设置或返回一个链接的反向关系。

rel 和 rev 属性可以同时在 <a> 标签中使用。

rel (relationship) 属性规定了从源文档到目标文档的关系。rev (reverse) 属性规定了从目标文档到当前文档的反向关系。

浏览器可以使用它们改变锚内容的外观，或者自动构建文档浏览菜单。其他工具也可以使用这些属性构建特殊的链接集合、目录和索引等。

语法

anchorObject.rev=relationship

两个属性均可采用下面的值：

值 | 描述
appendix | 链接到文档的附录页。
alternate | 链接到一个备选的源。
bookmark | 链接到一个书签。在 web blogs 中常用于 "permalink"。
chapter | 从当前文档链接到一个章节。
contents | 链接到当前文档的内容目录。
copyright | 链接到当前文档的版权或隐私页面。
glossary | 链接到当前文档术语表。
index | 链接到当前文档的索引。
next | 链接到集合中的下一个文档。
prev | 链接到集合中的前一个文档。
section | 链接到文档列表中的一个小节。
start | 链接到当前文档的第一页。
subsection | 链接到当前文档列表中的子小节。（一个小节可拥有多个子小节。）
head | 链接到集合中的顶级文档。
toc | 链接到集合的目录。
parent | 链接到源上面的文档。
child | 链接到源下面的文档。

实例

下面的例子可返回链接的反向关系：

<html>
<body>

<p><a id="myAnchor" rev="subsection"
href="/htmldom/prop_anchor_rev.asp">
HTML DOM rev Property</a></p>

<script type="text/javascript">
x=document.getElementById("myAnchor");
document.write(x.rev);
</script>

</body>
</html>

TIY

取得链接的反向关系

返回 HTML DOM Anchor 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM rev 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM rev 属性

返回 HTML DOM Link 对象参考手册

定义和用法

The rev property sets or returns the relationship between the target URL and the current document.

The rel and rev properties work together. Those two properties are used by search engines to provide a linked navigation menu.

语法

linkObject.rev=relationship

The rel property can have one of the following values:

Value | Description
appendix | Link to the appendix page of the document
alternate | Link to an alternative source of the document
bookmark | Link to a bookmark
chapter | Link to a chapter
contents | Link to the table of contents of the document
copyright | Link to copyright or the policy of the document
glossary | Link to the glossary page of the document
index | Link to the index page of the document
next | Link to the next page
prev | Link to the previous page
section | Link to a section in a list of documents
start | Link to the first page (used by search engines to show the first page)
stylesheet | Link to the style sheet of the document.
subsection | Link to a sub-section in a list of current documents

实例

The following example returns the relationship between the target URL and the current document:

<html>
<head>
<link rev="subsection" id="link1"
href="/htmldom/prop_link_rev.asp" />
</head>
<body>

<script type="text/javascript">
x=document.getElementById("link1");
document.write("Reverse relationship: " + x.rev);
document.write("<br />This page is a subsection of: ");
document.write(x.href);
</script>

</body>
</html>

TIY

Return the reverse relationship of a <link> element

返回 HTML DOM Link 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM right 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM right 属性

返回HTML DOM Style 对象参考手册

定义和用法

right 属性设置定位元素右外边距边界与其包含块右边界之间的偏移。

语法：

Object.style.right=auto|%|length

可能的值

值 | 描述
auto | 默认。通过浏览器来计算右侧的位置。
% | 设置元素的右边到最近一个具有定位设置父元素的右边缘的百分比位置。
length | 使用 px、cm 等单位设置元素的右边到最近一个具有定位设置父元素的右边缘的位置。可使用负值。

提示和注释

注释：如果 "position" 属性的值为 "static"，那么设置 "right" 属性不会产生任何效果。

实例

本例对按钮的左边进行设置：

<html>
<head>
<style type="text/css">
input
{
position:absolute;
}
</style>
<script type="text/javascript">
function setRightEdge()
{
document.getElementById("b1").style.right="100px";
}
</script>
</head>
<body>

<input type="button" id="b1" onclick="setRightEdge()"
value="Set right edge to 100 px" />

</body>
</html>

TIY

right - 设置元素的右边界

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM rowIndex 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM rowIndex 属性

返回 HTML DOM Tablerow 对象参考手册

定义和用法

rowIndex 属性返回某一行在表格的行集合中的位置（row index）。

语法

tablerowObject.rowIndex

实例

下面的例子返回了某一行在表格中的位置：

<html>
<head>
<script type="text/javascript">
function alertRowIndex()
  {
  alert(document.getElementById("tr1").rowIndex);
  }
</script>
</head>
<body>

<table border="1">
<tr id="tr1">
<th>Firstname</th>
<th>Lastname</th>
</tr>
<tr id="tr2">
<td>Peter</td>
<td>Griffin</td>
</tr>
</table>
<br />
<input type="button" onclick="alertRowIndex()"
value="Alert row index" />

</body>
</html>

TIY

返回某一行在表格的行集合中的位置

返回 HTML DOM Tablerow 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM rows 集合

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM rows 集合

返回 HTML DOM Table 对象参考手册

定义和用法

rows 集合返回表格中所有行（TableRow 对象）的一个数组，即一个 HTMLCollection。

该集合包括 <thead>、<tfoot> 和 <tbody> 中定义的所有行。

语法

tableObject.rows[]

实例

下面的例子使用了 rows 集合来显示第一行中的内容：

<html>
<head>
<script type="text/javascript">
function showRow()
  {
  alert(document.getElementById('myTable').rows[0].innerHTML)
  }
</script>
</head>
<body>

<table id="myTable" border="1">
<tr>
<td>Row1 cell1</td>
<td>Row1 cell2</td>
</tr>
<tr>
<td>Row2 cell1</td>
<td>Row2 cell2</td>
</tr>
</table>
<br />
<input type="button" onclick="showRow()" value="Show innerHTML">

</body>
</html>

TIY

某一个行的 InnerHTML
通过 rows 集合向表格行添加一个单元格
排列表格行中的单元格内容
垂直排列表格行中的单元格内容
排列一个单独的单元格中的内容
垂直排列一个单独的单元格中的内容
更改表格单元格中的内容
更改一个表格行的 colspan

返回 HTML DOM Table 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM rows 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM rows 属性

返回 HTML DOM Frameset 对象参考手册

定义和用法

rows 属性可设置或返回框架中行的数目和尺寸。

由逗号分割的像素或百分比列表定义了列的数目和高度：

语法

framesetObject.rows=row1,row2,row3....

实例

在我们的例子中，首先将创建包含带有两个列的框架集的 HTML 文档。每列设置为浏览器窗口的 50%：

<html>
<frameset rows="50%,50%">
  <frame src="frame_rows.htm">
  <frame src="frame_a.htm">
</frameset>
</html>

HTML 文档 "frame_rows.htm" 被放入第一列，而 HTML 文档 "frame_a.htm" 被放入第二列。

下面是 "frame_rows.htm" 的源代码：

<html>
<head>
<script type="text/javascript">
function changeRows()
  {
  parent.document.getElementById("main").rows="30%,70%"
  }

function restoreRows()
  {
  parent.document.getElementById("main").rows="50%,50%"
  }
</script>
</head>
<body>

<form>
<input type="button" onclick="changeRows()"
value="Change row size" />
<input type="button" onclick="restoreRows()"
value="Restore row size" />
</form>

</body>
</html>

TIY

更改框架集的行尺寸

返回 HTML DOM Frameset 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM rows 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM rows 属性

返回 HTML DOM Textarea 对象参考手册

定义和用法

rows 属性设置或返回 textarea 的高度。

语法

textareaObject.rows=number_of rows

实例

本例改变 textarea 的高度：

<html>
<head>
<script type="text/javascript">
function changeRows()
  {
  document.getElementById('txt1').rows="15";
  }
</script>
</head>
<body>

<textarea id="txt1">
Hello world....This is a text area
</textarea>
<br />
<input type="button" onclick="changeRows()" value="Change height" />

</body>
</html>

返回 HTML DOM Textarea 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM rows 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM rows 属性

返回 HTML DOM Textarea 对象参考手册

定义和用法

tabIndex 属性设置或返回 textarea 的 tab 键控制次序。

语法

textareaObject.tabIndex=number

实例

本例输出不同表单域的 tab 键控制次序：

<html>
<head>
<script type="text/javascript">
function checkTab(x)
  {
  alert(x.tabIndex)
  }
</script>
</head>
<body>

<form>
<textarea id="txt1" tabindex="1" onclick="checkTab(this)">
Hello world....This is a text area
</textarea>
<input id="txt2" type="text" tabindex="2" onclick="checkTab(this)">
<input id="txt3" type="text" tabindex="3" onclick="checkTab(this)">
</form>

</body>
</html>

返回 HTML DOM Textarea 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM rowSpan 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM rowSpan 属性

返回 HTML DOM TableCell 对象参考手册

定义和用法

rowSpan 属性可设置或返回表元横跨的行数。

语法

tabledataObject.rowSpan=number_of_rows

实例

下面的例子更改了表元横跨的行数：

<html>
<head>
<script type="text/javascript">
function changeRowSpan()
  {
  document.getElementById("td2").rowSpan="2";
  }
</script>
</head>
<body>

<table border="1">
<tr>
<th>Firstname</th>
<th>Lastname</th>
</tr>
<tr>
<td id="td1">Peter</td>
<td id="td2">Griffin</td>
</tr>
<tr>
<td id="td3">Harry</td>
<td id="td4">Potter</td>
</tr>
</table>
<br />
<input type="button" onclick=changeRowSpan()
value="Change rowspan" />

</body>
</html>

TIY

更改表元横跨的行数

返回 HTML DOM TableCell 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM rules 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM rules 属性

返回 HTML DOM Table 对象参考手册

定义和用法

rules 属性可设置或返回表格的内部边线。

语法

tableObject.rules=none|groups|rows|cols|all

实例

下面的例子设置了表格的两种不同的内部边线：

<html>
<head>
<script type="text/javascript">
function rowRules()
  {
  document.getElementById('myTable').rules="rows"
  }
function colRules()
  {
  document.getElementById('myTable').rules="cols"
  }
</script>
</head>
<body>

<table id="myTable" border="1">
<tr>
<td>Row1 cell1</td>
<td>Row1 cell2</td>
</tr>
<tr>
<td>Row2 cell1</td>
<td>Row2 cell2</td>
</tr>
<tr>
<td>Row3 cell1</td>
<td>Row3 cell2</td>
</tr>
</table>
<br />
<input type="button" onclick="rowRules()"
value="Show only row borders">
<input type="button" onclick="colRules()"
value="Show only col borders">

</body>
</html>

TIY

规定表格的内部边线

返回 HTML DOM Table 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM scheme 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM scheme 属性

返回 HTML DOM Meta 对象参考手册

定义和用法

scheme 属性设置或返回用于解释 content 属性的值的格式。

语法

metaObject.scheme=format

实例

本例返回用于解释 content 属性的值的格式：

<html>
<head>
<meta name="revised" content="2006-11-03" scheme="YYYY-MM-DD" />
</head>

<body>

<script type="text/javascript">
x=document.getElementsByTagName("meta")[0];
document.write("Content format: " + x.scheme);
</script>

</body>

</html>

TIY

返回 <meta> 元素中 content 的格式

返回 HTML DOM Meta 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Screen 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Screen 对象

Screen 对象

Screen 对象实际上是 JavaScript 对象，而不是 HTML DOM 对象。

Screen 对象是由 JavaScript runtime engine 自动创建的，包含有关客户机显示屏幕的信息。

每个 Window 对象的 screen 属性都引用一个 Screen 对象。Screen 对象中存放着有关显示浏览器屏幕的信息。JavaScript 程序将利用这些信息来优化它们的输出，以达到用户的显示要求。例如，一个程序可以根据显示器的尺寸选择使用大图像还是使用小图像，它还可以根据显示器的颜色深度选择使用 16 位色还是使用 8 位色的图形。另外，JavaScript 程序还能根据有关屏幕尺寸的信息将新的浏览器窗口定位在屏幕中间。

IE: Internet Explorer, F: Firefox, O: Opera.

Screen 对象的属性

属性 | 描述 | IE | F | O
availHeight | 返回显示屏幕的高度 (除 Windows 任务栏之外)。 | 4 | 1 | 9
availWidth | 返回显示屏幕的宽度 (除 Windows 任务栏之外)。 | 4 | 1 | 9
bufferDepth | 设置或返回在 off-screen bitmap buffer 中调色板的比特深度。 | 4 | No | No
colorDepth | 返回目标设备或缓冲器上的调色板的比特深度。 | 4 | 1 | 9
deviceXDPI | 返回显示屏幕的每英寸水平点数。 | 6 | No | No
deviceYDPI | 返回显示屏幕的每英寸垂直点数。 | 6 | No | No
fontSmoothingEnabled | 返回用户是否在显示控制面板中启用了字体平滑。 | 4 | No | No
height | 返回显示屏幕的高度。 | 4 | 1 | 9
logicalXDPI | 返回显示屏幕每英寸的水平方向的常规点数。 | 6 | No | No
logicalYDPI | 返回显示屏幕每英寸的垂直方向的常规点数。 | 6 | No | No
pixelDepth | 返回显示屏幕的颜色分辨率（比特每像素）。 | No | 1 | 9
updateInterval | 设置或返回屏幕的刷新率。 | 4 | No | No
width | 返回显示器屏幕的宽度。 | 4 | 1 | 9

HTML DOM 参考手册
HTML DOM 实例


HTML DOM scrollbar3dLightColor 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM scrollbar3dLightColor 属性

返回HTML DOM Style 对象参考手册

定义和用法

scrollbar3dLightColor 属性设置箭头和滚动条的左边和上边的颜色。

语法：

Object.style.scrollbar3dLightColor=color

可能的值

值 | 描述
color | 颜色值可以是颜色名 (red)，rgb 值 (rgb(255,0,0))，或十六进制 (#ff0000)。

实例

本例设置箭头和滚动条的左边和上边的颜色：

<html>
<head>
<script type="text/javascript">
function setScrollbar3dLightColor()
{
document.body.style.scrollbar3dLightColor="blue";
}
</script>
</head>
<body>

<input type="button" onclick="setScrollbar3dLightColor()"
value="Set Scrollbar3dLightColor" />

</body>
</html>

TIY

scrollbar3dLightColor

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM scrollbarArrowColor 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM scrollbarArrowColor 属性

返回HTML DOM Style 对象参考手册

定义和用法

scrollbarArrowColor 属性设置滚动条中箭头的颜色。

语法：

Object.style.scrollbarArrowColor=color

可能的值

值 | 描述
color | 颜色值可以是颜色名 (red)，rgb 值 (rgb(255,0,0))，或十六进制 (#ff0000)。

实例

本例设置滚动条中箭头的颜色：

<html>
<head>
<script type="text/javascript">
function setScrollbarArrowColor()
{
document.body.style.scrollbarArrowColor="green";
}
</script>
</head>
<body>

<input type="button" onclick="setScrollbarArrowColor()"
value="Set ScrollbarArrowColor" />

</body>
</html>

TIY

scrollbarArrowColor

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM scrollbarBaseColor 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM scrollbarBaseColor 属性

返回HTML DOM Style 对象参考手册

定义和用法

scrollbarBaseColor 属性为整个滚动条设置底色。

语法：

Object.style.scrollbarBaseColor=color

可能的值

值 | 描述
color | 颜色值可以是颜色名 (red)，rgb 值 (rgb(255,0,0))，或十六进制 (#ff0000)。

实例

本例改变滚动条的颜色：

<html>
<head>
<script type="text/javascript">
function setScrollbarColor()
{
document.body.style.scrollbarBaseColor="green";
}
</script>
</head>
<body>

<input type="button" onclick="setScrollbarColor()"
value="Set ScrollbarColor" />

</body>
</html>

TIY

scrollbarColor

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM scrollbarDarkShadowColor 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM scrollbarDarkShadowColor 属性

返回HTML DOM Style 对象参考手册

定义和用法

scrollbarDarkShadowColor 属性设置箭头和滚动条的右边和下边的颜色。

提示：可以与 scrollbarShadowColor 一同使用，设置滚动条的阴影效果。

语法：

Object.style.scrollbarDarkShadowColor=color

可能的值

值 | 描述
color | 颜色值可以是颜色名 (red)，rgb 值 (rgb(255,0,0))，或十六进制 (#ff0000)。

实例

本例设置箭头和滚动条的右边和下边的颜色：

<html>
<head>
<script type="text/javascript">
function setScrollbarDarkShadowColor()
{
document.body.style.scrollbarDarkShadowColor="darkred";
}
</script>
</head>
<body>

<input type="button" onclick="setScrollbarDarkShadowColor()"
value="Set ScrollbarDarkShadowColor" />

</body>
</html>

TIY

scrollbarDarkShadowColor

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM scrollbarFaceColor 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM scrollbarFaceColor 属性

返回HTML DOM Style 对象参考手册

定义和用法

scrollbarFaceColor 属性设置滚动条的前景色。

语法：

Object.style.scrollbarFaceColor=color

可能的值

值 | 描述
color | 颜色值可以是颜色名 (red)，rgb 值 (rgb(255,0,0))，或十六进制 (#ff0000)。

实例

本例改变滚动条的前景色：

<html>
<head>
<script type="text/javascript">
function setScrollbarFaceColor()
{
document.body.style.scrollbarFaceColor="green";
}
</script>
</head>
<body>

<input type="button" onclick="setScrollbarFaceColor()"
value="Set ScrollbarFaceColor" />

</body>
</html>

TIY

scrollbarFaceColor

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM scrollbarHighlightColor 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM scrollbarHighlightColor 属性

返回HTML DOM Style 对象参考手册

定义和用法

scrollbarHighlightColor 属性设置箭头和滚动条的左边和上边的颜色，以及滚动条的背景。

语法：

Object.style.scrollbarHighlightColor=color

可能的值

值 | 描述
color | 颜色值可以是颜色名 (red)，rgb 值 (rgb(255,0,0))，或十六进制 (#ff0000)。

实例

本例设置箭头和滚动条的左边和上边的颜色，以及滚动条的背景：

<html>
<head>
<script type="text/javascript">
function setScrollbarHighlightColor()
{
document.body.style.scrollbarHighlightColor="purple";
}
</script>
</head>
<body>

<input type="button" onclick="setScrollbarHighlightColor()"
value="Set ScrollbarHighlightColor" />

</body>
</html>

TIY

scrollbarHighlightColor

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM scrollbarShadowColor 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM scrollbarShadowColor 属性

返回HTML DOM Style 对象参考手册

定义和用法

scrollbarShadowColor 属性设置箭头和滚动条的右边和下边的颜色。

提示：该属性可与 scrollbarDarkShadowColor 一同使用，在滚动条上设置阴影效果。

语法：

Object.style.scrollbarShadowColor=color

可能的值

值 | 描述
color | 颜色值可以是颜色名 (red)，rgb 值 (rgb(255,0,0))，或十六进制 (#ff0000)。

实例

本例设置箭头和滚动条的右边和下边的颜色：

<html>
<head>
<script type="text/javascript">
function setScrollbarShadowColor()
{
document.body.style.scrollbarShadowColor="pink";
}
</script>
</head>
<body>

<input type="button" onclick="setScrollbarShadowColor()"
value="Set ScrollbarShadowColor" />

</body>
</html>

TIY

scrollbarShadowColor

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM scrollbarTrackColor 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM scrollbarTrackColor 属性

返回HTML DOM Style 对象参考手册

定义和用法

scrollbarTrackColor 属性设置滚动条的背景色。

语法：

Object.style.scrollbarTrackColor=color

可能的值

值 | 描述
color | 颜色值可以是颜色名 (red)，rgb 值 (rgb(255,0,0))，或十六进制 (#ff0000)。

实例

本例设置滚动条的背景色：

<html>
<head>
<script type="text/javascript">
function setScrollbarTrackColor()
{
document.body.style.scrollbarTrackColor="pink";
}
</script>
</head>
<body>

<input type="button" onclick="setScrollbarTrackColor()"
value="Set ScrollbarTrackColor" />

</body>
</html>

TIY

scrollbarTrackColor

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM scrollBy() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM scrollBy() 方法

返回 HTML DOM Window 对象参考手册

定义和用法

scrollBy() 方法可把内容滚动指定的像素数。

语法

scrollBy(xnum,ynum)
参数 | 描述
xnum | 必需。把文档向右滚动的像素数。
ynum | 必需。把文档向下滚动的像素数。

实例

下面的例子可把内容滚动 100 像素：

<html>
<head>
<script type="text/javascript">
function scrollWindow()
  {
  window.scrollBy(100,100)
  }
</script>
</head>
<body>

<input type="button" onclick="scrollWindow()" value="Scroll" />
<p>SCROLL SCROLL SCROLL SCROLL SCROLL SCROLL SCROLL SCROLL</p>
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<p>SCROLL SCROLL SCROLL SCROLL SCROLL SCROLL SCROLL SCROLL</p>
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<p>SCROLL SCROLL SCROLL SCROLL SCROLL SCROLL SCROLL SCROLL</p>

</body>
</html>

TIY

通过 scrollBy() 滚动文档

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM scrolling 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM scrolling 属性

返回 HTML DOM Frame 对象参考手册

定义和用法

scrolling 属性可设置或返回框架是否拥有滚动条。

语法

frameObject.scrolling=yes|no

实例

在我们的例子中，首先将创建包含带有两个列的框架集的 HTML 文档。每列设置为浏览器窗口的 50%：

<html>
  <frameset cols="50%,50%">
    <frame id="leftFrame" src="frame_scroll.htm">
    <frame id="rightFrame" src="frame_a.htm">
  </frameset>
</html>

HTML 文档 "frame_scroll.htm" 被放入第一列，而 HTML 文档 "frame_a.htm" 被放入第二列。

下面是 "frame_scroll.htm" 的源代码：

<html>
<head>
<script type="text/javascript">
function enableScrolling()
  {
  parent.document.getElementById("leftFrame").scrolling="yes"
  parent.document.getElementById("rightFrame").scrolling="yes"
  }
function disableScrolling()
  {
  parent.document.getElementById("leftFrame").scrolling="no"
  parent.document.getElementById("rightFrame").scrolling="no"
  }
</script>
</head>

<body>
<input type="button" onclick="enableScrolling()"
value="Scroll bars" />
<input type="button" onclick="disableScrolling()"
value="No scroll bars" />
</body>

</html>

TIY

带有滚动条和不带有滚动条的框架

返回 HTML DOM Frame 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM scrolling 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM scrolling 属性

返回 HTML DOM Iframe 对象参考手册

定义和用法

scrolling 属性可设置或返回 iframe 是否拥有滚动条（滚动策略）。

语法

iframeObject.scrolling=auto|yes|no

实例

下面的例子可添加和删除 iframe 的滚动条：

<html>
<head>
<script type="text/javascript">
function addScrollbars()
  {
  document.getElementById("frame1").scrolling="yes";
  }
  function removeScrollbars()
  {
  document.getElementById("frame1").scrolling="no";
  }
</script>
</head>

<body>
<iframe src="frame_a.htm" id="frame1" ></iframe><br />

<input type="button" onclick="addScrollbars()"
value="Add Scrollbars" />
<input type="button" onclick="removeScrollbars()"
value="Remove Scrollbars" />

</body>
</html>

TIY

添加和删除 <iframe> 元素的滚动条

返回 HTML DOM Iframe 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM scrollTo() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM scrollTo() 方法

返回 HTML DOM Window 对象参考手册

定义和用法

scrollTo() 方法可把内容滚动到指定的坐标。

语法

scrollTo(xpos,ypos)
参数 | 描述
xpos | 必需。要在窗口文档显示区左上角显示的文档的 x 坐标。
ypos | 必需。要在窗口文档显示区左上角显示的文档的 y 坐标。

实例

下面的例子可把内容滚动到位置 100,500：

<html>
<head>
<script type="text/javascript">
function scrollWindow()
  {
  window.scrollTo(100,500)
  }
</script>
</head>
<body>

<input type="button" onclick="scrollWindow()" value="Scroll" />
<p>SCROLL SCROLL SCROLL SCROLL SCROLL SCROLL SCROLL SCROLL</p>
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<p>SCROLL SCROLL SCROLL SCROLL SCROLL SCROLL SCROLL SCROLL</p>
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<p>SCROLL SCROLL SCROLL SCROLL SCROLL SCROLL SCROLL SCROLL</p>

</body>
</html>

TIY

通过 scrollTo() 把窗口滚动到指定的位置

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM search 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM search 属性

返回 HTML DOM Location 对象参考手册

定义和用法

search 属性是一个可读可写的字符串，可设置或返回当前 URL 的查询部分（问号 ? 之后的部分）。

语法

location.search=path_from_questionmark

实例

假设当前的 URL 是: http://www.w3school.com.cn/tiy/t.asp?f=hdom_loc_search

<html>
<body>

<script type="text/javascript">
document.write(location.protocol);
</script>

</body>
</html>

输出：

?f=hdom_loc_search

TIY

使用 location 的 search 属性

返回 HTML DOM Location 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM search 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM search 属性

返回 HTML DOM Area 对象参考手册

定义和用法

search 属性可设置或返回某个区域中 link-URL 的查询字符串部分。

语法

areaObject.search=querystring

实例

下面的例子可返回 "Venus" 中的 link-URL 的查询字符串部分：

<html>
<body>

<img src="planets.gif"
width="145" height="126"
usemap="#planetmap" />

<map name="planetmap">
<area id="venus" shape="circle"
coords="124,58,8"
alt="Venus"
href="venus.htm?id=venus" />
</map>

<p>Query string part of Venus' link-URL:
<script type="text/javascript">
x=document.getElementById('venus')
document.write(x.search)
</script>
</p>

</body>
</html>

TIY

返回图像映射中某个区域的链接的查询字符串部分

返回 HTML DOM Area 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Select 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Select 对象

Select 对象

Select 对象代表 HTML 表单中的一个下拉列表。

在 HTML 表单中，<select> 标签每出现一次，一个 Select 对象就会被创建。

您可通过遍历表单的 elements[] 数组来访问某个 Select 对象，或者通过使用 document.getElementById()。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet 标准).

Select 对象的集合

集合 | 描述 | IE | F | O | W3C
options[] | 返回包含下拉列表中的所有选项的一个数组。 | 4 | 1 | 9 | Yes

Select 对象的属性

属性 | 描述 | IE | F | O | W3C
disabled | 设置或返回是否应禁用下拉列表。 | 5 | 1 | 9 | Yes
form | 返回对包含下拉列表的表单的引用。 | 4 | 1 | 9 | Yes
id | 设置或返回下拉列表的 id。 | 4 | 1 | 9 | Yes
length | 返回下拉列表中的选项数目。 | 4 | 1 | 9 | Yes
multiple | 设置或返回是否选择多个项目。 | 4 | 1 | 9 | Yes
name | 设置或返回下拉列表的名称。 | 4 | 1 | 9 | Yes
selectedIndex | 设置或返回下拉列表中被选项目的索引号。 | 4 | 1 | 9 | Yes
size | 设置或返回下拉列表中的可见行数。 | 4 | 1 | 9 | Yes
tabIndex | 设置或返回下拉列表的 tab 键控制次序。 | 5 | 1 | 9 | Yes
type | 返回下拉列表的表单类型。 | 4 | 1 | 9 | Yes

Standard Properties

属性 | 描述 | IE | F | O | W3C
className | Sets or returns the class attribute of an element | 5 | 1 | 9 | Yes
dir | Sets or returns the direction of text | 5 | 1 | 9 | Yes
lang | Sets or returns the language code for an element | 5 | 1 | 9 | Yes
title | Sets or returns an element's advisory title | 5 | 1 | 9 | Yes

Select 对象的方法

方法 | 描述 | IE | F | O | W3C
add() | 向下拉列表添加一个选项。 | 4 | 1 | 9 | Yes
blur() | 从下拉列表移开焦点。 | 4 | 1 | 9 | Yes
focus() | 在下拉列表上设置焦点。 | 4 | 1 | 9 | Yes
remove() | 从下拉列表中删除一个选项。 | 4 | 1 | 9 | Yes

Select 对象的事件句柄

方法 | 描述 | IE | F | O | W3C
onchange | 当改变选择时调用的事件句柄。 | 4 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM select() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM select() 方法

返回 HTML DOM Select 对象参考手册

定义和用法

select() 方法用于选取密码域中的文本。

语法

passwordObject.select()

实例

下面的例子可选取密码域中的文本：

<html>
<head>
<script type="text/javascript">
function selText()
  {
  document.getElementById('password1').select()
  }
</script>
</head>
<body>

<form>
<input type="password" id="password1" value="thgrt456" />
<input type="button" onclick="selText()" value="Select text" />
</form>

</body>
</html>

TIY

选取密码域中的文本

返回 HTML DOM Select 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM select() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM select() 方法

返回 HTML DOM Text 对象参考手册

定义和用法

select() 方法用于选取文本域中的内容。

语法

textObject.select()

实例

下面的例子可选取文本域中的内容：

<html>
<head>
<script type="text/javascript">
function selText()
  {
  document.getElementById("myText").select()
  }
</script>
</head>
<body>

<form>
<input size="25" type="text" id="myText" value="A cat played with a ball">
<input type="button" value="Select text" onclick="selText()">
</form>

</body>
</html>

TIY

选取文本域中的内容

返回 HTML DOM Text 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM select() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM select() 方法

返回 HTML DOM Textarea 对象参考手册

定义和用法

select() 方法用于选择该元素中的文本。

语法

textareaObject.select()

实例

下面的例子可选择文本框中的文本：

<html>
<head>
<script type="text/javascript">
function selText()
  {
  document.getElementById("txt1").select()
  }
</script>
</head>
<body>

<textarea id="txt1">Hello world....</textarea>
<input type="button" value="Select text" onclick="selText()">

</body>
</html>

返回 HTML DOM Textarea 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM selected 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM selected 属性

返回 HTML DOM Option 对象参考手册

定义和用法

selected 属性可设置或返回选项的 selected 属性的值。

该属性设置选项的当前状态，如果为 true，则该选项被选中。该属性的初始值来自 <option> 的 selected 属性。

语法

optionObject.selected=true|false

实例

本例可更改下拉列表中的被选选项：

<html>
<head>
<script type="text/javascript">
function selectOrange()
{
document.getElementById("orange").selected=true;
}
</script>
</head>

<body>
<form>
Select your favorite fruit:
<select>
<option id="apple">Apple</option>
<option id="orange">Orange</option>
<option id="pineapple" selected="selected">Pineapple</option>
<option id="banana">Banana</option>
</select>
<br /><br />
<input type="button" onclick="selectOrange()" value="Select Orange">
</form>
</body>
</html>

TIY

更改被选选项

返回 HTML DOM Option 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM selectedIndex 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM selectedIndex 属性

返回 HTML DOM Select 对象参考手册

定义和用法

size 属性可设置或返回下拉列表中一次显示显示的选项数。

注释：Opera 9 无法在脚本中设置该属性，仅能返回它。

语法

selectObject.size=number

实例

<html>
<head>
<script type="text/javascript">
function changeSize()
  {
  document.getElementById("mySelect").size=4
  }
</script>
</head>
<body>

<form>
<select id="mySelect">
  <option>Apple</option>
  <option>Banana</option>
  <option>Orange</option>
  <option>Melon</option>
</select>
<input type="button" onclick="changeSize()"
value="Change size">
</form>

</body>
</html>

TIY

更改下拉列表中的可见行数

返回 HTML DOM Select 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM selectedIndex 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM selectedIndex 属性

返回 HTML DOM Select 对象参考手册

定义和用法

selectedIndex 属性可设置或返回下拉列表中被选选项的索引号。

注释：若允许多重选择，则仅会返回第一个被选选项的索引号。

语法

selectObject.selectedIndex=number

实例

下面的例子可提示出被选选项的索引号：

<html>
<head>
<script type="text/javascript">
function getIndex()
  {
  var x=document.getElementById("mySelect")
  alert(x.selectedIndex)
  }
</script>
</head>
<body>

<form>
Select your favorite fruit:
<select id="mySelect">
  <option>Apple</option>
  <option>Orange</option>
  <option>Pineapple</option>
  <option>Banana</option>
</select>
<br /><br />
<input type="button" onclick="getIndex()"
value="Alert index of selected option">
</form>

</body>
</html>

TIY

显示被选选项的索引号
设置下拉列表中被选选项的文本
从下拉列表中删除选项

返回 HTML DOM Select 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM self 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM self 属性

返回 HTML DOM Window 对象参考手册

定义和用法

self 属性可返回对窗口自身的只读引用。等价于 Window 属性。

语法

window.self

实例

下面的例子窗口是否在一个框架中，如果是，则跳出框架：

<html>
<head>
<script type="text/javascript">
function breakout()
  {
  if (window.top!=window.self)
    {
    window.top.location="tryjs_breakout.htm"
    }
  }
</script>
</head>
<body>

<input type="button" onclick="breakout()"
value="Break out of frame!">

</body>
</html>

TIY

跳出框架

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM setInterval() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM setInterval() 方法

返回 HTML DOM Window 对象参考手册

定义和用法

setInterval() 方法可按照指定的周期（以毫秒计）来调用函数或计算表达式。

setInterval() 方法会不停地调用函数，直到 clearInterval() 被调用或窗口被关闭。由 setInterval() 返回的 ID 值可用作 clearInterval() 方法的参数。

语法

setInterval(code,millisec[,"lang"])
参数 | 描述
code | 必需。要调用的函数或要执行的代码串。
millisec | 必须。周期性执行或调用 code 之间的时间间隔，以毫秒计。

返回值

一个可以传递给 Window.clearInterval() 从而取消对 code 的周期性执行的值。

实例

<html>
<body>

<input type="text" id="clock" size="35" />
<script language=javascript>
var int=self.setInterval("clock()",50)
function clock()
  {
  var t=new Date()
  document.getElementById("clock").value=t
  }
</script>
</form>
<button onclick="int=window.clearInterval(int)">
Stop interval</button>

</body>
</html>

TIY

使用 setInterval() 和 clearInterval()

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM setTimeout() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM setTimeout() 方法

返回 HTML DOM Window 对象参考手册

定义和用法

setTimeout() 方法用于在指定的毫秒数后调用函数或计算表达式。

语法

setTimeout(code,millisec)
参数 | 描述
code | 必需。要调用的函数后要执行的 JavaScript 代码串。
millisec | 必需。在执行代码前需等待的毫秒数。

提示和注释

提示：setTimeout() 只执行 code 一次。如果要多次调用，请使用 setInterval() 或者让 code 自身再次调用 setTimeout()。

实例

<html>
<head>
<script type="text/javascript">
function timedMsg()
{
var t=setTimeout("alert('5 seconds!')",5000)
}
</script>
</head>

<body>
<form>
<input type="button" value="Display timed alertbox!"
onClick="timedMsg()">
</form>
<p>Click on the button above. An alert box will be
displayed after 5 seconds.</p>
</body>

</html>

TIY

简单的计时
另一个简单的计时
无穷循环中的计时
无穷循环中的计时 - 带有一个停止按钮
一个时钟

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM shape 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM shape 属性

返回 HTML DOM Anchor 对象参考手册

定义和用法

shape 属性可设置或返回图像映射中链接的形状。

语法

anchorObject.shape=RECT|CIRCLE|POLY|DEFAULT

实例

下面的例子可返回图像映射中链接的形状：

<html>
<body>

<img src="planets.gif"
width="145" height="126"
usemap="#planetmap" />

<map name="planetmap">
<area id="venus" shape="circle"
coords="124,58,8"
alt="Venus"
href="venus.htm" />
</map>

<p>Shape of Venus-link:
<script type="text/javascript">
x=document.getElementById("venus");
document.write(x.shape);
</script>
</p>

</body>
</html>

TIY

取得图像映射中链接的形状

返回 HTML DOM Anchor 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM shape 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM shape 属性

返回 HTML DOM Area 对象参考手册

定义和用法

shape 属性可设置或返回图像映射中某个区域的形状。

语法

areaObject.shape=RECT|CIRCLE|POLY|DEFAULT

实例

下面的例子可返回图像映射中 "Venus" 区域的形状：

<html>
<body>

<img src="planets.gif"
width="145" height="126"
usemap="#planetmap" />

<map name="planetmap">
<area id="venus" shape="circle"
coords="124,58,8"
alt="Venus"
href="venus.htm" />
</map>

<p>Venus shape:
<script type="text/javascript">
x=document.getElementById("venus");
document.write(x.shape);
</script>
</p>

</body>
</html>

TIY

返回图像映射中某个区域的形状

返回 HTML DOM Area 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM size 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM size 属性

返回 HTML DOM Password 对象参考手册

定义和用法

size 属性可设置或返回密码域的大小（以字符数计）。

语法

passwordObject.size=number_of_chars

实例

下面的例子更改了密码域的大小：

<html>
<head>
<script type="text/javascript">
function changeSize()
  {
  document.getElementById("password1").size=40
  }
</script>
</head>
<body>

<form>
<input type="password" id="password1" />
<input type="button" id="button1" onclick="changeSize()"
value="Change size of the password field" />
</form>

</body>
</html>

TIY

更改密码域的尺寸

返回 HTML DOM Password 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM size 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM size 属性

返回 HTML DOM Text 对象参考手册

定义和用法

size 属性设置或返回文本域的尺寸（以字符数计）

语法

textObject.size=number_of_char

实例

下面的例子提示出了文本域的尺寸：

<html>
<head>
<script type="text/javascript">
function fieldSize()
  {
  alert(document.getElementById("name").size)
  }
</script>
</head>

<body>
<form>
Name:
<input type="text" id="name" value="Mickey Mouse" size="20" maxlength="30" />
<br /><br />
<input type="button" onclick="fieldSize()" value="Alert size" />
</form>
</body>

</html>

TIY

提示出文本域的尺寸和最大字符数

返回 HTML DOM Text 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM src 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM src 属性

返回 HTML DOM Frame 对象参考手册

定义和用法

src 属性可设置或返回应当被载入框架中的文档的 URL。

该属性只是 HTML 的 <frame> 标记的一个对应，并不是 Window.location 这样的 Location 对象。

语法

frameObject.src=URL

实例

在我们的例子中，首先将创建包含带有两个列的框架集的 HTML 文档。每列设置为浏览器窗口的 50%：

<html>
  <frameset cols="50%,50%">
    <frame id="lFrame" src="frame_src.htm">
    <frame id="rFrame" src="frame_a.htm">
  </frameset>
</html>

HTML 文档 "frame_src.htm" 被放入第一列，而 HTML 文档 "frame_a.htm" 被放入第二列。

下面是 "frame_src.htm" 的源代码：

<html>
<head>
<script type="text/javascript">
function newSrc()
{
parent.document.getElementById("lFrame").src="http://w3school.com.cn"
parent.document.getElementById("rFrame").src="http://google.com"
}
</script>
</head>

<body>
<form>
<input type="button" onclick="newSrc()"
value="Change frame source" />
</form>
</body>

</html>

TIY

更改两个框架的源

返回 HTML DOM Frame 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM src 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM src 属性

返回 HTML DOM Iframe 对象参考手册

定义和用法

src 属性可设置或返回被载入 iframe 中的文档的 URL。

语法

iframeObject.src=URL

实例

下面的例子可更改两个框架的源：

<html>
<head>
<script type="text/javascript">
function changeSource()
  {
  document.getElementById("frame1").src="frame_c.htm"
  document.getElementById("frame2").src="frame_d.htm"
  }
</script>
</head>
<body>

<iframe src="frame_a.htm" id="frame1"></iframe>
<iframe src="frame_b.htm" id="frame2"></iframe>
<br /><br />
<input type="button" onclick="changeSource()"
value="Change source of the two iframes" />

</body>
</html>

TIY

更改两个框架的源

返回 HTML DOM Iframe 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM src 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM src 属性

返回 HTML DOM Image 对象参考手册

定义和用法

src 属性可设置或返回图像的 URL。

注释：该属性可在任意时间被更改。不过新图像会继承原始图像的 height 和 width 属性。

该属性的初始值由标记 <img> 的 src 属性来设置。当把该属性设置为新图像的 URL 时，浏览器就会把那幅新图像装载并显示出来。这对于更新网页的图像外观以响应用户的动作非常有用。

语法

imageObject.src=URL

实例

<html>
<head>
<script type="text/javascript">
function changeSrc()
  {
  document.getElementById("myImage").src="hackanm.gif"
  }
</script>
</head>
<body>

<img id="myImage" src="compman.gif" width="107" height="98" />
<br /><br />
<input type="button" onclick="changeSrc()" value="Change image">

</body>
</html>

TIY

更改图像的 src

返回 HTML DOM Image 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM status 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM status 属性

返回 HTML DOM Window 对象参考手册

定义和用法

status 属性可设置或返回窗口状态栏中的文本。

语法

window.status=sometext

说明

status 属性是一个可读可写的字符串，声明了要在窗口状态栏中显示的一条消息。通常显示这条消息的时间是有限的，直到其他的消息将它覆盖，或者用户把鼠标移动到窗口的其他区域为止。当擦除了 status 声明的消息时，状态栏要么恢复为它默认的空白状态，要么是再次显示出属性 defaultStatus 声明的默认消息。

据我们所知，不少浏览器已经关闭了脚本化它们的状态栏的功能。这是一项安全措施，防止隐藏了超链接真正目的的钓鱼攻击。

实例

下面的例子讲在状态栏设置文本：

<html>
<body>

<script type="text/javascript">
window.status="Some text in the status bar!!"
</script>

</body>
</html>

TIY

在窗口的状态栏设置文本

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Style 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Style 对象

Style 对象

Style 对象代表一个单独的样式声明。可从应用样式的文档或元素访问Style 对象。

使用Style 对象属性的语法：

document.getElementById("id").style.property="值"

Style 对象的属性：

  • 背景
  • 边框和边距
  • 布局
  • 列表
  • 杂项
  • 定位
  • 打印
  • 滚动条
  • 表格
  • 文本
  • 规范

IE: Internet Explorer, M: 仅适用于 Mac IE, W: 仅适用于 Windows IE, F: Firefox, O: Opera

W3C: 万维网联盟 World Wide Web Consortium (Internet 标准).

Background 属性

属性 | 描述 | IE | F | O | W3C
background | 在一行中设置所有的背景属性 | 4 | 1 | 9 | Yes
backgroundAttachment | 设置背景图像是否固定或随页面滚动 | 4 | 1 | 9 | Yes
backgroundColor | 设置元素的背景颜色 | 4 | 1 | 9 | Yes
backgroundImage | 设置元素的背景图像 | 4 | 1 | 9 | Yes
backgroundPosition | 设置背景图像的起始位置 | 4 | No | No | Yes
backgroundPositionX | 设置backgroundPosition属性的X坐标 | 4 | No | No | No
backgroundPositionY | 设置backgroundPosition属性的Y坐标 | 4 | No | No | No
backgroundRepeat | 设置是否及如何重复背景图像 | 4 | 1 | 9 | Yes

Border 和 Margin 属性

属性 | 描述 | IE | F | O | W3C
border | 在一行设置四个边框的所有属性 | 4 | 1 | 9 | Yes
borderBottom | 在一行设置底边框的所有属性 | 4 | 1 | 9 | Yes
borderBottomColor | 设置底边框的颜色 | 4 | 1 | 9 | Yes
borderBottomStyle | 设置底边框的样式 | 4 | 1 | 9 | Yes
borderBottomWidth | 设置底边框的宽度 | 4 | 1 | 9 | Yes
borderColor | 设置所有四个边框的颜色 (可设置四种颜色) | 4 | 1 | 9 | Yes
borderLeft | 在一行设置左边框的所有属性 | 4 | 1 | 9 | Yes
borderLeftColor | 设置左边框的颜色 | 4 | 1 | 9 | Yes
borderLeftStyle | 设置左边框的样式 | 4 | 1 | 9 | Yes
borderLeftWidth | 设置左边框的宽度 | 4 | 1 | 9 | Yes
borderRight | 在一行设置右边框的所有属性 | 4 | 1 | 9 | Yes
borderRightColor | 设置右边框的颜色 | 4 | 1 | 9 | Yes
borderRightStyle | 设置右边框的样式 | 4 | 1 | 9 | Yes
borderRightWidth | 设置右边框的宽度 | 4 | 1 | 9 | Yes
borderStyle | 设置所有四个边框的样式 (可设置四种样式) | 4 | 1 | 9 | Yes
borderTop | 在一行设置顶边框的所有属性 | 4 | 1 | 9 | Yes
borderTopColor | 设置顶边框的颜色 | 4 | 1 | 9 | Yes
borderTopStyle | 设置顶边框的样式 | 4 | 1 | 9 | Yes
borderTopWidth | 设置顶边框的宽度 | 4 | 1 | 9 | Yes
borderWidth | 设置所有四条边框的宽度 (可设置四种宽度) | 4 | 1 | 9 | Yes
margin | 设置元素的边距 (可设置四个值) | 4 | 1 | 9 | Yes
marginBottom | 设置元素的底边距 | 4 | 1 | 9 | Yes
marginLeft | 设置元素的左边距 | 4 | 1 | 9 | Yes
marginRight | 设置元素的右边据 | 4 | 1 | 9 | Yes
marginTop | 设置元素的顶边距 | 4 | 1 | 9 | Yes
outline | 在一行设置所有的outline属性 | 5M | 1 | 9 | Yes
outlineColor | 设置围绕元素的轮廓颜色 | 5M | 1 | 9 | Yes
outlineStyle | 设置围绕元素的轮廓样式 | 5M | 1 | 9 | Yes
outlineWidth | 设置围绕元素的轮廓宽度 | 5M | 1 | 9 | Yes
padding | 设置元素的填充 (可设置四个值) | 4 | 1 | 9 | Yes
paddingBottom | 设置元素的下填充 | 4 | 1 | 9 | Yes
paddingLeft | 设置元素的左填充 | 4 | 1 | 9 | Yes
paddingRight | 设置元素的右填充 | 4 | 1 | 9 | Yes
paddingTop | 设置元素的顶填充 | 4 | 1 | 9 | Yes

Layout 属性

属性 | 描述 | IE | F | O | W3C
clear | 设置在元素的哪边不允许其他的浮动元素 | 4 | 1 | 9 | Yes
clip | 设置元素的形状 | 4 | 1 | 9 | Yes
content | 设置元信息 | 5M | 1 |  | Yes
counterIncrement | 设置其后是正数的计数器名称的列表。其中整数指示每当元素出现时计数器的增量。默认是1。 | 5M | 1 |  | Yes
counterReset | 设置其后是正数的计数器名称的列表。其中整数指示每当元素出现时计数器被设置的值。默认是0。 | 5M | 1 |  | Yes
cssFloat | 设置图像或文本将出现（浮动）在另一元素中的何处。 | 5M | 1 | 9 | Yes
cursor | 设置显示的指针类型 | 4 | 1 | 9 | Yes
direction | 设置元素的文本方向 | 5 | 1 | 9 | Yes
display | 设置元素如何被显示 | 4 | 1 | 9 | Yes
height | 设置元素的高度 | 4 | 1 | 9 | Yes
markerOffset | 设置marker box的principal box距离其最近的边框边缘的距离 | 5M | 1 |  | Yes
marks | 设置是否cross marks或crop marks应仅仅被呈现于page box边缘之外 | 5M | 1 |  | Yes
maxHeight | 设置元素的最大高度 | 5M | 1 | 9 | Yes
maxWidth | 设置元素的最大宽度 | 5M | 1 | 9 | Yes
minHeight | 设置元素的最小高度 | 5M | 1 | 9 | Yes
minWidth | 设置元素的最小宽度 | 5M | 1 | 9 | Yes
overflow | 规定如何处理不适合元素盒的内容 | 4 | 1 | 9 | Yes
verticalAlign | 设置对元素中的内容进行垂直排列 | 4 | 1 | No | Yes
visibility | 设置元素是否可见 | 4 | 1 | 9 | Yes
width | 设置元素的宽度 | 4 | 1 | 9 | Yes

List 属性

属性 | 描述 | IE | F | O | W3C
listStyle | 在一行设置列表的所有属性 | 4 | 1 | 9 | Yes
listStyleImage | 把图像设置为列表项标记 | 4 | 1 | No | Yes
listStylePosition | 改变列表项标记的位置 | 4 | 1 | 9 | Yes
listStyleType | 设置列表项标记的类型 | 4 | 1 | 9 | Yes

Positioning 属性

属性 | 描述 | IE | F | O | W3C
bottom | 设置元素的底边缘距离父元素底边缘的之上或之下的距离 | 5 | 1 | 9 | Yes
left | 置元素的左边缘距离父元素左边缘的左边或右边的距离 | 4 | 1 | 9 | Yes
position | 把元素放置在static, relative, absolute 或 fixed 的位置 | 4 | 1 | 9 | Yes
right | 置元素的右边缘距离父元素右边缘的左边或右边的距离 | 5 | 1 | 9 | Yes
top | 设置元素的顶边缘距离父元素顶边缘的之上或之下的距离 | 4 | 1 | 9 | Yes
zIndex | 设置元素的堆叠次序 | 4 | 1 | 9 | Yes

Printing 属性

属性 | 描述 | IE | F | O | W3C
orphans | 设置段落留到页面底部的最小行数 | 5M | 1 | 9 | Yes
page | 设置显示某元素时使用的页面类型 | 5M | 1 | 9 | Yes
pageBreakAfter | 设置某元素之后的分页行为 | 4 | 1 | 9 | Yes
pageBreakBefore | 设置某元素之前的分页行为 | 4 | 1 | 9 | Yes
pageBreakInside | 设置某元素内部的分页行为 | 5M | 1 | 9 | Yes
size | 设置页面的方向和尺寸 |  | 1 | 9 | Yes
widows | 设置段落必须留到页面顶部的最小行数 | 5M | 1 | 9 | Yes

Scrollbar 属性 (IE-only)

属性 | 描述 | IE | F | O | W3C
scrollbar3dLightColor | 设置箭头和滚动条左侧和顶边的颜色 | 5W | No | No | No
scrollbarArrowColor | 设置滚动条上的箭头颜色 | 5W | No | No | No
scrollbarBaseColor | 设置滚动条的底色 | 5W | No | No | No
scrollbarDarkShadowColor | 设置箭头和滚动条右侧和底边的颜色 | 5W | No | No | No
scrollbarFaceColor | 设置滚动条的表色 | 5W | No | No | No
scrollbarHighlightColor | 设置箭头和滚动条左侧和顶边的颜色，以及滚动条的背景 | 5W | No | No | No
scrollbarShadowColor | 设置箭头和滚动条右侧和底边的颜色 | 5W | No | No | No
scrollbarTrackColor | 设置滚动条的背景色 | 5W | No | No | No

Table 属性

属性 | 描述 | IE | F | O | W3C
borderCollapse | 设置表格边框是否合并为单边框，或者像在标准的HTML中那样分离。 | 5 | 1 | 9 | Yes
borderSpacing | 设置分隔单元格边框的距离 | 5M | 1 | 9 | Yes
captionSide | 设置表格标题的位置 | 5M | No | No | Yes
emptyCells | 设置是否显示表格中的空单元格 | 5M | 1 | 9 | Yes
tableLayout | 设置用来显示表格单元格、行以及列的算法 | 5 | No | No | Yes

Text 属性

属性 | 描述 | IE | F | O | W3C
color | 设置文本的颜色 | 4 | 1 | 9 | Yes
font | 在一行设置所有的字体属性 | 4 | 1 | 9 | Yes
fontFamily | 设置元素的字体系列。 | 4 | 1 | 9 | Yes
fontSize | 设置元素的字体大小。 | 4 | 1 | 9 | Yes
fontSizeAdjust | 设置/调整文本的尺寸 | 5M | 1 | No | Yes
fontStretch | 设置如何紧缩或伸展字体 | 5M | No | No | Yes
fontStyle | 设置元素的字体样式 | 4 | 1 | 9 | Yes
fontVariant | 用小型大写字母字体来显示文本 | 4 | 1 | 9 | Yes
fontWeight | 设置字体的粗细 | 4 | 1 | 9 | Yes
letterSpacing | 设置字符间距 | 4 | 1 | 9 | Yes
lineHeight | 设置行间距 | 4 | 1 | 9 | Yes
quotes | 设置在文本中使用哪种引号 | 5M | 1 |  | Yes
textAlign | 排列文本 | 4 | 1 | 9 | Yes
textDecoration | 设置文本的修饰 | 4 | 1 | 9 | Yes
textIndent | 缩紧首行的文本 | 4 | 1 | 9 | Yes
textShadow | 设置文本的阴影效果 | 5M | 1 |  | Yes
textTransform | 对文本设置大写效果 | 4 | 1 | 9 | Yes
unicodeBidi |  | 5 | 1 |  | Yes
whiteSpace | 设置如何设置文本中的折行和空白符 | 4 | 1 | 9 | Yes
wordSpacing | 设置文本中的词间距 | 6 | 1 | 9 | Yes

Standard 属性

属性 | 描述 | IE | F | O | W3C
dir | 设置或返回文本的方向 | 5 | 1 | 9 | Yes
lang | 设置或返回元素的语言代码 | 5 | 1 | 9 | Yes
title | 设置或返回元素的咨询性的标题 | 5 | 1 | 9 | Yes

其他属性

cssText 属性

它是一组样式属性及其值的文本表示。这个文本格式化为一个 CSS 样式表，去掉了包围属性和值的元素选择器的花括号。将这一属性设置为非法的值将会抛出一个代码为 SYNTAX_ERR 的 DOMException 异常。当 CSS2Properties 对象是只读的时候，试图设置这一属性将会抛出一个代码为 NO_MODIFICATION_ALLOWED_ERR 的 DOMException 异常。

关于 CSS2Properties 对象

CSS2Properties 对象表示一组 CSS 样式属性及其值。它为 CSS 规范所定义的每一个 CSS 属性都定义了 JavaScript 属性。一个 HTMLElement 的 style 属性是一个可读可写的 CSS2Properties 对象，就好像 CSSRule 对象的 style 属性一样。

不过，Window.getComputedStyle() 的返回值是一个 CSS2Properties 对象，其属性是只读的。

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Submit 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Submit 对象

Submit 对象

Submit 对象代表 HTML 表单中的一个提交按钮 (submit button)。

在 HTML 表单中 <input type="submit"> 标签每出现一次，一个 Submit 对象就会被创建。

在表单提交之前，触发 onclick 事件句柄，并且一个句柄可以通过返回 fasle 来取消表单提交。

参阅 Form.submit() 方法 和 Form.onsubmit 事件句柄。

实例：表单验证

您可以通过遍历表单的 elements[] 数组来访问某个提交按钮，或者通过使用document.getElementById()。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet 标准).

Submit 对象的属性

属性 | 描述 | IE | F | O | W3C
accessKey | 设置或返回访问提交按钮的快捷键。 | 4 | 1 | 9 | Yes
alt | 设置或返回当浏览器不支持提交按钮时供显示的替代文本。 | 5 | 1 | 9 | Yes
disabled | 设置或返回提交按钮是否应被禁用。 | 5 | 1 | 9 | Yes
form | 返回一个对包含此提交按钮的表单的引用。 | 4 | 1 | 9 | Yes
id | 设置或返回提交按钮的 id。 | 4 | 1 | 9 | Yes
name | 设置或返回提交按钮的名称。 | 4 | 1 | 9 | Yes
tabIndex | 设置或返回提交按钮的 tab 键控制次序。 | 4 | 1 | 9 | Yes
type | 返回提交按钮的表单元素类型。 | 4 | 1 | 9 | Yes
value | 设置或返回在提交按钮上显示的文本。 | 4 | 1 | 9 | Yes

Standard Properties

Property | Description | IE | F | O | W3C
className | Sets or returns the class attribute of an element | 5 | 1 | 9 | Yes
dir | Sets or returns the direction of text | 5 | 1 | 9 | Yes
lang | Sets or returns the language code for an element | 5 | 1 | 9 | Yes
title | Sets or returns an element's advisory title | 5 | 1 | 9 | Yes

Submit 对象的方法

方法 | 描述 | IE | F | O | W3C
blur() | 从提交按钮上移开焦点。 | 4 | 1 | 9 | Yes
click() | 在提交按钮上模拟一次鼠标点击。 | 4 | 1 | 9 | Yes
focus() | 为提交按钮赋予焦点。 | 4 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM submit() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM submit() 方法

返回 HTML DOM Form 对象参考手册

定义和用法

submit() 方法把表单数据提交到 Web 服务器。

语法

formObject.submit()

说明

该方法提交表单的方式与用户单击 Submit 按钮一样，但是表单的 onsubmit 事件句柄不会被调用。

实例

<html>
<head>
<script type="text/javascript">
function formSubmit()
  {
  document.getElementById("myForm").submit()
  }
</script>
</head>

<body>

<form id="myForm" action="js_form_action.asp" method="get">
Firstname: <input type="text" name="firstname" size="20"><br />
Lastname: <input type="text" name="lastname" size="20"><br />
<br />
<input type="button" onclick="formSubmit()" value="Submit">
</form>
</body>

</html>

TIY

提交表单

返回 HTML DOM Form 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM summary 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM summary 属性

返回 HTML DOM Table 对象参考手册

定义和用法

summary 属性可设置或返回表格的概述。

summary 属性为语音合成或非可视的浏览器规定了表格的概述。

语法

tableObject.summary=text

实例

下面的例子可返回表格的概述：

<html>
<head>
<script type="text/javascript">
function alertSummary()
  {
  alert(document.getElementById("table1").summary);
  }
</script>
</head>
<body>

<table id="table1" border="1"
summary="Example table of employees">
<tr>
<th>Firstname</th>
<th>Lastname</th>
</tr>
<tr>
<td>Peter</td>
<td>Griffin</td>
</tr>
</table>
<br />
<input type="button" onclick=alertSummary()
value="Alert table summary" />

</body>
</html>

TIY

取得表格的概述

返回 HTML DOM Table 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM systemLanguage 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM systemLanguage 属性

返回 HTML DOM Navigator 对象参考手册

定义和用法

systemLanguage 属性可返回操作系统使用的默认语言。

语法

navigator.systemLanguage

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>SystemLanguage: ")
document.write(navigator.systemLanguage + "</p>")
</script>
</body>

</html>

TIY

检测访问者的浏览器和版本号
有关访问者的浏览器的更多信息
有关访问者的浏览器的全部细节
根据浏览器来提醒用户

返回 HTML DOM Navigator 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM tabIndex 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM tabIndex 属性

返回 HTML DOM Anchor 对象参考手册

定义和用法

tabIndex 属性可为链接设置或返回 tab 键控制次序。

语法

anchorObject.tabIndex=tabIndex

实例

下面的例子可更改三个链接的 tab 键控制次序：

<html>
<head>
<script type="text/javascript">
function changeTabIndex()
  {
  document.getElementById('1').tabIndex="3"
  document.getElementById('2').tabIndex="2"
  document.getElementById('3').tabIndex="1"
  }
</script>
</head>

<body>
<p><a id="1" href="http://www.w3school.com.cn">1</a></p>
<p><a id="2" href="http://www.w3school.com.cn">2</a></p>
<p><a id="3" href="http://www.w3school.com.cn">3</a></p>

<input type="button" onclick="changeTabIndex()"
value="Change TabIndex" />

</body>
</html>

TIY

为链接设置 tab 键控制次序

返回 HTML DOM Anchor 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM tabIndex 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM tabIndex 属性

返回 HTML DOM Area 对象参考手册

定义和用法

tabIndex 属性可设置或返回某个区域的 tab 键控制次序。

语法

areaObject.tabIndex=tabIndex

实例

下面的例子可展示图像映射中区域的 tab 键控制次序：

<html>
<head>
<script type="text/javascript">
function showTabIndex()
{
var sun=document.getElementById('sun').tabIndex;
var mercury=document.getElementById('mercury').tabIndex;
var venus=document.getElementById('venus').tabIndex;

document.write("Tab index of Sun: " + sun);
document.write("<br />");
document.write("Tab index of Mercury: " + mercury);
document.write("<br />");
document.write("Tab index of Venus: " + venus);
}
</script>
</head>
<body>

<img src ="planets.gif"
width="145" height="126"
alt="Planets"
usemap ="#planetmap" />

<map name="planetmap">
<area shape ="rect" coords ="0,0,82,126"
href ="sun.htm" id="sun" tabIndex="1" />
<area shape ="circle" coords ="90,58,3"
href ="mercur.htm" id="mercury" tabIndex="2" />
<area shape ="circle" coords ="124,58,8"
href ="venus.htm" id="venus" tabIndex="3" />
</map>

<input type="button" onclick="showTabIndex()"
value="Show tabIndex" />

</body>
</html>

TIY

返回图像映射中区域的 tab 键控制次序

返回 HTML DOM Area 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM tabIndex 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM tabIndex 属性

返回 HTML DOM Button 对象参考手册

定义和用法

tabIndex 属性可设置或返回按钮的 tab 键控制次序。

语法

buttonObject.tabIndex=tabIndex

实例

下面的例子可返回按钮的 tab 键控制次序：

<html>
<head>
<script type="text/javascript">
function showTabIndex()
  {
  var b1=document.getElementById('b1').tabIndex;
  var b2=document.getElementById('b2').tabIndex;
  var b3=document.getElementById('b3').tabIndex;
  document.write("Tab index of Button 1: " + b1);
  document.write("<br />");
  document.write("Tab index of Button 2: " + b2);
  document.write("<br />");
  document.write("Tab index of Button 3: " + b3);
  }
</script>
</head>
<body>

<button id="b1" tabIndex="1">Button 1</button><br />
<button id="b2" tabIndex="2">Button 2</button><br />
<button id="b3" tabIndex="3">Button 3</button><br />
<br />
<input type="button" onclick="showTabIndex()"
value="Show tabIndex" />

</body>
</html>

TIY

返回按钮的 tab 键控制次序

返回 HTML DOM Button 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM tabIndex 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM tabIndex 属性

返回 HTML DOM Button 对象参考手册

定义和用法

tabIndex 属性可设置或返回按钮的 tab 键控制次序。

语法

buttonObject.tabIndex=tabIndex

实例

下面的例子将返回按钮的 tab 键控制次序：

<html>
<head>
<script type="text/javascript">
function showTabIndex()
  {
  var b1=document.getElementById('b1').tabIndex;
  var b2=document.getElementById('b2').tabIndex;
  var b3=document.getElementById('b3').tabIndex;
  document.write("Tab index of Button 1: " + b1);
  document.write("<br />");
  document.write("Tab index of Button 2: " + b2);
  document.write("<br />");
  document.write("Tab index of Button 3: " + b3);
  }
</script>
</head>
<body>

<form>
<input type="button" id="b1" tabIndex="1" value="Button 1" />
<br />
<input type="button" id="b2" tabIndex="2" value="Button 2" />
<br />
<input type="button" id="b3" tabIndex="3" value="Button 3" />
<br />
<input type="button" onclick="showTabIndex()"
value="Show tabIndex" />
</form>

</body>
</html>

TIY

显示按钮的 tab 控制次序

返回 HTML DOM Button 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM tabIndex 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM tabIndex 属性

返回 HTML DOM Checkbox 对象参考手册

定义和用法

tabIndex 属性可设置或返回 checkbox 的 tab 键控制次序。

语法

checkboxObject.tabIndex=number

实例

下面的例子可更改 checkbox 的 tab index：

<html>
<head>
<script type="text/javascript">
function changeTabIndex()
{
document.getElementById('check3').tabIndex="1"
document.getElementById('check1').tabIndex="3"
}
</script>
</head>
<body>

<form>
<input type="checkbox" id="check1" tabIndex="1" /><br />
<input type="checkbox" id="check2" tabIndex="2" /><br />
<input type="checkbox" id="check3" tabIndex="3" /><br />

<input type="button" onclick="changeTabIndex()" value="Change tabIndex" />
</form>

</body>
</html>

TIY

更改 checkbox 的 tab 键次序

返回 HTML DOM Checkbox 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM tabIndex 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM tabIndex 属性

返回 HTML DOM Password 对象参考手册

定义和用法

tabIndex 属性设置或返回密码域的 tab 键控制次序。

语法

passwordObject.tabIndex=number

实例

下面的例子可显示表单元素的 tab 键控制次序：

<html>
<head>
<script type="text/javascript">
function showTabIndex()
  {
  var email=document.getElementById('email').tabIndex;
  var pwd=document.getElementById('pwd').tabIndex;
  document.write("Tab index of email field: " + email);
  document.write("<br />");
  document.write("Tab index of password field: " + pwd);
  }
</script>
</head>
<body>

<form>
Email: <input type="text" id="email" tabindex="1" />
<br />
Password: <input type="password" id="pwd" tabindex="2" />
<br />
<input type="button" onclick="showTabIndex()" value="Show tabIndex" />
</form>

</body>
</html>

TIY

显示表单元素的 tab 键控制次序

返回 HTML DOM Password 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM tabIndex 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM tabIndex 属性

返回 HTML DOM Radio 对象参考手册

定义和用法

tabIndex 属性可设置或返回单选按钮的 tab 键控制次序。

语法

radioObject.tabIndex=number

实例

下面的例子可显示出单选按钮的 tab index：

<html>
<head>
<script type="text/javascript">
function showTabIndex()
  {
  var r1=document.getElementById('radio1').tabIndex;
  var r2=document.getElementById('radio2').tabIndex;
  var r3=document.getElementById('radio3').tabIndex;
  document.write("Tab index of radio button 1: " + r1);
  document.write("<br />");
  document.write("Tab index of radio button 2: " + r2);
  document.write("<br />");
  document.write("Tab index of radio button 3: " + r3);
  }
</script>
</head>
<body>

<form>
<input type="radio" id="radio1" tabindex="1" /><br />
<input type="radio" id="radio2" tabindex="2" /><br />
<input type="radio" id="radio3" tabindex="3" /><br />
<input type="button" onclick="showTabIndex()" value="Show tabIndex" />
</form>

</body>
</html>

TIY

显示单选按钮的 tab 键控制次序

返回 HTML DOM Radio 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM tabIndex 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM tabIndex 属性

返回 HTML DOM Submit 对象参考手册

定义和用法

tabIndex 属性可设置或返回确认按钮的 tab 键控制次序。

语法

submitObject.tabIndex=tabIndex

实例

下面的例子可显示表单元素的 tab 键控制次序：

<html>
<head>
<script type="text/javascript">
function showTabIndex()
  {
  var email=document.getElementById('email').tabIndex;
  var r1=document.getElementById('submit1').tabIndex;
  document.write("Tab index of email: " + email);
  document.write("<br />");
  document.write("Tab index of submit button: " + r1);
  }
</script>
</head>
<body>

<form>
Email: <input type="text" id="email" tabIndex="1"
size="25" value="someone@example.com" />
<br />
<input type="submit" id="submit1" tabIndex="2" />
<br /><br />
<input type="button" onclick="showTabIndex()" value="Show tabIndex" />
</form>

</body>
</html>

TIY

显示表单元素的 tab 键控制次序

返回 HTML DOM Submit 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM tabIndex 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM tabIndex 属性

返回 HTML DOM Text 对象参考手册

定义和用法

tabIndex 属性设置或返回文本域的 tab 键控制次序。

语法

textObject.tabIndex=number

实例

下面的例子显示出不同文本域的 tab 键控制次序：

<html>
<head>
<script type="text/javascript">
function checkTab(x)
{
alert(x.tabIndex)
}
</script>
</head>
<body>

<form id="myForm">
<input type="text" tabindex="1" onclick="checkTab(this)">
<input type="text" tabindex="2" onclick="checkTab(this)">
<input type="text" tabindex="3" onclick="checkTab(this)">
</form>

</body>
</html>

TIY

显示出不同文本域的 tab 键控制次序

返回 HTML DOM Text 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM tabIndex 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM tabIndex 属性

返回 HTML DOM Select 对象参考手册

定义和用法

tabIndex 属性可设桌返回下拉列表中的 tab 键控制次序。

语法

selectObject.tabIndex=number

实例

下面的例子将显示出一个文本框和一个下拉列表的 tab 键控制次序：

<html>
<head>
<script type="text/javascript">
function showTabIndex()
  {
  var email=document.getElementById('email').tabIndex;
  var sex=document.getElementById('sex').tabIndex;
  document.write("Tab index of email field: " + email);
  document.write("<br />");
  document.write("Tab index of dropdown list: " + sex);
  }
</script>
</head>
<body>

<form>
Email: <input type="text" id="email" tabindex="1" />
<br />
Sex:
<select id="sex" tabindex="2">
<option>Male</option>
<option>Female</option>
</select>
<br /><br />
<input type="button" onclick="showTabIndex()"
value="Show tabIndex" />
</form>

</body>
</html>

TIY

显示表单域的 tab 键控制次序

返回 HTML DOM Select 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Table 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Table 对象

Table 对象

Table 对象代表一个 HTML 表格。

在 HTML 文档中 <table> 标签每出现一次，一个 Table 对象就会被创建。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet 标准).

Table 对象的集合

集合 | 描述 | IE | F | O | W3C
cells[] | 返回包含表格中所有单元格的一个数组。 | 5 | 1 | 1 | No
rows[] | 返回包含表格中所有行的一个数组。 | 4 | 1 | 9 | Yes
tBodies[] | 返回包含表格中所有 tbody 的一个数组。 | 4 |  |  | Yes

Table 对象的属性

属性 | 描述 | IE | F | O | W3C
align | 表在文档中的水平对齐方式。（已废弃） | - | - | - | -
bgColor | 表在文档中的水平对齐方式。（已废弃） | - | - | - | -
border | 设置或返回表格边框的宽度。 | 4 | 1 | 9 | Yes
caption | 对表格的 <caption> 元素的引用。 | 4 | 1 | 9 | Yes
cellPadding | 设置或返回单元格内容和单元格边框之间的空白量。 | 4 | 1 | 9 | Yes
cellSpacing | 设置或返回在表格中的单元格之间的空白量。 | 4 | 1 | 9 | Yes
frame | 设置或返回表格的外部边框。 | 4 | 1 | 9 | Yes
id | 设置或返回表格的 id。 | 4 | 1 | 9 | Yes
rules | 设置或返回表格的内部边框（行线）。 | 4 | 1 | 9 | Yes
summary | 设置或返回对表格的描述（概述）。 | 6 | 1 | 9 | Yes
tFoot | 返回表格的 TFoot 对象。如果不存在该元素，则为 null。 | 4 | 1 | 9 | Yes
tHead | 返回表格的 THead 对象。如果不存在该元素，则为 null。 | 4 | 1 | 9 | Yes
width | 设置或返回表格的宽度。 | 4 | 1 | 9 | Yes

Standard Properties

Property | Description | IE | F | O | W3C
className | Sets or returns the class attribute of an element | 5 | 1 | 9 | Yes
dir | Sets or returns the direction of text | 5 | 1 | 9 | Yes
lang | Sets or returns the language code for an element | 5 | 1 | 9 | Yes
title | Sets or returns an element's advisory title | 5 | 1 | 9 | Yes

Table 对象的方法

方法 | 描述 | IE | F | O | W3C
createCaption() | 为表格创建一个 caption 元素。 | 4 | 1 | 9 | Yes
createTFoot() | 在表格中创建一个空的 tFoot 元素。 | 4 | 1 | 9 | Yes
createTHead() | 在表格中创建一个空的 tHead 元素。 | 4 | 1 | 9 | Yes
deleteCaption() | 从表格删除 caption 元素以及其内容。 | 4 | 1 | 9 | Yes
deleteRow() | 从表格删除一行。 | 4 | 1 | 9 | Yes
deleteTFoot() | 从表格删除 tFoot 元素及其内容。 | 4 | 1 | 9 | Yes
deleteTHead() | 从表格删除 tHead 元素及其内容。 | 4 | 1 | 9 | Yes
insertRow() | 在表格中插入一个新行。 | 4 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM TableCell 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM TableCell 对象

TableCell 对象

TableCell 对象代表一个 HTML 表格单元格。

在一个 HTML 文档中 <td> 标签每出现一次，一个 TableCell 对象就会被创建。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet 标准).

TableCell 对象的属性

属性 | 描述 | IE | F | O | W3C
abbr | 设置或返回单元格中内容的缩写版本。 | 6 | 1 | 9 | Yes
align | 设置或返回单元格内部数据的水平排列方式。 | 4 | 1 | 9 | Yes
axis | 设置或返回相关单元格的一个逗号分隔的列表。 | 6 | 1 | 9 | Yes
cellIndex | 返回单元格在某行的单元格集合中的位置。 | 4 | 1 | 9 | Yes
ch | 设置或返回单元格的对齐字符。 |  |  |  | Yes
chOff | 设置或返回单元格的对齐字符的偏移量。 |  |  |  | Yes
colSpan | 单元格横跨的列数。 | 4 | 1 | 9 | Yes
headers | 设置或返回 header-cell 的 id 值。 |  |  |  | Yes
id | 设置或返回单元格的 id。 | 4 | 1 | 9 | Yes
innerHTML | 设置或返回单元格的开始标签和结束标签之间的 HTML。 | 4 | 1 | 9 | No
rowSpan | 设置或返回单元格可横跨的行数。 | 4 | 1 | 9 | Yes
scope | 设置或返回此单元格是否可提供标签信息。 |  |  |  | Yes
vAlign | 设置或返回表格单元格内数据的垂直排列方式。 | 4 | 1 | 9 | Yes
width | 设置或返回单元格的宽度。 | 4 | 1 | 9 | Yes

Standard Properties

属性 | 描述 | IE | F | O | W3C
className | Sets or returns the class attribute of an element | 5 | 1 | 9 | Yes
dir | Sets or returns the direction of text | 5 | 1 | 9 | Yes
lang | Sets or returns the language code for an element | 5 | 1 | 9 | Yes
title | Sets or returns an element's advisory title | 5 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM tableLayout 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM tableLayout 属性

返回HTML DOM Style 对象参考手册

定义和用法

tableLayout 属性用来显示表格单元格、行、列的算法规则。

固定表格布局：

固定表格布局与自动表格布局相比，允许浏览器更快地对表格进行布局。

在固定表格布局中，水平布局仅取决于表格宽度、列宽度、表格边框宽度、单元格间距，而与单元格的内容无关。

通过使用固定表格布局，用户代理在接收到第一行后就可以显示表格。

自动表格布局：

在自动表格布局中，列的宽度是由列单元格中没有折行的最宽的内容设定的。

此算法有时会较慢，这是由于它需要在确定最终的布局之前访问表格中所有的内容。

语法：

Object.style.tableLayout=automatic|fixed

可能的值

值 | 描述
automatic | 默认。列宽度由单元格内容设定。
fixed | 列宽由表格宽度和列宽度设定。

实例

本例设置固定表格布局：

<html>
<head>
<script type="text/javascript">
function setFixedTableLayout()
{
document.getElementById('myTable').style.tableLayout="fixed";
}
</script>
</head>
<body>

<table id="myTable" border="1" width="100%">
<col width="20%"><col width="40%"><col width="40%">
<tr>
<td>1000000000000000000000000000</td>
<td>10000000</td>
<td>100</td>
</tr>
</table>

<input type="button" onclick="setFixedTableLayout()"
value="Set fixed table layout">

</body>
</html>

TIY

改变表格的布局 (tableLayout)

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM TableRow 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM TableRow 对象

TableRow 对象

TableRow 对象代表一个 HTML 表格行。

在 HTML 文档中 <tr> 标签每出现一次，一个 TableRow 对象就会被创建。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet 标准).

TableRow 对象的集合

集合 | 描述 | IE | F | O | W3C
cells[] | 返回包含行中所有单元格的一个数组。 | 4 | 1 | 9 | Yes

TableRow 对象的属性

属性 | 描述 | IE | F | O | W3C
align | 设置或返回在行中数据的水平排列。 | 4 | 1 | 9 | Yes
ch | 设置或返回在行中单元格的对齐字符。 |  |  |  | Yes
chOff | 设置或返回在行中单元格的对齐字符的偏移量。 |  |  |  | Yes
id | 设置或返回行的 id。 | 4 | 1 | 9 | Yes
innerHTML | 设置或返回行的开始标签和结束标签之间的 HTML。 | 5 | 1 | 9 | No
rowIndex | 返回该行在表中的位置。 | 4 | 1 | 9 | Yes
sectionRowIndex | 返回在 tBody 、tHead 或 tFoot 中，行的位置。 |  |  |  | Yes
vAlign | 设置或返回在行中的数据的垂直排列方式。 | 4 | 1 | 9 | Yes

TableRow 对象的方法

方法 | 描述 | IE | F | O | W3C
deleteCell() | 删除行中的指定的单元格。 | 4 | 1 | 9 | Yes
insertCell() | 在一行中的指定位置插入一个空的 <td> 元素。 | 4 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM taintEnabled() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM taintEnabled() 方法

返回 HTML DOM Navigator 对象参考手册

定义和用法

taintEnabled() 方法可返回一个布尔值，该值声明了当前浏览器是否启用了 data tainting。

语法

navigator.taintEnabled()

实例

下面的例子讲返回当前浏览器是否已启用 data tainting 的布尔值：

<html>
<body>

<script type="text/javascript">
alert(navigator.taintEnabled())
</script>

</body>
</html>

输出：

false

TIY

使用 navigator 对象的 taintEnabled() 方法

返回 HTML DOM Navigator 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM target 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM target 属性

返回 HTML DOM Anchor 对象参考手册

定义和用法

target 属性可设置或返回在何处打开链接。

语法

anchorObject.target=_blank|_parent|_self|_top

四个保留的目标名称：

  • _blank - 在一个新的未命名的窗口载入文档
  • _self - 在相同的框架或窗口中载入目标文档
  • _parent - 把文档载入父窗口或包含了超链接引用的框架的框架集
  • _top - 把文档载入包含该超链接的窗口,取代任何当前正在窗口中显示的框架

实例

下面的例子将更改一个链接的文本、URL 以及 target：

<html>
<head>
<script type="text/javascript">
function changeLink()
{
document.getElementById('myAnchor').innerHTML="W3School";
document.getElementById('myAnchor').href="http://www.w3school.com.cn";
document.getElementById('myAnchor').target="_blank";
}
</script>
</head>

<body>
<a id="myAnchor" href="http://www.microsoft.com">Microsoft</a>
<input type="button" onclick="changeLink()" value="Change link">
</body>

</html>

TIY

更改一个链接的文本、URL 以及 target

返回 HTML DOM Anchor 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM target 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM target 属性

返回 HTML DOM Area 对象参考手册

定义和用法

target 属性可设置或返回在何处打开区域中的 link-URL。

语法

areaObject.target=_blank|_parent|_self|_top

四个保留的目标名称：

  • _blank - 在一个新的未命名的窗口载入文档
  • _self - 在相同的框架或窗口中载入目标文档
  • _parent - 把文档载入父窗口或包含了超链接引用的框架的框架集
  • _top - 把文档载入包含该超链接的窗口,取代任何当前正在窗口中显示的框架

实例

The following example changes the target of the link in the image-map:

<html>
<head>
<script type="text/javascript">
function changeTarget()
  {
  document.getElementById('venus').target="_blank"
  }
</script>
</head>
<body>

<img src ="planets.gif"
width="145" height="126"
alt="Planets"
usemap ="#planetmap" />

<map name ="planetmap">
<area shape ="circle" coords ="124,58,8"
href ="venus.htm" id="venus" />
</map>
<br />
<input type="button" onclick="changeTarget()"
value="Change target" />

</body>
</html>

TIY

更改图像映射中某个链接的 target

返回 HTML DOM Area 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM target 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM target 属性

返回 HTML DOM Base 对象参考手册

定义和用法

target 属性可设置或返回页面中所有链接的默认 target。

语法

baseObject.target=target

实例

下面的例子可返回默认的链接 target：

<html>
<head>
<base id="myBaseId" target="_blank"
href="http://www.w3school.com.cn/htmldom/" />
</head>

<body>

<p>Base target:
<script type="text/javascript">
x=document.getElementById('myBaseId');
document.write(x.target);
</script>

</body>
</html>

输出：

Base target: _blank

TIY

取得 HTML 文档的基本 target

返回 HTML DOM Base 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM target 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM target 属性

返回 HTML DOM Form 对象参考手册

定义和用法

target 属性可设置或返回在何处打开表单中的 action-URL。

语法

formObject.target=_blank|_parent|_self|_top

四个保留的目标名称：

  • _blank - 在一个新的未命名的窗口载入文档
  • _self - 在相同的框架或窗口中载入目标文档
  • _parent - 把文档载入父窗口或包含了超链接引用的框架的框架集
  • _top - 把文档载入包含该超链接的窗口,取代任何当前正在窗口中显示的框架

实例

下面的例子可设置在一个新窗口打开 action-URL：

<html>
<head>
<script type="text/javascript">
function submitForm()
  {
  var x=document.getElementById("myForm");
  x.target="_blank";
  x.submit();
  }
</script>
</head>
<body>

<form id="myForm" action="default.asp">
Name: <input type="text" value="Mickey Mouse" />
<input type="button" onclick="submitForm()"
value="Submit" />
</form>

</body>
</html>

TIY

设置表单的 property 属性

返回 HTML DOM Form 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Text 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Text 对象

Text 对象

Text 对象代表 HTML 表单中的文本输入域。

在 HTML 表单中 <input type="text"> 每出现一次，Text 对象就会被创建。

该元素可创建一个单行的文本输入字段。当用户编辑显示的文本并随后把输入焦点转移到其他元素的时候，会触发 onchange 事件句柄。

您可以使用 HTML <textarea> 标记来创建多行文本输入。参阅 Textarea 对象。

对于掩码文本输入，把 <input type="text"> 中的 type 设置为 "password"。参阅 Input Password。

您可以通过表单的 elements[] 数组来访问文本输入域，或者通过使用 document.getElementById()。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet 标准).

Text 对象的属性

属性 | 描述 | IE | F | O | W3C
accessKey | 设置或返回访问文本域的快捷键。 | 4 | 1 | 9 | Yes
alt | 设置或返回当浏览器不支持文本域时供显示的替代文本。 | 5 | 1 | 9 | Yes
defaultValue | 设置或返回文本域的默认值。 | 4 | 1 | 9 | Yes
disabled | 设置或返回文本域是否应被禁用。 | 5 | 1 | 9 | Yes
form | 返回一个对包含文本域的表单对象的引用。 | 4 | 1 | 9 | Yes
id | 设置或返回文本域的 id。 | 4 | 1 | 9 | Yes
maxLength | 设置或返回文本域中的最大字符数。 | 4 | 1 | 9 | Yes
name | 设置或返回文本域的名称。 | 4 | 1 | 9 | Yes
readOnly | 设置或返回文本域是否应是只读的。 | 4 | 1 | 9 | Yes
size | 设置或返回文本域的尺寸。 | 4 | 1 | 9 | Yes
tabIndex | 设置或返回文本域的 tab 键控制次序。 | 4 | 1 | 9 | Yes
type | 返回文本域的表单元素类型。 | 4 | 1 | 9 | Yes
value | 设置或返回文本域的 value 属性的值。 | 4 | 1 | 9 | Yes

Standard Properties

Property | Description | IE | F | O | W3C
className | Sets or returns the class attribute of an element | 5 | 1 | 9 | Yes
dir | Sets or returns the direction of text | 5 | 1 | 9 | Yes
lang | Sets or returns the language code for an element | 5 | 1 | 9 | Yes
title | Sets or returns an element's advisory title | 5 | 1 | 9 | Yes

Text Object Methods

方法 | 描述 | IE | F | O | W3C
blur() | 从文本域上移开焦点。 | 4 | 1 | 9 | Yes
focus() | 在文本域上设置焦点。 | 4 | 1 | 9 | Yes
select() | 选取文本域中的内容。 | 4 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM text 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM text 属性

返回 HTML DOM Option 对象参考手册

定义和用法

text 属性可设置或返回选项的文本值。

该属性设置或返回的是包含在 <option> 元素中的纯文本。这个文本会作为选项的标签出现。

语法

optionObject.text=sometext

实例

下面的例子可返回被选选项的文本：

<html>
<head>
<script type="text/javascript">
function getOption()
  {
  var x=document.getElementById("mySelect")
  alert(x.options[x.selectedIndex].text)
  }
</script>
</head>
<body>

<form>
Select your favorite fruit:
<select id="mySelect">
  <option>Apple</option>
  <option>Orange</option>
  <option>Pineapple</option>
  <option>Banana</option>
</select>
<br /><br />
<input type="button" onclick="getOption()"
value="Alert text of selected option">
</form>

</body>
</html>

TIY

返回被选选项的文本
设置被选选项的文本

返回 HTML DOM Option 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM textAlign 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM textAlign 属性

返回HTML DOM Style 对象参考手册

定义和用法

textAlign 属性对齐元素中的文本。

语法：

Object.style.textAlign=left|right|center|justify

可能的值

值 | 描述
left | 把文本排列到左边。默认值：由浏览器决定。
right | 把文本排列到右边。
center | 把文本排列到中间。
justify | 根据 textJustify 属性对齐文本。

实例

本例对齐一段文本：

<html>
<head>
<script type="text/javascript">
function setTextAlign()
{
document.getElementById("p1").style.textAlign="right";
}
</script>
</head>
<body>

<p id="p1">This is an example paragraph.</p>

<input type="button" onclick="setTextAlign()"
value="Align text" />

</body>
</html>

TIY

textAlign - 对齐一段文本

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Textarea 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Textarea 对象

Textarea 对象

Textarea 对象代表 HTML 表单中的一个文本区 (text-area)。在表单中 <textarea> 标签每出现一次，一个 Textarea 对象就会被创建。

您可以通过索引相应表单的元素数组来访问某个 Textarea 对象，或者使用 getElementById()。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: World Wide Web Consortium (Internet 标准).

Textarea Object Properties

属性 | 描述 | IE | F | O | W3C
accessKey | 设置或返回访问 textarea 的键盘快捷键。 | 4 | 1 | 9 | Yes
cols | 设置或返回 textarea 的宽度。 | 4 | 1 | 9 | Yes
defaultValue | 设置或返回文本框中的初始内容。 | 4 | 1 | 9 | Yes
disabled | 设置或返回 textarea 是否应当被禁用。 | 5 | 1 | 9 | Yes
form | 返回对包含该 textarea 的表单对象的引用。 | 4 | 1 | 9 | Yes
id | 设置或返回某个 textarea 的 id | 4 | 1 | 9 | Yes
name | 设置或返回 textarea 的名称。 | 4 | 1 | 9 | Yes
readOnly | 设置或返回 textarea 是否应当是只读的。 | 4 | 1 | 9 | Yes
rows | 设置或返回 textarea 的高度。 | 4 | 1 | 9 | Yes
tabIndex | 设置或返回 textarea 的 tab 键控制次序。 | 4 | 1 | 9 | Yes
type | 返回该文本框的表单类型。 | 4 | 1 | 9 | Yes
value | 设置或返回在 textarea 中的文本。 | 4 | 1 | 9 | Yes

Standard Properties

属性 | 描述 | IE | F | O | W3C
className | Sets or returns the class attribute of an element | 5 | 1 | 9 | Yes
dir | Sets or returns the direction of text | 5 | 1 | 9 | Yes
lang | Sets or returns the language code for an element | 5 | 1 | 9 | Yes
title | Sets or returns an element's advisory title | 5 | 1 | 9 | Yes

Textarea 对象的方法

方法 | 描述 | IE | F | O | W3C
blur() | 从 textarea 移开焦点。 | 4 | 1 | 9 | Yes
focus() | 在 textarea 上设置焦点。 | 4 | 1 | 9 | Yes
select() | 选择 textarea 中的文本。 | 4 | 1 | 9 | Yes

Textarea 对象的事件句柄

事件句柄 | 描述 | IE | F | O | W3C
onchange | 当输入值改变时调用的事件句柄 | 4 | 1 | 9 | Yes

HTML DOM 参考手册
HTML DOM 实例


HTML DOM textDecoration 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM textDecoration 属性

返回HTML DOM Style 对象参考手册

定义和用法

textDecoration 属性对文本进行修饰。

语法：

Object.style.textDecoration=none|underline|overline|line-through|blink

可能的值

值 | 描述
none | 默认。定义标准的文本。
underline | 定义文本下的一条线。
overline | 定义文本上的一条线。
line-through | 定义穿过文本下的一条线。
blink | 定义闪烁的文本（无法运行在 IE 和 Opera 中）。

实例

本例给文本设置下划线：

<html>
<head>
<script type="text/javascript">
function setTextDecoration()
{
document.getElementById("p1").style.textDecoration="overline";
}
</script>
</head>
<body>

<p id="p1">This is an example paragraph.</p>

<input type="button" onclick="setTextDecoration()"
value="Set text-decoration" />

</body>
</html>

TIY

textDecoration - 装饰文本

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM textIndent 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM textIndent 属性

返回HTML DOM Style 对象参考手册

定义和用法

textIndent 属性缩进元素中的首行文本。

语法：

Object.style.textIndent=length|%

可能的值

值 | 描述
length | 定义固定的缩进。默认值：0。
% | 定义基于父元素宽度的百分比的缩进。

实例

本例缩进文本：

<html>
<head>
<script type="text/javascript">
function setTextIndent()
{
document.getElementById("div1").style.textIndent="50px";
}
</script>
</head>
<body>

<div id="div1">
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
</div>
<br />
<input type="button" onclick="setTextIndent()"
value="Indent first line of text" />

</body>
</html>

TIY

textIndent - 缩进文本

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM textTransform 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM textTransform 属性

返回HTML DOM Style 对象参考手册

定义和用法

textTransform 属性会改变元素中的字母大小写，而不论源文档中文本的大小写。

语法：

Object.style.whiteSpace=normal|nowrap|pre

可能的值

值 | 描述
none | 默认。定义带有小写字母和大写字母的标准的文本。
capitalize | 文本中的每个单词以大写字母开头。
uppercase | 定义仅有大写字母。
lowercase | 定义无大写字母，仅有小写字母。

实例

本例把每个单词的第一个字母转换为大写：

<html>
<head>
<script type="text/javascript">
function removeWrapping()
{
document.getElementById("div1").style.whiteSpace="nowrap";
}
</script>
</head>
<body>

<div id="div1">
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
</div>
<br />
<input type="button" onclick="removeWrapping()"
value="Do not let the text wrap" />

</body>
</html>

TIY

textTransform - 转换文本

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM title 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM title 属性

返回 HTML DOM Document 对象参考手册

定义和用法

title 属性可返回当前文档的标题（ HTML title 元素中的文本）。

语法

document.title

实例

<html>
<head>
<title>My title</title>
</head>

<body>
The title of the document is:
<script type="text/javascript">
document.write(document.title)
</script>
</body>

</html>

TIY

返回当前文档的标题

返回 HTML DOM Document 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM title 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM title 属性

返回HTML DOM Style 对象参考手册

定义和用法

title 属性设置或返回元素的（咨询性质的）标题。

语法：

object.title=title

实例 1

本例展示了两种获取 <body> 元素的 title 属性的方法：

<html>
<body id="myid" title="mytitle">

<script type="text/javascript">
x=document.getElementsByTagName('body')[0];
document.write("Body title: " + x.title);
document.write("<br />");
document.write("An alternate way: ");
document.write(document.getElementById('myid').title);
</script>

</body>
</html>

实例 2

本例返回图像映射中某个区域的 title：

<html>
<body>

<img src ="planets.gif"
width="145" height="126"
alt="Planets"
usemap ="#planetmap" />

<map name ="planetmap">
<area id="venus" shape="circle"
coords ="124,58,8"
title="Venus"
href ="venus.htm"  />
</map>

<p>Venus' advisory title (mouse over the Venus planet):
<script type="text/javascript">
x=document.getElementById('venus')
document.write(x.title)
</script>
</p>

</body>
</html>

TIY

返回 <body> 元素的 title 属性
返回图像映射中某个区域的 title

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM title 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM title 属性

返回 HTML DOM Area 对象参考手册

定义和用法

title 属性设置或返回元素的参考性的标题。

语法

areaObject.title=title

实例

本例返回 "Venus" 的 title：

<html>
<body>

<img src ="planets.gif"
width="145" height="126"
alt="Planets"
usemap ="#planetmap" />

<map name ="planetmap">
<area id="venus" shape="circle"
coords ="124,58,8"
title="Venus"
href ="venus.htm"  />
</map>

<p>Venus' advisory title (mouse over the Venus planet):
<script type="text/javascript">
x=document.getElementById('venus')
document.write(x.title)
</script>
</p>

</body>
</html>

TIY

返回 image-map 中 area 的 title

返回 HTML DOM Area 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM title 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM title 属性

返回 HTML DOM Body 对象参考手册

定义和用法

title 属性可设置或返回对元素的描述性短语。

语法

bodyObject.title=title

实例

下面的例子将展示设置 <body> 元素的 title 属性的两种方法：

<html>
<body id="myid" title="mytitle">

<script type="text/javascript">
x=document.getElementsByTagName('body')[0];
document.write("Body title: " + x.title);
document.write("<br />");
document.write("An alternate way: ");
document.write(document.getElementById('myid').title);
</script>

</body>
</html>

输出：

Body title: mytitle
An alternate way: mytitle

TIY

返回 <body> 元素的标题

返回 HTML DOM Body 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM top 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM top 属性

返回 HTML DOM Window 对象参考手册

定义和用法

top 属性返回最顶层的先辈窗口。

该属性返回队一个顶级窗口的只读引用。如果窗口本身就是一个顶级窗口，top 属性存放对窗口自身的引用。如果窗口是一个框架，那么 top 属性引用包含框架的顶层窗口。

语法

window.top

实例

下面的例子窗口是否在一个框架中，如果是，则跳出框架：

<html>
<head>
<script type="text/javascript">
function breakout()
{
if (window.top!=window.self)
{
window.top.location="tryjs_breakout.htm"
}
}
</script>
</head>

<body>
<form>
Click the button to break out of the frame:
<input type="button" onclick="breakout()" value="Break out!">
</form>
</body>

</html>

TIY

跳出框架
调整窗口的尺寸
把窗口调整为指定的尺寸

返回 HTML DOM Window 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM top 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM top 属性

返回HTML DOM Style 对象参考手册

定义和用法

top 属性设置一个定位元素的上外边距边界与其包含块上边界之间的偏移。

语法：

Object.style.top=auto|%|length

可能的值

值 | 描述
auto | 默认。通过浏览器来计算顶部的位置。
% | 设置元素的顶部到最近一个具有定位设置父元素的上边缘的百分比位置。
length | 使用 px、cm 等单位设置元素的顶部到最近一个具有定位设置上边缘的顶部的位置。可使用负值。

提示和注释

注释：如果 "position" 属性的值为 "static"，那么设置 "top" 属性不会产生任何效果。

实例

本例设置元素的上边界：

<html>
<head>
<style type="text/css">
input
{
position:absolute;
}
</style>
<script type="text/javascript">
function setTopEdge()
{
document.getElementById("b1").style.top="100px";
}
</script>
</head>
<body>

<input type="button" id="b1" onclick="setTopEdge()"
value="Set top edge to 100 px" />

</body>
</html>

TIY

top - 设置元素的上边界

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM type 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM type 属性

返回 HTML DOM Anchor 对象参考手册

定义和用法

type 属性可设置或返回被链资源的 MIME 类型。

语法

anchorObject.type=type

实例

下面的例子可返回被链资源的 MIME 类型：

<html>
<body>

<p><a id="myAnchor" type="text/html"
href="http://www.w3school.com.cn">W3School.com.cn</a></p>

<script type="text/javascript">
x=document.getElementById("myAnchor");
document.write(x.type);
</script>

</body>
</html>

TIY

取得链接的 MIME 类型

返回 HTML DOM Anchor 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM type 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM type 属性

返回 HTML DOM Button 对象参考手册

定义和用法

type 属性可返回表单元素的类型。对于一个 Buttom 对象，则永远是 "button" 类型。

语法

buttonObject.type

实例

<html>
<head>
<script type="text/javascript">
function alertType()
{
alert(document.getElementById("myButton").type)
}
</script>
</head>

<body>
<form>
<button id="myButton" onClick="alertType()">
Click Me!</button>
</form>
</body>

</html>

TIY

提示按钮的 id 和 类型 + 禁用按钮

返回 HTML DOM Button 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM type 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM type 属性

返回 HTML DOM Button 对象参考手册

定义和用法

type 属性可返回表单元素的类型。Button 对象的类型始终是 "button"。

语法

buttonObject.type

实例

下面的例子将返回按钮的表单元素类型：

<html>
<head>
<script type="text/javascript">
function alertType()
{
alert(document.getElementById("myButton").type)
}
</script>
</head>

<body>
<form>
<input type="button" value="Click me!" id="myButton"
onclick="alertType()" />
</form>
</body>

</html>

TIY

提示按钮的 id、类型和值 + 禁用按钮

返回 HTML DOM Button 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM type 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM type 属性

返回 HTML DOM Checkbox 对象参考手册

定义和用法

type 属性可返回元素的表单类型。对于一个 checkbox 对象，该属性总是返回 "checkbox"。

语法

checkboxObject.type

实例

下面的例子返回了 checkbox 的表单元素类型：

<html>
<body>

<form>
<input type="checkbox" id="check1" />
</form>

<script type="text/javascript">
x=document.getElementById("check1");
document.write("Form element type is: ");
document.write(x.type);
</script>

</body>
</html>

TIY

获得 checkbox 的表单元素类型

返回 HTML DOM Checkbox 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Type 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Type 属性

返回 HTML DOM Hidden 对象参考手册

定义和用法

type 属性可返回表单元素的类型。对于 hidden 对象，该属性总是 "hidden"。

语法

hiddenObject.type

实例

下面的例子返回了该隐藏域的表单元素类型：

<html>
<body>

<form>
<input type="hidden" id="hidden1" />
</form>

<script type="text/javascript">
x=document.getElementById("hidden1");
document.write("Form element type is: ");
document.write(x.type);
</script>

</body>
</html>

TIY

取得隐藏域的表单元素类型

返回 HTML DOM Hidden 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM type 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM type 属性

返回 HTML DOM Password 对象参考手册

定义和用法

type 属性可设置表单元素的类型。对于密码域，该属性总是 "password"。

语法

passwordObject.type

实例

下面的例子返回了该密码域的表单元素类型：

<html>
<body>

<form>
<input type="password" id="password1" />
</form>

<script type="text/javascript">
x=document.getElementById("password1");
document.write("Form element type is: ");
document.write(x.type);
</script>

</body>
</html>

TIY

取得密码域的表单元素类型

返回 HTML DOM Password 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM type 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM type 属性

返回 HTML DOM Radio 对象参考手册

定义和用法

type 属性可返回单选按钮的表单元素类型。对于单选按钮，该属性总是 "radio"。

语法

radioObject.type

实例

下面的例子可返回单选按钮的表单元素类型：

<html>
<body>

<form>
<input type="radio" id="radio1" />
</form>

<script type="text/javascript">
x=document.getElementById("radio1");
document.write("Form element type is: ");
document.write(x.type);
</script>

</body>
</html>

TIY

取得单选按钮的表单元素类型

返回 HTML DOM Radio 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM type 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM type 属性

返回 HTML DOM Reset 对象参考手册

定义和用法

type 属性可返回重置按钮的表单元素类型。对于确认按钮，该属性总是 "reset"。

语法

resetObject.type

实例

下面的例子可返回重置按钮的表单元素类型：

<html>
<head>
<script type="text/javascript">
function alertType()
{
alert(document.getElementById("reset1").type)
}
</script>
</head>

<body>
<form>
<input type="reset" id="reset1" onclick="alertType()" />
</form>
</body>

</html>

TIY

提示重置按钮的 id、类型和值 + 禁用按钮

返回 HTML DOM Reset 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM type 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM type 属性

返回 HTML DOM Submit 对象参考手册

定义和用法

type 属性可返回确认按钮的表单元素类型。对于确认按钮，该属性总是 "submit"。

语法

submitObject.type

实例

下面的例子可返回确认按钮的表单元素类型：

<html>
<head>
<script type="text/javascript">
function alertType()
{
alert(document.getElementById("submit1").type)
}
</script>
</head>

<body>
<form>
<input type="submit" id="submit1" onclick="alertType()" />
</form>
</body>

</html>

TIY

提示确认按钮的 id、类型和值 + 禁用按钮

返回 HTML DOM Submit 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM type 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM type 属性

返回 HTML DOM Text 对象参考手册

定义和用法

type 属性返回文本域的表单元素类型。对于文本域，该属性总是返回 "text"。

语法

textObject.type

实例

下面的例子返回了文本域的表单元素类型：

<html>
<body>

<form>
<input type="text" id="text1" />
</form>

<script type="text/javascript">
x=document.getElementById("text1");
document.write("Form element type is: ");
document.write(x.type);
</script>

</body>
</html>

TIY

获得了文本域的表单元素类型

返回 HTML DOM Text 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM type 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM type 属性

返回 HTML DOM Link 对象参考手册

定义和用法

The type property sets or returns the MIME type of the target URL (like "text/css", "text/javascript", "image/gif", etc.).

语法

linkObject.type=MIME_type

实例

The following example returns the MIME type of the target URL:

<html>
<head>
<link rel="stylesheet" type="text/css"
id="style1" href="try_dom_link.css" />
</head>
<body>

<script type="text/javascript">
x=document.getElementById("style1");
document.write("MIME type: " + x.type);
</script>

</body>
</html>

TIY

Get the MIME type of a <link> element

返回 HTML DOM Link 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM type 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM type 属性

返回 HTML DOM Select 对象参考手册

定义和用法

type 属性可返回下拉列表的表单类型。对于下拉列表，类型总是 "select-one" 或 "select-multiple"。

语法

selectObject.type

实例

下面的例子返回下拉列表的表单类型：

<html>
<head>
<script type="text/javascript">
function getType()
  {
  alert(document.getElementById("mySelect").type)
  }
</script>
</head>
<body>

<form>
<select id="mySelect">
  <option>Apple</option>
  <option>Pear</option>
  <option>Banana</option>
  <option>Orange</option>
</select>
<input type="button" onclick="getType()"
value="Alert type of dropdown list">
</form>
</body>
</html>

TIY

取得下拉列表的类型

返回 HTML DOM Select 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM type 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM type 属性

返回 HTML DOM Textarea 对象参考手册

定义和用法

type 属性返回表单元素的类型。对于 text area，永远是 "textarea"。

语法

textareaObject.type

实例

本例返回 textarea 元素所属的表单类型：

<html>
<head>
<script type="text/javascript">
function alertType()
  {
  alert(document.getElementById('txt1').type);
  }
</script>
</head>
<body>

<textarea id="txt1">
Hello world....This is a text area
</textarea>
<br />
<input type="button" onclick="alertType()" value="Alert type" />

</body>
</html>

返回 HTML DOM Textarea 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM updateInterval 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM updateInterval 属性

返回 HTML DOM Screen 对象参考手册

定义和用法

updateInterval 属性可设置或返回屏幕的刷新率。

语法

screen.updateInterval=number

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>Update Interval: ")
document.write(screen.updateInterval + "</p>")
</script>
</body>

</html>

TIY

检测有关客户机的屏幕的细节

返回 HTML DOM Screen 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM URL 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM URL 属性

返回 HTML DOM Document 对象参考手册

定义和用法

URL 属性可返回当前文档的 URL。

语法

document.URL

说明

一般情况下，该属性的值与包含文档的 Window 的 location.href 属性相同。不过，在 URL 重定向发生的时候，这个 URL 属性保存了文档的实际 URL，而 location.href 保存了请求的 URL。

实例

<html>

<body>
The URL of this document is:
<script type="text/javascript">
document.write(document.URL)
</script>
</body>

</html>

TIY

返回当前文档的 URL

返回 HTML DOM Document 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM useMap 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM useMap 属性

返回 HTML DOM Image 对象参考手册

定义和用法

useMap 属性可设置或返回图像的 usemap 属性的值。

语法

imageObject.useMap=URL

实例

下面的例子可输出客户端图像映射的 usemap 属性的值：

<html>
<body>

<img id="planets" src="planets.gif"
width="145" height="126"
usemap="#planetmap" />

<map name="planetmap">
<area id="venus" shape="circle"
coords="124,58,8"
alt="The planet Venus"
href="venus.htm" />
</map>

<p>The value of the usemap attribute=
<script type="text/javascript">
x=document.getElementById('planets');
document.write(x.useMap);
</script>
</p>

</body>
</html>

TIY

返回客户端图像映射的 usemap 属性的值

返回 HTML DOM Image 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM userAgent 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM userAgent 属性

返回 HTML DOM Navigator 对象参考手册

定义和用法

userAgent 属性是一个只读的字符串，声明了浏览器用于 HTTP 请求的用户代理头的值。

一般来讲，它是在 navigator.appCodeName 的值之后加上斜线和 navigator.appVersion 的值构成的。

例如：Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; SV1; .NET CLR 1.1.4322)。

注：用户代理头：user-agent header。

语法

navigator.userAgent

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>UserAgent: ")
document.write(navigator.userAgent + "</p>")
</script>
</body>

</html>

TIY

检测访问者的浏览器和版本号
有关访问者的浏览器的更多信息
有关访问者的浏览器的全部细节
根据浏览器来提醒用户

返回 HTML DOM Navigator 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM userLanguage 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM userLanguage 属性

返回 HTML DOM Navigator 对象参考手册

定义和用法

userLanguage 属性可返回操作系统的自然语言设置。

语法

navigator.userLanguage

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>UserLanguage: ")
document.write(navigator.userLanguage + "</p>")
</script>
</body>

</html>

TIY

检测访问者的浏览器和版本号
有关访问者的浏览器的更多信息
有关访问者的浏览器的全部细节
根据浏览器来提醒用户

返回 HTML DOM Navigator 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM vAlign 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM vAlign 属性

返回 HTML DOM TableCell 对象参考手册

定义和用法

vAlign 属性设置或返回单元格内数据的垂直排列方式。

语法

tabledataObject.vAlign=top|middle|bottom|baseline

实例

下面的例子更改了单元格内数据的垂直排列方式：

<html>
<head>
<script type="text/javascript">
function topAlign()
  {
  document.getElementById('td1').vAlign="top";
  document.getElementById('td2').vAlign="top";
  document.getElementById('td3').vAlign="top";
  }
</script>
</head>
<body>

<table width="50%" border="1">
<tr>
<th>Firstname</th>
<th>Lastname</th>
<th>Text</th>
</tr>
<tr>
<td id="td1">Peter</td>
<td id="td2">Griffin</td>
<td id="td3">Hello my name is Peter Griffin.
I need a long text for this example.
I need a long text for this example.</td>
</tr>
</table>
<br />
<input type="button" onclick="topAlign()"
value="Top-align table cells" />

</body>
</html>

TIY

更改单元格内数据的垂直排列方式

返回 HTML DOM TableCell 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM vAlign 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM vAlign 属性

返回 HTML DOM Tablerow 对象参考手册

定义和用法

vAlign 属性设置或返回数据在行中的垂直对齐方式。

语法

tablerowObject.vAlign=top|bottom|middle|baseline

实例

下面的例子更改了数据在行中的垂直排列方式：

<html>
<head>
<script type="text/javascript">
function topAlign()
  {
  document.getElementById('tr2').vAlign="top";
  }
</script>
</head>
<body>

<table width="50%" border="1">
<tr id="tr1">
<th>Firstname</th>
<th>Lastname</th>
<th>Text</th>
</tr>
<tr id="tr2">
<td>Peter</td>
<td>Griffin</td>
<td>Hello my name is Peter Griffin.
I need a long text for this example.
I need a long text for this example.</td>
</tr>
</table>
<br />
<input type="button" onclick="topAlign()"
value="Top-align table row" />

</body>
</html>

TIY

垂直对齐行中的单元格内容

返回 HTML DOM Tablerow 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM value 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM value 属性

返回 HTML DOM Button 对象参考手册

定义和用法

value 属性设置或返回显示在按钮上的文本。

语法

buttonObject.value=value

实例

下面的例子可返回显示在按钮上的文本：

<html>
<body>

<input type="button" id="button1" name="button1" value="Click Me!" />

<p>The text on the button is:
<script type="text/javascript">
x=document.getElementById('button1');
document.write(x.value);
</script></p>

</body>
</html>

TIY

获取按钮上的文本

返回 HTML DOM Button 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM value 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM value 属性

返回 HTML DOM Button 对象参考手册

定义和用法

value 属性可设置或返回显示在按钮上的文本。

语法

buttonObject.value=sometext

实例

<html>
<head>
<script type="text/javascript">
function alertValue()
{
alert(document.getElementById("myButton").value)
}
</script>
</head>

<body>
<form>
<input type="button" value="Click me!" id="myButton"
onclick="alertValue()" />
</form>
</body>

</html>

TIY

提示按钮的 id、类型和值 + 禁用按钮

返回 HTML DOM Button 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM value 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM value 属性

返回 HTML DOM Hidden 对象参考手册

定义和用法

value 属性可设置或返回隐藏输入域的 value 属性的值。

value 属性定义了该隐藏域的默认值。

语法

hiddenObject.value

实例

下面的例子可取得该隐藏域的值：

<html>
<head>
<script type="text/javascript">
function alertValue()
  {
  alert(document.getElementById("hidden1").value)
  }
</script>
</head>
<body>

<form>
<input type="hidden" id="hidden1" value="W3School" />
<input type="button" id="button1" onclick="alertValue()"
value="Show value of the hidden field" />
</form>

</body>
</html>

TIY

取得隐藏域的值

返回 HTML DOM Hidden 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM value 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM value 属性

返回 HTML DOM Password 对象参考手册

定义和用法

value 属性可设置或返回密码域的默认值。

出于安全考虑，一些浏览器可能阻止 JavaScript 代码读取 value 属性。

语法

passwordObject.value=text

实例

下面的例子可获得密码域的默认值：

<html>
<head>
<script type="text/javascript">
function alertValue()
  {
  alert(document.getElementById("password1").value)
  }
</script>
</head>
<body>

<form>
<input type="password" id="password1" value="thgrt456" />
<input type="button" id="button1" onclick="alertValue()"
value="Show default value" />
</form>

</body>
</html>

TIY

获得密码域的默认值

返回 HTML DOM Password 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM value 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM value 属性

返回 HTML DOM Radio 对象参考手册

定义和用法

value 属性可设置或返回单选按钮的 value 属性的值。

语法

radioObject.value=sometext

实例

<html>
<head>
<script type="text/javascript">
function check(browser)
  {
  document.getElementById("answer").value=browser
  }
</script>
</head>

<body>
<p>What's your favorite browser:</p>
<form>
<input type="radio" name="browser" onclick="check(this.value)"
value="Internet Explorer" />Internet Explorer<br />
<input type="radio" name="browser" onclick="check(this.value)"
value="Firefox" />Firefox<br />
<input type="radio" name="browser" onclick="check(this.value)"
value="Netscape" />Netscape<br />
<input type="radio" name="browser" onclick="check(this.value)"
value="Opera" />Opera<br />
<br />
Your favorite browser is: <input type="text" id="answer" size="20" />
</form>
</body>

</html>

TIY

使用单选按钮中的 value 属性

返回 HTML DOM Radio 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM value 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM value 属性

返回 HTML DOM Reset 对象参考手册

定义和用法

value 属性可设置或返回显示在重置按钮上的文本。

语法

resetObject.value=sometext

实例

下面的例子可提示出显示在重置按钮上的文本：

<html>
<head>
<script type="text/javascript">
function alertValue()
{
alert(document.getElementById("reset1").value)
}
</script>
</head>

<body>
<form>
<input type="reset" value="Reset values" id="reset1"
onclick="alertValue()" />
</form>
</body>

</html>

TIY

提示重置按钮的 id、类型和值 + 禁用按钮

返回 HTML DOM Reset 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM value 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM value 属性

返回 HTML DOM Submit 对象参考手册

定义和用法

value 属性可设置或返回显示在确认按钮上的文本。

语法

submitObject.value=sometext

实例

下面的例子可提示出显示在确认按钮上的文本：

<html>
<head>
<script type="text/javascript">
function alertValue()
{
alert(document.getElementById("submit1").value)
}
</script>
</head>

<body>
<form>
<input type="submit" value="submit values" id="submit1"
onclick="alertValue()" />
</form>
</body>

</html>

TIY

提示确认按钮的 id、类型和值 + 禁用按钮

返回 HTML DOM Submit 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM value 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM value 属性

返回 HTML DOM Text 对象参考手册

定义和用法

value 属性设置或返回文本域的值。

语法

textObject.value=text

实例

下面的例子可获得文本域的值：

<html>
<head>
<script type="text/javascript">
function alertValue()
  {
  alert(document.getElementById("text1").value)
  }
</script>
</head>
<body>

<form>
<input type="text" id="text1" value="Hello world!" />
<input type="button" id="button1" onclick="alertValue()"
value="Show default value" />
</form>

</body>
</html>

TIY

获得文本域的值
表单验证
表单中的单选按钮
表单中的复选按钮
表单中的下拉列表
另一个下拉列表

返回 HTML DOM Text 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM value 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM value 属性

返回 HTML DOM Option 对象参考手册

定义和用法

value 属性可设置或返回选项的值。

当表单提交发生的时候，如果这个选项被选中，value 会和表单一起提交。映射 <option> 的 value 属性。

语法

optionObject.value=somevalue

实例

下面的例子可返回被选选项的文本：

<html>
<head>
<script type="text/javascript">
function alertValue()
  {
  var x=document.getElementById("mySelect").selectedIndex;
  alert(document.getElementsByTagName("option")[x].value);
  }
</script>
</head>
<body>

<form>
Select your favorite fruit:
<select id="mySelect">
  <option value="apple">Apple</option>
  <option value="orange">Orange</option>
  <option value="pineapple">Pineapple</option>
  <option value="banana">Banana</option>
</select>
<br /><br />
<input type="button" onclick="alertValue()" value="Alert selected value">
</form>

</body>
</html>

TIY

返回被选选项的文本

返回 HTML DOM Option 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM value 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM value 属性

返回 HTML DOM Textarea 对象参考手册

定义和用法

value 属性设置或返回 textarea 的文本。

语法

textareaObject.value=text

实例

本例返回 textarea 元素的文本：

<html>
<head>
<script type="text/javascript">
function alertValue()
  {
  alert(document.getElementById('txt1').value);
  }
</script>
</head>
<body>

<textarea id="txt1">
Hello world....This is a text area
</textarea>
<br />
<input type="button" onclick="alertValue()" value="Alert value" />

</body>
</html>

返回 HTML DOM Textarea 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM verticalAlign 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM verticalAlign 属性

返回HTML DOM Style 对象参考手册

定义和用法

verticalAlign 属性设置内容在元素框中的垂直对齐方式。

语法：

Object.style.verticalAlign=value

可能的值

值 | 描述
baseline | 默认。元素放置在父元素的基线上。
sub | 垂直对齐文本的下标。
super | 垂直对齐文本的上标
top | 把元素的顶端与行中最高元素的顶端对齐
text-top | 把元素的顶端与父元素字体的顶端对齐
middle | 把此元素放置在父元素的中部。
bottom | 把元素的顶端与行中最低的元素的顶端对齐。
text-bottom | 把元素的底端与父元素字体的底端对齐。
length |
% | 使用 "line-height" 属性的百分比值来排列此元素。允许使用负值。

实例

本例设置表格中文本的垂直对齐方式：

<html>
<head>
<script type="text/javascript">
function alignText()
{
document.getElementById("td1").style.verticalAlign="bottom";
}
</script>
</head>
<body>

<table border="1" height="100px">
  <tr>
    <td id="td1">
    Some example text
    </td>
  </tr>
</table>
<br />
<input type="button" onclick="alignText()"
value="Align text" />

</body>
</html>

TIY

verticalAlign - 垂直对齐表格中的文本

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM visibility 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM visibility 属性

返回HTML DOM Style 对象参考手册

定义和用法

visibility 属性设置元素是否可见。

语法：

Object.style.visibility=visible|hidden|collapse

可能的值

值 | 描述
visible | 默认。元素框是可见的。
hidden | 元素框不可见，但仍然影响布局。
collapse | 当在表格元素中使用时，此值可删除一行或一列，但是它不会影响表格的布局。被行或列占据的空间会留给其他内容使用。如果此值被用在其他的元素上，会呈现为 "hidden"。

实例

下面的例子隐藏一段文本：

<html>
<head>
<script type="text/javascript">
function changeVisibility()
{
document.getElementById("p1").style.visibility="hidden";
}
</script>

</head>
<body>

<p id="p1">This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.</p>

<form>
<input type="button" onclick="changeVisibility()"
value="Hide paragraph" />
</form>

</body>
</html>

TIY

visibility - 隐藏一段文本

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM vspace 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM vspace 属性

返回 HTML DOM Image 对象参考手册

定义和用法

vspace 属性设置或返回图像的顶部和底部的空白。

Thspace 和 vspace 属性可与 align 一同使用，来设置图像与周围文本的距离。

语法

imageObject.vspace=pixels

实例

下面的例子将设置图像的 hspace 和 vspace 属性：

<html>
<head>
<script type="text/javascript">
function setSpace()
{
document.getElementById("compman").hspace="50"
document.getElementById("compman").vspace="50"
}
</script>
</head>
<body>

<img id="compman" src="compman.gif" alt="Computerman" align="right" />

<p>Some text. Some text. Some text. Some text.</p>

<input type="button" onclick="setSpace()"
value="Set hspace and vspace">

</body>
</html>

TIY

设置图像的水平和垂直定位

返回 HTML DOM Image 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM whiteSpace 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM whiteSpace 属性

返回HTML DOM Style 对象参考手册

定义和用法

whiteSpace 属性设置如何处理文本中的空白符（比如空格和换行符）。

语法：

Object.style.whiteSpace=normal|nowrap|pre

可能的值

值 | 描述
normal | 默认。空白会被浏览器忽略。
pre | 空白会被浏览器保留。其行为方式类似 HTML 中的 <pre> 标签。
nowrap | 文本不会换行，文本会在在同一行上继续，直到遇到 <br> 标签为止。

实例

本例不允许在文本内换行：

<html>
<head>
<script type="text/javascript">
function removeWrapping()
{
document.getElementById("div1").style.whiteSpace="nowrap";
}
</script>
</head>
<body>

<div id="div1">
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
This is some text. This is some text. This is some text.
</div>
<br />
<input type="button" onclick="removeWrapping()"
value="Do not let the text wrap" />

</body>
</html>

TIY

whiteSpace - 不允许在文本内换行

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM width 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM width 属性

返回 HTML DOM Screen 对象参考手册

定义和用法

width 属性声明了显示浏览器的屏幕的宽度，以像素计。

语法

screen.width

实例

<html>

<body>
<script type="text/javascript">
document.write("<p>Width: ")
document.write(screen.width + "</p>")
</script>
</body>

</html>

TIY

检测有关客户机的屏幕的细节

返回 HTML DOM Screen 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM width 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM width 属性

返回 HTML DOM Iframe 对象参考手册

定义和用法

width 属性可设置或返回 iframe 的宽度（以像素或百分比为单位）。

语法

iframeObject.width=pixels

实例

下面的例子可更改 iframe 的宽度：

<html>
<head>
<script type="text/javascript">
function changeWidth()
{
document.getElementById("frame1").width="100";
}
</script>
</head>
<body>

<iframe src="frame_a.htm" id="frame1" width="200"></iframe>
<br /><br />

<input type="button" onclick="changeWidth()"
value="Change size" />

</body>
</html>

TIY

更改 iframe 的高度和宽度

返回 HTML DOM Iframe 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM width 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM width 属性

返回 HTML DOM Image 对象参考手册

定义和用法

width 属性可设置或返回图像的宽度。

语法

imageObject.width=pixels

实例

下面的例子可设置图像的高度和宽度：

<html>
<head>
<script type="text/javascript">
function changeSize()
{
document.getElementById("compman").height="250"
document.getElementById("compman").width="300"
}
</script>
</head>

<body>
<img id="compman" src="compman.gif" width="107" height="98" />
<br /><br />
<input type="button" onclick="changeSize()"
value="Change size of image">
</body>

</html>

TIY

更改图像的高度和宽度

返回 HTML DOM Image 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM width 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM width 属性

返回 HTML DOM Table 对象参考手册

定义和用法

width 属性可设置或返回表格的宽度。

语法

tableObject.width=percent|pixels

实例

下面的例子可更改表格的宽度：

<html>
<head>
<script type="text/javascript">
function changeWidth()
  {
  document.getElementById("table1").width="100%";
  }
</script>
</head>
<body>

<table id="table1" border="1">
<thead>
<tr>
<th>Firstname</th>
<th>Lastname</th>
</tr>
<tr>
<td>Peter</td>
<td>Griffin</td>
</tr>
</table>
<br />
<input type="button" onclick=changeWidth()
value="Change table width" />
</body>
</html>

TIY

更改表格的宽度

返回 HTML DOM Table 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM width 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM width 属性

返回HTML DOM Style 对象参考手册

定义和用法

width 属性设置元素的宽度。

语法：

Object.style.width=auto|length|%

可能的值

值 | 描述
auto | 默认。浏览器可计算出实际的宽度。
% | 定义基于其包含块的百分比宽度。
length | 使用 px、cm 等单位定义宽度。

实例

本例设置按钮的宽度：

<html>
<head>
<script type="text/javascript">
function setWidth()
{
document.getElementById("b1").style.width="300px";
}
</script>
</head>
<body>

<input type="button" id="b1" onclick="setWidth()"
value="Change width to 300 px" />

</body>
</html>

TIY

width - 设置元素的宽度

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM width 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM width 属性

返回 HTML DOM TableCell 对象参考手册

定义和用法

width 属性设置或返回表元的宽度。

注释：整个列都会受到影响。

语法

tabledataObject.width=percent|pixels

实例

下面的例子更改了表元的宽度：

<html>
<head>
<script type="text/javascript">
function changeWidth()
  {
  document.getElementById("td1").width="200px";
  }
</script>
</head>
<body>

<table border="1">
<tr>
<th>Firstname</th>
<th>Lastname</th>
</tr>
<tr>
<td id="td1">Peter</td>
<td id="td2">Griffin</td>
</tr>
</table>
<br />
<input type="button" onclick=changeWidth() value="Change width" />

</body>
</html>

TIY

更改表元的宽度

返回 HTML DOM TableCell 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM Window 对象

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM Window 对象

Window 对象

Window 对象是 JavaScript 层级中的顶层对象。

Window 对象代表一个浏览器窗口或一个框架。

Window 对象会在 <body> 或 <frameset> 每次出现时被自动创建。

有关 Window 对象的详细描述。

IE: Internet Explorer, F: Firefox, O: Opera.

Window 对象的集合

Collection | Description | IE | F | O
frames[] | 返回窗口中所有命名的框架。该集合是 Window 对象的数组，每个 Window 对象在窗口中含有一个框架或 <iframe>。属性 frames.length 存放数组 frames[] 中含有的元素个数。注意，frames[] 数组中引用的框架可能还包括框架，它们自己也具有 frames[] 数组。 | 4 | 1 | 9

Window 对象的属性

属性 | 描述 | IE | F | O
closed | 返回窗口是否已被关闭。 | 4 | 1 | 9
defaultStatus | 设置或返回窗口状态栏中的默认文本。 | 4 | No | 9
document | 对 Document 对象的只读引用。请参阅 Document 对象。 | 4 | 1 | 9
history | 对 History 对象的只读引用。请参数 History 对象。 | 4 | 1 | 9
innerheight | 返回窗口的文档显示区的高度。 | No | No | No
innerwidth | 返回窗口的文档显示区的宽度。 | No | No | No
length | 设置或返回窗口中的框架数量。 | 4 | 1 | 9
location | 用于窗口或框架的 Location 对象。请参阅 Location 对象。 | 4 | 1 | 9
name | 设置或返回窗口的名称。 | 4 | 1 | 9
Navigator | 对 Navigator 对象的只读引用。请参数 Navigator 对象。 | 4 | 1 | 9
opener | 返回对创建此窗口的窗口的引用。 | 4 | 1 | 9
outerheight | 返回窗口的外部高度。 | No | No | No
outerwidth | 返回窗口的外部宽度。 | No | No | No
pageXOffset | 设置或返回当前页面相对于窗口显示区左上角的 X 位置。 | No | No | No
pageYOffset | 设置或返回当前页面相对于窗口显示区左上角的 Y 位置。 | No | No | No
parent | 返回父窗口。 | 4 | 1 | 9
Screen | 对 Screen 对象的只读引用。请参数 Screen 对象。 | 4 | 1 | 9
self | 返回对当前窗口的引用。等价于 Window 属性。 | 4 | 1 | 9
status | 设置窗口状态栏的文本。 | 4 | No | 9
top | 返回最顶层的先辈窗口。 | 4 | 1 | 9
window | window 属性等价于 self 属性，它包含了对窗口自身的引用。 | 4 | 1 | 9
  • screenLeft
  • screenTop
  • screenX
  • screenY
 只读整数。声明了窗口的左上角在屏幕上的的 x 坐标和 y 坐标。IE、Safari 和 Opera 支持 screenLeft 和 screenTop，而 Firefox 和 Safari 支持 screenX 和 screenY。 4 1 9

Window 对象的方法

方法 | 描述 | IE | F | O
alert() | 显示带有一段消息和一个确认按钮的警告框。 | 4 | 1 | 9
blur() | 把键盘焦点从顶层窗口移开。 | 4 | 1 | 9
clearInterval() | 取消由 setInterval() 设置的 timeout。 | 4 | 1 | 9
clearTimeout() | 取消由 setTimeout() 方法设置的 timeout。 | 4 | 1 | 9
close() | 关闭浏览器窗口。 | 4 | 1 | 9
confirm() | 显示带有一段消息以及确认按钮和取消按钮的对话框。 | 4 | 1 | 9
createPopup() | 创建一个 pop-up 窗口。 | 4 | No | No
focus() | 把键盘焦点给予一个窗口。 | 4 | 1 | 9
moveBy() | 可相对窗口的当前坐标把它移动指定的像素。 | 4 | 1 | 9
moveTo() | 把窗口的左上角移动到一个指定的坐标。 | 4 | 1 | 9
open() | 打开一个新的浏览器窗口或查找一个已命名的窗口。 | 4 | 1 | 9
print() | 打印当前窗口的内容。 | 5 | 1 | 9
prompt() | 显示可提示用户输入的对话框。 | 4 | 1 | 9
resizeBy() | 按照指定的像素调整窗口的大小。 | 4 | 1 | 9
resizeTo() | 把窗口的大小调整到指定的宽度和高度。 | 4 | 1.5 | 9
scrollBy() | 按照指定的像素值来滚动内容。 | 4 | 1 | 9
scrollTo() | 把内容滚动到指定的坐标。 | 4 | 1 | 9
setInterval() | 按照指定的周期（以毫秒计）来调用函数或计算表达式。 | 4 | 1 | 9
setTimeout() | 在指定的毫秒数后调用函数或计算表达式。 | 4 | 1 | 9

Window 对象的描述

Window 对象表示一个浏览器窗口或一个框架。在客户端 JavaScript 中，Window 对象是全局对象，所有的表达式都在当前的环境中计算。也就是说，要引用当前窗口根本不需要特殊的语法，可以把那个窗口的属性作为全局变量来使用。例如，可以只写 document，而不必写 window.document。

同样，可以把当前窗口对象的方法当作函数来使用，如只写 alert()，而不必写 Window.alert()。

除了上面列出的属性和方法，Windos 对象还实现了核心 JavaScript 所定义的所有全局属性和方法。

Window 对象的 window 属性和 self 属性引用的都是它自己。当你想明确地引用当前窗口，而不仅仅是隐式地引用它时，可以使用这两个属性。除了这两个属性之外，parent 属性、top 属性以及 frame[] 数组都引用了与当前 Window 对象相关的其他 Window 对象。

要引用窗口中的一个框架，可以使用如下语法：

frame[i]		//当前窗口的框架
self.frame[i]	//当前窗口的框架
w.frame[i]	//窗口 w 的框架

要引用一个框架的父窗口（或父框架），可以使用下面的语法：

parent		//当前窗口的父窗口
self.parent	//当前窗口的父窗口
w.parent 		//窗口 w 的父窗口

要从顶层窗口含有的任何一个框架中引用它，可以使用如下语法：

top		//当前框架的顶层窗口
self.top		//当前框架的顶层窗口
f.top		//框架 f 的顶层窗口

新的顶层浏览器窗口由方法 Window.open() 创建。当调用该方法时，应把 open() 调用的返回值存储在一个变量中，然后使用那个变量来引用新窗口。新窗口的 opener 属性反过来引用了打开它的那个窗口。

一般来说，Window 对象的方法都是对浏览器窗口或框架进行某种操作。而 alert() 方法、confirm() 方法和 prompt 方法则不同，它们通过简单的对话框与用户进行交互。

HTML DOM 参考手册
HTML DOM 实例


HTML DOM wordSpacing 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM wordSpacing 属性

返回HTML DOM Style 对象参考手册

定义和用法

wordSpacing 属性设置文本中的单词间距。

语法：

Object.style.wordSpacing=normal|length

可能的值

值 | 描述
normal | 默认。定义单词间的标准空间。
length | 定义单词间的固定空间。

实例

本例改变单词间的间距：

<html>
<head>
<script type="text/javascript">
function changeWordSpacing()
{
document.getElementById("p1").style.wordSpacing="10px";
}
</script>
</head>
<body>

<p id="p1">This is an example paragraph</p>

<input type="button" onclick="changeWordSpacing()"
value="Change space between words" />

</body>
</html>

TIY

wordSpacing - 改变单词间的间距

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM write() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM write() 方法

返回 HTML DOM Document 对象参考手册

定义和用法

write() 方法可向文档写入 HTML 表达式或 JavaScript 代码。

可列出多个参数(exp1,exp2,exp3,...) ，它们将按顺序被追加到文档中。

语法

document.write(exp1,exp2,exp3,....)

说明

虽然根据 DOM 标准，该方法只接受单个字符串作为参数。不过根据经验，write() 可接受任何多个参数。

我们通常按照两种的方式使用 write() 方法：一是在使用该方在文档中输出 HTML，另一种是在调用该方法的的窗口之外的窗口、框架中产生新文档。在第二种情况中，请务必使用 close() 方法来关闭文档。

实例

<html>
<body>

<script type="text/javascript">
document.write("Hello World!");
</script>

</body>
</html>

TIY

使用 document.write() 向输出流写文本
使用 document.write() 向输出流写 HTML
使用多参数的 document.write()

返回 HTML DOM Document 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM writeln() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM writeln() 方法

返回 HTML DOM Document 对象参考手册

定义和用法

writeln() 方法与 write() 方法作用相同，外加可在每个表达式后写一个换行符。

语法

document.writeln(exp1,exp2,exp3,....)

提示和注释

提示：在编写 <pre> 标记的内容时，该方法很有用。

实例

<html>
<body>

<script type="text/javascript">
document.writeln("Hello World!");
</script>

</body>
</html>

TIY

使用 document.write() 向输出流写文本
使用 document.write() 向输出流写 HTML
使用多参数的 document.write()

返回 HTML DOM Document 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM zIndex 属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM zIndex 属性

返回HTML DOM Style 对象参考手册

定义和用法

zIndex 属性设置元素的堆叠顺序。

该属性设置一个定位元素沿 z 轴的位置，z 轴定义为垂直延伸到显示区的轴。如果为正数，则离用户更近，为负数则表示离用户更远。

语法：

Object.style.zIndex=auto|number

可能的值

值 | 描述
auto | 默认。堆叠顺序与父元素相等。
number | 设置元素的堆叠顺序。

提示和注释

注释：元素可拥有负的 z-index 属性值。

注释：Z-index 仅能在定位元素上奏效（例如 position:absolute;）！

实例

本例改变元素的堆叠顺序：

<html>
<head>
<style type="text/css">
#img1
{
position:absolute;
left:0px;
top:0px;
z-index:-1
}
</style>
<script type="text/javascript">
function changeStackOrder()
{
document.getElementById("img1").style.zIndex="1";
}
</script>
</head>
<body>

<h1>This is a Heading</h1>

<img id="img1" src="bulbon.gif" width="100" height="180">

<p>Default z-index is 0. Z-index -1 has lower priority.</p>

<input type="button" onclick="changeStackOrder()"
value="Change stack order" />

</body>
</html>

TIY

zIndex - 改变元素的堆叠顺序

返回HTML DOM Style 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


HTML DOM 参考手册

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM 参考手册

  • Previous Page
  • Next Page

JavaScript 对象

点击以下链接，可以获得以下对象的更多信息，包括它们的集合、属性、方法以及事件。其中包含大量实例！

对象 | 描述
Window | JavaScript 层级中的顶层对象。Windows 对象会呈现 (represent) 一个浏览器窗口。每当 <body> 或者 <frameset> 标签出现，Window 对象就会被自动创建。
Navigator | 包含客户端浏览器的信息。
Screen | 包含客户端显示屏的信息。
History | 包含了浏览器窗口访问过的 URL。
Location | 包含了当前 URL 的信息。

HTML DOM 对象

请点击下面的链接，学习更多有关对象及其集合、属性、方法和事件的知识。其中包含大量实例！

对象 | 描述
Document | 代表整个 HTML 文档，可被用来访问页面中的所有元素
Anchor | 代表一个 <a> 元素
Area | 代表一个图像地图中的 <area> 元素
Base | 代表 <base> 元素
Body | 代表 <body> 元素
Button | 代表 <button> 元素
Event | 代表某个事件的状态
Form | 代表 <form> 元素
Frame | 代表一个 <frame> 元素
Frameset | 代表一个 <frameset> 元素
Iframe | 代表一个 <iframe> 元素
Image | 代表一个 <img> 元素
Input button | 代表 HTML 表单中的一个按钮
Input checkbox | 代表 HTML 表单中的一个复选框
Input file | 代表 HTML 表单中的一个文件上传
Input hidden | 代表 HTML 表单中的一个隐藏域
Input password | 代表 HTML 表单中的一个密码域
Input radio | 代表 HTML 表单中的一个单选按钮
Input reset | 代表 HTML 表单中的一个重置按钮
Input submit | 代表 HTML 表单中的一个确认按钮
Input text | 代表 HTML 表单中的一个文本输入域（文本框）
Link | 代表一个 <link> 元素
Meta | 代表一个 <meta> 元素
Object | 代表一个 <Object> 元素
Option | 代表一个 <option> 元素
Select | 代表 HTML 表单中的一个选择列表
Style | 代表一个单独的样式声明
Table | 代表一个 <table> 元素
TableData | 代表一个 <td> 元素
TableRow | 代表一个 <tr> 元素
Textarea | 代表一个 <textarea> 元素
  • Previous Page
  • Next Page

HTML DOM 参考手册
HTML DOM 实例


HTML DOM 访问节点

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM 访问节点

  • Previous Page
  • Next Page

通过 DOM，您可访问 HTML 文档中的每个节点。

查找并访问节点

你可通过若干种方法来查找您希望操作的元素：

  • 通过使用 getElementById() 和 getElementsByTagName() 方法
  • 通过使用一个元素节点的 parentNode、firstChild 以及 lastChild 属性

getElementById() 和 getElementsByTagName()

getElementById() 和 getElementsByTagName() 这两种方法，可查找整个 HTML 文档中的任何 HTML 元素。

这两种方法会忽略文档的结构。假如您希望查找文档中所有的 <p> 元素，getElementsByTagName() 会把它们全部找到，不管 <p> 元素处于文档中的哪个层次。同时，getElementById() 方法也会返回正确的元素，不论它被隐藏在文档结构中的什么位置。

这两种方法会像您提供任何你所需要的 HTML 元素，不论它们在文档中所处的位置！

getElementById() 可通过指定的 ID 来返回元素：

getElementById() 语法

document.getElementById("ID");

注释：getElementById() 无法工作在 XML 中。在 XML 文档中，您必须通过拥有类型 id 的属性来进行搜索，而此类型必须在 XML DTD 中进行声明。

getElementsByTagName() 方法会使用指定的标签名返回所有的元素（作为一个节点列表），这些元素是您在使用此方法时所处的元素的后代。

getElementsByTagName() 可被用于任何的 HTML 元素：

getElementsByTagName() 语法

document.getElementsByTagName("标签名称");

或者：

document.getElementById('ID').getElementsByTagName("标签名称");

实例 1

下面这个例子会返回文档中所有 <p> 元素的一个节点列表：

document.getElementsByTagName("p");

实例 2

下面这个例子会返回所有 <p> 元素的一个节点列表，且这些 <p> 元素必须是 id 为 "maindiv" 的元素的后代：

document.getElementById('maindiv').getElementsByTagName("p");

节点列表（nodeList）

当我们使用节点列表时，通常要把此列表保存在一个变量中，就像这样：

var x=document.getElementsByTagName("p");

现在，变量 x 包含着页面中所有 <p> 元素的一个列表，并且我们可以通过它们的索引号来访问这些 <p> 元素。

注释：索引号从 0 开始。

您可以通过使用 length 属性来循环遍历节点列表：

var x=document.getElementsByTagName("p");
for (var i=0;i<x.length;i++)
  {
  // do something with each paragraph
  }

您也可以通过索引号来访问某个具体的元素。

要访问第三个 <p> 元素，您可以这么写：

var y=x[2];

parentNode、firstChild以及lastChild

这三个属性 parentNode、firstChild 以及 lastChild 可遵循文档的结构，在文档中进行“短距离的旅行”。

请看下面这个 HTML 片段：

<table>
  <tr>
    <td>John</td>
    <td>Doe</td>
    <td>Alaska</td>
  </tr>
</table>

在上面的HTML代码中，第一个 <td> 是 <tr> 元素的首个子元素（firstChild），而最后一个 <td> 是 <tr>元素的最后一个子元素（lastChild）。

此外，<tr> 是每个 <td>元 素的父节点（parentNode）。

对 firstChild 最普遍的用法是访问某个元素的文本：

var x=[a paragraph];
var text=x.firstChild.nodeValue;

parentNode 属性常被用来改变文档的结构。假设您希望从文档中删除带有 id 为 "maindiv" 的节点：

var x=document.getElementById("maindiv");
x.parentNode.removeChild(x);

首先，您需要找到带有指定 id 的节点，然后移至其父节点并执行 removeChild() 方法。

根节点

有两种特殊的文档属性可用来访问根节点：

  • document.documentElement
  • document.body

第一个属性可返回存在于 XML 以及 HTML 文档中的文档根节点。

第二个属性是对 HTML 页面的特殊扩展，提供了对 <body> 标签的直接访问。

  • Previous Page
  • Next Page

HTML DOM 参考手册
HTML DOM 实例


HTML DOM 简介

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM 简介

  • Previous Page
  • Next Page

HTML 文档对象模型（HTML Document Object Model）定义了访问和处理 HTML 文档的标准方法。

您应当具备的基础知识

在继续学习之前，您需要对下面的知识有基本的了解：

  • HTML / XHTML
  • JavaScript

如果您希望首先学习这些项目，请在我们的首页访问这些教程。

什么是 DOM？

通过 JavaScript，您可以重构整个 HTML 文档。您可以添加、移除、改变或重排页面上的项目。

要改变页面的某个东西，JavaScript 就需要对 HTML 文档中所有元素进行访问的入口。这个入口，连同对 HTML 元素进行添加、移动、改变或移除的方法和属性，都是通过文档对象模型来获得的（DOM）。

在 1998 年，W3C 发布了第一级的 DOM 规范。这个规范允许访问和操作 HTML 页面中的每一个单独的元素。

所有的浏览器都执行了这个标准，因此，DOM 的兼容性问题也几乎难觅踪影了。

DOM 可被 JavaScript 用来读取、改变 HTML、XHTML 以及 XML 文档。

DOM 被分为不同的部分（核心、XML及HTML）和级别（DOM Level 1/2/3）：

Core DOM
定义了一套标准的针对任何结构化文档的对象
XML DOM
定义了一套标准的针对 XML 文档的对象
HTML DOM
定义了一套标准的针对 HTML 文档的对象。

您可以在我们的《W3C教程》阅读更多有关 W3C DOM 规范/级别的信息。

  • Previous Page
  • Next Page

HTML DOM 参考手册
HTML DOM 实例


HTML DOM 教程

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM 教程

  • Next Page

HTML DOM 定义了访问和操作HTML文档的标准方法。

HTML DOM 把 HTML 文档呈现为带有元素、属性和文本的树结构（节点树）。

开始学习 HTML DOM！

DOM HTML TREE

HTML DOM 实例

学习 100 个实例！使用我们的编辑器，你可以编辑 HTML 文档，然后单击 TIY 按钮来查看结果。

HTML DOM 实例

HTML DOM 参考手册

在 W3School，我们为您准备了完整的 HTML DOM 参考手册。

HTML DOM 参考手册

  • Next Page

HTML DOM 参考手册
HTML DOM 实例


HTML DOM 节点

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM 节点

  • Previous Page
  • Next Page

HTML 文档中的每个成分都是一个节点。

节点

根据 DOM，HTML 文档中的每个成分都是一个节点。

DOM 是这样规定的：

  • 整个文档是一个文档节点
  • 每个 HTML 标签是一个元素节点
  • 包含在 HTML 元素中的文本是文本节点
  • 每一个 HTML 属性是一个属性节点
  • 注释属于注释节点

Node 层次

节点彼此都有等级关系。

HTML 文档中的所有节点组成了一个文档树（或节点树）。HTML 文档中的每个元素、属性、文本等都代表着树中的一个节点。树起始于文档节点，并由此继续伸出枝条，直到处于这棵树最低级别的所有文本节点为止。

下面这个图片表示一个文档树（节点树）：

  • Previous Page
  • Next Page

HTML DOM 参考手册
HTML DOM 实例


HTML DOM 节点树

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM 节点树

  • Previous Page
  • Next Page

一棵节点树中的所有节点彼此都是有关系的。

文档树（节点数）

请看下面这个HTML文档：

<html>
  <head>
    <title>DOM Tutorial</title>
  </head>
  <body>
    <h1>DOM Lesson one</h1>
    <p>Hello world!</p>
  </body>
</html>

上面所有的节点彼此间都存在关系。

除文档节点之外的每个节点都有父节点。举例，<head> 和 <body> 的父节点是 <html> 节点，文本节点 "Hello world!" 的父节点是 <p> 节点。

大部分元素节点都有子节点。比方说，<head> 节点有一个子节点：<title> 节点。<title> 节点也有一个子节点：文本节点 "DOM Tutorial"。

当节点分享同一个父节点时，它们就是同辈（同级节点）。比方说，<h1> 和 <p>是同辈，因为它们的父节点均是 <body> 节点。

节点也可以拥有后代，后代指某个节点的所有子节点，或者这些子节点的子节点，以此类推。比方说，所有的文本节点都是 <html>节点的后代，而第一个文本节点是 <head> 节点的后代。

节点也可以拥有先辈。先辈是某个节点的父节点，或者父节点的父节点，以此类推。比方说，所有的文本节点都可把 <html> 节点作为先辈节点。

  • Previous Page
  • Next Page

HTML DOM 参考手册
HTML DOM 实例


HTML DOM 节点信息

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML DOM 节点信息

  • Previous Page
  • Next Page

nodeName、nodeValue 以及 nodeType 包含有关于节点的信息。

节点信息

每个节点都拥有包含着关于节点某些信息的属性。这些属性是：

  • nodeName（节点名称）
  • nodeValue（节点值）
  • nodeType（节点类型）

nodeName

nodeName 属性含有某个节点的名称。

  • 元素节点的 nodeName 是标签名称
  • 属性节点的 nodeName 是属性名称
  • 文本节点的 nodeName 永远是 #text
  • 文档节点的 nodeName 永远是 #document

注释：nodeName 所包含的 XML 元素的标签名称永远是大写的

nodeValue

对于文本节点，nodeValue 属性包含文本。

对于属性节点，nodeValue 属性包含属性值。

nodeValue 属性对于文档节点和元素节点是不可用的。

nodeType

nodeType 属性可返回节点的类型。

最重要的节点类型是：

元素类型 | 节点类型
元素 | 1
属性 | 2
文本 | 3
注释 | 8
文档 | 9
  • Previous Page
  • Next Page

HTML DOM 参考手册
HTML DOM 实例


initEvent() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

initEvent() 方法

返回 Event 对象参考手册

定义和用法

初始化新事件对象的属性

语法

event.initEvent(eventType,canBubble,cancelable)
参数 | 描述
eventType | 字符串值。事件的类型。
canBubble | 事件是否起泡。
cancelable | 是否可以用 preventDefault() 方法取消事件。

说明

该方法将初始化 Document.createEvent() 方法创建的合成 Event 对象的 type 属性、bubbles 属性和 cancelable 属性。只有在新创建的 Event 对象被 Document 对象或 Element 对象的 dispatchEvent() 方法分派之前，才能调用 Event.initEvent() 方法。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


metaKey 事件属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

metaKey 事件属性

返回 Event 对象参考手册

定义和用法

metaKey 事件属性可返回一个布尔值，指示当事件发生时，"meta" 键是否被按下并保持住。

语法

event.metaKey

实例

下面的例子可提示当鼠标按键被点击时 "meta" 键是否被按住：

<html>
<head>
<script type="text/javascript">
function isKeyPressed(event)
{
  if (event.metaKey==1)
    {
    alert("The meta key was pressed!")
    }
  else
    {
    alert("The meta key was NOT pressed!")
    }
  }
</script>
</head>

<body onmousedown="isKeyPressed(event)">

<p>Click somewhere in the document.
An alert box will tell you if you
pressed the meta key or not.</p>

</body>
</html>

TIY

metakey
检测 meta 键是否被按住（不支持 IE）。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


onabort 事件

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

onabort 事件

返回 Event 对象参考手册

定义和用法

onabort 事件会在图像加载被中断时发生。

当用户在图像完成载入之前放弃图像的装载（如单击了 stop 按钮）时，就会调用该句柄。

语法

onabort="SomeJavaScriptCode"
参数 | 描述
SomeJavaScriptCode | 必需。规定该事件发生时执行的 JavaScript。

支持该事件的 HTML 标签：

<img>

支持该事件的 JavaScript 对象：

image

实例 1

在本例中，如果图像的加载被中断，则会显示一个对话框：

<img src="image_w3default.gif"
onabort="alert('Error: Loading of the image was aborted')" />

实例 2

在本例中，如果图像的加载中断，我们将调用一个函数：

<html>
<head>
<script type="text/javascript">
function abortImage()
{
alert('Error: Loading of the image was aborted')
}
</script>
</head>

<body>
<img src="image_w3default.gif" onabort="abortImage()" />
</body>

</html>

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


onblur 事件

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

onblur 事件

返回 Event 对象参考手册

定义和用法

onblur 事件会在对象失去焦点时发生。

语法

onblur="SomeJavaScriptCode"
参数 | 描述
SomeJavaScriptCode | 必需。规定该事件发生时执行的 JavaScript。

支持该事件的 HTML 标签：

<a>, <acronym>, <address>, <area>, <b>, <bdo>, <big>, <blockquote>,
<button>, <caption>, <cite>, <dd>, <del>, <dfn>, <div>, <dl>, <dt>,
<em>, <fieldset>, <form>, <frame>, <frameset>, <h1> to <h6>, <hr>, <i>,
<iframe>, <img>, <input>, <ins>, <kbd>, <label>, <legend>, <li>,
<object>, <ol>, <p>, <pre>, <q>, <samp>, <select>, <small>, <span>,
<strong>, <sub>, <sup>, <table>, <tbody>, <td>, <textarea>, <tfoot>,
<th>, <thead>, <tr>, <tt>, <ul>, <var>

支持该事件的 JavaScript 对象：

button, checkbox, fileUpload, layer, frame, password,
radio, reset, submit, text, textarea, window

实例 1

在本例中，我们将在用户离开输入框时执行 JavaScript 代码：

<html>
<head>
<script type="text/javascript">
function upperCase()
{
var x=document.getElementById("fname").value
document.getElementById("fname").value=x.toUpperCase()
}
</script>
</head>

<body>

输入您的姓名：
<input type="text" id="fname" onblur="upperCase()" />

</body>
</html>

输出：

输入您的姓名：

TIY

onblur
如何使用 onblur 事件在用户离开输入框时执行 JavaScript 代码

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


onblur 事件

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

onblur 事件

返回 Event 对象参考手册

定义和用法

onchange 事件会在域的内容改变时发生。

语法

onchange="SomeJavaScriptCode"
参数 | 描述
SomeJavaScriptCode | 必需。规定该事件发生时执行的 JavaScript。

支持该事件的 HTML 标签：

<input type="text">, <select>, <textarea>

支持该事件的 JavaScript 对象：

fileUpload, select, text, textarea

实例 1

在本例中，我们将在用户改变输入域内容时执行 JavaScript 代码：

<html>
<head>
<script type="text/javascript">
function upperCase(x)
{
var y=document.getElementById(x).value
document.getElementById(x).value=y.toUpperCase()
}
</script>
</head>

<body>

输入您的姓名：
<input type="text" id="fname" onchange="upperCase(this.id)" />

</body>
</html>

输出：

输入您的姓名：

TIY

onchange
如何使用 onchange 事件在用户改变输入域的内容时执行 JavaScript 代码

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


onclick 事件

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

onclick 事件

返回 Event 对象参考手册

定义和用法

onclick 事件会在对象被点击时发生。

请注意， onclick 与 onmousedown 不同。单击事件是在同一元素上发生了鼠标按下事件之后又发生了鼠标放开事件时才发生的。

语法

onclick="SomeJavaScriptCode"
参数 | 描述
SomeJavaScriptCode | 必需。规定该事件发生时执行的 JavaScript。

支持该事件的 HTML 标签：

<a>, <address>, <area>, <b>, <bdo>, <big>, <blockquote>, <body>, <button>,
<caption>, <cite>, <code>, <dd>, <dfn>, <div>, <dl>, <dt>, <em>, <fieldset>,
<form>, <h1> to <h6>, <hr>, <i>, <img>, <input>, <kbd>, <label>, <legend>,
<li>, <map>, <object>, <ol>, <p>, <pre>, <samp>, <select>, <small>, <span>,
<strong>, <sub>, <sup>, <table>, <tbody>, <td>, <textarea>, <tfoot>, <th>,
<thead>, <tr>, <tt>, <ul>, <var>

支持该事件的 JavaScript 对象：

button, document, checkbox, link, radio, reset, submit

实例 1

在本例中，当按钮被单击时，第一个输入框中的文本会被拷贝到第二个输入框中：

<html>
<body>

Field1: <input type="text" id="field1" value="Hello World!">
<br />
Field2: <input type="text" id="field2">
<br /><br />
点击下面的按钮，把 Field1 的内容拷贝到 Field2 中：
<br />
<button onclick="document.getElementById('field2').value=
document.getElementById('field1').value">Copy Text</button>

</body>
</html>

输出：

Field1:

Field2:

点击下面的按钮，把 Field1 的内容拷贝到 Field2 中：

TIY

onclick
如何使用 onclick

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


ondblclick 事件

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ondblclick 事件

返回 Event 对象参考手册

定义和用法

ondblclick 事件会在对象被双击时发生。

语法

ondblclick="SomeJavaScriptCode"
参数 | 描述
SomeJavaScriptCode | 必需。规定该事件发生时执行的 JavaScript。

支持该事件的 HTML 标签：

<a>, <address>, <area>, <b>, <bdo>, <big>, <blockquote>, <body>,
<button>, <caption>, <cite>, <code>, <dd>, <dfn>, <div>, <dl>, <dt>,
<em>, <fieldset>, <form>, <h1> to <h6>, <hr>, <i>, <img>, <input>,
<kbd>, <label>, <legend>, <li>, <map>, <object>, <ol>, <p>, <pre>,
<samp>, <select>, <small>, <span>, <strong>, <sub>, <sup>, <table>,
<tbody>, <td>, <textarea>, <tfoot>, <th>, <thead>, <tr>, <tt>, <ul>, <var>

支持该事件的 JavaScript 对象：

document, link

实例 1

在本例中，当您双击按钮时，第二个域中内容会根据第一个域的内容而改变：

<html>
<body>

Field1: <input type="text" id="field1" value="Hello World!">
<br />
Field2: <input type="text" id="field2">
<br /><br />
双击下面的按钮，把 Field1 的内容拷贝到 Field2 中：
<br />
<button ondblclick="document.getElementById('field2').value=
document.getElementById('field1').value">Copy Text</button>

</body>
</html>

输出：

Field1:

Field2:

双击下面的按钮，把 Field1 的内容拷贝到 Field2 中：

TIY

ondblclick
如何使用 ondblclick。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


onerror 事件

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

onerror 事件

返回 Event 对象参考手册

定义和用法

onerror 事件会在文档或图像加载过程中发生错误时被触发。

在装载文档或图像的过程中如果发生了错误，就会调用该事件句柄。

语法

onerror="SomeJavaScriptCode"
参数 | 描述
SomeJavaScriptCode | 必需。规定该事件发生时执行的 JavaScript。

支持该事件的 HTML 标签：

<img>, <object>, <style>

支持该事件的 JavaScript 对象：

window, image

实例 1

在本例中，如果装载图像时发生了错误，则显示一个对话框：

<img src="image.gif" onerror="alert('The image could not be loaded.')" />

TIY

onerror
如何使用 onerror。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


onfocus 事件

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

onfocus 事件

返回 Event 对象参考手册

定义和用法

onfocus 事件在对象获得焦点时发生。

语法

onfocus="SomeJavaScriptCode"
参数 | 描述
SomeJavaScriptCode | 必需。规定该事件发生时执行的 JavaScript。

支持该事件的 HTML 标签：

<a>, <acronym>, <address>, <area>, <b>, <bdo>, <big>, <blockquote>, <button>,
<caption>, <cite>, <dd>, <del>, <dfn>, <div>, <dl>, <dt>, <em>, <fieldset>,
<form>, <frame>, <frameset>, <h1> to <h6>, <hr>, <i>, <iframe>, <img>, <input>,
<ins>, <kbd>, <label>, <legend>, <li>, <object>, <ol>, <p>, <pre>, <q>,
<samp>, <select>, <small>, <span>, <strong>, <sub>, <sup>, <table>, <tbody>,
<td>, <textarea>, <tfoot>, <th>, <thead>, <tr>, <tt>, <ul>, <var>

支持该事件的 JavaScript 对象：

button, checkbox, fileUpload, layer, frame, password, radio, reset, select, submit,
text, textarea, window

实例

在本例中，当输入框获得焦点时，其背景颜色将改变：

<html>
<head>
<script type="text/javascript">
function setStyle(x)
{
document.getElementById(x).style.background="yellow"
}
</script>
</head>

<body>

First name: <input type="text"
onfocus="setStyle(this.id)" id="fname" />
<br />
Last name: <input type="text"
onfocus="setStyle(this.id)" id="lname" />

</body>
</html>

输出：

First name:

Last name:

TIY

onfocus
如何使用 onfocus。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


onkeydown 事件

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

onkeydown 事件

返回 Event 对象参考手册

定义和用法

onkeydown 事件会在用户按下一个键盘按键时发生。

语法

onkeydown="SomeJavaScriptCode"
参数 | 描述
SomeJavaScriptCode | 必需。规定该事件发生时执行的 JavaScript。

支持该事件的 HTML 标签：

<a>, <acronym>, <address>, <area>, <b>, <bdo>, <big>, <blockquote>, <body>,
<button>, <caption>, <cite>, <code>, <dd>, <del>, <dfn>, <div>, <dt>, <em>,
<fieldset>, <form>, <h1> to <h6>, <hr>, <i>, <input>, <kbd>, <label>, <legend>,
<li>, <map>, <object>, <ol>, <p>, <pre>, <q>, <samp>, <select>, <small>,
<span>, <strong>, <sub>, <sup>, <table>, <tbody>, <td>, <textarea>, <tfoot>,
<th>, <thead>, <tr>, <tt>, <ul>, <var>

支持该事件的 JavaScript 对象：

document, image, link, textarea

提示和注释

浏览器差异：Internet Explorer 使用 event.keyCode 取回被按下的字符，而 Netscape/Firefox/Opera 使用 event.which。

实例

在本例中，用户无法在输入框中键入数字：

<html>
<body>
<script type="text/javascript">
function noNumbers(e)
{
var keynum
var keychar
var numcheck

if(window.event) // IE
  {
  keynum = e.keyCode
  }
else if(e.which) // Netscape/Firefox/Opera
  {
  keynum = e.which
  }

keychar = String.fromCharCode(keynum)
numcheck = /\d/
return !numcheck.test(keychar)
}
</script>

<form>
<input type="text" onkeydown="return noNumbers(event)" />
</form>

</html>

输出：

TIY

onkeydown
如何使用 onkeydown。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


onkeypress 事件

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

onkeypress 事件

返回 Event 对象参考手册

定义和用法

onkeydown 事件会在键盘按键被按下并释放一个键时发生。

语法

onkeypress="SomeJavaScriptCode"
参数 | 描述
SomeJavaScriptCode | 必需。规定该事件发生时执行的 JavaScript。

支持该事件的 HTML 标签：

<a>, <acronym>, <address>, <area>, <b>, <bdo>, <big>, <blockquote>, <body>,
<button>, <caption>, <cite>, <code>, <dd>, <del>, <dfn>, <div>, <dt>, <em>,
<fieldset>, <form>, <h1> to <h6>, <hr>, <i>, <input>, <kbd>, <label>, <legend>,
<li>, <map>, <object>, <ol>, <p>, <pre>, <q>, <samp>, <select>, <small>,
<span>, <strong>, <sub>, <sup>, <table>, <tbody>, <td>, <textarea>, <tfoot>,
<th>, <thead>, <tr>, <tt>, <ul>, <var>

支持该事件的 JavaScript 对象：

document, image, link, textarea

提示和注释

浏览器差异：Internet Explorer 使用 event.keyCode 取回被按下的字符，而 Netscape/Firefox/Opera 使用 event.which。

实例

在本例中，用户无法在输入框中键入数字：

<html>
<body>
<script type="text/javascript">
function noNumbers(e)
{
var keynum
var keychar
var numcheck

if(window.event) // IE
  {
  keynum = e.keyCode
  }
else if(e.which) // Netscape/Firefox/Opera
  {
  keynum = e.which
  }
keychar = String.fromCharCode(keynum)
numcheck = /\d/
return !numcheck.test(keychar)
}
</script>

<form>
<input type="text" onkeypress="return noNumbers(event)" />
</form>

</html>

输出：

TIY

onkeypress
如何使用 onkeypress

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


onKeyUp 事件

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

onKeyUp 事件

返回 Event 对象参考手册

定义和用法

onkeyup 事件会在键盘按键被松开时发生。

语法

onkeyup="SomeJavaScriptCode"
参数 | 描述
SomeJavaScriptCode | 必需。规定该事件发生时执行的 JavaScript。

支持该事件的 HTML 标签：

<a>, <acronym>, <address>, <area>, <b>, <bdo>, <big>, <blockquote>, <body>,
<button>, <caption>, <cite>, <code>, <dd>, <del>, <dfn>, <div>, <dt>, <em>,
<fieldset>, <form>, <h1> to <h6>, <hr>, <i>, <input>, <kbd>, <label>, <legend>,
<li>, <map>, <object>, <ol>, <p>, <pre>, <q>, <samp>, <select>, <small>,
<span>, <strong>, <sub>, <sup>, <table>, <tbody>, <td>, <textarea>, <tfoot>,
<th>, <thead>, <tr>, <tt>, <ul>, <var>

支持该事件的 JavaScript 对象：

document, image, link, textarea

实例

当您在例子中的输入域中键入字符时，字符会被更改为大写（逐一地）：

<html>

<head>
<script type="text/javascript">
function upperCase(x)
{
var y=document.getElementById(x).value
document.getElementById(x).value=y.toUpperCase()
}
</script>
</head>

<body>

输入您的姓名： <input type="text" id="fname" onkeyup="upperCase(this.id)" />

</body>
</html>

输出：

输入您的姓名：

TIY

onkeyup
如何使用 onkeyup。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


onload 事件

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

onload 事件

返回 Event 对象参考手册

定义和用法

onload 事件会在页面或图像加载完成后立即发生。

语法

onload="SomeJavaScriptCode"
参数 | 描述
SomeJavaScriptCode | 必需。规定该事件发生时执行的 JavaScript。

支持该事件的 HTML 标签：

<body>, <frame>, <frameset>, <iframe>, <img>, <link>, <script>

支持该事件的 JavaScript 对象：

image, layer, window

实例

在本例中，文本 "Page is loaded" 会被显示在状态栏中：

<html>
<head>
<script type="text/javascript">
function load()
{
window.status="Page is loaded"
}
</script>
</head>

<body onload="load()">
</body>

</html>

TIY

onload
如何使用 onload 在页面完成加载时在状态栏显示一段文本。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


onmousedown 事件

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

onmousedown 事件

返回 Event 对象参考手册

定义和用法

onmousedown 事件会在鼠标按键被按下时发生。

语法

onmousedown="SomeJavaScriptCode"
参数 | 描述
SomeJavaScriptCode | 必需。规定该事件发生时执行的 JavaScript。

支持该事件的 HTML 标签：

<a>, <address>, <area>, <b>, <bdo>, <big>, <blockquote>, <body>, <button>,
<caption>, <cite>, <code>, <dd>, <dfn>, <div>, <dl>, <dt>, <em>, <fieldset>,
<form>, <h1> to <h6>, <hr>, <i>, <img>, <input>, <kbd>, <label>, <legend>,
<li>, <map>, <ol>, <p>, <pre>, <samp>, <select>, <small>, <span>, <strong>,
<sub>, <sup>, <table>, <tbody>, <td>, <textarea>, <tfoot>, <th>, <thead>,
<tr>, <tt>, <ul>, <var>

支持该事件的 JavaScript 对象：

button, document, link

实例

在本例中，当您点击下面的图片时会弹出一个对话框：

<img src="/i/example_mouse2.jpg"
onmousedown="alert('You clicked the picture!')" />

输出：（请点击图片）

实例 2

在本例中，对话框将显示出您所点击的元素的标签名：

<html>
<head>
<script type="text/javascript">
function whichElement(e)
{
var targ
if (!e) var e = window.event
if (e.target) targ = e.target
else if (e.srcElement) targ = e.srcElement
if (targ.nodeType == 3) // defeat Safari bug
targ = targ.parentNode
var tname
tname=targ.tagName
alert("You clicked on a " + tname + " element.")
}
</script>
</head>

<body onmousedown="whichElement(event)">

<h2>This is a header</h2>
<p>This is a paragraph</p>
<img border="0" src="ball16.gif" alt="Ball">

</body>
</html>

TIY

onmousedown
如何使用 onmousedown 在图像被点击时显示一个对话框。
onmousedown 2
如何使用 onmousedown 来显示您所点击的元素的标签名。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


onmousemove 事件

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

onmousemove 事件

返回 Event 对象参考手册

定义和用法

onmousemove 事件会在鼠标指针移动时发生。

语法

onmousemove="SomeJavaScriptCode"
参数 | 描述
SomeJavaScriptCode | 必需。规定该事件发生时执行的 JavaScript。

支持该事件的 HTML 标签：

<a>, <address>, <area>, <b>, <bdo>, <big>, <blockquote>, <body>, <button>,
<caption>, <cite>, <code>, <dd>, <dfn>, <div>, <dl>, <dt>, <em>, <fieldset>,
<form>, <h1> to <h6>, <hr>, <i>, <img>, <input>, <kbd>, <label>, <legend>,
<li>, <map>, <ol>, <p>, <pre>, <samp>, <select>, <small>, <span>, <strong>,
<sub>, <sup>, <table>, <tbody>, <td>, <textarea>, <tfoot>, <th>, <thead>,
<tr>, <tt>, <ul>, <var>

支持该事件的 JavaScript 对象：

onmousemove is, by default, not an event of any object,
because mouse movement happens very frequently.

提示和注释

注释：每当用户把鼠标移动一个像素，就会发生一个 mousemove 事件。这会耗费系统资源去处理所有这些 mousemove 事件。因此请审慎地使用该事件。

实例

下面的例子中，当用户把鼠标移动到图像上时，将显示一个对话框：

<img src="/i/eg_mouse2.jpg" alt="mouse"
onmousemove="alert('您的鼠标刚才经过了图片！')" />

输出(请把鼠标放到图片上)：

TIY

onmousemove
如何使用 onmousemove。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


onmouseout 事件

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

onmouseout 事件

返回 Event 对象参考手册

定义和用法

onmouseout 事件会在鼠标指针移出指定的对象时发生。

语法

onmouseout="SomeJavaScriptCode"
参数 | 描述
SomeJavaScriptCode | 必需。规定该事件发生时执行的 JavaScript。

支持该事件的 HTML 标签：

<a>, <address>, <area>, <b>, <bdo>, <big>, <blockquote>, <body>, <button>,
<caption>, <cite>, <code>, <dd>, <dfn>, <div>, <dl>, <dt>, <em>, <fieldset>,
<form>, <h1> to <h6>, <hr>, <i>, <img>, <input>, <kbd>, <label>, <legend>,
<li>, <map>, <ol>, <p>, <pre>, <samp>, <select>, <small>, <span>, <strong>,
<sub>, <sup>, <table>, <tbody>, <td>, <textarea>, <tfoot>, <th>, <thead>,
<tr>, <tt>, <ul>, <var>

支持该事件的 JavaScript 对象：

layer, link

实例 1

在下面的例子中，我们将在鼠标指针移出图像时显示一个对话框：

<img src="/i/example_mouse2.jpg" alt="mouse"
onmousemove="alert('您的鼠标刚才离开了图片！')" />

输出：(请把鼠标从图片上移开):

实例 2

下面的例子中，我们将在网页上添加一个用作连接按钮的图像，然后我们会添加 onMouseOver 和 onMouseOut 事件，这样就可以在运行两个 JavaScript 函数来切换两幅图像：

<html>
<head>
<script type="text/javascript">
function mouseOver()
{
document.getElementById('b1').src ="/i/eg_mouse.jpg"
}
function mouseOut()
{
document.getElementById('b1').src ="/i/eg_mouse2.jpg"
}
</script>
</head>

<body>
<a href="http://www.w3school.com.cn"
onmouseover="mouseOver()" onmouseout="mouseOut()">
<img alt="Visit W3School!" src="/i/example_mouse2.jpg" id="b1" />
</a>
</body>
</html>

输出：

TIY

onmouseout
如何使用 onmouseout。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


onmouseover 事件

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

onmouseover 事件

返回 Event 对象参考手册

定义和用法

onmouseover 时间会在鼠标指针移动到指定的对象上时发生。

语法

onmouseover="SomeJavaScriptCode"
参数 | 描述
SomeJavaScriptCode | 必需。规定该事件发生时执行的 JavaScript。

支持该事件的 HTML 标签：

<a>, <address>, <area>, <b>, <bdo>, <big>, <blockquote>, <body>, <button>,
<caption>, <cite>, <code>, <dd>, <dfn>, <div>, <dl>, <dt>, <em>, <fieldset>,
<form>, <h1> to <h6>, <hr>, <i>, <img>, <input>, <kbd>, <label>, <legend>,
<li>, <map>, <ol>, <p>, <pre>, <samp>, <select>, <small>, <span>, <strong>,
<sub>, <sup>, <table>, <tbody>, <td>, <textarea>, <tfoot>, <th>, <thead>,
<tr>, <tt>, <ul>, <var>

支持该事件的 JavaScript 对象：

layer, link

实例 1

在下面的例子中，我们将在用户把鼠标指针移动到图像上时显示一个对话框：

<img src="/i/eg_mouse2.jpg" alt="mouse"
onmouseover="alert('您的鼠标在图片上！')" />

输出：(请把鼠标移动图片上):

实例 2

下面的例子中，我们将在网页上添加一个用作连接按钮的图像，然后我们会添加 onMouseOver 和 onMouseOut 事件，这样就可以在运行两个 JavaScript 函数来切换两幅图像：

<html>
<head>
<script type="text/javascript">
function mouseOver()
{
document.getElementById('b1').src ="/i/eg_mouse.jpg"
}
function mouseOut()
{
document.getElementById('b1').src ="/i/eg_mouse2.jpg"
}
</script>
</head>

<body>
<a href="http://www.w3school.com.cn"
onmouseover="mouseOver()" onmouseout="mouseOut()">
<img alt="Visit W3School!" src="/i/eg_mouse2.jpg" id="b1" />
</a>
</body>
</html>

输出：

TIY

onmouseover
如何使用 onmouseover。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


onmouseup 事件

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

onmouseup 事件

返回 Event 对象参考手册

定义和用法

onmouseup 事件会在鼠标按键被松开时发生。

语法

onmouseup="SomeJavaScriptCode"
参数 | 描述
SomeJavaScriptCode | 必需。规定该事件发生时执行的 JavaScript。

支持该事件的 HTML 标签：

<a>, <address>, <area>, <b>, <bdo>, <big>, <blockquote>, <body>, <button>,
<caption>, <cite>, <code>, <dd>, <dfn>, <div>, <dl>, <dt>, <em>, <fieldset>,
<form>, <h1> to <h6>, <hr>, <i>, <img>, <input>, <kbd>, <label>, <legend>,
<li>, <map>, <ol>, <p>, <pre>, <samp>, <select>, <small>, <span>, <strong>,
<sub>, <sup>, <table>, <tbody>, <td>, <textarea>, <tfoot>, <th>, <thead>,
<tr>, <tt>, <ul>, <var>

支持该事件的 JavaScript 对象：

button, document, link

实例 1

在本例中，在点击图片并松开鼠标按键后，将显示一个对话框：

<img src="/i/eg_mouse2.jpg" alt="mouse"
onmouseup="alert('您点击了图片！')" />

输出：(请点击图片)：

实例 2

在本例中，对话框中会显示出您所点击的元素的标签名：

<html>
<head>
<script type="text/javascript">
function whichElement(e)
{
var targ
if (!e) var e = window.event
if (e.target) targ = e.target
else if (e.srcElement) targ = e.srcElement
if (targ.nodeType == 3) // defeat Safari bug
targ = targ.parentNode
var tname
tname=targ.tagName
alert("You clicked on a " + tname + " element.")
}
</script>
</head>

<body onmouseup="whichElement(event)">

<h2>This is a header</h2>
<p>This is a paragraph</p>
<img border="0" src="ball16.gif" alt="Ball">

</body>
</html>

TIY

onmouseup
如何使用 onmouseup 在图像被点击时显示一个对话框。
onmouseup 2
如何使用 onmouseup 来显示您所点击的元素的标签名。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


onreset 事件

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

onreset 事件

返回 Event 对象参考手册

定义和用法

onreset 事件会在表单中的重置按钮被点击时发生。

语法

onreset="SomeJavaScriptCode"
参数 | 描述
SomeJavaScriptCode | 必需。规定该事件发生时执行的 JavaScript。

支持该事件的 HTML 标签：

<form>

支持该事件的 JavaScript 对象：

form

实例

在本例中，当重置按钮被点击时，表单会改为默认值，并显示一个对话框：

<form onreset="alert('The form will be reset')">

Firstname: <input type="text" name="fname" value="John" />
<br />
Lastname: <input type="text" name="lname" />
<br /><br />
<input type="reset" value="Reset">

</form>

输出：

Firstname:

Lastname:

TIY

onreset
如何使用 onreset 在 reset 事件发生时显示一个对话框。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


onresize 事件

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

onresize 事件

返回 Event 对象参考手册

定义和用法

onresize 事件会在窗口或框架被调整大小时发生。

语法

onresize="SomeJavaScriptCode"
参数 | 描述
SomeJavaScriptCode | 必需。规定该事件发生时执行的 JavaScript。

支持该事件的 HTML 标签：

<a>, <address>, <b>, <big>, <blockquote>, <body>, <button>, <cite>, <code>,
<dd>, <dfn>, <div>, <dl>, <dt>, <em>, <fieldset>, <form>, <frame>, <h1> to <h6>,
<hr>, <i>, <img>, <input>, <kbd>, <label>, <legend>, <li>, <object>, <ol>, <p>,
<pre>, <samp>, <select>, <small>, <span>, <strong>, <sub>, <sup>, <table>,
<textarea>, <tt>, <ul>, <var>

支持该事件的 JavaScript 对象：

window

实例

在本例中，当用户试图调整窗口的大小时，将显示一个对话框：

<body onresize="alert('You have changed the size of the window')">
</body>

TIY

onresize
如何使用 onresize 在窗口被调整大小时显示一个对话框。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


onselect 事件

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

onselect 事件

返回 Event 对象参考手册

定义和用法

onselect 事件会在文本框中的文本被选中时发生。

语法

onselect="SomeJavaScriptCode"
参数 | 描述
SomeJavaScriptCode | 必需。规定该事件发生时执行的 JavaScript。

支持该事件的 HTML 标签：

<input type="text">, <textarea>

支持该事件的 JavaScript 对象：

window

实例

在本例中，当用户试图选择文本框中的文本时，会显示一个对话框：

<form>

Select text: <input type="text" value="Hello world!"
onselect="alert('You have selected some of the text.')" />
<br /><br />
Select text: <textarea cols="20" rows="5"
onselect="alert('You have selected some of the text.')">
Hello world!</textarea>

</form>

输出：

TIY

onselect
如何使用 onselect。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


onsubmit 事件

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

onsubmit 事件

返回 Event 对象参考手册

定义和用法

onsubmit 事件会在表单中的确认按钮被点击时发生。

语法

onsubmit="SomeJavaScriptCode"
参数 | 描述
SomeJavaScriptCode | 必需。规定该事件发生时执行的 JavaScript。

支持该事件的 HTML 标签：

<form>

支持该事件的 JavaScript 对象：

form

实例

在本例中，当用户点击提交按钮时，会显示一个对话框：

<form name="testform" action="jsref_onsubmit.asp"
onsubmit="alert('Hello ' + testform.fname.value +'!')">

What is your name?<br />
<input type="text" name="fname" />
<input type="submit" value="Submit" />

</form>

输出：

What is your name?

TIY

onsubmit
如何使用 onsubmit。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


onunload 事件

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

onunload 事件

返回 Event 对象参考手册

定义和用法

onunload 事件在用户退出页面时发生。

语法

onunload="SomeJavaScriptCode"
参数 | 描述
SomeJavaScriptCode | 必需。规定该事件发生时执行的 JavaScript。

支持该事件的 HTML 标签：

<body>, <frameset>

支持该事件的 JavaScript 对象：

window

实例

在本例中，在页面关闭时会显示一个对话框：

<body onunload="alert('The onunload event was triggered')">
</body>

TIY

onunload
如何使用 onunload。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


preventDefault() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

preventDefault() 方法

返回 Event 对象参考手册

定义和用法

取消事件的默认动作。

语法

event.preventDefault()

说明

该方法将通知 Web 浏览器不要执行与事件关联的默认动作（如果存在这样的动作）。例如，如果 type 属性是 "submit"，在事件传播的任意阶段可以调用任意的事件句柄，通过调用该方法，可以阻止提交表单。注意，如果 Event 对象的 cancelable 属性是 fasle，那么就没有默认动作，或者不能阻止默认动作。无论哪种情况，调用该方法都没有作用。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


relatedTarget 事件属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

relatedTarget 事件属性

返回 Event 对象参考手册

定义和用法

relatedTarget 事件属性返回与事件的目标节点相关的节点。

对于 mouseover 事件来说，该属性是鼠标指针移到目标节点上时所离开的那个节点。

对于 mouseout 事件来说，该属性是离开目标时，鼠标指针进入的节点。

对于其他类型的事件来说，这个属性没有用。

语法

event.relatedTarget

实例

下面例子可返回指针刚刚离开的元素：

<html>
<head>
<script type="text/javascript">
function getRelElement(event)
  {
  var txt="The cursor just exited the ";
  txt=txt + event.relatedTarget.tagName + " element.";
  alert(txt);
  }
</script>
</head>
<body>

<p onmouseover="getRelElement(event)">
Mouse over this paragraph.</p>

</body>
</html>

TIY

relatedtarget
返回指针刚刚离开的元素（不支持 IE）。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


screenX 事件属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

screenX 事件属性

返回 Event 对象参考手册

定义和用法

screenX 事件属性可返回事件发生时鼠标指针相对于屏幕的水平坐标。

语法

event.screenX

实例

下面的例子可显示出事件发生时鼠标指针的坐标：

<html>
<head>
<script type="text/javascript">
function show_coords(event)
  {
  x=event.screenX
  y=event.screenY
  alert("X coords: " + x + ", Y coords: " + y)
  }
</script>
</head>
<body onmousedown="show_coords(event)">

<p>Click in the document. An alert box will alert
the x and y coordinates of the cursor.</p>

</body>
</html>

TIY

screenX
提示鼠标指针的坐标。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


screenY 事件属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

screenY 事件属性

返回 Event 对象参考手册

定义和用法

screenY 事件属性可返回事件发生时鼠标指针相对于屏幕的垂直坐标。

语法

event.screenY

实例

下面的例子可显示出事件发生时鼠标指针的坐标：

<html>
<head>
<script type="text/javascript">
function show_coords(event)
  {
  x=event.screenX
  y=event.screenY
  alert("X coords: " + x + ", Y coords: " + y)
  }
</script>
</head>
<body onmousedown="show_coords(event)">

<p>Click in the document. An alert box will alert
the x and y coordinates of the cursor.</p>

</body>
</html>

TIY

screenY
提示鼠标指针的坐标。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


shiftKey 事件属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

shiftKey 事件属性

返回 Event 对象参考手册

定义和用法

shiftKey 事件属性可返回一个布尔值，指示当事件发生时，"SHIFT" 键是否被按下并保持住。

语法

event.shiftKey=true|false|1|0

实例

下面的例子可提示当鼠标按键被点击时 "SHIFT" 键是否被按住：

<html>
<head>
<script type="text/javascript">
function isKeyPressed(event)
{
  if (event.shiftKey==1)
    {
    alert("The shift key was pressed!")
    }
  else
    {
    alert("The shift key was NOT pressed!")
    }
  }
</script>
</head>

<body onmousedown="isKeyPressed(event)">

<p>Click somewhere in the document.
An alert box will tell you if you
pressed the shift key or not.</p>

</body>
</html>

TIY

shiftKey
检测 SHIFT 键是否被按住。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


stopPropagation() 方法

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

stopPropagation() 方法

返回 Event 对象参考手册

定义和用法

不再派发事件。

语法

event.stopPropagation()

说明

该方法将停止事件的传播，阻止它被分派到其他 Document 节点。在事件传播的任何阶段都可以调用它。注意，虽然该方法不能阻止同一个 Document 节点上的其他事件句柄被调用，但是它可以阻止把事件分派到其他节点。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


target 事件属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

target 事件属性

返回 Event 对象参考手册

定义和用法

target 事件属性可返回事件的目标节点（触发该事件的节点），如生成事件的元素、文档或窗口。

语法

event.target

实例

下面的例子可获得触发事件的元素：

<html>
<head>

<script type="text/javascript">
function getEventTrigger(event)
  {
  x=event.target;
  alert("The id of the triggered element: "
  + x.id);
  }
</script>

</head>
<body >

<p id="p1" onmousedown="getEventTrigger(event)">
Click on this paragraph. An alert box will
show which element triggered the event.</p>

</body>
</html>

TIY

target event
获得触发事件的元素（IE 浏览器不支持）。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


timeStamp 事件属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

timeStamp 事件属性

返回 Event 对象参考手册

定义和用法

timeStamp 事件属性可返回一个时间戳。指示发生事件的日期和时间（从 epoch 开始的毫秒数）。

epoch 是一个事件参考点。在这里，它是客户机启动的时间。

并非所有系统都提供该信息，因此，timeStamp 属性并非对所有系统/事件都是可用的。

语法

event.timeStamp

实例

下面的例子可获得系统启动开始的事件戳：

<html>
<head>
<script type="text/javascript">
function showTimestamp(event)
  {
  var minutes = 1000*60
  x=event.timeStamp;
  alert(x/minutes)
  }
</script>
</head>

<body onmousedown="showTimestamp(event)">

<p>Click in the document. An alert
box will alert the timestamp.</p>

</body>
</html>

TIY

timestamp event
返回系统启动至今的分钟数（IE 浏览器不支持）。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


type 事件属性

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

type 事件属性

返回 Event 对象参考手册

定义和用法

type 事件属性返回发生的事件的类型，即当前 Event 对象表示的事件的名称。

它与注册的事件句柄同名，或者是事件句柄属性删除前缀 "on" 比如 "submit"、"load" 或 "click"。

语法

event.type

实例

下面的例子可返回被触发的事件的类型：

<html>
<head>
<script type="text/javascript">
function getEventType(event)
  {
  alert(event.type);
  }
</script>
</head>

<body onmousedown="getEventType(event)">

<p>Click somewhere in the document.
An alert box will tell what event
type you triggered.</p>

</body>
</html>

TIY

type event
返回被触发的事件的类型（IE 浏览器不支持）。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


您已经学习了 HTML DOM，接下来的学习内容是什么呢？

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

您已经学习了 HTML DOM，接下来的学习内容是什么呢？

  • Previous Page
  • Next Page

HTML DOM 概要

本教程已经向您讲授了如何使用 HTML DOM 提高您的网站的动态性和交互性。

您已经学习了操作 HTML 元素来对不同的情况作出响应。

如需更多有关 HTML DOM 的信息，请访问我们的 HTML DOM 实例 和 HTML DOM 参考手册。

现在您已经学习了 HTML DOM，下一步呢？

下一步，您应当学习 ASP。

HTML 文件中的脚本是在客户端（浏览器中）执行的，而 ASP 文件中的脚本是在服务器上执行的。

通过 ASP，你可以动态地编辑、改变、添加网页的任何内容，对从 HTML 表单提交的信息作出响应，访问任何数据或者数据库并把结果返回浏览器，为不同的用户定制网页，使页面的可用性更强。

由于 ASP 文件所返回的内容是纯粹的 HTML，因此它们可显示于任何浏览器中。

如果您希望学习更多有关ASP的知识，请访问我们的 ASP 教程。

  • Previous Page
  • Next Page

HTML DOM 参考手册
HTML DOM 实例


一个 HTML DOM 实例

HTML DOM

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 节点访问
  • DOM 节点信息
  • DOM How To
  • DOM 参考
  • DOM 总结

DOM 实例

  • DOM 实例

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Canvas
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

一个 HTML DOM 实例

  • Previous Page
  • Next Page

一个 HTML DOM 的实例

下面这个例子向我们展示了当一个用户在文档中点击时，HTML 文档的背景颜色如何被改变。

<html>

<head>
<script type="text/javascript">
function ChangeColor()
{
document.body.bgColor="yellow"
}
</script>
</head>

<body onclick="ChangeColor()">
Click on this document!
</body>

</html>

TIY

  • Previous Page
  • Next Page

HTML DOM 参考手册
HTML DOM 实例


ECMAScript Boolean 运算符

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript Boolean 运算符

  • Previous Page
  • Next Page

Boolean 运算符非常重要，它使得程序语言得以正常运行。

Boolean 运算符有三种：NOT、AND 和 OR。

逻辑 NOT 运算符

在 ECMAScript 中，逻辑 NOT 运算符与 C 和 Java 中的逻辑 NOT 运算符相同，都由感叹号（!）表示。

与逻辑 OR 和逻辑 AND 运算符不同的是，逻辑 NOT 运算符返回的一定是 Boolean 值。

逻辑 NOT 运算符的行为如下：

  • 如果运算数是对象，返回 false
  • 如果运算数是数字 0，返回 true
  • 如果运算数是 0 以外的任何数字，返回 false
  • 如果运算数是 null，返回 true
  • 如果运算数是 NaN，返回 true
  • 如果运算数是 undefined，发生错误

通常，该运算符用于控制循环：

var bFound = false;
var i = 0;

while (!bFound) {
  if (aValue[i] == vSearchValues) {
    bFound = true;
  } else {
    i++;
  }
}

在这个例子中，Boolean 变量（bFound）用于记录检索是否成功。找到问题中的数据项时，bFound 将被设置为 true，!bFound 将等于 false，意味着运行将跳出 while 循环。

判断 ECMAScript 变量的 Boolean 值时，也可以使用逻辑 NOT 运算符。这样做需要在一行代码中使用两个 NOT 运算符。无论运算数是什么类型，第一个 NOT 运算符返回 Boolean 值。第二个 NOT 将对该 Boolean 值求负，从而给出变量真正的 Boolean 值。

var bFalse = false;
var sRed = "red";
var iZero = 0;
var iThreeFourFive = 345;
var oObject = new Object;

document.write("bFalse 的逻辑值是 " + (!!bFalse));
document.write("sBlue 的逻辑值是 " + (!!sBlue));
document.write("iZero 的逻辑值是 " + (!!iZero));
document.write("iThreeFourFive 的逻辑值是 " + (!!iThreeFourFive));
document.write("oObject 的逻辑值是 " + (!!oObject));

结果：

bFalse 的逻辑值是 false
sRed 的逻辑值是 true
iZero 的逻辑值是 false
iThreeFourFive 的逻辑值是 true
oObject 的逻辑值是 true

逻辑 AND 运算符

在 ECMAScript 中，逻辑 AND 运算符用双和号（&&）表示：

例如：

var bTrue = true;
var bFalse = false;
var bResult = bTrue && bFalse;

下面的真值表描述了逻辑 AND 运算符的行为：

运算数 1 | 运算数 2 | 结果
true | true | true
true | false | false
false | true | false
false | false | false

逻辑 AND 运算的运算数可以是任何类型的，不止是 Boolean 值。

如果某个运算数不是原始的 Boolean 型值，逻辑 AND 运算并不一定返回 Boolean 值：

  • 如果一个运算数是对象，另一个是 Boolean 值，返回该对象。
  • 如果两个运算数都是对象，返回第二个对象。
  • 如果某个运算数是 null，返回 null。
  • 如果某个运算数是 NaN，返回 NaN。
  • 如果某个运算数是 undefined，发生错误。

与 Java 中的逻辑 AND 运算相似，ECMAScript 中的逻辑 AND 运算也是简便运算，即如果第一个运算数决定了结果，就不再计算第二个运算数。对于逻辑 AND 运算来说，如果第一个运算数是 false，那么无论第二个运算数的值是什么，结果都不可能等于 true。

考虑下面的例子：

var bTrue = true;
var bResult = (bTrue && bUnknown);	//发生错误
alert(bResult);			//这一行不会执行

这段代码在进行逻辑 AND 运算时将引发错误，因为变量 bUnknown 是未定义的。变量 bTrue 的值为 true，因为逻辑 AND 运算将继续计算变量 bUnknown。这样做就会引发错误，因为 bUnknown 的值是 undefined，不能用于逻辑 AND 运算。

如果修改这个例子，把第一个数设为 false，那么就不会发生错误：

var bFalse = false;
var bResult = (bFalse && bUnknown);
alert(bResult);			//输出 "false"

在这段代码中，脚本将输出逻辑 AND 运算返回的值，即字符串 "false"。即使变量 bUnknown 的值为 undefined，它也不会被计算，因为第一个运算数的值是 false。

提示：在使用逻辑 AND 运算符时，必须记住它的这种简便计算特性。

逻辑 OR 运算符

ECMAScript 中的逻辑 OR 运算符与 Java 中的相同，都由双竖线（||）表示：

var bTrue = true;
var bFalse = false;
var bResult = bTrue || bFalse;

下面的真值表描述了逻辑 OR 运算符的行为：

运算数 1 | 运算数 2 | 结果
true | true | true
true | false | true
false | true | true
false | false | false

与逻辑 AND 运算符相似，如果某个运算数不是 Boolean 值，逻辑 OR 运算并不一定返回 Boolean 值：

  • 如果一个运算数是对象，另一个是 Boolean 值，返回该对象。
  • 如果两个运算数都是对象，返回第一个对象。
  • 如果某个运算数是 null，返回 null。
  • 如果某个运算数是 NaN，返回 NaN。
  • 如果某个运算数是 undefined，发生错误。

与逻辑 AND 运算符一样，逻辑 OR 运算也是简便运算。对于逻辑 OR 运算符来说，如果第一个运算数值为 true，就不再计算第二个运算数。

例如：

var bTrue = true;
var bResult = (bTrue || bUnknown);
alert(bResult);			//输出 "true"

与前面的例子相同，变量 bUnknown 是未定义的。不过，由于变量 bTrue 的值为 true，bUnknown 不会被计算，因此输出的是 "true"。

如果把 bTrue 改为 false，将发生错误：

var bFalse = false;
var bResult = (bFalse || bUnknown);	//发生错误
alert(bResult);			//不会执行这一行
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript break 和 continue 语句

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript break 和 continue 语句

  • Previous Page
  • Next Page

break 和 continue 语句对循环中的代码执行提供了更严格的控制。

break 和 continue 语句的不同之处

break 语句可以立即退出循环，阻止再次反复执行任何代码。

而 continue 语句只是退出当前循环，根据控制表达式还允许继续进行下一次循环。

例如：

var iNum = 0;

for (var i=1; i<10; i++) {
  if (i % 5 == 0) {
    break;
  }
  iNum++;
}
alert(iNum);	//输出 "4"

在以上代码中，for 循环从 1 到 10 迭代变量 i。在循环主体中，if 语句将（使用取模运算符）检查 i 的值是否能被 5 整除。如果能被 5 整除，将执行 break 语句。alert 显示 "4"，即退出循环前执行循环的次数。

如果用 continue 语句代替这个例子中的 break 语句，结果将不同：

var iNum = 0;

for (var i=1; i<10; i++) {
  if (i % 5 == 0) {
    continue;
  }
  iNum++;
}
alert(iNum);	//输出 "8"

这里，alert 将显示 "8"，即执行循环的次数。可能执行的循环总数为 9，不过当 i 的值为 5 时，将执行 continue 语句，会使循环跳过表达式 iNum++，返回循环开头。

与有标签的语句一起使用

break 语句和 continue 语句都可以与有标签的语句联合使用，返回代码中的特定位置。

通常，当循环内部还有循环时，会这样做，例如：

var iNum = 0;

outermost:
for (var i=0; i<10; i++) {
  for (var j=0; j<10; j++) {
    if (i == 5 && j == 5) {
    break outermost;
  }
  iNum++;
  }
}

alert(iNum);	//输出 "55"

在上面的例子中，标签 outermost 表示的是第一个 for 语句。正常情况下，每个 for 语句执行 10 次代码块，这意味着 iNum++ 正常情况下将被执行 100 次，在执行完成时，iNum 应该等于 100。这里的 break 语句有一个参数，即停止循环后要跳转到的语句的标签。这样 break 语句不止能跳出内部 for 语句（即使用变量 j 的语句），还能跳出外部 for 语句（即使用变量 i 的语句）。因此，iNum 最后的值是 55，因为当 i 和 j 的值都等于 5 时，循环将终止。

可以以相同的方式使用 continue 语句：

var iNum = 0;

outermost:
for (var i=0; i<10; i++) {
  for (var j=0; j<10; j++) {
    if (i == 5 && j == 5) {
    continue outermost;
  }
  iNum++;
  }
}

alert(iNum);	//输出 "95"

在上例中，continue 语句会迫使循环继续，不止是内部循环，外部循环也如此。当 j 等于 5 时出现这种情况，意味着内部循环将减少 5 次迭代，致使 iNum 的值为 95。

提示：可以看出，与 break 和 continue 联合使用的有标签语句非常强大，不过过度使用它们会给调试代码带来麻烦。要确保使用的标签具有说明性，同时不要嵌套太多层循环。

提示：想了解什么是有标签语句，请阅读 ECMAScript 标签语句 这一节。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript Function 对象（类）

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript Function 对象（类）

  • Previous Page
  • Next Page

ECMAScript 的函数实际上是功能完整的对象。

Function 对象（类）

ECMAScript 最令人感兴趣的可能莫过于函数实际上是功能完整的对象。

Function 类可以表示开发者定义的任何函数。

用 Function 类直接创建函数的语法如下：

var function_name = new function(arg1, arg2, ..., argN, function_body)

在上面的形式中，每个 arg 都是一个参数，最后一个参数是函数主体（要执行的代码）。这些参数必须是字符串。

记得下面这个函数吗？

function sayHi(sName, sMessage) {
  alert("Hello " + sName + sMessage);
}

还可以这样定义它：

var sayHi
=
new Function("sName", "sMessage", "alert(\"Hello \" + sName + sMessage);");

虽然由于字符串的关系，这种形式写起来有些困难，但有助于理解函数只不过是一种引用类型，它们的行为与用 Function 类明确创建的函数行为是相同的。

请看下面这个例子：

function doAdd(iNum) {
  alert(iNum + 20);
}

function doAdd(iNum) {
  alert(iNum + 10);
}

doAdd(10);	//输出 "20"

如你所知，第二个函数重载了第一个函数，使 doAdd(10) 输出了 "20"，而不是 "30"。

如果以下面的形式重写该代码块，这个概念就清楚了：

var doAdd = new Function("iNum", "alert(iNum + 20)");
var doAdd = new Function("iNum", "alert(iNum + 10)");
doAdd(10);

请观察这段代码，很显然，doAdd 的值被改成了指向不同对象的指针。函数名只是指向函数对象的引用值，行为就像其他对象一样。甚至可以使两个变量指向同一个函数：

var doAdd = new Function("iNum", "alert(iNum + 10)");
var alsodoAdd = doAdd;
doAdd(10);	//输出 "20"
alsodoAdd(10);	//输出 "20"

在这里，变量 doAdd 被定义为函数，然后 alsodoAdd 被声明为指向同一个函数的指针。用这两个变量都可以执行该函数的代码，并输出相同的结果 - "20"。因此，如果函数名只是指向函数的变量，那么可以把函数作为参数传递给另一个函数吗？回答是肯定的！

function callAnotherFunc(fnFunction, vArgument) {
  fnFunction(vArgument);
}

var doAdd = new Function("iNum", "alert(iNum + 10)");

callAnotherFunc(doAdd, 10);	//输出 "20"

在上面的例子中，callAnotherFunc() 有两个参数 - 要调用的函数和传递给该函数的参数。这段代码把 doAdd() 传递给 callAnotherFunc() 函数，参数是 10，输出 "20"。

注意：尽管可以使用 Function 构造函数创建函数，但最好不要使用它，因为用它定义函数比用传统方式要慢得多。不过，所有函数都应看作 Function 类的实例。

Function 对象的 length 属性

如前所述，函数属于引用类型，所以它们也有属性和方法。

ECMAScript 定义的属性 length 声明了函数期望的参数个数。例如：

function doAdd(iNum) {
  alert(iNum + 10);
}

function sayHi() {
  alert("Hi");
}

alert(doAdd.length);	//输出 "1"
alert(sayHi.length);	//输出 "0"

函数 doAdd() 定义了一个参数，因此它的 length 是 1；sayHi() 没有定义参数，所以 length 是 0。

记住，无论定义了几个参数，ECMAScript 可以接受任意多个参数（最多 25 个），这一点在《函数概述》这一章中讲解过。属性 length 只是为查看默认情况下预期的参数个数提供了一种简便方式。

Function 对象的方法

Function 对象也有与所有对象共享的 valueOf() 方法和 toString() 方法。这两个方法返回的都是函数的源代码，在调试时尤其有用。例如：

function doAdd(iNum) {
  alert(iNum + 10);
}

document.write(doAdd.toString());

上面这段代码输出了 doAdd() 函数的文本。亲自试一试！

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript if 语句

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript if 语句

  • Previous Page
  • Next Page

if 语句是 ECMAScript 中最常用的语句之一。

ECMAScript 语句

ECMA - 262 描述了 ECMAScript 的几种语句（statement）。

语句主要定义了 ECMAScript 的大部分语句，通常采用一个或多个关键字，完成给定的任务。

语句可以非常简单，例如通知函数退出，也可以非常复杂，如声明一组要反复执行的命令。

在《ECMAScript 语句》这一章，我们介绍了所有标准的 ECMAScript 语句。

if 语句

if 语句是 ECMAScript 中最常用的语句之一，事实上在许多计算机语言中都是如此。

if 语句的语法：

if (condition) statement1 else statement2

其中 condition 可以是任何表达式，计算的结果甚至不必是真正的 boolean 值，ECMAScript 会把它转换成 boolean 值。

如果条件计算结果为 true，则执行 statement1；如果条件计算结果为 false，则执行 statement2。

每个语句都可以是单行代码，也可以是代码块。

例如：

if (i > 30)
  {alert("大于 30");}
else
  {alert("小于等于 30");}

提示：使用代码块被认为是一种最佳的编程实践，即使要执行的代码只有一行。这样做可以使每个条件要执行什么一目了然。

还可以串联多个 if 语句。就像这样：

if (condition1) statement1 else if (condition2) statement2 else statement3

例如：

if (i > 30) {
  alert("大于 30");
} else if (i < 0) {
  alert("小于 0");
} else {
  alert("在 0 到 30 之间");
}
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript with 语句

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript switch 语句

  • Previous Page
  • Next Page

switch 语句

switch 语句是 if 语句的兄弟语句。

开发者可以用 switch 语句为表达式提供一系列的情况（case）。

switch 语句的语法：

switch (expression)
  case value: statement;
    break;
  case value: statement;
    break;
  case value: statement;
    break;
  case value: statement;
    break;
...
  case value: statement;
    break;
  default: statement;

每个情况（case）都是表示“如果 expression 等于 value，就执行 statement”。

关键字 break 会使代码跳出 switch 语句。如果没有关键字 break，代码执行就会继续进入下一个 case。

关键字 default 说明了表达式的结果不等于任何一种情况时的操作（事实上，它相对于 else 从句）。

switch 语句主要是为避免让开发者编写下面的代码：

if (i == 20)
  alert("20");
else if (i == 30)
  alert("30");
else if (i == 40)
  alert("40");
else
  alert("other");

等价的 switch 语句是这样的：

switch (i) {
  case 20: alert("20");
    break;
  case 30: alert("30");
    break;
  case 40: alert("40");
    break;
  default: alert("other");
}

ECMAScript 和 Java 中的 switch 语句

ECMAScript 和 Java 中的 switch 语句有两点不同。在 ECMAScript 中，switch 语句可以用于字符串，而且能用不是常量的值说明情况：

var BLUE = "blue", RED = "red", GREEN  = "green";

switch (sColor) {
  case BLUE: alert("Blue");
    break;
  case RED: alert("Red");
    break;
  case GREEN: alert("Green");
    break;
  default: alert("Other");
}

这里，switch 语句用于字符串 sColor，声明 case 使用的是变量 BLUE、RED 和 GREEN，这在 ECMAScript 中是完全有效的。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript with 语句

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript with 语句

  • Previous Page
  • Next Page

有标签的语句

with 语句用于设置代码在特定对象中的作用域。

它的语法：

with (expression) statement

例如：

var sMessage = "hello";
with(sMessage) {
  alert(toUpperCase());	//输出 "HELLO"
}

在这个例子中，with 语句用于字符串，所以在调用 toUpperCase() 方法时，解释程序将检查该方法是否是本地函数。如果不是，它将检查伪对象 sMessage，看它是否为该对象的方法。然后，alert 输出 "HELLO"，因为解释程序找到了字符串 "hello" 的 toUpperCase() 方法。

提示：with 语句是运行缓慢的代码块，尤其是在已设置了属性值时。大多数情况下，如果可能，最好避免使用它。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript 保留字

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript 保留字

  • Previous Page
  • Next Page

本节提供完整的 ECMAScript 保留字列表。

ECMAScript 保留字

ECMA-262 定义了 ECMAScript 支持的一套保留字（reserved word）。

保留字在某种意思上是为将来的关键字而保留的单词。因此保留字不能被用作变量名或函数名。

ECMA-262 第三版中保留字的完整列表如下：

abstract
boolean
byte
char
class
const
debugger
double
enum
export
extends
final
float
goto
implements
import
int
interface
long
native
package
private
protected
public
short
static
super
synchronized
throws
transient
volatile

注意：如果把关键字用作变量名或函数名，那么除非将来的浏览器实现了该保留字，否则很可能收不到任何错误消息。当浏览器将其实现后，该单词将被看做关键字，如此将出现关键字错误。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript 闭包

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript 闭包（closure）

  • Previous Page
  • Next Page

ECMAScript 最易让人误解的一点是，它支持闭包（closure）。

闭包，指的是词法表示包括不被计算的变量的函数，也就是说，函数可以使用函数之外定义的变量。

简单的闭包实例

在 ECMAScript 中使用全局变量是一个简单的闭包实例。请思考下面这段代码：

var sMessage = "hello world";

function sayHelloWorld() {
  alert(sMessage);
}

sayHelloWorld();

在上面这段代码中，脚本被载入内存后，并没有为函数 sayHelloWorld() 计算变量 sMessage 的值。该函数捕获 sMessage 的值只是为了以后的使用，也就是说，解释程序知道在调用该函数时要检查 sMessage 的值。sMessage 将在函数调用 sayHelloWorld() 时（最后一行）被赋值，显示消息 "hello world"。

复杂的闭包实例

在一个函数中定义另一个会使闭包变得更加复杂。例如：

var iBaseNum = 10;

function addNum(iNum1, iNum2) {
  function doAdd() {
    return iNum1 + iNum2 + iBaseNum;
  }
  return doAdd();
}

这里，函数 addNum() 包括函数 doAdd() （闭包）。内部函数是一个闭包，因为它将获取外部函数的参数 iNum1 和 iNum2 以及全局变量 iBaseNum 的值。 addNum() 的最后一步调用了 doAdd()，把两个参数和全局变量相加，并返回它们的和。

这里要掌握的重要概念是，doAdd() 函数根本不接受参数，它使用的值是从执行环境中获取的。

可以看到，闭包是 ECMAScript 中非常强大多用的一部分，可用于执行复杂的计算。

提示：就像使用任何高级函数一样，使用闭包要小心，因为它们可能会变得非常复杂。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript 变量

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript 变量

  • Previous Page
  • Next Page

请使用 var 运算符声明变量。

变量名需要遵守一些简单的规则。

声明变量

在上一节中我们讲解过，ECMAScript 中的变量是用 var 运算符（variable 的缩写）加变量名定义的。例如：

var test = "hi";

在这个例子中，声明了变量 test，并把它的值初始化为 "hi"（字符串）。由于 ECMAScript 是弱类型的，所以解释程序会为 test 自动创建一个字符串值，无需明确的类型声明。

还可以用一个 var 语句定义两个或多个变量：

var test1 = "hi", var test2 = "hello";

前面的代码定义了变量 test1，初始值为 "hi"，还定义了变量 test2，初始值为 "hello"。

不过用同一个 var 语句定义的变量不必具有相同的类型，如下所示：

var test = "hi", age = 25;

这个例子除了（再次）定义 test 外，还定义了 age，并把它初始化为 25。即使 test 和 age 属于两种不同的数据类型，在 ECMAScript 中这样定义也是完全合法的。

与 Java 不同，ECMAScript 中的变量并不一定要初始化（它们是在幕后初始化的，将在后面讨论这一点）。因此，下面这一行代码也是有效的：

var test;

此外，与 Java 不同的还有变量可以存放不同类型的值。这是弱类型变量的优势。例如，可以把变量初始化为字符串类型的值，之后把它设置为数字值，如下所示：

var test = "hi";
alert(test);
test = 55;
alert(test);

这段代码将毫无问题地输出字符串值和数字值。但是，如前所述，使用变量时，好的编码习惯是始终存放相同类型的值。

命名变量

变量名需要遵守两条简单的规则：

  • 第一个字符必须是字母、下划线（_）或美元符号（$）
  • 余下的字符可以是下划线、美元符号或任何字母或数字字符

下面的变量都是合法的：

var test;
var $test;
var $1;
var _$te$t2;

著名的变量命名规则

只是因为变量名的语法正确，并不意味着就该使用它们。变量还应遵守以下某条著名的命名规则：

Camel 标记法

首字母是小写的，接下来的字母都以大写字符开头。例如：

var myTestValue = 0, mySecondValue = "hi";

Pascal 标记法

首字母是大写的，接下来的字母都以大写字符开头。例如：

var MyTestValue = 0, MySecondValue = "hi";

匈牙利类型标记法

在以 Pascal 标记法命名的变量前附加一个小写字母（或小写字母序列），说明该变量的类型。例如，i 表示整数，s 表示字符串，如下所示“

var iMyTestValue = 0, sMySecondValue = "hi";

本教程采用了这些前缀，以使示例代码更易阅读：

类型 | 前缀 | 示例
数组 | a | aValues
布尔型 | b | bFound
浮点型（数字） | f | fValue
函数 | fn | fnMethod
整型（数字） | i | iValue
对象 | o | oType
正则表达式 | re | rePattern
字符串 | s | sValue
变型（可以是任何类型） | v | vValue

变量声明不是必须的

ECMAScript 另一个有趣的方面（也是与大多数程序设计语言的主要区别），是在使用变量之前不必声明。例如：

var sTest = "hello ";
sTest2 = sTest + "world";
alert(sTest2);

在上面的代码中，首先，sTest 被声明为字符串类型的值 "hello"。接下来的一行，用变量 sTest2 把 sTest 与字符串 "world" 连在一起。变量 sTest2 并没有用 var 运算符定义，这里只是插入了它，就像已经声明过它一样。

ECMAScript 的解释程序遇到未声明过的标识符时，用该变量名创建一个全局变量，并将其初始化为指定的值。

这是该语言的便利之处，不过如果不能紧密跟踪变量，这样做也很危险。最好的习惯是像使用其他程序设计语言一样，总是所有变量。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript 标签语句

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript 标签语句

  • Previous Page
  • Next Page

有标签的语句

可以用下列语句给语句加标签，以便以后调用：

label : statement

例如：

start : i = 5;

在这个例子中，标签 start 可以被之后的 break 或 continue 语句引用。

提示：在下面的章节，我们将为您介绍 break 和 continue 语句。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript 乘性运算符

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript 乘性运算符

  • Previous Page
  • Next Page

ECMAScript 的乘性运算符与 Java、C、Perl 等于语言中的同类运算符的运算方式相似。

需要注意的是，乘性运算符还具有一些自动转换功能。

乘法运算符

乘法运算符由星号（*）表示，用于两数相乘。

ECMAScript 中的乘法语法与 C 语言中的相同：

var iResult = 12 * 34

不过，在处理特殊值时，ECMAScript 中的乘法还有一些特殊行为：

  • 如果结果太大或太小，那么生成的结果是 Infinity 或 -Infinity。
  • 如果某个运算数是 NaN，结果为 NaN。
  • Infinity 乘以 0，结果为 NaN。
  • Infinity 乘以 0 以外的任何数字，结果为 Infinity 或 -Infinity。
  • Infinity 乘以 Infinity，结果为 Infinity。

注释：如果运算数是数字，那么执行常规的乘法运算，即两个正数或两个负数为正数，两个运算数符号不同，结果为负数。

除法运算符

除法运算符由斜杠（/）表示，用第二个运算数除第一个运算数：

var iResult = 88 /11;

与乘法运算符相似，在处理特殊值时，除法运算符也有一些特殊行为：

  • 如果结果太大或太小，那么生成的结果是 Infinity 或 -Infinity。
  • 如果某个运算数是 NaN，结果为 NaN。
  • Infinity 被 Infinity 除，结果为 NaN。
  • Infinity 被任何数字除，结果为 Infinity。
  • 0 除一个任何非无穷大的数字，结果为 NaN。
  • Infinity 被 0 以外的任何数字除，结果为 Infinity 或 -Infinity。

注释：如果运算数是数字，那么执行常规的除法运算，即两个正数或两个负数为正数，两个运算数符号不同，结果为负数。

取模运算符

除法（余数）运算符由百分号（%）表示，使用方法如下：

var iResult = 26%5; //等于 1

与其他乘性运算符相似，对于特殊值，取模运算符也有特殊的行为：

  • 如果被除数是 Infinity，或除数是 0，结果为 NaN。
  • Infinity 被 Infinity 除，结果为 NaN。
  • 如果除数是无穷大的数，结果为被除数。
  • 如果被除数为 0，结果为 0。

注释：如果运算数是数字，那么执行常规的算术除法运算，返回除法运算得到的余数。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript 等性运算符

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript 等性运算符

  • Previous Page
  • Next Page

判断两个变量是否相等是程序设计中非常重要的运算。在处理原始值时，这种运算相当简单，但涉及对象，任务就稍有点复杂。

ECMAScript 提供了两套等性运算符：等号和非等号用于处理原始值，全等号和非全等号用于处理对象。

等号和非等号

在 ECMAScript 中，等号由双等号（==）表示，当且仅当两个运算数相等时，它返回 true。非等号由感叹号加等号（!=）表示，当且仅当两个运算数不相等时，它返回 true。为确定两个运算数是否相等，这两个运算符都会进行类型转换。

执行类型转换的规则如下：

  • 如果一个运算数是 Boolean 值，在检查相等性之前，把它转换成数字值。false 转换成 0，true 为 1。
  • 如果一个运算数是字符串，另一个是数字，在检查相等性之前，要尝试把字符串转换成数字。
  • 如果一个运算数是对象，另一个是字符串，在检查相等性之前，要尝试把对象转换成字符串。
  • 如果一个运算数是对象，另一个是数字，在检查相等性之前，要尝试把对象转换成数字。

在比较时，该运算符还遵守下列规则：

  • 值 null 和 undefined 相等。
  • 在检查相等性时，不能把 null 和 undefined 转换成其他值。
  • 如果某个运算数是 NaN，等号将返回 false，非等号将返回 true。
  • 如果两个运算数都是对象，那么比较的是它们的引用值。如果两个运算数指向同一对象，那么等号返回 true，否则两个运算数不等。

重要提示：即使两个数都是 NaN，等号仍然返回 false，因为根据规则，NaN 不等于 NaN。

下表列出了一些特殊情况，以及它们的结果：

表达式 | 值
null == undefined | true
"NaN" == NaN | false
5 == NaN | false
NaN == NaN | false
NaN != NaN | true
false == 0 | true
true == 1 | true
true == 2 | false
undefined == 0 | false
null == 0 | false
"5" == 5 | true

全等号和非全等号

等号和非等号的同类运算符是全等号和非全等号。这两个运算符所做的与等号和非等号相同，只是它们在检查相等性前，不执行类型转换。

全等号由三个等号表示（===），只有在无需类型转换运算数就相等的情况下，才返回 true。

例如：

var sNum = "66";
var iNum = 66;
alert(sNum == iNum);	//输出 "true"
alert(sNum === iNum);	//输出 "false"

在这段代码中，第一个 alert 使用等号来比较字符串 "66" 和数字 66，输出 "true"。如前所述，这是因为字符串 "66" 将被转换成数字 66，，然后才与另一个数字 66 进行比较。第二个 alert 使用全等号在没有类型转换的情况下比较字符串和数字，当然，字符串不等于数字，所以输出 "false"。

非全等号由感叹号加两个等号（!==）表示，只有在无需类型转换运算数不相等的情况下，才返回 true。

例如：

var sNum = "66";
var iNum = 66;
alert(sNum != iNum);	//输出 "false"
alert(sNum !== iNum);	//输出 "true"

这里，第一个 alert 使用非等号，把字符串 "66" 转换成数字 66，使得它与第二个运算数 66 相等。因此，计算结果为 "false"，因为两个运算数是相等的。第二个 alert 使用的非全等号。该运算是在问："sNum" 与 "iNum" 不同吗？这个问题的答案是：是的（true），因为 sNum 是字符串，而 iNum 是数字，它们当然不同。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript 迭代语句

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript 迭代语句

  • Previous Page
  • Next Page

迭代语句又叫循环语句，声明一组要反复执行的命令，直到满足某些条件为止。

循环通常用于迭代数组的值（因此而得名），或者执行重复的算术任务。

本节为您介绍 ECMAScript 提供的四种迭代语句。

do-while 语句

do-while 语句是后测试循环，即退出条件在执行循环内部的代码之后计算。这意味着在计算表达式之前，至少会执行循环主体一次。

它的语法如下：

do {statement} while (expression);

例子：

var i = 0;
do {i += 2;} while (i < 10);

while 语句

while 语句是前测试循环。这意味着退出条件是在执行循环内部的代码之前计算的。因此，循环主体可能根本不被执行。

它的语法如下：

while (expression) statement

例子：

var i = 0;
while (i < 10) {
  i += 2;
}

for 语句

for 语句是前测试循环，而且在进入循环之前，能够初始化变量，并定义循环后要执行的代码。

它的语法如下：

for (initialization; expression; post-loop-expression) statement

注意：post-loop-expression 之后不能写分号，否则无法运行。

例子：

iCount = 6;
for (var i = 0; i < iCount; i++) {
  alert(i);
}

这段代码定义了初始值为 0 的变量 i。只有当条件表达式（i < iCount）的值为 true 时，才进入 for 循环，这样循环主体可能不被执行。如果执行了循环主体，那么将执行循环后表达式，并迭代变量 i。

for-in 语句

for 语句是严格的迭代语句，用于枚举对象的属性。

它的语法如下：

for (property in expression) statement

例子：

for (sProp in window) {
  alert(sProp);
}

这里，for-in 语句用于显示 window 对象的所有属性。

前面讨论过的 PropertyIsEnumerable() 是 ECMAScript 中专门用于说明属性是否可以用 for-in 语句访问的方法。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript 逗号运算符

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript 逗号运算符

  • Previous Page
  • Next Page

逗号运算符

用逗号运算符可以在一条语句中执行多个运算。

例如：

var iNum1 = 1, iNum = 2, iNum3 = 3;

逗号运算符常用变量声明中。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript 赋值运算符

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript 赋值运算符

  • Previous Page
  • Next Page

赋值运算符

简单的赋值运算符由等号（=）实现，只是把等号右边的值赋予等号左边的变量。

例如：

var iNum = 10;

复合赋值运算是由乘性运算符、加性运算符或位移运算符加等号（=）实现的。这些赋值运算符是下列这些常见情况的缩写形式：

var iNum = 10;
iNum = iNum + 10；

可以用一个复合赋值运算符改写第二行代码：

var iNum = 10;
iNum += 10；

每种主要的算术运算以及其他几个运算都有复合赋值运算符：

  • 乘法/赋值（*=）
  • 除法/赋值（/=）
  • 取模/赋值（%=）
  • 加法/赋值（+=）
  • 减法/赋值（-=）
  • 左移/赋值（<<=）
  • 有符号右移/赋值（>>=）
  • 无符号右移/赋值（>>>=）
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript 关键字

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript 关键字

  • Previous Page
  • Next Page

本节提供完整的 ECMAScript 关键字列表。

ECMAScript 关键字

ECMA-262 定义了 ECMAScript 支持的一套关键字（keyword）。

这些关键字标识了 ECMAScript 语句的开头和/或结尾。根据规定，关键字是保留的，不能用作变量名或函数名。

下面是 ECMAScript 关键字的完整列表：

break
case
catch
continue
default
delete
do
else
finally
for
function
if
in
instanceof
new
return
switch
this
throw
try
typeof
var
void
while
with

注意：如果把关键字用作变量名或函数名，可能得到诸如 "Identifier Expected"（应该有标识符、期望标识符）这样的错误消息。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript 关系运算符

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript 关系运算符

  • Previous Page
  • Next Page

关系运算符执行的是比较运算。每个关系运算符都返回一个布尔值。

常规比较方式

关系运算符小于、大于、小于等于和大于等于执行的是两个数的比较运算，比较方式与算术比较运算相同。

每个关系运算符都返回一个布尔值：

var bResult1 = 2 > 1	//true
var bResult2 = 2 < 1	//false

不过，对两个字符串应用关系运算符，它们的行为则不同。许多人认为小于表示“在字母顺序上靠前”，大于表示“在字母顺序上靠后”，但事实并非如此。对于字符串，第一个字符串中每个字符的代码都与会第二个字符串中对应位置的字符的代码进行数值比较。完成这种比较操作后，返回一个 Boolean 值。问题在于大写字母的代码都小于小写字母的代码，这意味这着可能会遇到下列情况：

var bResult = "Blue" < "alpha";
alert(bResult);	//输出 true

在上面的例子中，字符串 "Blue" 小于 "alpha"，因为字母 B 的字符代码是 66，字母 a 的字符代码是 97。要强制性得到按照真正的字母顺序比较的结果，必须把两个数转换成相同的大小写形式（全大写或全小写的），然后再进行比较：

var bResult = "Blue".toLowerCase() < "alpha".toLowerCase();
alert(bResult);	//输出 false

把两个运算数都转换成小写，确保了正确识别出 "alpha" 在字母顺序上位于 "Blue" 之前。

比较数字和字符串

另一种棘手的状况发生在比较两个字符串形式的数字时，比如：

var bResult = "25" < "3";
alert(bResult);	//输出 "true"

上面这段代码比较的是字符串 "25" 和 "3"。两个运算数都是字符串，所以比较的是它们的字符代码（"2" 的字符代码是 50，"3" 的字符代码是 51）。

不过，如果把某个运算数该为数字，那么结果就有趣了：

var bResult = "25" < 3;
alert(bResult);	//输出 "false"

这里，字符串 "25" 将被转换成数字 25，然后与数字 3 进行比较，结果不出所料。

无论何时比较一个数字和一个字符串，ECMAScript 都会把字符串转换成数字，然后按照数字顺序比较它们。

不过，如果字符串不能转换成数字又该如何呢？考虑下面的例子：

var bResult = "a" < 3;
alert(bResult);

你能预料到这段代码输出什么吗？字母 "a" 不能转换成有意义的数字。不过，如果对它调用 parseInt() 方法，返回的是 NaN。根据规则，任何包含 NaN 的关系运算符都要返回 false，因此这段代码也输出 false：

var bResult = "a" >= 3;
alert(bResult);

通常，如果小于运算的两个值返回 false，那么大于等于运算必须返回 true，不过如果某个数字是 NaN，情况则非如此。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript 函数概述

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript 函数概述

  • Previous Page
  • Next Page

什么是函数？

函数是一组可以随时随地运行的语句。

函数是 ECMAScript 的核心。

函数是由这样的方式进行声明的：关键字 function、函数名、一组参数，以及置于括号中的待执行代码。

函数的基本语法是这样的：

function functionName(arg0, arg1, ... argN) {
  statements
}

例如：

function sayHi(sName, sMessage) {
  alert("Hello " + sName + sMessage);
}

如何调用函数？

函数可以通过其名字加上括号中的参数进行调用，如果有多个参数。

如果您想调用上例中的那个函数，可以使用如下的代码：

sayHi("David", " Nice to meet you!")

调用上面的函数 sayHi() 会生成一个警告窗口。您可以亲自试一试这个例子。

函数如何返回值？

函数 sayHi() 未返回值，不过不必专门声明它（像在 Java 中使用 void 那样）。

即使函数确实有值，也不必明确地声明它。该函数只需要使用 return 运算符后跟要返回的值即可。

function sum(iNum1, iNum2) {
  return iNum1 + iNum2;
}

下面的代码把 sum 函数返回的值赋予一个变量：

var iResult = sum(1,1);
alert(iResult);	//输出 "2"

另一个重要概念是，与在 Java 中一样，函数在执行过 return 语句后立即停止代码。因此，return 语句后的代码都不会被执行。

例如，在下面的代码中，alert 窗口就不会显示出来：

function sum(iNum1, iNum2) {
  return iNum1 + iNum2;
  alert(iNum1 + iNum2);
}

一个函数中可以有多个 return 语句，如下所示：

function diff(iNum1, iNum2) {
  if (iNum1 > iNum2) {
    return iNum1 - iNum2;
  } else {
    return iNum2 - iNum1;
  }
}

上面的函数用于返回两个数的差。要实现这一点，必须用较大的数减去较小的数，因此用 if 语句决定执行哪个 return 语句。

如果函数无返回值，那么可以调用没有参数的 return 运算符，随时退出函数。

例如：

function sayHi(sMessage) {
  if (sMessage == "bye") {
    return;
  }

  alert(sMessage);
}

这段代码中，如果 sMessage 等于 "bye"，就永远不显示警告框。

注释：如果函数无明确的返回值，或调用了没有参数的 return 语句，那么它真正返回的值是 undefined。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript 函数概述

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript arguments 对象

  • Previous Page
  • Next Page

arguments 对象

在函数代码中，使用特殊对象 arguments，开发者无需明确指出参数名，就能访问它们。

例如，在函数 sayHi() 中，第一个参数是 message。用 arguments[0] 也可以访问这个值，即第一个参数的值（第一个参数位于位置 0，第二个参数位于位置 1，依此类推）。

因此，无需明确命名参数，就可以重写函数：

function sayHi() {
  if (arguments[0] == "bye") {
    return;
  }

  alert(arguments[0]);
}

检测参数个数

还可以用 arguments 对象检测函数的参数个数，引用属性 arguments.length 即可。

下面的代码将输出每次调用函数使用的参数个数：

function howManyArgs() {
  alert(arguments.length);
}

howManyArgs("string", 45);
howManyArgs();
howManyArgs(12);

上面这段代码将依次显示 "2"、"0" 和 "1"。

注释：与其他程序设计语言不同，ECMAScript 不会验证传递给函数的参数个数是否等于函数定义的参数个数。开发者定义的函数都可以接受任意个数的参数（根据 Netscape 的文档，最多可接受 25 个），而不会引发任何错误。任何遗漏的参数都会以 undefined 传递给函数，多余的函数将忽略。

模拟函数重载

用 arguments 对象判断传递给函数的参数个数，即可模拟函数重载：

function doAdd() {
  if(arguments.length == 1) {
    alert(arguments[0] + 5);
  } else if(arguments.length == 2) {
    alert(arguments[0] + arguments[1]);
  }
}

doAdd(10);	//输出 "15"
doAdd(40, 20);	//输出 "60"

当只有一个参数时，doAdd() 函数给参数加 5。如果有两个参数，则会把两个参数相加，返回它们的和。所以，doAdd(10) 输出的是 "15"，而 doAdd(40, 20) 输出的是 "60"。

虽然不如重载那么好，不过已足以避开 ECMAScript 的这种限制。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript 加性运算符

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript 加性运算符

  • Previous Page
  • Next Page

在多数程序设计语言中，加性运算符（即加号或减号）通常是最简单的数学运算符。

在 ECMAScript 中，加性运算符有大量的特殊行为。

加法运算符

法运算符由加号（+）表示：

var iResult = 1 + 2

与乘性运算符一样，在处理特殊值时，ECMAScript 中的加法也有一些特殊行为：

  • 某个运算数是 NaN，那么结果为 NaN。
  • -Infinity 加 -Infinity，结果为 -Infinity。
  • Infinity 加 -Infinity，结果为 NaN。
  • +0 加 +0，结果为 +0。
  • -0 加 +0，结果为 +0。
  • -0 加 +0，结果为 -0。

不过，如果某个运算数是字符串，那么采用下列规则：

  • 如果两个运算数都是字符串，把第二个字符串连接到第一个上。
  • 如果只有一个运算数是字符串，把另一个运算数转换成字符串，结果是两个字符串连接成的字符串。

例如：

var result = 5 + 5;	//两个数字
alert(result);		//输出 "10"
var result2 = 5 + "5";	//一个数字和一个字符串
alert(result);		//输出 "55"

这段代码说明了加法运算符的两种模式之间的差别。正常情况下，5+5 等于 10（原始数值），如上述代码中前两行所示。不过，如果把一个运算数改为字符串 "5"，那么结果将变为 "55"（原始的字符串值），因为另一个运算数也会被转换为字符串。

注意：为了避免 JavaScript 中的一种常见错误，在使用加法运算符时，一定要仔细检查运算数的数据类型。

减法运算符

减法运算符（-），也是一个常用的运算符：

var iResult = 2 - 1;

与加法运算符一样，在处理特殊值时，减法运算符也有一些特殊行为：

  • 某个运算数是 NaN，那么结果为 NaN。
  • -Infinity 减 Infinity，结果为 NaN。
  • -Infinity 减 -Infinity，结果为 NaN。
  • Infinity 减 -Infinity，结果为 Infinity。
  • -Infinity 减 Infinity，结果为 -Infinity。
  • +0 减 +0，结果为 +0。
  • -0 减 -0，结果为 -0。
  • +0 减 -0，结果为 +0。
  • 某个运算符不是数字，那么结果为 NaN。

注释：如果运算数都是数字，那么执行常规的减法运算，并返回结果。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript 类型转换

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript 类型转换

  • Previous Page
  • Next Page

所有程序设计语言最重要的特征之一是具有进行类型转换的能力。

ECMAScript 给开发者提供了大量简单的类型转换方法。

大部分类型具有进行简单转换的方法，还有几个全局方法可以用于更复杂的转换。无论哪种情况，在 ECMAScript 中，类型转换都是简短的一步操作。

转换成字符串

ECMAScript 的 Boolean 值、数字和字符串的原始值的有趣之处在于它们是伪对象，这意味着它们实际上具有属性和方法。

例如，要获得字符串的长度，可以采用下面的代码：

var sColor = "red";
alert(sColor.length);	//输出 "3"

尽管 "red" 是原始类型的字符串，它仍然具有属性 length，用于存放字符串的大小。

总而言之，3 种主要的原始类型 Boolean 值、数字和字符串都有 toString() 方法，可以把它们的值转换成字符串。

提示：您也许会问，“字符串还有 toString() 方法吗，这不是多余吗？”是的，的确如此，不过 ECMAScript 定义所有对象都有 toString() 方法，无论它是伪对象，还是真对象。因为 String 类型属于伪对象，所以它一定有 toString() 方法。

Boolean 类型的 toString() 方法只是输出 "true" 或 "false"，结果由变量的值决定：

var bFound = false;
alert(bFound.toString());	//输出 "false"

Number 类型的 toString() 方法比较特殊，它有两种模式，即默认模式和基模式。采用默认模式，toString() 方法只是用相应的字符串输出数字值（无论是整数、浮点数还是科学计数法），如下所示：

var iNum1 = 10;
var iNum2 = 10.0;
alert(iNum1.toString());	//输出 "10"
alert(iNum2.toString());	//输出 "10"

注释：在默认模式中，无论最初采用什么表示法声明数字，Number 类型的 toString() 方法返回的都是数字的十进制表示。因此，以八进制或十六进制字面量形式声明的数字输出的都是十进制形式的。

采用 Number 类型的 toString() 方法的基模式，可以用不同的基输出数字，例如二进制的基是 2，八进制的基是 8，十六进制的基是 16。

基只是要转换成的基数的另一种加法而已，它是 toString() 方法的参数：

var iNum = 10;
alert(iNum1.toString(2));	//输出 "1010"
alert(iNum1.toString(8));	//输出 "12"
alert(iNum1.toString(16));	//输出 "A"

在前面的示例中，以 3 种不同的形式输出了数字 10，即二进制形式、八进制形式和十六进制形式。HTML 采用十六进制表示每种颜色，在 HTML 中处理数字时这种功能非常有用。

注释：对数字调用 toString(10) 与调用 toString() 相同，它们返回的都是该数字的十进制形式。

参阅：

请参阅 JavaScript 参考手册提供的有关 toString() 方法的详细信息：

  • arrayObject.toString()
  • booleanObject.toString()
  • dateObject.toString()
  • NumberObject.toString()
  • stringObject.toString()

转换成数字

ECMAScript 提供了两种把非数字的原始值转换成数字的方法，即 parseInt() 和 parseFloat()。

正如您可能想到的，前者把值转换成整数，后者把值转换成浮点数。只有对 String 类型调用这些方法，它们才能正确运行；对其他类型返回的都是 NaN。

parseInt()

在判断字符串是否是数字值前，parseInt() 和 parseFloat() 都会仔细分析该字符串。

parseInt() 方法首先查看位置 0 处的字符，判断它是否是个有效数字；如果不是，该方法将返回 NaN，不再继续执行其他操作。但如果该字符是有效数字，该方法将查看位置 1 处的字符，进行同样的测试。这一过程将持续到发现非有效数字的字符为止，此时 parseInt() 将把该字符之前的字符串转换成数字。

例如，如果要把字符串 "12345red" 转换成整数，那么 parseInt() 将返回 12345，因为当它检查到字符 r 时，就会停止检测过程。

字符串中包含的数字字面量会被正确转换为数字，比如 "0xA" 会被正确转换为数字 10。不过，字符串 "22.5" 将被转换成 22，因为对于整数来说，小数点是无效字符。

一些示例如下：

var iNum1 = parseInt("12345red");	//返回 12345
var iNum1 = parseInt("0xA");	//返回 10
var iNum1 = parseInt("56.9");	//返回 56
var iNum1 = parseInt("red");	//返回 NaN

parseInt() 方法还有基模式，可以把二进制、八进制、十六进制或其他任何进制的字符串转换成整数。基是由 parseInt() 方法的第二个参数指定的，所以要解析十六进制的值，需如下调用 parseInt() 方法：

var iNum1 = parseInt("AF", 16);	//返回 175

当然，对二进制、八进制甚至十进制（默认模式），都可以这样调用 parseInt() 方法：

var iNum1 = parseInt("10", 2);	//返回 2
var iNum2 = parseInt("10", 8);	//返回 8
var iNum3 = parseInt("10", 10);	//返回 10

如果十进制数包含前导 0，那么最好采用基数 10，这样才不会意外地得到八进制的值。例如：

var iNum1 = parseInt("010");	//返回 8
var iNum2 = parseInt("010", 8);	//返回 8
var iNum3 = parseInt("010", 10);	//返回 10

在这段代码中，两行代码都把字符 "010" 解析成一个数字。第一行代码把这个字符串看作八进制的值，解析它的方式与第二行代码（声明基数为 8）相同。最后一行代码声明基数为 10，所以 iNum3 最后等于 10。

参阅

请参阅 JavaScript 参考手册提供的有关 parseInt() 方法的详细信息：parseInt()。

parseFloat()

parseFloat() 方法与 parseInt() 方法的处理方式相似，从位置 0 开始查看每个字符，直到找到第一个非有效的字符为止，然后把该字符之前的字符串转换成整数。

不过，对于这个方法来说，第一个出现的小数点是有效字符。如果有两个小数点，第二个小数点将被看作无效的。parseFloat() 会把这个小数点之前的字符转换成数字。这意味着字符串 "11.22.33" 将被解析成 11.22。

使用 parseFloat() 方法的另一不同之处在于，字符串必须以十进制形式表示浮点数，而不是用八进制或十六进制。该方法会忽略前导 0，所以八进制数 0102 将被解析为 102。对于十六进制数 0xA，该方法将返回 NaN，因为在浮点数中，x 不是有效字符。

此外，parseFloat() 方法也没有基模式。

下面是使用 parseFloat() 方法的一些示例：

var fNum1 = parseFloat("12345red");	//返回 12345
var fNum2 = parseFloat("0xA");	//返回 NaN
var fNum3 = parseFloat("11.2");	//返回 11.2
var fNum4 = parseFloat("11.22.33");	//返回 11.22
var fNum5 = parseFloat("0102");	//返回 102
var fNum1 = parseFloat("red");	//返回 NaN

参阅

请参阅 JavaScript 参考手册提供的有关 parseFloat() 方法的详细信息：parseFloat()。

强制类型转换

您还可以使用强制类型转换（type casting）来处理转换值的类型。使用强制类型转换可以访问特定的值，即使它是另一种类型的。

编者注：cast 有“铸造”之意，很贴合“强制转换”的意思。

ECMAScript 中可用的 3 种强制类型转换如下：

  • Boolean(value) - 把给定的值转换成 Boolean 型；
  • Number(value) - 把给定的值转换成数字（可以是整数或浮点数）；
  • String(value) - 把给定的值转换成字符串；

用这三个函数之一转换值，将创建一个新值，存放由原始值直接转换成的值。这会造成意想不到的后果。

Boolean() 函数

当要转换的值是至少有一个字符的字符串、非 0 数字或对象时，Boolean() 函数将返回 true。如果该值是空字符串、数字 0、undefined 或 null，它将返回 false。

可以用下面的代码测试 Boolean 型的强制类型转换：

var b1 = Boolean("");		//false - 空字符串
var b2 = Boolean("hello");		//true - 非空字符串
var b1 = Boolean(50);		//true - 非零数字
var b1 = Boolean(null);		//false - null
var b1 = Boolean(0);		//false - 零
var b1 = Boolean(new object());	//true - 对象

Number() 函数

Number() 函数的强制类型转换与 parseInt() 和 parseFloat() 方法的处理方式相似，只是它转换的是整个值，而不是部分值。

还记得吗，parseInt() 和 parseFloat() 方法只转换第一个无效字符之前的字符串，因此 "1.2.3" 将被转换为 "4.5"。

用 Number() 进行强制类型转换，"1.2.3" 将返回 NaN，因为整个字符串值不能转换成数字。如果字符串值能被完整地转换，Number() 将判断是调用 parseInt() 方法还是 parseFloat() 方法。

下表说明了对不同的值调用 Number() 方法会发生的情况：

用法 | 结果
Number(false) | 0
Number(true) | 1
Number(undefined) | NaN
Number(null) | 0
Number("1.2") | 1.2
Number("12") | 12
Number("1.2.3") | NaN
Number(new object()) | NaN
Number(50) | 50

String() 函数

最后一种强制类型转换方法 String() 是最简单的，因为它可把任何值转换成字符串。

要执行这种强制类型转换，只需要调用作为参数传递进来的值的 toString() 方法，即把 12 转换成 "12"，把 true 转换成 "true"，把 false 转换成 "false"，以此类推。

强制转换成字符串和调用 toString() 方法的唯一不同之处在于，对 null 和 undefined 值强制类型转换可以生成字符串而不引发错误：

var s1 = String(null);	//"null"
var oNull = null;
var s2 = oNull.toString();	//会引发错误

在处理 ECMAScript 这样的弱类型语言时，强制类型转换非常有用，不过应该确保使用值的正确。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript 条件运算符

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript 条件运算符

  • Previous Page
  • Next Page

条件运算符

条件运算符是 ECMAScript 中功能最多的运算符，它的形式与 Java 中的相同。

variable = boolean_expression ? true_value : false_value;

该表达式主要是根据 boolean_expression 的计算结果有条件地为变量赋值。如果 Boolean_expression 为 true，就把 true_value 赋给变量；如果它是 false，就把 false_value 赋给变量。

例如：

var iMax = (iNum1 > iNum2) ? iNum1 : iNum2;

在这里例子中，iMax 将被赋予数字中的最大值。表达式声明如果 iNum1 大于 iNum2，则把 iNum1 赋予 iMax。但如果表达式为 false（即 iNum2 大于或等于 iNum1），则把 iNum2 赋予 iMax。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript 位运算符

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript 位运算符

  • Previous Page
  • Next Page

位运算符是在数字底层（即表示数字的 32 个数位）进行操作的。

重温整数

ECMAScript 整数有两种类型，即有符号整数（允许用正数和负数）和无符号整数（只允许用正数）。在 ECMAScript 中，所有整数字面量默认都是有符号整数，这意味着什么呢？

有符号整数使用 31 位表示整数的数值，用第 32 位表示整数的符号，0 表示正数，1 表示负数。数值范围从 -2147483648 到 2147483647。

可以以两种不同的方式存储二进制形式的有符号整数，一种用于存储正数，一种用于存储负数。正数是以真二进制形式存储的，前 31 位中的每一位都表示 2 的幂，从第 1 位（位 0）开始，表示 20，第 2 位（位 1）表示 21。没用到的位用 0 填充，即忽略不计。例如，下图展示的是数 18 的表示法。

18 的二进制版本只用了前 5 位，它们是这个数字的有效位。把数字转换成二进制字符串，就能看到有效位：

var iNum = 18;
alert(iNum.toString(2));	//输出 "10010"

这段代码只输出 "10010"，而不是 18 的 32 位表示。其他的数位并不重要，因为仅使用前 5 位即可确定这个十进制数值。如下图所示：

5 位二进制表示的整数 18

负数也存储为二进制代码，不过采用的形式是二进制补码。计算数字二进制补码的步骤有三步：

  1. 确定该数字的非负版本的二进制表示（例如，要计算 -18的二进制补码，首先要确定 18 的二进制表示）
  2. 求得二进制反码，即要把 0 替换为 1，把 1 替换为 0
  3. 在二进制反码上加 1

要确定 -18 的二进制表示，首先必须得到 18 的二进制表示，如下所示：

0000 0000 0000 0000 0000 0000 0001 0010

接下来，计算二进制反码，如下所示：

1111 1111 1111 1111 1111 1111 1110 1101

最后，在二进制反码上加 1，如下所示：

1111 1111 1111 1111 1111 1111 1110 1101
                                      1
---------------------------------------
1111 1111 1111 1111 1111 1111 1110 1110

因此，-18 的二进制表示即 1111 1111 1111 1111 1111 1111 1110 1110。记住，在处理有符号整数时，开发者不能访问 31 位。

有趣的是，把负整数转换成二进制字符串后，ECMAScript 并不以二进制补码的形式显示，而是用数字绝对值的标准二进制代码前面加负号的形式输出。例如：

var iNum = -18;
alert(iNum.toString(2));	//输出 "-10010"

这段代码输出的是 "-10010"，而非二进制补码，这是为避免访问位 31。为了简便，ECMAScript 用一种简单的方式处理整数，使得开发者不必关心它们的用法。

另一方面，无符号整数把最后一位作为另一个数位处理。在这种模式中，第 32 位不表示数字的符号，而是值 231。由于这个额外的位，无符号整数的数值范围为 0 到 4294967295。对于小于 2147483647 的整数来说，无符号整数看来与有符号整数一样，而大于 2147483647 的整数则要使用位 31（在有符号整数中，这一位总是 0）。

把无符号整数转换成字符串后，只返回它们的有效位。

注意：所有整数字面量都默认存储为有符号整数。只有 ECMAScript 的位运算符才能创建无符号整数。

位运算 NOT

位运算 NOT 由否定号（~）表示，它是 ECMAScript 中为数不多的与二进制算术有关的运算符之一。

位运算 NOT 是三步的处理过程：

  1. 把运算数转换成 32 位数字
  2. 把二进制数转换成它的二进制反码
  3. 把二进制数转换成浮点数

例如：

var iNum1 = 25;		//25 等于 00000000000000000000000000011001
var iNum2 = ~iNum1;	//转换为 11111111111111111111111111100110
alert(iNum2);		//输出 "-26"

位运算 NOT 实质上是对数字求负，然后减 1，因此 25 变 -26。用下面的方法也可以得到同样的方法：

var iNum1 = 25;
var iNum2 = -iNum1 -1;
alert(iNum2);	//输出 -26

位运算 AND

位运算 AND 由和号（&）表示，直接对数字的二进制形式进行运算。它把每个数字中的数位对齐，然后用下面的规则对同一位置上的两个数位进行 AND 运算：

第一个数字中的数位 | 第二个数字中的数位 | 结果
1 | 1 | 1
1 | 0 | 0
0 | 1 | 0
0 | 0 | 0

例如，要对数字 25 和 3 进行 AND 运算，代码如下所示：

var iResult = 25 & 3;
alert(iResult);	//输出 "1"

25 和 3 进行 AND 运算的结果是 1。为什么？分析如下：

 25 = 0000 0000 0000 0000 0000 0000 0001 1001
  3 = 0000 0000 0000 0000 0000 0000 0000 0011
---------------------------------------------
AND = 0000 0000 0000 0000 0000 0000 0000 0001

可以看出，在 25 和 3 中，只有一个数位（位 0）存放的都是 1，因此，其他数位生成的都是 0，所以结果为 1。

位运算 OR

位运算 OR 由符号（|）表示，也是直接对数字的二进制形式进行运算。在计算每位时，OR 运算符采用下列规则：

第一个数字中的数位 | 第二个数字中的数位 | 结果
1 | 1 | 1
1 | 0 | 1
0 | 1 | 1
0 | 0 | 0

仍然使用 AND 运算符所用的例子，对 25 和 3 进行 OR 运算，代码如下：

var iResult = 25 | 3;
alert(iResult);	//输出 "27"

25 和 3 进行 OR 运算的结果是 27：

25 = 0000 0000 0000 0000 0000 0000 0001 1001
 3 = 0000 0000 0000 0000 0000 0000 0000 0011
--------------------------------------------
OR = 0000 0000 0000 0000 0000 0000 0001 1011

可以看出，在两个数字中，共有 4 个数位存放的是 1，这些数位被传递给结果。二进制代码 11011 等于 27。

位运算 XOR

位运算 XOR 由符号（^）表示，当然，也是直接对二进制形式进行运算。XOR 不同于 OR，当只有一个数位存放的是 1 时，它才返回 1。真值表如下：

第一个数字中的数位 | 第二个数字中的数位 | 结果
1 | 1 | 0
1 | 0 | 1
0 | 1 | 1
0 | 0 | 0

对 25 和 3 进行 XOR 运算，代码如下：

var iResult = 25 ^ 3;
alert(iResult);	//输出 "26"

25 和 3 进行 XOR 运算的结果是 26：

 25 = 0000 0000 0000 0000 0000 0000 0001 1001
  3 = 0000 0000 0000 0000 0000 0000 0000 0011
---------------------------------------------
XOR = 0000 0000 0000 0000 0000 0000 0001 1010

可以看出，在两个数字中，共有 4 个数位存放的是 1，这些数位被传递给结果。二进制代码 11010 等于 26。

左移运算

左移运算由两个小于号表示（<<）。它把数字中的所有数位向左移动指定的数量。例如，把数字 2（等于二进制中的 10）左移 5 位，结果为 64（等于二进制中的 1000000）：

var iOld = 2;		//等于二进制 10
var iNew = iOld << 5;	//等于二进制 1000000 十进制 64

注意：在左移数位时，数字右边多出 5 个空位。左移运算用 0 填充这些空位，使结果成为完整的 32 位数字。

数字 2 进行左移运算

注意：左移运算保留数字的符号位。例如，如果把 -2 左移 5 位，得到的是 -64，而不是 64。“符号仍然存储在第 32 位中吗？”是的，不过这在 ECMAScript 后台进行，开发者不能直接访问第 32 个数位。即使输出二进制字符串形式的负数，显示的也是负号形式（例如，-2 将显示 -10。）

有符号右移运算

有符号右移运算符由两个大于号表示（>>）。它把 32 位数字中的所有数位整体右移，同时保留该数的符号（正号或负号）。有符号右移运算符恰好与左移运算相反。例如，把 64 右移 5 位，将变为 2：

var iOld = 64;		//等于二进制 1000000
var iNew = iOld >> 5;	//等于二进制 10 十进制 2

同样，移动数位后会造成空位。这次，空位位于数字的左侧，但位于符号位之后。ECMAScript 用符号位的值填充这些空位，创建完整的数字，如下图所示：

数字 64 进行有符号右移运算

无符号右移运算

无符号右移运算符由三个大于号（>>>）表示，它将无符号 32 位数的所有数位整体右移。对于正数，无符号右移运算的结果与有符号右移运算一样。

用有符号右移运算中的例子，把 64 右移 5 位，将变为 2：

var iOld = 64;		//等于二进制 1000000
var iNew = iOld >>> 5;	//等于二进制 10 十进制 2

对于负数，情况就不同了。

无符号右移运算用 0 填充所有空位。对于正数，这与有符号右移运算的操作一样，而负数则被作为正数来处理。

由于无符号右移运算的结果是一个 32 位的正数，所以负数的无符号右移运算得到的总是一个非常大的数字。例如，如果把 -64 右移 5 位，将得到 134217726。如果得到这种结果的呢？

要实现这一点，需要把这个数字转换成无符号的等价形式（尽管该数字本身还是有符号的），可以通过以下代码获得这种形式：

var iUnsigned64 = -64 >>> 0;

然后，用 Number 类型的 toString() 获取它的真正的位表示，采用的基为 2：

alert(iUnsigned64.toString(2));

这将生成 11111111111111111111111111000000，即有符号整数 -64 的二进制补码表示，不过它等于无符号整数 4294967232。

出于这种原因，使用无符号右移运算符要小心。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript 一元运算符

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript 一元运算符

  • Previous Page
  • Next Page

一元运算符只有一个参数，即要操作的对象或值。它们是 ECMAScript 中最简单的运算符。

delete

delete 运算符删除对以前定义的对象属性或方法的引用。例如：

var o = new Object;
o.name = "David";
alert(o.name);	//输出 "David"
delete o.name;
alert(o.name);	//输出 "undefined"

在这个例子中，删除了 name 属性，意味着强制解除对它的引用，将其设置为 undefined（即创建的未初始化的变量的值）。

delete 运算符不能删除开发者未定义的属性和方法。例如，下面的代码将引发错误：

delete o.toString;

即使 toString 是有效的方法名，这行代码也会引发错误，因为 toString() 方法是原始的 ECMAScript 方法，不是开发者定义的。

void

void 运算符对任何值返回 undefined。该运算符通常用于避免输出不应该输出的值，例如，从 HTML 的 <a> 元素调用 JavaScript 函数时。要正确做到这一点，函数不能返回有效值，否则浏览器将清空页面，只显示函数的结果。例如：

<a href="javascript:window.open('about:blank')">Click me</a>

如果把这行代码放入 HTML 页面，点击其中的链接，即可看到屏幕上显示 "[object]"。TIY

这是因为 window.open() 方法返回了新打开的窗口的引用。然后该对象将被转换成要显示的字符串。

要避免这种效果，可以用 void 运算符调用 window.open() 函数：

<a href="javascript:void(window.open('about:blank'))">Click me</a>

这使 window.open() 调用返回 undefined，它不是有效值，不会显示在浏览器窗口中。

提示：请记住，没有返回值的函数真正返回的都是 undefined。

前增量/前减量运算符

直接从 C（和 Java）借用的两个运算符是前增量运算符和前减量运算符。

所谓前增量运算符，就是数值上加 1，形式是在变量前放两个加号（++）：

var iNum = 10;
++iNum;

第二行代码把 iNum 增加到了 11，它实质上等价于：

var iNum = 10;
iNum = iNum + 1；

同样，前减量运算符是从数值上减 1，形式是在变量前放两个减号（--）：

var iNum = 10;
--iNum;

在这个例子中，第二行代码把 iNum 的值减到 9。

在使用前缀式运算符时，注意增量和减量运算符都发生在计算表达式之前。考虑下面的例子：

var iNum = 10;
--iNum;
alert(iNum);	//输出 "9"
alert(--iNum);	//输出 "8"
alert(iNum);	//输出 "8"

第二行代码对 iNum 进行减量运算，第三行代码显示的结果是（"9"）。第四行代码又对 iNum 进行减量运算，不过这次前减量运算和输出操作出现在同一个语句中，显示的结果是 "8"。为了证明已实现了所有的减量操作，第五行代码又输出一次"8"。

在算术表达式中，前增量和前减量运算符的优先级是相同的，因此要按照从左到右的顺序计算之。例如：

var iNum1 = 2;
var iNum2 = 20;
var iNum3 = --iNum1 + ++iNum2;	//等于 "22"
var iNum4 = iNum1 + iNum2;		//等于 "22"

在前面的代码中，iNum3 等于 22，因为表达式要计算的是 1 + 21。变量 iNum4 也等于 22，也是 1 + 21。

后增量/后减量运算符

还有两个直接从 C（和 Java）借用的运算符，即后增量运算符和后减量运算符。

后增量运算符也是给数值上加 1，形式是在变量后放两个加号（++）：

var iNum = 10;
iNum++;

不出所料，后减量运算符也是从数值上减 1，形式为在变量后加两个减号（--）：

var iNum = 10;
iNum--;

第二行代码把 iNum 的 值减到 9。

与前缀式运算符不同的是，后缀式运算符是在计算过包含它们的表达式后才进行增量或减量运算的。考虑以下的例子：

var iNum = 10;
iNum--;
alert(iNum);	//输出 "9"
alert(iNum--);	//输出 "9"
alert(iNum);	//输出 "8"

与前缀式运算符的例子相似，第二行代码对 iNum 进行减量运算，第三行代码显示结果（"9"）。第四行代码继续显示 iNum 的值，不过这次是在同一语句中应用减量运算符。由于减量运算发生在计算过表达式之后，所以这条语句显示的数是 "9"。执行了第五行代码后，alert 函数显示的是 "8"，因为在执行第四行代码之后和执行第五行代码之前，执行了后减量运算。

在算术表达式中，后增量和后减量运算符的优先级是相同的，因此要按照从左到右的顺序计算之。例如：

var iNum1 = 2;
var iNum2 = 20;
var iNum3 = iNum1-- + iNum2++;	//等于 "22"
var iNum4 = iNum1 + iNum2;		//等于 "22"

在前面的代码中，iNum3 等于 22，因为表达式要计算的是 2 + 20。变量 iNum4 也等于 22，不过它计算的是 1 + 21，因为增量和减量运算都在给 iNum3 赋值后才发生。

一元加法和一元减法

大多数人都熟悉一元加法和一元减法，它们在 ECMAScript 中的用法与您高中数学中学到的用法相同。

一元加法本质上对数字无任何影响：

var iNum = 20;
iNum = +iNum;
alert(iNum);	//输出 "20"

这段代码对数字 20 应用了一元加法，返回的还是 20。

尽管一元加法对数字无作用，但对字符串却有有趣的效果，会把字符串转换成数字。

var sNum = "20";
alert(typeof sNum);	//输出 "string"
var iNum = +sNum;
alert(typeof iNum);	//输出 "number"

这段代码把字符串 "20" 转换成真正的数字。当一元加法运算符对字符串进行操作时，它计算字符串的方式与 parseInt() 相似，主要的不同是只有对以 "0x" 开头的字符串（表示十六进制数字），一元运算符才能把它转换成十进制的值。因此，用一元加法转换 "010"，得到的总是 10，而 "0xB" 将被转换成 11。

另一方面，一元减法就是对数值求负（例如把 20 转换成 -20）：

var iNum = 20;
iNum = -iNum;
alert(iNum);	//输出 "-20"

与一元加法运算符相似，一元减法运算符也会把字符串转换成近似的数字，此外还会对该值求负。例如：

var sNum = "20";
alert(typeof sNum);	//输出 "string"
var iNum = -sNum;
alert(iNum);		//输出 "-20"
alert(typeof iNum);	//输出 "number"

在上面的代码中，一元减法运算符将把字符串 "-20" 转换成 -20（一元减法运算符对十六进制和十进制的处理方式与一元加法运算符相似，只是它还会对该值求负）。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript 引用类型

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript 引用类型

  • Previous Page
  • Next Page

引用类型通常叫做类（class）。

本教程会讨论大量的 ECMAScript 预定义引用类型。

引用类型

引用类型通常叫做类（class），也就是说，遇到引用值，所处理的就是对象。

本教程会讨论大量的 ECMAScript 预定义引用类型。

从现在起，将重点讨论与已经讨论过的原始类型紧密相关的引用类型。

注意：从传统意义上来说，ECMAScript 并不真正具有类。事实上，除了说明不存在类，在 ECMA-262 中根本没有出现“类”这个词。ECMAScript 定义了“对象定义”，逻辑上等价于其他程序设计语言中的类。

提示：本教程将使用术语“对象”。

对象是由 new 运算符加上要实例化的对象的名字创建的。例如，下面的代码创建 Object 对象的实例：

var o = new Object();

这种语法与 Java 语言的相似，不过当有不止一个参数时，ECMAScript 要求使用括号。如果没有参数，如以下代码所示，括号可以省略：

var o = new Object;

注意：尽管括号不是必需的，但是为了避免混乱，最好使用括号。

提示：我们会在对象基础这一章中更深入地探讨对象及其行为。

这一节的重点是具有等价的原始类型的引用类型。

Object 对象

Object 对象自身用处不大，不过在了解其他类之前，还是应该了解它。因为 ECMAScript 中的 Object 对象与 Java 中的 java.lang.object 相似，ECMAScript 中的所有对象都由这个对象继承而来，Object 对象中的所有属性和方法都会出现在其他对象中，所以理解了 Object 对象，就可以更好地理解其他对象。

Object 对象具有下列属性：

constructor
对创建对象的函数的引用（指针）。对于 Object 对象，该指针指向原始的 Object() 函数。
Prototype
对该对象的对象原型的引用。对于所有的对象，它默认返回 Object 对象的一个实例。

Object 对象还具有几个方法：

hasOwnProperty(property)
判断对象是否有某个特定的属性。必须用字符串指定该属性。（例如，o.hasOwnProperty("name")）
IsPrototypeOf(object)
判断该对象是否为另一个对象的原型。
PropertyIsEnumerable
判断给定的属性是否可以用 for...in 语句进行枚举。
ToString()
返回对象的原始字符串表示。对于 Object 对象，ECMA-262 没有定义这个值，所以不同的 ECMAScript 实现具有不同的值。
ValueOf()
返回最适合该对象的原始值。对于许多对象，该方法返回的值都与 ToString() 的返回值相同。

注释：上面列出的每种属性和方法都会被其他对象覆盖。

Boolean 对象

Boolean 对象是 Boolean 原始类型的引用类型。

要创建 Boolean 对象，只需要传递 Boolean 值作为参数：

var oBooleanObject = new Boolean(true);

Boolean 对象将覆盖 Object 对象的 ValueOf() 方法，返回原始值，即 true 和 false。ToString() 方法也会被覆盖，返回字符串 "true" 或 "false"。

遗憾的是，在 ECMAScript 中很少使用 Boolean 对象，即使使用，也不易理解。

问题通常出现在 Boolean 表达式中使用 Boolean 对象时。例如：

var oFalseObject = new Boolean(false);
var bResult = oFalseObject && true;	//输出 true

在这段代码中，用 false 值创建 Boolean 对象。然后用这个值与原始值 true 进行 AND 操作。在 Boolean 运算中，false 和 true 进行 AND 操作的结果是 false。不过，在这行代码中，计算的是 oFalseObject，而不是它的值 false。

正如前面讨论过的，在 Boolean 表达式中，所有对象都会被自动转换为 true，所以 oFalseObject 的值是 true。然后 true 再与 true 进行 AND 操作，结果为 true。

注意：虽然你应该了解 Boolean 对象的可用性，不过最好还是使用 Boolean 原始值，避免发生这一节提到的问题。

参阅

如需更多有关 Boolean 对象的信息，请访问 JavaScript Boolean 对象参考手册。

Number 对象

正如你可能想到的，Number 对象是 Number 原始类型的引用类型。要创建 Number 对象，采用下列代码：

var oNumberObject = new Number(68);

您应该已认出本章前面小节中讨论特殊值（如 Number.MAX_VALUE）时提到的 Number 对象。所有特殊值都是 Number 对象的静态属性。

要得到数字对象的 Number 原始值，只需要使用 valueOf() 方法：

var iNumber = oNumberObject.valueOf();

当然，Number 类也有 toString() 方法，在讨论类型转换的小节中已经详细讨论过该方法。

除了从 Object 对象继承的标准方法外，Number 对象还有几个处理数值的专用方法。

toFixed() 方法

toFixed() 方法返回的是具有指定位数小数的数字的字符串表示。例如：

var oNumberObject = new Number(68);
alert(oNumberObject.toFixed(2));  //输出 "68.00"

在这里，toFixed() 方法的参数是 2，说明应该显示两位小数。该方法返回 "68.00"，空的字符串位由 0 来补充。对于处理货币的应用程序，该方法非常有用。toFixed() 方法能表示具有 0 到 20 位小数的数字，超过这个范围的值会引发错误。

toExponential() 方法

与格式化数字相关的另一个方法是 toExponential()，它返回的是用科学计数法表示的数字的字符串形式。

与 toFixed() 方法相似，toExponential() 方法也有一个参数，指定要输出的小数的位数。例如：

var oNumberObject = new Number(68);
alert(oNumberObject.toExponential(1));  //输出 "6.8e+1"

这段代码的结果是 "6.8e+1"，前面解释过，它表示 6.8x101。问题是，如果不知道要用哪种形式（预定形式或指数形式）表示数字怎么办？可以用 toPrecision() 方法。

toPrecision() 方法

toPrecision() 方法根据最有意义的形式来返回数字的预定形式或指数形式。它有一个参数，即用于表示数的数字总数（不包括指数）。例如，

var oNumberObject = new Number(68);
alert(oNumberObject.toPrecision(1));  //输出 "7e+1"

这段代码的任务是用一位数字表示数字 68，结果为 "7e+1"，以另外的形式表示即 70。的确，toPrecision() 方法会对数进行舍入。不过，如果用 2 位数字表示 68，就容易多了：

var oNumberObject = new Number(68);
alert(oNumberObject.toPrecision(2));  //输出 "68"

当然，输出的是 "68"，因为这正是该数的准确表示。不过，如果指定的位数多于需要的位数又如何呢？

var oNumberObject = new Number(68);
alert(oNumberObject.toPrecision(3));  //输出 "68.0"

在这种情况下，toPrecision(3) 等价于 toFixed(1)，输出的是 "68.0"。

toFixed()、toExponential() 和 toPrecision() 方法都会进行舍入操作，以便用正确的小数位数正确地表示一个数。

提示：与 Boolean 对象相似，Number 对象也很重要，不过应该少用这种对象，以避免潜在的问题。只要可能，都使用数字的原始表示法。

参阅

如需更多有关 Number 对象的信息，请访问 JavaScript Number 对象参考手册。

String 对象

String 对象是 String 原始类型的对象表示法，它是以下方式创建的：

var oStringObject = new String("hello world");

String 对象的 valueOf() 方法和 toString() 方法都会返回 String 类型的原始值：

alert(oStringObject.valueOf() == oStringObject.toString());	//输出 "true"

如果运行这段代码，输出是 "true"，说明这些值真的相等。

注释：String 对象是 ECMAScript 中比较复杂的引用类型之一。同样，本节的重点只是 String 类的基本功能。更多的高级功能请阅读本教程相关的章节，或参阅 JavaScript String 对象参考手册。

length 属性

String 对象具有属性 length，它是字符串中的字符个数：

var oStringObject = new String("hello world");
alert(oStringObject.length);	//输出 "11"

这个例子输出的是 "11"，即 "hello world" 中的字符个数。注意，即使字符串包含双字节的字符（与 ASCII 字符相对，ASCII 字符只占用一个字节），每个字符也只算一个字符。

charAt() 和 charCodeAt() 方法

String 对象还拥有大量的方法。

首先，两个方法 charAt() 和 charCodeAt() 访问的是字符串中的单个字符。这两个方法都有一个参数，即要操作的字符的位置。

charAt() 方法返回的是包含指定位置处的字符的字符串：

var oStringObject = new String("hello world");
alert(oStringObject.charAt(1));	//输出 "e"

在字符串 "hello world" 中，位置 1 处的字符是 "e"。在“ECMAScript 原始类型”这一节中我们讲过，第一个字符的位置是 0，第二个字符的位置是 1，依此类推。因此，调用 charAt(1) 返回的是 "e"。

如果想得到的不是字符，而是字符代码，那么可以调用 charCodeAt() 方法：

var oStringObject = new String("hello world");
alert(oStringObject.charCodeAt(1));	//输出 "101"

这个例子输出 "101"，即小写字母 "e" 的字符代码。

concat() 方法

接下来是 concat() 方法，用于把一个或多个字符串连接到 String 对象的原始值上。该方法返回的是 String 原始值，保持原始的 String 对象不变：

var oStringObject = new String("hello ");
var sResult = oStringObject.concat("world");
alert(sResult);		//输出 "hello world"
alert(oStringObject);	//输出 "hello "

在上面这段代码中，调用 concat() 方法返回的是 "hello world"，而 String 对象存放的仍然是 "hello "。出于这种原因，较常见的是用加号（+）连接字符串，因为这种形式从逻辑上表明了真正的行为：

var oStringObject = new String("hello ");
var sResult = oStringObject + "world";
alert(sResult);		//输出 "hello world"
alert(oStringObject);	//输出 "hello "

indexOf() 和 lastIndexOf() 方法

迄今为止，已讨论过连接字符串的方法，访问字符串中的单个字符的方法。不过如果无法确定在某个字符串中是否确实存在一个字符，应该调用什么方法呢？这时，可调用 indexOf() 和 lastIndexOf() 方法。

indexOf() 和 lastIndexOf() 方法返回的都是指定的子串在另一个字符串中的位置，如果没有找不到子串，则返回 -1。

这两个方法的不同之处在于，indexOf() 方法是从字符串的开头（位置 0）开始检索字符串，而 lastIndexOf() 方法则是从字符串的结尾开始检索子串。例如：

var oStringObject = new String("hello world!");
alert(oStringObject.indexOf("o"));		输出 "4"
alert(oStringObject.lastIndexOf("o"));	输出 "7"

在这里，第一个 "o" 字符串出现在位置 4，即 "hello" 中的 "o"；最后一个 "o" 出现在位置 7，即 "world" 中的 "o"。如果该字符串中只有一个 "o" 字符串，那么 indexOf() 和 lastIndexOf() 方法返回的位置相同。

localeCompare() 方法

下一个方法是 localeCompare()，对字符串进行排序。该方法有一个参数 - 要进行比较的字符串，返回的是下列三个值之一：

  • 如果 String 对象按照字母顺序排在参数中的字符串之前，返回负数。
  • 如果 String 对象等于参数中的字符串，返回 0
  • 如果 String 对象按照字母顺序排在参数中的字符串之后，返回正数。

注释：如果返回负数，那么最常见的是 -1，不过真正返回的是由实现决定的。如果返回正数，那么同样的，最常见的是 1，不过真正返回的是由实现决定的。

示例如下：

var oStringObject = new String("yellow");
alert(oStringObject.localeCompare("brick"));		//输出 "1"
alert(oStringObject.localeCompare("yellow"));		//输出 "0"
alert(oStringObject.localeCompare("zoo"));		//输出 "-1"

在这段代码中，字符串 "yellow" 与 3 个值进行了对比，即 "brick"、"yellow" 和 "zoo"。由于按照字母顺序排列，"yellow" 位于 "brick" 之后，所以 localeCompare() 返回 1；"yellow" 等于 "yellow"，所以 localeCompare() 返回 0；"zoo" 位于 "yellow" 之后，localeCompare() 返回 -1。再强调一次，由于返回的值是由实现决定的，所以最好以下面的方式调用 localeCompare() 方法：

var oStringObject1 = new String("yellow");
var oStringObject2 = new String("brick");

var iResult = sTestString.localeCompare("brick");

if(iResult < 0) {
  alert(oStringObject1 + " comes before " + oStringObject2);
} else if (iResult > 0) {
  alert(oStringObject1 + " comes after " + oStringObject2);
} else {
  alert("The two strings are equal");
}

采用这种结构，可以确保这段代码在所有实现中都能正确运行。

localeCompare() 方法的独特之处在于，实现所处的区域（locale，兼指国家/地区和语言）确切说明了这种方法运行的方式。在美国，英语是 ECMAScript 实现的标准语言，localeCompare() 是区分大小写的，大写字母在字母顺序上排在小写字母之后。不过，在其他区域，情况可能并非如此。

slice() 和 substring()

ECMAScript 提供了两种方法从子串创建字符串值，即 slice() 和 substring()。这两种方法返回的都是要处理的字符串的子串，都接受一个或两个参数。第一个参数是要获取的子串的起始位置，第二个参数（如果使用的话）是要获取子串终止前的位置（也就是说，获取终止位置处的字符不包括在返回的值内）。如果省略第二个参数，终止位就默认为字符串的长度。

与 concat() 方法一样，slice() 和 substring() 方法都不改变 String 对象自身的值。它们只返回原始的 String 值，保持 String 对象不变。

var oStringObject = new String("hello world");
alert(oStringObject.slice("3"));		//输出 "lo world"
alert(oStringObject.substring("3"));		//输出 "lo world"
alert(oStringObject.slice("3, 7"));		//输出 "lo w"
alert(oStringObject.substring("3, 7"));	//输出 "lo w"

在这个例子中，slice() 和 substring() 的用法相同，返回值也一样。当只有参数 3 时，两个方法返回的都是 "lo world"，因为 "hello" 中的第二个 "l" 位于位置 3 上。当有两个参数 "3" 和 "7" 时，两个方法返回的值都是 "lo w"（"world" 中的字母 "o" 位于位置 7 上，所以它不包括在结果中）。

为什么有两个功能完全相同的方法呢？事实上，这两个方法并不完全相同，不过只在参数为负数时，它们处理参数的方式才稍有不同。

对于负数参数，slice() 方法会用字符串的长度加上参数，substring() 方法则将其作为 0 处理（也就是说将忽略它）。例如：

var oStringObject = new String("hello world");
alert(oStringObject.slice("-3"));		//输出 "rld"
alert(oStringObject.substring("-3"));	//输出 "hello world"
alert(oStringObject.slice("3, -4"));		//输出 "lo w"
alert(oStringObject.substring("3, -4"));	//输出 "hel"

这样即可看出 slice() 和 substring() 方法的主要不同。

当只有参数 -3 时，slice() 返回 "rld"，substring() 则返回 "hello world"。这是因为对于字符串 "hello world"，slice("-3") 将被转换成 slice("8")，而 substring("-3") 将被转换成 substring("0")。

同样，使用参数 3 和 -4 时，差别也很明显。slice() 将被转换成 slice(3, 7)，与前面的例子相同，返回 "lo w"。而 substring() 方法则将两个参数解释为 substring(3, 0)，实际上即 substring(0, 3)，因为 substring() 总把较小的数字作为起始位，较大的数字作为终止位。因此，substring("3, -4") 返回的是 "hel"。这里的最后一行代码用来说明如何使用这些方法。

toLowerCase()、toLocaleLowerCase()、toUpperCase() 和 toLocaleUpperCase()

最后一套要讨论的方法涉及大小写转换。有 4 种方法用于执行大小写转换，即

  • toLowerCase()
  • toLocaleLowerCase()
  • toUpperCase()
  • toLocaleUpperCase()

从名字上可以看出它们的用途，前两种方法用于把字符串转换成全小写的，后两种方法用于把字符串转换成全大写的。

toLowerCase() 和 toUpperCase() 方法是原始的，是以 java.lang.String 中相同方法为原型实现的。

toLocaleLowerCase() 和 toLocaleUpperCase() 方法是基于特定的区域实现的（与 localeCompare() 方法相同）。在许多区域中，区域特定的方法都与通用的方法完全相同。不过，有几种语言对 Unicode 大小写转换应用了特定的规则（例如土耳其语），因此必须使用区域特定的方法才能进行正确的转换。

var oStringObject = new String("Hello World");
alert(oStringObject.toLocaleUpperCase());	//输出 "HELLO WORLD"
alert(oStringObject.toUpperCase());		//输出 "HELLO WORLD"
alert(oStringObject.toLocaleLowerCase());	//输出 "hello world"
alert(oStringObject.toLowerCase());		//输出 "hello world"

这段代码中，toUpperCase() 和 toLocaleUpperCase() 输出的都是 "HELLO WORLD"，toLowerCase() 和 toLocaleLowerCase() 输出的都是 "hello world"。一般来说，如果不知道在以哪种编码运行一种语言，则使用区域特定的方法比较安全。

提示：记住，String 对象的所有属性和方法都可应用于 String 原始值上，因为它们是伪对象。

instanceof 运算符

在使用 typeof 运算符时采用引用类型存储值会出现一个问题，无论引用的是什么类型的对象，它都返回 "object"。ECMAScript 引入了另一个 Java 运算符 instanceof 来解决这个问题。

instanceof 运算符与 typeof 运算符相似，用于识别正在处理的对象的类型。与 typeof 方法不同的是，instanceof 方法要求开发者明确地确认对象为某特定类型。例如：

var oStringObject = new String("hello world");
alert(oStringObject instanceof String);	//输出 "true"

这段代码问的是“变量 oStringObject 是否为 String 对象的实例？”oStringObject 的确是 String 对象的实例，因此结果是 "true"。尽管不像 typeof 方法那样灵活，但是在 typeof 方法返回 "object" 的情况下，instanceof 方法还是很有用的。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript 语法

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript 语法

  • Previous Page
  • Next Page

熟悉 Java、C 和 Perl 这些语言的开发者会发现 ECMAScript 的语法很容易掌握，因为它借用了这些语言的语法。

Java 和 ECMAScript 有一些关键的语法特性相同，也有一些完全不同。

区分大小写

与 Java 一样，变量、函数名、运算符以及其他一切东西都是区分大小写的。

比如：

变量 test 与变量 TEST 是不同的。

变量是弱类型的

与 Java 和 C 不同，ECMAScript 中的变量无特定的类型，定义变量时只用 var 运算符，可以将它初始化为任意值。

因此，可以随时改变变量所存数据的类型（尽量避免这样做）。

例子

var color = "red";
var num = 25;
var visible = true;

每行结尾的分行可有可无

Java、C 和 Perl 都要求每行代码以分号（;）结束才符合语法。

ECMAScript 则允许开发者自行决定是否以分号结束一行代码。如果没有分号，ECMAScript 就把折行代码的结尾看做该语句的结尾（与 Visual Basic 和 VBScript 相似），前提是这样没有破坏代码的语义。

最好的代码编写习惯是总加入分号，因为没有分号，有些浏览器就不能正确运行，不过根据 ECMAScript 标准，下面两行代码都是正确的：

var test1 = "red"
var test2 = "blue";

注释与 Java、C 和 PHP 语言的注释相同

ECMAScript 借用了这些语言的注释语法。

有两种类型的注释：

  • 单行注释以双斜杠开头（//）
  • 多行注释以单斜杠和星号开头（/*），以星号和单斜杠结尾（*/）
//this is a single-line comment

/*this is a multi-
line comment*/

括号表示代码块

从 Java 中借鉴的另一个概念是代码块。

代码块表示一系列应该按顺序执行的语句，这些语句被封装在左括号（{）和右括号（}）之间。

例如：

if (test1 == "red") {
    test1 = "blue";
    alert(test1);
}
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript 原始类型

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript 原始类型

  • Previous Page
  • Next Page

ECMAScript 有 5 种原始类型（primitive type），即 Undefined、Null、Boolean、Number 和 String。

typeof 运算符

typeof 运算符有一个参数，即要检查的变量或值。例如：

var sTemp = "test string";
alert (typeof sTemp);    //输出 "string"
alert (typeof 86);    //输出 "number"

对变量或值调用 typeof 运算符将返回下列值之一：

  • undefined - 如果变量是 Undefined 类型的
  • boolean - 如果变量是 Boolean 类型的
  • number - 如果变量是 Number 类型的
  • string - 如果变量是 String 类型的
  • object - 如果变量是一种引用类型或 Null 类型的

注释：您也许会问，为什么 typeof 运算符对于 null 值会返回 "Object"。这实际上是 JavaScript 最初实现中的一个错误，然后被 ECMAScript 沿用了。现在，null 被认为是对象的占位符，从而解释了这一矛盾，但从技术上来说，它仍然是原始值。

Undefined 类型

如前所述，Undefined 类型只有一个值，即 undefined。当声明的变量未初始化时，该变量的默认值是 undefined。

var oTemp;

前面一行代码声明变量 oTemp，没有初始值。该变量将被赋予值 undefined，即 undefined 类型的字面量。可以用下面的代码段测试该变量的值是否等于 undefined：

var oTemp;
alert(oTemp == undefined);

这段代码将显示 "true"，说明这两个值确实相等。还可以用 typeof 运算符显示该变量的值是 undefined：

var oTemp;
alert(typeof oTemp); //输出 "undefined"

提示：值 undefined 并不同于未定义的值。但是，typeof 运算符并不真正区分这两种值。考虑下面的代码：

var oTemp;

alert(typeof oTemp);  //输出 "undefined"
alert(typeof oTemp2);  //输出 "undefined"

前面的代码对两个变量输出的都是 "undefined"，即使只有变量 oTemp2 从未被声明过。如果对 oTemp2 使用除 typeof 之外的其他运算符的话，会引起错误，因为其他运算符只能用于已声明的变量上。

例如，下面的代码将引发错误：

var oTemp;
alert(oTemp2 == undefined);

当函数无明确返回值时，返回的也是值 "undefined"，如下所示：

function testFunc() {
}

alert(testFunc() == undefined);  //输出 "true"

Null 类型

另一种只有一个值的类型是 Null，它只有一个专用值 null，即它的字面量。值 undefined 实际上是从值 null 派生来的，因此 ECMAScript 把它们定义为相等的。

alert(null == undefined);  //输出 "true"

尽管这两个值相等，但它们的含义不同。undefined 是声明了变量但未对其初始化时赋予该变量的值，null 则用于表示尚未存在的对象（在讨论 typeof 运算符时，简单地介绍过这一点）。如果函数或方法要返回的是对象，那么找不到该对象时，返回的通常是 null。

Boolean 类型

Boolean 类型是 ECMAScript 中最常用的类型之一。它有两个值 true 和 false （即两个 Boolean 字面量）。

即使 false 不等于 0，0 也可以在必要时被转换成 false，这样在 Boolean 语句中使用两者都是安全的。

var bFound = true;
var bLost = false;

Number 类型

ECMA-262 中定义的最特殊的类型是 Number 类型。这种类型既可以表示 32 位的整数，还可以表示 64 为的浮点数。

直接输入的（而不是从另一个变量访问的）任何数字都被看做 Number 类型的字面量。例如，下面的代码声明了存放整数值的变量，它的值由字面量 86 定义：

var iNum = 86;

八进制数和十六进制数

整数也可以被表示为八进制（以 8 为底）或十六进制（以 16 为底）的字面量。八进制字面量的首数字必须是 0，其后的数字可以是任何八进制数字（0-7），如下面的代码所示：

var iNum = 070;  //070 等于十进制的 56

要创建十六进制的字面量，首位数字必须为 0，后面接字母 x，然后是任意的十六进制数字（0 到 9 和 A 到 F）。这些字母可以是大写的，也可以是小写的。例如：

var iNum = 0x1f;  //0x1f 等于十进制的 31
var iNum = 0xAB;  //0xAB 等于十进制的 171

提示：尽管所有整数都可以表示为八进制或十六进制的字面量，但所有数学运算返回的都是十进制结果。

浮点数

要定义浮点值，必须包括小数点和小数点后的一位数字（例如，用 1.0 而不是 1）。这被看作浮点数字面量。例如：

var fNum = 5.0;

对于浮点字面量的有趣之处在于，用它进行计算前，真正存储的是字符串。

科学计数法

对于非常大或非常小的数，可以用科学计数法表示浮点数，可以把一个数表示为数字（包括十进制数字）加 e（或 E），后面加乘以 10 的倍数。例如：

var fNum = 5.618e7

该符号表示的是数 56180000。把科学计数法转化成计算式就可以得到该值：5.618 x 107。

也可以用科学计数法表示非常小的数，例如 0.00000000000000008 可以表示为 8-e17（这里，10 被升到 -17 次冥，意味着需要被 10 除 17 次）。ECMAScript 默认把具有 6 个或 6 个以上前导 0 的浮点数转换成科学计数法。

提示：也可用 64 位 IEEE 754 形式存储浮点值，这意味着十进制值最多可以有 17 个十进制位。17 位之后的值将被裁去，从而造成一些小的数学误差。

特殊的 Number 值

几个特殊值也被定义为 Number 类型。前两个是 Number.MAX_VALUE 和 Number.MIN_VALUE，它们定义了 Number 值集合的外边界。所有 ECMAScript 数都必须在这两个值之间。不过计算生成的数值结果可以不落在这两个值之间。

当计算生成的数大于 Number.MAX_VALUE 时，它将被赋予值 Number.POSITIVE_INFINITY，意味着不再有数字值。同样，生成的数值小于 Number.MIN_VALUE 的计算也会被赋予值 Number.NEGATIVE_INFINITY，也意味着不再有数字值。如果计算返回的是无穷大值，那么生成的结果不能再用于其他计算。

事实上，有专门的值表示无穷大，（如你猜到的）即 Infinity。Number.POSITIVE_INFINITY 的值为 Infinity。Number.NEGATIVE_INFINITY 的值为 -Infinity。

由于无穷大数可以是正数也可以是负数，所以可用一个方法判断一个数是否是有穷的（而不是单独测试每个无穷数）。可以对任何数调用 isFinite() 方法，以确保该数不是无穷大。例如：

var iResult = iNum * some_really_large_number;

if (isFinite(iResult)) {
    alert("finite");
}

else {
    alert("infinite");
}

最后一个特殊值是 NaN，表示非数（Not a Number）。NaN 是个奇怪的特殊值。一般说来，这种情况发生在类型（String、Boolean 等）转换失败时。例如，要把单词 blue 转换成数值就会失败，因为没有与之等价的数值。与无穷大一样，NaN 也不能用于算术计算。NaN 的另一个奇特之处在于，它与自身不相等，这意味着下面的代码将返回 false：

alert(NaN == NaN);  //输出 "false"

出于这个原因，不推荐使用 NaN 值本身。函数 isNaN() 会做得相当好：

alert(isNaN("blue"));  //输出 "true"
alert(isNaN("666"));  //输出 "false"

String 类型

String 类型的独特之处在于，它是唯一没有固定大小的原始类型。可以用字符串存储 0 或更多的 Unicode 字符，有 16 位整数表示（Unicode 是一种国际字符集，本教程后面将讨论它）。

字符串中每个字符都有特定的位置，首字符从位置 0 开始，第二个字符在位置 1，依此类推。这意味着字符串中的最后一个字符的位置一定是字符串的长度减 1：

字符串字面量是由双引号（"）或单引号（'）声明的。而 Java 则是用双引号声明字符串，用单引号声明字符。但是由于 ECMAScript 没有字符类型，所以可使用这两种表示法中的任何一种。例如，下面的两行代码都有效：

var sColor1 = "red";
var sColor2 = 'red';

String 类型还包括几种字符字面量，Java、C 和 Perl 的开发者应该对此非常熟悉。

下面列出了 ECMAScript 的字符字面量：

字面量 | 含义
\n | 换行
\t | 制表符
\b | 空格
\r | 回车
\f | 换页符
\\ | 反斜杠
\' | 单引号
\" | 双引号
\0nnn | 八进制代码 nnn 表示的字符（n 是 0 到 7 中的一个八进制数字）
\xnn | 十六进制代码 nn 表示的字符（n 是 0 到 F 中的一个十六进制数字）
\unnnn | 十六进制代码 nnnn 表示的 Unicode 字符（n 是 0 到 F 中的一个十六进制数字）
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


ECMAScript 值

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ECMAScript 值

  • Previous Page
  • Next Page

在 ECMAScript 中，变量可以存在两种类型的值，即原始值和引用值。

原始值和引用值

在 ECMAScript 中，变量可以存在两种类型的值，即原始值和引用值。

原始值
存储在栈（stack）中的简单数据段，也就是说，它们的值直接存储在变量访问的位置。
引用值
存储在堆（heap）中的对象，也就是说，存储在变量处的值是一个指针（point），指向存储对象的内存处。

为变量赋值时，ECMAScript 的解释程序必须判断该值是原始类型，还是引用类型。要实现这一点，解释程序则需尝试判断该值是否为 ECMAScript 的原始类型之一，即 Undefined、Null、Boolean 和 String 型。由于这些原始类型占据的空间是固定的，所以可将他们存储在较小的内存区域 - 栈中。这样存储便于迅速查寻变量的值。

在许多语言中，字符串都被看作引用类型，而非原始类型，因为字符串的长度是可变的。ECMAScript 打破了这一传统。

如果一个值是引用类型的，那么它的存储空间将从堆中分配。由于引用值的大小会改变，所以不能把它放在栈中，否则会降低变量查寻的速度。相反，放在变量的栈空间中的值是该对象存储在堆中的地址。地址的大小是固定的，所以把它存储在栈中对变量性能无任何负面影响。如下图所示：

原始类型

如前所述，ECMAScript 有 5 种原始类型（primitive type），即 Undefined、Null、Boolean、Number 和 String。EMCA-262 把术语类型（type）定义为值的一个集合，每种原始类型定义了它包含的值的范围及其字面量表示形式。

ECMAScript 提供了 typeof 运算符来判断一个值是否在某种类型的范围内。可以用这种运算符判断一个值是否表示一种原始类型：如果它是原始类型，还可以判断它表示哪种原始类型。

在稍后的章节，我们将为您深入讲解 ECMAScript 的原始类型和引用类型。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaCript 总结

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaCript 总结

  • Previous Page
  • Next Page

现在已经你已经学习了 JavaScript，接下来该学习什么呢？

JavaScript 概要

本教程中我们向您讲授了如何向 html 页面添加 JavaScript，使得网站的动态性和交互性更强。

你已经学习了如何创建对事件的响应，验证表单，以及如何根据不同的情况运行不同的脚本。

你也学到了如何创建和使用对象，以及如何使用 JavaScript 的内置对象。

如需更多关于 JavaScript 的信息和知识，请参阅我们的 JavaScript 实例 和 JavaScript 参考手册。

现在已经你已经学习了 JavaScript，接下来该学习什么呢？

下一步应该学习 HTML DOM 和 DHTML。

如果你希望学习关于服务器端脚本的知识，那么下一步应该学习 ASP。

HTML DOM

HTML DOM 定义了访问和操作 HTML 文档的标准方法。

HTML DOM 独立于平台和语言，可被任何编程语言使用，比如 Java、JavaScript 和 VBscript。

假如希望了解更多关于 DOM 的知识，请访问我们的 HTML DOM 教程。

DHTML

DHTML 是 HTML、CSS 和 JavaScript 的集合。DHTML 用于创建动态的交互式的网站。

W3C 有过这样的描述： "Dynamic HTML is a term used by some vendors to describe the combination of HTML, style sheets and scripts that allows documents to be animated."

假如你希望学习更多关于 DHTML 的知识，请访问我们的 DTHML 教程。

ASP

和 HTML 文档中的脚本运行于客户端（浏览器）不同，ASP 文件中的脚本运行于服务器之上。

使用 ASP，你可以动态地编辑、改变或者添加网站内容，对由 HTML 表单提交而来的数据进行响应，访问数据或者数据库并向浏览器返回结果，或者定制对不同的用户来说更有帮助的网页。由于 ASP 文件返回纯粹的 HTML，因此可被任何浏览器所读取。

如果希望学习更多关于 ASP 的知识，请访问我们的 ASP 教程。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript abs() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript abs() 方法

返回 JavaScript Math 对象参考手册

定义和用法

abs() 方法可返回数的绝对值。

语法

Math.abs(x)
参数 | 描述
x | 必需。必须是一个数值。

返回值

x 的绝对值。

实例

在本例中，我将取得正数和负数的绝对值：

<script type="text/javascript">

document.write(Math.abs(7.25) + "<br />")
document.write(Math.abs(-7.25) + "<br />")
document.write(Math.abs(7.25-10))

</script>

输出：

7.25
7.25
2.75

TIY

abs()
如何使用 abs() 来取得数的绝对值。

返回 JavaScript Math 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript acos() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript acos() 方法

返回 JavaScript Math 对象参考手册

定义和用法

acos() 方法可返回一个数的反余弦。

语法

Math.acos(x)
参数 | 描述
x | 必需。必须是 -1.0 ~ 1.0 之间的数。

返回值

x 的反余弦值。返回的值是 0 到 PI 之间的弧度值。

提示和注释

注释：如果参数 x 超过了 -1.0 ~ 1.0 的范围，那么浏览器将返回 NaN。

注释：如果参数 x 取值 -1，那么将返回 PI。

实例

在本例中，我们将取得不同数的反余弦值：

<script type="text/javascript">

document.write(Math.acos(0.64) + "<br />")
document.write(Math.acos(0) + "<br />")
document.write(Math.acos(-1) + "<br />")
document.write(Math.acos(1) + "<br />")
document.write(Math.acos(2))

</script>

输出：

0.8762980611683406
1.5707963267948965
3.141592653589793
0
NaN

TIY

acos()
如何使用 acos() 来取得不同数的反余弦值。

返回 JavaScript Math 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript anchor() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript anchor() 方法

返回 JavaScript String 对象参考手册

定义和用法

anchor() 方法用于创建 HTML 锚。

stringObject.anchor(anchorname)
参数 | 描述
anchorname | 必需。为锚定义名称。

实例

在本例中，我们会为文本添加一个锚：

<script type="text/javascript">

var txt="Hello world!"
document.write(txt.anchor("myanchor"))

</script>

上面的代码将输出为纯粹的 HTML：

<a name="myanchor">Hello world!</a>

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript Array 对象的参考手册

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript Array 对象的参考手册

Array 对象的方法

FF: Firefox, N: Netscape, IE: Internet Explorer

方法 | 描述 | FF | N | IE
concat() | 连接两个或更多的数组，并返回结果。 | 1 | 4 | 4
join() | 把数组的所有元素放入一个字符串。元素通过指定的分隔符进行分隔。 | 1 | 3 | 4
pop() | 删除并返回数组的最后一个元素 | 1 | 4 | 5.5
push() | 向数组的末尾添加一个或更多元素，并返回新的长度。 | 1 | 4 | 5.5
reverse() | 颠倒数组中元素的顺序。 | 1 | 3 | 4
shift() | 删除并返回数组的第一个元素 | 1 | 4 | 5.5
slice() | 从某个已有的数组返回选定的元素 | 1 | 4 | 4
sort() | 对数组的元素进行排序 | 1 | 3 | 4
splice() | 删除元素，并向数组添加新元素。 | 1 | 4 | 5.5
toSource() | 代表对象的源代码 | 1 | 4 | -
toString() | 把数组转换为字符串，并返回结果。 | 1 | 3 | 4
toLocaleString() | 把数组转换为本地数组，并返回结果。 | 1 | 3 | 4
unshift() | 向数组的开头添加一个或更多元素，并返回新的长度。 | 1 | 4 | 6
valueOf() | 返回数组对象的原始值 | 1 | 2 | 4

Array 对象的属性

FF: Firefox, N: Netscape, IE: Internet Explorer

属性 | 描述 | FF | N | IE
constructor | 对创建此对象的函数的一个引用 | 1 | 2 | 4
index |  | 1 | 3 | 4
input |  | 1 | 3 | 4
length | 设置或返回数组中元素的数目。 | 1 | 2 | 4
prototype | 使您有能力向对象添加属性和方法 | 1 | 2 | 4

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript Array（数组）对象

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript Array（数组）对象

  • Previous Page
  • Next Page

数组对象的作用是：使用单独的变量名来存储一系列的值。

实例

创建数组
创建数组，为其赋值，然后输出这些值。
For...In 声明
使用 for...in 声明来循环输出数组中的元素。
合并两个数组 - concat()
如何使用 concat() 方法来合并两个数组。
用数组的元素组成字符串 - join()
如何使用 join() 方法将数组的所有元素组成一个字符串。
文字数组 - sort()
如何使用 sort() 方法从字面上对数组进行排序。
数字数组 - sort()
如何使用 sort() 方法从数值上对数组进行排序。

完整的 Array 对象参考手册

我们提供 JavaScript Array 对象参考手册，其中包括所有可用于数组对象的属性和方法。

该手册包含了对每个属性和方法的详细描述以及相关实例。

定义数组

数组对象用来在单独的变量名中存储一系列的值。

我们使用关键词 new 来创建数组对象。下面的代码定义了一个名为 myArray 的数组对象：

var myArray=new Array()

有两种向数组赋值的方法（你可以添加任意多的值，就像你可以定义你需要的任意多的变量一样）。

1:

var mycars=new Array()
mycars[0]="Saab"
mycars[1]="Volvo"
mycars[2]="BMW"

也可以使用一个整数自变量来控制数组的容量：

var mycars=new Array(3)
mycars[0]="Saab"
mycars[1]="Volvo"
mycars[2]="BMW"

2:

var mycars=new Array("Saab","Volvo","BMW")

注意：如果你需要在数组内指定数值或者逻辑值，那么变量类型应该是数值变量或者布尔变量，而不是字符变量。

访问数组

通过指定数组名以及索引号码，你可以访问某个特定的元素。

下面是代码行：

document.write(mycars[0])

下面是输出：

Saab

修改已有数组中的值

如需修改已有数组中的值，只要向指定下标号添加一个新值即可：

mycars[0]="Opel";

现在，以上代码：

document.write(mycars[0]);

将输出：

Opel
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript asin() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript asin() 方法

返回 JavaScript Math 对象参考手册

定义和用法

asin() 方法可返回一个数的反正弦值。

语法

Math.asin(x)
参数 | 描述
x | 必需。必须是一个数值，该值介于 -1.0 ~ 1.0 之间。

返回值

x 的反正弦值。返回的值是 -PI/2 到 PI/2 之间的弧度值。

提示和注释

注释：如果参数 x 超过了 -1.0 ~ 1.0 的范围，那么浏览器将返回 NaN。

注释：如果参数 x 取值 1，那么将返回 PI/2。

实例

在本例中，我们将取得不同数字的反正弦值：

<script type="text/javascript">

document.write(Math.asin(0.64) + "<br />")
document.write(Math.asin(0) + "<br />")
document.write(Math.asin(-1) + "<br />")
document.write(Math.asin(1) + "<br />")
document.write(Math.asin(2))

</script>

输出：

0.6944982656265559
0
-1.5707963267948965
1.5707963267948965
NaN

TIY

asin()
如何使用 asin() 来取得不同数字的反正弦值。

返回 JavaScript Math 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript atan() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript atan() 方法

返回 JavaScript Math 对象参考手册

定义和用法

atan() 方法可返回数字的反正切值。

语法

Math.atan(x)
参数 | 描述
x | 必需。必须是一个数值。

返回值

x 的反正切值。返回的值是 -PI/2 到 PI/2 之间的弧度值。

实例

下面这个例子可通过 atan() 方法返回不同数字的反正切值：

<script type="text/javascript">

document.write(Math.atan(0.50) + "<br />")
document.write(Math.atan(-0.50) + "<br />")
document.write(Math.atan(5) + "<br />")
document.write(Math.atan(10) + "<br />")
document.write(Math.atan(-5) + "<br />")
document.write(Math.atan(-10))

</script>

输出：

0.4636476090008061
-0.4636476090008061
1.373400766945016
1.4711276743037347
-1.373400766945016
-1.4711276743037347

TIY

atan()
如何使用 atan() 来返回不同数值的反正切值。

返回 JavaScript Math 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript atan2() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript atan2() 方法

返回 JavaScript Math 对象参考手册

定义和用法

atan2() 方法可返回从 x 轴到点 (x,y) 之间的角度。

语法

Math.atan2(y,x)
参数 | 描述
x | 必需。指定点的 X 坐标。
y | 必需。指定点的 Y 坐标。

返回值

-PI 到 PI 之间的值，是从 X 轴正向逆时针旋转到点 (x,y) 时经过的角度。

提示和注释

注释：请注意这个函数的参数顺序，Y 坐标在 X 坐标之前传递。

实例

下面这个例子可通过 atan2() 方法返回不同 (x,y) 点的角度：

<script type="text/javascript">

document.write(Math.atan2(0.50,0.50) + "<br />")
document.write(Math.atan2(-0.50,-0.50) + "<br />")
document.write(Math.atan2(5,5) + "<br />")
document.write(Math.atan2(10,20) + "<br />")
document.write(Math.atan2(-5,-5) + "<br />")
document.write(Math.atan2(-10,10))

</script>

输出：

0.7853981633974483
-2.356194490192345
0.7853981633974483
0.4636476090008061
-2.356194490192345
-0.7853981633974483

TIY

atan2()
如何使用 atan2() 来返回不同 (x,y) 点的角度。

返回 JavaScript Math 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript big() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript big() 方法

返回 JavaScript String 对象参考手册

定义和用法

big() 方法用于把字符串显示为大号字体。

stringObject.big()

实例

在本例中，"Hello world!" 将被显示为大号字体：

<script type="text/javascript">

var str="Hello world!"
document.write(str.big())

</script>

TIY

big()
如何使用 big() 把字符串显示为大号字体。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript blink() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript blink() 方法

返回 JavaScript String 对象参考手册

定义和用法

blink() 方法用于显示闪动的字符串。

语法

stringObject.blink()

提示和注释

注释：此方法无法工作于 Internet Explorer 中。

实例

在本例中，"Hello world!" 将被显示为闪动的文本：

<script type="text/javascript">

var str="Hello world!"
document.write(str.blink())

</script>

TIY

blink()
如何使用 blink() 来显示闪动的文本。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript bold() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript bold() 方法

返回 JavaScript String 对象参考手册

定义和用法

bold() 方法用于把字符串显示为粗体。

语法

stringObject.bold()

实例

在本例中，"Hello world!" 将被显示为粗体：

<script type="text/javascript">

var str="Hello world!"
document.write(str.bold())

</script>

TIY

bold()
如何使用 bold() 把字符串显示为粗体。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript Boolean 对象的参考手册

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript Boolean 对象的参考手册

Boolean 对象是 JavaScript 的一种基本数据类型。

Boolean 对象是一个把布尔值打包的布尔对象。

Boolean 对象的方法

FF: Firefox, N: Netscape, IE: Internet Explorer

方法 | 描述 | FF | N | IE
toSource() | 代表对象的源代码 | 1 | 4 | -
toString() | 把逻辑值转换为字符串，并返回结果。 | 1 | 4 | 4
valueOf() | 返回 Boolean 对象的原始值 | 1 | 4 | 4

Boolean 对象的属性

FF: Firefox, N: Netscape, IE: Internet Explorer

属性 | 描述 | FF | N | IE
constructor | 对创建此对象的函数的一个引用 | 1 | 2 | 4
prototype | 允许您向对象添加属性和方法 | 1 | 2 | 4

课外书

如需更多信息，请阅读 JavaScript 高级教程中的相关内容：

ECMAScript 引用类型
引用类型通常叫做类（class）或对象。本节讲解 ECMAScript 的预定义引用类型。

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript Boolean（逻辑）对象

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript Boolean（逻辑）对象

  • Previous Page
  • Next Page

Boolean（逻辑）对象用于将非逻辑值转换为逻辑值（true 或者 false）。

实例

检查逻辑值
检查逻辑对象是 true 还是 false。

完整的 Boolean 对象参考手册

我们提供 JavaScript Boolean 对象参考手册，其中包括所有可用于数组对象的属性和方法。

该手册包含了对每个属性和方法的详细描述以及相关实例。

Boolean 对象

您可以将 Boolean 对象理解为一个产生逻辑值的对象包装器。

Boolean（逻辑）对象用于将非逻辑值转换为逻辑值（true 或者 false）。

使用关键词 new 来定义 Boolean 对象。下面的代码定义了一个名为 myBoolean 的逻辑对象：

var myBoolean=new Boolean()

注释：如果逻辑对象无初始值或者其值为 0、-0、null、""、false、undefined 或者 NaN，那么对象的值为 false。否则，其值为 true（即使当自变量为字符串 "false" 时）！

下面的所有的代码行均会创建初始值为 false 的 Boolean 对象。

var myBoolean=new Boolean()
var myBoolean=new Boolean(0)
var myBoolean=new Boolean(null)
var myBoolean=new Boolean("")
var myBoolean=new Boolean(false)
var myBoolean=new Boolean(NaN)

下面的所有的代码行均会创初始值为 true 的 Boolean 对象：

var myBoolean=new Boolean(true)
var myBoolean=new Boolean("true")
var myBoolean=new Boolean("false")
var myBoolean=new Boolean("Richard")
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript Break 和 Continue

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript Break 和 Continue

  • Previous Page
  • Next Page

有两种可以用在循环中的语句：break 和 continue。

实例

break 语句
使用 break 语句来终止循环。
continue 语句
使用 continue 语句来终止当前的循环，然后从下一个值继续执行。

JavaScript break 和 continue 语句

有两种特殊的语句可用在循环内部：break 和 continue。

Break

break 命令可以终止循环的运行，然后继续执行循环之后的代码（如果循环之后有代码的话）。

实例：

<html>
<body>
<script type="text/javascript">
var i=0
for (i=0;i<=10;i++)
{
if (i==3){break}
document.write("The number is " + i)
document.write("<br />")
}
</script>
</body>
</html>

结果：

The number is 0
The number is 1
The number is 2

Continue

continue 命令会终止当前的循环，然后从下一个值继续运行。

实例：

<html>
<body>
<script type="text/javascript">
var i=0
for (i=0;i<=10;i++)
{
if (i==3){continue}
document.write("The number is " + i)
document.write("<br />")
}
</script>
</body>
</html>

结果：

The number is 0
The number is 1
The number is 2
The number is 4
The number is 5
The number is 6
The number is 7
The number is 8
The number is 9
The number is 10
  • Previous Page
  • Next Page

课外书

如需更多有关 JavaScript Break 和 Continue 语句的知识，请阅读 JavaScript 高级教程中的相关内容：

ECMAScript break 和 continue 语句
本节讲解了break 语句和 continue 语句的不同之处，以及如何与有标签语句一起使用。

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript ceil() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript ceil() 方法

返回 JavaScript Math 对象参考手册

定义和用法

ceil() 方法可对一个数进行上舍入。

语法

Math.ceil(x)
参数 | 描述
x | 必需。必须是一个数值。

返回值

大于等于 x，并且与它最接近的整数。

说明

ceil() 方法执行的是向上取整计算，它返回的是大于或等于函数参数，并且与之最接近的整数。

实例

在本例中，我们将把 ceil() 方法运用到不同的数字上：

<script type="text/javascript">

document.write(Math.ceil(0.60) + "<br />")
document.write(Math.ceil(0.40) + "<br />")
document.write(Math.ceil(5) + "<br />")
document.write(Math.ceil(5.1) + "<br />")
document.write(Math.ceil(-5.1) + "<br />")
document.write(Math.ceil(-5.9))

</script>

输出：

1
1
5
6
-5
-5

TIY

ceil()
如何使用 ceil() 方法。

返回 JavaScript Math 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript charAt() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript charAt() 方法

返回 JavaScript String 对象参考手册

定义和用法

charAt() 方法可返回指定位置的字符。

请注意，JavaScript 并没有一种有别于字符串类型的字符数据类型，所以返回的字符是长度为 1 的字符串。

语法

stringObject.charAt(index)
参数 | 描述
index | 必需。表示字符串中某个位置的数字，即字符在字符串中的下标。

提示和注释

注释：字符串中第一个字符的下标是 0。如果参数 index 不在 0 与 string.length 之间，该方法将返回一个空字符串。

实例

在字符串 "Hello world!" 中，我们将返回位置 1 的字符：

<script type="text/javascript">

var str="Hello world!"
document.write(str.charAt(1))

</script>

以上代码的输出是：

e

TIY

charAt()
如何使用 charAt() 从某个字符串取得具体的字符。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript charCodeAt() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript charCodeAt() 方法

返回 JavaScript String 对象参考手册

定义和用法

charCodeAt() 方法可返回指定位置的字符的 Unicode 编码。这个返回值是 0 - 65535 之间的整数。

方法 charCodeAt() 与 charAt() 方法执行的操作相似，只不过前者返回的是位于指定位置的字符的编码，而后者返回的是字符子串。

语法

stringObject.charCodeAt(index)
参数 | 描述
index | 必需。表示字符串中某个位置的数字，即字符在字符串中的下标。

提示和注释

注释：字符串中第一个字符的下标是 0。如果 index 是负数，或大于等于字符串的长度，则 charCodeAt() 返回 NaN。

实例

在字符串 "Hello world!" 中，我们将返回位置 1 的字符的 Unicode 编码：

<script type="text/javascript">

var str="Hello world!"
document.write(str.charCodeAt(1))

</script>

以上代码的输出是：

101

TIY

charCodeAt()
如何使用 charCodeAt() 来获得字符串中某个具体字符的 Unicode 编码。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript concat() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript concat() 方法

返回 JavaScript Array 对象参考手册

定义和用法

concat() 方法用于连接两个或多个数组。

该方法不会改变现有的数组，而仅仅会返回被连接数组的一个副本。

语法

arrayObject.concat(arrayX,arrayX,......,arrayX)
参数 | 描述
arrayX | 必需。该参数可以是具体的值，也可以是数组对象。可以是任意多个。

返回值

返回一个新的数组。该数组是通过把所有 arrayX 参数添加到 arrayObject 中生成的。如果要进行 concat() 操作的参数是数组，那么添加的是数组中的元素，而不是数组。

实例

例子 1

在本例中，我们将把 concat() 中的参数连接到数组 a 中：

<script type="text/javascript">

var a = [1,2,3];
document.write(a.concat(4,5));

</script>

输出：

1,2,3,4,5

例子 2

在本例中，我们创建了两个数组，然后使用 concat() 把它们连接起来：

<script type="text/javascript">

var arr = new Array(3)
arr[0] = "George"
arr[1] = "John"
arr[2] = "Thomas"

var arr2 = new Array(3)
arr2[0] = "James"
arr2[1] = "Adrew"
arr2[2] = "Martin"

document.write(arr.concat(arr2))

</script>

输出：

George,John,Thomas,James,Adrew,Martin

例子 3

在本例中，我们创建了三个数组，然后使用 concat() 把它们连接起来：

<script type="text/javascript">

var arr = new Array(3)
arr[0] = "George"
arr[1] = "John"
arr[2] = "Thomas"

var arr2 = new Array(3)
arr2[0] = "James"
arr2[1] = "Adrew"
arr2[2] = "Martin"

var arr3 = new Array(2)
arr3[0] = "William"
arr3[1] = "Franklin"

document.write(arr.concat(arr2,arr3))

</script>

输出：

George,John,Thomas,James,Adrew,Martin,William,Franklin

TIY

如何使用 concat() 连接数组中的值
如何使用 concat() 连接两个数组
如何使用 concat() 连接三个数组

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript concat() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript concat() 方法

返回 JavaScript String 对象参考手册

定义和用法

concat() 方法用于连接两个或多个字符串。

语法

stringObject.concat(stringX,stringX,...,stringX)
参数 | 描述
stringX | 必需。将被连接为一个字符串的一个或多个字符串对象。

concat() 方法将把它的所有参数转换成字符串，然后按顺序连接到字符串 stringObject 的尾部，并返回连接后的字符串。请注意，stringObject 本身并没有被更改。

stringObject.concat() 与 Array.concat() 很相似。

提示和注释

提示：请注意，使用 " + " 运算符来进行字符串的连接运算通常会更简便一些。

实例

在本例中，我们将创建两个字符串，然后使用 concat() 把它们显示为一个字符串：

<script type="text/javascript">

var str1="Hello "
var str2="world!"
document.write(str1.concat(str2))

</script>

以上代码的输出是：

Hello world!

TIY

concat()
如何使用 concat() 来连接两个字符串。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript Cookies

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript Cookies

  • Previous Page
  • Next Page

cookie 用来识别用户。

实例

创建一个欢迎 cookie
利用用户在提示框中输入的数据创建一个 JavaScript Cookie，当该用户再次访问该页面时，根据 cookie 中的信息发出欢迎信息。

什么是cookie?

cookie 是存储于访问者的计算机中的变量。每当同一台计算机通过浏览器请求某个页面时，就会发送这个 cookie。你可以使用 JavaScript 来创建和取回 cookie 的值。

有关cookie的例子：

名字 cookie
当访问者首次访问页面时，他或她也许会填写他/她们的名字。名字会存储于 cookie 中。当访问者再次访问网站时，他们会收到类似 "Welcome John Doe!" 的欢迎词。而名字则是从 cookie 中取回的。
密码 cookie
当访问者首次访问页面时，他或她也许会填写他/她们的密码。密码也可被存储于 cookie 中。当他们再次访问网站时，密码就会从 cookie 中取回。
日期 cookie
当访问者首次访问你的网站时，当前的日期可存储于 cookie 中。当他们再次访问网站时，他们会收到类似这样的一条消息："Your last visit was on Tuesday August 11, 2005!"。日期也是从 cookie 中取回的。

创建和存储 cookie

在这个例子中我们要创建一个存储访问者名字的 cookie。当访问者首次访问网站时，他们会被要求填写姓名。名字会存储于 cookie 中。当访问者再次访问网站时，他们就会收到欢迎词。

首先，我们会创建一个可在 cookie 变量中存储访问者姓名的函数：

function setCookie(c_name,value,expiredays)
{
var exdate=new Date()
exdate.setDate(exdate.getDate()+expiredays)
document.cookie=c_name+ "=" +escape(value)+
((expiredays==null) ? "" : ";expires="+exdate.toGMTString())
}

上面这个函数中的参数存有 cookie 的名称、值以及过期天数。

在上面的函数中，我们首先将天数转换为有效的日期，然后，我们将 cookie 名称、值及其过期日期存入 document.cookie 对象。

之后，我们要创建另一个函数来检查是否已设置 cookie：

function getCookie(c_name)
{
if (document.cookie.length>0)
  {
  c_start=document.cookie.indexOf(c_name + "=")
  if (c_start!=-1)
    {
    c_start=c_start + c_name.length+1
    c_end=document.cookie.indexOf(";",c_start)
    if (c_end==-1) c_end=document.cookie.length
    return unescape(document.cookie.substring(c_start,c_end))
    }
  }
return ""
}

上面的函数首先会检查 document.cookie 对象中是否存有 cookie。假如 document.cookie 对象存有某些 cookie，那么会继续检查我们指定的 cookie 是否已储存。如果找到了我们要的 cookie，就返回值，否则返回空字符串。

最后，我们要创建一个函数，这个函数的作用是：如果 cookie 已设置，则显示欢迎词，否则显示提示框来要求用户输入名字。

function checkCookie()
{
username=getCookie('username')
if (username!=null && username!="")
  {alert('Welcome again '+username+'!')}
else
  {
  username=prompt('Please enter your name:',"")
  if (username!=null && username!="")
    {
    setCookie('username',username,365)
    }
  }
}

这是所有的代码：

<html>
<head>
<script type="text/javascript">
function getCookie(c_name)
{
if (document.cookie.length>0)
  {
  c_start=document.cookie.indexOf(c_name + "=")
  if (c_start!=-1)
    {
    c_start=c_start + c_name.length+1
    c_end=document.cookie.indexOf(";",c_start)
    if (c_end==-1) c_end=document.cookie.length
    return unescape(document.cookie.substring(c_start,c_end))
    }
  }
return ""
}

function setCookie(c_name,value,expiredays)
{
var exdate=new Date()
exdate.setDate(exdate.getDate()+expiredays)
document.cookie=c_name+ "=" +escape(value)+
((expiredays==null) ? "" : ";expires="+exdate.toGMTString())
}

function checkCookie()
{
username=getCookie('username')
if (username!=null && username!="")
  {alert('Welcome again '+username+'!')}
else
  {
  username=prompt('Please enter your name:',"")
  if (username!=null && username!="")
    {
    setCookie('username',username,365)
    }
  }
}
</script>
</head>

<body onLoad="checkCookie()">
</body>
</html>
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript cos() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript cos() 方法

返回 JavaScript Math 对象参考手册

定义和用法

cos() 方法可返回一个数字的余弦值。

语法

Math.cos(x)
参数 | 描述
x | 必需。必须是一个数值。

返回值

x 的余弦值。返回的是 -1.0 到 1.0 之间的数。

实例

在本例中，我们将返回不同数值的余弦值：

<script type="text/javascript">

document.write(Math.cos(3) + "<br />")
document.write(Math.cos(-3) + "<br />")
document.write(Math.cos(0) + "<br />")
document.write(Math.cos(Math.PI) + "<br />")
document.write(Math.cos(2*Math.PI))

</script>

输出：

-0.9899924966004454
-0.9899924966004454
1
-1
1

TIY

cos()
如何使用 cos() 来取得一些数字的余弦值。

返回 JavaScript Math 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript Date 对象参考手册

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript Date 对象参考手册

Date 对象是 JavaScript 的一种内部数据类型。

Date 对象没有可以直接读写的属性，所有对日期和时间值的访问都是通过其方法执行的。

请从下面的表格访问有关 Date 对象的方法的详细信息。

Date 对象的方法

FF: Firefox, N: Netscape, IE: Internet Explorer

方法 | 描述 | FF | N | IE
Date() | 返回当日的日期和时间 | 1 | 2 | 3
getDate() | 从 Date 对象返回一个月中的某一天 (1 ~ 31) | 1 | 2 | 3
getDay() | 从 Date 对象返回一周中的某一天 (0 ~ 6) | 1 | 2 | 3
getMonth() | 从 Date 对象返回月份 (0 ~ 11) | 1 | 2 | 3
getFullYear() | 从 Date 对象以四位数字返回年份 | 1 | 4 | 4
getYear() | 从 Date 对象以两位或四位数字返回年份。 | 1 | 2 | 3
getHours() | 返回 Date 对象的小时 (0 ~ 23) | 1 | 2 | 3
getMinutes() | 返回 Date 对象的分钟 (0 ~ 59) | 1 | 2 | 3
getSeconds() | 返回 Date 对象的秒数 (0 ~ 59)) | 1 | 2 | 3
getMilliseconds() | 返回 Date 对象的毫秒(0 ~ 999) | 1 | 4 | 4
getTime() | 返回 1970 年 1 月 1 日至今的毫秒数 | 1 | 2 | 3
getTimezoneOffset() | 返回本地时间与格林威治标准时间的分钟差 (GMT) | 1 | 2 | 3
getUTCDate() | 根据世界时从 Date 对象返回月中的一天 (1 ~ 31) | 1 | 4 | 4
getUTCDay() | 根据世界时从 Date 对象返回周中的一天 (0 ~ 6) | 1 | 4 | 4
getUTCMonth() | 根据世界时从 Date 对象返回月份 (0 ~ 11) | 1 | 4 | 4
getUTCFullYear() | 根据世界时从 Date 对象返回四位数的年份 | 1 | 4 | 4
getUTCHours() | 根据世界时返回 Date 对象的小时 (0 ~ 23) | 1 | 4 | 4
getUTCMinutes() | 根据世界时返回 Date 对象的分钟 (0 ~ 59) | 1 | 4 | 4
getUTCSeconds() | 根据世界时返回 Date 对象的秒钟 (0 ~ 59) | 1 | 4 | 4
getUTCMilliseconds() | 根据世界时返回 Date 对象的毫秒(0 ~ 999) | 1 | 4 | 4
parse() | 返回1970年1月1日午夜到指定日期（字符串）的毫秒数 | 1 | 2 | 3
setDate() | 设置 Date 对象中月的某一天 (1 ~ 31)) | 1 | 2 | 3
setMonth() | 设置 Date 对象中月份 (0 ~ 11)) | 1 | 2 | 3
setFullYear() | 设置 Date 对象中的年份（四位数字） | 1 | 4 | 4
setYear() | 设置 Date 对象中的年份（两位或四位数字）。 | 1 | 2 | 3
setHours() | 设置 Date 对象中的小时 (0 ~ 23) | 1 | 2 | 3
setMinutes() | 设置 Date 对象中的分钟 (0 ~ 59) | 1 | 2 | 3
setSeconds() | 设置 Date 对象中的秒钟 (0 ~ 59) | 1 | 2 | 3
setMilliseconds() | 设置 Date 对象中的毫秒 (0 ~ 999) | 1 | 4 | 4
setTime() | 通过向或从1970年1月1日午夜添加或减去指定数目的毫秒来计算日期和时间 | 1 | 2 | 3
setUTCDate() | 根据世界时设置 Date 对象中月份的一天 (1 ~ 31) | 1 | 4 | 4
setUTCMonth() | 根据世界时设置 Date 对象中的月份 (0 ~ 11) | 1 | 4 | 4
setUTCFullYear() | 根据世界时设置 Date 对象中年份（四位数字） | 1 | 4 | 4
setUTCHours() | 根据世界时设置 Date 对象中小时 (0 ~ 23) | 1 | 4 | 4
setUTCMinutes() | 根据世界时设置 Date 对象中分钟 (0 ~ 59) | 1 | 4 | 4
setUTCSeconds() | 根据世界时设置 Date 对象中秒钟 (0 ~ 59) | 1 | 4 | 4
setUTCMilliseconds() | 根据世界时设置 Date 对象中毫秒S(0 ~ 999) | 1 | 4 | 4
toSource() | 代表对象的源代码 | 1 | 4 | -
toString() | 把 Date 对象转换为字符串。 | 1 | 2 | 4
toTimeString() | 把 Date 对象的时间部分转换为字符串。 | 1 | 2 | 4
toDateString() | 把 Date 对象的日期部分转换为字符串。 | 1 | 2 | 4
toGMTString() | 根据格林威治时间，把 Date 对象转换为字符串。 | 1 | 2 | 3
toUTCString() | 根据世界时，把 Date 对象转换为字符串。 | 1 | 4 | 4
toLocaleString() | 根据本地时间格式，把 Date 对象转换为字符串。 | 1 | 2 | 3
toLocaleTimeString() | 根据本地时间格式，把 Date 对象的时间部分转换为字符串 | 1 | 2 | 3
toLocaleDateString() | 根据本地时间格式，把 Date 对象的日期部分转换为字符串 | 1 | 2 | 3
UTC() | 根据世界时，获得一个日期，然后返回1970年1月1日午夜到该日期的毫秒数。 | 1 | 2 | 3
valueOf() | 返回 Date 对象的原始值。 | 1 | 2 | 4

Date 对象的属性

FF: Firefox, N: Netscape, IE: Internet Explorer

属性 | 描述 | FF | N | IE
constructor | 一个对创建对象的函数的引用 | 1 | 4 | 4
prototype | 使您有能力向对象添加属性和方法 | 1 | 3 | 4

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript Date() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript Date() 方法

返回 JavaScript Date 对象参考手册

定义和用法

Date() 方法可返回当天的日期和时间。

语法

Date()

实例

在本例中，我们将输出今天的日期和时间：

<script type="text/javascript">

document.write(Date())

</script>

输出：

TIY

Date()
如何使用 Date() 来取得当天的日期。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript Date（日期）对象

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript Date（日期）对象

  • Previous Page
  • Next Page

日期对象用于处理日期和时间。

JavaScript Date（日期）对象 实例

返回当日的日期和时间
如何使用 Date() 方法或者当日的日期。
getTime()
使用 getTime() 计算从 1970 年到今天有多少年。
setFullYear()
如何使用 setFullYear() 得到精确的日期。
toUTCString()
如何使用 toUTCString() 将当日的日期（根据 UTC）转换为字符串。
getDay()
如何使用 getDay() 来显示星期，而不仅仅是数字。
显示一个钟表
如何在网页上显示一个钟表。

完整的 Date 对象参考手册

我们提供 JavaScript Date 对象参考手册，其中包括所有可用于日期对象的属性和方法。

该手册包含了对每个属性和方法的详细描述以及相关实例。

定义日期

Date 对象用于处理日期和时间。

可以通过 new 关键词来定义 Date 对象。以下代码定义了名为 myDate 的 Date 对象：

var myDate=new Date()

注释：Date 对象自动使用当前的日期和时间作为其初始值。

操作日期

通过使用针对日期对象的方法，我们可以很容易地对日期进行操作。

在下面的例子中，我们为日期对象设置了一个特定的日期 (2008 年 8 月 9 日)：

var myDate=new Date()
myDate.setFullYear(2008,7,9)

注意：表示月份的参数介于 0 到 11 之间。也就是说，如果希望把月设置为 8 月，则参数应该是 7。

在下面的例子中，我们将日期对象设置为 5 天后的日期：

var myDate=new Date()
myDate.setDate(myDate.getDate()+5)

注意：如果增加天数会改变月份或者年份，那么日期对象会自动完成这种转换。

比较日期

日期对象也可用于比较两个日期。

下面的代码将当前日期与 2008 年 8 月 9 日做了比较：

var myDate=new Date();
myDate.setFullYear(2008,7,9);

var today = new Date();

if (myDate>today)
{
alert("Today is before 9th August 2008");
}
else
{
alert("Today is after 9th August 2008");
}
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript decodeURI() 函数

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript decodeURI() 函数

返回 JavaScript 全局对象参考手册

定义和用法

decodeURI() 函数可对 encodeURI() 函数编码过的 URI 进行解码。

语法

decodeURI(URIstring)
参数 | 描述
URIstring | 必需。一个字符串，含有要解码的 URI 或其他要解码的文本。

返回值

URIstring 的副本，其中的十六进制转义序列将被它们表示的字符替换。

实例

在本例中，我们将使用 decodeURI() 对一个编码后的 URI 进行解码：

<script type="text/javascript">

var test1="http://www.w3school.com.cn/My first/"

document.write(encodeURI(test1)+ "<br />")
document.write(decodeURI(test1))

</script>

输出：

http://www.w3school.com.cn/My%20first/
http://www.w3school.com.cn/My first/

TIY

decodeURI()
如何使用 decodeURI() 对编码后的 URI 进行解码。

返回 JavaScript 全局对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript decodeURIComponent() 函数

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript decodeURIComponent() 函数

返回 JavaScript 全局对象参考手册

定义和用法

decodeURIComponent() 函数可对 encodeURIComponent() 函数编码的 URI 进行解码。

语法

decodeURIComponent(URIstring)
参数 | 描述
URIstring | 必需。一个字符串，含有编码 URI 组件或其他要解码的文本。

返回值

URIstring 的副本，其中的十六进制转义序列将被它们表示的字符替换。

实例

在本例中，我们将使用 decodeURIComponent() 对编码后的 URI 进行解码：

<script type="text/javascript">

var test1="http://www.w3school.com.cn/My first/"

document.write(encodeURIComponent(test1)+ "<br />")
document.write(decodeURIComponent(test1))

</script>

输出：

http%3A%2F%2Fwww.w3school.com.cn%2FMy%20first%2F
http://www.w3school.com.cn/My first/

TIY

decodeURIComponent()
如何使用 decodeURIComponent() 对编码后的 URI 进行解码。

返回 JavaScript 全局对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript encodeURI() 函数

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript encodeURI() 函数

返回 JavaScript 全局对象参考手册

定义和用法

encodeURI() 函数可把字符串作为 URI 进行编码。

语法

encodeURI(URIstring)
参数 | 描述
URIstring | 必需。一个字符串，含有 URI 或其他要编码的文本。

返回值

URIstring 的副本，其中的某些字符将被十六进制的转义序列进行替换。

说明

该方法不会对 ASCII 字母和数字进行编码，也不会对这些 ASCII 标点符号进行编码： - _ . ! ~ * ' ( ) 。

该方法的目的是对 URI 进行完整的编码，因此对以下在 URI 中具有特殊含义的 ASCII 标点符号，encodeURI() 函数是不会进行转义的：;/?:@&=+$,#

提示和注释

提示：如果 URI 组件中含有分隔符，比如 ? 和 #，则应当使用 encodeURIComponent() 方法分别对各组件进行编码。

实例

在本例zhogn，我们将使用 encodeURI() 对 URI 进行编码：

<script type="text/javascript">

document.write(encodeURI("http://www.w3school.com.cn")+ "<br />")
document.write(encodeURI("http://www.w3school.com.cn/My first/"))
document.write(encodeURI(",/?:@&=+$#"))

</script>

输出：

http://www.w3school.com.cn
http://www.w3school.com.cn/My%20first/
,/?:@&=+$#

TIY

encodeURI()
如何使用 encodeURI() 来编码不同的 URI。

返回 JavaScript 全局对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript encodeURIComponent() 函数

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript encodeURIComponent() 函数

返回 JavaScript 全局对象参考手册

定义和用法

encodeURIComponent() 函数可把字符串作为 URI 组件进行编码。

语法

encodeURIComponent(URIstring)
参数 | 描述
URIstring | 必需。一个字符串，含有 URI 组件或其他要编码的文本。

返回值

URIstring 的副本，其中的某些字符将被十六进制的转义序列进行替换。

说明

该方法不会对 ASCII 字母和数字进行编码，也不会对这些 ASCII 标点符号进行编码： - _ . ! ~ * ' ( ) 。

其他字符（比如 ：;/?:@&=+$,# 这些用于分隔 URI 组件的标点符号），都是由一个或多个十六进制的转义序列替换的。

提示和注释

提示：请注意 encodeURIComponent() 函数 与 encodeURI() 函数的区别之处，前者假定它的参数是 URI 的一部分（比如协议、主机名、路径或查询字符串）。因此 encodeURIComponent() 函数将转义用于分隔 URI 各个部分的标点符号。

实例

在本例中，我们将使用 encodeURIComponent() 对 URI 进行编码：

<script type="text/javascript">

document.write(encodeURIComponent("http://www.w3school.com.cn"))
document.write("<br />")
document.write(encodeURIComponent("http://www.w3school.com.cn/p 1/"))
document.write("<br />")
document.write(encodeURIComponent(",/?:@&=+$#"))

</script>

输出：

http%3A%2F%2Fwww.w3school.com.cn
http%3A%2F%2Fwww.w3school.com.cn%2Fp%201%2F
%2C%2F%3F%3A%40%26%3D%2B%24%23

TIY

encodeURIComponent()
如何使用 encodeURIComponent() 来编码不同的 URI。

返回 JavaScript 全局对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript escape() 函数

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript escape() 函数

返回 JavaScript 全局对象参考手册

定义和用法

escape() 函数可对字符串进行编码，这样就可以在所有的计算机上读取该字符串。

语法

escape(string)
参数 | 描述
string | 必需。要被转义或编码的字符串。

返回值

已编码的 string 的副本。其中某些字符被替换成了十六进制的转义序列。

说明

该方法不会对 ASCII 字母和数字进行编码，也不会对下面这些 ASCII 标点符号进行编码： - _ . ! ~ * ' ( ) 。其他所有的字符都会被转义序列替换。

提示和注释

提示：可以使用 unescape() 对 escape() 编码的字符串进行解码。

注释：ECMAScript v3 反对使用该方法，应用使用 decodeURI() 和 decodeURIComponent() 替代它。

实例

在本例中，我们将使用 escape() 来编码字符串：

<script type="text/javascript">

document.write(escape("Visit W3School!") + "<br />")
document.write(escape("?!=()#%&"))

</script>

输出：

TIY

escape()
如何使用 escape() 来编码字符串。

返回 JavaScript 全局对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript eval() 函数

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript eval() 函数

返回 JavaScript 全局对象参考手册

定义和用法

eval() 函数可计算某个字符串，并执行其中的的 JavaScript 代码。

语法

eval(string)
参数 | 描述
string | 必需。要计算的字符串，其中含有要计算的 JavaScript 表达式或要执行的语句。

返回值

通过计算 string 得到的值（如果有的话）。

说明

该方法只接受原始字符串作为参数，如果 string 参数不是原始字符串，那么该方法将不作任何改变地返回。因此请不要为 eval() 函数传递 String 对象来作为参数。

如果试图覆盖 eval 属性或把 eval() 方法赋予另一个属性，并通过该属性调用它，则 ECMAScript 实现允许抛出一个 EvalError 异常。

抛出

如果参数中没有合法的表达式和语句，则抛出 SyntaxError 异常。

如果非法调用 eval()，则抛出 EvalError 异常。

如果传递给 eval() 的 Javascript 代码生成了一个异常，eval() 将把该异常传递给调用者。

提示和注释

提示：虽然 eval() 的功能非常强大，但在实际使用中用到它的情况并不多。

实例

例子 1

在本例中，我们将在几个字符串上运用 eval()，并看看返回的结果：

<script type="text/javascript">

eval("x=10;y=20;document.write(x*y)")

document.write(eval("2+2"))

var x=10
document.write(eval(x+17))

</script>

输出：

200
4
27

例子 2

看一下在其他情况中，eval() 返回的结果：

eval("2+3")	// 返回 5
var myeval = eval;	// 可能会抛出 EvalError 异常
myeval("2+3");	// 可能会抛出 EvalError 异常

可以使用下面这段代码来检测 eval() 的参数是否合法：

try  {
     alert("Result:" + eval(prompt("Enter an expression:","")));
     }

catch(exception) {
     alert(exception);
     }

TIY

eval()
如何使用 eval()。

返回 JavaScript 全局对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript exec() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript exec() 方法

返回 JavaScript RegExp 对象参考手册

定义和用法

exec() 方法用于检索字符串中的正则表达式的匹配。

语法

RegExpObject.exec(string)
参数 | 描述
string | 必需。要检索的字符串。

返回值

返回一个数组，其中存放匹配的结果。如果未找到匹配，则返回值为 null。

说明

exec() 方法的功能非常强大，它是一个通用的方法，而且使用起来也比 test() 方法以及支持正则表达式的 String 对象的方法更为复杂。

如果 exec() 找到了匹配的文本，则返回一个结果数组。否则，返回 null。此数组的第 0 个元素是与正则表达式相匹配的文本，第 1 个元素是与 RegExpObject 的第 1 个子表达式相匹配的文本（如果有的话），第 2 个元素是与 RegExpObject 的第 2 个子表达式相匹配的文本（如果有的话），以此类推。除了数组元素和 length 属性之外，exec() 方法还返回两个属性。index 属性声明的是匹配文本的第一个字符的位置。input 属性则存放的是被检索的字符串 string。我们可以看得出，在调用非全局的 RegExp 对象的 exec() 方法时，返回的数组与调用方法 String.match() 返回的数组是相同的。

但是，当 RegExpObject 是一个全局正则表达式时，exec() 的行为就稍微复杂一些。它会在 RegExpObject 的 lastIndex 属性指定的字符处开始检索字符串 string。当 exec() 找到了与表达式相匹配的文本时，在匹配后，它将把 RegExpObject 的 lastIndex 属性设置为匹配文本的最后一个字符的下一个位置。这就是说，您可以通过反复调用 exec() 方法来遍历字符串中的所有匹配文本。当 exec() 再也找不到匹配的文本时，它将返回 null，并把 lastIndex 属性重置为 0。

提示和注释

重要事项：如果在一个字符串中完成了一次模式匹配之后要开始检索新的字符串，就必须手动地把 lastIndex 属性重置为 0。

提示：请注意，无论 RegExpObject 是否是全局模式，exec() 都会把完整的细节添加到它返回的数组中。这就是 exec() 与 String.match() 的不同之处，后者在全局模式下返回的信息要少得多。因此我们可以这么说，在循环中反复地调用 exec() 方法是唯一一种获得全局模式的完整模式匹配信息的方法。

实例

在本例中，我们将全局检索字符串中的 W3School：

<script type="text/javascript">

var str = "Visit W3School";
var patt = new RegExp("W3School","g");
var result;

while ((result = patt.exec(str)) != null)  {
  document.write(result);
  document.write("<br />");
  document.write(result.lastIndex);
 }
</script>

输出：

W3School
14

TIY

exec()
如何使用 exec() 来检索字符串。

返回 JavaScript RegExp 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript exp() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript exp() 方法

返回 JavaScript Math 对象参考手册

定义和用法

exp() 方法可返回 e 的 x 次幂的值。

语法

Math.exp(x)
参数 | 描述
x | 必需。任意数值或表达式。被用作指数。

返回值

返回 e 的 x 次幂。e 代表自然对数的底数，其值近似为 2.71828。

实例

在下面的例子中，我们将把 exp() 运用到不同的数值上：

<script type="text/javascript">

document.write(Math.exp(1) + "<br />")
document.write(Math.exp(-1) + "<br />")
document.write(Math.exp(5) + "<br />")
document.write(Math.exp(10) + "<br />")

</script>

输出：

2.718281828459045
0.36787944117144233
148.4131591025766
22026.465794806718

TIY

exp()
如何使用 exp() 方法。

返回 JavaScript Math 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript fixed() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript fixed() 方法

返回 JavaScript String 对象参考手册

定义和用法

fixed() 方法用于把字符串显示为打字机字体。

语法

stringObject.fixed()

实例

在本例中，"Hello world!" 将被显示为打字机文本：

<script type="text/javascript">

var str="Hello world!"
document.write(str.fixed())

</script>

TIY

fixed()
如何使用 fixed() 把字符串显示为打字机字体。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript floor() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript floor() 方法

返回 JavaScript Math 对象参考手册

定义和用法

floor() 方法可对一个数进行下舍入。

语法

Math.floor(x)
参数 | 描述
x | 必需。任意数值或表达式。

返回值

小于等于 x，且与 x 最接近的整数。

说明

floor() 方法执行的是向下取整计算，它返回的是小于或等于函数参数，并且与之最接近的整数。

实例

In this example we will use the floor() method on different numbers:

<script type="text/javascript">

document.write(Math.floor(0.60) + "<br />")
document.write(Math.floor(0.40) + "<br />")
document.write(Math.floor(5) + "<br />")
document.write(Math.floor(5.1) + "<br />")
document.write(Math.floor(-5.1) + "<br />")
document.write(Math.floor(-5.9))

</script>

输出：

0
0
5
5
-6
-6

TIY

floor()
如何使用 floor() 方法。

返回 JavaScript Math 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript fontcolor() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript fontcolor() 方法

返回 JavaScript String 对象参考手册

定义和用法

fontcolor() 方法用于按照指定的颜色来显示字符串。

语法

stringObject.fontcolor(color)
参数 | 描述
color | 必需。为字符串规定 font-color。该值必须是颜色名(red)、RGB 值(rgb(255,0,0))或者十六进制数(#FF0000)。

实例

在本例中，"Hello world!" 将显示为红色：

<script type="text/javascript">

var str="Hello world!"
document.write(str.fontcolor("Red"))

</script>

TIY

fontcolor()
如何使用 fontcolor() 来把字符串显示为红色。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript fontsize() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript fontsize() 方法

返回 JavaScript String 对象参考手册

定义和用法

fontsize() 方法用于按照指定的尺寸来显示字符串。

语法

stringObject.fontsize(size)

提示和注释

注释：size 参数必须是从 1 至 7 的数字。

实例

在本例中，"Hello world!" 将显示为大号字：

<script type="text/javascript">

var str="Hello world!"
document.write(str.fontsize(7))

</script>

TIY

fontsize()
如何使用 fontsize() 把字符串显示为大号字。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript For 循环

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript For 循环

  • Previous Page
  • Next Page

JavaScript 中的循环用来将同一段代码执行指定的次数（或者当指定的条件为 true 时）。

实例

For 循环
如何编写 loop 循环来按照指定的次数执行相同的代码。
循环产生 HTML 标题
如何使用Loop循环来产生不同的HTML标题。

JavaScript 循环

在编写代码时，你常常希望反复执行同一段代码。我们可以使用循环来完成这个功能，这样就用不着重复地写若干行相同的代码。

JavaScript 有两种不同种类的循环：

for
将一段代码循环执行指定的次数
while
当指定的条件为 true 时循环执行代码

for 循环

在脚本的运行次数已确定的情况下使用 for 循环。

语法：

for (变量=开始值;变量<=结束值;变量=变量+步进值)
{
    需执行的代码
}

实例：

解释：下面的例子定义了一个循环程序，这个程序中 i 的起始值为 0。每执行一次循环，i 的值就会累加一次 1，循环会一直运行下去，直到 i 等于 10 为止。

注释：步进值可以为负。如果步进值为负，需要调整 for 声明中的比较运算符。

<html>
<body>

<script type="text/javascript">
var i=0
for (i=0;i<=10;i++)
{
document.write("The number is " + i)
document.write("<br />")
}
</script>

</body>
</html>

结果：

The number is 0
The number is 1
The number is 2
The number is 3
The number is 4
The number is 5
The number is 6
The number is 7
The number is 8
The number is 9
The number is 10

while 循环

我们将在下一节中学习 while 循环。

  • Previous Page
  • Next Page

课外书

如需更多有关 JavaScript for 语句的知识，请阅读 JavaScript 高级教程中的相关内容：

ECMAScript 迭代语句
迭代语句又叫循环语句。本节为您介绍 ECMAScript 提供的四种迭代语句。

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript For...In 声明

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript For...In 声明

  • Previous Page
  • Next Page

For...In 声明用于遍历数组或者对象的属性（对数组或者对象的属性进行循环操作）。

实例

For...In 声明
如何使用 For...In 声明来遍历数组内的元素。

JavaScript For...In 声明

For...In 声明用于对数组或者对象的属性进行循环操作。

for ... in 循环中的代码每执行一次，就会对数组的元素或者对象的属性进行一次操作。

语法：

for (变量 in 对象)
{
    在此执行代码
}

“变量”用来指定变量，指定的变量可以是数组元素，也可以是对象的属性。

实例：

使用 for ... in 循环遍历数组。

<html>
<body>

<script type="text/javascript">
var x
var mycars = new Array()
mycars[0] = "Saab"
mycars[1] = "Volvo"
mycars[2] = "BMW"

for (x in mycars)
{
document.write(mycars[x] + "<br />")
}
</script>

</body>
</html>
  • Previous Page
  • Next Page

课外书

如需更多有关 JavaScript for-in 语句的知识，请阅读 JavaScript 高级教程中的相关内容：

ECMAScript 迭代语句
迭代语句又叫循环语句。本节为您介绍 ECMAScript 提供的四种迭代语句。

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript fromCharCode() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript fromCharCode() 方法

返回 JavaScript String 对象参考手册

定义和用法

fromCharCode() 可接受一个指定的 Unicode 值，然后返回一个字符串。

语法

String.fromCharCode(numX,numX,...,numX)
参数 | 描述
numX | 必需。一个或多个 Unicode 值，即要创建的字符串中的字符的 Unicode 编码。

提示和注释

注释：该方法是 String 的静态方法，字符串中的每个字符都由单独的数字 Unicode 编码指定。

它不能作为您已创建的 String 对象的方法来使用。因此它的语法应该是 String.fromCharCode()，而不是 myStringObject.fromCharCode()。

实例

在本例中，我们将根据 Unicode 来输出 "HELLO" 和 "ABC"：

<script type="text/javascript">

document.write(String.fromCharCode(72,69,76,76,79))
document.write("<br />")
document.write(String.fromCharCode(65,66,67))

</script>

以上代码的输出：

HELLO
ABC

TIY

fromCharCode()
如何使用 fromCharCode() 来根据 Unicode 值显示字符串。

参阅

charCodeAt() 方法

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript getClass() 函数

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript getClass() 函数

返回 JavaScript 全局对象参考手册

定义和用法

getClass() 函数可返回一个 JavaObject 的 JavaClass。

语法

getClass(javaobj)
参数 | 描述
javaobj | 一个 JavaObject 对象。

返回值

javaobj 的 JavaClass 对象。

说明

该函数可接受一个 JavaObject 对象作为其参数，并返回该对象的 JavaClass，即返回 JavaClass 对象。该 JavaClass 对象表示 Java 对象的 Java 类，而这个 Java 对象所表示的 Java 类是由 JavaObject 指定的。

习惯用法

请不要把 JavaScript 的 getClass() 函数与所有 Java 对象的 getClass 方法混淆在一起。也不要把 JavaScript 的 JavaClass 对象与 Java java.lang.Class 类混淆了。

请看下面这行代码，它可创建一个 Java Rectangle 对象：

var obj = new java.awt.Rectangle();

obj 是一个保存了 JavaObject 的 JavaScript 变量。我们可以调用 JavaScript 函数 getClass() 返回一个 JavaClass 对象，该 JavaClass 对象表示 java.awt.Rectangle 类：

var cls = getClass(obj);

而调用 Java getClass() 的方式有所不同，且执行完全不同的功能：

cls = obj.getClass();

在执行了上面这行代码后，cls 是表示 java.lang.class 对象的一个 Java Object。这个 java.lang.class 对象是一个 Java 对象，它是 java.awt.Rectangle 类的一个 Java 表示。

最后，对于任何的 JavaObject obj，您do会看到下面的表示式始终为 true：

(getClass(obj.getClass()) == java.lang.Class)

返回 JavaScript 全局对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript getDate() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript Date() 方法

返回 JavaScript Date 对象参考手册

定义和用法

getDate() 方法可返回月份的某一天。

语法

dateObject.getDate()

返回值

dateObject 所指的月份中的某一天，使用本地时间。返回值是 1 ~ 31 之间的一个整数。

提示和注释：

注释：该方法总是结合一个 Date 对象来使用。

实例

例子 1

在本例中，我们将输出当前月份的日期：

<script type="text/javascript">

var d = new Date()
document.write(d.getDate())

</script>

输出：

例子 2

在本例中，我们定义了一个带有具体日期的变量，并输出变量中月份的天：

<script type="text/javascript">

var birthday = new Date("July 21, 1983 01:15:00")
document.write(birthday.getDate())

</script>

输出：

21

TIY

getDate()
如何使用 getDate() 来取得当前月份的日期。
以不同的格式显示当前日期
如何使用 getDate(), getMonth() 以及 getFullYear() 以不同的格式来显示当前日期。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript getDay() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript getDay() 方法

返回 JavaScript Date 对象参考手册

定义和用法

getDay() 方法可返回表示星期的某一天的数字。

语法

dateObject.getDay()

返回值

dateObject 所指的星期中的某一天，使用本地时间。返回值是 0（周日） 到 6（周日） 之间的一个整数。

提示和注释：

注释：该方法总是结合一个 Date 对象来使用。

实例

例子 1

在本例中，我们将以数字取得星期的当前一天：

<script type="text/javascript">

var d=new Date()
document.write(d.getDay())

</script>

输出：

例子 2

现在，我们将创建一个数组，这样就可以使上面的例子输出星期的名称，而不是数字：

<script type="text/javascript">

var d=new Date()

var weekday=new Array(7)
weekday[0]="Sunday"
weekday[1]="Monday"
weekday[2]="Tuesday"
weekday[3]="Wednesday"
weekday[4]="Thursday"
weekday[5]="Friday"
weekday[6]="Saturday"

document.write("Today it is " + weekday[d.getDay()])

</script>

输出：

TIY

getDay()
使用 getDay() 和一个数组来输出星期的名称，而不是数字。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript getFullYear() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript getFullYear() 方法

返回 JavaScript Date 对象参考手册

定义和用法

getFullYear() 方法可返回一个表示年份的 4 位数字。

语法

dateObject.getFullYear()

返回值

当 dateObject 用本地时间表示时返回的年份。返回值是一个四位数，表示包括世纪值在内的完整年份，而不是两位数的缩写形式。

提示和注释：

注释：该方法总是结合一个 Date 对象来使用。

实例

例子 1

在本例中，我们将取得当前的年份，并输出它：

<script type="text/javascript">

var d = new Date()
document.write(d.getFullYear())

</script>

输出：

例子 2

在本例中，我们将从具体到日期提取年份：

<script type="text/javascript">

var born = new Date("July 21, 1983 01:15:00")
document.write("I was born in " + born.getFullYear())

</script>

输出：

I was born in 1983

TIY

以不同的格式显示当前的日期
如何使用 getDate(), getMonth() 以及 getFullYear() 以不同的格式来显示当前的日期。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript getHours() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript getHours() 方法

返回 JavaScript Date 对象参考手册

定义和用法

getHours() 方法可返回时间的小时字段。

语法

dateObject.getHours()

返回值

dateObject 的小时字段，以本地时间显示。返回值是 0 （午夜） 到 23 （晚上 11 点）之间的一个整数。

提示和注释：

注释：由 getHours() 返回的值是一个两位的数字。不过返回值不总是两位的，如果该值小于 10，则仅返回一位数字。

注释：该方法总是结合一个 Date 对象来使用。

实例

例子 1

在本例中，我们可取得当前时间的小时：

<script type="text/javascript">

var d = new Date()
document.write(d.getHours())

</script>

输出：

例子 2

在本例中，我们将从具体的日期和时间中提取出小时字段：

<script type="text/javascript">

var born = new Date("July 21, 1983 01:15:00")
document.write(born.getHours())

</script>

输出：

1

TIY

显示当前时间
如何使用 getHours(), getMinutes() 以及 getSeconds() 来显示当前的时间。
显示当前时间（带有一个判断数值是否小于 10 的函数）
如何使用 getHours(), getMinutes() 以及 getSeconds() 来显示当前的时间。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript getMilliseconds() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript getMilliseconds() 方法

返回 JavaScript Date 对象参考手册

定义和用法

getMilliseconds() 方法可返回时间的毫秒。

语法

dateObject.getMilliseconds()

返回值

dateObject 的毫秒字段，以本地时间显示。返回值是 0 ~ 999 之间的一个整数。

提示和注释：

注释：由 getMilliseconds() 返回的值是一个三位的数字。不过返回值不总是三位的，如果该值小于 100，则仅返回两位数字，如果该值小于 10，则仅返回一位数字。

注释：该方法总是结合一个 Date 对象来使用。

实例

例子 1

在本例中，我们可取得当前时间的毫秒：

<script type="text/javascript">

var d = new Date()
document.write(d.getMilliseconds())

</script>

输出：

例子 2

在本例中，我们将从具体的日期和时间中提取出毫秒字段：

<script type="text/javascript">

var born = new Date("July 21, 1983 01:15:00")
document.write(born.getMilliseconds())

</script>

输出：

0

TIY

getMilliseconds()
如何使用 getMilliseconds() 来取得当前的毫秒。
显示当前时间
如何使用 getHours(), getMinutes() 以及 getSeconds() 来显示当前的时间。
显示当前时间（带有一个判断数值是否小于 10 的函数）
如何使用 getHours(), getMinutes() 以及 getSeconds() 来显示当前的时间。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript getMinutes() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript getMinutes() 方法

返回 JavaScript Date 对象参考手册

定义和用法

getMinutes() 方法可返回时间的分钟字段。

语法

dateObject.getMinutes()

返回值

dateObject 的分钟字段，以本地时间显示。返回值是 0 ~ 59 之间的一个整数。

提示和注释：

注释：由 getMinutes() 返回的值是一个两位的数字。不过返回值不总是两位的，如果该值小于 10，则仅返回一位数字。

注释：该方法总是结合一个 Date 对象来使用。

实例

例子 1

在本例中，我们可取得当前时间的分钟：

<script type="text/javascript">

var d = new Date()
document.write(d.getMinutes())

</script>

输出：

例子 2

在本例中，我们将从具体的日期和时间中提取出分钟字段：

<script type="text/javascript">

var born = new Date("July 21, 1983 01:15:00")
document.write(born.getMinutes())

</script>

输出：

15

TIY

显示当前时间
如何使用 getHours(), getMinutes() 以及 getSeconds() 来显示当前的时间。
显示当前时间（带有一个判断数值是否小于 10 的函数）
如何使用 getHours(), getMinutes() 以及 getSeconds() 来显示当前的时间。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript getMonth() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript getMonth() 方法

返回 JavaScript Date 对象参考手册

定义和用法

getMonth() 方法可返回表示月份的数字。

语法

dateObject.getMonth()

返回值

dateObject 的月份字段，使用本地时间。返回值是 0（一月） 到 11（十二月） 之间的一个整数。

提示和注释：

注释：该方法总是结合一个 Date 对象来使用。

实例

例子 1

在本例中，我们将取得当前的日期，并把它输出：

<script type="text/javascript">

var d=new Date()

document.write(d.getMonth())

</script>

输出：

例子 2

现在，我们将创建一个数组，以输出月份的名称，而不是一个数字：

<script type="text/javascript">

var d=new Date()

var month=new Array(12)
month[0]="January"
month[1]="February"
month[2]="March"
month[3]="April"
month[4]="May"
month[5]="June"
month[6]="July"
month[7]="August"
month[8]="September"
month[9]="October"
month[10]="November"
month[11]="December"

document.write("The month is " + month[d.getMonth()])

</script>

输出：

TIY

getMonth()
如何使用 getMonth() 来取得当前月份的名称。
以不同的格式显示当前的日期
如何使用 getDate(), getMonth() 以及 getFullYear() 以不同的格式来显示当前的日期。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript getSeconds() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript getSeconds() 方法

返回 JavaScript Date 对象参考手册

定义和用法

getSeconds() 方法可返回时间的秒。

语法

dateObject.getSeconds()

返回值

dateObject 的分钟字段，以本地时间显示。返回值是 0 ~ 59 之间的一个整数。

提示和注释：

注释：由 getSeconds() 返回的值是一个两位的数字。不过返回值不总是两位的，如果该值小于 10，则仅返回一位数字。

注释：该方法总是结合一个 Date 对象来使用。

实例

例子 1

在本例中，我们可取得当前时间的秒：

<script type="text/javascript">

var d = new Date()
document.write(d.getSeconds())

</script>

输出：

例子 2

在本例中，我们将从具体的日期和时间中提取出秒字段：

<script type="text/javascript">

var Birthday = new Date("July 21, 1983 01:15:00")
document.write(Birthday.getSeconds())

</script>

输出：

0

TIY

显示当前时间
如何使用 getHours(), getMinutes() 以及 getSeconds() 来显示当前的时间。
显示当前时间（带有一个判断数值是否小于 10 的函数）
如何使用 getHours(), getMinutes() 以及 getSeconds() 来显示当前的时间。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript getTime() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript getTime() 方法

返回 JavaScript Date 对象参考手册

定义和用法

getTime() 方法可返回距 1970 年 1 月 1 日之间的毫秒数。

语法

dateObject.getTime()

返回值

dateObject 指定的日期和时间距 1970 年 1 月 1 日午夜（GMT 时间）之间的毫秒数。

提示和注释：

注释：该方法总是结合一个 Date 对象来使用。

实例

例子 1

在本例中，我们将取得从 1970/01/01 至今的毫秒数，并输出它：

<script type="text/javascript">

var d = new Date()
document.write(d.getTime() + " milliseconds since 1970/01/01")

</script>

输出：

例子 2

在下面的例子中，我们将计算出从 1970/01/01 至今有多少年：

<script type="text/javascript">

var minutes = 1000*60
var hours = minutes*60
var days = hours*24
var years = days*365
var d = new Date()
var t = d.getTime()
var y = t/years
document.write("It's been: " + y + " years since 1970/01/01!")

</script>

输出：

TIY

getTime()
使用 getTime() 来计算从 1970 至今有多少年。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript getTimezoneOffset() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript getTimezoneOffset() 方法

返回 JavaScript Date 对象参考手册

定义和用法

getTimezoneOffset() 方法可返回格林威治时间和本地时间之间的时差，以分钟为单位。

语法

dateObject.getTimezoneOffset()

返回值

本地时间与 GMT 时间之间的时间差，以分钟为单位。

说明

getTimezoneOffset() 方法返回的是本地时间与 GMT 时间或 UTC 时间之间相差的分钟数。实际上，该函数告诉我们运行 JavaScript 代码的时区，以及指定的时间是否是夏令时。

返回之所以以分钟计，而不是以小时计，原因是某些国家所占有的时区甚至不到一个小时的间隔。

提示和注释：

注释：由于使用夏令时的惯例，该方法的返回值不是一个常量。

注释：该方法总是结合一个 Date 对象来使用。

实例

例子 1

在下面的例子中，我们将取得 GMT 时间与本地时间以分钟计的时间差：

<script type="text/javascript">

var d = new Date()
document.write(d.getTimezoneOffset())

</script>

输出：

例子 2

现在，我们将把上面的例子转换为 GMT +/- 小时：

<script type="text/javascript">

var d = new Date()
var gmtHours = d.getTimezoneOffset()/60
document.write("The local time zone is: GMT " + gmtHours)

</script>

输出：

The local time zone is: GMT -2

TIY

getTimezoneOffset()
如何使用 getTimezoneOffset() 根据 GMT 来取得本地时区。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript getUTCDate() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript getUTCDate() 方法

返回 JavaScript Date 对象参考手册

定义和用法

getUTCDate() 方法可根据世界时返回一个月 (UTC) 中的某一天。

语法

dateObject.getUTCDate()

返回值

dateObject 用世界时表示时，返回该月中的某一天 （是 1 ~ 31 中的一个值）。

提示和注释：

注释：该方法总是结合一个 Date 对象来使用。

提示：有关通用协调时间 (UTC) 的更多资料，请参阅百度百科。

实例

例子 1

在本例中，我们将根据 UTC 来输出此约的当前一天：

<script type="text/javascript">

var d = new Date()
document.write(d.getUTCDate())

</script>

输出：

例子 2

我们在此处定义了一个带有具体日期的变量，然后根据 UTC 输出变量中的月中的那一天：

<script type="text/javascript">

var birthday = new Date("July 21, 1983 01:15:00")
document.write(birthday.getUTCDate())

</script>

输出：

21

TIY

getUTCDate()
如何使用 getUTCDate() 来取得此月的当前一天（根据 UTC）。
以不同的格式来显示 UTC 日期。
如何使用 getUTCDate(), getUTCMonth() 以及 getUTCFullYear() 以不同的格式来显示 UTC 日期。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript getUTCDay() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript getUTCDay() 方法

返回 JavaScript Date 对象参考手册

定义和用法

getUTCDay() 方法根据世界时返回表示星期的一天的一个数字。

语法

dateObject.getUTCDay()

返回值

dateObject 用世界时表示时，返回该星期中的某一天 ，该值是 0（星期天） ~ 6（星期六） 中的一个值。

提示和注释：

注释：该方法总是结合一个 Date 对象来使用。

提示：有关通用协调时间 (UTC) 的更多资料，请参阅百度百科。

实例

例子 1

在本例中，我们将取得本周的当前 UTC 天（以一个数字）：

<script type="text/javascript">

var d=new Date()
document.write(d.getUTCDay())

</script>

输出：

例子 2

现在，我将创建一个数组，使得上面的例子能够输出星期的名称，而不仅仅是一个数字：

<script type="text/javascript">

var d=new Date()

var weekday=new Array(7)
weekday[0]="Sunday"
weekday[1]="Monday"
weekday[2]="Tuesday"
weekday[3]="Wednesday"
weekday[4]="Thursday"
weekday[5]="Friday"
weekday[6]="Saturday"

document.write("Today it is " + weekday[d.getUTCDay()])

</script>

输出：

TIY

getUTCDay()
使用 getUTCDay() 和一个数组来输出星期的名称，而不是一个数字。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript getUTCFullYear() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript getUTCFullYear() 方法

返回 JavaScript Date 对象参考手册

定义和用法

getUTCFullYear() 方法可返回根据世界时 (UTC) 表示的年份的四位数字。

语法

dateObject.getUTCFullYear()

返回值

返回 dateObject 用世界时表示时的年份，该值是一个四位的整数，而不是两位数的缩写。

提示和注释：

注释：该方法总是结合一个 Date 对象来使用。

提示：有关通用协调时间 (UTC) 的更多资料，请参阅百度百科。

实例

例子 1

In this example we get the current year and print it:

<script type="text/javascript">

var d = new Date()
document.write(d.getUTCFullYear())

</script>

输出：

例子 2

Here we will extract the year out of the specific date:

<script type="text/javascript">

var born = new Date("July 21, 1983 01:15:00")
document.write("I was born in " + born.getUTCFullYear())

</script>

输出：

I was born in 1983

TIY

以不同的格式显示 UTC 日期
如何使用 getUTCDate(), getUTCMonth() 以及 getUTCFullYear() 来使用不同的格式显示 UTC 日期。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript getUTCHours() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript getUTCHours() 方法

返回 JavaScript Date 对象参考手册

定义和用法

getUTCHours() 方法可根据世界时 (UTC) 返回时间的小时。

语法

dateObject.getUTCHours()

返回值

返回 dateObject 用世界时表示时的小时字段，该值是一个 0（午夜） ~ 23（晚上 11 点） 之间的整数。

提示和注释：

注释：由 getUTCHours() 返回的值是一个两位的数字。不过返回值不总是两位的，如果该值小于 10，则仅返回一位数字。

注释：该方法总是结合一个 Date 对象来使用。

提示：有关通用协调时间 (UTC) 的更多资料，请参阅百度百科。

实例

例子 1

在本例中，我们将取得当前时间的 UTC 小时：

<script type="text/javascript">

var d = new Date()
document.write(d.getUTCHours())

</script>

输出：

例子 2

在这里，我们将从具体的日期和时间中提取 UTC 小时：

<script type="text/javascript">

var born = new Date("July 21, 1983 01:15:00")
document.write(born.getUTCHours())

</script>

输出：

TIY

显示当前的 UTC 时间
如何使用 getUTCHours() 显示当前的 UTC 时间。
显示当前的 UTC 时间（带有一个判断数值是否小于 10 的函数）
如何使用 getUTCHours(), getUTCMinutes() 以及 getUTCSeconds() 来显示当前的 UTC 时间。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript getUTCMilliseconds() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript getUTCMilliseconds() 方法

返回 JavaScript Date 对象参考手册

定义和用法

getUTCMilliseconds() 方法可根据世界时 (UTC) 返回时间的毫秒。

语法

dateObject.getUTCMilliseconds()

返回值

当 dateObject 用世界时表示时，返回它的毫秒字段，该值是一个 0 ~ 999 之间的整数。

提示和注释：

注释：由 getUTCMilliseconds() 返回的值是一个三位的数字。不过返回值不总是三位的，如果该值小于 100，则仅返回两位数字，如果该值小于 10，则仅返回一位数字。

注释：该方法总是结合一个 Date 对象来使用。

提示：有关通用协调时间 (UTC) 的更多资料，请参阅百度百科。

实例

例子 1

在本例中，我们将取得当前时间的 UTC 毫秒：

<script type="text/javascript">

var d = new Date()
document.write(d.getUTCMilliseconds())

</script>

输出：

例子 2

在此处，我们将从具体的日期和时间中提取 UTC 毫秒：

<script type="text/javascript">

var born = new Date("July 21, 1983 01:15:00")
document.write(born.getUTCMilliseconds())

</script>

输出：

0

注释：上面的代码将把毫秒设置为 1，这是由于在日期中没有定义毫秒。

TIY

getUTCMilliseconds()
如何使用 getUTCMilliseconds() 来取得当前的 UTC 毫秒。
显示当前的 UTC 时间
如何使用 getUTCHours() 显示当前的 UTC 时间。
显示当前的 UTC 时间（带有一个判断数值是否小于 10 的函数）
如何使用 getUTCHours(), getUTCMinutes() 以及 getUTCSeconds() 来显示当前的 UTC 时间。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript getUTCMinutes() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript getUTCMinutes() 方法

返回 JavaScript Date 对象参考手册

定义和用法

getUTCMinutes() 方法可根据世界时 (UTC) 返回时间的分钟字段。

语法

dateObject.getUTCMinutes()

返回值

返回 dateObject 用世界时表示时的分钟字段，该值是一个 0 ~ 59 之间的整数。

提示和注释：

注释：由 getUTCMinutes() 返回的值是一个两位的数字。不过返回值不总是两位的，如果该值小于 10，则仅返回一位数字。

注释：该方法总是结合一个 Date 对象来使用。

提示：有关通用协调时间 (UTC) 的更多资料，请参阅百度百科。

实例

例子 1

在本例中，我们将取得当前时间的 UTC 分钟：

<script type="text/javascript">

var d = new Date()
document.write(d.getUTCMinutes())

</script>

输出：

例子 2

在此处，我们将从具体的日期和时间中提取 UTC 分钟：

<script type="text/javascript">

var born = new Date("July 21, 1983 01:15:00")
document.write(born.getUTCMinutes())

</script>

输出：

TIY

显示当前的 UTC 时间
如何使用 getUTCHours() 显示当前的 UTC 时间。
显示当前的 UTC 时间（带有一个判断数值是否小于 10 的函数）
如何使用 getUTCHours(), getUTCMinutes() 以及 getUTCSeconds() 来显示当前的 UTC 时间。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript getUTCMonth() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript getUTCMonth() 方法

返回 JavaScript Date 对象参考手册

定义和用法

getUTCMonth() 方法可返回一个表示月份的数字（按照世界时 UTC）。

语法

dateObject.getUTCMonth()

返回值

返回 dateObject 用世界时表示时的月份，该值是 0（一月） ~ 11（十二月） 之间中的一个整数。

需要注意的是，Date 对象使用 1 来表示月的第一天，而不是像月份字段那样使用 0 来代表一年的第一个月。

提示和注释：

注释：该方法总是结合一个 Date 对象来使用。

提示：有关通用协调时间 (UTC) 的更多资料，请参阅百度百科。

实例

例子 1

在本例中，我们将取得当前月份，然后输出它：

<script type="text/javascript">

var d=new Date()

document.write(d.getUTCMonth())

</script>

输出：

例子 2

现在，我们将创建一个数组，使得我们上面的例子能够输出月份的名称，而不仅仅是一个数字：

<script type="text/javascript">

var d=new Date()

var month=new Array(12)
month[0]="January"
month[1]="February"
month[2]="March"
month[3]="April"
month[4]="May"
month[5]="June"
month[6]="July"
month[7]="August"
month[8]="September"
month[9]="October"
month[10]="November"
month[11]="December"

document.write("The month is " + month[d.getUTCMonth()])

</script>

输出：

TIY

getUTCMonth()
使用 getUTCMonth() 和一个数组来输出月份的名称，而不是一个数字。
以不同的格式显示 UTC 日期
如何使用 getUTCDate(), getUTCMonth() 以及 getUTCFullYear() 来使用不同的格式显示 UTC 日期。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript getUTCSeconds() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript getUTCSeconds() 方法

返回 JavaScript Date 对象参考手册

定义和用法

getUTCSeconds() 方法可根据世界时返回时间的秒。

语法

dateObject.getUTCSeconds()

返回值

当 dateObject 用世界时表示时，返回它的秒字段，该值是一个 0 ~ 59 之间的整数。

提示和注释：

注释：由 getUTCSeconds() 返回的值是一个两位的数字。不过返回值不总是两位的，如果该值小于 10，则仅返回一位数字。

注释：该方法总是结合一个 Date 对象来使用。

提示：有关通用协调时间 (UTC) 的更多资料，请参阅百度百科。

实例

例子 1

在本例中，我们将取得当前时间的 UTC 秒：

<script type="text/javascript">

var d = new Date()
document.write(d.getUTCSeconds())

</script>

输出：

例子 2

在此处，我们将从具体的日期和时间中提取 UTC 秒：

<script type="text/javascript">

var Birthday = new Date("July 21, 1983 01:15:00")
document.write(Birthday.getUTCSeconds())

</script>

输出：

0

TIY

显示当前的 UTC 时间
如何使用 getUTCHours() 显示当前的 UTC 时间。
显示当前的 UTC 时间（带有一个判断数值是否小于 10 的函数）
如何使用 getUTCHours(), getUTCMinutes() 以及 getUTCSeconds() 来显示当前的 UTC 时间。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript getYear() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript getYear() 方法

返回 JavaScript Date 对象参考手册

定义和用法

getYear() 方法可返回表示年份的两位或四位的数字。

语法

dateObject.getYear()

返回值

返回 Date 对象的年份字段。

提示和注释：

注释：由 getYear() 返回的值不总是 4 位的数字！对于介于 1900 与 1999 之间的年份，getYear() 方法仅返回两位数字。对于 1900 之前或 1999 之后的年份，则返回 4 位数字！

注释：该方法总是结合一个 Date 对象来使用。

重要事项：从 ECMAScript v3 开始，JavaScript 的实现就不再使用该方法，而使用 getFullYear() 方法取而代之！

实例

例子 1

在本例中，我们将取得当前的年份，并输出它：

<script type="text/javascript">

var d = new Date()
document.write(d.getYear())

</script>

输出：

例子 2

在本例中，我们将从具体的日期中提取年份：

<script type="text/javascript">

var born = new Date("July 21, 1983 01:15:00")
document.write("I was born in " + born.getYear())

</script>

输出：

I was born in 83

TIY

getYear()
如何使用 getYear() 来取得当前的年份。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript global 属性

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript global 属性

返回 JavaScript RegExp 对象参考手册

定义和用法

global 属性用于返回正则表达式是否具有标志 g。

它声明了给定的正则表达式是否执行全局匹配。

如果 g 标志被设置，则该属性为 true，否则为 false。

语法

RegExpObject.global

实例

在下面的例子中，我们将查看正则表达式是否具有标志 g：

<script type="text/javascript">
var str = "Visit W3School.com.cn";
var patt1 = new RegExp("W3");

if(patt1.global)
  {
  alert("Global property is set");
  }
else
  {
  alert("Global property is NOT set.");
  }
</script>

TIY

global
如何使用 global 属性来检测正则表达式是否具有标志 g。

返回 JavaScript RegExp 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript HTML DOM 对象

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript HTML DOM 对象

  • Previous Page
  • Next Page

除了内置的 JavaScript 对象以外，你还可以使用 JavaScript 访问并处理所有的 HTML DOM 对象。

更多 JavaScript 对象

点击以下链接，可以获得以下对象的更多信息，包括它们的集合、属性、方法以及事件。

对象 | 描述
Window | JavaScript 层级中的顶层对象。Windows 对象会呈现 (represent) 一个浏览器窗口。每当 <body> 或者 <frameset> 标签出现，Window 对象就会被自动创建。
Navigator | 包含客户端浏览器的信息。
Screen | 包含客户端显示屏的信息。
History | 包含了浏览器窗口访问过的 URL。
Location | 包含了当前URL的信息。

HTML DOM

HTML DOM 是 W3C 标准（是 HTML 文档对象模型的英文缩写，Document Object Model for HTML）。

HTML DOM 定义了用于 HTML 的一系列标准的对象，以及访问和处理 HTML 文档的标准方法。

通过 DOM，可以访问所有的 HTML 元素，连同它们所包含的文本和属性。可以对其中的内容进行修改和删除，同时也可以创建新的元素。

HTML DOM 独立于平台和编程语言。它可被任何编程语言诸如 Java、JavaScript 和 VBScript 使用。

点击下面的链接，可获得更多关于如何使用 JavaScript 来访问和处理 DOM 对象的知识：

对象 | 描述
Document | 代表整个 HTML 文档，用来访问页面中的所有元素。
Anchor | 代表 <a> 元素。
Area | 代表图像地图中的 <area> 元素。
Base | 代表 <base> 元素。
Body | 代表图像地图中的 <body> 元素。
Button | 代表 <button> 元素。
Event | 代表事件的状态
Form | 代表 <form> 元素
Frame | 代表 <frame> 元素
Frameset | 代表 <frameset> 元素
Iframe | 代表 <iframe> 元素
Image | 代表 <img> 元素
Input button | 代表 HTML 表单中的按钮
Input checkbox | 代表 HTML 表单中的选择框
Input file | 代表 HTML 表单中的 fileupload 。
Input hidden | 代表 HTML 表单中的隐藏域。
Input password | 代表 HTML 表单中的密码域。
Input radio | 代表 HTML 表单中的单选框。
Input reset | 代表 HTML 表单中的重置按钮。
Input submit | 代表 HTML 表单中的确认按钮。
Input text | 代表 HTML 表单中的文本输入域。
Link | 代表 <link> 元素
Meta | 代表 <meta> 元素
Object | 代表一个 <Object> 元素
Option | 代表 <option> 元素
Select | 代表 HTML 表单中的选择列表。
Style | 代表某个单独的样式声明。
Table | 代表 <table> 元素。
TableData | 代表 <td> 元素。
TableRow | 代表 <tr> 元素。
Textarea | 代表 <textarea> 元素。
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript If...Else 语句

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript If...Else 语句

  • Previous Page
  • Next Page

JavaScript 中的条件语句用于完成不同条件下的行为。

实例

If 语句
如何编写一个 If 语句。
If...else 语句
如何编写 if...else 语句。
If..else if...else 语句
如何编写 if..else if...else 语句
随机链接
本例演示一个随机的链接，当您单击这个链接时，会打开某个随机的网站。

条件语句

在您编写代码时，经常需要根据不同的条件完成不同的行为。可以在代码中使用条件语句来完成这个任务。

在 JavaScript 中，我们可以使用下面几种条件语句：

if 语句
在一个指定的条件成立时执行代码。
if...else 语句
在指定的条件成立时执行代码，当条件不成立时执行另外的代码。
if...else if....else 语句
使用这个语句可以选择执行若干块代码中的一个。
switch 语句
使用这个语句可以选择执行若干块代码中的一个。

If 语句

如果希望指定的条件成立时执行代码，就可以使用这个语句。

语法：

if (条件)
{
条件成立时执行代码
}

注意：请使用小写字母。使用大写的 IF 会出错！

实例 1

<script type="text/javascript">
//Write a "Good morning" greeting if
//the time is less than 10

var d=new Date()
var time=d.getHours()

if (time<10)
{
document.write("<b>Good morning</b>")
}
</script>

实例 2

<script type="text/javascript">
//Write "Lunch-time!" if the time is 11

var d=new Date()
var time=d.getHours()

if (time==11)
{
document.write("<b>Lunch-time!</b>")
}
</script>

注意：请使用双等号 (==) 来比较变量！

注意：在语法中没有 else。仅仅当条件为 true 时，代码才会执行。

If...else 语句

如果希望条件成立时执行一段代码，而条件不成立时执行另一段代码，那么可以使用 if....else 语句。

语法：

if (条件)
{
条件成立时执行此代码
}
else
{
条件不成立时执行此代码
}

实例

<script type="text/javascript">
//If the time is less than 10,
//you will get a "Good morning" greeting.
//Otherwise you will get a "Good day" greeting.

var d = new Date()
var time = d.getHours()

if (time < 10)
{
document.write("Good morning!")
}
else
{
document.write("Good day!")
}
</script>

If...else if...else 语句

当需要选择多套代码中的一套来运行时，请使用 if....else if...else 语句。

语法：

if (条件1)
{
条件1成立时执行代码
}
else if (条件2)
{
条件2成立时执行代码
}
else
{
条件1和条件2均不成立时执行代码
}

实例：

<script type="text/javascript">

var d = new Date()
var time = d.getHours()

if (time<10)
{
document.write("<b>Good morning</b>")
}
else if (time>10 && time<16)
{
document.write("<b>Good day</b>")
}
else
{
document.write("<b>Hello World!</b>")
}
</script>
  • Previous Page
  • Next Page

课外书

如需更多有关 JavaScript if 语句的知识，请阅读 JavaScript 高级教程中的相关内容：

ECMAScript if 语句
if 语句是 ECMAScript 中最常用的语句之一。本节为您详细讲解了如何使用 if 语句。

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript ignoreCase 属性

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript ignoreCase 属性

返回 JavaScript RegExp 对象参考手册

定义和用法

global 属性用于返回正则表达式是否具有标志 i。

它声明了给定的正则表达式是否执行区分大小写的匹配。

如果 i 标志被设置，则该属性为 true，否则为 false。

语法

RegExpObject.ignoreCase

实例

在下面的例子中，我们将查看正则表达式是否具有标志 i：

<script type="text/javascript">
var str = "Visit W3School";
var patt1 = new RegExp("W3");

if(patt1.ignoreCase)
  {
  alert("ignoreCase property is set");
  }
else
  {
  alert("ignoreCase property is NOT set.");
  }
</script>

TIY

ignoreCase
如何使用 ignoreCase 属性来检测正则表达式是否具有标志 i。

返回 JavaScript RegExp 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript indexOf() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript indexOf() 方法

返回 JavaScript String 对象参考手册

定义和用法

indexOf() 方法可返回某个指定的字符串值在字符串中首次出现的位置。

语法

stringObject.indexOf(searchvalue,fromindex)
参数 | 描述
searchvalue | 必需。规定需检索的字符串值。
fromindex | 可选的整数参数。规定在字符串中开始检索的位置。它的合法取值是 0 到 stringObject.length - 1。如省略该参数，则将从字符串的首字符开始检索。

说明

该方法将从头到尾地检索字符串 stringObject，看它是否含有子串 searchvalue。开始检索的位置在字符串的 fromindex 处或字符串的开头（没有指定 fromindex 时）。如果找到一个 searchvalue，则返回 searchvalue 的第一次出现的位置。stringObject 中的字符位置是从 0 开始的。

提示和注释

注释：indexOf() 方法对大小写敏感！

注释：如果要检索的字符串值没有出现，则该方法返回 -1。

实例

在本例中，我们将在"Hello world!" 字符串内进行不同的检索：

<script type="text/javascript">

var str="Hello world!"
document.write(str.indexOf("Hello") + "<br />")
document.write(str.indexOf("World") + "<br />")
document.write(str.indexOf("world"))

</script>

以上代码的输出：

0
-1
6

TIY

indexOf()
如何使用 indexOf() 在字符串内进行检索。

参阅

charCodeAt() 方法、lastIndexOf() 方法、substring() 方法

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript Infinity 属性

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript Infinity 属性

返回 JavaScript 全局对象参考手册

定义和用法

Infinity 属性用于存放表示正无穷大的数值。

语法

Infinity

说明

无法使用 for/in 循环来枚举 Infinity 属性，也不能用 delete 运算符来删除它。

Infinity 不是常量，可以把它设置为其他值。

实例

在本例中，我们将展示当一个数超出了 infinity 的限制发生的情况：

<script type="text/javascript">

var t1=1.7976931348623157E+10308
document.write(t1)

document.write("<br />")

var t2=-1.7976931348623157E+10308
document.write(t2)

</script>

输出：

Infinity
-Infinity

TIY

Infinity
如果一个数超出了 infinity 的限制会发生什么呢？

返回 JavaScript 全局对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript isFinite() 函数

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript isFinite() 函数

返回 JavaScript 全局对象参考手册

定义和用法

isFinite() 函数用于检查其参数是否是无穷大。

语法

isFinite(number)
参数 | 描述
number | 必需。要检测的数字。

返回值

如果 number 是有限数字（或可转换为有限数字），那么返回 true。否则，如果 number 是 NaN（非数字），或者是正、负无穷大的数，则返回 false。

实例

在本例中，我们将使用 isFinite() 在检测无穷数：

<script type="text/javascript">

document.write(isFinite(123)+ "<br />")
document.write(isFinite(-1.23)+ "<br />")
document.write(isFinite(5-2)+ "<br />")
document.write(isFinite(0)+ "<br />")
document.write(isFinite("Hello")+ "<br />")
document.write(isFinite("2005/12/12")+ "<br />")

</script>

输出：

true
true
true
true
false
false

TIY

isFinite()
如何使用 isFinite()。

返回 JavaScript 全局对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript isNaN() 函数

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript isNaN() 函数

返回 JavaScript 全局对象参考手册

定义和用法

isNaN() 函数用于检查其参数是否是非数字值。

语法

isNaN(x)
参数 | 描述
x | 必需。要检测的值。

返回值

如果 x 是特殊的非数字值 NaN（或者能被转换为这样的值），返回的值就是 true。如果 x 是其他值,则返回 false。

说明

isNaN() 函数可用于判断其参数是否是 NaN，该值表示一个非法的数字（比如被 0 除后得到的结果）。

如果把 NaN 与任何值（包括其自身）相比得到的结果均是 false，所以要判断某个值是否是 NaN，不能使用 == 或 === 运算符。正因为如此，isNaN() 函数是必需的。

提示和注释

提示：isNaN() 函数通常用于检测 parseFloat() 和 parseInt() 的结果，以判断它们表示的是否是合法的数字。当然也可以用 isNaN() 函数来检测算数错误，比如用 0 作除数的情况。

实例

在本例中，我们将使用 isFinite() 在检测无穷数：

<script type="text/javascript">

document.write(isFinite(123))	//返回 false
document.write(isFinite(-1.23))	//返回 false
document.write(isFinite(5-2))	//返回 false
document.write(isFinite(0))		//返回 false
document.write(isFinite(0/0))	//返回 true
document.write(isFinite("Hello"))	//返回 true
document.write(isFinite("2005/12/12"))	//返回 true
document.write(isFinite(true))	//返回 false
document.write(isFinite(undefined))	//返回 true

</script>

TIY

isNaN()
如何使用 isNaN()。

返回 JavaScript 全局对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript italics() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript italics() 方法

返回 JavaScript String 对象参考手册

定义和用法

italics() 方法用于把字符串显示为斜体。

语法

stringObject.italics()

实例

在本例中，"Hello world!" 将被显示为斜体：

<script type="text/javascript">

var str="Hello world!"
document.write(str.italics())

</script>

TIY

italics()
如何使用 italics() 把字符串显示为斜体。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript java 属性

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript java 属性

返回 JavaScript 全局对象参考手册

定义和用法

表示 java.* 包层级的 JavaPackage。

语法

java

说明

在包含了 LiveConnect 或其他用于脚本化 Java 的技术的 JavaScript 实现中，全局 java 属性就是一个 JavaPackage 对象，它表示 java.* 包层级。这个属性的存在意味着像 java.util 这样的一个 JavaScript 表示式引用的是 java.util 包。对于不符合 java.* 层级的 Java 包，请参阅全局 Packages 属性。

返回 JavaScript 全局对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript join() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript join() 方法

返回 JavaScript Array 对象参考手册

定义和用法

join() 方法用于把数组中的所有元素放入一个字符串。

元素是通过指定的分隔符进行分隔的。

语法

arrayObject.join(separator)
参数 | 描述
separator | 可选。指定要使用的分隔符。如果省略该参数，则使用逗号作为分隔符。

返回值

返回一个字符串。该字符串是通过把 arrayObject 的每个元素转换为字符串，然后把这些字符串连接起来，在两个元素之间插入 separator 字符串而生成的。

实例

例子 1

在本例中，我们将创建一个数组，然后把它的所有元素放入一个字符串：

<script type="text/javascript">

var arr = new Array(3)
arr[0] = "George"
arr[1] = "John"
arr[2] = "Thomas"

document.write(arr.join())

</script>

输出：

George,John,Thomas

例子 2

在本例中，我们将使用分隔符来分隔数组中的元素：

<script type="text/javascript">

var arr = new Array(3)
arr[0] = "George"
arr[1] = "John"
arr[2] = "Thomas"

document.write(arr.join("."))

</script>

输出：

George.John.Thomas

TIY

join()
如何使用 join() 从数组创建字符串。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript lastIndex 属性

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript lastIndex 属性

返回 JavaScript RegExp 对象参考手册

定义和用法

lastIndex 属性用于规定下次匹配的起始位置。

语法

RegExpObject.lastIndex

说明

该属性存放一个整数，它声明的是上一次匹配文本之后的第一个字符的位置。

上次匹配的结果是由方法 RegExp.exec() 和 RegExp.test() 找到的，它们都以 lastIndex 属性所指的位置作为下次检索的起始点。这样，就可以通过反复调用这两个方法来遍历一个字符串中的所有匹配文本。

该属性是可读可写的。只要目标字符串的下一次搜索开始，就可以对它进行设置。当方法 exec() 或 test() 再也找不到可以匹配的文本时，它们会自动把 lastIndex 属性重置为 0。

提示和注释

重要事项：不具有标志 g 和不表示全局模式的 RegExp 对象不能使用 lastIndex 属性。

提示：如果在成功地匹配了某个字符串之后就开始检索另一个新的字符串，需要手动地把这个属性设置为 0。

实例

在下面的例子中，我们将输出匹配完成之后的 lastIndex 属性：

<script type="text/javascript">
var str = "The rain in Spain stays mainly in the plain";
var patt1 = new RegExp("ain", "g");

patt1.test(str)
document.write("Match found. index now at: " + patt1.lastIndex);
</script>

TIY

lastIndex
如何使用 lastIndex 属性来检测从何处开始下一次匹配。

返回 JavaScript RegExp 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript lastIndexOf() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript lastIndexOf() 方法

返回 JavaScript String 对象参考手册

定义和用法

lastIndexOf() 方法可返回一个指定的字符串值最后出现的位置，在一个字符串中的指定位置从后向前搜索。

语法

stringObject.lastIndexOf(searchvalue,fromindex)
参数 | 描述
searchvalue | 必需。规定需检索的字符串值。
fromindex | 可选的整数参数。规定在字符串中开始检索的位置。它的合法取值是 0 到 stringObject.length - 1。如省略该参数，则将从字符串的最后一个字符处开始检索。

返回值

如果在 stringObject 中的 fromindex 位置之前存在 searchvalue，则返回的是出现的最后一个 searchvalue 的位置。

说明

该方法将从尾到头地检索字符串 stringObject，看它是否含有子串 searchvalue。开始检索的位置在字符串的 fromindex 处或字符串的结尾（没有指定 fromindex 时）。如果找到一个 searchvalue，则返回 searchvalue 的第一个字符在 stringObject 中的位置。stringObject 中的字符位置是从 0 开始的。

提示和注释

注释：lastIndexOf() 方法对大小写敏感！

注释：如果要检索的字符串值没有出现，则该方法返回 -1。

实例

在本例中，我们将在"Hello world!" 字符串内进行不同的检索：

<script type="text/javascript">

var str="Hello world!"
document.write(str.lastIndexOf("Hello") + "<br />")
document.write(str.lastIndexOf("World") + "<br />")
document.write(str.lastIndexOf("world"))

</script>

以上代码的输出：

0
-1
6

TIY

lastIndexOf()
如何使用 lastIndexOf() 在字符串内进行检索。

参阅

charCodeAt() 方法、indexOf() 方法、substring() 方法

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript length 属性

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript length 属性

返回 JavaScript Array 对象参考手册

定义和用法

length 属性可设置或返回数组中元素的数目。

语法

arrayObject.length

说明

数组的 length 属性总是比数组中定义的最后一个元素的下标大 1。对于那些具有连续元素，而且以元素 0 开始的常规数组而言，属性 length 声明了数组中的元素的个数。

数组的 length 属性在用构造函数 Array() 创建数组时被初始化。给数组添加新元素时，如果必要，将更新 length 的值。

设置 length 属性可改变数组的大小。如购设置的值比其当前值小，数组将被截断，其尾部的元素将丢失。如果设置的值比它的当前值大，数组将增大，新的元素被添加到数组的尾部，它们的值为 undefined。

实例

在本例中，我们将展示如何使用 length 属性返回并设置数组的长度：

<script type="text/javascript">

var arr = new Array(3)
arr[0] = "John"
arr[1] = "Andy"
arr[2] = "Wendy"

document.write("Original length: " + arr.length)
document.write("<br />")

arr.length=5
document.write("New length: " + arr.length)

</script>

输出：

Original length: 3
New length: 5

TIY

length
在本例中，我们将展示如何使用 length 属性。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript length 属性

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript length 属性

返回 JavaScript String 对象参考手册

定义和用法

length 属性可返回字符串中的字符数目。

语法

stringObject.length

实例

在本例中，我们将展示如何使用 length 属性来返回字符串中的字符数：

<script type="text/javascript">

var txt="Hello World!"
document.write(txt.length)

</script>

输出：

12

TIY

length
在本例中，我们将展示如何使用 length 属性。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript link() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript link() 方法

返回 JavaScript String 对象参考手册

定义和用法

link() 方法用于把字符串显示为超链接。

语法

stringObject.link(url)
参数 | 描述
url | 必需。规定要链接的 URL。

实例

在本例中，"Free Web Tutorials!" 将被显示为超链接：

<script type="text/javascript">

var str="Free Web Tutorials!"
document.write(str.link("http://www.w3school.com.cn"))

</script>

TIY

link()
如何使用 link() 来把字符串显示为超链接。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript localeCompare() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript localeCompare() 方法

返回 JavaScript String 对象参考手册

定义和用法

用本地特定的顺序来比较两个字符串。

语法

stringObject.localeCompare(target)
参数 | 描述
target | 要以本地特定的顺序与 stringObject 进行比较的字符串。

返回值

说明比较结果的数字。如果 stringObject 小于 target，则 localeCompare() 返回小于 0 的数。如果 stringObject 大于 target，则该方法返回大于 0 的数。如果两个字符串相等，或根据本地排序规则没有区别，该方法返回 0。

说明

把 < 和 > 运算符应用到字符串时，它们只用字符的 Unicode 编码比较字符串，而不考虑当地的排序规则。以这种方法生成的顺序不一定是正确的。例如，在西班牙语中，其中字符 “ch” 通常作为出现在字母 “c” 和 “d” 之间的字符来排序。

localeCompare() 方法提供的比较字符串的方法，考虑了默认的本地排序规则。ECMAscript 标准并没有规定如何进行本地特定的比较操作，它只规定该函数采用底层操作系统提供的排序规则。

实例

在本例中，我们将用本地特定排序规则对字符串数组进行排序：

var str;
str.sort (function(a,b){return a.localeCompare(b)})

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript log() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript log() 方法

返回 JavaScript Math 对象参考手册

定义和用法

log() 方法可返回一个数的自然对数。

语法

Math.log(x)
参数 | 描述
x | 必需。任意数值或表达式。

返回值

x 的自然对数。

说明

参数 x 必须大于 0。

实例

在本例中，我们将对不同的数运用 log() ：

<script type="text/javascript">

document.write(Math.log(2.7183) + "<br />")
document.write(Math.log(2) + "<br />")
document.write(Math.log(1) + "<br />")
document.write(Math.log(0) + "<br />")
document.write(Math.log(-1))

</script>

输出：

1.0000066849139877
0.6931471805599453
0
-Infinity
NaN

TIY

log()
如何使用 log 方法。

返回 JavaScript Math 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript match() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript match() 方法

返回 JavaScript String 对象参考手册

定义和用法

match() 方法可在字符串内检索指定的值，或找到一个或多个正则表达式的匹配。

该方法类似 indexOf() 和 lastIndexOf()，但是它返回指定的值，而不是字符串的位置。

语法

stringObject.match(searchvalue)
stringObject.match(regexp)
参数 | 描述
searchvalue | 必需。规定要检索的字符串值。
regexp | 必需。规定要匹配的模式的 RegExp 对象。如果该参数不是 RegExp 对象，则需要首先把它传递给 RegExp 构造函数，将其转换为 RegExp 对象。

返回值

存放匹配结果的数组。该数组的内容依赖于 regexp 是否具有全局标志 g。

说明

match() 方法将检索字符串 stringObject，以找到一个或多个与 regexp 匹配的文本。这个方法的行为在很大程度上有赖于 regexp 是否具有标志 g。

如果 regexp 没有标志 g，那么 match() 方法就只能在 stringObject 中执行一次匹配。如果没有找到任何匹配的文本， match() 将返回 null。否则，它将返回一个数组，其中存放了与它找到的匹配文本有关的信息。该数组的第 0 个元素存放的是匹配文本，而其余的元素存放的是与正则表达式的子表达式匹配的文本。除了这些常规的数组元素之外，返回的数组还含有两个对象属性。index 属性声明的是匹配文本的起始字符在 stringObject 中的位置，input 属性声明的是对 stringObject 的引用。

如果 regexp 具有标志 g，则 match() 方法将执行全局检索，找到 stringObject 中的所有匹配子字符串。若没有找到任何匹配的子串，则返回 null。如果找到了一个或多个匹配子串，则返回一个数组。不过全局匹配返回的数组的内容与前者大不相同，它的数组元素中存放的是 stringObject 中所有的匹配子串，而且也没有 index 属性或 input 属性。

注意：在全局检索模式下，match() 即不提供与子表达式匹配的文本的信息，也不声明每个匹配子串的位置。如果您需要这些全局检索的信息，可以使用 RegExp.exec()。

实例

例子 1

在本例中，我们将在 "Hello world!" 中进行不同的检索：

<script type="text/javascript">

var str="Hello world!"
document.write(str.match("world") + "<br />")
document.write(str.match("World") + "<br />")
document.write(str.match("worlld") + "<br />")
document.write(str.match("world!"))

</script>

输出：

world
null
null
world!

例子 2

在本例中，我们将使用全局匹配的正则表达式来检索字符串中的所有数字：

<script type="text/javascript">

var str="1 plus 2 equal 3"
document.write(str.match(/\d+/g))

</script>

输出：

1,2,3

TIY

match() 1
如何使用 match() 来检索一个字符串。
match() 2
如何使用 match() 来检索一个正则表达式的匹配。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript Math 对象的参考手册

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript Math 对象的参考手册

Math 对象并不像 Date 和 String 那样是对象的类，因此没有构造函数 Math()，像 Math.sin() 这样的函数只是函数，不是某个对象的方法。

Math 对象的方法

FF: Firefox, N: Netscape, IE: Internet Explorer

方法 | 描述 | FF | N | IE
abs(x) | 返回数的绝对值 | 1 | 2 | 3
acos(x) | 返回数的反余弦值 | 1 | 2 | 3
asin(x) | 返回数的反正弦值 | 1 | 2 | 3
atan(x) | 以介于 -PI/2 与 PI/2 弧度之间的数值来返回 x 的反正切值 | 1 | 2 | 3
atan2(y,x) | 返回从 x 轴到点 (x,y) 的角度（介于 -PI/2 与 PI/2 弧度之间） | 1 | 2 | 3
ceil(x) | 对一个数进行上舍入。 | 1 | 2 | 3
cos(x) | 返回数的余弦 | 1 | 2 | 3
exp(x) | 返回 e 的指数。 | 1 | 2 | 3
floor(x) | 对一个数进行下舍入。 | 1 | 2 | 3
log(x) | 返回数的自然对数（底为e） | 1 | 2 | 3
max(x,y) | 返回 x 和 y 中的最高值 | 1 | 2 | 3
min(x,y) | 返回 x 和 y 中的最低值 | 1 | 2 | 3
pow(x,y) | 返回 x 的 y 次幂 | 1 | 2 | 3
random() | 返回 0 ~ 1 之间的随机数 | 1 | 2 | 3
round(x) | 把一个数四舍五入为最接近的整数 | 1 | 2 | 3
sin(x) | 返回数的正弦 | 1 | 2 | 3
sqrt(x) | 返回数的平方根 | 1 | 2 | 3
tan(x) | 返回一个角的正切 | 1 | 2 | 3
toSource() | 代表对象的源代码 | 1 | 4 | -
valueOf() | 返回一个 Math 对象的原始值 | 1 | 2 | 4

Math 对象的属性

FF: Firefox, N: Netscape, IE: Internet Explorer

属性 | 描述 | FF | N | IE
constructor | 对创建此对象的函数的引用 | 1 | 2 | 4
E | 常量 e，自然对数的底数 (约等于2.718) | 1 | 2 | 3
LN2 | 返回 2 的自然对数(约等于0.693) | 1 | 2 | 3
LN10 | 返回 10 的自然对数(约等于2.302) | 1 | 2 | 3
LOG2E | 返回以 2 为底的 e 的对数 (约等于 1.414) | 1 | 2 | 3
LOG10E | 返回以 10 为底的 e 的对数 (约等于0.434) | 1 | 2 | 3
PI | 返回圆周率 (约等于3.14159) | 1 | 2 | 3
prototype | 允许您向对象添加属性和方法 | 1 | 2 | 4
SQRT1_2 | 返回 2 的平方根除 1 (约等于 0.707) | 1 | 2 | 3
SQRT2 | 返回 2 的平方根 (约等于 1.414) | 1 | 2 | 3

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript Math（算数）对象

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript Math（算数）对象

  • Previous Page
  • Next Page

Math（算数）对象的作用是：执行常见的算数任务。

实例

round()
如何使用 round()。
random()
如何使用 random() 来返回 0 到 1 之间的随机数。
max()
如何使用 max() 来返回两个给定的数中的较大的数。
min()
如何使用 min() 来返回两个给定的数中的较小的数。

完整的 Math 对象参考手册

我们提供 JavaScript Math 对象的参考手册，其中包括所有可用于数组对象的属性和方法。

该手册包含了对每个属性和方法的详细描述以及相关实例。

Math 对象

Math（算数）对象的作用是：执行普通的算数任务。

Math 对象提供多种算数值类型和函数。无需在使用这个对象之前对它进行定义。

算数值

JavaScript 提供 8 种可被 Math 对象访问的算数值：

  • 常数
  • 圆周率
  • 2 的平方根
  • 1/2 的平方根
  • 2 的自然对数
  • 10 的自然对数
  • 以 2 为底的 e 的对数
  • 以 10 为底的 e 的对数

这是在 Javascript 中使用这些值的方法：（与上面的算数值一一对应）

  • Math.E
  • Math.PI
  • Math.SQRT2
  • Math.SQRT1_2
  • Math.LN2
  • Math.LN10
  • Math.LOG2E
  • Math.LOG10E

算数方法

除了可被 Math 对象访问的算数值以外，还有几个函数（方法）可以使用。

函数（方法）实例：

下面的例子使用了 Math 对象的 round 方法对一个数进行四舍五入。

document.write(Math.round(4.7))

上面的代码输出为：

5

下面的例子使用了 Math 对象的 random() 方法来返回一个介于 0 和 1 之间的随机数：

document.write(Math.random())

上面的代码输出为：

0.9370844220218102

下面的例子使用了 Math 对象的 floor() 方法和 random() 来返回一个介于 0 和 10 之间的随机数：

document.write(Math.floor(Math.random()*11))

上面的代码输出为：

3
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript max() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript max() 方法

返回 JavaScript Math 对象参考手册

定义和用法

max() 方法可返回两个指定的数中带有较大的值的那个数。

语法

Math.max(x...)
参数 | 描述
x | 0 或多个值。在 ECMASCript v3 之前，该方法只有两个参数。

返回值

参数中最大的值。如果没有参数，则返回 -Infinity。如果有某个参数为 NaN，或是不能转换成数字的非数字值，则返回 NaN。

实例

在本例中，我们将展示如何使用 max() 来返回指定数字中带有最高值的数字：

<script type="text/javascript">

document.write(Math.max(5,7) + "<br />")
document.write(Math.max(-3,5) + "<br />")
document.write(Math.max(-3,-5) + "<br />")
document.write(Math.max(7.25,7.30))

</script>

输出：

7
5
-3
7.3

TIY

max()
如何使用 max() 来返回指定数字中带有最高值的数字。

返回 JavaScript Math 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript min() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript min() 方法

返回 JavaScript Math 对象参考手册

定义和用法

min() 方法可返回指定的数字中带有最低值的数字。

语法

Math.min(x,y)
参数 | 描述
x | 0 或多个值。在 ECMASCript v3 之前，该方法只有两个参数。

返回值

参数中最小的值。如果没有参数，则返回 Infinity。如果有某个参数为 NaN，或是不能转换成数字的非数字值，则返回 NaN。

实例

在本例中，我们将展示如何使用 min() 来返回指定数字中带有最低值的数字：

<script type="text/javascript">

document.write(Math.min(5,7) + "<br />")
document.write(Math.min(-3,5) + "<br />")
document.write(Math.min(-3,-5) + "<br />")
document.write(Math.min(7.25,7.30))

</script>

输出：

5
-3
-5
7.25

TIY

min()
如何使用 min() 来取得指定数字中带有最低值的数字。

返回 JavaScript Math 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript multiline 属性

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript multiline 属性

返回 JavaScript RegExp 对象参考手册

定义和用法

multiline 属性用于返回正则表达式是否具有标志 m。

它声明了给定的正则表达式是否以多行模式执行模式匹配。

在这种模式中，如果要检索的字符串中含有换行符，^ 和 $ 锚除了匹配字符串的开头和结尾外还匹配每行的开头和结尾。

例如，模式 /W3School$/im 匹配 "w3school" 和 "W3School\nisgreat"。（\n 是换行符\u000A）。

如果 m 标志被设置，则该属性为 true，否则为 false。

语法

RegExpObject.multiline

实例

在下面的例子中，我们将查看正则表达式是否具有标志 m：

<script type="text/javascript">
var str = "Visit W3School.com.cn";
var patt1 = new RegExp("W3","m");

if(patt1.multiline)
  {
  alert("Multiline property is set");
  }
else
  {
  alert("Multiline property is NOT set.");
  }
</script>

TIY

multiline
如何使用 multiline 属性来检测正则表达式是否具有标志 m。

返回 JavaScript RegExp 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript NaN 属性

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript NaN 属性

返回 JavaScript 全局对象参考手册

定义和用法

NaN 属性用于引用特殊的非数字值。

语法

NaN

说明

无法使用 for/in 循环来枚举 NaN 属性，也不能用 delete 运算符来删除它。

NaN 不是常量，可以把它设置为其他值。

提示和注释

提示：请使用 isNaN() 来判断一个值是否是数字。原因是 NaN 与所有值都不相等，包括它自己。

实例

在本例中，我们将展示当一个数超出了 infinity 的限制发生的情况：

<script type="text/javascript">

var test1="300"
var test2="Hello World!"

document.write(Number(test1)+ "<br />")
document.write(Number(test2)+ "<br />")

document.write(isNaN(test1)+ "<br />")
document.write(isNaN(test2))

</script>

输出：

TIY

NaN
如何通过 NaN 来判断一个值。

返回 JavaScript 全局对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript Number 对象参考手册

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript Number 对象参考手册

在 JavaScript 中，数字是一种基本的数据类型。

JavaScript 支持 Number 对象，该对象是原始数值的包装对象。

在必要时，JavaScript 会自动地在原始数据和对象之间转换。

构造函数 Number() 可以不与运算符 new 一起使用，而直接作为转化函数来使用。以这种方式调用 Number() 时，它会把自己的参数转化成一个数字，然后返回转换后的原始数值（或 NaN）。

Number 对象的方法

FF: Firefox, IE: Internet Explorer

方法 | 描述 | FF | IE
toString | 把数字转换为字符串，使用指定的基数。 | 1.0 | 4.0
toLocaleString | 把数字转换为字符串，使用本地数字格式顺序。 | 1.0 | 4.0
toFixed | 把数字转换为字符串，结果的小数点后有指定位数的数字。 | 1.0 | 5.5
toExponential | 把数字转换为字符串，结果采用指数计数法，小数点后有指定位数的小数。 | 1.0 | 5.5
toPrecision | 把数字转换为字符串，结果中包含指定位数的有效数字。采用指数计数法或定点计数法，由数字的大小和指定的有效数字位数决定采用哪种方法。 | 1.0 | 5.5
valueOf | 返回一个 Number 对象的基本数字值。 | 1.0 | 4.0

Number 对象的属性

FF: Firefox, IE: Internet Explorer

属性 | 描述 | FF | IE
MAX_VALUE | 可表示的最大的数。 | 1.0 | 4.0
MIN_VALUE | 可表示的最小的数。 | 1.0 | 4.0
NaN | 非数字值。 | 1.0 | 4.0
NEGATIVE_INFINITY | 负无穷大，溢出时返回该值。 | 1.0 | 4.0
POSITIVE_INFINITY | 正无穷大，溢出时返回该值。 | 1.0 | 4.0

注释：上面的这 5 个常量是构造函数 Number() 自身的属性，而不是单独的某个 Number 对象的属性。

比如这样使用属性 MAX_VALUE 是正确的：

var big = Number.MAX_VALUE

但是这样是错误的：

var n= new Number(2);
var big = n.MAX_VALUE

课外书

如需更多信息，请阅读 JavaScript 高级教程中的相关内容：

ECMAScript 引用类型
引用类型通常叫做类（class）或对象。本节讲解 ECMAScript 的预定义引用类型。

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript onerror 事件

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript onerror 事件

  • Previous Page
  • Next Page

使用 onerror 事件是一种老式的标准的在网页中捕获 Javascript 错误的方法。

实例

onerror 事件
如何使用 onerror 事件捕获网页中的错误。

onerror 事件

我们刚讲过如何使用 try...catch 声明来捕获网页中的错误。现在，我们继续讲解如何使用 onerror 事件来达到相同的目的。

只要页面中出现脚步错误，就会产生 onerror 事件。

如果需要利用 onerror 事件，就必须创建一个处理错误的函数。你可以把这个函数叫作 onerror 事件处理器 (onerror event handler)。这个事件处理器使用三个参数来调用：msg（错误消息）、url（发生错误的页面的 url）、line（发生错误的代码行）。

语法：

onerror=handleErrfunction handleErr(msg,url,l)
{
//Handle the error here
return true or false
}

浏览器是否显示标准的错误消息，取决于 onerror 的返回值。如果返回值为 false，则在控制台 (JavaScript console) 中显示错误消息。反之则不会。

实例：

下面的例子展示如何使用 onerror 事件来捕获错误：

<html>
<head>
<script type="text/javascript">
onerror=handleErr
var txt=""

function handleErr(msg,url,l)
{
txt="There was an error on this page.\n\n"
txt+="Error: " + msg + "\n"
txt+="URL: " + url + "\n"
txt+="Line: " + l + "\n\n"
txt+="Click OK to continue.\n\n"
alert(txt)
return true
}

function message()
{
adddlert("Welcome guest!")
}
</script>
</head>

<body>
<input type="button" value="View message" onclick="message()" />
</body>

</html>
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript Packages 属性

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript Packages 属性

返回 JavaScript 全局对象参考手册

定义和用法

根 JavaPackage。

语法

Packages

说明

在包含了 LiveConnect 或其他用于脚本化 Java 的技术的 JavaScript 实现中，全局 Packages 属性就是一个 JavaPackage 对象，其属性是 Java 解释器所知道的所有包的根。例如，Packages.javax.swing 引用的是 Java 包 javax.swing。全局属性 java 是 Packages.java 的简写。

返回 JavaScript 全局对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript parse() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript parse() 方法

返回 JavaScript Date 对象参考手册

定义和用法

parse() 方法可解析一个日期时间字符串，并返回 1970/1/1 午夜距离该日期时间的毫秒数。

语法

Date.parse(datestring)
参数 | 描述
datestring | 必需。表示日期和时间的字符串。

返回值

指定的日期和时间据 1970/1/1 午夜（GMT 时间）之间的毫秒数。

说明

该方法是 Date 对象的静态方法。一般采用 Date.parse() 的形式来调用，而不是通过 dateobject.parse() 调用该方法。

提示和注释：

注释：Date.parse() 是 Date 对象的静态方法。

实例

例子 1

在本例中，我们将取得从 1970/01/01 到 2005/07/08 的毫秒数：

<script type="text/javascript">

var d = Date.parse("Jul 8, 2005")
document.write(d)

</script>

输出：

例子 2

现在，我们将把上面的例子所输出的结果转换成年：

<script type="text/javascript">

var minutes = 1000 * 60
var hours = minutes * 60
var days = hours * 24
var years = days * 365
var t = Date.parse("Jul 8, 2005")
var y = t/years
document.write("It's been: " + y + " years from 1970/01/01")
document.write(" to 2005/07/08!")

</script>

输出：

TIY

parse()
使用 parse() 来输出从 1970/01/01 到一个具体日期的毫秒数。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript parseFloat() 函数

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript parseFloat() 函数

返回 JavaScript 全局对象参考手册

定义和用法

parseFloat() 函数可解析一个字符串，并返回一个浮点数。

语法

parseFloat(string)
参数 | 描述
x | 必需。要被解析的字符串。

返回值

返回解析后的数字。

提示和注释

注释：只有字符串中的第一个数字会被返回。

注释：开头和结尾的空格是允许的。

提示：如果字符串的第一个字符不能被转换为数字，那么 parseFloat() 会返回 NaN。

提示：如果只想解析数字的整数部分，请使用 parseInt() 方法。

实例

在本例中，我们将使用 parseFloat() 来解析不同的字符串：

<script type="text/javascript">

document.write(parseFloat("10"))
document.write(parseFloat("10.00"))
document.write(parseFloat("10.33"))
document.write(parseFloat("34 45 66"))
document.write(parseFloat(" 60 "))
document.write(parseFloat("40 years"))
document.write(parseFloat("He was 40"))

</script>

输出：

10
10
10.33
34
60
40
NaN

TIY

parseFloat()
如何使用 parseFloat() 来解析不同的字符串。

返回 JavaScript 全局对象参考手册

课外书

如需更多有关类型转换的知识，请阅读 JavaScript 高级教程中的相关内容：

ECMAScript 类型转换
本节讲解了 ECMAScript 提供的类型转换方法，以及如何进行强制类型转换。

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript parseInt() 函数

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript parseInt() 函数

返回 JavaScript 全局对象参考手册

定义和用法

parseInt() 函数可解析一个字符串，并返回一个整数。

语法

parseInt(string, radix)
参数 | 描述
string | 必需。要被解析的字符串。
radix | 可选。表示要解析的数字的基数。该值介于 2 ~ 36 之间。 如果省略该参数或其值为 0，则数字将以 10 为基础来解析。如果它以 “0x” 或 “0X” 开头，将以 16 为基数。 如果该参数小于 2 或者大于 36，则 parseInt() 将返回 NaN。

返回值

返回解析后的数字。

说明

当参数 radix 的值为 0，或没有设置该参数时，parseInt() 会根据 string 来判断数字的基数。

举例，如果 string 以 "0x" 开头，parseInt() 会把 string 的其余部分解析为十六进制的整数。如果 string 以 0 开头，那么 ECMAScript v3 允许 parseInt() 的一个实现把其后的字符解析为八进制或十六进制的数字。如果 string 以 1 ~ 9 的数字开头，parseInt() 将把它解析为十进制的整数。

提示和注释

注释：只有字符串中的第一个数字会被返回。

注释：开头和结尾的空格是允许的。

提示：如果字符串的第一个字符不能被转换为数字，那么 parseFloat() 会返回 NaN。

实例

在本例中，我们将使用 parseInt() 来解析不同的字符串：

parseInt("10");		//返回 10
parseInt("19",10);		//返回 19 (10+9)
parseInt("11",2);		//返回 3 (10+9)
parseInt("17",8);		//返回 15 (8+7)
parseInt("1f",16);		//返回 31 (16+15)
parseInt("010");		//未定：返回 10 或 8

TIY

parseInt()
如何使用 parseInt() 来解析不同的字符串。

返回 JavaScript 全局对象参考手册

课外书

如需更多有关类型转换的知识，请阅读 JavaScript 高级教程中的相关内容：

ECMAScript 类型转换
本节讲解了 ECMAScript 提供的类型转换方法，以及如何进行强制类型转换。

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript pop() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript pop() 方法

返回 JavaScript Array 对象参考手册

定义和用法

pop() 方法用于删除并返回数组的最后一个元素。

语法

arrayObject.pop()

返回值

arrayObject 的最后一个元素。

说明

pop() 方法将删除 arrayObject 的最后一个元素，把数组长度减 1，并且返回它删除的元素的值。如果数组已经为空，则 pop() 不改变数组，并返回 undefined 值。

实例

在本例中，我们将创建一个数组，然后删除数组的最后一个元素。请注意，这也会改变数组的程度：

<script type="text/javascript">

var arr = new Array(3)
arr[0] = "George"
arr[1] = "John"
arr[2] = "Thomas"

document.write(arr)

document.write("<br />")

document.write(arr.pop())

document.write("<br />")

document.write(arr)

</script>

输出：

George,John,Thomas
Thomas
George,John

TIY

pop()
如何使用 pop() 来删除并返回数组的最后一个元素。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript pow() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript pow() 方法

返回 JavaScript Math 对象参考手册

定义和用法

pow() 方法可返回 x 的 y 次幂的值。

语法

Math.pow(x,y)
参数 | 描述
x | 必需。底数。必须是数字。
y | 必需。幂数。必须是数字。

返回值

x 的 y 次幂。

说明

如果结果是虚数或负数，则该方法将返回 NaN。如果由于指数过大而引起浮点溢出，则该方法将返回 Infinity。

实例

在下面的例子中，我们将把 pow() 运用到不同的数字组合上：

<script type="text/javascript">

document.write(Math.pow(0,0) + "<br />")
document.write(Math.pow(0,1) + "<br />")
document.write(Math.pow(1,1) + "<br />")
document.write(Math.pow(1,10) + "<br />")
document.write(Math.pow(2,3) + "<br />")
document.write(Math.pow(-2,3) + "<br />")
document.write(Math.pow(2,4) + "<br />")
document.write(Math.pow(-2,4) + "<br />")

</script>

输出：

1
0
1
1
8
-8
16
16

TIY

pow()
如何使用 pow() 方法。

返回 JavaScript Math 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript push() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript push() 方法

返回 JavaScript Array 对象参考手册

定义和用法

push() 方法可向数组的末尾添加一个或多个元素，并返回新的长度。

语法

arrayObject.push(newelement1,newelement2,....,newelementX)
参数 | 描述
newelement1 | 必需。要添加到数组的第一个元素。
newelement2 | 可选。要添加到数组的第二个元素。
newelementX | 可选。可添加多个元素。

返回值

把指定的值添加到数组后的新长度。

说明

push() 方法可把它的参数顺序添加到 arrayObject 的尾部。它直接修改 arrayObject，而不是创建一个新的数组。push() 方法和 pop() 方法使用数组提供的先进后出栈的功能。

提示和注释

注释：该方法会改变数组的长度。

提示：要想数组的开头添加一个或多个元素，请使用 unshift() 方法。

实例

在本例中，我们将创建一个数组，并通过添加一个元素来改变其长度：

<script type="text/javascript">

var arr = new Array(3)
arr[0] = "George"
arr[1] = "John"
arr[2] = "Thomas"

document.write(arr + "<br />")
document.write(arr.push("James") + "<br />")
document.write(arr)

</script>

输出：

George,John,Thomas
4
George,John,Thomas,James

TIY

push()
如何使用 push() 来改变数组的长度。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript random() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript random() 方法

返回 JavaScript Math 对象参考手册

定义和用法

random() 方法可返回介于 0 ~ 1 之间的一个随机数。

语法

Math.random()

返回值

0.0 ~ 1.0 之间的一个伪随机数。

实例

在本例中，我们将取得介于 0 到 1 之间的一个随机数：

<script type="text/javascript">

document.write(Math.random())

</script>

输出：

TIY

random()
如何使用 random() 来取得一个随机数。

返回 JavaScript Math 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript RegExp 对象

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript RegExp 对象

  • Previous Page
  • Next Page

RegExp 对象用于规定在文本中检索的内容。

什么是 RegExp？

RegExp 是正则表达式的缩写。

当您检索某个文本时，可以使用一种模式来描述要检索的内容。RegExp 就是这种模式。

简单的模式可以是一个单独的字符。

更复杂的模式包括了更多的字符，并可用于解析、格式检查、替换等等。

您可以规定字符串中的检索位置，以及要检索的字符类型，等等。

定义 RegExp

RegExp 对象用于存储检索模式。

通过 new 关键词来定义 RegExp 对象。以下代码定义了名为 patt1 的 RegExp 对象，其模式是 "e"：

var patt1=new RegExp("e");

当您使用该 RegExp 对象在一个字符串中检索时，将寻找的是字符 "e"。

RegExp 对象的方法

RegExp 对象有 3 个方法：test()、exec() 以及 compile()。

test()

test() 方法检索字符串中的指定值。返回值是 true 或 false。

例子：

var patt1=new RegExp("e");

document.write(patt1.test("The best things in life are free"));

由于该字符串中存在字母 "e"，以上代码的输出将是：

true

TIY

exec()

exec() 方法检索字符串中的指定值。返回值是被找到的值。如果没有发现匹配，则返回 null。

例子 1：

var patt1=new RegExp("e");

document.write(patt1.exec("The best things in life are free"));

由于该字符串中存在字母 "e"，以上代码的输出将是：

e

TIY

例子 2：

您可以向 RegExp 对象添加第二个参数，以设定检索。例如，如果需要找到所有某个字符的所有存在，则可以使用 "g" 参数 ("global")。

如需关于如何修改搜索模式的完整信息，请访问我们的 RegExp 对象参考手册。

在使用 "g" 参数时，exec() 的工作原理如下：

  • 找到第一个 "e"，并存储其位置
  • 如果再次运行 exec()，则从存储的位置开始检索，并找到下一个 "e"，并存储其位置
var patt1=new RegExp("e","g");
do
{
result=patt1.exec("The best things in life are free");
document.write(result);
}
while (result!=null)

由于这个字符串中 6 个 "e" 字母，代码的输出将是：

eeeeeenull

TIY

compile()

compile() 方法用于改变 RegExp。

compile() 既可以改变检索模式，也可以添加或删除第二个参数。

例子：

var patt1=new RegExp("e");

document.write(patt1.test("The best things in life are free"));

patt1.compile("d");

document.write(patt1.test("The best things in life are free"));

由于字符串中存在 "e"，而没有 "d"，以上代码的输出是：

truefalse

TIY

完整的 RegExp 对象参考手册

如需可与 RegExp 对象一同使用所有属性和方法的完整信息，请访问我们的 RegExp 对象参考手册。

这个参考手册包含了对 RegExp 对象中每个属性和方法的详细描述，以及使用的例子。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript RegExp 对象参考手册

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript RegExp 对象参考手册

RegExp 对象表示正则表达式，它是对字符串执行模式匹配的强大工具。

RegExp 对象的方法

FF: Firefox, N: Netscape, IE: Internet Explorer

方法 | 描述 | FF | N | IE
exec | 检索字符串中指定的值。返回找到的值，并确定其位置。 | 1 | 4 | 4
test | 检索字符串中指定的值。返回 true 或 false。 | 1 | 4 | 4

支持正则表达式的 String 对象的方法

FF: Firefox, N: Netscape, IE: Internet Explorer

方法 | 描述 | FF | N | IE
search | 检索与正则表达式相匹配的值。 | 1 | 4 | 4
match | 找到一个或多个正在表达式的匹配。 | 1 | 4 | 4
replace | 替换与正则表达式匹配的子串。 | 1 | 4 | 4
split | 把字符串分割为字符串数组。 | 1 | 4 | 4

RegExp 对象的属性

属性 | 描述 | FF | N | IE
global | RegExp 对象是否具有标志 g。 | 1 | 4 | 4
ignoreCase | RegExp 对象是否具有标志 i。 | 1 | 4 | 4
lastIndex | 一个整数，标示开始下一次匹配的字符位置。 | 1 | 4 | 4
multiline | RegExp 对象是否具有标志 m。 | 1 | 4 | 4
source | 正则表达式的源文本。 | 1 | 4 | 4

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript replace() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript replace() 方法

返回 JavaScript String 对象参考手册

定义和用法

replace() 方法用于在字符串中用一些字符替换另一些字符，或替换一个与正则表达式匹配的子串。

语法

stringObject.replace(regexp,replacement)
参数 | 描述
regexp | 必需。规定了要替换的模式的 RegExp 对象。请注意，如果该值是一个字符串，则将它作为要检索的直接量文本模式，而不是首先被转换为 RegExp 对象。
replacement | 必需。一个字符串值。规定了替换文本或生成替换文本的函数。

返回值

一个新的字符串，是用 replacement 替换了 regexp 的第一次匹配或所有匹配之后得到的。

说明

字符串 stringObject 的 replace() 方法执行的是查找并替换的操作。它将在 stringObject 中查找与 regexp 相匹配的子字符串，然后用 replacement 来替换这些子串。如果 regexp 具有全局标志 g，那么 replace() 方法将替换所有匹配的子串。否则，它只替换第一个匹配子串。

replacement 可以是字符串，也可以是函数。如果它是字符串，那么没有匹配都将由字符串替换。但是 replacement 中的 $ 字符具有特定的含义。如下表所示，它说明从模式匹配得到的字符串将用于替换。

字符 | 替换文本
$1、$2、...、$99 | 与 regexp 中的第 1 到第 99 个子表达式相匹配的文本。
$& | 与 regexp 相匹配的子串。
$` | 位于匹配子串左侧的文本。
$' | 位于匹配子串右侧的文本。
$$ | 直接量符号。

注意：ECMAScript v3 规定，replace() 方法的参数 replacement 可以是函数而不是字符串。在这种情况下，每个匹配都调用该函数，它返回的字符串将作为替换文本使用。该函数的第一个参数是匹配模式的字符串。接下来的参数是与模式中的子表达式匹配的字符串，可以有 0 个或多个这样的参数。接下来的参数是一个整数，声明了匹配在 stringObject 中出现的位置。最后一个参数是 stringObject 本身。

实例

例子 1

在本例中，我们将使用 "W3School" 替换字符串中的 "Microsoft"：

<script type="text/javascript">

var str="Visit Microsoft!"
document.write(str.replace(/Microsoft/, "W3School"))

</script>

输出：

Visit W3School!

例子 2

在本例中，我们将执行一次全局替换，每当 "Microsoft" 被找到，它就被替换为 "W3School"：

<script type="text/javascript">

var str="Welcome to Microsoft! "
str=str + "We are proud to announce that Microsoft has "
str=str + "one of the largest Web Developers sites in the world."

document.write(str.replace(/Microsoft/g, "W3School"))

</script>

输出：

Welcome to W3School! We are proud to announce that W3School
has one of the largest Web Developers sites in the world.

例子 3

您可以使用本例提供的代码来确保匹配字符串大写字符的正确：

text = "javascript Tutorial";
text.replace(/javascript/i, "JavaScript");

例子 4

在本例中，我们将把 "Doe, John" 转换为 "John Doe" 的形式：

name = "Doe, John";
name.replace(/(\w+)\s*, \s*(\w+)/, "$2 $1");

例子 5

在本例中，我们将把所有的花引号替换为直引号：

name = '"a", "b"';
name.replace(/"([^"]*)"/g, "'$1'");

例子 6

在本例中，我们将把字符串中所有单词的首字母都转换为大写：

name = 'aaa bbb ccc';
uw=name.replace(/\b\w+\b/g, function(word){
  return word.substring(0,1).toUpperCase()+word.substring(1);}
  );

TIY

replace() 1
如何使用 replace() 来替换字符串中的字符。
replace() 2 - 全局搜索
如何使用 replace() 进行全局替换。
replace() 3 - 对大小写不敏感的搜索
如何使用 replace() 确保大写字母的正确性。
replace() 4
如何使用 replace() 来转换姓名的格式。
replace() 5
如何使用 replace() 来转换引号。
replace() 6
如何使用 replace() 把单词的首字母转换为大写。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript reverse() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript reverse() 方法

返回 JavaScript Array 对象参考手册

定义和用法

reverse() 方法用于颠倒数组中元素的顺序。

语法

arrayObject.reverse()

提示和注释

注释：该方法会改变原来的数组，而不会创建新的数组。

实例

在本例中，我们将创建一个数组，然后颠倒其元素的顺序：

<script type="text/javascript">

var arr = new Array(3)
arr[0] = "George"
arr[1] = "John"
arr[2] = "Thomas"

document.write(arr + "<br />")
document.write(arr.reverse())

</script>

输出：

George,John,Thomas
Thomas,John,George

TIY

reverse()
如何使用 reverse() 颠倒数组中元素的顺序。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript round() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript round() 方法

返回 JavaScript Math 对象参考手册

定义和用法

round() 方法可把一个数字舍入为最接近的整数。

语法

Math.round(x)
参数 | 描述
x | 必需。必须是数字。

返回值

与 x 最接近的整数。

说明

对于 0.5，该方法将进行上舍入。

例如，3.5 将舍入为 4，而 -3.5 将舍入为 -2。

实例

在下面的例子中，我们将把 pow() 运用到不同的数字组合上：

<script type="text/javascript">

document.write(Math.round(0.60) + "<br />")
document.write(Math.round(0.50) + "<br />")
document.write(Math.round(0.49) + "<br />")
document.write(Math.round(-4.40) + "<br />")
document.write(Math.round(-4.60))

</script>

输出：

1
1
0
-4
-5

TIY

round()
如何使用 round() 方法。

返回 JavaScript Math 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript search() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript search() 方法

返回 JavaScript String 对象参考手册

定义和用法

search() 方法用于检索字符串中指定的子字符串，或检索与正则表达式相匹配的子字符串。

语法

stringObject.search(regexp)
参数 | 描述
regexp | 该参数可以是需要在 stringObject 中检索的子串，也可以是需要检索的 RegExp 对象。 注释：要执行忽略大小写的检索，请追加标志 i。

返回值

stringObject 中第一个与 regexp 相匹配的子串的起始位置。

注释：如果没有找到任何匹配的子串，则返回 -1。

说明

search() 方法不执行全局匹配，它将忽略标志 g。它同时忽略 regexp 的 lastIndex 属性，并且总是从字符串的开始进行检索，这意味着它总是返回 stringObject 的第一个匹配的位置。

实例

例子 1

在本例中，我们将检索 "W3School"：

<script type="text/javascript">

var str="Visit W3School!"
document.write(str.search(/W3School/))

</script>

输出：

6

在下面的例子中，无法检索到 w3school（因为 search() 对大小写敏感）。

<script type="text/javascript">

var str="Visit W3School!"
document.write(str.search(/w3school/))

</script>

输出：

-1

例子 2

在本例中，我们将执行一次忽略大小写的检索：

<script type="text/javascript">

var str="Visit W3School!"
document.write(str.search(/w3school/i))

</script>

输出：

6

TIY

search()
如何使用 search() 来检索字符串中指定的子串。
search() 忽略大小写的检索
如何使用 search() 来检索字符串中指定的子串。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript setDate() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript setDate() 方法

返回 JavaScript Date 对象参考手册

定义和用法

setDate() 方法用于设置一个月的某一天。

语法

dateObject.setDate(day)
参数 | 描述
day | 必需。表示一个月中的一天的一个数值（1 ~ 31）。

返回值

调整过的日期的毫秒表示。在 ECMAScript 标准化之前，该方法什么都不返回。

提示和注释：

注释：该方法总是结合一个 Date 对象来使用。

实例

在本例中，我们将通过 setDate() 方法把当前月的天设置为 15：

<script type="text/javascript">

var d = new Date()
d.setDate(15)
document.write(d)

</script>

输出：

TIY

setDate()
如何使用 setDate() 来设置当前月的某一天。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript setFullYear() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript setFullYear() 方法

返回 JavaScript Date 对象参考手册

定义和用法

setFullYear() 方法用于设置年份。

语法

dateObject.setFullYear(year,month,day)
参数 | 描述
year | 必需。表示年份的四位整数。用本地时间表示。
month | 可选。表示月份的数值，介于 0 ~ 11 之间。用本地时间表示。
day | 可选。表示月中某一天的数值，介于 1 ~ 31 之间。用本地时间表示。

返回值

返回调整过的日期的毫秒表示。

提示和注释：

注释：该方法总是结合一个 Date 对象来使用。

实例

例子 1

在本例中，我们将通过 setFullYear() 把年份设置为1992：

<script type="text/javascript">

var d = new Date()
d.setFullYear(1992)
document.write(d)

</script>

输出：

例子 2

在本例中，我们将通过 setFullYear() 把日期设置为 November 3, 1992：

<script type="text/javascript">

var d = new Date()
d.setFullYear(1992,10,3)
document.write(d)

</script>

输出：

TIY

setFullYear()
如何使用 setFullYear() 来设置年份。
使用 setFullYear() 来设置具体的日期
如何使用 setFullYear() 来设置具体的日期。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript setHours() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript setHours() 方法

返回 JavaScript Date 对象参考手册

定义和用法

setHours() 方法用于设置指定的时间的小时字段。

语法

dateObject.setHours(hour,min,sec,millisec)
参数 | 描述
hour | 必需。表示小时的数值，介于 0（午夜） ~ 23（晚上11点） 之间，以本地时间计（下同）。
min | 可选。表示分钟的数值，介于 0 ~ 59 之间。在 EMCAScript 标准化之前，不支持该参数。
sec | 可选。表示秒的数值，介于 0 ~ 59 之间。在 EMCAScript 标准化之前，不支持该参数。
millisec | 可选。表示毫秒的数值，介于 0 ~ 999之间。在 EMCAScript 标准化之前，不支持该参数。

返回值

调整过的日期的毫秒表示。在 ECMAScript 标准化之前，该方法什么都不返回。

提示和注释：

注释：如果上面的参数之一使用一位的数字来规定，那么 JavaScript 会在结果中加一或两个前置 0。

注释：该方法总是结合一个 Date 对象来使用。

实例

例子 1

在本例中，我们将通过 setHours() 方法把当前时间的小时字段设置为 15：

<script type="text/javascript">

var d = new Date()
d.setHours(15)
document.write(d)

</script>

输出：

例子 2

在本例中，我们将通过 setHours() 方法把时间设置为 15:35:01：

<script type="text/javascript">

var d = new Date()
d.setHours(15,35,1)
document.write(d)

</script>

输出：

TIY

setHours()
如何使用 setHours() 来设置时间。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript setMilliseconds() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript setMilliseconds() 方法

返回 JavaScript Date 对象参考手册

定义和用法

setMilliseconds() 方法用于设置指定时间的毫秒字段。

语法

dateObject.setMilliseconds(millisec)
参数 | 描述
millisec | 必需。用于设置 dateObject 毫秒字段，该参数是介于 0 ~ 999 之间的整数。

返回值

调整过的日期的毫秒表示。

提示和注释：

注释：如果上面的参数之一使用一位的数字来规定，那么 JavaScript 会在结果中加一或两个前置 0。

注释：该方法总是结合一个 Date 对象来使用。

实例

在本例中，我们将通过 setMilliseconds() 方法把当前时间的毫秒字段设置为 001：

<script type="text/javascript">

var d = new Date()
d.setMilliseconds(1)
document.write(d)

</script>

输出：

TIY

setMilliseconds()
如何使用 setMilliseconds() 来更改当前的毫秒。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript setMinutes() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript setMinutes() 方法

返回 JavaScript Date 对象参考手册

定义和用法

setMinutes() 方法用于设置指定时间的分钟字段。

语法

dateObject.setMinutes(min,sec,millisec)
参数 | 描述
min | 必需。表示分钟的数值，介于 0 ~ 59 之间，以本地时间计（下同）。
sec | 可选。表示秒的数值，介于 0 ~ 59 之间。在 EMCAScript 标准化之前，不支持该参数。
millisec | 可选。表示毫秒的数值，介于 0 ~ 999 之间。在 EMCAScript 标准化之前，不支持该参数。

返回值

调整过的日期的毫秒表示。在 ECMAScript 标准化之前，该方法什么都不返回。

提示和注释：

注释：如果上面的参数之一使用一位的数字来规定，那么 JavaScript 会在结果中加一或两个前置 0。

注释：该方法总是结合一个 Date 对象来使用。

实例

在本例中，我们将通过 setMinutes() 方法把当前时间的分钟字段设置为 01：

<script type="text/javascript">

var d = new Date()
d.setMinutes(1)
document.write(d)

</script>

输出：

TIY

setMinutes()
如何使用 setMinutes() 来设置当前时间的分钟。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript setMonth() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript setMonth() 方法

返回 JavaScript Date 对象参考手册

定义和用法

setMonth() 方法用于设置月份。

语法

dateObject.setMonth(month,day)
参数 | 描述
month | 必需。一个表示月份的数值，该值介于 0（一月） ~ 11（十二月） 之间。
day | 可选。一个表示月的某一天的数值，该值介于 1 ~ 31 之间（以本地时间计）。 在 EMCAScript 标准化之前，不支持该参数。

返回值

调整过的日期的毫秒表示。在 ECMAScript 标准化之前，该方法什么都不返回。

提示和注释：

注释：该方法总是结合一个 Date 对象来使用。

实例

例子 1

在本例中，我们将通过 setMonth() 方法把对象 d 的月字段设置为 0 （一月）：

<script type="text/javascript">

var d=new Date()
d.setMonth(0)
document.write(d)

</script>

输出：

例子 2

在本例中，我们将通过 setMonth() 方法把对象 d 的月字段设置为 0 （一月），把天字段设置为 20：

<script type="text/javascript">

var d=new Date()
d.setMonth(0,20)
document.write(d)

</script>

输出：

TIY

setMonth()
如何使用 setMonth() 来设置月份。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript setSeconds() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript setSeconds() 方法

返回 JavaScript Date 对象参考手册

定义和用法

The setSeconds() method is used to set the seconds of a specified time.

语法

dateObject.setSeconds(sec,millisec)
参数 | 描述
sec | 必需。表示秒的数值，该值是介于 0 ~ 59 之间的整数。
millisec | 可选。表示毫秒的数值，介于 0 ~ 999 之间。在 EMCAScript 标准化之前，不支持该参数。

返回值

调整过的日期的毫秒表示。在 ECMAScript 标准化之前，该方法什么都不返回。

提示和注释：

注释：如果上面的参数之一使用一位的数字来规定，那么 JavaScript 会在结果中加一或两个前置 0。

注释：该方法总是结合一个 Date 对象来使用。

实例

在本例中，我们将通过 setSeconds() 方法把当前时间的秒字段设置为 01：

<script type="text/javascript">

var d = new Date()
d.setSeconds(1)
document.write(d)

</script>

输出：

TIY

setSeconds()
如何使用 setSeconds() 来设置当前时间的秒。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript setTime() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript setTime() 方法

返回 JavaScript Date 对象参考手册

定义和用法

setTime() 方法以毫秒设置 Date 对象。

语法

dateObject.setTime(millisec)
参数 | 描述
millisec | 必需。要设置的日期和时间据 GMT 时间 1997 年 1 月 1 日午夜之间的毫秒数。这种类型的毫秒值可以传递给 Date() 构造函数，可以通过调用 Date.UTC() 和 Date.parse() 方法获得该值。以毫秒形式表示日期可以使它独立于时区。

返回值

返回参数 millisec。在 ECMAScript 标准化之前，该方法不返回值。

提示和注释：

注释：该方法总是结合一个 Date 对象来使用。

实例

例子 1

在本例中，我们将向 1970/01/01 添加 77771564221 毫秒，并显示新的日期和时间：

<script type="text/javascript">

var d = new Date()
d.setTime(77771564221)
document.write(d)

</script>

输出：

例子 2

在本例中，我们将从 1970/01/01 减去 77771564221 毫秒，并显示新的日期和时间：

<script type="text/javascript">

var d = new Date()
d.setTime(-77771564221)
document.write(d)

</script>

输出：

TIY

setTime()
使用 setTime() 向 1970/01/01 添加毫秒，并显示新的日期和时间。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript setUTCDate() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript setUTCDate() 方法

返回 JavaScript Date 对象参考手册

定义和用法

setUTCDate() 方法用于根据世界时 (UTC) 设置一个月中的某一天。

语法

dateObject.setUTCDate(day)
参数 | 描述
day | 必需。要给 dateObject 设置的一个月中的某一天，用世界时表示。该参数是 1 ~ 31 之间的整数。

返回值

调整过的日期的毫秒表示。

提示和注释：

注释：该方法总是结合一个 Date 对象来使用。

提示：有关通用协调时间 (UTC) 的更多资料，请参阅百度百科。

实例

在本例中，我们将通过 setUTCDate() 方法把当前月的天字段设置为 15：

<script type="text/javascript">

var d = new Date()
d.setUTCDate(15)
document.write(d)

</script>

输出：

TIY

setUTCDate()
如何使用 setUTCDate() 来设置此月的天。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript setUTCFullYear() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript setUTCFullYear() 方法

返回 JavaScript Date 对象参考手册

定义和用法

setUTCFullYear() 方法用于根据世界时 (UTC) 设置年份。

语法

dateObject.setUTCFullYear(year,month,day)
参数 | 描述
year | 必需。要给 dateObject 设置的年份字段的值。 该参数应该是含有世纪值的完整年份，如 1999，而不只是缩写的年份值，比如 99。
month | 可选。要给 dateObject 设置的月份字段的值。使用世界时表示。 该参数是 0 ~ 11 之间的整数。
day | 可选。要给 dateObject 设置的天字段的值。使用世界时表示。 该参数是 1 ~ 31 之间的整数。

返回值

调整过的日期的毫秒表示。

提示和注释：

注释：该方法总是结合一个 Date 对象来使用。

提示：有关通用协调时间 (UTC) 的更多资料，请参阅百度百科。

实例

例子 1

在本例中，我们将通过 setUTCFullYear() 方法把年份设置为 1992：

<script type="text/javascript">

var d = new Date()
d.setUTCFullYear(1992)
document.write(d)

</script>

输出：

例子 2

在本例中，我将通过 setUTCFullYear() 方法把日期设置为 November 3, 1992：

<script type="text/javascript">

var d = new Date()
d.setUTCFullYear(1992,10,3)
document.write(d)

</script>

输出：

TIY

setUTCFullYear()
如何使用 setUTCFullYear() 来设置年份。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript setUTCHours() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript setUTCHours() 方法

返回 JavaScript Date 对象参考手册

定义和用法

setUTCFullYear() 方法用于根据世界时 (UTC) 设置年份。

语法

dateObject.setUTCFullYear(year,month,day)
参数 | 描述
year | 必需。要给 dateObject 设置的年份字段的值。 该参数应该是含有世纪值的完整年份，如 1999，而不只是缩写的年份值，比如 99。
month | 可选。要给 dateObject 设置的月份字段的值。使用世界时表示。 该参数是 0 ~ 11 之间的整数。
day | 可选。要给 dateObject 设置的天字段的值。使用世界时表示。 该参数是 1 ~ 31 之间的整数。

返回值

调整过的日期的毫秒表示。

提示和注释：

注释：该方法总是结合一个 Date 对象来使用。

提示：有关通用协调时间 (UTC) 的更多资料，请参阅百度百科。

实例

例子 1

在本例中，我们将通过 setUTCFullYear() 方法把年份设置为 1992：

<script type="text/javascript">

var d = new Date()
d.setUTCFullYear(1992)
document.write(d)

</script>

输出：

例子 2

在本例中，我将通过 setUTCFullYear() 方法把日期设置为 November 3, 1992：

<script type="text/javascript">

var d = new Date()
d.setUTCFullYear(1992,10,3)
document.write(d)

</script>

输出：

TIY

setUTCFullYear()
如何使用 setUTCFullYear() 来设置年份。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript setUTCMilliseconds() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript setUTCMilliseconds() 方法

返回 JavaScript Date 对象参考手册

定义和用法

setUTCMilliseconds() 方法用于根据世界时 (UTC) 设置指定时间的毫秒。

语法

dateObject.setUTCMilliseconds(millisec)
参数 | 描述
millisec | 必需。要给 dateObject 设置的毫秒字段的值。使用世界时表示。 该参数是 0 ~ 999 之间的整数。

返回值

调整过的日期的毫秒表示。

提示和注释：

注释：如果上面的参数之一使用一位的数字来规定，那么 JavaScript 会在结果中加一或两个前置 0。

注释：该方法总是结合一个 Date 对象来使用。

提示：有关通用协调时间 (UTC) 的更多资料，请参阅百度百科。

实例

在本例中，我们将通过 setUTCMilliseconds() 方法把当前时间的毫秒字段设置为 001：

<script type="text/javascript">

var d = new Date()
d.setUTCMilliseconds(1)
document.write(d)

</script>

输出：

TIY

setUTCMilliseconds()
如何使用 setUTCMilliseconds() 来设置当前时间的毫秒。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript setUTCMinutes() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript setUTCMinutes() 方法

返回 JavaScript Date 对象参考手册

定义和用法

setUTCMinutes() 方法用于根据世界时 (UTC) 来设置指定时间的分钟。

语法

dateObject.setUTCMinutes(min,sec,millisec)
参数 | 描述
min | 必需。要给 dateObject 设置的分钟字段的值，用世界时表示。 该参数应该是 0 ~ 59 之间的整数。
sec | 可选。要给 dateObject 设置的秒字段的值。使用世界时表示。 该参数是 0 ~ 59 之间的整数。
millisec | 可选。要给 dateObject 设置的毫秒字段的值。使用世界时表示。 该参数是 0 ~ 999 之间的整数。

返回值

调整过的日期的毫秒表示。

提示和注释：

注释：如果上面的参数之一使用一位的数字来规定，那么 JavaScript 会在结果中加一或两个前置 0。

注释：该方法总是结合一个 Date 对象来使用。

提示：有关通用协调时间 (UTC) 的更多资料，请参阅百度百科。

实例

在本例中，我们将通过 setUTCMinutes() 方法把当前时间的分钟字段设置为 01：

<script type="text/javascript">

var d = new Date()
d.setUTCMinutes(1)
document.write(d)

</script>

输出：

TIY

setUTCMinutes()
如何使用 setUTCMinutes() 来设置当前时间的分钟。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript setUTCMonth() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript setUTCMonth() 方法

返回 JavaScript Date 对象参考手册

定义和用法

setUTCMonth() 方法用于根据世界时 (UTC) 来设置月份。

语法

dateObject.setUTCMonth(month,day)
参数 | 描述
month | 必需。要给 dateObject 设置的月份字段的值，用世界时表示。 该参数是 0（一月） ~ 11（十二月） 之间的整数。
day | 可选。在 1 ~ 31 之间的整数，用作 dateObject 的天字段，用世界时表示。

返回值

调整过的日期的毫秒表示。

提示和注释：

注释：该方法总是结合一个 Date 对象来使用。

提示：有关通用协调时间 (UTC) 的更多资料，请参阅百度百科。

实例

例子 1

在本例中，我们将通过 setUTCMonth() 方法把月字段设置为 0 （一月）：

<script type="text/javascript">

var d=new Date()
d.setUTCMonth(0)
document.write(d)

</script>

输出：

例子 2

在本例中，我们将通过 setUTCMonth() 把月份设置为 0 （一月），把天字段设置为 20：

<script type="text/javascript">

var d=new Date()
d.setUTCMonth(0,20)
document.write(d)

</script>

输出：

TIY

setUTCMonth()
如何使用 setUTCMonth() 来设置月份。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript setUTCSeconds() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript setUTCSeconds() 方法

返回 JavaScript Date 对象参考手册

定义和用法

setUTCSeconds() 方法用于根据世界时 (UTC) 设置指定时间的秒。

语法

dateObject.setUTCSeconds(sec,millisec)
参数 | 描述
sec | 必需。要给 dateObject 设置的秒字段的值。使用世界时表示。 该参数是 0 ~ 59 之间的整数。
millisec | 可选。要给 dateObject 设置的毫秒字段的值。使用世界时表示。 该参数是 0 ~ 999 之间的整数。

返回值

调整过的日期的毫秒表示。

提示和注释：

注释：如果上面的参数之一使用一位的数字来规定，那么 JavaScript 会在结果中加一或两个前置 0。

注释：该方法总是结合一个 Date 对象来使用。

提示：有关通用协调时间 (UTC) 的更多资料，请参阅百度百科。

实例

在本例中，我们将通过 setUTCSeconds() 把当前时间的秒字段设置为 01：

<script type="text/javascript">

var d = new Date()
d.setUTCSeconds(1)
document.write(d)

</script>

输出：

TIY

setUTCSeconds()
如何使用 setUTCSeconds() 来设置当前时间的秒。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript setYear() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript setYear() 方法

返回 JavaScript Date 对象参考手册

定义和用法

setYear() 方法用于设置年份。

语法

dateObject.setYear(year)
参数 | 描述
year | 必需。表示年份的两位或四位数字。

返回值

调整过的日期的毫秒表示。在 ECMAScript 标准化之前，该方法什么都不返回。

提示和注释：

注释：如果 year 参数是两位的数字，比如 setYear(91)，则该方法会理解为 1991。如果要规定 1990 年之前或 1999 年之后的年份，请使用四位数字。

注释：该方法总是结合一个 Date 对象来使用。

重要事项：从 ECMAScript v3 起，JavaScript 实现不再要求使用该函数，而使用 setFullYear() 函数代替它。

实例

在本例中，我们将通过 setYear() 方法把年份设置为 1891：

<script type="text/javascript">

var d = new Date()
d.setYear(1891)
document.write(d)

</script>

输出：

TIY

setYear()
如何使用 setYear() 来设置年份。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript shift() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript shift() 方法

返回 JavaScript Array 对象参考手册

定义和用法

shift() 方法用于把数组的第一个元素从其中删除，并返回第一个元素的值。

语法

arrayObject.shift()

返回值

数组原来的第一个元素的值。

说明

如果数组是空的，那么 shift() 方法将不进行任何操作，返回 undefined 值。请注意，该方法不创建新数组，而是直接修改原有的 arrayObject。

提示和注释

注释：该方法会改变数组的长度。

提示：要删除并返回数组的最后一个元素，请使用 pop() 方法。

实例

在本例中，我们将创建一个数组，并删除数组的第一个元素。请注意，这也将改变数组的长度：

<script type="text/javascript">

var arr = new Array(3)
arr[0] = "George"
arr[1] = "John"
arr[2] = "Thomas"

document.write(arr + "<br />")
document.write(arr.shift() + "<br />")
document.write(arr)

</script>

输出：

George,John,Thomas
George
John,Thomas

TIY

shift()
如何使用 shift() 删除并返回数组的第一个元素。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript sin() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript sin() 方法

返回 JavaScript Math 对象参考手册

定义和用法

sin() 方法可返回一个数字的正弦。

语法

Math.sin(x)
参数 | 描述
x | 必需。一个以弧度表示的角。将角度乘以 0.017453293 （2PI/360）即可转换为弧度。

返回值

参数 x 的正弦值。返回值在 -1.0 到 1.0 之间。

实例

在本例中，我们将返回不同数字的正弦：

<script type="text/javascript">

document.write(Math.sin(3) + "<br />")
document.write(Math.sin(-3) + "<br />")
document.write(Math.sin(0) + "<br />")
document.write(Math.sin(Math.PI) + "<br />")
document.write(Math.sin(Math.PI/2)

</script>

输出：

0.1411200080598672
-0.1411200080598672
0
1.2246063538223772e-16
1

TIY

sin()
如何使用 sin() 来取得一些数字的正弦。

返回 JavaScript Math 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript slice() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript slice() 方法

返回 JavaScript Array 对象参考手册

定义和用法

slice() 方法可从已有的数组中返回选定的元素。

语法

arrayObject.slice(start,end)
参数 | 描述
start | 必需。规定从何处开始选取。如果是负数，那么它规定从数组尾部开始算起的位置。也就是说，-1 指最后一个元素，-2 指倒数第二个元素，以此类推。
end | 可选。规定从何处结束选取。该参数是数组片断结束处的数组下标。如果没有指定该参数，那么切分的数组包含从 start 到数组结束的所有元素。如果这个参数是负数，那么它规定的是从数组尾部开始算起的元素。

返回值

返回一个新的数组，包含从 start 到 end （不包括该元素）的 arrayObject 中的元素。

说明

请注意，该方法并不会修改数组，而是返回一个子数组。如果想删除数组中的一段元素，应该使用方法 Array.splice()。

提示和注释

注释：您可使用负值从数组的尾部选取元素。

注释：如果 end 未被规定，那么 slice() 方法会选取从 start 到数组结尾的所有元素。

实例

例子 1

在本例中，我们将创建一个新数组，然后显示从其中选取的元素：

<script type="text/javascript">

var arr = new Array(3)
arr[0] = "George"
arr[1] = "John"
arr[2] = "Thomas"

document.write(arr + "<br />")
document.write(arr.slice(1) + "<br />")
document.write(arr)

</script>

输出：

George,John,Thomas
John,Thomas
George,John,Thomas

例子 2

在本例中，我们将创建一个新数组，然后显示从其中选取的元素：

<script type="text/javascript">

var arr = new Array(6)
arr[0] = "George"
arr[1] = "John"
arr[2] = "Thomas"
arr[3] = "James"
arr[4] = "Adrew"
arr[5] = "Martin"

document.write(arr + "<br />")
document.write(arr.slice(2,4) + "<br />")
document.write(arr)

</script>

输出：

George,John,Thomas,James,Adrew,Martin
Thomas,James
George,John,Thomas,James,Adrew,Martin

TIY

slice()
如何使用 slice() 从已有的数组显示选取的元素。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript slice() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript slice() 方法

返回 JavaScript String 对象参考手册

定义和用法

slice() 方法可提取字符串的某个部分，并以新的字符串返回被提取的部分。

语法

stringObject.slice(start,end)
参数 | 描述
start | 要抽取的片断的起始下标。如果是负数，则该参数规定的是从字符串的尾部开始算起的位置。也就是说，-1 指字符串的最后一个字符，-2 指倒数第二个字符，以此类推。
end | 紧接着要抽取的片段的结尾的下标。若未指定此参数，则要提取的子串包括 start 到原字符串结尾的字符串。如果该参数是负数，那么它规定的是从字符串的尾部开始算起的位置。

返回值

一个新的字符串。包括字符串 stringObject 从 start 开始（包括 start）到 end 结束（不包括 end）为止的所有字符。

说明

String 对象的方法 slice()、substring() 和 substr() （不建议使用）都可返回字符串的指定部分。slice() 比 substring() 要灵活一些，因为它允许使用负数作为参数。slice() 与 substr() 有所不同，因为它用两个字符的位置来指定子串，而 substr() 则用字符位置和长度来指定子串。

还要注意的是，String.slice() 与 Array.slice() 相似。

实例

例子 1

在本例中，我们将提取从位置 6 开始的所有字符：

<script type="text/javascript">

var str="Hello happy world!"
document.write(str.slice(6))

</script>

输出：

happy world!

例子 2

在本例中，我们将提取从位置 6 到位置 11 的所有字符：

<script type="text/javascript">

var str="Hello happy world!"
document.write(str.slice(6,11))

</script>

输出：

happy

TIY

slice()
如何使用 slice() 从字符串提取字符。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript small() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript small() 方法

返回 JavaScript String 对象参考手册

定义和用法

small() 方法用于把字符串显示为小号字。

语法

stringObject.small()

实例

在本例中,"Hello world!" 将显示为小号字：

<script type="text/javascript">

var str="Hello world!"
document.write(str.small())

</script>

TIY

small()
如何使用 small() 把字符串显示为小号字。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript sort() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript sort() 方法

返回 JavaScript Array 对象参考手册

定义和用法

sort() 方法用于对数组的元素进行排序。

语法

arrayObject.sort(sortby)
参数 | 描述
sortby | 可选。规定排序顺序。必须是函数。

返回值

对数组的引用。请注意，数组在原数组上进行排序，不生成副本。

说明

如果调用该方法时没有使用参数，将按字母顺序对数组中的元素进行排序，说得更精确点，是按照字符编码的顺序进行排序。要实现这一点，首先应把数组的元素都转换成字符串（如有必要），以便进行比较。

如果想按照其他标准进行排序，就需要提供比较函数，该函数要比较两个值，然后返回一个用于说明这两个值的相对顺序的数字。比较函数应该具有两个参数 a 和 b，其返回值如下：

  • 若 a 小于 b，在排序后的数组中 a 应该出现在 b 之前，则返回一个小于 0 的值。
  • 若 a 等于 b，则返回 0。
  • 若 a 大于 b，则返回一个大于 0 的值。

提示和注释

注释：您可使用负值从数组的尾部选取元素。

注释：如果 end 未被规定，那么 slice() 方法会选取从 start 到数组结尾的所有元素。

实例

例子 1

在本例中，我们将创建一个数组，并按字母顺序进行排序：

<script type="text/javascript">

var arr = new Array(6)
arr[0] = "George"
arr[1] = "John"
arr[2] = "Thomas"
arr[3] = "James"
arr[4] = "Adrew"
arr[5] = "Martin"

document.write(arr + "<br />")
document.write(arr.sort())

</script>

输出：

George,John,Thomas,James,Adrew,Martin
Adrew,George,James,John,Martin,Thomas

例子 2

在本例中，我们将创建一个数组，并按字母顺序进行排序：

<script type="text/javascript">

var arr = new Array(6)
arr[0] = "10"
arr[1] = "5"
arr[2] = "40"
arr[3] = "25"
arr[4] = "1000"
arr[5] = "1"

document.write(arr + "<br />")
document.write(arr.sort())

</script>

输出：

10,5,40,25,1000,1
1,10,1000,25,40,5

请注意，上面的代码没有按照数值的大小对数字进行排序，要实现这一点，就必须使用一个排序函数：

<script type="text/javascript">

function sortNumber(a,b)
{
return a - b
}

var arr = new Array(6)
arr[0] = "10"
arr[1] = "5"
arr[2] = "40"
arr[3] = "25"
arr[4] = "1000"
arr[5] = "1"

document.write(arr + "<br />")
document.write(arr.sort(sortNumber))

</script>

输出：

10,5,40,25,1000,1
1,5,10,25,40,1000

TIY

sort() 按字母顺序
如何使用 sort() 按照字母顺序对数组进行排序。
sort() 按数值顺序
如何使用 sort() 按照数值顺序对数组进行排序。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript source 属性

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript source 属性

返回 JavaScript RegExp 对象参考手册

定义和用法

lastIndex 属性用于返回模式匹配所用的文本。

该文本不包括正则表达式直接量使用的定界符，也不包括标志 g、i、m。

语法

RegExpObject.source

实例

在下面的例子中，我们将获得用于模式匹配的文本：

<script type="text/javascript">
var str = "Visit W3School.com.cn";
var patt1 = new RegExp("W3S","g");

document.write("The regular expression is: " + patt1.source);
</script>

TIY

source
如何使用 source 属性来获得用于模式匹配的文本。

返回 JavaScript RegExp 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript splice() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript splice() 方法

返回 JavaScript Array 对象参考手册

定义和用法

splice() 方法用于插入、删除或替换数组的元素。

语法

arrayObject.splice(index,howmany,element1,.....,elementX)
参数 | 描述
index | 必需。规定从何处添加/删除元素。 该参数是开始插入和（或）删除的数组元素的下标，必须是数字。
howmany | 必需。规定应该删除多少元素。必须是数字，但可以是 "0"。 如果未规定此参数，则删除从 index 开始到原数组结尾的所有元素。
element1 | 可选。规定要添加到数组的新元素。从 index 所指的下标处开始插入。
elementX | 可选。可向数组添加若干元素。

返回值

如果从 arrayObject 中删除了元素，则返回的是含有被删除的元素的数组。

说明

splice() 方法可删除从 index 处开始的零个或多个元素，并且用参数列表中声明的一个或多个值来替换那些被删除的元素。

提示和注释

注释：请注意，splice() 方法与 slice() 方法的作用是不同的，splice() 方法会直接对数组进行修改。

实例

例子 1

在本例中，我们将创建一个新数组，并向其添加一个元素：

<script type="text/javascript">

var arr = new Array(6)
arr[0] = "George"
arr[1] = "John"
arr[2] = "Thomas"
arr[3] = "James"
arr[4] = "Adrew"
arr[5] = "Martin"

document.write(arr + "<br />")
arr.splice(2,0,"William")
document.write(arr + "<br />")

</script>

输出：

George,John,Thomas,James,Adrew,Martin
George,John,William,Thomas,James,Adrew,Martin

例子 2

在本例中我们将删除位于 index 2 的元素，并添加一个新元素来替代被删除的元素：

<script type="text/javascript">

var arr = new Array(6)
arr[0] = "George"
arr[1] = "John"
arr[2] = "Thomas"
arr[3] = "James"
arr[4] = "Adrew"
arr[5] = "Martin"

document.write(arr + "<br />")
arr.splice(2,1,"William")
document.write(arr)

</script>

输出：

George,John,Thomas,James,Adrew,Martin
George,John,William,James,Adrew,Martin

例子 3

在本例中我们将删除从 index 2 ("Thomas") 开始的三个元素，并添加一个新元素 ("William") 来替代被删除的元素：

<script type="text/javascript">

var arr = new Array(6)
arr[0] = "George"
arr[1] = "John"
arr[2] = "Thomas"
arr[3] = "James"
arr[4] = "Adrew"
arr[5] = "Martin"

document.write(arr + "<br />")
arr.splice(2,3,"William")
document.write(arr)

</script>

输出：

George,John,Thomas,James,Adrew,Martin
George,John,William,Martin

TIY

splice()
如何使用 splice() 来更改数组。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript split() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript split() 方法

返回 JavaScript String 对象参考手册

定义和用法

split() 方法用于把一个字符串分割成字符串数组。

语法

stringObject.split(separator, howmany)
参数 | 描述
separator | 必需。字符串或正则表达式，从该参数指定的地方分割 stringObject。
howmany | 可选。该参数可指定返回的数组的最大长度。如果设置了该参数，返回的子串不会多于这个参数指定的数组。如果没有设置该参数，整个字符串都会被分割，不考虑它的长度。

返回值

一个字符串数组。该数组是通过在 separator 指定的边界处将字符串 stringObject 分割成子串创建的。返回的数组中的字串不包括 separator 自身。

但是，如果 separator 是包含子表达式的正则表达式，那么返回的数组中包括与这些子表达式匹配的字串（但不包括与整个正则表达式匹配的文本）。

提示和注释

注释：如果把空字符串 ("") 用作 separator，那么 stringObject 中的每个字符之间都会被分割。

注释：String.split() 执行的操作与 Array.join 执行的操作是相反的。

实例

例子 1

在本例中，我们将按照不同的方式来分割字符串：

<script type="text/javascript">

var str="How are you doing today?"

document.write(str.split(" ") + "<br />")
document.write(str.split("") + "<br />")
document.write(str.split(" ",3))

</script>

输出：

How,are,you,doing,today?
H,o,w, ,a,r,e, ,y,o,u, ,d,o,i,n,g, ,t,o,d,a,y,?
How,are,you

例子 2

在本例中，我们将分割结构更为复杂的字符串：

"2:3:4:5".split(":")	//将返回["2", "3", "4", "5"]
"|a|b|c".split("|")	//将返回["", "a", "b", "c", ""]

例子 3

使用下面的代码，可以把句子分割成单词：

var words = sentence.split(' ')

或者使用正则表达式作为 separator：

var words = sentence.split(/\s+/)

例子 4

如果您希望把单词分割为字母，或者把字符串分割为字符，可使用下面的代码：

"hello".split("")	//可返回 ["h", "e", "l", "l", "o"]

若只需要返回一部分字符，请使用 howmany 参数：

"hello".split("", 3)	//可返回 ["h", "e", "l"]

TIY

split()
如何使用 split() 来分割字符串。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript sqrt() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript sqrt() 方法

返回 JavaScript Math 对象参考手册

定义和用法

sqrt() 方法可返回一个数的平方根。

语法

Math.sqrt(x)
参数 | 描述
x | 必需。必须是大于等于 0 的数。

返回值

参数 x 的平方根。如果 x 小于 0，则返回 NaN。

提示和注释

提示：Math.pow() 方法可以计算一个数的任意次根。

实例

在本例中，我们将返回不同数字的平方根：

<script type="text/javascript">

document.write(Math.sin(3) + "<br />")
document.write(Math.sin(-3) + "<br />")
document.write(Math.sin(0) + "<br />")
document.write(Math.sin(Math.PI) + "<br />")
document.write(Math.sin(Math.PI/2)

</script>

输出：

0.1411200080598672
-0.1411200080598672
0
1.2246063538223772e-16
1

TIY

sqrt()
如何使用 sqrt() 来计算一些数字的平方根。

返回 JavaScript Math 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript strike() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript strike() 方法

返回 JavaScript String 对象参考手册

定义和用法

strike() 方法用于显示加删除线的字符串。

语法

stringObject.strike()

实例

在本例中，"Hello world!" 将被加上一条删除线：

<script type="text/javascript">

var str="Hello world!"
document.write(str.strike())

</script>

TIY

strike()
如何使用 strike() 来显示加了删除线的字符串。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript String 对象参考手册

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript String 对象参考手册

字符串是 JavaScript 的一种基本的数据类型。

String 对象的 length 属性声明了该字符串中的字符数。String 类定义了大量操作字符串的方法。

需要注意的是，JavaScript 的字符串是不可变的，String 类定义的方法都不能改变字符串的内容。

String 对象的方法

FF: Firefox, N: Netscape, IE: Internet Explorer

方法 | 描述 | FF | N | IE
anchor() | 创建 HTML 锚。 | 1 | 2 | 3
big() | 用大号字体显示字符串。 | 1 | 2 | 3
blink() | 显示闪动字符串。 | 1 | 2 |
bold() | 使用粗体显示字符串。 | 1 | 2 | 3
charAt() | 返回在指定位置的字符。 | 1 | 2 | 3
charCodeAt() | 返回在指定的位置的字符的 Unicode 编码。 | 1 | 4 | 4
concat() | 连接字符串。 | 1 | 4 | 4
fixed() | 以打字机文本显示字符串。 | 1 | 2 | 3
fontcolor() | 使用指定的颜色来显示字符串。 | 1 | 2 | 3
fontsize() | 使用指定的尺寸来显示字符串。 | 1 | 2 | 3
fromCharCode() | 从字符编码创建一个字符串。 | 1 | 4 | 4
indexOf() | 检索字符串。 | 1 | 2 | 3
italics() | 使用斜体显示字符串。 | 1 | 2 | 3
lastIndexOf() | 从后向前搜索字符串。 | 1 | 2 | 3
link() | 将字符串显示为链接。 | 1 | 2 | 3
localeCompare() | 用本地特定的顺序来比较两个字符串。 | 1 | 4 | 4
match() | 找到一个或多个正在表达式的匹配。 | 1 | 4 | 4
replace() | 替换与正则表达式匹配的子串。 | 1 | 4 | 4
search() | 检索与正则表达式相匹配的值。 | 1 | 4 | 4
slice() | 提取字符串的片断，并在新的字符串中返回被提取的部分。 | 1 | 4 | 4
small() | 使用小字号来显示字符串。 | 1 | 2 | 3
split() | 把字符串分割为字符串数组。 | 1 | 4 | 4
strike() | 使用删除线来显示字符串。 | 1 | 2 | 3
sub() | 把字符串显示为下标。 | 1 | 2 | 3
substr() | 从起始索引号提取字符串中指定数目的字符。 | 1 | 4 | 4
substring() | 提取字符串中两个指定的索引号之间的字符。 | 1 | 2 | 3
sup() | 把字符串显示为上标。 | 1 | 2 | 3
toLocaleLowerCase() | 把字符串转换为小写。 | - | - | -
toLocaleUpperCase() | 把字符串转换为大写。 | - | - | -
toLowerCase() | 把字符串转换为小写。 | 1 | 2 | 3
toUpperCase() | 把字符串转换为大写。 | 1 | 2 | 3
toSource() | 代表对象的源代码。 | 1 | 4 | -
toString() | 返回字符串。 | - | - | -
valueOf() | 返回某个字符串对象的原始值。 | 1 | 2 | 4

String 对象的属性

FF: Firefox, N: Netscape, IE: Internet Explorer

属性 | 描述 | FF | N | IE
constructor | 对创建该对象的函数的引用 | 1 | 4 | 4
length | 字符串的长度 | 1 | 2 | 3
prototype | 允许您向对象添加属性和方法 | 1 | 2 | 4

课外书

如需更多信息，请阅读 JavaScript 高级教程中的相关内容：

ECMAScript 引用类型
引用类型通常叫做类（class）或对象。本节讲解 ECMAScript 的预定义引用类型。

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript sub() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript sub() 方法

返回 JavaScript String 对象参考手册

定义和用法

sub() 方法用于把字符串显示为下标。

语法

stringObject.sub()

实例

在本例中，"Hello world!" 将被显示为下标：

<script type="text/javascript">

var str="Hello world!"
document.write(str.sub())

</script>

TIY

sub()
如何使用 sub() 把字符串显示为下标。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript substr() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript substr() 方法

返回 JavaScript String 对象参考手册

定义和用法

substr() 方法可在字符串中抽取从 start 下标开始的指定数目的字符。

语法

stringObject.substr(start,length)
参数 | 描述
start | 必需。要抽取的子串的起始下标。必须是数值。如果是负数，那么该参数声明从字符串的尾部开始算起的位置。也就是说，-1 指字符串中最后一个字符，-2 指倒数第二个字符，以此类推。
length | 可选。子串中的字符数。必须是数值。如果省略了该参数，那么返回从 stringObject 的开始位置到结尾的字串。

返回值

一个新的字符串，包含从 stringObject 的 start（包括 start 所指的字符） 处开始的 lenght 个字符。如果没有指定 lenght，那么返回的字符串包含从 start 到 stringObject 的结尾的字符。

提示和注释

注释：substr() 的参数指定的是子串的开始位置和长度，因此它可以替代 substring() 和 splice() 来使用。

重要事项：ECMAscript 没有对该方法进行标准化，因此反对使用它。

重要事项：在 IE 4 中，参数 start 的值无效。在这个 BUG 中，start 规定的是第 0 个字符的位置。在之后的版本中，此 BUG 已被修正。

实例

例子 1

在本例中，我们将使用 substr() 从字符串中提取一些字符：

<script type="text/javascript">

var str="Hello world!"
document.write(str.substr(3))

</script>

输出：

lo world!

例子 2

在本例中，我们将使用 substr() 从字符串中提取一些字符：

<script type="text/javascript">

var str="Hello world!"
document.write(str.substr(3,7))

</script>

输出：

lo worl

TIY

substr()
如何使用 substr() 从字符串提取一些字符。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript substring() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript substring() 方法

返回 JavaScript String 对象参考手册

定义和用法

substring() 方法用于提取字符串中介于两个指定下标之间的字符。

语法

stringObject.substring(start,stop)
参数 | 描述
start | 必需。一个非负的整数，规定要提取的子串在第一个字符在 stringObject 中的位置。
stop | 可选。一个非负的整数，比要提取的子串的最后一个字符在 stringObject 中的位置多 1。如果省略该参数，那么返回的子串会一直到字符串的结尾。

返回值

一个新的字符串，该字符串值包含 stringObject 的一个子字符串，其内容是从 start 处到 stop-1 处的所有字符，其长度为 stop 减 start。

说明

substring() 方法返回的子串包括 start 处的字符，但不包括 end 处的字符。

如果参数 start 与 end 相等，那么该方法返回的就是一个空串（即长度为 0 的字符串）。如果 start 比 end 大，那么该方法在提取子串之前会先交换这两个参数。

提示和注释

重要事项：与 slice() 和 substr() 方法不同的是，substring() 不接受负的参数。

实例

例子 1

在本例中，我们将使用 substring() 从字符串中提取一些字符：

<script type="text/javascript">

var str="Hello world!"
document.write(str.substring(3))

</script>

输出：

lo world!

例子 2

在本例中，我们将使用 substring() 从字符串中提取一些字符：

<script type="text/javascript">

var str="Hello world!"
document.write(str.substring(3,7))

</script>

输出：

lo w

TIY

substring()
如何使用 substring() 从字符串中提取一些字符。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript sup() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript sup() 方法

返回 JavaScript String 对象参考手册

定义和用法

sup() 方法用于把字符串显示为上标。

语法

stringObject.sup()

实例

在本例中，"Hello world!" 将被显示为上标：

<script type="text/javascript">

var str="Hello world!"
document.write(str.sup())

</script>

TIY

sup()
如何使用 sup() 把字符串显示为上标。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript Switch 语句

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript Switch 语句

  • Previous Page
  • Next Page

JavaScript 中的条件语句用于完成基于不同条件的行为。

实例

Switch 语句
如何编写一个 Switch 语句。

JavaScript Switch 语句

如果希望选择执行若干代码块中的一个，你可以使用 switch 语句：

语法：

switch(n)
   {
   case 1:
     执行代码块 1
     break
   case 2:
     执行代码块 2
     break
   default:
     如果n即不是1也不是2，则执行此代码
   }

工作原理：switch 后面的 (n) 可以是表达式，也可以（并通常）是变量。然后表达式中的值会与 case 中的数字作比较，如果与某个 case 相匹配，那么其后的代码就会被执行。break 的作用是防止代码自动执行到下一行。

实例：

<script type="text/javascript">
//You will receive a different greeting based
//on what day it is. Note that Sunday=0,
//Monday=1, Tuesday=2, etc.

var d=new Date()
theDay=d.getDay()

switch (theDay)
   {
   case 5:
     document.write("Finally Friday")
     break
   case 6:
     document.write("Super Saturday")
     break
   case 0:
     document.write("Sleepy Sunday")
     break
   default:
     document.write("I'm looking forward to this weekend!")
}
</script>
  • Previous Page
  • Next Page

课外书

如需更多有关 JavaScript Switch 语句的知识，请阅读 JavaScript 高级教程中的相关内容：

ECMAScript switch 语句
switch 语句是 if 语句的兄弟语句。本节介绍了 switch 语句的用法，以及与 Java 中的 switch 语句的不同。

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript tan() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript tan() 方法

返回 JavaScript Math 对象参考手册

定义和用法

tan() 方法可返回一个表示某个角的正切的数字。

语法

Math.tan(x)
参数 | 描述
x | 必需。一个以弧度表示的角。将角度乘以 0.017453293 （2PI/360）即可转换为弧度。

返回值

参数 x 的正切值。

实例

在本例中，我们将计算不同数字的正切值：

<script type="text/javascript">

document.write(Math.tan(0.50) + "<br />")
document.write(Math.tan(-0.50) + "<br />")
document.write(Math.tan(5) + "<br />")
document.write(Math.tan(10) + "<br />")
document.write(Math.tan(-5) + "<br />")
document.write(Math.tan(-10))

</script>

输出：

0.5463024898437905
-0.5463024898437905
-3.380515006246586
0.6483608274590866
3.380515006246586
-0.6483608274590866

TIY

tan()
如何使用 tan() 来计算不同数字的正切值。

返回 JavaScript Math 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript test() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript test() 方法

返回 JavaScript RegExp 对象参考手册

定义和用法

test() 方法用于检测一个字符串是否匹配某个模式.

语法

RegExpObject.test(string)
参数 | 描述
string | 必需。要检测的字符串。

返回值

如果字符串 string 中含有与 RegExpObject 匹配的文本，则返回 true，否则返回 false。

说明

调用 RegExp 对象 r 的 test() 方法，并为它传递字符串 s，与这个表示式是等价的：(r.exec(s) != null)。

实例

在下面的例子中，我们将检索 "W3School"：

<script type="text/javascript">
var str = "Visit W3School";
var patt1 = new RegExp("W3School");

var result = patt1.test(str);

document.write("Result: " + result);
</script>

输出：

Result: true

TIY

test()
如何使用 test() 来检索字符串。

返回 JavaScript RegExp 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript Throw 声明

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript Throw 声明

  • Previous Page
  • Next Page

throw 声明的作用是创建 exception（异常或错误）。

实例

throw 声明
如何使用 throw 声明。

Throw 声明

throw 声明的作用是创建 exception（异常）。你可以把这个声明与 try...catch 声明配合使用，以达到控制程序流并产生精确错误消息的目的。

语法：

throw(exception)

exception 可以是字符串、整数、逻辑值或者对象。

注意：使用小写字母编写 throw。使用大写字母会出错！

实例 1

下面的实例的作用是测定变量 x 的值。如果 x 的值大于 10 或者小于 0，错误就会被抛出 (throw)。这个错误被 catch 的参数捕获后，就会显示出自定义的出错信息。

<html>
<body>
<script type="text/javascript">
var x=prompt("Enter a number between 0 and 10:","")
try
{
if(x>10)
throw "Err1"
else if(x<0)
throw "Err2"
}
catch(er)
{
if(er=="Err1")
alert("Error! The value is too high")
if(er == "Err2")
alert("Error! The value is too low")
}
</script>
</body>
</html>
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript toDateString() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript toDateString() 方法

返回 JavaScript Date 对象参考手册

定义和用法

toDateString() 方法可把 Date 对象的日期部分转换为字符串，并返回结果。

语法

dateObject.toDateString()

返回值

dateObject 的日期部分的字符串表示，由实现决定，使用本地时间表示。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript toExponential() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript toExponential() 方法

返回 JavaScript Number 对象参考手册

定义和用法

toExponential() 方法可把对象的值转换成指数计数法。

语法

NumberObject.toExponential(num)
参数 | 描述
num | 必需。规定指数计数法中的小数位数，是 0 ~ 20 之间的值，包括 0 和 20，有些实现可以支持更大的数值范围。如果省略了该参数，将使用尽可能多的数字。

返回值

返回 NumberObject 的字符串表示，采用指数计数法，即小数点之前有一位数字，小数点之后有 num 位数字。该数字的小数部分将被舍入，必要时用 0 补足，以便它达到指定的长度。

抛出

当 num 太小或太大时抛出异常 RangeError。0 ~ 20 之间的值不会引发该异常。有些实现支持更大范围或更小范围内的值。

当调用该方法的对象不是 Number 时抛出 TypeError 异常。

实例

在本例中，我们将把一个数字转换为指数计数法：

Show 10,000 as an exponential notation:
<script type="text/javascript">
var num = new Number(10000);
document.write (num.toExponential(1))
</script>

输出：

Show 10,000 as an exponential notation:
1.0e+4

TIY

toExponential()
如何使用 toExponential() 来把数字转换为指数计数法。

返回 JavaScript Number 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript toFixed() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript toFixed() 方法

返回 JavaScript Number 对象参考手册

定义和用法

toFixed() 方法可把 Number 四舍五入为指定小数位数的数字。

语法

NumberObject.toFixed(num)
参数 | 描述
num | 必需。规定小数的位数，是 0 ~ 20 之间的值，包括 0 和 20，有些实现可以支持更大的数值范围。如果省略了该参数，将用 0 代替。

返回值

返回 NumberObject 的字符串表示，不采用指数计数法，小数点后有固定的 num 位数字。如果必要，该数字会被舍入，也可以用 0 补足，以便它达到指定的长度。如果 num 大于 le+21，则该方法只调用 NumberObject.toString()，返回采用指数计数法表示的字符串。

抛出

当 num 太小或太大时抛出异常 RangeError。0 ~ 20 之间的值不会引发该异常。有些实现支持更大范围或更小范围内的值。

当调用该方法的对象不是 Number 时抛出 TypeError 异常。

实例

在本例中，我们将把数字舍入为仅有一位小数的数字：

Show the number 13.37 with one decimal:
<script type="text/javascript">
var num = new Number(13.37);
document.write (num.toFixed(1))
</script>

输出：

Show the number 13.37 with one decimal:
13.4

TIY

toFixed()
如何使用 toFixed() 来舍入一个数字。

返回 JavaScript Number 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript toGMTString() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript toGMTString() 方法

返回 JavaScript Date 对象参考手册

定义和用法

toGMTString() 方法可根据格林威治时间 (GMT) 把 Date 对象转换为字符串，并返回结果。

语法

dateObject.toGMTString()

返回值

dateObject 的字符串表示。此日期会在转换为字符串之前由本地时区转换为 GMT 时区。

提示和注释

不赞成使用此方法。请使用 toUTCString() 取而代之！！

实例

例子 1

在本例中，我们将把今天的日期转换为（根据 GMT）字符串：

<script type="text/javascript">

var d = new Date()
document.write (d.toGMTString())

</script>

输出：

例子 2

在下面的例子中，我们将把具体的日期转换为（根据 GMT）字符串：

<script type="text/javascript">

var born = new Date("July 21, 1983 01:15:00")
document.write(born.toGMTString())

</script>

输出：

TIY

toGMTString()
如何通过 toGMTString() 把今天的日期转换为（根据 GMT）字符串。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript toLocaleDateString() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript toLocaleDateString() 方法

返回 JavaScript Date 对象参考手册

定义和用法

toLocaleDateString() 方法可根据本地时间把 Date 对象的日期部分转换为字符串，并返回结果。

语法

dateObject.toLocaleDateString()

返回值

dateObject 的日期部分的字符串表示，以本地时间区表示，并根据本地规则格式化。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript toLocaleLowerCase() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript toLocaleLowerCase() 方法

返回 JavaScript String 对象参考手册

定义和用法

toLocaleLowerCase() 方法用于把字符串转换为小写。

语法

stringObject.toLocaleLowerCase()

返回值

一个新的字符串，在其中 stringObject 的所有大写字符全部被转换为了小写字符。

说明

与 toLowerCase() 不同的是，toLocaleLowerCase() 方法按照本地方式把字符串转换为小写。只有几种语言（如土耳其语）具有地方特有的大小写映射，所有该方法的返回值通常与 toLowerCase() 一样。

实例

在本例中，"Hello world!" 将以小写字母来显示：

<script type="text/javascript">

var str="Hello World!"
document.write(str.toLocaleLowerCase())

</script>

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript toLocaleString() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript toLocaleString() 方法

返回 JavaScript Array 对象参考手册

定义和用法

把数组转换为本地字符串。

语法

arrayObject.toLocaleString()

返回值

arrayObject 的本地字符串表示。

说明

首先调用每个数组元素的 toLocaleString() 方法，然后使用地区特定的分隔符把生成的字符串连接起来，形成一个字符串。

实例

<script type="text/javascript">

var arr = new Array(3)
arr[0] = "George"
arr[1] = "John"
arr[2] = "Thomas"

document.write(arr.toLocaleString())

</script>

输出：

George, John, Thomas

TIY

toLocaleString()
如何使用 toLocaleString() 来更改数组。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript toLocaleString() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript toLocaleString() 方法

返回 JavaScript Date 对象参考手册

定义和用法

toLocaleString() 方法可根据本地时间把 Date 对象转换为字符串，并返回结果。

语法

dateObject.toLocaleString()

返回值

dateObject 的字符串表示，以本地时间区表示，并根据本地规则格式化。

实例

例子 1

在本例中，我们将根据本地时间把今天的日期转换为字符串：

<script type="text/javascript">

var d = new Date()
document.write(d.toLocaleString())

</script>

输出：

例子 2

在本例中，我们将根据本地时间把具体的日期转换为字符串：

<script type="text/javascript">

var born = new Date("July 21, 1983 01:15:00")
document.write(born.toLocaleString())

</script>

输出：

TIY

toLocaleString()
如何使用 toLocaleString() 来根据本地时间把今天的日期转换为字符串。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript toLocaleString() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript toLocaleString() 方法

返回 JavaScript Number 对象参考手册

定义和用法

toLocaleString() 方法可把一个 Number 对象转换为本地格式的字符串。

语法

NumberObject.toLocaleString()

返回值

数字的字符串表示，由实现决定，根据本地规范进行格式化，可能影响到小数点或千分位分隔符采用的标点符号。

抛出

当调用该方法的对象不是 Number 时抛出 TypeError 异常。

返回 JavaScript Number 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript toLocaleTimeString() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript toLocaleTimeString() 方法

返回 JavaScript Date 对象参考手册

定义和用法

toLocaleTimeString() 方法可根据本地时间把 Date 对象的时间部分转换为字符串，并返回结果。

语法

dateObject.toLocaleTimeString()

返回值

dateObject 的时间部分的字符串表示，以本地时间区表示，并根据本地规则格式化。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript toLocaleUpperCase() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript toLocaleUpperCase() 方法

返回 JavaScript String 对象参考手册

定义和用法

toLocaleUpperCase() 方法用于把字符串转换为大写。

语法

stringObject.toLocaleUpperCase()

返回值

一个新的字符串，在其中 stringObject 的所有小写字符全部被转换为了大写字符。

说明

与 toUpperCase() 不同的是，toLocaleUpperCase() 方法按照本地方式把字符串转换为大写。只有几种语言（如土耳其语）具有地方特有的大小写映射，所有该方法的返回值通常与 toUpperCase() 一样。

实例

在本例中，"Hello world!" 将以大写字母来显示：

<script type="text/javascript">

var str="Hello World!"
document.write(str.toLocaleUpperCase())

</script>

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript toLowerCase() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript toLowerCase() 方法

返回 JavaScript String 对象参考手册

定义和用法

toLowerCase() 方法用于把字符串转换为小写。

语法

stringObject.toLowerCase()

返回值

一个新的字符串，在其中 stringObject 的所有大写字符全部被转换为了小写字符。

实例

在本例中，"Hello world!" 将以小写字母来显示：

<script type="text/javascript">

var str="Hello World!"
document.write(str.toLowerCase())

</script>

TIY

toLowerCase()
如何使用 toLowerCase() 来把字符串转换成小写。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript toPrecision() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript toPrecision() 方法

返回 JavaScript Number 对象参考手册

定义和用法

toPrecision() 方法可在对象的值超出指定位数时将其转换为指数计数法。

语法

NumberObject.toPrecision(num)
参数 | 描述
num | 必需。规定必须被转换为指数计数法的最小位数。该参数是 1 ~ 21 之间（且包括 1 和 21）的值。有效实现允许有选择地支持更大或更小的 num。如果省略了该参数，则调用方法 toString()，而不是把数字转换成十进制的值。

返回值

返回 NumberObject 的字符串表示，包含 num 个有效数字。如果 num 足够大，能够包括 NumberObject 整数部分的所有数字，那么返回的字符串将采用定点计数法。否则，采用指数计数法，即小数点前有一位数字，小数点后有 num-1 位数字。必要时，该数字会被舍入或用 0 补足。

抛出

当 num 太小或太大时抛出异常 RangeError。1 ~ 21 之间的值不会引发该异常。有些实现支持更大范围或更小范围内的值。

当调用该方法的对象不是 Number 时抛出 TypeError 异常。

实例

在本例中，我们将把一个数字转换为指数计数法：

Show 10,000 as an exponential notation:
<script type="text/javascript">
var num = new Number(10000);
document.write (num.toPrecision(4))
</script>

输出：

Show 10,000 as an exponential notation:
1.000e+4

TIY

toPrecision()
如何使用 toPrecision() 来把数字转换为指数计数法。

返回 JavaScript Number 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript toString() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript toString() 方法

返回 JavaScript Array 对象参考手册

定义和用法

toString() 方法可把数组转换为字符串，并返回结果。

语法

arrayObject.toString()

返回值

arrayObject 的字符串表示。返回值与没有参数的 join() 方法返回的字符串相同。

说明

当数组用于字符串环境时，JavaScript 会调用这一方法将数组自动转换成字符串。但是在某些情况下，需要显式地调用该方法。

提示和注释

注释：数组中的元素之间用逗号分隔。

实例

<script type="text/javascript">

var arr = new Array(3)
arr[0] = "George"
arr[1] = "John"
arr[2] = "Thomas"

document.write(arr.toString())

</script>

输出：

George,John,Thomas

TIY

toString()
如何使用 toString() 来更改数组。

返回 JavaScript String 对象参考手册

课外书

如需更多有关类型转换的知识，请阅读 JavaScript 高级教程中的相关内容：

ECMAScript 类型转换
本节讲解了 ECMAScript 提供的类型转换方法，以及如何进行强制类型转换。

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript toString() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript toString() 方法

返回 JavaScript Boolean 对象参考手册

定义和用法

toString() 方法可把一个逻辑值转换为字符串，并返回结果。

语法

booleanObject.toString()

返回值

根据原始布尔值或者 booleanObject 对象的值返回字符串 "true" 或 "false"。

抛出

如果调用该方法的对象不是 Boolean，则抛出异常 TypeError。

提示和注释

注释：在 Boolean 对象被用于字符串环境中时，此方法会被自动调用。

实例

在本例中，我们将创建一个 Boolean 对象，并把它转换成字符串：

<script type="text/javascript">

 var boo = new Boolean(true)
document.write(boo.toString())

</script>

输出：

true

TIY

toString()
如何使用 toString() 来把一个布尔值转换成字符串。

返回 JavaScript Boolean 对象参考手册

课外书

如需更多有关类型转换的知识，请阅读 JavaScript 高级教程中的相关内容：

ECMAScript 类型转换
本节讲解了 ECMAScript 提供的类型转换方法，以及如何进行强制类型转换。

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript toString() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript toString() 方法

返回 JavaScript Date 对象参考手册

定义和用法

toString() 方法可把 Date 对象转换为字符串，并返回结果。

语法

dateObject.toString()

返回值

dateObject 的字符串表示，使用本地时间表示。

实例

在本例中，我们将把今天的日期转换为字符串：

<script type="text/javascript">

var d = new Date()
document.write (d.toString())

</script>

输出：

TIY

toString()
如何使用 toString() 把今天的日期转换为字符串。

返回 JavaScript Date 对象参考手册

课外书

如需更多有关类型转换的知识，请阅读 JavaScript 高级教程中的相关内容：

ECMAScript 类型转换
本节讲解了 ECMAScript 提供的类型转换方法，以及如何进行强制类型转换。

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript toString() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript toString() 方法

返回 JavaScript Number 对象参考手册

定义和用法

toString() 方法可把一个 Number 对象转换为一个字符串，并返回结果。

语法

NumberObject.toString(radix)
参数 | 描述
radix | 可选。规定表示数字的基数，使 2 ~ 36 之间的整数。若省略该参数，则使用基数 10。但是要注意，如果该参数是 10 以外的其他值，则 ECMAScript 标准允许实现返回任意值。

返回值

数字的字符串表示。例如，当 radix 为 2 时，NumberObject 会被转换为二进制值表示的字符串。

抛出

当调用该方法的对象不是 Number 时抛出 TypeError 异常。

实例

在本例中，我们将把一个数字转换为字符串：

<script type="text/javascript">

var number = new Number(1337);
document.write (number.toString())

</script>

输出：

1337

TIY

toString()
如何使用 toString() 来把数字转换为字符串。

返回 JavaScript Number 对象参考手册

课外书

如需更多有关类型转换的知识，请阅读 JavaScript 高级教程中的相关内容：

ECMAScript 类型转换
本节讲解了 ECMAScript 提供的类型转换方法，以及如何进行强制类型转换。

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript toString() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript toString() 方法

返回 JavaScript String 对象参考手册

定义和用法

toString() 方法返回字符串。

语法

stringObject.toString()

返回值

stringObject 的原始字符串值。一般不会调用该方法。

抛出

当调用该方法的对象不是 String 时抛出 TypeError 异常。

参阅

array.toString() 、 boolean.toString() 、 date.toString() 、 Number.toString()

array.toLocaleString() 、 date.toLocaleString() 、 Number.toLocaleString()

stringObject.valueOf()

返回 JavaScript String 对象参考手册

课外书

如需更多有关类型转换的知识，请阅读 JavaScript 高级教程中的相关内容：

ECMAScript 类型转换
本节讲解了 ECMAScript 提供的类型转换方法，以及如何进行强制类型转换。

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript toTimeString() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript toTimeString() 方法

返回 JavaScript Date 对象参考手册

定义和用法

toTimeString() 方法可把 Date 对象的时间部分转换为字符串，并返回结果。

语法

dateObject.toTimeString()

返回值

dateObject 的时间部分的字符串表示，由实现决定，使用本地时间表示。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript toUpperCase() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript toUpperCase() 方法

返回 JavaScript String 对象参考手册

定义和用法

toUpperCase() 方法用于把字符串转换为大写。

语法

stringObject.toUpperCase()

返回值

一个新的字符串，在其中 stringObject 的所有小写字符全部被转换为了大写字符。

实例

在本例中，"Hello world!" 将以大写字母来显示：

<script type="text/javascript">

var str="Hello World!"
document.write(str.toUpperCase())

</script>

TIY

toUpperCase()
如何使用 toUpperCase() 来把字符串转换成大写。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript toUTCString() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript toUTCString() 方法

返回 JavaScript Date 对象参考手册

定义和用法

toUTCString() 方法可根据世界时 (UTC) 把 Date 对象转换为字符串，并返回结果。

语法

dateObject.toUTCString()

返回值

dateObject 的字符串表示，用世界时表示。

实例

例子 1

在下面的例子中，我们将使用 toUTCString() 来把今天的日期转换为（根据 UTC）字符串：

<script type="text/javascript">

var d = new Date()
document.write (d.toUTCString())

</script>

输出：

例子 2

在下面的例子中，我们将把具体的日期转换为（根据 UTC）字符串：

<script type="text/javascript">

var born = new Date("July 21, 1983 01:15:00")
document.write(born.toUTCString())

</script>

输出：

TIY

toUTCString()
如何使用 toUTCString() 来把今天的日期转换为（根据 UTC）字符串。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript Try...Catch 语句

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript Try...Catch 语句

  • Previous Page
  • Next Page

try...catch 的作用是测试代码中的错误。

实例

try...catch 语句
如何编写 try...catch 语句。
带有确认框的 try...catch 语句
另一个编写 try...catch 语句的例子。

JavaScript - 捕获错误

当我们在网上冲浪时，总会看到带有 runtime 错误的 Javascript 警告框，同时会询问我们“是否进行 debug？”。像这样的错误信息或许对开发人员有用，对用户则未必。当错误发生时，他们往往会选择离开这个站点。

本节向你讲解如何捕获和处理 Javascript 的错误消息，这样就可以为受众提供更多的便利。

有两种在网页中捕获错误的方法：

  • 使用 try...catch 语句。(在 IE5+、Mozilla 1.0、和 Netscape 6 中可用)
  • 使用 onerror 事件。这是用于捕获错误的老式方法。(Netscape 3 以后的版本可用)

Try...Catch 语句

try...catch 可以测试代码中的错误。try 部分包含需要运行的代码，而 catch 部分包含错误发生时运行的代码。

语法：

try
{
   //在此运行代码
}
catch(err)
{
   //在此处理错误
}

注意：try...catch 使用小写字母。大写字母会出错。

实例 1

下面的例子原本用在用户点击按钮时显示 "Welcome guest!" 这个消息。不过 message() 函数中的 alert() 被误写为 adddlert()。这时错误发生了：

<html>
<head>
<script type="text/javascript">
function message()
{
adddlert("Welcome guest!")
}
</script>
</head>

<body>
<input type="button" value="View message" onclick="message()" />
</body>

</html>

我们可以添加 try...catch 语句，这样当错误发生时可以采取更适当的措施。

下面的例子用 try...catch 语句重新修改了脚本。由于误写了 alert()，所以错误发生了。不过这一次，catch 部分捕获到了错误，并用一段准备好的代码来处理这个错误。这段代码会显示一个自定义的出错信息来告知用户所发生的事情。

<html>
<head>
<script type="text/javascript">
var txt=""
function message()
{
try
  {
  adddlert("Welcome guest!")
  }
catch(err)
  {
  txt="此页面存在一个错误。\n\n"
  txt+="错误描述: " + err.description + "\n\n"
  txt+="点击OK继续。\n\n"
  alert(txt)
  }
}
</script>
</head>

<body>
<input type="button" value="View message" onclick="message()" />
</body>

</html>

实例 2

下一个例子会显示一个确认框，让用户来选择在发生错误时点击确定按钮来继续浏览网页，还是点击取消按钮来回到首页。如果 confirm 方法的返回值为 false，代码会把用户重定向到其他的页面。如果 confirm 方法的返回值为 true，那么代码什么也不会做。

<html>
<head>
<script type="text/javascript">
var txt=""
function message()
{
try
  {
  adddlert("Welcome guest!")
  }
catch(err)
  {
  txt="There was an error on this page.\n\n"
  txt+="Click OK to continue viewing this page,\n"
  txt+="or Cancel to return to the home page.\n\n"
  if(!confirm(txt))
    {
    document.location.href="http://www.w3school.com.cn/"
    }
  }
}
</script>
</head>

<body>
<input type="button" value="View message" onclick="message()" />
</body>

</html>

onerror 事件

我们马上会讲解 onerror 事件。但首先您需要学习如何使用 throw 语句来创建异常。throw 语句可以与 try...catch 语句一起使用。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript undefined 属性

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript undefined 属性

返回 JavaScript 全局对象参考手册

定义和用法

undefined 属性用于存放 JavaScript 的 undefined 值。

语法

undefined

说明

无法使用 for/in 循环来枚举 undefined 属性，也不能用 delete 运算符来删除它。

undefined 不是常量，可以把它设置为其他值。

当尝试读取不存在的对象属性时也会返回 undefined。

提示和注释

提示：只能用 === 运算来测试某个值是否是未定义的，因为 == 运算符认为 undefined 值等价于 null。

注释：null 表示无值，而 undefined 表示一个未声明的变量，或已声明但没有赋值的变量，或一个并不存在的对象属性。

实例

在本例中，我们将检测两个变量中未定义的一个：

<script type="text/javascript">

var t1=""
var t2

if (t1===undefined) {document.write("t1 is undefined")}
if (t2===undefined) {document.write("t2 is undefined")}

</script>

输出：

t2 is undefined

TIY

undefined
如何检测两个变量中未定义的一个。

返回 JavaScript 全局对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript unescape() 函数

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript unescape() 函数

返回 JavaScript 全局对象参考手册

定义和用法

unescape() 函数可对通过 escape() 编码的字符串进行解码。

语法

unescape(string)
参数 | 描述
string | 必需。要解码或反转义的字符串。

返回值

string 被解码后的一个副本。

说明

该函数的工作原理是这样的：通过找到形式为 %xx 和 %uxxxx 的字符序列（x 表示十六进制的数字），用 Unicode 字符 \u00xx 和 \uxxxx 替换这样的字符序列进行解码。

提示和注释

注释：ECMAScript v3 已从标准中删除了 unescape() 函数，并反对使用它，因此应该用 decodeURI() 和 decodeURIComponent() 取而代之。

实例

在本例中，我们将使用 escape() 来编码字符串，然后使用 unescape() 对其解码：

<script type="text/javascript">

var test1="Visit W3School!"

test1=escape(test1)
document.write (test1 + "<br />")

test1=unescape(test1)
document.write(test1 + "<br />")

</script>

输出：

Visit%20W3School%21
Visit W3School!

TIY

unescape()
如何使用 unescape() 来解码字符串。

返回 JavaScript 全局对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript unshift() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript unshift() 方法

返回 JavaScript Array 对象参考手册

定义和用法

unshift() 方法可向数组的开头添加一个或更多元素，并返回新的长度。

语法

arrayObject.unshift(newelement1,newelement2,....,newelementX)
参数 | 描述
newelement1 | 必需。向数组添加的第一个元素。
newelement2 | 可选。向数组添加的第二个元素。
newelementX | 可选。可添加若干个元素。

返回值

arrayObject 的新长度。

说明

unshift() 方法将把它的参数插入 arrayObject 的头部，并将已经存在的元素顺次地移到较高的下标处，以便留出空间。该方法的第一个参数将成为数组的新元素 0，如果还有第二个参数，它将成为新的元素 1，以此类推。

请注意，unshift() 方法不创建新的创建，而是直接修改原有的数组。

提示和注释

注释：该方法会改变数组的长度。

注释：unshift() 方法无法在 Internet Explorer 中正确地工作！

提示：要把一个或多个元素添加到数组的尾部，请使用 push() 方法。

实例

在本例中，我们将创建一个数组，并把一个元素添加到数组的开头，并返回数组的新长度：

<script type="text/javascript">

var arr = new Array()
arr[0] = "George"
arr[1] = "John"
arr[2] = "Thomas"

document.write(arr + "<br />")
document.write(arr.unshift("William") + "<br />")
document.write(arr)

</script>

输出：

George,John,Thomas
4
William,George,John,Thomas

TIY

unshift()
如何使用 unshift() 把一个元素添加到数组的开头，并返回数组的新长度。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript UTC() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript UTC() 方法

返回 JavaScript Date 对象参考手册

定义和用法

UTC() 方法可根据世界时返回 1997 年 1 月 1 日 到指定日期的毫秒数。

语法

Date.UTC(year,month,day,hours,minutes,seconds,ms)
参数 | 描述
year | 必需。表示年份的四位数字。
month | 必需。表示月份的整数，介于 0 ~ 11。
day | 必需。表示日期的整数，介于 1 ~ 31。
hours | 可选。表示小时的整数，介于 0 ~ 23。
minutes | 可选。表示分钟的整数，介于 0 ~ 59。
seconds | 可选。表示秒的整数，介于 0 ~ 59。
ms | 可选。表示毫秒的整数，介于 0 ~ 999。

返回值

返回指定的时间距 GMT 时间 1997 年 1 月 1 日午夜的毫秒数。

说明

Date.UTC() 是一种静态方法，因为需要使用构造函数 Date() 来调用它，而不是通过某个 Date 对象调用。

Date.UTC() 方法的参数指定日期和时间，它们都是 UTC 时间，处于 GMT 时区。指定的 UTC 时间将转换成毫秒的形式，这样构造函数 Date() 和方法 Date.setTime() 就可以使用它了。

实例

例子 1

在本例中，我们将根据世界时取得从 1970/01/01 到 2005/07/08 的毫秒数：

<script type="text/javascript">

var d = Date.UTC(2005,7,8)
document.write(d)

</script>

输出：

1123459200000

例子 2

现在，我们将改造上面的例子，使得输出转换为年：

<script type="text/javascript">

var minutes = 1000 * 60
var hours = minutes * 60
var days = hours * 24
var years = days * 365
var t = Date.UTC(2005,7,8)
var y = t/years
document.write("It's been: " + y + " years from 1970/01/01")
document.write(" to 2005/07/08!")

</script>

输出：

It's been: 35.62465753424657 years from 1970/01/01 to 2005/07/08!

TIY

UTC()
使用 UTC() 来输出从 1970/01/01 到具体日期的毫秒数（根据世界时）。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript valueOf() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript valueOf() 方法

返回 JavaScript Boolean 对象参考手册

定义和用法

valueOf() 方法可返回 Boolean 对象的原始值。

语法

booleanObject.valueOf()

返回值

booleanObject 的原始布尔值。

抛出

如果调用该方法的对象不是 Boolean，则抛出异常 TypeError。

实例

在本例中，我们将创建一个 Boolean 对象，并使用 valueOf() 来取得此对象的原始值：

<script type="text/javascript">

var boo = new Boolean(false)
document.write(boo.valueOf())

</script>

输出：

false

TIY

valueOf()
如何使用 valueOf() 来取得一个 Boolean 对象的原始值。

返回 JavaScript Boolean 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript valueOf() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript valueOf() 方法

返回 JavaScript Date 对象参考手册

定义和用法

valueOf() 方法可返回 Date 对象的原始值。

该原始值是由从 Date 对象下来的所有对象继承的。

valueOf() 方法通常由 JavaScript 在后台自动进行调用，而不是显式地处于代码中。

返回值

date 的毫秒表示。返回值和方法 Date.getTime 返回的值相等。

返回 JavaScript Date 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript valueOf() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript valueOf() 方法

返回 JavaScript Number 对象参考手册

定义和用法

valueOf() 方法可以字符串返回数字。

字符串的输出通常等于该数字。

valueOf() 方法通常由 JavaScript 在后台自动进行调用，而不是显式地处于代码中。

语法

NumberObject.valueOf()

返回值

NumberObject 的原始数值。

抛出

当调用该方法的对象不是 Number 时抛出 TypeError 异常。

返回 JavaScript Number 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript valueOf() 方法

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript valueOf() 方法

返回 JavaScript String 对象参考手册

定义和用法

valueOf() 方法可返回 String 对象的原始值。

原始值是由从 String 对象下来的所有对象继承的。

valueOf() 方法通常由 JavaScript 在后台自动进行调用，而不是显式地处于代码中。

语法

stringObject.valueOf()

抛出

当调用该方法的对象不是 String 时抛出 TypeError 异常。

返回 JavaScript String 对象参考手册

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript While 循环

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript While 循环

  • Previous Page
  • Next Page

JavaScript 中的循环用来将同一段代码执行指定的次数（或者当指定的条件为 true 时）。

实例

While 循环
利用 while 循环在指定条件为 true 时来循环执行代码。
Do while 循环
利用 do...while 循环在指定条件为 true 时来循环执行代码。在即使条件为 false 时，这种循环也会至少执行一次。这是因为在条件被验证前，这个语句就会执行。

while 循环

while 循环用于在指定条件为 true 时循环执行代码。

语法：

while (变量<=结束值)
{
    需执行的代码
}

注意：除了<=，还可以使用其他的比较运算符。

实例：

解释：下面的例子定义了一个循环程序，这个循环程序的参数 i 的起始值为 0。该程序会反复运行，直到 i 大于 10 为止。i 的步进值为 1。

<html>
<body>
<script type="text/javascript">
var i=0
while (i<=10)
{
document.write("The number is " + i)
document.write("<br />")
i=i+1
}
</script>
</body>
</html>

结果：

The number is 0
The number is 1
The number is 2
The number is 3
The number is 4
The number is 5
The number is 6
The number is 7
The number is 8
The number is 9
The number is 10

do...while 循环

do...while 循环是 while 循环的变种。该循环程序在初次运行时会首先执行一遍其中的代码，然后当指定的条件为 true 时，它会继续这个循环。所以可以这么说，do...while 循环为执行至少一遍其中的代码，即使条件为 false，因为其中的代码执行后才会进行条件验证。

语法：

do
{
    需执行的代码
}
while (变量<=结束值)

实例：

<html>
<body>
<script type="text/javascript">
var i=0
do
{
document.write("The number is " + i)
document.write("<br />")
i=i+1
}
while (i<0)
</script>
</body>
</html>

结果：

The number is 0
  • Previous Page
  • Next Page

课外书

如需更多有关 JavaScript while 语句的知识，请阅读 JavaScript 高级教程中的相关内容：

ECMAScript 迭代语句
迭代语句又叫循环语句。本节为您介绍 ECMAScript 提供的四种迭代语句。

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 比较和逻辑运算符

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 比较和逻辑运算符

  • Previous Page
  • Next Page

比较和逻辑运算符用于测试 true 或 false。

比较运算符

比较运算符在逻辑语句中使用，以测定变量或值是否相等。

给定 x=5，下面的表格解释了比较运算符：

运算符 | 描述 | 例子
== | 等于 | x==8 为 false
=== | 全等（值和类型） | x===5 为 true；x==="5" 为 false
!= | 不等于 | x!=8 为 true
> | 大于 | x>8 为 false
< | 小于 | x<8 为 true
>= | 大于或等于 | x>=8 为 false
<= | 小于或等于 | x<=8 为 true

如何使用

可以在条件语句中使用比较运算符对值进行比较，然后根据结果来采取行动：

if (age<18) document.write("Too young");

您将在本教程的下一节中学习更多有关条件语句的知识。

逻辑运算符

逻辑运算符用于测定变量或值之间的逻辑。

给定 x=6 以及 y=3，下表解释了逻辑运算符：

运算符 | 描述 | 例子
&& | and | (x < 10 && y > 1) 为 true
|| | or | (x==5 || y==5) 为 false
! | not | !(x==y) 为 true

条件运算符

JavaScript 还包含了基于某些条件对变量进行赋值的条件运算符。

语法

variablename=(condition)?value1:value2

例子

greeting=(visitor=="PRES")?"Dear President ":"Dear ";

如果变量 visitor 中的值是 "PRES"，则向变量 greeting 赋值 "Dear President "，否则赋值 "Dear"。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 变量

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 变量

  • Previous Page
  • Next Page

变量是用于存储信息的容器：

x=5; length=66.10;

还记得在学校里学过的代数吗？

当您回忆在学校学过的代数课程时，想到的很可能是：x=5, y=6, z=x+y 等等。

还记得吗，一个字母可以保存一个值（比如 5），并且可以使用上面的信息计算出 z 的值是 11。

您一定没有忘记，对吧。

这些字母称为变量，变量可用于保存值 (x=5) 或表达式 (z=x+y)。

JavaScript 变量

正如代数一样，JavaScript 变量用于保存值或表达式。

可以给变量起一个简短名称，比如 x，或者更有描述性的名称，比如 length。

JavaScript 变量也可以保存文本值，比如 carname="Volvo"。

JavaScript 变量名称的规则：

  • 变量对大小写敏感（y 和 Y 是两个不同的变量）
  • 变量必须以字母或下划线开始

注释：由于 JavaScript 对大小写敏感，变量名也对大小写敏感。

实例

在脚本执行的过程中，可以改变变量的值。可以通过其名称来引用一个变量，以此显示或改变它的值。

本例为您展示原理。

声明（创建） JavaScript 变量

在 JavaScript 中创建变量经常被称为“声明”变量。

您可以通过 var 语句来声明 JavaScript 变量：

var x;
var carname;

在以上声明之后，变量并没有值，不过您可以在声明它们时向变量赋值：

var x=5;
var carname="Volvo";

注释：在为变量赋文本值时，请为该值加引号。

向 JavaScript 变量赋值

通过赋值语句向 JavaScript 变量赋值：

x=5;
carname="Volvo";

变量名在 = 符号的左边，而需要向变量赋的值在 = 的右侧。

在以上语句执行后，变量 x 中保存的值是 5，而 carname 的值是 Volvo。

向未声明的 JavaScript 变量赋值

如果您所赋值的变量还未进行过声明，该变量会自动声明。

这些语句：

x=5;
carname="Volvo";

与这些语句的效果相同：

var x=5;
var carname="Volvo";

重新声明 JavaScript 变量

如果您再次声明了 JavaScript 变量，该变量也不会丢失其原始值。

var x=5;
var x;

在以上语句执行后，变量 x 的值仍然是 5。在重新声明该变量时，x 的值不会被重置或清除。

JavaScript 算术

正如代数一样，您可以使用 JavaScript 变量来做算术：

y=x-5;
z=y+5;

在本教程的下一节中，您将学习能够在 JavaScript 变量间使用的运算符。

  • Previous Page
  • Next Page

课外阅读

JavaScript 高级教程： ECMAScript 语法、 ECMAScript 变量

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 表单验证

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 表单验证

  • Previous Page
  • Next Page

JavaScript 可用来在数据被送往服务器前对 HTML 表单中的这些输入数据进行验证。

JavaScript 表单验证

JavaScript 可用来在数据被送往服务器前对 HTML 表单中的这些输入数据进行验证。

被 JavaScript 验证的这些典型的表单数据有：

  • 用户是否已填写表单中的必填项目？
  • 用户输入的邮件地址是否合法？
  • 用户是否已输入合法的日期？
  • 用户是否在数据域 (numeric field) 中输入了文本？

必填（或必选）项目

下面的函数用来检查用户是否已填写表单中的必填（或必选）项目。假如必填或必选项为空，那么警告框会弹出，并且函数的返回值为 false，否则函数的返回值则为 true（意味着数据没有问题）：

function validate_required(field,alerttxt)
{
with (field)
{
if (value==null||value=="")
  {alert(alerttxt);return false}
else {return true}
}
}

下面是连同 HTML 表单的代码：

<html>
<head>
<script type="text/javascript">

function validate_required(field,alerttxt)
{
with (field)
  {
  if (value==null||value=="")
    {alert(alerttxt);return false}
  else {return true}
  }
}

function validate_form(thisform)
{
with (thisform)
  {
  if (validate_required(email,"Email must be filled out!")==false)
    {email.focus();return false}
  }
}
</script>
</head>

<body>
<form action="submitpage.htm" onsubmit="return validate_form(this)" method="post">
Email: <input type="text" name="email" size="30">
<input type="submit" value="Submit">
</form>
</body>

</html>

E-mail 验证

下面的函数检查输入的数据是否符合电子邮件地址的基本语法。

意思就是说，输入的数据必须包含 @ 符号和点号(.)。同时，@ 不可以是邮件地址的首字符，并且 @ 之后需有至少一个点号：

function validate_email(field,alerttxt)
{
with (field)
{
apos=value.indexOf("@")
dotpos=value.lastIndexOf(".")
if (apos<1||dotpos-apos<2)
  {alert(alerttxt);return false}
else {return true}
}
}

下面是连同 HTML 表单的完整代码：

<html>
<head>
<script type="text/javascript">
function validate_email(field,alerttxt)
{
with (field)
{
apos=value.indexOf("@")
dotpos=value.lastIndexOf(".")
if (apos<1||dotpos-apos<2)
  {alert(alerttxt);return false}
else {return true}
}
}

function validate_form(thisform)
{
with (thisform)
{
if (validate_email(email,"Not a valid e-mail address!")==false)
  {email.focus();return false}
}
}
</script>
</head>

<body>
<form action="submitpage.htm"onsubmit="return validate_form(this);" method="post">
Email: <input type="text" name="email" size="30">
<input type="submit" value="Submit">
</form>
</body>

</html>
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 参考手册

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 参考手册

  • Previous Page
  • Next Page

本节介绍内建的 JavaScript 对象。

请从左侧菜单访问这些 JavaScript 对象详细资料，其中包含它们的方法和属性。

我们还为您提供了所有内建 JavaScript 对象的全局属性和函数，以及 JavaScript 事件参考手册。

您也可以在左侧的菜单找到 HTML DOM 对象的完整列表。

JavaScript String 对象

String 对象用于支持对字符串的处理。

请访问我们的 String 对象参考手册，获得有关可用于 String 对象的属性和方法的完整参考信息。

该手册提供了每种属性和方法的详细描述和代码实例！

JavaScript Date 对象

Date 对象用于操作日期和时间。

请访问我们的 Date 对象参考手册，获得有关可用于 Date 对象的属性和方法的完整参考信息。

该手册提供了每种属性和方法的详细描述和代码实例！

JavaScript Array 对象

JavaScript Array 对象用于在单独的变量名中存储一系列的值。

请访问我们的 Array 对象参考手册，获得有关可用于 Array 对象的属性和方法的完整参考信息。

该手册提供了每种属性和方法的详细描述和代码实例！

JavaScript Boolean 对象

JavaScript Boolean 对象是一个针对逻辑值的对象包装。

请访问我们的 Boolean 对象参考手册，获得有关可用于 Boolean 对象的属性和方法的完整参考信息。

该手册提供了每种属性和方法的详细描述和代码实例！

JavaScript Math 对象

JavaScript Math 对象使我们有能力执行常用的数学任务。它包含了若干个数学常量和函数。

请访问我们的 Math 对象参考手册，获得有关可用于 Math 对象的属性和方法的完整参考信息。

该手册提供了每种属性和方法的详细描述和代码实例！

JavaScript Number 对象

JavaScript Number 对象无法设置具体的数字类型（比如 integer, short, long 或 double）。在 JavaScript 中，所有数字都是由浮点数表示的。JavaScript 采用 IEEE 754 标准定义的 64bit 浮点格式表示数字。这意味着它能表示的最大值是 1.7976931348623157e+308 (正的)，最小值是 5e-324 (负的)。

请访问我们的 JavaScript Number 对象参考手册，获得有关所有 JavaScrip Number 对象的属性和方法的完整参考信息。

该手册提供了每种属性和方法的详细描述和代码实例！

JavaScript RegExp 对象

正则表达式 (regular expression) 是一个描述字符模式的对象。在 JavaScript 中，正则表达式由 RegExp 对象表示。

注释：String 对象和 RegExp 对象都定义了使用正则表达式进行强大的模式匹配和文本检索与替换的函数。

请访问我们的 JavaScript RegExp 对象参考手册，获得有关所有 JavaScrip RegExp 对象的属性和方法的完整参考信息。

该手册提供了每种属性和方法的详细描述和代码实例！

JavaScript 顶层属性和函数

顶层属性和函数（全局属性和函数）可用于所有的JavaScrip内建对象。

请访问我们的 JavaScript 函数参考手册，获得有关所有内建 JavaScrip 对象的属性和函数的完整参考信息。

该手册提供了每种属性和函数的详细描述和代码实例！

JavaScript 事件

HTML 4.0 的新特性之一是有能力使 HTML 事件触发浏览器中的动作（action），比如当用户点击某个 HTML 元素时启动一段 JavaScript。

请访问我们的事件参考手册，获得有关所有事件属性的完整参考信息。

该手册提供了有关每种事件的用法的简要描述和代码实例！

HTML DOM 对象

除了内建的 JavaScript 对象之外，您也可以使用 JavaScript 来访问和处理所有 HTML DOM 对象。

HTML DOM 定义了一套针对 HTML 的标准对象，以及访问和操作 HTML 文档的标准方法。

请访问我们的 HTML DOM 参考手册，获得有关所有 HTML DOM 对象的完整参考信息。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 测验

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 测验

  • Previous Page
  • Next Page

您可以通过 W3SCHOOL 的测验程序来测试您的 JavaScript 技能。

关于本测验

本测验包含 20 道题，每道题的最长答题时间是 20 分钟（这是由于每个 session 的默认有效时间是 20 钟）。

本测验是非官方的测试，它仅仅提供了一个了解您对 JavaScript 的掌握程度的工具。

测验会被记分

每道题的分值是 1 分。在您完成全部的 20 道题之后，系统会为您的测验打分，并提供您做错的题目的正确答案。其中，绿色为正确答案，而红色为错误答案。

现在就开始测验！祝您好运。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 的历史

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 的历史

  • Previous Page
  • Next Page

为了发挥 JavaScript 的全部潜力，了解它的本质、历史及局限性是十分重要的。

本节为您讲解 JavaScript 和客户端脚本的起源。

Nombas 和 ScriptEase

大概在 1992 年，一家称作 Nombas 的公司开发了一种叫做 C 减减（C-minus-minus，简称 Cmm）的嵌入式脚本语言。Cmm 背后的理念很简单：一个足够强大可以替代宏操作（macro）的脚本语言，同时保持与 C （和 C ++）足够的相似性，以便开发人员能很快学会。这个脚本语言捆绑在一个叫做 CEnvi 的共享软件中，它首次向开发人员展示了这种语言的威力。

Nombas 最终把 Cmm 的名字改成了 ScriptEase，原因是后面的部分（mm）听起来过于消极，同时字母 C “令人害怕”。

现在 ScriptEase 已经成为了 Nombas 产品背后的主要驱动力。

Netscape 发明了 JavaScript

当 Netscape Navigator 崭露头角时，Nombas 开发了一个可以嵌入网页中的 CEnvi 的版本。这些早期的试验被成为 Espresso Page（浓咖啡般的页面），它们代表了第一个在万维网上使用的客户端语言。而 Nombas 丝毫没有料到它的理念将会成为万维网的一块重要基石。

当网上冲浪越来越流行时，对于开发客户端脚本的需求也逐渐增大。此时，大部分因特网用户还仅仅通过 28.8 kbit/s 的调制解调器连接到网络，即便这时网页已经不断地变得更大和更复杂。而更加加剧用户痛苦的是，仅仅为了简单的表单有效性验证，就要与服务器进行多次地往返交互。设想一下，用户填完一个表单，点击提交按钮，等待了 30 秒的处理后，看到的却是一条告诉你忘记填写一个必要的字段。

那时正处于技术革新最前沿的 Netscape，开始认真考虑开发一种客户端脚本语言来解决简单的处理问题。

当时工作于 Netscape 的 Brendan Eich，开始着手为即将在 1995 年发行的 Netscape Navigator 2.0 开发一个称之为 LiveScript 的脚本语言，当时的目的是在浏览器和服务器（本来要叫它 LiveWire）端使用它。Netscape 与 Sun 及时完成 LiveScript 实现。

就在 Netscape Navigator 2.0 即将正式发布前，Netscape 将其更名为 JavaScript，目的是为了利用 Java 这个因特网时髦词汇。Netscape 的赌注最终得到回报，JavaScript 从此变成了因特网的必备组件。

三足鼎立

因为 JavaScript 1.0 如此成功，Netscape 在 Netscape Navigator 3.0 中发布了 1.1 版。恰巧那个时候，微软决定进军浏览器，发布了 IE 3.0 并搭载了一个 JavaScript 的克隆版，叫做 JScript（这样命名是为了避免与 Netscape 潜在的许可纠纷）。微软步入 Web 浏览器领域的这重要一步虽然令其声名狼藉，但也成为 JavaScript 语言发展过程中的重要一步。

在微软进入后，有 3 种不同的 JavaScript 版本同时存在：Netscape Navigator 3.0 中的 JavaScript、IE 中的 JScript 以及 CEnvi 中的 ScriptEase。与 C 和其他编程语言不同的是，JavaScript 并没有一个标准来统一其语法或特性，而这 3 中不同的版本恰恰突出了这个问题。随着业界担心的增加，这个语言的标准化显然已经势在必行。

标准化

1997 年，JavaScript 1.1 作为一个草案提交给欧洲计算机制造商协会（ECMA）。第 39 技术委员会（TC39）被委派来“标准化一个通用、跨平台、中立于厂商的脚本语言的语法和语义”(http://www.ecma-international.org/memento/TC39.htm)。由来自 Netscape、Sun、微软、Borland 和其他一些对脚本编程感兴趣的公司的程序员组成的 TC39 锤炼出了 ECMA-262，该标准定义了名为 ECMAScript 的全新脚本语言。

在接下来的几年里，国际标准化组织及国际电工委员会（ISO/IEC）也采纳 ECMAScript 作为标准（ISO/IEC-16262）。从此，Web 浏览器就开始努力（虽然有着不同的程度的成功和失败）将 ECMAScript 作为 JavaScript 实现的基础。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 动画

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 动画

  • Previous Page
  • Next Page

我们可以使用 JavaScript 来创建动态的图像。

实例

按钮动画
利用两个不同的事件来驱动两个相应的函数，来切换两张对应的图片以创造出动画效果。

JavaScript 动画

使用 JavaScript 创建动态图像是可行的。

窍门是：使用 JavaScript 通过不同的事件来切换不同的图像。

在下面的例子中，我们要制作一个充当链接按钮的图像。我们将使用 onMouseOver 事件和 onMouseOut 事件来驱动 JavaScript 函数切换图像。

HTML 代码

这是 HTML 代码：

<a href="http://www.w3school.com.cn" target="_blank">
<img border="0" alt="Visit W3School!"
src="/i/eg_mouse2.jpg" name="b1"
onmouseOver="mouseOver()"
onmouseOut="mouseOut()" />
</a>

注意：我们已为图像添加了 name 属性，这样 JavaScript 就能找到它了。

onMouseOver 事件的作用是告知浏览器：一旦鼠标悬浮于图像之上，浏览器就会执行某个函数，这个函数会把这副图像替换为另一幅。

onMouseOut 事件的作用是告知浏览器：一旦鼠标离开图像，浏览器就要执行另一个函数，这个函数会重新插入原来的那幅图像。

JavaScript 代码

通过下面的代码来切换图像：

<script type="text/javascript">
function mouseOver()
{
document.b1.src ="/i/eg_mouse.jpg"
}
function mouseOut()
{
document.b1.src ="/i/eg_mouse2.jpg"
}
</script>

函数 mouseOver() 将图像切换为 "eg_mouse.jpg"。

函数 mouseOut() 将图像切换为 "eg_mouse2.jpg"。

完整的代码：

<html>
<head>
<script type="text/javascript">
function mouseOver()
  {
  document.b1.src ="/i/eg_mouse.jpg"
  }
function mouseOut()
  {
  document.b1.src ="/i/eg_mouse2.jpg"
  }
</script>
</head>

<body>
<a href="http://www.w3school.com.cn" target="_blank">
<img border="0" alt="Visit W3School!" src="/i/eg_mouse2.jpg" name="b1"
onmouseOver="mouseOver()"
onmouseOut="mouseOut()" />
</a>
</body>
</html>
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 对象简介

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 对象简介

  • Previous Page
  • Next Page

JavaScript 是面向对象的编程语言 (OOP)。

OOP 语言使我们有能力自定义对象和变量类型。

面向对象编程

JavaScript 是面向对象的编程语言 (OOP)。OOP 语言使我们有能力定义自己的对象和变量类型。

别着急，我们会在高级 JavaScript 的部分讲解如何创建自己的对象。现在，我们要开始学习内建的 JavaScript 对象，以及如何使用它们。从下一节开始，我们将具体地依次讲解的这些内建的 JavaScript 对象。

注意：对象只是一种特殊的数据。对象拥有属性和方法。

属性

属性指与对象有关的值。

在下面的例子中，我们使用字符串对象的长度属性来计算字符串中的字符数目。

<script type="text/javascript">

var txt="Hello World!"
document.write(txt.length)

</script>

上面的代码输出为：

12

方法

方法指对象可以执行的行为（或者可以完成的功能）。

在下面的例子中，我们使用字符串对象的 toUpperCase() 方法来显示大写字母文本。

<script type="text/javascript">

var str="Hello world!"
document.write(str.toUpperCase())

</script>

上面的代码输出为：

HELLO WORLD!
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 高级教程

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 高级教程

  • Next Page

JavaScript 是因特网上最流行的脚本语言，它存在于全世界所有 Web 浏览器中，能够增强用户与 Web 站点和 Web 应用程序之间的交互。

本教程是 w3school JavaScript 教程的高级版本。

本教程从 JavaScript 的历史开始讲起，直到当前它对 XML 和 Web 服务的支持。

您将学习到如何扩展该语言，以使它适应特殊的需求。

您还将学到如何使用 JavaScript 创建无缝的客户机 - 服务器通信。

开始学习 JavaScript 高级教程 ！

内容目录

JavaScript 简介

JavaScript 历史
本节为您讲解 JavaScript 和客户端脚本的起源。
JavaScript 实现
完整的 JavaScript 实现是由以下 3 个不同部分组成的：ECMAScript、文档对象模型、浏览器对象模型。

ECMAScript 基础

ECMAScript 语法
Java 和 ECMAScript 有一些关键的语法特性相同，也有一些完全不同。本节详细讲解了 ECMAScript 的语法。
ECMAScript 变量
本节讲解如何声明和命名变量，以及一些著名的变量命名规则。
ECMAScript 关键字
本节提供完整的 ECMAScript 关键字列表。
ECMAScript 保留字
本节提供完整的 ECMAScript 保留字列表。
ECMAScript 值
本节讲解 ECMAScript 的原始值和引用值，以及 ECMAScript 原始类型的概念。
ECMAScript 原始类型
本节详细讲解了 ECMAScript 的 5 种原始类型：Undefined、Null、Boolean、Number 和 String。
ECMAScript 类型转换
本节讲解了 ECMAScript 提供的类型转换方法，以及如何进行强制类型转换。
ECMAScript 引用类型
引用类型通常叫做类（class）或对象。本节讲解 ECMAScript 的预定义引用类型。

ECMAScript 运算符

ECMAScript 一元运算符
一元运算符只有一个参数，即要操作的对象或值。本节讲解 ECMAScript 中最简单的运算符 - 一元运算符。
ECMAScript 位运算符
位运算符是在数字底层进行操作的。本节深入讲解了有关整数的知识，并介绍了 ECMAScript 的各种位运算符。
ECMAScript Boolean 运算符
Boolean 运算符非常重要。本节深入讲解三种 Boolean 运算符：NOT、AND 和 OR。
ECMAScript 乘性运算符
本节讲解 ECMAScript 的乘性运算符：乘法、除法、取模运算符，以及它们的特殊行为。
ECMAScript 加性运算符
本节讲解 ECMAScript 的加性运算符：加法、减法运算符，以及它们的特殊行为。
ECMAScript 关系运算符
关系运算符执行的是比较运算。本节讲解关系运算符的常规比较方式，以及如何比较字符串与数字。
ECMAScript 等性运算符
等性运算符用于判断变量是否相等。ECMAScript 提供两套等性运算符：等号和非等号，以及全等号和非全等号。
ECMAScript 条件运算符
本节讲解 ECMAScript 中的条件运算符。
ECMAScript 赋值运算符
本节讲解 ECMAScript 中的赋值运算符。
ECMAScript 逗号运算符符
本节讲解 ECMAScript 中的逗号运算符。

ECMAScript 语句

ECMAScript if 语句
if 语句是 ECMAScript 中最常用的语句之一。本节为您详细讲解了如何使用 if 语句。
ECMAScript 迭代语句
迭代语句又叫循环语句。本节为您介绍 ECMAScript 提供的四种迭代语句。
ECMAScript 标签语句
本节简要介绍了带有标签的语句。
ECMAScript break 和 continue 语句
本节讲解了break 语句和 continue 语句的不同之处，以及如何与有标签语句一起使用。
ECMAScript with 语句
with 语句用于设置代码在特定对象中的作用域。本节介绍了 with 语句的用法。
ECMAScript switch 语句
switch 语句是 if 语句的兄弟语句。本节介绍了 switch 语句的用法，以及与 Java 中的 switch 语句的不同。

ECMAScript 函数

ECMAScript 函数概述
本节讲解函数的概念，ECMAScript 如何声明并调用函数，以及函数如何返回值。
ECMAScript arguments 对象
本节介绍了此对象的基本用法，然后讲解了如何使用 length 属性来测定函数的参数数目，以及模拟函数重载。
ECMAScript Function 对象（类）
本节讲解了如何使用 Function 类创建函数，然后介绍了 Function 对象的属性和方法。
ECMAScript 闭包（closure）
本节讲解了闭包（closure）的概念，并分别为您展示了简单和稍复杂的两个闭包实例。
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 函数

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 函数

  • Previous Page
  • Next Page

函数是由事件驱动的或者当它被调用时执行的可重复使用的代码块。

实例

函数
如何调用函数。
带有参数的函数
如何向函数传递变量，以及如何在函数中使用该变量。
带有参数的函数 2
如何向函数传递多个变量，以及如何在函数中使用这些变量。
返回值的函数
如何从函数返回值。
带有参数并返回值的函数
如何向函数输入两个参数值，并返回值。

JavaScript 函数

将脚本编写为函数，就可以避免页面载入时执行该脚本。

函数包含着一些代码，这些代码只能被事件激活，或者在函数被调用时才会执行。

你可以在页面中的任何位置调用脚本（如果函数嵌入一个外部的 .js 文件，那么甚至可以从其他的页面中调用）。

函数在页面起始位置定义，即 <head> 部分。

<html>
<head>
<script type="text/javascript">
function displaymessage()
{
alert("Hello World!")
}
</script>
</head>

<body>
<form>
<input type="button" value="Click me!" onclick="displaymessage()" >
</form>
</body>
</html>

假如上面的例子中的 alert("Hello world!!") 没有被写入函数，那么当页面被载入时它就会执行。现在，当用户击中按钮时，脚本才会执行。我们给按钮添加了 onClick 事件，这样按钮被点击时函数才会执行。

在 JS 事件这一章，你会学到更多关于 JavaScript 事件的知识。

如何定义函数

创建函数的语法：

function 函数名(var1,var2,...,varX)
  {
  代码．．．
  }

var1, var2 等指的是传入函数的变量或值。{ 和 } 定义了函数的开始和结束。

注意：无参数的函数必须在其函数名后加括号：

function 函数名()
    {
    代码．．．
    }

注意：别忘记 JavaScript 中大小写字母的重要性。"function" 这个词必须是小写的，否则 JavaScript 就会出错。另外需要注意的是，必须使用大小写完全相同的函数名来调用函数。

return 语句

return 语句用来规定从函数返回的值。

因此，需要返回某个值的函数必须使用这个 return 语句。

例子

下面的函数会返回两个数相乘的值（a 和 b）：

function prod(a,b)
{
x=a*b
return x
}

当您调用上面这个函数时，必须传入两个参数：

product=prod(2,3)

而从 prod() 函数的返回值是 6，这个值会存储在名为 product 的变量中。

JavaScript 变量的生存期

当您在函数内声明了一个变量后，就只能在该函数中访问该变量。当退出该函数后，这个变量会被撤销。这种变量称为本地变量。您可以在不同的函数中使用名称相同的本地变量，这是因为只有声明过变量的函数能够识别其中的每个变量。

如果您在函数之外声明了一个变量，则页面上的所有函数都可以访问该变量。这些变量的生存期从声明它们之后开始，在页面关闭时结束。

  • Previous Page
  • Next Page

课外书

如需更多有关 JavaScript 函数的知识，请阅读 JavaScript 高级教程中的相关内容：

ECMAScript 函数概述
本节讲解函数的概念，ECMAScript 如何声明并调用函数，以及函数如何返回值。
ECMAScript arguments 对象
本节介绍了此对象的基本用法，然后讲解了如何使用 length 属性来测定函数的参数数目，以及模拟函数重载。
ECMAScript Function 对象（类）
本节讲解了如何使用 Function 类创建函数，然后介绍了 Function 对象的属性和方法。
ECMAScript 闭包（closure）
本节讲解了闭包（closure）的概念，并分别为您展示了简单和稍复杂的两个闭包实例。

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 函数参考手册（全局对象）

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 函数参考手册（全局对象）

全局对象是预定义的对象，作为 JavaScript 的全局函数和全局属性的占位符。通过使用全局对象，可以访问所有其他所有预定义的对象、函数和属性。全局对象不是任何对象的属性，所以它没有名称。

全局对象只是一个对象，而不是类。既没有构造函数，也无法实例化一个新的全局对象。

顶层函数（全局函数）

FF: Firefox, N: Netscape, IE: Internet Explorer

函数 | 描述 | FF | N | IE
decodeURI() | 解码某个编码的 URI。 | 1 | 4 | 5.5
decodeURIComponent() | 解码一个编码的 URI 组件。 | 1 | 4 | 5.5
encodeURI() | 把字符串编码为 URI。 | 1 | 4 | 5.5
encodeURIComponent() | 把字符串编码为 URI 组件。 | 1 | 4 | 5.5
escape() | 对字符串进行编码。 | 1 | - | 3
eval() | 计算 JavaScript 字符串，并把它作为脚本代码来执行。 | 1 | 2 | 3
getClass() | 返回一个 JavaObject 的 JavaClass。 |  |  |
isFinite() | 检查某个值是否为有穷大的数。 | 1 | 4 | 4
isNaN() | 检查某个值是否是数字。 | 1 | 2 | 3
parseFloat() | 解析一个字符串并返回一个浮点数。 | 1 | 2 | 3
parseInt() | 解析一个字符串并返回一个整数。 | 1 | 2 | 3
unescape() | 对由 escape() 编码的字符串进行解码。 | 1 | - | 3

顶层属性（全局属性）

FF: Firefox, N: Netscape, IE: Internet Explorer

属性 | 描述 | FF | N | IE
Infinity | 代表正的无穷大的数值。 | 1 | 4 | 4
java | 代表 java.* 包层级的一个 JavaPackage。 |  |  |
NaN | 指示某个值是不是数字值。 | 1 | 4 | 4
Packages | 根 JavaPackage 对象。 |  |  |
undefined | 指示未定义的值。 | 1 | 4 | 5.5

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 计时

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 计时

  • Previous Page
  • Next Page

通过使用 JavaScript，我们有能力做到在一个设定的时间间隔之后来执行代码，而不是在函数被调用后立即执行。我们称之为计时事件。

实例

简单的计时
单击本例中的按钮后，会在 5 秒后弹出一个警告框。
另一个简单的计时
本例中的程序会执行 2 秒、4 秒和 6 秒的计时。
在一个无穷循环中的计时事件
在本例中，单击开始计时按钮后，程序开始从 0 以秒计时。
带有停止按钮的无穷循环中的计时事件
在本例中，点击计数按钮后根据用户输入的数值开始倒计时，点击停止按钮停止计时。
使用计时事件制作的钟表
一个 JavaScript 小时钟

JavaScript 计时事件

通过使用 JavaScript，我们有能力作到在一个设定的时间间隔之后来执行代码，而不是在函数被调用后立即执行。我们称之为计时事件。

在 JavaScritp 中使用计时事件是很容易的，两个关键方法是:

setTimeout()
未来的某时执行代码
clearTimeout()
取消setTimeout()

setTimeout()

语法

var t=setTimeout("javascript语句",毫秒)

setTimeout() 方法会返回某个值。在上面的语句中，值被储存在名为 t 的变量中。假如你希望取消这个 setTimeout()，你可以使用这个变量名来指定它。

setTimeout() 的第一个参数是含有 JavaScript 语句的字符串。这个语句可能诸如 "alert('5 seconds!')"，或者对函数的调用，诸如 alertMsg()"。

第二个参数指示从当前起多少毫秒后执行第一个参数。

提示：1000 毫秒等于一秒。

实例

当下面这个例子中的按钮被点击时，一个提示框会在5秒中后弹出。

<html>
<head>
<script type="text/javascript">
function timedMsg()
 {
 var t=setTimeout("alert('5 seconds!')",5000)
 }
</script>
</head>

<body>
<form>
<input type="button" value="Display timed alertbox!" onClick="timedMsg()">
</form>
</body>
</html>

实例 - 无穷循环

要创建一个运行于无穷循环中的计时器，我们需要编写一个函数来调用其自身。在下面的例子中，当按钮被点击后，输入域便从 0 开始计数。

<html>

<head>
<script type="text/javascript">
var c=0
var t
function timedCount()
 {
 document.getElementById('txt').value=c
 c=c+1
 t=setTimeout("timedCount()",1000)
 }
</script>
</head>

<body>
<form>
<input type="button" value="Start count!" onClick="timedCount()">
<input type="text" id="txt">
</form>
</body>

</html>

clearTimeout()

语法

clearTimeout(setTimeout_variable)

实例

下面的例子和上面的无穷循环的例子相似。唯一的不同是，现在我们添加了一个 "Stop Count!" 按钮来停止这个计数器：

<html>

<head>
<script type="text/javascript">
var c=0
var t

function timedCount()
 {
 document.getElementById('txt').value=c
 c=c+1
 t=setTimeout("timedCount()",1000)
 }

function stopCount()
 {
 clearTimeout(t)
 }
</script>
</head>

<body>
<form>
<input type="button" value="Start count!" onClick="timedCount()">
<input type="text" id="txt">
<input type="button" value="Stop count!" onClick="stopCount()">
</form>
</body>

</html>
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 简介

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 简介

  • Previous Page
  • Next Page

在数百万张页面中，JavaScript 被用来改进设计、验证表单、检测浏览器、创建cookies，等等等等。

JavaScript 是因特网上最流行的脚本语言，并且可在所有主要的浏览器中运行，比方说 Internet Explorer、 Mozilla、Firefox、Netscape、和 Opera。

你应该具备的基础知识：

在继续学习前，你应该对以下知识有基本的了解：

  • HTML
  • XHTML

如果你希望首先学习这些内容，请在 首页 访问相关教程。

什么是 JavaScript？
  • JavaScript 被设计用来向 HTML 页面添加交互行为。
  • JavaScript 是一种脚本语言（脚本语言是一种轻量级的编程语言）。
  • JavaScript 由数行可执行计算机代码组成。
  • JavaScript 通常被直接嵌入 HTML 页面。
  • JavaScript 是一种解释性语言（就是说，代码执行不进行预编译）。
  • 所有的人无需购买许可证均可使用 JavaScript。

Java 和 JavaScript 是相同的吗？

不同！

在概念和设计方面，Java 和 JavaScript 是两种完全不同的语言。

Java（由太阳微系统公司开发）很强大，同时也是更复杂的编程语言，就像同级别的 C 和 C++。

JavaScript 能做什么？

JavaScript 为 HTML 设计师提供了一种编程工具
HTML 创作者往往都不是程序员，但是 JavaScript 却是一种只拥有极其简单的语法的脚本语言！几乎每个人都有能力将短小的代码片断放入他们的 HTML 页面当中。
JavaScript 可以将动态的文本放入 HTML 页面
类似于这样的一段 JavaScript 声明可以将一段可变的文本放入 HTML 页面：document.write("<h1>" + name + "</h1>")
JavaScript 可以对事件作出响应
可以将 JavaScript 设置为当某事件发生时才会被执行，例如页面载入完成或者当用户点击某个 HTML 元素时。
JavaScript 可以读写 HTML 元素
JavaScript 可以读取及改变 HTML 元素的内容。
JavaScript 可被用来验证数据
在数据被提交到服务器之前，JavaScript 可被用来验证这些数据。
JavaScript 可被用来检测访问者的浏览器
JavaScript 可被用来检测访问者的浏览器，并根据所检测到的浏览器，为这个浏览器载入相应的页面。
JavaScript 可被用来创建 cookies
JavaScript 可被用来存储和取回位于访问者的计算机中的信息。

真实的名称是 ECMAScript

JavaScript 的正式名称是 "ECMAScript"。这个标准由 ECMA 组织发展和维护。

ECMA-262 是正式的 JavaScript 标准。这个标准基于 JavaScript (Netscape) 和 JScript (Microsoft)。

Netscape (Navigator 2.0) 的 Brendan Eich 发明了这门语言，从 1996 年开始，已经出现在所有的 Netscape 和 Microsoft 浏览器中。

ECMA-262 的开发始于 1996 年，在 1997 年 7 月，ECMA 会员大会采纳了它的首个版本。

在 1998 年，该标准成为了国际 ISO 标准 (ISO/IEC 16262)。

这个标准仍然处于发展之中。

  • Previous Page
  • Next Page

课外阅读

JavaScript 高级教程： JavaScript 历史 、 JavaScript 实现

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 教程

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 教程

  • Next Page

JavaScript 是属于网络的脚本语言！

JavaScript 被数百万计的网页用来改进设计、验证表单、检测浏览器、创建cookies，以及更多的应用。

JavaScript 是因特网上最流行的脚本语言。

JavaScript 很容易使用！你一定会喜欢它的！

开始学习 JavaScript ！

JavaScript 实例

学习 100 个实例！使用我们的编辑器，你可以编辑源代码，然后单击 TIY 按钮来查看结果。

JavaScript 实例

JavaScript Object 实例

HTML DOM 实例

JavaScript 测试

在 W3School 测试你的 JavaScript 技能！

开始 JavaScript 测验 ！

JavaScript 参考手册

在 W3School，我们为您提供完整的 JavaScript 对象参考手册。

完整的 JavaScript 对象参考手册（包含实例）

完整的 HTML DOM 对象参考手册（包含实例）

JavaScript 课外书

如果您已经把我们的 JavaScript 教程学习完毕，并且需要更深入地学习这门语言，那么 w3school 提供的 《JavaScript 高级教程》绝对是您最好的选择。

本教程从 JavaScript 的历史开始讲起，直到当前它对 XML 和 Web 服务的支持。

您将学习到如何扩展该语言，以使它适应特殊的需求。

您还将学到如何使用 JavaScript 创建无缝的客户机 - 服务器通信。

本教程深入浅出，在您认真学习之后，一定会获益良多。

马上开始学习 JavaScript 高级教程吧 ！

  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 实现

JavaScript 简介

  • JavaScript 高级教程
  • JavaScript 历史
  • JavaScript 实现

ECMAScript 基础

  • ECMAScript 语法
  • ECMAScript 变量
  • ECMAScript 关键字
  • ECMAScript 保留字
  • ECMAScript 值
  • ECMAScript 原始类型
  • ECMAScript 类型转换
  • ECMAScript 引用类型

ECMAScript 运算符

  • 一元运算符
  • 位运算符
  • 逻辑运算符
  • 乘性运算符
  • 加性运算符
  • 关系运算符
  • 等性运算符
  • 条件运算符
  • 赋值运算符
  • 逗号运算符

ECMAScript 语句

  • if 语句
  • 迭代语句
  • 标签语句
  • break 语句
  • continue 语句
  • with 语句
  • switch 语句

ECMAScript 函数

  • 函数概述
  • arguments 对象
  • Function 对象
  • 闭包（closure）

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 实现

  • Previous Page
  • Next Page

JavaScript 的核心 ECMAScript 描述了该语言的语法和基本对象；

DOM 描述了处理网页内容的方法和接口；

BOM 描述了与浏览器进行交互的方法和接口。

ECMAScript、DOM 和 BOM

尽管 ECMAScript 是一个重要的标准，但它并不是 JavaScript 唯一的部分，当然，也不是唯一被标准化的部分。实际上，一个完整的 JavaScript 实现是由以下 3 个不同部分组成的：

  • 核心（ECMAScript）
  • 文档对象模型（DOM）
  • 浏览器对象模型（BOM）
JavaScript 包括 ECMAScript、DOM 和 BOM

ECMAScript

ECMAScript 并不与任何具体浏览器相绑定，实际上，它也没有提到用于任何用户输入输出的方法（这点与 C 这类语言不同，它需要依赖外部的库来完成这类任务）。那么什么才是 ECMAScript 呢？ECMA-262 标准（第 2 段）的描述如下：

“ECMAScript 可以为不同种类的宿主环境提供核心的脚本编程能力，因此核心的脚本语言是与任何特定的宿主环境分开进行规定的... ...”

Web 浏览器对于 ECMAScript 来说是一个宿主环境，但它并不是唯一的宿主环境。事实上，还有不计其数的其他各种环境（例如 Nombas 的 ScriptEase，以及 Macromedia 同时用在 Flash 和 Director MX 中的 ActionScript）可以容纳 ECMAScript 实现。那么 ECMAScript 在浏览器之外规定了些什么呢？

简单地说，ECMAScript 描述了以下内容：

  • 语法
  • 类型
  • 语句
  • 关键字
  • 保留字
  • 运算符
  • 对象

ECMAScript 仅仅是一个描述，定义了脚本语言的所有属性、方法和对象。其他语言可以实现 ECMAScript 来作为功能的基准，JavaScript 就是这样：

每个浏览器都有它自己的 ECMAScript 接口的实现，然后这个实现又被扩展，包含了 DOM 和 BOM（在以下几节中再探讨）。当然还有其他实现并扩展了 ECMAScript 的语言，例如 Windows 脚本宿主（Windows Scripting Host, WSH）、Macromedia 在 Flash 和 Director MX 中的 ActionScript，以及 Nombas ScriptEase。

1. ECMAScript 的版本

ECMAScript 分成几个不同的版本，它是在一个叫做 ECMA-262 的标准中定义的。和其他标准一样，ECMA-262 会被编辑和更新。当有了主要更新时，就会发布一个标准的新版。最新 ECMA-262 的版本是第三版，于 1999 年 12 月发布。

ECMA-262 的第一版在本质上与 Netscape 的 JavaScript 1.1 是一样，只是把所有与浏览器相关的代码删除了，此外还有一些小的调整。首先，ECMA-262 要求对 Unicode 标准的支持（以便支持多语言）。第二，它要求对象是平台无关的（Netscape 的 JavaScript 1.1 事实上有不同的对象实现，例如 Date 对象，是依赖于平台）。这是 JavaScript 1.1 和 1.2 为什么不符合 ECMA-262 规范第一版的主要原因。

ECMA-262 的第二版大部分更新本质上是编辑性的。这次标准的更新是为了与 ISO/IEC-16262 的严格一致，也并没有特别添加、更改和删除内容。ECMAScript 一般不会遵守第二版。

ECMA-262 第三版是该标准第一次真正的更新。它提供了对字符串处理、错误定义和数值输出的更新。同时，它还增加了正则表达式、新的控制语句、try...catch 异常处理的支持，以及一些为使标准国际化而做的小改动。一般来说，它标志着 ECMAScript 成为一种真正的编程语言。

2. 何谓 ECMAScript 符合性

在 ECMA-262 中，ECMAScript 符合性（conformance）有明确的定义。一个脚本语言必须满足以下四项基本原则：

  • 符合的实现必须按照 ECMA-262 中所描述的支持所有的“类型、值、对象、属性、函数和程序语言及语义”（ECMA-262，第一页）
  • 符合的实现必须支持 Unicode 字符标准（UCS）
  • 符合的实现可以增加没有在 ECMA-262 中指定的“额外类型、值、对象、属性和函数”。ECMA-262 将这些增加描述为规范中未给定的新对象或对象的新属性
  • 符合的实现可以支持没有在 ECMA-262 中定义的“程序和正则表达式语法”（意思是可以替换或者扩展内建的正则表达式支持）

所有 ECMAScript 实现必须符合以上标准。

3. Web 浏览器中的 ECMAScript 支持

含有 JavaScript 1.1 的 Netscape Navigator 3.0 在 1996 年发布。然后，JavaScript 1.1 规范被作为一个新标准的草案被提交给 EMCA。有了 JavaScript 轰动性的流行，Netscape 十分高兴地开始开发 1.2 版。但有一个问题，ECMA 并未接受 Netscape 的草案。在 Netscape Navigator 3.0 发布后不久，微软就发布了 IE 3.0。该版本的 IE 含有 JScript 1.0（微软自己的 JavaScript 实现的名称），原本计划可以与 JavaScript 1.1 相提并论。然后，由于文档不全以及一些不当的重复特性，JScript 1.0 远远没有达到 JavaScript 1.1 的水平。

在 ECMA-262 第一版定稿之前，发布含有 JavaScript 1.2 的 Netscape Navigator 4.0 是在 1997 年，在那年晚些时候，ECMA-262 标准被接受并标准化。因此，JavaScript 1.2 并不和 ECMAScript 的第一版兼容，虽然 ECMAScript 应该基于 JavaScript 1.1。

JScript 的下一步是 IE 4.0 中加入的 JScript 3.0（2.0 版是随 IIS 3.0 一起发布的，但并未包含在浏览器中）。微软大力宣传 JScript 3.0 是世界上第一个真正符合 ECMA 标准的脚本语言。而那时，ECMA-262 还没有最终定稿，所以 JScript 3.0 也遭受了和 JavaScript 1.2 同样的命运 - 它还是没能符合最终的 ECMAScript 标准。

Netscape 选择在 Netscape Navigator 4.06 中升级它的 JavaScript 实现。JavaScript 1.3 使 Netscape 终于完全符合了 ECMAScript 第一版。Netscape 加入了对 Unicode 标准的支持，并让所有的对象保留了在 JavaScript 1.2 中引入的新特性的同时实现了平台独立。

当 Netscape 将它的源代码作为 Mozilla 项目公布于众时，本来计划 JavaScript 1.4 将会嵌入到 Netscape Navigator 5.0 中。然而，一个冒进的决定 - 要完全从头重新设计 Netscape 的代码，破坏了这个工作。JavaScript 1.4 仅仅作为一个 Netscape Enterprise Server 的服务器端脚本语言发布，以后也没有被放入浏览器中。

如今，所有主流的 Web 浏览器都遵守 ECMA-262 第三版。

下面的表格列出了大部分流行的 Web 浏览器中的 ECMAScript 支持：

浏览器 | DOM 兼容性
Netscape Navigator 2.0 | -
Netscape Navigator 3.0 | -
Netscape Navigator 4.0 - 4.05 | -
Netscape Navigator 4.06 - 4.79 | Edition 1
Netscape 6.0+ (Mozilla 0.6.0+) | Edition 3
Internet Explorer 3.0 | -
Internet Explorer 4.0 | -
Internet Explorer 5.0 | Edition 1
Internet Explorer 5.5+ | Edition 3
Opera 6.0 - 7.1 | Edition 2
Opera 7.2+ | Edition 3
Safari 1.0+/Konqueror ~ 2.0+ | Edition 3

DOM

DOM（文档对象模型）是 HTML 和 XML 的应用程序接口（API）。DOM 将把整个页面规划成由节点层级构成的文档。HTML 或 XML 页面的每个部分都是一个节点的衍生物。请考虑下面的 HTML 页面：

<html>
  <head>
    <title>Sample Page</title>
  </head>
  <body>
    <p>hello world!</p>
  </body>
</html>

这段代码可以用 DOM 绘制成一个节点层次图：

DOM 通过创建树来表示文档，从而使开发者对文档的内容和结构具有空前的控制力。用 DOM API 可以轻松地删除、添加和替换节点。

1. 为什么 DOM 必不可少

自从 IE 4.0 和 Netscape Navigator 4.0 开始支持不同形态的动态 HTML（DHTML），开发者首次能够在不重载网页的情况下修改它的外观和内容。这是 Web 技术的一大飞跃，不过也带来了巨大的问题。Netscape 和微软各自开发自己的 DHTML，从而结束了 Web 开发者只编写一个 HTML 页面就可以在所有浏览器中访问的时期。

业界决定必须要做点什么以保持 Web 的跨平台特性，他们担心如果放任 Netscape 和微软公司这样做，Web 必将分化为两个独立的部分，每一部分只适用于特定的浏览器。因此，负责指定 Web 通信标准的团体 W3C（World Wide Web Consortium）就开始制定 DOM。

2. DOM 的各个 level

DOM Level 1 是 W3C 于 1998 年 10 月提出的。它由两个模块组成，即 DOM Core 和 DOM HTML。前者提供了基于 XML 的文档的结构图，以便访问和操作文档的任意部分；后者添加了一些 HTML 专用的对象和方法，从而扩展了 DOM Core。

注意，DOM 不是 JavaScript 专有的，事实上许多其他语言都实现了它。不过，Web 浏览器中的 DOM 已经用 ECMAScript 实现了，现在是 JavaScript 语言的一个很大组成部分。

DOM Level 1 只是一个目标，即规划文档的结构，DOM Level 2 的目标就广泛多了。对原始 DOM 的扩展添加了对鼠标和用户界面事件（DHTML 对此有丰富的支持）、范围、遍历（重复执行 DOM 文档的方法）的支持，并通过对象接口添加了对 CSS（层叠样式表）的支持。由 Level 1 引入的原始 DOM Core 也加入了对 XML 命名空间的支持。

DOM Level 2 引入了几种 DOM 新模块，用于处理新的接口类型：

  • DOM 视图 - 描述跟踪文档的各种视图（即 CSS 样式化之前和 CSS 样式化之后的文档）
  • DOM 事件 - 描述事件的接口
  • DOM 样式 - 描述处理基于 CSS 样式的接口
  • DOM 遍历和范围 - 描述遍历和操作文档树的接口

DOM Level 3 引入了以统一的方式载入和保持文档的方法（包含在新模块 DOM Load and Save）以及验证文档（DOM Validation）的方法，从而进一步扩展了 DOM。在 Level 3 中，DOM Core 被扩展为支持所有的 XML 1.0 特性，包括 XML Infoset、XPath 和 XML Base。

在学习 DOM 时，可能会遇到有人引用 DOM Level 0。注意，根本没有 DOM Level 0 这个标准，它只是 DOM 的一个历史参考点（DOM Level 0 指的是 IE 4.0 和 Netscape Navigator 4.0 中支持的原始 DHTML）。

3. 其他 DOM

除了 DOM Core 和 DOM HTML 外，还有其他几种语言发布了自己的 DOM 标准。这些语言都是基于 XML 的，每种 DOM 都给对应语言添加了特有的方法和接口：

  • 可缩放矢量语言（SVG）1.0
  • 数字标记语言（MathML）1.0
  • 同步多媒体集成语言（SMIL）

注释：如果希望学习更多相关内容，请访问 w3school 的 SMIL 教程 和 SVG 教程。

此外，其他语言也开发了自己的 DOM 实现，如 Mozilla 的 XML 用户界面语言（XUL）。不过，只有上面列出的几种语言是 W3C 的推荐标准。

4. Web 浏览器中的 DOM 支持

DOM 在被 Web 浏览器开始实现之前就已经是一种标准了。IE 首次尝试 DOM 是在 5.0 版本中，不过其实直到 5.5 版本之后才具有真正的 DOM 支持，IE 5.5 实现了 DOM Level 1。从那时起，IE 就没有引入新的 DOM 功能。

Netscape 直到 Netscape 6（Mozilla 0.6.0）才引入 DOM 支持。目前，Mozilla 具有最好的 DOM 支持，实现了完整的 Level 1、几乎所有 Level 2 以及一部分 Level 3。（Mozilla 开发小组的目标是构造一个与标准 100% 兼容的浏览器，他们的工作得到了回报。）

Opera 直到 7.0 版本才加入 DOM 支持，还有 Safari 也实现了大部分 DOM Level 1。它们几乎都与 IE 5.5 处于同一水平，有些情况下，甚至超过了 IE 5.5。不过，就对 DOM 的支持而论，所有浏览器都远远落后于 Mozilla。下表列出了常用浏览器对 DOM 的支持。

浏览器 | DOM 兼容性
Netscape Navigator 1.0 - 4.x | -
Netscape 6.0+ (Mozilla 0.6.0+) | Level 1、Level 2、Level 3（部分）
IE 2.0 - 4.x | -
IE 5.0 | Level 1（最小）
IE 5.5+ | Level 1（几乎全部）
Opera 1.0 - 6.0 | -
Opera 7.0+ | Level 1（几乎全部）、Level （部分）
Safari 1.0+/Konqueror ~ 2.0+ | Level 1

注释：如果希望进一步地学习 DOM 的知识，请访问 w3school 的 HTML DOM 教程 和 XML DOM 教程。

BOM

IE 3.0 和 Netscape Navigator 3.0 提供了一种特性 - BOM（浏览器对象模型），可以对浏览器窗口进行访问和操作。使用 BOM，开发者可以移动窗口、改变状态栏中的文本以及执行其他与页面内容不直接相关的动作。使 BOM 独树一帜且又常常令人怀疑的地方在于，它只是 JavaScript 的一个部分，没有任何相关的标准。

BOM 主要处理浏览器窗口和框架，不过通常浏览器特定的 JavaScript 扩展都被看做 BOM 的一部分。这些扩展包括：

  • 弹出新的浏览器窗口
  • 移动、关闭浏览器窗口以及调整窗口大小
  • 提供 Web 浏览器详细信息的定位对象
  • 提供用户屏幕分辨率详细信息的屏幕对象
  • 对 cookie 的支持
  • IE 扩展了 BOM，加入了 ActiveXObject 类，可以通过 JavaScript 实例化 ActiveX 对象

由于没有相关的 BOM 标准，每种浏览器都有自己的 BOM 实现。有一些事实上的标准，如具有一个窗口对象和一个导航对象，不过每种浏览器可以为这些对象或其他对象定义自己的属性和方法。

参阅：

  • Window 对象
  • Navigator 对象
  • Screen 对象
  • History 对象
  • Location 对象
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 事件

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 事件

  • Previous Page
  • Next Page

事件是可以被 JavaScript 侦测到的行为。

事件

JavaScript 使我们有能力创建动态页面。事件是可以被 JavaScript 侦测到的行为。

网页中的每个元素都可以产生某些可以触发 JavaScript 函数的事件。比方说，我们可以在用户点击某按钮时产生一个 onClick 事件来触发某个函数。事件在 HTML 页面中定义。

事件举例：

  • 鼠标点击
  • 页面或图像载入
  • 鼠标悬浮于页面的某个热点之上
  • 在表单中选取输入框
  • 确认表单
  • 键盘按键

注意：事件通常与函数配合使用，当事件发生时函数才会执行。

如果需要更多有关 Javascript 可识别事件的知识，请阅读我们的 JavaScript 事件参考手册。

onload 和 onUnload

当用户进入或离开页面时就会触发 onload 和 onUnload 事件。

onload 事件常用来检测访问者的浏览器类型和版本，然后根据这些信息载入特定版本的网页。

onload 和 onUnload 事件也常被用来处理用户进入或离开页面时所建立的 cookies。例如，当某用户第一次进入页面时，你可以使用消息框来询问用户的姓名。姓名会保存在 cookie 中。当用户再次进入这个页面时，你可以使用另一个消息框来和这个用户打招呼："Welcome John Doe!"。

onFocus, onBlur 和 onChange

onFocus、onBlur 和 onChange 事件通常相互配合用来验证表单。

下面是一个使用 onChange 事件的例子。用户一旦改变了域的内容，checkEmail() 函数就会被调用。

<input type="text" size="30" id="email" onchange="checkEmail()">

onSubmit

onSubmit 用于在提交表单之前验证所有的表单域。

下面是一个使用 onSubmit 事件的例子。当用户单击表单中的确认按钮时，checkForm() 函数就会被调用。假若域的值无效，此次提交就会被取消。checkForm() 函数的返回值是 true 或者 false。如果返回值为true，则提交表单，反之取消提交。

<form method="post" action="xxx.htm" onsubmit="return checkForm()">

onMouseOver 和 onMouseOut

onMouseOver 和 onMouseOut 用来创建“动态的”按钮。

下面是一个使用 onMouseOver 事件的例子。当 onMouseOver 事件被脚本侦测到时，就会弹出一个警告框：

<a href="http://www.w3school.com.cn"
onmouseover="alert('An onMouseOver event');return false">

<img src="w3school.gif" width="100" height="30">

</a>
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 事件参考手册

JS 参考手册

  • JS 对象概述
  • JS Array
  • JS Boolean
  • JS Date
  • JS Math
  • JS Number
  • JS String
  • JS RegExp
  • JS 函数
  • JS 事件

DOM 对象

  • DOM Window
  • DOM Navigator
  • DOM Screen
  • DOM History
  • DOM Location
  • DOM Document
  • DOM Anchor
  • DOM Area
  • DOM Base
  • DOM Body
  • DOM Button
  • DOM Event
  • DOM Form
  • DOM Frame
  • DOM Frameset
  • DOM IFrame
  • DOM Image
  • DOM Input Button
  • DOM Input Checkbox
  • DOM Input File
  • DOM Input Hidden
  • DOM Input Password
  • DOM Input Radio
  • DOM Input Reset
  • DOM Input Submit
  • DOM Input Text
  • DOM Link
  • DOM Meta
  • DOM Object
  • DOM Option
  • DOM Select
  • DOM Style
  • DOM Table
  • DOM TableCell
  • DOM TableRow
  • DOM Textarea

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 事件参考手册

事件通常与函数配合使用，这样就可以通过发生的事件来驱动函数执行。

事件句柄

HTML 4.0 的新特性之一是有能力使 HTML 事件触发浏览器中的动作（action），比如当用户点击某个 HTML 元素时启动一段 JavaScript。下面是一个属性列表，这些属性可插入 HTML 标签来定义事件动作。

FF: Firefox, N: Netscape, IE: Internet Explorer

属性 | 当以下情况发生时，出现此事件 | FF | N | IE
onabort | 图像加载被中断 | 1 | 3 | 4
onblur | 元素失去焦点 | 1 | 2 | 3
onchange | 用户改变域的内容 | 1 | 2 | 3
onclick | 鼠标点击某个对象 | 1 | 2 | 3
ondblclick | 鼠标双击某个对象 | 1 | 4 | 4
onerror | 当加载文档或图像时发生某个错误 | 1 | 3 | 4
onfocus | 元素获得焦点 | 1 | 2 | 3
onkeydown | 某个键盘的键被按下 | 1 | 4 | 3
onkeypress | 某个键盘的键被按下或按住 | 1 | 4 | 3
onkeyup | 某个键盘的键被松开 | 1 | 4 | 3
onload | 某个页面或图像被完成加载 | 1 | 2 | 3
onmousedown | 某个鼠标按键被按下 | 1 | 4 | 4
onmousemove | 鼠标被移动 | 1 | 6 | 3
onmouseout | 鼠标从某元素移开 | 1 | 4 | 4
onmouseover | 鼠标被移到某元素之上 | 1 | 2 | 3
onmouseup | 某个鼠标按键被松开 | 1 | 4 | 4
onreset | 重置按钮被点击 | 1 | 3 | 4
onresize | 窗口或框架被调整尺寸 | 1 | 4 | 4
onselect | 文本被选定 | 1 | 2 | 3
onsubmit | 提交按钮被点击 | 1 | 2 | 3
onunload | 用户退出页面 | 1 | 2 | 3

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 特殊字符

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 特殊字符

  • Previous Page
  • Next Page

你可以在 JavaScript 中使用反斜杠来向文本字符串添加特殊字符。

插入特殊字符

反斜杠用来在文本字符串中插入省略号、换行符、引号和其他特殊字符。

请看下面的 JavaScript 代码：

var txt="We are the so-called "Vikings" from the north."
document.write(txt)

在 JavaScript 中，字符串使用单引号或者双引号来起始或者结束。这意味着上面的字符串将被截为：We are the so-called。

要解决这个问题，就必须把在 "Viking" 中的引号前面加上反斜杠 (\)。这样就可以把每个双引号转换为字面上的字符串。

var txt="We are the so-called \"Vikings\" from the north."
document.write(txt)

现在 JavaScript 就可以输出正确的文本字符串了：We are the so-called "Vikings" from the north。

这是另一个例子：

document.write ("You \& me are singing!")

上面的例子会产生以下输出：

You & me are singing!

下面的表格列出了其余的特殊字符，这些特殊字符都可以使用反斜杠来添加到文本字符串中：

代码 | 输出
\' | 单引号
\" | 双引号
\& | 和号
\\ | 反斜杠
\n | 换行符
\r | 回车符
\t | 制表符
\b | 退格符
\f | 换页符
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 图像地图

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 图像地图

  • Previous Page
  • Next Page

图像地图指的是带有可点击区域的图像。

实例

简单的 HTML 图像映射
本例演示一幅没有添加 JavaScript 的图像映射。
添加了 JavaScript 的图像映射
本例演示一幅添加了 JavaScript 的图像映射，当鼠标浮动于某个热点上时，会调用 JavaScript 函数来显示热点所对应的星球的简介。

JavaScript 图像地图

我们已经从 HTML 教程中了解到，图像地图是带有可点击区域的图像。通常情况下，每个区域是一个相关的超级链接。单击某个区域，就回到达相关的链接。

实例

下面的例子演示如何创建带有可点击区域的 html 图像地图：

<img src ="planets.gif" width ="145" height ="126"
alt="Planets"usemap ="#planetmap" />

<map id ="planetmap" name="planetmap">
<area shape ="rect" coords ="0,0,82,126" href ="sun.htm" target ="_blank"
  alt="Sun" />
<area shape ="circle" coords ="90,58,3" href ="mercur.htm" target ="_blank"
  alt="Mercury" />
<area shape ="circle" coords ="124,58,8" href ="venus.htm" target ="_blank"
  alt="Venus" />
</map>

结果

添加 JavaScript

我们可向图像地图内部的 <area> 标签添加（能调用JavaScript的）事件。<area> 标签支持以下事件：onClick、onDblClick、onMouseDown、onMouseUp、onMouseOver、onMouseMove、onMouseOut、onKeyPress、onKeyDown、onKeyUp、onFocus和onBlur。

这是添加了 JavaScript 的上面的例子：

<html>
<head>
<script type="text/javascript">
function writeText(txt)
{
document.getElementById("desc").innerHTML=txt
}
</script>
</head>

<body>
<img src="planets.gif" width="145" height="126"
alt="Planets" usemap="#planetmap" />

<map id ="planetmap" name="planetmap">
<area shape ="rect" coords ="0,0,82,126"
onMouseOver="writeText('The Sun and the gas giant
planets like Jupiter are by far the largest objects
in our Solar System.')"
href ="sun.htm" target ="_blank" alt="Sun" />

<area shape ="circle" coords ="90,58,3"
onMouseOver="writeText('The planet Mercury is very
difficult to study from the Earth because it is
always so close to the Sun.')"
href ="mercur.htm" target ="_blank" alt="Mercury" />

<area shape ="circle" coords ="124,58,8"
onMouseOver="writeText('Until the 1960s, Venus was
often considered a twin sister to the Earth because
Venus is the nearest planet to us, and because the
two planets seem to share many characteristics.')"
href ="venus.htm" target ="_blank" alt="Venus" />
</map>

<p id="desc"></p>

</body>
</html>
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 消息框

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 消息框

  • Previous Page
  • Next Page

可以在 JavaScript 中创建三种消息框：警告框、确认框、提示框。

实例

警告框
带有折行的警告框
确认框
提示框

警告框

警告框经常用于确保用户可以得到某些信息。

当警告框出现后，用户需要点击确定按钮才能继续进行操作。

语法：

alert("文本")

确认框

确认框用于使用户可以验证或者接受某些信息。

当确认框出现后，用户需要点击确定或者取消按钮才能继续进行操作。

如果用户点击确认，那么返回值为 true。如果用户点击取消，那么返回值为 false。

语法：

confirm("文本")

提示框

提示框经常用于提示用户在进入页面前输入某个值。

当提示框出现后，用户需要输入某个值，然后点击确认或取消按钮才能继续操纵。

如果用户点击确认，那么返回值为输入的值。如果用户点击取消，那么返回值为 null。

语法：

prompt("文本","默认值")
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 语句

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 语句

  • Previous Page
  • Next Page

JavaScript 是由浏览器执行的语句序列。

JavaScript 语句

JavaScript 语句是发给浏览器的命令。这些命令的作用是告诉浏览器要做的事情。

这个 JavaScript 语句告诉浏览器向网页输出 "Hello world"：

document.write("Hello world");

通常要在每行语句的结尾加上一个分号。大多数人都认为这是一个好的编程习惯，而且在 web 上的 JavaScript 案例中也常常会看到这种情况。

分号是可选的（根据 JavaScript 标准），浏览器把行末作为语句的结尾。正因如此，常常会看到一些结尾没有分号的例子。

注释：通过使用分号，可以在一行中写多条语句。

JavaScript 代码

JavaScript 代码是 JavaScript 语句的序列。

浏览器按照编写顺序依次执行每条语句。

本例向网页输出一个标题和两个段落：

<script type="text/javascript">
document.write("<h1>This is a header</h1>");
document.write("<p>This is a paragraph</p>");
document.write("<p>This is another paragraph</p>");
</script>

TIY

JavaScript 代码块

JavaScript 可以分批地组合起来。

代码块以左花括号开始，以右花括号结束。

代码块的作用是一并地执行语句序列。

本例向网页输出一个标题和两个段落：

<script type="text/javascript">
{
document.write("<h1>This is a header</h1>");
document.write("<p>This is a paragraph</p>");
document.write("<p>This is another paragraph</p>");
}
</script>

TIY

上例的用处不大。仅仅演示了代码块的使用而已。通常，代码块用于在函数或条件语句中把若干语句组合起来（比方说如果条件满足，就可以执行这个语句分组了）。

您会在稍后的章节学习到更多有关函数和条件的知识。

  • Previous Page
  • Next Page

课外阅读

JavaScript 高级教程： ECMAScript 语法

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 运算符

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 运算符

  • Previous Page
  • Next Page

运算符 = 用于赋值。

运算符 + 用于加值。

运算符 = 用于给 JavaScript 变量赋值。

算术运算符 + 用于把值加起来。

y=5;
z=2;
x=y+z;

在以上语句执行后，x 的值是 7。

JavaScript 算术运算符

算术运算符用于执行变量与/或值之间的算术运算。

给定 y=5，下面的表格解释了这些算术运算符：

运算符 | 描述 | 例子 | 结果
+ | 加 | x=y+2 | x=7
- | 减 | x=y-2 | x=3
* | 乘 | x=y*2 | x=10
/ | 除 | x=y/2 | x=2.5
% | 求系数 (保留整数) | x=y%2 | x=1
++ | 累加 | x=++y | x=6
-- | 递减 | x=--y | x=4

JavaScript 赋值运算符

赋值运算符用于给 JavaScript 变量赋值。

给定 x=10 和 y=5，下面的表格解释了赋值运算符：

运算符 | 例子 | 等价于 | 结果
= | x=y |  | x=5
+= | x+=y | x=x+y | x=15
-= | x-=y | x=x-y | x=5
*= | x*=y | x=x*y | x=50
/= | x/=y | x=x/y | x=2
%= | x%=y | x=x%y | x=0

用于字符串的 + 运算符

+ 运算符用于把文本值或字符串变量加起来（连接起来）。

如需把两个或多个字符串变量连接起来，请使用 + 运算符。

txt1="What a very";
txt2="nice day";
txt3=txt1+txt2;

在以上语句执行后，变量 txt3 包含的值是 "What a verynice day"。

要想在两个字符串之间增加空格，需要把空格插入一个字符串之中：

txt1="What a very ";
txt2="nice day";
txt3=txt1+txt2;

或者把空格插入表达式中：

txt1="What a very";
txt2="nice day";
txt3=txt1+" "+txt2;

在以上语句执行后，变量 txt3 包含的值是：

"What a very nice day"

对字符串和数字进行加法运算

请看这些例子：

x=5+5;
document.write(x);

x="5"+"5";
document.write(x);

x=5+"5";
document.write(x);

x="5"+5;
document.write(x);

TIY

规则是：

如果把数字与字符串相加，结果将成为字符串。

  • Previous Page
  • Next Page

课外书

如需更多有关 JavaScript 运算符的知识，请阅读 JavaScript 高级教程中的相关内容：

ECMAScript 一元运算符
一元运算符只有一个参数，即要操作的对象或值。本节讲解 ECMAScript 中最简单的运算符 - 一元运算符。
ECMAScript 位运算符
位运算符是在数字底层进行操作的。本节深入讲解了有关整数的知识，并介绍了 ECMAScript 的各种位运算符。
ECMAScript Boolean 运算符
Boolean 运算符非常重要。本节深入讲解三种 Boolean 运算符：NOT、AND 和 OR。
ECMAScript 乘性运算符
本节讲解 ECMAScript 的乘性运算符：乘法、除法、取模运算符，以及它们的特殊行为。
ECMAScript 加性运算符
本节讲解 ECMAScript 的加性运算符：加法、减法运算符，以及它们的特殊行为。
ECMAScript 关系运算符
关系运算符执行的是比较运算。本节讲解关系运算符的常规比较方式，以及如何比较字符串与数字。
ECMAScript 等性运算符
等性运算符用于判断变量是否相等。ECMAScript 提供两套等性运算符：等号和非等号，以及全等号和非全等号。
ECMAScript 条件运算符
本节讲解 ECMAScript 中的条件运算符。
ECMAScript 赋值运算符
本节讲解 ECMAScript 中的赋值运算符。
ECMAScript 逗号运算符符
本节讲解 ECMAScript 中的逗号运算符。

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 指导方针

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 指导方针

  • Previous Page
  • Next Page

本节的内容是：在使用 JavaScript 进行编码的过程中，其他一些需要了解的重要事项。

JavaScript 对大小写敏感

名为 "myfunction" 的函数和名为 "myFunction" 的函数是两个不同的函数，同样，变量 "myVar" 和变量 "myvar" 也是不同的。

JavaScript 对大小写敏感 - 所以当您创建或使用变量、对象及函数时，请注意字符的大小写。

空格

JavaScript 会忽略多余的空格。所以您可以在代码中添加适当的空格，使得代码的可读性更强。下面的两行是等效的：

name="Hege"
name = "Hege"

换行

您可以在文本字符串内部使用反斜杠对代码进行折行。下面的例子是正确的：

document.write("Hello \
World!")

但是不能像这样折行：

document.write \
("Hello World!")
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 注释

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 注释

  • Previous Page
  • Next Page

JavaScript 注释可用于增强代码的可读性。

JavaScript 注释

可以添加注释来对 JavaScript 进行解释，或者提高其可读性。

单行的注释以 // 开始。

本例用单行注释来解释代码：

<script type="text/javascript">
// 这行代码输出标题：
document.write("<h1>This is a header</h1>");
// 这行代码输出段落：
document.write("<p>This is a paragraph</p>");
document.write("<p>This is another paragraph</p>");
</script>

TIY

JavaScript 多行注释

多行注释以 /* 开头，以 */ 结尾。

本例使用多行注释来解释代码：

<script type="text/javascript">
/*
下面的代码将输出
一个标题和两个段落
*/
document.write("<h1>This is a header</h1>");
document.write("<p>This is a paragraph</p>");
document.write("<p>This is another paragraph</p>");
</script>

TIY

使用注释来防止执行

在本例中，我们用注释来阻止一行代码的执行：

<script type="text/javascript">
document.write("<h1>This is a header</h1>");
document.write("<p>This is a paragraph</p>");
//document.write("<p>This is another paragraph</p>");
</script>

TIY

在本例中，我们用注释来阻止若干行代码的执行：

<script type="text/javascript">
/*
document.write("<h1>This is a header</h1>");
document.write("<p>This is a paragraph</p>");
document.write("<p>This is another paragraph</p>");
*/
</script>

TIY

在行末使用注释

在本例中，注释放置在语句的行末：

<script type="text/javascript">
document.write("Hello"); // 输出 "Hello"
document.write("World"); // 输出 "World"
</script>
  • Previous Page
  • Next Page

课外阅读

JavaScript 高级教程： ECMAScript 语法

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 字符串(String)对象

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 字符串(String)对象

  • Previous Page
  • Next Page

String 对象用于处理已有的字符块。

JavaScript String（字符串）对象 实例

计算字符串的长度
如何使用长度属性来计算字符串的长度。
为字符串添加样式
如何为字符串添加样式。
indexOf() 方法
如何使用 indexOf() 来定位字符串中某一个指定的字符首次出现的位置。
match() 方法
如何使用 match() 来查找字符串中特定的字符，并且如果找到的话，则返回这个字符。
如何替换字符串中的字符 - replace()
如何使用 replace() 方法在字符串中用某些字符替换另一些字符。

完整的 String 对象参考手册

请查看我们的 JavaScript String 对象参考手册，其中提供了可以与字符串对象一同使用的所有的属性和方法。

这个手册包含的关于每个属性和方法的用法的详细描述和实例。

字符串对象

字符串对象用于处理已有的字符块。

例子：

下面的例子使用字符串对象的长度属性来计算字符串的长度。

var txt="Hello world!"
document.write(txt.length)

上面的代码输出为：

12

下面的例子使用字符串对象的toUpperCase()方法将字符串转换为大写：

var txt="Hello world!"
document.write(txt.toUpperCase())

上面的代码输出为：

HELLO WORLD!
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


JavaScript 浏览器检测

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 浏览器检测

  • Previous Page
  • Next Page

实例

检测浏览器及版本
使用 JavaScript 检测关于访问者的浏览器名称及其版本。
检测浏览器的更多信息
使用 JavaScript 检测关于访问者浏览器的更多信息。
检测浏览器的全部信息
使用 JavaScript 检测关于访问者浏览器的全部信息。
根据浏览器类型提醒用户
使用 JavaScript 检测关于访问者的浏览器名称及其版本，然后根据这些信息生成不同内容的警告框。

浏览器检测

本教程中几乎所有的代码均可在任何支持 JavaScript 的浏览器中运行。不过个别的代码无法运行于特定的浏览器，特别是老式的浏览器。

所以，有些时候对访问者的浏览器类型及版本进行检测是很有帮助的，然后可在此基础上为访问者提供合适的信息。

要做到这一点，最好的办法是使你的网页变得足够聪明，这样的话它就可以不同的方式对待不同类型的浏览器。

JavaScript 包含一个名为 Navigator 的对象，它就可以完成上述的任务。

Navigator 包含了有关访问者浏览器的信息，包括浏览器类型、版本等等。

Navigator 对象

JavaScript Navigator 对象包含了有关访问者浏览器的所有信息。接下来我们学习 Navigator 对象的两个属性。

appName
保存浏览器类型
appVersion
存有浏览器的版本信息（其他信息中的一项）

实例

<html>

<body>
<script type="text/javascript">
var browser=navigator.appName
var b_version=navigator.appVersion
var version=parseFloat(b_version)

document.write("Browser name: "+ browser)
document.write("<br />")
document.write("Browser version: "+ version)
</script>
</body>

</html>

上面例子中的 browser 变量存有浏览器的名称，比如，"Netscape" 或者 "Microsoft Internet Explorer"。

上面例子中的 appVersion 属性返回的字符串所包含的信息不止是版本号而已，但是现在我们只关注版本号。我们使用一个名为 parseFloat() 的函数会抽取字符串中类似十进制数的一段字符并将之返回，这样我们就可以从字符串中抽出版本号信息了。

重要事项：在 IE 5.0 及以后版本中，版本号是不正确的！在 IE 5.0 和 IE 6.0 中，微软为 appVersion 字符串赋的值是 4.0。怎么会出现这样的错误呢？无论如何，我们需要清楚的是，JavaScript 在 IE6、IE5 和 IE4 中的获得的版本号是相同的。

实例

下面的脚本会根据访问者的浏览器类型显示不同的警告。

<html>

<head>

<script type="text/javascript">
function detectBrowser()
{
var browser=navigator.appName
var b_version=navigator.appVersion
var version=parseFloat(b_version)

if ((browser=="Netscape"||browser=="Microsoft Internet Explorer")
&& (version>=4))
  {alert("Your browser is good enough!")}
else
  {alert("It's time to upgrade your browser!")}
  }
</script>

</head>

<body onload="detectBrowser()">
</body>

</html>
  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


把 JavaScript 放置到何处

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

把 JavaScript 放置到何处

  • Previous Page
  • Next Page

当页面载入时，会执行位于 body 部分的 JavaScript。

当被调用时，位于 head 部分的 JavaScript 才会被执行。

实例

head 部分
包含函数的脚本位于文档的 head 部分。这样我们就可以确保在调用函数前，脚本已经载入了。
body 部分
执行位于 body 部分的脚本。
外部 JavaScript
如何访问外部脚本。

在哪里放置 JavaScript

页面中的脚本会在页面载入浏览器后立即执行。我们并不总希望这样。有时，我们希望当页面载入时执行脚本，而另外的时候，我们则希望当用户触发事件时才执行脚本。

位于 head 部分的脚本：

当脚本被调用时，或者当事件被触发时，脚本就会被执行。当你把脚本放置到 head 部分后，就可以确保在需要使用脚本之前，它已经被载入了。

<html>
<head>
<script type="text/javascript">
....
</script>
</head>
....

位于 body 部分的脚本：

在页面载入时脚本就会被执行。当你把脚本放置于 body 部分后，它就会生成页面的内容。

<html>
<head>
</head>

<body>
<script type="text/javascript">
....
</script>
</body>
</html>

在 body 和 head 部分的脚本：

你可以在文档中放置任何数量的脚本，因此你既可以把脚本放置到 body，又可以放置到 head 部分。

<html>
<head>
<script type="text/javascript">
....
</script>
</head>

<body>
<script type="text/javascript">
....
</script>
</body>
</html>

使用外部 JavaScript

有时，你也许希望在若干个页面中运行 JavaScript，同时不在每个页面中写相同的脚本。

为了达到这个目的，你可以将 JavaScript 写入一个外部文件之中。然后以 .js 为后缀保存这个文件。

注意：外部文件不能包含 <script> 标签。

然后把 .js 文件指定给 <script> 标签中的 "src" 属性，就可以使用这个外部文件了：

<html>
<head>
<script src="xxx.js">....</script>
</head>
<body>
</body>
</html>

提示：您可以把 .js 文件放到网站目录中通常存放脚本的子目录中，这样更容易管理和维护。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


创建你自己的 JavaScript 对象

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

创建你自己的 JavaScript 对象

  • Previous Page
  • Next Page

对象有助于组织信息。

实例

创建对象的实例
本例向您展示如何创建 JavaCript 对象的实例 (instance)。
创建用于对象的模板
本例向您展示如何创建 JavaCript 对象的模板 (template)。

JavaScript 对象

在本教程前面的章节，我们已经学习到 JavaScript 拥有若干内置的对象，比如 String、Date、Array 等等。除了这些对象，你还可以创建自己的对象。

对象仅仅是一种特殊的数据类型而已，并拥有一系列的属性和方法。

让我们用一个例子来理解：一个人就是一个对象。属性是和对象有关的值。人的属性包括其名字、身高、体重、年纪、肤色、眼睛的颜色等等。所有的人都有这些属性，但是每个人的属性的值却各不相同。对象也拥有方法。方法是可施加于对象上的行为。人的方法可能是吃、睡、工作、玩等等。

属性

访问对象的属性的方法：

对象名.属性名

通过简单地向属性赋值，你就可以向对象添加属性。假定存在 personObj 这个对象 － 你可以添加诸如 firstname、lastname、age 以及 eyecolor 等属性。

personObj.firstname="John"
personObj.lastname="Doe"
personObj.age=30
personObj.eyecolor="blue"
document.write(personObj.firstname)

上面的代码生成以下的输出：

John

方法

对象可包含方法。

使用下面的语法来调用方法:

对象名.方法名()

注意：位于括号之间的用于方法的参数是可以省略的。

调用名为 sleep 的 personObj 对象的方法：

personObj.sleep()

创建你自己的对象

有多种不同的办法来创建对象：

1. 创建对象的实例

下列代码创建了一个对象的实例，并向其添加了四个属性：

personObj=new Object()
personObj.firstname="John"
personObj.lastname="Doe"
personObj.age=50
personObj.eyecolor="blue"

向 personObj 添加方法也很简单。下列代码向 personObj 添加了名为 eat() 的方法：

personObj.eat=eat

2. 创建对象的模版

模版定义了对象的结构。

function person(firstname,lastname,age,eyecolor)
{
this.firstname=firstname
this.lastname=lastname
this.age=age
this.eyecolor=eyecolor
}

注意：模版仅仅是一个函数。你需要在函数内部向 this.propertiName 分配内容。

一旦拥有模版，你就可以创建新的实例，就像这样：

myFather=new person("John","Doe",50,"blue")
myMother=new person("Sally","Rally",48,"green")

同样可以向 person 对象添加某些方法。并且同样需要在模版内进行操作：

function person(firstname,lastname,age,eyecolor)
{
this.firstname=firstname
this.lastname=lastname
this.age=age
this.eyecolor=eyecolor
this.newlastname=newlastname
}

注意：方法只是依附于对象的函数而已。然后，我们需要编写 newlastname() 函数：

function newlastname(new_lastname)
{
this.lastname=new_lastname
}

Newlastname() 函数定义 person 的新的 lastname，并将之分配给 person。通过使用 “this.”，JavaScript 即可得知你指的 person 是谁。因此，现在你可以这样写：myMother.newlastname("Doe")。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


如何实现 JavaScript

JavaScript 基础

  • JS 教程
  • JS 简介
  • JS 实现
  • JS 放置
  • JS 语句
  • JS 注释
  • JS 变量
  • JS 运算符
  • JS 比较
  • JS If...Else
  • JS Switch
  • JS 消息框
  • JS 函数
  • JS For Loop
  • JS While Loop
  • JS Break Loops
  • JS For...In
  • JS 事件
  • JS Try...Catch
  • JS Throw
  • JS onerror
  • JS 特殊字符
  • JS 指导方针

JavaScript 对象

  • JS 对象简介
  • JS 字符串
  • JS 日期
  • JS 数组
  • JS 逻辑
  • JS 算数
  • JS RegExp
  • JS HTML DOM

JavaScript 高级

  • JS 浏览器
  • JS Cookies
  • JS 验证
  • JS 动画
  • JS 图像地图
  • JS 计时
  • JS 创建对象
  • JS 总结

实例/测验

  • JS 实例
  • JS 对象实例
  • JS 测验

JS 参考手册

  • JS 对象
  • JS HTML DOM

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

如何实现 JavaScript

  • Previous Page
  • Next Page

HTML 的 <script> 标签用于把 JavaScript 插入 HTML 页面当中。

实例

生成文本
如何在页面中写文本
生成普通文本和标签
如何使用 JavaScript 在页面中写入普通文本和标签。

如何把 JavaScript 放入 HTML 页面

<html>
<body>
<script type="text/javascript">
document.write("Hello World!");
</script>
</body>
</html>

上面的代码会在 HTML 页面中产生这样的输出：

Hello World!

实例解释：

如果需要把一段 JavaScript 插入 HTML 页面，我们需要使用 <script> 标签（同时使用 type 属性来定义脚本语言）。

这样，<script type="text/javascript"> 和 </script> 就可以告诉浏览器 JavaScript 从何处开始，到何处结束。

<html>
<body>
<script type="text/javascript">
...
</script>
</body>
</html>

document.write 字段是标准的 JavaScript 命令，用来向页面写入输出。

把 document.write 命令输入到 <script type="text/javascript">与</script>之间后，浏览器就会把它当作一条 JavaScript 命令来执行。这样浏览器就会向页面写入 "Hello World!"。

<html>
<body>
<script type="text/javascript">
document.write("Hello World!");
</script>
</body>
</html>

TIY

注意：如果我们不使用 <script> 标签，浏览器就会把 document.write("Hello World!") 当作纯文本来处理，也就是说会把这条命令本身写到页面上。

TIY

如何与老的浏览器打交道

那些不支持 JavaScript 的浏览器会把脚本作为页面的内容来显示。为了防止这种情况发生，我们可以使用这样的 HTML 注释标签：

<html>
<body>
<script type="text/javascript">
<!--
document.write("Hello World!");
//-->
</script>
</body>
</html>

注释行末尾的两个正斜杠是 JavaScript 的注释符号，它会阻止 JavaScript 编译器对这一行的编译。

  • Previous Page
  • Next Page

JavaScript 参考手册
JavaScript 实例
JavaScript 测验
w3school 搜索


MIME 参考手册

媒介 基础

  • 媒介首页
  • 媒介简介
  • 音频格式
  • 视频格式
  • 音频播放
  • 视频播放
  • 视窗格式

Object元素

  • Object 简介
  • Object QuickTime
  • Object RealVideo

参考手册

  • 标签参考
  • 播放器参考
  • MIME 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

MIME 参考手册

  • Previous Page
  • Next Page

MIME 类型

MIME (Multipurpose Internet Mail Extensions) 是描述消息内容类型的因特网标准。

MIME 消息能包含文本、图像、音频、视频以及其他应用程序专用的数据。

官方的 MIME 信息是由 Internet Engineering Task Force (IETF) 在下面的文档中提供的：

  • RFC-822 Standard for ARPA Internet text messages
  • RFC-2045 MIME Part 1: Format of Internet Message Bodies
  • RFC-2046 MIME Part 2: Media Types
  • RFC-2047 MIME Part 3: Header Extensions for Non-ASCII Text
  • RFC-2048 MIME Part 4: Registration Procedures
  • RFC-2049 MIME Part 5: Conformance Criteria and Examples

不同的应用程序支持不同的 MIME 类型。

下面的参考手册是由 Microsoft Internet Information Server version 5 所支持的 MIMEI 类型列表。

按照内容类型排列的 Mime 类型列表

类型/子类型 | 扩展名
application/envoy | evy
application/fractals | fif
application/futuresplash | spl
application/hta | hta
application/internet-property-stream | acx
application/mac-binhex40 | hqx
application/msword | doc
application/msword | dot
application/octet-stream | *
application/octet-stream | bin
application/octet-stream | class
application/octet-stream | dms
application/octet-stream | exe
application/octet-stream | lha
application/octet-stream | lzh
application/oda | oda
application/olescript | axs
application/pdf | pdf
application/pics-rules | prf
application/pkcs10 | p10
application/pkix-crl | crl
application/postscript | ai
application/postscript | eps
application/postscript | ps
application/rtf | rtf
application/set-payment-initiation | setpay
application/set-registration-initiation | setreg
application/vnd.ms-excel | xla
application/vnd.ms-excel | xlc
application/vnd.ms-excel | xlm
application/vnd.ms-excel | xls
application/vnd.ms-excel | xlt
application/vnd.ms-excel | xlw
application/vnd.ms-outlook | msg
application/vnd.ms-pkicertstore | sst
application/vnd.ms-pkiseccat | cat
application/vnd.ms-pkistl | stl
application/vnd.ms-powerpoint | pot
application/vnd.ms-powerpoint | pps
application/vnd.ms-powerpoint | ppt
application/vnd.ms-project | mpp
application/vnd.ms-works | wcm
application/vnd.ms-works | wdb
application/vnd.ms-works | wks
application/vnd.ms-works | wps
application/winhlp | hlp
application/x-bcpio | bcpio
application/x-cdf | cdf
application/x-compress | z
application/x-compressed | tgz
application/x-cpio | cpio
application/x-csh | csh
application/x-director | dcr
application/x-director | dir
application/x-director | dxr
application/x-dvi | dvi
application/x-gtar | gtar
application/x-gzip | gz
application/x-hdf | hdf
application/x-internet-signup | ins
application/x-internet-signup | isp
application/x-iphone | iii
application/x-javascript | js
application/x-latex | latex
application/x-msaccess | mdb
application/x-mscardfile | crd
application/x-msclip | clp
application/x-msdownload | dll
application/x-msmediaview | m13
application/x-msmediaview | m14
application/x-msmediaview | mvb
application/x-msmetafile | wmf
application/x-msmoney | mny
application/x-mspublisher | pub
application/x-msschedule | scd
application/x-msterminal | trm
application/x-mswrite | wri
application/x-netcdf | cdf
application/x-netcdf | nc
application/x-perfmon | pma
application/x-perfmon | pmc
application/x-perfmon | pml
application/x-perfmon | pmr
application/x-perfmon | pmw
application/x-pkcs12 | p12
application/x-pkcs12 | pfx
application/x-pkcs7-certificates | p7b
application/x-pkcs7-certificates | spc
application/x-pkcs7-certreqresp | p7r
application/x-pkcs7-mime | p7c
application/x-pkcs7-mime | p7m
application/x-pkcs7-signature | p7s
application/x-sh | sh
application/x-shar | shar
application/x-shockwave-flash | swf
application/x-stuffit | sit
application/x-sv4cpio | sv4cpio
application/x-sv4crc | sv4crc
application/x-tar | tar
application/x-tcl | tcl
application/x-tex | tex
application/x-texinfo | texi
application/x-texinfo | texinfo
application/x-troff | roff
application/x-troff | t
application/x-troff | tr
application/x-troff-man | man
application/x-troff-me | me
application/x-troff-ms | ms
application/x-ustar | ustar
application/x-wais-source | src
application/x-x509-ca-cert | cer
application/x-x509-ca-cert | crt
application/x-x509-ca-cert | der
application/ynd.ms-pkipko | pko
application/zip | zip
audio/basic | au
audio/basic | snd
audio/mid | mid
audio/mid | rmi
audio/mpeg | mp3
audio/x-aiff | aif
audio/x-aiff | aifc
audio/x-aiff | aiff
audio/x-mpegurl | m3u
audio/x-pn-realaudio | ra
audio/x-pn-realaudio | ram
audio/x-wav | wav
image/bmp | bmp
image/cis-cod | cod
image/gif | gif
image/ief | ief
image/jpeg | jpe
image/jpeg | jpeg
image/jpeg | jpg
image/pipeg | jfif
image/svg+xml | svg
image/tiff | tif
image/tiff | tiff
image/x-cmu-raster | ras
image/x-cmx | cmx
image/x-icon | ico
image/x-portable-anymap | pnm
image/x-portable-bitmap | pbm
image/x-portable-graymap | pgm
image/x-portable-pixmap | ppm
image/x-rgb | rgb
image/x-xbitmap | xbm
image/x-xpixmap | xpm
image/x-xwindowdump | xwd
message/rfc822 | mht
message/rfc822 | mhtml
message/rfc822 | nws
text/css | css
text/h323 | 323
text/html | htm
text/html | html
text/html | stm
text/iuls | uls
text/plain | bas
text/plain | c
text/plain | h
text/plain | txt
text/richtext | rtx
text/scriptlet | sct
text/tab-separated-values | tsv
text/webviewhtml | htt
text/x-component | htc
text/x-setext | etx
text/x-vcard | vcf
video/mpeg | mp2
video/mpeg | mpa
video/mpeg | mpe
video/mpeg | mpeg
video/mpeg | mpg
video/mpeg | mpv2
video/quicktime | mov
video/quicktime | qt
video/x-la-asf | lsf
video/x-la-asf | lsx
video/x-ms-asf | asf
video/x-ms-asf | asr
video/x-ms-asf | asx
video/x-msvideo | avi
video/x-sgi-movie | movie
x-world/x-vrml | flr
x-world/x-vrml | vrml
x-world/x-vrml | wrl
x-world/x-vrml | wrz
x-world/x-vrml | xaf
x-world/x-vrml | xof

按照文件扩展名排列的 Mime 类型列表

扩展名 | 类型/子类型
 | application/octet-stream
323 | text/h323
acx | application/internet-property-stream
ai | application/postscript
aif | audio/x-aiff
aifc | audio/x-aiff
aiff | audio/x-aiff
asf | video/x-ms-asf
asr | video/x-ms-asf
asx | video/x-ms-asf
au | audio/basic
avi | video/x-msvideo
axs | application/olescript
bas | text/plain
bcpio | application/x-bcpio
bin | application/octet-stream
bmp | image/bmp
c | text/plain
cat | application/vnd.ms-pkiseccat
cdf | application/x-cdf
cer | application/x-x509-ca-cert
class | application/octet-stream
clp | application/x-msclip
cmx | image/x-cmx
cod | image/cis-cod
cpio | application/x-cpio
crd | application/x-mscardfile
crl | application/pkix-crl
crt | application/x-x509-ca-cert
csh | application/x-csh
css | text/css
dcr | application/x-director
der | application/x-x509-ca-cert
dir | application/x-director
dll | application/x-msdownload
dms | application/octet-stream
doc | application/msword
dot | application/msword
dvi | application/x-dvi
dxr | application/x-director
eps | application/postscript
etx | text/x-setext
evy | application/envoy
exe | application/octet-stream
fif | application/fractals
flr | x-world/x-vrml
gif | image/gif
gtar | application/x-gtar
gz | application/x-gzip
h | text/plain
hdf | application/x-hdf
hlp | application/winhlp
hqx | application/mac-binhex40
hta | application/hta
htc | text/x-component
htm | text/html
html | text/html
htt | text/webviewhtml
ico | image/x-icon
ief | image/ief
iii | application/x-iphone
ins | application/x-internet-signup
isp | application/x-internet-signup
jfif | image/pipeg
jpe | image/jpeg
jpeg | image/jpeg
jpg | image/jpeg
js | application/x-javascript
latex | application/x-latex
lha | application/octet-stream
lsf | video/x-la-asf
lsx | video/x-la-asf
lzh | application/octet-stream
m13 | application/x-msmediaview
m14 | application/x-msmediaview
m3u | audio/x-mpegurl
man | application/x-troff-man
mdb | application/x-msaccess
me | application/x-troff-me
mht | message/rfc822
mhtml | message/rfc822
mid | audio/mid
mny | application/x-msmoney
mov | video/quicktime
movie | video/x-sgi-movie
mp2 | video/mpeg
mp3 | audio/mpeg
mpa | video/mpeg
mpe | video/mpeg
mpeg | video/mpeg
mpg | video/mpeg
mpp | application/vnd.ms-project
mpv2 | video/mpeg
ms | application/x-troff-ms
mvb | application/x-msmediaview
nws | message/rfc822
oda | application/oda
p10 | application/pkcs10
p12 | application/x-pkcs12
p7b | application/x-pkcs7-certificates
p7c | application/x-pkcs7-mime
p7m | application/x-pkcs7-mime
p7r | application/x-pkcs7-certreqresp
p7s | application/x-pkcs7-signature
pbm | image/x-portable-bitmap
pdf | application/pdf
pfx | application/x-pkcs12
pgm | image/x-portable-graymap
pko | application/ynd.ms-pkipko
pma | application/x-perfmon
pmc | application/x-perfmon
pml | application/x-perfmon
pmr | application/x-perfmon
pmw | application/x-perfmon
pnm | image/x-portable-anymap
pot, | application/vnd.ms-powerpoint
ppm | image/x-portable-pixmap
pps | application/vnd.ms-powerpoint
ppt | application/vnd.ms-powerpoint
prf | application/pics-rules
ps | application/postscript
pub | application/x-mspublisher
qt | video/quicktime
ra | audio/x-pn-realaudio
ram | audio/x-pn-realaudio
ras | image/x-cmu-raster
rgb | image/x-rgb
rmi | audio/mid
roff | application/x-troff
rtf | application/rtf
rtx | text/richtext
scd | application/x-msschedule
sct | text/scriptlet
setpay | application/set-payment-initiation
setreg | application/set-registration-initiation
sh | application/x-sh
shar | application/x-shar
sit | application/x-stuffit
snd | audio/basic
spc | application/x-pkcs7-certificates
spl | application/futuresplash
src | application/x-wais-source
sst | application/vnd.ms-pkicertstore
stl | application/vnd.ms-pkistl
stm | text/html
svg | image/svg+xml
sv4cpio | application/x-sv4cpio
sv4crc | application/x-sv4crc
swf | application/x-shockwave-flash
t | application/x-troff
tar | application/x-tar
tcl | application/x-tcl
tex | application/x-tex
texi | application/x-texinfo
texinfo | application/x-texinfo
tgz | application/x-compressed
tif | image/tiff
tiff | image/tiff
tr | application/x-troff
trm | application/x-msterminal
tsv | text/tab-separated-values
txt | text/plain
uls | text/iuls
ustar | application/x-ustar
vcf | text/x-vcard
vrml | x-world/x-vrml
wav | audio/x-wav
wcm | application/vnd.ms-works
wdb | application/vnd.ms-works
wks | application/vnd.ms-works
wmf | application/x-msmetafile
wps | application/vnd.ms-works
wri | application/x-mswrite
wrl | x-world/x-vrml
wrz | x-world/x-vrml
xaf | x-world/x-vrml
xbm | image/x-xbitmap
xla | application/vnd.ms-excel
xlc | application/vnd.ms-excel
xlm | application/vnd.ms-excel
xls | application/vnd.ms-excel
xlt | application/vnd.ms-excel
xlw | application/vnd.ms-excel
xof | x-world/x-vrml
xpm | image/x-xpixmap
xwd | image/x-xwindowdump
z | application/x-compress
zip | application/zip
  • Previous Page
  • Next Page

Web 多媒体元素参考手册


Object 元素

媒介 基础

  • 媒介首页
  • 媒介简介
  • 音频格式
  • 视频格式
  • 音频播放
  • 视频播放
  • 视窗格式

Object元素

  • Object 简介
  • Object QuickTime
  • Object RealVideo

参考手册

  • 标签参考
  • 播放器参考
  • MIME 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Object 元素

  • Previous Page
  • Next Page

<object> 元素可支持多种不同的媒介类型，比如：

  • 图片
  • 音频
  • 视频
  • Other 对象

显示图片

你可以显示一幅图片：

<object height="100%" width="100%"
type="image/jpeg" data="audi.jpeg">
</object>

TIY

显示网页

您可以显示一张网页：

<object type="text/html" height="100%" width="100%"
data="http://www.w3school.com.cn">
</object>

TIY

播放音频

您可以播放音频：

<object
classid="clsid:22D6F312-B0F6-11D0-94AB-0080C74C7E95">
<param name="FileName" value="liar.wav" />
</object>

TIY

播放视频

你可以播放视频：

<object
classid="clsid:22D6F312-B0F6-11D0-94AB-0080C74C7E95">
<param name="FileName" value="3d.wmv" />
</object>

TIY

显示日历

您可以显示日历：

<object width="100%" height="80%"
classid="clsid:8E27C92B-1264-101C-8A2F-040224009C02">
<param name="BackColor" value="14544622">
<param name="DayLength" value="1">
</object>

TIY

显示图形：

你可以显示图形：

<object width="200" height="200"
classid="CLSID:369303C2-D7AC-11D0-89D5-00A0C90833E6">
<param name="Line0001"
value="setFillColor(255, 0, 255)">
<param name="Line0002"
value="Oval(-100, -50, 200, 100, 30)">
</object>

TIY

显示 Flash

您还可以显示 flash 动画：

<object width="400" height="40"
classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
codebase="http://download.macromedia.com
/pub/shockwave/cabs/flash/swflash.cab#4,0,0,0">
<param name="SRC" value="bookmark.swf">
<embed src="bookmark.swf" width="400" height="40"></embed>
</object>

TIY

  • Previous Page
  • Next Page

Web 多媒体元素参考手册


Web 多媒体 简介

媒介 基础

  • 媒介首页
  • 媒介简介
  • 音频格式
  • 视频格式
  • 音频播放
  • 视频播放
  • 视窗格式

Object元素

  • Object 简介
  • Object QuickTime
  • Object RealVideo

参考手册

  • 标签参考
  • 播放器参考
  • MIME 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Web 多媒体 简介

  • Previous Page
  • Next Page

多媒体（Multimedia）指图片、声音、音乐、动画和视频。

现代的 web 浏览器支持多种多媒体格式。

什么是多媒体？

多媒体是我们可以看到和听到的一切：文本、书籍、图片、音乐、声音、CD、视频、DVD、档案、电影等等。

多媒体以多种方式存在。在因特网上，您会发现很多被嵌入网页中的元素，并且今天的 web 浏览器已支持多种多媒体格式。

在本教程中，您会学到不同的多媒体格式，以及如何您的网页中使用它们。

浏览器支持

第一批因特网浏览器仅支持文本，甚至被限制为单一颜色的单一字体。

随后的 web 浏览器支持色彩、字体以及文本样式，并增加了对图像的支持。

不同的浏览器对声音、动画以及视频的处理方式是各不相同的。某些元素被内联处理，某些要求插件，而某些则要求 ActiveX 控件。

您将在下面的章节学到这方面的知识。

多媒体格式

多媒体元素（比如声音或视频）被存储在媒体文件中。

识别媒介类型的最通用的方法是查看文件的扩展名。

当浏览器获知文件的后缀是 .htm 或者 .html，它将假定文件是 HTML 页面。.xml 后缀表示 XML 文件，而 .CSS 后缀表示样式表。

图像格式是通过 .gif 或 .jpeg 后缀来识别的。

多媒体元素同样拥有带有不同后缀的文件格式。

在下面的章节，您将学到更多有关媒体文件后缀的知识。

  • Previous Page
  • Next Page

Web 多媒体元素参考手册


Web 多媒体元素参考手册

媒介 基础

  • 媒介首页
  • 媒介简介
  • 音频格式
  • 视频格式
  • 音频播放
  • 视频播放
  • 视窗格式

Object元素

  • Object 简介
  • Object QuickTime
  • Object RealVideo

参考手册

  • 标签参考
  • 播放器参考
  • MIME 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Web 多媒体元素参考手册

  • Previous Page
  • Next Page

<bgsound> 元素

属性 | 功能
id | A unique id for the element.
src | The location (URL) of the source file.
balance | The balance. (-10000=left, +10000=right).
loop | The number of loops. (-1=infinite).
volume | The volume. (0=max, -10000=min).

<embed> 元素

属性 | 定义
autostart | Automatic start. (true | false).
height | The height of the element in pixels or %.
hidden | The visibility of the element. (true | false).
src | The location (URL) of the source file.
width | The width of the element in pixels or %.

请同时参阅页面底部的样式化属性、通用 HTML 属性以及事件属性：

<applet> 元素

属性 | 定义
alt | An alternate text.
archive | The locations (URLs) of archive files.
code | The location (URL) of the applet code.
codebase | The base location (default URL) for all files.
height | The height of the applet in pixels or %.
name | The name of the applet.
object | A saved representation of the applet. Do not use.
width | The width of the applet in pixels or %.

请同时参阅页面底部的样式化属性、通用 HTML 属性以及事件属性：

<object> 元素

属性 | 定义
archive | The locations (URLs) of archive files.
classid | The location (URL) of the object.
codebase | The base path used to resolve relative URIs specified by the classid, data, and archive attributes.
codetype | The content type of the code.
data | The location (URL) of object data.
declare | Do not instantiate (execute) the object.
height | The height of the object in pixels or %.
name | The object's name.
standby | Text to display while object is loading.
tabindex | The position in the tab order
type | The content type of the object.
usemap | The location (URL) of an image map.
width | The width of the player in pixels or %.

请同时参阅页面底部的样式化属性、通用 HTML 属性以及事件属性：

<param> 元素

param 元素为 object 或 applet 元素定义参数。

属性 | 定义
id | A unique id for the element.
name | Parameter name.
type | Parameter content type.
value | Parameter value.
valuetype | Parameter value type.

样式化属性

注释：这些参数不被赞成使用。请使用样式取而代之。

属性 | 定义
align | The alignment of the object.
border | The border with in pixels.
hspace | The horizontal white-space (margin) in pixels.
vspace | The vertical white-space (margin) in pixels.

通用 HTML 属性

属性 | 定义
class | The element's class.
dir | The directionality of the element.
id | A unique id for the element.
lang | The language used by the element.
style | The element's style.
title | The elements title.

标准事件

事件 | 句柄
onclick | mouse clicked
ondblclick | mouse double clicked
onmousedown | mouse button pressed down
onmouseup | mouse button released
onmouseover | cursor moved onto the element
onmousemove | cursor moved within the element
onmouseout | cursor moved away from the element
onkeypressed | key pressed and released over the element
onkeydown | key pressed down over the element
onkeyup | key released over the element
  • Previous Page
  • Next Page

Web 多媒体元素参考手册


Windows Media Player 参考手册

媒介 基础

  • 媒介首页
  • 媒介简介
  • 音频格式
  • 视频格式
  • 音频播放
  • 视频播放
  • 视窗格式

Object元素

  • Object 简介
  • Object QuickTime
  • Object RealVideo

参考手册

  • 标签参考
  • 播放器参考
  • MIME 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Windows Media Player 参考手册

  • Previous Page
  • Next Page

Windows Media Player

Windows Media Player 存在多个不同的版本。

在此，我们提供了不同版本的 class ID，以及参数列表。

为什么 class ID 会改变？

Windows Media Player 7 及更高版本的 class ID 是：clsid:6BF52A52-394A-11D3-B153-00C04F79FAA6.

因特网上的许多地方把 class ID 声明为：clsid:22D6F312-B0F6-11D0-94AB-0080C74C7E95. 此 class ID 是一个老的版本，但是依然可以工作，这是因为其向后兼容性。但是如果您使用了老的 class ID，就无法使用增加到组件中的新特性了。

Windows Media Player 10

clsid:6BF52A52-394A-11D3-B153-00C04F79FAA6 （与 WMP7 相同）

Windows Media Player 9

clsid:6BF52A52-394A-11D3-B153-00C04F79FAA6 （与 WMP7 相同）

Windows Media Player 7

clsid:6BF52A52-394A-11D3-B153-00C04F79FAA6

Windows Media Player 6.4

clsid:22D6F312-B0F6-11D0-94AB-0080C74C7E95

参数 | 默认值 | 描述
AudioStream | true |
AutoSize | true |
AutoStart | true | Sets if the player should start automatically
AnimationAtStart | true | Sets if an animation should show while the file loads
AllowScan | true |
AllowChangeDisplaySize | true |
AutoRewind | false |
Balance | false |
BaseURL |  |
BufferingTime | 5 |
CaptioningID |  |
ClickToPlay | true | Sets if the player should start when the user clicks in the play area
CursorType | false |
CurrentPosition | true |
CurrentMarker | false |
DefaultFrame |  |
DisplayBackColor | false |
DisplayForeColor | 16777215 |
DisplayMode | false |
DisplaySize | false |
Enabled | true |
EnableContextMenu | true |
EnablePositionControls | true |
EnableFullScreenControls | false |
EnableTracker | true |
Filename | URL | The URL of the file to play
InvokeURLs | true |
Language | true |
Mute | false |
PlayCount | 1 |
PreviewMode | false |
Rate | 1 |
SAMILang |  |
SAMIStyle |  |
SAMIFileName |  |
SelectionStart | true |
SelectionEnd | true |
SendOpenStateChangeEvents | true |
SendWarningEvents | true |
SendErrorEvents | true |
SendKeyboardEvents | false |
SendMouseClickEvents | false |
SendMouseMoveEvents | false |
SendPlayStateChangeEvents | true |
ShowCaptioning | false |
ShowControls | true | Sets if the player controls should show
ShowAudioControls | true | Sets if the audio controls should show
ShowDisplay | false | Sets if the display should show
ShowGotoBar | false | Sets if the GotoBar should show
ShowPositionControls | true |
ShowStatusBar | false |
ShowTracker | true |
TransparantAtStart | false |
VideoBorderWidth | false |
VideoBorderColor | false |
VideoBorder3D | false |
Volume | -200 |
WindowlessVideo | false |

Windows Media Player 6 （更老的版本）

clsid:05589FA1-C356-11CE-BF01-00AA0055595A

参数 | 默认值 | 描述
Appearance | false |
AutoStart | false |
AllowChangeDisplayMode | true |
AllowHideDisplay | false |
AllowHideControls | true |
AutoRewind | true |
Balance | false |
CurrentPosition | false |
DisplayBackColor | false |
DisplayForeColor | 16777215 |
DisplayMode | false |
Enabled | true |
EnableContextMenu | true |
EnablePositionControls | true |
EnableSelectionControls | false |
EnableTracker | true |
Filename |  |
FullScreenMode | false |
MovieWindowSize | false |
PlayCount | 1 |
Rate | 1 |
SelectionStart | true |
SelectionEnd | true |
ShowControls | true |
ShowDisplay | true |
ShowPositionControls | false |
ShowTracker | true |
Volume | -200 |
  • Previous Page
  • Next Page

Web 多媒体元素参考手册


Windows 多媒体格式

媒介 基础

  • 媒介首页
  • 媒介简介
  • 音频格式
  • 视频格式
  • 音频播放
  • 视频播放
  • 视窗格式

Object元素

  • Object 简介
  • Object QuickTime
  • Object RealVideo

参考手册

  • 标签参考
  • 播放器参考
  • MIME 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Windows 多媒体格式

  • Previous Page
  • Next Page

Windows 媒介文件拥有这些后缀：.asf、.asx、.wma, 以及 .wmv。

ASF 格式

ASF 格式 (Advanced Streaming Format) 是专门为在因特网上运行而设计的。

ASF 文件包含音频、视频、幻灯片展示以及同步事件。

ASF 文件能够被深度压缩，同时能够以连续的数据流进行传输（在线电视和广播）。该格式的文件可以是任何大小，同时能够被压缩以适应不同的带宽（连接速度）。

ASX 格式

ASX (Advanced Stream Redirector) 文件并非媒介文件，而是元数据文件。

元数据文件提供有关文件的信息。ASX 文件是用于描述多媒体内容的纯文本文件：

<ASX VERSION="3.0">
<Title>Holiday 2001</Title>
<Entry>
    <ref href="holiday-1.avi"/>
</Entry>
<Entry>
    <ref href="holiday-2.avi"/>
</Entry>
<Entry>
    <ref href="holiday-2.avi"/>
</Entry>
</ASX>

上面的文件描述了三个多媒体文件。当 ASX 文件被播放器读取时，播放器可播放被描述的文件。

WMA 格式

WMA (Windows Media Audio) 格式是由微软开发的音频格式。

WMA 的设计目标是处理各种类型的音频内容。该格式的文件能够被深度压缩，且能够传输连续的数据流（在线广播）。WMA 文件可以是任何大小，同时能够被压缩以适应不同的带宽（连接速度）。

WMA 格式与 ASF 格式类似。（请参阅上面的内容）。

WMV 格式

WMV (Windows Media Video) 格式是由微软开发的一种视频格式。

WMV 的设计目标是处理各种类型的视频内容。该格式的文件能够被深度压缩，且能够传输连续的数据流（在线广播）。WMA 文件可以是任何大小，同时能够被压缩以适应不同的带宽（连接速度）。

WMV 格式与 ASF 格式类似。（请参阅上面的内容）。

其他 Windows Media 格式

WAX (Windows Media Audio Redirector) 文件与 ASX 文件非常相似，不过旨在描述音频文件（.wma 文件）。

WMP (Windows Media Player) 文件和 WMX 是微软供未来使用的预留文件类型。

  • Previous Page
  • Next Page

Web 多媒体元素参考手册


播放 QuickTime 影片

媒介 基础

  • 媒介首页
  • 媒介简介
  • 音频格式
  • 视频格式
  • 音频播放
  • 视频播放
  • 视窗格式

Object元素

  • Object 简介
  • Object QuickTime
  • Object RealVideo

参考手册

  • 标签参考
  • 播放器参考
  • MIME 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

播放 QuickTime 影片

  • Previous Page
  • Next Page

<object> 元素可播放 QuickTime 电影。

QuickTime 格式

QuickTime 格式由 Apple 开发。以 QuickTime 格式存储的视频的扩展名是 .mov。

在因特网上，QuickTime 是一种普遍的格式，但是如果没有额外的组件（免费），QuickTime 电影无法在非 Windows 的计算机上播放。

通过 object 元素，可轻松将播放 QuickTime 影片的代码添加到网页中。如果用户计算机中未安装 QuickTime 播放器，则可将 object 设置为自动安装 QuickTime 播放器。

解决方案

这些播放 QuickTime 影片的代码：

<object width="160" height="144"
classid="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B"
codebase="http://www.apple.com/qtactivex/qtplugin.cab">
<param name="src" value="sample.mov">
<param name="autoplay" value="true">
<param name="controller" value="false">

<embed src="sample.mov" width="160" height="144"
autoplay="true" controller="false"
pluginspage="http://www.apple.com/quicktime/download/">
</embed>

</object>

<object> 元素

object 元素的 width 和 height 属性应当匹配影片的尺寸（以像素计）。

classid 可唯一地标识要使用的播放器软件。它必须设置为 "clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B"。该唯一编码标识了在电影播放之前必须安装在用户 PC 上的 ActiveX 控件。如果用户未安装该 ActiveX 控件，则浏览器将自动下载并安装它。

codebase 属性规定了基准路径，该路径用于解析由 classid、data 和 archive 属性规定的相对 URL。如果未规定，则其默认值是当前文档的基准 URL。注释：Internet Explorer 使用该属性来规定播放器的下载位置。该属性必须被设置为 "http://www.apple.com/qtactivex/qtplugin.cab"。此位置包含 QuickTime 播放器的最新版本。

src 参数指向电影文件。

如果您希望电影自动播放的话，请将 autoplay 参数设置为 "true"。

如果您不希望显示控制按钮，请将 controller 参数设置为 "false"。

<embed> 元素

可以添加 embed 元素，来支持那些不支持 object 元素的浏览器。可理解 object 元素的浏览器将忽略 embed 元素。那些支持 ActiveX 控件的新浏览器（Internet Explorer 5、6、7）将使用 object 元素，而其他较老的浏览器 (Netscape 4 and 5) 将使用 embed 元素。

embed 元素的 width 和 height 属性应当匹配影片的尺寸（以像素计）。

embed 元素的 autoplay 和 controller 属性应设置为与 object 元素的相关属性相同的值。

pluginspage 属性定义了播放器的下载路径，必须被设置为 "http://www.apple.com/quicktime/download/"。

  • Previous Page
  • Next Page

Web 多媒体元素参考手册


播放 Real Video 影片

媒介 基础

  • 媒介首页
  • 媒介简介
  • 音频格式
  • 视频格式
  • 音频播放
  • 视频播放
  • 视窗格式

Object元素

  • Object 简介
  • Object QuickTime
  • Object RealVideo

参考手册

  • 标签参考
  • 播放器参考
  • MIME 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

播放 Real Video 影片

  • Previous Page
  • Next Page

<object> 元素能够播放 Real Video 影片。

Real Video 格式

RealVideo 格式由 Real Media 开发。以 Real Video 格式存储的视频，其扩展名是 .rm 或 .ram。

该格式允许低带宽下的视频流（在线视频、因特网电视）。由于其低带宽优先权，往往会削弱视频质量。

解决方案

这是播放 Real Video 影片所需的代码：

<object width="320" height="240"
classid="clsid:CFCDAA03-8BE4-11cf-B84B-0020AFBBCCFA">
<param name="controls" value="ImageWindow" />
<param name="autostart" value="true" />
<param name="src" value="male.ram" />
</object>

<object> 元素

object 元素的 width 和 height 属性应当匹配影片的尺寸（以像素计）。

classid 可唯一地标识要使用的播放器软件。它必须设置为 "clsid:CFCDAA03-8BE4-11cf-B84B-0020AFBBCCFA"。该唯一编码标识了在电影播放之前必须安装在用户 PC 上的 ActiveX 控件。如果用户未安装该 ActiveX 控件，则浏览器将自动下载并安装它。

param 元素为播放器提供附加信息。

src 参数指向电影文件。

如果您希望电影自动播放的话，请将 autostart 参数设置为 "true"。

如果您不希望显示控制按钮，请将 controls 参数设置为 "ImageWindow"，如果希望显示所有控制按钮，请将该参数设置为 "All"。

Object 参考

属性 | 定义
classid | 对象的唯一 id。
height | 对象的高度。以像素或百分比计。
width | 对象的宽度。以像素或百分比计。

Parameter 参考

属性 | 定义
src | RealAudio 或 RealVideo 片断的源。
controls | 控件的可见性。（请参阅下文）。
console | 链接多个控件的控制台名称。
autostart | 自动播放。 (true | false).
nolabels | 禁止控件窗口的 label 文本。
reset | 重置播放列表控件 (true | false).
autogotoURL | 如何处理 URL。(true | false)
True | 指向浏览器的向前 URL 事件。
False | 使用 VBScript 代之。

控件的值

值 | 显示
All | 显示带有所有控件的完整播放器。
InfoVolumePanel | 标题、作者、版权以及音量滑块。
InfoPanel | 标题、作者以及版权。
ControlPanel | 位置滑块、播放、暂停以及停止按钮。
StatusPanel | 消息、当前时间位置以及片断长度。
PlayButton | 播放和暂停按钮。
StopButton | 停止按钮。
VolumeSlider | 音量滑块。
PositionField | 位置和片断长度。
StatusField | 消息。
ImageWindow | 视频图像。
StatusBar | 状态、位置和频道。
  • Previous Page
  • Next Page

Web 多媒体元素参考手册


多媒体 视频格式

媒介 基础

  • 媒介首页
  • 媒介简介
  • 音频格式
  • 视频格式
  • 音频播放
  • 视频播放
  • 视窗格式

Object元素

  • Object 简介
  • Object QuickTime
  • Object RealVideo

参考手册

  • 标签参考
  • 播放器参考
  • MIME 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

多媒体 视频格式

  • Previous Page
  • Next Page

视频可通过多种格式进行存储。

AVI 格式

AVI 格式 (Audio Video Interleave) 由微软开发。

AVI 格式得到了所有运行 Windows 的计算机的支持，以及绝大多数最流行的浏览器。在因特网上，它是非常普遍的一种格式，但是并不总能在非 Windows 的计算机上播放。

以 AVI 格式存储的视频，其扩展名是 .avi

Windows 媒介格式

Windows Media 格式由微软开发。

在因特网上，Windows Media 是非常普遍的一种格式，但是如果不安装一个额外的组件（免费），Windows Media 格式的影片无法在在非 Windows 的计算机上播放。由于没有可用的的播放器，某些后来的 Windows Media 影片在所有非 Windows 的计算机上都无法播放。

以 Windows Media 格式存储的视频，其扩展名是 .wmv。

MPEG 格式

MPEG (Moving Pictures Expert Group) 格式是因特网上最流行的格式。它是跨平台的，且得到了所有最流行的浏览器的支持。

以 MPEG 格式储存的视频，其扩展名是 .mpg 或 .mpeg。

QuickTime 格式

QuickTime 格式由 Apple 开发。

在因特网上 QuickTime 是一种普遍的格式，但是如果不安装额外的组件，QuickTime 格式的影片无法在 Windows 计算机上播放。

以 QuickTime 格式存储的视频，其后缀是 .mov。

RealVideo 格式

RealAudio 格式由 Real Media 针对因特网开发。

此格式运行低带宽下的视频流（在线视频、因特网电视）。由于其低带宽的优先级，视频质量往往会被削弱。

以 RealVideo 格式存储的视频，其后缀是 .rm 或 .ram。

Shockwave (Flash) 格式

Shockwave 格式由 Macromedia 开发。

Shockwave 格式需要额外的组件才能播放。该组件在最新版本的 Netscape 和 Internet Explorer 中是预安装的。

以 Shockwave 格式存储的视频，其扩展名是 .swf。

  • Previous Page
  • Next Page

Web 多媒体元素参考手册


多媒体 音频格式

媒介 基础

  • 媒介首页
  • 媒介简介
  • 音频格式
  • 视频格式
  • 音频播放
  • 视频播放
  • 视窗格式

Object元素

  • Object 简介
  • Object QuickTime
  • Object RealVideo

参考手册

  • 标签参考
  • 播放器参考
  • MIME 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

多媒体 音频格式

  • Previous Page
  • Next Page

声音可通过多种格式进行存储。

MIDI 格式

MIDI 是一种在电子音乐设备（比如合成器与 PC 声卡）之间传送音乐信息的格式。

MIDI 格式由音乐行业在 1982 年发明。MIDI 格式的伸缩性很强，可用于从极其简单的到非常专业的各种音乐制作。

MIDI 文件不包含被采样的声音，而是一系列可被 PC 的声卡解释的数字音乐指令（音符）。

MIDI 的劣势是它无法记录声音（仅能记录音符）。或者换句话说：它不能存储歌曲，仅能存储曲调。

点击这里演奏 The Beatles。

MIDI 格式的优势是，由于它只包含指令（音符），MIDI 文件可以非常之小。上面的例子仅有 23K，但是却可以演奏将近 5 分钟。

MIDI 格式得到了大范围的平台上许多不同的软件系统的支持。MIDI 文件也得到了所有最流行的因特网浏览器的支持。

以 MIDI 格式存储的音频的格式是 .mid 或 .midi。

RealAudio 格式

RealAudio 格式由 Real Media 针对因特网开发。此格式也支持视频。

此格式允许低带宽下的音频流（在线音乐、因特网广播）。由于低带宽的优先级，其品质往往被削弱。

以 RealAudio 格式存储的音频，其扩展名是 .rm 或 .ram。

AU 格式

AU 格式得到了大范围的平台上许多不同的软件系统的支持。

以 AU 格式存储的音频，其扩展名是 .au。

AIFF 格式

AIFF 格式 (Audio Interchange File Format) 是由 Apple 开发的。

AIFF 不是跨平台的，也不被所有的 web 浏览器支持。

以 AIFF 格式存储的音频，其扩展名是 aif 或 .aiff。

SND 格式

SND (Sound) 由 Apple 开发。

SND 不是跨平台的，也不被所有的 web 浏览器支持。

以 SND 格式存储的音频，其扩展名是 .snd。

WAVE 格式

WAVE (waveform) 格式由 IBM 和 Microsoft 开发。

它得到了所有运行 Windows 以及几乎所有最流行的 web 浏览器的支持。

以 WAVE 格式存储的音频，其扩展名是 .wav。

MP3 格式 (MPEG)

MP3 文件实际上是 MPEG 文件。但是起初，MPEG 格式是由运动图像专家组（Moving Pictures Experts Group）针对视频进行开发的。我们可以这么说，MP3 文件是 MPEG 视频格式的组成部分。

MP3 是音乐记录方面最流行的音频格式之一。MP3 编码系统结合了高压缩（小巧的文件）和高品质的优点。期望未来所有的系统都支持它。

以 MP3 格式存储的音频，其后缀是 .mp3, 或 .mpga（针对 MPG Audio）。

使用哪种格式？

在因特网上，WAVE 格式是最流行的格式之一，且得到了所有流行的浏览器的支持。如果您希望所录制的声音可用于所有的访问者，就应该使用 WAVE 格式。

MP3 格式则是一种新近来临的音频格式。如果您的网站与音乐有关，MP3 格式应该也是不错的选择。

  • Previous Page
  • Next Page

Web 多媒体元素参考手册


网络多媒体 教程

媒介 基础

  • 媒介首页
  • 媒介简介
  • 音频格式
  • 视频格式
  • 音频播放
  • 视频播放
  • 视窗格式

Object元素

  • Object 简介
  • Object QuickTime
  • Object RealVideo

参考手册

  • 标签参考
  • 播放器参考
  • MIME 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

网络多媒体 教程

  • Next Page

在本教程中，您将学到如何向网页添加多媒体内容（音频和视频）。

开始学习！

内容目录

多媒体简介
本章讲解多媒体的概念，以及 Web 浏览器如何处理多媒体。
音频格式
本章讲解最常见或者最流行的音频格式。
视频格式
本章讲解最常见或者最流行的视频格式。
浏览器音频
本章讲解如何在网页中播放音频。
浏览器视频
本章讲解如何在网页中播放视频。
视窗媒体格式
本章讲解新的 Windows 媒体格式（Windows Media format）。
object 简介
本章讲解 object 元素。
QuickTime 对象
本章讲解如何使用 object 元素播放 QuickTime 电影。
RealMedia 对象
本章讲解如何使用 object 元素播放 Real 音频和 Real 视频。
标签参考
HTML 的多媒体标签参考。
播放器参考
Windows 媒体播放器参考（Windows Media Player）。
MIME 参考
多用途网际邮件扩充（MIME）的参考手册。
  • Next Page

Web 多媒体元素参考手册


在 Web 上播放视频

媒介 基础

  • 媒介首页
  • 媒介简介
  • 音频格式
  • 视频格式
  • 音频播放
  • 视频播放
  • 视窗格式

Object元素

  • Object 简介
  • Object QuickTime
  • Object RealVideo

参考手册

  • 标签参考
  • 播放器参考
  • MIME 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

在 Web 上播放视频

  • Previous Page
  • Next Page

根据您所使用的 HTML 元素，视频可“内联地”或通过某种“助手”进行播放。

内联视频（Inline Videos）

当视频被包含在网页中，或作为网页的一部份，它就被称为内联视频。

通过使用 <img> 元素，可向网页添加内联视频。

如果你计划在 web 应用程序中使用内联视频，您需要清楚一点，就是许多人对内联视频非常讨厌。也请注意，一些用户也许已经在他们的浏览器中关闭了内联视频的选项。

我们的建议是，最近仅仅在用户希望听到声音的地方包含内联视频。比方说在用户打开页面后，点击某个链接来观看视频。

使用助手（Plug-In，插件）

助手应用程序，是一种可通过浏览器启动来“帮助”浏览器播放视频的程序。助手应用程序也称为插件（Plug-Ins）。

助手应用程序可通过使用 <embed> 元素来启动，或者 <applet> 元素及 <object> 元素。

使用助手应用程序的一项巨大优势是，允许用户控制播放器的某些设置。

大多数助手应用程序允许手动地或通过编程控制音量设置以及播放功能，比如回放、暂停、停止和播放。

使用 <img> 元素

Internet Explorer 支持 <img> 元素中的 dynsrc 属性。

该元素的作用是在网页中嵌入多媒体元素：

<img dynsrc="video.avi" />

上面的代码片断为网页设置了一个嵌入的 AVI 文件。

注释：dynsrc 属性不是标准的 HTML 或 XHTML 元素。仅有 Internet Explorer 支持该属性。

使用 <embed> 元素

Internet Explorer 和 Netscape 都支持 <embed> 元素。

该元素的作用是在网页中嵌入多媒体元素：

<embed src="video.avi" />

上面的代码片断为网页设置了一个嵌入的 AVI 文件。

您可在本教程的最后一节找到 <embed> 元素的属性列表。

注释：Internet Explorer 和 Netscape 都支持 <embed> 元素，但它不是标准的 HTML 或 XHTML 元素。万维网联盟 (W3C) 推荐使用 <object> 元素来代替它。

使用 <object> 元素

Internet Explorer 和 Netscape 都支持 <object> 元素。

该元素的作用是在网页中嵌入多媒体元素：

<object data="video.avi" type="video/avi" />

上面的代码片断在网页设置了一个嵌入的的 AVI 文件。

您可在本教程的最后一节找到 <object> 元素的属性列表。

使用超链接

如果网页包含了一个指向某个媒介文件的超链接，大多数浏览器都会使用“助手程序”来播放该文件：

<a href="video.avi">点击此处来播放视频文件</a>

上面的代码片段设置了一个指向 AVI 文件的链接。如果用户点击该链接，浏览器将启动助手程序（比如 Windows Media Player）来播放该 AVI 文件。

  • Previous Page
  • Next Page

Web 多媒体元素参考手册


在 Web 上播放音频

媒介 基础

  • 媒介首页
  • 媒介简介
  • 音频格式
  • 视频格式
  • 音频播放
  • 视频播放
  • 视窗格式

Object元素

  • Object 简介
  • Object QuickTime
  • Object RealVideo

参考手册

  • 标签参考
  • 播放器参考
  • MIME 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

在 Web 上播放音频

  • Previous Page
  • Next Page

根据您所使用的 HTML 元素，音频可“内联地”或通过某种“助手”进行播放。

内联音频

当音频被包含在网页中，或作为网页的一部份，它就被称为内联音频。

通过使用 <bgsound> 元素或 <img> 元素，可向网页添加内联音频。

如果你计划在 web 应用程序中使用内联音频，您需要清楚一点，就是许多人对内联音频非常讨厌。也请注意，一些用户也许已经在他们的浏览器中关闭了内联音频的选项。

我们的建议是，最近仅仅在用户希望听到声音的地方包含内联音频。比方说在用户打开页面后，点击某个链接来收听一段录音。

使用助手 （Plug-In，插件）

助手应用程序，是一种可通过浏览器启动来“帮助”浏览器播放音频的程序。助手应用程序也称为插件（Plug-Ins）。

助手应用程序可通过使用 <embed> 元素来启动，或者 <applet> 元素及 <object> 元素。

使用助手应用程序的一项巨大优势是，允许用户控制播放器的某些设置。

大多数助手应用程序允许手动地或通过编程控制音量设置以及播放功能，比如回放、暂停、停止和播放。

使用 <bgsound> 元素

Internet Explorer 支持 <bgsound> 元素。

该元素的作用是为网页提供背景音：

<bgsound src="beatles.mid" />

上面的代码片断为网页设置了一个 MIDI 文件作为背景音乐。

TIY

您可在本教程的最后一节找到 <bgsound> 元素的属性列表。

注释：<bgsound> 元素不是标准的 HTML 或 XHTML 元素。仅有 Internet Explorer 支持该元素。

使用 <img> 元素

Internet Explorer 支持 <img> 元素中的 dynsrc 属性。

该元素的作用是在网页中嵌入多媒体元素：

<img dynsrc="horse.wav" />

上面的代码片断为网页设置了一个嵌入的 WAVE 文件。

TIY

注释：dynsrc 属性不是标准的 HTML 或 XHTML 元素。仅有 Internet Explorer 支持该属性。

使用 <embed> 元素

Internet Explorer 和 Netscape 都支持 <embed> 元素。

该元素的作用是在网页中嵌入多媒体元素：

<embed src="beatles.mid" />

上面的代码片断为网页设置了一个嵌入的 MIDI 文件。

TIY

您可在本教程的最后一节找到 <embed> 元素的属性列表。

注释：Internet Explorer 和 Netscape 都支持 <embed> 元素，但它不是标准的 HTML 或 XHTML 元素。万维网联盟 (W3C) 推荐使用 <object> 元素来代替它。

使用 <object> 元素

Internet Explorer 和 Netscape 都支持 <object> 元素。

该元素的作用是在网页中嵌入多媒体元素：

<object
classid="clsid:22D6F312-B0F6-11D0-94AB-0080C74C7E95">
<param name="FileName" value="liar.wav" />
</object>

上面的代码片断在网页设置了一个嵌入的的 WAVE 文件。

TIY

您可在本教程的最后一节找到 <object> 元素的属性列表。

使用超链接

如果网页包含了一个指向某个媒介文件的超链接，大多数浏览器都会使用“助手程序”来播放该文件：

<a href="beatles.mid">
点击此处来播放 the Beatles
</a>

上面的代码片段设置了一个指向 MIDI 文件的链接。如果用户点击该链接，浏览器将启动助手程序（比如 Windows Media Player）来播放该 MIDI 文件。

TIY

  • Previous Page
  • Next Page

Web 多媒体元素参考手册


.NET Web Services

Microsoft.NET

  • .NET 首页
  • .NET 简介
  • .NET 核心
  • .NET 软件
  • .NET 网络服务
  • .NET 标准
  • .NET 服务
  • .NET 未来

.NET 教程

  • .NET ASP
  • .NET Mobile

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

.NET Web Services

  • Previous Page
  • Next Page

Web services 是为处理某个有限的任务而构建的小代码单位。

什么是 Web Services?

  • Web services 是小的代码单位
  • Web services 被设计用于处理一系列有限的任务
  • Web services 使用基于 XML 的通信协议
  • Web services 独立于操作系统
  • Web services 独立于编程语言
  • Web services 把人、系统和设备连接在一起

您可以在我们的 Web Services 教程中获得更多信息。

小的代码单位

Web services 是被设计为处理一系列有限的任务的小代码单位。

举例，web service 可被设计用于向其他的应用程序提供股票交易价格，它也可被用来处理信用卡的支付。

基于 XML 的网络协议（XML Based Web Protocols）

Web services 使用标准的网络协议：HTTP、XML、SOAP、WSDL 以及 UDDI。

HTTP

HTTP（超文本传输协议）是用于在因特网上通信的万维网标准。HTTP 是由万维网联盟（W3C）进行标准化的。

XML

XML（扩展标记语言）是用来存储、传输以及交换数据的广为人知的一种标准。XML 同样由 W3C 标准化。

您可以在我们的 XML 教程中获得更多信息。

SOAP

SOAP（简单对象访问协议）是一种轻量级的独立于平台和语言的通信协议，它允许程序经由标准的因特网 HTTP 进行通信。SOAP 由 W3C 标准化。

您可以在我们的 SOAP 教程中获得更多关于 SOAP 的信息。

WSDL

WSDL（网络服务描述语言）是用于定义网络服务并描述如何访问这些服务的基于 XML 的语言。WSDL 是由 Ariba、IBM 以及微软公司向 W3C 中涉及 XML 协议的 XML 活动提出的旨在描述服务的提议。

您可以在我们的 WSDL 教程中获得更多关于 WSDL 的信息。

UDDI

UDDI 一种目录服务，通过它，企业可以注册并搜索 web services。

UDDI 是一种公用的注册（服务），可通过它发布和查询有关的 web services。

独立于操作系统

由于 web services 使用基于 XML 的协议和其他系统进行通信，web services 可独立于操作系统和编程语言。

调用网络服务（web service）的应用程序会始终使用 XML 来传送其请求，并获得作为 XML 返回的应答。因此这些（调用服务的）应用程序不会关心运行于其他计算机上的是何种操作系统或编程语言。

Web Services 带来的好处

  • 更易于在应用程序之间通信
  • 更易于重用现有的服务
  • 更易于向更多的用户分发信息
  • 快速开发

Web services 让不同应用程序之间的通信变得更加容易。它们同样使得开发人员重复使用现有的网络服务而不是开发新服务成为一种可能。

Web services 为许多企业创造出新的可能性（机遇），这要归功于它为向大量客户分发信息提供了简单的解决方案。航班时刻表和客票预订系统就是很好例子。

  • Previous Page
  • Next Page


.NET 构建模块（Building Blocks）

Microsoft.NET

  • .NET 首页
  • .NET 简介
  • .NET 核心
  • .NET 软件
  • .NET 网络服务
  • .NET 标准
  • .NET 服务
  • .NET 未来

.NET 教程

  • .NET ASP
  • .NET Mobile

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

.NET 构建模块（Building Blocks）

  • Previous Page
  • Next Page

.NET 构建模块是一系列核心的因特网服务（Internet Services）。

Web Services（网络服务）

Web Services 向其他的应用程序提供数据和服务。

未来的应用程序将通过标准的 Web 格式 (HTTP, HTML, XML, 以及 SOAP) 来访问 Web Services，而无需知晓 Web Services 本身是如何实现的。

在微软的 .NET 编程模型中，Web Services 是主要的构建模块。

Standard Communication（标准的通信）

正式的 Web 标准将被用来描述什么是因特网数据，以及 Web Services 可以做的事情。

未来的 Web 应用程序将被构建在灵活的服务之上，这些服务可以在保持其完整性的同时互相交互以及交换数据。

Internet Storages（因特网存储）

.NET 在网络上提供安全的可寻址的空间来存储数据和应用程序。并允许各种类型的因特网设备（PC、掌上电脑、移动电话等）访问数据和应用程序。

这些 Web Services 构建于微软公司现有的 NTFS、SQL Server 以及交换技术之上。

Internet Dynamic Delivery（因特网动态传送）

通过请求和安装独立的应用程序，可进行可靠的自动化的更新。

.NET 将支持可被动态重新配置的应用程序的快速开发。

Internet Identity（因特网验证）

.NET 提供多种层级的身份验证服务，比如密码、钱包以及智能卡片。

这些服务被构建于现有的微软 Passport 和 Windows 身份验证技术之上。

Internet Messaging（因特网通信）

.NET 支持把即时通信、电子邮件、语音邮件以及传真整合为一个统一的因特网服务，其对象是各种 PC 以及智能因特网设备。

这些服务构建在现有的 hotmail、交换以及即时通信软件技术之上。

Internet Calendar（因特网日历）

.NET 支持对工作、社会以及私人家庭日历在因特网进行集成。允许各种类型的设备（PC、掌上电脑、移动电话等）访问这些数据。

这些服务构建在现有的 Outlook 以及 Hotmail 技术之上。

Internet Directory Services（因特网目录服务）

.NET 支持新型的目录服务，可回答基于 XML 的和因特网服务相关的问题，远胜于搜索引擎以及黄页。

这些服务构建在 UDDI 标准之上。

  • Previous Page
  • Next Page


.NET 软件

Microsoft.NET

  • .NET 首页
  • .NET 简介
  • .NET 核心
  • .NET 软件
  • .NET 网络服务
  • .NET 标准
  • .NET 服务
  • .NET 未来

.NET 教程

  • .NET ASP
  • .NET Mobile

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

.NET 软件

  • Previous Page
  • Next Page

.NET 是技术、标准以及开发工具的混合体。

Windows.NET

今天，Windows 2000 和 Windows XP 组成了 .NET 的主干。

未来，.NET 基础构架会被整合到所有的微软操作系统中，包括桌面以及服务器产品。

Windows.NET 是下一代的 Windows。它将提供对所有 .NET 构建模块和 .NET 数字媒体的支持。当用户需要它时，Windows.NET 会经由 Internet 进行升级，以便进行自行维护。

Office.NET

新版本的微软 office - Office.NET - 将拥有新的基于因特网客户端以及 Web Services 的 .NET 基础构架。

通过 Office.NET 进行的浏览、通信、文档处理以及创作将被整合到一个基于 XML 的环境中，这个环境允许用户在因特网存储文档。

ASP.NET

ASP.NET 是最新版本的 ASP。它包括供连接使用 HTTP、HTML、XML 以及 SOAP 的应用程序、服务以及设备的 Web Services。

ASP.NET 的新特性:

  • 新的语言支持
  • 可编程的控件
  • 事件驱动的编程
  • 基于 XML 的组件
  • 用户身份验证
  • 用户帐户和角色
  • 高伸缩性
  • 已编译的代码
  • 易配置
  • 易部署
  • 非 ASP 程序的兼容性
  • 包含 ADO.NET

您可以在我们的 ASP.NET 教程中阅读更多关于 ASP.NET 和 ADO.NET 的信息。

Visual Studio.NET

Visual Studio 的最新版本 - Visual Studio.NET - 整合了 ASP.NET、ADO.NET、Web Services、Web 窗体以及对 Visual Basic 的语言革新。开发工具拥有对 XML 深层的支持、基于 XML 的编程模型、新的面向对象的编程性能。

Visual Basic.NET

Visual Basic 已经该语言进行了改进，使其成为完全面向对象（object-oriented）的编程语言。

SQL Server 2000

SQL Server 2000 是充分支持 web（fully web-enabled）的数据库。

SQL Server 2000 对 XML 和 HTTP 有着强有力的支持，这两者恰恰又是 .NET 的主要基础构架技术。

新的 SQL Server 的某些最重要的特性是：可从浏览器对数据的直接访问、以 XML 来返回对关系型数据查询的结果、使用关系型格式存储 XML。

Internet Information Services 6.0

IIS 6.0 对更多在服务器上发生的编程拥有强有力的支持，允许新的 web 应用程序运行于任何平台上的任何浏览器中。

  • Previous Page
  • Next Page


Microsoft .NET 简介

Microsoft.NET

  • .NET 首页
  • .NET 简介
  • .NET 核心
  • .NET 软件
  • .NET 网络服务
  • .NET 标准
  • .NET 服务
  • .NET 未来

.NET 教程

  • .NET ASP
  • .NET Mobile

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Microsoft .NET 简介

  • Previous Page
  • Next Page

Microsoft .NET 是微软新的因特网战略。

.NET 起初被称为 NGWS。

NGWS - 下一代视窗服务（Next Generation Windows Services）

在 .NET 被正式发布之前，NGWS 这术语一直被用于微软的某些计划，这些计划旨在创建一个下一代视窗服务的基于因特网的平台（"Internet-based platform of Next Generation Windows Services"）。

史蒂夫.鲍尔默于 2000 年：

“交付一个基于因特网的下一代视窗服务平台是我们公司的重中之重。我们在此谈论的突破包括对编程模型、用户界面、应用程序整合模型、文件系统、新的 XML schema ...的改变。”

Microsoft. NET

Microsoft. NET 战略在 2000 年 6 月由微软官方正式发布：

  • .NET 是微软的新的因特网和 Web 战略
  • .NET 不是一个操作系统
  • .NET 是一个基于因特网和 WEB 的全新架构
  • .NET 将软件作为 Web Services（提交给用户）
  • .NET 是用于通用服务（universal services）的一种构架
  • .NET 可运行于任何平台上的任何浏览器中
  • .NET 基于最新的 web 标准

.NET 因特网标准

.NET 被构建于以下因特网标准之上：

  • HTTP，因特网应用程序之间的通信协议
  • XML，用于在因特网应用程序之间交换数据的格式
  • SOAP，用于请求 Web Service 的标准格式
  • UDDI，用于搜索和发现 Web Service 的标准

.NET 框架（.NET Framework）

.NET 框架是为微软新的 .net 平台服务的基础结构。

.NET 框架是用于构建、开发以及运行 Web Service 和 Web 应用程序的公共环境。

.NET 框架包含着公用的类库 - 比如 ADO.NET、ASP.NET 以及 Windows 窗体 - 提供可被整合到多种计算机系统的高级标准服务。

.NET 框架是对语言中立的。目前，它支持 C++、C#、Visual Basic、JScript (JavaScript 的微软版本)以及 COBOL。第三方语言 - 比如 Eiffel、PerlPython、Smalltalk 等等 - 也将可用于构建未来的.NET 框架应用程序。

新的 Visual Studio.NET 是用于新的 .NET 框架的公共开发环境。它提供多功能的应用程序执行环境、简化开发以及多种开发语言之间简易的整合。

其他信息

.NET 计划包含一个新版本的 Windows 操作系统、一个新版本的 Office 以及一系列为开发人员构建基于 web 的应用程序准备的开发软件。

.NET 的背景可以理解为，当计算开始从桌面计算机转向可访问因特网的设备比如掌上电脑和移动电话时，微软公司为了维持其操作系统在市场中的垄断地位而采取的新措施的一个部分。

.NET 框架的最直观的组件是：新的 Internet 信息服务6.0（IIS 6.0）、对支持 ASP.NET 和 ADO.NET 的支持、可构建基于 web 的软件的 Visual Studio.NET 软件工具以及在 SQL Server 2000 数据库中新的 XML 支持。

  • Previous Page
  • Next Page


Microsoft.NET 教程

Microsoft.NET

  • .NET 首页
  • .NET 简介
  • .NET 核心
  • .NET 软件
  • .NET 网络服务
  • .NET 标准
  • .NET 服务
  • .NET 未来

.NET 教程

  • .NET ASP
  • .NET Mobile

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Microsoft.NET 教程

  • Next Page

在你完成对本教程的学习之后，你将了解什么是 .NET。

同时你会认识到：.NET 将会影响未来创建 WEB 应用程序的方式。

开始学习 Microsoft.NET！

内容目录

Microsoft .NET 简介
本简介阐述了.NET 的概念，以及它对未来的意义所在。
Microsoft .NET 核心构建模块
本章讲解 Microsoft .NET 的核心构建模块。
Microsoft .NET 软件
本章讲解 .NET 开发工具、软件、标准和应用。
Web Services
本章讲解 Web Services 的概念。
客户端和服务器端标准
W3School 对未来因特网分布式应用程序的展望。
应用程序必须是服务
W3School 关于.NET 应用程序服务的见解。
未来的应用程序
W3School 关于经得起未来考验的应用程序的见解。
  • Next Page


经得起未来考验的应用程序

Microsoft.NET

  • .NET 首页
  • .NET 简介
  • .NET 核心
  • .NET 软件
  • .NET 网络服务
  • .NET 标准
  • .NET 服务
  • .NET 未来

.NET 教程

  • .NET ASP
  • .NET Mobile

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

经得起未来考验的应用程序

  • Previous Page
  • Next Page

下面的段落描述了 W3School 对未来的因特网分布式应用程序的展望。

应用程序应当支持未来的变化

应用程序应当能意识到未来的变化，并良好地适应服务数量以及交换格式方面的变化。应用程序和数据交换格式必须支持扩展和已删除元素及版本控件。我们的建议是最好使用带有 XML Schema 的 XML。

应用程序应当可伸缩并可重新部署

应用程序应当有能力弹性地支持每日少许直到千百万次的请求。服务器服务应当有能力分布到多个服务器，或者在不中断应用程序的情况下从一个服务器转移至另外一个。我们的建议是使服务器服务独立于物理服务器，并使用标准的因特网统一资源定位器 (URL) 或者目录服务来定位服务。

应用程序必须支持其他应用程序

应用程序应当有能力与其它应用程序协同工作。我们的建议是最好使用相同的规则来创建所有的应用程序，并使用标准的因特网链接来连接这些应用程序。

应用程序必须支持未来的因特网标准

应用程序应当做好准备来支持新的因特网标准。

  • Previous Page
  • Next Page


客户端和服务器标准

Microsoft.NET

  • .NET 首页
  • .NET 简介
  • .NET 核心
  • .NET 软件
  • .NET 网络服务
  • .NET 标准
  • .NET 服务
  • .NET 未来

.NET 教程

  • .NET ASP
  • .NET Mobile

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

客户端和服务器标准

  • Previous Page
  • Next Page

下面的段落描述了 W3School 对未来因特网分布式应用程序的展望。

Executables, C++ (以及 Java) 会走向灭亡

C++ 和 Java 过去都无法创建运行于所有计算机之上的标准组件。在未来的分布式应用程序中，这些语言已经没有什么发展空间了。Executables 是非标准的。COM 对象也是非标准的，DLL 文件是非标准的。注册设置（Registry settings）是非标准的，INI 文件是非标准的。我们不会让这些组件毁坏了关于标准的分布式应用程序的那个梦想，即可允许于世界上所有的计算机上。

客户端必须成为标准的因特网浏览器

应用程序客户端必须是不带有额外组件的标准客户端。应用程序的任何一部分都不能存储在客户端计算机中。应用程序绝不能使用或依赖于任何组件、dll 或 ini 文件、注册设置或者任何其它非标准的存储在客户端计算机之中的设置或文件。（这样我们称之为瘦客户端）。我们的建议是最好让所以的用户在 Windows 或 Mac 中使用标准的因特网浏览器，比如 Internet Explorer、Netscape 或 Firefox 等。

服务器必须成为标准的因特网服务器

应用程序服务器必须是运行不带有额外组件的标准软件的标准的因特网服务器。应用程序绝不能使用或依赖于任何组件、dll 或 ini 文件、注册设置或者任何其它非标准的存储在客户端计算机之中的设置或文件。我们的建议是最好使用标准的因特网服务器，比如 IIS，带有标准的请求处理程序，比如 ASP，以及标准的数据库连接程序（接口），比如 ADO。至于数据存储，应该使用标准的基于 SQL 的数据库，比 Oracle 或者 MS SQL Server。

应用程序必须使用因特网通信

不允许应用程序客户端和服务器经由任何私有的协议进行通信。客户端必须经由标准的因特网协议请求服务器，服务器必须经由同样的协议作出响应。客户端必须有能力在不必维持某个永久的服务器连接的情况下使用任何的服务。我们的建议是最好让对服务器使用标准的无国界的因特网 HTTP 请求进行请求。服务器应当使用标准的无国界的因特网 HTTP 应答进行应答。

  • Previous Page
  • Next Page


应用程序必须是服务

Microsoft.NET

  • .NET 首页
  • .NET 简介
  • .NET 核心
  • .NET 软件
  • .NET 网络服务
  • .NET 标准
  • .NET 服务
  • .NET 未来

.NET 教程

  • .NET ASP
  • .NET Mobile

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

应用程序必须是服务

  • Previous Page
  • Next Page

下面的段落描述了 W3School 对未来的因特网分布式应用程序的展望。

应用程序必须是一系列的服务

应用程序不再被允许包含大量已编辑的可执行代码。应用程序应被分为一系列更小的专门的服务，这样就更易创建和维护。这些专门的服务可由更精简的团队进行开发和维护。服务（Services）与可执行文件、组件或者 DLL 文件不同。服务可对提交的请求进行应答，也可返回数据。我们的建议是把服务作为一系列服务器端的 HTML 以及（或者）XML 页面来进行开发。

服务不能为某个特殊的目的创建

在历史上，充斥着为完成某个单一的任务而创建的应用程序。这些应用程序中的许多在它们被发布前就已经失败了，这是由于它们无法根据需求的变化而进行改变。这是对金钱和时间的巨大浪费。我们（以及那些为我们的应用程序买单的人们）都希望可以创建更灵活的应用程序，这些应用程序具有很强的普适性，可以更好地应对未来的改变。未来 - 即使（在过去）没有考虑过 - 应用程序应当在保持完整性的同时更容易适应变化。我们的建议是创建灵活的标准服务来服务于大量的不同的请求。

服务必须易于创建和编辑

只要可以避免，服务（Services）就不应被代码化。即使需要被代码化，我们的建议是最好使用脚本。服务不应被编译为可执行文件。这样做会令服务难于访问和编辑。任何在应用程序中使用的预编译组件都会威胁到创建可移动、可伸缩以及良好支持未来扩展和变化的应用程序的可能性。应用程序应该通过编辑其属性和方法来创建和修改，而不是改变它们的可执行代码。我们的建议是使用某个 XML 编辑器来创建和编辑服务，并使用标准的服务引擎通过执行服务描述来提供服务。服务描述应当存储于类似数据库的数据仓库中或者某个 XML/HTML 文件中。

服务和数据必须能自我描述

应用程序客户端应当有能力为某个服务查询服务器，以及有能力请求当前的服务器功能。客户端和服务器也应当有能力通过某种可理解数据中每个元素的方法来交换数据。我们的建议是使用带有 DTD 的信息词表来交换服务器函数，并使用 XML 来交换数据。

  • Previous Page
  • Next Page


w3school 新闻

HTML教程

  • HTML
  • XHTML
  • CSS
  • TCP/IP

XML教程

  • XML
  • DTD
  • XML DOM
  • XSL
  • XSLT
  • XSL-FO
  • XPath
  • XQuery
  • XLink
  • XPointer
  • Schema
  • XForms
  • SOAP
  • WSDL
  • RDF
  • RSS
  • WAP
  • Web Services

浏览器脚本

  • JavaScript
  • HTML DOM
  • DHTML
  • VBScript
  • AJAX
  • E4X
  • WMLScript

服务器脚本

  • SQL
  • ASP
  • ADO
  • PHP

.NET(dotnet)

  • .NET Microsoft
  • .NET ASP
  • .NET Mobile

多媒体

  • Media
  • SMIL
  • SVG

建站手册

  • 网站构建
  • 万维网联盟 (W3C)
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

W3School 新闻

W3School 测试版本号升级为 alpha

中文网站技术教程站点 - W3School 于2007年8月8日升级为 alpha1.0 版本。

至此，W3School 已经完成了 base 版本的所有测试工作。在网站的 base 版本测试阶段，W3School对用户界面、在线测试工具（TIY 1.1）以及在线测验程序进行了测试，并上传了部分教程的草稿。

进入 alpha 测试阶段后，W3School 计划逐步完成内容建设，并继续对现有的应用程序进行完善，以及提供在线的用户反馈系统。

W3School 于2006年开始测试，其内容涉及网站技术教程、参考手册以及代码实例等，网站建成后将成为最大的中文在线 web 技术教程站点。

新闻发布时间：2007年8月8日

责任编辑：W3School 项目组

服务信箱：service#w3school.com.cn (请把 # 改为 @)

很抱歉，本邮件不接受技术问题的咨询，这样我们才会有更多的时间来制作更多更好的教程。

由于邮件繁多，不能一一回复，敬请谅解。

参考手册

  • HTML 4.01
  • XHTML 1.0
  • HTML 5
  • CSS 2.0
  • JavaScript
  • VBScript
  • HTML DOM
  • XML DOM
  • ASP
  • ADO
  • ASP.NET
  • PHP 5.1
  • XSLT 1.0
  • XPath 2.0
  • XSL-FO
  • WML 1.1
  • HTML 颜色

字符集

  • HTML ASCII
  • HTML Latin-1
  • HTML 符号

实例/案例

  • HTML 实例
  • CSS 实例
  • XML 实例
  • JavaScript 实例
  • JavaScript 对象实例
  • HTML DOM 实例
  • XML DOM 实例
  • DHTML 实例
  • AJAX 实例
  • VBScript 实例
  • ASP 实例
  • ADO 实例
  • SVG 实例
  • WAP 实例

测验/考试

  • HTML 测验
  • XHTML 测验
  • CSS 测验
  • XML 测验
  • JavaScript 测验
  • SQL 测验
  • ASP 测验

代码验证

  • 验证HTML
  • 验证CSS
  • 验证XHTML
  • 验证XML
  • 验证WML


AJAX XMLHttpRequest

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

AJAX XMLHttpRequest

  • Previous Page
  • Next Page

XMLHttpRequest 对象使 AJAX 成为可能。

XMLHttpRequest

XMLHttpRequest 对象是 AJAX 的关键。

该对象在 Internet Explorer 5.5 与 2000 年 7 月发布之后就已经可用了，但是在 2005 人们开始讨论 AJAX 和 Web 2.0 之前，这个对象并没有得到充分的认识。

创建 XMLHttpRequest 对象

不同的浏览器使用不同的方法来创建 XMLHttpRequest 对象。

Internet Explorer 使用 ActiveXObject。

其他浏览器使用名为 XMLHttpRequest 的 JavaScript 内建对象。

要克服这个问题，可以使用这段简单的代码：

var XMLHttp=null
if (window.XMLHttpRequest)
  {
  XMLHttp=new XMLHttpRequest()
  }
else if (window.ActiveXObject)
  {
  XMLHttp=new ActiveXObject("Microsoft.XMLHTTP")
  }

代码解释：

  1. 首先创建一个作为 XMLHttpRequest 对象使用的 XMLHttp 变量。把它的值设置为 null。
  2. 然后测试 window.XMLHttpRequest 对象是否可用。在新版本的 Firefox, Mozilla, Opera 以及 Safari 浏览器中，该对象是可用的。
  3. 如果可用，则用它创建一个新对象：XMLHttp=new XMLHttpRequest()
  4. 如果不可用，则检测 window.ActiveXObject 是否可用。在 Internet Explorer version 5.5 及更高的版本中，该对象是可用的。
  5. 如果可用，使用它来创建一个新对象：XMLHttp=new ActiveXObject()

改进的例子

一些程序员喜欢使用最新最快的版本的 XMLHttpRequest 对象。

下面的例子试图加载微软最新版本的 "Msxml2.XMLHTTP"，在 Internet Explorer 6 中可用，如果无法加载，则后退到 "Microsoft.XMLHTTP"，在 Internet Explorer 5.5 及其后版本中可用。

function GetXmlHttpObject()
{
var xmlHttp=null;

try
 {
 // Firefox, Opera 8.0+, Safari
 xmlHttp=new XMLHttpRequest();
 }
catch (e)
 {
 // Internet Explorer
 try
  {
  xmlHttp=new ActiveXObject("Msxml2.XMLHTTP");
  }
 catch (e)
  {
  xmlHttp=new ActiveXObject("Microsoft.XMLHTTP");
  }
 }
return xmlHttp;
}

代码解释：

  1. 首先创建用作 XMLHttpRequest 对象的 XMLHttp 变量。把它的值设置为 null。
  2. 按照 web 标准创建对象 (Mozilla, Opera 以及 Safari)：XMLHttp=new XMLHttpRequest()
  3. 按照微软的方式创建对象，在 Internet Explorer 6 及更高的版本可用：XMLHttp=new ActiveXObject("Msxml2.XMLHTTP")
  4. 如果捕获错误，则尝试更老的方法 (Internet Explorer 5.5) ：XMLHttp=new ActiveXObject("Microsoft.XMLHTTP")

更多有关 XMLHttpRequest 对象的信息

如果您希望阅读更多有关 XMLHttpRequest 的内容，请访问我们的 AJAX 教程。

  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


AJAX 简介

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

AJAX 简介

  • Previous Page
  • Next Page

AJAX = Asynchronous JavaScript And XML（异步 JavaScript 及 XML）

AJAX 是 Asynchronous JavaScript And XML 的首字母缩写。

AJAX 并不是一种新的编程语言，而仅仅是一种新的技术，它可以创建更好、更快且交互性更强的 web 应用程序。

AJAX 使用 JavaScript 在 web 浏览器与 web 服务器之间来发送和接收数据。

通过在幕后与 web 服务器交换数据，而不是每当用户作出改变时重载整个 web 页面，AJAX 技术可以使网页更迅速地响应。

AJAX 基于开放的标准

AJAX 基于以下开放的标准：

  • JavaScript
  • XML
  • HTML
  • CSS

在 AJAX 中使用的开放标准被良好地定义，并得到所有主要浏览器的支持。AJAX 应用程序独立于浏览器和平台。（可以说，它是一种跨平台跨浏览器的技术）。

AJAX 事关更好的 Internet 应用程序

与桌面应用程序相比，Web 应用程序有很多优势：

  • 可拥有更多用户
  • 更容易安装和维护
  • 更容易开发

但是， 应用程序不总是象传统应用程序那样强大和友好。

通过 AJAX，可以使 Internet 应用程序更加强大（更轻巧、更快速，且更易使用）。

今天您就可以开始使用 AJAX

没有什么新知识需要学习。

AJAX 基于开放的标准。而这些标准已被大多数开发者使用多年。

大多数 web 应用程序可通过使用 AJAX 技术进行重写，来替代传统的 HTML 表单。

AJAX 使用 XML 和 HTTP 请求

传统的 web 应用程序会把数据提交到 web 服务器（使用 HTML 表单）。在 web 服务器把数据处理完毕之后，会向用户返回一张完整的新网页。

由于每当用户提交输入，服务器就会返回新网页，传统的 web 应用程序往往运行缓慢，且越来越不友好。

通过 AJAX，web 应用程序无需重载网页，就可以发送并取回数据。完成这项工作，需要通过向服务器发送 HTTP 请求（在幕后），并通过当服务器返回数据时使用 JavaScript 仅仅修改网页的某部分。

一般使用 XML 作为接收服务器数据的格式，尽管可以使用任何格式，包括纯文本。

您将在本教程接下来的章节学习到如何完成这些工作。

PHP 和 AJAX

不存在什么 AJAX 服务器。

AJAX 是一种在浏览器运行的技术。它使用浏览器与 web 服务器之间的异步数据传输，使网页从服务器请求少量的信息，而不是整张页面。

AJAX 是一种独立于 web 服务器软件的 web 浏览器技术。

但是，在本教程中，我们将集中在运行在 PHP 服务器上的实际案例，而不是 AJAX 的工作原理。

如需阅读更多有关 AJAX 如何工作的知识，请访问我们的 AJAX 教程。

  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


HTML DOM alt Property

 HTML DOM alt Property http://www.w3school.com.cn/htmldom/prop_img_alt.asp HTML DOM height Property http://www.w3school.com.cn/htmldom/prop_img_height.asp HTML a tag http://www.w3school.com.cn/tags/tag_a.asp HTML br tag http://www.w3school.com.cn/tags/tag_br.asp CSS background Property http://www.w3school.com.cn/css/pr_background.asp CSS border Property http://www.w3school.com.cn/css/pr_border.asp JavaScript Date() Method http://www.w3school.com.cn/jsref/jsref_date.asp JavaScript anchor() Method http://www.w3school.com.cn/jsref/jsref_anchor.asp


PHP __construct() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP __construct() 函数

PHP SimpleXML 函数

定义和用法

__construct() 函数创建一个新的 SimpleXMLElement 对象。

如果成功，则该函数返回一个对象。如果失败，则返回 false。

语法

__construct(data,options,is_url,ns,is_prefix)
参数 | 描述
data | 必需。形式良好的 XML 字符串或 XML 文档的路径或 URL。
options | 可选。规定附加的 Libxml 参数。
is_url | 可选。规定 data 参数是否是 URL。默认是 false。
ns | 可选。
is_prefix | 可选。

返回值

返回一个表示数据的 SimpleXMLElement 对象。

例子

<?php
$xmlstring = <<<XML
<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>
XML;

$xml = new SimpleXMLElement($xmlstring);

echo $xml->body[0];
?>

输出类似：

Don't forget the meeting!

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP $_GET

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP $_GET

  • Previous Page
  • Next Page

$_GET 变量用于收集来自 method="get" 的表单中的值。

$_GET 变量

$_GET 变量是一个数组，内容是由 HTTP GET 方法发送的变量名称和值。

$_GET 变量用于收集来自 method="get" 的表单中的值。从带有 GET 方法的表单发送的信息，对任何人都是可见的（会显示在浏览器的地址栏），并且对发送的信息量也有限制（最多 100 个字符）。

例子

<form action="welcome.php" method="get">
Name: <input type="text" name="name" />
Age: <input type="text" name="age" />
<input type="submit" />
</form>

当用户点击提交按钮时，发送的 URL 会类似这样：

http://www.w3school.com.cn/welcome.php?name=Peter&age=37

"welcome.php" 文件现在可以通过 $_GET 变量来获取表单数据了（请注意，表单域的名称会自动成为 $_GET 数组中的 ID 键）：

Welcome <?php echo $_GET["name"]; ?>.<br />
You are <?php echo $_GET["age"]; ?> years old!

为什么使用 $_GET？

注释：在使用 $_GET 变量时，所有的变量名和值都会显示在 URL 中。所以在发送密码或其他敏感信息时，不应该使用这个方法。不过，正因为变量显示在 URL 中，因此可以在收藏夹中收藏该页面。在某些情况下，这是很有用的。

注释：HTTP GET 方法不适合大型的变量值；值是不能超过 100 个字符的。

$_REQUEST 变量

PHP 的 $_REQUEST 变量包含了 $_GET, $_POST 以及 $_COOKIE 的内容。

PHP 的 $_REQUEST 变量可用来取得通过 GET 和 POST 方法发送的表单数据的结果。

例子

Welcome <?php echo $_REQUEST["name"]; ?>.<br />
You are <?php echo $_REQUEST["age"]; ?> years old!
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP $_POST

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP $_POST

  • Previous Page
  • Next Page

$_POST 变量用于收集来自 method="post" 的表单中的值。

$_POST 变量

$_POST 变量是一个数组，内容是由 HTTP POST 方法发送的变量名称和值。

$_POST 变量用于收集来自 method="post" 的表单中的值。从带有 POST 方法的表单发送的信息，对任何人都是不可见的（会显示在浏览器的地址栏），并且对发送信息的量也没有限制。

例子

<form action="welcome.php" method="post">
Enter your name: <input type="text" name="name" />
Enter your age: <input type="text" name="age" />
<input type="submit" />
</form>

当用户点击提交按钮，URL 不会含有任何表单数据，看上去类似这样：

http://www.w3school.com.cn/welcome.php

"welcome.php" 文件现在可以通过 $_POST 变量来获取表单数据了（请注意，表单域的名称会自动成为 $_POST 数组中的 ID 键）：

Welcome <?php echo $_POST["name"]; ?>.<br />
You are <?php echo $_POST["age"]; ?> years old!

为什么使用 $_POST？

  • 通过 HTTP POST 发送的变量不会显示在 URL 中。
  • 变量没有长度限制。

不过，由于变量不显示在 URL 中，所有无法把页面加入书签。

$_REQUEST 变量

PHP 的 $_REQUEST 变量包含了 $_GET, $_POST 以及 $_COOKIE 的内容。

PHP 的 $_REQUEST 变量可用来取得通过 GET 和 POST 方法发送的表单数据的结果。

例子

Welcome <?php echo $_REQUEST["name"]; ?>.<br />
You are <?php echo $_REQUEST["age"]; ?> years old!
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP abs() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP abs() 函数

PHP Math 函数

定义和用法

abs() 函数返回一个数的绝对值。

语法

abs(x)
参数 | 描述
x | 必需。一个数。

说明

返回参数 x 的绝对值。如果参数 x 是 float，则返回的类型也是 float，否则返回 integer（因为 float 通常比 integer 有更大的取值范围）。

例子

<?php
echo(abs(6.7));
echo(abs(-3));
echo(abs(3));
?>

输出：

6.7
3
3

PHP Math 函数

PHP 参考手册
PHP 测验


PHP acos() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP acos() 函数

PHP Math 函数

定义和用法

acos() 函数返回一个数的反余弦。

语法

acos(x)
参数 | 描述
x | 必需。一个数，范围在 -1 到 1 之间。

说明

返回 x 的反余弦值，单位是弧度。acos() 是 cos() 的反函数，它的意思是在 acos() 范围里的每个值都是 a==cos(acos(a)) 。

如果 x 的值在 -1 到 1 之外，则返回 -1.#IND。如果为 -1，则返回 PI 的值。

例子

在本例中，我们将计算不同值的反余弦：

<?php
echo(acos(0.64));
echo(acos(0));
echo(acos(-1));
echo(acos(1));
echo(acos(2));
?>

输出：

0.876298061168
1.57079632679
3.14159265359
0
-1.#IND

PHP Math 函数

PHP 参考手册
PHP 测验


PHP acosh() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP acosh() 函数

PHP Math 函数

定义和用法

acosh() 函数返回一个数的反双曲余弦。

语法

acosh(x)
参数 | 描述
x | 必需。一个数。

说明

返回 x 的反双曲余弦值，即，其双曲余弦为 x 的那个值。

提示和注释

注释：本函数未在 Windows 平台下实现。

PHP Math 函数

PHP 参考手册
PHP 测验


PHP addAttribute() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP addAttribute() 函数

PHP SimpleXML 函数

定义和用法

addAttribute() 函数给 SimpleXML 元素添加一个属性。

该函数无返回值。

语法

class SimpleXMLElement
{
string addAttribute(name,value,ns)
}

参数 | 描述
name | 必需。规定属性的名称。
value | 必需。规定属性的值。
ns | 可选。规定属性的命名空间。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP 代码：

<?php
$xml = simplexml_load_file("test.xml");

$xml->body[0]->addAttribute("type", "small");

foreach($xml->body[0]->attributes() as $a => $b)
  {
  echo $a,'="',$b,'"';
  }
?>

输出：

type="small"

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP addChild() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP addChild() 函数

PHP SimpleXML 函数

定义和用法

addChild() 函数向指定的 XML 节点添加一个子节点。

该函数返回一个 SimpleXMLElement 对象，这个对象表示添加到 XML 节点的子元素。

语法

class SimpleXMLElement
{
string addChild(name,value,ns)
}
参数 | 描述
name | 必需。规定子元素的名称。
value | 必需。规定子元素的值。
ns | 可选。规定子元素的命名空间。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP 代码：

<?php
$xml = simplexml_load_file("test.xml");

$xml->body[0]->addChild("date", "2008-08-08");

foreach ($xml->body->children() as $child)
  {
  echo "Child node: " . $child;
  }
?>

输出：

Child node: 2008-08-08

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP addcslashes() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP addcslashes() 函数

PHP String 函数

定义和用法

addcslashes() 函数在指定的字符前添加反斜杠。

语法

addcslashes(string,characters)
参数 | 描述
string | 必需。规定要检查的字符串。
characters | 可选。规定受 addcslashes() 影响的字符或字符范围。

提示和注释

注释：在对 0，r，n 和 t 应用 addcslashes() 时要小心。在 PHP 中，\0，\r，\n 和 \t 是预定义的转义序列。

例子

例子 1

在本例中，我们要向字符串中的特定字符添加反斜杠：

<?php
$str = "Hello, my name is John Adams.";
echo $str;
echo addcslashes($str,'m');
echo addcslashes($str,'J');
?>

输出：

Hello, my name is John Adams.
Hello, \my na\me is John Ada\ms.
Hello, my name is \John Adams.

例子 2

在本例中，我们要向字符串中的一个范围内的字符添加反斜杠：

<?php
$str = "Hello, my name is John Adams.";
echo $str;
echo addcslashes($str,'A..Z');
echo addcslashes($str,'a..z');
echo addcslashes($str,'a..h');
?>

输出：

Hello, my name is John Adams.
\Hello, my name is \John \Adams.
H\e\l\l\o, \m\y \n\a\m\e \i\s \J\o\h\n \A\d\a\m\s.
H\ello, my n\am\e is Jo\hn A\d\ams.

PHP String 函数

PHP 参考手册
PHP 测验


PHP addslashes() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP addslashes() 函数

PHP String 函数

定义和用法

addslashes() 函数在指定的预定义字符前添加反斜杠。

这些预定义字符是：

  • 单引号 (')
  • 双引号 (")
  • 反斜杠 (\)
  • NULL

语法

addslashes(string)
参数 | 描述
string | 必需。规定要检查的字符串。

提示和注释

提示：该函数可用于为存储在数据库中的字符串以及数据库查询语句准备合适的字符串。

注释：默认情况下，PHP 指令 magic_quotes_gpc 为 on，对所有的 GET、POST 和 COOKIE 数据自动运行 addslashes()。不要对已经被 magic_quotes_gpc 转义过的字符串使用 addslashes()，因为这样会导致双层转义。遇到这种情况时可以使用函数 get_magic_quotes_gpc() 进行检测。

例子

在本例中，我们要向字符串中的预定义添加反斜杠：

<?php
$str = "Who's John Adams?";
echo $str . " This is not safe in a database query.<br />";
echo addslashes($str) . " This is safe in a database query.";
?>

输出：

Who's John Adams? This is not safe in a database query.
Who\'s John Adams? This is safe in a database query.

PHP String 函数

PHP 参考手册
PHP 测验


PHP array_change_key_case() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_change_key_case() 函数

PHP Array 函数

定义和用法

array_change_key_case() 函数将数组的所有的 KEY 都转换为大写或小写。

数组的数字索引不发生变化。如果未提供可选参数（即第二个参数），则默认转换为小写字母。

语法

array_change_key_case(array,case)
参数 | 描述
array | 必需。规定要使用的数组。
case

可选。可能的值：

  • CASE_LOWER - 默认值。以小写字母返回数组的键。
  • CASE_UPPER - 以大写字母返回数组的键。

提示和注释：

注释：如果在运行该函数时两个或多个键相同，则最后的元素会覆盖其他元素（参见例子 2）。

例子 1

<?php
$a=array("a"=>"Cat","b"=>"Dog","c"=>"Horse");
print_r(array_change_key_case($a,CASE_UPPER));
?>

输出：

Array ( [A] => Cat [B] => Dog [C] => Horse )

例子 2

<?php
$a=array("a"=>"Cat","b"=>"Dog","c"=>"Horse","B"=>"Bird");
print_r(array_change_key_case($a,CASE_UPPER));
?>

输出：

Array ( [A] => Cat [B] => Bird [C] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_chunk() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_chunk() 函数

PHP Array 函数

定义和用法

array_chunk() 函数把一个数组分割为新的数组块。

其中每个数组的单元数目由 size 参数决定。最后一个数组的单元数目可能会少几个。

可选参数 preserve_key 是一个布尔值，它指定新数组的元素是否有和原数组相同的键（用于关联数组），还是从 0 开始的新数字键（用于索引数组）。默认是分配新的键。

语法

array_chunk(array,size,preserve_key)
参数 | 描述
array | 必需。规定要使用的数组。
size | 必需。规定每个新数组包含多少个元素。
preserve_key

可选。可能的值：

  • true - 保留原始数组中的键名。
  • false - 默认。每个结果数组使用从零开始的新数组索引。

例子 1

<?php
$a=array("a"=>"Cat","b"=>"Dog","c"=>"Horse","d"=>"Cow");
print_r(array_chunk($a,2));
?>

输出：

Array (
[0] => Array ( [0] => Cat [1] => Dog )
[1] => Array ( [0] => Horse [1] => Cow )
)

例子 2

<?php
$a=array("a"=>"Cat","b"=>"Dog","c"=>"Horse","d"=>"Cow");
print_r(array_chunk($a,2,true));
?>

输出：

Array (
[0] => Array ( [a] => Cat [b] => Dog )
[1] => Array ( [c] => Horse [d] => Cow )
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_combine() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_combine() 函数

PHP Array 函数

定义和用法

array_combine() 函数通过合并两个数组来创建一个新数组，其中的一个数组是键名，另一个数组的值为键值。

如果其中一个数组为空，或者两个数组的元素个数不同，则该函数返回 false。

语法

array_combine(array1,array2)
参数 | 描述
array1 | 必需。规定键名。
array2 | 必需。规定值。

提示和注释

注释：两个参数必须有相同数目的元素。

例子

<?php
$a1=array("a","b","c","d");
$a2=array("Cat","Dog","Horse","Cow");
print_r(array_combine($a1,$a2));
?>

输出：

Array ( [a] => Cat [b] => Dog [c] => Horse [d] => Cow )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_count_values() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_count_values() 函数

PHP Array 函数

定义和用法

array_count_values() 函数用于统计数组中所有值出现的次数。

本函数返回一个数组，其元素的键名是原数组的值，键值是该值在原数组中出现的次数。

语法

array_count_values(array)
参数 | 描述
array | 必需。规定输入的数组。

例子

<?php
$a=array("Cat","Dog","Horse","Dog");
print_r(array_count_values($a));
?>

输出：

Array ( [Cat] => 1 [Dog] => 2 [Horse] => 1 )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_diff_assoc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_diff_assoc() 函数

PHP Array 函数

定义和用法

array_diff_assoc() 函数返回两个数组的差集数组。该数组包括了所有在被比较的数组中，但是不在任何其他参数数组中的键和值。

和 array_diff() 函数 不同，本函数要求键名和键值都进行比较。返回的数组中键名保持不变。

语法

array_diff_assoc(array1,array2,array3...)
参数 | 描述
array1 | 必需。与其他数组进行比较的第一个数组。
array2 | 必需。与第一个数组进行比较的数组。
array3 | 可选。与第一个数组进行比较的数组。可以有多个。

提示和注释

提示：可用一个或任意多个数组与第一个数组进行比较。

注释：键和值都用于比较。

例子

<?php
$a1=array(0=>"Cat",1=>"Dog";,2=>"Horse");
$a2=array(0=>"Rat",1=>"Horse";,2=>"Dog");
$a3=array(0=>"Horse",1=>"Dog",2=>"Cat");
print_r(array_diff_assoc($a1,$a2,$a3));
?>

输出：

Array ( [0] => Cat [2] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_diff_key() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_diff_key() 函数

PHP Array 函数

定义和用法

array_diff_key() 函数返回一个数组，该数组包括了所有在被比较的数组中，但是不在任何其他参数数组中的键。

语法

array_diff_key(array1,array2,array3...)
参数 | 描述
array1 | 必需。与其他数组进行比较的第一个数组。
array2 | 必需。与第一个数组进行比较的数组。
array3 | 可选。与第一个数组进行比较的数组。可以有多个。

提示和注释

提示：可用一个或任意多个数组与第一个数组进行比较。

注释：仅仅键名用于比较。

例子

<?php
$a1=array(0=>"Cat",1=>"Dog",2=>"Horse");
$a2=array(2=>"Bird",3=>"Rat",4=>"Fish");
$a3=array(5=>"Horse",6=>"Dog",7=>"Bird");
print_r(array_diff_key($a1,$a2,$a3));
?>

输出：

Array ( [0] => Cat [1] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_diff_uassoc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_diff_uassoc() 函数

PHP Array 函数

定义和用法

array_diff_uassoc() 函数使用用户自定义的回调函数 (callback) 做索引检查来计算两个或多个数组的差集。返回一个数组，该数组包括了在 array1 中但是不在任何其他参数数组中的值。

注意，与 array_diff() 函数 不同的是，键名也要进行比较。

参数 function 是用户自定义的用来比较两个数组的函数，该函数必须带有两个参数 - 即两个要进行对比的键名。因此与函数 array_diff_assoc() 的行为正好相反，后者是用内部函数进行比较的。

返回的数组中键名保持不变。

语法

array_diff_uassoc(array1,array2,array3...,function)
参数 | 描述
array1 | 必需。与其他数组进行比较的第一个数组。
array2 | 必需。与第一个数组进行比较的数组。
array3 | 可选。与第一个数组进行比较的数组。可以有多个。
function | 必需。用户自定义函数的名称。

例子 1

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
if ($v1>$v2)
    {
    return 1;
    }
else
    {
    return -1;
    }
}
$a1=array(0=>"Dog",1=>"Cat",2=>"Horse");
$a2=array(3=>"Dog",1=>"Cat",5=>"Horse");
print_r(array_diff_uassoc($a1,$a2,"myfunction"));
?>

输出：

Array ( [0] => Dog [2] => Horse )

例子 2

如何为该函数分配多个数组：

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
if ($v1>$v2)
    {
    return 1;
    }
else
    {
    return -1;
    }
}
$a1=array(0=>"Dog",1=>"Cat",2=>"Horse");
$a2=array(3=>"Dog",1=>"Cat",5=>"Horse");
$a3=array(6=>"Bird",0=>"Dog",5=>"Horse");
print_r(array_diff_uassoc($a1,$a2,$a3,"myfunction"));
?>

输出：

Array ( [2] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_diff_ukey() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_diff_ukey() 函数

PHP Array 函数

定义和用法

array_diff_ukey() 返回一个数组，该数组包括了所有出现在 array1 中但是未出现在任何其它参数数组中的键名的值。注意关联关系保留不变。与 array_diff() 不同的是，比较是根据键名而不是值来进行的。

此比较是通过用户提供的回调函数来进行的。如果认为第一个参数小于，等于，或大于第二个参数时必须分别返回一个小于零，等于零，或大于零的整数。

语法

array_diff_ukey(array1,array2,array3...,function)
参数 | 描述
array1 | 必需。与其他数组进行比较的第一个数组。
array2 | 必需。与第一个数组进行比较的数组。
array3 | 可选。与第一个数组进行比较的数组。可以有多个。
function | 必需。用户自定义函数的名称。

例子 1

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
if ($v1>$v2)
    {
    return 1;
    }
else
    {
    return -1;
    }
}
$a1=array(0=>"Dog",1=>"Cat",2=>"Horse");
$a2=array(3=>"Rat",1=>"Bird",5=>"Monkey");
print_r(array_diff_ukey($a1,$a2,"myfunction"));
?>

输出：

Array ( [0] => Dog [2] => Horse )

例子 2

如何为该函数分配多个数组：

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
if ($v1>$v2)
    {
    return 1;
    }
else
    {
    return -1;
    }
}
$a1=array(0=>"Dog",1=>"Cat",2=>"Horse");
$a2=array(3=>"Rat",1=>"Bird",5=>"Monkey");
$a3=array(6=>"Dog",7=>"Donkey",0=>"Horse");
print_r(array_diff_ukey($a1,$a2,$a3,"myfunction"));
?>

输出：

Array ( [2] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_diff() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_diff() 函数

PHP Array 函数

定义和用法

array_diff() 函数返回两个数组的差集数组。该数组包括了所有在被比较的数组中，但是不在任何其他参数数组中的键值。

在返回的数组中，键名保持不变。

语法

array_diff(array1,array2,array3...)
参数 | 描述
array1 | 必需。与其他数组进行比较的第一个数组。
array2 | 必需。与第一个数组进行比较的数组。
array3 | 可选。与第一个数组进行比较的数组。

提示和注释

提示：可用一个或任意多个数组与第一个数组进行比较。

注释：仅有值用于比较。

例子

<?php
$a1=array(0=>"Cat",1=>"Dog",2=>"Horse");
$a2=array(3=>"Horse",4=>"Dog",5=>"Fish");
print_r(array_diff($a1,$a2));
?>

输出：

Array ( [0] => Cat )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_fill() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_fill() 函数

PHP Array 函数

定义和用法

array_fill() 函数用给定的值填充数组，返回的数组有 number 个元素，值为 value。返回的数组使用数字索引，从 start 位置开始并递增。如果 number 为 0 或小于 0，就会出错。

语法

array_fill(start,number,value)
参数 | 描述
start | 必需。数值，规定键的起始索引。
number | 必需。数值，规定填充的数量，其值必须大于 0。
value | 必需。规定要插入的值。

例子

<?php
$a=array_fill(2,3,"Dog");
print_r($a);
?>

输出：

Array ( [2] => Dog [3] => Dog [4] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_filter() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_filter() 函数

PHP Array 函数

定义和用法

array_filter() 函数用回调函数过滤数组中的元素，如果自定义过滤函数返回 true，则被操作的数组的当前值就会被包含在返回的结果数组中， 并将结果组成一个新的数组。如果原数组是一个关联数组，键名保持不变。

语法

array_filter(array,function)
参数 | 描述
array | 必需。规定输入的数组。
function | 必需。自定义函数的名称。

例子

<?php
function myfunction($v)
{
if ($v==="Horse")
    {
    return true;
    }
return false;
}
$a=array(0=>"Dog",1=>"Cat",2=>"Horse");
print_r(array_filter($a,"myfunction"));
?>

输出：

Array ( [2] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_flip() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_flip() 函数

PHP Array 函数

定义和用法

array_flip() 函数返回一个反转后的数组，如果同一值出现了多次，则最后一个键名将作为它的值，所有其他的键名都将丢失。

如果原数组中的值的数据类型不是字符串或整数，函数将报错。

语法

array_flip(array)
参数 | 描述
array | 必需。规定输入的数组。

例子

<?php
$a=array(0=>"Dog",1=>"Cat",2=>"Horse");print_r(array_flip($a));
?>

输出：

Array ( [Dog] => 0 [Cat] => 1 [Horse] => 2 )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_intersect_assoc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_intersect_assoc() 函数

PHP Array 函数

定义和用法

array_intersect_assoc() 函数返回两个或多个数组的交集数组。

与 array_intersect() 函数 不同的是，本函数除了比较键值，还比较键名。返回的数组中元素的键名保持不变。

语法

array_intersect_assoc(array1,array2,array3...)
参数 | 描述
array1 | 必需。与其他数组进行比较的第一个数组。
array2 | 必需。与第一个数组进行比较的数组。
array3 | 可选。与第一个数组进行比较的数组。可以有多个。

例子 1

<?php
$a1=array(0=>"Cat",1=>"Dog",2=>"Horse");
$a2=array(3=>"Horse",1=>"Dog",0=>"Cat");
print_r(array_intersect_assoc($a1,$a2));
?>

输出：

Array ( [0] => Cat [1] => Dog )

例子 2

<?php
$a1=array(0=>"Cat",1=>"Dog",2=>"Horse");
$a2=array(3=>"Horse",1=>"Dog",5=>"Fish");
$a3=array(6=>"Cow",1=>"Dog",8=>"Fish");
print_r(array_intersect_assoc($a1,$a2,$a3));
?>

输出：

Array ( [1] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_intersect_key() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_intersect_key() 函数

PHP Array 函数

定义和用法

array_intersect_key() 函数使用键名比较计算数组的交集。

array_intersect_key() 返回一个数组，该数组包含了所有出现在被比较的数组中并同时出现在所有其它参数数组中的键名的值。

注释：仅有键名用于比较。

语法

array_intersect_key(array1,array2,array3...)
参数 | 描述
array1 | 必需。与其他数组进行比较的第一个数组。
array2 | 必需。与第一个数组进行比较的数组。
array3 | 可选。与第一个数组进行比较的数组。可以有多个。

例子 1

<?php
$a1=array(0=>"Cat",1=>"Dog",2=>"Horse");
$a2=array(2=>"Bird",0=>"Cat",4=>"Fish");
print_r(array_intersect_key($a1,$a2));
?>

输出：

Array ( [0] => Cat [2] => Horse )

例子 2

<?php
$a1=array(0=>"Cat",1=>"Dog",2=>"Horse");
$a2=array(2=>"Bird",3=>"Rat",4=>"Fish");
$a3=array(2=>"Dog",6=>"Cow",7=>"Bird");
print_r(array_intersect_key($a1,$a2,$a3));
?>

输出：

Array ( [2] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_intersect_uassoc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_intersect_uassoc() 函数

PHP Array 函数

定义和用法

array_intersect_uassoc() 函数使用用户自定义的回调函数计算数组的交集，用回调函数比较索引。

array_intersect_uassoc() 返回一个数组，该数组包含了所有在 array1 中也同时出现在所有其它参数数组中的值。返回的数组中键名保持不变。

注意，与 array_intersect() 不同的是除了比较键值，还要比较键名。

此比较是通过用户提供的回调函数来进行的。该函数带有两个参数，即两个要进行对比的键名。如果第一个参数小于第二个参数，则函数要返回一个负数，如果两个参数相等，则要返回 0，如果第一个参数大于第二个参数，则返回一个正数。

语法

array_intersect_uassoc(array1,array2,array3...,function)
参数 | 描述
array1 | 必需。与其他数组进行比较的第一个数组。
array2 | 必需。与第一个数组进行比较的数组。
array3 | 可选。与第一个数组进行比较的数组。可以有多个。
function | 用户自定义函数的名称。

例子 1

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
if ($v1>$v2)
    {
    return 1;
    }
else
    {
    return -1;
    }
}
$a1=array(0=>"Dog",1=>"Cat",2=>"Horse");
$a2=array(3=>"Dog",1=>"Cat",5=>"Horse");
print_r(array_intersect_uassoc($a1,$a2,"myfunction"));
?>

输出：

Array ( [1] => Cat )

例子 2

如何为函数分配多个数组：

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
if ($v1>$v2)
    {
    return 1;
    }
else
    {
    return -1;
    }
}
$a1=array(0=>"Dog",1=>"Cat",2=>"Horse");
$a2=array(0=>"Dog",1=>"Cat",5=>"Horse");
$a3=array(6=>"Bird",0=>"Dog",5=>"Horse");
print_r(array_intersect_uassoc($a1,$a2,$a3,"myfunction"));
?>

输出：

Array ( [0] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_intersect_ukey() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_intersect_ukey() 函数

PHP Array 函数

定义和用法

array_intersect_ukey() 函数用回调函数比较键名来计算数组的交集。

array_intersect_ukey() 返回一个数组，该数组包含了所有出现在 array1 中并同时出现在所有其它参数数组中的键名的值。

此比较是通过用户提供的回调函数来进行的。该函数带有两个参数，即两个要进行对比的键名。如果第一个参数小于第二个参数，则函数要返回一个负数，如果两个参数相等，则要返回 0，如果第一个参数大于第二个参数，则返回一个正数。

语法

array_intersect_uassoc(array1,array2,array3...,function)
参数 | 描述
array1 | 必需。与其他数组进行比较的第一个数组。
array2 | 必需。与第一个数组进行比较的数组。
array3 | 可选。与第一个数组进行比较的数组。可以有多个。
function | 用户自定义函数的名称。

例子 1

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
if ($v1>$v2)
    {
    return 1;
    }
else
    {
    return -1;
    }
}
$a1=array(0=>"Dog",1=>"Cat",2=>"Horse");
$a2=array(3=>"Rat",1=>"Bird",5=>"Monkey");
print_r(array_intersect_ukey($a1,$a2,"myfunction"));
?>

输出：

Array ( [1] => Cat )

例子 2

如何为函数分配多个数组：

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
if ($v1>$v2)
    {
    return 1;
    }
else
    {
    return -1;
    }
}
$a1=array(0=>"Dog",1=>"Cat",2=>"Horse");
$a2=array(0=>"Rat",1=>"Bird",5=>"Monkey");
$a3=array(6=>"Dog",7=>"Donkey",0=>"Horse");
print_r(array_intersect_ukey($a1,$a2,$a3,"myfunction"));
?>

输出：

Array ( [0] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_intersect() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_intersect() 函数

PHP Array 函数

定义和用法

array_intersect() 函数返回两个或多个数组的交集数组。

结果数组包含了所有在被比较数组中，也同时出现在所有其他参数数组中的值，键名保留不变。

注释：仅有值用于比较。

语法

array_intersect(array1,array2,array3...)
参数 | 描述
array1 | 必需。与其他数组进行比较的第一个数组。
array2 | 必需。与第一个数组进行比较的数组。
array3 | 可选。与第一个数组进行比较的数组。可以有多个。

例子

<?php
$a1=array(0=>"Cat",1=>"Dog",2=>"Horse");
$a2=array(3=>"Horse",4=>"Dog",5=>"Fish");
print_r(array_intersect($a1,$a2));
?>

输出：

Array ( [1] => Dog [2] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_key_exists() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_key_exists() 函数

PHP Array 函数

定义和用法

array_key_exists() 函数判断某个数组中是否存在指定的 key，如果该 key 存在，则返回 true，否则返回 false。

语法

array_key_exists(key,array)
参数 | 描述
key | 必需。规定键名。
array | 必需。规定输入的数组。

例子 1

<?php
$a=array("a"=>"Dog","b"=>"Cat");
if (array_key_exists("a",$a))
    {
    echo "Key exists!";
    }
else
    {
    echo "Key does not exist!";
    }
?>

输出：

Key exists!

例子 2

<?php
$a=array("a"=>"Dog","b"=>"Cat");
if (array_key_exists("c",$a))
    {
    echo "Key exists!";
    }
else
    {
    echo "Key does not exist!";
    }
?>

输出：

Key does not exist!

例子 2

<?php
$a=array("Dog",Cat");
if (array_key_exists(0,$a))
    {
    echo "Key exists!";
    }
else
    {
    echo "Key does not exist!";
    }
?>

输出：

Key exists!

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_keys() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_keys() 函数

PHP Array 函数

定义和用法

array_keys() 函数返回包含数组中所有键名的一个新数组。

如果提供了第二个参数，则只返回键值为该值的键名。

如果 strict 参数指定为 true，则 PHP 会使用全等比较 (===) 来严格检查键值的数据类型。

语法

array_keys(array,value)
参数 | 描述
array | 必需。规定输入的数组。
value | 可选。指定值的索引（键）。
strict

可选。与 value 参数一起使用。可能的值：

  • true - 根据类型返回带有指定值的键名。
  • false - 默认值。不依赖类型。

例子 1

<?php
$a=array("a"=>"Horse","b"=>"Cat","c"=>"Dog");
print_r(array_keys($a));
?>

输出：

Array ( [0] => a [1] => b [2] => c )

例子 2

使用 value 参数：

<?php
$a=array("a"=>"Horse","b"=>"Cat","c"=>"Dog");
print_r(array_keys($a,"Dog"));
?>

输出：

Array ( [0] => c)

例子 3

使用 strict 参数 (false)：

<?php
$a=array(10,20,30,"10");
print_r(array_keys($a,"10",false));
?>

输出：

Array ( [0] => 0 [1] => 3 )

例子 4

使用 strict 参数 (true)：

<?php
$a=array(10,20,30,"10");
print_r(array_keys($a,"10",true));
?>

输出：

Array ( [0] => 3)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_map() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_map() 函数

PHP Array 函数

定义和用法

array_map() 函数返回用户自定义函数作用后的数组。回调函数接受的参数数目应该和传递给 array_map() 函数的数组数目一致。

语法

array_map(function,array1,array2,array3...)
参数 | 描述
function | 必需。用户自定义函数的名称，或者是 null。
array1 | 必需。规定数组。
array2 | 可选。规定数组。
array3 | 可选。规定数组。

例子 1

<?php
function myfunction($v)
{
if ($v==="Dog")
    {
    return "Fido";
    }
return $v;
}
$a=array("Horse","Dog","Cat");
print_r(array_map("myfunction",$a));
?>

输出：

Array ( [0] => Horse [1] => Fido [2] => Cat )

例子 2

使用多个参数：

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return "same";
    }
return "different";
}
$a1=array("Horse","Dog","Cat");
$a2=array("Cow","Dog","Rat");
print_r(array_map("myfunction",$a1,$a2));
?>

输出：

Array ( [0] => different [1] => same [2] => different )

例子 3

请看当自定义函数名设置为 null 时的情况：

<?php
$a1=array("Dog","Cat");
$a2=array("Puppy","Kitten");
print_r(array_map(null,$a1,$a2));
?>

输出：

Array (
[0] => Array ( [0] => Dog [1] => Puppy )
[1] => Array ( [0] => Cat [1] => Kitten )
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_merge_recursive() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_merge_recursive() 函数

PHP Array 函数

定义和用法

array_merge_recursive() 函数与 array_merge() 函数 一样，将一个或多个数组的元素的合并起来，一个数组中的值附加在前一个数组的后面。并返回作为结果的数组。

但是，与 array_merge() 不同的是，当有重复的键名时，值不会被覆盖，而是将多个相同键名的值递归组成一个数组。（参见例子 1）

语法

array_merge_recursive(array1,array2,array3...)
参数 | 描述
array1 | 必需。输入的第一个数组。
array2 | 必需。输入的第二个数组。
array3 | 可选。可指定的多个输入数组。

提示和注释

注释：当向 array_merge_recursive() 函数仅仅输入一个数组时，结果与 array_merge() 相同。

例子 1

<?php
$a1=array("a"=>"Horse","b"=>"Dog");
$a2=array("c"=>"Cow","b"=>"Cat");
print_r(array_merge_recursive($a1,$a2));
?>

输出：

Array (
[a] => Horse
[b] => Array ( [0] => Dog [1] => Cat )
[c] => Cow
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_merge() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_merge() 函数

PHP Array 函数

定义和用法

array_merge() 函数把两个或多个数组合并为一个数组。

如果键名有重复，该键的键值为最后一个键名对应的值（后面的覆盖前面的）。如果数组是数字索引的，则键名会以连续方式重新索引。

注释：如果仅仅向 array_merge() 函数输入了一个数组，且键名是整数，则该函数将返回带有整数键名的新数组，其键名以 0 开始进行重新索引。（参见例子 2）

语法

array_merge(array1,array2,array3...)
参数 | 描述
array1 | 必需。输入的第一个数组。
array2 | 必需。输入的第二个数组。
array3 | 可选。可指定的多个输入数组。

例子 1

<?php
$a1=array("a"=>"Horse","b"=>"Dog");
$a2=array("c"=>"Cow","b"=>"Cat");
print_r(array_merge($a1,$a2));
?>

输出：

Array ( [a] => Horse [b] => Cat [c] => Cow )

例子 2

仅使用一个数组参数：

<?php
$a=array(3=>"Horse",4=>"Dog");
print_r(array_merge($a));
?>

输出：

Array ( [0] => Horse [1] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_multisort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_multisort() 函数

PHP Array 函数

定义和用法

array_multisort() 函数对多个数组或多维数组进行排序。

参数中的数组被当成一个表的列并以行来进行排序 - 这类似 SQL 的 ORDER BY 子句的功能。第一个数组是要排序的主要数组。数组中的行（值）比较为相同的话，就会按照下一个输入数组中相应值的大小进行排序，依此类推。

第一个参数是数组，随后的每一个参数可能是数组，也可能是下面的排序顺序标志（排序标志用于更改默认的排列顺序）之一：

  • SORT_ASC - 默认，按升序排列。(A-Z)
  • SORT_DESC - 按降序排列。(Z-A)

随后可以指定排序的类型：

  • SORT_REGULAR - 默认。将每一项按常规顺序排列。
  • SORT_NUMERIC - 将每一项按数字顺序排列。
  • SORT_STRING - 将每一项按字母顺序排列。

语法

array_multisort(array1,sorting order,sorting type,array2,array3...)
参数 | 描述
array1 | 必需。规定输入的数组。
sorting order | 可选。规定排列顺序。可能的值是 SORT_ASC 和 SORT_DESC。
sorting type | 可选。规定排序类型。可能的值是SORT_REGULAR、SORT_NUMERIC和SORT_STRING。
array2 | 可选。规定输入的数组。
array3 | 可选。规定输入的数组。

提示和注释

注释：字符串键名将被保留，但是数字键将被重新索引，从 0 开始，并以 1 递增。

注释：您可以在每个数组后设置排序顺序和排序类型。如果没有设置，每个数组参数会使用默认值。

例子 1

<?php
$a1=array("Dog","Cat");
$a2=array("Fido","Missy");
array_multisort($a1,$a2);
print_r($a1);
print_r($a2);
?>

输出：

Array ( [0] => Cat [1] => Dog )
Array ( [0] => Missy [1] => Fido )

例子 2

当两个值相同时如何排序：

<?php
$a1=array("Dog","Dog","Cat");
$a2=array("Pluto","Fido","Missy");
array_multisort($a1,$a2);
print_r($a1);
print_r($a2);
?>

输出：

Array ( [0] => Cat [1] => Dog [2] => Dog )
Array ( [0] => Missy [1] => Fido [2] => Pluto )

例子 3

带有排序参数：

<?php
$a1=array("Dog","Dog","Cat");
$a2=array("Pluto","Fido","Missy");
array_multisort($a1,SORT_ASC,$a2,SORT_DESC);
print_r($a1);
print_r($a2);
?>

输出：

Array ( [0] => Cat [1] => Dog [2] => Dog )
Array ( [0] => Missy [1] => Pluto [2] => Fido )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_pad() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_pad() 函数

PHP Array 函数

定义和用法

array_pad() 函数向一个数组插入带有指定值的指定数量的元素。

语法

array_pad(array,size,value)
参数 | 描述
array | 必需。规定数组。
size | 必需。指定的长度。整数则填补到右侧，负数则填补到左侧。
value | 必需。用来填补的值。

提示和注释

提示：如何设置了负的长度值，该函数会在原始数组之前插入新的元素。（参见例子 2）

注释：如果 size 参数小于原始数组的长度，该函数不会删除任何元素。

例子 1

<?php
$a=array("Dog","Cat");
print_r(array_pad($a,5,0));
?>

输出：

Array ( [0] => Dog [1] => Cat [2] => 0 [3] => 0 [4] => 0 )

例子 2

带有负的 size 参数：

<?php
$a=array("Dog","Cat");
print_r(array_pad($a,-5,0));
?>

输出：

Array ( [0] => 0 [1] => 0 [2] => 0 [3] => Dog [4] => Cat )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_pop() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_pop() 函数

PHP Array 函数

定义和用法

array_pop() 函数删除数组中的最后一个元素。

语法

array_pop(array)
参数 | 描述
array | 必需。规定输入的数组参数。

例子

<?php
$a=array("Dog","Cat","Horse");
array_pop($a);
print_r($a);
?>

输出：

Array ( [0] => Dog [1] => Cat )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_product() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_product() 函数

PHP Array 函数

定义和用法

array_product() 函数计算并返回数组中所有值的乘积。

语法

array_product(array)
参数 | 描述
array | 必需。规定输入的数组参数。

例子

<?php
$a=array(5,5);
echo(array_product($a));
?>

输出：

25

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_push() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_push() 函数

PHP Array 函数

定义和用法

array_push() 函数向第一个参数的数组尾部添加一个或多个元素（入栈），然后返回新数组的长度。

该函数等于多次调用 $array[] = $value。

语法

array_push(array,value1,value2...)
参数 | 描述
array | 必需。规定一个数组。
value1 | 必需。规定要添加的值。
value2 | 可选。规定要添加的值。

提示和注释

注释：即使数组中有字符串键名，您添加的元素也始终是数字键。（参见例子 2）

注释：如果用 array_push() 来给数组增加一个单元，还不如用 $array[] =，因为这样没有调用函数的额外负担。

注释：如果第一个参数不是数组，array_push() 将发出一条警告。这和 $var[] 的行为不同，后者会新建一个数组。

例子 1

<?php
$a=array("Dog","Cat");
array_push($a,"Horse","Bird");
print_r($a);
?>

输出：

Array ( [0] => Dog [1] => Cat [2] => Horse [3] => Bird )

例子 2

带有字符串键的数组：

<?php
$a=array("a"=>"Dog","b"=>"Cat");
array_push($a,"Horse","Bird");
print_r($a);
?>

输出：

Array ( [a] => Dog [b] => Cat [0] => Horse [1] => Bird )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_rand() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_rand() 函数

PHP Array 函数

定义和用法

array_rand() 函数从数组中随机选出一个或多个元素，并返回。

第二个参数用来确定要选出几个元素。如果选出的元素不止一个，则返回包含随机键名的数组，否则返回该元素的键名。

注释：自 PHP 4.2.0 起，不再需要用 srand() 或 mt_srand() 函数给随机数发生器播种，现已被自动完成。

语法

array_rand(array,number)
参数 | 描述
array | 必需。规定输入的数组参数。
number | 可选。默认是 1。规定返回多少个随机的元素。

例子 1

<?php
$a=array("a"=>"Dog","b"=>"Cat","c"=>"Horse");
print_r(array_rand($a,1));
?>

输出：

b

例子 2

带有字符串键的数组：

<?php
$a=array("a"=>"Dog","b"=>"Cat","c"=>"Horse");
print_r(array_rand($a,2));
?>

输出：

Array ( [0] => c [1] => b )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_reduce() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_reduce() 函数

PHP Array 函数

定义和用法

array_reduce() 函数用回调函数迭代地将数组简化为单一的值。如果指定第三个参数，则该参数将被当成是数组中的第一个值来处理，或者如果数组为空的话就作为最终返回值。

语法

array_reduce(array,function,initial)
参数 | 描述
array | 必需。规定输入的数组。
function | 必需。规定自定义回调函数的名称。
initial | 可选。如果规定了该参数，该参数将作为数组中的第一个值来处理。

例子 1

<?php
function myfunction($v1,$v2)
{
return $v1 . "-" . $v2;
}
$a=array("Dog","Cat","Horse");
print_r(array_reduce($a,"myfunction"));
?>

输出：

-Dog-Cat-Horse

例子 2

带有 initial 参数：

<?php
function myfunction($v1,$v2)
{
return $v1 . "-" . $v2;
}
$a=array("Dog","Cat","Horse");
print_r(array_reduce($a,"myfunction",5));
?>

输出：

5-Dog-Cat-Horse

例子 3

返回总和：

<?php
function myfunction($v1,$v2)
{
return $v1+$v2;
}
$a=array(10,15,20);
print_r(array_reduce($a,"myfunction",5));
?>

输出：

50

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_reverse() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_reverse() 函数

PHP Array 函数

定义和用法

array_reverse() 函数将原数组中的元素顺序翻转，创建新的数组并返回。如果第二个参数指定为 true，则元素的键名保持不变，否则键名将丢失。

语法

array_reverse(array,preserve)
参数 | 描述
array | 必需。规定数组。
preserve | 可选。规定是否保留原始数组的键名。可能的值：true 和 false。 这个参数是 PHP 4.0.3 中新加的。

例子

<?php
$a=array("a"=>"Dog","b"=>"Cat","c"=>"Horse");
print_r(array_reverse($a));
?>

输出：

Array ( [c] => Horse [b] => Cat [a] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_search() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_search() 函数

PHP Array 函数

定义和用法

array_search() 函数与 in_array() 一样，在数组中查找一个键值。如果找到了该值，匹配元素的键名会被返回。如果没找到，则返回 false。

在 PHP 4.2.0 之前，函数在失败时返回 null 而不是 false。

如果第三个参数 strict 被指定为 true，则只有在数据类型和值都一致时才返回相应元素的键名。

语法

array_search(value,array,strict)
参数 | 描述
value | 必需。规定在数组中搜索的值。
array | 必需。被搜索的数组。
strict

可选。可能的值：

  • true
  • false - 默认

如果值设置为 true，还将在数组中检查给定值的类型。（参见例子 2）

例子 1

<?php
$a=array("a"=>"Dog","b"=>"Cat","c"=>"Horse");
echo array_search("Dog",$a);
?>

输出：

a

例子 2

<?php
$a=array("a"=>"5","b"=>5,"c"=>"5");
echo array_search(5,$a,true);
?>

输出：

b

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_shift() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_shift() 函数

PHP Array 函数

定义和用法

array_shift() 函数删除数组中的第一个元素，并返回被删除元素的值。

注释：如果键是数字的，所有元素都将获得新的键，从 0 开始，并以 1 递增。（参见例子 2）。

语法

array_shift(array)
参数 | 描述
array | 必需。规定输入的数组。

例子 1

<?php
$a=array("a"=>"Dog","b"=>"Cat","c"=>"Horse");
echo array_shift($a);
print_r ($a);
?>

输出：

Dog
Array ( [b] => Cat [c] => Horse )

例子 2

带有数字键：

<?php
$a=array(0=>"Dog",1=>"Cat",2=>"Horse");
echo array_shift($a);
print_r ($a);
?>

输出：

Dog
Array ( [0] => Cat [1] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_slice() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_slice() 函数

PHP Array 函数

定义和用法

array_slice() 函数在数组中根据条件取出一段值，并返回。

注释：如果数组有字符串键，所返回的数组将保留键名。（参见例子 4）

语法

array_slice(array,offset,length,preserve)
参数 | 描述
array | 必需。规定输入的数组。
offset

必需。数值。规定取出元素的开始位置。

如果是正数，则从前往后开始取，如果是负值，从后向前取 offset 绝对值。
length

可选。数值。规定被返回数组的长度。

如果是负数，则从后向前，选取该值绝对值数目的元素。如果未设置该值，则返回所有元素。
preserve

可选。可能的值：

  • true - 保留键
  • false - 默认 - 重置键

例子 1

<?php
$a=array(0=>"Dog",1=>"Cat",2=>"Horse",3=>"Bird");
print_r(array_slice($a,1,2));
?>

输出：

Array ( [0] => Cat [1] => Horse )

例子 2

带有负的 offset 参数：

<?php
$a=array(0=>"Dog",1=>"Cat",2=>"Horse",3=>"Bird");
print_r(array_slice($a,-2,1));
?>

输出：

Array ( [0] => Horse )

例子 3

preserve 参数设置为 true：

<?php
$a=array(0=>"Dog",1=>"Cat",2=>"Horse",3=>"Bird");
print_r(array_slice($a,1,2,true));
?>

输出：

Array ( [1] => Cat [2] => Horse )

例子 4

带有字符串键：

<?php
$a=array("a"=>"Dog","b"=>"Cat","c"=>"Horse","d"=>"Bird");
print_r(array_slice($a,1,2));
?>

输出：

Array ( [b] => Cat [c] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_splice() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_splice() 函数

PHP Array 函数

定义和用法

array_splice() 函数与 array_slice() 函数类似，选择数组中的一系列元素，但不返回，而是删除它们并用其它值代替。

如果提供了第四个参数，则之前选中的那些元素将被第四个参数指定的数组取代。

最后生成的数组将会返回。

语法

array_splice(array,offset,length,array)
参数 | 描述
array | 必需。规定数组。
offset | 必需。数值。如果 offset 为正，则从输入数组中该值指定的偏移量开始移除。如果 offset 为负，则从输入数组末尾倒数该值指定的偏移量开始移除。
length | 可选。数值。如果省略该参数，则移除数组中从 offset 到 结尾的所有部分。如果指定了 length 并且为正值，则移除这么多元素。如果指定了 length 且为负值，则移除从 offset 到数组末尾倒数 length 为止中间所有的元素。
array | 被移除的元素由此数组中的元素替代。如果没有移除任何值，则此数组中的元素将插入到指定位置。

提示和注释

提示：如果函数没有删除任何元素 (length=0)，则替代数组将从 start 参数的位置插入。（参见例子 3）

注释：不保留替代数组中的键。

例子 1

<?php
$a1=array(0=>"Dog",1=>"Cat",2=>"Horse",3=>"Bird");
$a2=array(0=>"Tiger",1=>"Lion");
array_splice($a1,0,2,$a2);
print_r($a1);
?>

输出：

Array ( [0] => Tiger [1] => Lion [2] => Horse [3] => Bird )

例子 2

与例子 1 相同，但是输出返回的数组：

<?php
$a1=array(0=>"Dog",1=>"Cat",2=>"Horse",3=>"Bird");
$a2=array(0=>"Tiger",1=>"Lion");
print_r(array_splice($a1,0,2,$a2));
?>

输出：

Array ( [0] => Dog [1] => Cat )

例子 3

length 参数设置为 0：

<?php
$a1=array(0=>"Dog",1=>"Cat");
$a2=array(0=>"Tiger",1=>"Lion");
array_splice($a1,1,0,$a2);
print_r($a1);
?>

输出：

Array ( [0] => Dog [1] => Tiger [2] => Lion [3] => Cat )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_sum() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_sum() 函数

PHP Array 函数

定义和用法

array_sum() 函数返回数组中所有值的总和。

如果所有值多是整数，则返回一个整数值。如果其中有一个或多个值是浮点数，则返回浮点数。

PHP 4.2.1 之前的版本修改了传入的数组本身，将其中的字符串值转换成数值（大多数情况下都转换成了零，根据具体制而定）。

语法

array_sum(array)
参数 | 描述
array | 必需。规定输入的数组。

例子

<?php
$a=array(0=>"5",1=>"15",2=>"25");
echo array_sum($a);
?>

输出：

45

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_udiff_assoc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_udiff_assoc() 函数

PHP Array 函数

定义和用法

array_udiff_assoc() 函数返回 array1 中存在但其它数组中都不存在的部分。

注意与 array_diff() 以及 array_udiff() 不同的是键名也用于比较。同时进行键名和键值的比较。如 "a"=>1 和 "b"=>1 这两个元素是不相等的。

数组数据的比较是用用户提供的回调函数进行的。在此方面和 array_diff_assoc() 的行为正好相反，后者是用内部函数进行比较的。

array_udiff_assoc() 函数的 function 参数指定的函数用于比较元素是否相等。function 函数带有两个将进行比较的参数。如果第一个参数小于第二个参数，则函数返回一个负数，如果两个参数相等，则要返回 0，如果第一个参数大于第二个，则返回一个正数。

语法

array_udiff_assoc(array1,array2,array3...,function)
参数 | 描述
array1 | 必需。被比较的数组。
array2 | 必需。用来做比较的数组。
array3 | 可选。用来做比较的数组，可有多个。
function | 可选。自定义的比较回调函数。

例子

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
return 1;
}
$a1=array("a"=>"Cat","b"=>"Dog","c"=>"Horse");
$a2=array("a"=>"Cat","b"=>"Horse","c"=>"Dog");
print_r(array_udiff_assoc($a1,$a2,"myfunction"));
?>

输出：

Array ( [b] => Dog [c] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_udiff_uassoc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_udiff_uassoc() 函数

PHP Array 函数

定义和用法

array_udiff_uassoc() 函数返回 array1 数组中存在但其它数组中都不存在的部分。返回的数组中键名保持不变。

注意与 array_diff() 以及 array_udiff() 不同的是键名也用于比较。同时进行键名和键值的比较，如 "a"=>1 和 "b"=>1 这两个元素是不相等的。

对键名（索引）的检查也是由回调函数 function1 进行的。这和 array_udiff_assoc() 的行为不同，后者是用内部函数比较索引的。

数组数据的比较是使用用户提供的回调函数 function2 进行的。在此方面和 array_diff_assoc() 的行为正好相反，后者是用内部函数进行比较的。

这两个函数都带有两个将进行比较的参数。如果第一个参数小于第二个参数，则函数返回一个负数，如果两个参数相等，则要返回 0，如果第一个参数大于第二个，则返回一个正数。

语法

array_udiff_uassoc(array1,array2,array3...,function1,function2)
参数 | 描述
array1 | 必需。被比较的数组。
array2 | 必需。用来做比较的数组。
array3 | 可选。用来做比较的数组，可有多个。
function1 | 必需。比较键名的自定义函数。
function2 | 必需。比较值的自定义函数。

注释：function1 指定的函数用于比较键名是否相等。function2 指定的函数用于比较键值是否相等。

例子

<?php
function myfunction_key($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
return 1;
}
function myfunction_value($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
return 1;
}
$a1=array("a"=>"Cat","b"=>"Dog","c"=>"Horse");
$a2=array("a"=>"Cat","b"=>"Dog","c"=>"Fish");
print_r(array_udiff_uassoc($a1,$a2,"myfunction_key","myfunction_value"));
?>

输出：

Array ( [c] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_udiff() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_udiff() 函数

PHP Array 函数

定义和用法

array_udiff() 函数返回一个数组，该数组包括了所有在被比较数组中，但是不在任何其它参数数组中的值，键名保留不变。

array_udiff() 函数与 array_diff() 函数 的行为不同，后者用内部函数进行比较。

数据的比较是用 array_udiff() 函数的 function 进行的。function 函数带有两个将进行比较的参数。如果第一个参数小于第二个参数，则函数返回一个负数，如果两个参数相等，则要返回 0，如果第一个参数大于第二个，则返回一个正数。

语法

array_udiff(array1,array2,array3...,function)
参数 | 描述
array1 | 必需。被比较的数组。
array2 | 必需。用来做比较的数组。
array3 | 可选。用来做比较的数组，可有多个。
function | 可选。自定义的比较回调函数。

注释和提示

注释：该函数只进行键值的比较，不比较键名。如 "a"=>1 和 "b"=>1 这两个元素视作相等的。

注释：array_udiff() 函数仅检查多维数组中的一维。

例子

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
return 1;
}
$a1=array("a"=>"Cat","b"=>"Dog","c"=>"Horse");
$a2=array(1=>"Cat",2=>"Dog",3=>"Fish");
print_r(array_udiff($a1,$a2,"myfunction"));
?>

输出：

Array ( [c] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_uintersect_assoc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_uintersect_assoc() 函数

PHP Array 函数

定义和用法

array_uintersect_assoc() 函数带索引检查计算数组的交集，用回调函数比较数据。

array_uintersect_assoc() 返回一个数组，该数组包含了所有在 array1 中也同时出现在所有其它参数数组中的值。

注意，与 array_uintersect() 不同的是键名也要比较。数据（键值）是用回调函数比较的。

语法

array_uintersect_assoc(array1,array2,array3...,function)
参数 | 描述
array1 | 必需。被比较的数组。
array2 | 必需。用来做比较的数组。
array3 | 可选。用来做比较的数组，可有多个。
function | 必需。自定义函数的名称。

说明

使用用户自定义的回调函数 function 来计算两个或多个数组的交集（即在 array1 中存在，同时也在其它任何数组中存在的所有数组元素），并返回结果数组。

同时进行键名和键值的比较，如 "a"=>1 和 "b"=>1 这两个元素是不相等的。

function 参数指定的函数用于比较元素是否相等。function 函数带有两个将进行比较的参数。如果第一个参数小于第二个参数，则函数返回一个负数，如果两个参数相等，则要返回 0，如果第一个参数大于第二个，则返回一个正数。

返回的数组中键名保持不变。

例子

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
return 1;
}
$a1=array("a"=>"Cat","b"=>"Dog","c"=>"Horse");
$a2=array("a"=>"Cat","b"=>"Horse","c"=>"Dog");
print_r(array_uintersect_assoc($a1,$a2,"myfunction"));
?>

输出：

Array ( [a] => Cat )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_uintersect_uassoc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_uintersect_uassoc() 函数

PHP Array 函数

定义和用法

array_uintersect_uassoc 函数带索引检查计算数组的交集，用回调函数来比较数据和索引。

array_uintersect_uassoc() 返回一个数组，该数组包含了所有在 array1 中也同时出现在所有其它参数数组中的值。

注意，与 array_uintersect() 不同的是键名也要比较。键值和键名（索引）都是用回调函数比较的。

语法

array_uintersect_uassoc(array1,array2,array3...,function1,function2)
参数 | 描述
array1 | 必需。被比较的数组。
array2 | 必需。用来做比较的数组。
array3 | 可选。用来做比较的数组，可有多个。
function1 | 必需。比较键名的自定义函数。
function2 | 必需。比较键值的自定义函数。

说明

使用用户自定义的回调函数 function1 和 function2 来计算两个或多个数组的交集（即在 array1 中存在，同时也在其它任何数组中存在的所有数组元素），并返回结果数组。

同时进行键名和键值的比较，如 "a"=>1 和 "b"=>1 这两个元素是不相等的。

function1 指定的函数用于比较键名是否相等。function2 指定的函数用于比较键值是否相等。这两个函数都带有两个将进行比较的参数。如果第一个参数小于第二个参数，则函数返回一个负数，如果两个参数相等，则要返回 0，如果第一个参数大于第二个，则返回一个正数。

返回的数组中键名保持不变。

例子

<?php
function myfunction_key($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
return 1;
}

function myfunction_value($v1,$v2)
{
if ($v1===$v2)
    {
    return 0;
    }
return 1;
}
$a1=array("a"=>"Cat","b"=>"Dog","c"=>"Horse");
$a2=array("a"=>"Cat","b"=>"Dog","c"=>"Dog");
print_r(array_uintersect_uassoc($a1,$a2,"myfunction_key","myfunction_value"));
?>

输出：

Array ( [a] => Cat [b] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_uintersect() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_uintersect() 函数

PHP Array 函数

定义和用法

array_uintersect() 函数计算数组的交集，用回调函数比较数据。

array_uintersect() 返回一个数组，该数组包含了所有在 array1 中也同时出现在所有其它参数数组中的值。数据（键值）比较是用回调函数进行的。

语法

array_uintersect(array1,array2,array3...,function)
参数 | 描述
array1 | 必需。被比较的数组。
array2 | 必需。用来做比较的数组。
array3 | 可选。用来做比较的数组，可有多个。
function | 必需。自定义函数的名称。

说明

使用用户自定义的回调函数 function 来计算两个或多个数组的交集（即在 array1 中存在同时也在其它任何数组中存在的所有数组元素），并返回结果数组。

只进行键值的比较，不比较键名，如 "a"=>1 和 "b"=>1 这两个元素视作相等的。

function 参数指定的函数用于比较元素是否相等。function 函数带有两个将进行比较的参数。如果第一个参数小于第二个参数，则函数返回一个负数，如果两个参数相等，则要返回 0，如果第一个参数大于第二个，则返回一个正数。

返回的数组中键名保持不变。

例子

<?php
function myfunction($v1,$v2)
{
if ($v1===$v2)
  {
  return 0;
  }
if ($v1 > $v2) return 1;
  {
  return -1;
  }
return 1;
}
$a1=array("a"=>"Cat","b"=>"Dog","c"=>"Horse");
$a2=array(1=>"Cat",2=>"Dog",3=>"Fish");
print_r(array_uintersect($a1,$a2,"myfunction"));
?>

输出：

Array ( [a] => Cat [b] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_unique() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_unique() 函数

PHP Array 函数

定义和用法

array_unique() 函数移除数组中的重复的值，并返回结果数组。

当几个数组元素的值相等时，只保留第一个元素，其他的元素被删除。

返回的数组中键名不变。

语法

array_unique(array)
参数 | 描述
array | 必需。规定输入的数组。

说明

array_unique() 先将值作为字符串排序，然后对每个值只保留第一个遇到的键名，接着忽略所有后面的键名。这并不意味着在未排序的 array 中同一个值的第一个出现的键名会被保留。

提示和注释

注释：被返回的数组将保持第一个数组元素的键类型。

例子

<?php
$a=array("a"=>"Cat","b"=>"Dog","c"=>"Cat");
print_r(array_unique($a));
?>

输出：

Array ( [a] => Cat [b] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_unshift() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_unshift() 函数

PHP Array 函数

定义和用法

array_unshift() 函数在数组开头插入一个或多个元素。

被加上的元素作为一个整体添加，这些元素在数组中的顺序和在参数中的顺序一样。

该函数会返回数组中元素的个数。

语法

array_unshift(array,value1,value2,value3...)
参数 | 描述
array | 必需。规定输入的数组。
value1 | 必需。规定插入的值。
value2 | 可选。规定插入的值。
value3 | 可选。规定插入的值。

提示和注释

注释：所有的数值键名将修改为从零开始重新计数，所有的字符串键名保持不变。

例子 1

<?php
$a=array("a"=>"Cat","b"=>"Dog");
array_unshift($a,"Horse");
print_r($a);
?>

输出：

Array ( [0] => Horse [a] => Cat [b] => Dog )

例子 2

返回键值：

<?php
$a=array("a"=>"Cat","b"=>"Dog");
print_r(array_unshift($a,"Horse"));
?>

输出：

3

例子 3

数组带有数值键：

<?php
$a=array(0=>"Cat",1=>"Dog");
array_unshift($a,"Horse");
print_r($a);
?>

输出：

Array ( [0] => Horse [1] => Cat [2] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_values() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_values() 函数

PHP Array 函数

定义和用法

array_values() 函数返回一个包含给定数组中所有键值的数组，但不保留键名。

语法

array_values(array)
参数 | 描述
array | 必需。规定给定的数组。

提示和注释

提示：被返回的数组将使用数值键，从 0 开始且以 1 递增。

例子

<?php
$a=array("a"=>"Cat","b"=>"Dog","c"=>"Horse");
print_r(array_values($a));
?>

输出：

Array ( [0] => Cat [1] => Dog [2] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_walk_recursive() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_walk_recursive() 函数

PHP Array 函数

定义和用法

与 array_walk() 函数 类似，array_walk_recursive() 函数对数组中的每个元素应用回调函数。不一样的是，如果原数组中的元素也是数组，就会递归地调用回调函数，也就是说，会递归到更深层的数组中去。

典型情况下，function 接受两个参数。array 参数的值作为第一个，键名作为第二个。如果提供了可选参数 userdata ，将被作为第三个参数传递给回调函数。

如果回调函数需要直接作用于数组中的值，可以将回调函数的第一个参数指定为引用，这样对这些单元的任何改变也将会改变原始数组本身。

语法

array_walk_recursive(array,function,userdata)
参数 | 描述
array | 必需。规定数组。
function | 必需。用户自定义函数的名称。
userdata | 可选。用户输入的值，可作为回调函数的参数。

例子

<?php
function myfunction($value,$key)
{
echo "The key $key has the value $value<br />";
}
$a1=array("a"=>"Cat","b"=>"Dog");
$a2=array($a1,"1"=>"Bird","2"=>"Horse");
array_walk_recursive($a2,"myfunction");
?>

输出：

The key a has the value Cat
The key b has the value Dog
The key 1 has the value Bird
The key 2 has the value Horse

PHP Array 函数

PHP 参考手册
PHP 测验


PHP array_walk() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array_walk() 函数

PHP Array 函数

定义和用法

array_walk() 函数对数组中的每个元素应用回调函数。如果成功则返回 TRUE，否则返回 FALSE。

典型情况下 function 接受两个参数。array 参数的值作为第一个，键名作为第二个。如果提供了可选参数 userdata ，将被作为第三个参数传递给回调函数。

如果 function 函数需要的参数比给出的多，则每次 array_walk() 调用 function 时都会产生一个 E_WARNING 级的错误。这些警告可以通过在 array_walk() 调用前加上 PHP 的错误操作符 @ 来抑制，或者用 error_reporting()。

语法

array_walk(array,function,userdata...)
参数 | 描述
array | 必需。规定数组。
function | 必需。用户自定义函数的名称。
userdata | 可选。用户输入的值，可作为回调函数的参数。

提示和注释

提示：您可以为函数设置一个或多个参数。

注释：如果回调函数需要直接作用于数组中的值，可以将回调函数的第一个参数指定为引用：&$value。（参见例子 3）

注释：将键名和 userdata 传递到 function 中是 PHP 4.0 新增加的。

例子 1

<?php
function myfunction($value,$key)
{
echo "The key $key has the value $value<br />";
}
$a=array("a"=>"Cat","b"=>"Dog","c"=>"Horse");
array_walk($a,"myfunction");
?>

输出：

The key a has the value Cat
The key b has the value Dog
The key c has the value Horse

例子 2

带有一个参数：

<?php
function myfunction($value,$key,$p)
{
echo "$key $p $value<br />";
}
$a=array("a"=>"Cat","b"=>"Dog","c"=>"Horse");
array_walk($a,"myfunction","has the value");
?>

输出：

a has the value Cat
b has the value Dog
c has the value Horse

例子 3

改变数组元素的值（请注意 &$value）：

<?php
function myfunction(&$value,$key)
{
$value="Bird;
}
$a=array("a"=>"Cat","b"=>"Dog","c"=>"Horse");
array_walk($a,"myfunction");
print_r($a);
?>

输出：

Array ( [a] => Bird [b] => Bird [c] => Bird )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP Array 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Array 函数

  • Previous Page
  • Next Page

PHP Array 简介

array 函数允许您对数组进行操作。

PHP 支持单维和多维的数组。同时提供了用数据库查询结果来构造数组的函数。

安装

array 函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

PHP Array 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
array() | 创建数组。 | 3
array_change_key_case() | 返回其键均为大写或小写的数组。 | 4
array_chunk() | 把一个数组分割为新的数组块。 | 4
array_combine() | 通过合并两个数组来创建一个新数组。 | 5
array_count_values() | 用于统计数组中所有值出现的次数。 | 4
array_diff() | 返回两个数组的差集数组。 | 4
array_diff_assoc() | 比较键名和键值，并返回两个数组的差集数组。 | 4
array_diff_key() | 比较键名，并返回两个数组的差集数组。 | 5
array_diff_uassoc() | 通过用户提供的回调函数做索引检查来计算数组的差集。 | 5
array_diff_ukey() | 用回调函数对键名比较计算数组的差集。 | 5
array_fill() | 用给定的值填充数组。 | 4
array_filter() | 用回调函数过滤数组中的元素。 | 4
array_flip() | 交换数组中的键和值。 | 4
array_intersect() | 计算数组的交集。 | 4
array_intersect_assoc() | 比较键名和键值，并返回两个数组的交集数组。 | 4
array_intersect_key() | 使用键名比较计算数组的交集。 | 5
array_intersect_uassoc() | 带索引检查计算数组的交集，用回调函数比较索引。 | 5
array_intersect_ukey() | 用回调函数比较键名来计算数组的交集。 | 5
array_key_exists() | 检查给定的键名或索引是否存在于数组中。 | 4
array_keys() | 返回数组中所有的键名。 | 4
array_map() | 将回调函数作用到给定数组的单元上。 | 4
array_merge() | 把一个或多个数组合并为一个数组。 | 4
array_merge_recursive() | 递归地合并一个或多个数组。 | 4
array_multisort() | 对多个数组或多维数组进行排序。 | 4
array_pad() | 用值将数组填补到指定长度。 | 4
array_pop() | 将数组最后一个单元弹出（出栈）。 | 4
array_product() | 计算数组中所有值的乘积。 | 5
array_push() | 将一个或多个单元（元素）压入数组的末尾（入栈）。 | 4
array_rand() | 从数组中随机选出一个或多个元素，并返回。 | 4
array_reduce() | 用回调函数迭代地将数组简化为单一的值。 | 4
array_reverse() | 将原数组中的元素顺序翻转，创建新的数组并返回。 | 4
array_search() | 在数组中搜索给定的值，如果成功则返回相应的键名。 | 4
array_shift() | 删除数组中的第一个元素，并返回被删除元素的值。 | 4
array_slice() | 在数组中根据条件取出一段值，并返回。 | 4
array_splice() | 把数组中的一部分去掉并用其它值取代。 | 4
array_sum() | 计算数组中所有值的和。 | 4
array_udiff() | 用回调函数比较数据来计算数组的差集。 | 5
array_udiff_assoc() | 带索引检查计算数组的差集，用回调函数比较数据。 | 5
array_udiff_uassoc() | 带索引检查计算数组的差集，用回调函数比较数据和索引。 | 5
array_uintersect() | 计算数组的交集，用回调函数比较数据。 | 5
array_uintersect_assoc() | 带索引检查计算数组的交集，用回调函数比较数据。 | 5
array_uintersect_uassoc() | 带索引检查计算数组的交集，用回调函数比较数据和索引。 | 5
array_unique() | 删除数组中重复的值。 | 4
array_unshift() | 在数组开头插入一个或多个元素。 | 4
array_values() | 返回数组中所有的值。 | 4
array_walk() | 对数组中的每个成员应用用户函数。 | 3
array_walk_recursive() | 对数组中的每个成员递归地应用用户函数。 | 5
arsort() | 对数组进行逆向排序并保持索引关系。 | 3
asort() | 对数组进行排序并保持索引关系。 | 3
compact() | 建立一个数组，包括变量名和它们的值。 | 4
count() | 计算数组中的元素数目或对象中的属性个数。 | 3
current() | 返回数组中的当前元素。 | 3
each() | 返回数组中当前的键／值对并将数组指针向前移动一步。 | 3
end() | 将数组的内部指针指向最后一个元素。 | 3
extract() | 从数组中将变量导入到当前的符号表。 | 3
in_array() | 检查数组中是否存在指定的值。 | 4
key() | 从关联数组中取得键名。 | 3
krsort() | 对数组按照键名逆向排序。 | 3
ksort() | 对数组按照键名排序。 | 3
list() | 把数组中的值赋给一些变量。 | 3
natcasesort() | 用“自然排序”算法对数组进行不区分大小写字母的排序。 | 4
natsort() | 用“自然排序”算法对数组排序。 | 4
next() | 将数组中的内部指针向前移动一位。 | 3
pos() | current() 的别名。 | 3
prev() | 将数组的内部指针倒回一位。 | 3
range() | 建立一个包含指定范围的元素的数组。 | 3
reset() | 将数组的内部指针指向第一个元素。 | 3
rsort() | 对数组逆向排序。 | 3
shuffle() | 把数组中的元素按随机顺序重新排列。 | 3
sizeof() | count() 的别名。 | 3
sort() | 对数组排序。 | 3
uasort() | 使用用户自定义的比较函数对数组中的值进行排序并保持索引关联。 | 3
uksort() | 使用用户自定义的比较函数对数组中的键名进行排序。 | 3
usort() | 使用用户自定义的比较函数对数组中的值进行排序。 | 3

PHP Array 常量

PHP：指示支持该常量的最早的 PHP 版本。

常量 | 描述 | PHP
CASE_LOWER | 用在 array_change_key_case() 中将数组键名转换成小写字母。 |
CASE_UPPER | 用在 array_change_key_case() 中将数组键名转换成大写字母。 |
SORT_ASC | 用在 array_multisort() 函数中，使其升序排列。 |
SORT_DESC | 用在 array_multisort() 函数中，使其降序排列。 |
SORT_REGULAR | 用于对对象进行通常比较。 |
SORT_NUMERIC | 用于对对象进行数值比较。 |
SORT_STRING | 用于对对象进行字符串比较。 |
SORT_LOCALE_STRING | 基于当前区域来对对象进行字符串比较。 | 4
COUNT_NORMAL |  |
COUNT_RECURSIVE |  |
EXTR_OVERWRITE |  |
EXTR_SKIP |  |
EXTR_PREFIX_SAME |  |
EXTR_PREFIX_ALL |  |
EXTR_PREFIX_INVALID |  |
EXTR_PREFIX_IF_EXISTS |  |
EXTR_IF_EXISTS |  |
EXTR_REFS |  |
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP array()

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP array()

PHP Array 函数

定义和用法

array() 创建数组，带有键和值。如果在规定数组时省略了键，则生成一个整数键，这个 key 从 0 开始，然后以 1 进行递增。

要用 array() 创建一个关联数组，可使用 => 来分隔键和值。

要创建一个空数组，则不传递参数给 array()：

$new = array();

注意：array() 实际上是一种语言结构 (language construct)，通常用来定义直接量数组，但它的用法和函数的用法很相似，所以我们把它也列到手册中。

语法

array(key => value)
参数 | 描述
key | 可选。规定 key，类型是数值或字符串。如果未设置，则生成整数类型的 key。
value | 必需。规定值。

例子 1

<?php
$a=array("a"=>"Dog","b"=>"Cat","c"=>"Horse");
print_r($a);
?>

输出：

Array ( [a] => Dog [b] => Cat [c] => Horse )

例子 2

<?php
$a=array("Dog","Cat","Horse");
print_r($a);
?>

输出：

Array ( [0] => Dog [1] => Cat [2] => Horse )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP arsort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP arsort() 函数

PHP Array 函数

定义和用法

arsort() 函数对数组进行逆向排序并保持索引关系。主要用于对那些单元顺序很重要的结合数组进行排序。

可选的第二个参数包含了附加的排序标识。

如果成功则返回 TRUE，否则返回 FALSE。

语法

arsort(array,sorttype)
参数 | 描述
array | 必需。输入的数组。
sorttype

可选。规定如何排列数组的值。可能的值：

  • SORT_REGULAR - 默认。以它们原来的类型进行处理（不改变类型）。
  • SORT_NUMERIC - 把值作为数字来处理
  • SORT_STRING - 把值作为字符串来处理
  • SORT_LOCALE_STRING - 把值作为字符串来处理，基于本地设置*。

*：该值是 PHP 4.4.0 和 5.0.2 新加的。在 PHP 6 之前，使用了系统的区域设置，可以用 setlocale() 来改变。自 PHP 6 起，必须用 i18n_loc_set_default() 函数。

例子

<?php
$my_array = array("a" => "Dog", "b" => "Cat", "c" => "Horse");

arsort($my_array);
print_r($my_array);
?>

输出：

Array
(
[c] => Horse
[a] => Dog
[b] => Cat
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP asin() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP asin() 函数

PHP Math 函数

定义和用法

asin() 函数返回不同数值的反正弦，返回的结果是介于 -PI/2 与 PI/2 之间的弧度值。

语法

asin(x)
参数 | 描述
x | 必需。一个数，范围在 -1 到 1 之间。

说明

返回 x 的反正弦值，单位是弧度。asin() 是 sin() 的反函数，它的意思是在 asin() 范围里的每个值都是 a==sin(asin(a))。

如果 x 的值在 -1 到 1 之外，则返回 -1.#IND。如果为 1，则返回 PI/2 的值。

例子

在本例中，我们将计算不同值的反正弦：

<?php
echo(asin(0.64));
echo(asin(0));
echo(asin(-1));
echo(asin(1));
echo(asin(2))
?>

输出：

0.694498265627
0
-1.57079632679
1.57079632679
-1.#IND

PHP Math 函数

PHP 参考手册
PHP 测验


PHP asinh() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP asinh() 函数

PHP Math 函数

定义和用法

asinh() 函数返回一个数的反双曲正弦。

语法

asinh(x)
参数 | 描述
x | 必需。一个数。

说明

返回 x 的反双曲正弦值，即，其双曲正弦为 x 的那个值。

提示和注释

注释：本函数未在 Windows 平台下实现。

PHP Math 函数

PHP 参考手册
PHP 测验


PHP asort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP asort() 函数

PHP Array 函数

定义和用法

asort() 函数对数组进行排序并保持索引关系。主要用于对那些单元顺序很重要的结合数组进行排序。

可选的第二个参数包含了附加的排序标识。

如果成功则返回 TRUE，否则返回 FALSE。

语法

asort(array,sorttype)
参数 | 描述
array | 必需。输入的数组。
sorttype

可选。规定如何排列数组的值。可能的值：

  • SORT_REGULAR - 默认。以它们原来的类型进行处理（不改变类型）。
  • SORT_NUMERIC - 把值作为数字来处理
  • SORT_STRING - 把值作为字符串来处理
  • SORT_LOCALE_STRING - 把值作为字符串来处理，基于本地设置*。

*：该值是 PHP 4.4.0 和 5.0.2 新加的。在 PHP 6 之前，使用了系统的区域设置，可以用 setlocale() 来改变。自 PHP 6 起，必须用 i18n_loc_set_default() 函数。

例子

<?php
$my_array = array("a" => "Dog", "b" => "Cat", "c" => "Horse");

asort($my_array);
print_r($my_array);
?>

输出：

Array
(
[b] => Cat
[a] => Dog
[c] => Horse
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP asXML() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP asXML() 函数

PHP SimpleXML 函数

定义和用法

asXML() 函数以字符串的形式从 SimpleXMLElement 对象返回 XML 文档。

若失败，则返回 false。

语法

class SimpleXMLElement
{
string asXML(file)
}
参数 | 描述
file | 可选。如果规定了此参数，则该函数会把 XML 写入一个文件，而不是返回它。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP 代码：

<?php
if (file_exists('test.xml'))
  {
  $xml = simplexml_load_file('test.xml');
  }

echo $xml->asXML();
?>

输出：

George John Reminder Don't forget the meeting!

如果在浏览器窗口中选择“查看源文件”，会看到这些 HTML：

<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP atan() 和 atan2() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP atan() 和 atan2() 函数

PHP Math 函数

定义和用法

atan() 函数返回一个数值的反正切，返回值介于 -PI/2 与 PI/2 之间。

atan2() 函数返回两个参数的反正切，返回值为弧度，其值在 -PI 和 PI 之间（包括 -PI 和 PI）。

语法

atan(x)

atan2(x,y)
参数 | 描述
x | 必需。一个数。
y | 必需。一个数。

说明

atan() 函数返回 x 的反正切值，单位是弧度。atan() 是 tan() 的反函数，它的意思是在 atan() 范围里的每个值都是 a==tan(atan(a))。

atan2() 函数计算两个变量 x 和 y 的反正切值。和计算 y / x 的反正切相似，不同的是两个参数的符号是用来确定结果的象限之外。

例子 1

本例计算不同值的反正切：

<?php
echo(atan(0.50));
echo(atan(-0.50));
echo(atan(5));
echo(atan(10));
echo(atan(-5));
echo(atan(-10))
?>

输出：

0.463647609001
-0.463647609001
1.37340076695
1.4711276743
-1.37340076695
-1.4711276743

例子 2

本例计算不同的变量 x 和 y 的反正切值：

<?php
echo(atan2(0.50,0.50));
echo(atan2(-0.50,-0.50));
echo(atan2(5,5));
echo(atan2(10,20));
echo(atan2(-5,-5));
echo(atan2(-10,10))
?>

输出：

0.785398163397
-2.35619449019
0.785398163397
0.463647609001
-2.35619449019
-0.785398163397

PHP Math 函数

PHP 参考手册
PHP 测验


PHP atanh() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP atanh() 函数

PHP Math 函数

定义和用法

atanh() 函数返回一个角度的反双曲正切。

语法

atanh(x)
参数 | 描述
x | 必需。一个数。

说明

atanh() 函数返回 x 的反双曲正切值，即，其双曲正切为 x 的那个值。

提示和注释

注释：本函数未在 Windows 平台下实现。

PHP Math 函数

PHP 参考手册
PHP 测验


PHP attributes() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP attributes() 函数

PHP SimpleXML 函数

定义和用法

attributes() 函数获取 SimpleXML 元素的属性。

该函数提供在一个 XML 标签中定义的属性和值。

语法

class SimpleXMLElement
{
string attributes(ns,is_prefix)
}
参数 | 描述
ns | 可选。被检索的属性的命名空间。
is_prefix | 可选。默认是 false。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP 代码：

<?php
$xml = simplexml_load_file("test.xml");

foreach($xml->body[0]->attributes() as $a => $b)
  {
  echo $a,'="',$b,'"';
  }
?>

输出：

type="small" important="low"

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP base_convert() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP base_convert() 函数

PHP Math 函数

定义和用法

base_convert() 函数在任意进制之间转换数字。

语法

base_convert(number,frombase,tobase)
参数 | 描述
number | 必需。原始值。
frombase | 必需。数字原来的进制。
tobase | 必需。要转换的进制。

说明

返回一个字符串，包含 number 以 tobase 进制的表示。number 本身的进制由 frombase 指定。frombase 和 tobase 都只能在 2 和 36 之间（包括 2 和 36）。高于十进制的数字用字母 a-z 表示，例如 a 表示 10，b 表示 11 以及 z 表示 35。

例子 1

把八进制数转换为十进制数：

<?php
$oct = "0031";
$dec = base_convert($oct,8,10);
echo "八进制的 $oct 等于十进制的 $dec。";
?>

输出：

八进制的 0031 等于十进制的 25。

例子 2

把八进制数转换为十六进制数：

<?php
$oct = "364";
$hex = base_convert($oct,8,16);
echo "八进制的 $oct 等于十六进制的 $hex。";
?>

输出：

八进制的 364 等于十六进制的 f4。

PHP Math 函数

PHP 参考手册
PHP 测验


PHP basename() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP basename() 函数

PHP Filesystem 函数

定义和用法

basename() 函数返回路径中的文件名部分。

语法

basename(path,suffix)
参数 | 描述
path | 必需。规定要检查的路径。
suffix | 可选。规定文件扩展名。如果文件有 suffix，则不会输出这个扩展名。

例子

<?php
$path = "/testweb/home.php";

//显示带有文件扩展名的文件名
echo basename($path);

//显示不带有文件扩展名的文件名
echo basename($path,".php");
?>

输出：

home.php
home

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP bin2hex() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP bin2hex() 函数

PHP String 函数

定义和用法

bin2hex() 函数把 ASCII 字符的字符串转换为十六进制值。

语法

bin2hex(string)
参数 | 描述
string | 必需。规定要转换的字符串。

例子

在本例中，我们将把一个字符串值从二进制转换为十六进制，再转换回去：

<?php
$str = "Hello world!";
echo bin2hex($str);
echo pack("H*",bin2hex($str));
?>

输出：

48656c6c6f20776f726c6421
Hello world!

PHP String 函数

PHP 参考手册
PHP 测验


PHP bindec() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP bindec() 函数

PHP Math 函数

定义和用法

bindec() 函数把二进制转换为十进制。

语法

bindec(binary_string)
参数 | 描述
binary_string | 必需。规定要转换的二进制数。

说明

返回 binary_string 参数所表示的二进制数的十进制等价值。

bindec() 函数将一个二进制数转换成 integer。可转换的最大的数为 31 位 1 或者说十进制的 2147483647。PHP 4.1.0 开始，该函数可以处理大数值，这种情况下，它会返回 float 类型。

例子

<?php
echo bindec("0011");
echo bindec("01");
echo bindec("11000110011");
echo bindec("111");
?>

输出：

3
1
1587
7

PHP Math 函数

PHP 参考手册
PHP 测验


PHP cal_days_in_month() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP cal_days_in_month() 函数

PHP Array 函数

定义和用法

cal_days_in_month() 函数针对指定的年份和日历，返回一个月中的天数。

语法

cal_days_in_month(calendar,month,year)
参数 | 描述
calendar | 必需。规定要使用的历法。
month | 必须。规定月。
year | 必须。规定年。

例子

<?php
$d=cal_days_in_month(CAL_GREGORIAN,10,2005);
echo("There was $d days in October 2005");
?>

输出：

There was 31 days in October 2005

PHP Array 函数

PHP 参考手册
PHP 测验


PHP cal_from_jd() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP cal_from_jd() 函数

PHP Array 函数

定义和用法

cal_from_jd() 函数把儒略日计数转换为指定历法的日期。

语法

cal_from_jd(jd,calendar)
参数 | 描述
jd | 必需。一个数字（儒略日计数）。
calendar

必需。规定要使用的历法。可以使用下面这些常量：

  • CAL_GREGORIAN
  • CAL_JULIAN
  • CAL_JEWISH
  • CAL_FRENCH

例子

<?php
$d=unixtojd(mktime(0,0,0,1,18,2006));
print_r(cal_from_jd($d,CAL_GREGORIAN));
?>

输出：

Array
(
[date] => 1/18/2006
[month] => 1
[day] => 18
[year] => 2006
[dow] => 3
[abbrevdayname] => Wed
[dayname] => Wednesday
[abbrevmonth] => Jan
[monthname] => January
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP cal_info() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP cal_info() 函数

PHP Array 函数

定义和用法

cal_info() 函数返回一个数组，其中包含了关于给定历法的信息。

所返回的数组包含这些元素：calname, calsymbol, month, abbrevmonth 以及 maxdaysinmonth。

语法

cal_from_jd(jd,calendar)
参数 描述
calendar

必需。规定要使用的历法。可以使用下面这些常量：

  • CAL_GREGORIAN
  • CAL_JULIAN
  • CAL_JEWISH
  • CAL_FRENCH

提示和注释

提示：在 PHP 5 中，如果没有指定 calendar 参数，则返回所有被支持的历法的信息。

例子

<?php
$calinfo=cal_info(0);
print_r($calinfo);
?>

输出：

Array
(
[months] => Array
(
[1] => January
[2] => February
[3] => March
[4] => April
[5] => May
[6] => June
[7] => July
[8] => August
[9] => September
[10] => October
[11] => November
[12] => December
)

[abbrevmonths] => Array
(
[1] => Jan
[2] => Feb
[3] => Mar
[4] => Apr
[5] => May
[6] => Jun
[7] => Jul
[8] => Aug
[9] => Sep
[10] => Oct
[11] => Nov
[12] => Dec
)

[maxdaysinmonth] => 31
[calname] => Gregorian
[calsymbol] => CAL_GREGORIAN
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP cal_to_jd() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP cal_to_jd() 函数

PHP Array 函数

定义和用法

cal_to_jd() 函数把指定的日期转换为儒略日计数。

语法

cal_to_jd(calendar,month,day,year)
参数 | 描述
calendar

必需。规定要使用的历法。可以使用下面这些常量：

  • CAL_GREGORIAN
  • CAL_JULIAN
  • CAL_JEWISH
  • CAL_FRENCH
month | 必需。规定月。
day | 必需。规定日。
year | 必需。规定年。

例子

<?php
$d=cal_to_jd(CAL_GREGORIAN,10,03,2005);
echo($d);
?>

输出：

2453647

PHP Array 函数

PHP 参考手册
PHP 测验


PHP Calendar 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Calendar 函数

  • Previous Page
  • Next Page

PHP Calendar 简介

当使用不同的历法格式时，calendar 函数很有用。它所基于的标准是儒略日计数 (Julian day count)。

编者注：Julian day count 是从 January 1, 4713 B.C. 开始计算的，中文译为儒略日计数或恺撒日计数。

请注意，Julian day count（儒略日计数） 与 Julian calendar（儒略历） 不是一回事。

注释：如需在日历格式之间转换，必须首先转换为 Julian day count，然后再转换为日历格式。

安装

PHP 的 windows 版本已内建了对日历扩展的支持。因此，Calendar 函数会自动工作。

不过，如果您运行的是 PHP 的 Linux 版本，就不得不通过 --enable-calendar 编译 PHP，这样日历函数才能工作。

PHP Calendar 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
cal_days_in_month() | 针对指定的年份和日历，返回一个月中的天数。 | 4
cal_from_jd() | 把儒略日计数转换为指定日历的日期。 | 4
cal_info() | 返回有关给定日历的信息。 | 4
cal_to_jd() | 把日期转换为儒略日计数。 | 4
easter_date() | 返回指定年份的复活节午夜的 Unix 时间戳。 | 3
easter_days() | 返回指定年份的复活节与 3 月 21 日之间的天数。 | 3
FrenchToJD() | 将法国共和历法转换成为儒略日计数。 | 3
GregorianToJD() | 将格利高里历法转换成为儒略日计数。 | 3
JDDayOfWeek() | 返回日期在周几。 | 3
JDMonthName() | 返回月的名称。 | 3
JDToFrench() | 把儒略日计数转换为法国共和国历法。 | 3
JDToGregorian() | 把儒略日计数转换为格利高里历法。 | 3
jdtojewish() | 把儒略日计数转换为犹太历法。 | 3
JDToJulian() | 把儒略日计数转换为儒略历。 | 3
jdtounix() | 把儒略日计数转换为 Unix 时间戳。 | 4
JewishToJD() | 把犹太历法转换为儒略日计数。 | 3
JulianToJD() | 把儒略历转换为儒略日计数。 | 3
unixtojd() | 把 Unix 时间戳转换为儒略日计数。 | 4

PHP Calendar 常量

PHP：指示支持该常量的最早的 PHP 版本。

常量 | 描述 | PHP
CAL_GREGORIAN | Gregorian calendar | 3
CAL_JULIAN | Julian calendar | 3
CAL_JEWISH | Jewish calendar | 3
CAL_FRENCH | French Republican calendar | 3
CAL_NUM_CALS |  | 3
CAL_DOW_DAYNO |  | 3
CAL_DOW_SHORT |  | 3
CAL_DOW_LONG |  | 3
CAL_MONTH_GREGORIAN_SHORT |  | 3
CAL_MONTH_GREGORIAN_LONG |  | 3
CAL_MONTH_JULIAN_SHORT |  | 3
CAL_MONTH_JULIAN_LONG |  | 3
CAL_MONTH_JEWISH |  | 3
CAL_MONTH_FRENCH |  | 3
CAL_EASTER_DEFAULT |  | 4
CAL_EASTER_DEFAULT |  | 4
CAL_EASTER_ROMAN |  | 4
CAL_EASTER_ALWAYS_GREGORIAN |  | 4
CAL_EASTER_ALWAYS_JULIAN |  | 4
CAL_JEWISH_ADD_ALAFIM_GERESH |  | 5
CAL_JEWISH_ADD_ALAFIM |  | 5
CAL_JEWISH_ADD_GERESHAYIM |  | 5
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP ceil() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ceil() 函数

PHP Math 函数

定义和用法

ceil() 函数向上舍入为最接近的整数。

语法

ceil(x)
参数 | 描述
x | 必需。一个数。

说明

返回不小于 x 的下一个整数，x 如果有小数部分则进一位。ceil() 返回的类型仍然是 float，因为 float 值的范围通常比 integer 要大。

例子

在本例中，我们将对不同的值应用 ceil() 函数：

<?php
echo(ceil(0.60);
echo(ceil(0.40);
echo(ceil(5);
echo(ceil(5.1);
echo(ceil(-5.1);
echo(ceil(-5.9));
?>

输出：

1
1
5
6
-5
-5

PHP Math 函数

PHP 参考手册
PHP 测验


PHP chdir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP chdir() 函数

PHP Directory 函数

定义和用法

chdir() 函数把当前的目录改变为指定的目录。

若成功，则该函数返回 true，否则返回 false。

语法

chdir(directory)
参数 | 描述
directory | 必需。规定新的当前目录。

例子

<?php
//获得当前目录
echo getcwd();
echo "<br />";

//改变为 images 目录
chdir("images");
echo "<br />";
echo getcwd();
?>

输出：

C:\testweb\main
C:\testweb\main\images

PHP Directory 函数

PHP 参考手册
PHP 测验


PHP checkdate() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP checkdate() 函数

PHP Date / Time 函数

定义和用法

checkdate() 函数验证一个格里高里日期。

如果指定的值合法，则该函数返回 true，否则返回 false。

日期在下列情况下为合法：

  • month 介于且包括 1 - 12
  • Day 的值在给定的 month 所应该具有的天数范围之内，闰年已经考虑进去了。
  • year 介于且包括 1 到 32767

语法

checkdate(month,day,year)
参数 | 描述
month | 必需。规定月。
day | 必需。规定日。
year | 必需。规定年。

例子

<?php
var_dump(checkdate(12,31,2000));
var_dump(checkdate(2,29,2003));
var_dump(checkdate(2,29,2004));
?>

输出：

bool(true)
bool(false)
bool(true)

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP chgrp() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP chgrp() 函数

PHP Filesystem 函数

定义和用法

chgrp() 函数改变文件所属的组。

如果成功则返回 TRUE，否则返回 FALSE。

语法

chgrp(file,group)
参数 | 描述
file | 必需。规定要检查的文件。
group | 可选。规定新的组。可以是组名或组的 ID。

说明

尝试将文件 file 所属的组改成 group （通过组名或组 ID 指定）。

只有超级用户可以任意修改文件的组，其它用户可能只能将文件的组改成该用户自己所在的组。

例子

<?php
chgrp("test.txt","admin")
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP children() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP children() 函数

PHP SimpleXML 函数

定义和用法

children() 函数获取指定节点的子节点。

语法

class SimpleXMLElement
{
string children(ns,is_prefix)
}
参数 | 描述
ns | 可选。
is_prefix | 可选。默认是 false。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP 代码：

<?php
$xml = simplexml_load_file("test.xml");

foreach ($xml->children() as $child)
  {
  echo "Child node: " . $child;
  }
?>

输出类似：

Child node: George
Child node: John
Child node: Reminder
Child node: Don't forget the meeting!

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP chmod() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP chmod() 函数

PHP Filesystem 函数

定义和用法

chmod() 函数改变文件模式。

如果成功则返回 TRUE，否则返回 FALSE。

语法

chmod(file,mode)
参数 | 描述
file | 必需。规定要检查的文件。
mode

可选。规定新的权限。

mode 参数由 4 个数字组成：

  • 第一个数字永远是 0
  • 第二个数字规定所有者的权限
  • 第二个数字规定所有者所属的用户组的权限
  • 第四个数字规定其他所有人的权限

可能的值（如需设置多个权限，请对下面的数字进行总计）：

  • 1 - 执行权限
  • 2 - 写权限
  • 4 - 读权限

例子

<?php
// 所有者可读写，其他人没有任何权限
chmod("test.txt",0600);

// 所有者可读写，其他人可读
chmod("test.txt",0644);

// 所有者有所有权限，其他所有人可读和执行
chmod("test.txt",0755);

// 所有者有所有权限，所有者所在的组可读
chmod("test.txt",0740);
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP chop() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP chop() 函数

PHP String 函数

定义和用法

chop() 函数从字符串的末端开始删除空白字符或其他预定义字符。

该函数的 rtrim() 函数的别名。

语法

chop(string,charlist)
参数 | 描述
string | 必需。规定要转换的字符串。
charlist

可选。规定从字符串中删除哪些字符。

如果未设置该参数，则全部删除以下字符：

  • "\0" - ASCII 0, NULL
  • "\t" - ASCII 9, 制表符
  • "\n" - ASCII 10, 新行
  • "\x0B" - ASCII 11, 垂直制表符
  • "\r" - ASCII 13, 回车
  • " " - ASCII 32, 空格

例子

在本例中，我们将使用 chop() 函数从字符串右端删除字符：

<?php
$str = "Hello World!\n\n";
echo $str;
echo chop($str);
?>

以上代码输出的源代码：

<html>

<body>
Hello World!

Hello World!</body>

</html>

输出：

Hello World! Hello World!

PHP String 函数

PHP 参考手册
PHP 测验


PHP chown() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP chown() 函数

PHP Filesystem 函数

定义和用法

chown() 函数改变指定文件的所有者。

如果成功则返回 TRUE，否则返回 FALSE。

语法

chown(file,owner)
参数 | 描述
file | 必需。规定要检查的文件。
owner | 规定新的所有者。可以是用户名或用户的 ID。

说明

尝试将文件 file 的所有者改成用户 owner （由用户名或用户 ID 指定）。只有超级用户可以改变文件的所有者。

例子

<?php
chown("test.txt","charles")
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP chr() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP chr() 函数

PHP String 函数

定义和用法

chr() 函数从指定的 ASCII 值返回字符。

语法

chr(ascii)
参数 | 描述
ascii | 必需。ASCII 值。

提示和注释

注释：ascii 参数可以是十进制、八进制或十六进制。通过前置 0 来规定八进制，通过前置 0x 来规定十六进制。

例子

<?php
echo chr(52);
echo chr(052);
echo chr(0x52);
?>

输出：

4
*
R

PHP String 函数

PHP 参考手册
PHP 测验


PHP chroot() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP chroot() 函数

PHP Directory 函数

定义和用法

chroot() 函数把当前进程的根目录改变为指定的目录。

若成功，则该函数返回 true，否则返回 false。

语法

chroot(directory)
参数 | 描述
directory | 必需。规定新的根目录。

提示和注释

提示：该函数没有在 Windows 平台上实现。

PHP Directory 函数

PHP 参考手册
PHP 测验


PHP chunk_split() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP chunk_split() 函数

PHP String 函数

定义和用法

chunk_split() 函数把字符串分割为一连串更小的部分。

语法

chunk_split(string,length,end)
参数 | 描述
string | 必需。规定要分割的字符串。
length | 可选。一个数字，定义字符串块的长度。
end | 可选。字符串值，定义在每个字符串块之后放置的内容。

提示和注释

注释：本函数不改变原始字符串。

例子

例子 1

本例分隔每个字符，并添加 "."：

<?php
$str = "Hello world!";
echo chunk_split($str,1,".");
?>

输出：

H.e.l.l.o. .w.o.r.l.d.!.

例子 2

本例将在六个字符之后分割一次字符串，并添加 "..."：

<?php
$str = "Hello world!";
echo chunk_split($str,6,"...");
?>

输出：

Hello ...world!...

PHP String 函数

PHP 参考手册
PHP 测验


PHP clearstatcache() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP clearstatcache() 函数

PHP Filesystem 函数

定义和用法

clearstatcache() 函数清除文件状态缓存。

clearstatcache() 函数会缓存某些函数的返回信息，以便提供更高的性能。但是有时候，比如在一个脚本中多次检查同一个文件，而该文件在此脚本执行期间有被删除或修改的危险时，你需要清除文件状态缓存，以便获得正确的结果。要做到这一点，就需要使用 clearstatcache() 函数。

会进行缓存的函数，即受 clearstatcache() 函数影响的函数：

  • stat()
  • lstat()
  • file_exists()
  • is_writable()
  • is_readable()
  • is_executable()
  • is_file()
  • is_dir()
  • is_link()
  • filectime()
  • fileatime()
  • filemtime()
  • fileinode()
  • filegroup()
  • fileowner()
  • filesize()
  • filetype()
  • fileperms()

语法

clearstatcache()

例子

<?php
//检查文件大小
echo filesize("test.txt");

$file = fopen("test.txt", "a+");

// 截取文件
ftruncate($file,100);
fclose($file);

//清除缓存并再次检查文件大小
clearstatcache();
echo filesize("test.txt");
?>

输出：

792
100

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP clearstatcache() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP clearstatcache() 函数

PHP Filesystem 函数

定义和用法

clearstatcache() 函数拷贝文件。

语法

copy(source,destination)
参数 | 描述
source | 必需。规定要复制的文件。
destination | 必需。规定复制文件的目的地。

说明

将文件从 source 拷贝到 destination。如果成功则返回 TRUE，否则返回 FALSE。

提示和注释

提示：如果要移动文件的话，请使用 rename() 函数。

注释：从 PHP 4.3.0 开始，如果启用了 "fopen wrappers" 的话，source 和 destination 都可以是 URL。更多信息见 fopen()。如果 destination 是一个 URL，则如果封装协议不支持覆盖已有的文件时拷贝操作会失败。

重要事项：如果目标文件已存在，将会被覆盖。

例子

<?php
echo copy("source.txt","target.txt");
?>

输出：

1

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP closedir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP closedir() 函数

PHP Directory 函数

定义和用法

closedir() 函数关闭由 opendir() 函数打开的目录句柄。

语法

closedir(dir_stream)
参数 | 描述
dir_stream | 必需。规定要关闭的目录句柄。

例子

<?php
//打开 images 目录
$dir = opendir("images");

//列出 images 目录中的文件
while (($file = readdir($dir)) !== false)
  {
  echo "filename: " . $file . "<br />";
  }
  closedir($dir);
?>

输出：

filename: .
filename: ..
filename: cat.gif
filename: dog.gif
filename: food
filename: horse.gif

PHP Directory 函数

PHP 参考手册
PHP 测验


PHP compact() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP compact() 函数

PHP Array 函数

定义和用法

compact() 函数创建一个由参数所带变量组成的数组。如果参数中存在数组，该数组中变量的值也会被获取。

本函数返回的数组是一个关联数组，键名为函数的参数，键值为参数中变量的值。

本函数执行的行为与 extract() 正好相反。

语法

compact(var1,var2...)
参数 | 描述
var1 | 必需。可以是带有变量名的字符串，或者是一个变量数组。
var2 | 可选。可以是带有变量名的字符串，或者是一个变量数组。允许多个参数。

注释和提示

注释：任何没有变量名与之对应的字符串都被略过。

例子 1

<?php
$firstname = "Peter";
$lastname = "Griffin";
$age = "38";

$result = compact("firstname", "lastname", "age");

print_r($result);
?>

输出：

Array
(
[firstname] => Peter
[lastname] => Griffin
[age] => 38
)

例子 2

使用没有对应变量名的字符串，以及一个变量名数组：

<?php
$firstname = "Peter";
$lastname = "Griffin";
$age = "38";

$name = array("firstname", "lastname");
$result = compact($name, "location", "age");

print_r($result);
?>

输出：

Array
(
[firstname] => Peter
[lastname] => Griffin
[age] => 38
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP connection_aborted() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP connection_aborted() 函数

PHP 杂项函数

定义和用法

connection_aborted() 函数检查是否断开客户机。

如果已终止连接，则该函返回 1，否则返回 0。

语法

connection_aborted()

例子

创建一个函数，在客户机终止脚本时写入一条日志消息：

<?php
function check_abort()
  {
  if (connection_aborted())
  error_log ("Script $GLOBALS[SCRIPT_NAME]" .
  "$GLOBALS[SERVER_NAME] was aborted by the user.");
  }

//要执行的一些代码

// 在脚本结束时调用 check_abort 函数
register_shutdown_function("check_abort");
?>

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP connection_status() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP connection_status() 函数

PHP 杂项函数

定义和用法

connection_status() 函数返回当前的连接状态。

可返回的可能值：

  • 0 - CONNECTION_NORMAL - 连接运行正常
  • 1 - CONNECTION_ABORTED - 连接由用户或网络错误终止
  • 2 - CONNECTION_TIMEOUT - 连接超时
  • 3 - CONNECTION_ABORTED & CONNECTION_TIMEOUT

语法

connection_status()

例子

<?php

switch (connection_status())
{
case CONNECTION_NORMAL:
   $txt = 'Connection is in a normal state';
   break;
case CONNECTION_ABORTED:
   $txt = 'Connection aborted';
   break;
case CONNECTION_TIMEOUT:
   $txt = 'Connection timed out';
   break;
case (CONNECTION_ABORTED & CONNECTION_TIMEOUT):
   $txt = 'Connection aborted and timed out';
   break;
default:
   $txt = 'Unknown';
   break;
}

echo $txt;
?>

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP constant() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP constant() 函数

PHP 杂项函数

定义和用法

constant() 函数返回常量的值。

语法

constant(constant)
参数 | 描述
constant | 必需。规定要检查的常量的名称。

提示和注释

注释：该函数仅适用于 class 常量。

例子

<?php
//定义一个常量
define("GREETING","Hello world!");

echo constant("GREETING");
?>

输出：

Hello world!

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP convert_cyr_string() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP convert_cyr_string() 函数

PHP String 函数

定义和用法

convert_cyr_string() 函数把字符由一种 Cyrillic 字符转换成另一种。

被支持的 Cyrillic 字符集是：

  • k - koi8-r
  • w - windows-1251
  • i - iso8859-5
  • a - x-cp866
  • d - x-cp866
  • m - x-mac-cyrillic

语法

convert_cyr_string(string,from,to)
参数 | 描述
string | 必需。规定要转换的字符串。
from | 必需。源 Cyrillic 字符集。
to | 必需。目标 Cyrillic 字符集。

提示和注释

注释：本函数可安全用于二进制对象。

PHP String 函数

PHP 参考手册
PHP 测验


PHP convert_uudecode() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP convert_uudecode() 函数

PHP String 函数

定义和用法

convert_uudecode() 函数对 uuencode 编码的字符串进行解码。

语法

convert_uudecode(string)
参数 | 描述
string | 必需。规定要解码的字符串。

例子

在本例中，我们将通过使用 convert_uudecode() 对 uuencode 编码的字符串进行解码：

<?php
$str = ",2&5L;&\@=V]R;&0A `";
echo convert_uudecode($str);
?>

输出：

Hello world!

PHP String 函数

PHP 参考手册
PHP 测验


PHP convert_uuencode() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP convert_uuencode() 函数

PHP String 函数

定义和用法

convert_uuencode() 函数使用 uuencode 算法对字符串进行编码。

语法

convert_uuencode(string)
参数 | 描述
string | 必需。规定进行 uuencode 的字符串。

提示和注释

注释：本函数把所有字符串（包括二进制的）转换为可打印的字符串，确保其网络传输的安全。

注释：uuencode 的字符串比原字符串增大大约 35%。

例子

在本例中，我们将使用 convert_uuencode() 对字符串进行编码：

<?php
$str = "Hello world!";
echo convert_uuencode($str);
?>

输出：

,2&5L;&\@=V]R;&0A `

PHP String 函数

PHP 参考手册
PHP 测验


PHP Cookies

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Cookies

  • Previous Page
  • Next Page

cookie 常用于识别用户。

什么是 Cookie？

cookie 常用于识别用户。cookie 是服务器留在用户计算机中的小文件。每当相同的计算机通过浏览器请求页面时，它同时会发送 cookie。通过 PHP，您能够创建并取回 cookie 的值。

如何创建 cookie？

setcookie() 函数用于设置 cookie。

注释：setcookie() 函数必须位于 <html> 标签之前。

语法

setcookie(name, value, expire, path, domain);

例子

在下面的例子中，我们将创建名为 "user" 的 cookie，把为它赋值 "Alex Porter"。我们也规定了此 cookie 在一小时后过期：

<?php
setcookie("user", "Alex Porter", time()+3600);
?>

<html>
<body>

</body>
</html>

注释：在发送 cookie 时，cookie 的值会自动进行 URL 编码，在取回时进行自动解码（为防止 URL 编码，请使用 setrawcookie() 取而代之）。

如何取回 Cookie 的值？

PHP 的 $_COOKIE 变量用于取回 cookie 的值。

在下面的例子中，我们取回了名为 "user" 的 cookie 的值，并把它显示在了页面上：

<?php
// Print a cookie
echo $_COOKIE["user"];

// A way to view all cookies
print_r($_COOKIE);
?>

在下面的例子中，我们使用 isset() 函数来确认是否已设置了 cookie：

<html>
<body>

<?php
if (isset($_COOKIE["user"]))
  echo "Welcome " . $_COOKIE["user"] . "!<br />";
else
  echo "Welcome guest!<br />";
?>

</body>
</html>

如何删除 cookie？

当删除 cookie 时，您应当使过期日期变更为过去的时间点。

删除的例子：

<?php
// set the expiration date to one hour ago
setcookie("user", "", time()-3600);
?>

如果浏览器不支持 cookie 该怎么办？

如果您的应用程序涉及不支持 cookie 的浏览器，您就不得不采取其他方法在应用程序中从一张页面向另一张页面传递信息。一种方式是从表单传递数据（有关表单和用户输入的内容，稍早前我们已经在本教程中介绍过了）。

下面的表单在用户单击提交按钮时向 "welcome.php" 提交了用户输入：

<html>
<body>

<form action="welcome.php" method="post">
Name: <input type="text" name="name" />
Age: <input type="text" name="age" />
<input type="submit" />
</form>

</body>
</html>

取回 "welcome.php" 中的值，就像这样：

<html>
<body>

Welcome <?php echo $_POST["name"]; ?>.<br />
You are <?php echo $_POST["age"]; ?> years old.

</body>
</html>
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP cos() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP cos() 函数

PHP Math 函数

定义和用法

cos() 函数返回一个数的余弦。

语法

cos(x)
参数 | 描述
x | 必需。一个数。

说明

cos() 返回参数 x 的余弦值。参数 x 的单位为弧度。

提示和注释

注释：cos() 返回的数值在 -1 和 1 之间。

例子

在本例中，我们将计算不同值的余弦：

<?php
echo(cos(3));
echo(cos(-3));
echo(cos(0));
echo(cos(M_PI));
echo(cos(2*M_PI));
?>

输出：

-0.9899924966004454
-0.9899924966004454
1
-1
1

PHP Math 函数

PHP 参考手册
PHP 测验


PHP cosh() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP cosh() 函数

PHP Math 函数

定义和用法

cosh() 函数返回一个数的双曲余弦。

语法

cosh(x)
参数 | 描述
x | 必需。一个数。

说明

返回 x 的双曲余弦值，定义为 (exp(arg) + exp(-arg))/2。

例子

在本例中，我们将返回不同数的双曲余弦：

<?php
echo(cosh(3);
echo(cosh(-3);
echo(cosh(0);
echo(cosh(M_PI);
echo(cosh(2*M_PI));
?>

输出：

10.0676619958
10.0676619958
1
11.5919532755
267.746761484

PHP Math 函数

PHP 参考手册
PHP 测验


PHP count_chars() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP count_chars() 函数

PHP String 函数

定义和用法

count_chars() 函数返回字符串所用字符的信息。

语法

count_chars(string,mode)
参数 | 描述
string | 必需。规定要检查的字符串。
mode

可选。规定返回模式。默认是 0。有以下不同的返回模式：

  • 0 - 数组，ASCII 值为键名，出现的次数为键值
  • 1 - 数组，ASCII 值为键名，出现的次数为键值，只列出出现次数大于 0 的值
  • 0 - 数组，ASCII 值为键名，出现的次数为键值，只列出出现次数等于 0 的值
  • 3 - 字符串，带有所有使用过的不同的字符
  • 3 - 字符串，带有所有未使用过的不同的字符

例子

例子 1

在本例中，我们将使用 count_chars() 来检查字符串，返回模式设置为 1：

<?php
$str = "Hello World!";
print_r(count_chars($str,1));
?>

输出：

Array
(
[32] => 1
[33] => 1
[72] => 1
[87] => 1
[100] => 1
[101] => 1
[108] => 3
[111] => 2
[114] => 1
)

例子 2

在本例中，我们将使用 count_chars() 来检查字符串，返回模式设置为 3：

<?php
$str = "Hello World!";
echo count_chars($str,3);
?>

输出：

 !HWdelor

PHP String 函数

PHP 参考手册
PHP 测验


PHP count() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP count() 函数

PHP Array 函数

定义和用法

count() 函数计算数组中的单元数目或对象中的属性个数。

对于数组，返回其元素的个数，对于其他值，返回 1。如果参数是变量而变量没有定义，则返回 0。如果 mode 被设置为 COUNT_RECURSIVE（或 1），则会递归底计算多维数组中的数组的元素个数。

语法

count(array,mode)
参数 | 描述
array | 必需。规定要计数的数组或对象。
mode

可选。规定函数的模式。可能的值：

  • 0 - 默认。不检测多维数组（数组中的数组）。
  • 1 - 检测多维数组。

注释：该参数是 PHP 4.2 中加入的。

提示和注释

注释：当变量未被设置，或是变量包含一个空的数组，该函数会返回 0。可使用 isset() 变量来测试变量是否被设置。

例子

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");
$result = count($people);

echo $result;
?>

输出：

4

PHP Array 函数

PHP 参考手册
PHP 测验


PHP crc32() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP crc32() 函数

PHP String 函数

定义和用法

crc32() 函数计算一个字符串的 crc32 多项式。

该函数可用于验证数据的完整性。

语法

crc32(string)
参数 | 描述
string | 必需。规定要计算的字符串。

说明

生成 string 参数的 32 位循环冗余校验码多项式。这通常用于检查传输的数据是否完整。

提示和注释

提示：由于 PHP 的整数是带符号的，许多 crc32 校验码将返回负整数，因此您需要使用 sprintf() 或 printf() 的 "%u" 格式符来获取表示无符号 crc32 校验码的字符串。

例子

例子 1

在本例中，我们将在使用以及不使用 "%u" 格式符的情况下，输出 crc32() 的结果（注意结果是相同的）：

<?php
$str = crc32("Hello world!");
echo 'Without %u: '.$str."<br />";
echo 'With %u: ';
printf("%u",$str);
?>

输出：

Without %u: 461707669
With %u: 461707669

例子 2

在本例中，我们将在使用以及不使用 "%u" 格式符的情况下，输出 crc32() 的结果（注意结果是不相同的）：

<?php
$str = crc32("Hello world.");
echo 'Without %u: '.$str."<br />";
echo 'With %u: ';
printf("%u",$str);
?>

输出：

Without %u: -1959132156
With %u: 2335835140

PHP String 函数

PHP 参考手册
PHP 测验


PHP crypt() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP crypt() 函数

PHP String 函数

定义和用法

crypt() 函数返回使用 DES、Blowfish 或 MD5 加密的字符串。

在不同的操作系统上，本函数的行为不同，某些操作系统支持一种以上的算法类型。在安装时，PHP 会检查什么算法可用以及使用什么算法。

语法

crypt(str,salt)
参数 | 描述
str | 必需。规定要编码的字符串。
salt | 可选。用于增加被编码字符数目的字符串，以使编码更加安全。 如果未提供 salt 参数，则每次调用该函数时会随机生成一个。

说明

确切的算法依赖于 salt 参数的格式和长度。

下面是与 crypt() 函数一起使用的一些常量。在安装时，由 PHP 设置这些常量：

  • [CRYPT_SALT_LENGTH]
  • [CRYPT_STD_DES]
  • [CRYPT_EXT_DES]
  • [CRYPT_MD5]
  • [CRYPT_BLOWFISH]

提示和注释

提示：解密函数是没有的。crypt() 函数使用一种单向算法。

例子

在本例中，我们将测试不同的算法：

<?php
if (CRYPT_STD_DES == 1)
{
echo "Standard DES: ".crypt("hello world")."\n<br />";
}
else
{
echo "Standard DES not supported.\n<br />";
}

if (CRYPT_EXT_DES == 1)
{
echo "Extended DES: ".crypt("hello world")."\n<br />";
}
else
{
echo "Extended DES not supported.\n<br />";
}

if (CRYPT_MD5 == 1)
{
echo "MD5: ".crypt("hello world")."\n<br />";
}
else
{
echo "MD5 not supported.\n<br />";
}

if (CRYPT_BLOWFISH == 1)
{
echo "Blowfish: ".crypt("hello world");
}
else
{
echo "Blowfish DES not supported.";
}
?>

输出类似（依赖于操作系统）：

Standard DES: $1$r35.Y52.$iyiFuvM.zFGsscpU0aZ4e.
Extended DES not supported.
MD5: $1$BN1.0I2.$8oBI/4mufxK6Tq89M12mk/
Blowfish DES not supported.

PHP String 函数

PHP 参考手册
PHP 测验


PHP current() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP current() 函数

PHP Array 函数

定义和用法

current() 函数返回数组中的当前元素（单元）。

每个数组中都有一个内部的指针指向它“当前的”元素，初始指向插入到数组中的第一个元素。

current() 函数返回当前被内部指针指向的数组元素的值，并不移动指针。如果内部指针指向超出了单元列表的末端，current() 返回 FALSE。

语法

current(array)
参数 | 描述
array | 必需。规定要使用的数组。

提示和注释

注释：如果有空的元素，或元素没有值，该函数也返回 FALSE。

提示：该函数不会移动内部指针。要做到这一点，请使用 next() 和 prev() 函数。

例子

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");

echo current($people) . "<br />";
?>

输出：

Peter

PHP Array 函数

PHP 参考手册
PHP 测验


PHP Database ODBC

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Database ODBC

  • Previous Page
  • Next Page

ODBC 指的是（Application Programming Interface，API），使我们有能力连接到某个数据源（比如一个 MS Access 数据库）。

创建 ODBC 连接

通过一个 ODBC 连接，您可以连接到您的网络中的任何计算机上的任何数据库，只要 ODBC 连接是可用的。

这是创建到达 MS Access 数据的 ODBC 连接的方法：

  1. 在控制面板中打开管理工具
  2. 双击其中的数据源 (ODBC) 图标
  3. 选择系统 DSN 选项卡
  4. 点击系统 DSN 选项卡中的“添加”按钮
  5. 选择 Microsoft Access Driver。点击完成。
  6. 在下一个界面，点击“选择”来定位数据库。
  7. 为这个数据库取一个数据源名 (DSN)。
  8. 点击确定。

请注意，必须在您的网站所在的计算机上完成这个配置。如果您的计算机上正在运行 Internet 信息服务器 (IIS)，上面的指令会生效，但是假如您的网站位于远程服务器，您必须拥有对该服务器的物理访问权限，或者请您的主机提供商为您建立 DSN。

连接到 ODBC

odbc_connect() 函数用于连接到 ODBC 数据源。该函数有四个参数：数据源名、用户名、密码以及可选的指针类型参数。

odbc_exec() 函数用于执行 SQL 语句。

例子

下面的例子创建了到达名为 northwind 的 DSN 的连接，不没有用户名和密码。然后创建并执行一条 SQL 语句：

$conn=odbc_connect('northwind','','');
$sql="SELECT * FROM customers";
$rs=odbc_exec($conn,$sql);

取回记录

odbc_fetch_row() 函数用于从结果集中返回记录。如果能够返回行，则返回 true，否则返回 false。

该函数有两个参数：ODBC 结果标识符和可选的行号：

odbc_fetch_row($rs)

从记录中取回字段

odbc_result() 函数用于从记录中读取字段。该函数有两个参数：ODBC 结果标识符和字段编号或名称。

下面的代码行从记录中返回第一个字段的值：

$compname=odbc_result($rs,1);

The code line below returns the value of a field called "CompanyName":

$compname=odbc_result($rs,"CompanyName");

关闭 ODBC 连接

odbc_close()函数用于关闭 ODBC 连接。

odbc_close($conn);

ODBC 实例

下面的例子展示了如何首先创建一个数据库连接，然后是结果集，然后在 HTML 表格中显示数据。

<html>
<body>

<?php
$conn=odbc_connect('northwind','','');
if (!$conn)
  {exit("Connection Failed: " . $conn);}
$sql="SELECT * FROM customers";
$rs=odbc_exec($conn,$sql);
if (!$rs)
  {exit("Error in SQL");}
echo "<table><tr>";
echo "<th>Companyname</th>";
echo "<th>Contactname</th></tr>";
while (odbc_fetch_row($rs))
{
  $compname=odbc_result($rs,"CompanyName");
  $conname=odbc_result($rs,"ContactName");
  echo "<tr><td>$compname</td>";
  echo "<td>$conname</td></tr>";
}
odbc_close($conn);
echo "</table>";
?>

</body>
</html>
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP Date / Time 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Date / Time 函数

  • Previous Page
  • Next Page

PHP Date / Time 简介

date/time 函数允许您提取并格式化服务器上的日期和时间。

注释：这些函数依赖于服务器的本地设置。

安装

date/time 函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

Runtime 配置

日期/时间函数的行为受到 php.ini 中设置的影响。

Date/Time 配置选项：

名称 | 默认 | 描述 | 可改变
date.default_latitude | "31.7667" | 规定默认纬度（从 PHP 5 开始可用）。date_sunrise() 和 date_sunset() 使用该选项。 | PHP_INI_ALL
date.default_longitude | "35.2333" | 规定默认经度（从 PHP 5 开始可用）。date_sunrise() 和 date_sunset() 使用该选项。 | PHP_INI_ALL
date.sunrise_zenith | "90.83" | 规定日出天顶（从 PHP 5 开始可用）。date_sunrise() 和 date_sunset() 使用该选项。 | PHP_INI_ALL
date.sunset_zenith | "90.83" | 规定日落天顶（从 PHP 5 开始可用）。date_sunrise() 和 date_sunset() 使用该选项。 | PHP_INI_ALL
date.timezone | "" | 规定默认时区（从 PHP 5.1 开始可用）。 | PHP_INI_ALL

PHP Date / Time 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
checkdate() | 验证格利高里日期。 | 3
date_default_timezone_get() | 返回默认时区。 | 5
date_default_timezone_set() | 设置默认时区。 | 5
date_sunrise() | 返回给定的日期与地点的日出时间。 | 5
date_sunset() | 返回给定的日期与地点的日落时间。 | 5
date() | 格式化本地时间／日期。 | 3
getdate() | 返回日期／时间信息。 | 3
gettimeofday() | 返回当前时间信息。 | 3
gmdate() | 格式化 GMT/UTC 日期/时间。 | 3
gmmktime() | 取得 GMT 日期的 UNIX 时间戳。 | 3
gmstrftime() | 根据本地区域设置格式化 GMT/UTC 时间／日期。 | 3
idate() | 将本地时间/日期格式化为整数 | 5
localtime() | 返回本地时间。 | 4
microtime() | 返回当前时间的微秒数。 | 3
mktime() | 返回一个日期的 Unix 时间戳。 | 3
strftime() | 根据区域设置格式化本地时间／日期。 | 3
strptime() | 解析由 strftime 生成的日期／时间。 | 5
strtotime() | 将任何英文文本的日期或时间描述解析为 Unix 时间戳。 | 3
time() | 返回当前时间的 Unix 时间戳。 | 3

PHP Date / Time 常量

PHP：指示支持该常量的最早的 PHP 版本。

常量 | 描述 | PHP
DATE_ATOM | 原子钟格式 (如: 2005-08-15T16:13:03+0000) |
DATE_COOKIE | HTTP Cookies 格式 (如: Sun, 14 Aug 2005 16:13:03 UTC) |
DATE_ISO8601 | ISO-8601 (如: 2005-08-14T16:13:03+0000) |
DATE_RFC822 | RFC 822 (如: Sun, 14 Aug 2005 16:13:03 UTC) |
DATE_RFC850 | RFC 850 (如: Sunday, 14-Aug-05 16:13:03 UTC) |
DATE_RFC1036 | RFC 1036 (如: Sunday, 14-Aug-05 16:13:03 UTC) |
DATE_RFC1123 | RFC 1123 (如: Sun, 14 Aug 2005 16:13:03 UTC) |
DATE_RFC2822 | RFC 2822 (如: Sun, 14 Aug 2005 16:13:03 +0000) |
DATE_RSS | RSS (如: Sun, 14 Aug 2005 16:13:03 UTC) |
DATE_W3C | World Wide Web Consortium (如: 2005-08-14T16:13:03+0000) |
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP date_default_timezone_get() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP date_default_timezone_get() 函数

PHP Date / Time 函数

定义和用法

date_default_timezone_get() 函数返回脚本中所有日期时间函数所使用的默认时区。

语法

date_default_timezone_get(void)
参数 | 描述
void | 可选。

说明

本函数返回默认时区，使用如下“假定”的顺序：

  • 用 date_default_timezone_set() 函数设定的时区（如果设定了的话）
  • TZ 环境变量（如果非空）
  • date.timezone 配置选项（如果设定了的话）
  • 自己推测（如果操作系统支持）
  • 如果以上选择都不成功，则返回 UTC

例子

<?php
echo(date_default_timezone_get());
?>

输出：

Europe/Paris

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP date_default_timezone_set() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP date_default_timezone_set() 函数

PHP Date / Time 函数

定义和用法

date_default_timezone_set() 函数设置用在脚本中所有日期/时间函数的默认时区。

语法

date_default_timezone_set(timezone)
参数 | 描述
timezone | 必需。时区标识符，比如 "UTC" 或 "Europe/Paris"。 合法时区的列表：http://www.php.net/manual/en/timezones.php

说明

注释：自 PHP 5.1.0 起（此版本日期时间函数被重写了），如果时区不合法则每个对日期时间函数的调用都会产生一条 E_NOTICE 级别的错误信息，如果使用系统设定或 TZ 环境变量则还会产生 E_STRICT 级别的信息。

例子

<?php
echo(date_default_timezone_set("Europe/Paris"));
?>

输出：

1

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP date_sunrise() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP date_sunrise() 函数

PHP Date / Time 函数

定义和用法

date_sunrise() 函数返回指定的日期与地点的日出时间。

语法

date_sunrise(timestamp,format,latitude,longitude,zenith,gmt_offset)
参数 | 描述
timestamp | 必需。
format

可选。规定如何返回结果：

  • SUNFUNCS_RET_STRING (以 string 格式返回结果，比如 16:46)
  • SUNFUNCS_RET_DOUBLE (以 float 格式返回结果，比如 16.78243132)
  • SUNFUNCS_RET_TIMESTAMP (以 integer 格式（时间戳）返回结果，比如 1095034606)
latitude | 可选。规定地点的纬度。默认是指北纬。因此如果要指定南纬，必须传递一个负值。
longitude | 可选。规定地点的经度。默认是指东经。因此如果要指定西经，必须传递一个负值。
zenith | 可选。
gmt_offset | 可选。规定 GMT 与本地时间的差值。单位是小时。

例子

<?php
//计算葡萄牙里斯本的日出时间
//Latitude: 北纬 38.4 度
//Longitude: 西经 9 度
//Zenith ~= 90
//offset: +1 GMT
echo("Date: " . date("D M d Y") . "<br />");
echo("Sunrise time: ");
echo(date_sunrise(time(),SUNFUNCS_RET_STRING,38.4,-9,90,1));
?>

输出：

Date: Tue Jan 24 2006
Sunrise time: 08:52

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP date_sunset() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP date_sunset() 函数

PHP Date / Time 函数

定义和用法

date_sunset() 函数返回指定的日期与地点的日落时间。

语法

date_sunset(timestamp,format,latitude,longitude,zenith,gmt_offset)
参数 | 描述
timestamp | 必需。
format

可选。规定如何返回结果：

  • SUNFUNCS_RET_STRING (以 string 格式返回结果，比如 16:46)
  • SUNFUNCS_RET_DOUBLE (以 float 格式返回结果，比如 16.78243132)
  • SUNFUNCS_RET_TIMESTAMP (以 integer 格式（时间戳）返回结果，比如 1095034606)
latitude | 可选。规定地点的纬度。默认是指北纬。因此如果要指定南纬，必须传递一个负值。
longitude | 可选。规定地点的经度。默认是指东经。因此如果要指定西经，必须传递一个负值。
zenith | 可选。
gmt_offset | 可选。规定 GMT 与本地时间的差值。单位是小时。

例子

<?php
//计算葡萄牙里斯本的日出时间
//Latitude: 北纬 38.4 度
//Longitude: 西经 9 度
//Zenith ~= 90
//offset: +1 GMT
echo("Date: " . date("D M d Y") . "<br />");
echo("Sunrise time: ");
echo(date_sunset(time(),SUNFUNCS_RET_STRING,38.4,-9,90,1));
?>

输出：

Date: Tue Jan 24 2006
Sunrise time: 18:44

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP Date()

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Date()

  • Previous Page
  • Next Page

PHP 的 date() 函数用于格式化时间或日期。

PHP Date() 函数

PHP Date() 函数可把时间戳格式化为可读性更好的日期和时间。

语法

date(format,timestamp)
参数 | 描述
format | 必需。规定时间戳的格式。
timestamp | 可选。规定时间戳。默认是当前的日期和时间。

PHP 日期 - 什么是时间戳（Timestamp）？

时间戳是自 1970 年 1 月 1 日（00:00:00 GMT）以来的秒数。它也被称为 Unix 时间戳（Unix Timestam）。

PHP 日期 - 格式化日期

date() 函数的第一个参数规定了如何格式化日期/时间。它使用字母来表示日期和时间的格式。这里列出了一些可用的字母：

  • d - 月中的天 (01-31)
  • m - 当前月，以数字计 (01-12)
  • Y - 当前的年（四位数）

您可以在我们的 PHP Date 参考手册中，找到格式参数中可以使用的所有字母。

可以在字母之间插入其他字符，比如 "/"、"." 或者 "-"，这样就可以增加附加格式了：

<?php
echo date("Y/m/d");
echo "<br />";
echo date("Y.m.d");
echo "<br />";
echo date("Y-m-d");
?>

以上代码的输出类似这样：

2006/07/11
2006.07.11
2006-07-11

PHP 日期 - 添加时间戳

date() 函数的第二个参数规定了一个时间戳。此参数是可选的。如果您没有提供时间戳，当前的时间将被使用。

在我们的例子中，我们将使用 mktime() 函数为明天创建一个时间戳。

mktime() 函数可为指定的日期返回 Unix 时间戳。

语法

mktime(hour,minute,second,month,day,year,is_dst)

如需获得某一天的时间戳，我们只要设置 mktime() 函数的 day 参数就可以了：

<?php
$tomorrow = mktime(0,0,0,date("m"),date("d")+1,date("Y"));
echo "Tomorrow is ".date("Y/m/d", $tomorrow);
?>

以上代码的输出类似这样：

明天是 2006/07/12

PHP 日期 - 参考手册

如需更多有关 PHP 日期函数的信息，请访问 W3School 为您提供的 PHP Date 参考手册。

  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP date() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP date() 函数

PHP Date / Time 函数

定义和用法

date() 函数格式化一个本地时间／日期。

语法

date(format,timestamp)
参数 | 描述
format | 必需。规定如何返回结果。
timestamp | 可选。

例子

<?php
echo("Result with date():<br />");
echo(date("l") . "<br />");
echo(date("l dS \of F Y h:i:s A") . "<br />");
echo("Oct 3,1975 was on a ".date("l", mktime(0,0,0,10,3,1975))."<br />");
echo(date(DATE_RFC822) . "<br />");
echo(date(DATE_ATOM,mktime(0,0,0,10,3,1975)) . "<br /><br />");

echo("Result with gmdate():<br />");
echo(gmdate("l") . "<br />");
echo(gmdate("l dS \of F Y h:i:s A") . "<br />");
echo("Oct 3,1975 was on a ".gmdate("l", mktime(0,0,0,10,3,1975))."<br />");
echo(gmdate(DATE_RFC822) . "<br />");
echo(gmdate(DATE_ATOM,mktime(0,0,0,10,3,1975)) . "<br />");
?>

输出：

Result with date():
Tuesday
Tuesday 24th of January 2006 02:41:22 PM
Oct 3,1975 was on a Friday
Tue, 24 Jan 2006 14:41:22 CET
1975-10-03T00:00:00+0100

Result with gmdate():
Tuesday
Tuesday 24th of January 2006 01:41:22 PM
Oct 3,1975 was on a Thursday
Tue, 24 Jan 2006 13:41:22 GMT
1975-10-02T23:00:00+0000

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP debug_backtrace() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP debug_backtrace() 函数

PHP Error 和 Logging 函数

定义和用法

PHP debug_backtrace() 函数生成一个 backtrace。

该函数返回一个关联数组。下面是可能返回的元素：

名称 | 类型 | 描述
function | 字符串 | 当前的函数名。
line | 整数 | 当前的行号。
file | 字符串 | 当前的文件名。
class | 字符串 | 当前的类名
object | 对象 | 当前对象。
type 字符串 当前的调用类型，可能的调用：
  • 返回: "->" - 方法调用
  • 返回: "::" - 静态方法调用
  • 返回 nothing - 函数调用
args | 数组 | 如果在函数中，列出函数参数。如果在被引用的文件中，列出被引用的文件名。

语法

debug_backtrace()

例子

<?php
function one($str1, $str2)
 {
 two("Glenn", "Quagmire");
 }
function two($str1, $str2)
 {
 three("Cleveland", "Brown");
 }
function three($str1, $str2)
 {
 print_r(debug_backtrace());
 }

one("Peter", "Griffin");
?>

输出：

Array
(
[0] => Array
 (
 [file] => C:\webfolder\test.php
 [line] => 7
 [function] => three
 [args] => Array
  (
  [0] => Cleveland
  [1] => Brown
  )
 )
[1] => Array
 (
 [file] => C:\webfolder\test.php
 [line] => 3
 [function] => two
 [args] => Array
  (
  [0] => Glenn
  [1] => Quagmire
  )
 )
[2] => Array
 (
 [file] => C:\webfolder\test.php
 [line] => 14
 [function] => one
 [args] => Array
  (
  [0] => Peter
  [1] => Griffin
  )
 )
)

PHP Error 和 Logging 函数

PHP 参考手册
PHP 测验


PHP debug_print_backtrace() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP debug_print_backtrace() 函数

PHP Error 和 Logging 函数

定义和用法

debug_print_backtrace() 函数输出 backtrace。

语法

debug_print_backtrace()

例子

<?php
function one($str1, $str2)
 {
 two("Glenn", "Quagmire");
 }
function two($str1, $str2)
 {
 three("Cleveland", "Brown");
 }
function three($str1, $str2)
 {
 debug_print_backtrace();
 }

one("Peter", "Griffin");
?>

输出：

#0 three(Cleveland, Brown) called at [C:\webfolder\test.php:8]
#1 two(Glenn, Quagmire) called at [C:\webfolder\test.php:4]
#2 one(Peter, Griffin) called at [C:\webfolder\test.php:15]

PHP Error 和 Logging 函数

PHP 参考手册
PHP 测验


PHP decbin() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP decbin() 函数

PHP Math 函数

定义和用法

decbin() 函数把十进制转换为二进制。

语法

decbin(dec_number)
参数 | 描述
dec_number | 必需。规定要转换的十进制数。

说明

返回一个字符串，包含有给定 dec_number 参数的二进制表示。所能转换的最大数值为十进制的 4294967295，其结果为 32 个 1 的字符串。

例子

<?php
echo decbin("3");
echo decbin("1");
echo decbin("1587");
echo decbin("7");
?>

输出：

11
1
11000110011
111

PHP Math 函数

PHP 参考手册
PHP 测验


PHP dechex() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP dechex() 函数

PHP Math 函数

定义和用法

dechex() 函数把十进制转换为十六进制。

语法

dechex(dec_number)
参数 | 描述
dec_number | 必需。规定要转换的十进制数。

说明

返回一个字符串，包含有给定 binary_string 参数的十六进制表示。所能转换的最大数值为十进制的 4294967295，其结果为 ""ffffffff"。

例子

<?php
echo dechex("30");
echo dechex("10");
echo dechex("1587");
echo dechex("70");
?>

输出：

1e
a
633
46

PHP Math 函数

PHP 参考手册
PHP 测验


PHP decoct() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP decoct() 函数

PHP Math 函数

定义和用法

decoct() 函数把十进制转换为八进制。

语法

decoct(dec_number)
参数 | 描述
dec_number | 必需。规定要转换的十进制数。

说明

返回一个字符串，包含有给定 dec_number 参数的八进制表示。所能转换的最大数值为十进制的 4294967295，其结果为 "37777777777"。

例子

<?php
echo decoct("30");
echo decoct("10");
echo decoct("1587");
echo decoct("70");
?>

输出：

36
12
3063
106

PHP Math 函数

PHP 参考手册
PHP 测验


PHP define() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP define() 函数

PHP 杂项函数

定义和用法

define() 函数定义一个常量。

常量类似变量，不同之处在于：

  • 在设定以后，常量的值无法更改
  • 常量名不需要开头的美元符号 ($)
  • 作用域不影响对常量的访问
  • 常量值只能是字符串或数字

语法

define(name,value,case_insensitive)
参数 | 描述
name | 必需。规定常量的名称。
value | 必需。规定常量的值。
case_insensitive | 必需。规定常量的名称是否对大小写敏感。 若设置为 true，则对大小写不敏感。默认是 false（大小写敏感）。

例子

例子 1

定义一个大小写敏感的常量：

<?php
define("GREETING","Hello world!");
echo constant("GREETING");
?>

输出：

Hello world!

例子 2

定义一个大小写不敏感的常量：

<?php
define("GREETING","Hello world!",TRUE);
echo constant("greeting");
?>

输出：

Hello world!

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP defined() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP defined() 函数

PHP 杂项函数

定义和用法

defined() 函数检查某常量是否存在。

若常量存在，则返回 true，否则返回 false。

语法

defined(name)
参数 | 描述
name | 必需。规定要检查的常量的名称。

例子

<?php
define("GREETING","Hello world!");
echo defined("GREETING");
?>

输出：

1

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP deg2rad() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP deg2rad() 函数

PHP Math 函数

定义和用法

deg2rad() 函数将角度转换为弧度。

语法

deg2rad(degree_number)
参数 | 描述
degree_number | 必需。规定要转换的角度。

说明

本函数把 degree_number 从角度转换成弧度。

例子 1

<?php
echo deg2rad("30");
echo deg2rad("10");
echo deg2rad("1587");
echo deg2rad("70");
?>

输出：

0.523598775598
0.174532925199
27.6983752292
1.2217304764

例子 2

<?php
$deg = 180;
$rad = deg2rad($deg);
echo "角度 $deg 等于弧度 $rad";
?>

输出：

角度 180 等于弧度 3.14159265359

PHP Math 函数

PHP 参考手册
PHP 测验


PHP die() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP die() 函数

PHP 杂项函数

定义和用法

die() 函数输出一条消息，并退出当前脚本。

该函数是 exit() 函数的别名。

语法

die(status)
参数 | 描述
status | 必需。规定在退出脚本之前写入的消息或状态号。状态号不会被写入输出。

说明

如果 status 是字符串，则该函数会在退出前输出字符串。

如果 status 是整数，这个值会被用作退出状态。退出状态的值在 0 至 254 之间。退出状态 255 由 PHP 保留，不会被使用。状态 0 用于成功地终止程序。

提示和注释

注释：如果 PHP 的版本号大于等于 4.2.0，那么在 status 是整数的情况下，不会输出该参数。

例子

<?php
$site = "http://www.w3school.com.cn/";
fopen($site,"r")
or die("Unable to connect to $site");
?>

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP dir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP dir() 函数

PHP Directory 函数

定义和用法

dir() 函数打开一个目录句柄，并返回一个对象。这个对象包含三个方法：read() , rewind() 以及 close()。

若成功，则该函数返回一个目录流，否则返回 false 以及一个 error。可以通过在函数名前加上 "@" 来隐藏 error 的输出。

语法

dir(directory)
参数 | 描述
directory | 必需。规定目录。

例子

例子 1

<?php
//打开 images 目录
$dir = dir("images");

//列出 images 目录中的文件
while (($file = $dir->read()) !== false)
{
echo "filename: " . $file . "<br />";
}

$dir->close();
?>

输出：

filename: .
filename: ..
filename: cat.gif
filename: dog.gif
filename: food
filename: horse.gif

例子 2

如果 dir() 的输出失败，本例会隐藏错误：

<?php
//打开 images 目录
$dir = @ dir("images");

//列出 images 目录中的文件
while (($file = $dir->read()) !== false)
  {
  echo "filename: " . $file . "<br />";
  }

$dir->close();
?>

输出：

filename: .
filename: ..
filename: cat.gif
filename: dog.gif
filename: food
filename: horse.gif

PHP Directory 函数

PHP 参考手册
PHP 测验


PHP Directory 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Directory 函数

  • Previous Page
  • Next Page

PHP Directory 简介

Directory 函数允许您获得关于目录及其内容的信息。

安装

Directory 函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

PHP Directory 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
chdir() | 改变当前的目录。 | 3
chroot() | 改变当前进程的根目录。 | 4
dir() | 打开一个目录句柄，并返回一个对象。 | 3
closedir() | 关闭目录句柄。 | 3
getcwd() | 返回当前目录。 | 4
opendir() | 打开目录句柄。 | 3
readdir() | 返回目录句柄中的条目。 | 3
rewinddir() | 重置目录句柄。 | 3
scandir() | 列出指定路径中的文件和目录。 | 5

PHP Directory 常量

PHP：指示支持该常量的最早的 PHP 版本。

常量 | 描述 | PHP
DIRECTORY_SEPARATOR |  | 3
PATH_SEPARATOR |  | 4
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP dirname() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP dirname() 函数

PHP Filesystem 函数

定义和用法

dirname() 函数返回路径中的目录部分。

语法

dirname(path)
参数 | 描述
path | 必需。规定要检查的路径。

说明

path 参数是一个包含有指向一个文件的全路径的字符串。该函数返回去掉文件名后的目录名。

例子

<?php
echo dirname("c:/testweb/home.php");
echo dirname("/testweb/home.php");
?>

输出：

c:/testweb
/testweb

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP disk_free_space() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP disk_free_space() 函数

PHP Filesystem 函数

定义和用法

disk_free_space() 函数返回目录中的可用空间

语法

disk_free_space(directory)
参数 | 描述
directory | 必需。规定要检查的目录。

说明

directory 参数是一个目录的字符串。该函数将根据相应的文件系统或磁盘分区返回可用的字节数。

例子

<?php
echo disk_free_space("C:");
?>

输出：

209693288558

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP disk_total_space() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP disk_total_space() 函数

PHP Filesystem 函数

定义和用法

disk_total_space() 函数返回指定目录的磁盘总大小。

语法

disk_total_space(directory)
参数 | 描述
directory | 必需。规定要检查的目录。

说明

directory 参数是一个目录的字符串。该函数将根据相应的文件系统或磁盘分区返回所有的字节数。

提示和注释

提示：本函数返回的是该目录所在的磁盘分区的总大小，因此在给出同一个磁盘分区的不同目录作为参数所得到的结果完全相同。在 Unix 和 Windows 200x/XP 中都支持将一个磁盘分区加载为一个子目录，这时正确使用本函数就很有意义。

例子

<?php
echo disk_total_space("C:");
?>

输出类似这样：

509693888668

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP diskfreespace() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP diskfreespace() 函数

PHP Filesystem 函数

定义和用法

diskfreespace() 函数返回目录中的可用空间。该函数是 disk_free_space() 函数的别名。

语法

diskfreespace(directory)
参数 | 描述
directory | 必需。规定要检查的目录。

说明

directory 参数是一个目录的字符串。该函数将根据相应的文件系统或磁盘分区返回可用的字节数。

例子

<?php
echo diskfreespace("C:");
?>

输出：

209693288558

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP each() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP each() 函数

PHP Array 函数

定义和用法

each() 函数生成一个由数组当前内部指针所指向的元素的键名和键值组成的数组，并把内部指针向前移动。

返回的数组中包括的四个元素：键名为 0，1，key 和 value。单元 0 和 key 包含有数组单元的键名，1 和 value 包含有数据。

如果内部指针越过了数组范围，本函数将返回 FALSE。

语法

each(array)
参数 | 描述
array | 必需。规定要使用的数组。

例子 1

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");
print_r (each($people));
?>

输出：

Array ( [1] => Peter [value] => Peter [0] => 0 [key] => 0 )

例子 2

each() 经常和 list() 结合使用来遍历数组。本例与上例类似，不过循环输出了整个数组：

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");

reset($people);

while (list($key, $val) = each($people))
  {
  echo "$key => $val<br />";
  }
?>

输出：

0 => Peter
1 => Joe
2 => Glenn
3 => Cleveland

例子解释

因为将一个数组赋值给另一个数组时会重置原来的数组指针，因此在上例中如果我们在循环内部将 $people 赋给了另一个变量的话将会导致无限循环。

PHP Array 函数

PHP 参考手册
PHP 测验


PHP easter_date() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP easter_date() 函数

PHP Array 函数

定义和用法

easter_date() 函数返回指定年份的复活节午夜的 Unix 时间戳。

输入一个年份，则以 UNIX 时间戳记的格式返回该年的复活节日期，若没有输入年份，则计算当年的日期。

语法

easter_date(year)
参数 | 描述
year | 可选。定义用于计算复活节日期的年份。若省略，使用当年。

提示和注释

注释：如果年份在 Unix 时间戳的范围之外（1970 之前或 2037 之后），该函数会生成一个警告。可使用 easter_days() 代替 easter_date() 来计算年份在范围之外的复活节日期。

例子

<?php
echo(easter_date() . "<br />");
echo(date("M-d-Y",easter_date()) . "<br />");
echo(date("M-d-Y",easter_date(2000)) . "<br />");
echo(date("M-d-Y",easter_date(2001)) . "<br />");
echo(date("M-d-Y",easter_date(2002)));
?>

输出：

1145138400
Apr-16-2006
Apr-23-2000
Apr-15-2001
Mar-31-2002

PHP Array 函数

PHP 参考手册
PHP 测验


PHP easter_days() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP easter_days() 函数

PHP Array 函数

定义和用法

easter_days() 函数返回指定年份的复活节与 3 月 21 日之间的天数。

输入一个年份，则计算该年复活节与三月二十一日之间的日期数，若没有输入年份，则以当年计算。这个函数可以用来替代 easter_date() 在 1970-2037 年范围外无法计算的问题。

语法

easter_date(year)
参数 | 描述
year | 可选。定义用于计算复活节日期的年份。若省略，使用当年。
method | 可选。允许你计算机与其它历法的复活节日期。例如，如果设置为 CAL_EASTER_ROMAN，则使用 1582 - 1752 年期间的格利高里历法。

例子

<?php
echo(easter_days() . "<br />");
echo(easter_days(1990) . "<br />");
echo(easter_days(1342) . "<br />");
echo(easter_days(2050);
?>

输出：

26
25
10
20

PHP Array 函数

PHP 参考手册
PHP 测验


PHP echo() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP echo() 函数

PHP String 函数

定义和用法

echo() 函数输出一个或多个字符串。

语法

echo(strings)
参数 | 描述
strings | 必需。一个或多个要发送到输出的字符串。

提示和注释

注释：echo() 实际上不是一个函数，因此您无需对其使用括号。不过，如果您希望向 echo() 传递一个或多个参数，那么使用括号会发生解析错误。

提示：echo() 函数比 print() 函数快一点点。

提示：echo() 函数可以使用简化语法。参见例子 5。

例子

例子 1

<?php
$str = "Who's John Adams?";
echo $str;
echo "<br />";
echo $str."<br />I don't know!";
?>

输出：

Who's John Adam?
Who's John Adam?
I don't know!

例子 2

<?php
echo "This text
spans multiple
lines.";
?>

输出：

This text spans multiple lines.

例子 3

<?php
echo 'This ','string ','was ','made ','with multiple parameters';
?>

输出：

This string was made with multiple parameters

例子 4

单引号和双引号的不同之处。单引号仅输出变量名，而不是值：

<?php
$color = "red";
echo "Roses are $color";
echo "<br />";
echo 'Roses are $color';
?>

输出：

Roses are red
Roses are $color

例子 5

简化语法：

<html>
<body>

<?php
$color = "red";
?>

<p>Roses are <?=$color?></p>

</body>
</html>

PHP String 函数

PHP 参考手册
PHP 测验


PHP end() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP each() 函数

PHP Array 函数

定义和用法

end() 函数将数组内部指针指向最后一个元素，并返回该元素的值（如果成功）。

语法

end(array)
参数 | 描述
array | 必需。规定要使用的数组。

例子

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");

echo current($people) . "<br />";
echo end($people);
?>

输出：

Peter
Cleveland

PHP Array 函数

PHP 参考手册
PHP 测验


PHP error_get_last() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP error_get_last() 函数

PHP Error 和 Logging 函数

定义和用法

error_get_last() 函数获取最后发生的错误。

该函数以数组的形式返回最后发生的错误。

返回的数组包含 4 个键和值：

  • [type] - 错误类型
  • [message] - 错误消息
  • [file] - 发生错误所在的文件
  • [line] - 发生错误所在的行

语法

error_get_last()

例子

<?php
echo $test;
print_r(error_get_last());
?>

输出：

Array
(
[type] => 8
[message] => Undefined variable: test
[file] => C:\webfolder\test.php
[line] => 2
)

PHP Error 和 Logging 函数

PHP 参考手册
PHP 测验


PHP error_log() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP error_log() 函数

PHP Error 和 Logging 函数

定义和用法

error_log() 函数向服务器错误记录、文件或远程目标发送一个错误。

若成功，返回 true，否则返回 false。

语法

error_log(error,type,destination,headers)
参数 | 描述
error | 必需。要记录的错误消息。
type

可选。规定错误记录的类型。

可能的记录类型：

  • 0 - 默认。根据在 php.ini 文件中的 error_log 配置，错误被发送到服务器日志系统或文件。
  • 1 - 错误被发送到 destination 参数中的地址。只有该类型使用 headers 参数。
  • 2 - 通过 PHP debugging 连接来发送错误。该选项只在 PHP 3 中可用。
  • 3 - 错误发送到文件目标字符串。
destination | 可选。规定向何处发送错误消息。该参数的值依赖于 "type" 参数的值。
headers

可选。只在 "type" 为 1 时使用。

规定附加的头部，比如 From, Cc 以及 Bcc。由 CRLF (\r\n) 分隔。

注释：在发送电子邮件时，必须包含 From 头部。可以在 php.ini 文件中或者通过此参数设置。

例子

本例发送一封带有自定义错误的电子邮件：

<?php
$test=2;

if ($test>1)
{
error_log("A custom error has been triggered",
1,"someone@example.com","From: webmaster@example.com");
}
?>

输出：

A custom error has been triggered

PHP Error 和 Logging 函数

PHP 参考手册
PHP 测验


PHP error_reporting() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP error_reporting() 函数

PHP Error 和 Logging 函数

定义和用法

error_reporting() 设置 PHP 的报错级别并返回当前级别。

语法

error_reporting(report_level)

如果参数 level 未指定，当前报错级别将被返回。下面几项是 level 可能的值：

值 | 常量 | 描述
1 | E_ERROR | Fatal run-time errors. Errors that can not be recovered from. Execution of the script is halted
2 | E_WARNING | Non-fatal run-time errors. Execution of the script is not halted
4 | E_PARSE | Compile-time parse errors. Parse errors should only be generated by the parser
8 | E_NOTICE | Run-time notices. The script found something that might be an error, but could also happen when running a script normally
16 | E_CORE_ERROR | Fatal errors at PHP startup. This is like an E_ERROR in the PHP core
32 | E_CORE_WARNING | Non-fatal errors at PHP startup. This is like an E_WARNING in the PHP core
64 | E_COMPILE_ERROR | Fatal compile-time errors. This is like an E_ERROR generated by the Zend Scripting Engine
128 | E_COMPILE_WARNING | Non-fatal compile-time errors. This is like an E_WARNING generated by the Zend Scripting Engine
256 | E_USER_ERROR | Fatal user-generated error. This is like an E_ERROR set by the programmer using the PHP function trigger_error()
512 | E_USER_WARNING | Non-fatal user-generated warning. This is like an E_WARNING set by the programmer using the PHP function trigger_error()
1024 | E_USER_NOTICE | User-generated notice. This is like an E_NOTICE set by the programmer using the PHP function trigger_error()
2048 | E_STRICT | Run-time notices. PHP suggest changes to your code to help interoperability and compatibility of the code
4096 | E_RECOVERABLE_ERROR | Catchable fatal error. This is like an E_ERROR but can be caught by a user defined handle (see also set_error_handler())
8191 | E_ALL | All errors and warnings, except level E_STRICT (E_STRICT will be part of E_ALL as of PHP 6.0)

例子

任意数目的以上选项都可以用“或”来连接（用 OR 或 |），这样可以报告所有需要的各级别错误。例如，下面的代码关闭了用户自定义的错误和警告，执行了某些操作，然后恢复到原始的报错级别：

<?php
//禁用错误报告
error_reporting(0);

//报告运行时错误
error_reporting(E_ERROR | E_WARNING | E_PARSE);

//报告所有错误
error_reporting(E_ALL);
?>

PHP Error 和 Logging 函数

PHP 参考手册
PHP 测验


PHP Error 和 Logging 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Error 和 Logging 函数

  • Previous Page
  • Next Page

PHP Error 和 Logging 简介

error 和 logging 函数允许你对错误进行处理和记录。

error 函数允许用户定义错误处理规则，并修改记录错误的方式。

logging 函数允许用户对应用程序进行日志记录，并把日志消息发送到电子邮件、系统日志或其他的机器。

安装

error 和 logging 函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

PHP Error 和 Logging 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
debug_backtrace() | 生成 backtrace。 | 4
debug_print_backtrace() | 输出 backtrace。 | 5
error_get_last() | 获得最后发生的错误。 | 5
error_log() | 向服务器错误记录、文件或远程目标发送一个错误。 | 4
error_reporting() | 规定报告哪个错误。 | 4
restore_error_handler() | 恢复之前的错误处理程序。 | 4
restore_exception_handler() | 恢复之前的异常处理程序。 | 5
set_error_handler() | 设置用户自定义的错误处理函数。 | 4
set_exception_handler() | 设置用户自定义的异常处理函数。 | 5
trigger_error() | 创建用户自定义的错误消息。 | 4
user_error() | trigger_error() 的别名。 | 4

PHP Error 和 Logging 常量

PHP：指示支持该常量的最早的 PHP 版本。

值 | 常量 | 描述 | PHP
1 | E_ERROR | 致命的运行时错误。错误无法恢复。脚本的执行被中断。 |
2 | E_WARNING | 非致命的运行时错误。脚本的执行不会中断。 |
4 | E_PARSE | 编译时语法解析错误。解析错误只应该由解析器生成。 |
8 | E_NOTICE | 运行时提示。可能是错误，也可能在正常运行脚本时发生。 |
16 | E_CORE_ERROR | 由 PHP 内部生成的错误。 | 4
32 | E_CORE_WARNING | 由 PHP 内部生成的警告。 | 4
64 | E_COMPILE_ERROR | 由 Zend 脚本引擎内部生成的错误。 | 4
128 | E_COMPILE_WARNING | 由 Zend 脚本引擎内部生成的警告。 | 4
256 | E_USER_ERROR | 由于调用 trigger_error() 函数生成的运行时错误。 | 4
512 | E_USER_WARNING | 由于调用 trigger_error() 函数生成的运行时警告。 | 4
1024 | E_USER_NOTICE | 由于调用 trigger_error() 函数生成的运行时提示。 | 4
2048 | E_STRICT | 运行时提示。对增强代码的互用性和兼容性有益。 | 5
4096 | E_RECOVERABLE_ERROR | 可捕获的致命错误。（参阅 set_error_handler()） | 5
8191 | E_ALL | 所有的错误和警告，除了 E_STRICT。 | 5
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP eval() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP eval() 函数

PHP 杂项函数

定义和用法

eval() 函数把字符串按照 PHP 代码来计算。

该字符串必须是合法的 PHP 代码，且必须以分号结尾。

如果没有在代码字符串中调用 return 语句，则返回 NULL。如果代码中存在解析错误，则 eval() 函数返回 false。

语法

eval(phpcode)
参数 | 描述
phpcode | 必需。规定要计算的 PHP 代码。

提示和注释

注释：返回语句会立即终止对字符串的计算。

注释：该函数对于在数据库文本字段中供日后计算而进行的代码存储很有用。

例子

<?php
$string = "beautiful";
$time = "winter";

$str = 'This is a $string $time morning!';
echo $str. "<br />";

eval("\$str = \"$str\";");
echo $str;
?>

输出：

This is a $string $time morning!
This is a beautiful winter morning!

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP exit() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP exit() 函数

PHP 杂项函数

定义和用法

exit() 函数输出一条消息，并退出当前脚本。

该函数是 die() 函数的别名。

语法

exit(status)
参数 | 描述
status | 必需。规定在退出脚本之前写入的消息或状态号。状态号不会被写入输出。

说明

如果 status 是字符串，则该函数会在退出前输出字符串。

如果 status 是整数，这个值会被用作退出状态。退出状态的值在 0 至 254 之间。退出状态 255 由 PHP 保留，不会被使用。状态 0 用于成功地终止程序。

提示和注释

注释：如果 PHP 的版本号大于等于 4.2.0，那么在 status 是整数的情况下，不会输出该参数。

例子

<?php
$site = "http://www.w3school.com.cn/";
fopen($site,"r")
or exit("Unable to connect to $site");
?>

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP exp() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP exp() 函数

PHP Math 函数

定义和用法

exp() 函数计算 e 的指数。

语法

exp(x)
参数 | 描述
x | 必需。一个数。

说明

返回 e 的 x 次方值。。

提示和注释

提示：用 'e' 作为自然对数的底 2.718282。

例子

在本例中，我们将对不同的数应用 exp() 函数：

<?php
echo(exp(1));
echo(exp(-1));
echo(exp(5));
echo(exp(10))
?>

输出：

2.718281828459045
0.36787944117144233
148.4131591025766
22026.465794806718

PHP Math 函数

PHP 参考手册
PHP 测验


PHP explode() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP explode() 函数

PHP String 函数

定义和用法

explode() 函数把字符串分割为数组。

语法

explode(separator,string,limit)
参数 | 描述
separator | 必需。规定在哪里分割字符串。
string | 必需。要分割的字符串。
limit | 可选。规定所返回的数组元素的最大数目。

说明

本函数返回由字符串组成的数组，其中的每个元素都是由 separator 作为边界点分割出来的子字符串。

separator 参数不能是空字符串。如果 separator 为空字符串（""），explode() 将返回 FALSE。如果 separator 所包含的值在 string 中找不到，那么 explode() 将返回包含 string 中单个元素的数组。

如果设置了 limit 参数，则返回的数组包含最多 limit 个元素，而最后那个元素将包含 string 的剩余部分。

如果 limit 参数是负数，则返回除了最后的 -limit 个元素外的所有元素。此特性是 PHP 5.1.0 中新增的。

提示和注释

注释：参数 limit 是在 PHP 4.0.1 中加入的。

注释：由于历史原因，虽然 implode() 可以接收两种参数顺序，但是 explode() 不行。你必须保证 separator 参数在 string 参数之前才行。

例子

在本例中，我们将把字符串分割为数组：

<?php
$str = "Hello world. It's a beautiful day.";
print_r (explode(" ",$str));
?>

输出：

Array
(
[0] => Hello
[1] => world.
[2] => It's
[3] => a
[4] => beautiful
[5] => day.
)

PHP String 函数

PHP 参考手册
PHP 测验


PHP expm1() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP expm1() 函数

PHP Math 函数

定义和用法

expm1() 函数返回 exp(x) - 1，甚至当 number 的值接近零也能计算出准确结果。

语法

expm1(x)
参数 | 描述
x | 必需。一个数。

说明

expm1() 返回 'exp(x) - 1'，甚至当 x 的值接近零也能计算出准确结果。但是当两个数值趋近于相等的时候， 'exp (x) - 1' 就会变得不太准确。

提示和注释

警告：本函数是实验性的。本函数的行为，包括函数名称以及其它任何关于本函数的文档可能会在没有通知的情况下随 PHP 以后的发布而改变。使用本函数风险自担。

提示：用 'e' 作为自然对数的底 2.718282。

注释：本函数未在 Windows 平台下实现。

例子

在本例中，我们将对不同的数应用 expm1() 函数：

<?php
echo(expm1(1));
echo(expm1(-1));
echo(expm1(5));
echo(expm1(10))
?>

PHP Math 函数

PHP 参考手册
PHP 测验


PHP extract() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP extract() 函数

PHP Array 函数

定义和用法

PHP extract() 函数从数组中把变量导入到当前的符号表中。

对于数组中的每个元素，键名用于变量名，键值用于变量值。

第二个参数 type 用于指定当某个变量已经存在，而数组中又有同名元素时，extract() 函数如何对待这样的冲突。

本函数返回成功设置的变量数目。

语法

extract(array,extract_rules,prefix)
参数 | 描述
array | 必需。规定要使用的输入。
extract_rules

可选。extract() 函数将检查每个键名是否为合法的变量名，同时也检查和符号表中的变量名是否冲突。

对非法、数字和冲突的键名的处理将根据此参数决定。可以是以下值之一：

可能的值：

  • EXTR_OVERWRITE - 默认。如果有冲突，则覆盖已有的变量。
  • EXTR_SKIP - 如果有冲突，不覆盖已有的变量。（忽略数组中同名的元素）
  • EXTR_PREFIX_SAME - 如果有冲突，在变量名前加上前缀 prefix。自 PHP 4.0.5 起，这也包括了对数字索引的处理。
  • EXTR_PREFIX_ALL - 给所有变量名加上前缀 prefix（第三个参数）。
  • EXTR_PREFIX_INVALID - 仅在非法或数字变量名前加上前缀 prefix。本标记是 PHP 4.0.5 新加的。
  • EXTR_IF_EXISTS - 仅在当前符号表中已有同名变量时，覆盖它们的值。其它的都不处理。可以用在已经定义了一组合法的变量，然后要从一个数组例如 $_REQUEST 中提取值覆盖这些变量的场合。本标记是 PHP 4.2.0 新加的。
  • EXTR_PREFIX_IF_EXISTS - 仅在当前符号表中已有同名变量时，建立附加了前缀的变量名，其它的都不处理。本标记是 PHP 4.2.0 新加的。
  • EXTR_REFS - 将变量作为引用提取。这有力地表明了导入的变量仍然引用了 var_array 参数的值。可以单独使用这个标志或者在 extract_type 中用 OR 与其它任何标志结合使用。本标记是 PHP 4.3.0 新加的。
prefix

可选。请注意 prefix 仅在 extract_type 的值是 EXTR_PREFIX_SAME，EXTR_PREFIX_ALL，EXTR_PREFIX_INVALID 或 EXTR_PREFIX_IF_EXISTS 时需要。如果附加了前缀后的结果不是合法的变量名，将不会导入到符号表中。

前缀和数组键名之间会自动加上一个下划线。

例子 1

<?php
$a = 'Original';
$my_array = array("a" => "Cat","b" => "Dog", "c" => "Horse");
extract($my_array);
echo "\$a = $a; \$b = $b; \$c = $c";
?>

输出：

$a = Cat; $b = Dog; $c = Horse

例子 2

使用全部参数：

<?php
$a = 'Original';
$my_array = array("a" => "Cat","b" => "Dog", "c" => "Horse");

extract($my_array, EXTR_PREFIX_SAME, 'dup');

echo "\$a = $a; \$b = $b; \$c = $c; \$dup_a = $dup_a;";
?>

输出：

$a = Original; $b = Dog; $c = Horse; $dup_a = Cat;

PHP Array 函数

PHP 参考手册
PHP 测验


PHP fclose() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fclose() 函数

PHP Filesystem 函数

定义和用法

fclose() 函数关闭一个打开文件。

语法

fclose(file)
参数 | 描述
file | 必需。规定要关闭的文件。

说明

file 参数是一个文件指针。fclose() 函数关闭该指针指向的文件。

如果成功则返回 true，否则返回 false。

文件指针必须有效，并且是通过 fopen() 或 fsockopen() 成功打开的。

例子

<?php
$file = fopen("test.txt","r");

//执行的一些代码...

fclose($file);
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP feof() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP feof() 函数

PHP Filesystem 函数

定义和用法

feof() 函数检测是否已到达文件末尾 (eof)。

如果文件指针到了 EOF 或者出错时则返回 TRUE，否则返回一个错误（包括 socket 超时），其它情况则返回 FALSE。

语法

feof(file)
参数 | 描述
file | 必需。规定要检查的打开文件。

说明

file 参数是一个文件指针。这个文件指针必须有效，并且必须指向一个由 fopen() 或 fsockopen() 成功打开（但还没有被 fclose() 关闭）的文件。

提示和注释

提示：feof() 函数对遍历长度未知的数据很有用。

注意：如果服务器没有关闭由 fsockopen() 所打开的连接，feof() 会一直等待直到超时而返回 TRUE。默认的超时限制是 60 秒，可以使用 stream_set_timeout() 来改变这个值。

注意：如果传递的文件指针无效可能会陷入无限循环中，因为 EOF 不会返回 TRUE。

例子

<?php
$file = fopen("test.txt", "r");

//输出文本中所有的行，直到文件结束为止。
while(! feof($file))
  {
  echo fgets($file). "<br />";
  }

fclose($file);
?>

输出：

Hello, this is a test file.
There are three lines here.
This is the last line.

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fflush() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fflush() 函数

PHP Filesystem 函数

定义和用法

fflush() 函数将缓冲内容输出到文件。

语法

fflush(file)
参数 | 描述
file | 必需。规定要检查的文件流。

说明

本函数强制将所有缓冲的输出写入 file 文件句柄所指向的资源。如果成功则返回 true，否则返回 false。

文件指针必须有效，并且必须指向一个由 fopen() 或 fsockopen() 成功打开（但还没有被 fclose() 关闭）的文件。

例子

<?php
file = fopen("test.txt","r+");

// 一些代码

fflush($file);
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fgetc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fgetc() 函数

PHP Filesystem 函数

定义和用法

fgetc() 函数从文件指针中读取一个字符。

语法

fgetc(file)
参数 | 描述
file | 必需。规定要检查的文件。

说明

返回一个包含有一个字符的字符串，该字符从 file 指向的文件中得到。碰到 EOF 则返回 false。

文件指针必须有效，并且必须指向一个由 fopen() 或 fsockopen() 成功打开（但还没有被 fclose() 关闭）的文件。

提示和注释

注意：该函数可能返回布尔值 false，但也可能返回一个与 false 等值的非布尔值，例如 0 或者 ""。

注释：该函数可安全用于二进制对象。

例子

例子 1

<?php

$file = fopen("test.txt","r");
echo fgetc($file);
fclose($file);

?>

输出类似：

H

例子 2

<?php

$file = fopen("test.txt","r");

while (! feof ($file))
  {
  echo fgetc($file);
  }

fclose($file);
?>

输出类似：

Hello, this is a test file.

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fgetcsv() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fgetcsv() 函数

PHP Filesystem 函数

定义和用法

fgetcsv() 函数从文件指针中读入一行并解析 CSV 字段。

与 fgets() 类似，不同的是 fgetcsv() 解析读入的行并找出 CSV 格式的字段，然后返回一个包含这些字段的数组。

fgetcsv() 出错时返回 FALSE，包括碰到文件结束时。

注释：从 PHP 4.3.5 起，fgetcsv() 的操作是二进制安全的。

语法

fgetcsv(file,length,separator,enclosure)
参数 | 描述
file | 必需。规定要检查的文件。
length | 可选。规定行的最大长度。必须大于 CVS 文件内最长的一行。 在 PHP 5 中该参数是可选的。在 PHP 5 之前是必需的。 如果忽略（在 PHP 5.0.4 以后的版本中设为 0）该参数的话，那么长度就没有限制，不过可能会影响执行效率。
separator | 可选。设置字段分界符（只允许一个字符），默认值为逗号。
enclosure | 可选。设置字段环绕符（只允许一个字符），默认值为双引号。 该参数是在 PHP 4.3.0 中添加的。

提示和注释

注释：CSV 文件中的空行将被返回为一个包含有单个 null 字段的数组，不会被当成错误。

注释：该函数对区域设置是敏感的。比如说 LANG 设为 en_US.UTF-8 的话，单字节编码的文件就会出现读取错误。

注释：如果碰到 PHP 在读取文件时不能识别 Macintosh 文件的行结束符，可以激活 auto_detect_line_endings 运行时配置选项。

例子

例子 1

<?php

$file = fopen("contacts.csv","r");
print_r(fgetcsv($file));
fclose($file);

?>

CSV 文件：

George, John, Thomas, USA
James, Adrew, Martin, USA

输出类似：

Array
(
[0] => George
[1] => John
[2] => Thomas
[3] => USA
)

例子 2

<?php

$file = fopen("contacts.csv","r");

while(! feof($file))
  {
  print_r(fgetcsv($file));
  }

fclose($file);

?>

CSV 文件：

George, John, Thomas, USA
James, Adrew, Martin, USA

输出类似：

Array
(
[0] => George
[1] => John
[2] => Thomas
[3] => USA

Array
(
[0] => James
[1] => Adrew
[2] => Martin
[3] => USA
)

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fgets() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fgets() 函数

PHP Filesystem 函数

定义和用法

fgets() 函数从文件指针中读取一行。

语法

fgets(file,length)
参数 | 描述
file | 必需。规定要读取的文件。
length | 可选。规定要读取的字节数。默认是 1024 字节。

说明

从 file 指向的文件中读取一行并返回长度最多为 length - 1 字节的字符串。碰到换行符（包括在返回值中）、EOF 或者已经读取了 length - 1 字节后停止（要看先碰到那一种情况）。如果没有指定 length，则默认为 1K，或者说 1024 字节。

若失败，则返回 false。

提示和注释

注释：length 参数从 PHP 4.2.0 起成为可选项，如果忽略，则行的长度被假定为 1024 字节。从 PHP 4.3 开始，忽略掉 length 将继续从流中读取数据直到行结束。如果文件中的大多数行都大于 8 KB，则在脚本中指定最大行的长度在利用资源上更为有效。

注释：从 PHP 4.3 开始本函数可以安全用于二进制文件。早期的版本则不行。

注释：如果碰到 PHP 在读取文件时不能识别 Macintosh 文件的行结束符，可以激活 auto_detect_line_endings 运行时配置选项。

例子

例子 1

<?php

$file = fopen("test.txt","r");
echo fgets($file);
fclose($file);

?>

输出类似：

Hello, this is a test file.

例子 2

<?php

$file = fopen("test.txt","r");

while(! feof($file))
  {
  echo fgets($file). "<br />";
  }

fclose($file);
?>

输出类似：

Hello, this is a test file.
There are three lines here.
This is the last line.

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fgetss() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fgetss() 函数

PHP Filesystem 函数

定义和用法

fgetss() 函数从打开的文件中读取一行并过滤掉 HTML 和 PHP 标记。

与 fgets() 相同，不同的是 fgetss 尝试从读取的文本中去掉任何 HTML 和 PHP 标记。

语法

fgetss(file,length,tags)
参数 | 描述
file | 必需。规定要读取的文件。
length | 可选。规定要读取的字节数。默认是 1024 字节。该参数在 PHP 5 之前是必需的。
tags | 可选。规定将被删除的标签。

说明

可以用可选的第三个参数 tags 指定哪些标记不被去掉。

若失败，则返回 false。

例子

例子 1

<?php

$file = fopen("test.htm","r");
echo fgetss($file);
fclose($file);

?>

输出类似：

This is a paragraph.

例子 2

<?php

$file = fopen("test.htm","r");
echo fgetss($file,1024,"<p>,<b>");
fclose($file);

?>

输出类似：

This is a paragraph.

输出的源代码是：

<p><b>This is a paragraph.</b></p>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP file_exists() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP file_exists() 函数

PHP Filesystem 函数

定义和用法

file_exists() 函数检查文件或目录是否存在。

如果指定的文件或目录存在则返回 true，否则返回 false。

语法

file_exists(path)
参数 | 描述
path | 必需。规定要检查的路径。

例子

<?php
echo file_exists("test.txt");
?>

输出：

1

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP file_get_contents() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP file_get_contents() 函数

PHP Filesystem 函数

定义和用法

file_get_contents() 函数把整个文件读入一个字符串中。

和 file() 一样，不同的是 file_get_contents() 把文件读入一个字符串。

file_get_contents() 函数是用于将文件的内容读入到一个字符串中的首选方法。如果操作系统支持，还会使用内存映射技术来增强性能。

语法

file_get_contents(path,include_path,context,start,max_length)
参数 | 描述
path | 必需。规定要读取的文件。
include_path | 可选。如果也想在 include_path 中搜寻文件的话，可以将该参数设为 "1"。
context | 可选。规定文件句柄的环境。 context 是一套可以修改流的行为的选项。若使用 null，则忽略。
start | 可选。规定在文件中开始读取的位置。该参数是 PHP 5.1 新加的。
max_length | 可选。规定读取的字节数。该参数是 PHP 5.1 新加的。

说明

对 context 的支持是 PHP 5.0.0 添加的。

提示和注释

注释：本函数可安全用于二进制对象。

例子

<?php
print_r(file("test.txt"));
?>

输出：

Array
(
[0] => Hello World. Testing testing!
[1] => Another day, another line.
[2] => If the array picks up this line,
[3] => then is it a pickup line?
)

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP file_put_contents() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP file_put_contents() 函数

PHP Filesystem 函数

定义和用法

file_put_contents() 函数把一个字符串写入文件中。

与依次调用 fopen()，fwrite() 以及 fclose() 功能一样。

语法

file_put_contents(file,data,mode,context)
参数 | 描述
file | 必需。规定要写入数据的文件。如果文件不存在，则创建一个新文件。
data | 可选。规定要写入文件的数据。可以是字符串、数组或数据流。
mode

可选。规定如何打开/写入文件。可能的值：

  • FILE_USE_INCLUDE_PATH
  • FILE_APPEND
  • LOCK_EX
context

可选。规定文件句柄的环境。

context 是一套可以修改流的行为的选项。若使用 null，则忽略。

说明

参数 data 可以是数组（但不能是多维数组）。

自 PHP 5.1.0 起，data 参数也可以被指定为 stream 资源，stream 中所保存的缓存数据将被写入到指定文件中，这种用法就相似于使用 stream_copy_to_stream() 函数。

对 context 参数的支持是 PHP 5.0.0 添加的。

返回值

该函数将返回写入到文件内数据的字节数。

提示和注释

提示：使用 FILE_APPEND 可避免删除文件中已有的内容。

注释：本函数可安全用于二进制对象。

例子

<?php
echo file_put_contents("test.txt","Hello World. Testing!");
?>

输出：

26

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP file() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP file() 函数

PHP Filesystem 函数

定义和用法

file() 函数把整个文件读入一个数组中。

与 file_get_contents() 类似，不同的是 file() 将文件作为一个数组返回。数组中的每个单元都是文件中相应的一行，包括换行符在内。

如果失败，则返回 false。

语法

file(path,include_path,context)
参数 | 描述
path | 必需。规定要读取的文件。
include_path | 可选。如果也想在 include_path 中搜寻文件的话，可以将该参数设为 "1"。
context | 可选。规定文件句柄的环境。 context 是一套可以修改流的行为的选项。若使用 null，则忽略。

说明

对 context 的支持是 PHP 5.0.0 添加的。

返回的数组中每一行都包括了行结束符，因此如果不需要行结束符时还需要使用 rtrim() 函数。

提示和注释

注释：从 PHP 4.3.0 开始，可以用 file_get_contents() 来将文件读入到一个字符串并返回。

注释：从 PHP 4.3.0 开始，file() 可以安全用于二进制文件。

注释：如果碰到 PHP 在读取文件时不能识别 Macintosh 文件的行结束符，可以激活 auto_detect_line_endings 运行时配置选项。

例子

<?php
print_r(file("test.txt"));
?>

输出：

Array
(
[0] => Hello World. Testing testing!
[1] => Another day, another line.
[2] => If the array picks up this line,
[3] => then is it a pickup line?
)

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fileatime() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fileatime() 函数

PHP Filesystem 函数

定义和用法

fileatime() 函数返回指定文件的上次访问时间。

该函数返回文件上次被访问的时间。如果出错则返回 false。时间以 Unix 时间戳的方式返回。

语法

fileatime(filename)
参数 | 描述
filename | 必需。规定要检查的文件。

提示和注释

提示：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

注释：文件的 atime 应该在不论何时读取了该文件中的数据块时被更改。当一个应用程序定期访问大量文件或目录时很影响性能。有些 Unix 文件系统可以在加载时关闭 atime 的更新以提高这类程序的性能。USENET 新闻组假脱机是一个常见的例子。在这种文件系统下，本函数没有用处。

例子

<?php
echo fileatime("test.txt");
echo "Last access: ".date("F d Y H:i:s.",fileatime("test.txt"));
?>

输出：

1140684501
Last access: February 23 2006 09:48:21.

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP filectime() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filectime() 函数

PHP Filesystem 函数

定义和用法

filectime() 函数返回指定文件的上次 inode 修改时间。

该函数返回文件上次 inode 被修改的时间。如果出错则返回 false。时间以 Unix 时间戳的方式返回。

语法

fileatime(filename)
参数 | 描述
filename | 必需。规定要检查的文件。

提示和注释

提示：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

注意：在大多数 Unix 文件系统中，当一个文件的 inode 数据被改变时则该文件被认为是修改了。也就是说，当文件的权限，所有者，所有组或其它 inode 中的元数据被更新时。参见 filemtime()（这才是你想用于在 Web 页面中建立“最后更新时间”脚注的函数）和 fileatime()。

注释：某些 Unix 说明文本中把 ctime 说成是该文件建立的时间，这是错的。在大多数 Unix 文件系统中，没有 Unix 文件的建立时间。

例子

<?php
echo filectime("test.txt");
echo "Last change: ".date("F d Y H:i:s.",filectime("test.txt"));
?>

输出：

1138609592
Last change: January 30 2006 09:26:32.

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP filegroup() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filegroup() 函数

PHP Filesystem 函数

定义和用法

filegroup() 函数返回指定文件的组 ID。

若成功，则返回指定文件所属组的 ID。若失败，则返回 false 以及一个 E_WARNING 级别的错误。

组 ID 以数字格式返回。

语法

filegroup(filename)
参数 | 描述
filename | 必需。规定要检查的文件。

提示和注释

提示：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

提示：请使用 posix_getgrgid() 来将组 ID 转换为组名。

例子

<?php
echo filegroup("test.txt");
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fileinode() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fileinode() 函数

PHP Filesystem 函数

定义和用法

fileinode() 函数返回文件的 inode 编号。

若成功，则返回指定文件的 inode 节点号。若失败，则返回 false。

语法

fileinode(filename)
参数 | 描述
filename | 必需。规定要检查的文件。

提示和注释

提示：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

<?php
echo fileinode("test.txt");
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP filemtime() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filemtime() 函数

PHP Filesystem 函数

定义和用法

filemtime() 函数返回文件内容上次的修改时间。

若成功，则时间以 Unix 时间戳的方式返回。若失败，则返回 false。

语法

filemtime(filename)
参数 | 描述
filename | 必需。规定要检查的文件。

说明

本函数返回文件中的数据块上次被写入的时间，也就是说，文件的内容上次被修改的时间。

提示和注释

提示：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

<?php
echo filemtime("test.txt");
echo "Last modified: ".date("F d Y H:i:s.",filemtime("test.txt"));
?>

输出：

1139919766
Last modified: February 14 2006 13:22:46.

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fileowner() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fileowner() 函数

PHP Filesystem 函数

定义和用法

fileowner() 函数返回文件的所有者。

若成功，则返回文件所有的用户 ID。若失败，则返回 false。用户 ID 以数字格式返回。

语法

fileowner(filename)
参数 | 描述
filename | 必需。规定要检查的文件。

提示和注释

提示：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

提示：用户 ID 以数字格式返回，请使用 posix_getpwuid() 来把用户 ID 转换为用户名。

例子

<?php
echo fileowner("test.txt");
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fileperms() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fileperms() 函数

PHP Filesystem 函数

定义和用法

fileperms() 函数返回文件或目录的权限。

若成功，则返回文件的访问权限。若失败，则返回 false。

语法

fileperms(filename)
参数 | 描述
filename | 必需。规定要检查的文件。

提示和注释

提示：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

例子 1

<?php
echo fileperms("test.txt");
?>

输出：

33206

例子 2

以八进制值返回权限：

<?php
echo substr(sprintf("%o",fileperms("test.txt")),-4);
?>

输出：

1777

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP filesize() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filesize() 函数

PHP Filesystem 函数

定义和用法

filesize() 函数返回指定文件的大小。

若成功，则返回文件大小的字节数。若失败，则返回 false 并生成一条 E_WARNING 级的错误。

语法

filesize(filename)
参数 | 描述
filename | 必需。规定要检查的文件。

提示和注释

提示：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

<?php
echo filesize("test.txt");
?>

输出：

20

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP Filesystem 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Filesystem 函数

  • Previous Page
  • Next Page

PHP Filesystem 简介

Filesystem 函数允许您访问和操作文件系统。

安装

Filesystem 函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

Runtime 配置

文件系统函数的行为受到 php.ini 中设置的影响。

文件系统配置选项：

名称 | 默认 | 描述 | 可改变
allow_url_fopen | "1" | 本选项激活了 URL 形式的 fopen 封装协议使得可以访问 URL 对象例如文件。默认的封装协议提供用 ftp 和 http 协议来访问远程文件，一些扩展库例如 zlib 可能会注册更多的封装协议。 （PHP 4.0.4 版以后可用。） | PHP_INI_SYSTEM
user_agent | NULL | 定义 PHP 发送的 User-Agent。 （PHP 4.3.0 版以后可用。） | PHP_INI_ALL
default_socket_timeout | "60" | 基于 socket 的流的默认超时时间(秒)。 （PHP 4.3.0 版以后可用。） | PHP_INI_ALL
from | "" | 定义匿名 ftp 的密码（您的 email 地址）。 | PHP_INI_ALL
auto_detect_line_endings | "0" | 当设为 On 时，PHP 将检查通过 fgets() 和 file() 取得的数据中的行结束符号是符合 Unix，MS-DOS，还是 Macintosh 的习惯。 这使得 PHP 可以和 Macintosh 系统交互操作，但是默认值是 Off，因为在检测第一行的 EOL 习惯时会有很小的性能损失，而且在 Unix 系统下使用回车符号作为项目分隔符的人们会遭遇向下不兼容的行为。 （PHP 4.3.0 版以后可用。） | PHP_INI_ALL

Unix / Windows 兼容性

当在 Unix 平台上规定路径时，正斜杠 (/) 用作目录分隔符。而在 Windows 平台上，正斜杠 (/) 和反斜杠 (\) 均可使用。

PHP Filesystem 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
basename() | 返回路径中的文件名部分。 | 3
chgrp() | 改变文件组。 | 3
chmod() | 改变文件模式。 | 3
chown() | 改变文件所有者。 | 3
clearstatcache() | 清除文件状态缓存。 | 3
copy() | 复制文件。 | 3
delete() | 参见 unlink() 或 unset()。 |
dirname() | 返回路径中的目录名称部分。 | 3
disk_free_space() | 返回目录的可用空间。 | 4
disk_total_space() | 返回一个目录的磁盘总容量。 | 4
diskfreespace() | disk_free_space() 的别名。 | 3
fclose() | 关闭打开的文件。 | 3
feof() | 测试文件指针是否到了文件结束的位置。 | 3
fflush() | 向打开的文件输出缓冲内容。 | 4
fgetc() | 从打开的文件中返回字符。 | 3
fgetcsv() | 从打开的文件中解析一行，校验 CSV 字段。 | 3
fgets() | 从打开的文件中返回一行。 | 3
fgetss() | 从打开的文件中读取一行并过滤掉 HTML 和 PHP 标记。 | 3
file() | 把文件读入一个数组中。 | 3
file_exists() | 检查文件或目录是否存在。 | 3
file_get_contents() | 将文件读入字符串。 | 4
file_put_contents | 将字符串写入文件。 | 5
fileatime() | 返回文件的上次访问时间。 | 3
filectime() | 返回文件的上次改变时间。 | 3
filegroup() | 返回文件的组 ID。 | 3
fileinode() | 返回文件的 inode 编号。 | 3
filemtime() | 返回文件的上次修改时间。 | 3
fileowner() | 文件的 user ID （所有者）。 | 3
fileperms() | 返回文件的权限。 | 3
filesize() | 返回文件大小。 | 3
filetype() | 返回文件类型。 | 3
flock() | 锁定或释放文件。 | 3
fnmatch() | 根据指定的模式来匹配文件名或字符串。 | 4
fopen() | 打开一个文件或 URL。 | 3
fpassthru() | 从打开的文件中读数据，直到 EOF，并向输出缓冲写结果。 | 3
fputcsv() | 将行格式化为 CSV 并写入一个打开的文件中。 | 5
fputs() | fwrite() 的别名。 | 3
fread() | 读取打开的文件。 | 3
fscanf() | 根据指定的格式对输入进行解析。 | 4
fseek() | 在打开的文件中定位。 | 3
fstat() | 返回关于一个打开的文件的信息。 | 4
ftell() | 返回文件指针的读/写位置 | 3
ftruncate() | 将文件截断到指定的长度。 | 4
fwrite() | 写入文件。 | 3
glob() | 返回一个包含匹配指定模式的文件名/目录的数组。 | 4
is_dir() | 判断指定的文件名是否是一个目录。 | 3
is_executable() | 判断文件是否可执行。 | 3
is_file() | 判断指定文件是否为常规的文件。 | 3
is_link() | 判断指定的文件是否是连接。 | 3
is_readable() | 判断文件是否可读。 | 3
is_uploaded_file() | 判断文件是否是通过 HTTP POST 上传的。 | 3
is_writable() | 判断文件是否可写。 | 4
is_writeable() | is_writable() 的别名。 | 3
link() | 创建一个硬连接。 | 3
linkinfo() | 返回有关一个硬连接的信息。 | 3
lstat() | 返回关于文件或符号连接的信息。 | 3
mkdir() | 创建目录。 | 3
move_uploaded_file() | 将上传的文件移动到新位置。 | 4
parse_ini_file() | 解析一个配置文件。 | 4
pathinfo() | 返回关于文件路径的信息。 | 4
pclose() | 关闭有 popen() 打开的进程。 | 3
popen() | 打开一个进程。 | 3
readfile() | 读取一个文件，并输出到输出缓冲。 | 3
readlink() | 返回符号连接的目标。 | 3
realpath() | 返回绝对路径名。 | 4
rename() | 重名名文件或目录。 | 3
rewind() | 倒回文件指针的位置。 | 3
rmdir() | 删除空的目录。 | 3
set_file_buffer() | 设置已打开文件的缓冲大小。 | 3
stat() | 返回关于文件的信息。 | 3
symlink() | 创建符号连接。 | 3
tempnam() | 创建唯一的临时文件。 | 3
tmpfile() | 建立临时文件。 | 3
touch() | 设置文件的访问和修改时间。 | 3
umask() | 改变文件的文件权限。 | 3
unlink() | 删除文件。 | 3

PHP Filesystem 常量

PHP：指示支持该常量的最早的 PHP 版本。

常量 | 描述 | PHP
GLOB_BRACE |  |
GLOB_ONLYDIR |  |
GLOB_MARK |  |
GLOB_NOSORT |  |
GLOB_NOCHECK |  |
GLOB_NOESCAPE |  |
PATHINFO_DIRNAME |  |
PATHINFO_BASENAME |  |
PATHINFO_EXTENSION |  |
FILE_USE_INCLUDE_PATH |  |
FILE_APPEND |  |
FILE_IGNORE_NEW_LINES |  |
FILE_SKIP_EMPTY_LINES |  |
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP filetype() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filetype() 函数

PHP Filesystem 函数

定义和用法

filetype() 函数返回指定文件或目录的类型。

若成功，则返回 7 种可能的值。若失败，则返回 false。

可能的值：

  • fifo
  • char
  • dir
  • block
  • link
  • file
  • unknown

语法

filetype(filename)
参数 | 描述
filename | 必需。规定要检查的文件。

提示和注释

提示：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

例子 1

<?php
echo filetype("test.txt");
?>

输出：

file

例子 2

<?php
echo filetype("images");
?>

输出：

dir

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP FILTER_CALLBACK 过滤器

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP FILTER_CALLBACK 过滤器

PHP Filter 函数

定义和用法

FILTER_CALLBACK 过滤器使用用户自定义函数对值进行过滤。

这个过滤器为我们提供了对数据过滤的完全控制。

指定的函数必须存入名为 "options" 的关联数组中。请参见下面的例子。

  • Name: "callback"
  • ID-number: 1024

提示和注释

提示：您可以创建自己的函数，或者使用已有的 PHP 函数。

例子

例子 1

<?php
function convertSpace($string)
 {
 return str_replace(" ", "_", $string);
 }

$string = "Peter is a great guy!";

echo filter_var($string, FILTER_CALLBACK,
array("options"=>"convertSpace"));
?>

输出：

Peter_is_a_great_guy!

例子 2

<?php
$string="Peter is a great guy!";

echo filter_var($string, FILTER_CALLBACK,
array("options"=>"strtoupper"));
?>

输出：

PETER IS A GREAT GUY!

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP filter_has_var() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filter_has_var() 函数

PHP Filter 函数

定义和用法

filter_has_var() 函数检查是否存在指定输入类型的变量。

若成功，则返回 true，否则返回 false。

语法

filter_has_var(type, variable)
参数 | 描述
type

必需。规定要检查的类型。可能的值：

  • INPUT_GET
  • INPUT_POST
  • INPUT_COOKIE
  • INPUT_SERVER
  • INPUT_ENV
variable | 必需。规定要检查的变量。

例子

在本例中，输入变量 "name" 被发送到 PHP 页面：

<?php
if(!filter_has_var(INPUT_GET, "name"))
 {
 echo("Input type does not exist");
 }
else
 {
 echo("Input type exists");
 }
?>

输出类似：

Input type exists

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP filter_id() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filter_id() 函数

PHP Filter 函数

定义和用法

filter_id() 函数返回指定过滤器的 ID 号。

若成功，则返回过滤器的 ID 号。如果该过滤器不存在，则返回 NULL。

语法

filter_id(filter_name)
参数 | 描述
type | 必需。规定被获取 ID 号的过滤器。必须是过滤器名称（不是过滤器 ID 名）。 请使用 filter_list() 函数来获取所有被支持的过滤器的名称。

例子

<?php
echo(filter_id("validate_email"));
?>

输出类似：

274

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP filter_input_array() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filter_input_array() 函数

PHP Filter 函数

定义和用法

filter_input_array() 函数从脚本外部获取多项输入，并进行过滤。

本函数无需重复调用 filter_input()，对过滤多个输入变量很有用。

本函数可从各种来源获取输入：

  • INPUT_GET
  • INPUT_POST
  • INPUT_COOKIE
  • INPUT_ENV
  • INPUT_SERVER
  • INPUT_SESSION (Not yet implemented)
  • INPUT_REQUEST (Not yet implemented)

如果成功，则返回被过滤的数据，如果失败，则返回 false。

语法

filter_input(input_type, args)
参数 | 描述
input_type | 必需。规定输入类型。参见上面的列表中可能的类型。
args | 可选。规定过滤器参数数组。 合法的数组键是变量名。合法的值是过滤器 ID，或者规定过滤器、标志以及选项的数组。 该参数也可以是一个单独的过滤器 ID，如果是这样，输入数组中的所有值由指定过滤器进行过滤。

提示和注释

提示：参见完整的 PHP Filter 参考手册，查看可与该函数一同使用的过滤器。

例子

在本例中，我们使用 filter_input_array() 函数来过滤三个 POST 变量。所接受的 POST 变量是姓名、年龄以及电子邮件地址：

<?php
$filters = array
 (
 "name" => array
  (
  "filter"=>FILTER_CALLBACK,
  "flags"=>FILTER_FORCE_ARRAY,
  "options"=>"ucwords"
  ),
 "age" => array
  (
  "filter"=>FILTER_VALIDATE_INT,
  "options"=>array
   (
   "min_range"=>1,
   "max_range"=>120
   )
  ),
 "email"=> FILTER_VALIDATE_EMAIL,
 );
print_r(filter_input_array(INPUT_POST, $filters));
?>

输出类似：

Array
 (
 [name] => Peter
 [age] => 41
 [email] => peter@example.com
 )

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP filter_input() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filter_input() 函数

PHP Filter 函数

定义和用法

filter_input() 函数从脚本外部获取输入，并进行过滤。

本函数用于对来自非安全来源的变量进行验证，比如用户的输入。

本函数可从各种来源获取输入：

  • INPUT_GET
  • INPUT_POST
  • INPUT_COOKIE
  • INPUT_ENV
  • INPUT_SERVER
  • INPUT_SESSION (Not yet implemented)
  • INPUT_REQUEST (Not yet implemented)

如果成功，则返回被过滤的数据，如果失败，则返回 false，如果 variable 参数未设置，则返回 NULL。

语法

filter_input(input_type, variable, filter, options)
参数 | 描述
input_type | 必需。规定输入类型。参见上面的列表中可能的类型。
variable | 规定要过滤的变量。
filter | 可选。规定要使用的过滤器的 ID。默认是 FILTER_SANITIZE_STRING。 请参见完整的 PHP Filter 函数参考手册，获得可能的过滤器。 过滤器 ID 可以是 ID 名称 （比如 FILTER_VALIDATE_EMAIL），或 ID 号（比如 274）。
options | 规定包含标志/选项的数组。检查每个过滤器可能的标志和选项。

例子

在本例中，我们使用 filter_input() 函数来过滤一个 POST 变量。所接受的 POST 变量是合法的 e-mail 地址。

<?php
if (!filter_input(INPUT_POST, 'email', FILTER_VALIDATE_EMAIL))
 {
 echo "E-Mail is not valid";
 }
else
 {
 echo "E-Mail is valid";
 }
?>

输出类似：

E-Mail is valid

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP filter_list() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filter_list() 函数

PHP Filter 函数

定义和用法

filter_list() 函数返回包含所有得到支持的过滤器的一个数组。

语法

filter_list()

提示和注释

注释：该函数的结果不是过滤器的 ID，而是过滤器名称。请使用 filter_id() 函数来获取过滤器 ID。

例子

<?php
print_r(filter_list());
?>

输出类似：

Array
 (
 [0] => int
 [1] => boolean
 [2] => float
 [3] => validate_regexp
 [4] => validate_url
 [5] => validate_email
 [6] => validate_ip
 [7] => string
 [8] => stripped
 [9] => encoded
 [10] => special_chars
 [11] => unsafe_raw
 [12] => email
 [13] => url
 [14] => number_int
 [15] => number_float
 [16] => magic_quotes
 [17] => callback
 )

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP FILTER_SANITIZE_EMAIL 过滤器

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP FILTER_SANITIZE_EMAIL 过滤器

PHP Filter 函数

定义和用法

FILTER_SANITIZE_EMAIL 过滤器删除字符串中所有非法的 e-mail 字符。

该过滤器允许所有的字符、数字以及 $-_.+!*'{}|^~[]`#%/?@&=。

  • Name: "email"
  • ID-number: 517

例子

<?php
$var="some(one)@exa\\mple.com";

var_dump(filter_var($var, FILTER_SANITIZE_EMAIL));
?>

输出：

string(19) "someone@example.com"

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP FILTER_SANITIZE_ENCODED 过滤器

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP FILTER_SANITIZE_ENCODED 过滤器

PHP Filter 函数

定义和用法

FILTER_SANITIZE_ENCODED 过滤器去除或 URL 编码不需要的字符。

该函数与 urlencode() 函数很类似。

  • Name: "encoded"
  • ID-number: 514

可能的选项或标志：

  • FILTER_FLAG_STRIP_LOW - 去除 ASCII 值在 32 以下的字符
  • FILTER_FLAG_STRIP_HIGH - 去除 ASCII 值在 32 以上的字符
  • FILTER_FLAG_ENCODE_LOW - 编码 ASCII 值在 32 以下的字符
  • FILTER_FLAG_ENCODE_HIGH - 编码 ASCII 值在 32 以上的字符

例子

<?php
$url="http://www.w3school.com.cn";

var_dump(filter_var($url,FILTER_SANITIZE_ENCODED));
?>

输出：

string(32) "http%3A%2F%2Fwww.w3school.com.cn"

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP FILTER_SANITIZE_MAGIC_QUOTES 过滤器

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP FILTER_SANITIZE_MAGIC_QUOTES 过滤器

PHP Filter 函数

定义和用法

FILTER_SANITIZE_MAGIC_QUOTES 过滤器对字符串执行 addslashes() 函数。

该过滤器在预定义的字符串前面设置反斜杠。

预定义字符是：

  • single quote (')
  • double quote (")
  • backslash (\)
  • NULL

FILTER_SANITIZE_MAGIC_QUOTES 信息：

  • Name: "number_float"
  • ID-number: 520

例子

<?php
$var="Peter's here!";

var_dump(filter_var($var, FILTER_SANITIZE_MAGIC_QUOTES));
?>

输出：

string(14) "Peter\'s here!"

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP FILTER_SANITIZE_NUMBER_FLOAT 过滤器

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP FILTER_SANITIZE_NUMBER_FLOAT 过滤器

PHP Filter 函数

定义和用法

FILTER_SANITIZE_NUMBER_FLOAT 过滤器删除浮点数中所有非法的字符。

该过滤器默认允许所有数字以及 +-。

  • Name: "number_float"
  • ID-number: 520

可能的标志：

  • FILTER_FLAG_ALLOW_FRACTION - 允许小数分隔符 （比如 .）
  • FILTER_FLAG_ALLOW_THOUSAND - 允许千分隔符 （比如 ,）
  • FILTER_FLAG_ALLOW_SCIENTIFIC - 允许科学技术法 （比如 e 和 E）

例子

<?php
$number="5-2f+3.3pp";

var_dump(filter_var($number, FILTER_SANITIZE_NUMBER_FLOAT,
FILTER_FLAG_ALLOW_FRACTION));
?>

输出：

string(7) "5-2+3.3"

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP FILTER_SANITIZE_NUMBER_INT 过滤器

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP FILTER_SANITIZE_NUMBER_INT 过滤器

PHP Filter 函数

定义和用法

FILTER_SANITIZE_NUMBER_INT 过滤器删除数字中所有非法的字符。

该过滤器允许所有数字以及 +-。

  • Name: "number_int"
  • ID-number: 519

例子

<?php
$number="5-2+3pp";

var_dump(filter_var($number, FILTER_SANITIZE_NUMBER_INT));
?>

输出：

string(5) "5-2+3"

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP FILTER_SANITIZE_SPECIAL_CHARS 过滤器

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP FILTER_SANITIZE_SPECIAL_CHARS 过滤器

PHP Filter 函数

定义和用法

FILTER_SANITIZE_SPECIAL_CHARS 过滤器对特殊字符进行 HTML 转义。

该过滤器用于对 "<>& 以及 ASCII 值在 32 值以下的字符进行转义。

  • Name: "special_chars"
  • ID-number: 515

可能的标志：

  • FILTER_FLAG_STRIP_LOW - 去除 ASCII 值在 32 以下的字符
  • FILTER_FLAG_STRIP_HIGH - 去除 ASCII 值在 32 以上的字符
  • FILTER_FLAG_ENCODE_HIGH - 编码 ASCII 值在 32 以上的字符

例子

<?php
$url="Is Peter <smart> & funny?";

var_dump(filter_var($url,FILTER_SANITIZE_SPECIAL_CHARS));
?>

输出：

string(37) "Is Peter <smart> & funny?"

如果您在浏览器中查看源代码，会看到以下 HTML：

string(37) "Is Peter &lt;smart&gt; &amp; funny?"

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP FILTER_SANITIZE_STRING 过滤器

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP FILTER_SANITIZE_STRING 过滤器

PHP Filter 函数

定义和用法

FILTER_SANITIZE_STRING 过滤器去除或编码不需要的字符。

这个过滤器删除那些对应用程序有潜在危害的数据。它用于去除标签以及删除或编码不需要的字符。

  • Name: "string"
  • ID-number: 513

可能的选项或标志：

  • FILTER_FLAG_NO_ENCODE_QUOTES - 该标志不编码引号
  • FILTER_FLAG_STRIP_LOW - 去除 ASCII 值在 32 以下的字符
  • FILTER_FLAG_STRIP_HIGH - 去除 ASCII 值在 32 以上的字符
  • FILTER_FLAG_ENCODE_LOW - 编码 ASCII 值在 32 以下的字符
  • FILTER_FLAG_ENCODE_HIGH - 编码 ASCII 值在 32 以上的字符
  • FILTER_FLAG_ENCODE_AMP - 把 & 字符编码为 &amp;

例子

<?php
$var="<b>Bill Gates<b>";

var_dump(filter_var($var, FILTER_SANITIZE_STRING));
?>

输出：

string(13) "Bill Gates"

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP FILTER_SANITIZE_STRIPPED 过滤器

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP FILTER_SANITIZE_STRIPPED 过滤器

PHP Filter 函数

定义和用法

FILTER_SANITIZE_STRIPPED 过滤器去除或编码不需要的字符。

该过滤去是 FILTER_SANITIZE_STRING 过滤器的别名。

这个过滤器删除那些对应用程序有潜在危害的数据。它用于去除标签或删除或编码不需要的字符。

  • Name: "string"
  • ID-number: 513

可能的选项或标志：

  • FILTER_FLAG_NO_ENCODE_QUOTES - 该标志不编码引号
  • FILTER_FLAG_STRIP_LOW - 去除 ASCII 值在 32 以下的字符
  • FILTER_FLAG_STRIP_HIGH - 去除 ASCII 值在 32 以上的字符
  • FILTER_FLAG_ENCODE_LOW - 编码 ASCII 值在 32 以下的字符
  • FILTER_FLAG_ENCODE_HIGH - 编码 ASCII 值在 32 以上的字符
  • FILTER_FLAG_ENCODE_AMP - 把 & 字符编码为 &amp;

例子

<?php
$var="<b>Bill Gates<b>";

var_dump(filter_var($var, FILTER_SANITIZE_STRIPPED));
?>

输出：

string(13) "Bill Gates"

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP FILTER_SANITIZE_URL 过滤器

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP FILTER_SANITIZE_URL 过滤器

PHP Filter 函数

定义和用法

FILTER_SANITIZE_URL 过滤器删除字符串中所有非法的 URL 字符。

该过滤器允许所有的字符、数字以及 $-_.+!*'(),{}|\\^~[]`"><#%;/?:@&=。

  • Name: "url"
  • ID-number: 518

例子

<?php
$var="http://www.w3schooêèél.coêèém.cn";

var_dump(filter_var($var, FILTER_SANITIZE_URL));
?>

输出：

string(24) "http://www.w3school.com.cn"

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP FILTER_UNSAFE_RAW 过滤器

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP FILTER_UNSAFE_RAW 过滤器

PHP Filter 函数

定义和用法

FILTER_UNSAFE_RAW 过滤器不进行任何过滤，去除或编码特殊字符。

这个过滤器删除那些对应用程序有潜在危害的数据。它用于去除标签以及删除或编码不需要的字符。

如果不规定标志，则该过滤器没有任何行为。

  • Name: "unsafe_raw"
  • ID-number: 516

可能的选项或标志：

  • FILTER_FLAG_STRIP_LOW - 去除 ASCII 值在 32 以下的字符
  • FILTER_FLAG_STRIP_HIGH - 去除 ASCII 值在 32 以上的字符
  • FILTER_FLAG_ENCODE_LOW - 编码 ASCII 值在 32 以下的字符
  • FILTER_FLAG_ENCODE_HIGH - 编码 ASCII 值在 32 以上的字符
  • FILTER_FLAG_ENCODE_AMP - 把 & 字符编码为 &amp;

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP FILTER_VALIDATE_BOOLEAN 过滤器

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP FILTER_VALIDATE_BOOLEAN 过滤器

PHP Filter 函数

定义和用法

FILTER_VALIDATE_BOOLEAN 过滤器把值作为布尔选项来验证。

  • Name: "boolean"
  • ID-number: 258

可能的返回值：

  • 如果是 "1", "true", "on" 以及 "yes"，则返回 true。
  • 如果是 "0", "false", "off", "no" 以及 ""，则返回 false。
  • 否则返回 NULL。

例子

<?php
$var="yes";

var_dump(filter_var($var, FILTER_VALIDATE_BOOLEAN));
?>

输出：

bool(true)

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP FILTER_VALIDATE_EMAIL 过滤器

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP FILTER_VALIDATE_EMAIL 过滤器

PHP Filter 函数

定义和用法

FILTER_VALIDATE_EMAIL 过滤器把值作为电子邮件地址来验证。

  • Name: "validate_email"
  • ID-number: 274

例子

<?php
$email = "someone@exa mple.com";

if(!filter_var($email, FILTER_VALIDATE_EMAIL))
 {
 echo "E-mail is not valid";
 }
else
 {
 echo "E-mail is valid";
 }
?>

输出：

E-mail is not valid

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP FILTER_VALIDATE_FLOAT 过滤器

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP FILTER_VALIDATE_FLOAT 过滤器

PHP Filter 函数

定义和用法

FILTER_VALIDATE_FLOAT 过滤器把值作为浮点数来验证。

  • Name: "float"
  • ID-number: 259

例子

<?php
$var=12.3;

var_dump(filter_var($var, FILTER_VALIDATE_FLOAT));
?>

输出：

float(12.3)

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP FILTER_VALIDATE_INT 过滤器

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP FILTER_VALIDATE_INT 过滤器

PHP Filter 函数

定义和用法

FILTER_VALIDATE_INT 过滤器以整数验证值。

  • Name: "int"
  • ID-number: 257

可能的选项或标志：

  • min_range - 规定最小整数值
  • max_range - 规定最大整数值
  • FILTER_FLAG_ALLOW_OCTAL - 允许八进制数值
  • FILTER_FLAG_ALLOW_HEX - 允许十六进制数值

提示和注释

注释：当在数组中规定选项时，选项必须存入一个名为 "options" 的关联多维数组中。请看下面的例子。

例子

<?php
$var=300;

$int_options = array("options"=>
array("min_range"=>0, "max_range"=>256));

var_dump(filter_var($var, FILTER_VALIDATE_INT, $int_options));
?>

输出：

bool(false)

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP FILTER_VALIDATE_IP 过滤器

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP FILTER_VALIDATE_IP 过滤器

PHP Filter 函数

定义和用法

FILTER_VALIDATE_IP 过滤器把值作为 IP 进行验证。

  • Name: "validate_ip"
  • ID-number: 275

可能的标志：

  • FILTER_FLAG_IPV4 - 要求值是合法的 IPv4 IP（比如 255.255.255.255）
  • FILTER_FLAG_IPV6 - 要求值是合法的 IPv6 IP（比如 2001:0db8:85a3:08d3:1319:8a2e:0370:7334）
  • FILTER_FLAG_NO_PRIV_RANGE - 要求值是 RFC 指定的私域 IP （比如 192.168.0.1）
  • FILTER_FLAG_NO_RES_RANGE - 要求值不在保留的 IP 范围内。该标志接受 IPV4 和 IPV6 值。

例子

例子 1

<?php
$ip = "192.168.0.1";

if(!filter_var($ip, FILTER_VALIDATE_IP))
 {
 echo "IP is not valid";
 }
else
 {
 echo "IP is valid";
 }
?>

输出：

IP is valid

例子 2

<?php
$ip = "2001:0db8:85a3:08d3:1319:8a2e:0370:7334";

if(!filter_var($ip, FILTER_VALIDATE_IP, FILTER_FLAG_IPV6))
 {
 echo "IP is not valid";
 }
else
 {
 echo "IP is valid";
 }
?>

输出：

IP is valid

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP FILTER_VALIDATE_REGEXP 过滤器

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP FILTER_VALIDATE_REGEXP 过滤器

PHP Filter 函数

定义和用法

FILTER_VALIDATE_REGEXP 过滤器根据兼容 Perl 的正则表达式来验证值。

  • Name: "validate_regexp"
  • ID-number: 272

可能的选项：

  • regexp - 验证所依据的正则表达式

例子

<?php
$string = "Match this string";

var_dump(filter_var($string, FILTER_VALIDATE_REGEXP,
array("options"=>array("regexp"=>"/^M(.*)/"))))
?>

输出：

string(17) "Match this string"

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP FILTER_VALIDATE_URL 过滤器

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP FILTER_VALIDATE_URL 过滤器

PHP Filter 函数

定义和用法

FILTER_VALIDATE_URL 过滤器把值作为 URL 进行验证。

  • Name: "validate_url"
  • ID-number: 273

可能的标志：

  • FILTER_FLAG_SCHEME_REQUIRED - 要求 URL 是 RFC 兼容 URL。（比如：http://example）
  • FILTER_FLAG_HOST_REQUIRED - 要求 URL 包含主机名（http://www.example.com）
  • FILTER_FLAG_PATH_REQUIRED - 要求 URL 在主机名后存在路径（比如：eg.com/example1/）
  • FILTER_FLAG_QUERY_REQUIRED - 要求 URL 存在查询字符串（比如："eg.php?age=37"）

例子

例子 1

<?php
$url = "http://www.example.com";

if(!filter_var($url, FILTER_VALIDATE_URL))
 {
 echo "URL is not valid";
 }
else
 {
 echo "URL is valid";
 }
?>

输出：

URL is valid

例子 2

<?php
$url = "example.php?name=Peter&age=37";

if(!filter_var($url, FILTER_VALIDATE_URL, FILTER_FLAG_QUERY_REQUIRED))
{
echo "URL is not valid";
}
else
{
echo "URL is valid";
}
?>

输出：

URL is valid

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP filter_var_array() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filter_var_array() 函数

PHP Filter 函数

定义和用法

filter_var_array() 函数获取多项变量，并进行过滤。

由于无需重复调用 filter_input()，因此本函数对过滤多个变量很有用。

如果成功，则返回包含被过滤的变量值的数组，如果失败，则返回 false。

语法

filter_var_array(array, args)
参数 | 描述
array | 必需。规定带有字符串键的数组，包含要过滤的数据。
args | 可选。规定过滤器参数数组。 合法的数组键是变量名。合法的值是过滤器 ID，或者规定过滤器、标志以及选项的数组。 该参数也可以是一个单独的过滤器 ID，如果是这样，输入数组中的所有值由指定过滤器进行过滤。

提示和注释

提示：参见完整的 PHP Filter 参考手册，查看可与该函数一同使用的过滤器。

例子

<?php
$arr = array
 (
 "name" => "peter griffin",
 "age" => "41",
 "email" => "peter@example.com",
 );

$filters = array
 (
 "name" => array
  (
  "filter"=>FILTER_CALLBACK,
  "flags"=>FILTER_FORCE_ARRAY,
  "options"=>"ucwords"
  ),
 "age" => array
  (
  "filter"=>FILTER_VALIDATE_INT,
  "options"=>array
   (
   "min_range"=>1,
   "max_range"=>120
   )
  ),
 "email"=> FILTER_VALIDATE_EMAIL,
 );

print_r(filter_var_array($arr, $filters));
?>

输出类似：

Array
 (
 [name] => Peter Griffin
 [age] => 41
 [email] => peter@example.com
 )

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP filter_var() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP filter_var() 函数

PHP Filter 函数

定义和用法

filter_var() 函数通过指定的过滤器过滤变量。

如果成功，则返回已过滤的数据，如果失败，则返回 false。

语法

filter_var(variable, filter, options)
参数 | 描述
variable | 必需。规定要过滤的变量。
filter | 可选。规定要使用的过滤器的 ID。
options | 规定包含标志/选项的数组。检查每个过滤器可能的标志和选项。

提示和注释

提示：参见完整的 PHP Filter 参考手册，查看可与该函数一同使用的过滤器。

例子

<?php
if(!filter_var("someone@example....com", FILTER_VALIDATE_EMAIL))
 {
 echo("E-mail is not valid");
 }
else
 {
 echo("E-mail is valid");
 }
?>

输出类似：

E-mail is not valid

PHP Filter 函数

PHP 参考手册
PHP 测验


PHP Filter 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Filter 函数

  • Previous Page
  • Next Page

PHP Filter 简介

PHP 过滤器用于对来自非安全来源的数据（比如用户输入）进行验证和过滤。

安装

filter 函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

PHP Filter 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
filter_has_var() | 检查是否存在指定输入类型的变量。 | 5
filter_id() | 返回指定过滤器的 ID 号。 | 5
filter_input() | 从脚本外部获取输入，并进行过滤。 | 5
filter_input_array() | 从脚本外部获取多项输入，并进行过滤。 | 5
filter_list() | 返回包含所有得到支持的过滤器的一个数组。 | 5
filter_var_array() | 获取多项变量，并进行过滤。 | 5
filter_var() | 获取一个变量，并进行过滤。 | 5

PHP Filters

ID 名称 | 描述
FILTER_CALLBACK | 调用用户自定义函数来过滤数据。
FILTER_SANITIZE_STRING | 去除标签，去除或编码特殊字符。
FILTER_SANITIZE_STRIPPED | "string" 过滤器的别名。
FILTER_SANITIZE_ENCODED | URL-encode 字符串，去除或编码特殊字符。
FILTER_SANITIZE_SPECIAL_CHARS | HTML 转义字符 '"<>& 以及 ASCII 值小于 32 的字符。
FILTER_SANITIZE_EMAIL | 删除所有字符，除了字母、数字以及 !#$%&'*+-/=?^_`{|}~@.[]
FILTER_SANITIZE_URL | 删除所有字符，除了字母、数字以及 $-_.+!*'(),{}|\\^~[]`<>#%";/?:@&=
FILTER_SANITIZE_NUMBER_INT | 删除所有字符，除了数字和 +-
FILTER_SANITIZE_NUMBER_FLOAT | 删除所有字符，除了数字、+- 以及 .,eE。
FILTER_SANITIZE_MAGIC_QUOTES | 应用 addslashes()。
FILTER_UNSAFE_RAW | 不进行任何过滤，去除或编码特殊字符。
FILTER_VALIDATE_INT | 在指定的范围以整数验证值。
FILTER_VALIDATE_BOOLEAN | 如果是 "1", "true", "on" 以及 "yes"，则返回 true，如果是 "0", "false", "off", "no" 以及 ""，则返回 false。否则返回 NULL。
FILTER_VALIDATE_FLOAT | 以浮点数验证值。
FILTER_VALIDATE_REGEXP | 根据 regexp，兼容 Perl 的正则表达式来验证值。
FILTER_VALIDATE_URL | 把值作为 URL 来验证。
FILTER_VALIDATE_EMAIL | 把值作为 e-mail 来验证。
FILTER_VALIDATE_IP | 把值作为 IP 地址来验证。
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP flock() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP flock() 函数

PHP Filesystem 函数

定义和用法

flock() 函数锁定或释放文件。

若成功，则返回 true。若失败，则返回 false。

语法

flock(file,lock,block)
参数 | 描述
file | 必需。规定要锁定或释放的已打开的文件。
lock | 必需。规定要使用哪种锁定类型。
block | 可选。若设置为 1 或 true，则当进行锁定时阻挡其他进程。

说明

flock() 操作的 file 必须是一个已经打开的文件指针。

lock 参数可以是以下值之一：

  • 要取得共享锁定（读取的程序），将 lock 设为 LOCK_SH（PHP 4.0.1 以前的版本设置为 1）。
  • 要取得独占锁定（写入的程序），将 lock 设为 LOCK_EX（PHP 4.0.1 以前的版本中设置为 2）。
  • 要释放锁定（无论共享或独占），将 lock 设为 LOCK_UN（PHP 4.0.1 以前的版本中设置为 3）。
  • 如果不希望 flock() 在锁定时堵塞，则给 lock 加上 LOCK_NB（PHP 4.0.1 以前的版本中设置为 4）。

提示和注释

提示：可以通过 fclose() 来释放锁定操作，代码执行完毕时也会自动调用。

注释：由于 flock() 需要一个文件指针， 因此可能不得不用一个特殊的锁定文件来保护打算通过写模式打开的文件的访问（在 fopen() 函数中加入 "w" 或 "w+"）。

例子

<?php

$file = fopen("test.txt","w+");

// 排它性的锁定
if (flock($file,LOCK_EX))
  {
  fwrite($file,"Write something");
  // release lock
  flock($file,LOCK_UN);
  }
else
  {
  echo "Error locking file!";
  }

fclose($file);
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP floor() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP floor() 函数

PHP Math 函数

定义和用法

floor() 函数向下舍入为最接近的整数。

语法

floor(x)
参数 | 描述
x | 必需。一个数。

说明

返回不大于 x 的下一个整数，将 x 的小数部分舍去取整。floor() 返回的类型仍然是 float，因为 float 值的范围通常比 integer 要大。

例子

在本例中，我们将对不同的数应用 floor() 函数：

<?php
echo(floor(0.60));
echo(floor(0.40));
echo(floor(5));
echo(floor(5.1));
echo(floor(-5.1));
echo(floor(-5.9))
?>

输出：

0
0
5
5
-6
-6

PHP Math 函数

PHP 参考手册
PHP 测验


PHP fmod() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fmod() 函数

PHP Math 函数

定义和用法

fmod() 函数返回除法的浮点数余数。

语法

fmod(x,y)
参数 | 描述
x | 必需。一个数。
y | 必需。一个数。

说明

返回被除数（x）除以除数（y）所得的浮点数余数。余数（r）的定义是：x = i * y + r，其中 i 是整数。如果 y 是非零值，则 r 和 x 的符号相同并且其数量值小于 y 。

例子

在本例中，我们将使用 fmod() 函数来返回 5/2 的余数：

<?php
$r = fmod(5,2);
echo $r
?>

输出：

1

PHP Math 函数

PHP 参考手册
PHP 测验


PHP fmod() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fmod() 函数

PHP Math 函数

定义和用法

fmod() 函数显示随机数最大的可能值。

语法

getrandmax()

说明

返回调用 rand() 可能返回的最大值。

例子

<?php
echo(getrandmax());
?>

输出类似：

38265

PHP Math 函数

PHP 参考手册
PHP 测验


PHP fnmatch() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fnmatch() 函数

PHP Filesystem 函数

定义和用法

fnmatch() 函数根据指定的模式来匹配文件名或字符串。

语法

fnmatch(pattern,string,flags)
参数 | 描述
pattern | 必需。规定要检索的模式。
string | 必需。规定要检查的字符串或文件。
flags | 可选。

说明

此函数对于文件名尤其有用，但也可以用于普通的字符串。普通用户可能习惯于 shell 模式或者至少其中最简单的形式 '?' 和 '*' 通配符，因此使用 fnmatch() 来代替 ereg() 或者 preg_match() 来进行前端搜索表达式输入对于非程序员用户更加方便。

提示和注释

重要事项：目前该函数无法在 Windows 或其它非 POSIX 兼容的系统上使用。

例子

根据 shell 通配符来检查颜色名：

<?php
$txt = "My car is darkgrey..."
if (fnmatch("*gr[ae]y",$txt))
  {
  echo "some form of gray ...";
  }
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fopen() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fopen() 函数

PHP Filesystem 函数

定义和用法

fopen() 函数打开文件或者 URL。

如果打开失败，本函数返回 FALSE。

语法

fopen(filename,mode,include_path,context)
参数 | 描述
filename | 必需。规定要打开的文件或 URL。
mode | 必需。规定要求到该文件/流的访问类型。可能的值见下表。
include_path | 可选。如果也需要在 include_path 中检索文件的话，可以将该参数设为 1 或 TRUE。
context | 可选。规定文件句柄的环境。Context 是可以修改流的行为的一套选项。

mode 参数的可能的值

mode | 说明
"r" | 只读方式打开，将文件指针指向文件头。
"r+" | 读写方式打开，将文件指针指向文件头。
"w" | 写入方式打开，将文件指针指向文件头并将文件大小截为零。如果文件不存在则尝试创建之。
"w+" | 读写方式打开，将文件指针指向文件头并将文件大小截为零。如果文件不存在则尝试创建之。
"a" | 写入方式打开，将文件指针指向文件末尾。如果文件不存在则尝试创建之。
"a+" | 读写方式打开，将文件指针指向文件末尾。如果文件不存在则尝试创建之。
"x" | 创建并以写入方式打开，将文件指针指向文件头。如果文件已存在，则 fopen() 调用失败并返回 FALSE，并生成一条 E_WARNING 级别的错误信息。如果文件不存在则尝试创建之。 这和给底层的 open(2) 系统调用指定 O_EXCL|O_CREAT 标记是等价的。 此选项被 PHP 4.3.2 以及以后的版本所支持，仅能用于本地文件。
"x+" | 创建并以读写方式打开，将文件指针指向文件头。如果文件已存在，则 fopen() 调用失败并返回 FALSE，并生成一条 E_WARNING 级别的错误信息。如果文件不存在则尝试创建之。 这和给底层的 open(2) 系统调用指定 O_EXCL|O_CREAT 标记是等价的。 此选项被 PHP 4.3.2 以及以后的版本所支持，仅能用于本地文件。

说明

fopen() 将 filename 指定的名字资源绑定到一个流上。如果 filename 是 "scheme://..." 的格式，则被当成一个 URL，PHP 将搜索协议处理器（也被称为封装协议）来处理此模式。如果该协议尚未注册封装协议，PHP 将发出一条消息来帮助检查脚本中潜在的问题并将 filename 当成一个普通的文件名继续执行下去。

如果 PHP 认为 filename 指定的是一个本地文件，将尝试在该文件上打开一个流。该文件必须是 PHP 可以访问的，因此需要确认文件访问权限允许该访问。如果激活了安全模式或者 open_basedir 则会应用进一步的限制。

如果 PHP 认为 filename 指定的是一个已注册的协议，而该协议被注册为一个网络 URL，PHP 将检查并确认 allow_url_fopen 已被激活。如果关闭了，PHP 将发出一个警告，而 fopen 的调用则失败。

对 context 的支持是 PHP 5.0.0 添加的。

提示和注释

注释：不同的操作系统家族具有不同的行结束习惯。当写入一个文本文件并想插入一个新行时，需要使用符合操作系统的行结束符号。基于 Unix 的系统使用 \n 作为行结束字符，基于 Windows 的系统使用 \r\n 作为行结束字符，基于 Macintosh 的系统使用 \r 作为行结束字符。 如果写入文件时使用了错误的行结束符号，则其它应用程序打开这些文件时可能会表现得很怪异。

Windows 下提供了一个文本转换标记（"t"）可以透明地将 \n 转换为 \r\n。与此对应还可以使用 "b" 来强制使用二进制模式，这样就不会转换数据。要使用这些标记，要么用 "b" 或者用 "t" 作为 mode 参数的最后一个字符。

默认的转换模式依赖于 SAPI 和所使用的 PHP 版本，因此为了便于移植鼓励总是指定恰当的标记。如果是操作纯文本文件并在脚本中使用了 \n 作为行结束符，但还要期望这些文件可以被其它应用程序例如 Notepad 读取，则在 mode 中使用 "t"。在所有其它情况下使用 "b"。

在操作二进制文件时如果没有指定 "b" 标记，可能会碰到一些奇怪的问题，包括坏掉的图片文件以及关于 \r\n 字符的奇怪问题。

注释：为移植性考虑，强烈建议在用 fopen() 打开文件时总是使用 "b" 标记。

注释：再一次，为移植性考虑，强烈建议你重写那些依赖于 "t" 模式的代码使其使用正确的行结束符并改成 "b" 模式。

例子

<?php
$file = fopen("test.txt","r");
$file = fopen("/home/test/test.txt","r");
$file = fopen("/home/test/test.gif","wb");
$file = fopen("http://www.example.com/","r");
$file = fopen("ftp://user:password@example.com/test.txt","w");
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fpassthru() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fpassthru() 函数

PHP Filesystem 函数

定义和用法

fpassthru() 函数输出文件指针处的所有剩余数据。

该函数将给定的文件指针从当前的位置读取到 EOF，并把结果写到输出缓冲区。

语法

fpassthru(file)
参数 | 描述
file | 必需。规定要读取的打开文件或资源。

说明

如果发生错误， fpassthru() 返回 false。否则 fpassthru() 返回从 file 读取并传递到输出的字符数目。

文件指针必须有效，并且必须指向一个由 fopen() 或 fsockopen() 成功打开（但还没有被 fclose() 关闭）的文件。

提示和注释

提示：如果已经向文件写入数据，就必须调用 rewind() 来将文件指针指向文件头。

提示：如果既不修改文件也不在特定位置检索，只想将文件的内容下载到输出缓冲区，应该使用 readfile()，这样可以省去 fopen() 调用。

注释：当在 Windows 系统中将 fpassthru() 用于二进制文件时，要确保在用 fopen() 打开文件时在 mode 中附加了 b 来将文件以二进制方式打开。鼓励在处理二进制文件时使用 b 标志，即使系统并不需要，这样可以使脚本的移植性更好。

例子

例子 1

<?php
$file = fopen("test.txt","r");

// 读取第一行
fgets($file);

// 把文件的其余部分发送到输出缓存
echo fpassthru($file);

fclose($file);
?>

输出：

There are three lines in this file.
This is the last line.59

注：59 指示被传递的字符数。

例子 2

转储 www 服务器的 index 页：

<?php
$file = fopen("http://www.example.com","r");
fpassthru($file);
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fprintf() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fprintf() 函数

PHP String 函数

定义和用法

fprintf() 函数把格式化的字符串写到指定的输出流（例如：文件或数据库）。

该函数返回被写字符串的长度。

语法

fprintf(stream,format,arg1,arg2,arg++)
参数 | 描述
stream | 可选。规定在哪里写/输出字符串。
format | 必需。转换格式。
arg1 | 必需。规定插到 format 字符串中第一个 % 符号处的参数。
arg2 | 可选。规定插到 format 字符串中第二个 % 符号处的参数。
arg++ | 可选。规定插到 format 字符串中第三、四等等 % 符号处的参数。

说明

参数 format 是转换的格式，以百分比符号 ("%") 开始到转换字符结束。下面的可能的 format 值：

  • %% - 返回百分比符号
  • %b - 二进制数
  • %c - 依照 ASCII 值的字符
  • %d - 带符号十进制数
  • %e - 可续计数法（比如 1.5e+3）
  • %u - 无符号十进制数
  • %f - 浮点数(local settings aware)
  • %F - 浮点数(not local settings aware)
  • %o - 八进制数
  • %s - 字符串
  • %x - 十六进制数（小写字母）
  • %X - 十六进制数（大写字母）

arg1, arg2, ++ 等参数将插入到主字符串中的百分号 (%) 符号处。该函数是逐步执行的。在第一个 % 符号中，插入 arg1，在第二个 % 符号处，插入 arg2，依此类推。

提示和注释

注释：如果 % 符号多于 arg 参数，则您必须使用占位符。占位符被插入 % 符号之后，由数字和 "\$" 组成。请参见例子 3。

提示：
相关函数：
printf()、
sprintf()、
vfprintf()、
vprintf() 以及
vsprintf()。

例子

例子 1

<?php
$arr = array('Hello','World!','Beautiful','Day!');
echo implode(" ",$arr);
?>

输出：

Hello World! Beautiful Day!

例子 2

<?php
$arr = array('Hello','World!','Beautiful','Day!');
echo implode(" ",$arr);
?>

输出：

Hello World! Beautiful Day!

例子 3

<?php
$arr = array('Hello','World!','Beautiful','Day!');
echo implode(" ",$arr);
?>

输出：

Hello World! Beautiful Day!

PHP String 函数

PHP 参考手册
PHP 测验


PHP fputcsv() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fputcsv() 函数

PHP Filesystem 函数

定义和用法

fputcsv() 函数将行格式化为 CSV 并写入一个打开的文件。

该函数返回写入字符串的长度。若出错，则返回 false。。

语法

fputcsv(file,fields,seperator,enclosure)
参数 | 描述
file | 必需。规定要写入的打开文件。
fields | 必需。规定要从中获得数据的数组。
seperator | 可选。规定字段分隔符的字符。默认是逗号 (,)。
enclosure | 可选。规定字段环绕符的字符。默认是双引号 "。

说明

fputcsv() 将一行（用 fields 数组传递）格式化为 CSV 格式并写入由 file 指定的文件。

提示和注释

提示：参见 fgetcsv() 函数。

例子

<?php
$list = array
(
"George,John,Thomas,USA",
"James,Adrew,Martin,USA",
);

$file = fopen("contacts.csv","w");

foreach ($list as $line)
  {
  fputcsv($file,split(',',$line));
  }

fclose($file);
?>

以上代码执行后，CSV 文件会类似这样：

George,John,Thomas,USA
James,Adrew,Martin,USA

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fputs() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fputs() 函数

PHP Filesystem 函数

定义和用法

fputs() 函数写入文件（可安全用于二进制文件）。

fputs() 函数是 fwrite() 函数的别名。

语法

fputs(file,string,length)
参数 | 描述
file | 必需。规定要写入的打开文件。
string | 必需。规定要写入文件的字符串。
length | 可选。规定要写入的最大字节数。

说明

fwrite() 把 string 的内容写入文件指针 file 处。 如果指定了 length，当写入了 length 个字节或者写完了 string 以后，写入就会停止，视乎先碰到哪种情况。

fwrite() 返回写入的字符数，出现错误时则返回 false。

例子

<?php
$file = fopen("test.txt","w");
echo fputs($file,"Hello World. Testing!");
fclose($file);
?>

输出：

21

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fread() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fread() 函数

PHP Filesystem 函数

定义和用法

fread() 函数读取文件（可安全用于二进制文件）。

语法

fread(file,length)
参数 | 描述
file | 必需。规定要读取打开文件。
length | 必需。规定要读取的最大字节数。

说明

fread() 从文件指针 file 读取最多 length 个字节。该函数在读取完最多 length 个字节数，或到达 EOF 的时候，或（对于网络流）当一个包可用时，或（在打开用户空间流之后）已读取了 8192 个字节时就会停止读取文件，视乎先碰到哪种情况。

返回所读取的字符串，如果出错返回 false。

提示和注释

提示：如果只是想将一个文件的内容读入到一个字符串中，请使用 file_get_contents()，它的性能比 fread() 好得多。

例子

例子 1

从文件中读取 10 个字节：

<?php
$file = fopen("test.txt","r");
fread($file,"10");
fclose($file);
?>

例子 2

读取整个文件：

<?php
$file = fopen("test.txt","r");
fread($file,filesize("test.txt"));
fclose($file);
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP FrenchToJD() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP FrenchToJD() 函数

PHP Array 函数

定义和用法

FrenchToJD() 函数将法国共和历法转换成为儒略日计数。

语法

frenchtojd(month,day,year)
参数 | 描述
month | 必需。规定月
day | 必需。规定日
year | 可选。必须在 1 到 14 的范围内。

提示和注释

法国共和历法是法国革命期间提出的一种历法，从 1793 年晚期开始，法国政府使用了大约 12 年。该函数只转换 1 到 14 年内的日期 （格利高里历 1792 年 9 月 22 日 - 1806 年 9 月 22 日）。

例子

<?php
$d=frenchtojd(3,3,14);
echo($d);
?>

输出：

2380650

PHP Array 函数

PHP 参考手册
PHP 测验


PHP fscanf() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fscanf() 函数

PHP Filesystem 函数

定义和用法

fscanf() 函数根据指定的格式对来自打开的文件的输入进行解析。

语法

fscanf(file,format,mixed)
参数 | 描述
file | 必需。规定要检查的文件。
format | 必需。规定格式。
mixed | 可选。

说明

fscanf() 函数与 sscanf() 相似，但是它从与 file 关联的文件中接受输入并根据指定的 format 来解释输入。如果只给此函数传递了两个参数，解析后的值会被作为数组返回。否则，如果提供了可选参数，此函数将返回被赋值的数目。可选参数必须用引用传递。

提示和注释

注释：格式字符串中的任何空白会与输入流中的任何空白匹配。这意味着甚至格式字符串中的制表符 \t 也会与输入流中的一个空格字符匹配。

注释：在 PHP 4.3.0 之前，从文件中读入的最大字符数是 512（或者第一个 \n，看先碰到哪种情况）。从 PHP 4.3.0 起可以读取任意长的行。

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fseek() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fseek() 函数

PHP Filesystem 函数

定义和用法

fseek() 函数在打开的文件中定位。

该函数把文件指针从当前位置向前或向后移动到新的位置，新位置从文件头开始以字节数度量。

成功则返回 0；否则返回 -1。注意，移动到 EOF 之后的位置不会产生错误。

语法

fseek(file,offset,whence)
参数 | 描述
file | 必需。规定要在其中定位的文件。
offset | 必需。规定新的位置（从文件头开始以字节数度量）。
whence 可选。可能的值：
  • SEEK_SET - 设定位置等于 offset 字节。默认。
  • SEEK_CUR - 设定位置为当前位置加上 offset。
  • SEEK_END - 设定位置为文件末尾加上 offset （要移动到文件尾之前的位置，offset 必须是一个负值）。

说明

whence 参数是 PHP 4.0.0 之后增加的。

提示和注释

提示：通过使用 ftell() 来找到当前位置。

例子

<?php
$file = fopen("test.txt","r");

// 读取第一行
fgets($file);

// 倒回文件的开头
fseek($file,0);
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fstat() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fstat() 函数

PHP Filesystem 函数

定义和用法

fstat() 函数返回关于打开文件的信息。

语法

fstat(file)
参数 | 描述
pipe | 必需。规定要检查的打开文件。

说明

获取由文件指针 handle 所打开文件的统计信息。

该函数返回的数组具有该文件的统计信息，该数组包含以下元素：

数字下标 | 关联键名（自 PHP 4.0.6） | 说明
0 | dev | 设备名
1 | ino | 号码
2 | mode | inode 保护模式
3 | nlink | 被连接数目
4 | uid | 所有者的用户 id
5 | gid | 所有者的组 id
6 | rdev | 设备类型，如果是 inode 设备的话
7 | size | 文件大小的字节数
8 | atime | 上次访问时间（Unix 时间戳）
9 | mtime | 上次修改时间（Unix 时间戳）
10 | ctime | 上次改变时间（Unix 时间戳）
11 | blksize | 文件系统 IO 的块大小
12 | blocks | 所占据块的数目

提示和注释

提示：本函数与 stat() 函数相似，不同的是，它是作用于已打开的文件指针而不是文件名。

例子

<?php
$file = fopen("test.txt","r");
print_r(fstat($file));
fclose($file);
?>

输出类似：

Array
(
[0] => 0
[1] => 0
[2] => 33206
[3] => 1
[4] => 0
[5] => 0
[6] => 0
[7] => 92
[8] => 1141633430
[9] => 1141298003
[10] => 1138609592
[11] => -1
[12] => -1
[dev] => 0
[ino] => 0
[mode] => 33206
[nlink] => 1
[uid] => 0
[gid] => 0
[rdev] => 0
[size] => 92
[atime] => 1141633430
[mtime] => 1141298003
[ctime] => 1138609592
[blksize] => -1
[blocks] => -1
)

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP ftell() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftell() 函数

PHP Filesystem 函数

定义和用法

ftell() 函数在打开文件中的当前位置。

该函数返回文件指针的当前位置。若失败，则返回 false。

语法

ftell(file)
参数 | 描述
file | 必需。规定要检查的已打开文件。

说明

文件指针 file 必须是有效的，且必须指向一个通过 fopen() 或 popen() 成功打开的文件。

在附加模式（加参数 "a" 打开文件）中 ftell() 会返回未定义错误。

例子

<?php
$file = fopen("test.txt","r");

// 输出当前位置
echo ftell($file);

// 改变当前位置
fseek($file,"15");

// 再次输出当前位置
echo ftell($file);

fclose($file);
?>

输出：

0
15

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP ftp_alloc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_alloc() 函数

PHP FTP 函数

定义和用法

ftp_alloc() 函数为要上传到 FTP 服务器的文件分配空间。

若成功，则返回 true。否则返回 false。

语法

ftp_alloc(ftp_connection,size,return)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接。
size | 可选。规定要分配的字节数。
return | 可选。规定存储服务器响应的字节数。

提示和注释

注释：很多服务器不支持该命令。

例子

例子 1

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

ftp_alloc($conn,"160",$response);
echo $response;

ftp_close($conn);
?>

例子 2

<?php

$file = "myfile.txt";

$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

if (ftp_alloc($conn, filesize($file), $response))
  {
  echo "Space allocated on server.";
  }
else
  {
  echo "Unable to allocate space. " . $response;
  }

ftp_close($conn);

?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_cdup() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_cdup() 函数

PHP FTP 函数

定义和用法

ftp_cdup() 函数把当前目录改变为 FTP 服务器上的父目录。

若成功，则返回 true。否则返回 false。

语法

ftp_cdup(ftp_connection)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

//输出当前目录
echo "Dir: ".ftp_pwd($conn);
echo "<br />";

//更改为 images 目录
ftp_chdir($conn,"images");
echo "Dir: ".ftp_pwd($conn);
echo "<br />";

//把当前目录切换为父目录
ftp_cdup($conn);
echo "Dir: ".ftp_pwd($conn);

ftp_close($ftp_server);
?>

输出：

Dir: /
Dir: /images
Dir: /

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_chdir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_chdir() 函数

PHP FTP 函数

定义和用法

ftp_chdir() 函数改变 FTP 服务器上的当前目录。

若成功，则返回 true。否则返回 false。如果切换目录失败，PHP 还会发出一条警告。

语法

ftp_chdir(ftp_connection,directory)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
directory | 必需。规定要切换到的目录。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

//输出当前目录
echo "Dir: ".ftp_pwd($conn);
echo "<br />";

//切换为 images 目录
ftp_chdir($conn,"images");
echo "Dir: ".ftp_pwd($conn);

ftp_close($ftp_server);
?>

输出：

Dir: /
Dir: /images

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_chmod() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_chmod() 函数

PHP FTP 函数

定义和用法

ftp_chmod() 函数设置 FTP 服务器上指定文件的权限。

若成功，则该函数返回新的权限。否则返回 false。

语法

ftp_chmod(ftp_connection,mode,file)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
mode | 必需。规定新的权限。
file | 必需。规定要修改权限的文件的名称。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"user","pass");

// 所有者可读写，其他人没有任何权限
ftp_chmod($conn,"0600","test.txt");

// 所有者可读写，其他人可读
ftp_chmod($conn,"0644","test.txt");

// 所有者拥有所有权限，其他人可读可执行
ftp_chmod($conn,"0755","test.txt");

// 所有者拥有所有权限，所有者所属的组可读
ftp_chmod($conn,"0740","test.txt");

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_close() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_close() 函数

PHP FTP 函数

定义和用法

ftp_close() 函数关闭 FTP 连接。

该函数关闭给出的连接标识符并释放资源。

语法

ftp_close(ftp_connection)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");

//要执行的一些代码

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_connect() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_connect() 函数

PHP FTP 函数

定义和用法

ftp_connect() 函数建立一个新的 FTP 连接。

若成功，则返回一个连接标识，否则返回 false。

语法

ftp_connect(host,port,timeout)
参数 | 描述
host | 必需。规定要连接的 FTP 服务器。可以是域名或 IP 地址。 后面不应以斜线结尾，前面也不需要用 ftp:// 开头。
port | 可选。规定 FTP 服务器的端口。
timeout | 可选。规定该 FTP 服务器的超时时间。默认是 90 秒。

说明

提示：超时时间可以在任何时候通过函数 ftp_set_option() 及 ftp_get_option() 来改变和获取。

参数 timeout 仅适用于 PHP 4.2.0 及以上版本。

例子

本例尝试连接一个 FTP 服务器。如果连接失败，则 die() 函数将终止脚本，并输出一条消息：

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_delete() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_delete() 函数

PHP FTP 函数

定义和用法

ftp_delete() 函数删除 FTP 服务器上的一个文件。

若成功，则返回 true，否则返回 false。

语法

ftp_delete(ftp_connection,path)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
path | 必需。规定要删除的文件的路径。

说明

ftp_delete() 函数用来删除 FTP 服务器上的一个由参数 path 指定的的文件。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

echo ftp_delete($conn,"test.txt");

ftp_close($conn);
?>

输出：

1

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_exec() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_exec() 函数

PHP FTP 函数

定义和用法

ftp_exec() 函数请求在 FTP 服务器上执行一个程序或命令。

若成功（服务器发送响应代码 200），则返回 true，否则返回 false。

语法

ftp_exec(ftp_connection,command)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
command | 必需。规定发送到服务器的命名请求。

说明

该函数发送一个 SITE EXEC command 请求到 FTP 服务器。

提示和注释

与 ftp_raw() 函数 不同，ftp_exec() 只有在登录到 FTP 服务器后才能发送命令。

例子

<?php
$command = "ls-al > test.txt";
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

if (ftp_exec($conn,$command))
  {
  echo "Command executed successfully";
  }
else
  {
  echo "Execution of command failed";
  }

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_fget() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_fget() 函数

PHP FTP 函数

定义和用法

ftp_fget() 函数从 FTP 服务器上下载一个文件并保存到本地一个已经打开的文件中。

若成功则返回 true，失败则返回 false。

语法

ftp_fget(ftp_connection,local,remote,mode,resume)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
local | 必需。本地已经打开的文件的句柄。
remote | 必需。规定从中进行拷贝的文件的路径。
mode 必需。规定传输模式。可能的值有：
  • FTP_ASCII
  • FTP_BINARY
resume | 必需。规定在远程文件中的何处开始拷贝。默认是 0。

说明

参数 resume 仅适用于 PHP 4.3.0 以上版本

例子

本例把文本从 "source.txt" 拷贝到 "target.txt" 中：

<?php
$source = "source.txt";
$target = fopen("target.txt", "w");

$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

ftp_fget($conn,$target,$source,FTP_ASCII);

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_fput() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_fput() 函数

PHP FTP 函数

定义和用法

ftp_fput() 函数上传一个已经打开的文件到 FTP 服务器。

若成功则返回 true，失败则返回 false。

语法

ftp_fput(ftp_connection,remote,local,mode,resume)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
remote | 必需。上传到服务器上的文件名。
local | 必需。规定所打开文件的句柄。
mode 必需。规定传输模式。可能的值有：
  • FTP_ASCII
  • FTP_BINARY
resume | 必需。规定在本地文件中的何处开始拷贝。默认是 0。

说明

参数 resume 仅适用于 PHP 4.3.0 以上版本

例子

本例把文本从 "source.txt" 拷贝到 "target.txt" 中：

<?php
$source = fopen("source.txt","r");

$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

echo ftp_fput($conn,"target.txt",$source,FTP_ASCII);

ftp_close($conn);
?>

输出：

1

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_get_option() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_get_option() 函数

PHP FTP 函数

定义和用法

ftp_get_option() 函数返回当前 FTP 连接的各种不同的选项设置。

语法

ftp_get_option(ftp_connection,option)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
option

必需。规定要返回的选项。可能的值有：

  • FTP_TIMEOUT_SEC - 返回网络操作的时间限制
  • FTP_AUTOSEEK - 如果设置该选项，则返回 true，否则返回 false

说明

如果成功，则返回选项的值，否则，如果给定的参数 option 选项若不被支持，则返回 false 同时会提示一条错误信息。

此函数会返回连接句柄为 ftp_connection，指定键值 option 的值。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

echo ftp_get_option($conn,FTP_TIMEOUT_SEC);

ftp_close($conn);
?>

输出：

90

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_get() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_get() 函数

PHP FTP 函数

定义和用法

ftp_get() 函数从 FTP 服务器上下载一个文件。

若成功则返回 true，失败则返回 false。

语法

ftp_get(ftp_connection,local,remote,mode,resume)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
local | 必需。规定本地文件。
remote | 必需。规定从中进行拷贝的文件的路径。
mode 必需。规定传输模式。可能的值有：
  • FTP_ASCII
  • FTP_BINARY
resume | 必需。规定在远程文件中的何处开始拷贝。默认是 0。

说明

参数 resume 仅适用于 PHP 4.3.0 以上版本

例子

本例把文本从 "source.txt" 拷贝到 "target.txt" 中：

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

echo ftp_get($conn,"target.txt","source.txt",FTP_ASCII);

ftp_close($conn);
?>

输出：

1

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_login() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_login() 函数

PHP FTP 函数

定义和用法

ftp_login() 函数登录 FTP 服务器。

若成功则返回 true，失败则返回 false 并发出一个警告。

语法

ftp_login(ftp_connection,username,password)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
username | 必需。规定用于登录的用户名。
password | 必需。规定用于登录的密码。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");
ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_mdtm() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_mdtm() 函数

PHP FTP 函数

定义和用法

ftp_mdtm() 函数返回指定文件的最后修改时间。

语法

ftp_login(ftp_connection,file)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
file | 必需。规定要检查的文件。

提示和注释

注释：并非所有 FTP 服务器都支持该函数。

注释：该函数不适用于检查目录。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

$mod = ftp_mdtm($conn,"test.txt");

//以 Unix 时间戳返回结果
echo $mod;
echo "<br />";

//把 Unix 时间戳格式化为日期
echo date(DATE_RFC822,$mod);

ftp_close($conn);
?>

输出：

1140082571
Thu, 16 Feb 2006 10:36:11 CET

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_mkdir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_mkdir() 函数

PHP FTP 函数

定义和用法

ftp_mkdir() 函数在 FTP 服务器上建立新目录。

语法

ftp_mkdir(ftp_connection,dir)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
dir | 必需。规定要创建的目录的名称。

说明

在 FTP 服务器上建立一个目录名为参数 dir 的新目录。

如果成功，则返回新建的目录名，否则返回 false。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

echo ftp_mkdir($conn,"testdir");

ftp_close($conn);
?>

输出：

/testdir

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_nb_continue() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_nb_continue() 函数

PHP FTP 函数

定义和用法

ftp_nb_continue() 函数连续获取 / 发送文件。

该函数返回下列值：

  • FTP_FAILED (send/receive failed)
  • FTP_FINISHED (send/receive completed)
  • FTP_MOREDATA (send/receive in progress)

该函数异步地发送/获取文件。这意味着您的程序可以在文件下载时执行其他操作。

语法

ftp_nb_continue(ftp_connection)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。

例子

<?php
$source = "source.txt";
$target = fopen("target.txt", "w");

$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

$status = ftp_nb_fget($conn,$source,$target,FTP_ASCII);

while ($status == FTP_MOREDATA)
  {
  $status = ftp_nb_continue($conn);
  }

if ($status != FTP_FINISHED)
  {
  echo "Download error";
  }

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_nb_fget() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_nb_fget() 函数

PHP FTP 函数

定义和用法

ftp_nb_fget() 函数从 FTP 服务器上下载一个文件并保存到本地已经打开的一个文件中 (non-blocking)。

该函数返回下列值：

  • FTP_FAILED (send/receive failed)
  • FTP_FINISHED (send/receive completed)
  • FTP_MOREDATA (send/receive in progress)

与 ftp_fget() 不同，该函数异步地获取文件。这意味着您的程序可以在文件下载时执行其他操作。

语法

ftp_nb_fget(ftp_connection,local,remote,mode,resume)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
local | 必需。规定本地文件。
remote | 必需。规定从中进行拷贝的文件的路径。
mode

必需。规定传输模式。可能的值有：

  • FTP_ASCII
  • FTP_BINARY
resume | 必需。规定在远程文件中的何处开始拷贝。默认是 0。

例子

本例把文本从 "source.txt" 拷贝到 "target.txt" 中：

<?php
$source = "source.txt";
$target = fopen("target.txt", "w");

$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

ftp_nb_fget($conn,$target,$source,FTP_ASCII);

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_nb_fput() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_nb_fput() 函数

PHP FTP 函数

定义和用法

ftp_nb_fput() 函数上传一个已打开的文件，并在 FTP 服务器上把它保存为文件 (non-blocking)。

该函数返回下列值：

  • FTP_FAILED (send/receive failed)
  • FTP_FINISHED (send/receive completed)
  • FTP_MOREDATA (send/receive in progress)

与 ftp_fput() 不同，该函数异步地获取文件。这意味着您的程序可以在文件下载时执行其他操作。

语法

ftp_nb_fput(ftp_connection,remote,local,mode,resume)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
remote | 必需。上传到服务器上的文件名。
local | 必需。规定所打开文件的句柄。
mode

必需。规定传输模式。可能的值有：

  • FTP_ASCII
  • FTP_BINARY
resume | 必需。规定在本地文件中的何处开始拷贝。默认是 0。

例子

本例把文本从 "source.txt" 拷贝到 "target.txt" 中：

<?php
$source = fopen("source.txt","r");

$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

ftp_nb_fput($conn,"target.txt",$source,FTP_ASCII);

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_nb_get() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_nb_get() 函数

PHP FTP 函数

定义和用法

ftp_nb_get() 函数从 FTP 服务器上获取文件并写入本地文件 (non-blocking)。

该函数返回下列值：

  • FTP_FAILED (send/receive failed)
  • FTP_FINISHED (send/receive completed)
  • FTP_MOREDATA (send/receive in progress)

与 ftp_get() 不同，该函数异步地获取文件。这意味着您的程序可以在文件传输时执行其他操作。

语法

ftp_nb_get(ftp_connection,local,remote,mode,resume)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
local | 必需。规定要写入的本地文件。若该文件已存在，则将被覆盖。
remote | 必需。规定从中进行拷贝的文件的路径。
mode

必需。规定传输模式。可能的值有：

  • FTP_ASCII
  • FTP_BINARY
resume | 必需。规定在远程文件中的何处开始拷贝。默认是 0。

例子

本例把文本从 "source.txt" 拷贝到 "target.txt" 中：

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

ftp_nb_get($conn,"target.txt","source.txt",FTP_ASCII);

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_nb_put() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_nb_put() 函数

PHP FTP 函数

定义和用法

ftp_nb_put() 函数把文件上传到服务器 (non-blocking)。

该函数返回下列值：

  • FTP_FAILED (send/receive failed)
  • FTP_FINISHED (send/receive completed)
  • FTP_MOREDATA (send/receive in progress)

与 ftp_put() 不同，该函数异步地获取文件。这意味着您的程序可以在文件传输时执行其他操作。

语法

ftp_nb_fput(ftp_connection,remote,local,mode,resume)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
remote | 必需。上传到服务器上的文件名。
local | 必需。规定要上传的本地文件的路径。
mode

必需。规定传输模式。可能的值有：

  • FTP_ASCII
  • FTP_BINARY
resume | 必需。规定在本地文件中的何处开始拷贝。默认是 0。

例子

本例把文本从 "source.txt" 拷贝到 "target.txt" 中：

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

ftp_nb_put($conn,"target.txt","source.txt",FTP_ASCII);

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_nlist() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_nlist() 函数

PHP FTP 函数

定义和用法

ftp_nlist() 函数返回指定目录的文件列表。

如果成功，则返回给定目录下的文件名组成的数组，否则返回 false。

语法

ftp_nlist(ftp_connection,dir)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
dir | 必需。规定要检查的目录。使用 "." 来获得当前目录。

提示和注释

注释：该函数不适用于 IIS (Internet Information Server)。它返回 nothing。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

print_r(ftp_nlist($conn,"images"));

ftp_close($conn);
?>

输出类似：

array(3)
{
[0]=> "flower.gif"
[1]=> "car.gif"
[2]=> "house.gif"
}

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_pasv() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_pasv() 函数

PHP FTP 函数

定义和用法

ftp_pasv() 函数把被动模式设置为打开或关闭。

在被动模式中，数据连接是由客户机来初始化的，而不是服务器。这在客户机位于防火墙之后时比较有用。

语法

ftp_pasv(ftp_connection,mode)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
mode

必需。规定模式。

  • TRUE = passive mode on
  • FALSE = passive mode off

说明

如果参数 mode 为真，打开被动模式传输 (PASV MODE) ，否则，如果参数 mode 为假，则关闭被动传输模式。在被动模式打开的情况下，数据的传送由客户机启动，而不是由服务器开始。

如果成功则返回 true，失败则返回 false。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

ftp_pasv($conn,TRUE);

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_put() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_put() 函数

PHP FTP 函数

定义和用法

ftp_put() 函数把文件上传到服务器。

若成功则返回 true，失败则返回 false。

语法

ftp_put(ftp_connection,remote,local,mode,resume)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
remote | 必需。上传到服务器上的文件名。
local | 必需。规定要上传的本地文件的路径。
mode

必需。规定传输模式。可能的值有：

  • FTP_ASCII
  • FTP_BINARY
resume | 必需。规定在本地文件中的何处开始拷贝。默认是 0。

例子

本例把文本从 "source.txt" 拷贝到 "target.txt" 中：

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

echo ftp_put($conn,"target.txt","source.txt",FTP_ASCII);

ftp_close($conn);
?>

输出：

1

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_pwd() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_pwd() 函数

PHP FTP 函数

定义和用法

ftp_pwd() 函数返回当前目录名。

语法

ftp_pwd(ftp_connection)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

// 输出当前目录
echo ftp_pwd($conn) . "<br />";

// 把目录改为 images
ftp_chdir($conn,"images");

// 输出当前目录
echo ftp_pwd($conn);

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_quit() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_quit() 函数

PHP FTP 函数

定义和用法

ftp_quit() 函数关闭 FTP 连接。

该函数关闭给出的连接标识符并释放资源。

语法

ftp_quit(ftp_connection)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。

提示和注释

提示：该函数是 ftp_close() 函数的别名。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");

//要执行的一些代码

ftp_quit($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_raw() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_raw() 函数

PHP FTP 函数

定义和用法

ftp_raw() 函数向 FTP 服务器发送一个 raw 命令。

语法

ftp_raw(ftp_connection,command)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
command | 必需。规定要执行的命令。

提示和注释

注释：该函数以字符串数组的形式返回服务器的响应。不执行解析，且 ftp_raw() 不检查命令是否正确。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");

print_r (ftp_raw($conn,"USER admin"));
print_r (ftp_raw($conn,"PASS ert456"));

ftp_close($conn);
?>

输出：

Array ([0] => 331 User admin, password please)
Array ([0] => 230 Password Ok, User logged in)

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_rawlist() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_rawlist() 函数

PHP FTP 函数

定义和用法

ftp_rawlist() 函数返回指定目录中文件的详细列表。

语法

ftp_rawlist(ftp_connection,dir,recursive)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
dir | 必需。规定目录。使用 "." 来规定当前目录。
recursive | 可选。默认地，该函数向服务器发送 "LIST" 命令。如果，如果 recursive 参数设置为 true，则发送 "LIST -R" 命令。

说明

ftp_rawlist() 函数将执行 FTP LIST 命令，并把结果返回为一个数组。数组的每个元素为返回文本的每一行，输出结构不会被解析。

使用函数 ftp_systype() 可以用来判断 FTP 服务器的类型，从而可以用来判断返回列表的类型。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

print_r (ftp_rawlist($conn,"."));

ftp_close($conn);
?>

输出类似：

Array
(
[0] => dr--r--r-- 1 user group 0 Feb 15 13:02 .
[1] => dr--r--r-- 1 user group 0 Feb 15 13:02 ..
[2] => drw-rw-rw- 1 user group 0 Jan 03 08:33 images
[3] => -rw-rw-rw- 1 user group 160 Feb 16 13:54 test.php
[4] => -rw-rw-rw- 1 user group 20 Feb 14 12:22 test.txt
)

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_rename() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_rename() 函数

PHP FTP 函数

定义和用法

ftp_rename() 函数更改 FTP 服务器上的文件或目录名。

如果成功，则返回 true，否则返回 false。

语法

ftp_rename(ftp_connection,from,to)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
from | 必需。规定要改名的文件或目录。
to | 必需。规定文件或目录的新名称。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

ftp_rename($conn,"oldname.txt","newname.txt");

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_rmdir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_rmdir() 函数

PHP FTP 函数

定义和用法

ftp_rmdir() 函数删除一个目录。

如果成功，则返回 true，否则返回 false。

语法

ftp_rmdir(ftp_connection,dir)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
dir | 必需。规定要删除的目录。

说明

删除由参数 dir 指定的目录。dir 必须是一个空目录的绝对或相对路径。

如果成功，则返回 true，否则返回 false。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

ftp_rmdir($conn,"testdir");

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_set_option() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_set_option() 函数

PHP FTP 函数

定义和用法

ftp_set_option() 函数设置各种 FTP 运行时选项。

语法

ftp_set_option(ftp_connection,option,value)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
option

必需。规定要删设置的运行时选项。可能的值：

  • FTP_TIMEOUT_SEC
  • FTP_AUTOSEEK

详细信息见下面的说明。
value | 必需。设置 option 参数的值。

说明

FTP_TIMEOUT_SEC 选项改变网络传输的超时时间。参数 value 必须为整数且大于 0。默认的超时时间为 90 秒。

当 FTP_AUTOSEEK 选项打开时，带 resumepos 或 startpos 参数的 GET 或 PUT 请求将先检索到文件中指定的位置。此选项默认是打开的。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

ftp_set_option($conn,FTP_TIMEOUT_SEC,120);

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_site() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_site() 函数

PHP FTP 函数

定义和用法

ftp_site() 函数向服务器发送 SITE 命令。

SITE 命令没有标准化。不同的服务器不尽相同。对于处理文件权限或组关系方面的事情，SITE 命令很有用。

语法

ftp_site(ftp_connection,command)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
command | 必需。规定向 FTP 发送的 SITE 命令。

说明

ftp_site() 函数向 FTP 服务器发送由参数 command 指定的命令。

如果成功则返回 true，失败则返回 false。

提示和注释

提示：如需查看哪些命令可用，请通过 ftp_raw() 函数发送 REMOTEHELP 命令。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

ftp_site($conn,"CHMOD 0600 sitetest.txt");

ftp_close($conn);
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_size() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_size() 函数

PHP FTP 函数

定义和用法

ftp_size() 函数返回指定文件的大小。

语法

ftp_size(ftp_connection,remote_file)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。
remote_file | 必需。规定要检查的文件。

说明

ftp_size() 函数以字节返回远程文件 remote_file 的大小。如果指定文件不存在或发生错误，则返回 -1。有些 FTP 服务器可能不支持此特性。

如果获取成功，则返回文件大小，否则返回 -1。

提示和注释

注释：并非所有 FTP 服务器均支持该函数。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

echo ftp_size($conn,"test.txt");

ftp_close($conn);
?>

输出类似：

160

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_ssl_connect() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_ssl_connect() 函数

PHP FTP 函数

定义和用法

ftp_ssl_connect() 函数打开一个安全的 SSL-FTP 连接。

当连接打开，您就可以在服务器运行 FTP 函数。

语法

ftp_ssl_connect(host,port,timeout)
参数 | 描述
host | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。 可以是域名或 IP 地址。该参数不能包含 "ftp://" 或 斜杠。
port | 可选。规定 FTP 服务器的端口。默认是 21。
timeout | 可选。规定 FTP 连接的超时时间。默认是 90 秒。

例子

本例尝试连接一个 FTP 服务器。如果连接失败，die() 函数会终止脚本的执行，并输出一条消息：

<?php
$conn = ftp_ssl_connect("ftp.testftp.com") or die("Could not connect");
?>

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP ftp_systype() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftp_systype() 函数

PHP FTP 函数

定义和用法

ftp_systype() 函数返回远程 FTP 服务器的系统类型标识符。

该函数返回远程服务器的系统类型。若发生错误，则返回 false。

语法

ftp_systype(ftp_connection)
参数 | 描述
ftp_connection | 必需。规定要使用的 FTP 连接（FTP 连接的标识符）。

例子

<?php
$conn = ftp_connect("ftp.testftp.com") or die("Could not connect");
ftp_login($conn,"admin","ert456");

echo ftp_systype($conn);

ftp_close($conn);
?>

输出类似：

UNIX

PHP FTP 函数

PHP 参考手册
PHP 测验


PHP FTP 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP FTP 函数

  • Previous Page
  • Next Page

PHP FTP 简介

FTP 函数通过文件传输协议 (FTP) 提供对文件服务器的客户端访问。

FTP 函数用于打开、登录以及关闭连接，同时用于上传、下载、重名命、删除及获取文件服务器上的文件信息。不是所有 FTP 函数对每个服务器都起作用或返回相同的结果。自 PHP 3 起，FTP 函数可用。

这些函数用于对 FTP 服务器进行细致的访问。如果您仅仅需要对 FTP 服务器进行读写操作，建议使用 Filesystem 函数中的 ftp:// wrapper。

安装

PHP 的 Windows 版本已经内置该 FTP 扩展模块的支持。无需加载任何附加扩展库即可使用这些函数。

不过，如果您运行的是 PHP 的 Linux 版本，在编译的时候请添加 --enable-ftp 选项 (PHP4 或以上版本) 或者 --with-ftp (PHP3 版本)。

PHP FTP 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
ftp_alloc() | 为要上传到 FTP 服务器的文件分配空间。 | 5
ftp_cdup() | 把当前目录改变为 FTP 服务器上的父目录。 | 3
ftp_chdir() | 改变 FTP 服务器上的当前目录。 | 3
ftp_chmod() | 通过 FTP 设置文件上的权限。 | 5
ftp_close() | 关闭 FTP 连接。 | 4
ftp_connect() | 打开 FTP 连接。 | 3
ftp_delete() | 删除 FTP 服务器上的文件。 | 3
ftp_exec() | 在 FTP 上执行一个程序/命令。 | 4
ftp_fget() | 从 FTP 服务器上下载一个文件并保存到本地一个已经打开的文件中。 | 3
ftp_fput() | 上传一个已打开的文件，并在 FTP 服务器上把它保存为一个文件。 | 3
ftp_get_option() | 返回当前 FTP 连接的各种不同的选项设置。 | 4
ftp_get() | 从 FTP 服务器下载文件。 | 3
ftp_login() | 登录 FTP 服务器。 | 3
ftp_mdtm() | 返回指定文件的最后修改时间。 | 3
ftp_mkdir() | 在 FTP 服务器创建一个新目录。 | 3
ftp_nb_continue() | 连续获取／发送文件 (non-blocking)。 | 4
ftp_nb_fget() | 从FTP服务器上下载文件并保存到本地已经打开的文件中(non-blocking) | 4
ftp_nb_fput() | 上传已打开的文件，并在FTP服务器上把它保存为文件(non-blocking)。 | 4
ftp_nb_get() | 从 FTP 服务器下载文件 (non-blocking)。 | 4
ftp_nb_put() | 把文件上传到服务器 (non-blocking)。 | 4
ftp_nlist() | 返回指定目录的文件列表。 | 3
ftp_pasv() | 返回当前 FTP 被动模式是否打开。 | 3
ftp_put() | 把文件上传到服务器。 | 3
ftp_pwd() | 返回当前目录名称。 | 3
ftp_quit() | ftp_close() 的别名。 | 3
ftp_raw() | 向 FTP 服务器发送一个 raw 命令。 | 5
ftp_rawlist() | 返回指定目录中文件的详细列表。 | 3
ftp_rename() | 重命名 FTP 服务器上的文件或目录。 | 3
ftp_rmdir() | 删除 FTP 服务器上的目录。 | 3
ftp_set_option() | 设置各种 FTP 运行时选项。 | 4
ftp_site() | 向服务器发送 SITE 命令。 | 3
ftp_size() | 返回指定文件的大小。 | 3
ftp_ssl_connect() | 打开一个安全的 SSL-FTP 连接。 | 4
ftp_systype() | 返回远程 FTP 服务器的系统类型标识符。 | 3

PHP FTP 常量

PHP：指示支持该常量的最早的 PHP 版本。

常量 | 描述 | PHP
FTP_ASCII |  | 3
FTP_TEXT |  | 3
FTP_BINARY |  | 3
FTP_IMAGE |  | 3
FTP_TIMEOUT_SEC |  | 3
FTP_AUTOSEEK |  | 4
FTP_AUTORESUME | 为 GET 和 PUT 请求自动决定恢复和开始的位置 只能工作在 FTP_AUTOSEEK 打开的情况下 | 4
FTP_FAILED | 异步传输失败 | 4
FTP_FINISHED | 异步传输成功 | 4
FTP_MOREDATA | 异步传输是活动状态的 | 4
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP ftruncate() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ftruncate() 函数

PHP Filesystem 函数

定义和用法

ftruncate() 函数把文件截断到指定的长度。

语法

ftruncate(file,size)
参数 | 描述
file | 必需。规定要截断的打开文件。
size | 必需。规定新的文件大小。

说明

接受文件指针 file 作为参数，并将文件大小截取为 size。如果成功则返回 TRUE，否则返回 FALSE。

提示和注释

注释：文件只会在 append 模式下改变。在 write 模式下，必须加上 fseek() 操作。

注释：在 PHP 4.3.3 之前，ftruncate() 在成功时返回一个整数值 1，而不是布尔值的 TRUE。

例子

<?php
//检查文件大小
echo filesize("test.txt");
echo "<br />";

$file = fopen("test.txt", "a+");
ftruncate($file,100);
fclose($file);

//清空缓存，再次检查文件大小
clearstatcache();
echo filesize("test.txt");
?>

输出类似：

792
100

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP fwrite() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP fwrite() 函数

PHP Filesystem 函数

定义和用法

fwrite() 函数写入文件（可安全用于二进制文件）。

语法

fwrite(file,string,length)
参数 | 描述
file | 必需。规定要写入的打开文件。
string | 必需。规定要写入文件的字符串。
length | 可选。规定要写入的最大字节数。

说明

fwrite() 把 string 的内容写入文件指针 file 处。 如果指定了 length，当写入了 length 个字节或者写完了 string 以后，写入就会停止，视乎先碰到哪种情况。

fwrite() 返回写入的字符数，出现错误时则返回 false。

例子

<?php
$file = fopen("test.txt","w");
echo fwrite($file,"Hello World. Testing!");
fclose($file);
?>

输出：

21

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP get_browser() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP get_browser() 函数

PHP 杂项函数

定义和用法

get_browser() 函数返回用户浏览器的性能。

该函数通过查阅用户的 browscap.ini 文件，来测定用户浏览器的性能。

若成功，则该函数返回包含用户浏览器信息的一个对象或一个数组，若失败，则返回 false。

语法

get_browser(user_agent,return_array)
参数 | 描述
user_agent | 可选。规定 HTTP 用户代理的名称。默认是 $HTTP_USER_AGENT 的值。 您可以通过设置 NULL 绕过该参数。
return_array | 可选。如果该参数设置为 true，本函数会返回一个数组而不是对象。

提示和注释

注释：返回语句会立即终止对字符串的计算。

注释：该函数对于在数据库文本字段中供日后计算而进行的代码存储很有用。

例子

<?php
echo $_SERVER['HTTP_USER_AGENT'] . "<br /><br />";
$browser = get_browser(null,true);
print_r($browser);
?>

输出：

Mozilla/4.0
(compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Array
(
[browser_name_regex] => ^mozilla/.\.0
(compatible; msie 6\.0.*;.*windows nt 5\.1.*\.net clr.*).*$
[browser_name_pattern] => Mozilla/?.0
(compatible; MSIE 6.0*;*Windows NT 5.1*.NET CLR*)*
[parent] => IE 6.0
[platform] => WinXP
[netclr] => 1
[browser] => IE
[version] => 6.0
[majorver] => 6
[minorver] => 0
[css] => 2
[frames] => 1
[iframes] => 1
[tables] => 1
[cookies] => 1
[backgroundsounds] => 1
[vbscript] => 1
[javascript] => 1
[javaapplets] => 1
[activexcontrols] => 1
[cdf] => 1
[aol] =>
[beta] =>
[win16] =>
[crawler] =>
[stripper] =>
[wap] =>
[ak] =>
[sk] =>
)

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP get_html_translation_table() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP get_html_translation_table() 函数

PHP String 函数

定义和用法

get_html_translation_table() 函数返回被 htmlentities() 和 htmlspecialchars() 函数使用的翻译表。

语法

get_html_translation_table(function,quotestyle)
参数 描述
function

可选。规定返回哪个翻译表。默认是 HTML_SPECIALCHARS。

可能的值：

  • HTML_ENTITIES - 翻译所有需要 URL 编码的字符，以便正确地显示在网页上。
  • HTML_SPECIALCHARS - 翻译某些需要 URL 编码的字符，以便正确地显示在网页上。
salt

可选。定义如何对单引号和双引号进行编码。默认是 ENT_COMPAT。

可能的值：

  • ENT_COMPAT - 编码双引号，不编码单引号。
  • ENT_QUOTES - 编码双引号和单引号。
  • ENT_NOQUOTES - 不编码单引号或双引号。

说明

提示和注释

提示：一些字符可以按照若干种方式进行编码。get_html_translation_table() 返回最普通的编码。

例子

在本例中，我们将展示两种翻译表：

<?php
print_r (get_html_translation_table());
echo "<br />";
print_r (get_html_translation_table(HTML_ENTITIES));
?>

输出：

PHP String 函数

PHP 参考手册
PHP 测验


PHP getcwd() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP getcwd() 函数

PHP Directory 函数

定义和用法

getcwd() 函数返回当前目录。

若成功，则返回当前工作目录，否则返回 false。

语法

getcwd()

例子

<?php
echo getcwd();
?>

输出：

C:\testweb\main

PHP Directory 函数

PHP 参考手册
PHP 测验


PHP getdate() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP getdate() 函数

PHP Date / Time 函数

定义和用法

getdate() 函数取得日期／时间信息。

语法

getdate(timestamp)
参数 | 描述
timestamp | 可选。规定 Unix 时间格式中的时间。

说明

返回一个根据 timestamp 得出的包含有日期信息的结合数组。如果没有给出时间戳，则认为是当前本地时间。

数组中的单元如下：

键名 | 说明 | 返回值例子
"seconds" | 秒的数字表示 | 0 到 59
"minutes" | 分钟的数字表示 | 0 到 59
"hours" | 小时的数字表示 | 0 到 23
"mday" | 月份中第几天的数字表示 | 1 到 31
"wday" | 星期中第几天的数字表示 | 0（表示星期天）到 6（表示星期六）
"mon" | 月份的数字表示 | 1 到 12
"year" | 4 位数字表示的完整年份 | 例如：1999 或 2003
"yday" | 一年中第几天的数字表示 | 0 到 365
"weekday" | 星期几的完整文本表示 | Sunday 到 Saturday
"month" | 月份的完整文本表示 | January 到 December
0 | 自从 Unix 纪元开始至今的秒数，和 time() 的返回值以及用于 date() 的值类似。 | 系统相关，典型值为从 -2147483648 到 2147483647。

例子

例子 1

<?php
print_r(getdate());
?>

输出：

Array
(
[seconds] => 45
[minutes] => 52
[hours] => 14
[mday] => 24
[wday] => 2
[mon] => 1
[year] => 2006
[yday] => 23
[weekday] => Tuesday
[month] => January
[0] => 1138110765
)

例子 2

<?php
$my_t=getdate(date("U"));
print("$my_t[weekday], $my_t[month] $my_t[mday], $my_t[year]");
?>

输出：

Wednesday, January 25, 2006

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP getDocNamespaces() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP getDocNamespaces() 函数

PHP SimpleXML 函数

定义和用法

getDocNamespaces() 函数从 SimpleXMLElement 对象返回在 XML 文档中声明的命名空间。

如果成功，该函数返回包含命名空间名称（带有关联的 URL）的数组。如果失败，则返回 false。

语法

class SimpleXMLElement
{
string getDocNamespaces(recursive)
}
参数 | 描述
recursive | 可选。规定是否返回父子节点中的所有命名空间。默认是 false。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note xmlns:b="http://www.w3school.com.cn/example/">
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<b:body>Don't forget the meeting!</b:body>
</note>

PHP 代码：

<?php
if (file_exists('test.xml'))
  {
  $xml = simplexml_load_file('test.xml');
  }

print_r($xml->getDocNamespaces());
?>

输出类似：

Array
(
[b] => http://www.w3school.com.cn/example/
)

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP getName() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP getName() 函数

PHP SimpleXML 函数

定义和用法

getName() 函数从 SimpleXMLElement 对象获取 XML 元素的名称。

如果成功，该函数返回当前的 XML 元素的名称。如果失败，则返回 false。

语法

class SimpleXMLElement
{
string getName()
}

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<b:body>Don't forget the meeting!</b:body>
</note>

PHP 代码：

<?php
if (file_exists('test.xml'))
  {
  $xml = simplexml_load_file('test.xml');
  }

echo $xml->getName();

foreach($xml->children() as $child)
  {
  echo $child->getName();
  }
?>

输出类似：

note
to
from
heading
body

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP getNamespace() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP getNamespace() 函数

PHP SimpleXML 函数

定义和用法

getNamespace() 函数获取在 XML 文档中使用的命名空间。

如果成功，该函数返回命名空间（带有关联的 URL）的一个数组。如果失败，则返回 false。

语法

class SimpleXMLElement
{
string getNamespace(recursive)
}
参数 | 描述
recursive | 可选。规定是否返回父子节点中使用的所有命名空间。默认是 false。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note xmlns:b="http://www.w3school.com.cn/example/">
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<b:body>Don't forget the meeting!</b:body>
</note>

PHP 代码：

<?php
if (file_exists('test.xml'))
  {
  $xml = simplexml_load_file('test.xml');
  }

print_r($xml->getNamespaces());
?>

输出类似：

Array
(
[b] => http://www.w3school.com.cn/example/
)

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP gettimeofday() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP gettimeofday() 函数

PHP Date / Time 函数

定义和用法

gettimeofday() 函数返回一个包含当前时间信息的数组。

自 PHP 5.1.0 起有个可选参数 return_float，当其设置为 TRUE 时，gettimeofday() 会返回一个浮点数。

所返回的数组键的含义是：

  • "sec" - 自 Unix 纪元起的秒数
  • "usec" - 微秒数
  • "minuteswest" - 格林威治向西的分钟数
  • "dsttime" - 夏令时修正的类型

语法

gettimeofday(return_float)
参数 | 描述
return_float | 可选。当其设置为 TRUE 时，gettimeofday() 会返回一个浮点数。

例子

例子 1

<?php
echo(gettimeofday(true) . "<br /><br />");
print_r(gettimeofday());
?>

输出：

1138111447.4

Array
(
[sec] => 1138111447
[usec] => 395863
[minuteswest] => -60
[dsttime] => 0
)

例子 2

<?php
$my_t=gettimeofday();
print("$my_t[sec].$my_t[usec]");
?>

输出：

1138197006.988273

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP glob() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP glob() 函数

PHP Filesystem 函数

定义和用法

glob() 函数返回匹配指定模式的文件名或目录。

该函数返回一个包含有匹配文件 / 目录的数组。如果出错返回 false。

语法

glob(pattern,flags)
参数 | 描述
file | 必需。规定检索模式。
size

可选。规定特殊的设定。

  • GLOB_MARK - 在每个返回的项目中加一个斜线
  • GLOB_NOSORT - 按照文件在目录中出现的原始顺序返回（不排序）
  • GLOB_NOCHECK - 如果没有文件匹配则返回用于搜索的模式
  • GLOB_NOESCAPE - 反斜线不转义元字符
  • GLOB_BRACE - 扩充 {a,b,c} 来匹配 'a'，'b' 或 'c'
  • GLOB_ONLYDIR - 仅返回与模式匹配的目录项
  • GLOB_ERR - 停止并读取错误信息（比如说不可读的目录），默认的情况下忽略所有错误

注释：GLOB_ERR 是 PHP 5.1 添加的。

例子

例子 1

<?php
print_r(glob("*.txt"));
?>

输出类似：

Array
(
[0] => target.txt
[1] => source.txt
[2] => test.txt
[3] => test2.txt
)

例子 2

<?php
print_r(glob("*.*"));
?>

输出类似：

Array
(
[0] => contacts.csv
[1] => default.php
[2] => target.txt
[3] => source.txt
[4] => tem1.tmp
[5] => test.htm
[6] => test.ini
[7] => test.php
[8] => test.txt
[9] => test2.txt
)

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP gmdate() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP gmdate() 函数

PHP Date / Time 函数

定义和用法

gmdate() 函数格式化 GMT/UTC 日期/时间。

同 date() 函数 类似，不同的是返回的时间是格林威治标准时（GMT）。

语法

gmdate(format,timestamp)

参数 | 描述
format | 可选。规定如何返回结果。
timestamp | 可选。

提示和注释

注释：在 PHP 5.1.0 之前，负的时间戳（1970 年之前的日期）在某些系统下（例如 Windows）不能工作。

例子

例子 1

当在中国（GMT +0800）运行以下程序时，第一行显示“Jan 01 2000 00:00:00”，而第二行显示“Dec 31 1999 16:00:00”。

<?php
echo date("M d Y H:i:s", mktime (0,0,0,1,1,2000));
echo gmdate("M d Y H:i:s", mktime (0,0,0,1,1,2000));
?>

输出：

Jan 01 2000 00:00:00
Dec 31 1999 16:00:00

例子 2

<?php
echo("Result with date():<br />");
echo(date("l") . "<br />");
echo(date("l dS \of F Y h:i:s A") . "<br />");
echo("Oct 3,1975 was on a ".date("l", mktime(0,0,0,10,3,1975))."<br />");
echo(date(DATE_RFC822) . "<br />");
echo(date(DATE_ATOM,mktime(0,0,0,10,3,1975)) . "<br /><br />");

echo("Result with gmdate():<br />");
echo(gmdate("l") . "<br />");
echo(gmdate("l dS \of F Y h:i:s A") . "<br />");
echo("Oct 3,1975 was on a ".gmdate("l", mktime(0,0,0,10,3,1975))."<br />");
echo(gmdate(DATE_RFC822) . "<br />");
echo(gmdate(DATE_ATOM,mktime(0,0,0,10,3,1975)) . "<br />");
?>

输出：

Result with date():
Tuesday
Tuesday 24th of January 2006 02:41:22 PM
Oct 3,1975 was on a Friday
Tue, 24 Jan 2006 14:41:22 CET
1975-10-03T00:00:00+0100

Result with gmdate():
Tuesday
Tuesday 24th of January 2006 01:41:22 PM
Oct 3,1975 was on a Thursday
Tue, 24 Jan 2006 13:41:22 GMT
1975-10-02T23:00:00+0000

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP gmmktime() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP gmmktime() 函数

PHP Date / Time 函数

定义和用法

gmmktime() 函数取得 GMT 日期的 UNIX 时间戳。

与 mktime() 类似，不同的是返回值是格林威治标准时的时间戳。

参数总是表示 GMT 日期，因此 is_dst 对结果没有影响。

与 mktime() 一样，参数可以从右到左依次空着，空着的参数会被设为相应的当前 GMT 值。

语法

gmmktime(hour,minute,second,month,day,year,is_dst)
参数 | 描述
hour | 可选。规定小时。
minute | 可选。规定分钟。
second | 可选。规定秒。
month | 可选。规定用数字表示的月。
day | 可选。规定天。
year | 可选。规定年。在某些系统上，合法值介于 1901 - 2038 之间。不过在 PHP 5 中已经不存在这个限制了。
is_dst | 可选。如果时间在日光节约时间(DST)期间，则设置为1，否则设置为0，若未知，则设置为-1。 自 5.1.0 起，is_dst 参数被废弃。因此应该使用新的时区处理特性。

提示和注释

注释：gmmktime() 内部使用了 mktime()，因此只有转换成本地时间也合法的时间才能用在其中。

例子

<?php
$my_birthday = gmmktime(0,0,0,10,3,1975);
print($my_birthday . "<br />");
print(date("M-d-Y",$my_birthday));
?>

输出：

181526400
Oct-03-1975

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP gmstrftime() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP gmstrftime() 函数

PHP Date / Time 函数

定义和用法

gmstrftime() 函数根据本地区域设置格式化 GMT/UTC 时间／日期。

语法

gmstrftime(format,timestamp)
参数 | 描述
format | 可选。规定如何返回结果。
timestamp | 可选。

提示和注释

提示：与 strftime() 的行为相同，不同的是返回时间是格林威治标准时（GMT）。

例子

输出 strftime() 和 gmstrftime() 的结果：

<?php
echo(strftime("%b %d %Y %X", mktime(20,0,0,12,31,98)));
echo(gmstrftime("%b %d %Y %X", mktime(20,0,0,12,31,98)));

//输出当前日期、时间和时区
echo(gmstrftime("It is %a on %b %d, %Y, %X time zone: %Z",time()));
?>

输出：

Dec 31 1998 20:00:00
Dec 31 1998 19:00:00
It is Wed on Jan 25, 2006, 11:32:10 time zone: W. Europe Standard Time

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP GregorianToJD() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP GregorianToJD() 函数

PHP Array 函数

定义和用法

GregorianToJD() 函数将格利高里历法转换成为儒略日计数。

语法

gregoriantojd(month,day,year)
参数 | 描述
month | 必需。规定月
day | 必需。规定日
year | 可选。合法的范围是 4714 B.C. 到 9999 A.D。

提示和注释

尽管该函数可处理 4714 B.C. 之前的日期，您还是要注意格利高里历法在 1582 年才建立，一些国家甚至更晚才接受它（大不列颠在 1752 年，苏联在 1918 年，希腊在 1923 年）。大部分欧洲国家使用罗马儒略历（公历）先于格利高里历法。

例子

<?php
$jd = gregoriantojd(10,3,1975);
echo($jd . "<br />");

$gregorian = jdtogregorian($jd);
echo($gregorian);
?>

输出：

2442689
10/3/1975

PHP Array 函数

PHP 参考手册
PHP 测验


PHP header() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP header() 函数

PHP HTTP 函数

定义和用法

header() 函数向客户端发送原始的 HTTP 报头。

认识到一点很重要，即必须在任何实际的输出被发送之前调用 header() 函数（在 PHP 4 以及更高的版本中，您可以使用输出缓存来解决此问题）：

<html>
<?php
// 结果出错
// 在调用 header() 之前已存在输出
header('Location: http://www.example.com/');
?>

语法

header(string,replace,http_response_code)
参数 | 描述
string | 必需。规定要发送的报头字符串。
replace | 可选。指示该报头是否替换之前的报头，或添加第二个报头。 默认是 true（替换）。false（允许相同类型的多个报头）。
http_response_code | 可选。把 HTTP 响应代码强制为指定的值。（PHP 4 以及更高版本可用）

提示和注释

注释：从 PHP 4.4 之后，该函数防止一次发送多个报头。这是对头部注入攻击的保护措施。

例子

例子 1

<?php
// Date in the past
header("Expires: Mon, 26 Jul 1997 05:00:00 GMT");
header("Cache-Control: no-cache");
header("Pragma: no-cache");
?>

<html>
<body>

...
...

注释：用户可能会设置一些选项来更改浏览器的默认缓存设置。通过发送上面的报头，您可以覆盖任何这些设置，强制浏览器不进行缓存！

例子 2

提示用户保存一个生成的 PDF 文件（Content-Disposition 报头用于提供一个推荐的文件名，并强制浏览器显示保存对话框）：

<?php
header("Content-type:application/pdf");

// 文件将被称为 downloaded.pdf
header("Content-Disposition:attachment;filename='downloaded.pdf'");

// PDF 源在 original.pdf 中
readfile("original.pdf");
?>

<html>
<body>

...
...

注释：微软 IE 5.5 存在一个阻止以上机制的 bug。通过升级为 Service Pack 2 或更高的版本，可以解决该 bug。

PHP HTTP 函数

PHP 参考手册
PHP 测验


PHP headers_list() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP headers_list() 函数

PHP HTTP 函数

定义和用法

headers_list() 函数返回已发送的（或待发送的）响应头部的一个列表。

该函数返回包含报头的数组。

语法

headers_list()

提示和注释

提示：如需确定是否已发送报头，请使用 headers_sent() 函数。

例子

<?php
setcookie("TestCookie","SomeValue"');
header("X-Sample-Test: foo");
header('Content-type: text/plain');
?>

<html>
<body>

<?php
// 发送哪些报头？
var_dump(headers_list());
?>

</body>
</html>

PHP HTTP 函数

PHP 参考手册
PHP 测验


PHP headers_sent() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP headers_sent() 函数

PHP HTTP 函数

定义和用法

headers_sent() 函数检查 HTTP 报头是否发送/已发送到何处。

如果报头已发送，则返回 true，否则返回 false。

语法

headers_sent(file,line)
参数 | 描述
file,line | 可选。如果设置 file 和 line 参数，headers_sent() 会把输出开始的 PHP 源文件名和行号存入 file 和 line 变量中。

提示和注释

注释：一旦报头块已经发送，就不能使用 header() 添加多个报头行。

注释：可选的 file 和 line 参数是 PHP 4.3 中新加的。

例子

例子 1

<?php
// 如果报头未发送，则发送一个
if (!headers_sent())
  {
  header("Location: http://www.w3school.com.cn/");
  exit;
  }
?>

<html>
<body>

...
...

例子 2

使用可选的 file 和 line 参数：

<?php
// 传递 $file 和 $line，供日后使用
// 不要预先为它们赋值
if (!headers_sent($file, $line))
  {
  header("Location: http://www.w3school.com.cn/");
  exit;
  // Trigger an error here
  }
else
  {
  echo "Headers sent in $file on line $line";
  exit;
  }
?>

<html>
<body>

...
...

PHP HTTP 函数

PHP 参考手册
PHP 测验


PHP hebrev() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP hebrev() 函数

PHP String 函数

定义和用法

hebrev() 函数把希伯来文本从右至左的流转换为左至右的流。

只有 224 至 251 之间的 ASCII 字符，以及标点符号受到影响。

语法

hebrev(string,maxcharline)
参数 | 描述
string | 必需。希伯来文本。
salt | 规定每行的最大字符数。如果可能，hebrev() 将避免把单词断开。

提示和注释

提示：hebrev() 和 hebrevc() 可以把希伯来逻辑文本转换为希伯来可见文本。希伯来可见文本不需要特殊的右至左字符支持，这使它对于在 web 上显示希伯来文本很有用处。

PHP String 函数

PHP 参考手册
PHP 测验


PHP hebrevc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP hebrevc() 函数

PHP String 函数

定义和用法

hebrevc() 函数把希伯来文本从右至左的流转换为左至右的流。它也会把新行 (\n) 转换为 <br />。

只有 224 至 251 之间的 ASCII 字符，以及标点符号受到影响。

语法

hebrev(string,maxcharline)
参数 | 描述
string | 必需。希伯来文本。
salt | 规定每行的最大字符数。如果可能，hebrev() 将避免把单词断开。

提示和注释

提示： hebrev() 和 hebrevc() 可以把希伯来逻辑文本转换为希伯来可见文本。希伯来可见文本不需要特殊的右至左字符支持，这使它对于在 web 上显示希伯来文本很有用处。

PHP String 函数

PHP 参考手册
PHP 测验


PHP hexdec() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP hexdec() 函数

PHP Math 函数

定义和用法

hexdec() 函数把十六进制转换为十进制。

语法

hexdec(hex_string)
参数 | 描述
hex_string | 必需。规定要转换的十六进制数。

说明

返回与 hex_string 参数所表示的十六进制数等值的的十进制数。hexdec() 将一个十六进制字符串转换为十进制数。所能转换的最大数值为 7fffffff，即十进制的 2147483647。PHP 4.1.0 开始，该函数可以处理大数字，这种情况下，它会返回 float 类型。

hexdec() 将遇到的所有非十六进制字符替换成 0。这样，所有左边的零都被忽略，但右边的零会计入值中。

例子

<?php
echo hexdec("1e");
echo hexdec("a");
echo hexdec("11ff");
echo hexdec("cceeff");
?>

输出：

30
10
4607
13430527

PHP Math 函数

PHP 参考手册
PHP 测验


PHP highlight_file() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP highlight_file() 函数

PHP 杂项函数

定义和用法

highlight_file() 函数对文件进行语法高亮显示。

语法

highlight_file(filename,return)
参数 | 描述
filename | 必需。要进行高亮处理的 PHP 文件的路径。
return | 可选。如果设置 true，则本函数返回高亮处理的代码。

说明

本函数通过使用 PHP 语法高亮程序中定义的颜色，输出或返回包含在 filename 中的代码的语法高亮版本。

许多服务器被配置为对带有 phps 后缀的文件进行自动高亮处理。例如，在查看 example.phps 时，将显示该文件被语法高亮显示的源代码。要启用该功能，请把下面这一行添加到 httpd.conf：

AddType application/x-httpd-php-source .phps

返回值

如果 return 参数被设置为 true，那么该函数会返回被高亮处理的代码，而不是输出它们。否则，若成功，则返回 true，失败则返回 false。

提示和注释

警告：需要注意的是，在使用 highlight_file() 函数时，请不要因为疏忽而泄露诸如密码或其他类型的敏感信息，否则会出现潜在的安全风险。

例子

"test.php":

<html>
<body>
<?php
highlight_file("test.php");
?>
</body>
</html>

输出：

<html>
<body>
<?php
highlight_file("test.php");
?>
</body>
</html>

在浏览器中查看的结果类似这样：

<html>
<body>
<code>
<span style="color: #000000">&lt;html&gt;
<br />
&lt;body&gt;
<br />
<span style="color: #0000BB">&lt;?php
<br />highlight_file</span>
<span style="color: #007700">(</span>
<span style="color: #DD0000">"test.php"</span>
<span style="color: #007700">);<br /></span>
<span style="color: #0000BB">?&gt;<br /></span>
&lt;/body&gt;
<br />
&lt;/html&gt;</span>
</code>
</body>
</html>

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP highlight_string() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP highlight_string() 函数

PHP 杂项函数

定义和用法

highlight_string() 函数对字符串进行语法高亮显示。

语法

highlight_string(string,return)
参数 | 描述
string | 必需。要进行高亮处理的字符串。
return | 可选。如果设置 true，则本函数返回高亮处理的代码。

说明

本函数通过使用 PHP 语法高亮程序中定义的颜色，输出或返回给定的 PHP 代码的语法高亮版本。

返回值

如果 return 参数被设置为 true，那么该函数会以字符串返回被高亮处理的代码，而不是输出它们。否则，若成功，则返回 true，失败则返回 false。

例子

<html>
<body>
<?php
highlight_string("Hello world! <?php phpinfo(); ?>");
?>
</body>
</html>

输出：

Hello world! <?php phpinfo();?>

在浏览器中查看的结果类似这样：

<html>
<body>
 <code>
  <span style="color: #000000">Hello&nbsp;world!&nbsp;
  <span style="color: #0000BB">&lt;?php&nbsp;phpinfo</span>
  <span style="color: #007700">();</span>
  <span style="color: #0000BB">?&gt;</span>
  </span>
 </code>
</body>
</html>

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP html_entity_decode() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP html_entity_decode() 函数

PHP String 函数

定义和用法

html_entity_decode() 函数把 HTML 实体转换为字符。

html_entity_decode() 是 htmlentities() 的反函数。

语法

html_entity_decode(string,quotestyle,character-set)
参数 | 描述
string | 必需。规定要解码的字符串。
quotestyle

可选。规定如何解码单引号和双引号。

  • ENT_COMPAT - 默认。仅解码双引号。
  • ENT_QUOTES - 解码双引号和单引号。
  • ENT_NOQUOTES - 不解码任何引号。
character-set

可选。字符串值，规定要使用的字符集。

  • ISO-8859-1 - 默认。西欧。
  • ISO-8859-15 - 西欧（增加 Euro 符号以及法语、芬兰语字母）。
  • UTF-8 - ASCII 兼容多字节 8 比特 Unicode
  • cp866 - DOS 专用 Cyrillic 字符集
  • cp1251 - Windows 专用 Cyrillic 字符集
  • cp1252 - Windows 专用西欧字符集
  • KOI8-R - 俄语
  • GB2312 - 简体中文，国家标准字符集
  • BIG5 - 繁体中文
  • BIG5-HKSCS - Big5 香港扩展
  • Shift_JIS - 日语
  • EUC-JP - 日语

提示和注释

提示：无法被识别的字符集将被忽略，并由 ISO-8859-1 代替。

例子

<?php
$str = "John &amp; &#039;Adams&#039;";
echo html_entity_decode($str);
echo "<br />";
echo html_entity_decode($str, ENT_QUOTES);
echo "<br />";
echo html_entity_decode($str, ENT_NOQUOTES);
?>

浏览器输出：

John & 'Adams'
John & 'Adams'
John & 'Adams'

如果在浏览器中查看源代码，会看到这些 HTML：

<html>
<body>
John & &#039;Adams&#039;<br />
John & 'Adams'<br />
John & &#039;Adams&#039;
</body>
</html>

PHP String 函数

PHP 参考手册
PHP 测验


PHP html_entity_decode() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP htmlspecialchars_decode() 函数

PHP String 函数

定义和用法

htmlspecialchars_decode() 函数把一些预定义的 HTML 实体转换为字符。

会被解码的 HTML 实体是：

  • &amp; 成为 & （和号）
  • &quot; 成为 " （双引号）
  • &#039; 成为 ' （单引号）
  • &lt; 成为 < （小于）
  • &gt; 成为 > （大于）

语法

htmlspecialchars_decode(string,quotestyle)
参数 | 描述
string | 必需。规定要解码的字符串。
quotestyle

可选。规定如何解码单引号和双引号。

  • ENT_COMPAT - 默认。仅解码双引号。
  • ENT_QUOTES - 解码双引号和单引号。
  • ENT_NOQUOTES - 不解码任何引号。

例子

<?php
$str = "John &amp; &#039;Adams&#039;";
echo htmlspecialchars_decode($str);
echo "<br />";
echo htmlspecialchars_decode($str, ENT_QUOTES);
echo "<br />";
echo htmlspecialchars_decode($str, ENT_NOQUOTES);
?>

浏览器输出：

John & 'Adams'
John & 'Adams'
John & 'Adams'

如果在浏览器中查看源代码，会看到这些 HTML：

<html>
<body>
John & &#039;Adams&#039;<br />
John & 'Adams'<br />
John & &#039;Adams&#039;
</body>
</html>

PHP String 函数

PHP 参考手册
PHP 测验


PHP htmlentities() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP htmlentities() 函数

PHP String 函数

定义和用法

htmlentities() 函数把字符转换为 HTML 实体。

语法

htmlentities(string,quotestyle,character-set)
参数 | 描述
string | 必需。规定要转换的字符串。
quotestyle

可选。规定如何编码单引号和双引号。

  • ENT_COMPAT - 默认。仅编码双引号。
  • ENT_QUOTES - 编码双引号和单引号。
  • ENT_NOQUOTES - 不编码任何引号。
character-set

可选。字符串值，规定要使用的字符集。

  • ISO-8859-1 - 默认。西欧。
  • ISO-8859-15 - 西欧（增加 Euro 符号以及法语、芬兰语字母）。
  • UTF-8 - ASCII 兼容多字节 8 比特 Unicode
  • cp866 - DOS 专用 Cyrillic 字符集
  • cp1251 - Windows 专用 Cyrillic 字符集
  • cp1252 - Windows 专用西欧字符集
  • KOI8-R - 俄语
  • GB2312 - 简体中文，国家标准字符集
  • BIG5 - 繁体中文
  • BIG5-HKSCS - Big5 香港扩展
  • Shift_JIS - 日语
  • EUC-JP - 日语

提示和注释

提示：无法被识别的字符集将被忽略，并由 ISO-8859-1 代替。

例子

<html>
<body>
<?php
$str = "John & 'Adams'";
echo htmlentities($str, ENT_COMPAT);
echo "<br />";
echo htmlentities($str, ENT_QUOTES);
echo "<br />";
echo htmlentities($str, ENT_NOQUOTES);
?>
</body>
</html>

浏览器输出：

John & 'Adams'
John & 'Adams'
John & 'Adams'

如果在浏览器中查看源代码，会看到这些 HTML：

<html>
<body>
John &amp; 'Adams'<br />
John &amp; &#039;Adams&#039;<br />
John &amp; 'Adams'
</body>
</html>

PHP String 函数

PHP 参考手册
PHP 测验


PHP htmlspecialchars() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP htmlspecialchars() 函数

PHP String 函数

定义和用法

htmlspecialchars() 函数把一些预定义的字符转换为 HTML 实体。

预定义的字符是：

  • & （和号） 成为 &amp;
  • " （双引号） 成为 &quot;
  • ' （单引号） 成为 &#039;
  • < （小于） 成为 &lt;
  • > （大于） 成为 &gt;

语法

htmlspecialchars(string,quotestyle,character-set)
参数 | 描述
string | 必需。规定要转换的字符串。
quotestyle

可选。规定如何编码单引号和双引号。

  • ENT_COMPAT - 默认。仅编码双引号。
  • ENT_QUOTES - 编码双引号和单引号。
  • ENT_NOQUOTES - 不编码任何引号。
character-set

可选。字符串值，规定要使用的字符集。

  • ISO-8859-1 - 默认。西欧。
  • ISO-8859-15 - 西欧（增加 Euro 符号以及法语、芬兰语字母）。
  • UTF-8 - ASCII 兼容多字节 8 比特 Unicode
  • cp866 - DOS 专用 Cyrillic 字符集
  • cp1251 - Windows 专用 Cyrillic 字符集
  • cp1252 - Windows 专用西欧字符集
  • KOI8-R - 俄语
  • GB2312 - 简体中文，国家标准字符集
  • BIG5 - 繁体中文
  • BIG5-HKSCS - Big5 香港扩展
  • Shift_JIS - 日语
  • EUC-JP - 日语

提示和注释

提示：无法被识别的字符集将被忽略，并由 ISO-8859-1 代替。

例子

<html>
<body>
<?php
$str = "John & 'Adams'";
echo htmlspecialchars($str, ENT_COMPAT);
echo "<br />";
echo htmlspecialchars($str, ENT_QUOTES);
echo "<br />";
echo htmlspecialchars($str, ENT_NOQUOTES);
?>
</body>
</html>

浏览器输出：

John & 'Adams'
John & 'Adams'
John & 'Adams'

如果在浏览器中查看源代码，会看到这些 HTML：

<html>
<body>
John &amp; 'Adams'<br />
John &amp; &#039;Adams&#039;<br />
John &amp; 'Adams'
</body>
</html>

PHP String 函数

PHP 参考手册
PHP 测验


PHP HTTP 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP HTTP 函数

  • Previous Page
  • Next Page

PHP HTTP 简介

HTTP 函数允许您在其他输出被发送之前，对由 web 服务器发送到浏览器的信息进行操作。

安装

HTTP 函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

PHP HTTP 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
header() | 向客户端发送原始的 HTTP 报头。 | 3
headers_list() | 返回已发送的（或待发送的）响应头部的一个列表。 | 5
headers_sent() | 检查 HTTP 报头是否发送/已发送到何处。 | 3
setcookie() | 向客户端发送一个 HTTP cookie。 | 3
setrawcookie() | 不对 cookie 值进行 URL 编码，发送一个 HTTP cookie。 | 5
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP hypot() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP hypot() 函数

PHP Math 函数

定义和用法

hypot() 函数计算一直角三角形的斜边长度。

语法

hypot(x,y)
参数 | 描述
x | 必需。边 x 的长度。
y | 必需。边 y 的长度。

说明

hypot() 函数将会跟据直角三角形的两直解边长度 x 和 y 计算其斜边的长度。或者是从标点 (x , y) 到原点的距离。该函数的算法等同于 sqrt(x*x + y*y)。

例子

<?php
echo hypot(2,3);
echo hypot(3,6);
echo hypot(3,6);
echo hypot(1,3);
?>

输出：

3.60555127546
6.7082039325
6.7082039325
3.16227766017

PHP Math 函数

PHP 参考手册
PHP 测验


PHP idate() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP idate() 函数

PHP Date / Time 函数

定义和用法

idate() 函数将本地时间/日期格式化为整数。

语法

strftime(format,timestamp)
参数 | 描述
format | 可选。规定如何返回结果。
timestamp | 可选。

说明

根据给定的格式字符对 timestamp 进行格式化，并返回数字结果。

timestamp 为可选项，默认值为本地当前时间，即 time() 的值。

提示和注释

注释：与 date() 不同，idate() 只接受一个字符作为 format 参数。

format 参数可识别以下字符

format 字符 | 描述
B | Swatch Beat/Internet Time
d | 月份中的第几天
h | 小时（12 小时格式）
H | 小时（24 小时格式）
i | 分钟
I | 如果启用夏时制则返回 1，否则返回 0
L | 如果是闰年则返回 1，否则返回 0
m | 月份的数字
s | 秒数
t | 本月的总天数
U | 自 Unix 纪元（January 1 1970 00:00:00 GMT）起的秒数――这和 time() 作用相同
w | 星期中的第几天（星期天是 0）
W | ISO-8601 格式年份中的第几个星期，每星期从星期一开始
y | 年份（1 或 2 位数字――见下面说明）
Y | 年份（4 位数字）
z | 年份中的第几天
Z | 以秒为单位的时区偏移量

例子

<?php
echo(idate("Y"));
?>

输出：

2008

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP If...Else 语句

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP If...Else 语句

  • Previous Page
  • Next Page

if、elseif 以及 else 语句用于执行基于不同条件的不同动作。

条件语句

当您编写代码时，您常常需要为不同的判断执行不同的动作。

您可以在代码中使用条件语句来完成此任务。

if...else 语句
在条件成立时执行一块代码，条件不成立时执行另一块代码
elseif 语句
与 if...else 配合使用，在若干条件之一成立时执行一个代码块

If...Else 语句

如果您希望在某个条件成立时执行一些代码，在条件不成立时执行另一些代码，请使用 if....else 语句。

语法

if (condition)
  code to be executed if condition is true;
else
  code to be executed if condition is false;

实例

如果当前日期是周五，下面的代码将输出 "Have a nice weekend!"，否则会输出 "Have a nice day!"：

<html>
<body>

<?php
$d=date("D");
if ($d=="Fri")
  echo "Have a nice weekend!";
else
  echo "Have a nice day!";
?>

</body>
</html>

如果需要在条件成立或不成立时执行多行代码，应该把这些代码行包括在花括号中：

<html>
<body>

<?php
$d=date("D");
if ($d=="Fri")
  {
  echo "Hello!<br />";
  echo "Have a nice weekend!";
  echo "See you on Monday!";
  }
?>

</body>
</html>

ElseIf 语句

如果希望在多个条件之一成立时执行代码，请使用 elseif 语句：

语法

if (condition)
  code to be executed if condition is true;
elseif (condition)
  code to be executed if condition is true;
else
  code to be executed if condition is false;

实例

如果当前日期是周五，下面的例子会输出 "Have a nice weekend!"，如果是周日，则输出 "Have a nice Sunday!"，否则输出 "Have a nice day!"：

<html>
<body>

<?php
$d=date("D");
if ($d=="Fri")
  echo "Have a nice weekend!";
elseif ($d=="Sun")
  echo "Have a nice Sunday!";
else
  echo "Have a nice day!";
?>

</body>
</html>
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP ignore_user_abort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ignore_user_abort() 函数

PHP 杂项函数

定义和用法

ignore_user_abort() 函数设置与客户机断开是否会终止脚本的执行。

本函数返回 user-abort 设置的之前的值（一个布尔值）。

语法

ignore_user_abort(setting)
参数 | 描述
setting | 可选。如果设置为 true，则忽略与用户的断开，如果设置为 false，会导致脚本停止运行。 如果未设置该参数，会返回当前的设置。

提示和注释

注释：PHP 不会检测到用户是否已断开连接，直到尝试向客户机发送信息为止。简单地使用 echo 语句无法确保信息发送，参阅 flush() 函数。

例子

<?php
ignore_user_abort();
?>

输出：

0

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP implode() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP implode() 函数

PHP String 函数

定义和用法

implode() 函数把数组元素组合为一个字符串。

语法

implode(separator,array)
参数 | 描述
separator | 可选。规定数组元素之间放置的内容。默认是 ""（空字符串）。
array | 必需。要结合为字符串的数组。

说明

虽然 separator 参数是可选的。但是为了向后兼容，推荐您使用使用两个参数。

提示和注释

注释：implode() 可以接收两种参数顺序。但是由于历史原因，explode() 是不行的。你必须保证 separator 参数在 string 参数之前才行。

例子

<?php
$arr = array('Hello','World!','Beautiful','Day!');
echo implode(" ",$arr);
?>

输出：

Hello World! Beautiful Day!

PHP String 函数

PHP 参考手册
PHP 测验


PHP in_array() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP in_array() 函数

PHP Array 函数

定义和用法

in_array() 函数在数组中搜索给定的值。

语法

in_array(value,array,type)
参数 | 描述
value | 必需。规定要在数组搜索的值。
array | 必需。规定要搜索的数组。
type | 可选。如果设置该参数为 true，则检查搜索的数据与数组的值的类型是否相同。

说明

如果给定的值 value 存在于数组 array 中则返回 true。如果第三个参数设置为 true，函数只有在元素存在于数组中且数据类型与给定值相同时才返回 true。

如果没有在数组中找到参数，函数返回 false。

注释：如果 value 参数是字符串，且 type 参数设置为 true，则搜索区分大小写。

例子 1

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");

if (in_array("Glenn",$people))
  {
  echo "Match found";
  }
else
  {
  echo "Match not found";
  }
?>

输出：

Match found

例子 2

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland", 23);

if (in_array("23",$people, TRUE))
  {
  echo "Match found<br />";
  }
else
  {
  echo "Match not found<br />";
  }if (in_array("Glenn",$people, TRUE))
  {
  echo "Match found<br />";
  }
else
  {
  echo "Match not found<br />";
  }if (in_array(23,$people, TRUE))
  {
  echo "Match found<br />";
  }
else
  {
  echo "Match not found<br />";
  }
?>

输出：

Match not found
Match found
Match not found

PHP Array 函数

PHP 参考手册
PHP 测验


PHP is_dir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP is_dir() 函数

PHP Filesystem 函数

定义和用法

is_dir() 函数检查指定的文件是否是目录。

语法

is_dir(file)
参数 | 描述
file | 必需。规定要检查的文件。

说明

如果文件名存在并且为目录，则返回 true。如果 file 是一个相对路径，则按照当前工作目录检查其相对路径。

提示和注释

注释：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

<?php
$file = "images";
if(is_dir($file))
  {
  echo ("$file is a directory");
  }
else
  {
  echo ("$file is not a directory");
  }
?>

输出：

images is a directory

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP is_executable() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP is_executable() 函数

PHP Filesystem 函数

定义和用法

is_executable() 函数检查指定的文件是否可执行。

语法

is_executable(file)
参数 | 描述
file | 必需。规定要检查的文件。

说明

如果文件存在且可执行，则返回 true。

提示和注释

注释：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

注释：is_executable() 自 PHP 5.0.0 版起可用于 Windows。

例子

<?php
$file = "setup.exe";
if(is_executable($file))
  {
  echo ("$file is executable");
  }
else
  {
  echo ("$file is not executable");
  }
?>

输出：

setup.exe is executable

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP is_file() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP is_file() 函数

PHP Filesystem 函数

定义和用法

is_file() 函数检查指定的文件名是否是正常的文件。

语法

is_file(file)
参数 | 描述
file | 必需。规定要检查的文件。

说明

如果文件存在且为正常的文件，则返回 true。

提示和注释

注释：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

例子 1

<?php
$file = "test.txt";
if(is_file($file))
  {
  echo ("$file is a regular file");
  }
else
  {
  echo ("$file is not a regular file");
  }
?>

输出：

test.txt is a regular file

例子 2

<?php
var_dump(is_file('a_file.txt')) . "\n";
var_dump(is_file('/usr/bin/')) . "\n";
?>

输出：

bool(true)
bool(false)

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP is_finite() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP is_finite() 函数

PHP Math 函数

定义和用法

is_finite() 函数判断是否为有限值。

语法

is_finite(x)
参数 | 描述
x | 必需。规定要检查的值。

说明

如果 x 是本机平台上 PHP 浮点数所允许范围中的一个合法的有限值，则返回 true。

例子

<?php
echo is_finite(2);
echo is_finite(log(0));
echo is_finite(2000);
?>

输出：

1

1

PHP Math 函数

PHP 参考手册
PHP 测验


PHP is_infinite() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP is_infinite() 函数

PHP Math 函数

定义和用法

is_infinite() 判断是否为无限值。

语法

is_infinite(x)
参数 | 描述
x | 必需。规定要检查的值。

说明

如果 x 为无穷大（正的或负的），例如 log(0) 的结果或者任何超出本平台的浮点数范围的值，则返回 true。

例子

<?php
echo is_infinite(2);
echo is_infinite(log(0));
echo is_infinite(2000);
?>

输出：

1

PHP Math 函数

PHP 参考手册
PHP 测验


PHP is_link() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP is_link() 函数

PHP Filesystem 函数

定义和用法

is_link() 函数判断指定文件名是否为一个符号连接。

语法

is_link(file)
参数 | 描述
file | 必需。规定要检查的文件。

说明

如果文件存在并且是一个符号连接，则返回 true。

提示和注释

注释：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

<?php
$link = "images";
if(is_link($link))
  {
  echo ("$link is a link");
  }
else
  {
  echo ("$link is not a link");
  }
?>

输出：

images is not a link

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP is_nan() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP is_nan() 函数

PHP Math 函数

定义和用法

is_nan() 判断是否为合法数值。

语法

is_nan(x)
参数 | 描述
x | 必需。规定要检查的值。

说明

如果 x 为“非数值”，例如 acos(1.01) 的结果，则返回 true。

例子

<?php
echo is_nan(200);
echo is_nan(acos(1.01));
?>

输出：

1

PHP Math 函数

PHP 参考手册
PHP 测验


PHP is_readable() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP is_readable() 函数

PHP Filesystem 函数

定义和用法

is_readable() 函数判断指定文件名是否可读。

语法

is_readable(file)
参数 | 描述
file | 必需。规定要检查的文件。

说明

如果由 file 指定的文件或目录存在并且可读，则返回 TRUE。

提示和注释

注释：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

<?php
$file = "test.txt";
if(is_readable($file))
  {
  echo ("$file is readable");
  }
else
  {
  echo ("$file is not readable");
  }
?>

输出：

test.txt is readable

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP is_uploaded_file() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP is_uploaded_file() 函数

PHP Filesystem 函数

定义和用法

is_uploaded_file() 函数判断指定的文件是否是通过 HTTP POST 上传的。

语法

is_uploaded_file(file)
参数 | 描述
file | 必需。规定要检查的文件。

说明

如果 file 所给出的文件是通过 HTTP POST 上传的则返回 TRUE。

该函数可以用于确保恶意的用户无法欺骗脚本去访问本不能访问的文件，例如 /etc/passwd。

这种检查显得格外重要，如果上传的文件有可能会造成对用户或本系统的其他用户显示其内容的话。

提示和注释

注释：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

<?php
$file = "test.txt";
if(is_uploaded_file($file))
  {
  echo ("$file is uploaded via HTTP POST");
  }
else
  {
  echo ("$file is not uploaded via HTTP POST");
  }
?>

输出：

test.txt is not uploaded via HTTP POST

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP is_writable() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP is_writable() 函数

PHP Filesystem 函数

定义和用法

is_writable() 函数判断指定的文件是否可写。

语法

is_writable(file)
参数 | 描述
file | 必需。规定要检查的文件。

说明

如果文件存在并且可写则返回 true。file 参数可以是一个允许进行是否可写检查的目录名。

提示和注释

注释：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

<?php
$file = "test.txt";
if(is_writable($file))
  {
  echo ("$file is writeable");
  }
else
  {
  echo ("$file is not writeable");
  }
?>

输出：

test.txt is writeable

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP is_writeable() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP is_writeable() 函数

PHP Filesystem 函数

定义和用法

is_writeable() 函数判断指定的文件是否可写。

该函数是 is_writable() 函数的别名。

语法

is_writeable(file)
参数 | 描述
file | 必需。规定要检查的文件。

说明

如果文件存在并且可写则返回 true。file 参数可以是一个允许进行是否可写检查的目录名。

提示和注释

注释：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

<?php
$file = "test.txt";
if(is_writeable($file))
  {
  echo ("$file is writeable");
  }
else
  {
  echo ("$file is not writeable");
  }
?>

输出：

test.txt is writeable

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP JDDayOfWeek() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP JDDayOfWeek() 函数

PHP Array 函数

定义和用法

JDDayOfWeek() 函数返回日期在周几。

语法

jddayofweek(jd,mode)
参数 | 描述
jd | 必需。数字（儒略日计数）。
mode

可选。定义返回的内容（数字还是字符串）。模式值：

  • 0 - 默认。以整数返回周的天。（0 为周日, 1 为周一... 余类推）
  • 1 - 返回包含周的天的字符串。（英文-格里高里历）
  • 2 - 返回包含周的天的简写的字符串。（英文-格里高里历）

例子

<?php
$jd=cal_to_jd(CAL_GREGORIAN,date("m"),date("d"),date("Y"));
echo(jddayofweek($jd,1));
?>

输出：

Thursday

PHP Array 函数

PHP 参考手册
PHP 测验


PHP JDMonthName() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP JDMonthName() 函数

PHP Array 函数

定义和用法

JDMonthName() 函数返回指定历法的月份字符串。

语法

jdmonthname(jd,mode)
参数 | 描述
jd | 必需。数字（儒略日计数）。
mode

可选。定义把儒略日计数转换为哪种历法，以及返回哪种月份名称。模式值：

  • 0 - 格里高里历 (缩写) (Jan, Feb, Mar, ...)
  • 1 - 格里高里历 (January, February, March, ...)
  • 2 - 凯撒历 (缩写) (Jan, Feb, Mar, ...)
  • 3 - 凯撒历 (January, February, March, ...)
  • 4 - 犹太历 (Tishri, Heshvan, Kislev, ...)
  • 5 - 法国共和历 (Vendemiaire, Brumaire, Frimaire, ...)

例子

<?php
$jd=cal_to_jd(CAL_GREGORIAN,date("m"),date("d"),date("Y"));
echo(jdmonthname($jd,1));
?>

输出：

January

PHP Array 函数

PHP 参考手册
PHP 测验


PHP JDToFrench() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP JDToFrench() 函数

PHP Array 函数

定义和用法

JDToFrench() 函数把儒略日计数转换为法国共和国历法。

语法

jdtofrench(jd)
参数 | 描述
jd | 必需。数字（儒略日计数）。

提示和注释：

注释：该函数以 "month/day/year" 的格式返回一个字符串。

提示：法国共和历法是法国革命期间提出的一种历法，从 1793 年晚期开始，法国政府使用了大约 12 年。

例子

<?php
$d=jdtofrench(2380650);
echo($d);
?>

输出：

3/3/14

PHP Array 函数

PHP 参考手册
PHP 测验


PHP JDToGregorian() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP JDToGregorian() 函数

PHP Array 函数

定义和用法

JDToGregorian() 函数把儒略日计数转换为格利高里历法。

语法

jdtogregorian(jd)
参数 | 描述
jd | 必需。数字（儒略日计数）。

提示和注释：

注释：该函数以 "month/day/year" 的格式返回一个字符串。

例子

<?php
$jd = gregoriantojd(10,3,1975);
echo($jd . "<br />");

$gregorian = jdtogregorian($jd);
echo($gregorian);
?>

输出：

2442689
10/3/1975

PHP Array 函数

PHP 参考手册
PHP 测验


PHP JDToGregorian() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP JDToJewish() 函数

PHP Array 函数

定义和用法

JDToJewish() 函数把儒略日计数转换为犹太历法

语法

JDToJewish(jd)
参数 | 描述
jd | 必需。数字（儒略日计数）。
hebrew | 可选。True 指示希伯来语输出格式。
fl

可选。定义希伯来语输出格式，可用的格式有：

  • CAL_JEWISH_ADD_ALAFIM_GERESH
  • CAL_JEWISH_ADD_ALAFIM
  • CAL_JEWISH_ADD_GERESHAYIM

例子

<?php
echo(jdtojewish(gregoriantojd(10,8,2002)));
?>

输出：

2/2/5763

PHP Array 函数

PHP 参考手册
PHP 测验


PHP JDToGregorian() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP JDToJulian() 函数

PHP Array 函数

定义和用法

JDToJulian() 函数把儒略日计数转换为儒略历。

语法

JDToJulian(jd)
参数 | 描述
jd | 必需。数字（儒略日计数）。

提示和注释：

注释：该函数以 "month/day/year" 的格式返回一个字符串。

例子

<?php
$jd = juliantojd(10,3,1975);
echo($jd . "<br />");

$julian = jdtojulian($jd);
echo($julian);
?>

输出：

2442702
10/3/1975

PHP Array 函数

PHP 参考手册
PHP 测验


PHP JDToUnix() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP JDToUnix() 函数

PHP Array 函数

定义和用法

JDToUnix() 函数把儒略日计数转换为 Unix 时间戳。

语法

JDToUnix(jd)
参数 | 描述
jd | 必需。数字（儒略日计数）。

提示和注释：

注释：如果参数 jd 不在 Unix 新纪元之中（意味着格利高里年必须介于 1970 和 2037 之间，或者 jd >= 2440588 且 jd <= 2465342），则该函数将返回 false。所返回的时间是本地时间。

例子

<?php
$jd = gregoriantojd(10,3,1970);
$unix = jdtounix($jd);
echo($unix);
?>

输出：

23760000

PHP Array 函数

PHP 参考手册
PHP 测验


PHP JewishToJD() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP JewishToJD() 函数

PHP Array 函数

定义和用法

JewishToJD() 函数把犹太历法转换为儒略日计数。

语法

JDToUnix(jd)
参数 | 描述
month | 必需。规定月。
day | 必需。规定日。
year | 必需。规定年。

提示和注释：

注释：有效的范围为犹太历法公元前 3761 年起。犹太历法存在了数千年，但早期并没有公式化的开始月份计算法。每年的第一个月为首次观测到的新月。

例子

<?php
echo(jewishtojd(2,2,5763));
?>

输出：

2452556

PHP Array 函数

PHP 参考手册
PHP 测验


PHP join() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP join() 函数

PHP String 函数

定义和用法

join() 函数把数组元素组合为一个字符串。

join() 函数是 implode() 函数的别名。

语法

join(separator,array)
参数 | 描述
separator | 可选。规定数组元素之间放置的内容。默认是 ""（空字符串）。
array | 必需。要结合为字符串的数组。

说明

虽然 separator 参数是可选的。但是为了向后兼容，推荐您使用使用两个参数。

提示和注释

注释：join() 可以接收两种参数顺序。但是由于历史原因，explode() 是不行的。你必须保证 separator 参数在 string 参数之前才行。

例子

<?php
$arr = array('Hello','World!','Beautiful','Day!');
echo join(" ",$arr);
?>

输出：

Hello World! Beautiful Day!

PHP String 函数

PHP 参考手册
PHP 测验


PHP JulianToJD() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP JulianToJD() 函数

PHP Array 函数

定义和用法

JulianToJD() 函数把儒略历转换为儒略日计数。

语法

JDToUnix(jd)
参数 | 描述
month | 必需。规定月。
day | 必需。规定日。
year | 必需。规定年。合法的范围是 4713 B.C. 到 9999 A.D。

提示和注释：

注释：有效的范围为凯撒历法公元前 4713 年至公元 9999 年。该函数能计算到公元前 4713 年，但这是不太有意义的。凯撒历法是在公元前 46 年建立的，但一些细节等到公元 8 年才稳定下来。

例子

<?php
$jd = juliantojd(10,3,1975);
echo($jd . "<br />");

$julian = jdtojulian($jd);
echo($julian);
?>

输出：

2442702
10/3/1975

PHP Array 函数

PHP 参考手册
PHP 测验


PHP key() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP key() 函数

PHP Array 函数

定义和用法

key() 函数返回数组内部指针当前指向元素的键名。

若失败，则返回 FALSE。

该函数与 current() 类似，只是返回的结果不同。current() 函数返回的是元素的值，而 key() 函数返回的是元素的键名。

语法

key(array)
参数 | 描述
array | 必需。规定要使用的数组。

例子

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");
echo "The key from the current position is: " . key($people);
?>

输出：

The key from the current position is: 0

PHP Array 函数

PHP 参考手册
PHP 测验


PHP krsort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP krsort() 函数

PHP Array 函数

定义和用法

krsort() 函数将数组按照键逆向排序，为数组值保留原来的键。

可选的第二个参数包含附加的排序标志。

若成功，则返回 TRUE，否则返回 FALSE。

语法

krsort(array,sorttype)
参数 | 描述
array | 必需。规定要排序的数组。
sorttype

可选。规定如何排列数组的值。可能的值：

  • SORT_REGULAR - 默认。以它们原来的类型进行处理（不改变类型）。
  • SORT_NUMERIC - 把值作为数字来处理
  • SORT_STRING - 把值作为字符串来处理
  • SORT_LOCALE_STRING - 把值作为字符串来处理，基于本地设置*。

*：该值是 PHP 4.4.0 和 5.0.2 新加的。在 PHP 6 之前，使用了系统的区域设置，可以用 setlocale() 来改变。自 PHP 6 起，必须用 i18n_loc_set_default() 函数。

例子

<?php
$my_array = array("a" => "Dog", "b" => "Cat", "c" => "Horse");
krsort($my_array);
print_r($my_array);
?>

输出：

Array
(
[c] => Horse
[b] => Cat
[a] => Dog
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP ksort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ksort() 函数

PHP Array 函数

定义和用法

ksort() 函数按照键名对数组排序，为数组值保留原来的键。

可选的第二个参数包含附加的排序标志。

若成功，则返回 TRUE，否则返回 FALSE。

语法

ksort(array,sorttype)
参数 | 描述
array | 必需。规定要排序的数组。
sorttype

可选。规定如何排列数组的值。可能的值：

  • SORT_REGULAR - 默认。以它们原来的类型进行处理（不改变类型）。
  • SORT_NUMERIC - 把值作为数字来处理
  • SORT_STRING - 把值作为字符串来处理
  • SORT_LOCALE_STRING - 把值作为字符串来处理，基于本地设置*。

*：该值是 PHP 4.4.0 和 5.0.2 新加的。在 PHP 6 之前，使用了系统的区域设置，可以用 setlocale() 来改变。自 PHP 6 起，必须用 i18n_loc_set_default() 函数。

例子

<?php
$my_array = array("a" => "Dog", "b" => "Cat", "c" => "Horse");
ksort($my_array);
print_r($my_array);
?>

输出：

Array
(
[a] => Dog
[b] => Cat
[c] => Horse
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP lcg_value() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP lcg_value() 函数

PHP Math 函数

定义和用法

lcg_value() 组合线性同余发生器。

语法

lcg_value()

说明

lcg_value() 返回范围为 (0, 1) 的一个伪随机数。本函数组合了周期为 2^31 - 85 和 2^31 - 249 的两个同余发生器。本函数的周期等于这两个素数的乘积。

例子

<?php
echo lcg_value();
?>

输出类似：

0.508212039328

PHP Math 函数

PHP 参考手册
PHP 测验


PHP levenshtein() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP levenshtein() 函数

PHP String 函数

定义和用法

levenshtein() 函数返回两个字符串之间的 Levenshtein 距离。

Levenshtein 距离，又称编辑距离，指的是两个字符串之间，由一个转换成另一个所需的最少编辑操作次数。许可的编辑操作包括将一个字符替换成另一个字符，插入一个字符，删除一个字符。

例如把 kitten 转换为 sitting：

  1. sitten （k→s）
  2. sittin （e→i）
  3. sitting （→g）

levenshtein() 函数给每个操作（替换、插入和删除）相同的权重。不过，您可以通过设置可选的 insert、replace、delete 参数，来定义每个操作的代价。

语法

levenshtein(string1,string2,insert,replace,delete)
参数 | 描述
string1 | 必需。要对比的第一个字符串。
string2 | 必需。要对比的第二个字符串。
insert | 可选。插入一个字符的代价。默认是 1。
replace | 可选。替换一个字符的代价。默认是 1。
delete | 可选。删除一个字符的代价。默认是 1。

提示和注释

注释：如果其中一个字符串超过 255 个字符，levenshtein() 函数返回 -1。

注释：levenshtein() 函数对大小写不敏感。

注释：levenshtein() 函数比 similar_text() 函数更快。不过，similar_text() 函数提供需要更少修改的更精确的结果。

例子

<?php
echo levenshtein("Hello World","ello World");
echo "<br />";
echo levenshtein("Hello World","ello World",10,20,30);
?>

输出：

1
30

PHP String 函数

PHP 参考手册
PHP 测验


PHP libxml_clear_errors() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP libxml_clear_errors() 函数

PHP libxml 函数

定义和用法

libxml_clear_errors() 函数清空 libxml 错误缓冲。

语法

libxml_clear_errors()

例子

<?php
libxml_clear_errors()
?>

PHP libxml 函数

PHP 参考手册
PHP 测验


PHP libxml_get_errors() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP libxml_get_errors() 函数

PHP libxml 函数

定义和用法

libxml_get_errors() 函数从 libxml 错误缓冲中获取错误。

该函数返回错误对象的一个数组，如果 libxml 错误缓冲中没有错误，则返回一个空数组。

语法

libxml_get_errors()

例子

<?php
libxml_get_errors()
?>

PHP libxml 函数

PHP 参考手册
PHP 测验


PHP libxml_get_last_error() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP libxml_get_last_error() 函数

PHP libxml 函数

定义和用法

libxml_get_last_error() 函数从 libxml 错误缓冲中获取最后一个错误。

若成功，则返回一个错误对象。若失败，或 libxml 错误缓冲中没有错误，则返回 false。

语法

libxml_get_last_error()

例子

<?php
libxml_get_last_error()
?>

PHP libxml 函数

PHP 参考手册
PHP 测验


PHP libxml_use_internal_errors() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP libxml_use_internal_errors() 函数

PHP libxml 函数

定义和用法

libxml_use_internal_errors() 函数禁用标准的 libxml 错误，并启用用户错误处理。

语法

libxml_use_internal_errors(user_errors)
参数 | 描述
user_errors | 可选。规定是否应该启用用户错误处理。默认是 false。

说明

该函数返回 user_errors 参数之前的值。

例子

<?php
libxml_use_internal_errors()
?>

PHP libxml 函数

PHP 参考手册
PHP 测验


PHP libxml 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP libxml 函数

  • Previous Page
  • Next Page

PHP libxml 简介

libxml 函数和常量与 SimpleXML, XSLT 以及 DOM 一起使用。

安装

这些函数需要 libxml 程序包。在 xmlsoft.org 下载。

PHP libxml 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
libxml_clear_errors() | 清空 libxml 错误缓冲。 | 5
libxml_get_errors() | 检索错误数组。 | 5
libxml_get_last_error() | 从 libxml 检索最后的错误。 | 5
libxml_set_streams_context() | 为下一次 libxml 文档加载或写入设置流环境。 | 5
libxml_use_internal_errors() | 禁用 libxml 错误，允许用户按需读取错误信息。 | 5

PHP libxml 常量

函数 | 描述 | PHP
LIBXML_COMPACT | 设置小型节点分配优化。会改善应用程序的性能。 | 5
LIBXML_DTDATTR | 设置默认 DTD 属性。 | 5
LIBXML_DTDLOAD | 加载外部子集。 | 5
LIBXML_DTDVALID | 通过 DTD 进行验证。 | 5
LIBXML_NOBLANKS | 删除空节点。 | 5
LIBXML_NOCDATA | 把 CDATA 设置为文本节点。 | 5
LIBXML_NOEMPTYTAG | 更改空标签（比如 <br/> 改为 <br></br>）。 仅在 DOMDocument->save() 和 DOMDocument->saveXML() 函数中可用。 | 5
LIBXML_NOENT | 替代实体。 | 5
LIBXML_NOERROR | 不显示错误报告。 | 5
LIBXML_NONET | 在加载文档时停止网络访问。 | 5
LIBXML_NOWARNING | 不显示警告报告。 | 5
LIBXML_NOXMLDECL | 在保存文档时，撤销 XML 声明。 | 5
LIBXML_NSCLEAN | 删除额外的命名空间声明。 | 5
LIBXML_XINCLUDE | 使用 XInclude 置换。 | 5
LIBXML_ERR_ERROR | 获得可恢复的错误。 | 5
LIBXML_ERR_FATAL | 获得致命错误。 | 5
LIBXML_ERR_NONE | 获得无错误。 | 5
LIBXML_ERR_WARNING | 获得简单警告。 | 5
LIBXML_VERSION | 获得 libxml 版本（例如：20605 或 20617）。 | 5
LIBXML_DOTTED_VERSION | 获得有点号的 libxml 版本（例如：2.6.5 或 2.6.17）。 | 5
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP link() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP link() 函数

PHP Filesystem 函数

定义和用法

link() 函数建立一个硬连接。

如果成功，则返回 true，失败则返回 false。

提示：创建的连接不是 HTML 链接，而是文件系统中的连接。

语法

link(target,link)
参数 | 描述
target | 必需。
link | 必需。

提示和注释

注释：本函数不能作用于远程文件，被检查的文件必须通过服务器的文件系统访问。

注释：本函数不能工作在 windows 平台上。

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP linkinfo() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP linkinfo() 函数

PHP Filesystem 函数

定义和用法

linkinfo() 函数返回连接的信息。

本函数返回设备 ID。若出错，则返回 0 或 FALSE。

语法

linkinfo(path)
参数 | 描述
path | 必需。规定要检查的路径

提示和注释

注释：本函数不能工作在 windows 平台上。

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP list() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP list() 函数

PHP Array 函数

定义和用法

list() 函数用数组中的元素为一组变量赋值。

注意，与 array() 类似，list() 实际上是一种语言结构，不是函数。

语法

list(var1,var2...)
参数 | 描述
var1 | 必需。第一个需要赋值的变量。
var2 | 可选。可以有多个变量。

提示和注释

注释：该函数只用于数字索引的数组，且假定数字索引从 0 开始。

例子 1

<?php
$my_array = array("Dog","Cat","Horse");

list($a, $b, $c) = $my_array;
echo "I have several animals, a $a, a $b and a $c.";
?>

输出：

I have several animals, a Dog, a Cat and a Horse.

例子 2

<?php
$my_array = array("Dog","Cat","Horse");

list($a, , $c) = $my_array;
echo "Here I only use the $a and $c variables.";
?>

输出：

Here I only use the Dog and Horse variables.

PHP Array 函数

PHP 参考手册
PHP 测验


PHP localeconv() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP localeconv() 函数

PHP String 函数

定义和用法

localeconv() 函数返回包含本地数字及货币信息格式的数组。

localeconv() 函数返回以下数组元素：

  • [decimal_point] - 小数点字符
  • [thousands_sep] - 千位分隔符
  • [int_curr_symbol] - 货币符号 （例如：USD）
  • [currency_symbol] - 货币符号 （例如：$）
  • [mon_decimal_point] - 货币小数点符号
  • [mon_thousands_sep] - 货币千位分隔符
  • [positive_sign] - 正值符号
  • [negative_sign] - 负值符号
  • [int_frac_digits] - 国际小数数字
  • [frac_digits] - 本地小数数字
  • [p_cs_precedes] - if 如果货币符号在正值之前，则是 True (1)，否则是 False (0)。
  • [p_sep_by_space] - True (1) 如果货币符号与正值之间有空间，则是 True (1)，否则是 False (0)。
  • [n_cs_precedes] - True (1) if 货币符号在负值之前，则是 True (1)，否则是 False (0)。
  • [p_sep_by_space] - True (1) 如果货币符号与负值之间有空间，则是 True (1)，否则是 False (0)。
  • [p_sign_posn] - 格式化选项：
    • 0 - 在数量和货币符号周围的圆括号
    • 1 - 数量和货币符号之前的 + 号
    • 2 - 数量和货币符号之后的 + 号
    • 3 - 货币符号之前的 + 号
    • 4 - 货币符号之后的 + 号
  • [n_sign_posn] - 格式化选项：
    • 0 - 在数量和货币符号周围的圆括号
    • 1 - 数量和货币符号之前的 - 号
    • 2 - 数量和货币符号之后的 - 号
    • 3 - 货币符号之前的 - 号
    • 4 - 货币符号之后的 - 号
  • [grouping] - 显示如何分组数字的 Array（例如：3 指示 1 000 000）
  • [mon_grouping] - 显示如何分组货币数字的 Array（例如：2 指示 1 00 00 00）

语法

localeconv()

提示和注释

提示：如需定义本地设置，请使用 setlocale() 函数。

例子

在本例中，我们将获得美国本地的数字格式化信息：

<?php
setlocale(LC_ALL, 'US');
$locale_info = localeconv();
print_r($locale_info);
?>

输出：

Array
(
[decimal_point] => .
[thousands_sep] => ,
[int_curr_symbol] => USD
[currency_symbol] => $
[mon_decimal_point] => .
[mon_thousands_sep] => ,
[positive_sign] =>
[negative_sign] => -
[int_frac_digits] => 2
[frac_digits] => 2
[p_cs_precedes] => 1
[p_sep_by_space] => 0
[n_cs_precedes] => 1
[n_sep_by_space] => 0
[p_sign_posn] => 3
[n_sign_posn] => 0
[grouping] => Array ([0] => 3)
[mon_grouping] => Array ([0] => 3)
)

PHP String 函数

PHP 参考手册
PHP 测验


PHP localtime() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP localtime() 函数

PHP Date / Time 函数

定义和用法

localtime() 函数返回本地时间（一个数组）。

localtime() 的第一个参数是时间戳，如果没有给出则使用从 time() 返回的当前时间。

第二个参数是 is_associative，如果设为 false 或未提供则返回的是普通的数字索引数组。如果该参数设为 true 则 localtime() 函数返回一个关联数组。

关联数组中不同的键名是：

  • "tm_sec" - 秒数
  • "tm_min" - 分钟数
  • "tm_hour" - 小时
  • "tm_mday" - 月份中的第几日
  • "tm_mon" - 年份中的第几个月，从 0 开始表示一月
  • "tm_year" - 年份，从 1900 开始
  • "tm_wday" - 星期中的第几天
  • "tm_yday" - 一年中的第几天
  • "tm_isdst" - 夏令时当前是否生效

注释：月份从 0（一月）到 11（十二月），星期数从 0（星期天）到 6（星期六）。

语法

localtime(timestamp,is_associative)
参数 | 描述
timestamp | 可选。规定被格式化的日期或时间。若未规定 timestamp，则使用当前的本地时间。
is_associative | 可选。规定返回索引数组还是关联数组。

例子

<?php
$localtime = localtime();
$localtime_assoc = localtime(time(), true);
print_r($localtime);
print_r($localtime_assoc);
?>

输出：

Array
(
    [0] => 24
    [1] => 3
    [2] => 19
    [3] => 3
    [4] => 3
    [5] => 105
    [6] => 0
    [7] => 92
    [9] => 1
)

Array
(
    [tm_sec] => 24
    [tm_min] => 3
    [tm_hour] => 19
    [tm_mday] => 3
    [tm_mon] => 3
    [tm_year] => 105
    [tm_wday] => 0
    [tm_yday] => 92
    [tm_isdst] => 1
)

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP log() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP log() 函数

PHP Math 函数

定义和用法

log() 返回自然对数。

语法

log(x,base)
参数 | 描述
x | 必需。一个数。
base | 可选。如果规定了该参数，则返回 logbasex。

说明

如果指定了可选的参数 base，log() 返回 logbasex ，否则 log() 返回参数 x 的自然对数。

注释：参数 base 自 PHP 4.3.0 开始可用。你可以计算任意以 b 为底 n 的对数，但其实使用的是数学等式：logb(n) = log(n)/log(b)，其中 log 是自然对数。

例子

<?php
echo lcg_value();
?>

输出类似：

0.508212039328

PHP Math 函数

PHP 参考手册
PHP 测验


PHP log10() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP log10() 函数

PHP Math 函数

定义和用法

log10() 以 10 为底的对数。

语法

log10(x)
参数 | 描述
x | 必需。一个数。

说明

返回参数 x 以 10 为底的对数。

提示和注释：

注释：如果参数 x 是负数，则返回 -1.#IND。

例子

在本例中，我们对不同的数应用 log10() 函数：

<?php
echo(log10(2.7183));
echo(log10(2));
echo(log10(1));
echo(log10(0));
echo(log10(-1));
?>

输出类似：

0.434297385125
0.301029995664
0
-1.#INF
-1.#IND

PHP Math 函数

PHP 参考手册
PHP 测验


PHP log1p() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP log1p() 函数

PHP Math 函数

定义和用法

log1p() 以返回 log(1 + x)，甚至当 x 的值接近零也能计算出准确结果。

语法

log1p(x)
参数 | 描述
x | 必需。一个数。

说明

警告：本函数是实验性的。本函数的行为，包括函数名称以及其它任何关于本函数的文档可能会在没有通知的情况下随 PHP 以后的发布而改变。使用本函数风险自担。

PHP Math 函数

PHP 参考手册
PHP 测验


PHP lstat() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP lstat() 函数

PHP Filesystem 函数

定义和用法

lstat() 函数返回关于文件或符号连接的信息。

语法

lstat(file)
参数 | 描述
file | 必需。规定要检查的文件。

说明

获取由 file 参数指定的文件或符号连接的统计信息。

lstat() 的返回格式

数字下标 | 关联键名（自 PHP 4.0.6） | 说明
0 | dev | 设备名
1 | ino | 号码
2 | mode | inode 保护模式
3 | nlink | 被连接数目
4 | uid | 所有者的用户 id
5 | gid | 所有者的组 id
6 | rdev | 设备类型，如果是 inode 设备的话
7 | size | 文件大小的字节数
8 | atime | 上次访问时间（Unix 时间戳）
9 | mtime | 上次修改时间（Unix 时间戳）
10 | ctime | 上次改变时间（Unix 时间戳）
11 | blksize | 文件系统 IO 的块大小
12 | blocks | 所占据块的数目

提示和注释

提示：本函数与 stat() 函数相同，不同之处只有一点：如果 file 参数是符号连接的话，则该符号连接的状态被返回，而不是该符号连接所指向的文件的状态。

注释：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

<?php
print_r(lstat("test.txt"));
?>

输出类似：

Array
(
[0] => 0
[1] => 0
[2] => 33206
[3] => 1
[4] => 0
[5] => 0
[6] => 0
[7] => 92
[8] => 1141633430
[9] => 1141298003
[10] => 1138609592
[11] => -1
[12] => -1
[dev] => 0
[ino] => 0
[mode] => 33206
[nlink] => 1
[uid] => 0
[gid] => 0
[rdev] => 0
[size] => 92
[atime] => 1141633430
[mtime] => 1141298003
[ctime] => 1138609592
[blksize] => -1
[blocks] => -1
)

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP ltrim() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ltrim() 函数

PHP String 函数

定义和用法

ltrim() 函数从字符串左侧删除空格或其他预定义字符。

语法

ltrim(string,charlist)
参数 | 描述
string | 必需。规定要转换的字符串。
charlist

可选。规定从字符串中删除哪些字符。

如果未设置该参数，则全部删除以下字符：

  • "\0" - ASCII 0, NULL
  • "\t" - ASCII 9, 制表符
  • "\n" - ASCII 10, 新行
  • "\x0B" - ASCII 11, 垂直制表符
  • "\r" - ASCII 13, 回车
  • " " - ASCII 32, 空格

例子

例子 1

<html>
<body>
<?php
$str = "    Hello World!";
echo "Without ltrim: " . $str;
echo "<br />";
echo "With ltrim: " . ltrim($str);
?>
<body>
<html>

输出：

Without ltrim: Hello World!
With ltrim: Hello World!

如果在浏览器中查看源代码，会看到以下 HTML：

<html>
<body>
Without ltrim:     Hello World!<br />With ltrim: Hello World!
</body>
</html>

例子 2

<?php
$str = "\r\nHello World!";
echo "Without ltrim: " . $str;
echo "<br />";
echo "With ltrim: " . ltrim($str);
?>

输出：

Without ltrim: Hello World!
With ltrim: Hello World!

如果在浏览器中查看源代码，会看到以下 HTML：

<html>
<body>
Without ltrim:
Hello World!<br />With ltrim: Hello World!
</body>
</html>

PHP String 函数

PHP 参考手册
PHP 测验


PHP Mail 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Mail 函数

  • Previous Page
  • Next Page

PHP Mail 简介

HTTP 函数允许您从脚本中直接发送电子邮件。

需求

要使邮件函数可用，PHP 需要已安装且正在运行的邮件系统。要使用的程序是由 php.ini 文件中的配置设置定义的。

安装

邮件函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

运行时配置

邮件函数的行为受 php.ini 的影响。

Mail 配置选项

名称 | 默认 | 描述 | 可更改
SMTP | "localhost" | Windows 专用：SMTP 服务器的 DNS 名称或 IP 地址。 | PHP_INI_ALL
smtp_port | "25" | Windows 专用：SMTP 段口号。自 PHP 4.3 起可用。 | PHP_INI_ALL
sendmail_from | NULL | Windows 专用：规定从 PHP 发送的邮件中使用的 "from" 地址。 | PHP_INI_ALL
sendmail_path | NULL | Unix 系统专用：规定sendmail 程序的路径（通常 /usr/sbin/sendmail 或 /usr/lib/sendmail） | PHP_INI_SYSTEM

PHP Mail 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
ezmlm_hash() | 计算 EZMLM 邮件列表系统所需的散列值。 | 3
mail() | 允许您从脚本中直接发送电子邮件。 | 3
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP mail() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mail() 函数

PHP Mail 函数

定义和用法

mail() 函数允许您从脚本中直接发送电子邮件。

如果邮件的投递被成功地接收，则返回 true，否则返回 false。

语法

mail(to,subject,message,headers,parameters)
参数 | 描述
to | 必需。规定邮件的接收者。
subject | 必需。规定邮件的主题。该参数不能包含任何换行字符。
message | 必需。规定要发送的消息。
headers | 必需。规定额外的报头，比如 From, Cc 以及 Bcc。
parameters | 必需。规定 sendmail 程序的额外参数。

说明

在 message 参数规定的消息中，行之间必须以一个 LF（\n）分隔。每行不能超过 70 个字符。

（Windows 下）当 PHP 直接连接到 SMTP 服务器时，如果在一行开头发现一个句号，则会被删掉。要避免此问题，将单个句号替换成两个句号。

<?php
$text = str_replace("\n.", "\n..", $text);
?>

提示和注释

注释：您需要紧记，邮件投递被接受，并不意味着邮件到达了计划的目的地。

例子

例子 1

发送一封简单的邮件：

<?php

$txt = "First line of text\nSecond line of text";

// 如果一行大于 70 个字符，请使用 wordwrap()。
$txt = wordwrap($txt,70);

// 发送邮件
mail("somebody@example.com","My subject",$txt);
?>

例子 2

发送带有额外报头的 email：

<?php

$to = "somebody@example.com";
$subject = "My subject";
$txt = "Hello world!";
$headers = "From: webmaster@example.com" . "\r\n" .
"CC: somebodyelse@example.com";

mail($to,$subject,$txt,$headers);
?>

例子 3

发送一封 HTML email：

<?php

$to = "somebody@example.com, somebodyelse@example.com";
$subject = "HTML email";

$message = "
<html>
<head>
<title>HTML email</title>
</head>
<body>
<p>This email contains HTML Tags!</p>
<table>
<tr>
<th>Firstname</th>
<th>Lastname</th>
</tr>
<tr>
<td>John</td>
<td>Doe</td>
</tr>
</table>
</body>
</html>
";

// 当发送 HTML 电子邮件时，请始终设置 content-type
$headers = "MIME-Version: 1.0" . "\r\n";
$headers .= "Content-type:text/html;charset=iso-8859-1" . "\r\n";

// 更多报头
$headers .= 'From: <webmaster@example.com>' . "\r\n";
$headers .= 'Cc: myboss@example.com' . "\r\n";

mail($to,$subject,$message,$headers);
?>

PHP Mail 函数

PHP 参考手册
PHP 测验


PHP Math 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Math 函数

  • Previous Page
  • Next Page

PHP Math 简介

数学 (Math) 函数能处理 integer 和 float 范围内的值。

安装

数学 (Math) 函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

PHP Math 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
abs() | 绝对值。 | 3
acos() | 反余弦。 | 3
acosh() | 反双曲余弦。 | 4
asin() | 反正弦。 | 3
asinh() | 反双曲正弦。 | 4
atan() | 反正切。 | 3
atan2() | 两个参数的反正切。 | 3
atanh() | 反双曲正切。 | 4
base_convert() | 在任意进制之间转换数字。 | 3
bindec() | 把二进制转换为十进制。 | 3
ceil() | 向上舍入为最接近的整数。 | 3
cos() | 余弦。 | 3
cosh() | 双曲余弦。 | 4
decbin() | 把十进制转换为二进制。 | 3
dechex() | 把十进制转换为十六进制。 | 3
decoct() | 把十进制转换为八进制。 | 3
deg2rad() | 将角度转换为弧度。 | 3
exp() | 返回 Ex 的值。 | 3
expm1() | 返回 Ex - 1 的值。 | 4
floor() | 向下舍入为最接近的整数。 | 3
fmod() | 返回除法的浮点数余数。 | 4
getrandmax() | 显示随机数最大的可能值。 | 3
hexdec() | 把十六进制转换为十进制。 | 3
hypot() | 计算直角三角形的斜边长度。 | 4
is_finite() | 判断是否为有限值。 | 4
is_infinite() | 判断是否为无限值。 | 4
is_nan() | 判断是否为合法数值。 | 4
lcg_value() | 返回范围为 (0, 1) 的一个伪随机数。 | 4
log() | 自然对数。 | 3
log10() | 以 10 为底的对数。 | 3
log1p() | 返回 log(1 + number)。 | 4
max() | 返回最大值。 | 3
min() | 返回最小值。 | 3
mt_getrandmax() | 显示随机数的最大可能值。 | 3
mt_rand() | 使用 Mersenne Twister 算法返回随机整数。 | 3
mt_srand() | 播种 Mersenne Twister 随机数生成器。 | 3
octdec() | 把八进制转换为十进制。 | 3
pi() | 返回圆周率的值。 | 3
pow() | 返回 x 的 y 次方。 | 3
rad2deg() | 把弧度数转换为角度数。 | 3
rand() | 返回随机整数。 | 3
round() | 对浮点数进行四舍五入。 | 3
sin() | 正弦。 | 3
sinh() | 双曲正弦。 | 4
sqrt() | 平方根。 | 3
srand() | 播下随机数发生器种子。 | 3
tan() | 正切。 | 3
tanh() | 双曲正切。 | 4

PHP Math 常量

常量名 | 常量名 | 常量值 | PHP
M_E | e | 2.7182818284590452354 | 4
M_EULER | Euler 常量 | 0.57721566490153286061 | 5.2.0
M_LNPI | log_e(pi) | 1.14472988584940017414 | 5.2.0
M_LN2 | log_e 2 | 0.69314718055994530942 | 4
M_LN10 | log_e 10 | 2.30258509299404568402 | 4
M_LOG2E | log_2 e | 1.4426950408889634074 | 4
M_LOG10E | log_10 e | 0.43429448190325182765 | 4
M_PI | Pi | 3.14159265358979323846 | 3
M_PI_2 | pi/2 | 1.57079632679489661923 | 4
M_PI_4 | pi/4 | 0.78539816339744830962 | 4
M_1_PI | 1/pi | 0.31830988618379067154 | 4
M_2_PI | 2/pi | 0.63661977236758134308 | 4
M_SQRTPI | sqrt(pi) | 1.77245385090551602729 | 5.2.0
M_2_SQRTPI | 2/sqrt(pi) | 1.12837916709551257390 | 4
M_SQRT1_2 | 1/sqrt(2) | 0.70710678118654752440 | 4
M_SQRT2 | sqrt(2) | 1.41421356237309504880 | 4
M_SQRT3 | sqrt(3) | 1.73205080756887729352 | 5.2.0
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP max() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP max() 函数

PHP Math 函数

定义和用法

max() 返回最大值。

语法

max(x,y)
参数 | 描述
x | 必需。一个数。
y | 必需。一个数。

说明

max() 返回参数中数值最大的值。

如果仅有一个参数且为数组，max() 返回该数组中最大的值。如果第一个参数是整数、字符串或浮点数，则至少需要两个参数而 max() 会返回这些值中最大的一个。可以比较无限多个值。

提示和注释

注释：PHP 会将非数值的字符串当成 0，但如果这个正是最大的数值则仍然会返回一个字符串。如果多个参数都求值为 0 且是最大值，max() 会返回其中数值的 0，如果参数中没有数值的 0，则返回按字母表顺序最大的字符串。

例子

在本例中，我们将使用 max() 来返回两个指定的数中的最大值：

<?php
echo(max(5,7));
echo(max(-3,5));
echo(max(-3,-5));
echo(max(7.25,7.30));
?>

输出类似：

7
5
-3
7.3

PHP Math 函数

PHP 参考手册
PHP 测验


PHP md5_file() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP md5_file() 函数

PHP String 函数

定义和用法

md5_file() 函数计算文件的 MD5 散列。

md5() 函数使用 RSA 数据安全，包括 MD5 报文摘译算法。

如果成功，则返回所计算的 MD5 散列，如果失败，则返回 false。

语法

md5(string,raw)
参数 | 描述
string | 必需。规定要计算的文件。
charlist

可选。规定十六进制或二进制输出格式：

  • TRUE - 原始 16 字符二进制格式
  • FALSE - 默认。32 字符十六进制数

注释：该参数是 PHP 5.0 中添加的。

例子

例子 1

<?php
$filename = "test.txt";
$md5file = md5_file($filename);
echo $md5file;
?>

输出：

5d41402abc4b2a76b9719d911017c592

例子 2

存储 "test.txt" 文件的 MD5 散列：

<?php
$md5file = md5_file("test.txt");
file_put_contents("md5file.txt",$md5file);
?>

在本例中，我们将检测 "test.txt" 是否已被更改（即是否 MD5 散列已被更改）：

<?php
$md5file = file_get_contents("md5file.txt");
if (md5_file("test.txt") == $md5file)
  {
  echo "The file is ok.";
  }
else
  {
  echo "The file has been changed.";
  }
?>

输出：

The file is ok.

PHP String 函数

PHP 参考手册
PHP 测验


PHP md5() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP md5() 函数

PHP String 函数

定义和用法

md5() 函数计算字符串的 MD5 散列。

md5() 函数使用 RSA 数据安全，包括 MD5 报文摘译算法。

如果成功，则返回所计算的 MD5 散列，如果失败，则返回 false。

语法

md5(string,raw)
参数 | 描述
string | 必需。规定要计算的字符串。
charlist

可选。规定十六进制或二进制输出格式：

  • TRUE - 原始 16 字符二进制格式
  • FALSE - 默认。32 字符十六进制数

注释：该参数是 PHP 5.0 中添加的。

例子

例子 1

<?php
$str = "Hello";
echo md5($str);
?>

输出：

8b1a9953c4611296a827abf8c47804d7

例子 2

<?php
$str = "Hello";
echo md5($str);

if (md5($str) == '8b1a9953c4611296a827abf8c47804d7')
  {
  echo "<br />Hello world!";
  exit;
  }
?>

输出：

8b1a9953c4611296a827abf8c47804d7
Hello world!

PHP String 函数

PHP 参考手册
PHP 测验


PHP metaphone() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP metaphone() 函数

PHP String 函数

定义和用法

metaphone() 函数计算字符串的 metaphone 键。

metaphone 键字符串的英语发音。

metaphone() 函数可用于拼写检查应用程序。

如果成功，则返回字符串的 metaphone 键，如果失败，则返回 false。

语法

metaphone(string,length)
参数 | 描述
string | 必需。规定要检查的字符串。
length | 可选。规定 metaphone 键的最大长度。

提示和注释

注释：metaphone() 为发音相似的单词创建相同的键。

注释：所生成的 metaphone 键长度可变。

提示：metaphone() 比 soundex() 函数更精确，因为 metaphone() 了解基本的英语发音规则。

例子

例子 1

<?php
echo metaphone("world");
?>

输出：

WRLT

例子 2

在本例中，我们对两个发音相似的单词应用 metaphone() 函数：

<?php
$str = "Sun";
$str2 = "Son";

echo metaphone($str);
echo metaphone($str2);
?>

输出：

SN
SN

PHP String 函数

PHP 参考手册
PHP 测验


PHP microtime() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP microtime() 函数

PHP Date / Time 函数

定义和用法

microtime() 函数返回当前 Unix 时间戳和微秒数。

语法

microtime(get_as_float)
参数 | 描述
get_as_float | 如果给出了 get_as_float 参数并且其值等价于 TRUE，该函数将返回一个浮点数。

说明

本函数仅在支持 gettimeofday() 系统调用的操作系统下可用。

如果调用时不带可选参数，本函数以 "msec sec" 的格式返回一个字符串，其中 sec 是自 Unix 纪元（0:00:00 January 1, 1970 GMT）起到现在的秒数，msec 是微秒部分。字符串的两部分都是以秒为单位返回的。

例子

<?php
echo(microtime());
?>

输出：

0.25139300 1138197510

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP min() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP min() 函数

PHP Math 函数

定义和用法

min() 返回最小值。

语法

min(x,y)
参数 | 描述
x | 必需。一个数。
y | 必需。一个数。

说明

min() 返回参数中数值最小的。

如果仅有一个参数且为数组，min() 返回该数组中最小的值。如果第一个参数是整数、字符串或浮点数，则至少需要两个参数而 min() 会返回这些值中最小的一个。可以比较无限多个值。

提示和注释

注释：PHP 会将非数值的 string 当成 0，但如果这个正是最小的数值则仍然会返回一个字符串。如果多个参数都求值为 0 且是最小值，min() 会返回按字母表顺序最小的字符串，如果其中没有字符串的话，则返回数值的 0。

例子

在本例中，我们将使用 min() 来返回两个指定的数中的最小值：

<?php
echo(min(5,7));
echo(min(-3,5));
echo(min(-3,-5));
echo(min(7.25,7.30));
?>

输出类似：

5
-3
-5
7.25

PHP Math 函数

PHP 参考手册
PHP 测验


PHP mkdir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mkdir() 函数

PHP Filesystem 函数

定义和用法

mkdir() 函数创建目录。

若成功，则返回 true，否则返回 false。

语法

mkdir(path,mode,recursive,context)
参数 | 描述
path | 必需。规定要创建的目录的名称。
mode | 必需。规定权限。默认是 0777。
recursive | 必需。规定是否设置递归模式。
context | 必需。规定文件句柄的环境。Context 是可修改流的行为的一套选项。

说明

mkdir() 尝试新建一个由 path 指定的目录。

默认的 mode 是 0777，意味着最大可能的访问权。

提示和注释

注释：mode 在 Windows 下被忽略。自 PHP 4.2.0 起成为可选项。

注释：对 context 的支持是 PHP 5.0.0 添加的。

注释：recursive 参数是 PHP 5.0.0 添加的。

例子

<?php
mkdir("testing");
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP mktime() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mktime() 函数

PHP Date / Time 函数

定义和用法

mktime() 函数返回一个日期的 Unix 时间戳。

参数总是表示 GMT 日期，因此 is_dst 对结果没有影响。

参数可以从右到左依次空着，空着的参数会被设为相应的当前 GMT 值。

语法

mktime(hour,minute,second,month,day,year,is_dst)
参数 | 描述
hour | 可选。规定小时。
minute | 可选。规定分钟。
second | 可选。规定秒。
month | 可选。规定用数字表示的月。
day | 可选。规定天。
year | 可选。规定年。在某些系统上，合法值介于 1901 - 2038 之间。不过在 PHP 5 中已经不存在这个限制了。
is_dst | 可选。如果时间在日光节约时间(DST)期间，则设置为1，否则设置为0，若未知，则设置为-1。 自 5.1.0 起，is_dst 参数被废弃。因此应该使用新的时区处理特性。

提示和注释

注释：在 PHP 5.1 之前，如果该函数的参数非法，则会返回 false。

例子

mktime() 函数对于日期运算和验证非常有用。它可以自动校正越界的输入：

<?php
echo(date("M-d-Y",mktime(0,0,0,12,36,2001)));
echo(date("M-d-Y",mktime(0,0,0,14,1,2001)));
echo(date("M-d-Y",mktime(0,0,0,1,1,2001)));
echo(date("M-d-Y",mktime(0,0,0,1,1,99)));
?>

输出：

Jan-05-2002
Feb-01-2002
Jan-01-2001
Jan-01-1999

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP money_format() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP money_format() 函数

PHP String 函数

定义和用法

money_format() 函数把字符串格式化为货币字符串。

语法

money_format(string,number)
参数 | 描述
string | 必需。规定要格式化的字符串。
number | 可选。被插入格式化字符串中 % 符号位置的数字。

提示和注释

注释：money_format() 函数无法在 windows 平台上工作。

例子

例子 1

国际 en_US 格式：

<?php
$number = 1234.56;
setlocale(LC_MONETARY, "en_US");
echo money_format("The price is %i", $number);
?>

输出：

The price is USD 1,234.56

例子 2

负数，带有 () 指示负数的 US 国际格式，右侧精度为 2，"*" 为填充字符：

<?php
$number = -1234.5672;

echo money_format("%=*(#10.2n", $number);
?>

输出：

($********1,234.57)

PHP String 函数

PHP 参考手册
PHP 测验


PHP move_uploaded_file() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP move_uploaded_file() 函数

PHP Filesystem 函数

定义和用法

move_uploaded_file() 函数将上传的文件移动到新位置。

若成功，则返回 true，否则返回 false。

语法

move_uploaded_file(file,newloc)
参数 | 描述
file | 必需。规定要移动的文件。
newloc | 必需。规定文件的新位置。

说明

本函数检查并确保由 file 指定的文件是合法的上传文件（即通过 PHP 的 HTTP POST 上传机制所上传的）。如果文件合法，则将其移动为由 newloc 指定的文件。

如果 file 不是合法的上传文件，不会出现任何操作，move_uploaded_file() 将返回 false。

如果 file 是合法的上传文件，但出于某些原因无法移动，不会出现任何操作，move_uploaded_file() 将返回 false，此外还会发出一条警告。

这种检查显得格外重要，如果上传的文件有可能会造成对用户或本系统的其他用户显示其内容的话。

提示和注释

注释：本函数仅用于通过 HTTP POST 上传的文件。

注意：如果目标文件已经存在，将会被覆盖。

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP mt_getrandmax() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mt_getrandmax() 函数

PHP Math 函数

定义和用法

mt_getrandmax() 显示随机数的最大可能值。

语法

mt_getrandmax()

说明

返回调用 mt_rand() 所能返回的最大的随机数。

例子

<?php
echo mt_getrandmax();
?>

输出类似：

3147483649

PHP Math 函数

PHP 参考手册
PHP 测验


PHP mt_rand() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mt_rand() 函数

PHP Math 函数

定义和用法

mt_rand() 使用 Mersenne Twister 算法返回随机整数。

语法

mt_rand(min,max)

说明

如果没有提供可选参数 min 和 max，mt_rand() 返回 0 到 RAND_MAX 之间的伪随机数。例如想要 5 到 15（包括 5 和 15）之间的随机数，用 mt_rand(5, 15)。

很多老的 libc 的随机数发生器具有一些不确定和未知的特性而且很慢。PHP 的 rand() 函数默认使用 libc 随机数发生器。mt_rand() 函数是非正式用来替换它的。该函数用了 Mersenne Twister 中已知的特性作为随机数发生器，它可以产生随机数值的平均速度比 libc 提供的 rand() 快四倍。

提示和注释

注释：自 PHP 4.2.0 起，不再需要用 srand() 或 mt_srand() 函数给随机数发生器播种，现在已自动完成。

注释：在 3.0.7 之前的版本中，max 的含义是 range 。要在这些版本中得到和上例相同 5 到 15 的随机数，简短的例子是 mt_rand (5, 11)。

例子

在本例中，我们会返回一些随机数：

<?php
echo(mt_rand());
echo(mt_rand());
echo(mt_rand(10,100));
?>

输出类似：

3150906288
513289678
35

PHP Math 函数

PHP 参考手册
PHP 测验


PHP mt_srand() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mt_srand() 函数

PHP Math 函数

定义和用法

mt_srand() 播种 Mersenne Twister 随机数生成器。

语法

mt_srand(seed)
参数 | 描述
seed | 必需。用 seed 来给随机数发生器播种。

说明

从 PHP 4.2.0 版开始，seed 参数变为可选项，当该项为空时，会被设为随时数。

提示和注释

注释：自 PHP 4.2.0 起，不再需要用 srand() 或 mt_srand() 函数给随机数发生器播种，现已自动完成。

例子

在本例中，我们将播种随机数生成器：

<?php
mt_srand(mktime());
echo(mt_rand());
?>

输出类似：

1132656473

PHP Math 函数

PHP 参考手册
PHP 测验


PHP mysql_affected_rows() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_affected_rows() 函数

PHP MySQL 函数

定义和用法

mysql_affected_rows() 函数返回前一次 MySQL 操作所影响的记录行数。

语法

mysql_affected_rows(link_identifier)
参数 | 描述
link_identifier | 必需。MySQL 的连接标识符。如果没有指定，默认使用最后被 mysql_connect() 打开的连接。如果没有找到该连接，函数会尝试调用 mysql_connect() 建立连接并使用它。如果发生意外，没有找到连接或无法建立连接，系统发出 E_WARNING 级别的警告信息。

说明

取得最近一次与 link_identifier 关联的 INSERT，UPDATE 或 DELETE 查询所影响的记录行数。

返回值

执行成功，则返回受影响的行的数目，如果最近一次查询失败的话，函数返回 -1。

如果最近一次操作是没有任何条件（WHERE）的 DELETE 查询，在表中所有的记录都会被删除，但本函数返回值在 4.1.2 版之前都为 0。

当使用 UPDATE 查询，MySQL 不会将原值与新值一样的列更新。这样使得 mysql_affected_rows() 函数返回值不一定就是查询条件所符合的记录数，只有真正被修改的记录数才会被返回。

REPLACE 语句首先删除具有相同主键的记录，然后插入一个新记录。该函数返回的是被删除的记录数加上被插入的记录数。

例子

<?php
$con = mysql_connect("localhost","mysql_user","mysql_pwd");
if (!$con)
  {
  die("Could not connect: " . mysql_error());
  }

mysql_select_db("mydb");
mysql_query("DELETE FROM mytable WHERE id < 5");
$rc = mysql_affected_rows();
echo "Records deleted: " . $rc;

mysql_close($con);
?>

输出：

Records deleted: 4

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_client_encoding() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_client_encoding() 函数

PHP MySQL 函数

定义和用法

mysql_client_encoding() 函数返回当前连接的字符集的名称。

语法

mysql_client_encoding(link_identifier)
参数 | 描述
link_identifier | 必需。MySQL 的连接标识符。如果没有指定，默认使用最后被 mysql_connect() 打开的连接。如果没有找到该连接，函数会尝试调用 mysql_connect() 建立连接并使用它。如果发生意外，没有找到连接或无法建立连接，系统发出 E_WARNING 级别的警告信息。

说明

从 MySQL 中取得 character_set 变量的值。

返回值

返回当前连接的默认字符集名称。

例子

<?php
$con = mysql_connect("localhost","mysql_user","mysql_pwd");
if (!$con)
  {
  die("Could not connect: " . mysql_error());
  }

$charset = mysql_client_encoding($con);
echo "The current character set is: $charset";

mysql_close($con);
?>

输出：

The current character set is: latin1

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_close() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_close() 函数

PHP MySQL 函数

定义和用法

mysql_close() 函数关闭非持久的 MySQL 连接。

语法

mysql_close(link_identifier)
参数 | 描述
link_identifier | 必需。MySQL 的连接标识符。如果没有指定，默认使用最后被 mysql_connect() 打开的连接。如果没有找到该连接，函数会尝试调用 mysql_connect() 建立连接并使用它。如果发生意外，没有找到连接或无法建立连接，系统发出 E_WARNING 级别的警告信息。

说明

本函数关闭指定的连接标识所关联的到 MySQL 服务器的非持久连接。如果没有指定 link_identifier，则关闭上一个打开的连接。

返回值

如果成功则返回 true，失败则返回 false。

提示和注释

提示：通常不需要使用 mysql_close()，因为已打开的非持久连接会在脚本执行完毕后自动关闭。

注释：mysql_close() 不会关闭由 mysql_pconnect() 建立的持久连接。

例子

<?php
$con = mysql_connect("localhost","mysql_user","mysql_pwd");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

// 一些代码...

mysql_close($con);
?>

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_connect() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_connect() 函数

PHP MySQL 函数

定义和用法

mysql_connect() 函数打开非持久的 MySQL 连接。

语法

mysql_connect(server,user,pwd,newlink,clientflag)
参数 | 描述
server

可选。规定要连接的服务器。

可以包括端口号，例如 "hostname:port"，或者到本地套接字的路径，例如对于 localhost 的 ":/path/to/socket"。

如果 PHP 指令 mysql.default_host 未定义（默认情况），则默认值是 'localhost:3306'。
user | 可选。用户名。默认值是服务器进程所有者的用户名。
pwd | 可选。密码。默认值是空密码。
newlink | 可选。如果用同样的参数第二次调用 mysql_connect()，将不会建立新连接，而将返回已经打开的连接标识。参数 new_link 改变此行为并使 mysql_connect() 总是打开新的连接，甚至当 mysql_connect() 曾在前面被用同样的参数调用过。
clientflag

可选。client_flags 参数可以是以下常量的组合：

  • MYSQL_CLIENT_SSL - 使用 SSL 加密
  • MYSQL_CLIENT_COMPRESS - 使用压缩协议
  • MYSQL_CLIENT_IGNORE_SPACE - 允许函数名后的间隔
  • MYSQL_CLIENT_INTERACTIVE - 允许关闭连接之前的交互超时非活动时间

返回值

如果成功，则返回一个 MySQL 连接标识，失败则返回 FALSE。

提示和注释

注释：脚本一结束，到服务器的连接就被关闭，除非之前已经明确调用 mysql_close() 关闭了。

提示：要创建一个持久连接，请使用 mysql_pconnect() 函数。

例子

<?php
$con = mysql_connect("localhost","mysql_user","mysql_pwd");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

// 一些代码...

mysql_close($con);
?>

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_data_seek() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_data_seek() 函数

PHP MySQL 函数

定义和用法

mysql_data_seek() 函数移动内部结果的指针。

语法

mysql_data_seek(data,row)
参数 | 描述
data | 必需。返回类型为 resource 的结果集。该结果集从 mysql_query() 的调用中得到。
row | 必需。想要设定的新的结果集指针的行数。0 指示第一个记录。

说明

mysql_data_seek() 将 data 参数指定的 MySQL 结果内部的行指针移动到指定的行号。

接着调用 mysql_fetch_row() 将返回那一行。

row 从 0 开始。row 的取值范围应该从 0 到 mysql_num_rows - 1。

但是如果结果集为空（mysql_num_rows() == 0），要将指针移动到 0 会失败并发出 E_WARNING 级的错误，mysql_data_seek() 将返回 false。

返回值

如果成功则返回 true，失败则返回 false。

提示和注释

注释：mysql_data_seek() 只能和 mysql_query() 一起使用，而不能用于 mysql_unbuffered_query()。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "SELECT * from Person";
$result = mysql_query($sql,$con);
print_r(mysql_fetch_row($result));

mysql_data_seek($result,3);
print_r(mysql_fetch_row($result));

mysql_close($con);
?>

输出：

Array
(
[0] => Adams
[1] => John
[2] => London
)

Array
(
[0] => Carter
[1] => Thomas
[2] => Beijing
)

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_db_name() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_db_name() 函数

PHP MySQL 函数

定义和用法

mysql_db_name() 函数取得 mysql_list_dbs() 调用所返回的数据库名。

语法

mysql_db_name(list,row,field)
参数 | 描述
list | 必需。mysql_list_dbs() 调用所返回的结果指针。
row | 必需。规定结果集中的行号。以 0 开始。
field | 可选。规定字段名。

说明

如果成功，则返回数据库名，失败返回 false。如果返回了 false，用 mysql_error() 来判断错误的种类。

例子

<?php
$con = mysql_connect("localhost", "peter", "abc123");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_list = mysql_list_dbs($con);

$i = 0;
$db_count = mysql_num_rows($db_list);
while ($i < $db_count)
  {
  echo mysql_db_name($db_list, $i) . "<br />";
  $i++;
  }

mysql_close($con);
?>

输出类似：

mysql
customers
movies

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP MySQL Delete From

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP MySQL Delete From

  • Previous Page
  • Next Page

DELETE FROM 语句用于从数据库表中删除行。

删除数据库中的数据

DELETE FROM 语句用于从数据库表中删除记录。

语法

DELETE FROM table_name
WHERE column_name = some_value

注释：SQL 对大小写不敏感。DELETE FROM 与 delete from 等效。

为了让 PHP 执行上面的语句，我们必须使用 mysql_query( 函数。该函数用于向 SQL 连接发送查询和命令。

例子

稍早时，我们在本教程中创建了一个名为 "Person" 的表。它看起来类似这样：

FirstName | LastName | Age
Peter | Griffin | 35
Glenn | Quagmire | 33

下面的例子删除 "Person" 表中所有 LastName='Griffin' 的记录：

<?php
$con = mysql_connect("localhost","peter","abc123");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

mysql_select_db("my_db", $con);

mysql_query("DELETE FROM Person WHERE LastName='Griffin'");

mysql_close($con);
?>

在这次删除之后，表是这样的：

FirstName | LastName | Age
Peter | Griffin | 35
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP mysql_errno() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_errno() 函数

PHP MySQL 函数

定义和用法

mysql_errno() 函数返回上一个 MySQL 操作中的错误信息的数字编码。

返回上一个 MySQL 函数的错误号码，如果没有出错则返回 0（零）。

语法

mysql_errno(connection)
参数 | 描述
connection | 可选。规定 SQL 连接标识符。如果未规定，则使用上一个打开的连接。

例子

在本例中，我们将尝试使用错误的用户名和密码来登录一个 MySQL 服务器：

<?php
$con = mysql_connect("localhost","wrong_user","wrong_pwd");
if (!$con)
  {
  die('Could not connect: ' . mysql_errno());
  }
mysql_close($con);
?>

输出类似：

Could not connect: 1045

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_error() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_error() 函数

PHP MySQL 函数

定义和用法

mysql_error() 函数返回上一个 MySQL 操作产生的文本错误信息。

本函数返回上一个 MySQL 函数的错误文本，如果没有出错则返回 ''（空字符串）。

语法

mysql_error(connection)
参数 | 描述
connection | 可选。规定 SQL 连接标识符。如果未规定，则使用上一个打开的连接。

例子

在本例中，我们将尝试使用错误的用户名和密码来登录一个 MySQL 服务器：

<?php
$con = mysql_connect("localhost","wrong_user","wrong_pwd");
if (!$con)
  {
  die(mysql_error());
  }
mysql_close($con);
?>

输出类似：

Access denied for user 'wrong_user'@'localhost'
(using password: YES)

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_fetch_array() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_fetch_array() 函数

PHP MySQL 函数

定义和用法

mysql_fetch_array() 函数从结果集中取得一行作为关联数组，或数字数组，或二者兼有

返回根据从结果集取得的行生成的数组，如果没有更多行则返回 false。

语法

mysql_fetch_array(data,array_type)
参数 | 描述
data | 可选。规定规定要使用的数据指针。该数据指针是 mysql_query() 函数产生的结果。
array_type

可选。规定返回哪种结果。可能的值：

  • MYSQL_ASSOC - 关联数组
  • MYSQL_NUM - 数字数组
  • MYSQL_BOTH - 默认。同时产生关联和数字数组

提示和注释

注释：mysql_fetch_array() 是 mysql_fetch_row() 的扩展版本。除了将数据以数字索引方式储存在数组中之外，还可以将数据作为关联索引储存，用字段名作为键名。

提示：有很重要的一点必须指出，用 mysql_fetch_array() 并不明显比用 mysql_fetch_row() 慢，而且还明显提供了更多的值。

注释：本函数返回的字段名是区分大小写的。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);
$sql = "SELECT * from Person WHERE Lastname='Adams'";
$result = mysql_query($sql,$con);
print_r(mysql_fetch_array($result));

mysql_close($con);
?>

输出类似：

Array
(
[0] => Adams
[LastName] => Adams
[1] => John
[FirstName] => John
[2] => London
[City] => London
)

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_fetch_assoc() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_fetch_assoc() 函数

PHP MySQL 函数

定义和用法

mysql_fetch_assoc() 函数从结果集中取得一行作为关联数组。

返回根据从结果集取得的行生成的关联数组，如果没有更多行，则返回 false。

语法

mysql_fetch_assoc(data)
参数 | 描述
data | 必需。要使用的数据指针。该数据指针是从 mysql_query() 返回的结果。

提示和注释

注释：mysql_fetch_assoc() 和用 mysql_fetch_array() 加上第二个可选参数 MYSQL_ASSOC 完全相同。它仅仅返回关联数组。这也是 mysql_fetch_array() 初始的工作方式。

提示：如果在关联索引之外还需要数字索引，用 mysql_fetch_array()。

注释：本函数返回的字段名是区分大小写的。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);
$sql = "SELECT * from Person WHERE Lastname='Adams'";
$result = mysql_query($sql,$con);
print_r(mysql_fetch_assoc($result));

mysql_close($con);
?>

输出：

Array
(
[LastName] => Adams
[FirstName] => John
[City] => London
)

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_fetch_field() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_fetch_field() 函数

PHP MySQL 函数

定义和用法

mysql_fetch_field() 函数从结果集中取得列信息并作为对象返回。

mysql_fetch_field() 可以用来从查询结果中取得字段的信息。如果没有指定字段偏移量，则提取下一个尚未被 mysql_fetch_field() 取得的字段。

该函数返回一个包含字段信息的对象。

被返回的对象的属性为：

  • name - 列名
  • table - 该列所在的表名
  • max_length - 该列最大长度
  • not_null - 1，如果该列不能为 NULL
  • primary_key - 1，如果该列是 primary key
  • unique_key - 1，如果该列是 unique key
  • multiple_key - 1，如果该列是 non-unique key
  • numeric - 1，如果该列是 numeric
  • blob - 1，如果该列是 BLOB
  • type - 该列的类型
  • unsigned - 1，如果该列是无符号数
  • zerofill - 1，如果该列是 zero-filled

语法

mysql_fetch_field(data,field_offset)
参数 | 描述
data | 必需。要使用的数据指针。该数据指针是从 mysql_query() 返回的结果。
field_offset | 必需。规定从哪个字段开始。0 指示第一个字段。如果未设置，则取回下一个字段。

提示和注释

注释：本函数返回的字段名是区分大小写的。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "SELECT * from Person";
$result = mysql_query($sql,$con);

while ($property = mysql_fetch_field($result))
  {
  echo "Field name: " . $property->name . "<br />";
  echo "Table name: " . $property->table . "<br />";
  echo "Default value: " . $property->def . "<br />";
  echo "Max length: " . $property->max_length . "<br />";
  echo "Not NULL: " . $property->not_null . "<br />";
  echo "Primary Key: " . $property->primary_key . "<br />";
  echo "Unique Key: " . $property->unique_key . "<br />";
  echo "Mutliple Key: " . $property->multiple_key . "<br />";
  echo "Numeric Field: " . $property->numeric . "<br />";
  echo "BLOB: " . $property->blob . "<br />";
  echo "Field Type: " . $property->type . "<br />";
  echo "Unsigned: " . $property->unsigned . "<br />";
  echo "Zero-filled: " . $property->zerofill . "<br /><br />";
  }

mysql_close($con);
?>

输出：

Field name: LastName
Table name: Person
Default value:
Max length: 8
Not NULL: 0
Primary Key: 0
Unique Key: 0
Mutliple Key: 0
Numeric Field: 0
BLOB: 0
Field Type: string
Unsigned: 0
Zero-filled: 0

Field name: FirstName
Table name: Person
Default value:
Max length: 7
Not NULL: 0
Primary Key: 0
Unique Key: 0
Mutliple Key: 0
Numeric Field: 0
BLOB: 0
Field Type: string
Unsigned: 0
Zero-filled: 0

Field name: City
Table name: Person
Default value:
Max length: 9
Not NULL: 0
Primary Key: 0
Unique Key: 0
Mutliple Key: 0
Numeric Field: 0
BLOB: 0
Field Type: string
Unsigned: 0
Zero-filled: 0

Field name: Age
Table name: Person
Default value:
Max length: 2
Not NULL: 0
Primary Key: 0
Unique Key: 0
Mutliple Key: 0
Numeric Field: 1
BLOB: 0
Field Type: int
Unsigned: 0
Zero-filled: 0

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_fetch_lengths() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_fetch_lengths() 函数

PHP MySQL 函数

定义和用法

mysql_fetch_lengths() 函数取得一行中每个字段的内容的长度。

行是由这些函数返回的：mysql_fetch_array()、mysql_fetch_assoc()、mysql_fetch_object() 或 mysql_fetch_row()。

若成功，则该函数返回一个数字数组，若出错或没有其他的行，则返回 false。

语法

mysql_fetch_lengths(data)
参数 | 描述
data | 必需。要使用的数据指针。该数据指针是从 mysql_query() 返回的结果。

例子

<?php
$con = mysql_connect("localhost", "peter", "abc123");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);
$sql = "SELECT * from Person WHERE Lastname='Refsnes'";
$result = mysql_query($sql,$con);
print_r(mysql_fetch_row($result));
print_r(mysql_fetch_lengths($result));

mysql_close($con);
?>

输出：

Array
(
[0] => Adams
[1] => John
[2] => London
)

Array
(
[0] => 5
[1] => 4
[2] => 6
)

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_fetch_object() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_fetch_object() 函数

PHP MySQL 函数

定义和用法

mysql_fetch_object() 函数从结果集（记录集）中取得一行作为对象。

若成功的话，本函数从 mysql_query() 获得一行，并返回一个对象。如果失败或没有更多的行，则返回 false。

语法

mysql_fetch_object(data)
参数 | 描述
data | 必需。要使用的数据指针。该数据指针是从 mysql_query() 返回的结果。

提示和注释

注释：每个随后对 mysql_fetch_object() 的调用都会返回记录集中的下一行。

注释：mysql_fetch_object() 与 mysql_fetch_array() 类似，只有一点区别 - 返回的是对象而不是数组。间接地，也意味着只能通过字段名来访问数组，而不是偏移量。

例子

<?php
$con = mysql_connect("localhost", "peter", "abc123");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);
$sql = "SELECT * from Person";
$result = mysql_query($sql,$con);

while ($row = mysql_fetch_object($result))
  {
  echo $row->FirstName . "<br />";
  }

mysql_close($con);
?>

输出：

John
George
Thomas

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_fetch_row() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_fetch_row() 函数

PHP MySQL 函数

定义和用法

mysql_fetch_row() 函数从结果集中取得一行作为数字数组。

语法

mysql_fetch_row(data)
参数 | 描述
data | 必需。要使用的数据指针。该数据指针是从 mysql_query() 返回的结果。

说明

mysql_fetch_row() 从和结果标识 data 关联的结果集中取得一行数据并作为数组返回。每个结果的列储存在一个数组的单元中，偏移量从 0 开始。

依次调用 mysql_fetch_row() 将返回结果集中的下一行，如果没有更多行则返回 FALSE。

返回值

返回根据所取得的行生成的数组，如果没有更多行则返回 false。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);
$sql = "SELECT * from Person WHERE Lastname='Adams'";
$result = mysql_query($sql,$con);
print_r(mysql_fetch_row($result));

mysql_close($con);
?>

输出：

Array
(
[0] => Adams
[1] => John
[2] => London
)

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_field_flags() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_field_flags() 函数

PHP MySQL 函数

定义和用法

mysql_field_flags() 函数从结果中取得和指定字段关联的标志。

本函数返回指定字段的字段标志。

如果 MySQL 版本足够新，则会支持以下的标志：

  • auto_intcrement
  • binary
  • blob
  • enum
  • multiple_key
  • not_null
  • primary_key
  • timestamp
  • unique_key
  • unsigned
  • zerofill

语法

mysql_field_flags(data,field_offset)
参数 | 描述
data | 必需。要使用的数据指针。该数据指针是从 mysql_query() 返回的结果。
field_offset | 必需。指示从哪个字段开始返回。0 指示第一个字段。

提示和注释

提示：每个标志都用一个单词表示，之间用一个空格分开，因此，您可以通过 explode() 函数把返回的字符串打散到一个数组中。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "SELECT * from Person";
$result = mysql_query($sql,$con);

$flags = mysql_field_flags($result, 0);
echo $flags;

mysql_close($con);
?>

输出：

not_null primary_key auto_increment

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_field_len() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_field_len() 函数

PHP MySQL 函数

定义和用法

mysql_field_len() 函数返回指定字段的长度。

如果成功，则返回字段的长度，如果失败，则返回 false。

语法

mysql_field_len(data,field_offset)
参数 | 描述
data | 必需。要使用的数据指针。该数据指针是从 mysql_query() 返回的结果。
field_offset | 必需。指示从哪个字段开始返回。0 指示第一个字段。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "SELECT * from Person";
$result = mysql_query($sql,$con);

$length = mysql_field_len($result, 0);

echo $length;

mysql_close($con);
?>

输出：

20

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_field_name() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_field_name() 函数

PHP MySQL 函数

定义和用法

mysql_field_name() 函数取得结果中指定字段的字段名。

如果成功，则返回字段的名称，如果失败，则返回 false。

语法

mysql_field_name(data,field_offset)
参数 | 描述
data | 必需。要使用的数据指针。该数据指针是从 mysql_query() 返回的结果。
field_offset | 必需。指示从哪个字段开始返回。0 指示第一个字段。

提示和注释

注释：本函数返回的字段名是区分大小写的。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "SELECT * from Person";
$result = mysql_query($sql,$con);

$name = mysql_field_name($result, 0);

echo $name;

mysql_close($con);
?>

输出：

LastName

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_field_seek() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_field_seek() 函数

PHP MySQL 函数

定义和用法

mysql_field_seek() 函数将结果集中的指针设定为指定的字段偏移量。

如果成功，则返回 true，如果失败，则返回 false。

语法

mysql_field_seek(data,field_offset)
参数 | 描述
data | 必需。要使用的数据指针。该数据指针是从 mysql_query() 返回的结果。
field_offset | 必需。指示从哪个字段开始返回。0 指示第一个字段。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "SELECT * from Person";
$result = mysql_query($sql,$con);

// 跳到第四个字段
mysql_field_seek($result,3);
print_r(mysql_fetch_field($result));

mysql_close($con);
?>

输出：

stdClass Object
(
[name] => Age
[table] => Person
[def] =>
[max_length] => 2
[not_null] => 0
[primary_key] => 0
[multiple_key] => 0
[unique_key] => 0
[numeric] => 1
[blob] => 0
[type] => int
[unsigned] => 0
[zerofill] => 0
)

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_field_table() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_field_table() 函数

PHP MySQL 函数

定义和用法

mysql_field_table() 函数返回指定字段所在的表名。

如果成功，则返回指定字段的表名，如果失败，则返回 false。

语法

mysql_field_table(data,field_offset)
参数 | 描述
data | 必需。要使用的数据指针。该数据指针是从 mysql_query() 返回的结果。
field_offset | 必需。指示从哪个字段开始返回。0 指示第一个字段。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "SELECT * from Person";
$result = mysql_query($sql,$con);

$table = mysql_field_table($result, 0);

echo $table;

mysql_close($con);
?>

输出：

Person

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_field_type() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_field_type() 函数

PHP MySQL 函数

定义和用法

mysql_field_type() 函数返回结果集中指定字段的类型。

如果成功，则返回指定字段的类型，如果失败，则返回 false。

语法

mysql_field_type(data,field_offset)
参数 | 描述
data | 必需。要使用的数据指针。该数据指针是从 mysql_query() 返回的结果。
field_offset | 必需。指示从哪个字段开始返回。0 指示第一个字段。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "SELECT * from Person";
$result = mysql_query($sql,$con);

$type = mysql_field_type($result, 0);

echo $type;

mysql_close($con);
?>

输出：

string

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_free_result() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_free_result() 函数

PHP MySQL 函数

定义和用法

mysql_free_result() 函数释放结果内存。

如果成功，则返回 true，如果失败，则返回 false。

语法

mysql_free_result(data)
参数 | 描述
data | 必需。要释放的结果标识符。该结果标识符是从 mysql_query() 返回的结果。

提示和注释

注释：mysql_free_result() 仅需要在考虑到返回很大的结果集时会占用多少内存时调用。在脚本结束后所有关联的内存都会被自动释放。

例子

<?php
$con = mysql_connect("localhost", "peter", "abc123");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "SELECT * from Person";
$result = mysql_query($sql,$con);
print_r(mysql_fetch_row($result));

// 释放内存
mysql_free_result($result);

$sql = "SELECT * from Customers";
$result = mysql_query($sql,$con);
print_r(mysql_fetch_row($result));

mysql_close($con);
?>

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_get_client_info() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_get_client_info() 函数

PHP MySQL 函数

定义和用法

mysql_get_client_info() 函数返回 MySQL 客户端信息。

如果成功，则返回 MySQL 客户端的版本号，如果失败，则返回 false。

语法

mysql_get_client_info()

例子

<?php
echo "MySQL client info: " . mysql_get_client_info();
?>

输出：

MySQL client info: 5.0.18

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_get_host_info() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_get_host_info() 函数

PHP MySQL 函数

定义和用法

mysql_get_host_info() 函数返回 MySQL 主机的信息。

如果成功，则返回当前正在使用的 MySQL 连接的类型，如果失败，则返回 false。

语法

mysql_get_host_info(connection)
参数 | 描述
connection | 可选。规定 MySQL 连接。如果未规定，则使用上一个连接。

说明

mysql_get_host_info() 返回一个字符串，说明了连接 connection 所使用的连接方式，包括服务器的主机名。如果省略 connection，则使用上一个打开的连接。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
echo "MySQL host info: " . mysql_get_host_info($con);
?>

输出：

MySQL host info: localhost via TCP/IP

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_get_proto_info() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_get_proto_info() 函数

PHP MySQL 函数

定义和用法

mysql_get_proto_info() 函数返回 MySQL 协议的信息。

如果成功，则返回 MySQL 协议的版本，如果失败，则返回 false。

语法

mysql_get_proto_info(connection)
参数 | 描述
connection | 可选。规定 MySQL 连接。如果未规定，则使用上一个连接。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
echo "MySQL protocol info: " . mysql_get_proto_info($con);
?>

输出：

MySQL protocol info: 10

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_get_server_info() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_get_server_info() 函数

PHP MySQL 函数

定义和用法

mysql_get_server_info() 函数返回 MySQL 服务器的信息。

如果成功，则返回 MySQL 服务器的版本号，如果失败，则返回 false。

语法

mysql_get_server_info(connection)
参数 | 描述
connection | 可选。规定 MySQL 连接。如果未规定，则使用上一个连接。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
echo "MySQL server info: " . mysql_get_server_info($con);
?>

输出：

MySQL server info: 5.0.18-nt

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_info() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_info() 函数

PHP MySQL 函数

定义和用法

mysql_info() 函数返回最近一条查询的信息。

如果成功，则返回有关该语句的信息，如果失败，则返回 false。

语法

mysql_info(connection)
参数 | 描述
connection | 可选。规定 MySQL 连接。如果未规定，则使用上一个连接。

说明

mysql_info() 返回通过给定的 connection 所进行的最新一条查询的详细信息。如果没有指定 connection，则假定为上一个打开的连接。

mysql_info() 对以下列出的所有语句返回一个字符串：

INSERT INTO ... SELECT ...

INSERT INTO ... VALUES (...),(...),(...)...

LOAD DATA INFILE ...

ALTER TABLE

UPDATE

对于其它任何语句返回 false。字符串的格式取决于给出的语句。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);
$sql = "INSERT INTO person VALUES ('John','Doe','Utah','17')";
$result = mysql_query($sql,$con);

$info = mysql_info($con);
echo $info;

mysql_close($con);
?>

输出类似：

String format: Records: 15 Duplicates: 0 Warnings: 0

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_insert_id() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_insert_id() 函数

PHP MySQL 函数

定义和用法

mysql_insert_id() 函数返回上一步 INSERT 操作产生的 ID。

如果上一查询没有产生 AUTO_INCREMENT 的 ID，则 mysql_insert_id() 返回 0。

语法

mysql_insert_id(connection)
参数 | 描述
connection | 可选。规定 MySQL 连接。如果未规定，则使用上一个连接。

说明

mysql_insert_id() 返回给定的 connection 中上一步 INSERT 查询中产生的 AUTO_INCREMENT 的 ID 号。如果没有指定 connection ，则使用上一个打开的连接。

提示和注释

注释：如果需要保存该值以后使用，要确保在产生了值的查询之后立即调用 mysql_insert_id()。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "INSERT INTO person VALUES ('Carter','Thomas','Beijing')";
$result = mysql_query($sql,$con);
echo "ID of last inserted record is: " . mysql_insert_id();

mysql_close($con);
?>

输出类似：

ID of last inserted record is: 5

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP MySQL Insert Into

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP MySQL Insert Into

  • Previous Page
  • Next Page

INSERT INTO 语句用于向数据库表中插入新纪录。

向数据库表插入数据

INSERT INTO 语句用于向数据库表添加新纪录。

语法

INSERT INTO table_name
VALUES (value1, value2,....)

您还可以规定希望在其中插入数据的列：

INSERT INTO table_name (column1, column2,...)
VALUES (value1, value2,....)

注释：SQL 语句对大小写不敏感。INSERT INTO 与 insert into 相同。

为了让 PHP 执行该语句，我们必须使用 mysql_query() 函数。该函数用于向 MySQL 连接发送查询或命令。

例子

在前面的章节，我们创建了一个名为 "Person" 的表，有三个列："Firstname", "Lastname" 以及 "Age"。我们将在本例中使用同样的表。下面的例子向 "Person" 表添加了两个新纪录：

<?php
$con = mysql_connect("localhost","peter","abc123");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

mysql_select_db("my_db", $con);

mysql_query("INSERT INTO person (FirstName, LastName, Age)
VALUES ('Peter', 'Griffin', '35')");

mysql_query("INSERT INTO person (FirstName, LastName, Age)
VALUES ('Glenn', 'Quagmire', '33')");

mysql_close($con);
?>

把来自表单的数据插入数据库

现在，我们创建一个 HTML 表单，这个表单可把新纪录插入 "Person" 表。

这是这个 HTML 表单：

<html>
<body>

<form action="insert.php" method="post">
Firstname: <input type="text" name="firstname" />
Lastname: <input type="text" name="lastname" />
Age: <input type="text" name="age" />
<input type="submit" />
</form>

</body>
</html>

当用户点击上例中 HTML 表单中的提交按钮时，表单数据被发送到 "insert.php"。"insert.php" 文件连接数据库，并通过 $_POST 变量从表单取回值。然后，mysql_query() 函数执行 INSERT INTO 语句，一条新的记录会添加到数据库表中。

下面是 "insert.php" 页面的代码：

<?php
$con = mysql_connect("localhost","peter","abc123");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

mysql_select_db("my_db", $con);

$sql="INSERT INTO person (FirstName, LastName, Age)
VALUES
('$_POST[firstname]','$_POST[lastname]','$_POST[age]')";

if (!mysql_query($sql,$con))
  {
  die('Error: ' . mysql_error());
  }
echo "1 record added";

mysql_close($con)
?>
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP mysql_list_dbs() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_list_dbs() 函数

PHP MySQL 函数

定义和用法

mysql_list_dbs() 函数列出 MySQL 服务器中所有的数据库。

语法

mysql_list_dbs(connection)
参数 | 描述
connection | 可选。规定 SQL 连接标识符。如果未规定，则使用上一个打开的连接。

说明

mysql_list_dbs() 将返回一个结果指针，包含了当前 MySQL 进程中所有可用的数据库。

用 mysql_tablename() 函数来遍历此结果指针，或者任何使用结果表的函数，例如 mysql_fetch_array()。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_list = mysql_list_dbs($con);

while ($db = mysql_fetch_object($db_list))
  {
  echo $db->Database . "<br />";
  }

mysql_close($con);
?>

输出类似：

mysql
test
test_db

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_list_processes() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_list_processes() 函数

PHP MySQL 函数

定义和用法

mysql_list_processes() 函数列出 MySQL 进程。

若成功，则 mysql_list_processes() 返回一个结果指针，说明了当前服务器的线程。如果失败，则返回 false。

语法

mysql_list_processes(connection)
参数 | 描述
connection | 可选。规定 MySQL 连接。如果未规定，则使用上一个连接。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$my_list = mysql_list_processes($con);
while ($row = mysql_fetch_assoc($my_list))
  {
  print_r($row);
  }

mysql_close($con);
?>

输出类似：

Array
(
[Id] => 2
[User] => hello
[Host] => localhost:1038
[db] =>
[Command] => Processlist
[Time] => 0
[State] =>
[Info] =>
)

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_num_fields() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_num_fields() 函数

PHP MySQL 函数

定义和用法

mysql_num_fields() 函数返回结果集中字段的数。

如果失败，则返回 false。

语法

mysql_num_fields(data)
参数 | 描述
data | 必需。规定规定要使用的数据指针。该数据指针是 mysql_query() 函数产生的结果。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "SELECT * FROM person";
$result = mysql_query($sql,$con);
echo mysql_num_fields($result);

mysql_close($con);
?>

输出类似：

3

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_num_rows() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_num_rows() 函数

PHP MySQL 函数

定义和用法

mysql_num_rows() 函数返回结果集中行的数目。

语法

mysql_num_rows(data)
参数 | 描述
data | 必需。结果集。该结果集从 mysql_query() 的调用中得到。

说明

mysql_num_rows() 返回结果集中行的数目。此命令仅对 SELECT 语句有效。要取得被 INSERT，UPDATE 或者 DELETE 查询所影响到的行的数目，用 mysql_affected_rows()。

提示和注释

注释：如果使用 mysql_unbuffered_query()，则直到结果集中的所有行都被提取后 mysql_num_rows() 才能返回正确的值。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db",$con);

$sql = "SELECT * FROM person";
$result = mysql_query($sql,$con);
echo mysql_num_rows($result);

mysql_close($con);
?>

输出类似：

3

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP MySQL Order By 关键词

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP MySQL Order By 关键词

  • Previous Page
  • Next Page

ORDER BY 关键词用于对记录集中的数据进行排序。

ORDER BY 关键词

ORDER BY 关键词用于对记录集中的数据进行排序。

语法

SELECT column_name(s)
FROM table_name
ORDER BY column_name

注释：SQL 对大小写不敏感。ORDER BY 与 order by 等效。

例子

下面的例子选取 "Person" 表中的存储的所有数据，并根据 "Age" 列对结果进行排序：

<?php
$con = mysql_connect("localhost","peter","abc123");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

mysql_select_db("my_db", $con);

$result = mysql_query("SELECT * FROM person ORDER BY age");

while($row = mysql_fetch_array($result))
  {
  echo $row['FirstName'];
  echo " " . $row['LastName'];
  echo " " . $row['Age'];
  echo "<br />";
  }

mysql_close($con);
?>

以上代码的输出：

Glenn Quagmire 33
Peter Griffin 35

升序或降序的排序

如果您使用 ORDER BY 关键词，记录集的排序顺序默认是升序（1 在 9 之前，"a" 在 "p" 之前）。

请使用 DESC 关键词来设定降序排序（9 在 1 之前，"p" 在 "a" 之前）：

SELECT column_name(s)
FROM table_name
ORDER BY column_name DESC

根据两列进行排序

可以根据多个列进行排序。当按照多个列进行排序时，只有第一列相同时才使用第二列：

SELECT column_name(s)
FROM table_name
ORDER BY column_name1, column_name2
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP mysql_pconnect() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_pconnect() 函数

PHP MySQL 函数

定义和用法

mysql_pconnect() 函数打开一个到 MySQL 服务器的持久连接。

mysql_pconnect() 和 mysql_connect() 非常相似，但有两个主要区别：

  1. 当连接的时候本函数将先尝试寻找一个在同一个主机上用同样的用户名和密码已经打开的（持久）连接，如果找到，则返回此连接标识而不打开新连接。
  2. 其次，当脚本执行完毕后到 SQL 服务器的连接不会被关闭，此连接将保持打开以备以后使用（mysql_close() 不会关闭由 mysql_pconnect() 建立的连接）。

语法

mysql_pconnect(server,user,pwd,clientflag)
参数 | 描述
server

可选。规定要连接的服务器。

可以包括端口号，例如 "hostname:port"，或者到本地套接字的路径，例如对于 localhost 的 ":/path/to/socket"。

如果 PHP 指令 mysql.default_host 未定义（默认情况），则默认值是 'localhost:3306'。
user | 可选。用户名。默认值是服务器进程所有者的用户名。
pwd | 可选。密码。默认值是空密码。
clientflag

可选。client_flags 参数可以是以下常量的组合：

  • MYSQL_CLIENT_SSL - 使用 SSL 加密
  • MYSQL_CLIENT_COMPRESS - 使用压缩协议
  • MYSQL_CLIENT_IGNORE_SPACE - 允许函数名后的间隔
  • MYSQL_CLIENT_INTERACTIVE - 允许关闭连接之前的交互超时非活动时间

返回值

如果成功，则返回一个 MySQL 持久连接标识符，出错则返回 FALSE。

提示和注释

注释：可选参数 clientflag 自 PHP 4.3.0 版起可用。

提示：要创建一个非持久连接，请使用 mysql_connect() 函数。

例子

<?php
$con = mysql_pconnect("localhost","mysql_user","mysql_pwd");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }
?>

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_ping() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_ping() 函数

PHP MySQL 函数

定义和用法

mysql_ping() 函数 Ping 一个服务器连接，如果没有连接则重新连接。

如果存在连接，则返回 true。如果失败，则返回 false。

语法

mysql_ping(connection)
参数 | 描述
connection | 可选。规定 MySQL 连接。如果未规定，则使用上一个连接。

提示和注释

注释：本函数可用于空闲很久的脚本来检查服务器是否关闭了连接。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
{
die('Could not connect: ' . mysql_error());
}

$db_selected = mysql_select_db("test_db", $con);
$sql = "SELECT * from Person";
$result = mysql_query($sql,$link);

mysql_ping();

// 一些代码...

mysql_close($con);
?>

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_query() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_query() 函数

PHP MySQL 函数

定义和用法

mysql_query() 函数执行一条 MySQL 查询。

语法

mysql_query(query,connection)
参数 | 描述
query | 必需。规定要发送的 SQL 查询。注释：查询字符串不应以分号结束。
connection | 可选。规定 SQL 连接标识符。如果未规定，则使用上一个打开的连接。

说明

如果没有打开的连接，本函数会尝试无参数调用 mysql_connect() 函数来建立一个连接并使用之。

返回值

mysql_query() 仅对 SELECT，SHOW，EXPLAIN 或 DESCRIBE 语句返回一个资源标识符，如果查询执行不正确则返回 FALSE。

对于其它类型的 SQL 语句，mysql_query() 在执行成功时返回 TRUE，出错时返回 FALSE。

非 FALSE 的返回值意味着查询是合法的并能够被服务器执行。这并不说明任何有关影响到的或返回的行数。很有可能一条查询执行成功了但并未影响到或并未返回任何行。

提示和注释

注释：该函数自动对记录集进行读取和缓存。如需运行非缓存查询，请使用 mysql_unbuffered_query()。

例子

例子 1

<?php
$con = mysql_connect("localhost","mysql_user","mysql_pwd");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$sql = "SELECT * FROM Person";
mysql_query($sql,$con);

// 一些代码

mysql_close($con);
?>

例子 2

通过 mysql_query() 函数创建一个新数据库：

<?php
$con = mysql_connect("localhost","mysql_user","mysql_pwd");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$sql = "CREATE DATABASE my_db";
if (mysql_query($sql,$con))
  {
  echo "Database my_db created";
  }
else
  {
  echo "Error creating database: " . mysql_error();
  }
?>

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_real_escape_string() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_real_escape_string() 函数

PHP MySQL 函数

定义和用法

mysql_real_escape_string() 函数转义 SQL 语句中使用的字符串中的特殊字符。

下列字符受影响：

  • \x00
  • \n
  • \r
  • \
  • '
  • "
  • \x1a

如果成功，则该函数返回被转义的字符串。如果失败，则返回 false。

语法

mysql_real_escape_string(string,connection)
参数 | 描述
string | 必需。规定要转义的字符串。
connection | 可选。规定 MySQL 连接。如果未规定，则使用上一个连接。

说明

本函数将 string 中的特殊字符转义，并考虑到连接的当前字符集，因此可以安全用于 mysql_query()。

提示和注释

提示：可使用本函数来预防数据库攻击。

例子

例子 1

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

// 获得用户名和密码的代码

// 转义用户名和密码，以便在 SQL 中使用
$user = mysql_real_escape_string($user);
$pwd = mysql_real_escape_string($pwd);

$sql = "SELECT * FROM users WHERE
user='" . $user . "' AND password='" . $pwd . "'"

// 更多代码

mysql_close($con);
?>

例子 2

数据库攻击。本例演示如果我们不对用户名和密码应用 mysql_real_escape_string() 函数会发生什么：

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$sql = "SELECT * FROM users
WHERE user='{$_POST['user']}'
AND password='{$_POST['pwd']}'";
mysql_query($sql);

// 不检查用户名和密码
// 可以是用户输入的任何内容，比如：
$_POST['user'] = 'john';
$_POST['pwd'] = "' OR ''='";

// 一些代码...

mysql_close($con);
?>

那么 SQL 查询会成为这样：

SELECT * FROM users
WHERE user='john' AND password='' OR ''=''

这意味着任何用户无需输入合法的密码即可登陆。

例子 3

预防数据库攻击的正确做法：

<?php
function check_input($value)
{
// 去除斜杠
if (get_magic_quotes_gpc())
  {
  $value = stripslashes($value);
  }
// 如果不是数字则加引号
if (!is_numeric($value))
  {
  $value = "'" . mysql_real_escape_string($value) . "'";
  }
return $value;
}

$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

// 进行安全的 SQL
$user = check_input($_POST['user']);
$pwd = check_input($_POST['pwd']);
$sql = "SELECT * FROM users WHERE
user=$user AND password=$pwd";

mysql_query($sql);

mysql_close($con);
?>

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_result() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_result() 函数

PHP MySQL 函数

定义和用法

mysql_result() 函数返回结果集中一个字段的值。

如果成功，则该函数返回字段值。如果失败，则返回 false。

语法

mysql_result(data,row,field)
参数 | 描述
data | 必需。规定要使用的结果标识符。该标识符是 mysql_query() 函数返回的。
row | 必需。规定行号。行号从 0 开始。
field | 可选。规定获取哪个字段。可以是字段偏移值，字段名或 table.fieldname。 如果该参数未规定，则该函数从指定的行获取第一个字段。

说明

当作用于很大的结果集时，应该考虑使用能够取得整行的函数。这些函数在一次函数调用中返回了多个单元的内容，比 mysql_result() 快得多。

此外请注意，在字段参数中指定数字偏移量比指定字段名或者 tablename.fieldname 要快得多。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db", $con);

$sql = "SELECT * from Person";
$result = mysql_query($sql,$con);

echo mysql_result($result,0);

mysql_close($con);

?>

输出类似：

Adams

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP MySQL Select

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP MySQL Select

  • Previous Page
  • Next Page

SELECT 语句用于从数据库中选取数据。

从数据库表中选取数据

SELECT 语句用于从数据库中选取数据。

语法

SELECT column_name(s) FROM table_name

注释：SQL 语句对大小写不敏感。SELECT 与 select 等效。

为了让 PHP 执行上面的语句，我们必须使用 mysql_query() 函数。该函数用于向 MySQL 发送查询或命令。

例子

下面的例子选取存储在 "Person" 表中的所有数据（* 字符选取表中所有数据）：

<?php
$con = mysql_connect("localhost","peter","abc123");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

mysql_select_db("my_db", $con);

$result = mysql_query("SELECT * FROM person");

while($row = mysql_fetch_array($result))
  {
  echo $row['FirstName'] . " " . $row['LastName'];
  echo "<br />";
  }

mysql_close($con);
?>

上面这个例子在 $result 变量中存放由 mysql_query() 函数返回的数据。接下来，我们使用 mysql_fetch_array() 函数以数组的形式从记录集返回第一行。每个随后对 mysql_fetch_array() 函数的调用都会返回记录集中的下一行。 while loop 语句会循环记录集中的所有记录。为了输出每行的值，我们使用了 PHP 的 $row 变量 ($row['FirstName'] 和 $row['LastName'])。

以上代码的输出：

Peter Griffin
Glenn Quagmire

在 HTML 表格中显示结果

下面的例子选取的数据与上面的例子相同，但是将把数据显示在一个 HTML 表格中：

<?php
$con = mysql_connect("localhost","peter","abc123");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

mysql_select_db("my_db", $con);

$result = mysql_query("SELECT * FROM person");

echo "<table border='1'>
<tr>
<th>Firstname</th>
<th>Lastname</th>
</tr>";

while($row = mysql_fetch_array($result))
  {
  echo "<tr>";
  echo "<td>" . $row['FirstName'] . "</td>";
  echo "<td>" . $row['LastName'] . "</td>";
  echo "</tr>";
  }
echo "</table>";

mysql_close($con);
?>

以上代码的输出：

Firstname | Lastname
Glenn | Quagmire
Peter | Griffin
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP mysql_select_db() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_select_db() 函数

PHP MySQL 函数

定义和用法

mysql_select_db() 函数设置活动的 MySQL 数据库。

如果成功，则该函数返回 true。如果失败，则返回 false。

语法

mysql_select_db(database,connection)
参数 | 描述
database | 必需。规定要选择的数据库。
connection | 可选。规定 MySQL 连接。如果未指定，则使用上一个连接。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db", $con);

if (!$db_selected)
  {
  die ("Can\'t use test_db : " . mysql_error());
  }

mysql_close($con);
?>

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_stat() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_stat() 函数

PHP MySQL 函数

定义和用法

mysql_stat() 函数返回 MySQL 服务器的当前系统状态。

如果成功，则该函数返回状态。如果失败，则返回 false。

语法

mysql_stat(connection)
参数 | 描述
connection | 可选。规定 MySQL 连接。如果未指定，则使用上一个连接。

提示和注释

注释：mysql_stat() 目前只返回 uptime、threads、queries、open tables、flush tables 和 queries per second。要得到其它状态变量的完整列表，只能使用 SQL 命令 SHOW STATUS。

例子

<?php
$con = mysql_connect("localhost", "hello", "321");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

$db_selected = mysql_select_db("test_db", $con);

echo mysql_stat();
?>

输出类似：

Uptime: 99410 Threads: 1 Questions: 162
Slow queries: 0 Opens: 0 Flush tables: 1
Open tables: 0 Queries per second avg: 0.002

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_thread_id() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_thread_id() 函数

PHP MySQL 函数

定义和用法

mysql_thread_id() 函数返回当前线程的 ID。

如果成功，则该函数线程的 ID。如果失败，则返回 false。

语法

mysql_thread_id(connection)
参数 | 描述
connection | 可选。规定 MySQL 连接。如果未指定，则使用上一个连接。

提示和注释

注释：每个 MySQL 连接的 线程 ID 是不同的。

例子

<?php
$con = mysql_connect("localhost", "peter", "abc123");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

echo mysql_thread_id();

mysql_close($con);
?>

输出类似：

38

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP mysql_unbuffered_query() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP mysql_unbuffered_query() 函数

PHP MySQL 函数

定义和用法

mysql_unbuffered_query() 函数向 MySQL 发送一条 SQL 查询（不获取 / 缓存结果）。

语法

mysql_unbuffered_query(query,connection)
参数 | 描述
query | 必需。规定要发送的 SQL 查询。注释：查询字符串不应以分号结束。
connection | 可选。规定 SQL 连接标识符。如果未规定，则使用上一个打开的连接。

说明

mysql_unbuffered_query() 向 MySQL 发送一条 SQL 查询 query ，但不像 mysql_query() 那样自动获取并缓存结果集。一方面，这在处理很大的结果集时会节省可观的内存。另一方面，可以在获取第一行后立即对结果集进行操作，而不用等到整个 SQL 语句都执行完毕。

当使用多个数据库连接时，必须指定可选参数 connection。

提示和注释

注释：mysql_unbuffered_query() 的好处是有代价的：在 mysql_unbuffered_query() 返回的结果集之上不能使用 mysql_num_rows() 和 mysql_data_seek()。此外在向 MySQL 发送一条新的 SQL 查询之前，必须提取所有未缓存的 SQL 查询所产生的结果行。

例子

<?php
$con = mysql_connect("localhost","mysql_user","mysql_pwd");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

// 大型查询
$sql = "SELECT * FROM Person";

mysql_unbuffered_query($sql,$con);

// 开始处理数据...

mysql_close($con);
?>

PHP MySQL 函数

PHP 参考手册
PHP 测验


PHP MySQL Update

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP MySQL Update

  • Previous Page
  • Next Page

UPDATE 语句用于中修改数据库表中的数据。

更新数据库中的数据

UPDATE 语句用于在数据库表中修改数据。

语法

UPDATE table_name
SET column_name = new_value
WHERE column_name = some_value

注释：SQL 对大小写不敏感。UPDATE 与 update 等效。

为了让 PHP 执行上面的语句，我们必须使用 mysql_query( 函数。该函数用于向 SQL 连接发送查询和命令。

例子

稍早时，我们在本教程中创建了一个名为 "Person" 的表。它看起来类似这样：

FirstName | LastName | Age
Peter | Griffin | 35
Glenn | Quagmire | 33

下面的例子更新 "Person" 表的一些数据：

<?php
$con = mysql_connect("localhost","peter","abc123");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

mysql_select_db("my_db", $con);

mysql_query("UPDATE Person SET Age = '36'
WHERE FirstName = 'Peter' AND LastName = 'Griffin'");

mysql_close($con);
?>

在这次更新后，"Person" 表格是这样的：

FirstName | LastName | Age
Peter | Griffin | 36
Glenn | Quagmire | 33
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP MySQL Where 子句

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP MySQL Where 子句

  • Previous Page
  • Next Page

如需选取匹配指定条件的数据，请向 SELECT 语句添加 WHERE 子句。

WHERE 子句

如需选取匹配指定条件的数据，请向 SELECT 语句添加 WHERE 子句。

语法

SELECT column FROM table
WHERE column operator value

下面的运算符可与 WHERE 子句一起使用：

运算符 | 说明
= | 等于
!= | 不等于
> | 大于
< | 小于
>= | 大于或等于
<= | 小于或等于
BETWEEN | 介于一个包含范围内
LIKE | 搜索匹配的模式

注释：SQL 语句对大小写不敏感。WHERE 与 where 等效。

为了让 PHP 执行上面的语句，我们必须使用 mysql_query() 函数。该函数用于向 SQL 连接发送查询和命令。

例子

下面的例子将从 "Person" 表中选取所有 FirstName='Peter' 的行：

<?php
$con = mysql_connect("localhost","peter","abc123");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

mysql_select_db("my_db", $con);

$result = mysql_query("SELECT * FROM person
WHERE FirstName='Peter'");

while($row = mysql_fetch_array($result))
  {
  echo $row['FirstName'] . " " . $row['LastName'];
  echo "<br />";
  }

?>

以上代码的输出：

Peter Griffin
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP MySQL 创建数据库和表

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP MySQL 创建数据库和表

  • Previous Page
  • Next Page

数据库存有一个或多个表。

创建数据库

CREATE DATABASE 语句用于在 MySQL 中创建数据库。

语法

CREATE DATABASE database_name

为了让 PHP 执行上面的语句，我们必须使用 mysql_query() 函数。此函数用于向 MySQL 连接发送查询或命令。

例子

在下面的例子中，我们创建了一个名为 "my_db" 的数据库：

<?php
$con = mysql_connect("localhost","peter","abc123");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

if (mysql_query("CREATE DATABASE my_db",$con))
  {
  echo "Database created";
  }
else
  {
  echo "Error creating database: " . mysql_error();
  }

mysql_close($con);
?>

创建表

CREATE TABLE 用于在 MySQL 中创建数据库表。

语法

CREATE TABLE table_name
(
column_name1 data_type,
column_name2 data_type,
column_name3 data_type,
.......
)

为了执行此命令，我必须向 mysql_query() 函数添加 CREATE TABLE 语句。

例子

下面的例子展示了如何创建一个名为 "person" 的表，此表有三列。列名是 "FirstName", "LastName" 以及 "Age"：

<?php
$con = mysql_connect("localhost","peter","abc123");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

// Create database
if (mysql_query("CREATE DATABASE my_db",$con))
  {
  echo "Database created";
  }
else
  {
  echo "Error creating database: " . mysql_error();
  }

// Create table in my_db database
mysql_select_db("my_db", $con);
$sql = "CREATE TABLE person
(
FirstName varchar(15),
LastName varchar(15),
Age int
)";
mysql_query($sql,$con);

mysql_close($con);
?>

重要事项：在创建表之前，必须首先选择数据库。通过 mysql_select_db() 函数选取数据库。

注释：当您创建 varchar 类型的数据库字段时，必须规定该字段的最大长度，例如：varchar(15)。

MySQL 数据类型

下面的可使用的各种 MySQL 数据类型：

数值类型 描述
  • int(size)
  • smallint(size)
  • tinyint(size)
  • mediumint(size)
  • bigint(size)
 仅支持整数。在 size 参数中规定数字的最大值。
  • decimal(size,d)
  • double(size,d)
  • float(size,d)

支持带有小数的数字。

在 size 参数中规定数字的最大值。在 d 参数中规定小数点右侧的数字的最大值。
文本数据类型 | 描述
char(size)

支持固定长度的字符串。（可包含字母、数字以及特殊符号）。

在 size 参数中规定固定长度。
varchar(size)

支持可变长度的字符串。（可包含字母、数字以及特殊符号）。

在 size 参数中规定最大长度。
tinytext | 支持可变长度的字符串，最大长度是 255 个字符。
  • text
  • blob
 支持可变长度的字符串，最大长度是 65535 个字符。
  • mediumtext
  • mediumblob
 支持可变长度的字符串，最大长度是 16777215 个字符。
  • longtext
  • longblob
 支持可变长度的字符串，最大长度是 4294967295 个字符。
日期数据类型 描述
  • date(yyyy-mm-dd)
  • datetime(yyyy-mm-dd hh:mm:ss)
  • timestamp(yyyymmddhhmmss)
  • time(hh:mm:ss)
 支持日期或时间
杂项数据类型 | 描述
enum(value1,value2,ect) | ENUM 是 ENUMERATED 列表的缩写。可以在括号中存放最多 65535 个值。
set | SET 与 ENUM 相似。但是，SET 可拥有最多 64 个列表项目，并可存放不止一个 choice

主键和自动递增字段

每个表都应有一个主键字段。

主键用于对表中的行进行唯一标识。每个主键值在表中必须是唯一的。此外，主键字段不能为空，这是由于数据库引擎需要一个值来对记录进行定位。

主键字段永远要被编入索引。这条规则没有例外。你必须对主键字段进行索引，这样数据库引擎才能快速定位给予该键值的行。

下面的例子把 personID 字段设置为主键字段。主键字段通常是 ID 号，且通常使用 AUTO_INCREMENT 设置。AUTO_INCREMENT 会在新纪录被添加时逐一增加该字段的值。要确保主键字段不为空，我们必须向该字段添加 NOT NULL 设置。

例子

$sql = "CREATE TABLE person
(
personID int NOT NULL AUTO_INCREMENT,
PRIMARY KEY(personID),
FirstName varchar(15),
LastName varchar(15),
Age int
)";

mysql_query($sql,$con);
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP MySQL 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP MySQL 函数

  • Previous Page
  • Next Page

PHP MySQL 简介

MySQL 函数允许您访问 MySQL 数据库服务器。

安装

为了能够顺利的使用本类函数，必须在编译 PHP 时添加对 MySQL 的支持。

编译时，只要使用 --with-mysql[=DIR] 配置选项即可，其中可选的 [DIR] 指向 MySQL 的安装目录。

虽然本 MySQL 扩展库兼容 MySQL 4.1.0 及其以后版本，但是它不支持这些版本提供的额外功能。要使用这些功能，请使用 MySQLi 扩展库。

如果要同时安装 mysql 扩展库和 mysqli 扩展库，必须使用同一个客户端库以避免任何冲突。

在 Linux 系统上安装

PHP 4

默认开启了 --with-mysql 选项。此默认行为可以用 --without-mysql 配置选项来禁止。如果启用 MySQL 而不指定安装目录的话，PHP 将使用绑定的 MySQL 客户端连接库。

还有其它应用程序使用 MySQL（例如 auth-mysql）的用户不要用绑定的库，而要指定 MySQL 的安装目录，如这样：--with-mysql=/path/to/mysql。这将强制 PHP 使用随 MySQL 安装的客户端连接库，就可以避免任何冲突。

PHP 5+

MySQL 默认未启用，也没有绑定的 MySQL 库。使用 --with-mysql[=DIR] 配置选项来加入 MySQL 的支持。可以从 MySQL 下载头文件和库。

在 Windows 系统上安装

PHP 4

PHP MySQL 扩展已经编译入 PHP。

PHP 5+

MySQL 默认未启用，因此必须在 php.ini 中激活 php_mysql.dll 动态连接库。此外，PHP 还需要访问 MySQL 客户端连接库。PHP 的 Windows 发行版包括了一个 libmysql.dll，为了让 PHP 能和 MySQL 对话，此文件必须放在 Windows 的系统路径 PATH 中。

要激活任何 PHP 扩展库（例如 php_mysql.dll），PHP 指令 extension_dir 要被设为 PHP 扩展库所在的目录。PHP 5 下 extension_dir 取值的一个例子是 c:\php\ext。

注释：如果启动 web 服务器时出现类似如下的错误："Unable to load dynamic library './php_mysql.dll'"，这是因为系统找不到 php_mysql.dll 和 / 或 libmysql.dll。

Runtime 配置

MySQL 函数的行为受到 php.ini 中设置的影响。

MySQL 配置选项：

名称 | 默认 | 描述 | 可更改
mysql.allow_persistent | "1" | 是否允许 MySQL 的持久连接。 | PHP_INI_SYSTEM
mysql.max_persistent | "-1" | 每个进程中最大的持久连接数目。 | PHP_INI_SYSTEM
mysql.max_links | "-1" | 每个进程中最大的连接数，包括持久连接。 | PHP_INI_SYSTEM
mysql.trace_mode | "0" | 跟踪模式。从 PHP 4.3.0 起可用。 | PHP_INI_ALL
mysql.default_port | NULL | 指定默认连接数据库的 TCP 端口号。 | PHP_INI_ALL
mysql.default_socket | NULL | 默认的 socket 名称。PHP 4.0.1起可用。 | PHP_INI_ALL
mysql.default_host | NULL | 默认的服务器地址。不适用于SQL安全模式。 | PHP_INI_ALL
mysql.default_user | NULL | 默认使用的用户名。不适用于SQL安全模式。 | PHP_INI_ALL
mysql.default_password | NULL | 默认使用的密码。不适用于SQL安全模式。 | PHP_INI_ALL
mysql.connect_timeout | "60" | 连接超时秒数。 | PHP_INI_ALL

资源类型

在 MySQL 模块中使用了两种资源类型。第一种是数据库的连接句柄，第二种是 SQL 查询返回的结果集。

PHP MySQL 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
mysql_affected_rows() | 取得前一次 MySQL 操作所影响的记录行数。 | 3
mysql_change_user() | 不赞成。改变活动连接中登录的用户 | 3
mysql_client_encoding() | 返回当前连接的字符集的名称 | 4
mysql_close() | 关闭非持久的 MySQL 连接。 | 3
mysql_connect() | 打开非持久的 MySQL 连接。 | 3
mysql_create_db() | 不赞成。新建 MySQL 数据库。使用 mysql_query() 代替。 | 3
mysql_data_seek() | 移动记录指针。 | 3
mysql_db_name() | 从对 mysql_list_dbs() 的调用返回数据库名称。 | 3
mysql_db_query() | 不赞成。发送一条 MySQL 查询。 使用 mysql_select_db() 和 mysql_query() 代替。 | 3
mysql_drop_db() | 不赞成。丢弃（删除）一个 MySQL 数据库。 使用 mysql_query() 代替。 | 3
mysql_errno() | 返回上一个 MySQL 操作中的错误信息的数字编码。 | 3
mysql_error() | 返回上一个 MySQL 操作产生的文本错误信息。 | 3
mysql_escape_string() | 不赞成。转义一个字符串用于 mysql_query。 使用 mysql_real_escape_string() 代替。 | 4
mysql_fetch_array() | 从结果集中取得一行作为关联数组，或数字数组，或二者兼有。 | 3
mysql_fetch_assoc() | 从结果集中取得一行作为关联数组。 | 4
mysql_fetch_field() | 从结果集中取得列信息并作为对象返回。 | 3
mysql_fetch_lengths() | 取得结果集中每个字段的内容的长度。 | 3
mysql_fetch_object() | 从结果集中取得一行作为对象。 | 3
mysql_fetch_row() | 从结果集中取得一行作为数字数组。 | 3
mysql_field_flags() | 从结果中取得和指定字段关联的标志。 | 3
mysql_field_len() | 返回指定字段的长度。 | 3
mysql_field_name() | 取得结果中指定字段的字段名。 | 3
mysql_field_seek() | 将结果集中的指针设定为指定的字段偏移量。 | 3
mysql_field_table() | 取得指定字段所在的表名。 | 3
mysql_field_type() | 取得结果集中指定字段的类型。 | 3
mysql_free_result() | 释放结果内存。 | 3
mysql_get_client_info() | 取得 MySQL 客户端信息。 | 4
mysql_get_host_info() | 取得 MySQL 主机信息。 | 4
mysql_get_proto_info() | 取得 MySQL 协议信息。 | 4
mysql_get_server_info() | 取得 MySQL 服务器信息。 | 4
mysql_info() | 取得最近一条查询的信息。 | 4
mysql_insert_id() | 取得上一步 INSERT 操作产生的 ID。 | 3
mysql_list_dbs() | 列出 MySQL 服务器中所有的数据库。 | 3
mysql_list_fields() | 不赞成。列出 MySQL 结果中的字段。 使用 mysql_query() 代替。 | 3
mysql_list_processes() | 列出 MySQL 进程。 | 4
mysql_list_tables() | 不赞成。列出 MySQL 数据库中的表。 使用Use mysql_query() 代替。 | 3
mysql_num_fields() | 取得结果集中字段的数目。 | 3
mysql_num_rows() | 取得结果集中行的数目。 | 3
mysql_pconnect() | 打开一个到 MySQL 服务器的持久连接。 | 3
mysql_ping() | Ping 一个服务器连接，如果没有连接则重新连接。 | 4
mysql_query() | 发送一条 MySQL 查询。 | 3
mysql_real_escape_string() | 转义 SQL 语句中使用的字符串中的特殊字符。 | 4
mysql_result() | 取得结果数据。 | 3
mysql_select_db() | 选择 MySQL 数据库。 | 3
mysql_stat() | 取得当前系统状态。 | 4
mysql_tablename() | 不赞成。取得表名。使用 mysql_query() 代替。 | 3
mysql_thread_id() | 返回当前线程的 ID。 | 4
mysql_unbuffered_query() | 向 MySQL 发送一条 SQL 查询（不获取 / 缓存结果）。 | 4

PHP MySQL 常量

在 PHP 4.3.0 以后的版本中，允许在 mysql_connect() 函数和 mysql_pconnect() 函数中指定更多的客户端标记：

PHP：指示支持该常量的最早的 PHP 版本。

常量 | 描述 | PHP
MYSQL_CLIENT_COMPRESS | 使用压缩的通讯协议。 | 4.3
MYSQL_CLIENT_IGNORE_SPACE | 允许在函数名后留空格位。 | 4.3
MYSQL_CLIENT_INTERACTIVE | 在关闭连接前所允许的交互超时非活动时间。 | 4.3
MYSQL_CLIENT_SSL | 使用 SSL 加密（仅在 MySQL 客户端库版本为 4+ 时可用）。 | 4.3

mysql_fetch_array() 函数使用一个常量来表示所返回数组的类型：

常量 | 描述 | PHP
MYSQL_ASSOC | 返回的数据列使用字段名作为数组的索引名。 |
MYSQL_BOTH | 返回的数据列使用字段名及数字索引作为数组的索引名。 |
MYSQL_NUM | 返回的数据列使用数字索引作为数组的索引名。 索引从 0 开始，表示返回结果的第一个字段。 |
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP MySQL 简介

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP MySQL 简介

  • Previous Page
  • Next Page

MySQL 是最流行的开源数据库服务器。

什么是 MySQL？

MySQL 是一种数据库。数据库定义了存储信息的结构。

在数据库中，存在着一些表。类似 HTML 表格，数据库表含有行、列以及单元。

在分类存储信息时，数据库非常有用。一个公司的数据库可能拥有这些表："Employees", "Products", "Customers" 以及 "Orders"。

数据库表

数据库通常包含一个或多个表。每个表都一个名称（比如 "Customers" 或 "Orders"）。每个表包含带有数据的记录（行）。

下面是一个名为 "Persons" 的表的例子：

LastName | FirstName | Address | City
Hansen | Ola | Timoteivn 10 | Sandnes
Svendson | Tove | Borgvn 23 | Sandnes
Pettersen | Kari | Storgt 20 | Stavanger

上面的表含有三个记录（每个记录是一个人）和四个列（LastName, FirstName, Address 以及 City）。

查询

查询是一种询问或请求。

通过 MySQL，我们可以向数据库查询具体的信息，并得到返回的记录集。

请看下面的查询：

SELECT LastName FROM Persons

上面的查询选取了 Persons 表中 LastName 列的所有数据，并返回类似这样的记录集：

LastName
Hansen
Svendson
Pettersen

下载 MySQL 数据库

如果您的 PHP 服务器没有 MySQL 数据库，可以在此下载 MySQL：http://www.mysql.com/downloads/index.html

Facts About MySQL Database

关于 MySQL 的一点很棒的特性是，可以对它进行缩减，来支持嵌入的数据库应用程序。也许正因如此，许多人认为 MySQL 仅仅能处理中小型的系统。

事实上，对于那些支持巨大数据和访问量的网站，MySQL 是事实上的标准数据库（比如 Friendster, Yahoo, Google）。这个地址提供了使用 MySQL 的公司的概览：http://www.mysql.com/customers/。

  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP MySQL 连接数据库

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP MySQL 连接数据库

  • Previous Page
  • Next Page

免费的 MySQL 数据库通常是通过 PHP 来使用的。

连接到一个 MySQL 数据库

在您能够访问并处理数据库中的数据之前，您必须创建到达数据库的连接。

在 PHP 中，这个任务通过 mysql_connect() 函数完成。

语法

mysql_connect(servername,username,password);
参数 | 描述
servername | 可选。规定要连接的服务器。默认是 "localhost:3306"。
username | 可选。规定登录所使用的用户名。默认值是拥有服务器进程的用户的名称。
password | 可选。规定登录所用的密码。默认是 ""。

注释：虽然还存在其他的参数，但上面列出了最重要的参数。请访问 W3School 提供的 PHP MySQL 参考手册，获得更多的细节信息。

例子

在下面的例子中，我们在一个变量中 ($con) 存放了在脚本中供稍后使用的连接。如果连接失败，将执行 "die" 部分：

<?php
$con = mysql_connect("localhost","peter","abc123");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

// some code

?>

关闭连接

脚本一结束，就会关闭连接。如需提前关闭连接，请使用 mysql_close() 函数。

<?php
$con = mysql_connect("localhost","peter","abc123");
if (!$con)
  {
  die('Could not connect: ' . mysql_error());
  }

// some code

mysql_close($con);
?>
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP natcasesort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP natcasesort() 函数

PHP Array 函数

定义和用法

natcasesort() 函数用不区分大小写的自然顺序算法对给定数组中的元素排序。

natcasesort() 函数实现了“自然排序”，即数字从 1 到 9 的排序方法，字母从 a 到 z 的排序方法，短者优先，该函数不区分大小写。数组的索引与单元值保持关联。

如果成功，则该函数返回 TRUE，否则返回 FALSE。

语法

natcasesort(array)
参数 | 描述
array | 必需。规定要进行排序的数组。

提示和注释

提示：natcasesort() 是 natsort() 函数 的不区分大小写字母的版本。

例子

<?php
$temp_files = array("temp15.txt","Temp10.txt",
"temp1.txt","Temp22.txt","temp2.txt");

natsort($temp_files);
echo "Natural order: ";
print_r($temp_files);
echo "<br />";

natcasesort($temp_files);
echo "Natural order case insensitve: ";
print_r($temp_files);
?>

输出：

Natural order:
Array
(
[0] => Temp10.txt
[1] => Temp22.txt
[2] => temp1.txt
[4] => temp2.txt
[3] => temp15.txt
)

Natural order case insensitve:
Array
(
[2] => temp1.txt
[4] => temp2.txt
[0] => Temp10.txt
[3] => temp15.txt
[1] => Temp22.txt
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP natsort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP natsort() 函数

PHP Array 函数

定义和用法

natsort() 函数用自然顺序算法对给定数组中的元素排序。

natsort() 函数实现了“自然排序”，即数字从 1 到 9 的排序方法，字母从 a 到 z 的排序方法，短者优先。数组的索引与单元值保持关联。

如果成功，则该函数返回 TRUE，否则返回 FALSE。

语法

natsort(array)
参数 | 描述
array | 必需。规定要进行排序的数组。

例子

本函数所用的自然排序算法，与通常的计算机字符串排序算法（用于 sort()）的区别，见下面示例：

<?php
$temp_files = array("temp15.txt","temp10.txt",
"temp1.txt","temp22.txt","temp2.txt");

sort($temp_files);
echo "Standard sorting: ";
print_r($temp_files);
echo "<br />";

natsort($temp_files);
echo "Natural order: ";
print_r($temp_files);
?>

输出：

Standard sorting: Array
(
[0] => temp1.txt
[1] => temp10.txt
[2] => temp15.txt
[3] => temp2.txt
[4] => temp22.txt
)

Natural order: Array
(
[0] => temp1.txt
[3] => temp2.txt
[1] => temp10.txt
[2] => temp15.txt
[4] => temp22.txt
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP next() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP next() 函数

PHP Array 函数

定义和用法

next() 函数把指向当前元素的指针移动到下一个元素的位置，并返回当前元素的值。

如果内部指针已经超过数组的最后一个元素，函数返回 false。

语法

next(array)
参数 | 描述
array | 必需。规定要使用的数组。

说明

next() 和 current() 的行为类似，只有一点区别，在返回值之前将内部指针向前移动一位。这意味着它返回的是下一个数组单元的值并将数组指针向前移动了一位。如果移动指针的结果超出了数组单元的末端，则 next() 返回 FALSE。

注意：如果数组包含空的单元，或者单元的值是 0 则该函数碰到这些单元也返回 FALSE。要正确遍历可能含有空单元或者单元值为 0 的数组，请参见 each() 函数。

例子

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");

echo current($people) . "<br />";
echo next($people);
?>

输出：

Peter
Joe

PHP Array 函数

PHP 参考手册
PHP 测验


PHP nl_langinfo() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP nl_langinfo() 函数

PHP String 函数

定义和用法

nl_langinfo() 函数返回指定的本地信息。

如果成功，则返回指定的本地信息。如果失败，则返回 false。

语法

nl_langinfo(element)
参数 | 描述
element | 必需。规定要返回哪个元素。必须是说明中列出的元素之一。

说明

时间和日历：

  • ABDAY_(1-7) - Abbreviated name of the numbered day of the week
  • DAY_(1-7) - Name of the numbered day of the week (DAY_1 = Sunday)
  • ABMON_(1-12) - Abbreviated name of the numbered month of the year
  • MON_(1-12) - Name of the numbered month of the year
  • AM_STR - String for Ante meridian
  • PM_STR - String for Post meridian
  • D_T_FMT - String that can be used as the format string for strftime() to represent time and date
  • D_FMT - String that can be used as the format string for strftime() to represent date
  • T_FMT - String that can be used as the format string for strftime() to represent time
  • T_FMT_AMPM - String that can be used as the format string for strftime() to represent time in 12-hour format with ante/post meridian
  • ERA - Alternate era
  • ERA_YEAR - Year in alternate era format
  • ERA_D_T_FMT - Date and time in alternate era format (string can be used in strftime())
  • ERA_D_FMT - Date in alternate era format (string can be used in strftime())
  • ERA_T_FMT - Time in alternate era format (string can be used in strftime())

货币类别：

  • INT_CURR_SYMBOL - Currency symbol (example: USD)
  • CURRENCY_SYMBOL - Currency symbol (example: $)
  • CRNCYSTR - Same as CURRENCY_SYMBOL
  • MON_DECIMAL_POINT - Monetary decimal point character
  • MON_THOUSANDS_SEP - Monetary thousands separator
  • POSITIVE_SIGN - Positive value character
  • NEGATIVE_SIGN -Negative value character
  • MON_GROUPING - Array displaying how monetary numbers are grouped (example: 1 000 000)
  • INT_FRAC_DIGITS - International fractional digits
  • FRAC_DIGITS - Local fractional digits
  • P_CS_PRECEDES - True (1) if currency symbol is placed in front of a positive value, False (0) if it is placed behind
  • P_SEP_BY_SPACE - True (1) if there is a spaces between the currency symbol and a positive value, False (0) otherwise
  • N_CS_PRECEDES - True (1) if currency symbol is placed in front of a negative value, False (0) if it is placed behind
  • N_SEP_BY_SPACE - True (1) if there is a spaces between the currency symbol and a negative value, False (0) otherwise
  • P_SIGN_POSN - Formatting setting. Possible return values:
    • 0 - Parentheses surround the quantity and currency symbol
    • 1 - The sign string is placed in front of the quantity and currency symbol
    • 2 - The sign string is placed after the quantity and currency symbol
    • 3 - The sign string is placed immediately in front of the currency symbol
    • 4 - The sign string is placed immediately after the currency symbol
  • N_SIGN_POSN - Formatting setting. Possible return values:
    • 0 - Parentheses surround the quantity and currency symbol
    • 1 - The sign string is placed in front of the quantity and currency symbol
    • 2 - The sign string is placed after the quantity and currency symbol
    • 3 - The sign string is placed immediately in front of the currency symbol
    • 4 - The sign string is placed immediately after the currency symbol

数字类别：

  • DECIMAL_POINT - Decimal point character
  • RADIXCHAR - Same as DECIMAL_POINT
  • THOUSANDS_SEP - Separator character for thousands
  • THOUSEP - Same as THOUSANDS_SEP
  • GROUPING - Array displaying how numbers are grouped (example: 1 000 000)

通信类别：

  • YESEXPR - Regex string for matching 'yes' input
  • NOEXPR - Regex string for matching 'no' input
  • YESSTR - Output string for 'yes'
  • NOSTR - Output string for 'no'

代码集类别：

  • CODESET Return a string with the name of the character encoding.

提示和注释

注释：money_format() 函数无法在 windows 平台上工作。

提示：与返回所有本地格式化信息的 localeconv() 函数不同，nl_langinfo() 返回指定的信息。

PHP String 函数

PHP 参考手册
PHP 测验


PHP nl2br() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP nl2br() 函数

PHP String 函数

定义和用法

nl2br() 函数在字符串中的每个新行 (\n) 之前插入 HTML 换行符 (<br />)。

语法

nl2br(string)
参数 | 描述
string | 必需。规定要检查的字符串。

例子

<?php
echo nl2br("One line.\nAnother line.");
?>

输出：

One line.
Another line.

HTML 代码：

One line.<br />
Another line.

PHP String 函数

PHP 参考手册
PHP 测验


PHP number_format() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP number_format() 函数

PHP String 函数

定义和用法

number_format() 函数通过千位分组来格式化数字。

语法

number_format(number,decimals,decimalpoint,separator)
参数 | 描述
number | 必需。要格式化的数字。 如果未设置其他参数，则数字会被格式化为不带小数点且以逗号 (,) 作为分隔符。
decimals | 可选。规定多少个小数。如果设置了该参数，则使用点号 (.) 作为小数点来格式化数字。
decimalpoint | 可选。规定用作小数点的字符串。
separator | 可选。规定用作千位分隔符的字符串。 仅使用该参数的第一个字符。比如 "xyz" 仅输出 "x"。 注释：如果设置了该参数，那么所有其他参数都是必需的。

提示和注释

注释：该函数支持一个、两个或四个参数（不是三个）。

例子

<?php
echo number_format("1000000");
echo number_format("1000000",2);
echo number_format("1000000",2,",",".");
?>

输出：

1,000,000
1,000,000.00
1.000.000,00

PHP String 函数

PHP 参考手册
PHP 测验


PHP octdec() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP octdec() 函数

PHP Math 函数

定义和用法

octdec() 函数把八进制转换为十进制。

语法

octdec(octal_string)
参数 | 描述
octal_string | 必需。规定要转换的八进制数。

说明

返回 octal_string 参数所表示的八进制数的十进制等值。可转换的最大的数值为 17777777777 或十进制的 2147483647。从 PHP 4.1.0 开始，该函数可以处理大数字，这种情况下，它会返回 float 类型。

例子

<?php
echo octdec("36");
echo octdec("12");
echo octdec("3063");
echo octdec("106");
?>

输出类似：

30
10
1587
70

PHP Math 函数

PHP 参考手册
PHP 测验


PHP opendir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP opendir() 函数

PHP Directory 函数

定义和用法

opendir() 函数打开一个目录句柄，可由 closedir()，readdir() 和 rewinddir() 使用。

若成功，则该函数返回一个目录流，否则返回 false 以及一个 error。可以通过在函数名前加上 "@" 来隐藏 error 的输出。

语法

opendir(path,context)
参数 | 描述
path | 必需。规定要打开的目录路径。
context | 可选。规定目录句柄的环境。context 是可修改目录流的行为的一套选项。

提示和注释

注释：从 PHP 5.0.0 开始，path 参数支持 ftp:// URL wrapper。

注释：在 PHP 4.3.0 中， path 参数可以是任何支持目录列表的 URL，不过在 PHP 4 中只有 file:// URL wrapper 支持此功能。

例子

例子 1

<?php
//打开 images 目录
$dir = opendir("images");

//列出 images 目录中的文件
while (($file = readdir($dir)) !== false)
  {
  echo "filename: " . $file . "<br />";
  }
  closedir($dir);
?>

输出：

filename: .
filename: ..
filename: cat.gif
filename: dog.gif
filename: food
filename: horse.gif

例子 2

如果 opendir() 的输出失败，本例会隐藏错误：

<?php
//打开 images 目录
$dir = @ opendir("images");

//列出 images 目录中的文件
while (($file = readdir($dir)) !== false)
  {
  echo "filename: " . $file . "<br />";
  }
  closedir($dir);
?>

输出：

filename: .
filename: ..
filename: cat.gif
filename: dog.gif
filename: food
filename: horse.gif

PHP Directory 函数

PHP 参考手册
PHP 测验


PHP ord() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ord() 函数

PHP String 函数

定义和用法

ord() 函数返回字符串第一个字符的 ASCII 值。

语法

ord(string)
参数 | 描述
string | 必需。要从中获得 ASCII 值的字符串。

例子

<?php
echo ord("h");
echo ord("hello");
?>

输出：

104
104

PHP String 函数

PHP 参考手册
PHP 测验


PHP pack() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP pack() 函数

PHP 杂项函数

定义和用法

pack() 函数把数据装入一个二进制字符串。

语法

pack(format,args+)
参数 | 描述
format | 必需。规定在包装数据时所使用的格式。
args+ | 可选。规定被包装的一个或多个参数。

format 参数的可能值：

  • a - NUL-padded string
  • A - SPACE-padded string
  • h - Hex string, low nibble first
  • H - Hex string, high nibble first
  • c - signed char
  • C - unsigned char
  • s - signed short (always 16 bit, machine byte order)
  • S - unsigned short (always 16 bit, machine byte order)
  • n - unsigned short (always 16 bit, big endian byte order)
  • v - unsigned short (always 16 bit, little endian byte order)
  • i - signed integer (machine dependent size and byte order)
  • I - unsigned integer (machine dependent size and byte order)
  • l - signed long (always 32 bit, machine byte order)
  • L - unsigned long (always 32 bit, machine byte order)
  • N - unsigned long (always 32 bit, big endian byte order)
  • V - unsigned long (always 32 bit, little endian byte order)
  • f - float (machine dependent size and representation)
  • d - double (machine dependent size and representation)
  • x - NUL byte
  • X - Back up one byte
  • @ - NUL-fill to absolute position

例子

例子 1

<?php
echo pack("C3",80,72,80);
?>

输出：

PHP

例子 2

<?php
echo pack("C*",80,72,80);
?>

输出：

PHP

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP parse_ini_file() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP parse_ini_file() 函数

PHP Filesystem 函数

定义和用法

parse_ini_file() 函数解析一个配置文件，并以数组的形式返回其中的设置。

语法

parse_ini_file(file,process_sections)
参数 | 描述
file | 必需。规定要检查的 ini 文件。
process_sections | 可选。如果设置为 true，则返回一个多维数组，包括了配置文件中每一节的名称和设置。默认是 false。

说明

ini 文件的结构和 php.ini 的相似。

常量也可以在 ini 文件中被解析，因此如果在运行 parse_ini_file() 之前定义了常量作为 ini 的值，将会被集成到结果中去。只有 ini 的值会被求值。

由数字组成的键名和小节名会被 PHP 当作整数来处理，因此以 0 开头的数字会被当作八进制而以 0x 开头的会被当作十六进制。

提示和注释

注释：本函数可以用来读取你自己的应用程序的配置文件。本函数与 php.ini 文件没有关系，该文件在运行脚本时就已经处理过了。

注释：如果 ini 文件中的值包含任何非字母数字的字符，需要将其括在双引号中（"）。

注释：有些保留字不能作为 ini 文件中的键名，包括：null，yes，no，true 和 false。值为 null，no 和 false 等效于 ""，值为 yes 和 true 等效于 "1"。字符 {}|"~![()" 也不能用在键名的任何地方，而且这些字符在选项值中有着特殊的意义。

注释：自 PHP 5.0 版本开始，该函数也处理选项值内的新行。

例子

例子 1

"test.ini" 的内容：

[names]
me = Robert
you = Peter

[urls]
first = "http://www.example.com"
second = "http://www.w3school.com.cn"

PHP 代码：

<?php
print_r(parse_ini_file("test.ini"));
?>

输出：

Array
(
[me] => Robert
[you] => Peter
[first] => http://www.example.com
[second] => http://www.w3school.com.cn
)

例子 2

"test.ini" 的内容：

[names]
me = Robert
you = Peter

[urls]
first = "http://www.example.com"
second = "http://www.w3school.com.cn"

PHP 代码（process_sections 设置为 true）：

<?php
print_r(parse_ini_file("test.ini",true));
?>

输出：

Array
(
[names] => Array
  (
  [me] => Robert
  [you] => Peter
  )
[urls] => Array
  (
  [first] => http://www.example.com
  [second] => http://www.w3school.com.cn
  )
)

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP parse_str() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP parse_str() 函数

PHP String 函数

定义和用法

parse_str() 函数把查询字符串解析到变量中。

语法

parse_str(string,array)
参数 | 描述
string | 必需。规定要解析的字符串。
array | 可选。规定存储变量的数组名称。该参数指示变量存储到数组中。

提示和注释

注释：如果未设置 array 参数，由该函数设置的变量将覆盖已由同名变量。

注释：php.ini 中的 magic_quotes_gpc 设置影响该函数的输出。如果已启用，那么在 parse_str() 解析之前，变量会被 addslashes() 转换。

例子

例子 1

<?php
parse_str("id=23&name=John%20Adams");
echo $id."<br />";
echo $name;
?>

输出：

23
John Adams

例子 2

<?php
parse_str("id=23&name=John%20Adams",$myArray);
print_r($myArray);
?>

输出：

Array
(
[id] => 23
[name] => John Adams
)

PHP String 函数

PHP 参考手册
PHP 测验


PHP pathinfo() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP pathinfo() 函数

PHP Filesystem 函数

定义和用法

pathinfo() 函数以数组的形式返回文件路径的信息。

语法

pathinfo(path,options)
参数 | 描述
path | 必需。规定要检查的路径。
process_sections

可选。规定要返回的数组元素。默认是 all。

可能的值：

  • PATHINFO_DIRNAME - 只返回 dirname
  • PATHINFO_BASENAME - 只返回 basename
  • PATHINFO_EXTENSION - 只返回 extension

说明

pathinfo() 返回一个关联数组包含有 path 的信息。

包括以下的数组元素：

  • [dirname]
  • [basename]
  • [extension]

提示和注释

注释：如果不是要求取得所有单元，则 pathinfo() 函数返回字符串。

例子

例子 1

<?php
print_r(pathinfo("/testweb/test.txt"));
?>

输出：

Array
(
[dirname] => /testweb
[basename] => test.txt
[extension] => txt
)

例子 2

<?php
print_r(pathinfo("/testweb/test.txt",PATHINFO_BASENAME));
?>

输出：

test.txt

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP pclose() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP pclose() 函数

PHP Filesystem 函数

定义和用法

pclose() 函数关闭由 popen() 打开的管道。

语法

pclose(pipe)
参数 | 描述
pipe | 必需。规定由 popen() 打开的管道。

说明

该函数返回运行的进程的终止状态。

若出错，则返回 false。

例子

<?php
$file = popen("/bin/ls","r");

//一些要执行的代码

pclose($file);
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP pi() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP pi() 函数

PHP Math 函数

定义和用法

pi() 函数返回圆周率的值。

语法

pi()

说明

返回圆周率的近似值。返回值的 float 精度是由 php.ini 中的 precision 指令确定。默认值是 14。您也可以使用 M_PI 常量，该常量产生与 pi() 完全相同的结果。

例子

<?php
echo pi();
?>

输出类似：

3.14159265359

PHP Math 函数

PHP 参考手册
PHP 测验


PHP popen() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP popen() 函数

PHP Filesystem 函数

定义和用法

popen() 函数打开进程文件指针。

语法

popen(command,mode)
参数 | 描述
command | 必需。规定要执行的命令。
mode 必需。规定连接模式。 可能的值：
  • r: 只读。
  • w: 只写 (打开并清空已有文件或创建一个新文件)

说明

打开一个指向进程的管道，该进程由派生指定的 command 命令执行而产生。

返回一个和 fopen() 所返回的相同的文件指针，只不过它是单向的（只能用于读或写）并且必须用 pclose() 来关闭。此指针可以用于 fgets()，fgetss() 和 fwrite()。

若出错，则返回 false。

例子

<?php
$file = popen("/bin/ls","r");

//一些要执行的代码

pclose($file);
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP pos() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP pos() 函数

PHP Array 函数

定义和用法

pos() 函数是 current() 函数 的别名。它可返回数组中当前元素的值。

语法

pos(array)
参数 | 描述
array | 必需。规定要使用的数组。

例子

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");
echo pos($people) . "<br />";
?>

输出：

Peter

PHP Array 函数

PHP 参考手册
PHP 测验


PHP pow() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP pow() 函数

PHP Math 函数

定义和用法

pow() 函数返回 x 的 y 次方。

语法

pow(x,y)
参数 | 描述
x | 必需。一个数。
y | 必需。一个数。

说明

返回 x 的 y 次方的幂。如果可能，本函数会返回 integer。

如果不能计算幂，将发出一条警告，pow() 将返回 false。PHP 4.2.0 版开始 pow() 不要产生任何的警告。

例子

<?php
echo pow(4,2);
echo pow(6,2);
echo pow(-6,2);
echo pow(-6,-2);
echo pow(-6,5.5);
?>

输出类似：

16
36
36
0.0277777777778
-1.#IND

PHP Math 函数

PHP 参考手册
PHP 测验


PHP prev() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP prev() 函数

PHP Array 函数

定义和用法

next() 函数把指向当前元素的指针移动到上一个元素的位置，并返回当前元素的值。

如果内部指针已经超过数组的第一个元素之前，函数返回 false。

语法

next(array)
参数 | 描述
array | 必需。规定要使用的数组。

说明

prev() 和 next() 的行为类似，不过它将内部指针倒回一位而不是前移一位。

注意：如果数组包含空的单元，或者单元的值是 0 则该函数碰到这些单元也返回 FALSE。要正确遍历可能含有空单元或者单元值为 0 的数组，请参见 each() 函数。

例子

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");

echo current($people) . "<br />";
echo next($people) . "<br />";
echo prev($people);
?>

输出：

Peter
Joe
Peter

PHP Array 函数

PHP 参考手册
PHP 测验


PHP print() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP print() 函数

PHP String 函数

定义和用法

print() 函数输出一个或多个字符串。

语法

print(strings)
参数 | 描述
strings | 必需。发送到输出的一个或多个字符串。

提示和注释

注释：print() 函数实际上不是函数，所以您不必对它使用括号。

注释：print() 函数稍慢于 echo()。

例子

例子 1

<?php
$str = "Who's John Adams?";
print $str;
print "<br />";
print $str."<br />I don't know!";
?>

输出：

Who's John Adams?
Who's John Adams?
I don't know!

例子 2

<?php
print "This text
spans multiple
lines.";
?>

输出：

This text spans multiple lines.

例子 3

<?php
$color = "red";
print "Roses are $color";
print "<br />";
print 'Roses are $color';
?>

输出：

Roses are red
Roses are $color

PHP String 函数

PHP 参考手册
PHP 测验


PHP printf() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP printf() 函数

PHP String 函数

定义和用法

printf() 函数输出格式化的字符串。

语法

printf(format,arg1,arg2,arg++)
参数 | 描述
format | 必需。规定字符串以及如何格式化其中的变量。
arg1 | 必需。规定插到格式化字符串中第一个 % 符号处的参数。
arg2 | 可选。规定插到格式化字符串中第二个 % 符号处的参数。
arg++ | 可选。规定插到格式化字符串中第三、四等等 % 符号处的参数。

说明

arg1, arg2, ++ 等参数将插入到主字符串中的百分号 (%) 符号处。该函数是逐步执行的。在第一个 % 符号中，插入 arg1，在第二个 % 符号处，插入 arg2，依此类推。

提示和注释

注释：如果 % 符号多于 arg 参数，则您必须使用占位符。占位符被插入 % 符号之后，由数字和 "\$" 组成。请参见例子 3。

注释：
相关函数：
fprintf()、
sprintf()、
vfprintf()、
vprintf() 以及
vsprintf()。

例子

例子 1

<?php
$str = "Hello";
$number = 123;
printf("%s world. Day number %u",$str,$number);
?>

输出：

Hello world. Day number 123

例子 2

<?php
$number = 123;
printf("%f",$number);
?>

输出：

123.000000

例子 3

使用占位符：

<?php
$number = 123;
printf("With 2 decimals: %1\$.2f<br />With no decimals: %1\$u",$number);
?>

输出：

With 2 decimals: 123.00
With no decimals: 123

PHP String 函数

PHP 参考手册
PHP 测验


PHP quoted_printable_decode() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP quoted_printable_decode() 函数

PHP String 函数

定义和用法

quoted_printable_decode() 函数对经过 quoted-printable 编码后的字符串进行解码，返回 8 位的字符串。

该函数类似于 imap_qprint() 函数。不同的是，应用 imap_qprint() 函数需要让系统加载 IMAP 模块，而本函数不需要加载 IMAP 模块。

语法

quoted_printable_decode(string)
参数 | 描述
string | 必需。规定要解码的 quoted-printable 字符串。

例子

在本例中，应用 quoted_printable_decode() 函数对经过 quoted-printable 编码后的字符串 "=0A" 进行解码，并返回 8 位的字符串：

<?php
$str = "Hello=0Aworld.";
echo quoted_printable_decode($str);
?>

输出：

Hello world.

HTML 源代码：

Hello
world.

PHP String 函数

PHP 参考手册
PHP 测验


PHP quotemeta() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP quotemeta() 函数

PHP String 函数

定义和用法

quotemeta() 函数在字符串中某些预定义的字符前添加反斜杠。

这些预定义字符是：

  • 句号 (.)
  • 反斜杠 (\)
  • 加号 (+)
  • 星号 (*)
  • 问号 (?)
  • 方括号 ([])
  • 脱字符号 (^)
  • 美元符号 ($)
  • 圆括号 (())

语法

quotemeta(string)
参数 | 描述
string | 必需。规定要检查的字符串。

提示和注释

提示：该函数可用于转义拥有特殊意义的字符，比如 SQL 中的 ( )、[ ] 以及 *。

例子

<?php
$str = "Hello world. (can you hear me?)";
echo quotemeta($str);
?>

输出：

Hello world\. \(can you hear me\?\)

PHP String 函数

PHP 参考手册
PHP 测验


PHP rad2deg() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP rad2deg() 函数

PHP Math 函数

定义和用法

rad2deg() 函数把弧度数转换为角度数。

语法

rad2deg(radian_number)
参数 | 描述
radian_number | 必需。规定要转换的弧度。

说明

本函数将 radian_number 从弧度转换为角度。

例子

<?php
$rad = M_PI;
$deg = rad2deg($rad);
echo "$rad radians is equal to $deg degrees";
?>

输出类似：

3.14159265359 radians is equal to 180 degrees

PHP Math 函数

PHP 参考手册
PHP 测验


PHP rand() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP rand() 函数

PHP Math 函数

定义和用法

rand() 函数返回随机整数。

语法

rand(min,max)
参数 | 描述
min,max | 可选。规定随机数产生的范围。

说明

如果没有提供可选参数 min 和 max，rand() 返回 0 到 RAND_MAX 之间的伪随机整数。例如，想要 5 到 15（包括 5 和 15）之间的随机数，用 rand(5, 15)。

提示和注释

注释：在某些平台下（例如 Windows）RAND_MAX 只有 32768。如果需要的范围大于 32768，那么指定 min 和 max 参数就可以生成大于 RAND_MAX 的数了，或者考虑用 mt_rand() 来替代它。

注释：自 PHP 4.2.0 起，不再需要用 srand() 或 mt_srand() 函数给随机数发生器播种，现在已自动完成。

注释：在 3.0.7 之前的版本中，max 的含义是 range 。要在这些版本中得到和上例相同 5 到 15 的随机数，简短的例子是 rand (5, 11)。

例子

本例会返回一些随机数：

<?php
echo(rand();
echo(rand();
echo(rand(10,100))
?>

输出：

17757
3794
97

PHP Math 函数

PHP 参考手册
PHP 测验


PHP range() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP range() 函数

PHP Array 函数

定义和用法

range() 函数创建并返回一个包含指定范围的元素的数组。

语法

range(first,second,step)
参数 | 描述
first | 必需。规定数组元素的最小值。
second | 必需。规定数组元素的最大值。
step | 可选。规定元素之间的步进制。默认是 1。 注释：该参数是 PHP 5 中加入的。

说明

该函数创建一个数组，包含从 first 到 second （包含 first 和 second）之间的整数或字符。如果 second 比 first 小，则返回反序的数组。

例子 1

<?php
$number = range(0,5);
print_r ($number);
?>

输出：

Array
(
[0] => 0
[1] => 1
[2] => 2
[3] => 3
[4] => 4
[5] => 5
)

例子 2

<?php
$number = range(0,50,10);
print_r ($number);
?>

输出：

Array
(
[0] => 0
[1] => 10
[2] => 20
[3] => 30
[4] => 40
[5] => 50
)

例子 3

<?php
$letter = range("a","d");
print_r ($letter);
?>

输出：

Array
(
[0] => a
[1] => b
[2] => c
[3] => d
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP readdir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP readdir() 函数

PHP Directory 函数

定义和用法

readdir() 函数返回由 opendir() 打开的目录句柄中的条目。

若成功，则该函数返回一个文件名，否则返回 false。

语法

readdir(dir_stream)
参数 | 描述
dir_stream | 必需。规定要使用的目录句柄。

说明

返回目录中下一个文件的文件名。文件名以在文件系统中的排序返回。

例子

<?php
//打开 images 目录
$dir = opendir("images");

//列出 images 目录中的文件
while (($file = readdir($dir)) !== false)
  {
  echo "filename: " . $file . "<br />";
  }
  closedir($dir);
?>

输出：

filename: .
filename: ..
filename: cat.gif
filename: dog.gif
filename: food
filename: horse.gif

PHP Directory 函数

PHP 参考手册
PHP 测验


PHP readfile() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP readfile() 函数

PHP Filesystem 函数

定义和用法

readfile() 函数输出一个文件。

该函数读入一个文件并写入到输出缓冲。

若成功，则返回从文件中读入的字节数。若失败，则返回 false。您可以通过 @readfile() 形式调用该函数，来隐藏错误信息。

语法

readfile(filename,include_path,context)
参数 | 描述
filename | 必需。规定要读取的文件。
include_path | 必需。如果也想在 include_path 中搜索文件，可以使用该参数并将其设为 true。
context | 必需。规定文件句柄的环境。Context 是可以修改流的行为的一套选项。

说明

对 context 参数的支持是 PHP 5.0.0 添加的。

提示和注释

提示：如果在 php.ini 文件中 "fopen wrappers" 已经被激活，则在本函数中可以把 URL 作为文件名来使用。

例子

<?php
echo readfile("test.txt");
?>

输出：

There are two lines in this file.
This is the last line.
57

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP readlink() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP readlink() 函数

PHP Filesystem 函数

定义和用法

readlink() 函数返回符号连接指向的目标。

若成功，则该函数返回连接的目标。若失败，则返回 false。

语法

readlink(linkpath)
参数 | 描述
linkpath | 必需。规定要检查的连接路径。

提示和注释

注释：本函数未在 Windows 平台下实现。。

例子

<?php
echo readlink("/user/testlink");
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP realpath() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP realpath() 函数

PHP Filesystem 函数

定义和用法

realpath() 函数返回绝对路径。

该函数删除所有符号连接（比如 '/./', '/../' 以及多余的 '/'），返回绝对路径名。

若失败，则返回 false。比如说文件不存在的话。

语法

readlink(linkpath)
参数 | 描述
linkpath | 必需。规定要检查的连接路径。

说明

在 BSD 系统上，如果仅仅是 linkpath 不存在的话，PHP 并不会像其它系统那样返回 false。

例子

<?php
echo realpath("test.txt");
?>

输出：

C:\Inetpub\testweb\test.txt

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP registerXPathNamespace() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP registerXPathNamespace() 函数

PHP SimpleXML 函数

定义和用法

registerXPathNamespace() 函数为下一次 XPath 查询创建命名空间语境。

语法

class SimpleXMLElement
{
string registerXPathNamespace(prefix,ns)
}
参数 | 描述
prefix | 必需。规定命名空间前缀。
ns | 必需。规定命名空间 URL。必须匹配 XML 文档中的命名空间。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note xmlns:b="http://www.w3school.com.cn/example/">
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<b:body>Don't forget the meeting!</b:body>
</note>

PHP 代码：

<?php
$xml = simplexml_load_file("test.xml");

$xml->registerXPathNamespace("msg", "http://www.w3school.com.cn/example/");
$result = $xml->xpath("msg:body");

foreach ($result as $message)
  {
  echo $message;
  }
?>

输出类似：

Don't forget the meeting!

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP rename() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP rename() 函数

PHP Filesystem 函数

定义和用法

rename() 函数重命名文件或目录。

若成功，则该函数返回 true。若失败，则返回 false。

语法

rename(oldname,newname,context)
参数 | 描述
oldname | 必需。规定要重命名的文件或目录。
newname | 必需。规定文件或目录的新名称。
context | 必需。规定文件句柄的环境。Context 是可修改流的行为的一套选项。

提示和注释

注释：在 PHP 4.3.3 之前，rename() 不能在基于 *nix 的系统中跨磁盘分区重命名文件。

注释：用于 oldname 中的封装协议必须和用于 newname 中的相匹配。

注释：对 context 的支持是 PHP 5.0.0 添加的。

例子

<?php
rename("images","pictures");
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP reset() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP reset() 函数

PHP Array 函数

定义和用法

reset() 函数把数组的内部指针指向第一个元素，并返回这个元素的值。

若失败，则返回 FALSE。

语法

reset(array)
参数 | 描述
array | 必需。规定要使用的数组。

例子

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");

echo current($people) . "<br />";
echo next($people) . "<br />";
echo reset($people);
?>

输出：

Peter
Joe
Peter

PHP Array 函数

PHP 参考手册
PHP 测验


PHP restore_error_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP restore_error_handler() 函数

PHP Error 和 Logging 函数

定义和用法

restore_error_handler() 函数恢复之前的错误处理程序，该程序是由 set_error_handler() 函数改变的。

该函数永远返回 true。

语法

restore_error_handler()

提示和注释

提示：之前的错误处理程序可能是在错误处理程序或用户自定义函数中构建的。

例子

<?php
//custom error handler function
function customError($errno, $errstr, $errfile, $errline)
 {
 echo "<b>Custom error:</b> [$errno] $errstr<br />";
 echo " Error on line $errline in $errfile<br />";
 }

//set user-defined error handler
set_error_handler("customError");

$test=2;

//trigger error
if ($test>1)
 {
 trigger_error("A custom error has been triggered");
 }

//restore built-in error handler
restore_error_handler

//trigger error again
if ($test>1)
 {
 trigger_error("A custom error has been triggered");
 }
?>

输出：

Custom error: [1024] A custom error has been triggered
Error on line 14 in C:\webfolder\test.php

Notice: A custom error has been triggered in
C:\webfolder\test.php on line 21

PHP Error 和 Logging 函数

PHP 参考手册
PHP 测验


PHP restore_exception_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP restore_exception_handler() 函数

PHP Error 和 Logging 函数

定义和用法

restore_exception_handler() 函数恢复之前的异常处理程序，该程序是由 set_exception_handler() 函数改变的。

该函数永远返回 true。

语法

restore_exception_handler()

提示和注释

提示：之前的异常处理程序可能是在异常处理程序或用户自定义函数中构建的。

例子

<?php
restore_exception_handler();

throw new Exception('Uncaught Exception occured');
?>

输出：

Fatal error: Uncaught exception 'Exception' with message
'Uncaught Exception occured' in C:\webfolder\test.php:4
Stack trace: #0 {main} thrown in C:\webfolder\test.php on line 4

PHP Error 和 Logging 函数

PHP 参考手册
PHP 测验


PHP rewind() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP rewind() 函数

PHP Filesystem 函数

定义和用法

rewind() 函数将文件指针的位置倒回文件的开头。

若成功，则返回 true。若失败，则返回 false。

语法

rewind(file)
参数 | 描述
file | 必需。规定已打开的文件。

例子

<?php
$file = fopen("test.txt","r");

//改变文件指针的位置
fseek($file,"15");

//把文件指针设定为 0
rewind($file);

fclose($file);
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP rewinddir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP rewinddir() 函数

PHP Directory 函数

定义和用法

rewinddir() 函数重置由 opendir() 打开的目录句柄。

本函数什么都不会返回。

语法

rewinddir(dir_stream)
参数 | 描述
dir_stream | 必需。规定要使用的目录句柄。

提示和注释

提示：本函数重读目录，并可用于检查目录中的变化。

例子

<?php
//打开 images 目录
$dir = opendir("images");

//列出 images 目录中的文件
while (($file = readdir($dir)) !== false)
  {
  echo "filename: " . $file . "<br />";
  }

//重置目录流
rewinddir($dir);

//供检查变化的代码

closedir($dir);
?>

PHP Directory 函数

PHP 参考手册
PHP 测验


PHP rmdir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP rmdir() 函数

PHP Filesystem 函数

定义和用法

rmdir() 函数删除空的目录。

若成功，则该函数返回 true。若失败，则返回 false。

语法

rmdir(dir,context)
参数 | 描述
dir | 必需。规定要删除的目录。
context | 必需。规定文件句柄的环境。Context 是可修改流的行为的一套选项。

说明

尝试删除 dir 所指定的目录。 该目录必须是空的，而且要有相应的权限。

提示和注释

注释：对 context 的支持是 PHP 5.0.0 添加的。

例子

<?php
$path = "images";
if(!rmdir($path))
  {
  echo ("Could not remove $path");
  }
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP round() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP round() 函数

PHP Math 函数

定义和用法

round() 函数对浮点数进行四舍五入。

语法

round(x,prec)
参数 | 描述
x | 可选。规定要舍入的数字。
prec | 可选。规定小数点后的位数。

说明

返回将 x 根据指定精度 prec （十进制小数点后数字的数目）进行四舍五入的结果。prec 也可以是负数或零（默认值）。

提示和注释

注释：PHP 默认不能正确处理类似 "12,300.2" 的字符串。

注释：prec 参数是在 PHP 4 中被引入的。。

例子

<?php
echo(round(0.60));
echo(round(0.50));
echo(round(0.49));
echo(round(-4.40));
echo(round(-4.60));
?>

输出：

1
1
0
-4
-5

PHP Math 函数

PHP 参考手册
PHP 测验


PHP rsort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP rsort() 函数

PHP Array 函数

定义和用法

rsort() 函数对数组的元素按照键值进行逆向排序。与 arsort() 的功能基本相同。

注释：该函数为 array 中的单元赋予新的键名。这将删除原有的键名而不仅是重新排序。

如果成功则返回 TRUE，否则返回 FALSE。

可选的第二个参数包含另外的排序标志。

语法

rsort(array,sorttype)
参数 | 描述
array | 必需。输入的数组。
sorttype

可选。规定如何排列数组的值。可能的值：

  • SORT_REGULAR - 默认。以它们原来的类型进行处理（不改变类型）。
  • SORT_NUMERIC - 把值作为数字来处理
  • SORT_STRING - 把值作为字符串来处理
  • SORT_LOCALE_STRING - 把值作为字符串来处理，基于本地设置*。

*：该值是 PHP 4.4.0 和 5.0.2 新加的。在 PHP 6 之前，使用了系统的区域设置，可以用 setlocale() 来改变。自 PHP 6 起，必须用 i18n_loc_set_default() 函数。

例子

<?php
$my_array = array("a" => "Dog", "b" => "Cat", "c" => "Horse");
rsort($my_array);
print_r($my_array);
?>

输出：

Array
(
[0] => Horse
[1] => Dog
[2] => Cat
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP rtrim() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP rtrim() 函数

PHP String 函数

定义和用法

chop() 函数从字符串的末端开始删除空白字符或其他预定义字符。

语法

rtrim(string,charlist)
参数 | 描述
string | 必需。规定要转换的字符串。
charlist

可选。规定从字符串中删除哪些字符。

如果未设置该参数，则全部删除以下字符：

  • "\0" - ASCII 0, NULL
  • "\t" - ASCII 9, 制表符
  • "\n" - ASCII 10, 新行
  • "\x0B" - ASCII 11, 垂直制表符
  • "\r" - ASCII 13, 回车
  • " " - ASCII 32, 空格

例子

在本例中，我们将使用 rtrim() 函数从字符串右端删除字符：

<?php
$str = "Hello World!\n\n";
echo $str;
echo rtrim($str);
?>

以上代码输出的源代码：

<html>

<body>
Hello World!

Hello World!</body>

</html>

输出：

Hello World! Hello World!

PHP String 函数

PHP 参考手册
PHP 测验


PHP scandir() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP scandir() 函数

PHP Directory 函数

定义和用法

scandir() 函数返回一个数组，其中包含指定路径中的文件和目录。

若成功，则返回一个数组，若失败，则返回 false。如果 directory 不是目录，则返回布尔值 false 并生成一条 E_WARNING 级的错误。

语法

scandir(directory,sort,context)
参数 | 描述
directory | 必需。规定要扫描的目录。
sort | 可选。规定排列顺序。默认是 0 （升序）。如果是 1，则为降序。
context | 可选。规定目录句柄的环境。context 是可修改目录流的行为的一套选项。

例子

<?php
print_r(scandir("images"));
?>

输出：

Array
(
[0] => .
[1] => ..
[2] => dog.jpg
[3] => house.jpg
[4] => logo.gif
)

PHP Directory 函数

PHP 参考手册
PHP 测验


PHP Sessions

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Sessions

  • Previous Page
  • Next Page

PHP session 变量用于存储有关用户会话的信息，或更改用户会话的设置。Session 变量保存的信息是单一用户的，并且可供应用程序中的所有页面使用。

PHP Session 变量

当您运行一个应用程序时，您会打开它，做些更改，然后关闭它。这很像一次会话。计算机清楚你是谁。它知道你何时启动应用程序，并在何时终止。但是在因特网上，存在一个问题：服务器不知道你是谁以及你做什么，这是由于 HTTP 地址不能维持状态。

通过在服务器上存储用户信息以便随后使用，PHP session 解决了这个问题（比如用户名称、购买商品等）。不过，会话信息是临时的，在用户离开网站后将被删除。如果您需要永久储存信息，可以把数据存储在数据库中。

Session 的工作机制是：为每个访问者创建一个唯一的 id (UID)，并基于这个 UID 来存储变量。UID 存储在 cookie 中，亦或通过 URL 进行传导。

开始 PHP Session

在您把用户信息存储到 PHP session 中之前，首先必须启动会话。

注释：session_start() 函数必须位于 <html> 标签之前：

<?php session_start(); ?>

<html>
<body>

</body>
</html>

上面的代码会向服务器注册用户的会话，以便您可以开始保存用户信息，同时会为用户会话分配一个 UID。

存储 Session 变量

存储和取回 session 变量的正确方法是使用 PHP $_SESSION 变量：

<?php
session_start();
// store session data
$_SESSION['views']=1;
?>

<html>
<body>

<?php
//retrieve session data
echo "Pageviews=". $_SESSION['views'];
?>

</body>
</html>

输出：

Pageviews=1

在下面的例子中，我们创建了一个简单的 page-view 计数器。isset() 函数检测是否已设置 "views" 变量。如果已设置 "views" 变量，我们累加计数器。如果 "views" 不存在，则我们创建 "views" 变量，并把它设置为 1：

<?php
session_start();

if(isset($_SESSION['views']))
  $_SESSION['views']=$_SESSION['views']+1;

else
  $_SESSION['views']=1;
echo "Views=". $_SESSION['views'];
?>

终结 Session

如果您希望删除某些 session 数据，可以使用 unset() 或 session_destroy() 函数。

unset() 函数用于释放指定的 session 变量：

<?php
unset($_SESSION['views']);
?>

您也可以通过 session_destroy() 函数彻底终结 session：

<?php
session_destroy();
?>

注释：session_destroy() 将重置 session，您将失去所有已存储的 session 数据。

  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP set_error_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP set_error_handler() 函数

PHP Error 和 Logging 函数

定义和用法

set_error_handler() 函数设置用户自定义的错误处理函数。

该函数用于创建运行时期间的用户自己的错误处理方法。

该函数会返回旧的错误处理程序，若失败，则返回 null。

语法

set_error_handler(error_function,error_types)
参数 | 描述
error_function | 必需。规定发生错误时运行的函数。
error_types | 可选。规定在哪个错误报告级别会显示用户定义的错误。默认是 "E_ALL"。

提示和注释

提示：如果使用了该函数，会完全绕过标准的 PHP 错误处理函数，如果必要，用户定义的错误处理程序必须终止 (die() ) 脚本。

注释：如果在脚本执行前发生错误，由于在那时自定义程序还没有注册，因此就不会用到这个自定义错误处理程序。

例子

<?php
//error handler function
function customError($errno, $errstr, $errfile, $errline)
 {
 echo "<b>Custom error:</b> [$errno] $errstr<br />";
 echo " Error on line $errline in $errfile<br />";
 echo "Ending Script";
 die();
 }

//set error handler
set_error_handler("customError");

$test=2;

//trigger error
if ($test>1)
 {
 trigger_error("A custom error has been triggered");
 }
?>

输出：

Custom error: [1024] A custom error has been triggered
Error on line 19 in C:\webfolder\test.php
Ending Script

PHP Error 和 Logging 函数

PHP 参考手册
PHP 测验


PHP set_exception_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP set_exception_handler() 函数

PHP Error 和 Logging 函数

定义和用法

set_exception_handler() 函数设置用户自定义的异常处理函数。

该函数用于创建运行时期间的用户自己的异常处理方法。

该函数会返回旧的异常处理程序，若失败，则返回 null。

语法

set_exception_handler(exception_function)
参数 | 描述
error_function | 必需。规定未捕获的异常发生时调用的函数。 该函数必须在调用 set_exception_handler() 函数之前定义。 这个异常处理函数需要需要一个参数，即抛出的 exception 对象。

提示和注释

提示：在这个异常处理程序被调用后，脚本会停止执行。

例子

<?php
function myException($exception)
{
echo "<b>Exception:</b> " , $exception->getMessage();
}

set_exception_handler('myException');

throw new Exception('Uncaught Exception occurred');
?>

输出：

Exception: Uncaught Exception occurred

PHP Error 和 Logging 函数

PHP 参考手册
PHP 测验


PHP set_exception_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP set_exception_handler() 函数

PHP Error 和 Logging 函数

定义和用法

trigger_error() 函数创建用户定义的错误消息。

trigger_error() 用于在用户指定的条件下触发一个错误消息。它与内建的错误处理器一同使用，也可以与由 set_error_handler() 函数创建的用户自定义函数使用。

如果指定了一个不合法的错误类型，该函数返回 false，否则返回 true。

语法

trigger_error(error_message,error_types)
参数 | 描述
error_message | 必需。规定错误消息。长度限制为 1024 个字符。
error_types 可选。规定错误消息的错误类型。 可能的值：
  • E_USER_ERROR
  • E_USER_WARNING
  • E_USER_NOTICE

例子

<?php
$test=2;
if ($test>1)
{
trigger_error("A custom error has been triggered");
}
?>

输出：

Notice: A custom error has been triggered
in C:\webfolder\test.php on line 6

PHP Error 和 Logging 函数

PHP 参考手册
PHP 测验


PHP set_file_buffer() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP set_file_buffer() 函数

PHP Filesystem 函数

定义和用法

set_file_buffer() 函数设置打开文件的缓冲大小。

若成功，则该函数返回 0。若失败，则返回 EOF。

语法

set_file_buffer(file,buffer)
参数 | 描述
file | 必需。规定打开的文件。
buffer | 必需。规定缓冲大小，以字节计。

提示和注释

注释：该函数是 stream_set_write_buffer() 的别名。

例子

创建无缓冲的流：

<?php
$file = fopen("test.txt","w");
if ($file)
  {
  set_file_buffer($file,0);
  fwrite($file,"Hello World. Testing!");
  fclose($file);
  }
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP setcookie() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP setcookie() 函数

PHP HTTP 函数

定义和用法

setcookie() 函数向客户端发送一个 HTTP cookie。

cookie 是由服务器发送到浏览器的变量。cookie 通常是服务器嵌入到用户计算机中的小文本文件。每当计算机通过浏览器请求一个页面，就会发送这个 cookie。

cookie 的名称指定为相同名称的变量。例如，如果被发送的 cookie 名为 "name"，会自动创建名为 $user 的变量，包含 cookie 的值。

必须在任何其他输出发送前对 cookie 进行赋值。

如果成功，则该函数返回 true，否则返回 false。

语法

setcookie(name,value,expire,path,domain,secure)
参数 | 描述
name | 必需。规定 cookie 的名称。
value | 必需。规定 cookie 的值。
expire | 可选。规定 cookie 的有效期。
path | 可选。规定 cookie 的服务器路径。
domain | 可选。规定 cookie 的域名。
secure | 可选。规定是否通过安全的 HTTPS 连接来传输 cookie。

提示和注释

注释：可以通过 $HTTP_COOKIE_VARS["user"] 或 $_COOKIE["user"] 来访问名为 "user" 的 cookie 的值。

注释：在发送 cookie 时，cookie 的值会自动进行 URL 编码。接收时会进行 URL 解码。如果你不需要这样，可以使用 setrawcookie() 代替。

例子

例子 1

设置并发送 cookie：

<?php
$value = "my cookie value";

// 发送一个简单的 cookie
setcookie("TestCookie",$value);
?>

<html>
<body>

...
...
<?php
$value = "my cookie value";

// 发送一个 24 小时候过期的 cookie
setcookie("TestCookie",$value, time()+3600*24);
?>

<html>
<body>

...
...

例子 2

检索 cookie 值的不同方法：

<html>
<body>

<?php

// 输出个别的 cookie
echo $_COOKIE["TestCookie"];
echo "<br />";
echo $HTTP_COOKIE_VARS["TestCookie"];
echo "<br />";

// 输出所有 cookie
print_r($_COOKIE);
?>

</body>
</html>

输出：

my cookie value
my cookie value
Array ([TestCookie] => my cookie value)

例子 3

通过把失效日期设置为过去的日期/时间，删除一个 cookie：

<?php
// 把失效日期设置为一小时前
setcookie ("TestCookie", "", time() - 3600);
?>

<html>
<body>

...
...

例子 4

创建一个数组 cookie：

<?php
setcookie("cookie[three]","cookiethree");
setcookie("cookie[two]","cookietwo");
setcookie("cookie[one]","cookieone");

// 输出 cookie （在重载页面后）
if (isset($_COOKIE["cookie"]))
  {
  foreach ($_COOKIE["cookie"] as $name => $value)
    {
    echo "$name : $value <br />";
    }
  }
?>

<html>
<body>

...
...

输出：

three : cookiethree
two : cookietwo
one : cookieone

PHP HTTP 函数

PHP 参考手册
PHP 测验


PHP setlocale() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP setlocale() 函数

PHP String 函数

定义和用法

setlocale() 函数设置地区信息（地域信息）。

地区信息是针对一个地理区域的语言、货币、时间以及其他信息。

该函数返回当前的地区设置，若失败则返回 false。

语法

setlocale(constant,location)
参数 描述
constant

必需。规定应该设置什么地区信息。

可用的常量：

  • LC_ALL - 包括下面的所有选项
  • LC_COLLATE -排序次序
  • LC_CTYPE - 字符类别及转换（例如所有字符大写或小写）
  • LC_MESSAGES - 系统消息格式
  • LC_MONETARY - 货币格式
  • LC_NUMERIC - 数字格式
  • LC_TIME - 日期/时间格式
location

必需。规定把地区信息设置为什么国家/地区。如果 location 参数是数组，setlocale() 会尝试每个数组元素，直到找到合法的语言或地区代码为止。如果某个地区在不同的系统上拥有不同的名称，这一点很有用。

注释：在此查找语言和地区代码。

提示和注释

注释：setlocale() 函数仅针对当前脚本改变地区信息。

提示：可以通过 setlocale(LC_ALL,NULL) 把地区信息设置为系统默认。

例子

在本例中，我们将把 locale 设置为 US English，然后再设置回系统默认：

<?php
echo setlocale(LC_ALL,"En-Us");
echo setlocale(LC_ALL,NULL);
?>

PHP String 函数

PHP 参考手册
PHP 测验


PHP setrawcookie() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP setrawcookie() 函数

PHP HTTP 函数

定义和用法

setrawcookie() 函数不对 cookie 值进行 URL 编码，发送一个 HTTP cookie。

cookie 是由服务器发送到浏览器的变量。cookie 通常是服务器嵌入到用户计算机中的小文本文件。每当计算机通过浏览器请求一个页面，就会发送这个 cookie。

cookie 的名称指定为相同名称的变量。例如，如果被发送的 cookie 名为 "name"，会自动创建名为 $user 的变量，包含 cookie 的值。

必须在任何其他输出发送前对 cookie 进行赋值。

如果成功，则该函数返回 true，否则返回 false。

语法

setcookie(name,value,expire,path,domain,secure)
参数 | 描述
name | 必需。规定 cookie 的名称。
value | 必需。规定 cookie 的值。
expire | 可选。规定 cookie 的有效期。
path | 可选。规定 cookie 的服务器路径。
domain | 可选。规定 cookie 的域名。
secure | 可选。规定是否通过安全的 HTTPS 连接来传输 cookie。

提示和注释

注释：可以通过 $HTTP_COOKIE_VARS["user"] 或 $_COOKIE["user"] 来访问名为 "user" 的 cookie 的值。

注释：setrawcookie() 与 setcookie() 几乎完全相同，不同的是不会在发往客户机时，对 cookie 值进行自动 URL 编码。

例子

例子 1

设置并发送 cookie：

<?php
$value = "my cookie value";

// 发送一个简单的 cookie
setrawcookie("TestCookie",$value);
?>

<html>
<body>

...
...
<?php
$value = "my cookie value";

// 发送一个 24 小时候过期的 cookie
setrawcookie("TestCookie",$value, time()+3600*24);
?>

<html>
<body>

...
...

例子 2

检索 cookie 值的不同方法：

<html>
<body>

<?php

// 输出个别的 cookie
echo $_COOKIE["TestCookie"];
echo "<br />";
echo $HTTP_COOKIE_VARS["TestCookie"];
echo "<br />";

// 输出所有 cookie
print_r($_COOKIE);
?>

</body>
</html>

输出：

my cookie value
my cookie value
Array ([TestCookie] => my cookie value)

例子 3

通过把失效日期设置为过去的日期/时间，删除一个 cookie：

<?php
// 把失效日期设置为一小时前
setrawcookie ("TestCookie", "", time() - 3600);
?>

<html>
<body>

...
...

例子 4

创建一个数组 cookie：

<?php
setrawcookie("cookie[three]","cookiethree");
setrawcookie("cookie[two]","cookietwo");
setrawcookie("cookie[one]","cookieone");

// 输出 cookie （在重载页面后）
if (isset($_COOKIE["cookie"]))
  {
  foreach ($_COOKIE["cookie"] as $name => $value)
    {
    echo "$name : $value <br />";
    }
  }
?>

<html>
<body>

...
...

输出：

three : cookiethree
two : cookietwo
one : cookieone

PHP HTTP 函数

PHP 参考手册
PHP 测验


PHP sha1_file() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP sha1_file() 函数

PHP String 函数

定义和用法

sha1_file() 函数计算文件的 SHA-1 散列。

sha1() 函数使用美国 Secure Hash 算法 1。

如果成功，则返回所计算的 SHA-1 散列，如果失败，则返回 false。

语法

sha1_file(file,raw)
参数 | 描述
string | 必需。规定要计算的文件。
charlist

可选。规定十六进制或二进制输出格式：

  • TRUE - 原始 20 字符二进制格式
  • FALSE - 默认。40 字符十六进制数

注释：该参数是 PHP 5.0 中添加的。

例子

例子 1

<?php
$filename = "test.txt";
$sha1file = sha1_file($filename);
echo $sha1file;
?>

输出：

aaf4c61ddcc5e8a2dabede0f3b482cd9aea9434d

例子 2

在一个文件中存储 "test.txt" 的 SHA-1 散列：

<?php
$sha1file = sha1_file("test.txt");
file_put_contents("sha1file.txt",$sha1file);
?>

在本例中，我们将测试 "test.txt" 是否已更改（即 SHA-1 hash 是否已更改）：

<?php
$sha1file = file_get_contents("sha1file.txt");
if (sha1_file("test.txt") == $sha1file)
  {
  echo "The file is ok.";
  }
else
  {
  echo "The file has been changed.";
  }
?>

输出：

The file is ok.

PHP String 函数

PHP 参考手册
PHP 测验


PHP sha1() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP sha1() 函数

PHP String 函数

定义和用法

sha1() 函数计算字符串的 SHA-1 散列。

sha1() 函数使用美国 Secure Hash 算法 1。

如果成功，则返回所计算的 SHA-1 散列，如果失败，则返回 false。

语法

sha1(string,raw)
参数 | 描述
string | 必需。规定要计算的字符串。
charlist

可选。规定十六进制或二进制输出格式：

  • TRUE - 原始 20 字符二进制格式
  • FALSE - 默认。40 字符十六进制数

注释：该参数是 PHP 5.0 中添加的。

例子

例子 1

<?php
$str = 'Hello';
echo sha1($str);
?>

输出：

f7ff9e8b7bb2e09b70935a5d785e0cc5d9d0abf0

例子 2

在本例中，我们将输出 sha1() 的结果，然后对其测试：

<?php
$str = 'Hello';
echo sha1($str);

if (sha1($str) == 'f7ff9e8b7bb2e09b70935a5d785e0cc5d9d0abf0')
  {
  echo "<br />Hello world!";
  exit;
  }
?>

输出：

f7ff9e8b7bb2e09b70935a5d785e0cc5d9d0abf0
Hello world!

PHP String 函数

PHP 参考手册
PHP 测验


PHP show_source() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP show_source() 函数

PHP 杂项函数

定义和用法

show_source() 函数对文件进行语法高亮显示。

本函数是 highlight_file() 的别名。

语法

show_source(filename,return)
参数 | 描述
filename | 必需。要进行高亮处理的 PHP 文件的路径。
return | 可选。如果设置 true，则本函数返回高亮处理的代码。

说明

本函数通过使用 PHP 语法高亮程序中定义的颜色，输出或返回包含在 filename 中的代码的语法高亮版本。

许多服务器被配置为对带有 phps 后缀的文件进行自动高亮处理。例如，在查看 example.phps 时，将显示该文件被语法高亮显示的源代码。要启用该功能，请把下面这一行添加到 httpd.conf：

AddType application/x-httpd-php-source .phps

返回值

如果 return 参数被设置为 true，那么该函数会返回被高亮处理的代码，而不是输出它们。否则，若成功，则返回 true，失败则返回 false。

提示和注释

警告：需要注意的是，在使用 show_source() 函数时，请不要因为疏忽而泄露诸如密码或其他类型的敏感信息，否则会出现潜在的安全风险。

例子

"test.php":

<html>
<body>
<?php
show_source("test.php");
?>
</body>
</html>

输出：

<html>
<body>
<?php
show_source("test.php");
?>
</body>
</html>

在浏览器中查看的结果类似这样：

<html>
<body>
<code>
<span style="color: #000000">&lt;html&gt;
<br />
&lt;body&gt;
<br />
<span style="color: #0000BB">&lt;?php
<br />show_source</span>
<span style="color: #007700">(</span>
<span style="color: #DD0000">"test.php"</span>
<span style="color: #007700">);<br /></span>
<span style="color: #0000BB">?&gt;<br /></span>
&lt;/body&gt;
<br />
&lt;/html&gt;</span>
</code>
</body>
</html>

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP shuffle() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP shuffle() 函数

PHP Array 函数

定义和用法

shuffle() 函数把数组中的元素按随机顺序重新排列。

若成功，则返回 TRUE，否则返回 FALSE。

注释：本函数为数组中的单元赋予新的键名。这将删除原有的键名而不仅是重新排序。

注释：自 PHP 4.2.0 起，不再需要用 srand() 或 mt_srand() 函数给随机数发生器播种，现已被自动完成。

语法

shuffle(array)
参数 | 描述
array | 必需。规定要使用的数组。

例子

<?php
$my_array = array("a" => "Dog", "b" => "Cat", "c" => "Horse");
shuffle($my_array);
print_r($my_array);
?>

输出：

Array ( [0] => Cat [1] => Horse [2] => Dog )

PHP Array 函数

PHP 参考手册
PHP 测验


PHP similar_text() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP similar_text() 函数

PHP String 函数

定义和用法

similar_text() 函数计算两个字符串的匹配字符的数目。

该函数也可以计算两个字符串的相似度（以百分比计）。

语法

similar_text(string1,string2,percent)
参数 | 描述
string1 | 必需。规定要比较的第一个字符串。
string2 | 必需。规定要比较的第二个字符串。
percent | 可选。规定供存储百分比相似度的变量名。

提示和注释

注释： levenshtein() 函数比 similar_text() 函数更快。不过，similar_text() 函数通过更少的必需修改次数提供更精确的结果。

例子

例子 1

<?php
echo similar_text("Hello World","Hello Peter");
?>

输出：

7

例子 2

<?php
similar_text("Hello World","Hello Peter",$percent);
echo $percent;
?>

输出：

63.6363636364

PHP String 函数

PHP 参考手册
PHP 测验


PHP SimpleXML

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP SimpleXML

  • Previous Page
  • Next Page

SimpleXML 处理最普通的 XML 任务，其余的任务则交由其它扩展。

什么是 SimpleXML？

SimpleXML 是 PHP 5 中的新特性。在了解 XML 文档 layout 的情况下，它是一种取得元素属性和文本的便利途径。

与 DOM 或 Expat 解析器相比，SimpleXML 仅仅用几行代码就可以从元素中读取文本数据。

SimpleXML 可把 XML 文档转换为对象，比如：

  • 元素 - 被转换为 SimpleXMLElement 对象的单一属性。当同一级别上存在多个元素时，它们会被置于数组中。
  • 属性 - 通过使用关联数组进行访问，其中的下标对应属性名称。
  • 元素数据 - 来自元素的文本数据被转换为字符串。如果一个元素拥有多个文本节点，则按照它们被找到的顺序进行排列。

当执行类似下列的基础任务时，SimpleXML 使用起来非常快捷：

  • 读取 XML 文件
  • 从 XML 字符串中提取数据
  • 编辑文本节点或属性

不过，在处理高级 XML 时，比如命名空间，最好使用 Expat 解析器或 XML DOM。

安装

从 PHP 5.0 开始，SimpleXML 函数是 PHP 核心的组成部分。无需安装就可以使用这些函数。

使用 SimpleXML

下面是 XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

我们打算从上面的 XML 文件输出元素的名称和数据。

这是需要做的事情：

  1. 加载 XML 文件
  2. 取得第一个元素的名称
  3. 使用 children() 函数创建在每个子节点上触发的循环
  4. 输出每个子节点的元素名称和数据

例子

<?php
$xml = simplexml_load_file("test.xml");

echo $xml->getName() . "<br />";

foreach($xml->children() as $child)
  {
  echo $child->getName() . ": " . $child . "<br />";
  }
?>

以上代码的输出：

note
to: George
from: John
heading: Reminder
body: Don't forget the meeting!

更多有关 PHP SimpleXML 的信息

如需更多有关 PHP SimpleXML 的信息，请访问我们的 PHP SimpleXML 参考手册。

  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP simplexml_import_dom() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP simplexml_import_dom() 函数

PHP SimpleXML 函数

定义和用法

simplexml_import_dom() 函数把 DOM 节点转换为 SimpleXMLElement 对象。

如果失败，则该函数返回 false。

语法

simplexml_import_dom(data,class)
参数 | 描述
data | 必需。规定要使用的 DOM 节点。
class | 必需。规定新对象的 class。

例子

<?php
$dom = new domDocument;
$dom->loadXML('<note><from>John</from></note>');

$xml = simplexml_import_dom($dom);

echo $xml->from;
?>

输出类似：

John

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP simplexml_load_file() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP simplexml_load_file() 函数

PHP SimpleXML 函数

定义和用法

simplexml_load_file() 函数把 XML 文档载入对象中。

如果失败，则返回 false。

语法

simplexml_load_file(file,class,options,ns,is_prefix)
参数 | 描述
file | 必需。规定要使用的 XML 文档。
class | 可选。规定新对象的 class。
options | 可选。规定附加的 Libxml 参数。
ns | 可选。
is_prefix | 可选。

返回值

返回类 SimpleXMLElement 的一个对象，该对象的属性包含 XML 文档中的数据。如果失败，则返回 false。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP 代码：

<?php
if (file_exists('test.xml'))
  {
  $xml = simplexml_load_file('test.xml');
  var_dump($xml);
  }

else
  {
  exit('Error.');
  }
?>

输出：

object(SimpleXMLElement)#1 (4)
{
["to"]=> string(4) "George"
["from"]=> string(4) "John"
["heading"]=> string(8) "Reminder"
["body"]=> string(29) "Don't forget the meeting!"
}

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP simplexml_load_string() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP simplexml_load_string() 函数

PHP SimpleXML 函数

定义和用法

simplexml_load_string() 函数把 XML 字符串载入对象中。

如果失败，则返回 false。

语法

simplexml_load_file(string,class,options,ns,is_prefix)
参数 | 描述
string | 必需。规定要使用的 XML 字符串。
class | 可选。规定新对象的 class。
options | 可选。规定附加的 Libxml 参数。
ns | 可选。
is_prefix | 可选。

返回值

返回类 SimpleXMLElement 的一个对象，该对象的属性包含 XML 文档中的数据。如果失败，则返回 false。

例子

<?php
$xmlstring = <<<XML
<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>
XML;

$xml = simplexml_load_string($xmlstring);

var_dump($xml);
?>

输出：

object(SimpleXMLElement)#1 (4)
{
["to"]=> string(4) "George"
["from"]=> string(4) "John"
["heading"]=> string(8) "Reminder"
["body"]=> string(29) "Don't forget the meeting!"
}

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP SimpleXML 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP SimpleXML 函数

  • Previous Page
  • Next Page

PHP SimpleXML 简介

SimpleXML 函数允许您把 XML 转换为对象。

通过普通的属性选择器或数组迭代器，可以处理这个对象，就像处理任何其他对象一样。

其中的一些函数需要最新的 PHP 版本。

安装

SimpleXML 函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

PHP SimpleXML 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
__construct() | 创建一个新的 SimpleXMLElement 对象。 | 5
addAttribute() | 给 SimpleXML 元素添加一个属性。 | 5
addChild() | 给 SimpleXML 元素添加一个子元素。 | 5
asXML() | 从 SimpleXML 元素获取 XML 字符串。 | 5
attributes() | 获取 SimpleXML 元素的属性。 | 5
children() | 获取指定节点的子。 | 5
getDocNamespaces() | 获取 XML 文档的命名空间。 | 5
getName() | 获取 SimpleXML 元素的名称。 | 5
getNamespaces() | 从 XML 数据获取命名空间。 | 5
registerXPathNamespace() | 为下一次 XPath 查询创建命名空间语境。 | 5
simplexml_import_dom() | 从 DOM 节点获取 SimpleXMLElement 对象。 | 5
simplexml_load_file() | 从 XML 文档获取 SimpleXMLElement 对象。 | 5
simplexml_load_string() | 从 XML 字符串获取 SimpleXMLElement 对象。 | 5
xpath() | 对 XML 数据运行 XPath 查询。 | 5

PHP SimpleXML 常量

无。

  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP sin() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP sin() 函数

PHP Math 函数

定义和用法

sin() 函数返回一个数的正弦。

语法

sin(x)
参数 | 描述
x | 必需。一个数。

说明

sin() 返回参数 x 的正弦值。参数 x 的单位为弧度。

提示和注释

注释：sin() 函数返回的数值介于 -1 和 1 之间。

例子

在本例中，我们将计算不同值的正弦：

<?php
echo(sin(3));
echo(sin(-3));
echo(sin(0));
echo(sin(M_PI));
echo(sin(M_PI_2))
?>

输出：

0.14112000806
-0.14112000806
0
1.22460635382E-016
1

PHP Math 函数

PHP 参考手册
PHP 测验


PHP sinh() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP sinh() 函数

PHP Math 函数

定义和用法

sinh() 函数返回一个数的双曲正弦。

语法

sinh(x)
参数 | 描述
x | 必需。一个数字。

说明

返回 x 的双曲正弦值，定义为 (exp(arg) - exp(-arg))/2。

例子

在本例中，我们将返回不同数的双曲正弦：

<?php
echo(sinh(3));
echo(sinh(-3));
echo(sinh(0));
echo(sinh(M_PI));
echo(sinh(M_PI_2));
?>

输出：

10.0178749274
-10.0178749274
0
11.5487393573
2.30129890231

PHP Math 函数

PHP 参考手册
PHP 测验


PHP sizeof() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP sizeof() 函数

PHP Array 函数

定义和用法

sizeof() 函数计算数组中的单元数目或对象中的属性个数。

该函数是 count() 的别名。

语法

sizeof(array,mode)
参数 | 描述
array | 必需。规定要计数的数组或对象。
mode

可选。规定函数的模式。可能的值：

  • 0 - 默认。不检测多维数组（数组中的数组）。
  • 1 - 检测多维数组。

注释：该参数是 PHP 4.2 中加入的。

提示和注释

注释：当变量未被设置，或是变量包含一个空的数组，该函数会返回 0。可使用 isset() 变量来测试变量是否被设置。

例子

<?php
$people = array("Peter", "Joe", "Glenn", "Cleveland");
$result = sizeof($people);

echo $result;
?>

输出：

4

PHP Array 函数

PHP 参考手册
PHP 测验


PHP sleep() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP sleep() 函数

PHP 杂项函数

定义和用法

sleep() 函数延迟代码执行若干秒。

语法

sleep(seconds)
参数 | 描述
seconds | 必需。以秒计的暂停时间。

返回值

若成功，返回 0，否则返回 false。

错误／异常

如果指定的描述 seconds 是负数，该函数将生成一个 E_WARNING。

例子

<?php
echo date('h:i:s') . "<br />";

//暂停 10 秒
sleep(10);

//重新开始
echo date('h:i:s');

?>

输出：

12:00:08
12:00:18

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP sort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP sort() 函数

PHP Array 函数

定义和用法

sort() 函数按升序对给定数组的值排序。

注释：本函数为数组中的单元赋予新的键名。原有的键名将被删除。

如果成功则返回 TRUE，否则返回 FALSE。

语法

sort(array,sorttype)
参数 | 描述
array | 必需。输入的数组。
sorttype

可选。规定如何排列数组的值。可能的值：

  • SORT_REGULAR - 默认。以它们原来的类型进行处理（不改变类型）。
  • SORT_NUMERIC - 把值作为数字来处理
  • SORT_STRING - 把值作为字符串来处理
  • SORT_LOCALE_STRING - 把值作为字符串来处理，基于本地设置*。

*：该值是 PHP 4.4.0 和 5.0.2 新加的。在 PHP 6 之前，使用了系统的区域设置，可以用 setlocale() 来改变。自 PHP 6 起，必须用 i18n_loc_set_default() 函数。

例子

<?php
$my_array = array("a" => "Dog", "b" => "Cat", "c" => "Horse");

sort($my_array);
print_r($my_array);
?>

输出：

Array
(
0] => Cat
[1] => Dog
[2] => Horse
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP soundex() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP soundex() 函数

PHP String 函数

定义和用法

soundex() 函数计算字符串的 soundex 键。

soundex 键是 4 字符长的字母数字字符串，表示一个单词的英文发音。

soundex() 函数可用于拼写检查程序。

如果成功，则返回字符串的 soundex 键，如果失败，则返回 false。

语法

soundex(string)
参数 | 描述
string | 必需。规定要检查的字符串。
提示和注释

注释：soundex() 为发音相似的单词创建相同的键。

提示： metaphone() 比 soundex() 函数更精确，因为 metaphone() 了解基本的英语发音规则。

例子

例子 1

<?php
$str = "hello";
echo soundex($str);
?>

输出：

H400

例子 2

在本例中，我们对两个发音相似的单词应用 soundex() 函数：

<?php
$str = "Sun";
$str2 = "Son";

echo soundex($str);
echo "<br />";
echo soundex($str2);
?>

输出：

S500
S500

PHP String 函数

PHP 参考手册
PHP 测验


PHP sprintf() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP sprintf() 函数

PHP String 函数

定义和用法

sprintf() 函数把格式化的字符串写写入一个变量中。

语法

sprintf(format,arg1,arg2,arg++)
参数 | 描述
format | 必需。转换格式。
arg1 | 必需。规定插到 format 字符串中第一个 % 符号处的参数。
arg2 | 可选。规定插到 format 字符串中第二个 % 符号处的参数。
arg++ | 可选。规定插到 format 字符串中第三、四等等 % 符号处的参数。

说明

参数 format 是转换的格式，以百分比符号 ("%") 开始到转换字符结束。下面的可能的 format 值：

  • %% - 返回百分比符号
  • %b - 二进制数
  • %c - 依照 ASCII 值的字符
  • %d - 带符号十进制数
  • %e - 可续计数法（比如 1.5e+3）
  • %u - 无符号十进制数
  • %f - 浮点数(local settings aware)
  • %F - 浮点数(not local settings aware)
  • %o - 八进制数
  • %s - 字符串
  • %x - 十六进制数（小写字母）
  • %X - 十六进制数（大写字母）

arg1, arg2, ++ 等参数将插入到主字符串中的百分号 (%) 符号处。该函数是逐步执行的。在第一个 % 符号中，插入 arg1，在第二个 % 符号处，插入 arg2，依此类推。

提示和注释

注释：如果 % 符号多于 arg 参数，则您必须使用占位符。占位符插到 % 符号后面，由数字和 "\$" 组成。请参见例子 3。

提示：
相关函数：
fprintf()、
printf()、
vfprintf()、
vprintf() 以及
vsprintf()。

例子

例子 1

<?php
$str = "Hello";
$number = 123;
$txt = sprintf("%s world. Day number %u",$str,$number);
echo $txt;
?>

输出：

Hello world. Day number 123

例子 2

<?php
$number = 123;
$txt = sprintf("%f",$number);
echo $txt;
?>

输出：

123.000000

例子 3

<?php
$number = 123;
$txt = sprintf("With 2 decimals: %1\$.2f<br />With no decimals: %1\$u",$number);
echo $txt;
?>

输出：

With 2 decimals: 123.00
With no decimals: 123

PHP String 函数

PHP 参考手册
PHP 测验


PHP sqrt() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP sqrt() 函数

PHP Math 函数

定义和用法

sqrt() 函数返回一个数的平方根。

语法

sqrt(x)
参数 | 描述
x | 必需。一个数字。

说明

返回 x 的平方根。

提示和注释

注释：如果参数 x 是负数，则 sqrt() 函数返回 -1.#IND。

例子

在本例中，我们将返回不同数的平方根：

<?php
echo(sqrt(0));
echo(sqrt(1));
echo(sqrt(9));
echo(sqrt(0.64));
echo(sqrt(-9));
?>

输出：

0
1
3
0.8
-1.#IND

PHP Math 函数

PHP 参考手册
PHP 测验


PHP srand() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP srand() 函数

PHP Math 函数

定义和用法

srand() 函数播下随机数发生器种子。

语法

srand(seed)
参数 | 描述
seed | 可选。用 seed 播下随机数发生器种子。

说明

从 PHP 4.2.0 版开始，seed 参数变为可选项，当该项为空时，会被设为随时数。

提示和注释

注释：自 PHP 4.2.0 起，不再需要用 srand() 或 mt_srand() 函数给随机数发生器播种，现在已自动完成。

例子

在本例中，我们将播种随机数发生器：

<?php
srand(mktime());
echo(rand());
?>

输出：

23054

PHP Math 函数

PHP 参考手册
PHP 测验


PHP sscanf() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP sscanf() 函数

PHP String 函数

定义和用法

sscanf() 函数根据指定的格式解析来自一个字符串的输入。

如果只向该函数传递两个参数，数据将以数组的形式返回。否则，如果传递了额外的参数，那么被解析的数据会存储在这些参数中。如果区分符的数目大于包含它们的变量的数目，则会发生错误。不过，如果区分符少于变量，则额外的变量包含 NULL。

语法

sscanf(string,format,arg1,arg2,arg++)
参数 | 描述
string | 必需。规定要读取的字符串。
format | 必需。规定要使用的格式。
arg1 | 可选。存储数据的第一个变量。
arg2 | 可选。存储数据的第二个变量。
arg++ | 可选。存储数据的第三、四个变量。依此类推。

说明

参数 format 是转换的格式，以百分比符号 ("%") 开始到转换字符结束。下面的可能的 format 值：

  • %% - 返回百分比符号
  • %b - 二进制数
  • %c - 依照 ASCII 值的字符
  • %d - 带符号十进制数
  • %e - 可续计数法（比如 1.5e+3）
  • %u - 无符号十进制数
  • %f - 浮点数(local settings aware)
  • %F - 浮点数(not local settings aware)
  • %o - 八进制数
  • %s - 字符串
  • %x - 十六进制数（小写字母）
  • %X - 十六进制数（大写字母）

例子

<?php
$string = "age:30 weight:60kg";
sscanf($string,"age:%d weight:%dkg",$age,$weight);
// show types and values
var_dump($age,$weight);
?>

输出：

int(30)
int(60)

PHP String 函数

PHP 参考手册
PHP 测验


PHP stat() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP stat() 函数

PHP Filesystem 函数

定义和用法

stat() 函数返回关于文件的信息。

语法

fstat(file)
参数 | 描述
file | 必需。规定要检查的文件。

说明

获取由 file 指定的文件的统计信息。如果 file 是符号连接，则统计信息是关于被连接文件本身的，而不是符号连接。

如果出错，stat() 返回 false，并且发出一条警告。

返回的数组包含有文件的统计信息，该数组具有以下列出的单元，数组下标从零开始。除了数字索引之外，从 PHP 4.0.6 起还可以通过关联索引来访问。

stat() 的返回格式

数字下标 | 关联键名（自 PHP 4.0.6） | 说明
0 | dev | 设备名
1 | ino | 号码
2 | mode | inode 保护模式
3 | nlink | 被连接数目
4 | uid | 所有者的用户 id
5 | gid | 所有者的组 id
6 | rdev | 设备类型，如果是 inode 设备的话
7 | size | 文件大小的字节数
8 | atime | 上次访问时间（Unix 时间戳）
9 | mtime | 上次修改时间（Unix 时间戳）
10 | ctime | 上次改变时间（Unix 时间戳）
11 | blksize | 文件系统 IO 的块大小
12 | blocks | 所占据块的数目

提示和注释

提示： lstat() 与 stat() 类似，不同的是，它会返回符号连接的状态。

注释：本函数的结果会被缓存。请使用 clearstatcache() 来清除缓存。

例子

<?php
$file = fopen("test.txt","r");
print_r(stat($file));
fclose($file);
?>

输出类似：

Array
(
[0] => 0
[1] => 0
[2] => 33206
[3] => 1
[4] => 0
[5] => 0
[6] => 0
[7] => 92
[8] => 1141633430
[9] => 1141298003
[10] => 1138609592
[11] => -1
[12] => -1
[dev] => 0
[ino] => 0
[mode] => 33206
[nlink] => 1
[uid] => 0
[gid] => 0
[rdev] => 0
[size] => 92
[atime] => 1141633430
[mtime] => 1141298003
[ctime] => 1138609592
[blksize] => -1
[blocks] => -1
)

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP str_ireplace() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP str_ireplace() 函数

PHP String 函数

定义和用法

str_ireplace() 函数使用一个字符串替换字符串中的另一些字符。

语法

str_ireplace(find,replace,string,count)
参数 | 描述
find | 必需。规定要查找的值。
replace | 必需。规定替换 find 中的值的值。
string | 必需。规定被搜索的字符串。
count | 可选。一个变量，对替换数进行计数。

提示和注释

注释：该函数对大小写敏感。请使用 str_replace() 执行对大小写不敏感的搜索。

注释：该函数是二进制安全的。

例子

例子 1

<?php
echo str_ireplace("world","John","Hello world!");
?>

输出：

Hello John!

例子 2

在本例中，我们将演示带有数组和 count 变量的 str_ireplace() 函数：

<?php
$arr = array("blue","red","green","yellow");
print_r(str_ireplace("red","pink",$arr,$i));
echo "Replacements: $i";
?>

输出：

Array
(
[0] => blue
[1] => pink
[2] => green
[3] => yellow
)
Replacements: 1

例子 3

<?php
$find = array("Hello","world");
$replace = array("B");
$arr = array("Hello","world","!");
print_r(str_ireplace($find,$replace,$arr));
?>

输出：

Array
(
[0] => B
[1] =>
[2] => !
)

PHP String 函数

PHP 参考手册
PHP 测验


PHP str_pad() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP str_pad() 函数

PHP String 函数

定义和用法

str_pad() 函数把字符串填充为指定的长度。

语法

str_pad(string,length,pad_string,pad_type)
参数 | 描述
string | 必需。规定要填充的字符串。
length | 必需。规定新字符串的长度。如果该值小于原始字符串的长度，则不进行任何操作。
pad_string | 可选。规定供填充使用的字符串。默认是空白。
pad_type

可选。规定填充字符串的那边。

可能的值：

  • STR_PAD_BOTH - 填充到字符串的两头。如果不是偶数，则右侧获得额外的填充。
  • STR_PAD_LEFT - 填充到字符串的左侧。
  • STR_PAD_RIGHT - 填充到字符串的右侧。这是默认的。

例子

例子 1

<?php
$str = "Hello World";
echo str_pad($str,20,".");
?>

输出：

Hello World.........

例子 2

<?php
$str = "Hello World";
echo str_pad($str,20,".",STR_PAD_LEFT);
?>

输出：

.........Hello World

例子 3

<?php
$str = "Hello World";
echo str_pad($str,20,".:",STR_PAD_BOTH);
?>

输出：

.:.:Hello World.:.:.

PHP String 函数

PHP 参考手册
PHP 测验


PHP str_repeat() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP str_repeat() 函数

PHP String 函数

定义和用法

str_repeat() 函数把字符串重复指定的次数。

语法

str_repeat(string,repeat)
参数 | 描述
string | 必需。规定要重复的字符串。
repeat | 必需。规定字符串将被重复的次数。必须大于等于 0。

例子

<?php
echo str_repeat(".",13);
?>

输出：

.............

PHP String 函数

PHP 参考手册
PHP 测验


PHP str_replace() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP str_replace() 函数

PHP String 函数

定义和用法

str_replace() 函数使用一个字符串替换字符串中的另一些字符。

语法

str_replace(find,replace,string,count)
参数 | 描述
find | 必需。规定要查找的值。
replace | 必需。规定替换 find 中的值的值。
string | 必需。规定被搜索的字符串。
count | 可选。一个变量，对替换数进行计数。

提示和注释

注释：该函数对大小写敏感。请使用 str_ireplace() 执行对大小写不敏感的搜索。

注释：该函数是二进制安全的。

例子

例子 1

<?php
echo str_replace("world","John","Hello world!");
?>

输出：

Hello John!

例子 2

在本例中，我们将演示带有数组和 count 变量的 str_replace() 函数：

<?php
$arr = array("blue","red","green","yellow");
print_r(str_replace("red","pink",$arr,$i));
echo "Replacements: $i";
?>

输出：

Array
(
[0] => blue
[1] => pink
[2] => green
[3] => yellow
)
Replacements: 1

例子 3

<?php
$find = array("Hello","world");
$replace = array("B");
$arr = array("Hello","world","!");
print_r(str_replace($find,$replace,$arr));
?>

输出：

Array
(
[0] => B
[1] =>
[2] => !
)

PHP String 函数

PHP 参考手册
PHP 测验


PHP str_rot13() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP str_rot13() 函数

PHP String 函数

定义和用法

str_rot13() 函数对字符串执行 ROT13 编码。

ROT-13 编码是一种每一个字母被另一个字母代替的方法。这个代替字母是由原来的字母向前移动 13 个字母而得到的。数字和非字母字符保持不变。

语法

str_rot13(string)
参数 | 描述
string | 必需。规定要编码的字符串。

提示和注释

提示：编码和解码都是由相同的函数完成的。如果您把一个已编码的字符串作为参数，那么将返回原始字符串。

例子

在本例中，我们将通过使用 str_rot13() 函数对字符串进行编码和解码：

<?php
echo str_rot13("Hello World");
echo "<br />";
echo str_rot13("Uryyb Jbeyq");
?>

输出：

Uryyb Jbeyq
Hello World

PHP String 函数

PHP 参考手册
PHP 测验


PHP str_shuffle() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP str_shuffle() 函数

PHP String 函数

定义和用法

str_shuffle() 函数随机地打乱字符串中的所有字符。

语法

str_shuffle(string)
参数 | 描述
string | 必需。规定要打乱的字符串。

例子

<?php
echo str_shuffle("Hello World");
?>

输出：

H elooWlrdl

PHP String 函数

PHP 参考手册
PHP 测验


PHP str_split() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP str_split() 函数

PHP String 函数

定义和用法

str_split() 函数把字符串分割到数组中。

语法

str_split(string,length)
参数 | 描述
string | 必需。规定要分割的字符串。
length | 可选。规定每个数组元素的长度。默认是 1。

说明

如果 length 小于 1，str_split() 函数将返回 false。

如果 length 大于字符串的长度，整个字符串将作为数组的唯一元素返回。

例子

例子 1

<?php
print_r(str_split("Hello"));
?>

输出：

Array
(
[0] => H
[1] => e
[2] => l
[3] => l
[4] => o
)

例子 2

<?php
print_r(str_split("Hello",3));
?>

输出：

Array
(
[0] => Hel
[1] => lo
)

PHP String 函数

PHP 参考手册
PHP 测验


PHP str_word_count() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP str_word_count() 函数

PHP String 函数

定义和用法

str_word_count() 函数计算字符串中的单词数。

语法

str_word_count(string,return,char)
参数 | 描述
string | 必需。规定要检查的字符串。
return

可选。规定 str_word_count() 函数的返回值。

可能的值：

  • 0 - 默认。返回找到的单词的数目。
  • 1 - 返回包含字符串中的单词的数组。
  • 2 - 返回一个数组，其中的键是单词在字符串中的位置，值是实际的单词。
return | 可选。规定被认定为单词的特殊字符。该参数是 PHP 5.1 中新加的。

例子

例子 1

<?php
echo str_word_count("Hello world!");
?>

输出：

2

例子 2

<?php
print_r(str_word_count("Hello world!",1));
?>

输出：

Array
(
[0] => Hello
[1] => world
)

例子 3

<?php
print_r(str_word_count("Hello world!",2));
?>

输出：

Array
(
[0] => Hello
[6] => world
)

例子 4

<?php
print_r(str_word_count("Hello world & good morning!",1));
print_r(str_word_count("Hello world & good morning!",1,"&"));
?>

输出：

Array
(
[0] => Hello
[1] => world
[2] => good
[3] => morning
)

Array
(
[0] => Hello
[1] => world
[2] => &
[3] => good
[4] => morning
)

PHP String 函数

PHP 参考手册
PHP 测验


PHP strcasecmp() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strcasecmp() 函数

PHP String 函数

定义和用法

strcasecmp() 函数比较两个字符串。

该函数返回：

  • 0 - 如果两个字符串相等
  • <0 - 如果 string1 小于 string2
  • >0 - 如果 string1 大于 string2

语法

strcasecmp(string1,string2)
参数 | 描述
string1 | 必需。规定要比较的第一个字符串。
string2 | 必需。规定要比较的第二个字符串。

提示和注释

注释：该函数是二进制安全的，且对大小写不敏感。

例子

<?php
echo strcasecmp("Hello world!","HELLO WORLD!");
?>

输出：

0

PHP String 函数

PHP 参考手册
PHP 测验


PHP strchr() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strchr() 函数

PHP String 函数

定义和用法

strchr() 函数搜索一个字符串在另一个字符串中的第一次出现。

该函数返回字符串的其余部分（从匹配点）。如果未找到所搜索的字符串，则返回 false。

该函数是 strstr() 函数的别名。

语法

strchr(string,search)
参数 | 描述
string | 必需。规定被搜索的字符串。
search | 必需。规定所搜索的字符串。如果该参数是数字，则搜索匹配数字 ASCII 值的字符。

提示和注释

注释：该函数是二进制安全的。

注释：该函数对大小写敏感。如需进行大小写不敏感的搜索，请使用 stristr()。

例子

例子 1

<?php
echo strchr("Hello world!","world");
?>

输出：

world!

例子 2

在本例中，我们将搜索 "o" 的 ASCII 值所代表的字符：

<?php
echo strchr("Hello world!",111);
?>

输出：

o world!

PHP String 函数

PHP 参考手册
PHP 测验


PHP strcmp() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strcmp() 函数

PHP String 函数

定义和用法

strcmp() 函数比较两个字符串。

该函数返回：

  • 0 - 如果两个字符串相等
  • <0 - 如果 string1 小于 string2
  • >0 - 如果 string1 大于 string2

语法

strcmp(string1,string2)
参数 | 描述
string1 | 必需。规定要比较的第一个字符串。
string2 | 必需。规定要比较的第二个字符串。

提示和注释

注释：该函数是二进制安全的，且对大小写敏感。

例子

<?php
echo strcmp("Hello world!","Hello world!");
?>

输出：

0

PHP String 函数

PHP 参考手册
PHP 测验


PHP strcoll() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strcoll() 函数

PHP String 函数

定义和用法

strcoll() 函数比较两个字符串。

该函数返回：

  • 0 - 如果两个字符串相等
  • <0 - 如果 string1 小于 string2
  • >0 - 如果 string1 大于 string2

字符串的比较会根据本地设置而变化。（A<a 或 A>a）。

语法

strcoll(string1,string2)
参数 | 描述
string1 | 必需。规定要比较的第一个字符串。
string2 | 必需。规定要比较的第二个字符串。

提示和注释

注释：该函数对大小写敏感，但不是二进制安全的。

注释：如果本地设置是 C 或 POSIX，则该函数的工作方式与 strcmp() 相同。

例子

<?php
setlocale (LC_COLLATE, 'NL');
echo strcoll("Hello World!","Hello WORLD!");
echo "<br />";

setlocale (LC_COLLATE, 'en_US');
echo strcoll("Hello World!","Hello WORLD!");
?>

输出：

-1
1

PHP String 函数

PHP 参考手册
PHP 测验


PHP strcspn() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strcspn() 函数

PHP String 函数

定义和用法

strcspn() 函数返回在找到任何指定的字符之前，在字符串查找的字符数。

语法

strcspn(string,char,start,length)
参数 | 描述
string | 必需。规定要搜索的字符串。
char | 必需。规定要查找的字符。
start | 可选。规定开始查找的位置。该参数是 PHP 4.3 中新加的。
length | 可选。规定字符串的长度（搜索多少字符）。该参数是 PHP 4.3 中新加的。

提示和注释

注释：该函数是二进制安全的。

例子

<?php
echo strcspn("Hello world!","w");
?>

输出：

6

PHP String 函数

PHP 参考手册
PHP 测验


PHP strftime() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strftime() 函数

PHP Date / Time 函数

定义和用法

strftime() 函数根据区域设置格式化本地时间／日期。

语法

strftime(format,timestamp)
参数 | 描述
format | 可选。规定如何返回结果。
timestamp | 可选。

提示和注释

提示：与 gmstrftime() 的行为相同，不同的是返回时间是本地时间。

例子

输出 strftime() 和 gmstrftime() 的结果：

<?php
echo(strftime("%b %d %Y %X", mktime(20,0,0,12,31,98)));
echo(gmstrftime("%b %d %Y %X", mktime(20,0,0,12,31,98)));

//输出当前日期、时间和时区
echo(gmstrftime("It is %a on %b %d, %Y, %X time zone: %Z",time()));
?>

输出：

Dec 31 1998 20:00:00
Dec 31 1998 19:00:00
It is Wed on Jan 25, 2006, 11:32:10 time zone: W. Europe Standard Time

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP String 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP String 函数

  • Previous Page
  • Next Page

PHP String 简介

String 字符串函数允许您对字符串进行操作。

安装

String 函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

PHP String 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
addcslashes() | 在指定的字符前添加反斜杠。 | 4
addslashes() | 在指定的预定义字符前添加反斜杠。 | 3
bin2hex() | 把 ASCII 字符的字符串转换为十六进制值。 | 3
chop() | rtrim() 的别名。 | 3
chr() | 从指定的 ASCII 值返回字符。 | 3
chunk_split() | 把字符串分割为一连串更小的部分。 | 3
convert_cyr_string() | 把字符由一种 Cyrillic 字符转换成另一种。 | 3
convert_uudecode() | 对 uuencode 编码的字符串进行解码。 | 5
convert_uuencode() | 使用 uuencode 算法对字符串进行编码。 | 5
count_chars() | 返回字符串所用字符的信息。 | 4
crc32() | 计算一个字符串的 32-bit CRC。 | 4
crypt() | 单向的字符串加密法 (hashing)。 | 3
echo() | 输出字符串。 | 3
explode() | 把字符串打散为数组。 | 3
fprintf() | 把格式化的字符串写到指定的输出流。 | 5
get_html_translation_table() | 返回翻译表。 | 4
hebrev() | 把希伯来文本从右至左的流转换为左至右的流。 | 3
hebrevc() | 同上，同时把(\n) 转为 <br />。 | 3
html_entity_decode() | 把 HTML 实体转换为字符。 | 4
htmlentities() | 把字符转换为 HTML 实体。 | 3
htmlspecialchars_decode() | 把一些预定义的 HTML 实体转换为字符。 | 5
htmlspecialchars() | 把一些预定义的字符转换为 HTML 实体。 | 3
implode() | 把数组元素组合为一个字符串。 | 3
join() | implode() 的别名。 | 3
levenshtein() | 返回两个字符串之间的 Levenshtein 距离。 | 3
localeconv() | 返回包含本地数字及货币信息格式的数组。 | 4
ltrim() | 从字符串左侧删除空格或其他预定义字符。 | 3
md5() | 计算字符串的 MD5 散列。 | 3
md5_file() | 计算文件的 MD5 散列。 | 4
metaphone() | 计算字符串的 metaphone 键。 | 4
money_format() | 把字符串格式化为货币字符串。 | 4
nl_langinfo() | 返回指定的本地信息。 | 4
nl2br() | 在字符串中的每个新行之前插入 HTML 换行符。 | 3
number_format() | 通过千位分组来格式化数字。 | 3
ord() | 返回字符串第一个字符的 ASCII 值。 | 3
parse_str() | 把查询字符串解析到变量中。 | 3
print() | 输出一个或多个字符串。 | 3
printf() | 输出格式化的字符串。 | 3
quoted_printable_decode() | 解码 quoted-printable 字符串。 | 3
quotemeta() | 在字符串中某些预定义的字符前添加反斜杠。 | 3
rtrim() | 从字符串的末端开始删除空白字符或其他预定义字符。 | 3
setlocale() | 设置地区信息（地域信息）。 | 3
sha1() | 计算字符串的 SHA-1 散列。 | 4
sha1_file() | 计算文件的 SHA-1 散列。 | 4
similar_text() | 计算两个字符串的匹配字符的数目。 | 3
soundex() | 计算字符串的 soundex 键。 | 3
sprintf() | 把格式化的字符串写写入一个变量中。 | 3
sscanf() | 根据指定的格式解析来自一个字符串的输入。 | 4
str_ireplace() | 替换字符串中的一些字符。（对大小写不敏感） | 5
str_pad() | 把字符串填充为新的长度。 | 4
str_repeat() | 把字符串重复指定的次数。 | 4
str_replace() | 替换字符串中的一些字符。（对大小写敏感） | 3
str_rot13() | 对字符串执行 ROT13 编码。 | 4
str_shuffle() | 随机地打乱字符串中的所有字符。 | 4
str_split() | 把字符串分割到数组中。 | 5
str_word_count() | 计算字符串中的单词数。 | 4
strcasecmp() | 比较两个字符串。（对大小写不敏感） | 3
strchr() | 搜索字符串在另一字符串中的第一次出现。strstr() 的别名 | 3
strcmp() | 比较两个字符串。（对大小写敏感） | 3
strcoll() | 比较两个字符串（根据本地设置）。 | 4
strcspn() | 返回在找到任何指定的字符之前，在字符串查找的字符数。 | 3
strip_tags() | 剥去 HTML、XML 以及 PHP 的标签。 | 3
stripcslashes() | 删除由 addcslashes() 函数添加的反斜杠。 | 4
stripslashes() | 删除由 addslashes() 函数添加的反斜杠。 | 3
stripos() | 返回字符串在另一字符串中第一次出现的位置(大小写不敏感) | 5
stristr() | 查找字符串在另一字符串中第一次出现的位置(大小写不敏感) | 3
strlen() | 返回字符串的长度。 | 3
strnatcasecmp() | 使用一种“自然”算法来比较两个字符串（对大小写不敏感） | 4
strnatcmp() | 使用一种“自然”算法来比较两个字符串（对大小写敏感） | 4
strncasecmp() | 前 n 个字符的字符串比较（对大小写不敏感）。 | 4
strncmp() | 前 n 个字符的字符串比较（对大小写敏感）。 | 4
strpbrk() | 在字符串中搜索指定字符中的任意一个。 | 5
strpos() | 返回字符串在另一字符串中首次出现的位置（对大小写敏感） | 3
strrchr() | 查找字符串在另一个字符串中最后一次出现的位置。 | 3
strrev() | 反转字符串。 | 3
strripos() | 查找字符串在另一字符串中最后出现的位置(对大小写不敏感) | 5
strrpos() | 查找字符串在另一字符串中最后出现的位置(对大小写敏感) | 3
strspn() | 返回在字符串中包含的特定字符的数目。 | 3
strstr() | 搜索字符串在另一字符串中的首次出现（对大小写敏感） | 3
strtok() | 把字符串分割为更小的字符串。 | 3
strtolower() | 把字符串转换为小写。 | 3
strtoupper() | 把字符串转换为大写。 | 3
strtr() | 转换字符串中特定的字符。 | 3
substr() | 返回字符串的一部分。 | 3
substr_compare() | 从指定的开始长度比较两个字符串。 | 5
substr_count() | 计算子串在字符串中出现的次数。 | 4
substr_replace() | 把字符串的一部分替换为另一个字符串。 | 4
trim() | 从字符串的两端删除空白字符和其他预定义字符。 | 3
ucfirst() | 把字符串中的首字符转换为大写。 | 3
ucwords() | 把字符串中每个单词的首字符转换为大写。 | 3
vfprintf() | 把格式化的字符串写到指定的输出流。 | 5
vprintf() | 输出格式化的字符串。 | 4
vsprintf() | 把格式化字符串写入变量中。 | 4
wordwrap() | 按照指定长度对字符串进行折行处理。 | 4

PHP String 常量

PHP：指示支持该常量的最早的 PHP 版本。

常量 | 描述 | PHP
CRYPT_SALT_LENGTH | 包含系统默认加密方法的长度。对于标准 DES 加密，长度是 2。 |
CRYPT_STD_DES | 如果支持 2 字符 salt 的 DES 加密，则设置为 1，否则为 0。 |
CRYPT_EXT_DES | 如果支持 9 字符 salt 的 DES 加密，则设置为 1，否则为 0。 |
CRYPT_MD5 | 如果支持以$1$开始的 12 字符 salt 的MD5加密，则设置为1，否则为0。 |
CRYPT_BLOWFISH | 如果支持以 $2$ 或 $2a$ 开始的 16 字符 salt 的 Blowfish 加密，则设置为 1，否则为 0。 |
HTML_SPECIALCHARS |  |
HTML_ENTITIES |  |
ENT_COMPAT |  |
ENT_QUOTES |  |
ENT_NOQUOTES |  |
CHAR_MAX |  |
LC_CTYPE |  |
LC_NUMERIC |  |
LC_TIME |  |
LC_COLLATE |  |
LC_MONETARY |  |
LC_ALL |  |
LC_MESSAGES |  |
STR_PAD_LEFT |  |
STR_PAD_RIGHT |  |
STR_PAD_BOTH |  |
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP strip_tags() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strip_tags() 函数

PHP String 函数

定义和用法

strip_tags() 函数剥去 HTML、XML 以及 PHP 的标签。

语法

strip_tags(string,allow)
参数 | 描述
string | 必需。规定要检查的字符串。
allow | 可选。规定允许的标签。这些标签不会被删除。

提示和注释

注释：该函数始终会剥离 HTML 注释。这点无法通过 allow 参数改变。

例子

例子 1

<?php
echo strip_tags("Hello <b>world!</b>");
?>

输出：

Hello world!

例子 2

<?php
echo strip_tags("Hello <b><i>world!</i></b>","<b>");
?>

输出：

Hello world!

PHP String 函数

PHP 参考手册
PHP 测验


PHP strip_whitespace() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strip_whitespace() 函数

PHP 杂项函数

定义和用法

strip_whitespace() 函数返回已删除 PHP 注释以及空白字符的源代码文件。

该函数对于检测脚本中的实际代码量很有用。

语法

strip_whitespace(filename)
参数 | 描述
filename | 必需。规定文件名。

说明

若成功，则返回被剥离的源代码，若失败，则返回空字符串。

注释：在 PHP 5.0.1，该函数的行为与上面的描述一致。在这之前，它仅返回空字符串。

例子

"test.php":

<?php
// PHP comment

/*
*  Another PHP comment
*/

echo php_strip_whitespace      ("test.php");
?>

输出：

<?php
echo php_strip_whitespace ("test.php"); ?>

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP stripcslashes() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP stripcslashes() 函数

PHP String 函数

定义和用法

stripcslashes() 函数删除由 addcslashes() 函数添加的反斜杠。

语法

stripcslashes(string)
参数 | 描述
string | 必需。规定要检查的字符串。

提示和注释

注释：该函数用于清理从数据库中取回的数据。

例子

<?php
echo stripcslashes("Hello, \my na\me is Kai Ji\m.");
?>

输出：

Hello, my name is Kai Jim.

PHP String 函数

PHP 参考手册
PHP 测验


PHP stripos() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP stripos() 函数

PHP String 函数

定义和用法

stripos() 函数返回字符串在另一个字符串中第一次出现的位置。

如果没有找到该字符串，则返回 false。

语法

strpos(string,find,start)
参数 | 描述
string | 必需。规定被搜索的字符串。
find | 必需。规定要查找的字符。
start | 可选。规定开始搜索的位置。

提示和注释

注释：该函数对大小写不敏感。如需进行对大小写敏感的搜索，请使用 strpos() 函数。

例子

<?php
echo stripos("Hello world!","WO");
?>

输出：

6

PHP String 函数

PHP 参考手册
PHP 测验


PHP stripslashes() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP stripslashes() 函数

PHP String 函数

定义和用法

stripslashes() 函数删除由 addslashes() 函数添加的反斜杠。

语法

stripslashes(string)
参数 | 描述
string | 必需。规定要检查的字符串。

提示和注释

注释：该函数用于清理从数据库或 HTML 表单中取回的数据。

例子

<?php
echo stripslashes("Who\'s John Adams?");
?>

输出：

Who's John Adams?

PHP String 函数

PHP 参考手册
PHP 测验


PHP stristr() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP stristr() 函数

PHP String 函数

定义和用法

stristr() 函数查找字符串在另一个字符串中第一次出现的位置。

如果成功，则返回字符串的其余部分（从匹配点）。如果没有找到该字符串，则返回 false。

语法

stristr(string,search)
参数 | 描述
string | 必需。规定被搜索的字符串。
find | 必需。规定要查找的字符。如果该参数是数字，则搜索匹配该数字对应的 ASCII 值的字符。

提示和注释

注释：该函数是二进制安全的。

注释：该函数对大小写不敏感。如需对大小写敏感的搜索，请使用 strstr()。

例子

例子 1

<?php
echo stristr("Hello world!","WORLD");
?>

输出：

world!

例子 2

<?php
echo stristr("Hello world!",111);
?>

输出：

o world!

PHP String 函数

PHP 参考手册
PHP 测验


PHP strlen() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strlen() 函数

PHP String 函数

定义和用法

strlen() 函数返回字符串的长度。

语法

strlen(string)
参数 | 描述
string | 必需。规定要检查的字符串。

例子

<?php
echo strlen("Hello world!");
?>

输出：

12

PHP String 函数

PHP 参考手册
PHP 测验


PHP strnatcasecmp() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strnatcasecmp() 函数

PHP String 函数

定义和用法

strnatcasecmp() 函数使用一种“自然”算法来比较两个字符串。

在自然算法中，数字 "2" 小于数字 "10"。在计算机排序中，"2" 大于 "10"，这是因为 "2" 大于 "10" 的第一个数字。

该函数返回：

  • 0 - 如果两个字符串相等
  • <0 - 如果 string1 小于 string2
  • >0 - 如果 string1 大于 string2

语法

strnatcasecmp(string1,string2)
参数 | 描述
string1 | 必需。规定要比较的第一个字符串。
string2 | 必需。规定要比较的第二个字符串。

提示和注释

注释：该函数对大小写不敏感。

例子

<?php
echo strnatcasecmp("2Hello world!","10Hello world!");
echo "<br />";
echo strnatcasecmp("10Hello world!","2Hello world!");
?>

输出：

-1
1

PHP String 函数

PHP 参考手册
PHP 测验


PHP strnatcmp() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strnatcmp() 函数

PHP String 函数

定义和用法

strnatcmp() 函数使用一种“自然”算法来比较两个字符串。

在自然算法中，数字 "2" 小于数字 "10"。在计算机排序中，"2" 大于 "10"，这是因为 "2" 大于 "10" 的第一个数字。

该函数返回：

  • 0 - 如果两个字符串相等
  • <0 - 如果 string1 小于 string2
  • >0 - 如果 string1 大于 string2

语法

strnatcmp(string1,string2)
参数 | 描述
string1 | 必需。规定要比较的第一个字符串。
string2 | 必需。规定要比较的第二个字符串。

提示和注释

注释：该函数对大小写敏感。

例子

<?php
echo strnatcmp("2Hello world!","10Hello world!");
echo "<br />";
echo strnatcmp("10Hello world!","2Hello world!");
?>

输出：

-1
1

PHP String 函数

PHP 参考手册
PHP 测验


PHP strncasecmp() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strncasecmp() 函数

PHP String 函数

定义和用法

strncasecmp() 函数比较两个字符串。

该函数返回：

  • 0 - 如果两个字符串相等
  • <0 - 如果 string1 小于 string2
  • >0 - 如果 string1 大于 string2

语法

strncasecmp(string1,string2,length)
参数 | 描述
string1 | 必需。规定要比较的第一个字符串。
string2 | 必需。规定要比较的第二个字符串。
length | 必需。规定每个字符串用于比较的字符数。

提示和注释

注释：该函数是二进制安全的，且对大小写不敏感。

例子

<?php
echo strncasecmp("Hello world!","Hello earth!",6);
?>

输出：

0

PHP String 函数

PHP 参考手册
PHP 测验


PHP strncmp() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strncmp() 函数

PHP String 函数

定义和用法

strncmp() 函数比较两个字符串。

该函数返回：

  • 0 - 如果两个字符串相等
  • <0 - 如果 string1 小于 string2
  • >0 - 如果 string1 大于 string2

语法

strncmp(string1,string2,length)
参数 | 描述
string1 | 必需。规定要比较的第一个字符串。
string2 | 必需。规定要比较的第二个字符串。
length | 必需。规定每个字符串用于比较的字符数。

提示和注释

注释：该函数是二进制安全的，且对大小写敏感。

例子

<?php
echo strncmp("Hello world!","Hello earth!",6);
?>

输出：

0

PHP String 函数

PHP 参考手册
PHP 测验


PHP strpbrk() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strpbrk() 函数

PHP String 函数

定义和用法

strpbrk() 函数在字符串中搜索指定字符中的任意一个。

该函数返回指定字符第一次出现的位置开始的剩余部分。如果没有找到，则返回 false。

语法

strpbrk(string,charlist)
参数 | 描述
string | 必需。规定被搜索的字符串。
charlist | 必需。规定要查找的字符。

提示和注释

注释：该函数对大小写敏感。

例子

<?php
echo strpbrk("Hello world!","oe");
?>

输出：

ello world!

PHP String 函数

PHP 参考手册
PHP 测验


PHP strpos() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strpos() 函数

PHP String 函数

定义和用法

strpos() 函数返回字符串在另一个字符串中第一次出现的位置。

如果没有找到该字符串，则返回 false。

语法

strpos(string,find,start)
参数 | 描述
string | 必需。规定被搜索的字符串。
find | 必需。规定要查找的字符。
start | 可选。规定开始搜索的位置。

提示和注释

注释：该函数对大小写敏感。如需进行对大小写不敏感的搜索，请使用 stripos() 函数。

例子

<?php
echo strpos("Hello world!","wo");
?>

输出：

6

PHP String 函数

PHP 参考手册
PHP 测验


PHP strptime() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strptime() 函数

PHP Date / Time 函数

定义和用法

strptime() 函数解析由 strftime() 生成的日期／时间。

语法

strptime(date,format)
参数 | 描述
date | 要解析的字符串（例如从 strftime() 返回的）。
format | date 所使用的格式（与 strftime() 中所使用的相同）。

说明

strptime() 返回一个将 date 解析后的数组，如果出错返回 FALSE。

月份和星期几的名字以及其它与语种有关的字符串对应于 setlocale()设定的当前区域（LC_TIME）。

数组中包含以下单元：

键名 | 说明
tm_sec | 当前分钟内的秒数（0-61）
tm_min | 当前小时内的分钟数（0-59）
tm_hour | 午夜起的小时数（0-23）
tm_mday | 月份中的第几天（1-31）
tm_mon | 自一月起过了几个月（0-11）
tm_year | 自 1900 年起过了几年
tm_wday | 自星期天起过了几天（0-6）
tm_yday | 本年自一月一日起过了多少天（0-365）
unparsed date | 中未能通过指定的 format 识别的部分

例子

输出 strftime() 和 strptime() 的结果：

<?php
$format="%d/%m/%Y %H:%M:%S";
$strf=strftime($format);
echo("$strf");
print_r(strptime($strf,$format));
?>

输出：

03/10/2005 13:23:44
Array
(
[tm_sec] => 44
[tm_min] => 23
[tm_hour] => 13
[tm_mday] => 3
[tm_mon] => 9
[tm_year] => 105
[tm_wday] => 0
[tm_yday] => 276
[unparsed] =>
)

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP strrchr() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strrchr() 函数

PHP String 函数

定义和用法

strrchr() 函数查找字符串在另一个字符串中最后一次出现的位置，并返回从该位置到字符串结尾的所有字符。

如果成失败，否则返回 false。

语法

strrchr(string,char)
参数 | 描述
string | 必需。规定被搜索的字符串。
char | 必需。规定要查找的字符。如果该参数是数字，则搜索匹配数字 ASCII 值的字符。

提示和注释

注释：该函数是二进制安全的。

例子

例子 1

<?php
echo strrchr("Hello world!","world");
?>

输出：

world!

例子 2

<?php
echo strrchr("Hello world!",111);
?>

输出：

orld!

PHP String 函数

PHP 参考手册
PHP 测验


PHP strrev() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strrev() 函数

PHP String 函数

定义和用法

strrev() 函数反转字符串。

语法

strrev(string)
参数 | 描述
string | 必需。规定要反转的字符串。

例子

<?php
echo strrev("Hello World!");
?>

输出：

!dlroW olleH

PHP String 函数

PHP 参考手册
PHP 测验


PHP strripos() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strripos() 函数

PHP String 函数

定义和用法

strripos() 函数查找字符串在另一个字符串中最后一次出现的位置。

如果成功，则返回位置，否则返回 false。

语法

strrpos(string,find,start)
参数 | 描述
string | 必需。规定被搜索的字符串。
find | 必需。规定要查找的字符。
start | 可选。规定开始搜索的位置。

提示和注释

注释：该函数对大小写不敏感。如需进行大小写敏感的查找，请使用 strrpos()。

例子

<?php
echo strripos("Hello world!","WO");
?>

输出：

6

PHP String 函数

PHP 参考手册
PHP 测验


PHP strrpos() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strrpos() 函数

PHP String 函数

定义和用法

strrpos() 函数查找字符串在另一个字符串中最后一次出现的位置。

如果成功，则返回位置，否则返回 false。

语法

strrpos(string,find,start)
参数 | 描述
string | 必需。规定被搜索的字符串。
find | 必需。规定要查找的字符。
start | 可选。规定开始搜索的位置。

提示和注释

注释：该函数对大小写敏感。如需进行大小写不敏感的查找，请使用 strripos()。

例子

<?php
echo strrpos("Hello world!","wo");
?>

输出：

6

PHP String 函数

PHP 参考手册
PHP 测验


PHP strspn() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strspn() 函数

PHP String 函数

定义和用法

strspn() 函数返回在字符串中包含的特定字符的数目。

语法

strspn(string,charlist,start,length)
参数 | 描述
string | 必需。规定被搜索的字符串。
charlist | 必需。规定要查找的字符。
start | 可选。规定在字符串的何处开始。
length | 可选。规定字符串的长度。

提示和注释

注释：该函数是二进制安全的。

例子

例子 1

<?php
echo strspn("Hello world!","kHlleo");
?>

输出：

5

例子 2

<?php
echo strspn("abcdefand","abc");
?>

输出：

3

PHP String 函数

PHP 参考手册
PHP 测验


PHP strstr() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strstr() 函数

PHP String 函数

定义和用法

strstr() 函数搜索一个字符串在另一个字符串中的第一次出现。

该函数返回字符串的其余部分（从匹配点）。如果未找到所搜索的字符串，则返回 false。

语法

strstr(string,search)
参数 | 描述
string | 必需。规定被搜索的字符串。
search | 必需。规定所搜索的字符串。如果该参数是数字，则搜索匹配数字 ASCII 值的字符。

提示和注释

注释：该函数是二进制安全的。

注释：该函数对大小写敏感。如需进行大小写不敏感的搜索，请使用 stristr()。

例子

例子 1

<?php
echo strstr("Hello world!","world");
?>

输出：

world!

例子 2

在本例中，我们将搜索 "o" 的 ASCII 值所代表的字符：

<?php
echo strstr("Hello world!",111);
?>

输出：

o world!

PHP String 函数

PHP 参考手册
PHP 测验


PHP strtok() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strtok() 函数

PHP String 函数

定义和用法

strtok() 函数把字符串分割为更小的字符串。

语法

strtok(string,split)
参数 | 描述
string | 必需。规定要分割的字符串。
split | 必需。规定一个或多个分割字符。

例子

在下面的例子中，请注意，我们仅在第一次调用 strtok() 函数时使用了 string 参数。在首次调用后，该函数仅需要 split 参数，这是因为它清楚自己在当前函数中所在的位置：

<?php
$string = "Hello world. Beautiful day today.";
$token = strtok($string, " ");

while ($token !== false)
  {
  echo "$token<br />";
  $token = strtok(" ");
  }
?>

输出：

Hello
world.
Beautiful
day
today.

PHP String 函数

PHP 参考手册
PHP 测验


PHP strtolower() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strtolower() 函数

PHP String 函数

定义和用法

strtolower() 函数把字符串转换为小写。

语法

strtolower(string)
参数 | 描述
string | 必需。规定要转换的字符串。

例子

<?php
echo strtolower("Hello WORLD!");
?>

输出：

hello world!

PHP String 函数

PHP 参考手册
PHP 测验


PHP strtotime() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strtotime() 函数

PHP Date / Time 函数

定义和用法

strtotime() 函数将任何英文文本的日期时间描述解析为 Unix 时间戳。

语法

strtotime(time,now)
参数 | 描述
time | 规定要解析的时间字符串。
now | 用来计算返回值的时间戳。如果省略该参数，则使用当前时间。

说明

该函数预期接受一个包含美国英语日期格式的字符串并尝试将其解析为 Unix 时间戳（自 January 1 1970 00:00:00 GMT 起的秒数），其值相对于 now 参数给出的时间，如果没有提供此参数，则用系统当前时间。

该函数将使用 TZ 环境变量（如果有的话）来计算时间戳。自 PHP 5.1.0 起有更容易的方法来定义时区用于所有的日期／时间函数。此过程在 date_default_timezone_get() 函数页面中有说明。

返回值

成功则返回时间戳，否则返回 FALSE。在 PHP 5.1.0 之前本函数在失败时返回 -1。

例子

<?php
echo(strtotime("now"));
echo(strtotime("3 October 2005"));
echo(strtotime("+5 hours"));
echo(strtotime("+1 week"));
echo(strtotime("+1 week 3 days 7 hours 5 seconds"));
echo(strtotime("next Monday"));
echo(strtotime("last Sunday"));
?>

输出：

1138614504
1128290400
1138632504
1139219304
1139503709
1139180400
1138489200

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP strtoupper() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strtoupper() 函数

PHP String 函数

定义和用法

strtoupper() 函数把字符串转换为大写。

语法

strtoupper(string)
参数 | 描述
string | 必需。规定要转换的字符串。

例子

<?php
echo strtoupper("Hello WORLD!");
?>

输出：

HELLO WORLD!

PHP String 函数

PHP 参考手册
PHP 测验


PHP strtr() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP strtr() 函数

PHP String 函数

定义和用法

strtr() 函数转换字符串中特定的字符。

语法

strtr(string,from,to)

或者

strtr(string,array)
参数 | 描述
string1 | 必需。规定要转换的字符串。
from | 必需（除非使用数组）。规定要改变的字符。
to | 必需（除非使用数组）。规定要改变为的字符。
array | 必需（除非使用 from 和 to）。一个数组，其中的键是原始字符，值是目标字符。

说明

如果 from 和 to 的长度不同，则格式化为最短的长度。

例子

例子 1

<?php
echo strtr("Hilla Warld","ia","eo");
?>

输出：

Hello World

例子 2

<?php
$arr = array("Hello" => "Hi", "world" => "earth");
echo strtr("Hello world",$arr);
?>

输出：

Hi earth

PHP String 函数

PHP 参考手册
PHP 测验


PHP substr_compare() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP substr_compare() 函数

PHP String 函数

定义和用法

substr_compare() 函数从指定的开始长度比较两个字符串。

该函数返回：

  • 0 - 如果两字符串相等
  • <0 - 如果 string1 （从开始位置）小于 string2
  • >0 - 如果 string1 （从开始位置）大于 string2

语法

substr_compare(string1,string2,startpos,length,case)
参数 | 描述
string1 | 必需。规定要比较的第一个字符串。
string2 | 必需。规定要比较的第二个字符串。
startpos | 可选。规定在 string1 中的何处开始比较。
length | 可选。规定在 string1 中参与比较的字符数。
case | 可选。规定是否指定大小写比较。默认是 FALSE （对大小写敏感）。

说明

如果 length 大于或等于 string1 的长度，则函数返回 false。

例子

例子 1

<?php
echo substr_compare("Hello world","Hello world",0);
?>

输出：

0

例子 2

<?php
echo substr_compare("Hello world","world",6);
?>

输出：

0

例子 3

<?php
echo substr_compare("Hello world","WORLD",6,TRUE);
?>

输出：

0

PHP String 函数

PHP 参考手册
PHP 测验


PHP substr_count() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP substr_count() 函数

PHP String 函数

定义和用法

substr_count() 函数计算子串在字符串中出现的次数。

语法

substr_count(string,substring,start,length)
参数 | 描述
string | 必需。规定要检查的字符串。
replacement | 必需。规定要插入的字符串。
start | 可选。规定在字符串中何处开始搜索。
charlist | 可选。规定搜索的长度。

例子

<?php
echo substr_count("Hello world. The world is nice","world");
?>

输出：

2

PHP String 函数

PHP 参考手册
PHP 测验


PHP substr_replace() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP substr_replace() 函数

PHP String 函数

定义和用法

substr_replace() 函数把字符串的一部分替换为另一个字符串。

语法

substr_replace(string,replacement,start,length)
参数 | 描述
string | 必需。规定要检查的字符串。
replacement | 必需。规定要插入的字符串。
start

必需。规定在字符串的何处开始替换。

  • 正数 - 在第 start 个偏移量开始替换
  • 负数 - 在从字符串结尾的第 start 个偏移量开始替换
  • 0 - 在字符串中的第一个字符处开始替换
charlist

可选。规定要替换多少个字符。

  • 正数 - 被替换的字符串长度
  • 负数 - 从字符串末端开始的被替换字符数
  • 0 - 插入而非替换

提示和注释

注释：如果 start 是负数且 length 小于等于 start，则 length 为 0。

例子

<?php
echo substr_replace("Hello world","earth",6);
?>

输出：

Hello earth

PHP String 函数

PHP 参考手册
PHP 测验


PHP substr() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP substr() 函数

PHP String 函数

定义和用法

substr() 函数返回字符串的一部分。

语法

substr(string,start,length)
参数 | 描述
string | 必需。规定要返回其中一部分的字符串。
start

必需。规定在字符串的何处开始。

  • 正数 - 在字符串的指定位置开始
  • 负数 - 在从字符串结尾的指定位置开始
  • 0 - 在字符串中的第一个字符处开始
charlist

可选。规定要返回的字符串长度。默认是直到字符串的结尾。

  • 正数 - 从 start 参数所在的位置返回
  • 负数 - 从字符串末端返回

提示和注释

注释：如果 start 是负数且 length 小于等于 start，则 length 为 0。

例子

例子 1

<?php
echo substr("Hello world!",6);
?>

输出：

world!

例子 2

<?php
echo substr("Hello world!",6,5);
?>

输出：

world

PHP String 函数

PHP 参考手册
PHP 测验


PHP Switch 语句

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Switch 语句

  • Previous Page
  • Next Page

PHP 中的 Switch 语句用于执行基于多个不同条件的不同动作。

Switch 语句

如果您希望有选择地执行若干代码块之一，请使用 Switch 语句。

使用 Switch 语句可以避免冗长的 if..elseif..else 代码块。

语法

switch (expression)
{
case label1:
  code to be executed if expression = label1;
  break;
case label2:
  code to be executed if expression = label2;
  break;
default:
  code to be executed
  if expression is different
  from both label1 and label2;
}

实例

工作原理：

  1. 对表达式（通常是变量）进行一次计算
  2. 把表达式的值与结构中 case 的值进行比较
  3. 如果存在匹配，则执行与 case 关联的代码
  4. 代码执行后，break 语句阻止代码跳入下一个 case 中继续执行
  5. 如果没有 case 为真，则使用 default 语句
<?php
switch ($x)
{
case 1:
  echo "Number 1";
  break;
case 2:
  echo "Number 2";
  break;
case 3:
  echo "Number 3";
  break;
default:
  echo "No number between 1 and 3";
}
?>

</body>
</html>
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP symlink() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP symlink() 函数

PHP Filesystem 函数

定义和用法

symlink() 函数创建符号连接。

语法

link(target,link)
参数 | 描述
target | 必需。
link | 必需。

说明

symlink() 对于已有的 target 建立一个名为 link 的符号连接。

若成功则返回 true，失败则返回 false。

提示和注释

注释：本函数未在 Windows 平台下实现。

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP tan() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP tan() 函数

PHP Math 函数

定义和用法

tan() 函数返回正切。

语法

tan(x)
参数 | 描述
x | 必需。一个数。

说明

tan() 返回参数 x 的正切值。参数 x 的单位为弧度

例子

在本例中，我们将返回不同的数的正切：

<?php
echo(tan(M_PI_4));
echo(tan(0.50));
echo(tan(-0.50));
echo(tan(5));
echo(tan(10));
echo(tan(-5));
echo(tan(-10));
?>

输出：

1
0.546302489844
-0.546302489844
-3.38051500625
0.648360827459
3.38051500625
-0.648360827459

PHP Math 函数

PHP 参考手册
PHP 测验


PHP tanh() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP tanh() 函数

PHP Math 函数

定义和用法

tanh() 函数返回双曲正切。

语法

tanh(x)
参数 | 描述
x | 必需。一个数。

说明

返回 x 的双曲正切值，定义为 sinh(arg)/cosh(arg)。

例子

在本例中，我们将返回不同的数的双曲正切：

<?php
echo(tanh(M_PI_4));
echo(tanh(0.50));
echo(tanh(-0.50));
echo(tanh(5));
echo(tanh(10));
echo(tanh(-5));
echo(tanh(-10))
?>

输出：

0.655794202633
0.46211715726
-0.46211715726
0.999909204263
0.999999995878
-0.999909204263
-0.999999995878

PHP Math 函数

PHP 参考手册
PHP 测验


PHP tempnam() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP tempnam() 函数

PHP Filesystem 函数

定义和用法

tempnam() 函数创建一个具有唯一文件名的临时文件。

若成功，则该函数返回新的临时文件名。若失败，则返回 false。

语法

tempnam(dir,prefix)
参数 | 描述
dir | 必需。规定创建临时文件的目录。
prefix | 必需。规定文件名的开头。

说明

在指定目录中建立一个具有唯一文件名的文件。如果该目录不存在，tempnam() 会在系统临时目录中生成一个文件，并返回其文件名。

在 PHP 4.0.6 之前，tempnam() 函数的行为取决于系统。在 Windows 下 TMP 环境变量会越过 dir 参数，在 Linux 下 TMPDIR 环境变量优先，而在 SVR4 下总是使用 dir 参数，如果其指向的目录存在的话。

提示和注释

注释：如果 PHP 不能在指定的 dir 参数中创建文件，则退回到系统默认值。

注释：本函数的行为在 4.0.3 版中改变了。也会建立一个临时文件以避免竞争情形，即有可能会在产生出作为文件名的字符串与脚本真正建立该文件之间会在文件系统中存在同名文件。注意，如果不再需要该文件则要删除此文件，不会自动删除的。

提示：参见 tmpfile()

例子

<?php
echo tempnam("C:\inetpub\testweb","TMP0");
?>

输出：

C:\inetpub\testweb\TMP1.tmp

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP time_nanosleep() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP time_nanosleep() 函数

PHP 杂项函数

定义和用法

time_nanosleep() 函数延迟代码执行若干秒和纳秒。

语法

time_nanosleep(seconds,nanoseconds)
参数 | 描述
seconds | 必需。必须是正整数。
nanoseconds | 必需。必须是小于 10 亿的正整数。

说明

延迟程序执行指定的 seconds 和 nanoseconds 数。

返回值

如果成功则返回 TRUE，失败则返回 FALSE

如果延迟被一个信号中断，将返回带有以下组件的关联数组：

  • seconds - 延迟中剩余的秒数
  • nanoseconds - 延迟中剩余的纳秒数

提示和注释

注释：本函数未在 Windows 平台下实现。

例子

<?php
if (time_nanosleep(3,500000000) === true)
  {
  echo "暂停 3 秒半";
  }
?>

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP time_sleep_until() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP time_sleep_until() 函数

PHP 杂项函数

定义和用法

time_sleep_until() 函数延迟代码执行直到指定的时间。

语法

time_sleep_until(timestamp)
参数 | 描述
timestamp | 必需。脚本唤醒时的时间戳。

说明

使脚本暂停执行，直到指定的 timestamp。

返回值

如果成功则返回 TRUE，失败则返回 FALSE。

错误／异常

如果指定的时间戳位于过去，则该函数将生成一个 E_WARNING。

提示和注释

注释：所有信号都将在脚本唤醒后递送。

注释：本函数未在 Windows 平台下实现。

例子

<?php
// 从现在起 10 秒后唤醒
time_sleep_until(time()+10);
?>

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP time() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP time() 函数

PHP Date / Time 函数

定义和用法

time() 函数返回当前时间的 Unix 时间戳。

语法

time(void)
参数 | 描述
void | 可选。

说明

返回自从 Unix 纪元（格林威治时间 1970 年 1 月 1 日 00:00:00）到当前时间的秒数。

提示和注释

提示：自 PHP 5.1 起在 $_SERVER['REQUEST_TIME'] 中保存了发起该请求时刻的时间戳。

例子

例子 1

<?php
$t=time();
echo($t . "<br />");
echo(date("D F d Y",$t));
?>

输出：

1138618081
Mon January 30 2006

例子 2

<?php
$nextWeek = time() + (7 * 24 * 60 * 60); // 7 days; 24 hours; 60 mins; 60secs
echo 'Now:       '. date('Y-m-d') ."\n";
echo 'Next Week: '. date('Y-m-d', $nextWeek) ."\n";
?>

输出：

Now:       2005-03-30
Next Week: 2005-04-07

PHP Date / Time 函数

PHP 参考手册
PHP 测验


PHP tmpfile() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP tmpfile() 函数

PHP Filesystem 函数

定义和用法

tmpfile() 函数以读写（w+）模式建立一个具有唯一文件名的临时文件。

文件会在关闭后（用 fclose()）自动被删除，或当脚本结束后。

语法

tmpfile()

提示和注释

提示：参见 tempnam()。

例子

<?php
$temp = tmpfile();

fwrite($temp, "Testing, testing.");

//倒回文件的开头
rewind($temp);

//从文件中读取 1k
echo fread($temp,1024);

//删除文件
fclose($temp);
?>

输出：

Testing, testing.

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP touch() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP touch() 函数

PHP Filesystem 函数

定义和用法

touch() 函数设置指定文件的访问和修改时间。

语法

touch(filename,time,atime)
参数 | 描述
filename | 必需。规定要接触的文件。
time | 可选。设置时间。默认是当前系统时间。
atime | 可选。设置访问时间。默认是当前系统时间。

说明

尝试将由 filename 给出的文件的访问和修改时间设定为指定的时间。如果没有设置可选参数 time，则使用当前系统时间。如果给出了第三个参数 atime，则指定文件的访问时间会被设为 atime 。

如果成功则返回 true，失败则返回 false。

提示和注释

注释：如果文件不存在，则会被创建。

例子

<?php
touch("test.txt");
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP trim() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP trim() 函数

PHP String 函数

定义和用法

trim() 函数从字符串的两端删除空白字符和其他预定义字符。

语法

trim(string,charlist)
参数 | 描述
string | 必需。规定要检查的字符串。
charlist 可选。规定要转换的字符串。如果省略该参数，则删除以下所有字符：
  • "\0" - NULL
  • "\t" - tab
  • "\n" - new line
  • "\x0B" - 纵向列表符
  • "\r" - 回车
  • " " - 普通空白字符

例子

例子 1

<html>
<body>
<?php
$str = "    Hello World!    ";
echo "Without trim: " . $str;
echo "<br />";
echo "With trim: " . trim($str);
?>
<body>
<html>

输出：

Without trim: Hello World!
With trim: Hello World!

HTML 源码：

<html>
<body>
Without trim:     Hello World!    <br />With trim: Hello World!
</body>
</html>

例子 2

<?php
$str = "\r\nHello World!\r\n";
echo "Without trim: " . $str;
echo "<br />";
echo "With trim: " . trim($str);
?>

输出：

Without trim: Hello World!
With trim: Hello World!

HTML 源码：

<html>
<body>
Without trim:
Hello World!
<br />With trim: Hello World!
</body>
</html>

PHP String 函数

PHP 参考手册
PHP 测验


PHP uasort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP uasort() 函数

PHP Array 函数

定义和用法

uasort() 函数使用用户自定义的比较函数对数组排序，并保持索引关联（不为元素分配新的键）。

如果成功则返回 TRUE，否则返回 FALSE。

该函数主要用于对那些单元顺序很重要的结合数组进行排序。

语法

uasort(array,sorttype)
参数 | 描述
array | 必需。规定要排序的数组。
function

必需。用户自定义的函数。

函数必须设计为返回 -1, 0, 或 1，并应该接受两个供比较的参数，同时以类似下面这样的方式来工作：

  • 如果 a = b, 返回 0
  • 如果 a > b, 返回 1
  • 如果 a < b, 返回 -1

例子

<?php
function my_sort($a, $b)
  {
  if ($a == $b) return 0;
  return ($a > $b) ? -1 : 1;
  }

$people = array("Swanson" => "Joe",
"Griffin" => "Peter", "Quagmire" => "Glenn",
"swanson" => "joe", "griffin" => "peter",
"quagmire" => "glenn");

uasort($people, "my_sort");

print_r ($people);
?>

输出：

Array
(
[griffin] => peter
[swanson] => joe
[quagmire] => glenn
[Griffin] => Peter
[Swanson] => Joe
[Quagmire] => Glenn
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP ucfirst() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ucfirst() 函数

PHP String 函数

定义和用法

ucfirst() 函数把字符串中的首字符转换为大写。

语法

ucfirst(string)
参数 | 描述
string | 必需。规定要转换的字符串。

例子

<?php
echo ucfirst("hello world");
?>

输出：

Hello world

PHP String 函数

PHP 参考手册
PHP 测验


PHP ucwords() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP ucwords() 函数

PHP String 函数

定义和用法

ucwords() 函数把字符串中每个单词的首字符转换为大写。

语法

ucwords(string)
参数 | 描述
string | 必需。规定要转换的字符串。

例子

<?php
echo ucwords("hello world");
?>

输出：

Hello World

PHP String 函数

PHP 参考手册
PHP 测验


PHP uksort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP uksort() 函数

PHP Array 函数

定义和用法

uksort() 函数使用用户自定义的比较函数按照键名对数组排序，并保持索引关系。

如果成功则返回 TRUE，否则返回 FALSE。

如果要排序的数组需要用一种不寻常的标准进行排序，那么应该使用此函数。

自定义函数应接受两个参数，该参数将被数组中的一对键名填充。比较函数在第一个参数小于，等于，或大于第二个参数时必须分别返回一个小于零，等于零，或大于零的整数。

语法

uksort(array,sorttype)
参数 | 描述
array | 必需。规定要排序的数组。
function

必需。用户自定义的函数。

函数必须设计为返回 -1, 0, 或 1，并应该接受两个供比较的参数，同时以类似下面这样的方式来工作：

  • 如果 a = b, 返回 0
  • 如果 a > b, 返回 1
  • 如果 a < b, 返回 -1

例子

<?php
function my_sort($a, $b)
  {
  if ($a == $b) return 0;
  return ($a > $b) ? -1 : 1;
  }

$people = array("Swanson" => "Joe",
"Griffin" => "Peter", "Quagmire" => "Glenn",
"swanson" => "joe", "griffin" => "peter",
"quagmire" => "glenn");

uksort($people, "my_sort");

print_r ($people);
?>

输出：

Array
(
[swanson] => joe
[quagmire] => glenn
[griffin] => peter
[Swanson] => Joe
[Quagmire] => Glenn
[Griffin] => Peter
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP umask() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP umask() 函数

PHP Filesystem 函数

定义和用法

umask() 函数改变当前的 umask。

umask() 将 PHP 的 umask 设定为 mask & 0777 并返回原来的 umask。当 PHP 被作为服务器模块使用时，在每个请求结束后 umask 会被恢复。

无参数调用 umask() 会返回当前的 umask。

语法

umask(mask)
参数 | 描述
mask | 必需。规定新的权限。默认是 0777。

提示和注释

注释：在多线程的服务器上尽量避免使用这个函数。创建文件后要改变其权限最好还是使用 chmod()。使用 umask() 会导致并发程序和服务器发生不可预知的情况，因为它们使用相同的 umask。

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP uniqid() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP uniqid() 函数

PHP 杂项函数

定义和用法

uniqid() 函数基于以微秒计的当前时间，生成一个唯一的 ID。

语法

uniqid(prefix,more_entropy)
参数 | 描述
prefix | 可选。为 ID 规定前缀。如果两个脚本在相同的微妙生成 ID，该参数很有用。
more_entropy | 可选。规定位于返回值末尾的更多的熵。

说明

如果 prefix 参数为空，则返回的字符串有 13 个字符串长。如果 more_entropy 参数设置为 true，则是 23 个字符串长。

如果 more_entropy 参数设置为 true，则在返回值的末尾添加额外的熵（使用组合线形同余数生成程序），这样可以结果的唯一性更好。

返回值

以字符串的形式返回唯一标识符。

提示和注释

注释：由于基于系统时间，通过该函数生成的 ID 不是最佳的。如需生成绝对唯一的 ID，请使用 md5() 函数（请在字符串函数参考中查找）。

例子

<?php
echo uniqid();
?>

输出类似：

4415297e3af8c

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP UnixToJD() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP UnixToJD() 函数

PHP Array 函数

定义和用法

UnixToJD() 函数把 Unix 时间戳转换为儒略日计数。

语法

unixtojd(timestamp)
参数 | 描述
timestamp | 可选。

提示和注释：

注释：Unix 时间戳指示的是从格利高里历（不是罗马儒略历）的 1970 年 1 月 1 日至今的秒数。

例子

<?php
echo(unixtojd());
?>

输出：

2453755

PHP Array 函数

PHP 参考手册
PHP 测验


PHP unlink() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP unlink() 函数

PHP Filesystem 函数

定义和用法

unlink() 函数删除文件。

若成功，则返回 true，失败则返回 false。

语法

unlink(filename,context)
参数 | 描述
filename | 必需。规定要删除的文件。
context | 可选。规定文件句柄的环境。Context 是可修改流的行为的一套选项。

提示和注释

注释：对 context 的支持是 PHP 5.0.0 添加的。

例子

<?php
$file = "test.txt";
if (!unlink($file))
  {
  echo ("Error deleting $file");
  }
else
  {
  echo ("Deleted $file");
  }
?>

PHP Filesystem 函数

PHP 参考手册
PHP 测验


PHP unpack() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP unpack() 函数

PHP 杂项函数

定义和用法

unpack() 函数从二进制字符串对数据进行解包。

语法

unpack(format,data)
参数 | 描述
format | 必需。规定在解包数据时所使用的格式。
data | 可选。规定被解包的二进制数据。

format 参数的可能值：

  • a - NUL-padded string
  • A - SPACE-padded string
  • h - Hex string, low nibble first
  • H - Hex string, high nibble first
  • c - signed char
  • C - unsigned char
  • s - signed short (always 16 bit, machine byte order)
  • S - unsigned short (always 16 bit, machine byte order)
  • n - unsigned short (always 16 bit, big endian byte order)
  • v - unsigned short (always 16 bit, little endian byte order)
  • i - signed integer (machine dependent size and byte order)
  • I - unsigned integer (machine dependent size and byte order)
  • l - signed long (always 32 bit, machine byte order)
  • L - unsigned long (always 32 bit, machine byte order)
  • N - unsigned long (always 32 bit, big endian byte order)
  • V - unsigned long (always 32 bit, little endian byte order)
  • f - float (machine dependent size and representation)
  • d - double (machine dependent size and representation)
  • x - NUL byte
  • X - Back up one byte
  • @ - NUL-fill to absolute position

例子

例子 1

<?php
$data = "PHP";
print_r(unpack("C*",$data));
?>

输出：

Array
(
[1] => 80
[2] => 72
[3] => 80
)

例子 2

<?php
$data = "PHP";
print_r(unpack("C*myint",$data));
?>

输出：

Array
(
[myint1] => 80
[myint2] => 72
[myint3] => 80
)

例子 3

<?php
$bin = pack("c2n2",0x1234,0x5678,65,66);
print_r(unpack("c2chars/n2int",$bin));
?>

输出：

Array
(
[chars1] => 52
[chars2] => 120
[int1] => 65
[int2] => 66
)

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP usleep() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP usleep() 函数

PHP 杂项函数

定义和用法

usleep() 函数延迟代码执行若干微秒。

语法

usleep(microseconds)
参数 | 描述
microseconds | 必需。以微秒计的暂停时间。

返回值

无返回值。

提示和注释

注释：在 PHP 5 之前，该函数无法工作于 Windows 系统上。

注释：一微秒等于百万分之一秒。

例子

<?php
echo date('h:i:s') . "<br />";

//延迟 10 描述
usleep(10000000);

//再次开始
echo date('h:i:s');
?>

输出：

09:23:14
09:23:24

PHP 杂项函数

PHP 参考手册
PHP 测验


PHP usort() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP usort() 函数

PHP Array 函数

定义和用法

usort() 函数使用用户自定义的函数对数组排序。

注释：如果两个元素比较结果相同，则它们在排序后的数组中的顺序未经定义。到 PHP 4.0.6 之前，用户自定义函数将保留这些元素的原有顺序。但是由于在 4.1.0 中引进了新的排序算法，结果将不是这样了，因为对此没有一个有效的解决方案。

注释：本函数为 array 中的元素赋予新的键名。这会删除原有的键名。

语法

usort(array,sorttype)
参数 | 描述
array | 必需。规定要排序的数组。
function

必需。用户自定义的函数。

函数必须设计为返回 -1, 0, 或 1，并应该接受两个供比较的参数，同时以类似下面这样的方式来工作：

  • 如果 a = b, 返回 0
  • 如果 a > b, 返回 1
  • 如果 a < b, 返回 -1

例子

<?php
function my_sort($a, $b)
  {
  if ($a == $b) return 0;
  return ($a > $b) ? -1 : 1;
  }

$arr = array("Peter", "glenn","Cleveland","peter","cleveland", "Glenn");

usort($arr, "my_sort");

print_r ($arr);
?>

输出：

Array
(
[0] => peter
[1] => glenn
[2] => cleveland
[3] => Peter
[4] => Glenn
[5] => Cleveland
)

PHP Array 函数

PHP 参考手册
PHP 测验


PHP utf8_decode() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP utf8_decode() 函数

PHP XML Parser 函数

定义和用法

utf8_decode() 函数把 UTF-8 字符串解码为 ISO-8859-1。

该函数把用 UTF-8 方式编码的 ISO-8859-1 字符串转换成单字节的 ISO-8859-1 字符串。

如果成功，该函数将返回解码字符串；否则返回 false。

语法

utf8_decode(string)
参数 | 描述
string | 必需。规定要解码的字符串。

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP utf8_encode() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP utf8_encode() 函数

PHP XML Parser 函数

定义和用法

utf8_encode() 函数把 ISO-8859-1 字符串编码为 UTF-8。

Unicode 是全球标准，已经发展到能够通过唯一的编码来描述所有语言中的字符，外加大量的符号。

不过，并不是总能可靠地在计算机之间传递 Unicode 字符。UTF-8 可用于在计算机之间传输 Unicode 字符。

如果成功，该函数将返回编码字符串；否则返回 false。

语法

utf8_encode(string)
参数 | 描述
string | 必需。规定要编码的字符串。

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP vfprintf() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP vfprintf() 函数

PHP String 函数

定义和用法

vfprintf() 函数把格式化的字符串写到指定的输出流。

与 fprintf() 不同，vfprintf() 中的 arg 参数位于数组中。数组的元素会被插入主字符串的百分比 (%) 符号处。该函数是逐步执行的。在第一个 % 符号中，插入 arg1，在第二个 % 符号处，插入 arg2，依此类推。

该函数返回被写的字符串的长度。

语法

vfprintf(stream,format,argarray)
参数 | 描述
stream | 必需。规定在何处写/输出字符串。
format | 必需。转换格式。
argarray | 必需。带有参数的一个数组，这些参数会被插到 format 字符串中的 % 符号处。

说明

参数 format 是转换的格式，以百分比符号 ("%") 开始到转换字符结束。下面的可能的 format 值：

  • %% - 返回百分比符号
  • %b - 二进制数
  • %c - 依照 ASCII 值的字符
  • %d - 带符号十进制数
  • %e - 可续计数法（比如 1.5e+3）
  • %u - 无符号十进制数
  • %f - 浮点数(local settings aware)
  • %F - 浮点数(not local settings aware)
  • %o - 八进制数
  • %s - 字符串
  • %x - 十六进制数（小写字母）
  • %X - 十六进制数（大写字母）

提示和注释

注释：如果 % 符号多于 arg 参数，则您必须使用占位符。占位符插到 % 符号后面，由数字和 "\$" 组成。请参见例子 3。

提示：
相关函数：
fprintf()、
printf()、
sprintf()、
vprintf() 以及
vsprintf()。

例子

例子 1

<?php
$str = "Hello";
$number = 123;
$txt = sprintf("%s world. Day number %u",$str,$number);
echo $txt;
?>

输出：

Hello world. Day number 123

例子 2

<?php
$number = 123;
$txt = sprintf("%f",$number);
echo $txt;
?>

输出：

123.000000

例子 3

<?php
$number = 123;
$txt = sprintf("With 2 decimals: %1\$.2f<br />With no decimals: %1\$u",$number);
echo $txt;
?>

输出：

With 2 decimals: 123.00
With no decimals: 123

PHP String 函数

PHP 参考手册
PHP 测验


PHP vprintf() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP vprintf() 函数

PHP String 函数

定义和用法

vprintf() 函数输出格式化的字符串。

与 printf() 不同，vprintf() 中的 arg 参数位于数组中。数组的元素会被插入主字符串的百分比 (%) 符号处。该函数是逐步执行的。在第一个 % 符号中，插入 arg1，在第二个 % 符号处，插入 arg2，依此类推。

语法

vprintf(format,argarray)
参数 | 描述
format | 必需。转换格式。
argarray | 必需。带有参数的一个数组，这些参数会被插到 format 字符串中的 % 符号处。

说明

参数 format 是转换的格式，以百分比符号 ("%") 开始到转换字符结束。下面的可能的 format 值：

  • %% - 返回百分比符号
  • %b - 二进制数
  • %c - 依照 ASCII 值的字符
  • %d - 带符号十进制数
  • %e - 可续计数法（比如 1.5e+3）
  • %u - 无符号十进制数
  • %f - 浮点数(local settings aware)
  • %F - 浮点数(not local settings aware)
  • %o - 八进制数
  • %s - 字符串
  • %x - 十六进制数（小写字母）
  • %X - 十六进制数（大写字母）

提示和注释

注释：如果 % 符号多于 arg 参数，则您必须使用占位符。占位符插到 % 符号后面，由数字和 "\$" 组成。请参见例子 3。

提示：
相关函数：
fprintf()、
printf()、
sprintf()、
vfprintf() 以及
vsprintf()。

例子

例子 1

<?php
$str = "Hello";
$number = 123;
vprintf("%s world. Day number %u",array($str,$number));
?>

输出：

Hello world. Day number 123

例子 2

<?php
$num1 = 123;
$num2 = 456;
vprintf("%f%f",array($num1,$num2));
?>

输出：

123.000000456.000000

例子 3

使用占位符：

<?php
$number = 123;
vprintf("With 2 decimals: %1\$.2f<br />With no decimals: %1\$u",array($number));
?>

输出：

With 2 decimals: 123.00
With no decimals: 123

PHP String 函数

PHP 参考手册
PHP 测验


PHP vsprintf() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP vsprintf() 函数

PHP String 函数

定义和用法

vsprintf() 函数把格式化字符串写入变量中。

与 sprintf() 不同，vsprintf() 中的 arg 参数位于数组中。数组的元素会被插入主字符串的百分比 (%) 符号处。该函数是逐步执行的。在第一个 % 符号中，插入 arg1，在第二个 % 符号处，插入 arg2，依此类推。

语法

vsprintf(format,argarray)
参数 | 描述
format | 必需。转换格式。
argarray | 必需。带有参数的一个数组，这些参数会被插到 format 字符串中的 % 符号处。

说明

参数 format 是转换的格式，以百分比符号 ("%") 开始到转换字符结束。下面的可能的 format 值：

  • %% - 返回百分比符号
  • %b - 二进制数
  • %c - 依照 ASCII 值的字符
  • %d - 带符号十进制数
  • %e - 可续计数法（比如 1.5e+3）
  • %u - 无符号十进制数
  • %f - 浮点数(local settings aware)
  • %F - 浮点数(not local settings aware)
  • %o - 八进制数
  • %s - 字符串
  • %x - 十六进制数（小写字母）
  • %X - 十六进制数（大写字母）

提示和注释

注释：如果 % 符号多于 arg 参数，则您必须使用占位符。占位符插到 % 符号后面，由数字和 "\$" 组成。请参见例子 3。

提示：
相关函数：
fprintf()、
printf()、
sprintf()、
vfprintf() 以及
vprintf()。

例子

例子 1

<?php
$str = "Hello";
$number = 123;
$txt = vsprintf("%s world. Day number %u",array($str,$number));
echo $txt;
?>

输出：

Hello world. Day number 123

例子 2

<?php
$num1 = 123;
$num2 = 456;
$txt = vsprintf("%f%f",array($num1,$num2));
echo $txt;
?>

输出：

123.000000456.000000

例子 3

使用占位符：

<?php
$number = 123;
$txt = vsprintf("With 2 decimals: %1\$.2f
<br />With no decimals: %1\$u",array($number));
echo $txt;
?>

输出：

With 2 decimals: 123.00
With no decimals: 123

PHP String 函数

PHP 参考手册
PHP 测验


PHP wordwrap() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP wordwrap() 函数

PHP String 函数

定义和用法

wordwrap() 函数按照指定长度对字符串进行折行处理。

如果成功，则返回折行后的字符串。如果失败，则返回 false。

语法

wordwrap(string,width,break,cut)
参数 | 描述
string | 必需。规定要进行折行的字符串。
width | 可选。规定最大行宽度。默认是 75。
break | 可选。规定作为分隔符使用的字符（字串断开字符）。默认是 "\n"。
cut | 可选。规定是否对大约指定宽度的单词进行折行。默认是 FALSE (no-wrap)。

例子

例子 1

<?php
$str = "An example on a long word is: Supercalifragulistic";
echo wordwrap($str,15);
?>

浏览器输出：

An example on a long word is: Supercalifragulistic

HTML 源代码：

<html>
<body>
An example on a
long word is:
Supercalifragulistic
</body>
</html>

例子 2

<?php
$str = "An example on a long word is: Supercalifragulistic";
echo wordwrap($str,15,"<br />\n");
?>

输出：

An example on a
long word is:
Supercalifragulistic

例子 3

<?php
$str = "An example on a long word is: Supercalifragulistic";
echo wordwrap($str,15,"<br />\n",TRUE);
?>

输出：

An example on a
long word is:
Supercalifragul
istic

PHP String 函数

PHP 参考手册
PHP 测验


PHP XML DOM

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP XML DOM

  • Previous Page
  • Next Page

内建的 DOM 解析器使在 PHP 中处理 XML 文档成为可能。

什么是 DOM？

W3C DOM 提供了针对 HTML 和 XML 文档的标准对象集，以及用于访问和操作这些文档的标准接口。

W3C DOM 被分为不同的部分 (Core, XML 和 HTML) 和不同的级别 (DOM Level 1/2/3)：

  • Core DOM - 为任何结构化文档定义标准的对象集
  • XML DOM - 为 XML 文档定义标准的对象集
  • HTML DOM - 为 HTML 文档定义标准的对象集

如果您希望学习更多有关 XML DOM 的知识，请访问我们的 XML DOM 教程。

XML 解析

如需读取和更新 - 创建创建并处理 - 一个 XML 文档，您需要 XML 解析器。

有两种基本的 XML 解析器类型：

  • 基于树的解析器：这种解析器把 XML 文档转换为树型结构。它分析整篇文档，并提供了 API 来访问树种的元素，例如文档对象模型 (DOM)。
  • 基于事件的解析器：将 XML 文档视为一系列的事件。当某个具体的事件发生时，解析器会调用函数来处理。

DOM 解析器是基于树的解析器。

请看下面的 XML 文档片段：

<?xml version="1.0" encoding="ISO-8859-1"?>
<from>John</from>

XML DOM 把 XML 视为一个树形结构：

  • Level 1: XML 文档
  • Level 2: 根元素: <from>
  • Level 3: 文本元素: "John"

安装

DOM XML 解析器函数是 PHP 核心的组成部分。无需安装就可以使用这些函数。

XML 文件

将在我们的例子中使用下面的 XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

加载和输出 XML

我们需要初始化 XML 解析器，加载 XML，并把它输出：

例子

<?php
$xmlDoc = new DOMDocument();
$xmlDoc->load("note.xml");

print $xmlDoc->saveXML();
?>

以上代码的输出：

George John Reminder Don't forget the meeting!

假如您在浏览器窗口中查看源代码，会看到下面这些 HTML：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

上面的例子创建了一个 DOMDocument-Object，并把 "note.xml" 中的 XML 载入这个文档对象中。

saveXML() 函数把内部 XML 文档放入一个字符串，这样我们就可以输出它。

循环 XML

我们要初始化 XML 解析器，加载 XML，并循环 <note> 元素的所有元素：

例子

<?php
$xmlDoc = new DOMDocument();
$xmlDoc->load("note.xml");

$x = $xmlDoc->documentElement;
foreach ($x->childNodes AS $item)
  {
  print $item->nodeName . " = " . $item->nodeValue . "<br />";
  }
?>

以上代码的输出：

#text =
to = George
#text =
from = John
#text =
heading = Reminder
#text =
body = Don't forget the meeting!
#text =

在上面的例子中，您看到了每个元素之间存在空的文本节点。

当 XML 生成时，它通常会在节点之间包含空白。XML DOM 解析器把它们当作普通的元素，如果您不注意它们，有时会产生问题。

如果您希望学习更多有关 XML DOM 的知识，请访问我们的 XML DOM 教程。

  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP xml_error_string() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_error_string() 函数

PHP XML Parser 函数

定义和用法

xml_error_string() 函数获取 XML 解析器的错误描述。

语法

xml_error_string(errorcode)
参数 | 描述
errorcode | 必需。规定要使用的错误代码。该错误码是 xml_get_error_code() 函数的返回值。

说明

返回与 errorcode 描述的错误代码参数对应的文本描述字符串，若没有与之对应的描述，则返回 false。

例子

<?php
//无效的 xml 文件
$xmlfile = 'test.xml';

$xmlparser = xml_parser_create();

// open a file and read data
$fp = fopen($xmlfile, 'r');
while ($xmldata = fread($fp, 4096))
  {
  // parse the data chunk
  if (!xml_parse($xmlparser,$xmldata,feof($fp)))
    {
    die( print "ERROR: "
    . xml_error_string(xml_get_error_code($xmlparser))
    . "<br />"
    . "Line: "
    . xml_get_current_line_number($xmlparser)
    . "<br />"
    . "Column: "
    . xml_get_current_column_number($xmlparser)
    . "<br />");
    }
  }

xml_parser_free($xmlparser);
?>

输出：

ERROR: Mismatched tag
Line: 8
Column: 51

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP XML Expat 解析器

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP XML Expat 解析器

  • Previous Page
  • Next Page

内建的 Expat 解析器使在 PHP 中处理 XML 文档成为可能。

什么是 XML？

XML 用于描述数据，其焦点是数据是什么。XML 文件描述了数据的结构。

在 XML 中，没有预定义的标签。您必须定义自己的标签。

如果希望学习更多有关 XML 的内容，请访问我们的 XML 教程。

什么是 Expat？

如需读取和更新 - 创建创建并处理 - 一个 XML 文档，您需要 XML 解析器。

有两种基本的 XML 解析器类型：

  • 基于树的解析器：这种解析器把 XML 文档转换为树型结构。它分析整篇文档，并提供了 API 来访问树种的元素，例如文档对象模型 (DOM)。
  • 基于事件的解析器：将 XML 文档视为一系列的事件。当某个具体的事件发生时，解析器会调用函数来处理。

Expat 解析器是基于事件的解析器。

基于事件的解析器集中在 XML 文档的内容，而不是它们的结果。正因如此，基于事件的解析器能够比基于树的解析器更快地访问数据。

请看下面的 XML 片段：

<from>John</from>

基于事件的解析器把上面的 XML 报告为一连串的三个事件：

  • 开始元素：from
  • 开始 CDATA 部分, 值：John
  • 关闭元素： from

上面的 XML 范例包含了形式良好的 XML。不过这个例子是无效的 XML，因为没有与它关联的文档类型声明 (DTD)，也没有内嵌的 DTD。

不过，在使用 Expat 解析器时，这没有区别。Expat 是不检查有效性的解析器，忽略任何 DTD。

作为一款基于事件、非验证的 XML 解析器，Expat 快速且轻巧，十分适合 PHP 的 web 应用程序。

注释：XML 文档必须形式良好，否则 Expat 会生成错误。

安装

XML Expat 解析器是 PHP 核心的组成部分。无需安装就可以使用这些函数。

XML 文件

将在我们的例子中使用下面的 XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

初始化 XML 解析器

我们要在 PHP 中初始化 XML 解析器，为不同的 XML 事件定义处理器，然后解析这个 XML 文件。

例子

<?php

//Initialize the XML parser
$parser=xml_parser_create();

//Function to use at the start of an element
function start($parser,$element_name,$element_attrs)
  {
  switch($element_name)
    {
    case "NOTE":
    echo "-- Note --<br />";
    break;
    case "TO":
    echo "To: ";
    break;
    case "FROM":
    echo "From: ";
    break;
    case "HEADING":
    echo "Heading: ";
    break;
    case "BODY":
    echo "Message: ";
    }
  }

//Function to use at the end of an element
function stop($parser,$element_name)
  {
  echo "<br />";
  }

//Function to use when finding character data
function char($parser,$data)
  {
  echo $data;
  }

//Specify element handler
xml_set_element_handler($parser,"start","stop");

//Specify data handler
xml_set_character_data_handler($parser,"char");

//Open XML file
$fp=fopen("test.xml","r");

//Read data
while ($data=fread($fp,4096))
  {
  xml_parse($parser,$data,feof($fp)) or
  die (sprintf("XML Error: %s at line %d",
  xml_error_string(xml_get_error_code($parser)),
  xml_get_current_line_number($parser)));
  }

//Free the XML parser
xml_parser_free($parser);

?>

以上代码的输出：

-- Note --
To: George
From: John
Heading: Reminder
Message: Don't forget the meeting!

工作原理解释：

  • 通过 xml_parser_create() 函数初始化 XML 解析器
  • 创建配合不同事件处理程序的的函数
  • 添加 xml_set_element_handler() 函数来定义，当解析器遇到开始和结束标签时执行哪个函数
  • 添加 xml_set_character_data_handler() 函数来定义，当解析器遇到字符数据时执行哪个函数
  • 通过 xml_parse() 函数来解析文件 "test.xml"
  • 万一有错误的话，添加 xml_error_string() 函数把 XML 错误转换为文本说明
  • 调用 xml_parser_free() 函数来释放分配给 xml_parser_create() 函数的内存

更多 PHP Expat 解析器的信息

如需更多有关 PHP Expat 函数的信息，请访问我们的 PHP XML Parser 参考手册。

  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP xml_get_current_byte_index() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_get_current_byte_index() 函数

PHP XML Parser 函数

定义和用法

xml_get_current_byte_index() 函数获取 XML 解析器的当前字节索引。

语法

xml_get_current_byte_index(parser)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。

说明

如果 parser 没有指向一个合法的解析器，该函数将返回 false，否则将返回解析器当前在其数据缓冲区中的字节索引（起始值为 0）。

例子

<?php
//无效的 xml 文件
$xmlfile = 'test.xml';

$xmlparser = xml_parser_create();

// 打开文件并读取数据
$fp = fopen($xmlfile, 'r');
while ($xmldata = fread($fp, 4096))
  {
  // parse the data chunk
  if (!xml_parse($xmlparser,$xmldata,feof($fp)))
    {
    die( print "ERROR: "
    . xml_error_string(xml_get_error_code($xmlparser))
    . "<br />"
    . "Line: "
    . xml_get_current_line_number($xmlparser)
    . "<br />"
    . "Column: "
    . xml_get_current_column_number($xmlparser)
    . "<br />"
    . "Byte Index: "
    . xml_get_current_byte_index($xmlparser)
    . "<br />");
    }
  }

xml_parser_free($xmlparser);
?>

输出：

ERROR: Mismatched tag
Line: 8
Column: 51
Byte Index: 96

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_get_current_column_number() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_get_current_column_number() 函数

PHP XML Parser 函数

定义和用法

xml_get_current_column_number() 函数获取 XML 解析器的当前列号。

语法

xml_get_current_byte_index(parser)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。

说明

如果 parser 参数没有指向一个合法的解析器，该函数将返回 false。否则将返回指定解析器所在行（由函数 xml_get_current_line_number() 给定）的当前列号。

例子

<?php
//无效 xml 文件
$xmlfile = 'test.xml';

$xmlparser = xml_parser_create();

// 打开文件并读取数据
$fp = fopen($xmlfile, 'r');
while ($xmldata = fread($fp, 4096))
  {
  // parse the data chunk
  if (!xml_parse($xmlparser,$xmldata,feof($fp)))
    {
    die( print "ERROR: "
    . xml_error_string(xml_get_error_code($xmlparser))
    . "<br />"
    . "Line: "
    . xml_get_current_line_number($xmlparser)
    . "<br />"
    . "Column: "
    . xml_get_current_column_number($xmlparser)
    . "<br />");
    }
  }

xml_parser_free($xmlparser);
?>

输出：

ERROR: Mismatched tag
Line: 8
Column: 61

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_get_current_line_number() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_get_current_line_number() 函数

PHP XML Parser 函数

定义和用法

xml_get_current_line_number() 函数获取 XML 解析器的当前行号。

语法

xml_get_current_line_number(parser)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。

说明

如果 parser 参数没有指向一个合法的解析器，该函数将返回 FALSE，否则将返回指定解析器在其缓存中的当前行号。

例子

<?php
//无效 xml 文件
$xmlfile = 'test.xml';

$xmlparser = xml_parser_create();

// 打开文件并读取数据
$fp = fopen($xmlfile, 'r');
while ($xmldata = fread($fp, 4096))
  {
  // parse the data chunk
  if (!xml_parse($xmlparser,$xmldata,feof($fp)))
    {
    die( print "ERROR: "
    . xml_error_string(xml_get_error_code($xmlparser))
    . "<br />"
    . "Line: "
    . xml_get_current_line_number($xmlparser)
    . "<br />"
    . "Column: "
    . xml_get_current_column_number($xmlparser)
    . "<br />");
    }
  }

xml_parser_free($xmlparser);
?>

输出：

ERROR: Mismatched tag
Line: 8
Column: 61

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_get_error_code() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_get_error_code() 函数

PHP XML Parser 函数

定义和用法

xml_get_error_code() 函数获取 XML 解析器错误代码。

如果成功，则返回错误代码。否则，返回 false。

语法

xml_get_error_code(parser)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。

例子

<?php
//无效的 xml 文件
$xmlfile = 'test.xml';

$xmlparser = xml_parser_create();

// 打开文件并读取数据
$fp = fopen($xmlfile, 'r');
while ($xmldata = fread($fp, 4096))
  {
  // parse the data chunk
  if (!xml_parse($xmlparser,$xmldata,feof($fp)))
    {
    die( print "ERROR: "
    . xml_get_error_code($xmlparser)
    . "<br />"
    . "Line: "
    . xml_get_current_line_number($xmlparser)
    . "<br />"
    . "Column: "
    . xml_get_current_column_number($xmlparser)
    . "<br />");
    }
  }

xml_parser_free($xmlparser);
?>

输出：

ERROR: 76
Line: 8
Column: 61

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_parse_into_struct() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_parse_into_struct() 函数

PHP XML Parser 函数

定义和用法

xml_parse_into_struct() 函数把 XML 数据解析到数组中。

该函数把 XML 数据解析到 2 个数组中：

  • Value 数组 - 包含来自被解析的 XML 的数据
  • Index 数组 - 包含指向Value 数组中值的位置的指针

如果成功，则该函数返回 1。否则返回 0。

语法

xml_parse_into_struct(parser,xml,value_arr,index_arr)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
xml | 必需。规定要解析的 XML 数据。
parser | 必需。规定 XML 数据的目标数组。
parser | 可选。规定 index 数据的目标数组。

提示和注释

注释：xml_parse_into_struct() 若失败返回 0，成功则返回 1。这和 false 与 true 不同，使用例如 === 运算符时要注意。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP 代码：

<?php
//无效 xml 文件
$xmlfile = 'test.xml';
$xmlparser = xml_parser_create();

// 打开文件并读取数据
$fp = fopen($xmlfile, 'r');
$xmldata = fread($fp, 4096);

xml_parse_into_struct($xmlparser,$xmldata,$values);

xml_parser_free($xmlparser);
print_r($values);
?>

输出：

Array
(
[0] => Array
  (
  [tag] => NOTE
  [type] => open
  [level] => 1
  [value] =>
  )
  [1] => Array
    (
    [tag] => TO
    [type] => complete
    [level] => 2
    [value] => George
    )
[2] => Array
  (
  [tag] => NOTE
  [value] =>
  [type] => cdata
  [level] => 1
  )
  [3] => Array
    (
    [tag] => FROM
    [type] => complete
    [level] => 2
    [value] => John
    )
[4] => Array
  (
  [tag] => NOTE
  [value] =>
  [type] => cdata
  [level] => 1
  )
  [5] => Array
    (
    [tag] => HEADING
    [type] => complete
    [level] => 2
    [value] => Reminder
    )
[6] => Array
  (
  [tag] => NOTE
  [value] =>
  [type] => cdata
  [level] => 1
  )
  [7] => Array
    (
    [tag] => BODY
    [type] => complete
    [level] => 2
    [value] => Don't forget the meeting!
    )
[8] => Array
  (
  [tag] => NOTE
  [value] =>
  [type] => cdata
  [level] => 1
  )
[9] => Array
  (
  [tag] => NOTE
  [type] => close
  [level] => 1
  )
)

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_parse() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_parse() 函数

PHP XML Parser 函数

定义和用法

xml_parse() 函数解析 XML 文档。

如果成功，则返回 true。否则，返回 false。

语法

xml_parse(parser,xml,end)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
xml | 必需。规定要解析的 XML 数据。
end | 可选。如果该参数是 true，则 xml 参数中的数据为当前解析中最后一段数据。

提示和注释

提示：要创建 XML 解析器，请使用 xml_parser_create() 函数。

例子

<?php
//无效的 xml 文件
$xmlfile = 'test.xml';

$xmlparser = xml_parser_create();

// 打开文件并读取数据
$fp = fopen($xmlfile, 'r');
while ($xmldata = fread($fp, 4096))
  {
  // parse the data chunk
  if (!xml_parse($xmlparser,$xmldata,feof($fp)))
    {
    die( print "ERROR: "
    . xml_get_error_code($xmlparser)
    . "<br />"
    . "Line: "
    . xml_get_current_line_number($xmlparser)
    . "<br />"
    . "Column: "
    . xml_get_current_column_number($xmlparser)
    . "<br />");
    }
  }

xml_parser_free($xmlparser);
?>

输出：

ERROR: 76
Line: 8
Column: 61

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_parser_create_ns() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_parser_create_ns() 函数

PHP XML Parser 函数

定义和用法

xml_parser_create_ns() 函数创建带有命名空间支持的 XML 解析器。

该函数建立一个新的 XML 解析器并返回可被其它 XML 函数使用的资源句柄。

语法

xml_parser_create_ns(encoding,separator)
参数 | 描述
encoding | 可选。规定输出编码。
encoding | 可选。规定标签名和命名空间的输出分隔符。默认是 ":"。

说明

可选参数 encoding 在 PHP 4 中用来指定要被解析的 XML 输入的字符编码方式。

PHP 5 开始，自动侦测输入的 XML 的编码，因此 encoding 参数仅用来指定解析后输出数据的编码。

在 PHP 4 中，默认输出的编码与输入数据的编码是相同的。如果传递了空字符串，解析器会尝试搜索头 3 或 4 个字节以确定文档的编码。

在 PHP 5.0.0 和 5.0.1 中，默认输出的字符编码是 ISO-8859-1，而 PHP 5.0.2 及以上版本是 UTF-8。

解析器支持的编码有 ISO-8859-1, UTF-8 和 US-ASCII。

提示和注释

提示：要释放 XML 解析器，请使用 xml_parser_free() 函数。

提示：要创建没有命名空间支持的 XML 解析器，请使用 xml_parser_create() 函数。

例子

<?php
$xmlparser = xml_parser_create_ns();

xml_parser_free($xmlparser);
?>

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_parser_create() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_parser_create() 函数

PHP XML Parser 函数

定义和用法

xml_parser_create() 函数创建 XML 解析器。

该函数建立一个新的 XML 解析器并返回可被其它 XML 函数使用的资源句柄。

语法

xml_parser_create(encoding)
参数 | 描述
encoding | 可选。规定输出编码。

说明

可选参数 encoding 在 PHP 4 中用来指定要被解析的 XML 输入的字符编码方式。

PHP 5 开始，自动侦测输入的 XML 的编码，因此 encoding 参数仅用来指定解析后输出数据的编码。

在 PHP 4 中，默认输出的编码与输入数据的编码是相同的。如果传递了空字符串，解析器会尝试搜索头 3 或 4 个字节以确定文档的编码。

在 PHP 5.0.0 和 5.0.1 中，默认输出的字符编码是 ISO-8859-1，而 PHP 5.0.2 及以上版本是 UTF-8。

解析器支持的编码有 ISO-8859-1, UTF-8 和 US-ASCII。

提示和注释

提示：要释放 XML 解析器，请使用 xml_parser_free() 函数。

提示：要创建带有命名空间支持的 XML 解析器，请使用 xml_parser_create_ns() 函数。

例子

<?php
$xmlparser = xml_parser_create();

xml_parser_free($xmlparser);
?>

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_parser_free() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_parser_free() 函数

PHP XML Parser 函数

定义和用法

xml_parser_free() 函数释放 XML 解析器。

如果成功，则返回 true。否则返回 false。

语法

xml_parser_free(parser)
参数 | 描述
parser | 必需。规定要释放的 XML 解析器。

提示和注释

提示：要创建 XML 解析器，请使用 xml_parser_create() 函数。

例子

<?php
$xmlparser = xml_parser_create();

xml_parser_free($xmlparser);
?>

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_parser_get_option() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_parser_get_option() 函数

PHP XML Parser 函数

定义和用法

xml_parser_get_option() 函数从 XML 解析器获取选项设置信息。

语法

xml_parser_get_option(parser,option)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
option

必需。规定要获取的设置选项名称。可能的值：

  • XML_OPTION_CASE_FOLDING
  • XML_OPTION_TARGET_ENCODING

说明

如果 parser 参数没有指向一个合法的解析器或者 option 参数无效，该函数将返回 FALSE（同时产生 E_WARNING 警告）。否则将返回指定设置选项的值。

例子

<?php
$xmlparser = xml_parser_create();

echo xml_parser_get_option($xmlparser, XML_OPTION_CASE_FOLDING);

xml_parser_free($xmlparser);
?>

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_parser_set_option() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_parser_set_option() 函数

PHP XML Parser 函数

定义和用法

xml_parser_set_option() 函数为 XML 解析器进行选项设置。

如果成功，则返回 true。如果失败，则返回 false。

语法

xml_parser_set_option(parser,option,value)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
option

必需。规定要设置的设置选项名称。可能的值：

  • XML_OPTION_CASE_FOLDING
  • XML_OPTION_SKIP_TAGSTART
  • XML_OPTION_SKIP_WHITE
  • XML_OPTION_TARGET_ENCODING
value | 必需。规定选项的新值。

例子

<?php
$xmlparser = xml_parser_create();

xml_parser_set_option($xmlparser, XML_OPTION_SKIP_WHITE, 1);

xml_parser_free($xmlparser);
?>

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP XML Parser 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP XML Parser 函数

  • Previous Page
  • Next Page

PHP XML Parser 简介

XML 函数允许我们解析 XML 文档，但无法对其进行验证。

XML 是一种用于标准结构化文档交换的数据格式。您可以在我们的 XML 教程 中找到更多有关 XML 的信息。

该扩展使用 Expat XML 解析器。

Expat 是一种基于事件的解析器，它把 XML 文档视为一系列事件。当某个事件发生时，它调用一个指定的函数处理它。

Expat 是无验证的解析器，忽略任何链接到文档的 DTD。但是，如果文档的形式不好，则会以一个错误消息结束。

由于它基于事件，且无验证，Expat 具有快速并适合 web 应用程序的特性。

XML 解析器函数允许我们创建 XML 解析器，并为 XML 事件定义句柄。

安装

XML 函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

PHP XML Parser 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
utf8_decode() | 把 UTF-8 字符串解码为 ISO-8859-1。 | 3
utf8_encode() | 把 ISO-8859-1 字符串编码为 UTF-8。 | 3
xml_error_string() | 获取 XML 解析器的错误描述。 | 3
xml_get_current_byte_index() | 获取 XML 解析器的当前字节索引。 | 3
xml_get_current_column_number() | 获取 XML 解析器的当前列号。 | 3
xml_get_current_line_number() | 获取 XML 解析器的当前行号。 | 3
xml_get_error_code() | 获取 XML 解析器错误代码。 | 3
xml_parse() | 解析 XML 文档。 | 3
xml_parse_into_struct() | 把 XML 数据解析到数组中。 | 3
xml_parser_create_ns() | 创建带有命名空间支持的 XML 解析器。 | 4
xml_parser_create() | 创建 XML 解析器。 | 3
xml_parser_free() | 释放 XML 解析器。 | 3
xml_parser_get_option() | 从 XML 解析器获取选项设置信息。 | 3
xml_parser_set_option() | 为 XML 解析进行选项设置。 | 3
xml_set_character_data_handler() | 建立字符数据处理器。 | 3
xml_set_default_handler() | 建立默认的数据处理器。 | 3
xml_set_element_handler() | 建立起始和终止元素处理器。 | 3
xml_set_end_namespace_decl_handler() | 建立终止命名空间声明处理器。 | 4
xml_set_external_entity_ref_handler() | 建立外部实体处理器。 | 3
xml_set_notation_decl_handler() | 建立注释声明处理器。 | 3
xml_set_object() | 在对象中使用 XML 解析器。 | 4
xml_set_processing_instruction_handler() | 建立处理指令（PI）处理器。 | 3
xml_set_start_namespace_decl_handler() | 建立起始命名空间声明处理器。 | 4
xml_set_unparsed_entity_decl_handler() | 建立未解析实体定义声明处理器。 | 3

PHP XML Parser 常量

Constant
XML_ERROR_NONE (integer)
XML_ERROR_NO_MEMORY (integer)
XML_ERROR_SYNTAX (integer)
XML_ERROR_NO_ELEMENTS (integer)
XML_ERROR_INVALID_TOKEN (integer)
XML_ERROR_UNCLOSED_TOKEN (integer)
XML_ERROR_PARTIAL_CHAR (integer)
XML_ERROR_TAG_MISMATCH (integer)
XML_ERROR_DUPLICATE_ATTRIBUTE (integer)
XML_ERROR_JUNK_AFTER_DOC_ELEMENT (integer)
XML_ERROR_PARAM_ENTITY_REF (integer)
XML_ERROR_UNDEFINED_ENTITY (integer)
XML_ERROR_RECURSIVE_ENTITY_REF (integer)
XML_ERROR_ASYNC_ENTITY (integer)
XML_ERROR_BAD_CHAR_REF (integer)
XML_ERROR_BINARY_ENTITY_REF (integer)
XML_ERROR_ATTRIBUTE_EXTERNAL_ENTITY_REF (integer)
XML_ERROR_MISPLACED_XML_PI (integer)
XML_ERROR_UNKNOWN_ENCODING (integer)
XML_ERROR_INCORRECT_ENCODING (integer)
XML_ERROR_UNCLOSED_CDATA_SECTION (integer)
XML_ERROR_EXTERNAL_ENTITY_HANDLING (integer)
XML_OPTION_CASE_FOLDING (integer)
XML_OPTION_TARGET_ENCODING (integer)
XML_OPTION_SKIP_TAGSTART (integer)
XML_OPTION_SKIP_WHITE (integer)
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP xml_set_character_data_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_set_character_data_handler() 函数

PHP XML Parser 函数

定义和用法

xml_set_character_data_handler() 函数建立字符数据处理器。

该函数规定当解析器在 XML 文件中找到字符数据时所调用的函数。

如果处理器被成功的建立，该函数将返回 true；否则返回 false。

语法

xml_set_character_data_handler(parser,handler)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
handler | 必需。规定作为事件处理器使用的函数。

由 handler 参数规定的函数必须有两个参数：

参数 | 描述
parser | 必需。规定一个变量，包含调用处理器的 XML 解析器。
data | 必需。规定包含字符数据的变量。

说明

handler 参数也可以是一个数组，其中包含对象引用和方法名。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP 代码：

<?php

$parser=xml_parser_create();

function char($parser,$data)
  {
  echo $data;
  }

xml_set_character_data_handler($parser,"char");
$fp=fopen("test.xml","r");

while ($data=fread($fp,4096))
  {
  xml_parse($parser,$data,feof($fp)) or
  die (sprintf("XML Error: %s at line %d",
  xml_error_string(xml_get_error_code($parser)),
  xml_get_current_line_number($parser)));
  }

xml_parser_free($parser);
?>

输出：

George John Reminder Don't forget the meeting!

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_set_default_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_set_default_handler() 函数

PHP XML Parser 函数

定义和用法

xml_set_default_handler() 函数为 XML 解析器建立默认的数据处理器。

该函数规定在只要解析器在 XML 文件中找到数据时，所调用的函数。

如果处理器被成功的建立，该函数将返回 true；否则返回 false。

语法

xml_set_default_handler(parser,handler)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
handler | 必需。规定作为事件处理器使用的函数。

由 handler 参数规定的函数必须有三个参数：

参数 | 描述
parser | 必需。规定一个变量，包含调用处理器的 XML 解析器。
data | 必需。规定包含数据的变量。

说明

handler 参数也可以是一个数组，其中包含对象引用和方法名。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP 代码：

<?php

$parser=xml_parser_create();

function default($parser,$data)
  {
  echo $data;
  }

xml_set_default_handler($parser,"default");
$fp=fopen("test.xml","r");

while ($data=fread($fp,4096))
  {
  xml_parse($parser,$data,feof($fp)) or
  die (sprintf("XML Error: %s at line %d",
  xml_error_string(xml_get_error_code($parser)),
  xml_get_current_line_number($parser)));
  }

xml_parser_free($parser);
?>

输出：

George John Reminder Don't forget the meeting!

如果在浏览器中查看源代码，会看到下列 HTML：

<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_set_element_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_set_element_handler() 函数

PHP XML Parser 函数

定义和用法

xml_set_element_handler() 函数建立起始和终止元素处理器。

如果处理器被成功的建立，该函数将返回 true；否则返回 false。

语法

xml_set_element_handler(parser,start,end)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
start | 必需。规定在元素开始调用的函数。
end | 必需。规定在元素结束调用的函数。

由 start 参数规定的函数必须有三个参数：

参数 | 描述
parser | 必需。规定一个变量，包含调用处理器的 XML 解析器。
name | 必需。规定一个变量，包含元素的名称，这个元素触发该函数。
data | 必需。规定一个数组，包含元素属性。

由 end 参数规定的函数必须有三个参数：

参数 | 描述
parser | 必需。规定一个变量，包含调用处理器的 XML 解析器。
name | 必需。规定一个变量，包含元素的名称，这个元素触发该函数。

说明

start 和 end 参数也可以是一个数组，其中包含对象引用和方法名。

例子

<?php

$parser=xml_parser_create();

function start($parser,$element_name,$element_attrs)
  {
  switch($element_name)
    {
    case "NOTE":
    echo "-- Note --<br />";
    break;
    case "TO":
    echo "To: ";
    break;
    case "FROM":
    echo "From: ";
    break;
    case "HEADING":
    echo "Heading: ";
    break;
    case "BODY":
    echo "Message: ";
    }
  }

function stop($parser,$element_name)
  {
  echo "<br />";
  }

function char($parser,$data)
  {
  echo $data;
  }

xml_set_element_handler($parser,"start","stop");
xml_set_character_data_handler($parser,"char");
$fp=fopen("test.xml","r");

while ($data=fread($fp,4096))
  {
  xml_parse($parser,$data,feof($fp)) or
  die (sprintf("XML Error: %s at line %d",
  xml_error_string(xml_get_error_code($parser)),
  xml_get_current_line_number($parser)));
  }

xml_parser_free($parser);

?>

输出：

-- Note --
To: George
From: John
Heading: Reminder
Message: Don't forget the meeting!

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_set_external_entity_ref_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_set_external_entity_ref_handler() 函数

PHP XML Parser 函数

定义和用法

xml_set_external_entity_ref_handler() 函数规定当解析器在 XML 文档中找到外部实体时被调用的函数。

如果处理器被成功的建立，该函数将返回 true；否则返回 false。

语法

xml_set_external_entity_ref_handler(parser,handler)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
handler | 必需。规定当解析器找到外部实体时被调用的函数。

由 handler 参数规定的函数必须有六个参数：

参数 | 描述
parser | 必需。规定一个变量，包含调用处理器的 XML 解析器。
name | 必需。规定包含外部实体名称的变量。
base | 必需。规定一个变量，包含解析外部实体的系统标识符（system_id ）的基础。 当前该参数通常都被设置为空字符串。
system_id | 必需。规定包含外部实体的系统标识符的变量。
public_id | 必需。规定包含外部实体的公共标识符的变量。

说明

handler 参数也可以是一个数组，其中包含对象引用和方法名。

例子

<?php

$parser=xml_parser_create();

function char($parser,$data)
  {
  echo $data;
  }

function ext_ent_handler($parser,$ent,$base,$sysID,$pubID)
  {
  echo "$ent";
  echo "$sysID";
  echo "$pubID";
  }

xml_set_character_data_handler($parser,"char");
xml_set_external_entity_ref_handler($parser, "ext_ent_handler");
$fp=fopen("test.xml","r");

while ($data=fread($fp,4096))
  {
  xml_parse($parser,$data,feof($fp)) or
  die (sprintf("XML Error: %s at line %d",
  xml_error_string(xml_get_error_code($parser)),
  xml_get_current_line_number($parser)));
  }

xml_parser_free($parser);

?>

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_set_notation_decl_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_set_notation_decl_handler() 函数

PHP XML Parser 函数

定义和用法

xml_set_notation_decl_handler() 函数规定当解析器在 XML 文档中找到符号声明时被调用的函数。

如果处理器被成功的建立，该函数将返回 true；否则返回 false。

注释：“符号声明”，英文为 notation declaration，也有部分文献译为“注释声明”。

语法

xml_set_notation_decl_handler(parser,handler)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
handler | 必需。规定当解析器找到符号声明时被调用的函数。

由 handler 参数规定的函数必须有六个参数：

参数 | 描述
parser | 必需。规定一个变量，包含调用处理器的 XML 解析器。
name | 必需。规定包含实体名称的变量。
base | 必需。规定一个变量，包含解析实体的系统标识符（system_id ）的基础。 当前该参数通常都被设置为空字符串。
system_id | 必需。规定包含实体的系统标识符的变量。
public_id | 必需。规定包含实体的公共标识符的变量。
notation | 必需。规定一个变量，包含标识实体数据类型的符号。

说明

handler 参数也可以是一个数组，其中包含对象引用和方法名。

例子

<?php

$parser=xml_parser_create();

function char($parser,$data)
  {
  echo $data;
  }

function not_decl_handler($parser,$not,$base,$sysID,$pubID)
  {
  echo "$not<br />";
  echo "$sysID<br />";
  echo "$pubID<BR />";
  }

xml_set_character_data_handler($parser,"char");
xml_set_notation_decl_handler($parser, "not_decl_handler");
$fp=fopen("test.xml","r");

while ($data=fread($fp,4096))
  {
  xml_parse($parser,$data,feof($fp)) or
  die (sprintf("XML Error: %s at line %d",
  xml_error_string(xml_get_error_code($parser)),
  xml_get_current_line_number($parser)));
  }

xml_parser_free($parser);

?>

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_set_object() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_set_object() 函数

PHP XML Parser 函数

定义和用法

xml_set_object() 函数允许在对象中使用 XML 解析器。

语法

xml_set_object(parser,object)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
object | 必需。规定设置解析器的对象。

说明

该函数使得 parser 指定的解析器可以被用在 object 对象中。所有的回叫函数（callback function）都可以由 xml_set_element_handler() 等函数来设置，它们被假定为 object 对象的方法。

例子

<?php
class XMLParser
{
var $xmlparser;

function XMLParser()
  {
  $this->xmlparser = xml_parser_create();
  xml_set_object($this->xmlparser, $this);
  xml_set_character_data_handler($this->xmlparser,"char");
  xml_set_element_handler($this->xmlparser, "start_tag","end_tag");
  }

function parse($data)
  {
  xml_parse($this->xmlparser, $data);
  }

function parse_File($xmlfile)
  {
  $fp = fopen($xmlfile, 'r');
  while ($xmldata = fread($fp, 4096))
    {
    if
    (!xml_parse($this->xmlparser, $xmldata))
      {
      //If error
      die( print "ERROR: "
      . xml_error_string(xml_get_error_code($this->xmlparser))
      . "<br />Line: "
      . xml_get_current_line_number($this->xmlparser)
      . "<br />Column: "
      . xml_get_current_column_number($this->xmlparser)
      . "<br />");
      }
    }
  }

function start_tag($xmlparser, $tag, $attributes)
  {
  print $tag . "<br />";
  }

function end_tag(){}

function char($xmlparser,$data)
  {
  echo $data . "<br />";
  }

function close_Parser()
  {
  xml_parser_free($this->xmlparser);
  }
}

$myxmlparser = new XMLParser();
$myxmlparser->parse_File("test.xml");
$myxmlparser->close_parser();

?>

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_set_processing_instruction_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_set_processing_instruction_handler() 函数

PHP XML Parser 函数

定义和用法

xml_set_processing_instruction_handler() 函数规定当解析器在 XML 文档中找到处理指令时所调用的函数。

处理指令包含在 <? 和 ?> 分隔符中。

如果处理器被成功的建立，该函数将返回 true；否则返回 false。

例子：在本例中，处理指令把一个样式表与 XML 文档关联起来：

<?xml version="1.0" encoding="ISO-8859-1"?>
<?xml-stylesheet href="default.xsl" type="text/xml"?>
<note>
<to>Tove</to>
<from>Jani</from>
<heading>Reminder</heading>
<body>Don't forget me this weekend!</body>
</note>

语法

xml_set_processing_instruction_handler(parser,handler)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
handler | 必需。规定一个函数。

由 handler 参数规定的函数必须有三个参数：

参数 | 描述
parser | 必需。规定一个变量，包含调用处理器的 XML 解析器。
target | 必需。规定包含处理指令目标的变量。
data | 必需。规定包含处理指令数据的变量。

说明

handler 参数也可以是一个数组，其中包含对象引用和方法名。

例子

<?php

$parser=xml_parser_create();

function char($parser,$data)
  {
  echo $data;
  }

function pi_handler($parser, $target, $data)
  {
  echo "Target: $target<br />";
  echo "Data: $data<br />";
  }

xml_set_character_data_handler($parser,"char");
xml_set_processing_instruction_handler($parser, "pi_handler");
$fp=fopen("test.xml","r");

while ($data=fread($fp,4096))
  {
  xml_parse($parser,$data,feof($fp)) or
  die (sprintf("XML Error: %s at line %d",
  xml_error_string(xml_get_error_code($parser)),
  xml_get_current_line_number($parser)));
  }

xml_parser_free($parser);

?>

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xml_set_unparsed_entity_decl_handler() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xml_set_unparsed_entity_decl_handler() 函数

PHP XML Parser 函数

定义和用法

xml_set_unparsed_entity_decl_handler() 函数规定在遇到无法解析的实体名称（NDATA）声明时被调用的函数。

如果处理器被成功的建立，该函数将返回 true；否则返回 false。

语法

xml_set_unparsed_entity_decl_handler(parser,handler)
参数 | 描述
parser | 必需。规定要使用的 XML 解析器。
handler | 必需。规定一个函数。

由 handler 参数规定的函数必须有六个参数：

参数 | 描述
parser | 必需。规定一个变量，包含调用处理器的 XML 解析器。
name | 必需。规定包含实体名称的变量。
base | 必需。规定一个变量，包含解析实体的系统标识符（system_id ）的基础。 当前该参数通常都被设置为空字符串。
system_id | 必需。规定包含实体的系统标识符的变量。
public_id | 必需。规定包含实体的公共标识符的变量。
notation | 必需。规定一个变量，包含标识实体数据类型的符号。

说明

handler 参数也可以是一个数组，其中包含对象引用和方法名。

例子

<?php

$parser=xml_parser_create();

function char($parser,$data)
  {
  echo $data;
  }

function unparsed_ent_handler($parser,$entname,
$base,$sysID,$pubID,$notname)
  {
  print "$entname";
  print "$sysID";
  print "$pubID";
  print "$notname";
  }

xml_set_character_data_handler($parser,"char");
xml_set_unparsed_entity_decl_handler($parser,
"unparsed_ent_handler");

$fp=fopen("test.xml","r");

while ($data=fread($fp,4096))
  {
  xml_parse($parser,$data,feof($fp)) or
  die (sprintf("XML Error: %s at line %d",
  xml_error_string(xml_get_error_code($parser)),
  xml_get_current_line_number($parser)));
  }

xml_parser_free($parser);

?>

PHP XML Parser 函数

PHP 参考手册
PHP 测验


PHP xpath() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP xpath() 函数

PHP SimpleXML 函数

定义和用法

xpath() 函数运行对 XML 文档的 XPath 查询。

如果成功，则返回包含 SimpleXMLElement 对象的一个数组。如果失败，则返回 false。

语法

class SimpleXMLElement
{
string xpath(path)
}
参数 | 描述
path | 必需。XPath 路径。

例子

XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

PHP 代码：

<?php
$xml = simplexml_load_file("test.xml");

$result = $xml->xpath("from");

print_r($result);
?>

输出：

Array
(
[0] => SimpleXMLElement Object
  (
  [0] => John
  )
)

PHP SimpleXML 函数

PHP 参考手册
PHP 测验


PHP zip_close() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP zip_close() 函数

PHP Zip File 函数

定义和用法

zip_close() 函数关闭由 zip_open() 函数打开的 zip 档案文件。

语法

zip_close(zip)
参数 | 描述
zip | 必需。规定要关闭的 zip 资源（由 zip_open() 打开的 zip 文件）。

例子

<?php
$zip = zip_open("test.zip");

zip_read($zip);

// 一些代码...

zip_close($zip);
?>

PHP Zip File 函数

PHP 参考手册
PHP 测验


PHP zip_entry_close() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP zip_entry_close() 函数

PHP Zip File 函数

定义和用法

zip_entry_close() 函数关闭由 zip_entry_open() 函数打开的 zip 档案文件。

语法

zip_entry_close(zip_entry)
参数 | 描述
zip_entry | 必需。规定要关闭的 zip 项目资源（由 zip_read() 打开的 zip 项目）。

例子

<?php
$zip = zip_open("test.zip");

if ($zip)
  {
  while ($zip_entry = zip_read($zip))
    {
    echo "<p>";
    echo "Name: " . zip_entry_name($zip_entry) . "<br />";

    if (zip_entry_open($zip, $zip_entry))
      {
      // 一些代码...
      zip_entry_close($zip_entry);
      }
    echo "</p>";
  }
zip_close($zip);
}
?>

PHP Zip File 函数

PHP 参考手册
PHP 测验


PHP zip_entry_compressedsize() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP zip_entry_compressedsize() 函数

PHP Zip File 函数

定义和用法

zip_entry_compressedsize() 函数返回 zip 档案项目的压缩文件尺寸。

语法

zip_entry_compressedsize(zip_entry)
参数 | 描述
zip_entry | 必需。规定要读取的 zip 项目资源（由 zip_read() 打开的 zip 项目）。

例子

<?php
$zip = zip_open("test.zip");

if ($zip)
  {
  while ($zip_entry = zip_read($zip))
    {
    echo "<p>";
    echo "Name: " . zip_entry_name($zip_entry) . "<br />";
    echo "Compressed Size: "
    . zip_entry_compressedsize($zip_entry);
    echo "</p>";
    }
  zip_close($zip);
  }
?>

输出：

Name: ziptest.txt
Compressed Size: 68

Name: htmlziptest.html
Compressed Size: 159

PHP Zip File 函数

PHP 参考手册
PHP 测验


PHP zip_entry_compressionmethod() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP zip_entry_compressionmethod() 函数

PHP Zip File 函数

定义和用法

zip_entry_compressionmethod() 函数返回 zip 档案项目的压缩方法。

语法

zip_entry_compressionmethod(zip_entry)
参数 | 描述
zip_entry | 必需。规定要读取的 zip 项目资源（由 zip_read() 打开的 zip 项目）。

例子

<?php
$zip = zip_open("test.zip");

if ($zip)
  {
  while ($zip_entry = zip_read($zip))
    {
    echo "<p>";
    echo "Name: " . zip_entry_name($zip_entry) . "<br />";
    echo "Compression Method: "
    . zip_entry_compressionmethod($zip_entry);
    echo "</p>";
    }
  zip_close($zip);
  }
?>

输出：

Name: ziptest.txt
Compression Method: deflated

Name: htmlziptest.html
Compression Method: deflated

PHP Zip File 函数

PHP 参考手册
PHP 测验


PHP zip_entry_filesize() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP zip_entry_filesize() 函数

PHP Zip File 函数

定义和用法

zip_entry_filesize() 函数返回 zip 档案项目的原始大小（在压缩之前）。

语法

zip_entry_filesize(zip_entry)
参数 | 描述
zip_entry | 必需。规定要读取的 zip 项目资源（由 zip_read() 打开的 zip 项目）。

例子

<?php
$zip = zip_open("test.zip");

if ($zip)
  {
  while ($zip_entry = zip_read($zip))
    {
    echo "<p>";
    echo "Name: " . zip_entry_name($zip_entry) . "<br />";
    echo "Original size: " . zip_entry_filesize($zip_entry);
    echo "</p>";
    }
  zip_close($zip);
  }
?>

输出：

Name: ziptest.txt
Original size: 68

Name: htmlziptest.html
Original size: 159

PHP Zip File 函数

PHP 参考手册
PHP 测验


PHP zip_entry_name() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP zip_entry_name() 函数

PHP Zip File 函数

定义和用法

zip_entry_name() 函数返回 zip 档案项目的名称。

语法

zip_entry_name(zip_entry)
参数 | 描述
zip_entry | 必需。规定要读取的 zip 项目资源（由 zip_read() 打开的 zip 项目）。

例子

<?php
$zip = zip_open("test.zip");

if ($zip)
  {
  while ($zip_entry = zip_read($zip))
    {
    echo "Name: " . zip_entry_name($zip_entry) . "<br />";
    }
  zip_close($zip);
  }
?>

输出类似：

Name: ziptest.txt
Name: htmlziptest.html

PHP Zip File 函数

PHP 参考手册
PHP 测验


PHP zip_entry_open() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP zip_entry_open() 函数

PHP Zip File 函数

定义和用法

zip_entry_open() 函数打开一个 ZIP 档案项目以供读取。

语法

zip_entry_open(zip,zip_entry,mode)
参数 | 描述
zip | 必需。规定要读取的 zip 资源（由 zip_open() 打开的 zip 文件）。
zip_entry | 必需。规定要打开的 zip 项目资源（由 zip_read() 打开的 zip 项目）。
mode | 可选。规定 zip 档案项目的访问类型。

说明

在 PHP 5 中，mode 会被忽略，且总为 "rb"。这是因为在 PHP 中的 zip 支持是只读的。

例子

<?php
$zip = zip_open("test.zip");

if ($zip)
  {
  while ($zip_entry = zip_read($zip))
    {
    echo "<p>";
    echo "Name: " . zip_entry_name($zip_entry) . "<br />";

    if (zip_entry_open($zip, $zip_entry))
      {
      // some code
      }
    echo "</p>";
  }

zip_close($zip);

}
?>

PHP Zip File 函数

PHP 参考手册
PHP 测验


PHP zip_entry_read() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP zip_entry_read() 函数

PHP Zip File 函数

定义和用法

zip_entry_read() 函数从打开的 zip 档案项目中获取内容。

如果成功，则返回项目的内容。如果失败，则返回 false。

语法

zip_entry_read(zip_entry,length)
参数 | 描述
zip_entry | 必需。规定要读取的 zip 项目资源（由 zip_read() 打开的 zip 项目）。
length | 可选。规定返回的字节数。默认是 1024。

例子

<?php
$zip = zip_open("test.zip");

if ($zip)
  {
  while ($zip_entry = zip_read($zip))
    {
    echo "<p>";
    echo "Name: " . zip_entry_name($zip_entry) . "<br />";

    if (zip_entry_open($zip, $zip_entry))
      {
      echo "File Contents:<br/>";
      $contents = zip_entry_read($zip_entry);
      echo "$contents<br />";
      zip_entry_close($zip_entry);
      }
    echo "</p>";
  }

zip_close($zip);

}
?>

PHP Zip File 函数

PHP 参考手册
PHP 测验


PHP Zip File 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP Zip File 函数

  • Previous Page
  • Next Page

PHP Zip File 简介

压缩文件函数允许我们读取压缩文件。

安装

如需在服务器上运行 Zip File 函数，必须安装这些库：

  • Guido Draheim 的 ZZIPlib 库：下载 ZZIPlib 库
  • Zip PELC 扩展：下载 Zip PELC 扩展

在 Linux 系统上安装

PHP 5+：Zip 函数和 Zip 库默认不会启用，必须从上面的链接下载。请使用 --with-zip=DIR 配置选项来包含 Zip 支持。

在 Windows 系统上安装

PHP 5+：Zip 函数默认不会启用，必须从上面的链接下载 php_zip.dll 和 ZZIPlib 库。必须在php.ini 之内启用 php_zip.dll。

如需启用任何 PHP 扩展，PHP extension_dir 设置（在 php.ini 文件中）应该设置为该 PHP 扩展所在的目录。举例 extension_dir 的值可能是 c:\php\ext。

PHP Zip File 函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
zip_close() | 关闭 ZIP 文件。 | 4
zip_entry_close() | 关闭 ZIP 文件中的一个项目。 | 4
zip_entry_compressedsize() | 返回 ZIP 文件中的一个项目的被压缩尺寸。 | 4
zip_entry_compressionmethod() | 返回 ZIP 文件中的一个项目的压缩方法。 | 4
zip_entry_filesize() | 返回 ZIP 文件中的一个项目的实际文件尺寸。 | 4
zip_entry_name() | 返回 ZIP 文件中的一个项目的名称。 | 4
zip_entry_open() | 打开 ZIP 文件中的一个项目以供读取。 | 4
zip_entry_read() | 读取 ZIP 文件中的一个打开的项目。 | 4
zip_open() | 打开 ZIP 文件。 | 4
zip_read() | 读取 ZIP 文件中的下一个项目。 | 4

PHP Zip File 常量

无。

  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP zip_open() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP zip_open() 函数

PHP Zip File 函数

定义和用法

zip_open() 函数打开 ZIP 文件以供读取。

如果成功，则返回 zip 文件档案资源。如果失败，则返回 false。

语法

zip_open(filename)
参数 | 描述
filename | 必需。规定要打开的 zip 文件的文件名和路径。

提示和注释

提示：新打开的 zip 文件资源之后可被 zip_read() 和 zip_close() 函数使用。

例子

<?php
$zip = zip_open("test.zip");

zip_read($zip);

// 一些代码...

zip_close($zip);
?>

PHP Zip File 函数

PHP 参考手册
PHP 测验


PHP zip_read() 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP zip_read() 函数

PHP Zip File 函数

定义和用法

zip_read() 函数读取打开的 zip 档案中的下一个文件。

如果成功，则返回包含 zip 档案中一个文件的资源。如果没有更多的项目可供读取，则返回 false。

语法

zip_read(zip)
参数 | 描述
zip | 必需。规定要读取的 zip 资源（由 zip_open() 打开的 zip 文件）。

提示和注释

提示：由 zip_read() 函数返回的资源可供 zip_entry... 类的函数使用。

例子

<?php
$zip = zip_open("test.zip");

zip_read($zip);

// 一些代码...

zip_close($zip);
?>

PHP Zip File 函数

PHP 参考手册
PHP 测验


PHP 安全的电子邮件

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 安全的电子邮件

  • Previous Page
  • Next Page

在上一节中的 PHP e-mail 脚本中，存在着一个漏洞。

PHP E-mail 注入

首先，请看上一节中的 PHP 代码：

<html>
<body>

<?php
if (isset($_REQUEST['email']))
//if "email" is filled out, send email
  {
  //send email
  $email = $_REQUEST['email'] ;
  $subject = $_REQUEST['subject'] ;
  $message = $_REQUEST['message'] ;
  mail("someone@example.com", "Subject: $subject",
  $message, "From: $email" );
  echo "Thank you for using our mail form";
  }
else
//if "email" is not filled out, display the form
  {
  echo "<form method='post' action='mailform.php'>
  Email: <input name='email' type='text' /><br />
  Subject: <input name='subject' type='text' /><br />
  Message:<br />
  <textarea name='message' rows='15' cols='40'>
  </textarea><br />
  <input type='submit' />
  </form>";
  }
?>

</body>
</html>

以上代码存在的问题是，未经授权的用户可通过输入表单在邮件头部插入数据。

假如用户在表单中的输入框内加入这些文本，会出现什么情况呢？

someone@example.com%0ACc:person2@example.com
%0ABcc:person3@example.com,person3@example.com,
anotherperson4@example.com,person5@example.com
%0ABTo:person6@example.com

与往常一样，mail() 函数把上面的文本放入邮件头部，那么现在头部有了额外的 Cc:, Bcc: 以及 To: 字段。当用户点击提交按钮时，这封 e-mail 会被发送到上面所有的地址！

PHP 防止 E-mail 注入

防止 e-mail 注入的最好方法是对输入进行验证。

下面的代码与上一节类似，不过我们已经增加了检测表单中 email 字段的输入验证程序：

<html>
<body>
<?php
function spamcheck($field)
  {
  //filter_var() sanitizes the e-mail
  //address using FILTER_SANITIZE_EMAIL
  $field=filter_var($field, FILTER_SANITIZE_EMAIL);

  //filter_var() validates the e-mail
  //address using FILTER_VALIDATE_EMAIL
  if(filter_var($field, FILTER_VALIDATE_EMAIL))
    {
    return TRUE;
    }
  else
    {
    return FALSE;
    }
  }

if (isset($_REQUEST['email']))
  {//if "email" is filled out, proceed

  //check if the email address is invalid
  $mailcheck = spamcheck($_REQUEST['email']);
  if ($mailcheck==FALSE)
    {
    echo "Invalid input";
    }
  else
    {//send email
    $email = $_REQUEST['email'] ;
    $subject = $_REQUEST['subject'] ;
    $message = $_REQUEST['message'] ;
    mail("someone@example.com", "Subject: $subject",
    $message, "From: $email" );
    echo "Thank you for using our mail form";
    }
  }
else
  {//if "email" is not filled out, display the form
  echo "<form method='post' action='mailform.php'>
  Email: <input name='email' type='text' /><br />
  Subject: <input name='subject' type='text' /><br />
  Message:<br />
  <textarea name='message' rows='15' cols='40'>
  </textarea><br />
  <input type='submit' />
  </form>";
  }
?>

</body>
</html>

在上面的代码中，我们使用了 PHP 过滤器来对输入进行验证：

  • FILTER_SANITIZE_EMAIL 从字符串中删除电子邮件的非法字符
  • FILTER_VALIDATE_EMAIL 验证电子邮件地址

您可以在我们的 PHP 过滤器这一节中阅读更多有关过滤器的内容。

  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 安装

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 安装

  • Previous Page
  • Next Page

你需要做什么？

本教程不会为您讲解如何安装 PHP 、MySQL 或 Apache 服务器。

如果您的服务器支持 PHP - 那么您不需要做任何事情！您不需要编译任何软件，或安装额外的工具 - 只要在您的 web 目录中创建 .php 文件即可 - 然后您的服务器会为您解析这些文件。大多数主机都提供对 PHP 的支持。

不过，如果您的服务器不支持 PHP，那么您必须安装 PHP。下面的链接提供了来自 PHP.net 的优秀教程，您可以从中学习到如何安装 PHP5：

http://www.php.net/manual/en/install.php

下载 PHP

从此处下载免费的 PHP：http://www.php.net/downloads.php

下载 MySQL Database

从此处下载免费的 MySQL：http://www.mysql.com/downloads/index.html

下载 Apache Server

从此处下载免费的 Apache：http://httpd.apache.org/download.cgi

  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 变量

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 变量

  • Previous Page
  • Next Page

变量用于存储值，比如数字、字符串或函数的结果，这样我们就可以在脚本中多次使用它们了。

PHP 中的变量

变量用于存储值，比如数字、文本字符串或数组。

一旦设置了某个变量，我们就可以在脚本中重复地使用它。

PHP 中的所有变量都是以 $ 符号开始的。

在 PHP 中设置变量的正确方法是：

$var_name = value;

PHP 的入门者往往会忘记在变量的前面的 $ 符号。如果那样做的话，变量将是无效的。

让我们试着创建一个存有字符串的变量，和一个存有数值的变量：

<?php
$txt = "Hello World!";
$number = 16;
?>

PHP 是一门松散类型的语言（Loosely Typed Language）

在 PHP 中，不需要在设置变量之前声明该变量。

在上面的例子中，您看到了，不必向 PHP 声明该变量的数据类型。

根据变量被设置的方式，PHP 会自动地把变量转换为正确的数据类型。

在强类型的编程语言中，您必须在使用前声明变量的类型和名称。

在 PHP 中，变量会在使用时被自动声明。

变量的命名规则

  • 变量名必须以字母或下划线 "_" 开头。
  • 变量名只能包含字母数字字符以及下划线。
  • 变量名不能包含空格。如果变量名由多个单词组成，那么应该使用下划线进行分隔（比如 $my_string），或者以大写字母开头（比如 $myString）。
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 表单和用户输入

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 表单和用户输入

  • Previous Page
  • Next Page

PHP 的 $_GET 和 $_POST 用于检索表单中的值，比如用户输入。

PHP 表单处理

表单实例：

<html>
<body>

<form action="welcome.php" method="post">
Name: <input type="text" name="name" />
Age: <input type="text" name="age" />
<input type="submit" />
</form>

</body>
</html>

上面的 HTML 页面实例包含了两个输入框和一个提交按钮。当用户填写该表单并单击提交按钮时，表单的数据会被送往 "welcome.php" 这个文件。

"welcome.php" 文件类似这样：

<html>
<body>

Welcome <?php echo $_POST["name"]; ?>.<br />
You are <?php echo $_POST["age"]; ?> years old.

</body>
</html>

上面这个脚本的输出样本类似这样：

Welcome John.
You are 28 years old.

我们将在下一章解释 PHP $_GET 和 $_POST。

表单验证

应该在任何可能的时候对用户输入进行验证。客户端的验证速度更快，并且可以减轻服务器的负载。

不过，任何流量很高以至于不得不担心服务器资源的站点，也有必要担心站点的安全性。如果表单访问的是数据库，就非常有必要采用服务器端的验证。

在服务器验证表单的一种好的方式是，把表单传给它自己，而不是跳转到不同的页面。这样用户就可以在同一张表单页面得到错误信息。用户也就更容易发现错误了。

  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 参考手册

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 参考手册

  • Next Page

PHP 参考手册

在 W3School，我们为您提供包括所有 PHP 函数的完整参考手册：

  • Array 函数
  • PHP Calendar 函数
  • PHP Date 函数
  • Directory 函数
  • PHP Error 函数
  • Filesystem 函数
  • PHP Filter 函数
  • FTP 函数
  • HTTP 函数
  • LibXML 函数
  • Mail 函数
  • Math 函数
  • MySQL 函数
  • SimpleXML 函数
  • String 函数
  • XML Parser 函数
  • Zip 函数
  • 杂项函数
  • Next Page

PHP 参考手册
PHP 测验


PHP 测验

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 测验 （暂无内容）

  • Next Page

您可以通过 W3SCHOOL 的测验程序来测试您的 PHP 技能。

关于本测验

本测验包含 20 道题，每道题的最长答题时间是 20 分钟（这是由于每个 session 的默认有效时间是20钟）。

本测验是非官方的测试，它仅仅提供了一个了解您对 PHP 的掌握程度的工具。

测验会被记分

每道题的分值是 1 分。在您完成全部的 20 道题之后，系统会为您的测验打分，并提供您做错的题目的正确答案。其中，绿色为正确答案，而红色为错误答案。

现在就开始测验！祝您好运。

  • Next Page

PHP 参考手册
PHP 测验


PHP 错误处理

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 错误处理

  • Previous Page
  • Next Page

在 PHP 中，默认的错误处理很简单。一条消息会被发送到浏览器，这条消息带有文件名、行号以及一条描述错误的消息。

PHP 错误处理

在创建脚本和 web 应用程序时，错误处理是一个重要的部分。如果您的代码缺少错误检测编码，那么程序看上去很不专业，也为安全风险敞开了大门。

本教程介绍了 PHP 中一些最为重要的错误检测方法。

我们将为您讲解不同的错误处理方法：

  • 简单的 "die()" 语句
  • 自定义错误和错误触发器
  • 错误报告

基本的错误处理：使用 die() 函数

第一个例子展示了一个打开文本文件的简单脚本：

<?php
$file=fopen("welcome.txt","r");
?>

如果文件不存在，您会获得类似这样的错误：

Warning: fopen(welcome.txt) [function.fopen]: failed to open stream:
No such file or directory in C:\webfolder\test.php on line 2

为了避免用户获得类似上面的错误消息，我们在访问文件之前检测该文件是否存在：

<?php
if(!file_exists("welcome.txt"))
 {
 die("File not found");
 }
else
 {
 $file=fopen("welcome.txt","r");
 }
?>

现在，假如文件不存在，您会得到类似这样的错误消息：

File not found

比起之前的代码，上面的代码更有效，这是由于它采用了一个简单的错误处理机制在错误之后终止了脚本。

不过，简单地终止脚本并不总是恰当的方式。让我们研究一下用于处理错误的备选的 PHP 函数。

创建自定义错误处理器

创建一个自定义的错误处理器非常简单。我们很简单地创建了一个专用函数，可以在 PHP 中发生错误时调用该函数。

该函数必须有能力处理至少两个参数 (error level 和 error message)，但是可以接受最多五个参数（可选的：file, line-number 以及 error context）：

语法

error_function(error_level,error_message,
error_file,error_line,error_context)
参数 | 描述
error_level | 必需。为用户定义的错误规定错误报告级别。必须是一个值数。 参见下面的表格：错误报告级别。
error_message | 必需。为用户定义的错误规定错误消息。
error_file | 可选。规定错误在其中发生的文件名。
error_line | 可选。规定错误发生的行号。
error_context | 可选。规定一个数组，包含了当错误发生时在用的每个变量以及它们的值。

错误报告级别

这些错误报告级别是错误处理程序旨在处理的错误的不同的类型：

值 | 常量 | 描述
2 | E_WARNING | 非致命的 run-time 错误。不暂停脚本执行。
8 | E_NOTICE | Run-time 通知。 脚本发现可能有错误发生，但也可能在脚本正常运行时发生。
256 | E_USER_ERROR | 致命的用户生成的错误。这类似于程序员使用 PHP 函数 trigger_error() 设置的 E_ERROR。
512 | E_USER_WARNING | 非致命的用户生成的警告。这类似于程序员使用 PHP 函数 trigger_error() 设置的 E_WARNING。
1024 | E_USER_NOTICE | 用户生成的通知。这类似于程序员使用 PHP 函数 trigger_error() 设置的 E_NOTICE。
4096 | E_RECOVERABLE_ERROR | 可捕获的致命错误。类似 E_ERROR，但可被用户定义的处理程序捕获。(参见 set_error_handler())
8191 | E_ALL | 所有错误和警告，除级别 E_STRICT 以外。 （在 PHP 6.0，E_STRICT 是 E_ALL 的一部分）

现在，让我们创建一个处理错误的函数：

function customError($errno, $errstr)
 {
 echo "<b>Error:</b> [$errno] $errstr<br />";
 echo "Ending Script";
 die();
 }

上面的代码是一个简单的错误处理函数。当它被触发时，它会取得错误级别和错误消息。然后它会输出错误级别和消息，并终止脚本。

现在，我们已经创建了一个错误处理函数，我们需要确定在何时触发该函数。

Set Error Handler

PHP 的默认错误处理程序是内建的错误处理程序。我们打算把上面的函数改造为脚本运行期间的默认错误处理程序。

可以修改错误处理程序，使其仅应用到某些错误，这样脚本就可以不同的方式来处理不同的错误。不过，在本例中，我们打算针对所有错误来使用我们的自定义错误处理程序：

set_error_handler("customError");

由于我们希望我们的自定义函数来处理所有错误，set_error_handler() 仅需要一个参数，可以添加第二个参数来规定错误级别。

实例

通过尝试输出不存在的变量，来测试这个错误处理程序：

<?php
//error handler function
function customError($errno, $errstr)
 {
 echo "<b>Error:</b> [$errno] $errstr";
 }

//set error handler
set_error_handler("customError");

//trigger error
echo($test);
?>

以上代码的输出应该类似这样：

Custom error: [8] Undefined variable: test

触发错误

在脚本中用户输入数据的位置，当用户的输入无效时触发错误的很有用的。在 PHP 中，这个任务由 trigger_error() 完成。

例子

在本例中，如果 "test" 变量大于 "1"，就会发生错误：

<?php
$test=2;
if ($test>1)
{
trigger_error("Value must be 1 or below");
}
?>

以上代码的输出应该类似这样：

Notice: Value must be 1 or below
in C:\webfolder\test.php on line 6

您可以在脚本中任何位置触发错误，通过添加的第二个参数，您能够规定所触发的错误级别。

可能的错误类型：

  • E_USER_ERROR - 致命的用户生成的 run-time 错误。错误无法恢复。脚本执行被中断。
  • E_USER_WARNING - 非致命的用户生成的 run-time 警告。脚本执行不被中断。
  • E_USER_NOTICE - 默认。用户生成的 run-time 通知。脚本发现了可能的错误，也有可能在脚本运行正常时发生。

例子

在本例中，如果 "test" 变量大于 "1"，则发生 E_USER_WARNING 错误。如果发生了 E_USER_WARNING，我们将使用我们的自定义错误处理程序并结束脚本：

<?php
//error handler function
function customError($errno, $errstr)
 {
 echo "<b>Error:</b> [$errno] $errstr<br />";
 echo "Ending Script";
 die();
 }

//set error handler
set_error_handler("customError",E_USER_WARNING);

//trigger error
$test=2;
if ($test>1)
 {
 trigger_error("Value must be 1 or below",E_USER_WARNING);
 }
?>

以上代码的输出应该类似这样：

Error: [512] Value must be 1 or below
Ending Script

现在，我们已经学习了如何创建自己的 error，以及如何处罚它们，现在我们研究一下错误记录。

错误记录

默认地，根据在 php.ini 中的 error_log 配置，PHP 向服务器的错误记录系统或文件发送错误记录。通过使用 error_log() 函数，您可以向指定的文件或远程目的地发送错误记录。

通过电子邮件向您自己发送错误消息，是一种获得指定错误的通知的好办法。

通过 E-Mail 发送错误消息

在下面的例子中，如果特定的错误发生，我们将发送带有错误消息的电子邮件，并结束脚本：

<?php
//error handler function
function customError($errno, $errstr)
 {
 echo "<b>Error:</b> [$errno] $errstr<br />";
 echo "Webmaster has been notified";
 error_log("Error: [$errno] $errstr",1,
 "someone@example.com","From: webmaster@example.com");
}

//set error handler
set_error_handler("customError",E_USER_WARNING);

//trigger error
$test=2;
if ($test>1)
 {
 trigger_error("Value must be 1 or below",E_USER_WARNING);
 }
?>

以上代码的输出应该类似这样：

Error: [512] Value must be 1 or below
Webmaster has been notified

接收自以上代码的邮件类似这样：

Error: [512] Value must be 1 or below

这个方法不适合所有的错误。常规错误应当通过使用默认的 PHP 记录系统在服务器上进行记录。

  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 发送电子邮件

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 发送电子邮件

  • Previous Page
  • Next Page

PHP 允许您从脚本直接发送电子邮件。

PHP mail() 函数

PHP mail() 函数用于从脚本中发送电子邮件。

语法

mail(to,subject,message,headers,parameters)
参数 | 描述
to | 必需。规定 email 接收者。
subject | 必需。规定 email 的主题。注释：该参数不能包含任何新行字符。
message | 必需。定义要发送的消息。应使用 LF (\n) 来分隔各行。
headers | 可选。规定附加的标题，比如 From、Cc 以及 Bcc。 应当使用 CRLF (\r\n) 分隔附加的标题。
parameters | 可选。对邮件发送程序规定额外的参数。

注释：PHP 需要一个已安装且正在运行的邮件系统，以便使邮件函数可用。所用的程序通过在 php.ini 文件中的配置设置进行定义。请在我们的 PHP Mail 参考手册阅读更多内容。

PHP 简易 E-Mail

通过 PHP 发送电子邮件的最简单的方式是发送一封文本 email。

在下面的例子中，我们首先声明变量($to, $subject, $message, $from, $headers)，然后我们在 mail() 函数中使用这些变量来发送了一封 e-mail：

<?php

$to = "someone@example.com";
$subject = "Test mail";
$message = "Hello! This is a simple email message.";
$from = "someonelse@example.com";
$headers = "From: $from";
mail($to,$subject,$message,$headers);
echo "Mail Sent.";

?>

PHP Mail Form

通过 PHP，您能够在自己的站点制作一个反馈表单。下面的例子向指定的 e-mail 地址发送了一条文本消息：

<html>
<body>

<?php
if (isset($_REQUEST['email']))
//if "email" is filled out, send email
  {
  //send email
  $email = $_REQUEST['email'] ;
  $subject = $_REQUEST['subject'] ;
  $message = $_REQUEST['message'] ;
  mail( "someone@example.com", "Subject: $subject",
  $message, "From: $email" );
  echo "Thank you for using our mail form";
  }
else
//if "email" is not filled out, display the form
  {
  echo "<form method='post' action='mailform.php'>
  Email: <input name='email' type='text' /><br />
  Subject: <input name='subject' type='text' /><br />
  Message:<br />
  <textarea name='message' rows='15' cols='40'>
  </textarea><br />
  <input type='submit' />
  </form>";
  }
?>

</body>
</html>

例子解释：

  1. 首先，检查是否填写了邮件输入框
  2. 如果未填写（比如在页面被首次访问时），输出 HTML 表单
  3. 如果已填写（在表单被填写后），从表单发送邮件
  4. 当点击提交按钮后，重新载入页面，显示邮件发送成功的消息

PHP Mail 参考手册

如需更多有关 PHP mail() 函数的信息，请访问我们的 PHP Mail 参考手册。

  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 过滤器（Filter）

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 过滤器（Filter）

  • Previous Page
  • Next Page

PHP 过滤器用于验证和过滤来自非安全来源的数据，比如用户的输入。

什么是 PHP 过滤器？

PHP 过滤器用于验证和过滤来自非安全来源的数据。

验证和过滤用户输入或自定义数据是任何 Web 应用程序的重要组成部分。

设计 PHP 的过滤器扩展的目的是使数据过滤更轻松快捷。

为什么使用过滤器？

几乎所有 web 应用程序都依赖外部的输入。这些数据通常来自用户或其他应用程序（比如 web 服务）。通过使用过滤器，您能够确保应有程序获得正确的输入类型。

您应该始终对外部数据进行过滤！

输入过滤是最重要的应用程序安全课题之一。

什么是外部数据？

  • 来自表单的输入数据
  • Cookies
  • 服务器变量
  • 数据库查询结果

函数和过滤器

如需过滤变量，请使用下面的过滤器函数之一：

  • filter_var() - 通过一个指定的过滤器来过滤单一的变量
  • filter_var_array() - 通过相同的或不同的过滤器来过滤多个变量
  • filter_input - 获取一个输入变量，并对它进行过滤
  • filter_input_array - 获取多个输入变量，并通过相同的或不同的过滤器对它们进行过滤

在下面的例子中，我们用 filter_var() 函数验证了一个整数：

<?php
$int = 123;

if(!filter_var($int, FILTER_VALIDATE_INT))
 {
 echo("Integer is not valid");
 }
else
 {
 echo("Integer is valid");
 }
?>

上面的代码使用了 "FILTER_VALIDATE_INT" 过滤器来过滤变量。由于这个整数是合法的，因此代码的输出是："Integer is valid"。

假如我们尝试使用一个非整数的变量，则输出是："Integer is not valid"。

如需完整的函数和过滤器列表，请访问我们的 PHP Filter 参考手册。

Validating 和 Sanitizing

有两种过滤器：

Validating 过滤器：

  • 用于验证用户输入
  • 严格的格式规则（比如 URL 或 E-Mail 验证）
  • 返回若成功预期的类型，否则返回 FALSE

Sanitizing 过滤器：

  • 用于允许或禁止字符串中指定的字符
  • 无数据格式规则
  • 始终返回字符串

选项和标志

选项和标志用于向指定的过滤器添加额外的过滤选项。

不同的过滤器有不同的选项和标志。

在下面的例子中，我们用 filter_var() 和 "min_range" 以及 "max_range" 选项验证了一个整数：

<?php
$var=300;

$int_options = array(
"options"=>array
 (
 "min_range"=>0,
 "max_range"=>256
 )
);

if(!filter_var($var, FILTER_VALIDATE_INT, $int_options))
 {
 echo("Integer is not valid");
 }
else
 {
 echo("Integer is valid");
 }
?>

就像上面的代码一样，选项必须放入一个名为 "options" 的相关数组中。如果使用标志，则不需在数组内。

由于整数是 "300"，它不在指定的氛围内，以上代码的输出将是 "Integer is not valid"。

如需完整的函数及过滤器列表，请访问 W3School 提供的 PHP Filter 参考手册。您可以看到每个过滤器的可用选项和标志。

验证输入

让我们试着验证来自表单的输入。

我们需要作的第一件事情是确认是否存在我们正在查找的输入数据。

然后我们用 filter_input() 函数过滤输入的数据。

在下面的例子中，输入变量 "email" 被传到 PHP 页面：

<?php
if(!filter_has_var(INPUT_GET, "email"))
 {
 echo("Input type does not exist");
 }
else
 {
 if (!filter_input(INPUT_GET, "email", FILTER_VALIDATE_EMAIL))
  {
  echo "E-Mail is not valid";
  }
 else
  {
  echo "E-Mail is valid";
  }
 }
?>

例子解释：

上面的例子有一个通过 "GET" 方法传送的输入变量 (email)：

  1. 检测是否存在 "GET" 类型的 "email" 输入变量
  2. 如果存在输入变量，检测它是否是有效的邮件地址

净化输入

让我们试着清理一下从表单传来的 URL。

首先，我们要确认是否存在我们正在查找的输入数据。

然后，我们用 filter_input() 函数来净化输入数据。

在下面的例子中，输入变量 "url" 被传到 PHP 页面：

<?php
if(!filter_has_var(INPUT_POST, "url"))
 {
 echo("Input type does not exist");
 }
else
 {
 $url = filter_input(INPUT_POST,
 "url", FILTER_SANITIZE_URL);
 }
?>

例子解释：

上面的例子有一个通过 "POST" 方法传送的输入变量 (url)：

  1. 检测是否存在 "POST" 类型的 "url" 输入变量
  2. 如果存在此输入变量，对其进行净化（删除非法字符），并将其存储在 $url 变量中

假如输入变量类似这样："http://www.W3#$%S^%$#ool.com.cn/"，则净化后的 $url 变量应该是这样的：

http://www.W3School.com.cn/

过滤多个输入

表单通常由多个输入字段组成。为了避免对 filter_var 或 filter_input 重复调用，我们可以使用 filter_var_array 或 the filter_input_array 函数。

在本例中，我们使用 filter_input_array() 函数来过滤三个 GET 变量。接收到的 GET 变量是一个名称、一个年龄以及一个邮件地址：

<?php
$filters = array
 (
 "name" => array
  (
  "filter"=>FILTER_SANITIZE_STRING
  ),
 "age" => array
  (
  "filter"=>FILTER_VALIDATE_INT,
  "options"=>array
   (
   "min_range"=>1,
   "max_range"=>120
   )
  ),
 "email"=> FILTER_VALIDATE_EMAIL,
 );

$result = filter_input_array(INPUT_GET, $filters);

if (!$result["age"])
 {
 echo("Age must be a number between 1 and 120.<br />");
 }
elseif(!$result["email"])
 {
 echo("E-Mail is not valid.<br />");
 }
else
 {
 echo("User input is valid");
 }
?>

例子解释：

上面的例子有三个通过 "GET" 方法传送的输入变量 (name, age and email)

  1. 设置一个数组，其中包含了输入变量的名称，以及用于指定的输入变量的过滤器
  2. 调用 filter_input_array 函数，参数包括 GET 输入变量及刚才设置的数组
  3. 检测 $result 变量中的 "age" 和 "email" 变量是否有非法的输入。（如果存在非法输入，）

filter_input_array() 函数的第二个参数可以是数组或单一过滤器的 ID。

如果该参数是单一过滤器的 ID，那么这个指定的过滤器会过滤输入数组中所有的值。

如果该参数是一个数组，那么此数组必须遵循下面的规则：

  • 必须是一个关联数组，其中包含的输入变量是数组的键（比如 "age" 输入变量）
  • 此数组的值必须是过滤器的 ID ，或者是规定了过滤器、标志以及选项的数组

使用 Filter Callback

通过使用 FILTER_CALLBACK 过滤器，可以调用自定义的函数，把它作为一个过滤器来使用。这样，我们就拥有了数据过滤的完全控制权。

您可以创建自己的自定义函数，也可以使用已有的 PHP 函数。

规定您准备用到过滤器的函数，与规定选项的方法相同。

在下面的例子中，我们使用了一个自定义的函数把所有 "_" 转换为空格：

<?php
function convertSpace($string)
{
return str_replace("_", " ", $string);
}

$string = "Peter_is_a_great_guy!";

echo filter_var($string, FILTER_CALLBACK,
array("options"=>"convertSpace"));
?>

以上代码的结果是这样的：

Peter is a great guy!

例子解释：

上面的例子把所有 "_" 转换成空格：

  1. 创建一个把 "_" 替换为空格的函数
  2. 调用 filter_var() 函数，它的参数是 FILTER_CALLBACK 过滤器以及包含我们的函数的数组
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 函数

  • Previous Page
  • Next Page

PHP 的真正威力源自于它的函数。

在 PHP 中，提供了超过 700 个内建的函数。

PHP 函数

在本教程中，我们将为您讲解如何创建自己的函数。

如需内建函数的参考和实例，请访问我们的 PHP 参考手册。

创建 PHP 函数

函数是一种可以在任何被需要的时候执行的代码块。

创建 PHP 函数：

  1. 所有的函数都使用关键词 "function()" 来开始
  2. 命名函数 - 函数的名称应该提示出它的功能。函数名称以字母或下划线开头。
  3. 添加 "{" - 开口的花括号之后的部分是函数的代码。
  4. 插入函数代码
  5. 添加一个 "}" - 函数通过关闭花括号来结束。

例子

一个简单的函数，在其被调用时能输出我的名称的：

<html>
<body>

<?php
function writeMyName()
  {
  echo "David Yang";
  }

writeMyName();
?>

</body>
</html>

使用 PHP 函数

现在，我们要在 PHP 脚本中使用这个函数了：

<html>
<body>

<?php
function writeMyName()
  {
  echo "David Yang";
  }

echo "Hello world!<br />";
echo "My name is ";
writeMyName();
echo ".<br />That's right, ";
writeMyName();
echo " is my name.";
?>

</body>
</html>

以上代码的输出：

Hello world!
My name is David Yang.
That's right, David Yang is my name.

PHP 函数 - 添加参数

我们的第一个函数是一个非常简单的函数。它只能输出一个静态的字符串。

通过可以添加参数，我们向函数添加更多的功能。参数类似一个变量。

您可能注意到了，函数名称后面有一个括号，比如 writeMyName()。参数就是在括号中规定的。

例子 1

下面的例子讲输出不同的名字，但姓是相同的：

<html>
<body>

<?php
function writeMyName($fname)
  {
  echo $fname . " Yang.<br />";
  }

echo "My name is ";
writeMyName("David");

echo "My name is ";
writeMyName("Mike");

echo "My name is ";
writeMyName("John");
?>

</body>
</html>

上面的代码的输出：

My name is David Yang.
My name is Mike Yang.
My name is John Yang.

例子 2

下面的函数有两个参数：

<html>
<body>

<?php
function writeMyName($fname,$punctuation)
  {
  echo $fname . " Yang" . $punctuation . "<br />";
  }

echo "My name is ";
writeMyName("David",".");

echo "My name is ";
writeMyName("Mike","!");

echo "My name is ";
writeMyName("John","...");
?>

</body>
</html>

上面的代码的输出：

My name is David Yang.
My name is Mike Yang!
My name is John Yang...

PHP 函数 - 返回值

函数也能用于返回值。

例子

<html>
<body>

<?php
function add($x,$y)
  {
  $total = $x + $y;
  return $total;
  }

echo "1 + 16 = " . add(1,16);
?>

</body>
</html>

以上代码的输出：

1 + 16 = 17
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 和 AJAX Live Search

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 和 AJAX Live Search

  • Previous Page
  • Next Page

AJAX 可为用户提供更友好、交互性更强的搜索体验。

AJAX Live Search

在下面的 AJAX 例子中，我们将演示一个实时的搜索。

实时的搜索与传统搜索相比，具有很多优势：

  • 当键入数据时，就会显示出匹配的结果
  • 当继续键入数据时，对结果进行过滤
  • 如果结果太少，删除字符就可以获得更宽的范围

在下面的文本框中搜索 W3School 的页面

本例包括四个元素：

  • 简单的 HTML 表单
  • JavaScript
  • PHP 页面
  • XML 文档

在本例中，结果在一个 XML 文档 (links.xml) 中进行查找。为了让这个例子小而简单，我们只提供 8 个结果。

HTML 表单

这是 HTML 页面。它包含一个简单的 HTML 表单，针对此表单的 CSS 样式，以及指向 JavaScript 的链接：

<html>
<head>
<script src="livesearch.js"></script>
<style type="text/css">
#livesearch
  {
  margin:0px;
  width:194px;
  }
#txt1
  {
  margin:0px;
  }
</style>
</head>
<body>

<form>
<input type="text" id="txt1" size="30"
onkeyup="showResult(this.value)">

<div id="livesearch"></div>
</form>

</body>
</html>

例子解释 - HTML 表单

正如你看到的，HTML 页面包含一个简单的 HTML 表单，其中的文本框名为 "txt1"。

表单是这样工作的：

  1. 当用户在文本框中按键并松开按键时，会触发一个事件
  2. 当事件触发时，会执行名为 showResult() 的函数
  3. 表单下面是名为 "livesearch" 的 <div> 元素。它用作 showResult() 所返回数据的占位符

JavaScript

JavaScript 代码存储在与 HTML 文档连接的 "livesearch.js" 中：

var xmlHttp

function showResult(str)
{
if (str.length==0)
 {
 document.getElementById("livesearch").
 innerHTML="";
 document.getElementById("livesearch").
 style.border="0px";
 return
 }

xmlHttp=GetXmlHttpObject()

if (xmlHttp==null)
 {
 alert ("Browser does not support HTTP Request")
 return
 }

var url="livesearch.php"
url=url+"?q="+str
url=url+"&sid="+Math.random()
xmlHttp.onreadystatechange=stateChanged
xmlHttp.open("GET",url,true)
xmlHttp.send(null)
}

function stateChanged()
{
if (xmlHttp.readyState==4 || xmlHttp.readyState=="complete")
 {
 document.getElementById("livesearch").
 innerHTML=xmlHttp.responseText;
 document.getElementById("livesearch").
 style.border="1px solid #A5ACB2";
 }
}

function GetXmlHttpObject()
{
var xmlHttp=null;
try
 {
 // Firefox, Opera 8.0+, Safari
 xmlHttp=new XMLHttpRequest();
 }
catch (e)
 {
 // Internet Explorer
 try
  {
  xmlHttp=new ActiveXObject("Msxml2.XMLHTTP");
  }
 catch (e)
  {
  xmlHttp=new ActiveXObject("Microsoft.XMLHTTP");
  }
 }
return xmlHttp;
}

例子解释：

GetXmlHttpObject 与 PHP 和 AJAX 请求 中的例子相同。

showResult() 函数

该函数每当一个字符输入文本框就会执行一次。

如果文本域中没有输入 (str.length == 0)，该函数把返回字段设置为空，并删除周围的任何边框。

不过，如果文本域中存在输入，则函数执行：

  1. 定义发送到服务器的 url （文件名）
  2. 把带有输入框内容的参数 (q) 添加到 url
  3. 添加一个随机数，以防止服务器使用缓存文件
  4. 调用 GetXmlHttpObject 函数来创建 XMLHTTP 对象，并在触发一个变化时告知此函数执行名为 stateChanged 的一个函数
  5. 使用给定的 url 来打开 XMLHTTP 对象
  6. 向服务器发送 HTTP 请求

stateChanged() 函数

每当 XMLHTTP 对象的状态发生变化时，该函数就会执行。

当状态变为 4 (或 "complete") 时，就会使用响应文本来填充 txtHint 占位符的内容，并在返回字段周围设置一个边框。

PHP 页面

由 JavaScript 代码调用的服务器页面是名为 "livesearch.php" 的 PHP 文件。

"livesearch.php" 中的代码检查那个 XML 文档 "links.xml"。该文档 w3school.com.cn 上的一些页面的标题和 URL。

这些代码会搜索 XML 文件中匹配搜索字符串的标题，并以 HTML 返回结果：

<?php
$xmlDoc = new DOMDocument();
$xmlDoc->load("links.xml");

$x=$xmlDoc->getElementsByTagName('link');

//get the q parameter from URL
$q=$_GET["q"];

//lookup all links from the xml file if length of q>0
if (strlen($q) > 0)
{
$hint="";
for($i=0; $i<($x->length); $i++)
 {
 $y=$x->item($i)->getElementsByTagName('title');
 $z=$x->item($i)->getElementsByTagName('url');
 if ($y->item(0)->nodeType==1)
  {
  //find a link matching the search text
  if (stristr($y->item(0)->childNodes->item(0)->nodeValue,$q))
   {
   if ($hint=="")
    {
    $hint="<a href='" .
    $z->item(0)->childNodes->item(0)->nodeValue .
    "' target='_blank'>" .
    $y->item(0)->childNodes->item(0)->nodeValue . "</a>";
    }
   else
    {
    $hint=$hint . "<br /><a href='" .
    $z->item(0)->childNodes->item(0)->nodeValue .
    "' target='_blank'>" .
    $y->item(0)->childNodes->item(0)->nodeValue . "</a>";
    }
   }
  }
 }
}

// Set output to "no suggestion" if no hint were found
// or to the correct values
if ($hint == "")
 {
 $response="no suggestion";
 }
else
 {
 $response=$hint;
 }

//output the response
echo $response;
?>

例子解释：

如果从 JavaScript 送来了任何文本 (strlen($q) > 0)，会发生：

  1. PHP 创建 "links.xml" 文件的一个 XML DOM 对象
  2. 遍历所有 "title" 元素 (nodetypes = 1)，以便找到匹配 JavaScript 所传数据的 name
  3. 找到包含正确 title 的 link，并设置为 "$response" 变量。如果找到多于一个匹配，所有的匹配都会添加到变量
  4. 如果没有找到匹配，则把 $response 变量设置为 "no suggestion"
  5. $result 是送往 "livesearch" 占位符的输出
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 和 AJAX MySQL 数据库实例

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 和 AJAX MySQL 数据库实例

  • Previous Page
  • Next Page

AJAX 可用来与数据库进行交互式通信。

AJAX 数据库实例

在下面的 AJAX 实例中，我们将演示网页如何使用 AJAX 技术从 MySQL 数据库中读取信息。

在下拉列表中选择一个名字 （测试说明：该实例功能未实现）

Select a User:

在此列出用户信息。

此列由四个元素组成：

  • MySQL 数据库
  • 简单的 HTML 表单
  • JavaScript
  • PHP 页面

数据库

将在本例中使用的数据库看起来类似这样：

id | FirstName | LastName | Age | Hometown | Job
1 | Peter | Griffin | 41 | Quahog | Brewery
2 | Lois | Griffin | 40 | Newport | Piano Teacher
3 | Joseph | Swanson | 39 | Quahog | Police Officer
4 | Glenn | Quagmire | 41 | Quahog | Pilot

HTML 表单

上面的例子包含了一个简单的 HTML 表单，以及指向 JavaScript 的链接：

<html>
<head>
<script src="selectuser.js"></script>
</head>
<body>

<form>
Select a User:
<select name="users" onchange="showUser(this.value)">
<option value="1">Peter Griffin</option>
<option value="2">Lois Griffin</option>
<option value="3">Glenn Quagmire</option>
<option value="4">Joseph Swanson</option>
</select>
</form>

<p>
<div id="txtHint"><b>User info will be listed here.</b></div>
</p>

</body>
</html>

例子解释 - HTML 表单

正如您看到的，它仅仅是一个简单的 HTML 表单，其中带有名为 "users" 的下拉列表，这个列表包含了姓名，以及与数据库的 "id" 对应的选项值。

表单下面的段落包含了名为 "txtHint" 的 div。这个 div 用作从 web 服务器检索到的信息的占位符。

当用户选择数据时，执行名为 "showUser()" 的函数。该函数的执行由 "onchange" 事件触发。

换句话说：每当用户改变下拉列表中的值，就会调用 showUser() 函数。

JavaScript

这是存储在 "selectuser.js" 文件中的 JavaScript 代码：

var xmlHttp

function showUser(str)
{
xmlHttp=GetXmlHttpObject()
if (xmlHttp==null)
 {
 alert ("Browser does not support HTTP Request")
 return
 }
var url="getuser.php"
url=url+"?q="+str
url=url+"&sid="+Math.random()
xmlHttp.onreadystatechange=stateChanged
xmlHttp.open("GET",url,true)
xmlHttp.send(null)
}

function stateChanged()
{
if (xmlHttp.readyState==4 || xmlHttp.readyState=="complete")
 {
 document.getElementById("txtHint").innerHTML=xmlHttp.responseText
 }
}

function GetXmlHttpObject()
{
var xmlHttp=null;
try
 {
 // Firefox, Opera 8.0+, Safari
 xmlHttp=new XMLHttpRequest();
 }
catch (e)
 {
 //Internet Explorer
 try
  {
  xmlHttp=new ActiveXObject("Msxml2.XMLHTTP");
  }
 catch (e)
  {
  xmlHttp=new ActiveXObject("Microsoft.XMLHTTP");
  }
 }
return xmlHttp;
}

例子解释：

stateChanged() 和 GetXmlHttpObject 函数与 PHP AJAX 请求 那一节中的相同，您可以参阅其中的相关解释。

showUser() 函数

假如下拉列表中的项目被选择，函数执行：

  1. 调用 GetXmlHttpObject 函数来创建 XMLHTTP 对象
  2. 定义发送到服务器的 URL（文件名）
  3. 向 URL 添加带有下拉列表内容的参数 (q)
  4. 添加一个随机数，以防服务器使用缓存的文件
  5. 当触发事件时调用 stateChanged
  6. 通过给定的 URL 打开 XMLHTTP 对象
  7. 向服务器发送 HTTP 请求

PHP 页面

由 JavaScript 调用的服务器页面，是名为 "getuser.php" 的简单 PHP 文件。

该页面用 PHP 编写，并使用 MySQL 数据库。

其中的代码执行针对数据库的 SQL 查询，并以 HTML 表格返回结果：

<?php
$q=$_GET["q"];

$con = mysql_connect('localhost', 'peter', 'abc123');
if (!$con)
 {
 die('Could not connect: ' . mysql_error());
 }

mysql_select_db("ajax_demo", $con);

$sql="SELECT * FROM user WHERE id = '".$q."'";

$result = mysql_query($sql);

echo "<table border='1'>
<tr>
<th>Firstname</th>
<th>Lastname</th>
<th>Age</th>
<th>Hometown</th>
<th>Job</th>
</tr>";

while($row = mysql_fetch_array($result))
 {
 echo "<tr>";
 echo "<td>" . $row['FirstName'] . "</td>";
 echo "<td>" . $row['LastName'] . "</td>";
 echo "<td>" . $row['Age'] . "</td>";
 echo "<td>" . $row['Hometown'] . "</td>";
 echo "<td>" . $row['Job'] . "</td>";
 echo "</tr>";
 }
echo "</table>";

mysql_close($con);
?>

例子解释：

当查询从 JavaScript 被发送到这个 PHP 页面，会发生：

  1. PHP 打开到达 MySQL 服务器的连接
  2. 找到拥有指定姓名的 "user"
  3. 创建表格，插入数据，然后将其发送到 "txtHint" 占位符
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 和 AJAX responseXML 实例

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 和 AJAX responseXML 实例

  • Previous Page
  • Next Page

AJAX 可用于以 XML 返回数据库信息。

AJAX Database 转 XML 实例 （测试说明：该实例功能未实现）

在下面的 AJAX 实例中，我们将演示网页如何从 MySQL 数据库中读取信息，把数据转换为 XML 文档，并在不同的地方使用这个文档来显示信息。

本例与上一节中的 "PHP AJAX Database" 这个例子很相似，不过有一个很大的不同：在本例中，我们通过使用 responseXML 函数从 PHP 页面得到的是 XML 形式的数据。

把 XML 文档作为响应来接收，使我们有能力更新页面的多个位置，而不仅仅是接收一个 PHP 输出并显示出来。

在本例中，我们将使用从数据库接收到的信息来更新多个 <span> 元素。

在下拉列表中选择一个名字

Select a User:

此列由四个元素组成：

  • MySQL 数据库
  • 简单的 HTML 表单
  • JavaScript
  • PHP 页面

数据库

将在本例中使用的数据库看起来类似这样：

id | FirstName | LastName | Age | Hometown | Job
1 | Peter | Griffin | 41 | Quahog | Brewery
2 | Lois | Griffin | 40 | Newport | Piano Teacher
3 | Joseph | Swanson | 39 | Quahog | Police Officer
4 | Glenn | Quagmire | 41 | Quahog | Pilot

HTML 表单

上面的例子包含了一个简单的 HTML 表单，以及指向 JavaScript 的链接：

<html>
<head>
<script src="responsexml.js"></script>
</head>
<body>

<form>
Select a User:
<select name="users" onchange="showUser(this.value)">
<option value="1">Peter Griffin</option>
<option value="2">Lois Griffin</option>
<option value="3">Glenn Quagmire</option>
<option value="4">Joseph Swanson</option>
</select>
</form>

<h2>
<span id="firstname"></span>&nbsp;<span id="lastname"></span>
</h2>

<span id="job"></span>

<div style="text-align: right">
<span id="age_text"></span>
<span id="age"></span>
<span id="hometown_text"></span>
<span id="hometown"></span>
</div>

</body>
</html>

例子解释 - HTML 表单

  • HTML 表单是一个下拉列表，其 name 属性的值是 "users"，可选项的值与数据库的 id 字段相对应
  • 表单下面有几个 <span> 元素，它们用作我们所接收到的不同的值的占位符
  • 当用户选择了具体的选项，函数 "showUser()" 就会执行。该函数的执行由 "onchange" 事件触发

换句话说，每当用户在下拉列表中改变了值，函数 showUser() 就会执行，并在指定的 <span> 元素中输出结果。

JavaScript

这是存储在文件 "responsexml.js" 中的 JavaScript 代码：

var xmlHttp

function showUser(str)
 {
 xmlHttp=GetXmlHttpObject()
 if (xmlHttp==null)
  {
  alert ("Browser does not support HTTP Request")
  return
  }
 var url="responsexml.php"
 url=url+"?q="+str
 url=url+"&sid="+Math.random()
 xmlHttp.onreadystatechange=stateChanged
 xmlHttp.open("GET",url,true)
 xmlHttp.send(null)
 }

function stateChanged()
{
if (xmlHttp.readyState==4 || xmlHttp.readyState=="complete")
{
 xmlDoc=xmlHttp.responseXML;
 document.getElementById("firstname").innerHTML=
 xmlDoc.getElementsByTagName("firstname")[0].childNodes[0].nodeValue;
 document.getElementById("lastname").innerHTML=
 xmlDoc.getElementsByTagName("lastname")[0].childNodes[0].nodeValue;
 document.getElementById("job").innerHTML=
 xmlDoc.getElementsByTagName("job")[0].childNodes[0].nodeValue;
 document.getElementById("age_text").innerHTML="Age: ";
 document.getElementById("age").innerHTML=
 xmlDoc.getElementsByTagName("age")[0].childNodes[0].nodeValue;
 document.getElementById("hometown_text").innerHTML="<br/>From: ";
 document.getElementById("hometown").innerHTML=
 xmlDoc.getElementsByTagName("hometown")[0].childNodes[0].nodeValue;
 }
}

function GetXmlHttpObject()
 {
 var objXMLHttp=null
 if (window.XMLHttpRequest)
  {
  objXMLHttp=new XMLHttpRequest()
  }
 else if (window.ActiveXObject)
  {
  objXMLHttp=new ActiveXObject("Microsoft.XMLHTTP")
  }
 return objXMLHttp
 }

例子解释：

showUser() 与 GetXmlHttpObject 函数与 PHP 和 AJAX MySQL 数据库实例 这一节中的例子是相同的。您可以参阅其中的相关解释。

stateChanged() 函数

如果选择了下拉列表中的项目，该函数执行：

  1. 通过使用 responseXML 函数，把 "xmlDoc" 变量定义为一个 XML 文档
  2. 从这个 XML 文档中取回数据，把它们放在正确的 "span" 元素中

PHP 页面

这个由 JavaScript 调用的服务器页面，是一个名为 "responsexml.php" 的简单的 PHP 文件。

该页面由 PHP 编写，并使用 MySQL 数据库。

代码会运行一段针对数据库的 SQL 查询，并以 XML 文档返回结果：

<?php
header('Content-Type: text/xml');
header("Cache-Control: no-cache, must-revalidate");
//A date in the past
header("Expires: Mon, 26 Jul 1997 05:00:00 GMT");

$q=$_GET["q"];

$con = mysql_connect('localhost', 'peter', 'abc123');
if (!$con)
 {
 die('Could not connect: ' . mysql_error());
 }

mysql_select_db("ajax_demo", $con);

$sql="SELECT * FROM user WHERE id = ".$q."";

$result = mysql_query($sql);

echo '<?xml version="1.0" encoding="ISO-8859-1"?>
<person>';
while($row = mysql_fetch_array($result))
 {
 echo "<firstname>" . $row['FirstName'] . "</firstname>";
 echo "<lastname>" . $row['LastName'] . "</lastname>";
 echo "<age>" . $row['Age'] . "</age>";
 echo "<hometown>" . $row['Hometown'] . "</hometown>";
 echo "<job>" . $row['Job'] . "</job>";
 }
echo "</person>";

mysql_close($con);
?>

例子解释：

当查询从 JavaScript 送达 PHP 页面时，会发生：

  • PHP 文档的 content-type 被设置为 "text/xml"
  • PHP 文档被设置为 "no-cache"，以防止缓存
  • 用 HTML 页面送来的数据设置 $q 变量
  • PHP 打开与 MySQL 服务器的连接
  • 找到带有指定 id 的 "user"
  • 以 XML 文档输出数据
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 和 AJAX RSS 阅读器

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 和 AJAX RSS 阅读器

  • Previous Page
  • Next Page

RSS 阅读器用于阅读 RSS Feed。

RSS 允许对新闻和更新进行快速浏览。

AJAX RSS 阅读器

在下面的 AJAX 实例中，我们将演示一个 RSS 阅读器，通过它，来自 RSS 的内容在不进行刷新的情况下载入网页。

在下面的列表框中选择一个 RSS 新闻订阅

Select an RSS-Feed:

在此列出 RSS Feed。

本例包括三个元素：

  • 简单的 HTML 表单
  • JavaScript
  • PHP 页面

HTML 表单

这是 HTML 页面。它包含一个简单的 HTML 表单和执行一个 JavaScript 文件的链接：

<html>
<head>
<script type="text/javascript" src="getrss.js"></script>
</head>
<body>

<form>
Select an RSS-Feed:
<select onchange="showRSS(this.value)">
<option value="Google">Google News</option>
<option value="MSNBC">MSNBC News</option>
</select>
</form>

<p><div id="rssOutput">
<b>RSS Feed will be listed here.</b></div></p>
</body>
</html>

例子解释 - HTML 表单

正如您看到的，上面的 HTML 页面包含一个简单的 HTML 表单，其中带有一个下拉列表框。

表单是这样工作的：

  1. 当用户选择下拉框中的选项时，会触发一个事件
  2. 当事件触发时，执行 showRSS() 函数

表单下面是名为 "rssOutput" 的一个 <div>。它用作 showRSS() 函数所返回的数据的占位符。

JavaScript

JavaScript 代码存储在 "getrss.js" 中，它与 HTML 文档相连接：

var xmlHttp

function showRSS(str)
 {
 xmlHttp=GetXmlHttpObject()
 if (xmlHttp==null)
  {
  alert ("Browser does not support HTTP Request")
  return
  }
 var url="getrss.php"
 url=url+"?q="+str
 url=url+"&sid="+Math.random()
 xmlHttp.onreadystatechange=stateChanged
 xmlHttp.open("GET",url,true)
 xmlHttp.send(null)
 }

function stateChanged()
 {
 if (xmlHttp.readyState==4 || xmlHttp.readyState=="complete")
  {
  document.getElementById("rssOutput")
  .innerHTML=xmlHttp.responseText
  }
 }

function GetXmlHttpObject()
{
var xmlHttp=null;
try
 {
 // Firefox, Opera 8.0+, Safari
 xmlHttp=new XMLHttpRequest();
 }
catch (e)
 {
 // Internet Explorer
 try
  {
  xmlHttp=new ActiveXObject("Msxml2.XMLHTTP");
  }
 catch (e)
  {
  xmlHttp=new ActiveXObject("Microsoft.XMLHTTP");
  }
 }
return xmlHttp;
}

例子解释：

stateChanged() 和 GetXmlHttpObject 函数与 PHP 和 AJAX 请求 这一节中的例子相同。

showRSS() 函数

每当在下拉框中选择选择时，该函数就会执行：

  1. 定义发送到服务器的 url （文件名）
  2. 把参数 (q) 添加到 url，参数内容是下拉框中的被选项
  3. 添加一个随机数，以防止服务器缓存文件
  4. 调用 GetXmlHttpObject 函数来创建 XMLHTTP 对象，并告知该对象在触发一个改变时去执行 stateChanged 函数
  5. 通过给定的 url 来打开 XMLHTTP
  6. 把 HTTP 请求发动到服务器

PHP 页面

调用 JavaScript 代码的服务器页面是名为 "getrss.php" 的 PHP 文件：

<?php
//get the q parameter from URL
$q=$_GET["q"];

//find out which feed was selected
if($q=="Google")
 {
 $xml=("http://news.google.com/news?ned=us&topic=h&output=rss");
 }
elseif($q=="MSNBC")
 {
 $xml=("http://rss.msnbc.msn.com/id/3032091/device/rss/rss.xml");
 }

$xmlDoc = new DOMDocument();
$xmlDoc->load($xml);

//get elements from "<channel>"
$channel=$xmlDoc->getElementsByTagName('channel')->item(0);
$channel_title = $channel->getElementsByTagName('title')
->item(0)->childNodes->item(0)->nodeValue;
$channel_link = $channel->getElementsByTagName('link')
->item(0)->childNodes->item(0)->nodeValue;
$channel_desc = $channel->getElementsByTagName('description')
->item(0)->childNodes->item(0)->nodeValue;

//output elements from "<channel>"
echo("<p><a href='" . $channel_link
 . "'>" . $channel_title . "</a>");
echo("<br />");
echo($channel_desc . "</p>");

//get and output "<item>" elements
$x=$xmlDoc->getElementsByTagName('item');
for ($i=0; $i<=2; $i++)
 {
 $item_title=$x->item($i)->getElementsByTagName('title')
 ->item(0)->childNodes->item(0)->nodeValue;
 $item_link=$x->item($i)->getElementsByTagName('link')
 ->item(0)->childNodes->item(0)->nodeValue;
 $item_desc=$x->item($i)->getElementsByTagName('description')
 ->item(0)->childNodes->item(0)->nodeValue;

 echo ("<p><a href='" . $item_link
 . "'>" . $item_title . "</a>");
 echo ("<br />");
 echo ($item_desc . "</p>");
 }
?>

例子解释：

当一个选项从 JavaScript 发送时，会发生：

  1. PHP 找出哪个 RSS feed 被选中
  2. 为选中的 RSS feed 创建 XML DOM 对象
  3. 找到并输出来自 RSS 频道的元素
  4. 遍历前三个 RSS 项目中的元素，并进行输出
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 和 AJAX XML 实例

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 和 AJAX XML 实例

  • Previous Page
  • Next Page

AJAX 可与 XML 文件进行交互式通信。

AJAX XML 实例

在下面的 AJAX 实例中，我们将演示网页如何使用 AJAX 技术从 XML 文件中读取信息。

在列表中选择一张 CD （测试说明：该实例功能未实现）

Select a CD:
在此列出 CD 信息。

本例包括三张页面：

  • 一个简单 HTML 表单
  • 一个 XML 文件
  • 一个 JavaScript 文件
  • 一张 PHP 页面

HTML 表单

上面的例子包含了一张简单的 HTML 表单，以及指向 JavaScript 的链接：

<html>
<head>
<script src="selectcd.js"></script>
</head>

<body>

<form>
Select a CD:
<select name="cds" onchange="showCD(this.value)">
<option value="Bob Dylan">Bob Dylan</option>
<option value="Bee Gees">Bee Gees</option>
<option value="Cat Stevens">Cat Stevens</option>
</select>
</form>

<p>
<div id="txtHint"><b>CD info will be listed here.</b></div>
</p>

</body>
</html>

例子解释：

正如您看到的，它仅仅是一张简单的 HTML 表单，其中带有名为 "cds" 的下拉列表。

表单下面的段落包含了一个名为 "txtHint" 的 div。这个 div 用作从 web 服务器检索到的数据的占位符。

当用户选择数据时，会执行名为 "showCD" 的函数。这个函数的执行是由 "onchange" 事件触发的。

换句话说，每当用户改变了下拉列表中的值，就会调用 showCD 函数。

XML 文件

XML 文件是 "cd_catalog.xml"。该文件中包含了有关 CD 收藏的数据。

JavaScript

这是存储在 "selectcd.js" 文件中的 JavaScript 代码：

var xmlHttp

function showCD(str)
{
xmlHttp=GetXmlHttpObject()
if (xmlHttp==null)
 {
 alert ("Browser does not support HTTP Request")
 return
 }
var url="getcd.php"
url=url+"?q="+str
url=url+"&sid="+Math.random()
xmlHttp.onreadystatechange=stateChanged
xmlHttp.open("GET",url,true)
xmlHttp.send(null)
}

function stateChanged()
{
 if (xmlHttp.readyState==4 || xmlHttp.readyState=="complete")
 {
 document.getElementById("txtHint").innerHTML=xmlHttp.responseText
 }
}

function GetXmlHttpObject()
{
var xmlHttp=null;

try
 {
 // Firefox, Opera 8.0+, Safari
 xmlHttp=new XMLHttpRequest();
 }
catch (e)
 {
 // Internet Explorer
 try
  {
  xmlHttp=new ActiveXObject("Msxml2.XMLHTTP");
  }
 catch (e)
  {
  xmlHttp=new ActiveXObject("Microsoft.XMLHTTP");
  }
 }
return xmlHttp;
}

例子解释：

stateChanged() 和 GetXmlHttpObject 函数与上一节中的相同，您可以参阅上一页中的相馆解释。

showCD() 函数

假如选择了下拉列表中的某个项目，则函数执行：

  1. 调用 GetXmlHttpObject 函数来创建 XMLHTTP 对象
  2. 定义发送到服务器的 URL（文件名）
  3. 向 URL 添加带有下拉列表内容的参数 (q)
  4. 添加一个随机数，以防服务器使用缓存的文件
  5. 当触发事件时调用 stateChanged
  6. 通过给定的 URL 打开 XMLHTTP 对象
  7. 向服务器发送 HTTP 请求

PHP 页面

这个被 JavaScript 调用的服务器页面，是一个名为 "getcd.php" 的简单 PHP 文件。

这张页面是用 PHP 编写的，使用 XML DOM 来加载 XML 文档 "cd_catalog.xml"。

代码运行针对 XML 文件的查询，并以 HTML 返回结果：

<?php
$q=$_GET["q"];

$xmlDoc = new DOMDocument();
$xmlDoc->load("cd_catalog.xml");

$x=$xmlDoc->getElementsByTagName('ARTIST');

for ($i=0; $i<=$x->length-1; $i++)
{
//Process only element nodes
if ($x->item($i)->nodeType==1)
  {
  if ($x->item($i)->childNodes->item(0)->nodeValue == $q)
    {
    $y=($x->item($i)->parentNode);
    }
  }
}

$cd=($y->childNodes);

for ($i=0;$i<$cd->length;$i++)
{
//Process only element nodes
if ($cd->item($i)->nodeType==1)
  {
  echo($cd->item($i)->nodeName);
  echo(": ");
  echo($cd->item($i)->childNodes->item(0)->nodeValue);
  echo("<br />");
  }
}
?>

例子解释

当请求从 JavaScript 发送到 PHP 页面时，发生：

  1. PHP 创建 "cd_catalog.xml" 文件的 XML DOM 对象
  2. 循环所有 "artist" 元素 (nodetypes = 1)，查找与 JavaScript 所传数据向匹配的名字
  3. 找到 CD 包含的正确 artist
  4. 输出 album 的信息，并发送到 "txtHint" 占位符
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 和 AJAX 请求

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 和 AJAX 请求

  • Previous Page
  • Next Page

AJAX 请求

在下面的 AJAX 例子中，我们将演示当用户向 web 表单中输入数据时，网页如何与在线的 web 服务器进行通信。

在下面的文本框中输入一个名字（测试说明：该实例功能未实现）

Suggestions:

这个例子包括三张页面：

  • a simple HTML form
  • a JavaScript
  • a PHP page

HTML 表单

这是 HTML 表单。它包含一个简单的 HTML 表单和指向 JavaScript 的链接：

<html>
<head>
<script src="clienthint.js"></script>
</head>

<body>

<form>
First Name:
<input type="text" id="txt1"
onkeyup="showHint(this.value)">
</form>

<p>Suggestions: <span id="txtHint"></span></p>

</body>
</html>

例子解释 - HTML 表单

正如您看到的，上面的 HTML 页面含有一个简单的 HTML 表单，其中带有一个名为 "txt1" 的输入字段。

该表单是这样工作的：

  1. 当用户在输入域中按下并松开按键时，会触发一个事件
  2. 当该事件被触发时，执行名为 showHint() 的函数
  3. 表单的下面是一个名为 "txtHint" 的 <span>。它用作 showHint() 函数所返回数据的占位符。

JavaScript

JavaScript 代码存储在 "clienthint.js" 文件中，它被链接到 HTML 文档：

var xmlHttp

function showHint(str)
{
if (str.length==0)
  {
  document.getElementById("txtHint").innerHTML=""
  return
  }
xmlHttp=GetXmlHttpObject()
if (xmlHttp==null)
  {
  alert ("Browser does not support HTTP Request")
  return
  }
var url="gethint.php"
url=url+"?q="+str
url=url+"&sid="+Math.random()
xmlHttp.onreadystatechange=stateChanged
xmlHttp.open("GET",url,true)
xmlHttp.send(null)
}

function stateChanged()
{
if (xmlHttp.readyState==4 || xmlHttp.readyState=="complete")
 {
 document.getElementById("txtHint").innerHTML=xmlHttp.responseText
 }
}

function GetXmlHttpObject()
{
var xmlHttp=null;
try
 {
 // Firefox, Opera 8.0+, Safari
 xmlHttp=new XMLHttpRequest();
 }
catch (e)
 {
 // Internet Explorer
 try
  {
  xmlHttp=new ActiveXObject("Msxml2.XMLHTTP");
  }
 catch (e)
  {
  xmlHttp=new ActiveXObject("Microsoft.XMLHTTP");
  }
 }
return xmlHttp;
}

例子解释：

showHint() 函数

每当在输入域中输入一个字符，该函数就会被执行一次。

如果文本框中有内容 (str.length > 0)，该函数这样执行：

  1. 定义要发送到服务器的 URL（文件名）
  2. 把带有输入域内容的参数 (q) 添加到这个 URL
  3. 添加一个随机数，以防服务器使用缓存文件
  4. 调用 GetXmlHttpObject 函数来创建 XMLHTTP 对象，并在事件被触发时告知该对象执行名为 stateChanged 的函数
  5. 用给定的 URL 来打开打开这个 XMLHTTP 对象
  6. 向服务器发送 HTTP 请求

如果输入域为空，则函数简单地清空 txtHint 占位符的内容。

stateChanged() 函数

每当 XMLHTTP 对象的状态发生改变，则执行该函数。

在状态变成 4 （或 "complete"）时，用响应文本填充 txtHint 占位符 txtHint 的内容。

GetXmlHttpObject() 函数

AJAX 应用程序只能运行在完整支持 XML 的 web 浏览器中。

上面的代码调用了名为 GetXmlHttpObject() 的函数。

该函数的作用是解决为不同浏览器创建不同 XMLHTTP 对象的问题。

这一点在上一节中已经解释过了。

PHP 页面

被 JavaScript 代码调用的服务器页面是一个名为 "gethint.php" 的简单服务器页面。

"gethint.php" 中的代码会检查名字数组，然后向客户端返回对应的名字：

<?php
// Fill up array with names
$a[]="Anna";
$a[]="Brittany";
$a[]="Cinderella";
$a[]="Diana";
$a[]="Eva";
$a[]="Fiona";
$a[]="Gunda";
$a[]="Hege";
$a[]="Inga";
$a[]="Johanna";
$a[]="Kitty";
$a[]="Linda";
$a[]="Nina";
$a[]="Ophelia";
$a[]="Petunia";
$a[]="Amanda";
$a[]="Raquel";
$a[]="Cindy";
$a[]="Doris";
$a[]="Eve";
$a[]="Evita";
$a[]="Sunniva";
$a[]="Tove";
$a[]="Unni";
$a[]="Violet";
$a[]="Liza";
$a[]="Elizabeth";
$a[]="Ellen";
$a[]="Wenche";
$a[]="Vicky";

//get the q parameter from URL
$q=$_GET["q"];

//lookup all hints from array if length of q>0
if (strlen($q) > 0)
{
$hint="";
for($i=0; $i<count($a); $i++)
  {
  if (strtolower($q)==strtolower(substr($a[$i],0,strlen($q))))
    {
    if ($hint=="")
      {
      $hint=$a[$i];
      }
    else
      {
      $hint=$hint." , ".$a[$i];
      }
    }
  }
}

//Set output to "no suggestion" if no hint were found
//or to the correct values
if ($hint == "")
{
$response="no suggestion";
}
else
{
$response=$hint;
}

//output the response
echo $response;
?>

如果存在从 JavaScript 送来的文本 (strlen($q) > 0)，则：

  1. 找到与 JavaScript 所传送的字符相匹配的名字
  2. 如果找到多个名字，把所有名字包含在 response 字符串中
  3. 如果没有找到匹配的名字，把 response 设置为 "no suggestion"
  4. 如果找到一个或多个名字，把 response 设置为这些名字
  5. 把 response 发送到 "txtHint" 占位符
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 和 AJAX 投票

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 和 AJAX 投票

  • Previous Page
  • Next Page

AJAX 投票

在这个 AJAX 实例中，我们将演示一个投票程序，网页在不重新加载的情况下，就可以获得结果。

到目前为止，您喜欢 PHP 和 AJXA 吗？

Yes:
No:

本例包括四个元素：

  • HTML 表单
  • JavaScript
  • PHP 页面
  • 存放结果的文本文件

HTML 表单

这是 HTML 页面。它包含一个简单的 HTML 表单，以及一个与 JavaScript 文件的连接：

<html>
<head>
<script src="poll.js"></script>
</head>
<body>

<div id="poll">
<h2>Do you like PHP and AJAX so far?</h2>

<form>
Yes:
<input type="radio" name="vote"
value="0" onclick="getVote(this.value)">
<br />
No:
<input type="radio" name="vote"
value="1" onclick="getVote(this.value)">
</form>
</div>

</body>
</html>

例子解释 - HTML 表单

正如您看到的，上面的 HTML 页面包含一个简单的 HTML 表单，其中的 <div> 元素带有两个单选按钮。

表单这样工作：

  • 当用户选择 "yes" 或 "no" 时，会触发一个事件
  • 当事件触发时，执行 getVote() 函数
  • 围绕该表单的是名为 "poll" 的 <div>。当数据从 getVote() 函数返回时，返回的数据会替代该表单。

文本文件

文本文件 (poll_result.txt) 中存储来自投票程序的数据。

它类似这样：

0||0

第一个数字表示 "Yes" 投票，第二个数字表示 "No" 投票。

注释：记得只允许您的 web 服务器来编辑该文本文件。不要让其他人获得访问权，除了 web 服务器 (PHP)。

JavaScript

JavaScript 代码存储在 "poll.js" 中，并于 HTML 文档相连接：

var xmlHttp

function getVote(int)
{
xmlHttp=GetXmlHttpObject()
if (xmlHttp==null)
 {
 alert ("Browser does not support HTTP Request")
 return
 }
var url="poll_vote.php"
url=url+"?vote="+int
url=url+"&sid="+Math.random()
xmlHttp.onreadystatechange=stateChanged
xmlHttp.open("GET",url,true)
xmlHttp.send(null)
}

function stateChanged()
{
 if (xmlHttp.readyState==4 || xmlHttp.readyState=="complete")
 {
 document.getElementById("poll").
 innerHTML=xmlHttp.responseText;
 }
}

function GetXmlHttpObject()
{
var objXMLHttp=null
if (window.XMLHttpRequest)
 {
 objXMLHttp=new XMLHttpRequest()
 }
else if (window.ActiveXObject)
 {
 objXMLHttp=new ActiveXObject("Microsoft.XMLHTTP")
 }
return objXMLHttp
}

例子解释：

stateChanged() 和 GetXmlHttpObject 函数与 PHP 和 AJAX 请求 这一节中的例子相同。

getVote() 函数

当用户在 HTML 表单中选择 "yes" 或 "no" 时，该函数就会执行。

  1. 定义发送到服务器的 url （文件名）
  2. 向 url 添加参数 (vote)，参数中带有输入字段的内容
  3. 添加一个随机数，以防止服务器使用缓存的文件
  4. 调用 GetXmlHttpObject 函数来创建 XMLHTTP 对象，并告知该对象当触发一个变化时执行 stateChanged 函数
  5. 用给定的 url 来打开 XMLHTTP 对象
  6. 向服务器发送 HTTP 请求

PHP 页面

由 JavaScript 代码调用的服务器页面是名为 "poll_vote.php" 的一个简单的 PHP 文件。

<?php
$vote = $_REQUEST['vote'];

//get content of textfile
$filename = "poll_result.txt";
$content = file($filename);

//put content in array
$array = explode("||", $content[0]);
$yes = $array[0];
$no = $array[1];

if ($vote == 0)
 {
 $yes = $yes + 1;
 }
if ($vote == 1)
 {
 $no = $no + 1;
 }

//insert votes to txt file
$insertvote = $yes."||".$no;
$fp = fopen($filename,"w");
fputs($fp,$insertvote);
fclose($fp);
?>

<h2>Result:</h2>
<table>
<tr>
<td>Yes:</td>
<td>
<img src="poll.gif"
width='<?php echo(100*round($yes/($no+$yes),2)); ?>'
height='20'>
<?php echo(100*round($yes/($no+$yes),2)); ?>%
</td>
</tr>
<tr>
<td>No:</td>
<td>
<img src="poll.gif"
width='<?php echo(100*round($no/($no+$yes),2)); ?>'
height='20'>
<?php echo(100*round($no/($no+$yes),2)); ?>%
</td>
</tr>
</table>

例子解释：

所选的值从 JavaScript 传来，然后会发生：

  1. 获取 "poll_result.txt" 文件的内容
  2. 把文件内容放入变量，并向被选变量累加 1
  3. 把结果写入 "poll_result.txt" 文件
  4. 输出图形化的投票结果
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 简介

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 简介

  • Previous Page
  • Next Page

PHP 文件可包含文本、HTML 标签以及脚本。PHP 文件中的脚本可在服务器上执行。

您应当具备的基础知识

在继续学习之前，您需要对下面的知识有基本的了解：

  • HTML / XHTML
  • 基础的脚本知识

如果您希望首先学习这些项目，请在我们的 首页 访问这些教程。

什么是 PHP？

  • PHP 指 PHP:超文本预处理器（译者注：PHP: Hypertext Preprocessor，递归命名）
  • PHP 是一种服务器端的脚本语言，类似 ASP
  • PHP 脚本在服务器上执行
  • PHP 支持很多数据库（MySQL、Informix、Oracle、Sybase、Solid、PostgreSQL、Generic ODBC 等等）
  • PHP 是一个开源的软件（open source software，OSS）
  • PHP 可免费下载使用

什么是 PHP 文件？

  • PHP 文件可包含文本、HTML 标签以及脚本
  • PHP 文件向浏览器返回纯粹的 HTML
  • PHP 文件的文件后缀是".php"、".php3" 或 ".phtml"

什么是 MySQL？

  • MySQL 是一种数据库服务器
  • MySQL 支持标准的 SQL
  • MySQL 可在许多平台上编译
  • MySQL 可免费下载使用

PHP + MySQL

PHP 与 MySQL 的组合是跨平台的（意思是您可以在 Windows 环境进行开发，而在 Unix 平台上提供服务）

为什么要使用 PHP？

  • PHP 可在不同的平台上运行（Windows、Linux、Unix）
  • PHP 与目前几乎所有的正在被使用的服务器相兼容（Apache、IIS 等）
  • PHP 可从官方的 PHP 资源免费下载：www.php.net
  • PHP 易于学习，并可高效地运行在服务器端

从何处开始？

  • 在 Windows 或者 Linux 机器上安装 Apache 服务器
  • 在 Windows 或者 Linux 机器上安装 PHP
  • 在 Windows 或者 Linux 机器上安装 MySQL
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 教程

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 教程

  • Next Page

PHP 是一种创建动态交互性站点的强有力的服务器端脚本语言。

PHP 是免费的，并且使用非常广泛。同时，对于像微软 ASP 这样的竞争者来说，PHP 无疑是另一种高效率的选项。PHP 极其适合网站开发，其代码可以直接嵌入 HTML 代码。

PHP 语法非常类似于 Perl 和 C。PHP 常常搭配 Apache (web 服务器) 一起使用。不过它也支持 ISAPI，并且可以运行于 Windows 的微软 IIS 平台。

开始学习 PHP ！

PHP 参考手册

在 W3School，我们为您提供包括所有 PHP 函数的完整参考手册：

  • Array 函数
  • PHP Calendar 函数
  • PHP Date 函数
  • Directory 函数
  • PHP Error 函数
  • Filesystem 函数
  • Filter 函数
  • FTP 函数
  • HTTP 函数
  • LibXML 函数
  • Mail 函数
  • Math 函数
  • MySQL 函数
  • SimpleXML 函数
  • String 函数
  • XML Parser 函数
  • Zip 函数
  • 杂项函数
  • Next Page

PHP 参考手册
PHP 测验


PHP 数组

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 数组

  • Previous Page
  • Next Page

数组能够在单独的变量名中存储一个或多个值。

什么是数组？

在使用 PHP 进行开发的过程中，或早或晚，您会需要创建许多相似的变量。

无需很多相似的变量，你可以把数据作为元素存储在数组中。

数组中的元素都有自己的 ID，因此可以方便地访问它们。

有三种数组类型：

数值数组
带有数字 ID 键的数组
关联数组
数组中的每个 ID 键关联一个值
多维数组
包含一个或多个数组的数组

数值数组

数值数组存储的每个元素都带有一个数字 ID 键。

可以使用不同的方法来创建数值数组：

例子 1

在这个例子中，会自动分配 ID 键：

$names = array("Peter","Quagmire","Joe");

例子 2

在这个例子中，我们人工分配的 ID 键：

$names[0] = "Peter";
$names[1] = "Quagmire";
$names[2] = "Joe";

可以在脚本中使用这些 ID 键：

<?php

$names[0] = "Peter";
$names[1] = "Quagmire";
$names[2] = "Joe";

echo $names[1] . " and " . $names[2] . " are ". $names[0] . "'s neighbors";
?>

以上代码的输出：

Quagmire and Joe are Peter's neighbors

关联数组

关联数组，它的每个 ID 键都关联一个值。

在存储有关具体命名的值的数据时，使用数值数组不是最好的做法。

通过关联数组，我们可以把值作为键，并向它们赋值。

例子 1

在本例中，我们使用一个数组把年龄分配给不同的人：

$ages = array("Peter"=>32, "Quagmire"=>30, "Joe"=>34);

例子 2

本例与例子 1 相同，不过展示了另一种创建数组的方法：

$ages['Peter'] = "32";
$ages['Quagmire'] = "30";
$ages['Joe'] = "34";

可以在脚本中使用 ID 键：

<?php

$ages['Peter'] = "32";
$ages['Quagmire'] = "30";
$ages['Joe'] = "34";

echo "Peter is " . $ages['Peter'] . " years old.";
?>

以上脚本的输出：

Peter is 32 years old.

多维数组

在多维数组中，主数组中的每个元素也是一个数组。在子数组中的每个元素也可以是数组，以此类推。

例子 1

在本例中，我们创建了一个带有自动分配的 ID 键的多维数组：

$families = array
(
  "Griffin"=>array
  (
  "Peter",
  "Lois",
  "Megan"
  ),
  "Quagmire"=>array
  (
  "Glenn"
  ),
  "Brown"=>array
  (
  "Cleveland",
  "Loretta",
  "Junior"
  )
);

如果输出这个数组的话，应该类似这样：

Array
(
[Griffin] => Array
  (
  [0] => Peter
  [1] => Lois
  [2] => Megan
  )
[Quagmire] => Array
  (
  [0] => Glenn
  )
[Brown] => Array
  (
  [0] => Cleveland
  [1] => Loretta
  [2] => Junior
  )
)

例子 2

让我们试着显示上面的数组中的一个单一的值：

echo "Is " . $families['Griffin'][2] .
" a part of the Griffin family?";

以上代码的输出：

Is Megan a part of the Griffin family?
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 文件处理

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 文件处理

  • Previous Page
  • Next Page

fopen() 函数用于在 PHP 中打开文件。

打开文件

fopen() 函数用于在 PHP 中打开文件。

此函数的第一个参数含有要打开的文件的名称，第二个参数规定了使用哪种模式来打开文件：

<html>
<body>

<?php
$file=fopen("welcome.txt","r");
?>

</body>
</html>

文件可能通过下列模式来打开：

模式 | 描述
r | 只读。在文件的开头开始。
r+ | 读/写。在文件的开头开始。
w | 只写。打开并清空文件的内容；如果文件不存在，则创建新文件。
w+ | 读/写。打开并清空文件的内容；如果文件不存在，则创建新文件。
a | 追加。打开并向文件文件的末端进行写操作，如果文件不存在，则创建新文件。
a+ | 读/追加。通过向文件末端写内容，来保持文件内容。
x | 只写。创建新文件。如果文件以存在，则返回 FALSE。
x+ | 读/写。创建新文件。如果文件已存在，则返回 FALSE 和一个错误。 注释：如果 fopen() 无法打开指定文件，则返回 0 (false)。

例子

如果 fopen() 不能打开指定的文件，下面的例子会生成一段消息：

<html>
<body>

<?php
$file=fopen("welcome.txt","r") or exit("Unable to open file!");
?>

</body>
</html>

关闭文件

fclose() 函数用于关闭打开的文件。

<?php
$file = fopen("test.txt","r");

//some code to be executed

fclose($file);
?>

检测 End-of-file

feof() 函数检测是否已达到文件的末端 (EOF)。

在循环遍历未知长度的数据时，feof() 函数很有用。

注释：在 w 、a 以及 x 模式，您无法读取打开的文件！

if (feof($file)) echo "End of file";

逐行读取文件

fgets() 函数用于从文件中逐行读取文件。

注释：在调用该函数之后，文件指针会移动到下一行。

例子

下面的例子逐行读取文件，直到文件末端为止：

<?php
$file = fopen("welcome.txt", "r") or exit("Unable to open file!");
//Output a line of the file until the end is reached
while(!feof($file))
  {
  echo fgets($file). "<br />";
  }
fclose($file);
?>

逐字符读取文件

fgetc() 函数用于从文件逐字符地读取文件。

注释：在调用该函数之后，文件指针会移动到下一个字符。

例子

下面的例子逐字符地读取文件，直到文件末端为止：

<?php
$file=fopen("welcome.txt","r") or exit("Unable to open file!");
while (!feof($file))
  {
  echo fgetc($file);
  }
fclose($file);
?>

PHP Filesystem 参考手册

如需完整的 PHP 文件系统参考手册，请访问 W3School 提供的 PHP Filesystem 参考手册。

  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 文件上传

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 文件上传

  • Previous Page
  • Next Page

通过 PHP，可以把文件上传到服务器。

创建一个文件上传表单

允许用户从表单上传文件是非常有用的。

请看下面这个供上传文件的 HTML 表单：

<html>
<body>

<form action="upload_file.php" method="post"
enctype="multipart/form-data">
<label for="file">Filename:</label>
<input type="file" name="file" id="file" />
<br />
<input type="submit" name="submit" value="Submit" />
</form>

</body>
</html>

请留意如下有关此表单的信息：

<form> 标签的 enctype 属性规定了在提交表单时要使用哪种内容类型。在表单需要二进制数据时，比如文件内容，请使用 "multipart/form-data"。

<input> 标签的 type="file" 属性规定了应该把输入作为文件来处理。举例来说，当在浏览器中预览时，会看到输入框旁边有一个浏览按钮。

注释：允许用户上传文件是一个巨大的安全风险。请仅仅允许可信的用户执行文件上传操作。

创建上传脚本

"upload_file.php" 文件含有供上传文件的代码：

<?php
if ($_FILES["file"]["error"] > 0)
  {
  echo "Error: " . $_FILES["file"]["error"] . "<br />";
  }
else
  {
  echo "Upload: " . $_FILES["file"]["name"] . "<br />";
  echo "Type: " . $_FILES["file"]["type"] . "<br />";
  echo "Size: " . ($_FILES["file"]["size"] / 1024) . " Kb<br />";
  echo "Stored in: " . $_FILES["file"]["tmp_name"];
  }
?>

通过使用 PHP 的全局数组 $_FILES，你可以从客户计算机向远程服务器上传文件。

第一个参数是表单的 input name，第二个下标可以是 "name", "type", "size", "tmp_name" 或 "error"。就像这样：

  • $_FILES["file"]["name"] - 被上传文件的名称
  • $_FILES["file"]["type"] - 被上传文件的类型
  • $_FILES["file"]["size"] - 被上传文件的大小，以字节计
  • $_FILES["file"]["tmp_name"] - 存储在服务器的文件的临时副本的名称
  • $_FILES["file"]["error"] - 由文件上传导致的错误代码

这是一种非常简单文件上传方式。基于安全方面的考虑，您应当增加有关什么用户有权上传文件的限制。

上传限制

在这个脚本中，我们增加了对文件上传的限制。用户只能上传 .gif 或 .jpeg 文件，文件大小必须小于 20 kb：

<?php

if ((($_FILES["file"]["type"] == "image/gif")
|| ($_FILES["file"]["type"] == "image/jpeg")
|| ($_FILES["file"]["type"] == "image/pjpeg"))
&& ($_FILES["file"]["size"] < 20000))
  {
  if ($_FILES["file"]["error"] > 0)
    {
    echo "Error: " . $_FILES["file"]["error"] . "<br />";
    }
  else
    {
    echo "Upload: " . $_FILES["file"]["name"] . "<br />";
    echo "Type: " . $_FILES["file"]["type"] . "<br />";
    echo "Size: " . ($_FILES["file"]["size"] / 1024) . " Kb<br />";
    echo "Stored in: " . $_FILES["file"]["tmp_name"];
    }
  }
else
  {
  echo "Invalid file";
  }

?>

注释：对于 IE，识别 jpg 文件的类型必须是 pjpeg，对于 FireFox，必须是 jpeg。

保存被上传的文件

上面的例子在服务器的 PHP 临时文件夹创建了一个被上传文件的临时副本。

这个临时的复制文件会在脚本结束时消失。要保存被上传的文件，我们需要把它拷贝到另外的位置：

<?php
if ((($_FILES["file"]["type"] == "image/gif")
|| ($_FILES["file"]["type"] == "image/jpeg")
|| ($_FILES["file"]["type"] == "image/pjpeg"))
&& ($_FILES["file"]["size"] < 20000))
  {
  if ($_FILES["file"]["error"] > 0)
    {
    echo "Return Code: " . $_FILES["file"]["error"] . "<br />";
    }
  else
    {
    echo "Upload: " . $_FILES["file"]["name"] . "<br />";
    echo "Type: " . $_FILES["file"]["type"] . "<br />";
    echo "Size: " . ($_FILES["file"]["size"] / 1024) . " Kb<br />";
    echo "Temp file: " . $_FILES["file"]["tmp_name"] . "<br />";

    if (file_exists("upload/" . $_FILES["file"]["name"]))
      {
      echo $_FILES["file"]["name"] . " already exists. ";
      }
    else
      {
      move_uploaded_file($_FILES["file"]["tmp_name"],
      "upload/" . $_FILES["file"]["name"]);
      echo "Stored in: " . "upload/" . $_FILES["file"]["name"];
      }
    }
  }
else
  {
  echo "Invalid file";
  }
?>

上面的脚本检测了是否已存在此文件，如果不存在，则把文件拷贝到指定的文件夹。

注释：这个例子把文件保存到了名为 "upload" 的新文件夹。

  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 循环

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 循环

  • Previous Page
  • Next Page

PHP 中的循环语句用于执行相同的代码块指定的次数。

循环

在您编写代码时，您经常需要让相同的代码块运行很多次。您可以在代码中使用循环语句来完成这个任务。

在 PHP 中，我们可以使用下列循环语句：

while
只要指定的条件成立，则循环执行代码块
do...while
首先执行一次代码块，然后在指定的条件成立时重复这个循环
for
循环执行代码块指定的次数
foreach
根据数组中每个元素来循环代码块

while 语句

只要指定的条件成立，while 语句将重复执行代码块。

语法

while (condition)
code to be executed;

例子

下面的例子示范了一个循环，只要变量 i 小于或等于 5，代码就会一直循环执行下去。循环每循环一次，变量就会递增 1：

<html>
<body>

<?php
$i=1;
while($i<=5)
  {
  echo "The number is " . $i . "<br />";
  $i++;
  }
?>

</body>
</html>

do...while 语句

do...while 语句会至少执行一次代码 - 然后，只要条件成立，就会重复进行循环。

语法

do
{
code to be executed;
}
while (condition);

例子

下面的例子将对 i 的值进行一次累加，然后，只要 i 小于 5 的条件成立，就会继续累加下去：

<html>
<body>

<?php
$i=0;
do
  {
  $i++;
  echo "The number is " . $i . "<br />";
  }
while ($i<5);
?>

</body>
</html>

for 语句

如果您已经确定了代码块的重复执行次数，则可以使用 for 语句。

语法

for (initialization; condition; increment)
{
  code to be executed;
}

注释：for 语句有三个参数。第一个参数初始化变量，第二个参数保存条件，第三个参数包含执行循环所需的增量。如果 initialization 或 increment 参数中包括了多个变量，需要用逗号进行分隔。而条件必须计算为 true 或者 false。

例子

下面的例子会把文本 "Hello World!" 显示 5 次：

<html>
<body>

<?php
for ($i=1; $i<=5; $i++)
{
  echo "Hello World!<br />";
}
?>

</body>
</html>

foreach 语句

foreach 语句用于循环遍历数组。

每进行一次循环，当前数组元素的值就会被赋值给 value 变量（数组指针会逐一地移动） - 以此类推。

语法

foreach (array as value)
{
    code to be executed;
}

例子

下面的例子示范了一个循环，这个循环可以输出给定数组的值：

<html>
<body>

<?php
$arr=array("one", "two", "three");

foreach ($arr as $value)
{
  echo "Value: " . $value . "<br />";
}
?>

</body>
</html>
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 异常处理

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 异常处理

  • Previous Page
  • Next Page

异常（Exception）用于在指定的错误发生时改变脚本的正常流程。

什么是异常？

PHP 5 提供了一种新的面向对象的错误处理方法。

异常处理用于在指定的错误（异常）情况发生时改变脚本的正常流程。这种情况称为异常。

当异常被触发时，通常会发生：

  • 当前代码状态被保存
  • 代码执行被切换到预定义的异常处理器函数
  • 根据情况，处理器也许会从保存的代码状态重新开始执行代码，终止脚本执行，或从代码中另外的位置继续执行脚本

我们将展示不同的错误处理方法：

  • 异常的基本使用
  • 创建自定义的异常处理器
  • 多个异常
  • 重新抛出异常
  • 设置顶层异常处理器

异常的基本使用

当异常被抛出时，其后的代码不会继续执行，PHP 会尝试查找匹配的 "catch" 代码块。

如果异常没有被捕获，而且又没用使用 set_exception_handler() 作相应的处理的话，那么将发生一个严重的错误（致命错误），并且输出 "Uncaught Exception" （未捕获异常）的错误消息。

让我们尝试抛出一个异常，同时不去捕获它：

<?php
//create function with an exception
function checkNum($number)
 {
 if($number>1)
  {
  throw new Exception("Value must be 1 or below");
  }
 return true;
 }

//trigger exception
checkNum(2);
?>

上面的代码会获得类似这样的一个错误：

Fatal error: Uncaught exception 'Exception'
with message 'Value must be 1 or below' in C:\webfolder\test.php:6
Stack trace: #0 C:\webfolder\test.php(12):
checkNum(28) #1 {main} thrown in C:\webfolder\test.php on line 6

Try, throw 和 catch

要避免上面例子出现的错误，我们需要创建适当的代码来处理异常。

处理处理程序应当包括：

  1. Try - 使用异常的函数应该位于 "try" 代码块内。如果没有触发异常，则代码将照常继续执行。但是如果异常被触发，会抛出一个异常。
  2. Throw - 这里规定如何触发异常。每一个 "throw" 必须对应至少一个 "catch"
  3. Catch - "catch" 代码块会捕获异常，并创建一个包含异常信息的对象

让我们触发一个异常：

<?php
//创建可抛出一个异常的函数
function checkNum($number)
 {
 if($number>1)
  {
  throw new Exception("Value must be 1 or below");
  }
 return true;
 }

//在 "try" 代码块中触发异常
try
 {
 checkNum(2);
 //If the exception is thrown, this text will not be shown
 echo 'If you see this, the number is 1 or below';
 }

//捕获异常
catch(Exception $e)
 {
 echo 'Message: ' .$e->getMessage();
 }
?>

上面代码将获得类似这样一个错误：

Message: Value must be 1 or below

例子解释：

上面的代码抛出了一个异常，并捕获了它：

  1. 创建 checkNum() 函数。它检测数字是否大于 1。如果是，则抛出一个异常。
  2. 在 "try" 代码块中调用 checkNum() 函数。
  3. checkNum() 函数中的异常被抛出
  4. "catch" 代码块接收到该异常，并创建一个包含异常信息的对象 ($e)。
  5. 通过从这个 exception 对象调用 $e->getMessage()，输出来自该异常的错误消息

不过，为了遵循“每个 throw 必须对应一个 catch”的原则，可以设置一个顶层的异常处理器来处理漏掉的错误。

创建一个自定义的 Exception 类

创建自定义的异常处理程序非常简单。我们简单地创建了一个专门的类，当 PHP 中发生异常时，可调用其函数。该类必须是 exception 类的一个扩展。

这个自定义的 exception 类继承了 PHP 的 exception 类的所有属性，您可向其添加自定义的函数。

我们开始创建 exception 类：

<?php
class customException extends Exception
 {
 public function errorMessage()
  {
  //error message
  $errorMsg = 'Error on line '.$this->getLine().' in '.$this->getFile()
  .': <b>'.$this->getMessage().'</b> is not a valid E-Mail address';
  return $errorMsg;
  }
 }

$email = "someone@example...com";

try
 {
 //check if
 if(filter_var($email, FILTER_VALIDATE_EMAIL) === FALSE)
  {
  //throw exception if email is not valid
  throw new customException($email);
  }
 }

catch (customException $e)
 {
 //display custom message
 echo $e->errorMessage();
 }
?>

这个新的类是旧的 exception 类的副本，外加 errorMessage() 函数。正因为它是旧类的副本，因此它从旧类继承了属性和方法，我们可以使用 exception 类的方法，比如 getLine() 、 getFile() 以及 getMessage()。

例子解释：

上面的代码抛出了一个异常，并通过一个自定义的 exception 类来捕获它：

  1. customException() 类是作为旧的 exception 类的一个扩展来创建的。这样它就继承了旧类的所有属性和方法。
  2. 创建 errorMessage() 函数。如果 e-mail 地址不合法，则该函数返回一条错误消息
  3. 把 $email 变量设置为不合法的 e-mail 地址字符串
  4. 执行 "try" 代码块，由于 e-mail 地址不合法，因此抛出一个异常
  5. "catch" 代码块捕获异常，并显示错误消息

多个异常

可以为一段脚本使用多个异常，来检测多种情况。

可以使用多个 if..else 代码块，或一个 switch 代码块，或者嵌套多个异常。这些异常能够使用不同的 exception 类，并返回不同的错误消息：

<?php
class customException extends Exception
{
public function errorMessage()
{
//error message
$errorMsg = 'Error on line '.$this->getLine().' in '.$this->getFile()
.': <b>'.$this->getMessage().'</b> is not a valid E-Mail address';
return $errorMsg;
}
}

$email = "someone@example.com";

try
 {
 //check if
 if(filter_var($email, FILTER_VALIDATE_EMAIL) === FALSE)
  {
  //throw exception if email is not valid
  throw new customException($email);
  }
 //check for "example" in mail address
 if(strpos($email, "example") !== FALSE)
  {
  throw new Exception("$email is an example e-mail");
  }
 }

catch (customException $e)
 {
 echo $e->errorMessage();
 }

catch(Exception $e)
 {
 echo $e->getMessage();
 }
?>

例子解释：

上面的代码测试了两种条件，如何任何条件不成立，则抛出一个异常：

  1. customException() 类是作为旧的 exception 类的一个扩展来创建的。这样它就继承了旧类的所有属性和方法。
  2. 创建 errorMessage() 函数。如果 e-mail 地址不合法，则该函数返回一个错误消息。
  3. 执行 "try" 代码块，在第一个条件下，不会抛出异常。
  4. 由于 e-mail 含有字符串 "example"，第二个条件会触发异常。
  5. "catch" 代码块会捕获异常，并显示恰当的错误消息

如果没有捕获 customException，紧紧捕获了 base exception，则在那里处理异常。

重新抛出异常

有时，当异常被抛出时，您也许希望以不同于标准的方式对它进行处理。可以在一个 "catch" 代码块中再次抛出异常。

脚本应该对用户隐藏系统错误。对程序员来说，系统错误也许很重要，但是用户对它们并不感兴趣。为了让用户更容易使用，您可以再次抛出带有对用户比较友好的消息的异常：

<?php
class customException extends Exception
 {
 public function errorMessage()
  {
  //error message
  $errorMsg = $this->getMessage().' is not a valid E-Mail address.';
  return $errorMsg;
  }
 }

$email = "someone@example.com";

try
 {
 try
  {
  //check for "example" in mail address
  if(strpos($email, "example") !== FALSE)
   {
   //throw exception if email is not valid
   throw new Exception($email);
   }
  }
 catch(Exception $e)
  {
  //re-throw exception
  throw new customException($email);
  }
 }

catch (customException $e)
 {
 //display custom message
 echo $e->errorMessage();
 }
?>

例子解释：

上面的代码检测在邮件地址中是否含有字符串 "example"。如果有，则再次抛出异常：

  1. customException() 类是作为旧的 exception 类的一个扩展来创建的。这样它就继承了旧类的所有属性和方法。
  2. 创建 errorMessage() 函数。如果 e-mail 地址不合法，则该函数返回一个错误消息。
  3. 把 $email 变量设置为一个有效的邮件地址，但含有字符串 "example"。
  4. "try" 代码块包含另一个 "try" 代码块，这样就可以再次抛出异常。
  5. 由于 e-mail 包含字符串 "example"，因此触发异常。
  6. "catch" 捕获到该异常，并重新抛出 "customException"。
  7. 捕获到 "customException"，并显示一条错误消息。

如果在其目前的 "try" 代码块中异常没有被捕获，则它将在更高层级上查找 catch 代码块。

设置顶层异常处理器 （Top Level Exception Handler）

set_exception_handler() 函数可设置处理所有未捕获异常的用户定义函数。

<?php
function myException($exception)
{
echo "<b>Exception:</b> " , $exception->getMessage();
}

set_exception_handler('myException');

throw new Exception('Uncaught Exception occurred');
?>

以上代码的输出应该类似这样：

Exception: Uncaught Exception occurred

在上面的代码中，不存在 "catch" 代码块，而是触发顶层的异常处理程序。应该使用此函数来捕获所有未被捕获的异常。

异常的规则

  • 需要进行异常处理的代码应该放入 try 代码块内，以便捕获潜在的异常。
  • 每个 try 或 throw 代码块必须至少拥有一个对应的 catch 代码块。
  • 使用多个 catch 代码块可以捕获不同种类的异常。
  • 可以在 try 代码块内的 catch 代码块中再次抛出（re-thrown）异常。

简而言之：如果抛出了异常，就必须捕获它。

  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 引用文件

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 引用文件

  • Previous Page
  • Next Page

服务器端引用 (SSI) 用于创建可在多个页面重复使用的函数、页眉、页脚或元素。

服务器端引用（Server Side Includes）

通过 include() 或 require() 函数，您可以在服务器执行 PHP 文件之前在该文件中插入一个文件的内容。除了它们处理错误的方式不同之外，这两个函数在其他方面都是相同的。include() 函数会生成一个警告（但是脚本会继续执行），而 require() 函数会生成一个致命错误（fatal error）（在错误发生后脚本会停止执行）。

这两个函数用于创建可在多个页面重复使用的函数、页眉、页脚或元素。

这会为开发者节省大量的时间。这意味着您可以创建供所有网页引用的标准页眉或菜单文件。当页眉需要更新时，您只更新一个包含文件就可以了，或者当您向网站添加一张新页面时，仅仅需要修改一下菜单文件（而不是更新所有网页中的链接）。

include() 函数

include() 函数可获得指定文件中的所有文本，并把文本拷贝到使用 include 函数的文件中。

例子 1

假设您拥有一个标准的页眉文件，名为 "header.php"。如需在页面中引用这个页眉文件，请使用 include() 函数，就像这样：

<html>
<body>

<?php include("header.php"); ?>

<h1>Welcome to my home page</h1>

<p>Some text</p>

</body>
</html>

例子 2

现在，假设我们有一个在所有页面上使用的标准菜单文件。请看下面这个 "menu.php"：

<html>
<body>

<a href="http://www.w3school.com.cn/default.php">Home</a> |
<a href="http://www.w3school.com.cn/about.php">About Us</a> |
<a href="http://www.w3school.com.cn/contact.php">Contact Us</a>

三个文件，"default.php"、"about.php" 以及 "contact.php" 都引用了 "menu.php" 文件。这是 "default.php" 中的代码：

<?php include("menu.php"); ?>

<h1>Welcome to my home page</h1>

<p>Some text</p>

</body>
</html>

如果您在浏览器中查看 "default.php" 的源代码，应该类似这样：

<html>
<body>

<a href="default.php">Home</a> |
<a href="about.php">About Us</a> |
<a href="contact.php">Contact Us</a>

<h1>Welcome to my home page</h1>
<p>Some text</p>

</body>
</html>

同时，当然，我们也将用相同的方法处理 "about.php" 和 "contact.php"。通过使用引用文件，在您需要重命名链接、更改链接顺序或向站点添加另一张网页时，只要简单地更新 "menu.php" 文件中的文本即可。

require() 函数

require() 函数与 include() 相同，不同的是它对错误的处理方式。

include() 函数会生成一个警告（但是脚本会继续执行），而 require() 函数会生成一个致命错误（fatal error）（在错误发生后脚本会停止执行）。

如果在您通过 include() 引用文件时发生了错误，会得到类似下面这样的错误消息：

PHP 代码：

<html>
<body>

<?php
include("wrongFile.php");
echo "Hello World!";
?>

</body>
</html>

错误消息：

Warning: include(wrongFile.php) [function.include]:
failed to open stream:
No such file or directory in C:\home\website\test.php on line 5

Warning: include() [function.include]:
Failed opening 'wrongFile.php' for inclusion
(include_path='.;C:\php5\pear')
in C:\home\website\test.php on line 5

Hello World!

请注意，echo 语句依然被执行了！这是因为警告不会中止脚本的执行。

现在，让我们使用 require() 函数运行相同的例子。

PHP 代码：

<html>
<body>

<?php
require("wrongFile.php");
echo "Hello World!";
?>

</body>
</html>

错误消息：

Warning: require(wrongFile.php) [function.require]:
failed to open stream:
No such file or directory in C:\home\website\test.php on line 5

Fatal error: require() [function.require]:
Failed opening required 'wrongFile.php'
(include_path='.;C:\php5\pear')
in C:\home\website\test.php on line 5

由于在致命错误发生后终止了脚本的执行，因此 echo 语句不会执行。

正因为在文件不存在或被重命名后脚本不会继续执行，因此我们推荐使用 require() 而不是 include()。

  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 语法

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 语法

  • Previous Page
  • Next Page

您无法在浏览器中通过查看源文档的方式来查看 PHP 的源代码 - 您只能看到 PHP 文件的输出，即纯粹的 HTML。这是因为在结果返回浏览器之前，脚本就已经在服务器执行了。

基本的 PHP 语法

PHP 的脚本块以 <?php 开始，以 ?> 结束。您可以把 PHP 的脚本块放置在文档中的任何位置。

当然，在支持简写的服务器上，您可以使用 <? 和 ?> 来开始和结束脚本块。

不过，为了达到最好的兼容性，我们推荐您使用标准形式 (<?php)，而不是简写形式。

<?php

?>

PHP 文件通常会包含 HTML 标签，就像一个 HTML 文件，以及一些 PHP 脚本代码。

在下面，我们提供了一段简单的 PHP 脚本，它可以向浏览器输出文本 "Hello World"：

<html>
<body>

<?php
echo "Hello World";
?>

</body>
</html>

PHP 中的每个代码行都必须以分号结束。分号是一种分隔符，用于把指令集区分开来。

有两种通过 PHP 来输出文本的基础指令：echo 和 print。在上面的例子中，我们使用了 echo 语句来输出文本 "Hello World"。

PHP 中的注释

在 PHP 中，我们使用 // 来编写单行注释，或者使用 /* 和 */ 来编写大的注释块。

<html>
<body>

<?php

//This is a comment

/*
This is
a comment
block
*/

?>

</body>
</html>
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 运算符

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 运算符

  • Previous Page
  • Next Page

运算符用于对值进行运算.

PHP 运算符

本部分列出了在 PHP 中使用的各种运算符：

算数运算符

运算符 | 说明 | 例子 | 结果
+ | Addition | x=2 x+2 | 4
- | Subtraction | x=2 5-x | 3
* | Multiplication | x=4 x*5 | 20
/ | Division | 15/5 5/2 | 3 2.5
% | Modulus (division remainder) | 5%2 10%8 10%2 | 1 2 0
++ | Increment | x=5 x++ | x=6
-- | Decrement | x=5 x-- | x=4

赋值运算符

运算符 | 说明 | 例子
= | x=y | x=y
+= | x+=y | x=x+y
-= | x-=y | x=x-y
*= | x*=y | x=x*y
/= | x/=y | x=x/y
.= | x.=y | x=x.y
%= | x%=y | x=x%y

比较运算符

运算符 | 说明 | 例子
== | is equal to | 5==8 returns false
!= | is not equal | 5!=8 returns true
> | is greater than | 5>8 returns false
< | is less than | 5<8 returns true
>= | is greater than or equal to | 5>=8 returns false
<= | is less than or equal to | 5<=8 returns true

逻辑运算符

运算符 | 说明 | 例子
&& | and | x=6 y=3 (x < 10 && y > 1) returns true
|| | or | x=6 y=3 (x==5 || y==5) returns false
! | not | x=6 y=3 !(x==y) returns true
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 杂项函数

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 杂项函数

  • Previous Page
  • Next Page

PHP 杂项函数简介

我们把不属于其他类别的函数归纳到这个页面。

安装

杂项函数是 PHP 核心的组成部分。无需安装即可使用这些函数。

Runtime 配置

杂项函数函数的行为受到 php.ini 中设置的影响。

杂项函数配置选项：

名称 | 默认 | 描述 | 可更改
ignore_user_abort | "0" | FALSE 指示只要脚本在客户机终止连接后尝试进行输出，脚本将被终止。 | PHP_INI_ALL
highlight.string | "#DD0000" | 供突出显示符合 PHP 语法的字符串而使用的颜色。 | PHP_INI_ALL
highlight.comment | "#FF8000" | 供突出显示 PHP 注释而使用的颜色。 | PHP_INI_ALL
highlight.keyword | "#007700" | 供突出显示 PHP 关键词而使用的颜色（比如圆括号和分号）。 | PHP_INI_ALL
highlight.bg | "#FFFFFF" | 背景颜色。 | PHP_INI_ALL
highlight.default | "#0000BB" | PHP 语法的默认颜色。 | PHP_INI_ALL
highlight.html | "#000000" | HTML 代码的颜色。 | PHP_INI_ALL
browscap | NULL | 浏览器性能文件的名称和位置（例如：browscap.ini）。 | PHP_INI_SYSTEM

PHP 杂项函数

PHP：指示支持该函数的最早的 PHP 版本。

函数 | 描述 | PHP
connection_aborted() | 检查是否断开客户机。 | 3
connection_status() | 返回当前的连接状态。 | 3
connection_timeout() | 在 PHP 4.0.5 中不赞成使用。 | 3
constant() | 返回一个常量的值。 | 4
define() | 定义一个常量。 | 3
defined() | 检查某常量是否存在。 | 3
die() | 输出一条消息，并退出当前脚本。 | 3
eval() | 把字符串按照 PHP 代码来计算。 | 3
exit() | 输出一条消息，并退出当前脚本。 | 3
get_browser() | 返回用户浏览器的性能。 | 3
highlight_file() | 对文件进行语法高亮显示。 | 4
highlight_string() | 对字符串进行语法高亮显示。 | 4
ignore_user_abort() | 设置与客户机断开是否会终止脚本的执行。 | 3
pack() | 把数据装入一个二进制字符串。 | 3
php_check_syntax() | 在 PHP 5.0.5 中不赞成使用。 | 5
php_strip_whitespace() | 返回已删除 PHP 注释以及空白字符的源代码文件。 | 5
show_source() | highlight_file() 的别名。 | 4
sleep() | 延迟代码执行若干秒。 | 3
time_nanosleep() | 延迟代码执行若干秒和纳秒。 | 5
time_sleep_until() | 延迟代码执行指定的时间。 | 5
uniqid() | 生成唯一的 ID。 | 3
unpack() | 从二进制字符串对数据进行解包。 | 3
usleep() | 延迟代码执行若干微秒。 | 3

PHP Date / Time 常量

PHP：指示支持该常量的最早的 PHP 版本。

常量 | 描述 | PHP
CONNECTION_ABORTED |  |
CONNECTION_NORMAL |  |
CONNECTION_TIMEOUT |  |
__COMPILER_HALT_OFFSET__ |  | 5
  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


PHP 字符串

PHP 基础

  • PHP 教程
  • PHP 简介
  • PHP 安装
  • PHP 语法
  • PHP 变量
  • PHP 字符串
  • PHP 运算符
  • PHP If...Else
  • PHP Switch
  • PHP 数组
  • PHP 循环
  • PHP 函数
  • PHP 表单
  • PHP $_GET
  • PHP $_POST

PHP 高级

  • PHP 日期
  • PHP 引用
  • PHP 文件
  • PHP 文件上传
  • PHP Cookies
  • PHP Sessions
  • PHP E-mail
  • PHP 安全 E-mail
  • PHP Error
  • PHP Exception
  • PHP Filter

PHP 数据库

  • MySQL 简介
  • MySQL Connect
  • MySQL Create
  • MySQL Insert
  • MySQL Select
  • MySQL Where
  • MySQL Order By
  • MySQL Update
  • MySQL Delete
  • PHP ODBC

PHP XML

  • XML Expat Parser
  • XML DOM
  • XML SimpleXML

PHP 和 AJAX

  • AJAX 简介
  • XMLHttpRequest
  • AJAX Suggest
  • AJAX XML
  • AJAX Database
  • AJAX responseXML
  • AJAX Live Search
  • AJAX RSS Reader
  • AJAX Poll

PHP 参考手册

  • PHP Array
  • PHP Calendar
  • PHP Date
  • PHP Directory
  • PHP Error
  • PHP Filesystem
  • PHP Filter
  • PHP FTP
  • PHP HTTP
  • PHP LibXML
  • PHP Mail
  • PHP Math
  • PHP MySQL
  • PHP SimpleXML
  • PHP String
  • PHP XML
  • PHP Zip
  • PHP 杂项

PHP 测验

  • PHP Quiz

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

PHP 字符串

  • Previous Page
  • Next Page

字符串变量用于存储并处理文本片段。

PHP 中的字符串

字符串变量用于包含字符串的值。

在本教程中，我们打算介绍几个在 PHP 中用于操作字符串的最常用的函数和运算符。

在创建字符串之后，我们就可以对它进行操作了。您可以直接在函数中使用字符串，或者把它存储在变量中。

在下面，PHP 脚本把字符串 "Hello World" 赋值给名为 $txt 的字符串变量：

<?php
$txt="Hello World";
echo $txt;
?>

以上代码的输出：

Hello World

现在，让我们试着使用不同的函数和运算符来操作我们的字符串。

并置运算符（Concatenation Operator）

在 PHP 中，只有一个字符串运算符。

并置运算符 (.) 用于把两个字符串值连接起来。

要把两个变量连接在一起，请使用这个点运算符 (.) ：

<?php
$txt1="Hello World";
$txt2="1234";
echo $txt1 . " " . $txt2;
?>

以上代码的输出：

Hello World 1234

您可以看到，我们在上面的例子中使用了两次并置运算符。这是由于我们需要插入第三个字符串。

为了分隔这两个变量，我们在 $txt1 与 $txt2 之间插入了一个空格。

使用 strlen() 函数

strlen() 函数用于计算字符串的长度。

让我们算出字符串 "Hello world!" 的长度：

<?php
echo strlen("Hello world!");
?>

以上代码的输出：

12

字符串的长度信息常常用在循环或其他函数中，因为那时确定字符串何时结束是很重要的（例如，在循环中，我们需要在字符串中的最后一个字符之后结束循环）。

使用 strpos() 函数

strpos() 函数用于在字符串内检索一段字符串或一个字符。

如果在字符串中找到匹配，该函数会返回第一个匹配的位置。如果未找到匹配，则返回 FALSE。

让我们试一下，是不是能在字符串中找到子字符串 "world"：

<?php
echo strpos("Hello world!","world");
?>

以上代码的输出是：

6

正如您看到的，在我们的字符串中，字符串 "world" 的位置是 6。返回 6 而不是 7，是由于字符串中的首个位置的 0，而不是 1。

完整的 PHP String 参考手册

如需完整的字符串函数参考手册，请访问我们的 PHP String 参考手册。

这个手册提供了每个函数的简要描述和实例！

  • Previous Page
  • Next Page

PHP 参考手册
PHP 测验


Web Quality - 样式表

网站品质

  • 教程首页
  • Web 标准
  • HTML 元素
  • 样式表
  • 可读性
  • 易用性
  • 国际化

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Web 品质 - 样式表

  • Previous Page
  • Next Page

使用样式表对于提升网页品质至关重要。

请勿使用 font 标签

应使用 CSS 来设置显示网页上的字体尺寸。请不要使用 font 标签。

使用 <font> 标签会增加文档的规模，而且使您每次改变标准文字尺寸的工作成为一场梦魇。

请设想一下下面的情况：

一天您决定修改网站中所有标题的颜色和尺寸。通过 CSS，您只需要修改一行就可以做到这一点。假如您使用了 <font>标签，那么您需要把网站中所有页面的所有标题都修改一遍。

使用样式替代 <font> 标签可使我们更轻松地为网页制作高质量的界面。

请勿使用固定的字体尺寸

不要使用固定的尺寸值。请始终使用相对的尺寸值。

这项建议最重要的理由是无法通过浏览器重新调整固定尺寸的大小。

您的访问者会使用不同的设备（显示器）、不同的浏览环境（光线）以及可能的残疾（弱视）。

例如，可以把某人的文字尺寸设置为100%（或者 medium ），主标题设置为140%（或者 x-large ），而次级的标题设置为120%（或者 large ），这样用户就可以使用浏览器来重新设定最喜欢的尺寸了。

通过调整网页的文本尺寸的功能，也可以改变打印页面的文字数目。

请勿使用很小的默认字体尺寸

一些网站会使用很小的文字尺寸，这样就可以向每张页面“塞”入更多的内容，或者使页面看上去更“时髦”。

再次重申，使用不同的设备（显示器）、不同的浏览环境（光线）以及可能的残疾（弱视），都可能对用户造成阅读障碍。

请不要逼迫用户每次访问你的站点时都要放大文本的尺寸。

始终使用一致的背景颜色

大部分网页都会为不同的文本元素使用颜色。标题和链接的颜色通常与正文的文本颜色是不同的。

作为一位 web 设计者，您应当意识到的事实是，您的访问者能够修改默认的颜色选项。

如果您为 web 元素定义了颜色，那么同样应当定义背景颜色。

如果不定义背景颜色，那么您的网站可能会被糟糕的颜色组合搞砸（比如红色背景上面的亮红文字，或者深色文本搭配的深色背景）。

如果您不规定背景颜色，可能会使文本很难被识别。

  • Previous Page
  • Next Page


Web 品质 - 标准

网站品质

  • 教程首页
  • Web 标准
  • HTML 元素
  • 样式表
  • 可读性
  • 易用性
  • 国际化

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Web 品质 - 标准

  • Previous Page
  • Next Page

根据web标准编写您的页面有助于改善您的网站品质。

HTML 标准

XHTML 是最新的 HTML 标准，是用 XML 重新表达的 HTML 4.01。

根据 HTML 4.01 编写页面可使您的站点尽可能地接近 XHTML 标准。

阅读更多有关 XHTML 的内容。

CSS 标准

对于高品质的站点来说，使用层叠样式表（CSS）是将内容与样式分离的首选方式。通过使用 CSS，您能够在一个单独的文档中存储有关页面样式的所有信息。

所有现代的 web 浏览器均支持 CSS 1 和 CSS 2 标准。

对于不同的浏览器，使用 CSS 都可以改进网站的品质，并提高可读性。同时还可以极大地减少您的网站开发成本。

阅读更多关于 CSS 的内容。

Web 验证

web 验证工具是一种软件程序，可根据 web 标准对您的网站进行检查。

当您使用验证工具检查过HTML, XHTML 或 CSS 文档之后，验证器就会根据您选择的标准返回一系列所发现的错误。通常，验证器会返回所发现错误的行号。

请确保你在发布页面前进行验证成为一种习惯。

阅读更多关于 页面验证 的内容。

WAI - Web Accessibility Initiative

WAI 指的是"Web Accessibility Initiative"，是由 W3C 发起的。

WAI 协调全球的组织通过六项主要的工作领域来提升因特网的可用性：技术、指导方针、工具、教育、研究以及开发。

您能够通过根据 WAI 的指导方针编写的页面，来改善网站的品质，并使得您的站点可用于更多人群（及浏览器）。

您将在本教程稍后的章节学习更多有关 WAI 的内容。

  • Previous Page
  • Next Page


Web 品质 - 国际化

网站品质

  • 教程首页
  • Web 标准
  • HTML 元素
  • 样式表
  • 可读性
  • 易用性
  • 国际化

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Web 品质 - 国际化

  • Previous Page
  • Next Page

网络无国界。

网络无国界

With the Internet follows an absolute requirement to interchange data in a multiplicity of languages, which in turn utilize a bewildering number of characters.

--- H. Alvestrand, Internet工程工作小组 (IETF), 1998年1月。

国际字符集

所有的 W3C 标准（自从1996年），包括 HTML、XHTML 和 XML 都定义了一个名为 Unicode (ISO 10646) 内部的内部字符集。

所有现代 web 浏览器都在原生地使用此字符集。而大多数在 internet 上传输的文档并没有使用这个 Unicode 字符集。

正因如此，Internet 客户（浏览器）与 Internet 服务器 之间必须有一种在通信中一致使用字符集的方法。

对每个文档在用的字符集进行标记，对于提升网站的品质来说至关重要。

请始终在 <head> 元素内 使用下面的的元元素：

<meta http-equiv="Content-Type" content="text/html;charset=X" />

把 X 替换为你所使用的字符集，比如ISO-8859-1、UTF-8 或者 UTF-16。

国际日期

请不要使用类似 "04-03-02" 的日期格式。

上面的日期可以表示为2004年3月2日，或者2002年3月4日，亦或者2002年4月3日。

国际标准化 (ISO) 为日期定义的国际标准格式是 "yyyy-mm-dd"，yyyy 是年，mm 是月，dd 是日。

如果您使用了 ISO 的格式，那么大多数访问者都能明白你的日期。

  • Previous Page
  • Next Page


Web 品质 - 可读性

网站品质

  • 教程首页
  • Web 标准
  • HTML 元素
  • 样式表
  • 可读性
  • 易用性
  • 国际化

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Web 品质 - 可读性

  • Previous Page
  • Next Page

正确使用字体和颜色可使您的网站更易阅读。

留意颜色的对比

对于视力不太好的人或者对于不太好的显示设备来说，黑地白字或者白底黑字是最佳的。

在亮色背景上的灰色文字，对比度是很差的：

在暗色背景上的灰色文字，其对比度同样很差：

某些搭配 - 比如黑色和红色，黑色和蓝色，黄色和绿色 - 都会使人产生视觉疲劳：

这些搭配还是不错的：

留意字母的间距

对于视力比较弱的读者，比较近的字母间距会带有不小的阅读困难。

字母间距适中的文本就比较容易阅读了。

留意行间距

适中的行间距易于阅读，反之，行间距太小则难以阅读：

避免奇特的字体

本文中的字体是很适合阅读的。

但是下面的字体就不同了：

尽量少用斜体

普通字体易于阅读。斜体字往往难以阅读。

  • Previous Page
  • Next Page


Web 品质 - 易用性 (WAI)

网站品质

  • 教程首页
  • Web 标准
  • HTML 元素
  • 样式表
  • 可读性
  • 易用性
  • 国际化

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Web 品质 - 易用性 (WAI)

  • Previous Page
  • Next Page

能够被残障人士使用的网站才能称得上一个易用的（易访问的）网站。

残障人士指的是那些带有残疾或者身体不健康的用户。

Web Accessibility Initiative - WAI

WAI （由 W3C 在1997年发起）是一系列计划供 web 开发者、创作者以及设计者使用的指导方针 - 关于如何使内容对残障人士更易用。

这些指导方针的目标是易用性（accessibility），但是也有助于使 web 内容可用于更多的浏览器（语音浏览器、移动电话、手持设备），以及更多工作于困难环境的用户（非手持式的、强光、黑暗、弱视、噪音等）。

WAI 对您的网站来说很重要吗？

是的。

每天都有百万计的残障人士在网上冲浪，并且甚至超过百万计的人们正在使用着不良的浏览器设备，或者工作在困难的环境当中。

假如您的网站缺乏诸如可调节字体尺寸、带有文本描述的图形以及便捷的导航，那些人们就无法访问您的信息。

事实上：您的网站剥夺了这些人的权利。

增强网站易用性的理由还有：

  • 可提升网站的美誉度和形象
  • 可提升户满意度
  • 可增加访问者的数量
  • 可增加访问者在站点的停留时间
  • 可增加访问者的回访数量
  • 可同样为无残疾人士增加可用性
  • 可为关闭图形功能的访问者增加可用性
  • 可为使用老式设备的人群增加可用性
  • 可使您的网站为增长速度最快的人群提供服务：老年人群

使用可调节的字体尺寸

请使用相对的字体尺寸，这样用户就能够使用浏览器菜单来改变默认的字体尺寸。

使用 "alt" 属性

alt 属性允许你为图像（也可以为其它的元素）提供一条相对应的文字。

实例：

<img src="images/bana.jpg" alt="Banana" />

有时候浏览器会无法显示图像。具体的原因有：

  • 用户关闭了图像显示
  • 浏览器是不支持图形显示的迷你浏览器
  • 浏览器是语音浏览器（供盲人和弱视人群使用）

如果您使用了 alt 属性，那么浏览器至少可以显示或读出有关图像的描述。

  • Previous Page
  • Next Page


Web 品质 - 重要的 HTML 元素

网站品质

  • 教程首页
  • Web 标准
  • HTML 元素
  • 样式表
  • 可读性
  • 易用性
  • 国际化

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Web 品质 - 重要的 HTML 元素

  • Previous Page
  • Next Page

对于提升 web 品质，<DOCTYPE>、<title> 以及 <h1> 都是重要的标签。

<DOCTYPE> 元素

Doctype means a "document type declaration" (DTD).

所有的 HTML 和 XHTML 页面都应当使用 <Doctype> 元素来定义遵照何种 HTML 版本。

doctype 定义了您正在使用的 HTML 版本，并为浏览器提供重要的信息以便其更快速一致地呈现您的页面。

文档类型声明同时也使验证软件可以对页面的语法进行检查：

HTML 4.01 Strict, Transitional, Frameset

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd">

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN"
"http://www.w3.org/TR/html4/frameset.dtd">

XHTML 1.0 Strict, Transitional, Frameset

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Frameset//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-frameset.dtd">

XHTML 1.1 DTD

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN"
"http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">

参阅： HTML <!DOCTYPE> 标签

<title> 元素

<title> 元素是最重要的 HTML 元素之一。它的主要功能是描述网页的内容。

即使标题不是网页的一个可见的部分，它对于提升网站的品质依然是重要的，这是因为它在以下位置都是可见的：

  • 搜索引擎列表
  • 窗口的标题栏
  • 用户的书签中

标题应当尽可能地短，并具有可描述性。

当某个用户在 internet 上搜索网站时，大部分搜索引擎都会在搜索结果中显示出网站的标题。请确保标题与网页的内容是吻合的。这样的话用户有更多的可能通过点击这些链接来访问到你的网站。

当用户访问您的网站时，在窗口的标题栏中标题是可见的。请确保即使窗口被最小化，标题同样能起到描述网站内容的作用。

在用户访问你的网站之后，网页的标题会存储于历史文件夹（用户甚至会把网页收藏到他的收藏夹中）。为了后续的成功访问，同样请确保标题可以清楚地描述您的网站。

优秀的标题：

<title>HTML 教程</title>
<title>XML 简介</title>

差劲的标题：

<title>简介</title>
<title>章节 1</title>
<title>W3School 拥有一整套组织良好、易于理解的 HTML、CSS、JavaScript、
DHTML、XML、XHTML、WAP、ASP、SQL 教程，并包含非常多实例和源代码。</title>

参阅： HTML <title> 标签

<h1> 元素

<h1> 元素用来描述网页中最上层的标题。

由于一些浏览器会默认地把 <h1> 元素显示为很大的字体，因此会有一些 web 开发者使用 <h2> 元素代替 <h1> 元素来显示最上层的标题。这样做不会对读者产生影响，但会使那些试图“理解网页结构”的搜索引擎和其他软件感到迷惑。

请确保把 <h1> 用于最顶层的标题，<h1> 和 <h2> 用于较低的层级。

可以试着根据此模版来构造您的网页：

如果您不喜欢默认的标题字体尺寸，可以使用样式或样式表来改变。

参阅： HTML <h1> - <h6> 标签

  • Previous Page
  • Next Page


网站品质

网站品质

  • 教程首页
  • Web 标准
  • HTML 元素
  • 样式表
  • 可读性
  • 易用性
  • 国际化

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

网站品质

  • Next Page

在本教程中，您将学到如何将您的网站质量提升至最高。

您将学习使用最新的 WEB 标准。

您还将学习如何使网站的易用性更强、更易读。

内容目录

网站品质 - 标准
本章内容：最重要的质量标准。
网站品质 - HTML 元素
本章内容：最重要的HTML元素。
网站品质 - 样式表
本章内容：最重要的 CSS 元素。
网站品质 - 可读性
本章内容：如何确保站点内容更易读。
网站品质 - 易用性
本章内容：如何确保您的网页对于大多数用户和浏览器具有更强的易用性和适用性。
网站品质 - 国际化
本章内容：关于国际化的不同的品质问题。
  • Next Page


ASP 测验

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

ASP 测验

1 . ASP指的是？

  • A Server Page
  • Active Standard Pages
  • Active Server Pages
  • All Standard Pages

开始时间：28/01/2009 16:07:49

结束时间：28/01/2009 16:27:49

已用时间：0分钟


CSS 测验

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 测验

1 . CSS 指的是？

  • Computer Style Sheets
  • Cascading Style Sheets
  • Creative Style Sheets
  • Colorful Style Sheets

开始时间：28/01/2009 16:07:49

结束时间：28/01/2009 16:27:49

已用时间：0分钟


HTML 测验

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 测验

1 . HTML指的是？

  • 超文本标记语言（Hyper Text Markup Language）
  • 家庭工具标记语言（Home Tool Markup Language）
  • 超链接和文本标记语言（Hyperlinks and Text Markup Language）

开始时间：28/01/2009 16:07:49

结束时间：28/01/2009 16:27:49

已用时间：0分钟


JS 测验

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JS 测验

1 . 我们可以在下列哪个HTML元素中放置javascript代码？

  • <script>
  • <javascript>
  • <js>
  • <scripting>

开始时间：28/01/2009 16:07:49

结束时间：28/01/2009 16:27:49

已用时间：0分钟


SQL 测验

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL 测验

1 . SQL指的是？

  • Strong Question Language
  • Structured Question Language
  • Structured Query Language

开始时间：28/01/2009 16:07:49

结束时间：28/01/2009 16:27:49

已用时间：0分钟


XHTML 测验

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XHTML 测验

1 . XHTML指的是？

  • EXtensible HyperText Markup Language
  • EXtensible HyperText Marking Language
  • EXtreme HyperText Markup Language
  • EXtra Hyperlinks and Text Markup Language

开始时间：28/01/2009 16:07:49

结束时间：28/01/2009 16:27:49

已用时间：0分钟


XML 测验

HTML基础教程

  • HTML 教程
  • HTML 简介
  • HTML 元素
  • HTML 标签
  • HTML 属性
  • HTML 格式化
  • HTML 实体
  • HTML 链接
  • HTML 框架
  • HTML 表格
  • HTML 列表
  • HTML 表单
  • HTML 图像
  • HTML 背景
  • HTML 颜色
  • HTML 颜色值
  • HTML 颜色名
  • HTML 速查手册

HTML高级教程

  • HTML 布局
  • HTML 字体
  • HTML 4.0
  • HTML 样式
  • HTML 头部
  • HTML 元信息
  • HTML URL
  • HTML 脚本
  • HTML 属性
  • HTML 事件
  • HTML 网页服务器
  • HTML 摘要

实例/测验

  • HTML 实例
  • HTML 测验

参考手册

  • HTML 标签列表
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML 测验

1 . XML指的是？

  • Example Markup Language
  • X-Markup Language
  • eXtensible Markup Language
  • eXtra Modern Link

开始时间：28/01/2009 16:07:49

结束时间：28/01/2009 16:27:49

已用时间：0分钟


OWL 简介

RDF 教程

  • RDF 首页
  • RDF 简介
  • RDF 规则
  • RDF 实例
  • RDF 元素
  • RDF 容器
  • RDF 集合
  • RDF Schema
  • RDF 都柏林核心
  • RDF OWL

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

OWL 简介

  • Previous Page
  • Next Page

OWL 是一门供处理 web 信息的语言。

在学习之前应具备的基础知识

在您学习 OWL 之前，应当对 XML、XML 命名空间以及 RDF 有基本的了解。

如果首先学习这些项目，请访问：

W3School 的 XML 教程 和 RDF 教程。

什么是 OWL？

  • OWL 指的是 web 本体语言
  • OWL 构建在 RDF 的顶端之上
  • OWL 用于处理 web 上的信息
  • OWL 被设计为供计算机进行解释
  • OWL 不是被设计为供人类进行阅读的
  • OWL 由 XML 来编写
  • OWL 拥有三种子语言
  • OWL 是一项 web 标准

什么是本体？

本体”这个术语来自于哲学，它是研究世界上的各种实体以及他们是怎么关联的科学。

对于 web，本体则关于对 web 信息及 web 信息之间的关系的精确描述。

Why OWL?

OWL 是“语义网远景”的组成部分 - 目标是：

  • Web 信息拥有确切的含义
  • Web 信息可被计算机理解并处理
  • 计算机可从 Web 上整合信息

OWL 被设计为供计算机来处理信息

OWL 被设计为提供一种通用的处理 Web 信息的内容的方法（而不是把它显示出来）。

OWL 被设计为由计算机应用程序来读取（而不是被人类）。

OWL 与 RDF 不同

OWL 与 RDF 有很多相似之处，但是较之 RDF， OWL 是一门具有更强机器解释能力的更强大的语言。

与 RDF 相比，OWL 拥有更大的词汇表以及更强大的语言。

OWL 子语言

OWL 有三门子语言：

  • OWL Lite
  • OWL DL (包含 OWL Lite)
  • OWL Full (包含 OWL DL)

OWL 使用 XML 编写

通过使用 XML，OWL 信息可在使用不同类型的操作系统和应用语言的不同类型的计算机之间进行交换。

OWL 实例 （机场）

OWL 资源：http://www.daml.org/2001/10/html/airport-ont

类：Airport

属性：

  • elevation
  • iataCode
  • icaoCode
  • latitude
  • location
  • longitude
  • name

制作所使用：dumpont2.java

OWL 是一个 Web 标准

OWL 于 2004 年 2 月成为一项 W3C 的推荐标准。

W3C 推荐（标准）被业界以及 web 团体奉为 web 标准。W3C推荐标准 是由 W3C 工作组开发并经 W3C 成员评审的稳定规范。

在 w3c 有关 OWL 的文档：http://www.w3.org/2004/OWL/

  • Previous Page
  • Next Page

RDF 参考手册


RDF Schema (RDFS)

RDF 教程

  • RDF 首页
  • RDF 简介
  • RDF 规则
  • RDF 实例
  • RDF 元素
  • RDF 容器
  • RDF 集合
  • RDF Schema
  • RDF 都柏林核心
  • RDF OWL

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RDF Schema (RDFS)

  • Previous Page
  • Next Page

RDF Schema (RDFS) 是对 RDF 的一种扩展。

RDF Schema 和 应用程序的类

RDF 通过类、属性和值来描述资源。

此外，RDF 还需要一种定义应用程序专业的类和属性的方法。应用程序专用的类和属性必须使用对 RDF 的扩展来定义。

RDF Schema 就是这样一种扩展。

RDF Schema (RDFS)

RDF Schema 不提供实际的应用程序专用的类和属性，而是提供了描述应用程序专用的类和属性的框架。

RDF Schema 中的类与面向对象编程语言中的类非常相似。这就使得资源能够作为类的实例和类的子类来被定义。

RDFS 实例

下面的实例演示了 RDFS 的能力的某些方面：

<?xml version="1.0"?>

<rdf:RDF
xmlns:rdf= "http://www.w3.org/1999/02/22-rdf-syntax-ns#"
xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
xml:base=  "http://www.animals.fake/animals#">

<rdf:Description rdf:ID="animal">
  <rdf:type
   rdf:resource="http://www.w3.org/2000/01/rdf-schema#Class"/>
</rdf:Description>

<rdf:Description rdf:ID="horse">
  <rdf:type
   rdf:resource="http://www.w3.org/2000/01/rdf-schema#Class"/>
  <rdfs:subClassOf rdf:resource="#animal"/>
</rdf:Description>

</rdf:RDF>

在上面的例子中，资源 "horse" 是类 "animal" 的子类。

简写的例子

由于一个 RDFS 类就是一个 RDF 资源，我们可以通过使用 rdfs:Class 取代 rdf:Description，并去掉 rdf:type 信息，来把上面的例子简写一下：

<?xml version="1.0"?>

<rdf:RDF
xmlns:rdf= "http://www.w3.org/1999/02/22-rdf-syntax-ns#"
xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
xml:base=  "http://www.animals.fake/animals#">

<rdfs:Class rdf:ID="animal" />

<rdfs:Class rdf:ID="horse">
  <rdfs:subClassOf rdf:resource="#animal"/>
</rdfs:Class>

</rdf:RDF>

就是这样的！

  • Previous Page
  • Next Page

RDF 参考手册


RDF 参考手册

RDF 教程

  • RDF 首页
  • RDF 简介
  • RDF 规则
  • RDF 实例
  • RDF 元素
  • RDF 容器
  • RDF 集合
  • RDF Schema
  • RDF 都柏林核心
  • RDF OWL

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RDF 简介

  • Next Page

RDF 命名空间

RDF 命名空间 (xmlns:rdf)：

http://www.w3.org/1999/02/22-rdf-syntax-ns#

RDFS 命名空间 (xmlns:rdfs )：

http://www.w3.org/2000/01/rdf-schema#

RDF 扩展名和 Mime 类型

RDF 文件的推荐扩展名是 *.rdf。不过，*.xml 常用于提供对老式 XML 解析器的兼容性。

已注册的 MIME 类型是 "application/rdf+xml"。

RDFS / RDF 类

Element | Class of | Subclass of
rdfs:Class | All classes |
rdfs:Datatype | Data types | Class
rdfs:Resource | All resources | Class
rdfs:Container | Containers | Resource
rdfs:Literal | Literal values (text and numbers) | Resource
rdf:List | Lists | Resource
rdf:Property | Properties | Resource
rdf:Statement | Statements | Resource
rdf:Alt | Containers of alternatives | Container
rdf:Bag | Unordered containers | Container
rdf:Seq | Ordered containers | Container
rdfs:ContainerMembershipProperty | Container membership properties | Property
rdf:XMLLiteral | XML literal values | Literal

RDFS / RDF 属性

Element | Domain | Range | Description
rdfs:domain | Property | Class | The domain of the resource
rdfs:range | Property | Class | The range of the resource
rdfs:subPropertyOf | Property | Property | The property is a sub property of a property
rdfs:subClassOf | Class | Class | The resource is a subclass of a class
rdfs:comment | Resource | Literal | The human readable description of the resource
rdfs:label | Resource | Literal | The human readable label (name) of the resource
rdfs:isDefinedBy | Resource | Resource | The definition of the resource
rdfs:seeAlso | Resource | Resource | The additional information about the resource
rdfs:member | Resource | Resource | The member of the resource
rdf:first | List | Resource |
rdf:rest | List | List |
rdf:subject | Statement | Resource | The subject of the resource in an RDF Statement
rdf:predicate | Statement | Resource | The predicate of the resource in an RDF Statement
rdf:object | Statement | Resource | The object of the resource in an RDF Statement
rdf:value | Resource | Resource | The property used for values
rdf:type | Resource | Class | The resource is an instance of a class

RDF 属性

Element | Domain | Range | Description
rdf:about |  |  | Defines the resource being described
rdf:Description |  |  | Container for the description of a resource
rdf:resource |  |  | Defines a resource to identify a property
rdf:datatype |  |  | Defines the data type of an element
rdf:ID |  |  | Defines the ID of an element
rdf:li |  |  | Defines a list
rdf:_n |  |  | Defines a node
rdf:nodeID |  |  | Defines the ID of an element node
rdf:parseType |  |  | Defines how an element should be parsed
rdf:RDF |  |  | The root of an RDF document
xml:base |  |  | Defines the XML base
xml:lang |  |  | Defines the language of the element content
rdf:aboutEach |  |  | (removed)
rdf:aboutEachPrefix |  |  | (removed)
rdf:bagID |  |  | (removed)
  • Next Page

RDF 参考手册


RDF 都柏林核心元数据倡议

RDF 教程

  • RDF 首页
  • RDF 简介
  • RDF 规则
  • RDF 实例
  • RDF 元素
  • RDF 容器
  • RDF 集合
  • RDF Schema
  • RDF 都柏林核心
  • RDF OWL

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RDF 都柏林核心元数据倡议

  • Previous Page
  • Next Page

都柏林核心元数据倡议 (DCMI) 已创建了一些供描述文档的预定义属性。

Dublin 核心

RDF 是元数据（关于数据的数据）。RDF 被用于描述信息资源。

都柏林核心是一套供描述文档的预定义属性。

第一份都柏林核心属性是于1995年 在俄亥俄州的都柏林的元数据工作组被定义的，目前由都柏林元数据倡议来维护。

属性 | 定义
Contributor | 一个负责为资源内容作出贡献的实体(如作者)。
Coverage | 资源内容的氛围或作用域
Creator | 一个主要负责创建资源内容的实体。
Format | 物理或数字的资源表现形式。
Date | 在资源生命周期中某事件的日期。
Description | 对资源内容的说明。
Identifier | 一个对在给定上下文中的资源的明确引用
Language | 资源智力内容所用的语言。
Publisher | 一个负责使得资源内容可用的实体
Relation | 一个对某个相关资源的引用
Rights | 有关保留在资源之内和之上的权利的信息
Source | 一个对作为目前资源的来源的资源引用。
Subject | 一个资源内容的主题
Title | 一个给资源起的名称
Type | 资源内容的种类或类型。

通过浏览上面这个表格，我们可以发现 RDF 是非常适合表示都柏林核心信息的。

RDF 实例

下面的例子演示了都柏林核心属性在一个 RDF 文档中的使用：

<?xml version="1.0"?>

<rdf:RDF
xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
xmlns:dc= "http://purl.org/dc/elements/1.1/">

<rdf:Description rdf:about="http://www.w3school.com.cn">
  <dc:title>D-Lib Program</dc:title>
  <dc:description>W3School - Free tutorial</dc:description>
  <dc:publisher>w3school Data as</dc:publisher>
  <dc:date>2008-01-01</dc:date>
  <dc:type>Web Development</dc:type>
  <dc:format>text/html</dc:format>
  <dc:language>en</dc:language>
</rdf:Description>

</rdf:RDF>
  • Previous Page
  • Next Page

RDF 参考手册


RDF 规则

RDF 教程

  • RDF 首页
  • RDF 简介
  • RDF 规则
  • RDF 实例
  • RDF 元素
  • RDF 容器
  • RDF 集合
  • RDF Schema
  • RDF 都柏林核心
  • RDF OWL

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RDF 规则

  • Previous Page
  • Next Page

RDF 使用 Web 标识符 (URIs) 来标识资源。

RDF 使用属性和属性值来描述资源。

RDF 资源、属性和属性值

RDF 使用 Web 标识符来标识事物，并通过属性和属性值来描述资源。

对资源、属性和属性值的解释：

  • 资源是可拥有 URI 的任何事物，比如 "http://www.w3school.com.cn/rdf"
  • 属性是拥有名称的资源，比如 "author" 或 "homepage"
  • 属性值是某个属性的值，比如 "David" 或 "http://www.w3school.com.cn" （请注意一个属性值可以是另外一个资源）

下面的 RDF 文档可描述资源 "http://www.w3school.com.cn/rdf"：

<?xml version="1.0"?>

<RDF>
  <Description about="http://www.w3school.com.cn/RDF">
    <author>David</author>
    <homepage>http://www.w3school.com.cn</homepage>
  </Description>
</RDF>

提示：上面是一个简化的例子。命名空间被忽略了。

RDF 陈述

资源、属性和属性值的组合可形成一个陈述（被称为陈述的主体、谓语和客体）。

请看一些陈述的具体例子，来加深理解：

陈述："The author of http://www.w3school.com.cn/rdf is David."

  • 陈述的主体是：http://www.w3school.com.cn/rdf
  • 谓语是：author
  • 客体是：David

陈述："The homepage of http://www.w3school.com.cn/rdf is http://www.w3school.com.cn".

  • 陈述的主体是：http://www.w3school.com.cn/rdf
  • 谓语是：homepage
  • 客体是：http://www.w3school.com.cn
  • Previous Page
  • Next Page

RDF 参考手册


RDF 集合

RDF 教程

  • RDF 首页
  • RDF 简介
  • RDF 规则
  • RDF 实例
  • RDF 元素
  • RDF 容器
  • RDF 集合
  • RDF Schema
  • RDF 都柏林核心
  • RDF OWL

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RDF 集合

  • Previous Page
  • Next Page

RDF 集合用于描述仅包含指定成员的组。

rdf:parseType="Collection" 属性

正如在前面的章节所看到的，我们无法关闭一个容易。容器规定了所包含的资源为成员 - 它没有规定其他的成员是不被允许的。

RDF 集合用于描述仅包含指定成员的组。

集合是通过属性 rdf:parseType="Collection" 来描述的。

实例

<?xml version="1.0"?>

<rdf:RDF
xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
xmlns:cd="http://recshop.fake/cd#">

<rdf:Description
rdf:about="http://recshop.fake/cd/Beatles">
<cd:artist rdf:parseType="Collection">
<rdf:Description rdf:about="http://recshop.fake/cd/Beatles/George"/>
<rdf:Description rdf:about="http://recshop.fake/cd/Beatles/John"/>
<rdf:Description rdf:about="http://recshop.fake/cd/Beatles/Paul"/>
<rdf:Description rdf:about="http://recshop.fake/cd/Beatles/Ringo"/>
</cd:artist>
</rdf:Description>

</rdf:RDF>
  • Previous Page
  • Next Page

RDF 参考手册


RDF 简介

RDF 教程

  • RDF 首页
  • RDF 简介
  • RDF 规则
  • RDF 实例
  • RDF 元素
  • RDF 容器
  • RDF 集合
  • RDF Schema
  • RDF 都柏林核心
  • RDF OWL

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RDF 简介

  • Previous Page
  • Next Page

资源描述框架（RDF）是用于描述网络资源的 W3C 标准，比如网页的标题、作者、修改日期、内容以及版权信息。

您应当具备的基础知识

在继续学习之前，您需要对下面的知识有基本的了解：

  • HTML
  • XHTML
  • XML
  • XML 命名空间

如果您希望首先学习这些项目，请访问我们的 首页。

什么是 RDF？

  • RDF 指资源描述框架（Resource Description Framework）
  • RDF 是一个用于描述 Web 上的资源的框架
  • RDF 提供了针对数据的模型以及语法，这样独立的团体们就可以交换和使用它
  • RDF 被设计为可被计算机阅读和理解
  • RDF 被设计的目的不是为了向人们显示出来
  • RDF 使用 XML 编写
  • RDF 是 W3C 语义网络活动的组成部分
  • RDF 是一个 W3C 推荐标准

RDF - 应用举例

  • 描述购物项目的属性，比如价格以及可用性
  • 描述 Web 事件的时间表
  • 描述有关网页的信息，比如内容、作者以及被创建和修改的日期
  • 描述网络图片的内容和等级
  • 描述针对搜索引擎的内容
  • 描述电子图书馆

RDF 被设计为可被计算机读取

RDF 被设计为提供一种描述信息的通用方法，这样就可以被计算机应用程序读取并理解。

RDF 描述不是被设计用来在网络上显示的。

RDF 使用 XML 编写

RDF 文档使用 XML 编写。被 RDF 使用的 XML 语言被称为 RDF/XML。

通过使用 XML，RDF 信息可以轻易地在使用不同类型的操作系统和应用语言的计算机之间进行交换。

RDF 和语义网

RDF 语言是 W3C 的语义网活动的组成部分。W3C 的“语义网远景 (Semantic Web Vision)”的目标是：

  • Web 信息拥有确切的含义
  • Web 信息可被计算机理解并处理
  • 计算机可从 Web 上整合信息

RDF 是 W3C 标准

RDF 在 2004 年 2 月成为 W3C 标准。

W3C 推荐（标准）被业界以及 web 团体奉为 web 标准。W3C推荐标准 是由 W3C 工作组开发并经 W3C 成员评审的稳定规范。

可以通过此链接找到官方的 W3C 推荐标准。

http://www.w3.org/RDF/

  • Previous Page
  • Next Page

RDF 参考手册


RDF 教程

RDF 教程

  • RDF 首页
  • RDF 简介
  • RDF 规则
  • RDF 实例
  • RDF 元素
  • RDF 容器
  • RDF 集合
  • RDF Schema
  • RDF 都柏林核心
  • RDF OWL

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RDF 教程

  • Next Page

资源描述框架 (RDF) 是描述网络中资源的 W3C 标准。

RDF 是一个框架，用来描述网络资源，诸如网页的标题、作者、修改日期、内容以及版权信息等。

开始学习 RDF ！

内容目录

RDF 简介
本章讲解 RDF 的概念和作用。
RDF 规则
本章讲解在 RDF 中被用到的语法和术语。
RDF 实例
本章讲解一个 RDF 实例。
RDF 元素
本章讲解 RDF 的主要元素: <RDF> 和 <Description>。
RDF 容器
RDF 容器用于描述事物的分组。本章讲解 RDF 的容器元素: <Bag>、<Seq> 和 <Alt>。
RDF 集合
RDF 集合被用来描述仅包含指定成员的组。本章讲解如何描述集合。
RDF Schema
本章讲解 RDF Schema 对 RDF 的扩展。
RDF 都柏林核心
本章内容关于 DCMI，DCMI 提供描述网络对象的属性。
RDF OWL
本章阐述构建于 RDF 之上的 OWL 语言。
RDF 参考手册
本章包含了完整的 RDF 参考手册。
  • Next Page

RDF 参考手册


RDF 容器元素

RDF 教程

  • RDF 首页
  • RDF 简介
  • RDF 规则
  • RDF 实例
  • RDF 元素
  • RDF 容器
  • RDF 集合
  • RDF Schema
  • RDF 都柏林核心
  • RDF OWL

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RDF 容器元素

  • Previous Page
  • Next Page

RDF 容器用于描述一组事物。举个例子，把某本书的作者列在一起。

下面的 RDF 元素用于描述这些的组：<Bag>、<Seq> 以及 <Alt>。

<rdf:Bag> 元素

<rdf:Bag> 元素用于描述一个规定为无序的值的列表。

<rdf:Bag> 元素可包含重复的值。

实例

<?xml version="1.0"?>

<rdf:RDF
xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
xmlns:cd="http://www.recshop.fake/cd#">

<rdf:Description
 rdf:about="http://www.recshop.fake/cd/Beatles">
 <cd:artist>
   <rdf:Bag>
     <rdf:li>John</rdf:li>
     <rdf:li>Paul</rdf:li>
     <rdf:li>George</rdf:li>
     <rdf:li>Ringo</rdf:li>
   </rdf:Bag>
  </cd:artist>
</rdf:Description>

</rdf:RDF>

<rdf:Seq> 元素

<rdf:Seq> 元素用于描述一个规定为有序的值的列表（比如一个字母顺序的排序）。

<rdf:Bag> 元素可包含重复的值。

实例

<?xml version="1.0"?>

<rdf:RDF
xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
xmlns:cd="http://www.recshop.fake/cd#">

<rdf:Description
 rdf:about="http://www.recshop.fake/cd/Beatles">
 <cd:artist>
   <rdf:Seq>
     <rdf:li>George</rdf:li>
     <rdf:li>John</rdf:li>
     <rdf:li>Paul</rdf:li>
     <rdf:li>Ringo</rdf:li>
   </rdf:Seq>
  </cd:artist>
</rdf:Description>

</rdf:RDF>

<rdf:Alt> 元素

<rdf:Alt> 元素用于一个可替换的值的列表（用户仅可选择这些值的其中之一）。

实例

<?xml version="1.0"?>

<rdf:RDF
xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
xmlns:cd="http://www.recshop.fake/cd#">

<rdf:Description
 rdf:about="http://www.recshop.fake/cd/Beatles">
 <cd:format>
   <rdf:Alt>
     <rdf:li>CD</rdf:li>
     <rdf:li>Record</rdf:li>
     <rdf:li>Tape</rdf:li>
   </rdf:Alt>
  </cd:format>
</rdf:Description>

</rdf:RDF>

RDF 术语

在上面的例子中，我们在描述容器元素时已经讨论了“值的列表”。在 RDF 中，这些“值的列表”被称为成员（members）。

因此，我们可以这么说：

  • 一个容器是一个包含事物的资源
  • 被包含的事物被称为成员（不能称为“值的列表”）。
  • Previous Page
  • Next Page

RDF 参考手册


RDF 实例

RDF 教程

  • RDF 首页
  • RDF 简介
  • RDF 规则
  • RDF 实例
  • RDF 元素
  • RDF 容器
  • RDF 集合
  • RDF Schema
  • RDF 都柏林核心
  • RDF OWL

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RDF 实例

  • Previous Page
  • Next Page

RDF 实例

这是一个 CD 列表的其中几行:

Title | Artist | Country | Company | Price | Year
Empire Burlesque | Bob Dylan | USA | Columbia | 10.90 | 1985
Hide your heart | Bonnie Tyler | UK | CBS Records | 9.90 | 1988
... |  |  |  |  |

这是一个 RDF 文档的其中几行：

<?xml version="1.0"?>

<rdf:RDF
xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
xmlns:cd="http://www.recshop.fake/cd#">

<rdf:Description
 rdf:about="http://www.recshop.fake/cd/Empire Burlesque">
  <cd:artist>Bob Dylan</cd:artist>
  <cd:country>USA</cd:country>
  <cd:company>Columbia</cd:company>
  <cd:price>10.90</cd:price>
  <cd:year>1985</cd:year>
</rdf:Description>

<rdf:Description
 rdf:about="http://www.recshop.fake/cd/Hide your heart">
  <cd:artist>Bonnie Tyler</cd:artist>
  <cd:country>UK</cd:country>
  <cd:company>CBS Records</cd:company>
  <cd:price>9.90</cd:price>
  <cd:year>1988</cd:year>
</rdf:Description>
.
.
.
</rdf:RDF>

此 RDF 文档的第一行是 XML 声明。这个 XML 声明之后是 RDF 文档的根元素：<rdf:RDF>。

xmlns:rdf 命名空间，规定了带有前缀 rdf 的元素来自命名空间 "http://www.w3.org/1999/02/22-rdf-syntax-ns#"。

xmlns:cd 命名空间，规定了带有前缀 cd 的元素来自命名空间 "http://www.recshop.fake/cd#"。

<rdf:Description> 元素包含了对被 rdf:about 属性标识的资源的描述。

元素：<cd:artist>、<cd:country>、<cd:company> 等是此资源的属性。

RDF 在线验证器

W3C 的 RDF 验证服务在您学习 RDF 时是很有帮助的。在此您可对 RDF 文件进行试验。

RDF 在线验证器可解析您的 RDF 文档，检查其中的语法，并为您的 RDF 文档生成表格和图形视图。

把下面这个例子拷贝粘贴到 W3C 的 RDF 验证器：

<?xml version="1.0"?>

<rdf:RDF
xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
xmlns:si="http://www.recshop.fake/siteinfo#">
  <rdf:Description rdf:about="http://www.w3school.com.cn/RDF">
    <si:author>David</si:author>
    <si:homepage>http://www.w3school.com.cn</si:homepage>
  </rdf:Description>
</rdf:RDF>

在您对上面的例子进行解析后，结果将是类似这样的。

  • Previous Page
  • Next Page

RDF 参考手册


RDF 主要元素

RDF 教程

  • RDF 首页
  • RDF 简介
  • RDF 规则
  • RDF 实例
  • RDF 元素
  • RDF 容器
  • RDF 集合
  • RDF Schema
  • RDF 都柏林核心
  • RDF OWL

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RDF 主要元素

  • Previous Page
  • Next Page

RDF 的主要元素是 <RDF> 以及可表示某个资源的 <Description> 元素。

<rdf:RDF> 元素

<rdf:RDF> 是一个 RDF 文档的根源苏。它把 XML 文档定义为一个 RDF 文档。它也包含了对 RDF 命名空间的引用：

<?xml version="1.0"?>

<rdf:RDF
xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
.
. Description goes here
.
</rdf:RDF>

<rdf:Description> 元素

<rdf:Description> 元素可通过 about 属性标识一个资源。

<rdf:Description> 元素可包含描述资源的那些元素：

<?xml version="1.0"?>

<rdf:RDF
xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
xmlns:cd="http://www.recshop.fake/cd#">

<rdf:Description
 rdf:about="http://www.recshop.fake/cd/Empire Burlesque">
  <cd:artist>Bob Dylan</cd:artist>
  <cd:country>USA</cd:country>
  <cd:company>Columbia</cd:company>
  <cd:price>10.90</cd:price>
  <cd:year>1985</cd:year>
</rdf:Description>

</rdf:RDF>

artist、country、company、price 以及 year 这些元素被定义在命名空间 http://www.recshop.fake/cd# 中。此命名空间在 RDF 之外（并非 RDF 的组成部分）。RDF 仅仅定义了这个框架。而 artist、country、company、price 以及 year 这些元素必须被其他人（公司、组织或个人等）进行定义。

属性（property）来定义属性（attribute）

属性元素（property elements）也可作为属性（attributes）来被定义（取代元素）：

<?xml version="1.0"?>

<rdf:RDF
xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
xmlns:cd="http://www.recshop.fake/cd#">

<rdf:Description
 rdf:about="http://www.recshop.fake/cd/Empire Burlesque"
  cd:artist="Bob Dylan"  cd:country="USA"
  cd:company="Columbia"  cd:price="10.90"
  cd:year="1985" />

</rdf:RDF>

属性定义资源

属性元素（property elements）也可被作为资源（resources）来被定义：

在上面的例子中，属性 artist 没有值，但是却引用了一个对包含有关艺术家的信息的资源。

<?xml version="1.0"?>

<rdf:RDF
xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
xmlns:cd="http://www.recshop.fake/cd#">

<rdf:Description
 rdf:about="http://www.recshop.fake/cd/Empire Burlesque">
  <cd:artist rdf:resource="http://www.recshop.fake/cd/dylan" />
  .
  .
  .
  .
</rdf:Description>

</rdf:RDF>
  • Previous Page
  • Next Page

RDF 参考手册


 Resource The class resource, everything. Class The class of classes. subClassOf The subject is a subclass of a class. subPropertyOf The subject is a subproperty of a property. comment A description of the subject resource. label A human-readable name for the subject. domain A domain of the subject property. range A range of the subject property. seeAlso Further information about the subject resource. isDefinedBy The defininition of the subject resource. Literal The class of literal values, eg. textual strings and integers. Container The class of RDF containers. ContainerMembershipProperty The class of container membership properties, rdf:_1, rdf:_2, ..., all of which are sub-properties of 'member'. member A member of the subject resource. Datatype The class of RDF datatypes.


 The RDF Vocabulary (RDF) This is the RDF Schema for the RDF vocabulary defined in the RDF namespace. type The subject is an instance of a class. Property The class of RDF properties. Statement The class of RDF statements. subject The subject of the subject RDF statement. predicate The predicate of the subject RDF statement. object The object of the subject RDF statement. Bag The class of unordered containers. Seq The class of ordered containers. Alt The class of containers of alternatives. value Idiomatic property used for structured values. List The class of RDF Lists. nil The empty list, with no items in it. If the rest of a list is nil then the list has no more items in it. first The first item in the subject RDF list. rest The rest of the subject RDF list after the first item. XMLLiteral The class of XML literal values.


RSS <author> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <author> 元素

RSS 参考手册

定义和用法

<author> 元素规定 item 的作者的电子邮件地址。

注释：为了防止垃圾邮件，一些开发者不使用 <author> 元素。

实例

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
    <author>author@w3school.com.cn</author>
  </item>
</channel>

</rss>

RSS 参考手册

RSS 参考手册


RSS <category> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <category> 元素

RSS 参考手册

定义和用法

<category> 元素规定 channel 或 item 所属的一个或多个种类。<category> 元素也可以规定目录中的层级位置（<category> 元素的值是正斜杠分隔的字符串）。

<category> 元素可以使RSS聚合器对站点/文章的目录进行归类群组（基于目录对站点/文章进行分组）。

属性

标签 | 描述
domain | 可选。字符串或 URL，标识分类的分类法。 例子： <category domain="syndic8">IT</category>

实例

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <category>IT/Internet/Web development</category>
  <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
    <category>News</category>
    <category>Tutorial</category>
  </item>
</channel>

</rss>

RSS 参考手册

RSS 参考手册


RSS <channel> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <channel> 元素

  • Previous Page
  • Next Page

RSS 的 <channel> 元素可描述 RSS feed。

RSS <channel> 元素

请看下面这个 RSS 文档：

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
  </item>
</channel>

</rss>

正如前面提到的，<channel> 元素可描述 RSS feed，而拥有三个必需的子元素：

  • <title> - 定义频道的标题。（比如 w3school 首页）
  • <link> - 定义到达频道的超链接。（比如 www.w3school.com.cn）
  • <description> - 描述此频道（比如免费的网站建设教程）

<channel> 通常包含一个或多个 <item> 元素。每个 <item> 元素可定义 RSS feed 中的一篇文章或 "story"。

此外，还存在若干个可选的 <channel> 的子元素。我们会在后面讲解最重要的几个。

<category> 元素

<category> 子元素用于为 feed 规定种类。

<category> 子元素使 RSS 聚合器基于类别对网站进行分组成为可能。

上面的 RSS 文档的类别可能会是：

<category>Web development</category>

<copyright> 元素

<copyright> 子元素会告知有关版本资料的信息。

上面的 RSS 文档的版本可能会是

<copyright>2006 w3school.com.cn. All rights reserved.</copyright>

<image> 元素

<image> 子元素可在聚合器提供某个 feed 时显示一幅图像。

<image> 有三个必需的子元素：

  • <url> - 定义引用图像的 URL
  • <title> - 定义图像无法被显示时显示的文本
  • <link> - 定义到达提供此频道的网站的超链接

上面的 RSS 文档的图像可能是这样的：

<image>
  <url>http://www.w3school.com.cn/images/logo.gif</url>
  <title>W3School.com.cn</title>
  <link>http://www.w3school.com.cn</link>
</image>

<language> 元素

<language> 子元素用于规定用来编写文档的语言。

<language> 元素使 RSS 聚合器基于语言来对网站进行分组成为可能。

上面的 RSS 文档的语言可能是：

<language>en-us</language>

RSS <channel> 参考手册

元素 | 描述
<category> | 可选的。为 feed 定义所属的一个或多个种类。
<cloud> | 可选的。注册进程，以获得 feed 更新的立即通知。
<copyright> | 可选。告知版权资料。
<description> | 必需的。描述频道。
<docs> | 可选的。规定指向当前 RSS 文件所用格式说明的 URL。
<generator> | 可选的。指定用于生成 feed 的程序。
<image> | 可选的。在聚合器呈现某个 feed 时，显示一个图像。
<language> | 可选的。规定编写 feed 所用的语言。
<lastBuildDate> | 可选的。定义 feed 内容的最后修改日期。
<link> | 必需的。定义指向频道的超链接。
<managingEditor> | 可选的。定义 feed 内容编辑的电子邮件地址。
<pubDate> | 可选的。为 feed 的内容定义最后发布日期。
<rating> | 可选的。feed 的 PICS 级别。
<skipDays> | 可选的。规定忽略 feed 更新的天。
<skipHours> | 可选的。规定忽略 feed 更新的小时。
<textInput> | 可选的。规定应当与 feed 一同显示的文本输入域。
<title> | 必需的。定义频道的标题。
<ttl> | 可选的。指定从 feed 源更新此 feed 之前，feed 可被缓存的分钟数。
<webMaster> | 可选的。定义此 feed 的 web 管理员的电子邮件地址。
  • Previous Page
  • Next Page

RSS 参考手册


RSS <cloud> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <cloud> 元素

RSS 参考手册

定义和用法

<cloud> 元素允许所有进程注册一个 cloud，用于获得频道的更新通知，并为 rss 种子实现一个轻量级的发布订阅协议。

提示和注释

注释：xml-rpc 或 soap 均可实现 cloud。

实例

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <cloud domain="www.w3school.com.cn" port="80" path="/RPC"
  registerProcedure="NotifyMe" protocol="xml-rpc" />
    <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
  </item>
</channel>

</rss>

RSS 参考手册

RSS 参考手册


RSS <comments> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <comments> 元素

RSS 参考手册

定义和用法

<comments> 元素允许一个 item 链接到关于该 item 的注释。

实例

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
    <comments>http://www.w3school.com.cn/rss/comments.asp</comments>
  </item>
</channel>

</rss>

RSS 参考手册

RSS 参考手册


RSS <copyright> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <copyright> 元素

RSS 参考手册

定义和用法

<copyright> 元素用于通知版权资料。

实例

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <copyright>2008 YK investment. All rights reserved.</copyright>
  <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
  </item>
</channel>

</rss>

RSS 参考手册

RSS 参考手册


RSS <docs> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <docs> 元素

RSS 参考手册

定义和用法

<docs> 元素规定指向当前 RSS 文件所用格式说明的 URL。

实例

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <docs>http://blogs.law.harvard.edu/tech/rss</docs>
    <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
  </item>
</channel>

</rss>

RSS 参考手册

RSS 参考手册


RSS <enclosure> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <enclosure> 元素

RSS 参考手册

定义和用法

<enclosure> 元素允许把媒体文件包含在项目中。

属性

属性 | 描述
length | 必需。定义媒体文件的长度（以字节计）。
type | 必需。定义媒体文件的类型。
url | 必需。定义指向该媒体文件的 URL。

实例

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
    <enclosure url="http://www.w3school.com.cn/media/movie.wmv"
    length="856329" type="video/wmv" />
  </item>
</channel>

</rss>

RSS 参考手册

RSS 参考手册


RSS <generator> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <generator> 元素

RSS 参考手册

定义和用法

<generator> 元素规定用于生成该 RSS feed 的程序名称。

提示和注释

注释：在 feed 由自动生成器创建时，通常会使用该元素。

实例

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <generator>Notepad</generator>
    <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
  </item>
</channel>

</rss>

RSS 参考手册

RSS 参考手册


RSS <guid> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <guid> 元素

RSS 参考手册

定义和用法

<guid> 元素为 item 定义一个唯一的标识符。

提示和注释

提示：GUID = Globally Unique Identifier

注释：聚合器必须把 guid 视为字符串。这里没有固定的语法规则。这取决于文档的创建者，来确定字符串的唯一性。

属性

属性 | 描述
isPermaLink | 可选。如果设置为 true，那么阅读器会假定它是指向一个项的永久连接（指向由 <item& 元素描述的所有项目的 URL）。默认值是True。如果将其设置为 false，那么，guid 可能不会被假定为一个 URL。

实例

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
    <guid>http://www.w3school.com.cn/rss/item5803</guid>
  </item>
</channel>

</rss>

RSS 参考手册

RSS 参考手册


RSS <image> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <image> 元素

RSS 参考手册

定义和用法

<image> 元素指定一个图片，用以与频道一起显示。

提示和注释

注释：该图片必须是 GIF、JPEG 或 PNG 类型。

<image> 元素的子元素

标签 | 描述
<description> | 可选。规定图片链接的 HTML 标题属性中的文本。
<height> | 可选。定义图像的高度。默认是 31。最大值是 400。
<link> | 必需。定义提供该频道的网站的超连接。
<title> | 必需。定义当图片不能显示时所显示的替代文本。
<url> | 必需。定义图像的 URL。
<width> | 可选。定义图像的宽度。默认是 88。最大值是 144。

实例

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <image>
    <url>http://www.w3school.com.cn/images/logo.gif</url>
    <title>w3school.com.cn</title>
    <link>http://www.w3school.com.cn</link>
  </image>
  <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
  </item>
</channel>

</rss>

RSS 参考手册

RSS 参考手册


RSS <item> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <item> 元素

  • Previous Page
  • Next Page

每个 <item> 元素可定义 RSS feed 中的一篇文章或 "story"。

<item> 元素

请看下面的 RSS 文档：

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0"><channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
  </item>
</channel></rss>

正如前面提到的，每个 <item> 元素可定义 RSS feed 中的一篇文章或 story"。

<item> 元素拥有三个必需的子元素：

  • <title> - 定义项目的标题。（比如 RSS 教程）
  • <link> - 定义到达项目的超链接。（比如 http://www.w3school.com.cn/rss）
  • <description> - 描述此项目（比如 w3school 的 RSS 教程）

此外，存在若干个 <item> 的可选的子元素，我们会在下面介绍最重要的几个。

<author> 元素

<author> 子元素用于规定一个项目的作者的电子邮件地址。

注释：为了防止垃圾邮件，一些开发者不会使用这个 <author> 元素。

上面的 RSS 文档中项目的作者可能是：

<author>service@w3school.com.cn</author>

<comments> 元素

<comments> 子元素允许把一个项目连接到有关此项目的注释。

上面的 RSS 文档中项目的注释可能这样的：

<comments>http://www.w3school.com.cn/comments</comments>

<enclosure> 元素

<enclosure> 子元素允许将一个媒体文件导入一个项中。

<enclosure> 元素有三个必需的属性：

  • url - 定义指向此媒体文件的 URL
  • length - 定义此媒体文件的长度（字节）
  • type - 定义媒体文件的类型

在上面的 RSS 文档中，被包含在项目中的媒体文件可能是这样的：

<enclosure url="http://www.w3school.com.cn/rss/rss.mp3"
length="5000" type="audio/mpeg" />

RSS <item> 参考手册

元素 | 描述
<author> | 可选的。规定项目作者的电子邮件地址。
<category> | 可选的。定义项目所属的一个或多个类别。
<comments> | 可选的。允许项目连接到有关此项目的注释（文件）。
<description> | 必需的。描述此项目。
<enclosure> | 可选的。允许将一个媒体文件导入一个项中。
<guid> | 可选的。为项目定义一个唯一的标识符。
<link> | 必需的。定义指向此项目的超链接。
<pubDate> | 可选的。定义此项目的最后发布日期。
<source> | 可选的。为此项目指定一个第三方来源。
<title> | 必需的。定义此项目的标题。
  • Previous Page
  • Next Page

RSS 参考手册


RSS <language> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <language> 元素

RSS 参考手册

定义和用法

<language> 元素用于指定编写 RSS 文档时所使用的语言。

提示和注释

提示：<language> 元素可以使聚合器根据语言对站点进行分组。

注释： 标准的语言代码。

实例

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <language>zh-cn</language>
  <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
  </item>
</channel>

</rss>

RSS 参考手册

RSS 参考手册


RSS <lastBuildDate> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <lastBuildDate> 元素

RSS 参考手册

定义和用法

<lastBuildDate> 元素定义 feed 内容的最后修改日期。

实例

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <lastBuildDate>Thu, 27 Apr 2006</lastBuildDate>
  <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
  </item>
</channel>

</rss>

RSS 参考手册

RSS 参考手册


RSS <managingEditor> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <managingEditor> 元素

RSS 参考手册

定义和用法

<managingEditor> 元素定义 feed 内容编辑的电子邮件地址。

实例

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <managingEditor>editor@w3school.com.cn</managingEditor>
  <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
  </item>
</channel>

</rss>

RSS 参考手册

RSS 参考手册


RSS <pubDate> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <pubDate> 元素

RSS 参考手册

定义和用法

<pubDate> 元素为 feed 的内容定义最后发布日期。

实例

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <pubDate>Wed, 18 Jun 2008</pubDate>
  <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
  </item>
</channel>

</rss>

RSS 参考手册

RSS 参考手册


RSS <pubDate> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <pubDate> 元素

RSS 参考手册

定义和用法

<pubDate> 元素定义此项目的最后发布日期。

实例

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
    <pubDate>Wed, 18 Jun 2008</pubDate>
  </item>
</channel>

</rss>

RSS 参考手册

RSS 参考手册


RSS <skipDays> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <skipDays> 元素

RSS 参考手册

定义和用法

<skipDays> 元素规定在那些天，聚合器忽略更新 feed。

提示和注释

提示：最多可以用 7 个 <skipDays> 元素。

实例

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <skipDays>Saturday</skipDays>
  <skipDays>Sunday</skipDays>
  <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
  </item>
</channel>

</rss>

RSS 参考手册

RSS 参考手册


RSS <skipHours> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <skipHours> 元素

RSS 参考手册

定义和用法

<skipHours> 元素规定在那些小时，聚合器忽略更新 feed。

提示和注释

提示：最多可以用 24 个 <skipDays> 元素。

提示：0 表示午夜。

实例

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <skipHours>0</skipHours>
  <skipHours>1</skipHours>
  <skipHours>2</skipHours>
  <skipHours>3</skipHours>
  <skipHours>4</skipHours>
  <skipHours>5</skipHours>
  <skipHours>6</skipHours>
  <skipHours>7</skipHours>
  <skipHours>17</skipHours>
  <skipHours>18</skipHours>
  <skipHours>19</skipHours>
  <skipHours>20</skipHours>
  <skipHours>21</skipHours>
  <skipHours>22</skipHours>
  <skipHours>23</skipHours>
  <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
  </item>
</channel>

</rss>

RSS 参考手册

RSS 参考手册


RSS <source> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <source> 元素

RSS 参考手册

定义和用法

<source> 元素为此项目指定一个第三方来源。

属性

属性 | 描述
url | 必需。指定来源的链接。

实例

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
    <source url="http://www.w3school.com.cn">w3school.com.cn</source>
  </item>
</channel>

</rss>

RSS 参考手册

RSS 参考手册


RSS <textInput> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <textInput> 元素

RSS 参考手册

定义和用法

<textInput> 元素规定应当与 feed 一同显示的文本输入域。

提示和注释

注释：大多数聚合器忽略 <textInput> 元素。

<textInput> 的子元素

标签 | 描述
<description> | 必需。定义对文本输入域的描述。
<name> | 必需。定义在文本输入域中的文本对象的名称。
<link> | 必需。定义处理文本输入的 CGI 脚本的 URL。
<title> | 必需。定义文本输入域中的提交按钮的标注 (label)。

实例

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <textinput>
    <description>Search Google</description>
    <title>Search</title>
    <link>http://www.google.cn/search?</link>
    <name>q</name>
  </textinput>
  <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
  </item>
</channel>

</rss>

RSS 参考手册

RSS 参考手册


RSS <title>、<link> 以及 <description> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <title>、<link> 以及 <description> 元素

RSS 参考手册

定义和用法

<channel> 元素描述 RSS feed，该元素有三个必需的子元素：

  • <title> - 定义频道的标题（例如：w3school 首页）
  • <link> - 定义指向频道的超连接（例如：http://www.w3school.com.cn）
  • <description> - 描述频道（例如：免费的网站建设教程）

实例

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
</channel>

</rss>

RSS 参考手册

RSS 参考手册


RSS <title>、<link> 以及 <description> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <title>、<link> 以及 <description> 元素

RSS 参考手册

定义和用法

<item> 元素定义 RSS feed 中的一篇文章，该元素有三个必需的子元素：

  • <title> - 定义项目的标题（例如：RSS 教程）
  • <link> - 定义指向项目的超连接（例如：http://www.w3school.com.cn/rss/）
  • <description> - 描述项目（例如：w3school 最新的 RSS 教程）

实例

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
  </item>
  <item>
    <title>XML Tutorial</title>
    <link>http://www.w3school.com.cn/xml</link>
    <description>New XML tutorial on W3School</description>
  </item>
</channel>

</rss>

RSS 参考手册

RSS 参考手册


RSS <ttl> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <ttl> 元素

RSS 参考手册

定义和用法

<ttl> 元素指定在 feed 源更新此 feed 之前，feed 可被缓存的分钟数。

实例

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <ttl>80</ttl>
  <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
  </item>
</channel>

</rss>

RSS 参考手册

RSS 参考手册


RSS <webMaster> 元素

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS <webMaster> 元素

RSS 参考手册

定义和用法

<webMaster> 元素定义 feed 网络管理员的电子邮件地址。

实例

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <webMaster>webmaster@w3school.com.cn</webMaster>
  <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
  </item>
</channel>

</rss>

RSS 参考手册

RSS 参考手册


RSS 参考手册

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS 参考手册

  • Previous Page
  • Next Page

请点击元素列中的具体元素，获得更详细的信息。

RSS <channel> 元素

元素 | 描述
<category> | 可选的。为 feed 定义所属的一个或多个种类。
<cloud> | 可选的。注册进程，以获得 feed 更新的立即通知。
<copyright> | 可选。告知版权资料。
<description> | 必需的。描述频道。
<docs> | 可选的。规定指向当前 RSS 文件所用格式说明的 URL。
<generator> | 可选的。规定用于生成 feed 的程序。
<image> | 可选的。在聚合器呈现某个 feed 时，显示一个图像。
<language> | 可选的。规定编写 feed 所用的语言。
<lastBuildDate> | 可选的。定义 feed 内容的最后修改日期。
<link> | 必需的。定义指向频道的超链接。
<managingEditor> | 可选的。定义 feed 内容编辑的电子邮件地址。
<pubDate> | 可选的。为 feed 的内容定义最后发布日期。
<rating> | 可选的。feed 的 PICS 级别。
<skipDays> | 可选的。规定忽略 feed 更新的天。
<skipHours> | 可选的。规定忽略 feed 更新的小时。
<textInput> | 可选的。规定应当与 feed 一同显示的文本输入域。
<title> | 必需的。定义频道的标题。
<ttl> | 可选的。指定从 feed 源更新此 feed 之前，feed 可被缓存的分钟数。
<webMaster> | 可选的。定义此 feed 的 web 管理员的电子邮件地址。

RSS <item> 元素

元素 | 描述
<author> | 可选的。规定项目作者的电子邮件地址。
<category> | 可选的。定义项目所属的一个或多个类别。
<comments> | 可选的。允许项目连接到有关此项目的注释（文件）。
<description> | 必需的。描述此项目。
<enclosure> | 可选的。允许将一个媒体文件导入一个项中。
<guid> | 可选的。为项目定义一个唯一的标识符。
<description> | 必需的。定义指向此项目的超链接。
<pubDate> | 可选的。定义此项目的最后发布日期。
<source> | 可选的。为此项目指定一个第三方来源。
<description> | 必需的。定义此项目的标题。
  • Previous Page
  • Next Page

RSS 参考手册


RSS 的历史

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS 的历史

  • Previous Page
  • Next Page

RSS 已发布了很多不同的版本。

RSS 的历史

1997 年 - Dave Winer 开发出 scriptingNews。RSS 由此诞生。

1999 年 - Netscape 开发出 RSS 0.90 （由 scriptingNews 支持的）。这是带有一个 RDF header 的简单的 XML。

1999 年- Dave Winer 在 UserLand 公司开发出 scriptingNews 2.0b1 （包含了 Netscape 的 RSS 0.90 的特定）。

1999 年 - Netscape 开发出 RSS 0.91。在此版本中，他们删除了那个 RDF header，但是包含了大多数来自 scriptingNews 2.0b1 的特性。

1999 年 - UserLand 摆脱了 scriptingNews，而仅仅使用 RSS 0.91。

Netscape 停止了 RSS 的研发

2000 年 - UserLand 发布了正式的 0.91 规范

2000 年 - 一个由 Rael Dornfest 领导的团队在 O'Reilly 开发出 RSS 1.0。此歌是使用了 RDF 和命名空间。此版本常被混淆为 0.91 的新版本，不过它是完全不依赖 RSS 0.91 的新格式。

2000 年 - Dave Winer 在 UserLand 公司开发出 RSS 0.92。

2002 年 - Dave Winer 在离开 Userland 之后开发出 RSS 2.0。

2003 年 - 正式的 RSS 2.0 规范发布。

不同之处在哪里？

RSS 1.0 是唯一使用 W3C 的 RDF（资源描述框架） 标准进行开发的版本。

RDF 所蕴含的理念是帮助建立一张语义网。在此阅读更多有关 RDF 和语义网的内容。虽然这与普通用户的关系不大，但是通过使用 Web 标准，对于个人和应用程序来说数据交换会更加容易。

我应该使用哪个 RSS 版本？

RSS 0.91 和 RSS 2.0 较之 RSS 1.0 更容易理解。我们的教程基于 RSS 2.0。

存在 RSS 的 Web 标准吗？

没有正式的标准针对 RSS。

  • 所有 RSS feeds 中大约 50% 使用 RSS 0.91。
  • 大约 25% 使用 RSS 1.0。
  • 最后的 25% 使用 RSS 0.9x 版本或 RSS 2.0。
  • Previous Page
  • Next Page

RSS 参考手册


RSS 发布您的 feed

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS 发布您的 feed

  • Previous Page
  • Next Page

只能当其他人能够找到您的 RSS 文档时，它才是有用的。

把您的 RSS 发布到 Web 上

Now it's time to get your RSS file up on the web. Here are the steps:

1. 为您的 RSS 命名。请注意文件必须有 .xml 的后缀。

2. 验证您的 RSS 文件。（可以在 http://www.feedvalidator.org 找到很好的验证器）。

3. 把 RSS 文件上传到您的 web 服务器上的 web 目录。

4. 把这个小的橙色按钮 [image] 或 [image] 拷贝到您的 web 目录。

5. 在你希望向外界提供 RSS 的页面上放置这个小按钮。然后向这个按钮添加一个指向 RSS 文件的链接。代码应该类似这样：

<a href="www.w3school.com.cn/rss/myfirstrss.xml">
< img src="www.w3school.com.cn/rss/rss.gif" width="36" height="14">
</a>

6. 把你的 RSS feed 提交到 RSS Feed 目录。要注意！feed 的 URL 不是你的页面，而是您的指向您的 feed 的 URL，比如 "http://www.w3school.com.cn/rss/myfirstrss.xml"。 此处提供一些免费的 RSS 聚合服务：

  • Syndic8: Over 300,000 feeds listed. Register your feed here.
  • Daypop: Over 50,000 feeds. Register your feed here.
  • Newsisfree: Over 18,000 feeds. Register your feed here.

7. 在重要的搜索引擎注册您的 feed ：

  • Yahoo - http://publisher.yahoo.com/promote.php
  • Google - http://www.google.com/intl/zh-cn/webmasters/addfeed.html
  • MSN - http://rss.msn.com/publisher.armx

8. 更新您的 feed - 现在您已获得了来自 Google、Yahoo、以及 MSN 的 RSS feed 按钮。请您务必经常更新您的内容，并保持 RSS feed 的长期可用。

我可以自己来维护 RSS feed 吗？

确保 RSS feed 按照您期望的方式工作的最好的办法，就是自己来维护它。

不过，这么做很费时，特别是对于大量的更新工作来讲。

替代方案是使用一个第三方的自动 RSS。

自动的 RSS

如果您不想自己去更新 RSS feed，有一些工具和服务可以为您自动地完成工作，比如：

  • MyRSSCreator - 在 10 分钟之内提供自动的、可靠的 RSS 服务
  • FeedFire - 提供免费的 RSS feed 创建和分发

对于那些仅需要一个用于个人网站的 RSS feed 的用户来说，一些流行的 blog (Web Log) 管理器可提供内建的 RSS 服务：

  • Blogger
  • Radio
  • Previous Page
  • Next Page

RSS 参考手册


RSS 简介

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS 简介

  • Previous Page
  • Next Page

RSS 是一种使用 XML 向许多其他的网站分发某个网站上的网络内容的方法。

RSS 使我们有能力对新闻和更新进行快速浏览。

您应当具备的基础知识

在继续学习之前，您需要对下面的知识有基本的了解：

  • HTML / XHTML
  • XML / XML 命名空间

如果您希望首先学习这些项目，请在我们的 首页 访问这些教程。

什么是 RSS？

  • RSS 指 Really Simple Syndication（真正简易联合）
  • RSS 使您有能力聚合（syndicate）网站的内容
  • RSS 定义了非常简单的方法来共享和查看标题和内容
  • RSS 文件可被自动更新
  • RSS 允许为不同的网站进行视图的个性化
  • RSS 使用 XML 编写

为什么使用 RSS？

RSS 被设计用来展示选定的数据。

如果没有 RSS，用户就不得不每日都来您的网站检查新的内容。对许多用户来说这样太费时了。通过 RSS feed（RSS 通常被称为 News feed 或 RSS feed），用户们可以使用 RSS 聚合器来更快地检查您的网站更新（RSS 聚合器是用来聚集并分类 RSS feed 的网站或软件）。

由于 RSS 数据很小巧并可快速加载，它可轻易地被类似移动电话或 PDA 的服务使用。

拥有相似内容的网站环（Web-rings）可以轻易地在它们的网站共享内容，使这些网站更出色更有价值。

谁应当使用 RSS？

那些极少更新内容的网管们不需要 RSS！

RSS 对那些频繁更新内容的网站是很有帮助的，比如：

新闻站点
列出新闻的标题、日期以及描述
企业
列出新闻和新产品
日程表
列出即将来临的安排和重要日期
站点更新
列出更新过的页面或新的页面

RSS 的未来

RSS 会无所不在！

成千上万的网站在使用 RSS，每天都有越来越多的人们认识到它的用处。

通过 RSS，因特网上的信息会更易查找，而网站开发者也可更容易地把他们的内容传播到特定的受众。

  • Previous Page
  • Next Page

RSS 参考手册


RSS 教程

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS 教程

  • Next Page

通过使用 RSS，您可以有选择地浏览您感兴趣的以及与您的工作相关的新闻。

通过使用 RSS，您可以把需要的信息从不需要的信息（兜售信息，垃圾邮件等）中分离出来。

通过使用 RSS，您可以创建自己的新闻频道，并将之发布到因特网。

开始学习 RSS ！

内容目录

RSS 简介
RSS 的简介。包括其概念,以及 RSS 的优势。
RSS 历史
它是如何诞生的，RSS 的发展史。
RSS 语法
如何制作您的首个 RSS 文件。
RSS <channel>
<channel> 元素的概论。包括完整的参考手册和实例。
RSS <item>
<item> 元素的概论。包括完整的参考手册和实例。
RSS 发布 Feed
如何发布 RSS 文档。
RSS 读取 Feed
如何阅读其他站点的 RSS 文档。
  • Next Page

RSS 参考手册


RSS 语法

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS 语法

  • Previous Page
  • Next Page

RSS 2.0 的语法很简单，也很严格。这些规则很容易学习，也很容易使用。

RSS 如何工作

RSS 用于在网站间分享信息。

使用 RSS，您在名为聚合器的公司注册您的内容。

作为他的一部分，创建一个 RSS 文档，然后使用 .xml 后缀来保存它。然后把此文件上传导您的网站。接下来，通过一个 RSS 聚合器来注册。每天，聚合器都会到被注册的网站搜索 RSS 文档，校验其链接，并显示有关 feed 的信息，这样客户就能够链接到使他们产生兴趣的文档。

提示：请在 RSS 发布 这一节浏览免费的 RSS 聚合器服务。

一个 RSS 实例文档

RSS 文档使用一种简单的自我描述的语法：

让我们看一个简单的 RSS 文档：

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0">

<channel>
  <title>W3School Home Page</title>
  <link>http://www.w3school.com.cn</link>
  <description>Free web building tutorials</description>
  <item>
    <title>RSS Tutorial</title>
    <link>http://www.w3school.com.cn/rss</link>
    <description>New RSS tutorial on W3School</description>
  </item>
  <item>
    <title>XML Tutorial</title>
    <link>http://www.w3school.com.cn/xml</link>
    <description>New XML tutorial on W3School</description>
  </item>
</channel>

</rss>

文档中的第一行：XML 声明 - 定义了文档中使用的 XML 版本和字符编码。此例子遵守 1.0 规范，并使用 ISO-8859-1 (Latin-1/West European) 字符集。

下一行是标识此文档是一个 RSS 文档的 RSS 声明（此例是 RSS version 2.0）。

下一行含有 <channel> 元素。此元素用于描述 RSS feed。

<channel> 元素有三个必需的子元素：

  • <title> - 定义频道的标题。（比如 w3school 首页）
  • <link> - 定义到达频道的超链接。（比如 www.w3school.com.cn）
  • <description> - 描述此频道（比如免费的网站建设教程）

每个 <channel> 元素可拥有一个或多个 <item> 元素。

每个 <item> 元素可定义 RSS feed 中的一篇文章或 "story"。

<item> 元素拥有三个必需的子元素：

  • <title> - 定义项目的标题。（比如 RSS 教程）
  • <link> - 定义到达项目的超链接。（比如 http://www.w3school.com.cn/rss）
  • <description> - 描述此项目（比如 w3school 的 RSS 教程）

最后，后面的两行关闭 <channel> 和 <rss> 元素。

RSS 中的注释

在 RSS 中书写注释的语法与 HTML 的语法类似：

<!-- This is an RSS comment -->

RSS 使用 XML 来编写

因为 RSS 也是 XML，请记住：

  • 所有的元素必许拥有关闭标签
  • 元素对大小写敏感
  • 元素必需被正确地嵌套
  • 属性值必须带引号
  • Previous Page
  • Next Page

RSS 参考手册


RSS 阅读器

RSS 基础

  • RSS 首页
  • RSS 简介
  • RSS 历史
  • RSS 语法
  • RSS <channel>
  • RSS <item>
  • RSS 发布 Feed
  • RSS 读取 Feed

参考手册

  • RSS 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

RSS 阅读器

  • Previous Page
  • Next Page

RSS 阅读器用于读取 RSS feed！

RSS 阅读器可供许多不同的设备和操作系统使用。

RSS 阅读器

有很多不同的 RSS 阅读器。某些以 web services 的形式来工作，而某些则运行于 windows （或 Mac、PDA 或 UNIX）。

这是一些我尝试过并钟爱的阅读器：

NewsGator Online
一个免费的在线 RSS 阅读器。包含 Outlook 同步，通过 Media Center Edition 查看电视内容，以及 blog 和标题的发布。
RssReader
基于 Windows 的免费 RSS 阅读器。支持 RSS versions 0.9x、1.0 以及 2.0 和 Atom 0.1, 0.2 以及 0.3。
FeedDemon
基于 Windows 的 RSS 阅读器。使用很简便，界面很有条理。可以免费下载！
blogbot
一个针对 Outlook 或 Internet Explorer 的 RSS 阅读器插件。针对 Internet Explorer 的简化版是免费的。

提示：Mozilla Firefox 浏览器拥有内建的 RSS 阅读器。在您访问提供 RSS feed 的网站时，会在地址栏看到 Firefox 的 RSS 图标。点击这个图标可查看一个不同 feed 的列表，在此可选择你需要阅读的 feed。

我已经有一个 RSS 阅读器了，接下来怎么做呢？

点击您希望阅读的 RSS feed 旁边的橙色小图标 [image] 或 [image] ，把浏览器窗口的 URL 拷贝粘贴到您的 RSS 阅读器即可。

  • Previous Page
  • Next Page

RSS 参考手册


Schema 教程

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Schema 教程

  • Next Page

XML Schema 是基于 XML 的 DTD 替代者。

XML Schema 描述 XML 文档的结构。

XML Schema 语言也称作 XML Schema 定义（XML Schema Definition，XSD）。

在此教程中，你将学习如何在应用程序中读取和创建 XML Schema 语言，XML Schema 为何比 DTD 更加强大，以及如何在您的应用程序中使用 XML Schema。

开始学习 XML Schema ！

XML Schema 参考手册

在 W3School，我们提供完整的有效的 XML Schema 元素。

XML Schema 参考手册

  • Next Page

XML Schema 参考手册


XML Schema all 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema all 元素

返回 XML Schema 参考手册

定义和用法

all 元素规定子元素能够以任意顺序出现，每个子元素可出现零次或一次。

元素信息

出现次数 | 一次
父元素 | group、restriction (simpleContent)、extension (simpleContent)、restriction (complexContent)、extension (complexContent)、complexType
内容 | annotation、element

语法

<all
id=ID
maxOccurs=1
minOccurs=0|1
any attributes
>

(annotation?,element*)

</all>

（? 符号声明该元素可出现零次或一次，而 * 符号声明该元素可在所有元素中出现零次或多次。）

属性 | 描述
id | 可选。该元素的唯一标识符。
maxOccurs | 可选。元素可出现的最大次数。 该值必须是 1。
minOccurs | 可选。元素可出现的最小次数。 该值可以是整数 0 或 1。若要指定该元素是可选的，请将该属性设置为 0。 默认值为 1。
any attributes | 可选。规定带有 non-schema 命名空间的任何其他属性。

例子 1

<xs:element name="person">
  <xs:complexType>
    <xs:all>
      <xs:element name="firstname" type="xs:string"/>
      <xs:element name="lastname" type="xs:string"/>
    </xs:all>
  </xs:complexType>
</xs:element>

上面的例子指示 "firstname" 和 "lastname" 元素能够以任何顺序出现，两个元素都必须且只能出现一次！

例子 2

<xs:element name="person">
  <xs:complexType>
    <xs:all minOccurs="0">
      <xs:element name="firstname" type="xs:string"/>
      <xs:element name="lastname" type="xs:string"/>
    </xs:all>
  </xs:complexType>
</xs:element>

上面的例子指示 "firstname" 和 "lastname" 元素能够以任何顺序出现，每个元素都能出现零次或一次！

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema annotation 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema annotation 元素

返回 XML Schema 参考手册

定义和用法

annotation 元素是一个顶层元素，规定 schema 的注释。

注释：可以包含 appinfo 元素（由应用程序使用的信息）和 documentation 元素（由用户读取或使用的注释或文本）。

元素信息

项目 | 说明
出现次数 | 在父元素中一次。
父元素 | 任何元素
内容 | appinfo、documentation

语法

<annotation
id=ID
any attributes
>

(appinfo|documentation)*

</annotation>

（* 符号声明该元素可在 annotation 元素中出现零次或多次。）

属性 | 描述
id | 可选。该元素的唯一标识符。
any attributes | 可选。规定带有 non-schema 命名空间的任何其他属性。

例子 1

<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">

<xs:annotation>
  <xs:appInfo>W3School Note</xs:appInfo>
  <xs:documentation xml:lang="en">
  This Schema defines a W3School note!
  </xs:documentation>
</xs:annotation>

.
.
.

</xs:schema>

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema any 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema any 元素

返回 XML Schema 参考手册

定义和用法

any 元素使来自指定命名空间的任何元素可以显示在包含 sequence 或 choice 元素中。

该元素使创作者可以通过未被 schema 规定的元素来扩展 XML 文档。

元素信息

项目 | 说明
出现次数 | 无限制
父元素 | choice、sequence
内容 | annotation

语法

<any
id=ID
maxOccurs=nonNegativeInteger|unbounded
minOccurs=nonNegativeInteger
namespace=namespace
processContents=lax|skip|strict
any attributes
>

(annotation?)

</any>

（? 符号声明元素可在任何元素内出现零次或一次。）

属性

id

可选。规定该元素的唯一的 ID。

maxOccurs

可选。规定 any 元素在父元素中可出现的最大次数。该值可以是大于或等于零的整数。若不想对最大次数设置任何限制，请使用字符串 "unbounded"。 默认值为 1。

minOccurs

可选。规定 any 元素在父元素中可出现的最小次数。该值可以是大于或等于零的整数。若要指定该 any 组是可选的，请将此属性设置为零。 默认值为 1。

namespace

可选。规定包含可以使用的元素的命名空间。如果没有指定命名空间，则 ##any 为默认值。 如果指定命名空间，则必须是以下值之一：

  • ##any - 来自任何命名空间的元素都可以出现（默认）。
  • ##other - 来自该元素的父元素的目标命名空间之外的任何命名空间的元素都可以出现。
  • ##local - 未由命名空间限定的元素可以出现。
  • ##targetNamespace - 来自包含该元素的父元素的目标命名空间的元素可以出现。
  • {URI references of namespaces, ##targetNamespace, ##local} 的列表 - 来自通过空格分隔的命名空间列表的元素可以出现。 该列表可以包含以下内容： 命名空间 ##targetNamespace 和 ##local 的 URI 引用。

processContents

可选。一个指示符，指示应用程序或 XML 处理器应如何根据由该 any 元素指定的元素处理 XML 文档的验证。 如果没有指定 processContents 属性，则默认为 strict。 如果指定了 processContents，必须是以下值之一：

  • strict - XML 处理器必须获得所需命名空间的架构，并且必须验证来自这些命名空间的所有元素。（默认）
  • lax - 与 strict 相同；但是，即使不能获取该架构，也不会发生任何错误。
  • skip - XML 处理器不尝试验证来自指定命名空间的所有元素。

any attributes

可选。规定带有 non-schema 命名空间的任何其他属性。

例子

下面的例子展示了 "person" 元素的一个声明。通过使用 <any> 元素，创作者可以用任何元素扩展 "person" 的内容（在 <lastname> 之后）：

<xs:element name="person">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="firstname" type="xs:string"/>
      <xs:element name="lastname" type="xs:string"/>
      <xs:any minOccurs="0"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema anyAttribute 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema anyAttribute 元素

返回 XML Schema 参考手册

定义和用法

anyAttribute 元素使创作者可以通过未被 schema 规定的属性来扩展 XML 文档。

元素信息

项目 | 说明
出现次数 | 无限制
父元素 | complexType、restriction (simpleContent)、extension (simpleContent)、restriction (complexContent)、extension (complexContent)、attributeGroup
内容 | annotation

语法

<anyAttribute
id=ID
namespace=namespace
processContents=lax|skip|strict
any attributes
>

(annotation?)

</anyAttribute>

（? 符号声明该元素可在 anyAttribute 元素内出现零次或一次。）

属性

id

可选。规定该元素的唯一的 ID。

namespace

可选。规定包含可以使用的元素的命名空间。如果没有指定命名空间，则 ##any 为默认值。如果指定命名空间，则必须是以下值之一。

  • ##any - 来自任何命名空间的元素都可以出现（默认）。
  • ##other - 来自该元素的父元素的目标命名空间之外的任何命名空间的元素都可以出现。
  • ##local - 未由命名空间限定的元素可以出现。
  • ##targetNamespace - 来自包含该元素的父元素的目标命名空间的元素可以出现。
  • {URI references of namespaces, ##targetNamespace, ##local} 的列表 - 来自通过空格分隔的命名空间列表的元素可以出现。 该列表可以包含以下内容： 命名空间 ##targetNamespace 和 ##local 的 URI 引用。

processContents

可选。一个指示符，指示应用程序或 XML 处理器应如何根据由该 any 元素指定的元素处理 XML 文档的验证。 如果没有指定 processContents 属性，则默认为 strict。 如果指定了 processContents，必须是以下值之一。

  • strict - XML 处理器必须获得所需命名空间的架构，并且必须验证来自这些命名空间的所有元素。（默认）
  • lax - 与 strict 相同；但是，即使不能获取该架构，也不会发生任何错误。
  • skip - XML 处理器不尝试验证来自指定命名空间的所有元素。

any attributes

可选。规定带有 non-schema 命名空间的任何其他属性。

实例

下面的例子展示了针对 "person" 元素的一个声明。通过使用 <anyAttribute> 元素，创作者能够向 "person" 元素添加任意数量的属性：

<xs:element name="person">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="firstname" type="xs:string"/>
      <xs:element name="lastname" type="xs:string"/>
    </xs:sequence>
    <xs:anyAttribute/>
  </xs:complexType>
</xs:element>

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema appInfo 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema appInfo 元素

返回 XML Schema 参考手册

定义和用法

appInfo 元素规定 annotation 元素中应用程序要使用的信息。该元素必须位于 annotation 中。

注释：应用程序使用在 appinfo 元素内提供的信息处理指令。

元素信息

出现次数 | 无限制。
父元素 | annotation
内容 | 任何格式正确的 XML 内容。

语法

<appInfo
source=anyURL
>

Any well-formed XML content

</appInfo>
属性 | 描述
source | 可选。一个 URI 引用，规定应用程序信息的来源。

例子 1

<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">

<xs:annotation>
  <xs:appInfo>W3School Note</xs:appInfo>
  <xs:documentation xml:lang="en">
  This Schema defines a W3School note!
  </xs:documentation>
</xs:annotation>

.
.
.

</xs:schema>

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema attribute 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema attribute 元素

返回 XML Schema 参考手册

定义和用法

attribute 元素定义一个属性。

元素信息

出现次数 | 在 schema 元素中定义一次。 在复杂类型或属性组中引用多次。
父元素 | attributeGroup、schema、complexType、restriction (simpleContent)、extension (simpleContent)、restriction (complexContent)、extension (complexContent)
内容 | annotation、simpleType

语法

<attribute
default=string
fixed=string
form=qualified|unqualified
id=ID
name=NCName
ref=QName
type=QName
use=optional|prohibited|required
any attributes
>

(annotation?,(simpleType?))

</attribute>

（? 符号声明该元素可在 attribute 元素中出现零次或一次。）

属性

default

可选。规定属性的默认值。default 和 fixed 属性不能同时出现。

fixed

可选。规定属性的固定值。default 和 fixed 属性不能同时出现。

form

可选。规定属性的格式。默认值是包含该属性的 schema 元素的 attributeFormDefault 属性的值。可以设置为下列值：

  • "qualified" - 指示必须通过命名空间前缀和该属性的无冒号名称 (NCName) 来限定此属性。
  • "unqualified" - 指示此属性无须由命名空间前缀限定，且无须匹配此属性的无冒号名称 (NCName)，即本地名称。

id

可选。规定该元素的唯一的 ID。

name

可选。规定属性的名称。name 和 ref 属性不能同时出现。

ref

可选。规定对指定的属性的引用。name 和 ref 属性不能同时出现。如果 ref 出现，则 simpleType 元素、form 和 type 不能出现。

type

可选。规定内建的数据类型或简单类型。type 属性只能在内容不包含 simpleType 元素时出现。

use

可选。规定如何使用该属性。可设置下面的值：

  • optional - 属性是可选的并且可以具有任何值（默认）。
  • prohibited - 不能使用属性。
  • required - 属性的必需的。

any attributes

可选。规定带有 non-schema 命名空间的任何其他属性。

实例

例子 1

<xs:attribute name="code">

<xs:simpleType>
  <xs:restriction base="xs:string">
    <xs:pattern value="[A-Z][A-Z]"/>
  </xs:restriction>
</xs:simpleType>

</xs:attribute>

上面的例子指示 "code" 属性有一个限定。唯一可接受的值是大写字母 A 到 Z 中的两个字母。

例子 2

如需使用在复杂类型中一个已有的属性定义来声明一个属性，请使用 ref 属性：

<xs:attribute name="code">
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z][A-Z]"/>
    </xs:restriction>
  </xs:simpleType>
</xs:attribute>

<xs:complexType name="someComplexType">
  <xs:attribute ref="code"/>
</xs:complexType>

例子 3

属性既可以拥有默认值，也可以拥有指定的固定值。在没有其他的值被指定时，会自动向属性赋予默认值。在下面的例子中，默认值是 "EN"：

<xs:attribute name="lang" type="xs:string" default="EN"/>

在没有其他的值被指定时，会自动向属性赋予固定值。但是与默认值不同，如果您为属性规定了固定值以外的其他值，文档会验证为无效。在下面的例子中，固定值是 "EN"：

<xs:attribute name="lang" type="xs:string" fixed="EN"/>

例子 4

所有属性默认都是可选的。如需明确地规定属性为可选，请使用 "use" 属性：

<xs:attribute name="lang" type="xs:string" use="optional"/>

使属性成为必需的属性：

<xs:attribute name="lang" type="xs:string" use="required"/>

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema attributeGroup 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema attributeGroup 元素

返回 XML Schema 参考手册

定义和用法

attributeGroup 元素用于对属性声明进行组合，这样这些声明就能够以组合的形式合并到复杂类型中。

元素信息

出现次数 | 无限制
父元素 | attributeGroup、complexType、schema、restriction (simpleContent)、extension (simpleContent)、restriction (complexContent)、extension (complexContent)
内容 | annotation、attribute、attributeGroup、anyAttribute

语法

<attributeGroup
id=ID
name=NCName
ref=QName
any attributes
>

(annotation?),((attribute|attributeGroup)*,anyAttribute?))

</attributeGroup>

（? 符号声明在 attributeGroup 元素中，元素可出现零次或一次，* 符号声明元素可出现零次或多次。）

属性 | 描述
id | 可选。规定该元素的唯一的 ID。
name | 可选。规定属性组的名称。name 和 ref 属性不能同时出现。
ref | 可选。规定对指定的属性组的引用。name 和 ref 属性不能同时出现。
any attributes | 可选。规定带有 non-schema 命名空间的任何其他属性。

实例

<xs:attributeGroup name="personattr">
  <xs:attribute name="attr1" type="string"/>
  <xs:attribute name="attr2" type="integer"/>
</xs:attributeGroup>

<xs:complexType name="person">
  <xs:attributeGroup ref="personattr"/>
</xs:complexType>

上面的例子定义了一个名为 "personattr" 的属性组，在名为 "person" 的复杂类型中使用。

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema choice 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema choice 元素

返回 XML Schema 参考手册

定义和用法

XML Schema 的 choice 元素仅允许包含在 <choice> 声明中的元素之一出现在包含元素中。

元素信息

出现次数 | 在 group 和 complexType 元素中为一次；其他为无限制。
父元素 | group、choice、sequence、complexType、restriction (simpleContent)、extension (simpleContent)、restriction (complexContent)、extension (complexContent)
内容 | annotation、any、choice、element、group、sequence

语法

<choice
id=ID
maxOccurs=nonNegativeInteger|unbounded
minOccurs=nonNegativeInteger
any attributes
>

(annotation?,(element|group|choice|sequence|any)*)

</choice>

（? 符号声明在 choice 元素中，元素可出现零次或一次，* 符号声明元素可出现零次或多次。）

属性 | 描述
id | 可选。规定该元素的唯一的 ID。
maxOccurs | 可选。规定 choice 元素在父元素中可出现的最大次数。该值可以是大于或等于零的整数。若不想对最大次数设置任何限制，请使用字符串 "unbounded"。 默认值为 1。
minOccurs | 可选。规定 choice 元素在父元素中可出现的最小次数。该值可以是大于或等于零的整数。若要指定该 any 组是可选的，请将此属性设置为零。 默认值为 1。
any attributes | 可选。规定带有 non-schema 命名空间的任何其他属性。

实例

<xs:element name="person">
  <xs:complexType>
    <xs:choice>
      <xs:element name="employee" type="employee"/>
      <xs:element name="member" type="member"/>
    </xs:choice>
  </xs:complexType>
</xs:element>

上面的例子定义 "person" 元素必须包含一个 "employee" 元素或一个 "member" 元素。

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema complexContent 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema complexContent 元素

返回 XML Schema 参考手册

定义和用法

complexContent 元素定义对复杂类型（包含混合内容或仅包含元素）的扩展或限制。

元素信息

出现次数 | 一次
父元素 | complexType
内容 | 可选项。annotation 必选项。 有并且只有一个下列元素： restriction (complexContent) 或 extension (complexContent)。

语法

<complexContent
id=ID
mixed=true|false
any attributes
>

(annotation?,(restriction|extension))

</complexContent>

（? 符号声明元素可在 complexContent 元素内出现零次或一次。）

属性 | 描述
id | 可选。规定该元素的唯一的 ID。
mixed | 可选。规定是否允许字符数据出现在该 complexType 元素的子元素之间。 默认值为 false。
any attributes | 可选。规定带有 non-schema 命名空间的任何其他属性。

实例

下面的例子中有一个复杂类型 "fullpersoninfo"，这个复杂类型是通过用三个补充的元素扩展继承的类型，从另一个复杂类型 "personinfo" 衍生而来的：

<xs:element name="employee" type="fullpersoninfo"/>

<xs:complexType name="personinfo">
  <xs:sequence>
    <xs:element name="firstname" type="xs:string"/>
    <xs:element name="lastname" type="xs:string"/>
  </xs:sequence>
</xs:complexType>

<xs:complexType name="fullpersoninfo">
  <xs:complexContent>
    <xs:extension base="personinfo">
      <xs:sequence>
        <xs:element name="address" type="xs:string"/>
        <xs:element name="city" type="xs:string"/>
        <xs:element name="country" type="xs:string"/>
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>

在上例中，"employee" 元素必须按顺序包含下面的元素："firstname"、"lastname"、"address"、"city" 以及 "country"。

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema complexType 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema complexType 元素

返回 XML Schema 参考手册

定义和用法

complexType 元素定义复杂类型。复杂类型的元素是包含其他元素和/或属性的 XML 元素。

元素信息

出现次数 | 在架构内为无限制；在元素内为一次。
父元素 | element、redefine、schema
内容 | annotation、simpleContent、complexContent、group、all、choice、sequence、attribute、attributeGroup、anyAttribute

语法

<complexType
id=ID
name=NCName
abstract=true|false
mixed=true|false
block=(#all|list of (extension|restriction))
final=(#all|list of (extension|restriction))
any attributes
>

(annotation?,(simpleContent|complexContent|((group|all|
choice|sequence)?,((attribute|attributeGroup)*,anyAttribute?))))

</complexType>

（? 符号声明在 complexType 元素中，元素可出现零次或一次，* 符号声明元素可出现零次或多次。）

属性

id

可选。规定该元素的唯一的 ID。

name

可选。规定元素的名称。

abstract

可选。规定在实例文档中是否可以使用复杂类型。如果该值为 true，则元素不能直接使用该复杂类型，而是必须使用从该复杂类型派生的复杂类型。 默认值为 false。

mixed

可选。规定是否允许字符数据出现在该复杂类型的子元素之间。 默认值为 false。

  • 如果 simpleContent 元素是子元素，则不允许 mixed 属性。
  • 如果 complexContent 元素是子元素，则该 mixed 属性可被 complexContent 元素的 mixed 属性重写。

block

可选。防止具有指定派生类型的复杂类型被用来替代该复杂类型。该值可以包含 #all 或者一个列表，该列表是 extension 或 restriction 的子集：

  • extension - 防止通过扩展派生的复杂类型被用来替代该复杂类型。
  • restriction - 防止通过限制派生的复杂类型被用来替代该复杂类型。
  • #all - 防止所有派生的复杂类型被用来替代该复杂类型。

final

可选。防止从该 complexType 元素派生指定的类型。该值可以包含 #all 或者一个列表，该列表是 extension 或 restriction 的子集。

  • extension - 防止通过扩展派生。
  • restriction - 防止通过限制派生。
  • #all - 防止所有派生（扩展和限制）。

any attributes

可选。规定带有 non-schema 命名空间的任何其他属性。

实例

例子 1

下面的例子拥有一个名为 "note" 的复杂类型元素：

<xs:element name="note">
    <xs:complexType>
      <xs:sequence>
    <xs:element name="to" type="xs:string"/>
    <xs:element name="from" type="xs:string"/>
    <xs:element name="heading" type="xs:string"/>
    <xs:element name="body" type="xs:string"/>
      </xs:sequence>
    </xs:complexType>
</xs:element>

例子 2

下面的例子中有一个复杂类型 "fullpersoninfo"，它通过使用三个补充的元素 (address、city 和 country) 对继承的类型进行扩展，由另一个复杂类型 "personinfo" 派生而来：

<xs:element name="employee" type="fullpersoninfo"/>

<xs:complexType name="personinfo">
  <xs:sequence>
    <xs:element name="firstname" type="xs:string"/>
    <xs:element name="lastname" type="xs:string"/>
  </xs:sequence>
</xs:complexType>

<xs:complexType name="fullpersoninfo">
  <xs:complexContent>
    <xs:extension base="personinfo">
      <xs:sequence>
        <xs:element name="address" type="xs:string"/>
        <xs:element name="city" type="xs:string"/>
        <xs:element name="country" type="xs:string"/>
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>

在上面的例子中，上面的 "employee" 元素必须按顺序包含下列元素："firstname", "lastname", "address", "city" 以及 "country"。

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema documentation 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema documentation 元素

返回 XML Schema 参考手册

定义和用法

documentation 元素在 schema 中输入文本注释。该元素必须位于 annotation 元素内。

元素信息

出现次数 | 无限制
父元素 | annotation
内容 | 任何格式正确的 XML 内容。

语法

<documentation
source=URI reference
xml:lang=language
>

Any well-formed XML content

</documentation>
属性 | 描述
source | 可选。规定应用程序信息的来源。
xml:lang | 可选。规定内容中使用的语言。

实例

<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">

<xs:annotation>
  <xs:appInfo>W3School Note</xs:appInfo>
  <xs:documentation xml:lang="en">
  This Schema defines a W3School note!
  </xs:documentation>
</xs:annotation>

.
.
.

</xs:schema>

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema element 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema element 元素

返回 XML Schema 参考手册

定义和用法

element 元素定义一个元素。

元素信息

出现次数 | 在架构中定义的元素的数目。
父元素 | schema、choice、all、sequence
内容 | simpleType、complexType、key、keyref、unique

语法

<element
id=ID
name=NCName
ref=QName
type=QName
substitutionGroup=QName
default=string
fixed=string
form=qualified|unqualified
maxOccurs=nonNegativeInteger|unbounded
minOccurs=nonNegativeInteger
nillable=true|false
abstract=true|false
block=(#all|list of (extension|restriction))
final=(#all|list of (extension|restriction))
any attributes
>

annotation?,((simpleType|complexType)?,(unique|key|keyref)*))

</element>

（? 符号声明在 element 元素中，该元素可出现零次或一次，* 符号声明元素可出现零次或多次。）

属性

id

可选。规定该元素的唯一的 ID。

name

可选。规定元素的名称。如果父元素是 schema 元素，则此属性是必需的。

ref

可选。对另一个元素的引用。ref 属性可包含一个命名空间前缀。如果父元素是 schema 元素，则不是使用该属性。

type

可选。规定内建数据类型的名称，或者规定 simpleType 或 complexType 元素的名称。

substitutionGroup

可选。规定可用来替代该元素的元素的名称。 该元素必须具有相同的类型或从指定元素类型派生的类型。

如果父元素不是 schema 元素，则不可以使用该属性。

default

可选。为元素规定默认值（仅当元素内容是简单类型或 textOnly 时使用）。

fixed

可选。为元素规定固定值（仅当元素内容是简单类型或 textOnly 时使用）。

form

可选。该元素的形式。 默认值是包含该属性的 schema 元素的 elementFormDefault 属性的值。 该值必须是下列字符串之一： “qualified” 或 “unqualified”。

如果父元素是 schema 元素，则不能使用该属性。

  • 如果该值是 “unqualified”，则无须通过命名空间前缀限定该元素。
  • 如果该值是 “qualified”，则必须通过命名空间前缀限定该元素。

maxOccurs

可选。规定 element 元素在父元素中可出现的最大次数。该值可以是大于或等于零的整数。若不想对最大次数设置任何限制，请使用字符串 "unbounded"。 默认值为 1。

如果父元素是 schema 元素，则不能使用该属性。

minOccurs

可选。规定 element 元素在父元素中可出现的最小次数。该值可以是大于或等于零的整数。默认值为 1。

如果父元素是 schema 元素，则不能使用该属性。

nillable

可选。指示是否可以将显式的零值分配给该元素。此项应用于元素内容并且不是该元素的属性。 默认值为 false。

如果 nillable 为 true，将使该元素的实例可以将 nil 属性设置为 true。 nil 属性被定义为实例的 XML 架构命名空间的一部分。

例如，下段定义了单个元素，同时将 nillable 设置为 true。

<xs:element name="myDate" type="xs:date" nillable="true"/>

下段使用该元素并具有显式零值（nil 属性设置为 true）。

<myDate xsi:nil="true"></myDate<

abstract

可选。指示元素是否可以在实例文档中使用。如果该值为 true，则元素不能出现在实例文档中。 相反，substitutionGroup 属性包含该元素的限定名 (QName) 的其他元素必须出现在该元素的位置。多个元素可以在其 substitutionGroup 属性中引用该元素。默认值是 false。

block

可选。派生的类型。 block 属性防止具有指定派生类型的元素被用于替代该元素。该值可以包含 #all 或者一个列表，该列表是 extension、restriction 或 substitution 的子集：

  • extension - 防止通过扩展派生的元素被用来替代该元素。
  • restriction - 防止通过限制派生的元素被用来替代该元素。
  • substitution - 防止通过替换派生的元素被用来替代该元素。
  • #all - 防止所有派生的元素被用来替代该元素。

final

可选。设置 element 元素上 final 属性的默认值。如果父元素不是 schema 元素，则不能使用该属性。该值可以包含 #all 或者一个列表，该列表是 extension 或 restriction 的子集：

  • extension - 防止通过扩展派生的元素被用来替代该元素
  • restriction - 防止通过限制派生的元素被用来替代该元素
  • #all - 防止所有派生的元素被用来替代该元素

any attributes

可选。规定带有 non-schema 命名空间的任何其他属性。

实例

例子 1

下面的例子是一个schema，其中带有四个简单元素："fname", "lname", "age" 以及 "dateborn"，类型是 string、nonNegativeInteger 以及 date：

<?xml version="1.0"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">

<xs:element name="fname" type="xs:string"/>
<xs:element name="lname" type="xs:string"/>
<xs:element name="age" type="xs:nonNegativeInteger"/>
<xs:element name="dateborn" type="xs:date"/>

</xs:schema>

例子 2

下面的例子是一个带有复杂类型 "note" 元素的 schema。"note" 元素包含四个简单元素："to", "from", "heading" 以及 "body":

<?xml version="1.0"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">

<xs:element name="note">
    <xs:complexType>
      <xs:sequence>
    <xs:element name="to" type="xs:string"/>
    <xs:element name="from" type="xs:string"/>
    <xs:element name="heading" type="xs:string"/>
    <xs:element name="body" type="xs:string"/>
      </xs:sequence>
    </xs:complexType>
</xs:element>

</xs:schema>

例子 3

本例与例子 2 相同，但是在此例中，我们选择使用 ref 属性来引用元素名称：

<?xml version="1.0"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">

<xs:element name="note">
  <xs:complexType>
    <xs:sequence>
      <xs:element ref="to"/>
      <xs:element ref="from"/>
      <xs:element ref="heading"/>
      <xs:element ref="body"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>

<xs:element name="to" type="xs:string"/>
<xs:element name="from" type="xs:string"/>
<xs:element name="heading" type="xs:string"/>
<xs:element name="body" type="xs:string"/>

</xs:schema>

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema extension 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema extension 元素

返回 XML Schema 参考手册

定义和用法

extension 元素对 simpleType 或 complexType 的元素进行扩展。

元素信息

出现次数 | 一次
父元素 | complexContent
内容 | annotation、attribute、attributeGroup、anyAttribute、choice、all、sequence、group

语法

<extension
id=ID
base=QName
any attributes
>

(annotation?,((group|all|choice|sequence)?,
((attribute|attributeGroup)*,anyAttribute?)))

</extension>
属性 | 描述
id | 可选。规定该元素的唯一的 ID。
base | 必需。规定内建数据类型、simpleType 或 complexType 元素的名称。
xml:lang | 可选。规定内容中使用的语言。

（? 符号声明在 extension 元素内，该元素只能出现零次或一次，* 符号声明该元素可出现零次或多次。）

实例

例子 1

下面的例子通过添加属性，对一个已有的 simpleType 进行扩展：

<?xml version="1.0"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">

<xs:simpleType name="size">
  <xs:restriction base="xs:string">
    <xs:enumeration value="small" />
    <xs:enumeration value="medium" />
    <xs:enumeration value="large" />
  </xs:restriction>
</xs:simpleType>

<xs:complexType name="jeans">
  <xs:simpleContent>
    <xs:extension base="size">
      <xs:attribute name="sex">
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:enumeration value="male" />
            <xs:enumeration value="female" />
          </xs:restriction>
        </xs:simpleType>
      </xs:attribute>
    </xs:extension>
  </xs:simpleContent>
</xs:complexType>

</xs:schema>

例子 2

下面的例子通过添加三个元素，对一个已有的 complexType 元素进行扩展：

<?xml version="1.0"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">

<xs:element name="employee" type="fullpersoninfo"/>

<xs:complexType name="personinfo">
  <xs:sequence>
    <xs:element name="firstname" type="xs:string"/>
    <xs:element name="lastname" type="xs:string"/>
  </xs:sequence>
</xs:complexType>

<xs:complexType name="fullpersoninfo">
  <xs:complexContent>
    <xs:extension base="personinfo">
      <xs:sequence>
        <xs:element name="address" type="xs:string"/>
        <xs:element name="city" type="xs:string"/>
        <xs:element name="country" type="xs:string"/>
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>

</xs:schema>

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema field 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema field 元素

返回 XML Schema 参考手册

定义和用法

field 元素规定 XPath 表达式，该表达式指定用来定义标识约束（unique、key 和 keyref 元素）的值（或其中一个值）。

元素信息

出现次数 | 一次
父元素 | key、keyref、unique
内容 | annotation

语法

<field
id=ID
xpath=XPath expression
any attributes
>

(annotation?)

</field>
属性 | 描述
id | 可选。规定该元素的唯一的 ID。
xpath | 必需。标识其内容或值用于约束的单个元素或属性。如果该表达式标识一个元素，则该元素必须是简单类型。
xml:lang | 可选。规定内容中使用的语言。

（? 符号声明在 field 元素内，该元素可出现零次或一次。）

实例

例子 1

下面的例子展示了一个 field 元素，该元素把 "userID" 属性定义为用于标识约束的字段：

<xs:field xpath="@userID"/>

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema group 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema group 元素

返回 XML Schema 参考手册

定义和用法

group 元素用于定义在复杂类型定义中使用的元素组。

元素信息

出现次数 | 无限制
父元素 | schema、choice、sequence、complexType、restriction (complexContent)、extension (complexContent)
内容 | annotation、all、choice、sequence

语法

<group
id=ID
name=NCName
ref=QName
maxOccurs=nonNegativeInteger|unbounded
minOccurs=nonNegativeInteger
any attributes
>

annotation?,(all|choice|sequence)?)

</group>

（? 符号声明在 group 元素中，该元素可出现零次或一次。）

属性

id

可选。规定该元素的唯一的 ID。

name

可选。规定组的名称。该名称必须是在 XML 命名空间规范中定义的无冒号名称 (NCName)。

仅当 schema 元素是该 group 元素的父元素时才使用该属性。在此情况下，group 是由 complexType、choice 和 sequence 元素使用的模型组。

name 属性和 ref 属性不能同时出现。

ref

可选。引用另一个组的名称。ref 值必须是 QName。 ref 可以包含命名空间前缀。

name 属性和 ref 属性不能同时出现。

maxOccurs

可选。规定 group 元素可在父元素中出现的最大次数。该值可以是大于或等于零的整数。若不想对最大次数设置任何限制，请使用字符串 "unbounded"。默认值为 1。

minOccurs

可选。规定 group 元素可在父元素中出现的最小次数。该值可以是大于或等于零的整数。默认值为 1。

any attributes

可选。规定带有 non-schema 命名空间的任何其他属性。

实例

例子 1

下面的例子定义一个包含四个元素的序列的组，并在一个复杂类型定义中使用了这个 group 元素：

<?xml version="1.0"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">

<xs:group name="custGroup">
 <xs:sequence>
  <xs:element name="customer" type="xs:string"/>
  <xs:element name="orderdetails" type="xs:string"/>
  <xs:element name="billto" type="xs:string"/>
  <xs:element name="shipto" type="xs:string"/>
 </xs:sequence>
</xs:group>

<xs:element name="order" type="ordertype"/>

<xs:complexType name="ordertype">
  <xs:group ref="custGroup"/>
  <xs:attribute name="status" type="xs:string"/>
</xs:complexType>

</xs:schema>

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema import 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema import 元素

返回 XML Schema 参考手册

定义和用法

import 元素用于向一个文档添加带有不同目标命名空间的多个 schema。

元素信息

出现次数 | 无限制
父元素 | schema
内容 | annotation

语法

<import
id=ID
namespace=anyURI
schemaLocation=anyURI
any attributes
>

(annotation?)

</import>
属性 | 描述
id | 可选。规定该元素的唯一的 ID。
namespace | 必需。规定要导入的命名空间的 URI。
schemaLocation | 可选。规定被导入的命名空间的 URI。
any attributes | 可选。规定带有 non-schema 命名空间的任何其他属性。

（? 符号声明在 import 元素中，该元素可出现零次或一次。）

实例

下面的例子展示导入一个命名空间：

<?xml version="1.0"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">

<xs:import namespace="http://www.w3school.com.cn/schema"/>

..

..

..

</xs:schema>

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema include 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema include 元素

返回 XML Schema 参考手册

定义和用法

include 元素用于向一个文档添加带有相同目标命名空间的多个 schema。

元素信息

出现次数 | 无限制
父元素 | schema
内容 | annotation

语法

<include
id=ID
schemaLocation=anyURI
any attributes
>

(annotation?)

</include>
属性 | 描述
id | 可选。规定该元素的唯一的 ID。
schemaLocation | 必需。规定在包含 schema 的目标命名空间中，要包括的 schema 的 URI。
any attributes | 可选。规定带有 non-schema 命名空间的任何其他属性。

（? 符号声明在 include 元素中，该元素可出现零次或一次。）

实例

通过被包括的 schema，被包括的文件必须全部引用相同的目标命名空间。如果 schema 目标命名空间不匹配，则包括不会有效：

<?xml version="1.0"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema"
targetNamespace="http://www.w3school.com.cn/schema">

<xs:include schemaLocation="http://www.w3school.com.cn/schema/customer.xsd"/>
<xs:include schemaLocation="http://www.w3school.com.cn/schema/company.xsd"/>

..

..

..

</xs:schema>

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema key 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema key 元素

返回 XML Schema 参考手册

定义和用法

key 元素指定属性或元素值（或一组值）必须是指定范围内的键。键的范围为实例文档中的包含 element。键意味着数据在指定范围内应是唯一的、不为零的并且始终存在的。

key 元素必须按顺序包含下列元素：

selector 元素：

必须有一个且只有一个 selector 元素。

selector 元素包含一个 XPath 表达式，该表达式指定一个元素集，在元素集中，field 指定的值必须是唯一的。

field 元素

必须有一个或多个 field 元素。

每一个 field 元素均包含一个 XPath 表达式，该表达式指定对于由 selector 元素指定的元素集而言必须唯一的值（属性或元素值）。

如果有多个 field 元素，则 field 元素的组合必须是唯一的。 在此情况下，单个 field 元素的值对于选定元素不一定是唯一的，但所有字段的组合必须是唯一的。

元素信息

出现次数 | 无限制
父元素 | element
内容 | annotation、field、selector

语法

<key
id=ID
name=NCName
any attributes
>

(annotation?,(selector,field+))

</key>

（? 符号声明在 key 元素中，元素可出现零次或一次，+ 符号声明元素必须出现一次或多次。）

属性 | 描述
id | 可选。规定该元素的唯一的 ID。
name | 必需。规定 key 元素的名称。
any attributes | 可选。规定带有 non-schema 命名空间的任何其他属性。

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema keyref 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema keyref 元素

返回 XML Schema 参考手册

定义和用法

keyref 元素规定属性或元素值（或一组值）对应指定的 key 或 unique 元素的值。

keyref 元素必须按顺序包含下列元素：

selector 元素：

必须有一个且只有一个 selector 元素。

selector 元素包含一个 XPath 表达式，该表达式指定一个元素集，在元素集中，field 指定的值必须是唯一的。

field 元素

必须有一个或多个 field 元素。

每一个 field 元素均包含一个 XPath 表达式，该表达式指定对于由 selector 元素指定的元素集而言必须唯一的值（属性或元素值）。

如果有多个 field 元素，则 field 元素的组合必须是唯一的。 在此情况下，单个 field 元素的值对于选定元素不一定是唯一的，但所有字段的组合必须是唯一的。

元素信息

出现次数 | 一次
父元素 | element
内容 | annotation、field、selector

语法

<keyref
id=ID
name=NCName
refer=QName
any attributes
>

(annotation?,(selector,field+))

</include>

（? 符号声明在 key 元素中，元素可出现零次或一次，+ 符号声明元素必须出现一次或多次。）

属性 | 描述
id | 可选。规定该元素的唯一的 ID。
name | 必需。规定 key 元素的名称。
refer | 必需。规定在该 schema（或由指定的命名空间指示的其他 schema）中定义的 key 或 unique 元素的名称。refer 值必须是限定名 (QName)。 类型可以包括命名空间前缀。
any attributes | 可选。规定带有 non-schema 命名空间的任何其他属性。

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema list 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema list 元素

返回 XML Schema 参考手册

定义和用法

list 元素定义单个 simpleType 定义的集合。

该属性把简单类型定义为指定数据类型的值的一个列表。

元素信息

出现次数 | 一次
父元素 | simpleType
内容 | annotation、simpleType

语法

<list
id=ID
itemType=QName
any attributes
>

(annotation?,(simpleType?))

</list>

（? 符号声明在 list 元素中元素可出现零次或一次。）

属性 | 描述
id | 可选。规定该元素的唯一的 ID。
itemType | 在该 schema（或由指定的命名空间指示的其他 schema）中定义的内置数据类型或 simpleType 元素的名称。包含 list 元素的 simpleType 元素是从 list 值指定的简单类型派生的。list 值必须是限定名 (QName)。 如果内容包含 simpleType 元素，则不允许使用该属性，否则该属性是必需的。
any attributes | 可选。规定带有 non-schema 命名空间的任何其他属性。

实例

例子 1

下面的例子展示了为一列整数的简单类型：

<?xml version="1.0"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">

<xs:element name="intvalues" type="valuelist">

<xs:simpleType name="valuelist">
  <xs:list itemType="xs:integer"/>
</xs:simpleType>

</xs:schema>

文档中的 "intvalues" 元素类似这样（注意这个列表有五个列表项）：

<intvalues>100 34 56 -23 1567</intvalues>

注释：空格被作为列表项的分隔符。

例子 2

下面的例子展示了为一列字符串的简单类型：

<?xml version="1.0"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">

<xs:element name="stringvalues" type="valuelist">

<xs:simpleType name="valuelist">
  <xs:list itemType="xs:string"/>
</xs:simpleType>

</xs:schema>

文档中的 "stringvalues" 元素类似这样（注意这个列表有四个列表项）：

<stringvalues>I love XML Schema</stringvalues>

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema notation 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema notation 元素

返回 XML Schema 参考手册

定义和用法

notation 元素描述 XML 文档中非 XML 数据的格式。

元素信息

出现次数 | 无限制
父元素 | schema
内容 | annotation

语法

<notation
id=ID
name=NCName
public=anyURI
system=anyURI
any attributes
>

(annotation?)

</notation>

（? 符号声明在 notation 元素中该元素可出现零次或一次。）

属性 | 描述
id | 可选。规定该元素的唯一的 ID。
name | 必需。为元素规定名称。
public | 必需。与 public 标识符相对应的 URI 引用。
system | 与 system 标识符相对应的 URI 引用。
any attributes | 可选。规定带有 non-schema 命名空间的任何其他属性。

实例

例子 1

下面的例子通过使用一个查看应用程序 view.exe 来显示 gif 和 jpeg 格式的 notation：

<?xml version="1.0"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">

<xs:notation name="gif" public="image/gif" system="view.exe"/>
<xs:notation name="jpeg" public="image/jpeg" system="view.exe"/>

<xs:element name="image">
  <xs:complexType>
    <xs:simpleContent>
      <xs:attribute name="type">
        <xs:simpleType>
          <xs:restriction base="xs:NOTATION">
            <xs:enumeration value="gif"/>
            <xs:enumeration value="jpeg"/>
          <xs:restriction>
        </xs:simpleType>
      </xs:attribute>
    </xs:simpleContent>
  </xs:complexType>
</xs:element>

</xs:schema>

文档中的 "image" 元素是这样的：

<image type="gif"></image>

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema redefine 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema redefine 元素

返回 XML Schema 参考手册

定义和用法

redefine 元素允许在当前 Schema 中重新定义从外部架构文件中获取的简单和复杂类型、组和属性组。

元素信息

出现次数 | 无限制
父元素 | schema
内容 | annotation、attributeGroup、complexType、group、simpleType

语法

<redefine
id=ID
schemaLocation=anyURI
any attributes
>

(annotation|(simpleType|complexType|group|attributeGroup))*

</redefine>
属性 | 描述
id | 可选。规定该元素的唯一的 ID。
schemaLocation | 必需。对 schema 文档位置的 URI 引用。
any attributes | 可选。规定带有 non-schema 命名空间的任何其他属性。

实例

例子 1

下面的例子展示了一个 schema，Myschama2.xsd，其中存在由 Myschama1.xsd 规定的元素。pname 类型被重新定义。根据此 schema，被 pname 约束的元素必须以 "country" 元素结束：

Myschema1.xsd:

<?xml version="1.0"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">

<xs:complexType name="pname">
  <xs:sequence>
    <xs:element name="firstname"/>
    <xs:element name="lastname"/>
  </xs:sequence>
</xs:complexType>

<xs:element name="customer" type="pname"/>

</xs:schema>

Myschema2.xsd:

<?xml version="1.0"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">

<xs:redefine schemaLocation="Myschema1.xsd">
  <xs:complexType name="pname">
    <xs:complexContent>
      <xs:extension base="pname">
        <xs:sequence>
          <xs:element name="country"/>
        </xs:sequence>
      </xs:extension>
    </xs:complexContent>
  </xs:complexType>
</xs:redefine>

<xs:element name="author" type="pname"/>

</xs:schema>

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema restriction 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema restriction 元素

返回 XML Schema 参考手册

定义和用法

restriction 元素定义对 simpleType、simpleContent 或 complexContent 定义的约束。

元素信息

出现次数 | 一次
父元素 | complexContent
内容 | group、all、choice、sequence、attribute、attributeGroup、anyAttribute

语法

<restriction
id=ID
base=QName
any attributes
>

Content for simpleType:
(annotation?,(simpleType?,(minExclusive|minInclusive|
maxExclusive|maxInclusive|totalDigits|fractionDigits|
length|minLength|maxLength|enumeration|whiteSpace|pattern)*))

Content for simpleContent:
(annotation?,(simpleType?,(minExclusive |minInclusive|
maxExclusive|maxInclusive|totalDigits|fractionDigits|
length|minLength|maxLength|enumeration|whiteSpace|pattern)*)?,
((attribute|attributeGroup)*,anyAttribute?))

Content for complexContent:
(annotation?,(group|all|choice|sequence)?,
((attribute|attributeGroup)*,anyAttribute?))

</restriction>

（? 符号声明在 restriction 元素中该元素可出现零次或一次。）

属性 | 描述
id | 可选。规定该元素的唯一的 ID。
base | 必需。规定在该 schema（或由指定的命名空间指示的其他 schema）中定义的内建数据类型、simpleType 或 complexType 元素的名称。
any attributes | 可选。规定带有 non-schema 命名空间的任何其他属性。

实例

例子 1

下面的例子定义了一个带有约束且名为 "age" 的元素。age 的值不能小于 0 或大于 100：

<xs:element name="age">
  <xs:simpleType>
    <xs:restriction base="xs:integer">
      <xs:minInclusive value="0"/>
      <xs:maxInclusive value="100"/>
    </xs:restriction>
  </xs:simpleType>
</xs:element>

例子 2

本例定义了一个名为 "initials" 的元素。"initials" 元素是带有约束的简单类型。可接受的值是三个从 a 到 z 的大写或小写字母：

<xs:element name="initials">
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[a-zA-Z][a-zA-Z][a-zA-Z]"/>
    </xs:restriction>
  </xs:simpleType>
</xs:element>

例子 3

本例定义了一个名为 "password" 元素。"password" 元素是带有约束的简单类型。值必须为最少 5 个字符且最多 8 个字符：

<xs:element name="password">
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="5"/>
      <xs:maxLength value="8"/>
    </xs:restriction>
  </xs:simpleType>
</xs:element>

例子 4

本例展示了一个使用约束的复杂类型定义。复杂类型 "Chinese_customer" 从一个普通的 customer 复杂类型派生而来，其 country 元素的固定值是 "China"：

<xs:complexType name="customer">
  <xs:sequence>
    <xs:element name="firstname" type="xs:string"/>
    <xs:element name="lastname" type="xs:string"/>
    <xs:element name="country" type="xs:string"/>
  </xs:sequence>
</xs:complexType>

<xs:complexType name="Chinese_customer">
  <xs:complexContent>
    <xs:restriction base="customer">
      <xs:sequence>
        <xs:element name="firstname" type="xs:string"/>
        <xs:element name="lastname" type="xs:string"/>
        <xs:element name="country" type="xs:string" fixed="China"/>
      </xs:sequence>
    </xs:restriction>
  </xs:complexContent>
</xs:complexType>

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema schema 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema schema 元素

返回 XML Schema 参考手册

定义和用法

schema 元素定义 schema 的根元素。

元素信息

出现次数 | 一次
父元素 | （无父元素）
内容 | include、import、annotation、redefine、attribute、attributeGroup、element、group、notation、simpleType、complexType

语法

<schema
id=ID
attributeFormDefault=qualified|unqualified
elementFormDefault=qualified|unqualified
blockDefault=(#all|list of (extension|restriction|substitution))
finalDefault=(#all|list of (extension|restriction|list|union))
targetNamespace=anyURI
version=token
xmlns=anyURI
any attributes
>

((include|import|redefine|annotation)*,(((simpleType|complexType|
group|attributeGroup)|element|attribute|notation),annotation*)*)

</schema>

属性

id

可选。规定该元素的唯一的 ID。

attributeFormDefault

可选。在该 schema 的目标命名空间中声明的属性的形式。该值必须是下列字符串之一： "qualified" 或 "unqualified"。 默认值为 "unqualified"。

  • "unqualified" 指示无须通过命名空间前缀限定目标命名空间的属性。
  • "qualified" 指示必须通过命名空间前缀限定目标命名空间的属性。

elementFormDefault

可选。在该 schema 的目标命名空间中声明的元素的形式。该值必须是下列字符串之一： "qualified" 或 "unqualified"。 默认值为 "unqualified"。

  • "unqualified" 指示无须通过命名空间前缀限定目标命名空间的元素。
  • "qualified" 指示必须通过命名空间前缀限定目标命名空间的元素。

blockDefault

可选。规定在目标命名空间中 element 和 complexType 元素上的 block 属性的默认值。block 属性防止具有指定派生类型的复杂类型（或元素）被用来代替继承的复杂类型（或元素）。该值可以包含 #all 或者一个列表，该列表是 extension、restriction 或 substitution 的子集：

  • extension - 防止通过扩展派生的复杂类型被用来替代该复杂类型。
  • restriction - 防止通过限制派生的复杂类型被用来替代该复杂类型。
  • substitution - 防止元素的替换。
  • #all - 防止所有派生的复杂类型被用来替代该复杂类型。

finalDefault

可选。规定在该架构的目标命名空间中 element、simpleType 和 complexType 元素的 final 属性的默认值。final 属性防止 element、simpleType 或 complexType 元素的指定的派生类型。对于 element 和 complexType 元素，该值可以包含 #all 或一个列表，该列表是 extension 或 restriction 的子集。 对于 simpleType 元素，该值还可以包含 list 和 union：

  • extension - 默认情况下，该 schema 中的元素不能通过扩展派生。仅适用于 element 和 complexType 元素。
  • restriction - 防止通过限制派生。
  • list - 防止通过列表派生。仅适用于 simpleType 元素。
  • union - 防止通过联合派生。仅适用于 simpleType 元素。
  • #all - 默认情况下，该 schema 中的元素不能通过任何方法派生。

targetNamespace

该 schema 的命名空间的 URI 引用。还可以分配该命名空间的前缀。如果没有分配任何前缀，则该命名空间的 schema 组件可以和非限定的引用一起使用。

version

可选。规定 schema 的版本。

xmlns

规定在此 schema 中使用的一个或多个命名空间的 URI 引用。如果没有分配前缀，该命名空间的 schema 组件可与未限制的引用使用。

any attributes

可选。规定带有 non-schema 命名空间的任何其他属性。

实例

例子 1

<?xml version="1.0"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">

<xs:element name="values" type="xs:string">

</xs:schema>

例子 2

在本例中，http://www.w3.org/2001/XMLSchema 命名空间中 schema 组件 (element name, type) 是未限制的，而 http://www.w3school.com.cn/w3schoolschema (mystring) 是通过 wsc 前缀限制的：

<?xml version="1.0"?>
<schema xmlns="http://www.w3.org/2001/XMLSchema"
xmlns:wsc="http://www.w3school.com.cn/w3schoolschema">

<element name="fname" type="wsc:mystring"/>

</schema>

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema selector 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema selector 元素

返回 XML Schema 参考手册

定义和用法

selector 元素指定 XML 路径语言 (XPath) 表达式，该表达式为标识约束选择一组元素（unique、key 和 keyref 元素）。

元素信息

出现次数 | 一次
父元素 | key、keyref、unique
内容 | annotation

语法

<selector
id=ID
xpath=a subset of XPath expression
any attributes
>

(annotation?)

</selector>
属性 | 描述
id | 可选。规定该元素的唯一的 ID。
xpath | 必需。规定相对于所声明的元素的 XPath 表达式。该表达式标识应用标识约束（所声明的元素）的子元素。
any attributes | 可选。规定带有 non-schema 命名空间的任何其他属性。

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema sequence 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema sequence 元素

返回 XML Schema 参考手册

定义和用法

sequence 元素要求组中的元素以指定的顺序出现在包含元素中。每个子元素可出现 0 次到任意次数。

元素信息

出现次数 | 在组内为一次；否则为无限制。
父元素 | group、choice、sequence、complexType、restriction (simpleContent)、extension (simpleContent)、restriction (complexContent)、extension (complexContent)
内容 | annotation、any、choice、element、group、sequence

语法

<sequence
id=ID
maxOccurs=nonNegativeInteger|unbounded
minOccurs=nonNegativeInteger
any attributes
>

(annotation?,(element|group|choice|sequence|any)*)

</sequence>

（? 声明在 sequence 元素中该元素可出现零次或一次。）

属性 | 描述
id | 可选。规定该元素的唯一的 ID。
maxOccurs | 可选。规定 any 元素在父元素中可出现的最大次数。该值可以是大于或等于零的整数。若不想对最大次数设置任何限制，请使用字符串 "unbounded"。 默认值为 1。
minOccurs | 可选。规定 any 元素在父元素中可出现的最小次数。该值可以是大于或等于零的整数。若要指定该 any 组是可选的，请将此属性设置为零。 默认值为 1。
any attributes | 可选。规定带有 non-schema 命名空间的任何其他属性。

实例

例子 1

本例是一个针对 "personinfo" 元素的声明，该元素必需按顺序包含下列 5 个元素："firstname", "lastname", "address", "city", and "country"。

<xs:element name="personinfo">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="firstname" type="xs:string"/>
      <xs:element name="lastname" type="xs:string"/>
      <xs:element name="address" type="xs:string"/>
      <xs:element name="city" type="xs:string"/>
      <xs:element name="country" type="xs:string"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>

例子 2

本例是一个针对 "pets" 元素的声明，可包含零个或多个 dog 和 cat 元素：

<xs:element name="pets">
  <xs:complexType>
    <xs:sequence minOccurs="0" maxOccurs="unbounded">
      <xs:element name="dog" type="xs:string"/>
      <xs:element name="cat" type="xs:string"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema simpleContent 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema simpleContent 元素

返回 XML Schema 参考手册

定义和用法

simpleContent 元素包含对 complexType 元素（它以字符数据或 simpleType 元素为内容）的扩展或限制并且不包含任何元素。

元素信息

出现次数 | 一次
父元素 | complexType
内容 | 可选项 — annotation 必选项 — 有并且只有一个下列元素： restriction (simpleContent) 或 extension (simpleContent)。

语法

<simpleContent
id=ID
any attributes
>

(annotation?,(restriction|extension))

</simpleContent>

（? 符号声明在 simpleContent 元素中该元素可出现零次或一次。）

属性 | 描述
id | 可选。规定该元素的唯一的 ID。
any attributes | 可选。规定带有 non-schema 命名空间的任何其他属性。

实例

例子 1

这是一个仅包含文本的 XML 元素 (<shoesize>)：

<shoesize country="france">35</shoesize>

下面的例子声明了一个复杂类型 "shoesize"，其内容被定义为整数数据类型，并带有一个 country 属性：

<xs:element name="shoesize">
  <xs:complexType>
    <xs:simpleContent>
      <xs:extension base="xs:integer">
        <xs:attribute name="country" type="xs:string" />
      </xs:extension>
    </xs:simpleContent>
  </xs:complexType>
</xs:element>

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema simpleType 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema simpleType 元素

返回 XML Schema 参考手册

定义和用法

simpleType 元素定义一个简单类型，规定与具有纯文本内容的元素或属性的值有关的信息以及对它们的约束。

元素信息

出现次数 | 无限制
父元素 | attribute、element、list、restriction (simpleType)、schema、union
内容 | annotation、list、restriction (simpleType)、union

语法

<simpleType
id=ID
name=NCName
any attributes
>

(annotation?,(restriction|list|union))

</simpleType>

(? 符号声明元素可在 simpleType 元素中出现零次或一次。)

属性 | 描述
id | 可选。规定该元素的唯一的 ID。
name | 类型名称。 该名称必须是在 XML 命名空间规范中定义的无冒号名称 (NCName)。 如果指定，该名称在所有 simpleType 和 complexType 元素之间必须是唯一的。 如果 simpleType 元素是 schema 元素的子元素，则为必选项，在其他时候则是不允许的。
any attributes | 可选。规定带有 non-schema 命名空间的任何其他属性。

实例

例子 1

本例声明 "age" 元素是一个带有约束的简单类型。age 的值不能小于 0 或大于 100：

<xs:element name="age">
  <xs:simpleType>
    <xs:restriction base="xs:integer">
      <xs:minInclusive value="0"/>
      <xs:maxInclusive value="100"/>
    </xs:restriction>
  </xs:simpleType>
</xs:element>

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema union 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema union 元素

返回 XML Schema 参考手册

定义和用法

union 元素定义多个 simpleType 定义的集合。

元素信息

出现次数 | 一次
父元素 | simpleType
内容 | annotation、simpleType

语法

<union
id=ID
memberTypes="list of QNames"
any attributes
>

(annotation?,(simpleType*))

</union>

（? 符号声明在 union 元素中该元素可出现零次或一次。）

属性 | 描述
id | 可选。规定该元素的唯一的 ID。
memberTypes | 可选。规定在 schema 中定义的内置数据类型或 simpleType 元素的名称列表。
any attributes | 可选。规定带有 non-schema 命名空间的任何其他属性。

实例

例子 1

本例是一个合并了两个简单类型的简单类型：

<xs:element name="jeans_size">
  <xs:simpleType>
    <xs:union memberTypes="sizebyno sizebystring" />
  </xs:simpleType>
</xs:element>

<xs:simpleType name="sizebyno">
  <xs:restriction base="xs:positiveInteger">
    <xs:maxInclusive value="42"/>
  </xs:restriction>
</xs:simpleType>

<xs:simpleType name="sizebystring">
  <xs:restriction base="xs:string">
    <xs:enumeration value="small"/>
    <xs:enumeration value="medium"/>
    <xs:enumeration value="large"/>
  </xs:restriction>
</xs:simpleType>

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema unique 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema unique 元素

返回 XML Schema 参考手册

定义和用法

unique 元素指定属性或元素值（或者属性或元素值的组合）在指定范围内必须是唯一的。 该值必须唯一或为零。

unique 元素必须按顺序包含下列元素：

selector 元素

selector 元素包含 XPath 表达式，指定一个元素集，在其中由 field 元素指定的值必须唯一。

必须有一个且只有一个 selector 元素。

field 元素

每一个 field 元素均包含一个 XPath 表达式，指定对于由 selector 元素指定的元素集而言必须唯一的值（属性或元素值）。

如果有多个 field 元素，则 field 元素的组合必须是唯一的。 在此情况下，单个 field 元素的值对于选定元素不一定是唯一的，但所有字段的组合必须是唯一的。

必须有一个或多个 field 元素。

元素信息

出现次数 | 一次
父元素 | element
内容 | annotation、field、selector

语法

<unique
id=ID
name=NCName
any attributes
>

(annotation?,(selector,field+))

</unique>

（? 符号声明在 unique 元素中该元素可出现零次或一次。）

属性 | 描述
id | 可选。规定该元素的唯一的 ID。
name | 必需。为该元素指定名称。
any attributes | 可选。规定带有 non-schema 命名空间的任何其他属性。

实例

例子 1

本例是一个合并了两个简单类型的简单类型：

<xs:element name="jeans_size">
  <xs:simpleType>
    <xs:union memberTypes="sizebyno sizebystring" />
  </xs:simpleType>
</xs:element>

<xs:simpleType name="sizebyno">
  <xs:restriction base="xs:positiveInteger">
    <xs:maxInclusive value="42"/>
  </xs:restriction>
</xs:simpleType>

<xs:simpleType name="sizebystring">
  <xs:restriction base="xs:string">
    <xs:enumeration value="small"/>
    <xs:enumeration value="medium"/>
    <xs:enumeration value="large"/>
  </xs:restriction>
</xs:simpleType>

返回 XML Schema 参考手册

XML Schema 参考手册


XML Schema 参考手册

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema 参考手册

  • Previous Page
  • Next Page

XSD 元素

元素 | 解释
all | 规定子元素能够以任意顺序出现，每个子元素可出现零次或一次。
annotation | annotation 元素是一个顶层元素，规定 schema 的注释。
any | 使创作者可以通过未被 schema 规定的元素来扩展 XML 文档。
anyAttribute | 使创作者可以通过未被 schema 规定的属性来扩展 XML 文档。
appInfo | 规定 annotation 元素中应用程序要使用的信息。
attribute | 定义一个属性。
attributeGroup | 定义在复杂类型定义中使用的属性组。
choice | 仅允许在 <choice> 声明中包含一个元素出现在包含元素中。
complexContent | 定义对复杂类型（包含混合内容或仅包含元素）的扩展或限制。
complexType | 定义复杂类型。
documentation | 定义 schema 中的文本注释。
element | 定义元素。
extension | 扩展已有的 simpleType 或 complexType 元素。
field | 规定 XPath 表达式，该表达式规定用于定义标识约束的值。
group | 定义在复杂类型定义中使用的元素组。
import | 向一个文档添加带有不同目标命名空间的多个 schema。
include | 向一个文档添加带有相同目标命名空间的多个 schema。
key | 指定属性或元素值（或一组值）必须是指定范围内的键。
keyref | 规定属性或元素值（或一组值）对应指定的 key 或 unique 元素的值。
list | 把简单类型定义为指定数据类型的值的一个列表。
notation | 描述 XML 文档中非 XML 数据的格式。
redefine | 重新定义从外部架构文件中获取的简单和复杂类型、组和属性组。
restriction | 定义对 simpleType、simpleContent 或 complexContent 的约束。
schema | 定义 schema 的根元素。
selector | 指定 XPath 表达式，该表达式为标识约束选择一组元素。
sequence | 要求子元素必须按顺序出现。每个子元素可出现 0 到任意次数。
simpleContent | 包含对 complexType 元素的扩展或限制且不包含任何元素。
simpleType | 定义一个简单类型，规定约束以及关于属性或仅含文本的元素的值的信息。
union | 定义多个 simpleType 定义的集合。
unique | 指定属性或元素值（或者属性或元素值的组合）在指定范围内必须是唯一的。

XSD Restrictions/Facets for Datatypes

参阅 XSD 限定 / Facets

限定 | 描述
enumeration | 定义可接受值的一个列表
fractionDigits | 定义所允许的最大的小数位数。必须大于等于0。
length | 定义所允许的字符或者列表项目的精确数目。必须大于或等于0。
maxExclusive | 定义数值的上限。所允许的值必须小于此值。
maxInclusive | 定义数值的上限。所允许的值必须小于或等于此值。
maxLength | 定义所允许的字符或者列表项目的最大数目。必须大于或等于0。
minExclusive | 定义数值的下限。所允许的值必需大于此值。
minInclusive | 定义数值的下限。所允许的值必需大于或等于此值。
minLength | 定义所允许的字符或者列表项目的最小数目。必须大于或等于0。
pattern | 定义可接受的字符的精确序列。
totalDigits | 定义所允许的阿拉伯数字的精确位数。必须大于0。
whiteSpace | 定义空白字符（换行、回车、空格以及制表符）的处理方式。
  • Previous Page
  • Next Page

XML Schema 参考手册


XML Schema 简介

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Schema 简介

  • Previous Page
  • Next Page

XML Schema 是基于 XML 的 DTD 替代者。

XML Schema 可描述 XML 文档的结构。

XML Schema 语言也可作为 XSD（XML Schema Definition）来引用。

您应当具备的基础知识

在继续学习之前，您需要对下面的知识有基本的了解：

  • HTML / XHTML
  • XML 以及 XML 命名空间
  • 对 DTD 的基本了解

如果您希望首先学习这些项目，请在 首页 访问这些教程。

什么是 XML Schema？

XML Schema 的作用是定义 XML 文档的合法构建模块，类似 DTD。

XML Schema:

  • 定义可出现在文档中的元素
  • 定义可出现在文档中的属性
  • 定义哪个元素是子元素
  • 定义子元素的次序
  • 定义子元素的数目
  • 定义元素是否为空，或者是否可包含文本
  • 定义元素和属性的数据类型
  • 定义元素和属性的默认值以及固定值

XML Schema 是 DTD 的继任者

我们认为 XML Schema 很快会在大部分网络应用程序中取代 DTD。

理由如下：

  • XML Schema 可针对未来的需求进行扩展
  • XML Schema 更完善，功能更强大
  • XML Schema 基于 XML 编写
  • XML Schema 支持数据类型
  • XML Schema 支持命名空间

XML Schema 是 W3C 标准

XML Schema 在 2001 年 5 月 2 日成为 W3C 标准。

您可以在我们的《W3C 教程》中获得更多有关 XML Schema 标准的信息。

  • Previous Page
  • Next Page

XML Schema 参考手册


XSD - <schema> 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSD - <schema> 元素

  • Previous Page
  • Next Page

<schema> 元素是每一个 XML Schema 的根元素。

<schema> 元素

<schema> 元素是每一个 XML Schema 的根元素：

<?xml version="1.0"?>

<xs:schema>

...
...

</xs:schema>

<schema> 元素可包含属性。一个 schema 声明往往看上去类似这样：

<?xml version="1.0"?>

<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema"
targetNamespace="http://www.w3school.com.cn"
xmlns="http://www.w3school.com.cn"
elementFormDefault="qualified">

...
...
</xs:schema>

代码解释：

下面的片断：

xmlns:xs="http://www.w3.org/2001/XMLSchema"

显示 schema 中用到的元素和数据类型来自命名空间 "http://www.w3.org/2001/XMLSchema"。同时它还规定了来自命名空间 "http://www.w3.org/2001/XMLSchema" 的元素和数据类型应该使用前缀 xs：

这个片断：

targetNamespace="http://www.w3school.com.cn"

显示被此 schema 定义的元素 (note, to, from, heading, body) 来自命名空间： "http://www.w3school.com.cn"。

这个片断：

xmlns="http://www.w3school.com.cn"

指出默认的命名空间是 "http://www.w3school.com.cn"。

这个片断：

elementFormDefault="qualified"

指出任何 XML 实例文档所使用的且在此 schema 中声明过的元素必须被命名空间限定。

在 XML 文档中引用 Schema

此 XML 文档含有对 XML Schema 的引用：

<?xml version="1.0"?>

<note xmlns="http://www.w3school.com.cn"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://www.w3school.com.cn note.xsd">

<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

代码解释：

下面的片断：

xmlns="http://www.w3school.com.cn"

规定了默认命名空间的声明。此声明会告知 schema 验证器，在此 XML 文档中使用的所有元素都被声明于 "http://www.w3school.com.cn" 这个命名空间。

一旦您拥有了可用的 XML Schema 实例命名空间：

xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

您就可以使用 schemaLocation 属性了。此属性有两个值。第一个值是需要使用的命名空间。第二个值是供命名空间使用的 XML schema 的位置：

xsi:schemaLocation="http://www.w3school.com.cn note.xsd"
  • Previous Page
  • Next Page

XML Schema 参考手册


XSD <any> 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSD <any> 元素

  • Previous Page
  • Next Page

<any> 元素使我们有能力通过未被 schema 规定的元素来拓展 XML 文档！

<any> 元素

<any> 元素使我们有能力通过未被 schema 规定的元素来拓展 XML 文档！

下面这个例子是从名为 "family.xsd" 的 XML schema 中引用的片段。它展示了一个针对 "person" 元素的声明。通过使用 <any> 元素，我们可以通过任何元素（在 <lastname> 之后）扩展 "person" 的内容：

<xs:element name="person">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="firstname" type="xs:string"/>
      <xs:element name="lastname" type="xs:string"/>
      <xs:any minOccurs="0"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>

现在，我们希望使用 "children" 元素来扩展 "person" 元素。这此种情况下我们就可以这么做，即使以上这个 schema 的作者没有声明任何 "children" 元素。

请看这个 schema 文件，名为 "children.xsd"：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema"
targetNamespace="http://www.w3school.com.cn"
xmlns="http://www.w3school.com.cn"
elementFormDefault="qualified">

<xs:element name="children">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="childname" type="xs:string"
      maxOccurs="unbounded"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>

</xs:schema>

下面这个 XML 文件（名为 "Myfamily.xml"），使用了来自两个不同的 schema 中的成分，"family.xsd" 和 "children.xsd"：

<?xml version="1.0" encoding="ISO-8859-1"?>

<persons xmlns="http://www.microsoft.com"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:SchemaLocation="http://www.microsoft.com family.xsd
http://www.w3school.com.cn children.xsd">

<person>
<firstname>David</firstname>
<lastname>Smith</lastname>
<children>
  <childname>mike</childname>
</children>
</person>

<person>
<firstname>Tony</firstname>
<lastname>Smith</lastname>
</person>

</persons>

上面这个 XML 文件是有效的，这是由于 schema "family.xsd" 允许我们通过在 "lastname" 元素后的可选元素来扩展 "person" 元素。

<any> 和 <anyAttribute> 均可用于制作可扩展的文档！它们使文档有能力包含未在主 XML schema 中声明过的附加元素。

  • Previous Page
  • Next Page

XML Schema 参考手册


XSD <anyAttribute> 元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSD <anyAttribute> 元素

  • Previous Page
  • Next Page

<anyAttribute> 元素使我们有能力通过未被 schema 规定的属性来扩展 XML 文档！

<anyAttribute> 元素

<anyAttribute> 元素使我们有能力通过未被 schema 规定的属性来扩展 XML 文档！

下面的例子是来自名为 "family.xsd" 的 XML schema 的一个片段。它为我们展示了针对 "person" 元素的一个声明。通过使用 <anyAttribute> 元素，我们就可以向 "person" 元素添加任意数量的属性：

<xs:element name="person">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="firstname" type="xs:string"/>
      <xs:element name="lastname" type="xs:string"/>
    </xs:sequence>
    <xs:anyAttribute/>
  </xs:complexType>
</xs:element>

现在，我们希望通过 "gender" 属性来扩展 "person" 元素。在这种情况下我们就可以这样做，即使这个 schema 的作者从未声明过任何 "gender" 属性。

请看这个 schema 文件，名为 "attribute.xsd"：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema"
targetNamespace="http://www.w3school.com.cn"
xmlns="http://www.w3school.com.cn"
elementFormDefault="qualified">

<xs:attribute name="gender">
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="male|female"/>
    </xs:restriction>
  </xs:simpleType>
</xs:attribute>

</xs:schema>

下面这个 XML（名为 "Myfamily.xml"），使用了来自不同 schema 的成分，"family.xsd" 和 "attribute.xsd"：

<?xml version="1.0" encoding="ISO-8859-1"?>

<persons xmlns="http://www.microsoft.com"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:SchemaLocation="http://www.microsoft.com family.xsd
http://www.w3school.com.cn attribute.xsd">

<person gender="female">
<firstname>Jane</firstname>
<lastname>Smith</lastname>
</person>

<person gender="male">
<firstname>David</firstname>
<lastname>Smith</lastname>
</person>

</persons>

上面这个 XML 文件是有效的，这是因为 schema "family.xsd" 允许我们向 "person" 元素添加属性。

<any> 和 <anyAttribute> 均可用于制作可扩展的文档！它们使文档有能力包含未在主 XML schema 中声明过的附加元素。

  • Previous Page
  • Next Page

XML Schema 参考手册


XSD 带有混合内容的复合类型

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSD 带有混合内容的复合类型

  • Previous Page
  • Next Page

混合的复合类型可包含属性、元素以及文本。

带有混合内容的复合类型

XML 元素，"letter"，含有文本以及其他元素：

<letter>
Dear Mr.<name>John Smith</name>.
Your order <orderid>1032</orderid>
will be shipped on <shipdate>2001-07-13</shipdate>.
</letter>

下面这个 schema 声明了这个 "letter" 元素：

<xs:element name="letter">
  <xs:complexType mixed="true">
    <xs:sequence>
      <xs:element name="name" type="xs:string"/>
      <xs:element name="orderid" type="xs:positiveInteger"/>
      <xs:element name="shipdate" type="xs:date"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>

注释：为了使字符数据可以出现在 "letter" 的子元素之间，mixed 属性必须被设置为 "true"。<xs:sequence> 标签 (name、orderid 以及 shipdate ) 意味着被定义的元素必须依次出现在 "letter" 元素内部。

我们也可以为 complexType 元素起一个名字，并让 "letter" 元素的 type 属性引用 complexType 的这个名称（通过这个方法，若干元素均可引用同一个复合类型）：

<xs:element name="letter" type="lettertype"/>

<xs:complexType name="lettertype" mixed="true">
  <xs:sequence>
    <xs:element name="name" type="xs:string"/>
    <xs:element name="orderid" type="xs:positiveInteger"/>
    <xs:element name="shipdate" type="xs:date"/>
  </xs:sequence>
</xs:complexType>
  • Previous Page
  • Next Page

XML Schema 参考手册


XSD 复合空元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSD 复合空元素

  • Previous Page
  • Next Page

空的复合元素不能包含内容，只能含有属性。

复合空元素：

一个空的 XML 元素：

<product prodid="1345" />

上面的 "product" 元素根本没有内容。为了定义无内容的类型，我们就必须声明一个在其内容中只能包含元素的类型，但是实际上我们并不会声明任何元素，比如这样：

<xs:element name="product">
  <xs:complexType>
    <xs:complexContent>
      <xs:restriction base="xs:integer">
        <xs:attribute name="prodid" type="xs:positiveInteger"/>
      </xs:restriction>
    </xs:complexContent>
  </xs:complexType>
</xs:element>

在上面的例子中，我们定义了一个带有复合内容的复合类型。complexContent 元素给出的信号是，我们打算限定或者拓展某个复合类型的内容模型，而 integer 限定则声明了一个属性但不会引入任何的元素内容。

不过，也可以更加紧凑地声明此 "product" 元素：

<xs:element name="product">
  <xs:complexType>
    <xs:attribute name="prodid" type="xs:positiveInteger"/>
  </xs:complexType>
</xs:element>

或者您可以为一个 complexType 元素起一个名字，然后为 "product" 元素设置一个 type 属性并引用这个 complexType 名称（通过使用此方法，若干个元素均可引用相同的复合类型）：

<xs:element name="product" type="prodtype"/>

<xs:complexType name="prodtype">
  <xs:attribute name="prodid" type="xs:positiveInteger"/>
</xs:complexType>
  • Previous Page
  • Next Page

XML Schema 参考手册


XSD 复合类型 - 仅含元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSD 复合类型 - 仅含元素

  • Previous Page
  • Next Page

“仅含元素”的复合类型含有一个仅包含其他元素的元素。

复合类型仅包含元素

XML 元素，"person"，仅包含其他的元素：

<person>
<firstname>John</firstname>
<lastname>Smith</lastname>
</person>

您可在 schema 中这样定义 "person" 元素：

<xs:element name="person">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="firstname" type="xs:string"/>
      <xs:element name="lastname" type="xs:string"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>

请留意这个 <xs:sequence>。它意味着被定义的元素必须按上面的次序出现在 "person" 元素中。

或者您可以为 complexType 元素设定一个名称，并让 "person" 元素的 type 属性来引用此名称（如使用此方法，若干元素均可引用相同的复合类型）：

<xs:element name="person" type="persontype"/>

<xs:complexType name="persontype">
  <xs:sequence>
    <xs:element name="firstname" type="xs:string"/>
    <xs:element name="lastname" type="xs:string"/>
  </xs:sequence>
</xs:complexType>
  • Previous Page
  • Next Page

XML Schema 参考手册


XSD 复合类型指示器

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSD 复合类型指示器

  • Previous Page
  • Next Page

通过指示器，我们可以控制在文档中使用元素的方式。

指示器

有七种指示器：

Order 指示器：

  • All
  • Choice
  • Sequence

Occurrence 指示器：

  • maxOccurs
  • minOccurs

Group 指示器：

  • Group name
  • attributeGroup name

Order 指示器

Order 指示器用于定义元素的顺序。

All 指示器

<all> 指示器规定子元素可以按照任意顺序出现，且每个子元素必须只出现一次：

<xs:element name="person">
  <xs:complexType>
    <xs:all>
      <xs:element name="firstname" type="xs:string"/>
      <xs:element name="lastname" type="xs:string"/>
    </xs:all>
  </xs:complexType>
</xs:element>

注释：当使用 <all> 指示器时，你可以把 <minOccurs> 设置为 0 或者 1，并仅可把 <maxOccurs> 指示器设置为 1（稍后将讲解 <minOccurs> 以及 <maxOccurs>）。

Choice 指示器

<choice> 指示器规定可出现某个子元素或者可出现另外一个子元素（非此即彼）：

<xs:element name="person">
  <xs:complexType>
    <xs:choice>
      <xs:element name="employee" type="employee"/>
      <xs:element name="member" type="member"/>
    </xs:choice>
  </xs:complexType>
</xs:element>

Sequence 指示器

<sequence> 规定子元素必须按照特定的顺序出现：

<xs:element name="person">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="firstname" type="xs:string"/>
      <xs:element name="lastname" type="xs:string"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>

Occurrence 指示器

Occurrence 指示器用于定义某个元素出现的频率。

注释：对于所有的 "Order" 和 "Group" 指示器（any、all、choice、sequence、group name 以及 group reference），其中的 maxOccurs 以及 minOccurs 的默认值均为 1。

maxOccurs 指示器

<maxOccurs> 指示器可规定某个元素可出现的最大次数：

<xs:element name="person">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="full_name" type="xs:string"/>
      <xs:element name="child_name" type="xs:string" maxOccurs="10"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>

上面的例子表明，子元素 "child_name" 可在 "person" 元素中最少出现一次（其中 minOccurs 的默认值是 1），最多出现 10 次。

minOccurs 指示器

<minOccurs> 指示器可规定某个元素能够出现的最小次数：

<xs:element name="person">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="full_name" type="xs:string"/>
      <xs:element name="child_name" type="xs:string"
      maxOccurs="10" minOccurs="0"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>

上面的例子表明，子元素 "child_name" 可在 "person" 元素中出现最少 0 次，最多出现 10 次。

提示：如需使某个元素的出现次数不受限制，请使用 maxOccurs="unbounded" 这个声明：

一个实际的例子：

名为 "Myfamily.xml" 的 XML 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>

<persons xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:noNamespaceSchemaLocation="family.xsd">

<person>
<full_name>Tony Smith</full_name>
<child_name>Cecilie</child_name>
</person>

<person>
<full_name>David Smith</full_name>
<child_name>Jogn</child_name>
<child_name>mike</child_name>
<child_name>kyle</child_name>
<child_name>mary</child_name>
</person>

<person>
<full_name>Michael Smith</full_name>
</person>

</persons>

上面这个 XML 文件含有一个名为 "persons" 的根元素。在这个根元素内部，我们定义了三个 "person" 元素。每个 "person" 元素必须含有一个 "full_name" 元素，同时它可以包含多至 5 个 "child_name" 元素。

这是schema文件"family.xsd"：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema"
elementFormDefault="qualified">

<xs:element name="persons">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="person" maxOccurs="unbounded">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="full_name" type="xs:string"/>
            <xs:element name="child_name" type="xs:string"
            minOccurs="0" maxOccurs="5"/>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>

</xs:schema>

Group 指示器

Group 指示器用于定义相关的数批元素。

元素组

元素组通过 group 声明进行定义：

<xs:group name="组名称">
  ...
</xs:group>

您必须在 group 声明内部定义一个 all、choice 或者 sequence 元素。下面这个例子定义了名为 "persongroup" 的 group，它定义了必须按照精确的顺序出现的一组元素：

<xs:group name="persongroup">
  <xs:sequence>
    <xs:element name="firstname" type="xs:string"/>
    <xs:element name="lastname" type="xs:string"/>
    <xs:element name="birthday" type="xs:date"/>
  </xs:sequence>
</xs:group>

在您把 group 定义完毕以后，就可以在另一个定义中引用它了：

<xs:group name="persongroup">
  <xs:sequence>
    <xs:element name="firstname" type="xs:string"/>
    <xs:element name="lastname" type="xs:string"/>
    <xs:element name="birthday" type="xs:date"/>
  </xs:sequence>
</xs:group>

<xs:element name="person" type="personinfo"/>

<xs:complexType name="personinfo">
  <xs:sequence>
    <xs:group ref="persongroup"/>
    <xs:element name="country" type="xs:string"/>
  </xs:sequence>
</xs:complexType>

属性组

属性组通过 attributeGroup 声明来进行定义：

<xs:attributeGroup name="组名称">
  ...
</xs:attributeGroup>

下面这个例子定义了名为 "personattrgroup" 的一个属性组：

<xs:attributeGroup name="personattrgroup">
  <xs:attribute name="firstname" type="xs:string"/>
  <xs:attribute name="lastname" type="xs:string"/>
  <xs:attribute name="birthday" type="xs:date"/>
</xs:attributeGroup>

在您已定义完毕属性组之后，就可以在另一个定义中引用它了，就像这样：

<xs:attributeGroup name="personattrgroup">
  <xs:attribute name="firstname" type="xs:string"/>
  <xs:attribute name="lastname" type="xs:string"/>
  <xs:attribute name="birthday" type="xs:date"/>
</xs:attributeGroup>

<xs:element name="person">
  <xs:complexType>
    <xs:attributeGroup ref="personattrgroup"/>
  </xs:complexType>
</xs:element>
  • Previous Page
  • Next Page

XML Schema 参考手册


XSD 复合元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSD 复合元素

  • Previous Page
  • Next Page

复合元素包含了其他的元素及/或属性。

什么是复合元素？

复合元素指包含其他元素及/或属性的 XML 元素。

有四种类型的复合元素：

  • 空元素
  • 包含其他元素的元素
  • 仅包含文本的元素
  • 包含元素和文本的元素

注释：上述元素均可包含属性！

复合元素的例子

复合元素，"product"，是空的：

<product pid="1345"/>

复合元素，"employee"，仅包含其他元素：

<employee>
<firstname>John</firstname>
<lastname>Smith</lastname>
</employee>

复合元素，"food"，仅包含文本：

<food type="dessert">Ice cream</food>

复合元素，"description"，包含元素和文本：

<description>
It happened on <date lang="norwegian">03.03.99</date> ....
</description>

如何定义复合元素？

请看这个复合 XML 元素，"employee"，仅包含其他元素：

<employee>
<firstname>John</firstname>
<lastname>Smith</lastname>
</employee>

在 XML Schema 中，我们有两种方式来定义复合元素：

1. 通过命名此元素，可直接对"employee"元素进行声明，就像这样：

<xs:element name="employee">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="firstname" type="xs:string"/>
      <xs:element name="lastname" type="xs:string"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>

假如您使用上面所描述的方法，那么仅有 "employee" 可使用所规定的复合类型。请注意其子元素，"firstname" 以及 "lastname"，被包围在指示器 <sequence>中。这意味着子元素必须以它们被声明的次序出现。您会在 XSD 指示器 这一节学习更多有关指示器的知识。

2. "employee" 元素可以使用 type 属性，这个属性的作用是引用要使用的复合类型的名称：

<xs:element name="employee" type="personinfo"/>

<xs:complexType name="personinfo">
  <xs:sequence>
    <xs:element name="firstname" type="xs:string"/>
    <xs:element name="lastname" type="xs:string"/>
  </xs:sequence>
</xs:complexType>

如果您使用了上面所描述的方法，那么若干元素均可以使用相同的复合类型，比如这样：

<xs:element name="employee" type="personinfo"/>
<xs:element name="student" type="personinfo"/>
<xs:element name="member" type="personinfo"/>

<xs:complexType name="personinfo">
  <xs:sequence>
    <xs:element name="firstname" type="xs:string"/>
    <xs:element name="lastname" type="xs:string"/>
  </xs:sequence>
</xs:complexType>

您也可以在已有的复合元素之上以某个复合元素为基础，然后添加一些元素，就像这样：

<xs:element name="employee" type="fullpersoninfo"/>

<xs:complexType name="personinfo">
  <xs:sequence>
    <xs:element name="firstname" type="xs:string"/>
    <xs:element name="lastname" type="xs:string"/>
  </xs:sequence>
</xs:complexType>

<xs:complexType name="fullpersoninfo">
  <xs:complexContent>
    <xs:extension base="personinfo">
      <xs:sequence>
        <xs:element name="address" type="xs:string"/>
        <xs:element name="city" type="xs:string"/>
        <xs:element name="country" type="xs:string"/>
      </xs:sequence>
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
  • Previous Page
  • Next Page

XML Schema 参考手册


XSD 简易元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSD 简易元素

  • Previous Page
  • Next Page

XML Schema 可定义 XML 文件的元素。

简易元素指那些只包含文本的元素。它不会包含任何其他的元素或属性。

什么是简易元素？

简易元素指那些仅包含文本的元素。它不会包含任何其他的元素或属性。

不过，“仅包含文本”这个限定却很容易造成误解。文本有很多类型。它可以是 XML Schema 定义中包括的类型中的一种（布尔、字符串、数据等等），或者它也可以是您自行定义的定制类型。

您也可向数据类型添加限定（即 facets），以此来限制它的内容，或者您可以要求数据匹配某种特定的模式。

定义简易元素

定义简易元素的语法：

<xs:element name="xxx" type="yyy"/>

此处 xxx 指元素的名称，yyy 指元素的数据类型。XML Schema 拥有很多内建的数据类型。

最常用的类型是：

  • xs:string
  • xs:decimal
  • xs:integer
  • xs:boolean
  • xs:date
  • xs:time

例子：

这是一些 XML 元素：

<lastname>Smith</lastname>
<age>28</age>
<dateborn>1980-03-27</dateborn>

这是相应的简易元素定义：

<xs:element name="lastname" type="xs:string"/>
<xs:element name="age" type="xs:integer"/>
<xs:element name="dateborn" type="xs:date"/>

简易元素的默认值和固定值

简易元素可拥有指定的默认值或固定值。

当没有其他的值被规定时，默认值就会自动分配给元素。

在下面的例子中，缺省值是 "red"：

<xs:element name="color" type="xs:string" default="red"/>

固定值同样会自动分配给元素，并且您无法规定另外一个值。

在下面的例子中，固定值是 "red"：

<xs:element name="color" type="xs:string" fixed="red"/>
  • Previous Page
  • Next Page

XML Schema 参考手册


XSD 仅含文本复合元素

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSD 仅含文本复合元素

  • Previous Page
  • Next Page

仅含文本的复合元素可包含文本和属性。

仅含文本的复合元素

此类型仅包含简易的内容（文本和属性），因此我们要向此内容添加 simpleContent 元素。当使用简易内容时，我们就必须在 simpleContent 元素内定义扩展或限定，就像这样：

<xs:element name="某个名称">
  <xs:complexType>
    <xs:simpleContent>
      <xs:extension base="basetype">
        ....
        ....
      </xs:extension>
    </xs:simpleContent>
  </xs:complexType>
</xs:element>

或者：

<xs:element name="某个名称">
  <xs:complexType>
    <xs:simpleContent>
      <xs:restriction base="basetype">
        ....
        ....
      </xs:restriction>
    </xs:simpleContent>
  </xs:complexType>
</xs:element>

提示：请使用 extension 或 restriction 元素来扩展或限制元素的基本简易类型。

这里有一个 XML 元素的例子，"shoesize"，其中仅包含文本：

<shoesize country="france">35</shoesize>

下面这个例子声明了一个复合类型，其内容被定义为整数值，并且 "shoesize" 元素含有名为 "country" 的属性：

<xs:element name="shoesize">
  <xs:complexType>
    <xs:simpleContent>
      <xs:extension base="xs:integer">
        <xs:attribute name="country" type="xs:string" />
      </xs:extension>
    </xs:simpleContent>
  </xs:complexType>
</xs:element>

我们也可为 complexType 元素设定一个名称，并让 "shoesize" 元素的 type 属性来引用此名称（通过使用此方法，若干元素均可引用相同的复合类型）：

<xs:element name="shoesize" type="shoetype"/>

<xs:complexType name="shoetype">
  <xs:simpleContent>
    <xs:extension base="xs:integer">
      <xs:attribute name="country" type="xs:string" />
    </xs:extension>
  </xs:simpleContent>
</xs:complexType>
  • Previous Page
  • Next Page

XML Schema 参考手册


XSD 日期及时间数据类型（Date and Time Data Types）

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSD 日期及时间数据类型（Date and Time Data Types）

  • Previous Page
  • Next Page

日期及时间数据类型用于包含日期和时间的值。

日期数据类型（Date Data Type）

日期数据类型用于定义日期。

日期使用此格式进行定义："YYYY-MM-DD"，其中：

  • YYYY 表示年份
  • MM 表示月份
  • DD 表示天数

注释：所有的成分都是必需的！

下面是一个有关 schema 中日期声明的例子：

<xs:element name="start" type="xs:date"/>

文档中的元素看上去应该类似这样：

<start>2002-09-24</start>

时区

如需规定一个时区，您也可以通过在日期后加一个 "Z" 的方式，使用世界调整时间（UTC time）来输入一个日期 - 比如这样：

<start>2002-09-24Z</start>

或者也可以通过在日期后添加一个正的或负时间的方法，来规定以世界调整时间为准的偏移量 - 比如这样：

<start>2002-09-24-06:00</start>

或者：

<start>2002-09-24+06:00</start>

时间数据类型（Time Data Type）

时间数据类型用于定义时间。

时间使用下面的格式来定义："hh:mm:ss"，其中

  • hh 表示小时
  • mm 表示分钟
  • ss 表示秒

注释：所有的成分都是必需的！

下面是一个有关 schema 中时间声明的例子：

<xs:element name="start" type="xs:time"/>

文档中的元素看上去应该类似这样：

<start>09:00:00</start>

或者类似这样：

<start>09:30:10.5</start>

时区

如需规定一个时区，您也可以通过在时间后加一个 "Z" 的方式，使用世界调整时间（UTC time）来输入一个时间 - 比如这样：

<start>09:30:10Z</start>

或者也可以通过在时间后添加一个正的或负时间的方法，来规定以世界调整时间为准的偏移量 - 比如这样：

<start>09:30:10-06:00</start>

或者：

<start>09:30:10+06:00</start>

日期时间数据类型（DateTime Data Type）

日期时间数据类型用于定义日期和时间。

日期时间使用下面的格式进行定义："YYYY-MM-DDThh:mm:ss"，其中：

  • YYYY 表示年份
  • MM 表示月份
  • DD 表示日
  • T 表示必需的时间部分的起始
  • hh 表示小时
  • mm 表示分钟
  • ss 表示秒

注释：所有的成分都是必需的！

下面是一个有关 schema 中日期时间声明的例子：

<xs:element name="startdate" type="xs:dateTime"/>

文档中的元素看上去应该类似这样：

<startdate>2002-05-30T09:00:00</startdate>

或者类似这样：

<startdate>2002-05-30T09:30:10.5</startdate>

时区

如需规定一个时区，您也可以通过在日期时间后加一个 "Z" 的方式，使用世界调整时间（UTC time）来输入一个日期时间 - 比如这样：

<startdate>2002-05-30T09:30:10Z</startdate>

或者也可以通过在时间后添加一个正的或负时间的方法，来规定以世界调整时间为准的偏移量 - 比如这样：

<startdate>2002-05-30T09:30:10-06:00</startdate>

或者：

<startdate>2002-05-30T09:30:10+06:00</startdate>

持续时间数据类型（Duration Data Type）

持续时间数据类型用于规定时间间隔。

时间间隔使用下面的格式来规定："PnYnMnDTnHnMnS"，其中：

  • P 表示周期(必需)
  • nY 表示年数
  • nM 表示月数
  • nD 表示天数
  • T 表示时间部分的起始 （如果您打算规定小时、分钟和秒，则此选项为必需）
  • nH 表示小时数
  • nM 表示分钟数
  • nS 表示秒数

下面是一个有关 schema 中持续时间声明的例子：

<xs:element name="period" type="xs:duration"/>

文档中的元素看上去应该类似这样：

<period>P5Y</period>

上面的例子表示一个 5 年的周期。

或者类似这样：

<period>P5Y2M10D</period>

上面的例子表示一个 5 年、2 个月及 10 天的周期。

或者类似这样：

<period>P5Y2M10DT15H</period>

上面的例子表示一个 5 年、2 个月、10 天及 15 小时的周期。

或者类似这样：

<period>PT15H</period>

上面的例子表示一个 15 小时的周期。

负的持续时间

如需规定一个负的持续时间，请在 P 之前输入减号：

<period>-P10D</period>

上面的例子表示一个负 10 天的周期。

日期和时间数据类型

名称 | 描述
date | 定义一个日期值
dateTime | 定义一个日期和时间值
duration | 定义一个时间间隔
gDay | 定义日期的一个部分 - 天 (DD)
gMonth | 定义日期的一个部分 - 月 (MM)
gMonthDay | 定义日期的一个部分 - 月和天 (MM-DD)
gYear | 定义日期的一个部分 - 年 (YYYY)
gYearMonth | 定义日期的一个部分 - 年和月 (YYYY-MM)
time | 定义一个时间值

对日期数据类型的限定（Restriction）

可与日期数据类型一同使用的限定：

  • enumeration
  • maxExclusive
  • maxInclusive
  • minExclusive
  • minInclusive
  • pattern
  • whiteSpace
  • Previous Page
  • Next Page

XML Schema 参考手册


XSD 属性

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSD 属性

  • Previous Page
  • Next Page

所有的属性均作为简易类型来声明。

什么是属性？

简易元素无法拥有属性。假如某个元素拥有属性，它就会被当作某种复合类型。但是属性本身总是作为简易类型被声明的。

如何声明属性？

定义属性的语法是：

<xs:attribute name="xxx" type="yyy"/>

在此处，xxx 指属性名称，yyy 则规定属性的数据类型。XML Schema 拥有很多内建的数据类型。

最常用的类型是：

  • xs:string
  • xs:decimal
  • xs:integer
  • xs:boolean
  • xs:date
  • xs:time

实例

这是带有属性的 XML 元素：

<lastname lang="EN">Smith</lastname>

这是对应的属性定义：

<xs:attribute name="lang" type="xs:string"/>

属性的默认值和固定值

属性可拥有指定的默认值或固定值。

当没有其他的值被规定时，默认值就会自动分配给元素。

在下面的例子中，缺省值是 "EN"：

<xs:attribute name="lang" type="xs:string" default="EN"/>

固定值同样会自动分配给元素，并且您无法规定另外的值。

在下面的例子中，固定值是 "EN"：

<xs:attribute name="lang" type="xs:string" fixed="EN"/>

可选的和必需的属性

在缺省的情况下，属性是可选的。如需规定属性为必选，请使用 "use" 属性：

<xs:attribute name="lang" type="xs:string" use="required"/>

对内容的限定

当 XML 元素或属性拥有被定义的数据类型时，就会向元素或属性的内容添加限定。

假如 XML 元素的类型是 "xs:date"，而其包含的内容是类似 "Hello World" 的字符串，元素将不会（通过）验证。

通过 XML schema，您也可向您的 XML 元素及属性添加自己的限定。这些限定被称为 facet（编者注：意为(多面体的)面，可译为限定面）。您会在下一节了解到更多有关 facet 的知识。

  • Previous Page
  • Next Page

XML Schema 参考手册


XSD 数值数据类型（Numeric Data Types）

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSD 数值数据类型（Numeric Data Types）

  • Previous Page
  • Next Page

十进制数据类型用于数值。

十进制数据类型

十进制数据类型用于规定一个数值。

下面是一个关于某个 scheme 中十进制数声明的例子。

<xs:element name="prize" type="xs:decimal"/>

文档中的元素看上去应该类似这样：

<prize>999.50</prize>

或者类似这样：

<prize>+999.5450</prize>

或者类似这样：

<prize>-999.5230</prize>

或者类似这样：

<prize>0</prize>

或者类似这样：

<prize>14</prize>

注释：您可规定的十进制数字的最大位数是 18 位。

整数数据类型

整数数据类型用于规定无小数成分的数值。

下面是一个关于某个 scheme 中整数声明的例子。

<xs:element name="prize" type="xs:integer"/>

文档中的元素看上去应该类似这样：

<prize>999</prize>

或者类似这样：

<prize>+999</prize>

或者类似这样：

<prize>-999</prize>

或者类似这样：

<prize>0</prize>

数值数据类型

请注意，下面所有的数据类型均源自于十进制数据类型（除 decimal 本身以外）！

名字 | 秒数
byte | 有正负的 8 位整数
decimal | 十进制数
int | 有正负的 32 位整数
integer | 整数值
long | 有正负的 64 位整数
negativeInteger | 仅包含负值的整数 ( .., -2, -1.)
nonNegativeInteger | 仅包含非负值的整数 (0, 1, 2, ..)
nonPositiveInteger | 仅包含非正值的整数 (.., -2, -1, 0)
positiveInteger | 仅包含正值的整数 (1, 2, ..)
short | 有正负的 16 位整数
unsignedLong | 无正负的 64 位整数
unsignedInt | 无正负的 32 位整数
unsignedShort | 无正负的 16 位整数
unsignedByte | 无正负的 8 位整数

对数值数据类型的限定（Restriction）

可与数值数据类型一同使用的限定：

  • enumeration
  • fractionDigits
  • maxExclusive
  • maxInclusive
  • minExclusive
  • minInclusive
  • pattern
  • totalDigits
  • whiteSpace
  • Previous Page
  • Next Page

XML Schema 参考手册


XSD 限定 / Facets

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSD 限定 / Facets

  • Previous Page
  • Next Page

限定（restriction）用于为 XML 元素或者属性定义可接受的值。对 XML 元素的限定被称为 facet。

对值的限定

下面的例子定义了带有一个限定且名为 "age" 的元素。age 的值不能低于 0 或者高于 120：

<xs:element name="age">

<xs:simpleType>
  <xs:restriction base="xs:integer">
    <xs:minInclusive value="0"/>
    <xs:maxInclusive value="120"/>
  </xs:restriction>
</xs:simpleType>

</xs:element>

对一组值的限定

如需把 XML 元素的内容限制为一组可接受的值，我们要使用枚举约束（enumeration constraint）。

下面的例子定义了带有一个限定的名为 "car" 的元素。可接受的值只有：Audi, Golf, BMW：

<xs:element name="car">

<xs:simpleType>
  <xs:restriction base="xs:string">
    <xs:enumeration value="Audi"/>
    <xs:enumeration value="Golf"/>
    <xs:enumeration value="BMW"/>
  </xs:restriction>
</xs:simpleType>

</xs:element>

上面的例子也可以被写为：

<xs:element name="car" type="carType"/>

<xs:simpleType name="carType">
  <xs:restriction base="xs:string">
    <xs:enumeration value="Audi"/>
    <xs:enumeration value="Golf"/>
    <xs:enumeration value="BMW"/>
  </xs:restriction>
</xs:simpleType>

注释：在这种情况下，类型 "carType" 可被其他元素使用，因为它不是 "car" 元素的组成部分。

对一系列值的限定

如需把 XML 元素的内容限制定义为一系列可使用的数字或字母，我们要使用模式约束（pattern constraint）。

下面的例子定义了带有一个限定的名为 "letter" 的元素。可接受的值只有小写字母 a - z 其中的一个：

<xs:element name="letter">

<xs:simpleType>
  <xs:restriction base="xs:string">
    <xs:pattern value="[a-z]"/>
  </xs:restriction>
</xs:simpleType>

</xs:element>

下一个例子定义了带有一个限定的名为 "initials" 的元素。可接受的值是大写字母 A - Z 其中的三个：

<xs:element name="initials">

<xs:simpleType>
  <xs:restriction base="xs:string">
    <xs:pattern value="[A-Z][A-Z][A-Z]"/>
  </xs:restriction>
</xs:simpleType>

</xs:element>

下一个例子也定义了带有一个限定的名为 "initials" 的元素。可接受的值是大写或小写字母 a - z 其中的三个：

<xs:element name="initials">

<xs:simpleType>
  <xs:restriction base="xs:string">
    <xs:pattern value="[a-zA-Z][a-zA-Z][a-zA-Z]"/>
  </xs:restriction>
</xs:simpleType>

</xs:element>

下一个例子定义了带有一个限定的名为 "choice 的元素。可接受的值是字母 x, y 或 z 中的一个：

<xs:element name="choice">

<xs:simpleType>
  <xs:restriction base="xs:string">
    <xs:pattern value="[xyz]"/>
  </xs:restriction>
</xs:simpleType>

</xs:element>

下一个例子定义了带有一个限定的名为 "prodid" 的元素。可接受的值是五个阿拉伯数字的一个序列，且每个数字的范围是 0-9：

<xs:element name="prodid">

<xs:simpleType>
  <xs:restriction base="xs:integer">
    <xs:pattern value="[0-9][0-9][0-9][0-9][0-9]"/>
  </xs:restriction>
</xs:simpleType>

</xs:element>

对一系列值的其他限定

下面的例子定义了带有一个限定的名为 "letter" 的元素。可接受的值是 a - z 中零个或多个字母：

<xs:element name="letter">

<xs:simpleType>
  <xs:restriction base="xs:string">
    <xs:pattern value="([a-z])*"/>
  </xs:restriction>
</xs:simpleType>

</xs:element>

下面的例子定义了带有一个限定的名为 "letter" 的元素。可接受的值是一对或多对字母，每对字母由一个小写字母后跟一个大写字母组成。举个例子，"sToP"将会通过这种模式的验证，但是 "Stop"、"STOP" 或者 "stop" 无法通过验证：

<xs:element name="letter">

<xs:simpleType>
  <xs:restriction base="xs:string">
    <xs:pattern value="([a-z][A-Z])+"/>
  </xs:restriction>
</xs:simpleType>

</xs:element>

下面的例子定义了带有一个限定的名为 "gender" 的元素。可接受的值是 male 或者 female：

<xs:element name="gender">

<xs:simpleType>
  <xs:restriction base="xs:string">
    <xs:pattern value="male|female"/>
  </xs:restriction>
</xs:simpleType>

</xs:element>

下面的例子定义了带有一个限定的名为 "password" 的元素。可接受的值是由 8 个字符组成的一行字符，这些字符必须是大写或小写字母 a - z 亦或数字 0 - 9：

<xs:element name="password">

<xs:simpleType>
  <xs:restriction base="xs:string">
    <xs:pattern value="[a-zA-Z0-9]{8}"/>
  </xs:restriction>
</xs:simpleType>

</xs:element>

对空白字符的限定

如需规定对空白字符（whitespace characters）的处理方式，我们需要使用 whiteSpace 限定。

下面的例子定义了带有一个限定的名为 "address" 的元素。这个 whiteSpace 限定被设置为 "preserve"，这意味着 XML 处理器不会移除任何空白字符：

<xs:element name="address">

<xs:simpleType>
  <xs:restriction base="xs:string">
    <xs:whiteSpace value="preserve"/>
  </xs:restriction>
</xs:simpleType>

</xs:element>

这个例子也定义了带有一个限定的名为 "address" 的元素。这个 whiteSpace 限定被设置为 "replace"，这意味着 XML 处理器将移除所有空白字符（换行、回车、空格以及制表符）：

<xs:element name="address">

<xs:simpleType>
  <xs:restriction base="xs:string">
    <xs:whiteSpace value="replace"/>
  </xs:restriction>
</xs:simpleType>

</xs:element>

这个例子也定义了带有一个限定的名为 "address" 的元素。这个 whiteSpace 限定被设置为 "collapse"，这意味着 XML 处理器将移除所有空白字符（换行、回车、空格以及制表符会被替换为空格，开头和结尾的空格会被移除，而多个连续的空格会被缩减为一个单一的空格）：

<xs:element name="address">

<xs:simpleType>
  <xs:restriction base="xs:string">
    <xs:whiteSpace value="collapse"/>
  </xs:restriction>
</xs:simpleType>

</xs:element>

对长度的限定

如需限制元素中值的长度，我们需要使用 length、maxLength 以及 minLength 限定。

本例定义了带有一个限定且名为 "password" 的元素。其值必须精确到 8 个字符：

<xs:element name="password">

<xs:simpleType>
  <xs:restriction base="xs:string">
    <xs:length value="8"/>
  </xs:restriction>
</xs:simpleType>

</xs:element>

这个例子也定义了带有一个限定的名为 "password" 的元素。其值最小为 5 个字符，最大为 8 个字符：

<xs:element name="password">

<xs:simpleType>
  <xs:restriction base="xs:string">
    <xs:minLength value="5"/>
    <xs:maxLength value="8"/>
  </xs:restriction>
</xs:simpleType>

</xs:element>

数据类型的限定

限定 | 描述
enumeration | 定义可接受值的一个列表
fractionDigits | 定义所允许的最大的小数位数。必须大于等于0。
length | 定义所允许的字符或者列表项目的精确数目。必须大于或等于0。
maxExclusive | 定义数值的上限。所允许的值必须小于此值。
maxInclusive | 定义数值的上限。所允许的值必须小于或等于此值。
maxLength | 定义所允许的字符或者列表项目的最大数目。必须大于或等于0。
minExclusive | 定义数值的下限。所允许的值必需大于此值。
minInclusive | 定义数值的下限。所允许的值必需大于或等于此值。
minLength | 定义所允许的字符或者列表项目的最小数目。必须大于或等于0。
pattern | 定义可接受的字符的精确序列。
totalDigits | 定义所允许的阿拉伯数字的精确位数。必须大于0。
whiteSpace | 定义空白字符（换行、回车、空格以及制表符）的处理方式。
  • Previous Page
  • Next Page

XML Schema 参考手册


XSD 元素替换（Element Substitution）

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSD 元素替换（Element Substitution）

  • Previous Page
  • Next Page

通过 XML Schema，一个元素可对另一个元素进行替换。

元素替换

让我们举例说明：我们的用户来自英国和挪威。我们希望有能力让用户选择在 XML 文档中使用挪威语的元素名称还是英语的元素名称。

为了解决这个问题，我们可以在 XML schema 中定义一个 substitutionGroup。首先，我们声明主元素，然后我们会声明次元素，这些次元素可声明它们能够替换主元素。

<xs:element name="name" type="xs:string"/>
<xs:element name="navn" substitutionGroup="name"/>

在上面的例子中，"name" 元素是主元素，而 "navn" 元素可替代 "name" 元素。

请看一个 XML schema 的片段：

<xs:element name="name" type="xs:string"/>
<xs:element name="navn" substitutionGroup="name"/>

<xs:complexType name="custinfo">
  <xs:sequence>
    <xs:element ref="name"/>
  </xs:sequence>
</xs:complexType>

<xs:element name="customer" type="custinfo"/>
<xs:element name="kunde" substitutionGroup="customer"/>

有效的 XML 文档类似这样（根据上面的 schema）：

<customer>
  <name>John Smith</name>
</customer>

或类似这样：

<kunde>
  <navn>John Smith</navn>
</kunde>

阻止元素替换

为防止其他的元素替换某个指定的元素，请使用 block 属性：

<xs:element name="name" type="xs:string" block="substitution"/>

请看某个 XML schema 的片段：

<xs:element name="name" type="xs:string" block="substitution"/>
<xs:element name="navn" substitutionGroup="name"/>

<xs:complexType name="custinfo">
  <xs:sequence>
    <xs:element ref="name"/>
  </xs:sequence>
</xs:complexType>

<xs:element name="customer" type="custinfo" block="substitution"/>
<xs:element name="kunde" substitutionGroup="customer"/>

合法的 XML 文档应该类似这样（根据上面的 schema）：

<customer>
  <name>John Smith</name>
</customer>

但是下面的文档不再合法：

<kunde>
  <navn>John Smith</navn>
</kunde>

使用 substitutionGroup

可替换元素的类型必须和主元素相同，或者从主元素衍生而来。假如可替换元素的类型与主元素的类型相同，那么您就不必规定可替换元素的类型了。

请注意，substitutionGroup 中的所有元素（主元素和可替换元素）必须被声明为全局元素，否则就无法工作！

什么是全局元素（Global Elements）？

全局元素指 "schema" 元素的直接子元素！本地元素（Local elements）指嵌套在其他元素中的元素。

  • Previous Page
  • Next Page

XML Schema 参考手册


XSD 杂项数据类型（Miscellaneous Data Types）

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSD 杂项数据类型（Miscellaneous Data Types）

  • Previous Page
  • Next Page

其他杂项数据类型包括逻辑、base64Binary、十六进制、浮点、双精度、anyURI、anyURI 以及 NOTATION。

逻辑数据类型（Boolean Data Type）

逻辑数据性用于规定 true 或 false 值。

下面是一个关于某个 scheme 中逻辑声明的例子：

<xs:attribute name="disabled" type="xs:boolean"/>

文档中的元素看上去应该类似这样：

<prize disabled="true">999</prize>

注释：合法的布尔值是 true、false、1（表示 true） 以及 0（表示 false）。

二进制数据类型（Binary Data Types）

二进制数据类型用于表达二进制形式的数据。

我们可使用两种二进制数据类型：

  • base64Binary (Base64 编码的二进制数据)
  • hexBinary (十六进制编码的二进制数据)

下面是一个关于某个 scheme 中 hexBinary 声明的例子：

<xs:element name="blobsrc" type="xs:hexBinary"/>

AnyURI 数据类型（AnyURI Data Type）

anyURI 数据类型用于规定 URI。

下面是一个关于某个 scheme 中 anyURI 声明的例子：

<xs:attribute name="src" type="xs:anyURI"/>

文档中的元素看上去应该类似这样：

<pic src="http://www.w3school.com.cn/images/smiley.gif" />

注释：假如某个 URI 含有空格，请用 %20 替换它们。

杂项数据类型（Miscellaneous Data Types）

名称 | 描述
anyURI |
base64Binary |
boolean |
double |
float |
hexBinary |
NOTATION |
QName |

对杂项数据类型的限定（Restriction）

可与杂项数据类型一同使用的限定：

  • enumeration (布尔数据类型无法使用此约束*)
  • length (布尔数据类型无法使用此约束)
  • maxLength (布尔数据类型无法使用此约束)
  • minLength (布尔数据类型无法使用此约束)
  • pattern
  • whiteSpace

*译者注：约束指 constraint。

  • Previous Page
  • Next Page

XML Schema 参考手册


XSD 字符串数据类型

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSD 字符串数据类型

  • Previous Page
  • Next Page

字符串数据类型用于可包含字符串的值。

字符串数据类型（String Data Type）

字符串数据类型可包含字符、换行、回车以及制表符。

下面是一个关于某个 scheme 中字符串声明的例子：

<xs:element name="customer" type="xs:string"/>

文档中的元素看上去应该类似这样：

<customer>John Smith</customer>

或者类似这样：

<customer>	John Smith	</customer>

注释：如果您使用字符串数据类型，XML 处理器就不会更改其中的值。

规格化字符串数据类型（NormalizedString Data Type）

规格化字符串数据类型源自于字符串数据类型。

规格化字符串数据类型同样可包含字符，但是 XML 处理器会移除折行，回车以及制表符。

下面是一个关于在某个 schema 中规格化字符串数据类型的例子：

<xs:element name="customer" type="xs:normalizedString"/>

文档中的元素看上去应该类似这样：

<customer>John Smith</customer>

或者类似这样：

<customer>	John Smith	</customer>

注释：在上面的例子中，XML 处理器会使用空格替换所有的制表符。

Token 数据类型（Token Data Type）

Token 数据类型同样源自于字符串数据类型。

Token 数据类型同样可包含字符，但是 XML 处理器会移除换行符、回车、制表符、开头和结尾的空格以及（连续的）空格。

下面是在 schema 中一个有关 token 声明的例子：

<xs:element name="customer" type="xs:token"/>

文档中的元素看上去应该类似这样：

<customer>John Smith</customer>

或者类似这样：

<customer>	John Smith	</customer>

注释：在上面这个例子中，XML 解析器会移除制表符。

字符串数据类型

请注意，所有以下的数据类型均衍生于字符串数据类型（除了字符串数据类型本身）！

名称 | 描述
ENTITIES |
ENTITY |
ID | 在 XML 中提交 ID 属性的字符串 (仅与 schema 属性一同使用)
IDREF | 在 XML 中提交 IDREF 属性的字符串(仅与 schema 属性一同使用)
IDREFS language | 包含合法的语言 id 的字符串
Name | 包含合法 XML 名称的字符串
NCName |
NMTOKEN | 在 XML 中提交 NMTOKEN 属性的字符串 (仅与 schema 属性一同使用)
NMTOKENS |
normalizedString | 不包含换行符、回车或制表符的字符串
QName |
string | 字符串
token | 不包含换行符、回车或制表符、开头或结尾空格或者多个连续空格的字符串

对字符串数据类型的限定（Restriction）

可与字符串数据类型一同使用的限定：

  • enumeration
  • length
  • maxLength
  • minLength
  • pattern (NMTOKENS、IDREFS 以及 ENTITIES 无法使用此约束)
  • whiteSpace
  • Previous Page
  • Next Page

XML Schema 参考手册


您已经学习了 XML Schema，下一步学习什么呢？

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

您已经学习了 XML Schema，下一步学习什么呢？

  • Previous Page
  • Next Page

XML Schema 概要

本教程已经向您讲解了如何描述 XML 文档的结构。

您已经学习了如何使用 XML Schema 来定义 XML 文档的合法元素，就像 DTD。我们认为，XML Schema 作为 DTD 的替代者，会很快被应用于大多数 Web 应用程序中。

您还学习到，XML Schema 是很完善的。与 DTD 不同，XML Schema 支持数据类型（data type）和命名空间（namespace）。

请参阅我们的 XML Schema 参考手册，获得更多有关 XML Schema 的信息。

您已经学习了 XML Schema，下一步学习什么呢？

下一步应该学习 WSDL。

WSDL 是一种基于 schema 的语言，用来描述 Web service 以及如何如何访问它们。

WSDL 可描述 Web service，连同用于 Web service 的消息格式和协议细节。

如果您希望学习更多有关 WSDL 的知识，请访问我们的 WSDL 教程。

  • Previous Page
  • Next Page

XML Schema 参考手册


如何使用 XSD？

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

如何使用 XSD？

  • Previous Page
  • Next Page

XML 文档可对 DTD 或 XML Schema 进行引用。

一个简单的 XML 文档：

请看这个名为 "note.xml" 的 XML 文档：

<?xml version="1.0"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

DTD 文件

下面这个例子是名为 "note.dtd" 的 DTD 文件，它对上面那个 XML 文档的元素进行了定义：

<!ELEMENT note (to, from, heading, body)>
<!ELEMENT to (#PCDATA)>
<!ELEMENT from (#PCDATA)>
<!ELEMENT heading (#PCDATA)>
<!ELEMENT body (#PCDATA)>

第 1 行定义 note 元素有四个子元素："to, from, heading, body"。

第 2-5 行定义了 to, from, heading, body 元素的类型是 "#PCDATA"。

XML Schema

下面这个例子是一个名为 "note.xsd" 的 XML Schema 文件，它定义了上面那个 XML 文档的元素：

<?xml version="1.0"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema"
targetNamespace="http://www.w3school.com.cn"
xmlns="http://www.w3school.com.cn"
elementFormDefault="qualified">

<xs:element name="note">
    <xs:complexType>
      <xs:sequence>
    <xs:element name="to" type="xs:string"/>
    <xs:element name="from" type="xs:string"/>
    <xs:element name="heading" type="xs:string"/>
    <xs:element name="body" type="xs:string"/>
      </xs:sequence>
    </xs:complexType>
</xs:element>

</xs:schema>

note 元素是一个复合类型，因为它包含其他的子元素。其他元素 (to, from, heading, body) 是简易类型，因为它们没有包含其他元素。您将在下面的章节学习更多有关复合类型和简易类型的知识。

对 DTD 的引用

此文件包含对 DTD 的引用：

<?xml version="1.0"?>
<!DOCTYPE note SYSTEM "http://www.w3school.com.cn/dtd/note.dtd">
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

对 XML Schema 的引用

此文件包含对 XML Schema 的引用：

<?xml version="1.0"?>
<note
xmlns="http://www.w3school.com.cn"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://www.w3school.com.cn note.xsd">

<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>
  • Previous Page
  • Next Page

XML Schema 参考手册


为什么要使用XML Schema？

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

为什么要使用 XML Schema？

  • Previous Page
  • Next Page

XML Schema 比 DTD 更强大。

XML Schema 支持数据类型

XML Schema 最重要的能力之一就是对数据类型的支持。

通过对数据类型的支持：

  • 可更容易地描述允许的文档内容
  • 可更容易地验证数据的正确性
  • 可更容易地与来自数据库的数据一并工作
  • 可更容易地定义数据约束（data facets）
  • 可更容易地定义数据模型（或称数据格式）
  • 可更容易地在不同的数据类型间转换数据

编者注：数据约束，或称 facets，是 XML Schema 原型中的一个术语，中文可译为“面”，用来约束数据类型的容许值。

XML Schema 使用 XML 语法

另一个关于 XML Schema 的重要特性是，它们由 XML 编写。

由 XML 编写 XML Schema 有很多好处：

  • 不必学习新的语言
  • 可使用 XML 编辑器来编辑 Schema 文件
  • 可使用 XML 解析器来解析 Schema 文件
  • 可通过 XML DOM 来处理 Schema
  • 可通过 XSLT 来转换 Schema

XML Schema 可保护数据通信

当数据从发送方被发送到接受方时，其要点是双方应有关于内容的相同的“期望值”。

通过 XML Schema，发送方可以用一种接受方能够明白的方式来描述数据。

一种数据，比如 "03-11-2004"，在某些国家被解释为11月3日，而在另一些国家为当作3月11日。

但是一个带有数据类型的 XML 元素，比如：<date type="date">2004-03-11</date>，可确保对内容一致的理解，这是因为 XML 的数据类型 "date" 要求的格式是 "YYYY-MM-DD"。

XML Schema 可扩展

XML Schema 是可扩展的，因为它们由 XML 编写。

通过可扩展的 Schema 定义，您可以：

  • 在其他 Schema 中重复使用您的 Schema
  • 创建由标准类型衍生而来的您自己的数据类型
  • 在相同的文档中引用多重的 Schema

形式良好是不够的

我们把符合 XML 语法的文档称为形式良好的 XML 文档，比如：

  • 它必须以 XML 声明开头
  • 它必须拥有唯一的根元素
  • 开始标签必须与结束标签相匹配
  • 元素对大小写敏感
  • 所有的元素都必须关闭
  • 所有的元素都必须正确地嵌套
  • 必须对特殊字符使用实体

即使文档的形式良好，仍然不能保证它们不会包含错误，并且这些错误可能会产生严重的后果。

请考虑下面的情况：您订购的了 5 打激光打印机，而不是 5 台。通过 XML Schema，大部分这样的错误会被您的验证软件捕获到。

  • Previous Page
  • Next Page

XML Schema 参考手册


一个 XSD 实例

Schema 教程

  • XSD 首页
  • XSD 简介
  • XSD 为何使用
  • XSD 如何使用
  • XSD <schema>

简单的类型

  • XSD 元素
  • XSD 属性
  • XSD 限定

复杂的类型

  • XSD 元素
  • XSD 空元素
  • XSD 仅含元素
  • XSD 仅含文本
  • XSD 混合内容
  • XSD 指示器
  • XSD <any>
  • XSD <anyAttribute>
  • XSD 元素替换
  • XSD 实例

数据类型

  • XSD 字符串
  • XSD 日期
  • XSD 数值
  • XSD 杂项
  • XSD 总结

参考手册

  • XSD 参考手册
  • XSD 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

一个 XSD 实例

  • Previous Page
  • Next Page

本节会为您演示如何编写一个 XML Schema。您还将学习到编写 schema 的不同方法。

XML 文档

让我们看看这个名为 "shiporder.xml" 的 XML 文档：

<?xml version="1.0" encoding="ISO-8859-1"?>

<shiporder orderid="889923"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:noNamespaceSchemaLocation="shiporder.xsd">
 <orderperson>George Bush</orderperson>
 <shipto>
  <name>John Adams</name>
  <address>Oxford Street</address>
  <city>London</city>
  <country>UK</country>
 </shipto>
 <item>
  <title>Empire Burlesque</title>
  <note>Special Edition</note>
  <quantity>1</quantity>
  <price>10.90</price>
 </item>
 <item>
  <title>Hide your heart</title>
  <quantity>1</quantity>
  <price>9.90</price>
 </item>
</shiporder>

上面的XML文档包括根元素 "shiporder"，其中包含必须名为 "orderid" 的属性。"shiporder" 元素包含三个不同的子元素："orderperson"、"shipto" 以及 "item"。"item" 元素出现了两次，它含有一个 "title"、一个可选 "note" 元素、一个 "quantity" 以及一个 "price" 元素。

上面这一行 xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"，告知XML解析器根据某个 schema 来验证此文档。这一行：xsi:noNamespaceSchemaLocation="shiporder.xsd" 规定了 schema 的位置（在这里，它与 "shiporder.xml" 处于相同的文件夹）。

创建一个 XML Schema

现在，我们需要为上面这个 XML 文档创建一个 schema。

我们可以通过打开一个新的文件来开始，并把这个文件命名为 "shiporder.xsd"。要创建schema，我们仅仅需要简单地遵循 XML 文档中的结构，定义我们所发现的每个元素。首先我们开始定义一个标准的 XML 声明：

<?xml version="1.0" encoding="ISO-8859-1" ?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">
...
...

</xs:schema>

在上面的 schema 中，我们使用了标准的命名空间 (xs)，与此命名空间相关联的 URI 是 Schema 的语言定义（Schema language definition），其标准值是 http://www.w3.org/2001/XMLSchema。

接下来，我们需要定义 "shiporder" 元素。此元素拥有一个属性，其中包含其他的元素，因此我们将它认定为复合类型。"shiporder" 元素的子元素被 xs:sequence 元素包围，定义了子元素的次序：

<xs:element name="shiporder">
 <xs:complexType>
  <xs:sequence>
  ...
  ...
  </xs:sequence>
  ...
 </xs:complexType>
</xs:element>

然后我们需要把 "orderperson" 元素定义为简易类型（这是因为它不包含任何属性或者其他的元素）。类型 (xs:string) 的前缀是由命名空间的前缀规定的，此命名空间与指示预定义的 schema 数据类型的 XML schema 相关联：

<xs:element name="orderperson" type="xs:string"/>

接下来，我需要把两个元素定义为复合类型："shipto" 和 "item"。我们从定义 "shipto" 元素开始：

<xs:element name="shipto">
 <xs:complexType>
  <xs:sequence>
   <xs:element name="name" type="xs:string"/>
   <xs:element name="address" type="xs:string"/>
   <xs:element name="city" type="xs:string"/>
   <xs:element name="country" type="xs:string"/>
  </xs:sequence>
 </xs:complexType>
</xs:element>

通过 schema，我们可使用 maxOccurs 和 minOccurs 属性来定义某个元素可能出现的次数。maxOccurs 定义某元素出现次数的最大值，而 minOccurs 则定义某元素出现次数的最小值。maxOccurs 和 minOccurs 的默认值都是 1！

现在，我们可以定义 "item" 元素了。这个元素可在 "shiporder" 元素内部出现多次。这是通过把 "item" 元素的 maxOccurs 属性的值设定为 "unbounded" 来实现的，这样 "item" 元素就可出现创作者所希望的任意多次。请注意，"note" 元素是可选元素。我们已经把此元素的 minOccurs 属性设定为 0 了：

<xs:element name="item" maxOccurs="unbounded">
 <xs:complexType>
  <xs:sequence>
   <xs:element name="title" type="xs:string"/>
   <xs:element name="note" type="xs:string" minOccurs="0"/>
   <xs:element name="quantity" type="xs:positiveInteger"/>
   <xs:element name="price" type="xs:decimal"/>
  </xs:sequence>
 </xs:complexType>
</xs:element>

现在，我们可以声明 "shiporder" 元素的属性了。由于这是一个必选属性，我们规定 use="required"。

注释：此属性的声明必须被置于最后：

<xs:attribute name="orderid" type="xs:string" use="required"/>

这是这个名为 "shiporder.xsd" 的 schema 文件的文档清单：

<?xml version="1.0" encoding="ISO-8859-1" ?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">

<xs:element name="shiporder">
 <xs:complexType>
  <xs:sequence>
   <xs:element name="orderperson" type="xs:string"/>
   <xs:element name="shipto">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="name" type="xs:string"/>
      <xs:element name="address" type="xs:string"/>
      <xs:element name="city" type="xs:string"/>
      <xs:element name="country" type="xs:string"/>
     </xs:sequence>
    </xs:complexType>
   </xs:element>
   <xs:element name="item" maxOccurs="unbounded">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="title" type="xs:string"/>
      <xs:element name="note" type="xs:string" minOccurs="0"/>
      <xs:element name="quantity" type="xs:positiveInteger"/>
      <xs:element name="price" type="xs:decimal"/>
     </xs:sequence>
    </xs:complexType>
   </xs:element>
  </xs:sequence>
  <xs:attribute name="orderid" type="xs:string" use="required"/>
 </xs:complexType>
</xs:element>

</xs:schema>

分割 Schema

前面的设计方法非常容易，但当文档很复杂时却难以阅读和维护。

接下来介绍的设计方法基于首先对所有元素和属性的定义，然后再使用 ref 属性来引用它们。

这是用新方法设计的 schema 文件：

<?xml version="1.0" encoding="ISO-8859-1" ?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">

<!-- 简易元素的定义 -->
<xs:element name="orderperson" type="xs:string"/>
<xs:element name="name" type="xs:string"/>
<xs:element name="address" type="xs:string"/>
<xs:element name="city" type="xs:string"/>
<xs:element name="country" type="xs:string"/>
<xs:element name="title" type="xs:string"/>
<xs:element name="note" type="xs:string"/>
<xs:element name="quantity" type="xs:positiveInteger"/>
<xs:element name="price" type="xs:decimal"/>

<!-- 属性的定义 -->
<xs:attribute name="orderid" type="xs:string"/>

<!-- 复合元素的定义 -->
<xs:element name="shipto">
 <xs:complexType>
  <xs:sequence>
   <xs:element ref="name"/>
   <xs:element ref="address"/>
   <xs:element ref="city"/>
   <xs:element ref="country"/>
  </xs:sequence>
 </xs:complexType>
</xs:element>
<xs:element name="item">
 <xs:complexType>
  <xs:sequence>
   <xs:element ref="title"/>
   <xs:element ref="note" minOccurs="0"/>
   <xs:element ref="quantity"/>
   <xs:element ref="price"/>
  </xs:sequence>
 </xs:complexType>
</xs:element>

<xs:element name="shiporder">
 <xs:complexType>
  <xs:sequence>
   <xs:element ref="orderperson"/>
   <xs:element ref="shipto"/>
   <xs:element ref="item" maxOccurs="unbounded"/>
  </xs:sequence>
  <xs:attribute ref="orderid" use="required"/>
 </xs:complexType>
</xs:element>

</xs:schema>

使用指定的类型（Named Types）

第三种设计方法定义了类或者类型，这样使我们有能力重复使用元素的定义。具体的方式是：首先对简易元素和复合元素进行命名，然后通过元素的 type 属性来指向它们。

这是利用第三种方法设计的 schema 文件 ("shiporder.xsd")：

<?xml version="1.0" encoding="ISO-8859-1" ?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">

<xs:simpleType name="stringtype">
 <xs:restriction base="xs:string"/>
</xs:simpleType>

<xs:simpleType name="inttype">
 <xs:restriction base="xs:positiveInteger"/>
</xs:simpleType>

<xs:simpleType name="dectype">
 <xs:restriction base="xs:decimal"/>
</xs:simpleType>

<xs:simpleType name="orderidtype">
 <xs:restriction base="xs:string">
  <xs:pattern value="[0-9]{6}"/>
 </xs:restriction>
</xs:simpleType>

<xs:complexType name="shiptotype">
 <xs:sequence>
  <xs:element name="name" type="stringtype"/>
  <xs:element name="address" type="stringtype"/>
  <xs:element name="city" type="stringtype"/>
  <xs:element name="country" type="stringtype"/>
 </xs:sequence>
</xs:complexType>

<xs:complexType name="itemtype">
 <xs:sequence>
  <xs:element name="title" type="stringtype"/>
  <xs:element name="note" type="stringtype" minOccurs="0"/>
  <xs:element name="quantity" type="inttype"/>
  <xs:element name="price" type="dectype"/>
 </xs:sequence>
</xs:complexType>

<xs:complexType name="shipordertype">
 <xs:sequence>
  <xs:element name="orderperson" type="stringtype"/>
  <xs:element name="shipto" type="shiptotype"/>
  <xs:element name="item" maxOccurs="unbounded" type="itemtype"/>
 </xs:sequence>
 <xs:attribute name="orderid" type="orderidtype" use="required"/>
</xs:complexType>

<xs:element name="shiporder" type="shipordertype"/>

</xs:schema>

restriction 元素显示出数据类型源自于 W3C XML Schema 命名空间的数据类型。因此，下面的片段也就意味着元素或属性的值必须是字符串类型的值：

<xs:restriction base="xs:string">

restriction 元素常被用于向元素施加限制。请看下面这些来自以上 schema 的片段：

<xs:simpleType name="orderidtype">
 <xs:restriction base="xs:string">
  <xs:pattern value="[0-9]{6}"/>
 </xs:restriction>
</xs:simpleType>

这段代码指示出，元素或属性的值必须为字符串，并且必须是连续的六个字符，同时这些字符必须是 0-9 的数字。

  • Previous Page
  • Next Page

XML Schema 参考手册


w3school 搜索

HTML教程

  • HTML
  • XHTML
  • CSS
  • TCP/IP

XML教程

  • XML
  • DTD
  • XML DOM
  • XSL
  • XSLT
  • XSL-FO
  • XPath
  • XQuery
  • XLink
  • XPointer
  • Schema
  • XForms
  • SOAP
  • WSDL
  • RDF
  • RSS
  • WAP
  • Web Services

浏览器脚本

  • JavaScript
  • HTML DOM
  • DHTML
  • VBScript
  • AJAX
  • E4X
  • WMLScript

服务器脚本

  • SQL
  • ASP
  • ADO
  • PHP

.NET(dotnet)

  • .NET Microsoft
  • .NET ASP
  • .NET Mobile

多媒体

  • Media
  • SMIL
  • SVG

建站手册

  • 网站构建
  • 万维网联盟 (W3C)
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

W3School 搜索

Google 搜索

其他 Google 搜索

Google 代码搜索

Google 高级搜索

Google 帮助

Google.com in English

参考手册

  • HTML 4.01
  • XHTML 1.0
  • HTML 5
  • CSS 2.0
  • JavaScript
  • VBScript
  • HTML DOM
  • XML DOM
  • ASP
  • ADO
  • ASP.NET
  • PHP 5.1
  • XSLT 1.0
  • XPath 2.0
  • XSL-FO
  • WML 1.1
  • HTML 颜色

字符集

  • HTML ASCII
  • HTML Latin-1
  • HTML 符号

实例/案例

  • HTML 实例
  • CSS 实例
  • XML 实例
  • JavaScript 实例
  • JavaScript 对象实例
  • HTML DOM 实例
  • XML DOM 实例
  • DHTML 实例
  • AJAX 实例
  • VBScript 实例
  • ASP 实例
  • ADO 实例
  • SVG 实例
  • WAP 实例

测验/考试

  • HTML 测验
  • XHTML 测验
  • CSS 测验
  • XML 测验
  • JavaScript 测验
  • SQL 测验
  • ASP 测验

代码验证

  • 验证HTML
  • 验证CSS
  • 验证XHTML
  • 验证XML
  • 验证WML


有关语义网的话题

语义网

  • 语义网首页
  • 语义网实例
  • 语义网安全

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

有关语义网的话题

  • Previous Page
  • Next Page

这里列出了一些有关语义网的话题。

语义网代理

语义网不是可供搜索的免费文本。如希望搜索或访问语义网，我们需要软件的协助。

要使用语义网，我们就需要 “语音网代理” 或 “语义网络服务”。这些“代理”或“服务”会帮助我们在语义网上找到正在寻找的东西。

编者注：“语音网代理”："Semantic Web Agents"，“语义网络服务”："Semantic Web Services"。

在语音网上，我们可能会搜索这些信息：

最便宜的机票 适合我的汽车的装饰 书籍、电影或音乐 天气预报 时间表和日程 股票价格和汇率

在未来，要想在 Web 上找到任何信息，使用您的“语义网代理”就可以了。

语音网安全

我能信赖语义网上的一个卖家吗？我能信任语义网上的一个买家吗？

要解决上述问题，我需要访问更多 RDF 文件：

信用卡信息 银行信息 语义网记录 社会安全信息
Source | Person ID | Person Name | Status
Citybank | 11223344 | John Smith | trustworthy
VISA | 11223344 | John Smith | trustworthy
Recorded | 11223344 | John Smith | unknown
US Social Security | 11223344 | John Smith | born 10-10-1962

通过使用类似的这些 RDF 文件，我的“语义网”代理就能够确定能够我们是否能信任我正在打交道的这个人。

（能够通过 eBay 和 Amazon 之类的因特网交易公司来提供记录信息）

支付

要运营语音网，就必须开发支付手段。

易用的因特网“储蓄存款”可能成为此问题的解决方案。

“储蓄存款帐户”是一种只能接受存款的帐户。它可以为因特网上的所有提供便利，只要得到您的 ID（或者您的电子邮件地址，很类似 PayPal），任何人都可以把钱存入您的帐户。

通过使用这种支付手段，每个人都可以在因特网上公布他们的银行帐户，并在不需要中间人的情况下出售他们的汽车。

因特网银行业务的未来会是什么样子呢？

OWL - 您的网络词典

情景

  1. 您需要卖一本书
  2. 您打开 OWL 代理
  3. 您在种类中输入 “Book”
  4. 在新窗口中填写关于书的信息
  5. 您填写印在书上的 ISBN 号码
  6. 您选择“二手”，以及 "condition as new"，并单击返回
  7. 您的 OWL 代理会自动填写其余的部分
  8. 作者、年份、页数... 现在所有的信息都完整了
  9. 您的 OWL 代理已经搜集好您需要出售的书籍的所有信息
  10. 最后，您点击拍卖按钮。

您可以在我们的 RDF 教程中学习更多的内容。

您的拍卖代理

  1. 您的拍卖代理打开了。
  2. 您填好了最低价格，然后点击“提交”。
  3. 这样，您的书籍就可以在因特网上进行拍卖了。
  • Previous Page
  • Next Page


语义网

语义网

  • 语义网首页
  • 语义网实例
  • 语义网安全

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

语义网

  • Next Page

语义网=有意义的网络。

“如果说 HTML 和 WEB 将整个在线文档变成了一本巨大的书，那么 RDF, schema, 和 inference languages 将会使世界上所有的数据变成一个巨大的数据库。”

--- Tim Berners-Lee, Weaving the Web, 1999

什么是语义网？

semantic（语义的）这个词指有意思的或与之相关的。

语义网是一种使用可以被计算机理解的方式描述事物的网络。

  • 甲壳虫乐队是来自利物浦的著名乐队。
  • 约翰.列农是甲壳虫乐队的成员之一。
  • 唱片 "Hey Jude" 是由甲壳虫乐队录制的。

象这样的句子可以被人类理解。但是如何能够被计算机理解呢？

陈述是由语法规则构建的。一门语言的语法定义了构建该语言的陈述所需的规则。

这就是语义网的本质所在 - 以计算机应用程序可以理解的方式描述事物。

语义网和网页之间的链接没有关系。

语义网描述的是事物之间的关系（比方说 A 是 B 的一部分，而 Y 是 Z 的成员）以及事物的属性（例如尺寸、重量、使用期限和价格等等）。

资源描述框架

RDF(资源描述框架，Resource Description Framework)是一种用于描述网络上的信息和资源的的标记语言。

将信息至于 RDF 文件之中，这样的话，这些信息就有可能被计算机程序（"web spiders"）从网络中搜索、发现、摄取、筛选、分析和处理。

语义网使用 RDF 来描述网络资源。

如果您希望学习更多关于 RDF 的知识，请阅读我们的《RDF 教程》

如何使用语义网？

假如有关音乐、汽车、入场券（或者任何别的东西）的信息被存储于 RDF 文件，智能网络应用程序就会将信息从不同的源中进行摄取，并将其整合，然后以一个有意义的方式将信息提交给用户们。

类似如下内容的信息：

  • 不同经销商的汽车价格
  • 药品信息
  • 航班时刻表
  • 工业备件
  • 书籍信息（价格、页数、编辑、年份）
  • 某人是谁
  • 事件的日期
  • 软件更新

语义网技术容易被理解吗？

语义网不是快速发展的技术。

其学习曲线是原因之一。RDF 是由那些拥有逻辑学和人工智能方面的学院背景的人们发展起来的。对于一般的开发人员的来说，它并不是特别容易被理解。

RSS 是一种用于构建语义网应用的快速发展的语言。如果您希望了解更多 RSS 的知识，请阅读我们的《RSS 教程》。

在下面的教程中，我们将专注于 RDF 的使用，以发现语义网的潜力所在。

请单击下一章，您可以看到一个简单的语义网应用实例。

  • Next Page


语义网实例

语义网

  • 语义网首页
  • 语义网实例
  • 语义网安全

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

语义网实例

  • Previous Page
  • Next Page

语义网。一个简单的应用实例。

购买和出售二手车

假设某个语义网系统用于通过因特网管理二手车的销售和购买。

该系统可能包括两个主要的应用程序： 一个针对希望购买汽车的人群 一个针对希望出售汽车的人群

让我们把这两个应用程序称为 IBA (I Buy Application) 和 ISA (I Sell Application)。

IBA - I Buy Application

希望购买汽车的人群使用的 IBA 应用程序类似这样：

I Buy Application (IBA)

在真实世界的应用程序中，您可能在第一次使用该程序时被要求标示自己的身份。您的 ID 将存储在一个 RDF 文件中。您的 ID 会把您标示为一个带有名字、地址、电子邮件以及 ID 号的人。

当您提交查询时，应用程序会返回一个待售汽车的列表，这个列表会按照年份、价格、位置和可用性进行排序。通过在 web 对 RDF 文件的搜索，此信息会不断地从 web spider 返回。

ISA - I Sell Application

希望出售汽车的人群使用的 ISA 应用程序类似这样：

I Sell Application (ISA)

当您提交表单时，应用程序会向您请求跟多的信息，并把您的 ID 和信息存储在一个 RDF 文件中，以供 web 使用。

RDF 文件包含的信息类似：

  • 您的 ID: 姓名、地址、电子邮件、ID 号。
  • 您的出售条目: 类型、型号、图片、价格、描述。

幕后

在幕后，这个 "ISA" 应用程序会创建一个带有许多 RDF 指针的 RDF 文件。

它会创建一个指向带有关于 person 信息的文件的指针，一个指向带有关于 Volvo 和 Volvo 型号信息的文件的指针，一个指向带有关于 Volvo 经销商和出售者信息的文件的指针，等等。

RDF 指针是一种指向有关某事物的信息的指针（实际上是 URL），类似知识数据库。

有关于此的优点在于您不必对您本人或汽车的型号进行描述。这个 RDF 应用程序会为您对信息进行整理。

语义网将如何工作？

混乱？标准？我们需要什么？我们在期待什么？

由微软，由 Google，还是由 W3C 发展标准？

RDF 是关于数据的数据 - 即元数据。RDF 文件经常会描述其它的 RDF 文件。将来有可能把所有的 RDF 文件连接起来构建一个语义网吗？

没有人知道，但是总有人去尝试。

语义网会依靠自己发展起来吗？

我们不认为语义网会依靠自己发展起来。它需要第三方的协助才能成为现实。

不太可能的是，您仅仅在因特网上发布 RDF 文件，就能够出售您的汽车。

必须通过很多力量的参与，才能够发展类似上面的 "ISA" 和 "IBA" 应用程序。一方为所有的项目构建搜索引擎数据库，另一方则为其开发标准。

可能是 eBay，或 Microsoft，或 Google，也可能是别的公司。但是总会有人去做。

不久，我们就会看到基于 RDF 的市场。而有一天，您将能够使用标准化的 RDF 文件在 Web 上收集有关几乎所有事物的信息。

它可能免费。也可能你不得不为信息，或至少为出售您的信息来付费。

在因特网上发布信息将比过去更加容易。也许 RSS 语言（参阅我们的 RSS 教程）会成为很多问题的解决途径。

请阅读我们的下一节 - 有关语义网这个话题的更多内容。

  • Previous Page
  • Next Page


Web 安全

网站构建教程

  • 教程首页
  • 网站构建
  • 网站设计
  • 网络用户
  • 网站标准
  • 网站验证
  • 万维网联盟
  • 网络安全

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Web 安全

  • Previous Page
  • Next Page

此刻，您已向整个世界提供了您的 IP 地址。

请确保您没有同时提供对私人数据的访问权限。

您的 IP 地址是公共的

访问因特网是要冒安全方面的风险的。

当您连到因特网后，IP地址被用来识别您的 PC。假如您不加防范，外部世界会利用这个 IP 地址（非法）访问您的计算机。

固定的 IP 地址要冒更大的风险。

假如您正在使用拨号连接的 modem，那么每当您连到因特网上时就会获得一个新的 IP 地址，但是如果您拥有一个固定的 IP 地址（电缆、专线等），您的IP就不会有变化了。

如果您正在使用一个固定的 IP 地址，那么您给了那些黑客们随时对计算机进行攻击的可能性。

您的网络共享

个人电脑常常会连接到一个共享网络中。大企业中的个人电脑会连接到大的集团网络。小公司的个人电脑会连接到小的本地网络，而私人家庭中的电脑也会经常与家庭成员分享网路。

网络经常用来共享打印机、文件以及磁盘存储。

当您连接到因特网，您的共享资源可能被外部世界访问到。

常见的 windows 安全问题

不幸地是，很多微软的 windows 用户都意识不到其网络设置中常见的安全漏洞。

这是 Microsoft Windows 中常见的网络组件安装列表：

  • Microsoft 网络客户端
  • Microsoft 的文件和打印机网络共享
  • Internet 协议（TCP/IP ）

如果您的设置允许在 TCP/IP 上使用 NetBIOS，那么会面临一个安全问题：

  • 文件会被整个 Internet 共享
  • 您的登录名、计算机名称以及工作组名称对其他人都是可见的

如果您的设置允许 TCP/IP 上的文件和打印机共享，您也会面临安全问题：

  • 文件会被整个 Internet 共享

没有连接任何网络的计算机也可能拥有危险的网络设置，这是由于一旦 Internet 被安装，网络设置就会发生改变。

解决问题

请在网络连接属性中禁用 NetBIOS 协议和文件打印机共享，具体的操作方法会因不同的 windows 版本而略有不同。

如果您仍然需要需要在网络上共享打印机和文件，你可以选择使用 NetBEUI 协议来代替 TCP/IP 协议。

获取更多资讯，保护您的计算机

请访问天网安全阵线 - 资讯通，获得更多有关网络安全的技巧和资讯。

  • Previous Page
  • Next Page


Web 标准

网站构建教程

  • 教程首页
  • 网站构建
  • 网站设计
  • 网络用户
  • 网站标准
  • 网站验证
  • 万维网联盟
  • 网络安全

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Web 标准

  • Previous Page
  • Next Page

Web 标准会帮助我们实现 WWW 的梦想。

Web 标准让 Web 开发更加容易。

为什么使用 web 标准？

由于存在不同的浏览器版本，web 开发者常常需要为耗时的多版本开发而艰苦工作。当新的硬件（比如移动电话）和软件（比如微浏览器）开始浏览 web 时，这种情况开始会变得更加严重。

为了 web 更好地发展，对于开发人员和最终用户而言非常重要的事情是，在开发新的应用程序时，浏览器开发商和站点开发商共同遵守标准。

web 的不断壮大，使得越来越有必要依靠标准实现其全部潜力。web 标准可确保每个人都有权利访问相同的信息。如果没有 web 标准，那么未来的 web 应用，包括我们所梦想的应用程序，都是不可能实现的。

同时，Web 标准也可以使站点开发更快捷，更令人愉快。为了缩短开发和维护时间，未来的网站将不得不根据标准来进行编码。开发人员不必为了得到相同的结果，而挣扎于多版本的开发。

其他的考虑

一旦 web 开发人员遵守了 web 标准，由于开发人员可以更容易地理解彼此的编码，web 开发的团队协作将得到简化。

某些开发人员认为标准等同于约束，并认为利用特殊的浏览器特性会为其工作成果增加保障。但是当访问方式日益增加时，未来对这些页面的调整会变得越来越困难。遵守标准是您解决此问题需要走出的第一步。只有使用 web 标准，才能确保在不频繁和费时地重写代码的情况下，所有的浏览器，无论新的或老式的，都可以正确地显示您的站点。

Standardization 可增加网站的访问量。

标准的 web 文档更易被搜索引擎访问，也更易被准确地索引。

标准的 web 文档更易被转换为其他格式。

标准的 web 文档更易被程序代码访问（比如 JavaScript 和 DOM）。

希望节省大量的时间吗？请养成使用验证服务来验证页面的习惯吧。验证可使您的文档与标准保持一致，并免于严重的错误。

易用性

易用性是 HTML 标准的一个重要部分。

标准使得残疾人士更容易地使用 web。盲人可使用计算机为他们读出网页。而弱视的人士可重新排列并放大网页。简单的 web 标准，比如 HTML 和 CSS，将使您的网页更容易被语音阅读器和其他不常见的输出设备理解。

万维网联盟（World Wide Web Consortium）

万维网联盟，建立于 1994 年，是一个国际性的联盟，其宗旨是投身于“引领 web 以激发其全部潜能”。

作为开发人员，特别是当创建这个教育性的网站时，我们愿意帮助其实现这个梦想。

您可以在下一节阅读更多有关 W3C 的内容。

ECMA

欧洲计算机工业协会 (ECMA)，1961 年创建于瑞士，其目标是满足对计算机语言和输入输出代码进行标准化的需要。

ECMA 不是一个官方的标准化机构，而是一个与其它官方机构，比如国际标准化组织 (ISO) 和欧洲通信标准机构 (ETSI)，进行合作的公司联合体。

对于 web 开发人员来说，最重要的标准是 ECMAScript，JavaScript 的标准化。

ECMAScript 是一种标准化的脚本语言，用来处理由 W3C 文档对象模型 (DOM) 所规定的网页对象。通过 ECMAScript，可对 DOM 对象进行添加、删除或修改。

ECMAScript 标准基于 Netscape 的 JavaScript 和微软的 JScript。

最新的 ECMAScript 规范是 ECMA-262：

http://www.ecma-international.org/publications/standards/ECMA-262.HTM

  • Previous Page
  • Next Page


万维网联盟（World Wide Web Consortium）

网站构建教程

  • 教程首页
  • 网站构建
  • 网站设计
  • 网络用户
  • 网站标准
  • 网站验证
  • 万维网联盟
  • 网络安全

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

万维网联盟（World Wide Web Consortium）

  • Previous Page
  • Next Page

万维网联盟（W3C）创立了 WWW 标准。

W3C 的使命是通过发展规范、指导方针、软件以及工具，来尽展万维网潜能。

万维网联盟（World Wide Web Consortium）

引自 Tim Berners-Lee，万维网的发明人，W3C 的主任及创立者：

“web 蕴藏的梦想是一个可在其中通过分享信息而进行通信的公共信息空间”

万维网联盟（W3C），创建于 1994 年，是一个致力于“尽展万维网潜能”的国际性联盟。

  • W3C 指万维网联盟（World Wide Web Consortium）
  • W3C 被创建于 1994 年 10 月
  • W3C 由 Tim Berners-Lee 创立
  • W3C 由web 的发明人创立
  • W3C 以会员机构的形式进行组织
  • W3C 致力于对web 进行标准化
  • W3C 创建并维护了 WWW 标准
  • W3C 标准被称为 W3C 推荐标准（W3C Recommendations）

W3C 最重要的工作是发展 web 规范，也就是描述 web 通信协议（比如 HTML 和 XML）和其他构建模块的“推荐标准”。

最重要的 W3C 标准是：

  • HTML
  • XHTML
  • CSS
  • XML
  • XSL
  • DOM

您可以在 W3C 教程 中阅读更多有关 W3C 的知识。

W3School 中的 W3C 资源

W3C 简介
本节解释什么是 W3C，它如何工作，以及web如何被标准化。
W3C 程序
W3C 标准的核定程序包括7个不同的步骤。本节解释了 W3C 的标准化过程。
W3C HTML
HTML 是在万维网上发布超文本的混合语。本节概括了 W3C 上的 HTML 活动。
W3C XHTML
XHTML 1.0 是最新的 HTML 版本。本节概括了 W3C 的 XHTML 活动。
W3C XML
XML 被设计用来描述、存储、传送并交换数据。XML 1.0 是最新版本的 XML。本节概述了 W3C 的 XML 活动。
W3C CSS
样式表可描述文件如何被显示、念出或打印。W3C 支持两种类型的样式表：CSS 和 XSL。本节概述了 W3C 的 CSS 活动。
W3C XSL
样式表可描述文件如何被显示、念出或打印。W3C支持两种类型的样式表：CSS 和 XSL。本节概述了 W3C 的 XSL 活动。
W3C DOM
文档对象模型 (DOM) 是一个平台和中立于语言的应用程序编程接口，允许程序访问、更新文档的内容、结构及样式。本节概述了 W3C 的 DOM 活动。
W3C 其他
本节概述了 W3C 的其他的一些重要且有趣的活动。
  • Previous Page
  • Next Page


网页验证

网站构建教程

  • 教程首页
  • 网站构建
  • 网站设计
  • 网络用户
  • 网站标准
  • 网站验证
  • 万维网联盟
  • 网络安全

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

网页验证

  • Previous Page
  • Next Page

通过 W3C 验证 HTML 文件：

在以下的本文框输入你需要验证的网址：

通过 W3C 验证 CSS 文件：

在以下的本文框输入你需要验证的CSS文件：

通过 W3C 验证 XHTML 文件：

XHTML 文档根据文档类型声明（DTD）进行验证。

你可以在我们的 XHTML 教程 中阅读更多关于 XHTML 验证的信息。

在以下的本文框输入你需要验证的网址：

使用 Internet Explorer 验证 XML 文件：

在以下的本文框输入你需要验证的网址：

使用 Internet Explorer 验证 WML 文件：

在以下的本文框输入你需要验证的网址：

  • Previous Page
  • Next Page


网站构建

网站构建教程

  • 教程首页
  • 网站构建
  • 网站设计
  • 网络用户
  • 网站标准
  • 网站验证
  • 万维网联盟
  • 网络安全

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

网站构建

  • Previous Page
  • Next Page

每个网站开发者都必须了解以下 Web 构件：

  • HTML 4.01
  • CSS 的使用 （样式表）
  • XHTML
  • XML 和 XSLT
  • 客户端脚本
  • 服务器端脚本
  • 通过 SQL 管理数据
  • Web 的未来

HTML 4.01

HTML 是 Web 的语言，每一个 Web 开发者都需要对它拥有基本的了解。

HTML 4.01 是重要的 Web 标准，它与 HTML 3.2 的差异非常之大。

当类似 font 的标签和 color 属性被添加到 HTML 3.2 后，它就逐渐成为开发人员们的一场噩梦。开发那些必须把字体信息加入每个单独页面的网站，其过程成为了一种漫长而昂贵的折磨。

通过 HTML 4.01，所有的格式化信息可以被移出 HTML 文档，转而放入一个独立的样式表中。

HTML 4.01 之所以重要，另外一个原因是由于 XHTML 1.0，这个最新的 HTML 标准是作为一种 XML 应用被重新表达的 HTML 4.01。在您的页面中使用 HTML 4.01 可以确保在未来将 HTML 轻松升级到 XHTML。

请确保您使用了最新的 HTML 4.01 标准。

学习我们的完整的 HTML 4.01 参考手册。

层叠样式表（Cascading Style Sheets - CSS）

样式可定义 HTML 元素如何被显示，类似 font 标签在 HTML 3.2 中所起到的作用。样式通常被保存在 HTML 文档之外的文件中。外部样式表使您有能力仅仅通过编辑一个简单的 CSS 文档来改变网站内所有页面的外观和布局。如果您曾经尝试过进行某些改变，比如同时改变站内所有网页标题的字体或颜色，您就会明白 CSS 如何能够达到事半功倍的效果。

请务必学习我们的 CSS 教程。

XHTML - HTML 的未来

XHTML 指可扩展超文本标记语言（Extensible HyperText Markup Language）。

XHTML 1.0 是源自 W3C 的最新的 HTML 标准。它于 2000 年 1 月 26 日成为正式的推荐标准（Recommendation）。W3C Recommendation 意味着其规范的稳定性，同时其规范目前已成为一种 Web 标准。

XHTML 是一种使用 XML 进行重构的 HTML 4.01，并可以通过遵循一些简单的指导方针立即在现有的浏览器中投入使用。

为未来做好准备：请阅读如何将网站转化为 XHTML。

XML - 用于描述数据的工具

扩展标记语言（XML）并不是HTML的替代品。在未来的 web 开发中，XML 会被用来描述和存储数据，而 HTML 会被用来显示数据。

我们对 XML 最合适的描述是，一个跨平台的、独立于软硬件的，信息存储和传输工具。

我们相信 XML 的重要性不亚于 HTML 对于 web 的基础性地位，并且 XML 将会成为最重要的数据处理和传输工具。

请确保学习我们的 XML 教程。

XSLT - 用户转换数据的工具

XSLT（可扩展的样式表语言转换，Extensible Stylesheet Language Transformations），是用于转换 XML 的语言。

未来的网站将不得不向不同的浏览器并向其他web服务器以不同的格式传递数据。而 XSLT 则是一种将 XML 数据转换为不同格式的新的 W3C 标准。

XSLT 可以把 XML 文件转换为浏览器可识别的格式，比如 HTML，或者 WML - 一种用于许多手持设备的标记语言。

XSLT 还可以添加元素，并对元素进行删除、重新排列及排序，测试并确定显示哪些元素，等等。

请确保学习我们的 XSLT 教程。

客户端脚本

客户端脚本脚本是一种有关因特网浏览器行为的编程。您应该学习 JavaScript，这样才能有能力传递更多的动态网站内容：

JavaScript 是为 HTML 设计者提供的一种的编程工具
HTML 的创作者通常都不是程序员，但是 JavaScript 是一种语法非常简单的脚本语言！几乎任何人都能够把某些 JavaScript 的代码片断放入他们的 HTML 页面中。
JavaScript 可以在HTML页面中放入动态的文本
像这样的一条 JavaScript 语言可以在 HTML 页面中写入可变的文本：document.write("h1" + name + "/h1")
JavaScript 能够对事件进行反应
可以把 JavaScript 设置为在某事件执行时发生，比如当页面加载完毕或当用户点击某个 HTML 元素时。
JavaScript 可读取并修改 HTML 元素
JavaScript 能够读取并修改 HTML 元素的内容
JavaScript 可被用来验证数据
可使用 JavaScript 在表单被提交到服务器前对表单数据进行验证，这样可确保服务器进行正确的数据处理。

一定要学习我们的 JavaScript 教程。

服务器端脚本

服务器端脚本和因特网服务器编程有关。您应该学习服务器端脚本，这样才能有能力传递更多的动态网站内容。通过服务器端的编程，你可以：

  • 动态地编辑、修改或添加网页内容
  • 对用户从 HTML 提交的查询或数据进行响应
  • 访问数据或数据库，并把结果返回浏览器
  • 访问文件或 XML 数据，并把结果返回浏览器
  • 把 XML 转换为 HTML，并把结果返回到浏览器
  • 为不同的用户定制页面，提高页面的可用性
  • 对不同的网页提供安全和访问控制
  • 为不同类型的浏览器设计不同的输出
  • 最小化网络流量

在 W3SCHOOL，我们通过 ASP 和 PHP 为您演示了服务器端的脚本编程

请确保学习我们的 ASP 教程 和 PHP教程。

使用 SQL 管理数据

结构化查询语言（SQL）是对诸如下列数据库进行访问的通用标准：SQL Server、Oracle、Sybase 以及 Access。

对于那些希望从数据库存储和提取数据的人们来说，有关 SQL 的知识是极具价值的。

任何web管理员都应当明白，SQL 对于 web 上的数据库来说，是一种真正切合的引擎。

请确保学习我们的 SQL 教程。

未来的前景

您需要明白一件很重要的事情，网站的功能性将会彻底地变革。我们会看一种巨大的转变，那就是网站从“静态内容”的展示转向“动态内容”的传递。

我们还会看到很多新式的浏览器，比如移动设备中的浏览器，同时，我们还会看到更多有关服务器间，以及服务器与浏览器间使用XML来进行的数据通信。

  • Previous Page
  • Next Page


网站构建教程

网站构建教程

  • 教程首页
  • 网站构建
  • 网站设计
  • 网络用户
  • 网站标准
  • 网站验证
  • 万维网联盟
  • 网络安全

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

网站构建 高级教程

  • Next Page

当您将我们的《网站构建教程》学习完毕，您会掌握如何建设一个专业的网站。

您也会学到如何做好面向未来的准备，以及如何使用诸如 XHTML 和 XML 之类的新技术。

开始学习网站构建！

内容目录

网站构建
一个网站开发人员必须掌握的知识是什么？不要跳过本章，其中的内容非常重要。所以，将这一章全部读完吧！
网站设计
本章内容：如何设计你的站点。
网络用户
本章内容：网络用户以及他们使用什么类型的设备。
网站标准
本章内容：WEB 标准，以及如何使用它们。
网站验证
本章内容：如何验证您的网站中的 HTML、XHTML、CSS、XML、和 WMP 页面。
万维网联盟
本章内容：万维网联盟。
网络安全
本章内容：当网上冲浪时，如何保护您的计算机。
  • Next Page


网站设计

网站构建教程

  • 教程首页
  • 网站构建
  • 网站设计
  • 网络用户
  • 网站标准
  • 网站验证
  • 万维网联盟
  • 网络安全

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

网站设计

  • Previous Page
  • Next Page

设计网站需要严谨的思考和周全的计划。

最重要的事情是了解您的受众（用户）。

用户都是浏览者

如果您认为一般的用户会完完整整地阅读您的网页，那么您就错了。

无论您在网页中发布了多么有用的信息，一个访问者在决定是否继续阅读之前仅仅会花几秒钟的时间进行浏览。

如果您希望用户阅读您的文字，请确保在页面段落的第一句就说明您的观点。另外，您还需要在整个页面中使用简短的段落以及有趣的标题。

少即是多

使所有的句子尽可能地短。使所有的段落尽可能地短。使所有的章节尽可能地短。使您的页面尽可能地短。

请在段落和章节之间使用很多的留白。充斥着冗长文字的页面会赶走您的用户。

也不要在单一的页面上放置太多的内容。如果确实有必要传递大量的信息，请尽量把内容分为小块，然后放入不同的页面中。不要指望每个访问者都能把一张数千字的页面一路滚动到底。

导航

尽量创建通用于网站中所有页面的导航结构。

把文本段落中的超链接使用量降至最低。请不要使用文本段落内的超链接随意地把访问者带到别的页面。因此这样做会破坏导航结构一致性的感觉。

如果您必须使用超级链接，请把它们添加到段落的底部，或站点的导航菜单。

下载速度

最常见的错误是用于网站开发者的开发环境造成的，例如使用一台本地的机器开发站点，或者使用一条高速的因特网连接。开发人员有时不会意识到下载他们的页面要花很长的时间。

因特网可用性方面的研究告诉我们，如果网页的下载时间超过7秒，大多数的访问者会选择离开。

在您发布任何大量的内容前，请确保这些页面在低速的调制解调器连接上进行过测试。如果您的页面需要花大量的时间下载，您或许应当考虑删除某些图片或多媒体内容。

允许您的用户发言！

得到来自用户的反馈是件好事情。您的访问者就是你的“客户”。他们经常会给您一些有价值的点子，或者无偿地向您提供改进的建议。

如果您提供了某种方便的联系途径，您将得到来自很多技能和知识都各不相同的人们大量有益的反馈。

  • Previous Page
  • Next Page


网站用户

网站构建教程

  • 教程首页
  • 网站构建
  • 网站设计
  • 网络用户
  • 网站标准
  • 网站验证
  • 万维网联盟
  • 网络安全

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

网站用户

  • Previous Page
  • Next Page

您的用户所使用的硬件和软件各不相同。

最重要的事情是了解您的受众（用户）。

他们使用什么显示器？

请记住，在 web 上并非所有用户都使用与您相同的显示器。如果您针对 1024x768 分辨率的现实设计网页，那么某些使用低分辨率显示器的访问者在阅读您的网页时就会出现问题。

尽管某些用户仍然在使用 640x480 分辨率的显示器，但是 800x600 是低分辨率标准的趋势。W3SCHOOL 被设计为支持 1024x768 以上的分辨率。

如果您是拥有极高分辨率的开发人员中的一员，请确保使用了不同的低分辨率显示器来测试您的网页。

当设计网页布局时有一种明智的方法是，把页面的某个部分设计为可变的尺寸，这样就可以适应更大或更小的分辨率显示器。

他们使用什么浏览器？

两种主要的浏览器 (Netscape 和 Microsoft) 都有自己的特征和怪癖，这些都是您在设计网页时必须考虑的。

如果您很重视您的网站，那么请您不要忘记使用不同类型的浏览器来测试每张页面。

目前，最常见的浏览器是 Microsoft Internet Explorer 和 Mozilla Firefox。

此外，某些访问者也许会使用纯文本的浏览器，比如 Lynx，或者他们可能会通过某个类似 AOL 的在线服务来访问您的站点。这些浏览器中的某些可能不会按照您的预想来显示网页。

明智的做法是，使用严谨的、正式的且正确的 HTML（或 XHTML）。严谨且正确的编码总是有助于浏览器正确地显示您的页面。

他们安装了什么插件？

某些网页中的元素，比如声音和视频片断或者其他的多媒体内容，也许需要使用单独的程序（助手应用程序或插件）。

请不要在您的网页中使用这些元素，除非您能够保证访问者有权使用所需的软件来查看它们。

怎样帮助残疾人士？

一些人们拥有严重的视力或听力问题。这些用户也许同样需要访问您站点。

他们中的一些人会使用盲文点字法或基于语言的浏览器来设法阅读您的站点。请记住，如果您不为他们提供某些基于文本的选择来替代图象和其他图形元素，那么所有的视觉内容都会失去作用。

为残疾人士设计网站并非易事，但是有一件小事您是可以做到的 - 至少对于弱视的人们来说 - 令您的网页可使用可调节的字体尺寸。

用户都是浏览者

如果您认为一般的用户会完完整整地阅读您的网页，那么您就错了。

无论您在网页中发布了多么有用的信息，一个访问者在决定是否继续阅读之前仅仅会花几秒钟的时间进行浏览。

如果您希望用户阅读您的文字，请确保在页面段落的第一句就说明您的观点。另外，您还需要在整个页面中使用简短的段落以及有趣的标题。

  • Previous Page
  • Next Page


SMIL In HTML

SMIL 教程

  • SMIL 首页
  • SMIL 简介
  • SMIL 文件
  • SMIL HTML
  • SMIL XHTML
  • SMIL Timing
  • SMIL Sequence
  • SMIL Parallel
  • SMIL Transition
  • SMIL Media
  • SMIL 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SMIL In HTML

  • Previous Page
  • Next Page

Internet Explorer 能够在 HTML 文件中运行 SMIL 呈现。

在 IE 中运行 SMIL 呈现

通过 Internet Explorer 5.5 或更高的版本，能够将 SMIL 元素插入 HTML 文件中。

通过这种方式，任何 SMIL 呈现都能作为标准的 HTML 文件运行在因特网上。

添加引用

如需在 HTML 中使用 SMIL 元素，您必须为 Internet Explorer 定义一个 "time" 命名空间，这样才能识别这些元素。请这样做：

  • 向 <html> 标签添加命名空间定义
  • 添加一个 <?import> 元素，以导入 "time" 命名空间

如需向标准的 HTML 元素添加 SMIL 属性，您必须为 Internet Explorer 定义 "time" 类，这样才能识别这些属性。请这样做：

  • 添加一个定义 "time" 类的 <style> 元素
<html xmlns:time="urn:schemas-microsoft-com:time">
<head>
  <?import namespace="time" implementation="#default#time2">
  <style>.time {behavior: url(#default#time2)}</style>
</head>

在下一段，您可以看到完整的运行实例。

添加 SMIL 元素

如需在 HTML 中运行 SMIL 呈现，只要为 SMIL 元素添加一个前缀以及一个 class 属性：

<time:seq repeatCount="indefinite">
  <img class="time" src="image1.jpg" dur="3s" />
  <img class="time" src="image2.jpg" dur="3s" />
</time:seq>

在上面的例子汇总，我们为 <img> 元素添加了 class="time"，并为 SMIL 元素添加了 "time" 前缀。

提示：类和命名空间不必一定称为 "time"。任何名称都可以。

一个 Internet Explorer 实例

<html xmlns:time="urn:schemas-microsoft-com:time">
<head>
  <?import namespace="time" implementation="#default#time2">
  <style>.time {behavior: url(#default#time2)}</style>
</head>

<body>
  <time:seq repeatCount="indefinite">
    <img class="time" src="image1.jpg" dur="3s" />
    <img class="time" src="image2.jpg" dur="3s" />
  </time:seq>
</body>
</html>

TIY

  • Previous Page
  • Next Page

SMIL 参考手册


SMIL in Parallel

SMIL 教程

  • SMIL 首页
  • SMIL 简介
  • SMIL 文件
  • SMIL HTML
  • SMIL XHTML
  • SMIL Timing
  • SMIL Sequence
  • SMIL Parallel
  • SMIL Transition
  • SMIL Media
  • SMIL 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SMIL in Parallel

  • Previous Page
  • Next Page

<par> 元素中的对象将同时显示（并行地）。

并行元素 <par>

<par> 元素拥有许多属性。最常用的属性有：

属性 | 值 | 描述
begin | time | 设置元素显示之前的延迟。
dur | time | 设置显示的持续时间。
endsync | "first"|"last"|id(clip) | 同步元素的停止。
repeatCount | number | 设置显示的重复次数。

如需完整的 SMIL 元素和属性列表，请访问 W3School SMIL 参考手册。

同步（Synchronization ）

通过在 <par> 标签中使用 endsync 属性，片段的并行组能够在同时停止。

endsync="first" 会在最短的片段结束时停止所有 <par> 组中的片段，无论其它片段的时间参数被如何设置。

endsync="last" 会在所有片段均结束播放时终止 <par> 组。这是默认的。

endsync="id(ID)" 会在被标示 (ID) 的片段结束时终止 <par> 组。该 ID 将引用该片段的 id 属性的值。

实例：同时显示

<html xmlns:t="urn:schemas-microsoft-com:time">
<head>
  <?import namespace="t" implementation="#default#time2">
  <style>.t {behavior: url(#default#time2)}</style>
</head>
<body>

<par>

<t:audio
src="liar.wav"
repeatCount="indefinite"
type="wav" />

<t:seq repeatCount="indefinite">
  <h2 class="t" dur="1s">
  I will display for one second</h2>
  <h2 class="t" dur="2s">
  I will display for two seconds</h2>
</t:seq>

</par>

</body>
</html>

TIY

  • Previous Page
  • Next Page

SMIL 参考手册


SMIL Media 元素

SMIL 教程

  • SMIL 首页
  • SMIL 简介
  • SMIL 文件
  • SMIL HTML
  • SMIL XHTML
  • SMIL Timing
  • SMIL Sequence
  • SMIL Parallel
  • SMIL Transition
  • SMIL Media
  • SMIL 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SMIL Media 元素

  • Previous Page
  • Next Page

SMIL 使用媒介元素来描述内容。

Media 元素

可使用下面的媒介元素在 SMIL 文档中包括媒介对象：

元素 | 描述 | Ver
<animation> | 定义动画。 | 1
<audio> | 定义音频片断。 | 1
<brush> | 定义笔刷。 | 1
<img> | 定义图像。 | 1
<param> | 定义参数。 | 1
<ref> | 定义一般的媒介引用。 | 1
<text> | 定义文本。 | 1
<textstream> | 定义文本流。 | 1
<video> | 定义视频。 | 1

Media 属性

必须使用 src 属性中的引用（URL）来包括 SMIL 文档中的每个媒介对象。src 属性是最常用在媒介元素的属性。

type 属性用于定义媒介类型。如果 type 属性被忽略，则应用程序依赖由服务器告知的类型信息。开发者不应该依靠文件类型扩展名来定义文件类型。

属性 | 描述 | Ver
erase | 定义计时完成后该元素的行为。 | 1
src | 定义媒介对象的源。 | 1
type | 定义媒介类型。 | 1

如需完整的 SMIL 元素和属性列表，请访问 W3School SMIL 参考手册。

<animation> 元素

<animation> 元素定义了对动画对象的引用，该对象是以矢量图型或其他各式存储的。

不应把 <animation> 元素与 <animate> 元素相混淆。<animation> 元素通过引用定义了动画对象。而 <animate> 元素定义了其他元素的动画显示。

<audio> 元素

<audio> 元素定义了对音频对象的引用，该对象是以被录制的音频存储的。

实例：

<html xmlns:t="urn:schemas-microsoft-com:time">
<head>
  <?import namespace="t" implementation="#default#time2">
</head>
<body>

<t:audio
src="liar.wav"
repeatCount="indefinite"
type="wav" />

</body>
</html>

TIY

<brush> 元素

<brush> 元素定义了填充颜色或填充模式。

该元素定义了代替媒介对象的着色颜色或模式。

<img> 元素

<img> 元素定义了对图像对象的引用，该对象以 JPG 或其他图像格式存储。

实例：

<img src="myimage.gif" type="GIF" />

<param> 元素

<param> 元素为任何其他媒介元素定义参数。

实例：

<param name="color" value="red" />

<ref> 元素

<ref> 元素定义了对一般的媒介元素的引用。

可在媒介类型未被良好定义的情况下使用 <ref> 元素。

<text> 元素

<text> 元素定义了对文本对象的引用，该对象被存储为文本。

<textstream> 元素

<textstream> 元素定义了对存储为文本流的文本对象的引用。

<video> 元素

<video> 元素定义了对视频对象的引用，该对象被存储为录制的视频。

例子:

<html xmlns:t="urn:schemas-microsoft-com:time">
<head>
  <?import namespace="t" implementation="#default#time2">
</head>
<body>

<t:video
src="http://www.ananova.com/about/vap_windows_check.wmv"
repeatCount="indefinite"
type="wmv" />

</body>
</html>

TIY

  • Previous Page
  • Next Page

SMIL 参考手册


SMIL Sequence

SMIL 教程

  • SMIL 首页
  • SMIL 简介
  • SMIL 文件
  • SMIL HTML
  • SMIL XHTML
  • SMIL Timing
  • SMIL Sequence
  • SMIL Parallel
  • SMIL Transition
  • SMIL Media
  • SMIL 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SMIL Sequence

  • Previous Page
  • Next Page

<seq> - 最常用的 SMIL 元素 - 定义序列。

序列元素 <seq>

<seq> 元素可定义序列。<seq> 元素中的子元素依次显示在序列中。

您可以使用 <seq> 元素来定义要显示的图像列表、段落列表、视频列表，或任何其他的元素。

<seq> 元素拥有许多属性，最常用的属性有：

属性 | 值 | 描述
begin | time | 在元素被显示之前的延迟。
dur | time | 设置显示的持续时间。
repeatCount | number | 设置显示的重复次数。

如需完整的 SMIL 元素和属性列表，请访问 W3School SMIL 参考手册。

实例：显示图像序列

<html xmlns:t="urn:schemas-microsoft-com:time">
<head>
  <?import namespace="t" implementation="#default#time2">
  <style>.t {behavior: url(#default#time2)}</style>
</head>
<body>

<t:seq repeatCount="indefinite">
  <img class="t" src="image1.jpg" dur="1s" />
  <img class="t" src="image2.jpg" dur="1s" />
</t:seq>

</body>
</html>

TIY

实例：显示文本序列

<html xmlns:t="urn:schemas-microsoft-com:time">
<head>
  <?import namespace="t" implementation="#default#time2">
  <style>.t {behavior: url(#default#time2)}</style>
</head>
<body>

<t:seq repeatCount="indefinite">
  <h2 class="t" dur="1s">
  I will display for one second</h2>
  <h2 class="t" dur="2s">
  I will display for two seconds</h2>
  <h2 class="t" dur="3s">
  I will display for three seconds</h2>
</t:seq>

</body>
</html>

TIY

  • Previous Page
  • Next Page

SMIL 参考手册


SMIL Timing

SMIL 教程

  • SMIL 首页
  • SMIL 简介
  • SMIL 文件
  • SMIL HTML
  • SMIL XHTML
  • SMIL Timing
  • SMIL Sequence
  • SMIL Parallel
  • SMIL Transition
  • SMIL Media
  • SMIL 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SMIL Timing

  • Previous Page
  • Next Page

Timing 表示何时开始，并何时结束。

Timelines 和 Timing

大多数 SMIL 元素使用计时属性来定义呈现的时间线。

计时属性定义了元素的开始的时间，以及持续的时间。

下面的表格列出了可能的时间格式：

格式 例子
hh:mm:ss.f
  • 1:50:00 (1 小时 50 分)
  • 10:50 (10 分 50 秒)
  • 10.5 (10.5 秒)

number

[h|min|s|ms]
  • 3.5h (3.5 小时)
  • 3.5min (3.5 分钟)
  • 3.5sec (3.5 秒)
  • 35ms (35 毫秒)

wallclock

(YYY-MM-DDThh:mm:ss+zone)

wallclock(2003-08-01T12:10:30+1.00)

( 12 点之后 10 分 30 秒, 2003 年 8 月 1 日, 协调世界时 + 1 小时)

值 "indefinite" 可用于定义不结束的循环。

持续时间

元素的持续时间（duration，dur="5s"） 属性定义了元素的可见时长：

<html>
<head>
  <style>.t {behavior: url(#default#time2)}</style>
</head>
<body>

<img class="t" src="image1.jpg" dur="5s" />

</body>
</html>

TIY

从何时开始？

begin (begin="2s") 属性定义元素从何时起可见（开始播放）：

<html>
<head>
  <style>.t {behavior: url(#default#time2)}</style>
</head>
<body>

<img class="t" src="image1.jpg" begin="2s" />

</body>
</html>

TIY

  • Previous Page
  • Next Page

SMIL 参考手册


SMIL Transition

SMIL 教程

  • SMIL 首页
  • SMIL 简介
  • SMIL 文件
  • SMIL HTML
  • SMIL XHTML
  • SMIL Timing
  • SMIL Sequence
  • SMIL Parallel
  • SMIL Transition
  • SMIL Media
  • SMIL 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SMIL Transition

  • Previous Page
  • Next Page

Transition 能够为元素生成“淡入淡出”以及“擦除”等效果。

Transition 属于 SMIL 2.0

Transition 是 SMIL 2.0 中的新特性。Transition 不属于 SMIL 1.0 规范的组成部分。

Internet Explorer 6 支持基于 SMIL 2.0 规范的 Transition。Transition 由 <transitionfilter> 元素实现。

属性

<transitionfilter> 元素拥有若干元素，最常用的有：

属性 | 描述 | 例子
type | 定义 transition 滤镜的类型（参阅 transition 滤镜列表） | type="clockWipe"
begin | 定义何时开始 transition | begin="0s"
mode | 定义 transition 模式 | mode="in"
from | 定义 transition 的开始值 | from="0.2"
to | 定义 transition 的结束值 | to="0.8"

Transition 滤镜

可使用下面的 transition 滤镜：

fade, barnDoorWipe, barWipe, clockWipe, ellipseWipe, fanWipe, irisWipe,
pushWipe, slideWipe, snakeWipe, spiralWipe, starWipe

实例：显示 Transition

<html xmlns:t="urn:schemas-microsoft-com:time">
<head>
<?import namespace="t" implementation="#default#time2">
<style>.t {behavior: url(#default#time2)}</style>
</head>
<body>

<t:transitionfilter targetelement="keyb"
type="clockWipe"
begin="keyb.begin" dur="2s" />

<img id="keyb" class="t" src="pic_keyb.jpg" dur="4s"
width="128" height="107" />

</body>
</html>

在上面的例子中，图像将显示 4 秒钟。Transition 滤镜将用 2 秒钟以 "clockWipe" 的方式把图像显示出来。

提示：您必须运行 Internet Explorer 6 来显示这个例子。

TIY

  • Previous Page
  • Next Page

SMIL 参考手册


SMIL 参考手册

SMIL 教程

  • SMIL 首页
  • SMIL 简介
  • SMIL 文件
  • SMIL HTML
  • SMIL XHTML
  • SMIL Timing
  • SMIL Sequence
  • SMIL Parallel
  • SMIL Transition
  • SMIL Media
  • SMIL 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SMIL 参考手册

  • Previous Page
  • Next Page

下面是完整的 SMIL 参考手册（建设中）。

SMIL Timing 元素

元素 | 描述 | Ver
<excl> | Defines elements to be displayed exclusively | 2
<par> | Defines elements to be displayed in parallel | 1
<seq> | Defines elements to be displayed in a sequence | 1

SMIL Timing 属性

属性 | 描述 | Ver
begin | Sets the delay before the element is displayed | 1
dur | Sets the duration for the display | 1
endsync | Synchronizes the stopping of parallel elements | 1
repeatCount | Sets the number of repetitions for the display | 1

SMIL Media 元素

元素 | 描述 | Ver
<animation> | Defines an animation | 1
<audio> | Defines an audio clip | 1
<brush> | Defines a brush | 1
<img> | Defines an image | 1
<param> | Defines a parameter | 1
<ref> | Defines a generic media reference | 1
<text> | Defines a text | 1
<textstream> | Defines a textstream | 1
<video> | Defines a video | 1

SMIL Structure 元素

元素 | 描述 | Ver
<body> | Defines the body of a SMIL document | 1
<smil> | Defines a SMIL document | 1
  • Previous Page
  • Next Page

SMIL 参考手册


SMIL 简介

SMIL 教程

  • SMIL 首页
  • SMIL 简介
  • SMIL 文件
  • SMIL HTML
  • SMIL XHTML
  • SMIL Timing
  • SMIL Sequence
  • SMIL Parallel
  • SMIL Transition
  • SMIL Media
  • SMIL 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SMIL 简介

  • Previous Page
  • Next Page

SMIL 是一种用于描述视听呈现（audiovisual presentations）的易于学习的类似 HTML 的语言。

您应当具备的基础知识

在继续学习之前，您需要对下面的知识有基本的了解：

  • HTML
  • XHTML
  • XML
  • XML 命名空间

假如您希望首先学习这些项目，请在我们的首页访问这些教程。

什么是 SMIL？

  • SMIL 指同步多媒体集成语言
  • SMIL 的发音是 "smile"
  • SMIL 是一种用于描述视听呈现的语言
  • SMIL 易于学习和理解
  • SMIL 是一种类似 HTML 的语言
  • SMIL 使用 XML 编写
  • SMIL 呈现（SMIL presentations）可以使用文本编辑器来编写
  • SMIL 是 W3C 标准

简化的 SMIL 例子：

<smil>
<body>
  <seq repeatCount="indefinite">
    <img src="image1.jpg" dur="3s" />
    <img src="image2.jpg" dur="3s" />
  </seq>
</body>
</smil>

从上面的例子，您可以看到 SMIL 一门基于 XML、容易理解，而且可以被简单的文本编辑器编写的语言。

<smil></smil> 标签定义 SMIL 文档。<body> 元素定义呈现的主体。<seq> 定义显示序列。repeatCount 属性定了一个非确定的循环。每个 <img> 元素都用 src 属性来定义图像资源，而 dur 属性定义显示的持续时间。

SMIL 可以做什么？

  • SMIL 可用于创建因特网和内联网程序
  • SMIL 可用于创建幻灯片放映呈现
  • SMIL 已被描述为 PowerPoint 的 Internet 对应物
  • SMIL 呈现可显示多种文件类型（文本、视频、音频...）
  • SMIL 可同时显示多个文件
  • SMIL 可从多台网页服务器显示文件
  • SMIL 可包含到其他 SMIL 呈现的链接
  • SMIL 呈现可包含控制按钮（停止、开始、下一步...）
  • SMIL 拥有定义元素序列和持续时间的函数
  • SMIL 拥有定义元素位置和可见性的函数

在 W3C 的 SMIL

自从 1997 年，W3C 一直把 SMIL 作为一门用于精细编制多媒体呈现的语言来发展，以此实时地组合视频、音频、文本以及图形。

在 1997 年 11 月 SMIL 作为工作草案被提交。

SMIL 1.0 在 1998 年 6 月成为 W3C 标准。

SMIL 2.0 在 2001 年 8 月被确立为 W3C 标准。

  • Previous Page
  • Next Page

SMIL 参考手册


SMIL 教程

SMIL 教程

  • SMIL 首页
  • SMIL 简介
  • SMIL 文件
  • SMIL HTML
  • SMIL XHTML
  • SMIL Timing
  • SMIL Sequence
  • SMIL Parallel
  • SMIL Transition
  • SMIL Media
  • SMIL 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SMIL 教程

  • Next Page

SMIL 是一种易学的、类似 HTML、描述视听内容的语言。

您学习本教程后，将了解到什么是 SMIL，如何创建基于多媒体内容的页面，其中包含了音频、视频、图片、文本以及其他媒介类型。

开始学习 SMIL ！

内容目录

SMIL 简介
本章介绍SMIL的概念以及如何使用 SMIL。
SMIL 文件
本章讲解什么是 SMIL 文件。
SMIL HTML
本章介绍如何将 SMIL 应用于 HTML 中。
SMIL XHTML
本章介绍 SMIL 未来在 XHTML 中的应用。
SMIL Timing
本章讲解 SMIL 如何使用 timing 来显示其元素。
SMIL 序列
本章介绍 SMIL 如何显示序列。
SMIL Parallel
本章介绍 SMIL 如何并行地显示对象。
SMIL Transition
本章讲解 SMIL 如何向元素添加 transition（编者注：过渡、转换之意）。
SMIL Media
本章介绍 SMIL 如何定义媒介元素。
SMIL 参考手册
W3School 为您提供的完整的 SMIL 参考手册。
  • Next Page

SMIL 参考手册


SMIL 文件

SMIL 教程

  • SMIL 首页
  • SMIL 简介
  • SMIL 文件
  • SMIL HTML
  • SMIL XHTML
  • SMIL Timing
  • SMIL Sequence
  • SMIL Parallel
  • SMIL Transition
  • SMIL Media
  • SMIL 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SMIL 文件

  • Previous Page
  • Next Page

SMIL 文件可描述多媒体呈现 (multimedia presentation)。

SMIL 文件

SMIL 文件包含了描述多媒体程序所需的所有信息。

存储 SMIL 文件的扩展名是 *.smil。

SMIL 文件包含：

  • 呈现的布局 (the layout of the presentation )
  • 呈现的时间线 (The timeline of the presentation)
  • 多媒体元素的源 (The source of the multimedia elements )

SMIL 标记

由于 SMIL 基于 XML，因此其标签对大小写敏感。所有的 SMIL 标记都必须是小写字母。

SMIL 文档必须以 <smil> 标签开始，并以 </smil> 标签结束。它可包含一个 <head> 元素，且必须包含一个 <body> 元素。

<head> 元素用于存储有关呈现布局的信息，以及其他的元信息。

<body> 包含媒介元素。

<smil>
<body>
  <seq repeatCount="indefinite">
    <img src="image1.jpg" dur="3s" />
    <img src="image2.jpg" dur="3s" />
  </seq>
</body>
</smil>

如何播放 SMIL 文件？

如需播放 SMIL 呈现，你需要一个 SMIL 播放器。可以在因特网上找到不同的 SMIL 播放器：

  • RealNetworks 的 RealOne 平台提供了对 SMIL 2.0 的充分支持
  • Oratrix 的 GRiNS for SMIL-2.0 提供了一款 SMIL 2.0 播放器
  • InterObject 的 SMIL 播放器支持 SMIL 2.0 的基础框架

在 Internet Explorer 中播放 SMIL 呈现

通过 Internet Explorer 5.5 或更新的版本，能够把 SMIL 元素插入 HTML 文件中。

通过这种方式，任何 SMIL 呈现都能作为标准的 HTML 文件运行在因特网上。

本教程的其余部分将使用 Internet Explorer 5.5 或更高的版本来演示不同 SMIL 元素的使用。

  • Previous Page
  • Next Page

SMIL 参考手册


XHTML+SMIL

SMIL 教程

  • SMIL 首页
  • SMIL 简介
  • SMIL 文件
  • SMIL HTML
  • SMIL XHTML
  • SMIL Timing
  • SMIL Sequence
  • SMIL Parallel
  • SMIL Transition
  • SMIL Media
  • SMIL 参考

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XHTML+SMIL

  • Previous Page
  • Next Page

下一代的浏览器对音频和视频的处理，会像老式浏览器处理文本和图像那样简单。

HTML+TIME

在上一节中，您看到了 Internet Explorer 能够在 HTML 中显示 SMIL 元素。

其背景的历史简短如下：

在 1998 年 6 月，MIL 1.0 成为 W3C 推荐标准。

在 1998 年 9 月，Microsoft、Macromedia、Compaq/Digital 以及 Digital Renaissance 把 HTML+TIME 作为向 HTML 添加 SMIL 1.0 计时和同步的提案提交到了 W3C。

HTML+TIME 文档描述了可在 Internet Explorer 5 中体现出的对 SMIL 的诸多支持。

XHTML+SMIL

在 2001 年 8 月，SMIL 2.0 成为 W3C 推荐标准，XHTML+SMIL 成为了一个独立的工作草案，它基于 HTML+TIME 记录中的理念。

XHTML+SMIL 文档描述了可在 Internet Explorer 6.0 中找到的对 SMIL 的诸多支持。

您可以在我们的 W3C 教程中读到更多有关 SMIL 活动的内容。

目前正在发生什么？

SMIL 目前正处于一个非常有趣的开发过程中。

SMIL 1.0 定义了一种简单的方法来创建可视化的程序以及如何播放它们。

HTML+TIME 为几乎所有的 HTML 元素添加了 SMIL 1.0 能力。

SMIL 2.0 向 SMIL 1.0 添加了交互性（interactivity）和转换（transitions）。

XHTML+SMIL 为几乎所有的 HTML 元素添加了 SMIL 2.0 能力。

XHTML+SMIL 拥有把 web 带入更高水平的巨大潜能，使浏览器能够像老式浏览器处理文本和处理图像那样处理视频和音频。大部分的特性已经在 Internet Explorer 中实现了。

Why XHTML+SMIL?

这还不明显吗？

要想运行 SMIL 呈现，您就需要 SMIL 播放器。如果您希望您的受众看到这些呈现，他们就必须安装 SMIL 播放。如果受众在因特网浏览器中就能够显示您的呈现，那岂不是更好吗？

SMIL 定义了一系列的多媒体元素。可以为其中的每个元素都赋予布局、计时以及转换属性和规则。如果您能够把这些属性和规则添加到所有 HTML 元素，那岂不是更好吗？

在 W3School，我们创建了许多实例，任何人都可以使用简单的文本编辑器来提炼其中的精华，然后向电视媒介那样有效地传播他们的理念。请深入其中，亲自去实践吧。

  • Previous Page
  • Next Page

SMIL 参考手册


SOAP Body 元素

SOAP 教程

  • SOAP 首页
  • SOAP 简介
  • SOAP 语法
  • SOAP Envelope
  • SOAP Header
  • SOAP Body
  • SOAP Fault
  • SOAP HTTP Binding
  • SOAP 实例
  • SOAP 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SOAP Body 元素

  • Previous Page
  • Next Page

强制使用的 SOAP Body 元素包含实际的 SOAP 消息。

SOAP Body 元素

必需的 SOAP Body 元素可包含打算传送到消息最终端点的实际 SOAP 消息。

SOAP Body 元素的直接子元素可以是合格的命名空间。SOAP 在默认的命名空间中("http://www.w3.org/2001/12/soap-envelope")定义了 Body 元素内部的一个元素。即 SOAP 的 Fault 元素，用于指示错误消息。

<?xml version="1.0"?>
<soap:Envelope
xmlns:soap="http://www.w3.org/2001/12/soap-envelope"
soap:encodingStyle="http://www.w3.org/2001/12/soap-encoding">

<soap:Body>
   <m:GetPrice xmlns:m="http://www.w3school.com.cn/prices">
      <m:Item>Apples</m:Item>
   </m:GetPrice>
</soap:Body>

</soap:Envelope>

上面的例子请求苹果的价格。请注意，上面的 m:GetPrice 和 Item 元素是应用程序专用的元素。它们并不是 SOAP 标准的一部分。

而一个 SOAP 响应应该类似这样：

<?xml version="1.0"?>
<soap:Envelope
xmlns:soap="http://www.w3.org/2001/12/soap-envelope"
soap:encodingStyle="http://www.w3.org/2001/12/soap-encoding">

<soap:Body>
   <m:GetPriceResponse xmlns:m="http://www.w3school.com.cn/prices">
      <m:Price>1.90</m:Price>
   </m:GetPriceResponse>
</soap:Body>

</soap:Envelope>
  • Previous Page
  • Next Page


SOAP Envelope 元素

SOAP 教程

  • SOAP 首页
  • SOAP 简介
  • SOAP 语法
  • SOAP Envelope
  • SOAP Header
  • SOAP Body
  • SOAP Fault
  • SOAP HTTP Binding
  • SOAP 实例
  • SOAP 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SOAP Envelope 元素

  • Previous Page
  • Next Page

强制使用的 SOAP 的 Envelope 元素是 SOAP 消息的根元素。

SOAP Envelope 元素

必需的 SOAP 的 Envelope 元素是 SOAP 消息的根元素。它可把 XML 文档定义为 SOAP 消息。

请注意 xmlns:soap 命名空间的使用。它的值应当始终是：

http://www.w3.org/2001/12/soap-envelope

并且它可把封装定义为 SOAP 封装：

<?xml version="1.0"?>
<soap:Envelope
xmlns:soap="http://www.w3.org/2001/12/soap-envelope"
soap:encodingStyle="http://www.w3.org/2001/12/soap-encoding">
  ...
  Message information goes here
  ...
</soap:Envelope>

xmlns:soap 命名空间

SOAP 消息必须拥有与命名空间 "http://www.w3.org/2001/12/soap-envelope" 相关联的一个 Envelope 元素。

如果使用了不同的命名空间，应用程序会发生错误，并抛弃此消息。

encodingStyle 属性

SOAP 的 encodingStyle 属性用于定义在文档中使用的数据类型。此属性可出现在任何 SOAP 元素中，并会被应用到元素的内容及元素的所有子元素上。SOAP 消息没有默认的编码方式。

语法

soap:encodingStyle="URI"

实例

<?xml version="1.0"?>
<soap:Envelope
xmlns:soap="http://www.w3.org/2001/12/soap-envelope"
soap:encodingStyle="http://www.w3.org/2001/12/soap-encoding">
...
Message information goes here
...
</soap:Envelope>
  • Previous Page
  • Next Page


SOAP Fault 元素

SOAP 教程

  • SOAP 首页
  • SOAP 简介
  • SOAP 语法
  • SOAP Envelope
  • SOAP Header
  • SOAP Body
  • SOAP Fault
  • SOAP HTTP Binding
  • SOAP 实例
  • SOAP 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SOAP Fault 元素

  • Previous Page
  • Next Page

可选的 SOAP Fault 元素用于存留 SOAP 消息的错误和状态信息。

SOAP Fault 元素

来自 SOAP 消息的错误消息被携带于 Fault 元素内部。

如果已提供了 Fault 元素，则它必须是 Body 元素的子元素。在一条 SOAP 消息中，Fault 元素只能出现一次。

SOAP 的 Fault 元素用于下列子元素：

子元素 | 描述
<faultcode> | 供识别故障的代码
<faultstring> | 可供人阅读的有关故障的说明
<faultactor> | 有关是谁引发故障的信息
<detail> | 存留涉及 Body 元素的应用程序专用错误信息

SOAP Fault Codes

在下面定义的 faultcode 值必须用于描述故障时的 faultcode 元素中：

错误 | 描述
VersionMismatch | SOAP Envelope 元素的无效命名空间被发现
MustUnderstand | Header 元素的一个直接子元素（带有设置为 "1" 的 mustUnderstand 属性）无法被理解。
Client | 消息被不正确地构成，或包含了不正确的信息。
Server | 服务器有问题，因此无法处理进行下去。
  • Previous Page
  • Next Page


SOAP Header 元素

SOAP 教程

  • SOAP 首页
  • SOAP 简介
  • SOAP 语法
  • SOAP Envelope
  • SOAP Header
  • SOAP Body
  • SOAP Fault
  • SOAP HTTP Binding
  • SOAP 实例
  • SOAP 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SOAP Header 元素

  • Previous Page
  • Next Page

可选的 SOAP Header 元素包含头部信息。

SOAP Header 元素

可选的 SOAP Header 元素可包含有关 SOAP 消息的应用程序专用信息（比如认证、支付等）。如果 Header 元素被提供，则它必须是 Envelope 元素的第一个子元素。

注释：所有 Header 元素的直接子元素必须是合格的命名空间。

<?xml version="1.0"?>
<soap:Envelope
xmlns:soap="http://www.w3.org/2001/12/soap-envelope"
soap:encodingStyle="http://www.w3.org/2001/12/soap-encoding">

<soap:Header>
<m:Trans
xmlns:m="http://www.w3school.com.cn/transaction/"
soap:mustUnderstand="1">234</m:Trans>
</soap:Header>

...
...

</soap:Envelope>

上面的例子包含了一个带有一个 "Trans" 元素的头部，它的值是 234，此元素的 "mustUnderstand" 属性的值是 "1"。

SOAP 在默认的命名空间中 ("http://www.w3.org/2001/12/soap-envelope") 定义了三个属性。这三个属性是：actor、 mustUnderstand 以及 encodingStyle。这些被定义在 SOAP 头部的属性可定义容器如何对 SOAP 消息进行处理。

actor 属性

通过沿着消息路径经过不同的端点，SOAP 消息可从某个发送者传播到某个接收者。并非 SOAP 消息的所有部分均打算传送到 SOAP 消息的最终端点，不过，另一个方面，也许打算传送给消息路径上的一个或多个端点。

SOAP 的 actor 属性可被用于将 Header 元素寻址到一个特定的端点。

语法

soap:actor="URI"

实例

<?xml version="1.0"?>
<soap:Envelope
xmlns:soap="http://www.w3.org/2001/12/soap-envelope"
soap:encodingStyle="http://www.w3.org/2001/12/soap-encoding">

<soap:Header>
<m:Trans
xmlns:m="http://www.w3school.com.cn/transaction/"
soap:actor="http://www.w3school.com.cn/appml/">
234
</m:Trans>
</soap:Header>

...
...

</soap:Envelope>

mustUnderstand 属性

SOAP 的 mustUnderstand 属性可用于标识标题项对于要对其进行处理的接收者来说是强制的还是可选的。

假如您向 Header 元素的某个子元素添加了 "mustUnderstand="1"，则它可指示处理此头部的接收者必须认可此元素。假如此接收者无法认可此元素，则在处理此头部时必须失效。

语法

soap:mustUnderstand="0|1"

实例

<?xml version="1.0"?>
<soap:Envelope
xmlns:soap="http://www.w3.org/2001/12/soap-envelope"
soap:encodingStyle="http://www.w3.org/2001/12/soap-encoding">

<soap:Header>
<m:Trans
xmlns:m="http://www.w3school.com.cn/transaction/"
soap:mustUnderstand="1">
234
</m:Trans>
</soap:Header>

...
...

</soap:Envelope>

encodingStyle 属性

SOAP 的 encodingStyle 属性在上一节中已解释过了。

  • Previous Page
  • Next Page


SOAP HTTP Binding

SOAP 教程

  • SOAP 首页
  • SOAP 简介
  • SOAP 语法
  • SOAP Envelope
  • SOAP Header
  • SOAP Body
  • SOAP Fault
  • SOAP HTTP Binding
  • SOAP 实例
  • SOAP 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SOAP HTTP Binding

  • Previous Page
  • Next Page

HTTP 协议

HTTP 在 TCP/IP 之上进行通信。HTTP 客户机使用 TCP 连接到 HTTP 服务器。在建立连接之后，客户机可向服务器发送 HTTP 请求消息：

POST /item HTTP/1.1
Host: 189.123.345.239
Content-Type: text/plain
Content-Length: 200

随后服务器会处理此请求，然后向客户机发送一个 HTTP 响应。此响应包含了可指示请求状态的状态代码：

200 OK
Content-Type: text/plain
Content-Length: 200

在上面的例子中，服务器返回了一个 200 的状态代码。这是 HTTP 的标准成功代码。

假如服务器无法对请求进行解码，它可能会返回类似这样的信息：

400 Bad Request
Content-Length: 0

SOAP HTTP Binding

SOAP 方法指的是遵守 SOAP 编码规则的 HTTP 请求/响应。

HTTP + XML = SOAP

SOAP 请求可能是 HTTP POST 或 HTTP GET 请求。

HTTP POST 请求规定至少两个 HTTP 头：Content-Type 和 Content-Length。

Content-Type

SOAP 的请求和响应的 Content-Type 头可定义消息的 MIME 类型，以及用于请求或响应的 XML 主体的字符编码（可选）。

语法

Content-Type: MIMEType; charset=character-encoding

例子

POST /item HTTP/1.1
Content-Type: application/soap+xml; charset=utf-8

Content-Length

SOAP 的请求和响应的 Content-Length 头规定请求或响应主体的字节数。

语法

Content-Length: bytes

例子

POST /item HTTP/1.1
Content-Type: application/soap+xml; charset=utf-8
Content-Length: 250
  • Previous Page
  • Next Page


SOAP 简介

SOAP 教程

  • SOAP 首页
  • SOAP 简介
  • SOAP 语法
  • SOAP Envelope
  • SOAP Header
  • SOAP Body
  • SOAP Fault
  • SOAP HTTP Binding
  • SOAP 实例
  • SOAP 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SOAP 简介

  • Previous Page
  • Next Page

SOAP 是基于 XML 的简易协议，可使应用程序在 HTTP 之上进行信息交换。

或者更简单地说：SOAP 是用于访问网络服务的协议。

您应当具备的基础知识

在继续学习之前，您需要对下面的知识有基本的了解：

  • XML
  • XML 命名空间

如果您希望首先学习这些项目，请访问我们的《XML 教程》。

什么是 SOAP？

  • SOAP 指简易对象访问协议
  • SOAP 是一种通信协议
  • SOAP 用于应用程序之间的通信
  • SOAP 是一种用于发送消息的格式
  • SOAP 被设计用来通过因特网进行通信
  • SOAP 独立于平台
  • SOAP 独立于语言
  • SOAP 基于 XML
  • SOAP 很简单并可扩展
  • SOAP 允许您绕过防火墙
  • SOAP 将被作为 W3C 标准来发展

Why SOAP？

对于应用程序开发来说，使程序之间进行因特网通信是很重要的。

目前的应用程序通过使用远程过程调用（RPC）在诸如 DCOM 与 CORBA 等对象之间进行通信，但是 HTTP 不是为此设计的。RPC 会产生兼容性以及安全问题；防火墙和代理服务器通常会阻止此类流量。

通过 HTTP 在应用程序间通信是更好的方法，因为 HTTP 得到了所有的因特网浏览器及服务器的支持。SOAP 就是被创造出来完成这个任务的。

SOAP 提供了一种标准的方法，使得运行在不同的操作系统并使用不同的技术和编程语言的应用程序可以互相进行通信。

Microsoft 和 SOAP

SOAP 是微软 .net 架构的关键元素，用于未来的因特网应用程序开发。

SOAP 1.1 被提交到 W3C

在 2000 年 5 月，UserLand、Ariba、Commerce One、Compaq、Developmentor、HP、IBM、IONA、Lotus、Microsoft 以及 SAP 向 W3C 提交了 SOAP 因特网协议，这些公司期望此协议能够通过使用因特网标准（HTTP 以及 XML）把图形用户界面桌面应用程序连接到强大的因特网服务器，以此来彻底变革应用程序的开发。

W3C 正在发展 SOAP 1.2

首个关于 SOAP 的公共工作草案由 W3C 在 2001 年 12 月发布。如需阅读更多有关在 W3C 的 SOAP 活动的内容，请访问我们的《W3C 教程》。

  • Previous Page
  • Next Page


SOAP 教程

SOAP 教程

  • SOAP 首页
  • SOAP 简介
  • SOAP 语法
  • SOAP Envelope
  • SOAP Header
  • SOAP Body
  • SOAP Fault
  • SOAP HTTP Binding
  • SOAP 实例
  • SOAP 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SOAP 教程

  • Next Page

SOAP 是一种简单的基于 XML 的协议，它使应用程序通过 HTTP 来交换信息。

在我们的 SOAP 教程中，你将了解到什么是 SOAP，以及它如何在应用程序之间交换信息。

开始学习 SOAP ！

内容目录

SOAP 简介
本章讲解 SOAP 的概念和作用。
SOAP 语法
本章讲解 SOAP 的构建模块和 SOAP 的语法规则。
SOAP Envelope 元素
本章讲解 SOAP 的 Envelope 元素。
SOAP Header 元素
本章讲解 SOAP 的 Header 元素。
SOAP Body 元素
本章讲解 SOAP 的 Body 元素。
SOAP Fault 元素
本章讲解 SOAP 的 Fault 元素。
SOAP HTTP Binding
本章是对 SOAP HTTP 绑定的简介。
SOAP 实例
本章介绍了一个 SOAP 实例。
SOAP 总结
本节是对您在本教程所学内容的一个总结，并为您推荐了下一步应该学习的内容。
  • Next Page


SOAP 实例

SOAP 教程

  • SOAP 首页
  • SOAP 简介
  • SOAP 语法
  • SOAP Envelope
  • SOAP Header
  • SOAP Body
  • SOAP Fault
  • SOAP HTTP Binding
  • SOAP 实例
  • SOAP 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SOAP 实例

  • Previous Page
  • Next Page

一个 SOAP 实例

在下面的例子中，一个 GetStockPrice 请求被发送到了服务器。此请求有一个 StockName 参数，而在响应中则会返回一个 Price 参数。此功能的命名空间被定义在此地址中： "http://www.example.org/stock"

SOAP 请求：

POST /InStock HTTP/1.1
Host: www.example.org
Content-Type: application/soap+xml; charset=utf-8
Content-Length: nnn

<?xml version="1.0"?>
<soap:Envelope
xmlns:soap="http://www.w3.org/2001/12/soap-envelope"
soap:encodingStyle="http://www.w3.org/2001/12/soap-encoding">

  <soap:Body xmlns:m="http://www.example.org/stock">
    <m:GetStockPrice>
      <m:StockName>IBM</m:StockName>
    </m:GetStockPrice>
  </soap:Body>

</soap:Envelope>

SOAP 响应：

HTTP/1.1 200 OK
Content-Type: application/soap+xml; charset=utf-8
Content-Length: nnn

<?xml version="1.0"?>
<soap:Envelope
xmlns:soap="http://www.w3.org/2001/12/soap-envelope"
soap:encodingStyle="http://www.w3.org/2001/12/soap-encoding">

  <soap:Body xmlns:m="http://www.example.org/stock">
    <m:GetStockPriceResponse>
      <m:Price>34.5</m:Price>
    </m:GetStockPriceResponse>
  </soap:Body>

</soap:Envelope>
  • Previous Page
  • Next Page


SOAP 语法

SOAP 教程

  • SOAP 首页
  • SOAP 简介
  • SOAP 语法
  • SOAP Envelope
  • SOAP Header
  • SOAP Body
  • SOAP Fault
  • SOAP HTTP Binding
  • SOAP 实例
  • SOAP 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SOAP 语法

  • Previous Page
  • Next Page

SOAP 构建模块

一条 SOAP 消息就是一个普通的 XML 文档，包含下列元素：

  • 必需的 Envelope 元素，可把此 XML 文档标识为一条 SOAP 消息
  • 可选的 Header 元素，包含头部信息
  • 必需的 Body 元素，包含所有的调用和响应信息
  • 可选的 Fault 元素，提供有关在处理此消息所发生错误的信息

所有以上的元素均被声明于针对 SOAP 封装的默认命名空间中：

http://www.w3.org/2001/12/soap-envelope

以及针对 SOAP 编码和数据类型的默认命名空间：

http://www.w3.org/2001/12/soap-encoding

语法规则

这里是一些重要的语法规则：

  • SOAP 消息必须用 XML 来编码
  • SOAP 消息必须使用 SOAP Envelope 命名空间
  • SOAP 消息必须使用 SOAP Encoding 命名空间
  • SOAP 消息不能包含 DTD 引用
  • SOAP 消息不能包含 XML 处理指令

SOAP 消息的基本结构

<?xml version="1.0"?>
<soap:Envelope
xmlns:soap="http://www.w3.org/2001/12/soap-envelope"
soap:encodingStyle="http://www.w3.org/2001/12/soap-encoding">

<soap:Header>
  ...
  ...
</soap:Header>

<soap:Body>
  ...
  ...
  <soap:Fault>
    ...
    ...
  </soap:Fault>
</soap:Body>

</soap:Envelope>
  • Previous Page
  • Next Page


您已经学习了 SOAP，下一步呢？

SOAP 教程

  • SOAP 首页
  • SOAP 简介
  • SOAP 语法
  • SOAP Envelope
  • SOAP Header
  • SOAP Body
  • SOAP Fault
  • SOAP HTTP Binding
  • SOAP 实例
  • SOAP 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

您已经学习了 SOAP，下一步呢？

  • Previous Page
  • Next Page

SOAP 概要

此教程已向您讲解了如何透过 HTTP 使用 SOAP 在应用程序之间交换信息。

您已经学习了有关 SOAP 消息中不同元素和属性的知识。

您也学习了如何把 SOAP 作为一种协议来使用以访问 web service。

您已经学习了 SOAP，下一步呢？

下一步应该学习 WSDL 和 Web Services。

WSDL

WSDL 是基于 XML 的语言，用于描述 Web services 以及如何访问它们。

WSDL 可描述某个 web service，连同用于此 web service 的消息格式和协议细节。

如果您需要学习更多有关 WSDL 的知识，请访问我们的 WSDL 教程。

Web Services

Web services 可把应用程序转换为网络应用程序（web-applications）。

通过使用 XML，消息可在应用程序之间进行传送。

如果您需要学习更多有关 web services 的知识，请访问我们的 Web Services 教程。

  • Previous Page
  • Next Page


MySQL CURDATE() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

MySQL CURDATE() 函数

MySQL Date 函数

定义和用法

CURDATE() 函数返回当前的日期。

语法

CURDATE()

实例

例子 1

下面是 SELECT 语句：

SELECT NOW(),CURDATE(),CURTIME()

结果类似：

NOW() | CURDATE() | CURTIME()
2008-12-29 16:25:46 | 2008-12-29 | 16:25:46

例子 2

下面的 SQL 创建带有日期时间列 (OrderDate) 的 "Orders" 表：

CREATE TABLE Orders
(
OrderId int NOT NULL,
ProductName varchar(50) NOT NULL,
OrderDate datetime NOT NULL DEFAULT CURDATE(),
PRIMARY KEY (OrderId)
)

请注意，OrderDate 列规定 CURDATE() 作为默认值。作为结果，当您向表中插入行时，当前日期和时间自动插入列中。

现在，我们希望在 "Orders" 表中插入一条新纪录：

INSERT INTO Orders (ProductName) VALUES ('Computer')

"Orders" 表将类似这样：

OrderId | ProductName | OrderDate
1 | 'Computer' | 2008-12-29

MySQL Date 函数

SQL 测验


MySQL CURTIME() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

MySQL CURTIME() 函数

MySQL Date 函数

定义和用法

CURTIME() 函数返回当前的时间。

语法

CURTIME()

实例

下面是 SELECT 语句：

SELECT NOW(),CURDATE(),CURTIME()

结果类似：

NOW() | CURDATE() | CURTIME()
2008-12-29 16:25:46 | 2008-12-29 | 16:25:46

MySQL Date 函数

SQL 测验


MySQL DATE_ADD() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

MySQL DATE_ADD() 函数

MySQL Date 函数

定义和用法

DATE_ADD() 函数向日期添加指定的时间间隔。

语法

DATE_ADD(date,INTERVAL expr type)

date 参数是合法的日期表达式。expr 参数是您希望添加的时间间隔。

type 参数可以是下列值：

Type 值
MICROSECOND
SECOND
MINUTE
HOUR
DAY
WEEK
MONTH
QUARTER
YEAR
SECOND_MICROSECOND
MINUTE_MICROSECOND
MINUTE_SECOND
HOUR_MICROSECOND
HOUR_SECOND
HOUR_MINUTE
DAY_MICROSECOND
DAY_SECOND
DAY_MINUTE
DAY_HOUR
YEAR_MONTH

实例

假设我们有如下的表：

OrderId | ProductName | OrderDate
1 | 'Computer' | 2008-12-29 16:25:46.635

现在，我们希望向 "OrderDate" 添加 2 天，这样就可以找到付款日期。

我们使用下面的 SELECT 语句：

SELECT OrderId,DATE_ADD(OrderDate,INTERVAL 2 DAY) AS OrderPayDate
FROM Orders

结果：

OrderId | OrderPayDate
1 | 2008-12-31 16:25:46.635

MySQL Date 函数

SQL 测验


MySQL DATE_FORMAT() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

MySQL DATE_FORMAT() 函数

MySQL Date 函数

定义和用法

DATE_FORMAT() 函数用于以不同的格式显示日期/时间数据。

语法

DATE_FORMAT(date,format)

date 参数是合法的日期。format 规定日期/时间的输出格式。

可以使用的格式有：

格式 | 描述
%a | 缩写星期名
%b | 缩写月名
%c | 月，数值
%D | 带有英文前缀的月中的天
%d | 月的天，数值(00-31)
%e | 月的天，数值(0-31)
%f | 微妙
%H | 小时 (00-23)
%h | 小时 (01-12)
%I | 小时 (01-12)
%i | 分钟，数值(00-59)
%j | 年的天 (001-366)
%k | 小时 (0-23)
%l | 小时 (1-12)
%M | 月名
%m | 月，数值(00-12)
%p | AM 或 PM
%r | 时间，12-小时（hh:mm:ss AM 或 PM）
%S | 秒(00-59)
%s | 秒(00-59)
%T | 时间, 24-小时 (hh:mm:ss)
%U | 周 (00-53) 星期日是一周的第一天
%u | 周 (00-53) 星期一是一周的第一天
%V | 周 (01-53) 星期日是一周的第一天，与 %X 使用
%v | 周 (01-53) 星期一是一周的第一天，与 %x 使用
%W | 星期名
%w | 周的天 （0=星期日, 6=星期六）
%X | 年，其中的星期日是周的第一天，4 位，与 %V 使用
%x | 年，其中的星期一是周的第一天，4 位，与 %v 使用
%Y | 年，4 位
%y | 年，2 位

实例

下面的脚本使用 DATE_FORMAT() 函数来显示不同的格式。我们使用 NOW() 来获得当前的日期/时间：

DATE_FORMAT(NOW(),'%b %d %Y %h:%i %p')
DATE_FORMAT(NOW(),'%m-%d-%Y')
DATE_FORMAT(NOW(),'%d %b %y')
DATE_FORMAT(NOW(),'%d %b %Y %T:%f')

结果类似：

Dec 29 2008 11:45 PM
12-29-2008
29 Dec 08
29 Dec 2008 16:25:46.635

MySQL Date 函数

SQL 测验


MySQL DATE_SUB() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

MySQL DATE_SUB() 函数

MySQL Date 函数

定义和用法

DATE_SUB() 函数从日期减去指定的时间间隔。

语法

DATE_SUB(date,INTERVAL expr type)

date 参数是合法的日期表达式。expr 参数是您希望添加的时间间隔。

type 参数可以是下列值：

Type 值
MICROSECOND
SECOND
MINUTE
HOUR
DAY
WEEK
MONTH
QUARTER
YEAR
SECOND_MICROSECOND
MINUTE_MICROSECOND
MINUTE_SECOND
HOUR_MICROSECOND
HOUR_SECOND
HOUR_MINUTE
DAY_MICROSECOND
DAY_SECOND
DAY_MINUTE
DAY_HOUR
YEAR_MONTH

实例

假设我们有如下的表：

OrderId | ProductName | OrderDate
1 | 'Computer' | 2008-12-29 16:25:46.635

现在，我们希望从 "OrderDate" 减去 2 天。

我们使用下面的 SELECT 语句：

SELECT OrderId,DATE_SUB(OrderDate,INTERVAL 2 DAY) AS OrderPayDate
FROM Orders

结果：

OrderId | OrderPayDate
1 | 2008-12-27 16:25:46.635

MySQL Date 函数

SQL 测验


MySQL DATE() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

MySQL DATE() 函数

MySQL Date 函数

定义和用法

DATE() 函数返回日期或日期/时间表达式的日期部分。

语法

DATE(date)

date 参数是合法的日期表达式。

实例

假设我们有如下的表：

OrderId | ProductName | OrderDate
1 | 'Computer' | 2008-12-29 16:25:46.635

我们使用下面的 SELECT 语句：

SELECT ProductName, DATE(OrderDate) AS OrderDate
FROM Orders
WHERE OrderId=1

结果：

ProductName | OrderDate
'Computer' | 2008-12-29

MySQL Date 函数

SQL 测验


MySQL DATEDIFF() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

MySQL DATEDIFF() 函数

MySQL Date 函数

定义和用法

DATEDIFF() 函数返回两个日期之间的天数。

语法

DATEDIFF(date1,date2)

date1 和 date2 参数是合法的日期或日期/时间表达式。

注释：只有值的日期部分参与计算。

实例

例子 1

使用如下 SELECT 语句：

SELECT DATEDIFF('2008-12-30','2008-12-29') AS DiffDate

结果：

DiffDate
1

例子 2

使用如下 SELECT 语句：

SELECT DATEDIFF('2008-12-29','2008-12-30') AS DiffDate

结果：

DiffDate
-1

MySQL Date 函数

SQL 测验


MySQL EXTRACT() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

MySQL EXTRACT() 函数

MySQL Date 函数

定义和用法

EXTRACT() 函数用于返回日期/时间的单独部分，比如年、月、日、小时、分钟等等。

语法

EXTRACT(unit FROM date)

date 参数是合法的日期表达式。unit 参数可以是下列的值：

Unit 值
MICROSECOND
SECOND
MINUTE
HOUR
DAY
WEEK
MONTH
QUARTER
YEAR
SECOND_MICROSECOND
MINUTE_MICROSECOND
MINUTE_SECOND
HOUR_MICROSECOND
HOUR_SECOND
HOUR_MINUTE
DAY_MICROSECOND
DAY_SECOND
DAY_MINUTE
DAY_HOUR
YEAR_MONTH

实例

假设我们有如下的表：

OrderId | ProductName | OrderDate
1 | 'Computer' | 2008-12-29 16:25:46.635

我们使用下面的 SELECT 语句：

SELECT EXTRACT(YEAR FROM OrderDate) AS OrderYear,
EXTRACT(MONTH FROM OrderDate) AS OrderMonth,
EXTRACT(DAY FROM OrderDate) AS OrderDay,
FROM Orders
WHERE OrderId=1

结果：

OrderYear | OrderMonth | OrderDay
2008 | 12 | 29

MySQL Date 函数

SQL 测验


MySQL NOW() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

MySQL NOW() 函数

MySQL Date 函数

定义和用法

NOW() 函数返回当前的日期和时间。

语法

NOW()

实例

例子 1

下面是 SELECT 语句：

SELECT NOW(),CURDATE(),CURTIME()

结果类似：

NOW() | CURDATE() | CURTIME()
2008-12-29 16:25:46 | 2008-12-29 | 16:25:46

例子 2

下面的 SQL 创建带有日期时间列 (OrderDate) 的 "Orders" 表：

CREATE TABLE Orders
(
OrderId int NOT NULL,
ProductName varchar(50) NOT NULL,
OrderDate datetime NOT NULL DEFAULT NOW(),
PRIMARY KEY (OrderId)
)

请注意，OrderDate 列规定 NOW() 作为默认值。作为结果，当您向表中插入行时，当前日期和时间自动插入列中。

现在，我们希望在 "Orders" 表中插入一条新纪录：

INSERT INTO Orders (ProductName) VALUES ('Computer')

"Orders" 表将类似这样：

OrderId | ProductName | OrderDate
1 | 'Computer' | 2008-12-29 16:25:46.635

MySQL Date 函数

SQL 测验


SQL Alias（别名）

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL Alias（别名）

  • Previous Page
  • Next Page

通过使用 SQL，可以为列名称和表名称指定别名（Alias）。

SQL Alias

列的 SQL Alias 语法

SELECT column_name(s)
FROM table_name
AS alias_name

表的 SQL Alias 语法

SELECT column_name AS alias_name
FROM table_name

Alias 实例: 使用表名称别名

假设我们有两个表分别是："Persons" 和 "Product_Orders"。我们分别为它们指定别名 "p" 和 "po"。

现在，我们希望列出 "John Adams" 的所有定单。

我们可以使用下面的 SELECT 语句：

SELECT po.OrderID, p.LastName, p.FirstName
FROM Persons AS p, Product_Orders AS po
WHERE p.LastName='Adams'
WHERE p.FirstName='John'

不使用别名的 SELECT 语句：

SELECT Product_Orders.OrderID, Persons.LastName, Persons.FirstName
FROM Persons, Product_Orders
WHERE Persons.LastName='Hansen'
WHERE Persons.FirstName='Ola'

从上面两条 SELECT 语句您可以看到，别名使查询程序更易阅读和书写。

Alias 实例: 使用一个列名别名

表 Persons:

Id | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York
3 | Carter | Thomas | Changan Street | Beijing

SQL:

SELECT LastName AS Family, FirstName AS Name
FROM Persons

结果：

Family | Name
Adams | John
Bush | George
Carter | Thomas
  • Previous Page
  • Next Page

SQL 测验


SQL ALTER TABLE 语句

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL ALTER TABLE 语句

  • Previous Page
  • Next Page

ALTER TABLE 语句

ALTER TABLE 语句用于在已有的表中添加、修改或删除列。

SQL ALTER TABLE 语法

如需在表中添加列，请使用下列语法:

ALTER TABLE table_name
ADD column_name datatype

要删除表中的列，请使用下列语法：

ALTER TABLE table_name
DROP COLUMN column_name

注释：某些数据库系统不允许这种在数据库表中删除列的方式 (DROP COLUMN column_name)。

要改变表中列的数据类型，请使用下列语法：

ALTER TABLE table_name
ALTER COLUMN column_name datatype

原始的表 (用在例子中的)：

Persons 表:

Id | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York
3 | Carter | Thomas | Changan Street | Beijing

SQL ALTER TABLE 实例

现在，我们希望在表 "Persons" 中添加一个名为 "Birthday" 的新列。

我们使用下列 SQL 语句：

ALTER TABLE Persons
ADD Birthday date

请注意，新列 "Birthday" 的类型是 date，可以存放日期。数据类型规定列中可以存放的数据的类型。

新的 "Persons" 表类似这样：

Id | LastName | FirstName | Address | City | Birthday
1 | Adams | John | Oxford Street | London |
2 | Bush | George | Fifth Avenue | New York |
3 | Carter | Thomas | Changan Street | Beijing |

改变数据类型实例

现在我们希望改变 "Persons" 表中 "Birthday" 列的数据类型。

我们使用下列 SQL 语句：

ALTER TABLE Persons
ALTER COLUMN Birthday year

请注意，"Birthday" 列的数据类型是 year，可以存放 2 位或 4 位格式的年份。

DROP COLUMN 实例

接下来，我们删除 "Person" 表中的 "Birthday" 列：

ALTER TABLE Person
DROP COLUMN Birthday

Persons 表会成为这样:

Id | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York
3 | Carter | Thomas | Changan Street | Beijing
  • Previous Page
  • Next Page

SQL 测验


SQL AND & OR 运算符

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL AND & OR 运算符

  • Previous Page
  • Next Page

AND 和 OR 运算符用于基于一个以上的条件对记录进行过滤。

AND 和 OR 运算符

AND 和 OR 可在 WHERE 子语句中把两个或多个条件结合起来。

如果第一个条件和第二个条件都成立，则 AND 运算符显示一条记录。

如果第一个条件和第二个条件中只要有一个成立，则 OR 运算符显示一条记录。

原始的表 (用在例子中的)：

LastName | FirstName | Address | City
Adams | John | Oxford Street | London
Bush | George | Fifth Avenue | New York
Carter | Thomas | Changan Street | Beijing
Carter | William | Xuanwumen 10 | Beijing

AND 运算符实例

使用 AND 来显示所有姓为 "Carter" 并且名为 "Thomas" 的人：

SELECT * FROM Persons WHERE FirstName='Thomas' AND LastName='Carter'

结果：

LastName | FirstName | Address | City
Carter | Thomas | Changan Street | Beijing

OR 运算符实例

使用 OR 来显示所有姓为 "Carter" 或者名为 "Thomas" 的人：

SELECT * FROM Persons WHERE firstname='Thomas' OR lastname='Carter'

结果：

LastName | FirstName | Address | City
Carter | Thomas | Changan Street | Beijing
Carter | William | Xuanwumen 10 | Beijing

结合 AND 和 OR 运算符

我们也可以把 AND 和 OR 结合起来（使用圆括号来组成复杂的表达式）:

SELECT * FROM Persons WHERE (FirstName='Thomas' OR FirstName='William')
AND LastName='Carter'

结果：

LastName | FirstName | Address | City
Carter | Thomas | Changan Street | Beijing
Carter | William | Xuanwumen 10 | Beijing
  • Previous Page
  • Next Page

SQL 测验


SQL AUTO INCREMENT 字段

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL AUTO INCREMENT 字段

  • Previous Page
  • Next Page

Auto-increment 会在新纪录插入表中时生成一个唯一的数字。

AUTO INCREMENT 字段

我们通常希望在每次插入新纪录时，自动地创建主键字段的值。

我们可以在表中创建一个 auto-increment 字段。

用于 MySQL 的语法

下列 SQL 语句把 "Persons" 表中的 "P_Id" 列定义为 auto-increment 主键：

CREATE TABLE Persons
(
P_Id int NOT NULL AUTO_INCREMENT,
LastName varchar(255) NOT NULL,
FirstName varchar(255),
Address varchar(255),
City varchar(255),
PRIMARY KEY (P_Id)
)

MySQL 使用 AUTO_INCREMENT 关键字来执行 auto-increment 任务。

默认地，AUTO_INCREMENT 的开始值是 1，每条新纪录递增 1。

要让 AUTO_INCREMENT 序列以其他的值起始，请使用下列 SQL 语法：

ALTER TABLE Persons AUTO_INCREMENT=100

要在 "Persons" 表中插入新纪录，我们不必为 "P_Id" 列规定值（会自动添加一个唯一的值）：

INSERT INTO Persons (FirstName,LastName)
VALUES ('Bill','Gates')

上面的 SQL 语句会在 "Persons" 表中插入一条新纪录。"P_Id" 会被赋予一个唯一的值。"FirstName" 会被设置为 "Bill"，"LastName" 列会被设置为 "Gates"。

用于 SQL Server 的语法

下列 SQL 语句把 "Persons" 表中的 "P_Id" 列定义为 auto-increment 主键：

CREATE TABLE Persons
(
P_Id int PRIMARY KEY IDENTITY,
LastName varchar(255) NOT NULL,
FirstName varchar(255),
Address varchar(255),
City varchar(255)
)

MySQL 使用 IDENTITY 关键字来执行 auto-increment 任务。

默认地，IDENTITY 的开始值是 1，每条新纪录递增 1。

要规定 "P_Id" 列以 20 起始且递增 10，请把 identity 改为 IDENTITY(20,10)

要在 "Persons" 表中插入新纪录，我们不必为 "P_Id" 列规定值（会自动添加一个唯一的值）：

INSERT INTO Persons (FirstName,LastName)
VALUES ('Bill','Gates')

上面的 SQL 语句会在 "Persons" 表中插入一条新纪录。"P_Id" 会被赋予一个唯一的值。"FirstName" 会被设置为 "Bill"，"LastName" 列会被设置为 "Gates"。

用于 Access 的语法

下列 SQL 语句把 "Persons" 表中的 "P_Id" 列定义为 auto-increment 主键：

CREATE TABLE Persons
(
P_Id int PRIMARY KEY AUTOINCREMENT,
LastName varchar(255) NOT NULL,
FirstName varchar(255),
Address varchar(255),
City varchar(255)
)

MS Access 使用 AUTOINCREMENT 关键字来执行 auto-increment 任务。

默认地，AUTOINCREMENT 的开始值是 1，每条新纪录递增 1。

要规定 "P_Id" 列以 20 起始且递增 10，请把 autoincrement 改为 AUTOINCREMENT(20,10)

要在 "Persons" 表中插入新纪录，我们不必为 "P_Id" 列规定值（会自动添加一个唯一的值）：

INSERT INTO Persons (FirstName,LastName)
VALUES ('Bill','Gates')

上面的 SQL 语句会在 "Persons" 表中插入一条新纪录。"P_Id" 会被赋予一个唯一的值。"FirstName" 会被设置为 "Bill"，"LastName" 列会被设置为 "Gates"。

用于 Oracle 的语法

在 Oracle 中，代码稍微复杂一点。

您必须通过 sequence 对创建 auto-increment 字段（该对象生成数字序列）。

请使用下面的 CREATE SEQUENCE 语法：

CREATE SEQUENCE seq_person
MINVALUE 1
START WITH 1
INCREMENT BY 1
CACHE 10

上面的代码创建名为 seq_person 的序列对象，它以 1 起始且以 1 递增。该对象缓存 10 个值以提高性能。CACHE 选项规定了为了提高访问速度要存储多少个序列值。

要在 "Persons" 表中插入新纪录，我们必须使用 nextval 函数（该函数从 seq_person 序列中取回下一个值）：

INSERT INTO Persons (P_Id,FirstName,LastName)
VALUES (seq_person.nextval,'Lars','Monsen')

上面的 SQL 语句会在 "Persons" 表中插入一条新纪录。"P_Id" 的赋值是来自 seq_person 序列的下一个数字。"FirstName" 会被设置为 "Bill"，"LastName" 列会被设置为 "Gates"。

  • Previous Page
  • Next Page

SQL 测验


SQL AVG 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL AVG 函数

  • Previous Page
  • Next Page

定义和用法

AVG 函数返回数值列的平均值。NULL 值不包括在计算中。

SQL AVG() 语法

SELECT AVG(column_name) FROM table_name

SQL AVG() 实例

我们拥有下面这个 "Orders" 表：

O_Id | OrderDate | OrderPrice | Customer
1 | 2008/12/29 | 1000 | Bush
2 | 2008/11/23 | 1600 | Carter
3 | 2008/10/05 | 700 | Bush
4 | 2008/09/28 | 300 | Bush
5 | 2008/08/06 | 2000 | Adams
6 | 2008/07/21 | 100 | Carter

例子 1

现在，我们希望计算 "OrderPrice" 字段的平均值。

我们使用如下 SQL 语句：

SELECT AVG(OrderPrice) AS OrderAverage FROM Orders

结果集类似这样：

OrderAverage
950

例子 2

现在，我们希望找到 OrderPrice 值高于 OrderPrice 平均值的客户。

我们使用如下 SQL 语句：

SELECT Customer FROM Orders
WHERE OrderPrice>(SELECT AVG(OrderPrice) FROM Orders)

结果集类似这样：

Customer
Bush
Carter
Adams
  • Previous Page
  • Next Page

SQL 测验


SQL BETWEEN 操作符

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL BETWEEN 操作符

  • Previous Page
  • Next Page

BETWEEN 操作符在 WHERE 子句中使用，作用是选取介于两个值之间的数据范围。

BETWEEN 操作符

操作符 BETWEEN ... AND 会选取介于两个值之间的数据范围。这些值可以是数值、文本或者日期。

SQL BETWEEN 语法

SELECT column_name(s)
FROM table_name
WHERE column_name
BETWEEN value1 AND value2

原始的表 (在实例中使用：)

Persons 表:

Id | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York
3 | Carter | Thomas | Changan Street | Beijing
4 | Gates | Bill | Xuanwumen 10 | Beijing

BETWEEN 操作符实例

如需以字母顺序显示介于 "Adams"（包括）和 "Carter"（不包括）之间的人，请使用下面的 SQL：

SELECT * FROM Persons
WHERE LastName
BETWEEN 'Adams' AND 'Carter'

结果集：

Id | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York

重要事项：不同的数据库对 BETWEEN...AND 操作符的处理方式是有差异的。某些数据库会列出介于 "Adams" 和 "Carter" 之间的人，但不包括 "Adams" 和 "Carter" ；某些数据库会列出介于 "Adams" 和 "Carter" 之间并包括 "Adams" 和 "Carter" 的人；而另一些数据库会列出介于 "Adams" 和 "Carter" 之间的人，包括 "Adams" ，但不包括 "Carter" 。

所以，请检查你的数据库是如何处理 BETWEEN....AND 操作符的！

实例 2

如需使用上面的例子显示范围之外的人，请使用 NOT 操作符：

SELECT * FROM Persons
WHERE LastName
NOT BETWEEN 'Adams' AND 'Carter'

结果集：

Id | LastName | FirstName | Address | City
3 | Carter | Thomas | Changan Street | Beijing
4 | Gates | Bill | Xuanwumen 10 | Beijing
  • Previous Page
  • Next Page

SQL 测验


SQL CHECK 约束

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL CHECK 约束

  • Previous Page
  • Next Page

SQL CHECK 约束

CHECK 约束用于限制列中的值的范围。

如果对单个列定义 CHECK 约束，那么该列只允许特定的值。

如果对一个表定义 CHECK 约束，那么此约束会在特定的列中对值进行限制。

SQL CHECK Constraint on CREATE TABLE

下面的 SQL 在 "Persons" 表创建时为 "Id_P" 列创建 CHECK 约束。CHECK 约束规定 "Id_P" 列必须只包含大于 0 的整数。

My SQL:

CREATE TABLE Persons
(
Id_P int NOT NULL,
LastName varchar(255) NOT NULL,
FirstName varchar(255),
Address varchar(255),
City varchar(255),
CHECK (Id_P>0)
)

SQL Server / Oracle / MS Access:

CREATE TABLE Persons
(
Id_P int NOT NULL CHECK (Id_P>0),
LastName varchar(255) NOT NULL,
FirstName varchar(255),
Address varchar(255),
City varchar(255)
)

如果需要命名 CHECK 约束，以及为多个列定义 CHECK 约束，请使用下面的 SQL 语法：

MySQL / SQL Server / Oracle / MS Access:

CREATE TABLE Persons
(
Id_P int NOT NULL,
LastName varchar(255) NOT NULL,
FirstName varchar(255),
Address varchar(255),
City varchar(255),
CONSTRAINT chk_Person CHECK (Id_P>0 AND City='Sandnes')
)

SQL CHECK Constraint on ALTER TABLE

如果在表已存在的情况下为 "Id_P" 列创建 CHECK 约束，请使用下面的 SQL：

MySQL / SQL Server / Oracle / MS Access:

ALTER TABLE Persons
ADD CHECK (Id_P>0)

如果需要命名 CHECK 约束，以及为多个列定义 CHECK 约束，请使用下面的 SQL 语法：

MySQL / SQL Server / Oracle / MS Access:

ALTER TABLE Persons
ADD CONSTRAINT chk_Person CHECK (Id_P>0 AND City='Sandnes')

撤销 CHECK 约束

如需撤销 CHECK 约束，请使用下面的 SQL：

SQL Server / Oracle / MS Access:

ALTER TABLE Persons
DROP CONSTRAINT chk_Person
  • Previous Page
  • Next Page

SQL 测验


SQL COUNT() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL COUNT() 函数

  • Previous Page
  • Next Page

COUNT() 函数返回匹配指定条件的行数。

SQL COUNT() 语法

SQL COUNT(column_name) 语法

COUNT(column_name) 函数返回指定列的值的数目（NULL 不计入）：

SELECT COUNT(column_name) FROM table_name

SQL COUNT(*) 语法

COUNT(*) 函数返回表中的记录数：

SELECT COUNT(*) FROM table_name

SQL COUNT(DISTINCT column_name) 语法

COUNT(DISTINCT column_name) 函数返回指定列的不同值的数目：

SELECT COUNT(DISTINCT column_name) FROM table_name

注释：COUNT(DISTINCT) 适用于 ORACLE 和 Microsoft SQL Server，但是无法用于 Microsoft Access。

SQL COUNT(column_name) 实例

我们拥有下列 "Orders" 表：

O_Id | OrderDate | OrderPrice | Customer
1 | 2008/12/29 | 1000 | Bush
2 | 2008/11/23 | 1600 | Carter
3 | 2008/10/05 | 700 | Bush
4 | 2008/09/28 | 300 | Bush
5 | 2008/08/06 | 2000 | Adams
6 | 2008/07/21 | 100 | Carter

现在，我们希望计算客户 "Carter" 的订单数。

我们使用如下 SQL 语句：

SELECT COUNT(Customer) AS CustomerNilsen FROM Orders
WHERE Customer='Carter'

以上 SQL 语句的结果是 2，因为客户 Carter 共有 2 个订单：

CustomerNilsen
2
SQL COUNT(*) 实例

如果我们省略 WHERE 子句，比如这样：

SELECT COUNT(*) AS NumberOfOrders FROM Orders

结果集类似这样：

NumberOfOrders
6

这是表中的总行数。

SQL COUNT(DISTINCT column_name) 实例

现在，我们希望计算 "Orders" 表中不同客户的数目。

我们使用如下 SQL 语句：

SELECT COUNT(DISTINCT Customer) AS NumberOfCustomers FROM Orders

结果集类似这样：

NumberOfCustomers
3

这是 "Orders" 表中不同客户（Bush, Carter 和 Adams）的数目。

  • Previous Page
  • Next Page

SQL 测验


SQL CREATE DATABASE 语句

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL CREATE DATABASE 语句

  • Previous Page
  • Next Page

CREATE DATABASE 语句

CREATE DATABASE 用于创建数据库。

SQL CREATE DATABASE 语法

CREATE DATABASE database_name

SQL CREATE DATABASE 实例

现在我们希望创建一个名为 "my_db" 的数据库。

我们使用下面的 CREATE DATABASE 语句：

CREATE DATABASE my_db

可以通过 CREATE TABLE 来添加数据库表。

  • Previous Page
  • Next Page

SQL 测验


SQL CREATE INDEX 语句

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL CREATE INDEX 语句

  • Previous Page
  • Next Page

CREATE INDEX 语句用于在表中创建索引。

在不读取整个表的情况下，索引使数据库应用程序可以更快地查找数据。

索引

您可以在表中创建索引，以便更加快速高效地查询数据。

用户无法看到索引，它们只能被用来加速搜索/查询。

注释：更新一个包含索引的表需要比更新一个没有索引的表更多的时间，这是由于索引本身也需要更新。因此，理想的做法是仅仅在常常被搜索的列（以及表）上面创建索引。

SQL CREATE INDEX 语法

在表上创建一个简单的索引。允许使用重复的值：

CREATE INDEX index_name
ON table_name (column_name)

注释："column_name" 规定需要索引的列。

SQL CREATE UNIQUE INDEX 语法

在表上创建一个唯一的索引。唯一的索引意味着两个行不能拥有相同的索引值。

CREATE UNIQUE INDEX index_name
ON table_name (column_name)

CREATE INDEX 实例

本例会创建一个简单的索引，名为 "PersonIndex"，在 Person 表的 LastName 列：

CREATE INDEX PersonIndex
ON Person (LastName)

如果您希望以降序索引某个列中的值，您可以在列名称之后添加保留字 DESC：

CREATE INDEX PersonIndex
ON Person (LastName DESC)

假如您希望索引不止一个列，您可以在括号中列出这些列的名称，用逗号隔开：

CREATE INDEX PersonIndex
ON Person (LastName, FirstName)
  • Previous Page
  • Next Page

SQL 测验


SQL CREATE TABLE 语句

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL CREATE TABLE 语句

  • Previous Page
  • Next Page

CREATE TABLE 语句

CREATE TABLE 语句用于创建数据库中的表。

SQL CREATE TABLE 语法

CREATE TABLE 表名称
(
列名称1 数据类型,
列名称2 数据类型,
列名称3 数据类型,
....
)

数据类型（data_type）规定了列可容纳何种数据类型。下面的表格包含了SQL中最常用的数据类型：

数据类型 | 描述
  • integer(size)
  • int(size)
  • smallint(size)
  • tinyint(size)
 仅容纳整数。在括号内规定数字的最大位数。
  • decimal(size,d)
  • numeric(size,d)

容纳带有小数的数字。

"size" 规定数字的最大位数。"d" 规定小数点右侧的最大位数。
char(size)

容纳固定长度的字符串（可容纳字母、数字以及特殊字符）。

在括号中规定字符串的长度。
varchar(size)

容纳可变长度的字符串（可容纳字母、数字以及特殊的字符）。

在括号中规定字符串的最大长度。
date(yyyymmdd) | 容纳日期。

SQL CREATE TABLE 实例

本例演示如何创建名为 "Person" 的表。

该表包含 5 个列，列名分别是："Id_P"、"LastName"、"FirstName"、"Address" 以及 "Age"：

CREATE TABLE Persons
(
Id_P int,
LastName varchar(255),
FirstName varchar(255),
Address varchar(255),
City varchar(255)
)

Id_P 列的数据类型是 int，包含整数。其余 4 列的数据类型是 varchar，最大长度为 255 个字符。

空的 "Persons" 表类似这样：

Id_P | LastName | FirstName | Address | City

可使用 INSERT INTO 语句向空表写入数据。

  • Previous Page
  • Next Page

SQL 测验


SQL Date 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL Date 函数

  • Previous Page
  • Next Page

SQL 日期

当我们处理日期时，最难的任务恐怕是确保所插入的日期的格式，与数据库中日期列的格式相匹配。

只要数据包含的只是日期部分，运行查询就不会出问题。但是，如果涉及时间，情况就有点复杂了。

在讨论日期查询的复杂性之前，我们先来看看最重要的内建日期处理函数。

MySQL Date 函数

下面的表格列出了 MySQL 中最重要的内建日期函数：

函数 | 描述
NOW() | 返回当前的日期和时间
CURDATE() | 返回当前的日期
CURTIME() | 返回当前的时间
DATE() | 提取日期或日期/时间表达式的日期部分
EXTRACT() | 返回日期/时间按的单独部分
DATE_ADD() | 给日期添加指定的时间间隔
DATE_SUB() | 从日期减去指定的时间间隔
DATEDIFF() | 返回两个日期之间的天数
DATE_FORMAT() | 用不同的格式显示日期/时间

SQL Server Date 函数

下面的表格列出了 SQL Server 中最重要的内建日期函数：

函数 | 描述
GETDATE() | 返回当前日期和时间
DATEPART() | 返回日期/时间的单独部分
DATEADD() | 在日期中添加或减去指定的时间间隔
DATEDIFF() | 返回两个日期之间的时间
CONVERT() | 用不同的格式显示日期/时间

SQL Date 数据类型

MySQL 使用下列数据类型在数据库中存储日期或日期/时间值：

  • DATE - 格式 YYYY-MM-DD
  • DATETIME - 格式: YYYY-MM-DD HH:MM:SS
  • TIMESTAMP - 格式: YYYY-MM-DD HH:MM:SS
  • YEAR - 格式 YYYY 或 YY

SQL Server 使用下列数据类型在数据库中存储日期或日期/时间值：

  • DATE - 格式 YYYY-MM-DD
  • DATETIME - 格式: YYYY-MM-DD HH:MM:SS
  • SMALLDATETIME - 格式: YYYY-MM-DD HH:MM:SS
  • TIMESTAMP - 格式: 唯一的数字

SQL 日期处理

如果不涉及时间部分，那么我们可以轻松地比较两个日期！

假设我们有下面这个 "Orders" 表：

OrderId | ProductName | OrderDate
1 | computer | 2008-12-26
2 | printer | 2008-12-26
3 | electrograph | 2008-11-12
4 | telephone | 2008-10-19

现在，我们希望从上表中选取 OrderDate 为 "2008-12-26" 的记录。

我们使用如下 SELECT 语句：

SELECT * FROM Orders WHERE OrderDate='2008-12-26'

结果集：

OrderId | ProductName | OrderDate
1 | computer | 2008-12-26
3 | electrograph | 2008-12-26

现在假设 "Orders" 类似这样（请注意 "OrderDate" 列中的时间部分）：

OrderId | ProductName | OrderDate
1 | computer | 2008-12-26 16:23:55
2 | printer | 2008-12-26 10:45:26
3 | electrograph | 2008-11-12 14:12:08
4 | telephone | 2008-10-19 12:56:10

如果我们使用上面的 SELECT 语句：

SELECT * FROM Orders WHERE OrderDate='2008-12-26'

那么我们得不到结果。这是由于该查询不含有时间部分的日期。

提示：如果您希望使查询简单且更易维护，那么请不要在日期中使用时间部分！

  • Previous Page
  • Next Page

SQL 测验


SQL DEFAULT 约束

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL DEFAULT 约束

  • Previous Page
  • Next Page

SQL DEFAULT 约束

DEFAULT 约束用于向列中插入默认值。

如果没有规定其他的值，那么会将默认值添加到所有的新纪录。

SQL DEFAULT Constraint on CREATE TABLE

下面的 SQL 在 "Persons" 表创建时为 "City" 列创建 DEFAULT 约束：

My SQL / SQL Server / Oracle / MS Access:

CREATE TABLE Persons
(
Id_P int NOT NULL,
LastName varchar(255) NOT NULL,
FirstName varchar(255),
Address varchar(255),
City varchar(255) DEFAULT 'Sandnes'
)

通过使用类似 GETDATE() 这样的函数，DEFAULT 约束也可以用于插入系统值：

CREATE TABLE Orders
(
Id_O int NOT NULL,
OrderNo int NOT NULL,
Id_P int,
OrderDate date DEFAULT GETDATE()
)

SQL DEFAULT Constraint on ALTER TABLE

如果在表已存在的情况下为 "City" 列创建 DEFAULT 约束，请使用下面的 SQL：

MySQL:

ALTER TABLE Persons
ALTER City SET DEFAULT 'SANDNES'

SQL Server / Oracle / MS Access:

ALTER TABLE Persons
ALTER COLUMN City SET DEFAULT 'SANDNES'

撤销 DEFAULT 约束

如需撤销 DEFAULT 约束，请使用下面的 SQL：

MySQL:

ALTER TABLE Persons
ALTER City DROP DEFAULT

SQL Server / Oracle / MS Access:

ALTER TABLE Persons
ALTER COLUMN City DROP DEFAULT
  • Previous Page
  • Next Page

SQL 测验


SQL DELETE 语句

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL DELETE 语句

  • Previous Page
  • Next Page

DELETE 语句

DELETE 语句用于删除表中的行。

语法

DELETE FROM 表名称 WHERE 列名称 = 值

Person:

LastName | FirstName | Address | City
Gates | Bill | Xuanwumen 10 | Beijing
Wilson | Fred | Zhongshan 23 | Nanjing

删除某行

"Nina Rasmussen" 会被删除：

DELETE FROM Person WHERE LastName = 'Wilson'

结果:

LastName | FirstName | Address | City
Gates | Bill | Xuanwumen 10 | Beijing

删除所有行

可以在不删除表的情况下删除所有的行。这意味着表的结构、属性和索引都是完整的：

DELETE FROM table_name

或者：

DELETE * FROM table_name
  • Previous Page
  • Next Page

SQL 测验


SQL FIRST() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL FIRST() 函数

  • Previous Page
  • Next Page

FIRST() 函数

FIRST() 函数返回指定的字段中第一个记录的值。

提示：可使用 ORDER BY 语句对记录进行排序。

SQL FIRST() 语法

SELECT FIRST(column_name) FROM table_name

SQL FIRST() 实例

我们拥有下面这个 "Orders" 表：

O_Id | OrderDate | OrderPrice | Customer
1 | 2008/12/29 | 1000 | Bush
2 | 2008/11/23 | 1600 | Carter
3 | 2008/10/05 | 700 | Bush
4 | 2008/09/28 | 300 | Bush
5 | 2008/08/06 | 2000 | Adams
6 | 2008/07/21 | 100 | Carter

现在，我们希望查找 "OrderPrice" 列的第一个值。

我们使用如下 SQL 语句：

SELECT FIRST(OrderPrice) AS FirstOrderPrice FROM Orders

结果集类似这样：

FirstOrderPrice
1000
  • Previous Page
  • Next Page

SQL 测验


SQL FOREIGN KEY 约束

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL FOREIGN KEY 约束

  • Previous Page
  • Next Page

SQL FOREIGN KEY 约束

一个表中的 FOREIGN KEY 指向另一个表中的 PRIMARY KEY。

让我们通过一个例子来解释外键。请看下面两个表：

"Persons" 表：

Id_P | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York
3 | Carter | Thomas | Changan Street | Beijing

"Orders" 表：

Id_O | OrderNo | Id_P
1 | 77895 | 3
2 | 44678 | 3
3 | 22456 | 1
4 | 24562 | 1

请注意，"Orders" 中的 "Id_P" 列指向 "Persons" 表中的 "Id_P" 列。

"Persons" 表中的 "Id_P" 列是 "Persons" 表中的 PRIMARY KEY。

"Orders" 表中的 "Id_P" 列是 "Orders" 表中的 FOREIGN KEY。

FOREIGN KEY 约束用于预防破坏表之间连接的动作。

FOREIGN KEY 约束也能防止非法数据插入外键列，因为它必须是它指向的那个表中的值之一。

SQL FOREIGN KEY Constraint on CREATE TABLE

下面的 SQL 在 "Orders" 表创建时为 "Id_P" 列创建 FOREIGN KEY：

MySQL:

CREATE TABLE Orders
(
O_Id int NOT NULL,
OrderNo int NOT NULL,
Id_P int,
PRIMARY KEY (O_Id),
FOREIGN KEY (Id_P) REFERENCES Persons(Id_P)
)

SQL Server / Oracle / MS Access:

CREATE TABLE Orders
(
O_Id int NOT NULL PRIMARY KEY,
OrderNo int NOT NULL,
Id_P int FOREIGN KEY REFERENCES Persons(Id_P)
)

如果需要命名 FOREIGN KEY 约束，以及为多个列定义 FOREIGN KEY 约束，请使用下面的 SQL 语法：

MySQL / SQL Server / Oracle / MS Access:

CREATE TABLE Orders
(
O_Id int NOT NULL,
OrderNo int NOT NULL,
Id_P int,
PRIMARY KEY (O_Id),
CONSTRAINT fk_PerOrders FOREIGN KEY (Id_P)
REFERENCES Persons(Id_P)
)

SQL FOREIGN KEY Constraint on ALTER TABLE

如果在 "Orders" 表已存在的情况下为 "Id_P" 列创建 FOREIGN KEY 约束，请使用下面的 SQL：

MySQL / SQL Server / Oracle / MS Access:

ALTER TABLE Orders
ADD FOREIGN KEY (Id_P)
REFERENCES Persons(Id_P)

如果需要命名 FOREIGN KEY 约束，以及为多个列定义 FOREIGN KEY 约束，请使用下面的 SQL 语法：

MySQL / SQL Server / Oracle / MS Access:

ALTER TABLE Orders
ADD CONSTRAINT fk_PerOrders
FOREIGN KEY (Id_P)
REFERENCES Persons(Id_P)

撤销 FOREIGN KEY 约束

如需撤销 FOREIGN KEY 约束，请使用下面的 SQL：

MySQL:

ALTER TABLE Orders
DROP FOREIGN KEY fk_PerOrders

SQL Server / Oracle / MS Access:

ALTER TABLE Orders
DROP CONSTRAINT fk_PerOrders
  • Previous Page
  • Next Page

SQL 测验


SQL FORMAT() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL FORMAT() 函数

  • Previous Page
  • Next Page

FORMAT() 函数

FORMAT 函数用于对字段的显示进行格式化。

SQL FORMAT() 语法

SELECT FORMAT(column_name,format) FROM table_name
参数 | 描述
column_name | 必需。要格式化的字段。
format | 必需。规定格式。

SQL FORMAT() 实例

我们拥有下面这个 "Products" 表：

Prod_Id | ProductName | Unit | UnitPrice
1 | gold | 1000 g | 32.35
2 | silver | 1000 g | 11.56
3 | copper | 1000 g | 6.85

现在，我们希望显示每天日期所对应的名称和价格（日期的显示格式是 "YYYY-MM-DD"）。

我们使用如下 SQL 语句：

SELECT ProductName, UnitPrice, FORMAT(FORMAT(),'YYYY-MM-DD') as PerDate
FROM Products

结果集类似这样：

ProductName | UnitPrice | PerDate
gold | 32.35 | 12/29/2008
silver | 11.56 | 12/29/2008
copper | 6.85 | 12/29/2008
  • Previous Page
  • Next Page

SQL 测验


SQL FULL JOIN 关键字

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL FULL JOIN 关键字

  • Previous Page
  • Next Page

SQL FULL JOIN 关键字

只要其中某个表存在匹配，FULL JOIN 关键字就会返回行。

FULL JOIN 关键字语法

SELECT column_name(s)
FROM table_name1
FULL JOIN table_name2
ON table_name1.column_name=table_name2.column_name

注释：在某些数据库中， FULL JOIN 称为 FULL OUTER JOIN。

原始的表 (用在例子中的)：

"Persons" 表：

Id_P | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York
3 | Carter | Thomas | Changan Street | Beijing

"Orders" 表：

Id_O | OrderNo | Id_P
1 | 77895 | 3
2 | 44678 | 3
3 | 22456 | 1
4 | 24562 | 1
5 | 34764 | 65

全连接（FULL JOIN）实例

现在，我们希望列出所有的人，以及他们的定单，以及所有的定单，以及定购它们的人。

您可以使用下面的 SELECT 语句：

SELECT Persons.LastName, Persons.FirstName, Orders.OrderNo
FROM Persons
FULL JOIN Orders
ON Persons.Id_P=Orders.Id_P
ORDER BY Persons.LastName

结果集：

LastName | FirstName | OrderNo
Adams | John | 22456
Adams | John | 24562
Carter | Thomas | 77895
Carter | Thomas | 44678
Bush | George |
 |  | 34764

FULL JOIN 关键字会从左表 (Persons) 和右表 (Orders) 那里返回所有的行。如果 "Persons" 中的行在表 "Orders" 中没有匹配，或者如果 "Orders" 中的行在表 "Persons" 中没有匹配，这些行同样会列出。

  • Previous Page
  • Next Page

SQL 测验


SQL GROUP BY 语句

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL GROUP BY 语句

  • Previous Page
  • Next Page

合计函数 (比如 SUM) 常常需要添加 GROUP BY 语句。

GROUP BY 语句

GROUP BY 语句用于结合合计函数，根据一个或多个列对结果集进行分组。

SQL GROUP BY 语法

SELECT column_name, aggregate_function(column_name)
FROM table_name
WHERE column_name operator value
GROUP BY column_name

SQL GROUP BY 实例

我们拥有下面这个 "Orders" 表：

O_Id | OrderDate | OrderPrice | Customer
1 | 2008/12/29 | 1000 | Bush
2 | 2008/11/23 | 1600 | Carter
3 | 2008/10/05 | 700 | Bush
4 | 2008/09/28 | 300 | Bush
5 | 2008/08/06 | 2000 | Adams
6 | 2008/07/21 | 100 | Carter

现在，我们希望查找每个客户的总金额（总订单）。

我们想要使用 GROUP BY 语句对客户进行组合。

我们使用下列 SQL 语句：

SELECT Customer,SUM(OrderPrice) FROM Orders
GROUP BY Customer

结果集类似这样：

Customer | SUM(OrderPrice)
Bush | 2000
Carter | 1700
Adams | 2000

很棒吧，对不对？

让我们看一下如果省略 GROUP BY 会出现什么情况：

SELECT Customer,SUM(OrderPrice) FROM Orders

结果集类似这样：

Customer | SUM(OrderPrice)
Bush | 5700
Carter | 5700
Bush | 5700
Bush | 5700
Adams | 5700
Carter | 5700

上面的结果集不是我们需要的。

那么为什么不能使用上面这条 SELECT 语句呢？解释如下：上面的 SELECT 语句指定了两列（Customer 和 SUM(OrderPrice)）。"SUM(OrderPrice)" 返回一个单独的值（"OrderPrice" 列的总计），而 "Customer" 返回 6 个值（每个值对应 "Orders" 表中的每一行）。因此，我们得不到正确的结果。不过，您已经看到了，GROUP BY 语句解决了这个问题。

GROUP BY 一个以上的列

我们也可以对一个以上的列应用 GROUP BY 语句，就像这样：

SELECT Customer,OrderDate,SUM(OrderPrice) FROM Orders
GROUP BY Customer,OrderDate
  • Previous Page
  • Next Page

SQL 测验


SQL HAVING 子句

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL HAVING 子句

  • Previous Page
  • Next Page

HAVING 子句

在 SQL 中增加 HAVING 子句原因是，WHERE 关键字无法与合计函数一起使用。

SQL HAVING 语法

SELECT column_name, aggregate_function(column_name)
FROM table_name
WHERE column_name operator value
GROUP BY column_name
HAVING aggregate_function(column_name) operator value

SQL HAVING 实例

我们拥有下面这个 "Orders" 表：

O_Id | OrderDate | OrderPrice | Customer
1 | 2008/12/29 | 1000 | Bush
2 | 2008/11/23 | 1600 | Carter
3 | 2008/10/05 | 700 | Bush
4 | 2008/09/28 | 300 | Bush
5 | 2008/08/06 | 2000 | Adams
6 | 2008/07/21 | 100 | Carter

现在，我们希望查找订单总金额少于 2000 的客户。

我们使用如下 SQL 语句：

SELECT Customer,SUM(OrderPrice) FROM Orders
GROUP BY Customer
HAVING SUM(OrderPrice)<2000

结果集类似：

Customer | SUM(OrderPrice)
Carter | 1700

现在我们希望查找客户 "Bush" 或 "Adams" 拥有超过 1500 的订单总金额。

我们在 SQL 语句中增加了一个普通的 WHERE 子句：

SELECT Customer,SUM(OrderPrice) FROM Orders
WHERE Customer='Bush' OR Customer='Adams'
GROUP BY Customer
HAVING SUM(OrderPrice)>1500

结果集：

Customer | SUM(OrderPrice)
Bush | 2000
Adams | 2000
  • Previous Page
  • Next Page

SQL 测验


SQL IN 操作符

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL IN 操作符

  • Previous Page
  • Next Page

IN 操作符

IN 操作符允许我们在 WHERE 子句中规定多个值。

SQL IN 语法

SELECT column_name(s)
FROM table_name
WHERE column_name IN (value1,value2,...)

原始的表 (在实例中使用：)

Persons 表:

Id | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York
3 | Carter | Thomas | Changan Street | Beijing

IN 操作符实例

现在，我们希望从上表中选取姓氏为 Adams 和 Carter 的人：

我们可以使用下面的 SELECT 语句：

SELECT * FROM Persons
WHERE LastName IN ('Adams','Carter')

结果集：

Id | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
3 | Carter | Thomas | Changan Street | Beijing
  • Previous Page
  • Next Page

SQL 测验


SQL INNER JOIN 关键字

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL INNER JOIN 关键字

  • Previous Page
  • Next Page

SQL INNER JOIN 关键字

在表中存在至少一个匹配时，INNER JOIN 关键字返回行。

INNER JOIN 关键字语法

SELECT column_name(s)
FROM table_name1
INNER JOIN table_name2
ON table_name1.column_name=table_name2.column_name

注释：INNER JOIN 与 JOIN 是相同的。

原始的表 (用在例子中的)：

"Persons" 表：

Id_P | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York
3 | Carter | Thomas | Changan Street | Beijing

"Orders" 表：

Id_O | OrderNo | Id_P
1 | 77895 | 3
2 | 44678 | 3
3 | 22456 | 1
4 | 24562 | 1
5 | 34764 | 65

内连接（INNER JOIN）实例

现在，我们希望列出所有人的定购。

您可以使用下面的 SELECT 语句：

SELECT Persons.LastName, Persons.FirstName, Orders.OrderNo
FROM Persons
INNER JOIN Orders
ON Persons.Id_P=Orders.Id_P
ORDER BY Persons.LastName

结果集：

LastName | FirstName | OrderNo
Adams | John | 22456
Adams | John | 24562
Carter | Thomas | 77895
Carter | Thomas | 44678

INNER JOIN 关键字在表中存在至少一个匹配时返回行。如果 "Persons" 中的行在 "Orders" 中没有匹配，就不会列出这些行。

  • Previous Page
  • Next Page

SQL 测验


SQL INSERT INTO 语句

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL INSERT INTO 语句

  • Previous Page
  • Next Page

INSERT INTO 语句

INSERT INTO 语句用于向表格中插入新的行。

语法

INSERT INTO 表名称 VALUES (值1, 值2,....)

我们也可以指定所要插入数据的列：

INSERT INTO table_name (列1, 列2,...) VALUES (值1, 值2,....)

插入新的行

"Persons" 表：

LastName | FirstName | Address | City
Carter | Thomas | Changan Street | Beijing

SQL 语句：

INSERT INTO Persons VALUES ('Gates', 'Bill', 'Xuanwumen 10', 'Beijing')

结果：

LastName | FirstName | Address | City
Carter | Thomas | Changan Street | Beijing
Gates | Bill | Xuanwumen 10 | Beijing

在指定的列中插入数据

"Persons" 表：

LastName | FirstName | Address | City
Carter | Thomas | Changan Street | Beijing
Gates | Bill | Xuanwumen 10 | Beijing

SQL 语句：

INSERT INTO Persons (LastName, Address) VALUES ('Wilson', 'Champs-Elysees')

结果：

LastName | FirstName | Address | City
Carter | Thomas | Changan Street | Beijing
Gates | Bill | Xuanwumen 10 | Beijing
Wilson |  | Champs-Elysees |
  • Previous Page
  • Next Page

SQL 测验


SQL JOIN

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL JOIN

  • Previous Page
  • Next Page

SQL join 用于根据两个或多个表中的列之间的关系，从这些表中查询数据。

Join 和 Key

有时为了得到完整的结果，我们需要从两个或更多的表中获取结果。我们就需要执行 join。

数据库中的表可通过键将彼此联系起来。主键（Primary Key）是一个列，在这个列中的每一行的值都是唯一的。在表中，每个主键的值都是唯一的。这样做的目的是在不重复每个表中的所有数据的情况下，把表间的数据交叉捆绑在一起。

请看 "Persons" 表：

Id_P | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York
3 | Carter | Thomas | Changan Street | Beijing

请注意，"Id_P" 列是 Persons 表中的的主键。这意味着没有两行能够拥有相同的 Id_P。即使两个人的姓名完全相同，Id_P 也可以区分他们。

接下来请看 "Orders" 表：

Id_O | OrderNo | Id_P
1 | 77895 | 3
2 | 44678 | 3
3 | 22456 | 1
4 | 24562 | 1
5 | 34764 | 65

请注意，"Id_O" 列是 Orders 表中的的主键，同时，"Orders" 表中的 "Id_P" 列用于引用 "Persons" 表中的人，而无需使用他们的确切姓名。

请留意，"Id_P" 列把上面的两个表联系了起来。

引用两个表

我们可以通过引用两个表的方式，从两个表中获取数据：

谁订购了产品，并且他们订购了什么产品？

SELECT Persons.LastName, Persons.FirstName, Orders.OrderNo
FROM Persons, Orders
WHERE Persons.Id_P = Orders.Id_P

结果集：

LastName | FirstName | OrderNo
Adams | John | 22456
Adams | John | 24562
Carter | Thomas | 77895
Carter | Thomas | 44678

SQL JOIN - 使用 Join

除了上面的方法，我们也可以使用关键词 JOIN 来从两个表中获取数据。

如果我们希望列出所有人的定购，可以使用下面的 SELECT 语句：

SELECT Persons.LastName, Persons.FirstName, Orders.OrderNo
FROM Persons
INNER JOIN Orders
ON Persons.Id_P = Orders.Id_P
ORDER BY Persons.LastName

结果集：

LastName | FirstName | OrderNo
Adams | John | 22456
Adams | John | 24562
Carter | Thomas | 77895
Carter | Thomas | 44678

不同的 SQL JOIN

除了我们在上面的例子中使用的 INNER JOIN（内连接），我们还可以其他几种连接。

下面列出了您可以使用的 JOIN 类型，以及它们之间的差异。

  • JOIN: 如果表中有至少一个匹配，则返回行
  • LEFT JOIN: 即使右表中没有匹配，也从左表返回所有的行
  • RIGHT JOIN: 即使左表中没有匹配，也从右表返回所有的行
  • FULL JOIN: 只要其中一个表中存在匹配，就返回行
  • Previous Page
  • Next Page

SQL 测验


SQL LAST() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL LAST() 函数

  • Previous Page
  • Next Page

LAST() 函数

LAST() 函数返回指定的字段中最后一个记录的值。

提示：可使用 ORDER BY 语句对记录进行排序。

SQL LAST() 语法

SELECT LAST(column_name) FROM table_name

SQL LAST() 实例

我们拥有下面这个 "Orders" 表：

O_Id | OrderDate | OrderPrice | Customer
1 | 2008/12/29 | 1000 | Bush
2 | 2008/11/23 | 1600 | Carter
3 | 2008/10/05 | 700 | Bush
4 | 2008/09/28 | 300 | Bush
5 | 2008/08/06 | 2000 | Adams
6 | 2008/07/21 | 100 | Carter

现在，我们希望查找 "OrderPrice" 列的最后一个值。

我们使用如下 SQL 语句：

SELECT LAST(OrderPrice) AS LastOrderPrice FROM Orders

结果集类似这样：

LastOrderPrice
100
  • Previous Page
  • Next Page

SQL 测验


SQL LCASE() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL LCASE() 函数

  • Previous Page
  • Next Page

LCASE() 函数

LCASE 函数把字段的值转换为小写。

SQL LCASE() 语法

SELECT LCASE(column_name) FROM table_name

SQL LCASE() 实例

我们拥有下面这个 "Persons" 表：

Id | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York
3 | Carter | Thomas | Changan Street | Beijing

现在，我们希望选取 "LastName" 和 "FirstName" 列的内容，然后把 "LastName" 列转换为小写。

我们使用如下 SQL 语句：

SELECT LCASE(LastName) as LastName,FirstName FROM Persons

结果集类似这样：

LastName | FirstName
adams | John
bush | George
carter | Thomas
  • Previous Page
  • Next Page

SQL 测验


SQL LEFT JOIN 关键字

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL LEFT JOIN 关键字

  • Previous Page
  • Next Page

SQL LEFT JOIN 关键字

LEFT JOIN 关键字会从左表 (table_name1) 那里返回所有的行，即使在右表 (table_name2) 中没有匹配的行。

LEFT JOIN 关键字语法

SELECT column_name(s)
FROM table_name1
LEFT JOIN table_name2
ON table_name1.column_name=table_name2.column_name

注释：在某些数据库中， LEFT JOIN 称为 LEFT OUTER JOIN。

原始的表 (用在例子中的)：

"Persons" 表：

Id_P | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York
3 | Carter | Thomas | Changan Street | Beijing

"Orders" 表：

Id_O | OrderNo | Id_P
1 | 77895 | 3
2 | 44678 | 3
3 | 22456 | 1
4 | 24562 | 1
5 | 34764 | 65

左连接（LEFT JOIN）实例

现在，我们希望列出所有的人，以及他们的定购 - 如果有的话。

您可以使用下面的 SELECT 语句：

SELECT Persons.LastName, Persons.FirstName, Orders.OrderNo
FROM Persons
LEFT JOIN Orders
ON Persons.Id_P=Orders.Id_P
ORDER BY Persons.LastName

结果集：

LastName | FirstName | OrderNo
Adams | John | 22456
Adams | John | 24562
Carter | Thomas | 77895
Carter | Thomas | 44678
Bush | George |

LEFT JOIN 关键字会从左表 (Persons) 那里返回所有的行，即使在右表 (Orders) 中没有匹配的行。

  • Previous Page
  • Next Page

SQL 测验


SQL LEN() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL LEN() 函数

  • Previous Page
  • Next Page

LEN() 函数

LEN 函数返回文本字段中值的长度。

SQL LEN() 语法

SELECT LEN(column_name) FROM table_name

SQL LEN() 实例

我们拥有下面这个 "Persons" 表：

Id | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York
3 | Carter | Thomas | Changan Street | Beijing

现在，我们希望取得 "City" 列中值的长度。

我们使用如下 SQL 语句：

SELECT LEN(City) as LengthOfAddress FROM Persons

结果集类似这样：

LengthOfCity
6
8
7
  • Previous Page
  • Next Page

SQL 测验


SQL LIKE 操作符

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL LIKE 操作符

  • Previous Page
  • Next Page

LIKE 操作符用于在 WHERE 子句中搜索列中的指定模式。

LIKE 操作符

LIKE 操作符用于在 WHERE 子句中搜索列中的指定模式。

SQL LIKE 操作符语法

SELECT column_name(s)
FROM table_name
WHERE column_name LIKE pattern

原始的表 (用在例子中的)：

Persons 表:

Id | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York
3 | Carter | Thomas | Changan Street | Beijing

LIKE 操作符实例

例子 1

现在，我们希望从上面的 "Persons" 表中选取居住在以 "N" 开始的城市里的人：

我们可以使用下面的 SELECT 语句：

SELECT * FROM Persons
WHERE City LIKE 'N%'

提示："%" 可用于定义通配符（模式中缺少的字母）。

结果集：

Id | LastName | FirstName | Address | City
2 | Bush | George | Fifth Avenue | New York

例子 2

接下来，我们希望从 "Persons" 表中选取居住在以 "g" 结尾的城市里的人：

我们可以使用下面的 SELECT 语句：

SELECT * FROM Persons
WHERE City LIKE '%g'

结果集：

Id | LastName | FirstName | Address | City
3 | Carter | Thomas | Changan Street | Beijing

例子 3

接下来，我们希望从 "Persons" 表中选取居住在包含 "lon" 的城市里的人：

我们可以使用下面的 SELECT 语句：

SELECT * FROM Persons
WHERE City LIKE '%lon%'

结果集：

Id | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London

例子 4

通过使用 NOT 关键字，我们可以从 "Persons" 表中选取居住在不包含 "lon" 的城市里的人：

我们可以使用下面的 SELECT 语句：

SELECT * FROM Persons
WHERE City NOT LIKE '%lon%'

结果集：

Id | LastName | FirstName | Address | City
2 | Bush | George | Fifth Avenue | New York
3 | Carter | Thomas | Changan Street | Beijing
  • Previous Page
  • Next Page

SQL 测验


SQL MAX() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL MAX() 函数

  • Previous Page
  • Next Page

MAX() 函数

MAX 函数返回一列中的最大值。NULL 值不包括在计算中。

SQL MAX() 语法

SELECT MAX(column_name) FROM table_name

注释：MIN 和 MAX 也可用于文本列，以获得按字母顺序排列的最高或最低值。

SQL MAX() 实例

我们拥有下面这个 "Orders" 表：

O_Id | OrderDate | OrderPrice | Customer
1 | 2008/12/29 | 1000 | Bush
2 | 2008/11/23 | 1600 | Carter
3 | 2008/10/05 | 700 | Bush
4 | 2008/09/28 | 300 | Bush
5 | 2008/08/06 | 2000 | Adams
6 | 2008/07/21 | 100 | Carter

现在，我们希望查找 "OrderPrice" 列的最大值。

我们使用如下 SQL 语句：

SELECT MAX(OrderPrice) AS LargestOrderPrice FROM Orders

结果集类似这样：

LargestOrderPrice
2000
  • Previous Page
  • Next Page

SQL 测验


SQL MID() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL MID() 函数

  • Previous Page
  • Next Page

MID() 函数

MID 函数用于从文本字段中提取字符。

SQL MID() 语法

SELECT MID(column_name,start[,length]) FROM table_name
参数 | 描述
column_name | 必需。要提取字符的字段。
start | 必需。规定开始位置（起始值是 1）。
length | 可选。要返回的字符数。如果省略，则 MID() 函数返回剩余文本。

SQL MID() 实例

我们拥有下面这个 "Persons" 表：

Id | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York
3 | Carter | Thomas | Changan Street | Beijing

现在，我们希望从 "City" 列中提取前 3 个字符。

我们使用如下 SQL 语句：

SELECT MID(City,1,3) as SmallCity FROM Persons

结果集类似这样：

SmallCity
Lon
New
Bei
  • Previous Page
  • Next Page

SQL 测验


SQL MIN() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL MIN() 函数

  • Previous Page
  • Next Page

MIN() 函数

MIN 函数返回一列中的最小值。NULL 值不包括在计算中。

SQL MIN() 语法

SELECT MIN(column_name) FROM table_name

注释：MIN 和 MAX 也可用于文本列，以获得按字母顺序排列的最高或最低值。

SQL MIN() 实例

我们拥有下面这个 "Orders" 表：

O_Id | OrderDate | OrderPrice | Customer
1 | 2008/12/29 | 1000 | Bush
2 | 2008/11/23 | 1600 | Carter
3 | 2008/10/05 | 700 | Bush
4 | 2008/09/28 | 300 | Bush
5 | 2008/08/06 | 2000 | Adams
6 | 2008/07/21 | 100 | Carter

现在，我们希望查找 "OrderPrice" 列的最小值。

我们使用如下 SQL 语句：

SELECT MIN(OrderPrice) AS SmallestOrderPrice FROM Orders

结果集类似这样：

SmallestOrderPrice
100
  • Previous Page
  • Next Page

SQL 测验


SQL NOT NULL 约束

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL NOT NULL 约束

  • Previous Page
  • Next Page

SQL NOT NULL 约束

NOT NULL 约束强制列不接受 NULL 值。

NOT NULL 约束强制字段始终包含值。这意味着，如果不向字段添加值，就无法插入新纪录或者更新记录。

下面的 SQL 语句强制 "Id_P" 列和 "LastName" 列不接受 NULL 值：

CREATE TABLE Persons
(
Id_P int NOT NULL,
LastName varchar(255) NOT NULL,
FirstName varchar(255),
Address varchar(255),
City varchar(255)
)
  • Previous Page
  • Next Page

SQL 测验


SQL NOW() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL NOW() 函数

  • Previous Page
  • Next Page

NOW() 函数

NOW 函数返回当前的日期和时间。

SQL NOW() 语法

SELECT NOW() FROM table_name

SQL NOW() 实例

我们拥有下面这个 "Products" 表：

Prod_Id | ProductName | Unit | UnitPrice
1 | gold | 1000 g | 32.35
2 | silver | 1000 g | 11.56
3 | copper | 1000 g | 6.85

现在，我们希望显示当天的日期所对应的名称和价格。

我们使用如下 SQL 语句：

SELECT ProductName, UnitPrice, Now() as PerDate FROM Products

结果集类似这样：

ProductName | UnitPrice | PerDate
gold | 32.35 | 12/29/2008 11:36:05 AM
silver | 11.56 | 12/29/2008 11:36:05 AM
copper | 6.85 | 12/29/2008 11:36:05 AM
  • Previous Page
  • Next Page

SQL 测验


SQL NULL 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL NULL 函数

  • Previous Page
  • Next Page

SQL ISNULL()、NVL()、IFNULL() 和 COALESCE() 函数

请看下面的 "Products" 表：

P_Id | ProductName | UnitPrice | UnitsInStock | UnitsOnOrder
1 | computer | 699 | 25 | 15
2 | printer | 365 | 36 |
3 | telephone | 280 | 159 | 57

假如 "UnitsOnOrder" 是可选的，而且可以包含 NULL 值。

我们使用如下 SELECT 语句：

SELECT ProductName,UnitPrice*(UnitsInStock+UnitsOnOrder)
FROM Products

在上面的例子中，如果有 "UnitsOnOrder" 值是 NULL，那么结果是 NULL。

微软的 ISNULL() 函数用于规定如何处理 NULL 值。

NVL(), IFNULL() 和 COALESCE() 函数也可以达到相同的结果。

在这里，我们希望 NULL 值为 0。

下面，如果 "UnitsOnOrder" 是 NULL，则不利于计算，因此如果值是 NULL 则 ISNULL() 返回 0。

SQL Server / MS Access

SELECT ProductName,UnitPrice*(UnitsInStock+ISNULL(UnitsOnOrder,0))
FROM Products

Oracle

Oracle 没有 ISNULL() 函数。不过，我们可以使用 NVL() 函数达到相同的结果：

SELECT ProductName,UnitPrice*(UnitsInStock+NVL(UnitsOnOrder,0))
FROM Products

MySQL

MySQL 可以使用 ISNULL() 函数。不过它的工作方式与微软的 ISNULL() 函数有点不同。

在 MySQL 中，我们可以使用 IFNULL() 函数，就像这样：

SELECT ProductName,UnitPrice*(UnitsInStock+IFNULL(UnitsOnOrder,0))
FROM Products

或者我们可以使用 COALESCE() 函数，就像这样：

SELECT ProductName,UnitPrice*(UnitsInStock+COALESCE(UnitsOnOrder,0))
FROM Products
  • Previous Page
  • Next Page

SQL 测验


SQL NULL 值

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL NULL 值

  • Previous Page
  • Next Page

NULL 值是遗漏的未知数据。

默认地，表的列可以存放 NULL 值。

本章讲解 IS NULL 和 IS NOT NULL 操作符。

SQL NULL 值

如果表中的某个列是可选的，那么我们可以在不向该列添加值的情况下插入新纪录或更新已有的记录。这意味着该字段将以 NULL 值保存。

NULL 值的处理方式与其他值不同。

NULL 用作未知的或不适用的值的占位符。

注释：无法比较 NULL 和 0；它们是不等价的。

SQL 的 NULL 值处理

请看下面的 "Persons" 表：

Id | LastName | FirstName | Address | City
1 | Adams | John |  | London
2 | Bush | George | Fifth Avenue | New York
3 | Carter | Thomas |  | Beijing

假如 "Persons" 表中的 "Address" 列是可选的。这意味着如果在 "Address" 列插入一条不带值的记录，"Address" 列会使用 NULL 值保存。

那么我们如何测试 NULL 值呢？

无法使用比较运算符来测试 NULL 值，比如 =, <, 或者 <>。

我们必须使用 IS NULL 和 IS NOT NULL 操作符。

SQL IS NULL

我们如何仅仅选取在 "Address" 列中带有 NULL 值的记录呢？

我们必须使用 IS NULL 操作符：

SELECT LastName,FirstName,Address FROM Persons
WHERE Address IS NULL

结果集：

LastName | FirstName | Address
Adams | John |
Carter | Thomas |

提示：请始终使用 IS NULL 来查找 NULL 值。

SQL IS NOT NULL

我们如何选取在 "Address" 列中不带有 NULL 值的记录呢？

我们必须使用 IS NOT NULL 操作符：

SELECT LastName,FirstName,Address FROM Persons
WHERE Address IS NOT NULL

结果集：

LastName | FirstName | Address
Bush | George | Fifth Avenue

在下一节中，我们了解 ISNULL()、NVL()、IFNULL() 和 COALESCE() 函数。

  • Previous Page
  • Next Page

SQL 测验


SQL ORDER BY 子句

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL ORDER BY 子句

  • Previous Page
  • Next Page

ORDER BY 语句用于对结果集进行排序。

ORDER BY 语句

ORDER BY 语句用于根据指定的列对结果集进行排序。

ORDER BY 语句默认按照升序对记录进行排序。

如果您希望按照降序对记录进行排序，可以使用 DESC 关键字。

原始的表 (用在例子中的)：

Orders 表:

Company | OrderNumber
IBM | 3532
W3School | 2356
Apple | 4698
W3School | 6953

实例 1

以字母顺序显示公司名称：

SELECT Company, OrderNumber FROM Orders ORDER BY Company

结果：

Company | OrderNumber
Apple | 4698
IBM | 3532
W3School | 6953
W3School | 2356

实例 2

以字母顺序显示公司名称（Company），并以数字顺序显示顺序号（OrderNumber）：

SELECT Company, OrderNumber FROM Orders ORDER BY Company, OrderNumber

结果：

Company | OrderNumber
Apple | 4698
IBM | 3532
W3School | 2356
W3School | 6953

实例 3

以逆字母顺序显示公司名称：

SELECT Company, OrderNumber FROM Orders ORDER BY Company DESC

结果：

Company | OrderNumber
W3School | 6953
W3School | 2356
IBM | 3532
Apple | 4698

实例 4

以逆字母顺序显示公司名称，并以数字顺序显示顺序号：

SELECT Company, OrderNumber FROM Orders ORDER BY Company DESC, OrderNumber ASC

结果：

Company | OrderNumber
W3School | 2356
W3School | 6953
IBM | 3532
Apple | 4698

注意：在以上的结果中有两个相等的公司名称 (W3School)。只有这一次，在第一列中有相同的值时，第二列是以升序排列的。如果第一列中有些值为 nulls 时，情况也是这样的。

  • Previous Page
  • Next Page

SQL 测验


SQL PRIMARY KEY 约束

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL PRIMARY KEY 约束

  • Previous Page
  • Next Page

SQL PRIMARY KEY 约束

PRIMARY KEY 约束唯一标识数据库表中的每条记录。

主键必须包含唯一的值。

主键列不能包含 NULL 值。

每个表应该都一个主键，并且每个表只能有一个主键。

SQL PRIMARY KEY Constraint on CREATE TABLE

下面的 SQL 在 "Persons" 表创建时在 "Id_P" 列创建 PRIMARY KEY 约束：

MySQL:

CREATE TABLE Persons
(
Id_P int NOT NULL,
LastName varchar(255) NOT NULL,
FirstName varchar(255),
Address varchar(255),
City varchar(255),
PRIMARY KEY (Id_P)
)

SQL Server / Oracle / MS Access:

CREATE TABLE Persons
(
Id_P int NOT NULL PRIMARY KEY,
LastName varchar(255) NOT NULL,
FirstName varchar(255),
Address varchar(255),
City varchar(255)
)

如果需要命名 PRIMARY KEY 约束，以及为多个列定义 PRIMARY KEY 约束，请使用下面的 SQL 语法：

MySQL / SQL Server / Oracle / MS Access:

CREATE TABLE Persons
(
Id_P int NOT NULL,
LastName varchar(255) NOT NULL,
FirstName varchar(255),
Address varchar(255),
City varchar(255),
CONSTRAINT uc_PersonID PRIMARY KEY (Id_P,LastName)
)

SQL PRIMARY KEY Constraint on ALTER TABLE

如果在表已存在的情况下为 "Id_P" 列创建 PRIMARY KEY 约束，请使用下面的 SQL：

MySQL / SQL Server / Oracle / MS Access:

ALTER TABLE Persons
ADD PRIMARY KEY (Id_P)

如果需要命名 PRIMARY KEY 约束，以及为多个列定义 PRIMARY KEY 约束，请使用下面的 SQL 语法：

MySQL / SQL Server / Oracle / MS Access:

ALTER TABLE Persons
ADD CONSTRAINT pk_PersonID PRIMARY KEY (Id_P,LastName)

注释：如果您使用 ALTER TABLE 语句添加主键，必须把主键列声明为不包含 NULL 值（在表首次创建时）。

撤销 PRIMARY KEY 约束

如需撤销 PRIMARY KEY 约束，请使用下面的 SQL：

MySQL:

ALTER TABLE Persons
DROP PRIMARY KEY

SQL Server / Oracle / MS Access:

ALTER TABLE Persons
DROP CONSTRAINT pk_PersonID
  • Previous Page
  • Next Page

SQL 测验


SQL RIGHT JOIN 关键字

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL RIGHT JOIN 关键字

  • Previous Page
  • Next Page

SQL RIGHT JOIN 关键字

RIGHT JOIN 关键字会右表 (table_name2) 那里返回所有的行，即使在左表 (table_name1) 中没有匹配的行。

RIGHT JOIN 关键字语法

SELECT column_name(s)
FROM table_name1
RIGHT JOIN table_name2
ON table_name1.column_name=table_name2.column_name

注释：在某些数据库中， RIGHT JOIN 称为 RIGHT OUTER JOIN。

原始的表 (用在例子中的)：

"Persons" 表：

Id_P | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York
3 | Carter | Thomas | Changan Street | Beijing

"Orders" 表：

Id_O | OrderNo | Id_P
1 | 77895 | 3
2 | 44678 | 3
3 | 22456 | 1
4 | 24562 | 1
5 | 34764 | 65

右连接（RIGHT JOIN）实例

现在，我们希望列出所有的定单，以及定购它们的人 - 如果有的话。

您可以使用下面的 SELECT 语句：

SELECT Persons.LastName, Persons.FirstName, Orders.OrderNo
FROM Persons
RIGHT JOIN Orders
ON Persons.Id_P=Orders.Id_P
ORDER BY Persons.LastName

结果集：

LastName | FirstName | OrderNo
Adams | John | 22456
Adams | John | 24562
Carter | Thomas | 77895
Carter | Thomas | 44678
 |  | 34764

RIGHT JOIN 关键字会从右表 (Orders) 那里返回所有的行，即使在左表 (Persons) 中没有匹配的行。

  • Previous Page
  • Next Page

SQL 测验


SQL ROUND() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL ROUND() 函数

  • Previous Page
  • Next Page

ROUND() 函数

ROUND 函数用于把数值字段舍入为指定的小数位数。

SQL ROUND() 语法

SELECT ROUND(column_name,decimals) FROM table_name
参数 | 描述
column_name | 必需。要舍入的字段。
decimals | 必需。规定要返回的小数位数。

SQL ROUND() 实例

我们拥有下面这个 "Products" 表：

Prod_Id | ProductName | Unit | UnitPrice
1 | gold | 1000 g | 32.35
2 | silver | 1000 g | 11.56
3 | copper | 1000 g | 6.85

现在，我们希望把名称和价格舍入为最接近的整数。

我们使用如下 SQL 语句：

SELECT ProductName, ROUND(UnitPrice,0) as UnitPrice FROM Products

结果集类似这样：

ProductName | UnitPrice
gold | 32
silver | 12
copper | 7
  • Previous Page
  • Next Page

SQL 测验


SQL SELECT DISTINCT 语句

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL SELECT DISTINCT 语句

  • Previous Page
  • Next Page

本章讲解 SELECT DISTINCT 语句。

SQL SELECT DISTINCT 语句

在表中，可能会包含重复值。这并不成问题，不过，有时您也许希望仅仅列出不同（distinct）的值。

关键词 DISTINCT 用于返回唯一不同的值。

语法：

SELECT DISTINCT 列名称 FROM 表名称

使用 DISTINCT 关键词

如果要从 "Company" 列中选取所有的值，我们需要使用 SELECT 语句：

SELECT Company FROM Orders

"Orders"表：

Company | OrderNumber
IBM | 3532
W3School | 2356
Apple | 4698
W3School | 6953

结果：

Company
IBM
W3School
Apple
W3School

请注意，在结果集中，W3School 被列出了两次。

如需从 Company" 列中仅选取唯一不同的值，我们需要使用 SELECT DISTINCT 语句：

SELECT DISTINCT Company FROM Orders

结果：

Company
IBM
W3School
Apple

现在，在结果集中，"W3School" 仅被列出了一次。

  • Previous Page
  • Next Page

SQL 测验


SQL SELECT INTO 语句

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL SELECT INTO 语句

  • Previous Page
  • Next Page

SQL SELECT INTO 语句可用于创建表的备份复件。

SELECT INTO 语句

SELECT INTO 语句从一个表中选取数据，然后把数据插入另一个表中。

SELECT INTO 语句常用于创建表的备份复件或者用于对记录进行存档。

SQL SELECT INTO 语法

您可以把所有的列插入新表：

SELECT *
INTO new_table_name [IN externaldatabase]
FROM old_tablename

或者只把希望的列插入新表：

SELECT column_name(s)
INTO new_table_name [IN externaldatabase]
FROM old_tablename

SQL SELECT INTO 实例 - 制作备份复件

下面的例子会制作 "Persons" 表的备份复件：

SELECT *
INTO Persons_backup
FROM Persons

IN 子句可用于向另一个数据库中拷贝表：

SELECT *
INTO Persons IN 'Backup.mdb'
FROM Persons

如果我们希望拷贝某些域，可以在 SELECT 语句后列出这些域：

SELECT LastName,FirstName
INTO Persons_backup
FROM Persons

SQL SELECT INTO 实例 - 带有 WHERE 子句

我们也可以添加 WHERE 子句。

下面的例子通过从 "Persons" 表中提取居住在 "Beijing" 的人的信息，创建了一个带有两个列的名为 "Persons_backup" 的表：

SELECT LastName,Firstname
INTO Persons_backup
FROM Persons
WHERE City='Beijing'

SQL SELECT INTO 实例 - 被连接的表

从一个以上的表中选取数据也是可以做到的。

下面的例子会创建一个名为 "Persons_Order_Backup" 的新表，其中包含了从 Persons 和 Orders 两个表中取得的信息：

SELECT Persons.LastName,Orders.OrderNo
INTO Persons_Order_Backup
FROM Persons
INNER JOIN Orders
ON Persons.Id_P=Orders.Id_P
  • Previous Page
  • Next Page

SQL 测验


SQL SELECT 语句

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL SELECT 语句

  • Previous Page
  • Next Page

本章讲解 SELECT 和 SELECT * 语句。

SQL SELECT 语句

SELECT 语句用于从表中选取数据。

结果被存储在一个结果表中（称为结果集）。

SQL SELECT 语法

SELECT 列名称 FROM 表名称

以及：

SELECT * FROM 表名称

注释：SQL 语句对大小写不敏感。SELECT 等效于 select。

SQL SELECT 实例

如需获取名为 "LastName" 和 "FirstName" 的列的内容（从名为 "Persons" 的数据库表），请使用类似这样的 SELECT 语句：

SELECT LastName,FirstName FROM Persons

"Persons" 表:

Id | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York
3 | Carter | Thomas | Changan Street | Beijing

结果：

LastName | FirstName
Adams | John
Bush | George
Carter | Thomas

SQL SELECT * 实例

现在我们希望从 "Persons" 表中选取所有的列。

请使用符号 * 取代列的名称，就像这样：

SELECT * FROM Persons

提示：星号（*）是选取所有列的快捷方式。

结果：

Id | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York
3 | Carter | Thomas | Changan Street | Beijing

在结果集（result-set）中导航

由 SQL 查询程序获得的结果被存放在一个结果集中。大多数数据库软件系统都允许使用编程函数在结果集中进行导航，比如：Move-To-First-Record、Get-Record-Content、Move-To-Next-Record 等等。

类似这些编程函数不在本教程讲解之列。如需学习通过函数调用访问数据的知识，请访问我们的 ADO 教程 和 PHP 教程。

  • Previous Page
  • Next Page

SQL 测验


SQL Server CONVERT() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL Server CONVERT() 函数

SQL Server Date 函数

定义和用法

CONVERT() 函数是把日期转换为新数据类型的通用函数。

CONVERT() 函数可以用不同的格式显示日期/时间数据。

语法

CONVERT(data_type(length),data_to_be_converted,style)

data_type(length) 规定目标数据类型（带有可选的长度）。data_to_be_converted 含有需要转换的值。style 规定日期/时间的输出格式。

可以使用的 style 值：

Style ID | Style 格式
100 或者 0 | mon dd yyyy hh:miAM （或者 PM）
101 | mm/dd/yy
102 | yy.mm.dd
103 | dd/mm/yy
104 | dd.mm.yy
105 | dd-mm-yy
106 | dd mon yy
107 | Mon dd, yy
108 | hh:mm:ss
109 或者 9 | mon dd yyyy hh:mi:ss:mmmAM（或者 PM）
110 | mm-dd-yy
111 | yy/mm/dd
112 | yymmdd
113 或者 13 | dd mon yyyy hh:mm:ss:mmm(24h)
114 | hh:mi:ss:mmm(24h)
120 或者 20 | yyyy-mm-dd hh:mi:ss(24h)
121 或者 21 | yyyy-mm-dd hh:mi:ss.mmm(24h)
126 | yyyy-mm-ddThh:mm:ss.mmm（没有空格）
130 | dd mon yyyy hh:mi:ss:mmmAM
131 | dd/mm/yy hh:mi:ss:mmmAM

实例

下面的脚本使用 CONVERT() 函数来显示不同的格式。我们将使用 GETDATE() 函数来获得当前的日期/时间：

CONVERT(VARCHAR(19),GETDATE())
CONVERT(VARCHAR(10),GETDATE(),110)
CONVERT(VARCHAR(11),GETDATE(),106)
CONVERT(VARCHAR(24),GETDATE(),113)

结果类似：

Dec 29 2008 11:45 PM
12-29-2008
29 Dec 08
29 Dec 2008 16:25:46.635

SQL Server Date 函数

SQL 测验


SQL Server DATEADD() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL Server DATEADD() 函数

SQL Server Date 函数

定义和用法

DATEADD() 函数在日期中添加或减去指定的时间间隔。

语法

DATEADD(datepart,number,date)

date 参数是合法的日期表达式。number 是您希望添加的间隔数；对于未来的时间，此数是正数，对于过去的时间，此数是负数。

datepart 参数可以是下列的值：

datepart | 缩写
年 | yy, yyyy
季度 | qq, q
月 | mm, m
年中的日 | dy, y
日 | dd, d
周 | wk, ww
星期 | dw, w
小时 | hh
分钟 | mi, n
秒 | ss, s
毫秒 | ms
微妙 | mcs
纳秒 | ns

实例

假设我们有下面这个 "Orders" 表：

OrderId | ProductName | OrderDate
1 | 'Computer' | 2008-12-29 16:25:46.635

现在，我们希望向 "OrderDate" 添加 2 天，这样就可以找到付款日期。

我们使用如下 SELECT 语句：

SELECT OrderId,DATEADD(day,2,OrderDate) AS OrderPayDate
FROM Orders

结果：

OrderId | OrderPayDate
1 | 2008-12-31 16:25:46.635

SQL Server Date 函数

SQL 测验


SQL Server DATEDIFF() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL Server DATEDIFF() 函数

SQL Server Date 函数

定义和用法

DATEDIFF() 函数返回两个日期之间的天数。

语法

DATEDIFF(datepart,startdate,enddate)

startdate 和 enddate 参数是合法的日期表达式。

datepart 参数可以是下列的值：

datepart | 缩写
年 | yy, yyyy
季度 | qq, q
月 | mm, m
年中的日 | dy, y
日 | dd, d
周 | wk, ww
星期 | dw, w
小时 | hh
分钟 | mi, n
秒 | ss, s
毫秒 | ms
微妙 | mcs
纳秒 | ns

实例

例子 1

使用如下 SELECT 语句：

SELECT DATEDIFF(day,'2008-12-9','2008-12-30') AS DiffDate

结果：

DiffDate
1

例子 2

使用如下 SELECT 语句：

SELECT DATEDIFF(day,'2008-12-30','2008-12-29') AS DiffDate

结果：

DiffDate
-1

SQL Server Date 函数

SQL 测验


SQL Server DATEPART() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL Server DATEPART() 函数

SQL Server Date 函数

定义和用法

DATEPART() 函数用于返回日期/时间的单独部分，比如年、月、日、小时、分钟等等。

语法

DATEPART(datepart,date)

date 参数是合法的日期表达式。datepart 参数可以是下列的值：

datepart | 缩写
年 | yy, yyyy
季度 | qq, q
月 | mm, m
年中的日 | dy, y
日 | dd, d
周 | wk, ww
星期 | dw, w
小时 | hh
分钟 | mi, n
秒 | ss, s
毫秒 | ms
微妙 | mcs
纳秒 | ns

实例

假设我们有下面这个 "Orders" 表：

OrderId | ProductName | OrderDate
1 | 'Computer' | 2008-12-29 16:25:46.635

我们使用如下 SELECT 语句：

SELECT DATEPART(yyyy,OrderDate) AS OrderYear,
DATEPART(mm,OrderDate) AS OrderMonth,
DATEPART(dd,OrderDate) AS OrderDay,
FROM Orders
WHERE OrderId=1

结果：

OrderYear | OrderMonth | OrderDay
2008 | 12 | 29

SQL Server Date 函数

SQL 测验


SQL Server GETDATE() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL Server GETDATE() 函数

SQL Server Date 函数

定义和用法

GETDATE() 函数从 SQL Server 返回当前的时间和日期。

语法

GETDATE()

实例

例子 1

使用下面的 SELECT 语句：

SELECT GETDATE() AS CurrentDateTime

结果：

CurrentDateTime
2008-12-29 16:25:46.635

注释：上面的时间部分精确到毫秒。

例子 2

下面的 SQL 创建带有日期时间列 (OrderDate) 的 "Orders" 表：

CREATE TABLE Orders
(
OrderId int NOT NULL PRIMARY KEY,
ProductName varchar(50) NOT NULL,
OrderDate datetime NOT NULL DEFAULT GETDATE()
)

请注意，OrderDate 把 GETDATE() 规定为默认值。结果是，当您在表中插入新行时，当前日期和时间自动插入列中。

现在，我们希望在 "Orders" 表中插入一条记录：

INSERT INTO Orders (ProductName) VALUES ('Computer')

"Orders" 表将成为这样：

OrderId | ProductName | OrderDate
1 | 'Computer' | 2008-12-29 16:25:46.635

SQL Server Date 函数

SQL 测验


SQL SUM() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL SUM() 函数

  • Previous Page
  • Next Page

SUM() 函数

SUM 函数返回数值列的总数（总额）。

SQL SUM() 语法

SELECT SUM(column_name) FROM table_name

SQL SUM() 实例

我们拥有下面这个 "Orders" 表：

O_Id | OrderDate | OrderPrice | Customer
1 | 2008/12/29 | 1000 | Bush
2 | 2008/11/23 | 1600 | Carter
3 | 2008/10/05 | 700 | Bush
4 | 2008/09/28 | 300 | Bush
5 | 2008/08/06 | 2000 | Adams
6 | 2008/07/21 | 100 | Carter

现在，我们希望查找 "OrderPrice" 字段的总数。

我们使用如下 SQL 语句：

SELECT SUM(OrderPrice) AS OrderTotal FROM Orders

结果集类似这样：

OrderTotal
5700
  • Previous Page
  • Next Page

SQL 测验


SQL TOP 子句

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL TOP 子句

  • Previous Page
  • Next Page

TOP 子句

TOP 子句用于规定要返回的记录的数目。

对于拥有数千条记录的大型表来说，TOP 子句是非常有用的。

注释：并非所有的数据库系统都支持 TOP 子句。

SQL Server 的语法：

SELECT TOP number|percent column_name(s)
FROM table_name

MySQL 和 Oracle 中的 SQL SELECT TOP 是等价的

MySQL 语法

SELECT column_name(s)
FROM table_name
LIMIT number

例子

SELECT *
FROM Persons
LIMIT 5

Oracle 语法

SELECT column_name(s)
FROM table_name
WHERE ROWNUM <= number

例子

SELECT *
FROM Persons
WHERE ROWNUM <= 5

原始的表 (用在例子中的)：

Persons 表:

Id | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York
3 | Carter | Thomas | Changan Street | Beijing
4 | Obama | Barack | Pennsylvania Avenue | Washington

SQL TOP 实例

现在，我们希望从上面的 "Persons" 表中选取头两条记录。

我们可以使用下面的 SELECT 语句：

SELECT TOP 2 * FROM Persons

结果：

Id | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York

SQL TOP PERCENT 实例

现在，我们希望从上面的 "Persons" 表中选取 50% 的记录。

我们可以使用下面的 SELECT 语句：

SELECT TOP 50 PERCENT * FROM Persons

结果：

Id | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York
  • Previous Page
  • Next Page

SQL 测验


SQL UCASE() 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL UCASE() 函数

  • Previous Page
  • Next Page

UCASE() 函数

UCASE 函数把字段的值转换为大写。

SQL UCASE() 语法

SELECT UCASE(column_name) FROM table_name

SQL UCASE() 实例

我们拥有下面这个 "Persons" 表：

Id | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York
3 | Carter | Thomas | Changan Street | Beijing

现在，我们希望选取 "LastName" 和 "FirstName" 列的内容，然后把 "LastName" 列转换为大写。

我们使用如下 SQL 语句：

SELECT UCASE(LastName) as LastName,FirstName FROM Persons

结果集类似这样：

LastName | FirstName
ADAMS | John
BUSH | George
CARTER | Thomas
  • Previous Page
  • Next Page

SQL 测验


SQL UNION 和 UNION ALL 操作符

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL UNION 和 UNION ALL 操作符

  • Previous Page
  • Next Page

SQL UNION 操作符

UNION 操作符用于合并两个或多个 SELECT 语句的结果集。

请注意，UNION 内部的 SELECT 语句必须拥有相同数量的列。列也必须拥有相似的数据类型。同时，每条 SELECT 语句中的列的顺序必须相同。

SQL UNION 语法

SELECT column_name(s) FROM table_name1
UNION
SELECT column_name(s) FROM table_name2

注释：默认地，UNION 操作符选取不同的值。如果允许重复的值，请使用 UNION ALL。

SQL UNION ALL 语法

SELECT column_name(s) FROM table_name1
UNION ALL
SELECT column_name(s) FROM table_name2

另外，UNION 结果集中的列名总是等于 UNION 中第一个 SELECT 语句中的列名。

下面的例子中使用的原始表：

Employees_China:

E_ID | E_Name
01 | Zhang, Hua
02 | Wang, Wei
03 | Carter, Thomas
04 | Yang, Ming

Employees_USA:

E_ID | E_Name
01 | Adams, John
02 | Bush, George
03 | Carter, Thomas
04 | Gates, Bill

使用 UNION 命令

实例

列出所有在中国和美国的不同的雇员名：

SELECT E_Name FROM Employees_China
UNION
SELECT E_Name FROM Employees_USA

结果

E_Name
Zhang, Hua
Wang, Wei
Carter, Thomas
Yang, Ming
Adams, John
Bush, George
Gates, Bill

注释：这个命令无法列出在中国和美国的所有雇员。在上面的例子中，我们有两个名字相同的雇员，他们当中只有一个人被列出来了。UNION 命令只会选取不同的值。

UNION ALL

UNION ALL 命令和 UNION 命令几乎是等效的，不过 UNION ALL 命令会列出所有的值。

SQL Statement 1
UNION ALL
SQL Statement 2

使用 UNION ALL 命令

实例：

列出在中国和美国的所有的雇员：

SELECT E_Name FROM Employees_China
UNION ALL
SELECT E_Name FROM Employees_USA

结果

E_Name
Zhang, Hua
Wang, Wei
Carter, Thomas
Yang, Ming
Adams, John
Bush, George
Carter, Thomas
Gates, Bill
  • Previous Page
  • Next Page

SQL 测验


SQL UNIQUE 约束

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL UNIQUE 约束

  • Previous Page
  • Next Page

SQL UNIQUE 约束

UNIQUE 约束唯一标识数据库表中的每条记录。

UNIQUE 和 PRIMARY KEY 约束均为列或列集合提供了唯一性的保证。

PRIMARY KEY 拥有自动定义的 UNIQUE 约束。

请注意，每个表可以有多个 UNIQUE 约束，但是每个表只能有一个 PRIMARY KEY 约束。

SQL UNIQUE Constraint on CREATE TABLE

下面的 SQL 在 "Persons" 表创建时在 "Id_P" 列创建 UNIQUE 约束：

MySQL:

CREATE TABLE Persons
(
Id_P int NOT NULL,
LastName varchar(255) NOT NULL,
FirstName varchar(255),
Address varchar(255),
City varchar(255),
UNIQUE (Id_P)
)

SQL Server / Oracle / MS Access:

CREATE TABLE Persons
(
Id_P int NOT NULL UNIQUE,
LastName varchar(255) NOT NULL,
FirstName varchar(255),
Address varchar(255),
City varchar(255)
)

如果需要命名 UNIQUE 约束，以及为多个列定义 UNIQUE 约束，请使用下面的 SQL 语法：

MySQL / SQL Server / Oracle / MS Access:

CREATE TABLE Persons
(
Id_P int NOT NULL,
LastName varchar(255) NOT NULL,
FirstName varchar(255),
Address varchar(255),
City varchar(255),
CONSTRAINT uc_PersonID UNIQUE (Id_P,LastName)
)

撤销 UNIQUE 约束

如需撤销 UNIQUE 约束，请使用下面的 SQL：

MySQL:

ALTER TABLE Persons
DROP INDEX uc_PersonID

SQL Server / Oracle / MS Access:

ALTER TABLE Persons
DROP CONSTRAINT uc_PersonID
  • Previous Page
  • Next Page

SQL 测验


SQL UPDATE 语句

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL UPDATE 语句

  • Previous Page
  • Next Page

Update 语句

Update 语句用于修改表中的数据。

语法：

UPDATE 表名称 SET 列名称 = 新值 WHERE 列名称 = 某值

Person:

LastName | FirstName | Address | City
Gates | Bill | Xuanwumen 10 | Beijing
Wilson |  | Champs-Elysees |

更新某一行中的一个列

我们为 lastname 是 "Wilson" 的人添加 firstname：

UPDATE Person SET FirstName = 'Fred' WHERE LastName = 'Wilson'

结果：

LastName | FirstName | Address | City
Gates | Bill | Xuanwumen 10 | Beijing
Wilson | Fred | Champs-Elysees |

更新某一行中的若干列

我们会修改地址（address），并添加城市名称（city）：

UPDATE Person SET Address = 'Zhongshan 23', City = 'Nanjing'
WHERE LastName = 'Wilson'

结果：

LastName | FirstName | Address | City
Gates | Bill | Xuanwumen 10 | Beijing
Wilson | Fred | Zhongshan 23 | Nanjing
  • Previous Page
  • Next Page

SQL 测验


SQL VIEW（视图）

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL VIEW（视图）

  • Previous Page
  • Next Page

视图是可视化的表。

本章讲解如何创建、更新和删除视图。

SQL CREATE VIEW 语句

什么是视图？

在 SQL 中，视图是基于 SQL 语句的结果集的可视化的表。

视图包含行和列，就像一个真实的表。视图中的字段就是来自一个或多个数据库中的真实的表中的字段。我们可以向视图添加 SQL 函数、WHERE 以及 JOIN 语句，我们也可以提交数据，就像这些来自于某个单一的表。

注释：数据库的设计和结构不会受到视图中的函数、where 或 join 语句的影响。

SQL CREATE VIEW 语法

CREATE VIEW view_name AS
SELECT column_name(s)
FROM table_name
WHERE condition

注释：视图总是显示最近的数据。每当用户查询视图时，数据库引擎通过使用 SQL 语句来重建数据。

SQL CREATE VIEW 实例

可以从某个查询内部、某个存储过程内部，或者从另一个视图内部来使用视图。通过向视图添加函数、join 等等，我们可以向用户精确地提交我们希望提交的数据。

样本数据库 Northwind 拥有一些被默认安装的视图。视图 "Current Product List" 会从 Products 表列出所有正在使用的产品。这个视图使用下列 SQL 创建：

CREATE VIEW [Current Product List] AS
SELECT ProductID,ProductName
FROM Products
WHERE Discontinued=No

我们可以查询上面这个视图：

SELECT * FROM [Current Product List]

Northwind 样本数据库的另一个视图会选取 Products 表中所有单位价格高于平均单位价格的产品：

CREATE VIEW [Products Above Average Price] AS
SELECT ProductName,UnitPrice
FROM Products
WHERE UnitPrice>(SELECT AVG(UnitPrice) FROM Products)

我们可以像这样查询上面这个视图：

SELECT * FROM [Products Above Average Price]

另一个来自 Northwind 数据库的视图实例会计算在 1997 年每个种类的销售总数。请注意，这个视图会从另一个名为 "Product Sales for 1997" 的视图那里选取数据：

CREATE VIEW [Category Sales For 1997] AS
SELECT DISTINCT CategoryName,Sum(ProductSales) AS CategorySales
FROM [Product Sales for 1997]
GROUP BY CategoryName

我们可以像这样查询上面这个视图：

SELECT * FROM [Category Sales For 1997]

我们也可以向查询添加条件。现在，我们仅仅需要查看 "Beverages" 类的全部销量：

SELECT * FROM [Category Sales For 1997]
WHERE CategoryName='Beverages'

SQL 更新视图

您可以使用下面的语法来更新视图：

SQL CREATE OR REPLACE VIEW Syntax
CREATE OR REPLACE VIEW view_name AS
SELECT column_name(s)
FROM table_name
WHERE condition

现在，我们希望向 "Current Product List" 视图添加 "Category" 列。我们将通过下列 SQL 更新视图：

CREATE VIEW [Current Product List] AS
SELECT ProductID,ProductName,Category
FROM Products
WHERE Discontinued=No

SQL 撤销视图

您可以通过 DROP VIEW 命令来删除视图。

SQL DROP VIEW Syntax
DROP VIEW view_name
  • Previous Page
  • Next Page

SQL 测验


SQL WHERE 子句

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL WHERE 子句

  • Previous Page
  • Next Page

WHERE 子句用于规定选择的标准。

WHERE 子句

如需有条件地从表中选取数据，可将 WHERE 子句添加到 SELECT 语句。

语法

SELECT 列名称 FROM 表名称 WHERE 列 运算符 值

下面的运算符可在 WHERE 子句中使用：

操作符 | 描述
= | 等于
<> | 不等于
> | 大于
< | 小于
>= | 大于等于
<= | 小于等于
BETWEEN | 在某个范围内
LIKE | 搜索某种模式

注释：在某些版本的 SQL 中，操作符 <> 可以写为 !=。

使用 WHERE 子句

如果只希望选取居住在城市 "Beijing" 中的人，我们需要向 SELECT 语句添加 WHERE 子句：

SELECT * FROM Persons WHERE City='Beijing'

"Persons" 表

LastName | FirstName | Address | City | Year
Adams | John | Oxford Street | London | 1970
Bush | George | Fifth Avenue | New York | 1975
Carter | Thomas | Changan Street | Beijing | 1980
Gates | Bill | Xuanwumen 10 | Beijing | 1985

结果：

LastName | FirstName | Address | City | Year
Carter | Thomas | Changan Street | Beijing | 1980
Gates | Bill | Xuanwumen 10 | Beijing | 1985

引号的使用

请注意，我们在例子中的条件值周围使用的是单引号。

SQL 使用单引号来环绕文本值（大部分数据库系统也接受双引号）。如果是数值，请不要使用引号。

文本值：

这是正确的：
SELECT * FROM Persons WHERE FirstName='Bush'

这是错误的：
SELECT * FROM Persons WHERE FirstName=Bush

数值：

这是正确的：
SELECT * FROM Persons WHERE Year>1965

这是错误的：
SELECT * FROM Persons WHERE Year>'1965'
  • Previous Page
  • Next Page

SQL 测验


SQL 测验

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL 测验

  • Previous Page
  • Next Page

您可以通过 W3SCHOOL 的测验程序来测试您的 SQL 技能。

关于本测验

本测验包含 20 道题，每道题的最长答题时间是 20 分钟（这是由于每个 session 的默认有效时间是 20 钟）。

本测验是非官方的测试，它仅仅提供了一个了解您对 SQL 的掌握程度的工具。

测验会被记分

每道题的分值是 1 分。在您完成全部的20道题之后，系统会为您的测验打分，并提供您做错的题目的正确答案。其中，绿色为正确答案，而红色为错误答案。

现在就开始测验！祝您好运。

  • Previous Page
  • Next Page

SQL 测验


SQL 撤销索引、表以及数据库

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL 撤销索引、表以及数据库

  • Previous Page
  • Next Page

通过使用 DROP 语句，可以轻松地删除索引、表和数据库。

SQL DROP INDEX 语句

我们可以使用 DROP INDEX 命令删除表格中的索引。

用于 Microsoft SQLJet (以及 Microsoft Access) 的语法:

DROP INDEX index_name ON table_name

用于 MS SQL Server 的语法:

DROP INDEX table_name.index_name

用于 IBM DB2 和 Oracle 语法:

DROP INDEX index_name

用于 MySQL 的语法:

ALTER TABLE table_name DROP INDEX index_name

SQL DROP TABLE 语句

DROP TABLE 语句用于删除表（表的结构、属性以及索引也会被删除）：

DROP TABLE 表名称

SQL DROP DATABASE 语句

DROP DATABASE 语句用于删除数据库：

DROP DATABASE 数据库名称

SQL TRUNCATE TABLE 语句

如果我们仅仅需要除去表内的数据，但并不删除表本身，那么我们该如何做呢？

请使用 TRUNCATE TABLE 命令（仅仅删除表格中的数据）：

TRUNCATE TABLE 表名称
  • Previous Page
  • Next Page

SQL 测验


SQL 服务器 - RDBMS

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL 服务器 - RDBMS

  • Previous Page
  • Next Page

现代的 SQL 服务器构建在 RDBMS 之上。

DBMS - 数据库管理系统（Database Management System）

数据库管理系统是一种可以访问数据库中数据的计算机程序。

DBMS 使我们有能力在数据库中提取、修改或者存贮信息。

不同的 DBMS 提供不同的函数供查询、提交以及修改数据。

RDBMS - 关系数据库管理系统（Relational Database Management System）

关系数据库管理系统 (RDBMS) 也是一种数据库管理系统，其数据库是根据数据间的关系来组织和访问数据的。

20 世纪 70 年代初，IBM 公司发明了 RDBMS。

RDBMS 是 SQL 的基础，也是所有现代数据库系统诸如 Oracle、SQL Server、IBM DB2、Sybase、MySQL 以及 Microsoft Access 的基础。

  • Previous Page
  • Next Page

SQL 测验


SQL 函数

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL 函数

  • Previous Page
  • Next Page

SQL 拥有很多可用于计数和计算的内建函数。

函数的语法

内建 SQL 函数的语法是：

SELECT function(列) FROM 表

函数的类型

在 SQL 中，基本的函数类型和种类有若干种。函数的基本类型是：

  • Aggregate 函数
  • Scalar 函数

合计函数（Aggregate functions）

Aggregate 函数的操作面向一系列的值，并返回一个单一的值。

注释：如果在 SELECT 语句的项目列表中的众多其它表达式中使用 SELECT 语句，则这个 SELECT 必须使用 GROUP BY 语句！

"Persons" table (在大部分的例子中使用过)

Name | Age
Adams, John | 38
Bush, George | 33
Carter, Thomas | 28

MS Access 中的合计函数

函数 | 描述
AVG(column) | 返回某列的平均值
COUNT(column) | 返回某列的行数（不包括 NULL 值）
COUNT(*) | 返回被选行数
FIRST(column) | 返回在指定的域中第一个记录的值
LAST(column) | 返回在指定的域中最后一个记录的值
MAX(column) | 返回某列的最高值
MIN(column) | 返回某列的最低值
STDEV(column) |
STDEVP(column) |
SUM(column) | 返回某列的总和
VAR(column) |
VARP(column) |

在 SQL Server 中的合计函数

函数 | 描述
AVG(column) | 返回某列的行数
BINARY_CHECKSUM |
CHECKSUM |
CHECKSUM_AGG |
COUNT(column) | 返回某列的行数（不包括NULL值）
COUNT(*) | 返回被选行数
COUNT(DISTINCT column) | 返回相异结果的数目
FIRST(column) | 返回在指定的域中第一个记录的值（SQLServer2000 不支持）
LAST(column) | 返回在指定的域中最后一个记录的值（SQLServer2000 不支持）
MAX(column) | 返回某列的最高值
MIN(column) | 返回某列的最低值
STDEV(column) |
STDEVP(column) |
SUM(column) | 返回某列的总和
VAR(column) |
VARP(column) |

Scalar 函数

Scalar 函数的操作面向某个单一的值，并返回基于输入值的一个单一的值。

MS Access 中的 Scalar 函数

函数 | 描述
UCASE(c) | 将某个域转换为大写
LCASE(c) | 将某个域转换为小写
MID(c,start[,end]) | 从某个文本域提取字符
LEN(c) | 返回某个文本域的长度
INSTR(c,char) | 返回在某个文本域中指定字符的数值位置
LEFT(c,number_of_char) | 返回某个被请求的文本域的左侧部分
RIGHT(c,number_of_char) | 返回某个被请求的文本域的右侧部分
ROUND(c,decimals) | 对某个数值域进行指定小数位数的四舍五入
MOD(x,y) | 返回除法操作的余数
NOW() | 返回当前的系统日期
FORMAT(c,format) | 改变某个域的显示方式
DATEDIFF(d,date1,date2) | 用于执行日期计算
  • Previous Page
  • Next Page

SQL 测验


SQL 简介

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL 简介

  • Previous Page
  • Next Page

SQL 是用于访问和处理数据库的标准的计算机语言。

什么是 SQL？

  • SQL 指结构化查询语言
  • SQL 使我们有能力访问数据库
  • SQL 是一种 ANSI 的标准计算机语言

编者注：ANSI，美国国家标准化组织

SQL 能做什么？

  • SQL 面向数据库执行查询
  • SQL 可从数据库取回数据
  • SQL 可在数据库中插入新的纪录
  • SQL 可更新数据库中的数据
  • SQL 可从数据库删除记录
  • SQL 可创建新数据库
  • SQL 可在数据库中创建新表
  • SQL 可在数据库中创建存储过程
  • SQL 可在数据库中创建视图
  • SQL 可以设置表、存储过程和视图的权限

SQL 是一种标准 - 但是...

SQL 是一门 ANSI 的标准计算机语言，用来访问和操作数据库系统。SQL 语句用于取回和更新数据库中的数据。SQL 可与数据库程序协同工作，比如 MS Access、DB2、Informix、MS SQL Server、Oracle、Sybase 以及其他数据库系统。

不幸地是，存在着很多不同版本的 SQL 语言，但是为了与 ANSI 标准相兼容，它们必须以相似的方式共同地来支持一些主要的关键词（比如 SELECT、UPDATE、DELETE、INSERT、WHERE 等等）。

注释：除了 SQL 标准之外，大部分 SQL 数据库程序都拥有它们自己的私有扩展！

在您的网站中使用 SQL

要创建发布数据库中数据的网站，您需要以下要素：

  • RDBMS 数据库程序（比如 MS Access, SQL Server, MySQL）
  • 服务器端脚本语言（比如 PHP 或 ASP）
  • SQL
  • HTML / CSS

RDBMS

RDBMS 指的是关系型数据库管理系统。

RDBMS 是 SQL 的基础，同样也是所有现代数据库系统的基础，比如 MS SQL Server, IBM DB2, Oracle, MySQL 以及 Microsoft Access。

RDBMS 中的数据存储在被称为表（tables）的数据库对象中。

表是相关的数据项的集合，它由列和行组成。

  • Previous Page
  • Next Page

SQL 测验


SQL 教程

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL 教程

  • Next Page

SQL 是用于访问和处理数据库的标准的计算机语言。

在本教程中，您将学到如何使用 SQL 访问和处理数据系统中的数据，这类数据库包括：Oracle, Sybase, SQL Server, DB2, Access 等等。

开始学习 SQL ！

注：本教程中出现的姓名、地址等信息仅供教学，与实际情况无关。

SQL 测验

在 W3School 测试你的 SQL 技能!

开始 SQL 测验 ！

  • Next Page

SQL 测验


SQL 快速参考

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL 快速参考

  • Previous Page
  • Next Page

来自 W3School 的 SQL 快速参考。可以打印它，以备日常使用。

SQL 语句

语句 | 语法
AND / OR | SELECT column_name(s) FROM table_name WHERE condition AND|OR condition
ALTER TABLE (add column) | ALTER TABLE table_name ADD column_name datatype
ALTER TABLE (drop column) | ALTER TABLE table_name DROP COLUMN column_name
AS (alias for column) | SELECT column_name AS column_alias FROM table_name
AS (alias for table) | SELECT column_name FROM table_name AS table_alias
BETWEEN | SELECT column_name(s) FROM table_name WHERE column_name BETWEEN value1 AND value2
CREATE DATABASE | CREATE DATABASE database_name
CREATE INDEX | CREATE INDEX index_name ON table_name (column_name)
CREATE TABLE | CREATE TABLE table_name ( column_name1 data_type, column_name2 data_type, ....... )
CREATE UNIQUE INDEX | CREATE UNIQUE INDEX index_name ON table_name (column_name)
CREATE VIEW | CREATE VIEW view_name AS SELECT column_name(s) FROM table_name WHERE condition
DELETE FROM | DELETE FROM table_name (Note: Deletes the entire table!!) or DELETE FROM table_name WHERE condition
DROP DATABASE | DROP DATABASE database_name
DROP INDEX | DROP INDEX table_name.index_name
DROP TABLE | DROP TABLE table_name
GROUP BY | SELECT column_name1,SUM(column_name2) FROM table_name GROUP BY column_name1
HAVING | SELECT column_name1,SUM(column_name2) FROM table_name GROUP BY column_name1 HAVING SUM(column_name2) condition value
IN | SELECT column_name(s) FROM table_name WHERE column_name IN (value1,value2,..)
INSERT INTO | INSERT INTO table_name VALUES (value1, value2,....) or INSERT INTO table_name (column_name1, column_name2,...) VALUES (value1, value2,....)
LIKE | SELECT column_name(s) FROM table_name WHERE column_name LIKE pattern
ORDER BY | SELECT column_name(s) FROM table_name ORDER BY column_name [ASC|DESC]
SELECT | SELECT column_name(s) FROM table_name
SELECT * | SELECT * FROM table_name
SELECT DISTINCT | SELECT DISTINCT column_name(s) FROM table_name
SELECT INTO (used to create backup copies of tables) | SELECT * INTO new_table_name FROM original_table_name or SELECT column_name(s) INTO new_table_name FROM original_table_name
TRUNCATE TABLE (deletes only the data inside the table) | TRUNCATE TABLE table_name
UPDATE | UPDATE table_name SET column_name=new_value [, column_name=new_value] WHERE column_name=some_value
WHERE | SELECT column_name(s) FROM table_name WHERE condition
  • Previous Page
  • Next Page

SQL 测验


SQL 数据类型

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL 数据类型

  • Previous Page
  • Next Page

Microsoft Access、MySQL 以及 SQL Server 所使用的数据类型和范围。

Microsoft Access 数据类型

数据类型 | 描述 | 存储
Text | 用于文本或文本与数字的组合。最多 255 个字符。 |
Memo | Memo 用于更大数量的文本。最多存储 65,536 个字符。 注释：无法对 memo 字段进行排序。不过它们是可搜索的。 |
Byte | 允许 0 到 255 的数字。 | 1 字节
Integer | 允许介于 -32,768 到 32,767 之间的数字。 | 2 字节
Long | 允许介于 -2,147,483,648 与 2,147,483,647 之间的全部数字 | 4 字节
Single | 单精度浮点。处理大多数小数。 | 4 字节
Double | 双精度浮点。处理大多数小数。 | 8 字节
Currency | 用于货币。支持 15 位的元，外加 4 位小数。 提示：您可以选择使用哪个国家的货币。 | 8 字节
AutoNumber | AutoNumber 字段自动为每条记录分配数字，通常从 1 开始。 | 4 字节
Date/Time | 用于日期和时间 | 8 字节
Yes/No | 逻辑字段，可以显示为 Yes/No、True/False 或 On/Off。 在代码中，使用常量 True 和 False （等价于 1 和 0） 注释：Yes/No 字段中不允许 Null 值 | 1 比特
Ole Object | 可以存储图片、音频、视频或其他 BLOBs (Binary Large OBjects) | 最多 1GB
Hyperlink | 包含指向其他文件的链接，包括网页。 |
Lookup Wizard | 允许你创建一个可从下列列表中进行选择的选项列表。 | 4 字节

MySQL 数据类型

在 MySQL 中，有三种主要的类型：文本、数字和日期/时间类型。

Text 类型：

数据类型 | 描述
CHAR(size) | 保存固定长度的字符串（可包含字母、数字以及特殊字符）。在括号中指定字符串的长度。最多 255 个字符。
VARCHAR(size) | 保存可变长度的字符串（可包含字母、数字以及特殊字符）。在括号中指定字符串的最大长度。最多 255 个字符。 注释：如果值的长度大于 255，则被转换为 TEXT 类型。
TINYTEXT | 存放最大长度为 255 个字符的字符串。
TEXT | 存放最大长度为 65,535 个字符的字符串。
BLOB | 用于 BLOBs (Binary Large OBjects)。存放最多 65,535 字节的数据。
MEDIUMTEXT | 存放最大长度为 16,777,215 个字符的字符串。
MEDIUMBLOB | 用于 BLOBs (Binary Large OBjects)。存放最多 16,777,215 字节的数据。
LONGTEXT | 存放最大长度为 4,294,967,295 个字符的字符串。
LONGBLOB | 用于 BLOBs (Binary Large OBjects)。存放最多 4,294,967,295 字节的数据。
ENUM(x,y,z,etc.) | 允许你输入可能值的列表。可以在 ENUM 列表中列出最大 65535 个值。如果列表中不存在插入的值，则插入空值。 注释：这些值是按照你输入的顺序存储的。 可以按照此格式输入可能的值：ENUM('X','Y','Z')
SET | 与 ENUM 类似，SET 最多只能包含 64 个列表项，不过 SET 可存储一个以上的值。

Number 类型：

数据类型 | 描述
TINYINT(size) | -128 到 127 常规。0 到 255 无符号*。在括号中规定最大位数。
SMALLINT(size) | -32768 到 32767 常规。0 到 65535 无符号*。在括号中规定最大位数。
MEDIUMINT(size) | -8388608 到 8388607 普通。0 to 16777215 无符号*。在括号中规定最大位数。
INT(size) | -2147483648 到 2147483647 常规。0 到 4294967295 无符号*。在括号中规定最大位数。
BIGINT(size) | -9223372036854775808 到 9223372036854775807 常规。0 到 18446744073709551615 无符号*。在括号中规定最大位数。
FLOAT(size,d) | 带有浮动小数点的小数字。在括号中规定最大位数。在 d 参数中规定小数点右侧的最大位数。
DOUBLE(size,d) | 带有浮动小数点的大数字。在括号中规定最大位数。在 d 参数中规定小数点右侧的最大位数。
DECIMAL(size,d) | 作为字符串存储的 DOUBLE 类型，允许固定的小数点。

* 这些整数类型拥有额外的选项 UNSIGNED。通常，整数可以是负数或正数。如果添加 UNSIGNED 属性，那么范围将从 0 开始，而不是某个负数。

Date 类型：

数据类型 | 描述
DATE() | 日期。格式：YYYY-MM-DD 注释：支持的范围是从 '1000-01-01' 到 '9999-12-31'
DATETIME() | *日期和时间的组合。格式：YYYY-MM-DD HH:MM:SS 注释：支持的范围是从 '1000-01-01 00:00:00' 到 '9999-12-31 23:59:59'
TIMESTAMP() | *时间戳。TIMESTAMP 值使用 Unix 纪元('1970-01-01 00:00:00' UTC) 至今的描述来存储。格式：YYYY-MM-DD HH:MM:SS 注释：支持的范围是从 '1970-01-01 00:00:01' UTC 到 '2038-01-09 03:14:07' UTC
TIME() | 时间。格式：HH:MM:SS 注释：支持的范围是从 '-838:59:59' 到 '838:59:59'
YEAR() | 2 位或 4 位格式的年。 注释：4 位格式所允许的值：1901 到 2155。2 位格式所允许的值：70 到 69，表示从 1970 到 2069。

* 即便 DATETIME 和 TIMESTAMP 返回相同的格式，它们的工作方式很不同。在 INSERT 或 UPDATE 查询中，TIMESTAMP 自动把自身设置为当前的日期和时间。TIMESTAMP 也接受不同的格式，比如 YYYYMMDDHHMMSS、YYMMDDHHMMSS、YYYYMMDD 或 YYMMDD。

SQL Server 数据类型

Character 字符串：

数据类型 | 描述 | 存储
char(n) | 固定长度的字符串。最多 8,000 个字符。 | n
varchar(n) | 可变长度的字符串。最多 8,000 个字符。 |
varchar(max) | 可变长度的字符串。最多 1,073,741,824 个字符。 |
text | 可变长度的字符串。最多 2GB 字符数据。 |

Unicode 字符串：

数据类型 | 描述 | 存储
nchar(n) | 固定长度的 Unicode 数据。最多 4,000 个字符。 |
nvarchar(n) | 可变长度的 Unicode 数据。最多 4,000 个字符。 |
nvarchar(max) | 可变长度的 Unicode 数据。最多 536,870,912 个字符。 |
ntext | 可变长度的 Unicode 数据。最多 2GB 字符数据。 |

Binary 类型：

数据类型 | 描述 | 存储
bit | 允许 0、1 或 NULL |
binary(n) | 固定长度的二进制数据。最多 8,000 字节。 |
varbinary(n) | 可变长度的二进制数据。最多 8,000 字节。 |
varbinary(max) | 可变长度的二进制数据。最多 2GB 字节。 |
image | 可变长度的二进制数据。最多 2GB。 |

Number 类型：

数据类型 | 描述 | 存储
tinyint | 允许从 0 到 255 的所有数字。 | 1 字节
smallint | 允许从 -32,768 到 32,767 的所有数字。 | 2 字节
int | 允许从 -2,147,483,648 到 2,147,483,647 的所有数字。 | 4 字节
bigint | 允许介于 -9,223,372,036,854,775,808 和 9,223,372,036,854,775,807 之间的所有数字。 | 8 字节
decimal(p,s) | 固定精度和比例的数字。允许从 -10^38 +1 到 10^38 -1 之间的数字。 p 参数指示可以存储的最大位数（小数点左侧和右侧）。p 必须是 1 到 38 之间的值。默认是 18。 s 参数指示小数点右侧存储的最大位数。s 必须是 0 到 p 之间的值。默认是 0。 | 5-17 字节
numeric(p,s) | 固定精度和比例的数字。允许从 -10^38 +1 到 10^38 -1 之间的数字。 p 参数指示可以存储的最大位数（小数点左侧和右侧）。p 必须是 1 到 38 之间的值。默认是 18。 s 参数指示小数点右侧存储的最大位数。s 必须是 0 到 p 之间的值。默认是 0。 | 5-17 字节
smallmoney | 介于 -214,748.3648 和 214,748.3647 之间的货币数据。 | 4 字节
money | 介于 -922,337,203,685,477.5808 和 922,337,203,685,477.5807 之间的货币数据。 | 8 字节
float(n) | 从 -1.79E + 308 到 1.79E + 308 的浮动精度数字数据。 参数 n 指示该字段保存 4 字节还是 8 字节。float(24) 保存 4 字节，而 float(53) 保存 8 字节。n 的默认值是 53。 | 4 或 8 字节
real | 从 -3.40E + 38 到 3.40E + 38 的浮动精度数字数据。 | 4 字节

Date 类型：

数据类型 | 描述 | 存储
datetime | 从 1753 年 1 月 1 日 到 9999 年 12 月 31 日，精度为 3.33 毫秒。 | 8 bytes
datetime2 | 从 1753 年 1 月 1 日 到 9999 年 12 月 31 日，精度为 100 纳秒。 | 6-8 bytes
smalldatetime | 从 1900 年 1 月 1 日 到 2079 年 6 月 6 日，精度为 1 分钟。 | 4 bytes
date | 仅存储日期。从 0001 年 1 月 1 日 到 9999 年 12 月 31 日。 | 3 bytes
time | 仅存储时间。精度为 100 纳秒。 | 3-5 bytes
datetimeoffset | 与 datetime2 相同，外加时区偏移。 | 8-10 bytes
timestamp | 存储唯一的数字，每当创建或修改某行时，该数字会更新。timestamp 基于内部时钟，不对应真实时间。每个表只能有一个 timestamp 变量。 |

其他数据类型：

数据类型 | 描述
sql_variant | 存储最多 8,000 字节不同数据类型的数据，除了 text、ntext 以及 timestamp。
uniqueidentifier | 存储全局标识符 (GUID)。
xml | 存储 XML 格式化数据。最多 2GB。
cursor | 存储对用于数据库操作的指针的引用。
table | 存储结果集，供稍后处理。
  • Previous Page
  • Next Page

SQL 测验


SQL 通配符

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL 通配符

  • Previous Page
  • Next Page

在搜索数据库中的数据时，您可以使用 SQL 通配符。

SQL 通配符

在搜索数据库中的数据时，SQL 通配符可以替代一个或多个字符。

SQL 通配符必须与 LIKE 运算符一起使用。

在 SQL 中，可使用以下通配符：

通配符 | 描述
% | 替代一个或多个字符
_ | 仅替代一个字符
[charlist] | 字符列中的任何单一字符
[^charlist] 或者 [!charlist] | 不在字符列中的任何单一字符

原始的表 (用在例子中的)：

Persons 表:

Id | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York
3 | Carter | Thomas | Changan Street | Beijing

使用 % 通配符

例子 1

现在，我们希望从上面的 "Persons" 表中选取居住在以 "Ne" 开始的城市里的人：

我们可以使用下面的 SELECT 语句：

SELECT * FROM Persons
WHERE City LIKE 'Ne%'

结果集：

Id | LastName | FirstName | Address | City
2 | Bush | George | Fifth Avenue | New York

例子 2

接下来，我们希望从 "Persons" 表中选取居住在包含 "lond" 的城市里的人：

我们可以使用下面的 SELECT 语句：

SELECT * FROM Persons
WHERE City LIKE '%lond%'

结果集：

Id | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London

使用 _ 通配符

例子 1

现在，我们希望从上面的 "Persons" 表中选取名字的第一个字符之后是 "eorge" 的人：

我们可以使用下面的 SELECT 语句：

SELECT * FROM Persons
WHERE FirstName LIKE '_eorge'

结果集：

Id | LastName | FirstName | Address | City
2 | Bush | George | Fifth Avenue | New York

例子 2

接下来，我们希望从 "Persons" 表中选取的这条记录的姓氏以 "C" 开头，然后是一个任意字符，然后是 "r"，然后是任意字符，然后是 "er"：

我们可以使用下面的 SELECT 语句：

SELECT * FROM Persons
WHERE LastName LIKE 'C_r_er'

结果集：

Id | LastName | FirstName | Address | City
3 | Carter | Thomas | Changan Street | Beijing

使用 [charlist] 通配符

例子 1

现在，我们希望从上面的 "Persons" 表中选取居住的城市以 "A" 或 "O" 或 "F" 开头的人：

我们可以使用下面的 SELECT 语句：

SELECT * FROM Persons
WHERE City LIKE '[AOF]%'

结果集：

Id | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York

例子 2

现在，我们希望从上面的 "Persons" 表中选取居住的城市不以 "A" 或 "O" 或 "F" 开头的人：

我们可以使用下面的 SELECT 语句：

SELECT * FROM Persons
WHERE City LIKE '[!AOF]%'

结果集：

Id | LastName | FirstName | Address | City
3 | Carter | Thomas | Changan Street | Beijing
  • Previous Page
  • Next Page

SQL 测验


SQL 语法

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL 语法

  • Previous Page
  • Next Page

数据库表

一个数据库通常包含一个或多个表。每个表由一个名字标识（例如“客户”或者“订单”）。表包含带有数据的记录（行）。

下面的例子是一个名为 "Persons" 的表：

Id | LastName | FirstName | Address | City
1 | Adams | John | Oxford Street | London
2 | Bush | George | Fifth Avenue | New York
3 | Carter | Thomas | Changan Street | Beijing

上面的表包含三条记录（每一条对应一个人）和五个列（Id、姓、名、地址和城市）。

SQL 语句

您需要在数据库上执行的大部分工作都由 SQL 语句完成。

下面的语句从表中选取 LastName 列的数据：

SELECT LastName FROM Persons

结果集类似这样：

LastName
Adams
Bush
Carter

在本教程中，我们将为您讲解各种不同的 SQL 语句。

重要事项

一定要记住，SQL 对大小写不敏感！

SQL 语句后面的分号？

某些数据库系统要求在每条 SQL 命令的末端使用分号。在我们的教程中不使用分号。

分号是在数据库系统中分隔每条 SQL 语句的标准方法，这样就可以在对服务器的相同请求中执行一条以上的语句。

如果您使用的是 MS Access 和 SQL Server 2000，则不必在每条 SQL 语句之后使用分号，不过某些数据库软件要求必须使用分号。

SQL DML 和 DDL

可以把 SQL 分为两个部分：数据操作语言 (DML) 和 数据定义语言 (DDL)。

SQL (结构化查询语言)是用于执行查询的语法。但是 SQL 语言也包含用于更新、插入和删除记录的语法。

查询和更新指令构成了 SQL 的 DML 部分：

  • SELECT - 从数据库表中获取数据
  • UPDATE - 更新数据库表中的数据
  • DELETE - 从数据库表中删除数据
  • INSERT INTO - 向数据库表中插入数据

SQL 的数据定义语言 (DDL) 部分使我们有能力创建或删除表格。我们也可以定义索引（键），规定表之间的链接，以及施加表间的约束。

SQL 中最重要的 DDL 语句:

  • CREATE DATABASE - 创建新数据库
  • ALTER DATABASE - 修改数据库
  • CREATE TABLE - 创建新表
  • ALTER TABLE - 变更（改变）数据库表
  • DROP TABLE - 删除表
  • CREATE INDEX - 创建索引（搜索键）
  • DROP INDEX - 删除索引
  • Previous Page
  • Next Page

SQL 测验


SQL 约束 (Constraints)

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL 约束 (Constraints)

  • Previous Page
  • Next Page

SQL 约束

约束用于限制加入表的数据的类型。

可以在创建表时规定约束（通过 CREATE TABLE 语句），或者在表创建之后也可以（通过 ALTER TABLE 语句）。

我们将主要探讨以下几种约束：

  • NOT NULL
  • UNIQUE
  • PRIMARY KEY
  • FOREIGN KEY
  • CHECK
  • DEFAULT

注释：在下面的章节，我们会详细讲解每一种约束。

  • Previous Page
  • Next Page

SQL 测验


SQL 总结

SQL 基础

  • SQL 首页
  • SQL 简介
  • SQL 语法
  • SQL select
  • SQL distinct
  • SQL where
  • SQL AND & OR
  • SQL Order By
  • SQL insert
  • SQL update
  • SQL delete

SQL 高级

  • SQL Top
  • SQL Like
  • SQL 通配符
  • SQL In
  • SQL Between
  • SQL Aliases
  • SQL Join
  • SQL Inner Join
  • SQL Left Join
  • SQL Right Join
  • SQL Full Join
  • SQL Union
  • SQL Select Into
  • SQL Create DB
  • SQL Create Table
  • SQL Constraints
  • SQL Not Null
  • SQL Unique
  • SQL Primary Key
  • SQL Foreign Key
  • SQL Check
  • SQL Default
  • SQL Create Index
  • SQL Drop
  • SQL Alter
  • SQL Increment
  • SQL View
  • SQL Date
  • SQL Nulls
  • SQL isnull()
  • SQL 数据类型
  • SQL 服务器

SQL 函数

  • SQL functions
  • SQL avg()
  • SQL count()
  • SQL first()
  • SQL last()
  • SQL max()
  • SQL min()
  • SQL sum()
  • SQL Group By
  • SQL Having
  • SQL ucase()
  • SQL lcase()
  • SQL mid()
  • SQL len()
  • SQL round()
  • SQL now()
  • SQL format()
  • SQL 快速索引
  • SQL 总结

实例/测验

  • SQL 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

我们已经学习了 SQL，下一步学习什么呢？

  • Previous Page
  • Next Page

SQL 概要

本教程已经向您讲解了用来访问和处理数据库系统的标准计算机语言。

我们已经学习了如何使用 SQL 在数据库中执行查询、获取数据、插入新的纪录、删除记录以及更新记录。

SQL 是一种与数据库程序协同工作的标准语言，这些数据库程序包括 MS Access、DB2、Informix、MS SQL Server、Oracle、MySQL、Sybase 等等。

我们已经学习了 SQL，下一步学习什么呢？

下一步应该学习 ADO。

ADO 是一种从网站访问数据库中数据的编程接口。

ADO 使用 SQL 来查询数据库中的数据。

如果您需要学习更多关于 ADO 的知识，请访问我们的《ADO 教程》。

  • Previous Page
  • Next Page

SQL 测验


HTML 页面中的 SVG

SVG 基础

  • SVG 首页
  • SVG 简介
  • SVG 实例
  • SVG in HTML

SVG 形状

  • SVG 矩形
  • SVG 圆形
  • SVG 椭圆
  • SVG 线条
  • SVG 多边形
  • SVG 折线
  • SVG 路径

SVG 滤镜

  • SVG 滤镜简介
  • SVG 高斯滤镜

SVG 渐变

  • SVG 线形渐变
  • SVG 放射渐变

SVG 实例

  • SVG 实例

SVG 参考

  • SVG 元素

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 页面中的 SVG

  • Previous Page
  • Next Page

SVG 文件可通过以下标签嵌入 HTML 文档：<embed>、<object> 或者 <iframe>。

HTML 页面中的 SVG

下面，你会看到三种把 SVG 文件嵌入 HTML 页面的不同方法。

使用 <embed> 标签

<embed> 标签被所有主流的浏览器支持，并允许使用脚本。

注释：当在 HTML 页面中嵌入 SVG 时使用 <embed> 标签是 Adobe SVG Viewer 推荐的方法！然而，如果需要创建合法的 XHTML，就不能使用 <embed>。任何 HTML 规范中都没有 <embed> 标签。

语法：

<embed src="rect.svg" width="300" height="100"
type="image/svg+xml"
pluginspage="http://www.adobe.com/svg/viewer/install/" />

注释：pluginspage 属性指向下载插件的 URL。

使用 <object> 标签

<object> 标签是 HTML 4 的标准标签，被所有较新的浏览器支持。它的缺点是不允许使用脚本。

注释：假如您安装了最新版本的 Adobe SVG Viewer，那么当使用 <object> 标签时 SVG 文件无法工作（至少不能在 IE 中工作）！

语法：

<object data="rect.svg" width="300" height="100"
type="image/svg+xml"
codebase="http://www.adobe.com/svg/viewer/install/" />

注释：codebase 属性指向下载插件的 URL。

使用 <iframe> 标签

<iframe> 标签可工作在大部分的浏览器中。

语法：

<iframe src="rect.svg" width="300" height="100">
</iframe>

我期望....

如果仅仅通过引用 SVG 的命名空间，就能够把 SVG 元素之间添加到 HTML 代码中，那就太棒了，这像这样：

<html xmlns:svg="http://www.w3.org/2000/svg">
<body>

<p>This is an HTML paragraph</p>

<svg:svg width="300" height="100" version="1.1" >
<svg:circle cx="100" cy="50" r="40" stroke="black"
stroke-width="2" fill="red" />
</svg:svg>

</body>
</html>
  • Previous Page
  • Next Page

SVG 参考手册
SVG 实例


SVG <circle>

SVG 基础

  • SVG 首页
  • SVG 简介
  • SVG 实例
  • SVG in HTML

SVG 形状

  • SVG 矩形
  • SVG 圆形
  • SVG 椭圆
  • SVG 线条
  • SVG 多边形
  • SVG 折线
  • SVG 路径

SVG 滤镜

  • SVG 滤镜简介
  • SVG 高斯滤镜

SVG 渐变

  • SVG 线形渐变
  • SVG 放射渐变

SVG 实例

  • SVG 实例

SVG 参考

  • SVG 元素

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SVG <circle>

  • Previous Page
  • Next Page

<circle> 标签可用来创建一个圆。

<circle> 标签

<circle> 标签可用来创建一个圆。

请把下面的代码拷贝到记事本，然后把文件保存为 "circle1.svg"。把此文件放入您的web目录：

<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

<svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<circle cx="100" cy="50" r="40" stroke="black"
stroke-width="2" fill="red"/>

</svg>

代码解释：

cx 和 cy 属性定义圆点的 x 和 y 坐标。如果省略 cx 和 cy，圆的中心会被设置为 (0, 0)

r 属性定义圆的半径。

查看例子

  • Previous Page
  • Next Page

SVG 参考手册
SVG 实例


SVG <ellipse>

SVG 基础

  • SVG 首页
  • SVG 简介
  • SVG 实例
  • SVG in HTML

SVG 形状

  • SVG 矩形
  • SVG 圆形
  • SVG 椭圆
  • SVG 线条
  • SVG 多边形
  • SVG 折线
  • SVG 路径

SVG 滤镜

  • SVG 滤镜简介
  • SVG 高斯滤镜

SVG 渐变

  • SVG 线形渐变
  • SVG 放射渐变

SVG 实例

  • SVG 实例

SVG 参考

  • SVG 元素

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SVG <ellipse>

  • Previous Page
  • Next Page

<ellipse> 标签可用来创建椭圆。

<ellipse> 标签

<ellipse> 标签可用来创建椭圆。椭圆与圆很相似。不同之处在于椭圆有不同的 x 和 y 半径，而圆的 x 和 y 半径是相同的。

请把下面的代码拷贝到记事本，然后把文件保存为 "ellipse1.svg"。把此文件放入您的 web 目录：

<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

<svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<ellipse cx="300" cy="150" rx="200" ry="80"
style="fill:rgb(200,100,50);
stroke:rgb(0,0,100);stroke-width:2"/>

</svg>

代码解释：

  • cx 属性定义圆点的 x 坐标
  • cy 属性定义圆点的 y 坐标
  • rx 属性定义水平半径
  • ry 属性定义垂直半径

查看例子

下面的例子创建了三个累叠而上的椭圆：

<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

<svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<ellipse cx="240" cy="100" rx="220" ry="30"
style="fill:purple"/>

<ellipse cx="220" cy="70" rx="190" ry="20"
style="fill:lime"/>

<ellipse cx="210" cy="45" rx="170" ry="15"
style="fill:yellow"/>

</svg>

查看例子

下面的例子组合了两个椭圆（一个黄的和一个白的）：

<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

<svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<ellipse cx="240" cy="100" rx="220" ry="30"
style="fill:yellow"/>

<ellipse cx="220" cy="100" rx="190" ry="20"
style="fill:white"/>

</svg>

查看例子

  • Previous Page
  • Next Page

SVG 参考手册
SVG 实例


SVG <line>

SVG 基础

  • SVG 首页
  • SVG 简介
  • SVG 实例
  • SVG in HTML

SVG 形状

  • SVG 矩形
  • SVG 圆形
  • SVG 椭圆
  • SVG 线条
  • SVG 多边形
  • SVG 折线
  • SVG 路径

SVG 滤镜

  • SVG 滤镜简介
  • SVG 高斯滤镜

SVG 渐变

  • SVG 线形渐变
  • SVG 放射渐变

SVG 实例

  • SVG 实例

SVG 参考

  • SVG 元素

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SVG <line>

  • Previous Page
  • Next Page

<line> 标签用来创建线条。

<line> 标签

<line> 标签用来创建线条。

请把下面的代码拷贝到记事本，然后把文件保存为 "line1.svg"。把此文件放入您的 web 目录：

<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

<svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<line x1="0" y1="0" x2="300" y2="300"
style="stroke:rgb(99,99,99);stroke-width:2"/>

</svg>

代码解释：

  • x1 属性在 x 轴定义线条的开始
  • y1 属性在 y 轴定义线条的开始
  • x2 属性在 x 轴定义线条的结束
  • y2 属性在 y 轴定义线条的结束

查看例子

  • Previous Page
  • Next Page

SVG 参考手册
SVG 实例


SVG <path>

SVG 基础

  • SVG 首页
  • SVG 简介
  • SVG 实例
  • SVG in HTML

SVG 形状

  • SVG 矩形
  • SVG 圆形
  • SVG 椭圆
  • SVG 线条
  • SVG 多边形
  • SVG 折线
  • SVG 路径

SVG 滤镜

  • SVG 滤镜简介
  • SVG 高斯滤镜

SVG 渐变

  • SVG 线形渐变
  • SVG 放射渐变

SVG 实例

  • SVG 实例

SVG 参考

  • SVG 元素

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SVG <path>

  • Previous Page
  • Next Page

<path> 标签用来定义路径。

<path> 标签

<path> 标签用来定义路径。

下面的命令可用于路径数据：

  • M = moveto
  • L = lineto
  • H = horizontal lineto
  • V = vertical lineto
  • C = curveto
  • S = smooth curveto
  • Q = quadratic Belzier curve
  • T = smooth quadratic Belzier curveto
  • A = elliptical Arc
  • Z = closepath

注释：以上所有命令均允许小写字母。大写表示绝对定位，小写表示相对定位。

请把下面的代码拷贝到记事本，然后把文件保存为 "path1.svg"。把此文件放入您的 web 目录：

<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

<svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<path d="M250 150 L150 350 L350 350 Z" />

</svg>

上面的例子定义了一条路径，它开始于位置 250 150，到达位置 150 350，然后从那里开始到 350 350，最后在 250 150 关闭路径。

查看例子

下面的例子创建了一个螺旋：

<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

<svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<path d="M153 334
C153 334 151 334 151 334
C151 339 153 344 156 344
C164 344 171 339 171 334
C171 322 164 314 156 314
C142 314 131 322 131 334
C131 350 142 364 156 364
C175 364 191 350 191 334
C191 311 175 294 156 294
C131 294 111 311 111 334
C111 361 131 384 156 384
C186 384 211 361 211 334
C211 300 186 274 156 274"
style="fill:white;stroke:red;stroke-width:2"/>

</svg>

查看例子

很复杂吧？是的！！！由于绘制路径的复杂性，因此强烈建议您使用 SVG 编辑器来创建复杂的图形。

  • Previous Page
  • Next Page

SVG 参考手册
SVG 实例


SVG <polygon>

SVG 基础

  • SVG 首页
  • SVG 简介
  • SVG 实例
  • SVG in HTML

SVG 形状

  • SVG 矩形
  • SVG 圆形
  • SVG 椭圆
  • SVG 线条
  • SVG 多边形
  • SVG 折线
  • SVG 路径

SVG 滤镜

  • SVG 滤镜简介
  • SVG 高斯滤镜

SVG 渐变

  • SVG 线形渐变
  • SVG 放射渐变

SVG 实例

  • SVG 实例

SVG 参考

  • SVG 元素

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SVG <polygon>

  • Previous Page
  • Next Page

<polygon> 标签用来创建含有不少于三个边的图形。

<polygon> 标签

<polygon> 标签用来创建含有不少于三个边的图形。

请把下面的代码拷贝到记事本，然后把文件保存为 "polygon1.svg"。把此文件放入您的 web 目录：

<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

<svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<polygon points="220,100 300,210 170,250"
style="fill:#cccccc;
stroke:#000000;stroke-width:1"/>

</svg>

代码解释：

points 属性定义多边形每个角的 x 和 y 坐标

查看例子

下面的例子创建一个四边形：

<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

<svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<polygon points="220,100 300,210 170,250 123,234"
style="fill:#cccccc;
stroke:#000000;stroke-width:1"/>

</svg>

查看例子

  • Previous Page
  • Next Page

SVG 参考手册
SVG 实例


SVG <polyline>

SVG 基础

  • SVG 首页
  • SVG 简介
  • SVG 实例
  • SVG in HTML

SVG 形状

  • SVG 矩形
  • SVG 圆形
  • SVG 椭圆
  • SVG 线条
  • SVG 多边形
  • SVG 折线
  • SVG 路径

SVG 滤镜

  • SVG 滤镜简介
  • SVG 高斯滤镜

SVG 渐变

  • SVG 线形渐变
  • SVG 放射渐变

SVG 实例

  • SVG 实例

SVG 参考

  • SVG 元素

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SVG <polyline>

  • Previous Page
  • Next Page

SVG <polyline> 标签用来创建仅包含直线的形状。

<polyline> 标签

<polyline> 标签用来创建仅包含直线的形状。

请把下面的代码拷贝到记事本，然后把文件保存为 "polyline1.svg"。把此文件放入您的 web 目录：

<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

<svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<polyline points="0,0 0,20 20,20 20,40 40,40 40,60"
style="fill:white;stroke:red;stroke-width:2"/>

</svg>

查看例子

  • Previous Page
  • Next Page

SVG 参考手册
SVG 实例


SVG <rect>

SVG 基础

  • SVG 首页
  • SVG 简介
  • SVG 实例
  • SVG in HTML

SVG 形状

  • SVG 矩形
  • SVG 圆形
  • SVG 椭圆
  • SVG 线条
  • SVG 多边形
  • SVG 折线
  • SVG 路径

SVG 滤镜

  • SVG 滤镜简介
  • SVG 高斯滤镜

SVG 渐变

  • SVG 线形渐变
  • SVG 放射渐变

SVG 实例

  • SVG 实例

SVG 参考

  • SVG 元素

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SVG <rect>

  • Previous Page
  • Next Page

SVG 有一些预定义的形状元素，可被开发者使用和操作。

SVG 形状

SVG 有一些预定义的形状元素，可被开发者使用和操作：

  • 矩形 <rect>
  • 圆形 <circle>
  • 椭圆 <ellipse>
  • 线 <line>
  • 折线 <polyline>
  • 多边形 <polygon>
  • 路径 <path>

下面的章节会为您讲解这些元素，首先从矩形元素开始。

<rect> 标签

<rect> 标签可用来创建矩形，以及矩形的变种。

要理解它的工作原理，请把这些代码拷贝到记事本，然后保存为 "rect1.svg" 文件。把此文件放入web目录中：

<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

<svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<rect width="300" height="100"
style="fill:rgb(0,0,255);stroke-width:1;
stroke:rgb(0,0,0)"/>

</svg>

代码解释：

  • rect 元素的 width 和 height 属性可定义矩形的高度和宽度
  • style 属性用来定义 CSS 属性
  • CSS 的 fill 属性定义矩形的填充颜色（rgb 值、颜色名或者十六进制值）
  • CSS 的 stroke-width 属性定义矩形边框的宽度
  • CSS 的 stroke 属性定义矩形边框的颜色

查看此例

让我们看一下另一个包含新属性的例子：

<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

<svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<rect x="20" y="20" width="250" height="250"
style="fill:blue;stroke:pink;stroke-width:5;
fill-opacity:0.1;stroke-opacity:0.9"/>

</svg>

例子解释：

  • x 属性定义矩形的左侧位置（例如，x="0" 定义矩形到浏览器窗口左侧的距离是 0px）
  • y 属性定义矩形的顶端位置（例如，y="0" 定义矩形到浏览器窗口顶端的距离是 0px）
  • CSS 的 fill-opacity 属性定义填充颜色透明度（合法的范围是：0 - 1）
  • CSS 的 stroke-opacity 属性定义笔触颜色的透明度（合法的范围是：0 - 1）

查看例子

为整个元素定义透明度：

<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

<svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<rect x="20" y="20" width="250" height="250"
style="fill:blue;stroke:pink;stroke-width:5;
opacity:0.9"/>

</svg>

代码解释：

CSS 的 opacity 属性定义整个元素的透明值（合法的范围是：0 - 1）

查看例子

最后的例子，创建带有圆角的矩形：

<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

<svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<rect x="20" y="20" rx="20" ry="20" width="250"
height="100" style="fill:red;stroke:black;
stroke-width:5;opacity:0.5"/>

</svg>

代码解释：

rx 和 ry 属性可使矩形产生圆角。

查看例子

  • Previous Page
  • Next Page

SVG 参考手册
SVG 实例


SVG 参考手册

SVG 基础

  • SVG 首页
  • SVG 简介
  • SVG 实例
  • SVG in HTML

SVG 形状

  • SVG 矩形
  • SVG 圆形
  • SVG 椭圆
  • SVG 线条
  • SVG 多边形
  • SVG 折线
  • SVG 路径

SVG 滤镜

  • SVG 滤镜简介
  • SVG 高斯滤镜

SVG 渐变

  • SVG 线形渐变
  • SVG 放射渐变

SVG 实例

  • SVG 实例

SVG 参考

  • SVG 元素

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SVG 参考手册

  • Previous Page
  • Next Page

来自 W3C 推荐标准 (SVG Version 1.1) 的 SVG 元素

SVG 元素

元素列中的链接指向了具体元素的相关属性和更多有用的信息。

元素 | 描述
a | 定义超链接
altGlyph | 允许对象性文字进行控制，来呈现特殊的字符数据（例如，音乐符号或亚洲的文字）
altGlyphDef | 定义一系列象性符号的替换（例如，音乐符号或者亚洲文字）
altGlyphItem | 定义一系列候选的象性符号的替换
animate | 随时间动态改变属性
animateColor | 规定随时间进行的颜色转换
animateMotion | 使元素沿着动作路径移动
animateTransform | 对元素进行动态的属性转换
circle | 定义圆
clipPath |
color-profile | 规定颜色配置描述
cursor | 定义独立于平台的光标
definition-src | 定义单独的字体定义源
defs | 被引用元素的容器
desc | 对 SVG 中的元素的纯文本描述 - 并不作为图形的一部分来显示。用户代理会将其显示为工具提示。
ellipse | 定义椭圆
feBlend | SVG 滤镜。使用不同的混合模式把两个对象合成在一起。
feColorMatrix | SVG 滤镜。应用matrix转换。
feComponentTransfer | SVG 滤镜。执行数据的 component-wise 重映射。
feComposite | SVG 滤镜。
feConvolveMatrix | SVG 滤镜。
feDiffuseLighting | SVG 滤镜。
feDisplacementMap | SVG 滤镜。
feDistantLight | SVG 滤镜。 Defines a light source
feFlood | SVG 滤镜。
feFuncA | SVG 滤镜。feComponentTransfer 的子元素。
feFuncB | SVG 滤镜。feComponentTransfer 的子元素。
feFuncG | SVG 滤镜。feComponentTransfer 的子元素。
feFuncR | SVG 滤镜。feComponentTransfer 的子元素。
feGaussianBlur | SVG 滤镜。对图像执行高斯模糊。
feImage | SVG 滤镜。
feMerge | SVG 滤镜。创建累积而上的图像。
feMergeNode | SVG 滤镜。feMerge的子元素。
feMorphology | SVG 滤镜。 对源图形执行"fattening" 或者 "thinning"。
feOffset | SVG 滤镜。相对与图形的当前位置来移动图像。
fePointLight | SVG 滤镜。
feSpecularLighting | SVG 滤镜。
feSpotLight | SVG 滤镜。
feTile | SVG 滤镜。
feTurbulence | SVG 滤镜。
filter | 滤镜效果的容器。
font | 定义字体。
font-face | 描述某字体的特点。
font-face-format |
font-face-name |
font-face-src |
font-face-uri |
foreignObject |
g | 用于把相关元素进行组合的容器元素。
glyph | 为给定的象形符号定义图形。
glyphRef | 定义要使用的可能的象形符号。
hkern |
image |
line | 定义线条。
linearGradient | 定义线性渐变。
marker |
mask |
metadata | 规定元数据。
missing-glyph |
mpath |
path | 定义路径。
pattern |
polygon | 定义由一系列连接的直线组成的封闭形状。
polyline | 定义一系列连接的直线。
radialGradient | 定义放射形的渐变。
rect | 定义矩形。
script | 脚本容器。（例如ECMAScript）
set | 为指定持续时间的属性设置值
stop |
style | 可使样式表直接嵌入SVG内容内部。
svg | 定义SVG文档片断。
switch |
symbol |
text |
textPath |
title | 对 SVG 中的元素的纯文本描述 - 并不作为图形的一部分来显示。用户代理会将其显示为工具提示。
tref |
tspan |
use |
view |
vkern |
  • Previous Page
  • Next Page

SVG 参考手册
SVG 实例


SVG 放射性渐变

SVG 基础

  • SVG 首页
  • SVG 简介
  • SVG 实例
  • SVG in HTML

SVG 形状

  • SVG 矩形
  • SVG 圆形
  • SVG 椭圆
  • SVG 线条
  • SVG 多边形
  • SVG 折线
  • SVG 路径

SVG 滤镜

  • SVG 滤镜简介
  • SVG 高斯滤镜

SVG 渐变

  • SVG 线形渐变
  • SVG 放射渐变

SVG 实例

  • SVG 实例

SVG 参考

  • SVG 元素

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SVG 放射性渐变

  • Previous Page
  • Next Page

SVG 渐变必须在 <defs> 标签中进行定义。

放射性渐变

<radialGradient> 用来定义放射性渐变。

<radialGradient> 标签必须嵌套在 <defs> 中。<defs> 标签是 definitions 的缩写，它允许对诸如渐变等特殊元素进行定义。

请把下面的代码拷贝到记事本，然后把文件保存为 "radial1.svg"。把此文件放入您的 web 目录：

<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

<svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<defs>
<radialGradient id="grey_blue" cx="50%" cy="50%" r="50%"
fx="50%" fy="50%">
<stop offset="0%" style="stop-color:rgb(200,200,200);
stop-opacity:0"/>
<stop offset="100%" style="stop-color:rgb(0,0,255);
stop-opacity:1"/>
</radialGradient>
</defs>

<ellipse cx="230" cy="200" rx="110" ry="100"
style="fill:url(#grey_blue)"/>

</svg>

代码解释：

<radialGradient> 标签的 id 属性可为渐变定义一个唯一的名称，fill:url(#grey_blue) 属性把 ellipse 元素链接到此渐变，cx、cy 和 r 属性定义外圈，而 fx 和 fy 定义内圈 渐变的颜色范围可由两种或多种颜色组成。每种颜色通过一个 <stop> 标签来规定。offset 属性用来定义渐变的开始和结束位置。

查看例子

另一个例子：

<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

<svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<defs>
<radialGradient id="grey_blue" cx="20%" cy="40%" r="50%"
fx="50%" fy="50%">
<stop offset="0%" style="stop-color:rgb(200,200,200);
stop-opacity:0"/>
<stop offset="100%" style="stop-color:rgb(0,0,255);
stop-opacity:1"/>
</radialGradient>
</defs>

<ellipse cx="230" cy="200" rx="110" ry="100"
style="fill:url(#grey_blue)"/>

</svg>

查看例子

  • Previous Page
  • Next Page

SVG 参考手册
SVG 实例


SVG 高斯模糊

SVG 基础

  • SVG 首页
  • SVG 简介
  • SVG 实例
  • SVG in HTML

SVG 形状

  • SVG 矩形
  • SVG 圆形
  • SVG 椭圆
  • SVG 线条
  • SVG 多边形
  • SVG 折线
  • SVG 路径

SVG 滤镜

  • SVG 滤镜简介
  • SVG 高斯滤镜

SVG 渐变

  • SVG 线形渐变
  • SVG 放射渐变

SVG 实例

  • SVG 实例

SVG 参考

  • SVG 元素

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SVG 高斯模糊

  • Previous Page
  • Next Page

必须在 <defs> 标签中定义 SVG 滤镜。

高斯模糊（Gaussian Blur）

<filter> 标签用来定义 SVG 滤镜。<filter> 标签使用必需的 id 属性来定义向图形应用哪个滤镜？

<filter> 标签必须嵌套在 <defs> 标签内。<defs> 标签是 definitions 的缩写，它允许对诸如滤镜等特殊元素进行定义。

请把下面的代码拷贝到记事本，然后把文件保存为 "filter1.svg"。把此文件放入您的 web 目录：

<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

<svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<defs>
<filter id="Gaussian_Blur">
<feGaussianBlur in="SourceGraphic" stdDeviation="3" />
</filter>
</defs>

<ellipse cx="200" cy="150" rx="70" ry="40"
style="fill:#ff0000;stroke:#000000;
stroke-width:2;filter:url(#Gaussian_Blur)"/>

</svg>

代码解释：

  • <filter> 标签的 id 属性可为滤镜定义一个唯一的名称（同一滤镜可被文档中的多个元素使用）
  • filter:url 属性用来把元素链接到滤镜。当链接滤镜 id 时，必须使用 # 字符
  • 滤镜效果是通过 <feGaussianBlur> 标签进行定义的。fe 后缀可用于所有的滤镜
  • <feGaussianBlur> 标签的 stdDeviation 属性可定义模糊的程度
  • in="SourceGraphic" 这个部分定义了由整个图像创建效果

查看例子

另一个 stdDeviation 值不同的例子

<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

<svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<defs>
<filter id="Gaussian_Blur">
<feGaussianBlur in="SourceGraphic" stdDeviation="20"/>
</filter>
</defs>

<ellipse cx="200" cy="150" rx="70" ry="40"
style="fill:#ff0000;stroke:#000000;
stroke-width:2;filter:url(#Gaussian_Blur)"/>

</svg>

查看例子

  • Previous Page
  • Next Page

SVG 参考手册
SVG 实例


SVG 简介

SVG 基础

  • SVG 首页
  • SVG 简介
  • SVG 实例
  • SVG in HTML

SVG 形状

  • SVG 矩形
  • SVG 圆形
  • SVG 椭圆
  • SVG 线条
  • SVG 多边形
  • SVG 折线
  • SVG 路径

SVG 滤镜

  • SVG 滤镜简介
  • SVG 高斯滤镜

SVG 渐变

  • SVG 线形渐变
  • SVG 放射渐变

SVG 实例

  • SVG 实例

SVG 参考

  • SVG 元素

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SVG 简介

  • Previous Page
  • Next Page

SVG 是使用 XML 来描述二维图形和绘图程序的语言。

学习之前应具备的基础知识：

继续学习之前，你应该对以下内容有基本的了解：

  • HTML
  • XML 基础

如果希望首先学习这些内容，请在本站的首页选择相应的教程。

什么是SVG？

  • SVG 指可伸缩矢量图形 (Scalable Vector Graphics)
  • SVG 用来定义用于网络的基于矢量的图形
  • SVG 使用 XML 格式定义图形
  • SVG 图像在放大或改变尺寸的情况下其图形质量不会有所损失
  • SVG 是万维网联盟的标准
  • SVG 与诸如 DOM 和 XSL 之类的 W3C 标准是一个整体

SVG 的历史和优势

在 2003 年一月，SVG 1.1 被确立为 W3C 标准。

参与定义 SVG 的组织有：太阳微系统、Adobe、苹果公司、IBM 以及柯达。

与其他图像格式相比，使用 SVG 的优势在于：

  • SVG 可被非常多的工具读取和修改（比如记事本）
  • SVG 与 JPEG 和 GIF 图像比起来，尺寸更小，且可压缩性更强。
  • SVG 是可伸缩的
  • SVG 图像可在任何的分辨率下被高质量地打印
  • SVG 可在图像质量不下降的情况下被放大
  • SVG 图像中的文本是可选的，同时也是可搜索的（很适合制作地图）
  • SVG 可以与 Java 技术一起运行
  • SVG 是开放的标准
  • SVG 文件是纯粹的 XML

SVG 的主要竞争者是 Flash。

与 Flash 相比，SVG 最大的优势是与其他标准（比如 XSL 和 DOM）相兼容。而 Flash 则是未开源的私有技术。

目前，不是所有的浏览器都支持 SVG，这也是 SVG 普及的最大障碍。Mozilla、Firefox 和 Opera 都支持 SVG，而微软也计划这么做。

SVG 编辑器的数量正在增长，Adobe GoLive 5 也支持 SVG。

查看支持 SVG 的软件和服务

目前，只有安装插件（比如 Adobe SVG Viewer）才能查看 SVG 文件。

查看 SVG 文件

如果你使用的浏览器不支持 SVG 文件，就需要下载并安装 SVG 查看器。

注意：Firefox 1.5 和 Opera 9 天生就支持 SVG。如果你使用这些浏览器中任何的一款，那么恭喜你，你不需要下载 SVG 查看器了。

从 Adobe 下载免费的 SVG 查看器。

  • Previous Page
  • Next Page

SVG 参考手册
SVG 实例


SVG 教程

SVG 基础

  • SVG 首页
  • SVG 简介
  • SVG 实例
  • SVG in HTML

SVG 形状

  • SVG 矩形
  • SVG 圆形
  • SVG 椭圆
  • SVG 线条
  • SVG 多边形
  • SVG 折线
  • SVG 路径

SVG 滤镜

  • SVG 滤镜简介
  • SVG 高斯滤镜

SVG 渐变

  • SVG 线形渐变
  • SVG 放射渐变

SVG 实例

  • SVG 实例

SVG 参考

  • SVG 元素

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SVG 教程

  • Next Page

SVG 意为可缩放矢量图形（Scalable Vector Graphics）。

SVG 使用 XML 格式定义图像。

在我们的 SVG 教程中，你将学习 SVG 的相关知识。

开始学习 SVG ！

SVG 实例

通过实例学习 SVG ！

SVG 实例

SVG 参考手册

在 W3School，我们为您提供完整的 SVG 参考手册，其中列出了所有 W3C 推荐标准（SVG Version 1.1）中的 SVG 的元素。

SVG 参考手册

  • Next Page

SVG 参考手册
SVG 实例


SVG 滤镜

SVG 基础

  • SVG 首页
  • SVG 简介
  • SVG 实例
  • SVG in HTML

SVG 形状

  • SVG 矩形
  • SVG 圆形
  • SVG 椭圆
  • SVG 线条
  • SVG 多边形
  • SVG 折线
  • SVG 路径

SVG 滤镜

  • SVG 滤镜简介
  • SVG 高斯滤镜

SVG 渐变

  • SVG 线形渐变
  • SVG 放射渐变

SVG 实例

  • SVG 实例

SVG 参考

  • SVG 元素

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SVG 滤镜

  • Previous Page
  • Next Page

SVG 滤镜用来向形状和文本添加特殊的效果。

SVG 滤镜

在 SVG 中，可用的滤镜有：

  • feBlend
  • feColorMatrix
  • feComponentTransfer
  • feComposite
  • feConvolveMatrix
  • feDiffuseLighting
  • feDisplacementMap
  • feFlood
  • feGaussianBlur
  • feImage
  • feMerge
  • feMorphology
  • feOffset
  • feSpecularLighting
  • feTile
  • feTurbulence
  • feDistantLight
  • fePointLight
  • feSpotLight

注释：您可以在每个 SVG 元素上使用多个滤镜！

  • Previous Page
  • Next Page

SVG 参考手册
SVG 实例


SVG 实例

SVG 基础

  • SVG 首页
  • SVG 简介
  • SVG 实例
  • SVG in HTML

SVG 形状

  • SVG 矩形
  • SVG 圆形
  • SVG 椭圆
  • SVG 线条
  • SVG 多边形
  • SVG 折线
  • SVG 路径

SVG 滤镜

  • SVG 滤镜简介
  • SVG 高斯滤镜

SVG 渐变

  • SVG 线形渐变
  • SVG 放射渐变

SVG 实例

  • SVG 实例

SVG 参考

  • SVG 元素

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SVG 实例

  • Previous Page
  • Next Page

查看 SVG 文件

如果没有安装 SVG 查看器，您就无法查看 SVG 文件。

注释：Firefox 1.5 和 Opera 9 对 SVG 的支持是原生性的。假如您使用这些浏览器中的一款，就不必安装 SVG 查看器。

从 Adobe 免费下载 SVG 查看器。

查看 SVG 源代码

如需查看 SVG 源代码，请打开这些例子，然后在窗口中右键单击，选择“查看源代码”。

SVG 实例

SVG 形状

矩形
带有透明度的矩形
带有透明度的矩形 2
带有圆角的矩形
圆形
椭圆形
累叠而上的三个椭圆
两个椭圆
一条线
三角形
四边形
折线
路径
螺旋

SVG 滤镜

feGaussianBlur 滤镜
另一个feGaussianBlur 滤镜
feBlend 滤镜
feColorMatrix 滤镜
feComponentTransfer 滤镜
feOffset 滤镜
feOffset、feFlood、feComposite、feMerge 以及 feMergeNode
feMorphology 滤镜
滤镜 1
滤镜 2
滤镜 3
滤镜 4
滤镜 5
滤镜 6

SVG 渐变

线形渐变 (水平渐变)
线形渐变 (垂直渐变)
放射性渐变
放射性渐变 2

SVG Misc

向矩形添加一个 "a" 元素，这样矩形就可以作为一个超级链接了。
当用户在圆上面点击时，使用 JavaScript 创建一个元素。
重复用 5 秒时间淡出的矩形
动态改变矩形的 x、y 以及 width、height 属性来创造出动画效果，并改变矩形的颜色
会改变颜色的三个矩形
沿一个运动路径移动的文本
沿一个运动路径移动、旋转并缩放的文本
沿一个运动路径移动、旋转并缩放的文本 + 逐步放大并改变颜色的矩形
  • Previous Page
  • Next Page

SVG 参考手册
SVG 实例


SVG 线形渐变

SVG 基础

  • SVG 首页
  • SVG 简介
  • SVG 实例
  • SVG in HTML

SVG 形状

  • SVG 矩形
  • SVG 圆形
  • SVG 椭圆
  • SVG 线条
  • SVG 多边形
  • SVG 折线
  • SVG 路径

SVG 滤镜

  • SVG 滤镜简介
  • SVG 高斯滤镜

SVG 渐变

  • SVG 线形渐变
  • SVG 放射渐变

SVG 实例

  • SVG 实例

SVG 参考

  • SVG 元素

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SVG 线形渐变

  • Previous Page
  • Next Page

SVG 渐变必须在 <defs> 标签中进行定义。

SVG 渐变

渐变是一种从一种颜色到另一种颜色的平滑过渡。另外，可以把多个颜色的过渡应用到同一个元素上。

在 SVG 中，有两种主要的渐变类型：

  • 线性渐变
  • 放射性渐变

线性渐变

<linearGradient> 可用来定义 SVG 的线性渐变。

<linearGradient> 标签必须嵌套在 <defs> 的内部。<defs> 标签是 definitions 的缩写，它可对诸如渐变之类的特殊元素进行定义。

线性渐变可被定义为水平、垂直或角形的渐变：

  • 当 y1 和 y2 相等，而 x1 和 x2 不同时，可创建水平渐变
  • 当 x1 和 x2 相等，而 y1 和 y2 不同时，可创建垂直渐变
  • 当 x1 和 x2 不同，且 y1 和 y2 不同时，可创建角形渐变

请把下面的代码拷贝到记事本，然后把文件保存为 "linear1.svg"。把此文件放入您的 web 目录：

<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

<svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<defs>
<linearGradient id="orange_red" x1="0%" y1="0%" x2="100%" y2="0%">
<stop offset="0%" style="stop-color:rgb(255,255,0);
stop-opacity:1"/>
<stop offset="100%" style="stop-color:rgb(255,0,0);
stop-opacity:1"/>
</linearGradient>
</defs>

<ellipse cx="200" cy="190" rx="85" ry="55"
style="fill:url(#orange_red)"/>

</svg>

代码解释：

  • <linearGradient> 标签的 id 属性可为渐变定义一个唯一的名称
  • fill:url(#orange_red) 属性把 ellipse 元素链接到此渐变
  • <linearGradient> 标签的 x1、x2、y1、y2 属性可定义渐变的开始和结束位置
  • 渐变的颜色范围可由两种或多种颜色组成。每种颜色通过一个 <stop> 标签来规定。offset 属性用来定义渐变的开始和结束位置。

查看例子 （水平渐变）

另一个例子：

<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

<svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<defs>
<linearGradient id="orange_red" x1="0%" y1="0%" x2="0%" y2="100%">
<stop offset="0%" style="stop-color:rgb(255,255,0);
stop-opacity:1"/>
<stop offset="100%" style="stop-color:rgb(255,0,0);
stop-opacity:1"/>
</linearGradient>
</defs>

<ellipse cx="200" cy="190" rx="85" ry="55"
style="fill:url(#orange_red)"/>

</svg>

查看例子 （垂直渐变）

  • Previous Page
  • Next Page

SVG 参考手册
SVG 实例


SVG 一个例子

SVG 基础

  • SVG 首页
  • SVG 简介
  • SVG 实例
  • SVG in HTML

SVG 形状

  • SVG 矩形
  • SVG 圆形
  • SVG 椭圆
  • SVG 线条
  • SVG 多边形
  • SVG 折线
  • SVG 路径

SVG 滤镜

  • SVG 滤镜简介
  • SVG 高斯滤镜

SVG 渐变

  • SVG 线形渐变
  • SVG 放射渐变

SVG 实例

  • SVG 实例

SVG 参考

  • SVG 元素

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SVG 一个例子

  • Previous Page
  • Next Page

SVG 使用 XML 编写。

SVG 实例

下面的例子是一个简单的 SVG 文件的例子。SVG 文件必须使用 .svg 后缀来保存：

<?xml version="1.0" standalone="no"?>

<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

<svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<circle cx="100" cy="50" r="40" stroke="black"
stroke-width="2" fill="red"/>

</svg>

查看例子（仅用于支持 SVG 的浏览器）

（如需查看 SVG 源代码，请打开此例，然后在窗口中右击。选择“查看源代码”。）

代码解释：

第一行包含了 XML 声明。请注意 standalone 属性！该属性规定此 SVG 文件是否是“独立的”，或含有对外部文件的引用。

standalone="no" 意味着 SVG 文档会引用一个外部文件 - 在这里，是 DTD 文件。

第二和第三行引用了这个外部的 SVG DTD。该 DTD 位于 “http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd”。该 DTD 位于 W3C，含有所有允许的 SVG 元素。

SVG 代码以 <svg> 元素开始，包括开启标签 <svg> 和关闭标签 </svg> 。这是根元素。width 和 height 属性可设置此 SVG 文档的宽度和高度。version 属性可定义所使用的 SVG 版本，xmlns 属性可定义 SVG 命名空间。

SVG 的 <circle> 用来创建一个圆。cx 和 cy 属性定义圆中心的 x 和 y 坐标。如果忽略这两个属性，那么圆点会被设置为 (0, 0)。r 属性定义圆的半径。

stroke 和 stroke-width 属性控制如何显示形状的轮廓。我们把圆的轮廓设置为 2px 宽，黑边框。

fill 属性设置形状内的颜色。我们把填充颜色设置为红色。

关闭标签的作用是关闭 SVG 元素和文档本身。

注释：所有的开启标签必须有关闭标签！

  • Previous Page
  • Next Page

SVG 参考手册
SVG 实例


HTML 4.01 / XHTML 1.0 参考手册

参考手册

  • 标签列表（字母排序）
  • 标签列表（功能排序）
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML Latin-1
  • HTML 符号
  • HTML URL 编码
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 4.01 / XHTML 1.0 参考手册

  • Next Page

按字母顺序列出的HTML 4.01/XHTML 1.0标签手册

  • NN：显示所支持标签的 Netscape 最早版本
  • IE：显示所支持标签的 Internet Explorer 最早版本
  • DTD：显示在哪一种 XHTML 1.0 DTD 中，标签是被允许的。S=Strict,T=Transitional,F=Frameset.
标签 | 描述 | NN | IE | DTD
<!--...--> | 定义注释。 | 3.0 | 3.0 | STF
<!DOCTYPE> | 定义文档类型。 |  |  | STF
<a> | 定义锚。 | 3.0 | 3.0 | STF
<abbr> | 定义缩写。 | 6.2 |  | STF
<acronym> | 定义只取首字母的缩写。 | 6.2 | 4.0 | STF
<address> | 定义地址元素。 | 4.0 | 4.0 | STF
<applet> | 不赞成使用。定义 applet。 | 2.0 | 3.0 | TF
<area> | 定义图像映射内部的区域。 | 3.0 | 3.0 | STF
<b> | 定义粗体字。 | 3.0 | 3.0 | STF
<base> | 定义页面当中的所有链接的基准链接。 | 3.0 | 3.0 | STF
<basefont> | 不赞成使用。定义基准字体。 | 3.0 | 3.0 | TF
<bdo> | 定义文字显示的方向。 | 6.2 | 5.0 | STF
<big> | 定义大号字。 | 3.0 | 3.0 | STF
<blockquote> | 定义长的引用。 | 3.0 | 3.0 | STF
<body> | 定义 body 元素。 | 3.0 | 3.0 | STF
<br> | 插入一个回车（折行）。 | 3.0 | 3.0 | STF
<button> | 定义按钮 (push button)。 | 6.2 | 4.0 | STF
<caption> | 定义表格标题。 | 3.0 | 3.0 | STF
<center> | 不赞成使用。定义居中文本。 | 3.0 | 3.0 | TF
<cite> | 定义引用(citation)。 | 3.0 | 3.0 | STF
<code> | 定义计算机代码文本。 | 3.0 | 3.0 | STF
<col> | 定义用于表格列的属性。 |  | 3.0 | STF
<colgroup> | 定义表格的列组。 |  | 3.0 | STF
<dd> | 定义定义的描述。 | 3.0 | 3.0 | STF
<del> | 定义被删除文本。 | 6.2 | 4.0 | STF
<dir> | 不赞成使用。定义目录列表。 | 3.0 | 3.0 | TF
<div> | 定义文档中的节。 | 3.0 | 3.0 | STF
<dfn> | 定义定义的项目。 |  | 3.0 | STF
<dl> | 定义定义列表。 | 3.0 | 3.0 | STF
<dt> | 定义定义的项目。 | 3.0 | 3.0 | STF
<em> | 定义强调文本。 | 3.0 | 3.0 | STF
<fieldset> | 定义域结构。 | 6.2 | 4.0 | STF
<font> | 不赞成使用。定义文字的字体、尺寸和颜色。 | 3.0 | 3.0 | TF
<form> | 定义表单。 | 3.0 | 3.0 | STF
<frame> | 定义框架的子窗口。 | 3.0 | 3.0 | F
<frameset> | 定义框架集。 | 3.0 | 3.0 | F
<h1> to <h6> | 定义标题 1 到标题 6。 | 3.0 | 3.0 | STF
<head> | 定义关于文档的信息。 | 3.0 | 3.0 | STF
<hr> | 定义水平线。 | 3.0 | 3.0 | STF
<html> | 定义 html 文档。 | 3.0 | 3.0 | STF
<i> | 定义斜体字。 | 3.0 | 3.0 | STF
<iframe> | 定义内联框架。 | 6.0 | 4.0 | TF
<img> | 定义图像。 | 3.0 | 3.0 | STF
<input> | 定义输入域。 | 3.0 | 3.0 | STF
<ins> | 定义被插入文本。 | 6.2 | 4.0 | STF
<isindex> | 不赞成使用。定义单行的输入域。 | 3.0 | 3.0 | TF
<kbd> | 定义键盘文本。 | 3.0 | 3.0 | STF
<label> | 定义针对表单控件的标签。 | 6.2 | 4.0 | STF
<legend> | 定义框架集的标题。 | 6.2 | 4.0 | STF
<li> | 定义列表的项目。 | 3.0 | 3.0 | STF
<link> | 定义资源引用(resource reference)。 | 4.0 | 3.0 | STF
<map> | 定义图像映射。 | 3.0 | 3.0 | STF
<menu> | 不赞成使用。定义菜单列表。 | 3.0 | 3.0 | TF
<meta> | 定义元信息。 | 3.0 | 3.0 | STF
<noframes> | 定义无框架的节。 | 3.0 | 3.0 | TF
<noscript> | 定义无脚本的节。 | 3.0 | 3.0 | STF
<object> | 定义内嵌对象。 |  | 3.0 | STF
<ol> | 定义有序列表。 | 3.0 | 3.0 | STF
<optgroup> | 定义选项组。 | 6.0 | 6.0 | STF
<option> | 定义下拉列表中的选项。 | 3.0 | 3.0 | STF
<p> | 定义段落。 | 3.0 | 3.0 | STF
<param> | 定义用于对象的参数。 | 3.0 | 3.0 | STF
<pre> | 定义预格式文本。 | 3.0 | 3.0 | STF
<q> | 定义短的引用。 | 6.2 |  | STF
<s> | 不赞成使用。定义加删除线的文本。 | 3.0 | 3.0 | TF
<samp> | 定义计算机代码样本。 | 3.0 | 3.0 | STF
<script> | 定义脚本。 | 3.0 | 3.0 | STF
<select> | 定义选择列表。 | 3.0 | 3.0 | STF
<small> | 定义小字体文本。 | 3.0 | 3.0 | STF
<span> | 定义文档中的节。 | 4.0 | 3.0 | STF
<strike> | 不赞成使用。定义加删除线文本。 | 3.0 | 3.0 | TF
<strong>。 | 定义强调文本。 | 3.0 | 3.0 | STF
<style> | 定义样式的定义。 | 4.0 | 3.0 | STF
<sub> | 定义下标文本。 | 3.0 | 3.0 | STF
<sup> | 定义上标文本。 | 3.0 | 3.0 | STF
<table> | 定义表格。 | 3.0 | 3.0 | STF
<tbody> | 定义表格的主体（部分）。 |  | 4.0 | STF
<td> | 定义表格单元。 | 3.0 | 3.0 | STF
<textarea> | 定义文本区域。 | 3.0 | 3.0 | STF
<tfoot> | 定义表格的页脚（脚注）。 |  | 4.0 | STF
<th> | 定义表格的页眉（表头单元格）。 | 3.0 | 3.0 | STF
<thead> | 定义表格的标题。 |  | 4.0 | STF
<title> | 定义文档的标题。 | 3.0 | 3.0 | STF
<tr> | 定义表格的行。 | 3.0 | 3.0 | STF
<tt> | 定义打字机文本。 | 3.0 | 3.0 | STF
<u> | 不赞成使用。定义下划线文本。 | 3.0 | 3.0 | TF
<ul> | 定义无序列表。 | 3.0 | 3.0 | STF
<var> | 定义变量。 | 3.0 | 3.0 | STF
<xmp> | 不赞成使用。定义预格式文本。 | 3.0 | 3.0 |
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 4.01 / XHTML 1.0 参考手册

参考手册

  • 标签列表（字母排序）
  • 标签列表（功能排序）
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML Latin-1
  • HTML 符号
  • HTML URL 编码
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 4.01 / XHTML 1.0 参考手册

  • Previous Page
  • Next Page

按功能顺序列出的 HTML 4.01/XHTML 1.0 标签手册

  • NN：显示所支持标签的 Netscape 的最早版本。
  • IE：显示所支持标签的 Internet Explorer 的最早版本。
  • DTD：显示在哪一种XHTML 1.0 DTD中，标签是被允许的。S=Strict, T=Transitional, F=Frameset.
基本的标签 | 描述 | NN | IE | DTD
<!DOCTYPE> | 定义文档类型。 |  |  | STF
<html> | 定义 html 文档。 | 3.0 | 3.0 | STF
<body> | 定义 body 元素。 | 3.0 | 3.0 | STF
<h1> to <h6> | 定义标题 1 到标题 6。 | 3.0 | 3.0 | STF
<p> | 定义段落。 | 3.0 | 3.0 | STF
<br> | 插入一个换行。 | 3.0 | 3.0 | STF
<hr> | 定义水平线。 | 3.0 | 3.0 | STF
<!--...--> | 定义注释。 | 3.0 | 3.0 | STF
字符格式化 | 描述 | NN | IE | DTD
<b> | 定义粗体文本。 | 3.0 | 3.0 | STF
<font> | 不赞成使用。定义文字的字体、尺寸和颜色 | 3.0 | 3.0 | TF
<i> | 定义斜体文本。 | 3.0 | 3.0 | STF
<em> | 定义强调文本。 | 3.0 | 3.0 | STF
<big> | 定义大号字体文本。 | 3.0 | 3.0 | STF
<strong> | 定义语气更为强烈的强调文本。 | 3.0 | 3.0 | STF
<small> | 定义小号字体文本。 | 3.0 | 3.0 | STF
<sup> | 定义上标文本。 | 3.0 | 3.0 | STF
<sub> | 定义下标文本。 | 3.0 | 3.0 | STF
<bdo> | 定义文本显示的方向。 | 6.2 | 5.0 | STF
<u> | 不赞成使用。定义下划线文本。 | 3.0 | 3.0 | TF
输出 | 描述 | NN | IE | DTD
<pre> | 定义预格式文本 | 3.0 | 3.0 | STF
<code> | 定义计算机代码文本。 | 3.0 | 3.0 | STF
<tt> | 定义打字机文本。 | 3.0 | 3.0 | STF
<kbd> | 定义键盘文本。 | 3.0 | 3.0 | STF
<var> | 定义变量。 | 3.0 | 3.0 | STF
<dfn> | 定义定义项目。 |  | 3.0 | STF
<samp> | 定义样本文本。 | 3.0 | 3.0 | STF
<xmp> | 不赞成使用。定义预格式文本。 | 3.0 | 3.0 |
块级 | 描述 | NN | IE | DTD
<acronym> | 定义只取首字母的缩写。 | 6.2 | 4.0 | STF
<abbr> | 定义缩写。 | 6.2 |  | STF
<address> | 定义地址元素。 | 4.0 | 4.0 | STF
<blockquote> | 定义块引用。 | 3.0 | 3.0 | STF
<center> | 不赞成使用。定义居中字体。 | 3.0 | 3.0 | TF
<q> | 定义短的引用。 | 6.2 | 4.0 | STF
<cite> | 定义引用(citation)。 | 3.0 | 3.0 | STF
<ins> | 定义被插入文本。 | 6.2 | 4.0 | STF
<del> | 定义被删除文本。 | 6.2 | 4.0 | STF
<s> | 不赞成使用。定义加删除线的文本。 | 3.0 | 3.0 | TF
<strike> | 不赞成使用。定义加删除线的文本。 | 3.0 | 3.0 | TF
链接 | 描述 | NN | IE | DTD
<a> | 定义锚。 | 3.0 | 3.0 | STF
<link> | 定义资源引用(resource reference)。 | 4.0 | 3.0 | STF
框架 | 描述 | NN | IE | DTD
<frame> | 定义框架的子窗口 | 3.0 | 3.0 | F
<frameset> | 定义框架结构 | 3.0 | 3.0 | F
<noframes> | 定义无框架的节 | 3.0 | 3.0 | TF
<iframe> | 定义内联框架 | 6.0 | 4.0 | TF
输入 | 描述 | NN | IE | DTD
<form> | 定义表单。 | 3.0 | 3.0 | STF
<input> | 定义输入域。 | 3.0 | 3.0 | STF
<textarea> | 定义文本输入区。 | 3.0 | 3.0 | STF
<button> | 定义按钮。 | 6.2 | 4.0 | STF
<select> | 定义下拉式菜单。 | 3.0 | 3.0 | STF
<optgroup> | 定义选项分组。 | 6.0 | 6.0 | STF
<option> | 定义下拉列表中的可选项。 | 3.0 | 3.0 | STF
<label> | 为表单元素创建标记。 | 6.2 | 4.0 | STF
<fieldset> | 将表单内的相关元素分组。 | 6.2 | 4.0 | STF
<legend> | 定义框架结构的标题。 | 6.2 | 4.0 | STF
<isindex> | 不赞成使用。定义单行的输入域 | 3.0 | 3.0 | TF
列表 | 描述 | NN | IE | DTD
<ul> | 定义无序列表。 | 3.0 | 3.0 | STF
<ol> | 定义有序列表。 | 3.0 | 3.0 | STF
<li> | 定义列表项目。 | 3.0 | 3.0 | STF
<dir> | 不赞成使用。定义目录列表。 | 3.0 | 3.0 | TF
<dl> | 定义定义列表。 | 3.0 | 3.0 | STF
<dt> | 定义定义项目。 | 3.0 | 3.0 | STF
<dd> | 定义定义描述。 | 3.0 | 3.0 | STF
<menu> | 不赞成使用。定义菜单列表。 | 3.0 | 3.0 | TF
图像 | 描述 | NN | IE | DTD
<img> | 定义图像。 | 3.0 | 3.0 | STF
<map> | 定义图像映射。 | 3.0 | 3.0 | STF
<area> | 定义图像地图内部的区域。 | 3.0 | 3.0 | STF
表格 | 描述 | NN | IE | DTD
<table> | 定义表格 | 3.0 | 3.0 | STF
<caption> | 定义表格标题 | 3.0 | 3.0 | STF
<th> | 定义表格页眉 | 3.0 | 3.0 | STF
<tr> | 定义表格的行 | 3.0 | 3.0 | STF
<td> | 定义表格单元 | 3.0 | 3.0 | STF
<thead> | 定义表格的页眉 |  | 4.0 | STF
<tbody> | 定义表格的主体 |  | 4.0 | STF
<tfoot> | 定义表格的页脚 |  | 4.0 | STF
<col> | 定义用于表格列的属性 |  | 3.0 | STF
<colgroup> | 定义表格列的组 |  | 3.0 | STF
样式 | 描述 | NN | IE | DTD
<style> | 定义样式定义 | 4.0 | 3.0 | STF
<div> | 定义文档中的节 | 3.0 | 3.0 | STF
<span> | 定义文档中的节 | 4.0 | 3.0 | STF
元信息 | 描述 | NN | IE | DTD
<head> | 定义关于文档的信息 | 3.0 | 3.0 | STF
<title> | 定义文档的标题 | 3.0 | 3.0 | STF
<meta> | 定义元信息 | 3.0 | 3.0 | STF
<base> | 定义某个页面当中的所有链接的基准链接 | 3.0 | 3.0 | STF
<basefont> | 不赞成使用。定义基准字体 | 3.0 | 3.0 | TF
Programming | 描述 | NN | IE | DTD
<script> | 定义一段脚本。 | 3.0 | 3.0 | STF
<noscript> | 定义 noscript 部分。 | 3.0 | 3.0 | STF
<applet> | 不赞成使用。定义 applet。 | 2.0 | 3.0 | TF
<object> | 定义嵌入的对象。 |  | 3.0 | STF
<param> | 为对象定义参数。 | 3.0 | 3.0 | STF
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 4.01 符号实体

参考手册

  • 标签列表（字母排序）
  • 标签列表（功能排序）
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML Latin-1
  • HTML 符号
  • HTML URL 编码
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 4.01 符号实体

  • Previous Page
  • Next Page

本字符实体参考手册包括了数学符号、希腊字符、各种箭头记号、科技符号以及形状。

注释：实体名称对大小写敏感。

HTML 支持的数学符号

结果 | 描述 | 实体名称 | 实体编号
∀ | for all | &forall; | &#8704;
∂ | part | &part; | &#8706;
∃ | exists | &exists; | &#8707;
∅ | empty | &empty; | &#8709;
∇ | nabla | &nabla; | &#8711;
∈ | isin | &isin; | &#8712;
∉ | notin | &notin; | &#8713;
∋ | ni | &ni; | &#8715;
∏ | prod | &prod; | &#8719;
∑ | sum | &sum; | &#8721;
− | minus | &minus; | &#8722;
∗ | lowast | &lowast; | &#8727;
√ | square root | &radic; | &#8730;
∝ | proportional to | &prop; | &#8733;
∞ | infinity | &infin; | &#8734;
∠ | angle | &ang; | &#8736;
∧ | and | &and; | &#8743;
∨ | or | &or; | &#8744;
∩ | cap | &cap; | &#8745;
∪ | cup | &cup; | &#8746;
∫ | integral | &int; | &#8747;
∴ | therefore | &there4; | &#8756;
∼ | simular to | &sim; | &#8764;
≅ | approximately equal | &cong; | &#8773;
≈ | almost equal | &asymp; | &#8776;
≠ | not equal | &ne; | &#8800;
≡ | equivalent | &equiv; | &#8801;
≤ | less or equal | &le; | &#8804;
≥ | greater or equal | &ge; | &#8805;
⊂ | subset of | &sub; | &#8834;
⊃ | superset of | &sup; | &#8835;
⊄ | not subset of | &nsub; | &#8836;
⊆ | subset or equal | &sube; | &#8838;
⊇ | superset or equal | &supe; | &#8839;
⊕ | circled plus | &oplus; | &#8853;
⊗ | cirled times | &otimes; | &#8855;
⊥ | perpendicular | &perp; | &#8869;
⋅ | dot operator | &sdot; | &#8901;

HTML 支持的希腊字母

结果 | 描述 | 实体名称 | 实体编号
Α | Alpha | &Alpha; | &#913;
Β | Beta | &Beta; | &#914;
Γ | Gamma | &Gamma; | &#915;
Δ | Delta | &Delta; | &#916;
Ε | Epsilon | &Epsilon; | &#917;
Ζ | Zeta | &Zeta; | &#918;
Η | Eta | &Eta; | &#919;
Θ | Theta | &Theta; | &#920;
Ι | Iota | &Iota; | &#921;
Κ | Kappa | &Kappa; | &#922;
Λ | Lambda | &Lambda; | &#923;
Μ | Mu | &Mu; | &#924;
Ν | Nu | &Nu; | &#925;
Ξ | Xi | &Xi; | &#926;
Ο | Omicron | &Omicron; | &#927;
Π | Pi | &Pi; | &#928;
Ρ | Rho | &Rho; | &#929;
 | Sigmaf |  | undefined
Σ | Sigma | &Sigma; | &#931;
Τ | Tau | &Tau; | &#932;
Υ | Upsilon | &Upsilon; | &#933;
Φ | Phi | &Phi; | &#934;
Χ | Chi | &Chi; | &#935;
Ψ | Psi | &Psi; | &#936;
Ω | Omega | &Omega; | &#937;
α | alpha | &alpha; | &#945;
β | beta | &beta; | &#946;
γ | gamma | &gamma; | &#947;
δ | delta | &delta; | &#948;
ε | epsilon | &epsilon; | &#949;
ζ | zeta | &zeta; | &#950;
η | eta | &eta; | &#951;
θ | theta | &theta; | &#952;
ι | iota | &iota; | &#953;
κ | kappa | &kappa; | &#954;
λ | lambda | &lambda; | &#923;
μ | mu | &mu; | &#956;
ν | nu | &nu; | &#925;
ξ | xi | &xi; | &#958;
ο | omicron | &omicron; | &#959;
π | pi | &pi; | &#960;
ρ | rho | &rho; | &#961;
ς | sigmaf | &sigmaf; | &#962;
σ | sigma | &sigma; | &#963;
τ | tau | &tau; | &#964;
υ | upsilon | &upsilon; | &#965;
φ | phi | &phi; | &#966;
χ | chi | &chi; | &#967;
ψ | psi | &psi; | &#968;
ω | omega | &omega; | &#969;
ϑ | theta symbol | &thetasym; | &#977;
ϒ | upsilon symbol | &upsih; | &#978;
ϖ | pi symbol | &piv; | &#982;

HTML 支持的其他实体

结果 | 描述 | 实体名称 | 实体编号
Œ | capital ligature OE | &OElig; | &#338;
œ | small ligature oe | &oelig; | &#339;
Š | capital S with caron | &Scaron; | &#352;
š | small S with caron | &scaron; | &#353;
Ÿ | capital Y with diaeres | &Yuml; | &#376;
ƒ | f with hook | &fnof; | &#402;
ˆ | modifier letter circumflex accent | &circ; | &#710;
˜ | small tilde | &tilde; | &#732;
 | en space | &ensp; | &#8194;
 | em space | &emsp; | &#8195;
 | thin space | &thinsp; | &#8201;
‌ | zero width non-joiner | &zwnj; | &#8204;
‍ | zero width joiner | &zwj; | &#8205;
‎ | left-to-right mark | &lrm; | &#8206;
‏ | right-to-left mark | &rlm; | &#8207;
– | en dash | &ndash; | &#8211;
— | em dash | &mdash; | &#8212;
‘ | left single quotation mark | &lsquo; | &#8216;
’ | right single quotation mark | &rsquo; | &#8217;
‚ | single low-9 quotation mark | &sbquo; | &#8218;
“ | left double quotation mark | &ldquo; | &#8220;
” | right double quotation mark | &rdquo; | &#8221;
„ | double low-9 quotation mark | &bdquo; | &#8222;
† | dagger | &dagger; | &#8224;
‡ | double dagger | &Dagger; | &#8225;
• | bullet | &bull; | &#8226;
… | horizontal ellipsis | &hellip; | &#8230;
‰ | per mille | &permil; | &#8240;
′ | minutes | &prime; | &#8242;
″ | seconds | &Prime; | &#8243;
‹ | single left angle quotation | &lsaquo; | &#8249;
› | single right angle quotation | &rsaquo; | &#8250;
‾ | overline | &oline; | &#8254;
€ | euro | &euro; | &#8364;
™ | trademark | &trade; | &#8482;
← | left arrow | &larr; | &#8592;
↑ | up arrow | &uarr; | &#8593;
→ | right arrow | &rarr; | &#8594;
↓ | down arrow | &darr; | &#8595;
↔ | left right arrow | &harr; | &#8596;
↵ | carriage return arrow | &crarr; | &#8629;
⌈ | left ceiling | &lceil; | &#8968;
⌉ | right ceiling | &rceil; | &#8969;
⌊ | left floor | &lfloor; | &#8970;
⌋ | right floor | &rfloor; | &#8971;
◊ | lozenge | &loz; | &#9674;
♠ | spade | &spades; | &#9824;
♣ | club | &clubs; | &#9827;
♥ | heart | &hearts; | &#9829;
♦ | diamond | &diams; | &#9830;
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验

W3School提供的内容仅用于培训。我们不保证内容的正确性。通过使用本站内容随之而来的风险与本站无关。当使用本站时，代表您已接受了本站的使用条款和隐私条款。

版权所有，保留一切权利。未经书面许可，不得转载。W3School(s)简体中文版授权上海蒙信网络科技有限公司在中华人民共和国运营。


HTML 7 比特 ASCII 代码 参考手册

参考手册

  • 标签列表（字母排序）
  • 标签列表（功能排序）
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML Latin-1
  • HTML 符号
  • HTML URL 编码
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 7 比特 ASCII 代码 参考手册

  • Previous Page
  • Next Page

HTML 和 XHTML 用标准的 7 比特 ASCII 代码在网络上传输数据。

7 比特 ASCII 代码可提供 128 个不同的字符值。

7 比特 可显示的 ASCII 代码

结果 | 描述 | 实体编号
 | space | &#32;
! | exclamation mark | &#33;
" | quotation mark | &#34;
# | number sign | &#35;
$ | dollar sign | &#36;
% | percent sign | &#37;
& | ampersand | &#38;
' | apostrophe | &#39;
( | left parenthesis | &#40;
) | right parenthesis | &#41;
* | asterisk | &#42;
+ | plus sign | &#43;
, | comma | &#44;
- | hyphen | &#45;
. | period | &#46;
/ | slash | &#47;
0 | digit 0 | &#48;
1 | digit 1 | &#49;
2 | digit 2 | &#50;
3 | digit 3 | &#51;
4 | digit 4 | &#52;
5 | digit 5 | &#53;
6 | digit 6 | &#54;
7 | digit 7 | &#55;
8 | digit 8 | &#56;
9 | digit 9 | &#57;
: | colon | &#58;
; | semicolon | &#59;
< | less-than | &#60;
= | equals-to | &#61;
> | greater-than | &#62;
? | question mark | &#63;
@ | at sign | &#64;
A | uppercase A | &#65;
B | uppercase B | &#66;
C | uppercase C | &#67;
D | uppercase D | &#68;
E | uppercase E | &#69;
F | uppercase F | &#70;
G | uppercase G | &#71;
H | uppercase H | &#72;
I | uppercase I | &#73;
J | uppercase J | &#74;
K | uppercase K | &#75;
L | uppercase L | &#76;
M | uppercase M | &#77;
N | uppercase N | &#78;
O | uppercase O | &#79;
P | uppercase P | &#80;
Q | uppercase Q | &#81;
R | uppercase R | &#82;
S | uppercase S | &#83;
T | uppercase T | &#84;
U | uppercase U | &#85;
V | uppercase V | &#86;
W | uppercase W | &#87;
X | uppercase X | &#88;
Y | uppercase Y | &#89;
Z | uppercase Z | &#90;
[ | left square bracket | &#91;
\ | backslash | &#92;
] | right square bracket | &#93;
^ | caret | &#94;
_ | underscore | &#95;
` | grave accent | &#96;
a | lowercase a | &#97;
b | lowercase b | &#98;
c | lowercase c | &#99;
d | lowercase d | &#100;
e | lowercase e | &#101;
f | lowercase f | &#102;
g | lowercase g | &#103;
h | lowercase h | &#104;
i | lowercase i | &#105;
j | lowercase j | &#106;
k | lowercase k | &#107;
l | lowercase l | &#108;
m | lowercase m | &#109;
n | lowercase n | &#110;
o | lowercase o | &#111;
p | lowercase p | &#112;
q | lowercase q | &#113;
r | lowercase r | &#114;
s | lowercase s | &#115;
t | lowercase t | &#116;
u | lowercase u | &#117;
v | lowercase v | &#118;
w | lowercase w | &#119;
x | lowercase x | &#120;
y | lowercase y | &#121;
z | lowercase z | &#122;
{ | left curly brace | &#123;
| | vertical bar | &#124;
} | right curly brace | &#125;
~ | tilde | &#126;

7 比特 设备控制 ASCII代码

ASCII设备控制代码最初被设计为用来控制诸如打印机和磁带驱动器之类的硬件设备。在HTML文档中这些代码不会起任何作用。

结果 | 描述 | 实体编号
NUL | null character | &#00;
SOH | start of header | &#01;
STX | start of text | &#02;
ETX | end of text | &#03;
EOT | end of transmission | &#04;
ENQ | enquiry | &#05;
ACK | acknowledge | &#06;
BEL | bell (ring) | &#07;
BS | backspace | &#08;
HT | horizontal tab | &#09;
LF | line feed | &#10;
VT | vertical tab | &#11;
FF | form feed | &#12;
CR | carriage return | &#13;
SO | shift out | &#14;
SI | shift in | &#15;
DLE | data link escape | &#16;
DC1 | device control 1 | &#17;
DC2 | device control 2 | &#18;
DC3 | device control 3 | &#19;
DC4 | device control 4 | &#20;
NAK | negative acknowledge | &#21;
SYN | synchronize | &#22;
ETB | end transmission block | &#23;
CAN | cancel | &#24;
EM | end of medium | &#25;
SUB | substitute | &#26;
ESC | escape | &#27;
FS | file separator | &#28;
GS | group separator | &#29;
RS | record separator | &#30;
US | unit separator | &#31;
DEL | delete (rubout) | &#127;
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML <!--...--> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <!--...--> 标签

定义和用法

注释标签用来在源文档中插入注释。注释会被浏览器忽略。您可使用注释对您的代码进行解释，这样做有助于您在以后的时间对代码的编辑。

您也可以在注释内容存储针对程序所定制的信息。在这种情况下，这些信息对用户是不可见的，但是对程序来说是可用的。一个好的习惯是把注释或样式元素放入注释文本中，这样就可避免不支持脚本或样式的老浏览器把它们显示为纯文本。

除了在源文档中有非常明显的作用外，许多 Web 服务器也利用注释来实现文档服务端软件特有的特性。这些服务器可以扫描文档，从传统的 HTML/XHTML 注释中找到特定的字符序列，然后再根据嵌在注释中的命令采取相应的动作。这些动作可能是简单的包括其他文件中的文本（即所谓的服务器端包含，server-inside include），也可能是复杂地执行其他命令去动态生成文档的内容。

例子：

<!--This text is a comment-->
<p>This is a regular paragraph</p>

属性：无

TIY 实例

隐藏的注释
本例演示如何在 HTML 源代码中插入隐藏的注释。

HTML 参考手册
HTML 实例
HTML 测验


HTML <!DOCTYPE> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <!DOCTYPE> 标签

定义和用法

<!DOCTYPE> 声明位于文档中的最前面的位置，处于 <html> 标签之前。此标签可告知浏览器文档使用哪种 HTML 或 XHTML 规范。

该标签可声明三种 DTD 类型，分别表示严格版本、过渡版本以及基于框架的 HTML 文档。

以下面这个 <!DOCTYPE> 标签为例：

<!DOCTYPE html
PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

在上面的声明中，声明了文档的根元素是 html，它在公共标识符被定义为 "-//W3C//DTD XHTML 1.0 Strict//EN" 的 DTD 中进行了定义。浏览器将明白如何寻找匹配此公共标识符的 DTD。如果找不到，浏览器将使用公共标识符后面的 URL 作为寻找 DTD 的位置。

提示和注释：

注释：<!DOCTYPE> 标签没有结束标签！

HTML

HTML 4.01 规定了三种文档类型：Strict、Transitional 以及 Frameset。

HTML Strict DTD

如果您需要干净的标记，免于表现层的混乱，请使用此类型。请与层叠样式表（CSS）配合使用：

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "
http://www.w3.org/TR/html4/strict.dtd">

HTML Transitional DTD

Transitional DTD 可包含 W3C 所期望移入样式表的呈现属性和元素。如果您的读者使用了不支持层叠样式表（CSS）的浏览器以至于您不得不使用 HTML 的呈现特性时，请使用此类型：

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "
http://www.w3.org/TR/html4/loose.dtd">

Frameset DTD

Frameset DTD 应当被用于带有框架的文档。除 frameset 元素取代了 body 元素之外，Frameset DTD 等同于 Transitional DTD：

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN" "
http://www.w3.org/TR/html4/frameset.dtd">

XHTML

XHTML 1.0 规定了三种 XML 文档类型：Strict、Transitional 以及 Frameset。

XHTML Strict DTD

如果您需要干净的标记，免于表现层的混乱，请使用此类型。请与层叠样式表（CSS）配合使用：

<!DOCTYPE html
PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

XHTML Transitional DTD

Transitional DTD 可包含 W3C 所期望移入样式表的呈现属性和元素。如果您的读者使用了不支持层叠样式表（CSS）的浏览器以至于您不得不使用 XHTML 的呈现特性时，请使用此类型：

<!DOCTYPE html
PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

XHTML Frameset DTD

当您希望使用框架时，请使用此 DTD！

<!DOCTYPE html
PUBLIC "-//W3C//DTD XHTML 1.0 Frameset//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-frameset.dtd">

如需检查你是否编写了带有正确 DTD 的合法 XHTML 文档，您可以把您的 XHTML 页面链接到一个 XHTML 验证器。

属性：无

HTML 参考手册
HTML 实例
HTML 测验


HTML <a> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <a> 标签

定义和用法

<a> 标签可定义锚。一个锚有两种用法：

  • 通过使用 href 属性，创建一个到另外一个文档的链接
  • 通过使用 name 或 id 属性，创建一个文档内部的书签

术语解释

什么是超文本？

HTML 与 XHTML 之间的差异

NONE

提示和注释：

注释：被链接的页面通常被显示在当前的浏览器窗口中，除非您规定了其他的 target。

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 | 值 | 描述 | DTD
charset | 标准字符集的名称 | 规定目标 URL 的字符编码。 | STF
coords | 参见 coords 属性和 shape 属性 | STF
href | URL | 链接的目标 URL。 | STF
hreflang | ISO 标准的双字符语言代码 | 规定目标 URL 的基准语言。 | STF
name section_name

命名一个锚。请使用此属性在文档中创建某个书签。

在XHTML的未来版本中，name属性会被id属性取代！

 STF
rel
  • alternate
  • designates
  • stylesheet
  • start
  • next
  • prev
  • contents
  • index
  • glossary
  • copyright
  • chapter
  • section
  • subsection
  • appendix
  • help
  • bookmark
 规定当前文档与目标 URL 之间的关系。 STF
rev
  • alternate
  • designates
  • stylesheet
  • start
  • next
  • prev
  • contents
  • index
  • glossary
  • copyright
  • chapter
  • section
  • subsection
  • appendix
  • help
  • bookmark
 规定目标 URL 与当前文档之间的关系。 STF
shape | 参见 coords 属性和 shape 属性 | STF
target
  • _blank
  • _parent
  • _self
  • _top

在何处打开目标 URL。

  • _blank - 在一个新的未命名的窗口载入文档
  • _self - 在相同的框架或窗口中载入目标文档
  • _parent - 把文档载入父窗口或包含了超链接引用的框架的框架集
  • _top - 把文档载入包含该超链接的窗口,取代任何当前正在窗口中显示的框架
 TF
type | MIME 编码类型 | 规定目标 URL 的 MIME 类型。 | STF

coords 属性和 shape 属性

当前流行的浏览器已经不再支持这两种属性了，与 <area> 标签中的同名属性类似，coords 和 shape 属性会为 <a> 标签定义一个影响区域。

只有在 <a> 标签是 <map> 标签的一部分时，才可以在 <a> 标签中使用这两种属性。

参见 <map> 标签。参见 <area> 标签。参见 <area> 标签的 coords 属性。

标准属性

id, class, title, style, dir, lang, xml:lang, tabindex, accesskey

如需完整的描述，请访问标准属性。

事件属性

onfocus, onblur, onclick, ondblclick, onmousedown, onmouseup,
onmouseover, onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

创建超级链接
本例演示如何在 HTML 文档中创建链接。
将图像作为链接
本例演示如何使用图像作为链接。
在新的浏览器窗口打开链接
本例演示如何在新窗口打开一个页面，这样的话访问者就无需离开你的站点了。
链接到同一个页面的不同位置
本例演示如何使用链接跳转至文档的另一个部分
跳出框架
本例演示如何跳出框架，假如你的页面被固定在框架之内。
创建电子邮件链接
本例演示如何如何链接到一个邮件。（本例在安装邮件客户端程序后才能工作。）
创建电子邮件链接 2
本例演示更加复杂的邮件链接。

HTML 参考手册
HTML 实例
HTML 测验


HTML <abbr> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <abbr> 标签

定义和用法

表示一个缩写形式，比如 "Inc."、"etc."。通过对缩写词语进行标记，您就能够为浏览器、拼写检查程序、翻译系统以及搜索引擎分度器提供有用的信息。

<abbr> 标签最初是在 HTML 4.0 中引入的，表示它所包含的文本是一个更长的单词或短语的缩写形式。

浏览器可能会根据这个信息改变对这些文本的显示方式，或者用其他文本代替。也许当前流行的浏览器对 <abbr> 标签中包含的文本还没有任何处理方式，但是我们无法预测将来的版本将会如何实现该标签。

HTML 与 XHTML 之间的差异

无

例子

<abbr title="etcetera">etc.</abbr>

提示和注释：

注释：在某些浏览器中，当您把鼠标移至缩略词语上时，title 可被用来展示表达的完整版本。

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

缩写和首字母缩写
此例演示如何实现缩写或首字母缩写。

HTML 参考手册
HTML 实例
HTML 测验


HTML <abbr> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <acronym> 标签

定义和用法

<acronym> 元素可定义只取首字母缩写，比如 "NATO"。通过对只取首字母缩写进行标记，您就能够为浏览器、拼写检查程序、翻译系统以及搜索引擎分度器提供有用的信息。

HTML 与 XHTML 之间的差异

无

提示和注释：

注释：在某些浏览器中，当您把鼠标移至缩略词语上时，title 可用于展示表达的完整版本。

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

缩写和首字母缩写
此例演示如何实现缩写或首字母缩写。

HTML 参考手册
HTML 实例
HTML 测验


HTML <address> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <address> 标签

定义和用法

<address> 可定义一个地址（比如电子邮件地址）。您应当使用它来定义地址、签名或者文档的作者身份。

HTML 与 XHTML 之间的差异

无。

提示和注释：

注释：address 通常被呈现为斜体。大多数浏览器会在 address 元素的前后添加一个换行符，不过如果有必要的话，您需要在地址文本的内容添加额外的换行符。

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

地址
此例演示如何在 HTML 文件中写地址。

HTML 参考手册
HTML 实例
HTML 测验


HTML <applet> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <applet> 标签

定义和用法

定义一个嵌入的 applet。

HTML 与 XHTML 之间的差异

在 HTML 4.01 中，applet 元素不被赞成使用。

在 XHTML 1.0 Strict DTD 中，applet 元素不被支持。

提示和注释：

提示：如需包含 applet，请尽可能地使用 object 元素（因为在 XHTML 1.0 Strict DTD 中，applet 元素不被支持）。

必需的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 | 值 | 描述 | DTD
height | pixels | 定义 applet 的高度 | TF
width | pixels | 定义 applet 的宽度 | TF

可选的属性

属性 | 值 | 描述 | DTD
align
  • left
  • right
  • top
  • bottom
  • middle
  • baseline
  • texttop
  • absmiddle
  • absbottom
 定义围绕 applet 的文本排列方式。 TF
alt | text | 假如浏览器支持 applet，但无法运行此 applet 时，被显示的替换文本。 | TF
archive | URL | 当 applet 被存储在某个 JAVA 档案文件或 ZIP 文件中时，此 applet 的 URL。 | TF
code | URL | 执行 applet 的 class 的 URL。 | TF
codebase | URL | 指示 applet 的基准 URL，假如 code 属性是相对的。 | TF
hspace | pixels | 定义围绕 applet 的水平间隔。 | TF
name | unique_name | 定义针对 applet 的唯一名称（用在脚本中的）。 | TF
object | name | 定义了包含该 applet 的一系列版本的资源名称。 | TF
title | text | 在工具提示中显示的附加信息。 | TF
vspace | pixels | 定义围绕 applet 的垂直间隔。 | TF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

HTML 参考手册
HTML 实例
HTML 测验


HTML <area> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <area> 标签

定义和用法

定义图像映射中的某个区域。

HTML 与 XHTML 之间的差异

在 HTML 中，<area> 没有结束标签。

在 XHTML 中，<area> 必须被正确地关闭。

提示和注释：

此元素永远被嵌套在 <map> 标签内部。

注释：<img> 中的 usemap 属性可引用 <map> 中的 id 或 name 属性（由浏览器决定），所以我们需要同时向 <map> 添加 id 和 name 两个属性。

必需的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 | 值 | 描述 | DTD
alt | text | 定义此区域的替换文本。 | STF

可选的属性

属性 | 值 | 描述 | DTD
coords 坐标值

定义可点击区域（对鼠标敏感的区域）的坐标。

有关 coords 属性的详细信息。

 STF
href | URL | 定义此区域的目标 URL。 | STF
nohref
  • true
  • false
 从图像映射排除某个区域。 STF
shape
  • rect
  • rectangle
  • circ
  • circle
  • poly
  • polygon
 定义区域的形状。 STF
target
  • _blank
  • _parent
  • _self
  • _top

在何处打开目标 URL。

  • _blank - 在一个新的未命名的窗口载入文档
  • _self - 在相同的框架或窗口中载入目标文档
  • _parent - 把文档载入父窗口或包含了超链接引用的框架的框架集
  • _top - 把文档载入包含该超链接的窗口,取代任何当前正在窗口中显示的框架
 TF

标准属性

id, class, title, style, dir, lang, xml:lang, tabindex, accesskey

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover, onmousemove,
onmouseout, onkeypress, onkeydown, onkeyup, onfocus, onblur

如需完整的描述，请访问事件属性。

TIY

创建图像映射
本例显示如何创建带有可供点击区域的图像映射。其中的每个区域都是一个超级链接。

HTML 参考手册
HTML 实例
HTML 测验


HTML <area> 标签的 coords 属性

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <area> 标签的 coords 属性

coords 属性

<area> 标签的 coords 属性定义了客户端图像映射中对鼠标敏感的区域的坐标。坐标的数字及其含义取决于 shape 属性中决定的区域形状。可以将客户端图像映射中的超链接区域定义为矩形、圆形或多边形等。

下面列出了每种形状的适当值：

圆形：shape="circle"，coords="x,y,z"

这里的 x 和 y 定义了圆心的位置（"0,0" 是图像左上角的坐标），r 是以像素为单位的圆形半径。

多边形：shape="polygon"，coords="x1,y1,x2,y2,x3,y3,..."

每一对 "x,y" 坐标都定义了多边形的一个顶点（"0,0" 是图像左上角的坐标）。定义三角形至少需要三组坐标；高纬多边形则需要更多数量的顶点。

多边形会自动封闭，因此在列表的结尾不需要重复第一个坐标来闭合整个区域。

矩形：shape="rectangle"，coords="x1,y1,x2,y2"

第一个坐标是矩形的一个角的顶点坐标，另一对坐标是对角的顶点坐标，"0,0" 是图像左上角的坐标。请注意，定义矩形实际上是定义带有四个顶点的多边形的一种简化方法。

例如，下面的 XHTML 片段在一个 100x100 像素图像的右下方四分之一处，定义了一个对鼠标敏感的区域，并在图像的正中间定义了一个圆形区域。

<map name="map">
  <area shape="rect" coords="75,75,99,99" nohref="nohref">
  <area shape="circ" coords="50,50,25" nohref="nohref">
</map>

提示和注释

注释：如果某个 area 标签中的坐标和其他区域发生了重叠，会优先采用最先出现的 area 标签。浏览器会忽略超过图像边界范围之外的坐标。

HTML 参考手册
HTML 实例
HTML 测验


HTML <base> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <base> 标签

定义和用法

base 元素可规定页面中所有链接的基准 URL。

通常情况下，浏览器会从当前文档的 URL 中提取相应的元素来填写相对 URL 中的空白。

使用 <base> 标签可以改变这一点。浏览器随后将不再使用当前文档的 URL，而使用指定的基本 URL 来解析所有的相对 URL。这其中包括 <a>、<img>、<link>、<form> 标签中的 URL。

HTML 与 XHTML 之间的差异

在 HTML 中，<base> 标签没有结束标签。

在 XHTML 中，<base> 标签必须被正确地关闭。

提示和注释：

注释：<base> 标签必须位于 head 元素内部。

必需的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 | 值 | 描述 | DTD
href | URL | 规定页面中所有链接的基准 URL。 | STF

可选的属性

属性 值 描述 DTD
target
  • _blank
  • _parent
  • _self
  • _top

在何处打开页面中所有的链接。可通过在每个链接中使用 target 属性来覆盖此属性。

  • _blank - 在一个新的未命名的窗口载入文档
  • _self - 在相同的框架或窗口中载入目标文档
  • _parent - 把文档载入父窗口或包含了超链接引用的框架的框架集
  • _top - 把文档载入包含该超链接的窗口,取代任何当前正在窗口中显示的框架
 TF

标准的属性和事件

NONE

TIY 实例

一个 target，所有的链接
本例显示如何使用 base 标签使得页面中的所有标签在新窗口中打开。

HTML 参考手册
HTML 实例
HTML 测验


HTML <basefont> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <basefont> 标签

定义和用法

定义一个基准字体。

HTML 与 XHTML 之间的差异

在 HTML 4.01 中，basefont 元素是不被赞成使用的。

在 XHTML 1.0 Strict DTD 中，basefont 元素不被支持。

可选的属性

属性 | 值 | 描述 | DTD
color
  • rgb(x,x,x)
  • #xxxxxx
  • colorname
 规定文本的颜色。不赞成使用。请使用样式取代它。 TF
face | list_of_fontnames | 规定要使用的字体。不赞成使用。请使用样式取代它。 | TF
size default_text_size

针对 font 元素的字体尺寸(从 1 到 7 的数字)。

不赞成使用。请使用样式取代它。

 TF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

NONE

HTML 参考手册
HTML 实例
HTML 测验


HTML <bdo> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <bdo> 标签

定义和用法

bdo 元素可覆盖默认的文本方向。

HTML 与 XHTML 之间的差异

NONE

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 值 描述 DTD
dir
  • ltr
  • rtl
 定义文字的方向 STF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

TIY 实例

文字方向
此例演示如何改变文字的方向。

HTML 参考手册
HTML 实例
HTML 测验


HTML <blockquote> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <blockquote> 标签

定义和用法

<blockquote> 标签可定义一个块引用。

<blockquote> 与 </blockquote> 之间的所有文本都会从常规文本中分离出来，经常会在左、右两边进行缩进，而且有时会使用斜体。也就是说，块引用拥有它们自己的空间。

HTML 与 XHTML 之间的差异

应当在 <blockquote> 标签中仅仅包含块级元素，而不仅仅是纯文本。

如需把页面作为 strict XHTML 进行验证，您就必须在 <blockquote> 标签内容添加块级元素，比如这样：

<blockquote>
<p>here is a long quotation here is a long quotation</p>
</blockquote>

提示和注释：

注释：blockquote 元素经常会在文本的两端产生缩进。

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, and F=Frameset.

属性 | 值 | 描述 | DTD
cite | URL | 指示引用的来源。该属性的值是一个包含在引号中并指向联机文档的 URL，以及（如果有可能的话）引用在该文档中的确切位置。 | STF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

引用
此例演示如何实现长短不一的引用。

HTML 参考手册
HTML 实例
HTML 测验


HTML <blockquote> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <body> 标签

定义和用法

body 元素定义文档的主体。它包含文档的所有内容（比如文本、图像、颜色和图形等等。）

HTML 与 XHTML 之间的差异

在 HTML 4.01 中，所有 body 元素的“呈现属性”均不被赞成使用。

在 XHTML 1.0 Strict DTD 中，所有 body 元素的“呈现属性”均不被支持。

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, and F=Frameset.

属性 | 值 | 描述 | DTD
alink
  • rgb(x,x,x)
  • #xxxxxx
  • colorname
 规定文档中活动链接（active link）的的颜色。不赞成使用。请使用样式取代它。 TF
background | file_name | 用作背景的图像。不赞成使用。请使用样式取代它。 | TF
bgcolor
  • rgb(x,x,x)
  • #xxxxxx
  • colorname
 文档的背景颜色。不赞成使用。请使用样式取代它。 TF
link
  • rgb(x,x,x)
  • #xxxxxx
  • colorname
 规定文档中所有链接的颜色。不赞成使用。请使用样式取代它。 TF
text
  • rgb(x,x,x)
  • #xxxxxx
  • colorname
 规定文档中所有文本的颜色。不赞成使用。请使用样式取代它。 TF
vlink
  • rgb(x,x,x)
  • #xxxxxx
  • colorname
 规定文档中所有被访链接的颜色。不赞成使用。请使用样式取代它。 TF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onload, onunload, onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

一个简单的 HTML 文件
这个例子是一个很简单的 HTML 文件，使用了尽量少的 HTML 标签。它向您演示了 body 元素中的内容是如何被浏览器显示的。
背景颜色
本例演示如何为 HTML 页面添加背景颜色。
背景图片
本例演示如何添加背景图片到 HTML 页面。

HTML 参考手册
HTML 实例
HTML 测验


HTML <br> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <br> 标签

定义和用法

<br> 可插入一个简单的换行符。

<br> 标签是空标签（意味着它没有结束标签，因此这是错误的：<br></br>）。

clear 属性

如果您希望文本流在内联表格或图像的下一行继续输出，请使用 clear 属性，该属性有三个可选的值：left、right 或者 all，每个值都代表一个边界或两边的边界。

更多有关 <br> 标签的 clear 属性的信息。

HTML 与 XHTML 之间的差异

在 HTML 中，<br> 标签没有结束标签。

在 XHTML 中，<br> 标签必须被正确地关闭，比如这样：<br />。

提示和注释：

注释：请使用 <br> 来输入空行，而不是分割段落。

标准属性

id, class, title, style

如需完整的描述，请访问标准属性。

TIY 实例

换行
本例演示如何在文档中插入换行符。

HTML 参考手册
HTML 实例
HTML 测验


HTML <br> 标签的 clear 属性

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <br> 标签的 clear 属性

通常情况下，<br> 标签会告诉浏览器立即停止当前的文本流，并在下一行的左边，或者在左对齐的内联图形或表格的右边开始继续输出文本流。

但是有时候，您也许希望当前的文本流在当前左边或右边的内联表格或图像的下面一行继续输出。

HTML 4 和 XHTML 通过 <br> 标签提供了这样的功能。它可以具有三个值：left、right 或者 all，每个值都代表一个边界或两边的边界。当指定的边界没有图像时，浏览器才会继续输出文本。

提示和注释

提示：一般情况下，文本流中的其他行会在内联图像的底部显示，除非图形的 <img> 标签被设置为左对齐或右对齐（对于 <table> 标签也一样）。因此，<br> 标签的 clear 属性只对这些左对齐或右对齐的图像或表格起作用。

TIY

不带有 align 属性的 <img> 标签与带有 clear 属性的 <br> 标签
带有 align 属性的 <img> 标签与不带有 clear 属性的 <br> 标签
带有 align 属性的 <img> 标签与带有 clear 属性的 <br> 标签
align 属性为 absmiddle 的 <img> 标签与clear 属性为 left 的 <br> 标签

HTML 参考手册
HTML 实例
HTML 测验


HTML <button> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <button> 标签

定义和用法

定义一个按钮。在 button 元素内部，您可以放置内容，比如文本或图像。这是该元素与使用 input 元素创建的按钮之间的不同之处。

<button> 控件 与 <input type="button"> 相比，提供了更为强大的功能和更丰富的内容。<button> 与 </button> 标签之间的所有内容都是按钮的内容，其中包括任何可接受的正文内容，比如文本或多媒体内容。例如，我们可以在按钮中包括一个图像和相关的文本，用它们在按钮中创建一个吸引人的标记图像。

唯一禁止使用的元素是图像映射，因为它对鼠标和键盘敏感的动作会干扰表单按钮的行为。

HTML 与 XHTML 之间的差异

NONE

可选的属性

属性 | 值 | 描述 | DTD
disabled | disabled | 禁用此按钮。 | STF
name | button_name | 规定此按钮的唯一名称。 | STF
type
  • button
  • reset
  • submit
 定义按钮的类型。 STF
value | some_value | 规定按钮的初始值。此值可被脚本修改。 | STF

标准属性

id, class, title, style, dir, lang, xml:lang, accesskey, tabindex

如需完整的描述，请访问标准属性。

事件属性

onfocus, onblur, onclick, ondblclick, onmousedown, onmouseup,
onmouseover, onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

HTML 参考手册
HTML 实例
HTML 测验


HTML <caption> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <caption> 标签

定义和用法

caption 元素可定义一个表格标题。caption 标签必须紧随 table 标签之后。您只能对每个表格定义一个标题。通常这个标题会被居中于表格之上。

HTML 与 XHTML 之间的差异

在 HTML 4.01 中，caption 元素的 align 属性是不被赞成使用的。

在 XHTML 1.0 Strict DTD 中，caption 元素的 align 属性是不被支持的。

可选的属性

属性 值 描述 DTD
align
  • left
  • right
  • top
  • bottom
 如何对齐该标题。不赞成使用。请使用样式取而代之。 TF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

带有标题的表格
本例演示一个带标题(caption)的表格

HTML 参考手册
HTML 实例
HTML 测验


HTML <caption> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <center> 标签

定义和用法

对其所包括的文本进行水平居中。

HTML 与 XHTML 之间的差异

在 HTML 4.01 中，center 元素不被赞成使用。

在 XHTML 1.0 Strict DTD 中，center 元素不被支持。

提示和注释：

注释：提示：请使用 CSS 样式来居中文本！

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

HTML 参考手册
HTML 实例
HTML 测验


HTML <col> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <col> 标签

定义和用法

为表格中一个或多个列定义属性值。您只能在表格或 colgroup 中使用此元素。

HTML 与 XHTML 之间的差异

在 HTML 中，<col> 没有结束标签。

在 XHTML 中，<col> 标签必须被正确的嵌套。

提示和注释：

注释：col 元素是仅包含属性的空元素。如需创建列，您就必须在 tr 元素内部规定 td 元素。

提示：如果您希望在 colgroup 内部为每个列规定不同的属性值时，请使用此元素。如果没有 col 元素，列会从 colgroup 那里继承所有的属性值。

例子

<table border="1">

  <colgroup span="3">
    <col width="20"></col>
    <col width="50"></col>
    <col width="80"></col>
  </colgroup>

  <tr>
    <td>1</td>
    <td>2</td>
    <td>3</td>
    <td>4</td>
  </tr>

</table>

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 | 值 | 描述 | DTD
align
  • right
  • left
  • center
  • justify
  • char
 在列中定义单元格中内容的水平排列方式。 STF
char character

规定根据哪个字符来进行文本对齐。

注释：仅当 align="char" 时使用！

 STF
charoff
  • pixels
  • %

规定第一个对齐字符的偏移量。

注释：仅当 align="char" 时使用！

 STF
span | number | 定义 <col> 应当横跨的列数。有关 span 属性的详细信息。 | STF
valign
  • top
  • middle
  • bottom
  • baseline
 在列中定义单元格中内容的垂直排列方式。 STF
width
  • %
  • pixels
  • relative_length

定义列的宽度。

注释：将覆盖 <colgroup> 中设置的宽度。

 STF

span 属性

<col> 标签，如同 <colgroup> 标签中的 span 属性一样，允许设置设置 <col> 标签能够影响多少列。

在默认情况下，它只能影响一列。举个例子，创建一个有 5 列的 <colgroup>。我们分别将第一列和最后一列靠左和靠右对齐，中间的三列居中。

<colgroup>
  <col align="left" />
  <col align="center" span="3" />
  <col align="right" />
</colgroup>

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

HTML 参考手册
HTML 实例
HTML 测验


HTML <colgroup> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <colgroup> 标签

定义和用法

定义表格列的分组。通过此元素，您可以对列进行组合以便进行格式化。此元素只有在 <table> 标签内部才是合法的。

有两种方式来使用 <colgroup> 标签：一种是对几个同样的列进行简单的定义，另一种是将几个不同的列组合起来。

HTML 与 XHTML 之间的差异

NONE

提示和注释：

注释：col 元素是仅包含属性的空元素。如需创建列，您就必须在 tr 元素内部规定 td 元素。

例子

<table border="1">

  <colgroup span="3" style="color:#FF0000;"></colgroup>

  <tr>
    <td>1</td>
    <td>2</td>
    <td>3</td>
    <td>4</td>
  </tr>

</table>

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 值 描述 DTD
align
  • right
  • left
  • center
  • justify
  • char
 定义列组合中内容的水平排列方式。 STF
char character

定义一个字符，用来把文本向此字符进行排列。

（与align="char"配合使用）

 STF
charoff
  • pixels
  • %

定义向第一个字符排列的排列偏移量。

（与align="char"配合使用）

 STF
span number

定义 <colgroup> 可以横跨的列数。

有关 span 属性的详细信息。

 STF
valign
  • top
  • middle
  • bottom
  • baseline
 定义在列组合中内容的垂直排列方式。 STF
width
  • %
  • pixels
  • relative_length

定义列组合的宽度。

注释：可通过在 <col> 中设置宽度来覆盖 width 属性！

 STF

span 属性

在 <colgroup> 标签中使用 span，可获得第一个列组的类型。span 属性的值是 <colgroup> 标签能够影响到的列数。

例如，有 6 列的一个表格，第一组有 4 列，第二组有 2 列，这样的表格在源码上如下所示：

<colgroup span="4"></colgroup>
<colgroup span="2"></colgroup>

浏览器在用例子中的代码将表格单元格合成列时，它会将每行前四个单元格合成第一个列组，将接下来的两个单元格合成第二个列组。这样，<colgroup> 标签的其他属性就可以用于该列组包含的列中了。

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

HTML 参考手册
HTML 实例
HTML 测验


HTML <dd> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <dd> 标签

定义和用法

<dd> 可在定义列表中定义条目的定义部分。

HTML 与 XHTML 之间的差异

NONE

例子

<dl>
   <dt>Coffee</dt>
   <dd>Black hot drink</dd>
   <dt>Milk</dt>
   <dd>White cold drink</dd>
</dl>

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

定义列表
本例演示一个定义列表。

HTML 参考手册
HTML 实例
HTML 测验


HTML <del> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <del> 标签

定义和用法

定义文档中已被删除的文本。

HTML 与 XHTML 之间的差异

NONE

提示和注释：

注释：请与 <ins> 标签配合使用，来描述文档中的更新和修正。

例子

a dozen is &lt;del&gt;20&lt;/del&gt; 12 pieces

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover, onmousemove,
onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

删除和插入文本
此例演示如何标记文档中删除和插入的文本。

HTML 参考手册
HTML 实例
HTML 测验


HTML <dir> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <dir> 标签

定义和用法

<dir> 标签可定义目录列表。

HTML 与 XHTML 之间的差异

在 HTML 4.01 中，dir 元素不被赞成使用。

在 XHTML 1.0 Strict DTD 中，dir 元素不被支持。

提示和注释：

注释：请使用 CSS 样式来定义列表的类型！

例子

<dir>
   <li>html</li>
   <li>xhtml</li>
</dir>

可选的属性

属性 | 值 | 描述 | DTD
compact | compact_rendering | 不赞成使用。请使用样式代替。 | TF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onfocus, onblur, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

HTML 参考手册
HTML 实例
HTML 测验


HTML <div> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <div> 标签

定义和用法

<div> 可定义文档中的分区或节（division/section）。

<div> 标签可以把文档分割为独立的、不同的部分。它可以用作严格的组织工具，并且不使用任何格式与其关联。

如果用 id 或 class 来标记 <div>，那么该标签的作用会变得更加有效。

用法

<div> 是一个块级元素。这意味着它的内容自动地开始一个新行。实际上，换行是 <div> 固有的唯一格式表现。可以通过 <div> 的 class 或 id 应用额外的样式。

不必为每一个 <div> 都加上类或 id，虽然这样做也有一定的好处。

可以对同一个 <div> 元素应用 class 或 id 属性，但是更常见的情况是只应用其中一种。这两者的主要差异是，class 用于元素组（类似的元素，或者可以理解为某一类元素），而 id 用于标识单独的唯一的元素。

HTML 与 XHTML 之间的差异

在 HTML 4.01 中，div 元素的 "align" 属性不被赞成使用。

在 XHTML 1.0 Strict DTD 中，div 元素的 "align" 属性不被支持。

提示和注释：

注释：<div> 是一个块级元素，也就是说，浏览器通常会在 div 元素前后放置一个换行符。

提示：请使用 <div> 元素来组合块级元素，这样就可以使用样式对它们进行格式化。

例子

<body>

 <h1>NEWS WEBSITE</h1>
  <p>some text. some text. some text...</p>
  ...

 <div class="news">
  <h2>News headline 1</h2>
  <p>some text. some text. some text...</p>
  ...
 </div>

 <div class="news">
  <h2>News headline 2</h2>
  <p>some text. some text. some text...</p>
  ...
 </div>

 ...
</body>

例子解释

正如您看到的，上面这段 HTML 模拟了新闻网站的结构。其中的每个 div 把每条新闻的标题和摘要组合在一起，也就是说，div 为文档添加了额外的结构。同时，由于这些 div 属于同一类元素，所以可以使用 class="news" 对这些 div 进行标识，这么做不仅为 div 添加了合适的语义，而且便于进一步使用样式对 div 进行格式化，可谓一举两得。

提示：如需更深入地学习 class 和 id 的用法，请阅《W3school 的结构化标记》这一章中 div、id 和其他帮手 这一节。

可选的属性

属性 值 描述 DTD
align
  • left
  • right
  • center
  • justify
 对齐 div 元素中的文本。不赞成使用。请使用样式取而代之。 TF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

HTML 参考手册
HTML 实例
HTML 测验


HTML <dl> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <dl> 标签

定义和用法

<dl> 标签定义了定义列表。

HTML 与 XHTML 之间的差异

NONE

例子

<dl>
   <dt>Coffee</dt>
   <dd>Black hot drink</dd>
   <dt>Milk</dt>
   <dd>White cold drink</dd>
</dl>

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

定义列表
本例演示一个定义列表。

HTML 参考手册
HTML 实例
HTML 测验


HTML <dt> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <dt> 标签

定义和用法

<dt> 标签定义了定义列表中的项目（即术语部分）。

HTML 与 XHTML 之间的差异

NONE

例子

<dl>
   <dt>Coffee</dt>
   <dd>Black hot drink</dd>
   <dt>Milk</dt>
   <dd>White cold drink</dd>
</dl>

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

定义列表
如何创建定义列表。

HTML 参考手册
HTML 实例
HTML 测验


HTML <em> <strong> <dfn> <code> <samp> <kbd><var> <cite> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <em> <strong> <dfn> <code> <samp> <kbd><var> <cite> 标签

定义和用法

以下元素都是短语元素。虽然这些标签定义的文本大多会呈现出特殊的样式，但实际上，这些标签都拥有确切的语义。

我们并不反对使用它们，但是如果您只是为了达到某种视觉效果而使用这些标签的话，我们建议您使用样式表，那么做会达到更加丰富的效果。

<em> | 把文本定义为强调的内容。
<strong> | 把文本定义为语气更强的强调的内容。
<dfn> | 定义一个定义项目。
<code> | 定义计算机代码文本。
<samp> | 定义样本文本。
<kbd> | 定义键盘文本。它表示文本是从键盘上键入的。它经常用在与计算机相关的文档或手册中。
<var> | 定义变量。您可以将此标签与 <pre> 及 <code> 标签配合使用。
<cite> | 定义引用。可使用该标签对参考文献的引用进行定义，比如书籍或杂志的标题。

HTML 与 XHTML 之间的差异

无

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

HTML 文本格式化实例

文本格式化
此例演示如何在一个 HTML 文件中对文本进行格式化
“计算机输出”标签
此例演示不同的“计算机输出”标签的显示效果。

HTML 参考手册
HTML 实例
HTML 测验


HTML <fieldset> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <fieldset> 标签

定义和用法

fieldset 元素可将表单内的相关元素分组。

<fieldset> 标签将表单内容的一部分打包，生成一组相关表单的字段。<fieldset> 标签没有必需的或唯一的属性。

当一组表单元素放到 <fieldset> 标签内时，浏览器会以特殊方式来显示它们，它们可能有特殊的边界、3D 效果，或者甚至可创建一个子表单来处理这些元素。

HTML 与 XHTML 之间的差异

NONE

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

accesskey, onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

围绕数据的 Fieldset
本例演示如何在数据周围绘制一个带标题的框。

HTML 参考手册
HTML 实例
HTML 测验


HTML <font> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <font> 标签

定义和用法

<font> 可规定文本的字体、字体尺寸、字体颜色。

HTML 与 XHTML 之间的差异

在 HTML 4.01 中，font 元素不被赞成使用。

在 XHTML 1.0 Strict DTD 中，font 元素不被支持。

提示和注释：

注释：请使用样式（代替 <font>）来定义文本的字体、字体颜色、字体尺寸。

可选的属性

属性 | 值 | 描述 | DTD
color
  • rgb(x,x,x)
  • #xxxxxx
  • colorname
 定义font元素中文本的颜色。 TF
face | 字体名称列表 | 定义font元素中文本的字体。 | TF
size 从1到7的数字

如果已经定义了basefont，您可以规定从-6到6之间的数字。

定义font元素中的文本尺寸。

 TF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

NONE

如需完整的描述，请访问事件属性。

TIY 实例

设置文字的字体
本例演示如何设置文字的字体。
设置文字的尺寸
本例演示如何设置文字的尺寸。
设置文字的颜色
本例演示如何设置文字的颜色。
设置文字的字体、字体尺寸、字体颜色
本例演示如何设置文字的字体、字体尺寸、字体颜色.

HTML 参考手册
HTML 实例
HTML 测验


HTML <form> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <form> 标签

定义和用法

form 元素可为用户输入创建表单。

表单可包含文本域，复选框，单选按钮等等。表单用于向指定的 URL 传递用户数据。

HTML 与 XHTML 之间的差异

NONE

必需的属性

属性 | 值 | 描述 | DTD
action | URL | 当确认按钮被按下时，接受和处理表单数据的 URL。 | STF
method
  • get
  • post
 用于向 action URL 传送数据的 HTTP 方法。默认为 get。 STF

可选的属性

属性 | 值 | 描述 | DTD
accept-charset | 字符集名称列表 | 一个服务器可接受的字符集的列表（用逗号分隔）。 | STF
enctype | MIME 类型 | 用来编码表单内容的 MIME 类型. | STF
name | 表单名称 | 定义表单的唯一名称。 | TF
target
  • _blank
  • _parent
  • _self
  • _top
 在何处打开目标 URL。 TF

method 属性

method="get"：此方法可传送 URL 中的表单内容：URL?name=value&name=value。

注释：如果表单值包含非 ASCII 字符或者超过 100 个字符，您则必须使用 method="post"。

method="post"：此方法可传送 request 主体中的表单内容。

有关 method 方法的详细信息。

accept-charset 属性

accept-charset 属性允许您指定一系列字符集，服务器必须支持这些字符集，从而得以正确解释表单中的数据。

该属性的值是用引号包含字符集名称列表。如果可接受字符集与用户所使用的字符即不相匹配的话，浏览器可以选择忽略表单或是将该表单区别对待。

此属性的默认值是 "unknown"，表示表单的字符集与包含表单的文档的字符集相同。

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onsubmit, onreset, onclick, ondblclick, onmousedown, onmouseup,
onmouseover, onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

文本域(Text fields)
本例演示如何在HTML页面创建文本域。用户可以在文本域写入文本。
密码域
本例演示如何创建HTML的密码域。
复选框
本例演示如何在HTML页中创建文本框。用户可以选中或取消选取复选框。
单选按钮
本例演示如何在HTML中创建单选按钮。
简单的下拉列表
本例演示如何在HTML页面中创建简单的下拉列表框。下拉列表框是一个可选列表。
另一个下拉列表
本例演示如何创建一个简单的带有预选值的下拉列表。（注：预选值指预先指定的首选项。）
文本域(Textarea)
本例演示如何创建一个文本域（多行文本输入控制）。用户可以在文本域中写入文本。在文本域中，可写入的字符字数不受限制。
创建按钮
本例演示如何创建按钮。你可以对按钮上的文字进行自定义。
围绕数据的Fieldset
本例演示如何在数据周围绘制一个带标题的框。
带有输入框和确认按钮的表单
本例演示如何向页面添加表单。此表单包含两个输入框和一个确认按钮。
带有复选框的表单
此表单包含两个复选框和一个确认按钮。
带有单选按钮的表单
此表单包含两个单选框和一个确认按钮。
从表单发送电子邮件
此例演示如何从表单发送电子邮件。

HTML 参考手册
HTML 实例
HTML 测验


HTML <form> 标签的 method 属性

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <form> 标签的 method 属性

method 属性

浏览器使用 method 属性设置的方法将表单中的数据传送给服务器进行处理。共有两种方法：POST 方法和 GET 方法。

如果采用 POST 方法，浏览器将会按照下面两步来发送数据。首先，浏览器将与 action 属性中指定的表单处理服务器建立联系，一旦建立连接之后，浏览器就会按分段传输的方法将数据发送给服务器。

在服务器端，一旦 POST 样式的应用程序开始执行时，就应该从一个标志位置读取参数，而一旦读到参数，在应用程序能够使用这些表单值以前，必须对这些参数进行解码。用户特定的服务器会明确指定应用程序应该如何接受这些参数。

另一种情况是采用 GET 方法，这时浏览器会与表单处理服务器建立连接，然后直接在一个传输步骤中发送所有的表单数据：浏览器会将数据直接附在表单的 action URL 之后。这两者之间用问号进行分隔。

一般浏览器通过上述任何一种方法都可以传输表单信息，而有些服务器只接受其中一种方法提供的数据。可以在 <form> 标签的 method （方法）属性中指明表单处理服务器要用方法来处理数据，使 POST 还是 GET。

POST 还是 GET？

如果表单处理服务器既支持 POST 方法又支持 GET 方法，那么你该选择哪种方法呢？下面是有关这方面的一些规律：

  • 如果希望获得最佳表单传输性能，可以采用 GET 方法发送只有少数简短字段的小表单。
  • 一些服务器操作系统在处理可以立即传递给应用程序的命令行参数时，会限制其数目和长度，在这种情况下，对那些有许多字段或是很长的文本域的表单来说，就应该采用 POST 方法来发送。
  • 如果你在编写服务器端的表单处理应用程序方面经验不足，应该选择 GET 方法。如果采用 POST 方法，就要在读取和解码方法做些额外的工作，也许这并不很难，但是也许你不太愿意去处理这些问题。
  • 如果安全性是个问题，那么我们建议选用 POST 方法。GET 方法将表单参数直接放在应用程序的 URL 中，这样网络窥探者可以很轻松地捕获它们，还可以从服务器的日志文件中进行摘录。如果参数中包含了信用卡帐号这样的敏感信息，就会在不知不觉中危及用户的安全。而 POST 应用程序就没有安全方面的漏洞，在将参数作为单独的事务传输给服务器进行处理时，至少还可以采用加密的方法。
  • 如果想在表单之外调用服务器端的应用程序，而且包括向其传递参数的过程，就要采用 GET 方法，因为该方法允许把表单这样的参数包括进来作为 URL 的一部分。而另一方面，使用 POST 样式的应用程序却希望在 URL 后还能有一个来自浏览器额外的传输过程，其中传输的内容不能作为传统 <a> 标签的内容。

明确传递参数

前面的一些建议也可以作为选择此种方式的一定解释。假设你有一个很简单的表单，其中只包含 x 和 y 这两个参数。在对这些元素的值进行编码时，它们的形式如下所示：

x=28&y=66

如果表单采用了 method=GET，那么用来引用服务器端应用程序的 URL 将如下所示：

http://www.example.com/example/program?x=28&y=66

在任何时候我们都可以创建一个传统的 <a> 标签，用它在调用带有所需参数值的表单，其形式如下所示：

<a href="http://www.example.com/example/program?x=28&y=66">

唯一的问题是，分隔参数所用的 & 符号也是字符实体中的插入符号。如果在 <a> 标签的 href 属性中放入一个 & 符号，浏览器就会将其后面的字符替换成相应的字符实体。

为了防止出现这种情况，我们必须用它的实体对等物来替换 & 符号，也就是用 "&#38;" 或 "&amp;" 来替换。替换之后，上面的那个引用服务器应用程序的非表单示例将如下所示：

<a href="http://www.example.com/example/program?x=28&amp;y=66">

由于这样还是不能在 URL 中使用 & 符号，并且有可能在将来带来混乱，因此我们鼓励服务器设置最后也能够接受用分号作为参数分隔符。您也可以看看自己的服务器文档，了解服务器是否支持这种功能。

HTML 参考手册
HTML 实例
HTML 测验


HTML <frame> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <frame> 标签

定义和用法

在 <frameset> 中定义一个框架。

HTML 与 XHTML 之间的差异

在 HTML 中，<frame> 标签没有结束标签。

在 XHTML 中，<frame> 标签必须被正确地关闭。

提示和注释：

注释：如果您希望验证某个包含框架的页面，请确保 DTD 被设置为 "Frameset DTD"。阅读更多有关 XHTML 验证的内容。

重要事项：您不能与 <frameset></frameset> 标签一起使用 <body></body> 标签。不过，如果您需要为不支持框架的浏览器添加一个 <noframes> 标签，请务必将此标签放置在 <body></body> 标签中！

可选的属性

属性 | 值 | 描述 | DTD
frameborder
  • 0
  • 1
 规定是否显示框架周围的边框。 F
longdesc | URL | 描述此框架内容的长的 URL。可为那些不支持框架的浏览器使用此属性。 | F
marginheight | pixels | 定义框架中的顶部和底部边距。 | F
marginwidth | pixels | 定义框架中的左侧和右侧边距。 | F
name | frame_name | 为框架定义唯一的名称（以便在脚本中使用）。 | F
noresize | noresize | 当设置为 noresize 时，用户无法对框架调整尺寸。 | F
scrolling
  • yes
  • no
  • auto
 确定滚动条的行为。 F
src | URL | 定义显示在框架中的文件的 URL。 | F

标准属性

id, class, title, style

如需完整的描述，请访问标准属性。

TIY 实例

垂直框架
本例演示：如何使用三份不同的文档制作一个垂直框架。
水平框架
本例演示：如何使用三份不同的文档制作一个水平框架。
如何使用 <noframes> 标签
本例演示：如何使用 <noframes> 标签。
混合框架结构
本例演示如何制作含有三份文档的框架结构，同时将他们混合置于行和列之中。
含有 noresize="noresize" 属性的框架结构
本例演示 noresize 属性。在本例中，框架是不可调整尺寸的。在框架间的边框上拖动鼠标，你会发现边框是无法移动的。
导航框架
本例演示如何制作导航框架。导航框架包含一个将第二个框架作为目标的链接列表。名为 "contents.htm" 的文件包含三个链接。
内联框架
本例演示如何创建内联框架（HTML 页中的框架）。
跳转至框架内的一个指定的节
本例演示两个框架。其中的一个框架设置了指向另一个文件内指定的节的链接。这个 "link.htm" 文件内指定的节使用 <a name="C10"> 进行标识。
使用框架导航跳转至指定的节
本利演示两个框架。左侧的导航框架包含了一个链接列表，这些链接将第二个框架作为目标。第二个框架显示被链接的文档。导航框架其中的链接指向目标文件中指定的节。

HTML 参考手册
HTML 实例
HTML 测验


HTML <frameset> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <frameset> 标签

定义和用法

frameset 元素可定义一个框架集。它被用来组织多个窗口（框架）。每个框架存有独立的文档。在其最简单的应用中，frameset 元素仅仅会规定在框架集中存在多少列或多少行。您必须使用 cols 或 rows 属性。

HTML 与 XHTML 之间的差异

NONE

提示和注释：

注释：如果您希望验证某个包含框架的页面，请确保 DTD 被设置为 "Frameset DTD"。阅读更多有关 XHTML 验证的内容。

重要事项：您不能与 <frameset></frameset> 标签一起使用 <body></body> 标签。不过，如果您需要为不支持框架的浏览器添加一个 <noframes> 标签，请务必将此标签放置在 <body></body> 标签中！

可选的属性

属性 值 描述 DTD
cols
  • pixels
  • %
  • *
 定义框架集中列的数目和尺寸。有关 cols 属性的详细信息。 F
rows
  • pixels
  • %
  • *
 定义框架集中行的数目和尺寸。有关 rows 属性的详细信息。 F

标准属性

id, class, title, style

如需完整的描述，请访问标准属性。

事件属性

NONE

如需完整的描述，请访问事件属性。

TIY 实例

垂直框架
本例演示：如何使用三份不同的文档制作一个垂直框架。
水平框架
本例演示：如何使用三份不同的文档制作一个水平框架。
如何使用 <noframes> 标签
本例演示：如何使用 <noframes> 标签。
混合框架结构
本例演示如何制作含有三份文档的框架结构，同时将他们混合置于行和列之中。
含有 noresize="noresize" 属性的框架结构
本例演示 noresize 属性。在本例中，框架是不可调整尺寸的。在框架间的边框上拖动鼠标，你会发现边框是无法移动的。
导航框架
本例演示如何制作导航框架。导航框架包含一个将第二个框架作为目标的链接列表。名为 "contents.htm" 的文件包含三个链接。
内联框架
本例演示如何创建内联框架（HTML 页中的框架）。
跳转至框架内的一个指定的节
本例演示两个框架。其中的一个框架设置了指向另一个文件内指定的节的链接。这个 "link.htm" 文件内指定的节使用 <a name="C10"> 进行标识。
使用框架导航跳转至指定的节
本利演示两个框架。左侧的导航框架包含了一个链接列表，这些链接将第二个框架作为目标。第二个框架显示被链接的文档。导航框架其中的链接指向目标文件中指定的节。

HTML 参考手册
HTML 实例
HTML 测验


HTML <frameset> 标签的 cols 属性和 rows 属性

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <frameset> 标签的 cols 属性和 rows 属性

作用和用法

<frameset> 标签有一个必需的属性：要么是 rows，要么是 cols，这取决于您的选择，它们定义了文档窗口中框架或嵌套的框架集的行或列的大小及数目。

这两个属性都接受用引号括起来并用逗号分开的值列表，这些数值指定了框架的绝对（像素点）或相对（百分比或其余空间）宽度（对列而言），或者绝对或相对高度（对行而言）。这些属性值的数目决定了浏览器将会在文档窗口中显示多少行或列的框架。

与表格一样，浏览器在显示时会尽可能接近给定的框架集尺寸。但是，浏览器不会为了能够容纳下超出边沿的框架集而扩展文档窗口的边界，也不会在指定的框架没有填满整个窗口时用空白区域来填满窗口。相反，浏览器会根据一个框架在行和列中相对于其他框架的大小来分配空间，这样就能够填满整个文档窗口了。（注意到一个主框架文档中没有滚动条了吗？）

例子

例子 1

下面的代码将创建 3 行框架：

<frameset rows="150,300,150">

其中的每行都贯穿整个文档窗口。第一和最后一个框架被设为 150 像素高，第二行设置成 300 像素高。

实际上，除非浏览器窗口正好是 600 像素高，否则浏览器将会自动按照比例延伸或压缩第一和最后一个框架，使得这两个框架都占据 1/4 的窗口空间。中间行将会占据剩下 1/2 的窗口空间。

例子 2

用窗口尺寸的百分比表示的框架行和列尺寸数据更加实际。

例如，下面这个示例与刚才那个示例的效果相同：

<frameset rows="25%,50%,25%">

当然，如果这些百分比加起来不是 100%，浏览器也会自动按照比例重新给出每行尺寸以消除差异。

例子 3

如果你像我们一样，那么将问题综合起来就不是一件难事。可能有的框架设计人员正为同样的困难而感到苦恼，这就解释了为什么他们要在 <frameset> 的 rows 和 cols 值上加上星号。它告诉浏览器要在将相邻的框架放入框架集之后，给剩下的空间分配各自的行或列。

例如，当浏览器遇到下列框架标签时：

<frameset cols="100, *">

上面的例子会生成一个宽为固定的 100 像素的列，然后再生成另一个框架列，该列会占据框架集中其余所有的空间。

例子 4

您还可以对多个列或行属性值使用星号。在这样的情况下，相应的行或列将对可用空间进行等分，例如：

<frameset rows="*, 100, *">

这条语句在框架集的中间生成一个 100 像素高的行，并在这行的上边和下边各生成一个相同尺寸的行。

例子 5

如果在星号前放置一个整数值，相应的行或列九回相对地获得更多的可用空间。例如：

<frameset cols="10%, 3*, *, *">

它生成了 4 列：第一列占据整个框架集宽度的 10%。然后浏览器把其他空间的 3/5 分配给第二个框架，第三个和第四个框架各分配其余空间的 1/5。

从上面的例子可以发现，使用星号（尤其是用数值作为前缀），可以很容易地在一个框架集中分割剩下的空间。

提示和注释

提示：需要注意的是，浏览器允许用户手动地为单个框架文档的行或列重新确定大小，并因此改变每个框架在框架显示中各自占据的相对比例，除非你显式地告诉浏览器不要这样做。为了防止这种情况，可以在 <frame> 标签中使用 noresize 属性。

HTML 参考手册
HTML 实例
HTML 测验


HTML <h1> to <h6> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <h1> to <h6> 标签

定义和用法

<h1> - <h6> 标签可定义标题。<h1> 定义最大的标题。<h6> 定义最小的标题。

由于 h 元素拥有确切的语义，因此请您慎重地选择恰当的标签层级来构建文档的结构。因此，请不要利用标题标签来改变同一行中的字体大小。相反，我们应当使用层叠样式表定义来达到漂亮的显示效果。

如果您希望了解更多有关 HTML 标签选择和使用的信息，请阅读《Web 品质》。

HTML 与 XHTML 之间的差异

在 HTML 4.01 中，h1 - h6 元素的 "align" 属性不被赞成使用。

在 XHTML 1.0 Strict DTD 中，h1 - h6 元素的 "align" 属性不被支持。

例子

<h1>这是标题 1</h1>
<h1>这是标题 2</h1>
<h2>这是标题 3</h2>
<h4>这是标题 4</h4>
<h5>这是标题 5</h5>
<h6>这是标题 6</h6>

可选的属性

属性 值 描述 DTD
align
  • left
  • center
  • right
  • justify
 规定标题中文本的排列。 TF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

标题
本例演示在 HTML 文档中显示标题的标签。
居中排列的标题
本例演示一个居中排列的标题。

HTML 参考手册
HTML 实例
HTML 测验


HTML <head> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <head> 标签

定义和用法

head 元素可包含关于文档的信息。浏览器不会向用户显示这些头部信息（"head information"）。下面这些标签可用在 head 部分：<base>, <link>, <meta>, <script>, <style>, 以及 <title>。

HTML 与 XHTML 之间的差异

NONE

提示和注释：

提示：请记住始终为文档规定标题！

例子

<html>

<head>
  <title>文档的标题</title>
</head>

<body>
...
...
...
</body>
</html>

可选的属性

属性 | 值 | 描述 | DTD
profile | URL | 一个由空格分隔的 URL 列表，这些 URL 包含着有关页面的元数据信息。 | STF

标准属性

dir, lang, xml:lang

如需完整的描述，请访问标准属性。

TIY 实例

文档的标题
头元素内部的标题信息不会被显示在浏览器窗口中。
一个target，所有的链接
本例显示如何使用 base 标签使页面中的所有标签在新窗口中打开。
HTML 中的样式
本例演示如何使用添加到 <head> 部分的样式信息对 HTML 进行格式化。
链接到一个外部样式表
本例演示如何通过 <link> 标签链接到一个外部样式表。
文档描述
Meta 元素中的信息可以描述 HTML 文档。
文档关键字
Meta 元素中的信息可以描述文档的关键词。
重定向
这个例子演示：在网址已经变更的情况下，将用户重定向到另外一个地址。

HTML 参考手册
HTML 实例
HTML 测验


HTML <hr> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <hr> 标签

定义和用法

<hr> 标签可插入一个水平线。

水平分隔线（horizontal rule）可以在视觉上将文档分隔成各个部分。

HTML 与 XHTML 之间的差异

在 HTML 中，<hr> 标签没有结束标签。

在 XHTML 中，<hr> 必须被正确地关闭。

在 HTML 4.01 中，hr 元素的所有呈现属性均不被赞成使用。

在 XHTML 1.0 Strict DTD 中，hr 元素的所有呈现属性均不被支持。

例子

<h1>This is header 1</h1>
<hr />
<p>This is some text</p>

可选的属性

属性 值 描述 DTD
align
  • center
  • left
  • right
 规定水平线的排列。 TF
noshade noshade

当设置为 true 时，水平线呈现为纯色（2D 效果）。

当设置为 false 时，水平线显示为双色凹槽（3D 效果）。

 TF
size
  • pixels
  • %
 规定水平线的厚度（高度）。 TF
width
  • pixels
  • %
 规定了水平线的宽度。 TF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

水平线
如何插入水平线。

HTML 参考手册
HTML 实例
HTML 测验


HTML <html> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <html> 标签

定义和用法

此元素可告知浏览器其自身是一个 HTML 文档。

HTML 与 XHTML 之间的差异

xmlns 属性在 XHTML 中是必需的，但在 HTML 中不是。不过，即使 XHTML 文档中的 <html> 没有使用此属性，W3C 的验证器也不会报错。这是因为 "xmlns=http://www.w3.org/1999/xhtml" 是一个固定值，即使您没有包含它，此值也会被添加到 <html> 标签中。

有关 xmlns 属性的更多信息。

例子

<html xmlns="http://www.w3.org/1999/xhtml">
<head>
</head>
<body>
  ...
  ...
  ...
</body>
</html>

可选的属性

属性 | 值 | 描述 | DTD
xmlns | http://www.w3.org/1999/xhtml | 定义 XML namespace 属性。 | STF

标准属性

dir, lang, xml:lang

如需完整的描述，请访问标准属性。

TIY 实例

一个简单的 HTML 文件
这个例子是一个很简单的 HTML 文件，使用了尽量少的 HTML 标签。它向您演示了 body 元素中的内容是如何被浏览器显示的。

HTML 参考手册
HTML 实例
HTML 测验


HTML <iframe> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <iframe> 标签

定义和用法

iframe 元素会创建一个包含另外一个文档的内联框架。

HTML 与 XHTML 之间的差异

NONE

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 | 值 | 描述 | DTD
align
  • left
  • right
  • top
  • middle
  • bottom
 规定如何根据周围的文本来排列此框架。 TF
frameborder
  • 1
  • 0
 规定是否显示框架的边框。 TF
height
  • pixels
  • %
 定义 iframe 的高度。 TF
longdesc | URL | 描述此框架内容的长描述的URL。 | TF
marginheight | pixels | 定义 iframe 的顶部和底部的边距。 | TF
marginwidth | pixels | 定义 iframe 的左侧和右侧的边距。 | TF
name | frame_name | 规定 iframe 的唯一名称 （以便在脚本中使用）。 | TF
scrolling
  • yes
  • no
  • auto
 定义滚动条。 TF
src | URL | 在 iframe 中显示文档的 URL。 | TF
width
  • pixels
  • %
 定义 iframe 的宽度。 TF

标准属性

id, class, title, style

如需完整的描述，请访问标准属性。

TIY 实例

内联框架
本例演示如何创建内联框架（HTML 页中的框架）。

HTML 参考手册
HTML 实例
HTML 测验


HTML <img> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <img> 标签

定义和用法

img 元素可定义一副图像。

HTML 与 XHTML 之间的差异

在 HTML 中，<img> 标签没有结束标签。

在 XHTML 中，<img> 标签必须被正确地关闭。

在 HTML 4.01 中，image 元素的"align"、"border"、"hspace" 以及 "vspace" 是不被赞成使用的。

在 XHTML 1.0 Strict DTD 中，image 元素的 "align"、"border"、"hspace" 以及 "vspace" 是不被支持的。

Mozilla Firefox 和 alt 属性

如果您在 Firefox 中使用 alt 属性，那么当鼠标悬浮在图片或图像地图时不会像其他的浏览器那样出现提示文本。

Firefox 使用 alt 属性的方式与此属性被预想的方式是一致的，比如假如图像没有载入时出现的替代文本，而不是 mouse-over 文本。

如果您在 <img> 标签中使用 title 属性，那么 Firefox 不会支持图像或图像地图之上的 mouse-over 注释。

例如，<img src="image.gif" alt="bla" title="bla bla bla" />

例子

<img src="angry.gif" alt="Angry" />

必需的属性

DTD指示此属性允许在哪种DTD中使用。S=Strict, T=Transitional, F=Frameset.

属性 | 值 | 描述 | DTD
alt | text | 定义图像的简短描述（即图像的替代文本）。不超过 1024 个字符。 | STF
src | URL | 所显示图像的 URL。 | STF

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 | 值 | 描述 | DTD
align
  • top
  • bottom
  • middle
  • left
  • right
 规定如何根据周围的文本来排列图像。 TF
border | pixels | 定义图像周围的边框。 | TF
height
  • pixels
  • %
 定义图像的高度。 STF
hspace | pixels | 定义图像左侧和右侧的空白。 | TF
ismap | URL | 定义作为服务器端图像映射的一幅图像。有关 ismap 属性的详细信息。 | STF
longdesc | URL | 指向包含长的图像描述文档的 URL。 | STF
usemap URL

定义作为客户端图像映射的一幅图像。有关 usemap 属性的详细信息。

请参阅 <map> 和 <area> 标签，以领会其工作原理。

 STF
vspace | pixels | 定义图像顶部和底部的空白。 | TF
width
  • pixels
  • %
 设置图像的宽度。 STF

标准属性

id, class, title, style, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

插入图像
本例演示如何在网页中显示图像。
从不同的位置插入图片
本例演示如何将其他文件夹或服务器的图片显示到网页中。
背景图片
本例演示如何添加背景图片到HTML页面。
排列图片
本例演示如何在文字中排列图像。
浮动图像
本例演示如何使图片浮动至段落的左边或右边。
调整图像尺寸
本例演示如何将图片调整到不同的尺寸。
为图片显示替换文本
本例演示如何为图片显示替换文本。在浏览器无法载入图像时，替换文本属性告诉读者她们失去的信息。为页面上的图像都加上替换文本属性是个好习惯。
制作图像链接
本例演示如何将图像作为一个链接使用。
创建图像地图
本例显示如何创建带有可供点击区域的图像地图。其中的每个区域都是一个超级链接。

HTML 参考手册
HTML 实例
HTML 测验


HTML <img> 标签的 ismap 和 usemap 属性

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <img> 标签的 ismap 和 usemap 属性

<img> 标签的 ismap 和 usemap 属性告诉浏览器这个图像是一个特殊的可视映射，可以通过鼠标来对一个或多个超链接进行选择，也就是通常所说的图像映射（image map）。

ismap 属性

图像映射的 ismap 样式被称为 “服务器端”图像映射，它只可以用在 <a> 标签标识的超链接里面。

请看下面的例子：

<a href="/example/map">
  <img src="/i/map.gif" ismap="ismap" />
</a>

当用户在 ismap 图像上单击了某处时，浏览器会自动把鼠标的 x、y 位置（相对于图像的左上角）发送到服务器端。特殊的服务器端软件（在本例中是 /example/map 程序）可以根据这些坐标来做出响应。

usemap 属性

usemap 属性提供了一种“客户端”的图像映射机制，有效地消除了服务器端对鼠标坐标的处理，以及由此带来的网络延迟问题。通过特殊的 <map> 和 <area> 标签，HTML 创作者可以提供一个描述 usemap 图像中超链接敏感区域坐标的映射，这个映射同时包含相应的超链接 URL。usemap 属性的值是一个 URL，它指向特殊的 <map> 区域。用户计算机上的浏览器将把鼠标在图像上单击时的坐标转换成特定的行为，包括加载和显示另外一个文档。

我们举例说明一下，下面这段源代码将一个 100x100 像素的图像 map.gif 映射为 4 个区域，当用户单击其中某一个区域时，将被链接到不同的文档中。请注意，在这个 <img> 标签中，我们已经有效地包含了对 ismap 图像映射的处理功能，这样，那些使用不具有 usemap 处理功能的浏览器用户，就可以通过另外一中途径，即服务器端机制来处理图像映射：

<a href="/example/map">
  <img src="/i/map.gif" ismap="ismap" usemap="#map" />
</a>

<map name="map">
  <area coords="0,0,49,49" href="link1.html">
  <area coords="50,0,99,49" href="link2.html">
  <area coords="0,50,49,99" href="link3.html">
  <area coords="50,50,99,99" href="link4.html">
</map>

ismap 属性和 usemap 属性的应用差异

地图就是很好地应用 ismap 和 usemap 属性的一个示例，例如，在浏览一家全国范围的大公司网页时，用户可能会在地图上单击他们所居住的城市，以获得附近地区零售店的地址和电话号码等。

usemap 客户端处理图像映射的好处是，它不要求有服务器或特殊的服务器软件，与 ismap 机制不同，它可以用在非 web （无网络）环境中，例如在本地的文件或者 CD-ROM 中使用。

HTML 参考手册
HTML 实例
HTML 测验


HTML <input> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <input> 标签

定义和用法

<input> 标签可定义输入域的开始，在其中用户可输入数据。

对于大量通常的表单控件，可以使用 <input> 标签来进行定义，其中包括文本字段、多选列表、可单击的图像和提交按钮等。

虽然 <input> 标签中有许多属性，但是对每个元素来说，只有 type 属性和 name 属性是必需的（提交或重置按钮只有 type 属性）。

HTML 与 XHTML 之间的差异

在 HTML 中，<input> 标签没有结束标签。

在 XHTML 中，<input> 标签必须被正确地关闭。

提示和注释：

注释：input 元素是空的，它仅包含属性。

提示：请使用 label 元素为某个表单控件定义标签。

必需的属性

属性 值 描述 DTD
type
  • button
  • checkbox
  • file
  • hidden
  • image
  • password
  • radio
  • reset
  • submit
  • text

指示 input 元素的类型。默认值是 "text"。

注释：此属性不是必需的属性，但是我们认为应当包含此属性。如果被忽略，IE 5.5 会显示一个文本域，而 Netscape 4.7 不会。

 STF
name field_name

定义用于此 input 元素的唯一名称。

注释：此属性必需与 type="button"、type="checkbox"、type="file"、type="hidden"、type="image"、type="password"、type="text" 以及 type="radio" 一同使用。

 STF

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 | 值 | 描述 | DTD
accept | list_of_mime_types | 一个逗号分隔的 MIME 类型列表，指示文件传输的 MIME 类型。注释：仅可与 type="file" 配合使用。 | STF
align
  • left
  • right
  • top
  • texttop
  • middle
  • absmiddle
  • baseline
  • bottom
  • absbottom

定义图像之后的文本的排列。

注释：仅可与 type="image" 配合使用。

 TF
alt text

定义图像的替代文本。

注释：仅可与 type="image" 配合使用。

 STF
checked checked

指示此 input 元素首次加载时应当被选中。

注释：请与 type="checkbox" 及 type="radio" 配合使用。

 STF
disabled disabled

当 input 元素首次加载时禁用此元素，这样用户就无法在其中写文本，或选定它。

注释：不能与 type="hidden" 一同使用。

 STF
maxlength number

定义在某个文本域中所允许的最大字符数。

注释：仅可与 type="text" 配合使用。

 STF
readonly readonly

指示此域的值不能被修改。

注释：仅可与 type="text" 配合使用。

 STF
size number_of_char

定义 input 元素的尺寸。

注释：不能与 type="hidden" 一同使用。

 STF
src URL

定义所显示图像的URL

注释：仅可与 type="image" 一同使用。

 STF
value value

对于按钮、重置按钮和确认按钮：定义按钮上的文本。

对于图像按钮：定义传递向某个脚本的此域的符号结果。

对于复选框和单选按钮：定义 input 元素被点击时的结果。

对于隐藏域、密码域以及文本域：定义元素的默认值。

注释：不能与 type="file" 一同使用。

注释：与 type="checkbox" 和 type="radio" 一同使用时，此元素是必需的。

 STF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

tabindex, accesskey, onfocus, onblur, onselect, onchange,
onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

文本域(Text fields)
本例演示如何在 HTML 页面创建文本域。用户可以在文本域写入文本。
密码域
本例演示如何创建 HTML 的密码域。
复选框
本例演示如何在 HTML 页中创建文本框。用户可以选中或取消选取复选框。
单选按钮
本例演示如何在 HTML 中创建单选按钮。
简单的下拉列表
本例演示如何在 HTML 页面中创建简单的下拉列表框。下拉列表框是一个可选列表。
另一个下拉列表
本例演示如何创建一个简单的带有预选值的下拉列表。（译者注：预选值指预先指定的首选项。）
文本域(Textarea)
本例演示如何创建一个文本域（多行文本输入控制）。用户可以在文本域中写入文本。在文本域中，可写入的字符字数不受限制。
创建按钮
本例演示如何创建按钮。你可以对按钮上的文字进行自定义。
围绕数据的Fieldset
本例演示如何在数据周围绘制一个带标题的框。
带有输入框和确认按钮的表单
本例演示如何向页面添加表单。此表单包含两个输入框和一个确认按钮。
带有复选框的表单
此表单包含两个复选框和一个确认按钮。
带有单选按钮的表单
此表单包含两个单选框和一个确认按钮。
从表单发送电子邮件
此例演示如何从表单发送电子邮件。

HTML 参考手册
HTML 实例
HTML 测验


HTML <ins> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <ins> 标签

定义和用法

定义一个被插入的文本。

HTML 与 XHTML 之间的差异

NONE

提示和注释：

注释：请与 <del> 一同使用，来描述对文档的更新和修正。

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 | 值 | 描述 | DTD
cite | URL | 指向另外一个文档的 URL，此文档可解释文本被插入的原因。 | STF
datetime | YYYYMMDD | 定义文本被插入的日期和时间。 | STF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

删除字效果和插入字效果
此例演示如何标示删除文本和插入文本。

HTML 参考手册
HTML 实例
HTML 测验


HTML <label> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <label> 标签

定义和用法

向控件定义标注（标记）。如果您在 label 元素内点击文本，就会触发此控件。就是说，当用户选择该标签时，浏览器就会自动将焦点转到和标签相关的表单控件上。

HTML 与 XHTML 之间的差异

NONE

提示和注释：

注释："for" 属性可把 label 绑定到另外一个元素。请把 "for" 属性的值设置为相关元素的 id 属性的值。

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 | 值 | 描述 | DTD
for | id_of_another_field | 定义 label 针对哪个表单元素。设置为某个表单元素的 id。 注释：如果此属性未被规定，那么 label 会关联其内容。 | STF

隐式和显式的联系

标记通常以下面两种方式中的一种来和表单控件相联系：将表单控件作为标记标签的内容，这样的就是隐式形式，或者为 <label> 标签下的 for 属性命名一个目标表单 id，这样就是显式形式。

例如，在 XHTML 中：

<label for="SSN">Social Security Number:</label>
<input type="text" name="SocSecNum" id="SSn" />
<label>Date of Birth: <input type="text" name="DofB" /></label>

第一个标记是以显式形式将文本 "Social Security Number:" 和表单的社会安全号码的文本输入控件 ("SocSecNum") 联系起来，它的 for 属性的值和控件的 id 一样，都是 SSN。第二个标记 ("Date of Birth:") 不需要 for 属性，它的相关控件也不需要 id 属性，它们是通过在 <label> 标签中放入 <input> 标签来隐式地连接起来的。

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

accesskey, onfocus, onblur, onclick, ondblclick, onmousedown, onmouseup,
onmouseover, onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

label
如何为控件定义标记。

HTML 参考手册
HTML 实例
HTML 测验


HTML <legend> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <legend> 标签

定义和用法

legend 元素可为 fieldset 定义一个标题。

实例

<fieldset>
<legend>Health information:</legend>
<form>
<label>Height: <input type="text" /></label>
<label>Weight: <input type="text" /></label>
</form>
</fieldset>

HTML 与 XHTML 之间的差异

在 HTML 4.01 中，align 属性不被赞成使用。

在 XHTML 1.0 Strict DTD 中，align 属性不被支持。

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 值 描述 DTD
align
  • top
  • bottom
  • left
  • right
 为 fieldset 中的内容定义排列方式。默认值是 Top。 TF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

accesskey, onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

围绕数据的 Fieldset
本例演示如何在数据周围绘制一个带标题的框。

HTML 参考手册
HTML 实例
HTML 测验


HTML <li> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <li> 标签

定义和用法

<li> 标签定义了列表项目。<li> 标签可用在有序列表 (<ol>) 和无序列表 (<ul>) 中。

HTML 与 XHTML 之间的差异

在 HTML 4.01 中，li 元素的 "type" 和 "value" 属性是不被赞成使用的。

在 XHTML 1.0 Strict DTD 中，li 元素的 "type" 和 "value" 属性是不被支持的。

提示和注释：

注释：请使用样式来定义列表的类型。

例子

<ol>
   <li>Coffee</li>
   <li>Tea</li>
</ol>

<ul>
   <li>Coffee</li>
   <li>Tea</li>
</ul>

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 | 值 | 描述 | DTD
type
  • A
  • a
  • I
  • i
  • 1
  • disc
  • square
  • circle
 规定列表的类型。不赞成使用。请使用样式替代。 TF
value | number_of_list_item | 不赞成使用。请使用样式替代。 | TF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

一个无序列表
本例演示一个无序列表。
不同类型的无序列表
本例演示不同类型的无序列表。
一个有序列表
本例演示一个有序列表。
不同类型的有序列表
本例演示不同类型的有序列表。
嵌套列表
本例演示如何嵌套列表。
嵌套列表 2
本例演示更复杂的嵌套列表。

HTML 参考手册
HTML 实例
HTML 测验


HTML <link> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <link> 标签

定义和用法

此元素定义了当前文档与 Web 集合中其他文档的关系。

HTML 与 XHTML 之间的差异

在 HTML 中，<link> 标签没有结束标签。

在 XHTML 中，<link> 标签必须被正确的关闭。

提示和注释：

注释：link 元素是空元素，它仅包含属性。

注释：此元素只能存在于 head 部分，不过它可出现任何次数。

例子

<head>
<link rel="stylesheet" type="text/css" href="theme.css"   />
</head>

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 | 值 | 描述 | DTD
charset | charset | 定义目标 URL 的字符编码方式。默认值是 "ISO-8859-1"。 | STF
href | URL | 目标文档或资源的 URL。 | STF
hreflang | language_code | 定义目标 URL 的基准语言。 | STF
media
  • screen
  • tty
  • tv
  • projection
  • handheld
  • print
  • braille
  • aural
  • all
 规定文档将显示在什么设备上。 STF
rel
  • alternate
  • appendix
  • bookmark
  • chapter
  • contents
  • copyright
  • glossary
  • help
  • home
  • index
  • next
  • prev
  • section
  • start
  • stylesheet
  • subsection
 定义当前文档与目标文档之间的关系。 STF
rev
  • alternate
  • appendix
  • bookmark
  • chapter
  • contents
  • copyright
  • glossary
  • help
  • home
  • index
  • next
  • prev
  • section
  • start
  • stylesheet
  • subsection
 定义目标文档与当前文档之间的关系。 STF
target
  • _blank
  • _parent
  • _self
  • _top

在何处打开目标 URL:

  • _blank - 在一个新的未命名的窗口载入文档
  • _self - 在相同的框架或窗口中载入目标文档
  • _parent - 把文档载入父窗口或包含了超链接引用的框架的框架集
  • _top - 把文档载入包含该超链接的窗口,取代任何当前正在窗口中显示的框架
 TF
title | 字符串 | 为要链接的文档指定标题。在引用不带有标题的源（例如图像或非 HTML 文档）时，该属性非常有用。在这种情况下，浏览器会在显示被引用的文档时使用 <link> 标题。 | STF
type

MIME_type

比如：

  • text/css
  • text/javascript
  • image/gif
 规定目标 URL 的 MIME 类型。 STF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

链接到一个外部样式表
本例演示如何 <link> 标签链接到一个外部样式表。

HTML 参考手册
HTML 实例
HTML 测验


HTML <map> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <map> 标签

定义和用法

定义一个客户端图像映射。图像映射（image-map）指带有可点击区域的一幅图像。

HTML 与 XHTML 之间的差异

NONE

提示和注释：

注释：area 元素永远嵌套在 map 元素内部。area 元素可定义图像映射中的区域。

注释：<img>中的 usemap 属性可引用 <map> 中的 id 或 name 属性（取决于浏览器），所以我们应同时向 <map> 添加 id 和 name 属性。

必需的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 | 值 | 描述 | DTD
id | unique_name | 为 map 标签定义唯一的名称。 | STF

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 | 值 | 描述 | DTD
name | unique_name | 为 map 标签定义唯一的名称（用于向后兼容）。 | STF

标准属性

class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

tabindex, accesskey, onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup, onfocus, onblur

如需完整的描述，请访问事件属性。

TIY 实例

创建图像地图
本例显示如何创建带有可点击区域的图像地图。其中的每个区域都是一个超级链接。

HTML 参考手册
HTML 实例
HTML 测验


HTML <menu> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <menu> 标签

定义和用法

<menu> 标签可定义一个菜单列表。

HTML 与 XHTML 之间的差异

在 HTML 4.01 中，menu 元素不被赞成使用。

在 XHTML 1.0 Strict DTD 中，menu 元素不被支持。

提示和注释：

提示：请使用 CSS 样式来定义列表的类型！

例子

<menu>
<li>html</li>
<li>xhtml</li>
</menu>

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 | 值 | 描述 | DTD
compact | compact_rendering | Deprecated. Use styles instead | TF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onfocus, onblur, onmousedown, onmouseup,
onmouseover, onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

HTML 参考手册
HTML 实例
HTML 测验


HTML <meta> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <meta> 标签

定义和用法

<meta> 元素可提供有关页面的元信息（meta-information），比如针对搜索引擎和更新频度的描述和关键词。

<meta> 标签位于文档的头部，不包含任何内容。<meta> 标签的属性定义了与文档相关联的名称/值对。

HTML 与 XHTML 之间的差异

在 HTML 中，<meta> 标签没有结束标签。

在 XHTML 中，<meta> 标签必须被正确地关闭。

提示和注释：

注释：<meta> 标签永远位于 head 元素内部。

注释：元数据总是以名称/值的形式被成对传递的。

必需的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 | 值 | 描述 | DTD
content | some_text | 定义与 http-equiv 或 name 属性相关的元信息 | STF

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 | 值 | 描述 | DTD
http-equiv
  • content-type
  • expires
  • refresh
  • set-cookie
 把 content 属性关联到 HTTP 头部。 STF
name
  • author
  • description
  • keywords
  • generator
  • revised
  • others
 把 content 属性关联到一个名称。 STF
scheme | some_text | 定义用于翻译 content 属性值的格式。 | STF

name 属性

name 属性提供了名称/值对中的名称。HTML 和 XHTML 标签都没有指定任何预先定义的 <meta> 名称。通常情况下，您可以自由使用对自己和源文档的读者来说富有意义的名称。

"keywords" 是一个经常被用到的名称。它为文档定义了一组关键字。某些搜索引擎在遇到这些关键字时，会用这些关键字对文档进行分类。

类似这样的 meta 标签可能对于进入搜索引擎的索引有帮助：

<meta name="keywords" content="HTML,ASP,PHP,SQL"

如果没有提供 name 属性，那么名称/值对中的名称会采用 http-equiv 属性的值。

http-equiv 属性

http-equiv 属性为名称/值对提供了名称。并指示服务器在发送实际的文档之前先在要传送给浏览器的 MIME 文档头部包含名称/值对。

当服务器向浏览器发送文档时，会先发送许多名称/值对。虽然有些服务器会发送许多这种名称/值对，但是所有服务器都至少要发送一个：content-type:text/html。这将告诉浏览器准备接受一个 HTML 文档。

使用带有 http-equiv 属性的 <meta> 标签时，服务器将把名称/值对添加到发送给浏览器的内容头部。例如，添加：

<meta http-equiv="charset" content="iso-8859-1">
<meta http-equiv="expires" content="31 Dec 2008">

这样发送到浏览器的头部就应该包含：

content-type: text/html
charset:iso-8859-1
expires:31 Dec 2007

当然，只有浏览器可以接受这些附加的头部字段，并能以适当的方式使用它们时，这些字段才有意义。

content 属性

content 属性提供了名称/值对中的值。该值可以是任何有效的字符串。

content 属性始终要和 name 属性或 http-equiv 属性一起使用。

scheme 属性

scheme 属性用于指定要用来翻译属性值的方案。此方案应该在由 <head> 标签的 profile 属性指定的概况文件中进行了定义。

标准属性

dir, lang, xml:lang

如需完整的描述，请访问标准属性。

TIY 实例

文档描述
Meta 元素中的信息可以描述 HTML 文档。
文档关键字
Meta 元素中的信息可以描述文档的关键词。
重定向
这个例子演示：在网址已经变更的情况下，将用户重定向到另外一个地址。

HTML 参考手册
HTML 实例
HTML 测验


HTML <noframes> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <noframes> 标签

定义和用法

noframes 元素可为那些不支持框架的浏览器显示文本。noframes 元素位于 frameset 元素内部。

HTML 与 XHTML 之间的差异

NONE

提示和注释：

注释：如果浏览器有能力处理框架，就不会显示出 frameset 元素中的文本。

重要事项：如果您希望 frameset 添加 <noframes> 标签，就必须报其中的文本包装在 <body></body> 标签中！

注释：如果您希望验证包含框架的页面，请确保 DTD 被设置为 "Frameset DTD"。

阅读更多有关 XHTML 验证的内容。

注释：在XHTML 1.0 Strict DTD 中，<noframes> 标签是不被允许的。

例子

<frameset cols = "25%, 25%,*">
  <noframes>
  <body>Your browser does not handle frames!</body>
  </noframes>
  <frame src ="venus.htm" />
  <frame src   ="sun.htm" />
  <frame src ="mercur.htm"   />
</frameset>

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

TIY 实例

如何使用 <noframes> 标签
本例演示：如何使用 <noframes> 标签。

HTML 参考手册
HTML 实例
HTML 测验


HTML <noscript> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <noscript> 标签

定义和用法

noscript 元素用来定义在脚本未被执行时的替代内容（文本）。

此标签可被用于可识别 <script> 标签但无法支持其中的脚本的浏览器。

HTML 与 XHTML 之间的差异

NONE

提示和注释：

注释：如果浏览器支持脚本，那么它不会显示出 noscript 元素中的文本。

注释：无法识别 <script> 标签的浏览器会把标签的内容显示到页面上。为了避免浏览器这样做，您应当在注释标签中隐藏脚本。老式的（无法识别 <script> 标签的）浏览器会忽略注释，这样就不会把标签的内容写到页面上，而新式的浏览器则懂得执行这些脚本，即使它们被包围在注释标签中！

例子

JavaScript

<body>
  ...
  ...

  <script type="text/javascript">
    <!--
    document.write("Hello World!")
    //-->
  </script>

  <noscript>Your browser does not support JavaScript!</noscript>
  ...
  ...
</body>

VBScript

<body>
  ...
  ...
  <script type="text/vbscript">
   <!--
   document.write("Hello World!")
   '-->
  </script>

  <noscript>Your browser does not support VBScript!</noscript>
  ...
  ...
</body>

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

TIY 实例

运行于不支持脚本的浏览器
本例演示如何对付不支持脚本的浏览器。

HTML 参考手册
HTML 实例
HTML 测验


HTML <object> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <object> 标签

定义和用法

定义一个嵌入的对象。请使用此元素向您的 XHTML 页面添加多媒体。此元素运行您规定插入 HTML 文档中的对象的数据和参数，以及可用来显示和操作数据的代码。

HTML 与 XHTML 之间的差异

NONE

提示和注释：

注释：object 元素可位于在 head 元素或 body 元素内部。<object> 与 </object> 之间的文本是替换文本，针对不支持此标签的浏览器。<param> 标签可定义用于对象的 run-time 设置。

注释：至于图像，请使用 <img> 标签代替 <object> 标签。

可选的属性

属性 | 值 | 描述 | DTD
align
  • left
  • right
  • top
  • bottom
 定义围绕该对象的文本对齐方式。 TF
archive | URL | 一个空格分隔的指向档案文件的 URL 列表。这些档案文件包含了与对象相关的资源。有关 archive 属性的详细信息。 | STF
border | pixels | 定义对象周围的边框。 | TF
classid class ID

定义嵌入 Windows Registry 中或某个 URL 中的类的 ID 值，此属性可用来指定浏览器中包含的对象的位置，通常是一个 Java 类。

有关 classid 属性的详细信息。

 STF
codebase URL

定义在何处可找到对象所需的代码，提供一个基准 URL。

有关 codebase 属性的详细信息。

 STF
codetype MIME type

通过 classid 属性所引用的代码的 MIME 类型。

有关 codetype 属性的详细信息。

 STF
data URL

定义引用对象数据的 URL。如果有需要对象处理的数据文件,要用 data 属性来指定这些数据文件。

有关 data 属性的详细信息。

 STF
declare declare

可定义此对象仅可被声明，但不能被创建或例示，直到此对象得到应用为止。

有关 declare 属性的详细信息。

 STF
height | pixels | 定义对象的高度。 | STF
hspace | pixels | 定义对象周围水平方向的空白。 | TF
name | unique_name | 为对象定义唯一的名称（以便在脚本中使用）。 | STF
standby | text | 定义当对象正在加载时所显示的文本。 | STF
type | MIME_type | 定义被规定在 data 属性中指定的文件中出现的数据的 MIME 类型。 | STF
usemap | URL | 规定与对象一同使用的客户端图像映射的 URL。 | STF
vspace | pixels | 定义对象的垂直方向的空白。 | TF
width | pixels | 定义对象的宽度。 | STF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

accesskey, tabindex, onclick, ondblclick, onmousedown, onmouseup,
onmouseover, onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

HTML 参考手册
HTML 实例
HTML 测验


HTML <object> 标签的重要属性

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <object> 标签的重要属性

archive 属性

因为性能方面的原因，可以选择预先下载包含一个或多个档案中的对象集。对基于 Java 的应用程序来说尤其是这样，在这些应用程序中，一个 Java 类将会依赖于很多其他类才能完成它的工作。

archive 属性的值是一个用引号括起来的 URL 列表，其中每个 URL 都指向一个在显示或执行对象之前浏览器需要加载的档案文件。

classid 属性

classid 属性用于指定浏览器中包含的对象的位置，通常是一个 Java 类。

它的值是对象的绝对或相对的 URL。如果提供了 codebase 属性的话，相对 URL 是相对于 codebase 属性指定的 URL 而言的；否则，它们是相对于当前文档的 URL。

例如，为了执行包含在 clock.class 文件中的时间 Java applet，可以在 HTML 文档中包含如下的代码：

<object classid="clock.class"></object>

浏览器将会用当前文档的基本 URL 为这个 applet 查找代码。因此，如果当前文档的 URL 如下所示：

http://www.w3school.com.cn/time.html

浏览器将会在下列地址为我们的 clock.class 实例获取 applet 代码：

http://www.w3school.com.cn/clock.class

提示：classid 属性与 <applet> 标签的 code 属性类似，提供了包含这个对象的文件名。

codebase 属性

codebase 属性是一个可选的属性，提供了一个基本的 URL。该属性的值是一个 URL，该 URL 指向的目录包含了 classid 属性所引用的对象。

codebase URL 会覆盖文档的基本 URL，但不会永久替代它。如果不使用 codebase 属性，这个基本 URL 就是默认值。

现在，我们继续使用前面的那个例子，假设文档来源于 http://www.w3school.com.cn，但是这个时钟 applet 放在一个名为 classes 的单独目录中。通过指定 classid= "classes/clock.class" 无法获得这个 applet。相反，需要将 codebase 属性和新的基本 URL 包含在内：

<object classid="clock.class" codebase="http://www.w3school.com.cn/classes/">
</object>

这行语句可以解析为这个 URL：

http://www.w3school.com.cn/classes/clock.class

尽管我们在此例中使用了绝对 URL，实际上也可以使用相对 URL。例如，applet 往往和主机文档一起保存在同一台服务器上，因此，处于重新定位的缘故，为 codebase 指定一个相对的 URL，情况往往更好一些，例如：

<object classid="clock.class" codebase="/classes/">
</object>

提示：从以上几个例子可以看到，codebase 属性与 classid 属性配合使用，可以指定对象的完整 URL。

codetype 属性

codetype 属性用于标识程序代码类型。

只有在浏览器无法根据 classid 属性决定 applet 的 MIME 类型，或者如果在下载某个对象时服务器没有传输正确的 MIME 类型的情况下，才需要使用 codetype 属性。

codetype 属性与 type 属性类似。不同的是，它用来标识程序代码类型，而 type 属性用来标识数据文件类型。

下面这个例子显式地告知浏览器，对象的代码是 Java：

<object codebase="clock.class" codetype="application/java">
</object>

declare 属性

declare 属性可以定义一个对象，但同时防止浏览器进行下载和处理。

与 name 属性一起使用时，这个工具类似于更为传统的编程语言中的某种前置声明，这样的声明能够延迟下载对象的时间，直到这个对象确实在文档中得到了应用。

data 属性

data 属性用于指定供对象处理的数据文件的 URL。

该属性的值是文件的 URL，该 URL 可能是相对于文件基本 URL 的绝对 URL 或相对 URL，或者是相对于用 codebase 属性提供的 URL 的绝对或相对 URL。

浏览器通过插入到文档中的对象类型来决定数据的类型。

该属性类似于 <img> 标签中的 src 属性，因为它下载的是要由包含对象进行处理的数据。当然，它们之间的差别在于，data 属性允许包含几乎任何文件类型，而不仅仅是图像文件。

HTML 参考手册
HTML 实例
HTML 测验


HTML <ol> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <ol> 标签

定义和用法

<ol> 标签定义了有序列表。

HTML 与 XHTML 之间的差异

在 HTML 4.01 中，ol 元素的 "compact"、"start" 以及 "type" 属性是不被赞成使用的。

在 XHTML 1.0 Strict DTD 中，ol 元素的 "compact"、"start" 以及 "type" 属性是不被支持的。

提示和注释：

注释：请使用样式来定义列表的类型。

例子

<ol>
   <li>Coffee</li>
   <li>Tea</li>
</ol>

可选的属性

属性 | 值 | 描述 | DTD
compact | compact_rendering | 不赞成使用。请使用样式代替。 | TF
start | start_on_number | 规定起始数字。不赞成使用。请使用样式代替。 | TF
type
  • A
  • a
  • I
  • i
  • 1
 规定列表的类型。不赞成使用。请使用样式代替。 TF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

有序列表
本例演示一个有序列表。
不同类型的有序列表
本例演示不同类型的有序列表。

HTML 参考手册
HTML 实例
HTML 测验


HTML <optgroup> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <optgroup> 标签

定义和用法

定义选项组。此元素允许您组合选项。当您使用一个长的选项列表时，对相关的选项进行组合会使处理更加容易。

HTML 与 XHTML 之间的差异

NONE

例子

<select>
      <optgroup label="Swedish Cars">
      <option value ="volvo">Volvo</option>
      <option value ="saab">Saab</option>
      </optgroup>

      <optgroup label="German Cars">
      <option value ="mercedes">Mercedes</option>
      <option value ="audi">Audi</option>
      </optgroup>
</select>

必需的属性

属性 | 值 | 描述 | DTD
label | text_label | 定义选项组的标记 | STF

可选的属性

属性 | 值 | 描述 | DTD
disabled | disabled | 当选项组首次加载时，禁用此选项组 | STF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

tabindex, onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

HTML 参考手册
HTML 实例
HTML 测验


HTML <option> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <option> 标签

定义和用法

option 元素可定义下拉列表中的一个选项（一个条目）。

浏览器将 <option> 标签中的内容作为 <select> 标签的菜单或是滚动列表中的一个元素显示。

HTML 与 XHTML 之间的差异

在 HTML 中，<option> 没有结束标签。

在 XHTML 中，<option> 必须被正确关闭。

提示和注释：

注释：<option> 标签可以在不带有任何属性的情况下使用，但是您通常需要使用 value 属性，此属性会指示出被送往服务器的内容。

注释：请与 select 元素配合使用此标签，否则这个标签是没有意义的。

例子

<select>
  <option value="volvo">Volvo</option>
  <option value="saab">Saab</option>
  <option value="opel" selected="selected">Opel</option>
  <option value="audi">Audi</option>
</select>

可选的属性

属性 | 值 | 描述 | DTD
disabled | disabled | 规定此选项应在首次加载时被禁用。 | STF
label | text | 定义当使用 <optgroup> 时所使用的标注。 | STF
selected | selected | 规定选项（在首次显示在列表中时）表现为选中状态。 | STF
value | text | 定义送往服务器的选项值。 | STF

标准属性

id, class, title, style, dir, lang, xml:lang, tabindex

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

简单的下拉列表
本例演示如何在 HTML 页面中创建简单的下拉列表框。下拉列表框是一个可选列表。
另一个下拉列表
本例演示如何创建一个简单的带有预选值的下拉列表。（注：预选值指预先指定的首选项。）

HTML 参考手册
HTML 实例
HTML 测验


HTML <p> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <p> 标签

定义和用法

<p> 标签可定义一个段落。

HTML 与 XHTML 之间的差异

在 HTML 4.01 中，所有 p 元素的呈现属性均不被赞成使用。

在 XHTML 1.0 Strict DTD 中，所有 p 元素的呈现属性均不被支持。

例子

<p>This is some text in a very short paragraph</p>

可选的属性

属性 值 描述 DTD
align
  • left
  • right
  • center
  • justify
 规定段落中文本的排列方式。 TF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

简单的段落
此例演示：段落元素中的文字如何被浏览器显示。
更多的段落
本例演示段落元素的某些缺省的行为。
“诗歌”问题
本例演示 HTML 格式化的某些问题。

HTML 参考手册
HTML 实例
HTML 测验


HTML <param> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <param> 标签

定义和用法

param 元素允许您为插入 XHTML 文档的对象规定 run-time 设置，也就是说，此标签可为包含它的 <object> 或者 <applet> 标签提供参数。

HTML 与 XHTML 之间的差异

在 HTML 中，<param> 标签没有结束标签。

在 XHTML 中，<param> 标签必须被正确地关闭。

必需的属性

属性 | 值 | 描述 | DTD
name | unique_name | 定义参数的唯一的名称（唯一标识符） | STF

可选的属性

属性 | 值 | 描述 | DTD
name | unique_name | 定义参数的唯一的名称（唯一标识符） | STF
type | MIME type | 规定参数的 MIME 类型（internet media type）。 | STF
value | value | 规定参数的值。 | STF
valuetype
  • data
  • ref
  • object
 规定值的 MIME 类型。 STF

标准属性

id

如需完整的描述，请访问标准属性。

HTML 参考手册
HTML 实例
HTML 测验


HTML <pre> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <pre> 标签

定义和用法

pre 元素可定义预格式化的文本。被包围在 pre 元素中的文本通常会保留空格和换行符。而文本也会呈现为等宽字体。

<pre> 标签的一个常见应用就是用来表示计算机的源代码。

提示和注释

制表符（tab）在 <pre> 标签定义的块当中可以起到应有的作用，每个制表符占据 8 个字符的位置。但是我们不推荐使用它，因为在不同的浏览器中，Tab 的实现各不相同。在用 <pre> 标签格式化的文档段中使用空格，可以确保文本正确的水平位置。

HTML 与 XHTML 之间的差异

在 HTML 4.01 中，pre 元素的 "width" 属性是不被赞成使用的。

在 XHTML 1.0 Strict DTD 中，pre 元素的 "width" 属性是不被支持的。

可选的属性

属性 | 值 | 描述 | DTD
width | number | 定义每行的最大字符数（通常是 40、80 或 132）。 | TF

标准属性

id, class, title, style, dir, lang, xml:lang, xml:space

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

预格式文本
此例演示如何使用pre标签对空行和空格进行控制。

HTML 参考手册
HTML 实例
HTML 测验


HTML <q> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <q> 标签

定义和用法

<q> 标签可定义一个短的引用。

HTML 与 XHTML 之间的差异

NONE

提示和注释：

注释：根据 HTML 4.01 规范，q 元素应当使用分界引号来呈现，就就是说，q 元素包含的文本必须以引号来开始和结束。Mozilla 浏览器 (Firefox) 以及 Opera 符合这个规定，但是 Internet Explorer 却不支持此规定。

提示：<q> 标签在本质上与 <blockquote> 是一样的。不同之处在于它们的显示和应用。<q> 标签用于简短的行内引用。

可选的属性

属性 | 值 | 描述 | DTD
cite | citation | 定义引用的出处或来源（citation） | STF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

引用
此例演示如何实现长短不一的引用语。

HTML 参考手册
HTML 实例
HTML 测验


HTML <s> 和 <strike> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <s> 和 <strike> 标签

定义和用法

<s> 和 <strike> 标签可定义加删除线文本定义。

HTML 与 XHTML 之间的差异

在 HTML 4.01 中，<s> 和 <strike> 标签不被赞成使用。

在 XHTML 1.0 Strict DTD 中，<s> 和 <strike> 标签不被支持。

提示和注释：

注释：请使用 <del> 替代它！

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

块引用
此例演示如何实现长短不一的引用语。

HTML 参考手册
HTML 实例
HTML 测验


HTML <script> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <script> 标签

定义和用法

定义一段诸如 JavaScript 的脚本。

HTML 与 XHTML 之间的差异

在 HTML 4.01 中，script 元素的 "language" 属性不被赞成使用。

在 XHTML 1.0 Strict DTD 中，script 元素的 "language" 属性不被支持。

提示和注释：

注释：假如此元素内部的代码没有位于某个函数中，那么这些代码会在页面被加载时被立即执行。<frameset> 标签之后的脚本会被忽略。

例子

<script type="text/javascript">
document.write("Hello World!")
</script>

必选的属性

属性 值 描述 DTD
type
  • text/ecmascript
  • text/javascript
  • application/ecmascript
  • application/javascript
  • text/vbscript
 指示脚本的 MIME 类型。有关 type 属性的详细信息。 STF

可选的属性

属性 | 值 | 描述 | DTD
charset | charset | 定义用在脚本中的字符编码。 | STF
defer | defer | 指示脚本不会生成任何的文档内容。浏览器可以继续解析并绘制页面。 | STF
language
  • javascript
  • livescript
  • vbscript
  • other
 规定脚本语言。不赞成使用。请使用 type 属性代替它。 TF
src | URL | 定义指向包含脚本的文件的 URL（这样您就可以引用某个包含脚本的文件，而不是直接把脚本插入您的 HTML 文档中）。 | STF

标准属性

xml:space

如需完整的描述，请访问标准属性。

事件属性

NONE

如需完整的描述，请访问事件属性。

TIY 实例

插入一段脚本
本例演示如何将脚本插入 HTML 文档。
运行于不支持脚本的浏览器
本例演示如何对付不支持脚本的浏览器。

HTML 参考手册
HTML 实例
HTML 测验


HTML <script> 标签的属性

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <script> 标签的属性

type 和 language 属性

type 和 language 属性都可用来指定 <script> 标签中的脚本的类型。

language 属性在 HTML 和 XHTML 标准中受到了非议，这两个标准提倡使用 type 属性。遗憾的是，这两个属性的值是不一样的。

如果您在使用 JavaScript，可以使用下面两种属性：

language = "JavaScript"

或者：

type = "text/javascript"

您可能偶尔会看见 language 的值为 VBScript（对 type 而言是 text/vbscript），表示包含的脚本代码是用 Microsoft 的 Visual Basic Script 编写的。

利用 JavaScript，您还可以使用 language 的值 "JavaScript 1.1"，表示包含的脚本语句只能被 Netscape 3.0 或更新的版本处理。Netscape 2.0 只支持 JavaScript 1.0，而无法处理标记为 "JavaScript 1.1" 的脚本。

提示：如果您希望学习有关 JavaScript 和 VBScript 的知识，请访问我们的 JavaScript 教程和 VBScript 教程。

src 和 charset 属性

对特别长的 JavaScript 程序或者经常重复使用的程序来说，你可以希望将这些代码存放到一个单独的文件中。在这样的情况下，让浏览器通过 src 属性来载入那个单独的文件。

src 的值是包含这个 JavaScript 程序的文件的 URL。保存的文件的 MIME 类型应是 application/x-javascript，但如果文件名的后缀为 .js，也能够被正确配置了的服务器进行恰当的处理。

例如下面的语句：

<script type="text/javascript" src="/w3school.com.cn/abc.js">....</script>

上面的例子告诉支持 <script> 的浏览器从服务器上下载名为 abc.js 的 JavaScript 程序。

重要事项：请注意，尽管<script> 标签没有内容，结束的 </script> 标签也是必需的。

charset 属性与 src 属性一起使用，告诉浏览器用来编码这个 javascript 程序的字符集。它的值是任何一个 ISO 标准字符集编码的名称。

defer 属性

有的 javascript 脚本 document.write 方法来创建当前的文档内容，其他脚本就不一定是了。

如果您的脚本不会改变文档的内容，可将 defer 属性加入到 <script> 标签中，以便加快处理文档的速度。因为浏览器知道它将能够安全地读取文档的剩余部分而不用执行脚本，它将推迟对脚本的解释，直到文档已经显示给用户为止。

返回 HTML <script> 标签

HTML 参考手册
HTML 实例
HTML 测验


HTML <select> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <select> 标签

定义和用法

select 元素可创建单选或多选菜单。

当提交表单时，浏览器会提交选定的项目，或者收集用逗号分隔的多个选项，将其合成一个单独的参数列表，并且在将 <select> 表单数据提交给服务器时包括 name 属性。

HTML 与 XHTML 之间的差异

NONE

提示和注释：

提示：请在 form 元素中使用此标签来接受用户的输入。

例子

<select>
  <option value ="volvo">Volvo</option>
  <option value ="saab">Saab</option>
  <option value="opel">Opel</option>
  <option value="audi">Audi</option>
</select>

可选的属性

属性 | 值 | 描述 | DTD
disabled | disabled | 当设置此属性时，会禁用该菜单。 | STF
multiple | multiple | 当设置此属性时，会规定可同时选定多个项目。 | STF
name | unique_name | 定义下拉列表的唯一标识符。 | STF
size | number | 定义菜单中可见项目的数目。 | STF

标准属性

id, class, title, style, dir, lang, xml:lang, accesskey, tabindex

如需完整的描述，请访问标准属性。

事件属性

onfocus, onblur, onchange

如需完整的描述，请访问事件属性。

TIY 实例

简单的下拉列表
本例演示如何在HTML页面中创建简单的下拉列表框。下拉列表框是一个可选列表。
另一个下拉列表
本例演示如何创建一个简单的带有预选值的下拉列表。（译者注：预选值指预先指定的首选项。）

HTML 参考手册
HTML 实例
HTML 测验


HTML <span> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <span> 标签

定义和用法

<span> 标签被用来组合文档中的行内元素。

HTML 与 XHTML 之间的差异

NONE

提示和注释：

提示：请使用 <span> 来组合行内元素，以便通过样式来格式化它们。

注释：span 没有固定的格式表现。当对它应用样式时，它才会产生视觉上的变化。

例子

<p><span>some text.</span>some other text.</p>

例子解释

如果不对 span 应用样式，那么 span 元素中的文本与其他文本不会任何视觉上的差异。尽管如此，上例中的 span 元素仍然为 p 元素增加了额外的结构。

可以为 span 应用 id 或 class 属性，这样既可以增加适当的语义，又便于对 span 应用样式。

可以对同一个 <span> 元素应用 class 或 id 属性，但是更常见的情况是只应用其中一种。这两者的主要差异是，class 用于元素组（类似的元素，或者可以理解为某一类元素），而 id 用于标识单独的唯一的元素。

提示：事实上，您允许已经注意到了，W3School 站点上有一些文本的样式与其他文本是不同的。比如“提示”使用了粗体的橘红色。尽管实现这种效果的方法非常多，但是我们的做法是：使用“提示”使用 span 元素，然后对这个 span 元素的父元素，即 p 元素应用 class，这样就可以对这个类的子元素 span 应用相应的样式了。

HTML:

<p class="tip"><span>提示：</span>... ... ...</p>

CSS:

p.tip span {
    font-weight:bold;
    color:#ff9955;
    }

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

HTML 参考手册
HTML 实例
HTML 测验


HTML <style> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <style> 标签

定义和用法

style 元素位于 head 部分中。

如果您希望在页面中包含样式表，您应当在外部定义样式表，并使用 link 标签来链接它。

HTML 与 XHTML 之间的差异

NONE

提示和注释：

注释：如需学习更多有关样式表的知识，请访问我们的 CSS 教程。

例子

<head>

<style type="text/css">
h1 {color: red}
h2 {color: blue}
</style>

</head>

必需的属性

属性 | 值 | 描述 | DTD
type | text/css | 定义内容类型。 | STF

可选的属性

属性 值 描述 DTD
media
  • screen
  • tty
  • tv
  • projection
  • handheld
  • print
  • braille
  • aural
  • all
 此样式信息的目标媒介。 STF

标准属性

title, dir, lang, xml:space

如需完整的描述，请访问标准属性。

TIY 实例

HTML中的样式
本例演示如何使用添加到 <head> 部分的样式信息对 HTML 进行格式化。
没有下划线的链接
本例演示如何使用样式属性做一个没有下划线的链接。
链接到一个外部样式表
本例演示如何<link>标签链接到一个外部样式表。

HTML 参考手册
HTML 实例
HTML 测验


HTML <sub> 和 <sup> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <sub> 和 <sup> 标签

定义和用法

<sub> 标签可定义下标文本。<sup> 可定义上标文本。

HTML 与 XHTML 之间的差异

NONE

例子

这段文本包含 <sub>下标</sub>

这段文本包含 <sup>上标</sup>

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

上标和下标
本例演示如何使用 sup 和 sub 元素。

HTML 参考手册
HTML 实例
HTML 测验


HTML <table> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <table> 标签

定义和用法

<table> 标签可定义表格。在 <table> 标签内部，你可以放置表格的标题、表格行、表格列、表格单元以及其他的表格。

HTML 与 XHTML 之间的差异

在 HTML 4.01 中，table 元素的 "align" 和 "bgcolor" 属性是不被赞成使用的。

在 XHTML 1.0 Strict DTD，table 元素的 "align" 和 "bgcolor" 属性是不被支持的。

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 | 值 | 描述 | DTD
align
  • left
  • center
  • right
 排列表格。不赞成使用。请使用样式取而代之。 TF
bgcolor
  • rgb(x,x,x)
  • #xxxxxx
  • colorname
 规定表格的背景颜色。不赞成使用。请使用样式取而代之。 TF
border pixels

规定表格边框的宽度。

提示：可通过设置 border="0" 来显示无边框的表格！

 STF
cellpadding
  • pixels
  • %
 规定单元边沿与其内容之间的空白。 STF
cellspacing
  • pixels
  • %
 规定单元格之间的空白。 STF
frame
  • void
  • above
  • below
  • hsides
  • lhs
  • rhs
  • vsides
  • box
  • border

规定表格周围的哪一侧的边框是可见的。

注释："border" 属性可与 "frame" 属性配合使用，来规定边框的宽度！

 STF
rules
  • none
  • groups
  • rows
  • cols
  • all

规定水平或垂直的分界线。

注释：必须与 "border" 属性配合使用！

 STF
summary | text | 为语音合成/非视觉浏览器规定表格的摘要。 | STF
width
  • %
  • pixels
 规定表格的宽度。 STF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

表格
这个例子演示如何在 HTML 文档中创建表格。
表格边框
本例演示各种类型的表格边框。
没有边框的表格
本例演示一个没有边框的表格。
表格中的标题(Headings)
本例演示如何显示表格标题。
空单元格
本例展示如何使用 "&nbsp;" 处理没有内容的单元格。
带有标题的表格
本例演示一个带标题 (caption) 的表格
跨行或跨列的表格单元格
本例演示如何定义跨行或跨列的表格单元格。
表格内的标签
本例演示如何在不同的元素内显示元素。
单元格填充(Cell padding)
本例演示如何使用单元格填充来创建单元格内容与其边框之间的空白。
单元格间距(Cell spacing)
本例演示如何使用单元格间距增加单元格之间的距离。
向表格添加背景颜色或背景图像
本例演示如何向表格添加背景
向表格单元添加背景颜色或者背景图像
本例演示如何向一个或者更多表格单元添加背景
在表格单元中排列内容
本例演示如何使用 "align" 属性排列单元格内容,以便创建一个美观的表格。
框架(frame)属性
本例演示如何使用 "frame" 属性来控制围绕表格的边框。

HTML 参考手册
HTML 实例
HTML 测验


HTML <tbody> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <tbody> 标签

定义和用法

定义一段表格主体（正文）。

使用 <tbody> 标签，可以将表格分为一个单独的部分。<tbody> 标签可将表格中的一行或几行合成一组。

虽然您可能想包括一个，甚至会在表格中包括两个或更多个 <tbody> 标签，但是我们建议最好在表格中没有 <tbody> 标签。

在 <tbody> 标签中，只有 <tr> 标签可以定义表格行。并且一旦定义，一个 <tbody> 标签就是表格中的一个独立的部分。例如不能从一个 <tbody> 跨越到另一个 <tbody> 中。

thead、tfoot 以及 tbody 元素使您有能力对表格中的行进行分组。当您创建某个表格时，您也许希望拥有一个标题行，一些带有数据的行，以及位于底部的一个总计行。这种划分使浏览器有能力支持独立于表格标题和页脚的表格正文滚动。当长的表格被打印时，表格的表头和页脚可被打印在包含表格数据的每张页面上。

HTML 与 XHTML 之间的差异

NONE

提示和注释：

注释：<thead> 内部必须拥有 <tr> 标签！

注释：如果您使用 thead、tfoot 以及 tbody 元素，您就必须使用全部的元素。它们的出现次序是：thead、tfoot、tbody，这样浏览器就可以在收到所有数据前呈现页脚了。您必须在 table 元素内部使用这些标签。

注释：<thead>、<tbody> 以及 <tfoot> 很少被使用，这是因为糟糕的浏览器支持。我们期望在 XHTML 的未来版本中这种情况会发生变化。假如您使用 Internet Explorer 5.0 或更新的浏览器，可以在我们的 XML 教程中查看一个例子。

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 值 描述 DTD
align
  • right
  • left
  • center
  • justify
  • char
 定义单元格内的文本排列方式。 STF
char character

规定根据哪个字符来进行文本对齐。

注释：仅当 align="char" 时使用！

 STF
charoff
  • pixels
  • %

规定第一个对齐字符的偏移量。

注释：仅当 align="char" 时使用！

 STF
valign
  • top
  • middle
  • bottom
  • baseline
 规定单元格内垂直的文本排列方式。 STF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

HTML 参考手册
HTML 实例
HTML 测验


HTML <td> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <td> 标签

定义和用法

定义表格中的一个单元格。

HTML 与 XHTML 之间的差异

在 HTML 4.01 中，td 元素的 "bgcolor"、"height"、"width" 以及 "nowrap" 是不被赞成使用的。

在 XHTML 1.0 Strict DTD 中，td 元素的 "bgcolor"、"height"、"width" 以及 "nowrap" 是不被支持的。

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 | 值 | 描述 | DTD
abbr | abbr_text | 规定单元格中内容的缩写版本。 | STF
align
  • left
  • right
  • center
  • justify
  • char
 规定单元格内容的水平排列方式。 STF
axis | category_names | 为单元格定义一个名字。有关 axis 属性的详细信息。 | STF
bgcolor
  • rgb(x,x,x)
  • #xxxxxx
  • colorname
 规定单元格的背景颜色。不赞成使用。请使用样式取而代之。 TF
char character

规定根据哪个字符来进行文本对齐。

注释：仅当 align="char" 时使用！

有关 char 和 charoff 属性的详细信息。

 STF
charoff pixels %

规定第一个对齐字符的偏移量。

注释：仅当 align="char" 时使用！

有关 char 和 charoff 属性的详细信息。

 STF
colspan | number | 规定此单元格可横跨的列数。 | STF
headers | header_cells'_id | 一个空格分隔的单元格 ID 列表，这些 ID 可为单元格提供表头的信息。此属性允许纯文本的浏览器为某个给定的单元格呈现表头信息。有关 headers 属性的详细信息。 | STF
height | pixels | 规定表格单元格的高度。不赞成使用。请使用样式取而代之。 | TF
nowrap | nowrap | 是否在此单元格中禁用或启用正文的文本环绕。不赞成使用。请使用样式取而代之。 | TF
rowspan | number | 规定此单元格可横跨的行数。 | STF
scope
  • col
  • colgroup
  • row
  • rowgroup

规定此单元格是否为以下部分提供表头信息：包含此单元格的行 row) 的其余部分，包含此单元格的列 (col) 的其余部分，包含此单元格的行组 (rowgroup) 的其余部分，包含此单元格的列组 (colgroup) 的其余部分。

有关 scope 属性的详细信息。

 STF
valign
  • top
  • middle
  • bottom
  • baseline
 规定单元格内容的垂直排列方式。 STF
width
  • pixels
  • %
 规定表格单元格的宽度。不赞成使用。请使用样式取而代之。 TF

char 和 charoff 属性

即使是最简单的文字处理器也允许在表格中排列十进制数字中的点。直到 HTML 4.0 标准的出现，网页设计语言一直不能充分满足这方面的要求。

现在，可以使用 char 属性，来指定表格行内单元格中的一个字母，这个字母就是对齐的中心线。不需要为 char 指定值。如果你没有指定的话，默认的字符是基于语言：例如，在英语中是一个句点，而在法语中是一个逗号。如果把一个单字符指定为 char 属性的值，则可以指定不同的对齐字符。

使用 charoff 属性和一个整数值可指定每行对齐字符第一次出现的偏移量。如果一行中不包括对齐字符，应该水平平移到对齐位置的最后。

char 和 charoff 属性在 HTML 4 和 XHTML 中是新出现的属性，还没有得到任何一个流行浏览器的支持。

headers 属性

headers 属性会将表格中的一个表头单元格和一个数据单元格联系起来。

这个属性的值是引号包括的一列名称，这些名称是用 id 属性定义的不同表头单元格的名称。

headers 属性对非可视化的浏览器，也就是那些在显示出相关数据单元格内容之前就显示表头单元格内容的浏览器非常有用。

scope 属性

使用 scope 属性，可以将数据单元格与表头单元格联系起来。

通过属性值 row，表头行包括的所有表格都将和表头单元格联系起来。指定 col，会将当前列的所有单元格和表头单元格绑定起来。

使用 rowgroup 和 colgroup 会将单元格的行组（由 <thead>、<tbody> 或 <tfoot> 标签定义）或列组中的所有单元格和表头单元格绑定起来（由 <col> 或 <colgroup> 标签定义）。

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

表格
这个例子演示如何在 HTML 文档中创建表格。
表格边框
本例演示各种类型的表格边框。
没有边框的表格
本例演示一个没有边框的表格。
表格中的标题(Headings)
本例演示如何显示表格标题。
空单元格
本例展示如何使用"&nbsp;"处理没有内容的单元格。
带有标题的表格
本例演示一个带标题(caption)的表格
跨行或跨列的表格单元格
本例演示如何定义跨行或跨列的表格单元格。
表格内的标签
本例演示如何显示在不同的元素内显示元素。
单元格填充(Cell padding)
本例演示如何使用单元格填充来创建单元格内容与其边框之间的空白。
单元格间距(Cell spacing)
本例演示如何使用单元格间距增加单元格之间的距离。
向表格添加背景颜色或背景图像
本例演示如何向表格添加背景
向表格单元添加背景颜色或者背景图像
本例演示如何向一个或者更多表格单元添加背景
在表格单元中排列内容
本例演示如何使用 "align" 属性排列单元格内容,以便创建一个美观的表格。
框架(frame)属性
本例演示如何使用 "frame" 属性来控制围绕表格的边框。

HTML 参考手册
HTML 实例
HTML 测验


HTML <textarea> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <textarea> 标签

定义和用法

定义一个文本区域 (text-area) （一个多行的文本输入区域）。用户可在此文本区域中写文本。在一个文本区中，您可输入无限数量的文本。文本区中的默认字体是等宽字体 (fixed pitch)。

注释：在文本输入区内的文本行间，用 "%OD%OA" （回车/换行）进行分隔。

提示：可以通过 <textarea> 标签的 wrap 属性设置文本输入区内的换行模式。有关 wrap 属性的详细信息。

HTML 与 XHTML 之间的差异

NONE

例子

<textarea rows="3" cols="30">
这里是文本域中的文本 ... ... ... ...
</textarea>

必需的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 | 值 | 描述 | DTD
cols | number | 规定文本区内可见的列数。 | STF
rows | number | 规定文本区内可见的行数。 | STF

可选的属性

DTD指示此属性允许在哪种DTD中使用。S=Strict, T=Transitional, and F=Frameset.

属性 | 值 | 描述 | DTD
disabled | disabled | 当此文本区首次加载时禁用此文本区。 | STF
name | name_of_textarea | 为此文本区规定一个名称。 | STF
readonly | readonly | 指明用户无法修改文本区内的内容。 | STF

标准属性

id, class, title, style, dir, lang, xml:lang, tabindex, accesskey

如需完整的描述，请访问标准属性。

事件属性

onfocus, onblur, onselect, onchange, onclick, ondblclick, onmousedown,
 onmouseup, onmouseover, onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

Textarea
如何创建 textarea。

HTML 参考手册
HTML 实例
HTML 测验


HTML <textarea> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <textarea> 标签的 wrap 属性

wrap 属性

通常情况下，当用户在输入文本区域中键入文本后，浏览器会将它们按照键入时的状态发送给服务器。只有用户按下 Enter 键的地方生成换行。

如果您希望启动自动换行功能（word wrapping），请将 wrap 属性设置为 virtual 或 physical。当用户键入的一行文本长于文本区的宽度时，浏览器会自动将多余的文字挪到下一行，在文字中最近的那一点换行。

wrap="virtual" 将实现文本区内的自动换行，以改善对用户的显示，但在传输给服务器时，文本只在用户按下 Enter 键的地方进行换行，其他地方没有换行的效果。

wrap="physical" 将实现文本区内的自动换行，并以这种形式传送给服务器，就像用户真的那样键入的。因为文本要以用户在文本区内看到的效果传输给服务器，因为使用自动换行是非常有用的方法。

如果把 wrap 设置为 off，将得到默认的动作。

例子

以下面这个例子为例,将 60 个字符的文本输入到一个 40 个字符宽的文本区域内：

word wrapping is  a feature that makes life easier for users.

如果设置为 wrap="wrap"，文本区会包含一行文本，用户必须将光标移动到右边才能看到全部文本，这时将把一行文本传送给服务器。

如果设置为 wrap="virtual"，文本区会包含两行文本，并在单词 "makes" 后面换行。但是只有一行文本被传送到服务器：没有嵌入新行字符。

如果设置为 wrap="physical"，文本区会包含两行文本，并在单词 "makes" 后面换行，这时发送给服务器两行文本，单词 "makes" 后的新行字符将分隔这两行文本。

HTML 参考手册
HTML 实例
HTML 测验


HTML <tfoot> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <tfoot> 标签

定义和用法

定义表格的页脚（脚注）。

thead、tfoot 以及 tbody 元素使您有能力对表格中的行进行分组。当您创建某个表格时，您也许希望拥有一个标题行，一些带有数据的行，以及位于底部的一个总计行。这种划分使浏览器有能力支持独立于表格标题和页脚的表格正文滚动。当长的表格被打印时，表格的表头和页脚可被打印在包含表格数据的每张页面上。

HTML 与 XHTML 之间的差异

NONE

提示和注释：

注释：<thead> 内部必须拥有 <tr> 标签！

注释：如果您使用 thead、tfoot 以及 tbody 元素，您就必须使用全部的元素。它们的出现次序是：thead、tfoot、tbody，这样浏览器就可以在收到所有数据前呈现页脚了。您必须在 table 元素内部使用这些标签。

注释：<thead>、<tbody> 以及 <tfoot> 很少被使用，这是因为糟糕的浏览器支持。我们期望在 XHTML 的未来版本中这种情况会发生变化。假如您使用 Internet Explorer 5.0 或更新的浏览器，可以在我们的 XML 教程中查看一个例子。

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 值 描述 DTD
align
  • right
  • left
  • center
  • justify
  • char
 定义单元格内的文本排列方式。 STF
char character

规定根据哪个字符来进行文本对齐。

注释：仅当 align="char" 时使用！

 STF
charoff
  • pixels
  • %

规定第一个对齐字符的偏移量。

注释：仅当 align="char" 时使用！

 STF
valign
  • top
  • middle
  • bottom
  • baseline
 规定单元格内垂直的文本排列方式。 STF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

HTML 参考手册
HTML 实例
HTML 测验


HTML <th> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <th> 标签

定义和用法

定义表格内的表头单元格。此 th 元素内部的文本通常会呈现为粗体。

HTML 与 XHTML 之间的差异

在 HTML 4.01 中，th 元素的 "bgcolor"、"height"、"width" 以及 "nowrap" 属性是不被赞成使用的。

在 XHTML 1.0 Strict DTD 中，th 元素的 "bgcolor"、"height"、"width" 以及 "nowrap" 属性是不被支持。

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 | 值 | 描述 | DTD
abbr | abbr_text | 规定一个单元格中内容的缩写版本。 | STF
align
  • left
  • right
  • center
  • justify
  • char
 规定单元格内容的水平排列方式。 STF
axis | category_names | 为单元格定义一个名称。 | STF
bgcolor
  • rgb(x,x,x)
  • #xxxxxx
  • colorname
 规定表格单元格的背景颜色。不赞成使用，请使用样式替代它。 TF
char character

规定哪个字符是最齐的中心线，例如将十进制数字对齐。

注释：仅当 align="char" 时使用。

 STF
charoff
  • pixels
  • %

规定每行对齐字符第一次出现的偏移量，如果一行中不包含对齐字符，应该水平平移到对齐位置的最后。

注释：仅当 align="char" 时使用。

 STF
colspan | number | 指明此单元格可横跨的列数 | STF
headers | header_cells'_id | 一个空格分隔的单元格ID列表，这些ID可为单元格提供表头的信息。此属性允许纯文本的浏览器为某个给定的单元格呈现表头信息。 | STF
height | pixels | 规定表格单元格的高度。Deprecated. Use styles instead. | TF
nowrap | nowrap | 是否在此单元格中禁用或启用正文的文本环绕。Deprecated. Use styles instead. | TF
rowspan | number | 指明此单元格可横跨的行数。 | STF
scope
  • col
  • colgroup
  • row
  • rowgroup

规定此单元格是否为以下部分提供表头信息：包含此单元格的行(row)的其余部分，包含此单元格的列(col)的其余部分，包含此单元格的行组(rowgroup)的其余部分，包含此单元格的列组(colgroup)的其余部分。

 STF
valign
  • top
  • middle
  • bottom
  • baseline
 规定单元格内容的垂直排列 STF
width
  • pixels
  • %
 规定表格单元格的宽度。Deprecated. Use styles instead. TF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

表格
这个例子演示如何在HTML文档中创建表格。
表格边框
本例演示各种类型的表格边框。
没有边框的表格
本例演示一个没有边框的表格。
表格中的标题(Headings)
本例演示如何显示表格标题。
空单元格
本例展示如何使用"&nbsp;"处理没有内容的单元格。
带有标题的表格
本例演示一个带标题(caption)的表格
跨行或跨列的表格单元格
本例演示如何定义跨行或跨列的表格单元格。
表格内的标签
本例演示如何显示在不同的元素内显示元素。
单元格填充(Cell padding)
本例演示如何使用单元格填充来创建单元格内容与其边框之间的空白。
单元格间距(Cell spacing)
本例演示如何使用单元格间距增加单元格之间的距离。
向表格添加背景颜色或背景图像
本例演示如何向表格添加背景
向表格单元添加背景颜色或者背景图像
本例演示如何向一个或者更多表格单元添加背景
在表格单元中排列内容
本例演示如何使用"align"属性排列单元格内容,以便创建一个美观的表格。
框架(frame)属性
本例演示如何使用"frame"属性来控制围绕表格的边框。

HTML 参考手册
HTML 实例
HTML 测验


HTML <thead> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <thead> 标签

定义和用法

定义表格的表头。

thead、tfoot 以及 tbody 元素使您有能力对表格中的行进行分组。当您创建某个表格时，您也许希望拥有一个标题行，一些带有数据的行，以及位于底部的一个总计行。这种划分使浏览器有能力支持独立于表格标题和页脚的表格正文滚动。当长的表格被打印时，表格的表头和页脚可被打印在包含表格数据的每张页面上。

HTML 与 XHTML 之间的差异

NONE

提示和注释：

注释：<thead> 内部必须拥有 <tr> 标签！

注释：如果您使用 thead、tfoot 以及 tbody 元素，您就必须使用全部的元素。它们的出现次序是：thead、tfoot、tbody，这样浏览器就可以在收到所有数据前呈现页脚了。您必须在 table 元素内部使用这些标签。

注释：<thead>、<tbody> 以及 <tfoot> 很少被使用，这是因为糟糕的浏览器支持。我们期望在 XHTML 的未来版本中这种情况会发生变化。假如您使用 Internet Explorer 5.0 或更新的浏览器，可以在我们的 XML 教程中查看一个例子。

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 值 描述 DTD
align
  • right
  • left
  • center
  • justify
  • char
 定义单元格内的文本排列方式。 STF
char character

规定根据哪个字符来进行文本对齐。

注释：仅当 align="char" 时使用！

 STF
charoff
  • pixels
  • %

规定第一个对齐字符的偏移量。

注释：仅当 align="char" 时使用！

 STF
valign
  • top
  • middle
  • bottom
  • baseline
 规定单元格内垂直的文本排列方式。 STF

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

HTML 参考手册
HTML 实例
HTML 测验


HTML <title> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <title> 标签

定义和用法

此元素可定义文档的标题。

HTML 与 XHTML 之前的差异

NONE

例子

<html>

  <head>
    <title>XHTML Tag   Reference</title>
  </head>

  <body>
    The content of the document......
  </body>

</html>

标准属性

id, class, dir, lang, style, xml:lang

如需完整的描述，请访问标准属性。

HTML 参考手册
HTML 实例
HTML 测验


HTML <tr> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <tr> 标签

定义和用法

在表格中定义一行。

HTML 与 XHTML 之间的差异

在 HTML 4.01 中，tr 元素的 "bgcolor" 是不被赞成使用的。

在 XHTML 1.0 Strict DTD 中，tr 元素的 "bgcolor" 是不被支持的。

例子

<table border = "1">
<tr>
<td>Cell A</td>
<td>Cell B</td>
</tr>
</table>

可选的属性

DTD 指示此属性允许在哪种 DTD 中使用。S=Strict, T=Transitional, F=Frameset.

属性 值 描述 DTD
align
  • right
  • left
  • center
  • justify
  • char
 定义单元格中的文本排列 STF
bgcolor
  • rgb(x,x,x)
  • #xxxxxx
  • colorname
 规定表格单元格的背景颜色。不赞成使用。请使用样式取而代之。 TF
char character

规定根据哪个字符来进行文本对齐。

注释：仅当 align="char" 时使用！

有关 char 和 charoff 属性的详细信息。

 STF
charoff
  • pixels
  • %

规定第一个对齐字符的偏移量。

注释：仅当 align="char" 时使用！

有关 char 和 charoff 属性的详细信息。

 STF
valign
  • top
  • middle
  • bottom
  • baseline
 规定单元格中文本的垂直排列方式。 STF

char 和 charoff 属性

即使是最简单的文字处理器也允许在表格中排列十进制数字中的点。直到 HTML 4.0 标准的出现，网页设计语言一直不能充分满足这方面的要求。

现在，可以使用 char 属性，来指定表格行内单元格中的一个字母，这个字母就是对齐的中心线。不需要为 char 指定值。如果你没有指定的话，默认的字符是基于语言：例如，在英语中是一个句点，而在法语中是一个逗号。如果把一个单字符指定为 char 属性的值，则可以指定不同的对齐字符。

使用 charoff 属性和一个整数值可指定每行对齐字符第一次出现的偏移量。如果一行中不包括对齐字符，应该水平平移到对齐位置的最后。

char 和 charoff 属性在 HTML 4 和 XHTML 中是新出现的属性，还没有得到任何一个流行浏览器的支持。

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

表格
这个例子演示如何在 HTML 文档中创建表格。
表格边框
本例演示各种类型的表格边框。
没有边框的表格
本例演示一个没有边框的表格。
表格中的标题(Headings)
本例演示如何显示表格标题。
空单元格
本例展示如何使用"&nbsp;"处理没有内容的单元格。
带有标题的表格
本例演示一个带标题(caption)的表格
跨行或跨列的表格单元格
本例演示如何定义跨行或跨列的表格单元格。
表格内的标签
本例演示如何显示在不同的元素内显示元素。
单元格填充(Cell padding)
本例演示如何使用单元格填充来创建单元格内容与其边框之间的空白。
单元格间距(Cell spacing)
本例演示如何使用单元格间距增加单元格之间的距离。
向表格添加背景颜色或背景图像
本例演示如何向表格添加背景
向表格单元添加背景颜色或者背景图像
本例演示如何向一个或者更多表格单元添加背景
在表格单元中排列内容
本例演示如何使用 "align" 属性排列单元格内容,以便创建一个美观的表格。
框架(frame)属性
本例演示如何使用 "frame" 属性来控制围绕表格的边框。

HTML 参考手册
HTML 实例
HTML 测验


HTML <tt> <i> <b> <big> <small> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <tt> <i> <b> <big> <small> 标签

定义和用法

以下的元素均是字体样式元素.它们不被赞成使用,通过使用样式表会取得更加多样的效果。

<tt> | 呈现类似打字机或者等宽的文本效果。
<i> | 显示斜体文本效果。
<b> | 呈现粗体文本效果。
<big> | 呈现大号字体效果。
<small> | 呈现小号字体效果。

HTML 与 XHTML 之间的差异

无。

标准属性

id, class, title, style, dir, lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown onkeyup

如需完整的描述，请访问事件属性。

TIY 实例

文本格式化
此例演示如何在一个 HTML 文件中对文本进行格式化

HTML 参考手册
HTML 实例
HTML 测验


HTML <u> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <u> 标签

定义和用法

<u> 标签可定义下划线文本。

HTML 与 XHTML 之间的差异

在 HTML 4.01 中，u 元素是不被赞成使用的。

在 XHTML 1.0 Strict DTD 中，u 元素是不被支持的。

提示和注释：

注释：请尽量避免为文本加下划线 - 用户会把它混淆为一个超链接！

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
 onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

HTML 参考手册
HTML 实例
HTML 测验


HTML <ul> 标签

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML <ul> 标签

定义和用法

<ul> 标签定义了无序列表。

HTML 与 XHTML 之间的差异

在 HTML 4.01 中，ul 元素的 "compact" 和 "type" 属性是不被赞成使用的。

在 XHTML 1.0 Strict DTD 中，ul 元素的 "compact" 和 "type" 属性是不被支持的。

提示和注释：

提示：请使用样式来定义列表的类型。

例子

<ul>
<li>Coffee</li>
<li>Tea</li>
</ul>

标准属性

id, class, title, style, dir, lang, xml:lang

如需完整的描述，请访问标准属性。

事件属性

onclick, ondblclick, onmousedown, onmouseup, onmouseover,
onmousemove, onmouseout, onkeypress, onkeydown, onkeyup

如需完整的描述，请访问事件属性。

HTML 列表实例

一个无序列表
本例演示一个无序列表。
不同类型的无序列表
本例演示不同类型的无序列表。
嵌套列表
本例演示如何嵌套列表。
嵌套列表 2
本例演示更复杂的嵌套列表。

HTML 参考手册
HTML 实例
HTML 测验


HTML Latin-1 字符实体

参考手册

  • 标签列表（字母排序）
  • 标签列表（功能排序）
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML Latin-1
  • HTML 符号
  • HTML URL 编码
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML Latin-1 字符实体

  • Previous Page
  • Next Page

HTML 4.01 支持 ISO 8859-1 (Latin-1) 字符集。

ISO-8859-1 的较低部分（从 1 到 127 之间的代码）是最初的 7 比特 ASCII。

ISO-8859-1 的较高部分（从 160 到 255 之间的代码）全都有实体名称。

这些符号中的大多数都可以在不进行实体引用的情况下使用，但是实体名称或实体编号为那些不容易通过键盘键入的符号提供了表达的方法。

注释：实体名称对大小写敏感。

带有实体名称的 ASCII 实体

结果 | 描述 | 实体名称 | 实体编号
" | quotation mark | &quot; | &#34;
' | apostrophe | &apos; | &#39;
& | ampersand | &amp; | &#38;
< | less-than | &lt; | &#60;
> | greater-than | &gt; | &#62;

ISO 8859-1 符号实体

结果 | 描述 | 实体名称 | 实体编号
 | non-breaking space | &nbsp; | &#160;
¡ | inverted exclamation mark | &iexcl; | &#161;
¢ | cent | &cent; | &#162;
£ | pound | &pound; | &#163;
¤ | currency | &curren; | &#164;
¥ | yen | &yen; | &#165;
¦ | broken vertical bar | &brvbar; | &#166;
§ | section | &sect; | &#167;
¨ | spacing diaeresis | &uml; | &#168;
© | copyright | &copy; | &#169;
ª | feminine ordinal indicator | &ordf; | &#170;
« | angle quotation mark (left) | &laquo; | &#171;
¬ | negation | &not; | &#172;
 | soft hyphen | &shy; | &#173;
® | registered trademark | &reg; | &#174;
¯ | spacing macron | &macr; | &#175;
° | degree | &deg; | &#176;
± | plus-or-minus | &plusmn; | &#177;
² | superscript 2 | &sup2; | &#178;
³ | superscript 3 | &sup3; | &#179;
´ | spacing acute | &acute; | &#180;
µ | micro | &micro; | &#181;
¶ | paragraph | &para; | &#182;
· | middle dot | &middot; | &#183;
¸ | spacing cedilla | &cedil; | &#184;
¹ | superscript 1 | &sup1; | &#185;
º | masculine ordinal indicator | &ordm; | &#186;
» | angle quotation mark (right) | &raquo; | &#187;
¼ | fraction 1/4 | &frac14; | &#188;
½ | fraction 1/2 | &frac12; | &#189;
¾ | fraction 3/4 | &frac34; | &#190;
¿ | inverted question mark | &iquest; | &#191;
× | multiplication | &times; | &#215;
÷ | division | &divide; | &#247;

ISO 8859-1 字符实体

结果 | 描述 | 实体名称 | 实体编号
À | capital a, grave accent | &Agrave; | &#192;
Á | capital a, acute accent | &Aacute; | &#193;
Â | capital a, circumflex accent | &Acirc; | &#194;
Ã | capital a, tilde | &Atilde; | &#195;
Ä | capital a, umlaut mark | &Auml; | &#196;
Å | capital a, ring | &Aring; | &#197;
Æ | capital ae | &AElig; | &#198;
Ç | capital c, cedilla | &Ccedil; | &#199;
È | capital e, grave accent | &Egrave; | &#200;
É | capital e, acute accent | &Eacute; | &#201;
Ê | capital e, circumflex accent | &Ecirc; | &#202;
Ë | capital e, umlaut mark | &Euml; | &#203;
Ì | capital i, grave accent | &Igrave; | &#204;
Í | capital i, acute accent | &Iacute; | &#205;
Î | capital i, circumflex accent | &Icirc; | &#206;
Ï | capital i, umlaut mark | &Iuml; | &#207;
Ð | capital eth, Icelandic | &ETH; | &#208;
Ñ | capital n, tilde | &Ntilde; | &#209;
Ò | capital o, grave accent | &Ograve; | &#210;
Ó | capital o, acute accent | &Oacute; | &#211;
Ô | capital o, circumflex accent | &Ocirc; | &#212;
Õ | capital o, tilde | &Otilde; | &#213;
Ö | capital o, umlaut mark | &Ouml; | &#214;
Ø | capital o, slash | &Oslash; | &#216;
Ù | capital u, grave accent | &Ugrave; | &#217;
Ú | capital u, acute accent | &Uacute; | &#218;
Û | capital u, circumflex accent | &Ucirc; | &#219;
Ü | capital u, umlaut mark | &Uuml; | &#220;
Ý | capital y, acute accent | &Yacute; | &#221;
Þ | capital THORN, Icelandic | &THORN; | &#222;
ß | small sharp s, German | &szlig; | &#223;
à | small a, grave accent | &agrave; | &#224;
á | small a, acute accent | &aacute; | &#225;
â | small a, circumflex accent | &acirc; | &#226;
ã | small a, tilde | &atilde; | &#227;
ä | small a, umlaut mark | &auml; | &#228;
å | small a, ring | &aring; | &#229;
æ | small ae | &aelig; | &#230;
ç | small c, cedilla | &ccedil; | &#231;
è | small e, grave accent | &egrave; | &#232;
é | small e, acute accent | &eacute; | &#233;
ê | small e, circumflex accent | &ecirc; | &#234;
ë | small e, umlaut mark | &euml; | &#235;
ì | small i, grave accent | &igrave; | &#236;
í | small i, acute accent | &iacute; | &#237;
î | small i, circumflex accent | &icirc; | &#238;
ï | small i, umlaut mark | &iuml; | &#239;
ð | small eth, Icelandic | &eth; | &#240;
ñ | small n, tilde | &ntilde; | &#241;
ò | small o, grave accent | &ograve; | &#242;
ó | small o, acute accent | &oacute; | &#243;
ô | small o, circumflex accent | &ocirc; | &#244;
õ | small o, tilde | &otilde; | &#245;
ö | small o, umlaut mark | &ouml; | &#246;
ø | small o, slash | &oslash; | &#248;
ù | small u, grave accent | &ugrave; | &#249;
ú | small u, acute accent | &uacute; | &#250;
û | small u, circumflex accent | &ucirc; | &#251;
ü | small u, umlaut mark | &uuml; | &#252;
ý | small y, acute accent | &yacute; | &#253;
þ | small thorn, Icelandic | &thorn; | &#254;
ÿ | small y, umlaut mark | &yuml; | &#255;
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验

W3School提供的内容仅用于培训。我们不保证内容的正确性。通过使用本站内容随之而来的风险与本站无关。当使用本站时，代表您已接受了本站的使用条款和隐私条款。

版权所有，保留一切权利。未经书面许可，不得转载。W3School(s)简体中文版授权上海蒙信网络科技有限公司在中华人民共和国运营。


HTML URL 编码

参考手册

  • 标签列表（字母排序）
  • 标签列表（功能排序）
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML Latin-1
  • HTML 符号
  • HTML URL 编码
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML URL 编码

  • Previous Page
  • Next Page

下面是用 URL 编码形式表示的 ASCII 字符（十六进制格式）。

十六进制格式用于在浏览器和插件中显示非标准的字母和字符。

URL 编码 - 从 %00 到 %8f

ASCII Value | URL-encode | ASCII Value | URL-encode | ASCII Value | URL-encode
æ | %00 | 0 | %30 | ` | %60
 | %01 | 1 | %31 | a | %61
 | %02 | 2 | %32 | b | %62
 | %03 | 3 | %33 | c | %63
 | %04 | 4 | %34 | d | %64
 | %05 | 5 | %35 | e | %65
 | %06 | 6 | %36 | f | %66
 | %07 | 7 | %37 | g | %67
backspace | %08 | 8 | %38 | h | %68
tab | %09 | 9 | %39 | i | %69
linefeed | %0a | : | %3a | j | %6a
 | %0b | ; | %3b | k | %6b
 | %0c | < | %3c | l | %6c
c return | %0d | = | %3d | m | %6d
 | %0e | > | %3e | n | %6e
 | %0f | ? | %3f | o | %6f
 | %10 | @ | %40 | p | %70
 | %11 | A | %41 | q | %71
 | %12 | B | %42 | r | %72
 | %13 | C | %43 | s | %73
 | %14 | D | %44 | t | %74
 | %15 | E | %45 | u | %75
 | %16 | F | %46 | v | %76
 | %17 | G | %47 | w | %77
 | %18 | H | %48 | x | %78
 | %19 | I | %49 | y | %79
 | %1a | J | %4a | z | %7a
 | %1b | K | %4b | { | %7b
 | %1c | L | %4c | | | %7c
 | %1d | M | %4d | } | %7d
 | %1e | N | %4e | ~ | %7e
 | %1f | O | %4f |  | %7f
space | %20 | P | %50 | € | %80
! | %21 | Q | %51 |  | %81
" | %22 | R | %52 | ‚ | %82
# | %23 | S | %53 | ƒ | %83
$ | %24 | T | %54 | „ | %84
% | %25 | U | %55 | … | %85
& | %26 | V | %56 | † | %86
' | %27 | W | %57 | ‡ | %87
( | %28 | X | %58 | ˆ | %88
) | %29 | Y | %59 | ‰ | %89
* | %2a | Z | %5a | Š | %8a
+ | %2b | [ | %5b | ‹ | %8b
, | %2c | \ | %5c | Œ | %8c
- | %2d | ] | %5d |  | %8d
. | %2e | ^ | %5e | Ž | %8e
/ | %2f | _ | %5f |  | %8f

URL 编码 - 从 %90 到 %ff

ASCII Value | URL-encode | ASCII Value | URL-encode | ASCII Value | URL-encode
 | %90 | À | %c0 | ð | %f0
‘ | %91 | Á | %c1 | ñ | %f1
’ | %92 | Â | %c2 | ò | %f2
“ | %93 | Ã | %c3 | ó | %f3
” | %94 | Ä | %c4 | ô | %f4
• | %95 | Å | %c5 | õ | %f5
– | %96 | Æ | %c6 | ö | %f6
— | %97 | Ç | %c7 | ÷ | %f7
˜ | %98 | È | %c8 | ø | %f8
™ | %99 | É | %c9 | ù | %f9
š | %9a | Ê | %ca | ú | %fa
› | %9b | Ë | %cb | û | %fb
œ | %9c | Ì | %cc | ü | %fc
 | %9d | Í | %cd | ý | %fd
ž | %9e | Î | %ce | þ | %fe
Ÿ | %9f | Ï | %cf | ÿ | %ff
 | %a0 | Ð | %d0 |  |
¡ | %a1 | Ñ | %d1 |  |
¢ | %a2 | Ò | %d2 |  |
£ | %a3 | Ó | %d3 |  |
 | %a4 | Ô | %d4 |  |
¥ | %a5 | Õ | %d5 |  |
| | %a6 | Ö | %d6 |  |
§ | %a7 |  | %d7 |  |
¨ | %a8 | Ø | %d8 |  |
© | %a9 | Ù | %d9 |  |
ª | %aa | Ú | %da |  |
« | %ab | Û | %db |  |
¬ | %ac | Ü | %dc |  |
¯ | %ad | Ý | %dd |  |
® | %ae | Þ | %de |  |
¯ | %af | ß | %df |  |
° | %b0 | à | %e0 |  |
± | %b1 | á | %e1 |  |
² | %b2 | â | %e2 |  |
³ | %b3 | ã | %e3 |  |
´ | %b4 | ä | %e4 |  |
µ | %b5 | å | %e5 |  |
¶ | %b6 | æ | %e6 |  |
· | %b7 | ç | %e7 |  |
¸ | %b8 | è | %e8 |  |
¹ | %b9 | é | %e9 |  |
º | %ba | ê | %ea |  |
» | %bb | ë | %eb |  |
¼ | %bc | ì | %ec |  |
½ | %bd | í | %ed |  |
¾ | %be | î | %ee |  |
¿ | %bf | ï | %ef |  |
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验

W3School提供的内容仅用于培训。我们不保证内容的正确性。通过使用本站内容随之而来的风险与本站无关。当使用本站时，代表您已接受了本站的使用条款和隐私条款。

版权所有，保留一切权利。未经书面许可，不得转载。W3School(s)简体中文版授权上海蒙信网络科技有限公司在中华人民共和国运营。


HTML xmlns 属性

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

HTML xmlns 属性

xmlns 属性

xmlns 属性可以在文档中定义一个或多个可供选择的命名空间。该属性可以放置在文档内任何元素的开始标签中。该属性的值类似于 URL，它定义了一个命名空间，浏览器会将此命名空间用于该属性所在元素内的所有内容。

例如，如果需要使用符合 XML 规范的 XHTML 文档，则应该在文档中的<html> 标签中至少使用一个 xmlns 属性，以指定整个文档所使用的主要命名空间：

<html xmlns="http://www.w3.org/1999/xhtml">

如果需要在一个 div 元素中显示一串数学公式，则可以为该 div 元素定义一个数学命名空间。比如这样：

<div xmlns="http://www.w3.org/1999/Math/MathMl">x3/x</div>

如果您不希望在每次显示除法公式时都在 div 元素中定义 xmlns 属性，那么更好的办法是在文档的开头处定义具有前缀的命名空间：

<html xmlns="http://www.w3.org/1999/xhtml">
xmlns:math="http://www.w3.org/1999/Math/MathMl">

然后，您就可以在 div 中使用该前缀了，就像这样：

<math:div>x3/X<div>

虽然在大多数情况下，绝大多数 XHTML 作者都不需要定义多个命名空间，但是您仍然有必要理解存在着多个命名空间，以便在需要选择将基于某个 DTD 的内容嵌入其他 DTD 定义的内容中时，可以管理多个命名空间。

参阅

如果需要了解更多有关命名空间的信息，请阅读的 XML 教程的 XML 命名空间一章。

返回HTML <html> 标签参考手册。

注释：在某些文献中，命名空间（Namespace）被译为名称空间。

HTML 参考手册
HTML 实例
HTML 测验


HTML 标准属性

参考手册

  • 标签列表（字母排序）
  • 标签列表（功能排序）
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML Latin-1
  • HTML 符号
  • HTML URL 编码
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 标准属性

  • Previous Page
  • Next Page

HTML 标签拥有属性。每个标签的特殊属性均被列于每个标签描述之下。这里列出的属性是通用于每个标签的核心属性和语言属性（有个别例外）：

核心属性 (Core Attributes)

以下标签不提供下面的属性：base、head、html、meta、param、script、style 以及 title 元素。

属性 | 值 | 描述
class | class_rule or style_rule | 元素的类(class)
id | id_name | 元素的某个特定id。
style | 样式定义 | 内联样式定义。
title | 提示文本 | 显示于提示工具中的文本。

语言属性 (Language Attributes)

以下标签不提供下面的属性：base、br、frame、frameset、hr、iframe、param 以及 script 元素。

属性 | 值 | 描述
dir | ltr | rtl | 设置文本的方向。
lang | 语言代码 | 设置语言代码。

键盘属性 (Keyboard Attributes)

属性 | 值 | 描述
accesskey | 字符 | 设置访问某元素的键盘快捷键。
tabindex | 数 | 设置某元素的Tab次序。
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 事件属性

参考手册

  • 标签列表（字母排序）
  • 标签列表（功能排序）
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML Latin-1
  • HTML 符号
  • HTML URL 编码
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 事件属性

  • Previous Page
  • Next Page

HTML 4.0 的新特性之一是使 HTML 事件触发浏览器中的行为，比方说当用户点击一个 HTML 元素时启动一段 JavaScript。以下就是可被插入 HTML 标签以定义事件行为的一系列属性。

假如你希望学习如何使用这些事件进行编程，那么你应该学习我们的 JavaScript 教程和 DHTML 教程。

窗口事件 (Window Events)

仅在 body 和 frameset 元素中有效。

属性 | 值 | 描述
onload | 脚本 | 当文档被载入时执行脚本
onunload | 脚本 | 当文档被卸下时执行脚本

表单元素事件 (Form Element Events)

仅在表单元素中有效。

属性 | 值 | 描述
onchange | 脚本 | 当元素改变时执行脚本
onsubmit | 脚本 | 当表单被提交时执行脚本
onreset | 脚本 | 当表单被重置时执行脚本
onselect | 脚本 | 当元素被选取时执行脚本
onblur | 脚本 | 当元素失去焦点时执行脚本
onfocus | 脚本 | 当元素获得焦点时执行脚本

键盘事件 (Keyboard Events)

在下列元素中无效：base、bdo、br、frame、frameset、head、html、iframe、meta、param、script、style 以及 title 元素。

属性 | 值 | 描述
onkeydown | 脚本 | 当键盘被按下时执行脚本
onkeypress | 脚本 | 当键盘被按下后又松开时执行脚本
onkeyup | 脚本 | 当键盘被松开时执行脚本

鼠标事件 (Keyboard Events)

在下列元素中无效：base、bdo、br、frame、frameset、head、html、iframe、meta、param、script、style 以及 title 元素。

属性 | 值 | 描述
onclick | 脚本 | 当鼠标被单击时执行脚本
ondblclick | 脚本 | 当鼠标被双击时执行脚本
onmousedown | 脚本 | 当鼠标按钮被按下时执行脚本
onmousemove | 脚本 | 当鼠标指针移动时执行脚本
onmouseout | 脚本 | 当鼠标指针移出某元素时执行脚本
onmouseover | 脚本 | 当鼠标指针悬停于某元素之上时执行脚本
onmouseup | 脚本 | 当鼠标按钮被松开时执行脚本
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTML 颜色名

参考手册

  • 标签列表（字母排序）
  • 标签列表（功能排序）
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML Latin-1
  • HTML 符号
  • HTML URL 编码
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 颜色名

  • Previous Page
  • Next Page

本页提供了被大多数浏览器支持的颜色名。

提示：W3C 的 HTML 4.0 标准仅支持 16 种颜色名，它们是：aqua、black、blue、fuchsia、gray、green、lime、maroon、navy、olive、purple、red、silver、teal、white、yellow。

如果使用其它颜色的话，就应该使用十六进制的颜色值。

颜色名列表

单击一个颜色名或者 16 进制值，就可以查看与不同文字颜色搭配的背景颜色。

颜色名 | 十六进制颜色值 | 颜色
AliceBlue | #F0F8FF |
AntiqueWhite | #FAEBD7 |
Aqua | #00FFFF |
Aquamarine | #7FFFD4 |
Azure | #F0FFFF |
Beige | #F5F5DC |
Bisque | #FFE4C4 |
Black | #000000 |
BlanchedAlmond | #FFEBCD |
Blue | #0000FF |
BlueViolet | #8A2BE2 |
Brown | #A52A2A |
BurlyWood | #DEB887 |
CadetBlue | #5F9EA0 |
Chartreuse | #7FFF00 |
Chocolate | #D2691E |
Coral | #FF7F50 |
CornflowerBlue | #6495ED |
Cornsilk | #FFF8DC |
Crimson | #DC143C |
Cyan | #00FFFF |
DarkBlue | #00008B |
DarkCyan | #008B8B |
DarkGoldenRod | #B8860B |
DarkGray | #A9A9A9 |
DarkGreen | #006400 |
DarkKhaki | #BDB76B |
DarkMagenta | #8B008B |
DarkOliveGreen | #556B2F |
Darkorange | #FF8C00 |
DarkOrchid | #9932CC |
DarkRed | #8B0000 |
DarkSalmon | #E9967A |
DarkSeaGreen | #8FBC8F |
DarkSlateBlue | #483D8B |
DarkSlateGray | #2F4F4F |
DarkTurquoise | #00CED1 |
DarkViolet | #9400D3 |
DeepPink | #FF1493 |
DeepSkyBlue | #00BFFF |
DimGray | #696969 |
DodgerBlue | #1E90FF |
Feldspar | #D19275 |
FireBrick | #B22222 |
FloralWhite | #FFFAF0 |
ForestGreen | #228B22 |
Fuchsia | #FF00FF |
Gainsboro | #DCDCDC |
GhostWhite | #F8F8FF |
Gold | #FFD700 |
GoldenRod | #DAA520 |
Gray | #808080 |
Green | #008000 |
GreenYellow | #ADFF2F |
HoneyDew | #F0FFF0 |
HotPink | #FF69B4 |
IndianRed | #CD5C5C |
Indigo | #4B0082 |
Ivory | #FFFFF0 |
Khaki | #F0E68C |
Lavender | #E6E6FA |
LavenderBlush | #FFF0F5 |
LawnGreen | #7CFC00 |
LemonChiffon | #FFFACD |
LightBlue | #ADD8E6 |
LightCoral | #F08080 |
LightCyan | #E0FFFF |
LightGoldenRodYellow | #FAFAD2 |
LightGrey | #D3D3D3 |
LightGreen | #90EE90 |
LightPink | #FFB6C1 |
LightSalmon | #FFA07A |
LightSeaGreen | #20B2AA |
LightSkyBlue | #87CEFA |
LightSlateBlue | #8470FF |
LightSlateGray | #778899 |
LightSteelBlue | #B0C4DE |
LightYellow | #FFFFE0 |
Lime | #00FF00 |
LimeGreen | #32CD32 |
Linen | #FAF0E6 |
Magenta | #FF00FF |
Maroon | #800000 |
MediumAquaMarine | #66CDAA |
MediumBlue | #0000CD |
MediumOrchid | #BA55D3 |
MediumPurple | #9370D8 |
MediumSeaGreen | #3CB371 |
MediumSlateBlue | #7B68EE |
MediumSpringGreen | #00FA9A |
MediumTurquoise | #48D1CC |
MediumVioletRed | #C71585 |
MidnightBlue | #191970 |
MintCream | #F5FFFA |
MistyRose | #FFE4E1 |
Moccasin | #FFE4B5 |
NavajoWhite | #FFDEAD |
Navy | #000080 |
OldLace | #FDF5E6 |
Olive | #808000 |
OliveDrab | #6B8E23 |
Orange | #FFA500 |
OrangeRed | #FF4500 |
Orchid | #DA70D6 |
PaleGoldenRod | #EEE8AA |
PaleGreen | #98FB98 |
PaleTurquoise | #AFEEEE |
PaleVioletRed | #D87093 |
PapayaWhip | #FFEFD5 |
PeachPuff | #FFDAB9 |
Peru | #CD853F |
Pink | #FFC0CB |
Plum | #DDA0DD |
PowderBlue | #B0E0E6 |
Purple | #800080 |
Red | #FF0000 |
RosyBrown | #BC8F8F |
RoyalBlue | #4169E1 |
SaddleBrown | #8B4513 |
Salmon | #FA8072 |
SandyBrown | #F4A460 |
SeaGreen | #2E8B57 |
SeaShell | #FFF5EE |
Sienna | #A0522D |
Silver | #C0C0C0 |
SkyBlue | #87CEEB |
SlateBlue | #6A5ACD |
SlateGray | #708090 |
Snow | #FFFAFA |
SpringGreen | #00FF7F |
SteelBlue | #4682B4 |
Tan | #D2B48C |
Teal | #008080 |
Thistle | #D8BFD8 |
Tomato | #FF6347 |
Turquoise | #40E0D0 |
Violet | #EE82EE |
VioletRed | #D02090 |
Wheat | #F5DEB3 |
White | #FFFFFF |
WhiteSmoke | #F5F5F5 |
Yellow | #FFFF00 |
YellowGreen | #9ACD32 |
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


HTTP 状态消息

参考手册

  • 标签列表（字母排序）
  • 标签列表（功能排序）
  • HTML 属性
  • HTML 事件
  • HTML 颜色名
  • HTML ASCII
  • HTML Latin-1
  • HTML 符号
  • HTML URL 编码
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTTP 状态消息

  • Previous Page
  • Next Page

当浏览器从 web 服务器请求服务时，可能会发生错误。

从而有可能会返回下面的一系列状态消息：

1xx: 信息

消息: | 描述:
100 Continue | 服务器仅接收到部分请求，但是一旦服务器并没有拒绝该请求，客户端应该继续发送其余的请求。
101 Switching Protocols | 服务器转换协议：服务器将遵从客户的请求转换到另外一种协议。

2xx: 成功

消息: | 描述:
200 OK | 请求成功（其后是对GET和POST请求的应答文档。）
201 Created | 请求被创建完成，同时新的资源被创建。
202 Accepted | 供处理的请求已被接受，但是处理未完成。
203 Non-authoritative Information | 文档已经正常地返回，但一些应答头可能不正确，因为使用的是文档的拷贝。
204 No Content | 没有新文档。浏览器应该继续显示原来的文档。如果用户定期地刷新页面，而Servlet可以确定用户文档足够新，这个状态代码是很有用的。
205 Reset Content | 没有新文档。但浏览器应该重置它所显示的内容。用来强制浏览器清除表单输入内容。
206 Partial Content | 客户发送了一个带有Range头的GET请求，服务器完成了它。

3xx: 重定向

消息: | 描述:
300 Multiple Choices | 多重选择。链接列表。用户可以选择某链接到达目的地。最多允许五个地址。
301 Moved Permanently | 所请求的页面已经转移至新的url。
302 Found | 所请求的页面已经临时转移至新的url。
303 See Other | 所请求的页面可在别的url下被找到。
304 Not Modified | 未按预期修改文档。客户端有缓冲的文档并发出了一个条件性的请求（一般是提供If-Modified-Since头表示客户只想比指定日期更新的文档）。服务器告诉客户，原来缓冲的文档还可以继续使用。
305 Use Proxy | 客户请求的文档应该通过Location头所指明的代理服务器提取。
306 Unused | 此代码被用于前一版本。目前已不再使用，但是代码依然被保留。
307 Temporary Redirect | 被请求的页面已经临时移至新的url。

4xx: 客户端错误

消息: | 描述:
400 Bad Request | 服务器未能理解请求。
401 Unauthorized | 被请求的页面需要用户名和密码。
402 Payment Required | 此代码尚无法使用。
403 Forbidden | 对被请求页面的访问被禁止。
404 Not Found | 服务器无法找到被请求的页面。
405 Method Not Allowed | 请求中指定的方法不被允许。
406 Not Acceptable | 服务器生成的响应无法被客户端所接受。
407 Proxy Authentication Required | 用户必须首先使用代理服务器进行验证，这样请求才会被处理。
408 Request Timeout | 请求超出了服务器的等待时间。
409 Conflict | 由于冲突，请求无法被完成。
410 Gone | 被请求的页面不可用。
411 Length Required | "Content-Length"未被定义。如果无此内容，服务器不会接受请求。
412 Precondition Failed | 请求中的前提条件被服务器评估为失败。
413 Request Entity Too Large | 由于所请求的实体的太大，服务器不会接受请求。
414 Request-url Too Long | 由于url太长，服务器不会接受请求。当post请求被转换为带有很长的查询信息的get请求时，就会发生这种情况。
415 Unsupported Media Type | 由于媒介类型不被支持，服务器不会接受请求。
416 | 服务器不能满足客户在请求中指定的Range头。
417 Expectation Failed |

5xx: 服务器错误

消息: | 描述:
500 Internal Server Error | 请求未完成。服务器遇到不可预知的情况。
501 Not Implemented | 请求未完成。服务器不支持所请求的功能。
502 Bad Gateway | 请求未完成。服务器从上游服务器收到一个无效的响应。
503 Service Unavailable | 请求未完成。服务器临时过载或当机。
504 Gateway Timeout | 网关超时。
505 HTTP Version Not Supported | 服务器不支持请求中指明的HTTP协议版本。
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


W3School 颜色测试：

背景色：AliceBlue，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#F0F8FF，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：AntiqueWhite，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FAEBD7，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Aqua，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#00FFFF，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Aquamarine，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#7FFFD4，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Azure，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#F0FFFF，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Beige，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#F5F5DC，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Bisque，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FFE4C4，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Black，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#000000，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：BlanchedAlmond，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FFEBCD，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Blue，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#0000FF，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：BlueViolet，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#8A2BE2，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Brown，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#A52A2A，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：BurlyWood，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#DEB887，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：CadetBlue，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#5F9EA0，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Chartreuse，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#7FFF00，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Chocolate，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#D2691E，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Coral，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FF7F50，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：CornflowerBlue，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#6495ED，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Cornsilk，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FFF8DC，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Crimson，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#DC143C，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Cyan，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：DarkBlue，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#00008B，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：DarkCyan，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#008B8B，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：DarkGoldenRod，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#B8860B，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：DarkGray，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#A9A9A9，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：DarkGreen，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#006400，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：DarkKhaki，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#BDB76B，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：DarkMagenta，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#8B008B，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：DarkOliveGreen，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#556B2F，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Darkorange，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FF8C00，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：DarkOrchid，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#9932CC，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：DarkRed，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#8B0000，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：DarkSalmon，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#E9967A，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：DarkSeaGreen，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#8FBC8F，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：DarkSlateBlue，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#483D8B，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：DarkSlateGray，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#2F4F4F，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：DarkTurquoise，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#00CED1，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：DarkViolet，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#9400D3，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：DeepPink，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FF1493，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：DeepSkyBlue，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#00BFFF，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：DimGray，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#696969，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：DodgerBlue，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#1E90FF，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Feldspar，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#D19275，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：FireBrick，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#B22222，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：FloralWhite，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FFFAF0，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：ForestGreen，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#228B22，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Fuchsia，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FF00FF，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Gainsboro，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#DCDCDC，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：GhostWhite，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#F8F8FF，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Gold，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FFD700，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：GoldenRod，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#DAA520，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Gray，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#808080，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Green，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#008000，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：GreenYellow，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#ADFF2F，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：HoneyDew，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#F0FFF0，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：HotPink，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FF69B4，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：IndianRed，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#CD5C5C，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Indigo，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#4B0082，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Ivory，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FFFFF0，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Khaki，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#F0E68C，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Lavender，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#E6E6FA，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：LavenderBlush，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FFF0F5，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：LawnGreen，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#7CFC00，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：LemonChiffon，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FFFACD，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：LightBlue，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#ADD8E6，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：LightCoral，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#F08080，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：LightCyan，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#E0FFFF，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：LightGoldenRodYellow，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FAFAD2，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：LightGrey，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#D3D3D3，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：LightGreen，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#90EE90，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：LightPink，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FFB6C1，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：LightSalmon，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FFA07A，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：LightSeaGreen，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#20B2AA，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：LightSkyBlue，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#87CEFA，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：LightSlateBlue，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#8470FF，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：LightSlateGray，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#778899，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：LightSteelBlue，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#B0C4DE，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：LightYellow，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FFFFE0，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Lime，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#00FF00，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：LimeGreen，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#32CD32，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Linen，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FAF0E6，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Magenta，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Maroon，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#800000，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：MediumAquaMarine，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#66CDAA，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：MediumBlue，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#0000CD，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：MediumOrchid，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#BA55D3，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：MediumPurple，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#9370D8，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：MediumSeaGreen，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#3CB371，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：MediumSlateBlue，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#7B68EE，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：MediumSpringGreen，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#00FA9A，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：MediumTurquoise，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#48D1CC，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：MediumVioletRed，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#C71585，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：MidnightBlue，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#191970，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：MintCream，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#F5FFFA，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：MistyRose，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FFE4E1，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Moccasin，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FFE4B5，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：NavajoWhite，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FFDEAD，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Navy，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#000080，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：OldLace，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FDF5E6，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Olive，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#808000，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：OliveDrab，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#6B8E23，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Orange，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FFA500，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：OrangeRed，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FF4500，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Orchid，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#DA70D6，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：PaleGoldenRod，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#EEE8AA，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：PaleGreen，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#98FB98，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：PaleTurquoise，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#AFEEEE，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：PaleVioletRed，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#D87093，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：PapayaWhip，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FFEFD5，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：PeachPuff，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FFDAB9，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Peru，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#CD853F，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Pink，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FFC0CB，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Plum，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#DDA0DD，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：PowderBlue，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#B0E0E6，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Purple，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#800080，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Red，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FF0000，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：RosyBrown，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#BC8F8F，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：RoyalBlue，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#4169E1，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：SaddleBrown，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#8B4513，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Salmon，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FA8072，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：SandyBrown，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#F4A460，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：SeaGreen，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#2E8B57，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：SeaShell，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FFF5EE，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Sienna，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#A0522D，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Silver，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#C0C0C0，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：SkyBlue，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#87CEEB，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：SlateBlue，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#6A5ACD，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：SlateGray，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#708090，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Snow，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FFFAFA，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：SpringGreen，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#00FF7F，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：SteelBlue，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#4682B4，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Tan，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#D2B48C，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Teal，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#008080，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Thistle，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#D8BFD8，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Tomato，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FF6347，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Turquoise，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#40E0D0，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Violet，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#EE82EE，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：VioletRed，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#D02090，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Wheat，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#F5DEB3，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：White，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FFFFFF，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：WhiteSmoke，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#F5F5F5，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：Yellow，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#FFFF00，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：YellowGreen，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


W3School 颜色测试：

背景色：#9ACD32，与不同的文本颜色一同显示。

十六进制 | RGB 值 | 颜色名称
F0F8FF | 240,248,255 | AliceBlue
FAEBD7 | 250,235,215 | AntiqueWhite
00FFFF | 0,255,255 | Aqua
7FFFD4 | 127,255,212 | Aquamarine
F0FFFF | 240,255,255 | Azure
F5F5DC | 245,245,220 | Beige
FFE4C4 | 255,228,196 | Bisque
000000 | 0,0,0 | Black
FFEBCD | 255,235,205 | BlanchedAlmond
0000FF | 0,0,255 | Blue
8A2BE2 | 138,43,226 | BlueViolet
A52A2A | 165,42,42 | Brown
DEB887 | 222,184,135 | BurlyWood
5F9EA0 | 95,158,160 | CadetBlue
7FFF00 | 127,255,0 | Chartreuse
D2691E | 210,105,30 | Chocolate
FF7F50 | 255,127,80 | Coral
6495ED | 100,149,237 | CornflowerBlue
FFF8DC | 255,248,220 | Cornsilk
DC143C | 237,164,61 | Crimson
00FFFF | 0,255,255 | Cyan
00008B | 0,0,139 | DarkBlue
008B8B | 0,139,139 | DarkCyan
B8860B | 184,134,11 | DarkGoldenRod
A9A9A9 | 169,169,169 | DarkGray
A9A9A9 | 169,169,169 | DarkGrey
006400 | 0,100,0 | DarkGreen
BDB76B | 189,183,107 | DarkKhaki
8B008B | 139,0,139 | DarkMagenta
556B2F | 85,107,47 | DarkOliveGreen
FF8C00 | 255,140,0 | Darkorange
9932CC | 153,50,204 | DarkOrchid
8B0000 | 139,0,0 | DarkRed
E9967A | 233,150,122 | DarkSalmon
8FBC8F | 143,188,143 | DarkSeaGreen
483D8B | 72,61,139 | DarkSlateBlue
2F4F4F | 47,79,79 | DarkSlateGray
2F4F4F | 47,79,79 | DarkSlateGrey
00CED1 | 0,206,209 | DarkTurquoise
9400D3 | 148,0,211 | DarkViolet
FF1493 | 255,20,147 | DeepPink
00BFFF | 0,191,255 | DeepSkyBlue
696969 | 105,105,105 | DimGray
696969 | 105,105,105 | DimGrey
1E90FF | 30,144,255 | DodgerBlue
B22222 | 178,34,34 | FireBrick
FFFAF0 | 255,250,240 | FloralWhite
228B22 | 34,139,34 | ForestGreen
FF00FF | 255,0,255 | Fuchsia
DCDCDC | 220,220,220 | Gainsboro
F8F8FF | 248,248,255 | GhostWhite
FFD700 | 255,215,0 | Gold
DAA520 | 218,165,32 | GoldenRod
808080 | 128,128,128 | Gray
808080 | 128,128,128 | Grey
008000 | 0,128,0 | Green
ADFF2F | 173,255,47 | GreenYellow
F0FFF0 | 240,255,240 | HoneyDew
FF69B4 | 255,105,180 | HotPink
CD5C5C | 205,92,92 | IndianRed
4B0082 | 75,0,130 | Indigo
FFFFF0 | 255,255,240 | Ivory
F0E68C | 240,230,140 | Khaki
E6E6FA | 230,230,250 | Lavender
FFF0F5 | 255,240,245 | LavenderBlush
7CFC00 | 124,252,0 | LawnGreen
FFFACD | 255,250,205 | LemonChiffon
ADD8E6 | 173,216,230 | LightBlue
F08080 | 240,128,128 | LightCoral
E0FFFF | 224,255,255 | LightCyan
FAFAD2 | 250,250,210 | LightGoldenRodYellow
D3D3D3 | 211,211,211 | LightGray
D3D3D3 | 211,211,211 | LightGrey
90EE90 | 144,238,144 | LightGreen
FFB6C1 | 255,182,193 | LightPink
FFA07A | 255,160,122 | LightSalmon
20B2AA | 32,178,170 | LightSeaGreen
87CEFA | 135,206,250 | LightSkyBlue
778899 | 119,136,153 | LightSlateGray
778899 | 119,136,153 | LightSlateGrey
B0C4DE | 176,196,222 | LightSteelBlue
FFFFE0 | 255,255,224 | LightYellow
00FF00 | 0,255,0 | Lime
32CD32 | 50,205,50 | LimeGreen
FAF0E6 | 250,240,230 | Linen
FF00FF | 255,0,255 | Magenta
800000 | 128,0,0 | Maroon
66CDAA | 102,205,170 | MediumAquaMarine
0000CD | 0,0,205 | MediumBlue
BA55D3 | 186,85,211 | MediumOrchid
9370D8 | 147,112,219 | MediumPurple
3CB371 | 60,179,113 | MediumSeaGreen
7B68EE | 123,104,238 | MediumSlateBlue
00FA9A | 0,250,154 | MediumSpringGreen
48D1CC | 72,209,204 | MediumTurquoise
C71585 | 199,21,133 | MediumVioletRed
191970 | 25,25,112 | MidnightBlue
F5FFFA | 245,255,250 | MintCream
FFE4E1 | 255,228,225 | MistyRose
FFE4B5 | 255,228,181 | Moccasin
FFDEAD | 255,222,173 | NavajoWhite
000080 | 0,0,128 | Navy
FDF5E6 | 253,245,230 | OldLace
808000 | 128,128,0 | Olive
6B8E23 | 107,142,35 | OliveDrab
FFA500 | 255,165,0 | Orange
FF4500 | 255,69,0 | OrangeRed
DA70D6 | 218,112,214 | Orchid
EEE8AA | 238,232,170 | PaleGoldenRod
98FB98 | 152,251,152 | PaleGreen
AFEEEE | 175,238,238 | PaleTurquoise
D87093 | 219,112,147 | PaleVioletRed
FFEFD5 | 255,239,213 | PapayaWhip
FFDAB9 | 255,218,185 | PeachPuff
CD853F | 205,133,63 | Peru
FFC0CB | 255,192,203 | Pink
DDA0DD | 221,160,221 | Plum
B0E0E6 | 176,224,230 | PowderBlue
800080 | 128,0,128 | Purple
FF0000 | 255,0,0 | Red
BC8F8F | 188,143,143 | RosyBrown
4169E1 | 65,105,225 | RoyalBlue
8B4513 | 139,69,19 | SaddleBrown
FA8072 | 250,128,114 | Salmon
F4A460 | 244,164,96 | SandyBrown
2E8B57 | 46,139,87 | SeaGreen
FFF5EE | 255,245,238 | SeaShell
A0522D | 160,82,45 | Sienna
C0C0C0 | 192,192,192 | Silver
87CEEB | 135,206,235 | SkyBlue
6A5ACD | 106,90,205 | SlateBlue
708090 | 112,128,144 | SlateGray
708090 | 112,128,144 | SlateGrey
FFFAFA | 255,250,250 | Snow
00FF7F | 0,255,127 | SpringGreen
4682B4 | 70,130,180 | SteelBlue
D2B48C | 210,180,140 | Tan
008080 | 0,128,128 | Teal
D8BFD8 | 216,191,216 | Thistle
FF6347 | 255,99,71 | Tomato
40E0D0 | 64,224,208 | Turquoise
EE82EE | 238,130,238 | Violet
F5DEB3 | 245,222,179 | Wheat
FFFFFF | 255,255,255 | White
F5F5F5 | 245,245,245 | WhiteSmoke
FFFF00 | 255,255,0 | Yellow
9ACD32 | 154,205,50 | YellowGreen


什么是超文本？

HTML 标签

  • <!-->
  • <!DOCTYPE>
  • <a>
  • <abbr>
  • <acronym>
  • <address>
  • <applet>
  • <area>
  • <b>
  • <base>
  • <basefont>
  • <bdo>
  • <big>
  • <blockquote>
  • <body>
  • <br>
  • <button>
  • <caption>
  • <center>
  • <cite>
  • <code>
  • <col>
  • <colgroup>
  • <dd>
  • <del>
  • <dfn>
  • <dir>
  • <div>
  • <dl>
  • <dt>
  • <em>
  • <fieldset>
  • <font>
  • <form>
  • <frame>
  • <frameset>
  • <head>
  • <h1> - <h6>
  • <hr>
  • <html>
  • <i>
  • <iframe>
  • <img>
  • <input>
  • <ins>
  • <kbd>
  • <label>
  • <legend>
  • <li>
  • <link>
  • <map>
  • <menu>
  • <meta>
  • <noframes>
  • <noscript>
  • <object>
  • <ol>
  • <optgroup>
  • <option>
  • <p>
  • <param>
  • <pre>
  • <q>
  • <s>
  • <samp>
  • <script>
  • <select>
  • <small>
  • <span>
  • <strike>
  • <strong>
  • <style>
  • <sub>
  • <sup>
  • <table>
  • <tbody>
  • <td>
  • <textarea>
  • <tfoot>
  • <th>
  • <thead>
  • <title>
  • <tr>
  • <tt>
  • <u>
  • <ul>
  • <var>

什么是超文本？

标记语言的真正威力在于其收集能力，它可以将收集来的文档组合成一个完整的信息库，并且可以将文档库与世界上的其他文档集合链接起来。

这样的话，读者不仅可以完全控制文档在屏幕上的显示，还可以通过超链接来控制浏览信息的顺序。这就是 HTML 和 XHTML 中的 “HT” - 超文本（hypertext），就是它将整个 Web 网络连接起来。

超文本的基础知识

超文本的基本特征就是可以超链接文档；你可以指向其他位置，该位置可以在当前的文档中、局域网中的其他文档，也可以在因特网上的任何位置的文档中。这些文档组成了一个杂乱的信息网。目标文档通常与其来源有某些关联，并且丰富了来源；来源中的链接元素则将这种关系传递给浏览者。

超链接可以用于各种效果。超链接可以用在目录和主题列表中。浏览者可以在浏览器屏幕上单击鼠标或在键盘上按下按键，从而选择并自动跳转到文档中自己感兴趣的那个主题，或跳转到世界上某处完全不同的集合中的某个文档。

超链接还可以向浏览者指出有关文档中某个主题的更多信息。例如，“如果您想了解更详细的信息，请参阅某某页面。”。作者可以使用超链接来减少重复信息。例如，我们建议创作者在每个文档中都签署上自己的姓名。这样就可以使用一个将名字和另一个包含地址、电话号码等信息的单独文档链接起来的超链接，而不必在每个文档中都包含完整的联系信息。

超链接（hyper text），或者按照标准叫法称为锚（anchor），是使用 <a> 标签标记的，可以用两种方式表示。锚的一种类型是在文档中创建一个热点，当用户激活或选中（通常是使用鼠标）这个热点时，会导致浏览器进行链接。浏览器会自动加载并显示同一文档或其他文档中的某个部分，或触发某些与因特网服务相关的操作，例如发送电子邮件或下载特殊文件等。锚的另一种类型会在文档中创建一个标记，该标记可以被超链接引用。

还有一些与超链接相关联的鼠标相关事件。这些事件与 JavaScript 结合使用可以产生一些令人激动的效果。

注释

锚的这两种类型都使用同样的标签；也许这就是它们拥有同样的名称的原因。但是我们发现，如果将它们区分开，把提供热点和超链接地址的锚看作“链接”，而用于标记文档的目标部分的锚称为“锚”，那么您将更容易理解这两种类型的锚。

HTML 参考手册
HTML 实例
HTML 测验


TCP/IP 简介

TCP/IP 教程

  • TCP/IP 首页
  • TCP/IP 简介
  • TCP/IP 地址
  • TCP/IP 协议
  • TCP/IP 邮件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

TCP/IP 简介

  • Previous Page
  • Next Page

TCP/IP 是用于因特网 (Internet) 的通信协议。

计算机通信协议

计算机通信协议是对那些计算机必须遵守以便彼此通信的的规则的描述。

什么是 TCP/IP？

TCP/IP 是供已连接因特网的计算机进行通信的通信协议。

TCP/IP 指传输控制协议/网际协议 (Transmission Control Protocol / Internet Protocol)。

TCP/IP 定义了电子设备（比如计算机）如何连入因特网，以及数据如何在它们之间传输的标准。

在 TCP/IP 内部

在 TCP/IP 中包含一系列用于处理数据通信的协议：

  • TCP (传输控制协议) - 应用程序之间通信
  • UDP (用户数据包协议) - 应用程序之间的简单通信
  • IP (网际协议) - 计算机之间的通信
  • ICMP (因特网消息控制协议) - 针对错误和状态
  • DHCP (动态主机配置协议) - 针对动态寻址

你将在本教程中学习到更多关于这些标准的知识。

TCP 使用固定的连接

TCP 用于应用程序之间的通信。

当应用程序希望通过 TCP 与另一个应用程序通信时，它会发送一个通信请求。这个请求必须被送到一个确切的地址。在双方“握手”之后，TCP 将在两个应用程序之间建立一个全双工 (full-duplex) 的通信。

这个全双工的通信将占用两个计算机之间的通信线路，直到它被一方或双方关闭为止。

UDP 和 TCP 很相似，但是更简单，同时可靠性低于 TCP。

IP 是无连接的

IP 用于计算机之间的通信。

IP 是无连接的通信协议。它不会占用两个正在通信的计算机之间的通信线路。这样，IP 就降低了对网络线路的需求。每条线可以同时满足许多不同的计算机之间的通信需要。

通过 IP，消息（或者其他数据）被分割为小的独立的包，并通过因特网在计算机之间传送。

IP 负责将每个包路由至它的目的地。

IP 路由器

当一个 IP 包从一台计算机被发送，它会到达一个 IP 路由器。

IP 路由器负责将这个包路由至它的目的地，直接地或者通过其他的路由器。

在一个相同的通信中，一个包所经由的路径可能会和其他的包不同。而路由器负责根据通信量、网络中的错误或者其他参数来进行正确地寻址。

TCP/IP

TCP/IP 意味着 TCP 和 IP 在一起协同工作。

TCP 负责应用软件（比如你的浏览器）和网络软件之间的通信。

IP 负责计算机之间的通信。

TCP 负责将数据分割并装入 IP 包，然后在它们到达的时候重新组合它们。

IP 负责将包发送至接受者。

  • Previous Page
  • Next Page


TCP/IP 教程

TCP/IP 教程

  • TCP/IP 首页
  • TCP/IP 简介
  • TCP/IP 地址
  • TCP/IP 协议
  • TCP/IP 邮件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

TCP/IP 教程

  • Next Page

TCP/IP 是针对因特网的通信协议。

在此教程中，你将了解到什么是 TCP/IP，以及它如何工作。开始学习 TCP/IP ！

TCP/IP 是因特网的通信协议。

通信协议是对计算机必须遵守的规则的描述，只有遵守这些规则，计算机之间才能进行通信。

浏览器和服务器都在使用 TCP/IP

因特网浏览器和因特网服务器均使用 TCP/IP 来连接因特网。浏览器使用 TCP/IP 来访问因特网服务器，服务器使用 TCP/IP 向浏览器传回 HTML。

电子邮件也使用 TCP/IP

电子邮件程序使用 TCP/IP 来连接因特网，这样才能收发邮件。

因特网地址也是 TCP/IP

你的因特网地址 124.229.222.37 也是标准的 TCP/IP 协议的一部分。

  • Next Page


TCP/IP 协议

TCP/IP 教程

  • TCP/IP 首页
  • TCP/IP 简介
  • TCP/IP 地址
  • TCP/IP 协议
  • TCP/IP 邮件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

TCP/IP 协议

  • Previous Page
  • Next Page

TCP/IP 是不同的通信协议的大集合。

协议族

TCP/IP 是基于 TCP 和 IP 这两个最初的协议之上的不同的通信协议的大的集合。

TCP - 传输控制协议

TCP 用于从应用程序到网络的数据传输控制。

TCP 负责在数据传送之前将它们分割为 IP 包，然后在它们到达的时候将它们重组。

IP - 网际协议

IP 负责计算机之间的通信。

IP 负责在因特网上发送和接收数据包。

HTTP - 超文本传输协议

HTTP 负责 web 服务器与 web 浏览器之间的通信。

HTTP 用于从 web 客户端（浏览器）向 web 服务器发送请求，并从 web 服务器向 web 客户端返回内容（网页）。

HTTPS - 安全的 HTTP

HTTPS 负责在 web 服务器和 web 浏览器之间的安全通信。

作为有代表性的应用，HTTPS 会用于处理信用卡交易和其他的敏感数据。

SSL - 安全套接字层

SSL 协议用于为安全数据传输加密数据。

SMTP - 简易邮件传输协议

SMTP 用于电子邮件的传输。

MIME - 多用途因特网邮件扩展

MIME 协议使 SMTP 有能力通过 TCP/IP 网络传输多媒体文件，包括声音、视频和二进制数据。

IMAP - 因特网消息访问协议

IMAP 用于存储和取回电子邮件。

POP - 邮局协议

POP 用于从电子邮件服务器向个人电脑下载电子邮件。

FTP - 文件传输协议

FTP 负责计算机之间的文件传输。

NTP - 网络时间协议

NTP 用于在计算机之间同步时间（钟）。

DHCP - 动态主机配置协议

DHCP 用于向网络中的计算机分配动态 IP 地址。

SNMP - 简单网络管理协议

SNMP 用于计算机网络的管理。

LDAP - 轻量级的目录访问协议

LDAP 用于从因特网搜集关于用户和电子邮件地址的信息。

ICMP - 因特网消息控制协议

ICMP 负责网络中的错误处理。

ARP - Address Resolution Protocol

ARP - 用于通过 IP 来查找基于 IP 地址的计算机网卡的硬件地址。

RARP - Reverse Address Resolution Protocol

RARP 用于通过 IP 查找基于硬件地址的计算机网卡的 IP 地址。

BOOTP - Boot Protocol

BOOTP 用于从网络启动计算机。

PPTP - 点对点隧道协议

PPTP 用于私人网络之间的连接（隧道）。

  • Previous Page
  • Next Page


TCP/IP 寻址

TCP/IP 教程

  • TCP/IP 首页
  • TCP/IP 简介
  • TCP/IP 地址
  • TCP/IP 协议
  • TCP/IP 邮件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

TCP/IP 寻址

  • Previous Page
  • Next Page

TCP/IP 使用 32 个比特或者 4 个 0 到 255 之间的数字来为计算机编址。

IP地址

每个计算机必须有一个 IP 地址才能够连入因特网。

每个 IP 包必须有一个地址才能够发送到另一台计算机。

在本教程下一节，你会学习到更多关于 IP 地址和 IP 名称的知识。

IP 地址包含 4 个数字：

这是你的 IP 地址：124.229.222.37

TCP/IP 使用 4 个数字来为计算机编址。每个计算机必须有一个唯一的 4 个数字的地址。

数字在 0 到 255 之间，并由点号隔开，像这样：192.168.1.60

TCP 使用固定的连接

TCP 用于应用程序之间的通信。

当应用程序希望通过 TCP 与另一个应用程序通信时，它会发送一个通信请求。这个请求必须被送到一个确切的地址。在双方“握手”之后，TCP 将在两个应用程序之间建立一个全双工 (full-duplex) 的通信。

这个全双工的通信将占用两个计算机之间的通信线路，直到它被一方或双方关闭为止。

UDP 和 TCP 很相似，但是更简单，同时可靠性低于 TCP。

32 比特 = 4 字节

TCP/IP 使用 32 个比特来编址。一个计算机字节是 8 比特。所以 TCP/IP 使用了 4 个字节。

一个计算机字节可以包含 256 个不同的值：

00000000、00000001、00000010、00000011、00000100、00000101、00000110、00000111、00001000 ....... 直到 11111111。

现在，你知道了为什么 TCP/IP 地址是介于 0 到 255 之间的 4 个数字。

域名

12 个阿拉伯数字很难记忆。使用一个名称更容易。

用于 TCP/IP 地址的名字被称为域名。w3school.com.cn 就是一个域名。

当你键入一个像 http://www.w3school.com.cn 这样的域名，域名会被一种 DNS 程序翻译为数字。

在全世界，数量庞大的 DNS 服务器被连入因特网。DNS 服务器负责将域名翻译为 TCP/IP 地址，同时负责使用新的域名更新彼此的系统。

当一个新的域名连同其 TCP/IP 地址一同注册后，全世界的 DNS 服务器都会对此信息进行更新。

  • Previous Page
  • Next Page


TCP/IP 邮件

TCP/IP 教程

  • TCP/IP 首页
  • TCP/IP 简介
  • TCP/IP 地址
  • TCP/IP 协议
  • TCP/IP 邮件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

TCP/IP 邮件

  • Previous Page
  • Next Page

电子邮件是 TCP/IP 最重要的应用之一。

你不会用到...

当你写邮件时，你不会用到 TCP/IP。

当你写邮件时，你用到的是电子邮件程序，例如莲花软件的 Notes，微软公司出品的 Outlook，或者 Netscape Communicator 等等。（w3school 的成员们都喜欢使用大名鼎鼎的 Foxmail。）

邮件程序会用到...

你的电子邮件程序使用不同的 TCP/IP 协议：

  • 使用 SMTP 来发送邮件
  • 使用 POP 从邮件服务器下载邮件
  • 使用 IMAP 连接到邮件服务器

SMTP - 简单邮件传输协议

SMTP 协议用于传输电子邮件。SMTP 负责把邮件发送到另一台计算机。

通常情况下，邮件会被送到一台邮件服务器（SMTP 服务器），然后被送到另一台（或几台）服务器，然后最终被送到它的目的地。

SMTP 也可以传送纯文本，但是无法传输诸如图片、声音或者电影之类的二进制数据。

SMTP 使用 MIME 协议通过 TCP/IP 网络来发送二进制数据。MIME 协议会将二进制数据转换为纯文本。

POP - 邮局协议

POP 协议被邮件程序用来取回邮件服务器上面的邮件。

假如你的邮件程序使用 POP，那么一旦它连接上邮件服务器，你的所有的邮件都会被下载到邮件程序中（或者称之为邮件客户端）。

IMAP - 因特网消息访问协议

与 POP 类似，IMAP 协议同样被邮件程序使用。

IMAP 协议与 POP 协议之间的主要差异是：如果 IMAP 连上了邮件服务器，它不会自动地将邮件下载到邮件程序之中。

IMAP 使你有能力在下载邮件之前先通过邮件服务器端查看他们。通过 IMAP，你可以选择下载这些邮件或者仅仅是删除它们。比方说你需要从不同的位置访问邮件服务器，但是仅仅希望回到办公室的时候再下载邮件，IMAP 在这种情况下会很有用。

  • Previous Page
  • Next Page


The getAllResponseHeaders() function returns the headers of a resource. The headers contain file information like length, server-type, content-type, date-modified, etc.


The getResponseHeader() function returns a header from a resource. Headers contain file information like length, server-type, content-type, date-modified, etc.


Using the HttpRequest Object

Status:

Status text:

Response:


First Name:

Suggestions:


图像不会随页面的其余部分滚动。

图像不会随页面的其余部分滚动。

图像不会随页面的其余部分滚动。

图像不会随页面的其余部分滚动。

图像不会随页面的其余部分滚动。

图像不会随页面的其余部分滚动。

图像不会随页面的其余部分滚动。

图像不会随页面的其余部分滚动。

图像不会随页面的其余部分滚动。

图像不会随页面的其余部分滚动。

图像不会随页面的其余部分滚动。

图像不会随页面的其余部分滚动。

图像不会随页面的其余部分滚动。

图像不会随页面的其余部分滚动。

图像不会随页面的其余部分滚动。

图像不会随页面的其余部分滚动。

图像不会随页面的其余部分滚动。

图像不会随页面的其余部分滚动。

图像不会随页面的其余部分滚动。

图像不会随页面的其余部分滚动。

图像不会随页面的其余部分滚动。

图像不会随页面的其余部分滚动。

图像不会随页面的其余部分滚动。

图像不会随页面的其余部分滚动。


这是标题 1

这是标题 2

这是段落

这个段落设置了内边距。


我是一个有花纹背景的段落。我是一个有放射性背景的链接。

注释：为了清晰地显示出段落和链接的背景图像，我们为它们设置了少许内边距。


注释：为了在 Mozilla 中实现此效果，background-attachment 属性必须设置为 "fixed"。


这是一些文本。

这是一些文本。

这是一些文本。

这是一些文本。

这是一些文本。

这是一些文本。

这是一些文本。

这是一些文本。

这是一些文本。

这是一些文本。

这是一些文本。

这是一些文本。

这是一些文本。

这是一些文本。

这是一些文本。

这是一些文本。

这是一些文本。

这是一些文本。

这是一些文本。

这是一些文本。

这是一些文本。

这是一些文本。

这是一些文本。

这是一些文本。


 IE5 introduced DHTML behaviors. Behaviors are a way to add DHTML functionality to HTML elements with the ease of CSS.

How does behaviors work?
By using XML we can link behaviors to any element in a web page and manipulate that element.


Mouse over me!!!


 AAA BBB CCC


Some text.


A dotted border

A dashed border

A solid border

A double border

A groove border

A ridge border

An inset border

An outset border


注释："border-bottom-width" 属性如果单独使用的话是不会起作用的。请首先使用 "border-style" 属性来设置边框。

Some text. Some more text.


One-colored border!

Two-colored border!

Three-colored border!

Four-colored border!

注释："border-width" 属性如果单独使用的话是不会起作用的。请首先使用 "border-style" 属性来设置边框。


注释："border-left-width" 属性如果单独使用的话是不会起作用的。请首先使用 "border-style" 属性来设置边框。

Some text. Some more text.


注释："border-right-width" 属性如果单独使用的话是不会起作用的。请首先使用 "border-style" 属性来设置边框。

Some text. Some more text.


Some text

Some text

Some text

Some text


注释："border-top-width" 属性如果单独使用的话是不会起作用的。请首先使用 "border-style" 属性来设置边框。

Some text. Some more text.


Some text

Some text

Some text

Some text

Some text

注释："border-width" 属性如果单独使用的话是不会起作用的。请首先使用 "border-style" 属性来设置边框。


Some text


clip 属性剪切了一幅图像：


这是 header 1

这是 header 2

这是一个段落。


请把鼠标移动到单词上，可以看到鼠标指针发生变化：

Auto
Crosshair
Default
Pointer
Move
e-resize
ne-resize
nw-resize
n-resize
se-resize
sw-resize
s-resize
w-resize
text
wait
help


这是拥有标准行高的段落。 默认行高大约是 1。 这是拥有标准行高的段落。 这是拥有标准行高的段落。 这是拥有标准行高的段落。 这是拥有标准行高的段落。 这是拥有标准行高的段落。

这个段落拥有更小的行高。 这个段落拥有更小的行高。 这个段落拥有更小的行高。 这个段落拥有更小的行高。 这个段落拥有更小的行高。 这个段落拥有更小的行高。 这个段落拥有更小的行高。

这个段落拥有更大的行高。 这个段落拥有更大的行高。 这个段落拥有更大的行高。 这个段落拥有更大的行高。 这个段落拥有更大的行高。 这个段落拥有更大的行高。 这个段落拥有更大的行高。


这是拥有标准行高的段落。 在大多数浏览器中默认行高大约是 110% 到 120%。 这是拥有标准行高的段落。 这是拥有标准行高的段落。 这是拥有标准行高的段落。 这是拥有标准行高的段落。 这是拥有标准行高的段落。

这个段落拥有更小的行高。 这个段落拥有更小的行高。 这个段落拥有更小的行高。 这个段落拥有更小的行高。 这个段落拥有更小的行高。 这个段落拥有更小的行高。 这个段落拥有更小的行高。

这个段落拥有更大的行高。 这个段落拥有更大的行高。 这个段落拥有更大的行高。 这个段落拥有更大的行高。 这个段落拥有更大的行高。 这个段落拥有更大的行高。 这个段落拥有更大的行高。


这是拥有标准行高的段落。 在大多数浏览器中默认行高大约是 20px。 这是拥有标准行高的段落。 这是拥有标准行高的段落。 这是拥有标准行高的段落。 这是拥有标准行高的段落。 这是拥有标准行高的段落。

这个段落拥有更小的行高。 这个段落拥有更小的行高。 这个段落拥有更小的行高。 这个段落拥有更小的行高。 这个段落拥有更小的行高。 这个段落拥有更小的行高。 这个段落拥有更小的行高。

这个段落拥有更大的行高。 这个段落拥有更大的行高。 这个段落拥有更大的行高。 这个段落拥有更大的行高。 这个段落拥有更大的行高。 这个段落拥有更大的行高。 这个段落拥有更大的行高。


这是一些文本。这是一些文本。这是一些文本。 这是一些文本。这是一些文本。这是一些文本。 这是一些文本。这是一些文本。这是一些文本。 这是一些文本。这是一些文本。这是一些文本。 这是一些文本。这是一些文本。这是一些文本。


 本例中的样式表把 span 元素设置为块级元素。 两个 span 元素之间产生了一个换行行为。


本例中的样式表把段落元素设置为内联元素。

而 div 元素不会显示出来！

div 元素的内容不会显示出来！


some text

some text


some text. some text.

some text. some text.


These are the necessary steps:

  • Intert Key
  • Turn key clockwise
  • Push accelerator

Do not push the brake at the same time as the accelerator.

注释：必须声明 DOCTYPE，这样 :first-child 才能在 IE 中生效。


I am a strong man. I am a strong man.

I am a strong man. I am a strong man.


You can use the :first-letter pseudo-element to add a special effect to the first letter of a text!


You can combine the :first-letter and :first-line pseudo-elements to add a special effect to the first letter and the first line of a text!


You can use the :first-line pseudo-element to add a special effect to the first line of a text!


在下面的段落中，我们添加了一个样式为 float:right 的图像。结果是这个图像会浮动到段落的右侧。

This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text.


在下面的段落中，图像会浮动到右侧，并且添加了点状的边框。我们还为图像添加了边距，这样就可以把文本推离图像：上和右外边距是 0px，下外边距是 15px，而图像左侧的外边距是 20px。

This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text.


CSS is fun!

This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text.

在上面的段落中，div 元素的宽度是 120 像素，它其中包含图像。div 元素浮动到右侧。我们向 div 元素添加了外边距，这样就可以把 div 推离文本。同时，我们还向 div 添加了边框和内边距。


This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text. This is some text.

在上面的段落中，文本的第一个字母包含在一个 span 元素中。这个 span 元素的宽度是当前字体尺寸的 0.7 倍。span 元素的字体尺寸是 400%，行高是 80%。span 中的字母字体是 "Algerian"


  • Link one
  • Link two
  • Link three
  • Link four

在上面的例子中，我们把 ul 元素和 a 元素浮向左浮动。li 元素显示为行内元素（元素前后没有换行）。这样就可以使列表排列成一行。ul 元素的宽度是 100%，列表中的每个超链接的宽度是 7em（当前字体尺寸的 7 倍）。我们添加了颜色和边框，以使其更漂亮。


W3School.com.cn

"Never increase, beyond what is necessary, the number of entities required to explain anything." William of Ockham (1285-1349)

Free Web Building Tutorials

At W3School.com.cn you will find all the Web-building tutorials you need, from basic HTML and XHTML to advanced XML, XSL, Multimedia and WAP.

W3School.com.cn - The Largest Web Developers Site On The Net!

Copyright 2008 by YingKe Investment.


This is a normal paragraph

This is a paragraph with a "caption" font


This is header 3

This is a paragraph

This is a paragraph


This is header 1

This is header 2

This is a paragraph


This is a paragraph

This is a paragraph


This is a paragraph

This is a paragraph

This is a paragraph


This is a paragraph


:lang 伪类允许您为不同的语言定义特殊的规则。在下面的例子中，在下面的例子中，:lang 类为带有值为 "no" 的 lang 属性的 q 元素定义引号的类型：

一些文本 段落中的引用 一些文本。


This is header 1

This is header 4


这是一个链接


这是一个链接。

注释：在 CSS 定义中，a:hover 必须位于 a:link 和 a:visited 之后，这样才能生效！

注释：在 CSS 定义中，a:active 必须位于 a:hover 之后，这样才能生效！


请把鼠标移动到这些链接上，以查看效果：

这个链接改变颜色

这个链接改变字体大小

这个链接改变背景颜色

这个链接改变字体系列

这个链接改变文本装饰


  • 咖啡
  • 茶
  • 可口可乐


该列表的 list-style-position 的值是 "inside"：

  • Earl Grey Tea - 一种黑颜色的茶
  • Jasmine Tea - 一种神奇的“全功能”茶
  • Honeybush Tea - 一种令人愉快的果味茶

该列表的 list-style-position 的值是 "outside"：

  • Earl Grey Tea - 一种黑颜色的茶
  • Jasmine Tea - 一种神奇的“全功能”茶
  • Honeybush Tea - 一种令人愉快的果味茶


  • Disc 类型
  • 茶
  • 可口可乐
  • Circle 类型
  • 茶
  • 可口可乐
  • Square 类型
  • 茶
  • 可口可乐
  • The "none" 类型
  • 茶
  • 可口可乐
  • Decimal 类型
  • 茶
  • 可口可乐
  • Decimal-leading-zero 类型
  • 茶
  • 可口可乐
  • Lower-roman 类型
  • 茶
  • 可口可乐
  • Upper-roman 类型
  • 茶
  • 可口可乐
  • Lower-alpha 类型
  • 茶
  • 可口可乐
  • Upper-alpha 类型
  • 茶
  • 可口可乐
  • Lower-greek 类型
  • 茶
  • 可口可乐
  • Lower-latin 类型
  • 茶
  • 可口可乐
  • Upper-latin 类型
  • 茶
  • 可口可乐
  • Hebrew 类型
  • 茶
  • 可口可乐
  • Armenian 类型
  • 茶
  • 可口可乐
  • Georgian 类型
  • 茶
  • 可口可乐
  • Cjk-ideographic 类型
  • 茶
  • 可口可乐
  • Hiragana 类型
  • 茶
  • 可口可乐
  • Katakana 类型
  • 茶
  • 可口可乐
  • Hiragana-iroha 类型
  • 茶
  • 可口可乐
  • Katakana-iroha 类型
  • 茶
  • 可口可乐


  • 咖啡
  • 茶
  • 可口可乐
  • 咖啡
  • 茶
  • 可口可乐
  • 咖啡
  • 茶
  • 可口可乐
  • 咖啡
  • 茶
  • 可口可乐


  1. 咖啡
  2. 茶
  3. 可口可乐
  1. 咖啡
  2. 茶
  3. 可口可乐
  1. 咖啡
  2. 茶
  3. 可口可乐
  1. 咖啡
  2. 茶
  3. 可口可乐
  1. 咖啡
  2. 茶
  3. 可口可乐


This is a paragraph with no margin specified

This is a paragraph with a specified bottom margin

This is a paragraph with no margin specified


这个段落没有指定外边距。

这个段落带有指定的下外边距。

这个段落没有指定外边距。


This is a paragraph with no margin specified

This is a paragraph with a specified left margin


这个段落没有指定外边距。

这个段落带有指定的左外边距。


This is a right aligned paragraph with no margin specified

This is a right aligned paragraph with a specified right margin


这个段落没有指定外边距。

这个段落带有指定的右外边距。这个段落带有指定的右外边距。这个段落带有指定的右外边距。


This is a paragraph with no margin specified

This is a paragraph with a specified top margin


这个段落没有指定外边距。

这个段落带有指定的上外边距。


这个段落没有指定外边距。

这个段落带有指定的外边距。这个段落带有指定的外边距。这个段落带有指定的外边距。这个段落带有指定的外边距。这个段落带有指定的外边距。

这个段落没有指定外边距。


A dotted outline

A dashed outline

A solid outline

A double outline

A groove outline

A ridge outline

An inset outline

An outset outline


Some text.

Some text.


如果元素中的内容超出了给定的宽度和高度属性，overflow 属性可以确定是否显示滚动条等行为。

这个属性定义溢出元素内容区的内容会如何处理。如果值为 scroll，不论是否需要，用户代理都会提供一种滚动机制。因此，有可能即使元素框中可以放下所有内容也会出现滚动条。默认值是 visible。


这个表格单元拥有下内边距。


这个表格单元拥有左内边距。


这个表格单元拥有右内边距。


这个表格单元拥有上内边距。


这个表格单元的每个边拥有相等的内边距。

这个表格单元的上和下内边距是 0.5cm，左和右内边距是 2.5cm。


这是带有绝对定位的标题

通过绝对定位，元素可以放置到页面上的任何位置。下面的标题距离页面左侧 100px，距离页面顶部 150px。


这是标题

一些文本。一些文本。一些文本。一些文本。一些文本。一些文本。


一些文本。

更多的文本。


这是位于正常位置的标题

这个标题相对于其正常位置向左移动

这个标题相对于其正常位置向右移动

相对定位会按照元素的原始位置对该元素进行移动。

样式 "left:-20px" 从元素的原始左侧位置减去 20 像素。

样式 "left:20px" 向元素的原始左侧位置增加 20 像素。


This is a Heading

一些文本。一些文本。一些文本。一些文本。一些文本。一些文本。


Adams | John
Bush | George

Adams | John
Bush | George


Adams | John
Bush | George

Carter | Thomas
Gates | Bill


This is a caption
Adams | John
Bush | George


Adams | John
Bush |


1000000000000000000000000000 10000000 100

1000000000000000000000000000 10000000 100


这是文本。 这是文本。 这是文本。 这是文本。 这是文本。 这是文本。 这是文本。 这是文本。 这是文本。 这是文本。 这是文本。 这是文本。 这是文本。 这是文本。 这是文本。 这是文本。 这是文本。 这是文本。


Some text. Right-to-left direction.
Some text. Left-to-right direction.


这是一些文本。 这是一些文本。 这是一些文本。 这是一些文本。 这是一些文本。 这是一些文本。 这是一些文本。 这是一些文本。 这是一些文本。 这是一些文本。 这是一些文本。 这是一些文本。


This is some text. This is some text.


这是标题 1

这是标题 2

这是标题 3


这是标题 1

这是标题 2

这是标题 3

这是一个链接


这是段落中的一些文本。 这是段落中的一些文本。 这是段落中的一些文本。 这是段落中的一些文本。 这是段落中的一些文本。 这是段落中的一些文本。 这是段落中的一些文本。 这是段落中的一些文本。 这是段落中的一些文本。 这是段落中的一些文本。 这是段落中的一些文本。 这是段落中的一些文本。


This is some text in a paragraph.

This is some text in a paragraph.

This is some text in a paragraph.


这是一幅 [image] 位于段落中的图像。

这是一幅 [image] 位于段落中的图像。


Adams | John
Bush | George


这是可见的标题

这是不可见的标题


这是一个标题

默认的 z-index 是 0。Z-index 1 拥有更高的优先级。


这是一个标题

默认的 z-index 是 0。Z-index -1 拥有更低的优先级。


 请把鼠标移动到这个图像上


 请把鼠标移动到图像链接上：


 闪烁的链接


闪动的标题


请把鼠标移动到图像上：


 请把鼠标移动到正方形上，背景颜色会发生改变！


请滚动页面，看看会发生什么。

请滚动页面，看看会发生什么。

请滚动页面，看看会发生什么。

请滚动页面，看看会发生什么。

请滚动页面，看看会发生什么。

请滚动页面，看看会发生什么。

请滚动页面，看看会发生什么。

请滚动页面，看看会发生什么。

请滚动页面，看看会发生什么。


请把鼠标移动到单词上，这样会看到鼠标指针的变化：

Auto
Crosshair
Default
Pointer
Hand
Move
e-resize
ne-resize
nw-resize
n-resize
se-resize
sw-resize
s-resize
w-resize
text
wait
help


请在页面上移动指针

W 3 S


请在页面上移动指针


请在页面上移动指针

指针文本


请把鼠标移动到文本上！


我的标题

注释：是脚本改变了该元素的样式！


注释：原始图片是一个笑脸，但是上面的脚本把图片改为风景。


旧标题

请注意，原始的文本是“旧标题”。


请把鼠标移动到这个标题上


 请把鼠标移动到链接上


在元素失去焦点时，会发生 onblur 事件。试着在输入框中点击或输入，然后在文档的其他位置点击，这样输入框就会失去焦点。

请输入您的名字：


请选择您喜欢的浏览器：


请双击 "W3School.com.cn"

W3School.com.cn


请输入您的名字：


当键盘按键被按下时，会发生 onkeydown 事件。

请输入您的名字：


请编写一条消息：


当敲击键盘上的按键时，会发生 onkeypress 事件。

要触发 onkeypress 事件，请确保窗口拥有焦点。


当键盘按键上升时，会发生 onkeyup 事件。

请编写一条消息：


请把鼠标移动到文本上


请点击灯泡，把它点亮！


请选择输入框中的内容


当您关闭该文档时，提示框会显示一条消息！


请点击这个灯泡，把它点亮吧！


标题一

标题二


请在页面上移动鼠标


把鼠标移动到下面的饮料上：

咖啡

牛奶


 图像："landscape.jpg" 没有光照效果：

同一个图像，带有光照效果：


 请移动这个图形：

www.W3School.com.cn

Can you read this text?
Pretty cool effect!
W3school DHTML Section
Can you read this text?
Pretty cool effect!
W3school DHTML Section


 请移动这个图形：


发光

模糊

Flip H

Flip V

阴影

阴影

波浪

注释：如果元素的 width 属性没有设置，那么滤镜不会起作用。


本例演示如何向按钮插入背景图像。

请把鼠标移动到图像上，按钮会获得一幅背景图像：


本例演示如何改变单选按钮的背景颜色。

请把鼠标移动到下面的三个表格单元上，背景颜色将会改变：

请把鼠标移动到图像上：


本例演示如何向单选按钮插入背景图像。

请把鼠标移动到图像上，单选按钮会获得一幅背景图像：

请把鼠标移动到图像上：


本例演示如何向 textarea 插入背景图像。

请把鼠标移动到图像上，textarea 会获得一幅背景图像：


本例演示如何向输入框插入背景图像。

把鼠标移动到这两幅图像上，输入框会获得一幅背景图像。


本例演示如何改变按钮的背景颜色。

请把鼠标移动到下面的三个表格单元上，背景颜色将会改变：


本例演示如何改变按钮的文本颜色。

请把鼠标移动到下面的三个表格单元上，文本颜色将会改变：


本例演示如何改变复选按钮的背景颜色。

请把鼠标移动到下面的三个表格单元上，背景颜色将会改变：

请把鼠标移动到颜色上面


本例演示如何改变单选按钮的背景颜色。

请把鼠标移动到下面的三个表格单元上，背景颜色将会改变：

请把鼠标移动到颜色上面


本例演示如何改变选项列表的背景颜色。

请把鼠标移动到下面的三个表格单元上，背景颜色将会改变：


本例演示如何改变选项列表的文本颜色。

请把鼠标移动到下面的三个表格单元上，文本颜色将会改变：


本例演示如何改变 textarea 的背景颜色。

请把鼠标移动到下面的三个表格单元上，背景颜色将会改变：


本例演示如何改变 textarea 的文本颜色。

请把鼠标移动到下面的三个表格单元上，文本颜色将会改变：


本例演示如何改变文本框的背景颜色。

请把鼠标移动到下面的三个表格单元上，输入框会改变 background-color：


本例演示如何改变文本框的文本颜色。

请把鼠标移动到下面的三个表格单元上，文本的颜色将会改变：


名：
姓：
地址：
电邮：

名：
姓：
地址：
电邮：


苹果
桔子
香蕉
西瓜


 Mouse over the image


 请把鼠标移动到图像链接上


 请把鼠标移动到这些图片上，背景会发生变化：


当您把鼠标移动到图片上时，会出现一幅新的图像。

新图像会立即出现，这是因为您的浏览器已经加载了这幅图像。


 Alpha:
Gray:
Invert:
Xray:
Mask:

The mask value makes the text transparent


 请把鼠标移动到图像上，会看到它在摇动：）


本例演示如何动态地插入反转滤镜。

请把鼠标移动到图像上：


本例演示如何动态地插入遮罩滤镜。

请把鼠标移动到图像上：

Mouse over this image landscape


请把鼠标移动到链接上：

W3School.com.cn
AltaVista
Yahoo!
Hello


 请把鼠标移动到链接上，就可以看到它们的 logo：
W3School.com.cn
Internet Explorer
Netscape Navigator


 请把鼠标移动到链接上，就可以看到关于它们的描述：
W3School.com.cn
Internet Explorer
Netscape Navigator


MENU
HTML
XHTML
CSS
XML
XSL

请把鼠标移动到 MENU 上，就可以看到菜单的选项。


MENU
HTML
XHTML
CSS
XML
XSL

请点击 MENU，您会看到菜单的选项。


HOME M
E
N
U
ASP
JavaScript
DHTML
VBScript

请把鼠标移动到 MENU，可以显示这个菜单。

可以尝试修改脚本中的 "speed" 变量，来改变菜单的滑动速度。


HOME M
E
N
U
ASP
JavaScript
DHTML
VBScript

请点击 MENU，来显示这个菜单。

可以尝试修改脚本中的 "speed" 变量，来改变菜单的滑动速度。


 首页
JavaScript

W3School

Explorer
Navigator

浏览器

Alta Vista
Yahoo!

搜索


下拉菜单

教程
HTML
XHTML
CSS
XML
XSL
脚本
JavaScript
VBScript
DHTML
ASP
ADO
验证
验证 HTML
验证 XHTML
验证 CSS
验证 XML
验证 WML

把鼠标移动到不同的选项上，就可以看到下拉菜单。


HOME A
JavaScript

Explorer B
Navigator

AltaVista C
Yahoo!


 菜单
W3School
Microsoft
Altavista
滚动页面，就可以看到“置顶”的菜单。

滚动页面，就可以看到“置顶”的菜单。

滚动页面，就可以看到“置顶”的菜单。

滚动页面，就可以看到“置顶”的菜单。

滚动页面，就可以看到“置顶”的菜单。

滚动页面，就可以看到“置顶”的菜单。

滚动页面，就可以看到“置顶”的菜单。

滚动页面，就可以看到“置顶”的菜单。

滚动页面，就可以看到“置顶”的菜单。

滚动页面，就可以看到“置顶”的菜单。

滚动页面，就可以看到“置顶”的菜单。

滚动页面，就可以看到“置顶”的菜单。


HOME
JavaScript
Explorer
Navigator
AltaVista
Yahoo!


请拖动这幅图像。


在页面点击鼠标右键可以触发该事件。

请注意，这个事件无法保证别人不会查看页面源代码或者盗取图片。


这是一个标题

通过绝对定位，可以把元素放置页面的任何位置。

这个标题的 LEFT 位置距离页面左侧 100 像素。TOP 位置距离页面顶端 150 个像素。


Normal Heading

Heading +20

Heading -20

相对定位相对于元素的正常位置对其进行移动。

"left:20" 给元素的 LEFT 位置增加 20 像素。

"left:-20" 从元素的 LEFT 位置减去 20 像素。


标题 A

这是段落。这是段落。这是段落。这是段落。这是段落。

标题 B

这是段落。这是段落。这是段落。这是段落。这是段落。

标题 C

这是段落。这是段落。这是段落。这是段落。这是段落。

标题 D

这是段落。这是段落。这是段落。这是段落。这是段落。


请刷新该页面，您会看到广告条的变化。


开发者们，你们好。这段脚本制作了一个滚动文本。请访问： W3School.com.cn


 Mouse over this link


W3School.com.cn!


标题 一

标题 二

标题二在哪儿？


本例演示 xray 滤镜：

请把图像移动到下面的图像上：


请在文档中点击。提示框会显示出指针的 x 和 y 坐标。


这是一个标题

默认 z-index 是 0。Z-index 1 有更高的优先级。


这是一个标题

默认 z-index 是 0。Z-index -1 有更低的优先级。


This demonstrates a parser error:


W3School.com.cn （请使用 Alt + w 给该链接赋予焦点）

HTML DOM （请使用 Alt + d 为该链接赋予焦点）


姓名：
密码：

选择您喜欢的浏览器：
Internet Explorer
Firefox

（请使用 Alt + accesskey 为不同的表单字段赋予焦点。）


 访问 W3School.com.cn


 访问 Microsoft

在本例中，我们改变超链接的文本和 URL。我们也改变 target 属性。target 属性的默认设置是 "_self"，这意味着会在相同的窗口中打开链接。通过把 target 属性设置为 "_blank"，链接将在新窗口中打开。


Links and Anchors

点击一个按钮，来显示第二个窗口中的锚。


这段脚本在达到文本框的最大长度时跳到下一个文本框：


 Click on this document!


名：

姓：

转换为大写


您的姓名：
您的汽车：

要访问集合中的项目，你既可以使用项目编号，也可以使用项目名称：


 第一个锚
第二个锚
第三个锚

文档中锚的数目：


 第一个锚
第二个锚
第三个锚

本文档中第一个锚的 InnerHTML 是：


 本文档的域名是：


这是标题

点击标题，会提示出它的值。


referrer 属性返回加载本文档的文档的 URL。

本文档的 referrer 是：


 该文档的 URL 是：


请在文档中点击。一个消息框会提示出你点击了哪个鼠标按键。


请在文档中点击。一个消息框会提示出鼠标指针的 x 和 y 坐标。


注释：在测试这个例子时，要确保右侧的框架获得了焦点。

在键盘上按一个键。消息框会提示出该按键的 unicode。


在文档中点击某个位置。消息框会提示出指针相对于屏幕的 x 和 y 坐标。


在文档中点击某个位置。消息框会告诉你是否按下了 shift 键。


在文档中点击某个位置。消息框会提示出您所点击的标签的名称。

这是标题

这是段落。


在文档中点击某个位置。消息框会提示出被触发的事件的类型。


名称：


你喜欢怎么喝咖啡？

加奶油
加糖块


您喜欢哪款浏览器？

Internet Explorer
Firefox
Netscape
Opera

您喜欢的浏览器是：


在下面的文本框中输入一些文本，然后点击重置按钮就可以重置表单。

姓名：
年龄：


在下面的文本框中输入一些文本，然后点击提交按钮就可以提交表单。

名：
姓：


名字（最多 10 个字符）：
年龄（从 1 到 100）：
电子邮件：


请选择您喜欢的水果：


请选择您喜欢的浏览器：

您喜欢的浏览器是：


请选择数字：


该表单的 id 是：


在您点击 “选择多个” 按钮之前，请尝试同时选取多个选项。在点击 “选择多个” 按钮之后，请再试一次。


请看状态栏中的文本。


100 | 200
300 | 400


cell 1 | cell 2
cell 3 | cell 4


Row1 cell1 | Row1 cell2
Row2 cell1 | Row2 cell2


Row 1
Row 2
Row 3


Row1 cell1 | Row1 cell2
Row2 cell1 | Row2 cell2
Row3 cell1 | Row3 cell2


-----名----- | -----姓-----
John | Adams


名 | 姓
John | Adams


名 | 姓 | 文本
John | Adams | 你们好。我是名字是 John Adams。 在本例中，我需要一段长的文本。 在本例中，我需要一段长的文本。 在本例中，我需要一段长的文本。


Firstname | Lastname
Peter | Griffin


请点击上面的按钮。输入框会从 0 开始一直进行计时。


请点击上面的“开始计时”按钮。输入框会从 0 开始一直进行计时。点击“停止计时”可停止计时。


点击上面的按钮。5 秒后会显示一个消息框。


在按钮上面点击。输入框会显示出已经流逝的 2、4、6 秒钟。


注释：我们使用的是 top 元素而不是 window 元素来表示顶级框架。如果您没有使用框架，请使用 window 元素。


文本文本文本文本文本文本文本文本文本文本文本文本文本

文本文本文本文本文本文本文本文本文本文本文本文本文本

文本文本文本文本文本文本文本文本文本文本文本文本文本

文本文本文本文本文本文本文本文本文本文本文本文本文本

文本文本文本文本文本文本文本文本文本文本文本文本文本

文本文本文本文本文本文本文本文本文本文本文本文本文本

文本文本文本文本文本文本文本文本文本文本文本文本文本

文本文本文本文本文本文本文本文本文本文本文本文本文本


 UN
WWW

在某些浏览器中，当您把鼠标移至缩略词语上时，title 可用于展示表达的完整版本。

仅对于 IE 5 中的 acronym 元素有效。

对于 Netscape 6.2 中的 abbr 和 acronym 元素都有效。


Donald Duck
BOX 555
Disneyland
USA


请点击图像上的星球，把它们放大。

Venus Mercury Sun

注释：img 元素中的 "usemap" 属性引用 map 元素中的 "id" 或 "name" 属性（根据浏览器），所以我们同时向 map 元素添加了 "id" 和 "name" 属性。


这是段落。这是段落。这是段落。这是段落。这是段落。这是段落。这是段落。这是段落。这是段落。这是段落。

这是另一个段落。这是另一个段落。这是另一个段落。这是另一个段落。这是另一个段落。这是另一个段落。这是另一个段落。


图像背景

gif 和 jpg 文件均可用作 HTML 背景。

如果图像小于页面，图像会进行重复。


这个连接 将在新窗口中加载，因为 target 属性被设置为 "_blank"。

这个连接 也将在新窗口中加载，即使没有 target 属性。


body元素中的内容会显示在浏览器中。


如果您的浏览器支持 bi-directional override (bdo)，下一行会从右向左输出 (rtl)；

Here is some Hebrew text


请看: 改变了颜色的背景。


我喜欢自行车：
我喜欢汽车：


A heading

A paragraph


这是常规的段落。


 Computer code
Keyboard input
Teletype text
Sample text
Computer variable

注释：这些标签常用于显示计算机/编程代码。


一打有 二十 十二 件。

大多数浏览器会改写为删除文本和下划线文本。

一些老式的浏览器会把删除文本和下划线文本显示为普通文本。


这是一个字符实体：�

您可以试着在编辑窗口用另一个数字（比如 169）代替 000，然后点击 TIY 按钮来查看结果。


健康信息：

如果输入表单周围没有边框，说明您的浏览器太老了。


This is a paragraph.

This is another paragraph.


This is a paragraph with some text in it. This is a paragraph with some text in it. This is a paragraph with some text in it. This is a paragraph with some text in it.


I have a bike:
I have a car:
I have an airplane:

如果您点击 "Submit" 按钮，您将把输入传送到名为 html_form_action.asp 的新页面。


这个表单会把电子邮件发送到 W3School。

姓名：

电邮：

内容：


Male:
Female:

如果您点击 "Submit" 按钮，您将把输入传送到名为 html_form_action.asp 的新页面。


Type your first name:
Type your last name:

如果您点击 "Submit" 按钮，您将把输入传送到名为 html_form_action.asp 的新页面。


被锁在框架中了吗？

请点击这里！


This is heading 1

上面的标题在页面中进行了居中排列。上面的标题在页面中进行了居中排列。上面的标题在页面中进行了居中排列。


This is heading 1

This is heading 2

This is heading 3

This is heading 4

This is heading 5
This is heading 6

请仅仅把标题标签用于标题文本。不要仅仅为了产生粗体文本而使用它们。请使用其它标签或 CSS 代替。


hr 标签定义水平线：

这是段落。

这是段落。

这是段落。


一些老的浏览器不支持 iframe。

如果得不到支持，iframe 是不可见的。


图像 [image] 在文本中

图像 [image] 在文本中

图像 [image] 在文本中

请注意，bottom 对齐方式是默认的对齐方式。

图像 [image] 在文本中

图像在文本前面

图像在文本后面


仅支持文本的浏览器无法显示图像，仅仅能够显示在图像的 "alt" 属性中指定的文本。在这里，"alt" 的文本是“向左转”。

请注意，如果您把鼠标指针移动到图像上，大多数浏览器会显示 "alt" 文本。


带有图像的一个段落。图像的 align 属性设置为 "left"。图像将浮动到文本的左侧。

带有图像的一个段落。图像的 align 属性设置为 "right"。图像将浮动到文本的右侧。


您也可以把图像作为链接来使用：


通过改变 img 标签的 "height" 和 "width" 属性的值，您可以放大或缩写图像。


一幅图像：

一幅动画图像：

请注意，插入动画图像的语法与插入普通图像的语法没有区别。


来自另一个文件夹的图像：

来自 W3School.com.cn 的图像：


您也可以使用图像来作链接：


名：
姓：


请把鼠标移动到图像上，看一下状态栏的坐标如何变化。


本文档的 meta 属性描述了该文档和它的关键词。


This is some text. This is some text. This is some text. This is some text. This is some text. Another text. Another text. Another text. Another text. Another text. Another text. Another text.


查看 Chapter 4。

Chapter 1

This chapter explains ba bla bla

Chapter 2

This chapter explains ba bla bla

Chapter 3

This chapter explains ba bla bla

Chapter 4

This chapter explains ba bla bla

Chapter 5

This chapter explains ba bla bla

Chapter 6

This chapter explains ba bla bla

Chapter 7

This chapter explains ba bla bla

Chapter 8

This chapter explains ba bla bla

Chapter 9

This chapter explains ba bla bla

Chapter 10

This chapter explains ba bla bla

Chapter 11

This chapter explains ba bla bla

Chapter 12

This chapter explains ba bla bla

Chapter 13

This chapter explains ba bla bla

Chapter 14

This chapter explains ba bla bla

Chapter 15

This chapter explains ba bla bla

Chapter 16

This chapter explains ba bla bla

Chapter 17

This chapter explains ba bla bla


 最后一页

如果把链接的 target 属性设置为 "_blank"，该链接会在新窗口中打开。


我通过外部样式表进行格式化。

我也一样！


 这是一个链接！


本文本 是一个指向本网站中的一个页面的链接。

本文本 是一个指向万维网上的页面的链接。


一个定义列表：

咖啡
黑色的热饮料
Milk
白色的冷饮料


一个有序列表：

  1. 咖啡
  2. 茶
  3. 牛奶


一个无序列表：

  • 咖啡
  • 茶
  • 牛奶


一个嵌套列表：

  • 咖啡
  • 茶
    • 红茶
    • 绿茶
  • 牛奶


一个嵌套列表：

  • 咖啡
  • 茶
    • 红茶
    • 绿茶
      • 中国茶
      • 非洲茶
  • 牛奶


数字列表：

  1. 苹果
  2. 香蕉
  3. 柠檬
  4. 桔子

字母列表：

  1. 苹果
  2. 香蕉
  3. 柠檬
  4. 桔子

小写字母列表：

  1. 苹果
  2. 香蕉
  3. 柠檬
  4. 桔子

罗马字母列表：

  1. 苹果
  2. 香蕉
  3. 柠檬
  4. 桔子

小写罗马字母列表：

  1. 苹果
  2. 香蕉
  3. 柠檬
  4. 桔子


Disc 项目符号列表：

  • 苹果
  • 香蕉
  • 柠檬
  • 桔子

Circle 项目符号列表：

  • 苹果
  • 香蕉
  • 柠檬
  • 桔子

Square 项目符号列表：

  • 苹果
  • 香蕉
  • 柠檬
  • 桔子


这是邮件链接： 发送邮件

注意：应该使用 %20 来替换单词之间的空格，这样浏览器就可以正确地显示文本了。


这是另一个 mailto 链接： 发送邮件！

注意：应该使用 %20 来替换单词之间的空格，这样浏览器就可以正确地显示文本了。


本文档的 meta 属性标识了创作者和编辑软件。


您的浏览器无法处理框架！


不支持 JavaScript 的浏览器将显示 noscript 元素中的文本。


To break
lines
in a
paragraph,
use the br tag.


这是段落。

这是段落。

这是段落。

段落元素由 p 标签定义。


这个段落 在源代码中 包含许多行 但是浏览器 忽略了它们。

这个段落 在源代码 中 包含 许多行 但是 浏览器 忽略了 它们。

段落的行数依赖于浏览器窗口的大小。如果调节浏览器窗口的大小，将改变段落中的行数。


用户：
密码：

请注意，当您在密码域中键入字符时，浏览器将使用项目符号来代替这些字符。


My Bonnie lies over the ocean. My Bonnie lies over the sea. My Bonnie lies over the ocean. Oh, bring back my Bonnie to me.

注意，浏览器忽略了源代码中的格式。


这是
预格式文本。
它保留了      空格
和换行。

pre 标签很适合显示计算机代码：

for i = 1 to 10
     print i
next i


 这是长的引用：
这是长的引用。这是长的引用。这是长的引用。这是长的引用。这是长的引用。这是长的引用。这是长的引用。这是长的引用。这是长的引用。这是长的引用。这是长的引用。
这是短的引用： 这是短的引用。

使用 blockquote 元素的话，浏览器会插入换行和外边距，而 q 元素不会有任何特殊的呈现。


男性：
女性：

当用户点击一个单选按钮时，该按钮会变为选中状态，其他所有按钮会变为非选中状态。


对不起。我们已经搬家了。您的 URL 是 http://www.w3school.com.cn

您将在 5 秒内被重定向到新的地址。

如果超过 5 秒后您仍然看到本消息，请点击上面的的链接。


这是 header 1

这是 header 3


This text contains subscript

This text contains superscript


消费项目.... | 一月 | 二月
衣服 | $241.10 | $50.20
化妆品 | $30.00 | $44.45
食物 | $730.40 | $650.00
总计 | $1001.50 | $744.65


背景颜色：

First | Row
Second | Row

背景图像：

First | Row
Second | Row


带有普通的边框：

First | Row
Second | Row

带有粗的边框：

First | Row
Second | Row

带有很粗的边框：

First | Row
Second | Row


单元背景：

First | Row
Second | Row


没有 cellpadding：

First | Row
Second | Row

带有 cellpadding：

First | Row
Second | Row


没有 cellspacing：

First | Row
Second | Row

带有 cellspacing：

First | Row
Second | Row


这是一个段落。

这是另一个段落。

 这个单元包含一个表格：
A | B
C | D
这个单元包含一个列表：
  • 苹果
  • 香蕉
  • 菠萝
 HELLO


如果在本例中您没有看到围绕表格的边框，那么您的浏览器太旧了，或者不支持该属性：

frame="border":

First | Row
Second | Row

frame="box":

First | Row
Second | Row

frame="void":

First | Row
Second | Row

frame="above":

First | Row
Second | Row

frame="below":

First | Row
Second | Row

frame="hsides":

First | Row
Second | Row

frame="vsides":

First | Row
Second | Row

frame="lhs":

First | Row
Second | Row

frame="rhs":

First | Row
Second | Row


表头：

姓名 | 电话 | 电话
Bill Gates | 555 77 854 | 555 77 855

垂直的表头：

姓名 | Bill Gates
电话 | 555 77 854
电话 | 555 77 855


Some text | Some text
 | Some text

正如您看到的，其中一个单元没有边框。这是因为它是空的。在该单元中插入一个空格后，仍然没有边框。

我们的技巧是在单元中插入一个 no-breaking 空格。

no-breaking 空格是一个字符实体。如果您不清楚什么是字符实体，请阅读关于字符实体的章节。

no-breaking 空格由和号开始 ("&")，然后是字符"nbsp"，并以分号结尾(";")。


横跨两列的单元格：

姓名 | 电话
Bill Gates | 555 77 854 | 555 77 855

横跨两行的单元格：

姓名 | Bill Gates
电话 | 555 77 854
 | 555 77 855


每个表格由 table 标签开始。

每个表格行由 tr 标签开始。

每个表格数据由 td 标签开始。

一列：

100

一行三列：

100 200 300

两行三列：

100 | 200 | 300
400 | 500 | 600


这个表格没有边框：

100 | 200 | 300
400 | 500 | 600

这个表格也没有边框：

100 | 200 | 300
400 | 500 | 600


这个表格有一个标题，以及粗边框：

我的标题
100 | 200 | 300
400 | 500 | 600


This example cannot be edited because our editor uses a textarea for input, and your browser does not allow a textarea inside a textarea.


 This text is bold
This text is strong
This text is big
This text is emphasized
This text is italic
This text is small
This text contains subscript
This text contains superscript


解释：循环会在 i=3 时中断。


解释：当 i=3 时，会中断循环，并从下一个值开始继续循环。


解释：

i 等于 0。

循环首先会运行。

每循环一次，i 就会累加 1。

当 i 小于或等于 5 时，循环会继续运行。


本例演示 if..else if...else 语句。


实际的脚本位于名为 "xxx.js" 的外部脚本中。


解释：

for 循环的步进值从 i=0 开始。

只要 i 小于等于 5，循环就会继续运行。

循环每循环一次，i 就会累加 1。


通过点击这个按钮，可以调用一个函数。该函数会输出传递给它的参数。


通过点击这个按钮，可以调用一个带参数的函数。该函数会输出这个参数。


body 部分中的脚本调用一个带有两个参数（6 和 5）的函数。

该函数会返回这两个参数的乘积。


body 部分中的脚本调用一个函数。

该函数返回一段文本。


通过点击这个按钮，可以调用一个函数。该函数会提示一条消息。


本例演示 If 语句。

如果浏览器时间小于 10，那么会向您问“早安”。


本例演示 If...Else 语句。

如果浏览器时间小于 10，那么会向您问“早安”，否则会向您问候“祝您愉快”。


 Venus Mercury Sun


This JavaScript will generate a different greeting based on what day it is. Note that Sunday=0, Monday=1, Tuesday=2, etc.


 document.write("Hello World!");


请点击上面的“开始计时”按钮来启动计时器。输入框会一直进行计时，从 0 开始。点击“停止计时”按钮可以终止计时。


请点击上面的按钮。警告框会在 5 秒后显示。


点击上面的按钮。输入框会显示出已经逝去的时间（2、4、6 秒）。


上面的脚本声明了一个变量，为其赋值，显示该值，改变该值，然后再显示该值。


规则是：

如果把数字与字符串相加，结果将成为字符串。


解释：

i 等于 0。

当 i 小于或等于 5 时，循环将继续运行。

循环每运行一次，i 会累加 1。


Calendar Object


Flash Animation As Object


Graphic Object


Picture As Object


Music In The Background


Beatles Embedded


Linking To Beatles

Click here to play the Beatles


Horse As An Image


Playing The Object


Web Page AS Object


I will display for one second

I will display for two seconds


I will display for one second

I will display for two seconds

I will display for three seconds


倒数计时到 3000 年：


本例使用 DateAdd 来计算从今天起 30 天后的日期。

DateAdd 的语法：DateAdd(interval,number,date).


VBScripts WeekdayName 函数用于获得 weekday：


FormatDateTime 的语法：FormatDateTime(date,namedformat).


函数程序可返回结果。


通常，我们在 head 部分放置函数。理由是，可以确保函数在调用前已经加载。


VBScripts MonthName 函数用于获得 month：


本例演示一个链接，该链接的地址是 W3School.com.cn 或者 microsoft.com。几率各占 50%。


本例演示 "select case" 语句。
您会得到基于日期的不同问候。
请注意，Sunday=1, Monday=2, Tuesday=3, 以此类推。


子程序不返回结果。


Click on one of the table rows to display the full album information.


Artist | Title
This is my CD collection


W3Schools Internal Note

To:
From:
Message:


Using the HttpRequest Object

status:

status text:

response:


With a HEAD request, a server will return the headers of a resource (not the resource itself). This means you can find out the Content-Type or Last-Modified of a document, without downloading it itself.


My title

 该文档的标题是：


<html>
<body>

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open(Server.Mappath("/db/northwind.mdb"))
set rs = Server.CreateObject("ADODB.recordset")
rs.Open "Select * from Customers", conn

do until rs.EOF
    for each x in rs.Fields
       Response.Write(x.name)
       Response.Write(" = ")
       Response.Write(x.value & "<br />")
    next
    Response.Write("<br />")
    rs.MoveNext
loop

rs.close
conn.close
%>

</body>
</html>


<html>
<body>

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open(Server.Mappath("/db/northwind.mdb"))

set rs = Server.CreateObject("ADODB.recordset")
rs.Open "SELECT Companyname, Contactname FROM Customers", conn
%>

<table border="1" width="100%">
<%do until rs.EOF%>
    <tr>
    <%for each x in rs.Fields%>
       <td><%Response.Write(x.value)%></td>
    <%next
    rs.MoveNext%>
    </tr>
<%loop
rs.close
conn.close
%>
</table>

</body>
</html>


<html>
<body>

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open(Server.Mappath("/db/northwind.mdb"))
set rs = Server.CreateObject("ADODB.recordset")
sql="SELECT Companyname, Contactname FROM Customers"
rs.Open sql, conn
%>

<table border="1" width="100%">
<tr>
<%for each x in rs.Fields
    response.write("<th>" & x.name & "</th>")
next%>
</tr>
<%do until rs.EOF%>
    <tr>
    <%for each x in rs.Fields%>
       <td><%Response.Write(x.value)%></td>
    <%next
    rs.MoveNext%>
    </tr>
<%loop
rs.close
conn.close
%>
</table>

</body>
</html>


<html>
<body>

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open(Server.Mappath("/db/northwind.mdb"))
set rs = Server.CreateObject("ADODB.recordset")
sql="SELECT Companyname, Contactname FROM Customers"
rs.Open sql, conn
%>

<table border="1" width="100%" bgcolor="#fff5ee">
<tr>
<%for each x in rs.Fields
    response.write("<th align='left' bgcolor='#b0c4de'>" & x.name & "</th>")
next%>
</tr>
<%do until rs.EOF%>
    <tr>
    <%for each x in rs.Fields%>
       <td><%Response.Write(x.value)%></td>
    <%next
    rs.MoveNext%>
    </tr>
<%loop
rs.close
conn.close
%>
</table>

</body>
</html>


<html>
<body>

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open(Server.Mappath("/db/northwind.mdb"))
set rs = Server.CreateObject("ADODB.recordset")
rs.Open "SELECT Companyname, Contactname FROM Customers", conn
str=rs.GetString(,,"</td><td>","</td></tr><tr><td>"," ")
%>

<table border="1" width="100%">
   <tr>
     <td><%Response.Write(str)%></td>
   </tr>
</table>

<%
rs.close
conn.close
set rs = Nothing
set conn = Nothing
%>

</body>
</html>


<html>
<body>

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open(Server.Mappath("/db/northwind.mdb"))
set rs = Server.CreateObject("ADODB.recordset")
rs.Open "Select * from Customers", conn

'The first number indicates how many records to copy
'The second number indicates what recordnumber to start on
p=rs.GetRows(2,0)

response.write("<p>This example returns the value of the first column in the first two records:</p>")
response.write(p(0,0))
response.write("<br>")
response.write(p(0,1))

response.write("<p>This example returns the value of the first three columns in the first record:</p>")
response.write(p(0,0))
response.write("<br>")
response.write(p(1,0))
response.write("<br>")
response.write(p(2,0))

rs.close
conn.close
%>

</body>
</html>


<html>
<body>

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open(Server.Mappath("/db/northwind.mdb"))
set rs = Server.CreateObject("ADODB.recordset")
sql="SELECT Companyname, Contactname FROM Customers WHERE CompanyName LIKE 'A%'"
rs.Open sql, conn
%>

<table border="1" width="100%">
<tr>
<%for each x in rs.Fields
    response.write("<th>" & x.name & "</th>")
next%>
</tr>
<%do until rs.EOF%>
    <tr>
    <%for each x in rs.Fields%>
       <td><%Response.Write(x.value)%></td>
    <%next
    rs.MoveNext%>
    </tr>
<%loop
rs.close
conn.close
%>
</table>

</body>
</html>


<html>
<body>

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open(Server.Mappath("/db/northwind.mdb"))
set rs = Server.CreateObject("ADODB.recordset")
sql="SELECT Companyname, Contactname FROM Customers WHERE CompanyName>'E'"
rs.Open sql, conn
%>

<table border="1" width="100%">
<tr>
<%for each x in rs.Fields
    response.write("<th>" & x.name & "</th>")
next%>
</tr>
<%do until rs.EOF%>
    <tr>
    <%for each x in rs.Fields%>
       <td><%Response.Write(x.value)%> </td>
    <%next
    rs.MoveNext%>
    </tr>
<%loop
rs.close
conn.close
%>
</table>

</body>
</html>


<html>
<body>

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open(Server.Mappath("/db/northwind.mdb"))
set rs = Server.CreateObject("ADODB.recordset")
sql="SELECT Companyname, Contactname FROM Customers WHERE Country='Spain'"
rs.Open sql, conn
%>

<table border="1" width="100%">
<tr>
<%for each x in rs.Fields
    response.write("<th>" & x.name & "</th>")
next%>
</tr>
<%do until rs.EOF%>
    <tr>
    <%for each x in rs.Fields%>
       <td><%Response.Write(x.value)%> </td>
    <%next
    rs.MoveNext%>
    </tr>
<%loop
rs.close
conn.close
%>
</table>

</body>
</html>


<html>
<body>

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open(Server.Mappath("/db/northwind.mdb"))

set rs=Server.CreateObject("ADODB.recordset")
sql="SELECT DISTINCT Country FROM Customers ORDER BY Country"
rs.Open sql,conn

country=request.form("country")

%>

<form method="post">
Choose Country <select name="country">
<%  do until rs.EOF
    response.write("<option")
    if rs.fields("country")=country then
      response.write(" selected")
    end if
    response.write(">")
    response.write(rs.fields("Country"))
    rs.MoveNext
loop
rs.Close
set rs=Nothing %>
</select>
<input type="submit" value="Show customers">
</form>

<%
if country<>"" then
   sql="SELECT Companyname,Contactname,Country FROM Customers WHERE country='" & country & "'"
   set rs=Server.CreateObject("ADODB.Recordset")
   rs.Open sql,conn
%>
   <table width="100%" cellspacing="0" cellpadding="2" border="1">
   <tr>
     <th>Companyname</th>
     <th>Contactname</th>
     <th>Country</th>
   </tr>
<%
do until rs.EOF
   response.write("<tr>")
   response.write("<td>" & rs.fields("companyname") & "</td>")
   response.write("<td>" & rs.fields("contactname") & "</td>")
   response.write("<td>" & rs.fields("country") & "</td>")
   response.write("</tr>")
   rs.MoveNext
loop
rs.close
conn.Close
set rs=Nothing
set conn=Nothing%>
</table>
<%  end if %>

</body>
</html>


<html>
<body>

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open(Server.Mappath("/db/northwind.mdb"))
set rs = Server.CreateObject("ADODB.recordset")
sql="SELECT Companyname, Contactname FROM Customers ORDER BY CompanyName"
rs.Open sql, conn
%>

<table border="1" width="100%">
<tr>
<%for each x in rs.Fields
    response.write("<th>" & x.name & "</th>")
next%>
</tr>
<%do until rs.EOF%>
    <tr>
    <%for each x in rs.Fields%>
       <td><%Response.Write(x.value)%></td>
    <%next
    rs.MoveNext%>
    </tr>
<%loop
rs.close
conn.close
%>
</table>

</body>
</html>


<html>
<body>

<%
set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open(Server.Mappath("/db/northwind.mdb"))
set rs = Server.CreateObject("ADODB.recordset")
sql="SELECT Companyname, Contactname FROM Customers ORDER BY CompanyName DESC"
rs.Open sql, conn
%>

<table border="1" width="100%">
<tr>
<%for each x in rs.Fields
    response.write("<th>" & x.name & "</th>")
next%>
</tr>
<%do until rs.EOF%>
    <tr>
    <%for each x in rs.Fields%>
       <td><%Response.Write(x.value)%> </td>
    <%next
    rs.MoveNext%>
    </tr>
<%loop
rs.close
conn.close
%>
</table>

</body>
</html>


<html>
<body>

<table border="1" width="100%" bgcolor="#fff5ee">
<tr>
<th align="left" bgcolor="#b0c4de">
<a href="/example/adoe/demo_adoe_sort_3.asp?sort=companyname">Company</a>
</th>
<th align="left" bgcolor="#b0c4de">
<a href="/example/adoe/demo_adoe_sort_3.asp?sort=contactname">Contact</a>
</th>
</tr>
<%
if request.querystring("sort")<>"" then
   sort=request.querystring("sort")
else
   sort="companyname"
end if

set conn=Server.CreateObject("ADODB.Connection")
conn.Provider="Microsoft.Jet.OLEDB.4.0"
conn.Open(Server.Mappath("/db/northwind.mdb"))
set rs=Server.CreateObject("ADODB.recordset")
sql="SELECT Companyname,Contactname FROM Customers ORDER BY " & sort
rs.Open sql,conn

do until rs.EOF
   response.write("<tr>")
   for each x in rs.Fields
     response.write("<td>" & x.value & "</td>")
   next
   rs.MoveNext
   response.write("</tr>")
loop
rs.close
conn.close
%>
</table>

</body>
</html>


<html>
<body>

<%
set adrotator=Server.CreateObject("MSWC.AdRotator")
adrotator.Border="2"
Response.Write(adrotator.GetAdvertisement("/example/aspe/advertisements.txt"))
%>

<p>
<b>注释：</b>由于图像是随机变化的，
同时由于本页可供选择的图片很少，
因此经常会出现两次显示同一广告的情况。
</p>

<p>
<a href="/example/aspe/advertisements.txt">
查看 advertisements.txt
</a>
</p>

</body>
</html>


<%
url=Request.QueryString("url")
If url<>"" then Response.Redirect(url)
%>
<html>
<body>

<%
set adrotator=Server.CreateObject("MSWC.AdRotator")
adrotator.TargetFrame="target='_blank'"
response.write(adrotator.GetAdvertisement("/example/aspe/advertisements2.txt"))
%>

<p>
<b>注释：</b>由于图像是随机变化的，
同时由于本页可供选择的图片很少，
因此经常会出现两次显示同一广告的情况。
</p>

<p>
<a href="/example/aspe/advertisements.txt">
查看 advertisements2.txt
</a>
</p>
</body>
</html>


<html>
<body>

<%
Dim fname(5),i
fname(0) = "George"
fname(1) = "John"
fname(2) = "Thomas"
fname(3) = "James"
fname(4) = "Adrew"
fname(5) = "Martin"

For i = 0 to 5
      response.write(fname(i) & "<br />")
Next
%>

</body>
</html>


<html>
<body>

<%
dim fs,f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile(Server.MapPath("testread.txt"))
Response.Write("文件 testread.txt 的属性是：" & f.Attributes)
set f=nothing
set fs=nothing
%>

</body>
</html>


<html>
<body>

<%
Dim fs, d, n
Set fs=Server.CreateObject("Scripting.FileSystemObject")
Set d=fs.GetDrive("c:")
n = "驱动器：" & d
n = n & "<br>以字节计的可用空间：" & d.AvailableSpace
Response.Write(n)
set d=nothing
set fs=nothing
%>

</body>
</html>


<html>
<body>

<%
Set MyBrow=Server.CreateObject("MSWC.BrowserType")
%>

<table border="1" width="65%">
   <tr>
     <td width="52%">客户机操作系统</td>
     <td width="48%"><%=MyBrow.platform%></td>
   </tr>
   <tr>
     <td >Web 浏览器</td>
     <td ><%=MyBrow.browser%></td>
   </tr>
   <tr>
     <td>浏览器版本</td>
     <td><%=MyBrow.version%></td>
   </tr>
   <tr>
     <td>框架支持</td>
     <td><%=MyBrow.frames%></td>
   </tr>
   <tr>
     <td>表格支持</td>
     <td><%=MyBrow.tables%></td>
   </tr>
   <tr>
     <td>音频支持</td>
     <td><%=MyBrow.backgroundsounds%></td>
   </tr>
   <tr>
     <td>Cookies 支持</td>
     <td><%=MyBrow.cookies%></td>
   </tr>
   <tr>
     <td>VBScript 支持</td>
     <td><%=MyBrow.vbscript%></td>
   </tr>
   <tr>
     <td>JavaScript 支持</td>
     <td><%=MyBrow.javascript%></td>
   </tr>
</table>

</body>
</html>


<%
Response.Buffer=true
%>
<html>
<body>
<p>
当您的 response 缓存清空时，这段文本就会发送到浏览器。
</p>
<%
Response.Flush
%>
</body>
</html>


<%
Response.Buffer=true
%>
<html>
<body>
<p>这是我希望发送给用户的文本。</p>
<p>不，我改变主意了。我希望清除这些文本。</p>
<%
Response.Clear
%>
</body>
</html>


<%
Response.Charset="ISO8859-1"
%>
<html>
<body>

<p>This is some text</p>

</body>
</html>


<html>
<body>
<%
fruits=Request.Form("fruits")
%>

<form action="/example/aspe/demo_aspe_checkboxes.asp" method="post">
<p>您喜欢哪些水果：</p>
<input type="checkbox" name="fruits" value="Apples"
<%if instr(fruits,"Apple") then Response.Write("checked")%>>
Apple
<br>
<input type="checkbox" name="fruits" value="Oranges"
<%if instr(fruits,"Oranges") then Response.Write("checked")%>>
Orange
<br>
<input type="checkbox" name="fruits" value="Bananas"
<%if instr(fruits,"Banana") then Response.Write("checked")%>>
Banana
<br>
<input type="submit" value="提交">
</form>
<%
if fruits<>"" then%>
   <p>您喜欢：<%Response.Write(fruits)%></p>
<%end if
%>

</body>
</html>


<html>
<body>

<%
Set fs=Server.CreateObject("Scripting.FileSystemObject")

Set f=fs.OpenTextFile(Server.MapPath("testread.txt"), 1)
Response.Write(f.Read(2))
Response.Write("<p>指针目前位于文本文件中的位置 " & f.Column & "。</p>")
f.Close

Set f=Nothing
Set fs=Nothing
%>

</body>
</html>


<html>
<body>

<p>下面的例子构建了一个内容列表：</p>

<%
dim c
dim i
set nl=server.createobject("MSWC.Nextlink")
c = nl.GetListCount("/example/aspe/links.txt")
i = 1
%>
<ul>
<%do while (i <= c) %>
<li><a href="<%=nl.GetNthURL("/example/aspe/links.txt", i)%>">
<%=nl.GetNthDescription("/example/aspe/links.txt", i)%></a>
<%
i = (i + 1)
loop
%>
</ul>

<p>文本文件包含页面 URL 的列表和链接描述。
每行文本针对一个页面。
请注意，URL 和描述必须由 TAB 字符分隔。
</p>

<p>
<a href="/example/aspe/links.txt">查看 links.txt</a>
</p>

</body>
</html>


<html>
<body>

<h1>这是页面 1</h1>

<%
Set nl=Server.CreateObject("MSWC.NextLink")
If (nl.GetListIndex("/example/aspe/links2.txt")>1) Then
%>
<a href="<%Response.Write(nl.GetPreviousURL("/example/aspe/links2.txt"))%>">
上一页
</a>
<%End If%>

<a href="<%Response.Write(nl.GetNextURL("/example/aspe/links2.txt"))%>">
下一页
</a>

<p>本例使用 Content Linking 组件
对文本文件中的 URL 进行导航。</p>

<p><a href="/example/aspe/links2.txt">查看 links2.txt</a></p>
</body>
</html>


<html>
<body>

<p><b>注释：</b>如果服务器未安装 ASP 3.0，则本例无法运行。</p>

<p>
<a href="/example/aspe/textads.asp">查看 textads.txt</a>
</p>

<%
set cr=server.createobject("MSWC.ContentRotator")
response.write(cr.ChooseContent("/example/aspe/textads.txt"))
%>

<p>
<b>注释：</b>由于文本文件中的内容字符串是随机改变的，
同时本页只有四条内容可供选择，
因此，有时页面会连续显示两次相同的内容。
</p>

</body>
</html>


<%
Response.ContentType="text/html"
%>
<html>
<body>

<p>This is some text.</p>

</body>
</html>


<%
dim numvisits
response.cookies("NumVisits").Expires=date+365
numvisits=request.cookies("NumVisits")

if numvisits="" then
   response.cookies("NumVisits")=1
   response.write("欢迎！这是您第一次访问本页面。")
else
   response.cookies("NumVisits")=numvisits+1
   response.write("之前，您已经访问过本页面 ")
   response.write(numvisits & " 次。")
end if
%>
<html>
<body>
</body>
</html>


<html>
<body>

<%
dim d, a, s, i
set d=Server.CreateObject("Scripting.Dictionary")
d.Add "c", "China"
d.Add "i", "Italy"
Response.Write("key/item 对的数目是：" & d.Count)
set d=nothing
%>

</body>
</html>


<html>
<body>

<%
dim fs, f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile(Server.MapPath("testread.txt"))
Response.Write("文件 testread.txt 的创建时间是：" & f.DateCreated)
set f=nothing
set fs=nothing
%>

</body>
</html>


<html>
<body>

<%
dim fs, f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile(Server.MapPath("testread.txt"))
Response.Write("文件 testread.txt 的最后访问时间是：" & f.DateLastAccessed)
set f=nothing
set fs=nothing
%>

</body>
</html>


<html>
<body>

<%
dim fs, f
set fs=Server.CreateObject("Scripting.FileSystemObject")
set f=fs.GetFile(Server.MapPath("testread.txt"))
Response.Write("文件 testread.txt 的最后修改时间是：" & f.DateLastModified)
set f=nothing
set fs=nothing
%>

</body>
</html>


<html>
<body>
<%
Set fs=Server.CreateObject("Scripting.FileSystemObject")

if fs.driveexists("c:") = true then
      Response.Write("驱动器 c: 存在。")
Else
      Response.Write("驱动器 c: 不存在。")
End If

Response.write("<br>")

if fs.driveexists("g:") = true then
      Response.Write("驱动器 g: 存在。")
Else
      Response.Write("驱动器 g: 不存在。")
End If

set fs=nothing
%>

</body>
</html>


<html>
<body>

<%
dim fs, d, n
set fs=Server.CreateObject("Scripting.FileSystemObject")
set d=fs.GetDrive("c:")
Response.Write("驱动器字母是：" & d.driveletter)
set d=nothing
set fs=nothing
%>

</body>
</html>


<html>
<body>

<%
dim fs, d, n
set fs=Server.CreateObject("Scripting.FileSystemObject")
set d=fs.GetDrive("c:")
Response.Write("驱动器类型是：" & d.DriveType)
set d=nothing
set fs=nothing
%>

</body>
</html>


<html>
<body>
<p>我正在写文本。这些文本不会被<br>
<%
Response.End
%>
完全发送。这时候已经不能输出任何文本了！</p>
</body>
</html>


<html>
<body>

<%
dim d
set d=Server.CreateObject("Scripting.Dictionary")
d.Add "c", "China"
d.Add "i", "Italy"
if d.Exists("c")= true then
    Response.Write("键存在。")
else
    Response.Write("键不存在。")
end if
set d=nothing
%>

</body>
</html>


<%Response.Expires=-1%>
<html>
<body>
<p>每当被访问，本页都会被刷新！</p>
</body>
</html>


<%
Response.ExpiresAbsolute=#May 05,2001 05:30:30#
%>
<html>
<body>
<p>本页面的缓存会在该日期失效：05, 2001 05:30:30！</p>
</body>
</html>


<html>
<body>

<%
Set fs=Server.CreateObject("Scripting.FileSystemObject")

If (fs.FileExists("c:\windows\cursors\xxx.cur"))=true Then

Response.Write("文件 c:\windows\cursors\xxx.cur 存在。")

Else
      Response.Write("文件 c:\windows\cursors\xxx.cur 不存在。")
End If

set fs=nothing
%>

</body>
</html>


<html>
<body>

<%
dim fs, d, n
set fs=Server.CreateObject("Scripting.FileSystemObject")
set d=fs.GetDrive("c:")
Response.Write("文件系统是：" & d.FileSystem)
set d=nothing
set fs=nothing
%>

</body>
</html>


<html>
<body>
<%
Set fs=Server.CreateObject("Scripting.FileSystemObject")

If fs.FolderExists("c:\temp") = true Then
      Response.Write("文件夹 c:\temp 存在。")
Else
      Response.Write("文件夹 c:\temp 不存在。")
End If

set fs=nothing
%>

</body>
</html>


<html>
<body>

<form action="/example/aspe/demo_aspe_form2.asp" method="post">
First name:
<input type="text" name="name" value="Donald" />
<br />
Last name:
<input type="text" name="name" value="Duck" />
<br />
<input type="submit" value="Submit" />
</form>
<hr />

<p>来自上面的表单的信息：</p>
<%
If Request.Form("name")<>"" Then
      Response.Write("<p>")
      Response.Write("name=" & Request.Form("name"))
      Response.Write("</p><p>")
      Response.Write("name 属性的数目：")
      Response.Write(Request.Form("name").Count)
      Response.Write("</p><p>")
      Response.Write("First name=" & Request.Form("name")(1))
      Response.Write("</p><p>")
      Response.Write("Last name=" & Request.Form("name")(2))
      Response.Write("</p>")
End if
%>

</body>
</html>


<html>
<body>
<%
response.write("<h2>您可以使用 HTML 标签来格式化文本</h2>")
%>

<%
response.write("<p style='color:#0000ff'>这段文本的样式是通过 style 属性添加的。</p>")
%>
</body>
</html>


<html>
<body>

<%
dim i
for i=1 to 6
   response.write("<h" & i & ">Header " & i & "</h" & i & ">")
next
%>

</body>
</html>


<html>
<body>

<%
Dim fs, d, n
Set fs=Server.CreateObject("Scripting.FileSystemObject")
Set d=fs.GetDrive("c:")
n = "驱动器：" & d
n = n & "<br />以字节计的剩余空间：" & d.FreeSpace
Response.Write(n)
set d=nothing
set fs=nothing
%>

</body>
</html>


<html>
<body>

<%
Set fs=Server.CreateObject("Scripting.FileSystemObject")

Response.Write(fs.GetBaseName("c:\windows\cursors\abc.cur"))
Response.Write("<br />")
Response.Write(fs.GetBaseName("c:\windows\cursors\"))
Response.Write("<br />")
Response.Write(fs.GetBaseName("c:\windows\"))

set fs=nothing
%>

</body>
</html>


<html>
<body>

<%
Set fs=Server.CreateObject("Scripting.FileSystemObject")
p=fs.GetDriveName("c:\windows\cursors\abc.cur")

Response.Write("驱动器名称是：" & p)

set fs=nothing
%>

</body>
</html>


<html>
<body>

<%
Set fs=Server.CreateObject("Scripting.FileSystemObject")

Response.Write("文件 3dgarro 的文件扩展名是：")
Response.Write(fs.GetExtensionName("c:\windows\cursors\abc.cur"))

set fs=nothing
%>

</body>
</html>


<html>
<body>

<%
Set fs=Server.CreateObject("Scripting.FileSystemObject")

Response.Write("这个文件名的最后一个成分是：")
Response.Write(fs.GetFileName("c:\windows\cursors\abc.cur"))
set fs=nothing
%>

</body>
</html>


<html>
<body>

<%
Set fs=Server.CreateObject("Scripting.FileSystemObject")
p=fs.GetParentFolderName("c:\winnt\cursors\3dgarro.cur")

Response.Write("c:\windows\cursors\abc.cur 的父文件夹名称是：" & p)

set fs=nothing
%>

</body>
</html>


<html>
<body>

<%
response.write("<p>")
response.write("默认 Timeout 是：" & Session.Timeout & " 分钟。")
response.write("</p>")

Session.Timeout=30

response.write("<p>")
response.write("现在的 Timeout 是 " & Session.Timeout & " 分钟。")
response.write("</p>")
%>

</body>
</html>


<%
Set FS=Server.CreateObject("Scripting.FileSystemObject")
Set RS=FS.OpenTextFile(Server.MapPath("/example/aspe/counter.txt"), 1, False)
fcount=RS.ReadLine
RS.Close

fcount=fcount+1

'This code is disabled due to the write access security on our server:
'Set RS=FS.OpenTextFile(Server.MapPath("counter.txt"), 2, False)
'RS.Write fcount
'RS.Close

Set RS=Nothing
Set FS=Nothing

%>
<html>
<body>
<p>
本页已被访问了 <%=fcount%>  次。
</p>
</body>
</html>


<html>
<body>

<%
If Response.IsClientConnected=true then
Response.Write("用户仍然保持连接。")
else
Response.Write("用户未连接。")
end if
%>

</body>
</html>


<html>
<body>

<%
dim fs,d,n
set fs=Server.CreateObject("Scripting.FileSystemObject")
set d=fs.GetDrive("c:")
n = "此 " & d.DriveLetter
if d.IsReady=true then
    n = n & " 驱动器已就绪。"
else
    n = n & " 驱动器未就绪。"
end if
Response.Write(n)
set d=nothing
set fs=nothing
%>

</body>
</html>


<html>
<body>

<%
dim d
set d=Server.CreateObject("Scripting.Dictionary")
d.Add "c", "China"
d.Add "i", "Italy"
Response.Write("项目 i 的值是：" & d.item("i"))
set d=nothing
%>

</body>
</html>


<html>
<body>

<%
dim d,a,i,s
set d=Server.CreateObject("Scripting.Dictionary")
d.Add "c", "China"
d.Add "i", "Italy"

Response.Write("<p>项目的值是：</p>")
a=d.Items
for i = 0 To d.Count -1
    s = s & a(i) & "<br>"
next
Response.Write(s)

set d=nothing
%>

</body>
</html>


<%@ language="javascript" %>
<html>
<head>
<%
function jsproc(num1,num2)
{
Response.Write(num1*num2)
}
%>
</head>

<body>
<p>
结果：<%jsproc(3,4)%>
</p>
</body>

</html>


<%@ language="javascript" %>
<html>
<body>
<%
var d=new Date()
var h=d.getHours()

Response.Write("<p>")
Response.Write(d + " (Beijing Time)")
Response.Write("</p>")
if (h<12)
   {
   Response.Write("Good Morning!")
   }
else
   {
   Response.Write("Good day!")
   }
%>
</body>
</html>


<html>
<body>

<%
dim d
set d=Server.CreateObject("Scripting.Dictionary")
d.Add "c", "China"
d.Add "i", "Italy"
d.Key("i") = "it"
Response.Write("键 i 已设置为 it，其值是：" & d.Item("it"))
set d=nothing
%>

</body>
</html>


<html>
<body>

<%
dim d,a,i,s
set d=Server.CreateObject("Scripting.Dictionary")
d.Add "c", "China"
d.Add "i", "Italy"
Response.Write("<p>键的值是：</p>")
a=d.Keys
for i = 0 To d.Count -1
    s = s & a(i) & "<br>"
next
Response.Write(s)
set d=nothing
%>

</body>
</html>


<html>
<body>

<%
Set fs = Server.CreateObject("Scripting.FileSystemObject")
Set rs = fs.GetFile(Server.MapPath("/example/aspe/demo_aspe_lastmodified.asp"))
modified = rs.DateLastModified
%>
本文件的最后修改时间是：<%response.write(modified)
Set rs = Nothing
Set fs = Nothing
%>

</body>
</html>


<html>
<body>
<p>这是文本文件中的所有行（带有行号）：</p>

<%
Set fs=Server.CreateObject("Scripting.FileSystemObject")
Set f=fs.OpenTextFile(Server.MapPath("testread.txt"), 1)

do while f.AtEndOfStream = false
Response.Write("Line:" & f.Line & " ")
Response.Write(f.ReadLine)
Response.Write("<br>")
loop

f.Close
Set f=Nothing
Set fs=Nothing
%>

</body>
</html>


<html>
<body>

<%
dim fs,d
set fs=Server.CreateObject("Scripting.FileSystemObject")
set d=fs.GetDrive("c:")
Response.Write("路径是：" & d.Path)
set d=nothing
set fs=nothing
%>

</body>
</html>


<html>
<%
dim cars
cars=Request.Form("cars")
%>
<body>
<form action="/example/aspe/demo_aspe_radiob.asp" method="post">
<p>请选择您喜欢的汽车：</p>

<input type="radio" name="cars"
<%if cars="Volvo" then Response.Write("checked")%>
value="Volvo">Volvo</input>
<br />
<input type="radio" name="cars"
<%if cars="Saab" then Response.Write("checked")%>
value="Saab">Saab</input>
<br />
<input type="radio" name="cars"
<%if cars="BMW" then Response.Write("checked")%>
value="BMW">BMW</input>
<br /><br />
<input type="submit" value="提交" />
</form>
<%
if cars<>"" then
   Response.Write("<p>您喜欢的汽车是" & cars & "</p>")
end if
%>
</body>
</html>


<html>
<body>

<%
randomize()
r=rnd()
if r>0.5 then
  response.write("<a href='http://www.w3school.com.cn'>W3School.com.cn!</a>")
else
  response.write("<a href='http://www.news.cn'>news.cn!</a>")
end if
%>

<p>
本例演示一个链接，每当您加载本页时，就会显示两个链接之一：W3School.com.cn! 或 news.cn！各占百分之五十的几率。
</p>

</body>
</html>


<html>
<body>
<p>这是从文本文件中读取的第一行：</p>

<%
Set fs=Server.CreateObject("Scripting.FileSystemObject")

Set f=fs.OpenTextFile(Server.MapPath("testread.txt"), 1)
Response.Write(f.ReadLine)
f.Close

Set f=Nothing
Set fs=Nothing
%>

</body>
</html>


<html>
<body>
<p>这是从文本文件中读取的所有行：</p>

<%
Set fs=Server.CreateObject("Scripting.FileSystemObject")
Set f=fs.OpenTextFile(Server.MapPath("testread.txt"), 1)

do while f.AtEndOfStream = false
Response.Write(f.ReadLine)
Response.Write("<br>")
loop

f.Close
Set f=Nothing
Set fs=Nothing
%>

</body>
</html>


<html>
<body>
<p>这是从文本文件中读取的前 5 个字符：</p>

<%
Set fs=Server.CreateObject("Scripting.FileSystemObject")

Set f=fs.OpenTextFile(Server.MapPath("testread.txt"), 1)
Response.Write(f.Read(5))
f.Close

Set f=Nothing
Set fs=Nothing
%>

</body>
</html>


<html>
<body>
<p>这就是文本文件中的文本：</p>
<%
Set fs=Server.CreateObject("Scripting.FileSystemObject")

Set f=fs.OpenTextFile(Server.MapPath("/example/aspe/testread.txt"), 1)
Response.Write(f.ReadAll)
f.Close

Set f=Nothing
Set fs=Nothing
%>
</body>
</html>


<%
if Request.Form("select")<>"" then
       Response.Redirect(Request.Form("select"))
end if
%>

<html>
<body>

<form action="/example/aspe/demo_aspe_redirect.asp" method="post">

<input type="radio" name="select"
value="/example/aspe/demo_aspe_server.asp">
服务器实例<br>

<input type="radio" name="select"
value="/example/aspe/demo_aspe_text.asp">
文本实例<br><br>
<input type="submit" value="跳转！">

</form>

</body>
</html>


<html>
<body>
<form action="/example/aspe/demo_aspe_reqquery.asp" method="get">
您的姓名：<input type="text" name="fname" size="20" />
<input type="submit" value="提交" />
</form>
<%
dim fname
fname=Request.QueryString("fname")
If fname<>"" Then
      Response.Write("你好！" & fname & "！<br />")
      Response.Write("今天过得怎么样？")
End If
%>
</body>
</html>


<html>
<body>

<%
If Request.QueryString<>"" Then
      If Request.QueryString("name")<>", " Then
           name1=Request.QueryString("name")(1)
           name2=Request.QueryString("name")(2)
      end if
end if
%>

<form action="/example/aspe/demo_aspe_reqquery2.asp" method="get">
First name:
<input type="text" name="name" value="<%=name1%>" />
<br />
Last name:
<input type="text" name="name" value="<%=name2%>" />
<br />
<input type="submit" value="Submit" />
</form>
<hr>
<%
If Request.QueryString<>"" Then
      Response.Write("<p>")
      Response.Write("The information received from the form was:")
      Response.Write("</p><p>")
      Response.Write("name=" & Request.QueryString("name"))
      Response.Write("</p><p>")
      Response.Write("The name property's count is: ")
      Response.Write(Request.QueryString("name").Count)
      Response.Write("</p><p>")
      Response.Write("First name=" & name1)
      Response.Write("</p><p>")
      Response.Write("Last name=" & name2)
      Response.Write("</p>")
end if
%>
</body>
</html>


<html>
<body>

<%
dim fs,d
set fs=Server.CreateObject("Scripting.FileSystemObject")
set d=fs.GetDrive("c:")
Response.Write("根文件是：" & d.RootFolder)
set d=nothing
set fs=nothing
%>

</body>
</html>


<html>
<body>

<%
dim fs,d
set fs=Server.CreateObject("Scripting.FileSystemObject")
set d=fs.GetDrive("c:")
Response.Write("序列号：" & d.SerialNumber)
set d=nothing
set fs=nothing
%>

</body>
</html>


<html>
<body>
<p>
<b>您正在通过这款浏览器访问我们的站点：</b>
<%Response.Write(Request.ServerVariables("http_user_agent"))%>
</p>
<p>
<b>您的 IP 地址是：</b>
<%Response.Write(Request.ServerVariables("remote_addr"))%>
</p>
<p>
<b>IP 地址的 DNS 查询是：</b>
<%Response.Write(Request.ServerVariables("remote_host"))%>
</p>
<p>
<b>调用该页面所用的方法是：</b>
<%Response.Write(Request.ServerVariables("request_method"))%>
</p>
<p>
<b>服务器的域名：</b>
<%Response.Write(Request.ServerVariables("server_name"))%>
</p>
<p>
<b>服务器的端口：</b>
<%Response.Write(Request.ServerVariables("server_port"))%>
</p>
<p>
<b>服务器的软件：</b>
<%Response.Write(Request.ServerVariables("server_software"))%>
</p>

</body>
</html>


<html>
<body>

<p>
所有可能的服务器变量：
</p>
<%
For Each Item in Request.ServerVariables
      Response.Write(Item & "<br />")
Next
%>

</body>
</html>


<html>
<body>

<%
Response.Write(Session.SessionID)
%>

</body>
</html>


<html>
<body>
<form action="/example/aspe/demo_aspe_simpleform.asp" method="post">
您的姓名：<input type="text" name="fname" size="20" />
<input type="submit" value="提交" />
</form>
<%
dim fname
fname=Request.Form("fname")
If fname<>"" Then
      Response.Write("您好！" & fname & "！<br />")
      Response.Write("今天过得怎么样？")
End If
%>
</body>
</html>


<html>
<body>

<form action="/example/aspe/demo_aspe_simpleform1.asp" method="post">
First name:
<input type="text" name="fname" value="Donald" />
<br />
Last name:
<input type="text" name="lname" value="Duck" />
<br />
<input type="submit" value="Submit" />
</form>

<%
Response.Write(Request.Form)
%>

</body>
</html>


<html>
<body>

<a href="/example/aspe/demo_aspe_simplequerystring.asp?color=green">Example</a>

<%
Response.Write(Request.QueryString)
%>

</body>
</html>


<html>
<body>

<form action="/example/aspe/demo_aspe_simplereqquery.asp" method="get">
First name: <input type="text" name="fname"><br>
Last name: <input type="text" name="lname"><br>
<input type="submit" value="Submit">
</form>

<%
Response.Write(Request.QueryString)
%>

</body>
</html>


<html>
<body>
<p>文本文件中的前 4 个字符被略掉了：</p>

<%
Set fs=Server.CreateObject("Scripting.FileSystemObject")

Set f=fs.OpenTextFile(Server.MapPath("testread.txt"), 1)
f.Skip(4)
Response.Write(f.ReadAll)
f.Close

Set f=Nothing
Set fs=Nothing
%>

</body>
</html>


<html>
<body>
<p>文本文件中的第一行被略掉了：</p>

<%
Set fs=Server.CreateObject("Scripting.FileSystemObject")

Set f=fs.OpenTextFile(Server.MapPath("testread.txt"), 1)
f.SkipLine
Response.Write(f.ReadAll)
f.Close

Set f=Nothing
Set fs=Nothing
%>

</body>
</html>


<html>
<body>

<%
response.write("Hello World!")
%>

</body>
</html>


<html>
<body>

<%
Set FS = Server.CreateObject("Scripting.FileSystemObject")
Set RS = FS.OpenTextFile(Server.MapPath("/example/aspe") & "\textfile.txt",1)
While not rs.AtEndOfStream
      Response.Write RS.ReadLine
      Response.Write("<br />")
Wend
%>

<p>
<a href="/example/aspe/textfile.txt">查看此文本文件</a>
</p>

</body>
</html>


<html>
<body>

<form action="/example/aspe/demo_aspe_totalbytes.asp" method="post">
请键入一些字符：
<input type="text" name="txt"><br><br>
<input type="submit" value="提交">
</form>

<%
If Request.Form("txt")<>"" Then
   Response.Write("您提交了：")
   Response.Write(Request.Form)
   Response.Write("<br><br>")
   Response.Write("字节总计：")
   Response.Write(Request.Totalbytes)
End If
%>

</body>
</html>


<html>
<body>

<%
Dim fs,d,n
Set fs=Server.CreateObject("Scripting.FileSystemObject")
Set d=fs.GetDrive("c:")
n = "驱动器：" & d
n = n & "<br>以字节计的总容量：" & d.TotalSize
Response.Write(n)
set d=nothing
set fs=nothing
%>

</body>
</html>


<html>
<body>

<%
dim name
name="Donald Duck"
response.write("My name is: " & name)
%>

</body>
</html>


<html>

<head>
<%
sub vbproc(num1,num2)
response.write(num1*num2)
end sub
%>
</head>

<body>
<p>您可以像这样调用一个程序：</p>
<p>结果：<%call vbproc(3,4)%></p>

<p>或者，像这样：</p>
<p>结果：<%vbproc 3,4%></p>
</body>

</html>


<html>
<head>
<%
sub vbproc(num1,num2)
Response.Write(num1*num2)
end sub
%>
<script  language="javascript" runat="server">
function jsproc(num1,num2)
{
Response.Write(num1*num2)
}
</script>
</head>

<body>
<p>结果：<%call vbproc(3,4)%></p>
<p>结果：<%call jsproc(3,4)%></p>
</body>

</html>


<html>
<body>
<%
dim h
h=hour(now())

response.write("<p>" & now())
response.write(" (Beijing Time) </p>")
If h<12 then
   response.write("Good Morning!")
else
   response.write("Good day!")
end if
%>
</body>
</html>


w3school在线测试工具 v1.1

W3School TIY

源代码：

运行结果：


w3school在线测试工具 v1.2

W3School TIY

（请在下面的文本框中编辑您的代码，然后单击此按钮测试结果。）

编辑您的代码：

查看结果:


标题不会显示在文档区

这段文本会显示出来。


VBScript Abs 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Abs 函数

返回 VBScript 函数参考手册

定义和用法

Abs 函数可返回指定的数字的绝对值。

注释：如果 number 参数包含Null，则返回 Null 。

注释：如果 number 参数是一个未初始化的变量，则返回 0 。

语法

Abs(number)
参数 | 描述
number | 必需的。一个数值表达式。

实例

例子 1

document.write(Abs(1))
document.write(Abs(-1))

输出：

1
1

例子 2

document.write(Abs(48.4))
document.write(Abs(-48.4))

输出：

48.4
48.4

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Array 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Array 函数

返回 VBScript 函数参考手册

定义和用法

Array 可返回一个包含数组的变量。

注释：数组中的第一个元素是零。

语法

Array(arglist)
参数 | 描述
arglist | 必需的。数组中元素值的列表（由逗号分割）。

实例

例子 1

dim a
a=Array(5,10,15,20)
document.write(a(3))

输出：

20

例子 2

dim a
a=Array(5,10,15,20)
document.write(a(0))

输出：

5

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Asc 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Asc 函数

返回 VBScript 函数参考手册

定义和用法

Asc 函数可把字符串中的第一个字母转换为对应的 ANSI 代码，并返回结果。

语法

Asc(string)
参数 | 描述
string | 必需的。字符串表达式。不能为空字符串！

实例

例子 1

document.write(Asc("A"))
document.write(Asc("F"))

输出分别是：

65
70

例子 2

document.write(Asc("a"))
document.write(Asc("f"))

输出分别是：

97
102

例子 3

document.write(Asc("W"))
document.write(Asc("W3School.com.cn"))

输出分别是：

87
87

例子 4

document.write(Asc("2"))
document.write(Asc("#"))

输出分别是：

50
35

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Atn 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Atn 函数

返回 VBScript 函数参考手册

定义和用法

Atn 函数可返回指定数字的正切。

语法

Atn(number)
参数 | 描述
number | 必需的。一个数值表达式。

实例

例子 1

document.write(Atn(89))

输出：

1.55956084453693

例子 2

document.write(Atn(8.9))

输出：

1.45890606062322

例子 3

' 计算 pi 的值：
dim pi
pi=4*Atn(1)
document.write(pi)

输出：

3.14159265358979

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Atn 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Atn 函数

返回 VBScript 函数参考手册

定义和用法

Cos 函数可返回指定数字（角度）的余弦。

语法

Cos(number)
参数 | 描述
number | 必需的。将某个角表示为弧度的数值表达式。

实例

例子 1

document.write(Atn(89))

输出：

0.964966028492113

例子 2

document.write(Cos(-50.0))

输出：

0.964966028492113

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript CBool 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript CBool 函数

返回 VBScript 函数参考手册

定义和用法

CBool 函数可把表达式转换为布尔类型。

语法

CBool(expression)
参数 | 描述
expression | 必需的。任何合法的表达式。非零的值返回 True，零返回 False。如果表达式不能解释为数值，则将发生 run-time 错误。

实例

例子 1

dim a,b
a=5
b=10
document.write(CBool(a))
document.write(CBool(b))

输出分别是：

True
True

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript CByte 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript CByte 函数

返回 VBScript 函数参考手册

定义和用法

CByte 函数可把表达式转换为字节（Byte）类型。

语法

CByte(expression)
参数 | 描述
expression | 必需的。任何合法的表达式。

实例

例子 1

dim a
a=134.345
document.write(CByte(a))

输出：

134

例子 2

dim a
a=14.345455
document.write(CByte(a))

输出：

14

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript CCur 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript CCur 函数

返回 VBScript 函数参考手册

定义和用法

CCur 函数可把表达式转换为货币（Currency）类型。

语法

CCur(expression)
参数 | 描述
expression | 必需的。任何合法的表达式。

实例

例子 1

dim a
a=134.345
document.write(CCur(a))

输出：

134.345

例子 2

dim a
a=1411111111.345455
document.write(CCur(a))	'请注意，此函数会把结果四舍五入为4位的小数。

输出：

1411111111.3455

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript CDate 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript CDate 函数

返回 VBScript 函数参考手册

定义和用法

CDate 函数可把一个合法的日期和时间表达式转换为 Date 类型，并返回结果。

提示：请使用 IsDate 函数来判断 date 是否可被转换为日期或时间。

注释：IsDate 函数使用本地设置来检测字符串是否可被转换为日期。

语法

CDate(date)
参数 | 描述
date | 必需的。任何有效的日期表达式。（比如 Date() 或者 Now()）

实例

例子 1

d="April 22, 2001"
if IsDate(d) then
  document.write(CDate(d))
end if

输出：

2/22/01

例子 2

d=#2/22/01#
if IsDate(d) then
  document.write(CDate(d))
end if

输出：

2/22/01

例子 3

d="3:18:40 AM"
if IsDate(d) then
  document.write(CDate(d))
end if

输出：

3:18:40 AM

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript CDbl 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript CDbl 函数

返回 VBScript 函数参考手册

定义和用法

CDbl 函数可把表达式转换为双精度（Double）类型。

语法

CDbl(expression)
参数 | 描述
expression | 必需的。任何合法的表达式。

实例

例子 1

dim a
a=134.345
document.write(CDbl(a))

输出：

134.345

例子 2

dim a
a=14111111113353355.345455
document.write(CDbl(a))

输出：

1.41111111133534E+16

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Chr 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Chr 函数

返回 VBScript 函数参考手册

定义和用法

Chr 函数可把指定的 ANSI 字符代码转换为字符。

注释：从0到31的数字代表不可打印的 ASCII 代码，举例，Chr(10) 会返回一个换行符。

语法

Chr(charcode)
参数 | 描述
charcode | 必需的。标识某个字符的数字。

实例

例子 1

document.write(Chr(65))
document.write(Chr(97))

输出分别是：

A
a

例子 2

document.write(Chr(37))
document.write(Chr(45))

输出分别是：

%
-

例子 2

document.write(Chr(50))
document.write(Chr(35))

输出分别是：

2
#

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript CInt 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript CInt 函数

返回 VBScript 函数参考手册

定义和用法

CInt 函数可把表达式转换为整数（Integer）类型。

注释：值必须是介于 -32768 与 32767 之间的数字。

注释：CInt 不同于 Fix 和 Int 函数删除数值的小数部分，而是采用四舍五入的方式。 当小数部分正好等于 0.5 时, CInt 总是将其四舍五入成最接近该数的偶数。例如， 0.5 四舍五入为 0, 以及 1.5 四舍五入为 2.

语法

CInt(expression)
参数 | 描述
expression | 必需的。任何有效的表达式。

实例

例子 1

dim a
a=134.345
document.write(CInt(a))

输出：

134

例子 2

dim a
a=-30000.24
document.write(CInt(a))

输出：

-30000

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript CLng 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript CLng 函数

返回 VBScript 函数参考手册

定义和用法

CLng 函数可把表达式转换为长整形（Long）类型。

注释：值必须是介于 -2147483648 与 2147483647 之间的数字。

注释：CLng 不同于 Fix 和 Int 函数删除小数部分， 而是采用四舍五入的方式。 当小数部分正好等于 0.5 时， CLng 函数总是将其四舍五入为最接近该数的偶数。如， 0.5 四舍五入为 0, 以及 1.5 四舍五入为 2 。

语法

CInt(expression)
参数 | 描述
expression | 必需的。任何有效的表达式。

实例

例子 1

dim a,b
a=23524.45
b=23525.55
document.write(CLng(a))
document.write(CLng(b))

输出分别是：

23524
23526

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript CreateObject 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript UCase 函数

返回 VBScript 函数参考手册

定义和用法

CreateObject 函数可创建一个指定类型的对象。

语法

CreateObject(servername.typename[,location])
参数 | 描述
servername | 必需的。提供此对象的应用程序名称。
typename | 必需的。对象的类型或类（type/class）。
location | 可选的。在何处创建对象。

实例

例子 1

dim myexcel
Set myexcel=CreateObject("Excel.Sheet")

myexcel.Application.Visible=True

...code...

myexcel.Application.Quit

Set myexcel=Nothing

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript CSng 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript CSng 函数

返回 VBScript 函数参考手册

定义和用法

CSng 函数可把表达式转换为单精度（Single）类型。

注释：如果表达式在 Single 子类型允许的范围之外，则发生错误。

语法

CSng(expression)
参数 | 描述
expression | 必需的。任何有效的表达式。

实例

例子 1

dim a,b
a=23524.4522
b=23525.5533
document.write(CSng(a) & "<br />")
document.write(CSng(b))

输出分别是：

23524.45
23525.55

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript CStr 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript CStr 函数

返回 VBScript 函数参考手册

定义和用法

CStr 函数可把表达式转换为字符串（String）类型。

注释：若表达式的类型不同，那么 CStr 输出的结果也会有所不同。

语法

CStr(expression)
参数 | 描述
expression | 必需的。任何有效的表达式。

当表达式为不同的值时，CStr 返回的结果：

表达式可能的值 | CStr 相应的返回结果
Boolean | 字符串，包含 True 或 False。
Date | 字符串，包含系统的短日期格式日期。
Null | 会发生 run-time 错误。
Empty | 零长度字符串 ("")。
Error | 字符串，包含跟随有错误号码的单词 Error。
其他数值 | 字符串，包含此数字。

实例

例子 1

dim a
a=false
document.write(CStr(a))

输出分别是：

false

例子 1

dim a
a=#01/01/01#
document.write(CStr(a))

输出分别是：

2001-1-1

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Date 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Date 函数

返回 VBScript 函数参考手册

定义和用法

Date 函数可返回当前的系统日期。

语法

Date

提示和注释

重要事项：

如果同时读取 Date、Time 以及 Now，那么 Now = Date + Time，但是实际上，我们不可能同时调用这三个函数，因为执行完一个函数之后，才能执行另一个函数，所以如果您在程序中必需同时取得当时的日期和时间，必需调用 Now，再利用 DateVale 及 TimeValue 分别取出日期和时间。

实例：取得某一时间点的日期和时间：

N = Now '这个时间点的日期和时间
D = Datevalue(N) '同一时间点的日期部分
T = TimeValue(N) '同一时间点的时间部分
D2 = Date '时间点1的日期
T2 = Time '时间点2的时间

问题思考

连续执行 Response.write Now 及 Response.Write Date + Time，则可能出现的最大误差值有多大？假设：

时间点1取得的	Now = #7/1/95 23:59:59#
时间点2取得的	Date = #7/1/95#

而如果“时间点3”刚好跨过一日，所以 Time = #0:00:00，于是 Now 与 Date+Time 的差距便成了23:59:59。

实例

例子 1

document.write("The current system date is: ")
document.write(Date)

输出：

The current system date is: 1/14/2002

TIY

Date
如何使用 Date 函数来显示当前日期。

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript DateAdd 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript DateAdd 函数

返回 VBScript 函数参考手册

定义和用法

DateAdd 函数可返回已添加指定时间间隔的日期。

语法

DateAdd(interval,number,date)
参数 | 描述
interval

必需的。需要增加的时间间隔。

可采用下面的值：

  • yyyy - 年
  • q - 季度
  • m - 月
  • y - 当年的第几天
  • d - 日
  • w - 当周的第几天
  • ww - 周
  • h - 小时
  • n - 分钟
  • s - 秒
number | 必需的。需要添加的时间间隔的数目。可对未来的日期使用正值，对过去的日期使用负值。
date | 必需的。代表被添加的时间间隔的日期的变量或文字。

实例

例子 1

给 January 31, 2000 增加一个月：

document.write(DateAdd("m",1,"31-Jan-00"))

输出：

2/29/2000

例子 1

给 January 31, 2001 增加一个月：

document.write(DateAdd("m",1,"31-Jan-01"))

输出：

2/28/2001

例子 1

从 January 31, 2001 减去一个月：

document.write(DateAdd("m",-1,"31-Jan-01"))

输出：

12/31/2000

TIY

DateAdd
如何使用 DateAdd 函数为日期增加一个月。
DateAdd
如何使用 DateAdd 函数从日期减去一个月。

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript DateDiff 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript DateDiff 函数

返回 VBScript 函数参考手册

定义和用法

DateDiff 函数可返回两个日期之间的时间间隔数。

DateDiff 函数用于计算两日期时间的差值，计算方法是 date2 - date1。

若比较年份，则不管月份一下的数值，若比较月份，则不管天数以下的数值...... 以此类推。

注释：firstdayofweek 参数会对使用“w”和“ww”间隔符号的计算产生影响。

语法

DateDiff(interval,date1,date2[,firstdayofweek[,firstweekofyear]])
参数 | 描述
interval

必需的。计算 date1 和 date2 之间的时间间隔的单位。

可采用下面的值：

  • yyyy - 年
  • q - 季度
  • m - 月
  • y - 当年的第几天
  • d - 日
  • w - 当周的第几天
  • ww - 周
  • h - 小时
  • n - 分钟
  • s - 秒
date1,date2 | 必需的。日期表达式。在计算中需要使用的两个日期。
firstdayofweek

可选的。规定一周的日数，即当周的第几天。

可采用下面的值：

  • 0 = vbUseSystemDayOfWeek - 使用区域语言支持 (NLS) API 设置。
  • 1 = vbSunday - 星期日 (默认)
  • 2 = vbMonday - 星期一
  • 3 = vbTuesday - 星期二
  • 4 = vbWednesday - 星期三
  • 5 = vbThursday - 星期四
  • 6 = vbFriday - 星期五
  • 7 = vbSaturday - 星期六
firstweekofyear

可选的。规定一年中的第一周。

可采用下面的值：

  • 0 = vbUseSystem - 使用区域语言支持 (NLS) API 设置。
  • 1 = vbFirstJan1 - 由 1 月 1 日所在的星期开始（默认）。
  • 2 = vbFirstFourDays - 由在新年中至少有四天的第一周开始。
  • 3 = vbFirstFullWeek - 由在新的一年中第一个完整的周开始。

实例

例子 1

document.write(Date & "<br />")
document.write(DateDiff("m",Date,"12/31/2002") & "<br />")
document.write(DateDiff("d",Date,"12/31/2002") & "<br />")
document.write(DateDiff("n",Date,"12/31/2002"))

输出：

1/14/2002
11
351
505440

例子 2

请注意在下面的代码中，date1>date2：

document.write(Date & "<br />")
document.write(DateDiff("d","12/31/2002",Date))

输出：

1/14/2002
-351

例子 3

'How many weeks (start on Monday),
'are left between the current date and 10/10/2002
document.write(Date & "<br />")
document.write(DateDiff("w",Date,"10/10/2002",vbMonday))

输出：

1/14/2002
38

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript DatePart 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript DatePart 函数

返回 VBScript 函数参考手册

定义和用法

DatePart 函数可返回给定日期的指定部分。

注释：firstdayofweek 参数会对使用“w”和“ww”间隔符号的计算产生影响。

语法

DatePart(interval,date[,firstdayofweek[,firstweekofyear]])
参数 | 描述
interval

必需的。计算 date1 和 date2 之间的时间间隔的单位。

可采用下面的值：

  • yyyy - 年
  • q - 季度
  • m - 月
  • y - 当年的第几天
  • d - 日
  • w - 当周的第几天
  • ww - 周
  • h - 小时
  • n - 分钟
  • s - 秒
date | 必需的。需计算的日期表达式。
firstdayofweek

可选的。规定一周的日数，即当周的第几天。

可采用下面的值：

  • 0 = vbUseSystemDayOfWeek - 使用区域语言支持 (NLS) API 设置。
  • 1 = vbSunday - 星期日 (默认)
  • 2 = vbMonday - 星期一
  • 3 = vbTuesday - 星期二
  • 4 = vbWednesday - 星期三
  • 5 = vbThursday - 星期四
  • 6 = vbFriday - 星期五
  • 7 = vbSaturday - 星期六
firstweekofyear

可选的。规定一年中的第一周。

可采用下面的值：

  • 0 = vbUseSystem - 使用区域语言支持 (NLS) API 设置。
  • 1 = vbFirstJan1 - 由 1 月 1 日所在的星期开始（默认）。
  • 2 = vbFirstFourDays - 由在新年中至少有四天的第一周开始。
  • 3 = vbFirstFullWeek - 由在新的一年中第一个完整的周开始。

实例

例子 1

d = #2/10/96 16:45:30#
document.write(DatePart("yyyy",d)) '输出：1996
document.write(DatePart("m",d)) '输出：2
document.write(DatePart("d",d)) '输出：10
document.write(DatePart("h",d)) '输出：16
document.write(DatePart("n",d)) '输出：45
document.write(DatePart("s",d)) '输出：30
document.write(DatePart("q",d)) '输出：1，2月是第1季
document.write(DatePart("y",d)) '输出：41，2月10日是1996年的第41日。
document.write(DatePart("ww",d)) '输出：6，2月10日是1996年的第6周。
document.write(DatePart("w",d)) '输出：7，2月10日在在1996年是第6周的第7日（星期六）。

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript DateSerial 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript DateSerial 函数

返回 VBScript 函数参考手册

定义和用法

DateSerial 函数可返回指定的年、月、日的子类型 Date 的 Variant 。

也就是说，DateSerial 函数可以把年、月、日合并为日期。

语法

DateSerial(year,month,day)
参数 | 描述
year | 必需的。介于100到9999的数字，或数值表达式。介于 0 到 99 的值被视为 1900–1999。对于所有其他的 year 参数，请使用完整的4位年份。
month | 必需的。任何数值表达式。若大于12，则日期从12月起向后推算mouth-12个月，若小于1，则日期从1月起向前推算1-month个月。
day | 必需的。任何数值表达式。若大于当月的日数，则日期从当月日数起，向后推算day-当月日数；若小于1，则日期从1日起向前推算1-day日。

实例

例子 1

document.write(DateSerial(1996,2,3)) '普通的调用方法

输出：

1996/2/3

例子 2

document.write(DateSerial(95,13,10)) '13月=1年+1月

输出：

1996/01/10

例子 3

document.write(DateSerial(96,-1,10)) '-1月要从1月起向前推算1-（-1）=2个月

输出：

1995/11/10

例子 4

document.write(DateSerial(95,2,30)) '95年2月有28日，所以30日=1月+2日

输出：

1995/03/02

例子 5

document.write(DateSerial(95,2,-2)) '-2日要从1日起向前推算1-（-2）=3日

输出：

1995/01/29

例子

document.write(DateSerial(1990-20,9-2,1-1))
'1990-20=1970年，9-2=7月，1-1=0日，0日要从1日起向前推算1-0=1日。

输出：

1970/6/30

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript DateValue 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript DateValue 函数

返回 VBScript 函数参考手册

定义和用法

DateValue 函数可返回一个日期类型。

也就是说，DateValue 函数可从表达式中取回日期。

注释：如果日期中的年份部分不省略，那么函数会使用来自计算机系统日期的当前年份。

注释：如果日期参数含有时间信息，那么时间信息不会被返回。如果日期中含有无效的时间信息，那么会发生 run-time 错误。

注释：如果参数中不含日期，那么 DateValue 函数将返回0 ，若输出则是12:00:00 AM，即0。

语法

DateValue(date)
参数 | 描述
date | 必需的。一个介于100年1月1日到9999年12月31日的日期，或者任何可表示日期、时间或日期时间兼而有之的表达式。

实例

例子 1

document.write(DateValue("31-Jan-02"))

输出：

1/31/2002

例子 2

document.write(DateValue("31-Jan")) '假设当年是2002年，则输出的是系统日期的年份

输出：

1/31/2002

例子 3

document.write(DateValue("31-Jan-02 2:39:49 AM"))
'如果参数同时包含日期和时间，则只输出日期。

输出：

1/31/2002

例子 4

document.write(DateValue("2:39:49 AM")) '输出 12:00:00 AM ，相当于0。

输出：

12:00:00 AM

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Day 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Day 函数

返回 VBScript 函数参考手册

定义和用法

Day 函数可返回介于 1 到 31 之间的一个代表月的天数的数字。

语法

Day(date)
参数 | 描述
date | 必需的。可表示一个日期的表达式。

实例

例子 1

document.write(Date & "<br />")
document.write(Day(Date))

输出：

1/14/2002
14

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Exp 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Exp 函数

返回 VBScript 函数参考手册

定义和用法

Exp 函数可e（自然对数的底）的幂次方。

注释：值不能超过 709.782712893 。常数 e 的值约为 2.718282。

提示：请参阅 Log 函数。Exp 函数完成 Log 函数的反运算，并且有时引用为反对数形式。

语法

Cos(number)
参数 | 描述
number | 必需的。有效的数值表达式。

实例

例子 1

document.write(Exp(6.7))

输出：

812.405825167543

例子 2

document.write(Exp(-6.7))

输出：

1.23091190267348E-03

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Filter 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Filter 函数

返回 VBScript 函数参考手册

定义和用法

Filter 函数可返回一个基于 0 的数组，此数组包含以特定过滤条件为基础的字符串数组的子集。

注释：如果找不到与 value 参数相匹配的值，Filter 函数会返回一个空数组。

注释：若参数 inputstrings 为 Null 或者不是一维数组，则会发生错误。

语法

Filter(inputstrings,value[,include[,compare]])
参数 | 描述
inputstrings | 必需的。需检索的一维字符串数组。
value | 必需的。要搜索的字符串。
include | 可选项。Boolean 值，指定返回的子字符串是否包含 Value。如果 Include 为 True，Filter 将返回包含子字符串 Value 的数组子集。如果 Include 为 False，Filter 将返回不包含子字符串 Value 的数组子集。
compare | 可选的。规定所使用的字符串比较类型。

参数 compare 的值：

常数 | 值 | 描述
vbBinaryCompare | 0 | 执行二进制比较。
vbTextCompare | 1 | 执行文本比较。

实例

例子 1

dim a(5),b
a(0)="Saturday"
a(1)="Sunday"
a(2)="Monday"
a(3)="Tuesday"
a(4)="Wednesday"
b=Filter(a,"n")
document.write(b(0))
document.write(b(1))
document.write(b(2))

输出：

Sunday
Monday
Wednesday

例子 2

dim a(5),b
a(0)="Saturday"
a(1)="Sunday"
a(2)="Monday"
a(3)="Tuesday"
a(4)="Wednesday"
b=Filter(a,"n",false)
document.write(b(0))
document.write(b(1))
document.write(b(2))

输出：

Saturday
Tuesday

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Fix 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Fix 函数

返回 VBScript 函数参考手册

定义和用法

Fix 函数可返回指定数字的整数部分。

注释：若 number 参数包含 Null ，则返回 Null 。

提示：请参阅 Int 函数。Int 和 Fix 函数都删除 number 参数的小数部分并返回以整数表示的结果。

Int 和 Fix 函数的区别在于如果 number 参数为负数时，Int 函数返回小于或等于 number 的第一个负整数，而 Fix 函数返回大于或等于 number 参数的第一个负整数。例如，Int 将 -8.4 转换为 -9，而 Fix 函数将 -8.4 转换为 -8。

语法

Int(number)
参数 | 描述
number | 必需的。有效的数值表达式。

实例

例子 1

document.write(Fix(6.83227))

输出：

6

例子 2

document.write(Fix(6.23443))

输出：

6

例子 3

document.write(Fix(-6.13443))

输出：

-6

例子 4

document.write(Fix(-6.93443))

输出：

-6

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript FormatCurrency 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript FormatCurrency 函数

返回 VBScript 函数参考手册

定义和用法

FormatCurrency 函数可返回作为货币值被格式化的表达式，使用系统控制面板中定义的货币符号。

语法

FormatCurrency(Expression[,NumDigAfterDec[,
IncLeadingDig[,UseParForNegNum[,GroupDig]]]])
参数 | 描述
expression | 必需的。需被格式化的表达式。
NumDigAfterDec | 指示小数点右侧显示位数的数值。默认值为 -1（使用的是计算机的区域设置）。
IncLeadingDig 可选的。指示是否显示小数值的前导零（leading zero）：
  • -2 = TristateUseDefault - 使用计算机区域设置中的设置。
  • -1 = TristateTrue - True
  • 0 = TristateFalse - False
UseParForNegNum 可选的。指示是否将负值置于括号中。
  • -2 = TristateUseDefault - 使用计算机区域设置中的设置。
  • -1 = TristateTrue - True
  • 0 = TristateFalse - False
GroupDig 可选的。指示是否使用计算机区域设置中指定的数字分组符号将数字分组。
  • -2 = TristateUseDefault - 使用计算机区域设置中的设置。
  • -1 = TristateTrue - True
  • 0 = TristateFalse - False

实例

例子 1

document.write(FormatCurrency(20000))

输出：

￥20,000.00

例子 2

document.write(FormatCurrency(20000.578,2))

输出：

￥20,000.58

例子 3

document.write(FormatCurrency(20000.578,2,,,0))

输出：

￥20000.58

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript FormatDateTime 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript FormatDateTime 函数

返回 VBScript 函数参考手册

定义和用法

FormatDateTime 函数可格式化并返回一个合法的日期或时间表达式。

语法

FormatDateTime(date,format)
参数 | 描述
date | 必需的。任何合法的日期表达式。(比如 Date() 或 Now())
format | 可选的。规定所使用的日期/时间格式的格式值。

format 参数：

常数 | 值 | 描述
vbGeneralDate | 0 | 显示日期和/或时间。如果有日期部分，则将该部分显示为短日期格式。如果有时间部分，则将该部分显示为长时间格式。如果都存在，则显示所有部分。
vbLongDate | 1 | 使用计算机区域设置中指定的长日期格式显示日期。
vbShortDate | 2 | 使用计算机区域设置中指定的短日期格式显示日期。
vbLongTime | 3 | 使用此格式显示时间：hh:mm:ss PM/AM
vbShortTime | 4 | 使用 24 小时格式 (hh:mm) 显示时间。

实例

例子 1

D = #2001/2/22#
document.write(FormatDateTime(D))

输出：

2001-2-22

例子 2

D = #2001/2/22#
document.write(FormatDateTime(D,1))

输出：

2001年2月22日

例子 3

D = #2001/2/22#
document.write(FormatDateTime(D,2))

输出：

2001-2-22

例子 4

D = #2001/2/22#
document.write(FormatDateTime(D,3))

输出：

2001-2-22

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript FormatNumber 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript FormatNumber 函数

返回 VBScript 函数参考手册

定义和用法

FormatNumber 函数可返回作为数字被格式化的表达式。

语法

FormatNumber(Expression[,NumDigAfterDec[,
IncLeadingDig[,UseParForNegNum[,GroupDig]]]])
参数 | 描述
expression | 必需的。需被格式化的表达式。
NumDigAfterDec | 指示小数点右侧显示位数的数值。默认值为 -1（使用的是计算机的区域设置）。
IncLeadingDig 可选的。指示是否显示小数值的前导零（leading zero）：
  • -2 = TristateUseDefault - 使用计算机区域设置中的设置。
  • -1 = TristateTrue - True
  • 0 = TristateFalse - False
UseParForNegNum 可选的。指示是否将负值置于括号中。
  • -2 = TristateUseDefault - 使用计算机区域设置中的设置。
  • -1 = TristateTrue - True
  • 0 = TristateFalse - False
GroupDig 可选的。指示是否使用计算机区域设置中指定的数字分组符号将数字分组。
  • -2 = TristateUseDefault - 使用计算机区域设置中的设置。
  • -1 = TristateTrue - True
  • 0 = TristateFalse - False

实例

例子 1

document.write(FormatNumber(20000))

输出：

20,000.00

例子 2

document.write(FormatNumber(20000.578,2))

输出：

20,000.58

例子 3

document.write(FormatNumber(20000.578,2,,,0))

输出：

20000.58

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript FormatPercent 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript FormatPercent 函数

返回 VBScript 函数参考手册

定义和用法

FormatPercent 函数可返回作为百分数被格式化的表达式（尾随有 % 符号的百分比（乘以 100 ））。

语法

FormatPercent(Expression[,NumDigAfterDec[,
IncLeadingDig[,UseParForNegNum[,GroupDig]]]])
参数 | 描述
expression | 必需的。需被格式化的表达式。
NumDigAfterDec | 指示小数点右侧显示位数的数值。默认值为 -1（使用的是计算机的区域设置）。
IncLeadingDig 可选的。指示是否显示小数值的前导零（leading zero）：
  • -2 = TristateUseDefault - 使用计算机区域设置中的设置。
  • -1 = TristateTrue - True
  • 0 = TristateFalse - False
UseParForNegNum 可选的。指示是否将负值置于括号中。
  • -2 = TristateUseDefault - 使用计算机区域设置中的设置。
  • -1 = TristateTrue - True
  • 0 = TristateFalse - False
GroupDig 可选的。指示是否使用计算机区域设置中指定的数字分组符号将数字分组。
  • -2 = TristateUseDefault - 使用计算机区域设置中的设置。
  • -1 = TristateTrue - True
  • 0 = TristateFalse - False

实例

例子 1

' 6 是 345 的百分之几?
document.write(FormatPercent(6/345))

输出：

1.74%

例子 2

' 6 是 345 的百分之几?
document.write(FormatPercent(6/345,1))

输出：

1.7%

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript GetLocale 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript GetLocale 函数

返回 VBScript 函数参考手册

定义和用法

GetLocale 函数可返回当前的 locale ID 。

locale 是用户参考信息集合，比如用户的语言、国家和文化传统。locale 决定键盘布局、字母排序顺序和日期、时间、数字与货币格式等等。

返回值可以是任意一个 32-位 的值，如 区域设置 ID 所示。

语法

GetLocale()

实例

例子 1

dim c
c=GetLocale
document.write(c)

输出：

1033

Locale ID 表

Locale 描述 | 简写 | 十六进制值 | 十进制值
Afrikaans | af | 0x0436 | 1078
Albanian | sq | 0x041C | 1052
Arabic ?United Arab Emirates | ar-ae | 0x3801 | 14337
Arabic - Bahrain | ar-bh | 0x3C01 | 15361
Arabic - Algeria | ar-dz | 0x1401 | 5121
Arabic - Egypt | ar-eg | 0x0C01 | 3073
Arabic - Iraq | ar-iq | 0x0801 | 2049
Arabic - Jordan | ar-jo | 0x2C01 | 11265
Arabic - Kuwait | ar-kw | 0x3401 | 13313
Arabic - Lebanon | ar-lb | 0x3001 | 12289
Arabic - Libya | ar-ly | 0x1001 | 4097
Arabic - Morocco | ar-ma | 0x1801 | 6145
Arabic - Oman | ar-om | 0x2001 | 8193
Arabic - Qatar | ar-qa | 0x4001 | 16385
Arabic - Saudi Arabia | ar-sa | 0x0401 | 1025
Arabic - Syria | ar-sy | 0x2801 | 10241
Arabic - Tunisia | ar-tn | 0x1C01 | 7169
Arabic - Yemen | ar-ye | 0x2401 | 9217
Armenian | hy | 0x042B | 1067
Azeri ?Latin | az-az | 0x042C | 1068
Azeri ?Cyrillic | az-az | 0x082C | 2092
Basque | eu | 0x042D | 1069
Belarusian | be | 0x0423 | 1059
Bulgarian | bg | 0x0402 | 1026
Catalan | ca | 0x0403 | 1027
Chinese - China | zh-cn | 0x0804 | 2052
Chinese - Hong Kong S.A.R. | zh-hk | 0x0C04 | 3076
Chinese ?Macau S.A.R | zh-mo | 0x1404 | 5124
Chinese - Singapore | zh-sg | 0x1004 | 4100
Chinese - Taiwan | zh-tw | 0x0404 | 1028
Croatian | hr | 0x041A | 1050
Czech | cs | 0x0405 | 1029
Danish | da | 0x0406 | 1030
Dutch ?The Netherlands | nl-nl | 0x0413 | 1043
Dutch - Belgium | nl-be | 0x0813 | 2067
English - Australia | en-au | 0x0C09 | 3081
English - Belize | en-bz | 0x2809 | 10249
English - Canada | en-ca | 0x1009 | 4105
English ?Carribbean | en-cb | 0x2409 | 9225
English - Ireland | en-ie | 0x1809 | 6153
English - Jamaica | en-jm | 0x2009 | 8201
English - New Zealand | en-nz | 0x1409 | 5129
English ?Phillippines | en-ph | 0x3409 | 13321
English - South Africa | en-za | 0x1C09 | 7177
English - Trinidad | en-tt | 0x2C09 | 11273
English - United Kingdom | en-gb | 0x0809 | 2057
English - United States | en-us | 0x0409 | 1033
Estonian | et | 0x0425 | 1061
Farsi | fa | 0x0429 | 1065
Finnish | fi | 0x040B | 1035
Faroese | fo | 0x0438 | 1080
French - France | fr-fr | 0x040C | 1036
French - Belgium | fr-be | 0x080C | 2060
French - Canada | fr-ca | 0x0C0C | 3084
French - Luxembourg | fr-lu | 0x140C | 5132
French - Switzerland | fr-ch | 0x100C | 4108
Gaelic ?Ireland | gd-ie | 0x083C | 2108
Gaelic - Scotland | gd | 0x043C | 1084
German - Germany | de-de | 0x0407 | 1031
German - Austria | de-at | 0x0C07 | 3079
German - Liechtenstein | de-li | 0x1407 | 5127
German - Luxembourg | de-lu | 0x1007 | 4103
German - Switzerland | de-ch | 0x0807 | 2055
Greek | el | 0x0408 | 1032
Hebrew | he | 0x040D | 1037
Hindi | hi | 0x0439 | 1081
Hungarian | hu | 0x040E | 1038
Icelandic | is | 0x040F | 1039
Indonesian | id | 0x0421 | 1057
Italian - Italy | it-it | 0x0410 | 1040
Italian - Switzerland | it-ch | 0x0810 | 2064
Japanese | ja | 0x0411 | 1041
Korean | ko | 0x0412 | 1042
Latvian | lv | 0x0426 | 1062
Lithuanian | lt | 0x0427 | 1063
FYRO Macedonian | mk | 0x042F | 1071
Malay - Malaysia | ms-my | 0x043E | 1086
Malay ?Brunei | ms-bn | 0x083E | 2110
Maltese | mt | 0x043A | 1082
Marathi | mr | 0x044E | 1102
Norwegian - Bokm錶 | no-no | 0x0414 | 1044
Norwegian ?Nynorsk | no-no | 0x0814 | 2068
Polish | pl | 0x0415 | 1045
Portuguese - Portugal | pt-pt | 0x0816 | 2070
Portuguese - Brazil | pt-br | 0x0416 | 1046
Raeto-Romance | rm | 0x0417 | 1047
Romanian - Romania | ro | 0x0418 | 1048
Romanian - Moldova | ro-mo | 0x0818 | 2072
Russian | ru | 0x0419 | 1049
Russian - Moldova | ru-mo | 0x0819 | 2073
Sanskrit | sa | 0x044F | 1103
Serbian - Cyrillic | sr-sp | 0x0C1A | 3098
Serbian ?Latin | sr-sp | 0x081A | 2074
Setsuana | tn | 0x0432 | 1074
Slovenian | sl | 0x0424 | 1060
Slovak | sk | 0x041B | 1051
Sorbian | sb | 0x042E | 1070
Spanish - Spain | es-es | 0x0C0A | 1034
Spanish - Argentina | es-ar | 0x2C0A | 11274
Spanish - Bolivia | es-bo | 0x400A | 16394
Spanish - Chile | es-cl | 0x340A | 13322
Spanish - Colombia | es-co | 0x240A | 9226
Spanish - Costa Rica | es-cr | 0x140A | 5130
Spanish - Dominican Republic | es-do | 0x1C0A | 7178
Spanish - Ecuador | es-ec | 0x300A | 12298
Spanish - Guatemala | es-gt | 0x100A | 4106
Spanish - Honduras | es-hn | 0x480A | 18442
Spanish - Mexico | es-mx | 0x080A | 2058
Spanish - Nicaragua | es-ni | 0x4C0A | 19466
Spanish - Panama | es-pa | 0x180A | 6154
Spanish - Peru | es-pe | 0x280A | 10250
Spanish - Puerto Rico | es-pr | 0x500A | 20490
Spanish - Paraguay | es-py | 0x3C0A | 15370
Spanish - El Salvador | es-sv | 0x440A | 17418
Spanish - Uruguay | es-uy | 0x380A | 14346
Spanish - Venezuela | es-ve | 0x200A | 8202
Sutu | sx | 0x0430 | 1072
Swahili | sw | 0x0441 | 1089
Swedish - Sweden | sv-se | 0x041D | 1053
Swedish - Finland | sv-fi | 0x081D | 2077
Tamil | ta | 0x0449 | 1097
Tatar | tt | 0X0444 | 1092
Thai | th | 0x041E | 1054
Turkish | tr | 0x041F | 1055
Tsonga | ts | 0x0431 | 1073
Ukrainian | uk | 0x0422 | 1058
Urdu | ur | 0x0420 | 1056
Uzbek ?Cyrillic | uz-uz | 0x0843 | 2115
Uzbek ?Latin | uz-uz | 0x0443 | 1091
Vietnamese | vi | 0x042A | 1066
Xhosa | xh | 0x0434 | 1076
Yiddish | yi | 0x043D | 1085
Zulu | zu | 0x0435 | 1077

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript GetObject 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript GetObject 函数

返回 VBScript 函数参考手册

定义和用法

GetObject 函数可返回对文件中 Automation 对象的引用。

语法

GetObject([pathname][,class])
参数 | 描述
pathname | 可选的。包含 automation 对象的文件的完整路径和名称。如果此参数被忽略，就必须有 class 参数。
class | 可选的。automation 对象的类。此参数使用此语法：appname.objectype。

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript GetRef 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript GetRef 函数

返回 VBScript 函数参考手册

定义和用法

GetRef 函数可把一段 VBScript 过程（子程序）连接到页面的一个 DHTML 事件上。

语法

Set object.event=GetRef(procname)
参数 | 描述
object | 必需的。事件所关联的对象的名称。
event | Required. 要与函数绑定的事件的名称。
procname | Required. 与事件关联的 Sub 或 Function 过程的名称。

实例

Function test()
dim txt
txt="GetRef Test" & vbCrLf
txt=txt & "Hello World!"
MsgBox txt
End Function

Window.Onload=GetRef("test")

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Hex 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Hex 函数

返回 VBScript 函数参考手册

定义和用法

Hex 函数可返回一个表示指定数字的十六进制值的字符串。

注释：如果 number 参数不是整数，则在进行运算前将其四舍五入为最接近的整数。

语法

Hex(number)
参数 描述
expression

必需的。任何有效的表达式。

如果 number 是：

  • Null - 那么 Hex 函数会返回 Null。
  • Empty - 那么 Hex 函数会返回零 (0)。
  • 其他数 - 那么 Hex 函数会返回最多 8 个十六进制字符。

实例

例子 1

document.write(Hex(3))
document.write(Hex(5))
document.write(Hex(9))
document.write(Hex(10))
document.write(Hex(11))
document.write(Hex(12))
document.write(Hex(400))
document.write(Hex(459))
document.write(Hex(460))

分别输出：

3
5
9
A
B
C
190
1CB
1CC

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Hour 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Hour 函数

返回 VBScript 函数参考手册

定义和用法

Hour 函数可返回介于 0 到 23 之间的代表天的小时数的数字。

语法

Hour(time)
参数 | 描述
time | 必需的。任何可表示时间的表达式。

实例

例子 1

T = #1/15/2002 10:07:47 AM#
document.write(Hour(T))

输出：

10

例子 2

T = #10:07:47 AM#
document.write(Hour(T))

输出：

10

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript How To ...

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript How To ...

  • Previous Page
  • Next Page

实例

使用 VBScript 写文本
如何在页面上写文本。
使用 HTML 标签格式化文本
如何协同使用 HTML 标签和 VBScript。

如何在 HTML 文档中放置 VBScript

<html>
<head>
</head>
<body>

<script type="text/vbscript">
document.write("Hello from VBScript!")
</script>

</body>
</html>

上面的代码会生成以下输出：

Hello from VBScript!

如需在 HTML 文档中插入脚本，请使用 <script> 标签。使用 type 属性来定义脚本语言。

<script type="text/vbscript">

然后输入 VBScript：在页面上写文本的命令是 document.write：

document.write("Hello from VBScript!")

脚本在此结束：

</script>

如何应对老式的浏览器

不支持脚本的老式浏览器会把脚本作为网页的内容显示出来。为了避免出现这样的情况，我们可以使用 HTML 的注释标签：

<script type="text/vbscript">
<!--
  在此输入语句
-->
</script>
  • Previous Page
  • Next Page

VBScript 参考手册
VBScript 实例


VBScript InputBox 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript InputBox 函数

返回 VBScript 函数参考手册

定义和用法

InputBox 函数可显示一个对话框，用户可在其中输入文本并/或点击一个按钮。如果用户点击点击确认按钮或按键盘上的回车键， 则 InputBox 函数返回文本框中的文本。如果用户点击取消按钮，函数返回一个空字符串("")。

注释：若同时规定helpfile 和 context 参数，则会向对话框添加一个帮助按钮。

提示：请参阅 MsgBox 函数。

语法

InputBox(prompt[,title][,default][,xpos][,ypos][,helpfile,context])
参数 | 描述
prompt | 必需的。现实在对话框中的消息。prompt 的最大长度大约是 1024 个字符，这取决于所使用的字符的宽度。如果 prompt 中包含多个行，则可在各行之间用回车符 (Chr(13))、换行符 (Chr(10)) 或回车换行符的组合 (Chr(13) & Chr(10)) 以分隔各行。
title | 可选的。显示在对话框标题栏中的字符串表达式。如果省略 title，则应用程序的名称将显示在标题栏中。
default | 可选的。显示在文本框中的字符串表达式，在没有其它输入时作为默认的响应值。如果省略 default，则文本框为空。
xpos | 可选的。数值表达式，用于指定对话框的左边缘与屏幕左边缘的水平距离（单位为缇）。如果省略 xpos，则对话框会在水平方向居中。
ypos | 可选的。数值表达式，用于指定对话框的上边缘与屏幕上边缘的垂直距离（单位为缇）。如果省略 ypos，则对话框显示在屏幕垂直方向距下边缘大约三分之一处。
helpfile | 可选的。字符串表达式，用于标识为对话框提供上下文相关帮助的帮助文件。如果已提供 helpfile，则必须提供 context。
context | 可选的。数值表达式，用于标识由帮助文件的作者指定给某个帮助主题的上下文编号。如果已提供 context，则必须提供 helpfile。

实例

dim fname
fname=InputBox("Enter your name:")
MsgBox("Your name is " & fname)

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript InStr 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript InStr 函数

返回 VBScript 函数参考手册

定义和用法

InStr 函数可返回一个字符串在另一个字符串中首次出现的位置。

InStr 函数可返回下面的值：

  • 如果 string1 为 ""（零长度） - InStr 返回 0
  • 如果 string1 为 Null - InStr 返回 Null
  • 如果 string2 为 "" - InStr 返回 start
  • 如果 string2 为 Null - InStr 返回 Null
  • 如果 string2 没有找到 - InStr 返回 0
  • 如果在 string1 中找到 string2，InStr 返回找到匹配字符串的位置。
  • 如果 start > Len(string1) - InStr 返回 0

提示：请参阅 InStrRev 函数。

语法

InStr([start,]string1,string2[,compare])
参数 | 描述
start | 可选的。规定每次搜索的起始位置。默认是搜索起始位置是第一个字符。如果已规定 compare 参数，则必须有此参数。
string1 | 必需的。需要被搜索的字符串。
string2 | 必需的。需搜索的字符串。
compare

必需的。规定要使用的字符串比较类型。默认是 0 。可采用下列值：

  • 0 = vbBinaryCompare - 执行二进制比较。
  • 1 = vbTextCompare - 执行文本比较。

实例

例子 1

dim txt,pos
txt="This is a beautiful day!"
pos=InStr(txt,"his")
document.write(pos)

输出：

2

例子 2

dim txt,pos
txt="This is a beautiful day!"
'A textual comparison starting at position 4
pos=InStr(4,txt,"is",1)
document.write(pos)

输出：

6

例子 3

dim txt,pos
txt="This is a beautiful day!"
'A binary comparison starting at position 1
pos=InStr(1,txt,"B",0)
document.write(pos)

输出：

0

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript InStrRev 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript InStrRev 函数

返回 VBScript 函数参考手册

定义和用法

InStrRev 函数可返回一个字符串在另一个字符串中首次出现的位置。搜索从字符串的末端开始，但是返回的位置是从字符串的起点开始计数的。

InStrRev 函数可返回下面的值：

  • 如果 string1 为 ""（零长度） - InStr 返回 0
  • 如果 string1 为 Null - InStr 返回 Null
  • 如果 string2 为 "" - InStr 返回 start
  • 如果 string2 为 Null - InStr 返回 Null
  • 如果 string2 没有找到 - InStr 返回 0
  • 如果在 string1 中找到 string2，InStr 返回找到匹配字符串的位置。
  • 如果 start > Len(string1) - InStr 返回 0

提示：请参阅 InStr 函数。

语法

InStrRev(string1,string2[,start[,compare]])
参数 | 描述
start | 可选的。规定每次搜索的起始位置。默认是搜索起始位置是第一个字符。如果已规定 compare 参数，则必须有此参数。
string1 | 必需的。需要被搜索的字符串。
string2 | 必需的。需搜索的字符串。
compare

必需的。规定要使用的字符串比较类型。默认是 0 。可采用下列值：

  • 0 = vbBinaryCompare - 执行二进制比较。
  • 1 = vbTextCompare - 执行文本比较。

实例

例子 1

dim txt,pos
txt="This is a beautiful day!"
pos=InStrRev(txt,"his")
document.write(pos)

输出：

2

例子 2

dim txt,pos
txt="This is a beautiful day!"
'textual comparison
pos=InStrRev(txt,"B",-1,1)
document.write(pos)

输出：

11

例子 3

dim txt,pos
txt="This is a beautiful day!"
'binary comparison
pos=InStrRev(txt,"T")
document.write(pos)

输出：

1

例子 4

dim txt,pos
txt="This is a beautiful day!"
'binary comparison
pos=InStrRev(txt,"t")
document.write(pos)

输出：

15

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Int 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Int 函数

返回 VBScript 函数参考手册

定义和用法

Int 函数可返回指定数字的整数部分。

注释：若 number 参数包含 Null ，则返回 Null 。

提示：请参阅 Fix 函数。Int 和 Fix 函数都删除 number 参数的小数部分并返回以整数表示的结果。

Int 和 Fix 函数的区别在于如果 number 参数为负数时，Int 函数返回小于或等于 number 的第一个负整数，而 Fix 函数返回大于或等于 number 参数的第一个负整数。例如，Int 将 -8.4 转换为 -9，而 Fix 函数将 -8.4 转换为 -8。

语法

Int(number)
参数 | 描述
number | 必需的。有效的数值表达式。

实例

例子 1

document.write(Int(6.83227))

输出：

6

例子 2

document.write(Int(6.23443))

输出：

6

例子 3

document.write(Int(-6.13443))

输出：

-7

例子 4

document.write(Int(-6.93443))

输出：

-7

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript IsArray 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript IsArray 函数

返回 VBScript 函数参考手册

定义和用法

IsArray 函数可返回一个指示指定的变量是否为数组的布尔值。如果变量为数组，则返回 True，否则返回 False。

语法

IsArray(variable)
参数 | 描述
variable | 必需的。任何变量。

实例

例子 1

dim a(5)
a(0)="Saturday"
a(1)="Sunday"
a(2)="Monday"
a(3)="Tuesday"
a(4)="Wednesday"
document.write(IsArray(a))

输出：

True

例子 2

dim a
a="Saturday"
document.write(IsArray(a))

输出：

False

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript IsDate 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript IsDate 函数

返回 VBScript 函数参考手册

定义和用法

IsDate 函数可一个布尔值，指示经计算的表达式是否可被转换为日期。如果表达式是日期，或可被转换为日期，则返回 True 。否则，返回 False 。

注释：IsDate 函数使用本地设置来检测字符串是否可以转换为日期。

语法

IsDate(expression)
参数 | 描述
expression | 必需的。要计算的表达式。

实例

例子 1

document.write(IsDate("April 22, 1947"))

输出：

True

例子 2

document.write(IsDate(#11/11/01#))

输出：

True

例子 3

document.write(IsDate("#11/11/01#"))

输出：

False

例子 4

document.write(IsDate("Hello World!"))

输出：

False

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript IsEmpty 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript IsEmpty 函数

返回 VBScript 函数参考手册

定义和用法

IsEmpty 函数可返回指定的变量是否被初始化的布尔值。如果未被初始化，则返回 true ，否则返回 False 。

语法

IsEmpty(expression)
参数 | 描述
expression | 必需的。表达式（通常是一个变量名）。

实例

dim x
document.write(IsEmpty(x))
x=10
document.write(IsEmpty(x))
x=Empty
document.write(IsEmpty(x))
x=Null
document.write(IsEmpty(x))

分别输出：

True
False
True
False

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript IsNull 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript IsNull 函数

返回 VBScript 函数参考手册

定义和用法

IsNull 函数可返回指示指定表达式是否无效数据的布尔值。如果表达式是 Null，则返回 True，否则返回 False。

语法

IsNull(expression)
参数 | 描述
expression | 必需的。表达式。

实例

dim x
document.write(IsNull(x))
x=10
document.write(IsNull(x))
x=Empty
document.write(IsNull(x))
x=Null
document.write(IsNull(x))

分别输出：

False
False
False
True

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript IsNumeric 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript IsNumeric 函数

返回 VBScript 函数参考手册

定义和用法

IsNumeric 函数可返回指示指定的表达式是否可作为数字来计算的布尔值。如果作为数字来计算，则返回 True ，否则返回 False。

注释：如果表达式是日期表达式，则 IsNumeric 返回 False。

语法

IsNumeric(expression)
参数 | 描述
expression | 必需的。表达式。

实例

dim x
x=10
document.write(IsNumeric(x))
x=Empty
document.write(IsNumeric(x))
x=Null
document.write(IsNumeric(x))
x="10"
document.write(IsNumeric(x))
x="911 Help"
document.write(IsNumeric(x))

分别输出：

True
True
False
True
False

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript IsObject 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript IsObject 函数

返回 VBScript 函数参考手册

定义和用法

IsObject 函数可返回指示是否指定的表达式是一个 automation 对象的布尔值。如果表达式是对象，则返回 True 。否则返回 False。

语法

IsObject(expression)
参数 | 描述
expression | 必需的。表达式。

实例

例子 1

dim x
set x=me
document.write(IsObject(x))

输出：

True

例子 2

dim x
x="me"
document.write(IsObject(x))

输出：

False

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Join 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Join 函数

返回 VBScript 函数参考手册

定义和用法

Join 函数可返回一个由某个数组中一系列子字符串组成的字符串。

语法

Join(list[,delimiter])
参数 | 描述
list | 必需的。一维数组，其中包含需被连接的子字符串。
delimiter | 可选的。用于在返回的字符串中分割子字符串的字符。默认是空格字符。

实例

例子 1

dim a(5),b
a(0)="Saturday"
a(1)="Sunday"
a(2)="Monday"
a(3)="Tuesday"
a(4)="Wednesday"
b=Filter(a,"n")
document.write(join(b))

输出：

Sunday Monday Wednesday

例子 2

dim a(5),b
a(0)="Saturday"
a(1)="Sunday"
a(2)="Monday"
a(3)="Tuesday"
a(4)="Wednesday"
b=Filter(a,"n")
document.write(join(b,", "))

输出：

Sunday, Monday, Wednesday

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript LBound 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript LBound 函数

返回 VBScript 函数参考手册

定义和用法

LBound 函数可返回指示数组维数的最小下标。

注释：任何维数的 LBound 总是 0。

提示：LBound 函数与 UBound 函数共同使用，可以确定数组的大小。使用 UBound 函数可以找到数组某一维的上界。

语法

LBound(arrayname[,dimension])
参数 | 描述
arrayname | 必需的。数组变量的名称。
dimension | 可选的。要返回哪一维的下界。 1 = 第一维， 2 = 第二维，以此类推。默认是 1 。

实例

例子 1

dim a(10)
a(0)="Saturday"
a(1)="Sunday"
a(2)="Monday"
a(3)="Tuesday"
a(4)="Wednesday"
a(5)="Thursday"
document.write(UBound(a))
document.write("<br />")
document.write(LBound(a))

输出：

10
0

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript LCase 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript LCase 函数

返回 VBScript 函数参考手册

定义和用法

LCase 函数可把指定的字符串转换为小写。

提示：请参阅 UCase 函数。

语法

LCase(string)
参数 | 描述
string | 必需的。需要被转换为小写的字符串。

实例

例子 1

dim txt
txt="THIS IS A BEAUTIFUL DAY!"
document.write(LCase(txt))

输出：

this is a beautiful day!

例子 2

dim txt
txt="This Is a Beautiful Day!"
document.write(LCase(txt))

输出：

this is a beautiful day!

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Left 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Left 函数

返回 VBScript 函数参考手册

定义和用法

Left 函数可从字符串的左侧返回指定数目的字符。

提示：请使用 Len 函数来确定字符串中的字符数目。

提示：请参阅 Right 函数。

语法

Left(string,length)
参数 | 描述
string | 必需的。从其中返回字符的字符串。
length | 必需的。规定需返回多少字符。如果设置为 0，则返回空字符串("")。如果设置为大于或等于字符串的长度，则返回整个字符串。

实例

例子 1

dim txt
txt="This is a beautiful day!"
document.write(Left(txt,11))

输出：

This is a b

例子 2

dim txt
txt="This is a beautiful day!"
document.write(Left(txt,100))

输出：

This is a beautiful day!

例子 3

dim txt,x
txt="This is a beautiful day!"
x=Len(txt)
document.write(Left(txt,x))

输出：

This is a beautiful day!

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Len 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Len 函数

返回 VBScript 函数参考手册

定义和用法

Len 函数可返回字符串中字符的数目。

语法

Len(string|varname)
参数 | 描述
string | 字符串表达式。
varname | 变量名称。

实例

例子 1

dim txt
txt="This is a beautiful day!"
document.write(Len(txt))

输出：

24

例子 2

document.write(Len("This is a beautiful day!"))

输出：

24

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript LoadPicture 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript LoadPicture 函数

返回 VBScript 函数参考手册

定义和用法

LoadPicture 函数可返回一个图片对象。

可被 LoadPicture 函数识别的图形格式有：

  • bitmap 文件 (.bmp)
  • icon 文件 (.ico)
  • run-length encoded 文件 (.rle)
  • metafile 文件 (.wmf)
  • enhanced meta文件 (.emf)
  • GIF 文件 (.gif)
  • JPEG 文件 (.jpg)

注释：此函数仅供 32-位 平台。

语法

LoadPicture(picturename)
参数 | 描述
picturename | 必需的。需被载入的图片文件的文件名。

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Log 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Log 函数

返回 VBScript 函数参考手册

定义和用法

Log 函数可返回指定数据的自然对数。自然对数是以 e 为底的对数。

注释：不允许使用负值。

提示：请参阅 Exp 函数。

语法

Log(number)
参数 | 描述
number | 必需的。大于 0 合法的数值表达式。

实例

例子 1

document.write(Log(38.256783227))

输出：

3.64432088381777

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript LTrim 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript LTrim 函数

返回 VBScript 函数参考手册

定义和用法

LTrim 函数可删除字符串左侧的空格。

语法

Len(string|varname)
参数 | 描述
string | 字符串表达式。

实例

例子 1

dim txt
txt="  This is a beautiful day!  "
document.write(LTrim(txt))

输出：

"This is a beautiful day!  "

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript LTrim 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript LTrim 函数

返回 VBScript 函数参考手册

定义和用法

RTrim 函数可删除字符串右侧的空格。

语法

RTrim(string)
参数 | 描述
string | 字符串表达式。

实例

例子 1

dim txt
txt="  This is a beautiful day!  "
document.write(RTrim(txt))

输出：

"  This is a beautiful day!"

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Mid 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Mid 函数

返回 VBScript 函数参考手册

定义和用法

Mid 函数可从字符串中返回指定数目的字符。

提示：请使用 Len 函数来确定字符串中的字符数目。

语法

Mid(string,start[,length])
参数 | 描述
string | 必需的。从其中返回字符的字符串表达式。如果字符串包含 Null，则返回 Null。
start | 必需的。规定起始位置。如果设置为大于字符串中的字符数目，则返回空字符串("")。
length | 可选的。要返回的字符数目。如果省略或 length 超过文本的字符数（包括 start 处的字符），将返回字符串中从 start 到字符串结束的所有字符。

实例

例子 1

dim txt
txt="This is a beautiful day!"
document.write(Mid(txt,1,1))

输出：

T

例子 2

dim txt
txt="This is a beautiful day!"
document.write(Mid(txt,1,11))

输出：

This is a b

例子 3

dim txt
txt="This is a beautiful day!"
document.write(Mid(txt,1))

输出：

This is a beautiful day!

例子 4

dim txt
txt="This is a beautiful day!"
document.write(Mid(txt,10))

输出：

beautiful day!

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Minute 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Minute 函数

返回 VBScript 函数参考手册

定义和用法

Minute 函数可返回表示小时的分钟数的数字，介于0到59。

语法

Minute(time)
参数 | 描述
time | 必需的。表示时间的表达式。

实例

例子 1

D = #1/15/2002 10:34:39 AM#
document.write(Minute(D))

输出：

34

例子 2

T = #10:34:39 AM#
document.write(Minute(T))

输出：

34

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Month 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Month 函数

返回 VBScript 函数参考手册

定义和用法

Month 函数可返回表示年的月份的数字，介于 1 到 12。

语法

Month(date)
参数 | 描述
date | 必需的。任何可表示日期的表达式。

实例

例子 1

D = #1/15/2002#
document.write(Month(D))

输出：

1

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript MonthName 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript MonthName 函数

返回 VBScript 函数参考手册

定义和用法

MonthName 函数可返回指定的月份的名称。

语法

MonthName(month[,abbreviate])
参数 | 描述
month | 必需的。规定月的数字。（比如一月是1，二月是2，依此类推。）
abbreviate | 可选的。一个布尔值，指示是否缩写月份名称。默认是 False。

实例

例子 1

document.write(MonthName(8))

输出：

八月

例子 2

document.write(MonthName(8,true))

输出：

Aug

注释：在中文系统中，仍然输出为“八月”。

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript MsgBox 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript MsgBox 函数

返回 VBScript 函数参考手册

定义和用法

MsgBox 函数可显示一个消息框，等待用户点击某个按钮，然后返回指示被点击按钮的值。

MsgBox 函数可返回下面的值：

  • 1 = vbOK - 确定按钮被单击。
  • 2 = vbCancel - 取消按钮被单击。
  • 3 = vbAbort - 终止按钮被单击。
  • 4 = vbRetry - 重试按钮被单击。
  • 5 = vbIgnore - 忽略按钮被单击。
  • 6 = vbYes - 是按钮被单击。
  • 7 = vbNo - 否按钮被单击。

注释：当 helpfile 和 context 参数均被规定后，用户可按 F1 键来查看帮助。

提示：请参阅 InputBox 函数。

语法

MsgBox(prompt[,buttons][,title][,helpfile,context])
参数 | 描述
prompt | 必需的。作为消息显示在对话框中的字符串表达式。prompt 的最大长度大约是 1024 个字符，这取决于所使用的字符的宽度。如果 prompt 中包含多个行，则可在各行之间用回车符 (Chr(13))、换行符 (Chr(10)) 或回车换行符的组合 (Chr(13) & Chr(10)) 分隔各行。
buttons

数值表达式，是表示指定显示按钮的数目和类型、使用的图标样式，默认按钮的标识以及消息框样式的数值的总和。如果省略，则 buttons 的默认值为 0。

button 的取值：

  • 0 = vbOKOnly - 只显示确定按钮。
  • 1 = vbOKCancel - 显示确定和取消按钮。
  • 2 = vbAbortRetryIgnore - 显示放弃、重试和忽略按钮。
  • 3 = vbYesNoCancel - 显示是、否和取消按钮。
  • 4 = vbYesNo - 显示是和否按钮。
  • 5 = vbRetryCancel - 显示重试和取消按钮。
  • 16 = vbCritical - 显示临界信息图标。
  • 32 = vbQuestion - 显示警告查询图标。
  • 48 = vbExclamation - 显示警告消息图标。
  • 64 = vbInformation - 显示信息消息图标。
  • 0 = vbDefaultButton1 - 第一个按钮为默认按钮。
  • 256 = vbDefaultButton2 - 第二个按钮为默认按钮。
  • 512 = vbDefaultButton3 - 第三个按钮为默认按钮。
  • 768 = vbDefaultButton4 - 第四个按钮为默认按钮。
  • 0 = vbApplicationModal - 应用程序模式：用户必须响应消息框才能继续在当前应用程序中工作。
  • 4096 = vbSystemModal - 系统模式：在用户响应消息框前，所有应用程序都被挂起。

第一组值 (0 - 5) 用于描述对话框中显示的按钮类型与数目；第二组值 (16, 32, 48, 64) 用于描述图标的样式；第三组值 (0, 256, 512) 用于确定默认按钮；而第四组值 (0, 4096) 则决定消息框的样式。在将这些数字相加以生成 buttons 参数值时，只能从每组值中取用一个数字。
title | 显示在对话框标题栏中的字符串表达式。如果省略 title，则将应用程序的名称显示在标题栏中。
helpfile | 字符串表达式，用于标识为对话框提供上下文相关帮助的帮助文件。如果已提供 helpfile，则必须提供 context。在 16 位系统平台上不可用。
context | 数值表达式，用于标识由帮助文件的作者指定给某个帮助主题的上下文编号。如果已提供 context，则必须提供 helpfile。在 16 位系统平台上不可用。

实例

dim answer
answer=MsgBox("Hello everyone!",65,"Example")
document.write(answer)

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Now 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Now 函数

返回 VBScript 函数参考手册

定义和用法

Now 函数可根据计算机系统的日期和时间设置返回当前的日期和时间。

语法

Now

提示和注释

重要事项：

如果同时读取 Date、Time 以及 Now，那么 Now = Date + Time，但是实际上，我们不可能同时调用这三个函数，因为执行完一个函数之后，才能执行另一个函数，所以如果您在程序中必需同时取得当时的日期和时间，必需调用 Now，再利用 DateVale 及 TimeValue 分别取出日期和时间。

实例：取得某一时间点的日期和时间：

N = Now '这个时间点的日期和时间
D = Datevalue(N) '同一时间点的日期部分
T = TimeValue(N) '同一时间点的时间部分
D2 = Date '时间点1的日期
T2 = Time '时间点2的时间

问题思考

连续执行 Response.write Now 及 Response.Write Date + Time，则可能出现的最大误差值有多大？假设：

时间点1取得的	Now = #7/1/95 23:59:59#
时间点2取得的	Date = #7/1/95#

而如果“时间点3”刚好跨过一日，所以 Time = #0:00:00，于是 Now 与 Date+Time 的差距便成了23:59:59。

实例

例子 1

document.write(Now)

输出：

2007-10-1 14:10:06

注释：输出的结果可能由于不同的计算机设置而略有差异。

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Oct 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Oct 函数

返回 VBScript 函数参考手册

定义和用法

Oct 函数可返回表示指定数字八进制值的字符串。

注释：如果 number 参数不是整数，则在进行运算前将其四舍五入为最接近的整数。

语法

Hex(number)
参数 描述
number

必需的。任何有效的表达式。

如果 number 是：

  • Null - 那么 Oct 函数会返回 Null。
  • Empty - 那么 Oct 函数会返回零 (0)。
  • 其他数 - 那么 Oct 函数会返回最多 11 个十六进制字符。

实例

例子 1

document.write(Oct(3))
document.write(Oct(5))
document.write(Oct(9))
document.write(Oct(10))
document.write(Oct(11))
document.write(Oct(12))
document.write(Oct(400))
document.write(Oct(459))
document.write(Oct(460))

分别输出：

3
5
11
12
13
14
620
713
714

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Replace 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Replace 函数

返回 VBScript 函数参考手册

定义和用法

Replace 函数可使用一个字符串替换另一个字符串指定的次数。

语法

Replace(string,find,replacewith[,start[,count[,compare]]])
参数 | 描述
string | 必需的。需要被搜索的字符串。
find | 必需的。将被替换的字符串部分。
replacewith | 必需的。用于替换的子字符串。
start | 可选的。规定开始位置。默认是 1。
count | 可选的。规定指定替换的次数。默认是 -1，表示进行所有可能的替换。
compare | 可选的。规定所使用的字符串比较类型。默认是 0。

参数 compare 的值：

常数 | 值 | 描述
vbBinaryCompare | 0 | 执行二进制比较。
vbTextCompare | 1 | 执行文本比较。

Replace 可能返回的值：

参数可能的取值 | Replace 返回的值
expression 为零长度 | 零长度字符串 ("")。
expression 为 Null | 错误。
find 参数为零长度 | expression 的副本。
replacewith 参数为零长度 | expression 的副本，其中删除了所有由 find 参数指定的内容。
start > Len(expression) | 零长度字符串。
count 为 0 | expression 的副本。

实例

例子 1

dim txt
txt="This is a beautiful day!"
document.write(Replace(txt,"beautiful","horrible"))

输出：

This is a horrible day!

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript RGB 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript RGB 函数

返回 VBScript 函数参考手册

定义和用法

RGB 函数可返回表示 RGB 颜色值的数字。

语法

RGB(red,green,blue)
参数 | 描述
red | 必需的。介于 0 - 255 之间（且包括）的数字，代表颜色红色部分。
green | 必需的。介于 0 - 255 之间（且包括）的数字，代表颜色绿色部分。
blue | 必需的。介于 0 - 255 之间（且包括）的数字，代表颜色蓝色部分。

实例

例子 1

document.write(rgb(255,0,0))

输出：

255

例子 2

document.write(rgb(255,30,30))

输出：

1974015

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Right 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Right 函数

返回 VBScript 函数参考手册

定义和用法

Right 函数可从字符串右侧返回指定数目的字符。

提示：请使用Len 函数来确定字符串中的字符数目。

提示：请参阅 Left 函数。

语法

Right(string,length)
参数 | 描述
string | 必需的。从其中返回字符的字符串。
length | 必需的。规定返回多少字符。如果设置为 0，则返回空字符串 ("")。如果设置为大于或等于字符串的长度，则返回整个的字符串。

实例

例子 1

dim txt
txt="This is a beautiful day!"
document.write(Right(txt,11))

输出：

utiful day!

例子 2

dim txt
txt="This is a beautiful day!"
document.write(Right(txt,100))

输出：

This is a beautiful day!

例子 3

dim txt,x
txt="This is a beautiful day!"
x=Len(txt)
document.write(Right(txt,x))

输出：

This is a beautiful day!

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Rnd 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Rnd 函数

返回 VBScript 函数参考手册

定义和用法

Rnd 函数可返回一个随机数。数字总是小于 1 但大于或等于 0 。

因每一次连续调用 Rnd 函数时都用序列中的前一个数作为下一个数的种子，所以对于任何最初给定的种子都会生成相同的数列。

在调用 Rnd 之前，先使用无参数的 Randomize 语句初始化随机数生成器，该生成器具有基于系统计时器的种子。

要产生指定范围的随机整数，请使用以下公式：

Int((upperbound - lowerbound + 1) * Rnd + lowerbound)

这里， upperbound 是此范围的上界，而 lowerbound 是此范围内的下界。

注释：要重复随机数的序列，请在使用数值参数调用 Randomize 之前，立即用负值参数调用 Rnd。使用同样 number 值的 Randomize 不能重复先前的随机数序列。

语法

Rnd[(number)]
参数 描述
number

可选的。合法的数值表达式。

如果数字是：

  • <0 - Rnd 会每次都返回相同的值。
  • >0 - Rnd 会返回序列中的下一个随机数。
  • =0 - Rnd 返回最近生成的数。
  • 省略 - Rnd 会返回序列中的下一个随机数。

实例

例子 1

document.write(Rnd)

输出：

0.7055475

例子 2

如果您使用例子 1 中的代码，相同的随机数会重复出现。

可以使用 Randomize 语句在页面每次重新载入的时候生成一个新的随机数：

Randomize
document.write(Rnd)

输出：

0.4758112

例子 3

dim max,min
max=100
min=1
document.write(Int((max-min+1)*Rnd+min))

输出：

71

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Round 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Round 函数

返回 VBScript 函数参考手册

定义和用法

Round 函数可对数字进行四舍五入。

语法

Round(expression[,numdecimalplaces])
参数 | 描述
expression | 必需的。需要被四舍五入的表达式。
numdecimalplaces | 可选的。规定对小数点右边的多少位进行四舍五入。默认是 0。

实例

例子 1

dim x
x=24.13278
document.write(Round(x))

输出：

24

例子 2

dim x
x=24.13278
document.write(Round(x,2))

输出：

24.13

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript ScriptEngine, ScriptEngineBuildVersion, ScriptEngineMajorVersion, 以及 ScriptEngineMinorVersion 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript ScriptEngine, ScriptEngineBuildVersion, ScriptEngineMajorVersion, 以及 ScriptEngineMinorVersion 函数

返回 VBScript 函数参考手册

ScriptEngine 函数

ScriptEngine 函数可返回当前使用的脚本语言。

此函数可返回下面的字符串：

  • VBScript - 指示当前使用的脚本引擎是 Microsoft(R) Visual Basic(R) Scripting Edition
  • JScript - 指示当前使用的编写脚本引擎是 Microsoft Visual Basic Scripting Edition(R)。
  • VBA - 指示当前使用的脚本引擎是 Microsoft Visual Basic for Applications。

ScriptEngineBuildVersion 函数

ScriptEngineBuildVersion 函数可返回当前在用的脚本引擎的版本号。

ScriptEngineMajorVersion 函数

ScriptEngineMajorVersion 函数可返回当前在用的脚本引擎的主版本号。

ScriptEngineMinorVersion 函数

ScriptEngineMinorVersion 函数可返回当前在用的脚本引擎的副版本。

语法

ScriptEngine

ScriptEngineBuildVersion

ScriptEngineMajorVersion

ScriptEngineMinorVersion

实例

document.write(ScriptEngine)
document.write(ScriptEngineBuildVersion)
document.write(ScriptEngineMajorVersion)
document.write(ScriptEngineMinorVersion)

输出：

VBScript
8827
5
6

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Second 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Second 函数

返回 VBScript 函数参考手册

定义和用法

Second 函数可返回表示分钟的秒数的数字，介于 0 到59 之间。

语法

Second(time)
参数 | 描述
time | 必需的。任何可表示时间的表达式。

实例

例子 1

D = #1/15/2002 10:55:51 AM#
document.write(Second(D))

输出：

51

例子 2

T = #10:55:51 AM#
document.write(Second(T))

输出：

51

例子 3

下面这个例子是一个可输出中文格式时间的 ASP 函数，其中使用到了 VBScript 的 Hour、Minute 以及 Second 函数。

<%
Sub HHMMSS(T)
H = Hour(T)
If H<12 then
  Response.Write "上午"&H&"时"
Else
  Response.Write "下午"&(H-12)&"时"
End If
Response.Write Minute(T)&"分"
Response.Write Second(T)&"秒"
End Sub
%>

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript SetLocale 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript SetLocale 函数

返回 VBScript 函数参考手册

定义和用法

SetLocale 函数可设置 locale ID，并返回之前的 locale ID。

locale 是用户参考信息集合，比如用户的语言、国家和文化传统。locale 可决定键盘布局、字母排序顺序和日期、时间、数字与货币格式等等。

语法

SetLocale(lcid)
参数 | 描述
lcid | 必需的。任意一个在 Locale ID 表 中的短字符串、十六进制值、十进制值，该值必须唯一标识一个地理区域。如果 lcid 参数被设置为 0 ，则 locale 将由系统设置。

实例

document.write(SetLocale(2057))
document.write(SetLocale(2058))

输出：

1033
2057

Locale ID 表

Locale 描述 | 简写 | 十六进制值 | 十进制值
Afrikaans | af | 0x0436 | 1078
Albanian | sq | 0x041C | 1052
Arabic ?United Arab Emirates | ar-ae | 0x3801 | 14337
Arabic - Bahrain | ar-bh | 0x3C01 | 15361
Arabic - Algeria | ar-dz | 0x1401 | 5121
Arabic - Egypt | ar-eg | 0x0C01 | 3073
Arabic - Iraq | ar-iq | 0x0801 | 2049
Arabic - Jordan | ar-jo | 0x2C01 | 11265
Arabic - Kuwait | ar-kw | 0x3401 | 13313
Arabic - Lebanon | ar-lb | 0x3001 | 12289
Arabic - Libya | ar-ly | 0x1001 | 4097
Arabic - Morocco | ar-ma | 0x1801 | 6145
Arabic - Oman | ar-om | 0x2001 | 8193
Arabic - Qatar | ar-qa | 0x4001 | 16385
Arabic - Saudi Arabia | ar-sa | 0x0401 | 1025
Arabic - Syria | ar-sy | 0x2801 | 10241
Arabic - Tunisia | ar-tn | 0x1C01 | 7169
Arabic - Yemen | ar-ye | 0x2401 | 9217
Armenian | hy | 0x042B | 1067
Azeri ?Latin | az-az | 0x042C | 1068
Azeri ?Cyrillic | az-az | 0x082C | 2092
Basque | eu | 0x042D | 1069
Belarusian | be | 0x0423 | 1059
Bulgarian | bg | 0x0402 | 1026
Catalan | ca | 0x0403 | 1027
Chinese - China | zh-cn | 0x0804 | 2052
Chinese - Hong Kong S.A.R. | zh-hk | 0x0C04 | 3076
Chinese ?Macau S.A.R | zh-mo | 0x1404 | 5124
Chinese - Singapore | zh-sg | 0x1004 | 4100
Chinese - Taiwan | zh-tw | 0x0404 | 1028
Croatian | hr | 0x041A | 1050
Czech | cs | 0x0405 | 1029
Danish | da | 0x0406 | 1030
Dutch ?The Netherlands | nl-nl | 0x0413 | 1043
Dutch - Belgium | nl-be | 0x0813 | 2067
English - Australia | en-au | 0x0C09 | 3081
English - Belize | en-bz | 0x2809 | 10249
English - Canada | en-ca | 0x1009 | 4105
English ?Carribbean | en-cb | 0x2409 | 9225
English - Ireland | en-ie | 0x1809 | 6153
English - Jamaica | en-jm | 0x2009 | 8201
English - New Zealand | en-nz | 0x1409 | 5129
English ?Phillippines | en-ph | 0x3409 | 13321
English - South Africa | en-za | 0x1C09 | 7177
English - Trinidad | en-tt | 0x2C09 | 11273
English - United Kingdom | en-gb | 0x0809 | 2057
English - United States | en-us | 0x0409 | 1033
Estonian | et | 0x0425 | 1061
Farsi | fa | 0x0429 | 1065
Finnish | fi | 0x040B | 1035
Faroese | fo | 0x0438 | 1080
French - France | fr-fr | 0x040C | 1036
French - Belgium | fr-be | 0x080C | 2060
French - Canada | fr-ca | 0x0C0C | 3084
French - Luxembourg | fr-lu | 0x140C | 5132
French - Switzerland | fr-ch | 0x100C | 4108
Gaelic ?Ireland | gd-ie | 0x083C | 2108
Gaelic - Scotland | gd | 0x043C | 1084
German - Germany | de-de | 0x0407 | 1031
German - Austria | de-at | 0x0C07 | 3079
German - Liechtenstein | de-li | 0x1407 | 5127
German - Luxembourg | de-lu | 0x1007 | 4103
German - Switzerland | de-ch | 0x0807 | 2055
Greek | el | 0x0408 | 1032
Hebrew | he | 0x040D | 1037
Hindi | hi | 0x0439 | 1081
Hungarian | hu | 0x040E | 1038
Icelandic | is | 0x040F | 1039
Indonesian | id | 0x0421 | 1057
Italian - Italy | it-it | 0x0410 | 1040
Italian - Switzerland | it-ch | 0x0810 | 2064
Japanese | ja | 0x0411 | 1041
Korean | ko | 0x0412 | 1042
Latvian | lv | 0x0426 | 1062
Lithuanian | lt | 0x0427 | 1063
FYRO Macedonian | mk | 0x042F | 1071
Malay - Malaysia | ms-my | 0x043E | 1086
Malay ?Brunei | ms-bn | 0x083E | 2110
Maltese | mt | 0x043A | 1082
Marathi | mr | 0x044E | 1102
Norwegian - Bokm錶 | no-no | 0x0414 | 1044
Norwegian ?Nynorsk | no-no | 0x0814 | 2068
Polish | pl | 0x0415 | 1045
Portuguese - Portugal | pt-pt | 0x0816 | 2070
Portuguese - Brazil | pt-br | 0x0416 | 1046
Raeto-Romance | rm | 0x0417 | 1047
Romanian - Romania | ro | 0x0418 | 1048
Romanian - Moldova | ro-mo | 0x0818 | 2072
Russian | ru | 0x0419 | 1049
Russian - Moldova | ru-mo | 0x0819 | 2073
Sanskrit | sa | 0x044F | 1103
Serbian - Cyrillic | sr-sp | 0x0C1A | 3098
Serbian ?Latin | sr-sp | 0x081A | 2074
Setsuana | tn | 0x0432 | 1074
Slovenian | sl | 0x0424 | 1060
Slovak | sk | 0x041B | 1051
Sorbian | sb | 0x042E | 1070
Spanish - Spain | es-es | 0x0C0A | 1034
Spanish - Argentina | es-ar | 0x2C0A | 11274
Spanish - Bolivia | es-bo | 0x400A | 16394
Spanish - Chile | es-cl | 0x340A | 13322
Spanish - Colombia | es-co | 0x240A | 9226
Spanish - Costa Rica | es-cr | 0x140A | 5130
Spanish - Dominican Republic | es-do | 0x1C0A | 7178
Spanish - Ecuador | es-ec | 0x300A | 12298
Spanish - Guatemala | es-gt | 0x100A | 4106
Spanish - Honduras | es-hn | 0x480A | 18442
Spanish - Mexico | es-mx | 0x080A | 2058
Spanish - Nicaragua | es-ni | 0x4C0A | 19466
Spanish - Panama | es-pa | 0x180A | 6154
Spanish - Peru | es-pe | 0x280A | 10250
Spanish - Puerto Rico | es-pr | 0x500A | 20490
Spanish - Paraguay | es-py | 0x3C0A | 15370
Spanish - El Salvador | es-sv | 0x440A | 17418
Spanish - Uruguay | es-uy | 0x380A | 14346
Spanish - Venezuela | es-ve | 0x200A | 8202
Sutu | sx | 0x0430 | 1072
Swahili | sw | 0x0441 | 1089
Swedish - Sweden | sv-se | 0x041D | 1053
Swedish - Finland | sv-fi | 0x081D | 2077
Tamil | ta | 0x0449 | 1097
Tatar | tt | 0X0444 | 1092
Thai | th | 0x041E | 1054
Turkish | tr | 0x041F | 1055
Tsonga | ts | 0x0431 | 1073
Ukrainian | uk | 0x0422 | 1058
Urdu | ur | 0x0420 | 1056
Uzbek ?Cyrillic | uz-uz | 0x0843 | 2115
Uzbek ?Latin | uz-uz | 0x0443 | 1091
Vietnamese | vi | 0x042A | 1066
Xhosa | xh | 0x0434 | 1076
Yiddish | yi | 0x043D | 1085
Zulu | zu | 0x0435 | 1077

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Sgn 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Sgn 函数

返回 VBScript 函数参考手册

定义和用法

Sgn 函数可返回指示指定数字的符号的整数。

语法

Sgn(number)
参数 描述
number

必需的。合法的数值表达式。

如果数字是：

  • >0 - Sgn 会返回 1。
  • <0 - Sgn 会返回 -1。
  • =0 - Sgn 会返回 0。

实例

例子 1

document.write(Sgn(15))

输出：

1

例子 2

document.write(Sgn(-5.67))

输出：

-1

例子 3

document.write(Sgn(0))

输出：

0

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Sin 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Sin 函数

返回 VBScript 函数参考手册

定义和用法

Sin 函数可返回指定数字（角度）的正弦。

Sin 函数取某个角并返回直角三角形两边的比值。此比值是直角三角形中该角的对边长度与斜边长度之比。结果的范围在 -1 到 1 之间。

注释：将角度乘以 pi/180 即可转换为弧度，将弧度乘以 180/pi 即可转换为角度。

语法

Sgn(number)
参数 | 描述
number | 必需的。将某个角表示为弧度的有效表达式。

实例

例子 1

document.write(Sin(47))

输出：

0.123573122745224

例子 2

document.write(Sin(-47))

输出：

-0.123573122745224

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Space 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Space 函数

返回 VBScript 函数参考手册

定义和用法

Space 函数可返回一个由指定数目的空格组成的字符串。

语法

Space(number)
参数 | 描述
number | 必需的。字符串中的空格数目。

实例

例子 1

dim txt
txt=Space(10)
document.write(txt)

输出：

"          "

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Split 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Split 函数

返回 VBScript 函数参考手册

定义和用法

Split 函数可返回基于 0 的一维数组，此数组包含指定数目的子字符串。

语法

Split(expression[,delimiter[,count[,compare]]])
参数 | 描述
expression | 必需的。包含子字符串和分隔符的字符串表达式。
delimiter | 可选的。用于识别子字符串界限的字符。默认是空格字符。
count | 可选的。需被返回的子字符串的数目。-1 指示返回所有的子字符串。
compare

可选的。规定要使用的字符串比较类型。

可采用下列的值：

  • 0 = vbBinaryCompare - 执行二进制比较。
  • 1 = vbTextCompare - 执行文本比较。

实例

例子 1

dim txt,a
txt="Hello World!"
a=Split(txt)
document.write(a(0) & "<br />")
document.write(a(1))

输出：

Hello
World!

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Sqr 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Sqr 函数

返回 VBScript 函数参考手册

定义和用法

Sqr 函数可返回一个数的平方根。

注释：number 参数不能是负值。

语法

Sqr(number)
参数 | 描述
number | 必需的。大于等于 0 的有效数值表达式。

实例

例子 1

document.write(Sqr(9))

输出：

3

例子 2

document.write(Sqr(0))

输出：

0

例子 3

document.write(Sqr(47))

输出：

6.85565460040104

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript StrComp 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript StrComp 函数

返回 VBScript 函数参考手册

定义和用法

StrComp 函数可比较两个字符串，并返回表示比较结果的一个值。

StrComp 函数可返回下面的值：

  • -1 (如果 string1 < string2)
  • 0 (如果 string1 = string2)
  • 1 (如果 string1 > string2)
  • Null (如果 string1 或 string2 为 Null)

语法

StrComp(string1,string2[,compare])
参数 | 描述
string1 | 必需的。字符串表达式。
string2 | 必需的。字符串表达式。
compare

可选的。规定要使用的字符串比较类型。默认是 0。Optional. Specifies the string comparison to use. Default is 0

可采用的值：

  • 0 = vbBinaryCompare - 执行二进制比较
  • 1 = vbTextCompare - 执行文本比较

实例

例子 1

document.write(StrComp("VBScript","VBScript"))

输出：

0

例子 2

document.write(StrComp("VBScript","vbscript"))

输出：

-1

例子 3

document.write(StrComp("VBScript","vbscript",1))

输出：

0

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript String 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript String 函数

返回 VBScript 函数参考手册

定义和用法

String 函数可返回包含指定长度的重复字符的一个字符串。

语法

String(number,character)
参数 | 描述
number | 必需的。被返回字符串的长度。
character | 必需的。被重复的字符。

实例

例子 1

document.write(String(10,"#"))

输出：

##########

例子 2

document.write(String(4,"*"))

输出：

****

例子 3

document.write(String(4,42))

输出：

****

例子 4

document.write(String(4,"XYZ"))

输出：

XXXX

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript StrReverse 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript StrReverse 函数

返回 VBScript 函数参考手册

定义和用法

StrReverse 函数可反转一个字符串。

语法

StrReverse(string)
参数 | 描述
string | 必需的。需被反转的字符串。

实例

例子 1

dim txt
txt="This is a beautiful day!"
document.write(StrReverse(txt))

输出：

!yad lufituaeb a si sihT

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Tan 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Tan 函数

返回 VBScript 函数参考手册

定义和用法

Tan 函数可返回指定数字（角度）的正切。

Tan 取某个角并返回直角三角形两个直角边的比值。此比值是直角三角形中该角的对边长度与邻边长度之比。

注释：将角度乘以 pi /180 即可转换为弧度，将弧度乘以 180/pi 即可转换为角度。

语法

Sqr(number)
参数 | 描述
number | 必需的。将某个角表示为弧度的有效表达式。

实例

例子 1

document.write(Tan(40))

输出：

-1.1172149309239

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Time 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Time 函数

返回 VBScript 函数参考手册

定义和用法

Time 函数可返回当前的系统时间。

语法

Time

提示和注释

重要事项：

如果同时读取 Date、Time 以及 Now，那么 Now = Date + Time，但是实际上，我们不可能同时调用这三个函数，因为执行完一个函数之后，才能执行另一个函数，所以如果您在程序中必需同时取得当时的日期和时间，必需调用 Now，再利用 DateVale 及 TimeValue 分别取出日期和时间。

实例：取得某一时间点的日期和时间：

N = Now '这个时间点的日期和时间
D = Datevalue(N) '同一时间点的日期部分
T = TimeValue(N) '同一时间点的时间部分
D2 = Date '时间点1的日期
T2 = Time '时间点2的时间

问题思考

连续执行 Response.write Now 及 Response.Write Date + Time，则可能出现的最大误差值有多大？假设：

时间点1取得的	Now = #7/1/95 23:59:59#
时间点2取得的	Date = #7/1/95#

而如果“时间点3”刚好跨过一日，所以 Time = #0:00:00，于是 Now 与 Date+Time 的差距便成了23:59:59。

实例

例子 1

document.write(Time)

输出：

14:34:38

注释：输出的结果可能由于不同的计算机设置而略有差异。

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Timer 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Timer 函数

返回 VBScript 函数参考手册

定义和用法

Timer 函数可返回午夜 12 时（12:00 AM）以后已经过去的秒数。

语法

Timer

实例

例子 1

document.write(Timer)

输出：

52744.64

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript TimeSerial 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript TimeSerial 函数

返回 VBScript 函数参考手册

定义和用法

TimeSerial 函数可把时、分、秒合并成为时间。

注释：时分秒若超过应有的范围，其推算的原理与 DateSerial 相同。若经推算后得到的时间小于 #00:00:00#，则自动将负时间变为正时间；若经推算后得到的时间大于等于 #24:00:00#，则时间向前增加，使数据变成一个含有日期时间的数据，其中日期的起算日是 #12/30/1899#。

语法

TimeSerial(hour,minute,second)
参数 | 描述
hour | 必需的。介于 0-23 的数字，或数值表达式。
minute | 必需的。介于 0-59 的数字，或数值表达式。
second | 必需的。介于 0-59 的数字，或数值表达式。

要指定一时刻，如 11:59:59，TimeSerial 的参数取值应在可接受的范围内；也就是说，小时应介于 0-23 之间，分和秒应介于 0-59 之间。但是，可以使用数值表达式为每个参数指定相对时间，这一表达式代表某时刻之前或之后的时、分或秒数。

当任何一个参数的取值超出可接受的范围时，它会正确地进位到下一个较大的时间单位中。例如，如果指定了 75 分钟，则这个时间被解释成一小时十五分钟。但是，如果任何一个参数值超出 -32768 到 32767 的范围，就会导致错误。如果使用三个参数直接指定的时间或通过表达式计算出的时间超出可接受的日期范围，也会导致错误。

实例

例子 1

document.write(TimeSerial(9,30,50)) '正常的调用方法

输出：

9:30:50 或 9:30:50 AM

例子 2

document.write(TimeSerial(0,9,11)) '正常的调用方法

输出：

0:09:11 或 12:09:11 AM

例子 3

document.write(TimeSerial(14+2,9-2,1-1)) '根据数值表达式的结果来输出时间

输出：

16:07:00 或 4:07:00 PM

例子 4

document.write(TimeSerial(26,30,0)) '日期从#12/30/1899#起向后增加1日

输出：

1899-12-31 2:30:00 AM

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript TimeValue 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript TimeValue 函数

返回 VBScript 函数参考手册

定义和用法

TimeValue 函数可返回包含时间的日期子类型的变量。

TimeValue 函数可用来取出参数的时间部分。

注释：若参数不含时间，则 TimeValue 将返回0，若输出结果则是 12:00:00 AM。

语法

TimeValue(time)
参数 | 描述
time | 必需的。介于 0:00:00 (12:00:00 A.M.) - 23:59:59 (11:59:59 P.M.) 的时间，或任何可表示此范围内时间的表达式。

实例

例子 1

D = #7/1/96 13:30:00#
document.write(TimeValue(D))

输出：

13:30:00 或 1:30:00 PM

例子 2

D = "7/1/96 13:30:00"
document.write(TimeValue(D)) '只要能够判断，字符串也能接受。

输出：

13:30:00 或 1:30:00 PM

例子 3

D = "7/1/96"
document.write(TimeValue(D)) '只有日期

输出：

12:00:00 AM '相当于0

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Trim 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Trim 函数

返回 VBScript 函数参考手册

定义和用法

Trim 函数可删除字符串两侧的空格。

语法

Trim(string)
参数 | 描述
string | 字符串表达式。

实例

例子 1

dim txt
txt="  This is a beautiful day!  "
document.write(Trim(txt))

输出：

"This is a beautiful day!"

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript TypeName 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript TypeName 函数

返回 VBScript 函数参考手册

定义和用法

TypeName 函数可指定变量的子类型。

TypeName 函数可返回的值：

值 | 描述
Byte | 字节值
Integer | 整型值
Long | 长整型值
Single | 单精度浮点值
Double | 双精度浮点值
Currency | 货币值
Decimal | 十进制值
Date | 日期或时间值
String | 字符串值
Boolean | Boolean 值；True 或 False
Empty | 未初始化
Null | 无有效数据
<object type> | 实际对象类型名
Object | 一般对象
Unknown | 未知对象类型
Nothing | 还未引用对象实例的对象变量
Error | 错误

语法

TypeName(varname)
参数 | 描述
varname | 必需的。变量的名称。

实例

dim x
x="Hello World!"
document.write(TypeName(x))
x=4
document.write(TypeName(x))
x=4.675
document.write(TypeName(x))
x=Null
document.write(TypeName(x))
x=Empty
document.write(TypeName(x))
x=True
document.write(TypeName(x))

输出：

String
Integer
Double
Null
Empty
Boolean

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript UBound 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript UBound 函数

返回 VBScript 函数参考手册

定义和用法

UBound 函数可返回指示数组维数的最大下标。

提示：LBound 函数与 UBound 函数共同使用，可以确定数组的大小。使用 UBound 函数可以找到数组某一维的上界。

语法

UBound(arrayname[,dimension])
参数 | 描述
arrayname | 必需的。数组变量的名称。
dimension | 可选的。要返回哪一维的上界。 1 = 第一维， 2 = 第二维，以此类推。默认是 1 。

实例

例子 1

dim a(10)
a(0)="Saturday"
a(1)="Sunday"
a(2)="Monday"
a(3)="Tuesday"
a(4)="Wednesday"
a(5)="Thursday"
document.write(UBound(a))
document.write("<br />")
document.write(LBound(a))

输出：

10
0

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript UCase 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript UCase 函数

返回 VBScript 函数参考手册

定义和用法

UCase 函数可把指定的字符串转换为大写。

提示：请参阅 LCase 函数。

语法

UCase(string)
参数 | 描述
string | 必需的。需被转换为大写的字符串。

实例

例子 1

dim txt
txt="This is a beautiful day!"
document.write(UCase(txt))

输出：

THIS IS A BEAUTIFUL DAY!

例子 2

dim txt
txt="This Is a Beautiful Day!"
document.write(UCase(txt))

输出：

THIS IS A BEAUTIFUL DAY!

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript VarType 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript VarType 函数

返回 VBScript 函数参考手册

定义和用法

VarType 函数可返回指示指定变量的子类型的值。

VarType 函数可返回的值：

常数 | 值 | 描述
vbEmpty | 0 | 未初始化（默认）
vbNull | 1 | 不包含任何有效数据
vbInteger | 2 | 整型子类型
vbLong | 3 | 长整型子类型
vbSingle | 4 | 单精度子类型
vbDouble | 5 | 双精度子类型
vbCurrency | 6 | 货币子类型
vbDate | 7 | 日期或时间值
vbString | 8 | 字符串值
vbObject | 9 | 字符串子类型
vbError | 10 | 错误子类型
vbBoolean | 11 | Boolean 子类型
vbVariant | 12 | Variant （仅用于变量数组）
vbDataObject | 13 | 数据访问对象
vbDecimal | 14 | 十进制子类型
vbByte | 17 | 字节子类型
vbArray | 8192 | 数组

注释：这些常数是由 VBScript 指定的。所以，这些名称可在代码中随处使用，以代替实际值。

注释：假如变量是数组，则 VarType() 会返回 8192 + VarType(数组元素)。举例：整数数组的 VarType() 会返回 8192 + 2 = 8194 。

语法

VarType(varname)
参数 | 描述
varname | 必需的。变量的名称。

实例

dim x
x="Hello World!"
document.write(VarType(x))
x=4
document.write(VarType(x))
x=4.675
document.write(VarType(x))
x=Null
document.write(VarType(x))
x=Empty
document.write(VarType(x))
x=True
document.write(VarType(x))

分别输出：

String
Integer
Double
Null
Empty
Boolean

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Weekday 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Weekday 函数

返回 VBScript 函数参考手册

定义和用法

Weekday 函数可返回表示一周的天数的数字，介于 1 和 7 之间。

注释：

语法

Weekday(date[,firstdayofweek])
参数 | 描述
date | 必需的。需计算的日期表达式。
firstdayofweek

可选的。规定周的第一天。

可采用下面的值：

  • 0 = vbUseSystemDayOfWeek - 使用区域语言支持 (NLS) API 设置。
  • 1 = vbSunday - 星期日（默认）
  • 2 = vbMonday - 星期一
  • 3 = vbTuesday - 星期二
  • 4 = vbWednesday - 星期三
  • 5 = vbThursday - 星期四
  • 6 = vbFriday - 星期五
  • 7 = vbSaturday - 星期六

实例

例子 1

D = #10/1/2007#
document.write(Weekday(D)) '2007年10月1日是星期一，即一周的第二天。

输出：

2

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript WeekdayName 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript WeekdayName 函数

返回 VBScript 函数参考手册

定义和用法

WeekdayName 函数可返回一周中指定一天的星期名。

注释：在英文 Windows 环境下，返回值是 "Sunday"、"Monday" 、... ...

语法

WeekdayName(weekday[,abbreviate[,firstdayofweek]])
参数 | 描述
weekday | 必需的。一周的第几天的数字。
abbreviate | 可选的。布尔值，指示是否缩写星期名。
firstdayofweek

可选的。规定周的第一天。

可采用下面的值：

  • 0 = vbUseSystemDayOfWeek - 使用区域语言支持 (NLS) API 设置。
  • 1 = vbSunday - 星期日（默认）
  • 2 = vbMonday - 星期一
  • 3 = vbTuesday - 星期二
  • 4 = vbWednesday - 星期三
  • 5 = vbThursday - 星期四
  • 6 = vbFriday - 星期五
  • 7 = vbSaturday - 星期六

实例

例子 1

document.write(WeekdayName(3))

输出：

星期二

例子 2

D = #2007/10/1#
document.write(WeekdayName(Weekday(D)))

输出：

星期一

例子 3

D = #2007/10/1#
document.write(WeekdayName(Weekday(Date),true))

输出：

星期一 或 Mon

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript Where To ...

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Where To ...

  • Previous Page
  • Next Page

实例

head 部分中的函数
可以把脚本放置在 head 部分。经常，我们会把所有的函数放置于 head 部分。这么做的目的是为了确保函数在调用前已经被载入。
body 部分中的脚本
本例会执行被放置于 body 部分的一段脚本。在 body 中的脚本会在页面载入时执行。

在何处放置 VBScript

当页面载入浏览器时，页面中的脚本会立即被执行。我们并不希望这种情况发生。有时我们希望当页面载入时执行脚本，而有时我们则希望当用户触发某个事件时执行这些脚本。

在 head 部分的脚本：当脚本被调用时，它们会被执行，或者某个事件被触发时，脚本也有可能会执行。当我们把脚本放置于 head 部分时，就可以确保在用户使用之前它们已经被载入了：

<html>
<head>
<script type="text/vbscript">
  some statements
</script>
</head>

在 body 部分的脚本：当页面的 body 部分被载入时，脚本就会被执行。当我们把脚本放置于 body 部分，它会生成页面的内容：

<html>
<head>
</head>
<body>
<script type="text/vbscript">
  some statements
</script>
</body>

位于 body 和 head 部分的脚本：您可以在文档中放置如何数量的脚本，因此您可以同时在 body 和 head 部分放置脚本：

<html>
<head>
<script type="text/vbscript">
  some statements
</script>
</head>
<body>
<script type="text/vbscript">
  some statements
</script>
</body>
  • Previous Page
  • Next Page

VBScript 参考手册
VBScript 实例


VBScript Year 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript Year 函数

返回 VBScript 函数参考手册

定义和用法

Year 函数可返回表示年份的一个数字。

语法

Year(date)
参数 | 描述
date | 必需的。能表示日期的任何表达式。

实例

例子 1

D = #2007/10/1#
document.write(Year(D))

输出：

2007

返回 VBScript 函数参考手册

VBScript 参考手册
VBScript 实例


VBScript 变量

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript 变量

  • Previous Page
  • Next Page

实例

创建变量
变量用于存储信息。本例演示如何创建一个变量，并为它赋值。
在一段文本中插入变量值
本例为您演示如何在一段文本中插入变量值。
创建数组
数组用来存储一系列相关的数据项。本例演示如何创建一个存储名字的数组。（我们使用 "for loop" 来演示如何输出名字。）
什么是变量？ 变量是可存储信息的“容器”。在脚本中，变量的值是可以改变的。您可以通过引用某个变量的名称，来查看或修改它的值。在 VBScript 中，所有的变量都与类型相关，可存储不同类型的数据。

变量名称的规则：

  • 必须以字母开头
  • 不能包含点号 (.)
  • 不能超过 255 个字符

变量声明

您可以使用 Dim、Public 或 Private 语句来声明变量，比如这样：

dim name
name=some value

现在，你创建了一个变量。变量名是 "name"。

您也可以通过使用其名称来创建变量。比如这样：

name=some value

这样，您同样创建了一个名为 "name" 的变量。

不过，后面这样的做法不是一种好习惯，这是因为您可能会在脚本中拼错变量名，那样可能会在脚本运行时引起奇怪的结果。比如，当您把 "name" 变量错拼为 "nime" 时，脚本会自动创建一个名为 "nime" 的变量。为了防止脚本这样做，您可以使用 Option Explicit 语句。如果您使用这个语句，就必须使用 dim、public 或 private 语句来声明所有的变量。把 Option Explicit 语句放置于脚本的顶端，这像这样：

option explicit
dim name
name=some value

为变量赋值

您可以像这样为某个变量赋值：

name="George"
i=300

变量名在表达式的左侧，需要赋的值在表达式的右侧。现在，变量 "name" 的值是 "George"。

变量的生存期

变量的生存期指的是它可以存在的时长。

当您在一个子程序中声明变量后，变量只能在此程序内进行访问。当退出此程序时，变量也会实效。这样的变量称为本地变量。您可以在不同的子程序中使用名称相同的本地变量，因为每个变量只能在声明它的程序内得到识别。

如果您在子程序以外声明了一个变量，在您的页面上的所有子程序都可以访问访问它。这类变量的生存期始于它们被声明，止于页面被关闭。

数组变量

有时，您需要向一个单一的变量赋于多个值。那么您可以创建一个可包含一系列值的变量。这种变量被称为数组。数组变量的声明使用变量名后跟一个括号()。在下面的例子中，创建了一个包含三个元素的数组：

dim names(2)

括号中的数字是 2。数组的下标以 0 开始，因为此数组包含三个元素。这是容量固定的数组。您可以为数组的每个元素分配数据：

names(0)="George"
names(1)="John"
names(2)="Thomas"

同样地，通过使用特定数组元素的下标号，我们也可以取回任何元素的值。比如：

father=names(0)

您可以在一个数组中使用多达 60 个维数。声明多维数组的方法是在括号中用逗号来分隔数字。比如，我们声明了一个包含 5 行 7 列的 2 维数组：

dim table(4, 6)
  • Previous Page
  • Next Page

VBScript 参考手册
VBScript 实例


VBScript 程序

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript 程序

  • Previous Page
  • Next Page

实例

子程序
这个子程序不会返回值。
函数程序
假如你希望返回某个值时，可以使用函数程序。

VBScript 程序

我们可使用两种程序：子程序和函数程序。

子程序：

  • 是一系列的语句，被封装在 Sub 和 End Sub 语句内。
  • 可执行某些操作，但不会返回值。
  • 可带有通过程序调用来向子程序传递参数。
  • 如果没有，必须带有空的圆括号
Sub mysub()
 some statements
End Sub
Sub mysub(argument1,argument2)
 some statements
End Sub

函数程序：

  • 是一系列的语句，被封装在 Function 和 End Function 语句内。
  • 可执行某些操作并返回值。
  • 可带有通过程序调用来向其传递参数。
  • 如果没有，必须带有空的圆括号
  • 通过向函数程序名赋值的方式，可使其返回值。
Function myfunction()
 some statements
 myfunction=some value
End Function
Function myfunction(argument1,argument2)
 some statements
 myfunction=some value
End Function

调用子程序或函数程序

可以这样调用某个函数：

name = findname()

此函数名为 "findname"，函数会返回一个值，这个值会存储于变量 "name" 中。

或者可以这样做：

msgbox "Your name is " & findname()

我们通过调用了名为 "findname" 的函数，这个函数返回的值会显示在消息框中。

可以这样调用子程序：

Call MyProc(argument)

或者，也可以省略 Call 语句：

MyProc argument
  • Previous Page
  • Next Page

VBScript 参考手册
VBScript 实例


VBScript 关键字

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript 关键字

  • Previous Page
  • Next Page

暂无内容，请访问下一节。

  • Previous Page
  • Next Page

VBScript 参考手册
VBScript 实例

/html>


VBScript 函数

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript 函数

  • Previous Page
  • Next Page

本页列出了所有内建的 VBScript 函数：

  • Date/Time 函数
  • Conversion 函数
  • Format 函数
  • Math 函数
  • Array 函数
  • String 函数
  • 其他函数

Date/Time 函数

函数 | 描述
CDate | 把一个有效的日期或时间表达式转换为日期类型。
Date | 返回当前的系统日期。
DateAdd | 返回已添加指定时间间隔的日期。
DateDiff | 返回两个日期之间的时间间隔数。
DatePart | 返回给定日期的指定部分。
DateSerial | 返回日期的指定年、月、日
DateValue | 返回日期
Day | 返回代表一月中一天的数字 （介于并包括1至31之间）
FormatDateTime | 返回以日期或时间格式化的表达式。
Hour | 返回可代表一天中的小时的数字 （介于并包括0至23之间）
IsDate | 返回可指示计算表达式能否转换为日期的布尔值。
Minute | 返回一个数字，代表小时的分钟 （介于并包括0至59）
Month | 返回一个数字，代表年的月份 （介于并包括1至12之间）。
MonthName | 返回指定月份的名称。
Now | 返回当前的系统日期和时间。
Second | 返回一个数字，代表分钟的秒 （介于并包括0至59之间）
Time | 返回当前的系统时间。
Timer | 返回自 12:00 AM 以来的秒数。
TimeSerial | 返回特定小时、分钟和秒的时间。
TimeValue | 返回时间。
Weekday | 返回一个数字，代表星期的一天（介于并包括1至7）
WeekdayName | 返回星期中指定的一天的星期名。
Year | 返回一个代表年份的数字。

Conversion 函数

Top
函数 | 描述
Asc | 把字符串中的首字母转换为 ANSI 字符代码。
CBool | 把表达式转换为布尔类型。
CByte | 把表达式转换为字节（Byte）类型。
CCur | 把表达式转换为货币（Currency）类型。
CDate | 把有效的日期和时间表达式转换为日期（Date）类型。
CDbl | 把表达式转换为双精度（Double）类型。
Chr | 把指定的 ANSI 字符代码转换为字符。
CInt | 把表达式转换为整数（Integer）类型。
CLng | 把表达式转换为长整形（Long）类型。
CSng | 把表达式转换为单精度（Single）类型。
CStr | 把表达式转换为子类型 String 的 variant 。
Hex | 返回指定数字的十六进制值。
Oct | 返回指定树木的八进制值。

Format 函数

Top
函数 | 描述
FormatCurrency | 返回作为货币值进行格式化的表达式。
FormatDateTime | 返回作为日期或时间进行格式化的表达式。
FormatNumber | 返回作为数字进行格式化的表达式。
FormatPercent | 返回作为百分数进行格式化的表达式。

Math 函数

Top
函数 | 描述
Abs | 返回指定数字的绝对值。
Atn | 返回指定数字的反正切。
Cos | 返回指定数字（角度）的余弦。
Exp | 返回 e（自然对数的底）的幂次方。
Hex | 返回指定数字的十六进制值。
Int | 返回指定数字的整数部分。
Fix | 返回指定数字的整数部分。
Log | 返回指定数字的自然对数。
Oct | 返回指定数字的余弦值。
Rnd | 返回小于1但大于或等于0的一个随机数。
Sgn | 返回可指示指定的数字的符号的一个整数。
Sin | 返回指定数字（角度）的正弦。
Sqr | 返回指定数字的平方根。
Tan | 返回指定数字（角度）的正切。

Array 函数

Top
函数 | 描述
Array | 返回一个包含数组的变量
Filter | 返回一个下标从零开始的数组，其中包含基于特定过滤条件的字符串数组的子集。
IsArray | 返回一个布尔值，可指示指定的变量是否是数组。
Join | 返回一个由数组中若干子字符串组成的字符串。
LBound | 返回指定数组维数的最小下标。
Split | 返回下标从0开始的一维数组，包含指定数目的子字符串。
UBound | 返回指定数组维数的最大下标。

String 函数

Top
函数 | 描述
InStr | 返回一个字符串在另一个字符串中首次出现的位置。检索从字符串的第一个字符开始。
InStrRev | 返回一个字符串在另一个字符串中首次出现的位置。检索从字符串的最后一个字符开始。
LCase | 把指定字符串转换为小写。
Left | 从字符串的左侧返回指定数目的字符。
Len | 返回字符串中的字符数目。
LTrim | 删除字符串左侧的空格。
RTrim | 删除字符串右侧的空格。
Trim | 删除字符串左侧和右侧的空格。
Mid | 从字符串返回指定数目的字符。
Replace | 使用另外一个字符串替换字符串的指定部分指定的次数。
Right | 返回从字符串右侧开始指定数目的字符。
Space | 返回由指定数目的空格组成的字符串。
StrComp | 比较两个字符串，返回代表比较结果的一个值。
String | 返回包含指定长度的重复字符的字符串。
StrReverse | 反转字符串。
UCase | 把指定的字符串转换为大写。

其他函数

Top
函数 | 描述
CreateObject | 创建指定类型对象。
Eval | 计算表达式，并返回结果。
GetLocale | 返回当前区域设置 ID 值。
GetObject | 返回对文件中 automation 对象的引用。
GetRef | 允许您把 VBScript 子程序连接到页面上的一个 DHTML 事件。
InputBox | 可显示对话框，用户可在其中输入文本，并/或点击按钮，然后返回结果。
IsEmpty | 返回一个布尔值，指示指定的变量是否已被初始化。
IsNull | 返回一个布尔值，指示指定的变量是否包含无效数据 (Null)。
IsNumeric | 返回一个布尔值，指示指定的表达式是否可作为数字来计算。
IsObject | 返回一个布尔值，指示指定的表达式是否是一个 automation 对象。
LoadPicture | 返回一个图片对象。仅用于32位平台。
MsgBox | 显示一个消息框，等待用户点击某个按钮，并返回一个指示用户点击了哪个按钮的值。
RGB | 返回一个表示 RGB 颜色值的数字。
Round | 对数进行四舍五入。
ScriptEngine | 返回使用中的脚本语言。
ScriptEngineBuildVersion | 返回使用中的脚本引擎版本号。
ScriptEngineMajorVersion | 返回使用中的脚本引擎的主版本号。
ScriptEngineMinorVersion | 返回使用中的脚本引擎的次版本号。
SetLocale | 设置地区 ID ，并返回之前的地区 ID。
TypeName | 返回指定变量的子类型。
VarType | 返回指示变量子类型的值。
  • Previous Page
  • Next Page

VBScript 参考手册
VBScript 实例


VBScript 简介

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript 简介

  • Previous Page
  • Next Page

学习之前，您需要具备的基础知识：

在继续学习之前，您应该对下面的知识有基本的了解：

  • WWW, HTML 以及网站建设的基础知识

如果您希望首先学习以上的项目，请访问我们的首页。

什么是VBScript?

  • VBScript 是一种脚本语言
  • 脚本语言是一种轻量级的编程语言
  • VBScript 是微软的编程语言 Visual Basic 的轻量级的版本

它如何工作？

当VBScript 被插入一个 HTML 文档后，因特网浏览器会读取这个文档，并对 VBScript 进行解释。VBScript 可能会立即执行，也可能在之后的事件发生时执行。

  • Previous Page
  • Next Page

VBScript 参考手册
VBScript 实例


VBScript 教程

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript 教程

  • Next Page

VBScript 是微软公司出品的脚本语言。

在我们的 VBScript 教程中，你可以学习如何写 VBScript，以及如何在你的HTML文件中插入这些代码，以使得这些 WEB 页面动态性和交互性更强。

开始学习 VBScript！

VBScript 实例

通过实例进行学习。使用我们的编辑器，你可以编辑源代码，然后单击 test 按钮来查看结果。

VBScript 实例

VBScript 参考手册

在 W3School，我们提供完整的 VBScript 参考手册。

VBScript 参考手册

  • Next Page

VBScript 参考手册
VBScript 实例


VBScript 条件语句

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript 条件语句

  • Previous Page
  • Next Page

实例

If...then..else 语句
本例演示如何编写 if...then..else 语句。
If...then..elseif 语句
本例演示如何编写 if...then...elseif... 语句。
Select case 语句
本例演示如何编写 select case 语句。

条件语句

经常地，当我们编写代码时，我们需要根据不同的判断执行不同操作。我们可以使用条件语句完成这个工作。

在 VBScript 我们可以使用三种条件语句：

if 语句
假如你希望在条件为 true 时执行一系列的代码，可以使用这个语句。
if...then...else 语句
假如你希望执行两套代码其中之一，可以使用这个语句。
if...then...elseif 语句
假如你希望选择多套代码之一来执行，可以使用这个语句。
select case 语句
假如你希望选择多套代码之一来执行，可以使用这个语句。

If....Then.....Else

在下面的情况中，您可以使用 If...Then...Else 语句：

  • 在条件为 true 时，执行某段代码
  • 选择两段代码之一来执行时

如果需要在条件为 true 时只执行一行语句，可以把代码写为一行：

if i=10 Then msgbox "Hello"

在上面的代码中，没有 .else.. 语句。我们仅仅让代码在条件为 true 时执行一项操作（当 i 为 10 时）。

假如我们需要在条件为 true 时执行不止一条语句，那么就必须在一行写一条语句，然后使用关键词 "End If" 来结束这个语句：

if i=10 Then
   msgbox "Hello"
   i = i+1
end If

在上面的代码中，同样没有 .else.. 语句。我们仅仅让代码在条件为 true 时执行了多项操作。

假如我们希望在条件为 true 时执行某条语句，并当条件为 true 时执行另一条语句，就必须添加关键词 "Else"：

if i=10 then
   msgbox "Hello"
else
   msgbox "Goodbye"
end If

当条件为 true 时会执行第一段代码，当条件不成立时执行第二段代码（当 i 不等于 10 时）。

If....Then.....Elseif

假如你希望选择多套代码之一来执行，可以使用if...then...elseif语句：

if payment="Cash" then
   msgbox "You are going to pay cash!"
 elseif payment="Visa" then
   msgbox "You are going to pay with visa."
 elseif payment="AmEx" then
   msgbox "You are going to pay with American Express."
 else
   msgbox "Unknown method of payment."
end If

Select Case

假如你希望选择多套代码之一来执行，可以使用 SELECT 语句：

select case payment
 case "Cash"
   msgbox "You are going to pay cash"
 case "Visa"
   msgbox "You are going to pay with visa"
 case "AmEx"
   msgbox "You are going to pay with American Express"
 case Else
   msgbox "Unknown method of payment"
end select

以上代码的工作原理：首先，我们需要一个简单的表达式（常常是一个变量），并且这个表达式会被做一次求值运算。然后，表达式的值会与每个 case 中的值作比较，如果匹配，被匹配的 case 所对应的代码会被执行。

  • Previous Page
  • Next Page

VBScript 参考手册
VBScript 实例


VBScript 循环语句

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

VBScript 循环语句

  • Previous Page
  • Next Page

实例

For..next 循环
本例演示如何编写一个简单的 For....Next 循环。
循环输出HTML标题
本例演示如何循环生成 6 个 HTML 标题。
For..each 循环
本例演示如何编写一个简单的 For.....Each 循环。
Do...While 循环
本例演示如何编写简单的 Do...While 循环。

Looping 语句

经常地，当编写代码时，我们希望将一段代码执行若干次。我们可以在代码中使用循环语句来完成这项工作。

在 VBScript 中，我们可以使用四种循环语句：

For...Next 语句
运行一段语句指定的次数
For Each...Next 语句
针对集合中的每个项目或者数组中的每个元素来运行某段语句。
Do...Loop 语句
运行循环，当条件为 true 或者直到条件为 true 时。
While...Wend 语句
不要使用这个语句 - 请使用 Do...Loop 语句代替它。

For...Next 循环

如果您已经确定需要重复执行代码的次数，那么您可以使用 For...Next 语句来运行这段代码。

我们可以使用一个计数器变量，这个变量会随着每次循环递增或递减，例如这样：

For i=1 to 10
  some code
Next

For 语句规定计数变量以及它的开始值和结束值。

Next 语句会以 1 作为步进值来递增变量i。

Step 关键词

通过使用 Step 关键词，我们可以规定计数变量递增或递减的步进值。

在下面的例子中，计数变量i每次循环的递增步进值为 2。

For i=2 To 10 Step 2
  some code
Next

如果要递减计数变量，就必须负的步进值。并且需要规定小于开始值的结束值。

在下面的例子中，计数变量i每次循环的递减步进值为 2。

For i=10 To 2 Step -2
  some code
Next

退出 For...Next

如需退出 For...Next 语句，可以使用 Exit 关键词。

  • Previous Page
  • Next Page

VBScript 参考手册
VBScript 实例


您已经学习了VBScript，下一步呢？

VBScript 教程

  • VB 首页
  • VB 简介
  • VB How to
  • VB Where to
  • VB 变量
  • VB 程序
  • VB 条件语句
  • VB 循环语句
  • VB 总结

实例

  • VB 实例

参考手册

  • VB 函数
  • VB 关键字

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

您已经学习了VBScript，下一步呢？

  • Previous Page
  • Next Page

VBScript 概要

本教程已经向您讲解如何向 HTML 页面添加 VBScript，以使您的网站具有更强的动态性和交互性。

您已经学习了如何创建变量、函数，以及如何根据不同的情况运行不同的脚步。

如需更多的信息，请阅读我们的 VBScript 实例 以及我们的 VBScript 参考手册 。

您已经学习了 VBScript，下一步的内容是？

下一步，您应该继续学习 ASP。

与 HTML 文件中运行于客户端的脚本不同，ASP文件中的脚本运行于服务器之上。

通过使用 ASP，你可以动态地编辑、改变或者添加网页的任何内容，对由 HTML 表单提交的数据作出响应，访问任何数据或数据库并向浏览器返回结果，为不同的用户定制更有用的页面等等。

由于 ASP 文件被作为纯粹的 HTML 返回浏览器，因此我们可以在任何浏览器中查看 ASP。

如果您需要学习更多关于 ASP 的知识，请访问我们的《ASP 教程》。

  • Previous Page
  • Next Page

VBScript 参考手册
VBScript 实例


W3C CSS 活动

万维网联盟

  • W3C 首页
  • W3C 简介
  • W3C 程序
  • W3C HTML
  • W3C XHTML
  • W3C XML
  • W3C CSS
  • W3C XSL
  • W3C XML Schema
  • W3C XPath
  • W3C XQuery
  • W3C DOM
  • W3C SOAP
  • W3C WSDL
  • W3C RDF
  • W3C SMIL
  • W3C 其他

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

W3C CSS 活动

  • Previous Page
  • Next Page

样式表可描述文档如何被显示、发音或打印。CSS 是一种向网页添加样式的机制。

XML 教程

如需学习更多有关 CSS 的知识，请阅读我们的 CSS 教程。

CSS 版本

CSS1

作为一项 W3C 推荐，CSS1 发布于 1996 年 12 月 17 日。1999 年 1 月 11 日，此推荐被重新修订。

CSS2

作为一项 W3C 推荐，CSS2 发布于 1999 年 1 月 11 日。CSS2 添加了对媒介（打印机和听觉设备）和可下载字体的支持。

CSS3

CSS3 计划将 CSS 划分为更小的模块。

W3C CSS 规范和时间线

规范 | 草案/提议 | 推荐
CSS 1 |  | 1996 年 12 月 17 日
CSS 1 (Revised) |  | 1999 年 1 月 11 日
CSS 2 |  | 1998 年 5 月 12 日
CSS 2.1 | 2007 年 7 月 19 日 |
CSS 2 Mobile | 2007 年 10 月 19 日 |
CSS 2 TV | 2003 年 5 月 14 日 |
CSS 2 Print | 2006 年 10 月 13 日 |
CSS 3 | 2001 年 5 月 23 日 |
CSS 3 Namespace | 2006 年 8 月 28 日 |
CSS 3 User Interface | 2004 年 5 月 11 日 |
CSS 3 Selectors | 2005 年 12 月 15 日 |
CSS 3 Fonts | 2002 年 8 月 2 日 |
CSS 3 Web Fonts | 2002 年 8 月 2 日 |
CSS 3 Colors | 2003 年 5 月 14 日 |
CSS 3 TV | 2003 年 5 月 14 日 |
CSS 3 Backgrounds and borders | 2005 年 2 月 16 日 |
CSS 3 Text | 2007 年 3 月 6 日 |
CSS 3 Lists | 2002 年 11 月 7 日 |
CSS 3 Line | 2002 年 5 月 15 日 |
CSS 3 Box model | 2007 年 8 月 9 日 |
CSS 3 Multi column | 2007 年 6 月 6 日 |
CSS 3 Ruby | 2003 年 5 月 14 日 |
CSS 3 Border | 2005 年 3 月 16 日 |
CSS 3 Speech | 2004 年 12 月 16 日 |
CSS 3 Paged Media (PM) | 2006 年 10 月 10 日 |
CSS 3 Generated PM | 2007 年 5 月 4 日 |
CSS 3 Print | 2006 年 10 月 13 日 |
CSS 3 Values | 2006 年 9 月 19 日 |
CSS 3 Cascade | 2005 年 12 月 15 日 |
CSS 3 Advanced Layout | 2007 年 8 月 9 日 |
CSS 3 Media Queries | 2007 年 6 月 6 日 |

W3C 引用

W3C CSS 主页

  • Previous Page
  • Next Page


W3C DOM 活动

万维网联盟

  • W3C 首页
  • W3C 简介
  • W3C 程序
  • W3C HTML
  • W3C XHTML
  • W3C XML
  • W3C CSS
  • W3C XSL
  • W3C XML Schema
  • W3C XPath
  • W3C XQuery
  • W3C DOM
  • W3C SOAP
  • W3C WSDL
  • W3C RDF
  • W3C SMIL
  • W3C 其他

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

W3C DOM 活动

  • Previous Page
  • Next Page

文档对象模型 (DOM) 是一个平台，一个中立于语言的应用程序编程接口 (API)，允许程序访问并更改文档的内容、结构和样式。

DOM 教程

如需学习更多有关 DOM 的知识，请阅读我们的 HTML DOM 教程和 XML DOM 教程。

DOM 级别 0

DOM 级别 0 不是 W3C 规范。而仅仅是对在 Netscape Navigator 3.0 和 Microsoft Internet Explorer 3.0 中的等价功能性的一种定义。

DOM 发展过程中的关键角色有：ArborText、IBM、Inso EPS、JavaSoft、Microsoft、Netscape、Novell、the Object Management Group、SoftQuad、Sun Microsystems 以及 Texcel。

W3C 的 DOM 级别 1 建立于此功能性之上。

DOM 级别 1

DOM 级别 1 专注于 HTML 和 XML 文档模型。它含有文档导航和处理功能。

DOM 级别 1 于 1998 年 10 月 1 日成为 W3C 推荐标准。

第二版的工作草案在 2000 年 9 月 29 日。

DOM 级别 2

DOM 级别 2 对 DOM 级别 1 添加了样式表对象模型，并定义了操作附于文档之上的样式信息的功能性。

DOM 级别 2 同时还定义了一个事件模型，并提供了对 XML 命名空间的支持。

作为一项 W3C 推荐标准，DOM 级别 2 规范发布于 2000 年 11 月 13 日：

DOM Level 2 核心

DOM Level 2 核心 规定了访问和更改文档内容及结构的一个 API，此 API 同时包含用于 XML 的接口。

DOM Level 2 HTML

DOM Level 2 HTML 规定了操作 HTML 文档结构和内容的 API。（这部分规范仍然是工作草案）

DOM Level 2 Views

DOM Level 2 规定了对文档视图进行访问和更改的 API。视图是与原文档相关联的表现形式或某种备用的表现形式。

DOM Level 2 Style

DOM Level 2 Style 规定了动态访问及更改内容样式表的 API。

DOM Level 2 Events

DOM Level 2 Events 规定了访问文档事件的 API。

DOM Level 2 Traversal-Range

DOM Level 2 Traversal-Range 规定了动态遍历和识别文档中内容范围的 API。

DOM 级别 3

DOM Level 3 规定了内容模型 (DTD 和 Schemas) 和文档验证。同时规定了文档加载和保存、文档查看、文档格式化和关键事件。DOM Level 3 建立于 DOM Core Level 2 之上。

DOM Level 3 Requirements

DOM Requirements 文档已经为 Level 3 requirements 进行了更新，并于 2000 年 4 月 12 日发布为工作草案。

下面的 DOM Level 3 工作草案发布于 2000 年 9 月 1 日：

DOM Level 3 Core

DOM Level 3 Core 规定了访问和更改文档内容、结构及样式的一个 API。

DOM Level 3 Events

通过增加新的接口和新的事件集，DOM Level 3 Events API 对 Level 2 Event API 的功能进行了扩展。

DOM Level 3 Load and Save

DOM Level 3 Content Model 规定了用于内容加载和保存、内容模型 (DTD and Schemas) 和文档验证支持的 API。

DOM Level 3 Views and Formatting

DOM Level 3 Views 规定了对文档视图进行访问和更改的 API。视图是与原文档相关联的表现形式或某种备用的表现形式。

W3C DOM 规范和时间线

规范 | 草案/提议 | 推荐
DOM Level 1 |  | 1998 年 10 月 1 日
DOM Level 1 (SE) | 2000 年 9 月 29 日 |
DOM Level 2 Core |  | 2000 年 11 月 13 日
DOM Level 2 HTML |  | 2003 年 1 月 9 日
DOM Level 2 Views |  | 2000 年 11 月 13 日
DOM Level 2 Style |  | 2000 年 11 月 13 日
DOM Level 2 Events |  | 2000 年 11 月 13 日
DOM Level 2 Traversal-Range |  | 2000 年 11 月 13 日
DOM Level 3 Requirements | 2004 年 2 月 26 日 |
DOM Level 3 Core |  | 2004 年 4 月 7 日
DOM Level 3 Events | 2007 年 12 月 21 日 |
DOM Level 3 Load and Save |  | 2004 年 4 月 7 日
DOM Level 3 Validation |  | 2004 年 1 月 27 日
DOM Level 3 XPath | 2004 年 2 月 26 日 |
DOM Level 3 Views | 2004 年 2 月 26 日 |

W3C 参考

W3C DOM 主页

  • Previous Page
  • Next Page


W3C HTML 活动

万维网联盟

  • W3C 首页
  • W3C 简介
  • W3C 程序
  • W3C HTML
  • W3C XHTML
  • W3C XML
  • W3C CSS
  • W3C XSL
  • W3C XML Schema
  • W3C XPath
  • W3C XQuery
  • W3C DOM
  • W3C SOAP
  • W3C WSDL
  • W3C RDF
  • W3C SMIL
  • W3C 其他

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

W3C HTML 活动

  • Previous Page
  • Next Page

HTML 是用于万维网发行的混合语言。

XHTML 是最新的HTML版本。

HTML 教程

如需学习更多有关 HTML 的内容，请阅读我们的 HTML 教程。

如需学习更多有关 XHTML 的内容，请阅读我们的 XHTML 教程。

HTML 版本

HTML 2.0

HTML 2.0 是 1996 年由 Internet 工程工作小组的 HTML 工作组开发的。

HTML 2.0 是过时的 HTML 版本。目前在市场上可以找到的浏览器都依赖于更新版本的 HTML。对于一位 WEB 开发者而言，没有任何必要需要 HTML 2.0 标准。

HTML 3.2

HTML 3.2 作为 W3C 标准发布于 1997 年 1 月 14 日。HTML 3.2 向 HTML 2.0 标准添加了被广泛运用的特性，诸如字体、表格、applets、围绕图像的文本流，上标和下标。

这些被添加到 1997 年 HTML 3.2 标准的元素之一 - <font> 标签 - 为 HTML 内容和呈现的分离这个重要的任务带来了不必要的麻烦。

HTML 4.0

作为一项 W3C 推荐，HTML 4.0 被发布于 1997 年 12 月 18 日。而仅仅进行了一些编辑修正的第二个版本发布于 1998 年 4 月 24 日。

HTML 4.0 最重要的特性是引入了样式表（CSS）。

我们的 W3C CSS 章节总结了 W3C CSS 活动。

HTML 4.01

作为一项 W3C 推荐，HTML 4.01 发布于 1999 年 12 月 24 日。

HTML 4.01 是对 HTML 4.0 的一次较小的更新，对后者进行了修正和漏洞修复。

W3C 不会继续发展 HTML。未来 W3C 的工作会集中在 XHTML 上。

XHTML 1.0 (最新版本的HTML)

XHTML 1.0 使用 XML 对 HTML 4.01 进行了重新地表示。

作为一项 W3C 推荐，XHTML 1.0 发布于 2000 年 1 月 20 日。

W3C HTML 规范和时间线

规范 | 推荐
HTML 3.2 | 1997年1月14日
HTML 4.0 | 1998年5月24日
HTML 4.01 | 1999年12月24日

在下一节会找到有关 XHTML 规范和时间线的内容。

W3C 参考：

W3C HTML 主页

  • Previous Page
  • Next Page


W3C RDF 和 OWL 活动

万维网联盟

  • W3C 首页
  • W3C 简介
  • W3C 程序
  • W3C HTML
  • W3C XHTML
  • W3C XML
  • W3C CSS
  • W3C XSL
  • W3C XML Schema
  • W3C XPath
  • W3C XQuery
  • W3C DOM
  • W3C SOAP
  • W3C WSDL
  • W3C RDF
  • W3C SMIL
  • W3C 其他

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

W3C RDF 和 OWL 活动

  • Previous Page
  • Next Page

RDF 和 OWL 是两项重要的语义网技术。

语义网 (Semantic Web)

语义网是为资产管理、企业整合及网络数据的共享和重用提供的一个框架。

语义网为企业、应用程序、公司、团体和个人间的数据共享提供了一个独立于平台和软件的框架。

RDF 和 OWL 是的语义网的关键技术。它们分别阐述了结构性描述和以万维网为基础的本体论。

RDF - 资源描述框架（Resource Description Framework）

RDF 是一门向万维网表达信息的语言。

RDF 可用于描述 web 资源，比如标题、作者以及版本信息、内容描述、可用时间表等等。

如果您需要学习有关 RDF 的知识，请访问我们的 RDF 教程。

OWL - Web 本体语言

OWL 是用于定义本体的语言。

本体可描述知识的领域。可供人类或软件用来分享有关对象的信息，这些对象可以是汽车、房屋、机器、书籍、产品、金融交易等等。

OWL 被设计为用于对信息进行处理（而不是现实信息）。

假如您需要学习更多有关 OWL 的知识，请访问我们的 RDF 教程。

SPARQL - 针对 RDF 的查询语言

SPARQL 是用于 RDF 数据的标准查询语言，可向开发者提供编写跨越 WEB 上广域 RDF 信息查询程序的途径。

W3C 规范和时间线

规范 | 草案/提议 | 推荐
RDF Primer |  | 2004 年 2 月 10 日
RDF Test Cases |  | 2004 年 2 月 10 日
RDF Concept |  | 2004 年 2 月 10 日
RDF Semantics |  | 2004 年 2 月 10 日
RDF Schema |  | 2004 年 2 月 10 日
RDF Syntax |  | 2004 年 2 月 10 日
OWL Overview |  | 2004 年 2 月 10 日
OWL Guide |  | 2004 年 2 月 10 日
OWL Reference |  | 2004 年 2 月 10 日
OWL Syntax |  | 2004 年 2 月 10 日
OWL Test Cases |  | 2004 年 2 月 10 日
OWL Use Cases |  | 2004 年 2 月 10 日
Parsing OWL in RDF | 2004 年 1 月 21 日 |
SPARQL Requirements | 2005 年 3 月 25 日 |
SPARQL Language | 2008 年 1 月 15 日 |

W3C 参考

W3C 语义网活动

  • Previous Page
  • Next Page


W3C SMIL 活动

万维网联盟

  • W3C 首页
  • W3C 简介
  • W3C 程序
  • W3C HTML
  • W3C XHTML
  • W3C XML
  • W3C CSS
  • W3C XSL
  • W3C XML Schema
  • W3C XPath
  • W3C XQuery
  • W3C DOM
  • W3C SOAP
  • W3C WSDL
  • W3C RDF
  • W3C SMIL
  • W3C 其他

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

W3C SMIL 活动

  • Previous Page
  • Next Page

SMIL 向 web 增加了对定时和媒介同步的支持。

SMIL

SMIL (Synchronized Multimedia Integration Language) 被设计为用来启用 web 上的多媒体呈现。

SMIL 呈现可由音频、视频、图像、文本以及其他媒介类型组成。

SMIL 是一门基于 XML 的类 HTML 语言。

您可以在我们的 SMIL 教程 中阅读更多有关 SMIL 的内容。

HTML+TIME

HTML+TIME 指的是对 HTML 的定时多媒体交互扩展（Timed Interactive Multimedia Extensions for HTML）。它的作用是向 HTML 添加 SMIL 1.0 的定时和同步支持。

HTML+TIME 被以下单位提交到 W3C ：Microsoft、Macromedia、Compaq/Digital 以及 Digital Renaissance。

您可以在我们的 SMIL 教程 教程中阅读更多有关 HTML+TIME 的知识。

HTML+SMIL

HTML+SMIL （对 HTML+TIME 的修正）曾在一份早期的 SMIL 2.0 工作草案被提及。

SMIL 2.0 成为 W3C 推荐标准后，HTML+SMIL 被从 SMIL 2.0 中删除，并成为名为 XHTM+SMIL 的独立工作草案。

XHTML+SMIL

XHTML+SMIL 在 XHTML 中提供了对 SMIL 2.0 功能性的支持，比如动作、媒介、定时、同步以及直接转换。

XHTML+SMIL 目前是被提交到 W3C 的一份记录，其意图是 XHTML+SMIL 能够被用作向 XHTML 中整合 SMIL 的工作基础。

您可以在我们的 SMIL 教程 教程中阅读更多有关 XHTML+SMIL 的内容。

HTML/XHTML+SMIL 的历史

15. June 1998
SMIL 1.0 成为 W3C 推荐标准。
18. September 1998
作为一项向 HTML 增加了 SMIL 1.0 定时和同步的提议，HTML+TIME 被 Microsoft、Macromedia、Compaq/Digital 以及 Digital Renaissance 提交到 W3C。
25. February 2000
HTML+TIME 以重新命名的 HTML+SMIL 被添加到 SMIL 2.0 的工作草案。
22. June 2000
HTML+SMIL 被从 SMIL 2.0 工作草案中删除。
07. August 2001
SMIL 2.0 成为 W3C 标准。
07. August 2001
HTML+SMIL 成为一个独立的工作草案，被重新命名为 XHTML+SMIL。
31. January 2002
XHTML+SMIL 作为 W3C 记录被重新提交。

W3C SMIL 规范和时间线

规范 | 草案/提议 | 推荐
SMIL 1.0 |  | 1998 年 6 月 15 日
SMIL 2.0 |  | 2001 年 8 月 7 日
SMIL 2.0 (2.ED) |  | 2005 年 12 月 13 日
SMIL 2.1 |  | 2005 年 12 月 13 日
HTML+TIME | 1998 年 9 月 18 日 |
HTML+SMIL | 2000 年 6 月 22 日 |
XHTML+SMIL | 2001 年 8 月 7 日 |
XHTML+SMIL Note | 2002 年 1 月 31 日 |

W3C 参考

W3C SMIL 主页

  • Previous Page
  • Next Page


W3C Soap 活动

万维网联盟

  • W3C 首页
  • W3C 简介
  • W3C 程序
  • W3C HTML
  • W3C XHTML
  • W3C XML
  • W3C CSS
  • W3C XSL
  • W3C XML Schema
  • W3C XPath
  • W3C XQuery
  • W3C DOM
  • W3C SOAP
  • W3C WSDL
  • W3C RDF
  • W3C SMIL
  • W3C 其他

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

W3C Soap 活动

  • Previous Page
  • Next Page

Web Services 与应用程序到应用程序的通信有关。

SOAP 是基于 XML 的 Web Services 间的通信协议。

SOAP 教程

SOAP (Simple Object Access Protocol) 是一种中立于平台和语言的轻量级通信协议，使得程序可以通过标准的因特网 HTTP 进行通信。

如需学习更多有关 SOAP 的知识，请阅读我们的 SOAP 教程。

SOAP 1.1

在 2000 年 5 月，SOAP 1.1 曾在一份记录中被建议到 W3C（由开发商：IBM, Lotus, Microsoft 以及 Userland），作为用于在分布式环境中交换信息的一种协议。

W3C SOAP 1.1 文档仅仅是一份用于讨论的纪录（NOTE）。此记录的发布不代表 W3C 对其任何程度的认可。

SOAP 1.2

W3C 的 XML Protocol 工作组目前正工作于 SOAP 1.2

第一份工作草案发布于 2001 年 12 月 17 日。

SOAP 1.2 于 2003 年 6 月 24 日被发布为 W3C 推荐标准。

W3C SOAP 规范和时间线

规范 | 草案/提议 | 推荐
SOAP 1.2 Primer |  | 2003 年 6 月 24 日
SOAP 1.2 Primer SE |  | 2007 年 4 月 27 日
SOAP 1.2 Messaging |  | 2003 年 6 月 24 日
SOAP 1.2 Messaging SE |  | 2007 年 4 月 27 日
SOAP 1.2 Adjuncts |  | 2003 年 6 月 24 日
SOAP 1.2 Adjuncts SE |  | 2007 年 4 月 27 日
SOAP 1.2 Test Collection |  | 2003 年 6 月 24 日
SOAP 1.2 Test Collection SE |  | 2007 年 4 月 27 日
SOAP 1.2 Attachments | 2004 年 6 月 8 日 |
SOAP 1.2 Email Bindings | 2002 年 7 月 3 日 |
SOAP 1.2 Normalization | 2003 年 10 月 8 日 |
SOAP 1.2 Serialization | 2004 年 6 月 8 日 |
Web Services Addressing 1.0 - Core |  | 2006 年 5 月 9 日
Web Services Addressing 1.0 - SOAP |  | 2006 年 5 月 9 日

W3C 参考

W3C SOAP 主页

  • Previous Page
  • Next Page


W3C WSDL 活动

万维网联盟

  • W3C 首页
  • W3C 简介
  • W3C 程序
  • W3C HTML
  • W3C XHTML
  • W3C XML
  • W3C CSS
  • W3C XSL
  • W3C XML Schema
  • W3C XPath
  • W3C XQuery
  • W3C DOM
  • W3C SOAP
  • W3C WSDL
  • W3C RDF
  • W3C SMIL
  • W3C 其他

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

W3C WSDL 活动

  • Previous Page
  • Next Page

Web Services 与应用程序到应用程序的通信有关。

WSDL 是一门基于 XML 的 Web Services 描述语言。

WSDL 教程

WSDL (Web Services Description Language) 是一种用于描述 Web Services 的 XML 格式。。

如需学习更多有关 WSDL 的知识，请阅读我们的 WSDL 教程。

WSDL 1.1

作为一种可描述 Web Services 的 XML 格式，WSDL 1.1 于 2001 年 3 月曾在一份记录中被建议到 W3C（由Ariba、IBM 以及 Microsoft）。

此记录还描述了如何结合 SOAP 1.1、HTTP GET/POST 以及 MIME 来使用 WSDL。

W3C WSDL 1.1 仅仅是用于讨论的纪录（NOTE）。此记录的发布不代表 W3C 对其任何程度的认可。

WSDL 1.2

第一份工作草案发布于 2001 年 12月 17 日。

最新的工作草案发布于 2003 年 6月 11 日。

WSDL 2.0

W3C 的 XML Protocol 工作组目前正在工作于 WSDL 2.0。

W3C WSDL 规范和时间线

规范 | 草案/提议 | 推荐
WSDL 1.1 Note | 2001 年 3 月 15 日 |
WSDL Usage Scenarios | 2002 年 6 月 4 日 |
WSDL Requirements | 2002 年 10 月 28 日 |
WSDL Architecture | 2004 年 2 月 11 日 |
WSDL Glossary | 2004 年 2 月 11 日 |
WSDL Usage Scenarios | 2004 年 2 月 11 日 |
WSDL 1.2 Core Language | 2003 年 6 月 11 日 |
WSDL 1.2 Message Patterns | 2003 年 6 月 11 日 |
WSDL 1.2 Bindings | 2003 年 6 月 11 日 |
WSDL 2.0 Primer | 2007 年 6 月 26 日 |
WSDL 2.0 Core Language | 2007 年 6 月 26 日 |
WSDL 2.0 Adjuncts | 2007 年 6 月 26 日 |
WSDL 2.0 SOAP 1.1 Binding | 2007 年 6 月 26 日 |
WSDL 2.0 RDF Mapping | 2007 年 6 月 26 日 |
WS Addressing Core |  | 2006 年 5 月 9 日
WS Addressing SOAP Binding |  | 2006 年 5 月 9 日
Web Architecture |  | 2004 年 12 月 15 日

W3C 参考

W3C Web Services 主页

  • Previous Page
  • Next Page


W3C XHTML 活动

万维网联盟

  • W3C 首页
  • W3C 简介
  • W3C 程序
  • W3C HTML
  • W3C XHTML
  • W3C XML
  • W3C CSS
  • W3C XSL
  • W3C XML Schema
  • W3C XPath
  • W3C XQuery
  • W3C DOM
  • W3C SOAP
  • W3C WSDL
  • W3C RDF
  • W3C SMIL
  • W3C 其他

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

W3C XHTML 活动

  • Previous Page
  • Next Page

HTML 是用于万维网发行的混合语言。

XHTML 是最新的 HTML 版本。

XHTML 教程

如需了解如何把网站转换至 XHTML，请阅读我们的 XHTML 教程。

XHTML 版本

XHTML 1.0

作为一项 W3C 推荐，XHTML 1.0 发布于 2000 年 1 月 20 日。

XHTML 1.0 第二版

作为一项 W3C 推荐，XHTML 1.0 第二版发布于 2002 年 8 月 1 日。它不是一个新的版本，而是一次更新和漏洞修复。

关于 XHTML 1.0

XHTML 1.0 是自 1997 年以来对 HTML 的第一次主要的改变，同时也是在向更广泛的用户代理提供更丰富网页的道路上迈出的非常重要的一步，这些用户代理（代理）包括桌面电脑、移动设备和手机等等。

XHTML 是一项可从 HTML 4.01 平稳迁移的 XML 应用。W3C 把 HTML 4.01 重构为 XML 的第一个步骤，导致了 XHTML 1.0 的诞生。XHTML 1.0 依赖于 HTML 4.01 标签所提供的语义。

下一步是把 XHTML 模块化为更小的元素集合，使得 XHTML 和其他标记语言（比如矢量图形和多媒体）的结合更加容易。

同时，XHTML 的模块化还可以减少开发费用，改善与其它应用程序（比如数据库）的协同，更易与不同的用户代理（浏览器）进行通信，以及 HTML 和不同 XML 标准之间更纯净的整合。

W3C XHTML 活动

XHTML 1.0

XHTML 1.0 是使用 XML 对 HTML 4.01 进行的重新表示。

如需学习更多有关 XHTML 的知识，请访问我们的 XHTML 教程。

XHTML 1.1 (模块化的 XHTML)

小型设备（比如移动电话）无法支持 XHTML 的全部功能。XHTML 1.1 将规范划分为具备有限功能的模型。小型浏览器可以通过支持选定的模型来减低其复杂性（不过一旦选定某个模型，就必须支持其全部特性）。

XHTML 1.1 是一门严格的语言。 XHTML 1.1 不能向后兼容 HTML 4。

XHTML 基础

XHTML Basic 是 XHTML 1.1 的小型子集。它仅包含基本的 XHTML 特性，比如文本结构、图像、基本的标单以及基本的表格。它是为小型浏览器设计的（比如在手持设备中）。

XHTML 事件

正是由于 XHTML 中对 W3C 文档对象模型级别 2 的支持，事件处理器就可以依附在 XHTML 元素上，这样父元素就可以在子元素之前或之后来处理事件。

如需学习更多有关 DOM 的知识，请学习我们的 DOM 教程。

XHTML 打印

XHTML-Print 是 XHTML 1.1 (模块化的 XHTML) 的一部分。

XHTML-Print 被设计用于移动设备和廉价的打印机，这些设备通常可在没有打印缓存和为设备定制的打印驱动的情况下，将一张页面从头到尾打印出来。

XForms

通过 XHTML 表单，用户可以访问某张页面，向页面添加信息，然后向Web服务器提交页面。

XForms 是 HTML 表单的继任者，提供一种更完善且独立于呈现的 Web交 互事务处理方式。用于它被设计为与 XHTML 进行整合，我们期望未来的电子商务应用程序会需要需要 XForms。

如需学习更多有关 XForms 的知识，请学习我们的 XForms 教程。

XHTML 模块化

XHTML 模块化指的是，把 XHTML 1.0 划分为可提供特定功能的小型模型的集合。

XHTML 1.0 的模块化是通过使用 XML DTD (Document Type Definition) 来实现的。

XHTML 2.0 的模块化是通过使用 XML Schemas 来实现的。

如需学习更多有关 DTD 的知识，请学习我们的 DTD 教程。

如需学习更多有关 XML Schemas 的知识，请学习我们的 XML Schemas 教程。

XHTML 2.0

XHTML 2.0 是下一代的标记语言。其功能性预计和 XHTML 1.1 很相似，但是可能被变更来遵守 XML 标准的要求，比如 XML Linking 和 XML Schema。

XLink

XLink 是在 XML 文档中创建超链接的一门语言。XLink 与 HTML 链接很相似 - 但是更加强有力地支持简单链接（比如 HTML）和扩展链接（用于把多项资源链接到一起）。

您可以在我们的 XLink 教程 中学习更多有关 XLink 的知识。

HLink

HLink 增加了一项能力，可规定在 XHTML 中元素哪项元素可表示超链接，并规定如何对超链接进行遍历。

HLink 是对 XLink 的扩展。

W3C HTML 规范 和 时间线

规范 | 草案/提议 | 推荐
XHTML 1.0 |  | 2000 年 1 月 26 日
XHTML 1.0 修订版 |  | 2002 年 8 月 1 日
XHTML 1.1 |  | 2001 年 5 月 31 日
XHTML Modules |  | 2001 年 4 月 10 日
XHTML Modules 1.1 | 2006 年 7 月 5 日 |
XHTML Basic |  | 2000 年 12 月 19 日
XHTML Basic 1.1 | 2006 年 7 月 5 日 |
XHTML Events |  | 2003 年 10 月 14 日
XHTML Events 2 | 2007 年 2 月 16 日 |
XHTML Print |  | 2006 年 9 月 20 日
XHTML Media Types | 2002 年 8 月 1 日 |
XForms 1.0 |  | 2003 年 10 月 14 日
XForms 1.0 (SE) |  | 2006 年 3 月 14 日
XForms 1.1 | 2007 年 2 月 22 日 |
XHTML 2.0 | 2006 年 7 月 26 日 |
XLink |  | 2001 年 6 月 27 日
HLink | 2002 年 9 月 13 日 |

W3C 参考：

W3C HTML 主页

  • Previous Page
  • Next Page


W3C XML Schema 活动

万维网联盟

  • W3C 首页
  • W3C 简介
  • W3C 程序
  • W3C HTML
  • W3C XHTML
  • W3C XML
  • W3C CSS
  • W3C XSL
  • W3C XML Schema
  • W3C XPath
  • W3C XQuery
  • W3C DOM
  • W3C SOAP
  • W3C WSDL
  • W3C RDF
  • W3C SMIL
  • W3C 其他

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

W3C XML Schema 活动

  • Previous Page
  • Next Page

XML Schema 是基于 XML 的 DTD 替代物。

XML 教程

如需学习更多有关 XML Schema 的知识，请阅读我们的 XML Schema 教程。

XML Schema

XML 1.0 支持可定义文档结构的 DTD。

XML Schema 对应用程序、文档结构、属性和数据类型有着更良好的支持。

未来的 XML 版本有赖于 XML Schema 来定义 XML 文档的类型。

  • XML Schema 的结构规定了 XML Schem 的定义语言。
  • XML Schema 的数据类型为 XML 规定了可扩展的数据类型。

W3C XML 规范和时间线

规范 | 草案/提议 | 推荐
XML Schema |  | 2001 年 5 月 2 日
XML Schema Structures |  | 2001 年 5 月 2 日
XML Schema Datatypes |  | 2001 年 5 月 2 日
XML Schema (2.Ed) |  | 2004 年 10 月 28 日
XML Schema Structures (2.Ed) |  | 2004 年 10 月 28 日
XML Schema Datatypes (2.Ed) |  | 2004 年 10 月 28 日
XML Schema Component Designators | 2005 年 3 月 29 日 |

W3C 参考

W3C XML Schema 主页

  • Previous Page
  • Next Page


W3C XML 活动

万维网联盟

  • W3C 首页
  • W3C 简介
  • W3C 程序
  • W3C HTML
  • W3C XHTML
  • W3C XML
  • W3C CSS
  • W3C XSL
  • W3C XML Schema
  • W3C XPath
  • W3C XQuery
  • W3C DOM
  • W3C SOAP
  • W3C WSDL
  • W3C RDF
  • W3C SMIL
  • W3C 其他

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

W3C XML 活动

  • Previous Page
  • Next Page

XML 被设计用来描述、存储、传送及交换数据。

XML 1.0 是 XML 的最新版本。

XML 教程

如需学习更多有关 XML 的知识，请阅读我们的 XML 教程。

XML 版本

XML 1.0

作为一项 W3C 推荐，XML 1.0 发布于 1998 年 2 月 10 日。

XML 1.0 (第二版)

作为一项 W3C 推荐，XML 1.0 (SE) 发布于 2000 年 10 月 6 日。

第二版仅仅是在合并第一版的勘误表的基础上进行的修正（漏洞修复）。

XML 1.0 (第三版)

第二版仅仅是在合并第一版和第二版的勘误表的基础上进行的修正（漏洞修复）。

XML 1.1

作为一份工作草案，XML 1.1 发布于2001 年 12 月 13 日，并作为一项候选推荐发布于2002年10月15日。

XML 1.1 允许在名称中使用几乎所有的 Unicode 字符。

其他 W3C XML 技术

XML 命名空间（Namespaces）

XML 命名空间可规定一种方法，通过与 URI 引用相关联的方式，来定义在 XML 中使用的元素和属性名称。

XML Linking (XLink、XPointer 以及 XML Base)

XML Linking 语言 (XLink)，允许您向XML文档中插入链接。

XML Pointer 语言 (XPointer)，允许将地址链接到 XML 文档的具体部分。

XML Base 是一种用于对外部 XML 资源进行默认引用的标准。(与 HTML 中的 <base> 类似)。

XInclude

XInclude 是一种使用元素、属性以及 URI 引用来合并 XML 文档的机制。

W3C XML 规范和时间线

规范 | 草案/提议 | 推荐
XML 1.0 |  | 1998 年 2 月 10 日
XML 1.0 (2.Ed) |  | 2000 年 10 月 6 日
XML 1.0 (3.Ed) |  | 2004 年 2 月 4 日
XML 1.1 |  | 2004 月 2 月 4 日
XML 1.1 (2.Ed) |  | 2006 年 8 月 16 日
XML 1.0 Namespaces |  | 1999 年 1 月 14 日
XML 1.0 Namespaces SE |  | 2004 年 3 月 4 日
XML 1.1 Namespaces |  | 2004 年 3 月 4 日
XML 1.1 Namespaces SE |  | 2006 年 8 月 16 日
XML Infoset |  | 2001 年 10 月 24 日
XML Infoset (2.Ed) |  | 2004 年 2 月 4 日
XML Base |  | 2001 年 6 月 27 日
XLink 1.0 |  | 2001 年 6 月 27 日
XPointer Framework |  | 2003 年 3 月 25 日
XPointer element() scheme |  | 2003 年 3 月 25 日
XPointer xmlns() scheme |  | 2003 年 3 月 25 日
XInclude 1.0 |  | 2004 年 12 月 20 日
XInclude 1.0 SE |  | 2006 年 11 月 15 日
XML Processing Model | 2004 年 4 月 5 日 |

W3C 引用

W3C XML 主页

  • Previous Page
  • Next Page


W3C XPath 活动

万维网联盟

  • W3C 首页
  • W3C 简介
  • W3C 程序
  • W3C HTML
  • W3C XHTML
  • W3C XML
  • W3C CSS
  • W3C XSL
  • W3C XML Schema
  • W3C XPath
  • W3C XQuery
  • W3C DOM
  • W3C SOAP
  • W3C WSDL
  • W3C RDF
  • W3C SMIL
  • W3C 其他

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

W3C XPath 活动

  • Previous Page
  • Next Page

XPath 是一门用于选取 XML 文档的部件的语言。

XPath 被设计为供 XSLT、XQuery 以及 XPointer 使用。

XML 教程

如需学习更多有关 XPath 的知识，请阅读我们的 XPath 教程。

如需学习更多有关 XQuery 的知识，请阅读我们的 XQuery 教程。

如需学习更多有关 XSLT 的知识，请阅读我们的 XSLT 教程。

XPath 版本

XPath 1.0

XPath 1.0 于 1999 年 11 月 16 日成为 W3C 推荐标准。

XPath 2.0

XPath 2.0 于 2007 年 1 月 23 日成为 W3C 推荐标准。

XPath 2.0 是一门由 XPath 1.0 和 XQuery 衍生而来的语言。XPath 2.0 和 XQuery 1.0 的产生是同源的，它们拥有不少相同的语法，而且不少文本也是一致的。

W3C XPath 规范和时间线

规范 | 草案/提议 | 推荐
XPath 1.0 |  | 1999 年 11 月 16 日
XPath 2.0 Requirements | 2005 年 6 月 3 日 |
XPath 2.0 Language |  | 2007 年 1 月 23 日
XPath 2.0 Functions |  | 2007 年 1 月 23 日
XPath 2.0 Data Model |  | 2007 年 1 月 23 日
XPath 2.0 Semantics |  | 2007 年 1 月 23 日
XPointer | 2002 年 8 月 16 日 |

W3C 参考

W3C XSL 主页

  • Previous Page
  • Next Page


W3C XQuery 活动

万维网联盟

  • W3C 首页
  • W3C 简介
  • W3C 程序
  • W3C HTML
  • W3C XHTML
  • W3C XML
  • W3C CSS
  • W3C XSL
  • W3C XML Schema
  • W3C XPath
  • W3C XQuery
  • W3C DOM
  • W3C SOAP
  • W3C WSDL
  • W3C RDF
  • W3C SMIL
  • W3C 其他

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

W3C XQuery 活动

  • Previous Page
  • Next Page

XQuery 是一门用于从 XML 文档中提取数据的语言。

XML 教程

如需学习更多有关 XQuery 的知识，请阅读我们的 XQuery 教程。

XQuery 版本

XQuery 1.0

XQuery 语言支持从 XML 文档提取数据的查询工具。

W3C XQuery 规范和时间线

规范 | 草案/提议 | 推荐
XQuery Requirements | 2007 年 3 月 23 日 |
XQuery Use Cases | 2007 年 3 月 23 日 |
XQuery 1.0 |  | 2007 年 1 月 23 日
XQuery 1.0 Functions |  | 2007 年 1 月 23 日
XQuery 1.0 Data Model |  | 2007 年 1 月 23 日
XQuery 1.0 Semantics |  | 2007 年 1 月 23 日
XQueryX |  | 2007 年 1 月 23 日

W3C 参考

W3C XSL 主页

  • Previous Page
  • Next Page


W3C XSL 活动

万维网联盟

  • W3C 首页
  • W3C 简介
  • W3C 程序
  • W3C HTML
  • W3C XHTML
  • W3C XML
  • W3C CSS
  • W3C XSL
  • W3C XML Schema
  • W3C XPath
  • W3C XQuery
  • W3C DOM
  • W3C SOAP
  • W3C WSDL
  • W3C RDF
  • W3C SMIL
  • W3C 其他

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

W3C XSL 活动

  • Previous Page
  • Next Page

样式表可描述文档如何被显示、发音或打印。XSL 语言包括三部分：XSLT、XPath 以及 XSL 格式化对象。

XML 教程

如需学习更多有关 XSL 的知识，请阅读我们的 XSL 教程。

XSL 版本

XSL 1.0

作为一项 W3C 推荐标准，XSL 1.0 作为一门表达样式表的语言被发布于 2001 年 10 月 15 日。它由三部分组成：XSLT、XPath 以及 XSL 格式化对象。

XSLT 1.0

XSLT 1.0于 1 999年11月16日成为 W3C 推荐标准。XSLT 是一门用于把 XML 文档转换为其他 XML 文档的语言。

XSLT 2.0

XSLT 2.0于 2007 年 1 月 23 日成为 W3C 推荐标准。

XSL-FO (XSL 格式化对象)

XSL 格式化对象一个用于规定格式化语义的词汇表。格式化指的是把XSL转换的结果转变为适合阅读器或收听器的过程。虽然不存在针对 XSL 格式化对象的独立 W3C 文档，但是还是可以在 XSL 1.0 推荐标准中找到相关的描述。

W3C XSL 规范和时间线

规范 | 草案/提议 | 推荐
XSL 1.0 (XSL-FO) |  | 2001 年 10 月 15 日
XSL 1.1 |  | 2006 年 12 月 5 日
XSLT 1.0 |  | 1999 年 11 月 16 日
XSLT 1.1 | 2001 年 8 月 24 日 |
XSLT 2.0 Requirements | 2001 年 2 月 14 日 |
XSLT 2.0 |  | 2007 年 1 月 23 日

W3C 引用

W3C XSL 主页

  • Previous Page
  • Next Page


W3C 程序

万维网联盟

  • W3C 首页
  • W3C 简介
  • W3C 程序
  • W3C HTML
  • W3C XHTML
  • W3C XML
  • W3C CSS
  • W3C XSL
  • W3C XML Schema
  • W3C XPath
  • W3C XQuery
  • W3C DOM
  • W3C SOAP
  • W3C WSDL
  • W3C RDF
  • W3C SMIL
  • W3C 其他

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

W3C 程序

  • Previous Page
  • Next Page

W3C 的标准化程序分为 7 个不同的步骤。

W3C 规范的批准步骤

在 W3C 发布某个新标准的过程中，规范是通过下面的严格程序由一个简单的理念逐步确立为推荐标准的：

  • W3C 收到一份提交
  • 由 W3C 发布一份记录
  • 由 W3C 创建一个工作组
  • 由 W3C 发布一份工作草案
  • 由 W3C 发布一份候选的推荐
  • 由 W3C 发布一份被提议的推荐
  • 由 W3C 发布推荐

在本教程下面的章节，总结了 HTML、CSS、XML、XSL 在 W3C 的相应活动，包括每项 Web 标准的状态和时间线。

W3C 提交 (W3C Submissions)

任何 W3C 的成员都可向联盟提交希望成为 Web 标准的某项建议（案）。大多数W3C推荐都发源于向联盟做出的某个提交。

如果某项提交在 W3C 的工作领域（或宪章）内，那么 W3C 将决定是否启动对该项提议的改进工作。

W3C 记录 (W3C Notes)

通常，一项对 W3C 的提交会成为一份记录。记录是对作为一份公共文档来提炼的一项提议的描述。

W3C 仅把记录用户讨论。记录的发布并不代表对其的认可。记录的内容是由提交此记录的会员来编辑的，而不是 W3C。记录可在任何时间被更新、替换或废弃。记录的发布也不表明 W3C 已启动与此记录相关的任何工作。

W3C 工作组 (W3C Working Groups)

当某项提交被 W3C 承认，一个工作组就会成立，其中包括会员和其他有兴趣的团体。

工作组通常会定义一个时间表，并发布有关被提议标准的工作草案。

W3C 工作草案 (W3C Working Drafts)

W3C 工作草案通常会被发布于 W3C 的网站上，连同对公共注解的邀请。

工作草案会说明进行中的工作，但不应被用作任何参考材料。其内容可在任何时间被更新、替换或废弃。

W3C 候选推荐 (W3C Candidate Recommendations)

某些规范会比其他规范更复杂，并可能需要来自会员和软件开发商的更多的经费、更多时间以及更多测试。有时，这些规范会作为候选的推荐来发布。

候选的推荐也是一种“正在进行的工作”，同样不应被用作参考材料。此文档可在任何时间被更新、替换或废弃。

W3C 提议推荐 (W3C Proposed Recommendations)

提议的推荐意味着工作组中工作的最后阶段。

提议推荐也是一种“正在进行的工作”。此文档可在任何时间被更新、替换或废弃。不过即使它不意味着 W3C 的任何官方的认可，在极多的情况下，提议的推荐无论在内容还是时间上都已接近于最后的推荐。

W3C 推荐 (W3C Recommendations)

W3C 推荐已经通过了 W3C 会员们的评审，并得到了 W3C 主任的正式批准。

W3C 推荐是一份稳定的文档，并可被用作参考材料。

在本教程下面的章节，总结了 HTML、CSS、XML、XSL 在 W3C 的相应活动，包括每项 Web 标准的状态和时间线。

参考

World Wide Web Consortium

  • Previous Page
  • Next Page


W3C 简介

万维网联盟

  • W3C 首页
  • W3C 简介
  • W3C 程序
  • W3C HTML
  • W3C XHTML
  • W3C XML
  • W3C CSS
  • W3C XSL
  • W3C XML Schema
  • W3C XPath
  • W3C XQuery
  • W3C DOM
  • W3C SOAP
  • W3C WSDL
  • W3C RDF
  • W3C SMIL
  • W3C 其他

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

W3C 简介

  • Previous Page
  • Next Page

W3C，这个建立于 1994 年的组织，其宗旨是通过促进通用协议的发展并确保其通用型，以激发 web 世界的全部潜能。

W3C 是什么？

  • W3C 指万维网联盟（World Wide Web Consortium）
  • W3C 创建于1994年10月
  • W3C 由 Tim Berners-Lee 创建
  • W3C 是一个会员组织
  • W3C 的工作是对web进行标准化
  • W3C 创建并维护 WWW 标准
  • W3C 标准被称为 W3C 推荐（W3C Recommendations）

W3C 是如何创建的？

万维网（World Wide Web）是作为欧洲核子研究组织的一个项目发展起来的，这那里 Tim Berners-Lee 开发出万维网的雏形。

Tim Berners-Lee - 万维网的发明人 - 目前是万维网联盟的主任。

W3C 在 1994 年被创建的目的是，为了完成麻省理工学院（MIT）与欧洲粒子物理研究所（CERN）之间的协同工作，并得到了美国国防部高级研究计划局（DARPA）和欧洲委员会（European Commission）的支持。

对 web 进行标准化

W3C 致力于实现所有的用户都能够对 web 加以利用（不论其文化教育背景、能力、财力以及其身体残疾）。

W3C 同时与其他标准化组织协同工作，比如 Internet 工程工作小组（Internet Engineering Task Force）、无线应用协议（WAP）以及 Unicode 联盟（Unicode Consortium）。

W3C 由美国麻省理工学院计算机科学和人工智能实验室 (MIT CSAIL)，总部位于法国的欧洲信息数学研究联盟 (ERCIM) 和日本的庆应大学（Keio University）联合运作，并且在世界范围内拥有分支办事处。

W3C 会员

正因为 Web 是如此的重要（不论在其影响范围还是在投资方面），以至于不应由任何一家单独的组织来对它的未来进行控制，因此 W3C 扮演者一个会员组织的角色：

一些知名的会员包括：

  • IBM
  • Microsoft
  • America Online
  • Apple
  • Adobe
  • Macromedia
  • Sun Microsystems

W3C 的会员包括了：软件开发商、内容提供商、企业用户、通信公司、研究机构、研究实验室、标准化团体以及政府。

W3C Recommendations

W3C 最重要的工作是发展 Web 规范（称为推荐，Recommendations），这些规范描述了 Web 的通信协议（比如 HTML 和 XHTML）和其他的构建模块。

每项 W3C 推荐的发展是通过由会员和受邀专家组成的工作组来完成的。工作组的经费来自公司和其他组织，并会创建一个工作草案，最后是一份提议推荐。一般来说，为了获得正式的批准，推荐都会被提交给 W3C 会员和主任。

下一节，我们会为您解释规范的批准过程。

  • Previous Page
  • Next Page


其他的 W3C 活动

万维网联盟

  • W3C 首页
  • W3C 简介
  • W3C 程序
  • W3C HTML
  • W3C XHTML
  • W3C XML
  • W3C CSS
  • W3C XSL
  • W3C XML Schema
  • W3C XPath
  • W3C XQuery
  • W3C DOM
  • W3C SOAP
  • W3C WSDL
  • W3C RDF
  • W3C SMIL
  • W3C 其他

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

其他的 W3C 活动

  • Previous Page
  • Next Page

本节概况了其他一些重要和有趣的 W3C 活动。

Web Accessibility Initiative (WAI)

WAI 定义了如何使残障人士更易使用 Web 内容的指导方针。

WAI 通过技术、指导方针、工具、教育、研究以及开发项目，为 "Web accessibility for all" 这个目标而努力。

W3C WAI 推荐标准

数学标记语言 - Mathematical Markup Language (MathML)

MathML 是一项用于描述数学符号的 XML 标准。

MathML 的目标的使数学能够在 Web 上被提供、接受和处理，就像 HTML 可以令文本实现的功能一样。

W3C MathML 推荐标准

可缩放的矢量图形 - Scalable Vector Graphics (SVG)

SVG 是一门用于在 XML 中描述二位图形的语言。

SVG 运行三种类型的图形对象：矢量图形形状、图像和文本。

特性设置包括了变换、裁剪路径、alpha 遮罩、滤镜效果、模版对象以及可扩展性。

W3C SVG 1.1 推荐标准

W3C SVG 1.2 工作草案

墨水标记语言 - Ink Markup Language (InkML)

InkML 是用于表达数字墨水数据的 XML 数据格式，这类数据的输入是通过作为多通路系统组成部分的电子笔或输入笔。

W3C InkML 工作草案

国际化 - Internationalization

W3C 国际化活动的目标是，在 W3C 内部以及与其他组织一起，建议并调整任何技术、协定、指导方针和活动，使得在不同的语言、脚本和文化范畴内更易在全球范围内使用 W3C 技术。

W3C 国际化活动

语音浏览器活动

W3C 的语音浏览器活动的工作是使人们可以通过口语指令和语音合成进行交互，以扩展 Web（的使用范畴）。

语音可扩展标记语言 （VoiceXML）

语音合成标记语言 （VoiceXML）

语音识别语法规范

语音浏览器呼叫控制 （CCXML）

W3C 参考

W3C 主页

  • Previous Page
  • Next Page


万维网联盟（W3C） 教程

万维网联盟

  • W3C 首页
  • W3C 简介
  • W3C 程序
  • W3C HTML
  • W3C XHTML
  • W3C XML
  • W3C CSS
  • W3C XSL
  • W3C XML Schema
  • W3C XPath
  • W3C XQuery
  • W3C DOM
  • W3C SOAP
  • W3C WSDL
  • W3C RDF
  • W3C SMIL
  • W3C 其他

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

万维网联盟（W3C） 教程

  • Next Page

当您将我们的《W3C 教程》学习完毕，您会对 W3C 有一个全面的了解。

您将了解到万维网联盟，以及 WEB 是如何被标准化的。

内容目录

W3C 简介
本节内容：W3C 是什么组织，它如何运作，网络是如何被标准化的。
W3C 程序
本节内容：W3C 的标准化过程。
W3C HTML
本节内容：简要介绍 W3C 的 HTML。
W3C XHTML
本节总结了 W3C 的 XHTML 活动。
W3C XML
本节总结了 W3C 的 XML 活动。
W3C CSS
本节总结了 W3C 的 CSS 活动。
W3C XSL
本节总结了 W3C 的 XSL 活动。
W3C XML Schema
本节总结了 W3C 的 XML Schema 活动。
W3C XPath
本节总结了 W3C 的 XPath 活动。
W3C XQuery
本节总结了 W3C 的 XQuery 活动。
W3C DOM
本节总结了 W3C 的 DOM 活动。
W3C SOAP
本节总结了 W3C 的 SOAP 活动。
W3C WSDL
本节总结了 W3C 的 WSDL 活动。
W3C RDF
本节总结了 W3C 的 RDF 活动。
W3C SMIL
本节总结了 W3C 的 SMIL 活动。
W3C Other
本节总结了 W3C 的其他活动。
  • Next Page


WAP Demo

W3School WAP 演示程序
WAP Demo 需要 Internet Explorer 5.0 或更高的版本！


WAP 基础

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WAP 基础

  • Previous Page
  • Next Page

WAP 主页

WAP 的主页与 HTML 的主页非常不同。用于 WAP 的标记语言是 WML (Wireless Markup Language)。WML 使用标签 - 类似 HTML - 但是语法更严格且遵守 XML 1.0 标准。

WML 页面的扩展名是 *.WML，就像 HTML 页面的扩展名是 *.HTML 一样。

WML 标签

WML 几乎都是关于文本的。会拖慢手持设备之间通信的标签不会成为 WML 标志的组成部分。表格和图像的使用被严格限制。

由于 WML 是一种 XML 应用，因此其标签对大小写敏感（<wml> 与 <WML> 不同），且标签必须正确关闭。

WML Deck 和 Card

WML 页面叫作 DECK（卡片组）。DECK 是由一系列 CARD （卡片）构造的，卡片之间通过链接彼此联系。当从移动电话访问一张 WML 页面时，页面中的所有卡片都会从 WAP 服务器下载下来。卡片之间的导航是通过电话的计算机完成的 - 在电话内部 - 不需要对服务器的额外访问。

WML 文档实例：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>

<card id="HTML" title="HTML Tutorial">
<p>
Our HTML Tutorial is an award winning
tutorial from W3School.
</p>
</card>

<card id="XML" title="XML Tutorial">
<p>
Our XML Tutorial is an award winning
tutorial from W3School.
</p>
</card>

</wml>

正如您从例子中看到的，WML 文档是一种 XML 文档。DOCTYPE 定义为 wml，并在 www.wapforum.org/DTD/wml_1.1.xml 访问 DTD。

文档内容位于 <wml>...</wml> 标签内。文档中的每个 card 位于 <card>...</card> 标签内，实际的段落在 <p>...</p> 标签中。每个 card 元素都有一个 id 以及一个 title。

  • Previous Page
  • Next Page

WML 参考手册
WAP 演示


WAP 简介

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WAP 简介

  • Previous Page
  • Next Page

WAP 协议被设计用来在无线客户端（比如移动电话）上展示因特网内容。

您应当具备的基础知识

在继续学习之前，您需要对下面的知识有基本的了解：

  • WWW, HTML 以及有关网页构建的基础知识
  • JavaScript
  • XML

如果您希望首先学习这些项目，请在我们的首页访问这些教程。

什么是 WAP？

无线产品提出了 WAP 的理念。此标准的要点是在无线设备上展示因特网内容。

  • WAP 指无线应用协议
  • WAP 是一种应用程序通信协议
  • WAP 被用来访问服务及信息
  • WAP 继承于因特网标准
  • WAP 针对诸如移动电话的手持设备
  • WAP 是一种为微浏览器设计的协议
  • WAP 使创建针对移动设备的 web 应用程序成为可能
  • WAP 使用标记语言 WML（不是 HTML）
  • WAP 作为 XML 1.0 的一种应用被定义

无线应用协议（Wireless Application Protocol）

WAP 是一种用于在无线终端（比如数字移动电话）进行信息服务的主要的标准。

WAP 标准基于因特网标准（HTML、XML 以及 TCP/IP）。它包括 WML 语言规范、WMLScript 规范以及无线电话应用接口规范（WTAI）。

WAP 由 WAP 论坛（WAP forum ）发布，被爱立信、摩托罗拉、诺基亚以及 Unwired Planet 创建于 1997 年。论坛的成员目前占据着超过 90% 的全球手机市场，同时又是领先的基础设施提供商、软件提供商及其他机构。您可以在我们的 WAP 论坛页面找到有关 WAP 论坛的更多信息。

WAP 微浏览器

为了适合小型无线终端，WAP使用了一种微浏览器。

微浏览器是一种小型软件，可向硬件、内存和 CPU 发布基本的指令。它可以显示用一种由被称为 WML 的受限标记语言编写的信息。

微浏览器也可翻译一种被称为 WMLScript 的 JavaScript 简化版。

什么是 WML？

WML 指无线标记语言。它是一种从 HTML 继承而来的标记语言，但是 WML 基于 XML，因此它较 HTML 更严格。

WML 被用来创建可显示在 WAP 浏览器中的页面。用WML编写的页面被称为 DECKS。DECKS 是作为一套 CARDS 被构造的。

什么是 WMLScript？

WML 使用 WMLScript 在客户端运行简单的代码。WMLScript 是一种轻量级的 JavaScript 语言。不过，WML 脚本并不嵌在 WML 页面中。WML页面仅仅含有对脚本 URL 的引用。WML 脚本在 WAP 浏览器运行之前，需要先在服务器上被编译为字节编码。

请访问我们的 WMLScript 教程，以学习更多有关 WML 文档中的脚本的知识。

WAP 应用举例

  • 查看列车时刻表信息
  • 票务交易
  • 航班登记
  • 查看交通信息
  • 查寻股票价格
  • 查寻电话号码
  • 查寻地址
  • 查寻体育竞赛结果

有关 WAP 的 FAQ

这些是被频繁问及的有关 WAP 的问题：

  • 什么是 WAP？
  • WAP 针对什么人群？
  • WAP 和标准化团体的关系？
  • WAP 与因特网标准的关系？
  • WAP 目前的状态如何？
  • WAP 的未来会怎样？

我们会尽力回答这些问题。同时，请在此阅读相关的解答：

http://www.wapforum.org/faqs/index.htm。

  • Previous Page
  • Next Page

WML 参考手册
WAP 演示


WAP 教程

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WAP 教程

  • Next Page

WAP 协议被设计为用来在诸如移动电话之类的无线客户端上展示因特网内容。

WML 是用来创建供 WAP 浏览器显示的页面的语言。

在我们的 WAP 教程，你将学习关于 WAP 和 WML 的知识。

你将学习如何将网页转换为袖珍的格式（pocket format），这样你的信息就可以被诸如移动电话之类的无线客户端访问到。

开始学习WAP / WML！

WML 参考手册

在 W3School 我们提供完整的 WML 参考手册，包括元素、属性、实体等等。

WML 参考手册

  • Next Page

WML 参考手册
WAP 演示


WAP 论坛 / 开放移动联盟

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WAP 论坛 / 开放移动联盟

  • Previous Page
  • Next Page

WAP 论坛 (WAP Forum)

无线应用协议 (WAP) 论坛为数字移动电话和其他无线终端开发了事实上的全球标准。 WAP 论坛发布了开放的全球无线协议规范，此规范基于已有的因特网标准，比如 XML 和 IP。

这个 WAP 论坛已经被统一在开放移动联盟 (OMA) 中，不再以独立组织的形式存在。

WAP 的规范化工作在 OMA 中得到了延续，在此处访问相关信息：

http://www.openmobilealliance.org/tech/affiliates/wap/wapindex.html

OMA (Open Mobile Alliance：开放移动联盟)

开发移动联盟是领导性的产业论坛，旨在发展市场驱动的、可共用的移动服务。

OMA 在 2002 年 6 月成立时，有接近 200 个公司参与，包括处于世界领导地位的移动操作系统、设备和网络提供商、信息技术公司以及内容和服务提供商。

"开放移动联盟" 这个新组织的是在 "开放移动平台"组织 （Open Mobile Architecture initiative）和 WAP 论坛的基础上形成的新国际化组织。

这个国际新组织旨在推动全球实现开放的标准，确保互用性，推动全球移动服务市场发展，召示了一个全球共享的平台即将为国际移动互联产业的发展提供更广阔的舞台。

"开放移动联盟"为移动通信业界提供开放的标准，创建满足市场及客户需要，跨国家、跨运营商和跨移动终端设备的互用性的服务。为了发展移动通信市场，支持"开放移动联盟"的公司将共同努力，推出一系列新颖、功能强劲的移动信息、通信和娱乐服务及应用系统。

可以在此处阅读更多有关 OMA 的信息:

http://www.openmobilealliance.org/about_OMA/index.html

OMA 会员

爱立信、IBM、英特尔、微软、摩托罗拉、NEC、诺基亚、NTT DoCoMo、Philips及三星等300以上的公司为其会员。设有15个工作组和2个委员会，正在制定许多规格。与ITU-T、W3C等国际标准化组织有密切合作关系。

如需完整的 OMA 会员列表，请访问：

http://member.openmobilealliance.org/Common_display/currentmembers.asp

  • Previous Page
  • Next Page

WML 参考手册
WAP 演示


WAP 软件

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WAP 软件

  • Previous Page
  • Next Page

WAP 公司

Symbian

Symbian 于 1998 年 6 月作为一家私有的独立公司成立，并被下列公司共同拥有：爱立信、诺基亚、松下、摩托罗拉、Psion、西门子以及索尼爱立信。

Symbian 提供先进的开放标准操作系统 - Symbian OS - 针对允许数据传送 (data-enabled) 的移动电话。

MobileDev - 无线应用开发 (Wireless Application Development)

MobileDev

有关无线应用开发的补充材料：

MobileDev is the first Wireless Development Environment (WDE) specifically for WAP Internet applications. Its innovative open-ended development model integrates a graphical application mapper with a wizard interface and a rich tool set. MobileDev supports WAP technologies like WML, HDML, Microsoft Active Server Pages (ASP), Perl and Java Server Pages (JSP).

Using the GUI application mapper to show the relationships between objects, developers can quickly outline the components of a WAP application. Then they can take advantage of wizards that generate Decks and Cards in both WML and HDML, and use MobileDev's code builder to write WML/HDML syntax that complements the wizard-generated code. The integration of the application mapper with wizards and the code builder provides a seamless WDE that delivers results fast.

MobileDev comes complete with its own powerful integrated runtime engine, MobileDev Server Script. Server Script can quickly create prototypes or build full-blown business WAP applications that can be natively connected to an RDBMS. MobileDev WDE is also designed to support development in ASP, JSP, Perl or other template-based server technologies.

  • Previous Page
  • Next Page

WML 参考手册
WAP 演示


WAP 演示

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WAP 演示

  • Previous Page
  • Next Page

请单击左侧的移动电话，启动演示程序！

注释：这个 WAP 演示程序需要 Internet Explorer 5.0 或更高的版本！

编译 WML 代码

如需测试并编译您的WML代码，可以下载免费的诺基亚移动互联网工具包。此工具包支持完整的 WAP 2.0 规范，包括 XHTML 和 CSS。

假如您在 IIS 或 Apache 服务器放置了WML 代码，那么您无需对代码进行编译。WAP网关会完成这项工作。您需要做的仅仅是把原始的WML代码放到您的服务器上。

  • Previous Page
  • Next Page

WML 参考手册
WAP 演示


WML <!--...--> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <!--...--> 标签

返回 WML 参考手册

定义和用法

注释标签用于在 WML 源代码中插入注释。注释将被浏览器忽略。你可以使用注释来解释你的代码，这有助于日后你对源代码的编辑。

代码：

<!--This text is a comment-->
<p>This is a regular paragraph</p>

输出：

This is a regular paragraph

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <a> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <a> 标签

返回 WML 参考手册

定义和用法

<a> 标签定义一个锚（链接），它允许您从一个卡片/卡片组跳转到另一个。

注释：在任何可能的情况下，请使用 <a> 标签代替 <anchor> 标签。

注释：不允许对锚进行嵌套。

语法

<a href="somefile">
..text..
..image..
</a>

属性

属性 | 值 | 描述
href | url | 必需。定义当用户选择链接时跳转到何处。
title | cdata | 定义标识链接的文本。
xml:lang | language_code | 设置元素中使用的语言。
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="A Tag">
<p>
 <a href="test.wml">Next page</a>
</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <access> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <access> 标签

返回 WML 参考手册

定义和用法

<access> 标签定义关于 WML 卡片组的访问控制的信息。

注释：如果 <access> 标签没有设置，任何其他 deck/card 都能够访问此 deck。

注释：<access> 标签永远位于 <head> 标签内部。每个 deck 只能有一个 <access> 标签。

语法

<head>
<access/>
</head>

属性

属性 | 值 | 描述
domain | cdata | 能够访问此 deck 中 card 的其他 deck 的 URL。
path | cdata | 能够访问此 deck 中 card 的其他 deck 的 URL。
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

访问被限制于 www.w3school.com.cn 中的其他 deck/card：

<head>
 <access domain="www.w3school.com.cn"/>
</head>

访问被限制于 www.w3school.com.cn/wap 中的其他 deck/card：

<head>
 <access domain="www.w3School.com.cn" path="/wap"/>
</head>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <anchor> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <anchor> 标签

返回 WML 参考手册

定义和用法

<anchor> 标签定义一个锚（链接），它允许您从一个卡片/卡片组跳转到另一个。<anchor> 标签总是拥有指定的任务（"go"、"prev"、"refresh"）。任务定义了用户选择该链接时所完成的任务。

注释：在任何可能的情况下，请使用 <a> 标签代替 <anchor> 标签。

注释：不允许对锚进行嵌套。

语法

<anchor>
..text..
..image..
..task..
</anchor>

属性

属性 | 值 | 描述
title | cdata | 定义标识链接的文本。
xml:lang | language_code | 设置元素中使用的语言。
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="Anchor Tag">
<p>
 <anchor>Next page
  <go href="test.wml"/>
 </anchor>
</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <br> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <br> 标签

返回 WML 参考手册

定义和用法

<br> 标签定义一个换行。

注释：WML 文档必须含有一个 XML 声明和一个 DTD。

语法

<br/>

属性

属性 | 值 | 描述
xml:lang | language_code | 设置元素中使用的语言。
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="Line Breaks">
<p>
This is a paragraph<br/>with a line break
</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <card> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <card> 标签

返回 WML 参考手册

定义和用法

一个 WML 卡片组包含一个或多个卡片。<card> 标签定义一个卡片。卡片 (card) 能包含文本、标记、链接、输入字段、任务、图像等等。

注释：card 元素的 "id" 属性可用作锚 (anchor)。

语法

<card>
..text..
..links..
..images..
</card>

属性

属性 | 值 | 描述
newcontext
  • true
  • false
 重新初始化浏览器环境。默认是 "false"。
ordered
  • true
  • false
 规定卡片内容的属性。当 ordered 设置为 "true" 时，浏览器将按照固定属性显示内容。当 ordered 设置为 "false" 时，用户可决定顺序。默认是 "true"。
title | cdata | 卡片的标题。
xml:lang | language_code | 设置元素中使用的语言。
onenterbackward | url | 当用户通过使用 "prev" 任务导航到一个卡片中时出现。
onenterforward | url | 当用户通过使用 "go" 任务导航到一个卡片中时出现。
ontimer | url | 当计时器终止时出现。
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card id="no1" title="Card 1">
<p>Hello World!</p>
</card>

<card id="no2" title="Card 2">
<p>Welcome to our WAP Tutorial!</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <do> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <do> 标签

返回 WML 参考手册

定义和用法

<do> 标签可用于在用户点击屏幕上的一个单词或短语时激活一个任务。

<do> 标签也可以嵌套在 <template> 标签内，这样 <do> 标签就可以应用到 deck 中的所有卡片。

语法

<do type="type">
..task..
</do>

属性

属性 | 值 | 描述
type
  • accept
  • prev
  • help
  • reset
  • options
  • delete
  • unknown
  • x-*
  • vnd.*
 必需。定义 "do" 元素的类型。
label | cdata | 为 "do" 元素创建 label。
name | nmtoken | 为 "do" 元素定义名称。
optional
  • true
  • false
 如果该属性设置为 true，则浏览器忽略该元素，如果设置为 false，则浏览器不会忽略该元素。默认是 "false"。
xml:lang | language_code | 设置元素中使用的语言。
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

下面的例子在一个 <template> 标签中使用了一个 <do> 标签，来向每个卡片添加一个 "Back" 链接：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<template>
 <do name="back" type="prev" label="Back">
  <prev/>
 </do>
</template>

<card id="card1" title="Card 1">
<p>
 Hello World!
</p>
</card>

<card id="card2" title="Card 2">
<p>
 From W3School!
</p>
</card>
</wml>

注释：

如果单个 <card> 包含多个类型为 "accept" 的 <do> 元素，且这些 <do> 元素没有被命名，WML 会出现编译错误，而且不会显示出页面。

引起这种情况的原因是，如果没有规定名称，那么默认的名称是元素的类型（accept）。

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <fieldset> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <fieldset> 标签

返回 WML 参考手册

定义和用法

<fieldset> 标签用于对卡片中的相关元素进行分组。

语法

<fieldset>
..the items to group together..
</fieldset>

属性

属性 | 值 | 描述
title | cdata | 为 fieldset 设置标题
xml:lang | language_code | 设置元素中使用的语言
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="Fieldset">
<p>
 <fieldset title="CD Info">
  Title: <input name="title" type="text"/><br/>
  Prize: <input name="price" type="text"/>
 </fieldset>
</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <go> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <go> 标签

返回 WML 参考手册

定义和用法

<go> 任务表示跳转到新卡片的动作。在 href 属性中规定跳转的目的地。

注释：<go> 标签的内容是可选的。

注释：<go> 标签可包含 <postfield> 或 <setvar> 标签。

语法

<go href="someurl">
..<postfield>..
..<setvar>..
</go>

属性

属性 | 值 | 描述
href | url | 必需。新卡片的 URL。
accept-charset | charset_list | 服务器能够处理的字符编码列表，用逗号或空格分隔。默认值是 "unknown"。
method
  • post
  • get
 设置如何向服务器发送数据。默认方法是 get。
sendreferer
  • true
  • false
 默认是 "false"。
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card>
<p>
 <anchor>
  Go To Card 2
  <go href="#card2">
   <setvar name="x" value="30"/>
  </go>
 </anchor>
</p>
</card>
</wml>

没有内容的 <go> 标签：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card>
<p>
 <anchor>
 Go To Test
  <go href="test.wml"/>
 </anchor>
</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <head> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <head> 标签

返回 WML 参考手册

定义和用法

<head> 标签包含关于文档的信息。

注释：下列标签可位于 head 元素中：<access> 和 <meta>。

语法

<head>
..<access>..
..<meta>..
</head>

属性

属性 | 值 | 描述
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<head>
   <access domain="www.w3school.com.cn"/>
   <meta name="keyword" content="WAP"/>
</head>

....
....
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <img> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <img> 标签

返回 WML 参考手册

定义和用法

<img> 标签定义图像。

注释：图像的格式必须是 .wbmp。

语法

<img src="somefile.wbmp" alt="sometext"/>

属性

属性 | 值 | 描述
align
  • top
  • middle
  • bottom
 对齐图像。默认是 "bottom"。
alt | cdata | 必需。设置图像无法显示时的替代文本。
height
  • px
  • %
 设置图像的高度。如果以像素规定这个值，语法是 "120"，而不是 "120px"。
hspace
  • px
  • %
 设置图像左边和右边的空白。如果以像素规定这个值，语法是 "10"，而不是 "10px"。默认是 "0"。
localsrc | cdata | 为图像设置一个代替的表现。如何设置了该属性，则浏览器使用该属性，而不是 "src"。
src | url | 必需。图像的路径。必须是 .wbmp 文件。
vspace
  • px
  • %
 设置图像上面和下面的空白。如果以像素规定这个值，语法是 "10"，而不是 "10px"。默认是 "0"。
width
  • px
  • %
 设置图像的宽度。如果以像素规定这个值，语法是 "120"，而不是 "120px"。
title | cdata | 定义标识链接的文本。
xml:lang | language_code | 设置元素中使用的语言。
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="Image">
<p>
 An image:
 <img src="stickman.wbmp" alt="Stickman"/>
</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <input> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <input> 标签

返回 WML 参考手册

定义和用法

<input> 标签定义输入字段（用户可在其中输入文本的文本域）。

语法

<input name="somename"/>

属性

属性 | 值 | 描述
name | nmtoken | 必需。变量的名称，其值是用户输入的结果。
emptyok
  • true
  • false
 设置用户是否可以不填写输入字段。默认是 "false"。
format
  • A
  • a
  • N
  • X
  • x
  • M
  • m
  • *f
  • nf

设置输入字段的数据格式。默认是 "*M"。

  • A = 大写字母或标点符号
  • a = 小写字母或标点符号
  • N = 数字
  • X = 大写字符
  • x = 小写字符
  • M = 所有字符
  • m = 所有字符
  • *f = 任何数量的字符。用上面的字母替代 f，可以规定用户可输入的字符类型。
  • nf = 用数字 1 - 9 代替 n，可以规定用户可输入的字符数目。用上面的字母替代 f，可以规定用户可输入的字符类型
maxlength | number | 设置用户可以在字段中输入的最大字符数。
size | number_of_char | 设置输入字段的宽度。
tabindex | number | 为输入字段设置 tab 位置。
title | cdata | 为输入字段设置标题。
type | text password | 指示输入字段的类型。默认值是 "text"。
value | cdata | 设置 "name" 属性中变量的默认值。
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="Input">
<p>
 Name: <input name="name" size="15"/><br/>
 Age:  <input name="age" size="15" format="*N"/><br/>
 Sex:  <input name="sex" size="15"/>
</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <meta> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <meta> 标签

返回 WML 参考手册

定义和用法

<meta> 标签提供关于 WML 文档的元信息 (meta-information)。

注释：<meta> 标签永远位于 head 元素内。

语法

<head>
<meta/>
</head>

属性

属性 | 值 | 描述
content | cdata | 规定 name 属性的描述。
forua
  • true
  • false
 规定是否把元数据传送到浏览器。如果设置为 true，元数据必须送到浏览器。
http-equiv | cdata | 设置 <meta> 标签的内容是否捆绑到一个 HTPP 响应头。
name | cdata | 为你需要在页面上描述的事物规定一个名称。可以是 "keywords"、"author" 等等。
scheme | cdata | 规定用于翻译元数据的结构。
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<head>
 <meta name="keyword" content="WAP"/>
 <meta http-equiv="cache-control" content="no-cache"/>
</head>
....
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <noop> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <noop> 标签

返回 WML 参考手册

定义和用法

<noop> 任务表示不进行任何动作（noop 指的是 "no operation"）。此标签用于防止事件的发生。

注释：<noop> 可以位于 <do> 或 <onevent> 标签内。

语法

<noop/>

属性

属性 | 值 | 描述
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

下面的例子使用 <do> 标签向卡片添加一个 "Back" 链接。当用户点击这个 "Back" 链接时，会跳转到前一个卡片。但是 <noop> 标签会阻止此操作；当点击 "Back" 链接时什么也不会发生：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card>
<p>
 <do type="prev" label="Back">
  <noop/>
 </do>
</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <onevent> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <onevent> 标签

返回 WML 参考手册

定义和用法

<onevent> 标签包含了当下列事件发生时所执行的代码：onenterbackward、onenterforward、onpick、ontimer。

语法

<onevent type="type">
..code..
</onevent>

属性

属性 | 值 | 描述
type
  • onenterbackward
  • onenterforward
  • onpick
  • ontimer

必需。规定 "onevent" 元素的类型。

  • onenterbackward - 当 <prev> 跳转到前一个卡片时触发
  • onenteredforward - 当 <go> 跳转到某一个卡片时触发
  • onpick - 当项目被选取或撤销选取时触发
  • ontimer - 当计时器终止时触发
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

下面的例子使用 <onevent> 标签在 onenterbackward 事件发生时导航到 card1：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<template>
 <onevent type="onenterbackward">
  <go href="#card1"/>
 </onevent>
</template>

<card id="card1" title="Card 1">
<p>
 Hello World!
</p>
</card>

<card id="card2" title="Card 2">
<p>
 From W3School!
</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <optgroup> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <optgroup> 标签

返回 WML 参考手册

定义和用法

<optgroup> 标签定义可选列表中的一组选项。

注释：<optgroup> 标签必须位于 select 元素中。

语法

<select>
 <optgroup>
  <option>text</option>
  <option>text</option>
 </optgroup>
  <optgroup>
  <option>text</option>
  <option>text</option>
 </optgroup>
</select>

属性

属性 | 值 | 描述
title | cdata | 为 optgroup 元素设置标题。
xml:lang | language_code | 设置元素中使用的语言。
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="Selectable List">
<p>
 <select>
   <optgroup title="HTML Tutorials">
    <option value="html">HTML Tutorial</option>
    <option value="css">CSS Tutorial</option>
    <option value="dhtml">XHTML Tutorial</option>
   </optgroup>
   <optgroup title="XML Tutorials">
    <option value="xml">XML Tutorial</option>
    <option value="xsl">XSL Tutorial</option>
    <option value="xforms">XForms Tutorial</option>
   </optgroup>
 </select>
</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <option> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <option> 标签

返回 WML 参考手册

定义和用法

<option> 标签定义可选列表中的选项。

通过 <select> 标签来创建可选列表。

语法

<option>
 ..text
 ..<img>
 ..<onevent>
</option>

属性

属性 | 值 | 描述
onpick | url | 设置当用户选择项目时发生的事情。
title | cdata | 为选项设置标题。
value | cdata | 如果在 select 元素中设置了 "name" 变量，则该属性设置所用的值。
xml:lang | language_code | 设置元素中使用的语言。
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="Selectable List">
<p>
 <select>
  <option value="htm">HTML Tutorial</option>
  <option value="xml">XML Tutorial</option>
  <option value="wap">WAP Tutorial</option>
 </select>
</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <p> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <p> 标签

返回 WML 参考手册

定义和用法

<p> 标签定义一个段落。

语法

<p>
..text..
..images..
..links..
</p>

属性

属性 | 值 | 描述
align
  • left
  • right
  • center
 对齐段落。默认是 left。
mode
  • wrap
  • nowrap
 设置段落是否换行。
xml:lang | language_code | 设置元素中使用的语言。
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="Paragraph">
<p>
This is a paragraph
</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <postfield> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <postfield> 标签

返回 WML 参考手册

定义和用法

<postfield> 标签包含了连同 <go> 标签被送往服务器的信息。

语法

<postfield name="somename" value="somevalue"/>

属性

属性 | 值 | 描述
name | cdata | 必需。字段的名称。
value | cdata | 必需。字段的值。
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card>
<p>
 Click OK to Send
 <do type="accept">
  <go href="test.wml" method="post">
   <postfield name="i" value="2"/>
   <postfield name="j" value="30"/>
  </go>
 </do>
</p>
</card>
</wml>

<postfield> 标签也可以与 get 方法一起使用。注释：如果使用该方法，字段以及它们的值会添加到 URL 的末尾：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card>
<p>
 Click OK to Send
 <do type="accept">
  <go href="test.wml" method="get">
   <postfield name="i" value="2"/>
   <postfield name="j" value="30"/>
  </go>
 </do>
</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <prev> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <prev> 标签

返回 WML 参考手册

定义和用法

<prev> 任务表示返回前一个访问过的卡片。如果不存在前一个卡片，规定 不会有任何效果。

注释：<prev>..</prev> 标签之间的内容是可选的。如果未规定任何内容，则必须使用 <prev/>。

语法

<prev>
..<setvar>..
</prev>

属性

属性 | 值 | 描述
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card>
<p>
 <do type="accept" label="Back">
  <prev>
   <setvar name="x" value="30"/>
  </prev>
 </do>
</p>
</card>
</wml>

没有内容的 <prev> 标签：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card>
<do type="accept" label="Back">
 <prev/>
</do>
<p>
Hello World!
</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <refresh> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <refresh> 标签

返回 WML 参考手册

定义和用法

<refresh> 任务刷新指定的卡片变量。如果有变量显示在屏幕上，此任务也会刷新屏幕。

注释：<refresh> 标签可嵌套在 <anchor>, <do> 或 <onevent> 标签内。

语法

<refresh>
..<setvar>..
</refresh>

属性

属性 | 值 | 描述
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

下面的例子使用 <anchor> 标签向卡片添加 "Refresh this page" 链接。当用户点击该链接时，会刷新此页面，变量 x 的值会设置为 30：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card>
<p>
 <anchor>
  Refresh this page
  <go href="thispage.wml"/>
  <refresh>
   <setvar name="x" value="30"/>
  </refresh>
 </anchor>
</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <select> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <select> 标签

返回 WML 参考手册

定义和用法

<select> 标签定义可选列表。

注释：<option> 标签用于定义可选列表中的选项。

语法

<select>
 <option>text</option>
 <option>text</option>
</select>

属性

属性 | 值 | 描述
iname | nmtoken | 命名变量，该变量通过选择的 index 结果进行设置。
ivalue | cdata | 设置预选的 option 元素。
multiple
  • true
  • false
 设置是否可进行多选。默认是 "false"。
name | nmtoken | 命名变量，该变量通过选择的结果进行设置。
tabindex | number | 设置 tab 位置。
title | cdata | 为列表设置标题。
value | cdata | 设置 "name" 属性中的变量的初始值。
xml:lang | language_code | 设置元素中使用的语言。
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="Selectable List">
<p>
 <select>
  <option value="htm">HTML Tutorial</option>
  <option value="xml">XML Tutorial</option>
  <option value="wap">WAP Tutorial</option>
 </select>
</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <setvar> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <setvar> 标签

返回 WML 参考手册

定义和用法

<setvar> 标签在 <go>、<prev> 或 <refresh> 任务中把变量设置为指定的值。

语法

<setvar name="somename" value="somevalue"/>

属性

属性 | 值 | 描述
name | cdata | 必需。设置变量的名称。
value | cdata | 必需。设置变量的值。
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card>
<p>
 <anchor>
  Go To Card 2
  <go href="#card2">
   <setvar name="x" value="30"/>
  </go>
 </anchor>
</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <table> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <table> 标签

返回 WML 参考手册

定义和用法

table 标签定义表格。

注释：<table> 标签与 <tr> 和 <td> 一起使用，来创建创建表格。

注释：number 属性是必需的。值 0 不允许使用。

注释：WML 表格没有边框。

语法

<table columns="a number">
..<tr>..
..<td>..
</table>

属性

属性 | 值 | 描述
columns | number | 必需。设置表格中的列数。
align
  • c
  • l
  • r
 对齐列中的文本。规定一系列的对齐值，每个对应一列。
title | cdata | 设置表格的标题。
xml:lang | language_code | 设置元素中使用的语言。
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="Table">
<p>
 <table columns="3">
  <tr>
   <td>Cell 1</td>
   <td>Cell 2</td>
   <td>Cell 3</td>
  </tr>
 </table>
</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <td> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <td> 标签

返回 WML 参考手册

定义和用法

<td> 标签定义一个表格单元。

注释：此元素必须位于 tr 元素中。

语法

<tr>
<td>..content..</td>
</tr>

属性

属性 | 值 | 描述
xml:lang | language_code | 设置元素中使用的语言。
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="Table">
<p>
 <table columns="3">
  <tr>
   <td>Cell 1</td>
   <td>Cell 2</td>
   <td>Cell 3</td>
  </tr>
 </table>
</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <template> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <template> 标签

返回 WML 参考手册

定义和用法

<template> 标签为 deck 中的所有 card 定义一个模板。<template> 标签中的“代码”会添加到 deck 中的每个卡片。

注释：只能为每个 deck 规定一个 <template> 标签。

注释：此标签只能包含 <do> 和 <onevent> 标签。

语法

<template>
..<do>..
..<onevent>..
</template>

属性

属性 | 值 | 描述
onenterbackward | url | 当用户通过使用 "prev" 任务导航到一个卡片中时出现。
onenterforward | url | 当用户通过使用 "go" 任务导航到一个卡片中时出现。
ontimer | url | 当计时器终止时出现。
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

本例使用一个 <do> 标签向每个卡片添加一个 "back" 链接：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<template>
 <do type="prev" label="Back">
  <prev/>
 </do>
</template>

<card id="card1" title="Card 1">
<p>
 <a href="#card2">Go to Card 2</a>
</p>
</card>

<card id="card2" title="Card 2">
<p>
 <a href="#card3">Go to Card 3</a>
</p>
</card>

<card id="card3" title="Card 3">
<p>
 Hello World!
</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <timer> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <timer> 标签

返回 WML 参考手册

定义和用法

<timer> 标签定义卡片计时器。当进入卡片时，该技术其启动，在推出卡片时，计时器停止。

注释：每张卡片不允许一个以上的 timer 元素。

注释：计时器的事件单位是一秒的十分之一。

注释：此标签可与 <card>、<onevent> 以及 <template> 一起使用。

语法

<timer value="somevalue"/>

属性

属性 | 值 | 描述
value | cdata | 必需。设置定义于 "name" 属性的变量的默认值。
name | nmtoken | 对变量进行命名，该变量通过计时器的值进行设置。
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

下面的例子将把 "Hello World!" 显示 3 秒钟，然后跳转到 "test.wml"：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card ontimer="test.wml">
<timer value="30"/>
 <p>Hello World!</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <tr> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <tr> 标签

返回 WML 参考手册

定义和用法

<tr> 标签定义一个表格行。

注释：此元素必须位于 table 元素中。

语法

<table columns="number">
<tr>
<td>..</td>
</tr>
</table>

属性

属性 | 值 | 描述
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="Table">
<p>
 <table columns="3">
  <tr>
   <td>Cell 1</td>
   <td>Cell 2</td>
   <td>Cell 3</td>
  </tr>
 </table>
</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <tr> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <tr> 标签

返回 WML 参考手册

定义和用法

下面的标签可以影响文本的格式：

<b> | 定义粗体的文本。
<big> | 定义大号的文本。
<em> | 定义着重文本。
<i> | 定义斜体的文本。
<small> | 定义小号的文本。
<strong> | 定义强调文本。
<u> | 定义下划线文本。

属性

属性 | 值 | 描述
xml:lang | language_code | 设置元素中使用的语言。
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="Formatting">
<p>
 <em>emphasized text</em><br/>
 <strong>strong text</strong><br/>
 <b>bold text</b><br/>
 <i>italic text</i><br/>
 <u>underlined text</u><br/>
 <big>big text</big><br/>
 <small>small text</small>
</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML <wml> 标签

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML <wml> 标签

返回 WML 参考手册

定义和用法

<wml> 标签定义一个 WML 卡片组 (deck)。此标签包含卡片和有关 WML 文档的信息。

注释：WML 文档必须含有一个 XML 声明和一个 DTD。

语法

<wml>
..text..
..tables..
..links..
..tasks..
..other elements..
</wml>

属性

属性 | 值 | 描述
xml:lang | language_code | 设置元素中使用的语言。
class | cdata | 为此元素设置的 class 名。这个 class 名对大小写敏感。一个元素可链接多个 class。claas 属性中的多个 class 名通过空格进行分隔。
id | id | 为此元素设置的唯一名称。

实例

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card id="no1" title="Card 1">
<p>Hello World!</p>
</card>
</wml>

返回 WML 参考手册

WML 参考手册
WAP 演示


WML DTD

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML DTD

  • Previous Page
  • Next Page

完整的 WML DTD：

<!--
Wireless Markup Language (WML) Document Type Definition.

Copyright Wireless Application Protocol
Forum Ltd., 1998,1999.
                      All rights reserved.

WML is an XML language.  Typical usage:
   <?xml version="1.0"?>
   <!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
          "http://www.wapforum.org/DTD/wml_1.1.xml">
   <wml>
   ...
   </wml>

Terms and conditions of use are
available from the Wireless
Application Protocol Forum Ltd. web site at
http://www.wapforum.org/docs/copyright.htm.
-->

<!ENTITY % length  "CDATA">
  <!-- [0-9]+ for pixels or [0-9]+"%"
   for percentage length -->
<!ENTITY % vdata   "CDATA">
  <!-- attribute value possibly containing
   variable references -->
<!ENTITY % HREF    "%vdata;">
  <!-- URI, URL or URN designating a
   hypertext node. May contain variable references -->
<!ENTITY % boolean	"(true|false)">
<!ENTITY % number  "NMTOKEN">
  <!-- a number, with format [0-9]+ -->
<!ENTITY % coreattrs  "id    ID     #IMPLIED
                       class CDATA  #IMPLIED">

<!ENTITY % emph
 "em | strong | b | i | u | big | small">
<!ENTITY % layout  "br">

<!ENTITY % text     "#PCDATA | %emph;">

<!-- flow covers "card-level" elements,
 such as text and images -->
<!ENTITY % flow
 "%text; | %layout; | img | anchor | a | table">

<!-- Task types -->
<!ENTITY % task   "go | prev | noop | refresh">

<!-- Navigation and event elements -->
<!ENTITY % navelmts "do | onevent">

<!--============= Decks and Cards =============-->

<!ELEMENT wml ( head?, template?, card+ )>
<!ATTLIST wml
  xml:lang        NMTOKEN        #IMPLIED
  %coreattrs;
  >

<!-- card intrinsic events -->
<!ENTITY % cardev
 "onenterforward  %HREF;          #IMPLIED
  onenterbackward %HREF;          #IMPLIED
  ontimer         %HREF;          #IMPLIED"
  >

<!-- card field types -->
<!ENTITY % fields
 "%flow; | input | select | fieldset">

<!ELEMENT card (onevent*, timer?, (do | p)*)>
<!ATTLIST card
  title           %vdata;       #IMPLIED
  newcontext      %boolean;     "false"
  ordered         %boolean;     "true"
  xml:lang        NMTOKEN       #IMPLIED
  %cardev;
  %coreattrs;
  >

<!--============= Event Bindings =============-->

<!ELEMENT do (%task;)>
<!ATTLIST do
  type         CDATA       #REQUIRED
  label        %vdata;     #IMPLIED
  name         NMTOKEN     #IMPLIED
  optional     %boolean;   "false"
  xml:lang     NMTOKEN     #IMPLIED
  %coreattrs;
  >

<!ELEMENT onevent (%task;)>
<!ATTLIST onevent
  type         CDATA       #REQUIRED
  %coreattrs;
  >

<!--======== Deck-level declarations ========-->

<!ELEMENT head ( access | meta )+>
<!ATTLIST head
  %coreattrs;
  >

<!ELEMENT template (%navelmts;)*>
<!ATTLIST template
  %cardev;
  %coreattrs;
  >

<!ELEMENT access EMPTY>
<!ATTLIST access
  domain       CDATA       #IMPLIED
  path         CDATA       #IMPLIED
  %coreattrs;
  >

<!ELEMENT meta EMPTY>
<!ATTLIST meta
  http-equiv     CDATA      #IMPLIED
  name           CDATA      #IMPLIED
  forua          %boolean;  #IMPLIED
  content        CDATA      #REQUIRED
  scheme         CDATA      #IMPLIED
  %coreattrs;
  >

<!--================ Tasks ================-->

<!ELEMENT go (postfield | setvar)*>
<!ATTLIST go
  href            %HREF;           #REQUIRED
  sendreferer     %boolean;       "false"
  method          (post|get)      "get"
  accept-charset  CDATA           #IMPLIED
  %coreattrs;
  >

<!ELEMENT prev (setvar)*>
<!ATTLIST prev
  %coreattrs;
  >

<!ELEMENT refresh (setvar)*>
<!ATTLIST refresh
  %coreattrs;
  >

<!ELEMENT noop EMPTY>
<!ATTLIST noop
  %coreattrs;
  >

<!--============= postfield =============-->

<!ELEMENT postfield EMPTY>
<!ATTLIST postfield
  name         %vdata;           #REQUIRED
  value        %vdata;           #REQUIRED
  %coreattrs;
  >

<!--============= variables =============-->

<!ELEMENT setvar EMPTY>
<!ATTLIST setvar
  name         %vdata;           #REQUIRED
  value        %vdata;           #REQUIRED
  %coreattrs;
  >

<!--============= Card Fields =============-->

<!ELEMENT select (optgroup|option)+>
<!ATTLIST select
  title        %vdata;           #IMPLIED
  name         NMTOKEN           #IMPLIED
  value        %vdata;           #IMPLIED
  iname        NMTOKEN           #IMPLIED
  ivalue       %vdata;           #IMPLIED
  multiple     %boolean;         "false"
  tabindex     %number;          #IMPLIED
  xml:lang     NMTOKEN           #IMPLIED
  %coreattrs;
  >

<!ELEMENT optgroup (optgroup|option)+ >
<!ATTLIST optgroup
  title      %vdata;    #IMPLIED
  xml:lang   NMTOKEN    #IMPLIED
  %coreattrs;
  >

<!ELEMENT option (#PCDATA | onevent)*>
<!ATTLIST option
  value      %vdata;    #IMPLIED
  title      %vdata;    #IMPLIED
  onpick     %HREF;     #IMPLIED
  xml:lang   NMTOKEN    #IMPLIED
  %coreattrs;
  >

<!ELEMENT input EMPTY>
<!ATTLIST input
  name       NMTOKEN           #REQUIRED
  type       (text|password)   "text"
  value      %vdata;           #IMPLIED
  format     CDATA             #IMPLIED
  emptyok    %boolean;         "false"
  size       %number;          #IMPLIED
  maxlength  %number;          #IMPLIED
  tabindex   %number;          #IMPLIED
  title      %vdata;           #IMPLIED
  xml:lang   NMTOKEN           #IMPLIED
  %coreattrs;
  >

<!ELEMENT fieldset (%fields; | do)* >
<!ATTLIST fieldset
  title           %vdata;      #IMPLIED
  xml:lang        NMTOKEN      #IMPLIED
  %coreattrs;
  >

<!ELEMENT timer EMPTY>
<!ATTLIST timer
  name       NMTOKEN           #IMPLIED
  value      %vdata;           #REQUIRED
  %coreattrs;
  >

<!--============= Images =============-->

<!ENTITY % IAlign "(top|middle|bottom)" >

<!ELEMENT img EMPTY>
<!ATTLIST img
  alt        %vdata;      #REQUIRED
  src        %HREF;       #REQUIRED
  localsrc   %vdata;      #IMPLIED
  vspace     %length;     "0"
  hspace     %length;     "0"
  align      %IAlign;     "bottom"
  height     %length;     #IMPLIED
  width      %length;     #IMPLIED
  xml:lang   NMTOKEN      #IMPLIED
  %coreattrs;
  >

<!--============= Anchor =============-->

<!ELEMENT anchor
 ( #PCDATA | br | img | go | prev | refresh )*>
<!ATTLIST anchor
  title        %vdata;      #IMPLIED
  xml:lang     NMTOKEN      #IMPLIED
  %coreattrs;
  >

<!ELEMENT a ( #PCDATA | br | img )*>
<!ATTLIST a
  href         %HREF;       #REQUIRED
  title        %vdata;      #IMPLIED
  xml:lang     NMTOKEN      #IMPLIED
  %coreattrs;
  >

<!--============= Tables =============-->

<!ELEMENT table (tr)+>
<!ATTLIST table
  title       %vdata;    #IMPLIED
  align       CDATA      #IMPLIED
  columns     %number;   #REQUIRED
  xml:lang    NMTOKEN    #IMPLIED
  %coreattrs;
  >

<!ELEMENT tr (td)+>
<!ATTLIST tr
  %coreattrs;
  >

<!ELEMENT td
 ( %text; | %layout; | img | anchor | a )*>
<!ATTLIST td
  xml:lang        NMTOKEN       #IMPLIED
  %coreattrs;
  >

<!--== Text layout and line breaks ==-->

<!ELEMENT em     (%flow;)*>
<!ATTLIST em
  xml:lang        NMTOKEN       #IMPLIED
  %coreattrs;
  >

<!ELEMENT strong (%flow;)*>
<!ATTLIST strong
  xml:lang        NMTOKEN       #IMPLIED
  %coreattrs;
  >

<!ELEMENT b      (%flow;)*>
<!ATTLIST b
  xml:lang        NMTOKEN       #IMPLIED
  %coreattrs;
  >

<!ELEMENT i      (%flow;)*>
<!ATTLIST i
  xml:lang        NMTOKEN       #IMPLIED
  %coreattrs;
  >

<!ELEMENT u      (%flow;)*>
<!ATTLIST u
  xml:lang        NMTOKEN       #IMPLIED
  %coreattrs;
  >

<!ELEMENT big    (%flow;)*>
<!ATTLIST big
  xml:lang        NMTOKEN       #IMPLIED
  %coreattrs;
  >

<!ELEMENT small  (%flow;)*>
<!ATTLIST small
  xml:lang        NMTOKEN       #IMPLIED
  %coreattrs;
  >

<!ENTITY % TAlign "(left|right|center)">
<!ENTITY % WrapMode "(wrap|nowrap)" >
<!ELEMENT p (%fields; | do)*>
<!ATTLIST p
  align       %TAlign;     "left"
  mode        %WrapMode;   #IMPLIED
  xml:lang    NMTOKEN      #IMPLIED
  %coreattrs;
  >

<!ELEMENT br EMPTY>
<!ATTLIST br
  xml:lang        NMTOKEN       #IMPLIED
  %coreattrs;
  >

<!ENTITY quot  "&#34;">
 <!-- quotation mark -->
<!ENTITY amp   "&#38;#38;">
 <!-- ampersand -->
<!ENTITY apos  "&#39;">
 <!-- apostrophe -->
<!ENTITY lt    "&#38;#60;">
 <!-- less than -->
<!ENTITY gt    "&#62;">
 <!-- greater than -->
<!ENTITY nbsp  "&#160;">
 <!-- non-breaking space -->
<!ENTITY shy   "&#173;">
 <!-- soft hyphen (discretionary hyphen) -->

<!--
Copyright Wireless Application Protocol
Forum Ltd., 1998,1999.
                      All rights reserved.
-->
  • Previous Page
  • Next Page

WML 参考手册
WAP 演示


WML 变量

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML 变量

  • Previous Page
  • Next Page

变量

当用户在卡片组的卡片之间切换时，我们需要在变量中存储数据。WML 变量对大小写敏感。

通过 Setvar 命令规定变量

当用户执行任务时（比如 go, prev 或 refresh），可使用 Setvar 元素设置带有指定值的变量。

下面的例子将创建一个名为 i 的变量，值是 500：

<setvar name="i" value="500"/>

name 和 value 属性是必需的。

为输入元素规定变量

可以为输入元素（比如input, select, option 等等）设置变量：

下面的例子将创建名为 schoolname 的变量：

<card id="card1">
<select name="schoolname">
<option value="HTML">HTML Tutorial</option>
<option value="XML">XML Tutorial</option>
</select>
</card>

使用上例中创建的变量：

<card id="card2">
<p>You selected: $(schoolname)</p>
</card>
  • Previous Page
  • Next Page

WML 参考手册
WAP 演示


WML 参考手册

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML 参考手册

  • Previous Page
  • Next Page

WAP 协议用于在无线客户端（比如移动电话）上展示因特网内容。

Deck / Card 元素

开始标签 | 作用 | WML
<access> | 定义关于 deck 的访问控件的信息。 | 1.1
<card> | 定义 deck 中的一个 card。 | 1.1
<head> | 包含关于文档的信息。 | 1.1
<meta> | 定义有关文档的元信息。 | 1.1
<template> | 为 deck 中的所有 card 定义代码模板。 | 1.1
<wml> | 定义 WML deck (WML 根) | 1.1
<!--> | 定义注释。 | 1.1

文本元素

开始标签 | 作用 | WML
<br> | 定义一个换行。 | 1.1
<p> | 定义一个段落。 | 1.1
<table> | 定义表格。 | 1.1
<td> | 定义一个表格单元（表格数据）。 | 1.1
<tr> | 定义一个表格行。 | 1.1

文本格式化标签

开始标签 | 作用 | WML
<b> | 定义粗体的文本。 | 1.1
<big> | 定义大号的文本。 | 1.1
<em> | 定义着重文本。 | 1.1
<i> | 定义斜体的文本。 | 1.1
<small> | 定义小号的文本。 | 1.1
<strong> | 定义强调文本。 | 1.1
<u> | 定义下划线文本。 | 1.1

锚元素

开始标签 | 作用 | WML
<a> | 定义一个锚（链接）。 | 1.1
<anchor> | 定义一个锚（链接）。 | 1.1

图像元素

开始标签 | 作用 | WML
<img> | 定义图像。 | 1.1

事件元素

开始标签 | 作用 | WML
<do> | 在用户点击屏幕上的一个单词或短语时激活一个任务。 | 1.1
<onevent> | 包含了当某些事件发生时所执行的代码。 | 1.1
<postfield> | 包含了连同 <go> 标签被送往服务器的信息。 | 1.1

任务元素

开始标签 | 作用 | WML
<go> | 表示跳转到新卡片的动作。 | 1.1
<noop> | 表示不进行任何动作（noop 指的是 "no operation"）。 | 1.1
<prev> | 表示返回前一个访问过的卡片。 | 1.1
<refresh> | 刷新指定的卡片变量。如果有变量显示在屏幕上，此任务也会刷新屏幕。 | 1.1

输入元素

开始标签 | 作用 | WML
<fieldset> | 用于对卡片中的相关元素进行分组。 | 1.1
<input> | 定义输入字段（用户可在其中输入文本的文本域）。 | 1.1
<optgroup> | 定义可选列表中的一组选项。 | 1.1
<option> | 定义可选列表中的选项。 | 1.1
<select> | 定义可选列表。 | 1.1

变量元素

开始标签 | 作用 | WML
<setvar> | 在 <go>、<prev> 或 <refresh> 任务中把变量设置为指定的值。 | 1.1
<timer> | 定义卡片计时器。 | 1.1
  • Previous Page
  • Next Page

WML 参考手册
WAP 演示


WML 格式化

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML 格式化

  • Previous Page
  • Next Page

Deck 和 Card

WML 页面通常称为 "deck"。每个 deck 含有一系列的 card。card 元素可包含文本、标记、链接、输入字段、task、图像等等。卡片之间通过链接彼此相互联系。

当从移动电话访问一张 WML 页面时，页面中的所有卡片都会从 WAP 服务器下载下来。卡片之间的导航是通过电话的计算机完成的 - 在电话内部 - 不需要对服务器的额外访问：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>

<card id="no1" title="Card 1">
<p>Hello World!</p>
</card>

<card id="no2" title="Card 2">
<p>Welcome to our WAP Tutorial!</p>
</card>

</wml>

在您的移动电话显示屏上，结果应该类似这样（请注意每次只显示一个 card）：

段落和换行

可以编写显示段落和换行的 WML 卡片：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="Paragraphs">

<p>
This is a paragraph
</p>
<p>
This is another<br/>with a line break
</p>

</card>
</wml>

在您的移动电话显示屏上，结果应该类似这样：

文本格式化

可以编写显示格式化文本的 WML 卡片：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="Formatting">

<p>
normal<br/>
<em>emphasized</em><br/>
<strong>strong</strong><br/>
<b>bold</b><br/>
<i>italic</i><br/>
<u>underline</u><br/>
<big>big</big><br/>
<small>small</small>
</p>

</card>
</wml>

在您的移动电话显示屏上，结果应该类似这样（不要认为所有格式化标签都会按照预期的效果呈现）：

表格

可以编写显示表格的 WML 卡片：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="Table">

<p>
<table columns="3">
<tr>
<td>Cell 1</td>
<td>Cell 2</td>
<td>Cell 3</td>
</tr>
</table>
</p>

</card>
</wml>

在您的移动电话显示屏上，结果应该类似这样：

  • Previous Page
  • Next Page

WML 参考手册
WAP 演示


WML 计时器

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML 计时器

  • Previous Page
  • Next Page

计时器 (Timer)

可以制作 WML 卡片来使用 WML 的计时器功能。计时器的时间单位是一秒的十分之一。

下面的例子将用 3 秒来显示一条消息，然后切换到文件 "test.wml"：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card ontimer="test.wml">

<timer value="30"/>
<p>Some Message</p>

</card>
</wml>
  • Previous Page
  • Next Page

WML 参考手册
WAP 演示


WML 链接和图像

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML 链接和图像

  • Previous Page
  • Next Page

链接

可以制作 WML 卡片来显示 WML 的锚功能。

<anchor>

<anchor> 标签总是要规定一个任务 ("go", "prev", 或 "refresh")。任务定义了当用户选择此链接时要做的事情。在本例中，当用户选择 "Next page"，其任务是 "前往 test.wml"：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="Anchor Tag">

<p>
<anchor>Next page
<go href="test.wml"/>
</anchor>
</p>

</card>
</wml>

<a>

<a> 标签永远执行 "go" 任务，不带参数。下面的例子与那个 <anchor> 标签的例子起得作用是相同的：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="A Tag">

<p>
<a href="test.wml">Next page</a>
</p>

</card>
</wml>

图像

可以制作 WML 卡片来显示图像：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="Image">

<p>
This is an image
<img src="/images/stickman.wbmp" alt="stickman" />
in a paragraph
</p>

</card>
</wml>

在您的移动电话显示屏上，结果也许类似这样：

请注意，.wbmp 是唯一可以显示在 WAP 浏览器中的图像类型。

  • Previous Page
  • Next Page

WML 参考手册
WAP 演示


WML 任务

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML 任务

  • Previous Page
  • Next Page

任务 (task) 定义了事件发生时所执行的动作，比如在输入一个卡片或选择一个链接之类的时间发生时。

Go 任务

<go> 任务表示切换到一个新卡片的动作。

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card>
<p>
 <anchor>
  Go To Test
  <go href="test.wml"/>
 </anchor>
</p>
</card>
</wml>

Prev 任务

<prev> 任务表示后退到前面的卡片的动作。

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card>
<p>
 <anchor>
  Previous Page
  <prev/>
 </anchor>
</p>
</card>
</wml>

Refresh 任务

<refresh> 任务会刷新一些指定的卡片变量。如果变量显示在屏幕上，任务也会刷新屏幕。

下面的例子使用 <anchor> 标签向卡片添加了一个 "Refresh this page" 链接。当用户点击该链接时，他或她会刷新页面，同时变量 x 的值将被设置为 30：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card>
<p>
 <anchor>
  Refresh this page
  <go href="thispage.wml"/>
  <refresh>
   <setvar name="x" value="30"/>
  </refresh>
 </anchor>
</p>
</card>
</wml>

Noop 任务

<noop> 任务规定不做任何事（noop 指的是 "no operation"）。此标签用于覆盖卡片组级别的元素。

<do> 标签用于在用户点击屏幕上的某个单词或短语时启动一个任务。

下面的例子使用 <do> 标签向卡片添加一个 "Back" 链接。当用户点击这个 "Back" 链接时，他或他被被带回前面的卡片。但是 <noop> 标签阻止了这个操作；当用户点击 "Back" 时，不会发生任何事情：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card>
<p>
 <do name="back" type="prev" label="Back">
  <noop/>
 </do>
</p>
</card>
</wml>

任务元素

开始标签 | 作用 | WML
<go> | 表示切换到新卡片的动作。 | 1.1
<noop> | 规定不做任何事情。用于覆盖卡片组级别的元素。 | 1.1
<prev> | 表示后退到前面的卡片的动作。 | 1.1
<refresh> | 刷新一些指定的卡片变量。如果有变量显示在屏幕上，此任务也刷新屏幕。 | 1.1
  • Previous Page
  • Next Page

WML 参考手册
WAP 演示


WML 实例

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML 实例

  • Previous Page
  • Next Page

带有两个卡片的一个卡片组 - 一个供用户输入，一个供显示结果 - 正如本例中展示的：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>

<card id="card1" title="Tutorial">
<do type="accept" label="Answer">
  <go href="#card2"/>
</do>
<p>
<select name="name">
  <option value="HTML">HTML Tutorial</option>
  <option value="XML">XML Tutorial</option>
  <option value="WAP">WAP Tutorial</option>
</select>
</p>
</card>

<card id="card2" title="Answer">
<p>
You selected: $(name)
</p>
</card>

</wml>

在您的移动电话显示屏上，结果看上去也许类似这样：

第二张卡片看上也许类似这样：

wap example 2

例子解释

Prolog

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

WML 文档中的第一行称为 prolog。prolog 定义了文档是 XML 文档，然后它定义了 XML 的版本，以及要引用的 DTD。

Deck

<wml> ..... </wml>

deck 是 WML 文档本身。它被嵌套在 >wml> 标签中。

Cards

<card> ..... </card>

一次只显示一个卡片。这个 WML 卡片组包含两个卡片 - 一个供用户输入，一个供结果显示。

<do> 元素

<do> ... </do>

第一个卡片拥有 <do> 元素，该元素定义了被触发的事件。<do> 元素的 type="accept" 属性使 label="Answer" 显示在屏幕的左下角。

Event

当用户点击 <do> 标记时会触发 <go> 元素。<go> 元素的 href="#card2" 属性使卡片二显示在屏幕上。

Variable

卡片二显示来自卡片一的 $(name) 变量，因为变量在卡片之间是有效的。

  • Previous Page
  • Next Page

WML 参考手册
WAP 演示


WML 实体

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML 实体

  • Previous Page
  • Next Page

字符实体

结果 | 描述 | 实体名称 | 实体编号
& | ampersand | &amp; | &#38;
' | apostrophe | &apos; | &#39;
> | greater-than | &gt; | &#62;
< | less-than | &lt; | &#60;
 | non-breaking space | &nbsp; | &#160;
" | quotation mark | &quot; | &#34;
 | soft hyphen | &shy; | &#173;
  • Previous Page
  • Next Page

WML 参考手册
WAP 演示


WML 输入

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WML 输入

  • Previous Page
  • Next Page

输入字段

可以制作让用户可输入信息的 WML 卡片，正如这个例子演示的：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="Input">

<p>
Name: <input name="Name" size="15"/><br/>
Age:  <input name="Age" size="15" format="*N"/><br/>
Sex:  <input name="Sex" size="15"/>
</p>

</card>
</wml>

在您的移动电话显示屏上结果也许类似这样：

选择和选项

可以制作 WML 卡片来显示 WML 的选择和选项功能：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="Selectable List 1">

<p>
<select>
<option value="htm">HTML Tutorial</option>
<option value="xml">XML Tutorial</option>
<option value="wap">WAP Tutorial</option>
</select>
</p>

</card>
</wml>

在您的移动电话显示屏上结果也许类似这样：

在下面的例子中，结果是一个用户可在其中选择多个项目的可选列表：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="Selectable List 2">

<p>
<select multiple="true">
<option value="htm">HTML Tutorial</option>
<option value="xml">XML Tutorial</option>
<option value="wap">WAP Tutorial</option>
</select>
</p>

</card>
</wml>

在您的移动电话显示屏上结果也许类似这样：

Fieldset

可以制作 WML 卡片来显示 WML 的 fieldset 函数：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card title="Fieldset">

<p>
<fieldset title="CD Info">
Title: <input name="title" type="text"/><br/>
Prize: <input name="prize" type="text"/>
</fieldset>
</p>

</card>
</wml>

在您的移动电话显示屏上结果也许类似这样：

  • Previous Page
  • Next Page

WML 参考手册
WAP 演示


从您的移动电话访问 W3School.com.cn

WAP 教程

  • WAP 教程
  • WAP 简介
  • WAP 基础
  • WML 格式化
  • WML 连接
  • WML 输入
  • WML 任务
  • WML 定时器
  • WML 变量
  • WML 实例
  • WAP 演示
  • WAP W3School

参考手册

  • WML 参考手册
  • WML 实体
  • WML DTD

资源

  • WAP 论坛/OMA
  • WAP 软件

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

从您的移动电话访问 W3School.com.cn

  • Previous Page
  • Next Page

如果您拥有支持 WAP 的移动电话，就可以访问 W3School 上的 WAP 页面。

打开您的 WAP 电话，输入下面的地址：

http://www.w3school.com.cn/wap.wml

这个地址链接了两部分的内容：

  • W3School 的 HTML 参考手册
  • W3School 的网站构建术语表
  • Previous Page
  • Next Page

WML 参考手册
WAP 演示


CSS 初级教程

网站构建初级教程

  • 首页
  • WWW
  • HTML
  • CSS
  • Javascript
  • XML
  • 服务器脚本
  • SQL

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

CSS 初级教程

  • Previous Page
  • Next Page

需要具备的基础知识

在继续学习之前，你需要对下面的知识有基本的了解：

  • HTML
  • XHTML

如果你希望首先学习这些项目，请在 首页 访问相关教程。

CSS 概述
  • CSS 指层叠样式表 (Cascading Style Sheets)
  • 样式定义如何显示 HTML 元素
  • 样式通常存储在样式表中
  • 把样式添加到 HTML 4.0 中，是为了解决内容与表现分离的问题
  • 外部样式表可以极大提高工作效率
  • 外部样式表通常存储在 CSS 文件中
  • 多个样式定义可层叠为一

样式解决了一个普遍的问题

HTML 标签原本被设计为用于定义文档内容。通过使用 <h1>, <p>, <table> 这样的标签，HTML 当初被指望用来表达“这是标题”、“这是段落”、“这是表格”之类的信息。而文档的布局被期望由浏览器来完成，而不使用任何的格式化标签。

由于两种主要的浏览器（Netscape 和 Internet Explorer）不断地将新的 HTML 标签和属性（比如字体标签和颜色属性）添加到 HTML 规范之中，因此创建文档内容清晰地独立于文档表现层的站点变得越来越困难。

为了解决这个问题，万维网联盟（W3C），这个非营利的标准化联盟，肩负起了 HTML 标准化的使命，并在 HTML 4.0 之外创造出 STYLES（样式）。

所有的主流浏览器均支持层叠样式表。

样式表极大地提高了工作效率

样式表定义如何显示 HTML 元素，诸如 HTML 3.2 的样式中的字体标签和颜色属性通常被保存在外部的 .css 文件中。通过仅仅编辑一个简单的 CSS 文档，外部样式表使你有能力同时改变站点中所有页面布局的外观。

由于允许同时控制多重页面的样式和布局，CSS 可以称得上 WEB 设计领域的一个突破。作为网站开发者，你可以为每个 HTML 元素定义样式，并将之应用于你希望的任意多的页面中。如需进行全局变换，只需简单地改变样式，然后网站中的所有元素均会被自动地更新。

多重样式将层叠为一个

样式表允许以多种方式规定样式信息。样式可以被规定于单个的 HTML 元素中，在 HTML 页的头元素中，或在一个外部的 CSS 文件中。甚至可以在一个单一的 HTML 文档内部引用多个外部样式表。

层叠次序

当同一个HTML元素被不止一个样式所定义时，会使用哪个样式呢？

一般而言，所有的样式会根据下面的规则层叠于一个新的虚拟样式表中，其中数字 4 拥有最高的优先权。

  1. 浏览器缺省设置
  2. 外部样式表
  3. 内部样式表（位于 <head> 标签内部）
  4. 内联样式（在 HTML 元素内部）

因此，内联样式（在 HTML 元素内部）拥有最高的优先权，这意味着它将优先于以下的样式声明：<head> 标签中的样式声明，外部样式表中的样式声明，或者浏览器中的样式声明（缺省值）。

  • Previous Page
  • Next Page


HTML 初级教程

网站构建初级教程

  • 首页
  • WWW
  • HTML
  • CSS
  • Javascript
  • XML
  • 服务器脚本
  • SQL

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

HTML 初级教程

  • Previous Page
  • Next Page
什么是 HTML 文件？
  • HTML 指超文本标签语言。
  • HTML 文件是包含一些标签的文本文件。
  • 这些标签告诉 WEB 浏览器如何显示页面。
  • HTML 文件必须使用 htm 或者 html 作为文件扩展名。
  • HTML 文件可以通过简单的文本编辑器来创建。

做个实验如何？

第一步：如果您使用 Windows，请启动记事本。

如果您使用 Mac，请启动 SimpleText。

（在 OSX 中请使用 TextEdit，并设置一下参数：在参数设置中选择 Plain text 字体替代 Rich text 字体，然后选择“在 HTML 文件中忽略 rich text 命令”。这一点很重要，因为不这样的话，HTML 代码也许不能正常工作。）

第二步：键入以下文本：

<html>
<head>
<title>Title of page</title>
</head>
<body>
This is my first homepage. <b>This text is bold</b>
</body>
</html>

第三步：将这个文件存为 "mypage.htm"。

第四步：启动您的浏览器。在浏览器的文件菜单中选择“打开”或者“打开页面”。这时会弹出一个对话框。单击“浏览”或者“选择文件”，找到您刚才创建的文件 - "mypage.htm"，选定它然后打开，现在您会看到对话框中有一行地址，比如："C:\MyDocuments\mypage.htm"。单击确定按钮，浏览器就会显示这个页面。

例子解释：

HTML 文件中的第一个标签是 <html>。这个标签告诉浏览器这个 HTML 文件的开始点。文件中最后一个标签是 </html>。这个标签告诉您的浏览器，这是 HTML 文件的结束点。

位于 <head> 标签和 </head> 标签之间的文本是头信息。头信息不会显示在浏览器窗口中。

<title> 标签中的文本是文件的标题。标题会显示在浏览器的标题栏。

<body> 标签中的文本是将被浏览器显示出来的文本。

<b> 和 </b> 标签中的文本将以粗体显示。

为什么我们要使用小写的标签？

我们刚才讲到：HTML 标签对大小写是不敏感的：<b> 和 <B> 的作用的相同的。当您在网上冲浪时，您会发现大多数教程在他们的例子中都使用大写的 HTML 标签。而我们总是使用小写。原因何在呢？

如果您希望为使用下一代 HTML 而做好准备，您就应该使用小写标签。万维网联盟 (W3C) 的标准是：建议在 HTML 4 中使用小写标签，而在 XHTML（下一代 HTML）中，必须使用小写标签。

HTM 还是 HTML 扩展名？

当您将一个 HTML 文件存盘时，您即可以使用 HTM 也可以使用 HTML 作为扩展名。我们刚才使用了 .htm 作为上面那个例子的扩展名。不过这样做也许是一个坏习惯，习惯于这样做的人也许是因为使用某些过时的软件而养成了这个坏习惯，这些软件只允许三个字母作为扩展名。

如果您使用新近的软件，我们认为使用 .html 是相当安全的做法。

关于 HTML 编辑器的注意事项:

您可以使用所见即所得的编辑器而不是纯文本编辑器，这样会更轻松的编辑 HTML 文件。比方说 FrontPage, Claris Home Page, 或者 Adobe PageMill。

但是，如果您希望成为一名熟练的开发人员，我们强烈推荐您使用纯文本编辑器来学习我们的《HTML 基础教程》。

常见问题（FAQ）

Q：我已经编辑了一个 HTML 文件，但是浏览器无法显示出结果。为什么？

A：首先确定您使用了正确的文件名和扩展名存盘，比如说 "c:\mypage.htm"。然后看一下是否在浏览器中使用了同样的文件名来打开这个文件。

Q：我重新编辑了 HTML 文件，但是浏览器的显示没有任何变化。为什么？

A：为了不重复读取同一个页面，浏览器要对您的页面进行缓存。浏览器不会意识到您已经修改了页面。通过使用刷新或者重载按钮，您可以使浏览器读取编辑后的页面。

Q：我应该使用何种浏览器？

A：您可以使用任何一款通用浏览器进行训练，例如 Internet Explorer, Mozilla, Netscape,或者 Opera。不过，我们的高级课程中的某些例子需要最新版本的浏览器的支持。

Q：我的电脑必须运行 Windows 吗？使用 Mac 机可以吗？

A：您可以在非 Windows 系统上进行所有的训练，比如 Mac。

  • Previous Page
  • Next Page


JavaScript 初级教程

网站构建初级教程

  • 首页
  • WWW
  • HTML
  • CSS
  • Javascript
  • XML
  • 服务器脚本
  • SQL

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

JavaScript 初级教程

  • Previous Page
  • Next Page

在数百万张页面中，JavaScript 被用来改进设计、验证表单、检测浏览器、创建cookies，等等等等。

JavaScript 是因特网上最流行的脚本语言，并且可在所有主要的浏览器中运行，比方说 Internet Explorer、 Mozilla、Firefox、Netscape、和 Opera。

你应该具备的基础知识：

在继续学习前，你应该对以下知识有基本的了解：

  • HTML
  • XHTML

如果你希望首先学习这些内容，请在 首页 访问相关教程。

什么是 JavaScript？
  • JavaScript 被设计用来向 HTML 页面添加交互行为。
  • JavaScript 是一种脚本语言（脚本语言是一种轻量级的编程语言）。
  • JavaScript 由数行可执行计算机代码组成。
  • JavaScript 通常被直接嵌入 HTML 页面。
  • JavaScript 是一种解释性语言（就是说，代码执行不进行预编译）。
  • 所有的人无需购买许可证均可使用 JavaScript。

Java 和 JavaScript 是相同的吗？

不同！

在概念和设计方面，Java 和 JavaScript 是两种完全不同的语言。

Java（由太阳微系统公司开发）很强大，同时也是更复杂的编程语言，就像同级别的 C 和 C++。

JavaScript 能做什么？

JavaScript 为 HTML 设计师提供了一种编程工具
HTML 创作者往往都不是程序员，但是 JavaScript 却是一种只拥有极其简单的语法的脚本语言！几乎每个人都有能力将短小的代码片断放入他们的 HTML 页面当中。
JavaScript 可以将动态的文本放入 HTML 页面
类似于这样的一段 JavaScript 声明可以将一段可变的文本放入 HTML 页面：document.write("<h1>" + name + "</h1>")
JavaScript 可以对事件作出响应
可以将 JavaScript 设置为当某事件发生时才会被执行，例如页面载入完成或者当用户点击某个 HTML 元素时。
JavaScript 可以读写 HTML 元素
JavaScript 可以读取及改变 HTML 元素的内容。
JavaScript 可被用来验证数据
在数据被提交到服务器之前，JavaScript 可被用来验证这些数据。
JavaScript 可被用来检测访问者的浏览器
JavaScript 可被用来检测访问者的浏览器，并根据所检测到的浏览器，为这个浏览器载入相应的页面。
JavaScript 可被用来创建 cookies
JavaScript 可被用来存储和取回位于访问者的计算机中的信息。
  • Previous Page
  • Next Page


SQL 初级教程

网站构建初级教程

  • 首页
  • WWW
  • HTML
  • CSS
  • Javascript
  • XML
  • 服务器脚本
  • SQL

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

SQL 初级教程

  • Previous Page
  • Next Page

SQL 是用于访问和处理数据库的标准的计算机语言。

通过 SQL 来管理数据

结构化查询语言 (SQL) 是用于访问数据库的标准语言，这些数据库包括 SQL Server、Oracle、MySQL、Sybase 以及 Access 等等。

对于那些希望在数据库中存储数据并从中获取数据的人来说，SQL 的知识是价值无法衡量的。

什么是 SQL?

  • SQL 指结构化查询语言 (Structured Query Language)
  • SQL 使我们有能力访问数据库
  • SQL 是一种 ANSI 的标准计算机语言
  • SQL 面向数据库执行查询
  • SQL 可从数据库取回数据
  • SQL 可在数据库中插入新的纪录
  • SQL 可从数据库删除记录
  • SQL 很容易学习

编者注：ANSI，美国国家标准化组织

SQL 是一种标准 - 但是...

SQL 是一门 ANSI 的标准计算机语言，用来访问和操作数据库系统。SQL 语句用于取回和更新数据库中的数据。SQL 可与数据库程序协同工作，比如 MS Access、DB2、Informix、MS SQL Server、Oracle、Sybase 以及其他数据库系统。

不幸地是，存在着很多不同版本的 SQL 语言，但是为了与 ANSI 标准相兼容，它们必须以相似的方式共同地来支持一些主要的关键词（比如 SELECT、UPDATE、DELETE、INSERT、WHERE 等等）。

注释：除了 SQL 标准之外，大部分 SQL 数据库程序都拥有它们自己的私有扩展！

SQL 数据库表

一个数据库通常包含一个或多个表。每个表由一个名字标识（例如“客户”或者“订单”）。表包含带有数据的记录（行）。

下面的例子是一个名为 "Persons" 的表：

LastName | FirstName | Address | City
Hansen | Ola | Timoteivn 10 | Sandnes
Svendson | Tove | Borgvn 23 | Sandnes
Pettersen | Kari | Storgt 20 | Stavanger

上面的表包含三条记录（每一条对应一个人）和四个列（姓、名、地址和城市）。

SQL 查询程序

通过 SQL，我们可以查询某个数据库，并获得返回的一个结果集。

查询程序类似这样：

SELECT LastName FROM Persons

结果集类似这样：

LastName
Hansen
Svendson
Pettersen

注释：某些数据库系统要求在 SQL 命令的末端使用分号。在我们的教程中不使用分号。

SQL 数据操作语言 (DML)

SQL (结构化查询语言)是用于执行查询的语法。但是 SQL 语言也包含用于更新、插入和删除记录的语法。

这些查询和更新语句都来自 SQL 的 DML 部分：

  • SELECT - 从数据库表中获取数据
  • UPDATE - 更新数据库表中的数据
  • DELETE - 从数据库表中删除数据
  • INSERT INTO - 向数据库表中插入数据

SQL 数据定义语言 (DDL)

SQL 的数据定义语言部分使我们有能力创建或删除表格。我们也可以定义索引（键），规定表之间的链接，以及施加表间的约束。

SQL 中最重要的 DDL 语句:

  • CREATE TABLE - 创建新表
  • ALTER TABLE - 变更（改变）数据库表
  • DROP TABLE - 删除表
  • CREATE INDEX - 创建索引（搜索键）
  • DROP INDEX - 删除索引

SQL 教程

学习 W3School 提供的 SQL 教程。

  • Previous Page
  • Next Page


WWW 初级教程

网站构建初级教程

  • 首页
  • WWW
  • HTML
  • CSS
  • Javascript
  • XML
  • 服务器脚本
  • SQL

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WWW 初级教程

  • Previous Page
  • Next Page

什么是 WWW？

它如何工作？

什么是浏览器？

什么是服务器？

什么是 WWW？

  • WWW 指万维网（World Wide Web）
  • 万维网常被称为Web
  • Web 是由遍布全球的计算机所组成的网络
  • 所有 Web 中的计算机都可以彼此通信
  • 所有这些计算机都使用名为 HTTP 的通信标准

WWW 如何工作？

  • Web 信息存储于被称为网页的文档中
  • 网页是存储于被称为 Web 服务器的计算机上
  • 读取网页的计算机称为 Web 客户端
  • Web 客户端通过称为浏览器的程序来查看网页
  • 主要的浏览器有 Internet Explorer 和 Mozilla Firefox

浏览器如何读取页面？

  • 浏览器可通过一个请求来读取某个服务器上的一张网页
  • 请求是一个包含页面地址的标准 HTTP 请求
  • 页面地址类似这样：http://www.someone.com/page.htm

浏览器如何显示页面？

  • 所有的网页都含有其如何被显示的结构
  • 浏览器通过阅读这些结构来显示页面
  • 最常用的显示结构称为 HTML 标签
  • 用于段落的 HTML 标签类似这样：<p>
  • 在 HTML 中像这样定义段落：<p>This is a Paragraph</p>

谁制定 web 标准？

  • web 标准不是由 Netscape 或 Microsoft 制定的
  • web 的规则制定主体是 W3C
  • W3C 指的是万维网联盟（World Wide Web Consortium）
  • W3C 将各种规范订立为 web 标准
  • 最核心的 web 标准是 HTML、CSS、XML
  • 最新的 HTML 标准是 XHTML 1.0

如需学习更多有关 W3C 的知识，请学习我们的 W3C 教程。

  • Previous Page
  • Next Page


XML 初级教程

网站构建初级教程

  • 首页
  • WWW
  • HTML
  • CSS
  • Javascript
  • XML
  • 服务器脚本
  • SQL

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML 初级教程

  • Previous Page
  • Next Page

XML 被设计用来描述数据，其焦点是数据的内容。

HTML 被设计用来显示数据，其焦点是数据的外观。

应该掌握的基础知识：

在您继续学习之前，需要对以下知识有基本的了解：

  • HTML / XHTML
  • JavaScript 或 VBScript

如果您希望首先学习这些项目，请在我们的 首页 访问这些教程。

什么是XML?

  • XML 指可扩展标记语言（EXtensible Markup Language）
  • XML 是一种标记语言，很类似 HTML
  • XML 被设计用来描述数据
  • XML 标签没有被预定义。您需要自行定义标签。
  • XML 使用文件类型声明（DTD）或者 XML Schema 来描述数据。
  • 带有 DTD 或者 XML Schema 的 XML 被设计为具有自我描述性。
  • XML 是一个 W3C 标准

XML 是一个 W3C 标准

可扩展标记语言于1998年2月10日被确立为 W3C 标准。

您可以在我们的 《W3C 教程》 中获得更多关于 XML 标准的信息。

XML 与 HTML 的主要差异

XML 被设计用来携带数据。

XML 不是用来替代 HTML 的。

XML 和 HTML 为不同的目的而设计：

XML 被设计用来描述数据，其焦点是数据的内容。

HTML 被设计用来显示数据，其焦点是数据的外观。

HTML 旨在显示信息，而 XML 旨在描述信息。

没有任何行为的 XML

XML 是不作为的。

也许这有点难以理解，但是 XML 不会做任何事情。XML 被设计用来结构化、存储以及传输信息。

下面是 John 写给 George 的便签，存储为 XML：

<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

这个标签有标题以及留言。它也包含了发送者和接受者的信息。但是，这个 XML 文档仍然没有做任何事情。它仅仅是包装在 XML 标签中的纯粹的信息。我们需要编写软件或者程序，才能传送、接收和显示出这个文档。

XML 是免费的、可扩展的

XML 标签没有被预定义。您必须“发明”自己的标签。

被用来标记 HTML 文档及其结构的标签是预定义的。HTML 文档的创作者只能使用在 HTML 标准中被定义的那些标签（比如<p>、<h1>。）。

XML 允许创作者定义自己的标签以及自己的文档结构。

上面的例子中的标签没有在任何一个 XML 标准中被定义过。这些标签是由 XML 文档的作者发明的。

XML 是对 HTML 的补充

XML 不是 HTML 的替代物。

您需要理解 XML 不是 HTML 的替代物，这一点非常重要。在未来的 Web 开发中，最有可能出现的情况是，XML 会被用来描述数据，而 HTML 会被用来格式化和显示这些数据。

我们关于 XML 最好的描述是：XML 是跨平台的、用于传输信息且独立于软件和硬件的工具。

XML 在未来的 Web 开发中扮演的角色

XML 将会无所不在。

当我们看到 XML 标准突飞猛进的开发进度，以及大批的软件开发商采用这个标准的日新月异的速度时，真的是不禁感叹这真是令人叹为观止。

我们坚定地认为，XML 将在 Web 的未来中起到的作用不会亚于一直作为 Web 基石的 HTML，并且，XML 将会成为所有数据处理和数据传输的最常用的工具。

  • Previous Page
  • Next Page


服务器端脚本 初级教程

网站构建初级教程

  • 首页
  • WWW
  • HTML
  • CSS
  • Javascript
  • XML
  • 服务器脚本
  • SQL

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

服务器端脚本 初级教程

  • Previous Page
  • Next Page

HTML 文件可以包含文本、HTML 标签以及脚本。

HTML 文件中的脚本可以在 web 服务器上执行。

服务器端脚本

服务器端脚本是对服务器行为的编程。这被称为服务器端脚本或服务器脚本。

客户端脚本是对浏览器行为的编程。（请参阅 JavaScript 初级教程）。

什么是服务器脚本？

通常，当浏览器请求某个 HTML 文件时，服务器会返回此文件，但是假如此文件含有服务器端的脚本，那么在此 HTML 文件作为纯 HTML 被返回浏览器之前，首先会执行 HTML 文件中的脚本。

服务器脚本能做什么呢？

  • 动态地向 web 页面编辑、改变或添加任何的内容
  • 对由 HTML 表单提交的用户请求或数据进行响应
  • 访问数据或数据库，并向浏览器返回结果
  • 为不同的用户定制页面
  • 提高网页安全性，使您的网页代码不会通过浏览器被查看到

重要事项：由于脚本在服务器上执行，因此浏览器在不支持脚本的情况下就可以显示服务器端的文件！

ASP 和 PHP

在 W3School，我们通过使用活动服务器页面（ASP）和超文本预处理器（PHP）来演示服务器端的脚本编程。

您无法通过查看源代码来查看 ASP 或 PHP 的源代码，您看到的仅仅是来自服务器的输出，那些纯粹的 HTML。这是因为在结果以纯粹的 HTML 发送到浏览器之前，脚本已经在服务器上执行了。

ASP 实例

通过 ASP 来写文本
如何通过 ASP 来写文本。
向文本添加 HTML
如何通过 HTML 标签来格式化文本。

脚本教程

请学习我们完整的 ASP 教程 和 PHP 教程。

  • Previous Page
  • Next Page


网站构建 初级教程

网站构建初级教程

  • 首页
  • WWW
  • HTML
  • CSS
  • Javascript
  • XML
  • 服务器脚本
  • SQL

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

网站构建 初级教程

  • Next Page

每个网站开发人员都有必要了解以下几方面的知识：

  • 万维网如何工作
  • HTML 语言
  • 如何使用层叠样式表 (CSS)
  • JavaScript 编程
  • XML 标准
  • 服务器脚本技术
  • 使用 SQL 来管理数据

WWW - 万维网

WWW 是遍布全球的计算机网络。WWW 常被称作 Web（网络）。

Web 上的计算机使用标准的协议和语言进行通信。

W3C 致力于发展用于 Web 的规则和标准。

HTML - Web 的语言

HTML 是属于 Web 的语言，每个开发人员都应对它具备基本的了解。

你可以使用 HTML 的标记标签来定义网页的内容和结构。

<h1> 定义标题，而 <p> 则定义段落。

CSS - 层叠样式表

样式表定义如何显示 HTML 元素。

如果样式保存在外部文件中，那么仅仅通过改变 CSS 文件，你就可以改变网站中所有 HTML 页面的的样式和外观。

假如你曾试图改变所有页面中标题的字体和颜色，就很容易理解 CSS 可以在多大程度上提高你的工作效率。

JavaScript - 客户端脚本

JavaScript 用于客户端的脚本化。客户端脚本化指的是 Web 浏览器编程。

你很有必要学习 JavaScript，这样你就有能力提供动态性更强的网站内容。

一个类似 document.write("<p>" + date + "</p>") 的 JavaScript 声明，可以向 HTML 页面写入动态的文本。

XML - 扩展标记语言

XML 不是 HTML 的替代者。XML 用来描述及传输数据，而 HTML 用来显示数据。

XML 及一系列的 XML 标准正迅速成为对数据进行传输、存储及操作的最常用（及通用）的工具。

服务器端脚本化

服务器端脚本化指的是服务器端编程。

学习服务器端脚本是很有必要的，这样我们就有能力提供动态性更强的网站内容。

通过服务器端编程，我们可以访问数据库，并向浏览器返回结果，这也是许许多多的服务器端脚本应用中的重要一项。

使用 SQL 管理网站数据

结构化查询语言 (SQL) 是用来访问诸如 SQL Server、Oracle、Sybase 及 Access 等数据库的通用标准。

网络管理员们都有必要明白，SQL 是用来和网络上的数据库交互的可靠引擎。

  • Next Page


Web Service 实例

Web Services 基础

  • WS 首页
  • WS 简介
  • Why WS?
  • WS 平台
  • WS 实例
  • WS 使用
  • WS 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Web Service 实例

  • Previous Page
  • Next Page

任何应用程序都可拥有 Web Service 组件。

Web Services 的创建与编程语言的种类无关。

一个实例：ASP.NET Web Service

在这个例子中，我们会使用 ASP.NET 来创建一个简单的 Web Service。

<%@ WebService Language="VB" Class="TempConvert" %>

Imports System
Imports System.Web.Services

Public Class TempConvert :Inherits WebService

<WebMethod()> Public Function FahrenheitToCelsius
(ByVal Fahrenheit As Int16) As Int16
    Dim celsius As Int16
    celsius = ((((Fahrenheit) - 32) / 9) * 5)
    Return celsius
End Function

<WebMethod()> Public Function CelsiusToFahrenheit
(ByVal Celsius As Int16) As Int16
    Dim fahrenheit As Int16
    fahrenheit = ((((Celsius) * 9) / 5) + 32)
    Return fahrenheit
End Function
End Class

此文档是一个 .asmx 文件。这是用于 XML Web Services 的 ASP.NET 文件扩展名。

要运行这个例子，我们需要一个 .NET 服务器

此文档中第一行表明这是一个 Web Service，由 VB 编写，其 class 名称是 "TempConvert"。

<%@ WebService Language="VB" Class="TempConvert" %>

接下来的代码行从 .NET 框架导入了命名空间 "System.Web.Services"。

Imports System
Imports System.Web.Services

下面这一行定义 "TempConvert" 类是一个 WebSerivce 类：

Public Class TempConvert :Inherits WebService

接下来的步骤是基础的 VB 编程。此应用程序有两个函数。一个把华氏度转换为摄氏度，而另一个把摄氏度转换为华氏度。

与普通的应用程序唯一的不同是，此函数被定义为 "WebMethod"。

请在您希望其成为 web services 的应用程序中使用 "WebMethod" 来标记函数。

<WebMethod()> Public Function FahrenheitToCelsius
(ByVal Fahrenheit As Int16) As Int16
    Dim celsius As Int16
    celsius = ((((Fahrenheit) - 32) / 9) * 5)
    Return celsius
End Function

<WebMethod()> Public Function CelsiusToFahrenheit
(ByVal Celsius As Int16) As Int16
    Dim fahrenheit As Int16
    fahrenheit = ((((Celsius) * 9) / 5) + 32)
    Return fahrenheit
End Function

最后要做的事情是终止函数和类：

End Function

End Class

假如您把此文件另存为 .asmx 文件，并发布于支持 .NET 的服务器上，那么您就拥有了第一个可工作的 Web Service。

ASP.NET 的自动化处理

通过 ASP.NET，你不必亲自编写 WSDL 和 SOAP 文档。

如果您仔细研究我们的这个例子，您会发现 ASP.NET 会自动创建 WSDL 和 SOAP 请求。

  • Previous Page
  • Next Page


Web Service 使用

Web Services 基础

  • WS 首页
  • WS 简介
  • Why WS?
  • WS 平台
  • WS 实例
  • WS 使用
  • WS 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Web Service 使用

  • Previous Page
  • Next Page

使用我们的 ASP.NET Web Service 例子

在上一节，我们创建了一个 Web Service 的例子。

请在此测试华氏度转换摄氏度函数：华氏度转换为摄氏度

请在此测试摄氏度转换华氏度函数：摄氏度转换为华氏度

这些函数会向您发送一个 XML 回答

本测试使用 HTTP POST，会发送类似这样的 XML 响应：

<?xml version="1.0" encoding="utf-8" ?>
<short xmlns="http://tempuri.org/">38</short>

使用表单来访问 Web Service

通过使用表单和 HTTP POST，您可以把 web service 置于您的站点上，比如这样：

您可以把 web service 置于您的站点上

您可以使用这些代码把 web service 放置在您的站点上：

<form target="_blank"
action='http://w3school.com.cn/webservices/tempconvert.asmx/FahrenheitToCelsius'
method="POST">

  <label>华氏度转换为摄氏度：</label>
  <p>

    <span>
      <input class="frmInput" type="text" size="30" name="Fahrenheit">
    </span>

    <span>
      <input type="submit" value="提交" class="button">
    </span>

  </p>

</form>

<form target="_blank"
action='http://w3school.com.cn/webservices/tempconvert.asmx/CelsiusToFahrenheit'
method="POST">

  <label>摄氏度转换为华氏度：</label>
  <p>

    <span>
     <input class="frmInput" type="text" size="30" name="Celsius">
    </span>

    <span>
     <input type="submit" value="提交" class="button">
    </span>

  </p>

</form>
  • Previous Page
  • Next Page


Web Services 简介

Web Services 基础

  • WS 首页
  • WS 简介
  • Why WS?
  • WS 平台
  • WS 实例
  • WS 使用
  • WS 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Web Services 简介

  • Previous Page
  • Next Page

Web Services 可使您的应用程序成为 Web 应用程序。

Web Services 通过 Web 进行发布、查找和使用。

您应当具备的基础知识

在继续学习之前，您需要对下面的知识有基本的了解：

  • HTML
  • XML

如果您希望首先学习这些项目，请在我们的首页访问这些教程。

什么是Web Services？

  • Web Services 是应用程序组件
  • Web Services 使用开放协议进行通信
  • Web Services 是独立的（self-contained）并可自我描述
  • Web Services 可通过使用UDDI来发现
  • Web Services 可被其他应用程序使用
  • XML 是 Web Services 的基础

它如何工作？

基础的 Web Services 平台是 XML + HTTP。

HTTP 协议是最常用的因特网协议。

XML 提供了一种可用于不同的平台和编程语言之间的语言。

Web services 平台的元素：

  • SOAP (简易对象访问协议)
  • UDDI (通用描述、发现及整合)
  • WSDL (Web services 描述语言)

我们会在本教程后面章节讲解这些主题。

Web services 的未来

请不要过早地期待太多！

Web services 平台是简单的可共同操作的消息收发框架。它仍然缺少许多诸如安全和路由等重要的特性。但是，一旦 SOAP 变得更加高级，这些事项就会得到解决。

Web services 有望使应用程序更加容易通信。

  • Previous Page
  • Next Page


Web Services 教程

Web Services 基础

  • WS 首页
  • WS 简介
  • Why WS?
  • WS 平台
  • WS 实例
  • WS 使用
  • WS 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Web Services 教程

  • Next Page

Web Services 可以将应用程序转换为网络应用程序。

通过使用 Web Services，您的应用程序可以向全世界发布信息，或提供某项功能。

Web Services 可以被其他应用程序使用。

通过 Web Services，您的会计部门的 Win 2k 服务器可以与 IT 供应商的 UXIX 服务器相连接。

基本的 Web Services 平台是 XML+HTTP。

Web services 使用 XML 来编解码数据，并使用 SOAP 来传输数据。

学习如何经由 ASP.NET 应用程序创建 Web Services。

在本教程中，我们把一个 ASP.NET 程序转换为了 Web Services。

开始学习 Web Services ！

内容目录

Web Services 简介
对 Web Services 的简要介绍。
Why Web Services?
为什么及如何使用 Web Services？
Web Services 平台
Web Services 平台之后的组成元素。
Web Services 实例
一个 ASP.NET 的 Web Services 实例。
Web Services 使用
将 Web Service 置于您的站点。
Web Services 总结
本节包括在本教程所学内容的一个总结，以及我们向你推荐的下一步应该学习的内容。
  • Next Page


Web Services 平台元素

Web Services 基础

  • WS 首页
  • WS 简介
  • Why WS?
  • WS 平台
  • WS 实例
  • WS 使用
  • WS 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Web Services 平台元素

  • Previous Page
  • Next Page

Web Services 拥有三种基本的元素。

它们是：SOAP、WSDL 以及 UDDI。

什么是 SOAP？

基本的 Web services 平台是 XML + HTTP。

  • SOAP 指简易对象访问协议
  • SOAP 是一种通信协议
  • SOAP 用于应用程序之间的通信
  • SOAP 是一种用于发送消息的格式
  • SOAP 被设计用来通过因特网进行通信
  • SOAP 独立于平台
  • SOAP 独立于语言
  • SOAP 基于 XML
  • SOAP 很简单并可扩展
  • SOAP 允许您绕过防火墙
  • SOAP 将作为 W3C 标准来发展

如需更多有关 SOAP 的知识，请访问我们的《SOAP 教程》

什么是 WSDL?

WSDL 是基于 XML 的用于描述 Web Services 以及如何访问 Web Services 的语言。

  • WSDL 指网络服务描述语言
  • WSDL 使用 XML 编写
  • WSDL 是一种 XML 文档
  • WSDL 用于描述网络服务
  • WSDL 也可用于定位网络服务
  • WSDL 还不是 W3C 标准

如需更多有关 WSDL 的知识，请访问我们的《WSDL 教程》

什么是UDDI？

UDDI 是一种目录服务，通过它，企业可注册并搜索 Web services。

  • UDDI 指通用的描述、发现以及整合（Universal Description, Discovery and Integration）。
  • UDDI 是一种用于存储有关 web services 的信息的目录。
  • UDDI 是一种由 WSDL 描述的网络服务接口目录。
  • UDDI 经由 SOAP 进行通迅。
  • UDDI 被构建于 Microsoft .NET 平台之中。
  • Previous Page
  • Next Page


Why Web Services?

Web Services 基础

  • WS 首页
  • WS 简介
  • Why WS?
  • WS 平台
  • WS 实例
  • WS 使用
  • WS 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

Why Web Services?

  • Previous Page
  • Next Page

几年前，Web services 的速度还没有快到让人们产生兴趣的程度。

感谢主要的 IT 开发商近年来的努力，大多数的人们和企业拥有了宽带连接，并越来越多地使用 Web。

最重要的事情是协同工作

由于所有主要的平台均可通过 Web 浏览器来访问 Web，不同的平台可以借此进行交互。为了让这些平台协同工作，Web 应用程序被开发了出来。

Web 应用程序是运行在 Web 上的简易应用程序。它们围绕 Web 浏览器标准被进行构建，几乎可被任何平台之上的任何浏览器来使用。

Web services 把 Web 应用程序提升到了另外一个层面

通过使用 Web services，您的应用程序可向全世界发布功能或消息。

Web services 使用 XML 来编解码数据，并使用 SOAP 借由开放的协议来传输数据。

通过 Web services，您的会计部门的 Win 2k 服务器可与 IT 供应商的 UNIX 服务器进行连接。

Web services 有两种类型的应用

可重复使用的应用程序组件

有一些功能是不同的应用程序常常会用到的。那么为什么要周而复始地开发它们呢？

Web services 可以把应用程序组件作为服务来提供，比如汇率转换、天气预报或者甚至是语言翻译等等。

比较理想的情况是，每种应用程序组件只有一个最优秀的版本，这样任何人都可以在其应用程序中使用它。

连接现有的软件

通过为不同的应用程序提供一种链接其数据的途径，Web services有助于解决协同工作的问题。

通过使用 Web services，您可以在不同的应用程序与平台之间来交换数据。

  • Previous Page
  • Next Page


您已经学习了 Web Services,下一步学习什么内容呢？

Web Services 基础

  • WS 首页
  • WS 简介
  • Why WS?
  • WS 平台
  • WS 实例
  • WS 使用
  • WS 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

您已经学习了 Web Services,下一步学习什么内容呢？

  • Previous Page
  • Next Page

Web Services 概要

本教程已经向您讲解了如何把应用程序转换为网络应用程序.

您已经学习了如何使用 XML 在应用程序间发送消息。

您也学习了如何从应用程序导出某项功能（创建一个 web service）。

您已经学习了 Web Services,下一步呢？

下一步您应当学习 WSDL 和 SOAP。

WSDL

WSDL 是基于 XML 的用来描述 Web services 以及如何访问它们的一种语言。

WSDL 可描述 web service，连同用于 web service 的消息格式和协议的细节。

如果您希望学习更多有关 WSDL 的知识，请访问我们的《WSDL 教程》。

SOAP

SOAP 是一种使应用程序有能力通过 HTTP 交换信息的基于 XML 的简易协议。

或者可以更简单地说：SOAP 是一种用于访问 web service 的协议。

如果您希望学习更多有关 SOAP 的知识，请访问我们的《SOAP 教程》。

  • Previous Page
  • Next Page


WMLScript abort() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript abort() 函数

返回 WMLScript Lang 库参考手册

abort() 函数中止 WMLScript，并向该脚本的调用者返回一条消息。

语法

Lang.abort(text)
成分 | 描述
text | 一个字符串。

例子

var errtxt = "Illegal value";
Lang.abort("Error in function: " + errtxt);

结果

The script is aborted, and the string "Error in function: Illegal value"
is returned to the caller of the script.

返回 WMLScript Lang 库参考手册

WMLScript 库 参考手册


WMLScript abs() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript abs() 函数

返回 WMLScript Lang 库参考手册

abs() 函数返回一个数的绝对值。

语法

n = Lang.abs(x)
成分 | 描述
n | 从函数返回的绝对值。
x | 计算这个数的绝对值。

例子

var a = Lang.abs(-5);
var b = Lang.abs(-3.4);

结果

a = 5
b = 3.4

返回 WMLScript Lang 库参考手册

WMLScript 库 参考手册


WMLScript alert() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript alert() 函数

返回 WMLScript Dialogs 库参考手册

alert() 函数显示一条消息，等待确认，然后返回一个空字符串。

语法

n = Dialogs.alert(message)
成分 | 描述
n | 该函数返回的空字符串。
message | 包含消息的字符串。

例子

var a = Dialogs.alert("The value must be numeric!");

结果

a = ""

返回 WMLScript Dialogs 库参考手册

WMLScript 库 参考手册


WMLScript ceil() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript ceil() 函数

返回 WMLScript Float 库参考手册

ceil() 函数返回不小于 x 参数值的最接近的整数。

语法

n = Float.ceil(x)
成分 | 描述
n | 该函数返回的整数。
x | 一个数。

例子

var a = Float.ceil(5.32);
var b = Float.ceil(5.55);
var c = Float.ceil(-5.32);

结果

a = 6
b = 6
c = -5

返回 WMLScript Float 库参考手册

WMLScript 库 参考手册


WMLScript characterSet() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript characterSet() 函数

返回 WMLScript Lang 库参考手册

characterSet() 函数返回 WMLScript 解释器所支持的字符集。

语法

n = Lang.characterSet()
成分 | 描述
n | 从函数返回的定义字符集的整数。

例子

var a = Lang.characterSet();

结果

a = 4

返回 WMLScript Lang 库参考手册

WMLScript 库 参考手册


WMLScript charAt() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript charAt() 函数

返回 WMLScript String 库参考手册

charAt() 函数返回位于指定位置的字符。

语法

n = String.charAt(string, index)
成分 | 描述
n | 从函数返回的字符串。
string | 一个字符串。
index | 规定在字符串中的下标位置的一个数。

例子

var a = String.charAt("world",2);
var b = String.charAt("world",0);
var c = String.charAt("world",10);

结果

a = "r"
b = "w"
c = ""

返回 WMLScript String 库参考手册

WMLScript 库 参考手册


WMLScript compare() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript compare() 函数

返回 WMLScript String 库参考手册

compare() 函数比较两个字符串，并返回一个表示比较结果的值。

compare() 函数可返回下列值：

  • -1 (if string1 < string2)
  • 0 (if string1 = string2)
  • 1 (if string1 > string2)

语法

n = String.compare(string1, string2)
成分 | 描述
n | 从函数返回的整数。
string1 | 一个字符串。
string2 | 一个字符串。

例子

var a = String.compare("world","world");
var b = String.compare("I","world");
var c = String.compare("world","I");

结果

a = 0
b = -1
c = 1

返回 WMLScript String 库参考手册

WMLScript 库 参考手册


WMLScript confirm() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript confirm() 函数

返回 WMLScript Dialogs 库参考手册

confirm() 函数显示一条消息，等待回答 ，然后根据用户所选的回答返回一个布尔值。如果用户选择 ok，则返回 true，如果用户选择 cancel，则选择 false。

语法

n = Dialogs.confirm(message, ok, cancel)
成分 | 描述
n | 从该函数返回的布尔值。
message | 包含消息的字符串。
ok | 包含 OK 文本的字符串。
cancel | 包含 cancel 文本的字符串。

例子

var a = Dialogs.confirm("Exit?","Yes","No");

结果

a = true (if "Yes" is selected)
a = false (if "No" is selected)

返回 WMLScript Dialogs 库参考手册

WMLScript 库 参考手册


WMLScript Dialogs 库

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript Dialogs 库

  • Previous Page
  • Next Page
Dialogs 库中包含了显示警告信息的函数，该函数库包含典型的用户界面程序。

WMLScript Dialogs 库的函数

函数 | 描述
alert() | 显示一条消息，并等待确认。
confirm() | 显示一条消息，并等待回答。
prompt() | 显示一个问题，并等待输入。
  • Previous Page
  • Next Page

WMLScript 库 参考手册


WMLScript elementAt() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript elementAt() 函数

返回 WMLScript String 库参考手册

elementAt() 函数把字符串划分为元素，并返回位于指定下标位置的元素。

语法

n = String.elementAt(string, index, separator)
成分 | 描述
n | 从函数返回的字符串。
string | 要解析的字符串。
index | 一个整数，定义被返回的部分。
separator | 分隔字符串的分隔符。

注释：如果 index 是负数，则返回第一个元素。如果 index 的值太大，则返回最后一个元素。

例子

var a= String.elementAt("Visit W3School today",0," ");
var b= String.elementAt("Visit W3School today",1," ");
var c= String.elementAt("Visit W3School today",2," ");
var d= String.elementAt("Apples+Bananas",0,"+");
var e= String.elementAt("Apples+Bananas",1,"+");
var f= String.elementAt("Apples+Bananas",5,"+");

结果

a = "Visit"
b = "W3School"
c = "today"
d = "Apples"
e = "Bananas"
f = "Bananas"

返回 WMLScript String 库参考手册

WMLScript 库 参考手册


WMLScript elements() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript elements() 函数

返回 WMLScript String 库参考手册

elements() 函数返回指定的值在字符串中出现的次数。

语法

n = String.elements(string, separator)
成分 | 描述
n | 在 separator 中规定的字符串在字符串 string 中出现的次数。
string | 被检索的字符串。
separator | 在字符串中搜索的字符串值。

例子

var a = String.elements("Visit W3School!","i");
var b = String.elements("Visit W3School!","V");
var c = String.elements("Visit W3School!"," ");

结果

a = 2
b = 1
c = 1

返回 WMLScript String 库参考手册

WMLScript 库 参考手册


WMLScript escapeString() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript escapeString() 函数

返回 WMLScript URL 库参考手册

escapeString() 函数用转义序列替换 URL 中的特殊字符，并返回结果。

语法

n = URL.escapeString(url)
成分 | 描述
n | 从函数返回的字符串。
url | 一个字符串。

例子

var a = URL.escapeString("http://w3School.com.cn/wml/");

结果

a = "http%3a%2f%2fw3School.com.cn%2fwml%2f"

返回 WMLScript URL 库参考手册

WMLScript 库 参考手册


WMLScript exit() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript exit() 函数

返回 WMLScript Lang 库参考手册

exit() 函数退出 WMLScript，并向该脚本的调用者返回一条消息。

语法

Lang.exit(value)
成分 | 描述
value | 任何值。

例子

Lang.exit("Value is 500");

结果

脚本结束，值 "Value is: 500" 返回脚本的调用者。

返回 WMLScript Lang 库参考手册

WMLScript 库 参考手册


WMLScript find() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript find() 函数

返回 WMLScript String 库参考手册

find() 函数返回在字符串中子字符串的位置。

语法

n = String.find(string, substring)
成分 | 描述
n | 从函数返回的整数。
string | 被检索的字符串。
substring | 在字符串中搜索的字符串值。

例子

var a = String.find("world","rl");
var b = String.find("world","hi");
var c = String.find("world","wo");

结果

a = 2
b = -1
c = 0

返回 WMLScript String 库参考手册

WMLScript 库 参考手册


WMLScript Float 库

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript Float 库

  • Previous Page
  • Next Page

Float 函数库包括了一系列数学函数。

WMLScript Float 库的函数

Float 函数库只在支持浮点数的客户机上有效。如果客户机不支持浮点数，则其所有函数返回 invalid。

函数 | 描述
ceil(x) | 返回不小于指定数字的最接近的整数。
floor(x) | 返回不大于指定数字的最接近的整数。
int(x) | 返回指定数字的整数部分。
maxFloat() | 返回最大的可能的浮点数。
minFloat() | 返回最小的可能的浮点数。
pow(x,y) | 返回 x 的 y 次方。
round(x) | 把一个数字舍入为最接近的整数。
sqrt(x) | 返回一个数的平方根。
  • Previous Page
  • Next Page

WMLScript 库 参考手册


WMLScript float() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript float() 函数

返回 WMLScript Lang 库参考手册

float() 函数返回一个布尔值，该值指示是否支持浮点数。

语法

n = Lang.float()
成分 | 描述
n | 从函数返回的布尔值。指示是否支持浮点数。

例子

var a = Lang.float();

结果

var a = true

返回 WMLScript Lang 库参考手册

WMLScript 库 参考手册


WMLScript floor() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript floor() 函数

返回 WMLScript Float 库参考手册

floor() 函数返回不大于 x 参数值的最接近的整数。

语法

n = Float.floor(x)
成分 | 描述
n | 该函数返回的整数。
x | 一个数。

例子

var a = Float.floor(5.32);
var b = Float.floor(-5.32);

结果

a = 5
b = -6

返回 WMLScript Float 库参考手册

WMLScript 库 参考手册


WMLScript format() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript format() 函数

返回 WMLScript String 库参考手册

format() 函数格式化一个值。

语法

n = String.format(format, value)
成分 | 描述
n | 从函数返回的字符串。
format | 规定如何格式化值。
value | 被格式化的值。

format 由三个部分组成：%width.precision type

width - 可选。规定所输出字符的最小数目。

precision - 可选。设置输出值的精度。可采用下列值：

  • d - 输出的最小位数。默认是 1。
  • f - 小数点后的位数。默认是 6。
  • s - 输出的最大字符数。默认输出所有字符。

type - 必需。确定如何解释被格式化的值。可采用下列的值：

  • d - 整数
  • f - 浮点数
  • s - 字符串

例子

var b = String.format("%4.3d", 32);
var d = String.format("%3f", 10.1234);
var e = String.format("%2.2f", 2.3)

结果

b = " 032"
d = "10.123"
e = "2.30"

返回 WMLScript String 库参考手册

WMLScript 库 参考手册


WMLScript getCurrentCard() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript getCurrentCard() 函数

返回 WMLScript WMLBrowser 库参考手册

getCurrentCard() 函数返回当前卡片的（相对）URL。

语法

n = WMLBrowser.getCurrentCard()
成分 | 描述
n | 该函数返回的字符串。

例子

var a = WMLBrowser.getCurrentCard();

结果

a = "card1#note"

返回 WMLScript WMLBrowser 库参考手册

WMLScript 库 参考手册


WMLScript getFragment() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript getFragment() 函数

返回 WMLScript URL 库参考手册

getFragment() 函数返回 URL 参数中的片段。

语法

n = URL.getFragment(url)
成分 | 描述
n | 从函数返回的字符串。
url | 一个字符串。

例子

var a = URL.getFragment("http://w3school.com.cn/wml#read");
var b = URL.getFragment("http://w3school.com.cn/wml");

结果

a = "read"
b = ""

返回 WMLScript URL 库参考手册

WMLScript 库 参考手册


WMLScript getHost() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript getHost() 函数

返回 WMLScript URL 库参考手册

getHost() 函数返回在 url 参数中规定的主机。

语法

n = URL.getHost(url)
成分 | 描述
n | 从函数返回的字符串。
url | 一个字符串。

例子

var a = URL.getHost("http://www.w3school.com.cn/wml");
var b = URL.getHost("/wml/functions");

结果

a = "www.w3school.com.cn"
b = ""

返回 WMLScript URL 库参考手册

WMLScript 库 参考手册


WMLScript getParameters() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript getParameters() 函数

返回 WMLScript URL 库参考手册

getParameters() 函数返回 URL 的最后一个路径片段中的参数。

语法

n = URL.getParameters(url)
成分 | 描述
n | 从函数返回的字符串。
url | 一个字符串。

例子

var a = URL.getParameters("http://w3school.com.cn/wml;tip");
var b = URL.getParameters("http://w3school.com.cn/wml");

结果

a = "tip"
b = ""

返回 WMLScript URL 库参考手册

WMLScript 库 参考手册


WMLScript getPath() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript getPath() 函数

返回 WMLScript URL 库参考手册

getPath() 函数返回 URL 中规定的路径。

语法

n = URL.getPath(url)
成分 | 描述
n | 从函数返回的字符串。
url | 一个字符串。

例子

var a = URL.getPath("http://w3school.com.cn/wml/tips.htm");
var b = URL.getPath("http://w3school.com.cn");

结果

a = "/wml/tips.htm"
b = ""

返回 WMLScript URL 库参考手册

WMLScript 库 参考手册


WMLScript getPort() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript getPort() 函数

返回 WMLScript URL 库参考手册

getPort() 函数返回 URL 中规定的端口号。

语法

n = URL.getPort(url)
成分 | 描述
n | 从函数返回的字符串。
url | 一个字符串。

例子

var a = URL.getPort("http://w3school.com.cn:80");
var b = URL.getPort("http://w3school.com.cn");

结果

a = "80"
b = ""

返回 WMLScript URL 库参考手册

WMLScript 库 参考手册


WMLScript getQuery() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript getQuery() 函数

返回 WMLScript URL 库参考手册

getPort() 函数返回 URL 中的查询部分。

语法

n = URL.getQuery(url)
成分 | 描述
n | 从函数返回的字符串。
url | 一个字符串。

例子

var a=URL.getQuery("http://example.com/go.asp?name=bill");
var b=URL.getQuery("http://example.com");

结果

a = "bill"
b = ""

返回 WMLScript URL 库参考手册

WMLScript 库 参考手册


WMLScript getScheme() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript getScheme() 函数

返回 WMLScript URL 库参考手册

getScheme() 函数返回 URL 中的 scheme。

语法

n = URL.getQuery(url)
成分 | 描述
n | 从函数返回的字符串。
url | 一个字符串。

例子

var a = URL.getScheme("http://www.w3school.com.cn");
var b = URL.getScheme("www.w3school.com.cn");
var c = URL.getScheme("ftp://www.w3school.com.cn");

结果

a = "http"
b = ""
c = "ftp"

返回 WMLScript URL 库参考手册

WMLScript 库 参考手册


WMLScript getVar() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript getVar() 函数

返回 WMLScript WMLBrowser 库参考手册

getVar() 函数返回浏览器环境中指定变量的值。

如果该变量不存在，此函数返回空字符串 ("")。

语法

n = WMLBrowser.getVar(variable)
成分 | 描述
n | 该函数返回的字符串。
variable | 一个字符串。

例子

var a = WMLBrowser.getVar("weeks");

结果

a = "52"

返回 WMLScript WMLBrowser 库参考手册

WMLScript 库 参考手册


WMLScript go() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript go() 函数

返回 WMLScript WMLBrowser 库参考手册

go() 函数转向一个新卡片（由新的 url 规定），并返回一个空字符串。

语法

n = WMLBrowser.go(url)
成分 | 描述
n | 该函数返回的字符串。
url | 一个字符串。

例子

var a = WMLBrowser.go(card);

结果

a = ""

返回 WMLScript WMLBrowser 库参考手册

WMLScript 库 参考手册


WMLScript insertAt() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript insertAt() 函数

返回 WMLScript String 库参考手册

insertAt() 函数把字符串划分为元素，并在指定的下标位置插入一个子字符串。

语法

n = String.insertAt(string, substring, index, separator)
成分 | 描述
n | 从函数返回的字符串。
string | 原始的字符串。
substring | 要插入原始字符串的子字符串。
index | 一个整数，规定在何处插入子字符串。
separator | 分隔符。

例子

var a = String.insertAt("Visit W3School!","us at",1," ");

结果

a = "Visit us at W3School!"

返回 WMLScript String 库参考手册

WMLScript 库 参考手册


WMLScript int() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript int() 函数

返回 WMLScript Float 库参考手册

int() 函数返回 x 参数值的整数部分。

语法

n = Float.int(x)
成分 | 描述
n | 该函数返回的整数。
x | 一个数。

例子

var a = Float.int(5.32);

结果

a = 5

返回 WMLScript Float 库参考手册

WMLScript 库 参考手册


WMLScript isEmpty() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript isEmpty() 函数

返回 WMLScript String 库参考手册

isEmpty() 函数检查字符串是否是空的。

语法

n = String.isEmpty(string)
成分 | 描述
n | 从函数返回的布尔值。
string | 一个字符串。

例子

var a = String.isEmpty("");
var b = String.isEmpty("Hello world");
var c = String.isEmpty(23.4);

结果

a = true
b = false
c = false

返回 WMLScript String 库参考手册

WMLScript 库 参考手册


WMLScript isFloat() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript isFloat() 函数

返回 WMLScript Lang 库参考手册

isFloat() 函数返回一个布尔值，指示是否能够通过 parseFloat() 函数把一个值转换为浮点数。如果可以，则返回 true，否则返回 false。

语法

n = Lang.isFloat(value)
成分 | 描述
n | 从函数返回的布尔值。
value | 任何值。

例子

var a = Lang.isFloat("576");
var b = Lang.isFloat("-576");
var c = Lang.isFloat("6.5");
var d = Lang.isFloat(" -9.45e2");
var e = Lang.isFloat("@13");
var f = Lang.isFloat("hello");

结果

a = true
b = true
c = true
d = true
e = false
f = false

返回 WMLScript Lang 库参考手册

WMLScript 库 参考手册


WMLScript isInt() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript isInt() 函数

返回 WMLScript Lang 库参考手册

isInt() 函数返回一个布尔值，指示是否能够通过 parseInt() 函数把一个值转换为整数。如果可以，则返回 true，否则返回 false。

语法

n = Lang.isInt(value)
成分 | 描述
n | 从函数返回的布尔值。
value | 任何值。

例子

var a = Lang.isInt("576");
var b = Lang.isInt("-576");
var c = Lang.isInt("6.5");
var d = Lang.isInt("@13");
var e = Lang.isInt("hello");

结果

a = true
b = true
c = true
d = false
e = false

返回 WMLScript Lang 库参考手册

WMLScript 库 参考手册


WMLScript isValid() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript isValid() 函数

返回 WMLScript URL 库参考手册

isValid() 函数返回一个布尔值，如果指定的 URL 的语法正确，则返回 true，否则返回 false。

语法

n = URL.isValid(url)
成分 | 描述
n | 从函数返回的布尔值。
url | 一个字符串。

例子

var a = URL.isValid("http://www.w3school.com.cn");
var b = URL.isValid("http//www.w3school.com.cn");
var c = URL.isValid("http://www.w3school.com.cn!!!!");

结果

a = "true"
b = "false"
c = "false"

返回 WMLScript URL 库参考手册

WMLScript 库 参考手册


WMLScript Lang 库

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript Lang 库

  • Previous Page
  • Next Page

Lang 函数库包含用于绝对值计算、数据类型操作以及随机数生成的函数。

WMLScript Lang 库的函数

函数 | 描述
abort() | 中止 WMLScript，并向该脚本的调用者返回一条消息。
abs(x) | 返回一个数的绝对值。
characterSet() | 返回 WMLScript 解释器所支持的字符集。
exit() | 退出 WMLScript，并向该脚本的调用者返回一条消息。
float() | 返回一个布尔值，该值指示是否支持浮点数。
isFloat() | 返回一个布尔值，指示是否能够通过 parseFloat() 函数把一个值转换为浮点数。
isInt() | 返回一个布尔值，指示是否能够通过 parseInt() 函数把一个值转换为整数。
max(x,y) | 返回 x 和 y 中的最高值。
maxInt() | 返回可能的最大整数值。
min(x,y) | 返回 x 和 y 中的最小值。
minInt() | 返回可能的最小整数值。
parseFloat() | 返回由一个字符串定义的浮点数。
parseInt() | 返回由一个字符串定义的整数。
random(x) | 返回介于 0 与 x 之间的随机整数。
seed() | 初始化带有一个数字的随机数生成器，并返回一个空字符串。

注释：Lang 函数库的名称容易使人误解，应该命名为 Math 函数库之类的名称。不过之所以它称为 Lang 函数库，是因为这个函数库所含的函数同 WMLScript 语言的核心有很密切的关系。

  • Previous Page
  • Next Page

WMLScript 库 参考手册


WMLScript length() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript length() 函数

返回 WMLScript String 库参考手册

length() 函数返回字符串的长度。

语法

n = String.length(string)
成分 | 描述
n | 从函数返回的字符串的长度。
string | 一个字符串。

例子

var a = String.length("");
var b = String.length("Hello world");
var c = String.length(23.4);

结果

a = 0
b = 11
c = 4

返回 WMLScript String 库参考手册

WMLScript 库 参考手册


WMLScript max() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript max() 函数

返回 WMLScript Lang 库参考手册

max() 函数返回 x 和 y 中的最高值。

语法

n = Lang.max(x,y)
成分 | 描述
n | 从函数返回的数。
x | 一个数。
y | 一个数。

例子

var a = Lang.max(20, 40.3);
var b = Lang.max(60, 59.7);

结果

a = 40.3
b = 60

返回 WMLScript Lang 库参考手册

WMLScript 库 参考手册


WMLScript maxFloat() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript maxFloat() 函数

返回 WMLScript Float 库参考手册

maxFloat() 函数返回最大的可能的浮点数。

语法

n = Float.maxFloat()
成分 | 描述
n | 该函数返回的最大的可能的浮点数(3.40282347E+38)。

例子

var a = Float.maxFloat();

结果

a = 3.40282347E+38

返回 WMLScript Float 库参考手册

WMLScript 库 参考手册


WMLScript maxInt() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript maxInt() 函数

返回 WMLScript Lang 库参考手册

maxInt() 函数返回可能的最大整数值。

语法

n = Lang.maxInt()
成分 | 描述
n | 从函数返回的最大整数。

例子

var a = Lang.maxInt();

结果

a = 2147483647

返回 WMLScript Lang 库参考手册

WMLScript 库 参考手册


WMLScript min() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript min() 函数

返回 WMLScript Lang 库参考手册

min() 函数返回 x 和 y 中的最小值。

语法

n = Lang.min(x,y)
成分 | 描述
n | 从函数返回的数。
x | 一个数。
y | 一个数。

例子

var a = Lang.min(20, 40.3);
var b = Lang.min(60, 59.7);

结果

a = 20
b = 59.7

返回 WMLScript Lang 库参考手册

WMLScript 库 参考手册


WMLScript minFloat() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript minFloat() 函数

返回 WMLScript Float 库参考手册

minFloat() 函数返回最小的可能的浮点数。

语法

n = Float.minFloat()
成分 | 描述
n | 该函数返回的最小的可能的浮点数 (1.17549435-38)。

例子

var a = Float.minFloat();

结果

a = 1.17549435-38

返回 WMLScript Float 库参考手册

WMLScript 库 参考手册


WMLScript minInt() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript minInt() 函数

返回 WMLScript Lang 库参考手册

minInt() 函数返回可能的最小整数值。

语法

n = Lang.minInt()
成分 | 描述
n | 从函数返回的最小整数。

例子

var a = Lang.minInt();

结果

a = -2147483648

返回 WMLScript Lang 库参考手册

WMLScript 库 参考手册


WMLScript newContext() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript newContext() 函数

返回 WMLScript WMLBrowser 库参考手册

newContext() 函数清空 WML 环境中的所有变量，并返回一个空字符串。

语法

n = WMLBrowser.go(url)
成分 | 描述
n | 该函数返回的空字符串。

例子

var a = WMLBrowser.newContext();

结果

a = ""

返回 WMLScript WMLBrowser 库参考手册

WMLScript 库 参考手册


WMLScript parseFloat() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript parseFloat() 函数

返回 WMLScript Lang 库参考手册

parseFloat() 函数返回由一个字符串定义的浮点数。

解析会在第一个不能作为浮点值解析的字符上结束。

语法

n = Lang.parseFloat(string)
成分 | 描述
n | 从函数返回的浮点值。
string | 一个字符串。

例子

var a = Lang.parseFloat("2345.14");
var b = Lang.parseFloat(" -4.45e2 Kg");
var c = Lang.parseFloat(" +4.45e2 Kg");
var d = Lang.parseFloat("-.3 C");
var e = Lang.parseFloat(" 300 ");

结果

a = 2345.14
b = -4.45e2
c = 4.45e2
d = -0.3
e = 300.0

返回 WMLScript Lang 库参考手册

WMLScript 库 参考手册


WMLScript parseInt() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript parseInt() 函数

返回 WMLScript Lang 库参考手册

parseInt() 函数返回由一个字符串定义的浮点数。

语法

n = Lang.parseInt(string)
成分 | 描述
n | 从函数返回的整数。
string | 一个字符串。

例子

var a = Lang.parseInt("2345");
var b = Lang.parseInt("200 m/s");

结果

a = 2345
b = 200

返回 WMLScript Lang 库参考手册

WMLScript 库 参考手册


WMLScript pow() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript pow() 函数

返回 WMLScript Float 库参考手册

pow() 函数返回 x 的 y 次方。

语法

n = Float.pow(x,y)
成分 | 描述
n | 该函数返回的浮点数。
x | 数字。
y | 数字。

例子

var a = Float.pow(4,2);
var b = Float.pow(-2,3);

结果

a = 16
b = -8

返回 WMLScript Float 库参考手册

WMLScript 库 参考手册


WMLScript prev() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript prev() 函数

返回 WMLScript WMLBrowser 库参考手册

prev() 函数告诉 WML 浏览器退回前面的卡片，并返回一个空字符串。

语法

n = WMLBrowser.prev()
成分 | 描述
n | 该函数返回的空字符串。

例子

var a = WMLBrowser.prev();

结果

a = ""

返回 WMLScript WMLBrowser 库参考手册

WMLScript 库 参考手册


WMLScript prompt() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript prompt() 函数

返回 WMLScript Dialogs 库参考手册

prompt() 函数显示一条消息，并等待输入。第二个参数是默认的输入值，如果用户没有输入值，就会返回这个值。该函数返回用户输入的值或默认值。

语法

n = Dialogs.prompt(message, defaultinput)
成分 | 描述
n | 从该函数返回的字符串。
message | 包含消息（问题）的字符串。
defaultinput | 包含默认输入（回答）的字符串。

例子

var a = Dialogs.prompt("Enter a number:","3");

结果

a = "5" (if the user entered the value 5)
a = "3" (if the user did not enter a value)

返回 WMLScript Dialogs 库参考手册

WMLScript 库 参考手册


WMLScript random() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript random() 函数

返回 WMLScript Lang 库参考手册

random() 函数返回介于 0 和 x 之间的随机整数。

语法

n = Lang.random(x)
成分 | 描述
n | 从函数返回的随机整数。
x | 一个数。

例子

var a = Lang.random(6.5);

结果

a = 介于 0 与 6 之间的随机整数

返回 WMLScript Lang 库参考手册

WMLScript 库 参考手册


WMLScript refresh() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript refresh() 函数

返回 WMLScript WMLBrowser 库参考手册

refresh() 函数刷新当前卡片，如果刷新成功，则返回一个空字符串。如果失败，则返回一个非空字符串。

语法

n = WMLBrowser.refresh()
成分 | 描述
n | 该函数返回的字符串。

例子

var a = WMLBrowser.setVar("day",11);
var b = WMLBrowser.refresh();

结果

a = true
b = ""

返回 WMLScript WMLBrowser 库参考手册

WMLScript 库 参考手册


WMLScript removeAt() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript removeAt() 函数

返回 WMLScript String 库参考手册

removeAt() 函数把字符串划分为元素，并删除指定的元素。

语法

n = String.removeAt(string, index, separator)
成分 | 描述
n | 从函数返回的字符串。
string | 原始字符串。
index | 要删除的元素的下标。
separator | 分隔符。

例子

var a = String.removeAt("Visit W3School!",0," ");
var b = String.removeAt("Visit W3School!",0,"W");
var c = String.removeAt("Visit W3School!",-2," ");
var d = String.removeAt("Visit W3School!",10," ");

结果

a = "W3School!"
b = "3School!"
c = "W3School!"
d = "Visit"

返回 WMLScript String 库参考手册

WMLScript 库 参考手册


WMLScript replace() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript replace() 函数

返回 WMLScript String 库参考手册

replace() 函数用一个新字符串替换字符串中的一个部分，并返回结果。

语法

n = String.replace(string, oldvalue, newvalue)
成分 | 描述
n | 从函数返回的字符串。
string | 原始字符串。
oldvalue | 将被替换的值。
newvalue | 将替换 oldvalue 的值。

例子

var a = String.replace("world","wor","bo");
var b = String.replace("world", "ld","ry");

结果

a = "bold"
b = "worry"

返回 WMLScript String 库参考手册

WMLScript 库 参考手册


WMLScript replaceAt() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript replaceAt() 函数

返回 WMLScript String 库参考手册

replaceAt() 函数把字符串划分为元素，并替换一个指定的元素。

语法

n = String.replaceAt(string, substring, index, separator)
成分 | 描述
n | 从函数返回的字符串。
string | 原始字符串。
substring | 替换在字符串中指定元素的字符串。
index | 一个整数，规定在何处替换子字符串。
separator | 分隔符。

例子

var a = String.replaceAt("Visit W3School!","I love",0," ");
var b = String.replaceAt("Visit W3School!","us!",2," ");

结果

a = "I love W3School!"
b = "Visit us!"

返回 WMLScript String 库参考手册

WMLScript 库 参考手册


WMLScript resolve() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript resolve() 函数

返回 WMLScript URL 库参考手册

resolve() 函数根据一个基准 URL 和 一个相对 URL 返回一个绝对 URL。

语法

n = URL.resolve(baseurl, relativeurl)
成分 | 描述
n | 从函数返回的字符串。
baseurl | 一个字符串。
relativeurl | 一个字符串。

例子

var a=URL.resolve("http://w3school.com.cn", "/wml/n.wml");

结果

a = "http://w3school.com.cn/wml/n.wml"

返回 WMLScript URL 库参考手册

WMLScript 库 参考手册


WMLScript round() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript round() 函数

返回 WMLScript Float 库参考手册

round() 函数把一个数字舍入为最接近的整数。

语法

n = Float.round(x)
成分 | 描述
n | 该函数返回的整数。
x | 数字。

例子

var a = Float.round(3.5);
var b = Float.round(3.4);

结果

a = 4
b = 3

返回 WMLScript Float 库参考手册

WMLScript 库 参考手册


WMLScript seed() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript seed() 函数

返回 WMLScript Lang 库参考手册

seed() 函数初始化带有一个数字的随机数生成器，并返回一个空字符串。

语法

n = Lang.seed(number)
成分 | 描述
n | 从函数返回的空字符串。
x | 一个数。

例子

var a = Lang.seed(8.2);

结果

a = ""

返回 WMLScript Lang 库参考手册

WMLScript 库 参考手册


WMLScript setVar() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript setVar() 函数

返回 WMLScript WMLBrowser 库参考手册

setVar() 函数设置浏览器环境中指定变量的值。

语法

n = WMLBrowser.setVar(variable, value)
成分 | 描述
n | 该函数返回的布尔值。
variable | 一个字符串。
value | 一个字符串。

例子

var a = WMLBrowser.setVar("weeks", 34);

结果

a = true

返回 WMLScript WMLBrowser 库参考手册

WMLScript 库 参考手册


WMLScript sqrt() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript sqrt() 函数

返回 WMLScript Float 库参考手册

sqrt() 函数返回一个数的平方根。

语法

n = Float.sqrt(x)
成分 | 描述
n | 该函数返回的浮点数。
x | 数字。

例子

var a = Float.sqrt(9);
var b = Float.sqrt(6.25);

结果

a = 3
b = 2.5

返回 WMLScript Float 库参考手册

WMLScript 库 参考手册


WMLScript squeeze() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript squeeze() 函数

返回 WMLScript String 库参考手册

squeeze() 函数把字符串中的所有连续空白压缩为单独的空格。

语法

n = String.squeeze(string)
成分 | 描述
n | 从函数返回的字符串。
string | 一个字符串。

例子

var a = String.squeeze("Visit   W3School!\r\n");

结果

a = "Visit W3School "

返回 WMLScript String 库参考手册

WMLScript 库 参考手册


WMLScript String 库

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript String 库

  • Previous Page
  • Next Page

String 函数库包含用于文本操作的函数。

WMLScript String 库的函数

函数 | 描述
charAt() | 返回位于指定位置的字符。
compare() | 比较两个字符串，并返回一个表示比较结果的值。
elementAt() | 把字符串划分为元素，并返回指定的元素。
elements() | 返回指定的值在字符串中出现的次数。
find() | 返回在字符串中子字符串的位置。
format() | 格式化一个值。
insertAt() | 把字符串划分为元素，并在指定的下标位置插入一个子字符串。
isEmpty() | 检查字符串是否是空的。
length() | 返回字符串的长度。
removeAt() | 把字符串划分为元素，并删除指定的元素。
replace() | 用一个新的字符串替换字符串中的一个部分。
replaceAt() | 把字符串划分为元素，并替换一个指定的元素。
squeeze() | 把字符串中的所有连续空格压缩为一个单独的空格。
subString() | 返回字符串的指定部分。
toString() | 把一个值转换为字符串。
trim() | 返回去掉开头和结尾空格后的字符串。
  • Previous Page
  • Next Page

WMLScript 库 参考手册


WMLScript subString() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript subString() 函数

返回 WMLScript String 库参考手册

subString() 函数返回字符串的指定部分。

语法

n = String.subString(string, start, length)
成分 | 描述
n | 从函数返回的新字符串。
string | 原始字符串。
start | 开始点。
length | 规定新字符串的长度。

例子

var a = String.subString("world",2,2);
var b = String.subString("world",0,5);
var c = String.subString("world",-2,3);
var d = String.subString("world",2,10);
var e = String.subString("world",10,10);

结果

a = "rl"
b = "world"
c = "wor"
d = "rld"
e = ""

返回 WMLScript String 库参考手册

WMLScript 库 参考手册


WMLScript toString() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript toString() 函数

返回 WMLScript String 库参考手册

toString() 函数把一个值转换为字符串。

语法

n = String.toString(value)
成分 | 描述
n | 从函数返回的字符串。
value | 任何值。

例子

var a = String.toString(66);
var b = String.toString(world);

结果

a = "66"
b = "world"

返回 WMLScript String 库参考手册

WMLScript 库 参考手册


WMLScript trim() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript trim() 函数

返回 WMLScript String 库参考手册

trim() 函数返回去掉开头和结尾空格后的字符串。

语法

n = String.trim(string)
成分 | 描述
n | 从函数返回的字符串。
string | 一个字符串。

例子

var a = String.trim(" Visit W3School ");

结果

a = "Visit W3School"

返回 WMLScript String 库参考手册

WMLScript 库 参考手册


WMLScript unescapeString() 函数

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript unescapeString() 函数

返回 WMLScript URL 库参考手册

unescapeString() 函数用字符替换 URL 中的转义序列。

语法

n = URL.unescapeString(string)
成分 | 描述
n | 从函数返回的字符串。
string | 一个字符串。

例子

var a=URL.unescapeString("http%3a%2f%2fw3s.com%2wml");

结果

a = "http://w3s.com/wml"

返回 WMLScript URL 库参考手册

WMLScript 库 参考手册


WMLScript URL 库

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript URL 库

  • Previous Page
  • Next Page

URL 函数库含有供处理 URL 的函数。

WMLScript URL 库的函数

函数 | 描述
escapeString() | 用转义序列替换 URL 中的特殊字符。
getBase() |
getFragment() | 返回 URL 中的片段。
getHost() | 返回 URL 中规定的主机名。
getParameters() | 返回 URL 的最后一个路径片段中的参数。
getPath() | 返回 URL 中规定的路径。
getPort() | 返回 URL 中规定的端口号。
getQuery() | 返回 URL 中的查询部分。
getReferer() |
getScheme() | 返回 URL 中的 scheme。
isValid() | 如果 URL 的语法正确，则返回 true，否则返回 false。
loadString() | 返回指定 URL 的内容和内容类型。
resolve() | 根据一个基准 URL 和 一个相对 URL 返回一个绝对 URL。
unescapeString() | 用字符替换 URL 中的转义序列。
  • Previous Page
  • Next Page

WMLScript 库 参考手册


WMLScript WMLBrowser 库

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript WMLBrowser 库

  • Previous Page
  • Next Page

WMLBrowser 函数库。

WMLScript WMLBrowser 库的函数

函数 | 描述
getCurrentCard() | 返回当前卡片的（相对）URL。
getVar() | 返回变量的值。
go() | 前往新的卡片。
newContext() | 清空所有变量。
prev() | 前往之前的卡片。
refresh() | 刷新当前卡片。
setvar() | 设置变量的值。
  • Previous Page
  • Next Page

WMLScript 库 参考手册


WMLScript 简介

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript 简介

  • Previous Page
  • Next Page

您应当具备的基础知识

在继续学习之前，您需要对下面的知识有基本的了解：

  • HTML
  • JavaScript
  • WML

如果您希望首先学习这些项目，请在我们的首页访问这些教程。

什么是 WML？

WML 指无线标记语言。它是一种从 HTML 继承而来的标记语言，但是 WML 基于 XML，因此它较 HTML 更严格。

WML 是可用于显示在 WAP 浏览器中的页面。使用 WML 编写的页面被称为 DECKS。DECKS 是作为一套 CARDS 被构造的。

什么是 WMLScript？

  • WMLScript 是在 WML 页面中使用的脚本语言
  • WMLScript 是一种轻量级的 JavaScript 语言
  • WML 脚本并不嵌在 WML 页面中，WML 页面仅仅包含对脚本 URL 的引用。
  • WML 脚本在 WAP 浏览器运行之前，需要先在服务器上编译为字节编码
  • WML 是 WAP 规范的一部分

WMLScript 可用来做什么？

  • WMLScript 可用于验证用户输入
  • WMLScript 可用于在本地生成消息框和对话框
  • WMLScript 可用于访问用户代理设备
  • Previous Page
  • Next Page

WMLScript 库 参考手册


WMLScript 教程

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WMLScript 教程

  • Next Page

WMLScript 是用于 WML 页面的脚本语言。

WML 页面可以在 WAP 浏览器中显示。

WMLScript 用于验证用户输入、生成对话框、显示出错消息以及访问用户代理设备等等。

开始学习 WMLScript ！

WMLScript 库

在 W3School，我们提供完整的 WMLScript 库参考手册：

  • WMLScript Dialogs 库
  • WMLScript Float 库
  • WMLScript Lang 库
  • WMLScript String 库
  • WMLScript URL 库
  • WMLScript WMLBrowser 库
  • Next Page

WMLScript 库 参考手册


如何调用 WMLScript

WMLScript 教程

  • WMLScript 首页
  • WMLScript 简介
  • WMLScript 调用

WML 库

  • WML Dialogs
  • WML Float
  • WML Lang
  • WML String
  • WML URL
  • WML Browser

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

如何调用 WMLScript

  • Previous Page
  • Next Page

如何从 WML 页面调用 WMLScript

请注意，WMLScripts 不嵌入 WML 页面。WML 页面仅包含对脚本 URL 的引用。

在下面的例子中，如果您选择 go label，外部脚本会把您重定向到 http://www.w3school.com.cn/wmlscript/wap.wml：

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>
<card id="no1" title="Go to URL">
<do type="options" label="Go">
<go href="check.wmls#go_url('W3School')"/>
</do>
</card>
</wml>

上面的蓝色代码包含了对 WMLScript 的引用。脚本位于名为 check.wmls 的文件中，函数名称是 go_url。

这是名为 check.wmls 的 WML 页面：

extern function go_url(the_url)
{
if (the_url=="W3School")
{
WMLBrowser.go("http://www.w3school.com.cn/wmlscript/wap.wml")
}
}

请注意函数使用的关键字 extern。当使用此关键字时，该函数就可以被 .wmls 文件以外的其他函数或事件调用。如果函数是私有函数，则不要使用 extern 关键字。

  • Previous Page
  • Next Page

WMLScript 库 参考手册


WSDL 绑定

WSDL 教程

  • WSDL 首页
  • WSDL 简介
  • WSDL 文档
  • WSDL 端口
  • WSDL 绑定
  • WSDL 和 UDDI
  • WSDL 语法
  • WSDL 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WSDL 绑定

  • Previous Page
  • Next Page

WSDL 绑定可为 web service 定义消息格式和协议细节。

绑定到 SOAP

一个 请求 - 响应 操作的例子：

<message name="getTermRequest">
   <part name="term" type="xs:string" />
</message>

<message name="getTermResponse">
   <part name="value" type="xs:string" />
</message>

<portType name="glossaryTerms">
  <operation name="getTerm">
      <input message="getTermRequest" />
      <output message="getTermResponse" />
  </operation>
</portType>

<binding type="glossaryTerms" name="b1">
<soap:binding style="document"
transport="http://schemas.xmlsoap.org/soap/http" />
  <operation>
    <soap:operation
     soapAction="http://example.com/getTerm" />
    <input>
      <soap:body use="literal" />
    </input>
    <output>
      <soap:body use="literal" />
    </output>
  </operation>
</binding>

binding 元素有两个属性 - name 属性和 type 属性。

name 属性定义 binding 的名称，而 type 属性指向用于 binding 的端口，在这个例子中是 "glossaryTerms" 端口。

soap:binding 元素有两个属性 - style 属性和 transport 属性。

style 属性可取值 "rpc" 或 "document"。在这个例子中我们使用 document。transport 属性定义了要使用的 SOAP 协议。在这个例子中我们使用 HTTP。

operation 元素定义了每个端口提供的操作符。

对于每个操作，相应的 SOAP 行为都需要被定义。同时您必须如何对输入和输出进行编码。在这个例子中我们使用了 "literal"。

  • Previous Page
  • Next Page


WSDL 端口

WSDL 教程

  • WSDL 首页
  • WSDL 简介
  • WSDL 文档
  • WSDL 端口
  • WSDL 绑定
  • WSDL 和 UDDI
  • WSDL 语法
  • WSDL 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WSDL 端口

  • Previous Page
  • Next Page

WSDL 端口可描述由某个 web service 提供的界面（合法操作）。

WSDL 端口

<portType> 元素是最重要的 WSDL 元素。

它可描述一个 web service、可被执行的操作，以及相关的消息。

端口定义了指向某个 web service 的连接点。可以把该元素比作传统编程语言中的一个函数库（或一个模块、或一个类），而把每个操作比作传统编程语言中的一个函数。

操作类型

请求-响应是最普通的操作类型，不过 WSDL 定义了四种类型：

类型 | 定义
One-way | 此操作可接受消息，但不会返回响应。
Request-response | 此操走可接受一个请求并会返回一个响应
Solicit-response | 此操作可发送一个请求，并会等待一个响应。
Notification | 此操作可发送一条消息，但不会等待响应。

One-Way 操作

一个 one-way 操作的例子：

<message name="newTermValues">
   <part name="term" type="xs:string"/>
   <part name="value" type="xs:string"/>
</message>

<portType name="glossaryTerms">
   <operation name="setTerm">
      <input name="newTerm" message="newTermValues"/>
   </operation>
</portType >

在这个例子中，端口 "glossaryTerms" 定义了一个名为 "setTerm" 的 one-way 操作。

这个 "setTerm" 操作可接受新术语表项目消息的输入，这些消息使用一条名为 "newTermValues" 的消息，此消息带有输入参数 "term" 和 "value"。不过，没有为这个操作定义任何输出。

Request-Response 操作

一个 request-response 操作的例子：

<message name="getTermRequest">
   <part name="term" type="xs:string"/>
</message>

<message name="getTermResponse">
   <part name="value" type="xs:string"/>
</message>

<portType name="glossaryTerms">
  <operation name="getTerm">
    <input message="getTermRequest"/>
    <output message="getTermResponse"/>
  </operation>
</portType>

在这个例子中，端口 "glossaryTerms" 定义了一个名为 "getTerm" 的 request-response 操作。

"getTerm" 操作会请求一个名为 "getTermRequest" 的输入消息，此消息带有一个名为 "term" 的参数，并将返回一个名为 "getTermResponse" 的输出消息，此消息带有一个名为 "value" 的参数。

  • Previous Page
  • Next Page


WSDL 和 UDDI

WSDL 教程

  • WSDL 首页
  • WSDL 简介
  • WSDL 文档
  • WSDL 端口
  • WSDL 绑定
  • WSDL 和 UDDI
  • WSDL 语法
  • WSDL 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WSDL 和 UDDI

  • Previous Page
  • Next Page

UDDI 是一种目录服务，企业可以使用它对 Web services 进行注册和搜索。

UDDI，英文为 "Universal Description, Discovery and Integration"，可译为“通用描述、发现与集成服务”。

什么是 UDDI？

UDDI 是一个独立于平台的框架，用于通过使用 Internet 来描述服务，发现企业，并对企业服务进行集成。

  • UDDI 指的是通用描述、发现与集成服务
  • UDDI 是一种用于存储有关 web services 的信息的目录。
  • UDDI 是一种由 WSDL 描述的 web services 界面的目录。
  • UDDI 经由 SOAP 进行通信
  • UDDI 被构建入了微软的 .NET 平台

UDDI 基于什么？

UDDI 使用 W3C 和 IETF* 的因特网标准，比如 XML、HTTP 和 DNS 协议。

UDDI 使用 WSDL 来描述到达 web services 的界面

此外，通过采用 SOAP，还可以实现跨平台的编程特性，大家知道，SOAP 是 XML 的协议通信规范，可在 W3C 的网站找到相关的信息。

*注释：IETF - Internet Engineering Task Force

UDDI 的好处

任何规模的行业或企业都能得益于 UDDI。

在 UDDI 之前，还不存在一种 Internet 标准，可以供企业为它们的企业和伙伴提供有关其产品和服务的信息。也不存在一种方法，来集成到彼此的系统和进程中。

UDDI 规范帮助我们解决的问题：

  • 使得在成百万当前在线的企业中发现正确的企业成为可能
  • 定义一旦首选的企业被发现后如何启动商业
  • 扩展新客户并增加对目前客户的访问
  • 扩展销售并延伸市场范围
  • 满足用户驱动的需要，为在全球 Internet 经济中快速合作的促进来清除障碍

UDDI 如何被使用

假如行业发布了一个用于航班比率检测和预订的 UDDI 标准，航空公司就可以把它们的服务注册到一个 UDDI 目录中。然后旅行社就能够搜索这个 UDDI 目录以找到航空公司预订界面。当此界面被找到后，旅行社就能够立即与此服务进行通信，这样由于它使用了一套定义良好的预订界面。

谁在支持 UDDI？

UDDI 是一个跨行业的研究项目，由所有主要的平台和软件提供商驱动，比如：Dell, Fujitsu, HP, Hitachi, IBM, Intel, Microsoft, Oracle, SAP, 以及 Sun, 它既是一个市场经营者的团体，也是一个电子商务的领导者。

已有数百家公司参与了这个 UDDI 团体。

  • Previous Page
  • Next Page


WSDL 简介

WSDL 教程

  • WSDL 首页
  • WSDL 简介
  • WSDL 文档
  • WSDL 端口
  • WSDL 绑定
  • WSDL 和 UDDI
  • WSDL 语法
  • WSDL 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WSDL 简介

  • Previous Page
  • Next Page

WSDL 是基于 XML 的用于描述 Web Services 以及如何访问 Web Services 的语言。

您应当具备的基础知识

在继续学习之前，您需要对下面的知识有基本的了解：

  • XML
  • XML 命名空间
  • XML Schema

如果您希望首先学习这些项目，请访问我们的 XML 系列教程。

什么是 WSDL?

  • WSDL 指网络服务描述语言
  • WSDL 使用 XML 编写
  • WSDL 是一种 XML 文档
  • WSDL 用于描述网络服务
  • WSDL 也可用于定位网络服务
  • WSDL 还不是 W3C 标准

WSDL 可描述网络服务（Web Services）

WSDL 指网络服务描述语言 (Web Services Description Language)。

WSDL 是一种使用 XML 编写的文档。这种文档可描述某个 Web service。它可规定服务的位置，以及此服务提供的操作（或方法）。

在 W3C 的 WSDL 发展史

在 2001 年 3 月，WSDL 1.1 被 IBM、微软作为一个 W3C 纪录（W3C note）提交到有关 XML 协议的 W3C XML 活动，用于描述网络服务。

（W3C 纪录仅供讨论。一项 W3C 纪录的发布并不代表它已被 W3C 或 W3C 团队亦或任何 W3C 成员认可。）

在 2002 年 7 月，W3C 发布了第一个 WSDL 1.2 工作草案。

请在我们的 W3C 教程 阅读更多有关规范的状态及时间线。

  • Previous Page
  • Next Page


WSDL 教程

WSDL 教程

  • WSDL 首页
  • WSDL 简介
  • WSDL 文档
  • WSDL 端口
  • WSDL 绑定
  • WSDL 和 UDDI
  • WSDL 语法
  • WSDL 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WSDL 教程

  • Next Page

WSDL（网络服务描述语言，Web Services Description Language）是一门基于 XML 的语言，用于描述 Web Services 以及如何对它们进行访问。

开始学习WSDL！

内容目录

WSDL 简介
本章讲解 WSDL 的概念。
WSDL 文档
本章讲解 WSDL 文档的主要部分。
WSDL 端口
本章讲解 WSDL 端口界面 (WSDL port interface)。
WSDL 绑定
本章讲解 WSDL binding interface。
WSDL 和 UDDI
本章讲解 UDDI 如何与 WSDL 进行整合。(UDDI: Universal Description Discovery and Integration.)
WSDL 语法
在 W3C note 中被列出的完整的 WSDL 语法。
WSDL 总结
本节向您推荐了在学习了 WSDL 教程之后，应该继续学习的内容。
  • Next Page


WSDL 文档

WSDL 教程

  • WSDL 首页
  • WSDL 简介
  • WSDL 文档
  • WSDL 端口
  • WSDL 绑定
  • WSDL 和 UDDI
  • WSDL 语法
  • WSDL 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

WSDL 文档

  • Previous Page
  • Next Page

WSDL 文档仅仅是一个简单的 XML 文档。

它包含一系列描述某个 web service 的定义。

WSDL 文档结构

WSDL 文档是利用这些主要的元素来描述某个 web service 的：

元素 | 定义
<portType> | web service 执行的操作
<message> | web service 使用的消息
<types> | web service 使用的数据类型
<binding> | web service 使用的通信协议

一个 WSDL 文档的主要结构是类似这样的：

<definitions>

<types>
   definition of types........
</types>

<message>
   definition of a message....
</message>

<portType>
   definition of a port.......
</portType>

<binding>
   definition of a binding....
</binding>

</definitions>

WSDL 文档可包含其它的元素，比如 extension 元素，以及一个 service 元素，此元素可把若干个 web services 的定义组合在一个单一的 WSDL 文档中。

如需完整的语法概述，请访问 WSDL 语法 这一节。

WSDL 端口

<portType> 元素是最重要的 WSDL 元素。

它可描述一个 web service、可被执行的操作，以及相关的消息。

可以把 <portType> 元素比作传统编程语言中的一个函数库（或一个模块、或一个类）。

WSDL 消息

<message> 元素定义一个操作的数据元素。

每个消息均由一个或多个部件组成。可以把这些部件比作传统编程语言中一个函数调用的参数。

WSDL types

<types> 元素定义 web service 使用的数据类型。

为了最大程度的平台中立性，WSDL 使用 XML Schema 语法来定义数据类型。

WSDL Bindings

<binding> 元素为每个端口定义消息格式和协议细节。

WSDL 实例

这是某个 WSDL 文档的简化的片段：

<message name="getTermRequest">
   <part name="term" type="xs:string"/>
</message>

<message name="getTermResponse">
   <part name="value" type="xs:string"/>
</message>

<portType name="glossaryTerms">
  <operation name="getTerm">
        <input message="getTermRequest"/>
        <output message="getTermResponse"/>
  </operation>
</portType>

在这个例子中，<portType> 元素把 "glossaryTerms" 定义为某个端口的名称，把 "getTerm" 定义为某个操作的名称。

操作 "getTerm" 拥有一个名为 "getTermRequest" 的输入消息，以及一个名为 "getTermResponse" 的输出消息。

<message> 元素可定义每个消息的部件，以及相关联的数据类型。

对比传统的编程，glossaryTerms 是一个函数库，而 "getTerm" 是带有输入参数 "getTermRequest" 和返回参数 getTermResponse 的一个函数。

  • Previous Page
  • Next Page


您已经学习了 WSDL，下一步呢？

WSDL 教程

  • WSDL 首页
  • WSDL 简介
  • WSDL 文档
  • WSDL 端口
  • WSDL 绑定
  • WSDL 和 UDDI
  • WSDL 语法
  • WSDL 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

您已经学习了 WSDL，下一步呢？

  • Previous Page
  • Next Page

WSDL 概要

本教程已为您讲解了如何创建可描述 web 服务的 WSDL 文档。它也规定了服务的位置和服务所提供的操作（或方法）。

您已经学习到如何为 web 服务定义消息格式和协议细节。

您也学习了可通过 UDDI 来注册和搜索 web 服务。

您已经学习了 WSDL，下一步呢？

下一步应该学习 SOAP 和 Web Services。

SOAP

SOAP 是一种基于 XML 的简易协议，允许应用程序通过 HTTP 来交换信息。

或者更简单地讲，SOAP 是用于访问 web 服务的协议。

如果您希望学习更多有关 SOAP 的知识，请访问我们的 SOAP 教程。

Web Services

Web services 可把您的应用程序转换为 web 应用程序。

通过使用 XML，可以在应用程序间传送消息。

如果您希望学习更多有关 Web services 的知识，请访问我们的 Web services 教程。

  • Previous Page
  • Next Page


完整的 WSDL 语法

WSDL 教程

  • WSDL 首页
  • WSDL 简介
  • WSDL 文档
  • WSDL 端口
  • WSDL 绑定
  • WSDL 和 UDDI
  • WSDL 语法
  • WSDL 总结

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

完整的 WSDL 语法

  • Previous Page
  • Next Page

描述于 W3C 工作草案的完整 WSDL 1.2 语法已列在下面：

<wsdl:definitions name="nmtoken"? targetNamespace="uri">

    <import namespace="uri" location="uri"/> *

    <wsdl:documentation .... /> ?

    <wsdl:types> ?
        <wsdl:documentation .... /> ?
        <xsd:schema .... /> *
    </wsdl:types>

    <wsdl:message name="ncname"> *
        <wsdl:documentation .... /> ?
        <part name="ncname" element="qname"? type="qname"?/> *
    </wsdl:message>

    <wsdl:portType name="ncname"> *
        <wsdl:documentation .... /> ?
        <wsdl:operation name="ncname"> *
            <wsdl:documentation .... /> ?
            <wsdl:input message="qname"> ?
                <wsdl:documentation .... /> ?
            </wsdl:input>
            <wsdl:output message="qname"> ?
                <wsdl:documentation .... /> ?
            </wsdl:output>
            <wsdl:fault name="ncname" message="qname"> *
                <wsdl:documentation .... /> ?
            </wsdl:fault>
        </wsdl:operation>
    </wsdl:portType>

    <wsdl:serviceType name="ncname"> *
        <wsdl:portType name="qname"/> +
    </wsdl:serviceType>

    <wsdl:binding name="ncname" type="qname"> *
        <wsdl:documentation .... /> ?
        <-- binding details --> *
        <wsdl:operation name="ncname"> *
            <wsdl:documentation .... /> ?
            <-- binding details --> *
            <wsdl:input> ?
                <wsdl:documentation .... /> ?
                <-- binding details -->
            </wsdl:input>
            <wsdl:output> ?
                <wsdl:documentation .... /> ?
                <-- binding details --> *
            </wsdl:output>
            <wsdl:fault name="ncname"> *
                <wsdl:documentation .... /> ?
                <-- binding details --> *
            </wsdl:fault>
        </wsdl:operation>
    </wsdl:binding>

    <wsdl:service name="ncname" serviceType="qname"> *
        <wsdl:documentation .... /> ?
        <wsdl:port name="ncname" binding="qname"> *
            <wsdl:documentation .... /> ?
            <-- address details -->
        </wsdl:port>
    </wsdl:service>

</wsdl:definitions>
  • Previous Page
  • Next Page


XForms 函数

XForms 教程

  • XForms 首页
  • XForms 简介
  • XForms 模型
  • XForms 命名空间
  • XForms 实例
  • XForms XPath
  • XForms 输入
  • XForms 选择
  • XForms 数据类型
  • XForms 属性
  • XForms 行为
  • XForms 函数

参考手册

  • XForms 数据类型

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XForms 函数

  • Previous Page
  • Next Page

  • Previous Page
  • Next Page

XForms 参考手册


XForms 和 XPath

XForms 教程

  • XForms 首页
  • XForms 简介
  • XForms 模型
  • XForms 命名空间
  • XForms 实例
  • XForms XPath
  • XForms 输入
  • XForms 选择
  • XForms 数据类型
  • XForms 属性
  • XForms 行为
  • XForms 函数

参考手册

  • XForms 数据类型

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XForms 和 XPath

  • Previous Page
  • Next Page

XForms 使用 XPath 对数据急性寻址。这个过程被称为绑定。

XForms 绑定

XForms 使用两个部分来定义数据：XForms 模型和 XForms 用户界面。

XForms 模型是针对数据的一个 XML 模板（实例），而 XForms 用户界面是对数据输入和显示的描述。

XForms 使用 XPath 来定义这个两个部分的连接。这被称为绑定（binding）。

XPath

XPath 用于定义 XML 文档的各部分的 W3C 标准语法。

XPath 使用路径表达式来标示 XML 文档中的节点。这些表达式与您在计算机系统中看到的文件路径表达式非常类似。

XPath 表达式：

/person/fname

对 XML 文档中的 fname 节点进行寻址：

<person>
   <fname>David</fname>
   <lname>Smith</lname>
</person>

在我们的 XPath 教程 中学习更多有关 XPath 的知识。

使用 Ref 进行绑定

XForms 模型是这样的：

<instance>
  <person>
    <name>
      <fname/>
      <lname/>
    </name>
  </person>
</instance>

XForms 用户界面可使用 ref 属性来捆绑 <input> 元素：

<input ref="name/fname">
<label>First Name</label>
</input>

<input ref="name/lname">
<label>Last Name</label>
</input>

上面例子中的 ref="name/fname" 属性是一个指向实例模型中 <fname> 元素的 XPath 表达式。它可将输入域捆绑到正从表单收集数据的 XML 文档（实例）中的 <fname> 元素。

XForms 用户界面也可以使用引用：

<input ref="/person/name/fname">
<label>First Name</label>
</input>
<input ref="/person/name/lname">
<label>Last Name</label>
</input>

在上面的例子中，XPath 表达式起始部位的正斜杠 (/) 指示 XML 文档的根。

使用 Bind 进行绑定

XForms 模型是这样的：

<model>
<instance>
  <person>
    <name>
      <fname/>
      <lname/>
    </name>
  </person>
</instance>
<bind nodeset="/person/name/fname" id="firstname"/>
<bind nodeset="/person/name/lname" id="lastname"/>
</model>

XForms 用户界面可使用 bind 属性来捆绑 <input> 元素：

<input bind="firstname">
<label>First Name</label>
</input>

<input bind="lastname">
<label>Last Name</label>
</input>

为什么会有两种将输入控件元素捆绑到实例数据的方法呢？

怎么说呢，当您在复杂的应用程序中开始使用 XForms 时，您会发现，使用 bind 进行绑定是一种更灵活的处理多重表单和多重实例模型的方法。

  • Previous Page
  • Next Page

XForms 参考手册


XForms 简介

XForms 教程

  • XForms 首页
  • XForms 简介
  • XForms 模型
  • XForms 命名空间
  • XForms 实例
  • XForms XPath
  • XForms 输入
  • XForms 选择
  • XForms 数据类型
  • XForms 属性
  • XForms 行为
  • XForms 函数

参考手册

  • XForms 数据类型

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XForms 简介

  • Previous Page
  • Next Page

XForms 是下一代的 HTML 表单。

XForms 使用 XML 来创建 web 上的输入表单。

您应当具备的基础知识

在继续学习之前，您需要对下面的知识有基本的了解：

  • HTML
  • HTML 表单
  • XHTML
  • XML

如果您希望首先学习这些项目，请在 首页 访问这些教程。

什么是XForms？

  • XForms 是下一代的 HTML 表单
  • XForms 与 HTML 表单相比更完善，更灵活
  • XForms 将在 XHTML 2.0 种成为表单标准
  • XForms 独立于平台和设备
  • XForms 可从表现分离数据和逻辑
  • XForms 使用 XML 来定义表单数据
  • XForms 可存储和传输 XML 文档中的数据
  • XForms 含有诸如计算以及表单验证等特性
  • XForms 可减少或根除对脚本的需求
  • XForms 是 W3C 标准

XForms 是 HTML 表单的继任者

在今天，表单是许多 web 应用程序的重要组成部分。HTML 表单使 web 应用程序从用户那里接收数据成为可能。

今天，在 HTML 表单成为 HTML 标准的组成部分的十年后，网络用户所进行的复杂事务正在超越标准的 HTML 表单的能力极限。

XForms 提供了一种更完善、更安全并独立于设备的方法来处理网络输入。我们应当期待未来的网络解决方案要求使用支持 XForms 的浏览器（所有未来的浏览器均应支持 XForms）。

XForms 可从表现分离数据和逻辑

XForms 使用 XML 来进行数据定义，而 HTML 或 XHTML 用于数据显示。XForms 可把表单的数据逻辑与其表现分离。XForms 数据的定义方式独立于最终用户与应用程序相交互的方式。

XForms 使用 XML 来定义表单数据

通过 XForms，可使用 XML 来表达描述和验证数据的规则。

XForms 使用 XML 来存储和传输数据

通过 XForms，显示在表单中的数据可存储在 XML 文档中，并且从表单提交的数据使用 XML 在因特网上传输。

数据以 Unicode 进行编码和传输。

XForms 独立于设备

把数据与表现分离使得 XForms 独立于设备，因为数据模型可被用于所有的设备。表现可为不同的用户界面定制，比如移动电话、手持设备以及针对盲人的盲文阅读器。

由于 XForms 独立于设备并基于 XML，这也使得向其他 XML 应用程序中添加 XForms 元素成为可能，比如 VoiceXML (speaking web data)、WML (无线标记语言), 以及 SVG (可伸缩矢量图形)。

XForms 是 W3C 标准

XForms 在2003年10月成为 W3C 标准。

可通过此链接找到官方的 W3C 推荐标准：

http://www.w3.org/TR/xforms/

  • Previous Page
  • Next Page

XForms 参考手册


XForms 教程

XForms 教程

  • XForms 首页
  • XForms 简介
  • XForms 模型
  • XForms 命名空间
  • XForms 实例
  • XForms XPath
  • XForms 输入
  • XForms 选择
  • XForms 数据类型
  • XForms 属性
  • XForms 行为
  • XForms 函数

参考手册

  • XForms 数据类型

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XForms 教程

  • Next Page

XForms 是下一代的 HTML 表单。

在我们的 XForms 教程中，您将学习如何在应用程序中开始应用 XForms。

开始学习 XForms ！

内容目录

XForms 简介
本章阐述 XForms 的概念，以及它与 HTML 表单的区别。
XForms 模型
本章讲解 XForms 模型（XForms Model）。
XForms 命名空间
本章讲解 XForms 命名空间。
XForms 实例
本章演示一个 XForms 实例。
XForms XPath
本章讲解 XForms 如何利用 XPath 来对数据进行寻址。
XForms 输入
本章讲解 XForms 的用户界面控件（user interface controls）。
XForms 选择
本章讲解 XForms 的选择控件（Selection Controls）。
XForms 数据类型
本章讲解在 XForms 中使用的数据类型。
XForms 属性
本章讲解 XForms 属性。
XForms 行为
本章讲解 XForms 行为（actions）。
XForms 函数
XForms 拥有预定义的函数。不过也可以调用已在脚本中定义过的函数。
  • Next Page

XForms 参考手册


XForms 命名空间

XForms 教程

  • XForms 首页
  • XForms 简介
  • XForms 模型
  • XForms 命名空间
  • XForms 实例
  • XForms XPath
  • XForms 输入
  • XForms 选择
  • XForms 数据类型
  • XForms 属性
  • XForms 行为
  • XForms 函数

参考手册

  • XForms 数据类型

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XForms 命名空间

  • Previous Page
  • Next Page

您应当在 HTML 和 XHTML 1.0 中使用一个 XForms 命名空间。

但是很有可能在 XHTML 2.0 中不再需要了。

XForms 命名空间

官方的 XForms 命名空间是：http://www.w3.org/2002/xforms

如果您需要在 HTML（或者 XHTML 1.0） 中使用 XForms，就必须通过一个 XForms 命名空间声明所有的 XForms 元素。

XForms 预计会成为 XHTML 2.0 的标准组成部分，这样就不再需要 XForms 命名空间了。

这个例子使用的 XForms 命名空间：

<html xmlns:xf="http://www.w3.org/2002/xforms">

<head>
<xf:model>
  <xf:instance>
  <person>
    <fname/>
    <lname/>
  </person>
  </xf:instance>
  <xf:submission id="form1" method="get"
  action="submit.asp"/>
</xf:model>
</head>

<body>
<xf:input ref="fname">
<xf:label>First Name</xf:label></xf:input>
<br />
<xf:input ref="lname">
<xf:label>Last Name</xf:label></xf:input>
<br />
<br />
<xf:submit submission="form1">
<xf:label>Submit</xf:label></xf:submit>
</body>
</html>

在上面的例子中，我使用了针对 XForms 命名空间的 xf: 前缀，但是您可自由调用你需要的任何前缀。

  • Previous Page
  • Next Page

XForms 参考手册


XForms 模型

XForms 教程

  • XForms 首页
  • XForms 简介
  • XForms 模型
  • XForms 命名空间
  • XForms 实例
  • XForms XPath
  • XForms 输入
  • XForms 选择
  • XForms 数据类型
  • XForms 属性
  • XForms 行为
  • XForms 函数

参考手册

  • XForms 数据类型

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XForms 模型

  • Previous Page
  • Next Page

XForms 模型为集中于表单中的数据定义了一个模板。

XForms 框架

HTML 表单的作用是搜集数据。XForms 的作用是相同的。

通过 XForms，输入数据被描述在两个不同的部分中：

  • XForms 模型（描述数据和逻辑）
  • XForms 用户界面（显示和输入数据）

XForms 模型定义了什么是表单，它包含什么数据，以及它应该做什么。

XForms 用户界面定义了输入域，以及它们如何被显示。

XForms 模型

XForms 模型用于描述数据。

数据模型是 XML 文档的一个实例（一个模板）。

XForms 模型定义了一个 <model> 元素内部的一个数据模型：

<model>

<instance>
  <person>
    <fname/>
    <lname/>
  </person>
</instance>

<submission id="form1" action="submit.asp" method="get"/>

</model>

从上面的例子，您可以看到 XForms 模型使用 一个 <instance> 元素来为需要收集的数据定义 XML 模板，并使用一个 <submission> 元素来描述如何提交数据。

<submission> 模型没有表达任何有关表单可见部分（用户界面）的信息。

XForms 命名空间

假如您忽略了这些例子中的 XForms 命名空间，或者假如您不清楚命名空间的概念，我们会在下一节介绍这个内容。

<instance> 元素

XForms 模型 <instance> 元素来定义数据收集的数据。

XForms 是为某个 XML 文档进行数据收集的。在这个 XForms 模型中的 <instance> 元素定义了这个 XML 文档。

在上面的例子中，表单为其收集数据的数据实例（XML 文档）类似这样：

<person>
  <fname/>
  <lname/>
</person>

在数据收集完毕后，这个 XML 文档也许看上去类似这样：

<person>
  <fname>John</fname>
  <lname>Smith</lname>
</person>

<submission> 元素

XForms 模型使用 <submission> 元素来描述如何提交数据。

<submission> 元素可定义表单以及如何提交表单。在上面的例子中，id="form1" 用于标示此表单，action="submit.asp" 属性表单被提交到的 URL，而 method="get" 属性定义了在表单提交过程中使用的方法。

XForms 用户界面

XForms 用户界面用于显示和输入数据。

XForms 的用户界面元素被称为控件或输入控件：

<input ref="fname"><label>First Name</label></input>
<input ref="lname"><label>Last Name</label></input>
<submit submission="form1"><label>Submit</label></submit>

在上面的例子中，两个 <input> 元素定义了两个输入域。ref="fname" 和 ref="lname" 属性指向了 XForms 模型中的 <fname> 和 <lname> 元素。

<submit> 元素中的 submission="form1" 属性可引用 XForms 模型中的 <submission> 元素。submit 元素通常被显示为按钮。

请留意例子中的 <label> 元素。使用 XForms 的话，每个输入控件元素都必须有 <label> 元素。

您将需要一个容器

XForms 没有被设计为单独工作的方式。也没有所谓的 XForms 文档。

XForms 必须工作在另外一个 XML 文档中。它可运行在 XHTML 1.0 中，同时它也将工作在 XHTML 2.0 中。

现在把所有的组合起来

如果我们把它组合起来，此文档是这样的：

<xforms>

<model>
<instance>
  <person>
    <fname/>
    <lname/>
  </person>
</instance>
<submission id="form1"
action="submit.asp"
method="get"/>
</model>

<input ref="fname"><label>First Name</label></input>
<input ref="lname"><label>Last Name</label></input>
<submit submission="form1"><label>Submit</label></submit>

</xforms>

页面会这样显示：

XForms 处理器

内建于浏览器中的 XForms 处理器将负责向目标提交 XForms 数据。

数据可作为 XML 来提交，类似这样：

<person>
  <fname>David</fname>
  <lname>Smith</lname>
</person>

或作为文本来提交，类似这样：

fname=David;lname=Smith
  • Previous Page
  • Next Page

XForms 参考手册


XForms 实例

XForms 教程

  • XForms 首页
  • XForms 简介
  • XForms 模型
  • XForms 命名空间
  • XForms 实例
  • XForms XPath
  • XForms 输入
  • XForms 选择
  • XForms 数据类型
  • XForms 属性
  • XForms 行为
  • XForms 函数

参考手册

  • XForms 数据类型

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XForms 实例

  • Previous Page
  • Next Page

通过 Internet Explorer 进行测试

您可以使用 Internet Explorer 5 或更高的版本来测试这个例子。

请点击例子下面的链接。

一个 XForms 实例

请看这个使用 XForms 的文档：

<xforms>

<model>
  <instance>
  <person>
    <fname/>
    <lname/>
  </person>
  </instance>
  <submission id="form1" method="get"
   action="submit.asp"/>
</model>

<input ref="fname">
<label>First Name</label></input><br />

<input ref="lname">
<label>Last Name</label></input><br /><br />

<submit submission="form1">
<label>Submit</label></submit>

</xforms>

页面会显示为这样：

在您的计算机上测试这个例子

  • Previous Page
  • Next Page

XForms 参考手册


XForms 输入控件

XForms 教程

  • XForms 首页
  • XForms 简介
  • XForms 模型
  • XForms 命名空间
  • XForms 实例
  • XForms XPath
  • XForms 输入
  • XForms 选择
  • XForms 数据类型
  • XForms 属性
  • XForms 行为
  • XForms 函数

参考手册

  • XForms 数据类型

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XForms 输入控件

  • Previous Page
  • Next Page

XForms 的用户界面使用 XForms 控件。

XForms 控件

XForms 中的用户界面元素被称为 XForms 控件。

最常用的控件元素是 <input> 和 <submit>。

每个控件元素均有 ref 属性指回 XForms 的数据模型。

独立于设备的控件

理解 XForms 用户界面并不会确切地描述如何显示 XForms 控件是很重要。

由于 XForms 是独立于平台和设备的，XForms 把如何显示这些空间的权利留给了浏览器。

正因如此，XForms 可被用于所有类型的设备，个人电脑，移动电话、手持计算机等等。XForms 同时也是为残障人士定义用户界面的完美解决方案。

input 控件

input 控件是最常用的 XForms 控件。它用于输入一行文本：

<input ref="name/fname">
<label>First Name</label>
</input>

大多数时候，input 控件会被显示为类似这样的输入域：

Try it yourself

<label> 元素

<label> 元素是所有 XForms 输入控件的强制子元素。

这一点的原因是为了确保表单可用于所有类型的设备（因为标签可通过不同的方式来处理。）对于语音软件，标签可被读出，而对于某些手持设备，标签必须一屏接一屏的跟随输入。

Secret 控件

Secret 控件是 input 空间的特殊变体，被设计用于输入密码或其他隐藏的信息：

<secret ref="name/password">
<label>Password:</label>
</secret>

大多数时候，secret 控件会显示为这样一个输入域：

Textarea 控件

Textarea 控件用于多行的输入：

<textarea ref="message">
<label>Message</label>
</textarea>

textarea 控件可显示为这样的输入域：

Submit 控件

Submit 控件用于提交数据：

<submit submission="form1">
<label>Submit</label>
</submit>

Trigger 控件

trigger 控件用于触发某个动作：

<trigger ref="calculate">
<label>Calculate!</label>
</trigger>

Output 控件：

output 空间用于显示 XForms 数据：

<p>First Name: <output ref="name/fname" /></p>
<p>Last Name:  <output ref="name/lname" /></p>

上面的例子仅仅可输出 XForms XML 文档（XForms 实例）中的 <fname> and <lname> 节点的内容：

<instance>
  <person>
    <name>
      <fname>David</fname>
      <lname>Smith</lname>
    </name>
  </person>
</instance>

显示为这样：

First Name: David
Last Name: Smith

Try it yourself

Upload 控件

upload 控件是为向服务器上传文件而设计的：

<upload bind="name">
<label>File to upload:</label>
<filename bind="file"/>
<mediatype bind="media"/>
</upload>
  • Previous Page
  • Next Page

XForms 参考手册


XForms 属性

XForms 教程

  • XForms 首页
  • XForms 简介
  • XForms 模型
  • XForms 命名空间
  • XForms 实例
  • XForms XPath
  • XForms 输入
  • XForms 选择
  • XForms 数据类型
  • XForms 属性
  • XForms 行为
  • XForms 函数

参考手册

  • XForms 数据类型

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XForms 属性

  • Previous Page
  • Next Page

XForms 属性可定义数据限定，类型和行为。

XForms 属性

XForms 使用属性来定义可影响 XForms 控件的行为的限定（或其他属性）。

例子：

required="true()" 属性不允许指定的实例数据被作为空值来提交。

type="decimal" 属性只允许提交十进制值。

calculate 属性可谓实例数据计算一个值。

请参阅此页面下方的属性参考。

把属性捆绑到数据

XForms 可使用 <bind> 元素把 XForms 属性绑定到 XForms 数据：

<model>
<instance>
  <person>
      <fname/>
      <lname/>
  </person>
</instance>
<bind nodeset="person/lname" required="true()"/>
</model>

在上面的例子中，属性 nodeset="person/lname" 可把属性 required="true()" 绑定到实例数据元素 <lname>。

XForms 属性参考

名称 | 描述
calculate | 定义对项目执行的计算。
constraint | 定义对项目的约束。
p3ptype | 为项目定义 P3P 数据类型。
readonly | 为项目定义一个编辑限定（edit restriction）（无法修改）
relevant | 定义数据如何相关联。（供显示还是提交）
required | 定义数据项目是必需项目。（不能为空）
type | 为项目定义数据类型。
  • Previous Page
  • Next Page

XForms 参考手册


XForms 数据类型

XForms 教程

  • XForms 首页
  • XForms 简介
  • XForms 模型
  • XForms 命名空间
  • XForms 实例
  • XForms XPath
  • XForms 输入
  • XForms 选择
  • XForms 数据类型
  • XForms 属性
  • XForms 行为
  • XForms 函数

参考手册

  • XForms 数据类型

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XForms 数据类型

  • Previous Page
  • Next Page

XForms 模型支持 XML Schema 数据类型。

XML Schema 数据类型

XForms 模型支持 XML Schema 数据类型。此特性使 XForms 处理器有能力为了确保输入值的正确性对数据进行检查。

您可以在我们的 XML Schema 教程 中学习更多有关 XML Schema 的指示。

如需使用 XML Schema 数据类型，您必须向命名空间声明添加 XML Schema 命名空间，就像这样：

<html
xmlns:xf="http://www.w3.org/2002/xforms"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

在添加 XML Schema 命名空间之后，您可以向 XForms 的 instance 元素添加 type 属性，就像这样：

<xf:instance>
<person xmlns="">
  <fname xsi:type="xsd:string"/>
  <lname xsi:type="xsd:string"/>
  <born  xsi:type="xsd:date>"/>
  <size  xsi:type="xsd:integer"/>
</person>
</xf:instance>

XForms 支持除下列类型以外的所有 XML Schema 数据类型：

  • duration
  • ENTITY
  • ENTITIES
  • NOTATION

如需完整的 XForms 数据类型参考，请访问：

完整的 XForms 数据类型参考手册

Try it yourself

数据类型绑定

在 XForms 中，您也可以使用 <bind> 元素来对实例数据与数据类型进行关联：

<xf:bind nodeset="/person/size" type="xsd:integer"/>
  • Previous Page
  • Next Page

XForms 参考手册


XForms 数据类型 参考手册

XForms 教程

  • XForms 首页
  • XForms 简介
  • XForms 模型
  • XForms 命名空间
  • XForms 实例
  • XForms XPath
  • XForms 输入
  • XForms 选择
  • XForms 数据类型
  • XForms 属性
  • XForms 行为
  • XForms 函数

参考手册

  • XForms 数据类型

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XForms 数据类型 参考手册

  • Previous Page
  • Next Page

完整的 XForms Data Types 参考手册。

字符串数据类型

名称 | 描述
ID | A string that represents the ID attribute
IDREF | A string that represents the IDREF attribute
IDREFS |
language | A string that contains a valid language id (e.g. en, en-US)
Name | A string that contains a valid XML name
NCName |
NMTOKEN | A string that represents the NMTOKEN attribute
NMTOKENS |
normalizedString | A string that does not contain new line characters or tabs
QName |
string | A string. This is the default data type XForms will use if no data type is specified. Note: string may contain tab characters and new line characters
token | A string that does not contain line feeds, carriage returns, tabs, leading or trailing spaces, or multiple spaces

所有的字符串数据类型都源自于 string 数据类型本身。

日期和时间数据类型

名称 | 描述
date | Defines a date value
dateTime | Defines a date and time value
gDay | Defines a part of a date - the day (DD)
gMonth | Defines a part of a date - the month (MM)
gMonthDay | Defines a part of a date - the month and day (MM-DD)
gYear | Defines a part of a date - the year (CCYY)
gYearMonth | Defines a part of a date - the year and month (CCYY-MM)
time | Defines a time value

数值数据类型

名称 | 描述
byte | A signed 8-bit integer
decimal | A decimal value
int | A signed 32-bit integer
integer | An integer value
long | A signed 64-bit integer
negativeInteger | An integer containing only negative values (..,-2,-1)
nonNegativeInteger | An integer containing only non-negative values (0,1,2,..)
nonPositiveInteger | An integer containing only non-positive values (..,-2,-1,0)
positiveInteger | An integer containing only positive values (1,2, ..)
short | A signed 16-bit integer
unsignedLong | An unsigned 64-bit integer
unsignedInt | An unsigned 32-bit integer
unsignedShort | An unsigned 16-bit integer
unsignedByte | An unsigned 8-bit integer

All numeric data types are derived from the decimal data type.

杂项数据类型

名称 | 描述
anyURI | Represents a URI, which includes web page addresses
base64Binary | Allows characters, including control characters, that otherwise aren't representable in XML
boolean | Defines a true/false or 1/0 value
double |
float |
hexBinary |

XForms 数据类型

名称 | 描述
listItems | Represents a whitespace-separated list
listItem | Represents only non-whitespace characters. An excellent base type for a whitespace-separated list
dayTimeDuration | Represents a duration of a certain number of seconds
yearMonthDuration | Represents a duration of a certain number of months
  • Previous Page
  • Next Page

XForms 参考手册


XForms 行为（Actions）

XForms 教程

  • XForms 首页
  • XForms 简介
  • XForms 模型
  • XForms 命名空间
  • XForms 实例
  • XForms XPath
  • XForms 输入
  • XForms 选择
  • XForms 数据类型
  • XForms 属性
  • XForms 行为
  • XForms 函数

参考手册

  • XForms 数据类型

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XForms 行为（Actions）

  • Previous Page
  • Next Page

XForms 行为可处理对事件的响应。

Message 行为

XForms 元素 <message> 可定义一条显示在 XForms 用户界面的消息。

请看这个简化的例子：

<input ref="fname">
<label>First Name</label>
<message level="ephemeral" event="DOMFocusIn">
Input Your First Name
</message>
</input>

在上面的例子中，当用户把焦点集中在此输入域时，"Input Your First Name" 这条消息可作为工具提示被显示处理：

event="DomFocusIn" 可定义触发行为的事件。

level="ephemeral" 可定义作为工具提示来显示的消息。

level 属性的其他值是 modal 和 modeless，可定义消息框（对话框）的不同类型。

Setvalue 行为

XForms 元素 <setvalue> 可定义在对某个事件做出响应时被设置的值。

请看这个简化的例子：

<input ref="size">
<label>Size</label>
<setvalue value="50" event="xforms-ready"/>
</input>

在上面的例子中，当表单打开时，值 50 会被存储在实例元素 <size> 中。

  • Previous Page
  • Next Page

XForms 参考手册


XForms 选择控件

XForms 教程

  • XForms 首页
  • XForms 简介
  • XForms 模型
  • XForms 命名空间
  • XForms 实例
  • XForms XPath
  • XForms 输入
  • XForms 选择
  • XForms 数据类型
  • XForms 属性
  • XForms 行为
  • XForms 函数

参考手册

  • XForms 数据类型

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XForms 选择控件

  • Previous Page
  • Next Page

XForms 用户界面使用 XForms 控件。

Select1 控件

select1 控件用于从一个项目列表中选取一个项目：

<select1 ref="status">
  <label>Status:</label>
  <item>
    <label>Male</label>
    <value>M</value>
  </item>
  <item>
    <label>Female</label>
    <value>F</value>
  </item>
</select1>

在上面的例子中，用户可在两个值中选择其中之一，Male 或者 Female。存储在 XForms 实例（XML 文档）中的数据将是 M 或 F。

Try it yourself

Select 控件

Select 控件用于从一个项目列表中选取项目（一个或多个）：

<select ref="languages">
  <label>Languages:</label>
  <item>
    <label>English</label>
    <value>E</value>
  </item>
  <item>
    <label>French</label>
    <value>F</value>
  </item>
  <item>
    <label>Spanish</label>
    <value>S</value>
  </item>
  <item>
    <label>German</label>
    <value>G</value>
  </item>
</select>

Range 控件

Range 控件用于从值的一个范围内选取值：

<range ref="length" start="0" end="100" step="5">
  <label>Length:</label>
</range>

在上面的例子中，用户可按照步长 5 选择介于 0 到 100 之间的某个值。

  • Previous Page
  • Next Page

XForms 参考手册


XHTM L与 HTML 之间的差异

XHTML 教程

  • XHTML 首页
  • XHTML 简介
  • XHTML Why
  • XHTML v HTML
  • XHTML 语法
  • XHTML DTD
  • XHTML HowTo
  • XHTML 验证
  • XHTML 模块
  • XHTML 属性
  • XHTML 事件
  • XHTML 总结
  • XHTML 结构化 1
  • XHTML 结构化 2

测验

  • XHTML 测验

参考手册

  • XHTML 标签列表
  • XHTML 属性
  • XHTML 事件
  • XHTML 颜色名
  • XHTML ASCII
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XHTML 与 HTML 之间的差异

  • Previous Page
  • Next Page

通过开始编写严格的 HTML，你可以为 XHTML 做好准备。

如何为 XHTML 做好准备

XHTML 与 HTML 4.01 标准没有太多的不同。

所以将你的代码升级至 4.01 是个不错的开始。我们的完整的《HTML 4.01 参考手册》会帮助你做到这一点。

另外，你应该马上使用小写字母编写HTML代码，同时绝不要养成忽略类似 </p> 标签的坏习惯。

祝您可以愉快地编码！

最主要的不同：

  • XHTML 元素必须被正确地嵌套。
  • XHTML 元素必须被关闭。
  • 标签名必须用小写字母。
  • XHTML 文档必须拥有根元素。

元素必须被正确地嵌套

在 HTML 中，某些元素可以像这样彼此不正确地嵌套：

<b><i>This text is bold and italic</b></i>

在 XHTML 中，所有的元素必须像这样彼此正确地嵌套：

<b><i>This text is bold and italic</i></b>

提示：在嵌套列表中一个容易犯的错误，是忘记内部列表必须位于 li 元素中，就像下面这样：

这是错误的：

<ul>
  <li>Coffee</li>
  <li>Tea
    <ul>
      <li>Black tea</li>
      <li>Green tea</li>
    </ul>
  <li>Milk</li>
</ul>

这是正确的：

<ul>
  <li>Coffee</li>
  <li>Tea
    <ul>
      <li>Black tea</li>
      <li>Green tea</li>
    </ul>
  </li>
  <li>Milk</li>
</ul>

注意：在正确代码的例子中，我们在 </ul> 之后插入了一个 </li> 标签。

XHTML 元素必须被关闭

非空标签必须使用结束标签。

这是错误的：

<p>This is a paragraph
<p>This is another paragraph

这是正确的：

<p>This is a paragraph</p>
<p>This is another paragraph</p>

空标签也必须被关闭

空标签也必须使用结束标签，或者其开始标签必须使用/>结尾。

这是错误的：

A break: <br>
A horizontal rule: <hr>
An image: <img src="happy.gif" alt="Happy face">

这是正确的：

A break: <br />
A horizontal rule: <hr />
An image: <img src="happy.gif" alt="Happy face" />

XHTML 元素必须小写

XHTML 规范定义：标签名和属性对大小写敏感。

这是错误的：

<BODY>
<P>This is a paragraph</P>
</BODY>

这是正确的：

<body>
<p>This is a paragraph</p>
</body>

XHTML 文档必须拥有一个根元素

所有的 XHTML 元素必须被嵌套于 <html> 根元素中。其余所有的元素均可有子元素。子元素必须是成对的且被嵌套在其父元素之中。基本的文档结构如下：

<html>
<head> ... </head>
<body> ... </body>
</html>
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


XHTML DTD

XHTML 教程

  • XHTML 首页
  • XHTML 简介
  • XHTML Why
  • XHTML v HTML
  • XHTML 语法
  • XHTML DTD
  • XHTML HowTo
  • XHTML 验证
  • XHTML 模块
  • XHTML 属性
  • XHTML 事件
  • XHTML 总结
  • XHTML 结构化 1
  • XHTML 结构化 2

测验

  • XHTML 测验

参考手册

  • XHTML 标签列表
  • XHTML 属性
  • XHTML 事件
  • XHTML 颜色名
  • XHTML ASCII
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XHTML DTD

  • Previous Page
  • Next Page

XHTML 定义了三种文件类型声明。

使用最普遍的是 XHTML Transitional。

<!DOCTYPE> 是强制使用的。

一个 XHTML 文档有三个主要的部分：

  • DOCTYPE
  • Head
  • Body

基本的文档结构是这样的：

<!DOCTYPE ...>
<html>
<head>
<title>... </title>
</head>
<body> ... </body>
</html>

在 XHTML 文档中，文档类型声明总是位于首行。

一个 XHTML 的实例

这个一个简单的（最小化的） XHTML 文档：

<!DOCTYPE html
PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html>
<head>
<title>simple document</title>
</head>
<body>
<p>a simple paragraph</p>
</body>
</html>

文档类型声明定义文档的类型：

<!DOCTYPE html
PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

文档的其余部分类似 HTML：

<html>
<head>
<title>simple document</title>
</head>
<body>
<p>a simple paragraph</p>
</body>
</html>

3种文档类型声明

  • DTD 规定了使用通用标记语言(SGML)的网页的语法。
  • 诸如 HTML 这样的通用标记语言应用使用 DTD 来规定应用于某种特定文档中的标签的规则，这些规则包括一系列的元素和实体的声明。
  • 在通用标记语言(SGML)的文档类型声明或 DTD 中，XHTML 被详细地进行了描述。
  • XHTML DTD 使用精确的可被计算机读取的语言来描述合法的 XHTML 标记的语法和句法。

存在三种XHTML文档类型：

  • STRICT（严格类型）
  • TRANSITIONAL（过渡类型）
  • FRAMESET（框架类型）

XHTML 1.0 的三种 XML 文档类型

XHTML 1.0 规定了三种 XML 文档类型，以对应上述三种 DTD。

XHTML 1.0 Strict

<!DOCTYPE html
PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

在此情况下使用：需要干净的标记，避免表现上的混乱。请与层叠样式表配合使用。

XHTML 1.0 Transitional

<!DOCTYPE html
PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

在此情况下使用：当需要利用 HTML 在表现上的特性时，并且当需要为那些不支持层叠样式表的浏览器编写 XHTML 时。

XHTML 1.0 Frameset

<!DOCTYPE html
PUBLIC "-//W3C//DTD XHTML 1.0 Frameset//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-frameset.dtd">

在此的情况下使用：需要使用HTML框架将浏览器窗口分割为两部分或更多框架时。

  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


XHTML 标准属性

XHTML 教程

  • XHTML 首页
  • XHTML 简介
  • XHTML Why
  • XHTML v HTML
  • XHTML 语法
  • XHTML DTD
  • XHTML HowTo
  • XHTML 验证
  • XHTML 模块
  • XHTML 属性
  • XHTML 事件
  • XHTML 总结
  • XHTML 结构化 1
  • XHTML 结构化 2

测验

  • XHTML 测验

参考手册

  • XHTML 标签列表
  • XHTML 属性
  • XHTML 事件
  • XHTML 颜色名
  • XHTML ASCII
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XHTML 标准属性

  • Previous Page
  • Next Page

HTML 标签拥有属性。每个标签的特殊属性均被列于每个标签描述之下。这里列出的属性是通用于每个标签的核心属性和语言属性（有个别例外）。

核心属性 (Core Attributes)

以下标签不提供下面的属性：base, head, html, meta, param, script, style, 以及 title 元素。

属性 | 值 | 描述
class | class_rule 或 style_rule | 元素的类(class)
id | id_name | 元素的某个特定id
style | 样式定义 | 内联样式定义
title | 提示文本 | 显示于提示工具中的文本

语言属性 (Language Attributes)

以下标签不提供下面的属性：base, br, frame, frameset, hr, iframe, param, 以及 script 元素。

属性 | 值 | 描述
dir | ltr | rtl | 设置文本的方向
lang | 语言代码 | 设置语言代码

键盘属性 (Keyboard Attributes)

属性 | 值 | 描述
accesskey | 字符 | 设置访问某元素的键盘快捷键
tabindex | 数 | 设置某元素的Tab次序
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


XHTML 测验

XHTML 教程

  • XHTML 首页
  • XHTML 简介
  • XHTML Why
  • XHTML v HTML
  • XHTML 语法
  • XHTML DTD
  • XHTML HowTo
  • XHTML 验证
  • XHTML 模块
  • XHTML 属性
  • XHTML 事件
  • XHTML 总结
  • XHTML 结构化 1
  • XHTML 结构化 2

测验

  • XHTML 测验

参考手册

  • XHTML 标签列表
  • XHTML 属性
  • XHTML 事件
  • XHTML 颜色名
  • XHTML ASCII
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XHTML 测验

  • Previous Page
  • Next Page

您可以通过 W3SCHOOL 的测验程序来测试您的 XHTML 技能。

关于本测验

本测验包含20道题，每道题的最长答题时间是20分钟（这是由于每个session的默认有效时间是20钟）。

本测验是非官方的测试，它仅仅提供了一个了解您对XHTML的掌握程度的工具。

测验会被记分

每道题的分值是1分。在您完成全部的20道题之后，系统会为您的测验打分，并提供您做错的题目的正确答案。其中，绿色为正确答案，而红色为错误答案。

现在就开始测验！祝您好运。

  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


XHTML 简介

XHTML 教程

  • XHTML 首页
  • XHTML 简介
  • XHTML Why
  • XHTML v HTML
  • XHTML 语法
  • XHTML DTD
  • XHTML HowTo
  • XHTML 验证
  • XHTML 模块
  • XHTML 属性
  • XHTML 事件
  • XHTML 总结
  • XHTML 结构化 1
  • XHTML 结构化 2

测验

  • XHTML 测验

参考手册

  • XHTML 标签列表
  • XHTML 属性
  • XHTML 事件
  • XHTML 颜色名
  • XHTML ASCII
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XHTML 简介

  • Previous Page
  • Next Page

XHTML 是更严格更纯净的 HTML 代码。

XHTML 是什么？
  • XHTML 指可扩展超文本标签语言（EXtensible HyperText Markup Language）。
  • XHTML 的目标是取代 HTML。
  • XHTML 与 HTML 4.01 几乎是相同的。
  • XHTML 是更严格更纯净的 HTML 版本。
  • XHTML 是作为一种 XML 应用被重新定义的 HTML。
  • XHTML 是一个 W3C 标准。

之前应该掌握的知识

在继续学习本教程之前，你应该对下列知识有一个基本的理解：

  • HTML
  • 基本的网站建设知识。

如果希望首先学习 HTML，请阅读我们的 HTML 教程 。

XHTML 是一个 W3C 标准

XHTML 于2000年的1月26日成为 W3C 标准。

W3C 将 XHTML 定义为最新的HTML版本。XHTML 将逐渐取代 HTML。

通过使用我们的 W3C 教程 ，你将与最新的 web 标准保持同步。

所有新的浏览器都支持 XHTML

XHTML 与 HTML 4.01 兼容。

所有新的浏览器都支持 XHTML。

我们使用 XHTML 构建了 W3School

XHTML 是以 XML 重构的 HTML 4.01。通过遵循一些简单的指导方针，XHTML 就可以立即在现有的浏览器中投入使用。

我们百分之百地使用XHTML来构建了 W3School。

点击这个按钮： 验证此页的XHTML部分 验证此页的 XHTML 部分。

点击这个按钮： 验证此页的CSS部分 验证此页的 CSS 部分。

关于本教程

下面的章节将讲解：

  • 为什么应该使用 XHTML？
  • XHTML 的语法
  • 如何将站点转换为 XHTML
  • XHTML 验证
  • XHTML 模块化
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


XHTML 教程

XHTML 教程

  • XHTML 首页
  • XHTML 简介
  • XHTML Why
  • XHTML v HTML
  • XHTML 语法
  • XHTML DTD
  • XHTML HowTo
  • XHTML 验证
  • XHTML 模块
  • XHTML 属性
  • XHTML 事件
  • XHTML 总结
  • XHTML 结构化 1
  • XHTML 结构化 2

测验

  • XHTML 测验

参考手册

  • XHTML 标签列表
  • XHTML 属性
  • XHTML 事件
  • XHTML 颜色名
  • XHTML ASCII
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XHTML 教程

  • Next Page

XHTML 教程

XHTML 是更严谨更纯净的 HTML 版本。

在此教程中，我们会为您讲解 HTML 与 XHTML 之间的差异，同时也会为您展示将该站点升级到 XHTML 的方法。

开始学习 XHTML！

XHTML 测验

测试您的 XHTML 技能

开始 XHTML 测验！

XHTML 参考手册

我们的 XHTML 参考手册是一个按字母顺序排列的 XHTML 标签列表，其中配合了相当多的实例和注释。

XHTML 1.0 参考手册

内容列表

XHTML 简介
此章节对 XHTML 进行了简要的介绍，并解释了 XHTML 的概念。
XHTML - Why?
这章解释了我们为何如此地需要一门像 XHTML 这样的语言。
XHTML与HTML之间的差异
这章解释了 XHTML 与 HTML 在语法上的主要不同之处。
XHTML 语法
这章介绍 XHTML 的基础语法。
XHTML DTD
这章讲解了三种不同的 XHTML 文档类型定义。
XHTML How To
讲解本站是如何由 HTML 转换至 XHTML 的。
XHTML 验证
这章介绍如何对 XHTML 文档进行验证。
XHTML 模块
这章讲解 XHTML 的模块化。
XHTML 总结
这章的内容包括：一篇您在本教程中所学内容的摘要，以及我们推荐的下一步您应该继续学习。
XHTML 参考手册
我们的完整的《XHTML1.0 参考手册》是一个按字母顺序排列的XHTML标签列表，其中配合了相当多的实例和注释.
XHTML 1.0 标准属性
所有的标签都有属性。这里列出的 XHTML1.0 标准属性指所有标签的核心属性和语言属性（有少量的例外），对这些属性的描述，并且列出了每种属性可能的值。
XHTML 1.0 事件属性
标签的所有标准事件属性。对这些属性进行的描述，并且列出了每种属性可能的值。
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


XHTML 结构化之二：案例分析：W3school 的结构化标记

XHTML 教程

  • XHTML 首页
  • XHTML 简介
  • XHTML Why
  • XHTML v HTML
  • XHTML 语法
  • XHTML DTD
  • XHTML HowTo
  • XHTML 验证
  • XHTML 模块
  • XHTML 属性
  • XHTML 事件
  • XHTML 总结
  • XHTML 结构化 1
  • XHTML 结构化 2

测验

  • XHTML 测验

参考手册

  • XHTML 标签列表
  • XHTML 属性
  • XHTML 事件
  • XHTML 颜色名
  • XHTML ASCII
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XHTML 结构化之二：案例分析：W3school 的结构化标记

  • 上一节
  • 下一节

无论如何，不要跳过本节。阅读本章将增进你的技能，为你的网页减肥，并且使你对标记与设计之间的差异有更清晰的认识。本章中的理念是易于学习的，但是却能极大的提高网站的性能，以及设计、制作和更新网站的便利性。

在本节，你将学到如何撰写合乎逻辑的、紧凑的标记，使得你有能力将带宽流量降低50%左右，在减少服务器负担和压力的同时，减少网站的加载时间。通过去除那些表现元素，并改掉那些没有任何好处的坏习惯，我们就可以达到上述的目的。

这些坏习惯折磨着网络中的许多站点，特别是那些将 CSS 代码与主要基于表格的布局混合在一起的站点。这种做法笨拙且不经济，即使是对于那些在其他领域很有经验的设计师来说。同时，出现这个问题的几率是均等的，不论是那些手写代码的站点，还是利用可见编辑工具，比如 Dreamweaver 和 GoLive，来创建的站点。

本节会提出这些常见的错误，这样你就可以识别和防范它们，并且学会如何改正错误。我们详细阐述唯一标识符属性 (id) - ，并展示它如何使你可以编写极其紧凑的 XHTML 代码，不论你创建的是混合布局还是纯粹的 CSS 布局。

每个元素都必须结构化吗？

正如上一节中我们讲到的那样，每个元素都可以被结构化，CSS 可使得一个有序或无序的列表显示为彻头彻尾的导航栏，其中还拥有反转按钮效果。文档的内容可以通过普通的元素进行标记，这些元素通过特定的结构化属性标志来指示出它们在网站设计中所扮演的语义角色。

我们在公元 2006 年创建了 W3School 的第一个中文测试版，我们在一开始就使用了 CSS 进行布局，并使用 XHTML 来结构化文档。每一个其中的元素都是结构化的，从标题到列表，乃至段落。你可以在 w3school 的每个页面看到具有反转效果的首页按钮和二级菜单按钮。下面是这两个组件的 XHTML 代码：

<div id="header"><h1><a href="/">w3school在线教程</a></h1></div>
<div id="navfirst">
<ul id="menu">
<li id="h"><a href="/h.asp" title="html教程">html教程</a></li>
<li id="x"><a href="/x.asp" title="XML教程">XML教程</a></li>
<li id="b"><a href="/b.asp" title="浏览器脚本">浏览器脚本</a></li>
<li id="s"><a href="/s.asp" title="服务器脚本">服务器脚本</a></li>
<li id="d"><a href="/d.asp" title="dot net教程">dot net教程</a></li>
<li id="m"><a href="/m.asp" title="多媒体教程">多媒体教程</a></li>
<li id="w"><a href="/w.asp" title="建站手册">建站手册</a></li>
</ul>
</div>

div、id 和其他帮手

如果被正确地使用，div 可以成为结构化标记的好帮手，而 id 则是一种令人惊讶的小工具，它使你有能力编写极其紧凑的 XTHML，以及巧妙地利用 CSS，并通过标准文档对象模型 (DOM) 向站点添加复杂精巧的行为。

W3C 在其最新的 XHTML2 草案的 XHTML 结构模型中这样定义 div：

div 元素，通过与 id、class 及 role 属性配合，提供向文档添加额外结构的通用机制。这个元素不会将表现的风格定义于内容。所以，创作者可以通过将这个元素与样式表、xml:lang、属性等配合使用，使 XHTML 适应他们自身的需求和口味。

div 是 division 的简写。division 意为分割、区域、分组。比方说，当你将一系列的链接组合在一起，就形成了文档的一个 division。

确定结构的通用机制

所有编写 HTML 的人对段落和标题这类常见的元素都很熟悉，但是有些人对 div 就可能不那么熟悉了。在W3C的描述中我们可以找到理解 div 元素的关键，“一种添加结构的通用机制。”

在本站的首页，我们将教程目录列表封装于一个 div 之中，这是因为教程目录并不是正文的任何元素的一部分。其中，h2元素标记每个教程的标题，同时 ul 列表元素标记每个教程的详细列表。但是在更大更具体的意义中，这个教程目录扮演了一个结构化的角色，即二级导航组件。为了强调这个角色，我们使用 navsecond 这个 id 标注这个 div。

<div id="navsecond">

<h2>HTML教程</h2>
<ul>
<li><a href="/html/index.asp" title="HTML教程">HTML</a></li>
<li><a href="/xhtml/index.asp" title="XHTML教程">XHTML</a></li>
<li><a href="/css/index.asp" title="CSS教程">CSS</a></li>
<li><a href="/tcpip/index.asp" title="TCP/IP教程">TCP/IP</a></li>
</ul>

<h2>XML教程</h2>
<ul>
<li><a href="/xml/index.asp" title="XML教程">XML</a></li>
<li><a href="/xsl/xsl_languages.asp" title="XSL语言">XSL</a></li>
... ...
... ...

</div>

你可以使用任何命名。"Gladys" 和 "orangebox"都完全符合 XHTML 的命名规则。但是语义的 (semantic) 或者元结构化 (meta-structural) 的命名是最好的（即能够解释其中元素所执行功能的命名）。

当客户决定使用蓝色时，你会觉得将站点某部分命名为 orangebox（橙色框）会非常地傻。下面的这种情况中，你会觉得自己更傻，当距离最后交付只有六个月时，你开始调校样式表，却怎么也想不起来 "Gladys"（格拉迪斯，女子名）到底代表导航区、侧栏还是搜索框。

因此，将 id 标注为 "menu"、"content" 或者 "searchform"会帮助你回忆。进一步讲，标记不等同于设计，结构良好的的页面可以被格式化为你希望的任何样子。这样做的结果是，无论你使用纯粹 CSS 布局或者混合布局，你都会彻底改掉使用表现标记进行思考和创作的习惯。

id Vs. class

id 属性对于 XHTML 并不新鲜；class 属性或者 div 元素也一样。它们都可以回溯到 HTML 时代。id 属性为一个元素分配一个唯一的名字。每个名字只能在被赋予的页面使用一次。（例如，假如你的页面包含 id 为 content 的 div，那么另外一个 div 或者其他别的元素都不能使用这个名字。相反地，class 属性可以被一遍有一遍地使用在页面中（例如，页面中的五个段落都可以使用名为 "small" 或者"footnote" 的 class 名称）。下面的标记将有助于阐明 id 和 class 的差异：

<div id="searchform">Search form components go here. This
section of the page is unique.</div>
<div class="blogentry">
   <h2>Today's blog post</h2>
   <p>Blog content goes here.</p>
   <p>Here is another paragraph of blog content.</p>
   <p>Just as there can be many paragraphs on a page, so too
   there may be many entries in a blog. A blog page could use
   multiple instances of the class "blogentry" (or any other
   class).</p>
</div>

<div class="blogentry">
   <h2>Yesterday's blog post</h2>
   <p>In fact, here we are inside another div of class
   "blogentry."</p>
   <p>They reproduce like rabbits.</p>
   <p>If there are ten blog posts on this page, there might
   be ten divs of class "blogentry" as well.</p>
</div>

在这个例子中，名为 searchform 的 div 被用来封装包含搜索表单的页面区域，而 div class="blogentry" 则用来封装 blog 中的每个文章入口。在页面中只有一个搜索表单，所以我们选择 id 标注这个唯一的组件。但是 blog 则拥有许多的（文章）入口，所以 class 属性被应用于这种情况。同样地，新闻站点通常拥有多个 div，这些 div 的 class 可以命名为 "newsitem" 或者别的什么。

然而不是所有的站点都需要 div。blog 站点可以仅仅使用 h1, H2, 和 h2 标题和 <p> 段落，新闻站点也一样。我们在这里展示 class 为 blogentry 的 div，并不是鼓励你在站点中塞满 div，而仅仅是为了向你展示这个原则：在同一个 HTML 文档中，使用多次 class，但只能使用一次 id。

粘性贴纸理论

把 id 属性比作粘性贴纸来进行思考应该是有帮助的。我会在冰箱上拍一张贴纸来提醒自己去买牛奶，电话上面也会贴一张，提醒我给一位逾期缴纳的客户打电话。还有一个，被贴在账本夹上面，来提醒我这个月 15 号之前必须缴纳的账单。

id同样会标注文档中的特殊区域，以便提醒你哪个区域需要特殊的处理，在这点上，id属性与粘性贴纸是相似的。为了实现所谓的特殊处理，你需要使用这个特殊的id在样式表中编写若干规则，或者在JavaScript文件中添加几行代码。比方说，你的CSS文件中有一些特定的规则，这些规则只应用于id名为searchform的div内的元素。

当某一 id 属性作为一个有磁性的东西（磁铁）被用于一系列特定的 CSS 规则时，它被称为CSS选择器。有许多创建选择器的方法，不过 id 是很容易使用的，并且有多的用途。

id 的力量

id 属性不可思议地强有力。它具有以下的能力：

  • 作为样式表选择器，使我们有能力创作紧凑的最小化的 XHTML。
  • 作为超文本的目标锚，取代过时的 name 属性。
  • 作为从基于 DOM 的脚本来定位特定元素的方法。
  • 作为对象元素的名称。
  • 作为一种综合用途处理 (general purpose processing) 的工具（在 W3C 的例子中，“当把数据从HTML页面中提取到数据库，或将 HTML 文档转换为其他格式等情况下，作为域识别工具来使用。”）。

id的规则

id 值必须以字母或者下划线开始；不能以数字开始。虽然 W3C 验证不会捕获这个错误，但是 XML 解析器会的。同时，如果你将 id 与 JavaScript 在表单中配合使用，那么 id 名称和值必须是合法的 JavaScript 变量。空格和连字号，特别是连字号，是不被允许的。不仅如此，将下划线用于 class 或者 id 名都不是个好主意，这是由于在 CSS2.0（以及某些浏览器）中的限制。

语义标记和可用性

现在，我们已经讨论过了用途广泛的 XHTML 元素（特别是 div 和 id），让我们在看看关于本站首页的例子。首先让我们回顾一下这个位于报头位置的菜单：

<div id="navfirst">
<ul id="menu">
<li id="h"><a href="/h.asp" title="html教程">html教程</a></li>
<li id="x"><a href="/x.asp" title="XML教程">XML教程</a></li>
<li id="b"><a href="/b.asp" title="浏览器脚本">浏览器脚本</a></li>
<li id="s"><a href="/s.asp" title="服务器脚本">服务器脚本</a></li>
<li id="d"><a href="/d.asp" title="dot net教程">dot net教程</a></li>
<li id="m"><a href="/m.asp" title="多媒体教程">多媒体教程</a></li>
<li id="w"><a href="/w.asp" title="建站手册">建站手册</a></li>
</ul>
</div>

我们拥有七个链接，每个链接被分配一个id来对应相应的内容：例如名为 h 的 id 对应 HTML 教程，以此类推。同时这些链接被封装于名为 menu 的列表元素内，名为 menu 的 id 标明了这个列表的职能 - 一个菜单列表，而更外围的名为 navfirst 的 div 则用来标注页面中的这个节 (section)，将之与诸如主要内容 (maincontent)、侧栏 (sidebar) 和页脚 (footer) 之类的元素区别开来。

div 和 ul 两个元素提供了真实的结构，即标明了其中内容的职能（导航栏）和它在文档中所属的位置（页面的报头位置）。相反地，传统的表格布局无法提供有关数据的任何语义信息，同时会轻松地吃掉三倍的带宽。

请注意这些标记没有包含img标签，所以不会牵扯到 width、height、background 或者 border 等等属性。同时它没有使用表格单元格，也不会涉及相关的一系列属性。它非常地干净小巧，同时提供了所有可供理解它的信息。

通过与 CSS 配合使用，这些标记向网站访问者提供了可靠的可快速加载的布局。同时也提供了为访问者创造更灵活多样的外观的可能性。并且在无 CSS 的环境中，我们的结构良好的标记依然可以毫不混乱地提供所有的内容。

目光敏锐的读者也许已经发现，a 元素中包含的文本并没有被浏览器显示出来，这也要归功于结构化标记与 CSS 的完美配合，使我们可以通过几行 CSS 规则来定义一个触发机制，当用户使用图形浏览器时，他们会看到漂亮的导航按钮，而当用户使用纯文本的阅读器时，他们也可以得到全部的文本，这样，对所有的用户来说，内容都是一样的。

并且，由于标记没有包含图像和表格单元，这个导航栏组件可以在不改变结构的情况下被站点内的任何页面所引用，同时赋予它不同的视觉效果。简而言之，通过对代码进行模块化，我们提高了代码的复用性。

  • 上一节
  • 下一节

HTML 参考手册
HTML 实例
HTML 测验


XHTML 结构化之一：使用 XHTML 重构网站

XHTML 教程

  • XHTML 首页
  • XHTML 简介
  • XHTML Why
  • XHTML v HTML
  • XHTML 语法
  • XHTML DTD
  • XHTML HowTo
  • XHTML 验证
  • XHTML 模块
  • XHTML 属性
  • XHTML 事件
  • XHTML 总结
  • XHTML 结构化 1
  • XHTML 结构化 2

测验

  • XHTML 测验

参考手册

  • XHTML 标签列表
  • XHTML 属性
  • XHTML 事件
  • XHTML 颜色名
  • XHTML ASCII
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XHTML 结构化之一：使用 XHTML 重构网站

  • Previous Page
  • Next Page

我们曾经为本节撰写的标题是：“XHTML : 简单的规则，容易的方针。”原因之一是，本节讨论的规则和方针是简单和容易的。原因之二是，一本简单和容易的 WEB 设计图书，就像超级市场的新式的免费商品一样，虽然常见却可以有效地吸引人的眼球，这样的东西可以刺激人的兴趣，并且鼓励人们尝试。

我确实希望本节的内容可以激发你的兴趣，并鼓励你去尝试。为什么这么说呢？因为一旦你掌握了本章包含的简单容易的理念，你就会重新思考网页运作的方式，并开始改变建造它们的方法。然而我并不希望你只是将代码重新改写一遍。我希望你可以实实在在地以另一种方式思考和工作。

另一方面，重构才是 XHTML 真正的意义。

在本章，我们将研究结构化标记的机制和涵义。如果你正在将网站标准融入你的开发项目，你或许会觉得本章的内容有些熟悉。不过即便是这方面的老手，也会从本章发现意外的收获。

XHTML 规则概要

将传统的 HTML 转换为 XHTML 1.0 是快捷且无痛的，只要你遵守一些简单的规则和容易的方针。不管是否使用过 HTML，都不会妨碍你使用 XHTML。

  • 使用恰当的文档类型声明和命名空间。
  • 使用 meta 元素声明你的内容类型。
  • 使用小写字母书写所有的元素和属性。
  • 为所有的属性值加引号。
  • 为所有的属性分配值。
  • 关闭所有的标签。
  • 使用空格和斜线关闭空标签。
  • 不要在注释中写双下划线。
  • 确保小于号及和号为 < 和 &

Unicode 和其他字符集

XML、XHTML、和HTML 4.0 文档的默认字符集是 Unicode，一个由 Unicode 联盟定义的标准。Unicode 是一套全面的字符集，它为每个字符提供了一个特定的唯一的数字，不论平台、程序和语言。Unicode 也是我们拥有的最接近通用字母表的事物，尽管它并不是一个字母表，而是一套数字映射方案。

尽管 Unicode 是 web 文档默认的字符集，开发人员依然可以自由地选择更适合他们的其他字符集。比方说，美国和西欧的网站常常使用 ISO-8859-1 (Latin-1) 编码，而中华人民共和国的国家标准是 gb2312。

为表达语义而标记文档，而不是为了样式

记住：请最大限度地使用 CSS 来进行布局。在 web 标准的世界里，XHTML 标记与表现无关，它只与文档结构有关。

结构良好的文档可以向浏览器传达尽可能多的语义，不论是浏览器位于掌上电脑还是时髦的桌面图形浏览器。结构良好的文档都能向用户传达可视化的语义，即使是在老的浏览器，或是在被用户关闭了 CSS 的现代浏览器中。

不是每个站点都能立即抛弃 HTML 表格布局。CSS 的发明者，W3C，直到 2002 年 11 月才将官方网站转换为 CSS 布局。然而，即使是顽固的唯标准主义者也不总是将表现从结构中完全分离处理，至少在 XHTML 1 中是做不到的。但是现在，我们可以向这个理想迈出重大的一步，通过将表现从结构中分离（或者说将数据从设计中），即使是混合的传统的布局也可从中受益。

下面有一些提示，可以帮助你通过更结构化的方式进行思维：

提纲内的色彩

在语法学校，我们中的大部分人都被迫使用标准的提纲格式来写文章。现在，我们成为了设计师，可以多么自由地摆脱提纲的限制，然后大胆地投身于独特的个人表达的自由领域（也许我们的宣传册和商业站点还不是那么独特和个人化）。但是至少我们不会再受到提纲的困扰了。

实际上，依照 HTML，我们应该将内容结构化为有组织的层级。在浏览器不支持 CSS 的时期，我们无法在交付可供销售的布局的同时做到这一点。但是今天，在将我们的设计不折不扣地实现的同时，我们有能力交付内在结构良好的文档。

当你将供网络使用的文本进行标记，或者当你将已有的文本文档转换为网页时，请使用传统提纲的这些条目进行思考。

<h1>我的主题</h1>
<p>介绍性文字</p>
<h2>补充性的观点</h2>
<p>相关文字</p>

同时，避免使用已被废弃的 HTML 元素比如 <font>，或者无语义的元素比如 <br />，来模拟其实不存在的逻辑结构。

比如，不要像这样做：

<font size="7">我的主题</font><br />
介绍性文字<br /><br />
<font size="6">补充性的观点</font><br />
相关文字<br />

根据它们的意义使用元素，而不是根据它们的外观

我们中一些人已经陷在了一个坏习惯中，当我们仅仅需要一个大号字的文本时使用h1，或者在我们需要在前面加一个圆点符号时使用 li。就像我们在前面的章节讨论过的，浏览器一直都习惯于将设计属性强加于 HTML 元素之上。我们都一直习惯于认为，h1 意味着大号字，而li意味着圆点，或者 blockquote 意味着文本缩进。我们中的大多数人还在使用结构化元素模拟表现效果的方式来胡乱地写作 HTML。

同样地，假如设计师希望所有的标题使用相同的字号，她会将所有的标题设置为 h1，即使这么做毫无结构化语义可言。

<h1>这是主标题，在我将文本按照提纲格式组织的情况下。</h1>
<h1>这不是主标题，但是我希望它与上面的标题使用一样的字体，但是我不知该如何使用CSS。</h1>
<h1>这根本不是一个标题。但是我非常希望页面中的文字使用相同的字体，以达到我希望的，
如果我了解CSS，就可以在不打乱文档结构的情况下达到这个设计。</h1>

我们必须把我们的小把戏放到一边，然后开始根据元素的语义来使用它们，而不是根据它们看上去的样子。实际上，h1可以成为你希望的任何样子。通过 CSS，h1 可以成为非粗体的小号的罗马字体，而 p 文本可以成为粗体的大号字，li 也可以没有圆点（你或者可以使用小猫小狗或者公司标志的 PNG,GIF 或者 JPEG 图片取而代之）等等。

从今天开始，我们将要使用 CSS 来决定元素的外观。我们甚至可以根据元素在页面中或者在站点中所在的位置来改变它们的外观。 CSS 可以将表现从结构中彻底抽离，并且允许你按照你喜欢的样式来格式化任何元素。

h1, h2, h2, h3, h5, h6 {
    font-family: georgia, palatino, "New Century Schoolbook",
    times, serif;
    font-weight: normal;
    font-size: 2em;
    margin-top: 1em;
    margin-bottom: 0;
    }

你为什么要这么做呢？这么做的目的是为了在图形浏览器中获得品牌化的外观和感觉的同时，在文本浏览器、无线设备、HTML 格式的电子邮件中，文档的结构得到保留。

我们并不想在关于 XHTML 的章节讲述更多 CSS 方面的技术。我们只是希望展示文档结构和可视表达是两个完全不同的事物，并且结构化元素应被用来转换文本，而不是强加显示效果。

使用结构化元素，而不是无意义的垃圾

由于我们已经忘记或者根本不知道 HTML 和 XHTML 的用途是传达结构化的意义，许多 HTML 争论者这样使用标签来插入列表：

项目一<br />
项目二<br />
项目三<br />

考虑一下使用有序或者无序列表取而代之：

<ul>
<li>项目一</li>
<li>项目二</li>
<li>项目三</li>
</ul>

"但是li给我一个圆点，而我不需要圆点！"你也许会这么说。根据上面的章节，CSS不对元素被期望的外观做任何假定。它等待你来告诉它你所期待的元素外观。关闭圆点是 CSS 的最基本的能力。它有能力使列表看起来和普通文本没有两样，也可以使列表看起来像图形导航栏，具有完整的反转效果。

所以，请使用列表元素来标记列表。相似地，使用 strong 来代替 b，使用 em 代替 i，等等。在大多数桌面浏览器缺省状态下，strong 的显示效果和 b 相同，而 em 和 i 相同，同时也可以在不破坏文档结构的情况下创建你期待的视觉效果。

尽管 CSS 不会为任何元素的显示作假设，浏览器却作了很多假设，并且我们还没有碰到一个将 strong 显示为其他效果而不是粗体字的浏览器（除非是被设计师创建的 CSS 指示以其他方式显示）。假如你担心某个陌生的浏览器不会将 strong 显示为粗体字，你可以编写这么一条 CSS 规则：

strong {
    font-weight: bold;
    font-style: normal;
    }

视觉元素和结构

web 标准不仅要求我们使用何种科技，而且还要遵守使用这些技术的方式。使用 XHTML 来编写标记，同时使用 CSS 来处理一部分或者全部的布局，并不一定会使站点更易用更轻便，同时节约多少带宽。就像我们在早期使用的技术那样，XHTML 和 CSS 也会被误用和滥用。冗长的 XHTML 和冗长的 HTML 一样，都会浪费用户的带宽和时间。冗长的过度的 CSS 也不能完全的代替表现 HTML 代码；这只不过是一种糟糕的东西被另一种代替了而已。

  • 上一节
  • 下一节

HTML 参考手册
HTML 实例
HTML 测验


XHTML 模块

XHTML 教程

  • XHTML 首页
  • XHTML 简介
  • XHTML Why
  • XHTML v HTML
  • XHTML 语法
  • XHTML DTD
  • XHTML HowTo
  • XHTML 验证
  • XHTML 模块
  • XHTML 属性
  • XHTML 事件
  • XHTML 总结
  • XHTML 结构化 1
  • XHTML 结构化 2

测验

  • XHTML 测验

参考手册

  • XHTML 标签列表
  • XHTML 属性
  • XHTML 事件
  • XHTML 颜色名
  • XHTML ASCII
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XHTML 模块

  • Previous Page
  • Next Page

XHTML 模块化模型定义了 XHTML 的模块。

XHTML 模块化的原因

XHTML 是简单而庞大的语言。XHTML 包含了网站开发者需要的大多数功能。

对于某些特殊的用途，XHTML 太大且太复杂，而对于其他的用途，它又太简单了。

通过将 XHTML 分为若干模块，W3C 已经创造出数套小巧且定义良好的 XHTML 元素，这些元素既可被独立应用于简易设备，又可以与其他 XML 标准并入大型且更复杂的应用程序。

通过使用模块化的 XHTML，产品和软件设计者可以：

  • 选择被某个使用标准 XHTML 构件的设备所支持的元素。
  • 在不打破 XHTML 标准的情况下，使用 XML 对 XHTML 进行扩展。
  • 针对诸如掌上电脑、移动电话、电视机和家用电器之类的设备，对 XHTML 进行简化。
  • 通过添加新的 XML 功能(比如MathML, SVG, 语音和多媒体)，针对复杂的应用对 XHTML 进行扩展。
  • 定义 XHTML 框架，比如 XHTML BASIC (针对移动设备的XHTML子集)。

XHTML 模块

W3C 已将 XHTML 的定义分为28种模型：

模块名称 | 描述
Applet Module (Applet模块) | 定义已被废弃的applet元素。
Base Module (基础模块) | 定义基本元素。
Basic Forms Module (基础表单模块) | 定义基本的表单元素 (forms)。
Basic Tables Module (基础表格模块) | 定义基本的表格元素 (table)。
Bi-directional Text Module (双向文本模块) | 定义bdo元素。
Client Image Map Module(客户端图像映射模块) | 定义浏览器端图像映射元素(image map elements)。
Edit Module (编辑模块) | 定义编辑元素删除和插入。
Forms Module (表单模块) | 定义所有在表单中使用的元素。
Frames Module (框架模块) | 定义frameset元素。
Hypertext Module (超文本模块) | 定义a元素。
Iframe Module (内联框架模块) | 定义iframe元素。
Image Module (图像模块) | 定义图像元素 (img)。
Intrinsic Events Module () | 定义事件属性 (event)，比如onblur和onchange。
Legacy Module (遗留模块) | 定义被废弃的元素和属性。
Link Module (链接模块) | 定义链接 (link)元素。
List Module (列表模块) | 定义列表元素ol, li, ul, dd, dt,和dl。
Metainformation Module (元信息模块) | 定义meta元素。
Name Identification Module (名称识别模块) | 定义已被废弃的name属性。
Object Module (对象模块) | 定义对象元素 (object)和param元素。
Presentation Module (表现模块) | 定义表现元素比如b和i。
Scripting Module (脚本模块) | 定义脚本 (script)和无脚本 (noscript)元素。
Server Image Map Module(服务器端图像映射模块) | 定义服务器端图像映射(server side image map)元素
Structure Module (结构模块) | 定义以下元素：html, head, title and body。
Style Attribute Module (样式属性模块) | 定义样式属性。
Style Sheet Module (样式表模块) | 定义样式元素。
Tables Module (表格模块) | 定义用于表格中的元素。
Target Module (Target模块) | 定义target属性。
Text Module (文本模块) | 定义文本容器元素 (text container)，比如p和h1。

*注：已被废弃的元素不应被用于XHTML之中。

  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


XHTML 事件属性

XHTML 教程

  • XHTML 首页
  • XHTML 简介
  • XHTML Why
  • XHTML v HTML
  • XHTML 语法
  • XHTML DTD
  • XHTML HowTo
  • XHTML 验证
  • XHTML 模块
  • XHTML 属性
  • XHTML 事件
  • XHTML 总结
  • XHTML 结构化 1
  • XHTML 结构化 2

测验

  • XHTML 测验

参考手册

  • XHTML 标签列表
  • XHTML 属性
  • XHTML 事件
  • XHTML 颜色名
  • XHTML ASCII
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XHTML 事件属性

  • Previous Page
  • Next Page

HTML 4.0 的新特性之一是使 HTML 事件触发浏览器中的行为，比方说当用户点击一个 HTML 元素时启动一段 JavaScript 。以下就是可被插入 HTML 标签以定义事件行为的一系列属性。

假如你希望学习如何使用这些事件进行编程，那么你应该学习我们的 JavaScript 教程 和 DHTML 教程。

窗口事件 (Window Events)

仅在 body 和 frameset 元素中有效。

属性 | 值 | 描述
onload | 脚本 | 当文档被载入时执行脚本
onunload | 脚本 | 当文档被卸下时执行脚本

表单元素事件 (Form Element Events)

仅在表单元素中有效。

属性 | 值 | 描述
onchange | 脚本 | 当元素改变时执行脚本
onsubmit | 脚本 | 当表单被提交时执行脚本
onreset | 脚本 | 当表单被重置时执行脚本
onselect | 脚本 | 当元素被选取时执行脚本
onblur | 脚本 | 当元素失去焦点时执行脚本
onfocus | 脚本 | 当元素获得焦点时执行脚本

键盘事件 (Keyboard Events)

在下列元素中无效：base, bdo, br, frame, frameset, head, html, iframe, meta, param, script, style, 以及 title 元素。

属性 | 值 | 描述
onkeydown | 脚本 | 当键盘被按下时执行脚本
onkeypress | 脚本 | 当键盘被按下后又松开时执行脚本
onkeyup | 脚本 | 当键盘被松开时执行脚本

鼠标事件 (Keyboard Events)

在下列元素中无效：base, bdo, br, frame, frameset, head, html, iframe, meta, param, script, style, title 元素。

属性 | 值 | 描述
onclick | 脚本 | 当鼠标被单击时执行脚本
ondblclick | 脚本 | 当鼠标被双击时执行脚本
onmousedown | 脚本 | 当鼠标按钮被按下时执行脚本
onmousemove | 脚本 | 当鼠标指针移动时执行脚本
onmouseout | 脚本 | 当鼠标指针移出某元素时执行脚本
onmouseover | 脚本 | 当鼠标指针悬停于某元素之上时执行脚本
onmouseup | 脚本 | 当鼠标按钮被松开时执行脚本
  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


XHTML 验证

XHTML 教程

  • XHTML 首页
  • XHTML 简介
  • XHTML Why
  • XHTML v HTML
  • XHTML 语法
  • XHTML DTD
  • XHTML HowTo
  • XHTML 验证
  • XHTML 模块
  • XHTML 属性
  • XHTML 事件
  • XHTML 总结
  • XHTML 结构化 1
  • XHTML 结构化 2

测验

  • XHTML 测验

参考手册

  • XHTML 标签列表
  • XHTML 属性
  • XHTML 事件
  • XHTML 颜色名
  • XHTML ASCII
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XHTML 验证

  • Previous Page
  • Next Page

XHTML 文档是根据文档类型声明进行验证的。

通过 DTD 验证 XHTML

XHTML 文档是根据文档类型声明（DTD）进行验证的。只有将正确的 DTD 添加到文件的首行，XHTML 文件才会被正确地验证。

严格 DTD 包含没有被反对使用的或不出现在框架结构中的元素和属性：

!DOCTYPE html PUBLIC
"-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"

过渡 DTD 包含严格 DTD 中的一切，外加那些不赞成使用的元素和属性。

!DOCTYPE html PUBLIC
"-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"

框架 DTD 包含过渡 DTD 中的一切，外加框架。

!DOCTYPE html PUBLIC
"-//W3C//DTD XHTML 1.0 Frameset//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-frameset.dtd"

这个一个简单的 XHTML 文档：

<!DOCTYPE html
PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html>

<head>
<title>simple document</title>
</head>

<body>
<p>a simple paragraph</p>
</body>

</html>

使用 W3C 验证器来测试你的 XHTML

在下面的文本框中输入你的网址：

  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


XHTML 语法

XHTML 教程

  • XHTML 首页
  • XHTML 简介
  • XHTML Why
  • XHTML v HTML
  • XHTML 语法
  • XHTML DTD
  • XHTML HowTo
  • XHTML 验证
  • XHTML 模块
  • XHTML 属性
  • XHTML 事件
  • XHTML 总结
  • XHTML 结构化 1
  • XHTML 结构化 2

测验

  • XHTML 测验

参考手册

  • XHTML 标签列表
  • XHTML 属性
  • XHTML 事件
  • XHTML 颜色名
  • XHTML ASCII
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XHTML 语法

  • Previous Page
  • Next Page

编写 XHTML 代码需要纯净的 HTML 语法。

更多的 XHTML 语法规则：
  • 属性名称必须小写
  • 属性值必须加引号
  • 属性不能简写
  • 用 Id 属性代替 name 属性
  • XHTML DTD 定义了强制使用的 HTML 元素

属性名称必须小写

这是错误的：

<table WIDTH="100%">

这是正确的：

<table width="100%">

属性值必须加引号

这是错误的：

<table width=100%>

这是正确的：

<table width="100%">

属性不能简写

这是错误的：

<input checked>
<input readonly>
<input disabled>
<option selected>
<frame noresize>

这是正确的：

<input checked="checked" />
<input readonly="readonly" />
<input disabled="disabled" />
<option selected="selected" />
<frame noresize="noresize" />

下面是一个 HTML 的简写属性列表，以及在 XHTML 中的改写：

HTML | XHTML
compact | compact="compact"
checked | checked="checked"
declare | declare="declare"
readonly | readonly="readonly"
disabled | disabled="disabled"
selected | selected="selected"
defer | defer="defer"
ismap | ismap="ismap"
nohref | nohref="nohref"
noshade | noshade="noshade"
nowrap | nowrap="nowrap"
multiple | multiple="multiple"
noresize | noresize="noresize"

用 id 属性代替 name 属性

HTML 4.01 针对下列元素定义 name 属性：a, applet, frame, iframe, img, 和map。

在 XHTML 中不鼓励使用 name 属性，应该使用 id 取而代之。

这是错误的：

<img src="picture.gif" name="picture1" />

这是正确的：

<img src="picture.gif" id="picture1" />

重要的兼容性提示：

你应该在 "/" 符号前添加一个额外的空格，以使你的 XHTML 与当今的浏览器相兼容。

语言属性（Lang）

Lang 属性应用于几乎所有的 XHTML 元素。它定义元素内部的内容的所用语言的类型。

如果在某元素中使用 lang 属性，就必须添加额外的 xml:lang，像这样：

<div lang="no" xml:lang="no">Heia Norge!</div>

强制使用的 XHTML 元素

所有 XHTML 文档必须进行文件类型声明（DOCTYPE declaration）。在 XHTML 文档中必须存在html、head、body元素，而 title 元素必须位于在 head 元素中。

下面是一个最小化的 XHTML 文件模板：

<!DOCTYPE Doctype goes here>
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>Title goes here</title>
</head>

<body>
</body>

</html>

提示：文件类型声明并非 XHTML 文档自身的组成部分。它并不是 XHTML 元素，也没有关闭标签。

提示：在 XHTML 中，<html> 标签内的 xmlns 属性是必需的。然而，即使当 XHTML 文档中没有这个属性时，w3.org 的验证工具也不会提示错误。这是因为，"xmlns=http://www.w3.org/1999/xhtml" 是一个固定的值，即使你没有把它包含在代码中，这个值也会被添加到 <html> 标签中。

你会在下一章学习更多关于 XHTML 文档类型声明的知识。

  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


XHTML 总结

XHTML 教程

  • XHTML 首页
  • XHTML 简介
  • XHTML Why
  • XHTML v HTML
  • XHTML 语法
  • XHTML DTD
  • XHTML HowTo
  • XHTML 验证
  • XHTML 模块
  • XHTML 属性
  • XHTML 事件
  • XHTML 总结
  • XHTML 结构化 1
  • XHTML 结构化 2

测验

  • XHTML 测验

参考手册

  • XHTML 标签列表
  • XHTML 属性
  • XHTML 事件
  • XHTML 颜色名
  • XHTML ASCII
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

你已经学习了XHTML，现在还需要学习什么呢？

  • Previous Page
  • Next Page

XHTML 概要

本教程已经向你教授了如何创建更严谨纯净的 HTML 页面。

你已经知道所有的 XHTML 元素都必须被正确地嵌套，XHTML 必须拥有良好的结构，所有的标签必须小写，并且所有的 XHTML 元素必须被关闭。

你也学到了所有的 XHTML 文档必须拥有 DOCTYPE 声明，并且 html、head、title 和 body 元素必须存在。

如果需要关于 XHTML 的更多信息，请查看我们的 XHTML 参考手册 。

课外阅读

如果希望继续深入学习 XHTML，请务必阅读 w3school 提供的 XHTML 课外书：

  • XHTML 结构化之一：使用 XHTML 重构网站
  • XHTML 结构化之二：案例分析：W3school 的结构化标记

现在你已经学会了 XHTML，下一步学习什么呢？

下一步你需要学习 CSS 和 JavaScript 。

CSS

CSS 被用于在同时控制多重页面的样式和布局。

通过使用 CSS，所有的格式化任务均可被移出 HTML 文档，并存储于一个独立的文件中。

在不把文档内容搞乱的情况下，CSS 允许你对布局进行完全地控制。

请访问我们的 《CSS 教程》，来学习如何创建样式表。

JavaScript

JavaScript 可使网站的动态性更强。

当你仅仅想展示固定不变的内容时，静态站点是不错的。然而动态站点可以对事件作出响应，并允许用户进行交互。

JavaScript 是因特网上最流行的脚本语言，并且它可以运行于所有的主流浏览器。

请访问我们的 《JavaScript 教程》 ，来学习更多关于 JavaScript 的知识。

  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


如何升级至 XHTML？

XHTML 教程

  • XHTML 首页
  • XHTML 简介
  • XHTML Why
  • XHTML v HTML
  • XHTML 语法
  • XHTML DTD
  • XHTML HowTo
  • XHTML 验证
  • XHTML 模块
  • XHTML 属性
  • XHTML 事件
  • XHTML 总结
  • XHTML 结构化 1
  • XHTML 结构化 2

测验

  • XHTML 测验

参考手册

  • XHTML 标签列表
  • XHTML 属性
  • XHTML 事件
  • XHTML 颜色名
  • XHTML ASCII
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

如何升级至 XHTML？

  • Previous Page
  • Next Page

如何将你的网站升级至 XHTML ？

为了将站点从 HTML 转换为 XHTML，你首先应该熟悉前几章讲解的 XHTML 语法规则。

下面讲解具体的步骤。

添加文件类型声明

将下面的文件类型声明添加至每页的首行：

<!DOCTYPE html PUBLIC
"-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

注意：本站 (w3school) 使用的是严格的 DTD。不过使用过渡的 DTD 也是个不错的选择，因为对于大多数入门的开发人员来说，严格的 DTD 可能显得“太严格了”。

关于文件类型声明的一点提示

如果你希望将页面验证为正确的 XHTML，那么页面中必须含有文件类型声明。

需要注意的是，根据不同的文件类型声明，新式的浏览器（比如 Internet Explorer 6）对文档的处理方式也是不同的。如果浏览器读到一个文件类型声明，那么它会按照“恰当”的方式来处理文档。如果没有 DOCTYPE，文档也许会以截然不同的方式显示出来。

小写的标签和属性名

由于 XHTML 对大小写敏感，同时也由于 XHTML 仅接受小写 HTML 标签和属性名，因此你可以执行一个简单的搜索和替换命令将所有的大写标签改为小写。对属性名也要做同样的处理。我们一直使用在自己的网站使用小写字母，因此基本上，替换功能没有太多地排上用场。

给所有属性加上引号

由于 W3C XHTML 1.0 标准中要求所有的属性值都必须加引号，所以，如果以前没有注意到这个细节，你需要逐页地对网站进行检查。这是一项费时的工作，所以绝不要再忘记为属性值加引号了。

空标签：<hr> , <br> 和 <img>

在 XHTML 中是不允许使用空标签（Empty tags）的。<hr> 和 <br> 标签应该被替换为 <hr /> 和 <br />。

这样做又产生了一个新问题，Netscape 会误读 <br/> 标签。我们不清楚原因所在，不过将之改为 <br />后就没有问题了。认识到这一点后，你需要再一次通过搜索和替换功能对标签进行更改。

其他一些标签（比如 <img> 标签）也会碰到上述同样的问题。不要使用闭合标签来关闭 <img>，而是要在标签的末端添加 / >。

验证站点

做完所有这一切以后，使用下面的链接根据官方的 W3C DTD 对所有修改过的页面进行验证： XHTML Validator。接下来，可能还会有少数的错误被发现，逐一对这些错误进行（手工地）修正。我们的经验是，最容易犯的错误是在列表中漏掉了 </li> 标签。

我们应该使用转换工具吗（比方说 TIDY）？对，我们本可以使用 TIDY。

Dave Raggett 的 HTML TIDY是用来清理HTML代码的免费工具。在处理那些由专门的 HTML 代码编辑器和转换工具生成的难以阅读的HTML代码方面，TIDY 还是做得很棒的。同时，它可以帮助你发现站点中哪些地方需要投入更多精力，使得对于残疾人士，网页具有更强的易用性。

我们没有使用 Tidy 是出于什么原因呢？当我们开始创建这个网站时，我们已经对 XHTML 非常地熟悉。当时我们已经知道使用小写标签以及为属性加引号。所以在网站测试的过程中，我们只是简单地通过 W3C 的 XHTML 验证器进行了测试，并修正了少许的错误。更重要的是，我们已经学到了很多关于编写 Tidy 式 HTML 代码的知识。

课外阅读

如果您希望更深入的理解利用 XHTML 对页面进行结构化的知识，请阅读《XHTML 结构化》。

  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


为什么要使用XHTML？

XHTML 教程

  • XHTML 首页
  • XHTML 简介
  • XHTML Why
  • XHTML v HTML
  • XHTML 语法
  • XHTML DTD
  • XHTML HowTo
  • XHTML 验证
  • XHTML 模块
  • XHTML 属性
  • XHTML 事件
  • XHTML 总结
  • XHTML 结构化 1
  • XHTML 结构化 2

测验

  • XHTML 测验

参考手册

  • XHTML 标签列表
  • XHTML 属性
  • XHTML 事件
  • XHTML 颜色名
  • XHTML ASCII
  • HTTP 消息

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

为什么要使用XHTML？

  • Previous Page
  • Next Page

XHTML 是 HTML 与 XML（扩展标记语言）的结合物。

XHTML 包含了所有与 XML 语法结合的 HTML 4.01 元素。

为什么要使用XHTML？

我们认为万维网上的许多页面都包含着糟糕的 HTML 代码。

下面的 HTML 代码仍然可以工作得很好，即使它没有遵守 HTML 规则：

<html>
<head>
<title>This is bad HTML</title>
<body>
<h1>Bad HTML
</body>

XML 是一种标记化语言，其中所有的东西都要被正确的标记，以产生形式良好的文档。

XML 用来描述数据，而 HTML 则用来显示数据。

今天的市场中存在着不同的浏览器技术，某些浏览器运行在计算机中，某些浏览器则运行在移动电话和手持设备上。而后者没有能力和手段来解释糟糕的标记语言。

因此，通过把 HTML 和 XML 各自的长处加以结合，我们得到了在现在和未来都能派上用场的标记语言 - XHTML。

XHTML 可以被所有的支持 XML 的设备读取，同时在其余的浏览器升级至支持 XML 之前，XHTML 使我们有能力编写出拥有良好结构的文档，这些文档可以很好地工作于所有的浏览器，并且可以向后兼容。

  • Previous Page
  • Next Page

HTML 参考手册
HTML 实例
HTML 测验


XLink 参考手册

XLINK 基础

  • XLink 首页
  • XLink 简介
  • XLink 语法
  • XLink 实例
  • XPointer 实例
  • XLink 总结

参考手册

  • XLink 属性

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XLink 参考手册

  • Previous Page
  • Next Page

XLink 属性 参考手册

属性 | 值 | 描述
xlink:actuate
  • onLoad
  • onRequest
  • other
  • none
 定义何时读取和显示被链接的资源。
xlink:href | URL | 要链接的 URL。
xlink:show
  • embed
  • new
  • replace
  • other
  • none
 在何处打开链接。Replace 是默认值。
xlink:type
  • simple
  • extended
  • locator
  • arc
  • resource
  • title
  • none
 链接的类型。
  • Previous Page
  • Next Page

XLink 参考手册


XLink 和 XPointer 教程

XLINK 基础

  • XLink 首页
  • XLink 简介
  • XLink 语法
  • XLink 实例
  • XPointer 实例
  • XLink 总结

参考手册

  • XLink 属性

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XLink 和 XPointer 教程

  • Next Page

XLink 定义在 XML 文档中创建超级链接的标准方法。

XPointer 允许这些超级链接指向 XML 文档中的更多具体部分（片断）。

开始学习 XLink 和 XPointer ！

内容目录

XLink 和 XPointer 简介
本章阐述 XLink 和 XPointer 的概念。
XLink 和 XPointer 语法
XLink 和 XPointer 的语法。
XLink 实例
一个在 XML 文档中使用 XLink 的实例。
XPointer 实例
一个在 XML 文档中使用 XLink 和 XPointer 的实例。
XLink 总结
本文包括在本教程所学内容的一个总结，以及我们向你推荐的下一步应该学习的内容。
XLink 属性参考
XLink 属性的参考表格。
  • Next Page

XLink 参考手册


XLink 和 XPointer 语法

XLINK 基础

  • XLink 首页
  • XLink 简介
  • XLink 语法
  • XLink 实例
  • XPointer 实例
  • XLink 总结

参考手册

  • XLink 属性

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XLink 和 XPointer 语法

  • Previous Page
  • Next Page

XLink 语法

在 HTML 中，我们知道 <a> 元素可定义超级链接。不过 XML 不是这样工作的。在 XML 文档中，您可以使用任何你需要的名称 - 因此对于浏览器来说是无法预知在 XML 文档中可调用何种超级链接元素。

在 XML 文档中定义超级链接的方法是在元素上放置可用作超级链接的标记。

下面是在 XML 文档中使用 XLink 来创建链接的简单实例：

<?xml version="1.0"?>

<homepages xmlns:xlink="http://www.w3.org/1999/xlink">

  <homepage xlink:type="simple"
  xlink:href="http://www.w3school.com.cn">Visit W3School</homepage>

  <homepage xlink:type="simple"
  xlink:href="http://www.w3.org">Visit W3C</homepage>

</homepages>

为了访问 XLink 的属性和特性，我们必须在文档的顶端声明 XLink 命名空间。

XLink 的命名空间是："http://www.w3.org/1999/xlink"。

<homepage> 元素中的 xlink:type 和 xlink:href 属性定义了来自 XLink 命名空间的 type 和 href 属性。

xlink:type="simple" 可创建一个简单的两端链接（意思是“从这里到哪里”）。稍后我们会研究多端链接（多方向）。

XPointer 语法

在 HTML 中，我们可创建一个既指向某个 HTML 页面又指向 HTML 页面内某个书签的超级链接（使用#）。

有时，可指向更多具体的内容会更有好处。举例，我们需要指向某个特定的列表的第三个项目，或者指向第五段的第二行。通过 XPointer 是很容易做到的。

假如超级链接指向某个 XML 文档，我们可以在 xlink:href 属性中把 XPointer 部分添加到 URL 后面，这样就可以导航（通过 XPath 表达式）到文档中某个具体的位置了。

举例，在下面的例子中，我们通过唯一的 id “rock” 使用 XPointer 指向某个列表中的第五个项目。

href="http://www.example.com/cdlist.xml#id('rock').child(5,item)"
  • Previous Page
  • Next Page

XLink 参考手册


XLink 实例

XLINK 基础

  • XLink 首页
  • XLink 简介
  • XLink 语法
  • XLink 实例
  • XPointer 实例
  • XLink 总结

参考手册

  • XLink 属性

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XLink 实例

  • Previous Page
  • Next Page

让我们通过研究一个实例来学习一些基础的 XLink 语法

XML 实例文档

请看下面的 XML 文档，"bookstore.xml"，它用来呈现书籍：

<?xml version="1.0" encoding="ISO-8859-1"?>

<bookstore xmlns:xlink="http://www.w3.org/1999/xlink">

<book title="Harry Potter">
  <description
  xlink:type="simple"
  xlink:href="http://book.com/images/HPotter.gif"
  xlink:show="new">
  As his fifth year at Hogwarts School of Witchcraft and
  Wizardry approaches, 15-year-old Harry Potter is.......
  </description>
</book>

<book title="XQuery Kick Start">
  <description
  xlink:type="simple"
  xlink:href="http://book.com/images/XQuery.gif"
  xlink:show="new">
  XQuery Kick Start delivers a concise introduction
  to the XQuery standard.......
  </description>
</book>

</bookstore>

在您的浏览器查看 "bookstore.xml" 文件。

在上面的例子中，XLink 文档命名空间被声明于文档的顶部：

xmlns:xlink="http://www.w3.org/1999/xlink"

这意味着文档可访问 XLink 的属性和特性。

xlink:type="simple" 可创建简单的类似 HTML 的链接。您也可以规定更多的复杂的链接（多方向链接），但是目前，我们仅使用简易链接。

xlink:href 属性规定了要链接的 URL，而 xlink:show 属性规定了在何处打开链接。xlink:show="new" 意味着链接（在此例中，是一幅图像）会在新窗口打开。

  • Previous Page
  • Next Page

XLink 参考手册


XLink 以及 XPointer 简介

XLINK 基础

  • XLink 首页
  • XLink 简介
  • XLink 语法
  • XLink 实例
  • XPointer 实例
  • XLink 总结

参考手册

  • XLink 属性

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XLink 以及 XPointer 简介

  • Previous Page
  • Next Page

XLink 定义了一套标准的在 XML 文档中创建超级链接的方法。

XPointer 使超级链接可以指向 XML 文档中更多具体的部分（片断）。

您应当具备的基础知识

在继续学习之前，您需要对以下知识点有基本的了解：

  • HTML / XHTML
  • XML / XML 命名空间
  • XPath

如果您希望首先学习这些项目，请在我们对 首页 访问这些教程。

什么是 XLink？

  • XLink 是 XML 链接语言（XML Linking Language）的缩写
  • XLink 是用于在 XML 文档中创建超级链接的语言
  • XLink 类似于 HTML 链接 - 但是更为强大
  • XML 文档中的任何元素均可成为 XLink
  • XLink 支持简易链接，也支持可将多重资源链接在一起的扩展链接
  • 通过 XLink，链接可在被链接文件外进行定义
  • XLink 是 W3C 推荐标准

什么是 XPointer？

  • XPointer 是 XML 指针文件（XML Pointer Language）的缩写
  • XPointer 使超级链接可以指向 XML 文档中更多具体的部分（片断）
  • XPointer 使用 XPath 表达式在 XML 文档中进行定位
  • XPointer 是 W3C 推荐标准

XLink 和 XPointer 是 W3C 标准

在2001年6月27日，XLink 被确立为 W3C 推荐标准。

XPointer 于2003年3月25日成为 W3C 推荐标准。

您可以在我们的《W3C 教程》中阅读更多有关 XML 标准的内容。

XLink 和 XPointer 的浏览器支持

浏览器只在最小限度内支持 XLink 和 XPointer。

在 Mozilla 0.98+、Netscape 6.02+ 以及 Internet Explorer 6.0 中，均具有对 XLink 某种程度的支持。更早版本的浏览器根本不支持 XLink。

  • Previous Page
  • Next Page

XLink 参考手册


XPointer 实例

XLINK 基础

  • XLink 首页
  • XLink 简介
  • XLink 语法
  • XLink 实例
  • XPointer 实例
  • XLink 总结

参考手册

  • XLink 属性

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XPointer 实例

  • Previous Page
  • Next Page

让我们通过研究一个实例来学习一些基础的 XPointer 语法。

XPointer 实例

在本例中，我们会为您展示如何使用 XPointer 并结合 XLink 来指向另外一个文档的某个具体的部分。

我们将通过研究目标 XML 文档开始（即我们要链接的那个文档）。

目标XML文档

目标XML文档名为 "dogbreeds.xml"，它列出了一些不同的狗种类：

<?xml version="1.0" encoding="ISO-8859-1"?>

<dogbreeds>

<dog breed="Rottweiler" id="Rottweiler">
  <picture url="http://dog.com/rottweiler.gif" />
  <history>
  The Rottweiler's ancestors were probably Roman
  drover dogs.....
  </history>
  <temperament>
  Confident, bold, alert and imposing, the Rottweiler
  is a popular choice for its ability to protect....
  </temperament>
</dog>

<dog breed="FCRetriever" id="FCRetriever">
  <picture url="http://dog.com/fcretriever.gif" />
  <history>
  One of the earliest uses of retrieving dogs was to
  help fishermen retrieve fish from the water....
  </history>
  <temperament>
  The flat-coated retriever is a sweet, exuberant,
  lively dog that loves to play and retrieve....
  </temperament>
</dog>

</dogbreeds>

在您的浏览器查看 "dogbreeds.xml" 文件。

注释：上面的 XML 文档在每个我们需要链接的元素上使用了 id 属性！

XML 链接文档

不止能够链接到整个文档（当使用 XLink 时），XPointer 允许您链接到文档的特定部分。如需链接到页面的某个具体的部分，请在 xlink:href 属性中的 URL 后添加一个井号 (#) 以及一个 XPointer 表达式。

表达式：#xpointer(id("Rottweiler")) 可引用目标文档中 id 值为 "Rottweiler" 的元素。

因此，xlink:href 属性会类似这样：xlink:href="http://dog.com/dogbreeds.xml#xpointer(id('Rottweiler'))"

不过，当使用 id 链接到某个元素时，XPointer 允许简写形式。您可以直接使用 id 的值，就像这样：xlink:href="http://dog.com/dogbreeds.xml#Rottweiler"。

下面的 XML 文档可引用每条狗的品种信息，均通过 XLink 和 XPointer 来引用：

<?xml version="1.0" encoding="ISO-8859-1"?>

<mydogs xmlns:xlink="http://www.w3.org/1999/xlink">

<mydog xlink:type="simple"
  xlink:href="http://dog.com/dogbreeds.xml#Rottweiler">
  <description xlink:type="simple"
  xlink:href="http://myweb.com/mydogs/anton.gif">
  Anton is my favorite dog. He has won a lot of.....
  </description>
</mydog>

<mydog xlink:type="simple"
  xlink:href="http://dog.com/dogbreeds.xml#FCRetriever">
  <description xlink:type="simple"
  xlink:href="http://myweb.com/mydogs/pluto.gif">
  Pluto is the sweetest dog on earth......
  </description>
</mydog>

</mydogs>
  • Previous Page
  • Next Page

XLink 参考手册


您已经学习了 XLink，下一步呢？

XLINK 基础

  • XLink 首页
  • XLink 简介
  • XLink 语法
  • XLink 实例
  • XPointer 实例
  • XLink 总结

参考手册

  • XLink 属性

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

您已经学习了 XLink，下一步呢？

  • Previous Page
  • Next Page

XLink 概要

本教程已经向您讲解了在 XML 文档中创建超级链接的一种标准方法。

您已经明白了 XML 中的链接被分为两个部分：XLink 和 XPointer。

XLink 定义了一套在 XML 文档中创建超级链接的标准方法。XPointer 使超级链接有能力指向 XML 文档中更多具体的部分（片断）。

如需更多有关 XLink 的知识，请浏览我们的《XLink 参考手册》。

您已经学习了 XLink，下一步呢？

下一步应当学习 XQuery。

XQuery

XQuery 和 XML 查询有关。

XQuery 被设计用来查询任何可以 XML 形态呈现的数据，包括数据库。

如果您希望学习更多有关 XQuery 的知识，请访问我们的《XQuery 教程》。

  • Previous Page
  • Next Page

XLink 参考手册


Belgian Waffles - $5.95
two of our famous Belgian Waffles with plenty of real maple syrup (650 calories per serving)
Strawberry Belgian Waffles - $7.95
light Belgian waffles covered with strawberries and whipped cream (900 calories per serving)
Berry-Berry Belgian Waffles - $8.95
light Belgian waffles covered with an assortment of fresh berries and whipped cream (900 calories per serving)
French Toast - $4.50
thick slices made from our homemade sourdough bread (600 calories per serving)
Homestyle Breakfast - $6.95
two eggs, bacon or sausage, toast, and our ever-popular hash browns (950 calories per serving)


XML CDATA

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML CDATA

  • Previous Page
  • Next Page

所有 XML 文档中的文本均会被解析器解析。

只有 CDATA 区段（CDATA section）中的文本会被解析器忽略。

Parsed Data

XML 解析器通常会解析 XML 文档中所有的文本。

当某个 XML 元素被解析时，其标签之间的文本也会被解析：

<message>此文本也会被解析</message>

解析器之所以这么做是因为 XML 元素可包含其他元素，就像这个例子中，其中的 <name> 元素包含着另外的两个元素(first 和 last)：

<name><first>Bill</first><last>Gates</last></name>

而解析器会把它分解为像这样的子元素：

<name>
   <first>Bill</first>
   <last>Gates</last>
</name>

转义字符

非法的 XML 字符必须被替换为实体引用（entity reference）。

假如您在 XML 文档中放置了一个类似 "<" 字符，那么这个文档会产生一个错误，这是因为解析器会把它解释为新元素的开始。因此你不能这样写：

<message>if salary < 1000 then</message>

为了避免此类错误，需要把字符 "<" 替换为实体引用，就像这样：

<message>if salary &lt; 1000 then</message>

在 XML 中有 5 个预定义的实体引用：

&lt; | < | 小于
&gt; | > | 大于
&amp; | & | 和号
&apos; | ' | 省略号
&quot; | " | 引号

注释：严格地讲，在 XML 中仅有字符 "<"和"&" 是非法的。省略号、引号和大于号是合法的，但是把它们替换为实体引用是个好的习惯。

CDATA

CDATA 内部的所有东西都会被解析器忽略。

假如文本中包含了大量的 "<" 和 "&" 字符 - 就像编程代码中经常出现的情况一样 - 那么这个 XML 元素就可以被定义为一个 CDATA 部分。

CDATA 区段开始于 "<![CDATA["，结束于 "]]>"：

<script>
<![CDATA[
function matchwo(a,b)
{
if (a < b && a < 0)
   {
   return 1
   }
else
   {
   return 0
   }
}
]]>
</script>

在上面的例子中，在 CDATA 区段中的所有东西都会被解析器忽略。

关于 CDATA 区段的注释：

CDATA 区段不能包含字符串 "]]>"，所以，CDATA 区段的嵌套是不被允许的。

同时也需要确保在 "]]>" 字符串中没有空格或折行。

  • Previous Page
  • Next Page

XML 实例
XML 测验


XML DOM

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM

  • Previous Page
  • Next Page

DOM （Document Object Model，文档对象模型）定义访问和操作文档的一套标准方法。

XML DOM

XML DOM (XML Document Object Model) 定义一套访问和操作 XML 文档的标准方法。

DOM 把 XML 文档作为树结构来查看。能够通过 DOM 树来访问所有元素。可以修改或删除它们的内容，并创建新的元素。元素，它们的文本，以及它们的属性，都被认为是节点。

在下面的例子中，我们使用 DOM 引用从 <to> 元素中获取文本：

xmlDoc.getElementsByTagName("to")[0].childNodes[0].nodeValue
  • xmlDoc -由解析器创建的 XML 文档
  • getElementsByTagName("to")[0] - 第一个 <to> 元素
  • childNodes[0] - <to> 元素的第一个子元素（文本节点）
  • nodeValue - 节点的值（文本本身）

您可以在 W3School 的 XML DOM 教程 中学习更多相关知识。

HTML DOM

HTML DOM (HTML Document Object Model) 定义一套访问和操作 HTML 文档的标准方法。

可以通过 HTML DOM 访问所有 HTML 元素。

在下面的例子中，我们使用 DOM 引用来改变 id="to" 的 HTML 元素的文本：

document.getElementById("to").innerHTML=
  • document - HTML 文档
  • getElementById("to") - 其中的 id="to" 的 HTML 元素
  • innerHTML - HTML 元素的内部文本

您可以在 W3School 的 HTML DOM 教程 中学习更多相关知识。

解析 XML 文件 - 跨浏览器实例

下列代码把一个 XML 文档 ("note.xml") 载入 XML 解析器中：

<html>
<head>
<script type="text/javascript">
function parseXML()
{
try //Internet Explorer
  {
  xmlDoc=new ActiveXObject("Microsoft.XMLDOM");
  }
catch(e)
  {
  try //Firefox, Mozilla, Opera, etc.
    {
    xmlDoc=document.implementation.createDocument("","",null);
    }
  catch(e)
    {
    alert(e.message);
    return;
    }
  }
xmlDoc.async=false;
xmlDoc.load("note.xml");

document.getElementById("to").innerHTML=
xmlDoc.getElementsByTagName("to")[0].childNodes[0].nodeValue;
document.getElementById("from").innerHTML=
xmlDoc.getElementsByTagName("from")[0].childNodes[0].nodeValue;
document.getElementById("message").innerHTML=
xmlDoc.getElementsByTagName("body")[0].childNodes[0].nodeValue;
}
</script>
</head>

<body onload="parseXML()">
<h1>W3School.com.cn Internal Note</h1>
<p><b>To:</b> <span id="to"></span><br />
<b>From:</b> <span id="from"></span><br />
<b>Message:</b> <span id="message"></span>
</p>
</body>
</html>

输出：

W3School.com.cn Internal Note

To: George
From: John
Message: Don't forget the meeting!

TIY

重要注释

如需从 XML 中提取文本 "John"，语法是：

getElementsByTagName("from")[0].childNodes[0].nodeValue

在这个 XML 例子中，只有一个 <from> 标签中，但是仍然需要规定数组的下标 [0]，这是因为 XML 解析器方法 getElementsByTagName() 返回所有 <from> 节点的一个数组。

解析 XML 字符串 - 跨浏览器实例

下面的代码加载并解析一个 XML 字符串：

<html>
<head>
<script type="text/javascript">
function parseXML()
{
text="<note>";
text=text+"<to>George</to>";
text=text+"<from>John</from>";
text=text+"<heading>Reminder</heading>";
text=text+"<body>Don't forget the meeting!</body>";
text=text+"</note>";
try //Internet Explorer
  {
  xmlDoc=new ActiveXObject("Microsoft.XMLDOM");
  xmlDoc.async="false";
  xmlDoc.loadXML(text);
  }
catch(e)
  {
  try // Firefox, Mozilla, Opera, etc.
    {
    parser=new DOMParser();
    xmlDoc=parser.parseFromString(text,"text/xml");
    }
  catch(e)
    {
    alert(e.message);
    return;
    }
  }
document.getElementById("to").innerHTML=
xmlDoc.getElementsByTagName("to")[0].childNodes[0].nodeValue;
document.getElementById("from").innerHTML=
xmlDoc.getElementsByTagName("from")[0].childNodes[0].nodeValue;
document.getElementById("message").innerHTML=
xmlDoc.getElementsByTagName("body")[0].childNodes[0].nodeValue;
}
</script>
</head>

<body onload="parseXML()">
<h1>W3School.com.cn Internal Note</h1>
<p><b>To:</b> <span id="to"></span><br />
<b>From:</b> <span id="from"></span><br />
<b>Message:</b> <span id="message"></span>
</p>
</body>
</html>

输出：

W3School.com.cn Internal Note

To: George
From: John
Message: Don't forget the meeting!

TIY

注释：Internet Explorer 使用 loadXML() 方法来解析 XML 字符串，而其他浏览器使用 DOMParser 对象。

  • Previous Page
  • Next Page

XML 实例
XML 测验


XML DOM 高级

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM 高级

  • Previous Page
  • Next Page

XML DOM (Document Object Model) 定义了访问和操作 XML 文档的标准方法。

XML DOM

DOM 把 XML 文档视为一种树结构。通过这个 DOM 树，可以访问所有的元素。可以修改它们的内容（文本以及属性），而且可以创建新的元素。元素，以及它们的文本和属性，均被视为节点。

在本教程的较早章节中，我们介绍了 XML DOM，并使用了 XML DOM 的 getElementsByTagName() 从 DOM 树中取回数据。

在本节中，我们将讲解一些其他较常用的 XML DOM 方法。在本例中，我们使用 XML 文件 books.xml，并使用一个 JavaScript 函数把 XML 文件加载到名为 xmlDoc 的 DOM 对象中。

如需学习更多有关 XML DOM 的知识，请访问我们的 XML DOM 教程。

获取元素的值

下面的代码检索第一个 <title> 元素的文本值：

x=xmlDoc.getElementsByTagName("title")[0].childNodes[0];
txt=x.nodeValue;

结果：txt = "Everyday Italian"

TIY

获取属性的值

下面的代码检索第一个 <title> 元素的 "lang" 属性的文本值：

txt=xmlDoc.getElementsByTagName("title")[0].getAttribute("lang");

结果：txt = "en"

TIY

改变元素的值

下面的代码改变第一个 <title> 元素的文本值：

x=xmlDoc.getElementsByTagName("title")[0].childNodes[0];
x.nodeValue="Easy Cooking";

TIY

改变属性的值

setAttribute() 方法可用于改变已有属性的值，或创建一个新属性。

下面的代码向每个 <book> 元素添加了名为 "edition" 的新属性（值是 "first"）：

x=xmlDoc.getElementsByTagName("book");

for(i=0;i<x.length;i++)
  {
  x[i].setAttribute("edition","first");
  }

TIY

创建元素

createElement() 方法创建新的元素节点。

createTextNode() 方法创建新的文本节点。

appendChild() 方法向节点添加子节点（在最后一个子节点之后）。

如需创建带有文本内容的新元素，需要同时创建元素节点和文本节点。

下面的代码创建了一个元素 (<edition>)，然后把它添加到第一个 <book> 元素中：

newel=xmlDoc.createElement("edition");
newtext=xmlDoc.createTextNode("First");
newel.appendChild(newtext);

x=xmlDoc.getElementsByTagName("book");
x[0].appendChild(newel);

例子解释：

  1. 创建 <edition> 元素
  2. 创建值为 "First" 的文本节点
  3. 把这个文本节点追加到 <edition> 元素
  4. 把 <edition> 元素追加到第一个 <book> 元素

TIY

删除元素

removeChild() 方法删除指定的节点（或元素）。

下面的代码片段将删除第一个 <book> 元素中的第一个节点：

x=xmlDoc.getElementsByTagName("book")[0];

x.removeChild(x.childNodes[0]);

TIY

注释：上例的结果可能会根据所用的浏览器而不同。Firefox 把新行字符当作空的文本节点，而 Internet Explorer 不是这样。您可以在 w3school 的 XML DOM 教程中阅读到更多有关这个问题以及如何避免它的知识。

这里提供的 XML DOM 实例，只想您展示了少数几个我们可以利用 XML DOM 完成的工作。

如需学习更多有关 XML DOM 的知识，请访问 w3school 的 XML DOM 教程。

  • Previous Page
  • Next Page

XML 实例
XML 测验


XML Don't

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML Don't

  • Previous Page
  • Next Page

您应该在使用 XML 时尽量避免本节列出的技术。

Internet Explorer - XML 数据岛

它是什么？XML 数据岛是嵌入 HTML 页面中的 XML 数据。

为什么要避免使用它？XML 数据岛只在 IE 浏览器中有效。

用什么代替它？您应当在 HTML 中使用 JavaScript 和 XML DOM 来解析并显示 XML。

如需更多有关 JavaScript 和 XML DOM 的信息，请访问 w3school 的 XML DOM 教程。

XML 数据岛实例

本例使用 XML 文档 "cd_catalog.xml"。

把 XML 文档绑定到 HTML 文档中的一个 <xml> 标签。id 属性为数据岛定义标识符，而 src 属性指向 XML 文件：

<html>
<body>

<xml id="cdcat" src="cd_catalog.xml"></xml>

<table border="1" datasrc="#cdcat">
<tr>
<td><span datafld="ARTIST"></span></td>
<td><span datafld="TITLE"></span></td>
</tr>
</table>

</body>
</html>

<table> 标签的 datasrc 属性把 HTML 表格绑定到 XML 数据岛。

<span> 标签允许 datafld 属性引用要显示的 XML 元素。在这个例子中，要引用的是 "ARTIST" 和 "TITLE"。当 XML 被读取时，会为每个 <CD> 元素创建额外的行。

如果您正在使用 Internet Explorer，可以亲自试一试。

Internet Explorer - 行为

它是什么？Internet Explorer 5 引入了行为（behaviors）。Behaviors 是通过使用 CSS 样式向 XML （或 HTML ）元素添加行为的一种方法。

为什么要避免使用它？只有 Internet Explorer 支持 behavior 属性。

使用什么代替它？使用 JavaScript 和 XML DOM （或 HTML DOM）来代替它。

实例

例子 1 - Mouseover Highlight

下面的 HTML 文件中的 <style> 元素为 <h1> 元素定义了一个行为：

<html>
<head>
<style type="text/css">
h1 { behavior: url(behave.htc) }
</style>
</head>

<body>
<h1>Mouse over me!!!</h1>
</body>
</html>

以下是 XML 文档 "behave.htc"：

<attach for="element" event="onmouseover" handler="hig_lite" />
<attach for="element" event="onmouseout" handler="low_lite" />

<script type="text/javascript">
function hig_lite()
{
element.style.color='red';
}

function low_lite()
{
element.style.color='blue';
}
</script>

这个 behavior 文件包含了一段 JavaScript，以及针对元素的事件句柄。

TIY （请把鼠标移到例子中的文本上）。

例子 2 - 打字机模拟

下面的 HTML 文件中的 <style> 元素为 id 为 "typing" 的元素定义了一个行为：

<html>
<head>
<style type="text/css">
#typing
{
behavior:url(typing.htc);
font-family:'courier new';
}
</style>
</head>

<body>
<span id="typing" speed="100">IE5 introduced DHTML behaviors.
Behaviors are a way to add DHTML functionality to HTML elements
with the ease of CSS.<br /><br />How do behaviors work?<br />
By using XML we can link behaviors to any element in a web page
and manipulate that element.</p>
</span>
</body>
</html>

以下是 XML 文档 "typing.htc"：

<attach for="window" event="onload" handler="beginTyping" />
<method name="type" />

<script type="text/javascript">
var i,text1,text2,textLength,t;

function beginTyping()
{
i=0;
text1=element.innerText;
textLength=text1.length;
element.innerText="";
text2="";
t=window.setInterval(element.id+".type()",speed);
}

function type()
{
text2=text2+text1.substring(i,i+1);
element.innerText=text2;
i=i+1;
if (i==textLength)
  {
  clearInterval(t);
  }
}
</script>

TIY

  • Previous Page
  • Next Page

XML 实例
XML 测验


XML Parser

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML 解析器

  • Previous Page
  • Next Page

大多数浏览器都有读取和操作 XML 的内建 XML 解析器。

解析器把 XML 转换为 JavaScript 可访问的对象。

实例

W3School 提供的实例是独立于浏览器和平台的。这些例子可以在所有现代浏览器中运行。

加载并解析 XML 文件
加载并解析 XML 字符串

解析 XML

所有现代浏览器都有读取和操作 XML 的内建 XML 解析器。

解析器把 XML 载入内存，然后把它转换为可通过 JavaScript 访问的 XML DOM 对象。

您将在本教程的下一节中学习更多有关 XML DOM 的知识。

微软的 XML 解析器与其他浏览器中的解析器之间，存在一些差异。微软的解析器支持 XML 文件和 XML 字符串（文本）的加载，而其他浏览器使用单独的解析器。不过，所有的解析器都包含遍历 XML 树、访问插入及删除节点（元素）及其属性的函数。

在本教程中，我们将为您展示如何创建可同时工作于 Internet Explorer 和其他浏览器中的脚本。

注释：当我们谈及 XML 解析，我们常常会使用有关 XML 元素的术语：节点。

通过微软的 XML 解析器来加载 XML

微软的 XML 解析器内建于 Internet Explorer 5 以及更高的版本中。

下面的 JavaScript 片段把一个 XML 文档载入解析器中：

var xmlDoc=new ActiveXObject("Microsoft.XMLDOM");
xmlDoc.async="false";
xmlDoc.load("note.xml");

例子解释：

  1. 上面代码的第一个行创建一个空的微软 XML 文档对象。
  2. 第二行关闭异步加载，这样确保在文档完全加载之前解析器不会继续脚本的执行。
  3. 第三行告知解析器加载名为 "note.xml" 的 XML 文档。

下面的 JavaScript 片段把字符串 txt 载入解析器：

var xmlDoc=new ActiveXObject("Microsoft.XMLDOM");
xmlDoc.async="false";
xmlDoc.loadXML(txt);

注释：loadXML() 方法用于加载字符串（文本），load() 用于加载文件。

在 Firefox 及其他浏览器中的 XML 解析器

下面的 JavaScript 片段把 XML 文档 ("note.xml") 载入解析器：

var xmlDoc=document.implementation.createDocument("","",null);
xmlDoc.async="false";
xmlDoc.load("note.xml");

例子解释：

  1. 上面代码的第一个行创建一个空的 XML 文档对象。
  2. 第二行关闭异步加载，这样确保在文档完全加载之前解析器不会继续脚本的执行。
  3. 第三行告知解析器加载名为 "note.xml" 的 XML 文档。

下面的 JavaScript 片段把字符串 txt 载入解析器：

var parser=new DOMParser();
var doc=parser.parseFromString(txt,"text/xml");

例子解释：

  1. 上面代码的第一个行创建一个空的微软 XML 文档对象。
  2. 第二行告知解析器载入名为 txt 的字符串。

注释：Internet Explorer 使用 loadXML() 方法来解析 XML 字符串，而其他浏览器使用 DOMParser 对象。

跨域访问

出于安全方面的原因，现代的浏览器不允许跨域的访问。

这意味着，网页以及它试图加载的 XML 文件，都必须位于相同的服务器上。

W3School 的实例所打开的 XML 文件位于 W3School 的域上。

假如你打算在自己的网页上使用上面的例子，则必须把 XML 文件放到自己的服务器上。否则，xmlDoc.load() 将产生错误 "Access is denied"。

XML DOM

在本教程的下一章节，您将学习如何从 XML 文档对象 (XML DOM) 来访问并取回数据。

  • Previous Page
  • Next Page

XML 实例
XML 测验


XML to HTML

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML to HTML

  • Previous Page
  • Next Page

本章讲解如何把 XML 数据显示为 HTML。

实例

把 XML 数据显示为 HTML 表格
从 XML 文件中加载数据，然后把数据显示为一个 HTML 表格

在 HTML 中显示数据

在上一节中，我们讲解了如何通过 JavaScript 来解析 XML 并访问 DOM。

本例遍历一个 XML 文件 (cd_catalog.xml)，然后把每个 CD 元素显示为一个 HTML 表格行：

<html>
<body>

<script type="text/javascript">
var xmlDoc=null;
if (window.ActiveXObject)
{
// code for IE
xmlDoc=new ActiveXObject("Microsoft.XMLDOM");
}
else if (document.implementation.createDocument)
{
// code for Mozilla, Firefox, Opera, etc.
xmlDoc=document.implementation.createDocument("","",null);
}
else
{
alert('Your browser cannot handle this script');
}
if (xmlDoc!=null)
{
xmlDoc.async=false;
xmlDoc.load("cd_catalog.xml");

document.write("<table border='1'>");

var x=xmlDoc.getElementsByTagName("CD");
for (i=0;i<x.length;i++)
{
document.write("<tr>");
document.write("<td>");
document.write(
x[i].getElementsByTagName("ARTIST")[0].childNodes[0].nodeValue);
document.write("</td>");

document.write("<td>");
document.write(
x[i].getElementsByTagName("TITLE")[0].childNodes[0].nodeValue);
document.write("</td>");
document.write("</tr>");
}
document.write("</table>");
}
</script>

</body>
</html>

TIY：在 HTML 表格中显示 XML 数据。

例子解释：

  1. 检测浏览器，然后使用合适的解析器来加载 XML
  2. 创建一个 HTML 表格（<table border="1">）
  3. 使用 getElementsByTagName() 来获得所有 XML 的 CD 节点
  4. 针对每个 CD 节点，把 ARTIST 和 TITLE 中的数据显示为表格数据
  5. 用 </table> 结束表格

如需更多有关 JavaScript 和 XML DOM 的信息，请访问我们的 XML DOM 教程。

跨域访问

出于安全方面的原因，现代的浏览器不允许跨域的访问。

这意味着，网页以及它试图加载的 XML 文件，都必须位于相同的服务器上。

W3School 的实例所打开的 XML 文件位于 W3School 的域上。

假如你打算在自己的网页上使用上面的例子，则必须把 XML 文件放到自己的服务器上。否则，xmlDoc.load() 将产生错误 "Access is denied"。

  • Previous Page
  • Next Page

XML 实例
XML 测验


XML 编辑器

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML 编辑器

  • Previous Page
  • Next Page

如果希望极认真地学习和使用 XML，那么您一定会从一款专业的 XML 编辑器的使用上受益。

XML 是基于文本的

XML 是基于文本的标记语言。

关于 XML 的一件很重要的事情是，XML 可被类似记事本这样的简单的文本编辑器来创建和编辑。

不过，在您开始使用 XML 进行工作时，您很快会发现，使用一款专业的 XML 编辑器来编辑 XML 文档会更好。

为什么不使用记事本?

许多开发人员使用记事本来编辑 XML 和 HTML 文档，这是因为最常用的操作系统都带有记事本，而且它很容易使用。从个人来讲，我经常使用记事本来快速地编辑某些简单的 HTML、CSS 以及 XML 文件。

但是，如果您将记事本用于 XML 编辑，可能很快会发现不少问题。

记事本不能确定您编辑的文档类型，所以也就无法辅助您的工作。

为什么使用 XML 编辑器?

当今，XML 是非常重要的技术，并且开发项目正在使用这些基于 XML 的技术：

  • 用 XML Schema 定义 XML 的结构和数据类型
  • 用 XSLT 来转换 XML 数据
  • 用 SOAP 来交换应用程序之间的 XML 数据
  • 用 WSDL 来描述网络服务
  • 用 RDF 来描述网络资源
  • 用 XPath 和 XQuery 来访问 XML 数据
  • 用 SMIL 来定义图形

为了能够编写出无错的 XML 文档，您需要一款智能的 XML 编辑器！

XML 编辑器

专业的 XML 编辑器会帮助您编写无错的 XML 文档，根据某种 DTD 或者 schema 来验证 XML，以及强制您创建合法的 XML 结构。

XML 编辑器应该具有如下能力：

  • 为开始标签自动添加结束标签
  • 强制您编写合法的 XML
  • 根据某种 DTD 来验证 XML
  • 根据某种 Schema 来验证 XML
  • 对您的 XML 语法进行代码的颜色化
  • Previous Page
  • Next Page

XML 实例
XML 测验


XML 编码

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML 编码

  • Previous Page
  • Next Page

XML 文档可能包含外国字符，比如挪威语，或者法语。

为了让 XML 解析器读懂这些字符，您需要把 XML 文档存为 Unicode。

Windows 2000 记事本

Windows 2000 记事本可以把文件保存为Unicode。

将XML文件保存为 Unicode（注意，此文档未包含任何编码属性）：

<?xml version="1.0"?>
<note>
  <from>John</from>
  <to>George</to>
  <message>French: êèé</message>
</note>

上面的文件，note_encode_none_u.xml，在 IE 5+、Firefox 或者 Opera 中不会出错，但是在 Netscape 6.2 中会出错。

Windows 2000 Notepad with Encoding

Windows 2000 记事本使用 "UTF-16" 编码将文件保存为 Unicode。

如果您为保存为 Unicode 的 XML 文件添加了一个编码属性，windows 的编码值可能产生错误。

下面的编码（打开它），不会报错：

<?xml version="1.0" encoding="windows-1252"?>

下面的编码（打开它），不会报错：

<?xml version="1.0" encoding="ISO-8859-1"?>

下面的编码（打开它），不会报错：

<?xml version="1.0" encoding="UTF-8"?>

下面的编码（打开它），在 IE 5+、Firefox 或者 Opera 重不会发出错误信息，但是在 Netscape 6.2 中会报错。

<?xml version="1.0" encoding="UTF-16"?>

错误消息

如果您试图向 IE 中载入 XML 文档，可能会得到两种指示编码问题的错误：

在文本内容中发现非法字符

如果 XML 文档中的某个字符与编码属性不匹配，您就会得到这个错误消息。通常，当 XML 文件中含有外国字符，且当文件使用类似记事本的单字节编码编辑器保存，以及没有指定编码属性时，您就会得到这个错误消息。

将当前编码切换为不被支持的指定编码

如果您的文件被保存为 Unicode/UTF-16，但是编码属性被指定为单字节编码（比如 Windows-1252、ISO-8859-1 或者 UTF-8）时，那么您就会得到这个错误消息。或者当您的文档被保存为单字节编码，但编码属性被指定为双字节编码（比如 UTF-16）时，也会得到这个错误消息。

结论

结论是：编码属性应当被指定为文档被保存时所使用的编码。我最好的避免错误的建议是：

  • 使用支持编码的编辑器
  • 确定编辑器使用的编码
  • 在您的 XML 文档中使用相同的编码属性
  • Previous Page
  • Next Page

XML 实例
XML 测验


XML 测验

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML 测验

  • Previous Page
  • Next Page

您可以通过 W3SCHOOL 的测验程序来测试您的 XML 技能。

关于本测验

本测验包含 20 道题，每道题的最长答题时间是 20 分钟（这是由于每个 session 的默认有效时间是 20 钟）。

本测验是非官方的测试，它仅仅提供了一个了解您对 XML 的掌握程度的工具。

测验会被记分

每道题的分值是 1 分。在您完成全部的 20 道题之后，系统会为您的测验打分，并提供您做错的题目的正确答案。其中，绿色为正确答案，而红色为错误答案。

现在就开始测验！祝您好运。

  • Previous Page
  • Next Page

XML 实例
XML 测验


XML 的相关技术

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML 的相关技术

  • Previous Page
  • Next Page

下面是一个与 XML 相关的技术的列表。

XHTML
更严格更纯净的基于 XML 的 HTML 版本。
XML DOM
访问和操作 XML 的标准文档模型。
XSLT

XSL 包含三个部分：

  • XSLT - 把 XML 转换为其他格式，比如 HTML
  • XSL-FO - 用于格式化 XML 文档的语言
  • XPath - 用于在 XML 文档中导航的语言
XQuery
基于 XML 的用于查询 XML 数据的语言。
DTD
用于定义 XML 文档中的合法元素的标准。
XSD
XML Schema。基于 XML 的 DTD 替代物。
XLink
在 XML 文档中创建超级链接的语言。
XPointer
允许 XLink 超级链接指向 XML 文档中更多具体的部分。
XForms
使用 XML 定义表单数据。
SOAP
允许应用程序在 HTTP 之上交换信息的基于 XML 的协议。
WSDL
用于描述网络服务的基于 XML 的语言。
RDF
用于描述网络资源的基于 XML 的语言。
RSS
聚合新闻以及类新闻站点内容的格式。
WAP
用于在无线设备上（比如移动电话）显示内容的一种基于 XML 的语言。
SMIL
描述视听呈现的语言。
SVG
使用 XML 格式定义图形。
  • Previous Page
  • Next Page

XML 实例
XML 测验


XML 的用途

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML 的用途

  • Previous Page
  • Next Page

XML 应用于 web 开发的许多方面，常用于简化数据的存储和共享。

XML 把数据从 HTML 分离

如果你需要在 HTML 文档中显示动态数据，那么每当数据改变时将花费大量的时间来编辑 HTML。

通过 XML，数据能够存储在独立的 XML 文件中。这样你就可以专注于使用 HTML 进行布局和显示，并确保修改底层数据不再需要对 HTML 进行任何的改变。

通过使用几行 JavaScript，你就可以读取一个外部 XML 文件，然后更新 HTML 中的数据内容。

您将在稍后的章节学习更多这方面的内容。

XML 简化数据共享

在真实的世界中，计算机系统和数据使用不兼容的格式来存储数据。

XML 数据以纯文本格式进行存储，因此提供了一种独立于软件和硬件的数据存储方法。

这让创建不同应用程序可以共享的数据变得更加容易。

XML 简化数据传输

通过 XML，可以在不兼容的系统之间轻松地交换数据。

对开发人员来说，其中一项最费时的挑战一直是在因特网上的不兼容系统之间交换数据。

由于可以通过各种不兼容的应用程序来读取数据，以 XML 交换数据降低了这种复杂性。

XML 简化平台的变更

升级到新的系统（硬件或软件平台），总是非常费时的。必须转换大量的数据，不兼容的数据经常会丢失。

XML 数据以文本格式存储。这使得 XML 在不损失数据的情况下，更容易扩展或升级到新的操作系统、新应用程序或新的浏览器。

XML 使您的数据更有用

由于 XML 独立于硬件、软件以及应用程序，XML 使您的数据更可用，也更有用。

不同的应用程序都能够访问您的数据，不仅仅在 HTML 页中，也可以从 XML 数据源中进行访问。

通过 XML，您的数据可供各种阅读设备使用（手持的计算机、语音设备、新闻阅读器等），还可以供盲人或其他残障人士使用。

XML 用于创建新的 Internet 语言

很多新的 Internet 语言是通过 XML 创建的：

其中的例子包括：

  • XHTML - 最新的 HTML 版本
  • WSDL - 用于描述可用的 web service
  • WAP 和 WML - 用于手持设备的标记语言
  • RSS - 用于 RSS feed 的语言
  • RDF 和 OWL - 用于描述资源和本体
  • SMIL - 用于描述针针对 web 的多媒体

假如开发人员都是理性的

假如他们都是理性的，就让未来的应用程序使用 XML 来交换数据吧。

未来也许会出现某种字处理软件、电子表格程序以及数据库，它们可以使用纯文本格式读取彼此的数据，而不需要使用任何的转换程序。

我们现在能做的只有祈祷微软公司和所有其他的软件开发商在这一方面取得一致了。

  • Previous Page
  • Next Page

XML 实例
XML 测验


XML 简介

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML 简介

  • Previous Page
  • Next Page

XML 被设计用来传输和存储数据。

HTML 被设计用来显示数据。

应该掌握的基础知识：

在您继续学习之前，需要对以下知识有基本的了解：

  • HTML / XHTML
  • JavaScript

如果您希望首先学习这些项目，请在我们的 首页 访问这些教程。

什么是 XML?

  • XML 指可扩展标记语言（EXtensible Markup Language）
  • XML 是一种标记语言，很类似 HTML
  • XML 的设计宗旨是传输数据，而非显示数据
  • XML 标签没有被预定义。您需要自行定义标签。
  • XML 被设计为具有自我描述性。
  • XML 是 W3C 的推荐标准

XML 与 HTML 的主要差异

XML 不是 HTML 的替代。

XML 和 HTML 为不同的目的而设计：

XML 被设计为传输和存储数据，其焦点是数据的内容。

HTML 被设计用来显示数据，其焦点是数据的外观。

HTML 旨在显示信息，而 XML 旨在传输信息。

没有任何行为的 XML

XML 是不作为的。

也许这有点难以理解，但是 XML 不会做任何事情。XML 被设计用来结构化、存储以及传输信息。

下面是 John 写给 George 的便签，存储为 XML：

<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

这个标签有标题以及留言。它也包含了发送者和接受者的信息。但是，这个 XML 文档仍然没有做任何事情。它仅仅是包装在 XML 标签中的纯粹的信息。我们需要编写软件或者程序，才能传送、接收和显示出这个文档。

XML 仅仅是纯文本

XML 没什么特别的。它仅仅是纯文本而已。有能力处理纯文本的软件都可以处理 XML。

不过，能够读懂 XML 的应用程序可以有针对性地处理 XML 的标签。标签的功能性意义依赖于应用程序的特性。

通过 XML 您可以发明自己的标签

上例中的标签没有在任何 XML 标准中定义过（比如 <to> 和 <from>）。这些标签是由文档的创作者发明的。

这是因为 XML 没有预定义的标签。

在 HTML 中使用的标签（以及 HTML 的结构）是预定义的。HTML 文档只使用在 HTML 标准中定义过的标签（比如 <p> 、<h1> 等等）。

XML 允许创作者定义自己的标签和自己的文档结构。

XML 不是对 HTML 的替代

XML 是对 HTML 的补充。

XML 不是对 HTML 的替代，理解这一点很重要。在大多数 web 应用程序中，XML 用于传输数据，而 HTML 用于格式化并显示数据。

对 XML 的最好的描述是：

XML 是独立于软件和硬件的信息传输工具。

XML 是 W3C 的推荐标准

可扩展标记语言 (XML) 于 1998 年 2 月 10 日成为 W3C 的推荐标准。

XML 无所不在

当我们看到 XML 标准突飞猛进的开发进度，以及大批的软件开发商采用这个标准的日新月异的速度时，真的是不禁感叹这真是令人叹为观止。

目前，XML 在 Web 中起到的作用不会亚于一直作为 Web 基石的 HTML。

XML 无所不在。XML 是各种应用程序之间进行数据传输的最常用的工具，并且在信息存储和描述领域变得越来越流行。

  • Previous Page
  • Next Page

XML 实例
XML 测验


XML 教程

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML 教程

  • Next Page

XML 指可扩展标记语言

XML 被设计用来传输和存储数据。

在我们的 XML 教程中，你将了解什么是 XML，以及 XML 与 HTML 之间的差异。

XML 很重要，也很容易学习。

开始学习 XML ！

XML 实例

通过实例进行学习！使用我们的编辑器，你可以编辑 XML 代码，然后点击测试按钮查看结果。

亲自试一试吧！

XML 测试

在 W3School 测试你的 XML 技能！

开始测验！

内容目录

XML 基础

XML 简介
什么是 XML，以及它与 HTML 的区别。
如何使用 XML
不同的 XML 使用方式。
XML 树结构
XML 文档如何形成一种有逻辑的树结构。
XML 语法
有逻辑且非常简单的 XML 语法规则。
XML 元素
XML 元素、内容和命名规则、父与子元素之间的关系。
XML 属性
如何使用 XML 属性提供关于元素的额外信息。
XML 验证
形式良好的文档与合法文档之间的差异，以及如何规定 XML 文档的结构。
XML 验证器
简单的 XML 在线语法检查工具。
XML 浏览器支持
大部分常用的浏览器对 XML 的支持
在浏览器中查看 XML
如何通过您的浏览器来查看 XML 文件。
使用 CSS 来显示 XML
如何使用 CSS 来显示一个 XML 文件。
使用 XSL 来显示 XML
如何使用 XSL 来显示一个 XML 文件。

XML JavaScript

XML 解析器
如何使用浏览器来读取、更新、创建并操作 XML 文档。
XML DOM
关于 XML 文档对象模型（DOM）。
XML to HTML
如何在 HTML 文档中显示 XML 数据。
XMLHttpRequest 对象
如何在不重新加载页面的情况下，使用来自服务器的数据对页面进行更新。
XML 应用程序
如何使用 XML 数据和 JavaScript 来创建复杂的 HTML 应用程序。

XML 高级

XML 命名空间
如何使用 XML 命名空间避免元素命名冲突。
XML CDATA
如何告知 XML 解析器不去解析文本。
XML 编码
如何在您的 XML 文档使用不同的字符集。
XML 服务器
如何从服务器端输出 XML。
XML DOM 高级
更多关于 XML 文档对象模型的知识。
XML Don't
本节讲解在在使用 XML 时尽量避免使用的技术。
把数据存储到 XML 文件
通常地，我们在数据库中存储数据。不过，假如我们希望数据更加易用，那么可以将数据存储于 XML 文件之中。
XML 技术
与 XML 相关的最常用的技术。
现实生活中的 XML
在现实世界中 XML 如何被使用的例子。
XML 编辑器
当编辑 XML 文档时，为什么要使用 XML 编辑器。
XML 总结
本文包括在本教程所学内容的一个总结，以及我们向你推荐的下一步应该学习的内容。

XML 实例/测验

XML 实例
非常多的 XML 实例！
XML 测验
在 W3School 测试你的 XML 技能！
  • Next Page

XML 实例
XML 测验


XML 命名空间（XML Namespaces）

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML 命名空间（XML Namespaces）

  • Previous Page
  • Next Page

XML 命名空间可提供避免元素命名冲突的方法。

命名冲突

由于 XML 中的元素名是预定义的，当两个不同的文档使用相同的元素名时，就会发生命名冲突。

这个 XML 文档携带着某个表格中的信息：

<table>
   <tr>
   <td>Apples</td>
   <td>Bananas</td>
   </tr>
</table>

这个 XML 文档携带有关桌子的信息（一件家具）：

<table>
   <name>African Coffee Table</name>
   <width>80</width>
   <length>120</length>
</table>

假如这两个 XML 文档被一起使用，由于两个文档都包含带有不同内容和定义的 <table> 元素，就会发生命名冲突。

使用前缀来避免命名冲突

此文档带有某个表格中的信息：

<h:table>
   <h:tr>
   <h:td>Apples</h:td>
   <h:td>Bananas</h:td>
   </h:tr>
</h:table>

此 XML 文档携带着有关一件家具的信息：

<f:table>
   <f:name>African Coffee Table</f:name>
   <f:width>80</f:width>
   <f:length>120</f:length>
</f:table>

现在，命名冲突不存在了，这是由于两个文档都使用了不同的名称来命名它们的 <table> 元素 (<h:table> 和 <f:table>)。

通过使用前缀，我们创建了两种不同类型的 <table> 元素。

使用命名空间（Namespaces）

这个 XML 文档携带着某个表格中的信息：

<h:table xmlns:h="http://www.w3.org/TR/html4/">
   <h:tr>
   <h:td>Apples</h:td>
   <h:td>Bananas</h:td>
   </h:tr>
</h:table>

此 XML 文档携带着有关一件家具的信息：

<f:table xmlns:f="http://www.w3school.com.cn/furniture">
   <f:name>African Coffee Table</f:name>
   <f:width>80</f:width>
   <f:length>120</f:length>
</f:table>

与仅仅使用前缀不同，我们为 <table> 标签添加了一个 xmlns 属性，这样就为前缀赋予了一个与某个命名空间相关联的限定名称。

XML Namespace (xmlns) 属性

XML 命名空间属性被放置于某个元素的开始标签之中，并使用以下的语法：

xmlns:namespace-prefix="namespaceURI"

当一个命名空间被定义在某个元素的开始标签中时，所有带有相同前缀的子元素都会与同一个命名空间相关联。

注释：用于标示命名空间的地址不会被解析器用于查找信息。其惟一的作用是赋予命名空间一个惟一的名称。不过，很多公司常常会作为指针来使用命名空间指向某个实存的网页，这个网页包含着有关命名空间的信息。

请访问 http://www.w3.org/TR/html4/。

统一资源标示符（Uniform Resource Identifier (URI)）

统一资源标示符是一串可以标示因特网资源的字符。最常用的 URI 是用来标示因特网域名地址的统一资源定位器(URL)。另一个不那么常用的 URI 是统一资源命名(URN)。在我们的例子中，我们仅使用 URL。

默认的命名空间（Default Namespaces）

为某个元素定义默认的命名空间可以让我们省去在所有的子元素中使用前缀的工作。

请使用下面的语法：

xmlns="namespaceURI"

这个 XML 文档携带着某个表格中的信息：

<table xmlns="http://www.w3.org/TR/html4/">
   <tr>
   <td>Apples</td>
   <td>Bananas</td>
   </tr>
</table>

此 XML 文档携带着有关一件家具的信息：

<table xmlns="http://www.w3school.com.cn/furniture">
   <name>African Coffee Table</name>
   <width>80</width>
   <length>120</length>
</table>

命名空间的实际应用

当开始使用 XSL 时，您不久就会看到实际使用中的命名空间。XSL 样式表用于将XML文档转换为其他格式，比如 HTML。

如果您仔细观察下面的这个 XSL 文档，就会看到大多数的标签是HTML标签。非 HTML 的标签都有前缀 xsl，并由此命名空间标示："http://www.w3.org/1999/XSL/Transform"：

<?xml version="1.0" encoding="ISO-8859-1"?>

<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
<html>
<body>
  <h2>My CD Collection</h2>
  <table border="1">
    <tr>
      <th align="left">Title</th>
      <th align="left">Artist</th>
    </tr>
    <xsl:for-each select="catalog/cd">
    <tr>
      <td><xsl:value-of select="title"/></td>
      <td><xsl:value-of select="artist"/></td>
    </tr>
    </xsl:for-each>
  </table>
</body>
</html>
</xsl:template>

</xsl:stylesheet>
  • Previous Page
  • Next Page

XML 实例
XML 测验


XML 属性

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML 属性

  • Previous Page
  • Next Page

XML 元素可以在开始标签中包含属性，类似 HTML。

属性 (Attribute) 提供关于元素的额外信息。

XML 属性

从 HTML，你会回忆起这个：<img src="computer.gif">。"src" 属性提供有关 <img> 元素的额外信息。

在 HTML 中（以及在 XML 中），属性提供有关元素的额外信息：

<img src="computer.gif">
<a href="demo.asp">

属性通常提供不属于数据组成部分的信息。在下面的例子中，文件类型与数据无关，但是对需要处理这个元素的软件来说却很重要：

<file type="gif">computer.gif</file>

XML 属性必须加引号

属性值必须被引号包围，不过单引号和双引号均可使用。比如一个人的性别，person 标签可以这样写：

<person sex="female">

或者这样也可以：

<person sex='female'>

注释：如果属性值本身包含双引号，那么有必要使用单引号包围它，就像这个例子：

<gangster name='George "Shotgun" Ziegler'>

或者可以使用实体引用：

<gangster name="George &quot;Shotgun&quot; Ziegler">

XML 元素 vs. 属性

请看这些例子：

<person sex="female">
  <firstname>Anna</firstname>
  <lastname>Smith</lastname>
</person>

<person>
  <sex>female</sex>
  <firstname>Anna</firstname>
  <lastname>Smith</lastname>
</person>

在第一个例子中，sex 是一个属性。在第二个例子中，sex 则是一个子元素。两个例子均可提供相同的信息。

没有什么规矩可以告诉我们什么时候该使用属性，而什么时候该使用子元素。我的经验是在 HTML 中，属性用起来很便利，但是在 XML 中，您应该尽量避免使用属性。如果信息感觉起来很像数据，那么请使用子元素吧。

我最喜欢的方式

下面的三个 XML 文档包含完全相同的信息：

第一个例子中使用了 date 属性：

<note date="08/08/2008">
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

第二个例子中使用了 date 元素：

<note>
<date>08/08/2008</date>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

第三个例子中使用了扩展的 date 元素（这是我的最爱）：

<note>
<date>
  <day>08</day>
  <month>08</month>
  <year>2008</year>
</date>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

避免 XML 属性？

因使用属性而引起的一些问题：

  • 属性无法包含多个值（子元素可以）
  • 属性无法描述树结构（子元素可以）
  • 属性不易扩展（为未来的变化）
  • 属性难以阅读和维护

请尽量使用元素来描述数据。而仅仅使用属性来提供与数据无关的信息。

不要做这样的蠢事（这不是 XML 应该被使用的方式）：

<note day="08" month="08" year="2008"
to="George" from="John" heading="Reminder"
body="Don't forget the meeting!">
</note>

针对元数据的 XML 属性

有时候会向元素分配 ID 引用。这些 ID 索引可用于标识 XML 元素，它起作用的方式与 HTML 中 ID 属性是一样的。这个例子向我们演示了这种情况：

<messages>
  <note id="501">
    <to>George</to>
    <from>John</from>
    <heading>Reminder</heading>
    <body>Don't forget the meeting!</body>
  </note>
  <note id="502">
    <to>John</to>
    <from>George</from>
    <heading>Re: Reminder</heading>
    <body>I will not</body>
  </note>
</messages>

上面的 ID 仅仅是一个标识符，用于标识不同的便签。它并不是便签数据的组成部分。

在此我们极力向您传递的理念是：元数据（有关数据的数据）应当存储为属性，而数据本身应当存储为元素。

  • Previous Page
  • Next Page

XML 实例
XML 测验


XML 树结构

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML 树结构

  • Previous Page
  • Next Page

XML 文档形成了一种树结构，它从“根部”开始，然后扩展到“枝叶”。

一个 XML 文档实例

XML 使用了简单的具有自我描述性的语法：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

第一行是 XML 声明。它定义 XML 的版本 (1.0) 和所使用的编码 (ISO-8859-1 = Latin-1/西欧字符集)。

下一行描述文档的根元素（像在说：“本文档是一个便签”）：

<note>

接下来 4 行描述根的 4 个子元素（to, from, heading 以及 body）：

<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>

最后一行定义根元素的结尾：

</note>

从本例可以设想，该 XML 文档包含了 John 给 George 的一张便签。

XML 具有出色的自我描述性，你同意吗？

XML 文档形成一种树结构

XML 文档必须包含根元素。该元素是所有其他元素的父元素。

XML 文档中的元素形成了一棵文档树。这棵树从根部开始，并扩展到树的最底端。

所有元素均可拥有子元素：

<root>
  <child>
    <subchild>.....</subchild>
  </child>
</root>

父、子以及同胞等术语用于描述元素之间的关系。父元素拥有子元素。相同层级上的子元素成为同胞（兄弟或姐妹）。

所有元素均可拥有文本内容和属性（类似 HTML 中）。

实例

上图表示下面的 XML 中的一本书：

<bookstore>
<book category="COOKING">
  <title lang="en">Everyday Italian</title>
  <author>Giada De Laurentiis</author>
  <year>2005</year>
  <price>30.00</price>
</book>
<book category="CHILDREN">
  <title lang="en">Harry Potter</title>
  <author>J K. Rowling</author>
  <year>2005</year>
  <price>29.99</price>
</book>
<book category="WEB">
  <title lang="en">Learning XML</title>
  <author>Erik T. Ray</author>
  <year>2003</year>
  <price>39.95</price>
</book>
</bookstore>

例子中的根元素是 <bookstore>。文档中的所有 <book> 元素都被包含在 <bookstore> 中。

<book> 元素有 4 个子元素：<title>、< author>、<year>、<price>。

  • Previous Page
  • Next Page

XML 实例
XML 测验


XML 验证

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML 验证

  • Previous Page
  • Next Page

拥有正确语法的 XML 被称为“形式良好”的 XML。

通过某个 DTD 进行了验证的 XML 是“合法”的 XML。

形式良好的 XML 文档

一个"形式良好"的 XML 文档拥有正确的语法。

一个"形式良好"的 XML 文档会遵守前几章介绍过的 XML 语法规则：

  • XML 文档必须有根元素
  • XML 文档必须有关闭标签
  • XML 标签对大小写敏感
  • XML 元素必须被正确的嵌套
  • XML 属性必须加引号
<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

验证 XML 文档

一个合法的 XML 文档是"形式良好"的 XML 文档，同样遵守文档类型定义 (DTD) 的语法规则：

<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE note SYSTEM "Note.dtd">
<note>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

在上例中，DOCTYPE 声明是对外部 DTD 文件的引用。下面的段落展示了这个文件的内容。

XML DTD

DTD 的作用是定义 XML 文档的结构。它使用一系列合法的元素来定义文档结构：

<!DOCTYPE note [
  <!ELEMENT note (to,from,heading,body)>
  <!ELEMENT to      (#PCDATA)>
  <!ELEMENT from    (#PCDATA)>
  <!ELEMENT heading (#PCDATA)>
  <!ELEMENT body    (#PCDATA)>
]>

如果您希望学习 DTD，请访问我们的 DTD 教程。

XML Schema

W3C 支持一种基于 XML 的 DTD 代替者，它名为 XML Schema：

<xs:element name="note">

<xs:complexType>
  <xs:sequence>
    <xs:element name="to"      type="xs:string"/>
    <xs:element name="from"    type="xs:string"/>
    <xs:element name="heading" type="xs:string"/>
    <xs:element name="body"    type="xs:string"/>
  </xs:sequence>
</xs:complexType>

</xs:element>

如果您需要学习 XML Schema，请访问我们的 XML Schema 教程。

一个通用的验证器

为了帮助您检查 XML 文件的语法，我们创建了这个工具，以便您对任何 XML 文件进行语法检查。

请看下一节。

  • Previous Page
  • Next Page

XML 实例
XML 测验


XML 验证器

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML 验证器

  • Previous Page
  • Next Page

XML 错误会终止您的程序

XML 文档中的错误会终止你的 XML 程序。

W3C 的 XML 规范声明：如果 XML 文档存在错误，那么程序就不应当继续处理这个文档。理由是，XML 软件应当轻巧，快速，具有良好的兼容性。

如果使用 HTML，创建包含大量错误的文档是有可能的（比如你忘记了结束标签）。其中一个主要的原因是 HTML 浏览器相当臃肿，兼容性也很差，并且它们有自己的方式来确定当发现错误时文档应该显示为什么样子。

使用 XML 时，这种情况不应当存在。

对您的 XML 进行语法检查 - 仅用于 IE 浏览器

为了帮助您对 XML 进行语法检查，我们创建了一个 XML 验证器。

把您的 XML 粘贴到下面的文本框中，然后点击"验证"按钮来进行语法检查。

根据 DTD 来验证 XML

只要把 DOCTYPE 声明添加到您的 XML 中，然后点击验证按钮即可：

注释：只有在 Internet Explorer 中，可以根据 DTD 来验证 XML。Firefox, Mozilla, Netscape 以及 Opera 做不到这一点。

  • Previous Page
  • Next Page

XML 实例
XML 测验


XML 应用程序

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML 应用程序

  • Previous Page
  • Next Page

本节演示由 HTML 和 JavaScript 构建的一个小型 XML 应用程序。

XML 文档实例

请看下面这个 XML 文档 ( "cd_catalog.xml" )，它描述了一个 CD 目录：

<?xml version="1.0" encoding="ISO-8859-1"?>
<CATALOG>
  <CD>
    <TITLE>Empire Burlesque</TITLE>
    <ARTIST>Bob Dylan</ARTIST>
    <COUNTRY>USA</COUNTRY>
    <COMPANY>Columbia</COMPANY>
    <PRICE>10.90</PRICE>
    <YEAR>1985</YEAR>
  </CD>
.
.
... more ...
.

在您的浏览器中查看完整的 "cd_catalog.xml" 文件。

加载 XML 文档

为了加载 XML 文档 (cd_catalog.xml)，我们使用了与 XML 解析器那一节中相同的代码：

var xmlDoc;
if (window.ActiveXObject)
  {
  // code for IE
  xmlDoc=new ActiveXObject("Microsoft.XMLDOM");
  }
else if (document.implementation.createDocument)
  {
  // code for Firefox, Mozilla, Opera, etc.
  xmlDoc=document.implementation.createDocument("","",null);
  }
else
  {
  alert('Your browser cannot handle this script');
  }
xmlDoc.async=false;
xmlDoc.load("cd_catalog.xml");

在本代码执行后，xmlDoc 成为一个 XML DOM 对象，可由 JavaScript 访问。

把 XML 数据显示为 HTML 表格

以下代码使用来自 XML DOM 对象的数据来填充一个 HTML 表格：

document.write("<table border='1'>");

var x=xmlDoc.getElementsByTagName("CD");
for (var i=0;i<x.length;i++)
{
document.write("<tr>");
document.write("<td>");
document.write(
x[i].getElementsByTagName("ARTIST")[0].childNodes[0].nodeValue);
document.write("</td>");

document.write("<td>");
document.write(
x[i].getElementsByTagName("TITLE")[0].childNodes[0].nodeValue);
document.write("</td>");
document.write("</tr>");
}
document.write("</table>");

针对 XML 文档中的每个 CD 元素，会创建一个表格行。每个表格行包含两个表格数据单元，其中的数据来自当前 CD 元素的 ARTIST 和 TITLE。

TIY：查看如何在一个 HTML 表格中显示 XML 数据。

在任意 HTML 元素中显示 XML 数据

XML 数据可以拷贝到任何有能力显示文本的 HTML 元素。

下面的代码为 HTML 文件的 <head> 部分。这段代码从第一个 <CD> 元素中获得 XML 数据，然后在 id="show" 的 HTML 元素中显示数据：

var x=xmlDoc.getElementsByTagName("CD");
i=0;

function display()
{
artist=
(x[i].getElementsByTagName("ARTIST")[0].childNodes[0].nodeValue);
title=
(x[i].getElementsByTagName("TITLE")[0].childNodes[0].nodeValue);
year=
(x[i].getElementsByTagName("YEAR")[0].childNodes[0].nodeValue);

txt="Artist: "+artist+"<br />Title: "+title+"<br />Year: "+year;

document.getElementById("show").innerHTML=txt;
}

HTML 的 body 元素包含一个 onload 事件属性，它的作用是在页面已经加载时调用 display() 函数。body 元素中还包含了供接受 XML 数据的 <div id='show'> 元素。

<div id='show'></div>

</body>

TIY：查看 XML 数据如何在 <div> 元素中显示。

通过上例，你只能看到来自 XML 文档中第一个 CD 元素中的数据。为了导航到数据的下一行，必须添加更多的代码。

添加导航脚本

为了向上例添加导航（功能），需要创建 next() 和 previous() 两个函数：

function next()
{
if (i<x.length)
  {
  i++;
  display();
  }
}

function previous()
{
if (i>0)
  {
  i--;
  display();
  }
}

next() 函数确保已到达最后一个 CD 元素后不显示任何东西，previous () 函数确保已到达第一个 CD 元素后不显示任何东西。

通过点击 next/previous 按钮来调用 next() 和 previous() 函数：

<input type="button" onclick="previous()" value="previous" />
<input type="button" onclick="next()" value="next" />

TIY：查看如何在 XML 记录中导航。

现在，把所有的东西组合起来！

只需要一点点创新，您就可以创建一个完整的应用程序。

如果您使用本页中学到的知识，再加上一点点想象力，就可以轻松地开发出一个完整的应用程序。

如果您正在使用 IE 5.0 或者更高的版本：看看您可以怎样为这个应用程序添加一点点想象力。

  • Previous Page
  • Next Page

XML 实例
XML 测验


XML 语法规则

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML 语法规则

  • Previous Page
  • Next Page

XML 的语法规则很简单，且很有逻辑。这些规则很容易学习，也很容易使用。

所有 XML 元素都须有关闭标签

在 HTML，经常会看到没有关闭标签的元素：

<p>This is a paragraph
<p>This is another paragraph

在 XML 中，省略关闭标签是非法的。所有元素都必须有关闭标签：

<p>This is a paragraph</p>
<p>This is another paragraph</p>

注释：您也许已经注意到 XML 声明没有关闭标签。这不是错误。声明不属于XML本身的组成部分。它不是 XML 元素，也不需要关闭标签。

XML 标签对大小写敏感

XML 元素使用 XML 标签进行定义。

XML 标签对大小写敏感。在 XML 中，标签 <Letter> 与标签 <letter> 是不同的。

必须使用相同的大小写来编写打开标签和关闭标签：

<Message>这是错误的。</message>

<message>这是正确的。</message>

注释：打开标签和关闭标签通常被称为开始标签和结束标签。不论您喜欢哪种术语，它们的概念都是相同的。

XML 必须正确地嵌套

在 HTML 中，常会看到没有正确嵌套的元素：

<b><i>This text is bold and italic</b></i>

在 XML 中，所有元素都必须彼此正确地嵌套：

<b><i>This text is bold and italic</i></b>

在上例中，正确嵌套的意思是：由于 <i> 元素是在 <b> 元素内打开的，那么它必须在 <b> 元素内关闭。

XML 文档必须有根元素

XML 文档必须有一个元素是所有其他元素的父元素。该元素称为根元素。

<root>
  <child>
    <subchild>.....</subchild>
  </child>
</root>

XML 的属性值须加引号

与 HTML 类似，XML 也可拥有属性（名称/值的对）。

在 XML 中，XML 的属性值须加引号。请研究下面的两个 XML 文档。第一个是错误的，第二个是正确的：

<note date=08/08/2008>
<to>George</to>
<from>John</from>
</note>

<note date="08/08/2008">
<to>George</to>
<from>John</from>
</note>

在第一个文档中的错误是，note 元素中的 date 属性没有加引号。

实体引用

在 XML 中，一些字符拥有特殊的意义。

如果你把字符 "<" 放在 XML 元素中，会发生错误，这是因为解析器会把它当作新元素的开始。

这样会产生 XML 错误：

<message>if salary < 1000 then</message>

为了避免这个错误，请用一个实体引用来代替 "<" 字符：

<message>if salary &lt; 1000 then</message>

在 XML 中，有 5 个预定义的实体引用：

&lt; | < | 小于
&gt; | > | 大于
&amp; | & | 和号
&apos; | ' | 单引号
&quot; | " | 引号

注释：在 XML 中，只有字符 "<" 和 "&" 确实是非法的。大于号是合法的，但是用实体引用来代替它是一个好习惯。

XML 中的注释

在 XML 中编写注释的语法与 HTML 的语法很相似：

<!-- This is a comment -->

在 XML 中，空格会被保留

HTML 会把多个连续的空格字符裁减为一个：

HTML:	Hello           my name is David.
输出:	Hello my name is David.

在 XML 中，文档中的空格不会被删节。

XML 以 LF 存储换行

在 Windows 应用程序中，换行通常以一对字符来存储：回车符 (CR) 和换行符 (LF)。这对字符与打字机设置新行的动作有相似之处。在 Unix 应用程序中，新行以 LF 字符存储。而 Macintosh 应用程序使用 CR 来存储新行。

  • Previous Page
  • Next Page

XML 实例
XML 测验


XML 元素

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML 元素

  • Previous Page
  • Next Page

XML 文档包含 XML 元素。

什么是 XML 元素？

XML 元素指的是从（且包括）开始标签直到（且包括）结束标签的部分。

元素可包含其他元素、文本或者两者的混合物。元素也可以拥有属性。

<bookstore>
<book category="CHILDREN">
  <title>Harry Potter</title>
  <author>J K. Rowling</author>
  <year>2005</year>
  <price>29.99</price>
</book>
<book category="WEB">
  <title>Learning XML</title>
  <author>Erik T. Ray</author>
  <year>2003</year>
  <price>39.95</price>
</book>
</bookstore>

在上例中，<bookstore> 和 <book> 都拥有元素内容，因为它们包含了其他元素。<author> 只有文本内容，因为它仅包含文本。

在上例中，只有 <book> 元素拥有属性 (category="CHILDREN")。

XML 命名规则

XML 元素必须遵循以下命名规则：

  • 名称可以含字母、数字以及其他的字符
  • 名称不能以数字或者标点符号开始
  • 名称不能以字符 “xml”（或者 XML、Xml）开始
  • 名称不能包含空格

可使用任何名称，没有保留的字词。

最佳命名习惯

使名称具有描述性。使用下划线的名称也很不错。

名称应当比较简短，比如：<book_title>，而不是：<the_title_of_the_book>。

避免 "-" 字符。如果您按照这样的方式进行命名："first-name"，一些软件会认为你需要提取第一个单词。

避免 "." 字符。如果您按照这样的方式进行命名："first.name"，一些软件会认为 "name" 是对象 "first" 的属性。

避免 ":" 字符。冒号会被转换为命名空间来使用（稍后介绍）。

XML 文档经常有一个对应的数据库，其中的字段会对应 XML 文档中的元素。有一个实用的经验，即使用数据库的名称规则来命名 XML 文档中的元素。

非英语的字母比如 éòá 也是合法的 XML 元素名，不过需要留意当软件开发商不支持这些字符时可能出现的问题。

XML 元素是可扩展的

XML 元素是可扩展，以携带更多的信息。

请看下面这个 XML 例子：

<note>
<to>George</to>
<from>John</from>
<body>Don't forget the meeting!</body>
</note>

让我们设想一下，我们创建了一个应用程序，可将 <to>、<from> 以及 <body> 元素提取出来，并产生以下的输出：

MESSAGE
To: George
From: John

Don't forget the meeting!

想象一下，之后这个 XML 文档作者又向这个文档添加了一些额外的信息：

<note>
<date>2008-08-08</date>
<to>George</to>
<from>John</from>
<heading>Reminder</heading>
<body>Don't forget the meeting!</body>
</note>

那么这个应用程序会中断或崩溃吗？

不会。这个应用程序仍然可以找到 XML 文档中的 <to>、<from> 以及 <body> 元素，并产生同样的输出。

XML 的优势之一，就是可以经常在不中断应用程序的情况进行扩展。

  • Previous Page
  • Next Page

XML 实例
XML 测验


XML 浏览器支持

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML 浏览器支持

  • Previous Page
  • Next Page

几乎所有的主流浏览器均支持 XML 和 XSLT。

Mozilla Firefox

从 1.0.2 版本开始，Firefox 就已开始支持 XML 和 XSLT（包括 CSS）。

Mozilla

Mozilla 含有用于 XML 解析的 Expat，并支持显示 XML + CSS。Mozilla 同时拥有对 Namespaces 的某些支持。

Mozilla 同样可做到对 XSLT 的执行（XSLT implementation）。

Netscape

自从版本 8 开始，Netscape 开始使用 Mozilla 的引擎，因此它对 XML / XSLT 的支持与 Mozilla 是相同的。

Opera

自从版本 9 开始，Opera 已经拥有对 XML / XSLT（以及 CSS）的支持。版本 8 仅支持 XML + CSS。

Internet Explorer

自从版本 6 开始，Internet Explorer 就开始支持 XML、Namespaces、CSS、XSLT 以及 XPath。

注释：Internet Explorer 5 同样拥有对 XML 的支持，但是 XSL 部分与 W3C 的官方标准不兼容！

  • Previous Page
  • Next Page

XML 实例
XML 测验


XMLHttpRequest 对象

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XMLHttpRequest 对象

  • Previous Page
  • Next Page

XMLHttpRequest 对象提供了在网页加载后与服务器进行通信的方法。

什么是 XMLHttpRequest 对象？

XMLHttpRequest 对象是开发者的梦想，因为您能够：

  • 在不重新加载页面的情况下更新网页
  • 在页面已加载后从服务器请求数据
  • 在页面已加载后从服务器接收数据
  • 在后台向服务器发送数据

所有现代的浏览器都支持 XMLHttpRequest 对象。

实例：当键入文本时与服务器进行 XML HTTP 通信。

创建 XMLHttpRequest 对象

通过一行简单的 JavaScript 代码，我们就可以创建 XMLHttpRequest 对象。

在所有现代浏览器中（包括 IE 7）：

xmlhttp=new XMLHttpRequest()

在 Internet Explorer 5 和 6 中：

xmlhttp=new ActiveXObject("Microsoft.XMLHTTP")

实例

<script type="text/javascript">
var xmlhttp;
function loadXMLDoc(url)
{
xmlhttp=null;
if (window.XMLHttpRequest)
  {// code for all new browsers
  xmlhttp=new XMLHttpRequest();
  }
else if (window.ActiveXObject)
  {// code for IE5 and IE6
  xmlhttp=new ActiveXObject("Microsoft.XMLHTTP");
  }
if (xmlhttp!=null)
  {
  xmlhttp.onreadystatechange=state_Change;
  xmlhttp.open("GET",url,true);
  xmlhttp.send(null);
  }
else
  {
  alert("Your browser does not support XMLHTTP.");
  }
}

function state_Change()
{
if (xmlhttp.readyState==4)
  {// 4 = "loaded"
  if (xmlhttp.status==200)
    {// 200 = OK
    // ...our code here...
    }
  else
    {
    alert("Problem retrieving XML data");
    }
  }
}
</script>

TIY

注释：onreadystatechange 是一个事件句柄。它的值 (state_Change) 是一个函数的名称，当 XMLHttpRequest 对象的状态发生改变时，会触发此函数。状态从 0 (uninitialized) 到 4 (complete) 进行变化。仅在状态为 4 时，我们才执行代码。

为什么使用 Async=true ？

我们的实例在 open() 的第三个参数中使用了 "true"。

该参数规定请求是否异步处理。

True 表示脚本会在 send() 方法之后继续执行，而不等待来自服务器的响应。

onreadystatechange 事件使代码复杂化了。但是这是在没有得到服务器响应的情况下，防止代码停止的最安全的方法。

通过把该参数设置为 "false"，可以省去额外的 onreadystatechange 代码。如果在请求失败时是否执行其余的代码无关紧要，那么可以使用这个参数。

TIY

更多实例

通过 XML HTTP 把一个 textfile 载入一个 div 元素中

通过 XML HTTP 进行 HEAD 请求

通过 XML HTTP 进行指定的 HEAD 请求

通过 XML HTTP 列出 XML 文件中的数据

XML / ASP

您也可以把 XML 文档打开并发送到服务器上的 ASP 页面，分析此请求，然后传回结果。

<html>
<body>
<script type="text/javascript">
xmlHttp=null;
if (window.XMLHttpRequest)
  {// code for IE7, Firefox, Opera, etc.
  xmlHttp=new XMLHttpRequest();
  }
else if (window.ActiveXObject)
  {// code for IE6, IE5
  xmlHttp=new ActiveXObject("Microsoft.XMLHTTP");
  }
if (xmlHttp!=null)
  {
  xmlHttp.open("GET", "note.xml", false);
  xmlHttp.send(null);
  xmlDoc=xmlHttp.responseText;

  xmlHttp.open("POST", "demo_dom_http.asp", false);
  xmlHttp.send(xmlDoc);
  document.write(xmlHttp.responseText);
  }
else
  {
  alert("Your browser does not support XMLHTTP.");
  }
</script>
</body>
</html>

ASP 页面，由 VBScript 编写：

<%
set xmldoc = Server.CreateObject("Microsoft.XMLDOM")
xmldoc.async=false
xmldoc.load(request)

for each x in xmldoc.documentElement.childNodes
   if x.NodeName = "to" then name=x.text
next
response.write(name)
%>

通过使用 response.write 属性把结果传回客户端。

TIY

XMLHttpRequest 对象是 W3C 的标准吗？

任何 W3C 推荐标准均未规定 XMLHttpRequest 对象。

不过，W3C DOM Level 3 的 "Load and Save" 规范包含了一些相似的功能性，但是还没有任何浏览器实现它们。

参阅

XML DOM 参考手册: XMLHttpRequest 对象

  • Previous Page
  • Next Page

XML 实例
XML 测验


把数据存储到 XML 文件

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

把数据存储到 XML 文件

  • Previous Page
  • Next Page

通常，我们在数据库中存储数据。不过，如果希望数据的可移植性更强，我们可以把数据存储 XML 文件中。

创建并保存 XML 文件

如果数据要被传送到非 Windows 平台上的应用程序，那么把数据保存在 XML 文件中是有好处的。请记住，XML 有很强的跨平台可移植性，并且数据无需转换！

首先，我们将学习如何创建并保存一个 XML 文件。下面的这个 XML 文件将被命名为 "test.xml"，并被保存在服务器上的 c 目录中。我们将使用 ASP 和微软的 XMLDOM 对象来创建并保存这个 XML 文件：

<%
Dim xmlDoc, rootEl, child1, child2, p

'创建XML文档
Set xmlDoc = Server.CreateObject("Microsoft.XMLDOM")

'创建根元素并将之加入文档
Set rootEl = xmlDoc.createElement("root")
xmlDoc.appendChild rootEl

'创建并加入子元素
Set child1 = xmlDoc.createElement("child1")
Set child2 = xmlDoc.createElement("child2")
rootEl.appendChild child1
rootEl.appendChild child2

'创建 XML processing instruction
'并把它加到根元素之前
Set p=xmlDoc.createProcessingInstruction("xml","version='1.0'")
xmlDoc.insertBefore p,xmlDoc.childNodes(0)

'把文件保存到c目录
xmlDoc.Save "c:\test.xml"
%>

如果您打开这个被保存的文件，它会使这个样子 ("test.xml")：

<?xml version="1.0"?>
<root>
  <child1 />
  <child2 />
</root>

真实的表单例子

现在，我们看一个真实的表单例子。

我们首先看一下这个被用在例子中的 HTML 表单：下面的HTML表单要求用户输入他们的名字、国籍以及电子邮件地址。随后这些信息会被写到一个 XML 文件，以便存储。

"customers.htm":

<html>

<body>
<form action="saveForm.asp" method="post">
<h1>请输入您的联系信息：</h1>
<label>名字: </label>
<p><input type="text" id="fname" name="fname"></p>

<label>姓氏: </label>
<p><input type="text" id="lname" name="lname"></p>

<label>国家: </label>
<p><input type="text" id="country" name="country"></p>

<label>邮件: </label>
<p><input type="text" id="email" name="email"></p>

<p>
<input type="submit" id="btn_sub" name="btn_sub" value="Submit">
<input type="reset" id="btn_res" name="btn_res" value="Reset">
</p>
</form>
</body>

</html>

用于以上 HTML 表单的 action 被设置为 "saveForm.asp"。"saveForm.asp" 文件是一个 ASP 页面，可循环遍表单域，并把它们的值存储在一个 XML 文件之中：

<%
dim xmlDoc
dim rootEl,fieldName,fieldValue,attID
dim p,i

'如果有错误发生，不允许程序终止
On Error Resume Next

Set xmlDoc = server.CreateObject("Microsoft.XMLDOM")
xmlDoc.preserveWhiteSpace=true

'创建并向文档添加根元素
Set rootEl = xmlDoc.createElement("customer")
xmlDoc.appendChild rootEl

'循环遍历Form集
for i = 1 To Request.Form.Count
  '除去表单中的button元素
  if instr(1,Request.Form.Key(i),"btn_")=0 then
    '创建field 和 value 元素，以及　id 属性
    Set fieldName = xmlDoc.createElement("field")
    Set fieldValue = xmlDoc.createElement("value")
    Set attID = xmlDoc.createAttribute("id")
    '把当前表单域的名称设置为id属性的值
    attID.Text = Request.Form.Key(i)
    '把id属性添加到field元素
    fieldName.setAttributeNode attID
    '把当前表单域的值设置为value元素的值
    fieldValue.Text = Request.Form(i)
    '将field元素作为根元素的子元素进行添加
    rootEl.appendChild fieldName
    '将value元素作为field元素的子元素进行添加
    fieldName.appendChild fieldValue
  end if
next

'添加XML processing instruction
'并把它加到根元素之前
Set p = xmlDoc.createProcessingInstruction("xml","version='1.0'")
xmlDoc.insertBefore p,xmlDoc.childNodes(0)

'保存XML文件
xmlDoc.save "c:\Customer.xml"

'释放所有的对象引用
set xmlDoc=nothing
set rootEl=nothing
set fieldName=nothing
set fieldValue=nothing
set attID=nothing
set p=nothing

'测试是否有错误发生
if err.number<>0 then
  response.write("Error: No information saved.")
else
  response.write("Your information has been saved.")
end if
%>

注释：如果指定的 XML 文件名已经存在，那个文件会被覆盖！

XML 文件会由上面的代码生成，大致的样子是这样的：("Customer.xml"):

<?xml version="1.0" ?>
<customer>
  <field id="firstName">
    <value>David</value>
  </field>
  <field id="lastName">
    <value>Smith</value>
  </field>
  <field id="country">
    <value>China</value>
  </field>
  <field id="email">
    <value>mymail@myaddress.com</value>
  </field>
</customer>
  • Previous Page
  • Next Page

XML 实例
XML 测验


查看 XML 文件

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

查看 XML 文件

  • Previous Page
  • Next Page

在所有现代浏览器中，可能够查看原始的 XML 文件。

不要指望 XML 文件会直接显示为 HTML 页面。

查看 XML 文件

查看这个 XML 文件：note.xml

打开 XML 文件 - XML 文档将显示为代码颜色化的根以及子元素。通过点击元素左侧的加号或减号，可以展开或收起元素的结构。如需查看不带有 + 和 - 符号的源代码，请从浏览器菜单中选择“查看源代码”。

注释：在 Netscape, Opera 以及 Safari 中，仅仅会显示元素文本！要查看原始的 XML，请右击页面，然后选择“查看源代码”。

查看某个无效的 XML 文件

如果浏览器打开了某个有错误的 XML 文件，那么它会报告这个错误。

请查看这个 XML 文件：note_error.xml

其他的 XML 实例

请查看这些 XML 文档，这会有助于您建立对 XML 的感性认识。

一个 XML 的 CD 目录
这是我父亲的 CD 收藏，被存储为 XML 数据（我猜可能是很老很无聊的题目... :-)）
一个 XML 的植物目录
来自园艺店的植物目录，存储为 XML 数据。
一个简单的菜单
这是来自餐馆的早餐菜单，存储为 XML 数据。

为什么 XML 会这样显示？

XML 文档不会携带有关如何显示数据的信息。

由于 XML 标签由 XML 文档的作者“发明”，浏览器无法确定像 <table> 这样一个标签究竟描述一个 HTML 表格还是一个餐桌。

在没有任何有关如何显示数据的信息的情况下，大多数的浏览器都会仅仅把 XML 文档显示为源代码。

在下面的章节，我们会了解几个有关这个显示问题的解决方案，其中会使用 CSS、XSL、JavaScript 以及 XML 数据岛。

  • Previous Page
  • Next Page

XML 实例
XML 测验


服务器上的 XML

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

服务器上的 XML

  • Previous Page
  • Next Page

XML 可以在不安装任何 XML 控件的情况下在服务器端生成。

在服务器上存储 XML

XML 文件可被存储在服务器上，和 HTML 文件的存储方式是完全相同的。

启动 Windows 记事本，并编写以下代码行：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
  <from>John</from>
  <to>George</to>
  <message>Don't forget the meeting!</message>
</note>

然后把这个文件命名为 "note.xml" 并保存在您的服务器。

通过 ASP 生成 XML

XML 可在不安装任何 XML 软件的情况下在服务器端生成。

如需从服务器生成 XML 响应 - 只需简单地编写以下代码并在服务器上把它保存为一个 ASP 文件：

<%
response.ContentType="text/xml"
response.Write("<?xml version='1.0' encoding='ISO-8859-1'?>")
response.Write("<note>")
response.Write("<from>John</from>")
response.Write("<to>George</to>")
response.Write("<message>Don't forget the meeting!</message>")
response.Write("</note>")
%>

请注意，此响应的内容类型必须设置为 "text/xml"。

查看这个ASP文件如何从服务器返回。

如果您还不懂如何编写 ASP，请访问我们的《ASP 教程》。

从数据库获取 XML

XML 可在不安装任何 XML 软件的情况下从数据库生成。

如需从服务器生成 XML 数据库响应，只需简单地编写以下代码，并把它在服务器上保存为 ASP 文件：

<%
response.ContentType = "text/xml"
set conn=Server.CreateObject("ADODB.Connection")
conn.provider="Microsoft.Jet.OLEDB.4.0;"
conn.open server.mappath("/db/database.mdb")
sql="select fname,lname from tblGuestBook"
set rs=Conn.Execute(sql)

rs.MoveFirst()

response.write("<?xml version='1.0' encoding='ISO-8859-1'?>")
response.write("<guestbook>")
while (not rs.EOF)
  response.write("<guest>")
  response.write("<fname>" & rs("fname") & "</fname>")
  response.write("<lname>" & rs("lname") & "</lname>")
  response.write("</guest>")
  rs.MoveNext()
wend

rs.close()
conn.close()
response.write("</guestbook>")
%>

上面的例子使用了带有 ADO 的 ASP。如果您不懂如何使用 ADO，请访问我们的《ADO 教程》。

  • Previous Page
  • Next Page

XML 实例
XML 测验


您已经学习了XML,下一步学习什么内容呢？

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

您已经学习了XML,下一步学习什么内容呢？

  • Previous Page
  • Next Page

XML 概要

本教程已经向您讲解了如何使用 XML 来描述数据。

您已经理解，XML 应当用来从 HTML 那里分离数据。

同时您也学习到，XML 可被用来交换、共享以及存储数据。

如需更多关于 XML 的信息，请查看我们的 XML 实例。

您已经学习了 XML，下一步学习什么内容呢？

下一步的学习内容是 XML DOM 和 XSLT。

如果您需要学习有关 XML 验证的知识，下一步的学习内容是 DTD 和 XML Schema。

XML DOM

XML DOM 定义了一种访问和操作 XML 文档的标准方法。

XML DOM 独立于语言和平台，可被任何编程语言使用，比如 Java、JavaScript 以及 VBScript。

如果您希望学习有关 DOM 的知识，请访问我们的 XML DOM 教程。

XSLT

XSLT 是一种针对 XML 文件的样式表语言。

通过 XSLT，您可以把 XML 文档转换为其他格式，比如 XHTML。

如果您需要学习有关 XSLT 的知识，请访问我们的 XSLT 教程。

DTD 和 XML Schema

DTD 的作用是定义在 XML 文档中什么元素、属性以及实体是合法的。

通过 DTD，您的每个 XML 文件均可携带有关其自身格式的描述。

DTD 可用于验证您接收到的以及您自己的数据的有效性。

如果需要学习有关 DTD 的知识，请访问我们的 DTD 教程。

XML Schema 将取代 DTD。

XML Schema 是一种基于 XML 的 DTD 替代物。

与 DTD 不同，XML Schema 已经开始支持数据类型，同时 XML Schema 使用 XML 语法。

如果您希望学习有关 XML Schema 的知识，请访问我们的 XML Schema 教程。

  • Previous Page
  • Next Page

XML 实例
XML 测验


使用 CSS 显示 XML

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

使用 CSS 显示 XML

  • Previous Page
  • Next Page

通过使用 CSS，可为 XML 文档添加显示信息。

使用 CSS 显示您的 XML？

使用 CSS 来格式化 XML 文档是有可能的。

下面的例子就是关于如何使用 CSS 样式表来格式化某个XML文档：

这是 XML 文件：CD 目录

这是样式表：CSS 文件

最后，请查看效果：由 CSS 文件格式化的 CD 目录

下面是此XML文件的一个片断。 第二行，<?xml-stylesheet type="text/css" href="cd_catalog.css"?>，把这个 XML 文件链接到 CSS 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<?xml-stylesheet type="text/css" href="cd_catalog.css"?>
<CATALOG>
  <CD>
    <TITLE>Empire Burlesque</TITLE>
    <ARTIST>Bob Dylan</ARTIST>
    <COUNTRY>USA</COUNTRY>
    <COMPANY>Columbia</COMPANY>
    <PRICE>10.90</PRICE>
    <YEAR>1985</YEAR>
  </CD>
  <CD>
    <TITLE>Hide your heart</TITLE>
    <ARTIST>Bonnie Tyler</ARTIST>
    <COUNTRY>UK</COUNTRY>
    <COMPANY>CBS Records</COMPANY>
    <PRICE>9.90</PRICE>
    <YEAR>1988</YEAR>
  </CD>
.
.
.
.
</CATALOG>

注释：使用 CSS 格式化 XML 不能代表 XML 文档样式化的未来。XML 文档应当使用 W3C 的 XSL 标准进行格式化！

  • Previous Page
  • Next Page

XML 实例
XML 测验


使用 XSLT 显示 XML

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

使用 XSLT 显示 XML

  • Previous Page
  • Next Page

通过使用 XSLT，您可以向 XML 文档添加显示信息。

使用 XSLT 显示 XML

XSLT 是首选的 XML 样式表语言。

XSLT (eXtensible Stylesheet Language Transformations) 远比 CSS 更加完善。

使用 XSLT 的方法之一是在浏览器显示 XML 文件之前，先把它转换为 HTML，正如以下的这些例子演示的那样：

查看 XML 文件，XSLT 样式表，查看结果。

下面是此 XML 文件的一个片断。 第二行，<?xml-stylesheet type="text/xsl" href="simple.xsl"?>，把这个 XML 文件链接到 XSL 文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<?xml-stylesheet type="text/xsl" href="simple.xsl"?>
<breakfast_menu>
  <food>
    <name>Belgian Waffles</name>
    <price>$5.95</price>
    <description>
       two of our famous Belgian Waffles
    </description>
    <calories>650</calories>
  </food>
</breakfast_menu>

如果您需要学习更多有关 XSLT 的知识，请访问我们的《XSLT 教程》。

在服务器上通过 XSLT 转换 XML

在上例中，XSLT 转换是由浏览器完成的，浏览器读取的是 XML 文件。

在使用 XSLT 来转换 XML 时，不同的浏览器可能会产生不同结果。为了减少这种问题，可以在服务器上进行 XSLT 转换。

查看结果。

请注意，不论转换由服务器还是由浏览器进行，输出结果完成相同。

  • Previous Page
  • Next Page

XML 实例
XML 测验


现实生活中的 XML

XML 基础

  • XML 首页
  • XML 简介
  • XML 用途
  • XML 树结构
  • XML 语法
  • XML 元素
  • XML 属性
  • XML 验证
  • XML 验证器
  • XML 浏览器
  • XML 查看
  • XML CSS
  • XML XSLT

XML JavaScript

  • XML 解析器
  • XML DOM
  • XML to HTML
  • XML HTTP Request
  • XML 应用程序

XML 高级

  • XML 命名空间
  • XML CDATA
  • XML 编码
  • XML 服务器
  • XML DOM 高级
  • XML Don't
  • XML 数据存储
  • XML 技术
  • XML 现实案例
  • XML 编辑器
  • XML 总结

实例/测验

  • XML 实例
  • XML 测验

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

现实生活中的 XML

  • Previous Page
  • Next Page

一个现实生活中的例子，向您展示 XML 如何携带数据。

实例: XML 新闻

XMLNews 是用于交换新闻和其他信息的规范。

对新闻的供求双方来说，通过使用这种标准，可以使各种类型的新闻信息通过不同软硬件以及编程语言进行的制作、接收和存档更加容易。

一个 XMLNews 文档实例:

<?xml version="1.0" encoding="ISO-8859-1"?>

<nitf>

<head>
<title>Colombia Earthquake</title>
</head>

<body>

<headline>
  <hl1>143 Dead in Colombia Earthquake</hl1>
</headline>
<byline>
  <bytag>By Jared Kotler, Associated Press Writer</bytag>
</byline>
<dateline>
  <location>Bogota, Colombia</location>
  <date>Monday January 25 1999 7:28 ET</date>
</dateline>

</body>

</nitf>

实例：XML Weather Service

国家气象服务案例，来自 NOAA (National Oceanic and Atmospheric Administration)：

<?xml version="1.0" encoding="ISO-8859-1" ?>

<current_observation>

<credit>NOAA's National Weather Service</credit>
<credit_URL>http://weather.gov/</credit_URL>

<image>
   <url>http://weather.gov/images/xml_logo.gif</url>
   <title>NOAA's National Weather Service</title>
   <link>http://weather.gov</link>
</image>

<location>New York/John F. Kennedy Intl Airport, NY</location>
<station_id>KJFK</station_id>
<latitude>40.66</latitude>
<longitude>-73.78</longitude>
<observation_time_rfc822>
Mon, 11 Feb 2008 06:51:00 -0500 EST
</observation_time_rfc822>

<weather>A Few Clouds</weather>
<temp_f>11</temp_f>
<temp_c>-12</temp_c>
<relative_humidity>36</relative_humidity>
<wind_dir>West</wind_dir>
<wind_degrees>280</wind_degrees>
<wind_mph>18.4</wind_mph>
<wind_gust_mph>29</wind_gust_mph>
<pressure_mb>1023.6</pressure_mb>
<pressure_in>30.23</pressure_in>
<dewpoint_f>-11</dewpoint_f>
<dewpoint_c>-24</dewpoint_c>
<windchill_f>-7</windchill_f>
<windchill_c>-22</windchill_c>
<visibility_mi>10.00</visibility_mi>

<icon_url_base>
http://weather.gov/weather/images/fcicons/
</icon_url_base>
<icon_url_name>nfew.jpg</icon_url_name>
<two_day_history_url>
http://www.weather.gov/data/obhistory/KJFK.html
</two_day_history_url>
<disclaimer_url>
http://weather.gov/disclaimer.html
</disclaimer_url>
<copyright_url>
http://weather.gov/disclaimer.html
</copyright_url>

</current_observation>
  • Previous Page
  • Next Page

XML 实例
XML 测验


XML DOM - Attr 对象

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM - Attr 对象

  • Previous Page
  • Next Page

Attr 对象表示 Element 对象的属性。

Attr 对象

Attr 对象表示 Element 对象的属性。属性的容许值通常定义在 DTD 中。

由于 Attr 对象也是一种节点，因此它继承 Node 对象的属性和方法。不过属性无法拥有父节点，同时属性也不被认为是元素的子节点，对于许多 Node 对象的属性来说都将返回 null。

Attr 对象的属性

属性 | 描述 | IE | F | O | W3C
baseURI | 返回属性的绝对基准 URI。 | No | 1 | No | Yes
isId | 如果属性是 id 类型，则返回 true，否则返回 false。 | No | No | No | Yes
localName | 返回属性名称的本地部分。 | No | 1 | 9 | Yes
name | 返回属性的名称。 | 5 | 1 | 9 | Yes
namespaceURI | 返回属性的命名空间 URI。 | No | 1 | 9 | Yes
nodeName | 返回节点的名称，依据其类型。 | 5 | 1 | 9 | Yes
nodeType | 返回节点的类型。 | 5 | 1 | 9 | Yes
nodeValue | 设置或返回节点的值，依据其类型。 | 5 | 1 | 9 | Yes
ownerDocument | 返回属性所属的根元素（document对象）。 | 5 | 1 | 9 | Yes
ownerElement | 返回属性所附属的元素节点。 | No | 1 | 9 | Yes
prefix | 设置或返回属性的命名空间前缀。 | No | 1 | 9 | Yes
schemaTypeInfo | 返回与属性相关联的类型信息。 | No | No | No | Yes
specified | 如果属性值被设置在文档中，则返回 true，如果其默认值被设置在 DTD/Schema 中，则返回 false。 | 5 | 1 | 9 | Yes
textContent | 设置或返回属性的文本内容。 | No | 1 | 9 | Yes
text | 返回属性的文本。IE-only。 | 5 | No | No | No
value | 设置或返回属性的值。 | 5 | 1 | 9 | Yes
xml | 返回属性的 XML。IE-only。 | 5 | No | No | No
  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM - CDATASection 对象

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM - CDATASection 对象

  • Previous Page
  • Next Page

CDATASection 对象表示文档中的 CDATA 区段。

实例

在下面的例子中，我们会使用 XML 文件books.xml，以及 JavaScript 函数 loadXMLDoc()。

createCDATASection() - 创建一个 CDATA 区段节点

CDATASection 对象

CDATASection 对象表示文档中的 CDATA Section。

CDATASection 接口是 Text 接口的子接口，没有定义任何自己的属性和方法。通过从 Node 接口继承 nodeValue 属性，或通过从 CharacterData 接口继承 data 属性，可以访问 CDATA Section 的文本内容。

虽然通常可以把 CDATASection 节点作为 Text 节点处理，但要注意，Node.normalize() 方法不并入相邻的 CDATA 部分。

使用 Document.createCDATASection() 来创建一个 CDATASection。

CDATA 区段包含了不会被解析器解析的文本。CDATA 区段中的标签不会被视为标记，同时实体也不会被展开。主要的目的是为了包含诸如 XML 片段之类的材料，而无需转义所有的分隔符。

在一个 CDATA 中唯一被识别的分隔符是 "]]>"，它可标示 CDATA 区段的结束。CDATA 区段不能进行嵌套。

CDATASection 对象的属性

属性 | 描述 | IE | F | O | W3C
data | 设置或返回此节点的文本 | 6 | 1 | No | Yes
length | 返回CDATA区段的长度 | 6 | 1 | No | Yes

CDATASection 对象的属性

方法 | 描述 | IE | F | O | W3C
appendData() | 向节点追加数据 | 6 | 1 | No | Yes
deleteData() | 从节点删除数据 | 6 | 1 | No | Yes
insertData() | 向节点中插入数据 | 6 | 1 | No | Yes
replaceData() | 替换节点中的数据 | 6 | 1 | No | Yes
splitText() | 把 CDATA 分拆为两个节点 | 6 | 1 | No |
substringData() | 从节点提取数据 | 6 | 1 | No | Yes
  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM - Comment 对象

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM - Comment 对象

  • Previous Page
  • Next Page

Comment 对象表示文档中注释节点的内容。

实例

在下面的例子中，我们会使用 XML 文件 books_comment.xml，以及 JavaScript 函数 loadXMLDoc()。

createComment() - 创建一个注释节点

Comment 对象

Comment 对象表示文档中注释节点的内容。

Comment 节点表示 HTML 或 XML 文档中的注释。

使用由 CharacterData 接口继承的 data 属性，或使用由 Node 接口继承的 nodeValue 属性，可以访问注释的内容。（即 <!-- 和 --> 之间的文本）。使用由 CharacterData 接口继承的各种方法可以操作注释的内容。

使用 Document.createComment() 来创建一个注释对象。

Comment 对象的属性

属性 | 描述 | IE | F | O | W3C
data | 可设置或返回此节点的文本。 | 6 | 1 | 9 | Yes
length | 可返回此节点的文本的长度。 | 6 | 1 | 9 | Yes

Comment 对象的方法

方法 | 描述 | IE | F | O | W3C
appendData() | 向节点追加数据。 | 6 | 1 | 9 | Yes
deleteData() | 从节点删除数据。 | 6 | 1 | 9 | Yes
insertData() | 向节点中插入数据。 | 6 | 1 | 9 | Yes
replaceData() | 替换节点中的数据。 | 6 | 1 | 9 | Yes
substringData() | 从节点中提取数据。 | 6 | 1 | 9 | Yes
  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM - Document 对象

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM - Document 对象

  • Previous Page
  • Next Page

Document 对象代表整个 XML 文档。

Document 对象

Document 对象是一棵文档树的根，可为我们提供对文档数据的最初（或最顶层）的访问入口。

用于元素节点、文本节点、注释、处理指令等均无法存在于 document 之外，document 对象同样提供了创建这些对象的方法。Node 对象提供了一个 ownerDocument 属性，此属性可把它们与在其中创建它们的 Document 关联起来。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: 万维网联盟 (因特网标准)

Document 对象的属性

属性 | 描述 | IE | F | O | W3C
async | 规定 XML 文件的下载是否应当被同步处理。 | 5 | 1.5 | 9 | No
childNodes | 返回属于文档的子节点的节点列表。 | 5 | 1 | 9 | Yes
doctype | 返回与文档相关的文档类型声明 (DTD)。 | 6 | 1 | 9 | Yes
documentElement | 返回文档的根节点 | 5 | 1 | 9 | Yes
documentURI | 设置或返回文档的位置 | No | 1 | 9 | Yes
domConfig | 返回normalizeDocument()被调用时所使用的配置 |  |  | No | Yes
firstChild | 返回文档的首个子节点 | 5 | 1 | 9 | Yes
implementation | 返回处理该文档的 DOMImplementation 对象。 | No | 1 | 9 | Yes
inputEncoding | 返回用于文档的编码方式（在解析时）。 | No | 1 | No | Yes
lastChild | 返回文档的最后一个子节点。 | 5 | 1 | 9 | Yes
nodeName | 依据节点的类型返回其名称。 | 5 | 1 | 9 | Yes
nodeType | 返回节点的节点类型。 | 5 | 1 | 9 | Yes
nodeValue | 根据节点的类型来设置或返回节点的值。 | 5 | 1 | 9 | Yes
strictErrorChecking | 设置或返回是否强制进行错误检查。 | No | 1 | No | Yes
text | 返回节点及其后代的文本（仅用于 IE）。 | 5 | No | No | No
xml | 返回节点及其后代的 XML（仅用于 IE）。 | 5 | No | No | No
xmlEncoding | 返回文档的编码方法。 | No | 1 | No | Yes
xmlStandalone | 设置或返回文档是否为 standalone。 | No | 1 | No | Yes
xmlVersion | 设置或返回文档的 XML 版本。 | No | 1 | No | Yes

Document 对象的方法

属性 | 描述 | IE | F | O | W3C
adoptNode(sourcenode) | 从另一个文档向本文档选定一个节点，然后返回被选节点。 |  |  | No | Yes
createAttribute(name) | 创建拥有指定名称的属性节点，并返回新的 Attr 对象。 | 6 | 1 | 9 | Yes
createAttributeNS(uri,name) | 创建拥有指定名称和命名空间的属性节点，并返回新的 Attr 对象。 |  |  | 9 | Yes
createCDATASection() | 创建 CDATA 区段节点。 | 5 | 1 | 9 | Yes
createComment() | 创建注释节点。 | 6 | 1 | 9 | Yes
createDocumentFragment() | 创建空的 DocumentFragment 对象，并返回此对象。 | 5 | 1 | 9 | Yes
createElement() | 创建元素节点。 | 5 | 1 | 9 | Yes
createElementNS() | 创建带有指定命名空间的元素节点。 | No | 1 | 9 | Yes
createEvent() | 创建新的 Event 对象。 |  |  |  | Yes
createEntityReference(name) | 创建 EntityReference 对象，并返回此对象。 | 5 |  | No | Yes
createExpression() | 创建一个XPath表达式以供稍后计算。 |  |  |  | Yes
createProcessingInstruction(target,data) | 创建 ProcessingInstruction 对象，并返回此对象。 | 5 |  | 9 | Yes
createRange() | 创建 Range 对象，并返回此对象。 | No |  |  | Yes
evaluate() | 计算一个 XPath 表达式。 | No | 1 | 9 | Yes
createTextNode() | 创建文本节点。 | 5 | 1 | 9 | Yes
getElementById() | 查找具有指定的唯一 ID 的元素。 | 5 | 1 | 9 | Yes
getElementsByTagName() | 返回所有具有指定名称的元素节点。 | 5 | 1 | 9 | Yes
getElementsByTagNameNS() | 返回所有具有指定名称和命名空间的元素节点。 | No | 1 | 9 | Yes
importNode() | 把一个节点从另一个文档复制到该文档以便应用。 |  |  | 9 | Yes
loadXML() | 通过解析XML标签字符串来组成文档。 |  |  |  |
normalizeDocument() |  |  |  | No | Yes
renameNode() | 重命名元素或者属性节点。 |  |  | No | Yes
  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM - DocumentFragment 对象

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM - DocumentFragment 对象

DocumentFragment 对象表示邻接节点和它们的子树。

DocumentFragment 对象

DocumentFragment 接口表示文档的一部分（或一段）。更确切地说，它表示一个或多个邻接的 Document 节点和它们的所有子孙节点。

DocumentFragment 节点不属于文档树，继承的 parentNode 属性总是 null。

不过它有一种特殊的行为，该行为使得它非常有用，即当请求把一个 DocumentFragment 节点插入文档树时，插入的不是 DocumentFragment 自身，而是它的所有子孙节点。这使得 DocumentFragment 成了有用的占位符，暂时存放那些一次插入文档的节点。它还有利于实现文档的剪切、复制和粘贴操作，尤其是与 Range 接口一起使用时更是如此。

可以用 Document.createDocumentFragment() 方法创建新的空 DocumentFragment 节点。

也可以用 Range.extractContents() 方法 或 Range.cloneContents() 方法 获取包含现有文档的片段的 DocumentFragment 节点。

XML DOM 参考手册
XML DOM 实例


XML DOM - DocumentImplementation 对象

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM - DomImplementation 对象

  • Previous Page
  • Next Page

DomImplementation 对象可执行与文档对象模型的任何实例无关的任何操作。

DomImplementation 对象

DomImplementation 对象可执行与文档对象模型的任何实例无关的任何操作。

DomImplementation 接口是一个占位符，存放不专属任何特定 Document 对象，而对 DOM 实现来说是“全局性”的方法。可以通过任何 Document 对象的 implementation 属性获得对 DomImplementation 对象的引用。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: 万维网联盟 (因特网标准)

DomImplementation 对象的方法

方法 | 描述
createDocument() | 创建一个新 Document 对象和指定的根元素。
createDocumentType() | 创建空的 DocumentType 节点。
getFeature() | 返回可执行定义特性和版本的 API 的对象。
hasFeature() | 检查 DOM implementation 是否可执行指定的特性和版本。
  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM - DocumentType 对象

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM - DocumentType 对象

  • Previous Page
  • Next Page

DocumentType 对象可向为 XML 所定义的实体提供一个接口。

DocumentType 对象

每个文档均有一个 DOCTYPE 属性，此属性的值可为 null，也可是一个 DocumentType 对象。

DocumentType 对象可向为 XML 所定义的实体提供接口。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: 万维网联盟 (因特网标准)

DocumentType 对象的属性

属性 | 描述 | IE | F | O | W3C
entities | 可返回含有在 DTD 中所声明的实体的 NamedNodeMap | 6 | No | 9 | Yes
internalSubset | 以字符串返回内部 DTD | No | No | No | Yes
name | 返回 DTD 的名称 | 6 | 1 | 9 | Yes
notations | 可返回含有在 DTD 中所声明的符号（notation）的 NamedNodeMap | 6 | No | 9 | Yes
systemId | 可返回外部 DTD 的系统识别符 | No | 1 | 9 | Yes
  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM - DOMException 对象

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM - DOMException 对象

  • Previous Page
  • Next Page

通知核心 DOM 对象的异常或通知。

常量

下面的常量定义了 DOMException 对象的 code 属性的合法值。

注释：这些常量是 DOMException 的静态属性，不是个别异常对象的属性。

INDEX_SIZE_ERR

说明数组或字符串下标的溢出错误。

DOMSTRING_SIZE_ERR

说明请求的文本太大，文本的指定范围不适合 DOMString。

HIERARCHY_REQUEST_ERR

说明发生了要把节点放在文档树层次中的不合法位置的操作。

WRONG_DOCUMENT_ERR

说明发生了从创建节点的文档以外的文档使用使用该节点的操作。

INVALID_CHARACTER_ERR

说明（比如在元素名中）使用了不合法的字符。

NO_DATA_ALLOWED_ERR

为不支持数据的 Node 指定数据。

NO_MODIFICATION_ALLOWED_ERR

说明发生了修改只读的、不允许修改的节点的操作。

NOT_FOUND_ERR

说明在期望的位置没有找到指定的节点

NOT_SUPPORTED_ERR

说明当前的 DOM 实现不支持某个属性或方法。

INUSE_ATTRIBUTE_ERR

说明在一个 Attr 节点已经关联到另一个 Element 节点时，发生了把一个 Attr 节点关联到另一个 Element 节点的操作。

INVALID_STATE_ERR

说明使用了处于不允许使用状态或不再允许使用状态的对象。

SYNTAX_ERR

说明指定的错误含有语法错误。通常由 CSS 属性声明使用。

INVALID_MODIFICATION_ERR

说明发生了修改 CSSRule 对象或 CSSValue 对象的操作。

NAMESPACE_ERR

说明有涉及元素或属性的命名空间的错误。

INVALID_ACCESS_ERR

说明以一种当前的实现不支持的方法访问对象。

code 属性

出错代码。提供了引发异常的原因的详细情况。该属性的合法值（和它们的含义）由前面列出的常量定义。

描述

当错误使用或在不适合的环境中使用某个 DOM 属性或方法时，就会抛出一个 DOMException 对象。code 属性的值说明了发生的异常的一般类型。注意，读写对象的属性或调用对象的方法时，都有可能抛出 DOMException 对象。

在 W3School 提供的 XML DOM 参考手册中，对象的属性和方法的描述部分列出了可能抛出的异常。

注意，并非 DOM 中的所有异常都由 DOMException 通知：涉及 DOM Range 模块的异常，会导致抛出 RangeException 异常。

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM - DOMParser 对象

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM - DOMParser 对象

  • Previous Page
  • Next Page

解析 XML 标记来创建一个文档。

构造函数

new DOMParser()

说明

DOMParser 对象解析 XML 文本并返回一个 XML Document 对象。要使用 DOMParser，使用不带参数的构造函数来实例化它，然后调用其 parseFromString() 方法：

var doc = (new DOMParser()).parseFromString(text)

IE 不支持 DOMParser 对象。相反，它支持使用 Document.loadXML() 的 XML 解析。

注意，XMLHttpRequest 对象也可以解析 XML 文档。参阅 XMLHttpRequest 的 responseXML 属性。

DOMParser.parseFromString()

解析 XML 标记

语法

parseFromString(text, contentType)

text 参数是要解析的 XML 标记。

contentType 是文本的内容类型。可能是 "text/xml" 、"application/xml" 或 "application/xhtml+xml" 中的一个。注意，不支持 "text/html"。

返回值

保存 text 解析后表示的一个 Document 对象。参阅 Document.loadXML()，了解这个方法的一个特定于 IE 的替代。

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM - Element 对象

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM - Element 对象

  • Previous Page
  • Next Page

Element 对象表示 XML 文档中的元素。

Element 对象

Element 对象表示 XML 文档中的元素。元素可包含属性、其他元素或文本。如果元素含有文本，则在文本节点中表示该文本。

重要事项：文本永远存储在文本节点中。在 DOM 处理过程中的一个常见的错误是，导航到元素节点，并认为此节点含有文本。不过，即使最简单的元素节点之下也拥有文本节点。举例，在 <year>2005</year> 中，有一个元素节点（year），同时此节点之下存在一个文本节点，其中含有文本（2005）。

由于元素对象也是一种节点，因此它可继承 Node 对象的属性和方法。

Element 对象的属性

属性 | 描述 | IE | F | O | W3C
attributes | 返回元素的属性的 NamedNodeMap | 5 | 1 | 9 | Yes
baseURI | 返回元素的绝对基准 URI | No | 1 | No | Yes
childNodes | 返回元素的子节点的 NodeList | 5 | 1 | 9 | Yes
firstChild | 返回元素的首个子节点 | 5 | 1 | 9 | Yes
lastChild | 返回元素的最后一个子节点 | 5 | 1 | 9 | Yes
localName | 返回元素名称的本地部分 | No | 1 | 9 | Yes
namespaceURI | 返回元素的命名空间 URI | No | 1 | 9 | Yes
nextSibling | 返回元素之后紧跟的节点 | 5 | 1 | 9 | Yes
nodeName | 返回节点的名称，依据其类型。 | 5 | 1 | 9 | Yes
nodeType | 返回节点的类型 | 5 | 1 | 9 | Yes
ownerDocument | 返回元素所属的根元素 (document 对象) | 5 | 1 | 9 | Yes
parentNode | 返回元素的父节点 | 5 | 1 | 9 | Yes
prefix | 设置或返回元素的命名空间前缀 | No | 1 | 9 | Yes
previousSibling | 返回元素之前紧随的节点 | 5 | 1 | 9 | Yes
schemaTypeInfo | 返回与元素相关联的类型信息 |  |  | No | Yes
tagName | 返回元素的名称 | 5 | 1 | 9 | Yes
textContent | 设置或返回元素及其后代的文本内容 | No | 1 | No | Yes
text | 返回节点及其后代的文本 (IE-only) | 5 | No | No | No
xml | 返回节点及其后代的 XML (IE-only) | 5 | No | No | No

Element 对象的方法

方法 | 描述 | IE | F | O | W3C
appendChild() | 向节点的子节点列表末尾添加新的子节点。 | 5 | 1 | 9 | Yes
cloneNode() | 克隆节点。 | 5 | 1 | 9 | Yes
compareDocumentPosition() | 比较两节点的文档位置。 | No | 1 | No | Yes
dispatchEvent() | 给节点分派一个合成事件。 | 5 | 1 | 9 | Yes
getAttribute() | 返回属性的值。 | 5 | 1 | 9 | Yes
getAttributeNS() | 返回属性的值。 | No | 1 | 9 | Yes
getAttributeNode() | 以 Attribute 对象返回属性节点。 | 5 | 1 | 9 | Yes
getAttributeNodeNS() | 以 Attribute 对象返回属性节点。 | No |  | 9 | Yes
getElementsByTagName() | 找到具有指定标签名的子孙元素。 | 5 | 1 | 9 | Yes
getElementsByTagNameNS() | 找到具有指定标签名和命名空间的元素。 | No | 1 | 9 | Yes
getFeature(feature,version) | 返回 DOM 对象，此对象可执行拥有指定特性和版本的专门的 API。 |  |  | No | Yes
getUserData(key) | 返回关联节点上键的对象。此对象必须首先通过使用相同的键来调用 setUserData 来设置到此节点。 |  |  | No | Yes
hasAttribute() | 返回元素是否拥有指定的属性。 | 5 | 1 | 9 | Yes
hasAttributeNS() | 返回元素是否拥有指定的属性。 | No | 1 | 9 | Yes
hasAttributes() | 返回元素是否拥有属性。 | 5 | 1 | 9 | Yes
hasChildNodes() | 返回元素是否拥有子节点。 | 5 | 1 | 9 | Yes
insertBefore() | 在已有的子节点之前插入一个新的子节点。 | 5 | 1 | 9 | Yes
isDefaultNamespace(URI) | 返回指定的命名空间 URI 是否为默认。 |  |  | No | Yes
isEqualNode() | 检查两节点是否相等。 | No | No | No | Yes
isSameNode() | 检查两节点是否为同一节点。 | No | 1 | No | Yes
isSupported(feature,version) | 返回指定的特性是否在此元素上得到支持。 |  |  | 9 | Yes
lookupNamespaceURI() | 返回匹配指定前缀的命名空间 URI。 | No | 1 | No | Yes
lookupPrefix() | 返回匹配指定的命名空间 URI 的前缀。 | No | 1 | No | Yes
normalize() |  | 5 | 1 | 9 | Yes
removeAttribute() | 删除指定的属性。 | 5 | 1 | 9 | Yes
removeAttributeNS() | 删除指定的属性。 | No | 1 | 9 | Yes
removeAttributeNode() | 删除指定的属性节点。 | 5 | 1 | 9 | Yes
removeChild() | 删除子节点。 | 5 | 1 | 9 | Yes
replaceChild() | 替换子节点。 | 5 | 1 | 9 | Yes
setUserData(key,data,handler) | 把对象关联到元素上的键。 |  |  | No | Yes
setAttribute() | 添加新属性。 | 5 | 1 | 9 | Yes
setAttributeNS() | 添加新属性。 |  | 1 | 9 | Yes
setAttributeNode() | 添加新的属性节点。 | 5 | 1 | 9 | Yes
setAttributeNodeNS(attrnode) | 添加新的属性节点。 |  |  | 9 | Yes
setIdAttribute(name,isId) | 如果 Attribute 对象 isId 属性为 true，那么此方法会把指定的属性声明为一个用户确定 ID 的属性（user-determined ID attribute）。 |  |  | No | Yes
setIdAttributeNS(uri,name,isId) | 如果 Attribute 对象 isId 属性为 true，那么此方法会把指定的属性声明为一个用户确定 ID 的属性（user-determined ID attribute）（带有命名空间）。 |  |  | No | Yes
setIdAttributeNode(idAttr,isId) | 如果 Attribute 对象 isId 属性为 true，那么此方法会把指定的属性声明为一个用户确定 ID 的属性（user-determined ID attribute）。 |  |  | No | Yes
  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM - Event 对象

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM - Event 对象

  • Previous Page
  • Next Page

Range 对象表示文档中的连续范围。

Event 对象

Event 对象的属性提供了有关事件的细节（例如，事件在其上发生的元素）。Event 对象的方法可以控制事件的传播。

2 级 DOM Events 标准定义了一个标准的事件模型，它被除 IE 以外的所有现代浏览器所实现，而 IE 定义了自己的、不兼容的模型。这个参考页列出了标准 Event 对象的属性以及 IE Event 对象对象的属性。

注意：在标准事件模型中，Event 对象传递给事件句柄函数；但是在 IE 事件模型中，它被存储在 Window 对象的 event 属性中。

在标准事件模型中，Event 的各种子接口定义了额外的属性，它们提供了和特定事件类型相关的细节。在 IE 事件模型中，只有一种类型的 Event 对象，它用于所有类型的事件。

标准 Event 属性

下面列出了 2 级 DOM 事件标准定义的属性。

属性 | 描述 | IE | F | O | W3C
bubbles | 返回一个布尔值，指示事件是否是起泡事件类型。 | No | 1 | 9 | Yes
cancelable | 返回一个指示布尔值，指示事件是否可拥可取消的默认动作。 | No | 1 | 9 | Yes
currentTarget | 返回其事件监听器触发该事件的元素。 | No | 1 | 9 | Yes
eventPhase | 返回事件传播的当前阶段。 |  |  |  | Yes
target | 返回触发此事件的元素（事件的目标节点）。 | No | 1 | 9 | Yes
timeStamp | 返回事件生成的日期和时间。 | No | 1 | 9 | Yes
type | 返回当前 Event 对象表示的事件的名称。 | 6 | 1 | 9 | Yes

标准 Event 方法

下面列出了 2 级 DOM 事件标准定义的方法。IE 的事件模型不支持这些方法：

方法 | 描述 | IE | F | O | W3C
initEvent() | 初始化新创建的 Event 对象的属性。 | No | 1 | 9 | Yes
preventDefault() | 通知浏览器不要执行与事件关联的默认动作。 | No | 1 | 9 | Yes
stopPropagation() | 终止事件在传播过程的捕获、目标处理或起泡阶段进一步传播。调用该方法后，该节点上处理该事件的处理程序将被调用，事件不再被分派到其他节点。 | No | 1 | 9 | Yes

IE 属性

IE 并不支持（至少在 IE 7 中）标准的 DOM 事件模型，并且 IE 的 Event 对象定义了一组完全不同的属性。

IE 事件模型并没有为不同的事件定义继承层级，因此所有和任何事件的类型相关的属性都在这里列出。

属性 | 描述
cancelBubble | 如果事件句柄想阻止事件传播到包容对象，必须把该属性设为 true。
fromElement | 对于 mouseover 和 mouseout 事件，fromElement 引用移出鼠标的元素。
keyCode | 对于 keypress 事件，该属性声明了被敲击的键生成的 Unicode 字符码。对于 keydown 和 keyup 事件，它指定了被敲击的键的虚拟键盘码。虚拟键盘码可能和使用的键盘的布局相关。
offsetX,offsetY | 发生事件的地点在事件源元素的坐标系统中的 x 坐标和 y 坐标。
returnValue | 如果设置了该属性，它的值比事件句柄的返回值优先级高。把这个属性设置为 fasle，可以取消发生事件的源元素的默认动作。
srcElement | 对于生成事件的 Window 对象、Document 对象或 Element 对象的引用。
toElement | 对于 mouseover 和 mouseout 事件，该属性引用移入鼠标的元素。
x,y | 事件发生的位置的 x 坐标和 y 坐标，它们相对于用CSS动态定位的最内层包容元素。
  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM - NamedNodeMap 对象

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM - NamedNodeMap 对象

  • Previous Page
  • Next Page

NamedNodeMap 对象表示一个无顺序的节点列表。

NamedNodeMap 对象

我们可通过节点名称来访问 NamedNodeMap 中的节点。

NamedNodeMap 可保持其自身的更新。假如节点列表或 XML 文档中的某元素被删除或添加，节点也会被自动更新。

注释：注释：在一个指定的节点地图中，节点不会以任何次序返回。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: 万维网联盟 (因特网标准)

NamedNodeMap 对象的属性

属性 | 描述 | IE | F | O | W3C
length | 可返回列表中的节点数目 | 5 | 1 | 9 | Yes

NamedNodeMap 对象的方法

方法 | 描述 | IE | F | O | W3C
getNamedItem() | 可返回指定的节点（通过名称） | 5 | 1 | 9 | Yes
getNamedItemNS() | 可返回指定的节点（通过名称和命名空间） |  |  | 9 | Yes
item() | 可返回处于指定索引号的节点 | 5 | 1 | 9 | Yes
removeNamedItem() | 可删除指定的节点（根据名称） | 6 | 1 | 9 | Yes
removeNamedItemNS() | 可删除指定的节点（根据名称和命名空间） |  |  | 9 | Yes
setNamedItem() | 设置指定的节点（根据名称） |  |  | 9 | Yes
setNamedItemNS() | 设置指定的节点（通过名称和命名空间） |  |  | 9 | Yes
  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM - Node 对象

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM - Node 对象

  • Previous Page
  • Next Page

节点对象代表文档树中的一个节点。

Node 对象

Node 对象是整个 DOM 的主要数据类型。

节点对象代表文档树中的一个单独的节点。

节点可以是元素节点、属性节点、文本节点，或者也可以是“节点类型”那一节中所介绍的任何一种节点。

请注意，虽然所有的对象均能继承用于处理父节点和子节点的属性和方法，但是并不是所有的对象都拥有父节点或子节点。例如，文本节点不能拥有子节点，所以向类似的节点添加子节点就会导致 DOM 错误。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: 万维网联盟 (因特网标准)

Node 对象的属性

属性 | 描述 | IE | F | O | W3C
baseURI | 返回节点的绝对基准 URI。 | No | 1 | No | Yes
childNodes | 返回节点到子节点的节点列表。 | 5 | 1 | 9 | Yes
firstChild | 返回节点的首个子节点。 | 5 | 1 | 9 | Yes
lastChild | 返回节点的最后一个子节点。 | 5 | 1 | 9 | Yes
localName | 返回节点的本地名称。 | No | 1 | 9 | Yes
namespaceURI | 返回节点的命名空间 URI。 | No | 1 | 9 | Yes
nextSibling | 返回节点之后紧跟的同级节点。 | 5 | 1 | 9 | Yes
nodeName | 返回节点的名称，根据其类型。 | 5 | 1 | 9 | Yes
nodeType | 返回节点的类型。 | 5 | 1 | 9 | Yes
nodeValue | 设置或返回节点的值，根据其类型。 | 5 | 1 | 9 | Yes
ownerDocument | 返回节点的根元素（document 对象）。 | 5 | 1 | 9 | Yes
parentNode | 返回节点的父节点。 | 5 | 1 | 9 | Yes
prefix | 设置或返回节点的命名空间前缀。 | No | 1 | 9 | Yes
previousSibling | 返回节点之前紧跟的同级节点。 | 5 | 1 | 9 | Yes
textContent | 设置或返回节点及其后代的文本内容。 | No | 1 | No | Yes
text | 返回节点及其后代的文本（IE 独有的属性）。 | 5 | No | No | No
xml | 返回节点及其后代的 XML（IE 独有的属性）。 | 5 | No | No | No

Node 对象的方法

方法 | 描述 | IE | F | O | W3C
appendChild() | 向节点的子节点列表的结尾添加新的子节点。 | 5 | 1 | 9 | Yes
cloneNode() | 复制节点。 | 5 | 1 | 9 | Yes
compareDocumentPosition() | 对比两个节点的文档位置。 | No | 1 | No | Yes
getFeature(feature,version) | 返回一个 DOM 对象，此对象可执行带有指定特性和版本的专门的 API。 |  |  | No | Yes
getUserData(key) | 返回与此节点上的某个键相关联的对象。此对象必须首先通过使用相同的键来调用 setUserData 被设置到此节点。 |  |  | No | Yes
hasAttributes() | 判断当前节点是否拥有属性。 | No | 1 | 9 | Yes
hasChildNodes() | 判断当前节点是否拥有子节点。 | 5 | 1 | 9 | Yes
insertBefore() | 在指定的子节点前插入新的子节点。 | 5 | 1 | 9 | Yes
isDefaultNamespace(URI) | 返回指定的命名空间 URI 是否为默认。 |  |  | No | Yes
isEqualNode() | 检查两个节点是否相等。 | No | No | No | Yes
isSameNode() | 检查两个节点是否是相同的节点。 | No | 1 | No | Yes
isSupported() | 返回当前节点是否支持某个特性。 |  |  | 9 | Yes
lookupNamespaceURI() | 返回匹配指定前缀的命名空间 URI。 | No | 1 | No | Yes
lookupPrefix() | 返回匹配指定命名空间 URI 的前缀。 | No | 1 | No | Yes
normalize() | 合并相邻的Text节点并删除空的Text节点。 | 5 | 1 | 9 | Yes
removeChild() | 删除（并返回）当前节点的指定子节点。 | 5 | 1 | 9 | Yes
replaceChild() | 用新节点替换一个子节点。 | 5 | 1 | 9 | Yes
selectNodes() | 用一个 XPath 表达式查询选择节点。 | 6 |  |  |
selectSingleNode() | 查找和 XPath 查询匹配的一个节点。 | 6 |  |  |
transformNode() | 使用 XSLT 把一个节点转换为一个字符串。 | 6 |  |  |
transformNodeToObject() | 使用 XSLT 把一个节点转换为一个文档。 | 6 |  |  |
setUserData(key,data,handler) | 把对象关联到节点上的一个键上。 |  |  | No | Yes
  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM - NodeList 对象

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM - NodeList 对象

  • Previous Page
  • Next Page

NodeList 对象代表一个有顺序的节点列表。

NodeList 对象

我们可通过节点列表中的节点索引号来访问列表中的节点（索引号由0开始）。

节点列表可保持其自身的更新。如果节点列表或 XML 文档中的某个元素被删除或添加，列表也会被自动更新。

注释：在一个节点列表中，节点被返回的顺序与它们在 XML 被规定的顺序相同。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: 万维网联盟 (因特网标准)

NodeList 对象的属性

属性 | 描述 | IE | F | O | W3C
length | 可返回节点列表中的节点数目。 | 5 | 1 | 9 | Yes

NodeList 对象的方法

方法 | 描述 | IE | F | O | W3C
item() | 可返回节点列表中处于指定的索引号的节点。 | 5 | 1 | 9 | Yes
  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM - ProcessingInstruction 对象

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM - ProcessingInstruction 对象

  • Previous Page
  • Next Page

ProcessingInstruction 对象表示处理指令。

DocumentType 对象

ProcessingInstruction 对象可表示处理指令。

这个不常用的接口表示 XML 文档中的一个处理指令（或 PI）。使用 HTML 文档的程序设计者不会遇到 ProcessingInstruction 节点。

处理指令可作为在 XML 文档的文本中保留处理器定制信息的方法来使用。

IE: Internet Explorer, F: Firefox, O: Opera, W3C: 万维网联盟 (因特网标准)

ProcessingInstruction 对象的属性

属性 | 描述
data | 设置或返回此处理指令的内容。 （即从目标开始后的第一个非空格字符到结束字符“?>”之间的字符，但不包括“?>”）。
target | 返回此处理指令的目标。 它是“<?”后的第一个标识符，指定了处理指令的处理器。
  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM - Range 对象

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM - Range 对象

  • Previous Page
  • Next Page

Range 对象表示文档中的连续范围。

Range 对象

Range 对象表示文档的连续范围区域，如用户在浏览器窗口中用鼠标拖动选中的区域。

如果一个实现支持 Range 模块，那么 Document 对象就定义了 createRange() 方法，调用它可创建新的 Range 对象。

注意：IE 定义了不兼容的 Document.createRange() 方法，它返回的对象与 Rang 接口相似，但不兼容。

Range 接口为指定文档“选中”的区域定义了大量的方法，此外还有几个方法可以用于在选中的区域中进行剪切和粘贴类型的操作。

Range 接口的属性提供了获取范围的边界节点和偏移量的方法。它的方法提供了设置范围边界的方法。注意，范围的边界可以设置为 Document 或 DocumentFragment 对象中的节点。一旦定义了范围的边界点，就可以使用 deleteContents()、extractContents()、cloneContents() 和 insertNode() 方法实现剪切、复制和粘贴的操作。

当通过插入或删除操作改变了文档时，表示文档一部分的所有 Range 对象都将改变（如果必要的话），以便使它们的边界点保持有效，并且让它们（尽可能接近地）表示同样的文档内容。

术语：范围、边界点和偏移量

一个范围具有两个边界点，即一个开始点和一个结束点。每个边界点由一个节点和那个节点的偏移量指定。该节点通常是 Element 节点、Document 节点或 Text 节点。对于 Element 节点和 Document 节点，偏移量指该节点的子节点。偏移量为 0，说明边界点位于该节点的第一个子节点之前。偏移量为 1，说明边界点位于该节点的第一个子节点之后，第二个子节点之前。但如果边界节点是 Text 节点，偏移量则指的是文本中两个字符之间的位置。

Range 对象的常量

这些常量指定了如何比较 Range 对象的边界点。

它们是 compareBoundaryPoints() 方法的 how 参数的合法值：

常量 | 描述
START_TO_START | 用指定范围的开始点与当前范围的开始点进行比较。
START_TO_END | 用指定范围的开始点与当前范围的结束点进行比较。
END_TO_END | 用指定范围的结束点与当前范围的结束点进行比较。
END_TO_START | 用指定范围的结束点与当前范围的开始点进行比较。

Range 对象的属性

注意：所有属性都是只读的，不能通过设置这些属性改变范围的开始点和结束点，必须调用 setEnd() 方法和 setStart() 方法实现这一点。

注意：调用 detach() 方法后，对这些属性的任何读操作都会抛出代码为 INVALID_STATE_ERR 的 DOMException 异常。

属性 | 描述
collapsed | 如果范围的开始点和结束点在文档的同一位置，则为 true，即范围是空的，或折叠的。
commonAncestorContainer | 范围的开始点和结束点的（即它们的祖先节点）、嵌套最深的 Document 节点。
endContainer | 包含范围的结束点的 Document 节点。
endOffset | endContainer 中的结束点位置。
startContainer | 包含范围的开始点的 Document 节点。
endOffset | startContainer 中的开始点位置。

Range 对象的方法

注意：如果调用了范围的 detach() 方法，那么接下来调用 Range 对象的任何方法都会抛出代码为 INVALID_STATE_ERR 的 DOMException 异常。

方法 | 描述
cloneContents() | 返回新的 DocumentFragment 对象，它包含该范围表示的文档区域的副本。
cloneRange() | 创建一个新的 Range 对象，表示与当前的 Range 对象相同的文档区域。
collapse() | 折叠该范围，使它的边界点重合。
compareBoundaryPoints() | 比较指定范围的边界点和当前范围的边界点，根据它们的顺序返回 -1、0 和 1。比较哪个边界点由它的第一个参数指定，它的值必须是前面定义的常量之一。
deleteContents() | 删除当前 Range 对象表示的文档区域。
detach() | 通知实现不再使用当前的范围，可以停止跟踪。如果调用了范围的这个方法，那么接下来调用的该范围任何方法都会抛出代码为 INVALID_STATE_ERR 的 DOMException 异常。
extractContents() | 删除当前范围表示的文档区域，并且以 DocumentFragment 对象的形式返回那个区域的内容。该方法和 cloneContents() 方法与 deleteContents() 方法的组合很相似。
insertNode() | 把指定的节点插入文档范围的开始点。
selectNode() | 设置该范围的边界点，使它包含指定的节点和它的所有子孙节点。
selectNodeContents() | 设置该范围的边界点，使它包含指定节点的子孙节点，但不包含指定的节点本身。
setEnd() | 把该范围的结束点设置为指定的节点和偏移量。
setEndAfter() | 把该范围的结束点设置为紧邻指定节点的节点之后。
setEndBefore() | 把该范围的结束点设置为紧邻指定节点之前。
setStart() | 把该范围的开始点设置为指定的节点中的指定偏移量。
setStartAfter() | 把该范围的开始点设置为紧邻指定节点的节点之后。
setStartBefore() | 把该范围的开始点设置为紧邻指定节点之前。
surroundContents() | 把指定的节点插入文档范围的开始点，然后重定范围中的所有节点的父节点，使它们成为新插入的节点的子孙节点。
toString() | 返回该范围表示的文档区域的纯文本内容。
  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM - Text 对象

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM - Text 对象

  • Previous Page
  • Next Page

Text 对象表示元素或属性的文本内容。

Text 对象

Text 节点表示 HTML 或 XML 文档中的一系列纯文本。因为纯文本出现在 HTML 和 XML 的元素和属性中，所以 Text 节点通常作为 Element 节点和 Attr 节点的子节点出现。

Text 节点继承了 CharacterData 接口，通过从 CharacterData 接口继承的 data 属性或从 Node 接口继承的 nadevalue 属性，可以访问 Text 节点的文本内容。

用从 CharacterData 继承的方法或 Text 接口自身定义的 splitText() 方法可以操作 Text 节点。使用 document.createTextNode() 来创建一个新的 Text 节点。

Text 节点没有子节点。

关于从文档的子树中删除空 Text 节点与合并相邻的 Text 节点的方法，请参阅 "Node.normalize()" 参考页。

Text 对象的属性

属性 | 描述 | IE | F | O | W3C
data | 设置或返回元素或属性的文本 | 6 | 1 | 9 | Yes
isElementContentWhitespace | 判断文本节点是否包含空白字符内容。 | No | No | No | Yes
length | 返回元素或属性的文本长度 | 6 | 1 | 9 | Yes
wholeText | 以文档中的顺序向此节点返回相邻文本节点的所有文本 | No | No | No | Yes

Text 对象的方法

方法 | 描述 | IE | F | O | W3C
appendData() | 向节点追加数据 | 6 | 1 | 9 | Yes
deleteData() | 从节点删除数据 | 6 | 1 | 9 | Yes
insertData() | 向节点中插入数据 | 6 | 1 | 9 | Yes
replaceData() | 替换节点中的数据 | 6 | 1 | 9 | Yes
replaceWholeText() | 使用指定文本来替换此节点以及所有相邻的文本节点 | No | No | No | Yes
splitText() | 把一个 Text 节点分割成两个。 | 6 | 1 | 9 | Yes
substringData() | 从节点提取数据 | 6 | 1 | 9 | Yes
  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM - XMLHttpRequest 对象

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM - XMLHttpRequest 对象

  • Previous Page
  • Next Page

XMLHttpRequest 对象

XMLHttpRequest 对象提供了对 HTTP 协议的完全的访问，包括做出 POST 和 HEAD 请求以及普通的 GET 请求的能力。XMLHttpRequest 可以同步或异步地返回 Web 服务器的响应，并且能够以文本或者一个 DOM 文档的形式返回内容。

尽管名为 XMLHttpRequest，它并不限于和 XML 文档一起使用：它可以接收任何形式的文本文档。

XMLHttpRequest 对象是名为 AJAX 的 Web 应用程序架构的一项关键功能。

浏览器支持

XMLHttpRequest 得到了所有现代浏览器较好的支持。唯一的浏览器依赖性涉及 XMLHttpRequest 对象的创建。在 IE 5 和 IE 6 中，必须使用特定于 IE 的 ActiveXObject() 构造函数。正如在 XMLHttpRequest 对象 这一节所介绍的。

W3C 标准化

XMLHttpRequest 对象还没有标准化，但是 W3C 已经开始了标准化的工作，本手册介绍的内容都是基于标准化的工作草案。

当前的 XMLHttpRequest 实现已经相当一致。但是和标准有细微的不同。例如，一个实现可能返回 null，而标准要求是空字符串，或者实现可能把 readyState 设置为 3 而不保证所有的响应头部都可用。

属性

readyState

HTTP 请求的状态.当一个 XMLHttpRequest 初次创建时，这个属性的值从 0 开始，直到接收到完整的 HTTP 响应，这个值增加到 4。

5 个状态中每一个都有一个相关联的非正式的名称，下表列出了状态、名称和含义：

状态 | 名称 | 描述
0 | Uninitialized | 初始化状态。XMLHttpRequest 对象已创建或已被 abort() 方法重置。
1 | Open | open() 方法已调用，但是 send() 方法未调用。请求还没有被发送。
2 | Sent | Send() 方法已调用，HTTP 请求已发送到 Web 服务器。未接收到响应。
3 | Receiving | 所有响应头部都已经接收到。响应体开始接收但未完成。
4 | Loaded | HTTP 响应已经完全接收。

readyState 的值不会递减，除非当一个请求在处理过程中的时候调用了 abort() 或 open() 方法。每次这个属性的值增加的时候，都会触发 onreadystatechange 事件句柄。

responseText

目前为止为服务器接收到的响应体（不包括头部），或者如果还没有接收到数据的话，就是空字符串。

如果 readyState 小于 3，这个属性就是一个空字符串。当 readyState 为 3，这个属性返回目前已经接收的响应部分。如果 readyState 为 4，这个属性保存了完整的响应体。

如果响应包含了为响应体指定字符编码的头部，就使用该编码。否则，假定使用 Unicode UTF-8。

responseXML

对请求的响应，解析为 XML 并作为 Document 对象返回。

status

由服务器返回的 HTTP 状态代码，如 200 表示成功，而 404 表示 "Not Found" 错误。当 readyState 小于 3 的时候读取这一属性会导致一个异常。

statusText

这个属性用名称而不是数字指定了请求的 HTTP 的状态代码。也就是说，当状态为 200 的时候它是 "OK"，当状态为 404 的时候它是 "Not Found"。和 status 属性一样，当 readyState 小于 3 的时候读取这一属性会导致一个异常。

事件句柄

onreadystatechange

每次 readyState 属性改变的时候调用的事件句柄函数。当 readyState 为 3 时，它也可能调用多次。

方法

abort()

取消当前响应，关闭连接并且结束任何未决的网络活动。

这个方法把 XMLHttpRequest 对象重置为 readyState 为 0 的状态，并且取消所有未决的网络活动。例如，如果请求用了太长时间，而且响应不再必要的时候，可以调用这个方法。

getAllResponseHeaders()

把 HTTP 响应头部作为未解析的字符串返回。

如果 readyState 小于 3，这个方法返回 null。否则，它返回服务器发送的所有 HTTP 响应的头部。头部作为单个的字符串返回，一行一个头部。每行用换行符 "\r\n" 隔开。

getResponseHeader()

返回指定的 HTTP 响应头部的值。其参数是要返回的 HTTP 响应头部的名称。可以使用任何大小写来制定这个头部名字，和响应头部的比较是不区分大小写的。

该方法的返回值是指定的 HTTP 响应头部的值，如果没有接收到这个头部或者 readyState 小于 3 则为空字符串。如果接收到多个有指定名称的头部，这个头部的值被连接起来并返回，使用逗号和空格分隔开各个头部的值。

open()

初始化 HTTP 请求参数，例如 URL 和 HTTP 方法，但是并不发送请求。

send()

发送 HTTP 请求，使用传递给 open() 方法的参数，以及传递给该方法的可选请求体。

setRequestHeader()

向一个打开但未发送的请求设置或添加一个 HTTP 请求。

XMLHttpRequest.open()

初始化 HTTP 请求参数

语法

open(method, url, async, username, password)

method 参数是用于请求的 HTTP 方法。值包括 GET、POST 和 HEAD。

url 参数是请求的主体。大多数浏览器实施了一个同源安全策略，并且要求这个 URL 与包含脚本的文本具有相同的主机名和端口。

async 参数指示请求使用应该异步地执行。如果这个参数是 false，请求是同步的，后续对 send() 的调用将阻塞，直到响应完全接收。如果这个参数是 true 或省略，请求是异步的，且通常需要一个 onreadystatechange 事件句柄。

username 和 password 参数是可选的，为 url 所需的授权提供认证资格。如果指定了，它们会覆盖 url 自己指定的任何资格。

说明

这个方法初始化请求参数以供 send() 方法稍后使用。它把 readyState 设置为 1，删除之前指定的所有请求头部，以及之前接收的所有响应头部，并且把 responseText、responseXML、status 以及 statusText 参数设置为它们的默认值。当 readyState 为 0 的时候（当 XMLHttpRequest 对象刚创建或者 abort() 方法调用后）以及当 readyState 为 4 时（已经接收响应时），调用这个方法是安全的。当针对任何其他状态调用的时候，open() 方法的行为是为指定的。

除了保存供 send() 方法使用的请求参数，以及重置 XMLHttpRequest 对象以便复用，open() 方法没有其他的行为。要特别注意，当这个方法调用的时候，实现通常不会打开一个到 Web 服务器的网络连接。

XMLHttpRequest.send()

发送一个 HTTP 请求

语法

send(body)

如果通过调用 open() 指定的 HTTP 方法是 POST 或 PUT，body 参数指定了请求体，作为一个字符串或者 Document 对象。如果请求体不适必须的话，这个参数就为 null。对于任何其他方法，这个参数是不可用的，应该为 null（有些实现不允许省略该参数）。

说明

这个方法导致一个 HTTP 请求发送。如果之前没有调用 open()，或者更具体地说，如果 readyState 不是 1，send() 抛出一个异常。否则，它发送一个 HTTP 请求，该请求由以下几部分组成：

  • 之前调用 open() 时指定的 HTTP 方法、URL 以及认证资格（如果有的话）。
  • 之前调用 setRequestHeader() 时指定的请求头部（如果有的话）。
  • 传递给这个方法的 body 参数。

一旦请求发布了，send() 把 readyState 设置为 2，并触发 onreadystatechange 事件句柄。

如果之前调用的 open() 参数 async 为 false，这个方法会阻塞并不会返回，直到 readyState 为 4 并且服务器的响应被完全接收。否则，如果 async 参数为 true，或者这个参数省略了，send() 立即返回，并且正如后面所介绍的，服务器响应将在一个后台线程中处理。

如果服务器响应带有一个 HTTP 重定向，send() 方法或后台线程自动遵从重定向。当所有的 HTTP 响应头部已经接收，send() 或后台线程把 readyState 设置为 3 并触发 onreadystatechange 事件句柄。如果响应较长，send() 或后台线程可能在状态 3 中触发 onreadystatechange 事件句柄：这可以作为一个下载进度指示器。最后，当响应完成，send() 或后台线程把 readyState 设置为 4，并最后一次触发事件句柄。

XMLHttpRequest.setRequestHeader()

语法

setRequestHeader(name, value)

name 参数是要设置的头部的名称。这个参数不应该包括空白、冒号或换行。

value 参数是头部的值。这个参数不应该包括换行。

说明

setRequestHeader() 方法指定了一个 HTTP 请求的头部，它应该包含在通过后续 send() 调用而发布的请求中。这个方法只有当 readyState 为 1 的时候才能调用，例如，在调用了 open() 之后，但在调用 send() 之前。

如果带有指定名称的头部已经被指定了，这个头部的新值就是：之前指定的值，加上逗号、空白以及这个调用指定的值。

如果 open() 调用指定了认证资格，XMLHttpRequest 自动发送一个适当的 Authorization 请求头部。但是，你可以使用 setRequestHeader() 来来添加这个头部。类似地，如果 Web 服务器已经保存了和传递给 open() 的 URL 相关联的 cookie，适当的 Cookie 或 Cookie2 头部也自动地包含到请求中。可以通过调用 setRequestHeader() 来把这些 cookie 添加到头部。XMLHttpRequest 也可以为 User-Agent 头部提供一个默认值。如果它这么做，你为该头部指定的任何值都会添加到这个默认值后面。

有些请求头部由 XMLHttpRequest 自动设置而不是由这个方法设置，以符合 HTTP 协议。这包括如下和代理相关的头部：

  • Host
  • Connection
  • Keep-Alive
  • Accept-charset
  • Accept-Encoding
  • If-Modified-Since
  • If-None-Match
  • If-Range
  • Range
  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM - XMLSerializer 对象

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM - XMLSerializer 对象

  • Previous Page
  • Next Page

序列化 XML 文档和节点。

XMLSerializer 对象

构造函数

new XMLSerializer()

说明

XMLSerializer 对象使你能够把一个 XML 文档或 Node 对象转化或“序列化”为未解析的 XML 标记的一个字符串。

要使用一个 XMLSerializer，使用不带参数的构造函数实例化它，然后调用其 serializeToString() 方法：

var text = (new XMLSerializer()).serializeToString(element)

IE 不支持 XMLSerializer 对象。相反，它通过 Node 对象的 xml 属性使 XML 文本变为可用。

参阅：Node.xml

XMLSerializer.serializeToString()

把一个 XML 文档或节点转换为一个字符串

语法

serializeToString(node)

node 参数是要序列化的 XML 节点。这可能是文档中一个 Document 对象或者任何 Element。

返回值

XML 标记的一个字符串，代表了指定节点及其所有子孙的序列化形式。

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM - XPathExpression 对象

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM - XPathExpression 对象

  • Previous Page
  • Next Page

一个编译过的 XPath 查询。

XPathExpression 对象是一个 XPath 查询的编译过的表现形式，由 Document.createExpression() 返回。使用 evaluate() 方法根据一个特定的文档节点来计算该表达式。如果你需要仅计算一个 XPath 查询一次，可以使用 Document.evaluate()，它在一个步骤里编译并计算表达式。

IE 不支持 XPathExpression 对象。

请参阅：Node.selectNodes() 和 Node.selectSingleNode()，了解特定于 IE 的 XPath 方法。

XPathExpression.evaluate()

计算一个编译过的 XPath 查询。

语法

evaluate(contextNode,type,result)

contextNode 参数计算查询应该依据的节点（或文档）。

type 参数是期待的结果类型。这个参数应该是 XPathResult 定义的一个常量。

result 参数是一个 XPathResult 对象，查询结果存储于其中。如果要让 evaluate() 方法创建并返回一个新的 XPathResult 对象，则为 null。

返回值

保存查询结果的一个 XPathResult。要么是作为 result 参数传递的对象，或者是 result 为 null 而新创建的一个 XPathResult 对象。

说明

这个方法根据指定的节点或文档来计算 XPathExpression，并把结果返回到一个 XPathResult 对象。

参阅 XPathResult，了解如何从返回对象中提取值。

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM - XPathResult 对象

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM - XPathResult 对象

  • Previous Page
  • Next Page

XPath 查询的结果。

XPathResult 对象

XPathResult 对象表示一个 XPath 表达式的值。该类型的对象由 Document.evaluate() 和 XPathExpression.evaluate() 返回。XPath 查询可以计算为字符串、数字、布尔值、节点以及节点的列表。XPath 实现可以以几种不同的方式返回节点的列表，因此，这个对象为获取一个 XPath 查询的实际结果而定义了略为复杂的 API。

要使用一个 XPathResult，首先检查 resultType 属性。它将保存一个 XPathResult 常量。这个属性的值告诉你需要使用哪个属性和方法来确定结果值。调用不是为当前的 resultType 定义的方法或者读取不是为它定义的属性会导致异常。

IE 不支持 XPathResult API。要在 IE 中执行 XPath 查询，参阅 Node.selectNodes() 和 Node.selectSingleNode() 。

XPathResult 对象的常量

如下常量定义了一个 XPath 查询可能返回的类型。XPathResult 对象的 resultType 属性保存了这些值中的一个，用来指定对象保存何种结果。这些常量与 Document.evaluate() 和 XPathExpression.evaluate() 一起使用，用来指定期待的结果类型。

这些常量及其含义如下：

ANY_TYPE

把这个值传递给 Document.evaluate() 或 XPathExpression.evaluate() 来指定可接受的结果类型。属性 resultType 并不设置这个值。

NUMBER_TYPE

numbervalue 保存结果。

STRING_TYPE

stringvalue 保存结果。

BOOLEAN_TYPE

booleanValue 保存结果。

UNORDERED_NODE_ITERATOR_TYPE

这个结果是节点的无序集合，可以通过重复调用 iterateNext() 直到返回 null 来依次访问。在此迭代过程中，文档必须不被修改。

ORDERED_NODE_ITERATOR_TYPE

结果是节点的列表，按照文档中的属性排列，可以通过重复调用 iterateNext() 直到返回 null 来依次访问。在此迭代过程中，文档必须不被修改。

UNORDERED_NODE_SNAPSHOT_TYPE

结果是一个随机访问的节点列表。snapshotLength 属性指定了列表的长度，并且 snapshotItem() 方法返回指定下标的节点。节点可能和它们出现在文档中的顺序不一样。既然这种结果是一个“快照”，因此即便文档发生变化，它也有效。

ORDERED_NODE_SNAPSHOT_TYPE

这个结果是一个随机访问的节点列表，就像 UNORDERED_NODE_SNAPSHOT_TYPE，只不过这个列表是按照文档中的顺序排列的。

ANY_UNORDERED_NODE_TYPE

singleNodeValue 属性引用和查询匹配的一个节点，如果没有匹配的节点则为 null。如果有多个节点和查询匹配，singleNodeValue 可能是任何一个匹配节点。

FIRST_ORDERED_NODE_TYPE

singleNodeValue 保存了文档中的第一个和查询匹配的节点，如果没有匹配的节点，则为 null。

XPathResult 对象的实例属性

这里的很多属性只有当 resultType 保存了一个特定的值时才有效。访问并非为当前 resultType 定义的属性会导致异常。

booleanValue

当 resultType 为 BOOLEAN_TYPE 时，保存结果值。

invalidIteratorState

如果 resultType 是 ITERATOR_TYPE 常量中的一个并且文档已经修改，则为 true；它使迭代无效，因为结果已经返回。

numberValue

当 resultType 为 NUMBER_TYPE 时，保存结果值。

resultType

使用 XPath 查询返回何种结果。它的值是前面列出等常量之一。这个属性的值告诉你可以使用那些其他属性和方法。

singleNodeValue

当 resultType 为 XPathResult.ANY_UNORDERED_NODE_TYPE 或 XPathResult.FIRST_UNORDERED_NODE_TYPE 时，保存结果值。

snapshotLength

当 resultType 为 UNORDERED_NODE_SNAPSHOT_TYPE 或 ORDERED_NODE_ITERATOR_TYPE 时，指定返回的节点数。和 snapshotItem() 联合使用这一属性。

stringValue

当 resultType 为 STRING_TYPE 时，保存结果值。

XPathResult 对象的方法

方法 | 描述
iterateNext() | 如果 resultType 是 UNORDERED_NODE_ITERATOR_TYPE 或 ORDERED_NODE_ITERATOR_TYPE，使用这个一方法。
snapshotItem() | 返回结果节点列表中指定下标的节点。这个方法只有在 resultType 是 UNORDERED_NODE_SNAPSHOT_TYPE 或 ORDERED_NODE_SNAPSHOT_TYPE 的时候才能使用。snapshotLength 属性和这个方法一起使用。

参阅

Document.evaluate() 和 XPathExpression.evaluate()

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM - XSLTProcessor 对象

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM - XSLTProcessor 对象

  • Previous Page
  • Next Page

XSLTProcessor 用 XSLT 来转换 XML。

XSLTProcessor 对象

XSLTProcessor 使用 XSLT 样式表来转换 XML 文档。

通过 importStylesheet() 方法用一个样式表来初始化它。
如果你的样式表使用参数，可以用 setParameter() 来设置这些参数。
最后，使用 transformToDocument() 或 transformToFragment() 来执行实际的转换。

IE 支持 XSLT 但没有实现 XSLTProcessor 对象。

参阅特定于 IE 的 Node 对象的 transformNode() 和 transformNodeToObject() 方法。

XSLTProcessor 对象的方法

方法 | 描述 | IE | F | O | W3C
clearParameters() | 删除之前的任何设置参数。 | No | 1 | 9 | Yes
getParameter() | 返回指定的参数的值。 | No | 1 | 9 | Yes
importStylesheet() | 指定要使用的 XSLT 样式表。 | No | 1 | 9 | Yes
removeParameter() | 删除指定的参数。 | No | 1 | 9 | Yes
reset() | 把 XSLTProcessor 恢复为默认状态。 | No | 1 | 9 | Yes
setParameter() | 设置样式表参数。 | No | 1 | 9 | Yes
transformToDocument() | 把节点或文档转换为新的文档。 | No | 1 | 9 | Yes
transformToFragment() | 把节点或文档转换为 DocumentFragment。 | No | 1 | 9 | Yes
  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM - 属性和方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM - 属性和方法

  • Previous Page
  • Next Page

属性和方法向 XML DOM 定义了编程接口。

实例

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

函数 loadXMLString()，位于外部 JavaScript 中，用于加载 XML 字符串。

加载并解析 XML 文件
加载并解析 XML 字符串

编程接口

DOM 把 XML 模拟为一系列节点接口。可通过 JavaScript 或其他编程语言来访问节点。在本教程中，我们使用 JavaScript。

对 DOM 的编程接口是通过一套标准的属性和方法来定义的。

属性经常按照“某事物是什么”的方式来使用（例如节点名是 "book"）。

方法经常按照“对某事物做什么”的方式来使用（例如删除 "book" 节点）。

XML DOM 属性

一些典型的 DOM 属性：

  • x.nodeName - x 的名称
  • x.nodeValue - x 的值
  • x.parentNode - x 的父节点
  • x.childNodes - x 的子节点
  • x.attributes - x 的属性节点

注释：在上面的列表中，x 是一个节点对象。

XML DOM 方法

  • x.getElementsByTagName(name) - 获取带有指定标签名称的所有元素
  • x.appendChild(node) - 向 x 插入子节点
  • x.removeChild(node) - 从 x 删除子节点

注释：在上面的列表中，x 是一个节点对象。

实例

从 books.xml 中的 <title> 元素获取文本的 JavaScript 代码：

txt=xmlDoc.getElementsByTagName("title")[0].childNodes[0].nodeValue

在此语句执行后，txt 保存的值是 "Everyday Italian"。

解释：

  • xmlDoc - 由解析器创建的 XML DOM
  • getElementsByTagName("title")[0] - 第一个 <title> 元素
  • childNodes[0] - <title> 元素的第一个子节点 (文本节点)
  • nodeValue - 节点的值 (文本自身)

在上面的例子中，getElementsByTagName 是方法，而 childNodes 和 nodeValue 是属性。

解析 XML 文件 - 跨浏览器实例

下面的代码片段使用 loadXMLDoc 函数把 books.xml 载入 XML 解析器中，并显示第一个 book 的数据：

xmlDoc=loadXMLDoc("books.xml");

document.write(xmlDoc.getElementsByTagName("title")
[0].childNodes[0].nodeValue);
document.write("<br />");
document.write(xmlDoc.getElementsByTagName("author")
[0].childNodes[0].nodeValue);
document.write("<br />");
document.write(xmlDoc.getElementsByTagName("year")
[0].childNodes[0].nodeValue);

输出：

Harry Potter
J K. Rowling
2005

TIY

在上面的例子中，我们为每个文本节点使用 childNodes[0]，即使每个元素只有一个文本节点。这是由于 getElementsByTagName() 方法总是会返回数组。

解析 XML 字符串 - 跨浏览器实例

下面的代码加载并解析一个 XML 字符串：

下面的代码片段使用 loadXMLString 函数把 books.xml 载入 XML 解析器，并显示第一个 book 的数据：

text="<bookstore>"
text=text+"<book>";
text=text+"<title>Harry Potter</title>";
text=text+"<author>J K. Rowling</author>";
text=text+"<year>2005</year>";
text=text+"</book>";
text=text+"</bookstore>";

xmlDoc=loadXMLString(text);

document.write(xmlDoc.getElementsByTagName("title")
[0].childNodes[0].nodeValue);
document.write("<br />");
document.write(xmlDoc.getElementsByTagName("author")
[0].childNodes[0].nodeValue);
document.write("<br />");
document.write(xmlDoc.getElementsByTagName("year")
[0].childNodes[0].nodeValue);

输出：

Harry Potter
J K. Rowling
2005

TIY

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM appendChild() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM appendChild() 方法

返回 Element 对象参考手册

定义和用法

appendChild() 方法在指定元素节点的最后一个子节点之后添加节点。

该方法返回新的子节点。

语法：

appendChild(node)
参数 | 描述
node | 必需。要追加的节点。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段创建并向第一个 <book> 元素追加了一个节点，然后输出第一个 <book> 元素的的所有子节点：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName('book');
var newel,newtext;

for (i=0;i<x.length;i++)
{
newel=xmlDoc.createElement('edition');
newtext=xmlDoc.createTextNode('First');
newel.appendChild(newtext);
x[i].appendChild(newel);
}

//Output all titles and editions
y=xmlDoc.getElementsByTagName("title");
z=xmlDoc.getElementsByTagName("edition");
for (i=0;i<y.length;i++)
{
document.write(y[i].childNodes[0].nodeValue);
document.write(" - Edition: ");
document.write(z[i].childNodes[0].nodeValue);
document.write("<br />");
}

以上代码的输出：

Everyday Italian - Edition: First
Harry Potter - Edition: First
XQuery Kick Start - Edition: First
Learning XML - Edition: First

注释：Internet Explorer 会忽略节点之间生成的空白文本节点（比如换行字符），而 Mozilla 不这么做。因此，在上面的例子中，我们仅仅处理元素节点（元素节点的 nodeType 等于 1）。

如需更多有关 IE 与 Mozilla 浏览器差异的内容，请访问 W3School 的 XML DOM 教程中的 DOM 浏览器 这一节。

TIY

appendChild() - 向第一个 <book> 节点追加子节点
appendChild() - 向所有 <book> 节点追加子节点

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM appendChild() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM appendChild() 方法

返回 Node 对象参考手册

定义和用法

appendChild() 方法可向节点的子节点列表的末尾添加新的子节点。

此方法可返回这个新的子节点。

语法：

appendChild(newchild)
参数 | 描述
newchild | 所添加的节点

返回值

加入的节点。

描述

该方法将把节点 newchild 添加到文档中，使它成为当前节点的最后一个子节点。

如果文档树中已经存在了 newchild，它将从文档树中删除，然后重新插入它的新位置。如果 newchild 是 DocumentFragment 节点，则不会直接插入它，而是把它的子节点按序插入当前节点的 childNodes[] 数组的末尾。

注意，来自一个文档的节点（或由一个文档创建的节点）不能插入另一个文档。也就是说，newchild 的 ownerDocument 属性必须与当前节点的 ownerDocument 属性相同。

例子

下面的函数将在文档末尾插入一个新段：

function appendMessage (message) {
  var pElement = document.createElement("p");
  var messageNode = document.createTextNode(message);
  pElement.appendChild(messageNode);
  document.body.appendChild(pElement);
}

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可创建并向首个 <book> 元素添加一个节点，然后输出首个 <book> 元素的所有子节点：

xmlDoc=loadXMLDoc("books.xml");

var newel=xmlDoc.createElement('edition');
var newtext=xmlDoc.createTextNode('First');
newel.appendChild(newtext);

var x=xmlDoc.getElementsByTagName('book')[0];
x.appendChild(newel);

var y=x.childNodes;
for (var i=0;i<y.length;i++)
  {
  //Display only element nodes
  if (y[i].nodeType==1)
    {
    document.write(y[i].nodeName);
    document.write("<br />");
    }
  }

输出：

title
author
year
price
edition

注释：Internet Explorer 会忽略节点间生成的空白文本节点（例如，换行符号），而 Mozilla 不会这样做。因此，在下面的例子中，我们仅处理元素节点（元素节点的 nodeType=1）。

提示：如需更多有关 IE 与 Mozilla 浏览器之间 XML DOM 的差异的内容，请访问我们的 DOM 浏览器 章节。

TIY

appendChild() - 向首个 <book> 节点添加子节点
appendChild() - 向所有 <book> 节点添加一个子节点

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM appendData() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM appendData() 方法

返回 Comment 对象参考手册

定义和用法

appendData() 方法把指定文本添加到注释节点所包含文本的末端。

语法：

commentNode.appedData(string)
参数 | 描述
string | 要附加到 comment 节点的字符串。

描述

该方法把字符串 string 附加到节点的 data 属性的末尾。

实例

以下代码段使用 JavaScript 函数 loadXMLDoc() 把 XML 文件 books_comment.xml 载入 xmlDoc 中，并把文本附加到第一个 comment 节点：

xmlDoc=loadXMLDoc("books_comment.xml");

x=xmlDoc.getElementsByTagName("book")[0].childNodes;

for (i=0;i<x.length;i++)
{
if (x[i].nodeType==8)
  {
  //仅仅处理 comment 节点
  x[i].appendData(" Special Offer");
  document.write(x[i].data);
  document.write("<br />");
  }
}

以上代码的输出：

(Book 6) (Hardcover) Special Offer

在本例中，我们使用一段循环和 if 语句来执行只针对 comment 节点的处理。comment 节点的节点类型是 8。

TIY

appendData() - 把字符串附加到注释节点

返回 Comment 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM appendData() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM appendData() 方法

返回 Text 对象参考手册

定义和用法

appendData() 方法在文本节点的末尾添加一个字符串。

语法：

textNode.appendData(string)
参数 | 描述
string | 必需。向文本节点添加的字符串。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段向 "books.xml" 中的第一个 <title> 元素追加文本：

xmlDoc=loadXMLDoc("books.xml");
x=xmlDoc.getElementsByTagName("title")[0].childNodes[0];

x.appendData(" Cooking");
document.write(x.data);

输出：

Everyday Italian Cooking

TIY

appendData() - 向文本节点追加文本

返回 Text 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM async 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM async 属性

返回 Document 对象参考手册

定义和用法

async 属性可规定 XML 文件的下载是否应当被同步处理。

True 意味着 load() 方法可在下载完成之前向调用程序返回控制权。

False 意味着在调用程序取回控制权之前必须完成下载。

语法：

documentObject.async

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

function loadXMLDoc(dname)
{
var xmlDoc;
// code for IE
if (window.ActiveXObject)
  {
  xmlDoc=new ActiveXObject("Microsoft.XMLDOM");
  }
// code for Mozilla, Firefox, Opera, etc.
else if (document.implementation && document.implementation.createDocument)
  {
  xmlDoc=document.implementation.createDocument("","",null);
  }
else
  {
  alert('Your browser cannot handle this script');
  }

xmlDoc.async=false;
xmlDoc.load(dname);
return(xmlDoc);
}

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM attributes 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM attributes 属性

返回 Element 对象参考手册

定义和用法

attributes 属性返回包含被选节点属性的 NamedNodeMap。

如果被选节点不是元素，则该属性返回 NULL。

语法：

elementNode.attributes

提示和注释

提示：该属性仅用于 element 节点。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

例子 1

下面的代码片段获取 "books.xml" 中第一个 <title> 元素的属性数目：

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName("book")[0].attributes;
document.write(x.length);

以上代码的输出：

1

例子 2

下面的代码片段输出第一个 <book> 元素中 "category" 属性的值：

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName("book")[0].attributes;
var att=x.getNamedItem("category");

document.write(att.value);

以上代码的输出：

COOKING

TIY

getNamedItem() 和 属性 - 获取项目的值
属性和长度 - 从元素中获取属性的数目

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM baseURI 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM baseURI 属性

返回 Attr 对象参考手册

定义和用法

baseURI 属性返回属性 (attribute) 的绝对基准 URI。

语法：

elementNode.baseURI

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的例子返回 "lang" 属性的基准 URI：

xmlDoc=loadXMLDoc("/example/xdom/books_ns.xml");

var x=xmlDoc.getElementsByTagName('title');

for(i=0;i<x.length;i++)
{
document.write(x.item(i).attributes[0].baseURI);
document.write("<br />");
}

以上代码的输出：

http://www.w3school.com.cn/example/xdom/books.xml
http://www.w3school.com.cn/example/xdom/books.xml
http://www.w3school.com.cn/example/xdom/books.xml
http://www.w3school.com.cn/example/xdom/books.xml

TIY

获取属性的基准 URI（IE 浏览器不支持）

返回 Attr 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM baseURI 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM baseURI 属性

返回 Element 对象参考手册

定义和用法

baseURI 属性返回 XML 文档的位置。

语法：

elementNode.baseURI

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段显示 XML 文档的位置：

xmlDoc=loadXMLDoc("books.xml");
x=xmlDoc.getElementsByTagName("book")[0];

document.write("Document location: " + x.baseURI);

以上代码的输出：

Document location: http://www.w3school.com.cn/dom/books.xml

TIY

baseURI - 获取 XML 文档的位置

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM baseURI 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM baseURI 属性

返回 Node 对象参考手册

定义和用法

baseURI 属性可返回某个节点的绝对基准 URI。

语法

nodeObject.baseURI

实例

在所有的例子中，我们将使用 XML 文件 books_ns.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可返回 <title> 的绝对基准 URI：

xmlDoc=loadXMLDoc("books_ns.xml");

var x=xmlDoc.getElementsByTagName('title');

for(i=0;i<x.length;i++)
  {
  document.write(x.item(i).baseURI);
  document.write("<br />");
  }

输出：

http://www.w3school.com.cn/dom/books_ns.xml
http://www.w3school.com.cn/dom/books_ns.xml

TIY

取得某个节点的前缀、本地名称、命名空间 URI、以及绝对基准 URI（IE 不支持）

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM bubbles 事件属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM bubbles 事件属性

返回 Event 对象参考手册

定义和用法

bubbles 事件属性返回一个布尔值，如果事件是起泡类型，则返回 true，否则返回 fasle。

语法

event.bubbles

事件传播

在 2 级 DOM 中，事件传播分为三个阶段：

第一，捕获阶段。事件从 Document 对象沿着文档树向下传递给目标节点。如果目标的任何一个先辈专门注册了捕获事件句柄，那么在事件传播过程中运行这些句柄。

第二个阶段发生在目标节点自身。直接注册砸目标上的适合的事件句柄将运行。这与 0 级事件模型提供的事件处理方法相似。

第三，起泡阶段。在此阶段，事件将从目标元素向上传播回或起泡回 Document 对象的文档层次。

实例

下面的例子可检测发生的事件是否是一个起泡事件：

<html>
<head>

<script type="text/javascript">
function getEventType(event)
  {
  alert(event.bubbles);
  }
</script>
</head>

<body onmousedown="getEventType(event)">

<p>Click somewhere in the document.
An alert box will tell if the event is a bubbling event.</p>

</body>
</html>

TIY

bubbling event
检测事件是否是起泡事件（IE 浏览器不支持）。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


XML DOM cancelable 事件属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM cancelable 事件属性

返回 Event 对象参考手册

定义和用法

cancelable 事件返回一个布尔值。如果用 preventDefault() 方法可以取消与事件关联的默认动作，则为 true，否则为 fasle。

语法

event.cancelable

实例

下面的例子讲检测发生的事件是否是一个 cancelable 事件：

<html>
<head>

<script type="text/javascript">
function isEventCancelable(event)
  {
  alert(event.cancelable);
  }
</script>
</head>

<body onmousedown="isEventCancelable(event)">

<p>Click somewhere in the document.
An alert box will tell if the
event is a cancelable event.</p>

</body>
</html>

TIY

cancelable event
检测事件是否是 cancelable 事件（IE 浏览器不支持）。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


XML DOM childNodes 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM childNodes 属性

返回 Document 对象参考手册

定义和用法

childNodes 属性可返回 document 的子节点的 NodeList。

语法：

documentObject.childNodes

提示和注释：

提示：请使用 NodeList 的长度属性来测定节点列表中的节点数目。在您已知晓节点列表的长度后，就能够轻易地循环遍历此节点，并提取您需要的值！

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可显示 XML 文档的子节点：

xmlDoc=loadXMLDoc("/example/xdom/books.xml");

var x=xmlDoc.childNodes;
for (i=0;i<x.length;i++)
  {
  document.write("Nodename: " + x[i].nodeName)
  document.write(" (nodetype: " + x[i].nodeType + ")<br />")
  }

IE 的输出：

Nodename: xml (nodetype: 7)
Nodename: #comment (nodetype: 8)
Nodename: #comment (nodetype: 8)
Nodename: bookstore (nodetype: 1)

Mozilla (Firefox) 的输出：

Nodename: #comment (nodetype: 8)
Nodename: #comment (nodetype: 8)
Nodename: bookstore (nodetype: 1)

TIY

显示 XML 文档的子节点
显示 XML 文档中所有元素的所有子节点

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM childNodes 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM childNodes 属性

返回 Element 对象参考手册

定义和用法

childNodes 属性返回包含被选节点的子节点的 NodeList。

如果选定的节点没有子节点，则该属性返回不包含节点的 NodeList。

语法：

elementNode.childNodes

提示和注释

提示：如需循环子节点列表，使用 nextSibling 属性，要比使用父对象的 childNodes 列表效率更高。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

例子 1

下面的代码片段输出 "books.xml" 中第一个 <title> 元素的文本节点：

xmlDoc=loadXMLDoc("books.xml");
var x=xmlDoc.getElementsByTagName("title")[0].childNodes[0];
document.write(x.nodeValue);

以上代码的输出：

Everyday Italian

例子 2

下面的代码片段输出 "books.xml" 中第一个 <book> 元素的子节点数量：

xmlDoc=loadXMLDoc("books.xml");
var x=xmlDoc.getElementsByTagName("book")[0].childNodes;
document.write(x.length);

在 Internet Explorer 中的输出：

4

在 Mozilla browsers 中的输出：

9

Internet Explorer 会忽略节点之间生成的空白文本节点（比如换行字符），而 Mozilla 不这么做。因此，在上面的例子中，输出是不同的。

如需更多有关 IE 与 Mozilla 浏览器差异的内容，请访问 W3School 的 XML DOM 教程中的 DOM 浏览器 这一节。

TIY

getelemenstByTagname() 和 childNodes - 获取元素的值
childNodes - 获取 NodeList 的长度

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM childNodes 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM childNodes 属性

返回 Node 对象参考手册

定义和用法

childNodes 属性可返回指定节点的子节点的节点列表。

语法：

nodeObject.childNodes

提示和注释

提示：请使用 length 属性来计算一个节点列表中节点的数目。当你已获悉节点列表的长度后，您就可以轻松地循环遍历此列表，并提取您所需要的值！

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段显示了此XML文档的子节点：

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.childNodes;

for (i=0;i<x.length;i++)
  {
  document.write("Nodename: " + x[i].nodeName)
  document.write(" (nodetype: " + x[i].nodeType + ")<br />")
  }

IE 的输出：

Nodename: xml (nodetype: 7)
Nodename: #comment (nodetype: 8)
Nodename: bookstore (nodetype: 1)

Mozilla (Firefox)的输出：

Nodename: #comment (nodetype: 8)
Nodename: bookstore (nodetype: 1)

TIY

显示 XML 文档的子节点
显示 XML 文档中所有元素的所有子节点

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM clearParameters() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM clearParameters() 方法

返回 XSLTProcessor 对象参考手册

定义和用法

clearParameters() 方法删除所有样式表参数值。

语法：

clearParameters()

描述

这个方法删除 setParameter() 已经指定的所有参数值。如果不带参数集来执行转换，那么样式表会使用指定的默认值。

返回 XSLTProcessor 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM cloneContents() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM cloneContents() 方法

返回 Range 对象参考手册

定义和用法

cloneContents() 方法把范围（Range）的内容复制到一个 DocumentFragment 对象。

语法：

extractContents()

返回值

一个 DocumentFragment 节点，包含该范围中的文档内容的副本。

抛出

如果当前范围包括 DocumentType 节点，该方法将抛出代码为 HIERARCHY_REQUEST_ERR 的 DOMException 异常。

描述

该方法将复制当前范围的内容，把它存放在一个 DocumentFragment 对象中，返回该对象。

返回 Range 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM cloneNode() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM cloneNode() 方法

返回 Element 对象参考手册

定义和用法

cloneNode() 方法创建指定节点的精确拷贝。

此方法返回被克隆的节点。

语法：

cloneNode(include_all)
参数 | 描述
include_all | 必需。如果这个布尔参数设置为 true，被克隆的节点会复制原始节点的所有子节点。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段复制第一个 <book> 节点，然后把此备份添加到节点列表的末尾：

xmlDoc=loadXMLDoc("books.xml");

oldNode=xmlDoc.getElementsByTagName('book')[0];
newNode=oldNode.cloneNode(true);
xmlDoc.documentElement.appendChild(newNode);

//Output all titles
y=xmlDoc.getElementsByTagName("title");
for (i=0;i<y.length;i++)
{
document.write(y[i].childNodes[0].nodeValue);
document.write("<br />");
}

以上代码的输出：

Everyday Italian
Harry Potter
XQuery Kick Start
Learning XML
Everyday Italian

TIY

cloneNode() - 复制并追加节点

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM cloneNode() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM cloneNode() 方法

返回 Node 对象参考手册

定义和用法

cloneNode() 方法可创建指定的节点的精确拷贝。

此方法可返回所复制的节点。

语法：

nodeObject.cloneNode(include_all)
参数 | 描述
include_all | 必需。假如逻辑参数被设置为真，那么被克隆的节点会克隆原节点的所有子节点。

返回值

当前节点的副本。

说明

该方法将复制并返回调用它的节点的副本。如果传递给它的参数是 true，它还将递归复制当前节点的所有子孙节点。否则，它只复制当前节点。

返回的节点不属于文档树，它的 parentNode 属性为 null。

当复制的是 Element 节点时，它的所有属性都将被复制。但要注意，当前节点上注册的事件监听器函数不会被复制。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可克隆首个 <book> 节点，然后把它添加到节点列表的末尾：

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName('book')[0];
var cloneNode=x.cloneNode(true);
xmlDoc.documentElement.appendChild(cloneNode);

//Output all titles
var y=xmlDoc.getElementsByTagName("title");
for (i=0;i<y.length;i++)
  {
  document.write(y[i].childNodes[0].nodeValue);
  document.write("<br />");
  }

输出：

Everyday Italian
Harry Potter
XQuery Kick Start
Learning XML
Everyday Italian

TIY

cloneNode() - 克隆节点

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM cloneRange() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM cloneRange() 方法

返回 Range 对象参考手册

定义和用法

cloneRange() 方法复制该范围。

语法：

cloneRange()

返回值

返回新创建的 Range 对象。

参阅

Document.createRange()

返回 Range 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM collapse() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM collapse() 方法

返回 Range 对象参考手册

定义和用法

collapse() 方法是范围的边界点重合。

语法：

collapse(toStart)

参数

如果把参数 toStart 设置为 true，该方法将把范围的结束点设置为与开始点相同的值。否则，它将把范围的开始点设置为与结束点相同的值。

描述

该方法将设置范围的一个边界点，使它与另一个边界点相同。要修改的边界点由参数 toStart 指定。该方法返回后，范围将“折叠”，即表示文档中的一个点，没有内容。当范围被折叠后，它的 collapsed 属性将被设置为 true。

返回 Range 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM compareDocumentPosition() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM compareDocumentPosition() 方法

返回 Element 对象参考手册

定义和用法

compareDocumentPosition() 方法按照文档顺序，比较当前节点与指定节点的文档位置。

该方法返回新的子节点。

语法：

elementNode.compareDocumentPostition(node)
参数 | 描述
node | 必需。规定与当前节点比较的节点。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段比较 "books.xml" 中第一个与第三个 <book> 节点：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName('book')[0];
y=xmlDoc.getElementsByTagName('book')[2];

document.write(x.compareDocumentPosition(y));

以上代码的输出：

4

注释：Internet Explorer 会忽略节点之间生成的空白文本节点（比如换行字符），而 Mozilla 不这么做。因此，在上面的例子中，Mozilla 输出 4，而 Internet Explorer 输出 2。

如需更多有关 IE 与 Mozilla 浏览器差异的内容，请访问 W3School 的 XML DOM 教程中的 DOM 浏览器 这一节。

TIY

compareDocumentPosition() - 比较两个节点的文档位置

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM compareDocumentPosition() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM compareDocumentPosition() 方法

返回 Node 对象参考手册

定义和用法

compareDocumentPosition() 方法可根据文档顺序使用指定的节点比较当前节点的文档位置。

语法：

nodeObject.compareDocumentPostition(node)
参数 | 描述
node | 必选。规定与当前节点进行比较的节点。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可比较第一个 book 元素与第三个 book 元素的文档位置：

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName('book')[0];
var y=xmlDoc.getElementsByTagName('book')[2];

document.write(x.compareDocumentPosition(y));

输出：

4

注释：Internet Explorer 会忽略节点间生成的空白文本节点（例如，换行符号），而 Mozilla 不会这样做。因此，在上面的例子中，Mozilla 浏览器会输出 4，而 Internet Explorer 会输出 2。

提示：如需更多有关 IE 与 Mozilla 浏览器之间 XML DOM 的差异的内容，请访问我们的 DOM 浏览器 章节。

TIY

compareDocumentPosition() - 比较两个节点的文档位置

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM createAttribute() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM createAttribute() 方法

返回 Document 对象参考手册

定义和用法

创建新的 Attr 节点。

语法：

createAttribute(name)
参数 | 描述
name | 新创建的属性的名称。

抛出

如果 name 参数中含有不合法的字符，该方法将抛出代码为 INVALID_CHARACTER_ERR 的 DOMException 异常。

参阅

Element.setAttribute() 、 Element.setAttributeNode()

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM createAttributeNS() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM createAttributeNS() 方法

返回 Document 对象参考手册

定义和用法

创建具有指定的名称和命名空间的 Attr 节点。

语法：

createAttributeNS(uri,name)
参数 | 描述
uri | Attr 的命名空间的唯一标识符。如果没有命名空间。则为 null。
name | 属性的限定名，应包括命名空间前缀、冒号和本地名。

返回值

返回新创建的 Attr 节点，具有指定的名称和命名空间。

说明

createAttributeNS() 方法与 createAttribute() 方法相似，只是它创建的 Attr 节点除了具有指定的名称外，还具有指定的命名空间。只有使用命名空间的 XML 文档才会使用该方法。

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM createCDATASection() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM createCDATASection() 方法

返回 Document 对象参考手册

定义和用法

createCDATASection() 方法可创建 CDATASection 节点。

此方法可返回 CDATASection 对象。

语法：

createCDATASection(data)
参数 | 描述
data | 字符串值，这个字符串可为此节点规定数据。

返回值

返回新创建的 CDATASection 节点，内容为指定的 data。

抛出

如果该文档是 HTML 文档，该方法将抛出代码为 NOT_SUPPORTED_ERR 的 DOMException 异常，因为 HTML 文档不支持 CDATASection 节点。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可向 <book> 元素添加一个 CDATA 区段节点：

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName('book');
var newCDATA,newtext;

newtext="Special Offer & Book Sale";

for (i=0;i<x.length;i++)
  {
  newCDATA=xmlDoc.createCDATASection(newtext);
  x[i].appendChild(newCDATA);
  }

TIY

createCDATASection() - 创建一个 CDATASection 节点

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM createComment() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM createComment() 方法

返回 Document 对象参考手册

定义和用法

createComment() 方法可创建注释节点。

此方法可返回一个 Comment 对象。

语法：

createComment(data)
参数 | 描述
data | 字符串值，这个字符串可为此节点规定数据。

返回值

返回新创建的 Comment 节点，文本为指定的 data。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可向 <book> 元素添加注释节点：

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName('book');
var newComment,newtext;
newtext="Revised September 2006";

for (i=0;i<x.length;i++)
  {
  newComment=xmlDoc.createComment(newtext);
  x[i].appendChild(newComment);
  }

TIY

createComment() - 创建注释节点

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM createDocument() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM createDocument() 方法

返回 DomImplementation 对象参考手册

定义和用法

createDocument() 方法创建一个新 Document 对象和指定的根元素。

语法：

nodeObject.createDocument(namespaceURI,qualifiedName,doctype)
参数 | 描述
namespaceURI | 为文档创建的根元素的命名空间的唯一标识符。 如果没有命名空间，则为 null。
qualifiedName | 为文档创建的根元素的名称。 如果 namespaceURI 不为 null，该名称应该包括命名空间前缀和冒号。
doctype | 新创建的 Document 对象的 DocumentType 对象。 如果没有想得到的 DocumentType 对象，则为 null。

返回值

一个带有 documentElement 属性的 Document 对象，设置为指定类型的 Element 根节点。

说明

该方法创建一个新的 Document 对象，并为文档指定它的根对象 documentElement。如果参数 doctype 不是 null，那么 DocumentType 对象的 ownerDocument 属性将被设置为新创建的文档。

该方法用于创建 XML 文档，只支持 HTML 的实现可能不支持它。

参阅

DomImplementation.createDocumentType()

返回 DomImplementation 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM createDocumentType() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM createDocumentType() 方法

返回 DomImplementation 对象参考手册

定义和用法

createDocumentType() 方法创建一个 DocumentType 节点。

语法：

nodeObject.createDocument(qualifiedName, publicId, systemId)
参数 | 描述
qualifiedName | 文档类型的名字。 如果使用 XML 命名空间，该参数可能是一个限定名，用来指定命名空间前缀和本地名，两者之间用冒号分隔。
publicId | 文档类型的公有标识符或 null。
systemId | 文档类型的系统标识符或 null。 该参数通常声明了 DTD 文件的本地文件名。

返回值

新创建的 DocumentType 对象，ownerdocument 属性为 null。

说明

该方法创建一个新的 DocumentType 节点。该方法只声明文档类型的一个外部子集。从 2 级 DOM 起，DOM 标准就不再提供声明内部子集的方法，返回的 DocumentType 对象不定义任何 Entity 节点和 Notation 节点。该方法只和 XML 文档一起使用，只支持 HTML 文档的实现不支持该方法。

返回 DomImplementation 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM createElement() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM createElement() 方法

返回 Document 对象参考手册

定义和用法

createElement() 方法可创建元素节点。

此方法可返回一个 Element 对象。

语法：

createElement(name)
参数 | 描述
name | 字符串值，这个字符串可为此元素节点规定名称。

返回值

新创建的 Element 节点，具有指定的标签名。

抛出

如果 name 参数中含有不合法的字符，该方法将抛出代码为 INVALID_CHARACTER_ERR 的 DOMException 异常。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可将一个带有文本节点的元素节点添加到每个 <book> 元素：

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName('book');
var newel,newtext

for (i=0;i<x.length;i++)
  {
  newel=xmlDoc.createElement('edition');
  newtext=xmlDoc.createTextNode('First');
  newel.appendChild(newtext);
  x[i].appendChild(newel);
  }

TIY

createElement() 和 createTextNode() - 创建元素节点和文本节点

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM createElementNS() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM createElementNS() 方法

返回 Document 对象参考手册

定义和用法

createElementNS() 方法可创建带有指定命名空间的元素节点。

此方法可返回一个 Element 对象。

语法：

createElementNS(ns,name)
参数 | 描述
ns | 字符串值，可为此元素节点规定命名空间的名称。
name | 字符串值，可为此元素节点规定其名称。

说明

createElementNS() 方法与 createElement() 方法相似，只是它创建的 Element 节点除了具有指定的名称外，还具有指定的命名空间。只有使用命名空间的 XML 文档才会使用该方法。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可将带有指定命名空间的元素节点添加到每个 <book>：

mlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName('book');
var newel,newtext;

for (i=0;i<x.length;i++)
  {
  newel=xmlDoc.createElementNS('p','edition');
  newtext=xmlDoc.createTextNode('First');
  newel.appendChild(newtext);
  x[i].appendChild(newel);
  }

TIY

createElementNS() - 创建带有命名空间的元素节点

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM createEvent() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM createEvent() 方法

返回 Document 对象参考手册

定义和用法

createEvent() 方法创建新的 Event 对象。

语法：

createEvent(eventType)
参数 | 描述
eventType | 想获取的 Event 对象的事件模块名。 关于有效的事件类型列表，请参阅“说明”部分。

返回值

返回新创建的 Event 对象，具有指定的类型。

抛出

如果实现支持需要的事件类型，该方法将抛出代码为 NOT_SUPPORTED_ERR 的 DOMException 异常。

说明

该方法将创建一种新的事件类型，该类型由参数 eventType 指定。注意，该参数的值不是要创建的事件接口的名称，而是定义那个接口的 DOM 模块的名称。

下表列出了 eventType 的合法值和每个值创建的事件接口：

参数 | 事件接口 | 初始化方法
HTMLEvents | HTMLEvent | iniEvent()
MouseEvents | MouseEvent | iniMouseEvent()
UIEvents | UIEvent | iniUIEvent()

用该方法创建了 Event 对象以后，必须用上表中所示的初始化方法初始化对象。关于初始化方法的详细信息，请参阅 Event 对象参考。

该方法实际上不是由 Document 接口定义的，而是由 DocumentEvent 接口定义的。如果一个实现支持 Event 模块，那么 Document 对象就会实现 DocumentEvent 接口并支持该方法。

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM createExpression() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM createExpression() 方法

返回 Document 对象参考手册

定义和用法

createExpression() 方法创建一个 XPath 表达式以供稍后计算。

语法：

createExpression(xpathText,namespaceURLMapper)
参数 | 描述
xpathText | 表示要编译的 XPath 表达式的字符串。
namespaceURLMapper | 从一个名字空间前缀映射到一个全称名字空间 URL 的一个函数。如果不需要这样的映射，则为 null。

返回值

一个 XPathExpression 对象。

抛出

如果 xpathText 包含一个语法错误，或者它使用了 namespaceURLMapper 无法解析的一个名字空间前缀，这个方法会抛出一个异常。

说明

这个方法接受表示 XPath 表达式的一个字符串，并将其转换为一个编译过的表达式，即一个 XPathExpression。除了这个表达式，该方法还接受一个形如 function(prefix) 的函数，该函数解析一个名字空间前缀字符串，并返回一个全称名字空间 URL 字符串。

IE 不支持这个 API。参阅 Node.selectNodes() 了解一种特定于 IE 的替代方法。

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM createProcessingInstruction() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM createProcessingInstruction() 方法

返回 Document 对象参考手册

定义和用法

createProcessingInstruction() 方法创建 ProcessingInstruction 节点。

语法：

createProcessingInstruction(target,data)
参数 | 描述
target | 处理指令的目标。
data | 处理指令的内容文本。

返回值

新创建的 ProcessingInstruction 节点。

抛出

如果 target 中含有不合法的字符，则抛出代码为 INVALID_CHARACTER_ERR 的 DOMException 异常。

如果是一个 HTML 文档，不支持处理指令，将抛出代码为 NOT_SUPPORTED_ERR 的 DOMException 异常。

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM createRange() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM createRange() 方法

返回 Document 对象参考手册

定义和用法

createRange() 方法创建 Range 对象。

语法：

createRange()

返回值

返回新创建的 Range 对象，两个边界点都被设置为文档的开头。

描述

该方法将创建一个 Range 对象，可以用来表示文档的一个区域或与该文档相关的 DocumentFragment 对象。

注意，该方法实际上不是由 Document 接口定义的，而是由 DocumentRange 接口定义的。如果一个实现支持 Range 模块，那么 Document 对象就会实现 DocumentRange 接口，并定义该方法。IE 6 不支持这个模块。

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM createTextNode() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM createTextNode() 方法

返回 Document 对象参考手册

定义和用法

reateTextNode() 可创建一个文本节点。

此方法可返回 Text 对象。

语法：

createTextNode(data)
参数 | 描述
data | 字符串值，可规定此节点的文本。

返回值

返回新创建的 Text 节点，表示指定的 data 字符串。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可向每个 <book> 元素添加一个带有文本节点的元素节点：

xmlDoc=loadXMLDoc("/example/xdom/books.xml");

var x=xmlDoc.getElementsByTagName('book');
var newel,newtext

for (i=0;i<x.length;i++)
  {
  newel=xmlDoc.createElement('edition');
  newtext=xmlDoc.createTextNode('First');
  newel.appendChild(newtext);
  x[i].appendChild(newel);
  }

TIY

createElement() 和 createTextNode() - 创建元素节点和文本节点

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM currentTarget 事件属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM currentTarget 事件属性

返回 Event 对象参考手册

定义和用法

currentTarget 事件属性返回其监听器触发事件的节点，即当前处理该事件的元素、文档或窗口。

在捕获和起泡阶段，该属性是非常有用的，因为在这两个节点，它不同于 target 属性。

语法

event.currentTarget

实例

下面的例子可获得哪个元素的监听器触发了事件：

<html>
<head>

<script type="text/javascript">
function getEventTrigger(event)
  {
  x=event.currentTarget;
  alert("The id of the triggered element: "
  + x.id);
  }
</script>
</head>

<body >

<p id="p1" onmousedown="getEventTrigger(event)">
Click on this paragraph. An alert box will
show which element triggered the event.</p>

</body>
</html>

TIY

currenttarget event
获得其监听器触发了事件的那个元素。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


XML DOM data 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM data 属性

返回 Comment 对象参考手册

定义和用法

data 属性返回注释的文本内容。

语法：

commentNode.data

实例

以下代码段使用 JavaScript 函数 loadXMLDoc() 把 XML 文件 books_comment.xml 载入 xmlDoc 中，并输出第一个 <book> 元素的注释文本内容：

xmlDoc=loadXMLDoc("books_comment.xml");

x=xmlDoc.getElementsByTagName("book")[0].childNodes;

for (i=0;i<x.length;i++)
{
if (x[i].nodeType==8)
  {
  //Process only comment nodes
  document.write(x[i].data);
  document.write("<br />");
  }
}

以上代码的输出：

(Book 6) (Hardcover)

在本例中，我们使用一段循环和 if 语句来执行只针对 comment 节点的处理。comment 节点的节点类型是 8。

TIY

data 属性 - 获取注释节点的数据

返回 Comment 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM data 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM data 属性

返回 Text 对象参考手册

定义和用法

data 属性设置或返回元素或属性的文本。

语法：

textNode.data

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段输出 "books.xml" 中的第一个 <title> 元素的文本：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("title")[0].childNodes[0];

document.write(x.data);

输出：

Everyday Italian

TIY

data - 获取文本节点的数据

返回 Text 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM deleteData() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM deleteData() 方法

返回 Comment 对象参考手册

定义和用法

deleteData() 方法从注释节点删除数据。

语法：

commentNode.deleteData(start,length)
参数 | 描述
start | 必需。要删除的第一个字符的位置。
length | 必需。要删除的字符的数量。

描述

该方法从 start 指定的字符开始，从 Comment 节点中删除 length 个字符。如果 start 加 length 大于 Comment 节点中的字符数，那么删除从 start 开始到字符串结尾的所有字符。

实例

以下代码段使用 JavaScript 函数 loadXMLDoc() 把 XML 文件 books_comment.xml 载入 xmlDoc 中，然后从第一个注释节点中删除一些字符：

xmlDoc=loadXMLDoc("books_comment.xml");

x=xmlDoc.getElementsByTagName("book")[0].childNodes;

for (i=0;i<x.length;i++)
{
if (x[i].nodeType==8)
  {
  //仅仅处理 comment 节点
  x[i].deleteData(0,9);
  document.write(x[i].data);
  document.write("<br />");
  }
}

以上代码的输出：

(Hardcover)

在本例中，我们使用一段循环和 if 语句来执行只针对 comment 节点的处理。comment 节点的节点类型是 8。

TIY

deleteData() - 从注释节点中删除字符

返回 Comment 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM deleteData() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM deleteData() 方法

返回 Text 对象参考手册

定义和用法

deleteData() 方法从文本节点删除数据。

语法：

deleteData(start,length)
参数 | 描述
start | 必需。规定从何处开始删除数据。开始值以 0 开始
length | 必需。规定删除多少个字符。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段从 "books.xml" 中的第一个 <title> 元素的文本节点删除一些字符：

xmlDoc=loadXMLDoc("books.xml");
x=xmlDoc.getElementsByTagName("title")[0].childNodes[0];

x.deleteData(0,9);
document.write(x.data);

输出：

Italian

TIY

deleteData() - 从文本节点删除文本

返回 Text 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM dispatchEvent() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM dispatchEvent() 方法

返回 Element 对象参考手册

定义和用法

dispatchEvent() 方法给节点分派一个合成事件。

语法：

dispatchEvent(evt)
参数 | 描述
evt | 必需。要分派的 Event 对象。

返回值

如果在事件传播过程中调用了 evt 的 preventDefault() 方法，则返回 false，否则返回 true。

抛出

如果 Event 对象 evt 没有被初始化，或者它的 type 属性为 null 或空串，该方法将抛出异常。

描述

该方法将分派一个合成事件，它由 Document.createEvent() 创建，由 Event 接口或它的某个子接口定义的初始化方法初始化。

调用该方法的节点将成为事件的目标节点，该事件在捕捉阶段中第一次沿着文档树向下传播。如果该事件的 bubbles 属性为 true，那么在事件的目标节点自身处理事件后，它将沿着文档树向上起泡。

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM doctype 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM doctype 属性

返回 Document 对象参考手册

定义和用法

doctype 属性可返回与文档相关的文档类型声明（Document Type Declaration）。

对于没有 DTD 的 XML 文档，则返回 null。

此属性可提供对 DocumentType 对象（Document 的一个子节点）的直接访问。

语法：

documentObject.doctype

实例

在所有的例子中，我们将使用 XML 文件 note_internal_dtd.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可返回一个 DocumentType 对象：

xmlDoc=loadXMLDoc("note_internal_dtd.xml");
document.write(xmlDoc.doctype);

输出：

[object DocumentType]

TIY

取得与 XML 文档相关联的 DOCTYPE 的名称

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM documentElement 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM documentElement 属性

返回 Document 对象参考手册

定义和用法

documentElement 属性可返回文档的根节点。

语法：

documentObject.documentElement

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可显示 XML 文档的位置：

xmlDoc=loadXMLDoc("/example/xdom/books.xml");

var x=xmlDoc.documentElement;

document.write("Nodename: " + x.nodeName + "<br />");
document.write("Nodevalue: " + x.nodeValue + "<br />");
document.write("Nodetype: " + x.nodeType);

输出：

Nodename: bookstore
Nodevalue: null
Nodetype: 1

TIY

取得 XML 文档的根元素

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM documentURI 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM documentURI 属性

返回 Document 对象参考手册

定义和用法

documentURI 属性可设置或返回文档的位置。

语法：

documentObject.documentURI

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可显示 XML 文档的位置：

xmlDoc=loadXMLDoc("/example/xdom/books.xml");
document.write("Document location: " + xmlDoc.documentURI);

输出：

Document location: http://www.w3school.com.cn/example/xdom/books.xml

TIY

取得文档的位置

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM entities 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM entities 属性

返回 DocumentType 对象参考手册

定义和用法

entities 属性可返回包含有在 DTD 中所声明的外部实体和内部实体的 NamedNodeMap。

语法：

documentObject.doctype.entities

实例

在所有的例子中，我们将使用 XML 文件 note_internal_dtd.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可显示在 DTD 中声明过的实体的节点名称和节点类型：

xmlDoc=loadXMLDoc("note_internal_dtd.xml");

var x=xmlDoc.doctype.entities

for (i=0;i<x.length;i++)
  {
  document.write("Nodename: " + x.item(i).nodeName);
  document.write("<br />")
  document.write("Nodetype: " + x.item(i).nodeType);
  document.write("<br />")
  }

输出：

Nodename: writer
Nodetype: 6
Nodename: copyright
Nodetype: 6

TIY

取得在 XML 文档的 DTD 中声明过的实体

返回 DocumentType 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM evaluate() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM evaluate() 方法

返回 Document 对象参考手册

定义和用法

evaluate() 方法计算一个 XPath 表达式。

语法：

evaluate(xpathText,contextNode,namespaceURLMapper,resultType,result)
参数 | 描述
xpathText | 表示要计算的 XPath 表达式的字符串。
contextNode | 文档中，对应要计算的表达式的节点。
namespaceURLMapper | 把一个命名空间前缀映射为一个全称命名空间 URL 的函数。 如果不需要这样的映射，就为 null。
resultType | 指定了期待作为结果的对象的类型，使用 XPath 转换来强制结果类型。 类型的可能的值是 XPathResult 对象所定义的常量。
result | 一个复用的 XPathResult 对象； 如果你要创建一个新的 XPathResult 对象，则为 null。

返回值

表示根据给定的 Context 节点计算的表达式的一个 XPathResult 对象。

抛出

如果 xpathText 包含语法错误，或者如果表达式的结果无法转换为想要的 resultType，或者如果表达式包含了 namespaceURLMapper 无法解析的命名空间，或者如果 contextNode 具有错误的类型或它和这个文档不相关，该方法都会抛出一个异常。

描述

该方法根据给定的 Context 节点来计算指定的 XPath 表达式，并且返回一个 XPathResult 对象，该对象是 type 来确定结果类型应该是什么。如果你想多次计算一个表达式，使用 Document.createExpression() 来把表达式编译成一个 XPathExpression 对象，然后使用 XPathExpression 的 evaluate() 方法。

IE 不支持这个 API。参阅 Node.selectNodes() 和 Node.selectSingleNode() 来了解一个特定于 IE 的替代方法。

参阅

  • Document.createExpression()
  • Node.selectNodes()
  • Node.selectSingleNode()
  • XPathExpression
  • XPathResult

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM eventPhase 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM eventPhase 属性

返回 Event 对象参考手册

定义和用法

eventPhase 属性返回事件传播的当前阶段。它的值是下面的三个常量之一，它们分别表示捕获阶段、正常事件派发和起泡阶段。

eventPhase 常量

常量 | 值
Event.CAPTURING_PHASE | 1
Event.AT_TARGET | 2
Event.BUBBLING_PHASE | 3

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


XML DOM extractContents() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM extractContents() 方法

返回 Range 对象参考手册

定义和用法

extractContents() 方法删除文档内容，并以 DocumentFragment 对象的形式返回它。

语法：

extractContents()

返回值

一个 DocumentFragment 节点，包含该范围的内容。

抛出

如果要提取的文档内容是只读的，该方法将抛出代码为 NO_MODIFICATION_ALLOWED_ERR 的 DOMException 异常。

如果当前范围包括 DocumentType 节点，该方法将抛出代码为 HIERARCHY_REQUEST_ERR 的 DOMException 异常。

描述

该方法将删除文档的指定范围，并返回包含被删除内容（或被删除的内容的副本）的 DocumentFragment 节点。当返回该方法时，范围将折叠，文档中可能出现相邻的 Text 节点（用 Node.normalize() 可以合并）。

返回 Range 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM firstChild 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM firstChild 属性

返回 Document 对象参考手册

定义和用法

firstChild 属性可返回文档的首个子节点。

语法：

documentObject.firstChild

提示和注释

注释：Internet Explorer 会忽略节点间生成的空白文本节点（例如，换行符号），而 Mozilla 不会这样做。因此，在下面的例子中，我们会使用一个函数来检查第一个子节点的节点类型。

元素节点的节点类型是 1，因此如果首个子节点不是一个元素节点，它就会移至下一个节点，然后继续检查此节点是否为元素节点。整个过程会一直持续到首个元素子节点被找到为止。通过这个方法，我们就可以在 Internet Explorer 和 Mozilla 得到正确的结果。

提示：如需更多有关 IE 与 Mozilla 浏览器之间 XML DOM 的差异的内容，请访问我们的 DOM 浏览器 章节。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可显示文档首个子节点的节点名称和节点类型：

//检查第一个节点是否是 element 节点
function get_firstchild(n)
{
var x=n.firstChild;
while (x.nodeType!=1)
{
x=x.nextSibling;
}
return x;
}

xmlDoc=loadXMLDoc("/example/xdom/books.xml");

var x=get_firstchild(xmlDoc);
document.write("Nodename: " + x.nodeName);
document.write(" (nodetype: " + x.nodeType + ")");

输出：

Nodename: bookstore (nodetype: 1)

TIY

取得文档的第一个子节点
取得文档的最后一个子节点

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM firstChild 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM firstChild 属性

返回 Element 对象参考手册

定义和用法

firstChild 属性返回被选节点的第一个子节点。

如果选定的节点没有子节点，则该属性返回 NULL。

语法：

elementNode.firstChild

提示和注释

注释：Internet Explorer 会忽略节点之间生成的空白文本节点（比如换行字符），而 Mozilla 不这么做。因此，在下面的例子中，我们用一个函数来检测第一个子节点的节点类型。

元素节点的节点类型是 1，因此假如第一个子节点不是元素节点，则移动到下一个节点，并检测该节点是否是元素节点。这个过程一直持续到找到第一个子节点为止。这种方法可以确保在 Internet Explorer 和 Mozilla 都获得正确的结果。

如需更多有关 IE 与 Mozilla 浏览器差异的内容，请访问 W3School 的 XML DOM 教程中的 DOM 浏览器 这一节。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段从 "books.xml" 中获取第一个子节点：

//check if the first node is an element node
function get_firstchild(n)
{
var x=n.firstChild;
while (x.nodeType!=1)
  {
  x=x.nextSibling;
  }
return x;
}

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.documentElement;
var firstNode=get_firstchild(x);

for (var i=0;i<firstNode.childNodes.length;i++)
{
  if (firstNode.childNodes[i].nodeType==1)
  {
  //Process only element nodes
  document.write(firstNode.childNodes[i].nodeName);
  document.write(" = ");
  document.write(firstNode.childNodes[i].childNodes[0].nodeValue);
  document.write("<br />");
  }
}

以上代码的输出：

title = Everyday Italian
author = Giada De Laurentiis
year = 2005
price = 30.00

TIY

firstChild - 获取 XML 文档中的第一个子节点

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM firstChild 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM firstChild 属性

返回 Node 对象参考手册

定义和用法

firstChild 属性可返回指定节点的首个子节点。

语法：

nodeObject.firstChild

提示和注释

注释：Internet Explorer 会忽略节点间生成的空白文本节点（例如，换行符号），而 Mozilla 不会这样做。因此，在下面的例子中，我们会使用一个函数来检查首个子节点的节点类型。

元素节点的节点类型是 1，因此如果首个子节点不是一个元素节点，它就会移至下一个节点，然后继续检查此节点是否为元素节点。整个过程会一直持续到首个元素子节点被找到为止。通过这个方法，我们就可以在 Internet Explorer 和 Mozilla 得到正确的结果。

提示：如需更多有关 IE 与 Mozilla 浏览器之间 XML DOM 的差异的内容，请访问我们的 DOM 浏览器 章节。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码可显示出文档的首个子节点的节点名称和节点类型：

//check if the first node is an element node
function get_firstchild(n)
{
var x=n.firstChild;
while (x.nodeType!=1)
{
x=x.nextSibling;
}
return x;
}

xmlDoc=loadXMLDoc("books.xml");

var x=get_firstchild(xmlDoc);
document.write("Nodename: " + x.nodeName);
document.write(" (nodetype: " + x.nodeType);

输出：

Nodename: bookstore (nodetype: 1)

TIY

取得文档的首个子节点
取得文档的最后一个子节点

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM getAttribute() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM getAttribute() 方法

返回 Element 对象参考手册

定义和用法

getAttribute() 方法通过名称获取属性的值。

语法：

elementNode.getAttribute(name)
参数 | 描述
name | 必需。规定从中取得属性值的属性。

提示和注释

对于使用名称空间的 XML 文档来说，需要使用 getAttributeNS() 方法。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段获取所有 <book> 元素中 "category" 属性的值：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName('book');

for (i=0;i<x.length;i++)
{
document.write(x[i].getAttribute('category'));
document.write("<br />");
}

以上代码的输出：

COOKING
CHILDREN
WEB
WEB

TIY

getAttribute() - 获取指定属性的值

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM getAttributeNode() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM getAttributeNode() 方法

返回 Element 对象参考手册

定义和用法

getAttributeNode() 方法从当前元素中通过名称获取属性节点。

语法：

elementNode.getAttributeNS(ns,name)
参数 | 描述
name | 必需。规定要获取的属性节点。

说明

该方法将返回一个 Attr 节点，表示指定的属性和值。请注意，通过从 Node 接口继承的 attributes 属性也可以获取该属性节点。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的例子从 "books.xml" 中的所有 <book> 元素获取 "category" 属性：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName('book');

for(i=0;i<x.length;i++)
{
attnode=x.item(i).getAttributeNode("category");
document.write(attnode.name);
document.write(" = ");
document.write(attnode.value);
document.write("<br />");
}

以上代码的输出：

category = COOKING
category = CHILDREN
category = WEB
category = WEB

TIY

getAttributeNode() - 获取拥有特定名称的所有属性节点

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM getAttributeNodeNS() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM getAttributeNodeNS() 方法

返回 Element 对象参考手册

定义和用法

getAttributeNS() 方法通过命名空间 URI 和名称来获取属性节点。

语法：

elementNode.getAttributeNodeNS(ns,name)
参数 | 描述
ns | 必需。唯一标识属性的命名空间的 URI。若没有命名空间，则该参数为 null。
name | 必需。声明该属性在命名空间中名称的标识符。

说明

该属性返回一个 Attr 节点，它的子孙表示制定属性的值。如果该元素没有这样的属性，则返回 null。

该方法与 getAttributeNode() 方法类似，只是属性名由命名空间 URI 和在这个命名空间中定义的本地名共同指定。只有使用命名空间的 XML 文档才使用该方法。

实例

在所有的例子中，我们将使用 XML 文件 books_ns.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段从 "books_ns.xml" 中的第一个 <title> 元素中获取 "lang" 属性的名称和值：

xmlDoc=loadXMLDoc("books_ns.xml");

x=xmlDoc.getElementsByTagName("title")[0];
ns="http://www.w3school.com.cn/children/";

y=x.getAttributeNodeNS(ns,"lang");

document.write(y.nodeName);
document.write(" = ");
document.write(y.nodeValue);

以上代码的输出：

c:lang = en

TIY

获取属性的值
此例使用 getAttributeNodeNS() 来获取 "books_ns.xml" 中 "lang" 属性的名称和值。

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM getAttributeNS() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM getAttributeNS() 方法

返回 Element 对象参考手册

定义和用法

getAttributeNS() 方法通过命名空间 URI 和名称来获取属性值。

语法：

elementNode.getAttributeNS(ns,name)
参数 | 描述
ns | 必需。规定从中获取属性值的命名空间 URI。
name | 必需。规定从中取得属性值的属性。

实例

在所有的例子中，我们将使用 XML 文件 books_ns.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段从 "books_ns.xml" 中的第一个 <title> 元素中获取 "lang" 属性的值：

xmlDoc=loadXMLDoc("books_ns.xml");

x=xmlDoc.getElementsByTagName("title")[0];
ns="http://www.w3school.com.cn/children/";

document.write(x.getAttributeNS(ns,"lang"));

以上代码的输出：

en

TIY

getAttributeNS() - 通过名称和命名空间来获取属性的值

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM getElementById() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM getElementById() 方法

返回 Document 对象参考手册

定义和用法

getElementById() 方法查找具有指定的唯一 ID 的元素。

语法：

getElementById(elementid)
参数 | 描述
elementid | 想获取的元素的 id 属性的值。

返回值

表示具有指定的 id 属性的文档元素的 Element 节点。如果没有找到这样的元素，则返回 null。

说明

该方法将检索 id 属性的值为 elementid 的元素节点，并返回它。如果没有找到这样的元素，则返回 null。id 属性的值在文档中是唯一的，如果该方法找到更多具有指定 elementid 的元素节点，它将随机返回一个这样的元素节点，或者返回 null。

这是一个重要的常用方法，因为它为获取表示指定的文档元素的 Element 对象提供了简便的方法。

注意：该方法的名称以 Id 结尾，不是 ID，不要拼错了。

在 HTML 文档中，该方法总是检索具有指定 id 的属性。可以使用 HTMLDocument.getElementByName() 方法，根据它们的 name 属性中的值来查找 HTML 元素。

在 XML 文档中，这个方法则是使用类型为 id 的任一属性来查找，而不管这个属性的名称是什么。如果 XML 属性的类型是未知的（比如 XML 解析器忽略了或不能定位文档的 DTD），该方法总是返回 null。在客户端 JavaScript 中，这个方法并不经常和 XML 文档一起使用。实际上，getElementById() 最初被定义为 HTMLDocument 接口的一个成员，但是在后来的 2 级 DOM 中移入到 Document 接口中。

参阅

Document.getElementsByTagName()

Element.getElementsByTagName()

HTMLDocument.getElementByName()

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM getElementsByTagName() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM getElementsByTagName() 方法

返回 Document 对象参考手册

定义和用法

getElementsByTagName() 方法可返回带有指定名称的所有元素的一个节点列表。

语法：

getElementsByTagName(name)
参数 | 描述
name | 字符串值，规定需检索的标签名。值 "*" 匹配所有的标签。

返回值

文档树中具有指定标记的 Element 节点的只读数组（从技术上讲，是 NodeList 对象）。返回的元素节点的顺序就是它们在源文档中出现的顺序。

说明

该方法将返回一个 NodeList 对象（可以作为只读数组处理），该对象存放文档中具有指定标签名的所有 Element 节点，它们存放的顺序就是在源文档中出现的顺序。NodeList 对象是“活”的，即如果在文档中添加或删除了指定标签名的元素，它的内容会自动进行必要的更新。

注意，Element 接口定义了一个同名的方法，该方法只检索文档的子树。另外，HTMLDocument 接口定义了 getElementsByName() 方法，基于 name 属性的值（而不是标签名）检索元素。

例子

可以用下列代码检索并遍历 HTML 文档中的所有 <h1> 标记：

var headings = document.getElementsByTagName("h1");

for (var i = 0; i < headings.length; i++)  {
  var h = headings[i];
}

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可显示 "books.xml" 中所有 <title> 元素的值：

xmlDoc=loadXMLDoc("/example/xdom/books.xml");

var x=xmlDoc.getElementsByTagName('title');
for (i=0;i<x.length;i++)
  {
  document.write(x[i].childNodes[0].nodeValue)
  document.write("<br />")
  }

输出：

Harry Potter
Everyday Italian
XQuery Kick Start
Learning XML

TIY

getElementsByTagName() - 取得指定节点的值

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM getElementsByTagName() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM getElementsByTagName() 方法

返回 Element 对象参考手册

定义和用法

getElementsByTagName() 方法返回拥有指定名称的所有元素的 NodeList。

语法：

getElementsByTagName(name)
参数 | 描述
name | 字符串值，规定要搜索的标签名。值 "*" 匹配所有的节点。

说明

该方法将遍历指定元素的子孙节点，返回一个 Element 节点的数组（实际上是 NodeList 对象），表示所有具有指定标签名的文档元素。元素在返回的数组中的顺序就是它们出现在文档源代码中的顺序。

注意，Document 接口也定义了 getElementsByTagName() 方法，它与该方法相似，但遍历整个文档，而不是遍历某个元素的子孙节点。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段显示 "books.xml" 中所有 <title> 元素的值：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName('title');
for (i=0;i<x.length;i++)
{
document.write(x[i].childNodes[0].nodeValue);
document.write("<br />");
}

以上代码的输出：

Everyday Italian
Harry Potter
XQuery Kick Start
Learning XML

TIY

getElementsByTagName() - 通过名称来获取指定元素的值

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM getElementsByTagNameNS() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM getElementsByTagNameNS() 方法

返回 Document 对象参考手册

定义和用法

getElementsByTagNameNS() 方法可返回带有指定名称和命名空间的所有元素的一个节点列表。

语法：

getElementsByTagNameNS(ns,name)
参数 | 描述
ns | 字符串值，可规定需检索的命名空间名称。值 "*" 可匹配所有的标签。
name | 字符串值，可规定需检索的标签名。值 "*" 可匹配所有的标签。

返回值

文档树中具有指定命名空间和本地名的 Element 节点的只读数组（从技术上讲，是 NodeList 对象）。

说明

该方法与 getElementsByTagName() 方法相似，只是它根据命名空间和名称来检索元素。只有使用命名空间的 XML 文档才会使用它。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可向每个 <book> 元素添加一个带有命名空间的元素节点：

xmlDoc=loadXMLDoc("/example/xdom/books.xml");

var x=xmlDoc.getElementsByTagName('book');
var newel,newtext;

for (i=0;i<x.length;i++)
  {
  newel=xmlDoc.createElementNS('p','edition');
  newtext=xmlDoc.createTextNode('First');
  newel.appendChild(newtext);
  x[i].appendChild(newel);
  }

//输出所有 title 和 edition
var y=xmlDoc.getElementsByTagName("title");
var z=xmlDoc.getElementsByTagNameNS("p","edition");

for (i=0;i<y.length;i++)
  {
  document.write(y[i].childNodes[0].nodeValue);
  document.write(" - ");
  document.write(z[i].childNodes[0].nodeValue);
  document.write(" edition");
  document.write("<br />");
  }

TIY

createElementNS() - 创建带有命名空间的元素节点（不支持 IE 浏览器）

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM getElementsByTagNameNS() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM getElementsByTagNameNS() 方法

返回 Element 对象参考手册

定义和用法

getElementsByTagNameNS() 方法返回带有指定名称和命名空间的所有元素的 NodeList。

语法：

elementNode.getElementsByTagNameNS(ns,name)
参数 | 描述
ns | 字符串值，规定要检索的命名空间。值 "*" 匹配所有标签。
name | 字符串值，规定要检索的标签名。值 "*" 匹配所有标签。

说明

该方法与 getElementsByTagName() 方法相似，只是想获取的元素的标记名被指定为命名空间 URI 和在命名空间中定义的本地名的组合。只有使用命名空间的 XML 文档才使用该方法。

实例

在所有的例子中，我们将使用 XML 文件 books_ns.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段通过标签名和命名空间获取元素：

xmlDoc=loadXMLDoc("books_ns.xml");

x=xmlDoc.getElementsByTagNameNS("http://www.w3school.com.cn/children/","title");
document.write(x[0].nodeName);

以上代码的输出：

c:title

TIY

getElementByTagNameNS() - 通过名称和命名空间检索元素

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM getNamedItem() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM getNamedItem() 方法

返回 NamedNodeMap 对象参考手册

定义和用法

getNamedItem() 方法可返回指定的节点。

语法：

getNamedItem(nodename)
参数 | 描述
nodename | 需检索的节点名称。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可循环遍历 <book> 元素，并输出 category 属性的值：

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName('book');

for(i=0;i<x.length;i++)
  {
  var att=x.item(i).attributes.getNamedItem("category");
  document.write(att.value + "<br />")
  }

输出：

COOKING
CHILDREN
WEB
WEB

TIY

getNamedItem() - 取得某个项目的值
getNamedItem() - 改变某个项目的值

返回 NamedNodeMap 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM getParameter() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM getParameter() 方法

返回 XSLTProcessor 对象参考手册

定义和用法

getParameter() 方法返回指定的参数的值。

语法：

getParameter(namespaceURI,localName)
参数 | 描述
namespaceURI | 参数的命名空间。
localName | 参数的名称。

返回值

参数的值，如果没有设置该参数，则为 null。

返回 XSLTProcessor 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM hasAttribute() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM hasAttribute() 方法

返回 Element 对象参考手册

定义和用法

如果当前元素节点拥有指定属性，则返回 true，否则返回 false。

语法：

hasAttribute(name)
参数 | 描述
name | 必需。规定要检索的属性。

说明

该方法判断一个元素是否具有指定的属性，但不返回那个属性的值。注意，如果这个文档中明确设置了指定的属性，或者文档类型声明为该属性设置了默认值，则 hasAttribute() 方法都返回 true。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段检查在 "books.xml" 中的第一个 <book> 元素是否拥有 "category" 属性：

xmlDoc=loadXMLDoc("books.xml");
x=xmlDoc.getElementsByTagName("book")[0];

document.write(x.hasAttribute("category"));

以上代码的输出：

true

TIY

hasAttribute() - 检查元素是否拥有指定的属性

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM hasAttributeNS() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM hasAttributeNS() 方法

返回 Element 对象参考手册

定义和用法

如果属性由指定的命名空间和名称组成，则 hasAttributeNS() 方法返回 true，否则返回 false。

语法：

hasAttributeNS(ns,name)
参数 | 描述
ns | 必需。规定要检索的属性的命名空间。
name | 必需。规定要检索的属性的名称。

说明

该方法与 hasAttribute() 方法类似，只是要检查的属性由命名空间和名称指定。只有使用命名空间的 XML 文档才使用方法。

实例

在所有的例子中，我们将使用 XML 文件 books_ns.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段检查 "books_ns.xml" 中的第一个 <title> 元素是否拥有带有指定的命名空间和名称的属性：

xmlDoc=loadXMLDoc("books_ns.xml");

x=xmlDoc.getElementsByTagName("title")[0];
ns="http://www.w3school.com.cn/children/";

document.write(x.hasAttributeNS(ns,"lang"));

以上代码的输出：

true

TIY

hasAttributeNS - 检查元素是否拥有带有指定的命名空间和名称的属性

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM hasAttributes() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM hasAttributes() 方法

返回 Element 对象参考手册

定义和用法

如果当前元素节点拥有任何属性，则 hasAttributes() 返回 true，否则返回 false。

语法：

hasAttributes()

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段检查 "books.xml" 中的第一个 <book> 元素是否拥有属性：

xxmlDoc=loadXMLDoc("books.xml");
x=xmlDoc.getElementsByTagName('book')[0];

document.write(x.hasAttributes());

以上代码的输出：

true

TIY

hasAttributes() - 检查元素是否拥有属性

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM hasAttributes() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM hasAttributes() 方法

返回 Node 对象参考手册

定义和用法

hasAttributes() 方法会在某节点用于任何属性时返回 true，否则返回 false。

语法：

nodeObject.hasAttributes()

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可返回是否首个 <book> 元素用于任何的属性：

xmlDoc=loadXMLDoc("books.xml");
var x=xmlDoc.getElementsByTagName('book')[0];

document.write(x.hasAttributes());

输出：

true

TIY

hasAttributes() - 检查某元素是否用于属性

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM hasChildNodes() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM hasChildNodes() 方法

返回 Element 对象参考手册

定义和用法

如果当前元素节点拥有子节点，则 hasChildNodes() 返回 true，返回返回 false。

语法：

elementNode.hasChildNodes()

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段检查 "books.xml" 中的第一个 元素是否拥有子节点：

xxmlDoc=loadXMLDoc("books.xml");
x=xmlDoc.getElementsByTagName("book")[0];

document.write(x.hasChildNodes());

以上代码的输出：

true

TIY

hasChildNodes() - 检查元素是否拥有子节点

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM hasChildNodes() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM hasChildNodes() 方法

返回 Node 对象参考手册

定义和用法

hasChildNodes() 方法可在某节点用于任何子节点时返回 true，否则返回 false。

语法：

nodeObject.hasChildNodes()

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可返回是否 <book> 元素是否拥有任何子节点：

xxmlDoc=loadXMLDoc("books.xml");
var x=xmlDoc.getElementsByTagName("book")[0];

document.write(x.hasChildNodes());

输出：

true

TIY

hasChildNodes() - 检查某个元素是否拥有任何子节点

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM hasFeature() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM hasFeature() 方法

返回 DomImplementation 对象参考手册

定义和用法

hasFeature() 方法确定 DOM 的实现是否支持某个特性。

语法：

nodeObject.selectNodes(feature, version)
参数 | 描述
feature | 特性名，用于判断哪个支持被测试。特性不区分大小写。 下面的表中列出了 2 级 DOM 标准支持的有效特性名的集合。
version | 版本号，用于判断哪个支持被测试，或者为 null。 如果该特性的所有版本都被支持，则为空串（""）。 在 2 级 DOM 标准中，支持的版本号是 1.0 和 2.0。

返回值

如果当前实现完全支持指定特性的指定版本，返回值为 true，否则为 false。如果没有指定版本号，而且实现完全支持指定特性的所有版本，该方法也返回 true。

说明

W3C DOM 标准是模块化的，不要求每种实现都实现标准中的所有模块或特性。该方法用于检测一种 DOM 实现是否支持 DOM 标准的制定模块。

注意，虽然 Internet Explorer 5 和 5.5 都部分地支持 1 级 DOM 标准，但在 IE 6 之前，没有实现支持这个重要的方法。

下表列出了可以作为 feature 参数的模块名的完整集合。

特性 | 描述
Core | 实现 Node、Element、Document、Text 和其他所有DOM实现都要求实现的基本接口 所有遵守 DOM 标准的实现都必须支持该模块。
HTML | 实现 HTMLElement、HTMLDocument 和其他 HTML 专有接口。
XML | 实现 Entity、EntityReference、ProcessingInstruction、Notation 和其他 XML 文档专用的节点类型。
StyleSheets | 实现描述普通样式表的简单接口。
CSS | 实现 CSS 样式表专有的接口。
CSS2 | 实现 CSS2Properties 接口。
Events | 实现基本的事件处理接口。
UIEvents | 实现处理用户界面事件的接口。
MouseEvents | 实现处理鼠标事件的接口。
HTMLEvents | 实现处理 HTML 事件的接口。
MutationEvents | 实现处理文档变化事件的接口。
Range | 实现操作文档范围的接口。
Traversal | 实现进行高级文档遍历的接口。
Views | 实现处理文档视图的接口。

参阅

Node.isSupported()

返回 DomImplementation 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM implementation 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM implementation 属性

返回 Document 对象参考手册

定义和用法

implementation 属性可返回处理该文档的 DOMImplementation 对象。

语法：

documentObject.implementation

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

以下的代码片段可返回操作该文档的 DOMImplementation 对象：

xmlDoc=loadXMLDoc("/example/xdom/books.xml");

document.write(xmlDoc.implementation);

输出：

[object DOMImplementation]

TIY

显示操作文档的 DOMImplementation 对象（不支持 IE 浏览器）

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM importNode() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM importNode() 方法

返回 Document 对象参考手册

定义和用法

importNode() 方法把一个节点从另一个文档复制到该文档以便应用。

语法：

importNode(importedNode,deep)
参数 | 描述
importedNode | 要导入的节点。
deep | 如果为 true，还要递归复制 importedNode 节点的所有子孙节点。

返回值

importedNode （可能还有它的子孙节点）的副本，它的 ownerDocument 属性设置到该文档。

抛出

如果 importedNode 是 Document 节点或 DocumentType 节点，该方法将抛出代码为 NOT_SUPPORTED_ERR 的 DOMException 异常，因为不能导入这些类型的节点。

说明

该方法的参数是另一个文档中定义的节点，返回值是适合插入该文档的节点的副本。如果 deep 值为 true，那么还要复制该节点的所有子孙节点。无论如何，原始节点和它的子孙节点都不会被修改。

返回的副本的 ownerDocument 属性被设置为当前文档，但是 parentNode 属性为 null，因为它还没有插入文档。在原始节点或树中注册的事件监听器函数不会被复制。

当导入 Element 节点时，只有在源文档中明确设置的属性才会被导入。当导入 Attr 节点时，将自动把它的 specified 属性设置为 true。

参阅

Node.cloneNode()

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM importStylesheet() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM importStylesheet() 方法

返回 XSLTProcessor 对象参考手册

定义和用法

importStylesheet() 方法指定一个 XSLT 样式表用于转换。

语法：

importStylesheet(stylesheet)
参数 | 描述
stylesheet | 要用于转换的 XSLT 样式表。 可以是 Document，也可以是 <xsl:stylesheet> 或 <xsl:transform> 元素。

说明

importStylesheet() 指定了将来调用 transformToDocument() 和 transformToFragment() 要用到的 XSLT 样式表。

返回 XSLTProcessor 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM initEvent() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM initEvent() 方法

返回 Event 对象参考手册

定义和用法

initEvent() 方法初始化新事件对象的属性。

语法

event.initEvent(eventType,canBubble,cancelable)
参数 | 描述
eventType | 字符串值。事件的类型。
canBubble | 事件是否起泡。
cancelable | 是否可以用 preventDefault() 方法取消事件。

说明

该方法将初始化 Document.createEvent() 方法 创建的合成 Event 对象的 type 属性、bubbles 属性和 cancelable 属性。 只有在新创建的 Event 对象被 Document 对象 或 Element 对象 的 dispatchEvent() 方法 分派之前，才能调用 Event.initEvent() 方法。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


XML DOM inputEncoding 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM inputEncoding 属性

返回 Document 对象参考手册

定义和用法

inputEncoding 属性可返回用于文档的编码（在解析时）。

语法：

documentObject.inputEncoding

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可显示 XML 编码、standalone 属性以及文档的 XML 版本：

xmlDoc=loadXMLDoc("/example/xdom/books.xml");

document.write("XML encoding: " + xmlDoc.xmlEncoding);
document.write("<br />");
document.write("XML standalone: " + xmlDoc.xmlStandalone);
document.write("<br />");
document.write("XML version: " + xmlDoc.xmlVersion);
document.write("<br />");
document.write("Encoding when parsing: " + xmlDoc.inputEncoding);

输出：

XML encoding: ISO-8859-1
XML standalone: false
XML version: 1.0
Encoding when parsing: ISO-8859-1

TIY

取得 XML 编码、standalone 属性以及文档的 XML 版本

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM insertBefore() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM insertBefore() 方法

返回 Element 对象参考手册

定义和用法

insertBefore() 方法在已有的子节点之前插入一个新的子节点。

该方法返回这个新的子节点。

语法：

elementNode.insertBefore(new_node,existing_node)
参数 | 描述
new_node | 必需。要插入的节点。
existing_node | 必需。已有节点。在此节点之前插入新节点。

提示和注释：

注释：Internet Explorer 会忽略节点之间生成的空白文本节点（比如换行字符），而 Mozilla 不这么做。因此，在下面的例子中，我们使用一个函数来检查最后一个子节点的节点类型。

元素节点的节点类型是 1，因此如果最后一个子节点不是元素节点，则移动到上一个节点，并检查这个节点是否是元素节点。这个过程一直会持续到找到最后一个属于元素节点的子节点为止。通过这个方法，在 Internet Explorer 和 Mozilla 中都会得到正确的结果。

如需更多有关 IE 与 Mozilla 浏览器差异的内容，请访问 W3School 的 XML DOM 教程中的 DOM 浏览器 这一节。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段创建一个新的 <book> 节点，并把它插到文档中最后一个 <book> 元素之前：

//check if the last childnode is an element node
function get_lastchild(n)
{
x=n.lastChild;
while (x.nodeType!=1)
  {
  x=x.previousSibling;
  }
return x;
}

xmlDoc=loadXMLDoc("books.xml");
newNode=xmlDoc.createElement("book");
newTitle=xmlDoc.createElement("title");
newText=xmlDoc.createTextNode("A Notebook");
newTitle.appendChild(newText);
newNode.appendChild(newTitle);

xmlDoc.documentElement.insertBefore(newNode,get_lastchild(x));

TIY

insertBefore() - 在指定节点之前添加节点
insertBefore() - 在指定子节点之前添加节点

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM insertBefore() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM insertBefore() 方法

返回 Node 对象参考手册

定义和用法

insertBefore() 方法可在已有的子节点前插入一个新的子节点。

此方法可返回新的子节点。

语法：

insertBefore(newchild,refchild)
参数 | 描述
newchild | 插入新的节点
refchild | 在此节点前插入新节点

提示和注释

注释：Internet Explorer 会忽略节点间生成的空白文本节点（例如，换行符号），而 Mozilla 不会这样做。因此，在下面的例子中，我们会使用一个函数来检查最后一个子节点的节点类型。

元素节点的节点类型是 1，因此如果首个子节点不是一个元素节点，它就会移至下一个节点，然后继续检查此节点是否为元素节点。整个过程会一直持续到首个元素子节点被找到为止。通过这个方法，我们就可以在 Internet Explorer 和 Mozilla 得到正确的方法。

提示：如需更多有关 IE 与 Mozilla 浏览器之间 XML DOM 的差异的内容，请访问我们的 DOM 浏览器 章节。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的下面片段可创建一个新的 <book> 节点，并在文档中的最后一个 <book> 元素前插入此节点：

//check if the last childnode is an element node
function get_lastchild(n)
{
var x=n.lastChild;
while (x.nodeType!=1)
{
x=x.previousSibling;
}
return x;
}

xmlDoc=loadXMLDoc("books.xml");
var newNode=xmlDoc.createElement("book");
var newTitle=xmlDoc.createElement("title");
var newText=xmlDoc.createTextNode("A Notebook");
newTitle.appendChild(newText);
newNode.appendChild(newTitle);

xmlDoc.documentElement.insertBefore(newNode,get_lastchild(x));

TIY

insertBefore() - 在某个指定的节点前插入节点

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM insertData() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM insertData() 方法

返回 Comment 对象参考手册

定义和用法

insertData() 方法把字符串插入注释节点。

语法：

commentNode.insertData(start,string)
参数 | 描述
start | 必需。规定再何处插入字符。该值从 0 开始。
length | 必需。要插入的字符的数量。

描述

该方法把字符串 string 插入指定位置 length 的 Comment 节点的文本处。

实例

以下代码段使用 JavaScript 函数 loadXMLDoc() 把 XML 文件 books_comment.xml 载入 xmlDoc 中，然后向第一个 Comment 节点插入一个字符串：

xmlDoc=loadXMLDoc("books_comment.xml");

x=xmlDoc.getElementsByTagName("book")[0].childNodes;

for (i=0;i<x.length;i++)
{
  if (x[i].nodeType==8)
  {
  //仅仅处理 comment 节点
  x[i].insertData(10,"Illustrated ");
  document.write(x[i].data);
  document.write("<br />");
  }
}

以上代码的输出：

(Book 6) (Illustrated Hardcover)

在本例中，我们使用一段循环和 if 语句来执行只针对 comment 节点的处理。comment 节点的节点类型是 8。

TIY

insertData() - 向注释节点插入文本

返回 Comment 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM insertData() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM insertData() 方法

返回 Text 对象参考手册

定义和用法

insertData() 方法向文本节点插入数据。

语法：

insertData(start,string)
参数 | 描述
start | 必需。规定在何处插入字符。开始值以 0 开始。
string | 必需。规定要插入的字符串。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段向 "books.xml" 中的第一个 <title> 元素的文本节点插入一个字符串：

xmlDoc=loadXMLDoc("books.xml");
x=xmlDoc.getElementsByTagName("title")[0].childNodes[0];

x.insertData(0,"Cooking: ");
document.write(x.data);

输出：

Cooking: Everyday Italian

TIY

insertData() - 向文本节点插入文本

返回 Text 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM internalSubset 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM internalSubset 属性

返回 DocumentType 对象参考手册

定义和用法

internalSubset 属性能够以一个字符串返回内部 DTD（无定界方括号），如果没有则返回 null。

语法：

documentObject.doctype.internalSubset

实例

在所有的例子中，我们将使用 XML 文件 note_internal_dtd.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段能够以字符串显示内部 DTD：

xmlDoc=loadXMLDoc("note_internal_dtd.xml");
document.write(xmlDoc.doctype.internalSubset);

输出：

<!ELEMENT note (to,from,heading,body)>
<!ELEMENT to (#PCDATA)>
<!ELEMENT from (#PCDATA)>
<!ELEMENT heading (#PCDATA)>
<!ELEMENT body (#PCDATA)>
<!ENTITY writer "Bill Gates">
<!ENTITY copyright "Copyright W3School.com.cn">

返回 DocumentType 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM isEqualNode() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM isEqualNode() 方法

返回 Element 对象参考手册

定义和用法

如果节点等于给定的节点，则 isEqualNode() 返回 true，否则返回 false。

语法：

elementObject.isEqualNode(node)
参数 | 描述
node | 必需。要检查的节点。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码检查两个节点是否相等：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("book")[1];
y=xmlDoc.getElementsByTagName("book")[2];

document.write(x.isEqualNode(y));

以上代码的输出：

false

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM isEqualNode() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM isEqualNode() 方法

返回 Node 对象参考手册

定义和用法

isEqualNode() 方法可在节点等于某个给定的节点时返回 true，否则返回 false。

语法：

nodeObject.isEqualNode(node)
参数 | 描述
node | 必需。要检查的节点。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码可检查两个节点是否相等：

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName("book")[1];
var y=xmlDoc.getElementsByTagName("book")[2];

document.write(x.isEqualNode(y));

输出：

false

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM isId 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM isId 属性

返回 Attr 对象参考手册

定义和用法

如果 attribute 是 ID 类型（例如，包含了其所属的元素的标识符），则 isId 属性返回 true，否则返回 false。

语法：

attrObject.isId

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段返回 category 属性是否是 <book> 元素的 ID 属性：

xmlDoc=loadXMLDoc("/example/xdom/books.xml");

var x=xmlDoc.getElementsByTagName('book');

for(i=0;i<x.length;i++)
{
document.write(x.item(i).attributes[0].isId);
document.write("<br />");
}

以上代码的输出应该是：

false
false
false
false

TIY

isId - 获取属性是否是 ID 类型（IE 浏览器不支持）

返回 Attr 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM isSameNode() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM isSameNode() 方法

返回 Element 对象参考手册

定义和用法

isSameNode() 方法检查指定的节点是否与已有节点相同。

如果两个节点相同，则该方法返回 true，否则返回 false。

语法：

elementNode.isSameNode(node)
参数 | 描述
node | 必需。要检查的节点。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的节点检查两节点是否相同：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("book")[0];
y=xmlDoc.getElementsByTagName("book")[1];

document.write(x.isSameNode(y));

以上代码的输出：

false

TIY

isSameNode() - 检查两节点是否相同

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM isSameNode() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM isSameNode() 方法

返回 Node 对象参考手册

定义和用法

isSameNode() 方法可在某个节点与给定的节点是同一个节点时返回 true，否则返回 false。

语法：

nodeObject.isSameNode(node)
参数 | 描述
node | 必需。要检查的节点。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码会检查两个节点是否为同一个节点：

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName("book")[0];
var y=xmlDoc.getElementsByTagName("book")[1];

document.write(x.isSameNode(y));

输出：

false

TIY

isSameNode() - 检查两个节点是否为同一个节点

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM isSupported() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM isSupported() 方法

返回 Node 对象参考手册

定义和用法

isSupported() 方法用于判断当前节点是否支持某个特性。

语法：

nodeObject.isSupported(feature, version)
参数 | 描述
feature | 要检测的特性的名称。
version | 要检测的特性的版本号，如果要检测对该特性的版本的支持，则为空串。

返回值

如果当前节点支持指定特性的指定版本，则返回 true，否则返回 false。

说明

W3C DOM 标准被模块化，它的实现不必实现标准规定的所有模块或特性。该方法用于检测当前节点的实现是否支持支持指定特性的指定版本。

关于参数 feature 和 version 的值的列表，请参阅 “DOMImplementation.hasFeature()” 参考页。

参阅

DOMImplementation.hasFeature()

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM item() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM item() 方法

返回 NamedNodeMap 对象参考手册

定义和用法

item() 方法可返回节点列表中处于指定索引号的节点。

语法：

item(index)
参数 | 描述
index | 索引号

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可循环遍历 <book> 元素，并输出 category 属性的值：

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName('book');

for(i=0;i<x.length;i++)
  {
  var att=x.item(i).attributes.getNamedItem("category");
  document.write(att.value + "<br />")
  }

输出：

COOKING
CHILDREN
WEB
WEB

TIY

item() - 循环遍历节点列表中的项目
getNamedItem() - 取得某个项目的值
getNamedItem() - 改变某个项目的值

返回 NamedNodeMap 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM item() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM item() 方法

返回 NodeList 对象参考手册

定义和用法

item() 方法可返回节点列表中处于指定索引号的节点。

语法

item(index)
参数 | 描述
index | 索引号

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可循环遍历 XML 文档中 <bookstore> 元素的所有直系的子节点：

xmlDoc=loadXMLDoc("/example/xdom/books.xml");

var x=xmlDoc.documentElement.childNodes;

for (i=0;i<x.length;i++)
  {
  //仅显示元素节点
  if (x.item(i).nodeType==1)
    {
    document.write(x.item(i).nodeName)
    document.write("<br />")
    }
  }

输出：

book
book
book
book

返回 NodeList 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM iterateNext() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM iterateNext() 方法

返回 XPathResult 对象参考手册

定义和用法

iterateNext() 方法返回和一个 XPath 查询匹配的下一个节点。

语法：

iterateNext()

返回值

返回匹配节点列表中的下一个节点，如果没有其他节点，则为 null。

抛出

既然 XPathResult 被返回，如果文档已经修改了，这个方法会抛出异常。如果 resultType 不是 UNORDERED_NODE_ITERATOR_TYPE 或 ORDERED_NODE_ITERATOR_TYPE 的时候调用，方法也会抛出异常。

说明

iterateNext() 方法返回与 XPath 查询匹配的下一个节点，如果所有匹配节点都已经返回了，则为 null。

当 XPathResult 是 UNORDERED_NODE_ITERATOR_TYPE 或 ORDERED_NODE_ITERATOR_TYPE 的时候使用这个方法。如果类型是有序的，节点按照它们在文档中出现的顺序返回，否则，它们按照任意顺序返回。

如果 invalidIteratorState 属性为 true，文档已经被修改了，这个方法抛出异常。

返回 XPathResult 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM lastChild 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM lastChild 属性

返回 Document 对象参考手册

定义和用法

lastChild 属性可返回文档的最后一个子节点。

语法：

documentObject.lastChild

提示和注释

注释：Internet Explorer 会忽略节点间生成的空白文本节点（例如，换行符号），而 Mozilla 不会这样做。因此，在下面的例子中，我们会使用一个函数来检查第一个子节点的节点类型。

元素节点的节点类型是 1，因此如果首个子节点不是一个元素节点，它就会移至下一个节点，然后继续检查此节点是否为元素节点。整个过程会一直持续到首个元素子节点被找到为止。通过这个方法，我们就可以在 Internet Explorer 和 Mozilla 得到正确的结果。

提示：如需更多有关 IE 与 Mozilla 浏览器之间 XML DOM 的差异的内容，请访问我们的 DOM 浏览器 章节。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可显示文档的最后一个子节点的节点名称和节点类型：

//检查最后一个节点是否是 element 节点
function get_lastchild(n)
{
var x=n.lastChild;
while (x.nodeType!=1)
{
x=x.previousSibling;
}
return x;
}

xmlDoc=loadXMLDoc("/example/xdom/books.xml");

var x=get_lastchild(xmlDoc);
document.write("Nodename: " + x.nodeName);
document.write(" (nodetype: " + x.nodeType + ")");

输出：

Nodename: bookstore (nodetype: 1)

TIY

取得文档的最后一个子节点
取得文档的第一个子节点

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM lastChild 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM lastChild 属性

返回 Element 对象参考手册

定义和用法

lastChild 属性返回被选节点的最后一个子节点。

如果选定的节点没有子节点，则该属性返回 NULL。

语法：

elementNode.lastChild

提示和注释

注释：Internet Explorer 会忽略节点之间生成的空白文本节点（比如换行字符），而 Mozilla 不这么做。因此，在下面的例子中，我们用一个函数来检测最后一个子节点的节点类型。

元素节点的节点类型是 1，因此假如第一个子节点不是元素节点，则移动到下一个节点，并检测该节点是否是元素节点。这个过程一直持续到找到第一个子节点为止。这种方法可以确保在 Internet Explorer 和 Mozilla 都获得正确的结果。

如需更多有关 IE 与 Mozilla 浏览器差异的内容，请访问 W3School 的 XML DOM 教程中的 DOM 浏览器 这一节。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段从 "books.xml" 中获取最后一个子节点：

//check if the last node is an element node
function get_lastchild(n)
{
var x=n.lastChild;
while (x.nodeType!=1)
  {
  x=x.previousSibling;
  }
return x;
}

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.documentElement;
var lastNode=get_lastchild(x);

for (var i=0;i<lastNode.childNodes.length;i++)
{
if (lastNode.childNodes[i].nodeType==1)
  {
  //Process only element nodes
  document.write(lastNode.childNodes[i].nodeName);
  document.write(" = ");
  document.write(lastNode.childNodes[i].childNodes[0].nodeValue);
  document.write("<br />");
  }
}

以上代码的输出：

title = Learning XML
author = Erik T. Ray
year = 2003
price = 39.95

TIY

lastChild - 获取 XML 文档中的最后一个子节点

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM lastChild 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM lastChild 属性

返回 Node 对象参考手册

定义和用法

lastChild 属性可返回指定节点的最后一个子节点。

语法：

nodeObject.lastChild

提示和注释

注释：Internet Explorer 会忽略节点间生成的空白文本节点（例如，换行符号），而 Mozilla 不会这样做。因此，在下面的例子中，我们会使用一个函数来检查首个子节点的节点类型。

元素节点的节点类型是 1，因此如果首个子节点不是一个元素节点，它就会移至下一个节点，然后继续检查此节点是否为元素节点。整个过程会一直持续到首个元素子节点被找到为止。通过这个方法，我们就可以在 Internet Explorer 和 Mozilla 得到正确的结果。

提示：如需更多有关 IE 与 Mozilla 浏览器之间 XML DOM 的差异的内容，请访问我们的 DOM 浏览器 章节。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码可显示出文档的最后一个子节点的节点名称和节点类型：

//check if the last node is an element node
function get_lastchild(n)
{
var x=n.lastChild;
while (x.nodeType!=1)
{
x=x.previousSibling;
}
return x;
}

xmlDoc=loadXMLDoc("books.xml");

var x=get_lastchild(xmlDoc);
document.write("Nodename: " + x.nodeName);
document.write(" (nodetype: " + x.nodeType);

输出：

Nodename: bookstore (nodetype: 1)

TIY

取得文档的首个子节点
取得文档的最后一个子节点

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM length 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM length 属性

返回 Comment 对象参考手册

定义和用法

length 属性返回注释节点中的文本长度，以字符数计。

语法：

commentNode.length

实例

以下代码段使用 JavaScript 函数 loadXMLDoc() 把 XML 文件 books_comment.xml 载入 xmlDoc 中，并获得第一个 <book> 元素的注释文本的长度：

xmlDoc=loadXMLDoc("books_comment.xml");

x=xmlDoc.getElementsByTagName("book")[0].childNodes;

for (i=0;i<x.length;i++)
{
if (x[i].nodeType==8)
  {
  //Process only comment nodes
  document.write(x[i].length);
  document.write("<br />");
  }
}

以上代码的输出：

20

在本例中，我们使用一段循环和 if 语句来执行只针对 comment 节点的处理。comment 节点的节点类型是 8。

TIY

length 属性 - 获取注释节点的长度

返回 Comment 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM length 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM length 属性

返回 NamedNodeMap 对象参考手册

定义和用法

length 属性可返回 NamedNodeMap 中的节点数目。

语法

nodemapObject.length

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可取得 XML 文档的第一个 <book> 元素中属性的数目：

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName('book');

document.write(x.item(0).attributes.length);

输出：

1

TIY

length - 可返回指定的节点地图中的节点数目
length - 可返回节点列表中节点的数目
length - 可循环遍历节点列表中的节点

返回 NamedNodeMap 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM length 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM length 属性

返回 NodeList 对象参考手册

定义和用法

length 属性可返回一个节点列表中的节点数目。

语法

nodelistObject.length

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可取得 XML 文档 中<title> 元素的数目：

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName('title');

document.write("Number of title elements: " + x.length);

输出：

Number of title elements: 4

TIY

length - 可返回节点列表中的节点数目
length - 循环遍历节点列表中的节点

返回 NodeList 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM length 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM length 属性

返回 Text 对象参考手册

定义和用法

length 属性返回节点的文本的长度（以字符计）。

语法：

textNode.length

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段输出 "books.xml" 中第一个 <title> 元素的文本节点数据和长度：

xmlDoc=loadXMLDoc("books.xml");
x=xmlDoc.getElementsByTagName("title")[0].childNodes[0];

document.write(x.data);
document.write(" - Length: ");
document.write(x.length);

输出：

Everyday Italian - Length: 16

TIY

length - 获取的文本节点的长度

返回 Text 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM loadXML() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM loadXML() 方法

返回 Document 对象参考手册

定义和用法

loadXML() 方法通过解析一个 XML 标签字符串来组成该文档。

语法：

loadXML(text)
参数 | 描述
text | 要解析的 XML 标签。

说明

这个特定于 IE 的方法解析指定的 XML 文本串，然后在当前文档对象中构建一棵 DOM 节点树，而丢弃此前存在于文档中的任何节点。

这个方法在表示 HTML 文档的 Document 对象上并不存在。在调用 loadXML() 之前，通常创建一个新的、空的 Document 对象来保存解析的内容：

var doc = new ActivexObject ("MSXML2.DOMDocument");
doc.loadXML(markup);

参阅 DOMParser.parseFromString() 以了解一种非 IE 的替代方法。

参阅

DOMParser.parseFromString()

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM localName 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM localName 属性

返回 Attr 对象参考手册

定义和用法

localName 属性返回属性名称的本地部分。

语法：

attrObject.localName

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段返回 "lang" 属性的本地名称：

xmlDoc=loadXMLDoc("/example/xdom/books.xml");

var x=xmlDoc.getElementsByTagName('title');

for(i=0;i<x.length;i++)
{
document.write(x.item(i).attributes[0].localName);
document.write("<br />");
}

以上代码的输出：

lang
lang
lang
lang

TIY

获取属性的 localName（IE 浏览器不支持）

返回 Attr 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM localName 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM localName 属性

返回 Element 对象参考手册

定义和用法

localName 属性返回被选元素的本地名称（元素名称）。

如果选定的节点不是元素或属性，则该属性返回 NULL。

语法：

elementNode.localName

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

例子 1

下面的代码片段从 "books.xml" 中的第一个 <book> 元素获取本地名称：

xmlDoc=loadXMLDoc("books.xml");
x=xmlDoc.getElementsByTagName("book")[0];

document.write(x.localName);

以上代码的输出：

book

例子 2

下面的代码片段从 "books.xml" 中的最后一个 <book> 元素获取本地名称：

//check if the last node is an element node
function get_lastchild(n)
{
var x=n.lastChild;
while (x.nodeType!=1)
  {
  x=x.previousSibling;
  }
return x;
}

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.documentElement;
var lastNode=get_lastchild(x);

document.write(lastNode.localName);

以上代码的输出：

book

TIY

localName - 获取节点的本地名称
localName - 获取最后一个子节点的本地名称

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM localName 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM localName 属性

返回 Node 对象参考手册

定义和用法

localName 属性可返回某个节点名称的本地部分。

语法：

nodeObject.localName

实例

在所有的例子中，我们将使用 XML 文件 books_ns.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可返回 <title> 元素的本地名称：

xmlDoc=loadXMLDoc("books_ns.xml");

var x=xmlDoc.getElementsByTagName('title');

for(i=0;i<x.length;i++)
  {
  document.write(x.item(i).localName);
  document.write("<br />");
  }

输出：

title
title

TIY

取得某个节点的前缀、本地名称、命名空间URI、以及绝对基准URI

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM lookupNamespaceURI() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM lookupNamespaceURI() 方法

返回 Element 对象参考手册

定义和用法

lookupNamespaceURI() 方法返回匹配当前节点上指定的前缀的命名空间。

语法：

elementNode.lookupNamespaceURI(prefix)
参数 | 描述
prefix | 必需。字符串值，规定要匹配的前缀。

实例

在所有的例子中，我们将使用 XML 文件 books_ns.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段查找第一个 <book> 元素中匹配 "c" 前缀的名字空间：

xmlDoc=loadXMLDoc("books_ns.xml");

x=xmlDoc.getElementsByTagName("book")[0];

document.write(x.lookupNamespaceURI("c"));

以上代码的输出：

http://www.w3school.com.cn/children/

TIY

lookupNamespaceURI() - 通过前缀获取命名空间

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM lookupNamespaceURI() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM lookupNamespaceURI() 方法

返回 Node 对象参考手册

定义和用法

lookupNamespaceURI() 方法可返回匹配某个节点上所指定的前缀的命名空间 URI。

语法：

nodeObject.lookupNamespaceURI(prefix)
参数 | 描述
prefix | 必需。前缀。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可在首个 <book> 元素中查找前缀 "c" 所属的命名空间：

xmlDoc=loadXMLDoc("books_ns.xml");

var x=xmlDoc.getElementsByTagName("book")[0];
document.write(x.lookupNamespaceURI("c"));

输出：

http://www.w3school.com.cn/children/

TIY

lookupNamespaceURI() - 通过前缀取得某个命名空间的 URI

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM lookupPrefix() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM lookupPrefix() 方法

返回 Element 对象参考手册

定义和用法

lookupPrefix() 方法返回在当前节点上匹配指定的命名空间 URI 的前缀。

语法：

elementNode.lookupPrefix(URI)
参数 | 描述
URI | 必需。要查找的前缀的命名空间。

实例

在所有的例子中，我们将使用 XML 文件 books_ns.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段查找第一个 <book> 元素中匹配命名空间 URI 的前缀：

xmlDoc=loadXMLDoc("books_ns.xml");

x=xmlDoc.getElementsByTagName("book")[0];

document.write(x.lookupPrefix("http://www.w3school.com.cn/children/"));

以上代码的输出：

c

TIY

lookupPrefix() - 通过命名空间获取前缀

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM lookupPrefix() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM lookupPrefix() 方法

返回 Node 对象参考手册

定义和用法

lookupPrefix() 方法可返回在节点上匹配指定的命名空间的前缀。

语法：

nodeObject.lookupPrefix(URI)
参数 | 描述
URI | 必需。命名空间 URI。

实例

在所有的例子中，我们将使用 XML 文件 books_ns.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可查找第一个 <book> 元素中所属命名空间 URI 的前缀：

xmlDoc=loadXMLDoc("books_ns.xml");

var x=xmlDoc.getElementsByTagName("book")[0];

document.write(x.lookupPrefix("http://www.w3school.com.cn/children/"));

输出：

c

TIY

lookupPrefix() - 通过命名空间取得某个前缀

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM name 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM name 属性

返回 Attr 对象参考手册

定义和用法

name 属性返回属性的名称。

语法：

attrObject.name

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段显示 category 属性的名称和值：

xmlDoc=loadXMLDoc("/example/xdom/books.xml");

var x=xmlDoc.getElementsByTagName('book');

for(i=0;i<x.length;i++)
{
document.write(x.item(i).attributes[0].name);
document.write(" = ");
document.write(x.item(i).attributes[0].value);
document.write("<br />");
}

以上代码的输出：

category = children
category = cooking
category = web
category = web

TIY

返回属性的名称和值

返回 Attr 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM name 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM name 属性

返回 DocumentType 对象参考手册

定义和用法

name 属性可返回 DTD 的名称（紧随关键词 DOCTYPE 的名称）

语法：

documentObject.doctype.name

实例

在所有的例子中，我们将使用 XML 文件 note_internal_dtd.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可显示与 XML 文档相关联的 DTD 的名称：

xmlDoc=loadXMLDoc("note_internal_dtd.xml");
document.write(xmlDoc.doctype.name);

输出：

note

DIY

取得与 XML 文档相关联的 DTD 的名称

返回 DocumentType 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM namespaceURI 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM namespaceURI 属性

返回 Attr 对象参考手册

定义和用法

namespaceURI 属性设置或返回属性的命名空间 URI。

语法：

attrObject.namespaceURI

实例

在所有的例子中，我们将使用 XML 文件 books_ns.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段返回 "lang" 属性的 namespace URI：

xmlDoc=loadXMLDoc("/example/xdom/books_ns.xml");

var x=xmlDoc.getElementsByTagName('title');

for(i=0;i<x.length;i++)
{
document.write(x.item(i).attributes[0].namespaceURI);
document.write("<br />");
}

以上代码的输出：

http://www.w3school.com.cn/children/
http://www.w3school.com.cn/xml/

TIY

获取属性的 namespaceURI

返回 Attr 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM namespaceURI 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM namespaceURI 属性

返回 Element 对象参考手册

定义和用法

namespaceURI 属性为被选节点返回命名空间的 URI。

如果选定的节点不是元素或属性，则该属性返回 NULL。

语法：

elementNode.namespaceURI

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段从 "books_ns.xml" 中的第一个 <title> 元素获取命名空间的 URI：

xmlDoc=loadXMLDoc("books_ns.xml");
x=xmlDoc.getElementsByTagName("title")[0];

document.write(x.namespaceURI);

以上代码的输出：

http://www.w3school.com.cn/children/

TIY

namespaceURI - 从节点获取命名空间的 URI

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM namespaceURI 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM namespaceURI 属性

返回 Node 对象参考手册

定义和用法

namespaceURI 属性可返回某个节点的命名空间 URI。

语法：

nodeObject.namespaceURI

实例

在所有的例子中，我们将使用 XML 文件 books_ns.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可返回 <title> 元素的命名空间 URI：

xmlDoc=loadXMLDoc("books_ns.xml");

var x=xmlDoc.getElementsByTagName('title');

for(i=0;i<x.length;i++)
  {
  document.write(x.item(i).namespaceURI);
  document.write("<br />");
  }

输出：

http://www.w3school.com.cn/children/
http://www.w3school.com.cn/xml/

TIY

取得某个节点的前缀、本地名称、命名空间 URI、以及绝对基准 URI

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM nextSibling 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM nextSibling 属性

返回 Element 对象参考手册

定义和用法

nextSibling 属性返回被选节点的下一个同级节点（在相同树层级中的下一个节点）。

如果不存在这样的节点，则该属性返回 NULL。

语法：

elementNode.nextSibling

提示和注释

注释：Internet Explorer 会忽略节点之间生成的空白文本节点（比如换行字符），而 Mozilla 不这么做。因此，在下面的例子中，我们用一个函数来检测下一个同级节点的节点类型。

元素节点的节点类型是 1，因此假如下一个同级节点不是元素节点，则移动到下一个节点，并检测该节点是否是元素节点。这个过程一直持续到找到下一个同级节点为止。这种方法可以确保在 Internet Explorer 和 Mozilla 都获得正确的结果。

如需更多有关 IE 与 Mozilla 浏览器差异的内容，请访问 W3School 的 XML DOM 教程中的 DOM 浏览器 这一节。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段获取 XML 文档中的一个 <title> 元素的下一个同级节点：

//check if the next sibling node is an element node
function get_nextsibling(n)
{
var x=n.nextSibling;
while (x.nodeType!=1)
 {
 x=x.nextSibling;
 }
return x;
}

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName("title")[0];
document.write(x.nodeName);
document.write(" = ");
document.write(x.childNodes[0].nodeValue);

var y=get_nextsibling(x);

document.write("<br />Next sibling: ");
document.write(y.nodeName);
document.write(" = ");
document.write(y.childNodes[0].nodeValue);

以上代码的输出：

title = Everyday Italian
Next sibling: author = Giada De Laurentiis

TIY

nextSibling - 获取节点的下一个同级节点
previousSibling - 获取节点的上一个同级节点

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM nextSibling 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM nextSibling 属性

返回 Node 对象参考手册

定义和用法

nextSibling 属性可返回某个元素之后紧跟的元素（处于同一树层级中）。

如果无此节点，则属性返回 null。

语法：

nodeObject.nextSibling

提示和注释

注释：Internet Explorer 会忽略节点间生成的空白文本节点（例如，换行符号），而 Mozilla 不会这样做。因此，在下面的例子中，我们会使用一个函数来检查首个子节点的节点类型。

元素节点的节点类型是 1，因此如果首个子节点不是一个元素节点，它就会移至下一个节点，然后继续检查此节点是否为元素节点。整个过程会一直持续到首个元素子节点被找到为止。通过这个方法，我们就可以在 Internet Explorer 和 Mozilla 得到正确的方法。

提示：如需更多有关 IE 与 Mozilla 浏览器之间 XML DOM 的差异的内容，请访问我们的 DOM 浏览器 章节。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可取得 XML 文档中首个 <title> 元素的下一个同级子节点：

//check if the next sibling node is an element node
function get_nextsibling(n)
  {
  var x=n.nextSibling;
  while (x.nodeType!=1)
   {
   x=x.nextSibling;
   }
  return x;
  }

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName("title")[0];
document.write(x.nodeName);
document.write(" = ");
document.write(x.childNodes[0].nodeValue);

var y=get_nextsibling(x);

document.write("<br />Next sibling: ");
document.write(y.nodeName);
document.write(" = ");
document.write(y.childNodes[0].nodeValue);

输出：

title = Everyday Italian
Next sibling: author = Giada De Laurentiis

TIY

nextSibling - 取得某节点的下一个同级节点
previousSibling - 取得某节点的上一个同级节点

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM Node List

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM Node List

  • Previous Page
  • Next Page

节点列表由 getElementsByTagName() 方法和 childNodes 属性返回。

实例

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

从第一个 <title> 元素获取文本
本例使用 getElementsByTagName() 方法从 "books.xml" 中的第一个 <title> 元素获取文本。
通过使用 length 属性来循环节点
本例使用节点列表和 length 属性来循环 "books.xml" 中的所有 <title> 元素。
获取元素的属性
本例使用属性列表从 "books.xml" 中的第一个 <title> 元素获取属性。

DOM Node List

当使用诸如 childNodes 或 getElementsByTagName() 属性或方法时，会返回 NodeList 对象。

NodeList 对象表示节点的列表，以 XML 中的相同顺序。

使用从 0 开始的下标来访问节点列表中的节点。

下面的图像表示 "books.xml" 中 <title> 元素的节点列表：

DOM node list

下面的代码片段通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中，并返回 "books.xml" 中 title 元素的一个节点列表：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("title");

以上语句执行之后，x 成为一个 NodeList 对象。

下面的代码片段从节点列表 x 中的第一个 <title> 元素中返回文本：

txt=x[0].childNodes[0].nodeValue;

在以上语句执行之后，txt = "Everyday Italian"。

TIY

Node List Length

NodeList 对象会保持自身的更新。如果删除或添加了元素，列表会自动更新。

节点列表的 length 属性是列表中节点的数量。

下面的代码片段通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc，并返回 "books.xml" 中 <title> 元素的数量：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName('title').length;

在上面的语句执行之后，x = 4。

节点列表的长度可用于循环列表中所有的元素。

下面的代码片段使用 length 属性来遍历 <title> 元素的列表：

xmlDoc=loadXMLDoc("books.xml");

//the x variable will hold a node list
x=xmlDoc.getElementsByTagName('title');

for (i=0;i<x.length;i++)
{
document.write(x[i].childNodes[0].nodeValue);
document.write("<br />");
}

输出：

Harry Potter
Everyday Italian
XQuery Kick Start
Learning XML

例子解释：

  • 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc
  • 设置保存所有 title 元素的节点列表的 x 变量
  • 从所有 <title> 元素的文本节点输出值

TIY

DOM Attribute List (Named Node Map)

元素节点的 attributes 属性返回属性节点的列表。

这被称为 Named Node Map，除了方法和属性上的一些差别以为，它与节点列表相似。

属性列表会保持自身的更新。如果删除或添加属性，这个列表会自动更新。

下面的代码片段通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中，并从 "books.xml" 中的第一个 <book> 元素返回属性节点的一个列表：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName('book')[0].attributes;

以上代码执行之后，x.length 等于属性的数量，可使用 x.getNamedItem() 返回属性节点。

下面的代码片段一个 book 的 "category" 属性的值，以及其属性的数量：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("book")[0].attributes;

document.write(x.getNamedItem("category").nodeValue);
document.write("<br />" + x.length);

输出：

children
1

例子解释：

  • 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  • 把 x 变量设置为第一个 <book> 元素的所有属性的一个列表
  • 从 "category" 属性输出其值
  • 输出属性列表的长度

TIY

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM nodeName 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM nodeName 属性

返回 Attr 对象参考手册

定义和用法

nodeName 属性根据节点的类型返回其名称。

语法：

attrObject.nodeName

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段显示 category 属性的节点名称、节点值以及节点类型：

xmlDoc=loadXMLDoc("/example/xdom/books.xml");
var x=xmlDoc.getElementsByTagName('book');

for(i=0;i<x.length;i++)
{
document.write(x.item(i).attributes[0].nodeName);
document.write(" = ");
document.write(x.item(i).attributes[0].nodeValue);
document.write(" (nodetype: ");
document.write(x.item(i).attributes[0].nodeType + ")");
document.write("<br />");
}

以上代码的输出：

category = children (nodetype: 2)
category = cooking (nodetype: 2)
category = web (nodetype: 2)
category = web (nodetype: 2)

TIY

显示属性的 nodeName 、nodeValue 以及 nodeType

返回 Attr 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM nodeName 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM nodeName 属性

返回 Document 对象参考手册

定义和用法

nodeName 属性可依据节点的类型返回其名称。

语法：

documentObject.nodeName

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可显示根节点的节点名称和节点类型：

xmlDoc=loadXMLDoc("books.xml");

document.write("Nodename: " + xmlDoc.nodeName);
document.write(" (nodetype: " + xmlDoc.nodeType);

输出：

Nodename: #document (nodetype: 9)

TIY

显示所有元素的节点名称和节点类型
显示所有元素的节点名称和节点值

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM nodeName 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM nodeName 属性

返回 Element 对象参考手册

定义和用法

nodeName 属性返回被选节点的标签名称。

语法：

elementNode.nodeName

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段从 "books.xml" 的第一个 <title> 元素获取标签名称：

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName("title")[0];
document.write(x.nodeName);

以上代码的输出：

title

TIY

nodeName - 从节点获取节点名称

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM nodeName 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM nodeName 属性

返回 Node 对象参考手册

定义和用法

nodeName 属性可返回节点的名称，根据其类型。

语法：

nodeObject.nodeName

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可显示根节点的节点名称和节点类型：

xmlDoc=loadXMLDoc("books.xml");

document.write("Nodename: " + xmlDoc.nodeName);
document.write(" (nodetype: " + xmlDoc.nodeType);

输出：

Nodename: #document (nodetype: 9)

TIY

显示所有元素的节点名称和节点类型
显示所有元素的节点名称和节点值

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM nodeType 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM nodeType 属性

返回 Attr 对象参考手册

定义和用法

nodeType 属性返回节点的类型。

语法：

attrObject.nodeType

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段显示 category 属性的节点名称、节点值以及节点类型：

xmlDoc=loadXMLDoc("/example/xdom/books.xml");
var x=xmlDoc.getElementsByTagName('book');

for(i=0;i<x.length;i++)
{
document.write(x.item(i).attributes[0].nodeName);
document.write(" = ");
document.write(x.item(i).attributes[0].nodeValue);
document.write(" (nodetype: ");
document.write(x.item(i).attributes[0].nodeType + ")");
document.write("<br />");
}

以上代码的输出：

category = children (nodetype: 2)
category = cooking (nodetype: 2)
category = web (nodetype: 2)
category = web (nodetype: 2)

TIY

显示属性的 nodeName 、nodeValue 以及 nodeType

返回 Attr 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM nodeType 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM nodeType 属性

返回 Document 对象参考手册

定义和用法

nodeType 属性可返回节点的节点类型。

语法：

documentObject.nodeType

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

以下的代码片段可显示根节点的节点名称和节点类型：

xmlDoc=loadXMLDoc("books.xml");

document.write("Nodename: " + xmlDoc.nodeName);
document.write(" (nodetype: " + xmlDoc.nodeType);

输出：

Nodename: #document (nodetype: 9)

TIY

显示所有元素的节点名称和节点类型
显示所有元素的节点名称和节点值

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM nodeType 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM nodeType 属性

返回 Element 对象参考手册

定义和用法

nodeType 属性返回被选节点的节点类型。

语法：

elementNode.nodeType
节点编号： | 节点名称：
1 | Element
2 | Attribute
3 | Text
4 | CDATA Section
5 | Entity Reference
6 | Entity
7 | Processing Instrucion
8 | Comment
9 | Document
10 | Document Type
11 | Document Fragment
12 | Notation

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段获取 "books.xml" 的第一个 <title> 元素的节点类型：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("title")[0];
document.write(x.nodeType);

以上代码的输出：

1

TIY

nodeType - 获取整个 XML 文档的节点类型
nodeType - 忽略空的文本节点

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM nodeType 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM nodeType 属性

返回 Node 对象参考手册

定义和用法

nodeType 属性可返回节点的节点类型。

语法：

nodeObject.nodeType

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可显示根节点的节点名称和节点类型：

xmlDoc=loadXMLDoc("books.xml");

document.write("Nodename: " + xmlDoc.nodeName);
document.write(" (nodetype: " + xmlDoc.nodeType);

输出：

Nodename: #document (nodetype: 9)

TIY

显示所有元素的节点名称和节点类型
显示所有元素的节点名称和节点值

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM nodeValue 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM nodeValue 属性

返回 Attr 对象参考手册

定义和用法

nodeValue 属性根据节点的类型设置或返回节点的值。

语法：

attrObject.nodeValue

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段显示 category 属性的节点名称、节点值以及节点类型：

xmlDoc=loadXMLDoc("/example/xdom/books.xml");
var x=xmlDoc.getElementsByTagName('book');

for(i=0;i<x.length;i++)
{
document.write(x.item(i).attributes[0].nodeName);
document.write(" = ");
document.write(x.item(i).attributes[0].nodeValue);
document.write(" (nodetype: ");
document.write(x.item(i).attributes[0].nodeType + ")");
document.write("<br />");
}

以上代码的输出：

category = children (nodetype: 2)
category = cooking (nodetype: 2)
category = web (nodetype: 2)
category = web (nodetype: 2)

TIY

显示属性的 nodeName 、nodeValue 以及 nodeType

返回 Attr 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM nodeValue 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM nodeValue 属性

返回 Node 对象参考手册

定义和用法

nodeValue 属性可设置或返回某节点的值，根据其类型。

语法：

nodeObject.nodeValue

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可显示根节点的节点名称和节点值：

xmlDoc=loadXMLDoc("books.xml");

document.write("Nodename: " + xmlDoc.nodeName);
document.write(" (value: " + xmlDoc.childNodes[0].nodeValue);

输出：

Nodename: #document (value: version="1.0" encoding="ISO-8859-1"

TIY

显示所有元素的节点名称和节点类型
显示所有元素的节点名称和节点值

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM nodeValue 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM nodeValue 属性

返回 Document 对象参考手册

定义和用法

nodeValue属性可根据节点的类型来设置或返回某个节点的值。

语法：

documentObject.nodeValue

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可显示根节点的节点名称和节点值：

xmlDoc=loadXMLDoc("books.xml");

document.write("Nodename: " + xmlDoc.nodeName);
document.write(" (value: " + xmlDoc.childNodes[0].nodeValue);

输出：

Nodename: #document (value: version="1.0" encoding="ISO-8859-1"

TIY

显示所有元素的节点名称和节点类型
显示所有元素的节点名称和节点值

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM normalize() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM normalize() 方法

返回 Node 对象参考手册

定义和用法

合并相邻的 Text 节点并删除空的 Text 节点。

语法：

nodeObject.normalize()

说明

这个方法将遍历当前节点的所有子孙节点，通过删除空的 Text 节点，已经合并所有相邻的 Text 节点来规范化文档。该方法在进行节点的插入或删除操作后，对于简化文档树的结构很有用。

参阅

Text

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM ownerDocument 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM ownerDocument 属性

返回 Attr 对象参考手册

定义和用法

ownerDocument 属性返回节点所属的根元素（Document 对象）。

语法：

attrObject.ownerDocument

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段返回 XML 文档中第一个 category 属性节点的根元素：

xmlDoc=loadXMLDoc("/example/xdom/books.xml");

x=xmlDoc.getElementsByTagName('book');

document.write(x.item(0).attributes[0].ownerDocument);
document.write("<br />");
document.write(x.item(0).attributes[0].ownerDocument.nodeName);
document.write("<br />");
document.write(x.item(0).attributes[0].ownerDocument.nodeType);

以上代码的输出：

[object XMLDocument]
#document
9

TIY

ownerDocument - 获取属性节点所属的根元素（document 对象）

返回 Attr 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM ownerDocument 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM ownerDocument 属性

返回 Element 对象参考手册

定义和用法

ownerDocument 属性返回选定的元素所属的文档对象。

语法：

elementNode.ownerDocument

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段获取 "books.xml" 中第一个 <title> 元素的属主文档的名称和节点类型：

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName("title")[0];
x=x.ownerDocument;

document.write("Nodename: " + x.nodeName);
document.write(" (nodetype: " + x.nodeType + ")");

以上代码的输出：

Nodename: #document (nodetype: 9)

TIY

ownerDocument - 获取节点的属主文档

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM ownerDocument 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM ownerDocument 属性

返回 Node 对象参考手册

定义和用法

ownerDocument 可返回某元素的根元素。

语法：

nodeObject.ownerDocument

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可XML文档中首个 <title> 节点的根元素：

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName("title")[0].ownerDocument;

document.write("Nodename: " + x.nodeName);
document.write(" (nodetype: " + x.nodeType + ")");

输出：

Nodename: #document (nodetype: 9)

TIY

ownerDocument - 取得某个节点的根元素（document对象）

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM ownerElement 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM ownerElement 属性

返回 Attr 对象参考手册

定义和用法

ownerElement 属性返回 attribute 所附属的元素节点。

语法：

attrObject.ownerElement

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段返回第一个 category 属性所附属的元素：

xmlDoc=loadXMLDoc("/example/xdom/books.xml");

x=xmlDoc.getElementsByTagName('book');

document.write(x.item(0).attributes[0].ownerElement);
document.write("<br />");
document.write(x.item(0).attributes[0].ownerElement.nodeName);
document.write("<br />");
document.write(x.item(0).attributes[0].ownerElement.nodeType);

以上代码的输出：

[object Element]
book
1

TIY

ownerElement - 获取属性所属的元素节点

返回 Attr 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM parentNode 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM parentNode 属性

返回 Element 对象参考手册

定义和用法

parentNode 属性返回指定节点的父节点。

语法：

elementNode.parentNode

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段获取 "books.xml" 中第一个 <title> 元素的父节点：

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName("title")[0];
var parent=x.parentNode;

document.write("Parent node: " + parent.nodeName);

以上代码的输出：

Parent node: book

TIY

parentNode - 获取元素的父节点

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM parentNode 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM parentNode 属性

返回 Node 对象参考手册

定义和用法

parentNode 属性可返回某节点的父节点。

语法：

nodeObject.parentNode

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可返回首个 <title> 元素的父节点：

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName("title")[0];
var parent=x.parentNode;

document.write("Parent node: " + parent.nodeName);

输出：

Parent node: book

TIY

parentNode - 取得一个节点的父节点

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM prefix 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM prefix 属性

返回 Attr 对象参考手册

定义和用法

prefix 属性设置或返回属性的 namespace 前缀。

语法：

attrObject.prefix

实例

在所有的例子中，我们将使用 XML 文件 books_ns.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段返回 "lang" 属性的 namespace 前缀：

xmlDoc=loadXMLDoc("books_ns.xml");

x=xmlDoc.getElementsByTagName('title');

for(i=0;i<x.length;i++)
{
document.write(x.item(i).attributes[0].prefix);
document.write("<br />");
}

以上代码的输出：

c
x

TIY

获取属性的前缀、本地名称、命名空间 URI 以及基准 URI

返回 Attr 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM prefix 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM prefix 属性

返回 Element 对象参考手册

定义和用法

prefix 属性返回选定的节点的命名空间前缀。

如果选定的节点不是元素或属性，则该属性返回 NULL。

语法：

elementNode.prefix

实例

在所有的例子中，我们将使用 XML 文件 books_ns.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段获取 "books_ns.xml" 中的第一个 <title> 元素的命名空间前缀：

xmlDoc=loadXMLDoc("books_ns.xml");
x=xmlDoc.getElementsByTagName("title")[0];

document.write(x.prefix);

以上代码的输出：

c

TIY

prefix - 从节点获取命名空间前缀

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM prefix 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM prefix 属性

返回 Node 对象参考手册

定义和用法

prefix 属性可设置或返回节点的命名空间前缀。

语法：

nodeObject.prefix

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可返回 <title> 元素的命名空间前缀：

xmlDoc=loadXMLDoc("books_ns.xml");

var x=xmlDoc.getElementsByTagName('title');

for(i=0;i<x.length;i++)
  {
  document.write(x.item(i).prefix);
  document.write("<br />");
  }

输出：

c
x

TIY

取得某个空间的前缀、本地命名、命名空间 URI 以及基准 URI

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM preventDefault() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM preventDefault() 方法

返回 Event 对象参考手册

定义和用法

preventDefault() 方法取消事件的默认动作。

语法

event.preventDefault()

说明

该方法将通知 Web 浏览器不要执行与事件关联的默认动作（如果存在这样的动作）。例如，如果 type 属性是 "submit"，在事件传播的任意阶段可以调用任意的事件句柄，通过调用该方法，可以阻止提交表单。注意，如果 Event 对象的 cancelable 属性是 fasle，那么就没有默认动作，或者不能阻止默认动作。无论哪种情况，调用该方法都没有作用。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


XML DOM previousSibling 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM previousSibling 属性

返回 Element 对象参考手册

定义和用法

previousSibling 属性返回选定节点的上一个同级节点（在相同树层级中的前一个节点）。

如果不存在这样的节点，则该属性返回 null。

语法：

elementNode.previousSibling

提示和注释

注释：Internet Explorer 会忽略节点之间生成的空白文本节点（比如换行字符），而 Mozilla 不这么做。因此，在下面的例子中，我们用一个函数来检测上一个同级节点的节点类型。

元素节点的节点类型是 1，因此假如上一个同级节点不是元素节点，则移动到上一个节点，并检测该节点是否是元素节点。这个过程一直持续到找到上一个同级节点为止。这种方法可以确保在 Internet Explorer 和 Mozilla 都获得正确的结果。

如需更多有关 IE 与 Mozilla 浏览器差异的内容，请访问 W3School 的 XML DOM 教程中的 DOM 浏览器 这一节。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段获取 XML 文档中第一个 <author> 元素的上一个同级节点：

//check if the previous sibling node is an element node
function get_previoussibling(n)
{
var x=n.previousSibling;
while (x.nodeType!=1)
  {
  x=x.previousSibling;
  }
return x;
}

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName("author")[0];
document.write(x.nodeName);
document.write(" = ");
document.write(x.childNodes[0].nodeValue);

var y=get_previoussibling(x);

document.write("<br />Previous sibling: ");
document.write(y.nodeName);
document.write(" = ");
document.write(y.childNodes[0].nodeValue);

以上代码的输出：

author = Giada De Laurentiis
Previous sibling: title = Everyday Italian

TIY

nextSibling - 获取节点的下一个同级节点
previousSibling - 获取节点的上一个同级节点

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM previousSibling 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM previousSibling 属性

返回 Node 对象参考手册

定义和用法

previousSibling 属性可返回某节点之前紧跟的节点（处于同一树层级）

如果没有此节点，那么该属性返回 null。

语法：

nodeObject.previousSibling

提示和注释

注释：Internet Explorer 会忽略节点间生成的空白文本节点（例如，换行符号），而 Mozilla 不会这样做。因此，在下面的例子中，我们会使用一个函数来检查首个子节点的节点类型。

元素节点的节点类型是 1，因此如果首个子节点不是一个元素节点，它就会移至下一个节点，然后继续检查此节点是否为元素节点。整个过程会一直持续到首个元素子节点被找到为止。通过这个方法，我们就可以在 Internet Explorer 和 Mozilla 得到正确的方法。

提示：如需更多有关 IE 与 Mozilla 浏览器之间 XML DOM 的差异的内容，请访问我们的 DOM 浏览器 章节。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可从XML文档中 <author> 元素取得前一个同级节点：

//check if the previous sibling node is an element node
function get_previoussibling(n)
{
var x=n.previousSibling;
while (x.nodeType!=1)
{
x=x.previousSibling;
}
return x;
}

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName("author")[0];
document.write(x.nodeName);
document.write(" = ");
document.write(x.childNodes[0].nodeValue);

var y=get_previoussibling(x);

document.write("<br />Previous sibling: ");
document.write(y.nodeName);
document.write(" = ");
document.write(y.childNodes[0].nodeValue);

输出：

author = Giada De Laurentiis
Previous sibling: title = Everyday Italian

TIY

previousSibling - 取得某节点的上一个同级节点
nextSibling - 取得某节点的下一个同级节点

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM removeAttribute() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM removeAttribute() 方法

返回 Element 对象参考手册

定义和用法

removeAttribute() 方法删除指定的属性。如果文档类型声明 (DTD) 为指定的属性设置了默认值，那么接下来调用 getAttribute() 方法将返回那个默认值。

删除不存在的属性或没有设置但具有默认值属性的操作将被忽略。

语法：

elementNode.removeAttribute(name)
参数 | 描述
name | 必需。规定要删除的属性的名称。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段删除 "books.xml" 中所有 <book> 元素的 "category" 属性：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName('book');

for (i=0;i<x.length;i++)
{
x[i].removeAttribute('category'));
}

TIY

removeAttributes() - 删除属性

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM removeAttributeNode() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM removeAttributeNode() 方法

返回 Element 对象参考手册

定义和用法

removeAttributeNode() 方法从元素中删除指定的属性节点。

语法：

elementNode.removeAttributeNode(node)
参数 | 描述
node | 必需。要删除的节点。

返回值

删除的 Attr 节点。

说明

该方法从当前元素的属性集合中删除（并返回）一个 Attr 节点。如果 DTD 给删除的属性设置了默认值，那么该方法将添加一个新的 Attr 节点，表示这个默认值。用 removeAttribute() 方法代替该方法往往会更简单。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面代码片段从 "books.xml" 中的所有 <book> 元素中删除 "category" 属性：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName('book');

for(i=0;i<x.length;i++)
{
attnode=x.item(i).getAttributeNode("category");
old_att=x.item(i).removeAttributeNode(attnode);
document.write("Removed attribute: " + old_att.name + "<br />");
}

输出：

Removed attribute: category
Removed attribute: category
Removed attribute: category
Removed attribute: category

TIY

removeAttributeNode() - 删除属性节点

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM removeAttributeNS() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM removeAttributeNS() 方法

返回 Element 对象参考手册

定义和用法

removeAttributeNS() 方法删除由命名空间和名称指定的属性。

语法：

elementNode.removeAttributeNS(ns,name)
参数 | 描述
ns | 必需。规定要删除的属性的名字空间。
name | 必需。规定要删除的属性的名称。

实例

在所有的例子中，我们将使用 XML 文件 books_ns.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段从 "books_ns.xml" 中的第一个 <title> 元素删除 "lang" 属性：

xmlDoc=loadXMLDoc("books_ns.xml");

x=xmlDoc.getElementsByTagName("title")[0];
ns="http://www.w3school.com.cn/children/";

document.write("Attribute Found: ");
document.write(x.hasAttributeNS(ns,"lang"));

x.removeAttributeNS(ns,"lang");

document.write("<br />Attribute Found: ");
document.write(x.hasAttributeNS(ns,"lang"));

输出：

Attribute Found: true
Attribute Found: false

TIY

removeAttributeNS() - 通过名称和名字空间删除属性

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM removeChild() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM removeChild() 方法

返回 Element 对象参考手册

定义和用法

removeChild() 方法删除子节点。

如成功，则返回被删除的节点，否则返回 NULL。

语法：

elementNode.removeChild(node)
参数 | 描述
node | 必需。规定要删除的子节点。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面对代码片段删除第一个 <book> 元素中最后一个子节点：

//check if last child node is an element node
function get_lastchild(n)
{
x=n.lastChild;
while (x.nodeType!=1)
  {
  x=x.previousSibling;
  }
return x;
}

xmlDoc=loadXMLDoc("books.xml");
x=xmlDoc.getElementsByTagName("book")[0];

deleted_node=x.removeChild(get_lastchild(x));
document.write("Node removed: " + deleted_node.nodeName);

输出：

Node removed: price

注释：Internet Explorer 会忽略节点间生成的空白文本节点（例如，换行符号），而 Mozilla 不会这样做。因此，在上面的例子中，我们创建了一个函数来获取正确的子元素。

提示：如需更多有关 IE 与 Mozilla 浏览器差异的内容，请访问 W3School 的 XML DOM 教程中的 DOM 浏览器 这一节。

TIY

removeChild() - 从 nodelist 中删除最后一个子节点

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM removeChild() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM removeChild() 方法

返回 Node 对象参考手册

定义和用法

removeChild() 方法可从子节点列表中删除某个节点。

如删除成功，此方法可返回被删除的节点，如失败，则返回 NULL。

语法：

nodeObject.removeChild(node)
参数 | 描述
node | 必需。指定需要删除的节点。

提示和注释

注释：Internet Explorer 会忽略节点间生成的空白文本节点（例如，换行符号），而 Mozilla 不会这样做。因此，在下面的例子中，我们会使用一个函数来检查最后一个子节点的节点类型。

元素节点的节点类型是1，因此如果首个子节点不是一个元素节点，它就会移至下一个节点，然后继续检查此节点是否为元素节点。整个过程会一直持续到首个元素子节点被找到为止。通过这个方法，我们就可以在 Internet Explorer 和 Mozilla 得到正确的方法。

提示：如需更多有关 IE 与 Mozilla 浏览器之间 XML DOM 的差异的内容，请访问我们的 DOM 浏览器 章节。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可删除首个 <book> 元素中的最后一个子节点：

//check if last child node is an element node
function get_lastchild(n)
{
var x=n.lastChild;
while (x.nodeType!=1)
  {
  x=x.previousSibling;
  }
return x;
}

xmlDoc=loadXMLDoc("books.xml");
var x=xmlDoc.getElementsByTagName("book")[0];

deleted_node=x.removeChild(get_lastchild(x));
document.write("Node removed: " + deleted_node.nodeName);

输出：

Node removed: price

TIY

removeChild() - 从节点列表删除最后一个子节点

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM removeNamedItem() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM removeNamedItem() 方法

返回 NamedNodeMap 对象参考手册

定义和用法

removeNamedItem() 方法可删除指定的节点。

如果被删除的属性拥有默认值，那么一个新的属性会立即产生，连同命名空间 URI、本地名称、前缀。

此方法可返回被删除的节点。

语法：

removeNamedItem(nodename)
参数 | 描述
nodename | 需删除节点的名称

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可循环遍历 <book> 元素，并删除 category 属性：

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName('book');

for(i=0;i<x.length;i++)
  {
  x.item(i).attributes.removeNamedItem("category");
  }

TIY

removeNamedItem() - 删除一个项目

返回 NamedNodeMap 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM removeParameter() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM removeParameter() 方法

返回 XSLTProcessor 对象参考手册

定义和用法

removeParameter() 方法删除一个参数值。

语法：

removeParameter(namespaceURI,localName)
参数 | 描述
namespaceURI | 参数的命名空间。
localName | 参数的名称。

说明

removeParameter() 删除指定的参数的值，如果这个参数之前用 setParameter() 设置过的话。后续的转换使用样式表中指定的这个参数的默认值。

返回 XSLTProcessor 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM renameNode() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM renameNode() 方法

返回 Document 对象参考手册

定义和用法

renameNode()方法重命名已有的元素节点或属性节点。

如有可能，此方法会改变所给定节点的名称，否则此方法会使用指定的名称来创建一个新节点，然后用此新节点来替换已有节点。

此方法返回已重新命名的节点。

语法：

renameNode(node,uri,name)
参数 | 描述
node | 需要重新命名的元素或属性。
uri | 字符串，规定新的命名空间名称。
name | 字符串，规定新的名称

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM replaceChild() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM replaceChild() 方法

返回 Element 对象参考手册

定义和用法

replaceChild() 方法用其他节点替换某个子节点。

如成功，该方法返回被替换的节点，如失败，则返回 null。

语法：

elementNode.replaceChild(new_node,old_node)
参数 | 描述
new_node | 必需。规定新的节点。
old_node | 必需。规定要替换的子节点。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段替换 "books.xml" 中第一个 <book> 元素的第一个 <title> 元素：

//check if first child node is an element node
function get_firstchild(n)
{
x=n.firstChild;
while (x.nodeType!=1)
  {
  x=x.nextSibling;
  }
return x;
}

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("book")[0];

//create a title element and a text node
newNode=xmlDoc.createElement("title");
newText=xmlDoc.createTextNode("Giada's Family Dinners");

//add the text node to the title node,
newNode.appendChild(newText);

//replace the last node with the new node
x.replaceChild(newNode,get_firstchild(x));

y=xmlDoc.getElementsByTagName("title");

for (i=0;i<y.length;i++)
{
document.write(y[i].childNodes[0].nodeValue);
document.write("<br />");
}

输出：

Giada's Family Dinners
Harry Potter
XQuery Kick Start
Learning XML

注释：Internet Explorer 会忽略节点间生成的空白文本节点（例如，换行符号），而 Mozilla 不会这样做。因此，在上面的例子中，我们创建了一个函数来创建正确的子元素。

提示：如需更多有关 IE 与 Mozilla 浏览器差异的内容，请访问 W3School 的 XML DOM 教程中的 DOM 浏览器 这一节。

TIY

replaceChild() - 替换元素节点

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM replaceChild() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM replaceChild() 方法

返回 Node 对象参考手册

定义和用法

replaceChild() 方法可将某个子节点替换为另一个。

如替换成功，此方法可返回被替换的节点，如替换失败，则返回 NULL。。

语法：

nodeObject.replaceChild(new_node,old_node)
参数 | 描述
new_node | 必需。指定新的节点。
old_node | 必需。指定被替换的节点。

提示和注释

注释：Internet Explorer 会忽略节点间生成的空白文本节点（例如，换行符号），而 Mozilla 不会这样做。因此，在下面的例子中，我们会使用一个函数来检查首个子节点的节点类型。

元素节点的节点类型是 1，因此如果首个子节点不是一个元素节点，它就会移至下一个节点，然后继续检查此节点是否为元素节点。整个过程会一直持续到首个元素子节点被找到为止。通过这个方法，我们就可以在 Internet Explorer 和 Mozilla 得到正确的方法。

提示：如需更多有关 IE 与 Mozilla 浏览器之间 XML DOM 的差异的内容，请访问我们的 DOM 浏览器 章节。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可替换首个 <book< 元素中的 <title> 元素：

//check if first child node is an element node
function get_firstchild(n)
{
var x=n.firstChild;
while (x.nodeType!=1)
  {
  x=x.nextSibling;
  }
return x;
}

xmlDoc=loadXMLDoc("books.xml");

//create a title element and a text node
var newNode=xmlDoc.createElement("title");
var newText=xmlDoc.createTextNode("Giada's Family Dinners");
//add the text node to the title node,
newNode.appendChild(newText);

//replace the first child node with the new node
var x=xmlDoc.getElementsByTagName("book")[0];
x.replaceChild(newNode,get_firstchild(x));

//output all titles
var y=xmlDoc.getElementsByTagName("title");
for (i=0;i<y.length;i++)
  {
  document.write(y[i].childNodes[0].nodeValue);
  document.write("<br />");
  }

输出：

Giada's Family Dinners
Harry Potter
XQuery Kick Start
Learning XML

TIY

replaceChild() - 替换某个元素节点

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM replaceData() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM replaceData() 方法

返回 Comment 对象参考手册

定义和用法

replaceData() 方法用指定的字符串替换注释节点中的数据。

语法：

commentNode.replaceData(start,length,string)
参数 | 描述
start | 必需。规定再何处替换字符。该值从 0 开始。
length | 必需。要替换的字符的数量。
string | 必需。要替换由 start 和 length 指定的字符的字符串。

描述

该方法用字符串 string 替换从 start 开始的 length 个字符。如果 start 加 length 大于 Comment 节点的长度，那么从 start 开始的所有字符都讲被替换。

实例

以下代码段使用 JavaScript 函数 loadXMLDoc() 把 XML 文件 books_comment.xml 载入 xmlDoc 中，然后用 "Paperback" 替换第一个 <book> 元素的注释节点中的 "Hardcover"：

xmlDoc=loadXMLDoc("books_comment.xml");

x=xmlDoc.getElementsByTagName("book")[0].childNodes;

for (i=0;i<x.length;i++)
{
if (x[i].nodeType==8)
  {
  //仅仅处理 comment 节点
  x[i].replaceData(10,9,"Easy");
  document.write(x[i].data);
  document.write("<br />");
  }
}

以上代码的输出：

(Book 6) (Paperback)

在本例中，我们使用一段循环和 if 语句来执行只针对 comment 节点的处理。comment 节点的节点类型是 8。

TIY

replaceData() - 替换注释节点中的数据

返回 Comment 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM replaceData() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM replaceData() 方法

返回 Text 对象参考手册

定义和用法

replaceData() 方法替换文本节点中的数据。

语法：

replaceData(start,length,string)
参数 | 描述
start | 必需。规定在何处替换字符。开始值以 0 开始。
length | 必需。规定替换多少个字符。
string | 必需。规定插入的字符串。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段用 "Easy" 替换 <title> 元素的文本节点的前 8 个字符：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("title")[0].childNodes[0];

x.replaceData(0,8,"Easy");

document.write(x.nodeValue);

输出：

Easy Italian

TIY

replaceData() - 替换文本节点中的数据

返回 Text 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM reset() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM reset() 方法

返回 XSLTProcessor 对象参考手册

定义和用法

reset() 方法把一个 XSLTProcessor 恢复为默认状态。

语法：

reset()

说明

这个方法把一个 XSLTProcessor 恢复为它的默认状态，就是它第一次创建时所处的状态。在调用这个方法之后，就没有和 XSLTProcessor 相关联的样式表和参数。

返回 XSLTProcessor 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM selectNodes() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM selectNodes() 方法

返回 Node 对象参考手册

定义和用法

selectNodes() 方法用一个 XPath 查询选择节点。

语法：

nodeObject.selectNodes(query)
参数 | 描述
query | XPath 查询串。

返回值

包含了匹配查询的节点的一个 NodeList。

说明

这个特定于 IE 的方法计算一个 XPath 表达式，使用该节点作为查询的根节点，并且将结果作为一个 NodeList 返回。这个 selectNodes() 方法只用于 XML 文档节点，不用于 HTML 文档节点。注意，既然 Document 对象是它们自己的节点，这个方法可以应用于整个 XML 文档。

参阅 Document.evaluate()，了解一个跨浏览器的替代方法。

参阅

Document.createExpression()

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM selectSingleNode() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM selectSingleNode() 方法

返回 Node 对象参考手册

定义和用法

selectSingleNode() 方法查找和 XPath 查询匹配的一个节点。

语法：

nodeObject.selectSingleNode(query)
参数 | 描述
query | XPath 查询串。

返回值

匹配查询的一个单独的 Node。如果没有，则为 null。

说明

这个特定于 IE 的方法计算一个 XPath 表达式，使用这个节点作为 context 节点。它返回找到的第一个匹配节点，如果没有匹配的节点就返回 null。

这个 selectSingleNode() 方法只在 XML 文档节点上存在，在 HTML 文档中不存在。注意，既然 Document 对象是它们自己的节点，这个方法可以应用于整个 XML 文档。

参阅 Document.evaluate()，了解一个跨浏览器的替代方法。

参阅

Document.createExpression()

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM setAttribute() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM setAttribute() 方法

返回 Element 对象参考手册

定义和用法

setAttribute() 方法创建或改变某个新属性。

语法：

elementNode.setAttribute(name,value)
参数 | 描述
name | 必需。规定要设置的属性名。
value | 必需。规定要设置的属性值。

说明

该方法把指定的属性设置为指定的值。如果不存在具有指定名称的属性，该方法将创建一个新属性。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段向 "books.xml" 中的所有 <book> 元素添加一个 "edition" 属性：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("book");

for(i=0;i<x.length;i++)
{
x.item(i).setAttribute("edition","first");
}

//Output book title and edition value
x=xmlDoc.getElementsByTagName("title");
for (i=0;i<x.length;i++)
{
document.write(x[i].childNodes[0].nodeValue);
document.write(" - Edition: ");
document.write(x[i].parentNode.getAttribute('edition'));
document.write("<br />");
}

输出：

Everyday Italian - Edition: FIRST
Harry Potter - Edition: FIRST
XQuery Kick Start - Edition: FIRST
Learning XML - Edition: FIRST

TIY

setAttribute() - 改变属性的值
setAttribute() - 创建新的属性和属性值

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM setAttributeNode() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM setAttributeNode() 方法

返回 Element 对象参考手册

定义和用法

setAttributeNode() 方法添加新的属性节点。

如果元素中已经存在指定名称的属性，那么该属性将被新属性替代。如果新属性替代了已有的属性，则返回被替代的属性，否则返回 NULL。

语法：

elementNode.setAttributeNode(att_node)
参数 | 描述
att_node | 必需。规定要设置的属性节点。

说明

该方法将给 Element 节点的属性集合添加新的 Attr 节点。如果当前 Element 已经具有一个同名的属性，该方法将用新属性替换那个属性，返回被替换的 Attr 节点。如果不存在这样的属性，该方法将为 Element 定义一个新属性。

通常，用 setAttribute() 方法比用 setAttributeNode() 简单。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码向 "books.xml" 中的所有 <book> 元素添加了 "edition" 属性：

xmlDoc=loadXMLDoc("books_ns.xml");

x=xmlDoc.getElementsByTagName("book")[0];
ns="http://www.w3school.com.cn/edition/";

x.setAttributeNS(ns,"edition","first");

document.write(x.getAttributeNS(ns,"edition"));

输出：

first

TIY

setAttributeNode() - 创建并插入一个新的 Attr 节点

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM setAttributeNS() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM setAttributeNS() 方法

返回 Element 对象参考手册

定义和用法

setAttributeNS() 方法创建或改变具有命名空间的属性。

语法：

elementNode.setAttributeNS(name,value)
参数 | 描述
ns | 必需。规定要设置的属性的命名空间 URI。
name | 必需。规定要设置的属性的名称。
value | 必需。规定要设置的属性的值。

说明

该方法与 setAttribute() 方法类似，只是要创建或设置的属性由命名空间 URI 和限定名（由名字空间前缀、冒号和名字空间中的本地名构成）共同指定。除了可以改变一个属性的值以外，使用该方法还可以改变属性的名字空间前缀。

只有使用名字空间的 XML 文档才会使用该方法。不支持 XML 文档的浏览器可能不会实现该方法。

实例

在所有的例子中，我们将使用 XML 文件 books_ns.xml，以及 JavaScript 函数 loadXMLDoc()。

例子 1

下面的代码向 "books_ns.xml" 中的第一个 <book> 元素添加一个 "edition" 属性：

xmlDoc=loadXMLDoc("books_ns.xml");

x=xmlDoc.getElementsByTagName("book")[0];
ns="http://www.w3school.com.cn/edition/";

x.setAttributeNS(ns,"edition","first");

document.write(x.getAttributeNS(ns,"edition"));

输出：

first

例子 2

下面的代码更改了 "books_ns.xml" 中第一个 <title> 元素的 "lang" 属性的值：

xmlDoc=loadXMLDoc("books_ns.xml");

x=xmlDoc.getElementsByTagName("title")[0];
ns="http://www.w3school.com.cn/children/";

x.setAttributeNS(ns,"c:lang","italian");

document.write(x.getAttributeNS(ns,"lang"));

输出：

italian

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM setParameter() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM setParameter() 方法

返回 XSLTProcessor 对象参考手册

定义和用法

setParameter() 方法设置一个样式表参数。

语法：

setParameter(namespaceURI,localName,value)
参数 | 描述
namespaceURI | 参数的命名空间。
localName | 参数的名称。
value | 参数的值。

说明

这个方法为指定的样式表参数指定一个值。

返回 XSLTProcessor 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM snapshotItem() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM snapshotItem() 方法

返回 XPathResult 对象参考手册

定义和用法

iterateNext() 方法返回与一个 XPath 查询匹配的一个节点。

语法：

snapshotItem(index)
参数 | 描述
index | 要返回的节点的下标。

返回值

指定下标的节点，如果下标小于 0 或者大于或等于 snapshotLength，则为 null。

抛出

如果 resultType 不是 UNORDERED_NODE_SNAPSHOT_TYPE 或 ORDERED_NODE_SNAPSHOT_TYPE 的时候调用，该方法会抛出异常。

返回 XPathResult 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM specified 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM specified 属性

返回 Attr 对象参考手册

定义和用法

如果在文档中设置了属性值，则 specified 属性返回 true，如果是 DTD/Schema 中的默认值，则返回 false。

语法：

attrObject.specified

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段显示 category 属性的名称和值：

xmlDoc=loadXMLDoc("/example/xdom/books.xml");

x=xmlDoc.getElementsByTagName('book');
for(i=0;i<x.length;i++)
{
document.write(x.item(i).attributes[0].specified);
document.write("<br />");
}

以上代码的输出：

true
true
true
true

TIY

返回是否在文档中设置了属性值

返回 Attr 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM splitText() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM splitText() 方法

返回 Text 对象参考手册

定义和用法

splitText() 方法按照指定的 offset 把文本节点分割为两个节点。

语法：

replaceData(offset)
参数 | 描述
offset | 必需。规定在何处分割文本节点。开始值以 0 开始。

返回值

从当前节点分割出的 Text 节点。

说明

该方法将在指定的 offset 处把 Text 节点分割成两个节点。原始的 Text 节点将被修改，使它包含 offset 指定的位置之前的文本内容（但不包括文本内容）。新的 Text 节点将被创建，用于存放从 offset 位置（包括该位置上的字符）到原字符结尾的所有字符。新的 Text 节点是该方法的返回值。此外，如果原始的 Text 节点具有 parentNode，新的 Text 节点将插入这个父节点，紧邻在原始节点之后。

CDATASection 接口继承了 Text 接口，CDATASection 节点也可以使用该方法 ，只是新创建的节点是 CDATASection 节点，而不是 Text 节点。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段将在第一个单词之后分割 Text 节点：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("title")[0].childNodes[0];
y=x.splitText(9);

document.write(x.nodeValue);
document.write("<br />");
document.write(y.nodeValue);

输出：

Everyday
Italian

TIY

replaceData() - 替换文本节点中的数据

参阅

Node.normalize()

返回 Text 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM stopPropagation() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM stopPropagation() 方法

返回 Event 对象参考手册

定义和用法

通过调用 stopPropagation() 方法，可以使事件不再被派发。

语法

event.stopPropagation()

说明

该方法将停止事件的传播，阻止它被分派到其他 Document 节点。在事件传播的任何阶段都可以调用它。注意，虽然该方法不能阻止同一个 Document 节点上的其他事件句柄被调用，但是它可以阻止把事件分派到其他节点。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


XML DOM strictErrorChecking 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM strictErrorChecking 属性

返回 Document 对象参考手册

定义和用法

strictErrorChecking 属性可设置或返回是否强制进行错误检查（error-checking）。

在设置为 false 后，实现不会对每个可能的错误情况进行测试。此属性被默认设置为 true。

语法：

documentObject.strictErrorChecking

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可返回错误检查是否被设置为强制执行：

xmlDoc=loadXMLDoc("books.xml");

var errCheck=xmlDoc.strictErrorChecking;
document.write(errCheck);

输出：

true

TIY

检测错误检查是否被设置为强制执行

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM substringData() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM substringData() 方法

返回 Comment 对象参考手册

定义和用法

substringData() 方法从注释节点中提取子串。

语法：

commentNode.substringData(start,length)
参数 | 描述
start | 必需。规定要返回的第一个字符的位置。该值从 0 开始。
length | 必需。规定要返回的子串中的字符数。

返回值

返回一个字符串，包含 Comment 节点中从 start 开始的 length 个字符。

描述

该方法从 Comment 节点返回从 start 开始的 length 个字符。只有当节点包含的文本的字符数大于浏览器的 JavaScript 实现中能填入的字符串的最大字符数，该方法才有用。在这种情况下，JavaScript 程序不能直接使用 Comment 节点的 data 属性，而必须用节点文本的较短子串。在实际应用中，这种情况不太可能出现。

实例

以下代码段使用 JavaScript 函数 loadXMLDoc() 把 XML 文件 books_comment.xml 载入 xmlDoc 中，然后从第一个注释节点中返回子串（"Hardcover"）：

xmlDoc=loadXMLDoc("books_comment.xml");

x=xmlDoc.getElementsByTagName("book")[0].childNodes;

for (i=0;i<x.length;i++)
{
if (x[i].nodeType==8)
  {
  //仅仅处理 comment 节点
  y=x[i].substringData(10,9);
  document.write(x[i].data);
  document.write("<br />");
  }
}

以上代码的输出：

(Hardcover)

在本例中，我们使用一段循环和 if 语句来执行只针对 comment 节点的处理。comment 节点的节点类型是 8。

TIY

substringData() - 从注释节点返回子串

返回 Comment 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM substringData() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM substringData() 方法

返回 Text 对象参考手册

定义和用法

substringData() 方法从文本节点中获取数据。

语法：

substringData(start,length)
参数 | 描述
start | 必需。从何处提取字符。开始值以 0 开始。
length | 必需。规定提取多少字符。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段从 "books.xml" 中的第一个 <title> 元素的文本节点中获取了一个片段，并将它输出：

xmlDoc=loadXMLDoc("books.xml");
x=xmlDoc.getElementsByTagName("title")[0].childNodes[0];

y=x.substringData(9,7);

document.write(x.nodeValue);
document.write("<br />");
document.write(y);

输出：

Everyday Italian
Italian

TIY

replaceData() - 替换文本节点中的数据

返回 Text 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM systemId 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM systemId 属性

返回 DocumentType 对象参考手册

定义和用法

systemId 属性可返回外部 DTD 的系统标识符。

语法：

documentObject.doctype.systemId

实例

在所有的例子中，我们将使用 XML 文件 note_internal_dtd.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可显示与 XML 文档相关联的外部 DTD 的系统 id：

xmlDoc=loadXMLDoc("note_external_dtd.xml");
document.write(xmlDoc.doctype.systemId);

输出：

note.dtd

DIY

取得 XML 文档中的外部 DTD 的系统标识符

返回 DocumentType 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM tagName 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM tagName 属性

返回 Element 对象参考手册

定义和用法

tagName 属性返回被选元素的标签名。

语法：

elementNode.tagName

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段获取 "books.xml" 的第一个 <title> 元素的标签名：

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName("title")[0];
document.write(x.tagName);

以上代码的输出：

title

TIY

tagname - 从节点获取标签名

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM target 事件属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM target 事件属性

返回 Event 对象参考手册

定义和用法

target 事件属性可返回事件的目标节点（触发该事件的节点），如生成事件的元素、文档或窗口。

语法

event.target

实例

下面的例子可获得触发事件的元素：

<html>
<head>

<script type="text/javascript">
function getEventTrigger(event)
  {
  x=event.target;
  alert("The id of the triggered element: "
  + x.id);
  }
</script>

</head>
<body >

<p id="p1" onmousedown="getEventTrigger(event)">
Click on this paragraph. An alert box will
show which element triggered the event.</p>

</body>
</html>

TIY

target event
获得触发事件的元素（IE 浏览器不支持）。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


XML DOM text 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM text 属性

返回 Attr 对象参考手册

定义和用法

text 属性返回属性的文本。

语法：

attrObject.text

提示和注释

注释：此属性是 Internet Explorer 专用的。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段显示 XML 文档中 category 属性的文本：

xmlDoc=loadXMLDoc("/example/xdom/books.xml");

x=xmlDoc.getElementsByTagName('book');

for(i=0;i<x.length;i++)
{
document.write(x.item(i).attributes[0].text);
document.write("<br />");
}

以上代码的输出：

children
cooking
web
web

TIY

显示属性的文本

返回 Attr 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM text 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM text 属性

返回 Document 对象参考手册

定义和用法

text 属性可返回某个节点及其后代的文本。

语法：

documentObject.text

提示和注释：

注释：此属性只可用于 Internet Explorer ！

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可显示 XML 文档的文本：

xmlDoc=loadXMLDoc("books.xml");
document.write(xmlDoc.text);

输出：

Harry Potter J K. Rowling 2005 29.99
Everyday Italian Giada De Laurentiis 2005 30.00
Learning XML Erik T. Ray 2003 39.95
XQuery Kick Start James McGovern Per Bothner
Kurt Cagle James Linn Vaidyanathan Nagarajan 2003 49.99

TIY

显示 XML 文档的文本

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM text 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM text 属性

返回 Element 对象参考手册

定义和用法

text 属性返回选定节点中所有文本节点的值。

语法：

elementNode.text

提示和注释：

提示：如需针对 Mozilla 浏览器返回文本节点的文本，请使用 textContent 属性。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段获取 "books.xml" 中第一个 <title> 元素的文本节点：

xmlDoc=loadXMLDoc("books.xml");
var x=xmlDoc.getElementsByTagName("title")[0];

document.write("Text Nodes: ");
document.write(x.text);

以上代码的输出：

Text Nodes: Everyday Italian

TIY

text - 从元素中获取文本节点

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM text 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM text 属性

返回 Node 对象参考手册

定义和用法

text 属性可返回节点及其后代的文本。

语法：

nodeObject.text

提示和注释

注释：此属性只能用于 Internet Explorer ！

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码可显示 XML 文档的文本：：

xmlDoc=loadXMLDoc("books.xml");
document.write(xmlDoc.text);

输出：

Everyday Italian Giada De Laurentiis 2005 30.00
Harry Potter J K. Rowling 2005 29.99 XQuery Kick Start
James McGovern Per Bothner Kurt Cagle James Linn
Vaidyanathan Nagarajan 2003 49.99 Learning XML
Erik T. Ray 2003 39.95

TIY

显示一个 XML 文档的文本

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM textContent 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM textContent 属性

返回 Attr 对象参考手册

定义和用法

textContent 属性设置或返回属性的文本内容。

语法：

attrObject.textContent

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段返回 category 属性的文本内容：

xmlDoc=loadXMLDoc("/example/xdom/books.xml");

x=xmlDoc.getElementsByTagName('book');

for(i=0;i<x.length;i++)
{
document.write(x.item(i).attributes[0].textContent);
document.write("<br />");
}

以上代码的输出：

children
cooking
web
web

TIY

textContent - 获取属性的文本内容（不支持 IE 浏览器）
textContent - 设置属性的文本内容（不支持 IE 浏览器）

返回 Attr 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM textContent 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM textContent 属性

返回 Element 对象参考手册

定义和用法

textContent 属性返回或设置选定元素的文本。

如果返回文本，则该属性返回元素节点内所有文本节点的值。

如果设置文本，则该属性删除所有子节点，并用单个文本节点来替换它们。

语法：

返回文本：

elementNode.textContent

设置文本：

elementNode.textContent=string

提示和注释：

提示：如需针对 IE 浏览器返回文本节点的文本，请使用 text 属性。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

例子 1

下面的代码片段获取 "books.xml" 中第一个 <title> 元素的文本节点：

xmlDoc=loadXMLDoc("books.xml");
var x=xmlDoc.getElementsByTagName("title")[0];

document.write("Text Nodes: ");
document.write(x.textContent);

以上代码的输出：

Text Nodes: Everyday Italian

例子 2

下面的代码片段从 "books.xml" 的第一个 <book> 元素返回文本节点，并用一个新的文本节点替换所有节点：

xmlDoc=loadXMLDoc("books.xml");
var x=xmlDoc.getElementsByTagName("book")[0];

document.write("Before: ");
document.write(x.textContent);

document.write("<br />");
x.textContent="hello";

document.write("After: ");
document.write(x.textContent);

以上代码的输出：

Before: Everyday Italian Giada De Laurentiis 2005 30.00
After: hello

TIY

textContent - 获取元素的文本节点
textContent - 获取元素的文本节点并替换它们

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM textContent 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM textContent 属性

返回 Node 对象参考手册

定义和用法

textContent 属性可设置或返回节点及其后代的文本内容。

关于设置，任何子节点可被删除，并被一个单独的文本节点所替换，所替换的内容是此属性所设置的字符串。

语法：

nodeObject.textContent

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可返回 <book> 元素的文本内容：

xmlDoc=loadXMLDoc("books.xml");

var x=xmlDoc.getElementsByTagName('book');

for(i=0;i<x.length;i++)
  {
  document.write(x.item(i).textContent);
  document.write("<br />");
  }

输出：

Everyday Italian Giada De Laurentiis 2005 30.00
Harry Potter J K. Rowling 2005 29.99
XQuery Kick Start James McGovern Per Bothner Kurt Cagle James Linn
Vaidyanathan Nagarajan 2003 49.99
Learning XML Erik T. Ray 2003 39.95

TIY

textContent - 取得某节点的文本内容（IE 不支持）
textContent - 设置某节点的文本内容（IE 不支持）

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM timeStamp 事件属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM timeStamp 事件属性

返回 Event 对象参考手册

定义和用法

timeStamp 事件属性可返回一个时间戳。指示发生事件的日期和时间（从 epoch 开始的毫秒数）。

epoch 是一个事件参考点。在这里，它是客户机启动的时间。

并非所有系统都提供该信息，因此，timeStamp 属性并非对所有系统/事件都是可用的。

语法

event.timeStamp

实例

下面的例子可获得系统启动开始的事件戳：

<html>
<head>
<script type="text/javascript">
function showTimestamp(event)
  {
  var minutes = 1000*60
  x=event.timeStamp;
  alert(x/minutes)
  }
</script>
</head>

<body onmousedown="showTimestamp(event)">

<p>Click in the document. An alert
box will alert the timestamp.</p>

</body>
</html>

TIY

timestamp event
返回系统启动至今的分钟数（IE 浏览器不支持）。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


XML DOM transformNode() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM transformNode() 方法

返回 Node 对象参考手册

定义和用法

transformNode() 方法使用 XSLT 把一个节点转换为一个字符串。

语法：

nodeObject.transformNode(xslt)
参数 | 描述
query | 一个 XSLT 样式表，解析为一个 Document 对象。

返回值

对该节点及其子孙应用指定的样式而产生的文本。

说明

这个特定于 IE 的方法根据一个 XSLT 样式表指定的规则来转换一个 Node 及其子孙，并将结果作为一个未解析的字符串返回。

这个 transformNode() 方法只在 XML 文档节点上存在，在 HTML 文档中不存在。注意，既然 Document 对象是它们自己的节点，这个方法可以应用于整个 XML 文档。

参阅 XSLTProcessor，了解其他浏览器中的相似功能。

参阅

Node.transformNodeToObject()

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM transformNodeToObject() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM transformNodeToObject() 方法

返回 Node 对象参考手册

定义和用法

transformNodeToObject() 方法使用 XSLT 把一个节点转换为一个文档。

语法：

nodeObject.transformNodeToObject(xslt)
参数 | 描述
query | 一个 XSLT 样式表，解析为一个 Document 对象。

返回值

转换的结果，解析为一个 Document 对象。

说明

这个特定于 IE 的方法根据一个 XSLT 样式表指定的规则来转换一个 Node 及其子孙，并将结果作为一个 Document 对象返回。

这个 transformNode() 方法只在 XML 文档节点上存在，HTML 文档不存在该方法。注意，既然 Document 对象是它们自己的节点，这个方法可以应用于整个 XML 文档。

参阅 XSLTProcessor，了解其他浏览器中的相似功能。

参阅

Node.transformNode()

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM transformToDocument() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM transformToDocument() 方法

返回 XSLTProcessor 对象参考手册

定义和用法

transformToDocument() 方法把一个节点或文档转换为一个新的文档。

语法：

transformToDocument(source)
参数 | 描述
source | 要转换的文档或节点。

返回值

保存了转换结果的一个 Document 对象。

说明

这个方法在一个指定的节点上执行一次 XSLT 转换，结果作为一个 Document 对象返回。

转换使用 importStylesheet() 指定的 XSLT 样式表和 setParameter() 指定的参数值。

返回 XSLTProcessor 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM transformToFragment() 方法

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM transformToFragment() 方法

返回 XSLTProcessor 对象参考手册

定义和用法

transformToFragment() 方法把一个节点或文档转换为一个 DocumentFragment。

语法：

transformToFragment(source,owner)
参数 | 描述
source | 要转换的文档或节点。
owner | 通过返回的 DocumentFragment 创建的文档。返回的 DocumentFragment 的 ownerDocument 属性引用这个文档。

返回值

保存了转换结果的一个 DocumentFragment 对象。

说明

这个方法在一个指定的节点上执行一次 XSLT 转换，结果作为一个 DocumentFragment 对象返回。转换使用 importStylesheet() 指定的 XSLT 样式表和 setParameter() 指定的参数值。返回的片段被插入到指定的 owner 文档中。

返回 XSLTProcessor 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM type 事件属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM type 事件属性

返回 Event 对象参考手册

定义和用法

type 事件属性返回发生的事件的类型，即当前 Event 对象表示的事件的名称。

它与注册的事件句柄同名，或者是事件句柄属性删除前缀 "on" 比如 "submit"、"load" 或 "click"。

语法

event.type

实例

下面的例子可返回被触发的事件的类型：

<html>
<head>
<script type="text/javascript">
function getEventType(event)
  {
  alert(event.type);
  }
</script>
</head>

<body onmousedown="getEventType(event)">

<p>Click somewhere in the document.
An alert box will tell what event
type you triggered.</p>

</body>
</html>

TIY

type event
返回被触发的事件的类型（IE 浏览器不支持）。

返回 Event 对象参考手册

HTML DOM 参考手册
HTML DOM 实例


XML DOM value 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM value 属性

返回 Attr 对象参考手册

定义和用法

value 属性返回属性的值。

语法：

attrObject.value

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段显示 category 属性的名称和值：

xmlDoc=loadXMLDoc("/example/xdom/books.xml");

x=xmlDoc.getElementsByTagName('book');

for(i=0;i<x.length;i++)
{
document.write(x.item(i).attributes[0].name);
document.write(" = ");
document.write(x.item(i).attributes[0].value);
document.write("<br />");
}

以上代码的输出：

category = children
category = cooking
category = web
category = web

TIY

返回属性的名称和值

返回 Attr 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM xml 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM xml 属性

返回 Attr 对象参考手册

定义和用法

xml 属性返回属性的 XML。

语法：

attrObject.xml

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段显示 XML 文档中 category 属性的 XML：

xmlDoc=loadXMLDoc("/example/xdom/books.xml");

x=xmlDoc.getElementsByTagName('book');

for(i=0;i<x.length;i++)
{
document.write("<xmp>" + x.item(i).attributes[0].xml + "</xmp>");
document.write("<br />");
}

以上代码的输出：

category="children"
category="cooking"
category="web"
category="web"

TIY

显示属性的 XML

返回 Attr 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM xml 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM xml 属性

返回 Document 对象参考手册

定义和用法

xml 属性可返回节点及其后代的 XML。

语法：

documentObject.xml

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可显示XML文档的XML：

xmlDoc=loadXMLDoc("books.xml");
document.write("<xmp>" + xmlDoc.xml + "</xmp>");

输出：

<?xml version="1.0" encoding="ISO-8859-1"?>
<!--  Copyright w3school.com.cn -->
<!-- W3School.com.cn bookstore example -->
  <bookstore>
    <book category="children">
    <title lang="en">Harry Potter</title>
    <author>J K. Rowling</author>
    <year>2005</year>
    <price>29.99</price>
  </book>
  <book category="cooking">
    <title lang="en">Everyday Italian</title>
    <author>Giada De Laurentiis</author>
    <year>2005</year>
    <price>30.00</price>
  </book>
  <book category="web" cover="paperback">
    <title lang="en">Learning XML</title>
    <author>Erik T. Ray</author>
    <year>2003</year>
    <price>39.95</price>
  </book>
  <book category="web">
    <title lang="en">XQuery Kick Start</title>
    <author>James McGovern</author>
    <author>Per Bothner</author>
    <author>Kurt Cagle</author>
    <author>James Linn</author>
    <author>Vaidyanathan Nagarajan</author>
    <year>2003</year>
    <price>49.99</price>
  </book>
</bookstore>

TIY

显示 XML 文档的 XML

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM xml 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM xml 属性

返回 Element 对象参考手册

定义和用法

xml 属性返回节点的 XML 及其后代。

语法：

elementNode.xml

提示和注释：

注释：该属性是 Internet Explorer 专用。

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段显示 XML 文档中第一个 <book> 元素的 XML：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("book")[0];
document.write("<xmp>" + x.xml + "</xmp>");

以上代码的输出：

<book category="COOKING">
  <title lang="en">Everyday Italian</title>
  <author>Giada De Laurentiis</author>
  <year>2005</year>
  <price>30.00</price>
</book>

TIY

xml - 显示节点的 XML

返回 Element 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM xml 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM xml 属性

返回 Node 对象参考手册

定义和用法

xml 属性可返回节点及其后代的 XML。

语法：

nodeObject.xml

提示和注释

注释：此属性只能用于 Internet Explorer！

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

下面的代码片段可显示 XML 文档的 XML：

xmlDoc=loadXMLDoc("books.xml");
document.write("<xmp>" + xmlDoc.xml + "</xmp>");

输出：

<?xml version="1.0"?>
<!-- Edited with XML Spy v2007 (http://www.altova.com) -->
<bookstore>
  <book category="COOKING">
    <title lang="en">Everyday Italian</title>
    <author>Giada De Laurentiis</author>
    <year>2005</year>
    <price>30.00</price>
  </book>
  <book category="CHILDREN">
    <title lang="en">Harry Potter</title>
    <author>J K. Rowling</author>
    <year>2005</year>
    <price>29.99</price>
  </book>
  <book category="WEB">
    <title lang="en">XQuery Kick Start</title>
    <author>James McGovern</author>
    <author>Per Bothner</author>
    <author>Kurt Cagle</author>
    <author>James Linn</author>
    <author>Vaidyanathan Nagarajan</author>
    <year>2003</year>
    <price>49.99</price>
  </book>
  <book category="WEB">
    <title lang="en">Learning XML</title>
    <author>Erik T. Ray</author>
    <year>2003</year>
    <price>39.95</price>
  </book>
</bookstore>

TIY

显示 XML 文档的 XML

返回 Node 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM xmlEncoding 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM xmlEncoding 属性

返回 Document 对象参考手册

定义和用法

xmlEncoding 属性可返回文档的编码方法。

语法：

documentObject.xmlEncoding

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可显示 XML 的编码方法、standalone 属性以及文档的 XML 版本：

xmlDoc=loadXMLDoc("books.xml");

document.write("XML encoding: " + xmlDoc.xmlEncoding);
document.write("<br />");
document.write("XML standalone: " + xmlDoc.xmlStandalone);
document.write("<br />");
document.write("XML version: " + xmlDoc.xmlVersion);
document.write("<br />");
document.write("Encoding when parsing: " + xmlDoc.inputEncoding);

输出：

XML encoding: ISO-8859-1
XML standalone: false
XML version: 1.0
Encoding when parsing: ISO-8859-1

TIY

取得 XML 的编码方法、standalone 属性以及文档的 XML 版本

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM xmlStandalone 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM xmlStandalone 属性

返回 Document 对象参考手册

定义和用法

xmlStandalone 属性可设置或返回文档是否为 standalone。

语法：

documentObject.xmlStandalone

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可显示 XML 的编码方法、standalone 属性以及文档的 XML 版本：

xmlDoc=loadXMLDoc("books.xml");

document.write("XML encoding: " + xmlDoc.xmlEncoding);
document.write("<br />");
document.write("XML standalone: " + xmlDoc.xmlStandalone);
document.write("<br />");
document.write("XML version: " + xmlDoc.xmlVersion);
document.write("<br />");
document.write("Encoding when parsing: " + xmlDoc.inputEncoding);

输出：

XML encoding: ISO-8859-1
XML standalone: false
XML version: 1.0
Encoding when parsing: ISO-8859-1

TIY

取得 XML 的编码方法、standalone 属性以及文档的 XML 版本

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM xmlVersion 属性

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM xmlVersion 属性

返回 Document 对象参考手册

定义和用法

xmlVersion 属性可设置或返回文档的 XML 版本。

语法：

documentObject.xmlVersion

实例

在所有的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

以下代码片段可显示 XML 的编码方法、standalone 属性以及文档的 XML 版本：

xmlDoc=loadXMLDoc("books.xml");

document.write("XML encoding: " + xmlDoc.xmlEncoding);
document.write("<br />");
document.write("XML standalone: " + xmlDoc.xmlStandalone);
document.write("<br />");
document.write("XML version: " + xmlDoc.xmlVersion);
document.write("<br />");
document.write("Encoding when parsing: " + xmlDoc.inputEncoding);

输出：

XML encoding: ISO-8859-1
XML standalone: false
XML version: 1.0
Encoding when parsing: ISO-8859-1

TIY

取得 XML 的编码方法、standalone 属性以及文档的 XML 版本

返回 Document 对象参考手册

XML DOM 参考手册
XML DOM 实例


XML DOM 遍历节点树

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM 遍历节点树

  • Previous Page
  • Next Page

遍历 (Traverse) 意味着在节点树中进行循环或移动。

实例

下面的例子使用 XML 文件 books.xml。

函数 loadXMLString()，位于外部 JavaScript 中，用于加载 XML 文件。

遍历一棵节点树
循环 <book> 元素的所有子节点。

遍历节点树

您经常需要循环 XML 文档，比如：当你需要提取每个元素的值时。

这个过程叫作“遍历节点树”。

下面的例子循环 <book> 的所有子节点，并显示它们的名称和值：

<html>
<head>
<script type="text/javascript" src="loadxmlstring.js"></script>
</head>
<body>
<script type="text/javascript">
text="<book>";
text=text+"<title>Harry Potter</title>";
text=text+"<author>J K. Rowling</author>";
text=text+"<year>2005</year>";
text=text+"</book>";

xmlDoc=loadXMLString(text);

// documentElement always represents the root node
x=xmlDoc.documentElement.childNodes;
for (i=0;i<x.length;i++)
{
document.write(x[i].nodeName);
document.write(": ");
document.write(x[i].childNodes[0].nodeValue);
document.write("<br />");
}
</script>
</body>
</html>

输出：

title: Harry Potter
author: J K. Rowling
year: 2005

例子解释：

  • loadXMLString() 把 XML 字符串载入 xmlDoc 中
  • 获取根元素的子节点
  • 输出每个子节点的名称，以及文本节点的节点值

TIY

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM 参考手册

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM 参考手册

  • Previous Page
  • Next Page

我们为您提供了完整的 XML DOM 参考手册，其中包括所有的 XML DOM 对象以及它们的属性和方法。

在每个对象的属性及方法的描述页面中，都提供了关于属性和方法的用法及定义的详细信息，以及相关的实例代码。

此外，我们提供的所有实例代码，您都可以亲自对其进行测试（TIY 功能）。

XML DOM 参考手册目录

  • XML DOM 节点类型
  • XML DOM Attr 对象
  • XML DOM CDATASection 对象
  • XML DOM Comment 对象
  • XML DOM Document 对象
  • XML DOM DocumentFragment 对象
  • XML DOM DocumentType 对象
  • XML DOM DOMException 对象
  • XML DOM DOMParser 对象
  • XML DOM Element 对象
  • XML DOM DomImplementation 对象
  • XML DOM NamedNodeMap 对象
  • XML DOM Node 对象
  • XML DOM NodeList 对象
  • XML DOM parseError 对象
  • XML DOM ProcessingInstruction 对象
  • XML DOM Range 对象
  • XML DOM Text 对象
  • XML DOM XMLHttpRequest 对象
  • XML DOM XMLSerializer 对象
  • XML DOM XPathExpression 对象
  • XML DOM XPathResult 对象
  • XML DOM XSLTProcessor 对象
  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM 创建节点

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM 创建节点

  • Previous Page
  • Next Page

实例

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

创建元素节点
本例使用 createElement() 来创建一个新的元素节点，并使用 appendChild() 把它添加到一个节点。
通过使用 createAttribute 来创建属性节点
本例使用 createAttribute() 来创建新的属性节点，并使用 setAttributeNode() 把该节点插入一个元素中。
通过使用 setAttribute 来创建属性节点
本例使用 setAttribute() 为一个元素创建一个新的属性。
创建文本节点
本例使用 createTextNode() 来创建新的文本节点，并使用 appendChild() 把该文本节点添加到一个元素中。
创建一个 CDATA section 节点
本例用 createCDATAsection() 来创建 CDATA section 节点，并使用 appendChild() 把它添加到元素中。
创建注释节点
本例使用 createComment() 来创建一个 comment 节点，并使用 appendChild() 把它添加到一个元素中。

创建新的元素节点

createElement() 方法创建新的元素节点：

xmlDoc=loadXMLDoc("books.xml");

newel=xmlDoc.createElement("edition");

x=xmlDoc.getElementsByTagName("book")[0];
x.appendChild(newel);

例子解释：

  1. 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  2. 创建一个新的元素节点 <edition>
  3. 向第一个 <book> 元素追加这个元素节点

TIY

遍历并向所有 <book> 元素添加一个元素：TIY

创建新的属性节点

createAttribute() 用于创建新的属性节点：

xmlDoc=loadXMLDoc("books.xml");

newatt=xmlDoc.createAttribute("edition");
newatt.nodeValue="first";

x=xmlDoc.getElementsByTagName("title");
x[0].setAttributeNode(newatt);

例子解释：

  1. 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  2. 创建一个新的属性节点 "edition"
  3. 向第一个 <title> 元素添加这个新的属性节点

TIY

遍历所有 <title> 元素，并添加一个新的属性节点：TIY

注释：如果该属性已存在，则被新属性替代。

通过使用 setAttribute() 来创建属性

由于 setAttribute() 可以在属性不存在的情况下创建新的属性，我们可以使用这个方法来创建新属性。

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName('book');
x[0].setAttribute("edition","first");

例子解释：

  1. 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  2. 为第一个 <book> 元素设置（创建）值为 "first" 的属性

TIY

遍历所有 <title> 元素并添加一个新属性：TIY

创建文本节点

createTextNode() 方法创建新的文本节点：

xmlDoc=loadXMLDoc("books.xml");

newel=xmlDoc.createElement("edition");
newtext=xmlDoc.createTextNode("first");
newel.appendChild(newtext);

x=xmlDoc.getElementsByTagName("book")[0];
x.appendChild(newel);

例子解释：

  1. 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  2. 创建一个新元素节点 <edition>
  3. 创建一个新的文本节点，其文本是 "first"
  4. 向这个元素节点追加新的文本节点
  5. 向第一个 <book> 元素追加新的元素节点

TIY

向所有 <book> 元素添加一个带有文本节点的元素节点：TIY

创建一个 CDATA Section 节点

createCDATASection() 方法创建一个新的 CDATA section 节点。

xmlDoc=loadXMLDoc("books.xml");

newCDATA=xmlDoc.createCDATASection("Special Offer & Book Sale");

x=xmlDoc.getElementsByTagName("book")[0];
x.appendChild(newCDATA);

例子解释：

  1. 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  2. 创建一个新的 CDATA section 节点
  3. 向第一个 <book> 元素追加这个新的 CDATA section 节点

TIY

遍历并向所有 <book> 元素添加一个 CDATA section：TIY

创建注释节点

createComment() 方法创建一个新的注释节点。

xmlDoc=loadXMLDoc("books.xml");

newComment=xmlDoc.createComment("Revised March 2008");

x=xmlDoc.getElementsByTagName("book")[0];
x.appendChild(newComment);

例子解释：

  1. 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  2. 创建一个新的注释节点
  3. 把这个新的注释节点追加到第一个 <book> 元素

TIY

循环并向所有 <book> 元素添加一个 comment 节点：TIY

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM 定位节点

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM 定位节点

  • Previous Page
  • Next Page

可通过使用节点间的关系对节点进行定位。

实例

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

获取节点的父节点
本例使用 parentNode 属性来获取节点的父节点。
获取节点的首个子节点
本例使用 firstChild() 方法和一个自定义函数来获取一个节点的首个子节点。

定位 DOM 节点

通过节点间的关系访问节点树中的节点，通常称为定位节点 （"navigating nodes"）。

在 XML DOM 中，节点的关系被定义为节点的属性：

  • parentNode
  • childNodes
  • firstChild
  • lastChild
  • nextSibling
  • previousSibling

下面的图像展示了 books.xml 中节点树的一个部分，并说明了节点之间的关系：

DOM node tree

DOM - 父节点

所有的节点都仅有一个父节点。下面的代码定位到 <book> 的父节点：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("book")[0];
document.write(x.parentNode.nodeName);

例子解释：

  • 通过使用 loadXMLDoc() 把 "books.xml" 载入到 xmlDoc 中
  • 获取第一个 <book> 元素
  • 输出 "x" 的父节点的节点名

TIY

避免空的文本节点

Firefox，以及其他一些浏览器，把空的空白或换行当作文本节点，而 IE 不会这么做。

这会在使用下列属性使产生一个问题：firstChild、lastChild、nextSibling、previousSibling。

为了避免定位到空的文本节点（元素节点之间的空格和换行符号），我们使用一个函数来检查节点的类型：

function get_nextSibling(n)
{
y=n.nextSibling;
while (y.nodeType!=1)
  {
  y=y.nextSibling;
  }
return y;
}

有了上面的函数，我们就可以使用 get_nextSibling(node) 来代替 node.nextSibling 属性。

代码解释：

元素节点的类型是 1。如果同级节点不是元素节点，就移动到下一个节点，直到找到元素节点为止。通过这个办法，在 IE 和 Firefox 中，都可以得到相同的结果。

获取第一个元素

下面的代码显示第一个 <book> 的第一个元素节点：

<html>
<head>
<script type="text/javascript" src="loadxmldoc.js">
</script>
<script type="text/javascript">
//check if the first node is an element node
function get_firstChild(n)
{
y=n.firstChild;
while (y.nodeType!=1)
  {
  y=y.nextSibling;
  }
return y;
}
</script>
</head>

<body>
<script type="text/javascript">
xmlDoc=loadXMLDoc("books.xml");

x=get_firstChild(xmlDoc.getElementsByTagName("book")[0]);
document.write(x.nodeName);
</script>
</body>
</html>

输出：

title

例子解释：

  • 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  • 在第一个 <book> 上使用 get_firstChild 函数，来获取元素节点中的第一个子节点
  • 输出第一个子节点（属于元素节点）的节点名

TIY

实例

下面的例子使用相似的函数：

  • firstChild: TIY
  • lastChild: TIY
  • nextSibling: TIY
  • previousSibling: TIY
  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM 访问节点

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM 访问节点

  • Previous Page
  • Next Page

通过 DOM，您能够访问 XML 文档中的每个节点。

实例

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

使用节点列表中的下标号来访问节点
本例使用 getElementsByTagname() 方法来获得 "books.xml" 中的第三个 <title> 元素。
使用 length 属性来循环节点
本例使用 length 属性来循环 "books.xml" 中的所有 <title> 元素。
查看元素的节点类型
本例使用 nodeType 属性来获得 "books.xml" 中根元素的节点类型。
循环元素节点
本例使用 nodeType 属性来处理 "books.xml" 中的元素节点。
使用节点的关系来循环元素节点
本例使用 nodeType 属性和 nextSibling 属性来处理 "books.xml" 中的元素节点。

访问节点

您可以通过三种方法来访问节点：

  1. 通过使用 getElementsByTagName() 方法
  2. 通过循环（遍历）节点树
  3. 通过利用节点的关系在节点树中导航

getElementsByTagName() 方法

getElementsByTagName() 返回拥有指定标签名的所有元素。

语法

node.getElementsByTagName("tagname");

实例

下面的例子返回 x 元素下的所有 <title> 元素：

x.getElementsByTagName("title");

请注意，上面的例子仅返回 x 节点下的 <title> 元素。要返回 XML 文档中的所有 <title> 元素，请使用：

xmlDoc.getElementsByTagName("title");

在这里，xmlDoc 就是文档本身（文档节点）。

DOM Node List

getElementsByTagName() 方法返回节点列表 (node list)。节点列表是节点的数组。

下面的代码通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中，然后在变量 x 中存储 <title> 节点的一个列表：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("title");

可通过下标访问 x 中的 <title> 元素。要访问第三个 <title>，您可以编写：

y=x[2];

TIY

注释：下标以 0 起始。

在本教程中稍后的章节，您将学到更多有关 Node List 的知识。

DOM Node List Length

length 属性定义节点列表的长度（即节点的数目）。

您能够通过使用 length 属性来循环一个节点列表：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("title");

for (i=0;i<x.length;i++)
  {
  document.write(x[i].childNodes[0].nodeValue);
  document.write("<br />");
  }

例子解释：

  1. 使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc
  2. 取得所有 <title> 元素节点
  3. 输出每个 <title> 元素的文本节点的值

TIY

Node Type

XML 文档的 documentElement 属性是根节点。

节点的 nodeName 属性是节点的名称。

节点的 nodeType 属性是节点的类型。

您将在本教程的下一节中学习更多有关节点属性的知识。

TIY

遍历节点

下面的代码循环根节点的子节点，同时也是元素节点：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.documentElement.childNodes;

for (i=0;i<x.length;i++)
{
  if (x[i].nodeType==1)
  {//Process only element nodes (type 1)
  document.write(x[i].nodeName);
  document.write("<br />");
  }
}

例子解释：

  1. 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  2. 获得根元素的子节点
  3. 检查每个子节点的节点类型。如果节点类型是 "1"，则是元素节点
  4. 如果是元素节点，则输出节点的名称

TIY

利用节点的关系进行导航

下面的代码通过利用节点的关系在节点树中进行导航：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("book")[0].childNodes;
y=xmlDoc.getElementsByTagName("book")[0].firstChild;

for (i=0;i<x.length;i++)
{
if (y.nodeType==1)
  {//Process only element nodes (type 1)
  document.write(y.nodeName + "<br />");
  }
y=y.nextSibling;
}
  1. 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  2. 获得第一个 book 元素的子节点
  3. 把 "y" 变量设置为第一个 book 元素的第一个子节点
  4. 检查每个子节点的节点类型，如果节点类型是 "1"，则是元素节点
  5. 如果是元素节点，则输出该节点的名称
  6. 把 "y" 变量设置为下一个同级节点，并再次运行循环

TIY

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM 改变节点值

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM 改变节点值

  • Previous Page
  • Next Page

nodeValue 属性用于改变节点值。

setAttribute() 方法用于改变属性的值。

实例

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

改变元素的文本节点
本例使用 nodeValue 属性来改变 "books.xml" 中第一个 <title> 元素的文本节点。
通过使用 setAttribute 来改变属性的值
本例使用 setAttribute() 方法来改变第一个 <book> 的 "category" 属性的值。
通过使用 nodeValue 来改变属性值
本例使用 nodeValue 属性来改变第一个 <book> 的 "category" 属性的值。

改变元素的值

在 DOM 中，每种成分都是节点。元素节点没有文本值。

元素节点的文本存储在子节点中。该节点称为文本节点。

改变元素文本的方法，就是改变这个子节点（文本节点）的值。

改变文本节点的值

nodeValue 属性可用于改变文本节点的值。

下面的代码片段改变了第一个 <title> 元素的文本节点值：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("title")[0].childNodes[0];
x.nodeValue="Hello World";

例子解释：

  • 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  • 获取第一个 <title> 元素的文本节点
  • 把此文本节点的节点值更改为 "Hello World"

TIY

遍历并更改所有 <title> 元素的文本节点：TIY

改变属性的值

在 DOM 中，属性也是节点。与元素节点不同，属性节点拥有文本值。

改变属性的值的方法，就是改变它的文本值。

可以通过使用 setAttribute() 方法或属性节点的 nodeValue 属性来完成这个任务。

通过使用 setAttribute() 来改变属性

setAttribute() 方法设置已有属性的值，或创建新属性。

下面的代码改变 <book> 元素的 category 属性：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName('book');
x[0].setAttribute("category","child");

例子解释：

  • 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  • 获取第一个 <book> 元素
  • 把 "category" 属性的值更改为 "child"

TIY

遍历所有 <title> 并添加一个新属性：TIY

注释：如果属性节点不存在，则创建一个新属性（拥有指定的名称和值）。

通过使用 nodeValue 改变属性

nodeValue 属性可用于更改属性节点的值：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("book")[0]
y=x.getAttributeNode("category");
y.nodeValue="child";

例子解释：

  • 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  • 获取第一个 <book> 元素的 "category" 属性
  • 把该属性节点的值更改为 "child"

TIY

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM 获取节点值

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM 获取节点值

  • Previous Page
  • Next Page

nodeValue 属性用于获取节点的文本值。

getAttribute() 方法返回属性的值。

实例

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

获取元素的值
本例使用 getElementsByTagname() 获取 "books.xml" 中第一个 <title> 元素。
获取属性的值
本例使用 getAttribute() 方法获取 "books.xml" 中第一个 <title> 元素的 "lang" 属性的值。

获取元素的值

在 DOM 中，每种成分都是节点。元素节点没有文本节点。

元素节点的文本存储在子节点中。该节点称为文本节点。

获取元素文本的方法，就是获取这个子节点（文本节点）的值。

获取元素值

getElementsByTagName() 方法返回包含拥有指定标签名的所有元素的节点列表，其中的元素的顺序是它们在源文档中出现的顺序。

下面的代码通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中，并检索第一个 <title> 元素：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("title")[0];

childNodes 属性返回子节点的列表。<title> 元素只有一个子节点，即一个文本节点。

下面的代码检索 <title> 元素的文本节点：

x=xmlDoc.getElementsByTagName("title")[0];
y=x.childNodes[0];

nodeValue 属性返回文本节点的文本值：

x=xmlDoc.getElementsByTagName("title")[0];
y=x.childNodes[0];
txt=y.nodeValue;

结果：txt = "Harry Potter"

TIY

遍历所有 <title> 元素：TIY

获取属性的值

在 DOM 中，属性也是节点。与元素节点不同，属性节点拥有文本值。

获取属性的值的方法，就是获取它的文本值。

可以通过使用 getAttribute() 方法或属性节点的 nodeValue 属性来完成这个任务。

获取属性值 - getAttribute()

getAttribute() 方法返回属性的值。

下面的代码检索第一个 <title> 元素的 "lang" 属性的文本值：

xmlDoc=loadXMLDoc("books.xml");

txt=xmlDoc.getElementsByTagName("title")[0].getAttribute("lang");

结果：txt = "en"

例子解释：

  • 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  • 把 txt 变量设置为第一个 title 元素节点的 "lang" 属性的值

TIY

遍历所有 <book> 元素，并获取它们的 "category" 属性：TIY

获取属性值 - getAttributeNode()

getAttributeNode() 方法返回属性节点。

下面代码检索第一个 <title> 元素的 "lang" 属性的文本值：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("title")[0].getAttributeNode("lang");
txt=x.nodeValue;

结果：txt = "en"

例子解释：

  • 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  • 获取第一个 <title> 元素节点的 "lang" 属性节点
  • 把 txt 变量设置为属性的值

TIY

循环所有 <book> 元素并获取它们的 "category" 属性：TIY

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM 加载函数

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM 加载函数

  • Previous Page
  • Next Page

可以把供加载 XML 文档的代码存储在单独的函数中。

实例

加载 XML 文档
使用函数来加载 XML 文档

加载函数

XML DOM 含有遍历 XML 树以及访问、插入、删除节点的方法（函数）。

然后，在访问并处理 XML 文档之前，必须把它载入 XML DOM 对象。

上一节演示了如何加载 XML 文档。为了避免因加载文档而重复编写代码，可以把代码存储在一个单独的 JavaScript 文件中：

function loadXMLDoc(dname)
{
try //Internet Explorer
  {
  xmlDoc=new ActiveXObject("Microsoft.XMLDOM");
  }
catch(e)
  {
  try //Firefox, Mozilla, Opera, etc.
    {
    xmlDoc=document.implementation.createDocument("","",null);
    }
  catch(e) {alert(e.message)}
  }
try
  {
  xmlDoc.async=false;
  xmlDoc.load(dname);
  return(xmlDoc);
  }
catch(e) {alert(e.message)}
return(null);
}

上面的函数存储在名为 "loadxmldoc.js" 的文件中。

下面的例子在其 <head> 部分有一个指向 "loadxmldoc.js" 的链接，并使用 loadXMLDoc() 函数加载 XML 文档 ("books.xml")：

<html>
<head>
<script type="text/javascript" src="loadxmldoc.js">
</script>
</head>

<body>
<script type="text/javascript">
xmlDoc=loadXMLDoc("books.xml");
document.write("xmlDoc is loaded, ready for use");
</script>
</body>
</html>

TIY

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM 简介

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM 简介

  • Previous Page
  • Next Page

XML DOM 定义了访问和处理 XML 文档的标准方法。

XML DOM 是 XML Document Object Model 的缩写，即 XML 文档对象模型。

您应当具备的基础支持

在继续学习之前，您应当对下列知识有基本的了解：

  • HTML / XHTML
  • JavaScript
  • XML

如果您希望首先学习这些项目，请在我们的首页访问这些教程。

什么是 DOM？

DOM 是 W3C（万维网联盟） 的推荐标准。

DOM 定义了访问诸如 XML 和 XHTML 文档的标准。

“W3C 文档对象模型（DOM）是一个使程序和脚本有能力动态地访问和更新文档的内容、结构以及样式的平台和语言中立的接口。”

W3C DOM 被分为 3 个不同的部分/级别（parts / levels）：

核心 DOM
用于任何结构化文档的标准模型
XML DOM
用于 XML 文档的标准模型
HTML DOM
用于 HTML 文档的标准模型

DOM 定义了所有文档元素的对象和属性，以及访问它们的方法（接口）。

您可以在我们的 W3C 教程 中获得更多有关 W3C DOM 规范/级别的信息。

什么是 HTML DOM？

HTML DOM 定义了所有 HTML 元素的对象和属性，以及访问它们的方法（接口）。

如果您希望学习 HTML DOM，请访问我们的 HTML DOM 教程。

什么是 XML DOM?

XML DOM 是：

  • 用于 XML 的标准对象模型
  • 用于 XML 的标准编程接口
  • 中立于平台和语言
  • W3C 的标准

XML DOM 定义了所有 XML 元素的对象和属性，以及访问它们的方法（接口）。

换句话说：

XML DOM 是用于获取、更改、添加或删除 XML 元素的标准。

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM 教程

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM 教程

  • Next Page

XML 文档对象模型定义访问和操作XML文档的标准方法。

DOM 将 XML 文档作为一个树形结构，而树叶被定义为节点。

开始学习 DOM！

XML DOM 对象 参考手册

在 W3School，我们提供完整的 DOM 参考手册，其中包括所有的对象以及它们的属性和方法。

XML DOM 参考手册

XML DOM 实例

学习 50 个实例！使用我们的编辑器，你可以编辑源代码，然后单击测试按钮来查看结果。

亲自试一试吧！

  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM 节点

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM 节点

  • Previous Page
  • Next Page

XML 文档中的每个成分都是一个节点。

节点

根据 DOM，XML 文档中的每个成分都是一个节点。

DOM 是这样规定的：

  • 整个文档是一个文档节点
  • 每个 XML 标签是一个元素节点
  • 包含在 XML 元素中的文本是文本节点
  • 每一个 XML 属性是一个属性节点
  • 注释属于注释节点

DOM 实例

请看下面的 XML 文件 (books.xml)：

<?xml version="1.0" encoding="ISO-8859-1"?>

<bookstore>

<book category="children">
  <title lang="en">Harry Potter</title>
  <author>J K. Rowling</author>
  <year>2005</year>
  <price>29.99</price>
</book>

<book category="cooking">
  <title lang="en">Everyday Italian</title>
  <author>Giada De Laurentiis</author>
  <year>2005</year>
  <price>30.00</price>
</book>

<book category="web">
  <title lang="en">Learning XML</title>
  <author>Erik T. Ray</author>
  <year>2003</year>
  <price>39.95</price>
</book>

<book category="web">
  <title lang="en">XQuery Kick Start</title>
  <author>James McGovern</author>
  <author>Per Bothner</author>
  <author>Kurt Cagle</author>
  <author>James Linn</author>
  <author>Vaidyanathan Nagarajan</author>
  <year>2003</year>
  <price>49.99</price>
</book>

</bookstore>

在上面的 XML 中，根节点是 <bookstore>。文档中的所有其他节点都被包含在 <bookstore> 中。

根节点 <bookstore> 有四个 <book> 节点。

第一个 <book> 节点有四个节点：<title>, <author>, <year> 以及 <price>，其中每个节点都包含一个文本节点，"Harry Potter", "J K. Rowling", "2005" 以及 "29.99"。

文本总是存储在文本节点中

在 DOM 处理中一个普遍的错误是，认为元素节点包含文本。

不过，元素节点的文本是存储在文本节点中的。

在这个例子中：<year>2005</year>，元素节点 <year>，拥有一个值为 "2005" 的文本节点。

"2005" 不是 <year> 元素的值！

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM 节点类型（Node Types）

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM 节点类型（Node Types）

  • Previous Page
  • Next Page

实例

在下面的例子中，我们将使用 XML 文件 books.xml，以及 JavaScript 函数 loadXMLDoc()。

显示所有元素的节点名称和节点类型
显示所有元素的节点名称和节点值

节点类型

下面的表格列出了不同的 W3C 节点类型，以及它们可拥有的子元素：

节点类型 | 描述 | 子元素
Document 表示整个文档（DOM 树的根节点）
  • Element (max. one)
  • ProcessingInstruction
  • Comment
  • DocumentType
DocumentFragment 表示轻量级的 Document 对象，其中容纳了一部分文档。
  • ProcessingInstruction
  • Comment
  • Text
  • CDATASection
  • EntityReference
DocumentType | 向为文档定义的实体提供接口。 | None
ProcessingInstruction | 表示处理指令。 | None
EntityReference 表示实体引用元素。
  • ProcessingInstruction
  • Comment
  • Text
  • CDATASection
  • EntityReference
Element 表示 element（元素）元素
  • Text
  • Comment
  • ProcessingInstruction
  • CDATASection
  • EntityReference
Attr 表示属性。
  • Text
  • EntityReference
Text | 表示元素或属性中的文本内容。 | None
CDATASection | 表示文档中的 CDATA 区段（文本不会被解析器解析） | None
Comment | 表示注释。 | None
Entity 表示实体。
  • ProcessingInstruction
  • Comment
  • Text
  • CDATASection
  • EntityReference
Notation | 表示在 DTD 中声明的符号。 | None

节点类型 - 所返回的值

下面的表格列出了对每个节点类型来说，nodeName 和 nodeValue 属性可返回的值：

节点类型 | nodeName 的返回值 | nodeValue 的返回值
Document | #document | null
DocumentFragment | #document fragment | null
DocumentType | doctype 名称 | null
EntityReference | 实体引用名称 | null
Element | element name | null
Attr | 属性名称 | 属性值
ProcessingInstruction | target | 节点的内容
Comment | #comment | 注释文本
Text | #text | 节点内容
CDATASection | #cdata-section | 节点内容
Entity | 实体名称 | null
Notation | 符号名称 | null

NodeTypes - 有名常数

NodeType | Named Constant
1 | ELEMENT_NODE
2 | ATTRIBUTE_NODE
3 | TEXT_NODE
4 | CDATA_SECTION_NODE
5 | ENTITY_REFERENCE_NODE
6 | ENTITY_NODE
7 | PROCESSING_INSTRUCTION_NODE
8 | COMMENT_NODE
9 | DOCUMENT_NODE
10 | DOCUMENT_TYPE_NODE
11 | DOCUMENT_FRAGMENT_NODE
12 | NOTATION_NODE
  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM 节点树

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM 节点树

  • Previous Page
  • Next Page

XML DOM 把 XML DOM 文档视为一棵节点树 (node-tree)。

树中的所有节点彼此之间都有关系。

XML DOM 节点树

XML DOM 把 XML 文档视为一种树结构。这种树结构被称为节点树。

可通过这棵树访问所有节点。可以修改或删除它们的内容，也可以创建新的元素。

这颗节点树展示了节点的集合，以及它们之间的联系。这棵树从根节点开始，然后在树的最低层级向文本节点长出枝条：

DOM node tree

上面的图片表示 XML 文件 books.xml。

父、子和同级节点

节点树中的节点彼此之间都有等级关系。

父、子和同级节点用于描述这种关系。父节点拥有子节点，位于相同层级上的子节点称为同级节点（兄弟或姐妹）。

  • 在节点树中，顶端的节点成为根节点
  • 根节点之外的每个节点都有一个父节点
  • 节点可以有任何数量的子节点
  • 叶子是没有子节点的节点
  • 同级节点是拥有相同父节点的节点

下面的图片展示出节点树的一个部分，以及节点间的关系：

因为 XML 数据是按照树的形式进行构造的，所以可以在不了解树的确切结构且不了解其中包含的数据类型的情况下，对其进行遍历。

您将在本教程稍后的章节学习更多有关遍历节点树的知识。

注释：父节点：Parent Node，子节点：Children Node，同级节点：Sibling Node。

第一个子节点 - 最后一个子节点

请看下面的 XML 片段：

<bookstore>
  <book category="CHILDREN">
    <title lang="en">Harry Potter</title>
    <author>J K. Rowling</author>
    <year>2005</year>
    <price>29.99</price>
  </book>
</bookstore>

在上面的 XML 中，<title> 元素是 <book> 元素的第一个子节点，而 <price> 元素是 <book> 元素的最后一个子节点。

此外，<book> 元素是 <title>、<author>、<year> 以及 <price> 元素的父节点。

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM 节点信息

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM 节点信息

  • Previous Page
  • Next Page

节点属性：nodeName、nodeValue 以及 nodeType。

实例

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

获取元素节点的节点名称
本例使用 nodeName 属性来获取 "books.xml" 中根元素的节点名称。
从文本节点获取文本
本例使用 nodeValue 属性来获取 "books.xml" 中第一个 <title> 元素的文本。
更改文本节点中的文本
本例使用 nodeValue 属性来更改 "books.xml" 中第一个 <title> 元素的文本。
获取元素节点的节点名称和类型
本例使用 nodeName 和 nodeType 属性来获取 "books.xml" 中根元素的节点名称和类型。

节点的属性

在 XML 文档对象模型 (DOM) 中，每个节点都是一个对象。

对象拥有方法（功能）和属性（关于对象的信息），并可通过 JavaScript 进行访问和操作。

三个重要的 XML DOM 节点属性是：

  • nodeName
  • nodeValue
  • nodeType

nodeName 属性

nodeName 属性规定节点的名称。

  • nodeName 是只读的
  • 元素节点的 nodeName 与标签名相同
  • 属性节点的 nodeName 是属性的名称
  • 文本节点的 nodeName 永远是 #text
  • 文档节点的 nodeName 永远是 #document

TIY

nodeValue 属性

nodeValue 属性规定节点的值。

  • 元素节点的 nodeValue 是 undefined
  • 文本节点的 nodeValue 是文本自身
  • 属性节点的 nodeValue 是属性的值

例子 1：获取元素的值

下面的代码检索第一个 <title> 元素的文本节点的值：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("title")[0].childNodes[0];
txt=x.nodeValue;

结果：txt = "Everyday Italian"

代码解释：

  • 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  • 获取第一个 <title> 元素节点的文本节点
  • 把 txt 变量设置为文本节点的值

TIY

例子 2：更改元素的值

下面的代码更改第一个 <title> 元素的文本节点的值：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("title")[0].childNodes[0];
x.nodeValue="Easy Cooking";

代码解释：

  • 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  • 获取第一个 <title> 元素节点的文本节点
  • 把文本节点的值更改为 "Easy Cooking"

TIY

nodeType 属性

nodeType 属性规定节点的类型。

nodeType 是只读的。

最重要的节点类型是：

元素类型 | 节点类型
元素 | 1
属性 | 2
文本 | 3
注释 | 8
文档 | 9

TIY

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM 解析器错误（Parser Errors）

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM 解析器错误（Parser Errors）

  • Previous Page
  • Next Page

微软的 parseError 对象可用于从微软的 XML 解析器中取回错误信息。

parseError 对象

在您试图打开一个 XML 文档时，就可能发生一个解析器错误（parser-error）。

通过这个 parseError 对象，您可取回错误代码、引起错误的行等等。

注释：parseError对象不属于 W3C DOM 标准！

文件错误（File Error）

在下面的代码中，我们会试图加载一个不存在的文件，并显示某些错误属性：

var xmlDoc = new ActiveXObject("Microsoft.XMLDOM")
xmlDoc.async="false"
xmlDoc.load("ksdjf.xml")

document.write("Error code: " + xmlDoc.parseError.errorCode)
document.write("<br />Error reason: " + xmlDoc.parseError.reason)
document.write("<br />Error line: " + xmlDoc.parseError.line)

TIY

XML 错误（XML Error）

在下面的代码中，我们会让解析器加载一个形式不良的 XML 文档。

（您可以在我们的 XML 教程 中阅读更多有关形式良好且有效的 XML。）

var xmlDoc = new ActiveXObject("Microsoft.XMLDOM")
xmlDoc.async="false"
xmlDoc.load("note_error.xml")

document.write("Error code: " + xmlDoc.parseError.errorCode)
document.write("<br />Error reason: " + xmlDoc.parseError.reason)
document.write("<br />Error line: " + xmlDoc.parseError.line)

TIY 或 仅仅查看此XML文件

parseError 对象的属性

属性 | 描述
errorCode | 返回一个长整型错误码。
reason | 返回包含错误原因的字符串。
line | 返回表示错误行号的长整型。
linepos | 返回表示错误的行位置的长整型。
srcText | 返回包含引起错误的行的字符串。
url | 返回指向被加载文档的 URL。
filepos | 返回错误的一个长整型文件位置。
  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM 克隆节点

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM 克隆节点

  • Previous Page
  • Next Page

实例

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

复制一个节点，并把它追加到已有的节点
本例使用 cloneNode() 来复制一个节点，并把它追加到 XML 文档的根节点。

复制节点

cloneNode() 方法创建指定节点的副本。

cloneNode() 方法有一个参数（true 或 false）。该参数指示被复制的节点是否包括原节点的所有属性和子节点。

下面的代码片段拷贝第一个 <book> 节点，并把它追加到文档的根节点：

xmlDoc=loadXMLDoc("books.xml");

oldNode=xmlDoc.getElementsByTagName('book')[0];
newNode=oldNode.cloneNode(true);
xmlDoc.documentElement.appendChild(newNode);

//Output all titles
y=xmlDoc.getElementsByTagName("title");
for (i=0;i<y.length;i++)
{
document.write(y[i].childNodes[0].nodeValue);
document.write("<br />");
}

输出：

Harry Potter
Everyday Italian
XQuery Kick Start
Learning XML
Harry Potter

例子解释：

  1. 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  2. 获取要复制的节点
  3. 通过使用 cloneNode 方法把节点复制到 "newNode" 中
  4. 向 XML 文档的根节点追加新节点
  5. 输出文档中所有 book 的 title

TIY

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM 删除节点

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM 删除节点

  • Previous Page
  • Next Page

removeChild() 方法删除指定节点。

removeAttribute() 方法删除指定属性。

实例

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

删除元素节点
本例使用 removeChild() 来删除第一个 <book> 元素。
删除当前元素节点
本例使用 parentNode 和 removeChild() 来删除当前的 <book> 元素。
删除文本节点
本例使用 removeChild() 来删除第一个 <title> 元素的文本节点。
清空文本节点的文本
本例使用 nodeValue() 属性来清空第一个 <title> 元素的文本节点。
根据名称删除属性
本例使用 removeAttribute() 从第一个 <book> 元素中删除 "category" 属性。
根据对象删除属性
本例使用 removeAttributeNode() 删除 <book> 元素中的所有属性。

删除元素节点

removeChild() 方法删除指定的节点。

当一个节点被删除时，其所有子节点也会被删除。

下面的代码片段将从载入的 xml 中删除第一个 <book> 元素：

xmlDoc=loadXMLDoc("books.xml");

y=xmlDoc.getElementsByTagName("book")[0];

xmlDoc.documentElement.removeChild(y);

例子解释：

  • 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  • 把变量 y 设置为要删除的元素节点
  • 通过使用 removeChild() 方法从父节点删除元素节点

TIY

删除自身 - 删除当前的节点

removeChild() 方法是唯一可以删除指定节点的方法。

当你已定位需要删除的节点时，就可以通过使用 parentNode 属性和 removeChild() 方法来删除此节点：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("book")[0];

x.parentNode.removeChild(x);

例子解释：

  • 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  • 把变量 y 设置为要删除的元素节点
  • 通过使用 parentNode 属性和 removeChild() 方法来删除此元素节点

TIY

删除文本节点

removeChild() 方法可用于删除文本节点：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("title")[0];

y=x.childNodes[0];
x.removeChild(y);

例子解释：

  • 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  • 把变量 x 设置为第一个 title 元素节点
  • 把变量 y 设置为 要删除的文本节点
  • 通过使用 removeChild() 方法从父节点删除节点

TIY

不太常用 removeChild() 从节点删除文本。可以使用 nodeValue 属性代替它。请看下一段。

清空文本节点

nodeValue 属性可用于改变或清空文本节点的值：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("title")[0].childNodes[0];
x.nodeValue="";

例子解释：

  • 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  • 把变量 x 设置为第一个 title 元素的文本节点
  • 使用 nodeValue 属性来清空文本节点的文本

TIY

循环并更改所有 <title> 元素的文本节点：TIY

根据名称删除属性节点

removeAttribute(name) 方法用于根据名称删除属性节点。

Example: removeAttribute('category')

下面的代码片段删除第一个 <book> 元素中的 "category" 属性：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("book");
x[0].removeAttribute("category");

例子解释：

  • 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  • 使用 getElementsByTagName() 来获取 book 节点
  • 从第一个 book 元素节点中删除 "category" 属性

TIY

遍历并删除所有 <book> 元素的 "category" 属性：TIY。

根据对象删除属性节点

removeAttributeNode(node) 方法通过使用 Node 对象作为参数，来删除属性节点。

Example: removeAttributeNode(x)

下面的代码片段删除所有 <book> 元素的所有属性：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("book");

for (i=0;i<x.length;i++)
{
while (x[i].attributes.length>0)
  {
  attnode=x[i].attributes[0];
  old_att=x[i].removeAttributeNode(attnode);
  }
}

例子解释：

  • 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  • 使用 getElementsByTagName() 来获取所有 book 节点
  • 检查每个 book 元素是否拥有属性
  • 如果在某个 book 元素中存在属性，则删除该属性

TIY

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM 替换节点

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM 替换节点

  • Previous Page
  • Next Page

replaceChild() 方法替换指定节点。

nodeValue 属性替换文本节点中的文本。

实例

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

替换元素节点
本例使用 replaceChild() 来替换第一个 <book> 节点。
替换文本节点中的数据
本例使用 nodeValue 属性来替换文本节点中的数据。

替换元素节点

replaceChild() 方法用于替换节点。

下面的代码片段替换第一个 <book> 元素：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.documentElement;

//创建一个 book 元素、一个 title 元素，以及一个 text 节点
newNode=xmlDoc.createElement("book");
newTitle=xmlDoc.createElement("title");
newText=xmlDoc.createTextNode("Hello World");

//向 title 节点添加文本节点
newTitle.appendChild(newText);

//向 book 节点添加 title 节点
newNode.appendChild(newTitle);

y=xmlDoc.getElementsByTagName("book")[0];

//用这个新节点替换第一个 book 节点
x.replaceChild(newNode,y);

例子解释：

  • 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  • 创建一个新的元素节点 <book>
  • 创建一个新的元素节点 <title>
  • 创建一个新的文本节点，带有文本 "Hello World"
  • 向新元素节点 <title> 追加这个新文本节点
  • 向新元素节点 <book> 追加这个新元素节点 <title>
  • 用新的 <book> 元素节点替换第一个 <book> 元素节点

TIY

替换文本节点中的数据

replaceData() 方法用于替换文本节点中的数据。

replaceData() 方法有三个参数：

  • offset - 在何处开始替换字符。Offset 值以 0 开始。
  • length - 要替换多少字符
  • string - 要插入的字符串
xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("title")[0].childNodes[0];

x.replaceData(0,8,"hello");

例子解释：

  • 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  • 获取第一个 <title> 元素节点的文本节点
  • 使用 replaceDat 方法把文本节点的前 8 个字符替换为 "hello"

TIY

使用 nodeValue 属性

用 nodeValue 属性来替换文本节点中数据会更加容易。

下面的代码片段将用 "Easy Italian" 替换第一个 <title> 元素中的文本节点值：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("title")[0].childNodes[0];

x.nodeValue="Hello World";

例子解释：

  • 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  • 获取第一个 <title> 元素节点的文本节点
  • 使用 nodeValue 属性来更改这个文本节点的文本

TIY

您可以在 改变节点 这一节中阅读更多有关更改节点值的内容。

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM 添加节点

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM 添加节点

  • Previous Page
  • Next Page

实例

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

在最后一个子节点之后添加一个节点
本例使用 appendChild() 方法向一个存在的节点添加一个子节点。
在指定的子节点之前添加一个节点
本例使用 insertBefore() 方法在一个指定的子节点之前插入一个节点。
添加一个新属性
本例使用 setAttribute() 方法添加一个新的属性。
向文本节点添加数据
本例使用 insertData() 把数据插入一个已存在的文本节点中。

添加节点 - appendChild()

appendChild() 方法向已存在的节点添加子节点。

新节点会添加（追加）到任何已存在的子节点之后。

注释：如果节点的位置很重要，请使用 insertBefore() 方法。

下面的代码片段创建一个元素（<edition>），并把它添加到第一个 <book> 元素最后一个子节点后面：

xmlDoc=loadXMLDoc("books.xml");

newel=xmlDoc.createElement("edition");

x=xmlDoc.getElementsByTagName("book")[0];
x.appendChild(newel);

例子解释：

  1. 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  2. 创建一个新节点 <edition>
  3. 把这个节点追加到第一个 <book> 元素

TIY

循环并把一个元素追加到所有 <book> 元素：TIY

插入节点 - insertBefore()

insertBefore() 方法用于在指定的子节点之前插入节点。

在被添加的节点的位置很重要时，此方法很有用。

xmlDoc=loadXMLDoc("books.xml");

newNode=xmlDoc.createElement("book");

x=xmlDoc.documentElement;
y=xmlDoc.getElementsByTagName("book")[3];

x.insertBefore(newNode,y);

例子解释：

  1. 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  2. 创建一个新的元素节点 <book>
  3. 把这个节点插到最后一个 <book> 元素节点之前

TIY

如果 insertBefore() 的第二个参数是 null，新节点将添加到最后一个已有的子节点之后。

x.insertBefore(newNode,null) 和 x.appendChild(newNode) 都可以向 x 追加一个新的子节点。

添加新属性

addAtribute() 这个方法是不存在的。

如果属性不存在，则 setAttribute() 可创建一个新的属性：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName('book');
x[0].setAttribute("edition","first");

例子解释：

  1. 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  2. 把第一个 <book> 元素的 "edition" 属性的值设置（创建）"first"

TIY

注释：如果属性已存在，setAttribute() 方法将覆盖已有的值。

向文本节点添加文本 - insertData()

insertData() 方法将数据插入已有的文本节点中。

insertData() 方法有两个参数：

  • offset - 在何处开始插入字符（以 0 开始）
  • string - 要插入的字符串

下面的代码片段将把 "Easy" 添加到已加载的 XML 的第一个 <title> 元素的文本节点：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.getElementsByTagName("title")[0].childNodes[0];

x.insertData(0,"Hello ");

TIY

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XML DOM 浏览器差异

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML DOM 浏览器差异

  • Previous Page
  • Next Page

不同的浏览器在 XML DOM 中处理空文本节点的方式是不同的。

实例

下面的例子使用 XML 文件 books.xml。

函数 loadXMLDoc()，位于外部 JavaScript 中，用于加载 XML 文件。

显示节点列表的长度
本例显示了一个节点列表的长度。在 IE 和其他浏览器中，结果是不同的。
忽略节点间的空文本
本例检查节点的 nodeType，且仅处理元素节点。

DOM 解析中的浏览器差异

所有现代浏览器都支持 W3C DOM 规范。

不过，浏览器之间是有差异的。重要的区别有两点：

  • 加载 XML 的方式
  • 处理空白和换行的方式

在 “解析 XML DOM” 这一节，已经解释了加载 XML 的不同方式。

在本节中，我们将讲解处理空白和换行的不同方式。

DOM - 空白和换行

XML 经常在节点之间含有换行或空白字符。这是在使用简单的编辑器（比如记事本）时经常出现的情况。

下面的例子（由记事本编辑）在每行之间含有 CR/LF，在每个子节点之前含有两个空格：

<book>
  <title>Harry Potter</title>
  <author>J K. Rowling</author>
  <year>2005</year>
  <price>29.99</price>
</book>

Firefox，以及其他一些浏览器，会把空的空白或换行作为文本节点来处理，而 Internet Explorer 不会这样。

下面的代码片段显示 （books.xml 的） 根元素拥有多少个子节点：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.documentElement.childNodes;
document.write("Number of child nodes: " + x.length);

例子解释：

  • 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  • 获取根元素的子节点
  • 输出子节点数目

结果取决于所使用的浏览器。Firefox 输出 9，而 IE 输出 4。

TIY

忽略节点间的空文本

如需忽略元素节点之间的空文本节点，需要检查节点类型。元素节点的类型是 1：

xmlDoc=loadXMLDoc("books.xml");

x=xmlDoc.documentElement.childNodes;

for (i=0;i<x.length;i++)
{
if (x[i].nodeType==1)
  {// only process element nodes
  document.write(x[i].nodeName);
  document.write("<br />");
  }
}

例子解释：

  • 通过使用 loadXMLDoc() 把 "books.xml" 载入 xmlDoc 中
  • 获取根元素的子节点
  • 检查每个子节点的节点类型。如果节点类型是 "1"，则是元素节点

TIY（简单） 或者 TIY（完整）

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XMLHttpRequest 对象

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XMLHttpRequest 对象

  • Previous Page
  • Next Page

XMLHttpRequest 对象提供了在网页加载后与服务器进行通信的方法。

什么是 XMLHttpRequest 对象？

XMLHttpRequest 对象是开发者的梦想，因为您能够：

  • 在不重新加载页面的情况下更新网页
  • 在页面已加载后从服务器请求数据
  • 在页面已加载后从服务器接收数据
  • 在后台向服务器发送数据

所有现代的浏览器都支持 XMLHttpRequest 对象。

实例：当键入文本时与服务器进行 XML HTTP 通信。

创建 XMLHttpRequest 对象

通过一行简单的 JavaScript 代码，我们就可以创建 XMLHttpRequest 对象。

在所有现代浏览器中（包括 IE 7）：

xmlhttp=new XMLHttpRequest()

在 Internet Explorer 5 和 6 中：

xmlhttp=new ActiveXObject("Microsoft.XMLHTTP")

实例

<script type="text/javascript">
var xmlhttp;
function loadXMLDoc(url)
{
xmlhttp=null;
if (window.XMLHttpRequest)
  {// code for all new browsers
  xmlhttp=new XMLHttpRequest();
  }
else if (window.ActiveXObject)
  {// code for IE5 and IE6
  xmlhttp=new ActiveXObject("Microsoft.XMLHTTP");
  }
if (xmlhttp!=null)
  {
  xmlhttp.onreadystatechange=state_Change;
  xmlhttp.open("GET",url,true);
  xmlhttp.send(null);
  }
else
  {
  alert("Your browser does not support XMLHTTP.");
  }
}

function state_Change()
{
if (xmlhttp.readyState==4)
  {// 4 = "loaded"
  if (xmlhttp.status==200)
    {// 200 = OK
    // ...our code here...
    }
  else
    {
    alert("Problem retrieving XML data");
    }
  }
}
</script>

TIY

注释：onreadystatechange 是一个事件句柄。它的值 (state_Change) 是一个函数的名称，当 XMLHttpRequest 对象的状态发生改变时，会触发此函数。状态从 0 (uninitialized) 到 4 (complete) 进行变化。仅在状态为 4 时，我们才执行代码。

为什么使用 Async=true ？

我们的实例在 open() 的第三个参数中使用了 "true"。

该参数规定请求是否异步处理。

True 表示脚本会在 send() 方法之后继续执行，而不等待来自服务器的响应。

onreadystatechange 事件使代码复杂化了。但是这是在没有得到服务器响应的情况下，防止代码停止的最安全的方法。

通过把该参数设置为 "false"，可以省去额外的 onreadystatechange 代码。如果在请求失败时是否执行其余的代码无关紧要，那么可以使用这个参数。

TIY

更多实例

通过 XML HTTP 把一个 textfile 载入一个 div 元素中

通过 XML HTTP 进行 HEAD 请求

通过 XML HTTP 进行指定的 HEAD 请求

通过 XML HTTP 列出 XML 文件中的数据

XML / ASP

您也可以把 XML 文档打开并发送到服务器上的 ASP 页面，分析此请求，然后传回结果。

<html>
<body>
<script type="text/javascript">
xmlHttp=null;
if (window.XMLHttpRequest)
  {// code for IE7, Firefox, Opera, etc.
  xmlHttp=new XMLHttpRequest();
  }
else if (window.ActiveXObject)
  {// code for IE6, IE5
  xmlHttp=new ActiveXObject("Microsoft.XMLHTTP");
  }
if (xmlHttp!=null)
  {
  xmlHttp.open("GET", "note.xml", false);
  xmlHttp.send(null);
  xmlDoc=xmlHttp.responseText;

  xmlHttp.open("POST", "demo_dom_http.asp", false);
  xmlHttp.send(xmlDoc);
  document.write(xmlHttp.responseText);
  }
else
  {
  alert("Your browser does not support XMLHTTP.");
  }
</script>
</body>
</html>

ASP 页面，由 VBScript 编写：

<%
set xmldoc = Server.CreateObject("Microsoft.XMLDOM")
xmldoc.async=false
xmldoc.load(request)

for each x in xmldoc.documentElement.childNodes
   if x.NodeName = "to" then name=x.text
next
response.write(name)
%>

通过使用 response.write 属性把结果传回客户端。

TIY

XMLHttpRequest 对象是 W3C 的标准吗？

任何 W3C 推荐标准均未规定 XMLHttpRequest 对象。

不过，W3C DOM Level 3 的 "Load and Save" 规范包含了一些相似的功能性，但是还没有任何浏览器实现它们。

参阅

XML DOM 参考手册: XMLHttpRequest 对象

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


解析 XML DOM

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

解析 XML DOM

  • Previous Page
  • Next Page

大多数浏览器都内建了供读取和操作 XML 的 XML 解析器。

解析器把 XML 转换为 JavaScript 可存取的对象。

实例

W3School 提供的实例独立于浏览器和平台。这些实例可在所有现代浏览器中运行。

加载并解析 XML 文件
加载并解析 XML 字符串

解析 XML

所有现代浏览器都内建了用于读取和操作 XML 的 XML 解析器。

解析器把 XML 读入内存，并把它转换为可被 JavaScript 访问的 XML DOM 对象。

微软的 XML 解析器与其他浏览器中的解析器是有差异的。微软的解析器支持对 XML 文件和 XML 字符串（文本）的加载，而其他浏览器使用单独的解析器。不过，所有的解析器都含有遍历 XML 树、访问、插入及删除节点的函数。

在本教程中，我们将为您讲解如何创建可在 IE 及其他浏览器中运行的脚本。

通过微软的 XML 解析器加载 XML

微软的 XML 解析器内建于 Internet Explorer 5 及更高版本中。

下面的 JavaScript 片段把 XML 文档 ("books.xml") 载入了解析器：

xmlDoc=new ActiveXObject("Microsoft.XMLDOM");
xmlDoc.async="false";
xmlDoc.load("books.xml");

代码解释：

  • 第一行创建空的微软 XML 文档对象
  • 第二行关闭异步加载，这样可确保在文档完整加载之前，解析器不会继续执行脚本
  • 第三行告知解析器加载名为 "books.xml" 的文档

下面的 JavaScript 片段把名为 txt 的字符串载入解析器中：

xmlDoc=new ActiveXObject("Microsoft.XMLDOM");
xmlDoc.async="false";
xmlDoc.loadXML(txt);

注释：loadXML() 方法用于加载字符串（文本），而 load() 用于加载文件。

在 Firefox 及其他浏览器中的 XML 解析器

下面的 JavaScript 片段把 XML 文档 ("books.xml") 载入了解析器：

xmlDoc=document.implementation.createDocument("","",null);
xmlDoc.async="false";
xmlDoc.load("books.xml");

代码解释：

  • 第一行创建空的 XML 文档对象
  • 第二行关闭异步加载，这样可确保在文档完整加载之前，解析器不会继续执行脚本
  • 第三行告知解析器加载名为 "books.xml" 的文档

下面的 JavaScript 片段把名为 txt 的字符串载入解析器中：

parser=new DOMParser();
xmlDoc=parser.parseFromString(txt,"text/xml");

代码解释：

  • 第一行创建一个空的 XML 文档对象
  • 第二行告知解析器加载名为 txt 的字符串

注释：Internet Explorer 使用 loadXML() 方法来解析 XML 字符串，而其他浏览器使用 DOMParser 对象。

解析 XML 文件 - 一个跨浏览器的实例

下面的例子把 XML 文档 ("books.xml") 载入 XML 解析器：

<html>
<body>
<script type="text/javascript">
try //Internet Explorer
  {
  xmlDoc=new ActiveXObject("Microsoft.XMLDOM");
  }
catch(e)
  {
  try //Firefox, Mozilla, Opera, etc.
    {
    xmlDoc=document.implementation.createDocument("","",null);
    }
  catch(e) {alert(e.message)}
  }
try
  {
  xmlDoc.async=false;
  xmlDoc.load("books.xml");
  document.write("xmlDoc is loaded, ready for use");
  }
catch(e) {alert(e.message)}
</script>
</body>
</html>

TIY

Error: Access Across Domains

出于安全方面的原因，现代的浏览器不允许跨域的访问。

这意味着，网页以及它试图加载的 XML 文件，都必须位于相同的服务器上。

W3School 的实例所打开的 XML 文件位于 W3School 的域上。

假如你打算在自己的网页上使用上面的例子，则必须把 XML 文件放到自己的服务器上。否则，xmlDoc.load() 将产生错误 "Access is denied"。

解析 XML 字符串 - 一个跨浏览器的实例

下面的代码加载并解析了一个 XML 字符串：

<html>
<body>
<script type="text/javascript">
text="<bookstore>"
text=text+"<book>";
text=text+"<title>Harry Potter</title>";
text=text+"<author>J K. Rowling</author>";
text=text+"<year>2005</year>";
text=text+"</book>";
text=text+"</bookstore>";

try //Internet Explorer
  {
  xmlDoc=new ActiveXObject("Microsoft.XMLDOM");
  xmlDoc.async="false";
  xmlDoc.loadXML(text);
  }
catch(e)
  {
  try //Firefox, Mozilla, Opera, etc.
    {
    parser=new DOMParser();
    xmlDoc=parser.parseFromString(text,"text/xml");
    }
  catch(e) {alert(e.message)}
  }
document.write("xmlDoc is loaded, ready for use");
</script>
</body>
</html>

TIY

注释：Internet Explorer 使用 loadXML() 方法来解析 XML 字符串，而其他浏览器使用 DOMParser 对象。

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


你已经学习了XML DOM，下一步呢？

XML DOM 教程

  • DOM 首页
  • DOM 简介
  • DOM 节点
  • DOM 节点树
  • DOM 解析
  • DOM 加载
  • DOM 属性和方法
  • DOM 访问节点
  • DOM 节点信息
  • DOM 节点列表
  • DOM 遍历节点
  • DOM 浏览器
  • DOM 定位节点

节点操作

  • DOM 获取节点
  • DOM 改变节点
  • DOM 删除节点
  • DOM 替换节点
  • DOM 创建节点
  • DOM 添加节点
  • DOM 克隆节点
  • DOM HttpRequest

XML DOM 参考手册

  • DOM 手册目录
  • DOM 节点类型
  • DOM Attr
  • DOM CDATASection
  • DOM Comment
  • DOM Document
  • DOM DocumentType
  • DOM DOMException
  • DOM DOMParser
  • DOM Element
  • DOM Event
  • DOM Implementation
  • DOM NamedNodeMap
  • DOM Node
  • DOM NodeList
  • DOM ParseError
  • DOM ProcessingInstr
  • DOM Range
  • DOM Text
  • DOM XMLHttpRequest
  • DOM XMLSerializer
  • DOM XPathExpression
  • DOM XPathResult
  • DOM XSLTProcessor
  • DOM 总结

实例

  • DOM 实例
  • DOM 验证器

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

你已经学习了XML DOM，下一步呢？

  • Previous Page
  • Next Page

XML DOM 概要

本教程已向您讲授了如何访问及操作 XML 文档。

您已经学习到 XML DOM 将 XML 文档视为一个元素嵌套其他元素的树结构，并且可以通过 DOM 树来访问所有的元素。他们的内容可被修改或删除，新的元素也可通过 DOM 来创建。

您学习了有关 XML 解析器的知识，以及如何把 XML 文档载入解析器。

我们也介绍了大部分重要的 DOM 对象，以及它们的用法。

如需更多有关 XML DOM 的知识，请访问我们的 XML DOM 实例。

你已经学习了 XML DOM，下一步呢？

下一步应当学习 XSLT。

如果你需要验证 XML 文档，下一步则需要学习有关 DTD 以及 XML Schema 的知识。

XSLT

XSLT 是针对 XML 文件的样式表语言。

通过 XSLT，您能够把 XML 文档转换为其他的格式，比如 XHTML。

如果您希望学习有关 XSLT 的知识，请访问我们的 XSLT 教程。

DTD

DTD 的作用是定义在某个 XML 文档中那些元素和属性是合法的。

DTD 被用来验证 XML 数据。

如果您希望学习更多有关 DTD 的知识，请访问我们的 DTD 教程。

XML Schema 将取代 DTD。

与 DTD 不同，XML Schema 拥有对数据类型和命名空间的支持。

如果您希望学习有关 XML Schema 的知识，请访问我们的 XML Schema 教程。

  • Previous Page
  • Next Page

XML DOM 参考手册
XML DOM 实例


XPath Axes（坐标轴）

XPath 教程

  • XPath 首页
  • XPath 简介
  • XPath 节点
  • XPath 语法
  • XPath 轴
  • XPath 运算符
  • XPath 实例
  • XPath 总结

参考手册

  • XPath 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XPath Axes（坐标轴）

  • Previous Page
  • Next Page

XML 实例文档

我们将在下面的例子中使用此 XML 文档：

<?xml version="1.0" encoding="ISO-8859-1"?>

<bookstore>

<book>
  <title lang="eng">Harry Potter</title>
  <price>29.99</price>
</book>

<book>
  <title lang="eng">Learning XML</title>
  <price>39.95</price>
</book>

</bookstore>

XPath 轴

轴可定义某个相对于当前节点的节点集。

轴名称 | 结果
ancestor | 选取当前节点的所有先辈（父、祖父等）
ancestor-or-self | 选取当前节点的所有先辈（父、祖父等）以及当前节点本身
attribute | 选取当前节点的所有属性
child | 选取当前节点的所有子元素。
descendant | 选取当前节点的所有后代元素（子、孙等）。
descendant-or-self | 选取当前节点的所有后代元素（子、孙等）以及当前节点本身。
following | 选取文档中当前节点的结束标签之后的所有节点。
namespace | 选取当前节点的所有命名空间节点
parent | 选取当前节点的父节点。
preceding | 选取文档中当前节点的开始标签之前的所有节点。
preceding-sibling | 选取当前节点之前的所有同级节点。
self | 选取当前节点。

位置路径表达式

位置路径可以是绝对的，也可以是相对的。

绝对路径起始于正斜杠( / )，而相对路径不会这样。在两种情况中，位置路径均包括一个或多个步，每个步均被斜杠分割：

绝对位置路径：

/step/step/...

相对位置路径：

step/step/...

每个步均根据当前节点集之中的节点来进行计算。

步（step）包括：

轴（axis）
定义所选节点与当前节点之间的树关系
节点测试（node-test）
识别某个轴内部的节点
零个或者更多谓语（predicate）
更深入地提炼所选的节点集

步的语法：

轴名称::节点测试[谓语]

实例

例子 | 结果
child::book | 选取所有属于当前节点的子元素的 book 节点
attribute::lang | 选取当前节点的 lang 属性
child::* | 选取当前节点的所有子元素
attribute::* | 选取当前节点的所有属性
child::text() | 选取当前节点的所有文本子节点
child::node() | 选取当前节点的所有子节点
descendant::book | 选取当前节点的所有 book 后代
ancestor::book | 选择当前节点的所有 book 先辈
ancestor-or-self::book | 选取当前节点的所有book先辈以及当前节点（假如此节点是book节点的话）
child::*/child::price | 选取当前节点的所有 price 孙。
  • Previous Page
  • Next Page

XPath, XQuery, 以及XSLT函数


XPath 简介

XPath 教程

  • XPath 首页
  • XPath 简介
  • XPath 节点
  • XPath 语法
  • XPath 轴
  • XPath 运算符
  • XPath 实例
  • XPath 总结

参考手册

  • XPath 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XPath 简介

  • Previous Page
  • Next Page

XPath 是一门在 XML 文档中查找信息的语言。XPath 用于在 XML 文档中通过元素和属性进行导航。

在学习之前应该具备的知识：

在您继续学习之前，应该对下面的知识有基本的了解：

  • HTML / XHTML
  • XML / XML 命名空间

如果您希望首先学习这些项目，请在我们的 首页 访问这些教程。

什么是 XPath?

  • XPath 使用路径表达式在 XML 文档中进行导航
  • XPath 包含一个标准函数库
  • XPath 是 XSLT 中的主要元素
  • XPath 是一个 W3C 标准

XPath 路径表达式

XPath 使用路径表达式来选取 XML 文档中的节点或者节点集。这些路径表达式和我们在常规的电脑文件系统中看到的表达式非常相似。

XPath 标准函数

XPath 含有超过 100 个内建的函数。这些函数用于字符串值、数值，日期和时间比较、节点和 QName 处理、序列处理、逻辑值等等。

XPath 在 XSLT 中使用

XPath 是 XSLT 标准中的主要元素。如果没有 XPath 方面的知识，您就无法创建 XSLT 文档。

您可以在我们的《XSLT 教程》中阅读更多的内容。

XQuery 和 XPointer 均构建于 XPath 表达式之上。XQuery 1.0 和 XPath 2.0 共享相同的数据模型，并支持相同的函数和运算符。

您可以在我们的《XQuery 教程》中阅读更多有关 XQuery 的知识。

XPath 是 W3C 标准

XPath 于 1999年11月16日 成为 W3C 标准。

XPath 被设计供 XSLT、XPointer 以及其他 XML 解析软件使用。

您可以在我们的《W3C 教程》中阅读更多有关 XPath 标准的信息。

  • Previous Page
  • Next Page

XPath, XQuery, 以及XSLT函数


XPath 教程

XPath 教程

  • XPath 首页
  • XPath 简介
  • XPath 节点
  • XPath 语法
  • XPath 轴
  • XPath 运算符
  • XPath 实例
  • XPath 总结

参考手册

  • XPath 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XPath 教程

  • Next Page

XPath 是一门在 XML 文档中查找信息的语言。XPath 可用来在 XML 文档中对元素和属性进行遍历。

XPath 是 W3C XSLT 标准的主要元素，并且 XQuery 和 XPointer 同时被构建于 XPath 表达之上。

因此，对 XPath 的理解是很多高级 XML 应用的基础。

开始学习 XPath ！

XPath 参考手册

在 W3School，我们提供完整的 XPath 2.0、XQuery 1.0 和 XSLT 2.0 的内置函数参考手册。

XPath 函数

内容目录

XPath 简介
本章讲解 XPath 的概念。
XPath 节点
本章详细介绍 XPath 中不同类型的节点，以及节点之间的关系。
XPath 语法
本章讲解 XPath 的语法。
XPath 轴
本章讲解 XPath axes（轴）。
XPath 运算符
本章列出了可以用于 XPath 表达式的运算符。
XPath 实例
本章使用 "books.xml" 文档来演示一些 XPath 实例。
XPath 摘要
本文内容包括在本教程所学知识的一个总结，以及我们向你推荐的下一步应该学习的内容。

XPath 参考手册

XPath 函数
XPath 2.0、XQuery 1.0 和 XSLT 2.0 的内置函数。
  • Next Page

XPath, XQuery, 以及XSLT函数


XPath 节点

XPath 教程

  • XPath 首页
  • XPath 简介
  • XPath 节点
  • XPath 语法
  • XPath 轴
  • XPath 运算符
  • XPath 实例
  • XPath 总结

参考手册

  • XPath 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XPath 节点

  • Previous Page
  • Next Page

在 XPath 中，有七种类型的节点：元素、属性、文本、命名空间、处理指令、注释以及文档节点（或成为根节点）。

XPath 术语

节点（Node）

在 XPath 中，有七种类型的节点：元素、属性、文本、命名空间、处理指令、注释以及文档（根）节点。XML 文档是被作为节点树来对待的。树的根被称为文档节点或者根节点。

请看下面这个 XML 文档：

<?xml version="1.0" encoding="ISO-8859-1"?>

<bookstore>

<book>
  <title lang="en">Harry Potter</title>
  <author>J K. Rowling</author>
  <year>2005</year>
  <price>29.99</price>
</book>

</bookstore>

上面的XML文档中的节点例子：

<bookstore> （文档节点）
<author>J K. Rowling</author> （元素节点）
lang="en" （属性节点）

基本值（或称原子值，Atomic value）

基本值是无父或无子的节点。

基本值的例子：

J K. Rowling
"en"

项目（Item）

项目是基本值或者节点。

节点关系

父（Parent）

每个元素以及属性都有一个父。

在下面的例子中，book 元素是 title、author、year 以及 price 元素的父：

<book>
  <title>Harry Potter</title>
  <author>J K. Rowling</author>
  <year>2005</year>
  <price>29.99</price>
</book>

子（Children）

元素节点可有零个、一个或多个子。

在下面的例子中，title、author、year 以及 price 元素都是 book 元素的子：

<book>
  <title>Harry Potter</title>
  <author>J K. Rowling</author>
  <year>2005</year>
  <price>29.99</price>
</book>

同胞（Sibling）

拥有相同的父的节点

在下面的例子中，title、author、year 以及 price 元素都是同胞：

<book>
  <title>Harry Potter</title>
  <author>J K. Rowling</author>
  <year>2005</year>
  <price>29.99</price>
</book>

先辈（Ancestor）

某节点的父、父的父，等等。

在下面的例子中，title 元素的先辈是 book 元素和 bookstore 元素：

<bookstore>

<book>
  <title>Harry Potter</title>
  <author>J K. Rowling</author>
  <year>2005</year>
  <price>29.99</price>
</book>

</bookstore>

后代（Descendant）

某个节点的子，子的子，等等。

在下面的例子中，bookstore的后代是 book、title、author、year 以及 price 元素：

<bookstore>

<book>
  <title>Harry Potter</title>
  <author>J K. Rowling</author>
  <year>2005</year>
  <price>29.99</price>
</book>

</bookstore>
  • Previous Page
  • Next Page

XPath, XQuery, 以及XSLT函数


XPath 实例

XPath 教程

  • XPath 首页
  • XPath 简介
  • XPath 节点
  • XPath 语法
  • XPath 轴
  • XPath 运算符
  • XPath 实例
  • XPath 总结

参考手册

  • XPath 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XPath 实例

  • Previous Page
  • Next Page

在本节，让我们通过实例来学习一些基础的 XPath 语法。

XML实例文档

我们将在下面的例子中使用这个 XML 文档：

"books.xml" :

<?xml version="1.0" encoding="ISO-8859-1"?>

<bookstore>

<book category="COOKING">
  <title lang="en">Everyday Italian</title>
  <author>Giada De Laurentiis</author>
  <year>2005</year>
  <price>30.00</price>
</book>

<book category="CHILDREN">
  <title lang="en">Harry Potter</title>
  <author>J K. Rowling</author>
  <year>2005</year>
  <price>29.99</price>
</book>

<book category="WEB">
  <title lang="en">XQuery Kick Start</title>
  <author>James McGovern</author>
  <author>Per Bothner</author>
  <author>Kurt Cagle</author>
  <author>James Linn</author>
  <author>Vaidyanathan Nagarajan</author>
  <year>2003</year>
  <price>49.99</price>
</book>

<book category="WEB">
  <title lang="en">Learning XML</title>
  <author>Erik T. Ray</author>
  <year>2003</year>
  <price>39.95</price>
</book>

</bookstore>

在您的浏览器中查看此 "books.xml" 文件。

节点选取

我们将使用微软的 XML DOM 对象来载入 XML 文档，并使用 selectNodes() 函数从 XML 文档选取节点：

set xmlDoc=CreateObject("Microsoft.XMLDOM")
xmlDoc.async="false"
xmlDoc.load("books.xml")

xmlDoc.selectNodes(路径表达式)

选取所有的 book 节点

下面的这个例子选取了 bookstore 元素下所有的 book 节点：

xmlDoc.selectNodes("/bookstore/book")

假如您正在使用 IE 5 或更高的版本，可以亲自试一试。

选取第一个 book 节点

下面的例子仅选取 bookstore 元素下第一个 book 节点：

xmlDoc.selectNodes("/bookstore/book[0]")

假如您正在使用 IE 5或更高的版本，可以亲自试一试。

注释：IE 5 和 6 会把 [0] 作为第一个节点来执行，但是根据 W3C 的标准，应该使用 [1] ！！

注释：这个问题在 IE 6 SP2 中被纠正了！

选取 price

下面的例子从所有的 price 节点选取文本：

xmlDoc.selectNodes("/bookstore/book/price/text()")

假如您正在使用 IE 5 或更高的版本，可以亲自试一试。

选取价格高于 35 的 price 价格

下面的例子会选取所有价格高于 35 的 price 节点：

xmlDoc.selectNodes("/bookstore/book[price>35]/price")

假如您正在使用 IE 5 或更高的版本，可以亲自试一试。

选取价格高于 35 的 title 节点

下面的例子会选取所有价格高于 35 的 title 节点：

xmlDoc.selectNodes("/bookstore/book[price>35]/title")

假如您正在使用 IE 5 或更高的版本，可以亲自试一试。

  • Previous Page
  • Next Page

XPath, XQuery, 以及XSLT函数


XPath 语法

XPath 教程

  • XPath 首页
  • XPath 简介
  • XPath 节点
  • XPath 语法
  • XPath 轴
  • XPath 运算符
  • XPath 实例
  • XPath 总结

参考手册

  • XPath 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XPath 语法

  • Previous Page
  • Next Page

XPath 使用路径表达式来选取 XML 文档中的节点或节点集。节点是通过沿着路径 (path) 或者步 (steps) 来选取的。

XML 实例文档

我们将在下面的例子中使用这个 XML 文档。

<?xml version="1.0" encoding="ISO-8859-1"?>

<bookstore>

<book>
  <title lang="eng">Harry Potter</title>
  <price>29.99</price>
</book>

<book>
  <title lang="eng">Learning XML</title>
  <price>39.95</price>
</book>

</bookstore>

选取节点

XPath 使用路径表达式在 XML 文档中选取节点。节点是通过沿着路径或者 step 来选取的。

下面列出了最有用的路径表达式：

表达式 | 描述
nodename | 选取此节点的所有子节点
/ | 从根节点选取
// | 从匹配选择的当前节点选择文档中的节点，而不考虑它们的位置
. | 选取当前节点
.. | 选取当前节点的父节点
@ | 选取属性

实例

在下面的表格中，我们已列出了一些路径表达式以及表达式的结果：

路径表达式 | 结果
bookstore | 选取 bookstore 元素的所有子节点
/bookstore | 选取根元素 bookstore 注释：假如路径起始于正斜杠( / )，则此路径始终代表到某元素的绝对路径！
bookstore/book | 选取所有属于 bookstore 的子元素的 book 元素。
//book | 选取所有 book 子元素，而不管它们在文档中的位置。
bookstore//book | 选择所有属于 bookstore 元素的后代的 book 元素，而不管它们位于 bookstore 之下的什么位置。
//@lang | 选取所有名为 lang 的属性。

谓语（Predicates）

谓语用来查找某个特定的节点或者包含某个指定的值的节点。

谓语被嵌在方括号中。

实例

在下面的表格中，我们列出了带有谓语的一些路径表达式，以及表达式的结果：

路径表达式 | 结果
/bookstore/book[1] | 选取属于 bookstore 子元素的第一个 book 元素。
/bookstore/book[last()] | 选取属于 bookstore 子元素的最后一个 book 元素。
/bookstore/book[last()-1] | 选取属于 bookstore 子元素的倒数第二个 book 元素。
/bookstore/book[position()<3] | 选取最前面的两个属于 bookstore 元素的子元素的 book 元素。
//title[@lang] | 选取所有拥有名为 lang 的属性的 title 元素。
//title[@lang='eng'] | 选取所有 title 元素，且这些元素拥有值为 eng 的 lang 属性。
/bookstore/book[price>35.00] | 选取所有 bookstore 元素的 book 元素，且其中的 price 元素的值须大于 35.00。
/bookstore/book[price>35.00]/title | 选取所有 bookstore 元素中的 book 元素的 title 元素，且其中的 price 元素的值须大于 35.00。

选取未知节点

XPath 通配符可用来选取未知的 XML 元素。

通配符 | 描述
* | 匹配任何元素节点
@* | 匹配任何属性节点
node() | 匹配任何类型的节点

实例

在下面的表格中，我们列出了一些路径表达式，以及这些表达式的结果：

路径表达式 | 结果
/bookstore/* | 选取 bookstore 元素的所有子节点
//* | 选取文档中的所有元素
//title[@*] | 选取所有带有属性的 title 元素。

选取若干路径

通过在路径表达式中使用“|”运算符，您可以选取若干个路径。

实例

在下面的表格中，我们列出了一些路径表达式，以及这些表达式的结果：

路径表达式 | 结果
//book/title | //book/price | 选取所有 book 元素的 title 和 price 元素。
//title | //price | 选取所有文档中的 title 和 price 元素。
/bookstore/book/title | //price | 选取所有属于 bookstore 元素的 book 元素的 title 元素，以及文档中所有的 price 元素。
  • Previous Page
  • Next Page

XPath, XQuery, 以及XSLT函数


XPath 运算符

XPath 教程

  • XPath 首页
  • XPath 简介
  • XPath 节点
  • XPath 语法
  • XPath 轴
  • XPath 运算符
  • XPath 实例
  • XPath 总结

参考手册

  • XPath 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XPath 运算符

  • Previous Page
  • Next Page

XPath 表达式可返回节点集、字符串、逻辑值以及数字。

XPath 运算符

下面列出了可用在 XPath 表达式中的运算符：

运算符 | 描述 | 实例 | 返回值
| | 计算两个节点集 | //book | //cd | 返回所有带有 book 和 ck 元素的节点集
+ | 加法 | 6 + 4 | 10
- | 减法 | 6 - 4 | 2
* | 乘法 | 6 * 4 | 24
div | 除法 | 8 div 4 | 2
= | 等于 | price=9.80 | 如果 price 是9.80，则返回 true。 如果 price 是9.90，则返回 fasle。
!= | 不等于 | price!=9.80 | 如果 price 是 9.90，则返回 true。 如果 price 是 9.98，则返回 fasle。
< | 小于 | price<9.80 | 如果price是9.00，则返回true 如果price是9.98，则返回fasle
<= | 小于或等于 | price<=9.80 | 如果 price 是9.00，则返回 true。 如果 price 是9.90，则返回 fasle。
> | 大于 | price>9.80 | 如果 price 是 9.90，则返回 true。 如果 price 是 9.80，则返回 fasle。
>= | 大于或等于 | price>=9.80 | 如果 price 是 9.90，则返回 true。 如果 price 是 9.70，则返回 fasle。
or | 或 | price=9.80 or price=9.70 | 如果 price 是 9.80，则返回 true。 如果 price 是 9.50，则返回 fasle。
and | 与 | price>9.00 and price<9.90 | 如果 price 是 9.80，则返回 true。 如果 price 是 8.50，则返回 fasle。
mod | 计算除法的余数 | 5 mod 2 | 1
  • Previous Page
  • Next Page

XPath, XQuery, 以及XSLT函数


XPath、XQuery 以及 XSLT 函数

XPath 教程

  • XPath 首页
  • XPath 简介
  • XPath 节点
  • XPath 语法
  • XPath 轴
  • XPath 运算符
  • XPath 实例
  • XPath 总结

参考手册

  • XPath 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XPath、XQuery 以及 XSLT 函数

  • Previous Page
  • Next Page
  • 存取
  • 错误和跟踪
  • 数值
  • 字符串
  • AnyURI
  • 逻辑
  • 持续时间/日期/时间
  • QName
  • 节点
  • 序列
  • Context

存取函数

名称 | 说明
fn:node-name(node) | 返回参数节点的节点名称。
fn:nilled(node) | 返回是否拒绝参数节点的布尔值。
fn:data(item.item,...) | 接受项目序列，并返回原子值序列。
  • fn:base-uri()
  • fn:base-uri(node)
 返回当前节点或指定节点的 base-uri 属性的值。
fn:document-uri(node) | 返回指定节点的 document-uri 属性的值。

错误和跟踪函数

名称 | 说明
  • fn:error()
  • fn:error(error)
  • fn:error(error,description)
  • fn:error(error,description,error-object)

例子：error(fn:QName('http://example.com/test', 'err:toohigh'), 'Error: Price is too high')

结果：向外部处理环境返回 http://example.com/test#toohigh 以及字符串 "Error: Price is too high"。
fn:trace(value,label) | 用于对查询进行 debug。

有关数值的函数

名称 | 说明
fn:number(arg) | 返回参数的数值。参数可以是布尔值、字符串或节点集。 例子：number('100') 结果：100
fn:abs(num) | 返回参数的绝对值。 例子：abs(3.14) 结果：3.14 例子：abs(-3.14) 结果：3.14
fn:ceiling(num) | 返回小于 num 参数的最小整数。 例子：ceiling(3.14) 结果：4
fn:floor(num) | 返回不大于 num 参数的最大整数。 例子：floor(3.14) 结果：3
fn:round(num) | 把 num 参数舍入为最接近的整数。 例子：round(3.14) 结果：3
fn:round-half-to-even() | 例子：round-half-to-even(0.5) 结果：0 例子：round-half-to-even(1.5) 结果：2 例子：round-half-to-even(2.5) 结果：2

有关字符串的函数

名称 | 说明
fn:string(arg)

返回参数的字符串值。参数可以是数字、逻辑值或节点集。

例子：string(314)

结果："314"
fn:codepoints-to-string(int,int,...)

根据代码点序列返回字符串。

例子：codepoints-to-string(84, 104, 233, 114, 232, 115, 101)

结果：'Thérèse'
fn:string-to-codepoints(string)

根据字符串返回代码点序列。

例子：string-to-codepoints("Thérèse")

结果：84, 104, 233, 114, 232, 115, 101
fn:codepoint-equal(comp1,comp2) | 根据 Unicode 代码点对照，如果 comp1 的值等于 comp2 的值，则返回 true。(http://www.w3.org/2005/02/xpath-functions/collation/codepoint)，否则返回 false。
  • fn:compare(comp1,comp2)
  • fn:compare(comp1,comp2,collation)

如果 comp1 小于 comp2，则返回 -1。如果 comp1 等于 comp2，则返回 0。如果 comp1 大于 comp2，则返回 1。（根据所用的对照规则）。

例子：compare('ghi', 'ghi')

结果：0
fn:concat(string,string,...)

返回字符串的拼接。

例子：concat('XPath ','is ','FUN!')

结果：'XPath is FUN!'
fn:string-join((string,string,...),sep)

使用 sep 参数作为分隔符，来返回 string 参数拼接后的字符串。

例子：string-join(('We', 'are', 'having', 'fun!'), ' ')

结果：' We are having fun! '

例子：string-join(('We', 'are', 'having', 'fun!'))

结果：'Wearehavingfun!'

例子：string-join((), 'sep')

结果：''
  • fn:substring(string,start,len)
  • fn:substring(string,start)

返回从 start 位置开始的指定长度的子字符串。第一个字符的下标是 1。如果省略 len 参数，则返回从位置 start 到字符串末尾的子字符串。

例子：substring('Beatles',1,4)

结果：'Beat'

例子：substring('Beatles',2)

结果：'eatles'
fn:string-length(string) fn:string-length()

返回指定字符串的长度。如果没有 string 参数，则返回当前节点的字符串值的长度。

例子：string-length('Beatles')

结果：7
  • fn:normalize-space(string)
  • fn:normalize-space()

删除指定字符串的开头和结尾的空白，并把内部的所有空白序列替换为一个，然后返回结果。如果没有 string 参数，则处理当前节点。

例子：normalize-space(' The XML ')

结果：'The XML'
  • fn:normalize-unicode()
  • fn:upper-case(string)

把 string 参数转换为大写。

例子：upper-case('The XML')

结果：'THE XML'
fn:lower-case(string)

把 string 参数转换为小写。

例子：lower-case('The XML')

结果：'the xml'
fn:translate(string1,string2,string3)

把 string1 中的 string2 替换为 string3。

例子：translate('12:30','30','45')

结果：'12:45'

例子：translate('12:30','03','54')

结果：'12:45'

例子：translate('12:30','0123','abcd')

结果：'bc:da'
fn:escape-uri(stringURI,esc-res)

例子：escape-uri("http://example.com/test#car", true())

结果："http%3A%2F%2Fexample.com%2Ftest#car"

例子：escape-uri("http://example.com/test#car", false())

结果："http://example.com/test#car"

例子：escape-uri ("http://example.com/~bébé", false())

结果："http://example.com/~b%C3%A9b%C3%A9"
fn:contains(string1,string2)

如果 string1 包含 string2，则返回 true，否则返回 false。

例子：contains('XML','XM')

结果：true
fn:starts-with(string1,string2)

如果 string1 以 string2 开始，则返回 true，否则返回 false。

例子：starts-with('XML','X')

结果：true
fn:ends-with(string1,string2)

如果 string1 以 string2 结尾，则返回 true，否则返回 false。

例子：ends-with('XML','X')

结果：false
fn:substring-before(string1,string2)

返回 string2 在 string1 中出现之前的子字符串。

例子：substring-before('12/10','/')

结果：'12'
fn:substring-after(string1,string2)

返回 string2 在 string1 中出现之后的子字符串。

例子：substring-after('12/10','/')

结果：'10'
fn:matches(string,pattern)

如果 string 参数匹配指定的模式，则返回 true，否则返回 false。

例子：matches("Merano", "ran")

结果：true
fn:replace(string,pattern,replace)

把指定的模式替换为 replace 参数，并返回结果。

例子：replace("Bella Italia", "l", "*")

结果：'Be**a Ita*ia'

例子：replace("Bella Italia", "l", "")

结果：'Bea Itaia'
fn:tokenize(string,pattern)

例子：tokenize("XPath is fun", "\s+")

结果：("XPath", "is", "fun")

针对 anyURI 的函数

名称 | 说明
fn:resolve-uri(relative,base) |

关于布尔值的函数

名称 | 说明
fn:boolean(arg) | 返回数字、字符串或节点集的布尔值。
fn:not(arg) | 首先通过 boolean() 函数把参数还原为一个布尔值。如果该布尔值为 false，则返回 true，否则返回 true。 例子：not(true()) 结果：false
fn:true() | 返回布尔值 true。 例子：true() 结果：true
fn:false() | 返回布尔值 false。 例子：false() 结果：false

有关持续时间、日期和时间的函数

日期、时间、持续时间的组件提取函数

名称 | 说明
fn:dateTime(date,time) | 把参数转换为日期和时间。
fn:years-from-duration(datetimedur) | 返回参数值的年份部分的整数，以标准词汇表示法来表示。
fn:months-from-duration(datetimedur) | 返回参数值的月份部分的整数，以标准词汇表示法来表示。
fn:days-from-duration(datetimedur) | 返回参数值的天部分的整数，以标准词汇表示法来表示。
fn:hours-from-duration(datetimedur) | 返回参数值的小时部分的整数，以标准词汇表示法来表示。
fn:minutes-from-duration(datetimedur) | 返回参数值的分钟部分的整数，以标准词汇表示法来表示。
fn:seconds-from-duration(datetimedur) | 返回参数值的分钟部分的十进制数，以标准词汇表示法来表示。
fn:year-from-dateTime(datetime) | 返回参数本地值的年部分的整数。 例子：year-from-dateTime(xs:dateTime("2005-01-10T12:30-04:10")) 结果：2005
fn:month-from-dateTime(datetime) | 返回参数本地值的月部分的整数。 例子：month-from-dateTime(xs:dateTime("2005-01-10T12:30-04:10")) 结果：01
fn:day-from-dateTime(datetime) | 返回参数本地值的天部分的整数。 例子：day-from-dateTime(xs:dateTime("2005-01-10T12:30-04:10")) 结果：10
fn:hours-from-dateTime(datetime) | 返回参数本地值的小时部分的整数。 例子：hours-from-dateTime(xs:dateTime("2005-01-10T12:30-04:10")) 结果：12
fn:minutes-from-dateTime(datetime) | 返回参数本地值的分钟部分的整数。 例子：minutes-from-dateTime(xs:dateTime("2005-01-10T12:30-04:10")) 结果：30
fn:seconds-from-dateTime(datetime) | 返回参数本地值的秒部分的十进制数。 例子：seconds-from-dateTime(xs:dateTime("2005-01-10T12:30:00-04:10")) 结果：0
fn:timezone-from-dateTime(datetime) | 返回参数的时区部分，如果存在。
fn:year-from-date(date) | 返回参数本地值中表示年的整数。 例子：year-from-date(xs:date("2005-04-23")) 结果：2005
fn:month-from-date(date) | 返回参数本地值中表示月的整数。 例子：month-from-date(xs:date("2005-04-23")) 结果：4
fn:day-from-date(date) | 返回参数本地值中表示天的整数。 例子：day-from-date(xs:date("2005-04-23")) 结果：23
fn:timezone-from-date(date) | 返回参数的时区部分，如果存在。
fn:hours-from-time(time) | 返回参数本地值中表示小时部分的整数。 例子：hours-from-time(xs:time("10:22:00")) 结果：10
fn:minutes-from-time(time) | 返回参数本地值中表示分钟部分的整数。 例子：minutes-from-time(xs:time("10:22:00")) 结果：22
fn:seconds-from-time(time) | 返回参数本地值中表示秒部分的整数。 例子：seconds-from-time(xs:time("10:22:00")) 结果：0
fn:timezone-from-time(time) | 返回参数的时区部分，如果存在。
fn:adjust-dateTime-to-timezone(datetime,timezone) | 如果 timezone 参数为空，则返回没有时区的 dateTime。否则返回带有时区的 dateTime。
fn:adjust-date-to-timezone(date,timezone) | 如果 timezone 参数为空，则返回没有时区的 date。否则返回带有时区的 date。
fn:adjust-time-to-timezone(time,timezone) | 如果 timezone 参数为空，则返回没有时区的 time。否则返回带有时区的 time。

与 QNames 相关的函数

名称 | 说明
fn:QName() |
fn:local-name-from-QName() |
fn:namespace-uri-from-QName() |
fn:namespace-uri-for-prefix() |
fn:in-scope-prefixes() |
fn:resolve-QName() |

关于节点的函数

名称 说明
  • fn:name()
  • fn:name(nodeset)
 返回当前节点的名称或指定节点集中的第一个节点。
  • fn:local-name()
  • fn:local-name(nodeset)
 返回当前节点的名称或指定节点集中的第一个节点 - 不带有命名空间前缀。
  • fn:namespace-uri()
  • fn:namespace-uri(nodeset)
 返回当前节点或指定节点集中第一个节点的命名空间 URI。
fn:lang(lang)

如果当前节点的语言匹配指定的语言，则返回 true。

例子：Lang("en") is true for <p xml:lang="en">...</p>

例子：Lang("de") is false for <p xml:lang="en">...</p>
  • fn:root()
  • fn:root(node)
 返回当前节点或指定的节点所属的节点树的根节点。通常是文档节点。

有关序列的函数

一般性的函数

名称 | 说明
fn:index-of((item,item,...),searchitem) | 返回在项目序列中等于 searchitem 参数的位置。 例子：index-of ((15, 40, 25, 40, 10), 40) 结果：(2, 4) 例子：index-of (("a", "dog", "and", "a", "duck"), "a") Result (1, 4) 例子：index-of ((15, 40, 25, 40, 10), 18) 结果：()
fn:remove((item,item,...),position) | 返回由 item 参数构造的新序列 - 同时删除 position 参数指定的项目。 例子：remove(("ab", "cd", "ef"), 0) 结果：("ab", "cd", "ef") 例子：remove(("ab", "cd", "ef"), 1) 结果：("cd", "ef") 例子：remove(("ab", "cd", "ef"), 4) 结果：("ab", "cd", "ef")
fn:empty(item,item,...) | 如果参数值是空序列，则返回 true，否则返回 false。 例子：empty(remove(("ab", "cd"), 1)) 结果：false
fn:exists(item,item,...) | 如果参数值不是空序列，则返回 true，否则返回 false。 例子：exists(remove(("ab"), 1)) 结果：false
fn:distinct-values((item,item,...),collation) | 返回唯一不同的值。 例子：distinct-values((1, 2, 3, 1, 2)) 结果：(1, 2, 3)
fn:insert-before((item,item,...),pos,inserts) | 返回由 item 参数构造的新序列 - 同时在 pos 参数指定位置插入 inserts 参数的值。 例子：insert-before(("ab", "cd"), 0, "gh") 结果：("gh", "ab", "cd") 例子：insert-before(("ab", "cd"), 1, "gh") 结果：("gh", "ab", "cd") 例子：insert-before(("ab", "cd"), 2, "gh") 结果：("ab", "gh", "cd") 例子：insert-before(("ab", "cd"), 5, "gh") 结果：("ab", "cd", "gh")
fn:reverse((item,item,...)) | 返回指定的项目的颠倒顺序。 例子：reverse(("ab", "cd", "ef")) 结果：("ef", "cd", "ab") 例子：reverse(("ab")) 结果：("ab")
fn:subsequence((item,item,...),start,len) | 返回 start 参数指定的位置返回项目序列，序列的长度由 len 参数指定。第一个项目的位置是 1。 例子：subsequence(($item1, $item2, $item3,...), 3) 结果：($item3, ...) 例子：subsequence(($item1, $item2, $item3, ...), 2, 2) 结果：($item2, $item3)
fn:unordered((item,item,...)) | 依据实现决定的顺序来返回项目。

测试序列容量的函数

名称 | 说明
fn:zero-or-one(item,item,...) | 如果参数包含零个或一个项目，则返回参数，否则生成错误。
fn:one-or-more(item,item,...) | 如果参数包含一个或多个项目，则返回参数，否则生成错误。
fn:exactly-one(item,item,...) | 如果参数包含一个项目，则返回参数，否则生成错误。

Equals, Union, Intersection and Except

名称 | 说明
fn:deep-equal(param1,param2,collation) | 如果 param1 和 param2 与彼此相等（deep-equal），则返回 true，否则返回 false。

合计函数

名称 | 说明
fn:count((item,item,...)) | 返回节点的数量。
fn:avg((arg,arg,...)) | 返回参数值的平均数。 例子：avg((1,2,3)) 结果：2
fn:max((arg,arg,...)) | 返回大于其它参数的参数。 例子：max((1,2,3)) 结果：3 例子：max(('a', 'k')) 结果：'k'
fn:min((arg,arg,...)) | 返回小于其它参数的参数。 例子：min((1,2,3)) 结果：1 例子：min(('a', 'k')) 结果：'a'
fn:sum(arg,arg,...) | 返回指定节点集中每个节点的数值的总和。

生成序列的函数

名称 | 说明
fn:id((string,string,...),node) | Returns a sequence of element nodes that have an ID value equal to the value of one or more of the values specified in the string argument
fn:idref((string,string,...),node) | Returns a sequence of element or attribute nodes that have an IDREF value equal to the value of one or more of the values specified in the string argument
fn:doc(URI)
fn:doc-available(URI) | 如果 doc() 函数返回文档节点，则返回 true，否则返回 false。
  • fn:collection()
  • fn:collection(string)

上下文函数

名称 | 说明
fn:position() | 返回当前正在被处理的节点的 index 位置。 例子：//book[position()<=3] 结果：选择前三个 book 元素
fn:last() | 返回在被处理的节点列表中的项目数目。 例子：//book[last()] 结果：选择最后一个 book 元素
fn:current-dateTime() | 返回当前的 dateTime（带有时区）。
fn:current-date() | 返回当前的日期（带有时区）。
fn:current-time() | 返回当前的时间（带有时区）。
fn:implicit-timezone() | 返回隐式时区的值。
fn:default-collation() | 返回默认对照的值。
fn:static-base-uri() | 返回 base-uri 的值。
  • Previous Page
  • Next Page

XPath, XQuery, 以及XSLT函数


您已经学习了 XPath，下一步呢？

XPath 教程

  • XPath 首页
  • XPath 简介
  • XPath 节点
  • XPath 语法
  • XPath 轴
  • XPath 运算符
  • XPath 实例
  • XPath 总结

参考手册

  • XPath 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

您已经学习了 XPath，下一步呢？

  • Previous Page
  • Next Page

XPath 概要

本教程已经向您讲解了如何在 XML 文档中查找信息。

您已经学习了如何使用 XPath 通过元素和属性在 XML 文档中进行导航。

你也学习了如何使用 XPath 中内建的某些标准函数。

如需更多有关 XPath 的信息，请阅读我们的《XPath 参考手册》。

您已经学习了 XPath，下一步应当学习什么呢？

您下一步应该学习 XSLT、XQuery、XLink 以及 XPointer。

XSLT

XSLT 是针对 XML 文件的样式表语言。

通过 XSLT，您可以把 XML 文件转换为其他的格式，比如 XHTML。

如果您希望学习更多有关 XSLT 的知识，请访问我们的《XSLT 教程》。

XQuery

XQuery 和 XML 数据查询有关。

XQuery 被设计用来查询任何可作为 XML 形态呈现的数据，包括数据库。

如果您希望学习更多有关 XQuery 的知识，请访问我们的《XQuery 教程》。

XLink 和 XPointer

XML 中的链接被分为两个部分：XLink 和 XPointer。

XLink 和 XPointer 定义了在 XML 文档中创建超级链接的标准方法。

如果你希望学习更多有关 XLink 和 XPointer 的知识，请访问我们的《XLink 教程和 XPointer教程》。

  • Previous Page
  • Next Page

XPath, XQuery, 以及XSLT函数


XQuery FLWOR + HTML

XQuery 基础

  • XQuery 首页
  • XQuery 简介
  • XQuery 实例
  • XQuery FLWOR
  • XQuery HTML
  • XQuery 术语
  • XQuery 语法

XQuery 高级

  • XQuery 添加
  • XQuery 选取
  • XQuery 函数
  • XQuery 总结

XQuery 参考手册

  • XQuery 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XQuery FLWOR + HTML

  • Previous Page
  • Next Page

XML 实例文档

我们将在下面的例子中使用这个 "books.xml" 文档（与上一节中的文件相同）。

在您的浏览器中查看 "books.xml" 文件。

在一个 HTML 列表中提交结果

请看下面的 XQuery FLWOR 表达式：

for $x in doc("books.xml")/bookstore/book/title
order by $x
return $x

上面的表达式会选取 bookstore 元素下的 book 元素下的所有 title 元素，并以字母顺序返回 title 元素。

现在，我们希望使用 HTML 列表列出我们的书店中所有的书目。我们向 FLWOR 表达式添加 <ul> 和 <li> 标签：

<ul>
{
for $x in doc("books.xml")/bookstore/book/title
order by $x
return <li>{$x}</li>
}
</ul>

以上代码的结果：

<ul>
<li><title lang="en">Everyday Italian</title></li>
<li><title lang="en">Harry Potter</title></li>
<li><title lang="en">Learning XML</title></li>
<li><title lang="en">XQuery Kick Start</title></li>
</ul>

现在我们希望去除 title 元素，而仅仅显示 title 元素内的数据。

<ul>
{
for $x in doc("books.xml")/bookstore/book/title
order by $x
return <li>{data($x)}</li>
}
</ul>

结果将是一个 HTML 列表：

<ul>
<li>Everyday Italian</li>
<li>Harry Potter</li>
<li>Learning XML</li>
<li>XQuery Kick Start</li>
</ul>
  • Previous Page
  • Next Page

XQuery 参考手册


XQuery FLWOR 表达式

XQuery 基础

  • XQuery 首页
  • XQuery 简介
  • XQuery 实例
  • XQuery FLWOR
  • XQuery HTML
  • XQuery 术语
  • XQuery 语法

XQuery 高级

  • XQuery 添加
  • XQuery 选取
  • XQuery 函数
  • XQuery 总结

XQuery 参考手册

  • XQuery 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XQuery FLWOR 表达式

  • Previous Page
  • Next Page

XML 实例文档

我们将在下面的例子中使用这个 "books.xml" 文档（与上一节中的 XML 文件相同）。

在您的浏览器中查看 "books.xml" 文件。

如果使用 FLWOR 从 "books.xml" 选取节点

请看下面这个路径表达式：

doc("books.xml")/bookstore/book[price>30]/title

上面这个表达式可选取 bookstore 元素下的 book 元素下所有的 title 元素，并且其中的 price 元素的值必须大于 30。

下面这个 FLWOR 表达式所选取的数据和上面的路径表达式是相同的：

for $x in doc("books.xml")/bookstore/book
where $x/price>30
return $x/title

结果是：

<title lang="en">XQuery Kick Start</title>
<title lang="en">Learning XML</title>

通过 FLWOR，您可以对结果进行排序：

for $x in doc("books.xml")/bookstore/book
where $x/price>30
order by $x/title
return $x/title

FLWOR 是 "For, Let, Where, Order by, Return" 的只取首字母缩写。

for 语句把 bookstore 元素下的所有 book 元素提取到名为 $x 的变量中。

where 语句选取了 price 元素值大于 30 的 book 元素。

order by 语句定义了排序次序。将根据 title 元素进行排序。

return 语句规定返回什么内容。在此返回的是 title 元素。

上面的 XQuery 表达式的结果：

<title lang="en">Learning XML</title>
<title lang="en">XQuery Kick Start</title>
  • Previous Page
  • Next Page

XQuery 参考手册


XQuery 参考手册

XQuery 基础

  • XQuery 首页
  • XQuery 简介
  • XQuery 实例
  • XQuery FLWOR
  • XQuery HTML
  • XQuery 术语
  • XQuery 语法

XQuery 高级

  • XQuery 添加
  • XQuery 选取
  • XQuery 函数
  • XQuery 总结

XQuery 参考手册

  • XQuery 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XQuery 参考手册

  • Previous Page
  • Next Page

XQuery 1.0 和 XPath 2.0 分享相同的数据模型，并支持相同的函数和运算符。

XQuery 函数

XQuery 构建在 XPath 表达式之上。XQuery 1.0 和 XPath 2.0 分享相同的数据模型，并支持相同的函数和运算符。

XPath 运算符

XPath 函数

XQuery 数据类型

XQuery 分享与 XML Schema 1.0 (XSD) 相同的数据类型。

XSD String

XSD Date

XSD Numeric

XSD Misc

  • Previous Page
  • Next Page

XQuery 参考手册


XQuery 函数

XQuery 基础

  • XQuery 首页
  • XQuery 简介
  • XQuery 实例
  • XQuery FLWOR
  • XQuery HTML
  • XQuery 术语
  • XQuery 语法

XQuery 高级

  • XQuery 添加
  • XQuery 选取
  • XQuery 函数
  • XQuery 总结

XQuery 参考手册

  • XQuery 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XQuery 函数

  • Previous Page
  • Next Page

XQuery 1.0、XPath 2.0 以及 XSLT 2.0 共享相同的函数库。

XQuery 函数

XQuery 含有超过 100 个内建的函数。这些函数可用于字符串值、数值、日期以及时间比较、节点和 QName 操作、序列操作、逻辑值等等。您也可在 XQuery 中定义自己的函数。

XQuery 内建函数

XQuery 函数命名空间的 URI：

http://www.w3.org/2005/02/xpath-functions

函数命名空间的默认前缀是 fn:。

提示：函数经常被通过 fn: 前缀进行调用，例如 fn:string()。不过，由于 fn: 是命名空间的默认前缀，所以函数名称不必在被调用时使用前缀。

您可以在我们的 XPath 教程中找到完整的《内建 XQuery 函数参考手册》。

函数调用实例

函数调用可与表达式一同使用。请看下面的例子：

例1：在元素中

<name>{uppercase($booktitle)}</name>

例2: 在路径表达式的谓语中

doc("books.xml")/bookstore/book[substring(title,1,5)='Harry']

例3: 在 let 语句中

let $name := (substring($booktitle,1,4))

XQuery 用户定义函数

如果找不到所需的 XQuery 函数，你可编写自己的函数。

可在查询中或独立的库中定义用户自定义函数。

语法

declare function 前缀:函数名($参数 AS 数据类型)
  AS 返回的数据类型
{

(: ...函数代码... :)

};

关于用户自定义函数的注释：

  • 请使用 declare function 关键词
  • 函数名须使用前缀
  • 参数的数据类型通常与在 XML Schema 中定义的数据类型一致
  • 函数主体须被花括号包围

一个在查询中声明的用户自定义函数的例子：

declare function local:minPrice(
  $price as xs:decimal?,
  $discount as xs:decimal?)
  AS xs:decimal?
{
let $disc := ($price * $discount) div 100
return ($price - $disc)
};

(: Below is an example of how to call the function above :)

<minPrice>{local:minPrice($book/price, $book/discount)}</minPrice>
  • Previous Page
  • Next Page

XQuery 参考手册


XQuery 简介

XQuery 基础

  • XQuery 首页
  • XQuery 简介
  • XQuery 实例
  • XQuery FLWOR
  • XQuery HTML
  • XQuery 术语
  • XQuery 语法

XQuery 高级

  • XQuery 添加
  • XQuery 选取
  • XQuery 函数
  • XQuery 总结

XQuery 参考手册

  • XQuery 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XQuery 简介

  • Previous Page
  • Next Page

解释XQuery最佳方式是这样讲：XQuery 相对于 XML 的关系，等同于 SQL 相对于数据库表的关系。

XQuery 被设计用来查询 XML 数据 - 不仅仅限于 XML 文件，还包括任何可以 XML 形态呈现的数据，包括数据库。

您应该具备的基础知识：

在您继续学习之前，需要对下面的知识有基本的了解：

  • HTML / XHTML
  • XML / XML 命名空间
  • XPath

如果您希望首先学习这些项目，请在我们的 首页 访问这些教程。

什么是 XQuery?

  • XQuery 是用于 XML 数据查询的语言
  • XQuery 对 XML 的作用类似 SQL 对数据库的作用
  • XQuery 被构建在 XPath 表达式之上
  • XQuery 被所有主要的数据库引擎支持（IBM、Oracle、Microsoft等等）
  • XQuery 是 W3C 标准。

XQuery 和 XML 查询有关

XQuery 是用来从 XML 文档查找和提取元素及属性的语言。

这是一个 XQuery 解决实际问题的例子：

“从存储在名为 cd_catalog.xml 的 XML 文档中的 CD 集那里选取所有价格低于 10 美元的 CD 纪录。”

XQuery 与 XPath

XQuery 1.0 和 XPath 2.0 共享相同的数据模型，并支持相同的函数和运算符。假如您已经学习了 XPath，那么学习 XQuery 也不会有问题。

您可以在我们的《XPath 教程》中阅读更多有关 XPath 的知识。

XQuery - 应用举例

XQuery 可被用来：

  • 提取信息以便在网络服务中使用
  • 生成摘要报告
  • 把 XML 数据转换为 XHTML
  • 为获得相关信息而搜索网络文档

XQuery 是一个 W3C 推荐标准

XQuery 与多种 W3C 标准相兼容，比如 XML、Namespaces、XSLT、XPath 以及 XML Schema。

XQuery 1.0 在 2007年1月23日 被确立为 W3C 推荐标准。

如需获得更多有关 W3C 的 XQuery 活动的信息，请阅读我们的《W3C 教程》。

  • Previous Page
  • Next Page

XQuery 参考手册


XQuery 教程

XQuery 基础

  • XQuery 首页
  • XQuery 简介
  • XQuery 实例
  • XQuery FLWOR
  • XQuery HTML
  • XQuery 术语
  • XQuery 语法

XQuery 高级

  • XQuery 添加
  • XQuery 选取
  • XQuery 函数
  • XQuery 总结

XQuery 参考手册

  • XQuery 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XQuery 教程

  • Next Page

解释 XQuery 的最佳方式是：XQuery 相对于 XML，等同于 SQL 相对于数据库。

XQuery 被设计用来查询 XML 数据。

XQuery 也被称为 XML Query。

开始学习 XQuery ！

XQuery 参考手册

在W3School，我们提供XQuery 1.0中所有operators、内置函数、数据类型的完整参考手册。

XQuery 参考手册

内容目录

XQuery 简介
XQuery 的简介。包括其概念和作用。
XQuery 实例
本章通过一个实例演示 XQuery。
XQuery FLWOR
本章讲解 XQuery FLWOR 表达式。
XQuery FLWOR + HTML
本章演示如何通过 HTML 列表提交 FLWOR 结果。
XQuery 术语
本章讲解 XQuery 中普遍使用的术语。
XQuery 语法
本章讲解 XQuery 中基本的语法规则。
XQuery 向结果添加结果和属性
本章讲解如何向结果添加你自己的元素和属性。
XQuery 筛选元素
本章讲解如何使用 FLWOR 筛选元素。
XQuery 函数
XQuery 内置函数和运算符的总论，以及如何创建用户自定义的函数。
XQuery 总结
本文包括在本教程所学内容的一个总结，以及我们向你推荐的下一步应该学习的内容。

XQuery 参考手册

XQuery 参考手册
包含 XQuery 运算符、内置函数、数据类型的完整参考手册。
  • Next Page

XQuery 参考手册


XQuery 实例

XQuery 基础

  • XQuery 首页
  • XQuery 简介
  • XQuery 实例
  • XQuery FLWOR
  • XQuery HTML
  • XQuery 术语
  • XQuery 语法

XQuery 高级

  • XQuery 添加
  • XQuery 选取
  • XQuery 函数
  • XQuery 总结

XQuery 参考手册

  • XQuery 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XQuery 实例

  • Previous Page
  • Next Page

在本节，让我们通过研究一个例子来学习一些基础的 XQuery 语法。

XML 实例文档

我们将在下面的例子中使用这个 XML 文档。

"books.xml" :

<?xml version="1.0" encoding="ISO-8859-1"?>

<bookstore>

<book category="COOKING">
  <title lang="en">Everyday Italian</title>
  <author>Giada De Laurentiis</author>
  <year>2005</year>
  <price>30.00</price>
</book>

<book category="CHILDREN">
  <title lang="en">Harry Potter</title>
  <author>J K. Rowling</author>
  <year>2005</year>
  <price>29.99</price>
</book>

<book category="WEB">
  <title lang="en">XQuery Kick Start</title>
  <author>James McGovern</author>
  <author>Per Bothner</author>
  <author>Kurt Cagle</author>
  <author>James Linn</author>
  <author>Vaidyanathan Nagarajan</author>
  <year>2003</year>
  <price>49.99</price>
</book>

<book category="WEB">
  <title lang="en">Learning XML</title>
  <author>Erik T. Ray</author>
  <year>2003</year>
  <price>39.95</price>
</book>

</bookstore>

在您的浏览器中查看 "books.xml" 文件。

如何从 "books.xml" 选取节点？

函数

XQuery 使用函数来提取 XML 文档中的数据。

doc() 用于打开 "books.xml" 文件：

doc("books.xml")

路径表达式

XQuery 使用路径表达式在 XML 文档中通过元素进行导航。

下面的路径表达式用于在 "books.xml" 文件中选取所有的 title 元素：

doc("books.xml")/bookstore/book/title

(/bookstore 选取 bookstore 元素，/book 选取 bookstore 元素下的所有 book 元素，而 /title 选取每个 book 元素下的所有 title 元素)

上面的 XQuery 可提取以下数据：

<title lang="en">Everyday Italian</title>
<title lang="en">Harry Potter</title>
<title lang="en">XQuery Kick Start</title>
<title lang="en">Learning XML</title>

谓语

XQuery 使用谓语来限定从 XML 文档所提取的数据。

下面的谓语用于选取 bookstore 元素下的所有 book 元素，并且所选取的 book 元素下的 price 元素的值必须小于 30：

doc("books.xml")/bookstore/book[price<30]

上面的 XQuery 可提取到下面的数据：

<book category="CHILDREN">
  <title lang="en">Harry Potter</title>
  <author>J K. Rowling</author>
  <year>2005</year>
  <price>29.99</price>
</book>
  • Previous Page
  • Next Page

XQuery 参考手册


XQuery 术语

XQuery 基础

  • XQuery 首页
  • XQuery 简介
  • XQuery 实例
  • XQuery FLWOR
  • XQuery HTML
  • XQuery 术语
  • XQuery 语法

XQuery 高级

  • XQuery 添加
  • XQuery 选取
  • XQuery 函数
  • XQuery 总结

XQuery 参考手册

  • XQuery 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XQuery 术语

  • Previous Page
  • Next Page

在 XQuery 中，有七种节点：元素、属性、文本、命名空间、处理指令、注释、以及文档节点（或称为根节点）。

XQuery 术语

节点

在 XQuery 中，有七种节点：元素、属性、文本、命名空间、处理指令、注释、以及文档（根）节点。XML 文档是被作为节点树来对待的。树的根被称为文档节点或者根节点。

请看下面的 XML 文档：

<?xml version="1.0" encoding="ISO-8859-1"?>

<bookstore>

<book>
  <title lang="en">Harry Potter</title>
  <author>J K. Rowling</author>
  <year>2005</year>
  <price>29.99</price>
</book>

</bookstore>

上面的 XML 文档中的节点例子：

<bookstore>  （文档节点）
<author>J K. Rowling</author>  （元素节点）
lang="en"  （属性节点）

基本值（或称原子值，Atomic value）

基本值是无父或无子的节点。

基本值的例子：

J K. Rowling
"en"

项目

项目是基本值或者节点。

节点关系

父（Parent）

每个元素以及属性都有一个父。

在下面的例子中，book 元素是 title、author、year 以及 price 元素的父：

<book>
  <title>Harry Potter</title>
  <author>J K. Rowling</author>
  <year>2005</year>
  <price>29.99</price>
</book>

子（Children）

节点元素可有零个、一个或多个子。

在下面的例子中，title、author、year 以及 price 元素都是 book 元素的子：

<book>
  <title>Harry Potter</title>
  <author>J K. Rowling</author>
  <year>2005</year>
  <price>29.99</price>
</book>

同胞（Sibling）

拥有相同的父的节点。

在下面的例子中，title、author、year 以及 price 元素都是同胞：

<book>
  <title>Harry Potter</title>
  <author>J K. Rowling</author>
  <year>2005</year>
  <price>29.99</price>
</book>

先辈（Ancestor）

某节点的父、父的父，等等。

在下面的例子中，title 元素的先辈是 book 元素和 bookstore元素：

<bookstore>

<book>
  <title>Harry Potter</title>
  <author>J K. Rowling</author>
  <year>2005</year>
  <price>29.99</price>
</book>

</bookstore>

后代（Descendant）

某个节点的子，子的子，等等。

在下面的例子中，bookstore 的后代是 book、title、author、year 以及 price元素：

<bookstore>

<book>
  <title>Harry Potter</title>
  <author>J K. Rowling</author>
  <year>2005</year>
  <price>29.99</price>
</book>

</bookstore>
  • Previous Page
  • Next Page

XQuery 参考手册


XQuery 添加元素和属性

XQuery 基础

  • XQuery 首页
  • XQuery 简介
  • XQuery 实例
  • XQuery FLWOR
  • XQuery HTML
  • XQuery 术语
  • XQuery 语法

XQuery 高级

  • XQuery 添加
  • XQuery 选取
  • XQuery 函数
  • XQuery 总结

XQuery 参考手册

  • XQuery 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XQuery 添加元素和属性

  • Previous Page
  • Next Page

XML 实例文档

我们将在下面的例子中使用这个 "books.xml" 文档（和上面的章节所使用的 XML 文件相同）。

在您的浏览器中查看 "books.xml" 文件。

向结果添加元素和属性

正如在前面一节看到的，我们可以在结果中引用输入文件中的元素和属性：

for $x in doc("books.xml")/bookstore/book/title
order by $x
return $x

上面的 XQuery 表达式会在结果中引用 title 元素和 lang 属性，就像这样：

<title lang="en">Everyday Italian</title>
<title lang="en">Harry Potter</title>
<title lang="en">Learning XML</title>
<title lang="en">XQuery Kick Start</title>

以上 XQuery 表达式返回 title 元素的方式和它们在输入文档中被描述的方式的相同的。

现在我们要向结果添加我们自己的元素和属性！

添加 HTML 元素和文本

现在，我们要向结果添加 HTML 元素。我们会把结果放在一个 HTML 列表中：

<html>
<body>

<h1>Bookstore</h1>

<ul>
{
for $x in doc("books.xml")/bookstore/book
order by $x/title
return <li>{data($x/title)}. Category: {data($x/@category)}</li>
}
</ul>

</body>
</html>

以上 XQuery 表达式会生成下面的结果：

<html>
<body>

<h1>Bookstore</h1>

<ul>
<li>Everyday Italian. Category: COOKING</li>
<li>Harry Potter. Category: CHILDREN</li>
<li>Learning XML. Category: WEB</li>
<li>XQuery Kick Start. Category: WEB</li>
</ul>

</body>
</html>

向 HTML 元素添加属性

接下来，我们要把 category 属性作为 HTML 列表中的 class 属性来使用：

<html>
<body>

<h1>Bookstore</h1>

<ul>
{
for $x in doc("books.xml")/bookstore/book
order by $x/title
return <li class="{data($x/@category)}">{data($x/title)}</li>
}
</ul>

</body>
</html>

上面的 XQuery 表达式可生成以下结果：

<html>
<body>

<h1>Bookstore</h1>

<ul>
<li class="COOKING">Everyday Italian</li>
<li class="CHILDREN">Harry Potter</li>
<li class="WEB">Learning XML</li>
<li class="WEB">XQuery Kick Start</li>
</ul>

</body>
</html>
  • Previous Page
  • Next Page

XQuery 参考手册


XQuery 选择和过滤

XQuery 基础

  • XQuery 首页
  • XQuery 简介
  • XQuery 实例
  • XQuery FLWOR
  • XQuery HTML
  • XQuery 术语
  • XQuery 语法

XQuery 高级

  • XQuery 添加
  • XQuery 选取
  • XQuery 函数
  • XQuery 总结

XQuery 参考手册

  • XQuery 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XQuery 选择和过滤

  • Previous Page
  • Next Page

XML实例文档

我们将在下面的例子中使用这个 "books.xml" 文档（和上面的章节所使用的 XML 文件相同）。

在您的浏览器中查看 "books.xml" 文件。

选择和过滤元素

正如在前面的章节所看到的，我们使用路径表达式或 FLWOR 表达式来选去和过滤元素。

请看下面的 FLWOR 表达式：

for $x in doc("books.xml")/bookstore/book
where $x/price>30
order by $x/title
return $x/title
for
（可选） 向每个由 in 表达式返回的项目捆绑一个变量
let
（可选）
where
（可选） 设定一个条件
order by
（可选） 设定结果的排列顺序
return
规定在结果中返回的内容

for 语句

for 语句可将变量捆绑到由 in 表达式返回的每个项目。for 语句可产生迭代。在同一个 FLWOR 表达式中可存在多重 for 语句。

如需在一个 for 语句中进行指定次数地循环，您可使用关键词 to ：

for $x in (1 to 5)
return <test>{$x}</test>

结果：

<test>1</test>
<test>2</test>
<test>3</test>
<test>4</test>
<test>5</test>

关键词 at 可用于计算迭代：

for $x at $i in doc("books.xml")/bookstore/book/title
return <book>{$i}. {data($x)}</book>

结果：

<book>1. Everyday Italian</book>
<book>2. Harry Potter</book>
<book>3. XQuery Kick Start</book>
<book>4. Learning XML</book>

在 for 语句中同样允许多个 in 表达式。请使用逗号来分割每一个 in 表达式：

for $x in (10,20), $y in (100,200)
return <test>x={$x} and y={$y}</test>

结果：

<test>x=10 and y=100</test>
<test>x=10 and y=200</test>
<test>x=20 and y=100</test>
<test>x=20 and y=200</test>

let 语句

let 语句可完成变量分配，并可避免多次重复相同的表达式。let 语句不会导致迭代。

let $x := (1 to 5)
return <test>{$x}</test>

结果：

<test>1 2 3 4 5</test>

where 语句

where 语句用于为结果设定一个或多个条件（criteria）。

where $x/price>30 and $x/price<100

order by 语句

order by 语句用于规定结果的排序次序。此处，我们要根据 category 和 title 来对结果进行排序：

for $x in doc("books.xml")/bookstore/book
order by $x/@category, $x/title
return $x/title

结果：

<title lang="en">Harry Potter</title>
<title lang="en">Everyday Italian</title>
<title lang="en">Learning XML</title>
<title lang="en">XQuery Kick Start</title>

return 语句：

return 语句规定要返回的内容。

for $x in doc("books.xml")/bookstore/book
return $x/title

结果：

<title lang="en">Everyday Italian</title>
<title lang="en">Harry Potter</title>
<title lang="en">XQuery Kick Start</title>
<title lang="en">Learning XML</title>
  • Previous Page
  • Next Page

XQuery 参考手册


XQuery 语法

XQuery 基础

  • XQuery 首页
  • XQuery 简介
  • XQuery 实例
  • XQuery FLWOR
  • XQuery HTML
  • XQuery 术语
  • XQuery 语法

XQuery 高级

  • XQuery 添加
  • XQuery 选取
  • XQuery 函数
  • XQuery 总结

XQuery 参考手册

  • XQuery 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XQuery 语法

  • Previous Page
  • Next Page

XQuery 对大小写敏感，XQuery 的元素、属性以及变量必须是合法的 XML 名称。

XQuery 的基础语法规则：

一些基本的语法规则：

  • XQuery 对大小写敏感
  • XQuery 的元素、属性以及变量必须是合法的 XML 名称。
  • XQuery 字符串值可使用单引号或双引号。
  • XQuery 变量由 “$” 并跟随一个名称来进行定义，举例，$bookstore
  • XQuery 注释被 (: 和 :) 分割，举例，(: XQuery 注释 :)

XQuery 条件表达式

"If-Then-Else" 可以在 XQuery 中使用。

请看下面的例子：

for $x in doc("books.xml")/bookstore/book
return	if ($x/@category="CHILDREN")
    then <child>{data($x/title)}</child>
    else <adult>{data($x/title)}</adult>

请注意 "If-Then-Else" 的语法：if 表达式后的圆括号是必需的。else 也是必需的，不过仅仅写 “else ()” 也是可以的。

上面的例子的结果：

<adult>Everyday Italian</adult>
<child>Harry Potter</child>
<adult>Learning XML</adult>
<adult>XQuery Kick Start</adult>

XQuery 比较

在 XQuery 中，有两种方法来比较值。

  1. 通用比较：=, !=, <, <=, >, >=
  2. 值的比较：eq、ne、lt、le、gt、ge

这两种比较方法的差异如下：

请看下面的 XQuery 表达式：

$bookstore//book/@q > 10

如果 q 属性的值大于 10，上面的表达式的返回值为 true。

$bookstore//book/@q gt 10

如果仅返回一个 q，且它的值大于 10，那么表达式返回 true。如果不止一个 q 被返回，则会发生错误。

  • Previous Page
  • Next Page

XQuery 参考手册


您已经学习了 XQuery，下一步呢？

XQuery 基础

  • XQuery 首页
  • XQuery 简介
  • XQuery 实例
  • XQuery FLWOR
  • XQuery HTML
  • XQuery 术语
  • XQuery 语法

XQuery 高级

  • XQuery 添加
  • XQuery 选取
  • XQuery 函数
  • XQuery 总结

XQuery 参考手册

  • XQuery 参考手册

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

您已经学习了 XQuery，下一步呢？

  • Previous Page
  • Next Page

XQuery 概要

本教程已经向您讲解了如何查询 XML 数据。

您已经明白，XQuery 被设计来查询以 XML 形态存在的任何数据，包括数据库。

您也学习了如何使用 FLWOR 表达式来查询 XML 数据，以及如何由选定的数据构造 XHTML 输出。

如需更多有关 XQuery 的信息，请阅读我们的《XQuery 参考手册》。

您已经学习了 XQuery，接下来该学习什么内容呢？

下一步该学习 XLink 和 XPointer。

XLink 和 XPointer

XML 中的链接被分为两部分：XLink 和 XPointer。

XLink 和 XPointer 定义了一套标准的在XML文档中创建超级链接的方法。

如果您希望学习更多有关 XLink 和 XPointer 的知识，请访问我们的《XLink 和 XPointer 教程》。

  • Previous Page
  • Next Page

XQuery 参考手册


My CD Collection

Title:
Artist:


My CD Collection

Title | Artist


My CD Collection


My CD Collection

Title | Artist
. | .


Title | Artist


My CD Collection

Title | Artist
Empire Burlesque | Bob Dylan
Hide your heart | Bonnie Tyler
Greatest Hits | Dolly Parton
Still got the blues | Gary Moore
Eros | Eros Ramazzotti
One night only | Bee Gees
Sylvias Mother | Dr.Hook
Maggie May | Rod Stewart
Romanza | Andrea Bocelli
When a man loves a woman | Percy Sledge
Black angel | Savage Rose
1999 Grammy Nominees | Many
For the good times | Kenny Rogers
Big Willie style | Will Smith
Tupelo Honey | Van Morrison
Soulsville | Jorn Hoel
The very best of | Cat Stevens
Stop | Sam Brown
Bridge of Spies | T`Pau
Private Dancer | Tina Turner
Midt om natten | Kim Larsen
Pavarotti Gala Concert | Luciano Pavarotti
The dock of the bay | Otis Redding
Picture book | Simply Red
Red | The Communards
Unchain my heart | Joe Cocker


Empire Burlesque

 Empire Burlesque Bob Dylan USA Columbia 10.90 1985 Hide your heart Bonnie Tyler UK CBS Records 9.90 1988 Greatest Hits Dolly Parton USA RCA 9.90 1982 Still got the blues Gary Moore UK Virgin records 10.20 1990 Eros Eros Ramazzotti EU BMG 9.90 1997 One night only Bee Gees UK Polydor 10.90 1998 Sylvias Mother Dr.Hook UK CBS 8.10 1973 Maggie May Rod Stewart UK Pickwick 8.50 1990 Romanza Andrea Bocelli EU Polydor 10.80 1996 When a man loves a woman Percy Sledge USA Atlantic 8.70 1987 Black angel Savage Rose EU Mega 10.90 1995 1999 Grammy Nominees Many USA Grammy 10.20 1999 For the good times Kenny Rogers UK Mucik Master 8.70 1995 Big Willie style Will Smith USA Columbia 9.90 1997 Tupelo Honey Van Morrison UK Polydor 8.20 1971 Soulsville Jorn Hoel Norway WEA 7.90 1996 The very best of Cat Stevens UK Island 8.90 1990 Stop Sam Brown UK A and M 8.90 1988 Bridge of Spies T`Pau UK Siren 7.90 1987 Private Dancer Tina Turner UK Capitol 8.90 1983 Midt om natten Kim Larsen EU Medley 7.80 1983 Pavarotti Gala Concert Luciano Pavarotti UK DECCA 9.90 1991 The dock of the bay Otis Redding USA Atlantic 7.90 1987 Picture book Simply Red EU Elektra 7.20 1985 Red The Communards UK London 7.80 1987 Unchain my heart Joe Cocker USA EMI 8.20 1987


Lover Birds

 Lover Birds Cynthia Randall Lucerne Publishing The Sundered Grail Eva Corets Lucerne Publishing Splish Splash Paula Thurman Scootney


Updated Tool Information:


Tool Information (edit):


XML 编辑器

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XML 编辑器

  • Previous Page
  • Next Page

如果希望极认真地学习和使用 XML，那么您一定会从一款专业的 XML 编辑器的使用上受益。

XML 是基于文本的

XML 是基于文本的标记语言。

关于 XML 的一件很重要的事情是，XML 可被类似记事本这样的简单的文本编辑器来创建和编辑。

不过，在您开始使用 XML 进行工作时，您很快会发现，使用一款专业的 XML 编辑器来编辑 XML 文档会更好。

为什么不使用记事本?

许多开发人员使用记事本来编辑 XML 和 HTML 文档，这是因为最常用的操作系统都带有记事本，而且它很容易使用。从个人来讲，我经常使用记事本来快速地编辑某些简单的 HTML、CSS 以及 XML 文件。

但是，如果您使用记事本对 XML 进行编辑，可能很快会发现不少问题。

记事本不能确定您编辑的文档类型，所以也就无法辅助您的工作。

为什么使用 XML 编辑器?

当今，XML 是非常重要的技术，并且开发项目正在使用这些基于 XML 的技术：

  • 用 XML Schema 定义 XML 的结构和数据类型
  • 用 XSLT 来转换 XML 数据
  • 用 SOAP 来交换应用程序之间的 XML 数据
  • 用 WSDL 来描述网络服务
  • 用 RDF 来描述网络资源
  • 用 XPath 和 XQuery 来访问 XML 数据
  • 用 SMIL 来定义图形

为了能够编写出无错的 XML 文档，您需要一款智能的 XML 编辑器！

XML 编辑器

专业的 XML 编辑器会帮助您编写无错的 XML 文档，根据某种 DTD 或者 schema 来验证 XML，以及强制您创建合法的 XML 结构。

XML 编辑器应该具有如下能力：

  • 为开始标签自动添加结束标签
  • 强制您编写合法的 XML
  • 根据 DTD 来验证 XML
  • 根据 Schema 来验证 XML
  • 对您的 XML 语法进行代码的颜色化显示
  • Previous Page
  • Next Page

XSLT 参考手册


XSL 语言

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSL 语言

  • Previous Page
  • Next Page

它起始于 XSL，结束于 XSLT、XPath 以及 XSL-FO。

起始于 XSL

XSL 指扩展样式表语言（EXtensible Stylesheet Language）。

万维网联盟 (W3C) 开始发展 XSL 的原因是：存在着对于基于 XML 的样式表语言的需求。

CSS = HTML 样式表

HTML 使用预先定义的标签，标签的意义很容易被理解。

HTML 元素中的 <table> 元素定义表格 - 并且浏览器清楚如何显示它。

向 HTML 元素添加样式是很容易的。通过 CSS，很容易告知浏览器用特定的字体或颜色显示一个元素。

XSL = XML 样式表

XML 不使用预先定义的标签（我们可以使用任何喜欢的标签名），并且这些标签的意义并不都那么容易被理解。

<table> 元素意味着一个 HTML 表格，一件家具，或是别的什么东西 - 浏览器不清楚如何显示它。

XSL 可描述如何来显示 XML 文档！

XSL - 不仅仅是样式表语言

XSL 包括三部分：

XSLT
一种用于转换 XML 文档的语言。
XPath
一种用于在 XML 文档中导航的语言。
XSL-FO
一种用于格式化 XML 文档的语言。

本教程的主要内容是 XSLT

本教程的其余部分是 XSLT - 用来转换 XML 文档的语言。

你也可以学习我们的《XPath 教程》和《XSL-FO 教程》。

  • Previous Page
  • Next Page

XSLT 参考手册


Title:


 Title -
Author -
Publisher -


XSLT - 编辑 XML

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT - 编辑 XML

  • Previous Page
  • Next Page

存储在 XML 文件中的数据可通过因特网浏览器进行编辑。

打开、编辑并保存 XML

现在，我们会为您展示如何打开、编辑及保存存储于服务器上的 XML 文件。

我们将使用 XSL 把 XML 文档转换到一个 HTML 表单中。XML 元素的值会被写到 HTML 表单中的 HTML 输入域。此表单是可编辑的。在被编辑完成后，数据会被提交回服务器，XML 文件会得到更新（这部分由 ASP 完成）。

XML 文件和 XSL 文件

首先，请看将被使用的 XML 文档 ("tool.xml")：

<?xml version="1.0" encoding="ISO-8859-1"?>
<tool>
  <field id="prodName">
    <value>HAMMER HG2606</value>
  </field>
  <field id="prodNo">
    <value>32456240</value>
  </field>
  <field id="price">
    <value>$30.00</value>
  </field>
</tool>

查看 XML 文件。

接着，请看下面的样式表("tool.xsl")：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
<html>
<body>
<form method="post" action="edittool.asp">
<h2>Tool Information (edit):</h2>
<table border="0">
<xsl:for-each select="tool/field">
<tr>
<td>
<xsl:value-of select="@id"/>
</td>
<td>
<input type="text">
<xsl:attribute name="id">
  <xsl:value-of select="@id" />
</xsl:attribute>
<xsl:attribute name="name">
  <xsl:value-of select="@id" />
</xsl:attribute>
<xsl:attribute name="value">
  <xsl:value-of select="value" />
</xsl:attribute>
</input>
</td>
</tr>
</xsl:for-each>
</table>
<br />
<input type="submit" id="btn_sub" name="btn_sub" value="Submit" />
<input type="reset" id="btn_res" name="btn_res" value="Reset" />
</form>
</body>
</html>
</xsl:template>
</xsl:stylesheet>

查看 XSL 文件。

上面这个 XSL 文件会循环遍历 XML 文件中的元素，并为每个 XML "field" 元素创建一个输入域。field 元素的 id 属性的值被添加到每个 HTML 输入域的 id 和 name 属性。"value" 元素的值被添加到每个 HTML 输入域的 "value" 属性。结果是，可以得到一个包含 XML 文件中值的可编辑的 HTML 表单。

然后，我们还有第二个样式表："tool_updated.xsl"。这个 XSL 文件会被用来显示已更新的 XML 数据。这个样式表不会输出可编辑 HTML 表单，而是一个静态的 HTML 表格：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
<html>
<body>
<h2>Updated Tool Information:</h2>
<table border="1">
<xsl:for-each select="tool/field">
<tr>
<td><xsl:value-of select="@id" /></td>
<td><xsl:value-of select="value" /></td>
</tr>
</xsl:for-each>
</table>
</body>
</html>
</xsl:template>

</xsl:stylesheet>

查看 XSL 文件。

ASP 文件

在上面 "tool.xsl" 文件中， HTML 表单的 action 属性的值是 "edittool.asp" 。

"edittool.asp" 页面包含两个函数：loadFile() 载入并转换 XML 文件，updateFile() 函数更新 XML 文件：

<%
function loadFile(xmlfile,xslfile)
Dim xmlDoc,xslDoc

'加载 XML 文件
set xmlDoc = Server.CreateObject("Microsoft.XMLDOM")
xmlDoc.async = false
xmlDoc.load(xmlfile)

'加载 XSL 文件
set xslDoc = Server.CreateObject("Microsoft.XMLDOM")
xslDoc.async = false
xslDoc.load(xslfile)

'转换文件
Response.Write(xmlDoc.transformNode(xslDoc))
end function

function updateFile(xmlfile)
Dim xmlDoc,rootEl,f
Dim i

'加载 XML 文件
set xmlDoc = Server.CreateObject("Microsoft.XMLDOM")
xmlDoc.async = false
xmlDoc.load(xmlfile)

'设置 rootEl 变量为根元素
Set rootEl = xmlDoc.documentElement

'循环遍历 form 集
for i = 1 To Request.Form.Count
   '除去表单中的按钮元素
   if instr(1,Request.Form.Key(i),"btn_")=0 then
   'selectSingleNode 方法可查询匹配某个查询的 XML 文件中的某个单一节点。
   '此查询会请求 value 元素，此 value 元素是 field 元素的子元素，
   '而此 field 元素拥有可匹配表单集中当前 key 值的 id 属性。
   '如果存在匹配，则设置 text 属性为表单集中当前域的值。
   set f = rootEl.selectSingleNode("field[@id='" & _
   Request.Form.Key(i) & "']/value")
   f.Text = Request.Form(i)
   end if
next

'保存已修改的 XML 文件
xmlDoc.save xmlfile

'释放所有的对象引用
set xmlDoc=nothing
set rootEl=nothing
set f=nothing

'通过一个样式表加载已修改的 XML 文件，这样客户端就可以看到所编辑的信息
loadFile xmlfile,server.MapPath("tool_updated.xsl")
end function

'如果表单已被提交，则更新XML文件并显示结果，如果没有被提交，则转换此 XML 文件以供编辑
if Request.Form("btn_sub")="" then
loadFile server.MapPath("tool.xml"),server.MapPath("tool.xsl")
else
updateFile server.MapPath("tool.xml")
end if
%>

提示：假如您不了解如何编写 ASP，请学习我们的《ASP 教程》。

注释：我们正在转换并更新位于服务器上的 XML 文件。这是一个跨平台的解决方案。客户端仅能获得从服务器返回的 HTML - 而 HTML 可运行于任何浏览器。

  • Previous Page
  • Next Page

XSLT 参考手册


XSLT - 客户端

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT - 客户端

  • Previous Page
  • Next Page

如果您的浏览器支持 XSLT，那么在浏览器中它可被用来将文档转换为 XHTML。

JavaScript 解决方案

在前面的章节，我们已向您讲解如何使用 XSLT 将某个 XML 文档转换为 XHTML。我们是通过以下途径完成这个工作的：向 XML 文件添加 XSL 样式表，并通过浏览器完成转换。

即使这种方法的效果很好，在 XML 文件中包含样式表引用也不总是令人满意的（例如，在无法识别XSLT的浏览器这种方法就无法奏效）。

更通用的方法是使用 JavaScript 来完成转换。

通过使用 JavaScript，我们可以：

  • 进行浏览器确认测试
  • 根据浏览器和使用者的需求来使用不同的样式表

这就是 XSLT 的魅力所在！XSLT 的设计目的之一就是使一种格式到另一种格式的转换成为可能，同时支持不同类型的浏览器以及不同的用户需求。

浏览器端的 XSLT 转换一定会成为未来浏览器所执行的主要任务之一，同时我们也会看到其在特定的浏览器市场的增长（盲文、网络打印机，听觉设备，等等）。

XML 文件和 XSL 文件

请看这个在前面的章节已展示过的 XML 文档：

<?xml version="1.0" encoding="ISO-8859-1"?>
<catalog>
  <cd>
    <title>Empire Burlesque</title>
    <artist>Bob Dylan</artist>
    <country>USA</country>
    <company>Columbia</company>
    <price>10.90</price>
    <year>1985</year>
  </cd>
.
.
.
</catalog>

查看此 XML 文件。

以及附随的 XSL 样式表：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
  <html>
  <body>
    <h2>My CD Collection</h2>
    <table border="1">
      <tr bgcolor="#9acd32">
        <th align="left">Title</th>
        <th align="left">Artist</th>
      </tr>
      <xsl:for-each select="catalog/cd">
      <tr>
        <td><xsl:value-of select="title" /></td>
        <td><xsl:value-of select="artist" /></td>
      </tr>
      </xsl:for-each>
  </table>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

查看此 XSL 文件。

请注意，这个 XML 文件没有包含对 XSL 文件的引用。

重要事项：上面这句话意味着，XML 文件可使用多个不同的 XSL 样式表来进行转换。

在浏览器中把 XML 转换为 XHTML

这是用于在客户端把 XML 文件转换为 XHTML 的源代码：

<html>
<body>

<script type="text/javascript">

// Load XML
var xml = new ActiveXObject("Microsoft.XMLDOM")
xml.async = false
xml.load("cdcatalog.xml")

// Load XSL
var xsl = new ActiveXObject("Microsoft.XMLDOM")
xsl.async = false
xsl.load("cdcatalog.xsl")

// Transform
document.write(xml.transformNode(xsl))

</script>

</body>
</html>

提示：假如您不了解如何编写 JavaScript，请学习我们的《JavaScript 教程》。

第一段代码创建了微软的 XML 解析器的一个实例，然后把 XML 文件载入了内存。第二段代码创建了解析器的另一个实例，然后把这个 XSL 文件载入了内存。最后一行代码使用 XSL 文档转换了 XML 文档，并在浏览器中把结果作为 XHTML 显示出来。任务完成！

请看它在 IE 中如何工作。

  • Previous Page
  • Next Page

XSLT 参考手册


XSLT - 在服务器上

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT - 在服务器上

  • Previous Page
  • Next Page

由于并非所有的浏览器都支持 XSLT，另一种解决方案是在服务器上完成 XML 至 XHTML 的转化。

跨浏览器解决方案

在前面的章节，我们讲解过如何在浏览器中使用 XSLT 来完成 XML 到 XHTML 的转化。我们创建了一段使用 XML 解析器来进行转化的 JavaScript。JavaScript 解决方案无法工作于没有 XML 解析器的浏览器。为了让 XML 数据适用于任何类型的浏览器，我们必须在服务器上对 XML 文档进行转换，然后将其作为 XHMTL 发送到浏览器。

这是 XSLT 的另一个优点。XSLT 的设计目标之一是使数据在服务器上从一种格式转换到另一种格式成为可能，并向所有类型的浏览器返回可读的数据。

XML 文件和 XSL 文件

请看这个在前面的章节已展示过的 XML 文档：

<?xml version="1.0" encoding="ISO-8859-1"?>
<catalog>
  <cd>
    <title>Empire Burlesque</title>
    <artist>Bob Dylan</artist>
    <country>USA</country>
    <company>Columbia</company>
    <price>10.90</price>
    <year>1985</year>
  </cd>
.
.
.
</catalog>

查看此 XML 文件。

以及附随的 XSL 样式表：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
  <html>
  <body>
    <h2>My CD Collection</h2>
    <table border="1">
      <tr bgcolor="#9acd32">
        <th align="left">Title</th>
        <th align="left">Artist</th>
      </tr>
      <xsl:for-each select="catalog/cd">
      <tr>
        <td><xsl:value-of select="title" /></td>
        <td><xsl:value-of select="artist" /></td>
      </tr>
      </xsl:for-each>
  </table>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

查看此 XSL 文件。

请注意，这个 XML 文件没有包含对 XSL 文件的引用。

重要事项：上面这句话表明，XML 文件可使用多个不同的 XSL 样式表来进行转换。

在服务器把 XML 转换为 XHTML

这是在服务器上把 XML 文件转换为 XHTML 的源代码：

<%
'Load XML
set xml = Server.CreateObject("Microsoft.XMLDOM")
xml.async = false
xml.load(Server.MapPath("cdcatalog.xml"))

'Load XSL
set xsl = Server.CreateObject("Microsoft.XMLDOM")
xsl.async = false
xsl.load(Server.MapPath("cdcatalog.xsl"))

'Transform file
Response.Write(xml.transformNode(xsl))
%>

提示：假如您不了解如何编写 ASP，您可以学习我们的《ASP 教程》。

第一段代码创建了微软的 XML 解析器的一个实例，然后把 XML 文件载入了内存。第二段代码创建了解析器的另一个实例，然后把这个 XSL 文件载入了内存。最后一行代码使用 XSL 文档转换了 XML 文档，并把结果作为 XHTML 发送到您的浏览器。任务完成！

请看它如何工作。

  • Previous Page
  • Next Page

XSLT 参考手册


XSLT - 转换

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT - 转换

  • Previous Page
  • Next Page

实例研究：如何使用 XSLT 将 XML 转换为 XHTML。

我们会在下一节对本例的细节进行解释。

正确的样式表声明

把文档声明为 XSL 样式表的根元素是 <xsl:stylesheet> 或 <xsl:transform>。

注释： <xsl:stylesheet> 和 <xsl:transform> 是完全同义的，均可被使用！

根据 W3C 的 XSLT 标准，声明 XSL 样式表的正确方法是：

<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

或者：

<xsl:transform version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

如需访问 XSLT 的元素、属性以及特性，我们必须在文档顶端声明 XSLT 命名空间。

xmlns:xsl="http://www.w3.org/1999/XSL/Transform" 指向了官方的 W3C XSLT 命名空间。如果您使用此命名空间，就必须包含属性 version="1.0"。

从一个原始的 XML 文档开始

我们现在要把下面这个 XML 文档（"cdcatalog.xml"）转换为 XHTML：

<?xml version="1.0" encoding="ISO-8859-1"?>
<catalog>
  <cd>
    <title>Empire Burlesque</title>
    <artist>Bob Dylan</artist>
    <country>USA</country>
    <company>Columbia</company>
    <price>10.90</price>
    <year>1985</year>
  </cd>
.
.
.
</catalog>

在 Internet Explorer 和 Firefox 中查看 XML 文件：

打开 XML 文件（通常通过点击某个链接） - XML 文档会以颜色化的代码方式来显示根元素及子元素。点击元素左侧的加号或减号可展开或收缩元素的结构。如需查看原始的XML源文件（不带有加号和减号），请在浏览器菜单中选择“查看页面源代码”。

在 Netscape 6 中查看 XML 文件：

打开 XML 文件，然后在 XML 文件中右击，并选择“查看页面源代码”。XML文档会以颜色化的代码方式来显示根元素及子元素。

在 Opera 7 中查看 XML 文件：

打开 XML 文件，然后在XML文件中右击，选择“框架”/“查看源代码”。XML文档将显示为纯文本。

查看"cdcatalog.xml"。

创建 XSL 样式表

然后创建一个带有转换模板的 XSL 样式表（"cdcatalog.xsl"）：

<?xml version="1.0" encoding="ISO-8859-1"?>

<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
  <html>
  <body>
    <h2>My CD Collection</h2>
    <table border="1">
    <tr bgcolor="#9acd32">
      <th align="left">Title</th>
      <th align="left">Artist</th>
    </tr>
    <xsl:for-each select="catalog/cd">
    <tr>
      <td><xsl:value-of select="title"/></td>
      <td><xsl:value-of select="artist"/></td>
    </tr>
    </xsl:for-each>
    </table>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

查看 "cdcatalog.xsl"

把 XSL 样式表链接到 XML 文档

向 XML 文档（"cdcatalog.xml"）添加 XSL 样式表引用：

<?xml version="1.0" encoding="ISO-8859-1"?>
<?xml-stylesheet type="text/xsl" href="cdcatalog.xsl"?>
<catalog>
  <cd>
    <title>Empire Burlesque</title>
    <artist>Bob Dylan</artist>
    <country>USA</country>
    <company>Columbia</company>
    <price>10.90</price>
    <year>1985</year>
  </cd>
.
.
.
</catalog>

如果您使用的浏览器兼容 XSLT，它会很顺利地把您的 XML 转换为 XHTML。

查看结果。

我们会在下一节对上面的例子中的细节进行解释。

  • Previous Page
  • Next Page

XSLT 参考手册


XSLT <xsl:apply-imports> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:apply-imports> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:apply-imports> 元素可应用来自导入样式表中的模版规则。

导入样式表中的模版规则的优先级要比主样式表中的模版规则要低。如果您希望使用导入样式表中的某条模版规则，而不是主样式表中的某条等价规则，就会用到 <xsl:apply-imports> 元素。

语法

<xsl:apply-imports/>

属性

None

实例

假设我们有一个名为 "standard.xsl" 的样式表，其中包含用于 message 元素的模版规则：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="message">
  <h2><xsl:apply-templates/></h2>
</xsl:template>

</xsl:stylesheet>

另一个样式表能够导入 "standard.xsl"，并修改 message，就像这样：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:import href="standard.xsl"/>

<xsl:template match="message">
  <div style="border:solid blue">
  <xsl:apply-imports/>
  </div>
</xsl:template>

</xsl:stylesheet>

结果是：将把一条消息转换到格状的元素中：

<div style="border:solid blue"><h2>...</h2></div>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:apply-templates> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:apply-templates> 元素

  • Previous Page
  • Next Page

<xsl:apply-templates> 元素可把一个模板应用于当前的元素或者当前元素的子节点。

<xsl:apply-templates> 元素

<xsl:apply-templates> 元素可把一个模板应用于当前的元素或者当前元素的子节点。

假如我们向 <xsl:apply-templates> 元素添加一个 select 属性，此元素就会仅仅处理与属性值匹配的子元素。我们可以使用 select 属性来规定子节点被处理的顺序。

请看下面的 XSL 样式表：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
<html>
<body>
<h2>My CD Collection</h2>
<xsl:apply-templates/>
</body>
</html>
</xsl:template>

<xsl:template match="cd">
<p>
<xsl:apply-templates select="title"/>
<xsl:apply-templates select="artist"/>
</p>
</xsl:template>

<xsl:template match="title">
Title: <span style="color:#ff0000">
<xsl:value-of select="."/></span>
<br />
</xsl:template>

<xsl:template match="artist">
Artist: <span style="color:#00ff00">
<xsl:value-of select="."/></span>
<br />
</xsl:template>

</xsl:stylesheet>

查看此XML文件，查看此XSL文件，查看结果。

  • Previous Page
  • Next Page

XSLT 参考手册


XSLT <xsl:apply-templates> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:apply-templates> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:apply-templates> 元素可向当前元素或当前元素的子元素应用模板。

如果我们向 <xsl:apply-templates> 元素添加 select 属性，那么它仅会处理匹配该属性的值的子元素。我们可使用 select 属性来规定处理子介点的顺序。

语法

<xsl:apply-templates select="expression" mode="name">
  <!-- Content:(xsl:sort|xsl:with-param)* -->
</xsl:apply-templates>

属性

属性 | 值 | 描述
select | 表达式 | 可选。规定要处理的节点。星号选取整个节点集。如果省略该属性，则将选取当前节点的所有子节点。
mode | 名称 | 可选。如果存在为相同元素定义的多个处理方法，那么用 mode 可以区分它们。

实例

例子 1

用 h1 元素包围文档中每个 title 元素：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="title">
  <h1><xsl:apply-templates/></h1>
</xsl:template>

</xsl:stylesheet>

例子 2

用 h1 元素包围文档中所有属于 message 的子元素的 title 元素：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="message">
  <h1><xsl:apply-templates select="title"/></h1>
</xsl:template>

</xsl:stylesheet>

例子 3

用 h1 元素包围文档中 mode 属性设置为 "big" 的 message 所有子节点：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="message">
  <h1><xsl:apply-templates select="*" mode="big"/></h1>
</xsl:template>

</xsl:stylesheet>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:attribute-set> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:attribute-set> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:attribute-set> 元素可创建命名的属性集。该属性集（attribute-set）可作为整体应用到输出文档。

注释：必须是 <xsl:stylesheet> 或 <xsl:transform> 的子节点。

语法

<xsl:attribute-set
name="name" use-attribute-sets="name-list">
  <!-- Content:xsl:attribute* -->
</xsl:attribute-set>

属性

属性 | 值 | 描述
name | name | 必需。规定属性集的名称。
use-attribute-sets | name-list | 可选。在该属性集中使用的其它属性集的列表，由空格分隔。

实例

例子 1

创建可应用到任何输出元素的属性集（attribute-set ）：

<xsl:attribute-set name="font">
  <xsl:attribute name="fname">Arial</xsl:attribute>
  <xsl:attribute name="size">14px</xsl:attribute>
  <xsl:attribute name="color">red</xsl:attribute>
</xsl:attribute-set>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:attribute> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:attribute> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:attribute> 元素用于向元素添加属性。

注释：<xsl:attribute> 元素会替换名称相同的已有属性。

语法

<xsl:attribute name="attributename" namespace="uri">
  <!-- Content:template -->
</xsl:attribute>

属性

属性 | 值 | 描述
name | attributename | 必需。规定属性的名称。
namespace | URI | 可选。为属性定义命名空间的 URI。

实例

例子 1

向 picture 元素添加 source 属性：

<picture>
  <xsl:attribute name="source"/>
</picture>

例子 2

向 picture 元素添加 source 属性，并使用 "images/name" 中的值为其赋值：

<picture>
  <xsl:attribute name="source">
    <xsl:value-of select="images/name" />
  </xsl:attribute>
</picture>

例子 3

创建能够应用到任何输出元素的属性集：

<xsl:attribute-set name="font">
  <xsl:attribute name="fname">Arial</xsl:attribute>
  <xsl:attribute name="size">14px</xsl:attribute>
  <xsl:attribute name="color">red</xsl:attribute>
</xsl:attribute-set>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:call-template> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:call-template> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:call-template> 元素可调用一个指定的模板。

语法

<xsl:call-template name="templatename">
  <!-- Content:xsl:with-param* -->
</xsl:call-template>

属性

属性 | 值 | 描述
name | templatename | 必需。规定被调用的模板名称。

实例

例子 1

当处理程序找到一个 car 元素时，调用名为 "description" 的模板：

<xsl:template match="car">
  <xsl:call-template name="description"/>
</xsl:template>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:choose> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:choose> 元素

  • Previous Page
  • Next Page

XSLT <xsl:choose> 元素用于结合 <xsl:when> 和 <xsl:otherwise> 来表达多重条件测试。

<xsl:choose> 元素

语法

<xsl:choose>
  <xsl:when test="expression">
    ... 输出 ...
  </xsl:when>
  <xsl:otherwise>
    ... 输出 ....
  </xsl:otherwise>
</xsl:choose>

在何处放置选择条件

要插入针对 XML 文件的多重条件测试，请向 XSL 文件添加 <xsl:choose>、<xsl:when> 以及 <xsl:otherwise>：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
  <html>
  <body>
    <h2>My CD Collection</h2>
    <table border="1">
      <tr bgcolor="#9acd32">
        <th>Title</th>
        <th>Artist</th>
      </tr>
      <xsl:for-each select="catalog/cd">
      <tr>
        <td><xsl:value-of select="title"/></td>
          <xsl:choose>
          <xsl:when test="price &gt; 10">
            <td bgcolor="#ff00ff">
            <xsl:value-of select="artist"/></td>
          </xsl:when>
          <xsl:otherwise>
            <td><xsl:value-of select="artist"/></td>
          </xsl:otherwise>
        </xsl:choose>
      </tr>
      </xsl:for-each>
    </table>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

上面的代码会在 CD 的价格高于 10 时向 "Artist" 列添加粉色的背景颜色。

上面的转换结果类似这样：

查看此 XML 文件，查看此 XSL 文件，查看结果。

另一个例子

这是另外一个包含两个 <xsl:when> 元素的例子：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
  <html>
  <body>
    <h2>My CD Collection</h2>
    <table border="1">
      <tr bgcolor="#9acd32">
        <th>Title</th>
        <th>Artist</th>
      </tr>
      <xsl:for-each select="catalog/cd">
      <tr>
        <td><xsl:value-of select="title"/></td>
          <xsl:choose>
          <xsl:when test="price &gt; 10">
            <td bgcolor="#ff00ff">
            <xsl:value-of select="artist"/></td>
          </xsl:when>
          <xsl:when test="price &gt; 9">
            <td bgcolor="#cccccc">
            <xsl:value-of select="artist"/></td>
          </xsl:when>
          <xsl:otherwise>
            <td><xsl:value-of select="artist"/></td>
          </xsl:otherwise>
        </xsl:choose>
      </tr>
      </xsl:for-each>
    </table>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

上面的代码会在 CD 的价格高于 10 时向 "Artist" 列添加粉色的背景颜色，并在 CD 的价格高于 9 且低于等于 10 时向 "Artist" 列添加灰色的背景颜色。

上面的转换结果类似这样：

查看此XML文件，查看此XSL文件，查看结果。

  • Previous Page
  • Next Page

XSLT 参考手册


XSLT <xsl:choose> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:choose> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:choose> 元素与 <xsl:when> 以及 <xsl:otherwise> 元素结合，可表达多重条件测试。

如果没有 <xsl:when> 是 true，则处理 <xsl:otherwise> 的内容。

如果没有 <xsl:when> 是 true，且不存在 <xsl:otherwise> 元素，则不创建任何内容。

提示：对于简单的条件测试，请使用 <xsl:if> 元素取而代之。

语法

<xsl:choose>
<!-- Content:(xsl:when+,xsl:otherwise?) -->
</xsl:choose>

属性

None

实例

例子 1

下面的代码会在 CD 的价格高于 10 时，向 artist 列添加粉色的背景色：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
  <html>
  <body>
    <h2>My CD Collection</h2>
    <table border="1">
      <tr bgcolor="#9acd32">
        <th>Title</th>
        <th>Artist</th>
      </tr>
      <xsl:for-each select="catalog/cd">
      <tr>
        <td><xsl:value-of select="title"/></td>
          <xsl:choose>
          <xsl:when test="price &gt; 10">
            <td bgcolor="#ff00ff">
            <xsl:value-of select="artist"/></td>
          </xsl:when>
          <xsl:otherwise>
            <td><xsl:value-of select="artist"/></td>
          </xsl:otherwise>
        </xsl:choose>
      </tr>
      </xsl:for-each>
    </table>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

查看 XML 文件，查看 XSL 文件，查看结果。

例子 2

声明名为 "color" 的变量。把这个变量的值赋值到 current 元素的 color 属性。如果 current 元素没有 color 属性，则 color 的值是 "green"：

<xsl:variable name="color">
  <xsl:choose>
    <xsl:when test="@color">
      <xsl:value-of select="@color"/>
    </xsl:when>
    <xsl:otherwise>green</xsl:otherwise>
  </xsl:choose>
</xsl:variable>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:comment> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:comment> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:comment> 元素用于在结果树中创建注释节点。

语法

<xsl:comment>
<!-- Content:template -->
</xsl:comment>

属性

None

实例

例子 1

<xsl:comment>This is a comment!</xsl:comment>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:copy-of> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:copy-of> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:copy-of> 元素可创建当前节点的一个副本。

注释：当前节点的 Namespace 节点、子节点以及属性都会被自动复制！

提示：该元素可用于把相同节点的多个副本插入到输出的不同位置。

语法

<xsl:copy-of select="expression"/>

属性

属性 | 值 | 描述
select | expression | 必需。规定要拷贝的内容。

实例

例子 1

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:variable name="header">
  <tr>
  <th>Element</th>
  <th>Description</th>
  </tr>
</xsl:variable>

<xsl:template match="/">
  <html>
  <body>
  <table>
    <xsl:copy-of select="$header" />
    <xsl:for-each select="reference/record">
    <tr>
    <xsl:if test="category='XML'">
      <td><xsl:value-of select="element"/></td>
      <td><xsl:value-of select="description"/></td>
    </xsl:if>
    </tr>
    </xsl:for-each>
  </table>
  <br />
  <table>
    <xsl:copy-of select="$header" />
    <xsl:for-each select="table/record">
    <tr>
    <xsl:if test="category='XSL'">
      <td><xsl:value-of select="element"/></td>
      <td><xsl:value-of select="description"/></td>
    </xsl:if>
    </tr>
    </xsl:for-each>
  </table>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:copy> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:copy> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:copy> 元素可创建当前节点的一个副本（拷贝）。

注释：当前节点的 Namespace 节点会被自动复制，但是当前节点的子节点和属性不会被自动复制！

语法

<xsl:copy use-attribute-sets="name-list">
  <!-- Content:template -->
</xsl:copy>

属性

属性 | 值 | 描述
use-attribute-sets | name-list | 可选。如果该节点是元素，则该属性是应用到输出节点的属性集列表，由空格分隔。

实例

例子 1

把 message 节点拷贝到输出文档：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="message">
  <xsl:copy>
    <xsl:apply-templates/>
  </xsl:copy>
</xsl:template>

</xsl:stylesheet>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:decimal-format> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:decimal-format> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:decimal-format> 元素定义了当通过 format-number() 函数把数字转换为字符串时，所要使用的字符和符号。

不是所有国家都使用相同的字符来分隔小数与整数的部分，或者对数字进行分组。通过 <xsl:decimal-format> 元素，您可以把具体到字符更改为其他的符号。

该元素是顶层的元素（top level）。

format-number() 函数可通过名称（name）来引用 <xsl:decimal-format> 元素。

语法

<xsl:decimal-format
name="name"
decimal-separator="char"
grouping-separator="char"
infinity="string"
minus-sign="char"
NaN="string"
percent="char"
per-mille="char"
zero-digit="char"
digit="char"
pattern-separator="char"/>

属性

属性 | 值 | 描述
name | name | 可选。为此格式规定名称。
decimal-separator | char | 可选。规定小数点字符。默认是 "."。
grouping-separator | char | 可选。规定千的分隔字符。默认是 ","。
infinity | string | 可选。规定用来表示无穷大的字符串。默认是 "Infinity"。
minus-sign | char | 可选。规定表示负数的字符。默认是 "-"。
NaN | string | 可选。规定当值不是数字时使用的字符串。默认是 "NaN"。
percent | char | 可选。规定百分比符号的字符。默认是 "%"。
per-mille | char | 可选。规定千分号的字符。默认是 "‰"。
zero-digit | char | 可选。规定数字 0 的字符。默认是 "0"。
digit | char | 可选。规定字符，该字符用于指示需要使用数字的地方。默认是 #。
pattern-separator | char. | 可选。规定字符，该字符用于分隔格式模式中的正负次模式。默认是 ";"。

实例

例子 1

下面的例子展示了，如何格式化为欧洲货币（请注意，format-number() 函数中的第三个参数引用了 <xsl:decimal-format> 元素的名称）：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:decimal-format name="euro" decimal-separator="," grouping-separator="."/>

<xsl:template match="/">
<xsl:value-of select="format-number(26825.8, '#.###,00', 'euro')"/>
</xsl:template>

</xsl:stylesheet>

输出：

26.825,80

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:element> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:element> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:element> 元素用于在输出文档中创建元素节点。

语法

<xsl:element
name="name"
namespace="URI"
use-attribute-sets="namelist">
  <!-- Content:template -->
</xsl:element>

属性

属性 | 值 | 描述
name | name | 必需。规定要创建的元素的名称（可以使用表达式为 name 属性赋值，这个表达式是在运行时进行计算的，比如：<xsl:element name="{$country}" />）
namespace | URI | 可选。规定元素的命名空间 URI。（可以使用表达式为 namespace 属性赋值，这个表达式是在运行时进行计算的，比如：<xsl:element name="{$country}" namespace="{$someuri}"/>）
use-attribute-sets | namelist | 可选。空格分隔的属性集，该属性集包含了需要向元素添加的属性。

实例

例子 1

创建一个名为 "singer" 的元素，该元素包含每个 artist 元素的值：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
  <xsl:for-each select="catalog/cd">
    <xsl:element name="singer">
      <xsl:value-of select="artist" />
    </xsl:element>
    <br />
  </xsl:for-each>
</xsl:template>

</xsl:stylesheet>

查看 XML 文件，查看 XSL 文件，查看结果。

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:fallback> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:fallback> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:fallback> 元素规定了在 XSL 处理程序不支持 XSL 元素时，所执行的替代代码。

语法

<xsl:fallback>

<!-- Content: template -->

</xsl:fallback>

属性

None

实例

例子 1

本例本来是要使用一个虚构的 <xsl:loop> 元素来循环遍历每个 "title" 元素。如果 XSL 处理器不支持该元素（它确实不支持），则会使用 <:xsl:for-each> 元素取而代之：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="catalog/cd">
  <xsl:loop select="title">
    <xsl:fallback>
      <xsl:for-each select="title">
        <xsl:value-of select="."/>
      </xsl:for-each>
    </xsl:fallback>
  </xsl:loop>
</xsl:template>

</xsl:stylesheet>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:for-each> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:for-each> 元素

  • Previous Page
  • Next Page

<xsl:for-each> 元素允许您在 XSLT 中进行循环。

<xsl:for-each> 元素

<xsl:for-each> 元素可用于选取指定的节点集中的每个 XML 元素。

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
  <html>
  <body>
    <h2>My CD Collection</h2>
    <table border="1">
      <tr bgcolor="#9acd32">
        <th>Title</th>
        <th>Artist</th>
      </tr>
      <xsl:for-each select="catalog/cd">
      <tr>
        <td><xsl:value-of select="title"/></td>
        <td><xsl:value-of select="artist"/></td>
      </tr>
      </xsl:for-each>
    </table>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

注释：select 属性的值是一个 XPath 表达式。此表达式的工作方式类似于定位某个文件系统，在其中正斜杠可选择子目录。

上面的转换结果类似这样：

查看此 XML 文件，查看此 XSL 文件，并查看结果。

结果过滤

通过在 <xsl:for-each> 元素中添加一个选择属性的判别式，我们也可以过滤从 XML 文件输出的结果。

<xsl:for-each select="catalog/cd[artist='Bob Dylan']">

合法的过滤运算符:

  • = (等于)
  • != (不等于)
  • &lt; (小于)
  • &gt; (大于)
<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
 <html>
  <body>
  <h2>My CD Collection</h2>
  <table border="1">
   <tr bgcolor="#9acd32">
      <th>Title</th>
      <th>Artist</th>
   </tr>
   <xsl:for-each select="catalog/cd[artist='Bob Dylan']">
   <tr>
      <td><xsl:value-of select="title"/></td>
      <td><xsl:value-of select="artist"/></td>
   </tr>
   </xsl:for-each>
  </table>
 </body>
 </html>
</xsl:template>

</xsl:stylesheet>

上面的转换结果类似这样：

查看此 XML 文件，查看此 XSL 文件，并查看结果。

  • Previous Page
  • Next Page

XSLT 参考手册


XSLT <xsl:for-each> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:for-each> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:for-each> 元素可遍历指定的节点集中的每个节点。

语法

<xsl:for-each
select="expression">

  <!-- Content:(xsl:sort*,template) -->

</xsl:for-each>

属性

属性 | 值 | 描述
select | expression | 必需。被处理的节点集。

实例

例子 1

循环遍历每个 "cd" 元素，并使用 <xsl:value-of> 把每个 title 和 artist 写到输出中：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
  <html>
  <body>
    <h2>My CD Collection</h2>
    <table border="1">
      <tr bgcolor="#9acd32">
        <th>Title</th>
        <th>Artist</th>
      </tr>
      <xsl:for-each select="catalog/cd">
      <tr>
        <td><xsl:value-of select="title"/></td>
        <td><xsl:value-of select="artist"/></td>
      </tr>
      </xsl:for-each>
    </table>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

查看 XML 文件，查看 XSL 文件，查看结果。

例子 2

循环遍历每个 "cd" 元素，并使用 <xsl:value-of> 把每个 title 和 artist 写到输出中（以 artist 排序）：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
  <html>
  <body>
    <h2>My CD Collection</h2>
    <table border="1">
      <tr bgcolor="#9acd32">
        <th>Title</th>
        <th>Artist</th>
      </tr>
      <xsl:for-each select="catalog/cd">
      <xsl:sort select="artist"/>
      <tr>
        <td><xsl:value-of select="title"/></td>
        <td><xsl:value-of select="artist"/></td>
      </tr>
      </xsl:for-each>
    </table>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

查看 XML 文件，查看 XSL 文件，查看结果。

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:if> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:if> 元素

  • Previous Page
  • Next Page

<xsl:if> 元素用于放置针对 XML 文件内容的条件测试。

<xsl:if> 元素

如需放置针对 XML 文件内容的条件测试，请向 XSL 文档添加 <xsl:if> 元素。

语法

<xsl:if test="expression">
  ...
  ...如果条件成立则输出...
  ...
</xsl:if>

在何处放置 <xsl:if> 元素

如需添加有条件的测试，请在 XSL 文件中的 <xsl:for-each> 元素内部添加 <xsl:if> 元素：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
<xsl:template match="/">
  <html>
  <body>
    <h2>My CD Collection</h2>
    <table border="1">
      <tr bgcolor="#9acd32">
        <th>Title</th>
        <th>Artist</th>
      </tr>
      <xsl:for-each select="catalog/cd">
      <xsl:if test="price &gt; 10">
        <tr>
          <td><xsl:value-of select="title"/></td>
          <td><xsl:value-of select="artist"/></td>
        </tr>
      </xsl:if>
      </xsl:for-each>
    </table>
  </body>
  </html>
</xsl:template>
</xsl:stylesheet>

注释：必选的 test 属性的值包含了需要求值的表达式。

上面的代码仅仅会输出价格高于 10 的 CD 的 title 和 artist 元素。

上面的转换结果类似这样：

查看此 XML 文件，查看此 XSL 文件，查看结果。

  • Previous Page
  • Next Page

XSLT 参考手册


XSLT <xsl:if> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:if> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:if> 包含了一个模板，只有指定的条件成立时，才应用此模板。

提示：请使用 <xsl:choose> 与 <xsl:when> 和 <xsl:otherwise> 结合，来表达多重条件测试！

语法

<xsl:if
test="expression">

<!-- Content: template -->

</xsl:if>

属性

属性 | 值 | 描述
test | expression | 必需。规定要测试的条件。

实例

例子 1

当 CD 的价格高于 10 时，选取 title 和 artist 的值：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
  <html>
  <body>
    <h2>My CD Collection</h2>
    <table border="1">
      <tr bgcolor="#9acd32">
        <th>Title</th>
        <th>Artist</th>
      </tr>
      <xsl:for-each select="catalog/cd">
      <xsl:if test="price &gt; 10">
        <tr>
          <td><xsl:value-of select="title"/></td>
          <td><xsl:value-of select="artist"/></td>
        </tr>
      </xsl:if>
      </xsl:for-each>
    </table>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

查看 XML 文件，查看 XSL 文件，查看结果。

例子 2

显示每个 CD 的标题。如果不是最后一个或倒数第二个 CD，则在每个 CD-title 间插入 ", "。如果是最后一个 CD，则在标题后添加 "!"。如果是倒数第二个 CD，则在其后添加 ", and "：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
  <html>
  <body>
    <h2>My CD Collection</h2>
    <p>Titles:
    <xsl:for-each select="catalog/cd">
      <xsl:value-of select="title"/>
      <xsl:if test="position()!=last()">
        <xsl:text>, </xsl:text>
      </xsl:if>
      <xsl:if test="position()=last()-1">
        <xsl:text> and </xsl:text>
      </xsl:if>
      <xsl:if test="position()=last()">
        <xsl:text>!</xsl:text>
      </xsl:if>
    </xsl:for-each>
    </p>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:import> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:import> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:import> 元素是顶层元素，用于把一个样式表中的内容倒入另一个样式表中。

注释：被导入的样式的优先级低于导出的样式表。

注释：该元素必须是 <xsl:stylesheet> 或 <xsl:transform> 的第一个子节点。

注释：Netscape 6 不支持导入优先规则，因此此元素的表现与 <xsl:include> 相同。

语法

<xsl:import href="URI"/>

属性

属性 | 值 | 描述
href | URI | 必需。规定到导入的样式表的 URI。

实例

例子 1

假设您有一个名为 "cdcatalog_ex3.xsl" 的样式表文件：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
 <html>
 <body>
   <h2>My CD Collection</h2>
   <table border="1">
     <tr bgcolor="#9acd32">
       <th>Title</th>
       <th>Artist</th>
     </tr>
     <tr>
      <td><xsl:value-of select="catalog/cd/title"/></td>
      <td><xsl:value-of select="catalog/cd/artist"/></td>
     </tr>
   </table>
 </body>
 </html>
</xsl:template>

</xsl:stylesheet>

第二个名为 "cdcatalog_import.xsl" 的样式表会导入 "cdcatalog_ex3.xsl"：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:import href="cdcatalog_ex3.xsl"/>

<xsl:template match="/">
  <xsl:apply-imports/>
</xsl:template>

</xsl:stylesheet>

查看 XML 文件，查看 XSL 文件，查看结果。

注释：此例无法在 Netscape 6 运行，因为 Netscape 6 不支持 <xsl:apply-imports> 元素！

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:include> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:include> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:include> 元素是顶层元素（top-level element），把一个样式表中的样式表内容包含到另一个样式表中。

注释：被包含的样式表（included style sheet）拥有与包含的样式表（including style sheet）相同的优先级。

注释：该元素必须是 <xsl:stylesheet> 或 <xsl:transform> 的子节点。

语法

<xsl:include href="URI"/>

属性

属性 | 值 | 描述
href | URI | 必需。规定要包含的样式表的 URI。

实例

例子 1

下面的例子包含了名为 xslincludefile.xsl 的样式表：

<?xml version=1.0'?>
<xsl:stylesheet version="1.0"
      xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:output method="xml" omit-xml-declaration="yes"/>

<xsl:template match="/">
   <xsl:for-each select="COLLECTION/BOOK">
      <xsl:apply-templates select="TITLE"/>
      <xsl:apply-templates select="AUTHOR"/>
      <xsl:apply-templates select="PUBLISHER"/>
      <BR/>  <!-- add this -->
   </xsl:for-each>
</xsl:template>

<xsl:template match="TITLE">
  <DIV STYLE="color:blue">
    Title: <xsl:value-of select="."/>
  </DIV>
</xsl:template>

<xsl:include href="/xsl/xslincludefile.xsl" />

</xsl:stylesheet>

查看 XSL 文件，查看被包含的 XSL 文件，查看结果。

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:key> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:key> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:key> 元素是顶层元素，它可声明一个命名的键（即为 XML 文档中指定的元素分配的名称和值对）。

此键通过 key() 函数在样式表中使用，帮助您有效地在复杂的 XML 文档中访问分配的元素。。

注释：键不必是唯一的！

语法

<xsl:key
name="name"
match="pattern"
use="expression"/>

属性

属性 | 值 | 描述
name | name | 必需。规定键的名称。
match | pattern | 必需。定义该键被应用到哪个节点。
use | expression | 必需。指定要作为该键的值使用的表达式。 键值可以是下列任一值：属性、子元素或匹配元素的内容。

实例

例子 1

假设您拥有名为 "persons.xml" 的 XML 文件：

<persons>
  <person name="Tarzan" id="050676"/>
  <person name="Donald" id="070754"/>
  <person name="Dolly" id="231256"/>
</persons>

您可以在 XSL 文件中定义一个键，就像这样：

<xsl:key name="preg" match="person" use="@id"/>

如需找到 id="050676" 的 person，请使用这些代码（在 XSL 文件中）：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:key name="preg" match="person" use="@id"/>

<xsl:template match="/">
  <html>
  <body>
  <xsl:for-each select="key('preg','050676')">
    <p>
    Id: <xsl:value-of select="@id"/><br />
    Name: <xsl:value-of select="@name"/>
    </p>
  </xsl:for-each>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:message> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:message> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:message> 元素可向输出写一条消息。该元素主要用于报告错误。

该元素能够包含几乎任何其他的 XSL 元素（<xsl:text> 、<xsl:value-of> 等等）。

terminate 属性允许您选择在错误发生时，是否应终止转换。

语法

<xsl:message terminate="yes|no">

  <!-- Content:template -->

</xsl:message>

属性

属性 值 描述
terminate
  • yes
  • no
 可选。"yes"：在消息写入输出后，终止处理。"no"：在消息写入输出后，继续进行处理。默认是 "no"。

实例

例子 1

检测 artist 是否是空字符串。如果是，则退出 XSL 处理器，并显示一条消息：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
  <html>
  <body>
  <xsl:for-each select="catalog/cd">
    <p>Title: <xsl:value-of select="title"/><br />
    Artist:
    <xsl:if test="artist=''">
      <xsl:message terminate="yes">
        Error: Artist is an empty string!
      </xsl:message>
    </xsl:if>
    <xsl:value-of select="artist"/>
    </p>
  </xsl:for-each>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:namespace-alias> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:namespace-alias> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:namespace-alias> 元素用于在输出中把样式表中的命名空间替换为不同的命名空间，换句话说，使用其他前缀替换与给定命名空间关联的前缀。

注释：<xsl:namespace-alias> 是顶层元素（top-level element），且必须是 <xsl:stylesheet> 或 <xsl:transform> 的子元素。

有时，XSLT 文件会生成另一个 XSLT。这为命名空间带来了问题，因为没有明确的方式可以声明同一个命名空间的两个前缀，而处理器又不会将两个前缀作为同一个命名空间对待并进行操作。使用 <xsl:namespace-alias> 命令可以将过渡命名空间分配给备用前缀，再应用样式表，然后将备用命名空间映射到 XSLT 命名空间。

虽然 XSL 到 XSL 的文件生成是此命令的主要用途，但并不是唯一用途。可以在任何命名空间冲突的地方使用该命令（例如 xsi: 架构数据类型命名空间）。

语法

<xsl:namespace-alias
stylesheet-prefix="prefix|#default"
result-prefix="prefix|"#default"/>

属性

属性 值 描述
stylesheet-prefix
  • prefix
  • #default
 必需。规定您希望更改的命名空间。
result-prefix
  • prefix
  • #default
 必需。为输出规定期望的命名空间。

实例

例子 1

前缀 wxsl 被在输出中被转换为前缀 xsl：

<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
xmlns:wxsl="http://www.w3school.com.cn/w3style.xsl">

<xsl:namespace-alias stylesheet-prefix="wxsl" result-prefix="xsl"/>

<xsl:template match="/">
  <wxsl:stylesheet>
    <xsl:apply-templates/>
  </wxsl:stylesheet>
</xsl:template>

</xsl:stylesheet>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:number> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:number> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:number> 元素用于测定在源中当前节点的整数位置。它也用于将格式化的数字插入结果树。

语法

<xsl:number
count="expression"
level="single|multiple|any"
from="expression"
value="expression"
format="formatstring"
lang="languagecode"
letter-value="alphabetic|traditional"
grouping-separator="character"
grouping-size="number"/>

属性

属性 | 值 | 描述
count | expression | 可选。XPath 表达式，规定要计算的节点。
level
  • single
  • multiple
  • any

可选。控制如何分配序号。

值可以是：

  • single (默认)
  • multiple
  • any (Netscape 6 不支持)
from | expression | 可选。XPath 表达式，规定从何处开始计数。
value | expression | 可选。规定用户提供的数字，用于代替产生的序号。
format | formatstring | 可选。定义数字的输出格式。可以使用的值。
lang | languagecode | 可选。规定用于编号的语言字母表。
letter-value | alphabetic traditional | 可选。消除使用字母的编号序列之间的歧义。值 "alphabetic" 指定字母序列；值 "traditional" 指定其他序列。默认值为 "alphabetic"。
grouping-separator | character | 可选。规定使用什么字符来分隔组或数字。默认是逗号。
grouping-size | number | 可选。规定分组的大小。默认是 3。

格式标记

格式标记 | 生成的序列
1 | 1 2 3 4 5 ... 10 11 12 ...
01 | 01 02 03 ... 19 10 11 ... 99 100 101...
a | a b c . .
A | A B C ...Z AA AB AC...
i | i ii iii iv v vi vii viii ix x...
I | I II III IV V VI VII VIII IX X...

注释：Netscape 6 不支持的标记：01、a、A、i、I。

实例

例子 1

<xsl:number value="250000" grouping-separator="."/>

输出：

250.000

例子 2

<xsl:number value="250000" grouping-size="2"/>

输出：

25,00,00

例子 3

<xsl:number value="12" grouping-size="1" grouping-separator="#" format="I"/>

输出：

X#I#I

例子 4

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
  <html>
  <body>
  <p>
  <xsl:for-each select="catalog/cd">
    <xsl:number value="position()" format="1" />
    <xsl:value-of select="title" /><br />
  </xsl:for-each>
  </p>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:otherwise> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:otherwise> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:otherwise> 元素规定了 <xsl:choose> 元素的默认行为。在没有 <xsl:when> 的条件应用时，将发生该行为。

语法

<xsl:otherwise>

<!-- Content:template -->

</xsl:otherwise>

属性

None

实例

例子 1

下面的代码将在 cd 的价格高于 30 时，向 artist 列添加粉色的背景色，否则仅仅会输出 artist 的 name：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
  <html>
  <body>
    <h2>My CD Collection</h2>
    <table border="1">
      <tr bgcolor="#9acd32">
        <th>Title</th>
        <th>Artist</th>
      </tr>
      <xsl:for-each select="catalog/cd">
      <tr>
        <td><xsl:value-of select="title"/></td>
          <xsl:choose>
          <xsl:when test="price&gt;'10'">
            <td bgcolor="#ff00ff">
            <xsl:value-of select="artist"/></td>
          </xsl:when>
          <xsl:otherwise>
            <td><xsl:value-of select="artist"/></td>
          </xsl:otherwise>
        </xsl:choose>
      </tr>
      </xsl:for-each>
    </table>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

查看 XML 文件，查看 XSL 文件，查看结果。

例子 2

声明一个名为 "color" 变量。把它的值赋给当前元素的 color 属性。如果当前元素没有 color 属性，"color" 的值将是 "green"：

<xsl:variable name="color">
  <xsl:choose>
    <xsl:when test="@color">
      <xsl:value-of select="@color"/>
    </xsl:when>
    <xsl:otherwise>green</xsl:otherwise>
  </xsl:choose>
</xsl:variable>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:output> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:output> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:output> 元素定义了输出文档的格式。

注释：<xsl:output> 是顶层元素（top-level element），必须是 <xsl:stylesheet> 或 <xsl:transform> 的子节点。

语法

<xsl:output
method="xml|html|text|name"
version="string"
encoding="string"
omit-xml-declaration="yes|no"
standalone="yes|no"
doctype-public="string"
doctype-system="string"
cdata-section-elements="namelist"
indent="yes|no"
media-type="string"/>

属性

属性 | 值 | 描述
method
  • xml
  • html
  • text
  • name
 可选。定义输出的格式。默认是 XML。Netscape 6 仅支持 "html" 和 "xml"。
version | string | 可选。设置输出格式的 W3C 版本号。（仅在 method="html" or method="xml" 时使用）。
encoding | string | 可选。设置输出中编码属性的值。
omit-xml-declaration
  • yes
  • no
 可选。 "yes" 规定在输出中省略 XML 声明 (<?xml...?>)。 "no" 规定应在输出中包含 XML 声明。默认是 "no"。
standalone
    • yes
    • no
 可选。规定 XSLT 处理器是否应输出独立文档声明；该值必须为 yes 或 no。默认是 "no"。Netscape 6 不支持该属性。
doctype-public | string | 可选。规定 DTD 中要使用的公共标识符。即输出中 DOCTYPE 声明的 PUBLIC 属性的值。
doctype-system | string | 可选。规定 DTD 中要使用的系统标识符。即输出中 DOCTYPE 声明的 SYSTEM 属性的值。
cdata-section-elements | namelist | 可选。一个空格分隔的元素列表，这些元素的文本内容应作为 CDATA 部分来输出。
indent
  • yes
  • no
 可选。在输出结果树时是否要增加空白；该值必须为 yes 或 no。Netscape 6 不支持该属性。
media-type | string | 可选。定义输出的 MIME 类型（数据的媒体类型）。默认是 "text/xml"。Netscape 6 不支持该属性。

method 属性

标识用于输出结果树的总体方法。如果没有前缀，则标识此文档中指定的方法，必须是 "xml"、"html"、"text" 或不是 NCName 的限定名 之一）。如果有前缀，则展开并标识输出方法。

method 属性的默认值的选择如下所示。如果下列任何条件为真，默认的输出方法为“html”：

结果树的根节点包含元素子级。

结果树中根节点的第一个元素子级（即文档元素）的扩展名称包含本地部分“html”（任意大小写组合）和空命名空间 URI。

结果树中根节点的第一个元素子级之前的任何文本节点只包含空白字符。

否则，默认的输出方法为 "xml"。如果没有 <xsl:output> 元素或没有 <xsl:output> 元素指定了 method 属性的值，应使用默认的输出方法。

实例

例子 1

在本例中，输出是 XML 文档，版本为 1.0。字符编码方式被设置为 "ISO-8859-1"，输出会进行缩进，以增进可读性：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:output method="xml" version="1.0" encoding="iso-8859-1" indent="yes"/>

...

...

</xsl:stylesheet>

例子 2

在本例中，输出是 HTML 文档，版本是 4.0。字符编码方式被设置为 "ISO-8859-1"，输出会进行缩进，以增进可读性：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:output method="html" version="4.0" encoding="iso-8859-1" indent="yes"/>

...

...

</xsl:stylesheet>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:param> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:param> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:param> 元素用于声明局部或全局参数。

注释：如果在模板内声明参数，就是局部参数，如果作为顶层元素来声明，就是全局参数。

语法

<xsl:param
name="name"
select="expression">

<!-- Content:template -->

</xsl:param>

属性

属性 | 值 | 描述
name | name | 必需。规定参数的名称。
select | expression | 可选。规定 XPath 表达式，该表达式是参数的默认值。

实例

例子 1

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:variable name="xx">
  <html>
  <body>
  <xsl:call-template name="show_title">
    <xsl:with-param name="title" />
  </xsl:call-template>
  </body>
  </html>
</xsl:variable>

<xsl:template name="show_title" match="/">
  <xsl:param name="title" />
  <xsl:for-each select="catalog/cd">
    <p>Title: <xsl:value-of select="$title" /></p>
  </xsl:for-each>
</xsl:template>

</xsl:stylesheet>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:preserve-space> 和 <xsl:strip-space> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:preserve-space> 和 <xsl:strip-space> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:preserve-space> 元素用于定义保留空白的元素。

<xsl:strip-space> 元素用于定义删除空白的元素。

注释：保留空白是默认的设置，所以只有当使用 <xsl:strip-space> 元素使才有必要使用 <xsl:preserve-space> 元素。

注释：<xsl:preserve-space> 元素和 <xsl:strip-space> 元素都是顶层元素（top-level element）。

语法

<xsl:preserve-space elements="list-of-element-names"/>

<xsl:strip-space elements="list-of-element-names"/>

属性

属性 | 值 | 描述
elements | list-of-element-names | 必需。一个空格分隔的元素列表，规定了保留/删除空白的元素。 注释：列表中可包含 "*" 和 "prefix:*"，这样就可以加入所有元素或来自特定命名空间的所有元素。

实例

例子 1

在本例中，我们为 title 和 artist 元素预留了空白节点，并从 country、company、price 以及 year 元素删除了空白节点：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:strip-space elements="country company price year" />
<xsl:preserve-space elements="title artist" />

<xsl:template match="/">
  <html>
  <body>
  <xsl:for-each select="catalog/cd">
    <p>
    <xsl:value-of select="title" /><br />
    <xsl:value-of select="artist" /><br />
    <xsl:value-of select="country" /><br />
    <xsl:value-of select="company" /><br />
    <xsl:value-of select="price" /><br />
    <xsl:value-of select="year" />
    </p>
  </xsl:for-each>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:processing-instruction> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:processing-instruction> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:processing-instruction> 元素可向输出写一条处理指令，即生成处理指令节点。

语法

<xsl:processing-instruction
name="process-name">

属性

属性 | 值 | 描述
name | process-name | 必需。规定处理指令的名称。

实例

例子 1

代码：

<xsl:processing-instruction name="xml-stylesheet">
href="style.css" type="text/css"
</xsl:processing-instruction>

创建标签：

<?xml-stylesheet href="style.css" type="text/css"?>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:sort> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:sort> 元素

  • Previous Page
  • Next Page

<xsl:sort> 元素用于对结果进行排序。

在何处放置排序信息

如需对结果进行排序，只要简单地在 XSL 文件中的 <xsl:for-each> 元素内部添加一个 <xsl:sort> 元素：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
  <html>
  <body>
    <h2>My CD Collection</h2>
    <table border="1">
      <tr bgcolor="#9acd32">
        <th>Title</th>
        <th>Artist</th>
      </tr>
      <xsl:for-each select="catalog/cd">
      <xsl:sort select="artist"/>
      <tr>
        <td><xsl:value-of select="title"/></td>
        <td><xsl:value-of select="artist"/></td>
      </tr>
      </xsl:for-each>
    </table>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

注释：select 属性指示需要排序的 XML 元素。

上面的转换结果类似这样：

查看此 XML 文件，查看此 XSL 文件，并查看结果。

  • Previous Page
  • Next Page

XSLT 参考手册


XSLT <xsl:sort> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:sort> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:sort> 元素用于对结果进行排序。

注释：<xsl:sort> 总是位于 <xsl:for-each> 或 <xsl:apply-templates> 内部。

语法

<xsl:sort
select="expression"
lang="language-code"
data-type="text|number|qname"
order="ascending|descending"
case-order="upper-first|lower-first"/>

属性

属性 | 值 | 描述
select | XPath-expression | 可选。规定节点的排序关键字，即根据哪个节点或节点集来排序。
lang | language-code | 可选。规定排序所用的语言。
data-type
  • text
  • number
  • qname
 可选。规定被排序的数据的数据类型。默认是 "text"。
order
  • ascending
  • descending
 可选。规定排序顺序。默认是 "ascending"。
case-order
  • upper-first
  • lower-first
 可选。规定是否首先按大写字母顺序进行排序。

实例

例子 1

下面的例子将以 artist 为关键字进行排序：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
  <html>
  <body>
    <h2>My CD Collection</h2>
    <table border="1">
      <tr bgcolor="#9acd32">
        <th>Title</th>
        <th>Artist</th>
      </tr>
      <xsl:for-each select="catalog/cd">
      <xsl:sort select="artist"/>
      <tr>
        <td><xsl:value-of select="title"/></td>
        <td><xsl:value-of select="artist"/></td>
      </tr>
      </xsl:for-each>
    </table>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:stylesheet> 和 <xsl:transform> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:stylesheet> 和 <xsl:transform> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:stylesheet> 和 <xsl:transform> 元素是完全同义的元素。都被用来定义样式表的根元素。

语法

<xsl:stylesheet
id="name"
version="version"
extension-element-prefixes="list"
exclude-result-prefixes="list">

  <!-- Content:(<xsl:import>*,top-level-elements) -->

</xsl:stylesheet>
<xsl:transform
id="name"
version="version"
extension-element-prefixes="list"
exclude-result-prefixes="list">

  <!-- Content:(<xsl:import>*,top-level-elements) -->

</xsl:transform>

属性

属性 | 值 | 描述
version | version | 必需。规定样式表的 XSLT 版本。
extension-element-prefixes | list | 可选。扩展元素的命名空间前缀列表，用空格分隔。 Netscape 6 不支持该属性。
exclude-result-prefixes | list | 可选。不应再输出中出现的命名空间前缀列表，用空格分隔。
id | name | 可选。样式表的唯一 id。 Netscape 6 不支持该属性。

实例

例子 1

<?xml version="1.0" encoding="ISO-8859-1"?>

<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

....

....

</xsl:stylesheet>

例子 2

<?xml version="1.0" encoding="ISO-8859-1"?>

<xsl:transform version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

....

....

</xsl:transform>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:template> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:template> 元素

  • Previous Page
  • Next Page

XSL 样式表由一个或多套被称为模板（template）的规则组成。

每个模板含有当某个指定的节点被匹配时所应用的规则。

<xsl:template> 元素

<xsl:template> 元素用于构建模板。

match 属性用于关联 XML 元素和模板。match 属性也可用来为整个文档定义模板。match 属性的值是 XPath 表达式（举例，match="/" 定义整个文档）。

好了，让我们看一下上一节中的 XSL 文件的简化版本：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
 <html>
 <body>
   <h2>My CD Collection</h2>
   <table border="1">
     <tr bgcolor="#9acd32">
       <th>Title</th>
       <th>Artist</th>
     </tr>
     <tr>
       <td>.</td>
       <td>.</td>
     </tr>
   </table>
 </body>
 </html>
</xsl:template>

</xsl:stylesheet>

代码解释：

由于 XSL 样式表本身也是一个 XML 文档，因此它总是由 XML 声明起始：

<?xml version="1.0" encoding="ISO-8859-1"?>

下一个元素，<xsl:stylesheet>，定义此文档是一个 XSLT 样式表文档（连同版本号和 XSLT 命名空间属性）。

<xsl:template> 元素定义了一个模板。而 match="/" 属性则把此模板与 XML 源文档的根相联系。

<xsl:template> 元素内部的内容定义了写到输出结果的 HTML 代码。

最后两行定义了模板的结尾，及样式表的结尾。

以上转换的结果类似这样：

查看XML文件，查看 XSL 文件，查看结果

此例的结果有一点小缺陷，因为数据没有从 XML 文档被复制到输出。

在下一节，您将学习到如何使用 <xsl:value-of> 元素从 XML 元素选取值。

  • Previous Page
  • Next Page

XSLT 参考手册


XSLT <xsl:template> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:template> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:template> 元素包含了当匹配指定节点时要应用的规则。

match 属性用于把模板关联到某个 XML 元素。match 属性也能用于为 XML 文档的全部分支定义模板（比如，match="/" 定义了整个文档）。

注释：<xsl:template> 是顶层元素（top-level element）。

语法

<xsl:template
name="name"
match="pattern"
mode="mode"
priority="number">

  <!-- Content:(<xsl:param>*,template) -->

</xsl:template>

属性

属性 | 值 | 描述
name | name | 可选。为模板定义名称。 注释：如果省略该属性，则必须设置 match 属性。
match | pattern | 可选。模板的匹配模式。 注释：如果省略该属性，则必须设置 name 属性。
mode | mode | 可选。为模板规定模式。
priority | number | 可选。模板的优先级编号。

实例

例子 1

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
  <html>
  <body>
  <h2>My CD Collection</h2>
  <xsl:apply-templates/>
  </body>
  </html>
</xsl:template>

<xsl:template match="cd">
  <p>
  <xsl:apply-templates select="title"/>
  <xsl:apply-templates select="artist"/>
  </p>
</xsl:template>

<xsl:template match="title">
  Title: <span style="color:#ff0000">
  <xsl:value-of select="."/></span>
  <br />
</xsl:template>

<xsl:template match="artist">
  Artist: <span style="color:#00ff00">
  <xsl:value-of select="."/></span>
  <br />
</xsl:template>

</xsl:stylesheet>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:text> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:text> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:text> 元素用于向输出写文本，即通过样式表生成文本节点。

提示：该元素可包含文本、实体引用，以及 #PCDATA。

语法

<xsl:text disable-output-escaping="yes|no">

  <!-- Content:#PCDATA -->

</xsl:text>

属性

属性 值 描述
disable-output-escaping
  • yes
  • no
 可选。 默认值为 "no"。如果值为 "yes"，通过实例化 <xsl:text> 元素生成的文本节点在输出时将不进行任何转义。 比如如果设置为 "yes"，则 "<" 将不进行转换。如果设置为 "no"，则被输出为 "&lt;"。 Netscape 6 不支持该属性。

实例

例子 1

显示每个 CD 的 title。如果不是最后一个或倒数第二个 CD，则在每个 cd-title 之间插入 ", "。如果是最后的 CD，则在 title 后添加 "!"。如果是倒数第二个 CD，则在 title 后添加 ", and "：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
  <html>
  <body>
    <h2>My CD Collection</h2>
    <p>Titles:
    <xsl:for-each select="catalog/cd">
      <xsl:value-of select="title"/>
      <xsl:if test="position() < last()-1">
        <xsl:text>, </xsl:text>
      </xsl:if>
      <xsl:if test="position()=last()-1">
        <xsl:text>, and </xsl:text>
      </xsl:if>
      <xsl:if test="position()=last()">
        <xsl:text>!</xsl:text>
      </xsl:if>
    </xsl:for-each>
    </p>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:value-of> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:value-of> 元素

  • Previous Page
  • Next Page

<xsl:value-of> 元素用于提取某个选定节点的值。

<xsl:value-of> 元素

<xsl:value-of> 元素用于提取某个选定节点的值，并把值添加到转换的输出流中：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
 <html>
 <body>
   <h2>My CD Collection</h2>
   <table border="1">
     <tr bgcolor="#9acd32">
       <th>Title</th>
       <th>Artist</th>
     </tr>
     <tr>
      <td><xsl:value-of select="catalog/cd/title"/></td>
      <td><xsl:value-of select="catalog/cd/artist"/></td>
     </tr>
   </table>
 </body>
 </html>
</xsl:template>

</xsl:stylesheet>

注释：select 属性的值是一个 XPath 表达式。此表达式的工作方式类似于定位某个文件系统，在其中正斜杠可选择子目录。

上面的转换结果类似这样：

查看此 XML 文件，查看此 XSL 文件，并查看结果。

这个例子的结果有一点缺陷：仅有一行数据从 XML 文档被拷贝到输出结果。

在下面的章节中，你将学习如何使用 <xsl:for-each> 元素来循环遍历 XML 元素，并显示所有的记录。

  • Previous Page
  • Next Page

XSLT 参考手册


XSLT <xsl:value-of> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:value-of> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:value-of> 元素可提取选定节点的值。

<xsl:value-of> 元素可用于选取某个 XML 元素的值，并把它输出。

注释：select 属性（必选）的值是一个 XPath 表达式。它的工作原理类似对文件系统的定位，比如用一个斜杠来选择子目录。

语法

<xsl:value-of
select="expression"
disable-output-escaping="yes|no"/>

属性

属性 | 值 | 描述
select | expression | 必需。XPath 表达式，规定了从哪个节点/属性来提取值。
disable-output-escaping
  • yes
  • no
 默认值为 "no"。如果值为 "yes"，通过实例化 <xsl:text> 元素生成的文本节点在输出时将不进行任何转义。 比如如果设置为 "yes"，则 "<" 将不进行转换。如果设置为 "no"，则被输出为 "&lt;"。

实例

例子 1

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
 <html>
 <body>
   <h2>My CD Collection</h2>
   <table border="1">
     <tr bgcolor="#9acd32">
       <th>Title</th>
       <th>Artist</th>
     </tr>
     <tr>
      <td><xsl:value-of select="catalog/cd/title"/></td>
      <td><xsl:value-of select="catalog/cd/artist"/></td>
     </tr>
   </table>
 </body>
 </html>
</xsl:template>

</xsl:stylesheet>

查看 XML 文件，查看 XSL 文件，查看结果。

例子 2

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
  <html>
  <body>
    <h2>My CD Collection</h2>
    <table border="1">
      <tr bgcolor="#9acd32">
        <th>Title</th>
        <th>Artist</th>
      </tr>
      <xsl:for-each select="catalog/cd">
      <tr>
        <td><xsl:value-of select="title"/></td>
        <td><xsl:value-of select="artist"/></td>
      </tr>
      </xsl:for-each>
    </table>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

查看 XML 文件，查看 XSL 文件，查看结果。

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:variable> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:variable> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:variable> 元素用于声明局部或全局的变量。

注释：如果被声明为顶层元素，则该变量是全局的，而如果在模板内声明，则变量是本地的。

注释：一旦您设置了变量的值，就无法改变或修改该值！

提示：您可以通过 <xsl:variable> 元素的内容或通过 select 属性，向变量添加值！

语法

<xsl:variable
name="name"
select="expression">

  <!-- Content:template -->

</xsl:variable>

属性

属性 | 值 | 描述
name | name | 必需。规定变量的名称。
select | expression | 可选。定义变量的值。

实例

例子 1

如果设置了 select 属性，<xsl:variable> 元素就不能包含任何内容。如果 select 属性含有文字字符串，则必须给字符串加引号。

下面的两个例子为变量 "color" 赋值 "red"：

<xsl:variable name="color" select="'red'" />
<xsl:variable name="color" select='"red"' />

例子 2

如果 <xsl:variable> 元素只包包含 name 属性，且没有内容，则变量的值是空字符串：

<xsl:variable name="j" />

例子 3

下面的例子通过 <xsl:variable> 元素的内容为变量 "header" 赋值：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:variable name="header">
  <tr>
  <th>Element</th>
  <th>Description</th>
  </tr>
</xsl:variable>

<xsl:template match="/">
  <html>
  <body>
  <table>
    <xsl:copy-of select="$header" />
    <xsl:for-each select="reference/record">
    <tr>
    <xsl:if category="XML">
      <td><xsl:value-of select="element"/></td>
      <td><xsl:value-of select="description"/></td>
    </xsl:if>
    </tr>
    </xsl:for-each>
  </table>
  <br />
  <table>
    <xsl:copy-of select="$header" />
    <xsl:for-each select="table/record">
    <tr>
    <xsl:if category="XSL">
      <td><xsl:value-of select="element"/></td>
      <td><xsl:value-of select="description"/></td>
    </xsl:if>
    </tr>
    </xsl:for-each>
  </table>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:when> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:when> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:when> 元素用于为 <xsl:choose> 元素规定相关动作。

<xsl:when> 元素会计算一个表达式，如果返回 true，则执行规定的动作。

注释：<xsl:when> 元素提供多个与 <xsl:choose> 元素和 <xsl:otherwise> 元素有关的条件测试。

语法

<xsl:when test="boolean-expression">

  <!-- Content: template -->

</xsl:when>

属性

属性 | 值 | 描述
test | boolean-expression | 必需。规定要测试的布尔表达式。

实例

例子 1

下面的代码会在 cd 的 price 高于 10 时向 artist 列添加粉色的背景色：

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
  <html>
  <body>
    <h2>My CD Collection</h2>
    <table border="1">
      <tr bgcolor="#9acd32">
        <th>Title</th>
        <th>Artist</th>
      </tr>
      <xsl:for-each select="catalog/cd">
      <tr>
        <td><xsl:value-of select="title"/></td>
          <xsl:choose>
          <xsl:when test="price&gt;'10'">
            <td bgcolor="#ff00ff">
            <xsl:value-of select="artist"/></td>
          </xsl:when>
          <xsl:otherwise>
            <td><xsl:value-of select="artist"/></td>
          </xsl:otherwise>
        </xsl:choose>
      </tr>
      </xsl:for-each>
    </table>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

查看 XML 文件，查看 XSL 文件，查看结果。

例子 2

声明了一个名为 "color" 的变量。把它的值赋给当前元素的 color 属性。如果当前元素没有 color 属性，则 "color" 的值将是 "green"：

<xsl:variable name="color">
  <xsl:choose>
    <xsl:when test="@color">
      <xsl:value-of select="@color"/>
    </xsl:when>
    <xsl:otherwise>green</xsl:otherwise>
  </xsl:choose>
</xsl:variable>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT <xsl:with-param> 元素

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT <xsl:with-param> 元素

返回 XSLT 元素参考手册

定义和用法

<xsl:with-param> 元素定义了传递给模板的参数的值。

注释：<xsl:with-param> 元素的 name 属性的值必须与 <xsl:param> 元素中的 name 相匹配，否则将忽略 <xsl:with-param> 元素，。

注释：<xsl:call-template> 和 <xsl:apply-templates> 中均允许使用 <xsl:with-param> 元素。

提示：您可以通过 <xsl:with-param> 元素的内容或通过 select 属性，来为参数赋值。

语法

<xsl:with-param name="name" select="expression">

  <!-- Content:template -->

</xsl:with-param>

属性

属性 | 值 | 描述
name | name | 必需。规定参数的名称。
select | expression | 可选。定义参数的值的 XPath 表达式。

实例

例子 1

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:variable name="xx">
  <html>
  <body>
  <xsl:call-template name="show_title">
    <xsl:with-param name="title" />
  </xsl:call-template>
  </body>
  </html>
</xsl:variable>

<xsl:template name="show_title" match="/">
  <xsl:param name="title" />
  <xsl:for-each select="catalog/cd">
    <p>Title: <xsl:value-of select="$title" /></p>
  </xsl:for-each>
</xsl:template>

</xsl:stylesheet>

返回 XSLT 元素参考手册

XSLT 参考手册


XSLT current() 函数

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT current() 函数

返回 XSLT 函数参考手册

定义和用法

current() 函数返回仅包含当前节点的节点集。通常，当前节点与上下文节点是相同的。

<xsl:value-of select="current()"/>

等于

<xsl:value-of select="."/>

不过，有一点不同。让我们看一下下面的 XPath 表达式："catalog/cd"。表达式选择了当前节点的 <catalog> 子节点，然后选择了 <catalog> 节点的 <cd> 子节点。这意味着，在计算的每一步上，"." 都有不同的意义。

下面这行：

<xsl:apply-templates select="//cd[@title=current()/@ref]"/>

将处理 title 属性的值等于当前节点的 ref 属性的值的所有 cd 元素。

与这个不同：

<xsl:apply-templates select="//cd[@title=./@ref]"/>

这个会处理 title 属性和 ref 属性具有相同值的所有 cd 元素。

语法

node-set current()

例子

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
  <html>
  <body>
  <xsl:for-each select="catalog/cd/artist">
    Current node: <xsl:value-of select="current()"/>
    <br />
  </xsl:for-each>
  </body>
  </html>
</xsl:template>

</xsl:stylesheet>

查看 XML 文件，查看 XSL 文件，查看结果。

返回 XSLT 函数参考手册

XSLT 参考手册


XSLT document() 函数

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT document() 函数

返回 XSLT 函数参考手册

定义和用法

document() 函数用于访问外部 XML 文档中的节点。外部 XML 文档必须是合法且可解析的。

此函数提供了从 XSLT 样式表中检索由输入流提供的初始数据以外的其他 XML 资源的方法。

使用该函数的一种方式是是在一个外部文档中查找数据。举例来说，我们希望找到与华氏度值相对应的摄氏度值，我们访问了包含预计算值的文档：

<xsl:value-of select="document('celsius.xml')/celsius/result[@value=$value]"/>

语法

node-set document(object,node-set?)

参数

参数 | 描述
object | 必需。定义外部 XML 文档的URI。
node-set | 可选。用于解析相对 URI。

返回 XSLT 函数参考手册

XSLT 参考手册


XSLT element-available() 函数

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT element-available() 函数

返回 XSLT 函数参考手册

定义和用法

element-available() 函数返回一个布尔值，该值指示 XSLT 处理器是否支持指定的元素。

该函数只能用来测试位于模板主体的元素。这些元素是：

  • xsl:apply-imports
  • xsl:apply-templates
  • xsl:attributes
  • xsl:call-template
  • xsl:choose
  • xsl:comment
  • xsl:copy
  • xsl:copy-of
  • xsl:element
  • xsl:fallback
  • xsl:for-each
  • xsl:if
  • xsl:message
  • xsl:number
  • xsl:processing instruction
  • xsl:text
  • xsl:value-of
  • xsl:variable

语法

boolean element-available(string)

参数

参数 | 描述
string | 必需。规定要测试的元素。

例子

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
<html>
<body>
<xsl:choose>
<xsl:when test="element-available('xsl:comment')">
<p>xsl:comment is supported.</p>
</xsl:when>
<xsl:otherwise>
<p>xsl:comment is not supported.</p>
</xsl:otherwise>
</xsl:choose>
<xsl:choose>
<xsl:when test="element-available('xsl:delete')">
<p>xsl:delete is supported.</p>
</xsl:when>
<xsl:otherwise>
<p>xsl:delete is not supported.</p>
</xsl:otherwise>
</xsl:choose>
</body>
</html>
</xsl:template>

</xsl:stylesheet>

查看 XSL 文件，查看结果。

返回 XSLT 函数参考手册

XSLT 参考手册


XSLT format-number() 函数

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT format-number() 函数

返回 XSLT 函数参考手册

定义和用法

format-number() 函数用于把数字转换为字符串。

语法

string format-number(number,format,[decimalformat])

参数

参数 | 描述
number | 必需。规定要格式化的数字。
format 必需。规定格式化模式。这是用在格式化模式中的字符：
  • # (表示数字。例如：####)
  • 0 (表示“.”字符前面和后面的零。例如：0000.00)
  • . (小数点的位置。例如：###.##)
  • , (千的组分隔符。例如：###,###.##)
  • % (把数字显示为百分比。例如：##%)
  • ; (模式分隔符。第一个模式用于正数，第二个模式用于负数。)
decimalformat | 可选。十进制格式名称。

例子

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
<html>
<body>
<xsl:value-of select='format-number(500100, "#.00")' />
<br />
<xsl:value-of select='format-number(500100, "#.0")' />
<br />
<xsl:value-of select='format-number(500100, "###,###.00")' />
<br />
<xsl:value-of select='format-number(0.23456, "##%")' />
<br />
<xsl:value-of select='format-number(500100, "#######")' />
</body>
</html>
</xsl:template>

</xsl:stylesheet>

查看 XSL 文件，查看结果。

返回 XSLT 函数参考手册

XSLT 参考手册


XSLT function-available() 函数

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT function-available() 函数

返回 XSLT 函数参考手册

定义和用法

function-available() 函数返回一个布尔值，该值指示 XSLT 处理器是否支持指定的函数。

你可以测试 XSLT 函数和被继承的 XPath 函数。

语法

boolean function-available(string)

参数

参数 | 描述
string | 必需。规定要测试的函数。

例子

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
<html>
<body>
<xsl:choose>
<xsl:when test="function-available('sum')">
<p>sum() is supported.</p>
</xsl:when>
<xsl:otherwise>
<p>sum() is not supported.</p>
</xsl:otherwise>
</xsl:choose>
<xsl:choose>
<xsl:when test="function-available('current')">
<p>current() is supported.</p>
</xsl:when>
<xsl:otherwise>
<p>current() is not supported.</p>
</xsl:otherwise>
</xsl:choose>
</body>
</html>
</xsl:template>

</xsl:stylesheet>

查看 XSL 文件，查看结果。

返回 XSLT 函数参考手册

XSLT 参考手册


XSLT generate-id() 函数

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT generate-id() 函数

返回 XSLT 函数参考手册

定义和用法

generate-id() 函数返回唯一标识指定节点的字符串值。

如果指定的节点集是空的，则返回空字符串。如果省略了 node-set 参数，则默认设置为当前节点。

语法

string generate-id(node-set?)

参数

参数 | 描述
node-set | 可选。规定生成哪个节点集的唯一 id。

例子

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
<html>
<body>
<h3>Artists:</h3>
<ul>
<xsl:for-each select="catalog/cd">
<li>
<a href="#{generate-id(artist)}">
<xsl:value-of select="artist" /></a>
</li>
</xsl:for-each>
</ul>
<hr />
<xsl:for-each select="catalog/cd">
Artist: <a name="{generate-id(artist)}">
<xsl:value-of select="artist" /></a>
<br />
Title: <xsl:value-of select="title" />
<br />
Price: <xsl:value-of select="price" />
<hr />
</xsl:for-each>
</body>
</html>
</xsl:template>

</xsl:stylesheet>

查看 XSL 文件，查看 XSL 文件，查看结果。

返回 XSLT 函数参考手册

XSLT 参考手册


XSLT key() 函数

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT key() 函数

返回 XSLT 函数参考手册

定义和用法

通过使用由 <xsl:key> 元素规定的索引号，key() 函数从文档中返回节点集。

key() 函数检索与 <xsl:key> 语句中指定的键名和键值相同的节点集（零个或多个节点）。初次处理 XSLT 样式表时，键将存储在内部，以便简化访问。键可以简化对 XML 文档中的节点的访问，但是也许不会比使用 XPath 检索相同的节点速度更快。

参阅 <xsl:key> 元素。

语法

node-set key(string, object)

参数

参数 | 描述
string | 必需。规定 xsl:key 元素的名称。
object | 必需。要检索的字符串。

例子

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:key name="cdlist" match="cd" use="title" />

<xsl:template match="/">
<html>
<body>
<xsl:for-each select="key('cdlist', 'Empire Burlesque')">
  <p>
  Title: <xsl:value-of select="title" />
  <br />
  Artist: <xsl:value-of select="artist" />
  <br />
  Price: <xsl:value-of select="price" />
  </p>
</xsl:for-each>
</body>
</html>
</xsl:template>

</xsl:stylesheet>

查看 XSL 文件，查看 XSL 文件，查看结果。

返回 XSLT 函数参考手册

XSLT 参考手册


XSLT system-property() 函数

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT system-property() 函数

返回 XSLT 函数参考手册

定义和用法

system-property() 函数返回通过名称标识的系统属性的值。

在 XSLT 命名空间中的系统属性：

系统属性 | 说明
xsl:version | 提供处理器所实现的 XSLT 版本的数字； 如果 XSLT 处理器实现本文档所指定的 XSLT 版本，该数字为 1。
xsl:vendor | XSLT 处理器的开发商。
xsl:vendor-url | 标识XSLT 处理器的开发商的 URL。
msxsl:version | 提供 Microsoft XML 核心服务 (MSXML) 版本的数字。

语法

object system-property(string)

参数

参数 | 描述
string | 必需。规定返回其值的系统属性。

例子

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="/">
<html>
<body>
<p>
Version:
<xsl:value-of select="system-property('xsl:version')" />
<br />
Vendor:
<xsl:value-of select="system-property('xsl:vendor')" />
<br />
Vendor URL:
<xsl:value-of select="system-property('xsl:vendor-url')" />
</p>
</body>
</html>
</xsl:template>

</xsl:stylesheet>

查看 XSL 文件，查看结果。

返回 XSLT 函数参考手册

XSLT 参考手册


XSLT unparsed-entity-uri() 函数

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT node-set() 函数

返回 XSLT 函数参考手册

定义和用法

使您可以将树转换为节点集。产生的节点集总是包含单个节点并且是树的根节点。

对于早期版本的 Microsoft XML 核心服务 (MSXML)，可以使用 <xsl:for-each select="$var/el"> 等表达式，其中的 var 是绑定到结果树上的 XSLT 变量。但是，此方法不适用于 MSXML 版本 3.0 以及更高版本。要在这些更高版本的 MSXML 中获得相同的结果，请使用 node-set 函数，如以下代码示例中所示。

<xsl:for-each select="msxsl:node-set($var)/el)">

语法

msxsl:node-set(string)

返回 XSLT 函数参考手册

XSLT 参考手册


XSLT unparsed-entity-uri() 函数

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT unparsed-entity-uri() 函数

返回 XSLT 函数参考手册

定义和用法

unparsed-entity-uri() 函数返回未解析实体的 URI。实体名称必须匹配被传递的参数。如果定义了实体，则返回未分析实体的 URI 字符串。否则，返回空字符串。

如果 DTD 含有下面的声明：

<!ENTITY pic SYSTEM "http://www.w3school.com.cn/picture.jpg" NDATA JPEG>

这个表达式：

unparsed-entity-uri('pic')

将返回文件 "picture.jpg" 的 URI。

语法

string unparsed-entity-uri(string)

参数

参数 | 描述
string | 必需。规定未解析的实体的名称。必须在与上下文节点相同的文档中定义实体。

返回 XSLT 函数参考手册

XSLT 参考手册


XSLT 函数参考手册

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT 函数参考手册

  • Previous Page
  • Next Page

XQuery 1.0、XPath 2.0 以及 XSLT 2.0 共享相同的函数库。

XSLT 函数

XSLT 含有超过 100 个内建的函数。这些函数用于字符串值、数值、日期和时间比较、节点和 QName 操作、序列操作、逻辑值，等等等等。

XSLT 函数的命名空间的 URI 是：

http://www.w3.org/2005/02/xpath-functions

函数命名空间的默认前缀是 fn。

提示：函数在被调用时常带有 fn: 前缀，比如 fn:string()。不过，既然 fn: 是命名空间的默认前缀，那么在被调用时，函数的名称不必使用前缀。

您可以在我们的 XPath 教程中访问所有内建的 XSLT 2.0 函数参考。

此外，在此列出了内建的 XSLT 函数：

名称 | 描述
current() | 返回当前节点作为唯一成员的节点集。
document() | 用于访问外部 XML 文档中的节点。
element-available() | 检测 XSLT 处理器是否支持指定的元素。
format-number() | 把数字转换为字符串。
function-available() | 检测 XSLT 处理器是否支持指定的函数。
generate-id() | 返回唯一标识指定节点的字符串值。
key() | 检索以前使用 <xsl:key> 语句标记的元素。
node-set | 将树转换为节点集。产生的节点集总是包含单个节点并且是树的根节点。
system-property() | 返回系统属性的值。
unparsed-entity-uri() | 返回未解析实体的 URI。
  • Previous Page
  • Next Page

XSLT 参考手册


XSLT 简介

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT 简介

  • Previous Page
  • Next Page

XSLT 是一种用于将 XML 文档转换为 XHTML 文档或其他 XML 文档的语言。

XPath 是一种用于在 XML 文档中进行导航的语言。

学习之前，您需要具备的基础知识：

在您继续学习之前，需要对以下知识有基本的了解：

  • HTML / XHTML
  • XML / XML 命名空间
  • XPath

如果您希望首先学习这些项目，请在我们的 首页 访问这些教程。

什么是 XSLT？

  • XSLT 指 XSL 转换（XSL Transformations）。
  • XSLT 是 XSL 中最重要的部分。
  • XSLT 可将一种 XML 文档转换为另外一种 XML 文档。
  • XSLT 使用 XPath 在 XML 文档中进行导航。
  • XPath 是一个 W3C 标准。

XSLT = XSL 转换

XSLT 是 XSL 中最重要的部分。

XSLT 用于将一种 XML 文档转换为另外一种 XML 文档，或者可被浏览器识别的其他类型的文档，比如 HTML 和 XHTML。通常，XSLT 是通过把每个 XML 元素转换为 (X)HTML 元素来完成这项工作的。

通过 XSLT，您可以向或者从输出文件添加或移除元素和属性。您也可重新排列元素，执行测试并决定隐藏或显示哪个元素，等等。

描述转化过程的一种通常的说法是，XSLT 把 XML 源树转换为 XML 结果树。

XSLT 使用 XPath

XSLT 使用 XPath 在 XML 文档中查找信息。XPath 被用来通过元素和属性在 XML 文档中进行导航。

如果您希望首先学习 XPath，请访问我们的 XPath 教程。

它如何工作？

在转换过程中，XSLT 使用 XPath 来定义源文档中可匹配一个或多个预定义模板的部分。一旦匹配被找到，XSLT 就会把源文档的匹配部分转换为结果文档。

XSLT 是 W3C 标准

XSLT 在 1999 年 11 月 16 日被确立为 W3C 标准。

如需更多有关 W3C 的 XSLT 活动的信息，请访问我们的 W3C 教程。

  • Previous Page
  • Next Page

XSLT 参考手册


XSLT 教程

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT 教程

  • Next Page

XSL 指扩展样式表语言（EXtensible Stylesheet Language）。

万维网联盟开始发展 XSL 的起因是由于对基于 XML 的样式表语言的需求。

XSLT 指 XSL 转换。在此教程中，你将学习如何使用 XSLT 将 XML 文档转换为其他文档，比如 XHTML。

开始学习 XSLT ！

XSLT 参考手册

XSLT 元素
对所有来自 W3C 标准的 XSLT 元素进行了描述，以及关于浏览器支持的信息。
XSLT 函数
XSLT 包含了超过 100 个内置函数。 这些函数可以用于字符串、数值、日期和时间比较、节点和 QName 处理, 序列处理, 逻辑值等等。

内容目录

XSL 语言
详细解释 XSL 的子语言: XSLT、XPath 和 XSL-FO。
XSLT 简介
XSLT 的简介。包括其概念和作用。
XSLT 浏览器
支持 XSLT 的浏览器总论。
XSLT 转换
如何使用 XSLT 将 XML 文档转换为 XHTML 文档。
XSLT 模板
<xsl:template> 元素包含了当指定的节点被匹配时所能应用的规则.
XSLT <xsl:value-of> 元素
<xsl:value-of> 元素可提取选定节点的值。
XSLT <xsl:for-each> 元素
<xsl:for-each> 元素允许您在 XSL 中进行循环。
XSLT <xsl:sort> 元素
<xsl:sort> 元素用于对输出进行排序。
XSLT <xsl:if> 元素
<xsl:if> 元素用于针对 XML 文件的内容放置一个条件测试。
XSLT <xsl:choose> 元素
<xsl:choose> 元素被用来与 <xsl:when> 和 <xsl:otherwise> 配合使用，来表达多重的条件检验。
XSLT <xsl:apply-templates> 元素
<xsl:apply-templates> 元素可把模板规则应用到当前节点或者当前元素的子节点。
客户端的 XSL
如何在客户端将 XML 文档转换为 XHTML 文档。
服务器端的X SL
如何在服务器端将 XML 文档转换为 XHTML 文档。
XSL Editing XML
存储在 XML 文件中的数据可以通过因特网浏览器进行编辑。本章将讲解如何打开、编辑、保存一个存储于服务器的 XML 文件。
XSL 编辑器
当编辑 XSL 文档时，为什么应该使用 XML 编辑器。
XSLT 总结
本节是对您在本教程所学内容的总结，并为您推荐了下一步应该学习的内容。

XSLT 参考手册

XSLT 元素
对所有来自 W3C 标准的 XSLT 元素进行了描述，以及关于浏览器支持的信息。
XSLT 函数
XSLT 拥有超过 100 个内置的函数。这些函数可以用于字符串、数值、日期和时间比较、节点和QName处理, 序列处理, 逻辑值等等。
  • Next Page

XSLT 参考手册


XSLT 元素参考手册

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT 元素参考手册

  • Previous Page
  • Next Page

源自于 W3C 推荐 (XSLT Version 1.0) 的 XSLT 元素。

XSLT 元素

如果您需要有关下列元素的更详细的信息，请点击元素列中的链接。

  • N: 表示最早支持此标签的 Netscape 版本
  • IE: 表示最早支持此标签的 Internet Explorer 版本

注释：在 IE 5 中所支持的元素可能出现非标准的行为，这是由于 IE 5 发布于 XSLT 被确立为正式的 W3C 标准之前。

元素 | 描述 | IE | N
apply-imports | 应用来自导入样式表中的模版规则。 | 6.0 |
apply-templates | 向当前元素或当前元素的子元素应用模板。 | 5.0 | 6.0
attribute | 向元素添加属性。 | 5.0 | 6.0
attribute-set | 创建命名的属性集。 | 6.0 | 6.0
call-template | 调用一个指定的模板。 | 6.0 | 6.0
choose | 与<when>以及<otherwise>协同使用，来表达多重条件测试。 | 5.0 | 6.0
comment | 在结果树中创建注释节点。 | 5.0 | 6.0
copy | 创建当前节点的一个备份（无子节点及属性）。 | 5.0 | 6.0
copy-of | 创建当前节点的一个备份（带有子节点及属性）。 | 6.0 | 6.0
decimal-format | 定义当通过 format-number() 函数把数字转换为字符串时，所要使用的字符和符号。 | 6.0 |
element | 在输出文档中创建一个元素节点。 | 5.0 | 6.0
fallback | 假如处理器不支持某个XSLT元素，规定一段备用代码来运行。 | 6.0 |
for-each | 遍历指定的节点集中的每个节点。 | 5.0 | 6.0
if | 包含一个模板，仅当某个指定的条件成立时应用此模板。 | 5.0 | 6.0
import | 用于把一个样式表中的内容倒入另一个样式表中。 | 6.0 | 6.0
include | 把一个样式表中的内容包含到另一个样式表中。 | 6.0 | 6.0
key | 声明一个命名的键。 | 6.0 | 6.0
message | 向输出写一条消息（用于错误报告）。 | 6.0 | 6.0
namespace-alias | 把样式表中的命名空间替换为输出中不同的命名空间。 | 6.0 |
number | 测定当前节点的整数位置，并对数字进行格式化。 | 6.0 | 6.0
otherwise | 规定 <choose> 元素的默认动作。 | 5.0 | 6.0
output | 定义输出文档的格式。 | 6.0 | 6.0
param | 声明一个局部或全局参数。 | 6.0 | 6.0
preserve-space | 用于定义保留空白的元素。 | 6.0 | 6.0
processing-instruction | 生成处理指令节点。 | 5.0 | 6.0
sort | 对结果进行排序。 | 6.0 | 6.0
strip-space | 定义应当删除空白字符的元素。 | 6.0 | 6.0
stylesheet | 定义样式表的根元素。 | 5.0 | 6.0
template | 当指定的节点被匹配时所应用的规则。 | 5.0 | 6.0
text | 通过样式表生成文本节点。 | 5.0 | 6.0
transform | 定义样式表的根元素。 | 6.0 | 6.0
value-of | 提取选定节点的值。 | 5.0 | 6.0
variable | 声明局部或者全局的变量。 | 6.0 | 6.0
when | 规定 <choose> 元素的动作。 | 5.0 | 6.0
with-param | 规定需被传入某个模板的参数的值。 | 6.0 | 6.0
  • Previous Page
  • Next Page

XSLT 参考手册


XSLT 浏览器

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSLT 浏览器

  • Previous Page
  • Next Page

几乎所有主要的浏览器均支持 XML 和 XSLT。

Mozilla Firefox

从 1.0.2 版本开始，Firefox 就已开始支持 XML 和 XSLT（以及 CSS）。

Mozilla

Mozilla 含有用于 XML 解析的 Expat，并支持 XML + CSS。Mozilla 同样支持命名空间。

Mozilla 可执行 XSLT。

Netscape

从版本 8 开始，Netscape 就开始使用 Mozilla 引擎，所以它对 XML / XSLT 的支持与Mozilla是相同的。

Opera

从版本 9 开始，Opera 已开始支持 XML 和 XSLT（以及 CSS）。版本 8 仅支持 XML + CSS。

Internet Explorer

从版本 6 开始，Internet Explorer 已开始 XML、命名空间、CSS、XSLT 以及 XPath。

版本 5 不兼容官方的 W3C XSL 标准。

  • Previous Page
  • Next Page

XSLT 参考手册


您已经学习了 XSLT，下一步呢?

XSLT 基础

  • XSLT 首页
  • XSL 语言
  • XSLT 简介
  • XSLT 浏览器
  • XSLT 转换
  • XSLT <template>
  • XSLT <xsl:value-of>
  • XSLT <for-each>
  • XSLT <sort>
  • XSLT <if>
  • XSLT <choose>
  • XSLT apply

XSLT 高级

  • XSLT 在客户端
  • XSLT 在服务器端
  • XSLT 编辑XML
  • XSLT 编辑器
  • XSLT 总结

参考手册

  • XSLT 元素
  • XSLT 函数

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

您已经学习了 XSLT，下一步呢?

  • Previous Page
  • Next Page

XSLT 概要

本教程已经向您讲解了如何使用 XSLT 把 XML 文档转换为其他格式，比如 XHTML。

您已经学会如何向输出文件添加元素和属性，并从输出文件移除元素和属性。

您也学习了如何对元素进行重新排列和排序，执行测试以及决定显示或隐藏哪些元素。

如需更多有关 XSLT 的知识，请查阅我们的 XSLT 参考手册。

您已经学习了 XSLT，下一步应当学习什么呢?

XSL 包括三种语言：XSLT、XPath 以及 XSL-FO，因此下一步应当学习 XPath 和 XSL-FO。

XPath

XPath 用于经由元素和属性在 XML 文档中进行导航。

XPath 是 W3C 的 XSL 标准的主要元素。对 XPath 的理解是深入使用 XML 的基础。

如果缺乏 XPath 方面的知识，您就无法创建 XSLT 文档。

如果你希望学习更多有关 XPath 的知识，请访问我们的 XPath 教程。

XSL-FO

XSL-FO 可描述输出到屏幕、纸媒介或者其他媒介的 XML 数据的格式。

XSL-FO 是带有关于输出布局以及输出内容的信息的 XML 文件。

如果你希望学习更多有关 XSL-FO 的知识，请访问我们的 XSL-FO 教程。

  • Previous Page
  • Next Page

XSLT 参考手册


XSL-FO Blocks（块）

XSLFO 教程

  • XSLFO 首页
  • XSLFO 简介
  • XSLFO 文档
  • XSLFO 区域
  • XSLFO 输出
  • XSLFO 流
  • XSLFO 页面
  • XSLFO 块
  • XSLFO 列表
  • XSLFO 表格
  • XSLFO 与 XSLT

XSLFO 参考手册

  • XSLFO 对象

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSL-FO Blocks（块）

  • Previous Page
  • Next Page

XSL-FO 的输出位于块区域中。

XSL-FO 页面、流以及块

内容“块”会“流”入“页面”中，然后输出到媒介。

XSL-FO 输出通常被嵌套在 <fo:block> 元素中，<fo:block> 嵌套于 <fo:flow> 元素中，<fo:flow> 嵌套于 <fo:page-sequence> 元素中：

<fo:page-sequence>
  <fo:flow flow-name="xsl-region-body">
    <fo:block>
      <!-- Output goes here -->
    </fo:block>
  </fo:flow>
</fo:page-sequence>

块区域的属性

块是位于矩形框中的输出序列：

<fo:block border-width="1mm">
这个输出块周围有一条一毫米的边框。
</fo:block>

由于块区域是矩形框，所以可共享许多公共的区域属性：

  • space before 和 space after
  • margin
  • border
  • padding
  • space before

图示：

space before 和 space after 是块与块之间起分割作用的空白。

margin 是块外侧的空白区域。

border 的区域外部边缘的矩形。其四个边均可有不同的宽度。它也可被填充为不同的颜色和背景图像。

padding 是位于内容区域与边框之间的区域。

内容区域可包含实际的内容，比如文本、图片、图形等等。

块边距

  • margin
  • margin-top
  • margin-bottom
  • margin-left
  • margin-right

块边框

边框样式属性:

  • border-style
  • border-before-style
  • border-after-style
  • border-start-style
  • border-end-style
  • border-top-style ((等同于 border-before)
  • border-bottom-style (等同于 border-after)
  • border-left-style (等同于 border-start)
  • border-right-style (等同于 border-end)

边框颜色属性:

  • border-color
  • border-before-color
  • border-after-color
  • border-start-color
  • border-end-color
  • border-top-color (等同于 border-before)
  • border-bottom-color (等同于 border-after)
  • border-left-color (等同于 border-start)
  • border-right-color (等同于 border-end)

边框宽度属性:

  • border-width
  • border-before-width
  • border-after-width
  • border-start-width
  • border-end-width
  • border-top-width (等同于 border-before)
  • border-bottom-width (等同于 border-after)
  • border-left-width (等同于 border-start)
  • border-right-width (等同于 border-end)

块填充

  • padding
  • padding-before
  • padding-after
  • padding-start
  • padding-end
  • padding-top (等同于 padding-before)
  • padding-bottom (等同于 padding-after)
  • padding-left (等同于 padding-start)
  • padding-right (等同于 padding-end)

块背景

  • background-color
  • background-image
  • background-repeat
  • background-attachment (scroll 或者 fixed)

块样式属性：

块是可被单独样式化的输出序列：

<fo:block
  font-size="12pt"
  font-family="sans-serif">
This block of output will be written in a 12pt sans-serif font.
</fo:block>

字体属性:

  • font-family
  • font-weight
  • font-style
  • font-size
  • font-variant

文本属性:

  • text-align
  • text-align-last
  • text-indent
  • start-indent
  • end-indent
  • wrap-option (定义自动换行，word wrap)
  • break-before (定义分页符，page breaks)
  • break-after (定义分页符，page breaks)
  • reference-orientation (定义 90" 内的文字旋转)

实例

<fo:block
    font-size="14pt" font-family="verdana" color="red"
    space-before="5mm" space-after="5mm">
W3School
</fo:block>

<fo:block
    text-indent="5mm"
    font-family="verdana" font-size="12pt"
    space-before="5mm" space-after="5mm">
At W3School you will find all the Web-building tutorials you
need, from basic HTML and XHTML to advanced XML, XSL, Multimedia
and WAP.
</fo:block>

结果：

请看上面的例子，如果要生成一个拥有许多标题和段落的文档，那么将会需要非常多的代码。

通常，XSL-FO 文档不会像我们刚才所做的那样对格式化信息和内容进行组合。

通过 XSLT 的些许帮助，我们就可以把格式化信息置入模板，然后编写出更纯净的内容。

您会在本教程后面的章节学习到如何使用 XSLT 模板来组合 XSL-FO。

  • Previous Page
  • Next Page

XSL-FO 参考手册


XSL-FO 表格

XSLFO 教程

  • XSLFO 首页
  • XSLFO 简介
  • XSLFO 文档
  • XSLFO 区域
  • XSLFO 输出
  • XSLFO 流
  • XSLFO 页面
  • XSLFO 块
  • XSLFO 列表
  • XSLFO 表格
  • XSLFO 与 XSLT

XSLFO 参考手册

  • XSLFO 对象

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSL-FO 表格

  • Previous Page
  • Next Page

XSL-FO 使用 <fo:table-and-caption> 元素来定义表格。

XSL-FO 表格

XSL-FO 表格模型与 HTML 表格模型是非常不同的。

有九种 XSL-FO 对象可用来创建表格：

  • fo:table-and-caption
  • fo:table
  • fo:table-caption
  • fo:table-column
  • fo:table-header
  • fo:table-footer
  • fo:table-body
  • fo:table-row
  • fo:table-cell

XSL-FO 使用 <fo:table-and-caption> 元素来定义表格。它包含一个 <fo:table> 以及一个可选的 <fo:caption> 元素。

<fo:table> 元素包含：

  • 可选的 <fo:table-column> 元素
  • 可选的 <fo:table-header> 元素
  • <fo:table-body> 元素
  • 可选的 <fo:table-footer> 元素

这些元素中的每一个都可能拥有一个或多个 <fo:table-row> 元素，而 <fo:table-row> 同时会带有一个或多个 <fo:table-cell> 元素：

<fo:table-and-caption>
<fo:table>
<fo:table-column column-width="25mm"/>
<fo:table-column column-width="25mm"/>

<fo:table-header>
  <fo:table-row>
    <fo:table-cell>
      <fo:block font-weight="bold">Car</fo:block>
    </fo:table-cell>
    <fo:table-cell>
      <fo:block font-weight="bold">Price</fo:block>
    </fo:table-cell>
  </fo:table-row>
</fo:table-header>

<fo:table-body>
  <fo:table-row>
    <fo:table-cell>
      <fo:block>Volvo</fo:block>
    </fo:table-cell>
    <fo:table-cell>
      <fo:block>$50000</fo:block>
    </fo:table-cell>
  </fo:table-row>
  <fo:table-row>
    <fo:table-cell>
      <fo:block>SAAB</fo:block>
    </fo:table-cell>
    <fo:table-cell>
      <fo:block>$48000</fo:block>
    </fo:table-cell>
  </fo:table-row>
</fo:table-body>

</fo:table>
</fo:table-and-caption>

以上代码的输出：

  • Previous Page
  • Next Page

XSL-FO 参考手册


XSL-FO 参考手册

XSLFO 教程

  • XSLFO 首页
  • XSLFO 简介
  • XSLFO 文档
  • XSLFO 区域
  • XSLFO 输出
  • XSLFO 流
  • XSLFO 页面
  • XSLFO 块
  • XSLFO 列表
  • XSLFO 表格
  • XSLFO 与 XSLT

XSLFO 参考手册

  • XSLFO 对象

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSL-FO 参考手册

  • Previous Page
  • Next Page

将描述转换为呈现的过程被称为格式化（formatting）。

对象 | 描述
basic-link | 定义一个链接的起始资源
bidi-override | Overrides the default Unicode BIDI direction
block | 定义一个输出块（比如段落和标题）
block-container | 定义一个块级的引用区域（reference-area）
character | 定义一个字符，该字符会被映射为供呈现的字形
color-profile | 定义样式表的一个颜色配置文件
conditional-page-master-reference | 规定一个当所定义的条件成立时使用的page-master
declarations | 组合针对某个样式表的全局声明
external-graphic | 用于图像数据位于XML结果树之外的某个图形
float | 典型的用法是，在页面起始位置的某个单独的区域放置一幅图片，或者把一幅图片放置到一侧，而内容则流动至图片的旁边。
flow | 包含所有被输出到页面的元素
footnote | 定义在页面的region-body内部的一个脚注
footnote-body | 定义脚注的内容
initial-property-set | 格式化<fo:block>的第一行
inline | 通过背景或者将其包围在一个边框中，来格式化文本的某个部分
inline-container | 定义一个行内的引用区域（inline reference-area）
instream-foreign-object | 用于行内图形（inline graphics）或用于普通对象，其中对象的数据作为<fo:instream-foreign-object>的后代存在。
layout-master-set | 存有所有用在文档中的master
leader | 用来生成"."由内容表格中的页码来分隔标题，或者创建表单中的输入域，或者创建水平线
list-block | 定义列表
list-item | 包含列表中的每个项目
list-item-body | 包含列表项的内容或主体
list-item-label | 包含列表项的标号（有代表性的是数据、字符等等）
marker | 与fo:retrieve-marker使用来创建连续的页面或页脚
multi-case | 包含 XSL-FO对象的每个供选择的子树（在<fo:multi-switch>内部）。父元素<fo:multi-switch>会选择显示那个选项并隐藏其余的选项。
multi-properties | 用来在两个或更多的属性集（property-sets）间转换
multi-property-set | 规定一个可供选择的属性集，这个属性集会被根据用户代理的状态来进行应用。
multi-switch | 存有一个或多个<fo:multi-case>对象，并控制它们之间的切换（通过<fo:multi-toggle>激活）
multi-toggle | 用来切换到另一个<fo:multi-case>
page-number | 表示当前的页面
page-number-citation | 为页面引用页码，此页面包含首个由被引用对象返回的标准区域。
page-sequence | 一个针对页面输出元素的容器。在其中一个<fo:page-sequence>对象针对每个页面布局。
page-sequence-master | 规定使用哪个simple-page-master，以及使用次序。
region-after | 定义页脚
region-before | 定义页眉
region-body | 定义页面主体
region-end | 定义页面的右侧栏
region-start | 定义页面的左侧栏
repeatable-page-master-alternatives | 定义一套simple-page-master的副本
repeatable-page-master-reference | 规定一个简单的simple-page-master的副本
retrieve-marker | 与<fo:marker>一同使用来创建连续页眉或者页脚
root | XSL-FO文档的根（顶）节点
simple-page-master | 定义页面的尺寸和形状
single-page-master-reference | 规定用在页面序列的某个给定的点的一个
static-content | 包含在许多页面上重复的静态内容（比如页眉和页脚）
table | 格式化一个表格的表格式的材料
table-and-caption | 格式化一个表格及其标题
table-body | 表格行和表格单元的容器
table-caption | 包含一个表格的标题
table-cell | 定义表格单元
table-column | 格式化表格的列
table-footer | 定义表格的页脚
table-header | 定义表格的页眉
table-row | 定义表格的行
title | 为页面序列定义一个标题
wrapper | 为一组XSL-FO对象规定继承属性
  • Previous Page
  • Next Page

XSL-FO 参考手册


XSL-FO 简介

XSLFO 教程

  • XSLFO 首页
  • XSLFO 简介
  • XSLFO 文档
  • XSLFO 区域
  • XSLFO 输出
  • XSLFO 流
  • XSLFO 页面
  • XSLFO 块
  • XSLFO 列表
  • XSLFO 表格
  • XSLFO 与 XSLT

XSLFO 参考手册

  • XSLFO 对象

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSL-FO 简介

  • Previous Page
  • Next Page

XSL-FO 用于格式化供输出的 XML 数据。

学习之前应当具备的基础知识：

在您学习 XSL-FO 之前，应当对 XML 和 XML 命名空间有基本的了解。

如果您希望首先学习这些项目，请阅读我们的《XML 教程》。

什么是 XSL-FO?

  • XSL-FO 是用于格式化 XML 数据的语言
  • XSL-FO 指可扩展样式表语言格式化对象（Extensible Stylesheet Language Formatting Objects）
  • XSL-FO 是一个 W3C 推荐标准
  • XSL-FO 目前通常被称为 XSL

XSL-FO 和格式化有关

XSL-FO 是一种基于 XML 的标记语言，用于描述向屏幕、纸或者其他媒介输出 XML 数据的格式化（信息）。

XSL-FO 目前通常被称为 XSL

为什么会存在这样的混淆呢？XSL-FO 和 XSL 是一回事吗？

可以这么说，不过我们需要向您作一个解释：

样式化（Styling）是关于转换信息和格式化信息两方面的信息。在万维网联盟编写他们的首个 XSL 工作草案的时候，这个草案包括了有关转换和格式化 XML 文档的语言语法。

后来，XSL 工作组把这个原始的草案分为独立的标准：

  • XSLT，用于转换 XML 文档的语言
  • XSL 和 XSL-FO，用于格式化 XML 文档的语言
  • XPath，是通过元素和属性在 XML 文档中进行导航的语言

本教程的其余内容均与文档的格式化有关：XSL-FO，也被称为 XSL。

您可以在我们的《XSLT 教程》阅读更多有关 XSLT 的内容。

您可以在我们的《XPath 教程》阅读更多有关 XPath 的内容。

XSL-FO 是一个 web 标准

XSL-FO 在 2001 年 10 月 15 日 被确立为 W3C 推荐标准。通常被称为 XSL。

如需阅读更多有关 W3C 的 XSL 活动的内容，请阅读我们的《W3C 教程》。

  • Previous Page
  • Next Page

XSL-FO 参考手册


XSL-FO 教程

XSLFO 教程

  • XSLFO 首页
  • XSLFO 简介
  • XSLFO 文档
  • XSLFO 区域
  • XSLFO 输出
  • XSLFO 流
  • XSLFO 页面
  • XSLFO 块
  • XSLFO 列表
  • XSLFO 表格
  • XSLFO 与 XSLT

XSLFO 参考手册

  • XSLFO 对象

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSL-FO 教程

  • Next Page

在我们的 XSL-FO 教程中，您将了解到什么是 XSL-FO。

您将学习如何使用 XSL-FO 对用于输出的XML文档进行格式化。

开始学习 XSL-FO！

内容目录

XSL-FO 简介
XSL-FO 的简介。包括其概念和作用。
XSL-FO 文档
本章将解 XSL-FO 文档的结构。
XSL-FO 区域
本章讲解 XSL-FO 的区域模型（area model）。
XSL-FO 输出
本章讲解 XSL-FO 文档的输出元素（Output Elements）。
XSL-FO 流
本章讲解 XSL-FO 文档的输出流（Output Flow）。
XSL-FO 页
本章讲解 XSL-FO 如何定义页面的布局。
XSL-FO 块
本章讲解 XSL-FO 输出块（output blocks）。
XSL-FO 列表
本章讲解 XSL-FO 如何定义列表。
XSL-FO 表格
本章讲解 XSL-FO 如何定义表格。
XSL-FO 和 XSLT
本章讲解 XSL-FO 如何使用 XSLT。
XSL-FO 对象参考手册
完整的 XSL-FO 对象列表，以及它们的属性。
  • Next Page

XSL-FO 参考手册


XSL-FO 列表

XSLFO 教程

  • XSLFO 首页
  • XSLFO 简介
  • XSLFO 文档
  • XSLFO 区域
  • XSLFO 输出
  • XSLFO 流
  • XSLFO 页面
  • XSLFO 块
  • XSLFO 列表
  • XSLFO 表格
  • XSLFO 与 XSLT

XSLFO 参考手册

  • XSLFO 对象

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSL-FO 列表

  • Previous Page
  • Next Page

XSL-FO 使用列表块（List Block）来定义列表。

XSL-FO 列表块

有四种 XSL-FO 对象可用来创建列表：

fo:list-block
包含整个列表。
fo:list-item
包含列表中的每个项目。
fo:list-item-label
包含用于 list-item 的标记 - 典型地，包含一个数字或者字符的 <fo:block> 。
fo:list-item-body
包含 list-item 的主体或内容 - 典型地，一个或多个 <fo:block> 对象。

一个 XSL-FO 列表实例:

<fo:list-block>

<fo:list-item>
 <fo:list-item-label>
   <fo:block>*</fo:block>
 </fo:list-item-label>
 <fo:list-item-body>
   <fo:block>Volvo</fo:block>
 </fo:list-item-body>
</fo:list-item>

<fo:list-item>
 <fo:list-item-label>
   <fo:block>*</fo:block>
 </fo:list-item-label>
 <fo:list-item-body>
   <fo:block>Saab</fo:block>
 </fo:list-item-body>
</fo:list-item>

</fo:list-block>

以上代码的输出：

  • Previous Page
  • Next Page

XSL-FO 参考手册


XSL-FO 流

XSLFO 教程

  • XSLFO 首页
  • XSLFO 简介
  • XSLFO 文档
  • XSLFO 区域
  • XSLFO 输出
  • XSLFO 流
  • XSLFO 页面
  • XSLFO 块
  • XSLFO 列表
  • XSLFO 表格
  • XSLFO 与 XSLT

XSLFO 参考手册

  • XSLFO 对象

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSL-FO 流

  • Previous Page
  • Next Page

XSL-FO 页面使用来自 <fo:flow> 元素的数据进行填充。

XSL-FO 页面顺序

XSL-FO 使用 <fo:page-sequence> 元素来定义输出页面。

每个输出页面都会引用一个定义布局的 page master。

每个输出页面均有一个定义输出的 <fo:flow>元素。

每个输出页面均会按顺序（序列）被打印或显示。

XSL-FO Flow（流）

XSL-FO 页面使用来自 <fo:flow> 元素的数据进行填充。

<fo:flow> 包含所有被打印到页面的元素。

当页面被印满以后，相同的 page master 会被一遍又一遍地被使用，直到所有页面的页面被打印为止。

流动到何处?

<fo:flow> 元素有一个名为 "flow-name" 的属性。

flow-name 属性的值定义 <fo:flow> 元素的内容会去往何处。

合法的值：

  • xsl-region-body （进入 region-body）
  • xsl-region-before （进入 region-before）
  • xsl-region-after （进入 region-after）
  • xsl-region-start （进入 region-start）
  • xsl-region-end （进入 region-end）
  • Previous Page
  • Next Page

XSL-FO 参考手册


XSL-FO 区域

XSLFO 教程

  • XSLFO 首页
  • XSLFO 简介
  • XSLFO 文档
  • XSLFO 区域
  • XSLFO 输出
  • XSLFO 流
  • XSLFO 页面
  • XSLFO 块
  • XSLFO 列表
  • XSLFO 表格
  • XSLFO 与 XSLT

XSLFO 参考手册

  • XSLFO 对象

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSL-FO 区域

  • Previous Page
  • Next Page

XSL-FO 使用矩形框（区域）来显示输出。

XSL-FO 区域

XSL 格式化模型定义了一系列的矩形（区域）框来显示输出。

所有的输出都会被格式化到这些框中，然后会被显示或打印到某个目标媒介。

让我们研究一下下面这些区域：

  • Pages（页面）
  • Regions（区）
  • Block areas（块区域）
  • Line areas（行区域）
  • Inline areas（行内区域）

XSL-FO Pages（页面）

XSL-FO 输出会被格式化到页面中。打印输出通常会进入分为许多分割的页面。浏览器输出经常会成为一个长的页面。

XSL-FO 页面包含区域（Region）。

XSL-FO Regions（区）

每个 XSL-FO 页面均包含一系列的 Regions（区）：

  • region-body (页面的主体)
  • region-before (页面的页眉)
  • region-after (页面的页脚)
  • region-start (左侧栏)
  • region-end (右侧栏)

XSL-FO Regions 包含块区域（Block Area）。

XSL-FO Block Areas（块区域）

XSL-FO 块区域可定义小的块元素（通常由一个新行开始），比如段落、表格以及列表。

XSL-FO 块区域可包含其他的块区域，不过大多数时候它们包含的是行区域（Line Area）。

XSL-FO Line Areas（行区域）

XSL-FO 行区域定义了块区域内部的文本行。

XSL-FO 行区域包含行内区域（Inline Area）。

XSL-FO Inline Areas（行内区域）

XSL-FO 行内区域定了行内部的文本（着重号、单字符以及图像等等）。

  • Previous Page
  • Next Page

XSL-FO 参考手册


XSL-FO 输出

XSLFO 教程

  • XSLFO 首页
  • XSLFO 简介
  • XSLFO 文档
  • XSLFO 区域
  • XSLFO 输出
  • XSLFO 流
  • XSLFO 页面
  • XSLFO 块
  • XSLFO 列表
  • XSLFO 表格
  • XSLFO 与 XSLT

XSLFO 参考手册

  • XSLFO 对象

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSL-FO 输出

  • Previous Page
  • Next Page

XSL-FO 在 <fo:flow> 元素内部定义输出。

XSL-FO 页面(Page)、流(Flow)以及块(Block)

内容“块”会“流”入“页面”中，然后输出到媒介。

XSL-FO 输出通常被嵌套在 <fo:block> 元素中，<fo:block> 嵌套于 <fo:flow> 元素中，<fo:flow> 嵌套于 <fo:page-sequence> 元素中：

<fo:page-sequence>
  <fo:flow flow-name="xsl-region-body">
    <fo:block>
      <!-- Output goes here -->
    </fo:block>
  </fo:flow>
</fo:page-sequence>

XSL-FO 实例

现在让我们看一个真实的 XSL-FO 实例：

<?xml version="1.0" encoding="ISO-8859-1"?>

<fo:root xmlns:fo="http://www.w3.org/1999/XSL/Format">

<fo:layout-master-set>
  <fo:simple-page-master master-name="A4">
  </fo:simple-page-master>
</fo:layout-master-set>

<fo:page-sequence master-reference="A4">
  <fo:flow flow-name="xsl-region-body">
    <fo:block>Hello W3School</fo:block>
  </fo:flow>
</fo:page-sequence>

</fo:root>

以上代码的输出类似这样：

  • Previous Page
  • Next Page

XSL-FO 参考手册


XSL-FO 文档

XSLFO 教程

  • XSLFO 首页
  • XSLFO 简介
  • XSLFO 文档
  • XSLFO 区域
  • XSLFO 输出
  • XSLFO 流
  • XSLFO 页面
  • XSLFO 块
  • XSLFO 列表
  • XSLFO 表格
  • XSLFO 与 XSLT

XSLFO 参考手册

  • XSLFO 对象

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSL-FO 文档

  • Previous Page
  • Next Page

XSL-FO 文档是带有输出信息的 XML 文件。

XSL-FO 文档

XSL-FO 文档是带有输出信息的 XML 文件。它们包含着有关输出布局以及输出内容的信息。

XSL-FO 文档存储在以 .fo 或 .fob 为后缀的文件中。以 .xml 为后缀存储的 XSL-FO 文档也很常见，这样做的话可以使 XSL-FO 文档更易被 XML 编辑器存取。

XSL-FO 文档的结构

XSL-FO 的文档结构类似这样：

<?xml version="1.0" encoding="ISO-8859-1"?>

<fo:root xmlns:fo="http://www.w3.org/1999/XSL/Format">

<fo:layout-master-set>
  <fo:simple-page-master master-name="A4">
    <!-- Page template goes here -->
  </fo:simple-page-master>
</fo:layout-master-set>

<fo:page-sequence master-reference="A4">
  <!-- Page content goes here -->
</fo:page-sequence>

</fo:root>

结构解释

XSL-FO 文档属于 XML 文档，因为也需要以 XML 声明来起始：

<?xml version="1.0" encoding="ISO-8859-1"?>

<fo:root> 元素是 XSL-FO 文档的根元素。这个根元素也要声明 XSL-FO 的命名空间：

<fo:root xmlns:fo="http://www.w3.org/1999/XSL/Format">
  <!-- 此处是 XSL-FO 文档的内容 -->
</fo:root>

<fo:layout-master-set> 元素含有一个或多个页面模板：

<fo:layout-master-set>
  <!-- 此处是所有的页面模板 -->
</fo:layout-master-set>

<fo:simple-page-master> 元素包含一个单一的页面模板。每个模板须有一个唯一的名称(master-name)：

<fo:simple-page-master master-name="A4">
  <!-- 此处是某一个页面模板 -->
</fo:simple-page-master>

一个或多个 <fo:page-sequence> 元素可描述页面的内容。master-reference 属性使用相同的名称来引用 simple-page-master 模板：

<fo:page-sequence master-reference="A4">
  <!-- 此处是页面内容 -->
</fo:page-sequence>

注释：master-reference 的值 "A4" 实际上并没有描述某个预定义的页面格式。它仅仅是一个名称。您可以使用任何名称，比如 "MyPage"、"MyTemplate" 等等。

  • Previous Page
  • Next Page

XSL-FO 参考手册


XSL-FO 页面

XSLFO 教程

  • XSLFO 首页
  • XSLFO 简介
  • XSLFO 文档
  • XSLFO 区域
  • XSLFO 输出
  • XSLFO 流
  • XSLFO 页面
  • XSLFO 块
  • XSLFO 列表
  • XSLFO 表格
  • XSLFO 与 XSLT

XSLFO 参考手册

  • XSLFO 对象

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSL-FO 页面

  • Previous Page
  • Next Page

XSL-FO 使用名为 "Page Masters" 的页面模板来定义页面的布局。

XSL-FO 页面模板

XSL-FO 使用名为 "Page Masters" 的页面模板来定义页面的布局。每个模板必须拥有一个唯一的名称：

<fo:simple-page-master master-name="intro">
  <fo:region-body margin="5in" />
</fo:simple-page-master>

<fo:simple-page-master master-name="left">
  <fo:region-body margin-left="2in" margin-right="3in" />
</fo:simple-page-master>

<fo:simple-page-master master-name="right">
  <fo:region-body margin-left="3in" margin-right="2in" />
</fo:simple-page-master>

在上面的例子中，三个 <fo:simple-page-master> 元素，定义了三个不同的模板。每个模板（page-master）都有不同的名称。

第一个模板名为 "intro"。它可作为介绍页面的模板使用。

第二个和第三个模板名为 "left" 和 "right"。它们可被用于偶数和奇数页码的页面。

XSL-FO 页面尺寸

XSL-FO 使用下面的属性来定义页面尺寸：

page-width
定义页面的宽度
page-height
定义页面的高度

XSL-FO 页面边距

XSL-FO 使用下面的属性定义页面边距：

margin-top
定义顶边距
margin-bottom
定义底边距
margin-left
定义左边距
margin-right
定义右边距
margin
定义所有边的边距

XSL-FO 页面去（Page Regions）

XSL-FO 使用下面的元素来定义页面的区：

region-body
定义主体区
region-before
定义顶部区 (页眉)
region-after
定义底部区 (页脚)
region-start
定义左侧区 (左侧栏)
region-end
定义右侧区 (右侧栏)

注释：region-before、region-after、region-start 以及 region-end 是主体区的一部分。为了避免主体区的文本覆盖到这些区域，主题区的边距至少要等于其他区的尺寸。

图示：

XSL-FO 实例

这是从某个 XSL-FO 文档中提取的一个片断：

<fo:simple-page-master master-name="A4"
 page-width="297mm" page-height="210mm"
 margin-top="1cm"   margin-bottom="1cm"
 margin-left="1cm"  margin-right="1cm">
  <fo:region-body   margin="3cm"/>
  <fo:region-before extent="2cm"/>
  <fo:region-after  extent="2cm"/>
  <fo:region-start  extent="2cm"/>
  <fo:region-end    extent="2cm"/>
</fo:simple-page-master>

上面的代码定义了名称为 "A4" 的 "Simple Page Master Template"。

页面的宽度是 297 毫米，高度是 210 毫米。

页面的四个边距均为 1 厘米。

主体的边距是 3 厘米（四个边都是）。

before、after、start 以及 end 区均为 2 厘米。

上面的例子中的主体的宽度可通过页面宽度减去左右边距以及 region-body 的边距来计算得出：

297mm - (2 x 1cm) - (2 x 3cm) = 297mm - 20mm - 60mm = 217mm.

注释：region （region-start 和 region-end） 没有被计算进来。正如之前讲解过的，这些区（region）是主体的组成部分。

  • Previous Page
  • Next Page

XSL-FO 参考手册


XSL-FO 与 XSLT

XSLFO 教程

  • XSLFO 首页
  • XSLFO 简介
  • XSLFO 文档
  • XSLFO 区域
  • XSLFO 输出
  • XSLFO 流
  • XSLFO 页面
  • XSLFO 块
  • XSLFO 列表
  • XSLFO 表格
  • XSLFO 与 XSLT

XSLFO 参考手册

  • XSLFO 对象

建站手册

  • 网站构建
  • 万维网联盟
  • 浏览器信息
  • 网站品质
  • 语义网
  • 职业规划
  • 网站主机

帮助 W3School

XSL-FO 与 XSLT

  • Previous Page
  • Next Page

XSL-FO 与 XSLT 可彼此互助。

还记得这个例子吗？

<fo:block
    font-size="14pt" font-family="verdana" color="red"
    space-before="5mm" space-after="5mm">
W3School
</fo:block>

<fo:block
    text-indent="5mm"
    font-family="verdana" font-size="12pt"
    space-before="5mm" space-after="5mm">
At W3School you will find all the Web-building tutorials you
need, from basic HTML and XHTML to advanced XML, XSL, Multimedia
and WAP.
</fo:block>

结果：

此例来自有关 XSL-FO 块区域的那一节。

来自 XSLT 的帮助

从文档移除 XSL-FO 信息：

<header>
W3School
</header>

<paragraph>
At W3School you will find all the Web-building tutorials you
need, from basic HTML and XHTML to advanced XML, XSL, Multimedia
and WAP.
</paragraph>

添加 XSLT 转换：

<xsl:template match="header">
<fo:block
    font-size="14pt" font-family="verdana" color="red"
    space-before="5mm" space-after="5mm">
    <xsl:apply-templates/>
</fo:block>
</xsl:template>

<xsl:template match="paragraph">
<fo:block
    text-indent="5mm"
    font-family="verdana" font-size="12pt"
    space-before="5mm" space-after="5mm">
    <xsl:apply-templates/>
</fo:block>
</xsl:template>

产生的结果是相同的：

  • Previous Page
  • Next Page

XSL-FO 参考手册


Easy CHM - http://www.eTextWizard.com

您现在使用的CHM文件由Easy CHM的未注册版本制作.
注册版本不会在CHM里自动添加此页面

Easy CHM 软件 软件出品: 国华软件 中国北京 |  | 截屏图片
 | 文件大小: 2989k - 2.84MB | 软件类型: 共享软件 购买注册: 这里
关键词: make chm, create chm, chm制作工具, chm电子书制作工具,chm帮助文件制作工具

描述:

Easy CHM是国华软件推出的一款强大的CHM电子书或CHM帮助文件的快速制作工具。使用EasyCHM只需要三个步骤就可以完成CHM的制作：1、用户指定一个目录，EasyCHM会自动导入全部目录及文件；2、设置CHM编译选项；3、开始制作。EasyCHM非常适合个人和单位制作高压缩比的带有全文检索及高亮显示搜索结果的网页集锦、CHM帮助文件、产品说明、公司介绍、CHM电子书等等。

主要功能：

  • 全自动的目录及文件导入（可以包括子目录）；
  • EasyCHM支持导入任意的文件类型；
  • EasyCHM操作速度快，性能稳定，EasyCHM因为上手容易深得广大用户好评；
  • EasyCHM自动生成CHM的目录列表并自动生成所有目录项；
  • 为CHM的目录列表自动添加多级编号；
  • 在编辑目录项、索引项时用到的移动、拖拽、替换等操作中Easy CHM完全支持多选操作，避免了一项一项地操作，极大的减少用户手工 － 非常适合企业维护CHM帮助文档；
  • 支持批量查找替换多级目录各项的标题文字内容；
  • 允许用户指定从文本文件的第N行自动截取标题；
  • 易用的目录编辑器；
  • 丰富实用的CHM制作选项帮助用户制作更加个性化的专业CHM电子书或CHM帮助文件；
  • EasyCHM自动生成输出Alias和Map头文件；
  • EasyCHM自动生成上下文相关的帮助文件（ContextID），适合于制作专业的支持Help Context ID的专业帮助文件；
  • EasyCHM可以保存工程文件，方便企业用户编辑维护文档。
  • 批量更换CHM目录各项的图标；
  • 内嵌CHM反编译工具；

EasyCHM未注册版本的主要限制：

  1. EasyCHM的未注册版本可以制作带任意层级目录的CHM，但是每个CHM的工具栏上都会自动添加一个ABOUT按钮，以提醒用户注册。注册版本不会添加ABOUT按钮。
  2. EasyCHM的未注册版本无法保存CHM的通用工程文件，如*.HHP、*.HHC、*.HHK等，未注册版本的EasyCHM会自动删除*.HHP、*.HHC、*.HHK这几个文件。

注册版本无任何限制。
如果EasyCHM可以为您的工作和学习提供帮助，请注册购买，感谢您给予软件作者的支持。
联系方式:
国华软件站点一: http://www.etextwizard.com
国华软件站点二: http://www.zipghost.com
技术支持信箱: webmaster@etextwizard.com
购买方式:
在线购买:（可提供发票，支持很多种支付方式，包括邮政汇款）
单用户企业版 299元 人民币 ：通过“共享软件注册中心”购买

单用户家庭版 99元 人民币： 通过“共享软件注册中心”购买
直接向作者注册（共3种方式）：
1、招商银行划款:
开户行： 招商银行北京分行双榆树支行
帐 号： 001015570093
户 名： 冯国华
2、中国农业银行金穗卡转帐（注意是卡号）：
金穗卡卡号： 95599 8001 42061 34216
收 款 人： 冯国华
3、中国工商银行牡丹灵通卡转帐：

开户城市：北京
牡丹灵通卡卡号：9558 8202 0000 3186295 （注意是卡号9558820200003186295）
收 款 人： 冯国华

注意事项：
直接向作者注册的用户请在汇出足额的注册费后以EMAIL形式通知作者，同时请尽量提供

  • 汇款日期

  • 汇出城市

  • 您汇到作者哪个帐号？

  • 汇款人姓名

  • 用于接收注册码的信箱（请确保可以接收邮件，最好多提供）

  • 您希望的注册用户名

  • 要注册的软件及套数

您提供的资料详细些会比较方便确认。
作者在确认支付已完成后将会马上发出注册码。
用户在收到注册信后请尽量给软件作者发个类似“已收到注册码”的确认信 - 感谢您的配合！
下载地址:

系统需求: Win98,WinME,WinXP,Windows2000,WinVista
安装支持: 支持安装及卸载